Win8-Examples: Class List

  • Main Page
  • Namespaces
  • Classes
  • Files
  • Directories
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Class List

Here are the classes, structs, unions and interfaces with brief descriptions:
_BAR_GRAPH_STATE
_FILE_PLAYBACK
_SDKMESHVERTEXELEMENT
_SWITCH_STATE
abstract
AccountPictureName::App
AccountPictureName::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
AccountPictureName::MainPage
AccountPictureName::Scenario
AccountPictureName::sealed
aligned_deleter
Alignment
AmpPixel
AnimateCirclePosition
AnimateLineListPosition
AnimateLinePosition
Animation< T >
anonymous_namespace{SoundFileReader.cpp}::ChunkHeader
anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
AntSystem::Ant
AntSystem::Edge
AntSystem::LatLong
AntSystem::Node
AppBarControl::App
AppBarControl::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
AppBarControl::MainPage
AppBarControl::Scenario
AppBarControl::sealed | An empty page that can be used on its own or navigated to within a Frame
AssociationLaunching::sealed
AsteroidData
AsyncCallback< T >
Audio
AudioController
AudioEngineCallbacks
AutoLock
AutoThrottle
Background::sealed
BackgroundTask::sealed
BackgroundTasks::sealed
BasicCamera
BasicLoader
BasicReaderWriter
BasicShapes
BasicSound
BasicSprites::InstanceData
BasicSprites::InstancingVertex
BasicSprites::ReplicationVertex
BasicSprites::SpriteBatch
BasicSprites::SpriteRunInfo
BasicSprites::TextureMapElement
BasicTimer
BasicVertex
Buffer
BumpMapping
Camera
CAppWindowProvider
CAsyncState
CAutoDXDevLockBase< DevManager, DevInterface >
CAutoDXGILock
CCopyModule
CDecoder
CDocumentSource
CGrayscale
CInvert
CInvertModule
Clipboard::App
Clipboard::Common::LayoutAwarePage
Clipboard::MainPage
Clipboard::Scenario
Clipboard::sealed
CMPEG1Source
CMPEG1Stream
CMPEG1Stream::SourceLock
Collision
CollisionInfo
ComAutoRelease
ComBase< InterfaceChain >
CommandListRenderer
CompositeModes
ComPtrList< T, NULLABLE >
ComputeCB
ComputeDoubleCB
ConstantBuffer
ConstantBufferChangeOnResize
ConstantBufferChangesEveryFrame
ConstantBufferChangesEveryPrim
ConstantBufferLayoutForDX9BrightPassPixelShader
ConstantBufferLayoutForGlowPixelShader
ConstantBufferNeverChanges
Contact
ContactPicker::App
ContactPicker::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
ContactPicker::MainPage
ContactPicker::MainPagePicker
ContactPicker::Scenario
ContactPicker::sealed | An empty page that can be used on its own or navigated to within a Frame
ContactPicker::sealed::SampleContact
ContentImageSource
ContentImageSource::ImageSourceDrawHelper
ConvolveMatrixEffect
CoreWindowEvents
CountdownTimer
CPolarEffect
CppSamplesUtils::SuspensionManager
CredentialPickerCPP::sealed
CritSec
CStreamState
CTriColorWindowFactory
CustomDeviceAccess::DeviceAsync | An empty page that can be used on its own or navigated to within a Frame
CustomDeviceAccess::DeviceList
CustomDeviceAccess::DeviceListEntry
CustomTextRenderer
Cylinder
CylinderMesh
D2D3DTransforms::sealed
D2D3DTransformsRenderer
D2DBasicAnimation
D2DEffectsHelloWorld
D2DEffectsOnPrimitives
D2DFactoryLock
D2DInterpolationModes
D2DLightingEffects::sealed
D2DLightingEffectsRenderer
D2DPerspectiveTransform
D2DTextAnimation
D3DPostProcessing
DatagramSocketSample::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
DatagramSocketSample::MainPage
DatagramSocketSample::Scenario
DatagramSocketSample::sealed | An empty page that can be used on its own or navigated to within a Frame
DDS_HEADER
DDS_HEADER_DXT10
DDS_PIXELFORMAT
Design
DeviceAppForPrinters::App
DeviceAppForPrinters::MainPage
DeviceAppForPrinters::Scenario
DeviceAppForWebcam::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
DeviceAppForWebcam::MainPage
DeviceAppForWebcam::sealed
Direct3DTutorial
Direct3DTutorialFrameworkView
Direct3DTutorialFrameworkViewSource
DirectX::BC4_SNORM
DirectX::BC4_UNORM
DirectX::Blob
DirectX::CBits< SizeInBytes >
DirectX::ConvertData
DirectX::D3DX_BC1
DirectX::D3DX_BC2
DirectX::D3DX_BC3
DirectX::D3DX_BC6H
DirectX::D3DX_BC6H::EncodeParams
DirectX::D3DX_BC6H::ModeDescriptor
DirectX::D3DX_BC6H::ModeInfo
DirectX::D3DX_BC7
DirectX::D3DX_BC7::EncodeParams
DirectX::D3DX_BC7::ModeInfo
DirectX::DDS_HEADER
DirectX::DDS_HEADER_DXT10
DirectX::DDS_PIXELFORMAT
DirectX::HDRColorA
DirectX::HDREndPntPair
DirectX::Image
DirectX::INTColor
DirectX::INTEndPntPair
DirectX::LDRColorA
DirectX::LDREndPntPair
DirectX::LegacyDDS
DirectX::Rect
DirectX::ScratchImage
DirectX::TexMetadata
DirectXApp
DirectXAppSource
DirectXFractal
Document
DrawRectCB
DWriteCustomTextRenderer
DWriteHelloWorld
DWriteHitTesting
DWriteInlineObject
DWriteParagraphText
DWriteVerticalText
DxgiRotation
EaseInExponentialAnimation< T >
EaseInOutExponentialAnimation< T >
EaseOutExponentialAnimation< T >
EdgeGestureSample::sealed
Element
ElementBase
ExtrudedTextRenderer
Extruder
Extruder::ExtrudingSink
Extruder::ExtrudingSink::Vertex2D
Face
FaceMesh
FontEnumeration::sealed
FontFileStream
FontLoader
FPSCounter
FPSCounter::AtlasText
FractalBufferElement
FractalVertex
FrameData
FrameProcessing
GameConfig
GameHud
GameInfoOverlay
GameObject
GameRenderer
GameTimer | THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A //// PARTICULAR PURPOSE. //// //// Copyright (c) Microsoft Corporation. All rights reserved
GeometryRealization
GeometryRealizationFactory
GeometryRealizationSample
handle_closer
HighScoreEntry
HighScoreTable
Hilo::CalendarExtensions
Hilo::Common::BindableBase | Implementation of INotifyPropertyChanged to simplify models
Hilo::Common::LayoutAwarePage Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
Hilo::Common::sealed | Value converter that translates true to false and vice versa
Hilo::DebugLoggingExceptionPolicy
Hilo::ExceptionPolicy
Hilo::ExceptionPolicyFactory
Hilo::ExifExtensions
Hilo::FileSystemRepository
Hilo::HiloPage
Hilo::ImageBase
Hilo::ImageNavigationData
Hilo::IMonthBlock
Hilo::IPhoto
Hilo::IPhotoGroup
Hilo::IResizable
Hilo::IResourceLoader
Hilo::IYearGroup
Hilo::NullPhotoGroup
Hilo::ObservableQuery
Hilo::ObserveException< T >
Hilo::PhotoCache
Hilo::PhotoPathComparer
Hilo::RandomPhotoSelector
Hilo::Repository
Hilo::sealed | Provides application-specific behavior to supplement the default Application class
Hilo::ThumbnailGenerator
Hilo::TileUpdateScheduler
Hilo::ViewModelBase
Hilo::WideFiveImageTile
HttpRequestStringCallback
IDWriteTextAnalysisSource1
Image
ImageFile
ImageFrame
ImageRenderer
IMFAsyncCallback
IMft0Vtbl
IndexTriplet
InkRenderer
InlineImage
IRenderer
LanguageFontCPP::sealed
Layer
Level1
Level2
Level3
Level4
Level5
Level6
LinearAnimation< T >
LineSegment
List< T >
List< T >::Node
List< T >::POSITION
LoadScreen
LockScreenAppsCPP::sealed
LonLatController
Magazine::sealed
ManipulatableObject
MarbleMaze
Material
Matrix4x4< T >
MediaCapture::AudioCapture | An empty page that can be used on its own or navigated to within a Frame
MediaCapture::BasicCapture | An empty page that can be used on its own or navigated to within a Frame
MediaEngineNotify
MediaExtensionsCPP::App
MediaExtensionsCPP::sealed
MediaExtensionsCS::App
MediaExtensionsCS::ScenarioInput1
MediaExtensionsCS::ScenarioInput2
MediaExtensionsCS::ScenarioInput3
MediaExtensionsCS::ScenarioInput4
MediaExtensionsCS::ScenarioList
MediaExtensionsCS::ScenarioOutput1
MediaExtensionsCS::ScenarioOutput2
MediaExtensionsCS::ScenarioOutput3
MediaExtensionsCS::ScenarioOutput4
MediaReader
MediaStreamer
MediaStreamSource::AudioSource | An empty page that can be used on its own or navigated to within a Frame
MediaStreamSource::PcmSource | A simple media source generating audio wave
MemDelete
MEPlayer
MoveLookController
MPEG1AudioFrameHeader
MPEG1PacketHeader
MPEG1StreamHeader
MPEG1SystemHeader
MPEG1VideoSeqHeader
NetworkStatusTask::sealed
NoOp< T >
NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent | Notification content object to display a glyph on a tile's badge
NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent | Notification content object to display a number on a tile's badge
NotificationsExtensions::NotificationBase | Base class for the notification content creation helper classes
NotificationsExtensions::NotificationContentImage
NotificationsExtensions::NotificationContentText
NotificationsExtensions::NotificationContentValidationException | Exception returned when invalid notification content is provided
NotificationsExtensions::TileContent::ISquareTileInternal
NotificationsExtensions::TileContent::TileContentFactory | A factory which creates tile content objects for all of the toast template types
NotificationsExtensions::TileContent::TileNotificationBase
NotificationsExtensions::TileContent::TileSquareBase
NotificationsExtensions::TileContent::TileSquareBlock
NotificationsExtensions::TileContent::TileSquareImage
NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
NotificationsExtensions::TileContent::TileSquareText01
NotificationsExtensions::TileContent::TileSquareText02
NotificationsExtensions::TileContent::TileSquareText03
NotificationsExtensions::TileContent::TileSquareText04
NotificationsExtensions::TileContent::TileWideBase
NotificationsExtensions::TileContent::TileWideBlockAndText01
NotificationsExtensions::TileContent::TileWideBlockAndText02
NotificationsExtensions::TileContent::TileWideImage
NotificationsExtensions::TileContent::TileWideImageAndText01
NotificationsExtensions::TileContent::TileWideImageAndText02
NotificationsExtensions::TileContent::TileWideImageCollection
NotificationsExtensions::TileContent::TileWidePeekImage01
NotificationsExtensions::TileContent::TileWidePeekImage02
NotificationsExtensions::TileContent::TileWidePeekImage03
NotificationsExtensions::TileContent::TileWidePeekImage04
NotificationsExtensions::TileContent::TileWidePeekImage05
NotificationsExtensions::TileContent::TileWidePeekImage06
NotificationsExtensions::TileContent::TileWidePeekImageAndText01
NotificationsExtensions::TileContent::TileWidePeekImageAndText02
NotificationsExtensions::TileContent::TileWidePeekImageCollection01
NotificationsExtensions::TileContent::TileWidePeekImageCollection02
NotificationsExtensions::TileContent::TileWidePeekImageCollection03
NotificationsExtensions::TileContent::TileWidePeekImageCollection04
NotificationsExtensions::TileContent::TileWidePeekImageCollection05
NotificationsExtensions::TileContent::TileWidePeekImageCollection06
NotificationsExtensions::TileContent::TileWideSmallImageAndText01
NotificationsExtensions::TileContent::TileWideSmallImageAndText02
NotificationsExtensions::TileContent::TileWideSmallImageAndText03
NotificationsExtensions::TileContent::TileWideSmallImageAndText04
NotificationsExtensions::TileContent::TileWideSmallImageAndText05
NotificationsExtensions::TileContent::TileWideText01
NotificationsExtensions::TileContent::TileWideText02
NotificationsExtensions::TileContent::TileWideText03
NotificationsExtensions::TileContent::TileWideText04
NotificationsExtensions::TileContent::TileWideText05
NotificationsExtensions::TileContent::TileWideText06
NotificationsExtensions::TileContent::TileWideText07
NotificationsExtensions::TileContent::TileWideText08
NotificationsExtensions::TileContent::TileWideText09
NotificationsExtensions::TileContent::TileWideText10
NotificationsExtensions::TileContent::TileWideText11
NotificationsExtensions::ToastContent::ToastAudio
NotificationsExtensions::ToastContent::ToastImageAndText01
NotificationsExtensions::ToastContent::ToastImageAndText02
NotificationsExtensions::ToastContent::ToastImageAndText03
NotificationsExtensions::ToastContent::ToastImageAndText04
NotificationsExtensions::ToastContent::ToastNotificationBase
NotificationsExtensions::ToastContent::ToastText01
NotificationsExtensions::ToastContent::ToastText02
NotificationsExtensions::ToastContent::ToastText03
NotificationsExtensions::ToastContent::ToastText04
OfferReclaimAPI
OpQueue< T, TOperation >
OutlineRenderer
Page
PageRenderer
PageRendererContext
PageRoll
PaperFragment
PaperRenderer
Parser
ParticleData
PersistentState
Physics
PNTVertex
PointSnapper
PointSnapper::PointSnappingSink
Polygon
Postcard::sealed
PostcardRenderer
PrintSample::BasePrintPage
PrintSample::InvalidPageException
PrintSample::PageDescription | Printable page description
PrintSample::sealed | A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed
Program
ProximityCPP::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
ProximityCPP::MainPage
ProximityCPP::Scenario
ProximityCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
QiList< InterfaceName, InterfaceChain >
QiList< InterfaceName, QiListNil >
QiListNil
QiListSelf< InterfaceName, InterfaceChain >
RandomAccessReader
RawNotificationsSampleCPP::sealed
ReadStreamTask
ReadStreamTask::ReadStreamTaskImpl
Rectangle
RenderBuffer
Renderer
Resource
ResourceLoading
RippleEffect
SampleOverlay
Samples::Devices::DeviceControlResult
Samples::Devices::Fx2::sealed | The device projection for an OSR Fx2 device
Samples::Devices::Repeater
SaveAsImageFile
ScenarioContext
ScheduledNotificationsSampleCPP::sealed
SConversion
ScopedObject< T >
ScreenQuadVertex
ScreenVertex
SDKANIMATION_DATA
SDKANIMATION_FILE_HEADER
SDKANIMATION_FRAME_DATA
SDKMesh
SDKMESH_FRAME
SDKMESH_HEADER
SDKMESH_INDEX_BUFFER_HEADER
SDKMESH_MATERIAL
SDKMESH_MESH
SDKMESH_SUBSET
SDKMESH_VERTEX_BUFFER_HEADER
SDKSample::AccelerometerCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Accessibility::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Animation::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::AnimationMetrics::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::App
SDKSample::ApplicationDataSample::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::ApplicationResources::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::ApplicationSettings::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::AtomPub::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::BackgroundTask::BackgroundTaskSample
SDKSample::BackgroundTask::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::BackgroundTaskSample
SDKSample::BackgroundTransfer::GuidComparer
SDKSample::BackgroundTransfer::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::CalendarSample::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::CallControl::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::CameraCapture::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::CameraOptions::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::CertificateEnrollment::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Common::LayoutAwarePage Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
SDKSample::Common::sealed | SuspensionManager captures global session state to simplify process lifetime management for an application
SDKSample::Common::SharePage
SDKSample::CompassCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Compression::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::ContextMenu::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::CoTaskMemFreeArray
SDKSample::CoTaskMemFreeStruct
SDKSample::CryptoWinRT::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::CustomDeviceAccess::DeviceList
SDKSample::CustomDeviceAccess::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::DataBinding::GeneratorIncrementalLoadingClass
SDKSample::DataBinding::IncrementalLoadingBase
SDKSample::DataBinding::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::DataReaderWriter::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::DateTimeFormatting::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::DeviceCaps::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::DeviceEnumeration::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::DisplayOrientation::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Drawing::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::EAS::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::ELS::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Errors
SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::FileAccess::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::FileExtensions
SDKSample::FilePicker::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::FilePickerContracts::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::FileSearch::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::FileThumbnails::sealed
SDKSample::Finally
SDKSample::FlipViewCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::FlipViewData::sealed | Creates a collection of groups and items with hard-coded content
SDKSample::FolderEnumeration::sealed
SDKSample::GeolocationCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::GlobalizationPreferencesSample::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::GyrometerCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Helpers
SDKSample::HighContrast::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::HomeGroup::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::HttpClientSample::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Images::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::InclinometerCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::IsRemoteSession::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::LightSensorCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::ListViewSampleDataSource::sealed
SDKSample::ListViewSimple::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::MainPage
SDKSample::MediaButtons::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::MediaCapture::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::MediaServerClient::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::MessageDialogSample::sealed
SDKSample::MicrosoftAccount::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::NetworkInformationApi::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::NumberFormatting::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::OrientationSensorCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PackageSample::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PasswordVaultCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PersonalityAnimations::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Personalization::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PlaybackManager2::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PlaybackManager::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Playlists::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PlayTo::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PlayToreceiver::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PortableDeviceCPP::EventCallback
SDKSample::PortableDeviceCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::PropVariantClearStruct
SDKSample::ProvisioningAgent::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::RemovableStorageCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Rotation::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Scaling::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Scenario
SDKSample::ScrollViewerCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::SDKTemplate::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::sealed
SDKSample::SearchContract::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::ShareSource::sealed
SDKSample::SimpleOrientationSensorCPP::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::SnapSample::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::SplashScreen::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Status
SDKSample::StoreSample::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::StringHelper
SDKSample::StringTrimmer
SDKSample::Syndication::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::TextDisplay::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::TextEditing::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::ThreadPool::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::ThreadPool::ThreadPoolSample
SDKSample::Tiles::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::TouchKeyboard::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::TouchKeyboardTextInput::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Transcode::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::Transforms::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::UserAndCustomControls::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::UserDomainName::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::UssdApi::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::WASAPIAudio::DEVICEPROPS
SDKSample::WASAPIAudio::MFSampleGenerator
SDKSample::WASAPIAudio::sealed
SDKSample::WASAPIAudio::ToneSampleGenerator
SDKSample::WASAPIAudio::WASAPICapture
SDKSample::WASAPIAudio::WASAPIRenderer
SDKSample::WebAuthentication::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::WebSocket::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::WebViewControl::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKSample::XAMLPopup::sealed | An empty page that can be used on its own or navigated to within a Frame
SDKTemplate::App | Provides application-specific behavior to supplement the default Application class
SDKTemplate::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | Implementation of IObservableMap that supports reentrancy for use as a default view model
SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
SDKTemplate::DeviceAppPage
SDKTemplate::MainPage | An empty page that can be used on its own or navigated to within a Frame
SDKTemplate::MainPageSizeChangedEventArgs
SDKTemplate::Scenario
SDKTemplateCS::MainPage
sealed | Wrap a WeakReference as a reference object for use in a collection
SecondaryTiles::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
SecondaryTiles::MainPage
SecondaryTiles::Scenario
SecondaryTiles::sealed | An empty page that can be used on its own or navigated to within a Frame
SetRateOp
Shape
ShapeRecord
ShareTarget::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
ShareTarget::sealed
Simple3DGame
Simple3DGameXaml::sealed
Simple3DTouch
SimpleBlogReader::sealed | Provides application-specific behavior to supplement the default Application class
SimpleCommunication::App
SimpleCommunication::CaptureFailedEventArgs
SimpleCommunication::Common::CaptureDevice
SimpleCommunication::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
SimpleCommunication::LowLatency | An empty page that can be used on its own or navigated to within a Frame
SimpleCommunication::MainPage
SimpleCommunication::Scenario
SimpleCommunication::SdkSample
SimpleCommunication::sealed | An empty page that can be used on its own or navigated to within a Frame
SimpleCommunication::sealed::StreamFilteringCriteria
SimpleCommunication::VideoChat | An empty page that can be used on its own or navigated to within a Frame
SimpleController
SimpleCubeVertex
SimpleSprites
SimpleVertex
SoundEffect
SoundEffectData
SoundFileReader
SourceOp
Sphere
SphereMesh
StartOp
STEREO_PARAMETERS
StereoParameters
StereoSimpleD3D
StopwatchTimer
Story
StreamEffect
StreamingVoiceContext
StreamList
StreamSocketSample::App
StreamSocketSample::Common::LayoutAwarePage | Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model
StreamSocketSample::MainPage
StreamSocketSample::Scenario
StreamSocketSample::sealed | An empty page that can be used on its own or navigated to within a Frame
SuspensionManager
SValue
TangentVertex
TargetTexture
Tasks::sealed
Text
TextAnalysis
TextAnalysis::LinkedRun
TextAnalysis::Run
TextButton
TextElement
TextFrame
TextInterop
TextStyle
TextureLock
TGA_EXTENSION
TGA_FOOTER
TGA_HEADER
ToastsSampleCPP::sealed
TreeIterator< T >
Triangle
TriColorValueHelper
TripOptimizerComponent::Details::TripOptimizerImpl
TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
TripOptimizerComponent::sealed
UiaCoreWindowProvider::IAppWindowProvider
UiaCoreWindowProvider::IDisconnectableProvider
UiaCoreWindowProvider::ITriColorControlInternal
UiaCoreWindowProvider::ITriColorControlProvider
UiaCoreWindowProvider::ITriColorFragmentProvider
UserInterface
Utils
Vector2< T >
Vector3< T >
Vector4< T >
VideoBufferLock
VideoView
ViewTransform
WaveEffect
WaveEffect::Vertex
Web::Details::HttpRequestBuffersCallback
Web::HttpRequest
WICConvert
WICTranslate
WorldCeilingMesh
WorldFloorMesh
WorldWallsMesh
Wrapper::DspSettings
Wrapper::sealed
XAudio2SoundPlayer
XAudio2SoundPlayer::ImplData
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: _BAR_GRAPH_STATE Struct Reference

  • Files
  • Directories
  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

_BAR_GRAPH_STATE Struct Reference

#include "public.h"

List of all members.

Public Attributes

union {
struct {
UCHAR Bar1: 1
UCHAR Bar2: 1
UCHAR Bar3: 1
UCHAR Bar4: 1
UCHAR Bar5: 1
UCHAR Bar6: 1
UCHAR Bar7: 1
UCHAR Bar8: 1
}
UCHAR BarsAsUChar
};
union {
struct {
UCHAR Bar1: 1
UCHAR Bar2: 1
UCHAR Bar3: 1
UCHAR Bar4: 1
UCHAR Bar5: 1
UCHAR Bar6: 1
UCHAR Bar7: 1
UCHAR Bar8: 1
}
UCHAR BarsAsUChar
};
union {
struct {
UCHAR Bar1: 1
UCHAR Bar2: 1
UCHAR Bar3: 1
UCHAR Bar4: 1
UCHAR Bar5: 1
UCHAR Bar6: 1
UCHAR Bar7: 1
UCHAR Bar8: 1
}
UCHAR BarsAsUChar
};

Detailed Description

Definition at line 45 of file public.h.

Member Data Documentation

union { ... }
union { ... }
union { ... }
UCHAR _BAR_GRAPH_STATE::Bar1

Definition at line 58 of file public.h.

UCHAR _BAR_GRAPH_STATE::Bar2

Definition at line 59 of file public.h.

UCHAR _BAR_GRAPH_STATE::Bar3

Definition at line 60 of file public.h.

UCHAR _BAR_GRAPH_STATE::Bar4

Definition at line 61 of file public.h.

UCHAR _BAR_GRAPH_STATE::Bar5

Definition at line 62 of file public.h.

UCHAR _BAR_GRAPH_STATE::Bar6

Definition at line 63 of file public.h.

UCHAR _BAR_GRAPH_STATE::Bar7

Definition at line 64 of file public.h.

UCHAR _BAR_GRAPH_STATE::Bar8

Definition at line 65 of file public.h.

UCHAR _BAR_GRAPH_STATE::BarsAsUChar

Definition at line 72 of file public.h.

The documentation for this struct was generated from the following files:
  • Custom driver access/C#,C++/DLL/public.h
  • Custom driver access/C++/DLL/public.h
  • Custom driver access/C++,JavaScript/DLL/public.h
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: _FILE_PLAYBACK Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

_FILE_PLAYBACK Struct Reference

#include "public.h"

List of all members.

Public Attributes

USHORT | Delay
WCHAR | Path [1]

Detailed Description

Definition at line 140 of file public.h.

Member Data Documentation

USHORT _FILE_PLAYBACK::Delay

Definition at line 146 of file public.h.

WCHAR _FILE_PLAYBACK::Path

Definition at line 152 of file public.h.

The documentation for this struct was generated from the following files:
  • Custom driver access/C#,C++/DLL/public.h
  • Custom driver access/C++/DLL/public.h
  • Custom driver access/C++,JavaScript/DLL/public.h
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: _SDKMESHVERTEXELEMENT Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

_SDKMESHVERTEXELEMENT Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

BYTE | Method
WORD | Offset
WORD | Stream
BYTE | Type
BYTE | Usage
BYTE | UsageIndex

Detailed Description

Definition at line 115 of file SDKMesh.h.

Member Data Documentation

BYTE _SDKMESHVERTEXELEMENT::Method

Definition at line 120 of file SDKMesh.h.

WORD _SDKMESHVERTEXELEMENT::Offset

Definition at line 118 of file SDKMesh.h.

WORD _SDKMESHVERTEXELEMENT::Stream

Definition at line 117 of file SDKMesh.h.

BYTE _SDKMESHVERTEXELEMENT::Type

Definition at line 119 of file SDKMesh.h.

BYTE _SDKMESHVERTEXELEMENT::Usage

Definition at line 121 of file SDKMesh.h.

BYTE _SDKMESHVERTEXELEMENT::UsageIndex

Definition at line 122 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: _SWITCH_STATE Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

_SWITCH_STATE Struct Reference

#include "public.h"

List of all members.

Public Attributes

union {
struct {
UCHAR Switch1: 1
UCHAR Switch2: 1
UCHAR Switch3: 1
UCHAR Switch4: 1
UCHAR Switch5: 1
UCHAR Switch6: 1
UCHAR Switch7: 1
UCHAR Switch8: 1
}
UCHAR SwitchesAsUChar
};
union {
struct {
UCHAR Switch1: 1
UCHAR Switch2: 1
UCHAR Switch3: 1
UCHAR Switch4: 1
UCHAR Switch5: 1
UCHAR Switch6: 1
UCHAR Switch7: 1
UCHAR Switch8: 1
}
UCHAR SwitchesAsUChar
};
union {
struct {
UCHAR Switch1: 1
UCHAR Switch2: 1
UCHAR Switch3: 1
UCHAR Switch4: 1
UCHAR Switch5: 1
UCHAR Switch6: 1
UCHAR Switch7: 1
UCHAR Switch8: 1
}
UCHAR SwitchesAsUChar
};

Detailed Description

Definition at line 85 of file public.h.

Member Data Documentation

union { ... }
union { ... }
union { ... }
UCHAR _SWITCH_STATE::Switch1

Definition at line 93 of file public.h.

UCHAR _SWITCH_STATE::Switch2

Definition at line 94 of file public.h.

UCHAR _SWITCH_STATE::Switch3

Definition at line 95 of file public.h.

UCHAR _SWITCH_STATE::Switch4

Definition at line 96 of file public.h.

UCHAR _SWITCH_STATE::Switch5

Definition at line 97 of file public.h.

UCHAR _SWITCH_STATE::Switch6

Definition at line 98 of file public.h.

UCHAR _SWITCH_STATE::Switch7

Definition at line 99 of file public.h.

UCHAR _SWITCH_STATE::Switch8

Definition at line 100 of file public.h.

UCHAR _SWITCH_STATE::SwitchesAsUChar

Definition at line 107 of file public.h.

The documentation for this struct was generated from the following files:
  • Custom driver access/C#,C++/DLL/public.h
  • Custom driver access/C++/DLL/public.h
  • Custom driver access/C++,JavaScript/DLL/public.h
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: abstract Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

abstract Class Reference

#include "DirectXBase.h"

List of all members.

Public Member Functions

bool | Continuous ()
void | Continuous (_In_ bool continuous)
bool | Continuous ()
void | Continuous (_In_ bool continuous)
virtual float | ConvertDipsToPixels (float dips)
virtual float | ConvertDipsToPixels (float dips)
virtual float | ConvertDipsToPixels (float dips)
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceIndependentResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateDeviceResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
virtual void | CreateWindowSizeDependentResources ()
void | Duration (_In_ float duration)
float | Duration ()
float | Duration ()
void | Duration (_In_ float duration)
virtual DirectX::XMFLOAT3 | Evaluate (_In_ float t)=0
virtual DirectX::XMFLOAT3 | Evaluate (_In_ float t)=0
bool | GetStereoEnabledStatus ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | HandleDeviceLost ()
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^swapChainPanel, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^swapChainPanel, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^swapChainPanel, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^swapChainPanel, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi)
bool | IsActive (_In_ float t)
bool | IsActive (_In_ float t)
bool | IsFinished (_In_ float t)
bool | IsFinished (_In_ float t)
virtual void | LoadState (PersistentState^state)
virtual void | LoadState (PersistentState^state)
Platform::String | Objective ()
Platform::String | Objective ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Present ()
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render (_In_ ID3D11DeviceContext *context)
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render (_In_ ID3D11DeviceContext *context)
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | Render ()=0
virtual void | SaveState (PersistentState^state)
virtual void | SaveState (PersistentState^state)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
virtual void | SetDpi (float dpi)
float | Start ()
void | Start (_In_ float start)
float | Start ()
void | Start (_In_ float start)
float | TimeLimit ()
float | TimeLimit ()
virtual bool | Update (float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects)
virtual bool | Update (float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects)
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
virtual void | UpdateForWindowSizeChange ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()
void | ValidateDevice ()

Public Attributes

internal | __pad0__: DirectXBase()
event D3DDeviceEventHandler | DeviceLost
event D3DDeviceEventHandler | DeviceReset

Private Member Functions

void | CheckStereoEnabledStatus ()
void | CheckStereoEnabledStatus ()
void | OnStereoEnabledChanged (_In_ Platform::Object^sender)
void | OnStereoEnabledChanged (_In_ Platform::Object^sender)
void | OnStereoEnabledChanged (_In_ Platform::Object^sender)
void | UpdateStereoEnabledStatus ()

Private Attributes

bool | m_continuous
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
Microsoft::WRL::ComPtr
< ID2D1Device > 		m_d2dDevice
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_d2dTargetBitmap
Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_d2dTargetBitmapRight
Microsoft::WRL::ComPtr
< ID3D11DeviceContext1 > 		m_d3dContext
Microsoft::WRL::ComPtr
< ID3D11DepthStencilView > 		m_d3dDepthStencilView
Microsoft::WRL::ComPtr
< ID3D11Device1 > 		m_d3dDevice
Microsoft::WRL::ComPtr
< ID3D11RenderTargetView > 		m_d3dRenderTargetView
Microsoft::WRL::ComPtr
< ID3D11RenderTargetView > 		m_d3dRenderTargetViewRight
float | m_dpi
float | m_duration
Microsoft::WRL::ComPtr
< IDWriteFactory1 > 		m_dwriteFactory
D3D_FEATURE_LEVEL | m_featureLevel
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
int | m_indexCount
unsigned int | m_numBuffers
Platform::String | m_objective
Windows::Graphics::Display::DisplayOrientations | m_orientation
Windows::Foundation::Size | m_renderTargetSize
D2D1::Matrix3x2F | m_rotationTransform2D
DirectX::XMFLOAT4X4 | m_rotationTransform3D
float4x4 m_rotationTransform3D
float | m_startTime
bool | m_stereoEnabled
Microsoft::WRL::ComPtr
< IDXGISwapChain1 > 		m_swapChain
Windows::UI::Xaml::Controls::SwapChainBackgroundPanel | m_swapChainPanel
float | m_timeLimit
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
int | m_vertexCount
Microsoft::WRL::ComPtr
< IWICImagingFactory2 > 		m_wicFactory
Platform::Agile
< Windows::UI::Core::CoreWindow > 		m_window
Windows::Foundation::Rect | m_windowBounds
bool | m_windowSizeChangeInProgress

Detailed Description

Definition at line 14 of file DirectXBase.h.

Member Function Documentation

void abstract::CheckStereoEnabledStatus ( ) [private]
void abstract::CheckStereoEnabledStatus ( ) [private]
bool abstract::Continuous ( )
void abstract::Continuous ( _In_ bool continuous )
bool abstract::Continuous ( )
void abstract::Continuous ( _In_ bool continuous )
virtual float abstract::ConvertDipsToPixels ( float dips ) [virtual]
virtual float abstract::ConvertDipsToPixels ( float dips ) [virtual]
virtual float abstract::ConvertDipsToPixels ( float dips ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceIndependentResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateDeviceResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
virtual void abstract::CreateWindowSizeDependentResources ( ) [virtual]
float abstract::Duration ( )
void abstract::Duration ( _In_ float duration )
float abstract::Duration ( )
void abstract::Duration ( _In_ float duration )
virtual DirectX::XMFLOAT3 abstract::Evaluate ( _In_ float t ) [pure virtual]
virtual DirectX::XMFLOAT3 abstract::Evaluate ( _In_ float t ) [pure virtual]
bool abstract::GetStereoEnabledStatus ( )
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::HandleDeviceLost ( ) [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^ | swapChainPanel,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^ | swapChainPanel,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^ | swapChainPanel,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^ | swapChainPanel,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
virtual void abstract::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [virtual]
bool abstract::IsActive ( _In_ float t ) [inline]

Definition at line 31 of file Animate.h.

{ return ((t >= m_startTime) && (m_continuous || (t < (m_startTime + m_duration)))); };

bool abstract::IsActive ( _In_ float t ) [inline]

Definition at line 31 of file Animate.h.

{ return ((t >= m_startTime) && (m_continuous || (t < (m_startTime + m_duration)))); };

bool abstract::IsFinished ( _In_ float t ) [inline]

Definition at line 32 of file Animate.h.

{ return (!m_continuous && (t >= (m_startTime + m_duration))); }

bool abstract::IsFinished ( _In_ float t ) [inline]

Definition at line 32 of file Animate.h.

{ return (!m_continuous && (t >= (m_startTime + m_duration))); }

virtual void abstract::LoadState ( PersistentState^ state ) [virtual]
virtual void abstract::LoadState ( PersistentState^ state ) [virtual]
Platform::String abstract::Objective ( )
Platform::String abstract::Objective ( )
void abstract::OnStereoEnabledChanged ( _In_ Platform::Object^ sender ) [private]
void abstract::OnStereoEnabledChanged ( _In_ Platform::Object^ sender ) [private]
void abstract::OnStereoEnabledChanged ( _In_ Platform::Object^ sender ) [private]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Present ( ) [virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( _In_ ID3D11DeviceContext * context ) [virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( _In_ ID3D11DeviceContext * context ) [virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::Render ( ) [pure virtual]
virtual void abstract::SaveState ( PersistentState^ state ) [virtual]
virtual void abstract::SaveState ( PersistentState^ state ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
virtual void abstract::SetDpi ( float dpi ) [virtual]
float abstract::Start ( )
void abstract::Start ( _In_ float start )
float abstract::Start ( )
void abstract::Start ( _In_ float start )
float abstract::TimeLimit ( )
float abstract::TimeLimit ( )
virtual bool abstract::Update | ( | float | time,
 |  | float | elapsedTime,
 |  | float | timeRemaining,
 |  | std::vector< GameObject^> | objects |
 | ) |  |  | [virtual]
virtual bool abstract::Update | ( | float | time,
 |  | float | elapsedTime,
 |  | float | timeRemaining,
 |  | std::vector< GameObject^> | objects |
 | ) |  |  | [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
virtual void abstract::UpdateForWindowSizeChange ( ) [virtual]
void abstract::UpdateStereoEnabledStatus ( ) [private]
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )
void abstract::ValidateDevice ( )

Member Data Documentation

internal abstract::__pad0__

Definition at line 17 of file DirectXBase.h.

event D3DDeviceEventHandler abstract::DeviceLost

Definition at line 36 of file DirectXBase.h.

event D3DDeviceEventHandler abstract::DeviceReset

Definition at line 37 of file DirectXBase.h.

bool abstract::m_continuous [private]

Definition at line 41 of file Animate.h.

Microsoft::WRL::ComPtr< ID2D1DeviceContext > abstract::m_d2dContext [private]

Definition at line 52 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID2D1Device > abstract::m_d2dDevice [private]

Definition at line 51 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID2D1Factory1 > abstract::m_d2dFactory [private]

Definition at line 50 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID2D1Bitmap1 > abstract::m_d2dTargetBitmap [private]

Definition at line 53 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID2D1Bitmap1 > abstract::m_d2dTargetBitmapRight [private]

Definition at line 53 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID3D11DeviceContext1 > abstract::m_d3dContext [private]

Definition at line 45 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID3D11DepthStencilView > abstract::m_d3dDepthStencilView [private]

Definition at line 56 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID3D11Device1 > abstract::m_d3dDevice [private]

Definition at line 44 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID3D11RenderTargetView > abstract::m_d3dRenderTargetView [private]

Definition at line 47 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID3D11RenderTargetView > abstract::m_d3dRenderTargetViewRight [private]

Definition at line 46 of file DirectXBase.h.

float abstract::m_dpi [private]

Definition at line 62 of file DirectXBase.h.

float abstract::m_duration [private]

Definition at line 43 of file Animate.h.

Microsoft::WRL::ComPtr< IDWriteFactory1 > abstract::m_dwriteFactory [private]

Definition at line 40 of file DirectXBase.h.

D3D_FEATURE_LEVEL abstract::m_featureLevel [private]

Definition at line 59 of file DirectXBase.h.

Microsoft::WRL::ComPtr< ID3D11Buffer > abstract::m_indexBuffer [private]

Definition at line 29 of file MeshObject.h.

int abstract::m_indexCount [private]

Definition at line 31 of file MeshObject.h.

unsigned int abstract::m_numBuffers [private]

Definition at line 58 of file DirectXBase.h.

Platform::String abstract::m_objective [private]

Definition at line 50 of file Level.h.

Windows::Graphics::Display::DisplayOrientations abstract::m_orientation [private]

Definition at line 73 of file DirectXBase.h.

Windows::Foundation::Size abstract::m_renderTargetSize [private]

Definition at line 60 of file DirectXBase.h.

D2D1::Matrix3x2F abstract::m_rotationTransform2D [private]

Definition at line 78 of file DirectXBase.h.

DirectX::XMFLOAT4X4 abstract::m_rotationTransform3D [private]

Definition at line 79 of file DirectXBase.h.

float4x4 abstract::m_rotationTransform3D [private]

Definition at line 62 of file DirectXBase.h.

float abstract::m_startTime [private]

Definition at line 42 of file Animate.h.

bool abstract::m_stereoEnabled [private]

Definition at line 64 of file DirectXBase.h.

Microsoft::WRL::ComPtr< IDXGISwapChain1 > abstract::m_swapChain [private]

Definition at line 46 of file DirectXBase.h.

Windows::UI::Xaml::Controls::SwapChainBackgroundPanel abstract::m_swapChainPanel [private]

Definition at line 36 of file DirectXBase.h.

float abstract::m_timeLimit [private]

Definition at line 51 of file Level.h.

Microsoft::WRL::ComPtr< ID3D11Buffer > abstract::m_vertexBuffer [private]

Definition at line 28 of file MeshObject.h.

int abstract::m_vertexCount [private]

Definition at line 30 of file MeshObject.h.

Microsoft::WRL::ComPtr< IWICImagingFactory2 > abstract::m_wicFactory [private]

Definition at line 41 of file DirectXBase.h.

Platform::Agile< Windows::UI::Core::CoreWindow > abstract::m_window [private]

Definition at line 37 of file DirectXBase.h.

Windows::Foundation::Rect abstract::m_windowBounds [private]

Definition at line 61 of file DirectXBase.h.

bool abstract::m_windowSizeChangeInProgress [private]

Definition at line 57 of file DirectXBase.h.

The documentation for this class was generated from the following files:
  • Direct2D 3D transform effect/C++/DirectXBase.h
  • Direct2D animated text/C++/DirectXBase.h
  • Direct2D animation/C++/DirectXBase.h
  • Direct2D basic image effects/C++/DirectXBase.h
  • Direct2D command list/C++/DirectXBase.h
  • Direct2D composite effect modes/C++/DirectXBase.h
  • Direct2D convolve matrix effect/C++/DirectXBase.h
  • Direct2D custom image effects/C++/ComputeShader/DirectXBase.h
  • Direct2D custom image effects/C++/PixelShader/DirectXBase.h
  • Direct2D custom image effects/C++/VertexShader/DirectXBase.h
  • Direct2D effects on primitives/C++/DirectXBase.h
  • Direct2D geometry realization/C++/DirectXBase.h
  • Direct2D interpolation modes/C++/DirectXBase.h
  • Direct2D perspective transform/C++/DirectXBase.h
  • Direct2D printing images and effects/C++/DirectXBase.h
  • Direct2D save to image file/C++/DirectXBase.h
  • Direct2Dapp printing/C++/DirectXBase.h
  • Direct3D bump mapping/C++/DirectXBase.h
  • Direct3D HLSL fractal generator/C++/DirectXBase.h
  • Direct3D post-processing effects/C++/DirectXBase.h
  • Direct3D resource loading/C++/DirectXBase.h
  • Direct3D sprite/C++/DirectXBase.h
  • Direct3D stereoscopic 3D/C++/DirectXBase.h
  • Direct3D tutorial/C++/Lesson5.Components/DirectXBase.h
  • Direct3D-Direct2D interop/C++/DirectXBase.h
  • DirectWrite custom text renderer/C++/DirectXBase.h
  • DirectWrite hello world/C++/DirectXBase.h
  • DirectWrite hit testing/C++/DirectXBase.h
  • DirectWrite inline object/C++/DirectXBase.h
  • DirectWrite paragraph text/C++/DirectXBase.h
  • DirectWrite vertical text/C++/DirectXBase.h
  • DirectX 3D shooting game/C++/Animate.h
  • DirectX 3D shooting game/C++/DirectXBase.h
  • DirectX 3D shooting game/C++/Level.h
  • DirectX 3D shooting game/C++/MeshObject.h
  • DirectX marble maze game/C++/DirectXBase.h
  • DirectX postcard app/C++/DirectXBase.h
  • DirectX swap chain implementation/C++/DirectXBase.h
  • DirectX touch input/C++/DirectXBase.h
  • DXGI offer and reclaim resources/C++/DirectXBase.h
  • DXGI swap chain rotation/C++/DirectXBase.h
  • Input Manipulations and gestures (C++)/C++/DirectXBase.h
  • Input Simplified ink/C++/DirectXBase.h
  • Input Touch hit testing/C++/DirectXBase.h
  • Media engine native C++ video playback/C++/meplayer.h
  • UI Automation core window provider/C++/DirectXBase.h
  • XAML Direct2D lighting effects/C++/DirectXBase.h
  • XAML DirectX 3D shooting game/C++/Animate.h
  • XAML DirectX 3D shooting game/C++/DirectXBase.h
  • XAML DirectX 3D shooting game/C++/Level.h
  • XAML DirectX 3D shooting game/C++/MeshObject.h
  • XAudio2 audio file playback/C++/DirectXBase.h
  • XAudio2 audio stream effect/C++/DirectXBase.h
  • XInput audio controller playback/C++/DirectXBase.h
  • XInput game controller/C++/DirectXBase.h
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AccountPictureName::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AccountPictureName
  • AccountPictureName::App
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

AccountPictureName::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()

Protected Member Functions

virtual void | OnActivated (Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override

Private Member Functions

void | SetupWindowing (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs)

Private Attributes

Windows::UI::Xaml::Controls::Frame | rootFrame

Detailed Description

Definition at line 24 of file App.xaml.h.

Member Function Documentation

virtual void AccountPictureName::App::OnActivated ( Windows::ApplicationModel::Activation::IActivatedEventArgs^ args ) [override, protected, virtual]
void App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]

Definition at line 43 of file App.xaml.cpp.

{
    if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
    {
        SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
        {
            try
            {
                restoreTask.get();
            }
            catch(Platform::Exception^)
            {
                // If restore fails, the app should proceed as though there was no restored state.
            }

            SetupWindowing(pArgs);
        });
    }
    else
    {
        SetupWindowing(pArgs);
    }

}

void App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]

Definition at line 34 of file App.xaml.cpp.

{
    auto deferral = pArgs->SuspendingOperation->GetDeferral();
    SuspensionManager::StartSaveTask().then([=]()
    {
        deferral->Complete();
    });
}

void App::SetupWindowing ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [private]

Definition at line 68 of file App.xaml.cpp.

{
    if (Window::Current->Content == nullptr)
    {
        rootFrame = ref new Frame();
        TypeName pageType = { "AccountPictureName.MainPage", TypeKind::Custom };
        rootFrame->Navigate(pageType);
        Window::Current->Content = rootFrame;
    }
    MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
    p->LaunchArgs = pArgs;
    Window::Current->Activate();
}

Member Data Documentation

internal AccountPictureName::App::__pad0__

Definition at line 27 of file App.xaml.h.

Windows::UI::Xaml::Controls::Frame AccountPictureName::App::rootFrame [private]

Definition at line 37 of file App.xaml.h.

The documentation for this class was generated from the following files:
  • Account picture name/C++/App.xaml.h
  • Account picture name/C++/App.xaml.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AccountPictureName::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AccountPictureName
  • Common
  • AccountPictureName::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

AccountPictureName::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 26 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String AccountPictureName::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void AccountPictureName::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 186 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void AccountPictureName::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void AccountPictureName::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 127 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal AccountPictureName::Common::LayoutAwarePage::__pad0__

Definition at line 29 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> AccountPictureName::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 51 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> AccountPictureName::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 53 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken AccountPictureName::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 52 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Account picture name/C++/common/LayoutAwarePage.h
  • Account picture name/C++/common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AccountPictureName::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AccountPictureName
  • AccountPictureName::MainPage
Public Member Functions | Static Private Attributes

AccountPictureName::MainPage Class Reference

#include "Constants.h"

List of all members.

Public Member Functions

void | LoadSetAccountPictureScenario ()

Static Private Attributes

static Platform::Array< Scenario > | scenariosInner

Detailed Description

Definition at line 23 of file Constants.h.

Member Function Documentation

void MainPage::LoadSetAccountPictureScenario ( )

Definition at line 28 of file Constants.cpp.

{
    LoadScenario("AccountPictureName.SetAccountPicture");
    Scenarios->SelectedIndex = 3;
    InvalidateSize();
}

Member Data Documentation

Platform::Array< Scenario > MainPage::scenariosInner [static, private]
Initial value:
 ref new Platform::Array<Scenario>
{

    { "Get User DisplayName", "AccountPictureName.GetUserDisplayName" },
    { "Get User First and Last Name", "AccountPictureName.GetUserFirstAndLastName" },
    { "Get Account Picture", "AccountPictureName.GetAccountPicture" },
    { "Set Account Picture", "AccountPictureName.SetAccountPicture" }
}

Definition at line 45 of file Constants.h.

The documentation for this class was generated from the following files:
  • Account picture name/C++/Constants.h
  • Account picture name/C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AccountPictureName::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AccountPictureName
  • AccountPictureName::Scenario
Public Attributes

AccountPictureName::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String AccountPictureName::Scenario::ClassName

Definition at line 20 of file Constants.h.

Platform::String AccountPictureName::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • Account picture name/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AccountPictureName::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AccountPictureName
  • AccountPictureName::sealed
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes

AccountPictureName::sealed Class Reference

#include "GetAccountPicture.xaml.h"

List of all members.

Public Member Functions

GetAccountPicture ()
GetUserDisplayName ()
GetUserFirstAndLastName ()
void | LoadScenario (Platform::String^scenarioName)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
SetAccountPicture ()

Protected Member Functions

void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Protected Attributes

internal | __pad0__: static MainPage^ Current

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

~MainPage ()
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetDisplayNameButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetFirstNameButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetLargeImageButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetLastNameButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetSmallImageButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetVideoButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | HideImageAndVideoControls ()
void | InvalidateSize ()
void | InvalidateViewState ()
void | PictureChanged (Platform::Object^sender, Platform::Object^e)
void | PopulateScenarios ()
void | SetAccountPictureName (Platform::String^strFeature)
void | SetImageButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetVideoButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs | _protocolEventArgs
bool | autoSizeInputSectionWhenSnapped
Windows::UI::Xaml::Controls::Frame | HiddenFrame
MainPage rootPage
Platform::Collections::Vector
< Object^> 		ScenarioList

Detailed Description

Definition at line 25 of file GetAccountPicture.xaml.h.

Constructor & Destructor Documentation

AccountPictureName::sealed::~MainPage ( ) [private]

Member Function Documentation

void AccountPictureName::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AccountPictureName::sealed::GetAccountPicture ( )
void AccountPictureName::sealed::GetDisplayNameButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AccountPictureName::sealed::GetFirstNameButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AccountPictureName::sealed::GetLargeImageButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AccountPictureName::sealed::GetLastNameButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AccountPictureName::sealed::GetSmallImageButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AccountPictureName::sealed::GetUserDisplayName ( )
AccountPictureName::sealed::GetUserFirstAndLastName ( )
void AccountPictureName::sealed::GetVideoButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AccountPictureName::sealed::HideImageAndVideoControls ( ) [private]
void AccountPictureName::sealed::InvalidateSize ( ) [private]
void AccountPictureName::sealed::InvalidateViewState ( ) [private]
void AccountPictureName::sealed::LoadScenario ( Platform::String^ scenarioName )
AccountPictureName::sealed::MainPage ( )
void AccountPictureName::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void AccountPictureName::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void AccountPictureName::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AccountPictureName::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AccountPictureName::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AccountPictureName::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AccountPictureName::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AccountPictureName::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void AccountPictureName::sealed::PictureChanged | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void AccountPictureName::sealed::PopulateScenarios ( ) [private]
void AccountPictureName::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
AccountPictureName::sealed::SetAccountPicture ( )
void AccountPictureName::sealed::SetAccountPictureName ( Platform::String^ strFeature ) [private]
void AccountPictureName::sealed::SetImageButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AccountPictureName::sealed::SetVideoButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal AccountPictureName::sealed::__pad0__ [protected]

Definition at line 104 of file MainPage.xaml.h.

Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs AccountPictureName::sealed::_protocolEventArgs [private]

Definition at line 96 of file MainPage.xaml.h.

bool AccountPictureName::sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 94 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame AccountPictureName::sealed::HiddenFrame [private]

Definition at line 92 of file MainPage.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 34 of file GetAccountPicture.xaml.h.

Platform::Collections::Vector<Object^> AccountPictureName::sealed::ScenarioList [private]

Definition at line 91 of file MainPage.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> AccountPictureName::sealed::MainPageResized

Definition at line 81 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> AccountPictureName::sealed::ScenarioLoaded

Definition at line 80 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Account picture name/C++/GetAccountPicture.xaml.h
  • Account picture name/C++/GetUserDisplayName.xaml.h
  • Account picture name/C++/GetUserFirstAndLastName.xaml.h
  • Account picture name/C++/MainPage.xaml.h
  • Account picture name/C++/SetAccountPicture.xaml.h
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: aligned_deleter Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

aligned_deleter Struct Reference

#include "scoped.h"

List of all members.

Public Member Functions

void operator() (void *p)

Detailed Description

Definition at line 23 of file scoped.h.

Member Function Documentation

void aligned_deleter::operator() ( void * p ) [inline]

Definition at line 23 of file scoped.h.

{ void operator()(void* p) { _aligned_free(p); } };

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/scoped.h
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Alignment Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

Alignment Struct Reference

#include "UserInterface.h"

List of all members.

Public Attributes

AlignType horizontal
AlignType vertical

Detailed Description

Definition at line 42 of file UserInterface.h.

Member Data Documentation

AlignType Alignment::horizontal

Definition at line 44 of file UserInterface.h.

AlignType Alignment::vertical

Definition at line 45 of file UserInterface.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/UserInterface.h
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AmpPixel Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

AmpPixel Struct Reference

#include "AmpPixel.h"

List of all members.

Public Member Functions

AmpPixel () restrict(cpu
amp | b (0)
amp | g (0)
amp | r (0)
void | SetFromRGB (float r, float g, float b) restrict(cpu
amp | u (0)
amp | v (0)

Public Attributes

amp | __pad0__: y(0)
float | b
float | g
float | r
float | u
float | v
float | y

Detailed Description

Definition at line 16 of file AmpPixel.h.

Constructor & Destructor Documentation

AmpPixel::AmpPixel ( )

Member Function Documentation

amp AmpPixel::b ( 0 ) [inline]

Definition at line 26 of file AmpPixel.h.

: y(0), u(0), v(0), r(0), g(0), b(0) {}

amp AmpPixel::g ( 0 )
amp AmpPixel::r ( 0 )
void AmpPixel::SetFromRGB | ( | float | r,
 |  | float | g,
 |  | float | b |
 | ) |  |  | [inline]
amp AmpPixel::u ( 0 )
amp AmpPixel::v ( 0 )

Member Data Documentation

amp AmpPixel::__pad0__

Definition at line 26 of file AmpPixel.h.

float AmpPixel::b

Definition at line 24 of file AmpPixel.h.

float AmpPixel::g

Definition at line 23 of file AmpPixel.h.

float AmpPixel::r

Definition at line 22 of file AmpPixel.h.

float AmpPixel::u

Definition at line 19 of file AmpPixel.h.

float AmpPixel::v

Definition at line 20 of file AmpPixel.h.

float AmpPixel::y

Definition at line 18 of file AmpPixel.h.

The documentation for this struct was generated from the following file:
  • Hilo C++/C++/CartoonEffect/AmpPixel.h
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AnimateCirclePosition Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

AnimateCirclePosition Class Reference

#include "Animate.h"

List of all members.

Public Member Functions

virtual DirectX::XMFLOAT3 | Evaluate (_In_ float t) override
virtual DirectX::XMFLOAT3 | Evaluate (_In_ float t) override

Public Attributes

internal | __pad0__: AnimateCirclePosition( _In_ DirectX::XMFLOAT3 center
internal _In_
DirectX::XMFLOAT3 _In_
DirectX::XMFLOAT3 _In_ float
_In_ bool _In_ bool 		clockwise
internal _In_
DirectX::XMFLOAT3 _In_
DirectX::XMFLOAT3 _In_ float
_In_ bool 		continuous
internal _In_
DirectX::XMFLOAT3 _In_
DirectX::XMFLOAT3 _In_ float 		duration
internal _In_
DirectX::XMFLOAT3 _In_
DirectX::XMFLOAT3 		planeNormal
internal _In_ DirectX::XMFLOAT3 | startPosition

Private Attributes

DirectX::XMFLOAT3 | m_center
bool | m_clockwise
DirectX::XMFLOAT3 | m_planeNormal
float | m_radius
DirectX::XMFLOAT4X4 | m_rotationMatrix
DirectX::XMFLOAT3 | m_startPosition

Detailed Description

Definition at line 113 of file Animate.h.

Member Function Documentation

XMFLOAT3 AnimateCirclePosition::Evaluate ( _In_ float t ) [override, virtual]

Definition at line 270 of file Animate.cpp.

{
    if (t <= m_startTime)
    {
        return m_startPosition;
    }

    if ((t >= (m_startTime + m_duration)) && !m_continuous)
    {
        return m_startPosition;
    }

    float startTime = m_startTime;
    if (m_continuous)
    {
        // For continuous operation move the start time forward to
        // eliminate previous iterations.
        startTime += ((int)((t - m_startTime) / m_duration)) * m_duration;
    }

    float u = (t - startTime) / m_duration * XM_2PI;

    XMFLOAT3 currentPosition;
    currentPosition.x = m_radius * cos(u);
    currentPosition.y = m_radius * sin(u);
    currentPosition.z = 0.0f;

    XMStoreFloat3(
        &currentPosition,
        XMVector3TransformCoord(
            XMLoadFloat3(&currentPosition),
            XMLoadFloat4x4(&m_rotationMatrix)
            )
        );

    return currentPosition;
}

virtual DirectX::XMFLOAT3 AnimateCirclePosition::Evaluate ( _In_ float t ) [override, virtual]

Member Data Documentation

internal AnimateCirclePosition::__pad0__

Definition at line 117 of file Animate.h.

internal _In_ DirectX::XMFLOAT3 _In_ DirectX::XMFLOAT3 _In_ float _In_ bool _In_ bool AnimateCirclePosition::clockwise

Definition at line 117 of file Animate.h.

internal _In_ DirectX::XMFLOAT3 _In_ DirectX::XMFLOAT3 _In_ float _In_ bool AnimateCirclePosition::continuous

Definition at line 117 of file Animate.h.

internal _In_ DirectX::XMFLOAT3 _In_ DirectX::XMFLOAT3 _In_ float AnimateCirclePosition::duration

Definition at line 117 of file Animate.h.

DirectX::XMFLOAT3 AnimateCirclePosition::m_center [private]

Definition at line 128 of file Animate.h.

bool AnimateCirclePosition::m_clockwise [private]

Definition at line 132 of file Animate.h.

DirectX::XMFLOAT3 AnimateCirclePosition::m_planeNormal [private]

Definition at line 129 of file Animate.h.

float AnimateCirclePosition::m_radius [private]

Definition at line 131 of file Animate.h.

DirectX::XMFLOAT4X4 AnimateCirclePosition::m_rotationMatrix [private]

Definition at line 127 of file Animate.h.

DirectX::XMFLOAT3 AnimateCirclePosition::m_startPosition [private]

Definition at line 130 of file Animate.h.

internal _In_ DirectX::XMFLOAT3 _In_ DirectX::XMFLOAT3 AnimateCirclePosition::planeNormal

Definition at line 117 of file Animate.h.

internal _In_ DirectX::XMFLOAT3 AnimateCirclePosition::startPosition

Definition at line 117 of file Animate.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Animate.h
  • XAML DirectX 3D shooting game/C++/Animate.h
  • DirectX 3D shooting game/C++/Animate.cpp
  • XAML DirectX 3D shooting game/C++/Animate.cpp
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AnimateLineListPosition Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

AnimateLineListPosition Class Reference

#include "Animate.h"

List of all members.

Public Member Functions

internal virtual _In_reads_(count)
DirectX DirectX::XMFLOAT3 		Evaluate (_In_ float t) override
internal virtual _In_reads_(count)
DirectX DirectX::XMFLOAT3 		Evaluate (_In_ float t) override

Public Attributes

internal | __pad0__: AnimateLineListPosition( _In_ unsigned int count

Private Attributes

unsigned int | m_count
std::vector< LineSegment > | m_segment
float | m_totalLength

Detailed Description

Definition at line 86 of file Animate.h.

Member Function Documentation

XMFLOAT3 AnimateLineListPosition::Evaluate ( _In_ float t ) [override, virtual]

Definition at line 155 of file Animate.cpp.

{
    if (t <= m_startTime)
    {
        return m_segment[0].position;
    }

    if ((t >= (m_startTime + m_duration)) && !m_continuous)
    {
        return m_segment[m_count-1].position;
    }

    float startTime = m_startTime;
    if (m_continuous)
    {
        // For continuous operation move the start time forward to
        // eliminate previous iterations.
        startTime += ((int)((t - m_startTime) / m_duration)) * m_duration;
    }

    float u = (t - startTime) / m_duration;
    // Find the right segment.
    unsigned int i = 0;
    while (u > m_segment[i + 1].uStart)
    {
        i++;
    }

    u -= m_segment[i].uStart;
    u /= m_segment[i].uLength;

    XMFLOAT3 currentPosition;
    currentPosition.x = m_segment[i].position.x + (m_segment[i + 1].position.x - m_segment[i].position.x)*u;
    currentPosition.y = m_segment[i].position.y + (m_segment[i + 1].position.y - m_segment[i].position.y)*u;
    currentPosition.z = m_segment[i].position.z + (m_segment[i + 1].position.z - m_segment[i].position.z)*u;

    return currentPosition;
}

internal virtual _In_reads_ (count) DirectX DirectX::XMFLOAT3 AnimateLineListPosition::Evaluate ( _In_ float t ) [override, virtual]

Member Data Documentation

internal AnimateLineListPosition::__pad0__

Definition at line 90 of file Animate.h.

unsigned int AnimateLineListPosition::m_count [private]

Definition at line 98 of file Animate.h.

std::vector< LineSegment > AnimateLineListPosition::m_segment [private]

Definition at line 100 of file Animate.h.

float AnimateLineListPosition::m_totalLength [private]

Definition at line 99 of file Animate.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Animate.h
  • XAML DirectX 3D shooting game/C++/Animate.h
  • DirectX 3D shooting game/C++/Animate.cpp
  • XAML DirectX 3D shooting game/C++/Animate.cpp
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AnimateLinePosition Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

AnimateLinePosition Class Reference

#include "Animate.h"

List of all members.

Public Member Functions

virtual DirectX::XMFLOAT3 | Evaluate (_In_ float t) override
virtual DirectX::XMFLOAT3 | Evaluate (_In_ float t) override

Public Attributes

internal | __pad0__: AnimateLinePosition( _In_ DirectX::XMFLOAT3 startPosition
internal _In_
DirectX::XMFLOAT3 _In_ float
_In_ bool 		continuous
internal _In_
DirectX::XMFLOAT3 _In_ float 		duration
internal _In_ DirectX::XMFLOAT3 | endPosition

Private Attributes

DirectX::XMFLOAT3 | m_endPosition
float | m_length
DirectX::XMFLOAT3 | m_startPosition

Detailed Description

Definition at line 52 of file Animate.h.

Member Function Documentation

XMFLOAT3 AnimateLinePosition::Evaluate ( _In_ float t ) [override, virtual]

Definition at line 84 of file Animate.cpp.

{
    if (t <= m_startTime)
    {
        return m_startPosition;
    }

    if ((t >= (m_startTime + m_duration)) && !m_continuous)
    {
        return m_endPosition;
    }

    float startTime = m_startTime;
    if (m_continuous)
    {
        // For continuous operation move the start time forward to
        // eliminate previous iterations.
        startTime += ((int)((t - m_startTime) / m_duration)) * m_duration;
    }

    float u = (t - startTime) / m_duration;
    XMFLOAT3 currentPosition;
    currentPosition.x = m_startPosition.x + (m_endPosition.x - m_startPosition.x)*u;
    currentPosition.y = m_startPosition.y + (m_endPosition.y - m_startPosition.y)*u;
    currentPosition.z = m_startPosition.z + (m_endPosition.z - m_startPosition.z)*u;

    return currentPosition;
}

virtual DirectX::XMFLOAT3 AnimateLinePosition::Evaluate ( _In_ float t ) [override, virtual]

Member Data Documentation

internal AnimateLinePosition::__pad0__

Definition at line 56 of file Animate.h.

internal _In_ DirectX::XMFLOAT3 _In_ float _In_ bool AnimateLinePosition::continuous

Definition at line 56 of file Animate.h.

internal _In_ DirectX::XMFLOAT3 _In_ float AnimateLinePosition::duration

Definition at line 56 of file Animate.h.

internal _In_ DirectX::XMFLOAT3 AnimateLinePosition::endPosition

Definition at line 56 of file Animate.h.

DirectX::XMFLOAT3 AnimateLinePosition::m_endPosition [private]

Definition at line 65 of file Animate.h.

float AnimateLinePosition::m_length [private]

Definition at line 66 of file Animate.h.

DirectX::XMFLOAT3 AnimateLinePosition::m_startPosition [private]

Definition at line 64 of file Animate.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Animate.h
  • XAML DirectX 3D shooting game/C++/Animate.h
  • DirectX 3D shooting game/C++/Animate.cpp
  • XAML DirectX 3D shooting game/C++/Animate.cpp
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes

Animation< T > Class Template Reference

#include "animation.h"

Inherited by EaseInExponentialAnimation< T >, EaseInOutExponentialAnimation< T >, EaseOutExponentialAnimation< T >, and LinearAnimation< T >.

List of all members.

Public Member Functions

Animation (T start, T end, T duration)
T | GetDuration ()
T | GetEnd ()
T | GetStart ()
T | GetValue (T time)
void | SetDuration (T duration)
void | SetEnd (T end)
void | SetStart (T start)

Protected Member Functions

virtual T | ComputeValue (T time)=0

Protected Attributes

T | m_Duration
T | m_End
T | m_Start

Detailed Description

template<class T>
class Animation< T >

Definition at line 19 of file animation.h.

Constructor & Destructor Documentation

template<class T >
Animation< T >::Animation | ( | T | start,
 |  | T | end,
 |  | T | duration |
 | ) |  |  | [inline]

Definition at line 22 of file animation.h.

                                          :
        m_Start(start),
        m_End(end),
        m_Duration(duration)
    {
    }

Member Function Documentation

template<class T >
virtual T Animation< T >::ComputeValue ( T time ) [protected, pure virtual]

Implemented in LinearAnimation< T >, EaseInExponentialAnimation< T >, EaseOutExponentialAnimation< T >, and EaseInOutExponentialAnimation< T >.

template<class T >
T Animation< T >::GetDuration ( ) [inline]

Definition at line 54 of file animation.h.

    {
        return m_Duration;
    }

template<class T >
T Animation< T >::GetEnd ( ) [inline]

Definition at line 44 of file animation.h.

    {
        return m_End;
    }

template<class T >
T Animation< T >::GetStart ( ) [inline]

Definition at line 34 of file animation.h.

    {
        return m_Start;
    }

template<class T >
T Animation< T >::GetValue ( T time ) [inline]

Definition at line 59 of file animation.h.

    {
        time = min(max(time, 0), m_Duration);
        return ComputeValue(time);
    }

template<class T >
void Animation< T >::SetDuration ( T duration ) [inline]

Definition at line 49 of file animation.h.

    {
        m_Duration = max(0, duration);
    }

template<class T >
void Animation< T >::SetEnd ( T end ) [inline]

Definition at line 39 of file animation.h.

    {
        m_End = end;
    }

template<class T >
void Animation< T >::SetStart ( T start ) [inline]

Definition at line 29 of file animation.h.

    {
        m_Start = start;
    }

Member Data Documentation

template<class T >
T Animation< T >::m_Duration [protected]

Definition at line 68 of file animation.h.

template<class T >
T Animation< T >::m_End [protected]

Definition at line 70 of file animation.h.

template<class T >
T Animation< T >::m_Start [protected]

Definition at line 69 of file animation.h.

The documentation for this class was generated from the following file:
  • Direct2D animation/C++/animation.h
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{SoundFileReader.cpp}::ChunkHeader Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • anonymous_namespace{SoundFileReader.cpp}
  • anonymous_namespace{SoundFileReader.cpp}::ChunkHeader
Public Attributes

anonymous_namespace{SoundFileReader.cpp}::ChunkHeader Struct Reference

List of all members.

Public Attributes

uint32 | size
uint32 | tag

Detailed Description

Definition at line 25 of file SoundFileReader.cpp.

Member Data Documentation

uint32 anonymous_namespace{SoundFileReader.cpp}::ChunkHeader::size

Definition at line 28 of file SoundFileReader.cpp.

uint32 anonymous_namespace{SoundFileReader.cpp}::ChunkHeader::tag

Definition at line 27 of file SoundFileReader.cpp.

The documentation for this struct was generated from the following file:
  • XAudio2 audio file playback/C++/SoundFileReader.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • anonymous_namespace{XAudio2SoundPlayer.cpp}
  • anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
Public Member Functions | Public Attributes | Private Attributes

anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander Class Reference

List of all members.

Public Member Functions

SoundCallbackHander (bool *isPlayingHolder)
~SoundCallbackHander ()
STDMETHOD_ (void, OnLoopEnd)(THIS_ void *bufferContext)
STDMETHOD_ (void, OnBufferEnd)(THIS_ void *bufferContext)
STDMETHOD_ (void, OnBufferStart)(THIS_ void *bufferContext)
STDMETHOD_ (void, OnStreamEnd)(THIS)
STDMETHOD_ (void, OnVoiceProcessingPassEnd)(THIS)
STDMETHOD_ (void, OnVoiceProcessingPassStart)(THIS_ UINT32 bytesRequired)
STDMETHOD_ (void, OnVoiceError)(THIS_ void *bufferContext

Public Attributes

HRESULT | error

Private Attributes

bool * | m_isPlayingHolder

Detailed Description

Definition at line 16 of file XAudio2SoundPlayer.cpp.

Constructor & Destructor Documentation

anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::SoundCallbackHander ( bool * isPlayingHolder ) [inline]

Definition at line 19 of file XAudio2SoundPlayer.cpp.

                                                       :
                m_isPlayingHolder(isPlayingHolder)
            {
            }

anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::~SoundCallbackHander ( ) [inline]

Definition at line 24 of file XAudio2SoundPlayer.cpp.

            {
                m_isPlayingHolder = nullptr;
            }

Member Function Documentation

anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::STDMETHOD_ | ( | void | ,
 |  | OnVoiceProcessingPassStart |
 | ) |  |
anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::STDMETHOD_ | ( | void | ,
 |  | OnVoiceError |
 | ) |  |
anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::STDMETHOD_ | ( | void | ,
 |  | OnLoopEnd |
 | ) |  |
anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::STDMETHOD_ | ( | void | ,
 |  | OnBufferEnd |
 | ) |  |
anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::STDMETHOD_ | ( | void | ,
 |  | OnBufferStart |
 | ) |  |
anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::STDMETHOD_ | ( | void | ,
 |  | OnStreamEnd |
 | ) |  |
anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::STDMETHOD_ | ( | void | ,
 |  | OnVoiceProcessingPassEnd |
 | ) |  |

Member Data Documentation

HRESULT anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::error

Definition at line 38 of file XAudio2SoundPlayer.cpp.

bool* anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander::m_isPlayingHolder [private]

Definition at line 41 of file XAudio2SoundPlayer.cpp.

The documentation for this class was generated from the following file:
  • XAudio2 audio file playback/C++/XAudio2SoundPlayer.cpp
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AntSystem::Ant Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AntSystem
  • AntSystem::Ant
Public Member Functions | Private Member Functions | Private Attributes

AntSystem::Ant Class Reference

List of all members.

Public Member Functions

Ant (const vector< shared_ptr< Node >> &nodes, vector< shared_ptr< Edge >> &edges, const size_t initialNodeIndex, double heuristicShortestDistance, double alpha, double beta)
void | Backtrack ()
void | Explore ()
void | GetTour (vector< size_t > &tour, double &tourLength) const

Private Member Functions

size_t | MoveNext (size_t currentNodeIndex)
Ant const & | operator= (Ant const &)

Private Attributes

double | m_alpha
double | m_beta
vector< shared_ptr< Edge > > & | m_edges
double | m_heuristicShortestDistance
const size_t | m_initialNodeIndex
double | m_lengthOfPath
const vector< shared_ptr< Node > > & | m_nodes
vector< size_t > | m_route

Detailed Description

Definition at line 110 of file AntSystem.cpp.

Constructor & Destructor Documentation

AntSystem::Ant::Ant | ( | const vector< shared_ptr< Node >> & | nodes,
 |  | vector< shared_ptr< Edge >> & | edges,
 |  | const size_t | initialNodeIndex,
 |  | double | heuristicShortestDistance,
 |  | double | alpha,
 |  | double | beta |
 | ) |  |  | [inline, explicit]

Definition at line 113 of file AntSystem.cpp.

            : m_nodes(nodes)
            , m_edges(edges)
            , m_initialNodeIndex(initialNodeIndex)
            , m_lengthOfPath(0)
            , m_heuristicShortestDistance(heuristicShortestDistance)
            , m_alpha(alpha)
            , m_beta(beta)
        {
        }

Member Function Documentation

void AntSystem::Ant::Backtrack ( )

Definition at line 248 of file AntSystem.cpp.

    {
        // The amount of pheromone is inversely proportional to the
        // length of the current tour.
        // This means that shorter tours receive a greater amount
        // of pheromone.
        const double amount = m_heuristicShortestDistance / m_lengthOfPath;

        auto last = end(m_route) - 1;
        for (auto iter = begin(m_route); iter != last; ++iter)
        {
            auto next = iter + 1;

            //
            // Drop pheromone on edge.

            auto edge = FindEdge(begin(m_edges), end(m_edges),
                m_nodes[*iter], m_nodes[*next]);

            edge->Pheromone += amount;
        }
    }

void AntSystem::Ant::Explore ( )

Definition at line 223 of file AntSystem.cpp.

    {
        // Clear previous route.
        m_route.clear();

        // Begin at start node.
        m_route.push_back(m_initialNodeIndex);

        // Tour the graph.
        size_t currentNodeIndex = m_initialNodeIndex;
        while (m_route.size() < m_nodes.size())
        {
            currentNodeIndex = MoveNext(currentNodeIndex);
            assert(currentNodeIndex != static_cast<size_t>(-1));
            m_route.push_back(currentNodeIndex);
        }

        // End at start node.
        m_route.push_back(m_initialNodeIndex);

        // Compute length of path.
        m_lengthOfPath = ComputeLengthOfRoute(m_nodes, m_route, m_edges);
    }

void AntSystem::Ant::GetTour | ( | vector< size_t > & | tour,
 |  | double & | tourLength |
 | ) |  |  | const [inline]

Definition at line 134 of file AntSystem.cpp.

        {
            tour = m_route;
            tourLength = m_lengthOfPath;
        }

size_t AntSystem::Ant::MoveNext ( size_t currentNodeIndex ) [private]

Definition at line 177 of file AntSystem.cpp.

    {
        size_t candidate = static_cast<size_t>(-1);

        // Compute the total edge pheromone contribution (denominator of formula).
        double totalEdgeContribution = 0.0;
        for (size_t i = 0; i < m_nodes.size(); ++i)
        {
            if (currentNodeIndex == i || find(begin(m_route), end(m_route), i) != end(m_route))
                continue;
            auto edge = FindEdge(begin(m_edges), end(m_edges), m_nodes[currentNodeIndex], m_nodes[i]);
            totalEdgeContribution += (pow(edge->Pheromone, m_alpha) * pow((1.0 / edge->TravelDistance), m_beta));
        }

        // Select next node.
        double bestProbability = 0.0;
        for (size_t i = 0; i < m_nodes.size(); ++i)
        {
            if (i == currentNodeIndex)
                continue;

            // If we did not yet visit this node...
            if (find(begin(m_route), end(m_route), i) == end(m_route))
            {
                // Get the edge that connects the current node to the candidate node.
                const auto edge = FindEdge(begin(m_edges), end(m_edges),
                    m_nodes[currentNodeIndex], m_nodes[i]);

                //
                // Choose this node if it is the best fit so far.

                double top = (pow(edge->Pheromone, m_alpha) * pow((1.0 / edge->TravelDistance), m_beta));
                double p = top / totalEdgeContribution;

                if (p >= bestProbability)
                {
                    bestProbability = p;
                    candidate = i;
                }
            }
        }

        return candidate;
    }

Ant const& AntSystem::Ant::operator= ( Ant const & ) [private]

Member Data Documentation

double AntSystem::Ant::m_alpha [private]

Definition at line 167 of file AntSystem.cpp.

double AntSystem::Ant::m_beta [private]

Definition at line 170 of file AntSystem.cpp.

vector<shared_ptr<Edge> >& AntSystem::Ant::m_edges [private]

Definition at line 152 of file AntSystem.cpp.

double AntSystem::Ant::m_heuristicShortestDistance [private]

Definition at line 164 of file AntSystem.cpp.

const size_t AntSystem::Ant::m_initialNodeIndex [private]

Definition at line 155 of file AntSystem.cpp.

double AntSystem::Ant::m_lengthOfPath [private]

Definition at line 161 of file AntSystem.cpp.

const vector<shared_ptr<Node> >& AntSystem::Ant::m_nodes [private]

Definition at line 149 of file AntSystem.cpp.

vector<size_t> AntSystem::Ant::m_route [private]

Definition at line 158 of file AntSystem.cpp.

The documentation for this class was generated from the following file:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/AntSystem.cpp
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AntSystem::Edge Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AntSystem
  • AntSystem::Edge
Public Member Functions | Public Attributes

AntSystem::Edge Struct Reference

#include "AntSystem.h"

List of all members.

Public Member Functions

Edge (std::shared_ptr< Node > pointA, std::shared_ptr< Node > pointB)

Public Attributes

double | Pheromone
std::shared_ptr< Node > | PointA
std::shared_ptr< Node > | PointB
double | TravelDistance

Detailed Description

Definition at line 62 of file AntSystem.h.

Constructor & Destructor Documentation

AntSystem::Edge::Edge | ( | std::shared_ptr< Node > | pointA,
 |  | std::shared_ptr< Node > | pointB |
 | ) |  |  | [inline, explicit]

Definition at line 64 of file AntSystem.h.

            : PointA(pointA)
            , PointB(pointB)
            , Pheromone(0.0)
            , TravelDistance(-1.0)
        {
        }

Member Data Documentation

double AntSystem::Edge::Pheromone

Definition at line 77 of file AntSystem.h.

std::shared_ptr<Node> AntSystem::Edge::PointA

Definition at line 73 of file AntSystem.h.

std::shared_ptr<Node> AntSystem::Edge::PointB

Definition at line 75 of file AntSystem.h.

double AntSystem::Edge::TravelDistance

Definition at line 79 of file AntSystem.h.

The documentation for this struct was generated from the following file:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/AntSystem.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AntSystem::LatLong Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AntSystem
  • AntSystem::LatLong
Public Member Functions | Public Attributes

AntSystem::LatLong Struct Reference

#include "AntSystem.h"

List of all members.

Public Member Functions

LatLong (double latitude, double longitude)

Public Attributes

double | Latitude
double | Longitude

Detailed Description

Definition at line 16 of file AntSystem.h.

Constructor & Destructor Documentation

AntSystem::LatLong::LatLong | ( | double | latitude,
 |  | double | longitude |
 | ) |  |  | [inline, explicit]

Definition at line 18 of file AntSystem.h.

            : Latitude(latitude)
            , Longitude(longitude)
        {
        }

Member Data Documentation

double AntSystem::LatLong::Latitude

Definition at line 25 of file AntSystem.h.

double AntSystem::LatLong::Longitude

Definition at line 26 of file AntSystem.h.

The documentation for this struct was generated from the following file:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/AntSystem.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AntSystem::Node Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AntSystem
  • AntSystem::Node
Public Member Functions | Public Attributes

AntSystem::Node Struct Reference

#include "AntSystem.h"

List of all members.

Public Member Functions

Node (const std::wstring &inputName)

Public Attributes

std::wstring | InputName
std::vector< LatLong > | Locations
std::vector< std::wstring > | Names
LatLong ResolvedLocation
std::wstring | ResolvedName

Detailed Description

Definition at line 30 of file AntSystem.h.

Constructor & Destructor Documentation

AntSystem::Node::Node ( const std::wstring & inputName ) [inline, explicit]

Definition at line 32 of file AntSystem.h.

            : InputName(inputName)
            , ResolvedLocation(0.0, 0.0)
        {
        }

Member Data Documentation

std::wstring AntSystem::Node::InputName

Definition at line 39 of file AntSystem.h.

std::vector<LatLong> AntSystem::Node::Locations

Definition at line 55 of file AntSystem.h.

std::vector<std::wstring> AntSystem::Node::Names

Definition at line 54 of file AntSystem.h.

LatLong AntSystem::Node::ResolvedLocation

Definition at line 42 of file AntSystem.h.

std::wstring AntSystem::Node::ResolvedName

Definition at line 45 of file AntSystem.h.

The documentation for this struct was generated from the following file:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/AntSystem.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AppBarControl::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AppBarControl
  • AppBarControl::App
Public Member Functions | Public Attributes | Private Attributes

AppBarControl::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()

Private Attributes

Windows::UI::Xaml::Controls::Frame | rootFrame

Detailed Description

Definition at line 24 of file App.xaml.h.

Member Function Documentation

void App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]

Definition at line 43 of file App.xaml.cpp.

{
    if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
    {
        SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
        {
            try
            {
                restoreTask.get();
            }
            catch (Platform::Exception^)
            {
                // If restore fails, the app should proceed as though there was no restored state.
            }
        });
    }
    if (Window::Current->Content == nullptr)
    {
        rootFrame = ref new Frame();
        TypeName pageType = { "AppBarControl.MainPage", TypeKind::Custom };
        rootFrame->Navigate(pageType);
        Window::Current->Content = rootFrame;
    }
    MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
    p->LaunchArgs = pArgs;
    Window::Current->Activate();
}

void App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]

Definition at line 34 of file App.xaml.cpp.

{
    auto deferral = pArgs->SuspendingOperation->GetDeferral();
    SuspensionManager::StartSaveTask().then([=]()
    {
        deferral->Complete();
    });
}

Member Data Documentation

internal AppBarControl::App::__pad0__

Definition at line 27 of file App.xaml.h.

Windows::UI::Xaml::Controls::Frame AppBarControl::App::rootFrame [private]

Definition at line 32 of file App.xaml.h.

The documentation for this class was generated from the following files:
  • XAML AppBar control/C++/App.xaml.h
  • XAML AppBar control/C++/App.xaml.cpp
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AppBarControl::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AppBarControl
  • Common
  • AppBarControl::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

AppBarControl::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 26 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String AppBarControl::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void AppBarControl::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 186 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void AppBarControl::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void AppBarControl::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 127 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal AppBarControl::Common::LayoutAwarePage::__pad0__

Definition at line 29 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> AppBarControl::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 50 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> AppBarControl::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 52 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken AppBarControl::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 51 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • XAML AppBar control/C++/common/LayoutAwarePage.h
  • XAML AppBar control/C++/common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AppBarControl::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AppBarControl
  • AppBarControl::MainPage

AppBarControl::MainPage Class Reference

#include "Constants.h"

Detailed Description

Definition at line 23 of file Constants.h.

The documentation for this class was generated from the following file:
  • XAML AppBar control/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AppBarControl::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AppBarControl
  • AppBarControl::Scenario
Public Attributes

AppBarControl::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String AppBarControl::Scenario::ClassName

Definition at line 20 of file Constants.h.

Platform::String AppBarControl::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • XAML AppBar control/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AppBarControl::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AppBarControl
  • AppBarControl::sealed
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes | Static Private Attributes

AppBarControl::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "GlobalPage.xaml.h"

List of all members.

Public Member Functions

GlobalPage ()
void | LoadScenario (Platform::String^scenarioName)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
Page1 ()
Page2 ()
Page3 ()
Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()

Protected Member Functions

void | BottonAppBar_Loaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Protected Attributes

internal | __pad0__: static MainPage^ Current

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

~MainPage ()
void | AddFavoriteButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Back_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Back_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateSize ()
void | InvalidateViewState ()
void | IsSticky_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PageTwo_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PopulateScenarios ()
void | RegisterAppBarButtons ()
void | RemoveSaveButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetFeatureName (Platform::String^strFeature)
void | ShowMe_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowMe_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | starButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

bool | autoSizeInputSectionWhenSnapped
Windows::UI::Xaml::Controls::Frame | HiddenFrame
Windows::UI::Xaml::Controls::StackPanel | rightPanel
GlobalPage | rootPage
MainPage rootPage
Platform::Collections::Vector
< Object^> 		ScenarioList
Windows::UI::Xaml::Controls::Button | starButton

Static Private Attributes

static MainPage | rootPage
static GlobalPage | rootPage

Detailed Description

Definition at line 18 of file GlobalPage.xaml.h.

Constructor & Destructor Documentation

AppBarControl::sealed::~MainPage ( ) [private]

Member Function Documentation

void AppBarControl::sealed::AddFavoriteButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AppBarControl::sealed::Back_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AppBarControl::sealed::Back_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AppBarControl::sealed::BottonAppBar_Loaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
void AppBarControl::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AppBarControl::sealed::GlobalPage ( )
void AppBarControl::sealed::InvalidateSize ( ) [private]
void AppBarControl::sealed::InvalidateViewState ( ) [private]
void AppBarControl::sealed::IsSticky_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AppBarControl::sealed::LoadScenario ( Platform::String^ scenarioName )
AppBarControl::sealed::MainPage ( )
void AppBarControl::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void AppBarControl::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AppBarControl::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
AppBarControl::sealed::Page1 ( )
AppBarControl::sealed::Page2 ( )
AppBarControl::sealed::Page3 ( )
void AppBarControl::sealed::PageTwo_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AppBarControl::sealed::PopulateScenarios ( ) [private]
void AppBarControl::sealed::RegisterAppBarButtons ( ) [private]
void AppBarControl::sealed::RemoveSaveButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AppBarControl::sealed::Scenario1 ( )
AppBarControl::sealed::Scenario2 ( )
AppBarControl::sealed::Scenario3 ( )
AppBarControl::sealed::Scenario4 ( )
void AppBarControl::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void AppBarControl::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
void AppBarControl::sealed::ShowMe_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AppBarControl::sealed::ShowMe_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AppBarControl::sealed::starButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal AppBarControl::sealed::__pad0__ [protected]

Definition at line 98 of file MainPage.xaml.h.

bool AppBarControl::sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 88 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame AppBarControl::sealed::HiddenFrame [private]

Definition at line 86 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::StackPanel AppBarControl::sealed::rightPanel [private]

Definition at line 30 of file Page2.xaml.h.

GlobalPage AppBarControl::sealed::rootPage [private]

Definition at line 28 of file Page2.xaml.h.

GlobalPage AppBarControl::sealed::rootPage [static, private]

Definition at line 27 of file Page1.xaml.h.

MainPage AppBarControl::sealed::rootPage [private]

Definition at line 36 of file Scenario1.xaml.h.

MainPage sealed::rootPage [static, private]

Definition at line 30 of file GlobalPage.xaml.h.

Platform::Collections::Vector<Object^> AppBarControl::sealed::ScenarioList [private]

Definition at line 85 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Button AppBarControl::sealed::starButton [private]

Definition at line 29 of file Page2.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> AppBarControl::sealed::MainPageResized

Definition at line 75 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> AppBarControl::sealed::ScenarioLoaded

Definition at line 74 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • XAML AppBar control/C++/GlobalPage.xaml.h
  • XAML AppBar control/C++/MainPage.xaml.h
  • XAML AppBar control/C++/Page1.xaml.h
  • XAML AppBar control/C++/Page2.xaml.h
  • XAML AppBar control/C++/Page3.xaml.h
  • XAML AppBar control/C++/Scenario1.xaml.h
  • XAML AppBar control/C++/Scenario2.xaml.h
  • XAML AppBar control/C++/Scenario3.xaml.h
  • XAML AppBar control/C++/Scenario4.xaml.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AssociationLaunching::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • AssociationLaunching
  • AssociationLaunching::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Static Private Member Functions | Private Attributes | Static Private Attributes

AssociationLaunching::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
virtual void | App::OnActivated (Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override
virtual void | App::OnFileActivated (Windows::ApplicationModel::Activation::FileActivatedEventArgs^args) override
String | ConvertResolution (ResolutionScale scale)
String | ConvertViewState (ApplicationViewState state)
void | DoNavigation (TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame)
LaunchFileInput ()
LaunchFileOutput ()
LaunchUriInput ()
LaunchUriOutput ()
MainPage ()
void | NotifyUser (String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
ReceiveFileInput ()
ReceiveFileOutput ()
ReceiveUriInput ()
ReceiveUriOutput ()
ScenarioList ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~App ()
~LaunchFileInput ()
~LaunchFileOutput ()
~LaunchUriInput ()
~LaunchUriOutput ()
~MainPage ()
~ReceiveFileInput ()
~ReceiveFileOutput ()
~ReceiveUriInput ()
~ReceiveUriOutput ()
~ScenarioList ()
void | CheckResolutionAndViewState ()
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, RoutedEventArgs^e)
void | inputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | LaunchFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LaunchFileOpenWithButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LaunchFileWithWarningButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LaunchUriButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LaunchUriOpenWithButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LaunchUriWithWarningButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | outputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | Page_Loaded (Object^sender, RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | PickAndLaunchFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetFeatureName (Platform::String^strFeature)

Static Private Member Functions

static Windows::Foundation::Point | GetOpenWithPosition (Windows::UI::Xaml::FrameworkElement^element)
static Windows::Foundation::Point | GetOpenWithPosition (Windows::UI::Xaml::FrameworkElement^element)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::ApplicationModel::Activation::FileActivatedEventArgs | _fileEventArgs
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _layoutHandlerToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs | _protocolEventArgs
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
MainPage | rootPage

Static Private Attributes

static Platform::String | fileToLaunch
static Platform::String | uriToLaunch

Detailed Description

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

AssociationLaunching::sealed::~App ( ) [private]
AssociationLaunching::sealed::~LaunchFileInput ( ) [private]
AssociationLaunching::sealed::~LaunchFileOutput ( ) [private]
AssociationLaunching::sealed::~LaunchUriInput ( ) [private]
AssociationLaunching::sealed::~LaunchUriOutput ( ) [private]
AssociationLaunching::sealed::~MainPage ( ) [private]
AssociationLaunching::sealed::~ReceiveFileInput ( ) [private]
AssociationLaunching::sealed::~ReceiveFileOutput ( ) [private]
AssociationLaunching::sealed::~ReceiveUriInput ( ) [private]
AssociationLaunching::sealed::~ReceiveUriOutput ( ) [private]
AssociationLaunching::sealed::~ScenarioList ( ) [private]

Member Function Documentation

AssociationLaunching::sealed::App ( )
virtual void AssociationLaunching::sealed::App::OnActivated ( Windows::ApplicationModel::Activation::IActivatedEventArgs^ args ) [override, virtual]
virtual void AssociationLaunching::sealed::App::OnFileActivated ( Windows::ApplicationModel::Activation::FileActivatedEventArgs^ args ) [override, virtual]
void AssociationLaunching::sealed::CheckResolutionAndViewState ( ) [private]
String AssociationLaunching::sealed::ConvertResolution ( ResolutionScale scale )
String AssociationLaunching::sealed::ConvertViewState ( ApplicationViewState state )
void AssociationLaunching::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void AssociationLaunching::sealed::DoNavigation | ( | TypeName | pageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | frame
 | ) |  |
void AssociationLaunching::sealed::Footer_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
static Windows::Foundation::Point AssociationLaunching::sealed::GetOpenWithPosition ( Windows::UI::Xaml::FrameworkElement^ element ) [static, private]
static Windows::Foundation::Point AssociationLaunching::sealed::GetOpenWithPosition ( Windows::UI::Xaml::FrameworkElement^ element ) [static, private]
void AssociationLaunching::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
void AssociationLaunching::sealed::LaunchFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AssociationLaunching::sealed::LaunchFileInput ( )
void AssociationLaunching::sealed::LaunchFileOpenWithButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AssociationLaunching::sealed::LaunchFileOutput ( )
void AssociationLaunching::sealed::LaunchFileWithWarningButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AssociationLaunching::sealed::LaunchUriButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AssociationLaunching::sealed::LaunchUriInput ( )
void AssociationLaunching::sealed::LaunchUriOpenWithButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AssociationLaunching::sealed::LaunchUriOutput ( )
void AssociationLaunching::sealed::LaunchUriWithWarningButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AssociationLaunching::sealed::MainPage ( )
void AssociationLaunching::sealed::NotifyUser | ( | String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void AssociationLaunching::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void AssociationLaunching::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void AssociationLaunching::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
void AssociationLaunching::sealed::Page_Loaded | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void AssociationLaunching::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void AssociationLaunching::sealed::PickAndLaunchFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
AssociationLaunching::sealed::ReceiveFileInput ( )
AssociationLaunching::sealed::ReceiveFileOutput ( )
AssociationLaunching::sealed::ReceiveUriInput ( )
AssociationLaunching::sealed::ReceiveUriOutput ( )
AssociationLaunching::sealed::ScenarioList ( )
void AssociationLaunching::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void AssociationLaunching::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken AssociationLaunching::sealed::_displayHandlerToken [private]

Definition at line 80 of file MainPage.xaml.h.

Windows::ApplicationModel::Activation::FileActivatedEventArgs AssociationLaunching::sealed::_fileEventArgs [private]

Definition at line 96 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame AssociationLaunching::sealed::_inputFrame [private]

Definition at line 77 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken AssociationLaunching::sealed::_inputFrameLoadedToken [private]

Definition at line 84 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken AssociationLaunching::sealed::_layoutHandlerToken [private]

Definition at line 81 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken AssociationLaunching::sealed::_logicalDpiChangedToken [private]

Definition at line 83 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame AssociationLaunching::sealed::_outputFrame [private]

Definition at line 78 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken AssociationLaunching::sealed::_outputFrameLoadedToken [private]

Definition at line 85 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken AssociationLaunching::sealed::_pageLoadedHandlerToken [private]

Definition at line 82 of file MainPage.xaml.h.

Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs AssociationLaunching::sealed::_protocolEventArgs [private]

Definition at line 95 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame AssociationLaunching::sealed::_scenariosFrame [private]

Definition at line 76 of file MainPage.xaml.h.

Platform::String AssociationLaunching::sealed::fileToLaunch [static, private]

Definition at line 42 of file LaunchFileInput.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 33 of file LaunchFileInput.xaml.h.

Platform::String AssociationLaunching::sealed::uriToLaunch [static, private]

Definition at line 41 of file LaunchUriInput.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> AssociationLaunching::sealed::OutputFrameLoaded

Definition at line 67 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Association launching/C++/App.xaml.h
  • Association launching/C++/LaunchFileInput.xaml.h
  • Association launching/C++/LaunchFileOutput.xaml.h
  • Association launching/C++/LaunchUriInput.xaml.h
  • Association launching/C++/LaunchUriOutput.xaml.h
  • Association launching/C++/MainPage.xaml.h
  • Association launching/C++/ReceiveFileInput.xaml.h
  • Association launching/C++/ReceiveFileOutput.xaml.h
  • Association launching/C++/ReceiveUriInput.xaml.h
  • Association launching/C++/ReceiveUriOutput.xaml.h
  • Association launching/C++/ScenarioList.xaml.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AsteroidData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

AsteroidData Struct Reference

#include "SimpleSprites.h"

List of all members.

Public Attributes

float2 pos
float | rot
float | rotVel
float | scale
float2 vel

Detailed Description

Definition at line 33 of file SimpleSprites.h.

Member Data Documentation

float2 AsteroidData::pos

Definition at line 35 of file SimpleSprites.h.

float AsteroidData::rot

Definition at line 37 of file SimpleSprites.h.

float AsteroidData::rotVel

Definition at line 38 of file SimpleSprites.h.

float AsteroidData::scale

Definition at line 39 of file SimpleSprites.h.

float2 AsteroidData::vel

Definition at line 36 of file SimpleSprites.h.

The documentation for this struct was generated from the following file:
  • Direct3D sprite/C++/SimpleSprites.h
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AsyncCallback< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Public Attributes

AsyncCallback< T > Class Template Reference

#include "AsyncCB.h"

Inherits IMFAsyncCallback, IMFAsyncCallback, and IMFAsyncCallback.

List of all members.

Public Types

typedef HRESULT(T::* | InvokeFn )(IMFAsyncResult *pAsyncResult)
typedef HRESULT(T::* | InvokeFn )(IMFAsyncResult *pAsyncResult)
typedef HRESULT(T::* | InvokeFn )(IMFAsyncResult *pAsyncResult)

Public Member Functions

AsyncCallback (T *pParent, InvokeFn fn)
AsyncCallback (T *pParent, InvokeFn fn)
AsyncCallback (T *pParent, InvokeFn fn)
STDMETHODIMP | GetParameters (DWORD *, DWORD *)
STDMETHODIMP | GetParameters (DWORD *, DWORD *)
STDMETHODIMP | GetParameters (DWORD *, DWORD *)
STDMETHODIMP | Invoke (IMFAsyncResult *pAsyncResult)
STDMETHODIMP | Invoke (IMFAsyncResult *pAsyncResult)
STDMETHODIMP | Invoke (IMFAsyncResult *pAsyncResult)
STDMETHODIMP | QueryInterface (REFIID iid, void **ppv)
STDMETHODIMP | QueryInterface (REFIID iid, void **ppv)
STDMETHODIMP | QueryInterface (REFIID iid, void **ppv)
STDMETHODIMP_ (ULONG) Release()
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (ULONG) Release()
STDMETHODIMP_ (ULONG) Release()
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (ULONG) AddRef()

Public Attributes

InvokeFn m_pInvokeFn
T * | m_pParent

Detailed Description

template<class T>
class AsyncCallback< T >

Definition at line 25 of file AsyncCB.h.

Member Typedef Documentation

template<class T>
typedef HRESULT(T::* AsyncCallback< T >::InvokeFn)(IMFAsyncResult *pAsyncResult)

Definition at line 28 of file AsyncCB.h.

template<class T>
typedef HRESULT(T::* AsyncCallback< T >::InvokeFn)(IMFAsyncResult *pAsyncResult)

Definition at line 28 of file AsyncCB.h.

template<class T>
typedef HRESULT(T::* AsyncCallback< T >::InvokeFn)(IMFAsyncResult *pAsyncResult)

Definition at line 28 of file AsyncCB.h.

Constructor & Destructor Documentation

template<class T>
AsyncCallback< T >::AsyncCallback | ( | T * | pParent,
 |  | InvokeFn | fn |
 | ) |  |  | [inline]

Definition at line 30 of file AsyncCB.h.

                                           : m_pParent(pParent), m_pInvokeFn(fn)
    {
    }

template<class T>
AsyncCallback< T >::AsyncCallback | ( | T * | pParent,
 |  | InvokeFn | fn |
 | ) |  |  | [inline]

Definition at line 30 of file AsyncCB.h.

                                           : m_pParent(pParent), m_pInvokeFn(fn)
    {
    }

template<class T>
AsyncCallback< T >::AsyncCallback | ( | T * | pParent,
 |  | InvokeFn | fn |
 | ) |  |  | [inline]

Definition at line 30 of file AsyncCB.h.

                                           : m_pParent(pParent), m_pInvokeFn(fn)
    {
    }

Member Function Documentation

template<class T>
STDMETHODIMP AsyncCallback< T >::GetParameters | ( | DWORD * | ,
 |  | DWORD * |  |
 | ) |  |  | [inline]

Definition at line 68 of file AsyncCB.h.

    {
        // Implementation of this method is optional.
        return E_NOTIMPL;
    }

template<class T>
STDMETHODIMP AsyncCallback< T >::GetParameters | ( | DWORD * | ,
 |  | DWORD * |  |
 | ) |  |  | [inline]

Definition at line 68 of file AsyncCB.h.

    {
        // Implementation of this method is optional.
        return E_NOTIMPL;
    }

template<class T>
STDMETHODIMP AsyncCallback< T >::GetParameters | ( | DWORD * | ,
 |  | DWORD * |  |
 | ) |  |  | [inline]

Definition at line 68 of file AsyncCB.h.

    {
        // Implementation of this method is optional.
        return E_NOTIMPL;
    }

template<class T>
STDMETHODIMP AsyncCallback< T >::Invoke ( IMFAsyncResult * pAsyncResult ) [inline]

Definition at line 74 of file AsyncCB.h.

    {
        return (m_pParent->*m_pInvokeFn)(pAsyncResult);
    }

template<class T>
STDMETHODIMP AsyncCallback< T >::Invoke ( IMFAsyncResult * pAsyncResult ) [inline]

Definition at line 74 of file AsyncCB.h.

    {
        return (m_pParent->*m_pInvokeFn)(pAsyncResult);
    }

template<class T>
STDMETHODIMP AsyncCallback< T >::Invoke ( IMFAsyncResult * pAsyncResult ) [inline]

Definition at line 74 of file AsyncCB.h.

    {
        return (m_pParent->*m_pInvokeFn)(pAsyncResult);
    }

template<class T>
STDMETHODIMP AsyncCallback< T >::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppv |
 | ) |  |  | [inline]

Definition at line 43 of file AsyncCB.h.

    {
        if (!ppv)
        {
            return E_POINTER;
        }
        if (iid == __uuidof(IUnknown))
        {
            *ppv = static_cast<IUnknown*>(static_cast<IMFAsyncCallback*>(this));
        }
        else if (iid == __uuidof(IMFAsyncCallback))
        {
            *ppv = static_cast<IMFAsyncCallback*>(this);
        }
        else
        {
            *ppv = NULL;
            return E_NOINTERFACE;
        }
        AddRef();
        return S_OK;
    }

template<class T>
STDMETHODIMP AsyncCallback< T >::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppv |
 | ) |  |  | [inline]

Definition at line 43 of file AsyncCB.h.

    {
        if (!ppv)
        {
            return E_POINTER;
        }
        if (iid == __uuidof(IUnknown))
        {
            *ppv = static_cast<IUnknown*>(static_cast<IMFAsyncCallback*>(this));
        }
        else if (iid == __uuidof(IMFAsyncCallback))
        {
            *ppv = static_cast<IMFAsyncCallback*>(this);
        }
        else
        {
            *ppv = NULL;
            return E_NOINTERFACE;
        }
        AddRef();
        return S_OK;
    }

template<class T>
STDMETHODIMP AsyncCallback< T >::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppv |
 | ) |  |  | [inline]

Definition at line 43 of file AsyncCB.h.

    {
        if (!ppv)
        {
            return E_POINTER;
        }
        if (iid == __uuidof(IUnknown))
        {
            *ppv = static_cast<IUnknown*>(static_cast<IMFAsyncCallback*>(this));
        }
        else if (iid == __uuidof(IMFAsyncCallback))
        {
            *ppv = static_cast<IMFAsyncCallback*>(this);
        }
        else
        {
            *ppv = NULL;
            return E_NOINTERFACE;
        }
        AddRef();
        return S_OK;
    }

template<class T>
AsyncCallback< T >::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 39 of file AsyncCB.h.

                                   {
        // Delegate to parent class.
        return m_pParent->Release();
    }

template<class T>
AsyncCallback< T >::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 35 of file AsyncCB.h.

                                  {
        // Delegate to parent class.
        return m_pParent->AddRef();
    }

template<class T>
AsyncCallback< T >::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 39 of file AsyncCB.h.

                                   {
        // Delegate to parent class.
        return m_pParent->Release();
    }

template<class T>
AsyncCallback< T >::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 35 of file AsyncCB.h.

                                  {
        // Delegate to parent class.
        return m_pParent->AddRef();
    }

template<class T>
AsyncCallback< T >::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 35 of file AsyncCB.h.

                                  {
        // Delegate to parent class.
        return m_pParent->AddRef();
    }

template<class T>
AsyncCallback< T >::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 39 of file AsyncCB.h.

                                   {
        // Delegate to parent class.
        return m_pParent->Release();
    }

Member Data Documentation

template<class T>
InvokeFn AsyncCallback< T >::m_pInvokeFn

Definition at line 80 of file AsyncCB.h.

template<class T>
T * AsyncCallback< T >::m_pParent

Definition at line 79 of file AsyncCB.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/AsyncCB.h
  • Media extensions/C++/MediaExtensions/Common/AsyncCB.h
  • Real-time communication/C++/MediaExtensions/Common/AsyncCB.h
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Audio Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Audio Class Reference

#include "Audio.h"

List of all members.

Public Member Functions

~Audio ()
void | CreateDeviceIndependentResources ()
void | CreateDeviceIndependentResources ()
void | CreateResources ()
bool | HasEngineExperiencedCriticalError ()
void | Initialize ()
void | Initialize ()
void | Initialize ()
bool | IsSoundEffectStarted (SoundEvent sound)
IXAudio2 * | MusicEngine ()
IXAudio2 * | MusicEngine ()
void | PlaySoundEffect (SoundEvent sound)
void | ReleaseResources ()
void | Render ()
void | ResumeAudio ()
void | ResumeAudio ()
void | ResumeAudio ()
void | SetEngineExperiencedCriticalError ()
void | SetRoomSize (float roomSize, float *wallDistances)
void | SetSoundEffectFilter (SoundEvent sound, float frequency, float oneOverQ)
void | SetSoundEffectPitch (SoundEvent sound, float pitch)
void | SetSoundEffectVolume (SoundEvent sound, float volume)
IXAudio2 * | SoundEffectEngine ()
IXAudio2 * | SoundEffectEngine ()
void | Start ()
void | StopSoundEffect (SoundEvent sound)
void | SuspendAudio ()
void | SuspendAudio ()
void | SuspendAudio ()

Public Attributes

internal | __pad0__: Audio()
bool | m_isAudioStarted

Private Member Functions

void | CreateReverb (IXAudio2 *engine, IXAudio2MasteringVoice *masteringVoice, XAUDIO2FX_REVERB_PARAMETERS *parameters, IXAudio2SubmixVoice **newSubmix, bool enableEffect)
void | CreateSourceVoice (SoundEvent)

Private Attributes

bool | m_audioAvailable
byte | m_audioBuffers [MAX_BUFFER_COUNT][STREAMING_BUFFER_SIZE]
uint32 | m_currentBuffer
bool | m_engineExperiencedCriticalError
Microsoft::WRL::ComPtr< IXAudio2 > | m_musicEngine
IXAudio2 * | m_musicEngine
AudioEngineCallbacks m_musicEngineCallback
IXAudio2MasteringVoice * | m_musicMasteringVoice
IXAudio2SubmixVoice * | m_musicReverbVoiceLargeRoom
IXAudio2SubmixVoice * | m_musicReverbVoiceSmallRoom
IXAudio2SourceVoice * | m_musicSourceVoice
MediaStreamer m_musicStreamer
XAUDIO2FX_REVERB_PARAMETERS | m_reverbParametersLarge
XAUDIO2FX_REVERB_PARAMETERS | m_reverbParametersSmall
IXAudio2 * | m_soundEffectEngine
Microsoft::WRL::ComPtr< IXAudio2 > | m_soundEffectEngine
AudioEngineCallbacks m_soundEffectEngineCallback
IXAudio2MasteringVoice * | m_soundEffectMasteringVoice
IXAudio2SubmixVoice * | m_soundEffectReverbVoiceLargeRoom
IXAudio2SubmixVoice * | m_soundEffectReverbVoiceSmallRoom
SoundEffectData | m_soundEffects [SOUND_EVENTS]
StreamingVoiceContext m_voiceContext

Detailed Description

Definition at line 17 of file Audio.h.

Constructor & Destructor Documentation

Audio::~Audio ( )

Definition at line 24 of file Audio.cpp.

{
    SuspendAudio();
}

Member Function Documentation

void Audio::CreateDeviceIndependentResources ( )

Definition at line 26 of file Audio.cpp.

{
    UINT32 flags = 0;

    DX::ThrowIfFailed(
        XAudio2Create(&m_musicEngine, flags)
        );

#if defined(_DEBUG)
    XAUDIO2_DEBUG_CONFIGURATION debugConfiguration = {0};
    debugConfiguration.BreakMask = XAUDIO2_LOG_ERRORS;
    debugConfiguration.TraceMask = XAUDIO2_LOG_ERRORS;
    m_musicEngine->SetDebugConfiguration(&debugConfiguration);
#endif

    HRESULT hr = m_musicEngine->CreateMasteringVoice(&m_musicMasteringVoice);
    if (FAILED(hr))
    {
        // Unable to create an audio device
        m_audioAvailable = false;
        return;
    }

    DX::ThrowIfFailed(
        XAudio2Create(&m_soundEffectEngine, flags)
        );

#if defined(_DEBUG)
    m_soundEffectEngine->SetDebugConfiguration(&debugConfiguration);
#endif

    DX::ThrowIfFailed(
        m_soundEffectEngine->CreateMasteringVoice(&m_soundEffectMasteringVoice)
        );

    m_audioAvailable = true;
}

void Audio::CreateDeviceIndependentResources ( )
void Audio::CreateResources ( )

Definition at line 157 of file Audio.cpp.

{
    try
    {
        // Media Foundation is a convenient way to get both file I/O and format decode for
        // audio assets. You can replace the streamer in this sample with your own file I/O
        // and decode routines.
        m_musicStreamer.Initialize(L"Media\\Audio\\background.wma");

        DX::ThrowIfFailed(
            XAudio2Create(&m_musicEngine)
            );

#if defined(_DEBUG)
        XAUDIO2_DEBUG_CONFIGURATION debugConfig = {0};
        debugConfig.BreakMask = XAUDIO2_LOG_ERRORS;
        debugConfig.TraceMask = XAUDIO2_LOG_ERRORS;
        m_musicEngine->SetDebugConfiguration(&debugConfig);
#endif

        m_musicEngineCallback.Initialize(this);
        m_musicEngine->RegisterForCallbacks(&m_musicEngineCallback);

        // This sample plays the equivalent of background music, which we tag on the
        // mastering voice as AudioCategory_GameMedia. In ordinary usage, if we were
        // playing the music track with no effects, we could route it entirely through
        // Media Foundation. Here we are using XAudio2 to apply a reverb effect to the
        // music, so we use Media Foundation to decode the data then we feed it through
        // the XAudio2 pipeline as a separate Mastering Voice, so that we can tag it
        // as Game Media. We default the mastering voice to 2 channels to simplify
        // the reverb logic.
        DX::ThrowIfFailed(
            m_musicEngine->CreateMasteringVoice(
                &m_musicMasteringVoice,
                2,
                48000,
                0,
                nullptr,
                nullptr,
                AudioCategory_GameMedia
                )
        );

        CreateReverb(
            m_musicEngine,
            m_musicMasteringVoice,
            &m_reverbParametersSmall,
            &m_musicReverbVoiceSmallRoom,
            true
            );
        CreateReverb(
            m_musicEngine,
            m_musicMasteringVoice,
            &m_reverbParametersLarge,
            &m_musicReverbVoiceLargeRoom,
            true
            );

        XAUDIO2_SEND_DESCRIPTOR descriptors[3];
        descriptors[0].pOutputVoice = m_musicMasteringVoice;
        descriptors[0].Flags = 0;
        descriptors[1].pOutputVoice = m_musicReverbVoiceSmallRoom;
        descriptors[1].Flags = 0;
        descriptors[2].pOutputVoice = m_musicReverbVoiceLargeRoom;
        descriptors[2].Flags = 0;
        XAUDIO2_VOICE_SENDS sends = {0};
        sends.SendCount = 3;
        sends.pSends = descriptors;
        WAVEFORMATEX& waveFormat = m_musicStreamer.GetOutputWaveFormatEx();

        DX::ThrowIfFailed(
            m_musicEngine->CreateSourceVoice(&m_musicSourceVoice, &waveFormat, 0, 1.0f, &m_voiceContext, &sends, nullptr)
            );

        DX::ThrowIfFailed(
            m_musicMasteringVoice->SetVolume(0.4f)
            );

        // Create a separate engine and mastering voice for sound effects in the sample
        // Games will use many voices in a complex graph for audio, mixing all effects down to a
        // single mastering voice.
        // We are creating an entirely new engine instance and mastering voice in order to tag
        // our sound effects with the audio category AudioCategory_GameEffects.
        DX::ThrowIfFailed(
            XAudio2Create(&m_soundEffectEngine)
            );

        m_soundEffectEngineCallback.Initialize(this);
        m_soundEffectEngine->RegisterForCallbacks(&m_soundEffectEngineCallback);

        // We default the mastering voice to 2 channels to simplify the reverb logic.
        DX::ThrowIfFailed(
            m_soundEffectEngine->CreateMasteringVoice(&m_soundEffectMasteringVoice, 2, 48000, 0, nullptr, nullptr, AudioCategory_GameEffects)
            );

        CreateReverb(m_soundEffectEngine, m_soundEffectMasteringVoice, &m_reverbParametersSmall, &m_soundEffectReverbVoiceSmallRoom, true);
        CreateReverb(m_soundEffectEngine, m_soundEffectMasteringVoice, &m_reverbParametersLarge, &m_soundEffectReverbVoiceLargeRoom, true);

        CreateSourceVoice(RollingEvent);
        CreateSourceVoice(FallingEvent);
        CreateSourceVoice(CollisionEvent);
        CreateSourceVoice(MenuChangeEvent);
        CreateSourceVoice(MenuSelectedEvent);
        CreateSourceVoice(CheckpointEvent);
    }
    catch (...)
    {
        m_engineExperiencedCriticalError = true;
    }
}

void Audio::CreateReverb | ( | IXAudio2 * | engine,
 |  | IXAudio2MasteringVoice * | masteringVoice,
 |  | XAUDIO2FX_REVERB_PARAMETERS * | parameters,
 |  | IXAudio2SubmixVoice ** | newSubmix,
 |  | bool | enableEffect |
 | ) |  |  | [private]

Definition at line 268 of file Audio.cpp.

{
    XAUDIO2_EFFECT_DESCRIPTOR soundEffectdescriptor;
    XAUDIO2_EFFECT_CHAIN soundEffectChain;
    Microsoft::WRL::ComPtr<IUnknown> soundEffectXAPO;

    DX::ThrowIfFailed(
        XAudio2CreateReverb(&soundEffectXAPO)
        );

    soundEffectdescriptor.InitialState = false;
    soundEffectdescriptor.OutputChannels = 2;
    soundEffectdescriptor.pEffect = soundEffectXAPO.Get();
    soundEffectChain.EffectCount = 1;
    soundEffectChain.pEffectDescriptors = &soundEffectdescriptor;

    DX::ThrowIfFailed(
        engine->CreateSubmixVoice(newSubmix, 2, 48000, 0, 0, nullptr, &soundEffectChain)
        );

    DX::ThrowIfFailed(
        (*newSubmix)->SetEffectParameters(0, parameters, sizeof(m_reverbParametersSmall))
        );

    if (enableEffect)
    {
        DX::ThrowIfFailed(
            (*newSubmix)->EnableEffect(0)
            );
    }

    DX::ThrowIfFailed(
        (*newSubmix)->SetVolume (1.0f)
        );

    float outputMatrix[4] = {0, 0, 0, 0};
    DX::ThrowIfFailed(
        (*newSubmix)->SetOutputMatrix(masteringVoice, 2, 2, outputMatrix)
        );
}

void Audio::CreateSourceVoice ( SoundEvent sound ) [private]

Definition at line 309 of file Audio.cpp.

{
    // Load all data for each sound effect into a single in-memory buffer
    MediaStreamer soundEffectStream;
    switch (sound)
    {
        case RollingEvent: soundEffectStream.Initialize(L"Media\\Audio\\MarbleRoll.wav"); break;
        case FallingEvent: soundEffectStream.Initialize(L"Media\\Audio\\MarbleFall.wav"); break;
        case CollisionEvent: soundEffectStream.Initialize(L"Media\\Audio\\MarbleHit.wav"); break;
        case MenuChangeEvent: soundEffectStream.Initialize(L"Media\\Audio\\MenuChange.wav"); break;
        case MenuSelectedEvent: soundEffectStream.Initialize(L"Media\\Audio\\MenuSelect.wav"); break;
        case CheckpointEvent: soundEffectStream.Initialize(L"Media\\Audio\\Checkpoint.wav"); break;
    }
    m_soundEffects[sound].m_soundEventType = sound;

    uint32 bufferLength = soundEffectStream.GetMaxStreamLengthInBytes();
    m_soundEffects[sound].m_soundEffectBufferData = new byte[bufferLength];
    soundEffectStream.ReadAll(m_soundEffects[sound].m_soundEffectBufferData, bufferLength, &m_soundEffects[sound].m_soundEffectBufferLength);

    XAUDIO2_SEND_DESCRIPTOR descriptors[3];
    descriptors[0].pOutputVoice = m_soundEffectMasteringVoice;
    descriptors[0].Flags = 0;
    descriptors[1].pOutputVoice = m_soundEffectReverbVoiceSmallRoom;
    descriptors[1].Flags = 0;
    descriptors[2].pOutputVoice = m_soundEffectReverbVoiceLargeRoom;
    descriptors[2].Flags = 0;
    XAUDIO2_VOICE_SENDS sends = {0};
    sends.SendCount = 3;
    sends.pSends = descriptors;

    // The rolling sound can have pitch shifting and a low-pass filter.
    if (sound == RollingEvent)
    {
        DX::ThrowIfFailed(
            m_soundEffectEngine->CreateSourceVoice(
                &m_soundEffects[sound].m_soundEffectSourceVoice,
                &(soundEffectStream.GetOutputWaveFormatEx()),
                XAUDIO2_VOICE_USEFILTER,
                2.0f,
                &m_voiceContext,
                &sends)
            );
    }
    else
    {
        DX::ThrowIfFailed(
            m_soundEffectEngine->CreateSourceVoice(
                &m_soundEffects[sound].m_soundEffectSourceVoice,
                &(soundEffectStream.GetOutputWaveFormatEx()),
                0,
                1.0f,
                &m_voiceContext,
                &sends)
            );
    }
    m_soundEffects[sound].m_soundEffectSampleRate = soundEffectStream.GetOutputWaveFormatEx().nSamplesPerSec;

    // Queue in-memory buffer for playback
    ZeroMemory(&m_soundEffects[sound].m_audioBuffer, sizeof(m_soundEffects[sound].m_audioBuffer));

    m_soundEffects[sound].m_audioBuffer.AudioBytes = m_soundEffects[sound].m_soundEffectBufferLength;
    m_soundEffects[sound].m_audioBuffer.pAudioData = m_soundEffects[sound].m_soundEffectBufferData;
    m_soundEffects[sound].m_audioBuffer.pContext = &m_soundEffects[sound];
    m_soundEffects[sound].m_audioBuffer.Flags = XAUDIO2_END_OF_STREAM;
    if (sound == RollingEvent)
    {
        m_soundEffects[sound].m_audioBuffer.LoopCount = XAUDIO2_LOOP_INFINITE;
    }
    else
    {
        m_soundEffects[sound].m_audioBuffer.LoopCount = 0;
    }

    if (sound == FallingEvent || sound == CheckpointEvent)
    {
        m_soundEffects[sound].m_soundEffectSourceVoice->SetVolume(0.4f);
    }

    DX::ThrowIfFailed(
        m_soundEffects[sound].m_soundEffectSourceVoice->SubmitSourceBuffer(&m_soundEffects[sound].m_audioBuffer)
        );
}

bool Audio::HasEngineExperiencedCriticalError ( ) [inline]

Definition at line 144 of file Audio.h.

    {
        return m_engineExperiencedCriticalError;
    }

void Audio::Initialize ( )

Definition at line 22 of file Audio.cpp.

{
}

void Audio::Initialize ( )
void Audio::Initialize ( )
bool Audio::IsSoundEffectStarted ( SoundEvent sound )

Definition at line 593 of file Audio.cpp.

{
    return m_soundEffects[sound].m_soundEffectStarted;
}

IXAudio2* Audio::MusicEngine ( )
IXAudio2 * Audio::MusicEngine ( )

Definition at line 65 of file Audio.cpp.

{
    return m_musicEngine.Get();
}

void Audio::PlaySoundEffect ( SoundEvent sound )

Definition at line 526 of file Audio.cpp.

{
    XAUDIO2_BUFFER buf = {0};
    XAUDIO2_VOICE_STATE state = {0};

    if (m_engineExperiencedCriticalError) {
        // If there's an error, then we'll recreate the engine on the next
        // render pass.
        return;
    }

    SoundEffectData* soundEffect = &m_soundEffects[sound];
    HRESULT hr = soundEffect->m_soundEffectSourceVoice->Start();
    if FAILED(hr)
    {
        m_engineExperiencedCriticalError = true;
        return;
    }

    // For one-off voices, submit a new buffer if there's none queued up,
    // and allow up to two collisions to be queued up.
    if (sound != RollingEvent)
    {
        XAUDIO2_VOICE_STATE state = {0};
        soundEffect->m_soundEffectSourceVoice->GetState(&state, XAUDIO2_VOICE_NOSAMPLESPLAYED);
        if (state.BuffersQueued == 0)
        {
            soundEffect->m_soundEffectSourceVoice->SubmitSourceBuffer(&soundEffect->m_audioBuffer);
        }
        else if (state.BuffersQueued < 2 && sound == CollisionEvent)
        {
            soundEffect->m_soundEffectSourceVoice->SubmitSourceBuffer(&soundEffect->m_audioBuffer);
        }

        // For the menu clicks, we want to stop the voice and replay the click right away.
        // Note that stopping and then flushing could cause a glitch due to the
        // waveform not being at a zero-crossing, but due to the nature of the sound
        // (fast and 'clicky'), we don't mind.
        if (state.BuffersQueued > 0 && sound == MenuChangeEvent)
        {
            soundEffect->m_soundEffectSourceVoice->Stop();
            soundEffect->m_soundEffectSourceVoice->FlushSourceBuffers();
            soundEffect->m_soundEffectSourceVoice->SubmitSourceBuffer(&soundEffect->m_audioBuffer);
            soundEffect->m_soundEffectSourceVoice->Start();
        }
    }

    m_soundEffects[sound].m_soundEffectStarted = true;
}

void Audio::ReleaseResources ( )

Definition at line 392 of file Audio.cpp.

{
    if (m_musicSourceVoice != nullptr)
    {
        m_musicSourceVoice->DestroyVoice();
    }
    if (m_soundEffectReverbVoiceSmallRoom != nullptr)
    {
        m_soundEffectReverbVoiceSmallRoom->DestroyVoice();
    }
    if (m_soundEffectReverbVoiceLargeRoom != nullptr)
    {
        m_soundEffectReverbVoiceLargeRoom->DestroyVoice();
    }
    if (m_musicReverbVoiceSmallRoom != nullptr)
    {
        m_musicReverbVoiceSmallRoom->DestroyVoice();
    }
    if (m_musicReverbVoiceLargeRoom != nullptr)
    {
        m_musicReverbVoiceLargeRoom->DestroyVoice();
    }
    for (int i = 0; i < ARRAYSIZE(m_soundEffects); i++)
    {
        if (m_soundEffects[i].m_soundEffectSourceVoice != nullptr)
        {
            m_soundEffects[i].m_soundEffectSourceVoice->DestroyVoice();
        }
        m_soundEffects[i].m_soundEffectSourceVoice = nullptr;
    }
    if (m_musicMasteringVoice != nullptr)
    {
            m_musicMasteringVoice->DestroyVoice();
    }
    if (m_soundEffectMasteringVoice != nullptr)
    {
        m_soundEffectMasteringVoice->DestroyVoice();
    }

    m_musicSourceVoice = nullptr;
    m_musicMasteringVoice = nullptr;
    m_soundEffectMasteringVoice = nullptr;
    m_soundEffectReverbVoiceSmallRoom = nullptr;
    m_soundEffectReverbVoiceLargeRoom = nullptr;
    m_musicReverbVoiceSmallRoom = nullptr;
    m_musicReverbVoiceLargeRoom = nullptr;
    m_musicEngine = nullptr;
    m_soundEffectEngine = nullptr;
}

void Audio::Render ( )

Definition at line 464 of file Audio.cpp.

{
    if (m_engineExperiencedCriticalError)
    {
        m_engineExperiencedCriticalError = false;
        ReleaseResources();
        Initialize();
        CreateResources();
        Start();
        if (m_engineExperiencedCriticalError)
        {
            return;
        }
    }

    try
    {
        bool streamComplete;
        XAUDIO2_VOICE_STATE state;
        uint32 bufferLength;
        XAUDIO2_BUFFER buf = {0};

        // Use MediaStreamer to stream the buffers.
        m_musicSourceVoice->GetState(&state);
        while (state.BuffersQueued <= MAX_BUFFER_COUNT - 1)
        {
            streamComplete = m_musicStreamer.GetNextBuffer(
                m_audioBuffers[m_currentBuffer],
                STREAMING_BUFFER_SIZE,
                &bufferLength
                );

            if (bufferLength > 0)
            {
                buf.AudioBytes = bufferLength;
                buf.pAudioData = m_audioBuffers[m_currentBuffer];
                buf.Flags = (streamComplete) ? XAUDIO2_END_OF_STREAM : 0;
                buf.pContext = 0;
                DX::ThrowIfFailed(
                    m_musicSourceVoice->SubmitSourceBuffer(&buf)
                    );

                m_currentBuffer++;
                m_currentBuffer %= MAX_BUFFER_COUNT;
            }

            if (streamComplete)
            {
                // Loop the stream.
                m_musicStreamer.Restart();
                break;
            }

            m_musicSourceVoice->GetState(&state);
        }
    }
    catch (...)
    {
        m_engineExperiencedCriticalError = true;
    }
}

void Audio::ResumeAudio ( )

Definition at line 84 of file Audio.cpp.

{
    if (m_audioAvailable)
    {
        DX::ThrowIfFailed(m_musicEngine->StartEngine());
        DX::ThrowIfFailed(m_soundEffectEngine->StartEngine());
    }
}

void Audio::ResumeAudio ( )
void Audio::ResumeAudio ( )
void Audio::SetEngineExperiencedCriticalError ( ) [inline]

Definition at line 139 of file Audio.h.

    {
        m_engineExperiencedCriticalError = true;
    }

void Audio::SetRoomSize | ( | float | roomSize,
 |  | float * | wallDistances
 | ) |  |

Definition at line 96 of file Audio.cpp.

{
    // Maximum "outdoors" is a room size of 1000.0f
    float normalizedRoomSize = roomSize  / 1000.0f;

    float outputMatrix[4] = {0, 0, 0, 0};
    float leftRatio = wallDistances[2] / (wallDistances[2] + wallDistances[3]);
    if ((wallDistances[2] + wallDistances[3]) == 0)
    {
        leftRatio = 0.5f;
    }
    float width = abs((wallDistances[3] + wallDistances[5] + wallDistances[7]) / 3.0f - (wallDistances[2] + wallDistances[4] + wallDistances[6]) / 3.0f);
    float height = abs(wallDistances[1] - wallDistances[0]);
    float widthNormalized = width / max(width, height);
    if (width == 0)
    {
        widthNormalized = 1.0f;
    }

    // As widthNormalized approaches 0, the room is taller than wide.
    // This means that the late-field reverb should be non-localized across both speakers.
    leftRatio -= .5f;
    leftRatio *= widthNormalized;
    leftRatio += .5f;

    // Near-field reverb with the speaker closest to the wall getting more reverb
    outputMatrix[0] = (1.0f - leftRatio)* normalizedRoomSize;
    outputMatrix[1] = 0;
    outputMatrix[2] = 0;
    outputMatrix[3] = leftRatio * normalizedRoomSize;
    DX::ThrowIfFailed(
        m_soundEffectReverbVoiceSmallRoom->SetOutputMatrix(m_soundEffectMasteringVoice, 2, 2, outputMatrix)
        );

    outputMatrix[0] = (1.0f - leftRatio) * normalizedRoomSize;
    outputMatrix[1] = 0;
    outputMatrix[2] = 0;
    outputMatrix[3]= leftRatio * normalizedRoomSize;
    DX::ThrowIfFailed(
        m_musicReverbVoiceSmallRoom->SetOutputMatrix(m_musicMasteringVoice, 2, 2, outputMatrix)
        );

    // Late-field reverb: The wall furthest away gets more of the late-field reverb
    outputMatrix[0] = leftRatio * (1.0f - normalizedRoomSize);
    outputMatrix[1] = 0;
    outputMatrix[2] = 0;
    outputMatrix[3]= (1.0f - leftRatio) * (1.0f - normalizedRoomSize);
    DX::ThrowIfFailed(
        m_soundEffectReverbVoiceLargeRoom->SetOutputMatrix(m_soundEffectMasteringVoice, 2, 2, outputMatrix)
        );

    outputMatrix[0] = leftRatio * (1.0f - normalizedRoomSize);
    outputMatrix[1] = 0;
    outputMatrix[2] = 0;
    outputMatrix[3] = (1.0f - leftRatio) * (1.0f - normalizedRoomSize);

    DX::ThrowIfFailed(
        m_musicReverbVoiceLargeRoom->SetOutputMatrix(m_musicMasteringVoice, 2, 2, outputMatrix)
        );
}

void Audio::SetSoundEffectFilter | ( | SoundEvent | sound,
 |  | float | frequency,
 |  | float | oneOverQ
 | ) |  |

Definition at line 612 of file Audio.cpp.

{
    if (m_soundEffects[sound].m_soundEffectSourceVoice != nullptr) {
        if (oneOverQ <= 0.1f)
        {
            oneOverQ = 0.1f;
        }
        if (oneOverQ > XAUDIO2_MAX_FILTER_ONEOVERQ)
        {
            oneOverQ = XAUDIO2_MAX_FILTER_ONEOVERQ;
        }
        XAUDIO2_FILTER_PARAMETERS params = {LowPassFilter, XAudio2CutoffFrequencyToRadians(frequency, m_soundEffects[sound].m_soundEffectSampleRate), oneOverQ};

        m_soundEffects[sound].m_soundEffectSourceVoice->SetFilterParameters(&params);
    }
}

void Audio::SetSoundEffectPitch | ( | SoundEvent | sound,
 |  | float | pitch
 | ) |  |

Definition at line 605 of file Audio.cpp.

{
    if (m_soundEffects[sound].m_soundEffectSourceVoice != nullptr) {
        m_soundEffects[sound].m_soundEffectSourceVoice->SetFrequencyRatio(pitch);
    }
}

void Audio::SetSoundEffectVolume | ( | SoundEvent | sound,
 |  | float | volume
 | ) |  |

Definition at line 598 of file Audio.cpp.

{
    if (m_soundEffects[sound].m_soundEffectSourceVoice != nullptr) {
        m_soundEffects[sound].m_soundEffectSourceVoice->SetVolume(volume);
    }
}

IXAudio2 * Audio::SoundEffectEngine ( )

Definition at line 70 of file Audio.cpp.

{
    return m_soundEffectEngine.Get();
}

IXAudio2* Audio::SoundEffectEngine ( )
void Audio::Start ( )

Definition at line 442 of file Audio.cpp.

{
    if (m_engineExperiencedCriticalError)
    {
        return;
    }

    HRESULT hr = m_musicSourceVoice->Start(0);

    if SUCCEEDED(hr) {
        m_isAudioStarted = true;
    }
    else
    {
        m_engineExperiencedCriticalError = true;
    }
}

void Audio::StopSoundEffect ( SoundEvent sound )

Definition at line 576 of file Audio.cpp.

{
    if (m_engineExperiencedCriticalError) {
        return;
    }

    HRESULT hr = m_soundEffects[sound].m_soundEffectSourceVoice->Stop();
    if FAILED(hr)
    {
        // If there's an error, then we'll recreate the engine on the next render pass
        m_engineExperiencedCriticalError = true;
        return;
    }

    m_soundEffects[sound].m_soundEffectStarted = false;
}

void Audio::SuspendAudio ( )

Definition at line 75 of file Audio.cpp.

{
    if (m_audioAvailable)
    {
        m_musicEngine->StopEngine();
        m_soundEffectEngine->StopEngine();
    }
}

void Audio::SuspendAudio ( )
void Audio::SuspendAudio ( )

Member Data Documentation

internal Audio::__pad0__

Definition at line 20 of file Audio.h.

bool Audio::m_audioAvailable [private]

Definition at line 30 of file Audio.h.

byte Audio::m_audioBuffers[MAX_BUFFER_COUNT][STREAMING_BUFFER_SIZE] [private]

Definition at line 100 of file Audio.h.

uint32 Audio::m_currentBuffer [private]

Definition at line 102 of file Audio.h.

bool Audio::m_engineExperiencedCriticalError [private]

Definition at line 110 of file Audio.h.

bool Audio::m_isAudioStarted

Definition at line 124 of file Audio.h.

Microsoft::WRL::ComPtr< IXAudio2 > Audio::m_musicEngine [private]

Definition at line 31 of file Audio.h.

IXAudio2* Audio::m_musicEngine [private]

Definition at line 94 of file Audio.h.

AudioEngineCallbacks Audio::m_musicEngineCallback [private]

Definition at line 111 of file Audio.h.

IXAudio2MasteringVoice * Audio::m_musicMasteringVoice [private]

Definition at line 33 of file Audio.h.

IXAudio2SubmixVoice* Audio::m_musicReverbVoiceLargeRoom [private]

Definition at line 109 of file Audio.h.

IXAudio2SubmixVoice* Audio::m_musicReverbVoiceSmallRoom [private]

Definition at line 108 of file Audio.h.

IXAudio2SourceVoice* Audio::m_musicSourceVoice [private]

Definition at line 98 of file Audio.h.

MediaStreamer Audio::m_musicStreamer [private]

Definition at line 101 of file Audio.h.

XAUDIO2FX_REVERB_PARAMETERS Audio::m_reverbParametersLarge [private]

Definition at line 104 of file Audio.h.

XAUDIO2FX_REVERB_PARAMETERS Audio::m_reverbParametersSmall [private]

Definition at line 105 of file Audio.h.

Microsoft::WRL::ComPtr< IXAudio2 > Audio::m_soundEffectEngine [private]

Definition at line 32 of file Audio.h.

IXAudio2* Audio::m_soundEffectEngine [private]

Definition at line 95 of file Audio.h.

AudioEngineCallbacks Audio::m_soundEffectEngineCallback [private]

Definition at line 112 of file Audio.h.

IXAudio2MasteringVoice * Audio::m_soundEffectMasteringVoice [private]

Definition at line 34 of file Audio.h.

IXAudio2SubmixVoice* Audio::m_soundEffectReverbVoiceLargeRoom [private]

Definition at line 107 of file Audio.h.

IXAudio2SubmixVoice* Audio::m_soundEffectReverbVoiceSmallRoom [private]

Definition at line 106 of file Audio.h.

SoundEffectData Audio::m_soundEffects[SOUND_EVENTS] [private]

Definition at line 103 of file Audio.h.

StreamingVoiceContext Audio::m_voiceContext [private]

Definition at line 99 of file Audio.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Audio.h
  • DirectX marble maze game/C++/Audio.h
  • XAML DirectX 3D shooting game/C++/Audio.h
  • DirectX 3D shooting game/C++/Audio.cpp
  • DirectX marble maze game/C++/Audio.cpp
  • XAML DirectX 3D shooting game/C++/Audio.cpp
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AudioController Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

AudioController Class Reference

#include "AudioController.h"

List of all members.

Public Member Functions

void | CreateAudioVoices (_In_ const char16 *deviceEndpointId)
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
void | FetchControllerInput ()
void | OnResuming ()
void | OnSuspending ()
void | ReleaseAudioResources ()
virtual void | Render () override
void | TriggerSoundEffect ()
void | Update (float TimeTotal, float TimeDelta)

Public Attributes

internal | __pad0__: AudioController()

Private Member Functions

~AudioController ()

Private Attributes

bool | m_aButtonWasPressed
IXAudio2 * | m_audioEngine
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_dataTextFormat
bool | m_isControllerConnected
bool | m_isHeadsetConnected
uint64 | m_lastEnumTime
uint64 | m_lastHeadsetCheckTime
IXAudio2MasteringVoice * | m_masteringVoice
SampleOverlay m_sampleOverlay
std::vector< byte > | m_soundEffectBuffer
IXAudio2SourceVoice * | m_sourceVoice
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush
XINPUT_CAPABILITIES | m_xinputCaps
XINPUT_STATE | m_xinputState

Detailed Description

Definition at line 17 of file AudioController.h.

Constructor & Destructor Documentation

AudioController::~AudioController ( ) [private]

Definition at line 49 of file AudioController.cpp.

{
    ReleaseAudioResources();
}

Member Function Documentation

void AudioController::CreateAudioVoices ( _In_ const char16 * deviceEndpointId )

Definition at line 98 of file AudioController.cpp.

{
    uint32 flags = 0;

    DX::ThrowIfFailed(
        XAudio2Create(&m_audioEngine, flags)
        );

    // Load all data for the sound effect into a single in-memory buffer
    MediaStreamer soundStream(ref new Platform::String(SOUND_FILE));
    m_soundEffectBuffer = soundStream.ReadAll();

    // Get the sample rate from the sound
    uint32 streamSampleRate = soundStream.GetOutputWaveFormatEx().nSamplesPerSec;

    // Create mastering voice for the stream, use stream's sample rate
    DX::ThrowIfFailed(
        m_audioEngine->CreateMasteringVoice(
            &m_masteringVoice,
            XAUDIO2_DEFAULT_CHANNELS,
            streamSampleRate,
            0,
            deviceEndpointId
            )
        );

    // Create a source voice for the sound effect using the stream's format
    DX::ThrowIfFailed(
        m_audioEngine->CreateSourceVoice(&m_sourceVoice, &(soundStream.GetOutputWaveFormatEx()))
        );
}

void AudioController::CreateDeviceResources ( ) [override, virtual]

Definition at line 54 of file AudioController.cpp.

{
    DirectXBase::CreateDeviceResources();

    //
    // Create and initialize the default Sample graphics object
    //
    m_sampleOverlay = ref new SampleOverlay();
    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        ref new Platform::String(APPLICATION_TITLE)
        );

    //
    // Setup the local graphics objects
    //
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            FONT_NAME,
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            FONT_SIZE_TEXT,
            FONT_LOCAL,
            &m_dataTextFormat
            )
        );

    DX::ThrowIfFailed(
        m_dataTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );
    DX::ThrowIfFailed(
        m_dataTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::White), &m_textBrush)
        );
}

void AudioController::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 154 of file AudioController.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();
    m_sampleOverlay->UpdateForWindowSizeChange();
}

void AudioController::FetchControllerInput ( )

Definition at line 246 of file AudioController.cpp.

{
    uint64 currentTime = ::GetTickCount64();

    if (!m_isControllerConnected)
    {
        //
        // Ennumerating for XInput devices takes 'time' on the order of milliseconds.
        // Any time a device is not currently known as connected (not yet called XInput, or calling
        // an XInput function after a failure) ennumeration happens.
        // An app should avoid repeatedly calling XInput functions if there are no known devices connected
        // as this can slow down application performance.
        // This sample takes the simple approach of not calling XInput functions after failure
        // until a specified timeout has passed.
        //
        if (currentTime - m_lastEnumTime < XINPUT_ENUM_TIMEOUT_MS)
        {
            return;
        }
        m_lastEnumTime = currentTime;

        // Check for controller connection by trying to get the capabilties
        uint32 capsResult = XInputGetCapabilities(0, XINPUT_FLAG_GAMEPAD, &m_xinputCaps);
        if (capsResult != ERROR_SUCCESS)
        {
            m_lastHeadsetCheckTime = currentTime;
            return;
        }

        // Device is connected
        m_isControllerConnected = true;

        //
        // Start with the assumption that the headset is not connected
        // and recheck the connection right away
        //
        m_isHeadsetConnected = false;
        m_lastHeadsetCheckTime = currentTime - XINPUT_HEADSET_CHECK_TIMEOUT_MS;
    }

    uint32 stateResult = XInputGetState(0, &m_xinputState);
    if (stateResult != ERROR_SUCCESS)
    {
        // Device is no longer connected
        m_isControllerConnected = false;
        m_isHeadsetConnected = false;
        m_lastEnumTime = currentTime;
        m_lastHeadsetCheckTime = currentTime;

        return;
    }

    if ((m_xinputCaps.Flags & XINPUT_CAPS_VOICE_SUPPORTED) == 0)
    {
        //
        // Controller does not support voice
        // We don't keep rechecking caps in this state as they shouldn't change without
        // the device first getting disconnected, then reconnected
        //
        return;
    }

    if (currentTime - m_lastHeadsetCheckTime < XINPUT_HEADSET_CHECK_TIMEOUT_MS)
    {
        // It is not time to test the headset connection
        return;
    }
    m_lastHeadsetCheckTime = currentTime;

    // Find the Audio Endpoint ID
    uint32 renderCount = 0;
    uint32 getEndpointResult = XInputGetAudioDeviceIds(0, nullptr, &renderCount, nullptr, nullptr);

    if ((getEndpointResult != ERROR_SUCCESS) || (renderCount == 0))
    {
        // The headset is not connected even if it was before
        m_isHeadsetConnected = false;
        return;
    }

    if (m_isHeadsetConnected == true)
    {
        // Was connected, still connected
        return;
    }

    // Newly connected, setup audio, get the full render ID
    char16* renderId = new char16[renderCount];
    getEndpointResult = XInputGetAudioDeviceIds(0, renderId, &renderCount, nullptr, nullptr);
    if ((getEndpointResult == ERROR_SUCCESS) && (renderId[0] != '\0'))
    {
        // Headset was there, and now is gone
        m_isHeadsetConnected = true;
        CreateAudioVoices(renderId);
    }
    delete[] renderId;
}

void AudioController::OnResuming ( )

Definition at line 236 of file AudioController.cpp.

{
    if (m_audioEngine != nullptr)
    {
        DX::ThrowIfFailed(
            m_audioEngine->StartEngine()
            );
    }
}

void AudioController::OnSuspending ( )

Definition at line 228 of file AudioController.cpp.

{
    if (m_audioEngine != nullptr)
    {
        m_audioEngine->StopEngine();
    }
}

void AudioController::ReleaseAudioResources ( )

Definition at line 133 of file AudioController.cpp.

{
    if (m_sourceVoice != nullptr)
    {
        m_sourceVoice->DestroyVoice();
        m_sourceVoice = nullptr;
    }

    if (m_masteringVoice != nullptr)
    {
        m_masteringVoice->DestroyVoice();
        m_masteringVoice = nullptr;
    }

    if (m_audioEngine != nullptr)
    {
        m_audioEngine->Release();
        m_audioEngine = nullptr;
    }
}

void AudioController::Render ( ) [override, virtual]

Definition at line 160 of file AudioController.cpp.

{
    // bind the render targets
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // clear both the render target and depth stencil to default values
    const float clearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        clearColor
        );

    m_sampleOverlay->Render();

    D2D1_SIZE_F size = m_d2dContext->GetSize();
    D2D1_RECT_F pos = D2D1::RectF(INFORMATION_START_X, INFORMATION_START_Y, size.width, size.height);

    m_d2dContext->BeginDraw();

    if (!m_isControllerConnected)
    {
        // Display a message when controller is not connected
        m_d2dContext->DrawText(
            MSG_NEED_CONTROLLER,
            static_cast<uint32>(::wcslen(MSG_NEED_CONTROLLER)),
            m_dataTextFormat.Get(),
            pos,
            m_textBrush.Get()
            );
    }
    else if (!m_isHeadsetConnected)
    {
        // Display a message when controller is connected, but not a headset

        m_d2dContext->DrawText(
            MSG_NEED_HEADSET,
            static_cast<uint32>(::wcslen(MSG_NEED_HEADSET)),
            m_dataTextFormat.Get(),
            pos,
            m_textBrush.Get()
            );
    }
    else
    {
        // Display a message when all is connected explaining what to do
        m_d2dContext->DrawText(
            MSG_INSTRUCTIONS,
            static_cast<uint32>(::wcslen(MSG_INSTRUCTIONS)),
            m_dataTextFormat.Get(),
            pos,
            m_textBrush.Get()
            );
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void AudioController::TriggerSoundEffect ( )

Definition at line 363 of file AudioController.cpp.

{
    XAUDIO2_BUFFER buf = {0};
    XAUDIO2_VOICE_STATE state = {0};

    // Interrupt sound effect if currently playing
    DX::ThrowIfFailed(
        m_sourceVoice->Stop()
        );
    DX::ThrowIfFailed(
        m_sourceVoice->FlushSourceBuffers()
        );

    // Queue in-memory buffer for playback and start the voice
    buf.AudioBytes = static_cast<uint32>(m_soundEffectBuffer.size());
    buf.pAudioData = &m_soundEffectBuffer[0];
    buf.Flags = XAUDIO2_END_OF_STREAM;

    DX::ThrowIfFailed(
        m_sourceVoice->SubmitSourceBuffer(&buf)
        );
    DX::ThrowIfFailed(
        m_sourceVoice->Start()
        );
}

void AudioController::Update | ( | float | TimeTotal,
 |  | float | TimeDelta
 | ) |  |

Definition at line 344 of file AudioController.cpp.

{
    FetchControllerInput();

    if (m_isHeadsetConnected)
    {
        if (m_xinputState.Gamepad.wButtons & XINPUT_GAMEPAD_A)
        {
            m_aButtonWasPressed = true;
        }
        else if (m_aButtonWasPressed)
        {
            // Trigger once, only on button release
            m_aButtonWasPressed = false;
            TriggerSoundEffect();
        }
    }
}

Member Data Documentation

internal AudioController::__pad0__

Definition at line 20 of file AudioController.h.

bool AudioController::m_aButtonWasPressed [private]

Definition at line 59 of file AudioController.h.

IXAudio2* AudioController::m_audioEngine [private]

Definition at line 47 of file AudioController.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> AudioController::m_dataTextFormat [private]

Definition at line 62 of file AudioController.h.

bool AudioController::m_isControllerConnected [private]

Definition at line 53 of file AudioController.h.

bool AudioController::m_isHeadsetConnected [private]

Definition at line 54 of file AudioController.h.

uint64 AudioController::m_lastEnumTime [private]

Definition at line 57 of file AudioController.h.

uint64 AudioController::m_lastHeadsetCheckTime [private]

Definition at line 58 of file AudioController.h.

IXAudio2MasteringVoice* AudioController::m_masteringVoice [private]

Definition at line 48 of file AudioController.h.

SampleOverlay AudioController::m_sampleOverlay [private]

Definition at line 44 of file AudioController.h.

std::vector<byte> AudioController::m_soundEffectBuffer [private]

Definition at line 50 of file AudioController.h.

IXAudio2SourceVoice* AudioController::m_sourceVoice [private]

Definition at line 49 of file AudioController.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> AudioController::m_textBrush [private]

Definition at line 63 of file AudioController.h.

XINPUT_CAPABILITIES AudioController::m_xinputCaps [private]

Definition at line 55 of file AudioController.h.

XINPUT_STATE AudioController::m_xinputState [private]

Definition at line 56 of file AudioController.h.

The documentation for this class was generated from the following files:
  • XInput audio controller playback/C++/AudioController.h
  • XInput audio controller playback/C++/AudioController.cpp
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AudioEngineCallbacks Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

AudioEngineCallbacks Class Reference

#include "Audio.h"

List of all members.

Public Member Functions

AudioEngineCallbacks ()
void | Initialize (Audio *audio)
void _stdcall | OnCriticalError (HRESULT Error)
void _stdcall | OnProcessingPassEnd ()
void _stdcall | OnProcessingPassStart ()

Private Attributes

Audio * m_audio

Detailed Description

Definition at line 71 of file Audio.h.

Constructor & Destructor Documentation

AudioEngineCallbacks::AudioEngineCallbacks ( ) [inline]

Definition at line 77 of file Audio.h.

{};

Member Function Documentation

void AudioEngineCallbacks::Initialize ( Audio * audio )

Definition at line 12 of file Audio.cpp.

{
    m_audio = audio;
}

void _stdcall AudioEngineCallbacks::OnCriticalError ( HRESULT Error )

Definition at line 19 of file Audio.cpp.

{
    m_audio->SetEngineExperiencedCriticalError();
}

void _stdcall AudioEngineCallbacks::OnProcessingPassEnd ( ) [inline]

Definition at line 84 of file Audio.h.

{};

void _stdcall AudioEngineCallbacks::OnProcessingPassStart ( ) [inline]

Definition at line 81 of file Audio.h.

{};

Member Data Documentation

Audio* AudioEngineCallbacks::m_audio [private]

Definition at line 74 of file Audio.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/Audio.h
  • DirectX marble maze game/C++/Audio.cpp
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AutoLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

AutoLock Class Reference

#include "CritSec.h"

List of all members.

Public Member Functions

_Acquires_lock_ (m_pCriticalSection) AutoLock(CritSec &crit)
_Acquires_lock_ (m_pCriticalSection) AutoLock(CritSec &crit)
_Acquires_lock_ (m_pCriticalSection) AutoLock(CritSec &crit)
_Releases_lock_ (m_pCriticalSection)~AutoLock()
_Releases_lock_ (m_pCriticalSection)~AutoLock()
_Releases_lock_ (m_pCriticalSection)~AutoLock()

Private Attributes

CritSec * m_pCriticalSection

Detailed Description

Definition at line 45 of file CritSec.h.

Member Function Documentation

AutoLock::_Acquires_lock_ ( m_pCriticalSection ) [inline]

Definition at line 50 of file CritSec.h.

    {
        m_pCriticalSection = &crit;
        m_pCriticalSection->Lock();
    }

AutoLock::_Acquires_lock_ ( m_pCriticalSection ) [inline]

Definition at line 50 of file CritSec.h.

    {
        m_pCriticalSection = &crit;
        m_pCriticalSection->Lock();
    }

AutoLock::_Acquires_lock_ ( m_pCriticalSection ) [inline]

Definition at line 50 of file CritSec.h.

    {
        m_pCriticalSection = &crit;
        m_pCriticalSection->Lock();
    }

AutoLock::_Releases_lock_ ( m_pCriticalSection ) [inline]

Definition at line 57 of file CritSec.h.

    {
      m_pCriticalSection->Unlock();
    }

AutoLock::_Releases_lock_ ( m_pCriticalSection ) [inline]

Definition at line 57 of file CritSec.h.

    {
      m_pCriticalSection->Unlock();
    }

AutoLock::_Releases_lock_ ( m_pCriticalSection ) [inline]

Definition at line 57 of file CritSec.h.

    {
      m_pCriticalSection->Unlock();
    }

Member Data Documentation

CritSec * AutoLock::m_pCriticalSection [private]

Definition at line 48 of file CritSec.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/CritSec.h
  • Media extensions/C++/MediaExtensions/Common/CritSec.h
  • Real-time communication/C++/MediaExtensions/Common/CritSec.h
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AutoThrottle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

AutoThrottle Class Reference

#include "AutoThrottle.h"

List of all members.

Public Member Functions

FrameWorkload | Update (float frameTime)
FrameWorkload | Update (float frameTime)

Public Attributes

internal | __pad0__: AutoThrottle(float targetFrameTime)

Private Attributes

unsigned int | m_missedFrameHistory
float | m_targetFrameTime

Detailed Description

Definition at line 17 of file AutoThrottle.h.

Member Function Documentation

FrameWorkload AutoThrottle::Update ( float frameTime )

Definition at line 28 of file AutoThrottle.cpp.

{
    static const float epsilon = 0.005f; // Compensation for noise in the frameTime value.
    static const unsigned int maskIncrease = 0x0000001F; // Require 5 made frames to increase workload.
    static const unsigned int maskDecrease = 0x00000003; // Require 2 missed frames to decrease workload.

    // Shift history back by one frame.  The LSB represents the most recent frame.
    m_missedFrameHistory <<= 1;

    if (frameTime > m_targetFrameTime - epsilon)
    {
        m_missedFrameHistory |= 1;
    }

    if ((m_missedFrameHistory & maskIncrease) == 0)
    {
        return FrameWorkload::Increase;
    }
    if ((m_missedFrameHistory & maskDecrease) == maskDecrease)
    {
        return FrameWorkload::Decrease;
    }

    return FrameWorkload::Maintain;
}

FrameWorkload AutoThrottle::Update ( float frameTime )

Member Data Documentation

internal AutoThrottle::__pad0__

Definition at line 20 of file AutoThrottle.h.

unsigned int AutoThrottle::m_missedFrameHistory [private]

Definition at line 24 of file AutoThrottle.h.

float AutoThrottle::m_targetFrameTime [private]

Definition at line 25 of file AutoThrottle.h.

The documentation for this class was generated from the following files:
  • Direct3D HLSL fractal generator/C++/AutoThrottle.h
  • Direct3D sprite/C++/AutoThrottle.h
  • Direct3D HLSL fractal generator/C++/AutoThrottle.cpp
  • Direct3D sprite/C++/AutoThrottle.cpp
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Background
  • Background::sealed
Public Member Functions

Background::sealed Class Reference

#include "Background.h"

List of all members.

Public Member Functions

void | InvokeSimpleToast (String^msgReceived)
void | InvokeSimpleToast (String^messageReceived)
virtual void | Run (IBackgroundTaskInstance^taskInstance)
virtual void | Run (IBackgroundTaskInstance^taskInstance)
virtual void | Run (IBackgroundTaskInstance^taskInstance)
virtual void | Run (IBackgroundTaskInstance^taskInstance)
virtual void | Run (IBackgroundTaskInstance^taskInstance)
virtual void | Run (IBackgroundTaskInstance^taskInstance)

Detailed Description

Definition at line 8 of file Background.h.

Member Function Documentation

void Background::sealed::InvokeSimpleToast ( String^ msgReceived )
void Background::sealed::InvokeSimpleToast ( String^ messageReceived )
virtual void Background::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
virtual void Background::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
virtual void Background::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
virtual void Background::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
virtual void Background::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
virtual void Background::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
The documentation for this class was generated from the following files:
  • ControlChannelTrigger StreamSocket/C++/Background/Background.h
  • ControlChannelTrigger XMLHTTPRequest/C++/Background/Background.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BackgroundTask::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BackgroundTask
  • BackgroundTask::sealed
Public Member Functions | Private Member Functions | Private Attributes

BackgroundTask::sealed Class Reference

#include "LocationBackgroundTask.h"

List of all members.

Public Member Functions

LocationBackgroundTask ()
virtual void | Run (Windows::ApplicationModel::Background::IBackgroundTaskInstance^taskInstance)

Private Member Functions

~LocationBackgroundTask ()
void | OnCanceled (Windows::ApplicationModel::Background::IBackgroundTaskInstance^taskInstance, Windows::ApplicationModel::Background::BackgroundTaskCancellationReason reason)

Private Attributes

Concurrency::cancellation_token_source | geopositionTaskTokenSource

Detailed Description

Definition at line 17 of file LocationBackgroundTask.h.

Constructor & Destructor Documentation

BackgroundTask::sealed::~LocationBackgroundTask ( ) [private]

Member Function Documentation

BackgroundTask::sealed::LocationBackgroundTask ( )
void BackgroundTask::sealed::OnCanceled | ( | Windows::ApplicationModel::Background::IBackgroundTaskInstance^ | taskInstance,
 |  | Windows::ApplicationModel::Background::BackgroundTaskCancellationReason | reason |
 | ) |  |  | [private]
virtual void BackgroundTask::sealed::Run ( Windows::ApplicationModel::Background::IBackgroundTaskInstance^ taskInstance ) [virtual]

Member Data Documentation

Concurrency::cancellation_token_source BackgroundTask::sealed::geopositionTaskTokenSource [private]

Definition at line 28 of file LocationBackgroundTask.h.

The documentation for this class was generated from the following file:
  • Geolocation/C++/backgroundtask/LocationBackgroundTask.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BackgroundTasks::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BackgroundTasks
  • BackgroundTasks::sealed
Public Member Functions

BackgroundTasks::sealed Class Reference

#include "BackgroundTask.h"

List of all members.

Public Member Functions

virtual void Run (Windows::ApplicationModel::Background::IBackgroundTaskInstance^taskInstance)

Detailed Description

Definition at line 13 of file BackgroundTask.h.

Member Function Documentation

virtual void BackgroundTasks::sealed::Run ( Windows::ApplicationModel::Background::IBackgroundTaskInstance^ taskInstance ) [virtual]
The documentation for this class was generated from the following file:
  • Raw notifications/C++/SampleBackgroundTask/BackgroundTask.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicCamera Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Private Member Functions | Private Attributes

BasicCamera Class Reference

#include "BasicCamera.h"

List of all members.

Private Member Functions

void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)

Private Attributes

internal | __pad0__: void GetViewMatrix(_Out_ float4x4 *viewMatrix)
float3 m_direction
float3 m_position
float4x4 m_projection
float4x4 m_view

Detailed Description

Definition at line 11 of file BasicCamera.h.

Member Function Documentation

void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]

Definition at line 16 of file BasicCamera.cpp.

{
    *projectionMatrix = m_projection;
}

void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]
void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]
void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]
void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]
void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]
void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]
void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]
void BasicCamera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]
void BasicCamera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]

Definition at line 44 of file BasicCamera.cpp.

{
    float minScale = 1.0f / tan(minimumFieldOfView * PI_F / 360.0f);
    float xScale = 1.0f;
    float yScale = 1.0f;
    if (aspectRatio < 1.0f)
    {
        xScale = minScale;
        yScale = minScale * aspectRatio;
    }
    else
    {
        xScale = minScale / aspectRatio;
        yScale = minScale;
    }
    float zScale = farPlane / (farPlane - nearPlane);
    m_projection = float4x4(
        xScale, 0.0f,   0.0f,    0.0f,
        0.0f,   yScale, 0.0f,    0.0f,
        0.0f,   0.0f,   -zScale, -nearPlane*zScale,
        0.0f,   0.0f,   -1.0f,   0.0f
        );
}

void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]
void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]
void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]
void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]
void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]
void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]
void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]

Definition at line 22 of file BasicCamera.cpp.

{
    m_position = eyePosition;
    m_direction = normalize(lookPosition - eyePosition);
    float3 zAxis = -m_direction;
    float3 xAxis = normalize(cross(up, zAxis));
    float3 yAxis = cross(zAxis, xAxis);
    float xOffset = -dot(xAxis, m_position);
    float yOffset = -dot(yAxis, m_position);
    float zOffset = -dot(zAxis, m_position);
    m_view = float4x4(
        xAxis.x, xAxis.y, xAxis.z, xOffset,
        yAxis.x, yAxis.y, yAxis.z, yOffset,
        zAxis.x, zAxis.y, zAxis.z, zOffset,
        0.0f,    0.0f,    0.0f,    1.0f
        );
}

void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]
void BasicCamera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]

Member Data Documentation

internal BasicCamera::__pad0__ [private]

Definition at line 21 of file BasicCamera.h.

float3 BasicCamera::m_direction [private]

Definition at line 16 of file BasicCamera.h.

float3 BasicCamera::m_position [private]

Definition at line 15 of file BasicCamera.h.

float4x4 BasicCamera::m_projection [private]

Definition at line 18 of file BasicCamera.h.

float4x4 BasicCamera::m_view [private]

Definition at line 17 of file BasicCamera.h.

The documentation for this class was generated from the following files:
  • Direct3D bump mapping/C++/BasicCamera.h
  • Direct3D post-processing effects/C++/BasicCamera.h
  • Direct3D resource loading/C++/BasicCamera.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicCamera.h
  • Direct3D-Direct2D interop/C++/BasicCamera.h
  • DirectX postcard app/C++/BasicCamera.h
  • DirectX touch input/C++/BasicCamera.h
  • DXGI offer and reclaim resources/C++/BasicCamera.h
  • DXGI swap chain rotation/C++/BasicCamera.h
  • Direct3D bump mapping/C++/BasicCamera.cpp
  • Direct3D post-processing effects/C++/BasicCamera.cpp
  • Direct3D resource loading/C++/BasicCamera.cpp
  • Direct3D tutorial/C++/Lesson5.Components/BasicCamera.cpp
  • Direct3D-Direct2D interop/C++/BasicCamera.cpp
  • DirectX postcard app/C++/BasicCamera.cpp
  • DirectX touch input/C++/BasicCamera.cpp
  • DXGI offer and reclaim resources/C++/BasicCamera.cpp
  • DXGI swap chain rotation/C++/BasicCamera.cpp
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicLoader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

BasicLoader Class Reference

#include "BasicLoader.h"

List of all members.

Public Member Functions

void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadMesh (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
concurrency::task< void > | LoadMeshAsync (_In_ Platform::String^filename, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
void | LoadShader (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadShader (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[], _In_ uint32 layoutDescNumElements, _Out_ ID3D11VertexShader **shader, _Out_opt_ ID3D11InputLayout **layout)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY *streamOutDeclaration, _In_ uint32 numEntries, _In_reads_opt_(numStrides) const uint32 *bufferStrides, _In_ uint32 numStrides, _In_ uint32 rasterizedStream, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11PixelShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11ComputeShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11DomainShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11GeometryShader **shader)
concurrency::task< void > | LoadShaderAsync (_In_ Platform::String^filename, _Out_ ID3D11HullShader **shader)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
void | LoadTexture (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)
concurrency::task< void > | LoadTextureAsync (_In_ Platform::String^filename, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView)

Public Attributes

internal | __pad0__: BasicLoader( _In_ ID3D11Device* d3dDevice
internal _In_opt_
IWICImagingFactory2 * 		wicFactory

Private Member Functions

void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateInputLayout (_In_reads_bytes_(bytecodeSize) byte *bytecode, _In_ uint32 bytecodeSize, _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC *layoutDesc, _In_ uint32 layoutDescNumElements, _Out_ ID3D11InputLayout **layout)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateMesh (_In_ byte *meshData, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ uint32 *vertexCount, _Out_opt_ uint32 *indexCount, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
void | CreateTexture (_In_ bool decodeAsDDS, _In_reads_bytes_(dataSize) byte *data, _In_ uint32 dataSize, _Out_opt_ ID3D11Texture2D **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_opt_ Platform::String^debugName)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
Platform::String | GetExtension (_In_ Platform::String^filename)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)
template<class DeviceChildType >
void | SetDebugName (_In_ DeviceChildType *object, _In_ Platform::String^name)

Private Attributes

BasicReaderWriter m_basicReaderWriter
Microsoft::WRL::ComPtr
< ID3D11Device > 		m_d3dDevice
Microsoft::WRL::ComPtr
< IWICImagingFactory2 > 		m_wicFactory

Detailed Description

Definition at line 14 of file BasicLoader.h.

Member Function Documentation

void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]

Definition at line 271 of file BasicLoader.cpp.

{
    if (layoutDesc == nullptr)
    {
        // If no input layout is specified, use the BasicVertex layout.
        const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
        {
            { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "NORMAL",   0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 24, D3D11_INPUT_PER_VERTEX_DATA, 0 },
        };

        DX::ThrowIfFailed(
            m_d3dDevice->CreateInputLayout(
                basicVertexLayoutDesc,
                ARRAYSIZE(basicVertexLayoutDesc),
                bytecode,
                bytecodeSize,
                layout
                )
            );
    }
    else
    {
        DX::ThrowIfFailed(
            m_d3dDevice->CreateInputLayout(
                layoutDesc,
                layoutDescNumElements,
                bytecode,
                bytecodeSize,
                layout
                )
            );
    }
}

void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateInputLayout | ( | _In_reads_bytes_(bytecodeSize) byte * | bytecode,
 |  | _In_ uint32 | bytecodeSize,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC * | layoutDesc,
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11InputLayout ** | layout |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]

Definition at line 313 of file BasicLoader.cpp.

{
    // The first 4 bytes of the BasicMesh format define the number of vertices in the mesh.
    uint32 numVertices = *reinterpret_cast<uint32*>(meshData);

    // The following 4 bytes define the number of indices in the mesh.
    uint32 numIndices = *reinterpret_cast<uint32*>(meshData + sizeof(uint32));

    // The next segment of the BasicMesh format contains the vertices of the mesh.
    BasicVertex* vertices = reinterpret_cast<BasicVertex*>(meshData + sizeof(uint32) * 2);

    // The last segment of the BasicMesh format contains the indices of the mesh.
    uint16* indices = reinterpret_cast<uint16*>(meshData + sizeof(uint32) * 2 + sizeof(BasicVertex) * numVertices);

    // Create the vertex and index buffers with the mesh data.

    D3D11_SUBRESOURCE_DATA vertexBufferData = {0};
    vertexBufferData.pSysMem = vertices;
    vertexBufferData.SysMemPitch = 0;
    vertexBufferData.SysMemSlicePitch = 0;
    CD3D11_BUFFER_DESC vertexBufferDesc(numVertices * sizeof(BasicVertex), D3D11_BIND_VERTEX_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &vertexBufferDesc,
            &vertexBufferData,
            vertexBuffer
            )
        );

    D3D11_SUBRESOURCE_DATA indexBufferData = {0};
    indexBufferData.pSysMem = indices;
    indexBufferData.SysMemPitch = 0;
    indexBufferData.SysMemSlicePitch = 0;
    CD3D11_BUFFER_DESC indexBufferDesc(numIndices * sizeof(uint16), D3D11_BIND_INDEX_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &indexBufferDesc,
            &indexBufferData,
            indexBuffer
            )
        );

    SetDebugName(*vertexBuffer, Platform::String::Concat(debugName, "_VertexBuffer"));
    SetDebugName(*indexBuffer, Platform::String::Concat(debugName, "_IndexBuffer"));

    if (vertexCount != nullptr)
    {
        *vertexCount = numVertices;
    }
    if (indexCount != nullptr)
    {
        *indexCount = numIndices;
    }
}

void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateMesh | ( | _In_ byte * | meshData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]

Definition at line 103 of file BasicLoader.cpp.

{
    ComPtr<ID3D11ShaderResourceView> shaderResourceView;
    ComPtr<ID3D11Texture2D> texture2D;

    if (decodeAsDDS)
    {
        ComPtr<ID3D11Resource> resource;

        if (textureView == nullptr)
        {
            CreateDDSTextureFromMemory(
                m_d3dDevice.Get(),
                data,
                dataSize,
                &resource,
                nullptr
                );
        }
        else
        {
            CreateDDSTextureFromMemory(
                m_d3dDevice.Get(),
                data,
                dataSize,
                &resource,
                &shaderResourceView
                );
        }

        DX::ThrowIfFailed(
            resource.As(&texture2D)
            );
    }
    else
    {
        if (m_wicFactory.Get() == nullptr)
        {
            // A WIC factory object is required in order to load texture
            // assets stored in non-DDS formats.  If BasicLoader was not
            // initialized with one, create one as needed.
            DX::ThrowIfFailed(
                CoCreateInstance(
                    CLSID_WICImagingFactory,
                    nullptr,
                    CLSCTX_INPROC_SERVER,
                    IID_PPV_ARGS(&m_wicFactory)
                    )
                );
        }

        ComPtr<IWICStream> stream;
        DX::ThrowIfFailed(
            m_wicFactory->CreateStream(&stream)
            );

        DX::ThrowIfFailed(
            stream->InitializeFromMemory(
                data,
                dataSize
                )
            );

        ComPtr<IWICBitmapDecoder> bitmapDecoder;
        DX::ThrowIfFailed(
            m_wicFactory->CreateDecoderFromStream(
                stream.Get(),
                nullptr,
                WICDecodeMetadataCacheOnDemand,
                &bitmapDecoder
                )
            );

        ComPtr<IWICBitmapFrameDecode> bitmapFrame;
        DX::ThrowIfFailed(
            bitmapDecoder->GetFrame(0, &bitmapFrame)
            );

        ComPtr<IWICFormatConverter> formatConverter;
        DX::ThrowIfFailed(
            m_wicFactory->CreateFormatConverter(&formatConverter)
            );

        DX::ThrowIfFailed(
            formatConverter->Initialize(
                bitmapFrame.Get(),
                GUID_WICPixelFormat32bppPBGRA,
                WICBitmapDitherTypeNone,
                nullptr,
                0.0,
                WICBitmapPaletteTypeCustom
                )
            );

        uint32 width;
        uint32 height;
        DX::ThrowIfFailed(
            bitmapFrame->GetSize(&width, &height)
            );

        std::unique_ptr<byte[]> bitmapPixels(new byte[width * height * 4]);
        DX::ThrowIfFailed(
            formatConverter->CopyPixels(
                nullptr,
                width * 4,
                width * height * 4,
                bitmapPixels.get()
                )
            );

        D3D11_SUBRESOURCE_DATA initialData;
        ZeroMemory(&initialData, sizeof(initialData));
        initialData.pSysMem = bitmapPixels.get();
        initialData.SysMemPitch = width * 4;
        initialData.SysMemSlicePitch = 0;

        CD3D11_TEXTURE2D_DESC textureDesc(
            DXGI_FORMAT_B8G8R8A8_UNORM,
            width,
            height,
            1,
            1
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateTexture2D(
                &textureDesc,
                &initialData,
                &texture2D
                )
            );

        if (textureView != nullptr)
        {
            CD3D11_SHADER_RESOURCE_VIEW_DESC shaderResourceViewDesc(
                texture2D.Get(),
                D3D11_SRV_DIMENSION_TEXTURE2D
                );

            DX::ThrowIfFailed(
                m_d3dDevice->CreateShaderResourceView(
                    texture2D.Get(),
                    &shaderResourceViewDesc,
                    &shaderResourceView
                    )
                );
        }
    }

    SetDebugName(texture2D.Get(), debugName);

    if (texture != nullptr)
    {
        *texture = texture2D.Detach();
    }
    if (textureView != nullptr)
    {
        *textureView = shaderResourceView.Detach();
    }
}

void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
void BasicLoader::CreateTexture | ( | _In_ bool | decodeAsDDS,
 |  | _In_reads_bytes_(dataSize) byte * | data,
 |  | _In_ uint32 | dataSize,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_opt_ Platform::String^ | debugName |
 | ) |  |  | [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]

Definition at line 79 of file BasicLoader.cpp.

{
    int lastDotIndex = -1;
    for (int i = filename->Length() - 1; i >= 0 && lastDotIndex == -1; i--)
    {
        if (*(filename->Data() + i) == '.')
        {
            lastDotIndex = i;
        }
    }
    if (lastDotIndex != -1)
    {
        std::unique_ptr<wchar_t[]> extension(new wchar_t[filename->Length() - lastDotIndex]);
        for (unsigned int i = 0; i < filename->Length() - lastDotIndex; i++)
        {
            extension[i] = tolower(*(filename->Data() + lastDotIndex + 1 + i));
        }
        return ref new Platform::String(extension.get());
    }
    return "";
}

Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
Platform::String BasicLoader::GetExtension ( _In_ Platform::String^ filename ) [private]
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |

Definition at line 834 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ meshData = m_basicReaderWriter->ReadData(filename);

    CreateMesh(
        meshData->Data,
        vertexBuffer,
        indexBuffer,
        vertexCount,
        indexCount,
        filename
        );
}

void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadMesh | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
task< void > BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |

Definition at line 854 of file BasicLoader.cpp.

{
    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ meshData)
    {
        CreateMesh(
            meshData->Data,
            vertexBuffer,
            indexBuffer,
            vertexCount,
            indexCount,
            filename
            );
    });
}

concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
concurrency::task<void> BasicLoader::LoadMeshAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ uint32 * | vertexCount,
 |  | _Out_opt_ uint32 * | indexCount
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |

Definition at line 412 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);

    DX::ThrowIfFailed(
        m_d3dDevice->CreateVertexShader(
            bytecode->Data,
            bytecode->Length,
            nullptr,
            shader
            )
        );

    SetDebugName(*shader, filename);

    if (layout != nullptr)
    {
        CreateInputLayout(
            bytecode->Data,
            bytecode->Length,
            layoutDesc,
            layoutDescNumElements,
            layout
            );

        SetDebugName(*layout, filename);
    }
}

void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |

Definition at line 603 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);

    DX::ThrowIfFailed(
        m_d3dDevice->CreateGeometryShader(
            bytecode->Data,
            bytecode->Length,
            nullptr,
            shader
            )
        );

    SetDebugName(*shader, filename);
}

void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |

Definition at line 642 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);

    DX::ThrowIfFailed(
        m_d3dDevice->CreateGeometryShaderWithStreamOutput(
            bytecode->Data,
            bytecode->Length,
            streamOutDeclaration,
            numEntries,
            bufferStrides,
            numStrides,
            rasterizedStream,
            nullptr,
            shader
            )
        );

    SetDebugName(*shader, filename);
}

void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |

Definition at line 756 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);

    DX::ThrowIfFailed(
        m_d3dDevice->CreateHullShader(
            bytecode->Data,
            bytecode->Length,
            nullptr,
            shader
            )
        );

    SetDebugName(*shader, filename);
}

void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |

Definition at line 564 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);

    DX::ThrowIfFailed(
        m_d3dDevice->CreateComputeShader(
            bytecode->Data,
            bytecode->Length,
            nullptr,
            shader
            )
        );

    SetDebugName(*shader, filename);
}

void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |

Definition at line 795 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);

    DX::ThrowIfFailed(
        m_d3dDevice->CreateDomainShader(
            bytecode->Data,
            bytecode->Length,
            nullptr,
            shader
            )
        );

    SetDebugName(*shader, filename);
}

void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |

Definition at line 525 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);

    DX::ThrowIfFailed(
        m_d3dDevice->CreatePixelShader(
            bytecode->Data,
            bytecode->Length,
            nullptr,
            shader
            )
        );

    SetDebugName(*shader, filename);
}

void BasicLoader::LoadShader | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
task< void > BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |

Definition at line 814 of file BasicLoader.cpp.

{
    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
    {
        DX::ThrowIfFailed(
            m_d3dDevice->CreateDomainShader(
                bytecode->Data,
                bytecode->Length,
                nullptr,
                shader
                )
            );

        SetDebugName(*shader, filename);
    });
}

concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
task< void > BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |

Definition at line 583 of file BasicLoader.cpp.

{
    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
    {
        DX::ThrowIfFailed(
            m_d3dDevice->CreateComputeShader(
                bytecode->Data,
                bytecode->Length,
                nullptr,
                shader
                )
            );

        SetDebugName(*shader, filename);
    });
}

concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
task< void > BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |

Definition at line 544 of file BasicLoader.cpp.

{
    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
    {
        DX::ThrowIfFailed(
            m_d3dDevice->CreatePixelShader(
                bytecode->Data,
                bytecode->Length,
                nullptr,
                shader
                )
            );

        SetDebugName(*shader, filename);
    });
}

concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
task< void > BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |

Definition at line 775 of file BasicLoader.cpp.

{
    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
    {
        DX::ThrowIfFailed(
            m_d3dDevice->CreateHullShader(
                bytecode->Data,
                bytecode->Length,
                nullptr,
                shader
                )
            );

        SetDebugName(*shader, filename);
    });
}

concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
task< void > BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |

Definition at line 622 of file BasicLoader.cpp.

{
    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
    {
        DX::ThrowIfFailed(
            m_d3dDevice->CreateGeometryShader(
                bytecode->Data,
                bytecode->Length,
                nullptr,
                shader
                )
            );

        SetDebugName(*shader, filename);
    });
}

concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
task< void > BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |

Definition at line 447 of file BasicLoader.cpp.

{
    // This method assumes that the lifetime of input arguments may be shorter
    // than the duration of this task.  In order to ensure accurate results, a
    // copy of all arguments passed by pointer must be made.  The method then
    // ensures that the lifetime of the copied data exceeds that of the task.

    // Create copies of the layoutDesc array as well as the SemanticName strings,
    // both of which are pointers to data whose lifetimes may be shorter than that
    // of this method's task.
    shared_ptr<vector<D3D11_INPUT_ELEMENT_DESC>> layoutDescCopy;
    shared_ptr<vector<string>> layoutDescSemanticNamesCopy;
    if (layoutDesc != nullptr)
    {
        layoutDescCopy.reset(
            new vector<D3D11_INPUT_ELEMENT_DESC>(
                layoutDesc,
                layoutDesc + layoutDescNumElements
                )
            );

        layoutDescSemanticNamesCopy.reset(
            new vector<string>(layoutDescNumElements)
            );

        for (uint32 i = 0; i < layoutDescNumElements; i++)
        {
            layoutDescSemanticNamesCopy->at(i).assign(layoutDesc[i].SemanticName);
        }
    }

    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
    {
        DX::ThrowIfFailed(
            m_d3dDevice->CreateVertexShader(
                bytecode->Data,
                bytecode->Length,
                nullptr,
                shader
                )
            );

        SetDebugName(*shader, filename);

        if (layout != nullptr)
        {
            if (layoutDesc != nullptr)
            {
                // Reassign the SemanticName elements of the layoutDesc array copy to point
                // to the corresponding copied strings. Performing the assignment inside the
                // lambda body ensures that the lambda will take a reference to the shared_ptr
                // that holds the data.  This will guarantee that the data is still valid when
                // CreateInputLayout is called.
                for (uint32 i = 0; i < layoutDescNumElements; i++)
                {
                    layoutDescCopy->at(i).SemanticName = layoutDescSemanticNamesCopy->at(i).c_str();
                }
            }

            CreateInputLayout(
                bytecode->Data,
                bytecode->Length,
                layoutDesc == nullptr ? nullptr : layoutDescCopy->data(),
                layoutDescNumElements,
                layout
                );

            SetDebugName(*layout, filename);
        }
    });
}

concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC | layoutDesc[],
 |  | _In_ uint32 | layoutDescNumElements,
 |  | _Out_ ID3D11VertexShader ** | shader,
 |  | _Out_opt_ ID3D11InputLayout ** | layout
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
task< void > BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |

Definition at line 671 of file BasicLoader.cpp.

{
    // This method assumes that the lifetime of input arguments may be shorter
    // than the duration of this task.  In order to ensure accurate results, a
    // copy of all arguments passed by pointer must be made.  The method then
    // ensures that the lifetime of the copied data exceeds that of the task.

    // Create copies of the streamOutDeclaration array as well as the SemanticName
    // strings, both of which are pointers to data whose lifetimes may be shorter
    // than that of this method's task.
    shared_ptr<vector<D3D11_SO_DECLARATION_ENTRY>> streamOutDeclarationCopy;
    shared_ptr<vector<string>> streamOutDeclarationSemanticNamesCopy;
    if (streamOutDeclaration != nullptr)
    {
        streamOutDeclarationCopy.reset(
            new vector<D3D11_SO_DECLARATION_ENTRY>(
                streamOutDeclaration,
                streamOutDeclaration + numEntries
                )
            );

        streamOutDeclarationSemanticNamesCopy.reset(
            new vector<string>(numEntries)
            );

        for (uint32 i = 0; i < numEntries; i++)
        {
            streamOutDeclarationSemanticNamesCopy->at(i).assign(streamOutDeclaration[i].SemanticName);
        }
    }

    // Create a copy of the bufferStrides array, which is a pointer to data
    // whose lifetime may be shorter than that of this method's task.
    shared_ptr<vector<uint32>> bufferStridesCopy;
    if (bufferStrides != nullptr)
    {
        bufferStridesCopy.reset(
            new vector<uint32>(
                bufferStrides,
                bufferStrides + numStrides
                )
            );
    }

    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
    {
        if (streamOutDeclaration != nullptr)
        {
            // Reassign the SemanticName elements of the streamOutDeclaration array copy to
            // point to the corresponding copied strings. Performing the assignment inside the
            // lambda body ensures that the lambda will take a reference to the shared_ptr
            // that holds the data.  This will guarantee that the data is still valid when
            // CreateGeometryShaderWithStreamOutput is called.
            for (uint32 i = 0; i < numEntries; i++)
            {
                streamOutDeclarationCopy->at(i).SemanticName = streamOutDeclarationSemanticNamesCopy->at(i).c_str();
            }
        }

        DX::ThrowIfFailed(
            m_d3dDevice->CreateGeometryShaderWithStreamOutput(
                bytecode->Data,
                bytecode->Length,
                streamOutDeclaration == nullptr ? nullptr : streamOutDeclarationCopy->data(),
                numEntries,
                bufferStrides == nullptr ? nullptr : bufferStridesCopy->data(),
                numStrides,
                rasterizedStream,
                nullptr,
                shader
                )
            );

        SetDebugName(*shader, filename);
    });
}

concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11DomainShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11HullShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11PixelShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY * | streamOutDeclaration,
 |  | _In_ uint32 | numEntries,
 |  | _In_reads_opt_(numStrides) const uint32 * | bufferStrides,
 |  | _In_ uint32 | numStrides,
 |  | _In_ uint32 | rasterizedStream,
 |  | _Out_ ID3D11GeometryShader ** | shader
 | ) |  |
concurrency::task<void> BasicLoader::LoadShaderAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_ ID3D11ComputeShader ** | shader
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |

Definition at line 375 of file BasicLoader.cpp.

{
    Platform::Array<byte>^ textureData = m_basicReaderWriter->ReadData(filename);

    CreateTexture(
        GetExtension(filename) == "dds",
        textureData->Data,
        textureData->Length,
        texture,
        textureView,
        filename
        );
}

void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
void BasicLoader::LoadTexture | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
task< void > BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |

Definition at line 393 of file BasicLoader.cpp.

{
    return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ textureData)
    {
        CreateTexture(
            GetExtension(filename) == "dds",
            textureData->Data,
            textureData->Length,
            texture,
            textureView,
            filename
            );
    });
}

concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
concurrency::task<void> BasicLoader::LoadTextureAsync | ( | _In_ Platform::String^ | filename,
 |  | _Out_opt_ ID3D11Texture2D ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView
 | ) |  |
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]
template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]

Definition at line 35 of file BasicLoader.cpp.

{
#if defined(_DEBUG)
    // Only assign debug names in debug builds.

    char nameString[1024];
    int nameStringLength = WideCharToMultiByte(
        CP_ACP,
        0,
        name->Data(),
        -1,
        nameString,
        1024,
        nullptr,
        nullptr
        );

    if (nameStringLength == 0)
    {
        char defaultNameString[] = "BasicLoaderObject";
        DX::ThrowIfFailed(
            object->SetPrivateData(
                WKPDID_D3DDebugObjectName,
                sizeof(defaultNameString) - 1,
                defaultNameString
                )
            );
    }
    else
    {
        DX::ThrowIfFailed(
            object->SetPrivateData(
                WKPDID_D3DDebugObjectName,
                nameStringLength - 1,
                nameString
                )
            );
    }
#endif
}

template<class DeviceChildType >
void BasicLoader::SetDebugName | ( | _In_ DeviceChildType * | object,
 |  | _In_ Platform::String^ | name |
 | ) |  |  | [inline, private]

Member Data Documentation

internal BasicLoader::__pad0__

Definition at line 18 of file BasicLoader.h.

BasicReaderWriter BasicLoader::m_basicReaderWriter [private]

Definition at line 139 of file BasicLoader.h.

Microsoft::WRL::ComPtr< ID3D11Device > BasicLoader::m_d3dDevice [private]

Definition at line 137 of file BasicLoader.h.

Microsoft::WRL::ComPtr< IWICImagingFactory2 > BasicLoader::m_wicFactory [private]

Definition at line 138 of file BasicLoader.h.

internal _In_opt_ IWICImagingFactory2 * BasicLoader::wicFactory
Initial value:
 nullptr
        )

Definition at line 19 of file BasicLoader.h.

The documentation for this class was generated from the following files:
  • Direct3D bump mapping/C++/BasicLoader.h
  • Direct3D HLSL fractal generator/C++/BasicLoader.h
  • Direct3D post-processing effects/C++/BasicLoader.h
  • Direct3D resource loading/C++/BasicLoader.h
  • Direct3D sprite/C++/BasicLoader.h
  • Direct3D stereoscopic 3D/C++/BasicLoader.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicLoader.h
  • Direct3D-Direct2D interop/C++/BasicLoader.h
  • DirectX 3D shooting game/C++/BasicLoader.h
  • DirectX marble maze game/C++/BasicLoader.h
  • DirectX postcard app/C++/BasicLoader.h
  • DirectX touch input/C++/BasicLoader.h
  • DXGI offer and reclaim resources/C++/BasicLoader.h
  • DXGI swap chain rotation/C++/BasicLoader.h
  • XAML DirectX 3D shooting game/C++/BasicLoader.h
  • Direct3D bump mapping/C++/BasicLoader.cpp
  • Direct3D HLSL fractal generator/C++/BasicLoader.cpp
  • Direct3D post-processing effects/C++/BasicLoader.cpp
  • Direct3D resource loading/C++/BasicLoader.cpp
  • Direct3D sprite/C++/BasicLoader.cpp
  • Direct3D stereoscopic 3D/C++/BasicLoader.cpp
  • Direct3D tutorial/C++/Lesson5.Components/BasicLoader.cpp
  • Direct3D-Direct2D interop/C++/BasicLoader.cpp
  • DirectX 3D shooting game/C++/BasicLoader.cpp
  • DirectX marble maze game/C++/BasicLoader.cpp
  • DirectX postcard app/C++/BasicLoader.cpp
  • DirectX touch input/C++/BasicLoader.cpp
  • DXGI offer and reclaim resources/C++/BasicLoader.cpp
  • DXGI swap chain rotation/C++/BasicLoader.cpp
  • XAML DirectX 3D shooting game/C++/BasicLoader.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicReaderWriter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Private Member Functions | Private Attributes

BasicReaderWriter Class Reference

#include "BasicReaderWriter.h"

List of all members.

Private Member Functions

BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
BasicReaderWriter (_In_ Windows::Storage::StorageFolder^folder)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
Platform::Array< byte > | ReadData (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
concurrency::task
< Platform::Array< byte >^> 		ReadDataAsync (_In_ Platform::String^filename)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
uint32 | WriteData (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)
concurrency::task< void > | WriteDataAsync (_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData)

Private Attributes

internal | __pad0__: BasicReaderWriter()
Windows::Storage::StorageFolder | m_location
Platform::String | m_locationPath

Detailed Description

Definition at line 14 of file BasicReaderWriter.h.

Constructor & Destructor Documentation

BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]

Definition at line 25 of file BasicReaderWriter.cpp.

{
    m_location = folder;
    Platform::String^ path = m_location->Path;
    if (path->Length() == 0)
    {
        // Applications are not permitted to access certain
        // folders, such as the Documents folder, using this
        // code path.  In such cases, the Path property for
        // the folder will be an empty string.
        throw ref new Platform::FailureException();
    }
    m_locationPath = Platform::String::Concat(path, "\\");
}

BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]
BasicReaderWriter::BasicReaderWriter ( _In_ Windows::Storage::StorageFolder^ folder ) [private]

Member Function Documentation

Platform::Array< byte > BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]

Definition at line 42 of file BasicReaderWriter.cpp.

{
    CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
    extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
    extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
    extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
    extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
    extendedParams.lpSecurityAttributes = nullptr;
    extendedParams.hTemplateFile = nullptr;

    Wrappers::FileHandle file(
        CreateFile2(
            Platform::String::Concat(m_locationPath, filename)->Data(),
            GENERIC_READ,
            FILE_SHARE_READ,
            OPEN_EXISTING,
            &extendedParams
            )
        );
    if (file.Get() == INVALID_HANDLE_VALUE)
    {
        throw ref new Platform::FailureException();
    }

    FILE_STANDARD_INFO fileInfo = {0};
    if (!GetFileInformationByHandleEx(
        file.Get(),
        FileStandardInfo,
        &fileInfo,
        sizeof(fileInfo)
        ))
    {
        throw ref new Platform::FailureException();
    }

    if (fileInfo.EndOfFile.HighPart != 0)
    {
        throw ref new Platform::OutOfMemoryException();
    }

    Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);

    if (!ReadFile(
        file.Get(),
        fileData->Data,
        fileData->Length,
        nullptr,
        nullptr
        ))
    {
        throw ref new Platform::FailureException();
    }

    return fileData;
}

Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
Platform::Array<byte> BasicReaderWriter::ReadData ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
task< Platform::Array< byte >^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]

Definition at line 100 of file BasicReaderWriter.cpp.

{
    return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
    {
        return FileIO::ReadBufferAsync(file);
    }).then([=](IBuffer^ buffer)
    {
        auto fileData = ref new Platform::Array<byte>(buffer->Length);
        DataReader::FromBuffer(buffer)->ReadBytes(fileData);
        return fileData;
    });
}

concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
concurrency::task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync ( _In_ Platform::String^ filename ) [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]

Definition at line 115 of file BasicReaderWriter.cpp.

{
    CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
    extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
    extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
    extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
    extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
    extendedParams.lpSecurityAttributes = nullptr;
    extendedParams.hTemplateFile = nullptr;

    Wrappers::FileHandle file(
        CreateFile2(
            Platform::String::Concat(m_locationPath, filename)->Data(),
            GENERIC_WRITE,
            0,
            CREATE_ALWAYS,
            &extendedParams
            )
        );
    if (file.Get() == INVALID_HANDLE_VALUE)
    {
        throw ref new Platform::FailureException();
    }

    DWORD numBytesWritten;
    if (
        !WriteFile(
            file.Get(),
            fileData->Data,
            fileData->Length,
            &numBytesWritten,
            nullptr
            ) ||
        numBytesWritten != fileData->Length
        )
    {
        throw ref new Platform::FailureException();
    }

    return numBytesWritten;
}

uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
uint32 BasicReaderWriter::WriteData | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
task< void > BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]

Definition at line 160 of file BasicReaderWriter.cpp.

{
    return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
    {
        FileIO::WriteBytesAsync(file, fileData);
    });
}

concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]
concurrency::task<void> BasicReaderWriter::WriteDataAsync | ( | _In_ Platform::String^ | filename,
 |  | _In_ const Platform::Array< byte >^ | fileData |
 | ) |  |  | [private]

Member Data Documentation

internal BasicReaderWriter::__pad0__ [private]

Definition at line 21 of file BasicReaderWriter.h.

Windows::Storage::StorageFolder BasicReaderWriter::m_location [private]

Definition at line 17 of file BasicReaderWriter.h.

Platform::String BasicReaderWriter::m_locationPath [private]

Definition at line 18 of file BasicReaderWriter.h.

The documentation for this class was generated from the following files:
  • Direct3D bump mapping/C++/BasicReaderWriter.h
  • Direct3D HLSL fractal generator/C++/BasicReaderWriter.h
  • Direct3D post-processing effects/C++/BasicReaderWriter.h
  • Direct3D resource loading/C++/BasicReaderWriter.h
  • Direct3D sprite/C++/BasicReaderWriter.h
  • Direct3D stereoscopic 3D/C++/BasicReaderWriter.h
  • Direct3D tutorial/C++/Lesson2.Triangles/BasicReaderWriter.h
  • Direct3D tutorial/C++/Lesson3.Cubes/BasicReaderWriter.h
  • Direct3D tutorial/C++/Lesson4.Textures/BasicReaderWriter.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicReaderWriter.h
  • Direct3D-Direct2D interop/C++/BasicReaderWriter.h
  • DirectX 3D shooting game/C++/BasicReaderWriter.h
  • DirectX marble maze game/C++/BasicReaderWriter.h
  • DirectX postcard app/C++/BasicReaderWriter.h
  • DirectX touch input/C++/BasicReaderWriter.h
  • DXGI offer and reclaim resources/C++/BasicReaderWriter.h
  • DXGI swap chain rotation/C++/BasicReaderWriter.h
  • XAML DirectX 3D shooting game/C++/BasicReaderWriter.h
  • Direct3D bump mapping/C++/BasicReaderWriter.cpp
  • Direct3D HLSL fractal generator/C++/BasicReaderWriter.cpp
  • Direct3D post-processing effects/C++/BasicReaderWriter.cpp
  • Direct3D resource loading/C++/BasicReaderWriter.cpp
  • Direct3D sprite/C++/BasicReaderWriter.cpp
  • Direct3D stereoscopic 3D/C++/BasicReaderWriter.cpp
  • Direct3D tutorial/C++/Lesson2.Triangles/BasicReaderWriter.cpp
  • Direct3D tutorial/C++/Lesson3.Cubes/BasicReaderWriter.cpp
  • Direct3D tutorial/C++/Lesson4.Textures/BasicReaderWriter.cpp
  • Direct3D tutorial/C++/Lesson5.Components/BasicReaderWriter.cpp
  • Direct3D-Direct2D interop/C++/BasicReaderWriter.cpp
  • DirectX 3D shooting game/C++/BasicReaderWriter.cpp
  • DirectX marble maze game/C++/BasicReaderWriter.cpp
  • DirectX postcard app/C++/BasicReaderWriter.cpp
  • DirectX touch input/C++/BasicReaderWriter.cpp
  • DXGI offer and reclaim resources/C++/BasicReaderWriter.cpp
  • DXGI swap chain rotation/C++/BasicReaderWriter.cpp
  • XAML DirectX 3D shooting game/C++/BasicReaderWriter.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicShapes Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

BasicShapes Class Reference

#include "BasicShapes.h"

List of all members.

Public Member Functions

void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateBox (float3 radii, _Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateCube (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateReferenceAxis (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)
void | CreateTangentSphere (_Out_ ID3D11Buffer **vertexBuffer, _Out_ ID3D11Buffer **indexBuffer, _Out_opt_ unsigned int *vertexCount, _Out_opt_ unsigned int *indexCount)

Public Attributes

internal | __pad0__: BasicShapes(ID3D11Device *d3dDevice)

Private Member Functions

void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateIndexBuffer (_In_ unsigned int numIndices, _In_ unsigned short *indexData, _Out_ ID3D11Buffer **indexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateTangentVertexBuffer (_In_ unsigned int numVertices, _In_ TangentVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)
void | CreateVertexBuffer (_In_ unsigned int numVertices, _In_ BasicVertex *vertexData, _Out_ ID3D11Buffer **vertexBuffer)

Private Attributes

Microsoft::WRL::ComPtr
< ID3D11Device > 		m_d3dDevice

Detailed Description

Definition at line 31 of file BasicShapes.h.

Member Function Documentation

void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |

Definition at line 202 of file BasicShapes.cpp.

{
    BasicVertex boxVertices[] =
    {
        // FLOOR
        {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
        {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
        {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
        {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
        // WALL
        {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
        {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
        {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
        {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
        // WALL
        {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
        {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
        {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
        {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
        // WALL
        {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
        {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
        {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
        {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
        // WALL
        {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
        {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
        {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
        {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
        // CEILING
        {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
        {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
        {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
        {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
    };

    unsigned short boxIndices[] =
    {
        0, 2, 1,
        1, 2, 3,

        4, 6, 5,
        5, 6, 7,

        8, 10, 9,
        9, 10, 11,

        12, 14, 13,
        13, 14, 15,

        16, 18, 17,
        17, 18, 19,

        20, 22, 21,
        21, 22, 23,
    };

    CreateVertexBuffer(
        ARRAYSIZE(boxVertices),
        boxVertices,
        vertexBuffer
        );
    if (vertexCount != nullptr)
    {
        *vertexCount = ARRAYSIZE(boxVertices);
    }

    CreateIndexBuffer(
        ARRAYSIZE(boxIndices),
        boxIndices,
        indexBuffer
        );
    if (indexCount != nullptr)
    {
        *indexCount = ARRAYSIZE(boxIndices);
    }
}

void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateBox | ( | float3 | radii,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |

Definition at line 120 of file BasicShapes.cpp.

{
    BasicVertex cubeVertices[] =
    {
        { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
        { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
        { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
        { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },

        { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
        { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
        { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
        { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },

        { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
        { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
        { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
        { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },

        { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
        { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
        { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
        { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },

        { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
        { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
        { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
        { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },

        { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
        { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
        { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
        { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
    };

    unsigned short cubeIndices[] =
    {
        0, 1, 2,
        0, 2, 3,

        4, 5, 6,
        4, 6, 7,

        8, 9, 10,
        8, 10, 11,

        12, 13, 14,
        12, 14, 15,

        16, 17, 18,
        16, 18, 19,

        20, 21, 22,
        20, 22, 23
    };

    CreateVertexBuffer(
        ARRAYSIZE(cubeVertices),
        cubeVertices,
        vertexBuffer
        );
    if (vertexCount != nullptr)
    {
        *vertexCount = ARRAYSIZE(cubeVertices);
    }

    CreateIndexBuffer(
        ARRAYSIZE(cubeIndices),
        cubeIndices,
        indexBuffer
        );
    if (indexCount != nullptr)
    {
        *indexCount = ARRAYSIZE(cubeIndices);
    }
}

void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateCube | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]

Definition at line 53 of file BasicShapes.cpp.

{
    *indexBuffer = nullptr;
    Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;

    D3D11_BUFFER_DESC IndexBufferDesc;
    IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
    IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
    IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
    IndexBufferDesc.CPUAccessFlags = 0;
    IndexBufferDesc.MiscFlags = 0;
    IndexBufferDesc.StructureByteStride = 0;

    D3D11_SUBRESOURCE_DATA IndexBufferData;
    IndexBufferData.pSysMem = indexData;
    IndexBufferData.SysMemPitch = 0;
    IndexBufferData.SysMemSlicePitch = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &IndexBufferDesc,
            &IndexBufferData,
            &indexBufferInternal
            )
        );

    *indexBuffer = indexBufferInternal.Detach();
}

void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateIndexBuffer | ( | _In_ unsigned int | numIndices,
 |  | _In_ unsigned short * | indexData,
 |  | _Out_ ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |

Definition at line 439 of file BasicShapes.cpp.

{
    BasicVertex axisVertices[] =
    {
        { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
        { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
        { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
        { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
        { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
        { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
        { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
        { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
        { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
        { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
        { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
        { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
        { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
        { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
        { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
        { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
        { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
        { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
        { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
        { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
        { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
        { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
        { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
        { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
        { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
        { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
        { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
        { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
        { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
        { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
        { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
    };

    unsigned short axisIndices[] =
    {
         0,  2,  1,
         3,  5,  4,
         6,  8,  7,
         9, 11, 10,
        12, 14, 13,
        12, 15, 14,
        16, 18, 17,
        19, 21, 20,
        22, 24, 23,
        25, 27, 26,
        28, 30, 29,
        28, 31, 30,
        32, 34, 33,
        35, 37, 36,
        38, 40, 39,
        41, 43, 42,
        44, 46, 45,
        44, 47, 46,
        48, 50, 49,
        51, 53, 52,
        54, 56, 55,
        57, 59, 58,
        60, 62, 61,
        60, 63, 62,
        64, 66, 65,
        67, 69, 68,
        70, 72, 71,
        73, 75, 74,
        76, 78, 77,
        76, 79, 78,
        80, 82, 81,
        83, 85, 84,
        86, 88, 87,
        89, 91, 90,
        92, 94, 93,
        92, 95, 94,
    };

    CreateVertexBuffer(
        ARRAYSIZE(axisVertices),
        axisVertices,
        vertexBuffer
        );
    if (vertexCount != nullptr)
    {
        *vertexCount = ARRAYSIZE(axisVertices);
    }

    CreateIndexBuffer(
        ARRAYSIZE(axisIndices),
        axisIndices,
        indexBuffer
        );
    if (indexCount != nullptr)
    {
        *indexCount = ARRAYSIZE(axisIndices);
    }
}

void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateReferenceAxis | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |

Definition at line 286 of file BasicShapes.cpp.

{
    const int numSegments = 64;
    const int numSlices = numSegments / 2;

    const int numVertices = (numSlices + 1) * (numSegments + 1);
    std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);

    for (int slice = 0; slice <= numSlices; slice++)
    {
        float v = (float)slice/(float)numSlices;
        float inclination = v * PI_F;
        float y = cos(inclination);
        float r = sin(inclination);
        for (int segment = 0; segment <= numSegments; segment++)
        {
            float u = (float)segment/(float)numSegments;
            float azimuth = u * PI_F * 2.0f;
            int index = slice * (numSegments+1) + segment;
            sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
            sphereVertices[index].norm = sphereVertices[index].pos;
            sphereVertices[index].tex = float2(u, v);
        }
    }

    const int numIndices = numSlices * (numSegments-2) * 6;
    std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);

    unsigned int index = 0;
    for (int slice = 0; slice < numSlices; slice++)
    {
        unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
        unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
        for (int segment = 0; segment < numSegments; segment++)
        {
            if (slice > 0)
            {
                sphereIndices[index++] = sliceBase0 + segment;
                sphereIndices[index++] = sliceBase0 + segment + 1;
                sphereIndices[index++] = sliceBase1 + segment + 1;
            }
            if (slice < numSlices-1)
            {
                sphereIndices[index++] = sliceBase0 + segment;
                sphereIndices[index++] = sliceBase1 + segment + 1;
                sphereIndices[index++] = sliceBase1 + segment;
            }
        }
    }

    CreateVertexBuffer(
        numVertices,
        sphereVertices.get(),
        vertexBuffer
        );
    if (vertexCount != nullptr)
    {
        *vertexCount = numVertices;
    }

    CreateIndexBuffer(
        numIndices,
        sphereIndices.get(),
        indexBuffer
        );
    if (indexCount != nullptr)
    {
        *indexCount = numIndices;
    }
}

void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |

Definition at line 361 of file BasicShapes.cpp.

{
    const int numSegments = 64;
    const int numSlices = numSegments / 2;

    const int numVertices = (numSlices + 1) * (numSegments + 1);
    std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);

    for (int slice = 0; slice <= numSlices; slice++)
    {
        float v = (float)slice/(float)numSlices;
        float inclination = v * PI_F;
        float y = cos(inclination);
        float r = sin(inclination);
        for (int segment = 0; segment <= numSegments; segment++)
        {
            float u = (float)segment/(float)numSegments;
            float azimuth = u * PI_F * 2.0f;
            int index = slice * (numSegments+1) + segment;
            sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
            sphereVertices[index].tex = float2(u, v);
            sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
            sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));

        }
    }

    const int numIndices = numSlices * (numSegments-2) * 6;
    std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);

    unsigned int index = 0;
    for (int slice = 0; slice < numSlices; slice++)
    {
        unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
        unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
        for (int segment = 0; segment < numSegments; segment++)
        {
            if (slice > 0)
            {
                sphereIndices[index++] = sliceBase0 + segment;
                sphereIndices[index++] = sliceBase0 + segment + 1;
                sphereIndices[index++] = sliceBase1 + segment + 1;
            }
            if (slice < numSlices-1)
            {
                sphereIndices[index++] = sliceBase0 + segment;
                sphereIndices[index++] = sliceBase1 + segment + 1;
                sphereIndices[index++] = sliceBase1 + segment;
            }
        }
    }

    CreateTangentVertexBuffer(
        numVertices,
        sphereVertices.get(),
        vertexBuffer
        );
    if (vertexCount != nullptr)
    {
        *vertexCount = numVertices;
    }

    CreateIndexBuffer(
        numIndices,
        sphereIndices.get(),
        indexBuffer
        );
    if (indexCount != nullptr)
    {
        *indexCount = numIndices;
    }
}

void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentSphere | ( | _Out_ ID3D11Buffer ** | vertexBuffer,
 |  | _Out_ ID3D11Buffer ** | indexBuffer,
 |  | _Out_opt_ unsigned int * | vertexCount,
 |  | _Out_opt_ unsigned int * | indexCount
 | ) |  |
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]

Definition at line 86 of file BasicShapes.cpp.

{
    *vertexBuffer = nullptr;
    Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;

    D3D11_BUFFER_DESC VertexBufferDesc;
    VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
    VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
    VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
    VertexBufferDesc.CPUAccessFlags = 0;
    VertexBufferDesc.MiscFlags = 0;
    VertexBufferDesc.StructureByteStride = 0;

    D3D11_SUBRESOURCE_DATA VertexBufferData;
    VertexBufferData.pSysMem = vertexData;
    VertexBufferData.SysMemPitch = 0;
    VertexBufferData.SysMemSlicePitch = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &VertexBufferDesc,
            &VertexBufferData,
            &vertexBufferInternal
            )
        );

    *vertexBuffer = vertexBufferInternal.Detach();
}

void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateTangentVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ TangentVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]

Definition at line 19 of file BasicShapes.cpp.

{
    *vertexBuffer = nullptr;
    Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;

    D3D11_BUFFER_DESC VertexBufferDesc;
    VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
    VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
    VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
    VertexBufferDesc.CPUAccessFlags = 0;
    VertexBufferDesc.MiscFlags = 0;
    VertexBufferDesc.StructureByteStride = 0;

    D3D11_SUBRESOURCE_DATA VertexBufferData;
    VertexBufferData.pSysMem = vertexData;
    VertexBufferData.SysMemPitch = 0;
    VertexBufferData.SysMemSlicePitch = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &VertexBufferDesc,
            &VertexBufferData,
            &vertexBufferInternal
            )
        );

    *vertexBuffer = vertexBufferInternal.Detach();
}

void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]
void BasicShapes::CreateVertexBuffer | ( | _In_ unsigned int | numVertices,
 |  | _In_ BasicVertex * | vertexData,
 |  | _Out_ ID3D11Buffer ** | vertexBuffer |
 | ) |  |  | [private]

Member Data Documentation

internal BasicShapes::__pad0__

Definition at line 34 of file BasicShapes.h.

Microsoft::WRL::ComPtr< ID3D11Device > BasicShapes::m_d3dDevice [private]

Definition at line 68 of file BasicShapes.h.

The documentation for this class was generated from the following files:
  • Direct3D bump mapping/C++/BasicShapes.h
  • Direct3D HLSL fractal generator/C++/BasicShapes.h
  • Direct3D post-processing effects/C++/BasicShapes.h
  • Direct3D resource loading/C++/BasicShapes.h
  • Direct3D sprite/C++/BasicShapes.h
  • Direct3D stereoscopic 3D/C++/BasicShapes.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicShapes.h
  • Direct3D-Direct2D interop/C++/BasicShapes.h
  • DirectX 3D shooting game/C++/BasicShapes.h
  • DirectX marble maze game/C++/BasicShapes.h
  • DirectX postcard app/C++/BasicShapes.h
  • DirectX touch input/C++/BasicShapes.h
  • DXGI offer and reclaim resources/C++/BasicShapes.h
  • DXGI swap chain rotation/C++/BasicShapes.h
  • XAML DirectX 3D shooting game/C++/BasicShapes.h
  • Direct3D bump mapping/C++/BasicShapes.cpp
  • Direct3D HLSL fractal generator/C++/BasicShapes.cpp
  • Direct3D post-processing effects/C++/BasicShapes.cpp
  • Direct3D resource loading/C++/BasicShapes.cpp
  • Direct3D stereoscopic 3D/C++/BasicShapes.cpp
  • Direct3D tutorial/C++/Lesson5.Components/BasicShapes.cpp
  • Direct3D-Direct2D interop/C++/BasicShapes.cpp
  • DirectX marble maze game/C++/BasicShapes.cpp
  • DirectX postcard app/C++/BasicShapes.cpp
  • DirectX touch input/C++/BasicShapes.cpp
  • DXGI offer and reclaim resources/C++/BasicShapes.cpp
  • DXGI swap chain rotation/C++/BasicShapes.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSound Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

BasicSound Class Reference

#include "BasicSound.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
void | OnPointerPressed (_In_ Windows::UI::Input::PointerPoint^p)
void | OnResuming ()
void | OnSuspending ()
virtual void | Render () override

Public Attributes

internal | __pad0__: BasicSound()

Private Member Functions

~BasicSound ()

Private Attributes

Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_dataTextFormat
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_greenBrush
float | m_rectangleHeight
float | m_rectangleWidth
SampleOverlay m_sampleOverlay
XAudio2SoundPlayer * m_soundPlayer
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush

Detailed Description

Definition at line 14 of file BasicSound.h.

Constructor & Destructor Documentation

BasicSound::~BasicSound ( ) [private]

Definition at line 78 of file BasicSound.cpp.

{
    delete m_soundPlayer;
    m_soundPlayer = nullptr;
}

Member Function Documentation

void BasicSound::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 88 of file BasicSound.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    //
    // Read the sound files and add them to the XAudio2 sound player, if we have sound.
    //
    if (m_soundPlayer == nullptr)
    {
        // We have no sound devices
        return;
    }
    for (size_t index = 0; SOUND_FILE_LIST[index]; ++index)
    {
        try
        {
            SoundFileReader nextSound(ref new Platform::String(SOUND_FILE_LIST[index]));
            (void)m_soundPlayer->AddSound(nextSound.GetSoundFormat(), nextSound.GetSoundData());
        }
        catch (Platform::FailureException^)
        {
            // If we have a failure, don't play that file, not worth stopping the whole sample
        }
    }

    // We should have at least one sound to play
    if (m_soundPlayer->GetSoundCount() == 0)
    {
        throw ref new Platform::FailureException();
    }
}

void BasicSound::CreateDeviceResources ( ) [override, virtual]

Definition at line 124 of file BasicSound.cpp.

{
    DirectXBase::CreateDeviceResources();

    //
    // Create the generic sample overlay
    //
    m_sampleOverlay = ref new SampleOverlay();
    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        ref new Platform::String(APPLICATION_TITLE)
        );

    //
    // Create the drawing brushes for the rectangles
    //
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_whiteBrush
            )
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Green),
            &m_greenBrush
            )
        );

    //
    // Setup the graphics objects related to drawing text
    //
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            FONT_NAME,
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            FONT_SIZE_TEXT,
            FONT_LOCALE,
            &m_dataTextFormat
            )
        );

    DX::ThrowIfFailed(
        m_dataTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );
    DX::ThrowIfFailed(
        m_dataTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::White), &m_textBrush)
        );
}

void BasicSound::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 193 of file BasicSound.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    if (m_soundPlayer != nullptr)
    {
        // Devide up the screen into sections based on the number of Wave Files
        D2D1_SIZE_F size = m_d2dContext->GetSize();
        m_rectangleWidth = (size.width / m_soundPlayer->GetSoundCount()) - 5;
        m_rectangleHeight = (size.height - TITLE_MARGIN)/2 - 5;
    }

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void BasicSound::OnPointerPressed ( _In_ Windows::UI::Input::PointerPoint^ p )

Definition at line 278 of file BasicSound.cpp.

{
    if (m_soundPlayer == nullptr)
    {
        //
        // No audio, ignore pointer presses
        //
        return;
    }

    if ((p->RawPosition.Y > TITLE_MARGIN) && (p->RawPosition.Y < (m_rectangleHeight + TITLE_MARGIN)))
    {
        size_t which = static_cast<size_t>(p->RawPosition.X / m_rectangleWidth);
        if (which < m_soundPlayer->GetSoundCount())
        {
            if (m_soundPlayer->IsSoundPlaying(which))
            {
                // Stop playing sound
                m_soundPlayer->StopSound(which);
            }
            else
            {
                // Start non-playing sound
                m_soundPlayer->PlaySound(which);
            }
        }
    }
}

void BasicSound::OnResuming ( )

Definition at line 315 of file BasicSound.cpp.

{
    if (m_soundPlayer != nullptr)
    {
        m_soundPlayer->Resume();
    }
}

void BasicSound::OnSuspending ( )

Definition at line 307 of file BasicSound.cpp.

{
    if (m_soundPlayer != nullptr)
    {
        m_soundPlayer->Suspend();
    }
}

void BasicSound::Render ( ) [override, virtual]

Definition at line 209 of file BasicSound.cpp.

{
    // bind the render targets
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // clear both the render target and depth stencil to default values
    const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        ClearColor
        );

    m_sampleOverlay->Render();

    m_d2dContext->BeginDraw();

    if (m_soundPlayer == nullptr)
    {
        //
        // If there is no audio, render a message.
        //
        D2D1_SIZE_F size = m_d2dContext->GetSize();
        D2D1_RECT_F pos = D2D1::RectF(INFORMATION_START_X, INFORMATION_START_Y, size.width, size.height);

        // Display a message when controller is not connected
        m_d2dContext->DrawText(
            MSG_NEED_AUDIO,
            static_cast<uint32>(::wcslen(MSG_NEED_AUDIO)),
            m_dataTextFormat.Get(),
            pos,
            m_textBrush.Get()
            );

    }
    else
    {
        //
        // There is Audio, display rectangles for clicking and playing indication
        //
        D2D1_RECT_F r = D2D1::RectF(0, TITLE_MARGIN, m_rectangleWidth, m_rectangleHeight + TITLE_MARGIN);
        for (size_t next = 0; next < m_soundPlayer->GetSoundCount(); ++next)
        {
            if (m_soundPlayer->IsSoundPlaying(next))
            {
                m_d2dContext->FillRectangle(&r, m_greenBrush.Get());
            }
            else
            {
                m_d2dContext->DrawRectangle(&r, m_whiteBrush.Get());
            }
            r.left += m_rectangleWidth;
            r.right += m_rectangleWidth;
        }
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

Member Data Documentation

internal BasicSound::__pad0__

Definition at line 17 of file BasicSound.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> BasicSound::m_dataTextFormat [private]

Definition at line 49 of file BasicSound.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> BasicSound::m_greenBrush [private]

Definition at line 46 of file BasicSound.h.

float BasicSound::m_rectangleHeight [private]

Definition at line 42 of file BasicSound.h.

float BasicSound::m_rectangleWidth [private]

Definition at line 41 of file BasicSound.h.

SampleOverlay BasicSound::m_sampleOverlay [private]

Definition at line 35 of file BasicSound.h.

XAudio2SoundPlayer* BasicSound::m_soundPlayer [private]

Definition at line 38 of file BasicSound.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> BasicSound::m_textBrush [private]

Definition at line 50 of file BasicSound.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> BasicSound::m_whiteBrush [private]

Definition at line 45 of file BasicSound.h.

The documentation for this class was generated from the following files:
  • XAudio2 audio file playback/C++/BasicSound.h
  • XAudio2 audio file playback/C++/BasicSound.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSprites::InstanceData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BasicSprites
  • BasicSprites::InstanceData
Public Attributes

BasicSprites::InstanceData Struct Reference

#include "BasicSprites.h"

List of all members.

Public Attributes

unsigned int | color
float2 offset
float2 origin
float | rotation

Detailed Description

Definition at line 66 of file BasicSprites.h.

Member Data Documentation

unsigned int BasicSprites::InstanceData::color

Definition at line 71 of file BasicSprites.h.

float2 BasicSprites::InstanceData::offset

Definition at line 69 of file BasicSprites.h.

float2 BasicSprites::InstanceData::origin

Definition at line 68 of file BasicSprites.h.

float BasicSprites::InstanceData::rotation

Definition at line 70 of file BasicSprites.h.

The documentation for this struct was generated from the following file:
  • Direct3D sprite/C++/BasicSprites.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSprites::InstancingVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BasicSprites
  • BasicSprites::InstancingVertex
Public Attributes

BasicSprites::InstancingVertex Struct Reference

#include "BasicSprites.h"

List of all members.

Public Attributes

float2 pos
float2 tex

Detailed Description

Definition at line 60 of file BasicSprites.h.

Member Data Documentation

float2 BasicSprites::InstancingVertex::pos

Definition at line 62 of file BasicSprites.h.

float2 BasicSprites::InstancingVertex::tex

Definition at line 63 of file BasicSprites.h.

The documentation for this struct was generated from the following file:
  • Direct3D sprite/C++/BasicSprites.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSprites::ReplicationVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BasicSprites
  • BasicSprites::ReplicationVertex
Public Attributes

BasicSprites::ReplicationVertex Struct Reference

#include "BasicSprites.h"

List of all members.

Public Attributes

unsigned int color
float2 pos
float2 tex

Detailed Description

Definition at line 53 of file BasicSprites.h.

Member Data Documentation

unsigned int BasicSprites::ReplicationVertex::color

Definition at line 57 of file BasicSprites.h.

float2 BasicSprites::ReplicationVertex::pos

Definition at line 55 of file BasicSprites.h.

float2 BasicSprites::ReplicationVertex::tex

Definition at line 56 of file BasicSprites.h.

The documentation for this struct was generated from the following file:
  • Direct3D sprite/C++/BasicSprites.h
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSprites::SpriteBatch Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BasicSprites
  • BasicSprites::SpriteBatch
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

BasicSprites::SpriteBatch Class Reference

#include "BasicSprites.h"

List of all members.

Public Member Functions

void | AddTexture (_In_ ID3D11Texture2D *texture)
void | Begin ()
void | Draw (_In_ ID3D11Texture2D *texture, _In_ float2 position, _In_ PositionUnits positionUnits, _In_ float2 size, _In_ SizeUnits sizeUnits, _In_ float4 color)
void | Draw (_In_ ID3D11Texture2D *texture, _In_ float2 position, _In_ PositionUnits positionUnits, _In_ float2 size, _In_ SizeUnits sizeUnits, _In_ float4 color, _In_ float rotation)
void | Draw (_In_ ID3D11Texture2D *texture, _In_ float2 position, _In_ PositionUnits positionUnits, _In_ float2 size, _In_ SizeUnits sizeUnits)
void | Draw (_In_ ID3D11Texture2D *texture, _In_ float2 position, _In_ PositionUnits positionUnits, _In_ float2 size, _In_ SizeUnits sizeUnits, _In_ float4 color, _In_ float rotation, _In_ BlendMode blendMode)
void | Draw (_In_ ID3D11Texture2D *texture, _In_ float2 position, _In_ PositionUnits positionUnits)
void | End ()
void | Initialize (_In_ ID3D11Device1 *d3dDevice, _In_ int capacity)
void | RemoveTexture (_In_ ID3D11Texture2D *texture)

Public Attributes

internal | __pad0__: SpriteBatch()

Private Member Functions

unsigned int | MakeUnorm (float4 color)
float2 | StandardOffset (float2 size, SizeUnits sizeUnits, float2 spriteSize, float dpi)
float2 | StandardOrigin (float2 position, PositionUnits positionUnits, float2 renderTargetSize, float dpi)

Private Attributes

Microsoft::WRL::ComPtr
< ID3D11BlendState1 > 		m_blendStateAdditive
Microsoft::WRL::ComPtr
< ID3D11BlendState1 > 		m_blendStateAlpha
int | m_capacity
ID3D11BlendState1 * | m_currentBlendState
ID3D11ShaderResourceView * | m_currentTextureView
Microsoft::WRL::ComPtr
< ID3D11DeviceContext1 > 		m_d3dContext
Microsoft::WRL::ComPtr
< ID3D11Device1 > 		m_d3dDevice
float | m_dpi
Microsoft::WRL::ComPtr
< ID3D11GeometryShader > 		m_geometryShader
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
std::unique_ptr< InstanceData[]> | m_instanceData
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_instanceDataBuffer
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_linearSampler
int | m_numSpritesDrawn
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_renderTargetInfoCbuffer
float2 m_renderTargetSize
std::vector< SpriteRunInfo > | m_spriteRuns
int | m_spritesInRun
RenderTechnique m_technique
std::map< ID3D11Texture2D
*, TextureMapElement > 		m_textureMap
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
std::unique_ptr
< ReplicationVertex[]> 		m_vertexData
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 87 of file BasicSprites.h.

Member Function Documentation

void SpriteBatch::AddTexture ( _In_ ID3D11Texture2D * texture )

Definition at line 364 of file BasicSprites.cpp.

{
    TextureMapElement mapElement;
    CD3D11_SHADER_RESOURCE_VIEW_DESC mapElementSrvDesc(
        texture,
        D3D11_SRV_DIMENSION_TEXTURE2D
        );
    DX::ThrowIfFailed(
        m_d3dDevice->CreateShaderResourceView(
            texture,
            &mapElementSrvDesc,
            &mapElement.srv
            )
        );

    D3D11_TEXTURE2D_DESC textureDesc;
    texture->GetDesc(&textureDesc);
    mapElement.size = float2(
        static_cast<float>(textureDesc.Width),
        static_cast<float>(textureDesc.Height)
        );

    m_textureMap[texture] = mapElement;
}

void SpriteBatch::Begin ( )

Definition at line 398 of file BasicSprites.cpp.

{
    // Reset internal sprite data.

    m_numSpritesDrawn = 0;
    m_spritesInRun = 0;
    m_spriteRuns.clear();

    // Get the current render target dimensions and logical DPI.

    ComPtr<ID3D11RenderTargetView> renderTargetView;
    m_d3dContext->OMGetRenderTargets(
        1,
        &renderTargetView,
        nullptr
        );

    ComPtr<ID3D11Resource> renderTarget;
    renderTargetView->GetResource(&renderTarget);

    ComPtr<ID3D11Texture2D> renderTargetTexture;
    renderTarget.As(&renderTargetTexture);

    D3D11_TEXTURE2D_DESC renderTargetTextureDesc;
    renderTargetTexture->GetDesc(&renderTargetTextureDesc);

    m_renderTargetSize = float2(
        static_cast<float>(renderTargetTextureDesc.Width),
        static_cast<float>(renderTargetTextureDesc.Height)
        );

    m_dpi = Windows::Graphics::Display::DisplayProperties::LogicalDpi;
}

void SpriteBatch::Draw | ( | _In_ ID3D11Texture2D * | texture,
 |  | _In_ float2 | position,
 |  | _In_ PositionUnits | positionUnits,
 |  | _In_ float2 | size,
 |  | _In_ SizeUnits | sizeUnits,
 |  | _In_ float4 | color
 | ) |  |

Definition at line 769 of file BasicSprites.cpp.

{
    Draw(
        texture,
        position,
        positionUnits,
        size,
        sizeUnits,
        color,
        0.0f
        );
}

void SpriteBatch::Draw | ( | _In_ ID3D11Texture2D * | texture,
 |  | _In_ float2 | position,
 |  | _In_ PositionUnits | positionUnits,
 |  | _In_ float2 | size,
 |  | _In_ SizeUnits | sizeUnits,
 |  | _In_ float4 | color,
 |  | _In_ float | rotation
 | ) |  |

Definition at line 789 of file BasicSprites.cpp.

{
    Draw(
        texture,
        position,
        positionUnits,
        size,
        sizeUnits,
        color,
        rotation,
        BlendMode::Alpha
        );
}

void SpriteBatch::Draw | ( | _In_ ID3D11Texture2D * | texture,
 |  | _In_ float2 | position,
 |  | _In_ PositionUnits | positionUnits,
 |  | _In_ float2 | size,
 |  | _In_ SizeUnits | sizeUnits,
 |  | _In_ float4 | color,
 |  | _In_ float | rotation,
 |  | _In_ BlendMode | blendMode
 | ) |  |

Definition at line 811 of file BasicSprites.cpp.

{
    // Fail if drawing this sprite would exceed the capacity of the sprite batch.
    if (m_numSpritesDrawn >= m_capacity)
    {
        throw ref new Platform::OutOfBoundsException();
    }

    // Retrieve information about the sprite.
    TextureMapElement element = m_textureMap[texture];
    ID3D11ShaderResourceView* textureView = element.srv.Get();
    float2 textureSize = element.size;
    ID3D11BlendState1* blendState = blendMode == BlendMode::Additive ? m_blendStateAdditive.Get() : m_blendStateAlpha.Get();

    // Fail if the texture has not previously been added to the sprite batch.
    if (textureView == nullptr)
    {
        throw ref new Platform::NullReferenceException();
    }

    // Unless this is the first sprite run, save out the previous run info if a new run is required.
    if (
        m_numSpritesDrawn > 0 && (
            textureView != m_currentTextureView ||
            blendState != m_currentBlendState
            )
        )
    {
        SpriteRunInfo runInfo;
        runInfo.textureView = m_currentTextureView;
        runInfo.blendState = m_currentBlendState;
        runInfo.numSprites = m_spritesInRun;
        m_spriteRuns.push_back(runInfo);
        m_spritesInRun = 0; // Reset for the next sprite run.
    }
    m_currentTextureView = textureView;
    m_currentBlendState = blendState;

    // Add the sprite to the buffer.

    float2 origin = StandardOrigin(position, positionUnits, m_renderTargetSize, m_dpi);
    float2 offset = StandardOffset(size, sizeUnits, textureSize, m_dpi);

    if (m_technique == RenderTechnique::GeometryShader || m_technique == RenderTechnique::Instancing)
    {
        m_instanceData[m_numSpritesDrawn].origin = origin;
        m_instanceData[m_numSpritesDrawn].offset = offset;
        m_instanceData[m_numSpritesDrawn].rotation = rotation;
        m_instanceData[m_numSpritesDrawn].color = MakeUnorm(color);
    }
    else if (m_technique == RenderTechnique::Replication)
    {
        float2 offsets[4] =
        {
            float2(-offset.x,  offset.y),
            float2( offset.x,  offset.y),
            float2(-offset.x, -offset.y),
            float2( offset.x, -offset.y)
        };

        float sinRotation = sinf(rotation);
        float cosRotation = cosf(rotation);

        for (int i = 0; i < 4; i++)
        {
            offsets[i] = float2(
                offsets[i].x * cosRotation - offsets[i].y * sinRotation,
                offsets[i].x * sinRotation + offsets[i].y * cosRotation
                );
            offsets[i].x /= m_renderTargetSize.x;
            offsets[i].y /= m_renderTargetSize.y;
        }

        // Write vertex buffer data.

        ReplicationVertex* singleSpriteVertices = &m_vertexData[m_numSpritesDrawn * 4];
        unsigned int colorUnorm = MakeUnorm(color);
        singleSpriteVertices[0].pos = origin + offsets[0];
        singleSpriteVertices[1].pos = origin + offsets[1];
        singleSpriteVertices[2].pos = origin + offsets[2];
        singleSpriteVertices[3].pos = origin + offsets[3];
        singleSpriteVertices[0].color = colorUnorm;
        singleSpriteVertices[1].color = colorUnorm;
        singleSpriteVertices[2].color = colorUnorm;
        singleSpriteVertices[3].color = colorUnorm;
        singleSpriteVertices[0].tex = float2(0.0f, 0.0f);
        singleSpriteVertices[1].tex = float2(1.0f, 0.0f);
        singleSpriteVertices[2].tex = float2(0.0f, 1.0f);
        singleSpriteVertices[3].tex = float2(1.0f, 1.0f);
    }

    m_spritesInRun++;
    m_numSpritesDrawn++;
}

void SpriteBatch::Draw | ( | _In_ ID3D11Texture2D * | texture,
 |  | _In_ float2 | position,
 |  | _In_ PositionUnits | positionUnits = PositionUnits::DIPs
 | ) |  |

Definition at line 736 of file BasicSprites.cpp.

{
    Draw(
        texture,
        position,
        positionUnits,
        float2(1.0f, 1.0f),
        SizeUnits::Normalized
        );
}

void SpriteBatch::Draw | ( | _In_ ID3D11Texture2D * | texture,
 |  | _In_ float2 | position,
 |  | _In_ PositionUnits | positionUnits,
 |  | _In_ float2 | size,
 |  | _In_ SizeUnits | sizeUnits
 | ) |  |

Definition at line 751 of file BasicSprites.cpp.

{
    Draw(
        texture,
        position,
        positionUnits,
        size,
        sizeUnits,
        float4(1.0f, 1.0f, 1.0f, 1.0f)
        );
}

void SpriteBatch::End ( )

Definition at line 432 of file BasicSprites.cpp.

{
    // If no sprites were drawn, do nothing.
    if (m_numSpritesDrawn == 0)
    {
        return;
    }

    // Save the final sprite run info.

    SpriteRunInfo runInfo;
    runInfo.textureView = m_currentTextureView;
    runInfo.blendState = m_currentBlendState;
    runInfo.numSprites = m_spritesInRun;
    m_spriteRuns.push_back(runInfo);

    // Update the buffer data.

    if (m_technique == RenderTechnique::GeometryShader || m_technique == RenderTechnique::Instancing)
    {
        CD3D11_BOX instanceDataBox(
            0,
            0,
            0,
            sizeof(InstanceData) * m_numSpritesDrawn,
            1,
            1
            );

        m_d3dContext->UpdateSubresource(
            m_instanceDataBuffer.Get(),
            0,
            &instanceDataBox,
            m_instanceData.get(),
            0,
            0
            );
    }
    else if (m_technique == RenderTechnique::Replication)
    {
        CD3D11_BOX vertexDataBox(
            0,
            0,
            0,
            sizeof(ReplicationVertex) * m_numSpritesDrawn * 4,
            1,
            1
            );

        m_d3dContext->UpdateSubresource(
            m_vertexBuffer.Get(),
            0,
            &vertexDataBox,
            m_vertexData.get(),
            0,
            0
            );
    }

    if (m_technique == RenderTechnique::GeometryShader || m_technique == RenderTechnique::Instancing)
    {
        D3D11_MAPPED_SUBRESOURCE mappedSubresource;
        m_d3dContext->Map(
            m_renderTargetInfoCbuffer.Get(),
            0,
            D3D11_MAP_WRITE_DISCARD,
            0,
            &mappedSubresource
            );
        *static_cast<float2*>(mappedSubresource.pData) = m_renderTargetSize;
        m_d3dContext->Unmap(
            m_renderTargetInfoCbuffer.Get(),
            0
            );
    }

    // Set the pipeline state

    if (m_technique == RenderTechnique::Instancing)
    {
        m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
        m_d3dContext->IASetIndexBuffer(
            m_indexBuffer.Get(),
            DXGI_FORMAT_R32_UINT,
            0
            );
    }
    else if (m_technique == RenderTechnique::Replication)
    {
        m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
        m_d3dContext->IASetIndexBuffer(
            m_indexBuffer.Get(),
            DXGI_FORMAT_R16_UINT,
            0
            );
    }
    else if (m_technique == RenderTechnique::GeometryShader)
    {
        m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_POINTLIST);
        m_d3dContext->GSSetShader(
            m_geometryShader.Get(),
            nullptr,
            0
            );
    }

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,
        0
        );

    if (m_technique == RenderTechnique::GeometryShader)
    {
        m_d3dContext->GSSetConstantBuffers(
            0,
            1,
            m_renderTargetInfoCbuffer.GetAddressOf()
            );
    }
    else if (m_technique == RenderTechnique::Instancing)
    {
        m_d3dContext->VSSetConstantBuffers(
            0,
            1,
            m_renderTargetInfoCbuffer.GetAddressOf()
            );
    }

    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,
        0
        );

    m_d3dContext->PSSetSamplers(
        0,
        1,
        m_linearSampler.GetAddressOf()
        );

    if (m_technique == RenderTechnique::GeometryShader)
    {
        unsigned int stride = sizeof(InstanceData);
        unsigned int offset = 0;
        m_d3dContext->IASetVertexBuffers(
            0,
            1,
            m_instanceDataBuffer.GetAddressOf(),
            &stride,
            &offset
            );
    }
    else if (m_technique == RenderTechnique::Instancing)
    {
        unsigned int stride = sizeof(InstancingVertex);
        unsigned int offset = 0;
        m_d3dContext->IASetVertexBuffers(
            0,
            1,
            m_vertexBuffer.GetAddressOf(),
            &stride,
            &offset
            );
    }
    else if (m_technique == RenderTechnique::Replication)
    {
        unsigned int stride = sizeof(ReplicationVertex);
        unsigned int offset = 0;
        m_d3dContext->IASetVertexBuffers(
            0,
            1,
            m_vertexBuffer.GetAddressOf(),
            &stride,
            &offset
            );
    }

    // Draw each sprite run

    unsigned int indexBase = 0;
    for (auto runIterator = m_spriteRuns.begin(); runIterator != m_spriteRuns.end(); runIterator++)
    {
        m_d3dContext->PSSetShaderResources(
            0,
            1,
            &runIterator->textureView
            );

        const FLOAT blendFactor[] = {0.0f, 0.0f, 0.0f, 0.0f};

        m_d3dContext->OMSetBlendState(
            runIterator->blendState,
            nullptr,
            0xFFFFFFFF
            );

        if (m_technique == RenderTechnique::GeometryShader)
        {
            unsigned int instancesToDraw = runIterator->numSprites;
            m_d3dContext->DrawInstanced(
                1,
                instancesToDraw,
                0,
                indexBase
                );
            indexBase += instancesToDraw;
        }
        else if (m_technique == RenderTechnique::Instancing)
        {
            unsigned int instancesToDraw = runIterator->numSprites;
            unsigned int stride = sizeof(InstanceData);
            unsigned int offset = indexBase * stride;
            // Instance data offset must be zero for the draw call on feature level 9.3 and below.
            // Instead, set the offset in the input assembler.
            m_d3dContext->IASetVertexBuffers(
                1,
                1,
                m_instanceDataBuffer.GetAddressOf(),
                &stride,
                &offset
                );
            m_d3dContext->DrawIndexedInstanced(
                6,
                instancesToDraw,
                0,
                0,
                0
                );
            indexBase += instancesToDraw;
        }
        else if (m_technique == RenderTechnique::Replication)
        {
            unsigned int indicesToDraw = runIterator->numSprites * 6;
            m_d3dContext->DrawIndexed(indicesToDraw, indexBase, 0);
            indexBase += indicesToDraw;
        }
    }
}

void SpriteBatch::Initialize | ( | _In_ ID3D11Device1 * | d3dDevice,
 |  | _In_ int | capacity = 1024
 | ) |  |

Definition at line 25 of file BasicSprites.cpp.

{
    m_d3dDevice = d3dDevice;
    m_d3dDevice->GetImmediateContext1(&m_d3dContext);
    m_capacity = capacity;

    // Determine the technique that will be used to render the sprites.
    auto featureLevel = m_d3dDevice->GetFeatureLevel();

    if (featureLevel >= D3D_FEATURE_LEVEL_10_0)
    {
        // On DirectX 10+ devices, the Geometry Shader allows the sprite vertices to be
        // generated on the GPU, significantly reducing memory bandwidth requirements.
        m_technique = RenderTechnique::GeometryShader;
    }
    else if (featureLevel >= D3D_FEATURE_LEVEL_9_3)
    {
        // On DirectX 9.3+ devices, instancing allows shared sprite geometry with unique
        // per-sprite instance parameters, eliminating redundant data transfer.
        m_technique = RenderTechnique::Instancing;
    }
    else
    {
        // On devices that do not support Instancing, sprite vertex data must be replicated
        // in order to achieve the desired effect.
        m_technique = RenderTechnique::Replication;

        if (capacity > static_cast<int>(Parameters::MaximumCapacityCompatible))
        {
            // The index buffer format for feature-level 9.1 devices may only be 16 bits.
            // With 4 vertices per sprite, this allows a maximum of (1 << 16) / 4 sprites.
            throw ref new Platform::InvalidArgumentException();
        }
    }

    // Create the texture sampler.

    D3D11_SAMPLER_DESC samplerDesc;
    ZeroMemory(&samplerDesc, sizeof(samplerDesc));
    samplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;
    samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDesc.MipLODBias = 0.0f;
    samplerDesc.MaxAnisotropy = 0;
    samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDesc.BorderColor[0] = 0.0f;
    samplerDesc.BorderColor[1] = 0.0f;
    samplerDesc.BorderColor[2] = 0.0f;
    samplerDesc.BorderColor[3] = 0.0f;
    samplerDesc.MinLOD = 0.0f;
    samplerDesc.MaxLOD = FLT_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDesc,
            &m_linearSampler
            )
        );

    // Create the blend states.

    D3D11_BLEND_DESC1 blendDesc;
    ZeroMemory(&blendDesc, sizeof(blendDesc));
    blendDesc.AlphaToCoverageEnable = false;
    blendDesc.IndependentBlendEnable = false;
    blendDesc.RenderTarget[0].BlendEnable = true;
    blendDesc.RenderTarget[0].LogicOpEnable = false;
    blendDesc.RenderTarget[0].SrcBlend = D3D11_BLEND_SRC_ALPHA;
    blendDesc.RenderTarget[0].DestBlend = D3D11_BLEND_INV_SRC_ALPHA;
    blendDesc.RenderTarget[0].BlendOp = D3D11_BLEND_OP_ADD;
    blendDesc.RenderTarget[0].SrcBlendAlpha = D3D11_BLEND_ONE;
    blendDesc.RenderTarget[0].DestBlendAlpha = D3D11_BLEND_ONE;
    blendDesc.RenderTarget[0].BlendOpAlpha = D3D11_BLEND_OP_ADD;
    blendDesc.RenderTarget[0].RenderTargetWriteMask = D3D11_COLOR_WRITE_ENABLE_ALL;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBlendState1(
            &blendDesc,
            &m_blendStateAlpha
            )
        );

    blendDesc.RenderTarget[0].DestBlend = D3D11_BLEND_ONE;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBlendState1(
            &blendDesc,
            &m_blendStateAdditive
            )
        );

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    if (m_technique == RenderTechnique::GeometryShader)
    {
        D3D11_INPUT_ELEMENT_DESC layoutDesc[] =
        {
            { "TRANSFORM", 0, DXGI_FORMAT_R32G32_FLOAT,   0, 0,  D3D11_INPUT_PER_INSTANCE_DATA, 1 },
            { "TRANSFORM", 1, DXGI_FORMAT_R32G32_FLOAT,   0, 8,  D3D11_INPUT_PER_INSTANCE_DATA, 1 },
            { "TRANSFORM", 2, DXGI_FORMAT_R32_FLOAT,      0, 16, D3D11_INPUT_PER_INSTANCE_DATA, 1 },
            { "COLOR",     0, DXGI_FORMAT_R8G8B8A8_UNORM, 0, 20, D3D11_INPUT_PER_INSTANCE_DATA, 1 }
        };
        loader->LoadShader(
            "BasicSprites.GeometryShader.vs.cso",
            layoutDesc,
            ARRAYSIZE(layoutDesc),
            &m_vertexShader,
            &m_inputLayout
            );
        loader->LoadShader(
            "BasicSprites.GeometryShader.gs.cso",
            &m_geometryShader
            );
    }
    else if (m_technique == RenderTechnique::Instancing)
    {
        D3D11_INPUT_ELEMENT_DESC layoutDesc[] =
        {
            { "POSITION",  0, DXGI_FORMAT_R32G32_FLOAT,   0, 0,  D3D11_INPUT_PER_VERTEX_DATA,   0 },
            { "TEXCOORD",  0, DXGI_FORMAT_R32G32_FLOAT,   0, 8,  D3D11_INPUT_PER_VERTEX_DATA,   0 },
            { "TRANSFORM", 0, DXGI_FORMAT_R32G32_FLOAT,   1, 0,  D3D11_INPUT_PER_INSTANCE_DATA, 1 },
            { "TRANSFORM", 1, DXGI_FORMAT_R32G32_FLOAT,   1, 8,  D3D11_INPUT_PER_INSTANCE_DATA, 1 },
            { "TRANSFORM", 2, DXGI_FORMAT_R32_FLOAT,      1, 16, D3D11_INPUT_PER_INSTANCE_DATA, 1 },
            { "COLOR",     0, DXGI_FORMAT_R8G8B8A8_UNORM, 1, 20, D3D11_INPUT_PER_INSTANCE_DATA, 1 }
        };
        loader->LoadShader(
            "BasicSprites.Instancing.vs.cso",
            layoutDesc,
            ARRAYSIZE(layoutDesc),
            &m_vertexShader,
            &m_inputLayout
            );
    }
    else if (m_technique == RenderTechnique::Replication)
    {
        D3D11_INPUT_ELEMENT_DESC layoutDesc[] =
        {
            { "POSITIONT", 0, DXGI_FORMAT_R32G32_FLOAT,   0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "TEXCOORD",  0, DXGI_FORMAT_R32G32_FLOAT,   0, 8,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "COLOR",     0, DXGI_FORMAT_R8G8B8A8_UNORM, 0, 16, D3D11_INPUT_PER_VERTEX_DATA, 0 }
        };
        loader->LoadShader(
            "BasicSprites.Replication.vs.cso",
            layoutDesc,
            ARRAYSIZE(layoutDesc),
            &m_vertexShader,
            &m_inputLayout
            );
    }

    loader->LoadShader(
        "BasicSprites.ps.cso",
        &m_pixelShader
        );

    // Create buffers.

    if (m_technique == RenderTechnique::GeometryShader)
    {
        // Create the instance data buffer.

        CD3D11_BUFFER_DESC instanceDataBufferDesc(
            m_capacity * sizeof(InstanceData),
            D3D11_BIND_VERTEX_BUFFER,
            D3D11_USAGE_DEFAULT,
            0
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &instanceDataBufferDesc,
                nullptr,
                &m_instanceDataBuffer
                )
            );

        m_instanceData.reset(new InstanceData[m_capacity]);
    }
    else if (m_technique == RenderTechnique::Instancing)
    {
        // Create the vertex buffer.

        InstancingVertex vertexBufferData[] =
        {
            { float2(-1.0f,  1.0f), float2(0.0f, 0.0f) },
            { float2( 1.0f,  1.0f), float2(1.0f, 0.0f) },
            { float2(-1.0f, -1.0f), float2(0.0f, 1.0f) },
            { float2( 1.0f, -1.0f), float2(1.0f, 1.0f) }
        };

        D3D11_SUBRESOURCE_DATA vertexInitialData;
        vertexInitialData.pSysMem = vertexBufferData;
        vertexInitialData.SysMemPitch = 0;
        vertexInitialData.SysMemSlicePitch = 0;

        CD3D11_BUFFER_DESC vertexBufferDesc(
            sizeof(vertexBufferData),
            D3D11_BIND_VERTEX_BUFFER,
            D3D11_USAGE_DEFAULT,
            0
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &vertexBufferDesc,
                &vertexInitialData,
                &m_vertexBuffer
                )
            );

        // Create the instance data buffer.

        CD3D11_BUFFER_DESC instanceDataBufferDesc(
            m_capacity * sizeof(InstanceData),
            D3D11_BIND_VERTEX_BUFFER,
            D3D11_USAGE_DEFAULT,
            0
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &instanceDataBufferDesc,
                nullptr,
                &m_instanceDataBuffer
                )
            );

        m_instanceData.reset(new InstanceData[m_capacity]);

        // Create the index buffer.

        unsigned int indexBufferData[] =
        {
            0, 1, 2,
            1, 3, 2
        };

        D3D11_SUBRESOURCE_DATA indexInitialData;
        indexInitialData.pSysMem = indexBufferData;
        indexInitialData.SysMemPitch = 0;
        indexInitialData.SysMemSlicePitch = 0;

        CD3D11_BUFFER_DESC indexBufferDesc(
            sizeof(indexBufferData),
            D3D11_BIND_INDEX_BUFFER,
            D3D11_USAGE_DEFAULT,
            0
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &indexBufferDesc,
                &indexInitialData,
                &m_indexBuffer
                )
            );
    }
    else if (m_technique == RenderTechnique::Replication)
    {
        // Create the vertex buffer.

        CD3D11_BUFFER_DESC vertexBufferDesc(
            m_capacity * 4 * sizeof(ReplicationVertex),
            D3D11_BIND_VERTEX_BUFFER,
            D3D11_USAGE_DEFAULT,
            0
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &vertexBufferDesc,
                nullptr,
                &m_vertexBuffer
                )
            );

        m_vertexData.reset(new ReplicationVertex[m_capacity * 4]);

        // Create the index buffer.

        std::unique_ptr<unsigned short[]> indexBufferData(new unsigned short[m_capacity * 6]);

        for (int i = 0; i < m_capacity; i++)
        {
            indexBufferData[i * 6 + 0] = i * 4 + 0;
            indexBufferData[i * 6 + 1] = i * 4 + 1;
            indexBufferData[i * 6 + 2] = i * 4 + 2;
            indexBufferData[i * 6 + 3] = i * 4 + 1;
            indexBufferData[i * 6 + 4] = i * 4 + 3;
            indexBufferData[i * 6 + 5] = i * 4 + 2;
        }

        D3D11_SUBRESOURCE_DATA initialData;
        initialData.pSysMem = indexBufferData.get();
        initialData.SysMemPitch = 0;
        initialData.SysMemSlicePitch = 0;

        CD3D11_BUFFER_DESC indexBufferDesc(
            m_capacity * 6 * sizeof(unsigned short),
            D3D11_BIND_INDEX_BUFFER,
            D3D11_USAGE_DEFAULT,
            0
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &indexBufferDesc,
                &initialData,
                &m_indexBuffer
                )
            );
    }

    if (m_technique == RenderTechnique::GeometryShader || m_technique == RenderTechnique::Instancing)
    {
        // Both the Geometry Shader and Instancing techniques scale geometry in shader code.
        // As a result, they require information about the render target size.

        CD3D11_BUFFER_DESC renderTargetInfoCbufferDesc(
            16, // Constant buffer sizes must be a multiple of 16 bytes.  16 is sufficient for the required float2 data.
            D3D11_BIND_CONSTANT_BUFFER,
            D3D11_USAGE_DYNAMIC,
            D3D11_CPU_ACCESS_WRITE
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &renderTargetInfoCbufferDesc,
                nullptr,
                &m_renderTargetInfoCbuffer
                )
            );
    }
}

unsigned int SpriteBatch::MakeUnorm ( float4 color ) [private]

Definition at line 674 of file BasicSprites.cpp.

{
    unsigned int r = max(0, min(255, static_cast<unsigned int>(color.r * 255.0f)));
    unsigned int g = max(0, min(255, static_cast<unsigned int>(color.g * 255.0f)));
    unsigned int b = max(0, min(255, static_cast<unsigned int>(color.b * 255.0f)));
    unsigned int a = max(0, min(255, static_cast<unsigned int>(color.a * 255.0f)));
    return
        (a << 24) |
        (b << 16) |
        (g << 8) |
        r;
}

void SpriteBatch::RemoveTexture ( _In_ ID3D11Texture2D * texture )

Definition at line 391 of file BasicSprites.cpp.

{
    m_textureMap.erase(texture);
}

float2 SpriteBatch::StandardOffset | ( | float2 | size,
 |  | SizeUnits | sizeUnits,
 |  | float2 | spriteSize,
 |  | float | dpi |
 | ) |  |  | [private]

Definition at line 718 of file BasicSprites.cpp.

{
    float2 offset;
    if (sizeUnits == SizeUnits::Pixels)
    {
        offset = size;
    }
    else if (sizeUnits == SizeUnits::DIPs)
    {
        offset = size * dpi / 96.0f;
    }
    else if (sizeUnits == SizeUnits::Normalized)
    {
        offset = spriteSize * size;
    }
    return offset;
}

float2 SpriteBatch::StandardOrigin | ( | float2 | position,
 |  | PositionUnits | positionUnits,
 |  | float2 | renderTargetSize,
 |  | float | dpi |
 | ) |  |  | [private]

Definition at line 687 of file BasicSprites.cpp.

{
    float2 origin;
    if (positionUnits == PositionUnits::Pixels)
    {
        origin.x = (position.x / renderTargetSize.x) * 2.0f - 1.0f;
        origin.y = 1.0f - (position.y / renderTargetSize.y) * 2.0f;
    }
    else if (positionUnits == PositionUnits::DIPs)
    {
        origin.x = ((position.x * dpi / 96.0f) / renderTargetSize.x) * 2.0f - 1.0f;
        origin.y = 1.0f - ((position.y * dpi / 96.0f) / renderTargetSize.y) * 2.0f;
    }
    else if (positionUnits == PositionUnits::Normalized)
    {
        origin.x = position.x * 2.0f - 1.0f;
        origin.y = 1.0f - position.y * 2.0f;
    }
    else if (positionUnits == PositionUnits::UniformWidth)
    {
        origin.x = position.x * 2.0f - 1.0f;
        origin.y = 1.0f - position.y * (renderTargetSize.x / renderTargetSize.y) * 2.0f;
    }
    else if (positionUnits == PositionUnits::UniformHeight)
    {
        origin.x = position.x * (renderTargetSize.y / renderTargetSize.x) * 2.0f - 1.0f;
        origin.y = 1.0f - position.y * 2.0f;
    }
    return origin;
}

Member Data Documentation

internal BasicSprites::SpriteBatch::__pad0__

Definition at line 90 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11BlendState1> BasicSprites::SpriteBatch::m_blendStateAdditive [private]

Definition at line 154 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11BlendState1> BasicSprites::SpriteBatch::m_blendStateAlpha [private]

Definition at line 153 of file BasicSprites.h.

int BasicSprites::SpriteBatch::m_capacity [private]

Definition at line 171 of file BasicSprites.h.

ID3D11BlendState1* BasicSprites::SpriteBatch::m_currentBlendState [private]

Definition at line 169 of file BasicSprites.h.

ID3D11ShaderResourceView* BasicSprites::SpriteBatch::m_currentTextureView [private]

Definition at line 168 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11DeviceContext1> BasicSprites::SpriteBatch::m_d3dContext [private]

Definition at line 149 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11Device1> BasicSprites::SpriteBatch::m_d3dDevice [private]

Definition at line 148 of file BasicSprites.h.

float BasicSprites::SpriteBatch::m_dpi [private]

Definition at line 174 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11GeometryShader> BasicSprites::SpriteBatch::m_geometryShader [private]

Definition at line 157 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> BasicSprites::SpriteBatch::m_indexBuffer [private]

Definition at line 152 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> BasicSprites::SpriteBatch::m_inputLayout [private]

Definition at line 155 of file BasicSprites.h.

std::unique_ptr<InstanceData[]> BasicSprites::SpriteBatch::m_instanceData [private]

Definition at line 163 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> BasicSprites::SpriteBatch::m_instanceDataBuffer [private]

Definition at line 151 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> BasicSprites::SpriteBatch::m_linearSampler [private]

Definition at line 159 of file BasicSprites.h.

int BasicSprites::SpriteBatch::m_numSpritesDrawn [private]

Definition at line 173 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> BasicSprites::SpriteBatch::m_pixelShader [private]

Definition at line 158 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> BasicSprites::SpriteBatch::m_renderTargetInfoCbuffer [private]

Definition at line 160 of file BasicSprites.h.

float2 BasicSprites::SpriteBatch::m_renderTargetSize [private]

Definition at line 170 of file BasicSprites.h.

std::vector<SpriteRunInfo> BasicSprites::SpriteBatch::m_spriteRuns [private]

Definition at line 165 of file BasicSprites.h.

int BasicSprites::SpriteBatch::m_spritesInRun [private]

Definition at line 172 of file BasicSprites.h.

RenderTechnique BasicSprites::SpriteBatch::m_technique [private]

Definition at line 167 of file BasicSprites.h.

std::map<ID3D11Texture2D*, TextureMapElement> BasicSprites::SpriteBatch::m_textureMap [private]

Definition at line 164 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> BasicSprites::SpriteBatch::m_vertexBuffer [private]

Definition at line 150 of file BasicSprites.h.

std::unique_ptr<ReplicationVertex[]> BasicSprites::SpriteBatch::m_vertexData [private]

Definition at line 162 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> BasicSprites::SpriteBatch::m_vertexShader [private]

Definition at line 156 of file BasicSprites.h.

The documentation for this class was generated from the following files:
  • Direct3D sprite/C++/BasicSprites.h
  • Direct3D sprite/C++/BasicSprites.cpp
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSprites::SpriteRunInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BasicSprites
  • BasicSprites::SpriteRunInfo
Public Attributes

BasicSprites::SpriteRunInfo Struct Reference

#include "BasicSprites.h"

List of all members.

Public Attributes

ID3D11BlendState1 * | blendState
unsigned int | numSprites
ID3D11ShaderResourceView * | textureView

Detailed Description

Definition at line 80 of file BasicSprites.h.

Member Data Documentation

ID3D11BlendState1* BasicSprites::SpriteRunInfo::blendState

Definition at line 83 of file BasicSprites.h.

unsigned int BasicSprites::SpriteRunInfo::numSprites

Definition at line 84 of file BasicSprites.h.

ID3D11ShaderResourceView* BasicSprites::SpriteRunInfo::textureView

Definition at line 82 of file BasicSprites.h.

The documentation for this struct was generated from the following file:
  • Direct3D sprite/C++/BasicSprites.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSprites::TextureMapElement Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • BasicSprites
  • BasicSprites::TextureMapElement
Public Attributes

BasicSprites::TextureMapElement Struct Reference

#include "BasicSprites.h"

List of all members.

Public Attributes

float2 size
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		srv

Detailed Description

Definition at line 74 of file BasicSprites.h.

Member Data Documentation

float2 BasicSprites::TextureMapElement::size

Definition at line 77 of file BasicSprites.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> BasicSprites::TextureMapElement::srv

Definition at line 76 of file BasicSprites.h.

The documentation for this struct was generated from the following file:
  • Direct3D sprite/C++/BasicSprites.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicTimer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Private Member Functions | Private Attributes

BasicTimer Class Reference

#include "BasicTimer.h"

List of all members.

Private Member Functions

void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Reset ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()
void | Update ()

Private Attributes

internal | __pad0__: BasicTimer()
LARGE_INTEGER | m_currentTime
float | m_delta
LARGE_INTEGER | m_frequency
LARGE_INTEGER | m_lastTime
LARGE_INTEGER | m_startTime
float | m_total

Detailed Description

Definition at line 13 of file BasicTimer.h.

Member Function Documentation

void BasicTimer::Reset ( ) [private]

Definition at line 20 of file BasicTimer.cpp.

{
    Update();
    m_startTime = m_currentTime;
    m_total = 0.0f;
    m_delta = 1.0f / 60.0f;
}

void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Reset ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]

Definition at line 28 of file BasicTimer.cpp.

{
    if (!QueryPerformanceCounter(&m_currentTime))
    {
        throw ref new Platform::FailureException();
    }

    m_total = static_cast<float>(
        static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
        static_cast<double>(m_frequency.QuadPart)
        );

    if (m_lastTime.QuadPart == m_startTime.QuadPart)
    {
        // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
        m_delta = 1.0f / 60.0f;
    }
    else
    {
        m_delta = static_cast<float>(
            static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
            static_cast<double>(m_frequency.QuadPart)
            );
    }

    m_lastTime = m_currentTime;
}

void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]
void BasicTimer::Update ( ) [private]

Member Data Documentation

internal BasicTimer::__pad0__ [private]

Definition at line 24 of file BasicTimer.h.

LARGE_INTEGER BasicTimer::m_currentTime [private]

Definition at line 17 of file BasicTimer.h.

float BasicTimer::m_delta [private]

Definition at line 21 of file BasicTimer.h.

LARGE_INTEGER BasicTimer::m_frequency [private]

Definition at line 16 of file BasicTimer.h.

LARGE_INTEGER BasicTimer::m_lastTime [private]

Definition at line 19 of file BasicTimer.h.

LARGE_INTEGER BasicTimer::m_startTime [private]

Definition at line 18 of file BasicTimer.h.

float BasicTimer::m_total [private]

Definition at line 20 of file BasicTimer.h.

The documentation for this class was generated from the following files:
  • Direct2D command list/C++/BasicTimer.h
  • Direct2D custom image effects/C++/PixelShader/BasicTimer.h
  • Direct2D custom image effects/C++/VertexShader/BasicTimer.h
  • Direct2D interpolation modes/C++/BasicTimer.h
  • Direct3D bump mapping/C++/BasicTimer.h
  • Direct3D HLSL fractal generator/C++/BasicTimer.h
  • Direct3D post-processing effects/C++/BasicTimer.h
  • Direct3D resource loading/C++/BasicTimer.h
  • Direct3D sprite/C++/BasicTimer.h
  • Direct3D stereoscopic 3D/C++/BasicTimer.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicTimer.h
  • Direct3D-Direct2D interop/C++/BasicTimer.h
  • DirectX marble maze game/C++/BasicTimer.h
  • DirectX touch input/C++/BasicTimer.h
  • DXGI offer and reclaim resources/C++/BasicTimer.h
  • DXGI swap chain rotation/C++/BasicTimer.h
  • XAudio2 audio file playback/C++/BasicTimer.h
  • XAudio2 audio stream effect/C++/BasicTimer.h
  • XInput audio controller playback/C++/BasicTimer.h
  • XInput game controller/C++/BasicTimer.h
  • Direct2D command list/C++/BasicTimer.cpp
  • Direct2D custom image effects/C++/PixelShader/BasicTimer.cpp
  • Direct2D custom image effects/C++/VertexShader/BasicTimer.cpp
  • Direct2D interpolation modes/C++/BasicTimer.cpp
  • Direct3D bump mapping/C++/BasicTimer.cpp
  • Direct3D HLSL fractal generator/C++/BasicTimer.cpp
  • Direct3D post-processing effects/C++/BasicTimer.cpp
  • Direct3D resource loading/C++/BasicTimer.cpp
  • Direct3D sprite/C++/BasicTimer.cpp
  • Direct3D stereoscopic 3D/C++/BasicTimer.cpp
  • Direct3D tutorial/C++/Lesson5.Components/BasicTimer.cpp
  • Direct3D-Direct2D interop/C++/BasicTimer.cpp
  • DirectX marble maze game/C++/BasicTimer.cpp
  • DirectX touch input/C++/BasicTimer.cpp
  • DXGI offer and reclaim resources/C++/BasicTimer.cpp
  • DXGI swap chain rotation/C++/BasicTimer.cpp
  • XAudio2 audio file playback/C++/BasicTimer.cpp
  • XAudio2 audio stream effect/C++/BasicTimer.cpp
  • XInput audio controller playback/C++/BasicTimer.cpp
  • XInput game controller/C++/BasicTimer.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

BasicVertex Struct Reference

#include "BasicShapes.h"

List of all members.

Public Attributes

float3 norm
float3 pos
float2 tex

Detailed Description

Definition at line 13 of file BasicShapes.h.

Member Data Documentation

float3 BasicVertex::norm

Definition at line 16 of file BasicShapes.h.

float3 BasicVertex::pos

Definition at line 15 of file BasicShapes.h.

float2 BasicVertex::tex

Definition at line 17 of file BasicShapes.h.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/BasicShapes.h
  • Direct3D HLSL fractal generator/C++/BasicShapes.h
  • Direct3D post-processing effects/C++/BasicShapes.h
  • Direct3D resource loading/C++/BasicShapes.h
  • Direct3D resource loading/C++/obj2vbo/obj2vbo.cpp
  • Direct3D sprite/C++/BasicShapes.h
  • Direct3D stereoscopic 3D/C++/BasicShapes.h
  • Direct3D tutorial/C++/Lesson4.Textures/Main.cpp
  • Direct3D tutorial/C++/Lesson5.Components/BasicShapes.h
  • Direct3D-Direct2D interop/C++/BasicShapes.h
  • DirectX 3D shooting game/C++/BasicShapes.h
  • DirectX marble maze game/C++/BasicShapes.h
  • DirectX postcard app/C++/BasicShapes.h
  • DirectX touch input/C++/BasicShapes.h
  • DXGI offer and reclaim resources/C++/BasicShapes.h
  • DXGI swap chain rotation/C++/BasicShapes.h
  • XAML DirectX 3D shooting game/C++/BasicShapes.h
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Buffer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

Buffer Class Reference

#include "Parse.h"

List of all members.

Public Member Functions

Buffer ()
Buffer ()
~Buffer ()
~Buffer ()
BYTE * | DataPtr ()
BYTE * | DataPtr ()
DWORD | DataSize () const
DWORD | DataSize () const
HRESULT | Initalize (DWORD cbSize)
HRESULT | Initalize (DWORD cbSize)
HRESULT | MoveEnd (DWORD cb)
HRESULT | MoveEnd (DWORD cb)
HRESULT | MoveStart (DWORD cb)
HRESULT | MoveStart (DWORD cb)
HRESULT | Reserve (DWORD cb)
HRESULT | Reserve (DWORD cb)

Private Member Functions

HRESULT | Allocate (DWORD alloc)
HRESULT | Allocate (DWORD alloc)
DWORD | CurrentFreeSize () const
DWORD | CurrentFreeSize () const
BYTE * | Ptr ()
BYTE * | Ptr ()
HRESULT | SetSize (DWORD count)
HRESULT | SetSize (DWORD count)

Private Attributes

DWORD | m_allocated
DWORD | m_begin
DWORD | m_count
DWORD | m_end
BYTE * | m_pArray

Detailed Description

Definition at line 175 of file Parse.h.

Constructor & Destructor Documentation

Buffer::Buffer ( )

Definition at line 95 of file Parse.cpp.

               : m_begin(0), m_end(0), m_count(0), m_allocated(0), m_pArray(NULL)
{
}

Buffer::~Buffer ( ) [inline]

Definition at line 179 of file Parse.h.

    {
        delete [] m_pArray;
    }

Buffer::Buffer ( )
Buffer::~Buffer ( ) [inline]

Definition at line 179 of file Parse.h.

    {
        delete [] m_pArray;
    }

Member Function Documentation

HRESULT Buffer::Allocate ( DWORD alloc ) [private]

Definition at line 143 of file Parse.cpp.

{
    HRESULT hr = S_OK;
    if (alloc > m_allocated)
    {
        BYTE *pTmp = new BYTE[alloc];
        if (pTmp)
        {
            ZeroMemory(pTmp, alloc);

            assert(m_count <= m_allocated);

            // Copy the elements to the re-allocated array.
            for (DWORD i = 0; i < m_count; i++)
            {
                pTmp[i] = m_pArray[i];
            }

            delete [] m_pArray;

            m_pArray = pTmp;
            m_allocated = alloc;
        }
        else
        {
            hr = E_OUTOFMEMORY;
        }
    }
    return hr;
}

HRESULT Buffer::Allocate ( DWORD alloc ) [private]
DWORD Buffer::CurrentFreeSize ( ) const [private]

Definition at line 287 of file Parse.cpp.

{
    assert(m_count >= DataSize());
    return m_count - DataSize();
}

DWORD Buffer::CurrentFreeSize ( ) const [private]
BYTE * Buffer::DataPtr ( )

Definition at line 121 of file Parse.cpp.

{
    return Ptr() + m_begin;
}

BYTE* Buffer::DataPtr ( )
DWORD Buffer::DataSize ( ) const

Definition at line 135 of file Parse.cpp.

{
    assert(m_end >= m_begin);

    return m_end - m_begin;
}

DWORD Buffer::DataSize ( ) const
HRESULT Buffer::Initalize ( DWORD cbSize )

Definition at line 105 of file Parse.cpp.

{
    HRESULT hr = SetSize(cbSize);
    if (SUCCEEDED(hr))
    {
        ZeroMemory(Ptr(), cbSize);
    }
    return hr;
}

HRESULT Buffer::Initalize ( DWORD cbSize )
HRESULT Buffer::MoveEnd ( DWORD cb )
HRESULT Buffer::MoveEnd ( DWORD cb )

Definition at line 267 of file Parse.cpp.

{
    HRESULT hr = S_OK;

    hr = Reserve(cb);

    if (SUCCEEDED(hr))
    {
        m_end += cb;
    }
    return hr;
}

HRESULT Buffer::MoveStart ( DWORD cb )

Definition at line 249 of file Parse.cpp.

{
    // Cannot advance pass the end of the buffer.
    if (cb > DataSize())
    {
        return E_INVALIDARG;
    }

    m_begin += cb;
    return S_OK;
}

HRESULT Buffer::MoveStart ( DWORD cb )
BYTE* Buffer::Ptr ( ) [inline, private]

Definition at line 201 of file Parse.h.

{ return m_pArray; }

BYTE* Buffer::Ptr ( ) [inline, private]

Definition at line 201 of file Parse.h.

{ return m_pArray; }

HRESULT Buffer::Reserve ( DWORD cb )

Definition at line 202 of file Parse.cpp.

{
    if (cb > MAXDWORD - DataSize())
    {
        return E_INVALIDARG; // Overflow
    }

    HRESULT hr = S_OK;

    // If this would push the end position past the end of the array,
    // then we need to copy up the data to start of the array. We might
    // also need to realloc the array.

    if (cb > m_count - m_end)
    {
        // New end position would be past the end of the array.
        // Check if we need to grow the array.

        if (cb > CurrentFreeSize())
        {
            // Array needs to grow
            hr = SetSize(DataSize() + cb);
        }

        if (SUCCEEDED(hr))
        {
            MoveMemory(Ptr(), DataPtr(), DataSize());

            // Reset begin and end.
            m_end = DataSize(); // Update m_end first before resetting m_begin!
            m_begin = 0;
        }
    }

    assert(CurrentFreeSize() >= cb);

    return hr;
}

HRESULT Buffer::Reserve ( DWORD cb )
HRESULT Buffer::SetSize ( DWORD count ) [private]
HRESULT Buffer::SetSize ( DWORD count ) [private]

Definition at line 175 of file Parse.cpp.

{
    assert (m_count <= m_allocated);

    HRESULT hr = S_OK;
    if (count > m_allocated)
    {
        hr = Allocate(count);
    }
    if (SUCCEEDED(hr))
    {
        m_count = count;
    }
    return hr;
}

Member Data Documentation

DWORD Buffer::m_allocated [private]

Definition at line 212 of file Parse.h.

DWORD Buffer::m_begin [private]

Definition at line 214 of file Parse.h.

DWORD Buffer::m_count [private]

Definition at line 211 of file Parse.h.

DWORD Buffer::m_end [private]

Definition at line 215 of file Parse.h.

BYTE * Buffer::m_pArray [private]

Definition at line 210 of file Parse.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.cpp
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BumpMapping Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

BumpMapping Class Reference

#include "BumpMapping.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
void | LoadInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
virtual void | Render () override
void | SaveInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | Update (float TimeTotal, float TimeDelta)

Public Attributes

internal | __pad0__: BumpMapping()

Private Attributes

BasicCamera m_camera
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
LonLatController m_controller
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
unsigned int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_normals
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_normalSampler
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_normalSRV
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_texture
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureSRV
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 26 of file BumpMapping.h.

Member Function Documentation

void BumpMapping::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 30 of file BumpMapping.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Allocate the scene camera.
    m_camera = ref new BasicCamera();

    // Allocate and initialize a controller object.
    m_controller = ref new LonLatController();
    m_controller->Initialize(m_window.Get());
    m_controller->SetPosition(START_POSITION);
}

void BumpMapping::CreateDeviceResources ( ) [override, virtual]

Definition at line 43 of file BumpMapping.cpp.

{
    DirectXBase::CreateDeviceResources();

    // Allocate and initialize the sample header
    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct3D bump mapping sample"
        );

    // Start loading assets
    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    loader->LoadShader(
        L"BumpVertexShader.cso",
        tangentVertexLayoutDesc,
        ARRAYSIZE(tangentVertexLayoutDesc),
        &m_vertexShader,
        &m_inputLayout
        );

    // create the vertex and index buffers for drawing the sphere

    BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());

    shapes->CreateTangentSphere(
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // create the constant buffer for updating model and camera data
    CD3D11_BUFFER_DESC constantBufferDesc(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
        &constantBufferDesc,
        nullptr,             // leave the buffer uninitialized
        &m_constantBuffer
        )
        );

    loader->LoadShader(
        L"BumpPixelShader.cso",
        &m_pixelShader
        );

    loader->LoadTexture(
        L"texture.dds",
        &m_texture,
        &m_textureSRV
        );

    loader->LoadTexture(
        L"normals.dds",
        &m_normals,
        &m_normalSRV
        );

    // create the sampler
    D3D11_SAMPLER_DESC samplerDesc;
    ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
    samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.MipLODBias = 0.0f;
    samplerDesc.MaxAnisotropy = m_featureLevel >= D3D_FEATURE_LEVEL_9_2 ? 4 : 2;
    samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDesc.BorderColor[0] = 0.0f;
    samplerDesc.BorderColor[1] = 0.0f;
    samplerDesc.BorderColor[2] = 0.0f;
    samplerDesc.BorderColor[3] = 0.0f;
    // allow use of all mip levels
    samplerDesc.MinLOD = 0;
    samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
        &samplerDesc,
        &m_sampler)
        );

    // create the normal map sampler
    ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
    samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.MipLODBias = 0.0f;
    samplerDesc.MaxAnisotropy = m_featureLevel >= D3D_FEATURE_LEVEL_9_2 ? 4 : 2;
    samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDesc.BorderColor[0] = 0.0f;
    samplerDesc.BorderColor[1] = 0.0f;
    samplerDesc.BorderColor[2] = 0.0f;
    samplerDesc.BorderColor[3] = 0.0f;
    // allow use of all mip levels
    samplerDesc.MinLOD = 0;
    samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
        &samplerDesc,
        &m_normalSampler)
        );
}

void BumpMapping::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 156 of file BumpMapping.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // specify the 3D projection matrix
    m_camera->SetProjectionParameters(
        70.0f,                                                  // use a 70-degree vertical field of view
        m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
        0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
        100.0f                                                  // specify the farthest Z-distance at which to draw vertices
        );

    // save the new projection matrix to the constant buffer data struct
    m_camera->GetProjectionMatrix(&m_constantBufferData.projection);

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void BumpMapping::LoadInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state )
void BumpMapping::Render ( ) [override, virtual]

Definition at line 174 of file BumpMapping.cpp.

{
    UINT stride = sizeof(TangentVertex);
    UINT offset = 0;

    // bind the render targets
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get());

    // clear both the render target and depth stencil to default values
    const float ClearColor[4] = { 0, 0, 0, 1 };

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        ClearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    // set the vertex and index buffers, and specify the way they define geometry
    m_d3dContext->IASetVertexBuffers(
        0,                              // starting at the first vertex buffer slot
        1,                              // set one vertex buffer binding
        m_vertexBuffer.GetAddressOf(),
        &stride,                        // specify the size in bytes of a single vertex
        &offset                         // specify the base vertex in the buffer
        );

    // set the index buffer
    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,   // unsigned short index format
        0                       // specify the base index in the buffer
        );

    // specify the way the vertex and index buffers define geometry
    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    // set the vertex shader stage state
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                              // starting at the first constant buffer slot
        1,                              // set one constant buffer binding
        m_constantBuffer.GetAddressOf()
        );

    // set the pixel shader stage state
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    // first put the two surfaces into an array
    ID3D11ShaderResourceView* shaderResourceViews[] = {
        m_textureSRV.Get(),
        m_normalSRV.Get()
    };

    // then bind them to the device
    m_d3dContext->PSSetShaderResources(
        0,                          // starting at the first shader resource slot
        2,                          // bind 2 shader resources
        shaderResourceViews
        );

    // then put the two samplers into an array
    ID3D11SamplerState* samplers[] = {
        m_sampler.Get(),
        m_normalSampler.Get()
    };

    // and bind them to the device
    m_d3dContext->PSSetSamplers(
        0,                          // starting at the first sampler slot
        2,                          // bind 2 shader resources
        samplers
        );

    // draw the mesh
    m_d3dContext->DrawIndexed(
        m_indexCount,   // draw all created vertices
        0,              // starting with the first vertex
        0               // and the first index
        );

    m_sampleOverlay->Render();

}

void BumpMapping::SaveInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state )
void BumpMapping::Update | ( | float | TimeTotal,
 |  | float | TimeDelta
 | ) |  |

Definition at line 278 of file BumpMapping.cpp.

{
    // update the model matrix based on the time
    m_constantBufferData.model = rotationY(TimeTotal * 10.0f);

    m_controller->Update(m_window.Get());

    // update the view matrix based on the camera position
    m_camera->SetViewParameters(
        m_controller->get_Position(),       // point we are at
        m_controller->get_LookPoint(),      // point to look towards
        float3(0, 1, 0)                     // up-vector  (+Y)
        );

    // get the camera transform for transmission to the GPU
    m_camera->GetViewMatrix(&m_constantBufferData.view);

    // update the constant buffer with the new data
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_constantBufferData,
        0,
        0
        );
}

Member Data Documentation

internal BumpMapping::__pad0__

Definition at line 29 of file BumpMapping.h.

BasicCamera BumpMapping::m_camera [private]

Definition at line 59 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> BumpMapping::m_constantBuffer [private]

Definition at line 55 of file BumpMapping.h.

ConstantBuffer BumpMapping::m_constantBufferData [private]

Definition at line 58 of file BumpMapping.h.

LonLatController BumpMapping::m_controller [private]

Definition at line 60 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> BumpMapping::m_indexBuffer [private]

Definition at line 46 of file BumpMapping.h.

unsigned int BumpMapping::m_indexCount [private]

Definition at line 57 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> BumpMapping::m_inputLayout [private]

Definition at line 44 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> BumpMapping::m_normals [private]

Definition at line 52 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> BumpMapping::m_normalSampler [private]

Definition at line 54 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> BumpMapping::m_normalSRV [private]

Definition at line 53 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> BumpMapping::m_pixelShader [private]

Definition at line 48 of file BumpMapping.h.

SampleOverlay BumpMapping::m_sampleOverlay [private]

Definition at line 42 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> BumpMapping::m_sampler [private]

Definition at line 51 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> BumpMapping::m_texture [private]

Definition at line 49 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> BumpMapping::m_textureSRV [private]

Definition at line 50 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> BumpMapping::m_vertexBuffer [private]

Definition at line 45 of file BumpMapping.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> BumpMapping::m_vertexShader [private]

Definition at line 47 of file BumpMapping.h.

The documentation for this class was generated from the following files:
  • Direct3D bump mapping/C++/BumpMapping.h
  • Direct3D bump mapping/C++/BumpMapping.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Camera Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Camera Class Reference

#include "Camera.h"

List of all members.

Public Member Functions

void | Eye (_In_ DirectX::XMFLOAT3 position)
DirectX::XMFLOAT3 | Eye ()
void | Eye (_In_ DirectX::XMFLOAT3 position)
DirectX::XMFLOAT3 | Eye ()
float | FarClipPlane ()
float | FarClipPlane ()
DirectX::XMMATRIX | LeftEyeProjection ()
DirectX::XMMATRIX | LeftEyeProjection ()
DirectX::XMFLOAT3 | LookAt ()
DirectX::XMFLOAT3 | LookAt ()
void | LookDirection (_In_ DirectX::XMFLOAT3 lookDirection)
void | LookDirection (_In_ DirectX::XMFLOAT3 lookDirection)
float | NearClipPlane ()
float | NearClipPlane ()
float | Pitch ()
float | Pitch ()
DirectX::XMMATRIX | Projection ()
DirectX::XMMATRIX | Projection ()
DirectX::XMMATRIX | RightEyeProjection ()
DirectX::XMMATRIX | RightEyeProjection ()
void | SetProjParams (_In_ float fieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetProjParams (_In_ float fieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetViewParams (_In_ DirectX::XMFLOAT3 eye, _In_ DirectX::XMFLOAT3 lookAt, _In_ DirectX::XMFLOAT3 up)
void | SetViewParams (_In_ DirectX::XMFLOAT3 eye, _In_ DirectX::XMFLOAT3 lookAt, _In_ DirectX::XMFLOAT3 up)
DirectX::XMFLOAT3 | Up ()
DirectX::XMFLOAT3 | Up ()
DirectX::XMMATRIX | View ()
DirectX::XMMATRIX | View ()
DirectX::XMMATRIX | World ()
DirectX::XMMATRIX | World ()
float | Yaw ()
float | Yaw ()

Public Attributes

internal | __pad0__: Camera()

Private Member Functions

void | GetProjectionMatrix (_Out_ float4x4 *projectionMatrix)
void | SetProjectionParameters (_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane)
void | SetViewParameters (_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up)

Private Attributes

float | m_aspectRatio
float | m_cameraPitchAngle
float | m_cameraYawAngle
float3 m_direction
DirectX::XMFLOAT3 | m_eye
float | m_farPlane
float | m_fieldOfView
DirectX::XMFLOAT4X4 | m_inverseView
DirectX::XMFLOAT3 | m_lookAt
float | m_nearPlane
float3 m_position
float4x4 m_projection
DirectX::XMFLOAT4X4 | m_projectionMatrix
DirectX::XMFLOAT4X4 | m_projectionMatrixLeft
DirectX::XMFLOAT4X4 | m_projectionMatrixRight
DirectX::XMFLOAT3 | m_up
float4x4 m_view
DirectX::XMFLOAT4X4 | m_viewMatrix

Detailed Description

Definition at line 15 of file Camera.h.

Member Function Documentation

void Camera::Eye ( _In_ DirectX::XMFLOAT3 position )
DirectX::XMFLOAT3 Camera::Eye ( )

Definition at line 177 of file Camera.cpp.

{
    return m_eye;
}

void Camera::Eye ( _In_ DirectX::XMFLOAT3 position )
DirectX::XMFLOAT3 Camera::Eye ( )
float Camera::FarClipPlane ( )
float Camera::FarClipPlane ( )

Definition at line 198 of file Camera.cpp.

{
    return m_farPlane;
}

void Camera::GetProjectionMatrix ( _Out_ float4x4 * projectionMatrix ) [private]

Definition at line 17 of file Camera.cpp.

{
    *projectionMatrix = m_projection;
}

DirectX::XMMATRIX Camera::LeftEyeProjection ( )
DirectX::XMMATRIX Camera::LeftEyeProjection ( )

Definition at line 156 of file Camera.cpp.

{
    return XMLoadFloat4x4(&m_projectionMatrixLeft);
}

DirectX::XMFLOAT3 Camera::LookAt ( )

Definition at line 184 of file Camera.cpp.

{
    return m_lookAt;
}

DirectX::XMFLOAT3 Camera::LookAt ( )
void Camera::LookDirection ( _In_ DirectX::XMFLOAT3 lookDirection )
void Camera::LookDirection ( _In_ DirectX::XMFLOAT3 lookDirection )
float Camera::NearClipPlane ( )
float Camera::NearClipPlane ( )

Definition at line 191 of file Camera.cpp.

{
    return m_nearPlane;
}

float Camera::Pitch ( )
float Camera::Pitch ( )

Definition at line 205 of file Camera.cpp.

{
    return m_cameraPitchAngle;
}

DirectX::XMMATRIX Camera::Projection ( )
DirectX::XMMATRIX Camera::Projection ( )

Definition at line 149 of file Camera.cpp.

{
    return XMLoadFloat4x4(&m_projectionMatrix);
}

DirectX::XMMATRIX Camera::RightEyeProjection ( )

Definition at line 163 of file Camera.cpp.

{
    return XMLoadFloat4x4(&m_projectionMatrixRight);
}

DirectX::XMMATRIX Camera::RightEyeProjection ( )
void Camera::SetProjectionParameters | ( | _In_ float | minimumFieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane |
 | ) |  |  | [private]

Definition at line 45 of file Camera.cpp.

{
    float minScale = 1.0f / tan(minimumFieldOfView * PI_F / 360.0f);
    float xScale = 1.0f;
    float yScale = 1.0f;
    if (aspectRatio < 1.0f)
    {
        xScale = minScale;
        yScale = minScale * aspectRatio;
    }
    else
    {
        xScale = minScale / aspectRatio;
        yScale = minScale;
    }
    float zScale = farPlane / (farPlane - nearPlane);
    m_projection = float4x4(
        xScale, 0.0f,   0.0f,    0.0f,
        0.0f,   yScale, 0.0f,    0.0f,
        0.0f,   0.0f,   zScale, -nearPlane*zScale,
        0.0f,   0.0f,   1.0f,    0.0f
        );
}

void Camera::SetProjParams | ( | _In_ float | fieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane
 | ) |  |
void Camera::SetProjParams | ( | _In_ float | fieldOfView,
 |  | _In_ float | aspectRatio,
 |  | _In_ float | nearPlane,
 |  | _In_ float | farPlane
 | ) |  |

Definition at line 89 of file Camera.cpp.

{
    // Set attributes for the projection matrix.
    m_fieldOfView = fieldOfView;
    m_aspectRatio = aspectRatio;
    m_nearPlane = nearPlane;
    m_farPlane = farPlane;
    XMStoreFloat4x4(
        &m_projectionMatrix,
        XMMatrixPerspectiveFovLH(
            m_fieldOfView,
            m_aspectRatio,
            m_nearPlane,
            m_farPlane
            )
        );

    STEREO_PARAMETERS* stereoParams = nullptr;
    // Update the projection matrix.
    XMStoreFloat4x4(
        &m_projectionMatrixLeft,
        MatrixStereoProjectionFovLH(
            stereoParams,
            STEREO_CHANNEL::LEFT,
            m_fieldOfView,
            m_aspectRatio,
            m_nearPlane,
            m_farPlane,
            STEREO_MODE::NORMAL
            )
        );

    XMStoreFloat4x4(
        &m_projectionMatrixRight,
        MatrixStereoProjectionFovLH(
            stereoParams,
            STEREO_CHANNEL::RIGHT,
            m_fieldOfView,
            m_aspectRatio,
            m_nearPlane,
            m_farPlane,
            STEREO_MODE::NORMAL
            )
        );
}

void Camera::SetViewParameters | ( | _In_ float3 | eyePosition,
 |  | _In_ float3 | lookPosition,
 |  | _In_ float3 | up |
 | ) |  |  | [private]

Definition at line 23 of file Camera.cpp.

{
    m_position = eyePosition;
    m_direction = normalize(lookPosition - eyePosition);
    float3 zAxis = m_direction;
    float3 xAxis = normalize(cross(up, zAxis));
    float3 yAxis = cross(zAxis, xAxis);
    float xOffset = -dot(xAxis, m_position);
    float yOffset = -dot(yAxis, m_position);
    float zOffset = -dot(zAxis, m_position);
    m_view = float4x4(
        xAxis.x, xAxis.y, xAxis.z, xOffset,
        yAxis.x, yAxis.y, yAxis.z, yOffset,
        zAxis.x, zAxis.y, zAxis.z, zOffset,
        0.0f,    0.0f,    0.0f,    1.0f
        );
}

void Camera::SetViewParams | ( | _In_ DirectX::XMFLOAT3 | eye,
 |  | _In_ DirectX::XMFLOAT3 | lookAt,
 |  | _In_ DirectX::XMFLOAT3 | up
 | ) |  |
void Camera::SetViewParams | ( | _In_ DirectX::XMFLOAT3 | eye,
 |  | _In_ DirectX::XMFLOAT3 | lookAt,
 |  | _In_ DirectX::XMFLOAT3 | up
 | ) |  |
DirectX::XMFLOAT3 Camera::Up ( )
DirectX::XMFLOAT3 Camera::Up ( )
DirectX::XMMATRIX Camera::View ( )

Definition at line 142 of file Camera.cpp.

{
    return XMLoadFloat4x4(&m_viewMatrix);
}

DirectX::XMMATRIX Camera::View ( )
DirectX::XMMATRIX Camera::World ( )
DirectX::XMMATRIX Camera::World ( )

Definition at line 170 of file Camera.cpp.

{
    return XMLoadFloat4x4(&m_inverseView);
}

float Camera::Yaw ( )
float Camera::Yaw ( )

Definition at line 212 of file Camera.cpp.

{
    return m_cameraYawAngle;
}

Member Data Documentation

internal Camera::__pad0__

Definition at line 18 of file Camera.h.

float Camera::m_aspectRatio [private]

Definition at line 54 of file Camera.h.

float Camera::m_cameraPitchAngle [private]

Definition at line 51 of file Camera.h.

float Camera::m_cameraYawAngle [private]

Definition at line 50 of file Camera.h.

float3 Camera::m_direction [private]

Definition at line 18 of file Camera.h.

DirectX::XMFLOAT3 Camera::m_eye [private]

Definition at line 47 of file Camera.h.

float Camera::m_farPlane [private]

Definition at line 56 of file Camera.h.

float Camera::m_fieldOfView [private]

Definition at line 53 of file Camera.h.

DirectX::XMFLOAT4X4 Camera::m_inverseView [private]

Definition at line 45 of file Camera.h.

DirectX::XMFLOAT3 Camera::m_lookAt [private]

Definition at line 48 of file Camera.h.

float Camera::m_nearPlane [private]

Definition at line 55 of file Camera.h.

float3 Camera::m_position [private]

Definition at line 17 of file Camera.h.

float4x4 Camera::m_projection [private]

Definition at line 20 of file Camera.h.

DirectX::XMFLOAT4X4 Camera::m_projectionMatrix [private]

Definition at line 41 of file Camera.h.

DirectX::XMFLOAT4X4 Camera::m_projectionMatrixLeft [private]

Definition at line 42 of file Camera.h.

DirectX::XMFLOAT4X4 Camera::m_projectionMatrixRight [private]

Definition at line 43 of file Camera.h.

DirectX::XMFLOAT3 Camera::m_up [private]

Definition at line 49 of file Camera.h.

float4x4 Camera::m_view [private]

Definition at line 19 of file Camera.h.

DirectX::XMFLOAT4X4 Camera::m_viewMatrix [private]

Definition at line 40 of file Camera.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Camera.h
  • DirectX marble maze game/C++/Camera.h
  • XAML DirectX 3D shooting game/C++/Camera.h
  • DirectX 3D shooting game/C++/Camera.cpp
  • DirectX marble maze game/C++/Camera.cpp
  • XAML DirectX 3D shooting game/C++/Camera.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CAppWindowProvider Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes | Private Member Functions

CAppWindowProvider Class Reference

List of all members.

Public Member Functions

CAppWindowProvider ()
IFACEMETHODIMP | AdviseEventAdded (_In_ EVENTID eventId, _In_ SAFEARRAY *propertyIDs)
IFACEMETHODIMP | AdviseEventRemoved (_In_ EVENTID eventId, _In_ SAFEARRAY *propertyIDs)
IFACEMETHODIMP | Disconnect ()
IFACEMETHODIMP | ElementProviderFromPoint (_In_ double x, _In_ double y, _Outptr_result_maybenull_ IRawElementProviderFragment **retVal)
IFACEMETHODIMP | get_BoundingRectangle (_Out_ UiaRect *retVal)
IFACEMETHODIMP | get_FragmentRoot (_Outptr_result_maybenull_ IRawElementProviderFragmentRoot **retVal)
IFACEMETHODIMP | get_HostRawElementProvider (_Outptr_result_maybenull_ IRawElementProviderSimple **retVal)
IFACEMETHODIMP | get_ProviderOptions (_Out_ ProviderOptions *retVal)
IFACEMETHODIMP | GetEmbeddedFragmentRoots (_Outptr_result_maybenull_ SAFEARRAY **retVal)
IFACEMETHODIMP | GetFocus (_Outptr_result_maybenull_ IRawElementProviderFragment **retVal)
IFACEMETHODIMP | GetPatternProvider (_In_ PATTERNID iid, _Outptr_result_maybenull_ IUnknown **retVal)
IFACEMETHODIMP | GetPropertyValue (_In_ PROPERTYID idProp, _Out_ VARIANT *retVal)
IFACEMETHODIMP | GetRuntimeId (_Outptr_result_maybenull_ SAFEARRAY **retVal)
IFACEMETHODIMP | Initialize (_In_ ITriColorControlInternal *pControl, _In_ IInspectable *pWindow)
IFACEMETHODIMP | Navigate (_In_ NavigateDirection direction, _Outptr_result_maybenull_ IRawElementProviderFragment **retVal)
IFACEMETHODIMP | SetFocus ()

Protected Member Functions

HRESULT | CheckDisconnected ()

Protected Attributes

Microsoft::WRL::ComPtr
< ITriColorControlInternal > 		m_control
BOOL | m_disconnected
Microsoft::WRL::ComPtr
< ABI::Windows::UI::Core::ICoreWindow > 		m_window

Private Member Functions

InspectableClass (RuntimeClass_UiaCoreWindowProvider_AppWindowProvider, BaseTrust)

Detailed Description

Definition at line 28 of file AppWindowProvider.cpp.

Constructor & Destructor Documentation

CAppWindowProvider::CAppWindowProvider ( )

Definition at line 88 of file AppWindowProvider.cpp.

    : m_disconnected(FALSE)
{
}

Member Function Documentation

IFACEMETHODIMP CAppWindowProvider::AdviseEventAdded | ( | _In_ EVENTID | eventId,
 |  | _In_ SAFEARRAY * | propertyIDs
 | ) |  |

Definition at line 311 of file AppWindowProvider.cpp.

{
    return S_OK;
}

IFACEMETHODIMP CAppWindowProvider::AdviseEventRemoved | ( | _In_ EVENTID | eventId,
 |  | _In_ SAFEARRAY * | propertyIDs
 | ) |  |

Definition at line 317 of file AppWindowProvider.cpp.

{
    return S_OK;
}

HRESULT CAppWindowProvider::CheckDisconnected ( ) [protected]

Definition at line 334 of file AppWindowProvider.cpp.

{
    return (m_disconnected) ? UIA_E_ELEMENTNOTAVAILABLE : S_OK;
}

IFACEMETHODIMP CAppWindowProvider::Disconnect ( )

Definition at line 326 of file AppWindowProvider.cpp.

{
    // Disconnect and drop our back reference
    m_disconnected = TRUE;
    m_window = nullptr;
    return S_OK;
}

IFACEMETHODIMP CAppWindowProvider::ElementProviderFromPoint | ( | _In_ double | x,
 |  | _In_ double | y,
 |  | _Outptr_result_maybenull_ IRawElementProviderFragment ** | retVal
 | ) |  |

Definition at line 260 of file AppWindowProvider.cpp.

{
    *retVal = nullptr;
    HRESULT hr = CheckDisconnected();
    if (SUCCEEDED(hr))
    {
        ABI::Windows::Foundation::Point pt = { static_cast<float>(x), static_cast<float>(y) };

        // Did we hit a color region?
        TriColorValue value;
        if (SUCCEEDED(m_control->ValueFromPoint(pt, &value)))
        {
            // Return the color region
            ComPtr<IInspectable> spFragmentProvider;
            hr = m_control->GetTriColorFragmentProvider(value, &spFragmentProvider);
            if (SUCCEEDED(hr))
            {
                hr = spFragmentProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
            }
        }
        // Otherwise, we just hit the app window itself, and we don't need to do anything for that;
        // nullptr is the correct response.
    }

    return hr;
}

IFACEMETHODIMP CAppWindowProvider::get_BoundingRectangle ( _Out_ UiaRect * retVal )

Definition at line 223 of file AppWindowProvider.cpp.

{
    ZeroMemory(retVal, sizeof(*retVal));

    // UIA implements this method on behalf of the root window
    return CheckDisconnected();
}

IFACEMETHODIMP CAppWindowProvider::get_FragmentRoot ( _Outptr_result_maybenull_ IRawElementProviderFragmentRoot ** retVal )

Definition at line 245 of file AppWindowProvider.cpp.

{
    *retVal = nullptr;
    HRESULT hr = CheckDisconnected();
    if (SUCCEEDED(hr))
    {
        return QueryInterface(IID_PPV_ARGS(retVal));
    }
    return hr;
}

IFACEMETHODIMP CAppWindowProvider::get_HostRawElementProvider ( _Outptr_result_maybenull_ IRawElementProviderSimple ** retVal )

Definition at line 175 of file AppWindowProvider.cpp.

{
    *ppRetVal = nullptr;
    if (m_window != nullptr)
    {
        IInspectable *pHostAsInspectable = nullptr;
        if (SUCCEEDED(m_window->get_AutomationHostProvider(&pHostAsInspectable)))
        {
            pHostAsInspectable->QueryInterface(ppRetVal);
            pHostAsInspectable->Release();
        }
    }
    return S_OK;
}

IFACEMETHODIMP CAppWindowProvider::get_ProviderOptions ( _Out_ ProviderOptions * retVal )

Definition at line 107 of file AppWindowProvider.cpp.

{
    *pRetVal = ProviderOptions_ServerSideProvider |
               ProviderOptions_UseComThreading |
               ProviderOptions_UseClientCoordinates;
    return S_OK;
}

IFACEMETHODIMP CAppWindowProvider::GetEmbeddedFragmentRoots ( _Outptr_result_maybenull_ SAFEARRAY ** retVal )

Definition at line 231 of file AppWindowProvider.cpp.

{
    *retVal = nullptr;

    // We don't have any embedded fragment roots
    return CheckDisconnected();
}

IFACEMETHODIMP CAppWindowProvider::GetFocus ( _Outptr_result_maybenull_ IRawElementProviderFragment ** retVal )

Definition at line 287 of file AppWindowProvider.cpp.

{
    *retVal = nullptr;
    HRESULT hr = CheckDisconnected();
    if (SUCCEEDED(hr))
    {
        // If we are being asked the question at all, then this window must already have focus.
        // In that case, the focused provider is always the control.
        ComPtr<IInspectable> spControlProvider;
        hr = m_control->GetTriColorControlProvider(&spControlProvider);
        if (SUCCEEDED(hr))
        {
            hr = spControlProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
        }
    }

    return hr;
}

IFACEMETHODIMP CAppWindowProvider::GetPatternProvider | ( | _In_ PATTERNID | iid,
 |  | _Outptr_result_maybenull_ IUnknown ** | retVal
 | ) |  |

Definition at line 115 of file AppWindowProvider.cpp.

{
    *ppRetVal = nullptr;
    return CheckDisconnected();
}

IFACEMETHODIMP CAppWindowProvider::GetPropertyValue | ( | _In_ PROPERTYID | idProp,
 |  | _Out_ VARIANT * | retVal
 | ) |  |

Definition at line 121 of file AppWindowProvider.cpp.

{
    pRetVal->vt = VT_EMPTY;
    HRESULT hr = CheckDisconnected();
    if (SUCCEEDED(hr))
    {
        switch (idProp)
        {
        case UIA_ProviderDescriptionPropertyId:
            pRetVal->bstrVal = SysAllocString(L"CAppWindowProvider");
            if (pRetVal->bstrVal != nullptr)
            {
                pRetVal->vt = VT_BSTR;
            }
            break;

        // case UIA_NamePropertyId:
        // The Name property is deliberately not set.
        // Names for Metro-style applications are set from their manifests.
        // Setting a name here would be confusing and redundant.

        case UIA_AutomationIdPropertyId:
            pRetVal->bstrVal = SysAllocString(L"CAppWindowProvider0001");
            if (pRetVal->bstrVal != nullptr)
            {
                pRetVal->vt = VT_BSTR;
            }
            break;

        case UIA_IsPasswordPropertyId:
            pRetVal->vt = VT_BOOL;
            pRetVal->boolVal = VARIANT_FALSE;
            break;

        case UIA_ControlTypePropertyId:
            pRetVal->vt = VT_I4;
            pRetVal->lVal = UIA_WindowControlTypeId;
            break;

        case UIA_HasKeyboardFocusPropertyId:
            hr = m_control->get_HasFocus(&pRetVal->boolVal);
            if (SUCCEEDED(hr))
            {
                pRetVal->vt = VT_BOOL;
            }
            break;
        }
    }
    return hr;
}

IFACEMETHODIMP CAppWindowProvider::GetRuntimeId ( _Outptr_result_maybenull_ SAFEARRAY ** retVal )

Definition at line 215 of file AppWindowProvider.cpp.

{
    *retVal = nullptr;

    // UIA implements this method on behalf of the root window
    return CheckDisconnected();
}

IFACEMETHODIMP CAppWindowProvider::Initialize | ( | _In_ ITriColorControlInternal * | pControl,
 |  | _In_ IInspectable * | pWindow
 | ) |  |

Definition at line 97 of file AppWindowProvider.cpp.

{
    m_control = pControl;
    return pWindow->QueryInterface(IID_PPV_ARGS(&m_window));
}

CAppWindowProvider::InspectableClass | ( | RuntimeClass_UiaCoreWindowProvider_AppWindowProvider | ,
 |  | BaseTrust |  |
 | ) |  |  | [private]
IFACEMETHODIMP CAppWindowProvider::Navigate | ( | _In_ NavigateDirection | direction,
 |  | _Outptr_result_maybenull_ IRawElementProviderFragment ** | retVal
 | ) |  |

Definition at line 194 of file AppWindowProvider.cpp.

{
    *retVal = nullptr;
    HRESULT hr = CheckDisconnected();
    if (SUCCEEDED(hr))
    {
        if (direction == NavigateDirection_FirstChild || direction == NavigateDirection_LastChild)
        {
            ComPtr<IInspectable> spControlProvider;
            hr = m_control->GetTriColorControlProvider(&spControlProvider);
            if (SUCCEEDED(hr))
            {
                hr = spControlProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
            }
        }
    }

    // For the other directions (parent, next, previous) the default of nullptr is correct
    return hr;
}

IFACEMETHODIMP CAppWindowProvider::SetFocus ( )

Definition at line 239 of file AppWindowProvider.cpp.

{
    // UIA implements this method on behalf of the root window
    return CheckDisconnected();
}

Member Data Documentation

Microsoft::WRL::ComPtr<ITriColorControlInternal> CAppWindowProvider::m_control [protected]

Definition at line 82 of file AppWindowProvider.cpp.

BOOL CAppWindowProvider::m_disconnected [protected]

Definition at line 85 of file AppWindowProvider.cpp.

Microsoft::WRL::ComPtr<ABI::Windows::UI::Core::ICoreWindow> CAppWindowProvider::m_window [protected]

Definition at line 79 of file AppWindowProvider.cpp.

The documentation for this class was generated from the following file:
  • UI Automation core window provider/C++/AppWindowProvider.cpp
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CAsyncState Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions

CAsyncState Class Reference

#include "Common.h"

List of all members.

Public Member Functions

CAsyncState (Platform::Array< int, 1 >^data, UINT32 size)

Public Attributes

Platform::Array< int, 1 > | m_Data
UINT32 | m_Size

Private Member Functions

virtual | ~CAsyncState ()

Detailed Description

Definition at line 116 of file Common.h.

Constructor & Destructor Documentation

CAsyncState::CAsyncState | ( | Platform::Array< int, 1 >^ | data,
 |  | UINT32 | size |
 | ) |  |  | [inline]

Definition at line 120 of file Common.h.

                                                           :
        m_Data(data),
        m_Size(size)
    {
    };

virtual CAsyncState::~CAsyncState ( ) [inline, private, virtual]

Definition at line 131 of file Common.h.

{};

Member Data Documentation

Platform::Array<int,1> CAsyncState::m_Data

Definition at line 124 of file Common.h.

UINT32 CAsyncState::m_Size

Definition at line 128 of file Common.h.

The documentation for this class was generated from the following file:
  • Windows Audio Session (WASAPI)/C++/Common.h
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CAutoDXDevLockBase< DevManager, DevInterface > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes

CAutoDXDevLockBase< DevManager, DevInterface > Class Template Reference

#include "d3dmanagerlock.hxx"

List of all members.

Public Member Functions

CAutoDXDevLockBase (_In_ Microsoft::WRL::ComPtr< DevManager > spDevManager)
~CAutoDXDevLockBase ()
virtual HRESULT | LockDevice (_Out_ Microsoft::WRL::ComPtr< DevInterface > &spDev)=0

Protected Attributes

HANDLE | m_hDev
bool | m_locked
Microsoft::WRL::ComPtr
< DevManager > 		m_spDevManager

Detailed Description

template<class DevManager, class DevInterface>
class CAutoDXDevLockBase< DevManager, DevInterface >

Definition at line 19 of file d3dmanagerlock.hxx.

Constructor & Destructor Documentation

template<class DevManager, class DevInterface>
CAutoDXDevLockBase< DevManager, DevInterface >::CAutoDXDevLockBase ( _In_ Microsoft::WRL::ComPtr< DevManager > spDevManager ) [inline]

Definition at line 34 of file d3dmanagerlock.hxx.

          :
        m_locked(false),
        m_hDev(NULL),
        m_spDevManager(spDevManager)
    {
        m_spDevManager->OpenDeviceHandle(&m_hDev);
    }

template<class DevManager, class DevInterface>
CAutoDXDevLockBase< DevManager, DevInterface >::~CAutoDXDevLockBase ( ) [inline]

Definition at line 51 of file d3dmanagerlock.hxx.

    {
        if (m_hDev != NULL)
        {
            if (m_locked)
            {
                m_spDevManager->UnlockDevice(m_hDev, FALSE);
            }
            m_spDevManager->CloseDeviceHandle(m_hDev);
        }
    }

Member Function Documentation

template<class DevManager, class DevInterface>
virtual HRESULT CAutoDXDevLockBase< DevManager, DevInterface >::LockDevice ( _Out_ Microsoft::WRL::ComPtr< DevInterface > & spDev ) [pure virtual]

Implemented in CAutoDXGILock.

Member Data Documentation

template<class DevManager, class DevInterface>
HANDLE CAutoDXDevLockBase< DevManager, DevInterface >::m_hDev [protected]

Definition at line 23 of file d3dmanagerlock.hxx.

template<class DevManager, class DevInterface>
bool CAutoDXDevLockBase< DevManager, DevInterface >::m_locked [protected]

Definition at line 24 of file d3dmanagerlock.hxx.

template<class DevManager, class DevInterface>
Microsoft::WRL::ComPtr<DevManager> CAutoDXDevLockBase< DevManager, DevInterface >::m_spDevManager [protected]

Definition at line 22 of file d3dmanagerlock.hxx.

The documentation for this class was generated from the following file:
  • Media engine native C++ video playback/C++/d3dmanagerlock.hxx
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CAutoDXGILock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

CAutoDXGILock Class Reference

#include "d3dmanagerlock.hxx"

Inherits CAutoDXDevLockBase< IMFDXGIDeviceManager, ID3D11Device >.

List of all members.

Public Member Functions

CAutoDXGILock (_In_ Microsoft::WRL::ComPtr< IMFDXGIDeviceManager > spDevManager)
HRESULT LockDevice (_Out_ Microsoft::WRL::ComPtr< ID3D11Device > &spDev)

Detailed Description

Definition at line 75 of file d3dmanagerlock.hxx.

Constructor & Destructor Documentation

CAutoDXGILock::CAutoDXGILock ( _In_ Microsoft::WRL::ComPtr< IMFDXGIDeviceManager > spDevManager ) [inline]

Definition at line 79 of file d3dmanagerlock.hxx.

                                                                              :
        CAutoDXDevLockBase(spDevManager)
    {}

Member Function Documentation

HRESULT CAutoDXGILock::LockDevice ( _Out_ Microsoft::WRL::ComPtr< ID3D11Device > & spDev ) [inline, virtual]

Implements CAutoDXDevLockBase< IMFDXGIDeviceManager, ID3D11Device >.

Definition at line 83 of file d3dmanagerlock.hxx.

    {
    HRESULT hr = S_OK;

        if (m_locked)
        {
            hr = E_FAIL;
        }

        MEDIA::ThrowIfFailed(
      m_spDevManager->LockDevice(
      m_hDev,
      __uuidof(ID3D11Device),
      &spDev,
      TRUE)
      );

        m_locked = true;

        return hr;
    }

The documentation for this class was generated from the following file:
  • Media engine native C++ video playback/C++/d3dmanagerlock.hxx
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CCopyModule Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Private Member Functions

CCopyModule Class Reference

#include "CopyModule.h"

List of all members.

Private Member Functions

virtual HRESULT | Initialize (ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight)
virtual HRESULT | Initialize (ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight)
virtual void | Invalidate ()
virtual void | Invalidate ()
virtual HRESULT | ProcessFrame (ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex)
virtual HRESULT | ProcessFrame (ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex)

Detailed Description

Definition at line 5 of file CopyModule.h.

Member Function Documentation

virtual HRESULT CCopyModule::Initialize | ( | ID3D11Device * | pDevice,
 |  | UINT | uiWidth,
 |  | UINT | uiHeight |
 | ) |  |  | [inline, private, virtual]

Definition at line 9 of file CopyModule.h.

{ return S_OK; }

virtual HRESULT CCopyModule::Initialize | ( | ID3D11Device * | pDevice,
 |  | UINT | uiWidth,
 |  | UINT | uiHeight |
 | ) |  |  | [inline, private, virtual]

Definition at line 9 of file CopyModule.h.

{ return S_OK; }

virtual void CCopyModule::Invalidate ( ) [inline, private, virtual]

Definition at line 7 of file CopyModule.h.

{}

virtual void CCopyModule::Invalidate ( ) [inline, private, virtual]

Definition at line 7 of file CopyModule.h.

{}

virtual HRESULT CCopyModule::ProcessFrame | ( | ID3D11Device * | pDevice,
 |  | ID3D11Texture2D * | pInput,
 |  | UINT | uiInIndex,
 |  | ID3D11Texture2D * | pOutput,
 |  | UINT | uiOutIndex |
 | ) |  |  | [inline, private, virtual]

Definition at line 11 of file CopyModule.h.

    {
        ComPtr<ID3D11DeviceContext> pContext;
        pDevice->GetImmediateContext(&pContext);

        pContext->CopySubresourceRegion(pOutput, uiOutIndex, 0, 0, 0, pInput, uiInIndex, NULL);

        return S_OK;
    }

virtual HRESULT CCopyModule::ProcessFrame | ( | ID3D11Device * | pDevice,
 |  | ID3D11Texture2D * | pInput,
 |  | UINT | uiInIndex,
 |  | ID3D11Texture2D * | pOutput,
 |  | UINT | uiOutIndex |
 | ) |  |  | [inline, private, virtual]

Definition at line 11 of file CopyModule.h.

    {
        ComPtr<ID3D11DeviceContext> pContext;
        pDevice->GetImmediateContext(&pContext);

        pContext->CopySubresourceRegion(pOutput, uiOutIndex, 0, 0, 0, pInput, uiInIndex, NULL);

        return S_OK;
    }

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Invert/CopyModule.h
  • Media extensions/C++/MediaExtensions/Invert/CopyModule.h
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CDecoder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Protected Member Functions | Protected Attributes | Private Member Functions

CDecoder Class Reference

#include "decoder.h"

List of all members.

Protected Member Functions

HRESULT | AllocateStreamingResources ()
HRESULT | AllocateStreamingResources ()
HRESULT | FreeStreamingResources ()
HRESULT | FreeStreamingResources ()
BOOL | HasPendingOutput () const
BOOL | HasPendingOutput () const
HRESULT | InternalProcessOutput (IMFSample *pSample, IMFMediaBuffer *pOutputBuffer)
HRESULT | InternalProcessOutput (IMFSample *pSample, IMFMediaBuffer *pOutputBuffer)
BOOL | IsValidInputStream (DWORD dwInputStreamID) const
BOOL | IsValidInputStream (DWORD dwInputStreamID) const
BOOL | IsValidOutputStream (DWORD dwOutputStreamID) const
BOOL | IsValidOutputStream (DWORD dwOutputStreamID) const
HRESULT | OnCheckInputType (IMFMediaType *pmt)
HRESULT | OnCheckInputType (IMFMediaType *pmt)
HRESULT | OnCheckOutputType (IMFMediaType *pmt)
HRESULT | OnCheckOutputType (IMFMediaType *pmt)
HRESULT | OnDiscontinuity ()
HRESULT | OnDiscontinuity ()
HRESULT | OnFlush ()
HRESULT | OnFlush ()
HRESULT | OnSetInputType (IMFMediaType *pmt)
HRESULT | OnSetInputType (IMFMediaType *pmt)
HRESULT | OnSetOutputType (IMFMediaType *pmt)
HRESULT | OnSetOutputType (IMFMediaType *pmt)
HRESULT | Process ()
HRESULT | Process ()

Protected Attributes

bool | m_bLowLatencyMode
bool | m_bPicture
DWORD | m_cbData
DWORD | m_cbImageSize
CRITICAL_SECTION | m_critSec
MFRatio | m_frameRate
UINT32 | m_imageHeightInPixels
UINT32 | m_imageWidthInPixels
BYTE * | m_pbData
IMFMediaBuffer * | m_pBuffer
IMFMediaType * | m_pInputType
IMFMediaType * | m_pOutputType
REFERENCE_TIME | m_rtFrame
UINT64 | m_rtLength
CStreamState m_StreamState

Private Member Functions

InspectableClass(RuntimeClass_MPEG1Decoder_MPEG1Decoder,
BaseTrust) public 		~CDecoder ()
InspectableClass(RuntimeClass_MPEG1Decoder_MPEG1Decoder,
BaseTrust) public 		~CDecoder ()
STDMETHODIMP | AddInputStreams (DWORD cStreams, DWORD *adwStreamIDs)
STDMETHODIMP | AddInputStreams (DWORD cStreams, DWORD *adwStreamIDs)
STDMETHODIMP | DeleteInputStream (DWORD dwStreamID)
STDMETHODIMP | DeleteInputStream (DWORD dwStreamID)
STDMETHODIMP | GetAttributes (IMFAttributes **pAttributes)
STDMETHODIMP | GetAttributes (IMFAttributes **pAttributes)
STDMETHODIMP | GetInputAvailableType (DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetInputAvailableType (DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetInputCurrentType (DWORD dwInputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetInputCurrentType (DWORD dwInputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetInputStatus (DWORD dwInputStreamID, DWORD *pdwFlags)
STDMETHODIMP | GetInputStatus (DWORD dwInputStreamID, DWORD *pdwFlags)
STDMETHODIMP | GetInputStreamAttributes (DWORD dwInputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetInputStreamAttributes (DWORD dwInputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetInputStreamInfo (DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetInputStreamInfo (DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetOutputAvailableType (DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetOutputAvailableType (DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetOutputCurrentType (DWORD dwOutputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetOutputCurrentType (DWORD dwOutputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetOutputStatus (DWORD *pdwFlags)
STDMETHODIMP | GetOutputStatus (DWORD *pdwFlags)
STDMETHODIMP | GetOutputStreamAttributes (DWORD dwOutputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetOutputStreamAttributes (DWORD dwOutputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetOutputStreamInfo (DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetOutputStreamInfo (DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetStreamCount (DWORD *pcInputStreams, DWORD *pcOutputStreams)
STDMETHODIMP | GetStreamCount (DWORD *pcInputStreams, DWORD *pcOutputStreams)
STDMETHODIMP | GetStreamIDs (DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs)
STDMETHODIMP | GetStreamIDs (DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs)
STDMETHODIMP | GetStreamLimits (DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum)
STDMETHODIMP | GetStreamLimits (DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum)
STDMETHODIMP | ProcessEvent (DWORD dwInputStreamID, IMFMediaEvent *pEvent)
STDMETHODIMP | ProcessEvent (DWORD dwInputStreamID, IMFMediaEvent *pEvent)
STDMETHODIMP | ProcessInput (DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags)
STDMETHODIMP | ProcessInput (DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags)
STDMETHODIMP | ProcessMessage (MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam)
STDMETHODIMP | ProcessMessage (MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam)
STDMETHODIMP | ProcessOutput (DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus)
STDMETHODIMP | ProcessOutput (DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus)
STDMETHODIMP | SetInputType (DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetInputType (DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetOutputBounds (LONGLONG hnsLowerBound, LONGLONG hnsUpperBound)
STDMETHODIMP | SetOutputBounds (LONGLONG hnsLowerBound, LONGLONG hnsUpperBound)
STDMETHODIMP | SetOutputType (DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetOutputType (DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags)
IFACEMETHOD() | SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
IFACEMETHOD() | SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)

Detailed Description

Definition at line 100 of file decoder.h.

Constructor & Destructor Documentation

CDecoder::~CDecoder ( ) [private]

Definition at line 52 of file decoder.cpp.

{
    SafeRelease(&m_pBuffer);
    DeleteCriticalSection(&m_critSec);
}

InspectableClass (RuntimeClass_MPEG1Decoder_MPEG1Decoder, BaseTrust) public CDecoder::~CDecoder ( ) [private]

Member Function Documentation

HRESULT CDecoder::AddInputStreams | ( | DWORD | cStreams,
 |  | DWORD * | adwStreamIDs |
 | ) |  |  | [private]

Definition at line 291 of file decoder.cpp.

{
    // This MFT has a fixed number of output streams, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CDecoder::AddInputStreams | ( | DWORD | cStreams,
 |  | DWORD * | adwStreamIDs |
 | ) |  |  | [private]
HRESULT CDecoder::AllocateStreamingResources ( ) [protected]

Definition at line 1218 of file decoder.cpp.

{
    //  Reinitialize variables
    OnDiscontinuity();

    return S_OK;
}

HRESULT CDecoder::AllocateStreamingResources ( ) [protected]
HRESULT CDecoder::DeleteInputStream ( DWORD dwStreamID ) [private]

Definition at line 279 of file decoder.cpp.

{
    // This MFT has a fixed number of input streams, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CDecoder::DeleteInputStream ( DWORD dwStreamID ) [private]
HRESULT CDecoder::FreeStreamingResources ( ) [protected]

Definition at line 1226 of file decoder.cpp.

{
    return S_OK;
}

HRESULT CDecoder::FreeStreamingResources ( ) [protected]
HRESULT CDecoder::GetAttributes ( IMFAttributes ** pAttributes ) [private]

Definition at line 235 of file decoder.cpp.

{
    // This MFT does not support any attributes, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CDecoder::GetAttributes ( IMFAttributes ** pAttributes ) [private]
HRESULT CDecoder::GetInputAvailableType | ( | DWORD | dwInputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 307 of file decoder.cpp.

{
    return MF_E_NO_MORE_TYPES;
}

STDMETHODIMP CDecoder::GetInputAvailableType | ( | DWORD | dwInputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CDecoder::GetInputCurrentType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 541 of file decoder.cpp.

{
    if (ppType == NULL)
    {
        return E_POINTER;
    }

    if (!IsValidInputStream(dwInputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    if (!m_pInputType)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }

    if (SUCCEEDED(hr))
    {
        *ppType = m_pInputType;
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CDecoder::GetInputCurrentType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CDecoder::GetInputStatus | ( | DWORD | dwInputStreamID,
 |  | DWORD * | pdwFlags |
 | ) |  |  | [private]

Definition at line 623 of file decoder.cpp.

{
    if (pdwFlags == NULL)
    {
        return E_POINTER;
    }

    if (!IsValidInputStream(dwInputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);

    // If we already have an input sample, we don't accept
    // another one until the client calls ProcessOutput or Flush.
    if (HasPendingOutput())
    {
        *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
    }
    else
    {
        *pdwFlags = 0;
    }

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CDecoder::GetInputStatus | ( | DWORD | dwInputStreamID,
 |  | DWORD * | pdwFlags |
 | ) |  |  | [private]
HRESULT CDecoder::GetInputStreamAttributes | ( | DWORD | dwInputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]

Definition at line 248 of file decoder.cpp.

{
    // This MFT does not support any attributes, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CDecoder::GetInputStreamAttributes | ( | DWORD | dwInputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]
STDMETHODIMP CDecoder::GetInputStreamInfo | ( | DWORD | dwInputStreamID,
 |  | MFT_INPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]
HRESULT CDecoder::GetInputStreamInfo | ( | DWORD | dwInputStreamID,
 |  | MFT_INPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]

Definition at line 151 of file decoder.cpp.

{
    if (pStreamInfo == NULL)
    {
        return E_POINTER;
    }

    if (!IsValidInputStream(dwInputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    pStreamInfo->hnsMaxLatency = 0;

    //  We can process data on any boundary.
    pStreamInfo->dwFlags = 0;

    pStreamInfo->cbSize = 1;
    pStreamInfo->cbMaxLookahead = 0;
    pStreamInfo->cbAlignment = 1;

    return S_OK;
}

STDMETHODIMP CDecoder::GetOutputAvailableType | ( | DWORD | dwOutputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CDecoder::GetOutputAvailableType | ( | DWORD | dwOutputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 323 of file decoder.cpp.

{
    if (ppType == NULL)
    {
        return E_INVALIDARG;
    }

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    if (dwTypeIndex != 0)
    {
        return MF_E_NO_MORE_TYPES;
    }

    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    IMFMediaType *pOutputType = NULL;

    if (m_pInputType == NULL)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }

    if (SUCCEEDED(hr))
    {
        hr = MFCreateMediaType(&pOutputType);
    }

    if (SUCCEEDED(hr))
    {
        hr = pOutputType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
    }

    if (SUCCEEDED(hr))
    {
        hr = pOutputType->SetGUID(MF_MT_SUBTYPE, MFVideoFormat_RGB32);
    }

    if (SUCCEEDED(hr))
    {
        hr = pOutputType->SetUINT32(MF_MT_FIXED_SIZE_SAMPLES, TRUE);
    }

    if (SUCCEEDED(hr))
    {
        hr = pOutputType->SetUINT32(MF_MT_ALL_SAMPLES_INDEPENDENT, TRUE);
    }

    if (SUCCEEDED(hr))
    {
        hr = pOutputType->SetUINT32(MF_MT_SAMPLE_SIZE, m_imageHeightInPixels * m_imageWidthInPixels * 4);
    }

    if (SUCCEEDED(hr))
    {
        hr = MFSetAttributeSize(pOutputType, MF_MT_FRAME_SIZE, m_imageWidthInPixels, m_imageHeightInPixels);
    }

    if (SUCCEEDED(hr))
    {
        hr = MFSetAttributeRatio(pOutputType, MF_MT_FRAME_RATE, m_frameRate.Numerator, m_frameRate.Denominator);
    }

    if (SUCCEEDED(hr))
    {
        hr = pOutputType->SetUINT32(MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
    }

    if (SUCCEEDED(hr))
    {
        hr = MFSetAttributeRatio(pOutputType, MF_MT_PIXEL_ASPECT_RATIO, 1, 1);
    }

    if (SUCCEEDED(hr))
    {
        *ppType = pOutputType;
        (*ppType)->AddRef();
    }

    SafeRelease(&pOutputType);
    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CDecoder::GetOutputCurrentType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 582 of file decoder.cpp.

{
    if (ppType == NULL)
    {
        return E_POINTER;
    }

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    if (!m_pOutputType)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }

    if (SUCCEEDED(hr))
    {
        *ppType = m_pOutputType;
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CDecoder::GetOutputCurrentType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CDecoder::GetOutputStatus ( DWORD * pdwFlags ) [private]

Definition at line 662 of file decoder.cpp.

{
    if (pdwFlags == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    // We can produce an output sample if (and only if)
    // we have an input sample.
    if (HasPendingOutput())
    {
        *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
    }
    else
    {
        *pdwFlags = 0;
    }

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CDecoder::GetOutputStatus ( DWORD * pdwFlags ) [private]
HRESULT CDecoder::GetOutputStreamAttributes | ( | DWORD | dwOutputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]

Definition at line 264 of file decoder.cpp.

{
    // This MFT does not support any attributes, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CDecoder::GetOutputStreamAttributes | ( | DWORD | dwOutputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]
STDMETHODIMP CDecoder::GetOutputStreamInfo | ( | DWORD | dwOutputStreamID,
 |  | MFT_OUTPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]
HRESULT CDecoder::GetOutputStreamInfo | ( | DWORD | dwOutputStreamID,
 |  | MFT_OUTPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]

Definition at line 185 of file decoder.cpp.

{
    if (pStreamInfo == NULL)
    {
        return E_POINTER;
    }

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);

    // NOTE: This method should succeed even when there is no media type on the
    //       stream. If there is no media type, we only need to fill in the dwFlags
    //       member of MFT_OUTPUT_STREAM_INFO. The other members depend on having a
    //       a valid media type.

    pStreamInfo->dwFlags =
        MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
        MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
        MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;

    if (m_pOutputType == NULL)
    {
        pStreamInfo->cbSize = 0;
        pStreamInfo->cbAlignment = 0;
    }
    else
    {
        pStreamInfo->cbSize = m_cbImageSize;
        pStreamInfo->cbAlignment = 1;
    }

    LeaveCriticalSection(&m_critSec);

    return S_OK;
}

HRESULT CDecoder::GetStreamCount | ( | DWORD * | pcInputStreams,
 |  | DWORD * | pcOutputStreams |
 | ) |  |  | [private]

Definition at line 108 of file decoder.cpp.

{
    if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))

    {
        return E_POINTER;
    }

    // This MFT has a fixed number of streams.
    *pcInputStreams = 1;
    *pcOutputStreams = 1;

    return S_OK;
}

STDMETHODIMP CDecoder::GetStreamCount | ( | DWORD * | pcInputStreams,
 |  | DWORD * | pcOutputStreams |
 | ) |  |  | [private]
HRESULT CDecoder::GetStreamIDs | ( | DWORD | dwInputIDArraySize,
 |  | DWORD * | pdwInputIDs,
 |  | DWORD | dwOutputIDArraySize,
 |  | DWORD * | pdwOutputIDs |
 | ) |  |  | [private]

Definition at line 133 of file decoder.cpp.

{
    // Do not need to implement, because this MFT has a fixed number of
    // streams and the stream IDs match the stream indexes.
    return E_NOTIMPL;
}

STDMETHODIMP CDecoder::GetStreamIDs | ( | DWORD | dwInputIDArraySize,
 |  | DWORD * | pdwInputIDs,
 |  | DWORD | dwOutputIDArraySize,
 |  | DWORD * | pdwOutputIDs |
 | ) |  |  | [private]
STDMETHODIMP CDecoder::GetStreamLimits | ( | DWORD * | pdwInputMinimum,
 |  | DWORD * | pdwInputMaximum,
 |  | DWORD * | pdwOutputMinimum,
 |  | DWORD * | pdwOutputMaximum |
 | ) |  |  | [private]
HRESULT CDecoder::GetStreamLimits | ( | DWORD * | pdwInputMinimum,
 |  | DWORD * | pdwInputMaximum,
 |  | DWORD * | pdwOutputMinimum,
 |  | DWORD * | pdwOutputMaximum |
 | ) |  |  | [private]

Definition at line 76 of file decoder.cpp.

{

    if ((pdwInputMinimum == NULL) ||
        (pdwInputMaximum == NULL) ||
        (pdwOutputMinimum == NULL) ||
        (pdwOutputMaximum == NULL))
    {
        return E_POINTER;
    }

    // This MFT has a fixed number of streams.
    *pdwInputMinimum = 1;
    *pdwInputMaximum = 1;
    *pdwOutputMinimum = 1;
    *pdwOutputMaximum = 1;

    return S_OK;
}

BOOL CDecoder::HasPendingOutput ( ) const [inline, protected]

Definition at line 236 of file decoder.h.

{ return m_pBuffer != NULL; }

BOOL CDecoder::HasPendingOutput ( ) const [inline, protected]

Definition at line 236 of file decoder.h.

{ return m_pBuffer != NULL; }

HRESULT CDecoder::InternalProcessOutput | ( | IMFSample * | pSample,
 |  | IMFMediaBuffer * | pOutputBuffer |
 | ) |  |  | [protected]
HRESULT CDecoder::InternalProcessOutput | ( | IMFSample * | pSample,
 |  | IMFMediaBuffer * | pOutputBuffer |
 | ) |  |  | [protected]

Definition at line 947 of file decoder.cpp.

{
    VideoBufferLock buffer(pOutputBuffer);

    HRESULT hr = S_OK;

    BYTE *pbData = NULL;
    LONG lDefaultStride = 0;
    LONG lActualStride = 0;

    DWORD dwTimeCode = 0;
    LONGLONG rt = 0;
    TCHAR szBuffer[20];

    lDefaultStride = m_imageWidthInPixels * 4; // Works only for RGB32

    if (SUCCEEDED(hr))
    {
        hr = buffer.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pbData, &lActualStride);
    }

    //  Generate our data
    if (SUCCEEDED(hr))
    {
        rt = m_StreamState.PictureTime(&dwTimeCode);

        hr = StringCchPrintf(szBuffer, ARRAYSIZE(szBuffer),
            TEXT("%2.2d:%2.2d:%2.2d:%2.2d\0"),
             (dwTimeCode >> 19) & 0x1F,
             (dwTimeCode >> 13) & 0x3F,
             (dwTimeCode >> 6) & 0x3F,
              dwTimeCode & 0x3F
              );
    }

    if (SUCCEEDED(hr))
    {
        // Update our bitmap with turquoise
        OurFillRect(pbData, m_imageWidthInPixels, m_imageHeightInPixels, lActualStride, RGB(0xFF,0x80,0x80));
        OurFillRect(pbData, m_imageWidthInPixels/2, m_imageHeightInPixels/2, lActualStride, RGB(0x00,0xff,0x00));

    }

    if (SUCCEEDED(hr))
    {
        hr = pOutputBuffer->SetCurrentLength(m_cbImageSize);
    }

    // Clean point / key frame
    if (SUCCEEDED(hr))
    {
        hr = pSample->SetUINT32(MFSampleExtension_CleanPoint, TRUE);
    }

    //  Set the timestamp
    //  Uncompressed video must always have a timestamp

    if (SUCCEEDED(hr))
    {
        rt = m_StreamState.PictureTime(&dwTimeCode);
        if (rt == INVALID_TIME)
        {
            rt = m_rtFrame;
        }
        hr = pSample->SetSampleTime(rt);
    }

    if (SUCCEEDED(hr))
    {
        hr = pSample->SetSampleDuration(m_rtLength);

    }

    if (SUCCEEDED(hr))
    {
        m_rtFrame = rt + m_rtLength;
    }

    return hr;
}

BOOL CDecoder::IsValidInputStream ( DWORD dwInputStreamID ) const [inline, protected]

Definition at line 239 of file decoder.h.

    {
        return dwInputStreamID == 0;
    }

BOOL CDecoder::IsValidInputStream ( DWORD dwInputStreamID ) const [inline, protected]

Definition at line 239 of file decoder.h.

    {
        return dwInputStreamID == 0;
    }

BOOL CDecoder::IsValidOutputStream ( DWORD dwOutputStreamID ) const [inline, protected]

Definition at line 245 of file decoder.h.

    {
        return dwOutputStreamID == 0;
    }

BOOL CDecoder::IsValidOutputStream ( DWORD dwOutputStreamID ) const [inline, protected]

Definition at line 245 of file decoder.h.

    {
        return dwOutputStreamID == 0;
    }

HRESULT CDecoder::OnCheckInputType ( IMFMediaType * pmt ) [protected]
HRESULT CDecoder::OnCheckInputType ( IMFMediaType * pmt ) [protected]

Definition at line 1029 of file decoder.cpp.

{
    HRESULT hr = S_OK;

    //  Check if the type is already set and if so reject any type that's not identical.
    if (m_pInputType)
    {
        DWORD dwFlags = 0;
        if (S_OK == m_pInputType->IsEqual(pmt, &dwFlags))
        {
            return S_OK;
        }
        else
        {
            return MF_E_INVALIDTYPE;
        }
    }

    GUID majortype = { 0 };
    GUID subtype = { 0 };
    UINT32 width = 0, height = 0;
    MFRatio fps = { 0 };
    UINT32 cbSeqHeader = 0;

    //  We accept MFMediaType_Video, MEDIASUBTYPE_MPEG1Video

    hr = pmt->GetMajorType(&majortype);

    if (SUCCEEDED(hr))
    {
        if (majortype != MFMediaType_Video)
        {
            hr = MF_E_INVALIDTYPE;
        }
    }

    if (SUCCEEDED(hr))
    {
        hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
    }

    if (SUCCEEDED(hr))
    {
        if (subtype != MFVideoFormat_MPG1)
        {
            hr = MF_E_INVALIDTYPE;
        }
    }

    // At this point a real decoder would validate the MPEG-1 format.

    // Validate the frame size.

    if (SUCCEEDED(hr))
    {
        hr = MFGetAttributeSize(pmt, MF_MT_FRAME_SIZE, &width, &height);
    }

    if (SUCCEEDED(hr))
    {
        if (width > MAX_VIDEO_WIDTH || height > MAX_VIDEO_HEIGHT)
        {
            hr = MF_E_INVALIDTYPE;
        }
    }

    // Make sure there is a frame rate.
    // *** A real decoder would also validate this. ***

    if (SUCCEEDED(hr))
    {
        hr = MFGetAttributeRatio(pmt, MF_MT_FRAME_RATE, (UINT32*)&fps.Numerator, (UINT32*)&fps.Denominator);
    }

    // Check for a sequence header.
    // We don't actually look at it for this sample.
    // *** A real decoder would validate the sequence header. ***

    if (SUCCEEDED(hr))
    {
        (void)pmt->GetBlobSize(MF_MT_MPEG_SEQUENCE_HEADER, &cbSeqHeader);

        if (cbSeqHeader < MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE)
        {
            hr = MF_E_INVALIDTYPE;
        }
    }

    return hr;
}

HRESULT CDecoder::OnCheckOutputType ( IMFMediaType * pmt ) [protected]
HRESULT CDecoder::OnCheckOutputType ( IMFMediaType * pmt ) [protected]

Definition at line 1159 of file decoder.cpp.

{
    //  Check if the type is already set and if so reject any type that's not identical.
    if (m_pOutputType)
    {
        DWORD dwFlags = 0;
        if (S_OK == m_pOutputType->IsEqual(pmt, &dwFlags))
        {
            return S_OK;
        }
        else
        {
            return MF_E_INVALIDTYPE;
        }
    }

    if (m_pInputType == NULL)
    {
        return MF_E_TRANSFORM_TYPE_NOT_SET; // Input type must be set first.
    }

    HRESULT hr = S_OK;
    BOOL bMatch = FALSE;

    IMFMediaType *pOurType = NULL;

    // Make sure their type is a superset of our proposed output type.
    hr = GetOutputAvailableType(0, 0, &pOurType);

    if (SUCCEEDED(hr))
    {
        hr = pOurType->Compare(pmt, MF_ATTRIBUTES_MATCH_OUR_ITEMS, &bMatch);
    }

    if (SUCCEEDED(hr))
    {
        if (!bMatch)
        {
            hr = MF_E_INVALIDTYPE;
        }
    }

    SafeRelease(&pOurType);
    return hr;
}

HRESULT CDecoder::OnDiscontinuity ( ) [protected]

Definition at line 1231 of file decoder.cpp.

{
    //  Zero our timestamp
    m_rtFrame = 0;

    //  No pictures yet
   m_bPicture   = false;

   //  Reset state machine
   m_StreamState.Reset();
   return S_OK;
}

HRESULT CDecoder::OnDiscontinuity ( ) [protected]
HRESULT CDecoder::OnFlush ( ) [protected]

Definition at line 1244 of file decoder.cpp.

{
    OnDiscontinuity();

    //  Release buffer
    SafeRelease(&m_pBuffer);

    return S_OK;
}

HRESULT CDecoder::OnFlush ( ) [protected]
HRESULT CDecoder::OnSetInputType ( IMFMediaType * pmt ) [protected]

Definition at line 1121 of file decoder.cpp.

{
    HRESULT hr = S_OK;

    SafeRelease(&m_pInputType);

    hr = MFGetAttributeSize(pmt, MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);

    if (SUCCEEDED(hr))
    {
       hr = MFGetAttributeRatio(pmt, MF_MT_FRAME_RATE, (UINT32*)&m_frameRate.Numerator, (UINT32*)&m_frameRate.Denominator);
    }

    // Also store the frame duration, derived from the frame rate.
    if (SUCCEEDED(hr))
    {

        if (m_frameRate.Numerator == 0 || m_frameRate.Denominator == 0) {
            m_rtLength = 0;
            return E_FAIL;
        }

        double fRate = (double)m_frameRate.Numerator / m_frameRate.Denominator;

        m_rtLength = (UINT64)((10000000 / fRate) + 0.5);
    }

    if (SUCCEEDED(hr))
    {
        m_cbImageSize = m_imageWidthInPixels * m_imageHeightInPixels * 4;

        m_pInputType = pmt;
        m_pInputType->AddRef();
    }

    return hr;
}

HRESULT CDecoder::OnSetInputType ( IMFMediaType * pmt ) [protected]
HRESULT CDecoder::OnSetOutputType ( IMFMediaType * pmt ) [protected]
HRESULT CDecoder::OnSetOutputType ( IMFMediaType * pmt ) [protected]

Definition at line 1207 of file decoder.cpp.

{
    SafeRelease(&m_pOutputType);

    m_pOutputType = pmt;
    m_pOutputType->AddRef();

    return S_OK;
}

HRESULT CDecoder::Process ( ) [protected]
HRESULT CDecoder::Process ( ) [protected]

Definition at line 1260 of file decoder.cpp.

{
    //  Process bytes and update our state machine
    while (m_cbData && !m_bPicture)
    {
        m_bPicture = m_StreamState.NextByte(*m_pbData);
        m_cbData--;
        m_pbData++;
    }

    //  Release buffer if we're done with it
    if (m_cbData == 0)
    {
        m_pBuffer->Unlock();

        m_pbData = NULL;

        SafeRelease(&m_pBuffer);
    }

    //  assert that if have no picture to output then we ate all the data
    assert(m_bPicture || m_cbData == 0);
    return S_OK;
}

HRESULT CDecoder::ProcessEvent | ( | DWORD | dwInputStreamID,
 |  | IMFMediaEvent * | pEvent |
 | ) |  |  | [private]

Definition at line 709 of file decoder.cpp.

{
    // This MFT does not handle any stream events, so the method can
    // return E_NOTIMPL. This tells the pipeline that it can stop
    // sending any more events to this MFT.
    return E_NOTIMPL;
}

STDMETHODIMP CDecoder::ProcessEvent | ( | DWORD | dwInputStreamID,
 |  | IMFMediaEvent * | pEvent |
 | ) |  |  | [private]
HRESULT CDecoder::ProcessInput | ( | DWORD | dwInputStreamID,
 |  | IMFSample * | pSample,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 781 of file decoder.cpp.

{
    if (pSample == NULL)
    {
        return E_POINTER;
    }

    if (!IsValidInputStream(dwInputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    if (dwFlags != 0)
    {
        return E_INVALIDARG; // dwFlags is reserved and must be zero.
    }

    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;
    LONGLONG rtTimestamp = 0;

    if (!m_pInputType || !m_pOutputType)
    {
        hr = MF_E_NOTACCEPTING;   // Client must set input and output types.
    }
    else if (HasPendingOutput())
    {
        hr = MF_E_NOTACCEPTING;   // We already have an input sample.
    }

    // Convert to a single contiguous buffer.
    if (SUCCEEDED(hr))
    {
        // NOTE: This does not cause a copy unless there are multiple buffers
        hr = pSample->ConvertToContiguousBuffer(&m_pBuffer);
    }

    if (SUCCEEDED(hr))
    {
        hr = m_pBuffer->Lock(&m_pbData, NULL, &m_cbData);
    }

    if (SUCCEEDED(hr))
    {
        // Get the time stamp. It is OK if this call fails.
        if (FAILED(pSample->GetSampleTime(&rtTimestamp)))
        {
            rtTimestamp = INVALID_TIME;
        }

        m_StreamState.TimeStamp(rtTimestamp);

        hr = Process();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CDecoder::ProcessInput | ( | DWORD | dwInputStreamID,
 |  | IMFSample * | pSample,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
HRESULT CDecoder::ProcessMessage | ( | MFT_MESSAGE_TYPE | eMessage,
 |  | ULONG_PTR | ulParam |
 | ) |  |  | [private]

Definition at line 726 of file decoder.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    switch (eMessage)
    {
    case MFT_MESSAGE_COMMAND_FLUSH:
        // Flush the MFT.
        hr = OnFlush();
        break;

    case MFT_MESSAGE_COMMAND_DRAIN:
        // Set the discontinuity flag on all of the input.
        hr = OnDiscontinuity();
        break;

    case MFT_MESSAGE_SET_D3D_MANAGER:
        // The pipeline should never send this message unless the MFT
        // has the MF_SA_D3D_AWARE attribute set to TRUE. However, if we
        // do get this message, it's invalid and we don't implement it.
        hr = E_NOTIMPL;
        break;

    case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
        hr = AllocateStreamingResources();
        break;

    case MFT_MESSAGE_NOTIFY_END_STREAMING:
        hr = FreeStreamingResources();
        break;

    // These messages do not require a response.
    case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
    case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
        break;

    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CDecoder::ProcessMessage | ( | MFT_MESSAGE_TYPE | eMessage,
 |  | ULONG_PTR | ulParam |
 | ) |  |  | [private]
HRESULT CDecoder::ProcessOutput | ( | DWORD | dwFlags,
 |  | DWORD | cOutputBufferCount,
 |  | MFT_OUTPUT_DATA_BUFFER * | pOutputSamples,
 |  | DWORD * | pdwStatus |
 | ) |  |  | [private]

Definition at line 852 of file decoder.cpp.

{
    // Check input parameters...

    // There are no flags that we accept in this MFT.
    // The only defined flag is MFT_PROCESS_OUTPUT_DISCARD_WHEN_NO_BUFFER. This
    // flag only applies when the MFT marks an output stream as lazy or optional.
    // However there are no lazy or optional streams on this MFT, so the flag is
    // not valid.
    if (dwFlags != 0)
    {
        return E_INVALIDARG;
    }

    if (pOutputSamples == NULL || pdwStatus == NULL)
    {
        return E_POINTER;
    }

    // Must be exactly one output buffer.
    if (cOutputBufferCount != 1)
    {
        return E_INVALIDARG;
    }

    // It must contain a sample.
    if (pOutputSamples[0].pSample == NULL)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;
    DWORD cbData = 0;

    IMFMediaBuffer *pOutput = NULL;

    // If we don't have an input sample, we need some input before
    // we can generate any output.
    if (!HasPendingOutput())
    {
        hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
    }

    // Get the output buffer.

    if (SUCCEEDED(hr))
    {
        hr = pOutputSamples[0].pSample->GetBufferByIndex(0, &pOutput);
    }

    if (SUCCEEDED(hr))
    {
        hr = pOutput->GetMaxLength(&cbData);
    }

    if (SUCCEEDED(hr))
    {
        if (cbData < m_cbImageSize)
        {
            hr = E_INVALIDARG;
        }
    }

    if (SUCCEEDED(hr))
    {
        hr = InternalProcessOutput(pOutputSamples[0].pSample, pOutput);
    }

    if (SUCCEEDED(hr))
    {
        //  Update our state
        m_bPicture = false;

        //  Is there any more data to output at this point?
        if (S_OK == Process())
        {
            pOutputSamples[0].dwStatus |= MFT_OUTPUT_DATA_BUFFER_INCOMPLETE;
        }
    }

    SafeRelease(&pOutput);
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CDecoder::ProcessOutput | ( | DWORD | dwFlags,
 |  | DWORD | cOutputBufferCount,
 |  | MFT_OUTPUT_DATA_BUFFER * | pOutputSamples,
 |  | DWORD * | pdwStatus |
 | ) |  |  | [private]
HRESULT CDecoder::SetInputType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 422 of file decoder.cpp.

{
    if (!IsValidInputStream(dwInputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    // Validate flags.
    if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
    {
        return E_INVALIDARG;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    // Does the caller want us to set the type, or just test it?
    BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);

    // If we have an input sample, the client cannot change the type now.
    if (HasPendingOutput())
    {
        hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
    }

    // Validate the type, if non-NULL.
    if (SUCCEEDED(hr))
    {
        if (pType)
        {
            hr = OnCheckInputType(pType);
        }
    }

    if (SUCCEEDED(hr))
    {
        // The type is OK.
        // Set the type, unless the caller was just testing.
        if (bReallySet)
        {
            hr = OnSetInputType(pType);
        }
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CDecoder::SetInputType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
STDMETHODIMP CDecoder::SetOutputBounds | ( | LONGLONG | hnsLowerBound,
 |  | LONGLONG | hnsUpperBound |
 | ) |  |  | [private]
HRESULT CDecoder::SetOutputBounds | ( | LONGLONG | hnsLowerBound,
 |  | LONGLONG | hnsUpperBound |
 | ) |  |  | [private]

Definition at line 693 of file decoder.cpp.

{
    // Implementation of this method is optional.
    return E_NOTIMPL;
}

HRESULT CDecoder::SetOutputType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 481 of file decoder.cpp.

{
    if (!IsValidOutputStream(dwOutputStreamID))
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    // Validate flags.
    if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
    {
        return E_INVALIDARG;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    // Does the caller want us to set the type, or just test it?
     BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);

    // If we have an input sample, the client cannot change the type now.
    if (HasPendingOutput())
    {
        hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
    }

    // Validate the type, if non-NULL.
    if (SUCCEEDED(hr))
    {
        if (pType)
        {
            hr = OnCheckOutputType(pType);
        }
    }

    if (SUCCEEDED(hr))
    {
        if (bReallySet)
        {
            // The type is OK.
            // Set the type, unless the caller was just testing.
            hr = OnSetOutputType(pType);
        }
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CDecoder::SetOutputType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
IFACEMETHOD() CDecoder::SetProperties ( ABI::Windows::Foundation::Collections::IPropertySet * pConfiguration ) [private]
IFACEMETHODIMP CDecoder::SetProperties ( ABI::Windows::Foundation::Collections::IPropertySet * pConfiguration ) [private]

Definition at line 64 of file decoder.cpp.

{
    return S_OK;
}

Member Data Documentation

bool CDecoder::m_bLowLatencyMode [protected]

Definition at line 288 of file decoder.h.

bool CDecoder::m_bPicture [protected]

Definition at line 287 of file decoder.h.

DWORD CDecoder::m_cbData [protected]

Definition at line 273 of file decoder.h.

DWORD CDecoder::m_cbImageSize [protected]

Definition at line 279 of file decoder.h.

CRITICAL_SECTION CDecoder::m_critSec [protected]

Definition at line 265 of file decoder.h.

MFRatio CDecoder::m_frameRate [protected]

Definition at line 278 of file decoder.h.

UINT32 CDecoder::m_imageHeightInPixels [protected]

Definition at line 277 of file decoder.h.

UINT32 CDecoder::m_imageWidthInPixels [protected]

Definition at line 276 of file decoder.h.

BYTE * CDecoder::m_pbData [protected]

Definition at line 272 of file decoder.h.

IMFMediaBuffer * CDecoder::m_pBuffer [protected]

Definition at line 271 of file decoder.h.

IMFMediaType * CDecoder::m_pInputType [protected]

Definition at line 268 of file decoder.h.

IMFMediaType * CDecoder::m_pOutputType [protected]

Definition at line 269 of file decoder.h.

REFERENCE_TIME CDecoder::m_rtFrame [protected]

Definition at line 282 of file decoder.h.

UINT64 CDecoder::m_rtLength [protected]

Definition at line 283 of file decoder.h.

CStreamState CDecoder::m_StreamState [protected]

Definition at line 286 of file decoder.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.h
  • Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.h
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.cpp
  • Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.cpp
Generated on Sat Nov 23 2024 16:09:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CDocumentSource Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

CDocumentSource Class Reference

#include "DocSource.h"

List of all members.

Public Member Functions

IFACEMETHODIMP | GetPreviewPageCollection (_In_ IPrintDocumentPackageTarget *docPackageTarget, _Out_ IPrintPreviewPageCollection **docPageCollection)
IFACEMETHODIMP | GetPreviewPageCollection (_In_ IPrintDocumentPackageTarget *docPackageTarget, _Out_ IPrintPreviewPageCollection **docPageCollection)
IFACEMETHODIMP | MakeDocument (_In_ IInspectable *docOptions, _In_ IPrintDocumentPackageTarget *docPackageTarget)
IFACEMETHODIMP | MakeDocument (_In_ IInspectable *docOptions, _In_ IPrintDocumentPackageTarget *docPackageTarget)
IFACEMETHODIMP | MakePage (_In_ uint32 desiredJobPage, _In_ float width, _In_ float height)
IFACEMETHODIMP | MakePage (_In_ uint32 desiredJobPage, _In_ float width, _In_ float height)
IFACEMETHODIMP | Paginate (_In_ uint32 currentJobPage, _In_ IInspectable *docOptions)
IFACEMETHODIMP | Paginate (_In_ uint32 currentJobPage, _In_ IInspectable *docOptions)
HRESULT | RuntimeClassInitialize (_In_ IUnknown *pageRenderer)
HRESULT | RuntimeClassInitialize (_In_ IUnknown *pageRenderer)

Private Member Functions

InspectableClass (L"Windows.Graphics.Printing.IPrintDocumentSource", BaseTrust)
InspectableClass (L"Windows.Graphics.Printing.IPrintDocumentSource", BaseTrust)
float | TransformedPageSize (_In_ float desiredWidth, _In_ float desiredHeight, _Out_ Windows::Foundation::Size *previewSize)
float | TransformedPageSize (_In_ float desiredWidth, _In_ float desiredHeight, _Out_ Windows::Foundation::Size *previewSize)

Private Attributes

Microsoft::WRL::ComPtr
< IPrintPreviewDxgiPackageTarget > 		m_dxgiPreviewTarget
float | m_height
D2D1_RECT_F | m_imageableRect
bool | m_paginateCalled
PageRenderer m_renderer
uint32 | m_totalPages
float | m_width

Detailed Description

Definition at line 14 of file DocSource.h.

Member Function Documentation

IFACEMETHODIMP CDocumentSource::GetPreviewPageCollection | ( | _In_ IPrintDocumentPackageTarget * | docPackageTarget,
 |  | _Out_ IPrintPreviewPageCollection ** | docPageCollection
 | ) |  |

Definition at line 17 of file DocSource.cpp.

{
    HRESULT hr = (docPackageTarget == nullptr) ? E_INVALIDARG : S_OK;

    // Get for IPrintPreviewDxgiPackageTarget interface.
    if (SUCCEEDED(hr))
    {
        hr = docPackageTarget->GetPackageTarget(
            ID_PREVIEWPACKAGETARGET_DXGI,
            IID_PPV_ARGS(&m_dxgiPreviewTarget)
            );
    }

    ComPtr<IPrintPreviewPageCollection> pageCollection;
    if (SUCCEEDED(hr))
    {
        ComPtr<CDocumentSource> docSource(this);
        hr = docSource.As<IPrintPreviewPageCollection>(&pageCollection);
    }

    if (SUCCEEDED(hr))
    {
        hr = pageCollection.CopyTo(docPageCollection);
    }

    return hr;
}

IFACEMETHODIMP CDocumentSource::GetPreviewPageCollection | ( | _In_ IPrintDocumentPackageTarget * | docPackageTarget,
 |  | _Out_ IPrintPreviewPageCollection ** | docPageCollection
 | ) |  |
CDocumentSource::InspectableClass | ( | L"Windows.Graphics.Printing.IPrintDocumentSource" | ,
 |  | BaseTrust |  |
 | ) |  |  | [private]
CDocumentSource::InspectableClass | ( | L"Windows.Graphics.Printing.IPrintDocumentSource" | ,
 |  | BaseTrust |  |
 | ) |  |  | [private]
IFACEMETHODIMP CDocumentSource::MakeDocument | ( | _In_ IInspectable * | docOptions,
 |  | _In_ IPrintDocumentPackageTarget * | docPackageTarget
 | ) |  |

Definition at line 49 of file DocSource.cpp.

{
    if (docOptions == nullptr || docPackageTarget == nullptr)
    {
        return E_INVALIDARG;
    }

    // Get print settings from PrintTaskOptions for printing, such as page description, which contains page size, imageable area, DPI.
    // User can obtain other print settings in the same way, such as ColorMode, NumberOfCopies, etc., which are not shown in this sample.
    PrintTaskOptions^ option = reinterpret_cast<PrintTaskOptions^>(docOptions);
    PrintPageDescription pageDesc = option->GetPageDescription(1); // Get the description of the first page.

    // Create a print control properties and set DPI from PrintPageDescription.
    D2D1_PRINT_CONTROL_PROPERTIES printControlProperties;

    printControlProperties.rasterDPI  = (float)(min(pageDesc.DpiX, pageDesc.DpiY)); // DPI for rasterization of all unsupported D2D commands or options
    printControlProperties.colorSpace = D2D1_COLOR_SPACE_SRGB;                  // Color space for vector graphics in D2D print control.
    printControlProperties.fontSubset = D2D1_PRINT_FONT_SUBSET_MODE_DEFAULT;    // Subset for used glyphs, send and discard font resource after every five pages

    HRESULT hr = S_OK;

    try
    {
        // Create a new print control linked to the package target.
        m_renderer->CreatePrintControl(
            docPackageTarget,
            &printControlProperties
            );

        // Calculate imageable area and page size from PrintPageDescription.
        D2D1_RECT_F imageableRect = D2D1::RectF(
            pageDesc.ImageableRect.X,
            pageDesc.ImageableRect.Y,
            pageDesc.ImageableRect.X + pageDesc.ImageableRect.Width,
            pageDesc.ImageableRect.Y + pageDesc.ImageableRect.Height
            );

        D2D1_SIZE_F pageSize = D2D1::SizeF(pageDesc.PageSize.Width, pageDesc.PageSize.Height);

        // Loop to add page command list to d2d print control.
        for (uint32 pageNum = 1; pageNum <= m_totalPages; ++pageNum)
        {
            m_renderer->PrintPage(
                pageNum,
                imageableRect,
                pageSize,
                nullptr // If a page-level print ticket is not specified here, the package print ticket is applied for each page.
                );
        }
    }
    catch (Platform::Exception^ e)
    {
        hr = e->HResult;

        if (hr == D2DERR_RECREATE_TARGET)
        {
            // In case of device lost, the whole print job will be aborted, and we should recover
            // so that the device is ready when used again. At the same time, we should propagate
            // this error to the Modern Print Dialog.
            m_renderer->HandleDeviceLost();
        }
    }

    // Make sure to close d2d print control even if AddPage fails.
    HRESULT hrClose = m_renderer->ClosePrintControl();

    if (SUCCEEDED(hr))
    {
        hr = hrClose;
    }

    return hr;
}

IFACEMETHODIMP CDocumentSource::MakeDocument | ( | _In_ IInspectable * | docOptions,
 |  | _In_ IPrintDocumentPackageTarget * | docPackageTarget
 | ) |  |
IFACEMETHODIMP CDocumentSource::MakePage | ( | _In_ uint32 | desiredJobPage,
 |  | _In_ float | width,
 |  | _In_ float | height
 | ) |  |
IFACEMETHODIMP CDocumentSource::MakePage | ( | _In_ uint32 | desiredJobPage,
 |  | _In_ float | width,
 |  | _In_ float | height
 | ) |  |

Definition at line 205 of file DocSource.cpp.

{
    HRESULT hr = (width > 0 && height > 0) ? S_OK : E_INVALIDARG;

    // When desiredJobPage is JOB_PAGE_APPLICATION_DEFINED, it means a new preview begins. If the implementation here is by an async way,
    // for example, queue MakePage calls for preview, app needs to clean resources for previous preview before next.
    // In this sample, we will reset page number if Paginate() has been called.
    if (desiredJobPage == JOB_PAGE_APPLICATION_DEFINED && m_paginateCalled)
    {
        desiredJobPage = 1;
    }

    if (SUCCEEDED(hr) && m_paginateCalled)
    {
        // Calculate the size of preview surface, according to desired width and height.
        Windows::Foundation::Size previewSize;
        float scale = TransformedPageSize(width, height, &previewSize);

        try
        {
            m_renderer->DrawPreviewSurface(
                previewSize.Width,
                previewSize.Height,
                scale,
                m_imageableRect,
                desiredJobPage,
                m_dxgiPreviewTarget.Get()
                );
        }
        catch (Platform::Exception^ e)
        {
            hr = e->HResult;

            if (hr == D2DERR_RECREATE_TARGET)
            {
                // In case of device lost, we should recover so that the device is ready to render
                // the next preview page when requested. At the same time, we should propagate this
                // error to the Modern Print Dialog.
                m_renderer->HandleDeviceLost();
            }
        }
    }

    return hr;
}

IFACEMETHODIMP CDocumentSource::Paginate | ( | _In_ uint32 | currentJobPage,
 |  | _In_ IInspectable * | docOptions
 | ) |  |

Definition at line 131 of file DocSource.cpp.

{
    HRESULT hr = (docOptions == nullptr) ? E_INVALIDARG : S_OK;

    if (SUCCEEDED(hr))
    {
        // Get print settings from PrintTaskOptions for printing, such as page description, which contains page size, imageable area, DPI.
        // User can obtain other print settings in the same way, such as ColorMode, NumberOfCopies, etc., which are not shown in this sample.
        PrintTaskOptions^ option = reinterpret_cast<PrintTaskOptions^>(docOptions);
        PrintPageDescription pageDesc = option->GetPageDescription(currentJobPage);

        hr = m_dxgiPreviewTarget->InvalidatePreview();

        // Set the total page number.
        if (SUCCEEDED(hr))
        {
            hr = m_dxgiPreviewTarget->SetJobPageCount(PageCountType::FinalPageCount, m_totalPages);
        }

        if (SUCCEEDED(hr))
        {
            m_width = pageDesc.PageSize.Width;
            m_height = pageDesc.PageSize.Height;

            m_imageableRect = D2D1::RectF(
                pageDesc.ImageableRect.X,
                pageDesc.ImageableRect.Y,
                pageDesc.ImageableRect.X + pageDesc.ImageableRect.Width,
                pageDesc.ImageableRect.Y + pageDesc.ImageableRect.Height
                );

            // Now we are ready to let MakePage to be called.
            m_paginateCalled = true;
        }
    }

    return hr;
}

IFACEMETHODIMP CDocumentSource::Paginate | ( | _In_ uint32 | currentJobPage,
 |  | _In_ IInspectable * | docOptions
 | ) |  |
HRESULT CDocumentSource::RuntimeClassInitialize ( _In_ IUnknown * pageRenderer ) [inline]

Definition at line 23 of file DocSource.h.

    {
        HRESULT hr = (pageRenderer != nullptr) ? S_OK : E_INVALIDARG;

        if (SUCCEEDED(hr))
        {
            m_paginateCalled = false;
            m_totalPages     = 1;
            m_height         = 0.f;
            m_width          = 0.f;

            // Cast d2dRender back to PageRenderer object.
            m_renderer = reinterpret_cast<PageRenderer^>(pageRenderer);
        }

        return hr;
    }

HRESULT CDocumentSource::RuntimeClassInitialize ( _In_ IUnknown * pageRenderer ) [inline]

Definition at line 23 of file DocSource.h.

    {
        HRESULT hr = (pageRenderer != nullptr) ? S_OK : E_INVALIDARG;

        if (SUCCEEDED(hr))
        {
            m_paginateCalled = false;
            m_totalPages     = 1;
            m_height         = 0.f;
            m_width          = 0.f;

            // Cast d2dRender back to PageRenderer object.
            m_renderer = reinterpret_cast<PageRenderer^>(pageRenderer);
        }

        return hr;
    }

float CDocumentSource::TransformedPageSize | ( | _In_ float | desiredWidth,
 |  | _In_ float | desiredHeight,
 |  | _Out_ Windows::Foundation::Size * | previewSize |
 | ) |  |  | [private]
float CDocumentSource::TransformedPageSize | ( | _In_ float | desiredWidth,
 |  | _In_ float | desiredHeight,
 |  | _Out_ Windows::Foundation::Size * | previewSize |
 | ) |  |  | [private]

Definition at line 178 of file DocSource.cpp.

{
    float scale = 1.0f;

    if (desiredWidth > 0 && desiredHeight > 0)
    {
        previewSize->Width  = desiredWidth;
        previewSize->Height = desiredHeight;

        scale = m_width / desiredWidth;
    }
    else
    {
        previewSize->Width = 0;
        previewSize->Height = 0;
    }

    return scale;
}

Member Data Documentation

Microsoft::WRL::ComPtr< IPrintPreviewDxgiPackageTarget > CDocumentSource::m_dxgiPreviewTarget [private]

Definition at line 88 of file DocSource.h.

float CDocumentSource::m_height [private]

Definition at line 84 of file DocSource.h.

D2D1_RECT_F CDocumentSource::m_imageableRect [private]

Definition at line 86 of file DocSource.h.

bool CDocumentSource::m_paginateCalled [private]

Definition at line 83 of file DocSource.h.

PageRenderer CDocumentSource::m_renderer [private]

Definition at line 87 of file DocSource.h.

uint32 CDocumentSource::m_totalPages [private]

Definition at line 82 of file DocSource.h.

float CDocumentSource::m_width [private]

Definition at line 85 of file DocSource.h.

The documentation for this class was generated from the following files:
  • Direct2D printing images and effects/C++/DocSource.h
  • Direct2Dapp printing/C++/DocSource.h
  • Direct2D printing images and effects/C++/DocSource.cpp
  • Direct2Dapp printing/C++/DocSource.cpp
Generated on Sat Nov 23 2024 16:09:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CGrayscale Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Private Member Functions | Private Attributes

CGrayscale Class Reference

#include "Grayscale.h"

List of all members.

Private Member Functions

InspectableClass(RuntimeClass_GrayscaleTransform_GrayscaleEffect,
BaseTrust) public 		~CGrayscale ()
InspectableClass(RuntimeClass_GrayscaleTransform_GrayscaleEffect,
BaseTrust) public 		~CGrayscale ()
STDMETHODIMP | AddInputStreams (DWORD cStreams, DWORD *adwStreamIDs)
STDMETHODIMP | AddInputStreams (DWORD cStreams, DWORD *adwStreamIDs)
HRESULT | BeginStreaming ()
HRESULT | BeginStreaming ()
STDMETHODIMP | DeleteInputStream (DWORD dwStreamID)
STDMETHODIMP | DeleteInputStream (DWORD dwStreamID)
HRESULT | EndStreaming ()
HRESULT | EndStreaming ()
STDMETHODIMP | GetAttributes (IMFAttributes **pAttributes)
STDMETHODIMP | GetAttributes (IMFAttributes **pAttributes)
STDMETHODIMP | GetInputAvailableType (DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetInputAvailableType (DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetInputCurrentType (DWORD dwInputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetInputCurrentType (DWORD dwInputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetInputStatus (DWORD dwInputStreamID, DWORD *pdwFlags)
STDMETHODIMP | GetInputStatus (DWORD dwInputStreamID, DWORD *pdwFlags)
STDMETHODIMP | GetInputStreamAttributes (DWORD dwInputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetInputStreamAttributes (DWORD dwInputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetInputStreamInfo (DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetInputStreamInfo (DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetOutputAvailableType (DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetOutputAvailableType (DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetOutputCurrentType (DWORD dwOutputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetOutputCurrentType (DWORD dwOutputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetOutputStatus (DWORD *pdwFlags)
STDMETHODIMP | GetOutputStatus (DWORD *pdwFlags)
STDMETHODIMP | GetOutputStreamAttributes (DWORD dwOutputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetOutputStreamAttributes (DWORD dwOutputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetOutputStreamInfo (DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetOutputStreamInfo (DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetStreamCount (DWORD *pcInputStreams, DWORD *pcOutputStreams)
STDMETHODIMP | GetStreamCount (DWORD *pcInputStreams, DWORD *pcOutputStreams)
STDMETHODIMP | GetStreamIDs (DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs)
STDMETHODIMP | GetStreamIDs (DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs)
STDMETHODIMP | GetStreamLimits (DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum)
STDMETHODIMP | GetStreamLimits (DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum)
BOOL | HasPendingOutput () const
BOOL | HasPendingOutput () const
BOOL | IsValidInputStream (DWORD dwInputStreamID) const
BOOL | IsValidInputStream (DWORD dwInputStreamID) const
BOOL | IsValidOutputStream (DWORD dwOutputStreamID) const
BOOL | IsValidOutputStream (DWORD dwOutputStreamID) const
HRESULT | OnCheckInputType (IMFMediaType *pmt)
HRESULT | OnCheckInputType (IMFMediaType *pmt)
HRESULT | OnCheckMediaType (IMFMediaType *pmt)
HRESULT | OnCheckMediaType (IMFMediaType *pmt)
HRESULT | OnCheckOutputType (IMFMediaType *pmt)
HRESULT | OnCheckOutputType (IMFMediaType *pmt)
HRESULT | OnFlush ()
HRESULT | OnFlush ()
HRESULT | OnGetPartialType (DWORD dwTypeIndex, IMFMediaType **ppmt)
HRESULT | OnGetPartialType (DWORD dwTypeIndex, IMFMediaType **ppmt)
HRESULT | OnProcessOutput (IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
HRESULT | OnProcessOutput (IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
void | OnSetInputType (IMFMediaType *pmt)
void | OnSetInputType (IMFMediaType *pmt)
void | OnSetOutputType (IMFMediaType *pmt)
void | OnSetOutputType (IMFMediaType *pmt)
STDMETHODIMP | ProcessEvent (DWORD dwInputStreamID, IMFMediaEvent *pEvent)
STDMETHODIMP | ProcessEvent (DWORD dwInputStreamID, IMFMediaEvent *pEvent)
STDMETHODIMP | ProcessInput (DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags)
STDMETHODIMP | ProcessInput (DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags)
STDMETHODIMP | ProcessMessage (MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam)
STDMETHODIMP | ProcessMessage (MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam)
STDMETHODIMP | ProcessOutput (DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus)
STDMETHODIMP | ProcessOutput (DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus)
STDMETHOD() | RuntimeClassInitialize ()
STDMETHOD() | RuntimeClassInitialize ()
STDMETHODIMP | SetInputType (DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetInputType (DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetOutputBounds (LONGLONG hnsLowerBound, LONGLONG hnsUpperBound)
STDMETHODIMP | SetOutputBounds (LONGLONG hnsLowerBound, LONGLONG hnsUpperBound)
STDMETHODIMP | SetOutputType (DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetOutputType (DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
STDMETHODIMP | SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
HRESULT | UpdateFormatInfo ()
HRESULT | UpdateFormatInfo ()

Private Attributes

bool | m_bStreamingInitialized
DWORD | m_cbImageSize
CRITICAL_SECTION | m_critSec
UINT32 | m_imageHeightInPixels
UINT32 | m_imageWidthInPixels
IMFAttributes * | m_pAttributes
IMFMediaType * | m_pInputType
IMFMediaType * | m_pOutputType
IMFSample * | m_pSample
IMAGE_TRANSFORM_FN m_pTransformFn
D2D_RECT_U | m_rcDest
D2D1::Matrix3x2F | m_transform

Detailed Description

Definition at line 79 of file Grayscale.h.

Constructor & Destructor Documentation

CGrayscale::~CGrayscale ( ) [private]

Definition at line 362 of file Grayscale.cpp.

{
    SafeRelease(&m_pInputType);
    SafeRelease(&m_pOutputType);
    SafeRelease(&m_pSample);
    SafeRelease(&m_pAttributes);
    DeleteCriticalSection(&m_critSec);
}

InspectableClass (RuntimeClass_GrayscaleTransform_GrayscaleEffect, BaseTrust) public CGrayscale::~CGrayscale ( ) [private]

Member Function Documentation

HRESULT CGrayscale::AddInputStreams | ( | DWORD | cStreams,
 |  | DWORD * | adwStreamIDs |
 | ) |  |  | [private]

Definition at line 628 of file Grayscale.cpp.

{
    // This MFT has a fixed number of output streams, so the method is not supported.
    return E_NOTIMPL;
}

STDMETHODIMP CGrayscale::AddInputStreams | ( | DWORD | cStreams,
 |  | DWORD * | adwStreamIDs |
 | ) |  |  | [private]
HRESULT CGrayscale::BeginStreaming ( ) [private]

Definition at line 1488 of file Grayscale.cpp.

{
    HRESULT hr = S_OK;

    if (!m_bStreamingInitialized)
    {
        // Get the configuration attributes.

        // Get the destination rectangle.

        RECT rcDest;
        hr = m_pAttributes->GetBlob(MFT_GRAYSCALE_DESTINATION_RECT, (UINT8*)&rcDest, sizeof(rcDest), NULL);
        if (hr == MF_E_ATTRIBUTENOTFOUND || !ValidateRect(rcDest))
        {
            // The client did not set this attribute, or the client provided an invalid rectangle.
            // Default to the entire image.

            m_rcDest = D2D1::RectU(0, 0, m_imageWidthInPixels, m_imageHeightInPixels);
            hr = S_OK;
        }
        else if (SUCCEEDED(hr))
        {
            m_rcDest = D2D1::RectU(rcDest.left, rcDest.top, rcDest.right, rcDest.bottom);
        }
        else
        {
            goto done;
        }

        // Get the chroma transformations.

        float scale = (float)MFGetAttributeDouble(m_pAttributes, MFT_GRAYSCALE_SATURATION, 0.0f);
        float angle = (float)MFGetAttributeDouble(m_pAttributes, MFT_GRAYSCALE_CHROMA_ROTATION, 0.0f);

        m_transform = D2D1::Matrix3x2F::Scale(scale, scale) * D2D1::Matrix3x2F::Rotation(angle);

        m_bStreamingInitialized = true;
    }

done:
    return hr;
}

HRESULT CGrayscale::BeginStreaming ( ) [private]
HRESULT CGrayscale::DeleteInputStream ( DWORD dwStreamID ) [private]

Definition at line 617 of file Grayscale.cpp.

{
    // This MFT has a fixed number of input streams, so the method is not supported.
    return E_NOTIMPL;
}

STDMETHODIMP CGrayscale::DeleteInputStream ( DWORD dwStreamID ) [private]
HRESULT CGrayscale::EndStreaming ( ) [private]

Definition at line 1538 of file Grayscale.cpp.

{
    m_bStreamingInitialized = false;
    return S_OK;
}

HRESULT CGrayscale::EndStreaming ( ) [private]
HRESULT CGrayscale::GetAttributes ( IMFAttributes ** pAttributes ) [private]

Definition at line 566 of file Grayscale.cpp.

{
    if (ppAttributes == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    *ppAttributes = m_pAttributes;
    (*ppAttributes)->AddRef();

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CGrayscale::GetAttributes ( IMFAttributes ** pAttributes ) [private]
HRESULT CGrayscale::GetInputAvailableType | ( | DWORD | dwInputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 643 of file Grayscale.cpp.

{
    if (ppType == NULL)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    // If the output type is set, return that type as our preferred input type.
    if (m_pOutputType == NULL)
    {
        // The output type is not set. Create a partial media type.
        hr = OnGetPartialType(dwTypeIndex, ppType);
    }
    else if (dwTypeIndex > 0)
    {
        hr = MF_E_NO_MORE_TYPES;
    }
    else
    {
        *ppType = m_pOutputType;
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CGrayscale::GetInputAvailableType | ( | DWORD | dwInputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CGrayscale::GetInputCurrentType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 860 of file Grayscale.cpp.

{
    if (ppType == NULL)
    {
        return E_POINTER;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        hr = MF_E_INVALIDSTREAMNUMBER;
    }
    else if (!m_pInputType)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }
    else
    {
        *ppType = m_pInputType;
        (*ppType)->AddRef();
    }
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CGrayscale::GetInputCurrentType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CGrayscale::GetInputStatus | ( | DWORD | dwInputStreamID,
 |  | DWORD * | pdwFlags |
 | ) |  |  | [private]

Definition at line 935 of file Grayscale.cpp.

{
    if (pdwFlags == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    // If an input sample is already queued, do not accept another sample until the
    // client calls ProcessOutput or Flush.

    // NOTE: It is possible for an MFT to accept more than one input sample. For
    // example, this might be required in a video decoder if the frames do not
    // arrive in temporal order. In the case, the decoder must hold a queue of
    // samples. For the video effect, each sample is transformed independently, so
    // there is no reason to queue multiple input samples.

    if (m_pSample == NULL)
    {
        *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
    }
    else
    {
        *pdwFlags = 0;
    }

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CGrayscale::GetInputStatus | ( | DWORD | dwInputStreamID,
 |  | DWORD * | pdwFlags |
 | ) |  |  | [private]
HRESULT CGrayscale::GetInputStreamAttributes | ( | DWORD | dwInputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]

Definition at line 588 of file Grayscale.cpp.

{
    // This MFT does not support any stream-level attributes, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CGrayscale::GetInputStreamAttributes | ( | DWORD | dwInputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]
HRESULT CGrayscale::GetInputStreamInfo | ( | DWORD | dwInputStreamID,
 |  | MFT_INPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]

Definition at line 470 of file Grayscale.cpp.

{
    if (pStreamInfo == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    // NOTE: This method should succeed even when there is no media type on the
    //       stream. If there is no media type, we only need to fill in the dwFlags
    //       member of MFT_INPUT_STREAM_INFO. The other members depend on having a
    //       a valid media type.

    pStreamInfo->hnsMaxLatency = 0;
    pStreamInfo->dwFlags = MFT_INPUT_STREAM_WHOLE_SAMPLES | MFT_INPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER;

    if (m_pInputType == NULL)
    {
        pStreamInfo->cbSize = 0;
    }
    else
    {
        pStreamInfo->cbSize = m_cbImageSize;
    }

    pStreamInfo->cbMaxLookahead = 0;
    pStreamInfo->cbAlignment = 0;

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CGrayscale::GetInputStreamInfo | ( | DWORD | dwInputStreamID,
 |  | MFT_INPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]
STDMETHODIMP CGrayscale::GetOutputAvailableType | ( | DWORD | dwOutputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CGrayscale::GetOutputAvailableType | ( | DWORD | dwOutputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 691 of file Grayscale.cpp.

{
    if (ppType == NULL)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    if (m_pInputType == NULL)
    {
        // The input type is not set. Create a partial media type.
        hr = OnGetPartialType(dwTypeIndex, ppType);
    }
    else if (dwTypeIndex > 0)
    {
        hr = MF_E_NO_MORE_TYPES;
    }
    else
    {
        *ppType = m_pInputType;
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CGrayscale::GetOutputCurrentType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 897 of file Grayscale.cpp.

{
    if (ppType == NULL)
    {
        return E_POINTER;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        hr = MF_E_INVALIDSTREAMNUMBER;
    }
    else if (!m_pOutputType)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }
    else
    {
        *ppType = m_pOutputType;
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CGrayscale::GetOutputCurrentType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CGrayscale::GetOutputStatus ( DWORD * pdwFlags ) [private]

Definition at line 982 of file Grayscale.cpp.

{
    if (pdwFlags == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    // The MFT can produce an output sample if (and only if) there an input sample.
    if (m_pSample != NULL)
    {
        *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
    }
    else
    {
        *pdwFlags = 0;
    }

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CGrayscale::GetOutputStatus ( DWORD * pdwFlags ) [private]
HRESULT CGrayscale::GetOutputStreamAttributes | ( | DWORD | dwOutputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]

Definition at line 603 of file Grayscale.cpp.

{
    // This MFT does not support any stream-level attributes, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CGrayscale::GetOutputStreamAttributes | ( | DWORD | dwOutputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]
STDMETHODIMP CGrayscale::GetOutputStreamInfo | ( | DWORD | dwOutputStreamID,
 |  | MFT_OUTPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]
HRESULT CGrayscale::GetOutputStreamInfo | ( | DWORD | dwOutputStreamID,
 |  | MFT_OUTPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]

Definition at line 517 of file Grayscale.cpp.

{
    if (pStreamInfo == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    // NOTE: This method should succeed even when there is no media type on the
    //       stream. If there is no media type, we only need to fill in the dwFlags
    //       member of MFT_OUTPUT_STREAM_INFO. The other members depend on having a
    //       a valid media type.

    pStreamInfo->dwFlags =
        MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
        MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
        MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;

    if (m_pOutputType == NULL)
    {
        pStreamInfo->cbSize = 0;
    }
    else
    {
        pStreamInfo->cbSize = m_cbImageSize;
    }

    pStreamInfo->cbAlignment = 0;

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CGrayscale::GetStreamCount | ( | DWORD * | pcInputStreams,
 |  | DWORD * | pcOutputStreams |
 | ) |  |  | [private]
HRESULT CGrayscale::GetStreamCount | ( | DWORD * | pcInputStreams,
 |  | DWORD * | pcOutputStreams |
 | ) |  |  | [private]

Definition at line 425 of file Grayscale.cpp.

{
    if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))

    {
        return E_POINTER;
    }

    // This MFT has a fixed number of streams.
    *pcInputStreams = 1;
    *pcOutputStreams = 1;
    return S_OK;
}

HRESULT CGrayscale::GetStreamIDs | ( | DWORD | dwInputIDArraySize,
 |  | DWORD * | pdwInputIDs,
 |  | DWORD | dwOutputIDArraySize,
 |  | DWORD * | pdwOutputIDs |
 | ) |  |  | [private]

Definition at line 449 of file Grayscale.cpp.

{
    // It is not required to implement this method if the MFT has a fixed number of
    // streams AND the stream IDs are numbered sequentially from zero (that is, the
    // stream IDs match the stream indexes).

    // In that case, it is OK to return E_NOTIMPL.
    return E_NOTIMPL;
}

STDMETHODIMP CGrayscale::GetStreamIDs | ( | DWORD | dwInputIDArraySize,
 |  | DWORD * | pdwInputIDs,
 |  | DWORD | dwOutputIDArraySize,
 |  | DWORD * | pdwOutputIDs |
 | ) |  |  | [private]
HRESULT CGrayscale::GetStreamLimits | ( | DWORD * | pdwInputMinimum,
 |  | DWORD * | pdwInputMaximum,
 |  | DWORD * | pdwOutputMinimum,
 |  | DWORD * | pdwOutputMaximum |
 | ) |  |  | [private]

Definition at line 396 of file Grayscale.cpp.

{
    if ((pdwInputMinimum == NULL) ||
        (pdwInputMaximum == NULL) ||
        (pdwOutputMinimum == NULL) ||
        (pdwOutputMaximum == NULL))
    {
        return E_POINTER;
    }

    // This MFT has a fixed number of streams.
    *pdwInputMinimum = 1;
    *pdwInputMaximum = 1;
    *pdwOutputMinimum = 1;
    *pdwOutputMaximum = 1;
    return S_OK;
}

STDMETHODIMP CGrayscale::GetStreamLimits | ( | DWORD * | pdwInputMinimum,
 |  | DWORD * | pdwInputMaximum,
 |  | DWORD * | pdwOutputMinimum,
 |  | DWORD * | pdwOutputMaximum |
 | ) |  |  | [private]
BOOL CGrayscale::HasPendingOutput ( ) const [inline, private]

Definition at line 218 of file Grayscale.h.

{ return m_pSample != NULL; }

BOOL CGrayscale::HasPendingOutput ( ) const [inline, private]

Definition at line 218 of file Grayscale.h.

{ return m_pSample != NULL; }

BOOL CGrayscale::IsValidInputStream ( DWORD dwInputStreamID ) const [inline, private]

Definition at line 221 of file Grayscale.h.

    {
        return dwInputStreamID == 0;
    }

BOOL CGrayscale::IsValidInputStream ( DWORD dwInputStreamID ) const [inline, private]

Definition at line 221 of file Grayscale.h.

    {
        return dwInputStreamID == 0;
    }

BOOL CGrayscale::IsValidOutputStream ( DWORD dwOutputStreamID ) const [inline, private]

Definition at line 227 of file Grayscale.h.

    {
        return dwOutputStreamID == 0;
    }

BOOL CGrayscale::IsValidOutputStream ( DWORD dwOutputStreamID ) const [inline, private]

Definition at line 227 of file Grayscale.h.

    {
        return dwOutputStreamID == 0;
    }

HRESULT CGrayscale::OnCheckInputType ( IMFMediaType * pmt ) [private]
HRESULT CGrayscale::OnCheckInputType ( IMFMediaType * pmt ) [private]

Definition at line 1330 of file Grayscale.cpp.

{
    assert(pmt != NULL);

    HRESULT hr = S_OK;

    // If the output type is set, see if they match.
    if (m_pOutputType != NULL)
    {
        DWORD flags = 0;
        hr = pmt->IsEqual(m_pOutputType, &flags);

        // IsEqual can return S_FALSE. Treat this as failure.
        if (hr != S_OK)
        {
            hr = MF_E_INVALIDMEDIATYPE;
        }
    }
    else
    {
        // Output type is not set. Just check this type.
        hr = OnCheckMediaType(pmt);
    }
    return hr;
}

HRESULT CGrayscale::OnCheckMediaType ( IMFMediaType * pmt ) [private]

Definition at line 1389 of file Grayscale.cpp.

{
    BOOL bFoundMatchingSubtype = FALSE;

    // Major type must be video.
    GUID major_type;
    HRESULT hr = pmt->GetGUID(MF_MT_MAJOR_TYPE, &major_type);
    if (FAILED(hr))
    {
        goto done;
    }

    if (major_type != MFMediaType_Video)
    {
        hr = MF_E_INVALIDMEDIATYPE;
        goto done;
    }

    // Subtype must be one of the subtypes in our global list.

    // Get the subtype GUID.
    GUID subtype;
    hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
    if (FAILED(hr))
    {
        goto done;
    }

    // Look for the subtype in our list of accepted types.
    for (DWORD i = 0; i < ARRAYSIZE(g_MediaSubtypes); i++)
    {
        if (subtype == g_MediaSubtypes[i])
        {
            bFoundMatchingSubtype = TRUE;
            break;
        }
    }

    if (!bFoundMatchingSubtype)
    {
        hr = MF_E_INVALIDMEDIATYPE; // The MFT does not support this subtype.
        goto done;
    }

    // Reject single-field media types.
    UINT32 interlace = MFGetAttributeUINT32(pmt, MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
    if (interlace == MFVideoInterlace_FieldSingleUpper  || interlace == MFVideoInterlace_FieldSingleLower)
    {
        hr = MF_E_INVALIDMEDIATYPE;
    }

done:
    return hr;
}

HRESULT CGrayscale::OnCheckMediaType ( IMFMediaType * pmt ) [private]
HRESULT CGrayscale::OnCheckOutputType ( IMFMediaType * pmt ) [private]
HRESULT CGrayscale::OnCheckOutputType ( IMFMediaType * pmt ) [private]

Definition at line 1359 of file Grayscale.cpp.

{
    assert(pmt != NULL);

    HRESULT hr = S_OK;

    // If the input type is set, see if they match.
    if (m_pInputType != NULL)
    {
        DWORD flags = 0;
        hr = pmt->IsEqual(m_pInputType, &flags);

        // IsEqual can return S_FALSE. Treat this as failure.
        if (hr != S_OK)
        {
            hr = MF_E_INVALIDMEDIATYPE;
        }

    }
    else
    {
        // Input type is not set. Just check this type.
        hr = OnCheckMediaType(pmt);
    }
    return hr;
}

HRESULT CGrayscale::OnFlush ( ) [private]
HRESULT CGrayscale::OnFlush ( ) [private]

Definition at line 1608 of file Grayscale.cpp.

{
    // For this MFT, flushing just means releasing the input sample.
    SafeRelease(&m_pSample);
    return S_OK;
}

HRESULT CGrayscale::OnGetPartialType | ( | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppmt |
 | ) |  |  | [private]
HRESULT CGrayscale::OnGetPartialType | ( | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppmt |
 | ) |  |  | [private]

Definition at line 1292 of file Grayscale.cpp.

{
    if (dwTypeIndex >= ARRAYSIZE(g_MediaSubtypes))
    {
        return MF_E_NO_MORE_TYPES;
    }

    IMFMediaType *pmt = NULL;

    HRESULT hr = MFCreateMediaType(&pmt);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = pmt->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = pmt->SetGUID(MF_MT_SUBTYPE, g_MediaSubtypes[dwTypeIndex]);
    if (FAILED(hr))
    {
        goto done;
    }

    *ppmt = pmt;
    (*ppmt)->AddRef();

done:
    SafeRelease(&pmt);
    return hr;
}

HRESULT CGrayscale::OnProcessOutput | ( | IMFMediaBuffer * | pIn,
 |  | IMFMediaBuffer * | pOut |
 | ) |  |  | [private]
HRESULT CGrayscale::OnProcessOutput | ( | IMFMediaBuffer * | pIn,
 |  | IMFMediaBuffer * | pOut |
 | ) |  |  | [private]

Definition at line 1548 of file Grayscale.cpp.

{
    BYTE *pDest = NULL;         // Destination buffer.
    LONG lDestStride = 0;       // Destination stride.

    BYTE *pSrc = NULL;          // Source buffer.
    LONG lSrcStride = 0;        // Source stride.

    // Helper objects to lock the buffers.
    VideoBufferLock inputLock(pIn);
    VideoBufferLock outputLock(pOut);

    // Stride if the buffer does not support IMF2DBuffer
    LONG lDefaultStride = 0;

    HRESULT hr = GetDefaultStride(m_pInputType, &lDefaultStride);
    if (FAILED(hr))
    {
        goto done;
    }

    // Lock the input buffer.
    hr = inputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pSrc, &lSrcStride);
    if (FAILED(hr))
    {
        goto done;
    }

    // Lock the output buffer.
    hr = outputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pDest, &lDestStride);
    if (FAILED(hr))
    {
        goto done;
    }

    // Invoke the image transform function.
    assert (m_pTransformFn != NULL);
    if (m_pTransformFn)
    {
        (*m_pTransformFn)(m_transform, m_rcDest, pDest, lDestStride, pSrc, lSrcStride,
            m_imageWidthInPixels, m_imageHeightInPixels);
    }
    else
    {
        hr = E_UNEXPECTED;
        goto done;
    }

    // Set the data size on the output buffer.
    hr = pOut->SetCurrentLength(m_cbImageSize);

    // The VideoBufferLock class automatically unlocks the buffers.
done:
    return hr;
}

void CGrayscale::OnSetInputType ( IMFMediaType * pmt ) [private]
void CGrayscale::OnSetInputType ( IMFMediaType * pmt ) [private]

Definition at line 1449 of file Grayscale.cpp.

{
    // if pmt is NULL, clear the type.
    // if pmt is non-NULL, set the type.

    SafeRelease(&m_pInputType);
    m_pInputType = pmt;
    if (m_pInputType)
    {
        m_pInputType->AddRef();
    }

    // Update the format information.
    UpdateFormatInfo();
}

void CGrayscale::OnSetOutputType ( IMFMediaType * pmt ) [private]
void CGrayscale::OnSetOutputType ( IMFMediaType * pmt ) [private]

Definition at line 1470 of file Grayscale.cpp.

{
    // If pmt is NULL, clear the type. Otherwise, set the type.

    SafeRelease(&m_pOutputType);
    m_pOutputType = pmt;
    if (m_pOutputType)
    {
        m_pOutputType->AddRef();
    }
}

HRESULT CGrayscale::ProcessEvent | ( | DWORD | dwInputStreamID,
 |  | IMFMediaEvent * | pEvent |
 | ) |  |  | [private]

Definition at line 1026 of file Grayscale.cpp.

{
    // This MFT does not handle any stream events, so the method can
    // return E_NOTIMPL. This tells the pipeline that it can stop
    // sending any more events to this MFT.
    return E_NOTIMPL;
}

STDMETHODIMP CGrayscale::ProcessEvent | ( | DWORD | dwInputStreamID,
 |  | IMFMediaEvent * | pEvent |
 | ) |  |  | [private]
HRESULT CGrayscale::ProcessInput | ( | DWORD | dwInputStreamID,
 |  | IMFSample * | pSample,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 1107 of file Grayscale.cpp.

{
    // Check input parameters.
    if (pSample == NULL)
    {
        return E_POINTER;
    }

    if (dwFlags != 0)
    {
        return E_INVALIDARG; // dwFlags is reserved and must be zero.
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    // Validate the input stream number.
    if (!IsValidInputStream(dwInputStreamID))
    {
        hr = MF_E_INVALIDSTREAMNUMBER;
        goto done;
    }

    // Check for valid media types.
    // The client must set input and output types before calling ProcessInput.
    if (!m_pInputType || !m_pOutputType)
    {
        hr = MF_E_NOTACCEPTING;
        goto done;
    }

    // Check if an input sample is already queued.
    if (m_pSample != NULL)
    {
        hr = MF_E_NOTACCEPTING;   // We already have an input sample.
        goto done;
    }

    // Initialize streaming.
    hr = BeginStreaming();
    if (FAILED(hr))
    {
        goto done;
    }

    // Cache the sample. We do the actual work in ProcessOutput.
    m_pSample = pSample;
    pSample->AddRef();  // Hold a reference count on the sample.

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CGrayscale::ProcessInput | ( | DWORD | dwInputStreamID,
 |  | IMFSample * | pSample,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
HRESULT CGrayscale::ProcessMessage | ( | MFT_MESSAGE_TYPE | eMessage,
 |  | ULONG_PTR | ulParam |
 | ) |  |  | [private]

Definition at line 1042 of file Grayscale.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    switch (eMessage)
    {
    case MFT_MESSAGE_COMMAND_FLUSH:
        // Flush the MFT.
        hr = OnFlush();
        break;

    case MFT_MESSAGE_COMMAND_DRAIN:
        // Drain: Tells the MFT to reject further input until all pending samples are
        // processed. That is our default behavior already, so there is nothing to do.
        //
        // For a decoder that accepts a queue of samples, the MFT might need to drain
        // the queue in response to this command.
    break;

    case MFT_MESSAGE_SET_D3D_MANAGER:
        // Sets a pointer to the IDirect3DDeviceManager9 interface.

        // The pipeline should never send this message unless the MFT sets the MF_SA_D3D_AWARE
        // attribute set to TRUE. Because this MFT does not set MF_SA_D3D_AWARE, it is an error
        // to send the MFT_MESSAGE_SET_D3D_MANAGER message to the MFT. Return an error code in
        // this case.

        // NOTE: If this MFT were D3D-enabled, it would cache the IDirect3DDeviceManager9
        // pointer for use during streaming.

        hr = E_NOTIMPL;
        break;

    case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
        hr = BeginStreaming();
        break;

    case MFT_MESSAGE_NOTIFY_END_STREAMING:
        hr = EndStreaming();
        break;

    // The next two messages do not require any action from this MFT.

    case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
        break;

    case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
        break;
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CGrayscale::ProcessMessage | ( | MFT_MESSAGE_TYPE | eMessage,
 |  | ULONG_PTR | ulParam |
 | ) |  |  | [private]
STDMETHODIMP CGrayscale::ProcessOutput | ( | DWORD | dwFlags,
 |  | DWORD | cOutputBufferCount,
 |  | MFT_OUTPUT_DATA_BUFFER * | pOutputSamples,
 |  | DWORD * | pdwStatus |
 | ) |  |  | [private]
HRESULT CGrayscale::ProcessOutput | ( | DWORD | dwFlags,
 |  | DWORD | cOutputBufferCount,
 |  | MFT_OUTPUT_DATA_BUFFER * | pOutputSamples,
 |  | DWORD * | pdwStatus |
 | ) |  |  | [private]

Definition at line 1172 of file Grayscale.cpp.

{
    // Check input parameters...

    // This MFT does not accept any flags for the dwFlags parameter.

    // The only defined flag is MFT_PROCESS_OUTPUT_DISCARD_WHEN_NO_BUFFER. This flag
    // applies only when the MFT marks an output stream as lazy or optional. But this
    // MFT has no lazy or optional streams, so the flag is not valid.

    if (dwFlags != 0)
    {
        return E_INVALIDARG;
    }

    if (pOutputSamples == NULL || pdwStatus == NULL)
    {
        return E_POINTER;
    }

    // There must be exactly one output buffer.
    if (cOutputBufferCount != 1)
    {
        return E_INVALIDARG;
    }

    // It must contain a sample.
    if (pOutputSamples[0].pSample == NULL)
    {
        return E_INVALIDARG;
    }

    HRESULT hr = S_OK;

    IMFMediaBuffer *pInput = NULL;
    IMFMediaBuffer *pOutput = NULL;

    EnterCriticalSection(&m_critSec);

    // There must be an input sample available for processing.
    if (m_pSample == NULL)
    {
        hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
        goto done;
    }

    // Initialize streaming.

    hr = BeginStreaming();
    if (FAILED(hr))
    {
        goto done;
    }

    // Get the input buffer.
    hr = m_pSample->ConvertToContiguousBuffer(&pInput);
    if (FAILED(hr))
    {
        goto done;
    }

    // Get the output buffer.
    hr = pOutputSamples[0].pSample->ConvertToContiguousBuffer(&pOutput);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = OnProcessOutput(pInput, pOutput);
    if (FAILED(hr))
    {
        goto done;
    }

    // Set status flags.
    pOutputSamples[0].dwStatus = 0;
    *pdwStatus = 0;

    // Copy the duration and time stamp from the input sample, if present.

    LONGLONG hnsDuration = 0;
    LONGLONG hnsTime = 0;

    if (SUCCEEDED(m_pSample->GetSampleDuration(&hnsDuration)))
    {
        hr = pOutputSamples[0].pSample->SetSampleDuration(hnsDuration);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    if (SUCCEEDED(m_pSample->GetSampleTime(&hnsTime)))
    {
        hr = pOutputSamples[0].pSample->SetSampleTime(hnsTime);
    }

done:
    SafeRelease(&m_pSample);   // Release our input sample.
    SafeRelease(&pInput);
    SafeRelease(&pOutput);
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHOD() CGrayscale::RuntimeClassInitialize ( ) [private]
STDMETHODIMP CGrayscale::RuntimeClassInitialize ( ) [private]

Definition at line 372 of file Grayscale.cpp.

{
    // Create the attribute store.
    return MFCreateAttributes(&m_pAttributes, 3);
}

HRESULT CGrayscale::SetInputType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 736 of file Grayscale.cpp.

{
    // Validate flags.
    if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    // Does the caller want us to set the type, or just test it?
    BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);

    // If we have an input sample, the client cannot change the type now.
    if (HasPendingOutput())
    {
        hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
        goto done;
    }

    // Validate the type, if non-NULL.
    if (pType)
    {
        hr = OnCheckInputType(pType);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    // The type is OK. Set the type, unless the caller was just testing.
    if (bReallySet)
    {
        OnSetInputType(pType);

        // When the type changes, end streaming.
        hr = EndStreaming();
    }

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CGrayscale::SetInputType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
STDMETHODIMP CGrayscale::SetOutputBounds | ( | LONGLONG | hnsLowerBound,
 |  | LONGLONG | hnsUpperBound |
 | ) |  |  | [private]
HRESULT CGrayscale::SetOutputBounds | ( | LONGLONG | hnsLowerBound,
 |  | LONGLONG | hnsUpperBound |
 | ) |  |  | [private]

Definition at line 1011 of file Grayscale.cpp.

{
    // Implementation of this method is optional.
    return E_NOTIMPL;
}

STDMETHODIMP CGrayscale::SetOutputType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
HRESULT CGrayscale::SetOutputType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 798 of file Grayscale.cpp.

{
    // Validate flags.
    if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    // Does the caller want us to set the type, or just test it?
    BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);

    // If we have an input sample, the client cannot change the type now.
    if (HasPendingOutput())
    {
        hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
        goto done;
    }

    // Validate the type, if non-NULL.
    if (pType)
    {
        hr = OnCheckOutputType(pType);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    // The type is OK. Set the type, unless the caller was just testing.
    if (bReallySet)
    {
        OnSetOutputType(pType);

        // When the type changes, end streaming.
        hr = EndStreaming();
    }

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CGrayscale::SetProperties ( ABI::Windows::Foundation::Collections::IPropertySet * pConfiguration ) [private]

Definition at line 384 of file Grayscale.cpp.

{
    return S_OK;
}

STDMETHODIMP CGrayscale::SetProperties ( ABI::Windows::Foundation::Collections::IPropertySet * pConfiguration ) [private]
HRESULT CGrayscale::UpdateFormatInfo ( ) [private]

Definition at line 1619 of file Grayscale.cpp.

{
    HRESULT hr = S_OK;

    GUID subtype = GUID_NULL;

    m_imageWidthInPixels = 0;
    m_imageHeightInPixels = 0;
    m_cbImageSize = 0;

    m_pTransformFn = NULL;

    if (m_pInputType != NULL)
    {
        hr = m_pInputType->GetGUID(MF_MT_SUBTYPE, &subtype);
        if (FAILED(hr))
        {
            goto done;
        }
        if (subtype == MFVideoFormat_YUY2)
        {
            m_pTransformFn = TransformImage_YUY2;
        }
        else if (subtype == MFVideoFormat_UYVY)
        {
            m_pTransformFn = TransformImage_UYVY;
        }
        else if (subtype == MFVideoFormat_NV12)
        {
            m_pTransformFn = TransformImage_NV12;
        }
        else
        {
            hr = E_UNEXPECTED;
            goto done;
        }

        hr = MFGetAttributeSize(m_pInputType, MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);
        if (FAILED(hr))
        {
            goto done;
        }

        // Calculate the image size (not including padding)
        hr = GetImageSize(subtype.Data1, m_imageWidthInPixels, m_imageHeightInPixels, &m_cbImageSize);
    }

done:
    return hr;
}

HRESULT CGrayscale::UpdateFormatInfo ( ) [private]

Member Data Documentation

bool CGrayscale::m_bStreamingInitialized [private]

Definition at line 251 of file Grayscale.h.

DWORD CGrayscale::m_cbImageSize [private]

Definition at line 259 of file Grayscale.h.

CRITICAL_SECTION CGrayscale::m_critSec [private]

Definition at line 244 of file Grayscale.h.

UINT32 CGrayscale::m_imageHeightInPixels [private]

Definition at line 258 of file Grayscale.h.

UINT32 CGrayscale::m_imageWidthInPixels [private]

Definition at line 257 of file Grayscale.h.

IMFAttributes * CGrayscale::m_pAttributes [private]

Definition at line 261 of file Grayscale.h.

IMFMediaType * CGrayscale::m_pInputType [private]

Definition at line 253 of file Grayscale.h.

IMFMediaType * CGrayscale::m_pOutputType [private]

Definition at line 254 of file Grayscale.h.

IMFSample * CGrayscale::m_pSample [private]

Definition at line 252 of file Grayscale.h.

IMAGE_TRANSFORM_FN CGrayscale::m_pTransformFn [private]

Definition at line 264 of file Grayscale.h.

D2D_RECT_U CGrayscale::m_rcDest [private]

Definition at line 248 of file Grayscale.h.

D2D1::Matrix3x2F CGrayscale::m_transform [private]

Definition at line 247 of file Grayscale.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Grayscale/Grayscale.h
  • Media extensions/C++/MediaExtensions/Grayscale/Grayscale.h
  • Media extensions/C#,C++/MediaExtensions/Grayscale/Grayscale.cpp
  • Media extensions/C++/MediaExtensions/Grayscale/Grayscale.cpp
Generated on Sat Nov 23 2024 16:09:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CInvert Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Private Member Functions | Private Attributes

CInvert Class Reference

#include "Invert.h"

List of all members.

Private Member Functions

InspectableClass(RuntimeClass_InvertTransform_InvertEffect,
BaseTrust) public 		~CInvert ()
InspectableClass(RuntimeClass_InvertTransform_InvertEffect,
BaseTrust) public 		~CInvert ()
STDMETHODIMP | AddInputStreams (DWORD cStreams, DWORD *adwStreamIDs)
STDMETHODIMP | AddInputStreams (DWORD cStreams, DWORD *adwStreamIDs)
HRESULT | BeginStreaming ()
HRESULT | BeginStreaming ()
HRESULT | CheckDX11Device ()
HRESULT | CheckDX11Device ()
STDMETHODIMP | DeleteInputStream (DWORD dwStreamID)
STDMETHODIMP | DeleteInputStream (DWORD dwStreamID)
STDMETHODIMP | GetAttributes (IMFAttributes **pAttributes)
STDMETHODIMP | GetAttributes (IMFAttributes **pAttributes)
STDMETHODIMP | GetInputAvailableType (DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetInputAvailableType (DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetInputCurrentType (DWORD dwInputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetInputCurrentType (DWORD dwInputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetInputStatus (DWORD dwInputStreamID, DWORD *pdwFlags)
STDMETHODIMP | GetInputStatus (DWORD dwInputStreamID, DWORD *pdwFlags)
STDMETHODIMP | GetInputStreamAttributes (DWORD dwInputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetInputStreamAttributes (DWORD dwInputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetInputStreamInfo (DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetInputStreamInfo (DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetOutputAvailableType (DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetOutputAvailableType (DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetOutputCurrentType (DWORD dwOutputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetOutputCurrentType (DWORD dwOutputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetOutputStatus (DWORD *pdwFlags)
STDMETHODIMP | GetOutputStatus (DWORD *pdwFlags)
STDMETHODIMP | GetOutputStreamAttributes (DWORD dwOutputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetOutputStreamAttributes (DWORD dwOutputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetOutputStreamInfo (DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetOutputStreamInfo (DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetStreamCount (DWORD *pcInputStreams, DWORD *pcOutputStreams)
STDMETHODIMP | GetStreamCount (DWORD *pcInputStreams, DWORD *pcOutputStreams)
STDMETHODIMP | GetStreamIDs (DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs)
STDMETHODIMP | GetStreamIDs (DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs)
STDMETHODIMP | GetStreamLimits (DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum)
STDMETHODIMP | GetStreamLimits (DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum)
void | InvalidateDX11Resources ()
void | InvalidateDX11Resources ()
HRESULT | OnCheckInputType (IMFMediaType *pmt)
HRESULT | OnCheckInputType (IMFMediaType *pmt)
HRESULT | OnCheckMediaType (IMFMediaType *pmt)
HRESULT | OnCheckMediaType (IMFMediaType *pmt)
HRESULT | OnCheckOutputType (IMFMediaType *pmt)
HRESULT | OnCheckOutputType (IMFMediaType *pmt)
HRESULT | OnGetPartialType (DWORD dwTypeIndex, IMFMediaType **ppmt)
HRESULT | OnGetPartialType (DWORD dwTypeIndex, IMFMediaType **ppmt)
HRESULT | OnProcessOutput (IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
HRESULT | OnProcessOutput (IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
STDMETHODIMP | ProcessEvent (DWORD dwInputStreamID, IMFMediaEvent *pEvent)
STDMETHODIMP | ProcessEvent (DWORD dwInputStreamID, IMFMediaEvent *pEvent)
STDMETHODIMP | ProcessInput (DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags)
STDMETHODIMP | ProcessInput (DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags)
STDMETHODIMP | ProcessMessage (MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam)
STDMETHODIMP | ProcessMessage (MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam)
STDMETHODIMP | ProcessOutput (DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus)
STDMETHODIMP | ProcessOutput (DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus)
STDMETHOD() | RuntimeClassInitialize ()
STDMETHOD() | RuntimeClassInitialize ()
STDMETHODIMP | SetInputType (DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetInputType (DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetOutputBounds (LONGLONG hnsLowerBound, LONGLONG hnsUpperBound)
STDMETHODIMP | SetOutputBounds (LONGLONG hnsLowerBound, LONGLONG hnsUpperBound)
STDMETHODIMP | SetOutputType (DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetOutputType (DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
STDMETHODIMP | SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
HRESULT | UpdateDX11Device ()
HRESULT | UpdateDX11Device ()
HRESULT | UpdateFormatInfo ()
HRESULT | UpdateFormatInfo ()

Private Attributes

bool | m_bStreamingInitialized
DWORD | m_cbImageSize
CRITICAL_SECTION | m_critSec
HANDLE | m_hDeviceHandle
UINT32 | m_imageHeightInPixels
UINT32 | m_imageWidthInPixels
ComPtr< IMFAttributes > | m_pAttributes
ComPtr< ID3D11DeviceContext > | m_pContext
ComPtr< ID3D11Device > | m_pDevice
ComPtr< IMFDXGIDeviceManager > | m_pDX11Manager
ComPtr< ID3D11Texture2D > | m_pInBufferTex
ComPtr< IMFMediaType > | m_pInputType
ComPtr< ID3D11Texture2D > | m_pOutBufferStage
ComPtr< ID3D11Texture2D > | m_pOutBufferTex
ComPtr< IMFMediaType > | m_pOutputType
ComPtr< IMFSample > | m_pSample
DirectXVideoTransform * | m_pTransform
ComPtr< IMFAttributes > | m_spOutputAttributes
ComPtr< IMFVideoSampleAllocatorEx > | m_spOutputSampleAllocator

Detailed Description

Definition at line 35 of file Invert.h.

Constructor & Destructor Documentation

CInvert::~CInvert ( ) [private]

Definition at line 29 of file Invert.cpp.

{
    DeleteCriticalSection(&m_critSec);
    if( m_pTransform )
    {
        delete m_pTransform;
    }
}

InspectableClass (RuntimeClass_InvertTransform_InvertEffect, BaseTrust) public CInvert::~CInvert ( ) [private]

Member Function Documentation

STDMETHODIMP CInvert::AddInputStreams | ( | DWORD | cStreams,
 |  | DWORD * | adwStreamIDs |
 | ) |  |  | [inline, private]

Definition at line 156 of file Invert.h.

          { return E_NOTIMPL; }

STDMETHODIMP CInvert::AddInputStreams | ( | DWORD | cStreams,
 |  | DWORD * | adwStreamIDs |
 | ) |  |  | [inline, private]

Definition at line 156 of file Invert.h.

          { return E_NOTIMPL; }

HRESULT CInvert::BeginStreaming ( ) [private]
HRESULT CInvert::BeginStreaming ( ) [private]

Definition at line 1135 of file Invert.cpp.

{
    HRESULT hr = S_OK;

    if (!m_bStreamingInitialized)
    {
        if( m_pDevice == nullptr )
        {
            hr = UpdateDX11Device();
            if (FAILED(hr))
            {
                goto done;
            }
        }

        hr = m_pTransform->Initialize(m_pDevice.Get(), m_imageWidthInPixels, m_imageHeightInPixels);
        if (FAILED(hr))
        {
            goto done;
        }

        // if the device is dxman we need to alloc samples...
        if( m_pDX11Manager != nullptr )
        {
            DWORD dwBindFlags = MFGetAttributeUINT32( m_spOutputAttributes.Get(), MF_SA_D3D11_BINDFLAGS, D3D11_BIND_RENDER_TARGET );
            dwBindFlags |= D3D11_BIND_RENDER_TARGET;        // render target binding must always be set
            hr = m_spOutputAttributes->SetUINT32( MF_SA_D3D11_BINDFLAGS, dwBindFlags );
            if (FAILED(hr))
            {
                goto done;
            }
            hr = m_spOutputAttributes->SetUINT32( MF_SA_BUFFERS_PER_SAMPLE, 1 );
            if (FAILED(hr))
            {
                goto done;
            }
            hr = m_spOutputAttributes->SetUINT32( MF_SA_D3D11_USAGE, D3D11_USAGE_DEFAULT );
            if (FAILED(hr))
            {
                goto done;
            }

            if ( NULL == m_spOutputSampleAllocator )
            {
                ComPtr<IMFVideoSampleAllocatorEx> spVideoSampleAllocator;
                ComPtr<IUnknown> spDXGIManagerUnk;

                hr = MFCreateVideoSampleAllocatorEx( IID_PPV_ARGS( &spVideoSampleAllocator ) );
                if (FAILED(hr))
                {
                    goto done;
                }

                hr = m_pDX11Manager.As( &spDXGIManagerUnk );
                if (FAILED(hr))
                {
                    goto done;
                }

                hr = spVideoSampleAllocator->SetDirectXManager( spDXGIManagerUnk.Get() );
                if (FAILED(hr))
                {
                    goto done;
                }

                m_spOutputSampleAllocator.Attach( spVideoSampleAllocator.Detach() );
            }

            hr = m_spOutputSampleAllocator->InitializeSampleAllocatorEx( 1, 10, m_spOutputAttributes.Get(), m_pOutputType.Get() );

            if ( FAILED(hr) && (dwBindFlags != D3D11_BIND_RENDER_TARGET) )
            {
                // Try again with only the mandatory "render target" binding
                hr = m_spOutputAttributes->SetUINT32( MF_SA_D3D11_BINDFLAGS, D3D11_BIND_RENDER_TARGET );
                if (FAILED(hr))
                {
                    goto done;
                }
                hr = m_spOutputSampleAllocator->InitializeSampleAllocatorEx( 1, 10, m_spOutputAttributes.Get(), m_pOutputType.Get() );
                if (FAILED(hr))
                {
                    goto done;
                }
            }
        }

        m_bStreamingInitialized = true;
    }

done:
    return hr;
}

HRESULT CInvert::CheckDX11Device ( ) [private]

Definition at line 911 of file Invert.cpp.

{
    HRESULT hr = S_OK;

    if(m_pDX11Manager != nullptr && m_hDeviceHandle )
    {
        if(m_pDX11Manager->TestDevice(m_hDeviceHandle) != S_OK)
        {
            InvalidateDX11Resources();

            hr = UpdateDX11Device();
            if (FAILED(hr))
            {
                return hr;
            }

            return m_pTransform->Initialize(m_pDevice.Get(), m_imageWidthInPixels, m_imageHeightInPixels);
        }
    }

    return S_OK;
}

HRESULT CInvert::CheckDX11Device ( ) [private]
STDMETHODIMP CInvert::DeleteInputStream ( DWORD dwStreamID ) [inline, private]

Definition at line 154 of file Invert.h.

{ return E_NOTIMPL; }

STDMETHODIMP CInvert::DeleteInputStream ( DWORD dwStreamID ) [inline, private]

Definition at line 154 of file Invert.h.

{ return E_NOTIMPL; }

HRESULT CInvert::GetAttributes ( IMFAttributes ** pAttributes ) [private]

Definition at line 247 of file Invert.cpp.

{
    if (ppAttributes == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    m_pAttributes.CopyTo(ppAttributes);

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CInvert::GetAttributes ( IMFAttributes ** pAttributes ) [private]
STDMETHODIMP CInvert::GetInputAvailableType | ( | DWORD | dwInputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CInvert::GetInputAvailableType | ( | DWORD | dwInputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 268 of file Invert.cpp.

{
    if (ppType == NULL)
    {
        return E_INVALIDARG;
    }

    if (dwInputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);
    HRESULT hr = S_OK;

    // If the output type is set, return that type as our preferred input type.
    if (m_pOutputType == NULL)
    {
        // The output type is not set. Create a partial media type.
        hr = OnGetPartialType(dwTypeIndex, ppType);
    }
    else if (dwTypeIndex > 0)
    {
        hr = MF_E_NO_MORE_TYPES;
    }
    else
    {
        *ppType = m_pOutputType.Get();
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::GetInputCurrentType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CInvert::GetInputCurrentType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 475 of file Invert.cpp.

{
    if (ppType == NULL)
    {
        return E_POINTER;
    }

    if (dwInputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;
    EnterCriticalSection(&m_critSec);

    if (!m_pInputType)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }
    else
    {
        *ppType = m_pInputType.Get();
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::GetInputStatus | ( | DWORD | dwInputStreamID,
 |  | DWORD * | pdwFlags |
 | ) |  |  | [private]
HRESULT CInvert::GetInputStatus | ( | DWORD | dwInputStreamID,
 |  | DWORD * | pdwFlags |
 | ) |  |  | [private]

Definition at line 550 of file Invert.cpp.

{
    if (pdwFlags == NULL)
    {
        return E_POINTER;
    }

    if (dwInputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);

    if (m_pSample == NULL)
    {
        *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
    }
    else
    {
        *pdwFlags = 0;
    }

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CInvert::GetInputStreamAttributes | ( | DWORD | dwInputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [inline, private]

Definition at line 149 of file Invert.h.

          { return E_NOTIMPL; }

STDMETHODIMP CInvert::GetInputStreamAttributes | ( | DWORD | dwInputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [inline, private]

Definition at line 149 of file Invert.h.

          { return E_NOTIMPL; }

STDMETHODIMP CInvert::GetInputStreamInfo | ( | DWORD | dwInputStreamID,
 |  | MFT_INPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]
HRESULT CInvert::GetInputStreamInfo | ( | DWORD | dwInputStreamID,
 |  | MFT_INPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]

Definition at line 149 of file Invert.cpp.

{
    if (pStreamInfo == NULL)
    {
        return E_POINTER;
    }

    if (dwInputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);

    pStreamInfo->hnsMaxLatency = 0;
    pStreamInfo->dwFlags = MFT_INPUT_STREAM_WHOLE_SAMPLES | MFT_INPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER;
    pStreamInfo->cbSize = m_pInputType == NULL ? 0 : m_cbImageSize;
    pStreamInfo->cbMaxLookahead = 0;
    pStreamInfo->cbAlignment = 0;

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

HRESULT CInvert::GetOutputAvailableType | ( | DWORD | dwOutputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 314 of file Invert.cpp.

{
    if (ppType == NULL)
    {
        return E_INVALIDARG;
    }

    if (dwOutputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);
    HRESULT hr = S_OK;

    if (m_pInputType == NULL)
    {
        // The input type is not set. Create a partial media type.
        hr = OnGetPartialType(dwTypeIndex, ppType);
    }
    else if (dwTypeIndex > 0)
    {
        hr = MF_E_NO_MORE_TYPES;
    }
    else
    {
        *ppType = m_pInputType.Get();
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::GetOutputAvailableType | ( | DWORD | dwOutputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
STDMETHODIMP CInvert::GetOutputCurrentType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CInvert::GetOutputCurrentType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 513 of file Invert.cpp.

{
    if (ppType == NULL)
    {
        return E_POINTER;
    }

    if( dwOutputStreamID != 0 )
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;
    EnterCriticalSection(&m_critSec);

    if (!m_pOutputType)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }
    else
    {
        m_pOutputType.CopyTo(ppType);
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::GetOutputStatus ( DWORD * pdwFlags ) [private]
HRESULT CInvert::GetOutputStatus ( DWORD * pdwFlags ) [private]

Definition at line 586 of file Invert.cpp.

{
    if (pdwFlags == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    // The MFT can produce an output sample if (and only if) there an input sample.
    if (m_pSample != NULL)
    {
        *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
    }
    else
    {
        *pdwFlags = 0;
    }

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

HRESULT CInvert::GetOutputStreamAttributes | ( | DWORD | dwOutputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]

Definition at line 220 of file Invert.cpp.

{
    HRESULT hr = S_OK;

    if (NULL == ppAttributes)
    {
        return E_POINTER;
    }

    if (dwOutputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    m_spOutputAttributes.CopyTo(ppAttributes);

    return( hr );
}

STDMETHODIMP CInvert::GetOutputStreamAttributes | ( | DWORD | dwOutputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]
STDMETHODIMP CInvert::GetOutputStreamInfo | ( | DWORD | dwOutputStreamID,
 |  | MFT_OUTPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]
HRESULT CInvert::GetOutputStreamInfo | ( | DWORD | dwOutputStreamID,
 |  | MFT_OUTPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]

Definition at line 181 of file Invert.cpp.

{
    if (pStreamInfo == NULL)
    {
        return E_POINTER;
    }

    if (dwOutputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);

    pStreamInfo->dwFlags =
        MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
        MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
        MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;

    if( m_pDX11Manager != nullptr )
    {
        pStreamInfo->dwFlags |= MFT_OUTPUT_STREAM_PROVIDES_SAMPLES;
    }

    pStreamInfo->cbSize = m_pInputType == NULL ? 0 : m_cbImageSize;
    pStreamInfo->cbAlignment = 0;

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

HRESULT CInvert::GetStreamCount | ( | DWORD * | pcInputStreams,
 |  | DWORD * | pcOutputStreams |
 | ) |  |  | [private]

Definition at line 127 of file Invert.cpp.

{
    if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))
    {
        return E_POINTER;
    }

    // This MFT has a fixed number of streams.
    *pcInputStreams = 1;
    *pcOutputStreams = 1;
    return S_OK;
}

STDMETHODIMP CInvert::GetStreamCount | ( | DWORD * | pcInputStreams,
 |  | DWORD * | pcOutputStreams |
 | ) |  |  | [private]
STDMETHODIMP CInvert::GetStreamIDs | ( | DWORD | dwInputIDArraySize,
 |  | DWORD * | pdwInputIDs,
 |  | DWORD | dwOutputIDArraySize,
 |  | DWORD * | pdwOutputIDs |
 | ) |  |  | [inline, private]

Definition at line 142 of file Invert.h.

          { return E_NOTIMPL; }

STDMETHODIMP CInvert::GetStreamIDs | ( | DWORD | dwInputIDArraySize,
 |  | DWORD * | pdwInputIDs,
 |  | DWORD | dwOutputIDArraySize,
 |  | DWORD * | pdwOutputIDs |
 | ) |  |  | [inline, private]

Definition at line 142 of file Invert.h.

          { return E_NOTIMPL; }

STDMETHODIMP CInvert::GetStreamLimits | ( | DWORD * | pdwInputMinimum,
 |  | DWORD * | pdwInputMaximum,
 |  | DWORD * | pdwOutputMinimum,
 |  | DWORD * | pdwOutputMaximum |
 | ) |  |  | [private]
HRESULT CInvert::GetStreamLimits | ( | DWORD * | pdwInputMinimum,
 |  | DWORD * | pdwInputMaximum,
 |  | DWORD * | pdwOutputMinimum,
 |  | DWORD * | pdwOutputMaximum |
 | ) |  |  | [private]

Definition at line 98 of file Invert.cpp.

{
    if ((pdwInputMinimum == NULL) ||
        (pdwInputMaximum == NULL) ||
        (pdwOutputMinimum == NULL) ||
        (pdwOutputMaximum == NULL))
    {
        return E_POINTER;
    }

    // This MFT has a fixed number of streams.
    *pdwInputMinimum = 1;
    *pdwInputMaximum = 1;
    *pdwOutputMinimum = 1;
    *pdwOutputMaximum = 1;
    return S_OK;
}

void CInvert::InvalidateDX11Resources ( ) [private]

Definition at line 935 of file Invert.cpp.

{
    m_pTransform->Invalidate();
    m_pDevice  = nullptr;
    m_pContext = nullptr;
    m_pInBufferTex = nullptr;
    m_pOutBufferTex = nullptr;
    m_pOutBufferStage = nullptr;
}

void CInvert::InvalidateDX11Resources ( ) [private]
HRESULT CInvert::OnCheckInputType ( IMFMediaType * pmt ) [private]

Definition at line 1030 of file Invert.cpp.

{
    assert(pmt != NULL);

    HRESULT hr = S_OK;

    // If the output type is set, see if they match.
    if (m_pOutputType != NULL)
    {
        DWORD flags = 0;
        hr = pmt->IsEqual(m_pOutputType.Get(), &flags);

        // IsEqual can return S_FALSE. Treat this as failure.
        if (hr != S_OK)
        {
            hr = MF_E_INVALIDMEDIATYPE;
        }
    }
    else
    {
        // Output type is not set. Just check this type.
        hr = OnCheckMediaType(pmt);
    }
    return hr;
}

HRESULT CInvert::OnCheckInputType ( IMFMediaType * pmt ) [private]
HRESULT CInvert::OnCheckMediaType ( IMFMediaType * pmt ) [private]
HRESULT CInvert::OnCheckMediaType ( IMFMediaType * pmt ) [private]

Definition at line 1084 of file Invert.cpp.

{
    // Major type must be video.
    GUID major_type;
    HRESULT hr = pmt->GetGUID(MF_MT_MAJOR_TYPE, &major_type);
    if (FAILED(hr))
    {
        goto done;
    }

    if (major_type != MFMediaType_Video)
    {
        hr = MF_E_INVALIDMEDIATYPE;
        goto done;
    }

    // Get the subtype GUID.
    GUID subtype;
    hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
    if (FAILED(hr))
    {
        goto done;
    }

    if(subtype != MFVideoFormat_ARGB32)
    {
        hr = MF_E_INVALIDMEDIATYPE;
        goto done;
    }

    // Reject single-field media types.
    UINT32 interlace = MFGetAttributeUINT32(pmt, MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
    if (interlace == MFVideoInterlace_FieldSingleUpper  || interlace == MFVideoInterlace_FieldSingleLower)
    {
        hr = MF_E_INVALIDMEDIATYPE;
        goto done;
    }

    // Reject media types without a frame size
    UINT width, height;
    hr = MFGetAttributeSize(pmt, MF_MT_FRAME_SIZE, &width, &height);
    if (FAILED(hr))
    {
        goto done;
    }

done:
    return hr;
}

HRESULT CInvert::OnCheckOutputType ( IMFMediaType * pmt ) [private]
HRESULT CInvert::OnCheckOutputType ( IMFMediaType * pmt ) [private]

Definition at line 1057 of file Invert.cpp.

{
    assert(pmt != NULL);

    HRESULT hr = S_OK;

    // If the input type is set, see if they match.
    if (m_pInputType != NULL)
    {
        DWORD flags = 0;
        hr = pmt->IsEqual(m_pInputType.Get(), &flags);

        // IsEqual can return S_FALSE. Treat this as failure.
        if (hr != S_OK)
        {
            hr = MF_E_INVALIDMEDIATYPE;
        }
    }
    else
    {
        // Input type is not set. Just check this type.
        hr = OnCheckMediaType(pmt);
    }
    return hr;
}

HRESULT CInvert::OnGetPartialType | ( | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppmt |
 | ) |  |  | [private]

Definition at line 996 of file Invert.cpp.

{
    if (dwTypeIndex > 0)
    {
        return MF_E_NO_MORE_TYPES;
    }

    ComPtr<IMFMediaType> pmt;

    HRESULT hr = MFCreateMediaType(&pmt);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = pmt->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = pmt->SetGUID(MF_MT_SUBTYPE, MFVideoFormat_ARGB32);
    if (FAILED(hr))
    {
        goto done;
    }

    pmt.CopyTo(ppmt);

done:
    return hr;
}

HRESULT CInvert::OnGetPartialType | ( | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppmt |
 | ) |  |  | [private]
HRESULT CInvert::OnProcessOutput | ( | IMFMediaBuffer * | pIn,
 |  | IMFMediaBuffer * | pOut |
 | ) |  |  | [private]
HRESULT CInvert::OnProcessOutput | ( | IMFMediaBuffer * | pIn,
 |  | IMFMediaBuffer * | pOut |
 | ) |  |  | [private]

Definition at line 1257 of file Invert.cpp.

{
    HRESULT hr = S_OK;
    ComPtr<ID3D11Texture2D> pInTex;
    ComPtr<ID3D11Texture2D> pOutTex;
    BOOL bNativeOut = FALSE, bNativeIn = FALSE;
    UINT uiInIndex = 0;
    UINT uiOutIndex = 0;

    // Attempt to convert directly to DX textures
    hr = BufferToDXType(pIn, &uiInIndex, &pInTex);
    bNativeIn = SUCCEEDED(hr) && pInTex != nullptr;
    hr = BufferToDXType(pOut, &uiOutIndex, &pOutTex);
    bNativeOut = SUCCEEDED(hr) && pOutTex != nullptr;

    // If the input or output textures' device does not match our device
    // we have to move them to our device
    if (bNativeIn)
    {
        ComPtr<ID3D11Device> pDev;
        pInTex->GetDevice(&pDev);
        if( pDev != m_pDevice )
        {
            bNativeIn = FALSE;
        }
    }
    if (bNativeOut)
    {
        ComPtr<ID3D11Device> pDev;
        pOutTex->GetDevice(&pDev);
        if( pDev != m_pDevice )
        {
            bNativeOut = FALSE;
        }
    }

    if (!bNativeIn)
    {
        // Native DX texture in the buffer failed
        // create a texture we can use and copy the data in
        if (m_pInBufferTex == nullptr)
        {
            D3D11_TEXTURE2D_DESC desc;
            ZeroMemory(&desc,sizeof(desc));
            desc.Width = m_imageWidthInPixels;
            desc.Height = m_imageHeightInPixels;
            desc.ArraySize = 1;
            desc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
            desc.Usage = D3D11_USAGE_DYNAMIC;
            desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
            desc.CPUAccessFlags = D3D11_CPU_ACCESS_WRITE;
            desc.MipLevels = 1;
            desc.SampleDesc.Count = 1;

            hr = m_pDevice->CreateTexture2D(&desc, NULL, &m_pInBufferTex);
            if (FAILED(hr))
            {
                goto done;
            }
        }

        // scope the texture lock
        {
            TextureLock tlock(m_pContext.Get(), m_pInBufferTex.Get());
            hr = tlock.Map(uiInIndex, D3D11_MAP_WRITE_DISCARD, 0);
            if (FAILED(hr))
            {
                goto done;
            }

            // scope the video buffer lock
            {
                VideoBufferLock lock;
                LONG lStride;

                hr = GetDefaultStride(m_pInputType.Get(), &lStride);
                if (FAILED(hr))
                {
                    goto done;
                }

                hr = lock.Lock(pIn, MF2DBuffer_LockFlags_Read, lStride * m_imageHeightInPixels, lStride);
                if (FAILED(hr))
                {
                    goto done;
                }

                hr = MFCopyImage((BYTE*)tlock.map.pData, tlock.map.RowPitch, lock.GetData(), lock.GetStride(), abs(lStride), m_imageHeightInPixels);
                if (FAILED(hr))
                {
                    goto done;
                }
            }
        }
        pInTex = m_pInBufferTex;
    }

    if (!bNativeOut)
    {
        if (m_pOutBufferTex == nullptr)
        {
            D3D11_TEXTURE2D_DESC desc;
            ZeroMemory(&desc,sizeof(desc));
            desc.Width = m_imageWidthInPixels;
            desc.Height = m_imageHeightInPixels;
            desc.ArraySize = 1;
            desc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
            desc.Usage = D3D11_USAGE_DEFAULT;
            desc.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
            desc.MipLevels = 1;
            desc.SampleDesc.Count = 1;
            hr = m_pDevice->CreateTexture2D(&desc, NULL, &m_pOutBufferTex);
            if (FAILED(hr))
            {
                goto done;
            }
        }
        pOutTex = m_pOutBufferTex;
    }

    // do some processing
    m_pTransform->ProcessFrame(m_pDevice.Get(),pInTex.Get(),uiInIndex,pOutTex.Get(),uiOutIndex);

    // write back pOut if necessary
    if (!bNativeOut)
    {
        if (m_pOutBufferStage == nullptr)
        {
            D3D11_TEXTURE2D_DESC desc;
            ZeroMemory(&desc,sizeof(desc));
            desc.Width = m_imageWidthInPixels;
            desc.Height = m_imageHeightInPixels;
            desc.ArraySize = 1;
            desc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
            desc.Usage = D3D11_USAGE_STAGING;
            desc.CPUAccessFlags = D3D11_CPU_ACCESS_READ;
            desc.MipLevels = 1;
            desc.SampleDesc.Count = 1;
            hr = m_pDevice->CreateTexture2D(&desc, NULL, &m_pOutBufferStage);
            if (FAILED(hr))
            {
                goto done;
            }
        }

        m_pContext->CopyResource(m_pOutBufferStage.Get(), m_pOutBufferTex.Get());

        {
            TextureLock tlock(m_pContext.Get(), m_pOutBufferStage.Get());
            hr = tlock.Map(uiOutIndex, D3D11_MAP_READ, 0);
            if (FAILED(hr))
            {
                goto done;
            }

            // scope the video buffer lock
            {
                VideoBufferLock lock;
                LONG lStride;

                hr = GetDefaultStride(m_pOutputType.Get(), &lStride);
                if (FAILED(hr))
                {
                    goto done;
                }

                hr = lock.Lock(pOut, MF2DBuffer_LockFlags_Write, lStride * m_imageHeightInPixels, lStride);
                if (FAILED(hr))
                {
                    goto done;
                }

                hr = MFCopyImage(lock.GetData(), lock.GetStride(), (BYTE*)tlock.map.pData, tlock.map.RowPitch, abs(lStride), m_imageHeightInPixels);
                if (FAILED(hr))
                {
                    goto done;
                }
            }
        }
    }

done:
    return hr;
}

STDMETHODIMP CInvert::ProcessEvent | ( | DWORD | dwInputStreamID,
 |  | IMFMediaEvent * | pEvent |
 | ) |  |  | [inline, private]

Definition at line 166 of file Invert.h.

          { return E_NOTIMPL; }

STDMETHODIMP CInvert::ProcessEvent | ( | DWORD | dwInputStreamID,
 |  | IMFMediaEvent * | pEvent |
 | ) |  |  | [inline, private]

Definition at line 166 of file Invert.h.

          { return E_NOTIMPL; }

HRESULT CInvert::ProcessInput | ( | DWORD | dwInputStreamID,
 |  | IMFSample * | pSample,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 693 of file Invert.cpp.

{
    // Check input parameters.
    if (pSample == NULL)
    {
        return E_POINTER;
    }

    if (dwFlags != 0)
    {
        return E_INVALIDARG; // dwFlags is reserved and must be zero.
    }

    // Validate the input stream number.
    if (dwInputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    // Check for valid media types.
    // The client must set input and output types before calling ProcessInput.
    if (!m_pInputType || !m_pOutputType)
    {
        hr = MF_E_NOTACCEPTING;
        goto done;
    }

    // Check if an input sample is already queued.
    if (m_pSample != NULL)
    {
        hr = MF_E_NOTACCEPTING;   // We already have an input sample.
        goto done;
    }

    // Initialize streaming.
    hr = BeginStreaming();
    if (FAILED(hr))
    {
        goto done;
    }

    // Cache the sample. We do the actual work in ProcessOutput.
    m_pSample = pSample;

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::ProcessInput | ( | DWORD | dwInputStreamID,
 |  | IMFSample * | pSample,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
HRESULT CInvert::ProcessMessage | ( | MFT_MESSAGE_TYPE | eMessage,
 |  | ULONG_PTR | ulParam |
 | ) |  |  | [private]

Definition at line 614 of file Invert.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;
    ComPtr<IUnknown> pUnk;
    ComPtr<IMFDXGIDeviceManager> pDXGIDeviceManager;

    switch (eMessage)
    {
    case MFT_MESSAGE_COMMAND_FLUSH:
        // Flush the MFT.
        m_pSample = nullptr;
        break;

    case MFT_MESSAGE_SET_D3D_MANAGER:
        if (ulParam != NULL)
        {
            pUnk = (IUnknown*)ulParam;
            hr = pUnk.As(&pDXGIDeviceManager);

            if( SUCCEEDED( hr ) && (m_pDX11Manager != pDXGIDeviceManager) )
            {
                InvalidateDX11Resources();
                m_pDX11Manager = nullptr;
                m_pDX11Manager = pDXGIDeviceManager;

                hr = UpdateDX11Device();
                if (FAILED(hr))
                {
                    goto done;
                }

                if( m_spOutputSampleAllocator )
                {
                    hr = m_spOutputSampleAllocator->SetDirectXManager(pUnk.Get());
                    if (FAILED(hr))
                    {
                        goto done;
                    }
                }
            }
        }
        else
        {
            InvalidateDX11Resources();
            m_pDX11Manager = nullptr;
        }
        break;

    case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
        hr = BeginStreaming();
        break;

    case MFT_MESSAGE_NOTIFY_END_STREAMING:
        m_bStreamingInitialized = false;
        break;

    // The remaining messages require no action
    case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
    case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
    case MFT_MESSAGE_COMMAND_DRAIN:
        break;
    }

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::ProcessMessage | ( | MFT_MESSAGE_TYPE | eMessage,
 |  | ULONG_PTR | ulParam |
 | ) |  |  | [private]
HRESULT CInvert::ProcessOutput | ( | DWORD | dwFlags,
 |  | DWORD | cOutputBufferCount,
 |  | MFT_OUTPUT_DATA_BUFFER * | pOutputSamples,
 |  | DWORD * | pdwStatus |
 | ) |  |  | [private]

Definition at line 756 of file Invert.cpp.

{
    if (dwFlags != 0)
    {
        return E_INVALIDARG;
    }

    if (pOutputSamples == NULL || pdwStatus == NULL)
    {
        return E_POINTER;
    }

    // There must be exactly one output buffer.
    if (cOutputBufferCount != 1)
    {
        return E_INVALIDARG;
    }

    // It must contain a sample.
    if (pOutputSamples[0].pSample == NULL && m_pDX11Manager == nullptr)
    {
        return E_INVALIDARG;
    }

    HRESULT hr = S_OK;
    ComPtr<IMFMediaBuffer> pInput;
    ComPtr<IMFMediaBuffer> pOutput;
    ComPtr<ID3D11Device> spDevice;
    ComPtr<IMFMediaBuffer> pMediaBuffer;
    bool bDeviceLocked = false;

    EnterCriticalSection(&m_critSec);

    // There must be an input sample available for processing.
    if (m_pSample == nullptr)
    {
        hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
        goto done;
    }

    // Initialize streaming.
    hr = BeginStreaming();
    if (FAILED(hr))
    {
        goto done;
    }

    // Check that our device is still good
    hr = CheckDX11Device();
    if (FAILED(hr))
    {
        goto done;
    }

    // When using DX we provide the output samples...
    if (m_pDX11Manager != nullptr)
    {
        hr = m_spOutputSampleAllocator->AllocateSample( &(pOutputSamples[0].pSample) );
        if (FAILED(hr))
        {
            goto done;
        }
    }

    if (pOutputSamples[0].pSample == nullptr)
    {
        hr = E_INVALIDARG;
        goto done;
    }

    // Get the input buffer.
    hr = m_pSample->GetBufferByIndex(0, &pInput);
    if (FAILED(hr))
    {
        goto done;
    }

    // Get the output buffer.
    hr = pOutputSamples[0].pSample->GetBufferByIndex(0, &pOutput);
    if (FAILED(hr))
    {
        goto done;
    }

    // Attempt to lock the device if necessary
    if (m_pDX11Manager != nullptr)
    {
        hr = m_pDX11Manager->LockDevice(m_hDeviceHandle, IID_PPV_ARGS( &spDevice ), TRUE );
        if (FAILED(hr))
        {
            goto done;
        }
        bDeviceLocked = true;
    }

    hr = OnProcessOutput(pInput.Get(), pOutput.Get());
    if (FAILED(hr))
    {
        goto done;
    }

    // Set status flags.
    pOutputSamples[0].dwStatus = 0;
    *pdwStatus = 0;

    // Copy the duration and time stamp from the input sample, if present.
    LONGLONG hnsDuration = 0;
    LONGLONG hnsTime = 0;

    if (SUCCEEDED(m_pSample->GetSampleDuration(&hnsDuration)))
    {
        hr = pOutputSamples[0].pSample->SetSampleDuration(hnsDuration);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    if (SUCCEEDED(m_pSample->GetSampleTime(&hnsTime)))
    {
        hr = pOutputSamples[0].pSample->SetSampleTime(hnsTime);
    }

    // Always set the sample size
    hr = pOutputSamples[0].pSample->GetBufferByIndex( 0, &pMediaBuffer );
    if (FAILED(hr))
    {
        goto done;
    }

    hr = pMediaBuffer->SetCurrentLength(m_cbImageSize);
    if (FAILED(hr))
    {
        goto done;
    }

done:
    m_pSample = nullptr;

    if (bDeviceLocked)
    {
        hr = m_pDX11Manager->UnlockDevice(m_hDeviceHandle, FALSE);
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::ProcessOutput | ( | DWORD | dwFlags,
 |  | DWORD | cOutputBufferCount,
 |  | MFT_OUTPUT_DATA_BUFFER * | pOutputSamples,
 |  | DWORD * | pdwStatus |
 | ) |  |  | [private]
STDMETHODIMP CInvert::RuntimeClassInitialize ( ) [private]

Definition at line 39 of file Invert.cpp.

{
    HRESULT hr = S_OK;

    // Create the attribute store.
    hr = MFCreateAttributes(&m_pAttributes, 3);
    if (FAILED(hr))
    {
        goto done;
    }

    // MFT supports DX11 acceleration
    hr = m_pAttributes->SetUINT32(MF_SA_D3D_AWARE, 1);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = m_pAttributes->SetUINT32(MF_SA_D3D11_AWARE, 1);
    if (FAILED(hr))
    {
        goto done;
    }

    // output attributes
    hr = MFCreateAttributes( &m_spOutputAttributes, 1 );
    if (FAILED(hr))
    {
        goto done;
    }

    // Load the transform
    m_pTransform = new CInvertModule();
    if( m_pTransform == nullptr )
    {
        hr = E_OUTOFMEMORY;
        goto done;
    }

done:
    return hr;
}

STDMETHOD() CInvert::RuntimeClassInitialize ( ) [private]
HRESULT CInvert::SetInputType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 357 of file Invert.cpp.

{
    // Validate flags.
    if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
    {
        return E_INVALIDARG;
    }

    if (dwInputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);
    HRESULT hr = S_OK;

    // If we have an input sample, the client cannot change the type now.
    if (m_pSample != NULL)
    {
        hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
        goto done;
    }

    // Validate the type, if non-NULL.
    if (pType)
    {
        hr = OnCheckInputType(pType);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    // The type is OK. Set the type, unless the caller was just testing.
    if ( (dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0 )
    {
        m_pInputType = nullptr;
        m_pInputType = pType;

        // Update the format information.
        UpdateFormatInfo();

        // When the type changes, end streaming.
        m_bStreamingInitialized = false;
    }

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::SetInputType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
STDMETHODIMP CInvert::SetOutputBounds | ( | LONGLONG | hnsLowerBound,
 |  | LONGLONG | hnsUpperBound |
 | ) |  |  | [inline, private]

Definition at line 161 of file Invert.h.

          { return E_NOTIMPL; }

STDMETHODIMP CInvert::SetOutputBounds | ( | LONGLONG | hnsLowerBound,
 |  | LONGLONG | hnsUpperBound |
 | ) |  |  | [inline, private]

Definition at line 161 of file Invert.h.

          { return E_NOTIMPL; }

STDMETHODIMP CInvert::SetOutputType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
HRESULT CInvert::SetOutputType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 418 of file Invert.cpp.

{
    // Validate flags.
    if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
    {
        return E_INVALIDARG;
    }

    if (dwOutputStreamID != 0)
    {
        return MF_E_INVALIDSTREAMNUMBER;
    }

    EnterCriticalSection(&m_critSec);
    HRESULT hr = S_OK;

    // If we have an input sample, the client cannot change the type now.
    if (m_pSample != NULL)
    {
        hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
        goto done;
    }

    // Validate the type, if non-NULL.
    if (pType)
    {
        hr = OnCheckOutputType(pType);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    // The type is OK. Set the type, unless the caller was just testing.
    if ( (dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0 )
    {
        m_pOutputType = pType;

        // When the type changes, end streaming.
        m_bStreamingInitialized = false;
    }

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CInvert::SetProperties ( ABI::Windows::Foundation::Collections::IPropertySet * pConfiguration ) [private]
HRESULT CInvert::SetProperties ( ABI::Windows::Foundation::Collections::IPropertySet * pConfiguration ) [private]

Definition at line 88 of file Invert.cpp.

{
    return S_OK;
}

HRESULT CInvert::UpdateDX11Device ( ) [private]
HRESULT CInvert::UpdateDX11Device ( ) [private]

Definition at line 946 of file Invert.cpp.

{
    HRESULT hr = S_OK;

    if (m_pDX11Manager != nullptr)
    {
        hr = m_pDX11Manager->OpenDeviceHandle(&m_hDeviceHandle);
        if (FAILED(hr))
        {
            goto done;
        }

        hr = m_pDX11Manager->GetVideoService(m_hDeviceHandle, __uuidof(m_pDevice), (void**)&m_pDevice);
        if (FAILED(hr))
        {
            goto done;
        }

        m_pDevice->GetImmediateContext(&m_pContext);
    }
    else
    {
        D3D_FEATURE_LEVEL level;
        D3D_FEATURE_LEVEL levelsWanted[] =
        {
            D3D_FEATURE_LEVEL_11_1,
            D3D_FEATURE_LEVEL_11_0,
            D3D_FEATURE_LEVEL_10_1,
            D3D_FEATURE_LEVEL_10_0,
        };
        DWORD numLevelsWanted = sizeof( levelsWanted ) / sizeof( levelsWanted[0] );

        hr = D3D11CreateDevice( NULL, D3D_DRIVER_TYPE_WARP, NULL, 0 , levelsWanted, numLevelsWanted,
                                D3D11_SDK_VERSION, &m_pDevice, &level, &m_pContext);
        if (FAILED(hr))
        {
            goto done;
        }

    }

    return hr;

done:
    InvalidateDX11Resources();
    return hr;
}

HRESULT CInvert::UpdateFormatInfo ( ) [private]
HRESULT CInvert::UpdateFormatInfo ( ) [private]

Definition at line 1445 of file Invert.cpp.

{
    HRESULT hr = S_OK;
    LONG lStride = 0;

    m_imageWidthInPixels = 0;
    m_imageHeightInPixels = 0;
    m_cbImageSize = 0;

    if (m_pInputType != NULL)
    {
        hr = MFGetAttributeSize(m_pInputType.Get(), MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);
        if (FAILED(hr))
        {
            goto done;
        }

        hr = GetDefaultStride(m_pInputType.Get(), &lStride);
        if (FAILED(hr))
        {
            goto done;
        }

        // Calculate the image size
        m_cbImageSize = abs(lStride) * 4 * m_imageHeightInPixels;
    }

done:
    return hr;
}

Member Data Documentation

bool CInvert::m_bStreamingInitialized [private]

Definition at line 188 of file Invert.h.

DWORD CInvert::m_cbImageSize [private]

Definition at line 196 of file Invert.h.

CRITICAL_SECTION CInvert::m_critSec [private]

Definition at line 185 of file Invert.h.

HANDLE CInvert::m_hDeviceHandle [private]

Definition at line 202 of file Invert.h.

UINT32 CInvert::m_imageHeightInPixels [private]

Definition at line 195 of file Invert.h.

UINT32 CInvert::m_imageWidthInPixels [private]

Definition at line 194 of file Invert.h.

ComPtr< IMFAttributes > CInvert::m_pAttributes [private]

Definition at line 198 of file Invert.h.

ComPtr< ID3D11DeviceContext > CInvert::m_pContext [private]

Definition at line 206 of file Invert.h.

ComPtr< ID3D11Device > CInvert::m_pDevice [private]

Definition at line 205 of file Invert.h.

ComPtr< IMFDXGIDeviceManager > CInvert::m_pDX11Manager [private]

Definition at line 201 of file Invert.h.

ComPtr< ID3D11Texture2D > CInvert::m_pInBufferTex [private]

Definition at line 207 of file Invert.h.

ComPtr< IMFMediaType > CInvert::m_pInputType [private]

Definition at line 190 of file Invert.h.

ComPtr< ID3D11Texture2D > CInvert::m_pOutBufferStage [private]

Definition at line 209 of file Invert.h.

ComPtr< ID3D11Texture2D > CInvert::m_pOutBufferTex [private]

Definition at line 208 of file Invert.h.

ComPtr< IMFMediaType > CInvert::m_pOutputType [private]

Definition at line 191 of file Invert.h.

ComPtr< IMFSample > CInvert::m_pSample [private]

Definition at line 189 of file Invert.h.

DirectXVideoTransform * CInvert::m_pTransform [private]

Definition at line 216 of file Invert.h.

ComPtr< IMFAttributes > CInvert::m_spOutputAttributes [private]

Definition at line 213 of file Invert.h.

ComPtr< IMFVideoSampleAllocatorEx > CInvert::m_spOutputSampleAllocator [private]

Definition at line 212 of file Invert.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Invert/Invert.h
  • Media extensions/C++/MediaExtensions/Invert/Invert.h
  • Media extensions/C#,C++/MediaExtensions/Invert/Invert.cpp
  • Media extensions/C++/MediaExtensions/Invert/Invert.cpp
Generated on Sat Nov 23 2024 16:09:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CInvertModule Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

CInvertModule Class Reference

#include "InvertModule.h"

List of all members.

Public Member Functions

virtual | ~CInvertModule ()
virtual | ~CInvertModule ()
virtual HRESULT | Initialize (ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight)
virtual HRESULT | Initialize (ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight)
virtual void | Invalidate ()
virtual void | Invalidate ()
virtual HRESULT | ProcessFrame (ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex)
virtual HRESULT | ProcessFrame (ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex)

Private Attributes

ComPtr< ID3D11PixelShader > | m_pPixelShader
ComPtr< ID3D11SamplerState > | m_pSampleStateLinear
ComPtr< ID3D11Buffer > | m_pScreenQuadVB
ComPtr< ID3D11VertexShader > | m_pVertexShader
ComPtr< ID3D11InputLayout > | m_spQuadLayout
UINT | m_uiHeight
UINT | m_uiWidth

Detailed Description

Definition at line 7 of file InvertModule.h.

Constructor & Destructor Documentation

CInvertModule::~CInvertModule ( ) [virtual]

Definition at line 11 of file InvertModule.cpp.

{
    Invalidate();
}

virtual CInvertModule::~CInvertModule ( ) [virtual]

Member Function Documentation

HRESULT CInvertModule::Initialize | ( | ID3D11Device * | pDevice,
 |  | UINT | uiWidth,
 |  | UINT | uiHeight |
 | ) |  |  | [virtual]

Definition at line 25 of file InvertModule.cpp.

{
    HRESULT hr = S_OK;

    m_uiWidth = uiWidth;
    m_uiHeight = uiHeight;

    if(m_pScreenQuadVB == nullptr)
    {
        // Vertex Buffer Layout
        D3D11_BUFFER_DESC vbdesc;

        // 2 vertices (Triangles), covering the whole Viewport, with the input video mapped as a texture
        const ScreenVertex svDefault[4] = {
            //   x      y     z     w         u     v
            { { -1.0f,  1.0f, 0.5f, 1.0f }, { 0.0f, 0.0f } }, // 0
            { {  1.0f,  1.0f, 0.5f, 1.0f }, { 1.0f, 0.0f } }, // 1
            { { -1.0f, -1.0f, 0.5f, 1.0f }, { 0.0f, 1.0f } }, // 2
            { {  1.0f, -1.0f, 0.5f, 1.0f }, { 1.0f, 1.0f } }  // 3
        };

        ZeroMemory(&vbdesc, sizeof(vbdesc));

        vbdesc.Usage = D3D11_USAGE_DYNAMIC;
        vbdesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
        vbdesc.CPUAccessFlags = D3D11_CPU_ACCESS_WRITE;
        vbdesc.MiscFlags = 0;
        vbdesc.ByteWidth = sizeof( svDefault );

        D3D11_SUBRESOURCE_DATA InitData;
        InitData.pSysMem = svDefault;
        InitData.SysMemPitch = 0;
        InitData.SysMemSlicePitch = 0;
        hr = pDevice->CreateBuffer( &vbdesc, &InitData, &m_pScreenQuadVB );
        if( FAILED(hr) )
        {
            goto done;
        }
    }

    // Pixel Shader
    {
        static
#       include "PixelShader.hps"
        if(m_pPixelShader == nullptr)
        {
            hr = pDevice->CreatePixelShader(g_psshader, sizeof(g_psshader), NULL, &m_pPixelShader);
      if(FAILED(hr))
      {
        goto done;
      }
        }
    }

    // Vertex Shader
    {
        static
#       include "VertexShader.hvs"
        if( m_pVertexShader == nullptr )
        {
            const D3D11_INPUT_ELEMENT_DESC quadlayout[] =
            {
                { "POSITION", 0, DXGI_FORMAT_R32G32B32A32_FLOAT, 0,  0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
                { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,       0, 16, D3D11_INPUT_PER_VERTEX_DATA, 0 },
            };
            hr = pDevice->CreateVertexShader(g_vsshader, sizeof(g_vsshader), NULL, &m_pVertexShader);
      if(FAILED(hr))
      {
        goto done;
      }

            hr = pDevice->CreateInputLayout(quadlayout, 2, g_vsshader, sizeof(g_vsshader), &m_spQuadLayout);
      if(FAILED(hr))
      {
        goto done;
      }
        }
    }

    if( m_pSampleStateLinear == NULL )
    {
        // Sampler
        D3D11_SAMPLER_DESC SamplerDesc;
        ZeroMemory(&SamplerDesc, sizeof(SamplerDesc));

        SamplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_CLAMP;
        SamplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_CLAMP;
        SamplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_CLAMP;
        SamplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;
        SamplerDesc.MaxLOD = D3D11_FLOAT32_MAX;

        hr = pDevice->CreateSamplerState( &SamplerDesc, &m_pSampleStateLinear);
        if( FAILED(hr) )
        {
            goto done;
        }
    }

    return hr;

done:
    m_pScreenQuadVB = nullptr;
    m_pSampleStateLinear = nullptr;
    m_spQuadLayout = nullptr;
    m_pVertexShader = nullptr;
    m_pPixelShader = nullptr;
    return hr;

}

virtual HRESULT CInvertModule::Initialize | ( | ID3D11Device * | pDevice,
 |  | UINT | uiWidth,
 |  | UINT | uiHeight |
 | ) |  |  | [virtual]
void CInvertModule::Invalidate ( ) [virtual]

Definition at line 16 of file InvertModule.cpp.

{
    m_pScreenQuadVB = nullptr;
    m_pSampleStateLinear = nullptr;
    m_spQuadLayout = nullptr;
    m_pVertexShader = nullptr;
    m_pPixelShader = nullptr;
}

virtual void CInvertModule::Invalidate ( ) [virtual]
HRESULT CInvertModule::ProcessFrame | ( | ID3D11Device * | pDevice,
 |  | ID3D11Texture2D * | pInput,
 |  | UINT | uiInIndex,
 |  | ID3D11Texture2D * | pOutput,
 |  | UINT | uiOutIndex |
 | ) |  |  | [virtual]

Definition at line 198 of file InvertModule.cpp.

{

    HRESULT hr = S_OK;
    ComPtr<ID3D11DeviceContext> pd3dImmediateContext;

    // Render targets
    ComPtr<ID3D11RenderTargetView> rgpOrigRTV;
    ComPtr<ID3D11DepthStencilView> pOrigDSV;
    ID3D11RenderTargetView *pRTVs[1] = { nullptr };

    // Shader resources
    ComPtr<ID3D11ShaderResourceView> rgpOrigSRV;
    ID3D11ShaderResourceView *pSRVs[1] = { nullptr };

    // Vertex buffers
    ID3D11Buffer *pBuffers[1] = { m_pScreenQuadVB.Get() };
    UINT vbStrides = sizeof( ScreenVertex );
    UINT vbOffsets = 0;

    // Samplers
    ID3D11SamplerState *pSamplers[1] = { m_pSampleStateLinear.Get() };

    // View port
    D3D11_VIEWPORT vpOld[D3D11_VIEWPORT_AND_SCISSORRECT_MAX_INDEX];
    UINT nViewPorts = 1;
    D3D11_VIEWPORT vp;

    // Get the context
    pDevice->GetImmediateContext(&pd3dImmediateContext);

    // Get the resource views
    hr = CreateShaderInputView(pInput, uiInIndex, pDevice, &(pSRVs[0]));
    if( FAILED(hr) )
    {
        goto done;
    }

    hr = CreateShaderOutputView(pOutput, uiOutIndex, pDevice, &(pRTVs[0]));
    if( FAILED(hr) )
    {
        goto done;
    }

    // Setup the Draw call
    pd3dImmediateContext->IASetInputLayout(m_spQuadLayout.Get());

    pd3dImmediateContext->IASetVertexBuffers(0, 1, pBuffers, &vbStrides, &vbOffsets);

    pd3dImmediateContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP);

    pd3dImmediateContext->PSSetSamplers(0, 1, pSamplers);

    pd3dImmediateContext->OMGetRenderTargets(1, &rgpOrigRTV, &pOrigDSV);

    pd3dImmediateContext->OMSetRenderTargets(1, pRTVs, NULL);

    pd3dImmediateContext->PSGetShaderResources(0, 1, &rgpOrigSRV);

    pd3dImmediateContext->PSSetShaderResources(0, 1, pSRVs);

    pd3dImmediateContext->RSGetViewports( &nViewPorts, vpOld );

    // Setup the viewport to match the backbuffer
    vp.Width = (float)m_uiWidth;
    vp.Height = (float)m_uiHeight;
    vp.MinDepth = 0.0f;
    vp.MaxDepth = 1.0f;
    vp.TopLeftX = 0.0f;
    vp.TopLeftY = 0.0f;

    pd3dImmediateContext->RSSetViewports( 1, &vp );

    pd3dImmediateContext->VSSetShader( m_pVertexShader.Get(), NULL, 0 );

    pd3dImmediateContext->PSSetShader( m_pPixelShader.Get(), NULL, 0 );

    pd3dImmediateContext->Draw( 4, 0 );

    // Restore the Old
    pd3dImmediateContext->RSSetViewports( nViewPorts, vpOld );
    pd3dImmediateContext->PSSetShaderResources(0, 1, rgpOrigSRV.GetAddressOf());
    pd3dImmediateContext->OMSetRenderTargets( 1, rgpOrigRTV.GetAddressOf(), pOrigDSV.Get() );

done:
    if(nullptr != pSRVs[0])
    {
        pSRVs[0]->Release();
    }
    if(nullptr != pRTVs[0])
    {
        pRTVs[0]->Release();
    }
    return hr;

}

virtual HRESULT CInvertModule::ProcessFrame | ( | ID3D11Device * | pDevice,
 |  | ID3D11Texture2D * | pInput,
 |  | UINT | uiInIndex,
 |  | ID3D11Texture2D * | pOutput,
 |  | UINT | uiOutIndex |
 | ) |  |  | [virtual]

Member Data Documentation

ComPtr< ID3D11PixelShader > CInvertModule::m_pPixelShader [private]

Definition at line 21 of file InvertModule.h.

ComPtr< ID3D11SamplerState > CInvertModule::m_pSampleStateLinear [private]

Definition at line 18 of file InvertModule.h.

ComPtr< ID3D11Buffer > CInvertModule::m_pScreenQuadVB [private]

Definition at line 17 of file InvertModule.h.

ComPtr< ID3D11VertexShader > CInvertModule::m_pVertexShader [private]

Definition at line 20 of file InvertModule.h.

ComPtr< ID3D11InputLayout > CInvertModule::m_spQuadLayout [private]

Definition at line 19 of file InvertModule.h.

UINT CInvertModule::m_uiHeight [private]

Definition at line 16 of file InvertModule.h.

UINT CInvertModule::m_uiWidth [private]

Definition at line 16 of file InvertModule.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Invert/InvertModule.h
  • Media extensions/C++/MediaExtensions/Invert/InvertModule.h
  • Media extensions/C#,C++/MediaExtensions/Invert/InvertModule.cpp
  • Media extensions/C++/MediaExtensions/Invert/InvertModule.cpp
Generated on Sat Nov 23 2024 16:09:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Clipboard
  • Clipboard::App
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Clipboard::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()

Private Member Functions

void | SetupWindowing (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs)

Private Attributes

Windows::UI::Xaml::Controls::Frame | rootFrame

Detailed Description

Definition at line 24 of file App.xaml.h.

Member Function Documentation

void App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]

Definition at line 44 of file App.xaml.cpp.

{
    if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
    {
        SuspensionManager::StartRestoreTask().then(
            [=](concurrency::task<void> restoreTask)
            {
                try
                {
                    restoreTask.get();
                }
                catch(Platform::Exception^)
                {
                    // If restore fails, the app should proceed as though there was no restored state.
                }

                SetupWindowing(pArgs);
            });
    }
    else
    {
        SetupWindowing(pArgs);
    }
}

void App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]

Definition at line 34 of file App.xaml.cpp.

{
    auto deferral = pArgs->SuspendingOperation->GetDeferral();
    SuspensionManager::StartSaveTask().then(
        [=]()
        {
            deferral->Complete();
        });
}

void App::SetupWindowing ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [private]

Definition at line 69 of file App.xaml.cpp.

{
    if (Window::Current->Content == nullptr)
    {
        rootFrame = ref new Frame();
        TypeName pageType = { "Clipboard.MainPage", TypeKind::Custom };
        rootFrame->Navigate(pageType);
        Window::Current->Content = rootFrame;
    }

    MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
    p->LaunchArgs = pArgs;
    Window::Current->Activate();
}

Member Data Documentation

internal Clipboard::App::__pad0__

Definition at line 27 of file App.xaml.h.

Windows::UI::Xaml::Controls::Frame Clipboard::App::rootFrame [private]

Definition at line 34 of file App.xaml.h.

The documentation for this class was generated from the following files:
  • Clipboard app/C++/App.xaml.h
  • Clipboard app/C++/App.xaml.cpp
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Clipboard
  • Common
  • Clipboard::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Clipboard::Common::LayoutAwarePage Class Reference

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 22 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String Clipboard::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void Clipboard::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Definition at line 144 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void Clipboard::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void Clipboard::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 96 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal Clipboard::Common::LayoutAwarePage::__pad0__

Definition at line 25 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> Clipboard::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 49 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> Clipboard::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 51 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken Clipboard::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 50 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Clipboard app/C++/common/LayoutAwarePage.h
  • Clipboard app/C++/common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Clipboard
  • Clipboard::MainPage
Static Private Attributes

Clipboard::MainPage Class Reference

#include "constants.h"

List of all members.

Static Private Attributes

static Platform::Array< Scenario > scenariosInner

Detailed Description

Definition at line 23 of file constants.h.

Member Data Documentation

Platform::Array< Scenario > MainPage::scenariosInner [static, private]
Initial value:
 ref new Platform::Array<Scenario>
{
    { "Copy and paste text", "Clipboard.CopyText" },
    { "Copy and paste an image", "Clipboard.CopyImage" },
    { "Copy and paste files", "Clipboard.CopyFiles" },
    { "Other Clipboard operations", "Clipboard.Others" }
}

Definition at line 43 of file constants.h.

The documentation for this class was generated from the following files:
  • Clipboard app/C++/constants.h
  • Clipboard app/C++/constants.cpp
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Clipboard
  • Clipboard::Scenario
Public Attributes

Clipboard::Scenario Struct Reference

#include "constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file constants.h.

Member Data Documentation

Platform::String Clipboard::Scenario::ClassName

Definition at line 20 of file constants.h.

Platform::String Clipboard::Scenario::Title

Definition at line 19 of file constants.h.

The documentation for this struct was generated from the following file:
  • Clipboard app/C++/constants.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Clipboard
  • Clipboard::sealed
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes | Static Private Attributes

Clipboard::sealed Class Reference

#include "CopyFiles.xaml.h"

List of all members.

Public Member Functions

CopyFiles ()
CopyImage ()
CopyText ()
void | LoadScenario (Platform::String^scenarioName)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
void | NotifyUserBackgroundThread (Platform::String^message, NotifyType type)
Others ()

Protected Member Functions

void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Protected Attributes

internal | __pad0__: static MainPage^ Current

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

~MainPage ()
void | ClearOutput ()
void | ClearOutputButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CopyBitmap (bool useDelayedRendering)
void | CopyButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CopyButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CopyButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CopyWithDelayedRenderingButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayFormats (Windows::ApplicationModel::DataTransfer::DataPackageView^dataPackageView)
void | EmptyClipboardButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | HandleClipboardChanged ()
void | InvalidateSize ()
void | InvalidateViewState ()
void | OnClipboardChanged (Platform::Object^sender, Platform::Object^e)
void | OnDeferredImageRequestedHandler (Windows::ApplicationModel::DataTransfer::DataProviderRequest^request)
void | OnVisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)
void | PasteButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PasteButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PasteButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PopulateScenarios ()
void | RegisterClipboardContentChanged_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetFeatureName (Platform::String^strFeature)
void | ShowFormatButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

bool | autoSizeInputSectionWhenSnapped
Windows::UI::Xaml::Controls::Frame | HiddenFrame
Platform::String | htmlDescription
Platform::String | imgSrc
Windows::Storage::Streams::RandomAccessStreamReference | imgStreamRef
MainPage rootPage
Platform::Collections::Vector
< Object^> 		ScenarioList
Platform::String | textDescription

Static Private Attributes

static
Windows::Foundation::EventRegistrationToken 		contentChangedToken
static bool | needToPrintClipboardFormat
static bool | registerContentChanged
static
Windows::Foundation::EventRegistrationToken 		visibilityChangedToken
static bool | windowVisible

Detailed Description

Definition at line 25 of file CopyFiles.xaml.h.

Constructor & Destructor Documentation

Clipboard::sealed::~MainPage ( ) [private]

Member Function Documentation

void Clipboard::sealed::ClearOutput ( ) [private]
void Clipboard::sealed::ClearOutputButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::CopyBitmap ( bool useDelayedRendering ) [private]
void Clipboard::sealed::CopyButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::CopyButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::CopyButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Clipboard::sealed::CopyFiles ( )
Clipboard::sealed::CopyImage ( )
Clipboard::sealed::CopyText ( )
void Clipboard::sealed::CopyWithDelayedRenderingButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::DisplayFormats ( Windows::ApplicationModel::DataTransfer::DataPackageView^ dataPackageView ) [private]
void Clipboard::sealed::EmptyClipboardButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::HandleClipboardChanged ( ) [private]
void Clipboard::sealed::InvalidateSize ( ) [private]
void Clipboard::sealed::InvalidateViewState ( ) [private]
void Clipboard::sealed::LoadScenario ( Platform::String^ scenarioName )
Clipboard::sealed::MainPage ( )
void Clipboard::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void Clipboard::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void Clipboard::sealed::NotifyUserBackgroundThread | ( | Platform::String^ | message,
 |  | NotifyType | type
 | ) |  |
void Clipboard::sealed::OnClipboardChanged | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::OnDeferredImageRequestedHandler ( Windows::ApplicationModel::DataTransfer::DataProviderRequest^ request ) [private]
virtual void Clipboard::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void Clipboard::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void Clipboard::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void Clipboard::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void Clipboard::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void Clipboard::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void Clipboard::sealed::OnVisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]
Clipboard::sealed::Others ( )
void Clipboard::sealed::PasteButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::PasteButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::PasteButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::PopulateScenarios ( ) [private]
void Clipboard::sealed::RegisterClipboardContentChanged_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Clipboard::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void Clipboard::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
void Clipboard::sealed::ShowFormatButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal Clipboard::sealed::__pad0__ [protected]

Definition at line 96 of file MainPage.xaml.h.

bool Clipboard::sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 88 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken Clipboard::sealed::contentChangedToken [static, private]

Definition at line 49 of file Others.xaml.h.

Windows::UI::Xaml::Controls::Frame Clipboard::sealed::HiddenFrame [private]

Definition at line 86 of file MainPage.xaml.h.

Platform::String Clipboard::sealed::htmlDescription [private]

Definition at line 40 of file CopyText.xaml.h.

Platform::String Clipboard::sealed::imgSrc [private]

Definition at line 42 of file CopyText.xaml.h.

Windows::Storage::Streams::RandomAccessStreamReference Clipboard::sealed::imgStreamRef [private]

Definition at line 44 of file CopyImage.xaml.h.

bool Clipboard::sealed::needToPrintClipboardFormat [static, private]

Definition at line 54 of file Others.xaml.h.

bool Clipboard::sealed::registerContentChanged [static, private]

Definition at line 53 of file Others.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 34 of file CopyFiles.xaml.h.

Platform::Collections::Vector<Object^> Clipboard::sealed::ScenarioList [private]

Definition at line 85 of file MainPage.xaml.h.

Platform::String Clipboard::sealed::textDescription [private]

Definition at line 41 of file CopyText.xaml.h.

Windows::Foundation::EventRegistrationToken Clipboard::sealed::visibilityChangedToken [static, private]

Definition at line 50 of file Others.xaml.h.

bool Clipboard::sealed::windowVisible [static, private]

Definition at line 52 of file Others.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> Clipboard::sealed::MainPageResized

Definition at line 76 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> Clipboard::sealed::ScenarioLoaded

Definition at line 75 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Clipboard app/C++/CopyFiles.xaml.h
  • Clipboard app/C++/CopyImage.xaml.h
  • Clipboard app/C++/CopyText.xaml.h
  • Clipboard app/C++/MainPage.xaml.h
  • Clipboard app/C++/Others.xaml.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CMPEG1Source Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Private Member Functions | Private Attributes

CMPEG1Source Class Reference

#include "MPEG1Src.h"

Inherits OpQueue< CMPEG1Source, SourceOp >, and OpQueue< CMPEG1Source, SourceOp >.

List of all members.

Public Member Functions

_Acquires_lock_ (m_critSec) void Lock()
_Acquires_lock_ (m_critSec) void Lock()
_Releases_lock_ (m_critSec) void Unlock()
_Releases_lock_ (m_critSec) void Unlock()
STDMETHODIMP | BeginGetEvent (IMFAsyncCallback *pCallback, IUnknown *punkState)
STDMETHODIMP | BeginGetEvent (IMFAsyncCallback *pCallback, IUnknown *punkState)
HRESULT | BeginOpen (IMFByteStream *pStream, IMFAsyncCallback *pCB, IUnknown *pUnkState)
HRESULT | BeginOpen (IMFByteStream *pStream, IMFAsyncCallback *pCB, IUnknown *pUnkState)
STDMETHODIMP | CreatePresentationDescriptor (IMFPresentationDescriptor **ppPresentationDescriptor)
STDMETHODIMP | CreatePresentationDescriptor (IMFPresentationDescriptor **ppPresentationDescriptor)
STDMETHODIMP | EndGetEvent (IMFAsyncResult *pResult, IMFMediaEvent **ppEvent)
STDMETHODIMP | EndGetEvent (IMFAsyncResult *pResult, IMFMediaEvent **ppEvent)
HRESULT | EndOpen (IMFAsyncResult *pResult)
HRESULT | EndOpen (IMFAsyncResult *pResult)
STDMETHODIMP | GetCharacteristics (DWORD *pdwCharacteristics)
STDMETHODIMP | GetCharacteristics (DWORD *pdwCharacteristics)
STDMETHODIMP | GetEvent (DWORD dwFlags, IMFMediaEvent **ppEvent)
STDMETHODIMP | GetEvent (DWORD dwFlags, IMFMediaEvent **ppEvent)
IFACEMETHOD() | GetRate (_Inout_opt_ BOOL *pfThin, _Inout_opt_ float *pflRate)
IFACEMETHOD() | GetRate (_Inout_opt_ BOOL *pfThin, _Inout_opt_ float *pflRate)
IFACEMETHOD() | GetService (_In_ REFGUID guidService, _In_ REFIID riid, _Out_opt_ LPVOID *ppvObject)
IFACEMETHOD() | GetService (_In_ REFGUID guidService, _In_ REFIID riid, _Out_opt_ LPVOID *ppvObject)
HRESULT | OnByteStreamRead (IMFAsyncResult *pResult)
HRESULT | OnByteStreamRead (IMFAsyncResult *pResult)
STDMETHODIMP | Pause ()
STDMETHODIMP | Pause ()
STDMETHODIMP | QueryInterface (REFIID iid, void **ppv)
STDMETHODIMP | QueryInterface (REFIID iid, void **ppv)
HRESULT | QueueAsyncOperation (SourceOp::Operation OpType)
HRESULT | QueueAsyncOperation (SourceOp::Operation OpType)
STDMETHODIMP | QueueEvent (MediaEventType met, REFGUID guidExtendedType, HRESULT hrStatus, const PROPVARIANT *pvValue)
STDMETHODIMP | QueueEvent (MediaEventType met, REFGUID guidExtendedType, HRESULT hrStatus, const PROPVARIANT *pvValue)
IFACEMETHOD() | SetRate (BOOL fThin, float flRate)
IFACEMETHOD() | SetRate (BOOL fThin, float flRate)
STDMETHODIMP | Shutdown ()
STDMETHODIMP | Shutdown ()
STDMETHODIMP | Start (IMFPresentationDescriptor *pPresentationDescriptor, const GUID *pguidTimeFormat, const PROPVARIANT *pvarStartPosition)
STDMETHODIMP | Start (IMFPresentationDescriptor *pPresentationDescriptor, const GUID *pguidTimeFormat, const PROPVARIANT *pvarStartPosition)
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (ULONG) Release()
STDMETHODIMP_ (ULONG) Release()
STDMETHODIMP | Stop ()
STDMETHODIMP | Stop ()

Static Public Member Functions

static HRESULT | CreateInstance (CMPEG1Source **ppSource)
static HRESULT | CreateInstance (CMPEG1Source **ppSource)

Private Member Functions

CMPEG1Source (HRESULT &hr)
CMPEG1Source (HRESULT &hr)
~CMPEG1Source ()
~CMPEG1Source ()
HRESULT | BeginAsyncOp (SourceOp *pOp)
HRESULT | BeginAsyncOp (SourceOp *pOp)
HRESULT | CheckShutdown () const
HRESULT | CheckShutdown () const
HRESULT | CompleteAsyncOp (SourceOp *pOp)
HRESULT | CompleteAsyncOp (SourceOp *pOp)
HRESULT | CompleteOpen (HRESULT hrStatus)
HRESULT | CompleteOpen (HRESULT hrStatus)
HRESULT | CreateStream (const MPEG1PacketHeader &packetHdr)
HRESULT | CreateStream (const MPEG1PacketHeader &packetHdr)
HRESULT | DeliverPayload ()
HRESULT | DeliverPayload ()
HRESULT | DispatchOperation (SourceOp *pOp)
HRESULT | DispatchOperation (SourceOp *pOp)
HRESULT | DoPause (SourceOp *pOp)
HRESULT | DoPause (SourceOp *pOp)
HRESULT | DoSetRate (SourceOp *pOp)
HRESULT | DoSetRate (SourceOp *pOp)
HRESULT | DoStart (StartOp *pOp)
HRESULT | DoStart (StartOp *pOp)
HRESULT | DoStop (SourceOp *pOp)
HRESULT | DoStop (SourceOp *pOp)
HRESULT | EndOfMPEGStream ()
HRESULT | EndOfMPEGStream ()
HRESULT | InitPresentationDescriptor ()
HRESULT | InitPresentationDescriptor ()
HRESULT | IsInitialized () const
HRESULT | IsInitialized () const
BOOL | IsRateSupported (float flRate, float *pflAdjustedRate)
BOOL | IsRateSupported (float flRate, float *pflAdjustedRate)
BOOL | IsStreamActive (const MPEG1PacketHeader &packetHdr)
BOOL | IsStreamActive (const MPEG1PacketHeader &packetHdr)
BOOL | IsStreamTypeSupported (StreamType type) const
BOOL | IsStreamTypeSupported (StreamType type) const
HRESULT | OnEndOfStream (SourceOp *pOp)
HRESULT | OnEndOfStream (SourceOp *pOp)
HRESULT | OnStreamRequestSample (SourceOp *pOp)
HRESULT | OnStreamRequestSample (SourceOp *pOp)
HRESULT | ParseData ()
HRESULT | ParseData ()
HRESULT | ReadPayload (DWORD *pcbAte, DWORD *pcbNextRequest)
HRESULT | ReadPayload (DWORD *pcbAte, DWORD *pcbNextRequest)
HRESULT | RequestData (DWORD cbRequest)
HRESULT | RequestData (DWORD cbRequest)
HRESULT | SelectStreams (IMFPresentationDescriptor *pPD, const PROPVARIANT varStart)
HRESULT | SelectStreams (IMFPresentationDescriptor *pPD, const PROPVARIANT varStart)
void | StreamingError (HRESULT hr)
void | StreamingError (HRESULT hr)
BOOL | StreamsNeedData () const
BOOL | StreamsNeedData () const
HRESULT | ValidateOperation (SourceOp *pOp)
HRESULT | ValidateOperation (SourceOp *pOp)
HRESULT | ValidatePresentationDescriptor (IMFPresentationDescriptor *pPD)
HRESULT | ValidatePresentationDescriptor (IMFPresentationDescriptor *pPD)

Private Attributes

DWORD | m_cPendingEOS
long | m_cRef
ULONG | m_cRestartCounter
CRITICAL_SECTION | m_critSec
float | m_flRate
AsyncCallback< CMPEG1Source > m_OnByteStreamRead
IMFAsyncResult * | m_pBeginOpenResult
IMFByteStream * | m_pByteStream
SourceOp * m_pCurrentOp
IMFMediaEventQueue * | m_pEventQueue
MPEG1SystemHeader * m_pHeader
Parser * m_pParser
IMFPresentationDescriptor * | m_pPresentationDescriptor
SourceOp * m_pSampleRequest
Buffer m_ReadBuffer
SourceState m_state
StreamList m_streams

Detailed Description

Definition at line 245 of file MPEG1Src.h.

Constructor & Destructor Documentation

CMPEG1Source::CMPEG1Source ( HRESULT & hr ) [private]

Definition at line 803 of file MPEG1Src.cpp.

                                      :
    OpQueue(m_critSec),
    m_cRef(1),
    m_pEventQueue(NULL),
    m_pPresentationDescriptor(NULL),
    m_pBeginOpenResult(NULL),
    m_pParser(NULL),
    m_pByteStream(NULL),
    m_pHeader(NULL),
    m_state(STATE_INVALID),
    m_pCurrentOp(NULL),
    m_pSampleRequest(NULL),
    m_cRestartCounter(0),
    m_OnByteStreamRead(this, &CMPEG1Source::OnByteStreamRead),
    m_flRate(1.0f)
{
    auto module = ::Microsoft::WRL::GetModuleBase();
    if (module != nullptr)
    {
        module->IncrementObjectCount();
    }

  InitializeCriticalSectionEx(&m_critSec, 3000, 0);

    // Create the media event queue.
    hr = MFCreateEventQueue(&m_pEventQueue);
}

CMPEG1Source::~CMPEG1Source ( ) [private]

Definition at line 831 of file MPEG1Src.cpp.

{
    if (m_state != STATE_SHUTDOWN)
    {
        Shutdown();
    }

    DeleteCriticalSection(&m_critSec);

  auto module = ::Microsoft::WRL::GetModuleBase();
    if (module != nullptr)
    {
        module->DecrementObjectCount();
    }
}

CMPEG1Source::CMPEG1Source ( HRESULT & hr ) [private]
CMPEG1Source::~CMPEG1Source ( ) [private]

Member Function Documentation

CMPEG1Source::_Acquires_lock_ ( m_critSec ) [inline]

Definition at line 294 of file MPEG1Src.h.

                   { EnterCriticalSection(&m_critSec); }

CMPEG1Source::_Acquires_lock_ ( m_critSec ) [inline]

Definition at line 294 of file MPEG1Src.h.

                   { EnterCriticalSection(&m_critSec); }

CMPEG1Source::_Releases_lock_ ( m_critSec ) [inline]

Definition at line 297 of file MPEG1Src.h.

                   { LeaveCriticalSection(&m_critSec); }

CMPEG1Source::_Releases_lock_ ( m_critSec ) [inline]

Definition at line 297 of file MPEG1Src.h.

                   { LeaveCriticalSection(&m_critSec); }

HRESULT CMPEG1Source::BeginAsyncOp ( SourceOp * pOp ) [private]

Definition at line 1090 of file MPEG1Src.cpp.

{
    // At this point, the current operation should be NULL (the
    // previous operation is NULL) and the new operation (pOp)
    // must not be NULL.

    if (pOp == NULL || m_pCurrentOp != NULL)
    {
        assert(FALSE);
        return E_FAIL;
    }

    // Store the new operation as the current operation.

    m_pCurrentOp = pOp;
    m_pCurrentOp->AddRef();

    return S_OK;
}

HRESULT CMPEG1Source::BeginAsyncOp ( SourceOp * pOp ) [private]
HRESULT CMPEG1Source::BeginGetEvent | ( | IMFAsyncCallback * | pCallback,
 |  | IUnknown * | punkState
 | ) |  |

Definition at line 133 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        hr = m_pEventQueue->BeginGetEvent(pCallback, punkState);
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CMPEG1Source::BeginGetEvent | ( | IMFAsyncCallback * | pCallback,
 |  | IUnknown * | punkState
 | ) |  |
HRESULT CMPEG1Source::BeginOpen | ( | IMFByteStream * | pStream,
 |  | IMFAsyncCallback * | pCB,
 |  | IUnknown * | pUnkState
 | ) |  |
HRESULT CMPEG1Source::BeginOpen | ( | IMFByteStream * | pStream,
 |  | IMFAsyncCallback * | pCB,
 |  | IUnknown * | pUnkState
 | ) |  |

Definition at line 620 of file MPEG1Src.cpp.

{
    if (pStream == NULL || pCB == NULL)
    {
        return E_POINTER;
    }

    if (m_state != STATE_INVALID)
    {
        return MF_E_INVALIDREQUEST;
    }

    HRESULT hr = S_OK;
    DWORD dwCaps = 0;

    EnterCriticalSection(&m_critSec);

    // Cache the byte-stream pointer.
    m_pByteStream = pStream;
    m_pByteStream->AddRef();

    // Validate the capabilities of the byte stream.
    // The byte stream must be readable and seekable.
    hr = pStream->GetCapabilities(&dwCaps);

    if (SUCCEEDED(hr))
    {
        if ((dwCaps & MFBYTESTREAM_IS_SEEKABLE) == 0)
        {
            hr = MF_E_BYTESTREAM_NOT_SEEKABLE;
        }
        else if ((dwCaps & MFBYTESTREAM_IS_READABLE) == 0)
        {
            hr = E_FAIL;
        }
    }

    // Reserve space in the read buffer.
    if (SUCCEEDED(hr))
    {
        hr = m_ReadBuffer.Initalize(INITIAL_BUFFER_SIZE);
    }

    // Create the MPEG-1 parser.
    if (SUCCEEDED(hr))
    {
        m_pParser = new (std::nothrow) Parser();
        if (m_pParser == NULL)
        {
            hr = E_OUTOFMEMORY;
        }
    }

    // Create an async result object. We'll use it later to invoke the callback.
    if (SUCCEEDED(hr))
    {
        hr = MFCreateAsyncResult(NULL, pCB, pState, &m_pBeginOpenResult);
    }

    // Start reading data from the stream.
    if (SUCCEEDED(hr))
    {
        hr = RequestData(READ_SIZE);
    }

    // At this point, we now guarantee to invoke the callback.
    if (SUCCEEDED(hr))
    {
        m_state = STATE_OPENING;
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CMPEG1Source::CheckShutdown ( ) const [inline, private]

Definition at line 309 of file MPEG1Src.h.

    {
        return ( m_state == STATE_SHUTDOWN ? MF_E_SHUTDOWN : S_OK );
    }

HRESULT CMPEG1Source::CheckShutdown ( ) const [inline, private]

Definition at line 309 of file MPEG1Src.h.

    {
        return ( m_state == STATE_SHUTDOWN ? MF_E_SHUTDOWN : S_OK );
    }

HRESULT CMPEG1Source::CompleteAsyncOp ( SourceOp * pOp ) [private]

Definition at line 1117 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    // At this point, the current operation (m_pCurrentOp)
    // must match the operation that is ending (pOp).

    if (pOp == NULL || m_pCurrentOp == NULL)
    {
        assert(FALSE);
        return E_FAIL;
    }

    if (m_pCurrentOp != pOp)
    {
        assert(FALSE);
        return E_FAIL;
    }

    // Release the current operation.
    SafeRelease(&m_pCurrentOp);

    // Process the next operation on the queue.
    hr = ProcessQueue();

    return hr;
}

HRESULT CMPEG1Source::CompleteAsyncOp ( SourceOp * pOp ) [private]
HRESULT CMPEG1Source::CompleteOpen ( HRESULT hrStatus ) [private]
HRESULT CMPEG1Source::CompleteOpen ( HRESULT hrStatus ) [private]

Definition at line 856 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    if (m_pBeginOpenResult)
    {
        hr = m_pBeginOpenResult->SetStatus(hrStatus);
        if (SUCCEEDED(hr))
        {
            hr = MFInvokeCallback(m_pBeginOpenResult);
        }
    }

    SafeRelease(&m_pBeginOpenResult);
    return hr;
}

HRESULT CMPEG1Source::CreateInstance ( CMPEG1Source ** ppSource ) [static]

Definition at line 49 of file MPEG1Src.cpp.

{
    if (ppSource == NULL)
    {
        return E_POINTER;
    }

    HRESULT hr = S_OK;
    CMPEG1Source *pSource = new (std::nothrow) CMPEG1Source(hr);
    if (pSource == NULL)
    {
        return E_OUTOFMEMORY;
    }

    if (SUCCEEDED(hr))
    {
        *ppSource = pSource;
        (*ppSource)->AddRef();
    }

    SafeRelease(&pSource);
    return hr;
}

static HRESULT CMPEG1Source::CreateInstance ( CMPEG1Source ** ppSource ) [static]
HRESULT CMPEG1Source::CreatePresentationDescriptor ( IMFPresentationDescriptor ** ppPresentationDescriptor )

Definition at line 230 of file MPEG1Src.cpp.

{
    if (ppPresentationDescriptor == NULL)
    {
        return E_POINTER;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    // Fail if the source is shut down.
    hr = CheckShutdown();

    // Fail if the source was not initialized yet.
    if (SUCCEEDED(hr))
    {
        hr = IsInitialized();
    }

    // Do we have a valid presentation descriptor?
    if (SUCCEEDED(hr))
    {
        if (m_pPresentationDescriptor == NULL)
        {
            hr = MF_E_NOT_INITIALIZED;
        }
    }

    // Clone our presentation descriptor.
    if (SUCCEEDED(hr))
    {
        hr = m_pPresentationDescriptor->Clone(ppPresentationDescriptor);
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CMPEG1Source::CreatePresentationDescriptor ( IMFPresentationDescriptor ** ppPresentationDescriptor )
HRESULT CMPEG1Source::CreateStream ( const MPEG1PacketHeader & packetHdr ) [private]

Definition at line 2012 of file MPEG1Src.cpp.

{
    // We validate the stream type before calling this method.
    assert(IsStreamTypeSupported(packetHdr.type));

    // First see if the stream already exists.
    if ( m_streams.Find(packetHdr.stream_id) != NULL )
    {
        // The stream already exists. Nothing to do.
        return S_OK;
    }

    HRESULT hr = S_OK;
    DWORD cbAte = 0;
    BYTE *pPayload = NULL;

    IMFMediaType *pType = NULL;
    IMFStreamDescriptor *pSD = NULL;
    CMPEG1Stream *pStream = NULL;
    IMFMediaTypeHandler *pHandler = NULL;

    MPEG1VideoSeqHeader videoSeqHdr;
    MPEG1AudioFrameHeader audioFrameHeader;

    // Get a pointer to the start of the payload.
    pPayload = m_ReadBuffer.DataPtr();

    // Create a media type, based on the packet type (audio/video)
    switch (packetHdr.type)
    {
    case StreamType_Video:
        // Video: Read the sequence header and use it to create a media type.
        hr = ReadVideoSequenceHeader(pPayload, packetHdr.cbPayload, videoSeqHdr, &cbAte);
        if (SUCCEEDED(hr))
        {
            hr = CreateVideoMediaType(videoSeqHdr, &pType);
        }
        break;

    case StreamType_Audio:
        // Audio: Read the frame header and use it to create a media type.
        hr = ReadAudioFrameHeader(pPayload, packetHdr.cbPayload, audioFrameHeader, &cbAte);
        if (SUCCEEDED(hr))
        {
            hr = CreateAudioMediaType(audioFrameHeader, &pType);
        }
        break;

    default:
        assert(false); // If this case occurs, then IsStreamTypeSupported() is wrong.
        hr = E_UNEXPECTED;
    }

    if (SUCCEEDED(hr))
    {
        // Create the stream descriptor from the media type.
        hr = MFCreateStreamDescriptor(packetHdr.stream_id, 1, &pType, &pSD);
    }

    // Set the default media type on the stream handler.
    if (SUCCEEDED(hr))
    {
        hr = pSD->GetMediaTypeHandler(&pHandler);
    }
    if (SUCCEEDED(hr))
    {
        hr = pHandler->SetCurrentMediaType(pType);
    }

    // Create the new stream.
    if (SUCCEEDED(hr))
    {
        pStream = new (std::nothrow) CMPEG1Stream(this, pSD, hr);
        if (pStream == NULL)
        {
            hr = E_OUTOFMEMORY;
        }
    }

    // Add the stream to the array.
    if (SUCCEEDED(hr))
    {
        hr = m_streams.AddStream(packetHdr.stream_id, pStream);
    }

    SafeRelease(&pSD);
    SafeRelease(&pStream);
    return hr;
}

HRESULT CMPEG1Source::CreateStream ( const MPEG1PacketHeader & packetHdr ) [private]
HRESULT CMPEG1Source::DeliverPayload ( ) [private]

Definition at line 1900 of file MPEG1Src.cpp.

{
    // When this method is called, the read buffer contains a complete
    // payload, and the payload belongs to a stream whose type we support.

    assert(m_pParser->HasPacket());

    HRESULT             hr = S_OK;
    MPEG1PacketHeader   packetHdr;
    CMPEG1Stream        *pStream = NULL;    // not AddRef'd

    IMFMediaBuffer      *pBuffer = NULL;
    IMFSample           *pSample = NULL;
    BYTE                *pData = NULL;      // Pointer to the IMFMediaBuffer data.

    packetHdr = m_pParser->PacketHeader();

    if (packetHdr.cbPayload > m_ReadBuffer.DataSize())
    {
        assert(FALSE);
        hr = E_UNEXPECTED;
    }

    // If we are still opening the file, then we might need to create this stream.
    if (SUCCEEDED(hr))
    {
        if (m_state == STATE_OPENING)
        {
            hr = CreateStream(packetHdr);
        }
    }

    if (SUCCEEDED(hr))
    {
        pStream = m_streams.Find(packetHdr.stream_id);
        assert(pStream != NULL);
    }

    // Create a media buffer for the payload.
    if (SUCCEEDED(hr))
    {
        hr = MFCreateMemoryBuffer(packetHdr.cbPayload, &pBuffer);
    }

    if (SUCCEEDED(hr))
    {
        hr = pBuffer->Lock(&pData, NULL, NULL);
    }

    if (SUCCEEDED(hr))
    {
        CopyMemory(pData, m_ReadBuffer.DataPtr(), packetHdr.cbPayload);
    }

    if (SUCCEEDED(hr))
    {
        hr = pBuffer->Unlock();
    }

    if (SUCCEEDED(hr))
    {
        hr = pBuffer->SetCurrentLength(packetHdr.cbPayload);
    }

    // Create a sample to hold the buffer.
    if (SUCCEEDED(hr))
    {
        hr = MFCreateSample(&pSample);
    }
    if (SUCCEEDED(hr))
    {
        hr = pSample->AddBuffer(pBuffer);
    }

    // Time stamp the sample.
    if (SUCCEEDED(hr))
    {
        if (packetHdr.bHasPTS)
        {
            LONGLONG hnsStart = packetHdr.PTS * 10000 / 90;

            hr = pSample->SetSampleTime(hnsStart);
        }
    }

    // Deliver the payload to the stream.
    if (SUCCEEDED(hr))
    {
        hr = pStream->DeliverPayload(pSample);
    }

    // If the open operation is still pending, check if we're done.
    if (SUCCEEDED(hr))
    {
        if (m_state == STATE_OPENING)
        {
            hr = InitPresentationDescriptor();
        }
    }

    SafeRelease(&pBuffer);
    SafeRelease(&pSample);
    return hr;
}

HRESULT CMPEG1Source::DeliverPayload ( ) [private]
HRESULT CMPEG1Source::DispatchOperation ( SourceOp * pOp ) [private, virtual]

Implements OpQueue< CMPEG1Source, SourceOp >.

HRESULT CMPEG1Source::DispatchOperation ( SourceOp * pOp ) [private, virtual]

Implements OpQueue< CMPEG1Source, SourceOp >.

Definition at line 1155 of file MPEG1Src.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    if (m_state == STATE_SHUTDOWN)
    {
        LeaveCriticalSection(&m_critSec);

        return S_OK; // Already shut down, ignore the request.
    }

    switch (pOp->Op())
    {

    // IMFMediaSource methods:

    case SourceOp::OP_START:
        hr = DoStart((StartOp*)pOp);
        break;

    case SourceOp::OP_STOP:
        hr = DoStop(pOp);
        break;

    case SourceOp::OP_PAUSE:
        hr = DoPause(pOp);
        break;

    case SourceOp::OP_SETRATE:
        hr = DoSetRate(pOp);
        break;

    // Operations requested by the streams:

    case SourceOp::OP_REQUEST_DATA:
        hr = OnStreamRequestSample(pOp);
        break;

    case SourceOp::OP_END_OF_STREAM:
        hr = OnEndOfStream(pOp);
        break;

    default:
        hr = E_UNEXPECTED;
    }

    if (FAILED(hr))
    {
        StreamingError(hr);
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CMPEG1Source::DoPause ( SourceOp * pOp ) [private]

Definition at line 1378 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    hr = BeginAsyncOp(pOp);

    // Pause is only allowed while running.
    if (SUCCEEDED(hr))
    {
        if (m_state != STATE_STARTED)
        {
            hr = MF_E_INVALID_STATE_TRANSITION;
        }
    }

    // Pause the active streams.
    if (SUCCEEDED(hr))
    {
        for (DWORD i = 0; i < m_streams.GetCount(); i++)
        {
            if (m_streams[i]->IsActive())
            {
                hr = m_streams[i]->Pause();
            }
            if (FAILED(hr))
            {
                break;
            }
        }
    }

    m_state = STATE_PAUSED;

    // Send the "paused" event. This might include a failure code.
    (void)m_pEventQueue->QueueEventParamVar(MESourcePaused, GUID_NULL, hr, NULL);

    CompleteAsyncOp(pOp);

    return hr;
}

HRESULT CMPEG1Source::DoPause ( SourceOp * pOp ) [private]
HRESULT CMPEG1Source::DoSetRate ( SourceOp * pOp ) [private]

Definition at line 1425 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;
    SetRateOp *pSetRateOp = static_cast<SetRateOp*>(pOp);

    hr = BeginAsyncOp(pOp);

    // Set rate on active streams.
    if (SUCCEEDED(hr))
    {
        for (DWORD i = 0; i < m_streams.GetCount(); i++)
        {
            if (m_streams[i]->IsActive())
            {
                hr = m_streams[i]->SetRate(pSetRateOp->GetRate());
            }
            if (FAILED(hr))
            {
                break;
            }
        }
    }

    if (SUCCEEDED(hr))
    {
        m_flRate = pSetRateOp->GetRate();
    }

    // Send the "rate changted" event. This might include a failure code.
    (void)m_pEventQueue->QueueEventParamVar(MESourceRateChanged, GUID_NULL, hr, NULL);

    CompleteAsyncOp(pOp);

    return hr;
}

HRESULT CMPEG1Source::DoSetRate ( SourceOp * pOp ) [private]
HRESULT CMPEG1Source::DoStart ( StartOp * pOp ) [private]
HRESULT CMPEG1Source::DoStart ( StartOp * pOp ) [private]

Definition at line 1247 of file MPEG1Src.cpp.

{
    assert(pOp->Op() == SourceOp::OP_START);

    IMFPresentationDescriptor *pPD = NULL;
    IMFMediaEvent  *pEvent = NULL;

    HRESULT     hr = S_OK;
    LONGLONG    llStartOffset = 0;
    BOOL        bRestartFromCurrentPosition = FALSE;
    BOOL        bSentEvents = FALSE;

    hr = BeginAsyncOp(pOp);

    // Get the presentation descriptor from the SourceOp object.
    // This is the PD that the caller passed into the Start() method.
    // The PD has already been validated.
    if (SUCCEEDED(hr))
    {
        hr = pOp->GetPresentationDescriptor(&pPD);
    }
    // Because this sample does not support seeking, the start
    // position must be 0 (from stopped) or "current position."

    // If the sample supported seeking, we would need to get the
    // start position from the PROPVARIANT data contained in pOp.

    if (SUCCEEDED(hr))
    {
        // Select/deselect streams, based on what the caller set in the PD.
        // This method also sends the MENewStream/MEUpdatedStream events.
        hr = SelectStreams(pPD, pOp->Data());
    }

    if (SUCCEEDED(hr))
    {
        m_state = STATE_STARTED;

        // Queue the "started" event. The event data is the start position.
        hr = m_pEventQueue->QueueEventParamVar(
            MESourceStarted,
            GUID_NULL,
            S_OK,
            &pOp->Data()
            );
    }

    if (FAILED(hr))
    {
        // Failure. Send the error code to the application.

        // Note: It's possible that QueueEvent itself failed, in which case it
        // is likely to fail again. But there is no good way to recover in
        // that case.

        (void)m_pEventQueue->QueueEventParamVar(
            MESourceStarted, GUID_NULL, hr, NULL);
    }

    CompleteAsyncOp(pOp);

    SafeRelease(&pEvent);
    SafeRelease(&pPD);
    return hr;
}

HRESULT CMPEG1Source::DoStop ( SourceOp * pOp ) [private]
HRESULT CMPEG1Source::DoStop ( SourceOp * pOp ) [private]

Definition at line 1319 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;
    QWORD qwCurrentPosition = 0;

    hr = BeginAsyncOp(pOp);

    // Stop the active streams.
    if (SUCCEEDED(hr))
    {
        for (DWORD i = 0; i < m_streams.GetCount(); i++)
        {
            if (m_streams[i]->IsActive())
            {
                hr = m_streams[i]->Stop();
            }
            if (FAILED(hr))
            {
                break;
            }
        }
    }

    // Seek to the start of the file. If we restart after stopping,
    // we will start from the beginning of the file again.
    if (SUCCEEDED(hr))
    {
        hr = m_pByteStream->Seek(
            msoBegin,
            0,
            MFBYTESTREAM_SEEK_FLAG_CANCEL_PENDING_IO,
            &qwCurrentPosition
            );
    }

    // Increment the counter that tracks "stale" read requests.
    if (SUCCEEDED(hr))
    {
        ++m_cRestartCounter; // This counter is allowed to overflow.
    }

    SafeRelease(&m_pSampleRequest);

    m_state = STATE_STOPPED;

    // Send the "stopped" event. This might include a failure code.
    (void)m_pEventQueue->QueueEventParamVar(MESourceStopped, GUID_NULL, hr, NULL);

    CompleteAsyncOp(pOp);

    return hr;
}

HRESULT CMPEG1Source::EndGetEvent | ( | IMFAsyncResult * | pResult,
 |  | IMFMediaEvent ** | ppEvent
 | ) |  |

Definition at line 150 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        hr = m_pEventQueue->EndGetEvent(pResult, ppEvent);
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CMPEG1Source::EndGetEvent | ( | IMFAsyncResult * | pResult,
 |  | IMFMediaEvent ** | ppEvent
 | ) |  |
HRESULT CMPEG1Source::EndOfMPEGStream ( ) [private]

Definition at line 1831 of file MPEG1Src.cpp.

{
    // Notify the streams. The streams might have pending samples.
    // When each stream delivers the last sample, it will send the
    // end-of-stream event to the pipeline and then notify the
    // source.

    // When every stream is done, the source sends the end-of-
    // presentation event.

    HRESULT hr = S_OK;

    for (DWORD i = 0; i < m_streams.GetCount(); i++)
    {
        if (m_streams[i]->IsActive())
        {
            hr = m_streams[i]->EndOfStream();
        }
        if (FAILED(hr))
        {
            break;
        }
    }

    return hr;
}

HRESULT CMPEG1Source::EndOfMPEGStream ( ) [private]
HRESULT CMPEG1Source::EndOpen ( IMFAsyncResult * pResult )
HRESULT CMPEG1Source::EndOpen ( IMFAsyncResult * pResult )

Definition at line 702 of file MPEG1Src.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    hr = pResult->GetStatus();

    if (FAILED(hr))
    {
        // The source is not designed to recover after failing to open.
        // Switch to shut-down state.
        Shutdown();
    }
    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CMPEG1Source::GetCharacteristics ( DWORD * pdwCharacteristics )

Definition at line 277 of file MPEG1Src.cpp.

{
    if (pdwCharacteristics == NULL)
    {
        return E_POINTER;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        *pdwCharacteristics =  MFMEDIASOURCE_CAN_PAUSE;
    }

    // NOTE: This sample does not implement seeking, so we do not
    // include the MFMEDIASOURCE_CAN_SEEK flag.

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CMPEG1Source::GetCharacteristics ( DWORD * pdwCharacteristics )
STDMETHODIMP CMPEG1Source::GetEvent | ( | DWORD | dwFlags,
 |  | IMFMediaEvent ** | ppEvent
 | ) |  |
HRESULT CMPEG1Source::GetEvent | ( | DWORD | dwFlags,
 |  | IMFMediaEvent ** | ppEvent
 | ) |  |

Definition at line 167 of file MPEG1Src.cpp.

{
    // NOTE:
    // GetEvent can block indefinitely, so we don't hold the critical
    // section. Therefore we need to use a local copy of the event queue
    // pointer, to make sure the pointer remains valid.

    HRESULT hr = S_OK;

    IMFMediaEventQueue *pQueue = NULL;

    EnterCriticalSection(&m_critSec);

    // Check shutdown
    hr = CheckShutdown();

    // Cache a local pointer to the queue.
    if (SUCCEEDED(hr))
    {
        pQueue = m_pEventQueue;
        pQueue->AddRef();
    }

    LeaveCriticalSection(&m_critSec);

    // Use the local pointer to call GetEvent.
    if (SUCCEEDED(hr))
    {
        hr = pQueue->GetEvent(dwFlags, ppEvent);
    }

    SafeRelease(&pQueue);
    return hr;
}

HRESULT CMPEG1Source::GetRate | ( | _Inout_opt_ BOOL * | pfThin,
 |  | _Inout_opt_ float * | pflRate
 | ) |  |

Definition at line 580 of file MPEG1Src.cpp.

{
    if (pfThin == nullptr || pflRate == nullptr)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);
    *pfThin = FALSE;
    *pflRate = m_flRate;
    LeaveCriticalSection(&m_critSec);

    return S_OK;
}

IFACEMETHOD() CMPEG1Source::GetRate | ( | _Inout_opt_ BOOL * | pfThin,
 |  | _Inout_opt_ float * | pflRate
 | ) |  |
IFACEMETHOD() CMPEG1Source::GetService | ( | _In_ REFGUID | guidService,
 |  | _In_ REFIID | riid,
 |  | _Out_opt_ LPVOID * | ppvObject
 | ) |  |
HRESULT CMPEG1Source::GetService | ( | _In_ REFGUID | guidService,
 |  | _In_ REFIID | riid,
 |  | _Out_opt_ LPVOID * | ppvObject
 | ) |  |

Definition at line 515 of file MPEG1Src.cpp.

{
    HRESULT hr = MF_E_UNSUPPORTED_SERVICE;

    if (ppvObject == nullptr)
    {
        return E_POINTER;
    }

    if (guidService == MF_RATE_CONTROL_SERVICE)
    {
        hr = QueryInterface(riid, ppvObject);
    }

    return hr;
}

HRESULT CMPEG1Source::InitPresentationDescriptor ( ) [private]

Definition at line 953 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;
    DWORD cStreams = 0;

    assert(m_pPresentationDescriptor == NULL);
    assert(m_state == STATE_OPENING);

    if (m_pHeader == NULL)
    {
        return E_FAIL;
    }

    // Get the number of streams, as declared in the MPEG-1 header, skipping
    // any streams with an unsupported format.
    for (DWORD i = 0; i < m_pHeader->cStreams; i++)
    {
        if (IsStreamTypeSupported(m_pHeader->streams[i].type))
        {
            cStreams++;
        }
    }

    // How many streams do we actually have?
    if (cStreams > m_streams.GetCount())
    {
        // Keep reading data until we have seen a packet for each stream.
        return S_OK;
    }

    // We should never create a stream we don't support.
    assert(cStreams == m_streams.GetCount());

    // Ready to create the presentation descriptor.

    // Create an array of IMFStreamDescriptor pointers.
    IMFStreamDescriptor **ppSD =
            new (std::nothrow) IMFStreamDescriptor*[cStreams];

    if (ppSD == NULL)
    {
        hr = E_OUTOFMEMORY;
        goto done;
    }

    ZeroMemory(ppSD, cStreams * sizeof(IMFStreamDescriptor*));

    // Fill the array by getting the stream descriptors from the streams.
    for (DWORD i = 0; i < cStreams; i++)
    {
        hr = m_streams[i]->GetStreamDescriptor(&ppSD[i]);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    // Create the presentation descriptor.
    hr = MFCreatePresentationDescriptor(cStreams, ppSD,
        &m_pPresentationDescriptor);

    if (FAILED(hr))
    {
        goto done;
    }

    // Select the first video stream (if any).
    for (DWORD i = 0; i < cStreams; i++)
    {
        GUID majorType = GUID_NULL;

        hr = GetStreamMajorType(ppSD[i], &majorType);
        if (FAILED(hr))
        {
            goto done;
        }

        hr = m_pPresentationDescriptor->SelectStream(i);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    // Switch state from "opening" to stopped.
    m_state = STATE_STOPPED;

    // Invoke the async callback to complete the BeginOpen operation.
    hr = CompleteOpen(S_OK);

done:
    // clean up:
    if (ppSD)
    {
        for (DWORD i = 0; i < cStreams; i++)
        {
            SafeRelease(&ppSD[i]);
        }
        delete [] ppSD;
    }
    return hr;
}

HRESULT CMPEG1Source::InitPresentationDescriptor ( ) [private]
HRESULT CMPEG1Source::IsInitialized ( ) const [private]
HRESULT CMPEG1Source::IsInitialized ( ) const [private]

Definition at line 880 of file MPEG1Src.cpp.

{
    if (m_state == STATE_OPENING || m_state == STATE_INVALID)
    {
        return MF_E_NOT_INITIALIZED;
    }
    else
    {
        return S_OK;
    }
}

BOOL CMPEG1Source::IsRateSupported | ( | float | flRate,
 |  | float * | pflAdjustedRate |
 | ) |  |  | [private]
BOOL CMPEG1Source::IsRateSupported | ( | float | flRate,
 |  | float * | pflAdjustedRate |
 | ) |  |  | [private]

Definition at line 2193 of file MPEG1Src.cpp.

{
    if (flRate < 0.00001f && flRate > -0.00001f)
    {
        *pflAdjustedRate = 0.0f;
        return TRUE;
    }
    else if(flRate < 1.0001f && flRate > 0.9999f)
    {
        *pflAdjustedRate = 1.0f;
        return TRUE;
    }
    return FALSE;
}

BOOL CMPEG1Source::IsStreamActive ( const MPEG1PacketHeader & packetHdr ) [private]
BOOL CMPEG1Source::IsStreamActive ( const MPEG1PacketHeader & packetHdr ) [private]

Definition at line 914 of file MPEG1Src.cpp.

{
    if (m_state == STATE_OPENING)
    {
        // The source is still opening.
        // Deliver payloads for every supported stream type.
        return IsStreamTypeSupported(packetHdr.type);
    }
    else
    {
        // The source is already opened. Check if the stream is active.
        CMPEG1Stream *pStream = m_streams.Find(packetHdr.stream_id);

        if (pStream == NULL)
        {
            return FALSE;
        }
        else
        {
            return pStream->IsActive();
        }
    }
}

BOOL CMPEG1Source::IsStreamTypeSupported ( StreamType type ) const [private]
BOOL CMPEG1Source::IsStreamTypeSupported ( StreamType type ) const [private]

Definition at line 899 of file MPEG1Src.cpp.

{
    // We support audio and video streams.
    return (type == StreamType_Video || type == StreamType_Audio);
}

HRESULT CMPEG1Source::OnByteStreamRead ( IMFAsyncResult * pResult )

Definition at line 729 of file MPEG1Src.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;
    DWORD cbRead = 0;

    IUnknown *pState = NULL;

    if (m_state == STATE_SHUTDOWN)
    {
        // If we are shut down, then we've already released the
        // byte stream. Nothing to do.
        LeaveCriticalSection(&m_critSec);
        return S_OK;
    }

    // Get the state object. This is either NULL or the most
    // recent OP_REQUEST_DATA operation.
    (void)pResult->GetState(&pState);

    // Complete the read opertation.
    hr = m_pByteStream->EndRead(pResult, &cbRead);

    // If the source stops and restarts in rapid succession, there is
    // a chance this is a "stale" read request, initiated before the
    // stop/restart.

    // To ensure that we don't deliver stale data, we store the
    // OP_REQUEST_DATA operation as a state object in pResult, and compare
    // this against the current value of m_cRestartCounter.

    // If they don't match, we discard the data.

    // NOTE: During BeginOpen, pState is NULL

    if (SUCCEEDED(hr))
    {
        if ((pState == NULL) || ( ((SourceOp*)pState)->Data().ulVal == m_cRestartCounter) )
        {
            // This data is OK to parse.

            if (cbRead == 0)
            {
                // There is no more data in the stream. Signal end-of-stream.
                hr = EndOfMPEGStream();
            }
            else
            {
                // Update the end-position of the read buffer.
                hr = m_ReadBuffer.MoveEnd(cbRead);

                // Parse the new data.
                if (SUCCEEDED(hr))
                {
                    hr = ParseData();
                }
            }
        }
    }

    if (FAILED(hr))
    {
        StreamingError(hr);
    }
    SafeRelease(&pState);
    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CMPEG1Source::OnByteStreamRead ( IMFAsyncResult * pResult )
HRESULT CMPEG1Source::OnEndOfStream ( SourceOp * pOp ) [private]

Definition at line 1522 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    hr = BeginAsyncOp(pOp);

    // Decrement the count of end-of-stream notifications.
    if (SUCCEEDED(hr))
    {
        --m_cPendingEOS;
        if (m_cPendingEOS == 0)
        {
            // No more streams. Send the end-of-presentation event.
            hr = m_pEventQueue->QueueEventParamVar(MEEndOfPresentation, GUID_NULL, S_OK, NULL);
        }

    }

    if (SUCCEEDED(hr))
    {
        hr = CompleteAsyncOp(pOp);
    }

    return hr;
}

HRESULT CMPEG1Source::OnEndOfStream ( SourceOp * pOp ) [private]
HRESULT CMPEG1Source::OnStreamRequestSample ( SourceOp * pOp ) [private]
HRESULT CMPEG1Source::OnStreamRequestSample ( SourceOp * pOp ) [private]

Definition at line 1469 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    hr = BeginAsyncOp(pOp);

    // Ignore this request if we are already handling an earlier request.
    // (In that case m_pSampleRequest will be non-NULL.)

    if (SUCCEEDED(hr))
    {
        if (m_pSampleRequest == NULL)
        {
            // Add the request counter as data to the operation.
            // This counter tracks whether a read request becomes "stale."

            PROPVARIANT var;
            var.vt = VT_UI4;
            var.ulVal = m_cRestartCounter;

            hr = pOp->SetData(var);

            if (SUCCEEDED(hr))
            {
                // Store this while the request is pending.
                m_pSampleRequest = pOp;
                m_pSampleRequest->AddRef();

                // Try to parse data - this will invoke a read request if needed.
                ParseData();
            }
        }

        CompleteAsyncOp(pOp);
    }

    return hr;
}

HRESULT CMPEG1Source::ParseData ( ) [private]

Definition at line 1670 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    DWORD cbNextRequest = 0;
    BOOL  bNeedMoreData = FALSE;

    // Keep processing data until
    // (a) All streams have enough samples, or
    // (b) The parser needs more data in the buffer.

    while ( StreamsNeedData() )
    {
        DWORD cbAte = 0;    // How much data we consumed from the read buffer.

        // Check if we got the first system header.
        if (m_pHeader == NULL && m_pParser->HasSystemHeader())
        {
            hr = m_pParser->GetSystemHeader(&m_pHeader);

            if (FAILED(hr)) { break; }
        }

        if (m_pParser->IsEndOfStream())
        {
            // The parser reached the end of the MPEG-1 stream. Notify the streams.
            hr = EndOfMPEGStream();
        }
        else if (m_pParser->HasPacket())
        {
            // The parser reached the start of a new packet.
            hr = ReadPayload(&cbAte, &cbNextRequest);
        }
        else
        {
            // Parse more data.
            hr = m_pParser->ParseBytes(m_ReadBuffer.DataPtr(), m_ReadBuffer.DataSize(), &cbAte);
        }

        // Parser::ParseBytes() or ReadPayload can return S_FALSE, meaning "Need more data"
        if (hr == S_FALSE)
        {
            bNeedMoreData = TRUE;
        }

        if (FAILED(hr)) { break; }

        // Advance the start of the read buffer by the amount consumed.
        hr = m_ReadBuffer.MoveStart(cbAte);

        if (FAILED(hr)) { break; }

        // If we need more data, start an async read operation.
        if (bNeedMoreData)
        {
            hr = RequestData( max(READ_SIZE, cbNextRequest) );

            // Break from the loop because we need to wait for the async read to complete.
            break;
        }
    }

    // Flag our state. If a stream requests more data while we are waiting for an async
    // read to complete, we can ignore the stream's request, because the request will be
    // dispatched as soon as we get more data.

    if (SUCCEEDED(hr))
    {
        if (!bNeedMoreData)
        {
            SafeRelease(&m_pSampleRequest);
        }
    }

    return hr;
}

HRESULT CMPEG1Source::ParseData ( ) [private]
STDMETHODIMP CMPEG1Source::Pause ( )
HRESULT CMPEG1Source::Pause ( )

Definition at line 308 of file MPEG1Src.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    // Fail if the source is shut down.
    hr = CheckShutdown();

    // Queue the operation.
    if (SUCCEEDED(hr))
    {
        hr = QueueAsyncOperation(SourceOp::OP_PAUSE);
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CMPEG1Source::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppv
 | ) |  |
HRESULT CMPEG1Source::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppv
 | ) |  |

Definition at line 78 of file MPEG1Src.cpp.

{
    if (ppv == nullptr)
    {
        return E_POINTER;
    }

    HRESULT hr = E_NOINTERFACE;
    if (riid == IID_IUnknown ||
        riid == IID_IMFMediaEventGenerator ||
        riid == IID_IMFMediaSource)
    {
        (*ppv) = static_cast<IMFMediaSource *>(this);
        AddRef();
        hr = S_OK;
    }
    else if (riid == IID_IMFGetService)
    {
        (*ppv) = static_cast<IMFGetService*>(this);
        AddRef();
        hr = S_OK;
    }
    else if (riid == IID_IMFRateControl)
    {
        (*ppv) = static_cast<IMFRateControl*>(this);
        AddRef();
        hr = S_OK;
    }

    return hr;
}

HRESULT CMPEG1Source::QueueAsyncOperation ( SourceOp::Operation OpType )

Definition at line 1067 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;
    SourceOp *pOp = NULL;

    hr = SourceOp::CreateOp(OpType, &pOp);

    if (SUCCEEDED(hr))
    {
        hr = QueueOperation(pOp);
    }

    SafeRelease(&pOp);
    return hr;
}

HRESULT CMPEG1Source::QueueAsyncOperation ( SourceOp::Operation OpType )
HRESULT CMPEG1Source::QueueEvent | ( | MediaEventType | met,
 |  | REFGUID | guidExtendedType,
 |  | HRESULT | hrStatus,
 |  | const PROPVARIANT * | pvValue
 | ) |  |

Definition at line 202 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        hr = m_pEventQueue->QueueEventParamVar(met, guidExtendedType, hrStatus, pvValue);
    }

    LeaveCriticalSection(&m_critSec);

    return hr;
}

STDMETHODIMP CMPEG1Source::QueueEvent | ( | MediaEventType | met,
 |  | REFGUID | guidExtendedType,
 |  | HRESULT | hrStatus,
 |  | const PROPVARIANT * | pvValue
 | ) |  |
HRESULT CMPEG1Source::ReadPayload | ( | DWORD * | pcbAte,
 |  | DWORD * | pcbNextRequest |
 | ) |  |  | [private]

Definition at line 1756 of file MPEG1Src.cpp.

{
    assert(m_pParser != NULL);
    assert(m_pParser->HasPacket());

    HRESULT hr = S_OK;

    DWORD cbPayloadRead = 0;
    DWORD cbPayloadUnread = 0;

    // At this point, the read buffer might be larger or smaller than the payload.
    // Calculate which portion of the payload has been read.
    if (m_pParser->PayloadSize() > m_ReadBuffer.DataSize())
    {
        cbPayloadUnread = m_pParser->PayloadSize() - m_ReadBuffer.DataSize();
    }

    cbPayloadRead = m_pParser->PayloadSize() - cbPayloadUnread;

    // Do we need to deliver this payload?
    if ( !IsStreamActive(m_pParser->PacketHeader()) )
    {
        QWORD qwCurrentPosition = 0;

        // Skip this payload. Seek past the unread portion of the payload.
        hr = m_pByteStream->Seek(
            msoCurrent,
            cbPayloadUnread,
            MFBYTESTREAM_SEEK_FLAG_CANCEL_PENDING_IO,
            &qwCurrentPosition
            );

        // Advance the data buffer to the end of payload, or the portion
        // that has been read.

        if (SUCCEEDED(hr))
        {
            *pcbAte = cbPayloadRead;

            // Tell the parser that we are done with this packet.
            m_pParser->ClearPacket();
        }

    }
    else if (cbPayloadUnread > 0)
    {
        // Some portion of this payload has not been read. Schedule a read.
        *pcbNextRequest = cbPayloadUnread;

        *pcbAte = 0;

        hr = S_FALSE; // Need more data.
    }
    else
    {
        // The entire payload is in the data buffer. Deliver the packet.
        hr = DeliverPayload();

        if (SUCCEEDED(hr))
        {
            *pcbAte = cbPayloadRead;

            // Tell the parser that we are done with this packet.
            m_pParser->ClearPacket();
        }
    }

    return hr;
}

HRESULT CMPEG1Source::ReadPayload | ( | DWORD * | pcbAte,
 |  | DWORD * | pcbNextRequest |
 | ) |  |  | [private]
HRESULT CMPEG1Source::RequestData ( DWORD cbRequest ) [private]
HRESULT CMPEG1Source::RequestData ( DWORD cbRequest ) [private]

Definition at line 1641 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    // Reserve a sufficient read buffer.
    hr = m_ReadBuffer.Reserve(cbRequest);

    // Submit the async read request.
    // When it completes, our OnByteStreamRead method will be invoked.

    if (SUCCEEDED(hr))
    {
        hr = m_pByteStream->BeginRead(
            m_ReadBuffer.DataPtr() + m_ReadBuffer.DataSize(),
            cbRequest,
            &m_OnByteStreamRead,
            m_pSampleRequest
            );
    }

    return hr;
}

HRESULT CMPEG1Source::SelectStreams | ( | IMFPresentationDescriptor * | pPD,
 |  | const PROPVARIANT | varStart |
 | ) |  |  | [private]

Definition at line 1555 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;
    BOOL    fSelected = FALSE;
    BOOL    fWasSelected = FALSE;
    DWORD   stream_id = 0;

    IMFStreamDescriptor *pSD = NULL;

    CMPEG1Stream *pStream = NULL; // Not add-ref'd

    // Reset the pending EOS count.
    m_cPendingEOS = 0;

    // Loop throught the stream descriptors to find which streams are active.
    for (DWORD i = 0; i < m_streams.GetCount(); i++)
    {
        hr = pPD->GetStreamDescriptorByIndex(i, &fSelected, &pSD);
        if (FAILED(hr))
        {
            goto done;
        }

        hr = pSD->GetStreamIdentifier(&stream_id);
        if (FAILED(hr))
        {
            goto done;
        }

        pStream = m_streams.Find((BYTE)stream_id);
        if (pStream == NULL)
        {
            hr = E_INVALIDARG;
            goto done;
        }

        // Was the stream active already?
        fWasSelected = pStream->IsActive();

        // Activate or deactivate the stream.
        hr = pStream->Activate(fSelected);
        if (FAILED(hr))
        {
            goto done;
        }

        if (fSelected)
        {
            m_cPendingEOS++;

            // If the stream was previously selected, send an "updated stream"
            // event. Otherwise, send a "new stream" event.
            MediaEventType met = fWasSelected ? MEUpdatedStream : MENewStream;

            hr = m_pEventQueue->QueueEventParamUnk(met, GUID_NULL, hr, pStream);
            if (FAILED(hr))
            {
                goto done;
            }

            // Start the stream. The stream will send the appropriate event.
            hr = pStream->Start(varStart);
            if (FAILED(hr))
            {
                goto done;
            }
        }
        SafeRelease(&pSD);
    }

done:
    SafeRelease(&pSD);
    return hr;
}

HRESULT CMPEG1Source::SelectStreams | ( | IMFPresentationDescriptor * | pPD,
 |  | const PROPVARIANT | varStart |
 | ) |  |  | [private]
IFACEMETHOD() CMPEG1Source::SetRate | ( | BOOL | fThin,
 |  | float | flRate
 | ) |  |
HRESULT CMPEG1Source::SetRate | ( | BOOL | fThin,
 |  | float | flRate
 | ) |  |

Definition at line 541 of file MPEG1Src.cpp.

{
    if (fThin)
    {
        return MF_E_THINNING_UNSUPPORTED;
    }
    if (!IsRateSupported(flRate, &flRate))
    {
        return MF_E_UNSUPPORTED_RATE;
    }

    EnterCriticalSection(&m_critSec);
    HRESULT hr = S_OK;
    SourceOp *pAsyncOp = nullptr;

    if (flRate == m_flRate)
    {
        goto done;
    }

    hr = SourceOp::CreateSetRateOp(fThin, flRate, &pAsyncOp);

    if (SUCCEEDED(hr))
    {
        // Queue asynchronous stop
        hr = QueueOperation(pAsyncOp);
    }

done:
    SafeRelease(&pAsyncOp);
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CMPEG1Source::Shutdown ( )
HRESULT CMPEG1Source::Shutdown ( )

Definition at line 332 of file MPEG1Src.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    CMPEG1Stream *pStream = NULL;

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        // Shut down the stream objects.

        for (DWORD i = 0; i < m_streams.GetCount(); i++)
        {
            (void)m_streams[i]->Shutdown();
        }

        // Shut down the event queue.
        if (m_pEventQueue)
        {
            (void)m_pEventQueue->Shutdown();
        }

        // Release objects.

        SafeRelease(&m_pEventQueue);
        SafeRelease(&m_pPresentationDescriptor);
        SafeRelease(&m_pBeginOpenResult);
        SafeRelease(&m_pByteStream);
        SafeRelease(&m_pCurrentOp);

        CoTaskMemFree(m_pHeader);
        m_pHeader = NULL;

        delete m_pParser;
        m_pParser = NULL;

        // Set the state.
        m_state = STATE_SHUTDOWN;
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CMPEG1Source::Start | ( | IMFPresentationDescriptor * | pPresentationDescriptor,
 |  | const GUID * | pguidTimeFormat,
 |  | const PROPVARIANT * | pvarStartPosition
 | ) |  |
HRESULT CMPEG1Source::Start | ( | IMFPresentationDescriptor * | pPresentationDescriptor,
 |  | const GUID * | pguidTimeFormat,
 |  | const PROPVARIANT * | pvarStartPosition
 | ) |  |

Definition at line 385 of file MPEG1Src.cpp.

{

    HRESULT hr = S_OK;
    SourceOp *pAsyncOp = NULL;

    // Check parameters.

    // Start position and presentation descriptor cannot be NULL.
    if (pvarStartPos == NULL || pPresentationDescriptor == NULL)
    {
        return E_INVALIDARG;
    }

    // Check the time format.
    if ((pguidTimeFormat != NULL) && (*pguidTimeFormat != GUID_NULL))
    {
        // Unrecognized time format GUID.
        return MF_E_UNSUPPORTED_TIME_FORMAT;
    }

    // Check the data type of the start position.
    if ((pvarStartPos->vt != VT_I8) && (pvarStartPos->vt != VT_EMPTY))
    {
        return MF_E_UNSUPPORTED_TIME_FORMAT;
    }

    EnterCriticalSection(&m_critSec);

    // Check if this is a seek request. This sample does not support seeking.

    if (pvarStartPos->vt == VT_I8)
    {
        // If the current state is STOPPED, then position 0 is valid.
        // Otherwise, the start position must be VT_EMPTY (current position).

        if ((m_state != STATE_STOPPED) || (pvarStartPos->hVal.QuadPart != 0))
        {
            hr = MF_E_INVALIDREQUEST;
            goto done;
        }
    }

    // Fail if the source is shut down.
    hr = CheckShutdown();
    if (FAILED(hr))
    {
        goto done;
    }

    // Fail if the source was not initialized yet.
    hr = IsInitialized();
    if (FAILED(hr))
    {
        goto done;
    }

    // Perform a sanity check on the caller's presentation descriptor.
    hr = ValidatePresentationDescriptor(pPresentationDescriptor);
    if (FAILED(hr))
    {
        goto done;
    }

    // The operation looks OK. Complete the operation asynchronously.

    hr = SourceOp::CreateStartOp(pPresentationDescriptor, &pAsyncOp);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = pAsyncOp->SetData(*pvarStartPos);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = QueueOperation(pAsyncOp);

done:
    SafeRelease(&pAsyncOp);
    LeaveCriticalSection(&m_critSec);
    return hr;
}

CMPEG1Source::STDMETHODIMP_ ( ULONG )
CMPEG1Source::STDMETHODIMP_ ( ULONG )
CMPEG1Source::STDMETHODIMP_ ( ULONG )
CMPEG1Source::STDMETHODIMP_ ( ULONG )
STDMETHODIMP CMPEG1Source::Stop ( )
HRESULT CMPEG1Source::Stop ( )

Definition at line 481 of file MPEG1Src.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    // Fail if the source is shut down.
    hr = CheckShutdown();

    // Fail if the source was not initialized yet.
    if (SUCCEEDED(hr))
    {
        hr = IsInitialized();
    }

    // Queue the operation.
    if (SUCCEEDED(hr))
    {
        hr = QueueAsyncOperation(SourceOp::OP_STOP);
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

void CMPEG1Source::StreamingError ( HRESULT hr ) [private]
void CMPEG1Source::StreamingError ( HRESULT hr ) [private]

Definition at line 2175 of file MPEG1Src.cpp.

{
    if (m_state == STATE_OPENING)
    {
        // An error happened during BeginOpen.
        // Invoke the callback with the status code.

        CompleteOpen(hr);
    }
    else if (m_state != STATE_SHUTDOWN)
    {
        // An error occurred during streaming. Send the MEError event
        // to notify the pipeline.

        QueueEvent(MEError, GUID_NULL, hr, NULL);
    }
}

BOOL CMPEG1Source::StreamsNeedData ( ) const [private]

Definition at line 1865 of file MPEG1Src.cpp.

{
    BOOL bNeedData = FALSE;

    switch (m_state)
    {
    case STATE_OPENING:
        // While opening, we always need data (until we get enough
        // to complete the open operation).
        return TRUE;

    case STATE_SHUTDOWN:
        // While shut down, we never need data.
        return FALSE;

    default:
        // If none of the above, ask the streams.
        for (DWORD i = 0; i < m_streams.GetCount(); i++)
        {
            if (m_streams[i]->NeedsData())
            {
                bNeedData = TRUE;
                break;
            }
        }
        return bNeedData;
    }
}

BOOL CMPEG1Source::StreamsNeedData ( ) const [private]
HRESULT CMPEG1Source::ValidateOperation ( SourceOp * pOp ) [private, virtual]

Implements OpQueue< CMPEG1Source, SourceOp >.

Definition at line 1226 of file MPEG1Src.cpp.

{
    if (m_pCurrentOp != NULL)
    {
        return MF_E_NOTACCEPTING;
    }
    return S_OK;
}

HRESULT CMPEG1Source::ValidateOperation ( SourceOp * pOp ) [private, virtual]

Implements OpQueue< CMPEG1Source, SourceOp >.

HRESULT CMPEG1Source::ValidatePresentationDescriptor ( IMFPresentationDescriptor * pPD ) [private]

Definition at line 2113 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;
    BOOL fSelected = FALSE;
    DWORD cStreams = 0;

    IMFStreamDescriptor *pSD = NULL;

    if (m_pHeader == NULL)
    {
        return E_UNEXPECTED;
    }

    // The caller's PD must have the same number of streams as ours.
    hr = pPD->GetStreamDescriptorCount(&cStreams);

    if (SUCCEEDED(hr))
    {
        if (cStreams != m_pHeader->cStreams)
        {
            hr = E_INVALIDARG;
        }
    }

    // The caller must select at least one stream.
    if (SUCCEEDED(hr))
    {
        for (DWORD i = 0; i < cStreams; i++)
        {
            hr = pPD->GetStreamDescriptorByIndex(i, &fSelected, &pSD);
            if (FAILED(hr))
            {
                break;
            }
            if (fSelected)
            {
                break;
            }
            SafeRelease(&pSD);
        }
    }

    if (SUCCEEDED(hr))
    {
        if (!fSelected)
        {
            hr = E_INVALIDARG;
        }
    }

    SafeRelease(&pSD);
    return hr;
}

HRESULT CMPEG1Source::ValidatePresentationDescriptor ( IMFPresentationDescriptor * pPD ) [private]

Member Data Documentation

DWORD CMPEG1Source::m_cPendingEOS [private]

Definition at line 369 of file MPEG1Src.h.

long CMPEG1Source::m_cRef [private]

Definition at line 352 of file MPEG1Src.h.

ULONG CMPEG1Source::m_cRestartCounter [private]

Definition at line 370 of file MPEG1Src.h.

CRITICAL_SECTION CMPEG1Source::m_critSec [private]

Definition at line 354 of file MPEG1Src.h.

float CMPEG1Source::m_flRate [private]

Definition at line 378 of file MPEG1Src.h.

AsyncCallback< CMPEG1Source > CMPEG1Source::m_OnByteStreamRead [private]

Definition at line 376 of file MPEG1Src.h.

IMFAsyncResult * CMPEG1Source::m_pBeginOpenResult [private]

Definition at line 362 of file MPEG1Src.h.

IMFByteStream * CMPEG1Source::m_pByteStream [private]

Definition at line 363 of file MPEG1Src.h.

SourceOp * CMPEG1Source::m_pCurrentOp [private]

Definition at line 372 of file MPEG1Src.h.

IMFMediaEventQueue * CMPEG1Source::m_pEventQueue [private]

Definition at line 360 of file MPEG1Src.h.

MPEG1SystemHeader * CMPEG1Source::m_pHeader [private]

Definition at line 365 of file MPEG1Src.h.

Parser * CMPEG1Source::m_pParser [private]

Definition at line 358 of file MPEG1Src.h.

IMFPresentationDescriptor * CMPEG1Source::m_pPresentationDescriptor [private]

Definition at line 361 of file MPEG1Src.h.

SourceOp * CMPEG1Source::m_pSampleRequest [private]

Definition at line 373 of file MPEG1Src.h.

Buffer CMPEG1Source::m_ReadBuffer [private]

Definition at line 357 of file MPEG1Src.h.

SourceState CMPEG1Source::m_state [private]

Definition at line 355 of file MPEG1Src.h.

StreamList CMPEG1Source::m_streams [private]

Definition at line 367 of file MPEG1Src.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp
Generated on Sat Nov 23 2024 16:09:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CMPEG1Stream Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Private Member Functions | Private Attributes

CMPEG1Stream Class Reference

#include "MPEG1Stream.h"

List of all members.

Classes

class | SourceLock

Public Member Functions

CMPEG1Stream (CMPEG1Source *pSource, IMFStreamDescriptor *pSD, HRESULT &hr)
~CMPEG1Stream ()
HRESULT | Activate (BOOL bActive)
STDMETHODIMP | BeginGetEvent (IMFAsyncCallback *pCallback, IUnknown *punkState)
HRESULT | DeliverPayload (IMFSample *pSample)
STDMETHODIMP | EndGetEvent (IMFAsyncResult *pResult, IMFMediaEvent **ppEvent)
HRESULT | EndOfStream ()
STDMETHODIMP | GetEvent (DWORD dwFlags, IMFMediaEvent **ppEvent)
STDMETHODIMP | GetMediaSource (IMFMediaSource **ppMediaSource)
STDMETHODIMP | GetStreamDescriptor (IMFStreamDescriptor **ppStreamDescriptor)
BOOL | IsActive () const
BOOL | NeedsData ()
HRESULT | OnDispatchSamples (IMFAsyncResult *pResult)
HRESULT | Pause ()
STDMETHODIMP | QueryInterface (REFIID iid, void **ppv)
STDMETHODIMP | QueueEvent (MediaEventType met, REFGUID guidExtendedType, HRESULT hrStatus, const PROPVARIANT *pvValue)
STDMETHODIMP | RequestSample (IUnknown *pToken)
HRESULT | SetRate (float flRate)
HRESULT | Shutdown ()
HRESULT | Start (const PROPVARIANT &varStart)
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (ULONG) Release()
HRESULT | Stop ()

Private Member Functions

HRESULT | CheckShutdown () const
HRESULT | DispatchSamples ()

Private Attributes

BOOL | m_bActive
BOOL | m_bEOS
long | m_cRef
float | m_flRate
IMFMediaEventQueue * | m_pEventQueue
CMPEG1Source * m_pSource
IMFStreamDescriptor * | m_pStreamDescriptor
TokenList m_Requests
SampleList m_Samples
SourceState m_state

Detailed Description

Definition at line 20 of file MPEG1Stream.h.

Constructor & Destructor Documentation

CMPEG1Stream::CMPEG1Stream | ( | CMPEG1Source * | pSource,
 |  | IMFStreamDescriptor * | pSD,
 |  | HRESULT & | hr
 | ) |  |

Definition at line 323 of file MPEG1Stream.cpp.

                                                                                :
    m_cRef(1),
    m_pEventQueue(NULL),
    m_state(STATE_STOPPED),
    m_bActive(FALSE),
    m_bEOS(FALSE),
    m_flRate(1.0f)
{
    auto module = ::Microsoft::WRL::GetModuleBase();
    if (module != nullptr)
    {
        module->IncrementObjectCount();
    }

  assert(pSource != NULL);
    assert(pSD != NULL);

    m_pSource = pSource;
    m_pSource->AddRef();

    m_pStreamDescriptor = pSD;
    m_pStreamDescriptor->AddRef();

    // Create the media event queue.
    hr = MFCreateEventQueue(&m_pEventQueue);
}

CMPEG1Stream::~CMPEG1Stream ( )

Definition at line 350 of file MPEG1Stream.cpp.

{
    assert(m_state == STATE_SHUTDOWN);
    SafeRelease(&m_pSource);

    auto module = ::Microsoft::WRL::GetModuleBase();
    if (module != nullptr)
    {
        module->DecrementObjectCount();
    }
}

Member Function Documentation

HRESULT CMPEG1Stream::Activate ( BOOL bActive )

Definition at line 369 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    if (bActive == m_bActive)
    {
        return S_OK; // No op
    }

    m_bActive = bActive;

    if (!bActive)
    {
        m_Samples.Clear();
        m_Requests.Clear();
    }
    return S_OK;
}

HRESULT CMPEG1Stream::BeginGetEvent | ( | IMFAsyncCallback * | pCallback,
 |  | IUnknown * | punkState
 | ) |  |

Definition at line 103 of file MPEG1Stream.cpp.

{
    HRESULT hr = S_OK;

    SourceLock lock(m_pSource);

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        hr = m_pEventQueue->BeginGetEvent(pCallback, punkState);
    }

    return hr;
}

HRESULT CMPEG1Stream::CheckShutdown ( ) const [inline, private]

Definition at line 78 of file MPEG1Stream.h.

    {
        return ( m_state == STATE_SHUTDOWN ? MF_E_SHUTDOWN : S_OK );
    }

HRESULT CMPEG1Stream::DeliverPayload ( IMFSample * pSample )

Definition at line 577 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    HRESULT hr = S_OK;

    // Queue the sample.
    hr = m_Samples.InsertBack(pSample);

    // Deliver the sample if there is an outstanding request.
    if (SUCCEEDED(hr))
    {
        hr = DispatchSamples();
    }

    return hr;
}

HRESULT CMPEG1Stream::DispatchSamples ( ) [private]

Definition at line 602 of file MPEG1Stream.cpp.

{
    HRESULT hr = S_OK;
    BOOL bNeedData = FALSE;
    BOOL bEOS = FALSE;

    SourceLock lock(m_pSource);

    // An I/O request can complete after the source is paused, stopped, or
    // shut down. Do not deliver samples unless the source is running.
    if (m_state != STATE_STARTED)
    {
        return S_OK;
    }

    IMFSample *pSample = NULL;
    IUnknown  *pToken = NULL;

    // Deliver as many samples as we can.
    while (!m_Samples.IsEmpty() && !m_Requests.IsEmpty())
    {
        // Pull the next sample from the queue.
        hr = m_Samples.RemoveFront(&pSample);
        if (FAILED(hr))
        {
            goto done;
        }

        // Pull the next request token from the queue. Tokens can be NULL.
        hr = m_Requests.RemoveFront(&pToken);
        if (FAILED(hr))
        {
            goto done;
        }

        if (pToken)
        {
            // Set the token on the sample.
            hr = pSample->SetUnknown(MFSampleExtension_Token, pToken);
            if (FAILED(hr))
            {
                goto done;
            }
        }

        // Send an MEMediaSample event with the sample.
        hr = m_pEventQueue->QueueEventParamUnk(
            MEMediaSample, GUID_NULL, S_OK, pSample);

        if (FAILED(hr))
        {
            goto done;
        }

        SafeRelease(&pSample);
        SafeRelease(&pToken);
    }

    if (m_Samples.IsEmpty() && m_bEOS)
    {
        // The sample queue is empty AND we have reached the end of the source
        // stream. Notify the pipeline by sending the end-of-stream event.

        hr = m_pEventQueue->QueueEventParamVar(
            MEEndOfStream, GUID_NULL, S_OK, NULL);

        if (FAILED(hr))
        {
            goto done;
        }

        // Notify the source. It will send the end-of-presentation event.
        hr = m_pSource->QueueAsyncOperation(SourceOp::OP_END_OF_STREAM);
        if (FAILED(hr))
        {
            goto done;
        }
    }
    else if (NeedsData())
    {
        // The sample queue is empty; the request queue is not empty; and we
        // have not reached the end of the stream. Ask for more data.
        hr = m_pSource->QueueAsyncOperation(SourceOp::OP_REQUEST_DATA);
        if (FAILED(hr))
        {
            goto done;
        }
    }

done:
    if (FAILED(hr) && (m_state != STATE_SHUTDOWN))
    {
        // An error occurred. Send an MEError even from the source,
        // unless the source is already shut down.
        m_pSource->QueueEvent(MEError, GUID_NULL, hr, NULL);
    }

    SafeRelease(&pSample);
    SafeRelease(&pToken);
    return S_OK;
}

HRESULT CMPEG1Stream::EndGetEvent | ( | IMFAsyncResult * | pResult,
 |  | IMFMediaEvent ** | ppEvent
 | ) |  |

Definition at line 119 of file MPEG1Stream.cpp.

{
    HRESULT hr = S_OK;

    SourceLock lock(m_pSource);

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        hr = m_pEventQueue->EndGetEvent(pResult, ppEvent);
    }

    return hr;
}

HRESULT CMPEG1Stream::EndOfStream ( )

Definition at line 501 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    m_bEOS = TRUE;

    return DispatchSamples();
}

HRESULT CMPEG1Stream::GetEvent | ( | DWORD | dwFlags,
 |  | IMFMediaEvent ** | ppEvent
 | ) |  |

Definition at line 135 of file MPEG1Stream.cpp.

{
    HRESULT hr = S_OK;

    IMFMediaEventQueue *pQueue = NULL;

    { // scope for lock

        SourceLock lock(m_pSource);

        // Check shutdown
        hr = CheckShutdown();

        // Cache a local pointer to the queue.
        if (SUCCEEDED(hr))
        {
            pQueue = m_pEventQueue;
            pQueue->AddRef();
        }
    }   // release lock

    // Use the local pointer to call GetEvent.
    if (SUCCEEDED(hr))
    {
        hr = pQueue->GetEvent(dwFlags, ppEvent);
    }

    SafeRelease(&pQueue);
    return hr;
}

HRESULT CMPEG1Stream::GetMediaSource ( IMFMediaSource ** ppMediaSource )

Definition at line 192 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    if (ppMediaSource == NULL)
    {
        return E_POINTER;
    }

    if (m_pSource == NULL)
    {
        return E_UNEXPECTED;
    }

    HRESULT hr = S_OK;

    hr = CheckShutdown();

    // QI the source for IMFMediaSource.
    // (Does not hold the source's critical section.)
    if (SUCCEEDED(hr))
    {
        hr = m_pSource->QueryInterface(IID_PPV_ARGS(ppMediaSource));
    }
    return hr;
}

HRESULT CMPEG1Stream::GetStreamDescriptor ( IMFStreamDescriptor ** ppStreamDescriptor )

Definition at line 225 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    if (ppStreamDescriptor == NULL)
    {
        return E_POINTER;
    }

    if (m_pStreamDescriptor == NULL)
    {
        return E_UNEXPECTED;
    }

    HRESULT hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        *ppStreamDescriptor = m_pStreamDescriptor;
        (*ppStreamDescriptor)->AddRef();

    };
    return hr;
}

BOOL CMPEG1Stream::IsActive ( ) const [inline]

Definition at line 52 of file MPEG1Stream.h.

{ return m_bActive; }

BOOL CMPEG1Stream::NeedsData ( )

Definition at line 561 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    // Note: The stream tries to keep a minimum number of samples
    // queued ahead.

    return (m_bActive && !m_bEOS && (m_Samples.GetCount() < SAMPLE_QUEUE));
}

HRESULT CMPEG1Stream::OnDispatchSamples ( IMFAsyncResult * pResult )
HRESULT CMPEG1Stream::Pause ( )

Definition at line 430 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    HRESULT hr = S_OK;

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        m_state = STATE_PAUSED;

        hr = QueueEvent(MEStreamPaused, GUID_NULL, S_OK, NULL);
    }

    return hr;
}

HRESULT CMPEG1Stream::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppv
 | ) |  |

Definition at line 76 of file MPEG1Stream.cpp.

{
    if (ppv == nullptr)
    {
        return E_POINTER;
    }

    HRESULT hr = E_NOINTERFACE;
    if (riid == IID_IUnknown ||
        riid == IID_IMFMediaEventGenerator ||
        riid == IID_IMFMediaStream)
    {
        (*ppv) = static_cast<IMFMediaStream *>(this);
        AddRef();
        hr = S_OK;
    }

    return hr;
}

HRESULT CMPEG1Stream::QueueEvent | ( | MediaEventType | met,
 |  | REFGUID | guidExtendedType,
 |  | HRESULT | hrStatus,
 |  | const PROPVARIANT * | pvValue
 | ) |  |

Definition at line 166 of file MPEG1Stream.cpp.

{
    HRESULT hr = S_OK;

    SourceLock lock(m_pSource);

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        hr = m_pEventQueue->QueueEventParamVar(met, guidExtendedType, hrStatus, pvValue);
    }

    return hr;
}

HRESULT CMPEG1Stream::RequestSample ( IUnknown * pToken )

Definition at line 258 of file MPEG1Stream.cpp.

{
    HRESULT hr = S_OK;
    IMFMediaSource *pSource = NULL;

    // Hold the media source object's critical section.
    SourceLock lock(m_pSource);

    hr = CheckShutdown();
    if (FAILED(hr))
    {
        goto done;
    }

    if (m_state == STATE_STOPPED)
    {
        hr = MF_E_INVALIDREQUEST;
        goto done;
    }

    if (!m_bActive)
    {
        // If the stream is not active, it should not get sample requests.
        hr = MF_E_INVALIDREQUEST;
        goto done;
    }

    if (m_bEOS && m_Samples.IsEmpty())
    {
        // This stream has already reached the end of the stream, and the
        // sample queue is empty.
        hr = MF_E_END_OF_STREAM;
        goto done;
    }

    hr = m_Requests.InsertBack(pToken);
    if (FAILED(hr))
    {
        goto done;
    }

    // Dispatch the request.
    hr = DispatchSamples();
    if (FAILED(hr))
    {
        goto done;
    }

done:
    if (FAILED(hr) && (m_state != STATE_SHUTDOWN))
    {
        // An error occurred. Send an MEError even from the source,
        // unless the source is already shut down.
        hr = m_pSource->QueueEvent(MEError, GUID_NULL, hr, NULL);
    }
    return hr;
}

HRESULT CMPEG1Stream::SetRate ( float flRate )

Definition at line 480 of file MPEG1Stream.cpp.

{
    HRESULT hr = S_OK;
    SourceLock lock(m_pSource);

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        m_flRate = flRate;
    }

    return hr;
}

HRESULT CMPEG1Stream::Shutdown ( )

Definition at line 516 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    HRESULT hr = S_OK;

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        m_state = STATE_SHUTDOWN;

        // Shut down the event queue.
        if (m_pEventQueue)
        {
            m_pEventQueue->Shutdown();
        }

        // Release objects.
        m_Samples.Clear();
        m_Requests.Clear();

        SafeRelease(&m_pStreamDescriptor);
        SafeRelease(&m_pEventQueue);

        // NOTE:
        // Do NOT release the source pointer here, because the stream uses
        // it to hold the critical section. In particular, the stream must
        // hold the critical section when checking the shutdown status,
        // which obviously can occur after the stream is shut down.

        // It is OK to hold a ref count on the source after shutdown,
        // because the source releases its ref count(s) on the streams,
        // which breaks the circular ref count.
    }

    return hr;
}

HRESULT CMPEG1Stream::Start ( const PROPVARIANT & varStart )

Definition at line 396 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    HRESULT hr = S_OK;

    hr = CheckShutdown();

    // Queue the stream-started event.
    if (SUCCEEDED(hr))
    {
        hr = QueueEvent(MEStreamStarted, GUID_NULL, S_OK, &varStart);
    }

    if (SUCCEEDED(hr))
    {
        m_state = STATE_STARTED;
    }

    // If we are restarting from paused, there may be
    // queue sample requests. Dispatch them now.
    if (SUCCEEDED(hr))
    {
        hr = DispatchSamples();
    }
    return hr;
}

CMPEG1Stream::STDMETHODIMP_ ( ULONG )
CMPEG1Stream::STDMETHODIMP_ ( ULONG )
HRESULT CMPEG1Stream::Stop ( )

Definition at line 454 of file MPEG1Stream.cpp.

{
    SourceLock lock(m_pSource);

    HRESULT hr = S_OK;

    hr = CheckShutdown();

    if (SUCCEEDED(hr))
    {
        m_Requests.Clear();
        m_Samples.Clear();

        m_state = STATE_STOPPED;

        hr = QueueEvent(MEStreamStopped, GUID_NULL, S_OK, NULL);
    }

    return hr;
}

Member Data Documentation

BOOL CMPEG1Stream::m_bActive [private]

Definition at line 93 of file MPEG1Stream.h.

BOOL CMPEG1Stream::m_bEOS [private]

Definition at line 94 of file MPEG1Stream.h.

long CMPEG1Stream::m_cRef [private]

Definition at line 86 of file MPEG1Stream.h.

float CMPEG1Stream::m_flRate [private]

Definition at line 99 of file MPEG1Stream.h.

IMFMediaEventQueue* CMPEG1Stream::m_pEventQueue [private]

Definition at line 90 of file MPEG1Stream.h.

CMPEG1Source* CMPEG1Stream::m_pSource [private]

Definition at line 88 of file MPEG1Stream.h.

IMFStreamDescriptor* CMPEG1Stream::m_pStreamDescriptor [private]

Definition at line 89 of file MPEG1Stream.h.

TokenList CMPEG1Stream::m_Requests [private]

Definition at line 97 of file MPEG1Stream.h.

SampleList CMPEG1Stream::m_Samples [private]

Definition at line 96 of file MPEG1Stream.h.

SourceState CMPEG1Stream::m_state [private]

Definition at line 92 of file MPEG1Stream.h.

The documentation for this class was generated from the following files:
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Stream.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Stream.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CMPEG1Stream::SourceLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CMPEG1Stream
  • CMPEG1Stream::SourceLock
Public Member Functions | Private Attributes

CMPEG1Stream::SourceLock Class Reference

List of all members.

Public Member Functions

_Acquires_lock_ (m_pSource) SourceLock(CMPEG1Source *pSource)
_Releases_lock_ (m_pSource)~SourceLock()

Private Attributes

CMPEG1Source * m_pSource

Detailed Description

Definition at line 64 of file MPEG1Stream.h.

Member Function Documentation

CMPEG1Stream::SourceLock::_Acquires_lock_ ( m_pSource )
CMPEG1Stream::SourceLock::_Releases_lock_ ( m_pSource )

Member Data Documentation

CMPEG1Source* CMPEG1Stream::SourceLock::m_pSource [private]

Definition at line 67 of file MPEG1Stream.h.

The documentation for this class was generated from the following file:
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Stream.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Collision Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Collision Class Reference

#include "Collision.h"

List of all members.

Public Member Functions

Collision ()
BOOL | BuildCollisionListForSphere (const Sphere &meshLocalSpace, FXMVECTOR path)
Contact * FindWorstInterpenetration ()
BOOL | IntersectsWithGround () const
void | UpdateInterpenetrations (FXMVECTOR newPosition, FXMVECTOR radius, FXMVECTOR path)

Public Attributes

std::vector< Contact > | m_collisions
std::vector< Triangle > | m_floorTriList
std::vector< Triangle > | m_groundTriList
std::vector< Triangle > | m_wallTriList

Private Member Functions

BOOL | AccumulateSphereTriangleIntersections (FXMVECTOR sphere, FXMVECTOR radius, FXMVECTOR path, MeshID mesh, const std::vector< Triangle > &triList)
void | MergeSharedEdgeCoplanarContacts (FXMVECTOR sphere, FXMVECTOR radius, FXMVECTOR path)

Private Attributes

BOOL | m_intersectsGround

Detailed Description

Definition at line 61 of file Collision.h.

Constructor & Destructor Documentation

Collision::Collision ( ) [inline]

Definition at line 72 of file Collision.h.

                :
        m_intersectsGround(FALSE)
    {
    }

Member Function Documentation

BOOL Collision::AccumulateSphereTriangleIntersections | ( | FXMVECTOR | sphere,
 |  | FXMVECTOR | radius,
 |  | FXMVECTOR | path,
 |  | MeshID | mesh,
 |  | const std::vector< Triangle > & | triList |
 | ) |  |  | [private]

Definition at line 66 of file Collision.cpp.

{
    size_t triCount = triList.size();

    BOOL found = FALSE;
    for (size_t i = 0; i < triCount; ++i)
    {
        Contact f(triList[i], i, mesh);

        if (f.CalculateContact(sphere, radius, path))
        {
            m_collisions.push_back(f);
            found = TRUE;
        }
    }

    return found;
}

BOOL Collision::BuildCollisionListForSphere | ( | const Sphere & | meshLocalSpace,
 |  | FXMVECTOR | path
 | ) |  |

Definition at line 92 of file Collision.cpp.

{
    m_collisions.clear();
    XMVECTOR sphere = XMLoadFloat4(&meshLocalSpace.center);
    XMVECTOR radius = XMVectorSplatW(sphere);

    m_intersectsGround = AccumulateSphereTriangleIntersections(sphere, radius, path, MeshID::Ground, m_groundTriList);

    BOOL intersected = m_intersectsGround;
    intersected |= AccumulateSphereTriangleIntersections(sphere, radius, path, MeshID::Wall, m_wallTriList);

    // NOTE: We don't collide against the floor, as the mesh has some edges which interfere with normal rolling.

    // intersected |= AccumulateSphereTriangleIntersections(sphere, radius, path, MeshID::Floor, m_floorTriList);

    MergeSharedEdgeCoplanarContacts(sphere, radius, path);

    return intersected;
}

Contact * Collision::FindWorstInterpenetration ( )

Definition at line 131 of file Collision.cpp.

{
    Contact* worst = nullptr;
    float worstDistance = FLT_MAX;

    for (size_t i = 0; i < m_collisions.size(); ++i)
    {
        Contact& c = m_collisions[i];

        if (c.IsColliding() && c.penetrationDistance < worstDistance && c.closingVelocity <= 0.0f)
        {
            worst = &c;
            worstDistance = c.penetrationDistance;
        }
    }

    return worst;
}

BOOL Collision::IntersectsWithGround ( ) const [inline]

Definition at line 77 of file Collision.h.

    {
        return m_intersectsGround;
    }

void Collision::MergeSharedEdgeCoplanarContacts | ( | FXMVECTOR | sphere,
 |  | FXMVECTOR | radius,
 |  | FXMVECTOR | path |
 | ) |  |  | [private]

Definition at line 152 of file Collision.cpp.

{
    size_t count = m_collisions.size();
    for (size_t j = 0; j < count; ++j)
    {
        Contact& c1 = m_collisions[j];
        if (!c1.IsColliding())
            continue;

        XMVECTOR A = XMLoadFloat3(&c1.triangle.A);
        XMVECTOR B = XMLoadFloat3(&c1.triangle.B);
        XMVECTOR C = XMLoadFloat3(&c1.triangle.C);
        XMVECTOR N = c1.triangle.Normal();

        XMVECTOR c1Contact = XMLoadFloat3(&c1.contactPosition);

        for (size_t i = j + 1; i < count; ++i)
        {
            Contact& c2 = m_collisions[i];
            if (!c2.IsColliding())
                continue;

            BOOL coplanar, sharesverts;
            c2.triangle.CheckSharesVertsOrCoplanar(A, B, C, N, sharesverts, coplanar);

            if (sharesverts)
            {
                if (coplanar)
                {
                    // If we share vertices with the other tri, and we're coplanar, then
                    // we're on a larger "plane" stretch, so we should use that.

                    c2.Invalidate();

                    // Update normal
                    XMStoreFloat3((XMFLOAT3*)&c1.plane, N);

                    // Update closing velocity.
                    XMStoreFloat(&c1.closingVelocity, XMVector3Dot(path, N));

                    XMVECTOR dist = XMVector3Dot(sphere - A, N);
                    XMVECTOR newContact = sphere - (dist * N);
                    XMVECTOR penetration = dist - radius;

                    // Find new contact point - project sphere center down onto plane.
                    XMStoreFloat3(&c1.contactPosition, newContact);
                    c1.contactIsEdge = FALSE;
                    XMStoreFloat(&c1.penetrationDistance, penetration);

                }
                else if (c1.contactIsEdge || c2.contactIsEdge)
                {
                    // We've got a contact position that's most likely on a corner.
                    const XMVECTOR epsilon = XMVectorSet(1E-4f, 1E-4f, 1E-4f, 1E-4f);
                    const XMVECTOR contactPos1 = XMLoadFloat3(&c1.contactPosition);
                    const XMVECTOR contactPos2 = XMLoadFloat3(&c2.contactPosition);

                    // If they're nearly equal, recalculate normal as average of two tris.
                    if (XMVector3NearEqual(contactPos1, contactPos2, epsilon))
                    {
                        c1.contactIsEdge = FALSE;
                        XMVECTOR C1Normal = c1.triangle.Normal();
                        XMVECTOR C2Normal = c2.triangle.Normal();
                        XMVECTOR newNormal = XMVector3Normalize(C1Normal + C2Normal);
                        XMStoreFloat3((XMFLOAT3*)&c1.plane, newNormal);

                        XMStoreFloat(&c1.closingVelocity, XMVector3Dot(path, newNormal));

                        // Calculate new penetration...
                        XMVECTOR dist = XMVector3Dot(sphere - contactPos1, newNormal);
                        XMVECTOR penetration = dist - radius;
                        XMStoreFloat(&c1.penetrationDistance, penetration);
                        c2.Invalidate();
                    }
                }
            }
            else
            {
                // If we don't share an edge, but we're coplanar, check if we're the same distance... If
                // we are, we're probably on a flat plane, and can merge the two.
                if (coplanar)
                {
                    const float PENETRATION_DIST_TOLERANCE = 1E-4f;
                    if (fabs(c1.penetrationDistance - c2.penetrationDistance) <= PENETRATION_DIST_TOLERANCE)
                    {
                        // Same plane!
                        c2.Invalidate();
                    }
                }
            }
        }
    }
}

void Collision::UpdateInterpenetrations | ( | FXMVECTOR | newPosition,
 |  | FXMVECTOR | radius,
 |  | FXMVECTOR | path
 | ) |  |

Definition at line 113 of file Collision.cpp.

{
    const size_t contacts = m_collisions.size();
    for (size_t i = 0; i < contacts; ++i)
    {
        Contact& c = m_collisions[i];

        if (!c.CalculateContact(newPosition, radius, path))
        {
            c.Invalidate();
        }
    }

    MergeSharedEdgeCoplanarContacts(newPosition, radius, path);
}

Member Data Documentation

std::vector<Contact> Collision::m_collisions

Definition at line 70 of file Collision.h.

std::vector<Triangle> Collision::m_floorTriList

Definition at line 69 of file Collision.h.

std::vector<Triangle> Collision::m_groundTriList

Definition at line 67 of file Collision.h.

BOOL Collision::m_intersectsGround [private]

Definition at line 64 of file Collision.h.

std::vector<Triangle> Collision::m_wallTriList

Definition at line 68 of file Collision.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/Collision.h
  • DirectX marble maze game/C++/Collision.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CollisionInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

CollisionInfo Struct Reference

#include "Physics.h"

List of all members.

Public Attributes

BOOL | elasticCollision
BOOL | isRollingOnFloor
float | maxCollisionSpeed
float | maxRollingSpeed

Detailed Description

Definition at line 24 of file Physics.h.

Member Data Documentation

BOOL CollisionInfo::elasticCollision

Definition at line 27 of file Physics.h.

BOOL CollisionInfo::isRollingOnFloor

Definition at line 26 of file Physics.h.

float CollisionInfo::maxCollisionSpeed

Definition at line 29 of file Physics.h.

float CollisionInfo::maxRollingSpeed

Definition at line 28 of file Physics.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/Physics.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ComAutoRelease Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

ComAutoRelease Class Reference

#include "LinkList.h"

List of all members.

Public Member Functions

void | operator() (IUnknown *p)
void | operator() (IUnknown *p)
void | operator() (IUnknown *p)

Detailed Description

Definition at line 391 of file LinkList.h.

Member Function Documentation

void ComAutoRelease::operator() ( IUnknown * p ) [inline]

Definition at line 394 of file LinkList.h.

    {
        if (p)
        {
            p->Release();
        }
    }

void ComAutoRelease::operator() ( IUnknown * p ) [inline]

Definition at line 394 of file LinkList.h.

    {
        if (p)
        {
            p->Release();
        }
    }

void ComAutoRelease::operator() ( IUnknown * p ) [inline]

Definition at line 394 of file LinkList.h.

    {
        if (p)
        {
            p->Release();
        }
    }

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/LinkList.h
  • Media extensions/C++/MediaExtensions/Common/LinkList.h
  • Real-time communication/C++/MediaExtensions/Common/LinkList.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ComBase< InterfaceChain > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes | Private Member Functions

ComBase< InterfaceChain > Class Template Reference

#include "pch.h"

List of all members.

Public Member Functions

ComBase ()
virtual | ~ComBase ()
IFACEMETHOD_ (ULONG, Release)()
IFACEMETHOD_ (ULONG, AddRef)()
IFACEMETHOD() | QueryInterface (IID const &iid, OUT void **ppObject)

Protected Attributes

ULONG | refValue_

Private Member Functions

ComBase (const ComBase &b)
ComBase & | operator= (ComBase const &)

Detailed Description

template<typename InterfaceChain>
class ComBase< InterfaceChain >

Definition at line 95 of file pch.h.

Constructor & Destructor Documentation

template<typename InterfaceChain>
ComBase< InterfaceChain >::ComBase ( ) [inline, explicit]

Definition at line 98 of file pch.h.

    :   refValue_(0)
    { }

template<typename InterfaceChain>
virtual ComBase< InterfaceChain >::~ComBase ( ) [inline, virtual]

Definition at line 128 of file pch.h.

    { }

template<typename InterfaceChain>
ComBase< InterfaceChain >::ComBase ( const ComBase< InterfaceChain > & b ) [private]

Member Function Documentation

template<typename InterfaceChain>
ComBase< InterfaceChain >::IFACEMETHOD_ | ( | ULONG | ,
 |  | AddRef |  |
 | ) |  |  | [inline]

Definition at line 114 of file pch.h.

    {
        return InterlockedIncrement(&refValue_);
    }

template<typename InterfaceChain>
ComBase< InterfaceChain >::IFACEMETHOD_ | ( | ULONG | ,
 |  | Release |  |
 | ) |  |  | [inline]

Definition at line 119 of file pch.h.

    {
        ULONG newCount = InterlockedDecrement(&refValue_);
        if (newCount == 0)
            delete this;

        return newCount;
    }

template<typename InterfaceChain>
ComBase& ComBase< InterfaceChain >::operator= ( ComBase< InterfaceChain > const & ) [private]
template<typename InterfaceChain>
IFACEMETHOD() ComBase< InterfaceChain >::QueryInterface | ( | IID const & | iid,
 |  | OUT void ** | ppObject |
 | ) |  |  | [inline]

Definition at line 103 of file pch.h.

    {
        *ppObject = nullptr;
        InterfaceChain::QueryInterfaceInternal(iid, ppObject);
        if (*ppObject == nullptr)
            return E_NOINTERFACE;

        AddRef();
        return S_OK;
    }

Member Data Documentation

template<typename InterfaceChain>
ULONG ComBase< InterfaceChain >::refValue_ [protected]

Definition at line 132 of file pch.h.

The documentation for this class was generated from the following file:
  • DirectWrite vertical text/C++/pch.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CommandListRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Static Private Member Functions | Private Attributes

CommandListRenderer Class Reference

#include "CommandListSample.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: CommandListRenderer()

Private Member Functions

void | DrawPattern ()
void | HandlePointerDoubleTapped (Windows::Foundation::Point position)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnManipulationUpdated (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerWheelChanged (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnTapped (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::TappedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | Update (float timeTotal)

Static Private Member Functions

static float | Clamp (float value, float low, float high)
static float | LinearInterpolate (float start, float end, float weight)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blueBrush
Microsoft::WRL::ComPtr
< ID2D1CommandList > 		m_commandList
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
Microsoft::WRL::ComPtr
< ID2D1ImageBrush > 		m_imageBrush
BOOL | m_recenter
D2D1_POINT_2F | m_recenterStartPosition
FLOAT | m_recenterStartTime
FLOAT | m_recenterStartZoom
SampleOverlay m_sampleOverlay
Windows::Foundation::Point | m_viewPosition
bool | m_windowClosed
bool | m_windowVisible
FLOAT | m_zoom

Detailed Description

Definition at line 13 of file CommandListSample.h.

Member Function Documentation

static float CommandListRenderer::Clamp | ( | float | value,
 |  | float | low,
 |  | float | high |
 | ) |  |  | [inline, static, private]

Definition at line 103 of file CommandListSample.h.

    {
        return (value < low) ? low : (value > high) ? high : value;
    }

void CommandListRenderer::CreateDeviceResources ( ) [override, virtual]

Definition at line 43 of file CommandListSample.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D command list and image brush sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::DarkBlue),
            &m_blueBrush
            )
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateCommandList(&m_commandList)
        );

    m_d2dContext->SetTarget(m_commandList.Get());
    m_d2dContext->BeginDraw();
    DrawPattern();

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    DX::ThrowIfFailed(
        m_commandList->Close()
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateImageBrush(
            m_commandList.Get(),
            D2D1::ImageBrushProperties(
                D2D1::RectF(198, 298, 370, 470),
                D2D1_EXTEND_MODE_WRAP,
                D2D1_EXTEND_MODE_WRAP,
                D2D1_INTERPOLATION_MODE_LINEAR
                ),
            &m_imageBrush
            )
        );
}

void CommandListRenderer::DrawPattern ( ) [private]

Definition at line 126 of file CommandListSample.cpp.

{
    Microsoft::WRL::ComPtr<ID2D1LinearGradientBrush>        linearGradientBrush;
    Microsoft::WRL::ComPtr<ID2D1GradientStopCollection>     gradientStopCollection;
    D2D1_GRADIENT_STOP gradientStops[4];
    gradientStops[0].color = D2D1::ColorF(D2D1::ColorF::Aqua, 0.7f);
    gradientStops[0].position = 0.0f;
    gradientStops[1].color = D2D1::ColorF(D2D1::ColorF::DarkMagenta, 0.5f);
    gradientStops[1].position = 0.3f;
    gradientStops[2].color = D2D1::ColorF(D2D1::ColorF::Olive, 0.5f);
    gradientStops[2].position = 0.6f;
    gradientStops[3].color = D2D1::ColorF(D2D1::ColorF::Aqua, 0.7f);
    gradientStops[3].position = 1.0f;

    DX::ThrowIfFailed(
        m_d2dContext->CreateGradientStopCollection(
            gradientStops,
            ARRAYSIZE(gradientStops),
            &gradientStopCollection
            )
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateLinearGradientBrush(
            D2D1::LinearGradientBrushProperties(
                D2D1::Point2F(250, 350),
                D2D1::Point2F(275, 375)
                ),
            gradientStopCollection.Get(),
            &linearGradientBrush
            )
        );

    m_d2dContext->FillEllipse(
        D2D1::Ellipse(
            D2D1::Point2F(287.5, 387.5),
            75.0f,
            75.0f
            ),
        m_blueBrush.Get()
        );

    m_d2dContext->FillEllipse(
        D2D1::Ellipse(
            D2D1::Point2F(262.5f, 362.5f),
            12.5f,
            12.5f
            ),
        linearGradientBrush.Get()
        );

    linearGradientBrush->SetTransform(
        D2D1::Matrix3x2F::Translation(D2D1::SizeF(50, 50))
        );

    m_d2dContext->FillEllipse(
        D2D1::Ellipse(
            D2D1::Point2F(312.5f, 412.5f),
            12.5f,
            12.5f
            ),
        linearGradientBrush.Get()
        );

    linearGradientBrush->SetTransform(
        D2D1::Matrix3x2F::Translation(D2D1::SizeF(50, 0))
        );

    m_d2dContext->FillEllipse(
        D2D1::Ellipse(
            D2D1::Point2F(312.5f, 362.5f),
            12.5f,
            12.5f
            ),
        linearGradientBrush.Get()
        );

    linearGradientBrush->SetTransform(
        D2D1::Matrix3x2F::Translation(D2D1::SizeF(0, 50))
        );

    m_d2dContext->FillEllipse(
        D2D1::Ellipse(
            D2D1::Point2F(262.5f, 412.5f),
            12.5f,
            12.5f
            ),
        linearGradientBrush.Get()
        );
}

void CommandListRenderer::HandlePointerDoubleTapped ( Windows::Foundation::Point position ) [private]
virtual void CommandListRenderer::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
static float CommandListRenderer::LinearInterpolate | ( | float | start,
 |  | float | end,
 |  | float | weight |
 | ) |  |  | [inline, static, private]

Definition at line 108 of file CommandListSample.h.

    {
        return start * (1.0f - weight) + end * weight;
    }

void CommandListRenderer::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 327 of file CommandListSample.cpp.

{
    // Retrieve stored variables from the LocalSettings collection if the app was terminated after suspension.
    IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;

    if (settingsValues->HasKey("m_zoom"))
    {
        m_zoom = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_zoom"))->GetSingle();
    }

    if (settingsValues->HasKey("m_viewPosition"))
    {
        m_viewPosition = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_viewPosition"))->GetPoint();
    }
}

void CommandListRenderer::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 387 of file CommandListSample.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
}

void CommandListRenderer::OnManipulationUpdated | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnPointerWheelChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 426 of file CommandListSample.cpp.

{
}

void CommandListRenderer::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnTapped | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::TappedEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void CommandListRenderer::Render ( ) [override, virtual]

Definition at line 98 of file CommandListSample.cpp.

{
    D2D1_SIZE_F size = m_d2dContext->GetSize();

    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    Matrix3x2F translation = Matrix3x2F::Translation(m_viewPosition.X / m_zoom, m_viewPosition.Y / m_zoom);
    Matrix3x2F zoom = Matrix3x2F::Scale(m_zoom, m_zoom);

    m_imageBrush->SetTransform(translation * zoom);

    m_d2dContext->FillRectangle(
        D2D1::RectF(0, 0, size.width, size.height),
        m_imageBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void CommandListRenderer::Run ( ) [virtual]

Definition at line 345 of file CommandListSample.cpp.

{
    BasicTimer^ timer = ref new BasicTimer();

    while (!m_windowClosed)
    {
        if (m_windowVisible)
        {
            timer->Update();
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
            Update(timer->Total);
            Render();
            Present(); // This call is synchronized to the display frame rate.
        }
        else
        {
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
        }
    }
}

virtual void CommandListRenderer::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void CommandListRenderer::Uninitialize ( ) [virtual]

Definition at line 366 of file CommandListSample.cpp.

{
}

void CommandListRenderer::Update ( float timeTotal ) [private]

Definition at line 217 of file CommandListSample.cpp.

{
    // A douple tap will set this variable to true, meaning we should start recentering.
    if (m_recenter)
    {
        // If the start time of the animation isn't known yet, set it to the current time.
        if (m_recenterStartTime == 0.0f)
        {
            m_recenterStartTime = timeTotal;
        }

        // Determine how far along in the animation we should be (we want the animation to take a
        // quarter of a second)
        float delta = (timeTotal - m_recenterStartTime) * 4.0f;

        // If we're at the end of the animation, ensure we've completely reset the position and zoom,
        // and clear the animation flag
        if (delta > 1.0f)
        {
            m_viewPosition.X = 0;
            m_viewPosition.Y = 0;
            m_zoom = 1.0f;
            m_recenterStartTime = 0.0f;
            m_recenter = false;
        }

        // Otherwise, linearly interpolate between the starting position and the reset position.
        else
        {
            m_viewPosition.X = LinearInterpolate(m_recenterStartPosition.x, 0, delta);
            m_viewPosition.Y = LinearInterpolate(m_recenterStartPosition.y, 0, delta);
            m_zoom = LinearInterpolate(m_recenterStartZoom, 1.0f, delta);
        }
    }
}

Member Data Documentation

internal CommandListRenderer::__pad0__

Definition at line 16 of file CommandListSample.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> CommandListRenderer::m_blueBrush [private]

Definition at line 116 of file CommandListSample.h.

Microsoft::WRL::ComPtr<ID2D1CommandList> CommandListRenderer::m_commandList [private]

Definition at line 115 of file CommandListSample.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> CommandListRenderer::m_gestureRecognizer [private]

Definition at line 124 of file CommandListSample.h.

Microsoft::WRL::ComPtr<ID2D1ImageBrush> CommandListRenderer::m_imageBrush [private]

Definition at line 114 of file CommandListSample.h.

BOOL CommandListRenderer::m_recenter [private]

Definition at line 120 of file CommandListSample.h.

D2D1_POINT_2F CommandListRenderer::m_recenterStartPosition [private]

Definition at line 121 of file CommandListSample.h.

FLOAT CommandListRenderer::m_recenterStartTime [private]

Definition at line 123 of file CommandListSample.h.

FLOAT CommandListRenderer::m_recenterStartZoom [private]

Definition at line 122 of file CommandListSample.h.

SampleOverlay CommandListRenderer::m_sampleOverlay [private]

Definition at line 113 of file CommandListSample.h.

Windows::Foundation::Point CommandListRenderer::m_viewPosition [private]

Definition at line 118 of file CommandListSample.h.

bool CommandListRenderer::m_windowClosed [private]

Definition at line 125 of file CommandListSample.h.

bool CommandListRenderer::m_windowVisible [private]

Definition at line 126 of file CommandListSample.h.

FLOAT CommandListRenderer::m_zoom [private]

Definition at line 119 of file CommandListSample.h.

The documentation for this class was generated from the following files:
  • Direct2D command list/C++/CommandListSample.h
  • Direct2D command list/C++/CommandListSample.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CompositeModes Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Static Private Member Functions | Private Attributes

CompositeModes Class Reference

#include "CompositeModes.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: CompositeModes()

Private Member Functions

~CompositeModes ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnManipulationUpdated (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | UpdateAlpha (_In_ float verticalPositionDelta)

Static Private Member Functions

static float | Clamp (float v, float low, float high)

Private Attributes

float | m_alpha
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_appleAlphaEffect
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_appleBitmap
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_appleEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_bananaAlphaEffect
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_bananaBitmap
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_bananaEffect
D2D1_SIZE_U | m_bitmapPixelSize
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_blendEffect
Platform::Array< Platform::String^> | m_blendModeNames
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_blendModeTextLayout
IDWriteTextLayout ** | m_captionLayouts
D2D1_SIZE_F | m_cellSize
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_compositeEffect
Platform::Array< Platform::String^> | m_compositeModeNames
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_compositeModeTextLayout
D2D1_SIZE_F | m_contextSize
bool | m_drawEnabled
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_headingTextFormat
float | m_horizontalOffset
D2D1_SIZE_F | m_imageSize
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_scaleEffect
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_snappedViewFormat
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush

Detailed Description

Definition at line 13 of file CompositeModes.h.

Constructor & Destructor Documentation

CompositeModes::~CompositeModes ( ) [private]

Definition at line 55 of file CompositeModes.cpp.

{
    if (m_captionLayouts != nullptr)
    {
        delete[] m_captionLayouts;
    }
}

Member Function Documentation

static float CompositeModes::Clamp | ( | float | v,
 |  | float | low,
 |  | float | high |
 | ) |  |  | [inline, static, private]

Definition at line 84 of file CompositeModes.h.

    {
        return (v < low) ? low : (v > high) ? high : v;
    }

void CompositeModes::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 63 of file CompositeModes.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            HeadingHeight,
            L"en-US", // locale
            &m_headingTextFormat
            )
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            LabelHeight,
            L"en-US", // locale
            &m_textFormat
            )
        );

    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            20.0f,
            L"en-us", // locale
            &m_snappedViewFormat
            )
        );

    DX::ThrowIfFailed(
        m_snappedViewFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    DX::ThrowIfFailed(
        m_snappedViewFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    m_blendModeNames = ref new Platform::Array<Platform::String^>(BlendModesLength);
    m_blendModeNames[0]  = "Multiply";
    m_blendModeNames[1]  = "Screen";
    m_blendModeNames[2]  = "Darken";
    m_blendModeNames[3]  = "Lighten";
    m_blendModeNames[4]  = "Dissolve";
    m_blendModeNames[5]  = "Color Burn";
    m_blendModeNames[6]  = "Linear Burn";
    m_blendModeNames[7]  = "Darker Color";
    m_blendModeNames[8]  = "Lighter Color";
    m_blendModeNames[9]  = "Color Dodge";
    m_blendModeNames[10] = "Linear Dodge";
    m_blendModeNames[11] = "Overlay";
    m_blendModeNames[12] = "Soft Light";
    m_blendModeNames[13] = "Hard Light";
    m_blendModeNames[14] = "Vivid Light";
    m_blendModeNames[15] = "Linear Light";
    m_blendModeNames[16] = "Pin Light";
    m_blendModeNames[17] = "Hard Mix";
    m_blendModeNames[18] = "Difference";
    m_blendModeNames[19] = "Exclusion";
    m_blendModeNames[20] = "Hue";
    m_blendModeNames[21] = "Saturation";
    m_blendModeNames[22] = "Color";
    m_blendModeNames[23] = "Luminosity";
    m_blendModeNames[24] = "Subtract";
    m_blendModeNames[25] = "Division";

    m_compositeModeNames = ref new Platform::Array<Platform::String^>(CompositeModesLength);
    m_compositeModeNames[0]  = "Source Over";
    m_compositeModeNames[1]  = "Destination Over";
    m_compositeModeNames[2]  = "Source In";
    m_compositeModeNames[3]  = "Destination In";
    m_compositeModeNames[4]  = "Source Out";
    m_compositeModeNames[5]  = "Destination Out";
    m_compositeModeNames[6]  = "Source Atop";
    m_compositeModeNames[7]  = "Destination Atop";
    m_compositeModeNames[8]  = "Xor";
    m_compositeModeNames[9]  = "Plus";
    m_compositeModeNames[10] = "Source Copy";
    // There are two extra modes we are not covering in this sample: bounded source copy
    // and mask invert. Bounded source copy looks just like source copy but limits the
    // copy to the bounds of the source rather than the union of the source and destination.
    // Mask invert is meant for caret drawing and appears much like an XOR.

    // Create the apple bitmap source.
    ComPtr<IWICBitmapDecoder> decoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"apple.png",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &decoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> frame;
    DX::ThrowIfFailed(
        decoder->GetFrame(0, &frame)
        );

    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&m_appleBitmap)
        );

    DX::ThrowIfFailed(
        m_appleBitmap->Initialize(
            frame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0f,
            WICBitmapPaletteTypeCustom  // Premultiplied BGRA has no paletting, so this is ignored.
            )
        );

    // Create the banana bitmap source.
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"banana.png",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &decoder
            )
        );

    DX::ThrowIfFailed(
        decoder->GetFrame(0, &frame)
        );

    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&m_bananaBitmap)
        );

    DX::ThrowIfFailed(
        m_bananaBitmap->Initialize(
            frame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0f,
            WICBitmapPaletteTypeCustom  // Premultiplied BGRA has no paletting, so this is ignored.
            )
        );

    // Store the image size in pixels (the apple and banana images are assumed to be the same size).
    // This remains constant regardless of the app's DPI.
    UINT width;
    UINT height;
    DX::ThrowIfFailed(
        m_bananaBitmap->GetSize(&width, &height)
        );

    m_bitmapPixelSize = D2D1::SizeU(width, height);
}

void CompositeModes::CreateDeviceResources ( ) [override, virtual]

Definition at line 236 of file CompositeModes.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D composite and blend effects sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_whiteBrush
            )
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_appleEffect)
        );

    DX::ThrowIfFailed(
        m_appleEffect->SetValue(
            D2D1_BITMAPSOURCE_PROP_INTERPOLATION_MODE,
            D2D1_BITMAPSOURCE_INTERPOLATION_MODE_CUBIC
            )
        );

    // The property system expects TRUE and FALSE rather than true or false to ensure that
    // the size of the value is consistent regardless of architecture.
    DX::ThrowIfFailed(
        m_appleEffect->SetValue(D2D1_PROPERTY_CACHED, TRUE)
        );

    DX::ThrowIfFailed(
        m_appleEffect->SetValue(D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE, m_appleBitmap.Get())
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_bananaEffect)
        );

    DX::ThrowIfFailed(
        m_bananaEffect->SetValue(
            D2D1_BITMAPSOURCE_PROP_INTERPOLATION_MODE,
            D2D1_BITMAPSOURCE_INTERPOLATION_MODE_CUBIC
            )
        );

    DX::ThrowIfFailed(
        m_bananaEffect->SetValue(D2D1_PROPERTY_CACHED, TRUE)
        );

    DX::ThrowIfFailed(
        m_bananaEffect->SetValue(D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE, m_bananaBitmap.Get())
        );

    // Create and initialize the composite and blend effects.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1Composite, &m_compositeEffect)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1Blend, &m_blendEffect)
        );

    // Create the effects that will set the alpha of each bitmap.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1ColorMatrix, &m_appleAlphaEffect)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1ColorMatrix, &m_bananaAlphaEffect)
        );

    // Wire up the graph. Note that the color matrix effects are used as the inputs for
    // both the blend and composite effects, so all we have to do is draw one or the other.
    m_appleAlphaEffect->SetInputEffect(0, m_appleEffect.Get());
    m_bananaAlphaEffect->SetInputEffect(0, m_bananaEffect.Get());
    m_blendEffect->SetInputEffect(0, m_appleAlphaEffect.Get());
    m_blendEffect->SetInputEffect(1, m_bananaAlphaEffect.Get());
    m_compositeEffect->SetInputEffect(0, m_appleAlphaEffect.Get());
    m_compositeEffect->SetInputEffect(1, m_bananaAlphaEffect.Get());
}

void CompositeModes::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 325 of file CompositeModes.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    m_contextSize = m_d2dContext->GetSize();

    // m_imageSize is in DIPs and changes depending on the app DPI.
    // This app ignores the source bitmap's DPI and assumes it is 96.
    m_imageSize = D2D1::SizeF(
        static_cast<float>(m_bitmapPixelSize.width) * 96.0f / m_dpi,
        static_cast<float>(m_bitmapPixelSize.height) * 96.0f / m_dpi
        );

    // The sample will render its content into a square area in both landscape and
    // portrait orientations. Make the square as large as the smallest dimension available.
    float minDimension = min(
        m_contextSize.width,
        m_contextSize.height - m_sampleOverlay->GetTitleHeightInDips()
        );

    // m_horizontalOffset is used for centering the content to be rendered
    m_horizontalOffset = (m_contextSize.width - minDimension) / 2.0f;

    // We want to divide the screen into cells in which each mode demonstration will sit.
    // m_cellSize stores the dimensions of a single cell. The width and height dimensions
    // are adjusted by the space taken up by the sample overlay, heading text, and gutters.
    m_cellSize = D2D1::SizeF(
        (minDimension - 4 * HeadingHeight - GutterSize) / GridColumns,
        (minDimension - GutterSize) / GridRows
        );

    float imageScaleSize = m_cellSize.width / m_imageSize.width;
    if (m_cellSize.height < m_cellSize.width)
    {
        imageScaleSize = m_cellSize.height / m_imageSize.height;
    }

    DX::ThrowIfFailed(
        m_appleEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, D2D1::Point2F(imageScaleSize, imageScaleSize))
        );

    DX::ThrowIfFailed(
        m_bananaEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, D2D1::Point2F(imageScaleSize, imageScaleSize))
        );

    if (m_captionLayouts != nullptr)
    {
        delete[] m_captionLayouts;
    }

    m_captionLayouts = new IDWriteTextLayout*[CompositeModesLength + BlendModesLength];
    for (int i = 0; i < CompositeModesLength; i++)
    {
        DX::ThrowIfFailed(
            m_dwriteFactory->CreateTextLayout(
                m_compositeModeNames[i]->Data(),
                m_compositeModeNames[i]->Length(),
                m_textFormat.Get(),
                m_cellSize.width,
                m_cellSize.height,
                &m_captionLayouts[i]
                )
            );
    }

    for (int i = CompositeModesLength; i < CompositeModesLength + BlendModesLength; i++)
    {
        DX::ThrowIfFailed(
            m_dwriteFactory->CreateTextLayout(
                m_blendModeNames[i - CompositeModesLength]->Data(),
                m_blendModeNames[i - CompositeModesLength]->Length(),
                m_textFormat.Get(),
                m_cellSize.width,
                m_cellSize.height,
                &m_captionLayouts[i]
                )
            );
    }

    Platform::String^ compositeModes = "Composite modes";
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            compositeModes->Data(),
            compositeModes->Length(),
            m_headingTextFormat.Get(),
            m_contextSize.height,
            m_contextSize.width,
            &m_compositeModeTextLayout
            )
        );

    Platform::String^ blendModes = "Blend modes";
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            blendModes->Data(),
            blendModes->Length(),
            m_headingTextFormat.Get(),
            m_contextSize.height,
            m_contextSize.width,
            &m_blendModeTextLayout
            )
        );
}

virtual void CompositeModes::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void CompositeModes::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 639 of file CompositeModes.cpp.

{
    IPropertySet^ appSettings = ApplicationData::Current->LocalSettings->Values;

    if (appSettings->HasKey("alpha"))
    {
        m_alpha = safe_cast<IPropertyValue^>(appSettings->Lookup("alpha"))->GetSingle();
    }

    // After the alpha value is loaded, invoke UpdateAlpha to update the properties on the effects.
    UpdateAlpha(0.0f);
}

void CompositeModes::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void CompositeModes::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 690 of file CompositeModes.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void CompositeModes::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 681 of file CompositeModes.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void CompositeModes::OnManipulationUpdated | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ | args |
 | ) |  |  | [private]
void CompositeModes::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void CompositeModes::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void CompositeModes::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void CompositeModes::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 725 of file CompositeModes.cpp.

{
}

void CompositeModes::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void CompositeModes::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void CompositeModes::Render ( ) [override, virtual]

Definition at line 429 of file CompositeModes.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    if (m_drawEnabled)
    {
        // Draw a virtual 2x6 grid of the composite mode examples. There is room for 12 examples but only
        // 11 composite modes are shown, so we ignore the additional cells.
        for (int i = 0; i < GridCompositeColumns; i++)
        {
            for (int j = 0; j < GridCompositeRows; j++)
            {
                if (j * GridCompositeColumns + i <= CompositeModesLength - 1)
                {
                    // The grid must be offset to account for the space taken up by the sample overlay and the
                    // "Composite Modes" heading text.
                    float left = m_cellSize.width * i + 2 * HeadingHeight + m_horizontalOffset;
                    float top = m_cellSize.height * j + m_sampleOverlay->GetTitleHeightInDips() + LabelHeight;

                    // Note we're setting a value as an integer rather than using the enumeration. While
                    // we recommend using the actual enumeration values for properties, they are simply
                    // integers and automated systems can iterate through them like integers.
                    DX::ThrowIfFailed(
                        m_compositeEffect->SetValue(D2D1_COMPOSITE_PROP_MODE, j * GridCompositeColumns + i)
                        );

                    // Draw the image in the top-left corner of the cell.
                    m_d2dContext->DrawImage(
                        m_compositeEffect.Get(),
                        D2D1::Point2F(left, top),
                        D2D1::RectF(0.0f, 0.0f, m_cellSize.width, m_cellSize.height)
                        );
                }
            }
        }

        // Now we draw a the grid of the blend mode examples.
        for (int i = 0; i < GridBlendColumns; i++)
        {
            for (int j = 0; j < GridBlendRows; j++)
            {
                // Again, there is room for 30 examples but only 26 blend modes are shown, so
                // we ignore the additional cells.
                if (j * GridBlendColumns + i <= BlendModesLength - 1)
                {
                    // The grid must be offset to account for the space taken up by the sample overlay and the
                    // composite modes grid, as well as the "Blend Modes" heading text.
                    float left = m_cellSize.width * (i + GridCompositeColumns) + 4 * HeadingHeight + m_horizontalOffset;
                    float top = m_cellSize.height * j + m_sampleOverlay->GetTitleHeightInDips() + LabelHeight;
                    DX::ThrowIfFailed(
                        m_blendEffect->SetValue(D2D1_BLEND_PROP_MODE, j * GridBlendColumns + i)
                        );

                    m_d2dContext->DrawImage(
                        m_blendEffect.Get(),
                        D2D1::Point2F(left, top),
                        D2D1::RectF(0.0f, 0.0f, m_cellSize.width, m_cellSize.height)
                        );
                }
            }
        }

        // As a performance optimization, we group all of the Direct2D Effects drawing operations
        // together, and draw the text afterwards.
        for (int i = 0; i < GridCompositeColumns; i++)
        {
            for (int j = 0; j < GridCompositeRows; j++)
            {
                if (j * GridCompositeColumns + i <= CompositeModesLength - 1)
                {
                    float left = m_cellSize.width * i + 2 * HeadingHeight + m_horizontalOffset;
                    float top = m_cellSize.height * j + m_sampleOverlay->GetTitleHeightInDips();

                    m_d2dContext->DrawTextLayout(
                        D2D1::Point2F(left, top),
                        m_captionLayouts[j * GridCompositeColumns + i],
                        m_whiteBrush.Get()
                        );
                }
            }
        }

        for (int i = 0; i < GridBlendColumns; i++)
        {
            for (int j = 0; j < GridBlendRows; j++)
            {
                if (j * GridBlendColumns + i <= BlendModesLength - 1)
                {
                    float left = m_cellSize.width * (i + GridCompositeColumns) + 4 * HeadingHeight + m_horizontalOffset;
                    float top = m_cellSize.height * j + m_sampleOverlay->GetTitleHeightInDips();

                    m_d2dContext->DrawTextLayout(
                        D2D1::Point2F(left, top),
                        m_captionLayouts[j * GridBlendColumns + i + CompositeModesLength],
                        m_whiteBrush.Get()
                        );
                }
            }
        }

        // Draw the "Blend Modes" and "Composite Modes" labels vertically.
        m_d2dContext->SetTransform(
            D2D1::Matrix3x2F::Rotation(-90.0f) *
            D2D1::Matrix3x2F::Translation(0, m_cellSize.height * GridRows / 2.0f + m_sampleOverlay->GetTitleHeightInDips())
            );

        m_d2dContext->DrawTextLayout(
            D2D1::Point2F(0.0f, 0.5f * HeadingHeight + m_horizontalOffset),
            m_compositeModeTextLayout.Get(),
            m_whiteBrush.Get()
            );

        m_d2dContext->DrawTextLayout(
            D2D1::Point2F(0.0f, m_cellSize.width * (GridCompositeColumns) + 2.5f * HeadingHeight + m_horizontalOffset),
            m_blendModeTextLayout.Get(),
            m_whiteBrush.Get()
            );
    }
    else // The blend/composite mode images are not drawn in the snapped-state.
    {
        Platform::String^ message = "This sample does not support snapped view.";

        m_d2dContext->DrawText(
            message->Data(),
            message->Length(),
            m_snappedViewFormat.Get(),
            D2D1::RectF(0, 0, m_contextSize.width, m_contextSize.height),
            m_whiteBrush.Get()
            );
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void CompositeModes::Run ( ) [virtual]

Definition at line 654 of file CompositeModes.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void CompositeModes::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void CompositeModes::Uninitialize ( ) [virtual]

Definition at line 662 of file CompositeModes.cpp.

{
}

void CompositeModes::UpdateAlpha ( _In_ float verticalPositionDelta ) [private]

Definition at line 764 of file CompositeModes.cpp.

{
    // Divide position data by screen height so that one swipe from top
    // to bottom of the screen changes alpha value exactly by '1'.
    m_alpha -= verticalPositionDelta / m_contextSize.height;

    m_alpha = Clamp(m_alpha, 0.0f, 1.0f);

    D2D1_MATRIX_5X4_F alphaMatrix = {0};
    alphaMatrix.m[0][0] = 1;
    alphaMatrix.m[1][1] = 1;
    alphaMatrix.m[2][2] = 1;
    alphaMatrix.m[3][3] = m_alpha;

    DX::ThrowIfFailed(
        m_appleAlphaEffect->SetValue(D2D1_COLORMATRIX_PROP_COLOR_MATRIX, alphaMatrix)
        );

    DX::ThrowIfFailed(
        m_bananaAlphaEffect->SetValue(D2D1_COLORMATRIX_PROP_COLOR_MATRIX, alphaMatrix)
        );

    Render();
    Present();
}

Member Data Documentation

internal CompositeModes::__pad0__

Definition at line 16 of file CompositeModes.h.

float CompositeModes::m_alpha [private]

Definition at line 117 of file CompositeModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> CompositeModes::m_appleAlphaEffect [private]

Definition at line 108 of file CompositeModes.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> CompositeModes::m_appleBitmap [private]

Definition at line 95 of file CompositeModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> CompositeModes::m_appleEffect [private]

Definition at line 103 of file CompositeModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> CompositeModes::m_bananaAlphaEffect [private]

Definition at line 109 of file CompositeModes.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> CompositeModes::m_bananaBitmap [private]

Definition at line 96 of file CompositeModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> CompositeModes::m_bananaEffect [private]

Definition at line 104 of file CompositeModes.h.

D2D1_SIZE_U CompositeModes::m_bitmapPixelSize [private]

Definition at line 113 of file CompositeModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> CompositeModes::m_blendEffect [private]

Definition at line 106 of file CompositeModes.h.

Platform::Array<Platform::String^> CompositeModes::m_blendModeNames [private]

Definition at line 112 of file CompositeModes.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> CompositeModes::m_blendModeTextLayout [private]

Definition at line 102 of file CompositeModes.h.

IDWriteTextLayout** CompositeModes::m_captionLayouts [private]

Definition at line 121 of file CompositeModes.h.

D2D1_SIZE_F CompositeModes::m_cellSize [private]

Definition at line 116 of file CompositeModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> CompositeModes::m_compositeEffect [private]

Definition at line 105 of file CompositeModes.h.

Platform::Array<Platform::String^> CompositeModes::m_compositeModeNames [private]

Definition at line 111 of file CompositeModes.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> CompositeModes::m_compositeModeTextLayout [private]

Definition at line 101 of file CompositeModes.h.

D2D1_SIZE_F CompositeModes::m_contextSize [private]

Definition at line 115 of file CompositeModes.h.

bool CompositeModes::m_drawEnabled [private]

Definition at line 119 of file CompositeModes.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> CompositeModes::m_gestureRecognizer [private]

Definition at line 93 of file CompositeModes.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> CompositeModes::m_headingTextFormat [private]

Definition at line 98 of file CompositeModes.h.

float CompositeModes::m_horizontalOffset [private]

Definition at line 118 of file CompositeModes.h.

D2D1_SIZE_F CompositeModes::m_imageSize [private]

Definition at line 114 of file CompositeModes.h.

SampleOverlay CompositeModes::m_sampleOverlay [private]

Definition at line 91 of file CompositeModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> CompositeModes::m_scaleEffect [private]

Definition at line 107 of file CompositeModes.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> CompositeModes::m_snappedViewFormat [private]

Definition at line 100 of file CompositeModes.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> CompositeModes::m_textFormat [private]

Definition at line 99 of file CompositeModes.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> CompositeModes::m_whiteBrush [private]

Definition at line 97 of file CompositeModes.h.

The documentation for this class was generated from the following files:
  • Direct2D composite effect modes/C++/CompositeModes.h
  • Direct2D composite effect modes/C++/CompositeModes.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ComPtrList< T, NULLABLE > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions

ComPtrList< T, NULLABLE > Class Template Reference

#include "LinkList.h"

Inherits List< T * >, List< T * >, and List< T * >.

List of all members.

Public Types

typedef T * | Ptr
typedef T * | Ptr
typedef T * | Ptr

Public Member Functions

~ComPtrList ()
~ComPtrList ()
~ComPtrList ()
void | Clear ()
void | Clear ()
void | Clear ()

Protected Member Functions

HRESULT | GetItem (const Node *pNode, Ptr *ppItem)
HRESULT | GetItem (const Node *pNode, Ptr *ppItem)
HRESULT | GetItem (const Node *pNode, Ptr *ppItem)
HRESULT | InsertAfter (Ptr item, Node *pBefore)
HRESULT | InsertAfter (Ptr item, Node *pBefore)
HRESULT | InsertAfter (Ptr item, Node *pBefore)
HRESULT | RemoveItem (Node *pNode, Ptr *ppItem)
HRESULT | RemoveItem (Node *pNode, Ptr *ppItem)
HRESULT | RemoveItem (Node *pNode, Ptr *ppItem)

Detailed Description

template<class T, bool NULLABLE = FALSE>
class ComPtrList< T, NULLABLE >

Definition at line 429 of file LinkList.h.

Member Typedef Documentation

template<class T, bool NULLABLE = FALSE>
typedef T* ComPtrList< T, NULLABLE >::Ptr

Definition at line 433 of file LinkList.h.

template<class T, bool NULLABLE = FALSE>
typedef T* ComPtrList< T, NULLABLE >::Ptr

Definition at line 433 of file LinkList.h.

template<class T, bool NULLABLE = FALSE>
typedef T* ComPtrList< T, NULLABLE >::Ptr

Definition at line 433 of file LinkList.h.

Constructor & Destructor Documentation

template<class T, bool NULLABLE = FALSE>
ComPtrList< T, NULLABLE >::~ComPtrList ( ) [inline]

Definition at line 441 of file LinkList.h.

    {
        Clear();
    }

template<class T, bool NULLABLE = FALSE>
ComPtrList< T, NULLABLE >::~ComPtrList ( ) [inline]

Definition at line 441 of file LinkList.h.

    {
        Clear();
    }

template<class T, bool NULLABLE = FALSE>
ComPtrList< T, NULLABLE >::~ComPtrList ( ) [inline]

Definition at line 441 of file LinkList.h.

    {
        Clear();
    }

Member Function Documentation

template<class T, bool NULLABLE = FALSE>
void ComPtrList< T, NULLABLE >::Clear ( ) [inline, virtual]

Reimplemented from List< T * >.

Definition at line 435 of file LinkList.h.

    {
        ComAutoRelease car;
        List<Ptr>::Clear(car);
    }

template<class T, bool NULLABLE = FALSE>
void ComPtrList< T, NULLABLE >::Clear ( ) [inline, virtual]

Reimplemented from List< T * >.

Definition at line 435 of file LinkList.h.

    {
        ComAutoRelease car;
        List<Ptr>::Clear(car);
    }

template<class T, bool NULLABLE = FALSE>
void ComPtrList< T, NULLABLE >::Clear ( ) [inline, virtual]

Reimplemented from List< T * >.

Definition at line 435 of file LinkList.h.

    {
        ComAutoRelease car;
        List<Ptr>::Clear(car);
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::GetItem | ( | const Node * | pNode,
 |  | Ptr * | ppItem |
 | ) |  |  | [inline, protected]

Definition at line 468 of file LinkList.h.

    {
        Ptr pItem = nullptr;

        // The base class gives us the pointer without AddRef'ing it.
        // If we return the pointer to the caller, we must AddRef().
        HRESULT hr = List<Ptr>::GetItem(pNode, &pItem);
        if (SUCCEEDED(hr))
        {
            assert(pItem || NULLABLE);
            if (pItem)
            {
                *ppItem = pItem;
                (*ppItem)->AddRef();
            }
        }
        return hr;
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::GetItem | ( | const Node * | pNode,
 |  | Ptr * | ppItem |
 | ) |  |  | [inline, protected]

Definition at line 468 of file LinkList.h.

    {
        Ptr pItem = nullptr;

        // The base class gives us the pointer without AddRef'ing it.
        // If we return the pointer to the caller, we must AddRef().
        HRESULT hr = List<Ptr>::GetItem(pNode, &pItem);
        if (SUCCEEDED(hr))
        {
            assert(pItem || NULLABLE);
            if (pItem)
            {
                *ppItem = pItem;
                (*ppItem)->AddRef();
            }
        }
        return hr;
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::GetItem | ( | const Node * | pNode,
 |  | Ptr * | ppItem |
 | ) |  |  | [inline, protected]

Definition at line 468 of file LinkList.h.

    {
        Ptr pItem = nullptr;

        // The base class gives us the pointer without AddRef'ing it.
        // If we return the pointer to the caller, we must AddRef().
        HRESULT hr = List<Ptr>::GetItem(pNode, &pItem);
        if (SUCCEEDED(hr))
        {
            assert(pItem || NULLABLE);
            if (pItem)
            {
                *ppItem = pItem;
                (*ppItem)->AddRef();
            }
        }
        return hr;
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::InsertAfter | ( | Ptr | item,
 |  | Node * | pBefore |
 | ) |  |  | [inline, protected]

Definition at line 447 of file LinkList.h.

    {
        // Do not allow nullptr item pointers unless NULLABLE is true.
        if (item == nullptr && !NULLABLE)
        {
            return E_POINTER;
        }

        if (item)
        {
            item->AddRef();
        }

        HRESULT hr = List<Ptr>::InsertAfter(item, pBefore);
        if (FAILED(hr) && item != nullptr)
        {
            item->Release();
        }
        return hr;
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::InsertAfter | ( | Ptr | item,
 |  | Node * | pBefore |
 | ) |  |  | [inline, protected]

Definition at line 447 of file LinkList.h.

    {
        // Do not allow nullptr item pointers unless NULLABLE is true.
        if (item == nullptr && !NULLABLE)
        {
            return E_POINTER;
        }

        if (item)
        {
            item->AddRef();
        }

        HRESULT hr = List<Ptr>::InsertAfter(item, pBefore);
        if (FAILED(hr) && item != nullptr)
        {
            item->Release();
        }
        return hr;
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::InsertAfter | ( | Ptr | item,
 |  | Node * | pBefore |
 | ) |  |  | [inline, protected]

Definition at line 447 of file LinkList.h.

    {
        // Do not allow nullptr item pointers unless NULLABLE is true.
        if (item == nullptr && !NULLABLE)
        {
            return E_POINTER;
        }

        if (item)
        {
            item->AddRef();
        }

        HRESULT hr = List<Ptr>::InsertAfter(item, pBefore);
        if (FAILED(hr) && item != nullptr)
        {
            item->Release();
        }
        return hr;
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::RemoveItem | ( | Node * | pNode,
 |  | Ptr * | ppItem |
 | ) |  |  | [inline, protected]

Definition at line 487 of file LinkList.h.

    {
        // ppItem can be nullptr, but we need to get the
        // item so that we can release it.

        // If ppItem is not nullptr, we will AddRef it on the way out.

        Ptr pItem = nullptr;

        HRESULT hr = List<Ptr>::RemoveItem(pNode, &pItem);

        if (SUCCEEDED(hr))
        {
            assert(pItem || NULLABLE);
            if (ppItem && pItem)
            {
                *ppItem = pItem;
                (*ppItem)->AddRef();
            }

            if (pItem)
            {
                pItem->Release();
                pItem = nullptr;
            }
        }

        return hr;
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::RemoveItem | ( | Node * | pNode,
 |  | Ptr * | ppItem |
 | ) |  |  | [inline, protected]

Definition at line 487 of file LinkList.h.

    {
        // ppItem can be nullptr, but we need to get the
        // item so that we can release it.

        // If ppItem is not nullptr, we will AddRef it on the way out.

        Ptr pItem = nullptr;

        HRESULT hr = List<Ptr>::RemoveItem(pNode, &pItem);

        if (SUCCEEDED(hr))
        {
            assert(pItem || NULLABLE);
            if (ppItem && pItem)
            {
                *ppItem = pItem;
                (*ppItem)->AddRef();
            }

            if (pItem)
            {
                pItem->Release();
                pItem = nullptr;
            }
        }

        return hr;
    }

template<class T, bool NULLABLE = FALSE>
HRESULT ComPtrList< T, NULLABLE >::RemoveItem | ( | Node * | pNode,
 |  | Ptr * | ppItem |
 | ) |  |  | [inline, protected]

Definition at line 487 of file LinkList.h.

    {
        // ppItem can be nullptr, but we need to get the
        // item so that we can release it.

        // If ppItem is not nullptr, we will AddRef it on the way out.

        Ptr pItem = nullptr;

        HRESULT hr = List<Ptr>::RemoveItem(pNode, &pItem);

        if (SUCCEEDED(hr))
        {
            assert(pItem || NULLABLE);
            if (ppItem && pItem)
            {
                *ppItem = pItem;
                (*ppItem)->AddRef();
            }

            if (pItem)
            {
                pItem->Release();
                pItem = nullptr;
            }
        }

        return hr;
    }

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/LinkList.h
  • Media extensions/C++/MediaExtensions/Common/LinkList.h
  • Real-time communication/C++/MediaExtensions/Common/LinkList.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ComputeCB Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ComputeCB Struct Reference

#include "DirectXFractal.h"

List of all members.

Public Attributes

float2 deltaPerDtidX
float2 deltaPerDtidY
float2 originDtid00

Detailed Description

Definition at line 76 of file DirectXFractal.h.

Member Data Documentation

float2 ComputeCB::deltaPerDtidX

Definition at line 79 of file DirectXFractal.h.

float2 ComputeCB::deltaPerDtidY

Definition at line 80 of file DirectXFractal.h.

float2 ComputeCB::originDtid00

Definition at line 78 of file DirectXFractal.h.

The documentation for this struct was generated from the following file:
  • Direct3D HLSL fractal generator/C++/DirectXFractal.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ComputeDoubleCB Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ComputeDoubleCB Struct Reference

#include "DirectXFractal.h"

List of all members.

Public Attributes

double2 deltaPerDtidX
double2 deltaPerDtidY
double2 originDtid00

Detailed Description

Definition at line 83 of file DirectXFractal.h.

Member Data Documentation

double2 ComputeDoubleCB::deltaPerDtidX

Definition at line 86 of file DirectXFractal.h.

double2 ComputeDoubleCB::deltaPerDtidY

Definition at line 87 of file DirectXFractal.h.

double2 ComputeDoubleCB::originDtid00

Definition at line 85 of file DirectXFractal.h.

The documentation for this struct was generated from the following file:
  • Direct3D HLSL fractal generator/C++/DirectXFractal.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConstantBuffer Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ConstantBuffer Struct Reference

#include "BumpMapping.h"

List of all members.

Public Attributes

float | lightStrength
float3 marblePosition
float | marbleRadius
DirectX::XMFLOAT4X4 | model
float4x4 model
float4x4 projection
DirectX::XMFLOAT4X4 | projection
float4x4 view
DirectX::XMFLOAT4X4 | view

Detailed Description

Definition at line 17 of file BumpMapping.h.

Member Data Documentation

float ConstantBuffer::lightStrength

Definition at line 32 of file MarbleMaze.h.

float3 ConstantBuffer::marblePosition

Definition at line 30 of file MarbleMaze.h.

float ConstantBuffer::marbleRadius

Definition at line 31 of file MarbleMaze.h.

DirectX::XMFLOAT4X4 ConstantBuffer::model

Definition at line 19 of file StereoSimpleD3D.h.

float4x4 ConstantBuffer::model

Definition at line 19 of file BumpMapping.h.

float4x4 ConstantBuffer::projection

Definition at line 21 of file BumpMapping.h.

DirectX::XMFLOAT4X4 ConstantBuffer::projection

Definition at line 21 of file StereoSimpleD3D.h.

float4x4 ConstantBuffer::view

Definition at line 20 of file BumpMapping.h.

DirectX::XMFLOAT4X4 ConstantBuffer::view

Definition at line 20 of file StereoSimpleD3D.h.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/BumpMapping.h
  • Direct3D post-processing effects/C++/D3DPostProcessing.h
  • Direct3D resource loading/C++/ResourceLoading.h
  • Direct3D stereoscopic 3D/C++/StereoSimpleD3D.h
  • Direct3D tutorial/C++/Lesson3.Cubes/Main.cpp
  • Direct3D tutorial/C++/Lesson4.Textures/Main.cpp
  • Direct3D tutorial/C++/Lesson5.Components/Direct3DTutorial.h
  • Direct3D-Direct2D interop/C++/TextInterop.h
  • DirectX marble maze game/C++/MarbleMaze.h
  • DirectX postcard app/C++/ExtrudedTextRenderer.h
  • DirectX touch input/C++/Simple3DTouch.h
  • DXGI offer and reclaim resources/C++/OfferReclaimAPI.h
  • DXGI swap chain rotation/C++/DxgiRotation.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConstantBufferChangeOnResize Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ConstantBufferChangeOnResize Struct Reference

#include "ConstantBuffers.h"

List of all members.

Public Attributes

DirectX::XMFLOAT4X4 projection

Detailed Description

Definition at line 30 of file ConstantBuffers.h.

Member Data Documentation

DirectX::XMFLOAT4X4 ConstantBufferChangeOnResize::projection

Definition at line 32 of file ConstantBuffers.h.

The documentation for this struct was generated from the following files:
  • DirectX 3D shooting game/C++/ConstantBuffers.h
  • XAML DirectX 3D shooting game/C++/ConstantBuffers.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConstantBufferChangesEveryFrame Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ConstantBufferChangesEveryFrame Struct Reference

#include "ConstantBuffers.h"

List of all members.

Public Attributes

DirectX::XMFLOAT4X4 view

Detailed Description

Definition at line 35 of file ConstantBuffers.h.

Member Data Documentation

DirectX::XMFLOAT4X4 ConstantBufferChangesEveryFrame::view

Definition at line 37 of file ConstantBuffers.h.

The documentation for this struct was generated from the following files:
  • DirectX 3D shooting game/C++/ConstantBuffers.h
  • XAML DirectX 3D shooting game/C++/ConstantBuffers.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConstantBufferChangesEveryPrim Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ConstantBufferChangesEveryPrim Struct Reference

#include "ConstantBuffers.h"

List of all members.

Public Attributes

DirectX::XMFLOAT4 | diffuseColor
DirectX::XMFLOAT4 | meshColor
DirectX::XMFLOAT4 | specularColor
float | specularPower
DirectX::XMFLOAT4X4 | worldMatrix

Detailed Description

Definition at line 40 of file ConstantBuffers.h.

Member Data Documentation

DirectX::XMFLOAT4 ConstantBufferChangesEveryPrim::diffuseColor

Definition at line 44 of file ConstantBuffers.h.

DirectX::XMFLOAT4 ConstantBufferChangesEveryPrim::meshColor

Definition at line 43 of file ConstantBuffers.h.

DirectX::XMFLOAT4 ConstantBufferChangesEveryPrim::specularColor

Definition at line 45 of file ConstantBuffers.h.

float ConstantBufferChangesEveryPrim::specularPower

Definition at line 46 of file ConstantBuffers.h.

DirectX::XMFLOAT4X4 ConstantBufferChangesEveryPrim::worldMatrix

Definition at line 42 of file ConstantBuffers.h.

The documentation for this struct was generated from the following files:
  • DirectX 3D shooting game/C++/ConstantBuffers.h
  • XAML DirectX 3D shooting game/C++/ConstantBuffers.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConstantBufferLayoutForDX9BrightPassPixelShader Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ConstantBufferLayoutForDX9BrightPassPixelShader Struct Reference

#include "D3DPostProcessing.h"

List of all members.

Public Attributes

float | pixelHeight
float | pixelWidth

Detailed Description

Definition at line 34 of file D3DPostProcessing.h.

Member Data Documentation

float ConstantBufferLayoutForDX9BrightPassPixelShader::pixelHeight

Definition at line 37 of file D3DPostProcessing.h.

float ConstantBufferLayoutForDX9BrightPassPixelShader::pixelWidth

Definition at line 36 of file D3DPostProcessing.h.

The documentation for this struct was generated from the following file:
  • Direct3D post-processing effects/C++/D3DPostProcessing.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConstantBufferLayoutForGlowPixelShader Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ConstantBufferLayoutForGlowPixelShader Struct Reference

#include "D3DPostProcessing.h"

List of all members.

Public Attributes

float4 | sampleOffsets [blurKernelSpan]
float4 | sampleWeights [blurKernelSpan]

Detailed Description

Definition at line 44 of file D3DPostProcessing.h.

Member Data Documentation

float4 ConstantBufferLayoutForGlowPixelShader::sampleOffsets[blurKernelSpan]

Definition at line 46 of file D3DPostProcessing.h.

float4 ConstantBufferLayoutForGlowPixelShader::sampleWeights[blurKernelSpan]

Definition at line 47 of file D3DPostProcessing.h.

The documentation for this struct was generated from the following file:
  • Direct3D post-processing effects/C++/D3DPostProcessing.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConstantBufferNeverChanges Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ConstantBufferNeverChanges Struct Reference

#include "ConstantBuffers.h"

List of all members.

Public Attributes

DirectX::XMFLOAT4 | lightColor
DirectX::XMFLOAT4 | lightPosition [4]

Detailed Description

Definition at line 24 of file ConstantBuffers.h.

Member Data Documentation

DirectX::XMFLOAT4 ConstantBufferNeverChanges::lightColor

Definition at line 27 of file ConstantBuffers.h.

DirectX::XMFLOAT4 ConstantBufferNeverChanges::lightPosition

Definition at line 26 of file ConstantBuffers.h.

The documentation for this struct was generated from the following files:
  • DirectX 3D shooting game/C++/ConstantBuffers.h
  • XAML DirectX 3D shooting game/C++/ConstantBuffers.h
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Contact Struct Reference

#include "Collision.h"

List of all members.

Public Member Functions

Contact (const Triangle &tri, size_t index, MeshID mesh)
BOOL | CalculateContact (FXMVECTOR position, FXMVECTOR radiusIn, FXMVECTOR path)
FORCEINLINE XMVECTOR | GetSurfaceNormal () const
void | Invalidate ()
BOOL | IsColliding () const
XMVECTOR | Resolve (FXMVECTOR position, FXMVECTOR radius)

Public Attributes

float | closingVelocity
BOOL | contactIsEdge
XMFLOAT3 | contactPosition
MeshID meshID
float | penetrationDistance
XMFLOAT4 | plane
Triangle triangle
size_t | triIndex

Detailed Description

Definition at line 20 of file Collision.h.

Constructor & Destructor Documentation

Contact::Contact | ( | const Triangle & | tri,
 |  | size_t | index,
 |  | MeshID | mesh |
 | ) |  |  | [inline]

Definition at line 31 of file Collision.h.

                                                            :
        triangle(tri),
        triIndex(index),
        meshID(mesh)
    {
        plane = tri.plane;
    }

Member Function Documentation

BOOL Contact::CalculateContact | ( | FXMVECTOR | position,
 |  | FXMVECTOR | radiusIn,
 |  | FXMVECTOR | path
 | ) |  |

Definition at line 254 of file Collision.cpp.

{
    XMVECTOR V0 = XMLoadFloat3(&triangle.A);
    XMVECTOR V1 = XMLoadFloat3(&triangle.B);
    XMVECTOR V2 = XMLoadFloat3(&triangle.C);

    // Load the sphere.
    XMVECTOR center = position;
    XMVECTOR radius = radiusIn;

    // Compute the plane of the triangle (has to be normalized).
    XMVECTOR N = XMVector3Normalize(XMVector3Cross(V1 - V0, V2 - V0));

    // Is velocity in
    XMVECTOR VDotN = XMVector3Dot(path, N);
    XMStoreFloat(&closingVelocity, VDotN);

    // Find the nearest feature on the triangle to the sphere.
    XMVECTOR dist = XMVector3Dot(center - V0, N);

    // If the center of the sphere is farther from the plane of the triangle than
    // the radius of the sphere, then there cannot be an intersection.
    XMVECTOR noIntersection = XMVectorLess(dist, -radius);
    noIntersection = XMVectorOrInt(noIntersection, XMVectorGreater(dist, radius));

    // Project the center of the sphere onto the plane of the triangle.
    XMVECTOR pointOnPlane = center - (N * dist);

    // Is it inside all the edges? If so we intersect because the distance
    // to the plane is less than the radius.
    XMVECTOR isOnPlaneInsideTriangle = PointOnPlaneInsideTriangle(pointOnPlane, V0, V1, V2);

    // Find the nearest point on each edge.
    XMVECTOR radiusSq = radius * radius;

    // Edge 0, 1
    XMVECTOR pointEdge01 = PointOnLineSegmentNearestPoint(V0, V1, center);

    XMVECTOR distEdge01 = XMVector3LengthSq(center - pointEdge01);

    // If the distance to the center of the sphere to the point is less than
    // the radius of the sphere then it must intersect.
    XMVECTOR intersection = XMVectorOrInt(isOnPlaneInsideTriangle, XMVectorLessOrEqual(distEdge01, radiusSq));

    // Edge 1, 2
    XMVECTOR pointEdge12 = PointOnLineSegmentNearestPoint(V1, V2, center);
    XMVECTOR distEdge12 = XMVector3LengthSq(center - pointEdge12);

    // If the distance to the center of the sphere to the point is less than
    // the radius of the sphere then it must intersect.
    intersection = XMVectorOrInt(intersection, XMVectorLessOrEqual(distEdge12, radiusSq));

    // Edge 2, 0
    XMVECTOR pointEdge20 = PointOnLineSegmentNearestPoint(V2, V0, center);
    XMVECTOR distEdge20 = XMVector3LengthSq(center - pointEdge20);

    // If the distance to the center of the sphere to the point is less than
    // the radius of the sphere then it must intersect.
    intersection = XMVectorOrInt(intersection, XMVectorLessOrEqual(distEdge20, radiusSq));

    XMVECTOR pointOnPlaneDist = XMVector3LengthSq(center - pointOnPlane);
    XMVECTOR contactPointDist = XMVectorSet(FLT_MAX, FLT_MAX, FLT_MAX, FLT_MAX);
    XMVECTOR contactPoint = pointOnPlane;
    XMVECTOR isEdge = XMVectorFalseInt();
    // if intersects plane, start with point on plane distance
    contactPointDist = XMVectorSelect(contactPointDist, pointOnPlaneDist, isOnPlaneInsideTriangle);

    XMVECTOR select = XMVectorLessOrEqual(distEdge01, contactPointDist);
    contactPointDist = XMVectorSelect(contactPointDist, distEdge01, select);
    contactPoint = XMVectorSelect(contactPoint, pointEdge01, select);
    isEdge = XMVectorOrInt(isEdge, select);

    select = XMVectorLessOrEqual(distEdge12, contactPointDist);
    contactPointDist = XMVectorSelect(contactPointDist, distEdge12, select);
    contactPoint = XMVectorSelect(contactPoint, pointEdge12, select);
    isEdge = XMVectorOrInt(isEdge, select);

    select = XMVectorLessOrEqual(distEdge20, contactPointDist);
    contactPointDist = XMVectorSelect(contactPointDist, distEdge20, select);
    contactPoint = XMVectorSelect(contactPoint, pointEdge20, select);
    isEdge = XMVectorOrInt(isEdge, select);

    contactPointDist = XMVectorSqrt(contactPointDist);

    // Store the contact point, and the contact edge.
    XMStoreFloat3(&contactPosition, contactPoint);
    contactIsEdge = XMVector4EqualInt(isEdge, XMVectorTrueInt());

    // Is the sphere at the contact point? In which case we just use the surface normal.
    XMVECTOR isContactAtSphereCenter = XMVectorInBounds(contactPointDist, XMVectorSplatEpsilon());
    XMVECTOR contactToCenterNormal = (center - contactPoint) / contactPointDist;
    XMVECTOR contactNormal = XMVectorSelect(contactToCenterNormal, N, isContactAtSphereCenter);

    // Store the contact normal
    XMStoreFloat3((XMFLOAT3*)&plane, contactNormal);

    // Figure out the penetration distance...

    XMVECTOR penetrationDistTemp = XMVector3Dot(center - contactPoint, contactNormal) - radius;

    XMStoreFloat(&penetrationDistance, penetrationDistTemp);

    return XMVector4EqualInt(XMVectorAndCInt(intersection, noIntersection), XMVectorTrueInt());
}

FORCEINLINE XMVECTOR Contact::GetSurfaceNormal ( ) const [inline]

Definition at line 39 of file Collision.h.

    {
        return XMLoadFloat3((XMFLOAT3*) &plane);
    }

void Contact::Invalidate ( ) [inline]

Definition at line 50 of file Collision.h.

    {
        penetrationDistance = FLT_MAX;
    }

BOOL Contact::IsColliding ( ) const [inline]

Definition at line 44 of file Collision.h.

    {
        const float MIN_COLLISION_DISTANCE = -1.0E-5f;
        return penetrationDistance <= MIN_COLLISION_DISTANCE;
    }

XMVECTOR Contact::Resolve | ( | FXMVECTOR | position,
 |  | FXMVECTOR | radius
 | ) |  |

Definition at line 247 of file Collision.cpp.

{
    XMVECTOR N = XMLoadFloat3((XMFLOAT3*) &plane);
    return position - (penetrationDistance * N);
}

Member Data Documentation

float Contact::closingVelocity

Definition at line 24 of file Collision.h.

BOOL Contact::contactIsEdge

Definition at line 26 of file Collision.h.

XMFLOAT3 Contact::contactPosition

Definition at line 23 of file Collision.h.

MeshID Contact::meshID

Definition at line 28 of file Collision.h.

float Contact::penetrationDistance

Definition at line 25 of file Collision.h.

XMFLOAT4 Contact::plane

Definition at line 22 of file Collision.h.

Triangle Contact::triangle

Definition at line 27 of file Collision.h.

size_t Contact::triIndex

Definition at line 29 of file Collision.h.

The documentation for this struct was generated from the following files:
  • DirectX marble maze game/C++/Collision.h
  • DirectX marble maze game/C++/Collision.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ContactPicker
  • ContactPicker::App
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

ContactPicker::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()

Protected Member Functions

virtual void | OnActivated (Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override

Private Member Functions

void | SetupWindowing (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs)

Private Attributes

Windows::UI::Xaml::Controls::Frame | rootFrame

Detailed Description

Definition at line 24 of file App.xaml.h.

Member Function Documentation

virtual void ContactPicker::App::OnActivated ( Windows::ApplicationModel::Activation::IActivatedEventArgs^ args ) [override, protected, virtual]
void App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]

Definition at line 44 of file App.xaml.cpp.

{
    if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
    {
        SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
        {
            try
            {
                restoreTask.get();
            }
            catch(Platform::Exception^)
            {
                // If restore fails, the app should proceed as though there was no restored state.
            }

            SetupWindowing(pArgs);
        });
    }
    else
    {
        SetupWindowing(pArgs);
    }
}

void App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]

Definition at line 35 of file App.xaml.cpp.

{
    auto deferral = pArgs->SuspendingOperation->GetDeferral();
    SuspensionManager::StartSaveTask().then([=]()
    {
        deferral->Complete();
    });
}

void App::SetupWindowing ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [private]

Definition at line 68 of file App.xaml.cpp.

{
    if (Window::Current->Content == nullptr)
    {
        rootFrame = ref new Frame();
        TypeName pageType = { "ContactPicker.MainPage", TypeKind::Custom };
        rootFrame->Navigate(pageType);
        Window::Current->Content = rootFrame;
    }
    MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
    p->LaunchArgs = pArgs;
    Window::Current->Activate();
}

Member Data Documentation

internal ContactPicker::App::__pad0__

Definition at line 27 of file App.xaml.h.

Windows::UI::Xaml::Controls::Frame ContactPicker::App::rootFrame [private]

Definition at line 37 of file App.xaml.h.

The documentation for this class was generated from the following files:
  • Contact Picker app/C++/App.xaml.h
  • Contact Picker app/C++/App.xaml.cpp
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ContactPicker
  • Common
  • ContactPicker::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

ContactPicker::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 26 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String ContactPicker::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void ContactPicker::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 186 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void ContactPicker::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void ContactPicker::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 127 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal ContactPicker::Common::LayoutAwarePage::__pad0__

Definition at line 29 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> ContactPicker::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 51 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> ContactPicker::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 53 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken ContactPicker::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 52 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Contact Picker app/C++/Common/LayoutAwarePage.h
  • Contact Picker app/C++/Common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ContactPicker
  • ContactPicker::MainPage
Static Private Attributes

ContactPicker::MainPage Class Reference

#include "Constants.h"

List of all members.

Static Private Attributes

static Platform::Array< Scenario > scenariosInner

Detailed Description

Definition at line 29 of file Constants.h.

Member Data Documentation

Platform::Array< Scenario > MainPage::scenariosInner [static, private]
Initial value:
 ref new Platform::Array<Scenario>
{
    { "Pick a single contact", "ContactPicker.ScenarioSingle" },
    { "Pick multiple contacts", "ContactPicker.ScenarioMultiple" },
}

Definition at line 49 of file Constants.h.

The documentation for this class was generated from the following files:
  • Contact Picker app/C++/Constants.h
  • Contact Picker app/C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker::MainPagePicker Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ContactPicker
  • ContactPicker::MainPagePicker
Static Private Attributes

ContactPicker::MainPagePicker Class Reference

#include "Constants.h"

List of all members.

Static Private Attributes

static Platform::Array< Scenario > scenariosInner

Detailed Description

Definition at line 55 of file Constants.h.

Member Data Documentation

Platform::Array< Scenario > MainPagePicker::scenariosInner [static, private]
Initial value:
 ref new Platform::Array<Scenario>
{
    { "Selection contact(s)", "ContactPicker.ContactPickerPage" }
}

Definition at line 74 of file Constants.h.

The documentation for this class was generated from the following files:
  • Contact Picker app/C++/Constants.h
  • Contact Picker app/C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ContactPicker
  • ContactPicker::Scenario
Public Attributes

ContactPicker::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String ContactPicker::Scenario::ClassName

Definition at line 20 of file Constants.h.

Platform::String ContactPicker::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • Contact Picker app/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ContactPicker
  • ContactPicker::sealed
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes | Static Private Attributes

ContactPicker::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "ContactPickerPage.xaml.h"

List of all members.

Classes

struct | SampleContact

Public Member Functions

ContactPickerPage ()
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
MainPage ()
MainPagePicker ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
ScenarioMultiple ()
ScenarioSingle ()

Protected Member Functions

void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPagePicker_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Protected Attributes

internal | __pad0__: Windows::ApplicationModel::Contacts::Provider::ContactPickerUI^ contactPickerUI
Windows::ApplicationModel::Contacts::Provider::ContactPickerUI | contactPickerUI

Properties

event
Windows::Foundation::EventHandler
< MainPagePickerSizeChangedEventArgs^> 		MainPagePickerResized
event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

~MainPage ()
~MainPagePicker ()
void | AddSampleContact (SampleContact sampleContact)
void | ContactList_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | OnContactRemoved (Windows::ApplicationModel::Contacts::Provider::ContactPickerUI^sender, Windows::ApplicationModel::Contacts::Provider::ContactRemovedEventArgs^e)
void | PickAContactButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickContactsButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PopulateScenarios ()
void | PopulateScenarios ()
SampleContact | ResolveSampleContact (Object^listBoxItem)
void | SetContactPicker (Platform::String^strFeature)
void | SetContactPicker (Platform::String^strFeature)

Private Attributes

bool | autoSizeInputSectionWhenSnapped
Windows::UI::Xaml::Controls::Frame | HiddenFrame
Platform::Collections::Vector
< Object^> 		ScenarioList
Windows::Foundation::EventRegistrationToken | token

Static Private Attributes

static Platform::Array
< SampleContact > 		contactSet

Detailed Description

Definition at line 28 of file ContactPickerPage.xaml.h.

Constructor & Destructor Documentation

ContactPicker::sealed::~MainPage ( ) [private]
ContactPicker::sealed::~MainPagePicker ( ) [private]

Member Function Documentation

void ContactPicker::sealed::AddSampleContact ( SampleContact sampleContact ) [private]
void ContactPicker::sealed::ContactList_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
ContactPicker::sealed::ContactPickerPage ( )
void ContactPicker::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ContactPicker::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ContactPicker::sealed::InvalidateSize ( ) [private]
void ContactPicker::sealed::InvalidateSize ( ) [private]
void ContactPicker::sealed::InvalidateViewState ( ) [private]
void ContactPicker::sealed::InvalidateViewState ( ) [private]
void ContactPicker::sealed::LoadScenario ( Platform::String^ scenarioName )
void ContactPicker::sealed::LoadScenario ( Platform::String^ scenarioName )
ContactPicker::sealed::MainPage ( )
void ContactPicker::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
ContactPicker::sealed::MainPagePicker ( )
void ContactPicker::sealed::MainPagePicker_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void ContactPicker::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void ContactPicker::sealed::OnContactRemoved | ( | Windows::ApplicationModel::Contacts::Provider::ContactPickerUI^ | sender,
 |  | Windows::ApplicationModel::Contacts::Provider::ContactRemovedEventArgs^ | e |
 | ) |  |  | [private]
virtual void ContactPicker::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ContactPicker::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ContactPicker::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ContactPicker::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void ContactPicker::sealed::PickAContactButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ContactPicker::sealed::PickContactsButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ContactPicker::sealed::PopulateScenarios ( ) [private]
void ContactPicker::sealed::PopulateScenarios ( ) [private]
SampleContact ContactPicker::sealed::ResolveSampleContact ( Object^ listBoxItem ) [private]
ContactPicker::sealed::ScenarioMultiple ( )
void ContactPicker::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void ContactPicker::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
ContactPicker::sealed::ScenarioSingle ( )
void ContactPicker::sealed::SetContactPicker ( Platform::String^ strFeature ) [private]
void ContactPicker::sealed::SetContactPicker ( Platform::String^ strFeature ) [private]

Member Data Documentation

internal sealed::__pad0__ [protected]

Definition at line 38 of file ContactPickerPage.xaml.h.

bool sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 82 of file MainPage.xaml.h.

Windows::ApplicationModel::Contacts::Provider::ContactPickerUI ContactPicker::sealed::contactPickerUI [protected]

Definition at line 89 of file MainPagePicker.xaml.h.

Platform::Array<SampleContact> ContactPicker::sealed::contactSet [static, private]

Definition at line 56 of file ContactPickerPage.xaml.h.

Windows::UI::Xaml::Controls::Frame sealed::HiddenFrame [private]

Definition at line 80 of file MainPage.xaml.h.

Platform::Collections::Vector< Object^> sealed::ScenarioList [private]

Definition at line 79 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ContactPicker::sealed::token [private]

Definition at line 63 of file ContactPickerPage.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPagePickerSizeChangedEventArgs^> ContactPicker::sealed::MainPagePickerResized

Definition at line 67 of file MainPagePicker.xaml.h.

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> ContactPicker::sealed::MainPageResized

Definition at line 69 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler< Platform::Object^> sealed::ScenarioLoaded

Definition at line 68 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Contact Picker app/C++/ContactPickerPage.xaml.h
  • Contact Picker app/C++/MainPage.xaml.h
  • Contact Picker app/C++/MainPagePicker.xaml.h
  • Contact Picker app/C++/ScenarioMultiple.xaml.h
  • Contact Picker app/C++/ScenarioSingle.xaml.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker::sealed::SampleContact Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ContactPicker
  • ContactPicker::sealed
  • ContactPicker::sealed::SampleContact
Public Attributes

ContactPicker::sealed::SampleContact Struct Reference

List of all members.

Public Attributes

Platform::String | Address
Platform::String | City
Platform::String | HomeEmail
Platform::String | HomePhone
Platform::String | Id
Platform::String | MobilePhone
Platform::String | Name
Platform::String | State
Platform::String | Street
Platform::String | WorkEmail
Platform::String | WorkPhone
Platform::String | ZipCode

Detailed Description

Definition at line 41 of file ContactPickerPage.xaml.h.

Member Data Documentation

Platform::String ContactPicker::sealed::SampleContact::Address

Definition at line 49 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::City

Definition at line 51 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::HomeEmail

Definition at line 44 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::HomePhone

Definition at line 46 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::Id

Definition at line 54 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::MobilePhone

Definition at line 48 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::Name

Definition at line 43 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::State

Definition at line 52 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::Street

Definition at line 50 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::WorkEmail

Definition at line 45 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::WorkPhone

Definition at line 47 of file ContactPickerPage.xaml.h.

Platform::String ContactPicker::sealed::SampleContact::ZipCode

Definition at line 53 of file ContactPickerPage.xaml.h.

The documentation for this struct was generated from the following file:
  • Contact Picker app/C++/ContactPickerPage.xaml.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContentImageSource Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Private Member Functions | Private Attributes

ContentImageSource Class Reference

#include "ContentImageSource.h"

List of all members.

Classes

class | ImageSourceDrawHelper

Public Member Functions

ContentImageSource (_In_ Element^content, _In_ Document^document, bool isOpaque)
virtual ULONG STDMETHODCALLTYPE | AddRef () override
SIZE | GetImageSize ()
Windows::UI::Xaml::Media::ImageSource | GetImageSource ()
virtual HRESULT STDMETHODCALLTYPE | QueryInterface (REFIID uuid, _Outptr_ void **object) override
virtual ULONG STDMETHODCALLTYPE | Release () override
void | UpdateContent (_In_ Element^content)
virtual HRESULT STDMETHODCALLTYPE | UpdatesNeeded () override

Private Member Functions

bool | Draw (RECT const &drawingBounds)
void | Initialize ()
void | Measure (_Out_ SIZE *contentSize)

Private Attributes

Element m_content
SIZE | m_contentSize
Document m_document
Windows::UI::Xaml::Media::Imaging::VirtualSurfaceImageSource | m_imageSource
Microsoft::WRL::ComPtr
< IVirtualSurfaceImageSourceNative > 		m_imageSourceNative
bool | m_isOpaque
ULONG | m_refCount

Detailed Description

Definition at line 17 of file ContentImageSource.h.

Constructor & Destructor Documentation

ContentImageSource::ContentImageSource | ( | _In_ Element^ | content,
 |  | _In_ Document^ | document,
 |  | bool | isOpaque
 | ) |  |

Definition at line 14 of file ContentImageSource.cpp.

      :
    m_refCount(),
    m_content(content),
    m_contentSize(),
    m_document(document),
    m_imageSource(nullptr),
    m_imageSourceNative(),
    m_isOpaque(isOpaque)
{
}

Member Function Documentation

ULONG STDMETHODCALLTYPE ContentImageSource::AddRef ( ) [override, virtual]

Definition at line 303 of file ContentImageSource.cpp.

{
    return static_cast<ULONG>(InterlockedIncrement(&m_refCount));
}

bool ContentImageSource::Draw ( RECT const & drawingBounds ) [private]

Definition at line 149 of file ContentImageSource.cpp.

{
    ComPtr<IDXGISurface> dxgiSurface;
    POINT surfaceOffset = {0};
    bool needRedraw;

    HRESULT hr = S_OK;
    {
        // If the underlying device is lost, the virtual surface image source may return a
        // device lost error from BeginDraw. In this case, the error will be thrown here
        // and caught in UpdatesNeeded
        ImageSourceDrawHelper imageSourceDrawHelper(
            m_imageSourceNative.Get(),
            drawingBounds,
            &dxgiSurface,
            &surfaceOffset,
            &hr
            );

        auto renderer = m_document->GetRenderer();

        ComPtr<ID2D1DeviceContext> d2dDeviceContext;
        renderer->GetD2DDeviceContext(&d2dDeviceContext);

        ComPtr<ID2D1Bitmap1> bitmap;
        DX::ThrowIfFailed(
            d2dDeviceContext->CreateBitmapFromDxgiSurface(
                dxgiSurface.Get(),
                nullptr,
                &bitmap
                )
            );

        // Begin the drawing batch
        d2dDeviceContext->BeginDraw();

        // Scale content design coordinate to the display coordinate,
        // then translate the drawing to the designated place on the surface.
        D2D1::Matrix3x2F transform =
            D2D1::Matrix3x2F::Scale(
                m_document->DesignToDisplayWidth(1.0f),
                m_document->DesignToDisplayHeight(1.0f)
                ) *
            D2D1::Matrix3x2F::Translation(
                static_cast<float>(surfaceOffset.x - drawingBounds.left),
                static_cast<float>(surfaceOffset.y - drawingBounds.top)
                );

        // Prepare to draw content. This is the appropriate time for content element
        // to draw to an intermediate if there is any. It is important for performance
        // reason that SetTarget isn't called too frequently. Preparing the intermediates
        // upfront reduces the number of times the render target switches back and forth.
        needRedraw = m_content->PrepareToDraw(
            m_document,
            transform
            );

        if (!needRedraw)
        {
            // Set the render target to surface given by the framework
            d2dDeviceContext->SetTarget(bitmap.Get());

            d2dDeviceContext->SetTransform(D2D1::IdentityMatrix());

            // Constrain the drawing only to the designated portion of the surface
            d2dDeviceContext->PushAxisAlignedClip(
                D2D1::RectF(
                    static_cast<float>(surfaceOffset.x),
                    static_cast<float>(surfaceOffset.y),
                    static_cast<float>(surfaceOffset.x + (drawingBounds.right - drawingBounds.left)),
                    static_cast<float>(surfaceOffset.y + (drawingBounds.bottom - drawingBounds.top))
                    ),
                D2D1_ANTIALIAS_MODE_ALIASED
                );

            // The Clear call must follow and not precede the PushAxisAlignedClip call.
            // Placing the Clear call before the clip is set violates the contract of the
            // virtual surface image source in that the application draws outside the
            // designated portion of the surface the image source hands over to it. This
            // violation won't actually cause the content to spill outside the designated
            // area because the image source will safeguard it. But this extra protection
            // has a runtime cost associated with it, and in some drivers this cost can be
            // very expensive. So the best performance strategy here is to never create a
            // situation where this protection is required. Not drawing outside the appropriate
            // clip does that the right way.
            d2dDeviceContext->Clear(D2D1::ColorF(0, 0));

            // Draw the content
            needRedraw = m_content->Draw(
                m_document,
                transform
                );

            d2dDeviceContext->PopAxisAlignedClip();

            d2dDeviceContext->SetTarget(nullptr);
        }

        // End the drawing
        // UpdatesNeeded handles D2DERR_RECREATETARGET, so it is okay to throw this error here.
        DX::ThrowIfFailed(
            d2dDeviceContext->EndDraw()
            );
    }

    DX::ThrowIfFailed(hr);

    return needRedraw;
}

SIZE ContentImageSource::GetImageSize ( )

Definition at line 62 of file ContentImageSource.cpp.

{
    if (m_imageSource == nullptr)
    {
        Initialize();
    }

    return m_contentSize;
}

ImageSource ContentImageSource::GetImageSource ( )

Definition at line 52 of file ContentImageSource.cpp.

{
    if (m_imageSource == nullptr)
    {
        Initialize();
    }

    return m_imageSource;
}

void ContentImageSource::Initialize ( ) [private]

Definition at line 29 of file ContentImageSource.cpp.

{
    // Measure the content and store its size.
    Measure(&m_contentSize);

    // Create an image source at the initial pixel size.
    // The last parameter helps improve rendering performance when the image source is known to be opaque.
    m_imageSource = ref new VirtualSurfaceImageSource(m_contentSize.cx, m_contentSize.cy, m_isOpaque);

    ComPtr<IUnknown> unknown(reinterpret_cast<IUnknown*>(m_imageSource));
    unknown.As(&m_imageSourceNative);

    auto renderer = m_document->GetRenderer();

    // Set DXGI device to the image source
    ComPtr<IDXGIDevice> dxgiDevice;
    renderer->GetDXGIDevice(&dxgiDevice);
    m_imageSourceNative->SetDevice(dxgiDevice.Get());

    // Register image source's update callback so update can be made to it.
    m_imageSourceNative->RegisterForUpdatesNeeded(this);
}

void ContentImageSource::Measure ( _Out_ SIZE * contentSize ) [private]

Definition at line 134 of file ContentImageSource.cpp.

{
    D2D1_RECT_F contentBounds = {0};

    // Measure the drawing content
    m_content->Measure(
        m_document,
        m_document->GetPageSize(),
        &contentBounds
        );

    contentSize->cx = static_cast<long>(m_document->DesignToDisplayWidth(contentBounds.right - contentBounds.left));
    contentSize->cy = static_cast<long>(m_document->DesignToDisplayHeight(contentBounds.bottom - contentBounds.top));
}

HRESULT STDMETHODCALLTYPE ContentImageSource::QueryInterface | ( | REFIID | uuid,
 |  | _Outptr_ void ** | object |
 | ) |  |  | [override, virtual]

Definition at line 283 of file ContentImageSource.cpp.

{
    if (    uuid == IID_IUnknown
        ||  uuid == __uuidof(IVirtualSurfaceUpdatesCallbackNative)
        )
    {
        *object = this;
        AddRef();
        return S_OK;
    }
    else
    {
        *object = nullptr;
        return E_NOINTERFACE;
    }
}

ULONG STDMETHODCALLTYPE ContentImageSource::Release ( ) [override, virtual]

Definition at line 308 of file ContentImageSource.cpp.

{
    ULONG newCount = static_cast<ULONG>(InterlockedDecrement(&m_refCount));

    if (newCount == 0)
        delete this;

    return newCount;
}

void ContentImageSource::UpdateContent ( _In_ Element^ content )

Definition at line 259 of file ContentImageSource.cpp.

{
    if (m_imageSourceNative != nullptr)
    {
        SIZE oldContentSize = m_contentSize;

        m_content = content;

        Measure(&m_contentSize);

        DX::ThrowIfFailed(
            m_imageSourceNative->Resize(m_contentSize.cx, m_contentSize.cy)
            );

        RECT bounds = {0};
        bounds.right =  m_contentSize.cx;
        bounds.bottom = m_contentSize.cy;

        DX::ThrowIfFailed(
            m_imageSourceNative->Invalidate(bounds)
            );
    }
}

HRESULT STDMETHODCALLTYPE ContentImageSource::UpdatesNeeded ( ) [override, virtual]

Definition at line 74 of file ContentImageSource.cpp.

{
    HRESULT hr = S_OK;

    try
    {
        ULONG drawingBoundsCount = 0;

        DX::ThrowIfFailed(
            m_imageSourceNative->GetUpdateRectCount(&drawingBoundsCount)
            );

        std::unique_ptr<RECT[]> drawingBounds(new RECT[drawingBoundsCount]);

        DX::ThrowIfFailed(
            m_imageSourceNative->GetUpdateRects(drawingBounds.get(), drawingBoundsCount)
            );

        // This code doesn't try to coalesce multiple drawing bounds into one. Although that
        // extra process will reduce the number of draw calls, it requires the virtual surface
        // image source to manage non-uniform tile size, which requires it to make extra copy
        // operations to the compositor. By using the drawing bounds it directly returns, which are
        // of non-overlapping uniform tile size, the compositor is able to use these tiles directly,
        // which can greatly reduce the amount of memory needed by the virtual surface image source.
        // It will result in more draw calls though, but Direct2D will be able to accommodate that
        // without significant impact on presentation frame rate.
        for (ULONG i = 0; i < drawingBoundsCount; ++i)
        {
            if (Draw(drawingBounds[i]))
            {
                // Drawing isn't complete. This can happen when the content is still being
                // asynchronously loaded. Inform the image source to invalidate the drawing
                // bounds so that it calls back to redraw.
                DX::ThrowIfFailed(
                    m_imageSourceNative->Invalidate(drawingBounds[i])
                    );
            }
        }
    }
    catch (Platform::Exception^ exception)
    {
        hr = exception->HResult;

        if (hr == D2DERR_RECREATE_TARGET ||
            hr == DXGI_ERROR_DEVICE_REMOVED)
        {
            // If a device lost error is encountered, notify the renderer. The renderer will then
            // recreate the device and fire the DeviceLost event so that all listeners can take
            // an appropriate action.
            m_document->GetRenderer()->HandleDeviceLost();

            // Invalidate the image source so that it calls back to redraw
            RECT bounds = { 0, 0, m_contentSize.cx, m_contentSize.cy };
            m_imageSourceNative->Invalidate(bounds);
        }
    }

    return hr;
}

Member Data Documentation

Element ContentImageSource::m_content [private]

Definition at line 78 of file ContentImageSource.h.

SIZE ContentImageSource::m_contentSize [private]

Definition at line 81 of file ContentImageSource.h.

Document ContentImageSource::m_document [private]

Definition at line 75 of file ContentImageSource.h.

Windows::UI::Xaml::Media::Imaging::VirtualSurfaceImageSource ContentImageSource::m_imageSource [private]

Definition at line 84 of file ContentImageSource.h.

Microsoft::WRL::ComPtr<IVirtualSurfaceImageSourceNative> ContentImageSource::m_imageSourceNative [private]

Definition at line 87 of file ContentImageSource.h.

bool ContentImageSource::m_isOpaque [private]

Definition at line 90 of file ContentImageSource.h.

ULONG ContentImageSource::m_refCount [private]

Definition at line 72 of file ContentImageSource.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/ContentImageSource.h
  • Direct2D magazine app/C++/ContentImageSource.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContentImageSource::ImageSourceDrawHelper Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ContentImageSource
  • ContentImageSource::ImageSourceDrawHelper
Public Member Functions | Private Attributes

ContentImageSource::ImageSourceDrawHelper Class Reference

List of all members.

Public Member Functions

ImageSourceDrawHelper (IVirtualSurfaceImageSourceNative *imageSourceNative, _In_ RECT updateRect, _Out_ IDXGISurface **pSurface, _Out_ POINT *offset, HRESULT *hr)
~ImageSourceDrawHelper ()

Private Attributes

HRESULT * m_hr
Microsoft::WRL::ComPtr
< IVirtualSurfaceImageSourceNative > 		m_imageSourceNative

Detailed Description

Definition at line 48 of file ContentImageSource.h.

Constructor & Destructor Documentation

ContentImageSource::ImageSourceDrawHelper::ImageSourceDrawHelper | ( | IVirtualSurfaceImageSourceNative * | imageSourceNative,
 |  | _In_ RECT | updateRect,
 |  | _Out_ IDXGISurface ** | pSurface,
 |  | _Out_ POINT * | offset,
 |  | HRESULT * | hr
 | ) |  |
ContentImageSource::ImageSourceDrawHelper::~ImageSourceDrawHelper ( )

Definition at line 337 of file ContentImageSource.cpp.

{
    // It is not safe to throw from a destructor. Instead we pass the error back to the caller
    // and let the caller throw the error.
    *m_hr = m_imageSourceNative->EndDraw();
}

Member Data Documentation

HRESULT* ContentImageSource::ImageSourceDrawHelper::m_hr [private]

Definition at line 62 of file ContentImageSource.h.

Microsoft::WRL::ComPtr<IVirtualSurfaceImageSourceNative> ContentImageSource::ImageSourceDrawHelper::m_imageSourceNative [private]

Definition at line 61 of file ContentImageSource.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/ContentImageSource.h
  • Direct2D magazine app/C++/ContentImageSource.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConvolveMatrixEffect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

ConvolveMatrixEffect Class Reference

#include "ConvolveMatrixEffect.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: ConvolveMatrixEffect()

Private Member Functions

void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnHolding (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::HoldingEventArgs^args)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | ShowMenu (Windows::Foundation::Point position)
void | SwitchKernel (_In_ Windows::UI::Popups::IUICommand^command)

Private Attributes

D2D1_SIZE_U | m_bitmapPixelSize
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_bitmapSourceEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_convolveMatrixEffect
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
D2D1_SIZE_F | m_imageSize
SampleOverlay m_sampleOverlay
KernelSelection m_selectedKernel
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_wicConvertedSource

Detailed Description

Definition at line 14 of file ConvolveMatrixEffect.h.

Member Function Documentation

void ConvolveMatrixEffect::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 31 of file ConvolveMatrixEffect.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Decode the image using WIC. The output of the format converter
    // is accessible via m_wicConvertedSource.
    ComPtr<IWICBitmapDecoder> decoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"beach.jpg",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &decoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> frame;
    DX::ThrowIfFailed(
        decoder->GetFrame(0, &frame)
        );

    // Store the image size in pixels. This remains constant regardless of the app's DPI.
    UINT width, height;
    DX::ThrowIfFailed(
        frame->GetSize(&width, &height)
        );

    m_bitmapPixelSize = D2D1::SizeU(width, height);

    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&m_wicConvertedSource)
        );

    // Format convert to a pixel format that is compatible with Direct2D.
    DX::ThrowIfFailed(
        m_wicConvertedSource->Initialize(
            frame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0f,
            WICBitmapPaletteTypeCustom
            )
        );
}

void ConvolveMatrixEffect::CreateDeviceResources ( ) [override, virtual]

Definition at line 78 of file ConvolveMatrixEffect.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D convolve matrix effect sample"
        );

    // Use the BitmapSource effect to load the image from WIC and make it usable
    // in the Direct2D effects graph.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_bitmapSourceEffect)
        );

    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(
            D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE,
            m_wicConvertedSource.Get()
            )
        );

    // Cache the BitmapSource output as it never needs to change.
    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(D2D1_PROPERTY_CACHED, TRUE)
        );

    // Create the ConvolveMatrix effect and add it to the end of the effect graph.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1ConvolveMatrix, &m_convolveMatrixEffect)
        );

    m_convolveMatrixEffect->SetInputEffect(0, m_bitmapSourceEffect.Get());
}

void ConvolveMatrixEffect::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 118 of file ConvolveMatrixEffect.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    D2D1_SIZE_F contextSize = m_d2dContext->GetSize();

    // m_imageSize is in DIPs and changes depending on the app DPI.
    // This app ignores the source bitmap's DPI and assumes it is 96.
    m_imageSize = D2D1::SizeF(
        static_cast<float>(m_bitmapPixelSize.width) * 96.0f / m_dpi,
        static_cast<float>(m_bitmapPixelSize.height) * 96.0f / m_dpi
        );

    // Resize the image to fit the screen.
    float zoom = max(
        contextSize.width / m_imageSize.width,
        contextSize.height / m_imageSize.height
        );

    D2D1_VECTOR_2F zoomVector = D2D1::Vector2F(zoom, zoom);
    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, zoomVector)
        );
}

virtual void ConvolveMatrixEffect::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void ConvolveMatrixEffect::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 421 of file ConvolveMatrixEffect.cpp.

{
    IPropertySet^ appSettings = ApplicationData::Current->LocalSettings->Values;

    if (appSettings->HasKey("kernelIndex"))
    {
        m_selectedKernel = static_cast<KernelSelection>(
            safe_cast<IPropertyValue^>(appSettings->Lookup("kernelIndex"))->GetUInt32()
            );
    }
}

void ConvolveMatrixEffect::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void ConvolveMatrixEffect::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 467 of file ConvolveMatrixEffect.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void ConvolveMatrixEffect::OnHolding | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::HoldingEventArgs^ | args |
 | ) |  |  | [private]
void ConvolveMatrixEffect::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 458 of file ConvolveMatrixEffect.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void ConvolveMatrixEffect::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void ConvolveMatrixEffect::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void ConvolveMatrixEffect::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void ConvolveMatrixEffect::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 506 of file ConvolveMatrixEffect.cpp.

{
}

void ConvolveMatrixEffect::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void ConvolveMatrixEffect::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void ConvolveMatrixEffect::Render ( ) [override, virtual]

Definition at line 143 of file ConvolveMatrixEffect.cpp.

{
    // Select the convolution kernel and set up the ConvolveMatrix properties accordingly.
    // The kernel definitions and parameters are defined in ConvolutionKernels.h.
    switch (m_selectedKernel)
    {
        case KernelSelection::Passthrough:
            // Because D2D1_CONVOLVEMATRIX_PROP_KERNEL_MATRIX is a "BLOB" type in the
            // Direct2D property type system, we need to specify the byte size of the
            // data as the third parameter.
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_MATRIX,
                    (byte *) ConvolutionKernels::Passthrough,
                    sizeof(float) * ConvolutionKernels::PassthroughWidth *
                        ConvolutionKernels::PassthroughWidth
                    )
                );

            // Specify the size of the kernel.
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_X,
                    ConvolutionKernels::PassthroughWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_Y,
                    ConvolutionKernels::PassthroughWidth
                    )
                );

            // The divisor allows us to easily normalize a kernel's output. Many
            // common kernels have a divisor of 1 (the default value).
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_DIVISOR,
                    ConvolutionKernels::DefaultDivisor
                    )
                );
            break;

        case KernelSelection::BoxBlur:
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_MATRIX,
                    (byte *) ConvolutionKernels::BoxBlur,
                    sizeof(float) * ConvolutionKernels::BoxBlurWidth *
                        ConvolutionKernels::BoxBlurWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_X,
                    ConvolutionKernels::BoxBlurWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_Y,
                    ConvolutionKernels::BoxBlurWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_DIVISOR,
                    ConvolutionKernels::BoxBlurDivisor
                    )
                );
            break;

        case KernelSelection::SimpleEdgeDetect:
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_MATRIX,
                    (byte *) ConvolutionKernels::SimpleEdgeDetect,
                    sizeof(float) * ConvolutionKernels::SimpleEdgeDetectWidth *
                        ConvolutionKernels::SimpleEdgeDetectWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_X,
                    ConvolutionKernels::SimpleEdgeDetectWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_Y,
                    ConvolutionKernels::SimpleEdgeDetectWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_DIVISOR,
                    ConvolutionKernels::DefaultDivisor
                    )
                );
            break;

        case KernelSelection::SimpleSharpen:
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_MATRIX,
                    (byte *) ConvolutionKernels::SimpleSharpen,
                    sizeof(float) * ConvolutionKernels::SimpleSharpenWidth *
                        ConvolutionKernels::SimpleSharpenWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_X,
                    ConvolutionKernels::SimpleSharpenWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_Y,
                    ConvolutionKernels::SimpleSharpenWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_DIVISOR,
                    ConvolutionKernels::SimpleSharpenDivisor
                    )
                );
            break;

        case KernelSelection::Emboss:
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_MATRIX,
                    (byte *) ConvolutionKernels::Emboss,
                    sizeof(float) * ConvolutionKernels::EmbossWidth *
                        ConvolutionKernels::EmbossWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_X,
                    ConvolutionKernels::EmbossWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_Y,
                    ConvolutionKernels::EmbossWidth
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_DIVISOR,
                    ConvolutionKernels::DefaultDivisor
                    )
                );
            break;

        case KernelSelection::HorizontalSmear:
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_MATRIX,
                    (byte *) ConvolutionKernels::HorizontalSmear,
                    sizeof(float) * ConvolutionKernels::HorizontalSmearWidth *
                        ConvolutionKernels::HorizontalSmearHeight
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_X,
                    ConvolutionKernels::HorizontalSmearWidth
                    )
                );

            // The horizontal smear kernel has a different width and height.
            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_KERNEL_SIZE_Y,
                    ConvolutionKernels::HorizontalSmearHeight
                    )
                );

            DX::ThrowIfFailed(
                m_convolveMatrixEffect->SetValue(
                    D2D1_CONVOLVEMATRIX_PROP_DIVISOR,
                    ConvolutionKernels::HorizontalSmearDivisor
                    )
                );
            break;

        default:
            throw ref new Platform::FailureException();
    }

    m_d2dContext->BeginDraw();

    m_d2dContext->DrawImage(
        m_convolveMatrixEffect.Get(),
        D2D1_INTERPOLATION_MODE_LINEAR,
        D2D1_COMPOSITE_MODE_SOURCE_COPY
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void ConvolveMatrixEffect::Run ( ) [virtual]

Definition at line 435 of file ConvolveMatrixEffect.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void ConvolveMatrixEffect::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void ConvolveMatrixEffect::ShowMenu ( Windows::Foundation::Point position ) [private]
void ConvolveMatrixEffect::SwitchKernel ( _In_ Windows::UI::Popups::IUICommand^ command ) [private]
void ConvolveMatrixEffect::Uninitialize ( ) [virtual]

Definition at line 443 of file ConvolveMatrixEffect.cpp.

{
}

Member Data Documentation

internal ConvolveMatrixEffect::__pad0__

Definition at line 17 of file ConvolveMatrixEffect.h.

D2D1_SIZE_U ConvolveMatrixEffect::m_bitmapPixelSize [private]

Definition at line 93 of file ConvolveMatrixEffect.h.

Microsoft::WRL::ComPtr<ID2D1Effect> ConvolveMatrixEffect::m_bitmapSourceEffect [private]

Definition at line 97 of file ConvolveMatrixEffect.h.

Microsoft::WRL::ComPtr<ID2D1Effect> ConvolveMatrixEffect::m_convolveMatrixEffect [private]

Definition at line 98 of file ConvolveMatrixEffect.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> ConvolveMatrixEffect::m_gestureRecognizer [private]

Definition at line 90 of file ConvolveMatrixEffect.h.

D2D1_SIZE_F ConvolveMatrixEffect::m_imageSize [private]

Definition at line 94 of file ConvolveMatrixEffect.h.

SampleOverlay ConvolveMatrixEffect::m_sampleOverlay [private]

Definition at line 89 of file ConvolveMatrixEffect.h.

KernelSelection ConvolveMatrixEffect::m_selectedKernel [private]

Definition at line 92 of file ConvolveMatrixEffect.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> ConvolveMatrixEffect::m_wicConvertedSource [private]

Definition at line 96 of file ConvolveMatrixEffect.h.

The documentation for this class was generated from the following files:
  • Direct2D convolve matrix effect/C++/ConvolveMatrixEffect.h
  • Direct2D convolve matrix effect/C++/ConvolveMatrixEffect.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CoreWindowEvents Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

CoreWindowEvents Class Reference

#include "CoreWindowEvents.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnCharacterReceived (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CharacterReceivedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyUp (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnWindowActivated (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowActivatedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Private Member Functions

void | EventPrint (_In_ Platform::String^eventText)
void | PrintPointerInfo (_In_ Platform::String^eventText, _In_ Windows::UI::Core::PointerEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Platform::String | m_eventName
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_eventTextFormat
SampleOverlay m_sampleOverlay

Detailed Description

Definition at line 13 of file CoreWindowEvents.h.

Member Function Documentation

void CoreWindowEvents::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 20 of file CoreWindowEvents.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create a DirectWrite text format object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            NULL,
            DWRITE_FONT_WEIGHT_REGULAR,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            20.0f,
            L"en-US", //locale
            &m_eventTextFormat
            )
        );

    // Align the text to left.
    m_eventTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING);
    // Center the text vertically.
    m_eventTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER);
}

void CoreWindowEvents::CreateDeviceResources ( ) [override, virtual]

Definition at line 44 of file CoreWindowEvents.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        L"CoreWindow Events Sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );
}

void CoreWindowEvents::EventPrint ( _In_ Platform::String^ eventText ) [private]

Definition at line 147 of file CoreWindowEvents.cpp.

{
    m_eventName = eventText;
    Render();
    Present();
}

virtual void CoreWindowEvents::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void CoreWindowEvents::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 128 of file CoreWindowEvents.cpp.

{
}

void CoreWindowEvents::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args
 | ) |  |
void CoreWindowEvents::OnCharacterReceived | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CharacterReceivedEventArgs^ | args
 | ) |  |
void CoreWindowEvents::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender )

Definition at line 241 of file CoreWindowEvents.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void CoreWindowEvents::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args
 | ) |  |
void CoreWindowEvents::OnKeyUp | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args
 | ) |  |
void CoreWindowEvents::OnLogicalDpiChanged ( _In_ Platform::Object^ sender )

Definition at line 232 of file CoreWindowEvents.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void CoreWindowEvents::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args
 | ) |  |
void CoreWindowEvents::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args
 | ) |  |
void CoreWindowEvents::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args
 | ) |  |
void CoreWindowEvents::OnWindowActivated | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowActivatedEventArgs^ | args
 | ) |  |
void CoreWindowEvents::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args
 | ) |  |
void CoreWindowEvents::PrintPointerInfo | ( | _In_ Platform::String^ | eventText,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void CoreWindowEvents::Render ( ) [override, virtual]

Definition at line 66 of file CoreWindowEvents.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));

    m_d2dContext->DrawText(
        m_eventName->Data(),
        m_eventName->Length(),
        m_eventTextFormat.Get(),
        D2D1::RectF(0.0, 0.0, m_renderTargetSize.Width, m_renderTargetSize.Height),
        m_blackBrush.Get());

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void CoreWindowEvents::Run ( ) [virtual]

Definition at line 134 of file CoreWindowEvents.cpp.

{
    CoreWindow::GetForCurrentThread()->Activate();

    Render();
    Present();
    CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void CoreWindowEvents::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void CoreWindowEvents::Uninitialize ( ) [virtual]

Definition at line 143 of file CoreWindowEvents.cpp.

{
}

Member Data Documentation

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> CoreWindowEvents::m_blackBrush [private]

Definition at line 95 of file CoreWindowEvents.h.

Platform::String CoreWindowEvents::m_eventName [private]

Definition at line 96 of file CoreWindowEvents.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> CoreWindowEvents::m_eventTextFormat [private]

Definition at line 94 of file CoreWindowEvents.h.

SampleOverlay CoreWindowEvents::m_sampleOverlay [private]

Definition at line 93 of file CoreWindowEvents.h.

The documentation for this class was generated from the following files:
  • DirectX swap chain implementation/C++/CoreWindowEvents.h
  • DirectX swap chain implementation/C++/CoreWindowEvents.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CountdownTimer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes

CountdownTimer Class Reference

#include "UserInterface.h"

Inherits TextElement.

List of all members.

Public Member Functions

CountdownTimer ()
virtual void | Initialize ()
bool | IsCountdownComplete () const
virtual void | Render ()
void | StartCountdown (int seconds)
virtual void | Update (float timeTotal, float timeDelta)

Protected Attributes

float | m_elapsedTime
int | m_secondsRemaining

Detailed Description

Definition at line 115 of file UserInterface.h.

Constructor & Destructor Documentation

CountdownTimer::CountdownTimer ( )

Definition at line 330 of file UserInterface.cpp.

                              :
    m_elapsedTime(0.0f),
    m_secondsRemaining(0)
{
}

Member Function Documentation

void CountdownTimer::Initialize ( ) [virtual]

Reimplemented from TextElement.

Definition at line 336 of file UserInterface.cpp.

{
    TextElement::Initialize();
}

bool CountdownTimer::IsCountdownComplete ( ) const

Definition at line 387 of file UserInterface.cpp.

{
    return (m_secondsRemaining == 0);
}

void CountdownTimer::Render ( ) [virtual]

Reimplemented from TextElement.

Definition at line 370 of file UserInterface.cpp.

{
    TextElement::Render();
}

void CountdownTimer::StartCountdown ( int seconds )

Definition at line 375 of file UserInterface.cpp.

{
    m_secondsRemaining = seconds;
    m_elapsedTime = 0.0f;

    WCHAR buffer[4];
    swprintf_s(buffer, L"%2d", m_secondsRemaining);
    SetText(buffer);
    SetTextOpacity(1.0f);
    FadeOut(1.0f);
}

void CountdownTimer::Update | ( | float | timeTotal,
 |  | float | timeDelta |
 | ) |  |  | [virtual]

Reimplemented from TextElement.

Definition at line 341 of file UserInterface.cpp.

{
    if (m_secondsRemaining > 0)
    {
        m_elapsedTime += timeDelta;
        if (m_elapsedTime >= 1.0f)
        {
            m_elapsedTime -= 1.0f;

            if (--m_secondsRemaining > 0)
            {
                WCHAR buffer[4];
                swprintf_s(buffer, L"%2d", m_secondsRemaining);
                SetText(buffer);
                SetTextOpacity(1.0f);
                FadeOut(1.0f);
            }
            else
            {
                SetText(L"Go!");
                SetTextOpacity(1.0f);
                FadeOut(1.0f);
            }
        }
    }

    TextElement::Update(timeTotal, timeDelta);
}

Member Data Documentation

float CountdownTimer::m_elapsedTime [protected]

Definition at line 129 of file UserInterface.h.

int CountdownTimer::m_secondsRemaining [protected]

Definition at line 130 of file UserInterface.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/UserInterface.h
  • DirectX marble maze game/C++/UserInterface.cpp
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CPolarEffect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Private Member Functions | Static Private Member Functions | Private Attributes

CPolarEffect Class Reference

#include "PolarEffect.h"

List of all members.

Private Member Functions

InspectableClass(RuntimeClass_PolarTransform_PolarEffect,
BaseTrust) public 		~CPolarEffect ()
InspectableClass(RuntimeClass_PolarTransform_PolarEffect,
BaseTrust) public 		~CPolarEffect ()
STDMETHODIMP | AddInputStreams (DWORD cStreams, DWORD *adwStreamIDs)
STDMETHODIMP | AddInputStreams (DWORD cStreams, DWORD *adwStreamIDs)
HRESULT | BeginStreaming ()
HRESULT | BeginStreaming ()
STDMETHODIMP | DeleteInputStream (DWORD dwStreamID)
STDMETHODIMP | DeleteInputStream (DWORD dwStreamID)
HRESULT | EndStreaming ()
HRESULT | EndStreaming ()
void | GeneratePolarLookup (UINT32 unWidth, UINT32 unHeight, UINT32 *pIndexLookup)
void | GeneratePolarLookup (UINT32 unWidth, UINT32 unHeight, UINT32 *pIndexLookup)
STDMETHODIMP | GetAttributes (IMFAttributes **pAttributes)
STDMETHODIMP | GetAttributes (IMFAttributes **pAttributes)
STDMETHODIMP | GetInputAvailableType (DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetInputAvailableType (DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetInputCurrentType (DWORD dwInputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetInputCurrentType (DWORD dwInputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetInputStatus (DWORD dwInputStreamID, DWORD *pdwFlags)
STDMETHODIMP | GetInputStatus (DWORD dwInputStreamID, DWORD *pdwFlags)
STDMETHODIMP | GetInputStreamAttributes (DWORD dwInputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetInputStreamAttributes (DWORD dwInputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetInputStreamInfo (DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetInputStreamInfo (DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetOutputAvailableType (DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetOutputAvailableType (DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType)
STDMETHODIMP | GetOutputCurrentType (DWORD dwOutputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetOutputCurrentType (DWORD dwOutputStreamID, IMFMediaType **ppType)
STDMETHODIMP | GetOutputStatus (DWORD *pdwFlags)
STDMETHODIMP | GetOutputStatus (DWORD *pdwFlags)
STDMETHODIMP | GetOutputStreamAttributes (DWORD dwOutputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetOutputStreamAttributes (DWORD dwOutputStreamID, IMFAttributes **ppAttributes)
STDMETHODIMP | GetOutputStreamInfo (DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetOutputStreamInfo (DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo)
STDMETHODIMP | GetStreamCount (DWORD *pcInputStreams, DWORD *pcOutputStreams)
STDMETHODIMP | GetStreamCount (DWORD *pcInputStreams, DWORD *pcOutputStreams)
STDMETHODIMP | GetStreamIDs (DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs)
STDMETHODIMP | GetStreamIDs (DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs)
STDMETHODIMP | GetStreamLimits (DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum)
STDMETHODIMP | GetStreamLimits (DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum)
BOOL | HasPendingOutput () const
BOOL | HasPendingOutput () const
BOOL | IsValidInputStream (DWORD dwInputStreamID) const
BOOL | IsValidInputStream (DWORD dwInputStreamID) const
BOOL | IsValidOutputStream (DWORD dwOutputStreamID) const
BOOL | IsValidOutputStream (DWORD dwOutputStreamID) const
HRESULT | OnCheckInputType (IMFMediaType *pmt)
HRESULT | OnCheckInputType (IMFMediaType *pmt)
HRESULT | OnCheckMediaType (IMFMediaType *pmt)
HRESULT | OnCheckMediaType (IMFMediaType *pmt)
HRESULT | OnCheckOutputType (IMFMediaType *pmt)
HRESULT | OnCheckOutputType (IMFMediaType *pmt)
HRESULT | OnFlush ()
HRESULT | OnFlush ()
HRESULT | OnGetPartialType (DWORD dwTypeIndex, IMFMediaType **ppmt)
HRESULT | OnGetPartialType (DWORD dwTypeIndex, IMFMediaType **ppmt)
HRESULT | OnProcessOutput (IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
HRESULT | OnProcessOutput (IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
void | OnSetInputType (IMFMediaType *pmt)
void | OnSetInputType (IMFMediaType *pmt)
void | OnSetOutputType (IMFMediaType *pmt)
void | OnSetOutputType (IMFMediaType *pmt)
STDMETHODIMP | ProcessEvent (DWORD dwInputStreamID, IMFMediaEvent *pEvent)
STDMETHODIMP | ProcessEvent (DWORD dwInputStreamID, IMFMediaEvent *pEvent)
STDMETHODIMP | ProcessInput (DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags)
STDMETHODIMP | ProcessInput (DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags)
STDMETHODIMP | ProcessMessage (MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam)
STDMETHODIMP | ProcessMessage (MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam)
STDMETHODIMP | ProcessOutput (DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus)
STDMETHODIMP | ProcessOutput (DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus)
STDMETHOD() | RuntimeClassInitialize ()
STDMETHOD() | RuntimeClassInitialize ()
STDMETHODIMP | SetInputType (DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetInputType (DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetOutputBounds (LONGLONG hnsLowerBound, LONGLONG hnsUpperBound)
STDMETHODIMP | SetOutputBounds (LONGLONG hnsLowerBound, LONGLONG hnsUpperBound)
STDMETHODIMP | SetOutputType (DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetOutputType (DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags)
STDMETHODIMP | SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
STDMETHODIMP | SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
HRESULT | UpdateFormatInfo ()
HRESULT | UpdateFormatInfo ()

Static Private Member Functions

static __forceinline DOUBLE | DefaultRadius (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | DefaultRadius (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | DefaultTheta (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | DefaultTheta (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | FisheyeRadius (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | FisheyeRadius (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | PinchRadius (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | PinchRadius (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | WarpTheta (DOUBLE r, DOUBLE R, DOUBLE theta)
static __forceinline DOUBLE | WarpTheta (DOUBLE r, DOUBLE R, DOUBLE theta)

Private Attributes

bool | m_bStreamingInitialized
DWORD | m_cbImageSize
CRITICAL_SECTION | m_critSec
UINT32 | m_imageHeightInPixels
UINT32 | m_imageWidthInPixels
IMFAttributes * | m_pAttributes
UINT32 * | m_pIndexLookup
IMFMediaType * | m_pInputType
IMFMediaType * | m_pOutputType
PolarTransformer m_pRadiusTransformFn
IMFSample * | m_pSample
PolarTransformer m_pThetaTransformFn
IMAGE_TRANSFORM_FN m_pTransformFn

Detailed Description

Definition at line 74 of file PolarEffect.h.

Constructor & Destructor Documentation

CPolarEffect::~CPolarEffect ( ) [private]

Definition at line 279 of file PolarEffect.cpp.

{
    SafeArrayDelete(&m_pIndexLookup);
    SafeRelease(&m_pInputType);
    SafeRelease(&m_pOutputType);
    SafeRelease(&m_pSample);
    SafeRelease(&m_pAttributes);
    DeleteCriticalSection(&m_critSec);
}

InspectableClass (RuntimeClass_PolarTransform_PolarEffect,BaseTrust) public CPolarEffect::~CPolarEffect ( ) [private]

Member Function Documentation

HRESULT CPolarEffect::AddInputStreams | ( | DWORD | cStreams,
 |  | DWORD * | adwStreamIDs |
 | ) |  |  | [private]

Definition at line 614 of file PolarEffect.cpp.

{
    // This MFT has a fixed number of output streams, so the method is not supported.
    return E_NOTIMPL;
}

STDMETHODIMP CPolarEffect::AddInputStreams | ( | DWORD | cStreams,
 |  | DWORD * | adwStreamIDs |
 | ) |  |  | [private]
HRESULT CPolarEffect::BeginStreaming ( ) [private]

Definition at line 1474 of file PolarEffect.cpp.

{
    HRESULT hr = S_OK;

    if (m_pIndexLookup == NULL)
    {
        UINT32 unVideoArea = m_imageWidthInPixels * m_imageHeightInPixels;

        m_pIndexLookup = new UINT32[unVideoArea];

        if (m_pIndexLookup != NULL)
        {
            ZeroMemory( m_pIndexLookup, unVideoArea * sizeof(UINT32) );

            GeneratePolarLookup( m_imageWidthInPixels,
                                 m_imageHeightInPixels,
                                 m_pIndexLookup );
        }
        else
        {
            hr = E_OUTOFMEMORY;
        }
    }

    if (SUCCEEDED(hr))
    {
        m_bStreamingInitialized = true;
    }

    return hr;
}

HRESULT CPolarEffect::BeginStreaming ( ) [private]
static __forceinline DOUBLE CPolarEffect::DefaultRadius | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 87 of file PolarEffect.h.

{ return r; }

static __forceinline DOUBLE CPolarEffect::DefaultRadius | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 87 of file PolarEffect.h.

{ return r; }

static __forceinline DOUBLE CPolarEffect::DefaultTheta | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 88 of file PolarEffect.h.

{ return theta; };

static __forceinline DOUBLE CPolarEffect::DefaultTheta | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 88 of file PolarEffect.h.

{ return theta; };

HRESULT CPolarEffect::DeleteInputStream ( DWORD dwStreamID ) [private]

Definition at line 603 of file PolarEffect.cpp.

{
    // This MFT has a fixed number of input streams, so the method is not supported.
    return E_NOTIMPL;
}

STDMETHODIMP CPolarEffect::DeleteInputStream ( DWORD dwStreamID ) [private]
HRESULT CPolarEffect::EndStreaming ( ) [private]

Definition at line 1513 of file PolarEffect.cpp.

{
    SafeArrayDelete(&m_pIndexLookup);
    m_bStreamingInitialized = false;
    return S_OK;
}

HRESULT CPolarEffect::EndStreaming ( ) [private]
static __forceinline DOUBLE CPolarEffect::FisheyeRadius | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 91 of file PolarEffect.h.

{ return (r*r)/R; };

static __forceinline DOUBLE CPolarEffect::FisheyeRadius | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 91 of file PolarEffect.h.

{ return (r*r)/R; };

void CPolarEffect::GeneratePolarLookup | ( | UINT32 | unWidth,
 |  | UINT32 | unHeight,
 |  | UINT32 * | pIndexLookup |
 | ) |  |  | [private]
void CPolarEffect::GeneratePolarLookup | ( | UINT32 | unWidth,
 |  | UINT32 | unHeight,
 |  | UINT32 * | pIndexLookup |
 | ) |  |  | [private]

Definition at line 1651 of file PolarEffect.cpp.

{
    LONG x, y;
    UINT32 *pIndex;
    LONG lMaxX, lMaxY;
    LONG lHalfWidth, lHalfHeight;
    LONG lTransDx, lTransDy;
    DOUBLE dRadius, dMaxRadius, dNewRadius;
    DOUBLE dTheta, dNewTheta;

    assert(m_pRadiusTransformFn != NULL);
    assert(m_pThetaTransformFn != NULL);

    lMaxX = (LONG)unWidth;
    lMaxY = (LONG)unHeight;
    lHalfWidth = unWidth / 2;
    lHalfHeight = unHeight / 2;
    dMaxRadius = floor( sqrtf( static_cast<float>(lHalfWidth*lHalfWidth+lHalfHeight*lHalfHeight) ) );

    pIndex = pIndexLookup;

    for(y = 0; y < lMaxY; y++)
    {
        for(x = 0; x < lMaxX; x++)
        {
            lTransDx = lHalfWidth - x;
            lTransDy = lHalfHeight - y;

            dRadius = ceil( sqrtf( static_cast<float>(lTransDx*lTransDx + lTransDy*lTransDy) ) );

            if( dRadius < dMaxRadius )
            {
                dTheta = atan2f( static_cast<float> (lTransDy), static_cast<float> (lTransDx) );

                dNewRadius = m_pRadiusTransformFn(dRadius, dMaxRadius, dTheta);
                dNewTheta = m_pThetaTransformFn(dRadius, dMaxRadius, dTheta);

                lTransDx = lHalfWidth - (LONG)(dNewRadius * cos(dNewTheta));
                lTransDy = lHalfHeight - (LONG)(dNewRadius * sin(dNewTheta));

                if( 0 <= lTransDx && lTransDx < lMaxX &&
                    0 <= lTransDy && lTransDy < lMaxY )
                {
                    *pIndex++ = lTransDy * lMaxX + lTransDx;
                }
                else
                {
                    *pIndex++ = 0;
                }
            }
            else
            {
                *pIndex++ = 0;
            }
        }
    }
}

HRESULT CPolarEffect::GetAttributes ( IMFAttributes ** pAttributes ) [private]

Definition at line 552 of file PolarEffect.cpp.

{
    if (ppAttributes == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    *ppAttributes = m_pAttributes;
    (*ppAttributes)->AddRef();

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CPolarEffect::GetAttributes ( IMFAttributes ** pAttributes ) [private]
HRESULT CPolarEffect::GetInputAvailableType | ( | DWORD | dwInputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 629 of file PolarEffect.cpp.

{
    if (ppType == NULL)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    // If the output type is set, return that type as our preferred input type.
    if (m_pOutputType == NULL)
    {
        // The output type is not set. Create a partial media type.
        hr = OnGetPartialType(dwTypeIndex, ppType);
    }
    else if (dwTypeIndex > 0)
    {
        hr = MF_E_NO_MORE_TYPES;
    }
    else
    {
        *ppType = m_pOutputType;
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CPolarEffect::GetInputAvailableType | ( | DWORD | dwInputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
STDMETHODIMP CPolarEffect::GetInputCurrentType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CPolarEffect::GetInputCurrentType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 846 of file PolarEffect.cpp.

{
    if (ppType == NULL)
    {
        return E_POINTER;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        hr = MF_E_INVALIDSTREAMNUMBER;
    }
    else if (!m_pInputType)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }
    else
    {
        *ppType = m_pInputType;
        (*ppType)->AddRef();
    }
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CPolarEffect::GetInputStatus | ( | DWORD | dwInputStreamID,
 |  | DWORD * | pdwFlags |
 | ) |  |  | [private]
HRESULT CPolarEffect::GetInputStatus | ( | DWORD | dwInputStreamID,
 |  | DWORD * | pdwFlags |
 | ) |  |  | [private]

Definition at line 921 of file PolarEffect.cpp.

{
    if (pdwFlags == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    // If an input sample is already queued, do not accept another sample until the
    // client calls ProcessOutput or Flush.

    // NOTE: It is possible for an MFT to accept more than one input sample. For
    // example, this might be required in a video decoder if the frames do not
    // arrive in temporal order. In the case, the decoder must hold a queue of
    // samples. For the video effect, each sample is transformed independently, so
    // there is no reason to queue multiple input samples.

    if (m_pSample == NULL)
    {
        *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
    }
    else
    {
        *pdwFlags = 0;
    }

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

HRESULT CPolarEffect::GetInputStreamAttributes | ( | DWORD | dwInputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]

Definition at line 574 of file PolarEffect.cpp.

{
    // This MFT does not support any stream-level attributes, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CPolarEffect::GetInputStreamAttributes | ( | DWORD | dwInputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]
HRESULT CPolarEffect::GetInputStreamInfo | ( | DWORD | dwInputStreamID,
 |  | MFT_INPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]

Definition at line 456 of file PolarEffect.cpp.

{
    if (pStreamInfo == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    // NOTE: This method should succeed even when there is no media type on the
    //       stream. If there is no media type, we only need to fill in the dwFlags
    //       member of MFT_INPUT_STREAM_INFO. The other members depend on having a
    //       a valid media type.

    pStreamInfo->hnsMaxLatency = 0;
    pStreamInfo->dwFlags = MFT_INPUT_STREAM_WHOLE_SAMPLES | MFT_INPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER;

    if (m_pInputType == NULL)
    {
        pStreamInfo->cbSize = 0;
    }
    else
    {
        pStreamInfo->cbSize = m_cbImageSize;
    }

    pStreamInfo->cbMaxLookahead = 0;
    pStreamInfo->cbAlignment = 0;

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CPolarEffect::GetInputStreamInfo | ( | DWORD | dwInputStreamID,
 |  | MFT_INPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]
STDMETHODIMP CPolarEffect::GetOutputAvailableType | ( | DWORD | dwOutputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CPolarEffect::GetOutputAvailableType | ( | DWORD | dwOutputStreamID,
 |  | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 677 of file PolarEffect.cpp.

{
    if (ppType == NULL)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    if (m_pInputType == NULL)
    {
        // The input type is not set. Create a partial media type.
        hr = OnGetPartialType(dwTypeIndex, ppType);
    }
    else if (dwTypeIndex > 0)
    {
        hr = MF_E_NO_MORE_TYPES;
    }
    else
    {
        *ppType = m_pInputType;
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CPolarEffect::GetOutputCurrentType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]
HRESULT CPolarEffect::GetOutputCurrentType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType ** | ppType |
 | ) |  |  | [private]

Definition at line 883 of file PolarEffect.cpp.

{
    if (ppType == NULL)
    {
        return E_POINTER;
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        hr = MF_E_INVALIDSTREAMNUMBER;
    }
    else if (!m_pOutputType)
    {
        hr = MF_E_TRANSFORM_TYPE_NOT_SET;
    }
    else
    {
        *ppType = m_pOutputType;
        (*ppType)->AddRef();
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CPolarEffect::GetOutputStatus ( DWORD * pdwFlags ) [private]
HRESULT CPolarEffect::GetOutputStatus ( DWORD * pdwFlags ) [private]

Definition at line 968 of file PolarEffect.cpp.

{
    if (pdwFlags == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    // The MFT can produce an output sample if (and only if) there an input sample.
    if (m_pSample != NULL)
    {
        *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
    }
    else
    {
        *pdwFlags = 0;
    }

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

HRESULT CPolarEffect::GetOutputStreamAttributes | ( | DWORD | dwOutputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]

Definition at line 589 of file PolarEffect.cpp.

{
    // This MFT does not support any stream-level attributes, so the method is not implemented.
    return E_NOTIMPL;
}

STDMETHODIMP CPolarEffect::GetOutputStreamAttributes | ( | DWORD | dwOutputStreamID,
 |  | IMFAttributes ** | ppAttributes |
 | ) |  |  | [private]
HRESULT CPolarEffect::GetOutputStreamInfo | ( | DWORD | dwOutputStreamID,
 |  | MFT_OUTPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]

Definition at line 503 of file PolarEffect.cpp.

{
    if (pStreamInfo == NULL)
    {
        return E_POINTER;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    // NOTE: This method should succeed even when there is no media type on the
    //       stream. If there is no media type, we only need to fill in the dwFlags
    //       member of MFT_OUTPUT_STREAM_INFO. The other members depend on having a
    //       a valid media type.

    pStreamInfo->dwFlags =
        MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
        MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
        MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;

    if (m_pOutputType == NULL)
    {
        pStreamInfo->cbSize = 0;
    }
    else
    {
        pStreamInfo->cbSize = m_cbImageSize;
    }

    pStreamInfo->cbAlignment = 0;

    LeaveCriticalSection(&m_critSec);
    return S_OK;
}

STDMETHODIMP CPolarEffect::GetOutputStreamInfo | ( | DWORD | dwOutputStreamID,
 |  | MFT_OUTPUT_STREAM_INFO * | pStreamInfo |
 | ) |  |  | [private]
HRESULT CPolarEffect::GetStreamCount | ( | DWORD * | pcInputStreams,
 |  | DWORD * | pcOutputStreams |
 | ) |  |  | [private]

Definition at line 411 of file PolarEffect.cpp.

{
    if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))

    {
        return E_POINTER;
    }

    // This MFT has a fixed number of streams.
    *pcInputStreams = 1;
    *pcOutputStreams = 1;
    return S_OK;
}

STDMETHODIMP CPolarEffect::GetStreamCount | ( | DWORD * | pcInputStreams,
 |  | DWORD * | pcOutputStreams |
 | ) |  |  | [private]
STDMETHODIMP CPolarEffect::GetStreamIDs | ( | DWORD | dwInputIDArraySize,
 |  | DWORD * | pdwInputIDs,
 |  | DWORD | dwOutputIDArraySize,
 |  | DWORD * | pdwOutputIDs |
 | ) |  |  | [private]
HRESULT CPolarEffect::GetStreamIDs | ( | DWORD | dwInputIDArraySize,
 |  | DWORD * | pdwInputIDs,
 |  | DWORD | dwOutputIDArraySize,
 |  | DWORD * | pdwOutputIDs |
 | ) |  |  | [private]

Definition at line 435 of file PolarEffect.cpp.

{
    // It is not required to implement this method if the MFT has a fixed number of
    // streams AND the stream IDs are numbered sequentially from zero (that is, the
    // stream IDs match the stream indexes).

    // In that case, it is OK to return E_NOTIMPL.
    return E_NOTIMPL;
}

HRESULT CPolarEffect::GetStreamLimits | ( | DWORD * | pdwInputMinimum,
 |  | DWORD * | pdwInputMaximum,
 |  | DWORD * | pdwOutputMinimum,
 |  | DWORD * | pdwOutputMaximum |
 | ) |  |  | [private]

Definition at line 382 of file PolarEffect.cpp.

{
    if ((pdwInputMinimum == NULL) ||
        (pdwInputMaximum == NULL) ||
        (pdwOutputMinimum == NULL) ||
        (pdwOutputMaximum == NULL))
    {
        return E_POINTER;
    }

    // This MFT has a fixed number of streams.
    *pdwInputMinimum = 1;
    *pdwInputMaximum = 1;
    *pdwOutputMinimum = 1;
    *pdwOutputMaximum = 1;
    return S_OK;
}

STDMETHODIMP CPolarEffect::GetStreamLimits | ( | DWORD * | pdwInputMinimum,
 |  | DWORD * | pdwInputMaximum,
 |  | DWORD * | pdwOutputMinimum,
 |  | DWORD * | pdwOutputMaximum |
 | ) |  |  | [private]
BOOL CPolarEffect::HasPendingOutput ( ) const [inline, private]

Definition at line 220 of file PolarEffect.h.

{ return m_pSample != NULL; }

BOOL CPolarEffect::HasPendingOutput ( ) const [inline, private]

Definition at line 220 of file PolarEffect.h.

{ return m_pSample != NULL; }

BOOL CPolarEffect::IsValidInputStream ( DWORD dwInputStreamID ) const [inline, private]

Definition at line 223 of file PolarEffect.h.

    {
        return dwInputStreamID == 0;
    }

BOOL CPolarEffect::IsValidInputStream ( DWORD dwInputStreamID ) const [inline, private]

Definition at line 223 of file PolarEffect.h.

    {
        return dwInputStreamID == 0;
    }

BOOL CPolarEffect::IsValidOutputStream ( DWORD dwOutputStreamID ) const [inline, private]

Definition at line 229 of file PolarEffect.h.

    {
        return dwOutputStreamID == 0;
    }

BOOL CPolarEffect::IsValidOutputStream ( DWORD dwOutputStreamID ) const [inline, private]

Definition at line 229 of file PolarEffect.h.

    {
        return dwOutputStreamID == 0;
    }

HRESULT CPolarEffect::OnCheckInputType ( IMFMediaType * pmt ) [private]

Definition at line 1316 of file PolarEffect.cpp.

{
    assert(pmt != NULL);

    HRESULT hr = S_OK;

    // If the output type is set, see if they match.
    if (m_pOutputType != NULL)
    {
        DWORD flags = 0;
        hr = pmt->IsEqual(m_pOutputType, &flags);

        // IsEqual can return S_FALSE. Treat this as failure.
        if (hr != S_OK)
        {
            hr = MF_E_INVALIDMEDIATYPE;
        }
    }
    else
    {
        // Output type is not set. Just check this type.
        hr = OnCheckMediaType(pmt);
    }
    return hr;
}

HRESULT CPolarEffect::OnCheckInputType ( IMFMediaType * pmt ) [private]
HRESULT CPolarEffect::OnCheckMediaType ( IMFMediaType * pmt ) [private]

Definition at line 1375 of file PolarEffect.cpp.

{
    BOOL bFoundMatchingSubtype = FALSE;

    // Major type must be video.
    GUID major_type;
    HRESULT hr = pmt->GetGUID(MF_MT_MAJOR_TYPE, &major_type);
    if (FAILED(hr))
    {
        goto done;
    }

    if (major_type != MFMediaType_Video)
    {
        hr = MF_E_INVALIDMEDIATYPE;
        goto done;
    }

    // Subtype must be one of the subtypes in our global list.

    // Get the subtype GUID.
    GUID subtype;
    hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
    if (FAILED(hr))
    {
        goto done;
    }

    // Look for the subtype in our list of accepted types.
    for (DWORD i = 0; i < ARRAYSIZE(g_MediaSubtypes); i++)
    {
        if (subtype == g_MediaSubtypes[i])
        {
            bFoundMatchingSubtype = TRUE;
            break;
        }
    }

    if (!bFoundMatchingSubtype)
    {
        hr = MF_E_INVALIDMEDIATYPE; // The MFT does not support this subtype.
        goto done;
    }

    // Reject single-field media types.
    UINT32 interlace = MFGetAttributeUINT32(pmt, MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
    if (interlace == MFVideoInterlace_FieldSingleUpper  || interlace == MFVideoInterlace_FieldSingleLower)
    {
        hr = MF_E_INVALIDMEDIATYPE;
    }

done:
    return hr;
}

HRESULT CPolarEffect::OnCheckMediaType ( IMFMediaType * pmt ) [private]
HRESULT CPolarEffect::OnCheckOutputType ( IMFMediaType * pmt ) [private]

Definition at line 1345 of file PolarEffect.cpp.

{
    assert(pmt != NULL);

    HRESULT hr = S_OK;

    // If the input type is set, see if they match.
    if (m_pInputType != NULL)
    {
        DWORD flags = 0;
        hr = pmt->IsEqual(m_pInputType, &flags);

        // IsEqual can return S_FALSE. Treat this as failure.
        if (hr != S_OK)
        {
            hr = MF_E_INVALIDMEDIATYPE;
        }

    }
    else
    {
        // Input type is not set. Just check this type.
        hr = OnCheckMediaType(pmt);
    }
    return hr;
}

HRESULT CPolarEffect::OnCheckOutputType ( IMFMediaType * pmt ) [private]
HRESULT CPolarEffect::OnFlush ( ) [private]

Definition at line 1583 of file PolarEffect.cpp.

{
    // For this MFT, flushing just means releasing the input sample.
    SafeRelease(&m_pSample);
    return S_OK;
}

HRESULT CPolarEffect::OnFlush ( ) [private]
HRESULT CPolarEffect::OnGetPartialType | ( | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppmt |
 | ) |  |  | [private]

Definition at line 1278 of file PolarEffect.cpp.

{
    if (dwTypeIndex >= ARRAYSIZE(g_MediaSubtypes))
    {
        return MF_E_NO_MORE_TYPES;
    }

    IMFMediaType *pmt = NULL;

    HRESULT hr = MFCreateMediaType(&pmt);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = pmt->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = pmt->SetGUID(MF_MT_SUBTYPE, g_MediaSubtypes[dwTypeIndex]);
    if (FAILED(hr))
    {
        goto done;
    }

    *ppmt = pmt;
    (*ppmt)->AddRef();

done:
    SafeRelease(&pmt);
    return hr;
}

HRESULT CPolarEffect::OnGetPartialType | ( | DWORD | dwTypeIndex,
 |  | IMFMediaType ** | ppmt |
 | ) |  |  | [private]
HRESULT CPolarEffect::OnProcessOutput | ( | IMFMediaBuffer * | pIn,
 |  | IMFMediaBuffer * | pOut |
 | ) |  |  | [private]

Definition at line 1524 of file PolarEffect.cpp.

{
    BYTE *pDest = NULL;         // Destination buffer.
    LONG lDestStride = 0;       // Destination stride.

    BYTE *pSrc = NULL;          // Source buffer.
    LONG lSrcStride = 0;        // Source stride.

    // Helper objects to lock the buffers.
    VideoBufferLock inputLock(pIn);
    VideoBufferLock outputLock(pOut);

    // Stride if the buffer does not support IMF2DBuffer
    LONG lDefaultStride = 0;

    HRESULT hr = GetDefaultStride(m_pInputType, &lDefaultStride);
    if (FAILED(hr))
    {
        goto done;
    }

    // Lock the input buffer.
    hr = inputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pSrc, &lSrcStride);
    if (FAILED(hr))
    {
        goto done;
    }

    // Lock the output buffer.
    hr = outputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pDest, &lDestStride);
    if (FAILED(hr))
    {
        goto done;
    }

    // Invoke the image transform function.
    assert (m_pTransformFn != NULL);
    if (m_pTransformFn)
    {
        (*m_pTransformFn)(m_pIndexLookup, pDest, lDestStride, pSrc, lSrcStride, m_imageWidthInPixels, m_imageHeightInPixels);
    }
    else
    {
        hr = E_UNEXPECTED;
        goto done;
    }

    // Set the data size on the output buffer.
    hr = pOut->SetCurrentLength(m_cbImageSize);

    // The VideoBufferLock class automatically unlocks the buffers.
done:
    return hr;
}

HRESULT CPolarEffect::OnProcessOutput | ( | IMFMediaBuffer * | pIn,
 |  | IMFMediaBuffer * | pOut |
 | ) |  |  | [private]
void CPolarEffect::OnSetInputType ( IMFMediaType * pmt ) [private]
void CPolarEffect::OnSetInputType ( IMFMediaType * pmt ) [private]

Definition at line 1435 of file PolarEffect.cpp.

{
    // if pmt is NULL, clear the type.
    // if pmt is non-NULL, set the type.

    SafeRelease(&m_pInputType);
    m_pInputType = pmt;
    if (m_pInputType)
    {
        m_pInputType->AddRef();
    }

    // Update the format information.
    UpdateFormatInfo();
}

void CPolarEffect::OnSetOutputType ( IMFMediaType * pmt ) [private]
void CPolarEffect::OnSetOutputType ( IMFMediaType * pmt ) [private]

Definition at line 1456 of file PolarEffect.cpp.

{
    // If pmt is NULL, clear the type. Otherwise, set the type.

    SafeRelease(&m_pOutputType);
    m_pOutputType = pmt;
    if (m_pOutputType)
    {
        m_pOutputType->AddRef();
    }
}

static __forceinline DOUBLE CPolarEffect::PinchRadius | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 90 of file PolarEffect.h.

{ return sqrt(r*R); };

static __forceinline DOUBLE CPolarEffect::PinchRadius | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 90 of file PolarEffect.h.

{ return sqrt(r*R); };

HRESULT CPolarEffect::ProcessEvent | ( | DWORD | dwInputStreamID,
 |  | IMFMediaEvent * | pEvent |
 | ) |  |  | [private]

Definition at line 1012 of file PolarEffect.cpp.

{
    // This MFT does not handle any stream events, so the method can
    // return E_NOTIMPL. This tells the pipeline that it can stop
    // sending any more events to this MFT.
    return E_NOTIMPL;
}

STDMETHODIMP CPolarEffect::ProcessEvent | ( | DWORD | dwInputStreamID,
 |  | IMFMediaEvent * | pEvent |
 | ) |  |  | [private]
STDMETHODIMP CPolarEffect::ProcessInput | ( | DWORD | dwInputStreamID,
 |  | IMFSample * | pSample,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
HRESULT CPolarEffect::ProcessInput | ( | DWORD | dwInputStreamID,
 |  | IMFSample * | pSample,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 1093 of file PolarEffect.cpp.

{
    // Check input parameters.
    if (pSample == NULL)
    {
        return E_POINTER;
    }

    if (dwFlags != 0)
    {
        return E_INVALIDARG; // dwFlags is reserved and must be zero.
    }

    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critSec);

    // Validate the input stream number.
    if (!IsValidInputStream(dwInputStreamID))
    {
        hr = MF_E_INVALIDSTREAMNUMBER;
        goto done;
    }

    // Check for valid media types.
    // The client must set input and output types before calling ProcessInput.
    if (!m_pInputType || !m_pOutputType)
    {
        hr = MF_E_NOTACCEPTING;
        goto done;
    }

    // Check if an input sample is already queued.
    if (m_pSample != NULL)
    {
        hr = MF_E_NOTACCEPTING;   // We already have an input sample.
        goto done;
    }

    // Initialize streaming.
    hr = BeginStreaming();
    if (FAILED(hr))
    {
        goto done;
    }

    // Cache the sample. We do the actual work in ProcessOutput.
    m_pSample = pSample;
    pSample->AddRef();  // Hold a reference count on the sample.

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CPolarEffect::ProcessMessage | ( | MFT_MESSAGE_TYPE | eMessage,
 |  | ULONG_PTR | ulParam |
 | ) |  |  | [private]
HRESULT CPolarEffect::ProcessMessage | ( | MFT_MESSAGE_TYPE | eMessage,
 |  | ULONG_PTR | ulParam |
 | ) |  |  | [private]

Definition at line 1028 of file PolarEffect.cpp.

{
    EnterCriticalSection(&m_critSec);

    HRESULT hr = S_OK;

    switch (eMessage)
    {
    case MFT_MESSAGE_COMMAND_FLUSH:
        // Flush the MFT.
        hr = OnFlush();
        break;

    case MFT_MESSAGE_COMMAND_DRAIN:
        // Drain: Tells the MFT to reject further input until all pending samples are
        // processed. That is our default behavior already, so there is nothing to do.
        //
        // For a decoder that accepts a queue of samples, the MFT might need to drain
        // the queue in response to this command.
    break;

    case MFT_MESSAGE_SET_D3D_MANAGER:
        // Sets a pointer to the IDirect3DDeviceManager9 interface.

        // The pipeline should never send this message unless the MFT sets the MF_SA_D3D_AWARE
        // attribute set to TRUE. Because this MFT does not set MF_SA_D3D_AWARE, it is an error
        // to send the MFT_MESSAGE_SET_D3D_MANAGER message to the MFT. Return an error code in
        // this case.

        // NOTE: If this MFT were D3D-enabled, it would cache the IDirect3DDeviceManager9
        // pointer for use during streaming.

        hr = E_NOTIMPL;
        break;

    case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
        hr = BeginStreaming();
        break;

    case MFT_MESSAGE_NOTIFY_END_STREAMING:
        hr = EndStreaming();
        break;

    // The next two messages do not require any action from this MFT.

    case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
        break;

    case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
        break;
    }

    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CPolarEffect::ProcessOutput | ( | DWORD | dwFlags,
 |  | DWORD | cOutputBufferCount,
 |  | MFT_OUTPUT_DATA_BUFFER * | pOutputSamples,
 |  | DWORD * | pdwStatus |
 | ) |  |  | [private]

Definition at line 1158 of file PolarEffect.cpp.

{
    // Check input parameters...

    // This MFT does not accept any flags for the dwFlags parameter.

    // The only defined flag is MFT_PROCESS_OUTPUT_DISCARD_WHEN_NO_BUFFER. This flag
    // applies only when the MFT marks an output stream as lazy or optional. But this
    // MFT has no lazy or optional streams, so the flag is not valid.

    if (dwFlags != 0)
    {
        return E_INVALIDARG;
    }

    if (pOutputSamples == NULL || pdwStatus == NULL)
    {
        return E_POINTER;
    }

    // There must be exactly one output buffer.
    if (cOutputBufferCount != 1)
    {
        return E_INVALIDARG;
    }

    // It must contain a sample.
    if (pOutputSamples[0].pSample == NULL)
    {
        return E_INVALIDARG;
    }

    HRESULT hr = S_OK;

    IMFMediaBuffer *pInput = NULL;
    IMFMediaBuffer *pOutput = NULL;

    EnterCriticalSection(&m_critSec);

    // There must be an input sample available for processing.
    if (m_pSample == NULL)
    {
        hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
        goto done;
    }

    // Initialize streaming.

    hr = BeginStreaming();
    if (FAILED(hr))
    {
        goto done;
    }

    // Get the input buffer.
    hr = m_pSample->ConvertToContiguousBuffer(&pInput);
    if (FAILED(hr))
    {
        goto done;
    }

    // Get the output buffer.
    hr = pOutputSamples[0].pSample->ConvertToContiguousBuffer(&pOutput);
    if (FAILED(hr))
    {
        goto done;
    }

    hr = OnProcessOutput(pInput, pOutput);
    if (FAILED(hr))
    {
        goto done;
    }

    // Set status flags.
    pOutputSamples[0].dwStatus = 0;
    *pdwStatus = 0;

    // Copy the duration and time stamp from the input sample, if present.

    LONGLONG hnsDuration = 0;
    LONGLONG hnsTime = 0;

    if (SUCCEEDED(m_pSample->GetSampleDuration(&hnsDuration)))
    {
        hr = pOutputSamples[0].pSample->SetSampleDuration(hnsDuration);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    if (SUCCEEDED(m_pSample->GetSampleTime(&hnsTime)))
    {
        hr = pOutputSamples[0].pSample->SetSampleTime(hnsTime);
    }

done:
    SafeRelease(&m_pSample);   // Release our input sample.
    SafeRelease(&pInput);
    SafeRelease(&pOutput);
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CPolarEffect::ProcessOutput | ( | DWORD | dwFlags,
 |  | DWORD | cOutputBufferCount,
 |  | MFT_OUTPUT_DATA_BUFFER * | pOutputSamples,
 |  | DWORD * | pdwStatus |
 | ) |  |  | [private]
STDMETHOD() CPolarEffect::RuntimeClassInitialize ( ) [private]
STDMETHODIMP CPolarEffect::RuntimeClassInitialize ( ) [private]

Definition at line 290 of file PolarEffect.cpp.

{
    // Create the attribute store.
    return MFCreateAttributes(&m_pAttributes, 3);
}

STDMETHODIMP CPolarEffect::SetInputType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
HRESULT CPolarEffect::SetInputType | ( | DWORD | dwInputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 722 of file PolarEffect.cpp.

{
    // Validate flags.
    if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidInputStream(dwInputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    // Does the caller want us to set the type, or just test it?
    BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);

    // If we have an input sample, the client cannot change the type now.
    if (HasPendingOutput())
    {
        hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
        goto done;
    }

    // Validate the type, if non-NULL.
    if (pType)
    {
        hr = OnCheckInputType(pType);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    // The type is OK. Set the type, unless the caller was just testing.
    if (bReallySet)
    {
        OnSetInputType(pType);

        // When the type changes, end streaming.
        hr = EndStreaming();
    }

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

HRESULT CPolarEffect::SetOutputBounds | ( | LONGLONG | hnsLowerBound,
 |  | LONGLONG | hnsUpperBound |
 | ) |  |  | [private]

Definition at line 997 of file PolarEffect.cpp.

{
    // Implementation of this method is optional.
    return E_NOTIMPL;
}

STDMETHODIMP CPolarEffect::SetOutputBounds | ( | LONGLONG | hnsLowerBound,
 |  | LONGLONG | hnsUpperBound |
 | ) |  |  | [private]
HRESULT CPolarEffect::SetOutputType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]

Definition at line 784 of file PolarEffect.cpp.

{
    // Validate flags.
    if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
    {
        return E_INVALIDARG;
    }

    EnterCriticalSection(&m_critSec);

    if (!IsValidOutputStream(dwOutputStreamID))
    {
        LeaveCriticalSection(&m_critSec);
        return MF_E_INVALIDSTREAMNUMBER;
    }

    HRESULT hr = S_OK;

    // Does the caller want us to set the type, or just test it?
    BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);

    // If we have an input sample, the client cannot change the type now.
    if (HasPendingOutput())
    {
        hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
        goto done;
    }

    // Validate the type, if non-NULL.
    if (pType)
    {
        hr = OnCheckOutputType(pType);
        if (FAILED(hr))
        {
            goto done;
        }
    }

    // The type is OK. Set the type, unless the caller was just testing.
    if (bReallySet)
    {
        OnSetOutputType(pType);

        // When the type changes, end streaming.
        hr = EndStreaming();
    }

done:
    LeaveCriticalSection(&m_critSec);
    return hr;
}

STDMETHODIMP CPolarEffect::SetOutputType | ( | DWORD | dwOutputStreamID,
 |  | IMFMediaType * | pType,
 |  | DWORD | dwFlags |
 | ) |  |  | [private]
STDMETHODIMP CPolarEffect::SetProperties ( ABI::Windows::Foundation::Collections::IPropertySet * pConfiguration ) [private]
HRESULT CPolarEffect::SetProperties ( ABI::Windows::Foundation::Collections::IPropertySet * pConfiguration ) [private]

Definition at line 302 of file PolarEffect.cpp.

{
    HRESULT hr = S_OK;

    if(pConfiguration)
    {
        Microsoft::WRL::ComPtr<IInspectable> spInsp;
        Microsoft::WRL::ComPtr<ABI::Windows::Foundation::Collections::IMap<HSTRING, IInspectable *>> spSetting;
        Microsoft::WRL::ComPtr<ABI::Windows::Foundation::IPropertyValue> spPropVal;

        hr = pConfiguration->QueryInterface(IID_PPV_ARGS(&spSetting));
        if (FAILED(hr))
        {
            hr = E_FAIL;
            goto done;
        }

        HStringReference strKey(L"effect");
        hr = spSetting->Lookup(strKey.Get(), spInsp.ReleaseAndGetAddressOf());
        if(FAILED(hr))
        {
            hr = E_INVALIDARG;
            goto done;
        }

        hr = spInsp.As(&spPropVal);
        if(FAILED(hr))
        {
            hr = E_INVALIDARG;
            goto done;
        }

        HString strEffectName;
        hr = spPropVal->GetString(strEffectName.GetAddressOf());
        if(FAILED(hr))
        {
            hr = E_INVALIDARG;
            goto done;
        }

        LPCWSTR pszEffectName = WindowsGetStringRawBuffer(strEffectName.Get(), nullptr);
        if (pszEffectName == nullptr)
        {
            hr = E_INVALIDARG;
            goto done;
        }

        if (wcscmp(pszEffectName, L"Fisheye") == 0)
        {
            m_pRadiusTransformFn = CPolarEffect::FisheyeRadius;
            m_pThetaTransformFn = CPolarEffect::DefaultTheta;
        }
        else if (wcscmp(pszEffectName, L"Pinch") == 0)
        {
            m_pRadiusTransformFn = CPolarEffect::PinchRadius;
            m_pThetaTransformFn = CPolarEffect::DefaultTheta;
        }
        else if (wcscmp(pszEffectName, L"Warp") == 0)
        {
            m_pRadiusTransformFn = CPolarEffect::DefaultRadius;
            m_pThetaTransformFn = CPolarEffect::WarpTheta;
        }
        else
        {
            hr = E_INVALIDARG;
            goto done;
        }
    }

done:
    return hr;
}

HRESULT CPolarEffect::UpdateFormatInfo ( ) [private]

Definition at line 1594 of file PolarEffect.cpp.

{
    HRESULT hr = S_OK;

    GUID subtype = GUID_NULL;

    m_imageWidthInPixels = 0;
    m_imageHeightInPixels = 0;
    m_cbImageSize = 0;

    m_pTransformFn = NULL;

    if (m_pInputType != NULL)
    {
        hr = m_pInputType->GetGUID(MF_MT_SUBTYPE, &subtype);
        if (FAILED(hr))
        {
            goto done;
        }
        if (subtype == MFVideoFormat_YUY2)
        {
            m_pTransformFn = TransformImage_YUY2;
        }
        else if (subtype == MFVideoFormat_UYVY)
        {
            m_pTransformFn = TransformImage_UYVY;
        }
        else if (subtype == MFVideoFormat_NV12)
        {
            m_pTransformFn = TransformImage_NV12;
        }
        else
        {
            hr = E_UNEXPECTED;
            goto done;
        }

        hr = MFGetAttributeSize(m_pInputType, MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);
        if (FAILED(hr))
        {
            goto done;
        }

        // Calculate the image size (not including padding)
        hr = GetImageSize(subtype.Data1, m_imageWidthInPixels, m_imageHeightInPixels, &m_cbImageSize);
    }

done:
    return hr;
}

HRESULT CPolarEffect::UpdateFormatInfo ( ) [private]
static __forceinline DOUBLE CPolarEffect::WarpTheta | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 92 of file PolarEffect.h.

{ return theta + r / R; };

static __forceinline DOUBLE CPolarEffect::WarpTheta | ( | DOUBLE | r,
 |  | DOUBLE | R,
 |  | DOUBLE | theta |
 | ) |  |  | [inline, static, private]

Definition at line 92 of file PolarEffect.h.

{ return theta + r / R; };

Member Data Documentation

bool CPolarEffect::m_bStreamingInitialized [private]

Definition at line 253 of file PolarEffect.h.

DWORD CPolarEffect::m_cbImageSize [private]

Definition at line 261 of file PolarEffect.h.

CRITICAL_SECTION CPolarEffect::m_critSec [private]

Definition at line 250 of file PolarEffect.h.

UINT32 CPolarEffect::m_imageHeightInPixels [private]

Definition at line 260 of file PolarEffect.h.

UINT32 CPolarEffect::m_imageWidthInPixels [private]

Definition at line 259 of file PolarEffect.h.

IMFAttributes * CPolarEffect::m_pAttributes [private]

Definition at line 263 of file PolarEffect.h.

UINT32 * CPolarEffect::m_pIndexLookup [private]

Definition at line 269 of file PolarEffect.h.

IMFMediaType * CPolarEffect::m_pInputType [private]

Definition at line 255 of file PolarEffect.h.

IMFMediaType * CPolarEffect::m_pOutputType [private]

Definition at line 256 of file PolarEffect.h.

PolarTransformer CPolarEffect::m_pRadiusTransformFn [private]

Definition at line 272 of file PolarEffect.h.

IMFSample * CPolarEffect::m_pSample [private]

Definition at line 254 of file PolarEffect.h.

PolarTransformer CPolarEffect::m_pThetaTransformFn [private]

Definition at line 273 of file PolarEffect.h.

IMAGE_TRANSFORM_FN CPolarEffect::m_pTransformFn [private]

Definition at line 266 of file PolarEffect.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Polar/PolarEffect.h
  • Media extensions/C++/MediaExtensions/Polar/PolarEffect.h
  • Media extensions/C#,C++/MediaExtensions/Polar/PolarEffect.cpp
  • Media extensions/C++/MediaExtensions/Polar/PolarEffect.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CppSamplesUtils::SuspensionManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CppSamplesUtils
  • CppSamplesUtils::SuspensionManager
Static Public Member Functions

CppSamplesUtils::SuspensionManager Class Reference

#include "CppSamplesUtils.h"

List of all members.

Static Public Member Functions

static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static
Windows::Foundation::Collections::PropertySet 		SessionState ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartRestoreTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()
static concurrency::task< void > | StartSaveTask ()

Detailed Description

Definition at line 30 of file CppSamplesUtils.h.

Member Function Documentation

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static Windows::Foundation::Collections::PropertySet CppSamplesUtils::SuspensionManager::SessionState ( ) [inline, static]

Definition at line 33 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation::Collections;
            using namespace Details;

            if (sessionState == nullptr)
            {
                sessionState = ref new PropertySet();
            }
            return sessionState;
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartRestoreTask ( ) [inline, static]

Definition at line 45 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            auto state = SessionState();
            state->Clear();

            concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
            return getFileTask.then([=](StorageFile^ file)
            {
                return DeserializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file cppsamplesutils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

static concurrency::task<void> CppSamplesUtils::SuspensionManager::StartSaveTask ( ) [inline, static]

Definition at line 62 of file CppSamplesUtils.h.

        {
            using namespace Windows::Foundation;
            using namespace Windows::Storage;
            using namespace Windows::Storage::Streams;
            using namespace Details;

            concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
            return createFileTask.then([=](StorageFile^ file)
            {
                return SerializeSessionState(file);
            });
        }

The documentation for this class was generated from the following files:
  • Account picture name/C++/sample-utils/CppSamplesUtils.h
  • Application resources and localization/C++/CppSamplesUtils.h
  • Association launching/C++/CppSamplesUtils.h
  • Clipboard app/C++/CppSamplesUtils.h
  • Clipboard app/C++/sample-utils/CppSamplesUtils.h
  • Configure keys for media/C++/sample-utils/CppSamplesUtils.h
  • Contact Picker app/C++/Sample-Utils/CppSamplesUtils.h
  • Credential picker/C++/CppSamplesUtils.h
  • DatagramSocket/C++/sample-utils/CppSamplesUtils.h
  • Edge gesture invocation/C++/CppSamplesUtils.h
  • Input Device capabilities/C++/cppsamplesutils.h
  • Language font mapping/C++/CppSamplesUtils.h
  • Lock screen apps/C#,C++/CppSamplesUtils.h
  • Media extensions/C++/CppSamplesUtils.h
  • Playback Manager Companion/C++/sample-utils/CppSamplesUtils.h
  • Print/C++/cppsamplesutils.h
  • Proximity/C++/sample-utils/CppSamplesUtils.h
  • Raw notifications/C++/MainAppSample/CppSamplesUtils.h
  • Real-time communication/C++/sample-utils/CppSamplesUtils.h
  • Scheduled notifications/C#,C++/CppSamplesUtils.h
  • Secondary tiles/C#,C++/Sample-Utils/cppsamplesutils.h
  • Sharing content target app/C++/sample-utils/CppSamplesUtils.h
  • StreamSocket/C++/sample-utils/CppSamplesUtils.h
  • Toast notifications/C#,C++/CppSamplesUtils.h
  • UI contrast and settings/C++/cppsamplesutils.h
  • XAML AppBar control/C++/Sample-Utils/CppSamplesUtils.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CredentialPickerCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CredentialPickerCPP
  • CredentialPickerCPP::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

CredentialPickerCPP::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
Platform::String | ConvertResolution (Windows::Graphics::Display::ResolutionScale scale)
Platform::String | ConvertViewState (Windows::UI::ViewManagement::ApplicationViewState state)
void | DoNavigation (Windows::UI::Xaml::Interop::TypeName inPageType, Windows::UI::Xaml::Controls::Frame^inFrame, Windows::UI::Xaml::Interop::TypeName outPageType, Windows::UI::Xaml::Controls::Frame^outFrame)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
void | NotifyUserFromAsyncThread (Platform::String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioInput3 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()
ScenarioOutput3 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~MainPage ()
~ScenarioInput1 ()
~ScenarioInput2 ()
~ScenarioInput3 ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
~ScenarioOutput3 ()
void | CheckResolutionAndViewState ()
void | CheckResolutionAndViewState ()
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | inputFrameNavigated (Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | Launch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Launch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Launch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | outputFrameNavigated (Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | Page_Loaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Page_Loaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | Protocol_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | SetError (Platform::String^errorText)
void | SetError (Platform::String^errorText)
void | SetError (Platform::String^errorText)
void | SetFeatureName (Platform::String^strFeature)
void | SetPasswordExplainVisibility (bool isShown)
void | SetResult (Windows::Security::Credentials::UI::CredentialPickerResults^res)
void | SetResult (Windows::Security::Credentials::UI::CredentialPickerResults^res)
void | SetResult (Windows::Security::Credentials::UI::CredentialPickerResults^res)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::Foundation::EventRegistrationToken | _frameLoadedToken
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _layoutHandlerToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
MainPage | rootPage

Detailed Description

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

CredentialPickerCPP::sealed::~MainPage ( ) [private]
CredentialPickerCPP::sealed::~ScenarioInput1 ( ) [private]
CredentialPickerCPP::sealed::~ScenarioInput2 ( ) [private]
CredentialPickerCPP::sealed::~ScenarioInput3 ( ) [private]
CredentialPickerCPP::sealed::~ScenarioList ( ) [private]
CredentialPickerCPP::sealed::~ScenarioOutput1 ( ) [private]
CredentialPickerCPP::sealed::~ScenarioOutput2 ( ) [private]
CredentialPickerCPP::sealed::~ScenarioOutput3 ( ) [private]

Member Function Documentation

CredentialPickerCPP::sealed::App ( )
void CredentialPickerCPP::sealed::CheckResolutionAndViewState ( ) [private]
void CredentialPickerCPP::sealed::CheckResolutionAndViewState ( ) [private]
Platform::String CredentialPickerCPP::sealed::ConvertResolution ( Windows::Graphics::Display::ResolutionScale scale )
Platform::String CredentialPickerCPP::sealed::ConvertViewState ( Windows::UI::ViewManagement::ApplicationViewState state )
void CredentialPickerCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void CredentialPickerCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void CredentialPickerCPP::sealed::DoNavigation | ( | Windows::UI::Xaml::Interop::TypeName | inPageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | inFrame,
 |  | Windows::UI::Xaml::Interop::TypeName | outPageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | outFrame
 | ) |  |
void CredentialPickerCPP::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::Launch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::Launch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::Launch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
CredentialPickerCPP::sealed::MainPage ( )
void CredentialPickerCPP::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void CredentialPickerCPP::sealed::NotifyUserFromAsyncThread | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void CredentialPickerCPP::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void CredentialPickerCPP::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void CredentialPickerCPP::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::Protocol_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void CredentialPickerCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
CredentialPickerCPP::sealed::ScenarioInput1 ( )
CredentialPickerCPP::sealed::ScenarioInput2 ( )
CredentialPickerCPP::sealed::ScenarioInput3 ( )
CredentialPickerCPP::sealed::ScenarioList ( )
CredentialPickerCPP::sealed::ScenarioOutput1 ( )
CredentialPickerCPP::sealed::ScenarioOutput2 ( )
CredentialPickerCPP::sealed::ScenarioOutput3 ( )
void CredentialPickerCPP::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void CredentialPickerCPP::sealed::SetError ( Platform::String^ errorText ) [private]
void CredentialPickerCPP::sealed::SetError ( Platform::String^ errorText ) [private]
void CredentialPickerCPP::sealed::SetError ( Platform::String^ errorText ) [private]
void CredentialPickerCPP::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
void CredentialPickerCPP::sealed::SetPasswordExplainVisibility ( bool isShown ) [private]
void CredentialPickerCPP::sealed::SetResult ( Windows::Security::Credentials::UI::CredentialPickerResults^ res ) [private]
void CredentialPickerCPP::sealed::SetResult ( Windows::Security::Credentials::UI::CredentialPickerResults^ res ) [private]
void CredentialPickerCPP::sealed::SetResult ( Windows::Security::Credentials::UI::CredentialPickerResults^ res ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken CredentialPickerCPP::sealed::_displayHandlerToken [private]

Definition at line 58 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::_frameLoadedToken [private]

Definition at line 35 of file ScenarioInput1.xaml.h.

Windows::UI::Xaml::Controls::Frame CredentialPickerCPP::sealed::_inputFrame [private]

Definition at line 55 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken CredentialPickerCPP::sealed::_inputFrameLoadedToken [private]

Definition at line 62 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken CredentialPickerCPP::sealed::_layoutHandlerToken [private]

Definition at line 59 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken CredentialPickerCPP::sealed::_logicalDpiChangedToken [private]

Definition at line 61 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame CredentialPickerCPP::sealed::_outputFrame [private]

Definition at line 56 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken CredentialPickerCPP::sealed::_outputFrameLoadedToken [private]

Definition at line 63 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken CredentialPickerCPP::sealed::_pageLoadedHandlerToken [private]

Definition at line 60 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame CredentialPickerCPP::sealed::_scenariosFrame [private]

Definition at line 54 of file MainPage.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 32 of file ScenarioInput1.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> CredentialPickerCPP::sealed::OutputFrameLoaded

Definition at line 45 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Credential picker/C++/App.xaml.h
  • Credential picker/C++/MainPage.xaml.h
  • Credential picker/C++/ScenarioInput1.xaml.h
  • Credential picker/C++/ScenarioInput2.xaml.h
  • Credential picker/C++/ScenarioInput3.xaml.h
  • Credential picker/C++/ScenarioList.xaml.h
  • Credential picker/C++/ScenarioOutput1.xaml.h
  • Credential picker/C++/ScenarioOutput2.xaml.h
  • Credential picker/C++/ScenarioOutput3.xaml.h
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CritSec Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

CritSec Class Reference

#include "CritSec.h"

List of all members.

Public Member Functions

CritSec ()
CritSec ()
CritSec ()
~CritSec ()
~CritSec ()
~CritSec ()
_Acquires_lock_ (m_criticalSection) void Lock()
_Acquires_lock_ (m_criticalSection) void Lock()
_Acquires_lock_ (m_criticalSection) void Lock()
_Releases_lock_ (m_criticalSection) void Unlock()
_Releases_lock_ (m_criticalSection) void Unlock()
_Releases_lock_ (m_criticalSection) void Unlock()

Public Attributes

CRITICAL_SECTION m_criticalSection

Detailed Description

Definition at line 8 of file CritSec.h.

Constructor & Destructor Documentation

CritSec::CritSec ( ) [inline]

Definition at line 13 of file CritSec.h.

    {
        InitializeCriticalSectionEx(&m_criticalSection, 100, 0);
    }

CritSec::~CritSec ( ) [inline]

Definition at line 18 of file CritSec.h.

    {
        DeleteCriticalSection(&m_criticalSection);
    }

CritSec::CritSec ( ) [inline]

Definition at line 13 of file CritSec.h.

    {
        InitializeCriticalSectionEx(&m_criticalSection, 100, 0);
    }

CritSec::~CritSec ( ) [inline]

Definition at line 18 of file CritSec.h.

    {
        DeleteCriticalSection(&m_criticalSection);
    }

CritSec::CritSec ( ) [inline]

Definition at line 13 of file CritSec.h.

    {
        InitializeCriticalSectionEx(&m_criticalSection, 100, 0);
    }

CritSec::~CritSec ( ) [inline]

Definition at line 18 of file CritSec.h.

    {
        DeleteCriticalSection(&m_criticalSection);
    }

Member Function Documentation

CritSec::_Acquires_lock_ ( m_criticalSection ) [inline]

Definition at line 23 of file CritSec.h.

    {
        EnterCriticalSection(&m_criticalSection);
    }

CritSec::_Acquires_lock_ ( m_criticalSection ) [inline]

Definition at line 23 of file CritSec.h.

    {
        EnterCriticalSection(&m_criticalSection);
    }

CritSec::_Acquires_lock_ ( m_criticalSection ) [inline]

Definition at line 23 of file CritSec.h.

    {
        EnterCriticalSection(&m_criticalSection);
    }

CritSec::_Releases_lock_ ( m_criticalSection ) [inline]

Definition at line 29 of file CritSec.h.

    {
        LeaveCriticalSection(&m_criticalSection);
    }

CritSec::_Releases_lock_ ( m_criticalSection ) [inline]

Definition at line 29 of file CritSec.h.

    {
        LeaveCriticalSection(&m_criticalSection);
    }

CritSec::_Releases_lock_ ( m_criticalSection ) [inline]

Definition at line 29 of file CritSec.h.

    {
        LeaveCriticalSection(&m_criticalSection);
    }

Member Data Documentation

CRITICAL_SECTION CritSec::m_criticalSection

Definition at line 11 of file CritSec.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/CritSec.h
  • Media extensions/C++/MediaExtensions/Common/CritSec.h
  • Real-time communication/C++/MediaExtensions/Common/CritSec.h
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CStreamState Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

CStreamState Class Reference

#include "decoder.h"

List of all members.

Public Member Functions

CStreamState ()
CStreamState ()
bool | NextByte (BYTE bData)
bool | NextByte (BYTE bData)
REFERENCE_TIME | PictureTime (DWORD *pdwTimeCode) const
REFERENCE_TIME | PictureTime (DWORD *pdwTimeCode) const
void | Reset ()
void | Reset ()
void | TimeStamp (REFERENCE_TIME rt)
void | TimeStamp (REFERENCE_TIME rt)

Private Attributes

struct {
bool bValid
REFERENCE_TIME rt
} m_arTS [4]
struct {
bool bValid
REFERENCE_TIME rt
} m_arTS [4]
BYTE | m_bGOPData [4]
DWORD | m_cbBytes
DWORD | m_dwNextTimeCode
DWORD | m_dwTimeCode
REFERENCE_TIME | m_rt

Detailed Description

Definition at line 48 of file decoder.h.

Constructor & Destructor Documentation

CStreamState::CStreamState ( ) [inline]

Definition at line 69 of file decoder.h.

    {
        Reset();
    }

CStreamState::CStreamState ( ) [inline]

Definition at line 69 of file decoder.h.

    {
        Reset();
    }

Member Function Documentation

bool CStreamState::NextByte ( BYTE bData )

Definition at line 1307 of file decoder.cpp.

{
    assert(m_arTS[0].bValid);

    switch (m_cbBytes)
    {
        case 0:
            if (bData == 0) {
                m_cbBytes++;
            }
            return false;

        case 1:
            if (bData == 0) {
                m_cbBytes++;
            } else {
                m_cbBytes = 0;

                //  Pick up new timestamp if there was one
                if (m_arTS[1].bValid) {
                    m_arTS[0].rt = m_arTS[1].rt;
                    m_arTS[1].bValid = false;
                }
            }
            return false;

        case 2:
            if (bData == 1) {
                m_cbBytes++;
            } else {
                if (bData == 0) {
                   if (m_arTS[1].bValid) {
                       m_arTS[0].rt = m_arTS[1].rt;
                       m_arTS[1].bValid = false;
                   }
                   if (m_arTS[2].bValid) {
                       m_arTS[1] = m_arTS[2];
                       m_arTS[2].bValid = false;
                   }
                } else {
                    //  Not 0 or 1, revert
                    m_cbBytes = 0;

                    //  and pick up latest timestamp
                    if (m_arTS[1].bValid) {
                        m_arTS[0].rt = m_arTS[1].rt;
                        m_arTS[1].bValid = false;
                    }
                    if (m_arTS[2].bValid) {
                        m_arTS[0].rt = m_arTS[2].rt;
                        m_arTS[2].bValid = false;
                    }
                }
            }
            return false;

        case 3:
        {
            //  It's a start code
            //  Return the timestamp and reset everything
            m_rt = m_arTS[0].rt;

            //  If it's a picture start code can't use this timestamp again.
            if (0 == bData) {
                m_arTS[0].rt = INVALID_TIME;
                m_cbBytes = 0;
            }

            //  Catch up and clean out timestamps
            for (int i = 1; i < 4; i++) {
                if (m_arTS[i].bValid) {
                    m_arTS[0].rt = m_arTS[i].rt;
                    m_arTS[i].bValid = false;
                }
            }

            // Picture start code?
            if (0 == bData) {
                m_cbBytes = 0;
                m_dwTimeCode = m_dwNextTimeCode;
                m_dwNextTimeCode++;
                return true;
            } else {
                //  Is it a GOP start code?
                if (bData == 0xb8) {
                    m_cbBytes++;
                } else {
                    m_cbBytes = 0;
                }
                return false;
            }
        }

        case 4:
        case 5:
        case 6:
        case 7:
            m_bGOPData[m_cbBytes - 4] = bData;
            m_cbBytes++;

            if (m_cbBytes == 8) {
                m_cbBytes = 0;
                m_dwNextTimeCode = ((DWORD)m_bGOPData[0] << 17) +
                                   ((DWORD)m_bGOPData[1] << 9) +
                                   ((DWORD)m_bGOPData[2] << 1) +
                                   ((DWORD)m_bGOPData[3] >> 7);
            }
            return false;
    }

    // Should never reach here
    return false;
};

bool CStreamState::NextByte ( BYTE bData )
REFERENCE_TIME CStreamState::PictureTime ( DWORD * pdwTimeCode ) const [inline]

Definition at line 79 of file decoder.h.

    {
        *pdwTimeCode = m_dwTimeCode;
        return m_rt;
    }

REFERENCE_TIME CStreamState::PictureTime ( DWORD * pdwTimeCode ) const [inline]

Definition at line 79 of file decoder.h.

    {
        *pdwTimeCode = m_dwTimeCode;
        return m_rt;
    }

void CStreamState::Reset ( )
void CStreamState::Reset ( )

Definition at line 1297 of file decoder.cpp.

{
    m_cbBytes = 0;
    m_dwNextTimeCode = 0;

    for (int i = 0; i < 4; i++) {
        m_arTS[i].bValid = false;
    }
}

void CStreamState::TimeStamp ( REFERENCE_TIME rt )

Definition at line 1289 of file decoder.cpp.

{
    DWORD dwIndex = m_cbBytes >= 4 ? 0 : m_cbBytes;

    m_arTS[dwIndex].bValid = true;
    m_arTS[dwIndex].rt = rt;
}

void CStreamState::TimeStamp ( REFERENCE_TIME rt )

Member Data Documentation

bool CStreamState::bValid

Definition at line 56 of file decoder.h.

struct { ... } CStreamState::m_arTS[4] [private]
struct { ... } CStreamState::m_arTS[4] [private]
BYTE CStreamState::m_bGOPData [private]

Definition at line 63 of file decoder.h.

DWORD CStreamState::m_cbBytes [private]

Definition at line 52 of file decoder.h.

DWORD CStreamState::m_dwNextTimeCode [private]

Definition at line 66 of file decoder.h.

DWORD CStreamState::m_dwTimeCode [private]

Definition at line 65 of file decoder.h.

REFERENCE_TIME CStreamState::m_rt [private]

Definition at line 61 of file decoder.h.

REFERENCE_TIME CStreamState::rt

Definition at line 57 of file decoder.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.h
  • Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.h
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.cpp
  • Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CTriColorWindowFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

CTriColorWindowFactory Class Reference

#include "TriColorWindow.h"

List of all members.

Public Member Functions

virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()

Detailed Description

Definition at line 169 of file TriColorWindow.h.

Member Function Documentation

Windows::ApplicationModel::Core::IFrameworkView CTriColorWindowFactory::CreateView ( ) [virtual]

Definition at line 740 of file TriColorWindow.cpp.

{
    return ref new CTriColorWindow();
}

The documentation for this class was generated from the following files:
  • UI Automation core window provider/C++/TriColorWindow.h
  • UI Automation core window provider/C++/TriColorWindow.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CustomDeviceAccess::DeviceAsync Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CustomDeviceAccess
  • CustomDeviceAccess::DeviceAsync
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

CustomDeviceAccess::DeviceAsync Class Reference

An empty page that can be used on its own or navigated to within a Frame.

Inherits SDKTemplate::Common::LayoutAwarePage.

List of all members.

Public Member Functions

DeviceAsync ()

Protected Member Functions

override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

void | ClearBarGraphTable ()
async void | deviceAsyncGet_Click_1 (object sender, RoutedEventArgs e)
void | deviceAsyncSet_Click_1 (object sender, RoutedEventArgs e)
void | UpdateBarGraphTable (bool[] barGraphArray)

Private Attributes

MainPage | rootPage = MainPage.Current

Detailed Description

Definition at line 22 of file Scenario4_DeviceAsync.xaml.cs.

Constructor & Destructor Documentation

CustomDeviceAccess::DeviceAsync::DeviceAsync ( ) [inline]

Definition at line 28 of file Scenario4_DeviceAsync.xaml.cs.

        {
            this.InitializeComponent();
        }

Member Function Documentation

void CustomDeviceAccess::DeviceAsync::ClearBarGraphTable ( ) [inline, private]

Definition at line 96 of file Scenario4_DeviceAsync.xaml.cs.

        {
            barGraphOutput.Inlines.Clear();
        }

async void CustomDeviceAccess::DeviceAsync::deviceAsyncGet_Click_1 | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 74 of file Scenario4_DeviceAsync.xaml.cs.

        {
            if (DeviceList.Current.Fx2Device == null)
            {
                rootPage.NotifyUser("Fx2 device not connected or accessible", NotifyType.ErrorMessage);
                return;
            }

            try
            {
                rootPage.NotifyUser("Getting Fx2 bars", NotifyType.StatusMessage);

                var result = await DeviceList.Current.Fx2Device.GetBarGraphDisplayAsync();
                rootPage.NotifyUser("Got bars value", NotifyType.StatusMessage);
                UpdateBarGraphTable(result.BarGraphDisplay);
            }
            catch (Exception exception)
            {
                rootPage.NotifyUser(exception.Message, NotifyType.ErrorMessage);
            }
        }

void CustomDeviceAccess::DeviceAsync::deviceAsyncSet_Click_1 | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 42 of file Scenario4_DeviceAsync.xaml.cs.

        {
            if (DeviceList.Current.Fx2Device == null)
            {
                rootPage.NotifyUser("Fx2 device not connected or accessible", NotifyType.ErrorMessage);
                return;
            }

            // Get the selector element
            var val = barGraphInput.SelectedIndex;
            bool[] barGraphArray = new bool[8];

            for (var i = 0; i < barGraphArray.Length; i += 1)
            {
                barGraphArray[i] = i < val;
            }

            try
            {
                DeviceList.Current.Fx2Device.SetBarGraphDisplay(barGraphArray);
            }
            catch (Exception exception)
            {
                rootPage.NotifyUser(exception.ToString(), NotifyType.ErrorMessage);
                return;
            }

            ClearBarGraphTable();
            rootPage.NotifyUser("Bar Graph Set to " + val, NotifyType.StatusMessage);
        }

override void CustomDeviceAccess::DeviceAsync::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 38 of file Scenario4_DeviceAsync.xaml.cs.

        {
        }

void CustomDeviceAccess::DeviceAsync::UpdateBarGraphTable ( bool[] barGraphArray ) [inline, private]

Definition at line 101 of file Scenario4_DeviceAsync.xaml.cs.

        {
            var output = barGraphOutput;

            DeviceList.CreateBooleanTable(
                output.Inlines,
                barGraphArray,
                null,
                "Bar Number",
                "Bar State",
                "Lit",
                "Not Lit"
                );
        }

Member Data Documentation

MainPage CustomDeviceAccess::DeviceAsync::rootPage = MainPage.Current [private]

Definition at line 26 of file Scenario4_DeviceAsync.xaml.cs.

The documentation for this class was generated from the following file:
  • Custom driver access/C#,C++/app_cs/Scenario4_DeviceAsync.xaml.cs
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CustomDeviceAccess::DeviceList Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CustomDeviceAccess
  • CustomDeviceAccess::DeviceList
Public Member Functions | Static Public Member Functions | Public Attributes | Properties | Events | Private Member Functions | Static Private Member Functions | Private Attributes

CustomDeviceAccess::DeviceList Class Reference

List of all members.

Public Member Functions

void | StartFx2Watcher ()
void | StopFx2Watcher ()

Static Public Member Functions

static void | CreateBooleanTable (InlineCollection Table, bool[] NewValues, bool[] OldValues, string IndexTitle, string ValueTitle, string TrueValue, string FalseValue)

Public Attributes

bool | WatcherStarted = false

Properties

static DeviceList | Current [get, set]
Samples.Devices.Fx2.Fx2Device | Fx2Device [get, set]
ObservableCollection
< DeviceListEntry > 		Fx2Devices [get]

Events

EventHandler | DeviceClosing

Private Member Functions

DeviceListEntry | FindInList (string id)
void | InitDeviceWatcher ()
async void | OnFx2Added (Windows.Devices.Enumeration.DeviceWatcher sender, Windows.Devices.Enumeration.DeviceInformation devInterface)
async void | OnFx2EnumerationComplete (Windows.Devices.Enumeration.DeviceWatcher sender, object args)
async void | OnFx2Removed (Windows.Devices.Enumeration.DeviceWatcher sender, Windows.Devices.Enumeration.DeviceInformationUpdate devInformation)
void | ResumeDeviceWatcher (object sender, object e)
void | SuspendDeviceWatcher (object sender, SuspendingEventArgs e)

Static Private Member Functions

static | DeviceList ()

Private Attributes

Samples.Devices.Fx2.Fx2Device | m_Fx2Device
ObservableCollection
< DeviceListEntry > 		m_Fx2Devices = new ObservableCollection<DeviceListEntry>()
Windows.Devices.Enumeration.DeviceWatcher | m_Fx2Watcher = null
bool | m_WatcherSuspended = false

Detailed Description

Definition at line 48 of file DeviceList.cs.

Constructor & Destructor Documentation

static CustomDeviceAccess::DeviceList::DeviceList ( ) [inline, static, private]

Definition at line 52 of file DeviceList.cs.

        {
            DeviceList.Current = new DeviceList();
            DeviceList.Current.InitDeviceWatcher();

            // Register for app suspend/resume handlers
            App.Current.Suspending += new SuspendingEventHandler(DeviceList.Current.SuspendDeviceWatcher);
            App.Current.Resuming += DeviceList.Current.ResumeDeviceWatcher;
        }

Member Function Documentation

static void CustomDeviceAccess::DeviceList::CreateBooleanTable | ( | InlineCollection | Table,
 |  | bool[] | NewValues,
 |  | bool[] | OldValues,
 |  | string | IndexTitle,
 |  | string | ValueTitle,
 |  | string | TrueValue,
 |  | string | FalseValue |
 | ) |  |  | [inline, static]

Definition at line 115 of file DeviceList.cs.

        {
            Table.Clear();

            for (var i = 0; i < NewValues.Length; i += 1)
            {
                var line = new Span();
                var block = new Run();
                block.Text = (i + 1).ToString("###");
                line.Inlines.Add(block);

                block = new Run();
                block.Text = "    ";
                line.Inlines.Add(block);

                block = new Run();
                block.Text = NewValues[i] ? TrueValue : FalseValue;

                if ((OldValues != null) && (OldValues[i] != NewValues[i]))
                {
                    var bold = new Bold();
                    bold.Inlines.Add(block);
                    line.Inlines.Add(bold);
                }
                else
                {
                    line.Inlines.Add(block);
                }

                line.Inlines.Add(new LineBreak());

                Table.Add(line);
            }
        }

DeviceListEntry CustomDeviceAccess::DeviceList::FindInList ( string id ) [inline, private]

Definition at line 281 of file DeviceList.cs.

        {
            return m_Fx2Devices.FirstOrDefault(entry => entry.Id == id);
        }

void CustomDeviceAccess::DeviceList::InitDeviceWatcher ( ) [inline, private]

Definition at line 174 of file DeviceList.cs.

        {
            // Define the selector to enumerate all of the fx2 device interface class instances
            var selector = Samples.Devices.Fx2.Fx2Device.GetDeviceSelector();

            // Create a device watcher to look for instances of the fx2 device interface
            m_Fx2Watcher = Windows.Devices.Enumeration.DeviceInformation.CreateWatcher(
                            selector,
                            new string[] { "System.Devices.DeviceInstanceId" }
                            );

            m_Fx2Watcher.Added += OnFx2Added;
            m_Fx2Watcher.Removed += OnFx2Removed;
            m_Fx2Watcher.EnumerationCompleted += OnFx2EnumerationComplete;
        }

async void CustomDeviceAccess::DeviceList::OnFx2Added | ( | Windows.Devices.Enumeration.DeviceWatcher | sender,
 |  | Windows.Devices.Enumeration.DeviceInformation | devInterface |
 | ) |  |  | [inline, private]

Event handler for arrival of Fx2 devices.

Parameters:
sender
devInterface The device interface which was added

Definition at line 195 of file DeviceList.cs.

        {
            await
            MainPage.Current.Dispatcher.RunAsync(
                Windows.UI.Core.CoreDispatcherPriority.Normal,
                () =>
                {
                    MainPage.Current.NotifyUser(String.Format("OnFx2Added: {0}", devInterface.Id), NotifyType.StatusMessage);

                    // search the device list for a device with a matching interface ID
                    DeviceListEntry match = FindInList(devInterface.Id);

                    // If we found a match then mark it as verified and return
                    if (match != null)
                    {
                        match.Matched = true;
                        return;
                    }

                    // Create a new element for this device interface, and queue up the query of its
                    // device information
                    match = new DeviceListEntry(devInterface);

                    // Add the new element to the end of the list of devices
                    m_Fx2Devices.Add(match);
                }
            );
        }

async void CustomDeviceAccess::DeviceList::OnFx2EnumerationComplete | ( | Windows.Devices.Enumeration.DeviceWatcher | sender,
 |  | object | args |
 | ) |  |  | [inline, private]

Event handler for the end of an enumeration/reenumeration started by calling Start on the device watcher.

This culls out any entries in the list which are no longer matched.

Parameters:
sender
args

Definition at line 259 of file DeviceList.cs.

        {
            await
            MainPage.Current.Dispatcher.RunAsync(
                Windows.UI.Core.CoreDispatcherPriority.Normal,
                () =>
                {
                    MainPage.Current.NotifyUser(String.Format("OnFx2EnumerationComplete"), NotifyType.StatusMessage);

                    DeviceListEntry removedDevice;

                    while ((removedDevice = m_Fx2Devices.FirstOrDefault(e => e.Matched == false)) != null)
                    {
                        MainPage.Current.NotifyUser("OnFx2EnumerationComplete: Removing missing device " + removedDevice.Id, NotifyType.StatusMessage);
                        m_Fx2Devices.Remove(removedDevice);
                    }
                }
            );
        }

async void CustomDeviceAccess::DeviceList::OnFx2Removed | ( | Windows.Devices.Enumeration.DeviceWatcher | sender,
 |  | Windows.Devices.Enumeration.DeviceInformationUpdate | devInformation |
 | ) |  |  | [inline, private]

Event handler for the removal of an Fx2 device.

Parameters:
sender
devInformation The device interface that was removed

Definition at line 230 of file DeviceList.cs.

        {
            await
            MainPage.Current.Dispatcher.RunAsync(
                Windows.UI.Core.CoreDispatcherPriority.Normal,
                () =>
                {
                    var deviceId = devInformation.Id;
                    MainPage.Current.NotifyUser(String.Format("OnFx2Removed: {0}", deviceId), NotifyType.StatusMessage);

                    // Search the list of devices for one with a matching ID
                    var match = FindInList(deviceId);
                    if (match != null)
                    {
                        // Remove the matched item
                        MainPage.Current.NotifyUser(String.Format("OnFx2Removed: {0} removed", deviceId), NotifyType.StatusMessage);
                        m_Fx2Devices.Remove(match);
                    }
                }
            );
        }

void CustomDeviceAccess::DeviceList::ResumeDeviceWatcher | ( | object | sender,
 |  | object | e |
 | ) |  |  | [inline, private]

Definition at line 295 of file DeviceList.cs.

        {
            if (m_WatcherSuspended)
            {
                StartFx2Watcher();
                m_WatcherSuspended = false;
            }
        }

void CustomDeviceAccess::DeviceList::StartFx2Watcher ( ) [inline]

Definition at line 94 of file DeviceList.cs.

        {
            MainPage.Current.NotifyUser("starting device watcher", NotifyType.StatusMessage);
            foreach (var entry in m_Fx2Devices)
            {
                entry.Matched = false;
            }

            WatcherStarted = true;
            m_Fx2Watcher.Start();

            return;
        }

void CustomDeviceAccess::DeviceList::StopFx2Watcher ( ) [inline]

Definition at line 108 of file DeviceList.cs.

        {
            MainPage.Current.NotifyUser("stopping fx2 watcher", NotifyType.StatusMessage);
            m_Fx2Watcher.Stop();
            WatcherStarted = false;
        }

void CustomDeviceAccess::DeviceList::SuspendDeviceWatcher | ( | object | sender,
 |  | SuspendingEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 286 of file DeviceList.cs.

        {
            if (WatcherStarted)
            {
                m_WatcherSuspended = WatcherStarted;
                StopFx2Watcher();
            }
        }

Member Data Documentation

Samples.Devices.Fx2.Fx2Device CustomDeviceAccess::DeviceList::m_Fx2Device [private]

The currently opened Fx2 device.

Definition at line 71 of file DeviceList.cs.

ObservableCollection<DeviceListEntry> CustomDeviceAccess::DeviceList::m_Fx2Devices = new ObservableCollection<DeviceListEntry>() [private]

Internal list of devices.

Definition at line 172 of file DeviceList.cs.

Windows.Devices.Enumeration.DeviceWatcher CustomDeviceAccess::DeviceList::m_Fx2Watcher = null [private]

The device watcher that we setup to look for Fx2 devices.

Definition at line 167 of file DeviceList.cs.

bool CustomDeviceAccess::DeviceList::m_WatcherSuspended = false [private]

Definition at line 279 of file DeviceList.cs.

bool CustomDeviceAccess::DeviceList::WatcherStarted = false

Flag to keep track of whether the device watcher has been started.

Definition at line 92 of file DeviceList.cs.

Property Documentation

DeviceList CustomDeviceAccess::DeviceList::Current [static, get, set]

Definition at line 50 of file DeviceList.cs.

Samples.Devices.Fx2.Fx2Device CustomDeviceAccess::DeviceList::Fx2Device [get, set]

The currently opened Fx2 device, wrapped in a property to unregister event handlers when closed.

Definition at line 78 of file DeviceList.cs.

ObservableCollection<DeviceListEntry> CustomDeviceAccess::DeviceList::Fx2Devices [get]

List of Fx2 devices currently attached to the system.

This list can be updated by the PNP watcher.

Definition at line 66 of file DeviceList.cs.

Event Documentation

EventHandler CustomDeviceAccess::DeviceList::DeviceClosing

Definition at line 158 of file DeviceList.cs.

The documentation for this class was generated from the following file:
  • Custom driver access/C#,C++/app_cs/DeviceList.cs
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CustomDeviceAccess::DeviceListEntry Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • CustomDeviceAccess
  • CustomDeviceAccess::DeviceListEntry
Public Member Functions | Public Attributes | Properties

CustomDeviceAccess::DeviceListEntry Class Reference

List of all members.

Public Member Functions

DeviceListEntry (Windows.Devices.Enumeration.DeviceInformation DeviceInterface)

Public Attributes

Windows.Devices.Enumeration.DeviceInformation | Device
bool | Matched = true

Properties

string | Id [get]
string | InstanceId [get]

Detailed Description

Definition at line 16 of file DeviceList.cs.

Constructor & Destructor Documentation

CustomDeviceAccess::DeviceListEntry::DeviceListEntry ( Windows.Devices.Enumeration.DeviceInformation DeviceInterface ) [inline]

Constructor.

Parameters:
DeviceInterface The device interface for this entry

Definition at line 42 of file DeviceList.cs.

        {
            this.Device = DeviceInterface;
        }

Member Data Documentation

Windows.Devices.Enumeration.DeviceInformation CustomDeviceAccess::DeviceListEntry::Device

The DeviceInformation object (device interface) for this Fx2 device.

Definition at line 21 of file DeviceList.cs.

bool CustomDeviceAccess::DeviceListEntry::Matched = true

Has the device been found during the current enumeration.

Definition at line 36 of file DeviceList.cs.

Property Documentation

string CustomDeviceAccess::DeviceListEntry::Id [get]

The device interface path.

Definition at line 26 of file DeviceList.cs.

string CustomDeviceAccess::DeviceListEntry::InstanceId [get]

The device's instance ID.

Definition at line 31 of file DeviceList.cs.

The documentation for this class was generated from the following file:
  • Custom driver access/C#,C++/app_cs/DeviceList.cs
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CustomTextRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

CustomTextRenderer Class Reference

#include "CustomTextRenderer.h"

List of all members.

Public Member Functions

CustomTextRenderer (Microsoft::WRL::ComPtr< ID2D1Factory > D2DFactory, Microsoft::WRL::ComPtr< ID2D1DeviceContext > D2DDeviceContext, Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > outlineBrush, Microsoft::WRL::ComPtr< ID2D1BitmapBrush > fillBrush)
IFACEMETHOD() | DrawGlyphRun (_In_opt_ void *clientDrawingContext, FLOAT baselineOriginX, FLOAT baselineOriginY, DWRITE_MEASURING_MODE measuringMode, _In_ DWRITE_GLYPH_RUN const *glyphRun, _In_ DWRITE_GLYPH_RUN_DESCRIPTION const *glyphRunDescription, IUnknown *clientDrawingEffect)
IFACEMETHOD() | DrawInlineObject (_In_opt_ void *clientDrawingContext, FLOAT originX, FLOAT originY, IDWriteInlineObject *inlineObject, BOOL isSideways, BOOL isRightToLeft, IUnknown *clientDrawingEffect)
IFACEMETHOD() | DrawStrikethrough (_In_opt_ void *clientDrawingContext, FLOAT baselineOriginX, FLOAT baselineOriginY, _In_ DWRITE_STRIKETHROUGH const *strikethrough, IUnknown *clientDrawingEffect)
IFACEMETHOD() | DrawUnderline (_In_opt_ void *clientDrawingContext, FLOAT baselineOriginX, FLOAT baselineOriginY, _In_ DWRITE_UNDERLINE const *underline, IUnknown *clientDrawingEffect)
IFACEMETHOD() | GetCurrentTransform (_In_opt_ void *clientDrawingContext, _Out_ DWRITE_MATRIX *transform)
IFACEMETHOD() | GetPixelsPerDip (_In_opt_ void *clientDrawingContext, _Out_ FLOAT *pixelsPerDip)
IFACEMETHOD_ (unsigned long, Release)()
IFACEMETHOD_ (unsigned long, AddRef)()
IFACEMETHOD() | IsPixelSnappingDisabled (_In_opt_ void *clientDrawingContext, _Out_ BOOL *isDisabled)
IFACEMETHOD() | QueryInterface (IID const &riid, void **ppvObject)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		D2DDeviceContext
Microsoft::WRL::ComPtr
< ID2D1Factory > 		D2DFactory
Microsoft::WRL::ComPtr
< ID2D1BitmapBrush > 		fillBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		outlineBrush
unsigned long | refCount

Detailed Description

Definition at line 22 of file CustomTextRenderer.h.

Constructor & Destructor Documentation

CustomTextRenderer::CustomTextRenderer | ( | Microsoft::WRL::ComPtr< ID2D1Factory > | D2DFactory,
 |  | Microsoft::WRL::ComPtr< ID2D1DeviceContext > | D2DDeviceContext,
 |  | Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > | outlineBrush,
 |  | Microsoft::WRL::ComPtr< ID2D1BitmapBrush > | fillBrush
 | ) |  |

Definition at line 16 of file CustomTextRenderer.cpp.

      :
    refCount(0),
    D2DFactory(D2DFactory),
    D2DDeviceContext(D2DDeviceContext),
    outlineBrush(outlineBrush),
    fillBrush(fillBrush)
{
}

Member Function Documentation

IFACEMETHODIMP CustomTextRenderer::DrawGlyphRun | ( | _In_opt_ void * | clientDrawingContext,
 |  | FLOAT | baselineOriginX,
 |  | FLOAT | baselineOriginY,
 |  | DWRITE_MEASURING_MODE | measuringMode,
 |  | _In_ DWRITE_GLYPH_RUN const * | glyphRun,
 |  | _In_ DWRITE_GLYPH_RUN_DESCRIPTION const * | glyphRunDescription,
 |  | IUnknown * | clientDrawingEffect
 | ) |  |

Definition at line 35 of file CustomTextRenderer.cpp.

{
    HRESULT hr = S_OK;

    // Create the path geometry.
    Microsoft::WRL::ComPtr<ID2D1PathGeometry> pathGeometry;
    hr = D2DFactory->CreatePathGeometry(&pathGeometry);

    // Write to the path geometry using the geometry sink.
    Microsoft::WRL::ComPtr<ID2D1GeometrySink> sink;
    if (SUCCEEDED(hr))
    {
        hr = pathGeometry->Open(&sink);
    }

    // Get the glyph run outline geometries back from DirectWrite and place them within the
    // geometry sink.
    if (SUCCEEDED(hr))
    {
        hr = glyphRun->fontFace->GetGlyphRunOutline(
            glyphRun->fontEmSize,
            glyphRun->glyphIndices,
            glyphRun->glyphAdvances,
            glyphRun->glyphOffsets,
            glyphRun->glyphCount,
            glyphRun->isSideways,
            glyphRun->bidiLevel%2,
            sink.Get()
            );
    }

    // Close the geometry sink
    if (SUCCEEDED(hr))
    {
        hr = sink.Get()->Close();
    }

    // Initialize a matrix to translate the origin of the glyph run.
    D2D1::Matrix3x2F const matrix = D2D1::Matrix3x2F(
        1.0f, 0.0f,
        0.0f, 1.0f,
        baselineOriginX, baselineOriginY
        );

    // Create the transformed geometry
    Microsoft::WRL::ComPtr<ID2D1TransformedGeometry> transformedGeometry;
    if (SUCCEEDED(hr))
    {
        hr = D2DFactory.Get()->CreateTransformedGeometry(
            pathGeometry.Get(),
            &matrix,
            &transformedGeometry
            );
    }

    // Draw the outline of the glyph run
    D2DDeviceContext->DrawGeometry(
        transformedGeometry.Get(),
        outlineBrush.Get()
        );

    // Fill in the glyph run
    D2DDeviceContext->FillGeometry(
        transformedGeometry.Get(),
        fillBrush.Get()
        );

    return hr;
}

IFACEMETHODIMP CustomTextRenderer::DrawInlineObject | ( | _In_opt_ void * | clientDrawingContext,
 |  | FLOAT | originX,
 |  | FLOAT | originY,
 |  | IDWriteInlineObject * | inlineObject,
 |  | BOOL | isSideways,
 |  | BOOL | isRightToLeft,
 |  | IUnknown * | clientDrawingEffect
 | ) |  |

Definition at line 239 of file CustomTextRenderer.cpp.

{
    // Not implemented
    return E_NOTIMPL;
}

IFACEMETHODIMP CustomTextRenderer::DrawStrikethrough | ( | _In_opt_ void * | clientDrawingContext,
 |  | FLOAT | baselineOriginX,
 |  | FLOAT | baselineOriginY,
 |  | _In_ DWRITE_STRIKETHROUGH const * | strikethrough,
 |  | IUnknown * | clientDrawingEffect
 | ) |  |

Definition at line 179 of file CustomTextRenderer.cpp.

{
    HRESULT hr;

    D2D1_RECT_F rect = D2D1::RectF(
        0,
        strikethrough->offset,
        strikethrough->width,
        strikethrough->offset + strikethrough->thickness
        );

    Microsoft::WRL::ComPtr<ID2D1RectangleGeometry> rectangleGeometry;
    hr = D2DFactory.Get()->CreateRectangleGeometry(
        &rect,
        &rectangleGeometry
        );

    // Initialize a matrix to translate the origin of the strikethrough
    D2D1::Matrix3x2F const matrix = D2D1::Matrix3x2F(
        1.0f, 0.0f,
        0.0f, 1.0f,
        baselineOriginX, baselineOriginY
        );

    Microsoft::WRL::ComPtr<ID2D1TransformedGeometry> transformedGeometry;
    if (SUCCEEDED(hr))
    {
        hr = D2DFactory.Get()->CreateTransformedGeometry(
            rectangleGeometry.Get(),
            &matrix,
            &transformedGeometry
            );
    }

    // Draw the outline of the rectangle
    D2DDeviceContext.Get()->DrawGeometry(
        transformedGeometry.Get(),
        outlineBrush.Get()
        );

    // Fill in the rectangle
    D2DDeviceContext.Get()->FillGeometry(
        transformedGeometry.Get(),
        fillBrush.Get()
        );

    return S_OK;
}

IFACEMETHODIMP CustomTextRenderer::DrawUnderline | ( | _In_opt_ void * | clientDrawingContext,
 |  | FLOAT | baselineOriginX,
 |  | FLOAT | baselineOriginY,
 |  | _In_ DWRITE_UNDERLINE const * | underline,
 |  | IUnknown * | clientDrawingEffect
 | ) |  |

Definition at line 118 of file CustomTextRenderer.cpp.

{
    HRESULT hr;

    D2D1_RECT_F rect = D2D1::RectF(
        0,
        underline->offset,
        underline->width,
        underline->offset + underline->thickness
        );

    Microsoft::WRL::ComPtr<ID2D1RectangleGeometry> rectangleGeometry;
    hr = D2DFactory.Get()->CreateRectangleGeometry(
        &rect,
        &rectangleGeometry
        );

    // Initialize a matrix to translate the origin of the underline
    D2D1::Matrix3x2F const matrix = D2D1::Matrix3x2F(
        1.0f, 0.0f,
        0.0f, 1.0f,
        baselineOriginX, baselineOriginY
        );

    Microsoft::WRL::ComPtr<ID2D1TransformedGeometry> transformedGeometry;
    if (SUCCEEDED(hr))
    {
        hr = D2DFactory.Get()->CreateTransformedGeometry(
            rectangleGeometry.Get(),
            &matrix,
            &transformedGeometry
            );
    }

    // Draw the outline of the rectangle
    D2DDeviceContext.Get()->DrawGeometry(
        transformedGeometry.Get(),
        outlineBrush.Get()
        );

    // Fill in the rectangle
    D2DDeviceContext.Get()->FillGeometry(
        transformedGeometry.Get(),
        fillBrush.Get()
        );

    return S_OK;
}

IFACEMETHODIMP CustomTextRenderer::GetCurrentTransform | ( | _In_opt_ void * | clientDrawingContext,
 |  | _Out_ DWRITE_MATRIX * | transform
 | ) |  |

Definition at line 298 of file CustomTextRenderer.cpp.

{
    // forward the render target's transform
    D2DDeviceContext->GetTransform(reinterpret_cast<D2D1_MATRIX_3X2_F*>(transform));
    return S_OK;
}

IFACEMETHODIMP CustomTextRenderer::GetPixelsPerDip | ( | _In_opt_ void * | clientDrawingContext,
 |  | _Out_ FLOAT * | pixelsPerDip
 | ) |  |

Definition at line 313 of file CustomTextRenderer.cpp.

{
    float x, yUnused;

    D2DDeviceContext.Get()->GetDpi(&x, &yUnused);
    *pixelsPerDip = x / 96;

    return S_OK;
}

CustomTextRenderer::IFACEMETHOD_ | ( | unsigned | long,
 |  | AddRef |
 | ) |  |
CustomTextRenderer::IFACEMETHOD_ | ( | unsigned | long,
 |  | Release |
 | ) |  |
IFACEMETHODIMP CustomTextRenderer::IsPixelSnappingDisabled | ( | _In_opt_ void * | clientDrawingContext,
 |  | _Out_ BOOL * | isDisabled
 | ) |  |

Definition at line 285 of file CustomTextRenderer.cpp.

{
    *isDisabled = FALSE;
    return S_OK;
}

IFACEMETHODIMP CustomTextRenderer::QueryInterface | ( | IID const & | riid,
 |  | void ** | ppvObject
 | ) |  |

Definition at line 330 of file CustomTextRenderer.cpp.

{
    if (__uuidof(IDWriteTextRenderer) == riid)
    {
        *ppvObject = this;
    }
    else if (__uuidof(IDWritePixelSnapping) == riid)
    {
        *ppvObject = this;
    }
    else if (__uuidof(IUnknown) == riid)
    {
        *ppvObject = this;
    }
    else
    {
        *ppvObject = nullptr;
        return E_FAIL;
    }

    this->AddRef();

    return S_OK;
}

Member Data Documentation

Microsoft::WRL::ComPtr<ID2D1DeviceContext> CustomTextRenderer::D2DDeviceContext [private]

Definition at line 94 of file CustomTextRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Factory> CustomTextRenderer::D2DFactory [private]

Definition at line 93 of file CustomTextRenderer.h.

Microsoft::WRL::ComPtr<ID2D1BitmapBrush> CustomTextRenderer::fillBrush [private]

Definition at line 96 of file CustomTextRenderer.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> CustomTextRenderer::outlineBrush [private]

Definition at line 95 of file CustomTextRenderer.h.

unsigned long CustomTextRenderer::refCount [private]

Definition at line 92 of file CustomTextRenderer.h.

The documentation for this class was generated from the following files:
  • DirectWrite custom text renderer/C++/CustomTextRenderer.h
  • DirectWrite custom text renderer/C++/CustomTextRenderer.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Cylinder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

Cylinder Class Reference

#include "Cylinder.h"

Inherits GameObject, and GameObject.

List of all members.

Public Member Functions

Cylinder (DirectX::XMFLOAT3 position, float radius, DirectX::XMFLOAT3 direction)
Cylinder (DirectX::XMFLOAT3 position, float radius, DirectX::XMFLOAT3 direction)
virtual bool | IsTouching (DirectX::XMFLOAT3 point, float radius, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal) override
virtual bool | IsTouching (DirectX::XMFLOAT3 point, float radius, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal) override

Public Attributes

internal | __pad0__: Cylinder()

Protected Member Functions

virtual void | UpdatePosition () override
virtual void | UpdatePosition () override

Private Member Functions

void | Initialize (DirectX::XMFLOAT3 position, float radius, DirectX::XMFLOAT3 direction)
void | Initialize (DirectX::XMFLOAT3 position, float radius, DirectX::XMFLOAT3 direction)

Private Attributes

DirectX::XMFLOAT3 | m_axis
float | m_length
float | m_radius
DirectX::XMFLOAT4X4 | m_rotationMatrix

Detailed Description

Definition at line 18 of file Cylinder.h.

Constructor & Destructor Documentation

Cylinder::Cylinder | ( | DirectX::XMFLOAT3 | position,
 |  | float | radius,
 |  | DirectX::XMFLOAT3 | direction
 | ) |  |
Cylinder::Cylinder | ( | DirectX::XMFLOAT3 | position,
 |  | float | radius,
 |  | DirectX::XMFLOAT3 | direction
 | ) |  |

Member Function Documentation

void Cylinder::Initialize | ( | DirectX::XMFLOAT3 | position,
 |  | float | radius,
 |  | DirectX::XMFLOAT3 | direction |
 | ) |  |  | [private]
void Cylinder::Initialize | ( | DirectX::XMFLOAT3 | position,
 |  | float | radius,
 |  | DirectX::XMFLOAT3 | direction |
 | ) |  |  | [private]
virtual bool Cylinder::IsTouching | ( | DirectX::XMFLOAT3 | point,
 |  | float | radius,
 |  | _Out_ DirectX::XMFLOAT3 * | contact,
 |  | _Out_ DirectX::XMFLOAT3 * | normal |
 | ) |  |  | [override, virtual]

Reimplemented from GameObject.

virtual bool Cylinder::IsTouching | ( | DirectX::XMFLOAT3 | point,
 |  | float | radius,
 |  | _Out_ DirectX::XMFLOAT3 * | contact,
 |  | _Out_ DirectX::XMFLOAT3 * | normal |
 | ) |  |  | [override, virtual]

Reimplemented from GameObject.

void Cylinder::UpdatePosition ( ) [override, protected, virtual]

Reimplemented from GameObject.

Definition at line 69 of file Cylinder.cpp.

{
    XMStoreFloat4x4(
        &m_modelMatrix,
        XMMatrixScaling(m_radius, m_radius, m_length) *
        XMLoadFloat4x4(&m_rotationMatrix) *
        XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
        );
}

virtual void Cylinder::UpdatePosition ( ) [override, protected, virtual]

Reimplemented from GameObject.

Member Data Documentation

internal Cylinder::__pad0__

Reimplemented from GameObject.

Definition at line 21 of file Cylinder.h.

DirectX::XMFLOAT3 Cylinder::m_axis [private]

Definition at line 45 of file Cylinder.h.

float Cylinder::m_length [private]

Definition at line 46 of file Cylinder.h.

float Cylinder::m_radius [private]

Definition at line 47 of file Cylinder.h.

DirectX::XMFLOAT4X4 Cylinder::m_rotationMatrix [private]

Definition at line 48 of file Cylinder.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Cylinder.h
  • XAML DirectX 3D shooting game/C++/Cylinder.h
  • DirectX 3D shooting game/C++/Cylinder.cpp
  • XAML DirectX 3D shooting game/C++/Cylinder.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CylinderMesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

CylinderMesh Class Reference

#include "CylinderMesh.h"

List of all members.

Public Attributes

internal | __pad0__: CylinderMesh(_In_ ID3D11Device *device
internal uint32 | segments

Detailed Description

Definition at line 18 of file CylinderMesh.h.

Member Data Documentation

internal CylinderMesh::__pad0__

Definition at line 21 of file CylinderMesh.h.

internal uint32 CylinderMesh::segments

Definition at line 21 of file CylinderMesh.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/CylinderMesh.h
  • XAML DirectX 3D shooting game/C++/CylinderMesh.h
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2D3DTransforms::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • D2D3DTransforms
  • D2D3DTransforms::sealed
Public Member Functions | Private Member Functions | Private Attributes

D2D3DTransforms::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
void | InitializeValues ()
MainPage ()
virtual void | OnLaunched (_In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
void | OnSuspending (Object^sender, Windows::ApplicationModel::SuspendingEventArgs^args)
void | ResetValues ()

Private Member Functions

void | OnDisplayContentsInvalidated (Object^sender)
void | OnEffectSelectorSelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^args)
void | OnGlobalOffsetXValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnGlobalOffsetYValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnGlobalOffsetZValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnLocalOffsetXValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnLocalOffsetYValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnLocalOffsetZValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnLogicalDpiChanged (Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPerspectiveValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnRestoreDefaultsClick (Object^sender, Windows::UI::Xaml::RoutedEventArgs^args)
void | OnRotationXValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnRotationYValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnRotationZValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnScaleXValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnScaleYValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | SetTransformEffect (TransformEffect transformEffect)
void | SetTransformProperty (TransformProperty transformProperty, float value)

Private Attributes

MainPage | m_mainPage
D2D3DTransformsRenderer m_renderer

Detailed Description

Definition at line 16 of file App.xaml.h.

Member Function Documentation

D2D3DTransforms::sealed::App ( )
void D2D3DTransforms::sealed::InitializeValues ( )
D2D3DTransforms::sealed::MainPage ( )
void D2D3DTransforms::sealed::OnDisplayContentsInvalidated ( Object^ sender ) [private]
void D2D3DTransforms::sealed::OnEffectSelectorSelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnGlobalOffsetXValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnGlobalOffsetYValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnGlobalOffsetZValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
virtual void D2D3DTransforms::sealed::OnLaunched ( _In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
void D2D3DTransforms::sealed::OnLocalOffsetXValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnLocalOffsetYValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnLocalOffsetZValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void D2D3DTransforms::sealed::OnLogicalDpiChanged ( Object^ sender ) [private]
void D2D3DTransforms::sealed::OnPerspectiveValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnRestoreDefaultsClick | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnRotationXValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnRotationYValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnRotationZValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnScaleXValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnScaleYValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnSuspending | ( | Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | args
 | ) |  |
void D2D3DTransforms::sealed::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::OnWindowSizeChanged | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2D3DTransforms::sealed::ResetValues ( )
void D2D3DTransforms::sealed::SetTransformEffect ( TransformEffect transformEffect ) [private]
void D2D3DTransforms::sealed::SetTransformProperty | ( | TransformProperty | transformProperty,
 |  | float | value |
 | ) |  |  | [private]

Member Data Documentation

MainPage D2D3DTransforms::sealed::m_mainPage [private]

Definition at line 40 of file App.xaml.h.

D2D3DTransformsRenderer D2D3DTransforms::sealed::m_renderer [private]

Definition at line 114 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Direct2D 3D transform effect/C++/App.xaml.h
  • Direct2D 3D transform effect/C++/MainPage.xaml.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2D3DTransformsRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

D2D3DTransformsRenderer Class Reference

#include "D2D3DTransformsRenderer.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Render () override
void | Render3DPerspectiveTransformEffect ()
void | Render3DTransformEffect ()
void | SetTransformEffect (TransformEffect transformEffect)
void | SetTransformProperty (TransformProperty transformProperty, float value)
void | UpdateForViewStateChanged (Windows::UI::ViewManagement::ApplicationViewState state)

Public Attributes

internal | __pad0__: D2D3DTransformsRenderer()

Private Member Functions

void | Draw3DPerspectiveProperty (Platform::String^caption, Platform::String^value, float horizontalOffset)
void | DrawMatrix (Platform::String^caption, D2D1_MATRIX_4X4_F matrix, float horizontalOffset)
void | DrawSymbol (Platform::String^symbol, float horizontalOffset)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_3DPerspectiveTransformEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_3DTransformEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_bitmapSourceEffect
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_captionFormat
float | m_captionHeight
float | m_captionTop
TransformEffect m_currentEffect
float | m_globalOffsetX
float | m_globalOffsetY
float | m_globalOffsetZ
D2D1_SIZE_U | m_imageSize
float | m_localOffsetX
float | m_localOffsetY
float | m_localOffsetZ
float | m_matrixHeight
float | m_matrixTop
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_matrixValueFormat
float | m_matrixWidth
float | m_perspective
float | m_propertyHeight
float | m_propertyTop
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_propertyValueFormat
float | m_propertyWidth
float | m_rotationX
float | m_rotationY
float | m_rotationZ
float | m_scaleX
float | m_scaleY
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_snappedViewFormat
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_symbolFormat
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_wicFormatConverter
Windows::UI::ViewManagement::ApplicationViewState | m_windowState

Detailed Description

Definition at line 36 of file D2D3DTransformsRenderer.h.

Member Function Documentation

void D2D3DTransformsRenderer::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 38 of file D2D3DTransformsRenderer.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Text formats used for displaying the effect properties are created in
    // this method, since they are independent of the Direct2D device itself.
    // In the event the device needs to be reinstantiated (due to a resolution
    // change for example), these font resources will not need to be recreated.

    String^ fontName = "Segoe UI";
    String^ locale = "en-US";

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            fontName->Data(),
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            11,
            locale->Data(),
            &m_captionFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_captionFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_captionFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            fontName->Data(),
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            12,
            locale->Data(),
            &m_matrixValueFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_matrixValueFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_matrixValueFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            fontName->Data(),
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            18,
            locale->Data(),
            &m_propertyValueFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_propertyValueFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            fontName->Data(),
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            18,
            locale->Data(),
            &m_symbolFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_symbolFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_symbolFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            fontName->Data(),
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            20,
            locale->Data(),
            &m_snappedViewFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_snappedViewFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_snappedViewFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    // Load an image from a Windows Imaging Component
    // decoder, which will be passed to the BitmapSource effect
    // in CreateDeviceResources.
    ComPtr<IWICBitmapDecoder> decoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"mammoth_small.jpg",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &decoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> frame;
    DX::ThrowIfFailed(
        decoder->GetFrame(0, &frame)
        );

    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&m_wicFormatConverter)
        );

    DX::ThrowIfFailed(
        m_wicFormatConverter->Initialize(
            frame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0f,
            WICBitmapPaletteTypeCustom
            )
        );

    // Get the size of the image.
    unsigned int width, height;
    DX::ThrowIfFailed(m_wicFormatConverter->GetSize(&width, &height));
    m_imageSize = D2D1::SizeU(width, height);
}

void D2D3DTransformsRenderer::CreateDeviceResources ( ) [override, virtual]

Definition at line 200 of file D2D3DTransformsRenderer.cpp.

{
    DirectXBase::CreateDeviceResources();

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_whiteBrush
            )
        );

    // Create a bitmap source effect and bind the WIC format converter to it.
    m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_bitmapSourceEffect);
    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(
            D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE,
            m_wicFormatConverter.Get()
            )
        );

    // Because the image will not be changing, the BitmapSource effect should be cached for better performance.

    // The property system expects TRUE and FALSE rather than true or false to ensure that
    // the size of the value is consistent regardless of architecture.
    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(
            D2D1_PROPERTY_CACHED,
            TRUE
            )
        );

    // Create the matrix-based transform effect.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D13DTransform, &m_3DTransformEffect)
        );

    m_3DTransformEffect->SetInputEffect(0, m_bitmapSourceEffect.Get());

    // Create the property-based transform effect.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D13DPerspectiveTransform, &m_3DPerspectiveTransformEffect)
        );

    m_3DPerspectiveTransformEffect->SetInputEffect(0, m_bitmapSourceEffect.Get());
}

void D2D3DTransformsRenderer::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 246 of file D2D3DTransformsRenderer.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Render effect properties centered at the bottom of the screen.
    m_captionTop = size.height + CaptionOffsetTop;
    m_matrixTop = size.height + MatrixOffsetTop;
    m_propertyTop = size.height + PropertyOffsetTop;

    // Scale image based on DPI.
    D2D1_POINT_2F scale = D2D1::Point2F(m_dpi / 96.0f, m_dpi / 96.0f);
    m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, scale);

    Render();
}

void D2D3DTransformsRenderer::Draw3DPerspectiveProperty | ( | Platform::String^ | caption,
 |  | Platform::String^ | value,
 |  | float | horizontalOffset |
 | ) |  |  | [private]
void D2D3DTransformsRenderer::DrawMatrix | ( | Platform::String^ | caption,
 |  | D2D1_MATRIX_4X4_F | matrix,
 |  | float | horizontalOffset |
 | ) |  |  | [private]
void D2D3DTransformsRenderer::DrawSymbol | ( | Platform::String^ | symbol,
 |  | float | horizontalOffset |
 | ) |  |  | [private]

Definition at line 658 of file D2D3DTransformsRenderer.cpp.

{
    m_d2dContext->DrawText(
        symbol->Data(),
        symbol->Length(),
        m_symbolFormat.Get(),
        D2D1::RectF(
            horizontalOffset,
            m_matrixTop,
            horizontalOffset + MatrixMargin,
            m_matrixTop + MatrixHeight
            ),
        m_whiteBrush.Get()
        );
}

void D2D3DTransformsRenderer::Render ( ) [override, virtual]

Definition at line 264 of file D2D3DTransformsRenderer.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));

    if (m_windowState != ApplicationViewState::Snapped)
    {
        // Only render the effect that is currently being manipuated by the XAML code.
        if (m_currentEffect == TransformEffect::D2D13DTransform)
        {
            Render3DTransformEffect();
        }
        else if (m_currentEffect == TransformEffect::D2D13DPerspectiveTransform)
        {
            Render3DPerspectiveTransformEffect();
        }
        else
        {
            throw ref new Platform::FailureException();
        }
    }
    else
    {
        // Display message that app is not designed to be run in snapped mode.

        Platform::String^ snapMessage = "This sample does not support snapped view.";

        D2D1_SIZE_F size = m_d2dContext->GetSize();

        m_d2dContext->DrawText(
            snapMessage->Data(),
            snapMessage->Length(),
            m_snappedViewFormat.Get(),
            D2D1::RectF(0.0f, 0.0f, size.width, size.height),
            m_whiteBrush.Get()
            );
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    Present();
}

void D2D3DTransformsRenderer::Render3DPerspectiveTransformEffect ( )

Definition at line 481 of file D2D3DTransformsRenderer.cpp.

{
    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Base property position off of the screen center.
    D2D1_POINT_2F screenCenter = D2D1::Point2F(
        size.width / 2.0f,
        size.height / 2.0f
        );

    // Assign properties to 3DPerspectiveProperties effect.
    D2D1_VECTOR_3F localOffset = D2D1::Vector3F(m_localOffsetX, m_localOffsetY, m_localOffsetZ);

    DX::ThrowIfFailed(
        m_3DPerspectiveTransformEffect->SetValue(
            D2D1_3DPERSPECTIVETRANSFORM_PROP_LOCAL_OFFSET,
            localOffset
            )
        );

    D2D1_VECTOR_3F rotation = D2D1::Vector3F(m_rotationX, m_rotationY, m_rotationZ);

    DX::ThrowIfFailed(
        m_3DPerspectiveTransformEffect->SetValue(
            D2D1_3DPERSPECTIVETRANSFORM_PROP_ROTATION,
            rotation
            )
        );

    DX::ThrowIfFailed(
        m_3DPerspectiveTransformEffect->SetValue(
            D2D1_3DPERSPECTIVETRANSFORM_PROP_DEPTH,
            m_perspective
            )
        );

    D2D1_VECTOR_3F globalOffset = D2D1::Vector3F(m_globalOffsetX, m_globalOffsetY, m_globalOffsetZ);

    DX::ThrowIfFailed(
        m_3DPerspectiveTransformEffect->SetValue(
            D2D1_3DPERSPECTIVETRANSFORM_PROP_GLOBAL_OFFSET,
            globalOffset
            )
        );

    Draw3DPerspectiveProperty("Scale Property", "Not available in 3DPerspective Transform", screenCenter.x + PropertyOffsetLeft);

    String^ localOffsetValue = "(" + m_localOffsetX.ToString() + ", " + m_localOffsetY.ToString() + ", " + m_localOffsetZ.ToString() + ")";
    Draw3DPerspectiveProperty("LocalOffset Property", localOffsetValue, screenCenter.x + PropertyOffsetLeft + (PropertyWidth + PropertyMargin));

    String^ rotationValue = "(" + m_rotationX.ToString() + ", " + m_rotationY.ToString() + ", " + m_rotationZ.ToString() + ")";
    Draw3DPerspectiveProperty("Rotation Property", rotationValue, screenCenter.x + PropertyOffsetLeft + (PropertyWidth + PropertyMargin) * 2.0f);

    String^ globalOffsetValue = "(" + m_globalOffsetX.ToString() + ", " + m_globalOffsetY.ToString() + ", " + m_globalOffsetZ.ToString() + ")";
    Draw3DPerspectiveProperty("GlobalOffset Property", globalOffsetValue, screenCenter.x + PropertyOffsetLeft + (PropertyWidth + PropertyMargin) * 3.0f);

    String^ depthValue = m_perspective.ToString();
    Draw3DPerspectiveProperty("Depth Property", depthValue, screenCenter.x + PropertyOffsetLeft + (PropertyWidth + PropertyMargin) * 4.0f);

    // Render 3DPerspectiveTransform effect.
    m_d2dContext->DrawImage(
        m_3DPerspectiveTransformEffect.Get(),
        D2D1::Point2F(
            screenCenter.x - (m_imageSize.width / 2.0f),
            screenCenter.y - (m_imageSize.height / 2.0f)
            )
        );
}

void D2D3DTransformsRenderer::Render3DTransformEffect ( )

Definition at line 375 of file D2D3DTransformsRenderer.cpp.

{
    // Generate Transform matrix for 3DTransform effect.
    D2D1::Matrix4x4F transformMatrix =                   // Parentheses below denote equivalent property in 3DPerspectiveTransform.
        D2D1::Matrix4x4F::Scale(m_scaleX, m_scaleY, 1) * // Scales the image. (No equivalent in 3DPerspectiveTransform)
        D2D1::Matrix4x4F::Translation(                   // Translate the image before rotation. (LOCAL_OFFSET property)
            m_localOffsetX,
            m_localOffsetY,
            m_localOffsetZ
            ) *
        D2D1::Matrix4x4F::RotationX(m_rotationX) *       // Rotate the image on the X, Y and Z axes. (ROTATION property)
        D2D1::Matrix4x4F::RotationY(m_rotationY) *
        D2D1::Matrix4x4F::RotationZ(m_rotationZ) *
        D2D1::Matrix4x4F::Translation(                   // Translate the image after rotation. (GLOBAL_OFFSET property)
            m_globalOffsetX,
            m_globalOffsetY,
            m_globalOffsetZ
            ) *
        D2D1::Matrix4x4F::PerspectiveProjection(         // Apply perspective to the image. (DEPTH property)
            m_perspective
            );

    DX::ThrowIfFailed(m_3DTransformEffect->SetValue(D2D1_3DTRANSFORM_PROP_TRANSFORM_MATRIX, transformMatrix));

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Base matrix position off of the screen center.
    D2D1_POINT_2F screenCenter = D2D1::Point2F(
        size.width / 2.0f,
        size.height / 2.0f
        );

    // Draw Scale matrix.
    DrawMatrix(
        "Matrix4x4F::Scale(" + m_scaleX.ToString() + ", " + m_scaleY.ToString() + ", 1)",
        D2D1::Matrix4x4F::Scale(m_scaleX, m_scaleY, 1),
        screenCenter.x + MatrixOffsetLeft
        );

    // Draw 'x' between matrices.
    DrawSymbol("x", screenCenter.x + MatrixOffsetLeft + MatrixWidth);

    // Draw the Local Offset matrix.
    DrawMatrix(
        "Matrix4x4F::Translation(" +
            m_localOffsetX.ToString() + ", " +
            m_localOffsetY.ToString() + ", " +
            m_localOffsetZ.ToString() + ")",
        D2D1::Matrix4x4F::Translation(m_localOffsetX, m_localOffsetY, m_localOffsetZ),
        screenCenter.x + MatrixOffsetLeft + MatrixWidth + MatrixMargin
        );

    // Draw 'x' between matrices.
    DrawSymbol("x", screenCenter.x + MatrixOffsetLeft + MatrixWidth * 2 + MatrixMargin);

    // Draw Rotation matrix. Two separate helper matrices are multipled together to create one rotation matrix.
    DrawMatrix(
        "Matrix4x4F::RotationX(" +m_rotationX.ToString() +
            ") * Matrix4x4F::RotationY(" + m_rotationY.ToString() +
            ") * Matrix4x4F::RotationZ(" + m_rotationZ.ToString() + ")",
        D2D1::Matrix4x4F::RotationX(m_rotationX) *
        D2D1::Matrix4x4F::RotationY(m_rotationY) *
        D2D1::Matrix4x4F::RotationZ(m_rotationZ),
        screenCenter.x + MatrixOffsetLeft + MatrixWidth * 2 + MatrixMargin * 2
        );

    // Draw 'x' between matrices.
    DrawSymbol("x", screenCenter.x + MatrixOffsetLeft + MatrixWidth * 3 + MatrixMargin * 2);

    // Draw the Global Offset matrix.
    DrawMatrix(
        "Matrix4x4F::Translation(" + m_globalOffsetX.ToString() + ", " + m_globalOffsetY.ToString() + ", " + m_globalOffsetZ.ToString() + ")",
        D2D1::Matrix4x4F::Translation(m_globalOffsetX, m_globalOffsetY, m_globalOffsetZ),
        screenCenter.x + MatrixOffsetLeft + MatrixWidth * 3 + MatrixMargin * 3
        );

    // Draw 'x' between matrices.
    DrawSymbol("x", screenCenter.x + MatrixOffsetLeft + MatrixWidth * 4 + MatrixMargin * 3);

    // Draw the Perspective matrix.
    DrawMatrix(
        "Matrix4x4F::PerspectiveProjection(\n" + m_perspective.ToString() + ")",
        D2D1::Matrix4x4F::PerspectiveProjection(m_perspective),
        screenCenter.x + MatrixOffsetLeft + MatrixWidth * 4 + MatrixMargin * 4
        );

    // Draw '=' between matrices.
    DrawSymbol("=", screenCenter.x + MatrixOffsetLeft + MatrixWidth * 5 + MatrixMargin * 4);

    // Result resultant transform matrix that is applied to m_3DTransformEffect.
    DrawMatrix(
        "",
        transformMatrix,
        screenCenter.x + MatrixOffsetLeft + MatrixWidth * 5 + MatrixMargin * 5
        );

    // Render 3DTransform effect.
    m_d2dContext->DrawImage(
        m_3DTransformEffect.Get(),
        D2D1::Point2F(
            screenCenter.x - (m_imageSize.width / 2.0f),
            screenCenter.y - (m_imageSize.height / 2.0f)
            )
        );
}

void D2D3DTransformsRenderer::SetTransformEffect ( TransformEffect transformEffect )

Definition at line 314 of file D2D3DTransformsRenderer.cpp.

{
    m_currentEffect = transformEffect;

    if (m_swapChainPanel != nullptr)
    {
        Render();
    }
}

void D2D3DTransformsRenderer::SetTransformProperty | ( | TransformProperty | transformProperty,
 |  | float | value
 | ) |  |

Definition at line 324 of file D2D3DTransformsRenderer.cpp.

{
    switch (transformProperty)
    {
    case TransformProperty::ScaleX:
        m_scaleX = value;
        break;
    case TransformProperty::ScaleY:
        m_scaleY = value;
        break;
    case TransformProperty::LocalOffsetX:
        m_localOffsetX = value;
        break;
    case TransformProperty::LocalOffsetY:
        m_localOffsetY = value;
        break;
    case TransformProperty::LocalOffsetZ:
        m_localOffsetZ = value;
        break;
    case TransformProperty::RotationX:
        m_rotationX = value;
        break;
    case TransformProperty::RotationY:
        m_rotationY = value;
        break;
    case TransformProperty::RotationZ:
        m_rotationZ = value;
        break;
    case TransformProperty::GlobalOffsetX:
        m_globalOffsetX = value;
        break;
    case TransformProperty::GlobalOffsetY:
        m_globalOffsetY = value;
        break;
    case TransformProperty::GlobalOffsetZ:
        m_globalOffsetZ = value;
        break;
    case TransformProperty::Perspective:
        m_perspective = value;
        break;
    default:
        throw ref new Platform::FailureException();
        break;
    }

    if (m_swapChainPanel != nullptr)
    {
        Render();
    }
}

void D2D3DTransformsRenderer::UpdateForViewStateChanged ( Windows::UI::ViewManagement::ApplicationViewState state )

Member Data Documentation

internal D2D3DTransformsRenderer::__pad0__

Definition at line 39 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2D3DTransformsRenderer::m_3DPerspectiveTransformEffect [private]

Definition at line 78 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2D3DTransformsRenderer::m_3DTransformEffect [private]

Definition at line 77 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2D3DTransformsRenderer::m_bitmapSourceEffect [private]

Definition at line 76 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2D3DTransformsRenderer::m_captionFormat [private]

Definition at line 100 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_captionHeight [private]

Definition at line 107 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_captionTop [private]

Definition at line 106 of file D2D3DTransformsRenderer.h.

TransformEffect D2D3DTransformsRenderer::m_currentEffect [private]

Definition at line 80 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_globalOffsetX [private]

Definition at line 93 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_globalOffsetY [private]

Definition at line 94 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_globalOffsetZ [private]

Definition at line 95 of file D2D3DTransformsRenderer.h.

D2D1_SIZE_U D2D3DTransformsRenderer::m_imageSize [private]

Definition at line 81 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_localOffsetX [private]

Definition at line 87 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_localOffsetY [private]

Definition at line 88 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_localOffsetZ [private]

Definition at line 89 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_matrixHeight [private]

Definition at line 109 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_matrixTop [private]

Definition at line 108 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2D3DTransformsRenderer::m_matrixValueFormat [private]

Definition at line 101 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_matrixWidth [private]

Definition at line 110 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_perspective [private]

Definition at line 96 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_propertyHeight [private]

Definition at line 112 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_propertyTop [private]

Definition at line 111 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2D3DTransformsRenderer::m_propertyValueFormat [private]

Definition at line 102 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_propertyWidth [private]

Definition at line 113 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_rotationX [private]

Definition at line 90 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_rotationY [private]

Definition at line 91 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_rotationZ [private]

Definition at line 92 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_scaleX [private]

Definition at line 85 of file D2D3DTransformsRenderer.h.

float D2D3DTransformsRenderer::m_scaleY [private]

Definition at line 86 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2D3DTransformsRenderer::m_snappedViewFormat [private]

Definition at line 104 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2D3DTransformsRenderer::m_symbolFormat [private]

Definition at line 103 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> D2D3DTransformsRenderer::m_whiteBrush [private]

Definition at line 105 of file D2D3DTransformsRenderer.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> D2D3DTransformsRenderer::m_wicFormatConverter [private]

Definition at line 75 of file D2D3DTransformsRenderer.h.

Windows::UI::ViewManagement::ApplicationViewState D2D3DTransformsRenderer::m_windowState [private]

Definition at line 73 of file D2D3DTransformsRenderer.h.

The documentation for this class was generated from the following files:
  • Direct2D 3D transform effect/C++/D2D3DTransformsRenderer.h
  • Direct2D 3D transform effect/C++/D2D3DTransformsRenderer.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DBasicAnimation Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

D2DBasicAnimation Class Reference

#include "D2DBasicAnimation.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: D2DBasicAnimation()

Private Member Functions

float | ComputeTriangleLocation (float startPoint, float endPoint, float duration, float elapsedTime)
void | CreateSpiralPathAndTriangle ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
float | m_elapsedTime
Microsoft::WRL::ComPtr
< ID2D1PathGeometry > 		m_objectGeometry
Microsoft::WRL::ComPtr
< ID2D1PathGeometry > 		m_pathGeometry
float | m_pathLength
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush
bool | m_windowClosed
bool | m_windowVisible

Detailed Description

Definition at line 13 of file D2DBasicAnimation.h.

Member Function Documentation

float D2DBasicAnimation::ComputeTriangleLocation | ( | float | startPoint,
 |  | float | endPoint,
 |  | float | duration,
 |  | float | elapsedTime |
 | ) |  |  | [private]

Definition at line 119 of file D2DBasicAnimation.cpp.

{
    float time = min(max(elapsedTime, 0), duration);
    return startPoint + ((endPoint - startPoint) * (time / duration));
}

void D2DBasicAnimation::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 30 of file D2DBasicAnimation.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();
}

void D2DBasicAnimation::CreateDeviceResources ( ) [override, virtual]

Definition at line 125 of file D2DBasicAnimation.cpp.

{
    DirectXBase::CreateDeviceResources();

    this->CreateSpiralPathAndTriangle();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D animation sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_whiteBrush
            )
        );
}

void D2DBasicAnimation::CreateSpiralPathAndTriangle ( ) [private]

Definition at line 35 of file D2DBasicAnimation.cpp.

{
    DX::ThrowIfFailed(
        m_d2dFactory->CreatePathGeometry(&m_pathGeometry)
        );

    {
        ComPtr<ID2D1GeometrySink> geometrySink;

        // Write to the path geometry using the geometry sink. We are going to create a
        // spiral.
        DX::ThrowIfFailed(
            m_pathGeometry->Open(&geometrySink)
            );

        D2D1_POINT_2F currentLocation = {0, 0};

        geometrySink->BeginFigure(currentLocation, D2D1_FIGURE_BEGIN_FILLED);

        D2D1_POINT_2F locDelta = {2, 2};
        float radius = 3;

        for (UINT i = 0; i < 30; ++i)
        {
            currentLocation.x += radius * locDelta.x;
            currentLocation.y += radius * locDelta.y;

            geometrySink->AddArc(
                D2D1::ArcSegment(
                    currentLocation,
                    D2D1::SizeF(2*radius, 2*radius),    // radius x/y
                    0.0f,                               // rotation angle
                    D2D1_SWEEP_DIRECTION_CLOCKWISE,
                    D2D1_ARC_SIZE_SMALL
                    )
                );

            locDelta = D2D1::Point2F(-locDelta.y, locDelta.x);

            radius += 3;
        }

        geometrySink->EndFigure(D2D1_FIGURE_END_OPEN);

        DX::ThrowIfFailed(
            geometrySink->Close()
            );
    }

    DX::ThrowIfFailed(
        m_d2dFactory->CreatePathGeometry(&m_objectGeometry)
        );

    {
        ComPtr<ID2D1GeometrySink> geometrySink;

        // Create a simple triangle by writing the object geometry using the geometry sink.
        DX::ThrowIfFailed(
            m_objectGeometry->Open(&geometrySink)
            );

        geometrySink->BeginFigure(
            D2D1::Point2F(0.0f, 0.0f),
            D2D1_FIGURE_BEGIN_FILLED
            );

        const D2D1_POINT_2F triangle[] = {{-10.0f, -10.0f}, {-10.0f, 10.0f}, {0.0f, 0.0f}};
        geometrySink->AddLines(triangle, 3);

        geometrySink->EndFigure(D2D1_FIGURE_END_OPEN);

        DX::ThrowIfFailed(
            geometrySink->Close()
            );
    }

    DX::ThrowIfFailed(
        m_pathGeometry->ComputeLength(
            nullptr,            // Apply no transform.
            &m_pathLength
            )
        );
}

virtual void D2DBasicAnimation::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void D2DBasicAnimation::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 270 of file D2DBasicAnimation.cpp.

{
}

void D2DBasicAnimation::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DBasicAnimation::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 322 of file D2DBasicAnimation.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
}

void D2DBasicAnimation::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 344 of file D2DBasicAnimation.cpp.

{
}

void D2DBasicAnimation::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void D2DBasicAnimation::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DBasicAnimation::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void D2DBasicAnimation::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DBasicAnimation::Render ( ) [override, virtual]

Definition at line 157 of file D2DBasicAnimation.cpp.

{
    // Retrieve the size of the render target.
    D2D1_SIZE_F renderTargetSize = m_d2dContext->GetSize();

    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    float minWidthHeightScale = min(renderTargetSize.width, renderTargetSize.height) / 512;

    D2D1::Matrix3x2F scale = D2D1::Matrix3x2F::Scale(
        minWidthHeightScale,
        minWidthHeightScale
        );

    D2D1::Matrix3x2F translation = D2D1::Matrix3x2F::Translation(
        renderTargetSize.width / 2.0f,
        renderTargetSize.height / 2.0f
        );

    // Center the path.
    m_d2dContext->SetTransform(scale * translation);

    // Draw the path in black.
    m_d2dContext->DrawGeometry(m_pathGeometry.Get(), m_blackBrush.Get());

    float length = ComputeTriangleLocation(0.0f, m_pathLength, AnimationDuration, m_elapsedTime);

    // Ask the geometry to give us the point that corresponds with the
    // length at the current time.
    D2D1_POINT_2F point;
    D2D1_POINT_2F tangent;
    DX::ThrowIfFailed(
        m_pathGeometry->ComputePointAtLength(
            length,
            nullptr,
            &point,
            &tangent
            )
        );

    // Reorient the triangle so that it follows the
    // direction of the path.
    D2D1_MATRIX_3X2_F triangleMatrix;
    triangleMatrix = D2D1::Matrix3x2F(
        tangent.x, tangent.y,
        -tangent.y, tangent.x,
        point.x, point.y
        );

    m_d2dContext->SetTransform(triangleMatrix * scale * translation);

    // Draw the white triangle.
    m_d2dContext->FillGeometry(m_objectGeometry.Get(), m_whiteBrush.Get());

    // When we reach the end of the animation, loop back to the beginning.
    if (m_elapsedTime >= AnimationDuration)
    {
        m_elapsedTime = 0.0f;
    }
    else
    {
        m_elapsedTime += 0.0166f; // This controls the number of time units that time is incremented by on every render call.
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void D2DBasicAnimation::Run ( ) [virtual]

Definition at line 276 of file D2DBasicAnimation.cpp.

{
    while (!m_windowClosed)
    {
        if (m_windowVisible)
        {
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
            Render();
            Present();
        }
        else
        {
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
        }
    }
}

virtual void D2DBasicAnimation::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void D2DBasicAnimation::Uninitialize ( ) [virtual]

Definition at line 293 of file D2DBasicAnimation.cpp.

{
}

Member Data Documentation

internal D2DBasicAnimation::__pad0__

Definition at line 16 of file D2DBasicAnimation.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> D2DBasicAnimation::m_blackBrush [private]

Definition at line 74 of file D2DBasicAnimation.h.

float D2DBasicAnimation::m_elapsedTime [private]

Definition at line 80 of file D2DBasicAnimation.h.

Microsoft::WRL::ComPtr<ID2D1PathGeometry> D2DBasicAnimation::m_objectGeometry [private]

Definition at line 77 of file D2DBasicAnimation.h.

Microsoft::WRL::ComPtr<ID2D1PathGeometry> D2DBasicAnimation::m_pathGeometry [private]

Definition at line 76 of file D2DBasicAnimation.h.

float D2DBasicAnimation::m_pathLength [private]

Definition at line 79 of file D2DBasicAnimation.h.

SampleOverlay D2DBasicAnimation::m_sampleOverlay [private]

Definition at line 71 of file D2DBasicAnimation.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2DBasicAnimation::m_textFormat [private]

Definition at line 75 of file D2DBasicAnimation.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> D2DBasicAnimation::m_whiteBrush [private]

Definition at line 78 of file D2DBasicAnimation.h.

bool D2DBasicAnimation::m_windowClosed [private]

Definition at line 72 of file D2DBasicAnimation.h.

bool D2DBasicAnimation::m_windowVisible [private]

Definition at line 73 of file D2DBasicAnimation.h.

The documentation for this class was generated from the following files:
  • Direct2D animation/C++/D2DBasicAnimation.h
  • Direct2D animation/C++/D2DBasicAnimation.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DEffectsHelloWorld Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

D2DEffectsHelloWorld Class Reference

#include "D2DEffectsHelloWorld.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: virtual void HandleDeviceLost() override

Private Member Functions

void | CreateEffectGraph ()
void | DecodeImage ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_bitmapSourceEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_gaussianBlurEffect
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IWICBitmapDecoder > 		m_wicDecoder
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_wicFormatConverter
Microsoft::WRL::ComPtr
< IWICBitmapFrameDecode > 		m_wicFrameDecode

Detailed Description

Definition at line 13 of file D2DEffectsHelloWorld.h.

Member Function Documentation

void D2DEffectsHelloWorld::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 33 of file D2DEffectsHelloWorld.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    DecodeImage();
}

void D2DEffectsHelloWorld::CreateDeviceResources ( ) [override, virtual]

Definition at line 40 of file D2DEffectsHelloWorld.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D basic image effects sample"
        );
}

void D2DEffectsHelloWorld::CreateEffectGraph ( ) [private]

Definition at line 99 of file D2DEffectsHelloWorld.cpp.

{
    UINT imageWidth;
    UINT imageHeight;
    m_wicFormatConverter->GetSize(&imageWidth, &imageHeight);

    D2D1_POINT_2F scale = D2D1::Point2F(
        m_renderTargetSize.Width/imageWidth,
        m_renderTargetSize.Height/imageHeight
        );

    // Create a Bitmap Source Effect.
    DX::ThrowIfFailed(m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_bitmapSourceEffect));

    // Set the scale property to the scale amount.
    DX::ThrowIfFailed(m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, scale));

    // Set the BitmapSource Property to the BitmapSource generated earlier.
    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE, m_wicFormatConverter.Get())
        );

    // Create the Gaussian Blur Effect.
    DX::ThrowIfFailed(m_d2dContext->CreateEffect(CLSID_D2D1GaussianBlur, &m_gaussianBlurEffect));

    // Set the input to recieve the bitmap from the BitmapSourceEffect.
    m_gaussianBlurEffect->SetInputEffect(0, m_bitmapSourceEffect.Get());

    // Set the blur amount.
    DX::ThrowIfFailed(m_gaussianBlurEffect->SetValue(D2D1_GAUSSIANBLUR_PROP_STANDARD_DEVIATION, sc_gaussianBlurStDev));
}

void D2DEffectsHelloWorld::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 55 of file D2DEffectsHelloWorld.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    CreateEffectGraph();
}

void D2DEffectsHelloWorld::DecodeImage ( ) [private]

Definition at line 62 of file D2DEffectsHelloWorld.cpp.

{
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"mammoth.jpg",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &m_wicDecoder
            )
        );

    DX::ThrowIfFailed(m_wicDecoder->GetFrame(0, &m_wicFrameDecode));

    DX::ThrowIfFailed(m_wicFactory->CreateFormatConverter(&m_wicFormatConverter));

    // We format convert to a pixel format that is compatible with Direct2D.
    // To optimize for performance when using WIC and Direct2D together, we need to
    // select the target pixel format based on the image's native precision:
    // - <= 8 bits per channel precision: use BGRA channel order
    //   (example: all JPEGs, including the image in this sample, are 8bpc)
    // -  > 8 bits per channel precision: use RGBA channel order
    //   (example: TIFF and JPEG-XR images support 32bpc float)
    // Note that a fully robust system will arbitrate between various WIC pixel formats
    // and hardware feature level support using the IWICPixelFormatInfo2 interface.
    DX::ThrowIfFailed(
        m_wicFormatConverter->Initialize(
            m_wicFrameDecode.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0f,
            WICBitmapPaletteTypeCustom
            )
        );
}

virtual void D2DEffectsHelloWorld::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void D2DEffectsHelloWorld::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 177 of file D2DEffectsHelloWorld.cpp.

{
    // This method is intentionally left empty.
}

void D2DEffectsHelloWorld::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DEffectsHelloWorld::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 217 of file D2DEffectsHelloWorld.cpp.

{
    // Ensure the D3D device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void D2DEffectsHelloWorld::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 208 of file D2DEffectsHelloWorld.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void D2DEffectsHelloWorld::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DEffectsHelloWorld::Render ( ) [override, virtual]

Definition at line 131 of file D2DEffectsHelloWorld.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));

    // Draw the scaled and blurred image.
    m_d2dContext->DrawImage(m_gaussianBlurEffect.Get());

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void D2DEffectsHelloWorld::Run ( ) [virtual]

Definition at line 184 of file D2DEffectsHelloWorld.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void D2DEffectsHelloWorld::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void D2DEffectsHelloWorld::Uninitialize ( ) [virtual]

Definition at line 192 of file D2DEffectsHelloWorld.cpp.

{
    // This method is intentionally left empty.
}

Member Data Documentation

internal D2DEffectsHelloWorld::__pad0__

Definition at line 17 of file D2DEffectsHelloWorld.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DEffectsHelloWorld::m_bitmapSourceEffect [private]

Definition at line 56 of file D2DEffectsHelloWorld.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DEffectsHelloWorld::m_gaussianBlurEffect [private]

Definition at line 57 of file D2DEffectsHelloWorld.h.

SampleOverlay D2DEffectsHelloWorld::m_sampleOverlay [private]

Definition at line 54 of file D2DEffectsHelloWorld.h.

Microsoft::WRL::ComPtr<IWICBitmapDecoder> D2DEffectsHelloWorld::m_wicDecoder [private]

Definition at line 59 of file D2DEffectsHelloWorld.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> D2DEffectsHelloWorld::m_wicFormatConverter [private]

Definition at line 61 of file D2DEffectsHelloWorld.h.

Microsoft::WRL::ComPtr<IWICBitmapFrameDecode> D2DEffectsHelloWorld::m_wicFrameDecode [private]

Definition at line 60 of file D2DEffectsHelloWorld.h.

The documentation for this class was generated from the following files:
  • Direct2D basic image effects/C++/D2DEffectsHelloWorld.h
  • Direct2D basic image effects/C++/D2DEffectsHelloWorld.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DEffectsOnPrimitives Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

D2DEffectsOnPrimitives Class Reference

#include "D2DEffectsOnPrimitives.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: virtual void HandleDeviceLost() override

Private Member Functions

void | CreateEffectGraph ()
void | CreatePrimitives ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_arithmeticCompositeEffect
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_coloredBrush
Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_inputImage
SampleOverlay m_sampleOverlay
Platform::String | m_string
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush

Detailed Description

Definition at line 13 of file D2DEffectsOnPrimitives.h.

Member Function Documentation

void D2DEffectsOnPrimitives::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 46 of file D2DEffectsOnPrimitives.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create the string to display.
    m_string = L"Direct2D";

    // Create a text format object to define the default font,
    // weight, stretch, style, and locale.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",                    // Font family name.
            nullptr,                        // Font collection (use the system font collection).
            DWRITE_FONT_WEIGHT_REGULAR,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            64.0f,                          // Font size.
            L"en-us",                       // Locale.
            &m_textFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );
}

void D2DEffectsOnPrimitives::CreateDeviceResources ( ) [override, virtual]

Definition at line 79 of file D2DEffectsOnPrimitives.cpp.

{
    DirectXBase::CreateDeviceResources();

    // Create the sample overlay.
    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        L"Direct2D effects on primitives sample"
        );

    // Create brushes for rendering Direct2D.
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::White), &m_whiteBrush)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::Red), &m_coloredBrush)
        );
}

void D2DEffectsOnPrimitives::CreateEffectGraph ( ) [private]

Definition at line 200 of file D2DEffectsOnPrimitives.cpp.

{
    ComPtr<ID2D1Effect> gaussianBlurEffect;
    ComPtr<ID2D1Effect> specularLightingEffect;
    ComPtr<ID2D1Effect> compositeEffect;

    // Create the Gaussian Blur Effect
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1GaussianBlur, &gaussianBlurEffect)
        );

    // Set the blur amount
    DX::ThrowIfFailed(
        gaussianBlurEffect->SetValue(D2D1_GAUSSIANBLUR_PROP_STANDARD_DEVIATION, sc_gaussianBlurStDev)
        );

    // Create the Specular Lighting Effect
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1PointSpecular, &specularLightingEffect)
        );

    DX::ThrowIfFailed(
        specularLightingEffect->SetValue(D2D1_POINTSPECULAR_PROP_LIGHT_POSITION, sc_specularLightPosition)
        );

    DX::ThrowIfFailed(
        specularLightingEffect->SetValue(D2D1_POINTSPECULAR_PROP_SPECULAR_EXPONENT, sc_specularExponent)
        );

    DX::ThrowIfFailed(
        specularLightingEffect->SetValue(D2D1_POINTSPECULAR_PROP_SURFACE_SCALE, sc_specularSurfaceScale)
        );

    DX::ThrowIfFailed(
        specularLightingEffect->SetValue(D2D1_POINTSPECULAR_PROP_SPECULAR_CONSTANT, sc_specularConstant)
        );

    // Create the Composite Effects
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1Composite, &compositeEffect)
        );

    DX::ThrowIfFailed(
        compositeEffect->SetValue(D2D1_COMPOSITE_PROP_MODE, D2D1_COMPOSITE_MODE_SOURCE_IN)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(CLSID_D2D1ArithmeticComposite, &m_arithmeticCompositeEffect)
        );

    DX::ThrowIfFailed(
        m_arithmeticCompositeEffect->SetValue(D2D1_ARITHMETICCOMPOSITE_PROP_COEFFICIENTS, sc_arithmeticCoefficients)
        );

    // Connect the graph.
    // Apply a blur effect to the original image.
    gaussianBlurEffect->SetInput(0, m_inputImage.Get());

    // Apply a specular lighting effect to the result.
    specularLightingEffect->SetInputEffect(0, gaussianBlurEffect.Get());

    // Compose the original bitmap under the output from lighting and blur.
    compositeEffect->SetInput(0, m_inputImage.Get());
    compositeEffect->SetInputEffect(1, specularLightingEffect.Get());

    // Compose the original bitmap under the output from lighting and blur.
    m_arithmeticCompositeEffect->SetInput(0, m_inputImage.Get());
    m_arithmeticCompositeEffect->SetInputEffect(1, compositeEffect.Get());
}

void D2DEffectsOnPrimitives::CreatePrimitives ( ) [private]

Definition at line 115 of file D2DEffectsOnPrimitives.cpp.

{
    // Convert from DIPs to pixels, since bitmaps are created in units of pixels.
    D2D1_SIZE_U bitmapSizeInPixels = D2D1::SizeU(
        static_cast<UINT32>(sc_inputBitmapSize.width / 96.0f * m_dpi),
        static_cast<UINT32>(sc_inputBitmapSize.height / 96.0f * m_dpi)
        );

    // Create the bitmap to which the effects will be applied.
    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmap(
            bitmapSizeInPixels,
            nullptr,
            0,
            D2D1::BitmapProperties1(
                D2D1_BITMAP_OPTIONS_TARGET,
                D2D1::PixelFormat(
                    DXGI_FORMAT_B8G8R8A8_UNORM,
                    D2D1_ALPHA_MODE_PREMULTIPLIED
                    ),
                m_dpi,
                m_dpi
                ),
            &m_inputImage
            )
        );

    // Draw onto the input bitmap instead of the window's surface.
    m_d2dContext->SetTarget(m_inputImage.Get());

    m_d2dContext->BeginDraw();

    // Clear the bitmap with transparent white.
    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::White, 0.0f));

    // Create a small rounded rectangle centered in the bitmap.
    D2D1_RECT_F rectangle1 = D2D1::RectF(
        (sc_inputBitmapSize.width - sc_smallRectangleSize.width) / 2,
        (sc_inputBitmapSize.height - sc_smallRectangleSize.height) / 2,
        (sc_inputBitmapSize.width + sc_smallRectangleSize.width) / 2,
        (sc_inputBitmapSize.height + sc_smallRectangleSize.height) / 2
        );

    D2D1_ROUNDED_RECT roundedRect1 = D2D1::RoundedRect(rectangle1, sc_roundingRadius, sc_roundingRadius);

    m_d2dContext->FillRoundedRectangle(&roundedRect1, m_coloredBrush.Get());

    // Create a larger rounded rectangle centered in the bitmap.
    D2D1_RECT_F rectangle2 = D2D1::RectF(
        (sc_inputBitmapSize.width - sc_largeRectangleSize.width) / 2,
        (sc_inputBitmapSize.height - sc_largeRectangleSize.height) / 2,
        (sc_inputBitmapSize.width + sc_largeRectangleSize.width) / 2,
        (sc_inputBitmapSize.height + sc_largeRectangleSize.height) / 2
        );

    D2D1_ROUNDED_RECT roundedRect2 = D2D1::RoundedRect(rectangle2, sc_roundingRadius, sc_roundingRadius);

    m_d2dContext->DrawRoundedRectangle(&roundedRect2, m_coloredBrush.Get(), sc_strokeWidth);

    // Draw some text onto the rectangles.
    m_d2dContext->DrawText(
        m_string->Data(),
        m_string->Length(),
        m_textFormat.Get(),
        D2D1::RectF(
            0,
            0,
            sc_inputBitmapSize.width,
            sc_inputBitmapSize.height
            ),
        m_whiteBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    // Reset the device context to render to the back buffer.
    m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
}

void D2DEffectsOnPrimitives::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 104 of file D2DEffectsOnPrimitives.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // Create the input bitmap of primitives.
    CreatePrimitives();

    // Create the image effects and apply them to the primitives.
    CreateEffectGraph();
}

virtual void D2DEffectsOnPrimitives::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void D2DEffectsOnPrimitives::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 333 of file D2DEffectsOnPrimitives.cpp.

{
    // This method is intentionally left empty.
}

void D2DEffectsOnPrimitives::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DEffectsOnPrimitives::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 373 of file D2DEffectsOnPrimitives.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void D2DEffectsOnPrimitives::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 364 of file D2DEffectsOnPrimitives.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void D2DEffectsOnPrimitives::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DEffectsOnPrimitives::Render ( ) [override, virtual]

Definition at line 270 of file D2DEffectsOnPrimitives.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Draw the bitmap with the original primitives.
    m_d2dContext->DrawImage(
        m_inputImage.Get(),
        D2D1::Point2F(
            (size.width - sc_inputBitmapSize.width) / 2,
            (size.height - sc_inputBitmapSize.height) / 2 - sc_offset
            )
        );

    // Draw the output of the effects graph.
    m_d2dContext->DrawImage(
        m_arithmeticCompositeEffect.Get(),
        D2D1::Point2F(
            (size.width - sc_inputBitmapSize.width) / 2,
            (size.height - sc_inputBitmapSize.height) / 2 + sc_offset
            )
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void D2DEffectsOnPrimitives::Run ( ) [virtual]

Definition at line 340 of file D2DEffectsOnPrimitives.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void D2DEffectsOnPrimitives::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void D2DEffectsOnPrimitives::Uninitialize ( ) [virtual]

Definition at line 348 of file D2DEffectsOnPrimitives.cpp.

{
    // This method is intentionally left empty.
}

Member Data Documentation

internal D2DEffectsOnPrimitives::__pad0__

Definition at line 17 of file D2DEffectsOnPrimitives.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DEffectsOnPrimitives::m_arithmeticCompositeEffect [private]

Definition at line 62 of file D2DEffectsOnPrimitives.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> D2DEffectsOnPrimitives::m_coloredBrush [private]

Definition at line 59 of file D2DEffectsOnPrimitives.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap1> D2DEffectsOnPrimitives::m_inputImage [private]

Definition at line 61 of file D2DEffectsOnPrimitives.h.

SampleOverlay D2DEffectsOnPrimitives::m_sampleOverlay [private]

Definition at line 54 of file D2DEffectsOnPrimitives.h.

Platform::String D2DEffectsOnPrimitives::m_string [private]

Definition at line 56 of file D2DEffectsOnPrimitives.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2DEffectsOnPrimitives::m_textFormat [private]

Definition at line 57 of file D2DEffectsOnPrimitives.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> D2DEffectsOnPrimitives::m_whiteBrush [private]

Definition at line 58 of file D2DEffectsOnPrimitives.h.

The documentation for this class was generated from the following files:
  • Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.h
  • Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DFactoryLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

D2DFactoryLock Class Reference

#include "D2DPageRendererContext.h"

List of all members.

Public Member Functions

D2DFactoryLock (_In_ ID2D1Factory *d2dFactory)
~D2DFactoryLock ()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Multithread > 		m_d2dMultithread

Detailed Description

Definition at line 22 of file D2DPageRendererContext.h.

Constructor & Destructor Documentation

D2DFactoryLock::D2DFactoryLock ( _In_ ID2D1Factory * d2dFactory ) [inline]

Definition at line 25 of file D2DPageRendererContext.h.

    {
        DX::ThrowIfFailed(
            d2dFactory->QueryInterface(IID_PPV_ARGS(&m_d2dMultithread))
            );

        m_d2dMultithread->Enter();
    }

D2DFactoryLock::~D2DFactoryLock ( ) [inline]

Definition at line 34 of file D2DPageRendererContext.h.

    {
        m_d2dMultithread->Leave();
    }

Member Data Documentation

Microsoft::WRL::ComPtr<ID2D1Multithread> D2DFactoryLock::m_d2dMultithread [private]

Definition at line 40 of file D2DPageRendererContext.h.

The documentation for this class was generated from the following file:
  • Direct2Dapp printing/C++/D2DPageRendererContext.h
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DInterpolationModes Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

D2DInterpolationModes Class Reference

#include "D2DInterpolationModes.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
void | MenuItemSelected (Windows::UI::Popups::IUICommand^command)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()
void | UpdateEffectMatrices ()

Public Attributes

internal | __pad0__: D2DInterpolationModes()

Private Member Functions

void | AddMenuItem (Windows::UI::Popups::PopupMenu^popupMenu, Platform::String^caption)
const float | Clamp (float v, float low, float high)
void | HandleManipulationUpdated (Windows::Foundation::Point position, Windows::Foundation::Point positionDelta, float zoomDelta)
void | HandlePointerPressed (Windows::UI::Input::PointerPoint^point)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnManipulationUpdated (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerWheelChanged (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_2DAffineTransformEffectLeft
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_2DAffineTransformEffectRight
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_bitmapSourceEffect
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
float | m_imageRotate
D2D1_SIZE_U | m_imageSize
D2D1_SIZE_F | m_imageSizeDips
bool | m_isSnapped
bool | m_isWindowClosed
bool | m_isWindowVisible
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_modeTextFormat
Platform::String | m_modeTextLeft
Platform::String | m_modeTextRight
float | m_renderDuration
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_renderTimeFormat
BasicTimer m_renderTimer
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_selectedEffect
float | m_totalZoom
D2D1_POINT_2F | m_viewPosition
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush

Detailed Description

Definition at line 16 of file D2DInterpolationModes.h.

Member Function Documentation

void D2DInterpolationModes::AddMenuItem | ( | Windows::UI::Popups::PopupMenu^ | popupMenu,
 |  | Platform::String^ | caption |
 | ) |  |  | [private]
const float D2DInterpolationModes::Clamp | ( | float | v,
 |  | float | low,
 |  | float | high |
 | ) |  |  | [inline, private]

Definition at line 119 of file D2DInterpolationModes.h.

    {
        return (v < low) ? low : (v > high) ? high : v;
    }

void D2DInterpolationModes::CreateDeviceResources ( ) [override, virtual]

Definition at line 40 of file D2DInterpolationModes.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D effects interpolation modes sample"
        );

    // Create Text Formats.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_THIN,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            30,
            L"en-US",
            &m_modeTextFormat
            )
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_THIN,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            20,
            L"en-US",
            &m_renderTimeFormat
            )
        );

    // Create white brush.
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_whiteBrush
            )
        );

    ComPtr<IWICBitmapDecoder> decoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"mammoth.jpg",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &decoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> frame;
    DX::ThrowIfFailed(
        decoder->GetFrame(0, &frame)
        );

    ComPtr<IWICFormatConverter> converter;
    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&converter)
        );

    DX::ThrowIfFailed(
        converter->Initialize(
            frame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0f,
            WICBitmapPaletteTypeCustom
            )
        );

    UINT width;
    UINT height;
    frame->GetSize(&width, &height);
    m_imageSize = D2D1::SizeU(width, height);

    // Create BitmapSource effect using the WIC Format Converter as an input.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1BitmapSource,
            &m_bitmapSourceEffect
            )
        );

    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(
            D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE,
            converter.Get()
            )
        );

    // Because the image produced by m_bitmapSourceEffect will never change,
    // enable caching for a performance gain.
    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(
            D2D1_PROPERTY_CACHED,
            TRUE
            )
        );

    // Create two 2DAffineTransform effects and set the inputs to the BitmapSource effect.
    // Both effects will default to the Nearest Neighbor interpolation mode.

    // Create left effect.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D12DAffineTransform,
            &m_2DAffineTransformEffectLeft
            )
        );

    m_2DAffineTransformEffectLeft->SetInputEffect(0, m_bitmapSourceEffect.Get(), false);

    DX::ThrowIfFailed(
        m_2DAffineTransformEffectLeft->SetValue(
            D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE,
            D2D1_INTERPOLATION_MODE_LINEAR
            )
        );

    m_modeTextLeft = "Interpolation mode: linear";

    // Create right effect.
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D12DAffineTransform,
            &m_2DAffineTransformEffectRight
            )
        );

    m_2DAffineTransformEffectRight->SetInputEffect(0, m_bitmapSourceEffect.Get(), false);

    DX::ThrowIfFailed(
        m_2DAffineTransformEffectRight->SetValue(
            D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE,
            D2D1_INTERPOLATION_MODE_LINEAR
            )
        );

    m_modeTextRight = "Interpolation mode: linear";

    m_selectedEffect = nullptr;
}

void D2DInterpolationModes::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 194 of file D2DInterpolationModes.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // Convert m_imageSize to DIPs in order to be DPI-independent.
    m_imageSizeDips =
        D2D1::SizeF(
            m_imageSize.width * 96.0f / m_dpi,
            m_imageSize.height * 96.0f / m_dpi
            );

    // Screen size in DIPs.
    D2D1_SIZE_F size = m_d2dContext->GetSize();

    m_totalZoom = min(
        size.width / m_imageSizeDips.width,
        size.height / m_imageSizeDips.height
        );

    UpdateEffectMatrices();
}

void D2DInterpolationModes::HandleManipulationUpdated | ( | Windows::Foundation::Point | position,
 |  | Windows::Foundation::Point | positionDelta,
 |  | float | zoomDelta |
 | ) |  |  | [private]
void D2DInterpolationModes::HandlePointerPressed ( Windows::UI::Input::PointerPoint^ point ) [private]
virtual void D2DInterpolationModes::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void D2DInterpolationModes::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 798 of file D2DInterpolationModes.cpp.

{
    // Retrieve user-manipulated variables from the LocalSettings collection if the app was previously suspended.
    IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;

    if (settingsValues->HasKey("m_totalZoom"))
    {
        m_totalZoom = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_totalZoom"))->GetSingle();
    }

    if (settingsValues->HasKey("m_viewPositionX"))
    {
        m_viewPosition.x = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_viewPositionX"))->GetSingle();
    }

    if (settingsValues->HasKey("m_viewPositionY"))
    {
        m_viewPosition.y = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_viewPositionY"))->GetSingle();
    }

    if (settingsValues->HasKey("m_imageRotate"))
    {
        m_imageRotate = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_imageRotate"))->GetSingle();
    }

    if (settingsValues->HasKey("leftInterpolationMode"))
    {
        int leftInterpolationMode = safe_cast<IPropertyValue^>(settingsValues->Lookup("leftInterpolationMode"))->GetInt32();
        m_2DAffineTransformEffectLeft->SetValue(D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE, leftInterpolationMode);
    }

    if (settingsValues->HasKey("rightInterpolationMode"))
    {
        int rightInterpolationMode = safe_cast<IPropertyValue^>(settingsValues->Lookup("rightInterpolationMode"))->GetInt32();
        m_2DAffineTransformEffectRight->SetValue(D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE, rightInterpolationMode);
    }

    if (settingsValues->HasKey("m_modeTextLeft"))
    {
        m_modeTextLeft = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_modeTextLeft"))->GetString();
    }

    if (settingsValues->HasKey("m_modeTextRight"))
    {
        m_modeTextRight = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_modeTextRight"))->GetString();
    }

    UpdateEffectMatrices();
}

void D2DInterpolationModes::MenuItemSelected ( Windows::UI::Popups::IUICommand^ command )
void D2DInterpolationModes::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]
void D2DInterpolationModes::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void D2DInterpolationModes::OnManipulationUpdated | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnPointerWheelChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 719 of file D2DInterpolationModes.cpp.

{
}

void D2DInterpolationModes::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DInterpolationModes::Render ( ) [override, virtual]

Definition at line 216 of file D2DInterpolationModes.cpp.

{
    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Start render duration timer.
    m_renderTimer->Update();

    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::DarkMagenta));

    // Caculate width, horizontal midpoint and height of screen, which will be used create
    // the rectangles that bound the left and right 2DAffineTransform effects.
    const float screenWidthMidpoint = size.width / 2.0f;
    const float screenWidth = size.width;
    const float screenHeight = size.height;

    // Draw left interpolation mode effect.
    m_d2dContext->DrawImage(
        m_2DAffineTransformEffectLeft.Get(),
        D2D1::Point2F(0, 0),
        D2D1::RectF(
            0,
            0,
            screenWidthMidpoint,
            screenHeight
            )
        );

    // Draw right interpolation mode effect.
    m_d2dContext->DrawImage(
        m_2DAffineTransformEffectRight.Get(),
        D2D1::Point2F(size.width / 2.0f, 0),
        D2D1::RectF(
            screenWidthMidpoint,
            0,
            screenWidth,
            screenHeight
            )
        );

    // Only draw text when not in snapped mode.
    if (!m_isSnapped)
    {
        // Draw left interpolation mode text.
        m_d2dContext->DrawText(
            m_modeTextLeft->Data(),
            m_modeTextLeft->Length(),
            m_modeTextFormat.Get(),
            D2D1::RectF(
                menuMargin,
                menuTop,
                screenWidthMidpoint,
                menuBottom
                ),
            m_whiteBrush.Get()
            );

        // Draw right interpolation mode text.
        m_d2dContext->DrawText(
            m_modeTextRight->Data(),
            m_modeTextRight->Length(),
            m_modeTextFormat.Get(),
            D2D1::RectF(
                menuMargin + screenWidthMidpoint,
                menuTop,
                screenWidth,
                menuBottom
                ),
            m_whiteBrush.Get()
            );

        // Don't draw render time on startup.
        if (m_renderDuration > 0.0f)
        {
            // Draw renderTime text, truncated to 2 decimal places.
            Platform::String^ renderTimeString =
                "Time to render frame: " + (floor(m_renderDuration * 100000.F) / 100.0f).ToString() + "ms";

            m_d2dContext->DrawText(
                renderTimeString->Data(),
                renderTimeString->Length(),
                m_renderTimeFormat.Get(),
                D2D1::RectF(
                    screenWidth - renderTimeTextOffset,
                    0,
                    screenWidth,
                    menuBottom
                    ),
                m_whiteBrush.Get()
                );
        }
    }

    // Create vertical line to divide the two interpolation modes.
    m_d2dContext->DrawLine(
        D2D1::Point2F(screenWidthMidpoint, 0.0f),
        D2D1::Point2F(screenWidthMidpoint, screenHeight),
        m_whiteBrush.Get(),
        0.5F
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();

    // Measure how long it took to perform image rendering operations.
    m_renderTimer->Update();
    m_renderDuration = m_renderTimer->Delta;

    Present();
}

void D2DInterpolationModes::Run ( ) [virtual]

Definition at line 850 of file D2DInterpolationModes.cpp.

{
    while (!m_isWindowClosed)
    {
        if (m_isWindowVisible)
        {
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
            m_gestureRecognizer->ProcessInertia();
        }
        else
        {
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
        }
    }
}

virtual void D2DInterpolationModes::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void D2DInterpolationModes::Uninitialize ( ) [virtual]

Definition at line 794 of file D2DInterpolationModes.cpp.

{
}

void D2DInterpolationModes::UpdateEffectMatrices ( )

Definition at line 450 of file D2DInterpolationModes.cpp.

{
    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Snaps image to center of screen once zoomed out.
    if (m_imageSizeDips.width * m_totalZoom < size.width ||
        m_imageSizeDips.height * m_totalZoom < size.height)
    {
        m_viewPosition.x = size.width / 2 - m_imageSizeDips.width * m_totalZoom / 2;
        m_viewPosition.y = size.height / 2 - m_imageSizeDips.height * m_totalZoom / 2;
    }

    Matrix3x2F scale = Matrix3x2F::Scale(m_totalZoom, m_totalZoom);

    Matrix3x2F translate = Matrix3x2F::Translation(
        m_viewPosition.x,
        m_viewPosition.y
        );

    Matrix3x2F rotate = Matrix3x2F::Rotation(
        m_imageRotate,
        D2D1::Point2F(
            size.width / 2,
            size.height / 2
            )
        );

    Matrix3x2F transformMatrix = scale * translate * rotate;

    DX::ThrowIfFailed(
        m_2DAffineTransformEffectLeft->SetValue(
            D2D1_2DAFFINETRANSFORM_PROP_TRANSFORM_MATRIX,
            transformMatrix
            )
        );

    DX::ThrowIfFailed(
        m_2DAffineTransformEffectRight->SetValue(
            D2D1_2DAFFINETRANSFORM_PROP_TRANSFORM_MATRIX,
            transformMatrix
            )
        );

    Render();
}

Member Data Documentation

internal D2DInterpolationModes::__pad0__

Definition at line 19 of file D2DInterpolationModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DInterpolationModes::m_2DAffineTransformEffectLeft [private]

Definition at line 143 of file D2DInterpolationModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DInterpolationModes::m_2DAffineTransformEffectRight [private]

Definition at line 144 of file D2DInterpolationModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DInterpolationModes::m_bitmapSourceEffect [private]

Definition at line 142 of file D2DInterpolationModes.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> D2DInterpolationModes::m_gestureRecognizer [private]

Definition at line 124 of file D2DInterpolationModes.h.

float D2DInterpolationModes::m_imageRotate [private]

Definition at line 134 of file D2DInterpolationModes.h.

D2D1_SIZE_U D2DInterpolationModes::m_imageSize [private]

Definition at line 136 of file D2DInterpolationModes.h.

D2D1_SIZE_F D2DInterpolationModes::m_imageSizeDips [private]

Definition at line 137 of file D2DInterpolationModes.h.

bool D2DInterpolationModes::m_isSnapped [private]

Definition at line 138 of file D2DInterpolationModes.h.

bool D2DInterpolationModes::m_isWindowClosed [private]

Definition at line 153 of file D2DInterpolationModes.h.

bool D2DInterpolationModes::m_isWindowVisible [private]

Definition at line 154 of file D2DInterpolationModes.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2DInterpolationModes::m_modeTextFormat [private]

Definition at line 130 of file D2DInterpolationModes.h.

Platform::String D2DInterpolationModes::m_modeTextLeft [private]

Definition at line 128 of file D2DInterpolationModes.h.

Platform::String D2DInterpolationModes::m_modeTextRight [private]

Definition at line 129 of file D2DInterpolationModes.h.

float D2DInterpolationModes::m_renderDuration [private]

Definition at line 151 of file D2DInterpolationModes.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2DInterpolationModes::m_renderTimeFormat [private]

Definition at line 131 of file D2DInterpolationModes.h.

BasicTimer D2DInterpolationModes::m_renderTimer [private]

Definition at line 150 of file D2DInterpolationModes.h.

SampleOverlay D2DInterpolationModes::m_sampleOverlay [private]

Definition at line 140 of file D2DInterpolationModes.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DInterpolationModes::m_selectedEffect [private]

Definition at line 147 of file D2DInterpolationModes.h.

float D2DInterpolationModes::m_totalZoom [private]

Definition at line 133 of file D2DInterpolationModes.h.

D2D1_POINT_2F D2DInterpolationModes::m_viewPosition [private]

Definition at line 135 of file D2DInterpolationModes.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> D2DInterpolationModes::m_whiteBrush [private]

Definition at line 126 of file D2DInterpolationModes.h.

The documentation for this class was generated from the following files:
  • Direct2D interpolation modes/C++/D2DInterpolationModes.h
  • Direct2D interpolation modes/C++/D2DInterpolationModes.cpp
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DLightingEffects::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • D2DLightingEffects
  • D2DLightingEffects::sealed
Public Member Functions | Private Member Functions | Private Attributes

D2DLightingEffects::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
void | InitializeValues ()
MainPage ()
virtual void | OnLaunched (_In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
void | OnSuspending (Object^sender, Windows::ApplicationModel::SuspendingEventArgs^args)
void | ResetValues ()

Private Member Functions

void | OnAzimuthValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnDiffuseConstantValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnDisplayContentsInvalidated (Object^sender)
void | OnEffectSelectorSelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | OnElevationValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnLightPositionZValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnLimitingConeAngleValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnLogicalDpiChanged (Object^sender)
void | OnRestoreDefaultsClick (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSpecularConstantValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnSpecularExponentValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnSpotFocusValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnSurfaceScaleValueChanged (Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSwapChainPointerMoved (Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnWindowSizeChanged (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | SetLightingEffect (LightingEffect lightingEffect)
void | SetLightingProperty (LightingProperty lightingProperty, float value)

Private Attributes

MainPage | m_mainPage
D2DLightingEffectsRenderer m_renderer

Detailed Description

Definition at line 16 of file App.xaml.h.

Member Function Documentation

D2DLightingEffects::sealed::App ( )
void D2DLightingEffects::sealed::InitializeValues ( )
D2DLightingEffects::sealed::MainPage ( )
void D2DLightingEffects::sealed::OnAzimuthValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnDiffuseConstantValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnDisplayContentsInvalidated ( Object^ sender ) [private]
void D2DLightingEffects::sealed::OnEffectSelectorSelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnElevationValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
virtual void D2DLightingEffects::sealed::OnLaunched ( _In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
void D2DLightingEffects::sealed::OnLightPositionZValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnLimitingConeAngleValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnLogicalDpiChanged ( Object^ sender ) [private]
void D2DLightingEffects::sealed::OnRestoreDefaultsClick | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnSpecularConstantValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnSpecularExponentValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnSpotFocusValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnSurfaceScaleValueChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnSuspending | ( | Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | args
 | ) |  |
void D2DLightingEffects::sealed::OnSwapChainPointerMoved | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | args |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::OnWindowSizeChanged | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DLightingEffects::sealed::ResetValues ( )
void D2DLightingEffects::sealed::SetLightingEffect ( LightingEffect lightingEffect ) [private]
void D2DLightingEffects::sealed::SetLightingProperty | ( | LightingProperty | lightingProperty,
 |  | float | value |
 | ) |  |  | [private]

Member Data Documentation

MainPage D2DLightingEffects::sealed::m_mainPage [private]

Definition at line 36 of file App.xaml.h.

D2DLightingEffectsRenderer D2DLightingEffects::sealed::m_renderer [private]

Definition at line 105 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • XAML Direct2D lighting effects/C++/App.xaml.h
  • XAML Direct2D lighting effects/C++/MainPage.xaml.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DLightingEffectsRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

D2DLightingEffectsRenderer Class Reference

#include "D2DLightingEffectsRenderer.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | HandleDeviceLost () override
bool | NeedsResourceUpdate ()
void | OnPointerMoved (float x, float y)
virtual void | Render () override
void | SetLightingEffect (LightingEffect lightingEffect)
void | SetLightingProperty (LightingProperty lightingProperty, float value)
void | UpdateForViewStateChanged (Windows::UI::ViewManagement::ApplicationViewState state)

Public Attributes

internal | __pad0__: D2DLightingEffectsRenderer()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_bitmapSourceEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_currentEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_distantDiffuseEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_distantSpecularEffect
D2D1_SIZE_U | m_imageSize
float | m_lightPositionZ
bool | m_needsResourceUpdate
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_pointDiffuseEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_pointSpecularEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_spotDiffuseEffect
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_spotSpecularEffect
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_wicConverter
Windows::UI::ViewManagement::ApplicationViewState | m_windowState

Detailed Description

Definition at line 37 of file D2DLightingEffectsRenderer.h.

Member Function Documentation

virtual void D2DLightingEffectsRenderer::CreateDeviceIndependentResources ( ) [override, virtual]
virtual void D2DLightingEffectsRenderer::CreateDeviceResources ( ) [override, virtual]
virtual void D2DLightingEffectsRenderer::CreateWindowSizeDependentResources ( ) [override, virtual]
virtual void D2DLightingEffectsRenderer::HandleDeviceLost ( ) [override, virtual]
bool D2DLightingEffectsRenderer::NeedsResourceUpdate ( ) [inline]

Definition at line 55 of file D2DLightingEffectsRenderer.h.

    {
        return m_needsResourceUpdate;
    }

void D2DLightingEffectsRenderer::OnPointerMoved | ( | float | x,
 |  | float | y
 | ) |  |
virtual void D2DLightingEffectsRenderer::Render ( ) [override, virtual]
void D2DLightingEffectsRenderer::SetLightingEffect ( LightingEffect lightingEffect )
void D2DLightingEffectsRenderer::SetLightingProperty | ( | LightingProperty | lightingProperty,
 |  | float | value
 | ) |  |
void D2DLightingEffectsRenderer::UpdateForViewStateChanged ( Windows::UI::ViewManagement::ApplicationViewState state )

Member Data Documentation

internal D2DLightingEffectsRenderer::__pad0__

Definition at line 40 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DLightingEffectsRenderer::m_bitmapSourceEffect [private]

Definition at line 67 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DLightingEffectsRenderer::m_currentEffect [private]

Definition at line 69 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DLightingEffectsRenderer::m_distantDiffuseEffect [private]

Definition at line 75 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DLightingEffectsRenderer::m_distantSpecularEffect [private]

Definition at line 72 of file D2DLightingEffectsRenderer.h.

D2D1_SIZE_U D2DLightingEffectsRenderer::m_imageSize [private]

Definition at line 65 of file D2DLightingEffectsRenderer.h.

float D2DLightingEffectsRenderer::m_lightPositionZ [private]

Definition at line 77 of file D2DLightingEffectsRenderer.h.

bool D2DLightingEffectsRenderer::m_needsResourceUpdate [private]

Definition at line 62 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DLightingEffectsRenderer::m_pointDiffuseEffect [private]

Definition at line 73 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DLightingEffectsRenderer::m_pointSpecularEffect [private]

Definition at line 70 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DLightingEffectsRenderer::m_spotDiffuseEffect [private]

Definition at line 74 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> D2DLightingEffectsRenderer::m_spotSpecularEffect [private]

Definition at line 71 of file D2DLightingEffectsRenderer.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> D2DLightingEffectsRenderer::m_wicConverter [private]

Definition at line 64 of file D2DLightingEffectsRenderer.h.

Windows::UI::ViewManagement::ApplicationViewState D2DLightingEffectsRenderer::m_windowState [private]

Definition at line 61 of file D2DLightingEffectsRenderer.h.

The documentation for this class was generated from the following file:
  • XAML Direct2D lighting effects/C++/D2DLightingEffectsRenderer.h
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DPerspectiveTransform Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

D2DPerspectiveTransform Class Reference

#include "D2DPerspectiveTransform.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: D2DPerspectiveTransform()

Private Member Functions

void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnManipulationUpdated (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_bitmapPerspective
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
float | m_rotationAngle
SampleOverlay m_sampleOverlay

Detailed Description

Definition at line 13 of file D2DPerspectiveTransform.h.

Member Function Documentation

void D2DPerspectiveTransform::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 29 of file D2DPerspectiveTransform.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();
}

void D2DPerspectiveTransform::CreateDeviceResources ( ) [override, virtual]

Definition at line 34 of file D2DPerspectiveTransform.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D perspective transform sample"
        );

    // Load a bitmap from the Windows Imaging Component decoder.
    ComPtr<IWICBitmapDecoder> decoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"mammoth_small.jpg",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &decoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> frame;
    DX::ThrowIfFailed(
        decoder->GetFrame(0, &frame)
        );

    ComPtr<IWICFormatConverter> converter;
    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&converter)
        );

    // We format convert to a pixel format that is compatible with Direct2D.
    // To optimize for performance when using WIC and Direct2D together, we need to
    // select the target pixel format based on the image's native precision:
    // - <= 8 bits per channel precision: use BGRA channel order
    //   (example: all JPEGs, including the image in this sample, are 8bpc)
    // -  > 8 bits per channel precision: use RGBA channel order
    //   (example: TIFF and JPEG-XR images support 32bpc float
    // Note that a fully robust system will arbitrate between various WIC pixel formats and
    // hardware feature level support using the IWICPixelFormatInfo2 interface.
    DX::ThrowIfFailed(
        converter->Initialize(
            frame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0f,
            WICBitmapPaletteTypeCustom
            )
        );

    // Create bitmap from WIC bitmap.
    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmapFromWicBitmap(
            converter.Get(),
            nullptr,
            &m_bitmapPerspective
            )
        );
}

void D2DPerspectiveTransform::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 100 of file D2DPerspectiveTransform.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();
}

virtual void D2DPerspectiveTransform::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void D2DPerspectiveTransform::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 196 of file D2DPerspectiveTransform.cpp.

{
    // Retrieve any stored variables from the LocalSettings collection.
    IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;

    if (settingsValues->HasKey("m_rotationAngle"))
    {
        m_rotationAngle = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_rotationAngle"))->GetSingle();
    }
}

void D2DPerspectiveTransform::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DPerspectiveTransform::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 241 of file D2DPerspectiveTransform.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void D2DPerspectiveTransform::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 232 of file D2DPerspectiveTransform.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void D2DPerspectiveTransform::OnManipulationUpdated | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DPerspectiveTransform::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DPerspectiveTransform::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DPerspectiveTransform::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DPerspectiveTransform::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 275 of file D2DPerspectiveTransform.cpp.

{
}

void D2DPerspectiveTransform::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void D2DPerspectiveTransform::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DPerspectiveTransform::Render ( ) [override, virtual]

Definition at line 105 of file D2DPerspectiveTransform.cpp.

{
    m_d2dContext->BeginDraw();
    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    D2D1_RECT_F destRect = D2D1::RectF(
        size.width / 4,
        size.height / 4,
        3 * size.width / 4,
        3 * size.height / 4
        );

    // Center the Image and apply the perspective transformation with rotation along the Y-axis.
    D2D1::Matrix4x4F matrix =
        D2D1::Matrix4x4F::Translation(-size.width/ 2, -size.height / 2, 0.0f) *
        D2D1::Matrix4x4F::RotationY(m_rotationAngle) *
        D2D1::Matrix4x4F::PerspectiveProjection(size.width/ 2) *
        D2D1::Matrix4x4F::Translation(size.width/ 2, size.height / 2, 0.0f);

    m_d2dContext->DrawBitmap(
        m_bitmapPerspective.Get(),
        &destRect,
        1.0f, // Draw the bitmap fully opaque.
        D2D1_INTERPOLATION_MODE_LINEAR,
        nullptr, // Use the full source bitmap for sampling.
        &matrix
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void D2DPerspectiveTransform::Run ( ) [virtual]

Definition at line 209 of file D2DPerspectiveTransform.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void D2DPerspectiveTransform::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void D2DPerspectiveTransform::Uninitialize ( ) [virtual]

Definition at line 217 of file D2DPerspectiveTransform.cpp.

{
}

Member Data Documentation

internal D2DPerspectiveTransform::__pad0__

Definition at line 16 of file D2DPerspectiveTransform.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap1> D2DPerspectiveTransform::m_bitmapPerspective [private]

Definition at line 85 of file D2DPerspectiveTransform.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> D2DPerspectiveTransform::m_gestureRecognizer [private]

Definition at line 86 of file D2DPerspectiveTransform.h.

float D2DPerspectiveTransform::m_rotationAngle [private]

Definition at line 87 of file D2DPerspectiveTransform.h.

SampleOverlay D2DPerspectiveTransform::m_sampleOverlay [private]

Definition at line 84 of file D2DPerspectiveTransform.h.

The documentation for this class was generated from the following files:
  • Direct2D perspective transform/C++/D2DPerspectiveTransform.h
  • Direct2D perspective transform/C++/D2DPerspectiveTransform.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DTextAnimation Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

D2DTextAnimation Class Reference

#include "D2DTextAnimation.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
void | CreateOpacityMask ()
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: D2DTextAnimation()

Private Member Functions

void | CalculateCenterPosition ()
void | DrawTextLayout (float x, float y)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnManipulationCompleted (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::ManipulationCompletedEventArgs^args)
void | OnManipulationUpdated (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerWheelChanged (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnTapped (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::TappedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

bool | m_animating
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
bool | m_firstRun
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_opacityBitmap
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
DWRITE_TEXT_METRICS | m_textMetrics
Windows::Foundation::Point | m_viewPosition
float | m_zoom

Detailed Description

Definition at line 18 of file D2DTextAnimation.h.

Member Function Documentation

void D2DTextAnimation::CalculateCenterPosition ( ) [private]

Definition at line 110 of file D2DTextAnimation.cpp.

{
    D2D1_SIZE_F size = m_d2dContext->GetSize();
    m_viewPosition.X = size.width/2 - m_textMetrics.widthIncludingTrailingWhitespace/2;
    m_viewPosition.Y = size.height/2 - m_textMetrics.height/2;
}

void D2DTextAnimation::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 36 of file D2DTextAnimation.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    Platform::String^ text = L"This sample demonstrates how to efficiently render animated text with D2D and DWrite. The text in this sample can be scaled and panned using touch and mouse controls. As the text's size and position are manipulated, this sample renders the animated text using a faster rendering mode than what is used when the text is static.";

    // Create a text format object to describe the text's style.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            18.0f,
            L"en-us",
            &m_textFormat
            )
        );

    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            text->Data(),
            text->Length(),
            m_textFormat.Get(),
            700, // maxWidth
            1000, // maxHeight
            &m_textLayout
            )
        );

    DX::ThrowIfFailed(
        m_textLayout->GetMetrics(&m_textMetrics)
        );
}

void D2DTextAnimation::CreateDeviceResources ( ) [override, virtual]

Definition at line 76 of file D2DTextAnimation.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D animated text sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );

    CreateOpacityMask();
}

void D2DTextAnimation::CreateOpacityMask ( )

Definition at line 117 of file D2DTextAnimation.cpp.

{
    D2D1_BITMAP_PROPERTIES1 properties = D2D1::BitmapProperties1(
        D2D1_BITMAP_OPTIONS_TARGET,
        D2D1::PixelFormat(DXGI_FORMAT_A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED)
        );

    D2D1_SIZE_U opacityBitmapSize = D2D1::SizeU(
        static_cast<UINT32>(OpacityMaskScaler * m_textMetrics.widthIncludingTrailingWhitespace),
        static_cast<UINT32>(OpacityMaskScaler * m_textMetrics.height)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmap(
            opacityBitmapSize,
            nullptr,
            0,
            &properties,
            &m_opacityBitmap
            )
        );

    D2D1::Matrix3x2F zoom = D2D1::Matrix3x2F::Scale(
        OpacityMaskScaler,
        OpacityMaskScaler
        );

    m_d2dContext->SetTarget(m_opacityBitmap.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(zoom);

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black, 0.0f));

    DrawTextLayout(0.0f, 0.0f);

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_d2dContext->SetTarget(nullptr);
}

void D2DTextAnimation::DrawTextLayout | ( | float | x,
 |  | float | y |
 | ) |  |  | [private]

Definition at line 100 of file D2DTextAnimation.cpp.

{
    m_d2dContext->DrawTextLayout(
        D2D1::Point2F(x, y),
        m_textLayout.Get(),
        m_blackBrush.Get(),
        D2D1_DRAW_TEXT_OPTIONS_NO_SNAP
        );
}

virtual void D2DTextAnimation::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void D2DTextAnimation::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 279 of file D2DTextAnimation.cpp.

{
    // Retrieve any stored variables from the LocalSettings collection.
    IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;

    if (settingsValues->HasKey("m_viewPosition"))
    {
        m_viewPosition = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_viewPosition"))->GetPoint();
    }

    if (settingsValues->HasKey("m_zoom"))
    {
        m_zoom = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_zoom"))->GetSingle();
    }

    if (settingsValues->HasKey("m_firstRun"))
    {
        m_firstRun = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_firstRun"))->GetBoolean();
    }
}

void D2DTextAnimation::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 334 of file D2DTextAnimation.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void D2DTextAnimation::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 325 of file D2DTextAnimation.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void D2DTextAnimation::OnManipulationCompleted | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::ManipulationCompletedEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnManipulationUpdated | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnPointerWheelChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnTapped | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::TappedEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void D2DTextAnimation::Render ( ) [override, virtual]

Definition at line 163 of file D2DTextAnimation.cpp.

{
    if (m_firstRun)
    {
        CalculateCenterPosition();
        m_firstRun = false;
    }

    D2D1::Matrix3x2F translation = D2D1::Matrix3x2F::Translation(
        m_viewPosition.X,
        m_viewPosition.Y
        );

    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));

    if (!m_animating)
    {
        // Use default (high quality) text rendering when the text is not being animated.
        D2D1::Matrix3x2F zoom = D2D1::Matrix3x2F::Scale(m_zoom, m_zoom);
        m_d2dContext->SetTransform(zoom * translation);
        DrawTextLayout(0.0f, 0.0f);
    }
    else
    {
        // Use fast opacity mask text rendering when the text is being animated.
        D2D1::Matrix3x2F defaultZoom = D2D1::Matrix3x2F::Scale(
            m_zoom / OpacityMaskScaler,
            m_zoom / OpacityMaskScaler
            );
        m_d2dContext->SetTransform(defaultZoom * translation);
        m_d2dContext->SetAntialiasMode(D2D1_ANTIALIAS_MODE_ALIASED);
        m_d2dContext->FillOpacityMask(m_opacityBitmap.Get(), m_blackBrush.Get(), D2D1_OPACITY_MASK_CONTENT_GRAPHICS);
        m_d2dContext->SetAntialiasMode(D2D1_ANTIALIAS_MODE_PER_PRIMITIVE);
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void D2DTextAnimation::Run ( ) [virtual]

Definition at line 302 of file D2DTextAnimation.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void D2DTextAnimation::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void D2DTextAnimation::Uninitialize ( ) [virtual]

Definition at line 310 of file D2DTextAnimation.cpp.

{
}

Member Data Documentation

internal D2DTextAnimation::__pad0__

Definition at line 21 of file D2DTextAnimation.h.

bool D2DTextAnimation::m_animating [private]

Definition at line 113 of file D2DTextAnimation.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> D2DTextAnimation::m_blackBrush [private]

Definition at line 106 of file D2DTextAnimation.h.

bool D2DTextAnimation::m_firstRun [private]

Definition at line 114 of file D2DTextAnimation.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> D2DTextAnimation::m_gestureRecognizer [private]

Definition at line 105 of file D2DTextAnimation.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap1> D2DTextAnimation::m_opacityBitmap [private]

Definition at line 108 of file D2DTextAnimation.h.

SampleOverlay D2DTextAnimation::m_sampleOverlay [private]

Definition at line 104 of file D2DTextAnimation.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> D2DTextAnimation::m_textFormat [private]

Definition at line 107 of file D2DTextAnimation.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> D2DTextAnimation::m_textLayout [private]

Definition at line 109 of file D2DTextAnimation.h.

DWRITE_TEXT_METRICS D2DTextAnimation::m_textMetrics [private]

Definition at line 110 of file D2DTextAnimation.h.

Windows::Foundation::Point D2DTextAnimation::m_viewPosition [private]

Definition at line 111 of file D2DTextAnimation.h.

float D2DTextAnimation::m_zoom [private]

Definition at line 112 of file D2DTextAnimation.h.

The documentation for this class was generated from the following files:
  • Direct2D animated text/C++/D2DTextAnimation.h
  • Direct2D animated text/C++/D2DTextAnimation.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D3DPostProcessing Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

D3DPostProcessing Class Reference

#include "D3DPostProcessing.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | HandleDeviceLost () override
virtual void | Render () override
void | Update (float timeTotal, float timeDelta)

Public Attributes

internal | __pad0__: D3DPostProcessing()

Private Member Functions

void | BrightPassDownFilter ()
void | CombineGlow ()
void | DrawQuad (ID3D11PixelShader *pixelShader, uint width, uint height)
void | RenderGlow ()

Private Attributes

Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_brightPassConstantBuffer
Microsoft::WRL::ComPtr
< ID3D11RenderTargetView > 		m_brightPassTextureRenderTargetView
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_brightPassTextureShaderResourceView
BasicCamera m_camera
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_downScaleBrightPass9PixelShader
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_downScaleBrightPassPixelShader
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_finalPassPixelShader
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_glowConstantBuffer
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_glowPixelShader
uint m_glowTextureHeight
Microsoft::WRL::ComPtr
< ID3D11RenderTargetView > 		m_glowTextureRenderTargetViews [numberOfGlowTextures]
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_glowTextureShaderResourceViews [numberOfGlowTextures]
uint m_glowTextureWidth
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
uint m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
uint m_intermediateRenderTargetHeight
uint m_intermediateRenderTargetWidth
Microsoft::WRL::ComPtr
< ID3D11RenderTargetView > 		m_intermediateTextureRenderTargetView
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_intermediateTextureShaderResourceView
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_linearSampler
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_pointSampler
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_quadLayout
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_quadVertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_quadVertexShader
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_texture
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureShaderResourceView
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 51 of file D3DPostProcessing.h.

Member Function Documentation

void D3DPostProcessing::BrightPassDownFilter ( ) [private]

Definition at line 678 of file D3DPostProcessing.cpp.

{
    m_d3dContext->OMSetRenderTargets(
        1,
        m_brightPassTextureRenderTargetView.GetAddressOf(),
        nullptr
        );

    m_d3dContext->PSSetShaderResources(
        0,
        1,
        m_intermediateTextureShaderResourceView.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,
        1,
        m_linearSampler.GetAddressOf()
        );

    if (m_featureLevel <= D3D_FEATURE_LEVEL_9_3)
    {
        // Bind constant buffer for pixel size
        m_d3dContext->PSSetConstantBuffers(
            0,
            1,
            m_brightPassConstantBuffer.GetAddressOf()
            );

        // Use DX9 pixel shader on a device of DX9 feature level
        DrawQuad(
            m_downScaleBrightPass9PixelShader.Get(),
            m_glowTextureWidth,
            m_glowTextureHeight
            );

        // unbind constant buffer
        ID3D11Buffer* nullConstantBuffers[] = {0};
        m_d3dContext->PSSetConstantBuffers(
            0,
            1,
            nullConstantBuffers
            );

    }
    else
    {
        // use the DX10 or later pixel shader
        DrawQuad(
            m_downScaleBrightPassPixelShader.Get(),
            m_glowTextureWidth,
            m_glowTextureHeight
            );
    }

    ID3D11ShaderResourceView* nullShaderResourceViews[] = { 0, 0 };
    m_d3dContext->PSSetShaderResources(0, 2, nullShaderResourceViews);
}

void D3DPostProcessing::CombineGlow ( ) [private]

Definition at line 941 of file D3DPostProcessing.cpp.

{
    // bind the final backbuffer render target
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),                 // backbuffer Render Target View
        nullptr                                            // no depth stencil
        );

    ID3D11ShaderResourceView* shaderResourceViews[] =
    {
        m_intermediateTextureShaderResourceView.Get(),
        m_glowTextureShaderResourceViews[0].Get()
    };

    m_d3dContext->PSSetShaderResources(
        0,
        2,
        shaderResourceViews
        );

    ID3D11SamplerState* samplers[] =
    {
        m_pointSampler.Get(),
        m_linearSampler.Get()
    };

    m_d3dContext->PSSetSamplers(
        0,
        2,
        samplers
        );

    DrawQuad(
        m_finalPassPixelShader.Get(),
        static_cast<uint>(m_renderTargetSize.Width),
        static_cast<uint>(m_renderTargetSize.Height)
        );

    // unbind shader resource views
    ID3D11ShaderResourceView* nullShaderResourceViews[] = { 0, 0, 0, 0 };
    m_d3dContext->PSSetShaderResources(
        0,
        4,
        nullShaderResourceViews
        );
}

void D3DPostProcessing::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 38 of file D3DPostProcessing.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();
}

void D3DPostProcessing::CreateDeviceResources ( ) [override, virtual]

Definition at line 43 of file D3DPostProcessing.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct3D post-processing effects sample"
        );

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    loader->LoadShader(
        "SimpleVertexShader.cso",
        nullptr,
        0,
        &m_vertexShader,
        &m_inputLayout
        );

    // create the vertex and index buffers for drawing the cube

    BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());

    shapes->CreateCube(
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // Create the constant buffer for updating model and camera data
    CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &constantBufferDescription,
            nullptr,             // Leave the buffer uninitialized
            &m_constantBuffer
            )
        );

    loader->LoadShader(
        "SimplePixelShader.cso",
        &m_pixelShader
        );

    loader->LoadTexture(
        "texture.dds",
        &m_texture,
        &m_textureShaderResourceView
        );

    // create the sampler
    D3D11_SAMPLER_DESC samplerDescription;
    samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.MipLODBias = 0.0f;
    samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
    samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDescription.BorderColor[0] = 0.0f;
    samplerDescription.BorderColor[1] = 0.0f;
    samplerDescription.BorderColor[2] = 0.0f;
    samplerDescription.BorderColor[3] = 0.0f;
    samplerDescription.MinLOD = 0;      // This allows the use of all mip levels
    samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDescription,
            &m_sampler)
        );

    m_camera = ref new BasicCamera();

    // Create resources for the Post Processing sample
    // Load the compiled Post Processing pixel shaders

    if (m_featureLevel <= D3D_FEATURE_LEVEL_9_3)
    {
        // load pixel shader for feature level 9
        loader->LoadShader(
            "DownScaleBrightPass9.cso",
            &m_downScaleBrightPass9PixelShader
            );
    }
    else
    {
        // load pixel shader for DX10 and higher feature-level hardware
        loader->LoadShader(
            "DownScale3x3BrightPass.cso",
            &m_downScaleBrightPassPixelShader
            );
    }

    loader->LoadShader(
        "Glow.cso",
        &m_glowPixelShader
        );

    loader->LoadShader(
        "FinalPass.cso",
        &m_finalPassPixelShader
        );

    // create the full window quad input layout
    D3D11_INPUT_ELEMENT_DESC quadLayout[] =
    {
        { "POSITION", 0, DXGI_FORMAT_R32G32B32A32_FLOAT, 0, 0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
        { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT, 0, D3D11_APPEND_ALIGNED_ELEMENT, D3D11_INPUT_PER_VERTEX_DATA, 0 },
    };

    // load the compiled Quad Vertex Shader

    loader->LoadShader(
        "QuadVertexShader.cso",
        quadLayout,
        2,
        &m_quadVertexShader,
        &m_quadLayout
        );

    // Setup constant buffer for DX9 version of the brightness threshold pixel shader
    D3D11_BUFFER_DESC brightPassConstantBufferDescription;
    brightPassConstantBufferDescription.Usage = D3D11_USAGE_DYNAMIC;
    brightPassConstantBufferDescription.BindFlags = D3D11_BIND_CONSTANT_BUFFER;
    brightPassConstantBufferDescription.CPUAccessFlags = D3D11_CPU_ACCESS_WRITE;
    brightPassConstantBufferDescription.MiscFlags = 0;
    brightPassConstantBufferDescription.ByteWidth =
        (sizeof(ConstantBufferLayoutForDX9BrightPassPixelShader) + 15) & ~0xF; // round size up to multiple of 16 bytes

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &brightPassConstantBufferDescription,
            nullptr,             // leave the buffer uninitialized
            &m_brightPassConstantBuffer
            )
        );

    // Setup constant buffer for Glow Pixel Shader
    D3D11_BUFFER_DESC glowConstantBufferDescription;
    glowConstantBufferDescription.Usage = D3D11_USAGE_DYNAMIC;
    glowConstantBufferDescription.BindFlags = D3D11_BIND_CONSTANT_BUFFER;
    glowConstantBufferDescription.CPUAccessFlags = D3D11_CPU_ACCESS_WRITE;
    glowConstantBufferDescription.MiscFlags = 0;
    glowConstantBufferDescription.ByteWidth = sizeof(ConstantBufferLayoutForGlowPixelShader);

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &glowConstantBufferDescription,
            nullptr,             // leave the buffer uninitialized
            &m_glowConstantBuffer
            )
        );

    // Samplers for Post Processing
    samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDescription.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDescription,
            &m_linearSampler
            )
        );

    samplerDescription.Filter = D3D11_FILTER_MIN_MAG_MIP_POINT;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDescription,
            &m_pointSampler
            )
        );

    // Create a quad vertex buffer for render-to-texture operations
    ScreenQuadVertex screenVertexQuad[4];
    screenVertexQuad[0].pos = float4(-1.0f, 1.0f, 0.5f, 1.0f);
    screenVertexQuad[0].tex = float2(0.0f, 0.0f);
    screenVertexQuad[1].pos = float4(1.0f, 1.0f, 0.5f, 1.0f);
    screenVertexQuad[1].tex = float2(1.0f, 0.0f);
    screenVertexQuad[2].pos = float4(-1.0f, -1.0f, 0.5f, 1.0f);
    screenVertexQuad[2].tex = float2(0.0f, 1.0f);
    screenVertexQuad[3].pos = float4(1.0f, -1.0f, 0.5f, 1.0f);
    screenVertexQuad[3].tex = float2(1.0f, 1.0f);

    D3D11_BUFFER_DESC vertexBufferDescription =
    {
        4 * sizeof(ScreenQuadVertex),
        D3D11_USAGE_DEFAULT,
        D3D11_BIND_VERTEX_BUFFER,
        0,
        0
    };

    D3D11_SUBRESOURCE_DATA initData;
    initData.pSysMem = screenVertexQuad;
    initData.SysMemPitch = 0;
    initData.SysMemSlicePitch = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &vertexBufferDescription,
            &initData,
            &m_quadVertexBuffer
            )
        );
}

void D3DPostProcessing::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 258 of file D3DPostProcessing.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // update the 3D projection matrix
    m_camera->SetProjectionParameters(
        70.0f,                                                  // use a 70-degree vertical field of view
        m_renderTargetSize.Width / m_renderTargetSize.Height,   // specify the aspect ratio of the window
        0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
        100.0f                                                  // specify the farthest Z-distance at which to draw vertices
        );

    // save the new projection matrix to the constant buffer data struct
    m_camera->GetProjectionMatrix(&m_constantBufferData.projection);

    // setup Post Processing sample-specific window size-dependent resources

    m_intermediateRenderTargetWidth  = static_cast<unsigned int>(m_renderTargetSize.Width  * 0.6f);
    m_intermediateRenderTargetHeight = static_cast<unsigned int>(m_renderTargetSize.Height * 0.6f);

    m_glowTextureWidth  = static_cast<unsigned int>(m_intermediateRenderTargetWidth  / 4.0f);
    m_glowTextureHeight = static_cast<unsigned int>(m_intermediateRenderTargetHeight / 4.0f);

    // set pixel size in DX9 level brightness threshold pass constant buffer

    D3D11_MAPPED_SUBRESOURCE mappedResource;
    DX::ThrowIfFailed (
        m_d3dContext->Map(
            m_brightPassConstantBuffer.Get(),
            0,
            D3D11_MAP_WRITE_DISCARD,
            0,
            &mappedResource
            )
        );

    ConstantBufferLayoutForDX9BrightPassPixelShader* brightPassConstantBuffer =
        static_cast<ConstantBufferLayoutForDX9BrightPassPixelShader*>(mappedResource.pData);

    brightPassConstantBuffer->pixelWidth  = 1.0f / m_intermediateRenderTargetWidth;
    brightPassConstantBuffer->pixelHeight = 1.0f / m_intermediateRenderTargetHeight;

    m_d3dContext->Unmap(
        m_brightPassConstantBuffer.Get(),
        0
        );

    // create intermediate render target for 3D cube scene

    Microsoft::WRL::ComPtr<ID3D11Texture2D> intermediateTexture; // will recieve 3D cube scene

    D3D11_TEXTURE2D_DESC intermediateRenderTargetDescription;
    ZeroMemory(&intermediateRenderTargetDescription, sizeof(D3D11_TEXTURE2D_DESC));
    intermediateRenderTargetDescription.ArraySize = 1;
    intermediateRenderTargetDescription.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
    intermediateRenderTargetDescription.Usage = D3D11_USAGE_DEFAULT;
    intermediateRenderTargetDescription.Format = DXGI_FORMAT_R8G8B8A8_UNORM;
    intermediateRenderTargetDescription.Width  = m_intermediateRenderTargetWidth;
    intermediateRenderTargetDescription.Height = m_intermediateRenderTargetHeight;
    intermediateRenderTargetDescription.MipLevels = 1;
    intermediateRenderTargetDescription.SampleDesc.Count = 1;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateTexture2D(
            &intermediateRenderTargetDescription,
            nullptr,
            &intermediateTexture
            )
        );

    // create the render target view
    D3D11_RENDER_TARGET_VIEW_DESC intermediateRenderTargetViewDescription;
    intermediateRenderTargetViewDescription.Format = intermediateRenderTargetDescription.Format;
    intermediateRenderTargetViewDescription.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
    intermediateRenderTargetViewDescription.Texture2D.MipSlice = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateRenderTargetView(
            intermediateTexture.Get(),
            &intermediateRenderTargetViewDescription,
            &m_intermediateTextureRenderTargetView
            )
        );

    // Create the shader resource view
    D3D11_SHADER_RESOURCE_VIEW_DESC intermediateShaderResourceViewDescription;
    intermediateShaderResourceViewDescription.Format = intermediateRenderTargetDescription.Format;
    intermediateShaderResourceViewDescription.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
    intermediateShaderResourceViewDescription.Texture2D.MipLevels = 1;
    intermediateShaderResourceViewDescription.Texture2D.MostDetailedMip = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateShaderResourceView(
            intermediateTexture.Get(),
            &intermediateShaderResourceViewDescription,
            &m_intermediateTextureShaderResourceView
            )
        );

    // Create a descriptor for the depth/stencil buffer.
    CD3D11_TEXTURE2D_DESC depthStencilDesc(
        DXGI_FORMAT_D24_UNORM_S8_UINT,
        m_intermediateRenderTargetWidth,
        m_intermediateRenderTargetHeight,
        1,
        1,
        D3D11_BIND_DEPTH_STENCIL
        );

    // Allocate a 2-D surface as the depth/stencil buffer.
    ComPtr<ID3D11Texture2D> depthStencil;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateTexture2D(
            &depthStencilDesc,
            nullptr,
            &depthStencil
            )
        );

    // Create a DepthStencil view on this surface to use on bind.
    CD3D11_DEPTH_STENCIL_VIEW_DESC depthStencilViewDesc(D3D11_DSV_DIMENSION_TEXTURE2D);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateDepthStencilView(
            depthStencil.Get(),
            &depthStencilViewDesc,
            &m_d3dDepthStencilView
            )
        );

    // Create the intermediate glow effect blur textures and views

    Microsoft::WRL::ComPtr<ID3D11Texture2D> glowTextures[numberOfGlowTextures];      // render targets for horizontal and vertical glow blur

    // Render target description for glow effect textures
    D3D11_TEXTURE2D_DESC glowTextureDescription;
    ZeroMemory(&glowTextureDescription, sizeof(D3D11_TEXTURE2D_DESC));
    glowTextureDescription.ArraySize = 1;
    glowTextureDescription.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
    glowTextureDescription.Usage = D3D11_USAGE_DEFAULT;
    glowTextureDescription.Format = DXGI_FORMAT_R8G8B8A8_UNORM;
    glowTextureDescription.Width = m_glowTextureWidth;
    glowTextureDescription.Height = m_glowTextureHeight;
    glowTextureDescription.MipLevels = 1;
    glowTextureDescription.SampleDesc.Count = 1;

    // Render target view description
    ZeroMemory(&intermediateRenderTargetViewDescription, sizeof(D3D11_RENDER_TARGET_VIEW_DESC));
    intermediateRenderTargetViewDescription.Format = glowTextureDescription.Format;
    intermediateRenderTargetViewDescription.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
    intermediateRenderTargetViewDescription.Texture2D.MipSlice = 0;

    // Shader resource view description
    ZeroMemory(&intermediateShaderResourceViewDescription, sizeof(D3D11_SHADER_RESOURCE_VIEW_DESC));
    intermediateShaderResourceViewDescription.Format = glowTextureDescription.Format;
    intermediateShaderResourceViewDescription.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
    intermediateShaderResourceViewDescription.Texture2D.MipLevels = 1;
    intermediateShaderResourceViewDescription.Texture2D.MostDetailedMip = 0;

    for (int i = 0; i < numberOfGlowTextures; i++)
    {
        DX::ThrowIfFailed(
            m_d3dDevice->CreateTexture2D(
                &glowTextureDescription,
                nullptr,
                &(glowTextures[i])
                )
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateRenderTargetView(
                glowTextures[i].Get(),
                &intermediateRenderTargetViewDescription,
                &(m_glowTextureRenderTargetViews[i])
                )
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateShaderResourceView(
                glowTextures[i].Get(),
                &intermediateShaderResourceViewDescription,
                &(m_glowTextureShaderResourceViews[i])
                )
            );
    }

    // Create the brightness threshold pass texture and views

    Microsoft::WRL::ComPtr<ID3D11Texture2D> brightPassTexture;    // render target for scaled down brightness threshold image

    DX::ThrowIfFailed(
        m_d3dDevice->CreateTexture2D(
            &glowTextureDescription,
            nullptr,
            &brightPassTexture
            )
        );

    intermediateRenderTargetViewDescription.Format = glowTextureDescription.Format;
    intermediateRenderTargetViewDescription.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
    intermediateRenderTargetViewDescription.Texture2D.MipSlice = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateRenderTargetView(
            brightPassTexture.Get(),
            &intermediateRenderTargetViewDescription,
            &m_brightPassTextureRenderTargetView
            )
        );

    intermediateShaderResourceViewDescription.Format = glowTextureDescription.Format;
    intermediateShaderResourceViewDescription.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
    intermediateShaderResourceViewDescription.Texture2D.MipLevels = 1;
    intermediateShaderResourceViewDescription.Texture2D.MostDetailedMip = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateShaderResourceView(
            brightPassTexture.Get(),
            &intermediateShaderResourceViewDescription,
            &m_brightPassTextureShaderResourceView
            )
        );

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void D3DPostProcessing::DrawQuad | ( | ID3D11PixelShader * | pixelShader,
 |  | uint | width,
 |  | uint | height |
 | ) |  |  | [private]

Definition at line 624 of file D3DPostProcessing.cpp.

{
    // Save the old viewport
    D3D11_VIEWPORT oldViewPort[1];
    unsigned int numberOfViewPorts = 1;
    m_d3dContext->RSGetViewports(&numberOfViewPorts, oldViewPort);

    // Setup the viewport to match the Render Target
    D3D11_VIEWPORT viewPort = {0};
    viewPort.Width = static_cast<float>(width);
    viewPort.Height = static_cast<float>(height);
    viewPort.MinDepth = 0.0f;
    viewPort.MaxDepth = 1.0f;
    viewPort.TopLeftX = 0;
    viewPort.TopLeftY = 0;
    m_d3dContext->RSSetViewports(1, &viewPort);

    unsigned int strides = sizeof(ScreenQuadVertex);
    unsigned int offsets = 0;

    m_d3dContext->IASetInputLayout(m_quadLayout.Get());

    m_d3dContext->IASetVertexBuffers(
        0,
        1,
        m_quadVertexBuffer.GetAddressOf(),
        &strides,
        &offsets
        );

    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP);

    m_d3dContext->VSSetShader(
        m_quadVertexShader.Get(),
        nullptr,
        0
        );

    m_d3dContext->PSSetShader(
        pixelShader,
        nullptr,
        0
        );

    m_d3dContext->Draw(4, 0);  // draw all 4 vertices of the quad, starting with vertex 0

    // Restore the Old viewport
    m_d3dContext->RSSetViewports(numberOfViewPorts, oldViewPort);
}

void D3DPostProcessing::HandleDeviceLost ( ) [override, virtual]

Definition at line 21 of file D3DPostProcessing.cpp.

{
    // Release window size-dependent resources prior to creating a new device and swap chain.
    m_intermediateTextureRenderTargetView = nullptr;
    m_intermediateTextureShaderResourceView = nullptr;
    m_brightPassTextureRenderTargetView = nullptr;
    m_brightPassTextureShaderResourceView = nullptr;

    for (int n = 0; n < numberOfGlowTextures; n++)
    {
        m_glowTextureRenderTargetViews[n] = nullptr;
        m_glowTextureShaderResourceViews[n] = nullptr;
    }

    DirectXBase::HandleDeviceLost();
}

void D3DPostProcessing::Render ( ) [override, virtual]

Definition at line 483 of file D3DPostProcessing.cpp.

{
    // for Post Processing sample bind intermediate render target instead of backbuffer
    m_d3dContext->OMSetRenderTargets(
        1,
        m_intermediateTextureRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // clear both the render target and depth stencil to default values
    const float clearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        m_intermediateTextureRenderTargetView.Get(),
        clearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    // set the vertex and index buffers, and specify the way they define geometry
    unsigned int stride = sizeof(BasicVertex);
    unsigned int offset = 0;

    m_d3dContext->IASetVertexBuffers(
        0,                              // starting at the first vertex buffer slot
        1,                              // set one vertex buffer binding
        m_vertexBuffer.GetAddressOf(),
        &stride,                        // specify the size in bytes of a single vertex
        &offset                         // specify the base vertex in the buffer
        );

    // set the index buffer
    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,   // unsigned short index format
        0                       // specify the base index in the buffer
        );

    // specify the way the vertex and index buffers define geometry
    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    // set the vertex shader stage state
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                              // starting at the first constant buffer slot
        1,                              // set one constant buffer binding
        m_constantBuffer.GetAddressOf()
        );

    // set the pixel shader stage state
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->PSSetShaderResources(
        0,                          // starting at the first shader resource slot
        1,                          // set one shader resource binding
        m_textureShaderResourceView.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,                          // starting at the first sampler slot
        1,                          // set one sampler binding
        m_sampler.GetAddressOf()
        );

    // Save the backbuffer viewport
    D3D11_VIEWPORT oldViewPort[1];
    unsigned int numberOfViewPorts = 1;
    m_d3dContext->RSGetViewports(&numberOfViewPorts, oldViewPort);

    // Setup the viewport to match the Intermediate Render Target
    D3D11_VIEWPORT viewPort = {0};
    viewPort.Width  = static_cast<float>(m_intermediateRenderTargetWidth);
    viewPort.Height = static_cast<float>(m_intermediateRenderTargetHeight);
    viewPort.MinDepth = 0.0f;
    viewPort.MaxDepth = 1.0f;
    viewPort.TopLeftX = 0;
    viewPort.TopLeftY = 0;
    m_d3dContext->RSSetViewports(1, &viewPort);

    // draw the cube
    m_d3dContext->DrawIndexed(
        m_indexCount,   // draw all created vertices
        0,              // starting with the first vertex
        0               // and the first index
        );

    // Restore the backbuffer viewport
    m_d3dContext->RSSetViewports(numberOfViewPorts, oldViewPort);

    // post processing: rendered 3D cube frame is now in the intermediate texture buffer

    BrightPassDownFilter(); // render brightness thresholded down-sample version

    RenderGlow();  // apply separable blur to brightness image -> glow

    CombineGlow(); // combine 3D cube frame and glow into backbuffer

    m_sampleOverlay->Render();
}

void D3DPostProcessing::RenderGlow ( ) [private]

Definition at line 784 of file D3DPostProcessing.cpp.

{
    // Horizontal Blur
    D3D11_MAPPED_SUBRESOURCE mappedResource;
    DX::ThrowIfFailed (
        m_d3dContext->Map(
            m_glowConstantBuffer.Get(),
            0,
            D3D11_MAP_WRITE_DISCARD,
            0,
            &mappedResource
            )
        );

    ConstantBufferLayoutForGlowPixelShader* glowConstantBuffer =
        reinterpret_cast<ConstantBufferLayoutForGlowPixelShader*>(mappedResource.pData);

    float4* sampleOffsets = glowConstantBuffer->sampleOffsets;
    float4* sampleWeights = glowConstantBuffer->sampleWeights;

    float textureCoordinateOffsets[blurKernelSpan];

    GetSampleOffsetsWeightsForBlur(
        m_glowTextureWidth,
        textureCoordinateOffsets,
        sampleWeights,
        5.0f,
        1.35f
        );

    for (int i = 0; i < 15; i++)
    {
        sampleOffsets[i] = float4(textureCoordinateOffsets[i], 0.0f, 0.0f, 0.0f);
    }

    m_d3dContext->Unmap(
        m_glowConstantBuffer.Get(),
        0
        );

    m_d3dContext->PSSetConstantBuffers(
        0,
        1,
        m_glowConstantBuffer.GetAddressOf()
        );

    m_d3dContext->OMSetRenderTargets(
        1,
        m_glowTextureRenderTargetViews[1].GetAddressOf(),
        nullptr
        );

    m_d3dContext->PSSetShaderResources(
        0,
        1,
        m_brightPassTextureShaderResourceView.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,
        1,
        m_pointSampler.GetAddressOf()
        );

    // render horizontally blurred brightness threshold image
    // from m_brightPassTexture to m_glowTexture[1]
    DrawQuad(
        m_glowPixelShader.Get(),
        m_glowTextureWidth,
        m_glowTextureHeight
        );

    // unbind shader resource views
    ID3D11ShaderResourceView* nullShaderResourceViews[] = { 0, 0, 0, 0 };
    m_d3dContext->PSSetShaderResources(
        0,
        4,
        nullShaderResourceViews
        );

    // Vertical Blur
    DX::ThrowIfFailed (
        m_d3dContext->Map(
            m_glowConstantBuffer.Get(),
            0,
            D3D11_MAP_WRITE_DISCARD,
            0,
            &mappedResource
            )
        );

    glowConstantBuffer = reinterpret_cast<ConstantBufferLayoutForGlowPixelShader*>(mappedResource.pData);
    sampleOffsets = glowConstantBuffer->sampleOffsets;
    sampleWeights = glowConstantBuffer->sampleWeights;

    GetSampleOffsetsWeightsForBlur(
        m_glowTextureHeight,
        textureCoordinateOffsets,
        sampleWeights,
        5.0f,
        1.35f
        );

    for (int i = 0; i < 15; i++)
    {
        sampleOffsets[i] = float4(0.0f, textureCoordinateOffsets[i], 0.0f, 0.0f);
    }

    m_d3dContext->Unmap(
        m_glowConstantBuffer.Get(),
        0
        );

    m_d3dContext->PSSetConstantBuffers(
        0,
        1,
        m_glowConstantBuffer.GetAddressOf()
        );

    m_d3dContext->OMSetRenderTargets(
        1,
        m_glowTextureRenderTargetViews[0].GetAddressOf(),
        nullptr
        );

    m_d3dContext->PSSetShaderResources(
        0,
        1,
        m_glowTextureShaderResourceViews[1].GetAddressOf()
        );

    // render vertically blurred horizontally blurred brightness threshold image
    // from m_glowTexture[1] to m_glowTexture[0]
    DrawQuad(
        m_glowPixelShader.Get(),
        m_glowTextureWidth,
        m_glowTextureHeight
        );

    // unbind shader resource views
    m_d3dContext->PSSetShaderResources(
        0,
        4,
        nullShaderResourceViews
        );

    // unbind constant buffer
    ID3D11Buffer* nullConstantBuffers[] = {0};
    m_d3dContext->PSSetConstantBuffers(
        0,
        1,
        nullConstantBuffers
        );
}

void D3DPostProcessing::Update | ( | float | timeTotal,
 |  | float | timeDelta
 | ) |  |

Definition at line 599 of file D3DPostProcessing.cpp.

{
    // update the model matrix based on the time
    m_constantBufferData.model = rotationY(-timeTotal * 60.0f);

    // update the view matrix based on the camera position
    // note that for this sample, the camera position is fixed
    m_camera->SetViewParameters(
        float3(0, 1.0f, 2.0f),
        float3(0, 0, 0),
        float3(0, 1, 0));

    m_camera->GetViewMatrix(&m_constantBufferData.view);

    // update the constant buffer with the new data
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_constantBufferData,
        0,
        0
        );
}

Member Data Documentation

internal D3DPostProcessing::__pad0__

Definition at line 54 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> D3DPostProcessing::m_brightPassConstantBuffer [private]

Definition at line 87 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11RenderTargetView> D3DPostProcessing::m_brightPassTextureRenderTargetView [private]

Definition at line 89 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> D3DPostProcessing::m_brightPassTextureShaderResourceView [private]

Definition at line 90 of file D3DPostProcessing.h.

BasicCamera D3DPostProcessing::m_camera [private]

Definition at line 79 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> D3DPostProcessing::m_constantBuffer [private]

Definition at line 75 of file D3DPostProcessing.h.

ConstantBuffer D3DPostProcessing::m_constantBufferData [private]

Definition at line 78 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> D3DPostProcessing::m_downScaleBrightPass9PixelShader [private]

Definition at line 100 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> D3DPostProcessing::m_downScaleBrightPassPixelShader [private]

Definition at line 99 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> D3DPostProcessing::m_finalPassPixelShader [private]

Definition at line 102 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> D3DPostProcessing::m_glowConstantBuffer [private]

Definition at line 88 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> D3DPostProcessing::m_glowPixelShader [private]

Definition at line 101 of file D3DPostProcessing.h.

uint D3DPostProcessing::m_glowTextureHeight [private]

Definition at line 96 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11RenderTargetView> D3DPostProcessing::m_glowTextureRenderTargetViews[numberOfGlowTextures] [private]

Definition at line 91 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> D3DPostProcessing::m_glowTextureShaderResourceViews[numberOfGlowTextures] [private]

Definition at line 92 of file D3DPostProcessing.h.

uint D3DPostProcessing::m_glowTextureWidth [private]

Definition at line 95 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> D3DPostProcessing::m_indexBuffer [private]

Definition at line 69 of file D3DPostProcessing.h.

uint D3DPostProcessing::m_indexCount [private]

Definition at line 77 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> D3DPostProcessing::m_inputLayout [private]

Definition at line 67 of file D3DPostProcessing.h.

uint D3DPostProcessing::m_intermediateRenderTargetHeight [private]

Definition at line 94 of file D3DPostProcessing.h.

uint D3DPostProcessing::m_intermediateRenderTargetWidth [private]

Definition at line 93 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11RenderTargetView> D3DPostProcessing::m_intermediateTextureRenderTargetView [private]

Definition at line 82 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> D3DPostProcessing::m_intermediateTextureShaderResourceView [private]

Definition at line 83 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> D3DPostProcessing::m_linearSampler [private]

Definition at line 105 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> D3DPostProcessing::m_pixelShader [private]

Definition at line 71 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> D3DPostProcessing::m_pointSampler [private]

Definition at line 104 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> D3DPostProcessing::m_quadLayout [private]

Definition at line 85 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> D3DPostProcessing::m_quadVertexBuffer [private]

Definition at line 84 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> D3DPostProcessing::m_quadVertexShader [private]

Definition at line 86 of file D3DPostProcessing.h.

SampleOverlay D3DPostProcessing::m_sampleOverlay [private]

Definition at line 65 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> D3DPostProcessing::m_sampler [private]

Definition at line 74 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> D3DPostProcessing::m_texture [private]

Definition at line 72 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> D3DPostProcessing::m_textureShaderResourceView [private]

Definition at line 73 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> D3DPostProcessing::m_vertexBuffer [private]

Definition at line 68 of file D3DPostProcessing.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> D3DPostProcessing::m_vertexShader [private]

Definition at line 70 of file D3DPostProcessing.h.

The documentation for this class was generated from the following files:
  • Direct3D post-processing effects/C++/D3DPostProcessing.h
  • Direct3D post-processing effects/C++/D3DPostProcessing.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocketSample::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DatagramSocketSample
  • Common
  • DatagramSocketSample::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DatagramSocketSample::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 30 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String DatagramSocketSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void DatagramSocketSample::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 186 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void DatagramSocketSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void DatagramSocketSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 127 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal DatagramSocketSample::Common::LayoutAwarePage::__pad0__

Definition at line 33 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> DatagramSocketSample::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 54 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> DatagramSocketSample::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 56 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken DatagramSocketSample::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 55 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • DatagramSocket/C++/Common/LayoutAwarePage.h
  • DatagramSocket/C++/Common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocketSample::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DatagramSocketSample
  • DatagramSocketSample::MainPage

DatagramSocketSample::MainPage Class Reference

#include "Constants.h"

Detailed Description

Definition at line 23 of file Constants.h.

The documentation for this class was generated from the following file:
  • DatagramSocket/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocketSample::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DatagramSocketSample
  • DatagramSocketSample::Scenario
Public Attributes

DatagramSocketSample::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String DatagramSocketSample::Scenario::ClassName

Definition at line 20 of file Constants.h.

Platform::String DatagramSocketSample::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • DatagramSocket/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocketSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DatagramSocketSample
  • DatagramSocketSample::sealed
Public Member Functions | Public Attributes | Protected Member Functions | Properties | Private Member Functions | Private Attributes

DatagramSocketSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "App.xaml.h"

List of all members.

Public Member Functions

DataWriter | GetWriter ()
boolean | IsConnected ()
bool | IsMatching (HostName^hostName, String^port)
ListenerContext (MainPage^rootPage, DatagramSocket^listener)
void | LoadScenario (Platform::String^scenarioName)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
void | OnMessage (DatagramSocket^socket, DatagramSocketMessageReceivedEventArgs^eventArguments)
void | OnMessage (DatagramSocket^socket, DatagramSocketMessageReceivedEventArgs^eventArguments)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
void | SetConnected ()
SocketContext (MainPage^rootPage, DatagramSocket^socket)

Public Attributes

internal | __pad0__: App()

Protected Member Functions

void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

~ListenerContext ()
~MainPage ()
~SocketContext ()
void | CloseSockets_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ConnectSocket_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | EchoMessage (DatagramSocketMessageReceivedEventArgs^eventArguments)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateSize ()
void | InvalidateViewState ()
void | NotifyUserFromAsyncThread (String^message, NotifyType type)
void | NotifyUserFromAsyncThread (String^message, NotifyType type)
void | PopulateScenarios ()
void | SendHello_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetFeatureName (Platform::String^strFeature)
void | StartListener_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

bool | autoSizeInputSectionWhenSnapped
boolean | connected
Windows::UI::Xaml::Controls::Frame | HiddenFrame
HostName | hostName
DatagramSocket | listener
CRITICAL_SECTION | lock
IOutputStream | outputStream
String | port
Windows::UI::Xaml::Controls::Frame | rootFrame
MainPage rootPage
Platform::Collections::Vector
< Object^> 		ScenarioList
DatagramSocket | socket
DataWriter | writer

Detailed Description

Definition at line 25 of file App.xaml.h.

Constructor & Destructor Documentation

DatagramSocketSample::sealed::~MainPage ( ) [private]
DatagramSocketSample::sealed::~ListenerContext ( ) [private]
DatagramSocketSample::sealed::~SocketContext ( ) [private]

Member Function Documentation

void DatagramSocketSample::sealed::CloseSockets_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void DatagramSocketSample::sealed::ConnectSocket_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void DatagramSocketSample::sealed::EchoMessage ( DatagramSocketMessageReceivedEventArgs^ eventArguments ) [private]
void DatagramSocketSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
DataWriter DatagramSocketSample::sealed::GetWriter ( )
void DatagramSocketSample::sealed::InvalidateSize ( ) [private]
void DatagramSocketSample::sealed::InvalidateViewState ( ) [private]
boolean DatagramSocketSample::sealed::IsConnected ( )
bool DatagramSocketSample::sealed::IsMatching | ( | HostName^ | hostName,
 |  | String^ | port
 | ) |  |
DatagramSocketSample::sealed::ListenerContext | ( | MainPage^ | rootPage,
 |  | DatagramSocket^ | listener
 | ) |  |
void DatagramSocketSample::sealed::LoadScenario ( Platform::String^ scenarioName )
DatagramSocketSample::sealed::MainPage ( )
void DatagramSocketSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void DatagramSocketSample::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void DatagramSocketSample::sealed::NotifyUserFromAsyncThread | ( | String^ | message,
 |  | NotifyType | type |
 | ) |  |  | [private]
void DatagramSocketSample::sealed::NotifyUserFromAsyncThread | ( | String^ | message,
 |  | NotifyType | type |
 | ) |  |  | [private]
virtual void DatagramSocketSample::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
void DatagramSocketSample::sealed::OnMessage | ( | DatagramSocket^ | socket,
 |  | DatagramSocketMessageReceivedEventArgs^ | eventArguments
 | ) |  |
void DatagramSocketSample::sealed::OnMessage | ( | DatagramSocket^ | socket,
 |  | DatagramSocketMessageReceivedEventArgs^ | eventArguments
 | ) |  |
virtual void DatagramSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void DatagramSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void DatagramSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void DatagramSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void DatagramSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void DatagramSocketSample::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void DatagramSocketSample::sealed::PopulateScenarios ( ) [private]
DatagramSocketSample::sealed::Scenario1 ( )
DatagramSocketSample::sealed::Scenario2 ( )
DatagramSocketSample::sealed::Scenario3 ( )
DatagramSocketSample::sealed::Scenario4 ( )
void DatagramSocketSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void DatagramSocketSample::sealed::SendHello_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void DatagramSocketSample::sealed::SetConnected ( )
void DatagramSocketSample::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
DatagramSocketSample::sealed::SocketContext | ( | MainPage^ | rootPage,
 |  | DatagramSocket^ | socket
 | ) |  |
void DatagramSocketSample::sealed::StartListener_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal sealed::__pad0__

Definition at line 28 of file App.xaml.h.

bool DatagramSocketSample::sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 89 of file MainPage.xaml.h.

boolean DatagramSocketSample::sealed::connected [private]

Definition at line 59 of file Scenario2.xaml.h.

Windows::UI::Xaml::Controls::Frame DatagramSocketSample::sealed::HiddenFrame [private]

Definition at line 87 of file MainPage.xaml.h.

HostName DatagramSocketSample::sealed::hostName [private]

Definition at line 57 of file Scenario1.xaml.h.

DatagramSocket DatagramSocketSample::sealed::listener [private]

Definition at line 55 of file Scenario1.xaml.h.

CRITICAL_SECTION DatagramSocketSample::sealed::lock [private]

Definition at line 53 of file Scenario1.xaml.h.

IOutputStream DatagramSocketSample::sealed::outputStream [private]

Definition at line 56 of file Scenario1.xaml.h.

String DatagramSocketSample::sealed::port [private]

Definition at line 58 of file Scenario1.xaml.h.

Windows::UI::Xaml::Controls::Frame DatagramSocketSample::sealed::rootFrame [private]

Definition at line 33 of file App.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

Platform::Collections::Vector<Object^> DatagramSocketSample::sealed::ScenarioList [private]

Definition at line 86 of file MainPage.xaml.h.

DatagramSocket DatagramSocketSample::sealed::socket [private]

Definition at line 57 of file Scenario2.xaml.h.

DataWriter DatagramSocketSample::sealed::writer [private]

Definition at line 58 of file Scenario2.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> DatagramSocketSample::sealed::MainPageResized

Definition at line 76 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> DatagramSocketSample::sealed::ScenarioLoaded

Definition at line 75 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • DatagramSocket/C++/App.xaml.h
  • DatagramSocket/C++/MainPage.xaml.h
  • DatagramSocket/C++/Scenario1.xaml.h
  • DatagramSocket/C++/Scenario2.xaml.h
  • DatagramSocket/C++/Scenario3.xaml.h
  • DatagramSocket/C++/Scenario4.xaml.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DDS_HEADER Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

DDS_HEADER Struct Reference

List of all members.

Public Attributes

uint32 | caps
uint32 | caps2
uint32 | caps3
uint32 | caps4
DDS_PIXELFORMAT ddspf
uint32 | depth
uint32 | flags
uint32 | height
uint32 | mipMapCount
uint32 | pitchOrLinearSize
uint32 | reserved1 [11]
uint32 | reserved2
uint32 | size
uint32 | width

Detailed Description

Definition at line 94 of file DDSTextureLoader.cpp.

Member Data Documentation

uint32 DDS_HEADER::caps

Definition at line 105 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::caps2

Definition at line 106 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::caps3

Definition at line 107 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::caps4

Definition at line 108 of file DDSTextureLoader.cpp.

DDS_PIXELFORMAT DDS_HEADER::ddspf

Definition at line 104 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::depth

Definition at line 101 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::flags

Definition at line 97 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::height

Definition at line 98 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::mipMapCount

Definition at line 102 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::pitchOrLinearSize

Definition at line 100 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::reserved1

Definition at line 103 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::reserved2

Definition at line 109 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::size

Definition at line 96 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER::width

Definition at line 99 of file DDSTextureLoader.cpp.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/DDSTextureLoader.cpp
  • Direct3D HLSL fractal generator/C++/DDSTextureLoader.cpp
  • Direct3D post-processing effects/C++/DDSTextureLoader.cpp
  • Direct3D resource loading/C++/DDSTextureLoader.cpp
  • Direct3D sprite/C++/DDSTextureLoader.cpp
  • Direct3D stereoscopic 3D/C++/DDSTextureLoader.cpp
  • Direct3D tutorial/C++/Lesson5.Components/DDSTextureLoader.cpp
  • Direct3D-Direct2D interop/C++/DDSTextureLoader.cpp
  • DirectX 3D shooting game/C++/DDSTextureLoader.cpp
  • DirectX marble maze game/C++/DDSTextureLoader.cpp
  • DirectX postcard app/C++/DDSTextureLoader.cpp
  • DirectX touch input/C++/DDSTextureLoader.cpp
  • DXGI offer and reclaim resources/C++/DDSTextureLoader.cpp
  • DXGI swap chain rotation/C++/DDSTextureLoader.cpp
  • XAML DirectX 3D shooting game/C++/DDSTextureLoader.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DDS_HEADER_DXT10 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

DDS_HEADER_DXT10 Struct Reference

List of all members.

Public Attributes

uint32 | arraySize
DXGI_FORMAT | dxgiFormat
uint32 | miscFlag
uint32 | reserved
uint32 | resourceDimension

Detailed Description

Definition at line 112 of file DDSTextureLoader.cpp.

Member Data Documentation

uint32 DDS_HEADER_DXT10::arraySize

Definition at line 117 of file DDSTextureLoader.cpp.

DXGI_FORMAT DDS_HEADER_DXT10::dxgiFormat

Definition at line 114 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER_DXT10::miscFlag

Definition at line 116 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER_DXT10::reserved

Definition at line 118 of file DDSTextureLoader.cpp.

uint32 DDS_HEADER_DXT10::resourceDimension

Definition at line 115 of file DDSTextureLoader.cpp.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/DDSTextureLoader.cpp
  • Direct3D HLSL fractal generator/C++/DDSTextureLoader.cpp
  • Direct3D post-processing effects/C++/DDSTextureLoader.cpp
  • Direct3D resource loading/C++/DDSTextureLoader.cpp
  • Direct3D sprite/C++/DDSTextureLoader.cpp
  • Direct3D stereoscopic 3D/C++/DDSTextureLoader.cpp
  • Direct3D tutorial/C++/Lesson5.Components/DDSTextureLoader.cpp
  • Direct3D-Direct2D interop/C++/DDSTextureLoader.cpp
  • DirectX 3D shooting game/C++/DDSTextureLoader.cpp
  • DirectX marble maze game/C++/DDSTextureLoader.cpp
  • DirectX postcard app/C++/DDSTextureLoader.cpp
  • DirectX touch input/C++/DDSTextureLoader.cpp
  • DXGI offer and reclaim resources/C++/DDSTextureLoader.cpp
  • DXGI swap chain rotation/C++/DDSTextureLoader.cpp
  • XAML DirectX 3D shooting game/C++/DDSTextureLoader.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DDS_PIXELFORMAT Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

DDS_PIXELFORMAT Struct Reference

List of all members.

Public Attributes

uint32 | ABitMask
uint32 | BBitMask
uint32 | flags
uint32 | fourCC
uint32 | GBitMask
uint32 | RBitMask
uint32 | RGBBitCount
uint32 | size

Detailed Description

Definition at line 46 of file DDSTextureLoader.cpp.

Member Data Documentation

uint32 DDS_PIXELFORMAT::ABitMask

Definition at line 55 of file DDSTextureLoader.cpp.

uint32 DDS_PIXELFORMAT::BBitMask

Definition at line 54 of file DDSTextureLoader.cpp.

uint32 DDS_PIXELFORMAT::flags

Definition at line 49 of file DDSTextureLoader.cpp.

uint32 DDS_PIXELFORMAT::fourCC

Definition at line 50 of file DDSTextureLoader.cpp.

uint32 DDS_PIXELFORMAT::GBitMask

Definition at line 53 of file DDSTextureLoader.cpp.

uint32 DDS_PIXELFORMAT::RBitMask

Definition at line 52 of file DDSTextureLoader.cpp.

uint32 DDS_PIXELFORMAT::RGBBitCount

Definition at line 51 of file DDSTextureLoader.cpp.

uint32 DDS_PIXELFORMAT::size

Definition at line 48 of file DDSTextureLoader.cpp.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/DDSTextureLoader.cpp
  • Direct3D HLSL fractal generator/C++/DDSTextureLoader.cpp
  • Direct3D post-processing effects/C++/DDSTextureLoader.cpp
  • Direct3D resource loading/C++/DDSTextureLoader.cpp
  • Direct3D sprite/C++/DDSTextureLoader.cpp
  • Direct3D stereoscopic 3D/C++/DDSTextureLoader.cpp
  • Direct3D tutorial/C++/Lesson5.Components/DDSTextureLoader.cpp
  • Direct3D-Direct2D interop/C++/DDSTextureLoader.cpp
  • DirectX 3D shooting game/C++/DDSTextureLoader.cpp
  • DirectX marble maze game/C++/DDSTextureLoader.cpp
  • DirectX postcard app/C++/DDSTextureLoader.cpp
  • DirectX touch input/C++/DDSTextureLoader.cpp
  • DXGI offer and reclaim resources/C++/DDSTextureLoader.cpp
  • DXGI swap chain rotation/C++/DDSTextureLoader.cpp
  • XAML DirectX 3D shooting game/C++/DDSTextureLoader.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Design Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Design Class Reference

#include "Design.h"

Inherits Element.

List of all members.

Public Member Functions

virtual bool | AcceptChildNode (_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override
D2D1_SIZE_F | GetPageSize ()
virtual bool | Initialize (_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override

Public Attributes

internal | __pad0__: Design()

Private Attributes

D2D1_SIZE_F | m_pageSize

Detailed Description

Definition at line 25 of file Design.h.

Member Function Documentation

virtual bool Design::AcceptChildNode | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::IXmlNode^ | childXmlNode |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

D2D1_SIZE_F Design::GetPageSize ( ) [inline]

Definition at line 40 of file Design.h.

    {
        return m_pageSize;
    }

virtual bool Design::Initialize | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::XmlElement^ | xmlElement |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Member Data Documentation

internal Design::__pad0__

Reimplemented from Element.

Definition at line 28 of file Design.h.

D2D1_SIZE_F Design::m_pageSize [private]

Definition at line 46 of file Design.h.

The documentation for this class was generated from the following file:
  • Direct2D magazine app/C++/Design.h
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForPrinters::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DeviceAppForPrinters
  • DeviceAppForPrinters::App
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DeviceAppForPrinters::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnActivated (Windows::ApplicationModel::Activation::IActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()

Private Member Functions

void | SetupWindowing (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs)

Private Attributes

Windows::UI::Xaml::Controls::Frame | rootFrame

Detailed Description

Definition at line 20 of file App.xaml.h.

Member Function Documentation

virtual void DeviceAppForPrinters::App::OnActivated ( Windows::ApplicationModel::Activation::IActivatedEventArgs^ pArgs ) [override, virtual]
virtual void DeviceAppForPrinters::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void DeviceAppForPrinters::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void DeviceAppForPrinters::App::SetupWindowing ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [private]

Member Data Documentation

internal DeviceAppForPrinters::App::__pad0__

Definition at line 21 of file App.xaml.h.

Windows::UI::Xaml::Controls::Frame DeviceAppForPrinters::App::rootFrame [private]

Definition at line 29 of file App.xaml.h.

The documentation for this class was generated from the following file:
  • Device app for printers SDK/C++/DeviceAppForPrinters/App.xaml.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForPrinters::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DeviceAppForPrinters
  • DeviceAppForPrinters::MainPage

DeviceAppForPrinters::MainPage Class Reference

#include "Constants.h"

Detailed Description

Definition at line 23 of file Constants.h.

The documentation for this class was generated from the following file:
  • Device app for printers SDK/C++/DeviceAppForPrinters/Constants.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForPrinters::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DeviceAppForPrinters
  • DeviceAppForPrinters::Scenario
Public Attributes

DeviceAppForPrinters::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String DeviceAppForPrinters::Scenario::ClassName

Definition at line 20 of file Constants.h.

Platform::String DeviceAppForPrinters::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • Device app for printers SDK/C++/DeviceAppForPrinters/Constants.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForWebcam::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DeviceAppForWebcam
  • Common
  • DeviceAppForWebcam::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DeviceAppForWebcam::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 26 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String DeviceAppForWebcam::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void DeviceAppForWebcam::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void DeviceAppForWebcam::Common::LayoutAwarePage::InvalidateVisualState ( )
void DeviceAppForWebcam::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::Common::LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal DeviceAppForWebcam::Common::LayoutAwarePage::__pad0__

Definition at line 29 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> DeviceAppForWebcam::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 51 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> DeviceAppForWebcam::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 53 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken DeviceAppForWebcam::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 52 of file LayoutAwarePage.h.

The documentation for this class was generated from the following file:
  • Windows Store device app for camera/C++/Common/LayoutAwarePage.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForWebcam::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DeviceAppForWebcam
  • DeviceAppForWebcam::MainPage

DeviceAppForWebcam::MainPage Class Reference

#include "Constants.h"

Detailed Description

Definition at line 17 of file Constants.h.

The documentation for this class was generated from the following file:
  • Windows Store device app for camera/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForWebcam::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DeviceAppForWebcam
  • DeviceAppForWebcam::sealed
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes

DeviceAppForWebcam::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

~DeviceAppPage ()
App ()
DeviceAppPage ()
void | Initialize (CameraSettingsActivatedEventArgs^args)
MainPage ()
virtual void | OnActivated (Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override
void | OnBrtAutoToggleChanged (Object^sender, RoutedEventArgs^e)
void | OnBrtSliderValueChanged (Object^sender, RangeBaseValueChangedEventArgs^e)
void | OnCrtAutoToggleChanged (Object^sender, RoutedEventArgs^e)
void | OnCrtSliderValueChanged (Object^sender, RangeBaseValueChangedEventArgs^e)
void | OnEffectEnabledToggleChanged (Object^sender, RoutedEventArgs^e)
void | OnEffectSliderValueChanged (Object^sender, RangeBaseValueChangedEventArgs^e)
void | OnExpAutoToggleChanged (Object^sender, RoutedEventArgs^e)
void | OnExpSliderValueChanged (Object^sender, RangeBaseValueChangedEventArgs^e)
void | OnFocusAutoToggleChanged (Object^sender, RoutedEventArgs^e)
void | OnFocusSliderValueChanged (Object^sender, RangeBaseValueChangedEventArgs^e)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

Wrapper::WinRTComponent | lcWrapper
Platform::Agile
< Windows::Media::Devices::VideoDeviceController > 		videoDevController

Protected Member Functions

void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Protected Attributes

internal | __pad0__: static MainPage^ Current

Properties

Windows::ApplicationModel::Activation::LaunchActivatedEventArgs | LaunchArgs

Private Member Functions

~MainPage ()
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateSize ()
void | InvalidateViewState ()
void | SetDeviceAppForWebcam (Platform::String^strFeature)

Private Attributes

Windows::UI::Xaml::Controls::Frame | HiddenFrame
Windows::UI::Xaml::Controls::Frame | rootFrame

Detailed Description

Definition at line 25 of file App.xaml.h.

Constructor & Destructor Documentation

DeviceAppForWebcam::sealed::~DeviceAppPage ( )
DeviceAppForWebcam::sealed::~MainPage ( ) [private]

Member Function Documentation

DeviceAppForWebcam::sealed::App ( )
DeviceAppForWebcam::sealed::DeviceAppPage ( )
void DeviceAppForWebcam::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void DeviceAppForWebcam::sealed::Initialize ( CameraSettingsActivatedEventArgs^ args )
void DeviceAppForWebcam::sealed::InvalidateSize ( ) [private]
void DeviceAppForWebcam::sealed::InvalidateViewState ( ) [private]
DeviceAppForWebcam::sealed::MainPage ( )
void DeviceAppForWebcam::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
virtual void DeviceAppForWebcam::sealed::OnActivated ( Windows::ApplicationModel::Activation::IActivatedEventArgs^ args ) [override, virtual]
void DeviceAppForWebcam::sealed::OnBrtAutoToggleChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnBrtSliderValueChanged | ( | Object^ | sender,
 |  | RangeBaseValueChangedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnCrtAutoToggleChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnCrtSliderValueChanged | ( | Object^ | sender,
 |  | RangeBaseValueChangedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnEffectEnabledToggleChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnEffectSliderValueChanged | ( | Object^ | sender,
 |  | RangeBaseValueChangedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnExpAutoToggleChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnExpSliderValueChanged | ( | Object^ | sender,
 |  | RangeBaseValueChangedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnFocusAutoToggleChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e
 | ) |  |
void DeviceAppForWebcam::sealed::OnFocusSliderValueChanged | ( | Object^ | sender,
 |  | RangeBaseValueChangedEventArgs^ | e
 | ) |  |
virtual void DeviceAppForWebcam::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
virtual void DeviceAppForWebcam::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void DeviceAppForWebcam::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void DeviceAppForWebcam::sealed::SetDeviceAppForWebcam ( Platform::String^ strFeature ) [private]

Member Data Documentation

internal DeviceAppForWebcam::sealed::__pad0__ [protected]

Definition at line 48 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame DeviceAppForWebcam::sealed::HiddenFrame [private]

Definition at line 39 of file MainPage.xaml.h.

Wrapper::WinRTComponent DeviceAppForWebcam::sealed::lcWrapper

Definition at line 36 of file DeviceAppPage.xaml.h.

Windows::UI::Xaml::Controls::Frame DeviceAppForWebcam::sealed::rootFrame [private]

Definition at line 34 of file App.xaml.h.

Platform::Agile<Windows::Media::Devices::VideoDeviceController> DeviceAppForWebcam::sealed::videoDevController

Definition at line 35 of file DeviceAppPage.xaml.h.

Property Documentation

Windows::ApplicationModel::Activation::LaunchActivatedEventArgs DeviceAppForWebcam::sealed::LaunchArgs

Definition at line 31 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Windows Store device app for camera/C++/App.xaml.h
  • Windows Store device app for camera/C++/DeviceAppPage.xaml.h
  • Windows Store device app for camera/C++/MainPage.xaml.h
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3DTutorial Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Direct3DTutorial Class Reference

#include "Direct3DTutorial.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Render () override
void | Update (float timeTotal, float timeDelta)

Public Attributes

internal | __pad0__: Direct3DTutorial()

Private Attributes

BasicCamera m_camera
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
unsigned int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_texture
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureSRV
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 22 of file Direct3DTutorial.h.

Member Function Documentation

void Direct3DTutorial::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 21 of file Direct3DTutorial.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();
}

void Direct3DTutorial::CreateDeviceResources ( ) [override, virtual]

Definition at line 26 of file Direct3DTutorial.cpp.

{
    DirectXBase::CreateDeviceResources();

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    loader->LoadShader(
        L"SimpleVertexShader.cso",
        nullptr,
        0,
        &m_vertexShader,
        &m_inputLayout
        );

    // create the vertex and index buffers for drawing the cube

    BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());

    shapes->CreateCube(
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // create the constant buffer for updating model and camera data
    CD3D11_BUFFER_DESC constantBufferDesc(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &constantBufferDesc,
            nullptr,             // leave the buffer uninitialized
            &m_constantBuffer
            )
        );

    loader->LoadShader(
        L"SimplePixelShader.cso",
        &m_pixelShader
        );

    loader->LoadTexture(
        L"reftexture.dds",
        &m_texture,
        &m_textureSRV
        );

    // create the sampler
    D3D11_SAMPLER_DESC samplerDesc;
    ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
    samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.MipLODBias = 0.0f;
    // use 4x on feature level 9.2 and above, otherwise use only 2x
    samplerDesc.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
    samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDesc.BorderColor[0] = 0.0f;
    samplerDesc.BorderColor[1] = 0.0f;
    samplerDesc.BorderColor[2] = 0.0f;
    samplerDesc.BorderColor[3] = 0.0f;
    // allow use of all mip levels
    samplerDesc.MinLOD = 0;
    samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDesc,
            &m_sampler)
        );

    m_camera = ref new BasicCamera();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "C++ and Direct3D tutorial sample for Windows Store apps"
        );
}

void Direct3DTutorial::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 110 of file Direct3DTutorial.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // update the 3D projection matrix
    m_camera->SetProjectionParameters(
        70.0f,                                                // use a 70-degree vertical field of view
        m_renderTargetSize.Width / m_renderTargetSize.Height, // specify the aspect ratio of the window
        0.01f,                                                // specify the nearest Z-distance at which to draw vertices
        100.0f                                                // specify the farthest Z-distance at which to draw vertices
        );

    // save the new projection matrix to the constant buffer data struct
    m_camera->GetProjectionMatrix(&m_constantBufferData.projection);

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void Direct3DTutorial::Render ( ) [override, virtual]

Definition at line 154 of file Direct3DTutorial.cpp.

{
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // clear both the render target and depth stencil to default values
    const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };
    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        ClearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    // set the vertex and index buffers, and specify the way they define geometry
    UINT stride = sizeof(BasicVertex);
    UINT offset = 0;
    m_d3dContext->IASetVertexBuffers(
        0,                              // starting at the first vertex buffer slot
        1,                              // set one vertex buffer binding
        m_vertexBuffer.GetAddressOf(),
        &stride,                        // specify the size in bytes of a single vertex
        &offset                         // specify the base vertex in the buffer
        );

    // set the index buffer
    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,   // unsigned short index format
        0                       // specify the base index in the buffer
        );

    // specify the way the vertex and index buffers define geometry
    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    // set the vertex shader stage state
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                              // starting at the first constant buffer slot
        1,                              // set one constant buffer binding
        m_constantBuffer.GetAddressOf()
        );

    // set the pixel shader stage state
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->PSSetShaderResources(
        0,                          // starting at the first shader resource slot
        1,                          // set one shader resource binding
        m_textureSRV.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,                          // starting at the first sampler slot
        1,                          // set one sampler binding
        m_sampler.GetAddressOf()
        );

    // draw the cube
    m_d3dContext->DrawIndexed(
        m_indexCount,   // draw all created vertices
        0,              // starting with the first vertex
        0               // and the first index
        );

    m_sampleOverlay->Render();
}

void Direct3DTutorial::Update | ( | float | timeTotal,
 |  | float | timeDelta
 | ) |  |

Definition at line 128 of file Direct3DTutorial.cpp.

{
    // update the model matrix based on the time
    m_constantBufferData.model = rotationY(-timeTotal * 60.0f);

    // update the view matrix based on the camera position
    // note that for this sample, the camera position is fixed
    m_camera->SetViewParameters(
        float3(0, 1.0f, 2.0f),
        float3(0, 0, 0),
        float3(0, 1, 0)
        );

    m_camera->GetViewMatrix(&m_constantBufferData.view);

    // update the constant buffer with the new data
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_constantBufferData,
        0,
        0
        );
}

Member Data Documentation

internal Direct3DTutorial::__pad0__

Definition at line 25 of file Direct3DTutorial.h.

BasicCamera Direct3DTutorial::m_camera [private]

Definition at line 47 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> Direct3DTutorial::m_constantBuffer [private]

Definition at line 43 of file Direct3DTutorial.h.

ConstantBuffer Direct3DTutorial::m_constantBufferData [private]

Definition at line 46 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> Direct3DTutorial::m_indexBuffer [private]

Definition at line 37 of file Direct3DTutorial.h.

unsigned int Direct3DTutorial::m_indexCount [private]

Definition at line 45 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> Direct3DTutorial::m_inputLayout [private]

Definition at line 35 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> Direct3DTutorial::m_pixelShader [private]

Definition at line 39 of file Direct3DTutorial.h.

SampleOverlay Direct3DTutorial::m_sampleOverlay [private]

Definition at line 34 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> Direct3DTutorial::m_sampler [private]

Definition at line 42 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> Direct3DTutorial::m_texture [private]

Definition at line 40 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> Direct3DTutorial::m_textureSRV [private]

Definition at line 41 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> Direct3DTutorial::m_vertexBuffer [private]

Definition at line 36 of file Direct3DTutorial.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> Direct3DTutorial::m_vertexShader [private]

Definition at line 38 of file Direct3DTutorial.h.

The documentation for this class was generated from the following files:
  • Direct3D tutorial/C++/Lesson5.Components/Direct3DTutorial.h
  • Direct3D tutorial/C++/Lesson5.Components/Direct3DTutorial.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3DTutorialFrameworkView Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

Direct3DTutorialFrameworkView Class Reference

List of all members.

Public Member Functions

virtual void | Initialize (_In_ CoreApplicationView^applicationView)
virtual void | Initialize (_In_ CoreApplicationView^applicationView)
virtual void | Initialize (_In_ CoreApplicationView^applicationView)
virtual void | Initialize (_In_ CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
void | OnActivated (_In_ CoreApplicationView^applicationView, _In_ IActivatedEventArgs^args)
void | OnActivated (_In_ CoreApplicationView^applicationView, _In_ IActivatedEventArgs^args)
void | OnActivated (_In_ CoreApplicationView^applicationView, _In_ IActivatedEventArgs^args)
void | OnActivated (_In_ CoreApplicationView^applicationView, _In_ IActivatedEventArgs^args)
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | SetWindow (_In_ CoreWindow^window)
virtual void | SetWindow (_In_ CoreWindow^window)
virtual void | SetWindow (_In_ CoreWindow^window)
virtual void | SetWindow (_In_ CoreWindow^window)
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()

Private Member Functions

void | CreateWindowSizeDependentResources ()
void | CreateWindowSizeDependentResources ()
void | CreateWindowSizeDependentResources ()
void | CreateWindowSizeDependentResources ()
void | OnWindowSizeChanged (_In_ CoreWindow^sender, _In_ WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ CoreWindow^sender, _In_ WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ CoreWindow^sender, _In_ WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ CoreWindow^sender, _In_ WindowSizeChangedEventArgs^args)

Private Attributes

ComPtr< ID3D11Buffer > | m_constantBuffer
ConstantBuffer m_constantBufferData
ComPtr< ID3D11Device1 > | m_d3dDevice
ComPtr< ID3D11DeviceContext1 > | m_d3dDeviceContext
ComPtr< ID3D11DepthStencilView > | m_depthStencilView
ComPtr< ID3D11RenderTargetView > | m_renderTargetView
ComPtr< IDXGISwapChain1 > | m_swapChain
Platform::Agile< CoreWindow > | m_window

Detailed Description

Definition at line 18 of file Main.cpp.

Member Function Documentation

void Direct3DTutorialFrameworkView::CreateWindowSizeDependentResources ( ) [inline, private]

Definition at line 172 of file Main.cpp.

    {
        if (m_swapChain != nullptr)
        {
            // If the swap chain already exists, resize it.
            DX::ThrowIfFailed(
                m_swapChain->ResizeBuffers(
                    2,
                    0,
                    0,
                    DXGI_FORMAT_B8G8R8A8_UNORM,
                    0
                    )
                );
        }
        else
        {
            // If the swap chain does not exist, create it.
            DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};

            swapChainDesc.Stereo = false;
            swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
            swapChainDesc.Scaling = DXGI_SCALING_NONE;
            swapChainDesc.Flags = 0;

            // Use automatic sizing.
            swapChainDesc.Width = 0;
            swapChainDesc.Height = 0;

            // This is the most common swap chain format.
            swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;

            // Don't use multi-sampling.
            swapChainDesc.SampleDesc.Count = 1;
            swapChainDesc.SampleDesc.Quality = 0;

            // Use two buffers to enable flip effect.
            swapChainDesc.BufferCount = 2;

            // We recommend using this swap effect for all applications.
            swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL;

            // Once the swap chain description is configured, it must be
            // created on the same adapter as the existing D3D Device.

            // First, retrieve the underlying DXGI Device from the D3D Device.
            ComPtr<IDXGIDevice2> dxgiDevice;
            DX::ThrowIfFailed(
                m_d3dDevice.As(&dxgiDevice)
                );

            // Ensure that DXGI does not queue more than one frame at a time. This both reduces
            // latency and ensures that the application will only render after each VSync, minimizing
            // power consumption.
            DX::ThrowIfFailed(
                dxgiDevice->SetMaximumFrameLatency(1)
                );

            // Next, get the parent factory from the DXGI Device.
            ComPtr<IDXGIAdapter> dxgiAdapter;
            DX::ThrowIfFailed(
                dxgiDevice->GetAdapter(&dxgiAdapter)
                );

            ComPtr<IDXGIFactory2> dxgiFactory;
            DX::ThrowIfFailed(
                dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
                );

            // Finally, create the swap chain.
            CoreWindow^ window = m_window.Get();
            DX::ThrowIfFailed(
                dxgiFactory->CreateSwapChainForCoreWindow(
                    m_d3dDevice.Get(),
                    reinterpret_cast<IUnknown*>(window),
                    &swapChainDesc,
                    nullptr, // allow on all displays
                    &m_swapChain
                    )
                );
        }

        // Once the swap chain is created, create a render target view.  This will
        // allow Direct3D to render graphics to the window.

        ComPtr<ID3D11Texture2D> backBuffer;
        DX::ThrowIfFailed(
            m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateRenderTargetView(
                backBuffer.Get(),
                nullptr,
                &m_renderTargetView
                )
            );

        // After the render target view is created, specify that the viewport,
        // which describes what portion of the window to draw to, should cover
        // the entire window.

        D3D11_TEXTURE2D_DESC backBufferDesc = {0};
        backBuffer->GetDesc(&backBufferDesc);

        D3D11_VIEWPORT viewport;
        viewport.TopLeftX = 0.0f;
        viewport.TopLeftY = 0.0f;
        viewport.Width = static_cast<float>(backBufferDesc.Width);
        viewport.Height = static_cast<float>(backBufferDesc.Height);
        viewport.MinDepth = D3D11_MIN_DEPTH;
        viewport.MaxDepth = D3D11_MAX_DEPTH;

        m_d3dDeviceContext->RSSetViewports(1, &viewport);
    }

void Direct3DTutorialFrameworkView::CreateWindowSizeDependentResources ( ) [inline, private]

Definition at line 319 of file Main.cpp.

    {
        if (m_swapChain != nullptr)
        {
            // If the swap chain already exists, resize it.
            DX::ThrowIfFailed(
                m_swapChain->ResizeBuffers(
                    2,
                    0,
                    0,
                    DXGI_FORMAT_B8G8R8A8_UNORM,
                    0
                    )
                );
        }
        else
        {
            // If the swap chain does not exist, create it.
            DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};

            swapChainDesc.Stereo = false;
            swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
            swapChainDesc.Scaling = DXGI_SCALING_NONE;
            swapChainDesc.Flags = 0;

            // Use automatic sizing.
            swapChainDesc.Width = 0;
            swapChainDesc.Height = 0;

            // This is the most common swap chain format.
            swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;

            // Don't use multi-sampling.
            swapChainDesc.SampleDesc.Count = 1;
            swapChainDesc.SampleDesc.Quality = 0;

            // Use two buffers to enable flip effect.
            swapChainDesc.BufferCount = 2;

            // We recommend using this swap effect for all applications.
            swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL;

            // Once the swap chain description is configured, it must be
            // created on the same adapter as the existing D3D Device.

            // First, retrieve the underlying DXGI Device from the D3D Device.
            ComPtr<IDXGIDevice2> dxgiDevice;
            DX::ThrowIfFailed(
                m_d3dDevice.As(&dxgiDevice)
                );

            // Ensure that DXGI does not queue more than one frame at a time. This both reduces
            // latency and ensures that the application will only render after each VSync, minimizing
            // power consumption.
            DX::ThrowIfFailed(
                dxgiDevice->SetMaximumFrameLatency(1)
                );

            // Next, get the parent factory from the DXGI Device.
            ComPtr<IDXGIAdapter> dxgiAdapter;
            DX::ThrowIfFailed(
                dxgiDevice->GetAdapter(&dxgiAdapter)
                );

            ComPtr<IDXGIFactory2> dxgiFactory;
            DX::ThrowIfFailed(
                dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
                );

            // Finally, create the swap chain.
            CoreWindow^ window = m_window.Get();
            DX::ThrowIfFailed(
                dxgiFactory->CreateSwapChainForCoreWindow(
                    m_d3dDevice.Get(),
                    reinterpret_cast<IUnknown*>(window),
                    &swapChainDesc,
                    nullptr, // allow on all displays
                    &m_swapChain
                    )
                );
        }

        // Once the swap chain is created, create a render target view.  This will
        // allow Direct3D to render graphics to the window.

        ComPtr<ID3D11Texture2D> backBuffer;
        DX::ThrowIfFailed(
            m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateRenderTargetView(
                backBuffer.Get(),
                nullptr,
                &m_renderTargetView
                )
            );

        // After the render target view is created, specify that the viewport,
        // which describes what portion of the window to draw to, should cover
        // the entire window.

        D3D11_TEXTURE2D_DESC backBufferDesc = {0};
        backBuffer->GetDesc(&backBufferDesc);

        D3D11_VIEWPORT viewport;
        viewport.TopLeftX = 0.0f;
        viewport.TopLeftY = 0.0f;
        viewport.Width = static_cast<float>(backBufferDesc.Width);
        viewport.Height = static_cast<float>(backBufferDesc.Height);
        viewport.MinDepth = D3D11_MIN_DEPTH;
        viewport.MaxDepth = D3D11_MAX_DEPTH;

        m_d3dDeviceContext->RSSetViewports(1, &viewport);
    }

void Direct3DTutorialFrameworkView::CreateWindowSizeDependentResources ( ) [inline, private]

Definition at line 555 of file Main.cpp.

    {
        if (m_swapChain != nullptr)
        {
            // If the swap chain already exists, resize it.
            DX::ThrowIfFailed(
                m_swapChain->ResizeBuffers(
                    2,
                    0,
                    0,
                    DXGI_FORMAT_B8G8R8A8_UNORM,
                    0
                    )
                );
        }
        else
        {
            // If the swap chain does not exist, create it.
            DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};

            swapChainDesc.Stereo = false;
            swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
            swapChainDesc.Scaling = DXGI_SCALING_NONE;
            swapChainDesc.Flags = 0;

            // Use automatic sizing.
            swapChainDesc.Width = 0;
            swapChainDesc.Height = 0;

            // This is the most common swap chain format.
            swapChainDesc.Format = DXGI_FORMAT_R8G8B8A8_UNORM;

            // Don't use multi-sampling.
            swapChainDesc.SampleDesc.Count = 1;
            swapChainDesc.SampleDesc.Quality = 0;

            // Use two buffers to enable flip effect.
            swapChainDesc.BufferCount = 2;

            // We recommend using this swap effect for all applications.
            swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL;

            // Once the swap chain description is configured, it must be
            // created on the same adapter as the existing D3D Device.

            // First, retrieve the underlying DXGI Device from the D3D Device.
            ComPtr<IDXGIDevice2> dxgiDevice;
            DX::ThrowIfFailed(
                m_d3dDevice.As(&dxgiDevice)
                );

            // Ensure that DXGI does not queue more than one frame at a time. This both reduces
            // latency and ensures that the application will only render after each VSync, minimizing
            // power consumption.
            DX::ThrowIfFailed(
                dxgiDevice->SetMaximumFrameLatency(1)
                );

            // Next, get the parent factory from the DXGI Device.
            ComPtr<IDXGIAdapter> dxgiAdapter;
            DX::ThrowIfFailed(
                dxgiDevice->GetAdapter(&dxgiAdapter)
                );

            ComPtr<IDXGIFactory2> dxgiFactory;
            DX::ThrowIfFailed(
                dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
                );

            // Finally, create the swap chain.
            CoreWindow^ window = m_window.Get();
            DX::ThrowIfFailed(
                dxgiFactory->CreateSwapChainForCoreWindow(
                    m_d3dDevice.Get(),
                    reinterpret_cast<IUnknown*>(window),
                    &swapChainDesc,
                    nullptr, // allow on all displays
                    &m_swapChain
                    )
                );
        }

        // Once the swap chain is created, create a render target view.  This will
        // allow Direct3D to render graphics to the window.

        ComPtr<ID3D11Texture2D> backBuffer;
        DX::ThrowIfFailed(
            m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateRenderTargetView(
                backBuffer.Get(),
                nullptr,
                &m_renderTargetView
                )
            );

        // Once the render target view is created, create a depth stencil view.  This
        // allows Direct3D to efficiently render objects closer to the camera in front
        // of objects further from the camera.

        D3D11_TEXTURE2D_DESC backBufferDesc = {0};
        backBuffer->GetDesc(&backBufferDesc);

        D3D11_TEXTURE2D_DESC depthStencilDesc;
        depthStencilDesc.Width = backBufferDesc.Width;
        depthStencilDesc.Height = backBufferDesc.Height;
        depthStencilDesc.MipLevels = 1;
        depthStencilDesc.ArraySize = 1;
        depthStencilDesc.Format = DXGI_FORMAT_D24_UNORM_S8_UINT;
        depthStencilDesc.SampleDesc.Count = 1;
        depthStencilDesc.SampleDesc.Quality = 0;
        depthStencilDesc.Usage = D3D11_USAGE_DEFAULT;
        depthStencilDesc.BindFlags = D3D11_BIND_DEPTH_STENCIL;
        depthStencilDesc.CPUAccessFlags = 0;
        depthStencilDesc.MiscFlags = 0;
        ComPtr<ID3D11Texture2D> depthStencil;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateTexture2D(
                &depthStencilDesc,
                nullptr,
                &depthStencil
                )
            );

        D3D11_DEPTH_STENCIL_VIEW_DESC depthStencilViewDesc;
        depthStencilViewDesc.Format = depthStencilDesc.Format;
        depthStencilViewDesc.ViewDimension = D3D11_DSV_DIMENSION_TEXTURE2D;
        depthStencilViewDesc.Flags = 0;
        depthStencilViewDesc.Texture2D.MipSlice = 0;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateDepthStencilView(
                depthStencil.Get(),
                &depthStencilViewDesc,
                &m_depthStencilView
                )
            );

        // After the render target and depth stencil views are created, specify that
        // the viewport, which describes what portion of the window to draw to, should
        // cover the entire window.

        D3D11_VIEWPORT viewport;
        viewport.TopLeftX = 0.0f;
        viewport.TopLeftY = 0.0f;
        viewport.Width = static_cast<float>(backBufferDesc.Width);
        viewport.Height = static_cast<float>(backBufferDesc.Height);
        viewport.MinDepth = D3D11_MIN_DEPTH;
        viewport.MaxDepth = D3D11_MAX_DEPTH;

        m_d3dDeviceContext->RSSetViewports(1, &viewport);

        // Finally, update the constant buffer perspective projection parameters
        // to account for the size of the application window.  In this sample,
        // the parameters are fixed to a 70-degree field of view, with a depth
        // range of 0.01 to 100.  See Lesson 5 for a generalized camera class.

        float xScale = 1.42814801f;
        float yScale = 1.42814801f;
        if (backBufferDesc.Width > backBufferDesc.Height)
        {
            xScale = yScale *
                static_cast<float>(backBufferDesc.Height) /
                static_cast<float>(backBufferDesc.Width);
        }
        else
        {
            yScale = xScale *
                static_cast<float>(backBufferDesc.Width) /
                static_cast<float>(backBufferDesc.Height);
        }

        m_constantBufferData.projection = float4x4(
            xScale, 0.0f,    0.0f,  0.0f,
            0.0f,   yScale,  0.0f,  0.0f,
            0.0f,   0.0f,   -1.0f, -0.01f,
            0.0f,   0.0f,   -1.0f,  0.0f
            );
    }

void Direct3DTutorialFrameworkView::CreateWindowSizeDependentResources ( ) [inline, private]

Definition at line 422 of file Main.cpp.

    {
        if (m_swapChain != nullptr)
        {
            // If the swap chain already exists, resize it.
            DX::ThrowIfFailed(
                m_swapChain->ResizeBuffers(
                    2,
                    0,
                    0,
                    DXGI_FORMAT_B8G8R8A8_UNORM,
                    0
                    )
                );
        }
        else
        {
            // If the swap chain does not exist, create it.
            DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};

            swapChainDesc.Stereo = false;
            swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
            swapChainDesc.Scaling = DXGI_SCALING_NONE;
            swapChainDesc.Flags = 0;

            // Use automatic sizing.
            swapChainDesc.Width = 0;
            swapChainDesc.Height = 0;

            // This is the most common swap chain format.
            swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;

            // Don't use multi-sampling.
            swapChainDesc.SampleDesc.Count = 1;
            swapChainDesc.SampleDesc.Quality = 0;

            // Use two buffers to enable flip effect.
            swapChainDesc.BufferCount = 2;

            // We recommend using this swap effect for all applications.
            swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL;

            // Once the swap chain description is configured, it must be
            // created on the same adapter as the existing D3D Device.

            // First, retrieve the underlying DXGI Device from the D3D Device.
            ComPtr<IDXGIDevice2> dxgiDevice;
            DX::ThrowIfFailed(
                m_d3dDevice.As(&dxgiDevice)
                );

            // Ensure that DXGI does not queue more than one frame at a time. This both reduces
            // latency and ensures that the application will only render after each VSync, minimizing
            // power consumption.
            DX::ThrowIfFailed(
                dxgiDevice->SetMaximumFrameLatency(1)
                );

            // Next, get the parent factory from the DXGI Device.
            ComPtr<IDXGIAdapter> dxgiAdapter;
            DX::ThrowIfFailed(
                dxgiDevice->GetAdapter(&dxgiAdapter)
                );

            ComPtr<IDXGIFactory2> dxgiFactory;
            DX::ThrowIfFailed(
                dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
                );

            // Finally, create the swap chain.
            CoreWindow^ window = m_window.Get();
            DX::ThrowIfFailed(
                dxgiFactory->CreateSwapChainForCoreWindow(
                    m_d3dDevice.Get(),
                    reinterpret_cast<IUnknown*>(window),
                    &swapChainDesc,
                    nullptr, // allow on all displays
                    &m_swapChain
                    )
                );
        }

        // Once the swap chain is created, create a render target view.  This will
        // allow Direct3D to render graphics to the window.

        ComPtr<ID3D11Texture2D> backBuffer;
        DX::ThrowIfFailed(
            m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateRenderTargetView(
                backBuffer.Get(),
                nullptr,
                &m_renderTargetView
                )
            );

        // Once the render target view is created, create a depth stencil view.  This
        // allows Direct3D to efficiently render objects closer to the camera in front
        // of objects further from the camera.

        D3D11_TEXTURE2D_DESC backBufferDesc = {0};
        backBuffer->GetDesc(&backBufferDesc);

        D3D11_TEXTURE2D_DESC depthStencilDesc;
        depthStencilDesc.Width = backBufferDesc.Width;
        depthStencilDesc.Height = backBufferDesc.Height;
        depthStencilDesc.MipLevels = 1;
        depthStencilDesc.ArraySize = 1;
        depthStencilDesc.Format = DXGI_FORMAT_D24_UNORM_S8_UINT;
        depthStencilDesc.SampleDesc.Count = 1;
        depthStencilDesc.SampleDesc.Quality = 0;
        depthStencilDesc.Usage = D3D11_USAGE_DEFAULT;
        depthStencilDesc.BindFlags = D3D11_BIND_DEPTH_STENCIL;
        depthStencilDesc.CPUAccessFlags = 0;
        depthStencilDesc.MiscFlags = 0;
        ComPtr<ID3D11Texture2D> depthStencil;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateTexture2D(
                &depthStencilDesc,
                nullptr,
                &depthStencil
                )
            );

        D3D11_DEPTH_STENCIL_VIEW_DESC depthStencilViewDesc;
        depthStencilViewDesc.Format = depthStencilDesc.Format;
        depthStencilViewDesc.ViewDimension = D3D11_DSV_DIMENSION_TEXTURE2D;
        depthStencilViewDesc.Flags = 0;
        depthStencilViewDesc.Texture2D.MipSlice = 0;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateDepthStencilView(
                depthStencil.Get(),
                &depthStencilViewDesc,
                &m_depthStencilView
                )
            );

        // After the render target and depth stencil views are created, specify that
        // the viewport, which describes what portion of the window to draw to, should
        // cover the entire window.

        D3D11_VIEWPORT viewport;
        viewport.TopLeftX = 0.0f;
        viewport.TopLeftY = 0.0f;
        viewport.Width = static_cast<float>(backBufferDesc.Width);
        viewport.Height = static_cast<float>(backBufferDesc.Height);
        viewport.MinDepth = D3D11_MIN_DEPTH;
        viewport.MaxDepth = D3D11_MAX_DEPTH;

        m_d3dDeviceContext->RSSetViewports(1, &viewport);

        // Finally, update the constant buffer perspective projection parameters
        // to account for the size of the application window.  In this sample,
        // the parameters are fixed to a 70-degree field of view, with a depth
        // range of 0.01 to 100.  See Lesson 5 for a generalized camera class.

        float xScale = 1.42814801f;
        float yScale = 1.42814801f;
        if (backBufferDesc.Width > backBufferDesc.Height)
        {
            xScale = yScale *
                static_cast<float>(backBufferDesc.Height) /
                static_cast<float>(backBufferDesc.Width);
        }
        else
        {
            yScale = xScale *
                static_cast<float>(backBufferDesc.Width) /
                static_cast<float>(backBufferDesc.Height);
        }

        m_constantBufferData.projection = float4x4(
            xScale, 0.0f,    0.0f,  0.0f,
            0.0f,   yScale,  0.0f,  0.0f,
            0.0f,   0.0f,   -1.0f, -0.01f,
            0.0f,   0.0f,   -1.0f,  0.0f
            );
    }

virtual void Direct3DTutorialFrameworkView::Initialize ( _In_ CoreApplicationView^ applicationView ) [inline, virtual]

Definition at line 29 of file Main.cpp.

    {
        applicationView->Activated +=
            ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &Direct3DTutorialFrameworkView::OnActivated);
    }

virtual void Direct3DTutorialFrameworkView::Initialize ( _In_ CoreApplicationView^ applicationView ) [inline, virtual]

Definition at line 31 of file Main.cpp.

    {
        applicationView->Activated +=
            ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &Direct3DTutorialFrameworkView::OnActivated);
    }

virtual void Direct3DTutorialFrameworkView::Initialize ( _In_ CoreApplicationView^ applicationView ) [inline, virtual]

Definition at line 47 of file Main.cpp.

    {
        applicationView->Activated +=
            ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &Direct3DTutorialFrameworkView::OnActivated);
    }

virtual void Direct3DTutorialFrameworkView::Initialize ( _In_ CoreApplicationView^ applicationView ) [inline, virtual]

Definition at line 48 of file Main.cpp.

    {
        applicationView->Activated +=
            ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &Direct3DTutorialFrameworkView::OnActivated);
    }

virtual void Direct3DTutorialFrameworkView::Load ( _In_ Platform::String^ entryPoint ) [inline, virtual]

Definition at line 64 of file Main.cpp.

    {
    }

virtual void Direct3DTutorialFrameworkView::Load ( _In_ Platform::String^ entryPoint ) [inline, virtual]

Definition at line 82 of file Main.cpp.

    {
    }

virtual void Direct3DTutorialFrameworkView::Load ( _In_ Platform::String^ entryPoint ) [inline, virtual]

Definition at line 66 of file Main.cpp.

    {
    }

virtual void Direct3DTutorialFrameworkView::Load ( _In_ Platform::String^ entryPoint ) [inline, virtual]

Definition at line 83 of file Main.cpp.

    {
    }

void Direct3DTutorialFrameworkView::OnActivated | ( | _In_ CoreApplicationView^ | applicationView,
 |  | _In_ IActivatedEventArgs^ | args |
 | ) |  |  | [inline]

Definition at line 73 of file Main.cpp.

    {
        // Activate the application window, making it visible and enabling it to receive events.
        CoreWindow::GetForCurrentThread()->Activate();
    }

void Direct3DTutorialFrameworkView::OnActivated | ( | _In_ CoreApplicationView^ | applicationView,
 |  | _In_ IActivatedEventArgs^ | args |
 | ) |  |  | [inline]

Definition at line 57 of file Main.cpp.

    {
        // Activate the application window, making it visible and enabling it to receive events.
        CoreWindow::GetForCurrentThread()->Activate();
    }

void Direct3DTutorialFrameworkView::OnActivated | ( | _In_ CoreApplicationView^ | applicationView,
 |  | _In_ IActivatedEventArgs^ | args |
 | ) |  |  | [inline]

Definition at line 55 of file Main.cpp.

    {
        // Activate the application window, making it visible and enabling it to receive events.
        CoreWindow::GetForCurrentThread()->Activate();
    }

void Direct3DTutorialFrameworkView::OnActivated | ( | _In_ CoreApplicationView^ | applicationView,
 |  | _In_ IActivatedEventArgs^ | args |
 | ) |  |  | [inline]

Definition at line 74 of file Main.cpp.

    {
        // Activate the application window, making it visible and enabling it to receive events.
        CoreWindow::GetForCurrentThread()->Activate();
    }

void Direct3DTutorialFrameworkView::OnWindowSizeChanged | ( | _In_ CoreWindow^ | sender,
 |  | _In_ WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [inline, private]

Definition at line 542 of file Main.cpp.

    {
        m_renderTargetView = nullptr;
        m_depthStencilView = nullptr;
        CreateWindowSizeDependentResources();
    }

void Direct3DTutorialFrameworkView::OnWindowSizeChanged | ( | _In_ CoreWindow^ | sender,
 |  | _In_ WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [inline, private]

Definition at line 409 of file Main.cpp.

    {
        m_renderTargetView = nullptr;
        m_depthStencilView = nullptr;
        CreateWindowSizeDependentResources();
    }

void Direct3DTutorialFrameworkView::OnWindowSizeChanged | ( | _In_ CoreWindow^ | sender,
 |  | _In_ WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [inline, private]

Definition at line 160 of file Main.cpp.

    {
        m_renderTargetView = nullptr;
        CreateWindowSizeDependentResources();
    }

void Direct3DTutorialFrameworkView::OnWindowSizeChanged | ( | _In_ CoreWindow^ | sender,
 |  | _In_ WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [inline, private]

Definition at line 307 of file Main.cpp.

    {
        m_renderTargetView = nullptr;
        CreateWindowSizeDependentResources();
    }

virtual void Direct3DTutorialFrameworkView::Run ( ) [inline, virtual]

Definition at line 88 of file Main.cpp.

    {
        // First, create the Direct3D device.

        // This flag is required in order to enable compatibility with Direct2D.
        UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;

#if defined(_DEBUG)
        // If the project is in a debug build, enable debugging via SDK Layers with this flag.
        creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
#endif

        // This array defines the ordering of feature levels that D3D should attempt to create.
        D3D_FEATURE_LEVEL featureLevels[] =
        {
            D3D_FEATURE_LEVEL_11_1,
            D3D_FEATURE_LEVEL_11_0,
            D3D_FEATURE_LEVEL_10_1,
            D3D_FEATURE_LEVEL_10_0,
            D3D_FEATURE_LEVEL_9_3,
            D3D_FEATURE_LEVEL_9_1
        };

        ComPtr<ID3D11Device> d3dDevice;
        ComPtr<ID3D11DeviceContext> d3dDeviceContext;
        DX::ThrowIfFailed(
            D3D11CreateDevice(
                nullptr,                    // specify nullptr to use the default adapter
                D3D_DRIVER_TYPE_HARDWARE,
                nullptr,                    // leave as nullptr if hardware is used
                creationFlags,              // optionally set debug and Direct2D compatibility flags
                featureLevels,
                ARRAYSIZE(featureLevels),
                D3D11_SDK_VERSION,          // always set this to D3D11_SDK_VERSION
                &d3dDevice,
                nullptr,
                &d3dDeviceContext
                )
            );

        // Retrieve the Direct3D 11.1 interfaces.
        DX::ThrowIfFailed(
            d3dDevice.As(&m_d3dDevice)
            );

        DX::ThrowIfFailed(
            d3dDeviceContext.As(&m_d3dDeviceContext)
            );

        // After the D3D device is created, create additional application resources.
        CreateWindowSizeDependentResources();

        // Create a Basic Reader-Writer class to load data from disk.  This class is examined
        // in the Resource Loading sample.
        BasicReaderWriter^ reader = ref new BasicReaderWriter();

        // Load the raw vertex shader bytecode from disk and create a vertex shader with it.
        auto vertexShaderBytecode = reader->ReadData("SimpleVertexShader.cso");
        ComPtr<ID3D11VertexShader> vertexShader;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateVertexShader(
                vertexShaderBytecode->Data,
                vertexShaderBytecode->Length,
                nullptr,
                &vertexShader
                )
            );

        // Create an input layout that matches the layout defined in the vertex shader code.
        // These correspond to the elements of the BasicVertex struct defined above.
        const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
        {
            { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0,  0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "NORMAL",   0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 24, D3D11_INPUT_PER_VERTEX_DATA, 0 },
        };

        ComPtr<ID3D11InputLayout> inputLayout;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateInputLayout(
                basicVertexLayoutDesc,
                ARRAYSIZE(basicVertexLayoutDesc),
                vertexShaderBytecode->Data,
                vertexShaderBytecode->Length,
                &inputLayout
                )
            );

        // Load the raw pixel shader bytecode from disk and create a pixel shader with it.
        auto pixelShaderBytecode = reader->ReadData("SimplePixelShader.cso");
        ComPtr<ID3D11PixelShader> pixelShader;
        DX::ThrowIfFailed(
            m_d3dDevice->CreatePixelShader(
                pixelShaderBytecode->Data,
                pixelShaderBytecode->Length,
                nullptr,
                &pixelShader
                )
            );

        // Create vertex and index buffers that define a simple unit cube.

        // In the array below, which will be used to initialize the cube vertex buffers,
        // multiple vertices are used for each corner to allow different normal vectors and
        // texture coordinates to be defined for each face.
        BasicVertex cubeVertices[] =
        {
            { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
            { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
            { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
            { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },

            { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
            { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
            { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
            { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },

            { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
            { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
            { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
            { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },

            { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
            { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
            { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
            { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },

            { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
            { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
            { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
            { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },

            { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
            { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
            { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
            { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
        };

        unsigned short cubeIndices[] =
        {
            0, 1, 2,
            0, 2, 3,

            4, 5, 6,
            4, 6, 7,

            8, 9, 10,
            8, 10, 11,

            12, 13, 14,
            12, 14, 15,

            16, 17, 18,
            16, 18, 19,

            20, 21, 22,
            20, 22, 23
        };

        D3D11_BUFFER_DESC vertexBufferDesc = {0};
        vertexBufferDesc.ByteWidth = sizeof(BasicVertex) * ARRAYSIZE(cubeVertices);
        vertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
        vertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
        vertexBufferDesc.CPUAccessFlags = 0;
        vertexBufferDesc.MiscFlags = 0;
        vertexBufferDesc.StructureByteStride = 0;

        D3D11_SUBRESOURCE_DATA vertexBufferData;
        vertexBufferData.pSysMem = cubeVertices;
        vertexBufferData.SysMemPitch = 0;
        vertexBufferData.SysMemSlicePitch = 0;

        ComPtr<ID3D11Buffer> vertexBuffer;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &vertexBufferDesc,
                &vertexBufferData,
                &vertexBuffer
                )
            );

        D3D11_BUFFER_DESC indexBufferDesc;
        indexBufferDesc.ByteWidth = sizeof(unsigned short) * ARRAYSIZE(cubeIndices);
        indexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
        indexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
        indexBufferDesc.CPUAccessFlags = 0;
        indexBufferDesc.MiscFlags = 0;
        indexBufferDesc.StructureByteStride = 0;

        D3D11_SUBRESOURCE_DATA indexBufferData;
        indexBufferData.pSysMem = cubeIndices;
        indexBufferData.SysMemPitch = 0;
        indexBufferData.SysMemSlicePitch = 0;

        ComPtr<ID3D11Buffer> indexBuffer;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &indexBufferDesc,
                &indexBufferData,
                &indexBuffer
                )
            );

        // Create a constant buffer for passing model, view, and projection matrices
        // to the vertex shader.  This will allow us to rotate the cube and apply
        // a perspective projection to it.

        D3D11_BUFFER_DESC constantBufferDesc = {0};
        constantBufferDesc.ByteWidth = sizeof(m_constantBufferData);
        constantBufferDesc.Usage = D3D11_USAGE_DEFAULT;
        constantBufferDesc.BindFlags = D3D11_BIND_CONSTANT_BUFFER;
        constantBufferDesc.CPUAccessFlags = 0;
        constantBufferDesc.MiscFlags = 0;
        constantBufferDesc.StructureByteStride = 0;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &constantBufferDesc,
                nullptr,
                &m_constantBuffer
                )
            );

        // Specify the view transform corresponding to a camera position of
        // X = 0, Y = 1, Z = 2.  See Lesson 5 for a generalized camera class.

        m_constantBufferData.view = float4x4(
            -1.00000000f, 0.00000000f,  0.00000000f,  0.00000000f,
             0.00000000f, 0.89442718f,  0.44721359f,  0.00000000f,
             0.00000000f, 0.44721359f, -0.89442718f, -2.23606800f,
             0.00000000f, 0.00000000f,  0.00000000f,  1.00000000f
            );

        // Load the raw texture data from disk and construct a subresource description that references it.
        auto textureData = reader->ReadData("texturedata.bin");
        D3D11_SUBRESOURCE_DATA textureSubresourceData = {0};
        textureSubresourceData.pSysMem = textureData->Data;

        // Specify the size of a row in bytes, known a priori about the texture data.
        textureSubresourceData.SysMemPitch = 1024;

        // As this is not a texture array or 3D texture, this parameter is ignored.
        textureSubresourceData.SysMemSlicePitch = 0;

        // Create a texture description from information known a priori about the data.
        // Generalized texture loading code can be found in the Resource Loading sample.
        D3D11_TEXTURE2D_DESC textureDesc = {0};
        textureDesc.Width = 256;
        textureDesc.Height = 256;
        textureDesc.Format = DXGI_FORMAT_R8G8B8A8_UNORM;
        textureDesc.Usage = D3D11_USAGE_DEFAULT;
        textureDesc.CPUAccessFlags = 0;
        textureDesc.MiscFlags = 0;

        // Most textures contain more than one MIP level.  For simplicity, this sample uses only one.
        textureDesc.MipLevels = 1;

        // As this will not be a texture array, this parameter is ignored.
        textureDesc.ArraySize = 1;

        // Don't use multi-sampling.
        textureDesc.SampleDesc.Count = 1;
        textureDesc.SampleDesc.Quality = 0;

        // Allow the texture to be bound as a shader resource.
        textureDesc.BindFlags = D3D11_BIND_SHADER_RESOURCE;

        ComPtr<ID3D11Texture2D> texture;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateTexture2D(
                &textureDesc,
                &textureSubresourceData,
                &texture
                )
            );

        // Once the texture is created, we must create a shader resource view of it
        // so that shaders may use it.  In general, the view description will match
        // the texture description.
        D3D11_SHADER_RESOURCE_VIEW_DESC textureViewDesc;
        ZeroMemory(&textureViewDesc, sizeof(textureViewDesc));
        textureViewDesc.Format = textureDesc.Format;
        textureViewDesc.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
        textureViewDesc.Texture2D.MipLevels = textureDesc.MipLevels;
        textureViewDesc.Texture2D.MostDetailedMip = 0;

        ComPtr<ID3D11ShaderResourceView> textureView;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateShaderResourceView(
                texture.Get(),
                &textureViewDesc,
                &textureView
                )
            );

        // Once the texture view is created, create a sampler.  This defines how the color
        // for a particular texture coordinate is determined using the relevant texture data.
        D3D11_SAMPLER_DESC samplerDesc;
        ZeroMemory(&samplerDesc, sizeof(samplerDesc));

        samplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;

        // The sampler does not use anisotropic filtering, so this parameter is ignored.
        samplerDesc.MaxAnisotropy = 0;

        // Specify how texture coordinates outside of the range 0..1 are resolved.
        samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
        samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
        samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;

        // Use no special MIP clamping or bias.
        samplerDesc.MipLODBias = 0.0f;
        samplerDesc.MinLOD = 0;
        samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;

        // Don't use a comparison function.
        samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;

        // Border address mode is not used, so this parameter is ignored.
        samplerDesc.BorderColor[0] = 0.0f;
        samplerDesc.BorderColor[1] = 0.0f;
        samplerDesc.BorderColor[2] = 0.0f;
        samplerDesc.BorderColor[3] = 0.0f;

        ComPtr<ID3D11SamplerState> sampler;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateSamplerState(
                &samplerDesc,
                &sampler
                )
            );

        // This value will be used to animate the cube by rotating it every frame;
        float degree = 0.0f;

        // Enter the render loop. Note that Windows Store apps should never exit.
        while (true)
        {
            // Process events incoming to the window.
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);

            // Update the constant buffer to rotate the cube model.
            m_constantBufferData.model = rotationY(-degree);
            degree += 1.0f;

            m_d3dDeviceContext->UpdateSubresource(
                m_constantBuffer.Get(),
                0,
                nullptr,
                &m_constantBufferData,
                0,
                0
                );

            // Specify the render target and depth stencil we created as the output target.
            m_d3dDeviceContext->OMSetRenderTargets(
                1,
                m_renderTargetView.GetAddressOf(),
                m_depthStencilView.Get()
                );

            // Clear the render target to a solid color, and reset the depth stencil.
            const float clearColor[4] = { 0.071f, 0.04f, 0.561f, 1.0f };
            m_d3dDeviceContext->ClearRenderTargetView(
                m_renderTargetView.Get(),
                clearColor
                );

            m_d3dDeviceContext->ClearDepthStencilView(
                m_depthStencilView.Get(),
                D3D11_CLEAR_DEPTH,
                1.0f,
                0
                );

            m_d3dDeviceContext->IASetInputLayout(inputLayout.Get());

            // Set the vertex and index buffers, and specify the way they define geometry.
            UINT stride = sizeof(BasicVertex);
            UINT offset = 0;
            m_d3dDeviceContext->IASetVertexBuffers(
                0,
                1,
                vertexBuffer.GetAddressOf(),
                &stride,
                &offset
                );

            m_d3dDeviceContext->IASetIndexBuffer(
                indexBuffer.Get(),
                DXGI_FORMAT_R16_UINT,
                0
                );

            m_d3dDeviceContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

            // Set the vertex and pixel shader stage state.
            m_d3dDeviceContext->VSSetShader(
                vertexShader.Get(),
                nullptr,
                0
                );

            m_d3dDeviceContext->VSSetConstantBuffers(
                0,
                1,
                m_constantBuffer.GetAddressOf()
                );

            m_d3dDeviceContext->PSSetShader(
                pixelShader.Get(),
                nullptr,
                0
                );

            m_d3dDeviceContext->PSSetShaderResources(
                0,
                1,
                textureView.GetAddressOf()
                );

            m_d3dDeviceContext->PSSetSamplers(
                0,
                1,
                sampler.GetAddressOf()
                );

            // Draw the cube.
            m_d3dDeviceContext->DrawIndexed(
                ARRAYSIZE(cubeIndices),
                0,
                0
                );

            // Present the rendered image to the window.  Because the maximum frame latency is set to 1,
            // the render loop will generally be throttled to the screen refresh rate, typically around
            // 60Hz, by sleeping the application on Present until the screen is refreshed.
            DX::ThrowIfFailed(
                m_swapChain->Present(1, 0)
                );
        }
    }

virtual void Direct3DTutorialFrameworkView::Run ( ) [inline, virtual]

Definition at line 71 of file Main.cpp.

    {
        // First, create the Direct3D device.

        // This flag is required in order to enable compatibility with Direct2D.
        UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;

#if defined(_DEBUG)
        // If the project is in a debug build, enable debugging via SDK Layers with this flag.
        creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
#endif

        // This array defines the ordering of feature levels that D3D should attempt to create.
        D3D_FEATURE_LEVEL featureLevels[] =
        {
            D3D_FEATURE_LEVEL_11_1,
            D3D_FEATURE_LEVEL_11_0,
            D3D_FEATURE_LEVEL_10_1,
            D3D_FEATURE_LEVEL_10_0,
            D3D_FEATURE_LEVEL_9_3,
            D3D_FEATURE_LEVEL_9_1
        };

        ComPtr<ID3D11Device> d3dDevice;
        ComPtr<ID3D11DeviceContext> d3dDeviceContext;
        DX::ThrowIfFailed(
            D3D11CreateDevice(
                nullptr,                    // specify nullptr to use the default adapter
                D3D_DRIVER_TYPE_HARDWARE,
                nullptr,                    // leave as nullptr if hardware is used
                creationFlags,              // optionally set debug and Direct2D compatibility flags
                featureLevels,
                ARRAYSIZE(featureLevels),
                D3D11_SDK_VERSION,          // always set this to D3D11_SDK_VERSION
                &d3dDevice,
                nullptr,
                &d3dDeviceContext
                )
            );

        // Retrieve the Direct3D 11.1 interfaces.
        DX::ThrowIfFailed(
            d3dDevice.As(&m_d3dDevice)
            );

        DX::ThrowIfFailed(
            d3dDeviceContext.As(&m_d3dDeviceContext)
            );

        // After the D3D device is created, create additional application resources.
        CreateWindowSizeDependentResources();

        // Create a Basic Reader-Writer class to load data from disk.  This class is examined
        // in the Resource Loading sample.
        BasicReaderWriter^ reader = ref new BasicReaderWriter();

        // Load the raw vertex shader bytecode from disk and create a vertex shader with it.
        auto vertexShaderBytecode = reader->ReadData("SimpleVertexShader.cso");
        ComPtr<ID3D11VertexShader> vertexShader;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateVertexShader(
                vertexShaderBytecode->Data,
                vertexShaderBytecode->Length,
                nullptr,
                &vertexShader
                )
            );

        // Create an input layout that matches the layout defined in the vertex shader code.
        // For this lesson, this is simply a float2 vector defining the vertex position.
        const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
        {
            { "POSITION", 0, DXGI_FORMAT_R32G32_FLOAT, 0, 0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
        };

        ComPtr<ID3D11InputLayout> inputLayout;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateInputLayout(
                basicVertexLayoutDesc,
                ARRAYSIZE(basicVertexLayoutDesc),
                vertexShaderBytecode->Data,
                vertexShaderBytecode->Length,
                &inputLayout
                )
            );

        // Load the raw pixel shader bytecode from disk and create a pixel shader with it.
        auto pixelShaderBytecode = reader->ReadData("SimplePixelShader.cso");
        ComPtr<ID3D11PixelShader> pixelShader;
        DX::ThrowIfFailed(
            m_d3dDevice->CreatePixelShader(
                pixelShaderBytecode->Data,
                pixelShaderBytecode->Length,
                nullptr,
                &pixelShader
                )
            );

        // Create vertex and index buffers that define a simple triangle.

        float2 triangleVertices[] =
        {
            float2(-0.5f, -0.5f),
            float2( 0.0f,  0.5f),
            float2( 0.5f, -0.5f),
        };

        unsigned short triangleIndices[] =
        {
            0, 1, 2,
        };

        D3D11_BUFFER_DESC vertexBufferDesc = {0};
        vertexBufferDesc.ByteWidth = sizeof(float2) * ARRAYSIZE(triangleVertices);
        vertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
        vertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
        vertexBufferDesc.CPUAccessFlags = 0;
        vertexBufferDesc.MiscFlags = 0;
        vertexBufferDesc.StructureByteStride = 0;

        D3D11_SUBRESOURCE_DATA vertexBufferData;
        vertexBufferData.pSysMem = triangleVertices;
        vertexBufferData.SysMemPitch = 0;
        vertexBufferData.SysMemSlicePitch = 0;

        ComPtr<ID3D11Buffer> vertexBuffer;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &vertexBufferDesc,
                &vertexBufferData,
                &vertexBuffer
                )
            );

        D3D11_BUFFER_DESC indexBufferDesc;
        indexBufferDesc.ByteWidth = sizeof(unsigned short) * ARRAYSIZE(triangleIndices);
        indexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
        indexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
        indexBufferDesc.CPUAccessFlags = 0;
        indexBufferDesc.MiscFlags = 0;
        indexBufferDesc.StructureByteStride = 0;

        D3D11_SUBRESOURCE_DATA indexBufferData;
        indexBufferData.pSysMem = triangleIndices;
        indexBufferData.SysMemPitch = 0;
        indexBufferData.SysMemSlicePitch = 0;

        ComPtr<ID3D11Buffer> indexBuffer;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &indexBufferDesc,
                &indexBufferData,
                &indexBuffer
                )
            );

        // Enter the render loop. Note that Windows Store apps should never exit.
        while (true)
        {
            // Process events incoming to the window.
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);

            // Specify the render target we created as the output target.
            m_d3dDeviceContext->OMSetRenderTargets(
                1,
                m_renderTargetView.GetAddressOf(),
                nullptr // use no depth stencil
                );

            // Clear the render target to a solid color.
            const float clearColor[4] = { 0.071f, 0.04f, 0.561f, 1.0f };
            m_d3dDeviceContext->ClearRenderTargetView(
                m_renderTargetView.Get(),
                clearColor
                );

            m_d3dDeviceContext->IASetInputLayout(inputLayout.Get());

            // Set the vertex and index buffers, and specify the way they define geometry.
            UINT stride = sizeof(float2);
            UINT offset = 0;
            m_d3dDeviceContext->IASetVertexBuffers(
                0,
                1,
                vertexBuffer.GetAddressOf(),
                &stride,
                &offset
                );

            m_d3dDeviceContext->IASetIndexBuffer(
                indexBuffer.Get(),
                DXGI_FORMAT_R16_UINT,
                0
                );

            m_d3dDeviceContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

            // Set the vertex and pixel shader stage state.
            m_d3dDeviceContext->VSSetShader(
                vertexShader.Get(),
                nullptr,
                0
                );

            m_d3dDeviceContext->PSSetShader(
                pixelShader.Get(),
                nullptr,
                0
                );

            // Draw the cube.
            m_d3dDeviceContext->DrawIndexed(
                ARRAYSIZE(triangleIndices),
                0,
                0
                );

            // Present the rendered image to the window.  Because the maximum frame latency is set to 1,
            // the render loop will generally be throttled to the screen refresh rate, typically around
            // 60Hz, by sleeping the application on Present until the screen is refreshed.
            DX::ThrowIfFailed(
                m_swapChain->Present(1, 0)
                );
        }
    }

virtual void Direct3DTutorialFrameworkView::Run ( ) [inline, virtual]

Definition at line 87 of file Main.cpp.

    {
        // First, create the Direct3D device.

        // This flag is required in order to enable compatibility with Direct2D.
        UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;

#if defined(_DEBUG)
        // If the project is in a debug build, enable debugging via SDK Layers with this flag.
        creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
#endif

        // This array defines the ordering of feature levels that D3D should attempt to create.
        D3D_FEATURE_LEVEL featureLevels[] =
        {
            D3D_FEATURE_LEVEL_11_1,
            D3D_FEATURE_LEVEL_11_0,
            D3D_FEATURE_LEVEL_10_1,
            D3D_FEATURE_LEVEL_10_0,
            D3D_FEATURE_LEVEL_9_3,
            D3D_FEATURE_LEVEL_9_1
        };

        ComPtr<ID3D11Device> d3dDevice;
        ComPtr<ID3D11DeviceContext> d3dDeviceContext;
        DX::ThrowIfFailed(
            D3D11CreateDevice(
                nullptr,                    // specify nullptr to use the default adapter
                D3D_DRIVER_TYPE_HARDWARE,
                nullptr,                    // leave as nullptr if hardware is used
                creationFlags,              // optionally set debug and Direct2D compatibility flags
                featureLevels,
                ARRAYSIZE(featureLevels),
                D3D11_SDK_VERSION,          // always set this to D3D11_SDK_VERSION
                &d3dDevice,
                nullptr,
                &d3dDeviceContext
                )
            );

        // Retrieve the Direct3D 11.1 interfaces.
        DX::ThrowIfFailed(
            d3dDevice.As(&m_d3dDevice)
            );

        DX::ThrowIfFailed(
            d3dDeviceContext.As(&m_d3dDeviceContext)
            );

        // After the D3D device is created, create additional application resources.
        CreateWindowSizeDependentResources();

        // Create a Basic Reader-Writer class to load data from disk.  This class is examined
        // in the Resource Loading sample.
        BasicReaderWriter^ reader = ref new BasicReaderWriter();

        // Load the raw vertex shader bytecode from disk and create a vertex shader with it.
        auto vertexShaderBytecode = reader->ReadData("SimpleVertexShader.cso");
        ComPtr<ID3D11VertexShader> vertexShader;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateVertexShader(
                vertexShaderBytecode->Data,
                vertexShaderBytecode->Length,
                nullptr,
                &vertexShader
                )
            );

        // Create an input layout that matches the layout defined in the vertex shader code.
        // For this lesson, this is simply a float3 vector defining the vertex position, and
        // a float3 vector defining the vertex color.
        const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
        {
            { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0,  0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "COLOR",    0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
        };

        ComPtr<ID3D11InputLayout> inputLayout;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateInputLayout(
                basicVertexLayoutDesc,
                ARRAYSIZE(basicVertexLayoutDesc),
                vertexShaderBytecode->Data,
                vertexShaderBytecode->Length,
                &inputLayout
                )
            );

        // Load the raw pixel shader bytecode from disk and create a pixel shader with it.
        auto pixelShaderBytecode = reader->ReadData("SimplePixelShader.cso");
        ComPtr<ID3D11PixelShader> pixelShader;
        DX::ThrowIfFailed(
            m_d3dDevice->CreatePixelShader(
                pixelShaderBytecode->Data,
                pixelShaderBytecode->Length,
                nullptr,
                &pixelShader
                )
            );

        // Create vertex and index buffers that define a simple unit cube.

        // In the array below, which will be used to initialize the cube vertex buffers,
        // each vertex is assigned a color in addition to a position.  This will allow
        // the pixel shader to color each face differently, enabling them to be distinguished.
        SimpleCubeVertex cubeVertices[] =
        {
            { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f) }, // +Y (top face)
            { float3( 0.5f, 0.5f, -0.5f), float3(1.0f, 1.0f, 0.0f) },
            { float3( 0.5f, 0.5f,  0.5f), float3(1.0f, 1.0f, 1.0f) },
            { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 1.0f) },

            { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, 0.0f, 1.0f) }, // -Y (bottom face)
            { float3( 0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 1.0f) },
            { float3( 0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f) },
            { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, 0.0f) },
        };

        unsigned short cubeIndices[] =
        {
            0, 1, 2,
            0, 2, 3,

            4, 5, 6,
            4, 6, 7,

            3, 2, 5,
            3, 5, 4,

            2, 1, 6,
            2, 6, 5,

            1, 7, 6,
            1, 0, 7,

            0, 3, 4,
            0, 4, 7
        };

        D3D11_BUFFER_DESC vertexBufferDesc = {0};
        vertexBufferDesc.ByteWidth = sizeof(SimpleCubeVertex) * ARRAYSIZE(cubeVertices);
        vertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
        vertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
        vertexBufferDesc.CPUAccessFlags = 0;
        vertexBufferDesc.MiscFlags = 0;
        vertexBufferDesc.StructureByteStride = 0;

        D3D11_SUBRESOURCE_DATA vertexBufferData;
        vertexBufferData.pSysMem = cubeVertices;
        vertexBufferData.SysMemPitch = 0;
        vertexBufferData.SysMemSlicePitch = 0;

        ComPtr<ID3D11Buffer> vertexBuffer;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &vertexBufferDesc,
                &vertexBufferData,
                &vertexBuffer
                )
            );

        D3D11_BUFFER_DESC indexBufferDesc;
        indexBufferDesc.ByteWidth = sizeof(unsigned short) * ARRAYSIZE(cubeIndices);
        indexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
        indexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
        indexBufferDesc.CPUAccessFlags = 0;
        indexBufferDesc.MiscFlags = 0;
        indexBufferDesc.StructureByteStride = 0;

        D3D11_SUBRESOURCE_DATA indexBufferData;
        indexBufferData.pSysMem = cubeIndices;
        indexBufferData.SysMemPitch = 0;
        indexBufferData.SysMemSlicePitch = 0;

        ComPtr<ID3D11Buffer> indexBuffer;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &indexBufferDesc,
                &indexBufferData,
                &indexBuffer
                )
            );

        // Create a constant buffer for passing model, view, and projection matrices
        // to the vertex shader.  This will allow us to rotate the cube and apply
        // a perspective projection to it.

        D3D11_BUFFER_DESC constantBufferDesc = {0};
        constantBufferDesc.ByteWidth = sizeof(m_constantBufferData);
        constantBufferDesc.Usage = D3D11_USAGE_DEFAULT;
        constantBufferDesc.BindFlags = D3D11_BIND_CONSTANT_BUFFER;
        constantBufferDesc.CPUAccessFlags = 0;
        constantBufferDesc.MiscFlags = 0;
        constantBufferDesc.StructureByteStride = 0;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &constantBufferDesc,
                nullptr,
                &m_constantBuffer
                )
            );

        // Specify the view transform corresponding to a camera position of
        // X = 0, Y = 1, Z = 2.  See Lesson 5 for a generalized camera class.

        m_constantBufferData.view = float4x4(
            -1.00000000f, 0.00000000f,  0.00000000f,  0.00000000f,
             0.00000000f, 0.89442718f,  0.44721359f,  0.00000000f,
             0.00000000f, 0.44721359f, -0.89442718f, -2.23606800f,
             0.00000000f, 0.00000000f,  0.00000000f,  1.00000000f
            );

        // This value will be used to animate the cube by rotating it every frame;
        float degree = 0.0f;

        // Enter the render loop. Note that Windows Store apps should never exit.
        while (true)
        {
            // Process events incoming to the window.
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);

            // Update the constant buffer to rotate the cube model.
            m_constantBufferData.model = rotationY(-degree);
            degree += 1.0f;

            m_d3dDeviceContext->UpdateSubresource(
                m_constantBuffer.Get(),
                0,
                nullptr,
                &m_constantBufferData,
                0,
                0
                );

            // Specify the render target and depth stencil we created as the output target.
            m_d3dDeviceContext->OMSetRenderTargets(
                1,
                m_renderTargetView.GetAddressOf(),
                m_depthStencilView.Get()
                );

            // Clear the render target to a solid color, and reset the depth stencil.
            const float clearColor[4] = { 0.071f, 0.04f, 0.561f, 1.0f };
            m_d3dDeviceContext->ClearRenderTargetView(
                m_renderTargetView.Get(),
                clearColor
                );

            m_d3dDeviceContext->ClearDepthStencilView(
                m_depthStencilView.Get(),
                D3D11_CLEAR_DEPTH,
                1.0f,
                0
                );

            m_d3dDeviceContext->IASetInputLayout(inputLayout.Get());

            // Set the vertex and index buffers, and specify the way they define geometry.
            UINT stride = sizeof(SimpleCubeVertex);
            UINT offset = 0;
            m_d3dDeviceContext->IASetVertexBuffers(
                0,
                1,
                vertexBuffer.GetAddressOf(),
                &stride,
                &offset
                );

            m_d3dDeviceContext->IASetIndexBuffer(
                indexBuffer.Get(),
                DXGI_FORMAT_R16_UINT,
                0
                );

            m_d3dDeviceContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

            // Set the vertex and pixel shader stage state.
            m_d3dDeviceContext->VSSetShader(
                vertexShader.Get(),
                nullptr,
                0
                );

            m_d3dDeviceContext->VSSetConstantBuffers(
                0,
                1,
                m_constantBuffer.GetAddressOf()
                );

            m_d3dDeviceContext->PSSetShader(
                pixelShader.Get(),
                nullptr,
                0
                );

            // Draw the cube.
            m_d3dDeviceContext->DrawIndexed(
                ARRAYSIZE(cubeIndices),
                0,
                0
                );

            // Present the rendered image to the window.  Because the maximum frame latency is set to 1,
            // the render loop will generally be throttled to the screen refresh rate, typically around
            // 60Hz, by sleeping the application on Present until the screen is refreshed.
            DX::ThrowIfFailed(
                m_swapChain->Present(1, 0)
                );
        }
    }

virtual void Direct3DTutorialFrameworkView::Run ( ) [inline, virtual]

Definition at line 69 of file Main.cpp.

    {
        // First, create the Direct3D device.

        // This flag is required in order to enable compatibility with Direct2D.
        UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;

#if defined(_DEBUG)
        // If the project is in a debug build, enable debugging via SDK Layers with this flag.
        creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
#endif

        // This array defines the ordering of feature levels that D3D should attempt to create.
        D3D_FEATURE_LEVEL featureLevels[] =
        {
            D3D_FEATURE_LEVEL_11_1,
            D3D_FEATURE_LEVEL_11_0,
            D3D_FEATURE_LEVEL_10_1,
            D3D_FEATURE_LEVEL_10_0,
            D3D_FEATURE_LEVEL_9_3,
            D3D_FEATURE_LEVEL_9_1
        };

        ComPtr<ID3D11Device> d3dDevice;
        ComPtr<ID3D11DeviceContext> d3dDeviceContext;
        DX::ThrowIfFailed(
            D3D11CreateDevice(
                nullptr,                    // specify nullptr to use the default adapter
                D3D_DRIVER_TYPE_HARDWARE,
                nullptr,                    // leave as nullptr if hardware is used
                creationFlags,              // optionally set debug and Direct2D compatibility flags
                featureLevels,
                ARRAYSIZE(featureLevels),
                D3D11_SDK_VERSION,          // always set this to D3D11_SDK_VERSION
                &d3dDevice,
                nullptr,
                &d3dDeviceContext
                )
            );

        // Retrieve the Direct3D 11.1 interfaces.
        DX::ThrowIfFailed(
            d3dDevice.As(&m_d3dDevice)
            );

        DX::ThrowIfFailed(
            d3dDeviceContext.As(&m_d3dDeviceContext)
            );

        // After the D3D device is created, create additional application resources.
        CreateWindowSizeDependentResources();

        // Enter the render loop. Note that Windows Store apps should never exit.
        while (true)
        {
            // Process events incoming to the window.
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);

            // Specify the render target we created as the output target.
            m_d3dDeviceContext->OMSetRenderTargets(
                1,
                m_renderTargetView.GetAddressOf(),
                nullptr // use no depth stencil
                );

            // Clear the render target to a solid color.
            const float clearColor[4] = { 0.071f, 0.04f, 0.561f, 1.0f };
            m_d3dDeviceContext->ClearRenderTargetView(
                m_renderTargetView.Get(),
                clearColor
                );

            // Present the rendered image to the window.  Because the maximum frame latency is set to 1,
            // the render loop will generally be throttled to the screen refresh rate, typically around
            // 60Hz, by sleeping the application on Present until the screen is refreshed.
            DX::ThrowIfFailed(
                m_swapChain->Present(1, 0)
                );
        }
    }

virtual void Direct3DTutorialFrameworkView::SetWindow ( _In_ CoreWindow^ window ) [inline, virtual]

Definition at line 40 of file Main.cpp.

    {
        m_window = window;

        // Specify the cursor type as the standard arrow cursor.
        m_window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);

        // Allow the application to respond when the window size changes.
        m_window->SizeChanged +=
            ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(
                this,
                &Direct3DTutorialFrameworkView::OnWindowSizeChanged
                );
    }

virtual void Direct3DTutorialFrameworkView::SetWindow ( _In_ CoreWindow^ window ) [inline, virtual]

Definition at line 38 of file Main.cpp.

    {
        m_window = window;

        // Specify the cursor type as the standard arrow cursor.
        m_window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);

        // Allow the application to respond when the window size changes.
        m_window->SizeChanged +=
            ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(
                this,
                &Direct3DTutorialFrameworkView::OnWindowSizeChanged
                );
    }

virtual void Direct3DTutorialFrameworkView::SetWindow ( _In_ CoreWindow^ window ) [inline, virtual]

Definition at line 56 of file Main.cpp.

    {
        m_window = window;

        // Specify the cursor type as the standard arrow cursor.
        m_window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);

        // Allow the application to respond when the window size changes.
        m_window->SizeChanged +=
            ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(
                this,
                &Direct3DTutorialFrameworkView::OnWindowSizeChanged
                );
    }

virtual void Direct3DTutorialFrameworkView::SetWindow ( _In_ CoreWindow^ window ) [inline, virtual]

Definition at line 57 of file Main.cpp.

    {
        m_window = window;

        // Specify the cursor type as the standard arrow cursor.
        m_window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);

        // Allow the application to respond when the window size changes.
        m_window->SizeChanged +=
            ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(
                this,
                &Direct3DTutorialFrameworkView::OnWindowSizeChanged
                );
    }

virtual void Direct3DTutorialFrameworkView::Uninitialize ( ) [inline, virtual]

Definition at line 300 of file Main.cpp.

    {
    }

virtual void Direct3DTutorialFrameworkView::Uninitialize ( ) [inline, virtual]

Definition at line 535 of file Main.cpp.

    {
    }

virtual void Direct3DTutorialFrameworkView::Uninitialize ( ) [inline, virtual]

Definition at line 153 of file Main.cpp.

    {
    }

virtual void Direct3DTutorialFrameworkView::Uninitialize ( ) [inline, virtual]

Definition at line 402 of file Main.cpp.

    {
    }

Member Data Documentation

ComPtr< ID3D11Buffer > Direct3DTutorialFrameworkView::m_constantBuffer [private]

Definition at line 42 of file Main.cpp.

ConstantBuffer Direct3DTutorialFrameworkView::m_constantBufferData [private]

Definition at line 43 of file Main.cpp.

ComPtr< ID3D11Device1 > Direct3DTutorialFrameworkView::m_d3dDevice [private]

Definition at line 23 of file Main.cpp.

ComPtr< ID3D11DeviceContext1 > Direct3DTutorialFrameworkView::m_d3dDeviceContext [private]

Definition at line 24 of file Main.cpp.

ComPtr< ID3D11DepthStencilView > Direct3DTutorialFrameworkView::m_depthStencilView [private]

Definition at line 41 of file Main.cpp.

ComPtr< ID3D11RenderTargetView > Direct3DTutorialFrameworkView::m_renderTargetView [private]

Definition at line 25 of file Main.cpp.

ComPtr< IDXGISwapChain1 > Direct3DTutorialFrameworkView::m_swapChain [private]

Definition at line 22 of file Main.cpp.

Platform::Agile< CoreWindow > Direct3DTutorialFrameworkView::m_window [private]

Definition at line 21 of file Main.cpp.

The documentation for this class was generated from the following files:
  • Direct3D tutorial/C++/Lesson1.Basics/Main.cpp
  • Direct3D tutorial/C++/Lesson2.Triangles/Main.cpp
  • Direct3D tutorial/C++/Lesson3.Cubes/Main.cpp
  • Direct3D tutorial/C++/Lesson4.Textures/Main.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3DTutorialFrameworkViewSource Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

Direct3DTutorialFrameworkViewSource Class Reference

List of all members.

Public Member Functions

virtual IFrameworkView | CreateView ()
virtual IFrameworkView | CreateView ()
virtual IFrameworkView | CreateView ()
virtual IFrameworkView | CreateView ()

Detailed Description

Definition at line 292 of file Main.cpp.

Member Function Documentation

virtual IFrameworkView Direct3DTutorialFrameworkViewSource::CreateView ( ) [inline, virtual]

Definition at line 295 of file Main.cpp.

    {
        return ref new Direct3DTutorialFrameworkView();
    }

virtual IFrameworkView Direct3DTutorialFrameworkViewSource::CreateView ( ) [inline, virtual]

Definition at line 742 of file Main.cpp.

    {
        return ref new Direct3DTutorialFrameworkView();
    }

virtual IFrameworkView Direct3DTutorialFrameworkViewSource::CreateView ( ) [inline, virtual]

Definition at line 609 of file Main.cpp.

    {
        return ref new Direct3DTutorialFrameworkView();
    }

virtual IFrameworkView Direct3DTutorialFrameworkViewSource::CreateView ( ) [inline, virtual]

Definition at line 442 of file Main.cpp.

    {
        return ref new Direct3DTutorialFrameworkView();
    }

The documentation for this class was generated from the following files:
  • Direct3D tutorial/C++/Lesson1.Basics/Main.cpp
  • Direct3D tutorial/C++/Lesson2.Triangles/Main.cpp
  • Direct3D tutorial/C++/Lesson3.Cubes/Main.cpp
  • Direct3D tutorial/C++/Lesson4.Textures/Main.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::BC4_SNORM Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::BC4_SNORM
Public Member Functions | Public Attributes

DirectX::BC4_SNORM Struct Reference

List of all members.

Public Member Functions

float | DecodeFromIndex (size_t uIndex) const
size_t | GetIndex (size_t uOffset) const
float | R (size_t uOffset) const
void | SetIndex (size_t uOffset, size_t uIndex)

Public Attributes

union {
struct {
uint8_t indices [6]
int8_t red_0
int8_t red_1
}
uint64_t data
};

Detailed Description

Definition at line 95 of file BC4BC5.cpp.

Member Function Documentation

float DirectX::BC4_SNORM::DecodeFromIndex ( size_t uIndex ) const [inline]

Definition at line 103 of file BC4BC5.cpp.

    {
        int8_t sred_0 = (red_0 == -128)? -127 : red_0;
        int8_t sred_1 = (red_1 == -128)? -127 : red_1;

        if (uIndex == 0)
            return sred_0 / 127.0f;
        if (uIndex == 1)
            return sred_1 / 127.0f;
        float fred_0 = sred_0 / 127.0f;
        float fred_1 = sred_1 / 127.0f;
        if (red_0 > red_1)
        {
            uIndex -= 1;
            return (fred_0 * (7-uIndex) + fred_1 * uIndex) / 7.0f;
        }
        else
        {
            if (uIndex == 6)
                return -1.0f;
            if (uIndex == 7)
                return 1.0f;
            uIndex -= 1;
            return (fred_0 * (5-uIndex) + fred_1 * uIndex) / 5.0f;
        }
    }

size_t DirectX::BC4_SNORM::GetIndex ( size_t uOffset ) const [inline]

Definition at line 130 of file BC4BC5.cpp.

    {
        return (size_t) ((data >> (3*uOffset + 16)) & 0x07);
    }

float DirectX::BC4_SNORM::R ( size_t uOffset ) const [inline]

Definition at line 97 of file BC4BC5.cpp.

    {
        size_t uIndex = GetIndex(uOffset);
        return DecodeFromIndex(uIndex);
    }

void DirectX::BC4_SNORM::SetIndex | ( | size_t | uOffset,
 |  | size_t | uIndex |
 | ) |  |  | [inline]

Definition at line 135 of file BC4BC5.cpp.

    {
        data &= ~((uint64_t) 0x07 << (3*uOffset + 16));
        data |= ((uint64_t) uIndex << (3*uOffset + 16));
    }

Member Data Documentation

union { ... }
uint64_t DirectX::BC4_SNORM::data

Definition at line 149 of file BC4BC5.cpp.

uint8_t DirectX::BC4_SNORM::indices[6]

Definition at line 147 of file BC4BC5.cpp.

int8_t DirectX::BC4_SNORM::red_0

Definition at line 145 of file BC4BC5.cpp.

int8_t DirectX::BC4_SNORM::red_1

Definition at line 146 of file BC4BC5.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC4BC5.cpp
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::BC4_UNORM Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::BC4_UNORM
Public Member Functions | Public Attributes

DirectX::BC4_UNORM Struct Reference

List of all members.

Public Member Functions

float | DecodeFromIndex (size_t uIndex) const
size_t | GetIndex (size_t uOffset) const
float | R (size_t uOffset) const
void | SetIndex (size_t uOffset, size_t uIndex)

Public Attributes

union {
struct {
uint8_t indices [6]
uint8_t red_0
uint8_t red_1
}
uint64_t data
};

Detailed Description

Definition at line 39 of file BC4BC5.cpp.

Member Function Documentation

float DirectX::BC4_UNORM::DecodeFromIndex ( size_t uIndex ) const [inline]

Definition at line 47 of file BC4BC5.cpp.

    {
        if (uIndex == 0)
            return red_0 / 255.0f;
        if (uIndex == 1)
            return red_1 / 255.0f;
        float fred_0 = red_0 / 255.0f;
        float fred_1 = red_1 / 255.0f;
        if (red_0 > red_1)
        {
            uIndex -= 1;
            return (fred_0 * (7-uIndex) + fred_1 * uIndex) / 7.0f;
        }
        else
        {
            if (uIndex == 6)
                return 0.0f;
            if (uIndex == 7)
                return 1.0f;
            uIndex -= 1;
            return (fred_0 * (5-uIndex) + fred_1 * uIndex) / 5.0f;
        }
    }

size_t DirectX::BC4_UNORM::GetIndex ( size_t uOffset ) const [inline]

Definition at line 71 of file BC4BC5.cpp.

    {
        return (size_t) ((data >> (3*uOffset + 16)) & 0x07);
    }

float DirectX::BC4_UNORM::R ( size_t uOffset ) const [inline]

Definition at line 41 of file BC4BC5.cpp.

    {
        size_t uIndex = GetIndex(uOffset);
        return DecodeFromIndex(uIndex);
    }

void DirectX::BC4_UNORM::SetIndex | ( | size_t | uOffset,
 |  | size_t | uIndex |
 | ) |  |  | [inline]

Definition at line 76 of file BC4BC5.cpp.

    {
        data &= ~((uint64_t) 0x07 << (3*uOffset + 16));
        data |= ((uint64_t) uIndex << (3*uOffset + 16));
    }

Member Data Documentation

union { ... }
uint64_t DirectX::BC4_UNORM::data

Definition at line 90 of file BC4BC5.cpp.

uint8_t DirectX::BC4_UNORM::indices[6]

Definition at line 88 of file BC4BC5.cpp.

uint8_t DirectX::BC4_UNORM::red_0

Definition at line 86 of file BC4BC5.cpp.

uint8_t DirectX::BC4_UNORM::red_1

Definition at line 87 of file BC4BC5.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC4BC5.cpp
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::Blob Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::Blob
Public Member Functions | Private Member Functions | Private Attributes

DirectX::Blob Class Reference

#include "DirectXTex.h"

List of all members.

Public Member Functions

Blob ()
~Blob ()
void * | GetBufferPointer () const
size_t | GetBufferSize () const
HRESULT | Initialize (_In_ size_t size)
void | Release ()

Private Member Functions

Blob (const Blob &)
Blob & | operator= (const Blob &)

Private Attributes

void * | _buffer
size_t | _size

Detailed Description

Definition at line 218 of file DirectXTex.h.

Constructor & Destructor Documentation

DirectX::Blob::Blob ( ) [inline]

Definition at line 221 of file DirectXTex.h.

: _buffer(0), _size(0) {}

DirectX::Blob::~Blob ( ) [inline]

Definition at line 222 of file DirectXTex.h.

{ Release(); }

DirectX::Blob::Blob ( const Blob & ) [private]

Member Function Documentation

void* DirectX::Blob::GetBufferPointer ( ) const [inline]

Definition at line 228 of file DirectXTex.h.

{ return _buffer; }

size_t DirectX::Blob::GetBufferSize ( ) const [inline]

Definition at line 229 of file DirectXTex.h.

{ return _size; }

HRESULT DirectX::Blob::Initialize ( _In_ size_t size )
Blob& DirectX::Blob::operator= ( const Blob & ) [private]
void DirectX::Blob::Release ( )

Definition at line 498 of file DirectXTexUtil.cpp.

{
    if ( _buffer )
    {
        _aligned_free( _buffer );
        _buffer = nullptr;
    }

    _size = 0;
}

Member Data Documentation

void* DirectX::Blob::_buffer [private]

Definition at line 232 of file DirectXTex.h.

size_t DirectX::Blob::_size [private]

Definition at line 233 of file DirectXTex.h.

The documentation for this class was generated from the following files:
  • Direct3D resource loading/C++/texconv/DirectXTex.h
  • Direct3D resource loading/C++/texconv/DirectXTexUtil.cpp
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::CBits< SizeInBytes > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::CBits< SizeInBytes >
Public Member Functions | Private Attributes

DirectX::CBits< SizeInBytes > Class Template Reference

#include "BC.h"

List of all members.

Public Member Functions

uint8_t | GetBit (_Inout_ size_t &uStartBit) const
uint8_t | GetBits (_Inout_ size_t &uStartBit, _In_ size_t uNumBits) const
void | SetBit (_Inout_ size_t &uStartBit, _In_ uint8_t uValue)
void | SetBits (_Inout_ size_t &uStartBit, _In_ size_t uNumBits, _In_ uint8_t uValue)

Private Attributes

uint8_t | m_uBits [SizeInBytes]

Detailed Description

template<size_t SizeInBytes>
class DirectX::CBits< SizeInBytes >

Definition at line 441 of file BC.h.

Member Function Documentation

template<size_t SizeInBytes>
uint8_t DirectX::CBits< SizeInBytes >::GetBit ( _Inout_ size_t & uStartBit ) const [inline]

Definition at line 444 of file BC.h.

    {
        assert(uStartBit < 128);
        _Analysis_assume_(uStartBit < 128);
        size_t uIndex = uStartBit >> 3;
        uint8_t ret = (m_uBits[uIndex] >> (uStartBit - (uIndex << 3))) & 0x01;
        uStartBit++;
        return ret;
    }

template<size_t SizeInBytes>
uint8_t DirectX::CBits< SizeInBytes >::GetBits | ( | _Inout_ size_t & | uStartBit,
 |  | _In_ size_t | uNumBits |
 | ) |  |  | const [inline]

Definition at line 454 of file BC.h.

    {
        if(uNumBits == 0) return 0;
        assert(uStartBit + uNumBits <= 128 && uNumBits <= 8);
        _Analysis_assume_(uStartBit + uNumBits <= 128 && uNumBits <= 8);
        uint8_t ret;
        size_t uIndex = uStartBit >> 3;
        size_t uBase = uStartBit - (uIndex << 3);
        if(uBase + uNumBits > 8)
        {
            size_t uFirstIndexBits = 8 - uBase;
            size_t uNextIndexBits = uNumBits - uFirstIndexBits;
            ret = (m_uBits[uIndex] >> uBase) | ((m_uBits[uIndex+1] & ((1 << uNextIndexBits) - 1)) << uFirstIndexBits);
        }
        else
        {
            ret = (m_uBits[uIndex] >> uBase) & ((1 << uNumBits) - 1);
        }
        assert(ret < (1 << uNumBits));
        uStartBit += uNumBits;
        return ret;
    }

template<size_t SizeInBytes>
void DirectX::CBits< SizeInBytes >::SetBit | ( | _Inout_ size_t & | uStartBit,
 |  | _In_ uint8_t | uValue |
 | ) |  |  | [inline]

Definition at line 477 of file BC.h.

    {
        assert(uStartBit < 128 && uValue < 2);
        _Analysis_assume_(uStartBit < 128 && uValue < 2);
        size_t uIndex = uStartBit >> 3;
        size_t uBase = uStartBit - (uIndex << 3);
        m_uBits[uIndex] &= ~(1 << uBase);
        m_uBits[uIndex] |= uValue << uBase;
        uStartBit++;
    }

template<size_t SizeInBytes>
void DirectX::CBits< SizeInBytes >::SetBits | ( | _Inout_ size_t & | uStartBit,
 |  | _In_ size_t | uNumBits,
 |  | _In_ uint8_t | uValue |
 | ) |  |  | [inline]

Definition at line 488 of file BC.h.

    {
        if(uNumBits == 0)
            return;
        assert(uStartBit + uNumBits <= 128 && uNumBits <= 8);
        _Analysis_assume_(uStartBit + uNumBits <= 128 && uNumBits <= 8);
        assert(uValue < (1 << uNumBits));
        size_t uIndex = uStartBit >> 3;
        size_t uBase = uStartBit - (uIndex << 3);
        if(uBase + uNumBits > 8)
        {
            size_t uFirstIndexBits = 8 - uBase;
            size_t uNextIndexBits = uNumBits - uFirstIndexBits;
            m_uBits[uIndex] &= ~(((1 << uFirstIndexBits) - 1) << uBase);
            m_uBits[uIndex] |= uValue << uBase;
            m_uBits[uIndex+1] &= ~((1 << uNextIndexBits) - 1);
            m_uBits[uIndex+1] |= uValue >> uFirstIndexBits;
        }
        else
        {
            m_uBits[uIndex] &= ~(((1 << uNumBits) - 1) << uBase);
            m_uBits[uIndex] |= uValue << uBase;
        }
        uStartBit += uNumBits;
    }

Member Data Documentation

template<size_t SizeInBytes>
uint8_t DirectX::CBits< SizeInBytes >::m_uBits[SizeInBytes] [private]

Definition at line 515 of file BC.h.

The documentation for this class was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::ConvertData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::ConvertData
Public Attributes

DirectX::ConvertData Struct Reference

List of all members.

Public Attributes

size_t | datasize
DWORD | flags
DXGI_FORMAT | format

Detailed Description

Definition at line 1719 of file DirectXTexConvert.cpp.

Member Data Documentation

size_t DirectX::ConvertData::datasize

Definition at line 1722 of file DirectXTexConvert.cpp.

DWORD DirectX::ConvertData::flags

Definition at line 1723 of file DirectXTexConvert.cpp.

DXGI_FORMAT DirectX::ConvertData::format

Definition at line 1721 of file DirectXTexConvert.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTexConvert.cpp
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC1 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC1
Public Attributes

DirectX::D3DX_BC1 Struct Reference

#include "BC.h"

List of all members.

Public Attributes

uint32_t | bitmap
uint16_t | rgb [2]

Detailed Description

Definition at line 285 of file BC.h.

Member Data Documentation

uint32_t DirectX::D3DX_BC1::bitmap

Definition at line 288 of file BC.h.

uint16_t DirectX::D3DX_BC1::rgb[2]

Definition at line 287 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC2 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC2
Public Attributes

DirectX::D3DX_BC2 Struct Reference

#include "BC.h"

List of all members.

Public Attributes

D3DX_BC1 bc1
uint32_t bitmap [2]

Detailed Description

Definition at line 292 of file BC.h.

Member Data Documentation

D3DX_BC1 DirectX::D3DX_BC2::bc1

Definition at line 295 of file BC.h.

uint32_t DirectX::D3DX_BC2::bitmap[2]

Definition at line 294 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC3 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC3
Public Attributes

DirectX::D3DX_BC3 Struct Reference

#include "BC.h"

List of all members.

Public Attributes

uint8_t | alpha [2]
D3DX_BC1 bc1
uint8_t | bitmap [6]

Detailed Description

Definition at line 299 of file BC.h.

Member Data Documentation

uint8_t DirectX::D3DX_BC3::alpha[2]

Definition at line 301 of file BC.h.

D3DX_BC1 DirectX::D3DX_BC3::bc1

Definition at line 303 of file BC.h.

uint8_t DirectX::D3DX_BC3::bitmap[6]

Definition at line 302 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC6H Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC6H
Classes | Public Member Functions | Private Types | Private Member Functions | Static Private Member Functions | Static Private Attributes

DirectX::D3DX_BC6H Class Reference

#include "BC.h"

Inherits CBits< 16 >.

List of all members.

Classes

struct | EncodeParams
struct | ModeDescriptor
struct | ModeInfo

Public Member Functions

void | Decode (_In_ bool bSigned, _Out_writes_(NUM_PIXELS_PER_BLOCK) HDRColorA *pOut) const
void | Encode (_In_ bool bSigned, _In_reads_(NUM_PIXELS_PER_BLOCK) const HDRColorA *const pIn)

Private Types

enum EField {
NA, M, D, RW,
RX, RY, RZ, GW,
GX, GY, GZ, BW,
BX, BY, BZ
}

Private Member Functions

void | AssignIndices (_In_ const EncodeParams *pEP, _In_reads_(BC6H_MAX_REGIONS) const INTEndPntPair aEndPts[], _Out_writes_(NUM_PIXELS_PER_BLOCK) size_t aIndices[], _Out_writes_(BC6H_MAX_REGIONS) float aTotErr[]) const
void | EmitBlock (_In_ const EncodeParams *pEP, _In_reads_(BC6H_MAX_REGIONS) const INTEndPntPair aEndPts[], _In_reads_(NUM_PIXELS_PER_BLOCK) const size_t aIndices[])
void | GeneratePaletteQuantized (_In_ const EncodeParams *pEP, _In_ const INTEndPntPair &endPts, _Out_writes_(BC6H_MAX_INDICES) INTColor aPalette[]) const
float | MapColors (_In_ const EncodeParams *pEP, _In_ size_t uRegion, _In_ size_t np, _In_reads_(np) const size_t *auIndex) const
float | MapColorsQuantized (_In_ const EncodeParams *pEP, _In_reads_(np) const INTColor aColors[], _In_ size_t np, _In_ const INTEndPntPair &endPts) const
void | OptimizeEndPoints (_In_ const EncodeParams *pEP, _In_reads_(BC6H_MAX_REGIONS) const float aOrgErr[], _In_reads_(BC6H_MAX_REGIONS) const INTEndPntPair aOrgEndPts[], _Inout_updates_all_(BC6H_MAX_REGIONS) INTEndPntPair aOptEndPts[]) const
void | OptimizeOne (_In_ const EncodeParams *pEP, _In_reads_(np) const INTColor aColors[], _In_ size_t np, _In_ float aOrgErr, _In_ const INTEndPntPair &aOrgEndPts, _Out_ INTEndPntPair &aOptEndPts) const
float | PerturbOne (_In_ const EncodeParams *pEP, _In_reads_(np) const INTColor aColors[], _In_ size_t np, _In_ uint8_t ch, _In_ const INTEndPntPair &oldEndPts, _Out_ INTEndPntPair &newEndPts, _In_ float fOldErr, _In_ int do_b) const
void | QuantizeEndPts (_In_ const EncodeParams *pEP, _Out_writes_(BC6H_MAX_REGIONS) INTEndPntPair *qQntEndPts) const
void | Refine (_Inout_ EncodeParams *pEP)
float | RoughMSE (_Inout_ EncodeParams *pEP) const

Static Private Member Functions

static bool | EndPointsFit (_In_ const EncodeParams *pEP, _In_reads_(BC6H_MAX_REGIONS) const INTEndPntPair aEndPts[])
static int | FinishUnquantize (_In_ int comp, _In_ bool bSigned)
static void | GeneratePaletteUnquantized (_In_ const EncodeParams *pEP, _In_ size_t uRegion, _Out_writes_(BC6H_MAX_INDICES) INTColor aPalette[])
static int | Quantize (_In_ int iValue, _In_ int prec, _In_ bool bSigned)
static void | SwapIndices (_In_ const EncodeParams *pEP, _Inout_updates_all_(BC6H_MAX_REGIONS) INTEndPntPair aEndPts[], _In_reads_(NUM_PIXELS_PER_BLOCK) size_t aIndices[])
static int | Unquantize (_In_ int comp, _In_ uint8_t uBitsPerComp, _In_ bool bSigned)

Static Private Attributes

static const ModeDescriptor | ms_aDesc [][82]
static const ModeInfo | ms_aInfo []
static const int | ms_aModeToInfo []

Detailed Description

Definition at line 522 of file BC.h.

Member Enumeration Documentation

enum DirectX::D3DX_BC6H::EField [private]
Enumerator:
NA
M
D
RW
RX
RY
RZ
GW
GX
GY
GZ
BW
BX
BY
BZ

Definition at line 529 of file BC.h.

                : uint8_t
    {
        NA, // N/A
        M,  // Mode
        D,  // Shape
        RW,
        RX,
        RY,
        RZ,
        GW,
        GX,
        GY,
        GZ,
        BW,
        BX,
        BY,
        BZ,
    };

Member Function Documentation

void DirectX::D3DX_BC6H::AssignIndices | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(BC6H_MAX_REGIONS) const INTEndPntPair | aEndPts[],
 |  | _Out_writes_(NUM_PIXELS_PER_BLOCK) size_t | aIndices[],
 |  | _Out_writes_(BC6H_MAX_REGIONS) float | aTotErr[] |
 | ) |  |  | const [private]
void DirectX::D3DX_BC6H::Decode | ( | _In_ bool | bSigned,
 |  | _Out_writes_(NUM_PIXELS_PER_BLOCK) HDRColorA * | pOut |
 | ) |  |  | const
void DirectX::D3DX_BC6H::EmitBlock | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(BC6H_MAX_REGIONS) const INTEndPntPair | aEndPts[],
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const size_t | aIndices[] |
 | ) |  |  | [private]
void DirectX::D3DX_BC6H::Encode | ( | _In_ bool | bSigned,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const HDRColorA *const | pIn
 | ) |  |
static bool DirectX::D3DX_BC6H::EndPointsFit | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(BC6H_MAX_REGIONS) const INTEndPntPair | aEndPts[] |
 | ) |  |  | [static, private]
static int DirectX::D3DX_BC6H::FinishUnquantize | ( | _In_ int | comp,
 |  | _In_ bool | bSigned |
 | ) |  |  | [static, private]
void DirectX::D3DX_BC6H::GeneratePaletteQuantized | ( | _In_ const EncodeParams * | pEP,
 |  | _In_ const INTEndPntPair & | endPts,
 |  | _Out_writes_(BC6H_MAX_INDICES) INTColor | aPalette[] |
 | ) |  |  | const [private]
static void DirectX::D3DX_BC6H::GeneratePaletteUnquantized | ( | _In_ const EncodeParams * | pEP,
 |  | _In_ size_t | uRegion,
 |  | _Out_writes_(BC6H_MAX_INDICES) INTColor | aPalette[] |
 | ) |  |  | [static, private]
float DirectX::D3DX_BC6H::MapColors | ( | _In_ const EncodeParams * | pEP,
 |  | _In_ size_t | uRegion,
 |  | _In_ size_t | np,
 |  | _In_reads_(np) const size_t * | auIndex |
 | ) |  |  | const [private]
float DirectX::D3DX_BC6H::MapColorsQuantized | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(np) const INTColor | aColors[],
 |  | _In_ size_t | np,
 |  | _In_ const INTEndPntPair & | endPts |
 | ) |  |  | const [private]
void DirectX::D3DX_BC6H::OptimizeEndPoints | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(BC6H_MAX_REGIONS) const float | aOrgErr[],
 |  | _In_reads_(BC6H_MAX_REGIONS) const INTEndPntPair | aOrgEndPts[],
 |  | _Inout_updates_all_(BC6H_MAX_REGIONS) INTEndPntPair | aOptEndPts[] |
 | ) |  |  | const [private]
void DirectX::D3DX_BC6H::OptimizeOne | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(np) const INTColor | aColors[],
 |  | _In_ size_t | np,
 |  | _In_ float | aOrgErr,
 |  | _In_ const INTEndPntPair & | aOrgEndPts,
 |  | _Out_ INTEndPntPair & | aOptEndPts |
 | ) |  |  | const [private]
float DirectX::D3DX_BC6H::PerturbOne | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(np) const INTColor | aColors[],
 |  | _In_ size_t | np,
 |  | _In_ uint8_t | ch,
 |  | _In_ const INTEndPntPair & | oldEndPts,
 |  | _Out_ INTEndPntPair & | newEndPts,
 |  | _In_ float | fOldErr,
 |  | _In_ int | do_b |
 | ) |  |  | const [private]
static int DirectX::D3DX_BC6H::Quantize | ( | _In_ int | iValue,
 |  | _In_ int | prec,
 |  | _In_ bool | bSigned |
 | ) |  |  | [static, private]
void DirectX::D3DX_BC6H::QuantizeEndPts | ( | _In_ const EncodeParams * | pEP,
 |  | _Out_writes_(BC6H_MAX_REGIONS) INTEndPntPair * | qQntEndPts |
 | ) |  |  | const [private]
void DirectX::D3DX_BC6H::Refine ( _Inout_ EncodeParams * pEP ) [private]
float DirectX::D3DX_BC6H::RoughMSE ( _Inout_ EncodeParams * pEP ) const [private]
static void DirectX::D3DX_BC6H::SwapIndices | ( | _In_ const EncodeParams * | pEP,
 |  | _Inout_updates_all_(BC6H_MAX_REGIONS) INTEndPntPair | aEndPts[],
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) size_t | aIndices[] |
 | ) |  |  | [static, private]
static int DirectX::D3DX_BC6H::Unquantize | ( | _In_ int | comp,
 |  | _In_ uint8_t | uBitsPerComp,
 |  | _In_ bool | bSigned |
 | ) |  |  | [static, private]

Member Data Documentation

const D3DX_BC6H::ModeDescriptor DirectX::D3DX_BC6H::ms_aDesc [static, private]

Definition at line 614 of file BC.h.

const D3DX_BC6H::ModeInfo DirectX::D3DX_BC6H::ms_aInfo [static, private]
Initial value:
{
    {0x00, 1, true,  3, LDRColorA(10,10,10,0), LDRColorA( 5, 5, 5,0), LDRColorA(5,5,5,0), LDRColorA(5,5,5,0)},
    {0x01, 1, true,  3, LDRColorA( 7, 7, 7,0), LDRColorA( 6, 6, 6,0), LDRColorA(6,6,6,0), LDRColorA(6,6,6,0)},
    {0x02, 1, true,  3, LDRColorA(11,11,11,0), LDRColorA( 5, 4, 4,0), LDRColorA(5,4,4,0), LDRColorA(5,4,4,0)},
    {0x06, 1, true,  3, LDRColorA(11,11,11,0), LDRColorA( 4, 5, 4,0), LDRColorA(4,5,4,0), LDRColorA(4,5,4,0)},
    {0x0a, 1, true,  3, LDRColorA(11,11,11,0), LDRColorA( 4, 4, 5,0), LDRColorA(4,4,5,0), LDRColorA(4,4,5,0)},
    {0x0e, 1, true,  3, LDRColorA( 9, 9, 9,0), LDRColorA( 5, 5, 5,0), LDRColorA(5,5,5,0), LDRColorA(5,5,5,0)},
    {0x12, 1, true,  3, LDRColorA( 8, 8, 8,0), LDRColorA( 6, 5, 5,0), LDRColorA(6,5,5,0), LDRColorA(6,5,5,0)},
    {0x16, 1, true,  3, LDRColorA( 8, 8, 8,0), LDRColorA( 5, 6, 5,0), LDRColorA(5,6,5,0), LDRColorA(5,6,5,0)},
    {0x1a, 1, true,  3, LDRColorA( 8, 8, 8,0), LDRColorA( 5, 5, 6,0), LDRColorA(5,5,6,0), LDRColorA(5,5,6,0)},
    {0x1e, 1, false, 3, LDRColorA( 6, 6, 6,0), LDRColorA( 6, 6, 6,0), LDRColorA(6,6,6,0), LDRColorA(6,6,6,0)},
    {0x03, 0, false, 4, LDRColorA(10,10,10,0), LDRColorA(10,10,10,0), LDRColorA(0,0,0,0), LDRColorA(0,0,0,0)},
    {0x07, 0, true,  4, LDRColorA(11,11,11,0), LDRColorA( 9, 9, 9,0), LDRColorA(0,0,0,0), LDRColorA(0,0,0,0)},
    {0x0b, 0, true,  4, LDRColorA(12,12,12,0), LDRColorA( 8, 8, 8,0), LDRColorA(0,0,0,0), LDRColorA(0,0,0,0)},
    {0x0f, 0, true,  4, LDRColorA(16,16,16,0), LDRColorA( 4, 4, 4,0), LDRColorA(0,0,0,0), LDRColorA(0,0,0,0)},
}

Definition at line 615 of file BC.h.

const int DirectX::D3DX_BC6H::ms_aModeToInfo [static, private]

Definition at line 616 of file BC.h.

The documentation for this class was generated from the following files:
  • Direct3D resource loading/C++/texconv/BC.h
  • Direct3D resource loading/C++/texconv/BC6HBC7.cpp
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC6H::EncodeParams Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC6H
  • DirectX::D3DX_BC6H::EncodeParams
Public Member Functions | Public Attributes

DirectX::D3DX_BC6H::EncodeParams Struct Reference

List of all members.

Public Member Functions

EncodeParams (const HDRColorA *const aOriginal, bool bSignedFormat)

Public Attributes

const HDRColorA *const | aHDRPixels
INTColor | aIPixels [NUM_PIXELS_PER_BLOCK]
INTEndPntPair | aUnqEndPts [BC6H_MAX_SHAPES][BC6H_MAX_REGIONS]
const bool | bSigned
float | fBestErr
uint8_t | uMode
uint8_t | uShape

Detailed Description

Definition at line 563 of file BC.h.

Constructor & Destructor Documentation

DirectX::D3DX_BC6H::EncodeParams::EncodeParams | ( | const HDRColorA *const | aOriginal,
 |  | bool | bSignedFormat |
 | ) |  |  | [inline]

Definition at line 573 of file BC.h.

                                                                           :
            aHDRPixels(aOriginal), fBestErr(FLT_MAX), bSigned(bSignedFormat)
        {
            for(size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
            {
                aIPixels[i].Set(aOriginal[i], bSigned);
            }
        }

Member Data Documentation

const HDRColorA* const DirectX::D3DX_BC6H::EncodeParams::aHDRPixels

Definition at line 569 of file BC.h.

INTColor DirectX::D3DX_BC6H::EncodeParams::aIPixels[NUM_PIXELS_PER_BLOCK]

Definition at line 571 of file BC.h.

INTEndPntPair DirectX::D3DX_BC6H::EncodeParams::aUnqEndPts[BC6H_MAX_SHAPES][BC6H_MAX_REGIONS]

Definition at line 570 of file BC.h.

const bool DirectX::D3DX_BC6H::EncodeParams::bSigned

Definition at line 566 of file BC.h.

float DirectX::D3DX_BC6H::EncodeParams::fBestErr

Definition at line 565 of file BC.h.

uint8_t DirectX::D3DX_BC6H::EncodeParams::uMode

Definition at line 567 of file BC.h.

uint8_t DirectX::D3DX_BC6H::EncodeParams::uShape

Definition at line 568 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC6H::ModeDescriptor Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC6H
  • DirectX::D3DX_BC6H::ModeDescriptor
Public Attributes

DirectX::D3DX_BC6H::ModeDescriptor Struct Reference

List of all members.

Public Attributes

EField m_eField
uint8_t m_uBit

Detailed Description

Definition at line 548 of file BC.h.

Member Data Documentation

EField DirectX::D3DX_BC6H::ModeDescriptor::m_eField

Definition at line 550 of file BC.h.

uint8_t DirectX::D3DX_BC6H::ModeDescriptor::m_uBit

Definition at line 551 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC6H::ModeInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC6H
  • DirectX::D3DX_BC6H::ModeInfo
Public Attributes

DirectX::D3DX_BC6H::ModeInfo Struct Reference

List of all members.

Public Attributes

bool | bTransformed
LDRColorA | RGBAPrec [BC6H_MAX_REGIONS][2]
uint8_t | uIndexPrec
uint8_t | uMode
uint8_t | uPartitions

Detailed Description

Definition at line 554 of file BC.h.

Member Data Documentation

bool DirectX::D3DX_BC6H::ModeInfo::bTransformed

Definition at line 558 of file BC.h.

LDRColorA DirectX::D3DX_BC6H::ModeInfo::RGBAPrec[BC6H_MAX_REGIONS][2]

Definition at line 560 of file BC.h.

uint8_t DirectX::D3DX_BC6H::ModeInfo::uIndexPrec

Definition at line 559 of file BC.h.

uint8_t DirectX::D3DX_BC6H::ModeInfo::uMode

Definition at line 556 of file BC.h.

uint8_t DirectX::D3DX_BC6H::ModeInfo::uPartitions

Definition at line 557 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC7 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC7
Classes | Public Member Functions | Private Member Functions | Static Private Member Functions | Static Private Attributes

DirectX::D3DX_BC7 Class Reference

#include "BC.h"

Inherits CBits< 16 >.

List of all members.

Classes

struct | EncodeParams
struct | ModeInfo

Public Member Functions

void | Decode (_Out_writes_(NUM_PIXELS_PER_BLOCK) HDRColorA *pOut) const
void | Encode (_In_reads_(NUM_PIXELS_PER_BLOCK) const HDRColorA *const pIn)

Private Member Functions

void | AssignIndices (_In_ const EncodeParams *pEP, _In_ size_t uShape, _In_ size_t uIndexMode, _In_reads_(BC7_MAX_REGIONS) LDREndPntPair endpts[], _Inout_updates_all_(NUM_PIXELS_PER_BLOCK) size_t aIndices[], _Inout_updates_all_(NUM_PIXELS_PER_BLOCK) size_t aIndices2[], _Out_writes_(BC7_MAX_REGIONS) float afTotErr[]) const
void | EmitBlock (_In_ const EncodeParams *pEP, _In_ size_t uShape, _In_ size_t uRotation, _In_ size_t uIndexMode, _In_reads_(BC7_MAX_REGIONS) const LDREndPntPair aEndPts[], _In_reads_(NUM_PIXELS_PER_BLOCK) const size_t aIndex[], _In_reads_(NUM_PIXELS_PER_BLOCK) const size_t aIndex2[])
void | Exhaustive (_In_ const EncodeParams *pEP, _In_reads_(np) const LDRColorA aColors[], _In_ size_t np, _In_ size_t uIndexMode, _In_ size_t ch, _Inout_ float &fOrgErr, _Inout_ LDREndPntPair &optEndPt) const
void | GeneratePaletteQuantized (_In_ const EncodeParams *pEP, _In_ size_t uIndexMode, _In_ const LDREndPntPair &endpts, _Out_writes_(BC7_MAX_INDICES) LDRColorA aPalette[]) const
float | MapColors (_In_ const EncodeParams *pEP, _In_reads_(np) const LDRColorA aColors[], _In_ size_t np, _In_ size_t uIndexMode, _In_ const LDREndPntPair &endPts, _In_ float fMinErr) const
void | OptimizeEndPoints (_In_ const EncodeParams *pEP, _In_ size_t uShape, _In_ size_t uIndexMode, _In_reads_(BC7_MAX_REGIONS) const float orig_err[], _In_reads_(BC7_MAX_REGIONS) const LDREndPntPair orig_endpts[], _Out_writes_(BC7_MAX_REGIONS) LDREndPntPair opt_endpts[]) const
void | OptimizeOne (_In_ const EncodeParams *pEP, _In_reads_(np) const LDRColorA colors[], _In_ size_t np, _In_ size_t uIndexMode, _In_ float orig_err, _In_ const LDREndPntPair &orig_endpts, _Out_ LDREndPntPair &opt_endpts) const
float | PerturbOne (_In_ const EncodeParams *pEP, _In_reads_(np) const LDRColorA colors[], _In_ size_t np, _In_ size_t uIndexMode, _In_ size_t ch, _In_ const LDREndPntPair &old_endpts, _Out_ LDREndPntPair &new_endpts, _In_ float old_err, _In_ uint8_t do_b) const
float | Refine (_In_ const EncodeParams *pEP, _In_ size_t uShape, _In_ size_t uRotation, _In_ size_t uIndexMode)

Static Private Member Functions

static uint8_t | Quantize (_In_ uint8_t comp, _In_ uint8_t uPrec)
static LDRColorA | Quantize (_In_ const LDRColorA &c, _In_ const LDRColorA &RGBAPrec)
static float | RoughMSE (_Inout_ EncodeParams *pEP, _In_ size_t uShape, _In_ size_t uIndexMode)
static uint8_t | Unquantize (_In_ uint8_t comp, _In_ size_t uPrec)
static LDRColorA | Unquantize (_In_ const LDRColorA &c, _In_ const LDRColorA &RGBAPrec)

Static Private Attributes

static const ModeInfo | ms_aInfo []

Detailed Description

Definition at line 620 of file BC.h.

Member Function Documentation

void DirectX::D3DX_BC7::AssignIndices | ( | _In_ const EncodeParams * | pEP,
 |  | _In_ size_t | uShape,
 |  | _In_ size_t | uIndexMode,
 |  | _In_reads_(BC7_MAX_REGIONS) LDREndPntPair | endpts[],
 |  | _Inout_updates_all_(NUM_PIXELS_PER_BLOCK) size_t | aIndices[],
 |  | _Inout_updates_all_(NUM_PIXELS_PER_BLOCK) size_t | aIndices2[],
 |  | _Out_writes_(BC7_MAX_REGIONS) float | afTotErr[] |
 | ) |  |  | const [private]
void DirectX::D3DX_BC7::Decode ( _Out_writes_(NUM_PIXELS_PER_BLOCK) HDRColorA * pOut ) const
void DirectX::D3DX_BC7::EmitBlock | ( | _In_ const EncodeParams * | pEP,
 |  | _In_ size_t | uShape,
 |  | _In_ size_t | uRotation,
 |  | _In_ size_t | uIndexMode,
 |  | _In_reads_(BC7_MAX_REGIONS) const LDREndPntPair | aEndPts[],
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const size_t | aIndex[],
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const size_t | aIndex2[] |
 | ) |  |  | [private]
void DirectX::D3DX_BC7::Encode ( _In_reads_(NUM_PIXELS_PER_BLOCK) const HDRColorA *const pIn )
void DirectX::D3DX_BC7::Exhaustive | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(np) const LDRColorA | aColors[],
 |  | _In_ size_t | np,
 |  | _In_ size_t | uIndexMode,
 |  | _In_ size_t | ch,
 |  | _Inout_ float & | fOrgErr,
 |  | _Inout_ LDREndPntPair & | optEndPt |
 | ) |  |  | const [private]
void DirectX::D3DX_BC7::GeneratePaletteQuantized | ( | _In_ const EncodeParams * | pEP,
 |  | _In_ size_t | uIndexMode,
 |  | _In_ const LDREndPntPair & | endpts,
 |  | _Out_writes_(BC7_MAX_INDICES) LDRColorA | aPalette[] |
 | ) |  |  | const [private]
float DirectX::D3DX_BC7::MapColors | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(np) const LDRColorA | aColors[],
 |  | _In_ size_t | np,
 |  | _In_ size_t | uIndexMode,
 |  | _In_ const LDREndPntPair & | endPts,
 |  | _In_ float | fMinErr |
 | ) |  |  | const [private]
void DirectX::D3DX_BC7::OptimizeEndPoints | ( | _In_ const EncodeParams * | pEP,
 |  | _In_ size_t | uShape,
 |  | _In_ size_t | uIndexMode,
 |  | _In_reads_(BC7_MAX_REGIONS) const float | orig_err[],
 |  | _In_reads_(BC7_MAX_REGIONS) const LDREndPntPair | orig_endpts[],
 |  | _Out_writes_(BC7_MAX_REGIONS) LDREndPntPair | opt_endpts[] |
 | ) |  |  | const [private]
void DirectX::D3DX_BC7::OptimizeOne | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(np) const LDRColorA | colors[],
 |  | _In_ size_t | np,
 |  | _In_ size_t | uIndexMode,
 |  | _In_ float | orig_err,
 |  | _In_ const LDREndPntPair & | orig_endpts,
 |  | _Out_ LDREndPntPair & | opt_endpts |
 | ) |  |  | const [private]
float DirectX::D3DX_BC7::PerturbOne | ( | _In_ const EncodeParams * | pEP,
 |  | _In_reads_(np) const LDRColorA | colors[],
 |  | _In_ size_t | np,
 |  | _In_ size_t | uIndexMode,
 |  | _In_ size_t | ch,
 |  | _In_ const LDREndPntPair & | old_endpts,
 |  | _Out_ LDREndPntPair & | new_endpts,
 |  | _In_ float | old_err,
 |  | _In_ uint8_t | do_b |
 | ) |  |  | const [private]
static LDRColorA DirectX::D3DX_BC7::Quantize | ( | _In_ const LDRColorA & | c,
 |  | _In_ const LDRColorA & | RGBAPrec |
 | ) |  |  | [inline, static, private]

Definition at line 657 of file BC.h.

    {
        LDRColorA q;
        q.r = Quantize(c.r, RGBAPrec.r);
        q.g = Quantize(c.g, RGBAPrec.g);
        q.b = Quantize(c.b, RGBAPrec.b);
        if(RGBAPrec.a)
            q.a = Quantize(c.a, RGBAPrec.a);
        else
            q.a = 255;
        return q;
    }

static uint8_t DirectX::D3DX_BC7::Quantize | ( | _In_ uint8_t | comp,
 |  | _In_ uint8_t | uPrec |
 | ) |  |  | [inline, static, private]

Definition at line 650 of file BC.h.

    {
        assert(0 < uPrec && uPrec <= 8);
        uint8_t rnd = (uint8_t) std::min<uint16_t>(255, uint16_t(comp) + (1 << (7 - uPrec)));
        return rnd >> (8 - uPrec);
    }

float DirectX::D3DX_BC7::Refine | ( | _In_ const EncodeParams * | pEP,
 |  | _In_ size_t | uShape,
 |  | _In_ size_t | uRotation,
 |  | _In_ size_t | uIndexMode |
 | ) |  |  | [private]
static float DirectX::D3DX_BC7::RoughMSE | ( | _Inout_ EncodeParams * | pEP,
 |  | _In_ size_t | uShape,
 |  | _In_ size_t | uIndexMode |
 | ) |  |  | [static, private]
static LDRColorA DirectX::D3DX_BC7::Unquantize | ( | _In_ const LDRColorA & | c,
 |  | _In_ const LDRColorA & | RGBAPrec |
 | ) |  |  | [inline, static, private]

Definition at line 677 of file BC.h.

    {
        LDRColorA q;
        q.r = Unquantize(c.r, RGBAPrec.r);
        q.g = Unquantize(c.g, RGBAPrec.g);
        q.b = Unquantize(c.b, RGBAPrec.b);
        q.a = RGBAPrec.a > 0 ? Unquantize(c.a, RGBAPrec.a) : 255;
        return q;
    }

static uint8_t DirectX::D3DX_BC7::Unquantize | ( | _In_ uint8_t | comp,
 |  | _In_ size_t | uPrec |
 | ) |  |  | [inline, static, private]

Definition at line 670 of file BC.h.

    {
        assert(0 < uPrec && uPrec <= 8);
        comp = comp << (8 - uPrec);
        return comp | (comp >> uPrec);
    }

Member Data Documentation

const D3DX_BC7::ModeInfo DirectX::D3DX_BC7::ms_aInfo [static, private]
Initial value:
{
    {2, 4, 6, 0, 0, 3, 0, LDRColorA(4,4,4,0), LDRColorA(5,5,5,0)},

    {1, 6, 2, 0, 0, 3, 0, LDRColorA(6,6,6,0), LDRColorA(7,7,7,0)},

    {2, 6, 0, 0, 0, 2, 0, LDRColorA(5,5,5,0), LDRColorA(5,5,5,0)},

    {1, 6, 4, 0, 0, 2, 0, LDRColorA(7,7,7,0), LDRColorA(8,8,8,0)},

    {0, 0, 0, 2, 1, 2, 3, LDRColorA(5,5,5,6), LDRColorA(5,5,5,6)},

    {0, 0, 0, 2, 0, 2, 2, LDRColorA(7,7,7,8), LDRColorA(7,7,7,8)},

    {0, 0, 2, 0, 0, 4, 0, LDRColorA(7,7,7,7), LDRColorA(8,8,8,8)},

    {1, 6, 4, 0, 0, 2, 0, LDRColorA(5,5,5,5), LDRColorA(6,6,6,6)}

}

Definition at line 715 of file BC.h.

The documentation for this class was generated from the following files:
  • Direct3D resource loading/C++/texconv/BC.h
  • Direct3D resource loading/C++/texconv/BC6HBC7.cpp
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC7::EncodeParams Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC7
  • DirectX::D3DX_BC7::EncodeParams
Public Member Functions | Public Attributes

DirectX::D3DX_BC7::EncodeParams Struct Reference

List of all members.

Public Member Functions

EncodeParams (const HDRColorA *const aOriginal)

Public Attributes

LDREndPntPair | aEndPts [BC7_MAX_SHAPES][BC7_MAX_REGIONS]
const HDRColorA *const | aHDRPixels
LDRColorA | aLDRPixels [NUM_PIXELS_PER_BLOCK]
uint8_t | uMode

Detailed Description

Definition at line 640 of file BC.h.

Constructor & Destructor Documentation

DirectX::D3DX_BC7::EncodeParams::EncodeParams ( const HDRColorA *const aOriginal ) [inline]

Definition at line 647 of file BC.h.

: aHDRPixels(aOriginal) {}

Member Data Documentation

LDREndPntPair DirectX::D3DX_BC7::EncodeParams::aEndPts[BC7_MAX_SHAPES][BC7_MAX_REGIONS]

Definition at line 643 of file BC.h.

const HDRColorA* const DirectX::D3DX_BC7::EncodeParams::aHDRPixels

Definition at line 645 of file BC.h.

LDRColorA DirectX::D3DX_BC7::EncodeParams::aLDRPixels[NUM_PIXELS_PER_BLOCK]

Definition at line 644 of file BC.h.

uint8_t DirectX::D3DX_BC7::EncodeParams::uMode

Definition at line 642 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::D3DX_BC7::ModeInfo Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::D3DX_BC7
  • DirectX::D3DX_BC7::ModeInfo
Public Attributes

DirectX::D3DX_BC7::ModeInfo Struct Reference

List of all members.

Public Attributes

LDRColorA RGBAPrec
LDRColorA RGBAPrecWithP
uint8_t | uIndexModeBits
uint8_t | uIndexPrec
uint8_t | uIndexPrec2
uint8_t | uPartitionBits
uint8_t | uPartitions
uint8_t | uPBits
uint8_t | uRotationBits

Detailed Description

Definition at line 627 of file BC.h.

Member Data Documentation

LDRColorA DirectX::D3DX_BC7::ModeInfo::RGBAPrec

Definition at line 636 of file BC.h.

LDRColorA DirectX::D3DX_BC7::ModeInfo::RGBAPrecWithP

Definition at line 637 of file BC.h.

uint8_t DirectX::D3DX_BC7::ModeInfo::uIndexModeBits

Definition at line 633 of file BC.h.

uint8_t DirectX::D3DX_BC7::ModeInfo::uIndexPrec

Definition at line 634 of file BC.h.

uint8_t DirectX::D3DX_BC7::ModeInfo::uIndexPrec2

Definition at line 635 of file BC.h.

uint8_t DirectX::D3DX_BC7::ModeInfo::uPartitionBits

Definition at line 630 of file BC.h.

uint8_t DirectX::D3DX_BC7::ModeInfo::uPartitions

Definition at line 629 of file BC.h.

uint8_t DirectX::D3DX_BC7::ModeInfo::uPBits

Definition at line 631 of file BC.h.

uint8_t DirectX::D3DX_BC7::ModeInfo::uRotationBits

Definition at line 632 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::DDS_HEADER Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::DDS_HEADER
Public Attributes

DirectX::DDS_HEADER Struct Reference

#include "DDS.h"

List of all members.

Public Attributes

DDS_PIXELFORMAT ddspf
uint32_t | dwCaps
uint32_t | dwCaps2
uint32_t | dwCaps3
uint32_t | dwCaps4
uint32_t | dwDepth
uint32_t | dwFlags
uint32_t | dwHeight
uint32_t | dwMipMapCount
uint32_t | dwPitchOrLinearSize
uint32_t | dwReserved1 [11]
uint32_t | dwReserved2
uint32_t | dwSize
uint32_t | dwWidth

Detailed Description

Definition at line 183 of file DDS.h.

Member Data Documentation

DDS_PIXELFORMAT DirectX::DDS_HEADER::ddspf

Definition at line 193 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwCaps

Definition at line 194 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwCaps2

Definition at line 195 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwCaps3

Definition at line 196 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwCaps4

Definition at line 197 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwDepth

Definition at line 190 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwFlags

Definition at line 186 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwHeight

Definition at line 187 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwMipMapCount

Definition at line 191 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwPitchOrLinearSize

Definition at line 189 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwReserved1[11]

Definition at line 192 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwReserved2

Definition at line 198 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwSize

Definition at line 185 of file DDS.h.

uint32_t DirectX::DDS_HEADER::dwWidth

Definition at line 188 of file DDS.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DDS.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::DDS_HEADER_DXT10 Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::DDS_HEADER_DXT10
Public Attributes

DirectX::DDS_HEADER_DXT10 Struct Reference

#include "DDS.h"

List of all members.

Public Attributes

uint32_t | arraySize
DXGI_FORMAT | dxgiFormat
uint32_t | miscFlag
uint32_t | reserved
uint32_t | resourceDimension

Detailed Description

Definition at line 201 of file DDS.h.

Member Data Documentation

uint32_t DirectX::DDS_HEADER_DXT10::arraySize

Definition at line 206 of file DDS.h.

DXGI_FORMAT DirectX::DDS_HEADER_DXT10::dxgiFormat

Definition at line 203 of file DDS.h.

uint32_t DirectX::DDS_HEADER_DXT10::miscFlag

Definition at line 205 of file DDS.h.

uint32_t DirectX::DDS_HEADER_DXT10::reserved

Definition at line 207 of file DDS.h.

uint32_t DirectX::DDS_HEADER_DXT10::resourceDimension

Definition at line 204 of file DDS.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DDS.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::DDS_PIXELFORMAT Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::DDS_PIXELFORMAT
Public Attributes

DirectX::DDS_PIXELFORMAT Struct Reference

#include "DDS.h"

List of all members.

Public Attributes

uint32_t | dwABitMask
uint32_t | dwBBitMask
uint32_t | dwFlags
uint32_t | dwFourCC
uint32_t | dwGBitMask
uint32_t | dwRBitMask
uint32_t | dwRGBBitCount
uint32_t | dwSize

Detailed Description

Definition at line 37 of file DDS.h.

Member Data Documentation

uint32_t DirectX::DDS_PIXELFORMAT::dwABitMask

Definition at line 46 of file DDS.h.

uint32_t DirectX::DDS_PIXELFORMAT::dwBBitMask

Definition at line 45 of file DDS.h.

uint32_t DirectX::DDS_PIXELFORMAT::dwFlags

Definition at line 40 of file DDS.h.

uint32_t DirectX::DDS_PIXELFORMAT::dwFourCC

Definition at line 41 of file DDS.h.

uint32_t DirectX::DDS_PIXELFORMAT::dwGBitMask

Definition at line 44 of file DDS.h.

uint32_t DirectX::DDS_PIXELFORMAT::dwRBitMask

Definition at line 43 of file DDS.h.

uint32_t DirectX::DDS_PIXELFORMAT::dwRGBBitCount

Definition at line 42 of file DDS.h.

uint32_t DirectX::DDS_PIXELFORMAT::dwSize

Definition at line 39 of file DDS.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DDS.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::HDRColorA Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::HDRColorA
Public Member Functions | Public Attributes

DirectX::HDRColorA Class Reference

#include "BC.h"

List of all members.

Public Member Functions

HDRColorA ()
HDRColorA (float _r, float _g, float _b, float _a)
HDRColorA (const LDRColorA &c)
HDRColorA (const HDRColorA &c)
HDRColorA & | Clamp (_In_ float fMin, _In_ float fMax)
HDRColorA | operator* (_In_ float f) const
float | operator* (_In_ const HDRColorA &c) const
HDRColorA & | operator*= (_In_ float f)
HDRColorA | operator+ (_In_ const HDRColorA &c) const
HDRColorA & | operator+= (_In_ const HDRColorA &c)
HDRColorA | operator- (_In_ const HDRColorA &c) const
HDRColorA & | operator-= (_In_ const HDRColorA &c)
HDRColorA | operator/ (_In_ float f) const
HDRColorA & | operator/= (_In_ float f)
HDRColorA & | operator= (_In_ const LDRColorA &c)
LDRColorA | ToLDRColorA () const

Public Attributes

float | a
float | b
float | g
float | r

Detailed Description

Definition at line 144 of file BC.h.

Constructor & Destructor Documentation

DirectX::HDRColorA::HDRColorA ( ) [inline]

Definition at line 150 of file BC.h.

{}

DirectX::HDRColorA::HDRColorA | ( | float | _r,
 |  | float | _g,
 |  | float | _b,
 |  | float | _a |
 | ) |  |  | [inline]

Definition at line 151 of file BC.h.

: r(_r), g(_g), b(_b), a(_a) {}

DirectX::HDRColorA::HDRColorA ( const HDRColorA & c ) [inline]

Definition at line 152 of file BC.h.

: r(c.r), g(c.g), b(c.b), a(c.a) {}

DirectX::HDRColorA::HDRColorA ( const LDRColorA & c ) [inline]

Definition at line 153 of file BC.h.

    {
        r = float(c.r) * (1.0f/255.0f);
        g = float(c.g) * (1.0f/255.0f);
        b = float(c.b) * (1.0f/255.0f);
        a = float(c.a) * (1.0f/255.0f);
    }

Member Function Documentation

HDRColorA& DirectX::HDRColorA::Clamp | ( | _In_ float | fMin,
 |  | _In_ float | fMax |
 | ) |  |  | [inline]

Definition at line 235 of file BC.h.

    {
        r = std::min<float>(fMax, std::max<float>(fMin, r));
        g = std::min<float>(fMax, std::max<float>(fMin, g));
        b = std::min<float>(fMax, std::max<float>(fMin, b));
        a = std::min<float>(fMax, std::max<float>(fMin, a));
        return *this;
    }

HDRColorA DirectX::HDRColorA::operator* ( _In_ float f ) const [inline]

Definition at line 172 of file BC.h.

    {
        return HDRColorA(r * f, g * f, b * f, a * f);
    }

float DirectX::HDRColorA::operator* ( _In_ const HDRColorA & c ) const [inline]

Definition at line 183 of file BC.h.

    {
        return r * c.r + g * c.g + b * c.b + a * c.a;
    }

HDRColorA& DirectX::HDRColorA::operator*= ( _In_ float f ) [inline]

Definition at line 207 of file BC.h.

    {
        r *= f;
        g *= f;
        b *= f;
        a *= f;
        return *this;
    }

HDRColorA DirectX::HDRColorA::operator+ ( _In_ const HDRColorA & c ) const [inline]

Definition at line 162 of file BC.h.

    {
        return HDRColorA(r + c.r, g + c.g, b + c.b, a + c.a);
    }

HDRColorA& DirectX::HDRColorA::operator+= ( _In_ const HDRColorA & c ) [inline]

Definition at line 189 of file BC.h.

    {
        r += c.r;
        g += c.g;
        b += c.b;
        a += c.a;
        return *this;
    }

HDRColorA DirectX::HDRColorA::operator- ( _In_ const HDRColorA & c ) const [inline]

Definition at line 167 of file BC.h.

    {
        return HDRColorA(r - c.r, g - c.g, b - c.b, a - c.a);
    }

HDRColorA& DirectX::HDRColorA::operator-= ( _In_ const HDRColorA & c ) [inline]

Definition at line 198 of file BC.h.

    {
        r -= c.r;
        g -= c.g;
        b -= c.b;
        a -= c.a;
        return *this;
    }

HDRColorA DirectX::HDRColorA::operator/ ( _In_ float f ) const [inline]

Definition at line 177 of file BC.h.

    {
        float fInv = 1.0f / f;
        return HDRColorA(r * fInv, g * fInv, b * fInv, a * fInv);
    }

HDRColorA& DirectX::HDRColorA::operator/= ( _In_ float f ) [inline]

Definition at line 216 of file BC.h.

    {
        float fInv = 1.0f / f;
        r *= fInv;
        g *= fInv;
        b *= fInv;
        a *= fInv;
        return *this;
    }

HDRColorA& DirectX::HDRColorA::operator= ( _In_ const LDRColorA & c ) [inline]

Definition at line 226 of file BC.h.

    {
        r = (float) c.r;
        g = (float) c.g;
        b = (float) c.b;
        a = (float) c.a;
        return *this;
    }

LDRColorA DirectX::HDRColorA::ToLDRColorA ( ) const [inline]

Definition at line 244 of file BC.h.

    {
        return LDRColorA((uint8_t) (r + 0.01f), (uint8_t) (g + 0.01f), (uint8_t) (b + 0.01f), (uint8_t) (a + 0.01f));
    }

Member Data Documentation

float DirectX::HDRColorA::a

Definition at line 147 of file BC.h.

float DirectX::HDRColorA::b

Definition at line 147 of file BC.h.

float DirectX::HDRColorA::g

Definition at line 147 of file BC.h.

float DirectX::HDRColorA::r

Definition at line 147 of file BC.h.

The documentation for this class was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::HDREndPntPair Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::HDREndPntPair
Public Attributes

DirectX::HDREndPntPair Struct Reference

#include "BC.h"

List of all members.

Public Attributes

HDRColorA A
HDRColorA B

Detailed Description

Definition at line 268 of file BC.h.

Member Data Documentation

HDRColorA DirectX::HDREndPntPair::A

Definition at line 270 of file BC.h.

HDRColorA DirectX::HDREndPntPair::B

Definition at line 271 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::Image Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::Image
Public Attributes

DirectX::Image Struct Reference

#include "DirectXTex.h"

List of all members.

Public Attributes

DXGI_FORMAT | format
size_t | height
uint8_t * | pixels
size_t | rowPitch
size_t | slicePitch
size_t | width

Detailed Description

Definition at line 165 of file DirectXTex.h.

Member Data Documentation

DXGI_FORMAT DirectX::Image::format

Definition at line 169 of file DirectXTex.h.

size_t DirectX::Image::height

Definition at line 168 of file DirectXTex.h.

uint8_t* DirectX::Image::pixels

Definition at line 172 of file DirectXTex.h.

size_t DirectX::Image::rowPitch

Definition at line 170 of file DirectXTex.h.

size_t DirectX::Image::slicePitch

Definition at line 171 of file DirectXTex.h.

size_t DirectX::Image::width

Definition at line 167 of file DirectXTex.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTex.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::INTColor Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::INTColor
Public Member Functions | Public Attributes | Static Private Member Functions

DirectX::INTColor Class Reference

#include "BC.h"

List of all members.

Public Member Functions

INTColor ()
INTColor (int nr, int ng, int nb)
INTColor (const INTColor &c)
INTColor & | Clamp (_In_ int iMin, _In_ int iMax)
INTColor & | operator&= (_In_ const INTColor &c)
INTColor & | operator+= (_In_ const INTColor &c)
INTColor | operator- (_In_ const INTColor &c) const
INTColor & | operator-= (_In_ const INTColor &c)
int & | operator[] (_In_ uint8_t i)
void | Set (_In_ const HDRColorA &c, _In_ bool bSigned)
INTColor & | SignExtend (_In_ const LDRColorA &Prec)
void | ToF16 (_Out_writes_(3) PackedVector::HALF aF16[3], _In_ bool bSigned) const

Public Attributes

int | b
int | g
int | r

Static Private Member Functions

static int | F16ToINT (_In_ const PackedVector::HALF &f, _In_ bool bSigned)
static PackedVector::HALF | INT2F16 (_In_ int input, _In_ bool bSigned)

Detailed Description

Definition at line 307 of file BC.h.

Constructor & Destructor Documentation

DirectX::INTColor::INTColor ( ) [inline]

Definition at line 313 of file BC.h.

{}

DirectX::INTColor::INTColor | ( | int | nr,
 |  | int | ng,
 |  | int | nb |
 | ) |  |  | [inline]

Definition at line 314 of file BC.h.

{r = nr; g = ng; b = nb;}

DirectX::INTColor::INTColor ( const INTColor & c ) [inline]

Definition at line 315 of file BC.h.

{r = c.r; g = c.g; b = c.b;}

Member Function Documentation

INTColor& DirectX::INTColor::Clamp | ( | _In_ int | iMin,
 |  | _In_ int | iMax |
 | ) |  |  | [inline]

Definition at line 365 of file BC.h.

    {
        r = std::min<int>(iMax, std::max<int>(iMin, r));
        g = std::min<int>(iMax, std::max<int>(iMin, g));
        b = std::min<int>(iMax, std::max<int>(iMin, b));
        return *this;
    }

static int DirectX::INTColor::F16ToINT | ( | _In_ const PackedVector::HALF & | f,
 |  | _In_ bool | bSigned |
 | ) |  |  | [inline, static, private]

Definition at line 389 of file BC.h.

    {
        uint16_t input = *((const uint16_t*) &f);
        int out, s;
        if(bSigned)
        {
            s = input & F16S_MASK;
            input &= F16EM_MASK;
            if(input > F16MAX) out = F16MAX;
            else out = input;
            out = s ? -out : out;
        }
        else
        {
            if(input & F16S_MASK) out = 0;
            else out = input;
        }
        return out;
    }

static PackedVector::HALF DirectX::INTColor::INT2F16 | ( | _In_ int | input,
 |  | _In_ bool | bSigned |
 | ) |  |  | [inline, static, private]

Definition at line 409 of file BC.h.

    {
        PackedVector::HALF h;
        uint16_t out;
        if(bSigned)
        {
            int s = 0;
            if(input < 0)
            {
                s = F16S_MASK;
                input = -input;
            }
            out = uint16_t(s | input);
        }
        else
        {
            assert(input >= 0 && input <= F16MAX);
            out = (uint16_t) input;
        }

        *((uint16_t*) &h) = out;
        return h;
    }

INTColor& DirectX::INTColor::operator&= ( _In_ const INTColor & c ) [inline]

Definition at line 338 of file BC.h.

    {
        r &= c.r;
        g &= c.g;
        b &= c.b;
        return *this;
    }

INTColor& DirectX::INTColor::operator+= ( _In_ const INTColor & c ) [inline]

Definition at line 322 of file BC.h.

    {
        r += c.r;
        g += c.g;
        b += c.b;
        return *this;
    }

INTColor DirectX::INTColor::operator- ( _In_ const INTColor & c ) const [inline]

Definition at line 317 of file BC.h.

    {
        return INTColor(r - c.r, g - c.g, b - c.b);
    }

INTColor& DirectX::INTColor::operator-= ( _In_ const INTColor & c ) [inline]

Definition at line 330 of file BC.h.

    {
        r -= c.r;
        g -= c.g;
        b -= c.b;
        return *this;
    }

int& DirectX::INTColor::operator[] ( _In_ uint8_t i ) [inline]

Definition at line 346 of file BC.h.

    {
        assert(i < sizeof(INTColor) / sizeof(int));
        _Analysis_assume_(i < sizeof(INTColor) / sizeof(int));
        return ((int*) this)[i];
    }

void DirectX::INTColor::Set | ( | _In_ const HDRColorA & | c,
 |  | _In_ bool | bSigned |
 | ) |  |  | [inline]

Definition at line 353 of file BC.h.

    {
        PackedVector::XMHALF4 aF16;

        XMVECTOR v = XMLoadFloat4( (const XMFLOAT4*)& c );
        XMStoreHalf4( &aF16, v );

        r = F16ToINT(aF16.x, bSigned);
        g = F16ToINT(aF16.y, bSigned);
        b = F16ToINT(aF16.z, bSigned);
    }

INTColor& DirectX::INTColor::SignExtend ( _In_ const LDRColorA & Prec ) [inline]

Definition at line 373 of file BC.h.

    {
        r = SIGN_EXTEND(r, Prec.r);
        g = SIGN_EXTEND(g, Prec.g);
        b = SIGN_EXTEND(b, Prec.b);
        return *this;
    }

void DirectX::INTColor::ToF16 | ( | _Out_writes_(3) PackedVector::HALF | aF16[3],
 |  | _In_ bool | bSigned |
 | ) |  |  | const [inline]

Definition at line 381 of file BC.h.

    {
        aF16[0] = INT2F16(r, bSigned);
        aF16[1] = INT2F16(g, bSigned);
        aF16[2] = INT2F16(b, bSigned);
    }

Member Data Documentation

int DirectX::INTColor::b

Definition at line 310 of file BC.h.

int DirectX::INTColor::g

Definition at line 310 of file BC.h.

int DirectX::INTColor::r

Definition at line 310 of file BC.h.

The documentation for this class was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::INTEndPntPair Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::INTEndPntPair
Public Attributes

DirectX::INTEndPntPair Struct Reference

#include "BC.h"

List of all members.

Public Attributes

INTColor A
INTColor B

Detailed Description

Definition at line 434 of file BC.h.

Member Data Documentation

INTColor DirectX::INTEndPntPair::A

Definition at line 436 of file BC.h.

INTColor DirectX::INTEndPntPair::B

Definition at line 437 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::LDRColorA Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::LDRColorA
Public Member Functions | Static Public Member Functions | Public Attributes

DirectX::LDRColorA Class Reference

#include "BC.h"

List of all members.

Public Member Functions

LDRColorA ()
LDRColorA (uint8_t _r, uint8_t _g, uint8_t _b, uint8_t _a)
LDRColorA | operator= (_In_ const HDRColorA &c)
const uint8_t & | operator[] (_In_range_(0, 3) size_t uElement) const
uint8_t & | operator[] (_In_range_(0, 3) size_t uElement)

Static Public Member Functions

static void | Interpolate (_In_ const LDRColorA &c0, _In_ const LDRColorA &c1, _In_ size_t wc, _In_ size_t wa, _In_ _In_range_(2, 4) size_t wcprec, _In_ _In_range_(2, 4) size_t waprec, _Out_ LDRColorA &out)
static void | InterpolateA (_In_ const LDRColorA &c0, _In_ const LDRColorA &c1, _In_ size_t wa, _In_range_(2, 4) _In_ size_t waprec, _Out_ LDRColorA &out)
static void | InterpolateRGB (_In_ const LDRColorA &c0, _In_ const LDRColorA &c1, _In_ size_t wc, _In_ _In_range_(2, 4) size_t wcprec, _Out_ LDRColorA &out)

Public Attributes

uint8_t | a
uint8_t | b
uint8_t | g
uint8_t | r

Detailed Description

Definition at line 75 of file BC.h.

Constructor & Destructor Documentation

DirectX::LDRColorA::LDRColorA ( ) [inline]

Definition at line 80 of file BC.h.

{}

DirectX::LDRColorA::LDRColorA | ( | uint8_t | _r,
 |  | uint8_t | _g,
 |  | uint8_t | _b,
 |  | uint8_t | _a |
 | ) |  |  | [inline]

Definition at line 81 of file BC.h.

: r(_r), g(_g), b(_b), a(_a) {}

Member Function Documentation

static void DirectX::LDRColorA::Interpolate | ( | _In_ const LDRColorA & | c0,
 |  | _In_ const LDRColorA & | c1,
 |  | _In_ size_t | wc,
 |  | _In_ size_t | wa,
 |  | _In_ _In_range_(2, 4) size_t | wcprec,
 |  | _In_ _In_range_(2, 4) size_t | waprec,
 |  | _Out_ LDRColorA & | out |
 | ) |  |  | [inline, static]

Definition at line 137 of file BC.h.

    {
        InterpolateRGB(c0, c1, wc, wcprec, out);
        InterpolateA(c0, c1, wa, waprec, out);
    }

static void DirectX::LDRColorA::InterpolateA | ( | _In_ const LDRColorA & | c0,
 |  | _In_ const LDRColorA & | c1,
 |  | _In_ size_t | wa,
 |  | _In_range_(2, 4) _In_ size_t | waprec,
 |  | _Out_ LDRColorA & | out |
 | ) |  |  | [inline, static]

Definition at line 124 of file BC.h.

    {
        const int* aWeights = nullptr;
        switch(waprec)
        {
        case 2: aWeights = g_aWeights2; assert( wa < 4 ); _Analysis_assume_( wa < 4 ); break;
        case 3: aWeights = g_aWeights3; assert( wa < 8 ); _Analysis_assume_( wa < 8 ); break;
        case 4: aWeights = g_aWeights4; assert( wa < 16 ); _Analysis_assume_( wa < 16 ); break;
        default: assert(false); out.a = 0; return;
        }
        out.a = uint8_t((uint32_t(c0.a) * uint32_t(BC67_WEIGHT_MAX - aWeights[wa]) + uint32_t(c1.a) * uint32_t(aWeights[wa]) + BC67_WEIGHT_ROUND) >> BC67_WEIGHT_SHIFT);
    }

static void DirectX::LDRColorA::InterpolateRGB | ( | _In_ const LDRColorA & | c0,
 |  | _In_ const LDRColorA & | c1,
 |  | _In_ size_t | wc,
 |  | _In_ _In_range_(2, 4) size_t | wcprec,
 |  | _Out_ LDRColorA & | out |
 | ) |  |  | [inline, static]

Definition at line 109 of file BC.h.

    {
        const int* aWeights = nullptr;
        switch(wcprec)
        {
        case 2: aWeights = g_aWeights2; assert( wc < 4 ); _Analysis_assume_( wc < 4 ); break;
        case 3: aWeights = g_aWeights3; assert( wc < 8 ); _Analysis_assume_( wc < 8 ); break;
        case 4: aWeights = g_aWeights4; assert( wc < 16 ); _Analysis_assume_( wc < 16 ); break;
        default: assert(false); out.r = out.g = out.b = 0; return;
        }
        out.r = uint8_t((uint32_t(c0.r) * uint32_t(BC67_WEIGHT_MAX - aWeights[wc]) + uint32_t(c1.r) * uint32_t(aWeights[wc]) + BC67_WEIGHT_ROUND) >> BC67_WEIGHT_SHIFT);
        out.g = uint8_t((uint32_t(c0.g) * uint32_t(BC67_WEIGHT_MAX - aWeights[wc]) + uint32_t(c1.g) * uint32_t(aWeights[wc]) + BC67_WEIGHT_ROUND) >> BC67_WEIGHT_SHIFT);
        out.b = uint8_t((uint32_t(c0.b) * uint32_t(BC67_WEIGHT_MAX - aWeights[wc]) + uint32_t(c1.b) * uint32_t(aWeights[wc]) + BC67_WEIGHT_ROUND) >> BC67_WEIGHT_SHIFT);
    }

LDRColorA DirectX::LDRColorA::operator= ( _In_ const HDRColorA & c ) [inline]

Definition at line 250 of file BC.h.

{
    LDRColorA ret;
    HDRColorA tmp(c);
    tmp = tmp.Clamp(0.0f, 1.0f) * 255.0f;
    ret.r = uint8_t(tmp.r + 0.001f);
    ret.g = uint8_t(tmp.g + 0.001f);
    ret.b = uint8_t(tmp.b + 0.001f);
    ret.a = uint8_t(tmp.a + 0.001f);
    return ret;
}

const uint8_t& DirectX::LDRColorA::operator[] ( _In_range_(0, 3) size_t uElement ) const [inline]

Definition at line 83 of file BC.h.

    {
        switch(uElement)
        {
        case 0: return r;
        case 1: return g;
        case 2: return b;
        case 3: return a;
        default: assert(false); return r;
        }
    }

uint8_t& DirectX::LDRColorA::operator[] ( _In_range_(0, 3) size_t uElement ) [inline]

Definition at line 95 of file BC.h.

    {
        switch(uElement)
        {
        case 0: return r;
        case 1: return g;
        case 2: return b;
        case 3: return a;
        default: assert(false); return r;
        }
    }

Member Data Documentation

uint8_t DirectX::LDRColorA::a

Definition at line 78 of file BC.h.

uint8_t DirectX::LDRColorA::b

Definition at line 78 of file BC.h.

uint8_t DirectX::LDRColorA::g

Definition at line 78 of file BC.h.

uint8_t DirectX::LDRColorA::r

Definition at line 78 of file BC.h.

The documentation for this class was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::LDREndPntPair Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::LDREndPntPair
Public Attributes

DirectX::LDREndPntPair Struct Reference

#include "BC.h"

List of all members.

Public Attributes

LDRColorA A
LDRColorA B

Detailed Description

Definition at line 262 of file BC.h.

Member Data Documentation

LDRColorA DirectX::LDREndPntPair::A

Definition at line 264 of file BC.h.

LDRColorA DirectX::LDREndPntPair::B

Definition at line 265 of file BC.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/BC.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::LegacyDDS Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::LegacyDDS
Public Attributes

DirectX::LegacyDDS Struct Reference

List of all members.

Public Attributes

DWORD | convFlags
DDS_PIXELFORMAT ddpf
DXGI_FORMAT | format

Detailed Description

Definition at line 40 of file DirectXTexDDS.cpp.

Member Data Documentation

DWORD DirectX::LegacyDDS::convFlags

Definition at line 43 of file DirectXTexDDS.cpp.

DDS_PIXELFORMAT DirectX::LegacyDDS::ddpf

Definition at line 44 of file DirectXTexDDS.cpp.

DXGI_FORMAT DirectX::LegacyDDS::format

Definition at line 42 of file DirectXTexDDS.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTexDDS.cpp
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::Rect Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::Rect
Public Member Functions | Public Attributes

DirectX::Rect Struct Reference

#include "DirectXTex.h"

List of all members.

Public Member Functions

Rect ()
Rect (size_t _x, size_t _y, size_t _w, size_t _h)

Public Attributes

size_t | h
size_t | w
size_t | x
size_t | y

Detailed Description

Definition at line 429 of file DirectXTex.h.

Constructor & Destructor Documentation

DirectX::Rect::Rect ( ) [inline]

Definition at line 436 of file DirectXTex.h.

{}

DirectX::Rect::Rect | ( | size_t | _x,
 |  | size_t | _y,
 |  | size_t | _w,
 |  | size_t | _h |
 | ) |  |  | [inline]

Definition at line 437 of file DirectXTex.h.

: x(_x), y(_y), w(_w), h(_h) {}

Member Data Documentation

size_t DirectX::Rect::h

Definition at line 434 of file DirectXTex.h.

size_t DirectX::Rect::w

Definition at line 433 of file DirectXTex.h.

size_t DirectX::Rect::x

Definition at line 431 of file DirectXTex.h.

size_t DirectX::Rect::y

Definition at line 432 of file DirectXTex.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTex.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::ScratchImage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::ScratchImage
Public Member Functions | Private Member Functions | Private Attributes

DirectX::ScratchImage Class Reference

#include "DirectXTex.h"

List of all members.

Public Member Functions

ScratchImage ()
~ScratchImage ()
const Image * | GetImage (_In_ size_t mip, _In_ size_t item, _In_ size_t slice) const
size_t | GetImageCount () const
const Image * | GetImages () const
const TexMetadata & | GetMetadata () const
uint8_t * | GetPixels () const
size_t | GetPixelsSize () const
HRESULT | Initialize (_In_ const TexMetadata &mdata)
HRESULT | Initialize1D (_In_ DXGI_FORMAT fmt, _In_ size_t length, _In_ size_t arraySize, _In_ size_t mipLevels)
HRESULT | Initialize2D (_In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t arraySize, _In_ size_t mipLevels)
HRESULT | Initialize3D (_In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t depth, _In_ size_t mipLevels)
HRESULT | Initialize3DFromImages (_In_reads_(depth) const Image *images, _In_ size_t depth)
HRESULT | InitializeArrayFromImages (_In_reads_(nImages) const Image *images, _In_ size_t nImages, _In_ bool allow1D=false)
HRESULT | InitializeCube (_In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t nCubes, _In_ size_t mipLevels)
HRESULT | InitializeCubeFromImages (_In_reads_(nImages) const Image *images, _In_ size_t nImages)
HRESULT | InitializeFromImage (_In_ const Image &srcImage, _In_ bool allow1D=false)
void | Release ()

Private Member Functions

ScratchImage (const ScratchImage &)
ScratchImage & | operator= (const ScratchImage &)

Private Attributes

Image * _image
uint8_t * | _memory
TexMetadata _metadata
size_t | _nimages
size_t | _size

Detailed Description

Definition at line 175 of file DirectXTex.h.

Constructor & Destructor Documentation

DirectX::ScratchImage::ScratchImage ( ) [inline]

Definition at line 178 of file DirectXTex.h.

: _nimages(0), _size(0), _image(0), _memory(0) {}

DirectX::ScratchImage::~ScratchImage ( ) [inline]

Definition at line 179 of file DirectXTex.h.

{ Release(); }

DirectX::ScratchImage::ScratchImage ( const ScratchImage & ) [private]

Member Function Documentation

const Image* DirectX::ScratchImage::GetImage | ( | _In_ size_t | mip,
 |  | _In_ size_t | item,
 |  | _In_ size_t | slice |
 | ) |  |  | const
size_t DirectX::ScratchImage::GetImageCount ( ) const [inline]

Definition at line 199 of file DirectXTex.h.

{ return _nimages; }

const Image* DirectX::ScratchImage::GetImages ( ) const [inline]

Definition at line 198 of file DirectXTex.h.

{ return _image; }

const TexMetadata& DirectX::ScratchImage::GetMetadata ( ) const [inline]

Definition at line 195 of file DirectXTex.h.

{ return _metadata; }

uint8_t* DirectX::ScratchImage::GetPixels ( ) const [inline]

Definition at line 201 of file DirectXTex.h.

{ return _memory; }

size_t DirectX::ScratchImage::GetPixelsSize ( ) const [inline]

Definition at line 202 of file DirectXTex.h.

{ return _size; }

HRESULT DirectX::ScratchImage::Initialize ( _In_ const TexMetadata & mdata )
HRESULT DirectX::ScratchImage::Initialize1D | ( | _In_ DXGI_FORMAT | fmt,
 |  | _In_ size_t | length,
 |  | _In_ size_t | arraySize,
 |  | _In_ size_t | mipLevels
 | ) |  |
HRESULT DirectX::ScratchImage::Initialize2D | ( | _In_ DXGI_FORMAT | fmt,
 |  | _In_ size_t | width,
 |  | _In_ size_t | height,
 |  | _In_ size_t | arraySize,
 |  | _In_ size_t | mipLevels
 | ) |  |
HRESULT DirectX::ScratchImage::Initialize3D | ( | _In_ DXGI_FORMAT | fmt,
 |  | _In_ size_t | width,
 |  | _In_ size_t | height,
 |  | _In_ size_t | depth,
 |  | _In_ size_t | mipLevels
 | ) |  |
HRESULT DirectX::ScratchImage::Initialize3DFromImages | ( | _In_reads_(depth) const Image * | images,
 |  | _In_ size_t | depth
 | ) |  |
HRESULT DirectX::ScratchImage::InitializeArrayFromImages | ( | _In_reads_(nImages) const Image * | images,
 |  | _In_ size_t | nImages,
 |  | _In_ bool | allow1D = false
 | ) |  |
HRESULT DirectX::ScratchImage::InitializeCube | ( | _In_ DXGI_FORMAT | fmt,
 |  | _In_ size_t | width,
 |  | _In_ size_t | height,
 |  | _In_ size_t | nCubes,
 |  | _In_ size_t | mipLevels
 | ) |  |
HRESULT DirectX::ScratchImage::InitializeCubeFromImages | ( | _In_reads_(nImages) const Image * | images,
 |  | _In_ size_t | nImages
 | ) |  |
HRESULT DirectX::ScratchImage::InitializeFromImage | ( | _In_ const Image & | srcImage,
 |  | _In_ bool | allow1D = false
 | ) |  |
ScratchImage& DirectX::ScratchImage::operator= ( const ScratchImage & ) [private]
void DirectX::ScratchImage::Release ( )

Definition at line 586 of file DirectXTexImage.cpp.

{
    _nimages = 0;
    _size = 0;

    if ( _image )
    {
        delete [] _image;
        _image = 0;
    }

    if ( _memory )
    {
        _aligned_free( _memory );
        _memory = 0;
    }

    memset(&_metadata, 0, sizeof(_metadata));
}

Member Data Documentation

Image* DirectX::ScratchImage::_image [private]

Definition at line 208 of file DirectXTex.h.

uint8_t* DirectX::ScratchImage::_memory [private]

Definition at line 209 of file DirectXTex.h.

TexMetadata DirectX::ScratchImage::_metadata [private]

Definition at line 207 of file DirectXTex.h.

size_t DirectX::ScratchImage::_nimages [private]

Definition at line 205 of file DirectXTex.h.

size_t DirectX::ScratchImage::_size [private]

Definition at line 206 of file DirectXTex.h.

The documentation for this class was generated from the following files:
  • Direct3D resource loading/C++/texconv/DirectXTex.h
  • Direct3D resource loading/C++/texconv/DirectXTexImage.cpp
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX::TexMetadata Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • DirectX
  • DirectX::TexMetadata
Public Member Functions | Public Attributes

DirectX::TexMetadata Struct Reference

#include "DirectXTex.h"

List of all members.

Public Member Functions

size_t | ComputeIndex (_In_ size_t mip, _In_ size_t item, _In_ size_t slice) const

Public Attributes

size_t | arraySize
size_t | depth
TEX_DIMENSION dimension
DXGI_FORMAT | format
size_t | height
size_t | mipLevels
uint32_t | miscFlags
size_t | width

Detailed Description

Definition at line 78 of file DirectXTex.h.

Member Function Documentation

size_t DirectX::TexMetadata::ComputeIndex | ( | _In_ size_t | mip,
 |  | _In_ size_t | item,
 |  | _In_ size_t | slice |
 | ) |  |  | const

Member Data Documentation

size_t DirectX::TexMetadata::arraySize

Definition at line 83 of file DirectXTex.h.

size_t DirectX::TexMetadata::depth

Definition at line 82 of file DirectXTex.h.

TEX_DIMENSION DirectX::TexMetadata::dimension

Definition at line 87 of file DirectXTex.h.

DXGI_FORMAT DirectX::TexMetadata::format

Definition at line 86 of file DirectXTex.h.

size_t DirectX::TexMetadata::height

Definition at line 81 of file DirectXTex.h.

size_t DirectX::TexMetadata::mipLevels

Definition at line 84 of file DirectXTex.h.

uint32_t DirectX::TexMetadata::miscFlags

Definition at line 85 of file DirectXTex.h.

size_t DirectX::TexMetadata::width

Definition at line 80 of file DirectXTex.h.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTex.h
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectXApp Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DirectXApp Class Reference

#include "DirectXApp.h"

List of all members.

Public Member Functions

virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: DirectXApp()

Private Member Functions

void | HideGameInfoOverlay ()
void | HideSnapped ()
void | InitializeGameState ()
void | InitPrintManager ()
void | InitPrintManager ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDeviceLost ()
void | OnDeviceReset ()
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyUp (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyUp (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnManipulationUpdated (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args)
void | OnOrientationChanged (_In_ Platform::Object^sender)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerWheelChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnWindowActivationChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowActivatedEventArgs^args)
void | OnWindowActivationChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowActivatedEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | SetAction (GameInfoOverlayCommand command)
void | SetGameInfoOverlay (GameInfoOverlayState state)
void | SetPrintTask (_In_ Windows::Graphics::Printing::PrintManager^sender, _In_ Windows::Graphics::Printing::PrintTaskRequestedEventArgs^args)
void | SetPrintTask (_In_ Windows::Graphics::Printing::PrintManager^sender, _In_ Windows::Graphics::Printing::PrintTaskRequestedEventArgs^args)
void | SetSnapped ()
void | ShowGameInfoOverlay ()
void | Update ()
void | UpdateViewState ()

Private Attributes

MoveLookController m_controller
Simple3DGame m_game
GameInfoOverlayCommand m_gameInfoOverlayCommand
GameInfoOverlayState m_gameInfoOverlayState
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
bool | m_haveFocus
uint32 | m_loadingCount
PressResultState m_pressResult
Windows::Graphics::Printing::PrintManager | m_printManager
Direct3DTutorial m_renderer
Simple3DTouch m_renderer
BasicSound m_renderer
D3DPostProcessing m_renderer
StreamEffect m_renderer
SimpleController m_renderer
PageRenderer m_renderer
GameRenderer m_renderer
BumpMapping m_renderer
ResourceLoading m_renderer
SimpleSprites m_renderer
DxgiRotation m_renderer
TextInterop m_renderer
AudioController m_renderer
StereoSimpleD3D m_renderer
MarbleMaze m_renderer
OfferReclaimAPI m_renderer
DirectXFractal m_renderer
bool | m_renderNeeded
bool | m_rotationKeyDown
UpdateEngineState m_updateState
UpdateEngineState m_updateStateNext
bool | m_visible
bool | m_windowClosed
bool | m_windowVisible

Detailed Description

Definition at line 12 of file DirectXApp.h.

Member Function Documentation

void DirectXApp::HideGameInfoOverlay ( ) [private]

Definition at line 816 of file DirectXApp.cpp.

{
    m_renderer->InfoOverlay()->HideGameInfoOverlay();
}

void DirectXApp::HideSnapped ( ) [private]

Definition at line 831 of file DirectXApp.cpp.

{
    m_renderer->InfoOverlay()->HideGameInfoOverlay();
    SetGameInfoOverlay(m_gameInfoOverlayState);
}

virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DirectXApp::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void DirectXApp::InitializeGameState ( ) [private]

Definition at line 270 of file DirectXApp.cpp.

{
    // Set up the initial state machine for handling Game playing state
    if (m_game->GameActive() && m_game->LevelActive())
    {
        // The last time the game terminated it was in the middle
        // of a level.
        // We are waiting for the user to continue the game.
        m_updateState = UpdateEngineState::WaitingForResources;
        m_pressResult = PressResultState::ContinueLevel;
        SetGameInfoOverlay(GameInfoOverlayState::Pause);
        SetAction(GameInfoOverlayCommand::PleaseWait);
    }
    else if (!m_game->GameActive() && (m_game->HighScore().totalHits > 0))
    {
        // The last time the game terminated the game had been completed.
        // Show the high score.
        // We are waiting for the user to acknowledge the high score and start a new game.
        // The level resources for the first level will be loaded later.
        m_updateState = UpdateEngineState::WaitingForPress;
        m_pressResult = PressResultState::LoadGame;
        SetGameInfoOverlay(GameInfoOverlayState::GameStats);
        m_controller->WaitForPress(m_renderer->GameInfoOverlayUpperLeft(), m_renderer->GameInfoOverlayLowerRight());
        SetAction(GameInfoOverlayCommand::TapToContinue);
    }
    else
    {
        // This is either the first time the game has run or
        // the last time the game terminated the level was completed.
        // We are waiting for the user to begin the next level.
        m_updateState = UpdateEngineState::WaitingForResources;
        m_pressResult = PressResultState::PlayLevel;
        SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
        SetAction(GameInfoOverlayCommand::PleaseWait);
    }
    ShowGameInfoOverlay();
}

void DirectXApp::InitPrintManager ( ) [private]
void DirectXApp::InitPrintManager ( ) [private]

Definition at line 142 of file DirectXApp.cpp.

{
    // Call static method to get PrintManager object.
    m_printManager = Windows::Graphics::Printing::PrintManager::GetForCurrentView();

    // Start print task event.
    m_printManager->PrintTaskRequested +=
        ref new TypedEventHandler<PrintManager^, PrintTaskRequestedEventArgs^>(this, &DirectXApp::SetPrintTask);
}

virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 64 of file DirectXApp.cpp.

{
}

virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void DirectXApp::Load ( _In_ Platform::String^ entryPoint ) [virtual]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnDeviceLost ( ) [private]

Definition at line 573 of file DirectXApp.cpp.

{
    if (m_updateState == UpdateEngineState::Dynamics)
    {
        // Game is in the active game play state, Stop Game Timer and Pause play and save state
        m_game->PauseGame();
    }
    m_renderNeeded = false;
}

void DirectXApp::OnDeviceReset ( ) [private]

Definition at line 584 of file DirectXApp.cpp.

{

    SetAction(GameInfoOverlayCommand::PleaseWait);
    SetGameInfoOverlay(GameInfoOverlayState::Loading);
    m_updateState = UpdateEngineState::WaitingForResources;
    m_renderNeeded = true;

    create_task([this]()
    {
        return m_renderer->CreateGameDeviceResourcesAsync(m_game);

    }).then([this]()
    {
        // The finalize code needs to run in the same thread context
        // as the m_renderer object was created because the D3D device context
        // can ONLY be accessed on a single thread.
        m_renderer->FinalizeCreateGameDeviceResources();

        // Reset the main state machine based on the current game state now
        // that the device resources have been restored.
        InitializeGameState();

        if (m_updateState == UpdateEngineState::WaitingForResources)
        {
            // In the middle of a game so spin up the async task to load the level.
            return m_game->LoadLevelAsync().then([this]()
            {
                // The m_game object may need to deal with D3D device context work so
                // again the finalize code needs to run in the same thread
                // context as the m_renderer object was created because the D3D
                // device context can ONLY be accessed on a single thread.
                m_game->FinalizeLoadLevel();
                m_game->SetCurrentLevelToSavedState();
                m_updateState = UpdateEngineState::ResourcesLoaded;

            }, task_continuation_context::use_current());
        }
        else
        {
            // The game is not in the middle of a level so there aren't any level
            // resources to load.  Creating a no-op task so that in both cases
            // the same continuation logic is used.
            return create_task([]()
            {
            });
        }

    }, task_continuation_context::use_current()).then([this]()
    {
        // Since Device lost is an unexpected event, the app visual state
        // may be snapped or not have focus.  Put the state machine
        // into the correct state to reflect these cases.
        if (ApplicationView::Value == ApplicationViewState::Snapped)
        {
            m_updateStateNext = m_updateState;
            m_updateState = UpdateEngineState::Snapped;
            m_controller->Active(false);
            HideGameInfoOverlay();
            SetSnapped();
            m_renderNeeded = true;
        }
        else if (!m_haveFocus)
        {
            m_updateStateNext = m_updateState;
            m_updateState = UpdateEngineState::Deactivated;
            m_controller->Active(false);
            SetAction(GameInfoOverlayCommand::None);
            m_renderNeeded = true;
        }
    }, task_continuation_context::use_current());
}

void DirectXApp::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 239 of file DirectXApp.cpp.

{
    m_renderNeeded = true;
}

void DirectXApp::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 213 of file DirectXApp.cpp.

{
    if (args->VirtualKey == VirtualKey::Shift)
    {
        m_rotationKeyDown = true;
    }
}

void DirectXApp::OnKeyUp | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnKeyUp | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 224 of file DirectXApp.cpp.

{
    if (args->VirtualKey == VirtualKey::Shift)
    {
        m_rotationKeyDown = false;
    }
}

void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 115 of file DirectXApp.cpp.

{
    m_renderer->SetDpi(DisplayProperties::LogicalDpi);
}

void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DirectXApp::OnManipulationUpdated | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 235 of file DirectXApp.cpp.

{
    m_renderer->HandleViewManipulation(
        args->Delta.Rotation,
        args->Delta.Scale,
        args->Delta.Translation.X,
        args->Delta.Translation.Y
        );
}

void DirectXApp::OnOrientationChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 127 of file DirectXApp.cpp.

{
    m_renderer->UpdateForWindowSizeChange();
}

void DirectXApp::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 196 of file DirectXApp.cpp.

{
    m_gestureRecognizer->ProcessMoveEvents(args->GetIntermediatePoints());
}

void DirectXApp::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 180 of file DirectXApp.cpp.

{
    m_gestureRecognizer->ProcessDownEvent(args->CurrentPoint);
}

void DirectXApp::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 188 of file DirectXApp.cpp.

{
    m_gestureRecognizer->ProcessUpEvent(args->CurrentPoint);
}

void DirectXApp::OnPointerWheelChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 204 of file DirectXApp.cpp.

{
    // Force mouse wheel movement to be interpreted as zooming or rotating.
    m_gestureRecognizer->ProcessMouseWheelEvent(args->CurrentPoint, m_rotationKeyDown, true);
}

void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 135 of file DirectXApp.cpp.

{
}

void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowActivationChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowActivatedEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 453 of file DirectXApp.cpp.

{
    if (args->WindowActivationState == CoreWindowActivationState::Deactivated)
    {
        m_haveFocus = false;

        switch (m_updateState)
        {
        case UpdateEngineState::Dynamics:
            // From Dynamic mode, when coming out of Deactivated rather than going directly back into game play
            // go to the paused state waiting for user input to continue
            m_updateStateNext = UpdateEngineState::WaitingForPress;
            m_pressResult = PressResultState::ContinueLevel;
            SetGameInfoOverlay(GameInfoOverlayState::Pause);
            ShowGameInfoOverlay();
            m_game->PauseGame();
            m_updateState = UpdateEngineState::Deactivated;
            SetAction(GameInfoOverlayCommand::None);
            m_renderNeeded = true;
            break;

        case UpdateEngineState::WaitingForResources:
        case UpdateEngineState::WaitingForPress:
            m_updateStateNext = m_updateState;
            m_updateState = UpdateEngineState::Deactivated;
            SetAction(GameInfoOverlayCommand::None);
            ShowGameInfoOverlay();
            m_renderNeeded = true;
            break;
        }
        // Don't have focus so shutdown input processing
        m_controller->Active(false);
    }
    else if (args->WindowActivationState == CoreWindowActivationState::CodeActivated
        || args->WindowActivationState == CoreWindowActivationState::PointerActivated)
    {
        m_haveFocus = true;

        if (m_updateState == UpdateEngineState::Deactivated)
        {
            m_updateState = m_updateStateNext;

            if (m_updateState == UpdateEngineState::WaitingForPress)
            {
                SetAction(GameInfoOverlayCommand::TapToContinue);
                m_controller->WaitForPress(m_renderer->GameInfoOverlayUpperLeft(), m_renderer->GameInfoOverlayLowerRight());
            }
            else if (m_updateStateNext == UpdateEngineState::WaitingForResources)
            {
                SetAction(GameInfoOverlayCommand::PleaseWait);
            }
        }
    }
}

void DirectXApp::OnWindowActivationChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 90 of file DirectXApp.cpp.

{
    m_renderer->SetSnappedMode(ApplicationView::Value == ApplicationViewState::Snapped);
    m_renderer->UpdateForWindowSizeChange();
}

void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
void DirectXApp::Run ( ) [virtual]

Definition at line 70 of file DirectXApp.cpp.

{
    while (!m_windowClosed)
    {
        if (m_windowVisible)
        {
            CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(Windows::UI::Core::CoreProcessEventsOption::ProcessAllIfPresent);
            m_renderer->Render();
        }
        else
        {
            CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(Windows::UI::Core::CoreProcessEventsOption::ProcessOneAndAllPending);
        }
    }
}

virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
virtual void DirectXApp::Run ( ) [virtual]
void DirectXApp::SetAction ( GameInfoOverlayCommand command ) [private]

Definition at line 801 of file DirectXApp.cpp.

{
    m_gameInfoOverlayCommand = command;
    m_renderer->InfoOverlay()->SetAction(command);
}

void DirectXApp::SetGameInfoOverlay ( GameInfoOverlayState state ) [private]

Definition at line 747 of file DirectXApp.cpp.

{
    m_gameInfoOverlayState = state;
    switch (state)
    {
    case GameInfoOverlayState::Loading:
        m_renderer->InfoOverlay()->SetGameLoading(m_loadingCount);
        break;

    case GameInfoOverlayState::GameStats:
        m_renderer->InfoOverlay()->SetGameStats(
            m_game->HighScore().levelCompleted + 1,
            m_game->HighScore().totalHits,
            m_game->HighScore().totalShots
            );
        break;

    case GameInfoOverlayState::LevelStart:
        m_renderer->InfoOverlay()->SetLevelStart(
            m_game->LevelCompleted() + 1,
            m_game->CurrentLevel()->Objective(),
            m_game->CurrentLevel()->TimeLimit(),
            m_game->BonusTime()
            );
        break;

    case GameInfoOverlayState::GameOverCompleted:
        m_renderer->InfoOverlay()->SetGameOver(
            true,
            m_game->LevelCompleted() + 1,
            m_game->TotalHits(),
            m_game->TotalShots(),
            m_game->HighScore().totalHits
            );
        break;

    case GameInfoOverlayState::GameOverExpired:
        m_renderer->InfoOverlay()->SetGameOver(
            false,
            m_game->LevelCompleted(),
            m_game->TotalHits(),
            m_game->TotalShots(),
            m_game->HighScore().totalHits
            );
        break;

    case GameInfoOverlayState::Pause:
        m_renderer->InfoOverlay()->SetPause();
        break;
    }
}

void DirectXApp::SetPrintTask | ( | _In_ Windows::Graphics::Printing::PrintManager^ | sender,
 |  | _In_ Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::SetPrintTask | ( | _In_ Windows::Graphics::Printing::PrintManager^ | sender,
 |  | _In_ Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ | args |
 | ) |  |  | [private]
void DirectXApp::SetSnapped ( ) [private]

Definition at line 823 of file DirectXApp.cpp.

{
    m_renderer->InfoOverlay()->SetPause();
    m_renderer->InfoOverlay()->ShowGameInfoOverlay();
}

virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DirectXApp::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void DirectXApp::ShowGameInfoOverlay ( ) [private]

Definition at line 809 of file DirectXApp.cpp.

{
    m_renderer->InfoOverlay()->ShowGameInfoOverlay();
}

virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
void DirectXApp::Uninitialize ( ) [virtual]

Definition at line 86 of file DirectXApp.cpp.

{
}

virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
virtual void DirectXApp::Uninitialize ( ) [virtual]
void DirectXApp::Update ( ) [private]

Definition at line 310 of file DirectXApp.cpp.

{
    static uint32 loadCount = 0;

    m_controller->Update();

    switch (m_updateState)
    {
    case UpdateEngineState::WaitingForResources:
        // Waiting for initial load.  Display an update once per 60 updates.
        loadCount++;
        if ((loadCount % 60) == 0)
        {
            m_loadingCount++;
            SetGameInfoOverlay(m_gameInfoOverlayState);
        }
        break;

    case UpdateEngineState::ResourcesLoaded:
        switch (m_pressResult)
        {
        case PressResultState::LoadGame:
            SetGameInfoOverlay(GameInfoOverlayState::GameStats);
            break;

        case PressResultState::PlayLevel:
            SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
            break;

        case PressResultState::ContinueLevel:
            SetGameInfoOverlay(GameInfoOverlayState::Pause);
            break;
        }
        m_updateState = UpdateEngineState::WaitingForPress;
        SetAction(GameInfoOverlayCommand::TapToContinue);
        m_controller->WaitForPress(m_renderer->GameInfoOverlayUpperLeft(), m_renderer->GameInfoOverlayLowerRight());
        ShowGameInfoOverlay();
        m_renderNeeded = true;
        break;

    case UpdateEngineState::WaitingForPress:
        if (m_controller->IsPressComplete())
        {
            switch (m_pressResult)
            {
            case PressResultState::LoadGame:
                m_updateState = UpdateEngineState::WaitingForResources;
                m_pressResult = PressResultState::PlayLevel;
                m_controller->Active(false);
                m_game->LoadGame();
                SetAction(GameInfoOverlayCommand::PleaseWait);
                SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
                ShowGameInfoOverlay();

                m_game->LoadLevelAsync().then([this]()
                {
                    m_game->FinalizeLoadLevel();
                    m_updateState = UpdateEngineState::ResourcesLoaded;

                }, task_continuation_context::use_current());
                break;

            case PressResultState::PlayLevel:
                m_updateState = UpdateEngineState::Dynamics;
                HideGameInfoOverlay();
                m_controller->Active(true);
                m_game->StartLevel();
                break;

            case PressResultState::ContinueLevel:
                m_updateState = UpdateEngineState::Dynamics;
                HideGameInfoOverlay();
                m_controller->Active(true);
                m_game->ContinueGame();
                break;
            }
        }
        break;

    case UpdateEngineState::Dynamics:
        if (m_controller->IsPauseRequested())
        {
            m_game->PauseGame();
            SetGameInfoOverlay(GameInfoOverlayState::Pause);
            SetAction(GameInfoOverlayCommand::TapToContinue);
            m_updateState = UpdateEngineState::WaitingForPress;
            m_pressResult = PressResultState::ContinueLevel;
            ShowGameInfoOverlay();
        }
        else
        {
            GameState runState = m_game->RunGame();
            switch (runState)
            {
            case GameState::TimeExpired:
                SetAction(GameInfoOverlayCommand::TapToContinue);
                SetGameInfoOverlay(GameInfoOverlayState::GameOverExpired);
                ShowGameInfoOverlay();
                m_updateState = UpdateEngineState::WaitingForPress;
                m_pressResult = PressResultState::LoadGame;
                break;

            case GameState::LevelComplete:
                SetAction(GameInfoOverlayCommand::PleaseWait);
                SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
                ShowGameInfoOverlay();
                m_updateState = UpdateEngineState::WaitingForResources;
                m_pressResult = PressResultState::PlayLevel;

                m_game->LoadLevelAsync().then([this]()
                {
                    m_game->FinalizeLoadLevel();
                    m_updateState = UpdateEngineState::ResourcesLoaded;

                }, task_continuation_context::use_current());
                break;

            case GameState::GameComplete:
                SetAction(GameInfoOverlayCommand::TapToContinue);
                SetGameInfoOverlay(GameInfoOverlayState::GameOverCompleted);
                ShowGameInfoOverlay();
                m_updateState  = UpdateEngineState::WaitingForPress;
                m_pressResult = PressResultState::LoadGame;
                break;
            }
        }

        if (m_updateState == UpdateEngineState::WaitingForPress)
        {
            // Transitioning state, so enable waiting for the press event
            m_controller->WaitForPress(m_renderer->GameInfoOverlayUpperLeft(), m_renderer->GameInfoOverlayLowerRight());
        }
        if (m_updateState == UpdateEngineState::WaitingForResources)
        {
            // Transitioning state, so shut down the input controller until resources are loaded
            m_controller->Active(false);
        }
        break;
    }
}

void DirectXApp::UpdateViewState ( ) [private]

Definition at line 659 of file DirectXApp.cpp.

{
    m_renderNeeded = true;

    if (ApplicationView::Value == ApplicationViewState::Snapped)
    {
        switch (m_updateState)
        {
        case UpdateEngineState::Dynamics:
            // From Dynamic mode, when coming out of SNAPPED layout rather than going directly back into game play
            // go to the paused state waiting for user input to continue
            m_updateStateNext = UpdateEngineState::WaitingForPress;
            m_pressResult = PressResultState::ContinueLevel;
            SetGameInfoOverlay(GameInfoOverlayState::Pause);
            SetAction(GameInfoOverlayCommand::TapToContinue);
            m_game->PauseGame();
            break;

        case UpdateEngineState::WaitingForResources:
        case UpdateEngineState::WaitingForPress:
            // Avoid corrupting the m_updateStateNext on a transition from Snapped -> Snapped.
            // Otherwise just cache the current state and return to it when leaving SNAPPED layout

            m_updateStateNext = m_updateState;
            break;

        default:
            break;
        }

        m_updateState = UpdateEngineState::Snapped;
        m_controller->Active(false);
        HideGameInfoOverlay();
        SetSnapped();
    }
    else if (ApplicationView::Value == ApplicationViewState::Filled ||
        ApplicationView::Value == ApplicationViewState::FullScreenLandscape ||
        ApplicationView::Value == ApplicationViewState::FullScreenPortrait)
    {
        if (m_updateState == UpdateEngineState::Snapped)
        {
            HideSnapped();
            ShowGameInfoOverlay();
            m_renderNeeded = true;

            if (m_haveFocus)
            {
                if (m_updateStateNext == UpdateEngineState::WaitingForPress)
                {
                    SetAction(GameInfoOverlayCommand::TapToContinue);
                }
                else if (m_updateStateNext == UpdateEngineState::WaitingForResources)
                {
                    SetAction(GameInfoOverlayCommand::PleaseWait);
                }

                m_updateState = m_updateStateNext;
            }
            else
            {
                m_updateState = UpdateEngineState::Deactivated;
                SetAction(GameInfoOverlayCommand::None);
            }
        }
        else if (m_updateState == UpdateEngineState::Dynamics)
        {
            // In Dynamic mode, when a resize event happens, go to the paused state waiting for user input to continue.
            m_pressResult = PressResultState::ContinueLevel;
            SetGameInfoOverlay(GameInfoOverlayState::Pause);
            m_game->PauseGame();
            if (m_haveFocus)
            {
                m_updateState = UpdateEngineState::WaitingForPress;
                SetAction(GameInfoOverlayCommand::TapToContinue);
            }
            else
            {
                m_updateState = UpdateEngineState::Deactivated;
                SetAction(GameInfoOverlayCommand::None);
            }
            ShowGameInfoOverlay();
            m_renderNeeded = true;
        }
    }
}

Member Data Documentation

internal DirectXApp::__pad0__

Definition at line 15 of file DirectXApp.h.

MoveLookController DirectXApp::m_controller [private]

Definition at line 150 of file DirectXApp.h.

Simple3DGame DirectXApp::m_game [private]

Definition at line 152 of file DirectXApp.h.

GameInfoOverlayCommand DirectXApp::m_gameInfoOverlayCommand [private]

Definition at line 158 of file DirectXApp.h.

GameInfoOverlayState DirectXApp::m_gameInfoOverlayState [private]

Definition at line 157 of file DirectXApp.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> DirectXApp::m_gestureRecognizer [private]

Definition at line 94 of file DirectXApp.h.

bool DirectXApp::m_haveFocus [private]

Definition at line 147 of file DirectXApp.h.

uint32 DirectXApp::m_loadingCount [private]

Definition at line 159 of file DirectXApp.h.

PressResultState DirectXApp::m_pressResult [private]

Definition at line 156 of file DirectXApp.h.

Windows::Graphics::Printing::PrintManager DirectXApp::m_printManager [private]

Definition at line 67 of file DirectXApp.h.

OfferReclaimAPI DirectXApp::m_renderer [private]

Definition at line 61 of file DirectXApp.h.

BumpMapping DirectXApp::m_renderer [private]

Definition at line 61 of file DirectXApp.h.

SimpleSprites DirectXApp::m_renderer [private]

Definition at line 72 of file DirectXApp.h.

DxgiRotation DirectXApp::m_renderer [private]

Definition at line 55 of file DirectXApp.h.

PageRenderer DirectXApp::m_renderer [private]

Definition at line 66 of file DirectXApp.h.

GameRenderer DirectXApp::m_renderer [private]

Definition at line 151 of file DirectXApp.h.

BasicSound DirectXApp::m_renderer [private]

Definition at line 66 of file DirectXApp.h.

AudioController DirectXApp::m_renderer [private]

Definition at line 61 of file DirectXApp.h.

SimpleController DirectXApp::m_renderer [private]

Definition at line 61 of file DirectXApp.h.

D3DPostProcessing DirectXApp::m_renderer [private]

Definition at line 51 of file DirectXApp.h.

ResourceLoading DirectXApp::m_renderer [private]

Definition at line 61 of file DirectXApp.h.

TextInterop DirectXApp::m_renderer [private]

Definition at line 51 of file DirectXApp.h.

Direct3DTutorial DirectXApp::m_renderer [private]

Definition at line 51 of file DirectXApp.h.

StereoSimpleD3D DirectXApp::m_renderer [private]

Definition at line 67 of file DirectXApp.h.

Simple3DTouch DirectXApp::m_renderer [private]

Definition at line 61 of file DirectXApp.h.

StreamEffect DirectXApp::m_renderer [private]

Definition at line 61 of file DirectXApp.h.

MarbleMaze DirectXApp::m_renderer [private]

Definition at line 91 of file DirectXApp.h.

DirectXFractal DirectXApp::m_renderer [private]

Definition at line 93 of file DirectXApp.h.

bool DirectXApp::m_renderNeeded [private]

Definition at line 146 of file DirectXApp.h.

bool DirectXApp::m_rotationKeyDown [private]

Definition at line 97 of file DirectXApp.h.

UpdateEngineState DirectXApp::m_updateState [private]

Definition at line 154 of file DirectXApp.h.

UpdateEngineState DirectXApp::m_updateStateNext [private]

Definition at line 155 of file DirectXApp.h.

bool DirectXApp::m_visible [private]

Definition at line 148 of file DirectXApp.h.

bool DirectXApp::m_windowClosed [private]

Definition at line 68 of file DirectXApp.h.

bool DirectXApp::m_windowVisible [private]

Definition at line 69 of file DirectXApp.h.

The documentation for this class was generated from the following files:
  • Direct2D printing images and effects/C++/DirectXApp.h
  • Direct2Dapp printing/C++/DirectXApp.h
  • Direct3D bump mapping/C++/DirectXApp.h
  • Direct3D HLSL fractal generator/C++/DirectXApp.h
  • Direct3D post-processing effects/C++/DirectXApp.h
  • Direct3D resource loading/C++/DirectXApp.h
  • Direct3D sprite/C++/DirectXApp.h
  • Direct3D stereoscopic 3D/C++/DirectXApp.h
  • Direct3D tutorial/C++/Lesson5.Components/DirectXApp.h
  • Direct3D-Direct2D interop/C++/DirectXApp.h
  • DirectX 3D shooting game/C++/DirectXApp.h
  • DirectX marble maze game/C++/DirectXApp.h
  • DirectX touch input/C++/DirectXApp.h
  • DXGI offer and reclaim resources/C++/DirectXApp.h
  • DXGI swap chain rotation/C++/DirectXApp.h
  • XAudio2 audio file playback/C++/DirectXApp.h
  • XAudio2 audio stream effect/C++/DirectXApp.h
  • XInput audio controller playback/C++/DirectXApp.h
  • XInput game controller/C++/DirectXApp.h
  • Direct2D printing images and effects/C++/DirectXApp.cpp
  • Direct2Dapp printing/C++/DirectXApp.cpp
  • Direct3D bump mapping/C++/DirectXApp.cpp
  • Direct3D HLSL fractal generator/C++/DirectXApp.cpp
  • Direct3D post-processing effects/C++/DirectXApp.cpp
  • Direct3D resource loading/C++/DirectXApp.cpp
  • Direct3D sprite/C++/DirectXApp.cpp
  • Direct3D stereoscopic 3D/C++/DirectXApp.cpp
  • Direct3D tutorial/C++/Lesson5.Components/DirectXApp.cpp
  • Direct3D-Direct2D interop/C++/DirectXApp.cpp
  • DirectX 3D shooting game/C++/DirectXApp.cpp
  • DirectX marble maze game/C++/DirectXApp.cpp
  • DirectX touch input/C++/DirectXApp.cpp
  • DXGI offer and reclaim resources/C++/DirectXApp.cpp
  • DXGI swap chain rotation/C++/DirectXApp.cpp
  • XAudio2 audio file playback/C++/DirectXApp.cpp
  • XAudio2 audio stream effect/C++/DirectXApp.cpp
  • XInput audio controller playback/C++/DirectXApp.cpp
  • XInput game controller/C++/DirectXApp.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectXAppSource Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

DirectXAppSource Class Reference

#include "D2DTextAnimation.h"

List of all members.

Public Member Functions

virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()

Detailed Description

Definition at line 117 of file D2DTextAnimation.h.

Member Function Documentation

IFrameworkView DirectXAppSource::CreateView ( ) [virtual]

Definition at line 481 of file D2DTextAnimation.cpp.

{
    return ref new D2DTextAnimation();
}

virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView DirectXAppSource::CreateView ( ) [virtual]
The documentation for this class was generated from the following files:
  • Direct2D animated text/C++/D2DTextAnimation.h
  • Direct2D animation/C++/D2DBasicAnimation.h
  • Direct2D basic image effects/C++/D2DEffectsHelloWorld.h
  • Direct2D command list/C++/CommandListSample.h
  • Direct2D composite effect modes/C++/CompositeModes.h
  • Direct2D convolve matrix effect/C++/ConvolveMatrixEffect.h
  • Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.h
  • Direct2D geometry realization/C++/GeometryRealizationSample.h
  • Direct2D interpolation modes/C++/D2DInterpolationModes.h
  • Direct2D perspective transform/C++/D2DPerspectiveTransform.h
  • Direct2D printing images and effects/C++/DirectXApp.h
  • Direct2D save to image file/C++/SaveAsImageFileSample.h
  • Direct2Dapp printing/C++/DirectXApp.h
  • Direct3D bump mapping/C++/DirectXApp.h
  • Direct3D HLSL fractal generator/C++/DirectXApp.h
  • Direct3D post-processing effects/C++/DirectXApp.h
  • Direct3D resource loading/C++/DirectXApp.h
  • Direct3D sprite/C++/DirectXApp.h
  • Direct3D stereoscopic 3D/C++/DirectXApp.h
  • Direct3D tutorial/C++/Lesson5.Components/DirectXApp.h
  • Direct3D-Direct2D interop/C++/DirectXApp.h
  • DirectWrite custom text renderer/C++/DWriteCustomTextRenderer.h
  • DirectWrite hello world/C++/DWriteHelloWorld.h
  • DirectWrite hit testing/C++/DWriteHitTesting.h
  • DirectWrite inline object/C++/DWriteInlineObject.h
  • DirectWrite paragraph text/C++/DWriteParagraphText.h
  • DirectWrite vertical text/C++/DWriteVerticalText.h
  • DirectX 3D shooting game/C++/DirectXApp.h
  • DirectX marble maze game/C++/DirectXApp.h
  • DirectX swap chain implementation/C++/CoreWindowEvents.h
  • DirectX touch input/C++/DirectXApp.h
  • DXGI offer and reclaim resources/C++/DirectXApp.h
  • DXGI swap chain rotation/C++/DirectXApp.h
  • Input Touch hit testing/C++/ShapesPuzzle.h
  • XAudio2 audio file playback/C++/DirectXApp.h
  • XAudio2 audio stream effect/C++/DirectXApp.h
  • XInput audio controller playback/C++/DirectXApp.h
  • XInput game controller/C++/DirectXApp.h
  • Direct2D animated text/C++/D2DTextAnimation.cpp
  • Direct2D animation/C++/D2DBasicAnimation.cpp
  • Direct2D basic image effects/C++/D2DEffectsHelloWorld.cpp
  • Direct2D command list/C++/CommandListSample.cpp
  • Direct2D composite effect modes/C++/CompositeModes.cpp
  • Direct2D convolve matrix effect/C++/ConvolveMatrixEffect.cpp
  • Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.cpp
  • Direct2D geometry realization/C++/GeometryRealizationSample.cpp
  • Direct2D interpolation modes/C++/D2DInterpolationModes.cpp
  • Direct2D perspective transform/C++/D2DPerspectiveTransform.cpp
  • Direct2D printing images and effects/C++/DirectXApp.cpp
  • Direct2D save to image file/C++/SaveAsImageFileSample.cpp
  • Direct2Dapp printing/C++/DirectXApp.cpp
  • Direct3D bump mapping/C++/DirectXApp.cpp
  • Direct3D HLSL fractal generator/C++/DirectXApp.cpp
  • Direct3D post-processing effects/C++/DirectXApp.cpp
  • Direct3D resource loading/C++/DirectXApp.cpp
  • Direct3D sprite/C++/DirectXApp.cpp
  • Direct3D stereoscopic 3D/C++/DirectXApp.cpp
  • Direct3D tutorial/C++/Lesson5.Components/DirectXApp.cpp
  • Direct3D-Direct2D interop/C++/DirectXApp.cpp
  • DirectWrite hello world/C++/DWriteHelloWorld.cpp
  • DirectWrite hit testing/C++/DWriteHitTesting.cpp
  • DirectWrite inline object/C++/DWriteInlineObject.cpp
  • DirectWrite paragraph text/C++/DWriteParagraphText.cpp
  • DirectWrite vertical text/C++/DWriteVerticalText.cpp
  • DirectX 3D shooting game/C++/DirectXApp.cpp
  • DirectX marble maze game/C++/DirectXApp.cpp
  • DirectX swap chain implementation/C++/CoreWindowEvents.cpp
  • DirectX touch input/C++/DirectXApp.cpp
  • DXGI offer and reclaim resources/C++/DirectXApp.cpp
  • DXGI swap chain rotation/C++/DirectXApp.cpp
  • Input Simplified ink/C++/simpleInk.cpp
  • Input Touch hit testing/C++/ShapesPuzzle.cpp
  • XAudio2 audio file playback/C++/DirectXApp.cpp
  • XAudio2 audio stream effect/C++/DirectXApp.cpp
  • XInput audio controller playback/C++/DirectXApp.cpp
  • XInput game controller/C++/DirectXApp.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectXFractal Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DirectXFractal Class Reference

#include "DirectXFractal.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | HandleDeviceLost () override
void | HandleViewManipulation (float dRotation, float dScale, float dX, float dY)
void | LoadInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
virtual void | Render () override
void | SaveInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | Update (float timeTotal, float timeDelta)

Public Attributes

internal | __pad0__: DirectXFractal()

Private Member Functions

void | DetermineFractalTechnique ()
int | RoundUpTo16 (int value)
void | SaveInternalValue (_In_ Windows::Foundation::Collections::IPropertySet^state, _In_ Platform::String^key, _In_ Platform::Object^value)

Private Attributes

int | m_bufferHeight
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_bufferInfoCB
int | m_bufferWidth
bool | m_complete
int | m_completedIterations
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_computeCB
Microsoft::WRL::ComPtr
< ID3D11ComputeShader > 		m_directComputeCS
float | m_downSampleRatio
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_drawRectCB
bool | m_fastGenerate
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_finalPS
Microsoft::WRL::ComPtr
< ID3D11RenderTargetView > 		m_finalRTV
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_finalSRV
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_gradient
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_initialPS
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_linearSampler
AutoThrottle m_movingThrottle
int | m_numIterationsPerFrame
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_pointSampler
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_renderBufferPS
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_renderTexturePS
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_singlePassPS
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_stepPS
FractalTechnique m_technique
Microsoft::WRL::ComPtr
< ID3D11RenderTargetView > 		m_tempRTV [2]
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_tempSRV [2]
Microsoft::WRL::ComPtr
< ID3D11UnorderedAccessView > 		m_tempUAV
ViewTransform m_transform
bool | m_useDoubles
bool | m_useUnormTextures
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 96 of file DirectXFractal.h.

Member Function Documentation

void DirectXFractal::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 39 of file DirectXFractal.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create the performance throttler.

    m_movingThrottle = ref new AutoThrottle(SampleSettings::Performance::TargetFrameTime);
}

void DirectXFractal::CreateDeviceResources ( ) [override, virtual]

Definition at line 100 of file DirectXFractal.cpp.

{
    DirectXBase::CreateDeviceResources();

    DetermineFractalTechnique();

    // Create vertex and index buffers.
    // These are sufficiently general that they can be used with all fractal generation techniques.

    FractalVertex vertices[] =
    {
        { float2(-1.0f,  1.0f), float2(0.0f, 0.0f), float2(-0.5f,  0.5f) },
        { float2( 1.0f,  1.0f), float2(1.0f, 0.0f), float2( 0.5f,  0.5f) },
        { float2(-1.0f, -1.0f), float2(0.0f, 1.0f), float2(-0.5f, -0.5f) },
        { float2( 1.0f, -1.0f), float2(1.0f, 1.0f), float2( 0.5f, -0.5f) },
    };

    D3D11_SUBRESOURCE_DATA vertexBufferData = {0};
    vertexBufferData.pSysMem = vertices;
    vertexBufferData.SysMemPitch = 0;
    vertexBufferData.SysMemSlicePitch = 0;
    CD3D11_BUFFER_DESC vertexBufferDesc(sizeof(vertices), D3D11_BIND_VERTEX_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &vertexBufferDesc,
            &vertexBufferData,
            &m_vertexBuffer
            )
        );

    uint16 indices[] =
    {
        0, 1, 2,
        1, 3, 2,
    };
    m_indexCount = ARRAYSIZE(indices);

    D3D11_SUBRESOURCE_DATA indexBufferData = {0};
    indexBufferData.pSysMem = indices;
    indexBufferData.SysMemPitch = 0;
    indexBufferData.SysMemSlicePitch = 0;
    CD3D11_BUFFER_DESC indexBufferDesc(sizeof(indices), D3D11_BIND_INDEX_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &indexBufferDesc,
            &indexBufferData,
            &m_indexBuffer
            )
        );

    // Load all shaders and textures from the package.

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    D3D11_INPUT_ELEMENT_DESC inputLayoutDesc[] =
    {
        { "POSITION", 0, DXGI_FORMAT_R32G32_FLOAT, 0,  0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
        { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT, 0,  8, D3D11_INPUT_PER_VERTEX_DATA, 0 },
        { "TEXCOORD", 1, DXGI_FORMAT_R32G32_FLOAT, 0, 16, D3D11_INPUT_PER_VERTEX_DATA, 0 },
    };

    loader->LoadShader(
        "DrawRect.vs.cso",
        inputLayoutDesc,
        ARRAYSIZE(inputLayoutDesc),
        &m_vertexShader,
        &m_inputLayout
        );

    loader->LoadTexture(
        "gradient.dds",
        nullptr,
        &m_gradient
        );

    if (m_technique == FractalTechnique::ThreePhase)
    {
        loader->LoadShader(
            m_useUnormTextures ? "Initial.unorm.ps.cso" : "Initial.ps.cso",
            &m_initialPS
            );

        loader->LoadShader(
            m_useUnormTextures ? "Step.unorm.ps.cso" : "Step.ps.cso",
            &m_stepPS
            );

        loader->LoadShader(
            m_useUnormTextures ? "Final.unorm.ps.cso" : "Final.ps.cso",
            &m_finalPS
            );

        loader->LoadShader(
            "RenderTexture.ps.cso",
            &m_renderTexturePS
            );
    }

    if (m_technique == FractalTechnique::SinglePass)
    {
        loader->LoadShader(
            "SinglePass.ps.cso",
            &m_singlePassPS
            );

        loader->LoadShader(
            "RenderTexture.ps.cso",
            &m_renderTexturePS
            );
    }

    if (m_technique == FractalTechnique::DirectCompute)
    {
        loader->LoadShader(
            m_useDoubles ? "DirectCompute.double.cs.cso" : "DirectCompute.cs.cso",
            &m_directComputeCS
            );

        loader->LoadShader(
            "RenderBuffer.ps.cso",
            &m_renderBufferPS
            );
    }

    // Create constant buffers.

    CD3D11_BUFFER_DESC drawRectCBDesc(
        RoundUpTo16(sizeof(DrawRectCB)),
        D3D11_BIND_CONSTANT_BUFFER,
        D3D11_USAGE_DYNAMIC,
        D3D11_CPU_ACCESS_WRITE
        );

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &drawRectCBDesc,
            nullptr,
            &m_drawRectCB
            )
        );

    if (m_technique == FractalTechnique::DirectCompute)
    {
        CD3D11_BUFFER_DESC computeCBDesc(
            RoundUpTo16(
                m_useDoubles ?
                sizeof(ComputeDoubleCB) :
                sizeof(ComputeCB)
                ),
            D3D11_BIND_CONSTANT_BUFFER,
            D3D11_USAGE_DYNAMIC,
            D3D11_CPU_ACCESS_WRITE
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &computeCBDesc,
                nullptr,
                &m_computeCB
                )
            );

        CD3D11_BUFFER_DESC bufferInfoCBDesc(
            RoundUpTo16(sizeof(int)),
            D3D11_BIND_CONSTANT_BUFFER,
            D3D11_USAGE_DYNAMIC,
            D3D11_CPU_ACCESS_WRITE
            );

        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &bufferInfoCBDesc,
                nullptr,
                &m_bufferInfoCB
                )
            );
    }

    // Create texture samplers.

    D3D11_SAMPLER_DESC samplerDesc;
    ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
    samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_CLAMP;
    samplerDesc.MipLODBias = 0.0f;
    samplerDesc.MaxAnisotropy = 0;
    samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDesc.BorderColor[0] = 0.0f;
    samplerDesc.BorderColor[1] = 0.0f;
    samplerDesc.BorderColor[2] = 0.0f;
    samplerDesc.BorderColor[3] = 0.0f;
    samplerDesc.MinLOD = 0;
    samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;

    samplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDesc,
            &m_linearSampler
            )
        );

    if (m_technique != FractalTechnique::DirectCompute)
    {
        samplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_POINT;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateSamplerState(
                &samplerDesc,
                &m_pointSampler
                )
            );
    }

    // Create the Sample Overlay.

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DirectX and DirectCompute fractal generator sample"
        );
}

void DirectXFractal::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 327 of file DirectXFractal.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // Set the initial size of the intermediate render target.
    // This will be automatically refined based on performace measurements.
    m_downSampleRatio = SampleSettings::Performance::InitialDownSampleRatio;

    // Force a regeneration of the fractal.
    m_fastGenerate = true;
    m_complete = false;

    if (m_technique == FractalTechnique::DirectCompute)
    {
        // Create a buffer to save completed fractal calculations.
        m_bufferWidth =
            ((static_cast<int>(m_renderTargetSize.Width) + SampleSettings::DirectCompute::ThreadGroupSizeX - 1) /
            SampleSettings::DirectCompute::ThreadGroupSizeX) *
            SampleSettings::DirectCompute::ThreadGroupSizeX; // round up elements per row to match group dimension
        m_bufferHeight = static_cast<int>(m_renderTargetSize.Height);

        ComPtr<ID3D11Buffer> tempBuffer;
        CD3D11_BUFFER_DESC tempBufferDesc(
            sizeof(FractalBufferElement) * m_bufferWidth * m_bufferHeight,
            D3D11_BIND_SHADER_RESOURCE | D3D11_BIND_UNORDERED_ACCESS,
            D3D11_USAGE_DEFAULT,
            0,
            D3D11_RESOURCE_MISC_BUFFER_STRUCTURED,
            sizeof(FractalBufferElement)
            );
        DX::ThrowIfFailed(
            m_d3dDevice->CreateBuffer(
                &tempBufferDesc,
                nullptr,
                &tempBuffer
                )
            );

        CD3D11_SHADER_RESOURCE_VIEW_DESC tempSRVDesc(
            tempBuffer.Get(),
            DXGI_FORMAT_UNKNOWN,
            0,
            m_bufferWidth * m_bufferHeight
            );
        DX::ThrowIfFailed(
            m_d3dDevice->CreateShaderResourceView(
                tempBuffer.Get(),
                &tempSRVDesc,
                &m_tempSRV[0]
                )
            );

        CD3D11_UNORDERED_ACCESS_VIEW_DESC tempUAVDesc(
            tempBuffer.Get(),
            DXGI_FORMAT_UNKNOWN,
            0,
            m_bufferWidth * m_bufferHeight
            );
        DX::ThrowIfFailed(
            m_d3dDevice->CreateUnorderedAccessView(
                tempBuffer.Get(),
                &tempUAVDesc,
                &m_tempUAV
                )
            );

        // Update the buffer info constant buffer.

        D3D11_MAPPED_SUBRESOURCE mappedResource;
        DX::ThrowIfFailed(
            m_d3dContext->Map(
                m_bufferInfoCB.Get(),
                0,
                D3D11_MAP_WRITE_DISCARD,
                0,
                &mappedResource
                )
            );

        *static_cast<int*>(mappedResource.pData) = m_bufferWidth;

        m_d3dContext->Unmap(
            m_bufferInfoCB.Get(),
            0
            );
    }

    if (m_technique == FractalTechnique::ThreePhase)
    {
        // Create two intermediate textures to save partially completed fractal calculations.
        for (int i = 0; i < 2; i++)
        {
            ComPtr<ID3D11Texture2D> tempTexture;
            CD3D11_TEXTURE2D_DESC tempTextureDesc(
                m_useUnormTextures ?
                    DXGI_FORMAT_R8G8B8A8_UNORM :
                    DXGI_FORMAT_R16G16B16A16_FLOAT,
                static_cast<UINT>(m_renderTargetSize.Width),
                static_cast<UINT>(m_renderTargetSize.Height),
                1,
                1,
                D3D11_BIND_SHADER_RESOURCE | D3D11_BIND_RENDER_TARGET
                );
            DX::ThrowIfFailed(
                m_d3dDevice->CreateTexture2D(
                    &tempTextureDesc,
                    nullptr,
                    &tempTexture
                    )
                );

            CD3D11_RENDER_TARGET_VIEW_DESC tempRTVDesc(
                tempTexture.Get(),
                D3D11_RTV_DIMENSION_TEXTURE2D
                );
            DX::ThrowIfFailed(
                m_d3dDevice->CreateRenderTargetView(
                    tempTexture.Get(),
                    &tempRTVDesc,
                    &m_tempRTV[i]
                    )
                );

            CD3D11_SHADER_RESOURCE_VIEW_DESC tempSRVDesc(
                tempTexture.Get(),
                D3D11_SRV_DIMENSION_TEXTURE2D
                );
            DX::ThrowIfFailed(
                m_d3dDevice->CreateShaderResourceView(
                    tempTexture.Get(),
                    &tempSRVDesc,
                    &m_tempSRV[i]
                    )
                );
        }
    }

    if (m_technique != FractalTechnique::DirectCompute)
    {
        // Create a texture to save the full-resolution fractal once generated.

        CD3D11_TEXTURE2D_DESC tempTextureDesc(
            DXGI_FORMAT_R8G8B8A8_UNORM,
            static_cast<UINT>(m_renderTargetSize.Width),
            static_cast<UINT>(m_renderTargetSize.Height),
            1,
            1,
            D3D11_BIND_SHADER_RESOURCE | D3D11_BIND_RENDER_TARGET
            );
        ComPtr<ID3D11Texture2D> tempTexture;
        DX::ThrowIfFailed(
            m_d3dDevice->CreateTexture2D(
                &tempTextureDesc,
                nullptr,
                &tempTexture
                )
            );

        CD3D11_RENDER_TARGET_VIEW_DESC finalRTVDesc(
            tempTexture.Get(),
            D3D11_RTV_DIMENSION_TEXTURE2D
            );
        DX::ThrowIfFailed(
            m_d3dDevice->CreateRenderTargetView(
                tempTexture.Get(),
                &finalRTVDesc,
                &m_finalRTV
                )
            );

        CD3D11_SHADER_RESOURCE_VIEW_DESC finalSRVDesc(
            tempTexture.Get(),
            D3D11_SRV_DIMENSION_TEXTURE2D
            );
        DX::ThrowIfFailed(
            m_d3dDevice->CreateShaderResourceView(
                tempTexture.Get(),
                &finalSRVDesc,
                &m_finalSRV
                )
            );
    }

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void DirectXFractal::DetermineFractalTechnique ( ) [private]

Definition at line 48 of file DirectXFractal.cpp.

{
    if (m_featureLevel >= D3D_FEATURE_LEVEL_11_0)
    {
        // DirectCompute is always available on 11.0 and higher feature levels.
        m_technique = FractalTechnique::DirectCompute;

        // Additionally, double-precision is optionally available.  Where available,
        // this will enable deeper zoom into the fractal.
        D3D11_FEATURE_DATA_DOUBLES doubleFeatureData;
            DX::ThrowIfFailed(
                m_d3dDevice->CheckFeatureSupport(
                    D3D11_FEATURE_DOUBLES,
                    &doubleFeatureData,
                    sizeof(doubleFeatureData)
                    )
                );
        m_useDoubles = (doubleFeatureData.DoublePrecisionFloatShaderOps == TRUE);
    }
    else if (m_featureLevel >= D3D_FEATURE_LEVEL_10_0)
    {
        // Feature level 10.0 and 10.1 can optionally support DirectCompute.
        D3D11_FEATURE_DATA_D3D10_X_HARDWARE_OPTIONS computeFeatureData;
        DX::ThrowIfFailed(
            m_d3dDevice->CheckFeatureSupport(
                D3D11_FEATURE_D3D10_X_HARDWARE_OPTIONS,
                &computeFeatureData,
                sizeof(computeFeatureData)
                )
            );

        if (computeFeatureData.ComputeShaders_Plus_RawAndStructuredBuffers_Via_Shader_4_x)
        {
            m_technique = FractalTechnique::DirectCompute;
        }
        else
        {
            m_technique = FractalTechnique::SinglePass;
        }
    }
    else
    {
        // The instruction count and register limitations of
        // feature level 9 shaders require multi-pass generation.
        m_technique = FractalTechnique::ThreePhase;

        // Additionally, on feature level 9.1, only a handful of specific
        // texture formats are available for use as render targets.
        m_useUnormTextures = m_featureLevel < D3D_FEATURE_LEVEL_9_3;
    }
}

void DirectXFractal::HandleDeviceLost ( ) [override, virtual]

Definition at line 25 of file DirectXFractal.cpp.

{
    // Release window size-dependent resources prior to creating a new device and swap chain.
    m_tempRTV[0] = nullptr;
    m_tempRTV[1] = nullptr;
    m_tempUAV = nullptr;
    m_tempSRV[0] = nullptr;
    m_tempSRV[1] = nullptr;
    m_finalRTV = nullptr;
    m_finalSRV = nullptr;

    DirectXBase::HandleDeviceLost();
}

void DirectXFractal::HandleViewManipulation | ( | float | dRotation,
 |  | float | dScale,
 |  | float | dX,
 |  | float | dY
 | ) |  |

Definition at line 1106 of file DirectXFractal.cpp.

{
    // Save the old transform values.  If manipulation of the fractal view by the user
    // changes any of these values, then fast fractal generation will be enabled and any
    // existing intermediate surfaces will be invalidated.
    ViewTransform transformOld;
    memcpy(&transformOld, &m_transform, sizeof(transformOld));

    // Translations must be interpreted based on the current scale and rotation of the view.
    float translateX = dX * static_cast<float>(m_transform.scale) / m_windowBounds.Width;
    float translateY = dY * static_cast<float>(m_transform.scale) / m_windowBounds.Width;
    float sinRotation = sinf(static_cast<float>(m_transform.rotation) * PI_F / 180.0f);
    float cosRotation = cosf(static_cast<float>(m_transform.rotation) * PI_F / 180.0f);
    m_transform.translationX -= translateX * cosRotation + translateY * sinRotation;
    m_transform.translationY += translateY * cosRotation - translateX * sinRotation;

    // Scale and rotation changes are independent of the current view.
    m_transform.scale /= dScale;
    m_transform.rotation += dRotation;

    // Ensure rotation values stay near zero to ensure trigonometric function accuracy.
    if (m_transform.rotation < -360.0f) m_transform.rotation += 360.0f;
    if (m_transform.rotation > 360.0f) m_transform.rotation -= 360.0f;

    // Clamp the scale setting.
    double minScale;
    if (m_useDoubles)
    {
        minScale = SampleSettings::Manipulation::MinimumF64Scale;
    }
    else if (m_technique == FractalTechnique::DirectCompute || m_technique == FractalTechnique::SinglePass)
    {
        minScale = SampleSettings::Manipulation::MinimumF32Scale;
    }
    else if (!m_useUnormTextures)
    {
        minScale = SampleSettings::Manipulation::MinimumF16Scale;
    }
    else
    {
        minScale = SampleSettings::Manipulation::MinimumF8Scale;
    }

    m_transform.scale = min(SampleSettings::Manipulation::MaximumScale, max(minScale, m_transform.scale));

    // Clamp translation to a certain radius about the origin of the complex plane.
    float translationMag = sqrtf(
        static_cast<float>(m_transform.translationX) * static_cast<float>(m_transform.translationX) +
        static_cast<float>(m_transform.translationY) * static_cast<float>(m_transform.translationY)
        );
    if (translationMag > SampleSettings::Manipulation::MaximumTranslationMagnitude)
    {
        m_transform.translationX *= SampleSettings::Manipulation::MaximumTranslationMagnitude / translationMag;
        m_transform.translationY *= SampleSettings::Manipulation::MaximumTranslationMagnitude / translationMag;
    }

    // If the transform values have changed, enable fast fractal generation and
    // invalidate existing intermediate surfaces.
    if (memcmp(&m_transform, &transformOld, sizeof(transformOld)) != 0)
    {
        m_fastGenerate = true;
        m_complete = false;
    }
}

void DirectXFractal::LoadInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state )
void DirectXFractal::Render ( ) [override, virtual]

Definition at line 536 of file DirectXFractal.cpp.

{
    // Initialize the fractal target size to equal the screen render target size.
    float2 targetSize = float2(
        m_renderTargetSize.Width,
        m_renderTargetSize.Height
        );

    // If the fractal is being manipulated, scale back the target size in order to reduce
    // frame workload, enabling more responsive manipulation.  If the fractal is not being
    // manipulated, iterate at the full resolution.
    if (m_fastGenerate)
    {
        targetSize.x = floor(targetSize.x / m_downSampleRatio);
        targetSize.y = floor(targetSize.y / m_downSampleRatio);
    }

    // Calculate the fractal boundary transformation matrix.
    double4x4 boundsTransform = identityDouble();
    boundsTransform = mulDouble(boundsTransform, translationDouble(m_transform.translationX, m_transform.translationY, 0.0));
    boundsTransform = mulDouble(boundsTransform, rotationZDouble(m_transform.rotation));
    boundsTransform = mulDouble(boundsTransform, scaleDouble(m_transform.scale, m_transform.scale, 1.0));
    boundsTransform = mulDouble(boundsTransform, scaleDouble(1.0, m_windowBounds.Height / m_windowBounds.Width, 1.0));

    // Update constant buffers.
    D3D11_MAPPED_SUBRESOURCE mappedResource = {0};
    DX::ThrowIfFailed(
        m_d3dContext->Map(
            m_drawRectCB.Get(),
            0,
            D3D11_MAP_WRITE_DISCARD,
            0,
            &mappedResource
            )
        );

    DrawRectCB* drawRectCB = static_cast<DrawRectCB*>(mappedResource.pData);

    drawRectCB->boundsTransform = convert(boundsTransform);

    if (m_technique == FractalTechnique::DirectCompute)
    {
        // When using the DirectCompute generation technique, the buffer is rendered using
        // indexed access, so scaling the pixel shader tex coordinate to matching values
        // makes this task simpler.
        drawRectCB->texScale = targetSize;
    }
    else
    {
        if (m_fastGenerate)
        {
            // If fast generation is used, only a portion of the intermediate texture is drawn.
            drawRectCB->texScale.x = targetSize.x / m_renderTargetSize.Width;
            drawRectCB->texScale.y = targetSize.y / m_renderTargetSize.Height;
        }
        else
        {
            // Otherwise, the entire texture is drawn.
            drawRectCB->texScale = float2(1.0f, 1.0f);
        }
    }

    m_d3dContext->Unmap(
        m_drawRectCB.Get(),
        0
        );

    if (m_technique == FractalTechnique::DirectCompute)
    {
        // Update DirectCompute-specific constant buffers.
        DX::ThrowIfFailed(
            m_d3dContext->Map(
                m_computeCB.Get(),
                0,
                D3D11_MAP_WRITE_DISCARD,
                0,
                &mappedResource
                )
            );

        // This constant buffer provides information on how to map a particular compute thread to
        // a coordinate in the complex plane, and how to map that to an index in the structured buffer.
        double2 topLeftCorner = mulDouble(double2(-0.5, 0.5), boundsTransform);
        double2 deltaAllDtidX = mulDouble(double2(0.5, 0.5), boundsTransform) - topLeftCorner;
        double2 deltaAllDtidY = mulDouble(double2(-0.5, -0.5), boundsTransform) - topLeftCorner;

        if (m_useDoubles)
        {
            ComputeDoubleCB* computeCB = static_cast<ComputeDoubleCB*>(mappedResource.pData);

            computeCB->originDtid00.x = topLeftCorner.x;
            computeCB->originDtid00.y = topLeftCorner.y;
            computeCB->deltaPerDtidX.x = deltaAllDtidX.x / targetSize.x;
            computeCB->deltaPerDtidX.y = deltaAllDtidX.y / targetSize.x;
            computeCB->deltaPerDtidY.x = deltaAllDtidY.x / targetSize.y;
            computeCB->deltaPerDtidY.y = deltaAllDtidY.y / targetSize.y;
        }
        else
        {
            ComputeCB* computeCB = static_cast<ComputeCB*>(mappedResource.pData);

            computeCB->originDtid00.x = static_cast<float>(topLeftCorner.x);
            computeCB->originDtid00.y = static_cast<float>(topLeftCorner.y);
            computeCB->deltaPerDtidX.x = static_cast<float>(deltaAllDtidX.x) / targetSize.x;
            computeCB->deltaPerDtidX.y = static_cast<float>(deltaAllDtidX.y) / targetSize.x;
            computeCB->deltaPerDtidY.x = static_cast<float>(deltaAllDtidY.x) / targetSize.y;
            computeCB->deltaPerDtidY.y = static_cast<float>(deltaAllDtidY.y) / targetSize.y;
        }

        m_d3dContext->Unmap(
            m_computeCB.Get(),
            0
            );
    }

    // Set up pipeline state common to all fractal generation techniques.
    UINT stride = sizeof(FractalVertex);
    UINT offset = 0;
    m_d3dContext->IASetVertexBuffers(
        0,
        1,
        m_vertexBuffer.GetAddressOf(),
        &stride,
        &offset
        );

    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,
        0
        );

    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,
        0
        );

    m_d3dContext->VSSetConstantBuffers(
        0,
        1,
        m_drawRectCB.GetAddressOf()
        );

    // Create null shader binding arrays.  These will be used to unbind resources from pipeline stages.
    ID3D11ShaderResourceView* nullSRV[] = {nullptr, nullptr};
    ID3D11RenderTargetView* nullRTV[] = {nullptr};
    ID3D11UnorderedAccessView* nullUAV[] = {nullptr};

    if (m_technique == FractalTechnique::DirectCompute)
    {
        if (!m_complete)
        {
            // Generate the fractal using the DirectCompute technique.

            m_d3dContext->CSSetShader(
                m_directComputeCS.Get(),
                nullptr,
                0
                );

            ID3D11Buffer* directComputeCBs[] =
            {
                m_bufferInfoCB.Get(),
                m_computeCB.Get()
            };

            m_d3dContext->CSSetConstantBuffers(
                0,
                ARRAYSIZE(directComputeCBs),
                directComputeCBs
                );

            m_d3dContext->CSSetUnorderedAccessViews(
                0,
                1,
                m_tempUAV.GetAddressOf(),
                nullptr
                );

            // Dispatch the minimum number of threads required to assign one thread
            // to each complex coordinate in the fractal we wish to iterate on.
            m_d3dContext->Dispatch(
                (static_cast<int>(targetSize.x) + SampleSettings::DirectCompute::ThreadGroupSizeX - 1) / SampleSettings::DirectCompute::ThreadGroupSizeX,
                (static_cast<int>(targetSize.y) + SampleSettings::DirectCompute::ThreadGroupSizeY - 1) / SampleSettings::DirectCompute::ThreadGroupSizeY,
                1
                );

            m_d3dContext->CSSetUnorderedAccessViews(
                0,
                ARRAYSIZE(nullUAV),
                nullUAV,
                nullptr
                );
        }

        // Draw the intermediate buffer.

        CD3D11_VIEWPORT renderTargetViewport(
            0.0f,
            0.0f,
            m_renderTargetSize.Width,
            m_renderTargetSize.Height
            );

        m_d3dContext->RSSetViewports(
            1,
            &renderTargetViewport
            );

        m_d3dContext->OMSetRenderTargets(
            1,
            m_d3dRenderTargetView.GetAddressOf(),
            nullptr
            );

        m_d3dContext->PSSetShader(
            m_renderBufferPS.Get(),
            nullptr,
            0
            );

        m_d3dContext->PSSetConstantBuffers(
            0,
            1,
            m_bufferInfoCB.GetAddressOf()
            );

        ID3D11ShaderResourceView* renderBufferSRVs[] =
        {
            m_tempSRV[0].Get(),
            m_gradient.Get()
        };
        m_d3dContext->PSSetShaderResources(
            0,
            ARRAYSIZE(renderBufferSRVs),
            renderBufferSRVs
            );

        m_d3dContext->PSSetSamplers(
            0,
            1,
            m_linearSampler.GetAddressOf()
            );

        m_d3dContext->DrawIndexed(
            m_indexCount,
            0,
            0
            );

        m_d3dContext->PSSetShaderResources(
            0,
            ARRAYSIZE(nullSRV),
            nullSRV
            );
    }

    if (m_technique == FractalTechnique::SinglePass)
    {
        if (!m_complete)
        {
            // Generate the fractal using the single-pass technique.

            // Constrain the rasterizer to only draw to a portion of the intermediate texture.

            CD3D11_VIEWPORT targetSizeViewport(
                0.0f,
                0.0f,
                targetSize.x,
                targetSize.y
                );

            m_d3dContext->RSSetViewports(
                1,
                &targetSizeViewport
                );

            m_d3dContext->OMSetRenderTargets(
                1,
                m_finalRTV.GetAddressOf(),
                nullptr
                );

            m_d3dContext->PSSetShader(
                m_singlePassPS.Get(),
                nullptr,
                0
                );

            m_d3dContext->PSSetShaderResources(
                0,
                1,
                m_gradient.GetAddressOf()
                );

            m_d3dContext->PSSetSamplers(
                0,
                1,
                m_linearSampler.GetAddressOf()
                );

            m_d3dContext->DrawIndexed(
                m_indexCount,
                0,
                0
                );
        }

        // Draw the intermediate texture.

        CD3D11_VIEWPORT renderTargetViewport(
            0.0f,
            0.0f,
            m_renderTargetSize.Width,
            m_renderTargetSize.Height
            );

        m_d3dContext->RSSetViewports(
            1,
            &renderTargetViewport
            );

        m_d3dContext->OMSetRenderTargets(
            1,
            m_d3dRenderTargetView.GetAddressOf(),
            nullptr
            );

        m_d3dContext->PSSetShader(
            m_renderTexturePS.Get(),
            nullptr,
            0
            );

        m_d3dContext->PSSetShaderResources(
            0,
            1,
            m_finalSRV.GetAddressOf()
            );

        m_d3dContext->DrawIndexed(
            m_indexCount,
            0,
            0
            );

        m_d3dContext->PSSetShaderResources(
            0,
            ARRAYSIZE(nullSRV),
            nullSRV
            );
    }

    if (m_technique == FractalTechnique::ThreePhase)
    {
        if (!m_complete)
        {
            // Generate the fractal using the three-phase technique.

            // Perform the initial pass, constraining the rasterizer to only draw to a portion of the intermediate texture.
            CD3D11_VIEWPORT targetSizeViewport(
                0.0f,
                0.0f,
                targetSize.x,
                targetSize.y
                );

            m_d3dContext->RSSetViewports(
                1,
                &targetSizeViewport
                );

            m_d3dContext->OMSetRenderTargets(
                1,
                m_tempRTV[0].GetAddressOf(),
                nullptr
                );

            m_d3dContext->PSSetShader(
                m_initialPS.Get(),
                nullptr,
                0
                );

            m_d3dContext->DrawIndexed(
                m_indexCount,
                0,
                0
                );

            // Determine the number of intermediate iteration steps to run, based on the target number
            // of iterations, the number of iterations performed during the initial phase, and the
            // number of iterations to be performed during the final phase.
            int numStepsToRun =
                (SampleSettings::TargetIterations - SampleSettings::ThreePhase::InitialIterations - SampleSettings::ThreePhase::FinalIterations) /
                SampleSettings::ThreePhase::StepIterations;
            for (int i = 0; i < numStepsToRun; i++)
            {
                // Use the previous generation's intermediate data (index 0) and write the output
                // to the next generation's intermediate data (index 1).
                m_d3dContext->OMSetRenderTargets(
                    1,
                    m_tempRTV[1].GetAddressOf(),
                    nullptr
                    );

                m_d3dContext->PSSetShader(
                    m_stepPS.Get(),
                    nullptr,
                    0
                    );

                m_d3dContext->PSSetShaderResources(
                    0,
                    1,
                    m_tempSRV[0].GetAddressOf()
                    );

                m_d3dContext->PSSetSamplers(
                    0,
                    1,
                    m_pointSampler.GetAddressOf()
                    );

                m_d3dContext->DrawIndexed(
                    m_indexCount,
                    0,
                    0
                    );

                m_d3dContext->PSSetShaderResources(
                    0,
                    ARRAYSIZE(nullSRV),
                    nullSRV
                    );

                // Swap the intermediate textures, as the output of the current generation will
                // be the input of the next generation.
                m_tempRTV[0].Swap(m_tempRTV[1]);
                m_tempSRV[0].Swap(m_tempSRV[1]);
            }

            // Perform the final generation step.
            m_d3dContext->OMSetRenderTargets(
                1,
                m_finalRTV.GetAddressOf(),
                nullptr
                );

            m_d3dContext->PSSetShader(
                m_finalPS.Get(),
                nullptr,
                0
                );

            ID3D11ShaderResourceView* finalSRVs[] =
            {
                m_tempSRV[0].Get(),
                m_gradient.Get()
            };
            m_d3dContext->PSSetShaderResources(
                0,
                ARRAYSIZE(finalSRVs),
                finalSRVs
                );

            ID3D11SamplerState* finalSamplers[] =
            {
                m_pointSampler.Get(),
                m_linearSampler.Get()
            };
            m_d3dContext->PSSetSamplers(
                0,
                ARRAYSIZE(finalSamplers),
                finalSamplers
                );

            m_d3dContext->DrawIndexed(
                m_indexCount,
                0,
                0
                );

            m_d3dContext->PSSetShaderResources(
                0,
                ARRAYSIZE(nullSRV),
                nullSRV
                );
        }

        // Draw the intermediate texture.

        CD3D11_VIEWPORT renderTargetViewport(
            0.0f,
            0.0f,
            m_renderTargetSize.Width,
            m_renderTargetSize.Height
            );

        m_d3dContext->RSSetViewports(
            1,
            &renderTargetViewport
            );

        m_d3dContext->OMSetRenderTargets(
            1,
            m_d3dRenderTargetView.GetAddressOf(),
            nullptr
            );

        m_d3dContext->PSSetShader(
            m_renderTexturePS.Get(),
            nullptr,
            0
            );

        m_d3dContext->PSSetShaderResources(
            0,
            1,
            m_finalSRV.GetAddressOf()
            );

        m_d3dContext->PSSetSamplers(
            0,
            1,
            m_linearSampler.GetAddressOf()
            );

        m_d3dContext->DrawIndexed(
            m_indexCount,
            0,
            0
            );

        m_d3dContext->PSSetShaderResources(
            0,
            ARRAYSIZE(nullSRV),
            nullSRV
            );
    }

    if (m_fastGenerate)
    {
        // If the generation just performed was a fast generation, set the next generation
        // to be a full generation.  If manipulation occurs, this flag will be reset to true.
        m_fastGenerate = false;
    }
    else
    {
        // Otherwise, the intermediate surface contains full-resolution fractal data, and should
        // simply be displayed in future frames, as long as it is valid.
        m_complete = true;
    }

    // Render the Sample Overlay.
    m_sampleOverlay->Render();
}

int DirectXFractal::RoundUpTo16 ( int value ) [private]

Definition at line 1099 of file DirectXFractal.cpp.

{
    // This method is useful when defining constant buffers, as
    // their size must be a multiple of 16 bytes.
    return (value + 15) & ~0xF;
}

void DirectXFractal::SaveInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state )
void DirectXFractal::SaveInternalValue | ( | _In_ Windows::Foundation::Collections::IPropertySet^ | state,
 |  | _In_ Platform::String^ | key,
 |  | _In_ Platform::Object^ | value |
 | ) |  |  | [private]
void DirectXFractal::Update | ( | float | timeTotal,
 |  | float | timeDelta
 | ) |  |

Definition at line 513 of file DirectXFractal.cpp.

{
    if (m_fastGenerate)
    {
        // Only update throttle settings if the performance-sensitive code path is being utilized.

        auto control = m_movingThrottle->Update(timeDelta);

        if (control == FrameWorkload::Increase)
        {
            m_downSampleRatio -= SampleSettings::Performance::DownSampleRatioDeltaDecrease;
        }
        if (control == FrameWorkload::Decrease)
        {
            m_downSampleRatio += SampleSettings::Performance::DownSampleRatioDeltaIncrease;
        }
        if (control != FrameWorkload::Maintain)
        {
            m_downSampleRatio = max(1.0f, min(SampleSettings::Performance::DownSampleRatioMax, m_downSampleRatio));
        }
    }
}

Member Data Documentation

internal DirectXFractal::__pad0__

Definition at line 99 of file DirectXFractal.h.

int DirectXFractal::m_bufferHeight [private]

Definition at line 152 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> DirectXFractal::m_bufferInfoCB [private]

Definition at line 135 of file DirectXFractal.h.

int DirectXFractal::m_bufferWidth [private]

Definition at line 151 of file DirectXFractal.h.

bool DirectXFractal::m_complete [private]

Definition at line 147 of file DirectXFractal.h.

int DirectXFractal::m_completedIterations [private]

Definition at line 154 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> DirectXFractal::m_computeCB [private]

Definition at line 134 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11ComputeShader> DirectXFractal::m_directComputeCS [private]

Definition at line 131 of file DirectXFractal.h.

float DirectXFractal::m_downSampleRatio [private]

Definition at line 148 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> DirectXFractal::m_drawRectCB [private]

Definition at line 133 of file DirectXFractal.h.

bool DirectXFractal::m_fastGenerate [private]

Definition at line 146 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> DirectXFractal::m_finalPS [private]

Definition at line 130 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11RenderTargetView> DirectXFractal::m_finalRTV [private]

Definition at line 141 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> DirectXFractal::m_finalSRV [private]

Definition at line 142 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> DirectXFractal::m_gradient [private]

Definition at line 136 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> DirectXFractal::m_indexBuffer [private]

Definition at line 126 of file DirectXFractal.h.

int DirectXFractal::m_indexCount [private]

Definition at line 145 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> DirectXFractal::m_initialPS [private]

Definition at line 128 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> DirectXFractal::m_inputLayout [private]

Definition at line 122 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> DirectXFractal::m_linearSampler [private]

Definition at line 137 of file DirectXFractal.h.

AutoThrottle DirectXFractal::m_movingThrottle [private]

Definition at line 121 of file DirectXFractal.h.

int DirectXFractal::m_numIterationsPerFrame [private]

Definition at line 153 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> DirectXFractal::m_pointSampler [private]

Definition at line 143 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> DirectXFractal::m_renderBufferPS [private]

Definition at line 132 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> DirectXFractal::m_renderTexturePS [private]

Definition at line 124 of file DirectXFractal.h.

SampleOverlay DirectXFractal::m_sampleOverlay [private]

Definition at line 120 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> DirectXFractal::m_singlePassPS [private]

Definition at line 127 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> DirectXFractal::m_stepPS [private]

Definition at line 129 of file DirectXFractal.h.

FractalTechnique DirectXFractal::m_technique [private]

Definition at line 155 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11RenderTargetView> DirectXFractal::m_tempRTV[2] [private]

Definition at line 138 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> DirectXFractal::m_tempSRV[2] [private]

Definition at line 140 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11UnorderedAccessView> DirectXFractal::m_tempUAV [private]

Definition at line 139 of file DirectXFractal.h.

ViewTransform DirectXFractal::m_transform [private]

Definition at line 144 of file DirectXFractal.h.

bool DirectXFractal::m_useDoubles [private]

Definition at line 149 of file DirectXFractal.h.

bool DirectXFractal::m_useUnormTextures [private]

Definition at line 150 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> DirectXFractal::m_vertexBuffer [private]

Definition at line 125 of file DirectXFractal.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> DirectXFractal::m_vertexShader [private]

Definition at line 123 of file DirectXFractal.h.

The documentation for this class was generated from the following files:
  • Direct3D HLSL fractal generator/C++/DirectXFractal.h
  • Direct3D HLSL fractal generator/C++/DirectXFractal.cpp
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Document Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Document Class Reference

#include "Document.h"

List of all members.

Public Member Functions

float | DesignToDisplayHeight (float designHeight)
float | DesignToDisplayWidth (float designWidth)
float | DisplayToDesignHeight (float displayHeight)
float | DisplayToDesignWidth (float displayWidth)
Element GetContentRoot ()
void | GetDWriteFactory (_Outptr_ IDWriteFactory **dwriteFactory)
void | GetFontCollection (_Outptr_result_maybenull_ IDWriteFontCollection **fontCollection)
Windows::Storage::StorageFolder | GetLocation ()
D2D1_SIZE_F | GetPageSize ()
Renderer GetRenderer ()
concurrency::task< void > | LoadAsync ()
void | Parse ()

Public Attributes

internal | __pad0__: Document( _In_ Windows::Storage::StorageFolder^ location
internal _In_ Platform::String | fileName
internal _In_ Platform::String
_In_ Renderer 		renderer

Private Member Functions

~Document ()
Element UpdateDesign ()

Private Attributes

Design m_design
Microsoft::WRL::ComPtr
< IDWriteFactory > 		m_dwriteFactory
Platform::String | m_fileName
Microsoft::WRL::ComPtr
< IDWriteFontCollection > 		m_fontCollection
Microsoft::WRL::ComPtr
< FontLoader > 		m_fontLoader
Windows::Storage::StorageFolder | m_location
Renderer m_renderer
Story m_rootElement
Windows::Data::Xml::Dom::IXmlNode | m_rootXml

Detailed Description

Definition at line 27 of file Document.h.

Constructor & Destructor Documentation

Document::~Document ( ) [private]

Definition at line 50 of file Document.cpp.

{
    if (m_fontLoader != nullptr)
    {
        // Unregister the font loader from DirectWrite factory
        DX::ThrowIfFailed(
            m_dwriteFactory->UnregisterFontCollectionLoader(m_fontLoader.Get())
            );

        DX::ThrowIfFailed(
            m_dwriteFactory->UnregisterFontFileLoader(m_fontLoader.Get())
            );
    }
}

Member Function Documentation

float Document::DesignToDisplayHeight ( float designHeight )

Definition at line 178 of file Document.cpp.

{
    return designHeight / GetPageSize().height * m_renderer->GetDisplayHeight();
}

float Document::DesignToDisplayWidth ( float designWidth )

Definition at line 172 of file Document.cpp.

{
    return designWidth / GetPageSize().width * m_renderer->GetDisplayWidth();
}

float Document::DisplayToDesignHeight ( float displayHeight )

Definition at line 190 of file Document.cpp.

{
    return displayHeight / m_renderer->GetDisplayHeight() * GetPageSize().height;
}

float Document::DisplayToDesignWidth ( float displayWidth )

Definition at line 184 of file Document.cpp.

{
    return displayWidth / m_renderer->GetDisplayWidth() * GetPageSize().width;
}

Element Document::GetContentRoot ( )

Definition at line 152 of file Document.cpp.

{
    // Content root is the direct child of the design element.
    return UpdateDesign()->GetFirstChild();
}

void Document::GetDWriteFactory ( _Outptr_ IDWriteFactory ** dwriteFactory )

Definition at line 124 of file Document.cpp.

{
    *dwriteFactory = ComPtr<IDWriteFactory>(m_dwriteFactory).Detach();
}

void Document::GetFontCollection ( _Outptr_result_maybenull_ IDWriteFontCollection ** fontCollection )

Definition at line 95 of file Document.cpp.

{
    if (m_fontCollection != nullptr)
    {
        *fontCollection = ComPtr<IDWriteFontCollection>(m_fontCollection).Detach();
    }
    else if (m_fontLoader != nullptr)
    {
        // The font collection key is simply set to zero because the loader only
        // represents a single collection of fonts used in this document.
        size_t fontCollectionKey = 0;

        DX::ThrowIfFailed(
            m_dwriteFactory->CreateCustomFontCollection(
                m_fontLoader.Get(),
                &fontCollectionKey,
                sizeof(size_t),
                &m_fontCollection
                )
            );

        *fontCollection = ComPtr<IDWriteFontCollection>(m_fontCollection).Detach();
    }
    else
    {
        *fontCollection = nullptr;
    }
}

Windows::Storage::StorageFolder Document::GetLocation ( ) [inline]

Definition at line 44 of file Document.h.

    {
        return m_location;
    }

D2D1_SIZE_F Document::GetPageSize ( )

Definition at line 166 of file Document.cpp.

{
    return m_design != nullptr ? m_design->GetPageSize() : D2D1::SizeF();
}

Renderer Document::GetRenderer ( ) [inline]

Definition at line 49 of file Document.h.

    {
        return m_renderer;
    }

task< void > Document::LoadAsync ( )

Definition at line 65 of file Document.cpp.

{
    // Get the document file from the storage location
    return task<StorageFile^>(m_location->GetFileAsync(m_fileName)).then([=](StorageFile^ file)
    {
        auto xmlDocument = ref new XmlDocument();
        return xmlDocument->LoadFromFileAsync(file);

    }).then([=](XmlDocument^ loadedXml)
    {
        m_rootXml = loadedXml->SelectSingleNode("story");

        // Create a font loader and start loading all the font files in the document location.
        m_fontLoader = new FontLoader(m_location, m_dwriteFactory.Get());
        return m_fontLoader->LoadAsync();

    }).then([=]()
    {
        // Register the font loader to DirectWrite factory
        // The loaders are needed to load custom fonts used within the document.
        DX::ThrowIfFailed(
            m_dwriteFactory->RegisterFontCollectionLoader(m_fontLoader.Get())
            );

        DX::ThrowIfFailed(
            m_dwriteFactory->RegisterFontFileLoader(m_fontLoader.Get())
            );
    });
}

void Document::Parse ( )

Definition at line 131 of file Document.cpp.

{
    if (m_rootXml != nullptr)
    {
        Story^ rootElement = Element::Create<Story>(this, m_rootXml);

        if (rootElement != nullptr)
        {
            TreeIterator<Element> it(rootElement);
            do
            {
                if (!(it.GetCurrentNode())->BindResource(rootElement))
                    return;

            } while (++it);

            m_rootElement = rootElement;
        }
    }
}

Element Document::UpdateDesign ( ) [private]

Definition at line 158 of file Document.cpp.

{
    // Get the design most appropriate for the current display size.
    m_design = m_rootElement->GetDesign(GetRenderer()->GetDisplaySize());

    return m_design;
}

Member Data Documentation

internal Document::__pad0__

Definition at line 31 of file Document.h.

internal _In_ Platform::String Document::fileName

Definition at line 31 of file Document.h.

Design Document::m_design [private]

Definition at line 84 of file Document.h.

Microsoft::WRL::ComPtr<IDWriteFactory> Document::m_dwriteFactory [private]

Definition at line 90 of file Document.h.

Platform::String Document::m_fileName [private]

Definition at line 75 of file Document.h.

Microsoft::WRL::ComPtr<IDWriteFontCollection> Document::m_fontCollection [private]

Definition at line 96 of file Document.h.

Microsoft::WRL::ComPtr<FontLoader> Document::m_fontLoader [private]

Definition at line 93 of file Document.h.

Windows::Storage::StorageFolder Document::m_location [private]

Definition at line 72 of file Document.h.

Renderer Document::m_renderer [private]

Definition at line 87 of file Document.h.

Story Document::m_rootElement [private]

Definition at line 81 of file Document.h.

Windows::Data::Xml::Dom::IXmlNode Document::m_rootXml [private]

Definition at line 78 of file Document.h.

internal _In_ Platform::String _In_ Renderer Document::renderer

Definition at line 31 of file Document.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/Document.h
  • Direct2D magazine app/C++/Document.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DrawRectCB Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

DrawRectCB Struct Reference

#include "DirectXFractal.h"

List of all members.

Public Attributes

float4x4 boundsTransform
float2 texScale

Detailed Description

Definition at line 70 of file DirectXFractal.h.

Member Data Documentation

float4x4 DrawRectCB::boundsTransform

Definition at line 72 of file DirectXFractal.h.

float2 DrawRectCB::texScale

Definition at line 73 of file DirectXFractal.h.

The documentation for this struct was generated from the following file:
  • Direct3D HLSL fractal generator/C++/DirectXFractal.h
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DWriteCustomTextRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DWriteCustomTextRenderer Class Reference

#include "DWriteCustomTextRenderer.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: DWriteCustomTextRenderer()

Private Member Functions

void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1BitmapBrush > 		m_bitmapBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Microsoft::WRL::ComPtr
< ID2D1Bitmap > 		m_logoBitmap
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
Microsoft::WRL::ComPtr
< CustomTextRenderer > 		m_textRenderer
Microsoft::WRL::ComPtr
< IDWriteTypography > 		m_textTypography
Microsoft::WRL::ComPtr
< IWICBitmapDecoder > 		m_wicBitmapDecoder
Microsoft::WRL::ComPtr
< IWICBitmapFrameDecode > 		m_wicBitmapFrame
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_wicFormatConverter

Detailed Description

Definition at line 14 of file DWriteCustomTextRenderer.h.

Member Function Documentation

virtual void DWriteCustomTextRenderer::CreateDeviceIndependentResources ( ) [override, virtual]
virtual void DWriteCustomTextRenderer::CreateDeviceResources ( ) [override, virtual]
virtual void DWriteCustomTextRenderer::CreateWindowSizeDependentResources ( ) [override, virtual]
virtual void DWriteCustomTextRenderer::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void DWriteCustomTextRenderer::Load ( _In_ Platform::String^ entryPoint ) [virtual]
void DWriteCustomTextRenderer::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteCustomTextRenderer::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]
void DWriteCustomTextRenderer::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void DWriteCustomTextRenderer::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void DWriteCustomTextRenderer::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DWriteCustomTextRenderer::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
virtual void DWriteCustomTextRenderer::Render ( ) [override, virtual]
virtual void DWriteCustomTextRenderer::Run ( ) [virtual]
virtual void DWriteCustomTextRenderer::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void DWriteCustomTextRenderer::Uninitialize ( ) [virtual]

Member Data Documentation

internal DWriteCustomTextRenderer::__pad0__

Definition at line 14 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<ID2D1BitmapBrush> DWriteCustomTextRenderer::m_bitmapBrush [private]

Definition at line 68 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> DWriteCustomTextRenderer::m_blackBrush [private]

Definition at line 60 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap> DWriteCustomTextRenderer::m_logoBitmap [private]

Definition at line 67 of file DWriteCustomTextRenderer.h.

SampleOverlay DWriteCustomTextRenderer::m_sampleOverlay [private]

Definition at line 70 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> DWriteCustomTextRenderer::m_textFormat [private]

Definition at line 61 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> DWriteCustomTextRenderer::m_textLayout [private]

Definition at line 63 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<CustomTextRenderer> DWriteCustomTextRenderer::m_textRenderer [private]

Definition at line 69 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTypography> DWriteCustomTextRenderer::m_textTypography [private]

Definition at line 62 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<IWICBitmapDecoder> DWriteCustomTextRenderer::m_wicBitmapDecoder [private]

Definition at line 64 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<IWICBitmapFrameDecode> DWriteCustomTextRenderer::m_wicBitmapFrame [private]

Definition at line 65 of file DWriteCustomTextRenderer.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> DWriteCustomTextRenderer::m_wicFormatConverter [private]

Definition at line 66 of file DWriteCustomTextRenderer.h.

The documentation for this class was generated from the following file:
  • DirectWrite custom text renderer/C++/DWriteCustomTextRenderer.h
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DWriteHelloWorld Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DWriteHelloWorld Class Reference

#include "DWriteHelloWorld.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: DWriteHelloWorld()

Private Member Functions

void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
Microsoft::WRL::ComPtr
< IDWriteTypography > 		m_textTypography

Detailed Description

Definition at line 13 of file DWriteHelloWorld.h.

Member Function Documentation

void DWriteHelloWorld::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 24 of file DWriteHelloWorld.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create a DirectWrite text format object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Gabriola",
            nullptr,
            DWRITE_FONT_WEIGHT_REGULAR,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            64.0f,
            L"en-US", // locale
            &m_textFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );
}

void DWriteHelloWorld::CreateDeviceResources ( ) [override, virtual]

Definition at line 53 of file DWriteHelloWorld.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DirectWrite Hello World sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );
}

void DWriteHelloWorld::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 75 of file DWriteHelloWorld.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    Platform::String^ text = "Hello World From ... DirectWrite!";

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Create a DirectWrite Text Layout object
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            text->Data(),                       // Text to be displayed
            text->Length(),                     // Length of the text
            m_textFormat.Get(),                 // DirectWrite Text Format object
            size.width,                         // Width of the Text Layout
            size.height,                        // Height of the Text Layout
            &m_textLayout
            )
        );

    // Text range for the "DirectWrite!" at the end of the string
    DWRITE_TEXT_RANGE textRange = {21, 12}; // 21 references the "D" in DirectWrite! and 12 is the number of characters in the word

    // Set the font size on that text range to 100
    DX::ThrowIfFailed(
        m_textLayout->SetFontSize(100.0f, textRange)
        );

    // Create a DirectWrite Typography object
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTypography(
            &m_textTypography
            )
        );

    // Enumerate a stylistic set 6 font feature for application to our text layout
    DWRITE_FONT_FEATURE fontFeature = {DWRITE_FONT_FEATURE_TAG_STYLISTIC_SET_6, 1};

    // Apply the previously enumerated font feature to our Text Typography object
    DX::ThrowIfFailed(
        m_textTypography->AddFontFeature(fontFeature)
        );

    // Move our text range to the entire length of the string
    textRange.length = text->Length();
    textRange.startPosition = 0;

    // Apply our recently defined typography to our entire text range
    DX::ThrowIfFailed(
        m_textLayout->SetTypography(
            m_textTypography.Get(),
            textRange
            )
        );

    // Move the text range to the end again
    textRange.length = 12;
    textRange.startPosition = 21;

    // Set the underline on the text range
    DX::ThrowIfFailed(
        m_textLayout->SetUnderline(TRUE, textRange)
        );

    // Set the font weight on the text range
    DX::ThrowIfFailed(
        m_textLayout->SetFontWeight(DWRITE_FONT_WEIGHT_BOLD, textRange)
        );
}

virtual void DWriteHelloWorld::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void DWriteHelloWorld::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 201 of file DWriteHelloWorld.cpp.

{
}

void DWriteHelloWorld::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteHelloWorld::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 239 of file DWriteHelloWorld.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void DWriteHelloWorld::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 230 of file DWriteHelloWorld.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void DWriteHelloWorld::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 265 of file DWriteHelloWorld.cpp.

{
}

void DWriteHelloWorld::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DWriteHelloWorld::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteHelloWorld::Render ( ) [override, virtual]

Definition at line 145 of file DWriteHelloWorld.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    m_d2dContext->DrawTextLayout(
        D2D1::Point2F(0.0f, 0.0f),
        m_textLayout.Get(),
        m_blackBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void DWriteHelloWorld::Run ( ) [virtual]

Definition at line 207 of file DWriteHelloWorld.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void DWriteHelloWorld::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void DWriteHelloWorld::Uninitialize ( ) [virtual]

Definition at line 215 of file DWriteHelloWorld.cpp.

{
}

Member Data Documentation

internal DWriteHelloWorld::__pad0__

Definition at line 16 of file DWriteHelloWorld.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> DWriteHelloWorld::m_blackBrush [private]

Definition at line 62 of file DWriteHelloWorld.h.

SampleOverlay DWriteHelloWorld::m_sampleOverlay [private]

Definition at line 66 of file DWriteHelloWorld.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> DWriteHelloWorld::m_textFormat [private]

Definition at line 63 of file DWriteHelloWorld.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> DWriteHelloWorld::m_textLayout [private]

Definition at line 65 of file DWriteHelloWorld.h.

Microsoft::WRL::ComPtr<IDWriteTypography> DWriteHelloWorld::m_textTypography [private]

Definition at line 64 of file DWriteHelloWorld.h.

The documentation for this class was generated from the following files:
  • DirectWrite hello world/C++/DWriteHelloWorld.h
  • DirectWrite hello world/C++/DWriteHelloWorld.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DWriteHitTesting Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DWriteHitTesting Class Reference

#include "DWriteHitTesting.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: DWriteHitTesting()

Private Member Functions

void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | SetUnderlineOnRedraw ()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
SampleOverlay m_sampleOverlay
Platform::String | m_text
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
Microsoft::WRL::ComPtr
< IDWriteTypography > 		m_textTypography
Platform::Array< bool > | m_underlineArray

Detailed Description

Definition at line 13 of file DWriteHitTesting.h.

Member Function Documentation

void DWriteHitTesting::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 27 of file DWriteHitTesting.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    m_text = "Touch Me To Change My Underline!";

    // Create a DirectWrite text format object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            64.0f,
            L"en-US", // locale
            &m_textFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    // Boolean array to keep track of which characters are underlined
    m_underlineArray = ref new Platform::Array<bool>(m_text->Length());

    // Initialize the array to all false in order to represent the initial un-underlined text
    for (unsigned int i = 0; i < m_text->Length(); i++)
    {
        m_underlineArray[i] = false;
    }
}

void DWriteHitTesting::CreateDeviceResources ( ) [override, virtual]

Definition at line 67 of file DWriteHitTesting.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DirectWrite hit testing sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );
}

void DWriteHitTesting::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 89 of file DWriteHitTesting.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Create a DirectWrite Text Layout object
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            m_text->Data(),                     // Text to be displayed
            m_text->Length(),                   // Length of the text
            m_textFormat.Get(),                 // DirectWrite Text Format object
            size.width,                         // Width of the Text Layout
            size.height,                        // Height of the Text Layout
            &m_textLayout
            )
        );

    SetUnderlineOnRedraw();
}

virtual void DWriteHitTesting::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void DWriteHitTesting::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 169 of file DWriteHitTesting.cpp.

{
    // Retrieve any stored variables from the LocalSettings collection.
    IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;

    if (settingsValues->HasKey("m_underlineArray"))
    {
        safe_cast<IPropertyValue^>(settingsValues->Lookup("m_underlineArray"))->GetBooleanArray(&m_underlineArray);
        SetUnderlineOnRedraw();
    }
}

void DWriteHitTesting::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteHitTesting::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 272 of file DWriteHitTesting.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void DWriteHitTesting::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 263 of file DWriteHitTesting.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void DWriteHitTesting::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DWriteHitTesting::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 305 of file DWriteHitTesting.cpp.

{
}

void DWriteHitTesting::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DWriteHitTesting::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteHitTesting::Render ( ) [override, virtual]

Definition at line 110 of file DWriteHitTesting.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    m_d2dContext->DrawTextLayout(
        D2D1::Point2F(0.0f, 0.0f),
        m_textLayout.Get(),
        m_blackBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void DWriteHitTesting::Run ( ) [virtual]

Definition at line 183 of file DWriteHitTesting.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

void DWriteHitTesting::SetUnderlineOnRedraw ( ) [private]

Definition at line 252 of file DWriteHitTesting.cpp.

{
    for (unsigned int i = 0; i < m_text->Length(); i++)
    {
        DWRITE_TEXT_RANGE textRange = {i, 1};
        DX::ThrowIfFailed(
            m_textLayout->SetUnderline(m_underlineArray[i], textRange)
            );
    }
}

virtual void DWriteHitTesting::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void DWriteHitTesting::Uninitialize ( ) [virtual]

Definition at line 191 of file DWriteHitTesting.cpp.

{
}

Member Data Documentation

internal DWriteHitTesting::__pad0__

Definition at line 16 of file DWriteHitTesting.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> DWriteHitTesting::m_blackBrush [private]

Definition at line 69 of file DWriteHitTesting.h.

SampleOverlay DWriteHitTesting::m_sampleOverlay [private]

Definition at line 73 of file DWriteHitTesting.h.

Platform::String DWriteHitTesting::m_text [private]

Definition at line 75 of file DWriteHitTesting.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> DWriteHitTesting::m_textFormat [private]

Definition at line 70 of file DWriteHitTesting.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> DWriteHitTesting::m_textLayout [private]

Definition at line 72 of file DWriteHitTesting.h.

Microsoft::WRL::ComPtr<IDWriteTypography> DWriteHitTesting::m_textTypography [private]

Definition at line 71 of file DWriteHitTesting.h.

Platform::Array<bool> DWriteHitTesting::m_underlineArray [private]

Definition at line 74 of file DWriteHitTesting.h.

The documentation for this class was generated from the following files:
  • DirectWrite hit testing/C++/DWriteHitTesting.h
  • DirectWrite hit testing/C++/DWriteHitTesting.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DWriteInlineObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DWriteInlineObject Class Reference

#include "DWriteInlineObject.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | HandleDeviceLost () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: DWriteInlineObject()

Private Member Functions

void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Microsoft::WRL::ComPtr
< IDWriteInlineObject > 		m_inlineImage
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
Microsoft::WRL::ComPtr
< IDWriteTypography > 		m_textTypography

Detailed Description

Definition at line 14 of file DWriteInlineObject.h.

Member Function Documentation

void DWriteInlineObject::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 33 of file DWriteInlineObject.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create a DirectWrite text format object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            64.0f,
            L"en-US", // locale
            &m_textFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );
}

void DWriteInlineObject::CreateDeviceResources ( ) [override, virtual]

Definition at line 62 of file DWriteInlineObject.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DirectWrite inline object sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );
}

void DWriteInlineObject::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 84 of file DWriteInlineObject.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    Platform::String^ text = "Inline object * sample";

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Create a DirectWrite Text Layout object
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            text->Data(),                       // Text to be displayed
            text->Length(),                     // Length of the text
            m_textFormat.Get(),                 // DirectWrite Text Format object
            size.width,                         // Width of the Text Layout
            size.height,                        // Height of the Text Layout
            &m_textLayout
            )
        );

    m_inlineImage = new InlineImage(m_d2dContext.Get(), m_wicFactory.Get(), L"img1.jpg");

    DWRITE_TEXT_RANGE textRange = {14, 1};

    DX::ThrowIfFailed(
        m_textLayout->SetInlineObject(m_inlineImage.Get(), textRange)
        );
}

void DWriteInlineObject::HandleDeviceLost ( ) [override, virtual]

Definition at line 24 of file DWriteInlineObject.cpp.

{
    // Release window size-dependent resources prior to creating a new device and swap chain.
    m_inlineImage = nullptr;
    m_textLayout = nullptr;

    DirectXBase::HandleDeviceLost();
}

virtual void DWriteInlineObject::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void DWriteInlineObject::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 169 of file DWriteInlineObject.cpp.

{
}

void DWriteInlineObject::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteInlineObject::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 207 of file DWriteInlineObject.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void DWriteInlineObject::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 198 of file DWriteInlineObject.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void DWriteInlineObject::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 233 of file DWriteInlineObject.cpp.

{
}

void DWriteInlineObject::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DWriteInlineObject::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteInlineObject::Render ( ) [override, virtual]

Definition at line 113 of file DWriteInlineObject.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    m_d2dContext->DrawTextLayout(
        D2D1::Point2F(0.0f, 0.0f),
        m_textLayout.Get(),
        m_blackBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void DWriteInlineObject::Run ( ) [virtual]

Definition at line 175 of file DWriteInlineObject.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void DWriteInlineObject::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void DWriteInlineObject::Uninitialize ( ) [virtual]

Definition at line 183 of file DWriteInlineObject.cpp.

{
}

Member Data Documentation

internal DWriteInlineObject::__pad0__

Definition at line 17 of file DWriteInlineObject.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> DWriteInlineObject::m_blackBrush [private]

Definition at line 64 of file DWriteInlineObject.h.

Microsoft::WRL::ComPtr<IDWriteInlineObject> DWriteInlineObject::m_inlineImage [private]

Definition at line 68 of file DWriteInlineObject.h.

SampleOverlay DWriteInlineObject::m_sampleOverlay [private]

Definition at line 69 of file DWriteInlineObject.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> DWriteInlineObject::m_textFormat [private]

Definition at line 65 of file DWriteInlineObject.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> DWriteInlineObject::m_textLayout [private]

Definition at line 67 of file DWriteInlineObject.h.

Microsoft::WRL::ComPtr<IDWriteTypography> DWriteInlineObject::m_textTypography [private]

Definition at line 66 of file DWriteInlineObject.h.

The documentation for this class was generated from the following files:
  • DirectWrite inline object/C++/DWriteInlineObject.h
  • DirectWrite inline object/C++/DWriteInlineObject.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DWriteParagraphText Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DWriteParagraphText Class Reference

#include "DWriteParagraphText.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: DWriteParagraphText()

Private Member Functions

void | ApplyJustificationSettings ()
void | ApplySpacingSettings ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnHolding (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::HoldingEventArgs^args)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | ShowMenu (Windows::Foundation::Point position)
void | UpdateCharacterSpacing (Windows::UI::Popups::IUICommand^command)
void | UpdateJustification (Windows::UI::Popups::IUICommand^command)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
bool | m_isIncreasedSpacing
bool | m_isJustified
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IDWriteTextLayout1 > 		m_textLayout1
DWRITE_TEXT_RANGE | m_textRange
Microsoft::WRL::ComPtr
< IDWriteTypography > 		m_textTypography

Detailed Description

Definition at line 13 of file DWriteParagraphText.h.

Member Function Documentation

void DWriteParagraphText::ApplyJustificationSettings ( ) [private]

Definition at line 405 of file DWriteParagraphText.cpp.

{
    if (!m_isJustified)
    {
        m_textLayout1->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER);
    }
    else
    {
        m_textLayout1->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_JUSTIFIED);
    }
}

void DWriteParagraphText::ApplySpacingSettings ( ) [private]

Definition at line 417 of file DWriteParagraphText.cpp.

{
    if (!m_isIncreasedSpacing)
    {
        m_textLayout1->SetCharacterSpacing(0.5f, 0.5f, 0, m_textRange);
    }
    else
    {
        m_textLayout1->SetCharacterSpacing(2, 2, 0, m_textRange);
    }
}

void DWriteParagraphText::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 29 of file DWriteParagraphText.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create a DirectWrite text format object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_REGULAR,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            64.0f,
            L"en-US", // locale
            &m_textFormat
            )
        );

    // Create two booleans to store the state of the layout.
    m_isJustified = false;
    m_isIncreasedSpacing = false;

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );
}

void DWriteParagraphText::CreateDeviceResources ( ) [override, virtual]

Definition at line 62 of file DWriteParagraphText.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DirectWrite paragraph text sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );
}

void DWriteParagraphText::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 84 of file DWriteParagraphText.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    Platform::String^ text = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc convallis, \
dui vel luctus posuere, mauris metus sodales justo, sit amet tincidunt velit \
ipsum placerat augue. Integer consequat pellentesque orci, id pharetra dolor \
lacinia quis. Donec leo neque, tempor ac imperdiet in, adipiscing vel nibh. \
Curabitur sed est nibh. Etiam tincidunt sagittis tortor sed luctus. Nam purus \
turpis, mattis nec malesuada vel, molestie ut velit. Etiam semper rutrum vestibulum.\
Proin eget mi nunc. Vivamus lobortis iaculis risus at dapibus. In libero ipsum, feugiat \
quis convallis ut, rutrum eget quam. ";

    D2D1_SIZE_F size = m_d2dContext->GetSize();
    size.height = size.height / 3;
    size.width = size.width / 3;

    ComPtr<IDWriteTextLayout> textLayout;

    // Create a DirectWrite text layout object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            text->Data(),                       // Text to be displayed
            text->Length(),                     // Length of the text
            m_textFormat.Get(),                 // DirectWrite Text Format object
            size.width,                         // Width of the Text Layout
            size.height,                        // Height of the Text Layout
            &textLayout
            )
        );

    // QI the IDWriteTextLayout into a IDWriteTextLayout1.
    textLayout.As(&m_textLayout1);

    m_textRange.startPosition = 0;
    m_textRange.length = text->Length();
    m_textLayout1->SetFontSize(16, m_textRange);
    m_textLayout1->SetCharacterSpacing(0.5f, 0.5f, 0, m_textRange);
}

virtual void DWriteParagraphText::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void DWriteParagraphText::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 254 of file DWriteParagraphText.cpp.

{
    // Retrieve any stored variables from the LocalSettings collection.
    IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;

    if (settingsValues->HasKey("m_isJustified"))
    {
        m_isJustified = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_isJustified"))->GetBoolean();
        ApplyJustificationSettings();
    }
    if (settingsValues->HasKey("m_isIncreasedSpacing"))
    {
        m_isIncreasedSpacing = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_isIncreasedSpacing"))->GetBoolean();
        ApplySpacingSettings();
    }
}

void DWriteParagraphText::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteParagraphText::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 307 of file DWriteParagraphText.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    ApplyJustificationSettings();
    ApplySpacingSettings();
    Render();
    Present();
}

void DWriteParagraphText::OnHolding | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::HoldingEventArgs^ | args |
 | ) |  |  | [private]
void DWriteParagraphText::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 298 of file DWriteParagraphText.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void DWriteParagraphText::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DWriteParagraphText::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DWriteParagraphText::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void DWriteParagraphText::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 348 of file DWriteParagraphText.cpp.

{
}

void DWriteParagraphText::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void DWriteParagraphText::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteParagraphText::Render ( ) [override, virtual]

Definition at line 124 of file DWriteParagraphText.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    D2D1_SIZE_F screenSize = m_d2dContext->GetSize();

    D2D1_SIZE_F size = m_d2dContext->GetSize();
    size.height = size.height / 3;
    size.width = size.width / 3;

    m_d2dContext->DrawLine(
        D2D1::Point2F((screenSize.width - 2 * size.width), 0.0f),
        D2D1::Point2F((screenSize.width - 2 * size.width), screenSize.height),
        m_blackBrush.Get()
        );

    m_d2dContext->DrawLine(
        D2D1::Point2F((screenSize.width - size.width), 0.0f),
        D2D1::Point2F((screenSize.width - size.width), screenSize.height),
        m_blackBrush.Get()
        );

    m_d2dContext->DrawTextLayout(
        D2D1::Point2F(size.width, size.height),
        m_textLayout1.Get(),
        m_blackBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void DWriteParagraphText::Run ( ) [virtual]

Definition at line 273 of file DWriteParagraphText.cpp.

{
    Render();
    Present();

    CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void DWriteParagraphText::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void DWriteParagraphText::ShowMenu ( Windows::Foundation::Point position ) [private]
void DWriteParagraphText::Uninitialize ( ) [virtual]

Definition at line 281 of file DWriteParagraphText.cpp.

{
}

void DWriteParagraphText::UpdateCharacterSpacing ( Windows::UI::Popups::IUICommand^ command ) [private]
void DWriteParagraphText::UpdateJustification ( Windows::UI::Popups::IUICommand^ command ) [private]

Member Data Documentation

internal DWriteParagraphText::__pad0__

Definition at line 16 of file DWriteParagraphText.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> DWriteParagraphText::m_blackBrush [private]

Definition at line 87 of file DWriteParagraphText.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> DWriteParagraphText::m_gestureRecognizer [private]

Definition at line 91 of file DWriteParagraphText.h.

bool DWriteParagraphText::m_isIncreasedSpacing [private]

Definition at line 95 of file DWriteParagraphText.h.

bool DWriteParagraphText::m_isJustified [private]

Definition at line 94 of file DWriteParagraphText.h.

SampleOverlay DWriteParagraphText::m_sampleOverlay [private]

Definition at line 90 of file DWriteParagraphText.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> DWriteParagraphText::m_textFormat [private]

Definition at line 88 of file DWriteParagraphText.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout1> DWriteParagraphText::m_textLayout1 [private]

Definition at line 92 of file DWriteParagraphText.h.

DWRITE_TEXT_RANGE DWriteParagraphText::m_textRange [private]

Definition at line 93 of file DWriteParagraphText.h.

Microsoft::WRL::ComPtr<IDWriteTypography> DWriteParagraphText::m_textTypography [private]

Definition at line 89 of file DWriteParagraphText.h.

The documentation for this class was generated from the following files:
  • DirectWrite paragraph text/C++/DWriteParagraphText.h
  • DirectWrite paragraph text/C++/DWriteParagraphText.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DWriteVerticalText Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

DWriteVerticalText Class Reference

#include "DWriteVerticalText.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: DWriteVerticalText()

Private Member Functions

void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Microsoft::WRL::ComPtr
< FlowLayout > 		m_flowLayout
Microsoft::WRL::ComPtr
< FlowLayoutSink > 		m_flowLayoutSink
Microsoft::WRL::ComPtr
< FlowLayoutSource > 		m_flowLayoutSource
const wchar_t * | m_fontName
float | m_fontSize
const wchar_t * | m_localeName
ReadingDirection m_readingDirection
Microsoft::WRL::ComPtr
< IDWriteRenderingParams > 		m_renderingParams
SampleOverlay m_sampleOverlay
const wchar_t * | m_text
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
UINT32 | m_textLength
Microsoft::WRL::ComPtr
< IDWriteTypography > 		m_textTypography

Detailed Description

Definition at line 14 of file DWriteVerticalText.h.

Member Function Documentation

void DWriteVerticalText::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 24 of file DWriteVerticalText.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Set Layout Sample Text
    m_readingDirection = ReadingDirectionLeftToRightTopToBottom;
    m_text =
        L"『世界人権宣言』\r\n"
        L"（1948.12.10 第３回国連総会採択）〈前文〉\r\n"
        L"\r\n"
        L"人類社会のすべての構成員の固有の尊厳と平等で譲ることのできない権利とを承認することは、世界における自由、正義及び平和の基礎であるので、\r\n"
        L"\r\n"
        L"人権の無視及び軽侮が、人類の良心を踏みにじった野蛮行為をもたらし、言論及び信仰の自由が受けられ、恐怖及び欠乏のない世界の到来が、一般の人々の最高の願望として宣言されたので、\r\n"
        L"\r\n"
        L"人間が専制と圧迫とに対する最後の手段として反逆に訴えることがないようにするためには、法の支配によって人権を保護することが肝要であるので、\r\n"
        L"\r\n"
        L"諸国間の友好関係の発展を促進することが肝要であるので、\r\n"
        L"\r\n"
        L"国際連合の諸国民は、国連憲章において、基本的人権、人間の尊厳及び価値並びに男女の同権についての信念を再確認し、かつ、一層大きな自由のうちで社会的進歩と生活水準の向上とを促進することを決意したので、\r\n"
        L"\r\n"
        L"加盟国は、国際連合と協力して、人権及び基本的自由の普遍的な尊重及び遵守の促進を達成することを誓約したので、\r\n"
        L"\r\n"
        L"これらの権利及び自由に対する共通の理解は、この誓約を完全にするためにもっとも重要であるので、\r\n"
        L"\r\n"
        L"よって、ここに、国連総会は、\r\n"
        L"\r\n"
        L"\r\n"
        L"社会の各個人及び各機関が、この世界人権宣言を常に念頭に置きながら、加盟国自身の人民の間にも、また、加盟国の管轄下にある地域の人民の間にも、これらの権利と自由との尊重を指導及び教育によって促進すること並びにそれらの普遍的措置によって確保することに努力するように、すべての人民とすべての国とが達成すべき共通の基準として、この人権宣言を公布する。\r\n"
        L"\r\n"
        L"第１条\r\n"
        L"すべての人間は、生まれながらにして自由であり、かつ、尊厳と権利と について平等である。人間は、理性と良心とを授けられており、互いに同 胞の精神をもって行動しなければならない。\r\n"
        L"\r\n"
        L"第２条"
        L"すべて人は、人種、皮膚の色、性、言語、宗教、政治上その他の意見、\r\n"
        L"\r\n"
        L"国民的もしくは社会的出身、財産、門地その他の地位又はこれに類するい\r\n"
        L"\r\n"
        L"かなる自由による差別をも受けることなく、この宣言に掲げるすべての権\r\n"
        L"\r\n"
        L"利と自由とを享有することができる。\r\n"
        L"\r\n"
        L"さらに、個人の属する国又は地域が独立国であると、信託統治地域で\r\n"
        L"\r\n"
        L"あると、非自治地域であると、又は他のなんらかの主権制限の下にあると\r\n"
        L"\r\n"
        L"を問わず、その国又は地域の政治上、管轄上又は国際上の地位に基ずくい\r\n"
        L"\r\n"
        L"かなる差別もしてはならない。\r\n"
        L"\r\n"
        L"第３条\r\n"
        L"すべての人は、生命、自由及び身体の安全に対する権利を有する。\r\n"
        L"\r\n"
        L"第４条\r\n"
        L"何人も、奴隷にされ、又は苦役に服することはない。奴隷制度及び奴隷\r\n"
        L"\r\n"
        L"売買は、いかなる形においても禁止する。\r\n"
        L"\r\n"
        L"第５条\r\n"
        L"何人も、拷問又は残虐な、非人道的なもしくは屈辱的な取扱もしくは刑\r\n"
        L"\r\n"
        L"罰を受けることはない。\r\n";

    m_fontName                        = L"";
    m_localeName                      = L"";
    m_textLength                      = 0;
    m_fontSize                        = 14;

    m_fontName = L"Meiryo UI";
    m_localeName = L"ja-jp";
    m_readingDirection = ReadingDirectionTopToBottomRightToLeft;

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            m_fontName,
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            m_fontSize,
            m_localeName,
            &m_textFormat
            )
        );
}

void DWriteVerticalText::CreateDeviceResources ( ) [override, virtual]

Definition at line 109 of file DWriteVerticalText.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DirectWrite vertical text sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );
}

void DWriteVerticalText::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 131 of file DWriteVerticalText.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    m_flowLayoutSource = new FlowLayoutSource;
    m_flowLayoutSink = new FlowLayoutSink(m_dwriteFactory.Get());
    m_flowLayout = new FlowLayout(m_dwriteFactory.Get());
    m_flowLayout->SetTextFormat(m_textFormat.Get());
    m_flowLayout->SetReadingDirection(m_readingDirection);
    m_flowLayout->SetReadingDirection(m_readingDirection);

    if (m_textLength == 0)
    {
        m_textLength = static_cast<UINT32>(wcsnlen(m_text, UINT32_MAX));
    }

    m_flowLayout->SetText(m_text, m_textLength);
    m_flowLayout->AnalyzeText();
    m_flowLayoutSource->SetSize(size.width, size.height);
    m_flowLayoutSource->Reset();
    m_flowLayoutSink->Reset();
    m_flowLayout->FlowText(m_flowLayoutSource.Get(), m_flowLayoutSink.Get());
}

virtual void DWriteVerticalText::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void DWriteVerticalText::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 202 of file DWriteVerticalText.cpp.

{
}

void DWriteVerticalText::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteVerticalText::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 242 of file DWriteVerticalText.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void DWriteVerticalText::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 233 of file DWriteVerticalText.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void DWriteVerticalText::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void DWriteVerticalText::Render ( ) [override, virtual]

Definition at line 157 of file DWriteVerticalText.cpp.

{
    m_d2dContext->BeginDraw();
    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    m_flowLayoutSink->DrawGlyphRuns(m_d2dContext.Get(), m_renderingParams.Get(), m_blackBrush.Get());

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void DWriteVerticalText::Run ( ) [virtual]

Definition at line 208 of file DWriteVerticalText.cpp.

{
    m_window->Activate();

    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

virtual void DWriteVerticalText::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void DWriteVerticalText::Uninitialize ( ) [virtual]

Definition at line 218 of file DWriteVerticalText.cpp.

{
}

Member Data Documentation

internal DWriteVerticalText::__pad0__

Definition at line 17 of file DWriteVerticalText.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> DWriteVerticalText::m_blackBrush [private]

Definition at line 53 of file DWriteVerticalText.h.

Microsoft::WRL::ComPtr<FlowLayout> DWriteVerticalText::m_flowLayout [private]

Definition at line 60 of file DWriteVerticalText.h.

Microsoft::WRL::ComPtr<FlowLayoutSink> DWriteVerticalText::m_flowLayoutSink [private]

Definition at line 59 of file DWriteVerticalText.h.

Microsoft::WRL::ComPtr<FlowLayoutSource> DWriteVerticalText::m_flowLayoutSource [private]

Definition at line 58 of file DWriteVerticalText.h.

const wchar_t* DWriteVerticalText::m_fontName [private]

Definition at line 62 of file DWriteVerticalText.h.

float DWriteVerticalText::m_fontSize [private]

Definition at line 65 of file DWriteVerticalText.h.

const wchar_t* DWriteVerticalText::m_localeName [private]

Definition at line 63 of file DWriteVerticalText.h.

ReadingDirection DWriteVerticalText::m_readingDirection [private]

Definition at line 67 of file DWriteVerticalText.h.

Microsoft::WRL::ComPtr<IDWriteRenderingParams> DWriteVerticalText::m_renderingParams [private]

Definition at line 57 of file DWriteVerticalText.h.

SampleOverlay DWriteVerticalText::m_sampleOverlay [private]

Definition at line 61 of file DWriteVerticalText.h.

const wchar_t* DWriteVerticalText::m_text [private]

Definition at line 66 of file DWriteVerticalText.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> DWriteVerticalText::m_textFormat [private]

Definition at line 54 of file DWriteVerticalText.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> DWriteVerticalText::m_textLayout [private]

Definition at line 56 of file DWriteVerticalText.h.

UINT32 DWriteVerticalText::m_textLength [private]

Definition at line 64 of file DWriteVerticalText.h.

Microsoft::WRL::ComPtr<IDWriteTypography> DWriteVerticalText::m_textTypography [private]

Definition at line 55 of file DWriteVerticalText.h.

The documentation for this class was generated from the following files:
  • DirectWrite vertical text/C++/DWriteVerticalText.h
  • DirectWrite vertical text/C++/DWriteVerticalText.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DxgiRotation Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

DxgiRotation Class Reference

#include "DxgiRotation.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Render () override
void | Update (float TimeTotal, float TimeDelta)

Public Attributes

internal | __pad0__: virtual void CreateDeviceIndependentResources() override

Private Attributes

BasicCamera m_Camera
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
unsigned int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
Microsoft::WRL::ComPtr
< ID2D1Bitmap > 		m_referenceBitmap
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_referenceBitmapSource
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_texture
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureSRV
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 23 of file DxgiRotation.h.

Member Function Documentation

void DxgiRotation::CreateDeviceResources ( ) [override, virtual]

Definition at line 81 of file DxgiRotation.cpp.

{
    DirectXBase::CreateDeviceResources();

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    loader->LoadShader(
        "SimpleVertexShader.cso",
        nullptr,
        0,
        &m_vertexShader,
        &m_inputLayout
        );

    // Create the vertex and index buffers for drawing the cube.

    BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());

    shapes->CreateCube(
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // Create the constant buffer for updating model and camera data.
    CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &constantBufferDescription,
            nullptr,             // leave the buffer uninitialized
            &m_constantBuffer
            )
        );

    loader->LoadShader(
        "SimplePixelShader.cso",
        &m_pixelShader
        );

    loader->LoadTexture(
        "reference3d.png",
        &m_texture,
        &m_textureSRV
        );

    // Create the sampler.
    D3D11_SAMPLER_DESC samplerDescription;
    ZeroMemory(&samplerDescription, sizeof(D3D11_SAMPLER_DESC));
    samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.MipLODBias = 0.0f;
    samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
    samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDescription.BorderColor[0] = 0.0f;
    samplerDescription.BorderColor[1] = 0.0f;
    samplerDescription.BorderColor[2] = 0.0f;
    samplerDescription.BorderColor[3] = 0.0f;
    // allow use of all mip levels
    samplerDescription.MinLOD = 0;
    samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDescription,
            &m_sampler
            )
        );

    m_Camera = ref new BasicCamera();

    // Create a 2D bitmap using a reference image.
    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmapFromWicBitmap(
            m_referenceBitmapSource.Get(),
            &m_referenceBitmap
            )
        );

    // Create a brush to draw the reference text with.
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::DarkGray),
            &m_textBrush
            )
        );

    // Create the Sample Overlay.

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DXGI swap chain rotation sample"
        );
}

void DxgiRotation::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 183 of file DxgiRotation.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // update the 3D projection matrix
    m_Camera->SetProjectionParameters(
        70.0f,                                                  // use a 70-degree minimum field of view
        m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
        0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
        100.0f                                                  // specify the farthest Z-distance at which to draw vertices
        );

    // save the new projection matrix to the constant buffer data struct
    m_Camera->GetProjectionMatrix(&m_constantBufferData.projection);

    // rotate the projection matrix as it will be used to render to the rotated swap chain
    m_constantBufferData.projection = mul(m_constantBufferData.projection, m_rotationTransform3D);

    // create a text layout to fill the screen
    Platform::String^ repeatString =
        "Lorem ipsum dolor sit amet, consectetur adipiscing " \
        "elit. Vivamus tempor scelerisque lorem in vehicula. " \
        "Aliquam tincidunt, lacus ut sagittis tristique, turpis " \
        "massa volutpat augue, eu rutrum ligula ante a ante. " \
        "Pellentesque porta, mauris quis interdum vehicula, " \
        "urna sapien ultrices velit, nec venenatis dui odio " \
        "in augue. Cras posuere, enim a cursus convallis, neque " \
        "turpis malesuada erat, ut adipiscing neque tortor ac erat. ";

    // repeat the text enough times to ensure that it fills the window
    Platform::String^ textString = "";
    for (int i = 0; i < 50; i++)
    {
        textString = Platform::String::Concat(textString, repeatString);
    }

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            textString->Data(),                 // Text to be displayed
            textString->Length(),               // Length of the text
            m_textFormat.Get(),                 // DirectWrite Text Format object
            m_windowBounds.Width,               // Width of the Text Layout
            m_windowBounds.Height,              // Height of the Text Layout
            &m_textLayout
            )
        );

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void DxgiRotation::Render ( ) [override, virtual]

Definition at line 233 of file DxgiRotation.cpp.

{
    UINT stride = sizeof(BasicVertex);
    UINT offset = 0;

    // bind the render targets
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // clear both the render target and depth stencil to default values
    const float ClearColor[4] = {0.071f, 0.040f, 0.561f, 1.0f};

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        ClearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    // render 2D reference image and text
    m_d2dContext->BeginDraw();

    // draw reference text
    m_d2dContext->SetTransform(
        Matrix3x2F::Translation(0.0f, 64.0f) *
        m_rotationTransform2D
        );
    m_d2dContext->DrawTextLayout(
        Point2F(0, 0),
        m_textLayout.Get(),
        m_textBrush.Get()
        );

    // draw reference bitmap at the center of the screen
    m_d2dContext->SetTransform(
        Matrix3x2F::Translation(
            m_windowBounds.Width / 2.0f - 768.0f / 2.0f,
            m_windowBounds.Height / 2.0f - 768.0f / 2.0f
            ) *
        m_rotationTransform2D // apply 2D prerotation transform
        );
    m_d2dContext->DrawBitmap(m_referenceBitmap.Get());

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    // set the vertex and index buffers, and specify the way they define geometry
    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    m_d3dContext->IASetVertexBuffers(
        0,                              // starting at the first vertex buffer slot
        1,                              // set one vertex buffer binding
        m_vertexBuffer.GetAddressOf(),
        &stride,                        // specify the size in bytes of a single vertex
        &offset                         // specify the base vertex in the buffer
        );

    // set the index buffer
    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,   // unsigned short index format
        0                       // specify the base index in the buffer
        );

    // specify the way the vertex and index buffers define geometry
    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    // set the vertex shader stage state
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                              // starting at the first constant buffer slot
        1,                              // set one constant buffer binding
        m_constantBuffer.GetAddressOf()
        );

    // set the pixel shader stage state
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->PSSetShaderResources(
        0,                          // starting at the first shader resource slot
        1,                          // set one shader resource binding
        m_textureSRV.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,                          // starting at the first sampler slot
        1,                          // set one sampler binding
        m_sampler.GetAddressOf()
        );

    // draw the cube
    m_d3dContext->DrawIndexed(
        m_indexCount,   // draw all created vertices
        0,              // starting with the first vertex
        0               // and the first index
        );

    // Render the Sample Overlay.
    m_sampleOverlay->Render(m_rotationTransform2D);
}

void DxgiRotation::Update | ( | float | TimeTotal,
 |  | float | TimeDelta
 | ) |  |

Definition at line 356 of file DxgiRotation.cpp.

{
    // update the model matrix based on the time
    m_constantBufferData.model = rotationY(-TimeTotal * 60.0f);

    // update the view matrix based on the camera position
    // note that for this sample, the camera position is fixed
    m_Camera->SetViewParameters(
        float3(0, 1, 2),
        float3(0, 0, 0),
        float3(0, 1, 0)
        );

    m_Camera->GetViewMatrix(&m_constantBufferData.view);

    // update the constant buffer with the new data
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_constantBufferData,
        0,
        0
        );
}

Member Data Documentation

internal DxgiRotation::__pad0__

Definition at line 26 of file DxgiRotation.h.

BasicCamera DxgiRotation::m_Camera [private]

Definition at line 53 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> DxgiRotation::m_constantBuffer [private]

Definition at line 44 of file DxgiRotation.h.

ConstantBuffer DxgiRotation::m_constantBufferData [private]

Definition at line 52 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> DxgiRotation::m_indexBuffer [private]

Definition at line 38 of file DxgiRotation.h.

unsigned int DxgiRotation::m_indexCount [private]

Definition at line 51 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> DxgiRotation::m_inputLayout [private]

Definition at line 36 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> DxgiRotation::m_pixelShader [private]

Definition at line 40 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap> DxgiRotation::m_referenceBitmap [private]

Definition at line 46 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> DxgiRotation::m_referenceBitmapSource [private]

Definition at line 45 of file DxgiRotation.h.

SampleOverlay DxgiRotation::m_sampleOverlay [private]

Definition at line 34 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> DxgiRotation::m_sampler [private]

Definition at line 43 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> DxgiRotation::m_textBrush [private]

Definition at line 47 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> DxgiRotation::m_textFormat [private]

Definition at line 48 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> DxgiRotation::m_textLayout [private]

Definition at line 49 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> DxgiRotation::m_texture [private]

Definition at line 41 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> DxgiRotation::m_textureSRV [private]

Definition at line 42 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> DxgiRotation::m_vertexBuffer [private]

Definition at line 37 of file DxgiRotation.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> DxgiRotation::m_vertexShader [private]

Definition at line 39 of file DxgiRotation.h.

The documentation for this class was generated from the following files:
  • DXGI swap chain rotation/C++/DxgiRotation.h
  • DXGI swap chain rotation/C++/DxgiRotation.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EaseInExponentialAnimation< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions

EaseInExponentialAnimation< T > Class Template Reference

#include "animation.h"

Inherits Animation< T >.

List of all members.

Public Member Functions

EaseInExponentialAnimation (T start=0, T end=0, T duration=0)

Protected Member Functions

T ComputeValue (T time)

Detailed Description

template<class T>
class EaseInExponentialAnimation< T >

Definition at line 101 of file animation.h.

Constructor & Destructor Documentation

template<class T >
EaseInExponentialAnimation< T >::EaseInExponentialAnimation | ( | T | start = 0,
 |  | T | end = 0,
 |  | T | duration = 0 |
 | ) |  |  | [inline]

Definition at line 104 of file animation.h.

                                                                       :
        Animation(start, end, duration)
    {
    }

Member Function Documentation

template<class T >
T EaseInExponentialAnimation< T >::ComputeValue ( T time ) [inline, protected, virtual]

Implements Animation< T >.

Definition at line 109 of file animation.h.

    {
        return m_Start + (m_End - m_Start) * pow(2, 10 * (time/m_Duration - 1));
    }

The documentation for this class was generated from the following file:
  • Direct2D animation/C++/animation.h
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EaseInOutExponentialAnimation< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions

EaseInOutExponentialAnimation< T > Class Template Reference

#include "animation.h"

Inherits Animation< T >.

List of all members.

Public Member Functions

EaseInOutExponentialAnimation (T start=0, T end=0, T duration=0)

Protected Member Functions

T ComputeValue (T time)

Detailed Description

template<class T>
class EaseInOutExponentialAnimation< T >

Definition at line 143 of file animation.h.

Constructor & Destructor Documentation

template<class T >
EaseInOutExponentialAnimation< T >::EaseInOutExponentialAnimation | ( | T | start = 0,
 |  | T | end = 0,
 |  | T | duration = 0 |
 | ) |  |  | [inline]

Definition at line 146 of file animation.h.

                                                                          :
        Animation(start, end, duration)
    {
    }

Member Function Documentation

template<class T >
T EaseInOutExponentialAnimation< T >::ComputeValue ( T time ) [inline, protected, virtual]

Implements Animation< T >.

Definition at line 151 of file animation.h.

    {
        // compute the current time relative to the midpoint
        time = time / (m_Duration / 2);
        // if we haven't reached the midpoint, we want to do the ease-in portion
        if (time < 1)
        {
            return m_Start + (m_End - m_Start)/2 * pow(2, 10 * (time - 1));
        }
        // otherwise, do the ease-out portion
        return m_Start + (m_End - m_Start)/2 * (-pow(2, -10 * --time) + 2);
    }

The documentation for this class was generated from the following file:
  • Direct2D animation/C++/animation.h
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EaseOutExponentialAnimation< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions

EaseOutExponentialAnimation< T > Class Template Reference

#include "animation.h"

Inherits Animation< T >.

List of all members.

Public Member Functions

EaseOutExponentialAnimation (T start=0, T end=0, T duration=0)

Protected Member Functions

T ComputeValue (T time)

Detailed Description

template<class T>
class EaseOutExponentialAnimation< T >

Definition at line 122 of file animation.h.

Constructor & Destructor Documentation

template<class T >
EaseOutExponentialAnimation< T >::EaseOutExponentialAnimation | ( | T | start = 0,
 |  | T | end = 0,
 |  | T | duration = 0 |
 | ) |  |  | [inline]

Definition at line 125 of file animation.h.

                                                                        :
        Animation(start, end, duration)
    {
    }

Member Function Documentation

template<class T >
T EaseOutExponentialAnimation< T >::ComputeValue ( T time ) [inline, protected, virtual]

Implements Animation< T >.

Definition at line 130 of file animation.h.

    {
        return m_Start + (m_End - m_Start) * (-pow(2, -10 * time/m_Duration) + 1);
    }

The documentation for this class was generated from the following file:
  • Direct2D animation/C++/animation.h
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EdgeGestureSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • EdgeGestureSample
  • EdgeGestureSample::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

EdgeGestureSample::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
String | ConvertResolution (ResolutionScale scale)
String | ConvertViewState (ApplicationViewState state)
void | DoNavigation (TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame)
MainPage ()
void | NotifyUser (String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~MainPage ()
~ScenarioInput1 ()
~ScenarioInput2 ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
void | CheckResolutionAndViewState ()
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, RoutedEventArgs^e)
void | InitializeEdgeGestureHandlers ()
void | InitializeEdgeGestureHandlers ()
void | inputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | OnCanceled (EdgeGesture^sender, EdgeGestureEventArgs^e)
void | OnCanceled (EdgeGesture^sender, EdgeGestureEventArgs^e)
void | OnCompleted (EdgeGesture^sender, EdgeGestureEventArgs^e)
void | OnCompleted (EdgeGesture^sender, EdgeGestureEventArgs^e)
void | OnContextMenu (Object^sender, RightTappedRoutedEventArgs^e)
void | OnContextMenu (Object^sender, RightTappedRoutedEventArgs^e)
void | OnStarting (EdgeGesture^sender, EdgeGestureEventArgs^e)
void | OnStarting (EdgeGesture^sender, EdgeGestureEventArgs^e)
void | outputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | Page_Loaded (Object^sender, RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | RightClickOverride (Object^sender, RightTappedRoutedEventArgs^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | SetFeatureName (Platform::String^strFeature)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::Foundation::EventRegistrationToken | _frameLoadedToken
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _layoutHandlerToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
Windows::Foundation::EventRegistrationToken | EdgeGestureCanceledEventToken
Windows::Foundation::EventRegistrationToken | EdgeGestureCompletedEventToken
Windows::Foundation::EventRegistrationToken | EdgeGestureStartingEventToken
TextBlock | outputText
Windows::Foundation::EventRegistrationToken | RightClickEventToken
ListBox | RightClickRegion
Windows::Foundation::EventRegistrationToken | RightClickRegionEventToken
MainPage | rootPage

Detailed Description

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

EdgeGestureSample::sealed::~MainPage ( ) [private]
EdgeGestureSample::sealed::~ScenarioInput1 ( ) [private]
EdgeGestureSample::sealed::~ScenarioInput2 ( ) [private]
EdgeGestureSample::sealed::~ScenarioList ( ) [private]
EdgeGestureSample::sealed::~ScenarioOutput1 ( ) [private]
EdgeGestureSample::sealed::~ScenarioOutput2 ( ) [private]

Member Function Documentation

EdgeGestureSample::sealed::App ( )
void EdgeGestureSample::sealed::CheckResolutionAndViewState ( ) [private]
String EdgeGestureSample::sealed::ConvertResolution ( ResolutionScale scale )
String EdgeGestureSample::sealed::ConvertViewState ( ApplicationViewState state )
void EdgeGestureSample::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void EdgeGestureSample::sealed::DoNavigation | ( | TypeName | pageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | frame
 | ) |  |
void EdgeGestureSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::InitializeEdgeGestureHandlers ( ) [private]
void EdgeGestureSample::sealed::InitializeEdgeGestureHandlers ( ) [private]
void EdgeGestureSample::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
EdgeGestureSample::sealed::MainPage ( )
void EdgeGestureSample::sealed::NotifyUser | ( | String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void EdgeGestureSample::sealed::OnCanceled | ( | EdgeGesture^ | sender,
 |  | EdgeGestureEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::OnCanceled | ( | EdgeGesture^ | sender,
 |  | EdgeGestureEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::OnCompleted | ( | EdgeGesture^ | sender,
 |  | EdgeGestureEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::OnCompleted | ( | EdgeGesture^ | sender,
 |  | EdgeGestureEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::OnContextMenu | ( | Object^ | sender,
 |  | RightTappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::OnContextMenu | ( | Object^ | sender,
 |  | RightTappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void EdgeGestureSample::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void EdgeGestureSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void EdgeGestureSample::sealed::OnStarting | ( | EdgeGesture^ | sender,
 |  | EdgeGestureEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::OnStarting | ( | EdgeGesture^ | sender,
 |  | EdgeGestureEventArgs^ | e |
 | ) |  |  | [private]
virtual void EdgeGestureSample::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void EdgeGestureSample::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::Page_Loaded | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::RightClickOverride | ( | Object^ | sender,
 |  | RightTappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void EdgeGestureSample::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
EdgeGestureSample::sealed::ScenarioInput1 ( )
EdgeGestureSample::sealed::ScenarioInput2 ( )
EdgeGestureSample::sealed::ScenarioList ( )
EdgeGestureSample::sealed::ScenarioOutput1 ( )
EdgeGestureSample::sealed::ScenarioOutput2 ( )
void EdgeGestureSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void EdgeGestureSample::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken EdgeGestureSample::sealed::_displayHandlerToken [private]

Definition at line 70 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::_frameLoadedToken [private]

Definition at line 50 of file ScenarioInput1.xaml.h.

Windows::UI::Xaml::Controls::Frame EdgeGestureSample::sealed::_inputFrame [private]

Definition at line 67 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken EdgeGestureSample::sealed::_inputFrameLoadedToken [private]

Definition at line 74 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::_layoutHandlerToken [private]

Definition at line 71 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken EdgeGestureSample::sealed::_logicalDpiChangedToken [private]

Definition at line 73 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame EdgeGestureSample::sealed::_outputFrame [private]

Definition at line 68 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken EdgeGestureSample::sealed::_outputFrameLoadedToken [private]

Definition at line 75 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken EdgeGestureSample::sealed::_pageLoadedHandlerToken [private]

Definition at line 72 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame EdgeGestureSample::sealed::_scenariosFrame [private]

Definition at line 66 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::EdgeGestureCanceledEventToken [private]

Definition at line 38 of file ScenarioInput1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::EdgeGestureCompletedEventToken [private]

Definition at line 37 of file ScenarioInput1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::EdgeGestureStartingEventToken [private]

Definition at line 36 of file ScenarioInput1.xaml.h.

TextBlock sealed::outputText [private]

Definition at line 34 of file ScenarioInput1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::RightClickEventToken [private]

Definition at line 35 of file ScenarioInput1.xaml.h.

ListBox EdgeGestureSample::sealed::RightClickRegion [private]

Definition at line 33 of file ScenarioInput2.xaml.h.

Windows::Foundation::EventRegistrationToken EdgeGestureSample::sealed::RightClickRegionEventToken [private]

Definition at line 35 of file ScenarioInput2.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 33 of file ScenarioInput1.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> EdgeGestureSample::sealed::OutputFrameLoaded

Definition at line 57 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Edge gesture invocation/C++/App.xaml.h
  • Edge gesture invocation/C++/MainPage.xaml.h
  • Edge gesture invocation/C++/ScenarioInput1.xaml.h
  • Edge gesture invocation/C++/ScenarioInput2.xaml.h
  • Edge gesture invocation/C++/ScenarioList.xaml.h
  • Edge gesture invocation/C++/ScenarioOutput1.xaml.h
  • Edge gesture invocation/C++/ScenarioOutput2.xaml.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Element Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Element Class Reference

#include "Element.h"

Inherited by Design, ImageFrame, Layer, Page, PageRoll, Rectangle, Resource, Story, and TextFrame.

List of all members.

Public Member Functions

virtual bool | AcceptChildNode (_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode)
void | AddChild (_In_ Element^element)
void | AddSibling (_In_ Element^element)
virtual bool | BindResource (_In_ Element^rootElement)
virtual bool | Draw (_In_ Document^document, D2D1::Matrix3x2F const &transform)
Element GetFirstChild ()
Platform::String | GetName ()
Element GetNextSibling ()
virtual float | GetOpacity ()
Element GetParent ()
D2D1_SIZE_F | GetSize ()
virtual bool | Initialize (_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement)
virtual void | Measure (_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds)
virtual bool | PrepareToDraw (_In_ Document^document, D2D1::Matrix3x2F const &transform)
virtual void | ReleaseParent ()

Static Public Member Functions

template<typename T >
static T | Create (_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode)

Public Attributes

internal | __pad0__: Element()

Private Member Functions

bool | DrawChildren (_In_ Document^document, D2D1::Matrix3x2F const &transform)
uint32 | ParseColor (_In_ Platform::String^value)
Platform::String | ParseNameIdentifier (_In_ Platform::String^value)
bool | PrepareToDrawChildren (_In_ Document^document, D2D1::Matrix3x2F const &transform)

Private Attributes

Element m_firstChild
Platform::String | m_name
Element m_nextSibling
D2D1_POINT_2F | m_offset
Element m_parent
D2D1_SIZE_F | m_size

Detailed Description

Definition at line 29 of file Element.h.

Member Function Documentation

virtual bool Element::AcceptChildNode | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::IXmlNode^ | childXmlNode |
 | ) |  |  | [virtual]

Reimplemented in Design, Layer, List< T >, Page, Text, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

void Element::AddChild ( _In_ Element^ element )

Definition at line 45 of file Element.cpp.

{
    if (m_firstChild == nullptr)
    {
        element->m_parent = this;
        m_firstChild = element;
    }
    else
    {
        m_firstChild->AddSibling(element);
    }
}

void Element::AddSibling ( _In_ Element^ element )

Definition at line 58 of file Element.cpp.

{
    if (m_nextSibling == nullptr)
    {
        element->m_parent = m_parent;
        m_nextSibling = element;
    }
    else
    {
        m_nextSibling->AddSibling(element);
    }
}

bool Element::BindResource ( _In_ Element^ rootElement ) [virtual]

Reimplemented in ImageFrame, and TextFrame.

Definition at line 125 of file Element.cpp.

{
    // Succeed by default without actually binding any resource
    return true;
}

template<typename T >
T Element::Create | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::IXmlNode^ | xmlNode |
 | ) |  |  | [static]

Definition at line 146 of file Element.h.

{
    T^ element = nullptr;

    if (xmlNode->NodeType == NodeType::ElementNode)
    {
        Windows::Data::Xml::Dom::XmlElement^ xmlElement = dynamic_cast<Windows::Data::Xml::Dom::XmlElement^>(xmlNode);

        element = ref new T();

        if (element)
        {
            if (element->Initialize(document, xmlElement))
            {
                if (xmlNode->HasChildNodes())
                {
                    Windows::Data::Xml::Dom::IXmlNode^ childXmlNode = xmlNode->FirstChild;

                    while (childXmlNode != nullptr)
                    {
                        if (!element->AcceptChildNode(document, childXmlNode))
                        {
                            break;
                        }

                        childXmlNode = childXmlNode->NextSibling;
                    }
                }
            }
            else
            {
                element = nullptr;
            }
        }
    }

    return element;
}

bool Element::Draw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [virtual]

Reimplemented in ImageFrame, List< T >, Rectangle, Resource, TextFrame, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

Definition at line 218 of file Element.cpp.

{
    return DrawChildren(
        document,
        D2D1::Matrix3x2F::Translation(m_offset.x, m_offset.y) * transform
        );
}

bool Element::DrawChildren | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [private]

Definition at line 229 of file Element.cpp.

{
    Element^ child = GetFirstChild();

    while (child)
    {
        if (child->Draw(document, transform))
            return true;

        child = child->GetNextSibling();
    }

    return false;
}

Element Element::GetFirstChild ( ) [inline]

Definition at line 94 of file Element.h.

    {
        return m_firstChild;
    }

Platform::String Element::GetName ( ) [inline]

Definition at line 80 of file Element.h.

    {
        return m_name;
    }

Element Element::GetNextSibling ( ) [inline]

Definition at line 99 of file Element.h.

    {
        return m_nextSibling;
    }

virtual float Element::GetOpacity ( ) [inline, virtual]

Reimplemented in Layer, Rectangle, and TextFrame.

Definition at line 70 of file Element.h.

    {
        return 1.0f;
    }

Element Element::GetParent ( ) [inline]

Definition at line 89 of file Element.h.

    {
        return m_parent;
    }

D2D1_SIZE_F Element::GetSize ( ) [inline]

Definition at line 75 of file Element.h.

    {
        return m_size;
    }

virtual bool Element::Initialize | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::XmlElement^ | xmlElement |
 | ) |  |  | [virtual]

Reimplemented in Design, Image, ImageFrame, List< T >, Rectangle, Text, TextFrame, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

void Element::Measure | ( | _In_ Document^ | document,
 |  | D2D1_SIZE_F const & | parentSize,
 |  | _Out_ D2D1_RECT_F * | bounds |
 | ) |  |  | [virtual]

Reimplemented in ImageFrame, List< T >, PageRoll, Rectangle, Resource, TextFrame, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

Definition at line 131 of file Element.cpp.

{
    D2D1_SIZE_F size = m_size;

    if (size.width <= 0 && size.height <= 0)
    {
        // When no size is specified, assume its parent size.
        size = parentSize;
    }

    D2D1_RECT_F maxBounds = {0};

    Element^ child = GetFirstChild();

    while (child)
    {
        D2D1_RECT_F childBounds = {0};

        child->Measure(document, size, &childBounds);

        if (childBounds.left < maxBounds.left)
        {
            maxBounds.left = childBounds.left;
        }

        if (childBounds.right > maxBounds.right)
        {
            maxBounds.right = childBounds.right;
        }

        if (childBounds.top < maxBounds.top)
        {
            maxBounds.top = childBounds.top;
        }

        if (childBounds.bottom > maxBounds.bottom)
        {
            maxBounds.bottom = childBounds.bottom;
        }

        child = child->GetNextSibling();
    }

    // Element size may be adjusted to accommodate the bounds of all its children.
    m_size = D2D1::SizeF(maxBounds.right - maxBounds.left, maxBounds.bottom - maxBounds.top);

    *bounds = D2D1::RectF(
        maxBounds.left + m_offset.x,
        maxBounds.top + m_offset.y,
        maxBounds.right + m_offset.x,
        maxBounds.bottom + m_offset.y
        );
}

uint32 Element::ParseColor ( _In_ Platform::String^ value ) [private]

Definition at line 247 of file Element.cpp.

{
    uint32 color = 0;

    wchar_t const* string = value->Data();

    if (!value->IsEmpty() && string[0] == '#')
    {
        color = wcstoul(string + 1, nullptr, 16);
    }

    return color;
}

Platform::String Element::ParseNameIdentifier ( _In_ Platform::String^ value ) [private]

Definition at line 261 of file Element.cpp.

{
    wchar_t const* string = value->Data();

    if (!value->IsEmpty() && string[0] == '#')
    {
        Platform::String^ name = ref new Platform::String(const_cast<wchar_t*>(string + 1));
        return name;
    }

    return nullptr;
}

bool Element::PrepareToDraw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [virtual]

Reimplemented in Resource, and TextFrame.

Definition at line 189 of file Element.cpp.

{
    return PrepareToDrawChildren(
        document,
        D2D1::Matrix3x2F::Translation(m_offset.x, m_offset.y) * transform
        );
}

bool Element::PrepareToDrawChildren | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [private]

Definition at line 200 of file Element.cpp.

{
    Element^ child = GetFirstChild();

    while (child)
    {
        if (child->PrepareToDraw(document, transform))
            return true;

        child = child->GetNextSibling();
    }

    return false;
}

void Element::ReleaseParent ( ) [virtual]

Definition at line 30 of file Element.cpp.

{
    if (m_firstChild != nullptr)
    {
        m_firstChild->ReleaseParent();
    }

    if (m_nextSibling != nullptr)
    {
        m_nextSibling->ReleaseParent();
    }

    m_parent = nullptr;
}

Member Data Documentation

internal Element::__pad0__

Reimplemented in Design, Image, ImageFrame, Layer, List< T >, PageRoll, Rectangle, Resource, Story, Text, TextFrame, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

Definition at line 32 of file Element.h.

Element Element::m_firstChild [private]

Definition at line 138 of file Element.h.

Platform::String Element::m_name [private]

Definition at line 122 of file Element.h.

Element Element::m_nextSibling [private]

Definition at line 135 of file Element.h.

D2D1_POINT_2F Element::m_offset [private]

Definition at line 125 of file Element.h.

Element Element::m_parent [private]

Definition at line 132 of file Element.h.

D2D1_SIZE_F Element::m_size [private]

Definition at line 128 of file Element.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/Element.h
  • Direct2D magazine app/C++/Element.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ElementBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes

ElementBase Class Reference

#include "UserInterface.h"

Inherited by TextElement.

List of all members.

Public Member Functions

D2D1_RECT_F | GetBounds ()
virtual void | Initialize ()
bool | IsVisible () const
virtual void | Render ()
void | SetAlignment (AlignType horizontal, AlignType vertical)
virtual void | SetContainer (const D2D1_RECT_F &container)
void | SetVisible (bool visible)
virtual void | Update (float timeTotal, float timeDelta)

Protected Member Functions

ElementBase ()
virtual void | CalculateSize ()

Protected Attributes

Alignment m_alignment
D2D1_RECT_F | m_container
D2D1_SIZE_F | m_size
bool | m_visible

Detailed Description

Definition at line 48 of file UserInterface.h.

Constructor & Destructor Documentation

ElementBase::ElementBase ( ) [protected]

Definition at line 109 of file UserInterface.cpp.

                        :
    m_visible(false)
{
}

Member Function Documentation

virtual void ElementBase::CalculateSize ( ) [inline, protected, virtual]

Reimplemented in TextElement, and TextButton.

Definition at line 66 of file UserInterface.h.

{ }

D2D1_RECT_F ElementBase::GetBounds ( )

Definition at line 130 of file UserInterface.cpp.

{
    CalculateSize();

    D2D1_RECT_F bounds = D2D1::RectF();

    switch (m_alignment.horizontal)
    {
    case AlignNear:
        bounds.left = m_container.left;
        bounds.right = bounds.left + m_size.width;
        break;

    case AlignCenter:
        bounds.left = m_container.left + (m_container.right - m_container.left - m_size.width) / 2.0f;
        bounds.right = bounds.left + m_size.width;
        break;

    case AlignFar:
        bounds.right = m_container.right;
        bounds.left = bounds.right - m_size.width;
        break;
    }

    switch (m_alignment.vertical)
    {
    case AlignNear:
        bounds.top = m_container.top;
        bounds.bottom = bounds.top + m_size.height;
        break;

    case AlignCenter:
        bounds.top = m_container.top + (m_container.bottom - m_container.top - m_size.height) / 2.0f;
        bounds.bottom = bounds.top + m_size.height;
        break;

    case AlignFar:
        bounds.bottom = m_container.bottom;
        bounds.top = bounds.bottom - m_size.height;
        break;
    }

    return bounds;
}

virtual void ElementBase::Initialize ( ) [inline, virtual]

Reimplemented in TextElement, CountdownTimer, StopwatchTimer, TextButton, and HighScoreTable.

Definition at line 51 of file UserInterface.h.

{ }

bool ElementBase::IsVisible ( ) const [inline]

Definition at line 61 of file UserInterface.h.

{ return m_visible; }

virtual void ElementBase::Render ( ) [inline, virtual]

Reimplemented in TextElement, CountdownTimer, StopwatchTimer, TextButton, and HighScoreTable.

Definition at line 53 of file UserInterface.h.

{ }

void ElementBase::SetAlignment | ( | AlignType | horizontal,
 |  | AlignType | vertical
 | ) |  |

Definition at line 114 of file UserInterface.cpp.

{
    m_alignment.horizontal = horizontal;
    m_alignment.vertical = vertical;
}

void ElementBase::SetContainer ( const D2D1_RECT_F & container ) [virtual]

Definition at line 120 of file UserInterface.cpp.

{
    m_container = container;
}

void ElementBase::SetVisible ( bool visible )

Definition at line 125 of file UserInterface.cpp.

{
    m_visible = visible;
}

virtual void ElementBase::Update | ( | float | timeTotal,
 |  | float | timeDelta |
 | ) |  |  | [inline, virtual]

Reimplemented in TextElement, CountdownTimer, StopwatchTimer, TextButton, and HighScoreTable.

Definition at line 52 of file UserInterface.h.

{ }

Member Data Documentation

Alignment ElementBase::m_alignment [protected]

Definition at line 68 of file UserInterface.h.

D2D1_RECT_F ElementBase::m_container [protected]

Definition at line 69 of file UserInterface.h.

D2D1_SIZE_F ElementBase::m_size [protected]

Definition at line 70 of file UserInterface.h.

bool ElementBase::m_visible [protected]

Definition at line 71 of file UserInterface.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/UserInterface.h
  • DirectX marble maze game/C++/UserInterface.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ExtrudedTextRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

ExtrudedTextRenderer Class Reference

#include "ExtrudedTextRenderer.h"

List of all members.

Public Member Functions

void | CreateDeviceIndependentResources (Microsoft::WRL::ComPtr< ID2D1Factory1 > d2dFactory, Microsoft::WRL::ComPtr< IDWriteFactory1 > dwriteFactory)
void | CreateDeviceResources (Microsoft::WRL::ComPtr< ID3D11Device1 > d3dDevice, Microsoft::WRL::ComPtr< ID3D11DeviceContext1 > d3dContext)
void | CreateWindowSizeDependentResources (float dpi, Microsoft::WRL::ComPtr< ID3D11RenderTargetView > renderTargetView, Microsoft::WRL::ComPtr< ID3D11DepthStencilView > depthStencilView, Windows::Foundation::Size renderTargetSize)
void | DrawExtrudedText ()
void | OnManipulationDelta (Windows::Foundation::Point position, Windows::Foundation::Point positionDelta, float zoomDelta, float rotation)
void | ReleaseBufferResources ()
void | Reset ()
void | SetExtrudedText (Platform::String^text)

Public Attributes

internal | __pad0__: ExtrudedTextRenderer()

Private Member Functions

void | CreateBuffers (uint32 numVertices, uint32 numIndices, BasicVertex *vertexData, unsigned short *indexData, ID3D11Buffer **vertexBuffer, ID3D11Buffer **indexBuffer)
void | GenerateTextOutline (ID2D1Geometry **ppGeometry)
void | UpdateModelAndCamera ()
void | UpdateTextGeometry ()

Private Attributes

BasicCamera m_camera
Platform::String | m_characters
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
Microsoft::WRL::ComPtr
< ID3D11DeviceContext1 > 		m_d3dContext
Microsoft::WRL::ComPtr
< ID3D11DepthStencilView > 		m_d3dDepthStencilView
Microsoft::WRL::ComPtr
< ID3D11Device1 > 		m_d3dDevice
Microsoft::WRL::ComPtr
< ID3D11RenderTargetView > 		m_d3dRenderTargetView
float | m_dpi
Microsoft::WRL::ComPtr
< IDWriteFactory1 > 		m_dwriteFactory
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
unsigned int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
Windows::Foundation::Point | m_panPosition
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
Windows::Foundation::Size | m_renderTargetSize
Microsoft::WRL::ComPtr
< ID2D1Geometry > 		m_textGeometry
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader
float | m_zoom

Detailed Description

Definition at line 26 of file ExtrudedTextRenderer.h.

Member Function Documentation

void ExtrudedTextRenderer::CreateBuffers | ( | uint32 | numVertices,
 |  | uint32 | numIndices,
 |  | BasicVertex * | vertexData,
 |  | unsigned short * | indexData,
 |  | ID3D11Buffer ** | vertexBuffer,
 |  | ID3D11Buffer ** | indexBuffer |
 | ) |  |  | [private]

Definition at line 401 of file ExtrudedTextRenderer.cpp.

{
    *vertexBuffer = nullptr;
    *indexBuffer = nullptr;
    ComPtr<ID3D11Buffer> vertexBufferInternal;
    ComPtr<ID3D11Buffer> indexBufferInternal;

    D3D11_BUFFER_DESC VertexBufferDesc;
    VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
    VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
    VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
    VertexBufferDesc.CPUAccessFlags = 0;
    VertexBufferDesc.MiscFlags = 0;
    VertexBufferDesc.StructureByteStride = 0;

    D3D11_SUBRESOURCE_DATA VertexBufferData;
    VertexBufferData.pSysMem = vertexData;
    VertexBufferData.SysMemPitch = 0;
    VertexBufferData.SysMemSlicePitch = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &VertexBufferDesc,
            &VertexBufferData,
            &vertexBufferInternal
            )
        );

    D3D11_BUFFER_DESC IndexBufferDesc;
    IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
    IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
    IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
    IndexBufferDesc.CPUAccessFlags = 0;
    IndexBufferDesc.MiscFlags = 0;
    IndexBufferDesc.StructureByteStride = 0;

    D3D11_SUBRESOURCE_DATA IndexBufferData;
    IndexBufferData.pSysMem = indexData;
    IndexBufferData.SysMemPitch = 0;
    IndexBufferData.SysMemSlicePitch = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &IndexBufferDesc,
            &IndexBufferData,
            &indexBufferInternal
            )
        );

    *vertexBuffer = vertexBufferInternal.Detach();
    *indexBuffer = indexBufferInternal.Detach();
}

void ExtrudedTextRenderer::CreateDeviceIndependentResources | ( | Microsoft::WRL::ComPtr< ID2D1Factory1 > | d2dFactory,
 |  | Microsoft::WRL::ComPtr< IDWriteFactory1 > | dwriteFactory
 | ) |  |
void ExtrudedTextRenderer::CreateDeviceResources | ( | Microsoft::WRL::ComPtr< ID3D11Device1 > | d3dDevice,
 |  | Microsoft::WRL::ComPtr< ID3D11DeviceContext1 > | d3dContext
 | ) |  |
void ExtrudedTextRenderer::CreateWindowSizeDependentResources | ( | float | dpi,
 |  | Microsoft::WRL::ComPtr< ID3D11RenderTargetView > | renderTargetView,
 |  | Microsoft::WRL::ComPtr< ID3D11DepthStencilView > | depthStencilView,
 |  | Windows::Foundation::Size | renderTargetSize
 | ) |  |
void ExtrudedTextRenderer::DrawExtrudedText ( )

Definition at line 92 of file ExtrudedTextRenderer.cpp.

{
    if (m_characters != nullptr && m_characters->Length() > 0)
    {
        // Get the outline of the current text as a geometry.
        ComPtr<ID2D1Geometry> textOutlineGeometry;
        GenerateTextOutline(&textOutlineGeometry);

        // Extrude the geometry into a vector of SimpleVertex.
        std::vector<SimpleVertex> vertices;
        Extruder::ExtrudeGeometry(
            textOutlineGeometry.Get(),
            24.0f, // height
            &vertices
            );

        m_indexCount = vertices.size();

        // Convert the vector of SimpleVertex into an array of BasicVertex.
        std::unique_ptr<BasicVertex[]> basicVertices(new BasicVertex[m_indexCount]);
        for (unsigned int i = 0; i < m_indexCount; i++)
        {
            SimpleVertex v = vertices[i];
            basicVertices[i].pos = v.Pos;
            basicVertices[i].norm = v.Norm;
            // basicVertices[i].tex is not used
        }

        // Build the index buffer. It's reversed so that handedness is correct.
        std::unique_ptr<unsigned short[]> indices(new unsigned short[m_indexCount]);
        for (unsigned int i = 0; i < m_indexCount; i++)
        {
            indices[i] = m_indexCount - i - 1;
        }

        CreateBuffers(
            m_indexCount,
            m_indexCount,
            basicVertices.get(),
            indices.get(),
            &m_vertexBuffer,
            &m_indexBuffer
            );

        uint stride = sizeof(BasicVertex);
        uint offset = 0;

        // Bind the render targets.
        m_d3dContext->OMSetRenderTargets(
            1,
            m_d3dRenderTargetView.GetAddressOf(),
            m_d3dDepthStencilView.Get()
            );

        m_d3dContext->ClearDepthStencilView(
            m_d3dDepthStencilView.Get(),
            D3D11_CLEAR_DEPTH,
            1.0f,
            0
            );

        m_d3dContext->IASetInputLayout(m_inputLayout.Get());

        // Set the vertex buffer.
        m_d3dContext->IASetVertexBuffers(
            0,                              // starting at the first vertex buffer slot
            1,                              // set one vertex buffer binding
            m_vertexBuffer.GetAddressOf(),
            &stride,                        // specify the size in bytes of a single vertex
            &offset                         // specify the base vertex in the buffer
            );

        // Set the index buffer.
        m_d3dContext->IASetIndexBuffer(
            m_indexBuffer.Get(),
            DXGI_FORMAT_R16_UINT,   // unsigned short index format
            0                       // specify the base index in the buffer
            );

        // Specify the way the vertex and index buffers define geometry.
        m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

        // Set the vertex shader stage state.
        m_d3dContext->VSSetShader(
            m_vertexShader.Get(),
            nullptr,                // don't use shader linkage
            0                       // don't use shader linkage
            );

        // Set the constant buffer.
        m_d3dContext->VSSetConstantBuffers(
            0,                              // starting at the first constant buffer slot
            1,                              // set one constant buffer binding
            m_constantBuffer.GetAddressOf()
            );

        // Create a viewport descriptor of the full window size. The
        // panning position is used to offset the rendering.
        CD3D11_VIEWPORT viewport(
            m_panPosition.X,
            m_panPosition.Y,
            m_renderTargetSize.Width,
            m_renderTargetSize.Height
            );

        // Set the current viewport using the descriptor.
        m_d3dContext->RSSetViewports(1, &viewport);

        // Set the pixel shader stage state.
        m_d3dContext->PSSetShader(
            m_pixelShader.Get(),
            nullptr,                // don't use shader linkage
            0                       // don't use shader linkage
            );

        // Draw the vertices.
        m_d3dContext->DrawIndexed(
            m_indexCount,   // draw all created vertices
            0,              // starting with the first vertex
            0               // and the first index
            );
    }
}

void ExtrudedTextRenderer::GenerateTextOutline ( ID2D1Geometry ** ppGeometry ) [private]

Definition at line 362 of file ExtrudedTextRenderer.cpp.

{
    DWRITE_LINE_METRICS lineMetrics;
    DWRITE_TEXT_METRICS textMetrics;
    UINT actualNumLines;

    //
    // We're assuming here that the text doesn't wrap and doesn't contain
    // newlines.
    //
    DX::ThrowIfFailed(
        m_textLayout->GetLineMetrics(
            &lineMetrics,
            1,                  // maxLineCount
            &actualNumLines     // ignored
            )
        );

    DX::ThrowIfFailed(
        m_textLayout->GetMetrics(&textMetrics)
        );

    float offsetY = -lineMetrics.baseline;
    float offsetX = -textMetrics.widthIncludingTrailingWhitespace / 2;

    ComPtr<ID2D1TransformedGeometry> pTransformedGeometry;
    DX::ThrowIfFailed(
        m_d2dFactory->CreateTransformedGeometry(
            m_textGeometry.Get(),
            D2D1::Matrix3x2F::Translation(offsetX, offsetY),
            &pTransformedGeometry
            )
        );

    // Transfer reference.
    *ppGeometry = pTransformedGeometry.Get();
    (*ppGeometry)->AddRef();
}

void ExtrudedTextRenderer::OnManipulationDelta | ( | Windows::Foundation::Point | position,
 |  | Windows::Foundation::Point | positionDelta,
 |  | float | zoomDelta,
 |  | float | rotation
 | ) |  |
void ExtrudedTextRenderer::ReleaseBufferResources ( )

Definition at line 230 of file ExtrudedTextRenderer.cpp.

{
    m_d3dRenderTargetView = nullptr;
    m_d3dDepthStencilView = nullptr;
}

void ExtrudedTextRenderer::Reset ( )

Definition at line 223 of file ExtrudedTextRenderer.cpp.

{
    m_characters = nullptr;
    m_panPosition = Point(0.0f, 0.0f);
    m_zoom = 1.0f;
}

void ExtrudedTextRenderer::SetExtrudedText ( Platform::String^ text )
void ExtrudedTextRenderer::UpdateModelAndCamera ( ) [private]

Definition at line 253 of file ExtrudedTextRenderer.cpp.

{
    // Update the model based on the current zoom level.
    float4x4 model = identity();
    model = mul(model, scale(m_zoom, m_zoom, m_zoom));

    m_constantBufferData.model = model;

    // Update the view matrix based on the camera position.
    // For this sample, the camera position is fixed.
    m_camera->SetViewParameters(
        float3(0, -20, -500.0f),
        float3(0, -20.0f, 0),
        float3(0, -1, 0)
        );

    m_camera->GetViewMatrix(&m_constantBufferData.view);

    // Update the constant buffer with the new data.
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_constantBufferData,
        0,
        0
        );
}

void ExtrudedTextRenderer::UpdateTextGeometry ( ) [private]

Definition at line 285 of file ExtrudedTextRenderer.cpp.

{
    if (m_characters != nullptr && m_characters->Length() > 0)
    {
        const float fontSize = 72.0f;

        ComPtr<IDWriteTextFormat> textFormat;
        DX::ThrowIfFailed(
            m_dwriteFactory->CreateTextFormat(
                L"Gabriola",
                nullptr,
                DWRITE_FONT_WEIGHT_EXTRA_BOLD,
                DWRITE_FONT_STYLE_NORMAL,
                DWRITE_FONT_STRETCH_NORMAL,
                fontSize,
                L"en-us",
                &textFormat
                )
            );

        DX::ThrowIfFailed(
            m_dwriteFactory->CreateTextLayout(
                m_characters->Data(),
                m_characters->Length(),
                textFormat.Get(),
                0.0f,           // lineWidth (ignored because of NO_WRAP)
                fontSize,       // lineHeight
                &m_textLayout
                )
            );

        DX::ThrowIfFailed(
            m_textLayout->SetWordWrapping(DWRITE_WORD_WRAPPING_NO_WRAP)
            );

        ComPtr<IDWriteTypography> typography;
        DX::ThrowIfFailed(
            m_dwriteFactory->CreateTypography(&typography)
            );

        DWRITE_FONT_FEATURE fontFeature =
        {
            DWRITE_FONT_FEATURE_TAG_STYLISTIC_SET_7,
            1
        };

        DX::ThrowIfFailed(
            typography->AddFontFeature(fontFeature)
            );

        DWRITE_TEXT_RANGE textRange = {0, m_characters->Length()};

        DX::ThrowIfFailed(
            m_textLayout->SetTypography(typography.Get(), textRange)
            );

        // Create a custom text renderer, then pass the text through it via
        // the Draw method in order to compute the text's outline.
        ComPtr<OutlineRenderer> renderer;
        OutlineRenderer::CreateOutlineRenderer(m_d2dFactory.Get(), &renderer);

        DX::ThrowIfFailed(
            m_textLayout->Draw(
                nullptr,    // clientDrawingContext
                renderer.Get(),
                0.0f,       // originX
                0.0f        // originY
                )
            );

        // Retrieve the ID2D1Geometry representing the text's outline.
        renderer->GetGeometry(&m_textGeometry);
    }
}

Member Data Documentation

internal ExtrudedTextRenderer::__pad0__

Definition at line 29 of file ExtrudedTextRenderer.h.

BasicCamera ExtrudedTextRenderer::m_camera [private]

Definition at line 95 of file ExtrudedTextRenderer.h.

Platform::String ExtrudedTextRenderer::m_characters [private]

Definition at line 97 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> ExtrudedTextRenderer::m_constantBuffer [private]

Definition at line 91 of file ExtrudedTextRenderer.h.

ConstantBuffer ExtrudedTextRenderer::m_constantBufferData [private]

Definition at line 94 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Factory1> ExtrudedTextRenderer::m_d2dFactory [private]

Definition at line 76 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11DeviceContext1> ExtrudedTextRenderer::m_d3dContext [private]

Definition at line 79 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11DepthStencilView> ExtrudedTextRenderer::m_d3dDepthStencilView [private]

Definition at line 81 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11Device1> ExtrudedTextRenderer::m_d3dDevice [private]

Definition at line 78 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11RenderTargetView> ExtrudedTextRenderer::m_d3dRenderTargetView [private]

Definition at line 80 of file ExtrudedTextRenderer.h.

float ExtrudedTextRenderer::m_dpi [private]

Definition at line 83 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<IDWriteFactory1> ExtrudedTextRenderer::m_dwriteFactory [private]

Definition at line 77 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> ExtrudedTextRenderer::m_indexBuffer [private]

Definition at line 88 of file ExtrudedTextRenderer.h.

unsigned int ExtrudedTextRenderer::m_indexCount [private]

Definition at line 93 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> ExtrudedTextRenderer::m_inputLayout [private]

Definition at line 86 of file ExtrudedTextRenderer.h.

Windows::Foundation::Point ExtrudedTextRenderer::m_panPosition [private]

Definition at line 98 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> ExtrudedTextRenderer::m_pixelShader [private]

Definition at line 90 of file ExtrudedTextRenderer.h.

Windows::Foundation::Size ExtrudedTextRenderer::m_renderTargetSize [private]

Definition at line 82 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Geometry> ExtrudedTextRenderer::m_textGeometry [private]

Definition at line 101 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> ExtrudedTextRenderer::m_textLayout [private]

Definition at line 102 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> ExtrudedTextRenderer::m_vertexBuffer [private]

Definition at line 87 of file ExtrudedTextRenderer.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> ExtrudedTextRenderer::m_vertexShader [private]

Definition at line 89 of file ExtrudedTextRenderer.h.

float ExtrudedTextRenderer::m_zoom [private]

Definition at line 99 of file ExtrudedTextRenderer.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/ExtrudedTextRenderer.h
  • DirectX postcard app/C++/ExtrudedTextRenderer.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extruder Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Static Public Member Functions | Static Private Member Functions

Extruder Class Reference

#include "Extruder.h"

List of all members.

Classes

class | ExtrudingSink

Static Public Member Functions

static void | ExtrudeGeometry (ID2D1Geometry *pGeometry, float height, std::vector< SimpleVertex > *vertices)

Static Private Member Functions

static void | D2DFlatten (ID2D1Geometry *pGeometry, float flatteningTolerance, ID2D1Geometry **ppGeometry)
static void | D2DOutline (ID2D1Geometry *pGeometry, ID2D1Geometry **ppGeometry)

Detailed Description

Definition at line 19 of file Extruder.h.

Member Function Documentation

void Extruder::D2DFlatten | ( | ID2D1Geometry * | pGeometry,
 |  | float | flatteningTolerance,
 |  | ID2D1Geometry ** | ppGeometry |
 | ) |  |  | [static, private]

Definition at line 63 of file Extruder.cpp.

{
    ComPtr<ID2D1Factory> pFactory;
    pGeometry->GetFactory(&pFactory);

    ComPtr<ID2D1PathGeometry> pPathGeometry;
    DX::ThrowIfFailed(
        pFactory->CreatePathGeometry(&pPathGeometry)
        );

    ComPtr<ID2D1GeometrySink> pSink;
    DX::ThrowIfFailed(
        pPathGeometry->Open(&pSink)
        );

    DX::ThrowIfFailed(
        pGeometry->Simplify(
            D2D1_GEOMETRY_SIMPLIFICATION_OPTION_LINES,
            nullptr, // world transform
            flatteningTolerance,
            pSink.Get()
            )
        );

    DX::ThrowIfFailed(
        pSink->Close()
        );

    *ppGeometry = pPathGeometry.Get();
    (*ppGeometry)->AddRef();
}

void Extruder::D2DOutline | ( | ID2D1Geometry * | pGeometry,
 |  | ID2D1Geometry ** | ppGeometry |
 | ) |  |  | [static, private]

Definition at line 99 of file Extruder.cpp.

{
    ComPtr<ID2D1Factory> pFactory;
    pGeometry->GetFactory(&pFactory);

    ComPtr<ID2D1PathGeometry> pPathGeometry;
    DX::ThrowIfFailed(
        pFactory->CreatePathGeometry(&pPathGeometry)
        );

    ComPtr<ID2D1GeometrySink> pSink;
    DX::ThrowIfFailed(
        pPathGeometry->Open(&pSink)
        );

    DX::ThrowIfFailed(
        pGeometry->Outline(nullptr, pSink.Get())
        );

    DX::ThrowIfFailed(
        pSink->Close()
        );

    *ppGeometry = pPathGeometry.Get();
    (*ppGeometry)->AddRef();
}

void Extruder::ExtrudeGeometry | ( | ID2D1Geometry * | pGeometry,
 |  | float | height,
 |  | std::vector< SimpleVertex > * | vertices |
 | ) |  |  | [static]

Definition at line 15 of file Extruder.cpp.

{
    //
    // The basic idea here is to generate the side faces by walking the
    // geometry and constructing quads, and use ID2D1Geometry::Tessellate
    // to generate the front and back faces.
    //

    // Flatten our geometry first so we don't have to worry about stitching
    // together seams of Beziers.
    ComPtr<ID2D1Geometry> pFlattenedGeometry;
    D2DFlatten(pGeometry, FlatteningTolerance, &pFlattenedGeometry);

    // D2DOutline will remove any self-intersections. This is important to
    // ensure that the tessellator doesn't introduce new vertices (which
    // can cause T-junctions).
    ComPtr<ID2D1Geometry> pOutlinedGeometry;
    D2DOutline(pFlattenedGeometry.Get(), &pOutlinedGeometry);

    ComPtr<ID2D1Geometry> pSnappedGeometry;
    PointSnapper::SnapGeometry(pOutlinedGeometry.Get(), &pSnappedGeometry);

    ComPtr<ExtrudingSink> helper;
    ExtrudingSink::CreateExtrudingSink(height, vertices, &helper);

    DX::ThrowIfFailed(
        pSnappedGeometry->Tessellate(nullptr, helper.Get())
        );

    // Simplify is a convenient API for extracting the data out of a geometry.
    DX::ThrowIfFailed(
        pOutlinedGeometry->Simplify(
            D2D1_GEOMETRY_SIMPLIFICATION_OPTION_LINES,
            nullptr, // world transform
            helper.Get()
            )
        );

    // This Close() call is a little ambiguous, since it refers both to the
    // ID2D1TessellationSink and to the ID2D1SimplifiedGeometrySink.
    // Thankfully, it really doesn't matter with our ExtrudingSink.
    DX::ThrowIfFailed(
        helper->Close()
        );
}

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/Extruder.h
  • DirectX postcard app/C++/Extruder.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extruder::ExtrudingSink Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Extruder
  • Extruder::ExtrudingSink
Classes | Public Member Functions | Static Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Extruder::ExtrudingSink Class Reference

List of all members.

Classes

struct | Vertex2D

Public Member Functions

STDMETHOD() | Close ()
STDMETHOD() | QueryInterface (REFIID riid, _Outptr_ void **object) override
STDMETHOD_ (ULONG, AddRef)() override
STDMETHOD_ (void, AddLines)(const D2D1_POINT_2F *points
STDMETHOD_ (void, AddTriangles)(const D2D1_TRIANGLE *triangles
STDMETHOD_ (void, SetSegmentFlags)(D2D1_PATH_SEGMENT)
STDMETHOD_ (void, SetFillMode)(D2D1_FILL_MODE)
STDMETHOD_ (void, EndFigure)(D2D1_FIGURE_END)
STDMETHOD_ (void, AddBeziers)(const D2D1_BEZIER_SEGMENT *
STDMETHOD_ (void, BeginFigure)(D2D1_POINT_2F startPoint
STDMETHOD_ (ULONG, Release)() override

Static Public Member Functions

static void | CreateExtrudingSink (float height, _In_ std::vector< SimpleVertex > *pVertices, _Outptr_ ExtrudingSink **ppExtrudingSink)

Public Attributes

D2D1_FIGURE_BEGIN
UINT pointsCount
UINT trianglesCount
UINT

Private Member Functions

ExtrudingSink (float height, _In_ std::vector< SimpleVertex > *pVertices)
float2 | GetNormal (uint32 i)
float2 | Normalize (float2 pt)

Private Attributes

std::vector< Vertex2D > | m_figureVertices
float | m_height
D2D1_POINT_2F | m_lastPoint
ULONG | m_ref
D2D1_POINT_2F | m_startPoint
std::vector< SimpleVertex > * | m_vertices

Detailed Description

Definition at line 32 of file Extruder.h.

Constructor & Destructor Documentation

Extruder::ExtrudingSink::ExtrudingSink | ( | float | height,
 |  | _In_ std::vector< SimpleVertex > * | pVertices |
 | ) |  |  | [private]

Definition at line 143 of file Extruder.cpp.

                                                                                :
    m_height(height),
    m_vertices(pVertices),
    m_ref(0)
{
}

Member Function Documentation

HRESULT Extruder::ExtrudingSink::Close ( )

Definition at line 199 of file Extruder.cpp.

{
    return S_OK;
}

void Extruder::ExtrudingSink::CreateExtrudingSink | ( | float | height,
 |  | _In_ std::vector< SimpleVertex > * | pVertices,
 |  | _Outptr_ ExtrudingSink ** | ppExtrudingSink |
 | ) |  |  | [static]

Definition at line 133 of file Extruder.cpp.

{
    *ppExtrudingSink = new ExtrudingSink(height, pVertices);
    (*ppExtrudingSink)->AddRef();
}

float2 Extruder::ExtrudingSink::GetNormal ( uint32 i ) [private]

Definition at line 370 of file Extruder.cpp.

{
    uint32 j = (i+1) % m_figureVertices.size();

    float2 pti = m_figureVertices[i].pt;
    float2 ptj = m_figureVertices[j].pt;
    float2 vecij = ptj - pti;

    return Normalize(float2(vecij.y, vecij.x));
}

float2 Extruder::ExtrudingSink::Normalize ( float2 pt ) [private]

Definition at line 381 of file Extruder.cpp.

{
    return pt / sqrtf(pt.x*pt.x+pt.y*pt.y);
}

HRESULT Extruder::ExtrudingSink::QueryInterface | ( | REFIID | riid,
 |  | _Outptr_ void ** | object |
 | ) |  |  | [override]

Definition at line 392 of file Extruder.cpp.

{
    *object = nullptr;
    return E_NOTIMPL;
}

Extruder::ExtrudingSink::STDMETHOD_ | ( | void | ,
 |  | AddBeziers |  |
 | ) |  |  | const
Extruder::ExtrudingSink::STDMETHOD_ | ( | void | ,
 |  | AddTriangles |  |
 | ) |  |  | const
Extruder::ExtrudingSink::STDMETHOD_ | ( | void | ,
 |  | SetSegmentFlags |
 | ) |  |
Extruder::ExtrudingSink::STDMETHOD_ | ( | void | ,
 |  | EndFigure |
 | ) |  |
Extruder::ExtrudingSink::STDMETHOD_ | ( | void | ,
 |  | AddLines |  |
 | ) |  |  | const
Extruder::ExtrudingSink::STDMETHOD_ | ( | void | ,
 |  | SetFillMode |
 | ) |  |
Extruder::ExtrudingSink::STDMETHOD_ | ( | void | ,
 |  | BeginFigure |
 | ) |  |
Extruder::ExtrudingSink::STDMETHOD_ | ( | ULONG | ,
 |  | Release |  |
 | ) |  |  | [override]
Extruder::ExtrudingSink::STDMETHOD_ | ( | ULONG | ,
 |  | AddRef |  |
 | ) |  |  | [override]

Member Data Documentation

Extruder::ExtrudingSink::D2D1_FIGURE_BEGIN

Definition at line 44 of file Extruder.h.

std::vector<Vertex2D> Extruder::ExtrudingSink::m_figureVertices [private]

Definition at line 76 of file Extruder.h.

float Extruder::ExtrudingSink::m_height [private]

Definition at line 71 of file Extruder.h.

D2D1_POINT_2F Extruder::ExtrudingSink::m_lastPoint [private]

Definition at line 72 of file Extruder.h.

ULONG Extruder::ExtrudingSink::m_ref [private]

Definition at line 78 of file Extruder.h.

D2D1_POINT_2F Extruder::ExtrudingSink::m_startPoint [private]

Definition at line 73 of file Extruder.h.

std::vector<SimpleVertex>* Extruder::ExtrudingSink::m_vertices [private]

Definition at line 75 of file Extruder.h.

UINT Extruder::ExtrudingSink::pointsCount

Definition at line 43 of file Extruder.h.

UINT Extruder::ExtrudingSink::trianglesCount

Definition at line 49 of file Extruder.h.

Extruder::ExtrudingSink::UINT

Definition at line 42 of file Extruder.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/Extruder.h
  • DirectX postcard app/C++/Extruder.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extruder::ExtrudingSink::Vertex2D Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Extruder
  • Extruder::ExtrudingSink
  • Extruder::ExtrudingSink::Vertex2D
Public Attributes

Extruder::ExtrudingSink::Vertex2D Struct Reference

List of all members.

Public Attributes

float2 interpNorm1
float2 interpNorm2
float2 norm
float2 pt

Detailed Description

Definition at line 63 of file Extruder.h.

Member Data Documentation

float2 Extruder::ExtrudingSink::Vertex2D::interpNorm1

Definition at line 67 of file Extruder.h.

float2 Extruder::ExtrudingSink::Vertex2D::interpNorm2

Definition at line 68 of file Extruder.h.

float2 Extruder::ExtrudingSink::Vertex2D::norm

Definition at line 66 of file Extruder.h.

float2 Extruder::ExtrudingSink::Vertex2D::pt

Definition at line 65 of file Extruder.h.

The documentation for this struct was generated from the following file:
  • DirectX postcard app/C++/Extruder.h
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Face Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

Face Class Reference

#include "Face.h"

Inherits GameObject, and GameObject.

List of all members.

Public Member Functions

Face (DirectX::XMFLOAT3 origin, DirectX::XMFLOAT3 p1, DirectX::XMFLOAT3 p2)
Face (DirectX::XMFLOAT3 origin, DirectX::XMFLOAT3 p1, DirectX::XMFLOAT3 p2)
virtual bool | IsTouching (DirectX::XMFLOAT3 point, float radius, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal) override
virtual bool | IsTouching (DirectX::XMFLOAT3 point, float radius, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal) override
void | SetPlane (DirectX::XMFLOAT3 origin, DirectX::XMFLOAT3 p1, DirectX::XMFLOAT3 p2)
void | SetPlane (DirectX::XMFLOAT3 origin, DirectX::XMFLOAT3 p1, DirectX::XMFLOAT3 p2)

Public Attributes

internal | __pad0__: Face()

Protected Member Functions

virtual void | UpdatePosition () override
virtual void | UpdatePosition () override

Private Member Functions

void | UpdateMatrix ()
void | UpdateMatrix ()

Private Attributes

float | m_height
DirectX::XMFLOAT3 | m_heightVector
DirectX::XMFLOAT3 | m_normal
DirectX::XMFLOAT3 | m_point [4]
DirectX::XMFLOAT4X4 | m_rotationMatrix
float | m_width
DirectX::XMFLOAT3 | m_widthVector

Detailed Description

Definition at line 17 of file Face.h.

Constructor & Destructor Documentation

Face::Face | ( | DirectX::XMFLOAT3 | origin,
 |  | DirectX::XMFLOAT3 | p1,
 |  | DirectX::XMFLOAT3 | p2
 | ) |  |
Face::Face | ( | DirectX::XMFLOAT3 | origin,
 |  | DirectX::XMFLOAT3 | p1,
 |  | DirectX::XMFLOAT3 | p2
 | ) |  |

Member Function Documentation

virtual bool Face::IsTouching | ( | DirectX::XMFLOAT3 | point,
 |  | float | radius,
 |  | _Out_ DirectX::XMFLOAT3 * | contact,
 |  | _Out_ DirectX::XMFLOAT3 * | normal |
 | ) |  |  | [override, virtual]

Reimplemented from GameObject.

virtual bool Face::IsTouching | ( | DirectX::XMFLOAT3 | point,
 |  | float | radius,
 |  | _Out_ DirectX::XMFLOAT3 * | contact,
 |  | _Out_ DirectX::XMFLOAT3 * | normal |
 | ) |  |  | [override, virtual]

Reimplemented from GameObject.

void Face::SetPlane | ( | DirectX::XMFLOAT3 | origin,
 |  | DirectX::XMFLOAT3 | p1,
 |  | DirectX::XMFLOAT3 | p2
 | ) |  |
void Face::SetPlane | ( | DirectX::XMFLOAT3 | origin,
 |  | DirectX::XMFLOAT3 | p1,
 |  | DirectX::XMFLOAT3 | p2
 | ) |  |
void Face::UpdateMatrix ( ) [private]

Definition at line 192 of file Face.cpp.

{
    // Determine the Model transform for the cannonical face to align with the position
    // and orientation of the defined face.  The cannonical face geometry is
    // a rectangle at the origin extending 1 unit in the +X and 1 unit in the +Y direction.

    XMVECTOR w = XMVectorSet(1.0f, 0.0f, 0.0f, 1.0f);
    XMVECTOR h = XMVectorSet(0.0f, 1.0f, 0.0f, 1.0f);
    XMVECTOR epsilon = XMVectorReplicate(0.0001f);
    XMVECTOR width = XMVectorScale(XMLoadFloat3(&m_widthVector), 1.0f / m_width);
    XMVECTOR height = XMVectorScale(XMLoadFloat3(&m_heightVector), 1.0f / m_height);
    XMMATRIX mat1 = XMMatrixIdentity();
    XMMATRIX mat2 = XMMatrixIdentity();

    // Determine the necessary rotation to align the widthVector with the +X axis.
    // Then apply the rotation to the cannonical H vector (+Y).
    if (!XMVector3NearEqual(w, width, epsilon))
    {
        float angle1 = XMVectorGetX(
            XMVector3AngleBetweenVectors(w, width)
            );

        if (XMVector3NearEqual(w, XMVectorNegate(width), epsilon))
        {
            // The angle between w and width is ~180 degrees, so
            // pick a axis of rotation perpendicular to the W vector.
            mat1 = XMMatrixRotationAxis(XMVector3Orthogonal(w), angle1);
            h = XMVector3TransformCoord(h, mat1);
        }
        else if ((angle1 * angle1) > 0.025)
        {
            // Take the cross product between the w and width vectors to
            // determine the axis to rotate that is perpendicular to both vectors.
            XMVECTOR axis1 = XMVector3Cross(w, width);
            mat1 = XMMatrixRotationAxis(axis1, angle1);
            h = XMVector3TransformCoord(h, mat1);
        }
    }

    // Determine the necessary rotation to align the transformed heightVector
    // with the transformed H vector.
    if (!XMVector3NearEqual(h, height, epsilon))
    {
        float angle2 = XMVectorGetX(
            XMVector3AngleBetweenVectors(h, height)
            );

        if (XMVector3NearEqual(h, XMVectorNegate(height), epsilon))
        {
            // The angle between the h' and height vectors is ~180 degrees,
            // so rotate around the width vector to keep it aligned in the right
            // place.
            mat2 = XMMatrixRotationAxis(width, angle2);
        }
        else if ((angle2 * angle2) > 0.025)
        {
            // Take the cross product between the h' and height vectors
            // to determine the axis to rotate that is perpendicular to both vectors.
            XMVECTOR axis2 = XMVector3Cross(h, height);
            mat2 = XMMatrixRotationAxis(axis2, angle2);
        }
    }
    XMStoreFloat4x4(&m_rotationMatrix, mat1 * mat2);

    // Generate the composite matrix to scale, rotate and translate to cannonical
    // face geometry to be positioned correctly in world space.
    XMStoreFloat4x4(
        &m_modelMatrix,
        XMMatrixScaling(m_width, m_height, 1.0f) *
        mat1 *
        mat2 *
        XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
        );
}

void Face::UpdateMatrix ( ) [private]
void Face::UpdatePosition ( ) [override, protected, virtual]

Reimplemented from GameObject.

Definition at line 69 of file Face.cpp.

{
    m_point[0] = m_position;
    XMStoreFloat3(&m_point[1], XMLoadFloat3(&m_position) + XMLoadFloat3(&m_widthVector));
    XMStoreFloat3(&m_point[3], XMLoadFloat3(&m_position) + XMLoadFloat3(&m_heightVector));
    XMStoreFloat3(&m_point[2], XMLoadFloat3(&m_point[1]) + XMLoadFloat3(&m_heightVector));

    XMStoreFloat4x4(
        &m_modelMatrix,
        XMMatrixScaling(m_width, m_height, 1.0f) *
        XMLoadFloat4x4(&m_rotationMatrix) *
        XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
        );
}

virtual void Face::UpdatePosition ( ) [override, protected, virtual]

Reimplemented from GameObject.

Member Data Documentation

internal Face::__pad0__

Reimplemented from GameObject.

Definition at line 20 of file Face.h.

float Face::m_height [private]

Definition at line 51 of file Face.h.

DirectX::XMFLOAT3 Face::m_heightVector [private]

Definition at line 47 of file Face.h.

DirectX::XMFLOAT3 Face::m_normal [private]

Definition at line 48 of file Face.h.

DirectX::XMFLOAT3 Face::m_point [private]

Definition at line 49 of file Face.h.

DirectX::XMFLOAT4X4 Face::m_rotationMatrix [private]

Definition at line 52 of file Face.h.

float Face::m_width [private]

Definition at line 50 of file Face.h.

DirectX::XMFLOAT3 Face::m_widthVector [private]

Definition at line 46 of file Face.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Face.h
  • XAML DirectX 3D shooting game/C++/Face.h
  • DirectX 3D shooting game/C++/Face.cpp
  • XAML DirectX 3D shooting game/C++/Face.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FaceMesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

FaceMesh Class Reference

#include "FaceMesh.h"

List of all members.

Public Attributes

internal __pad0__: FaceMesh(_In_ ID3D11Device *device)

Detailed Description

Definition at line 20 of file FaceMesh.h.

Member Data Documentation

internal FaceMesh::__pad0__

Definition at line 23 of file FaceMesh.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/FaceMesh.h
  • XAML DirectX 3D shooting game/C++/FaceMesh.h
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FontEnumeration::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • FontEnumeration
  • FontEnumeration::sealed
Public Member Functions

FontEnumeration::sealed Class Reference

#include "FontEnumerator.h"

List of all members.

Public Member Functions

Platform::Array< Platform::String^> ListSystemFonts ()

Detailed Description

Definition at line 5 of file FontEnumerator.h.

Member Function Documentation

Platform::Array<Platform::String^> FontEnumeration::sealed::ListSystemFonts ( )
The documentation for this class was generated from the following file:
  • DirectWrite font enumeration/C++,JavaScript/cpp/FontEnumerator.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FontFileStream Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

FontFileStream Class Reference

#include "FontFileStream.h"

List of all members.

Public Member Functions

FontFileStream (_In_ Platform::Array< byte >^data)
virtual ULONG STDMETHODCALLTYPE | AddRef () override
virtual HRESULT STDMETHODCALLTYPE | GetFileSize (_Out_ UINT64 *fileSize) override
virtual HRESULT STDMETHODCALLTYPE | GetLastWriteTime (_Out_ UINT64 *lastWriteTime) override
virtual HRESULT STDMETHODCALLTYPE | QueryInterface (REFIID uuid, _Outptr_ void **object) override
virtual HRESULT STDMETHODCALLTYPE | ReadFileFragment (_Outptr_result_bytebuffer_(fragmentSize) void const **fragmentStart, UINT64 fileOffset, UINT64 fragmentSize, _Out_ void **fragmentContext) override
virtual ULONG STDMETHODCALLTYPE | Release () override
virtual void STDMETHODCALLTYPE | ReleaseFileFragment (_In_ void *fragmentContext) override

Private Attributes

Platform::Array< byte > | m_data
ULONG | m_refCount

Detailed Description

Definition at line 10 of file FontFileStream.h.

Constructor & Destructor Documentation

FontFileStream::FontFileStream ( _In_ Platform::Array< byte >^ data )

Definition at line 10 of file FontFileStream.cpp.

                                                             :
    m_refCount(),
    m_data(data)
{
}

Member Function Documentation

ULONG STDMETHODCALLTYPE FontFileStream::AddRef ( ) [override, virtual]

Definition at line 36 of file FontFileStream.cpp.

{
    return static_cast<ULONG>(InterlockedIncrement(&m_refCount));
}

HRESULT STDMETHODCALLTYPE FontFileStream::GetFileSize ( _Out_ UINT64 * fileSize ) [override, virtual]

Definition at line 83 of file FontFileStream.cpp.

{
    *fileSize = m_data->Length;
    return S_OK;
}

HRESULT STDMETHODCALLTYPE FontFileStream::GetLastWriteTime ( _Out_ UINT64 * lastWriteTime ) [override, virtual]

Definition at line 91 of file FontFileStream.cpp.

{
    // The concept of last write time does not apply to this loader.
    *lastWriteTime = 0;
    return E_NOTIMPL;
}

HRESULT STDMETHODCALLTYPE FontFileStream::QueryInterface | ( | REFIID | uuid,
 |  | _Outptr_ void ** | object |
 | ) |  |  | [override, virtual]

Definition at line 16 of file FontFileStream.cpp.

{
    if (    uuid == IID_IUnknown
        ||  uuid == __uuidof(IDWriteFontFileStream)
        )
    {
        *object = this;
        AddRef();
        return S_OK;
    }
    else
    {
        *object = nullptr;
        return E_NOINTERFACE;
    }
}

HRESULT STDMETHODCALLTYPE FontFileStream::ReadFileFragment | ( | _Outptr_result_bytebuffer_(fragmentSize) void const ** | fragmentStart,
 |  | UINT64 | fileOffset,
 |  | UINT64 | fragmentSize,
 |  | _Out_ void ** | fragmentContext |
 | ) |  |  | [override, virtual]

Definition at line 53 of file FontFileStream.cpp.

{
    // The loader is responsible for doing a bounds check.
    if (    fileOffset <= m_data->Length
        &&  fragmentSize + fileOffset <= m_data->Length
        )
    {
        *fragmentStart = m_data->Data + static_cast<ULONG>(fileOffset);
        *fragmentContext = nullptr;
        return S_OK;
    }
    else
    {
        *fragmentStart = nullptr;
        *fragmentContext = nullptr;
        return E_FAIL;
    }
}

ULONG STDMETHODCALLTYPE FontFileStream::Release ( ) [override, virtual]

Definition at line 41 of file FontFileStream.cpp.

{
    ULONG newCount = static_cast<ULONG>(InterlockedDecrement(&m_refCount));

    if (newCount == 0)
    {
        delete this;
    }

    return newCount;
}

void STDMETHODCALLTYPE FontFileStream::ReleaseFileFragment ( _In_ void * fragmentContext ) [override, virtual]

Definition at line 77 of file FontFileStream.cpp.

{
}

Member Data Documentation

Platform::Array<byte> FontFileStream::m_data [private]

Definition at line 48 of file FontFileStream.h.

ULONG FontFileStream::m_refCount [private]

Definition at line 45 of file FontFileStream.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/FontFileStream.h
  • Direct2D magazine app/C++/FontFileStream.cpp
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FontLoader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

FontLoader Class Reference

#include "FontLoader.h"

List of all members.

Public Member Functions

FontLoader (_In_ Windows::Storage::StorageFolder^location, _In_ IDWriteFactory *dwriteFactory)
virtual ULONG STDMETHODCALLTYPE | AddRef () override
virtual HRESULT STDMETHODCALLTYPE | CreateEnumeratorFromKey (_In_ IDWriteFactory *factory, _In_reads_bytes_(fontCollectionKeySize) void const *fontCollectionKey, uint32 fontCollectionKeySize, _Outptr_ IDWriteFontFileEnumerator **fontFileEnumerator) override
virtual HRESULT STDMETHODCALLTYPE | CreateStreamFromKey (_In_reads_bytes_(fontFileReferenceKeySize) void const *fontFileReferenceKey, uint32 fontFileReferenceKeySize, _Outptr_ IDWriteFontFileStream **fontFileStream) override
virtual HRESULT STDMETHODCALLTYPE | GetCurrentFontFile (OUT IDWriteFontFile **currentFontFile) override
concurrency::task< void > | LoadAsync ()
virtual HRESULT STDMETHODCALLTYPE | MoveNext (OUT BOOL *hasCurrentFile) override
virtual HRESULT STDMETHODCALLTYPE | QueryInterface (REFIID uuid, _Outptr_ void **object) override
virtual ULONG STDMETHODCALLTYPE | Release () override

Private Attributes

Microsoft::WRL::ComPtr
< IDWriteFontFile > 		m_currentFontFile
Microsoft::WRL::ComPtr
< IDWriteFactory > 		m_dwriteFactory
size_t | m_fontFileCount
size_t | m_fontFileStreamIndex
std::vector
< Microsoft::WRL::ComPtr
< FontFileStream > > 		m_fontFileStreams
Windows::Storage::StorageFolder | m_location
ULONG | m_refCount

Detailed Description

Definition at line 19 of file FontLoader.h.

Constructor & Destructor Documentation

FontLoader::FontLoader | ( | _In_ Windows::Storage::StorageFolder^ | location,
 |  | _In_ IDWriteFactory * | dwriteFactory
 | ) |  |

Member Function Documentation

ULONG STDMETHODCALLTYPE FontLoader::AddRef ( ) [override, virtual]

Definition at line 96 of file FontLoader.cpp.

{
    return static_cast<ULONG>(InterlockedIncrement(&m_refCount));
}

HRESULT STDMETHODCALLTYPE FontLoader::CreateEnumeratorFromKey | ( | _In_ IDWriteFactory * | factory,
 |  | _In_reads_bytes_(fontCollectionKeySize) void const * | fontCollectionKey,
 |  | uint32 | fontCollectionKeySize,
 |  | _Outptr_ IDWriteFontFileEnumerator ** | fontFileEnumerator |
 | ) |  |  | [override, virtual]

Definition at line 115 of file FontLoader.cpp.

{
    *fontFileEnumerator = ComPtr<IDWriteFontFileEnumerator>(this).Detach();
    return S_OK;
}

HRESULT STDMETHODCALLTYPE FontLoader::CreateStreamFromKey | ( | _In_reads_bytes_(fontFileReferenceKeySize) void const * | fontFileReferenceKey,
 |  | uint32 | fontFileReferenceKeySize,
 |  | _Outptr_ IDWriteFontFileStream ** | fontFileStream |
 | ) |  |  | [override, virtual]

Definition at line 158 of file FontLoader.cpp.

{
    if (fontFileReferenceKeySize != sizeof(size_t))
    {
        return E_INVALIDARG;
    }

    size_t fontFileStreamIndex = *(static_cast<size_t const*>(fontFileReferenceKey));

    *fontFileStream = ComPtr<IDWriteFontFileStream>(m_fontFileStreams.at(fontFileStreamIndex).Get()).Detach();

    return S_OK;
}

HRESULT STDMETHODCALLTYPE FontLoader::GetCurrentFontFile ( OUT IDWriteFontFile ** currentFontFile ) [override, virtual]

Definition at line 148 of file FontLoader.cpp.

{
    *currentFontFile = ComPtr<IDWriteFontFile>(m_currentFontFile.Get()).Detach();
    return S_OK;
}

task< void > FontLoader::LoadAsync ( )

Definition at line 32 of file FontLoader.cpp.

{
    // Locate the "fonts" sub-folder within the document folder
    return task<StorageFolder^>(m_location->GetFolderAsync("fonts")).then([=](StorageFolder^ folder)
    {
        // Enumerate a list of .TTF files in the storage location
        auto filters = ref new Platform::Collections::Vector<Platform::String^>();
        filters->Append(".ttf");

        auto queryOptions = ref new QueryOptions(CommonFileQuery::DefaultQuery, filters);
        auto queryResult = folder->CreateFileQueryWithOptions(queryOptions);

        return queryResult->GetFilesAsync();

    }).then([=](IVectorView<StorageFile^>^ files)
    {
        m_fontFileCount = files->Size;

        std::vector<task<IBuffer^>> tasks;

        for (uint32 i = 0; i < m_fontFileCount; ++i)
        {
            auto file = dynamic_cast<StorageFile^>(files->GetAt(i));

            tasks.push_back(task<IBuffer^>(FileIO::ReadBufferAsync(file)));
        }

        return when_all(tasks.begin(), tasks.end());

    }).then([=](std::vector<IBuffer^> buffers)
    {
        for each (IBuffer^ buffer in buffers)
        {
            auto fileData = ref new Platform::Array<byte>(buffer->Length);
            DataReader::FromBuffer(buffer)->ReadBytes(fileData);

            ComPtr<FontFileStream> fontFileStream(new FontFileStream(fileData));
            m_fontFileStreams.push_back(fontFileStream);
        }
    });
}

HRESULT STDMETHODCALLTYPE FontLoader::MoveNext ( OUT BOOL * hasCurrentFile ) [override, virtual]

Definition at line 126 of file FontLoader.cpp.

{
    *hasCurrentFile = FALSE;

    if (m_fontFileStreamIndex < m_fontFileCount)
    {
        DX::ThrowIfFailed(
            m_dwriteFactory->CreateCustomFontFileReference(
                &m_fontFileStreamIndex,
                sizeof(size_t),
                this,
                &m_currentFontFile
                )
            );

        *hasCurrentFile = TRUE;
        ++m_fontFileStreamIndex;
    }

    return S_OK;
}

HRESULT STDMETHODCALLTYPE FontLoader::QueryInterface | ( | REFIID | uuid,
 |  | _Outptr_ void ** | object |
 | ) |  |  | [override, virtual]

Definition at line 74 of file FontLoader.cpp.

{
    if (    uuid == IID_IUnknown
        ||  uuid == __uuidof(IDWriteFontCollectionLoader)
        ||  uuid == __uuidof(IDWriteFontFileEnumerator)
        ||  uuid == __uuidof(IDWriteFontFileLoader)
        )
    {
        *object = this;
        AddRef();
        return S_OK;
    }
    else
    {
        *object = nullptr;
        return E_NOINTERFACE;
    }
}

ULONG STDMETHODCALLTYPE FontLoader::Release ( ) [override, virtual]

Definition at line 101 of file FontLoader.cpp.

{
    ULONG newCount = static_cast<ULONG>(InterlockedDecrement(&m_refCount));

    if (newCount == 0)
        delete this;

    return newCount;
}

Member Data Documentation

Microsoft::WRL::ComPtr<IDWriteFontFile> FontLoader::m_currentFontFile [private]

Definition at line 78 of file FontLoader.h.

Microsoft::WRL::ComPtr<IDWriteFactory> FontLoader::m_dwriteFactory [private]

Definition at line 81 of file FontLoader.h.

size_t FontLoader::m_fontFileCount [private]

Definition at line 69 of file FontLoader.h.

size_t FontLoader::m_fontFileStreamIndex [private]

Definition at line 75 of file FontLoader.h.

std::vector<Microsoft::WRL::ComPtr<FontFileStream> > FontLoader::m_fontFileStreams [private]

Definition at line 72 of file FontLoader.h.

Windows::Storage::StorageFolder FontLoader::m_location [private]

Definition at line 66 of file FontLoader.h.

ULONG FontLoader::m_refCount [private]

Definition at line 63 of file FontLoader.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/FontLoader.h
  • Direct2D magazine app/C++/FontLoader.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FPSCounter Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

FPSCounter Class Reference

#include "FPSCounter.h"

List of all members.

Classes

struct | AtlasText

Public Member Functions

void | Initialize ()
void | Render ()

Public Attributes

internal | __pad0__: FPSCounter( _In_ ID2D1DeviceContext* d2dContext
internal _In_ float | dpi
internal _In_ float _In_
Platform::String _In_
IDWriteTextFormat _In_
D2D1_POINT_2F 		position
internal _In_ float _In_
Platform::String 		text
internal _In_ float _In_
Platform::String _In_
IDWriteTextFormat * 		textFormat

Private Member Functions

int | DipsToPixelsRoundDown (float value)
int | DipsToPixelsRoundUp (float value)
void | DrawAtlasText (_In_ const AtlasText &atlasText, _In_ D2D1_POINT_2F offset)
float | PixelsToDips (int value)
void | PositionAtlasText (_In_ Platform::String^text, _In_ D2D1_POINT_2U offsetInAtlas, _Outptr_ IDWriteTextLayout **layout, _Out_ AtlasText *atlasText)

Private Attributes

AtlasText | m_cachedDigits [10]
AtlasText m_cachedStaticText
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
float | m_dpi
Microsoft::WRL::ComPtr
< IDWriteFactory > 		m_dwriteFactory
Microsoft::WRL::ComPtr
< IDXGIDevice2 > 		m_dxgiDevice
D2D1_POINT_2U | m_firstDigitOffset
D2D1_POINT_2F | m_position
Platform::String | m_staticText
Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_textAtlasBitmap
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
std::list< int > | m_times

Detailed Description

Definition at line 19 of file FPSCounter.h.

Member Function Documentation

int FPSCounter::DipsToPixelsRoundDown ( float value ) [private]

Definition at line 324 of file FPSCounter.cpp.

{
    return static_cast<int>(floor(value * m_dpi / 96.0f));
}

int FPSCounter::DipsToPixelsRoundUp ( float value ) [private]

Definition at line 330 of file FPSCounter.cpp.

{
    return static_cast<int>(ceil(value * m_dpi / 96.0f));
}

void FPSCounter::DrawAtlasText | ( | _In_ const AtlasText & | atlasText,
 |  | _In_ D2D1_POINT_2F | offset |
 | ) |  |  | [private]

Definition at line 246 of file FPSCounter.cpp.

{
    D2D1_ANTIALIAS_MODE oldAAMode = m_d2dContext->GetAntialiasMode();
    m_d2dContext->SetAntialiasMode(D2D1_ANTIALIAS_MODE_ALIASED);

    D2D1_RECT_F sourceRect;
    sourceRect.left = PixelsToDips(atlasText.atlasRect.left);
    sourceRect.top = PixelsToDips(atlasText.atlasRect.top);
    sourceRect.right = PixelsToDips(atlasText.atlasRect.right);
    sourceRect.bottom = PixelsToDips(atlasText.atlasRect.bottom);

    D2D1_RECT_F destRect;
    destRect.left = offset.x + PixelsToDips(atlasText.originOffset.x);
    destRect.top = offset.y + PixelsToDips(atlasText.originOffset.y);
    destRect.right = destRect.left + sourceRect.right - sourceRect.left;
    destRect.bottom = destRect.top + sourceRect.bottom - sourceRect.top;

    m_d2dContext->FillOpacityMask(
        m_textAtlasBitmap.Get(),
        m_textBrush.Get(),
        destRect,
        sourceRect
        );

    m_d2dContext->SetAntialiasMode(oldAAMode);
}

void FPSCounter::Initialize ( )

Definition at line 29 of file FPSCounter.cpp.

{
    DX::ThrowIfFailed(
        DWriteCreateFactory(
            DWRITE_FACTORY_TYPE_SHARED,
            __uuidof(IDWriteFactory),
            &m_dwriteFactory
            )
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_textBrush
            )
        );

    // The static text will be placed at the top left corner of the atlas

    ComPtr<IDWriteTextLayout> staticTextLayout;

    PositionAtlasText(
        m_staticText,
        D2D1::Point2U(0, 0), // offsetInAtlas
        &staticTextLayout,
        &m_cachedStaticText
        );

    // Determine the offset for the FPS counter. We place
    // the FPS counter on screen just to the right
    // of the last character in the text layout.

    float pointX;
    float pointY;
    DWRITE_HIT_TEST_METRICS hitTestMetrics;
    DX::ThrowIfFailed(
        staticTextLayout->HitTestTextPosition(
            m_staticText->Length() - 1, // textPosition
            TRUE, // isTrailingHit
            &pointX,
            &pointY,
            &hitTestMetrics
            )
        );

    m_firstDigitOffset.x = static_cast<uint32>(pointX);
    m_firstDigitOffset.y = static_cast<uint32>(pointY);

    // Position each digit in the atlas just to the right of everything else
    // we've already positioned. At the same time, grow the atlas size to ensure
    // that it is big enough.
    //
    // Note that more general atlasing approaches will position various elements
    // in an atlas in two dimensions. This class only grows the atlas in one
    // dimension.

    uint32 bitmapWidth = m_cachedStaticText.atlasRect.right - m_cachedStaticText.atlasRect.left;
    uint32 bitmapHeight = m_cachedStaticText.atlasRect.bottom - m_cachedStaticText.atlasRect.top;

    ComPtr<IDWriteTextLayout> digitLayouts[10];
    for (uint32 i = 0; i < 10; i++)
    {
        char16 digit = static_cast<char16>(L'0' + i);

        PositionAtlasText(
            digit.ToString(),
            D2D1::Point2U(bitmapWidth, 0), // offsetInAtlas
            &digitLayouts[i],
            &m_cachedDigits[i]
            );

        bitmapWidth += m_cachedDigits[i].atlasRect.right - m_cachedDigits[i].atlasRect.left;
        bitmapHeight = max(bitmapHeight, m_cachedDigits[i].atlasRect.bottom - m_cachedDigits[i].atlasRect.top);
    }

    // This class does not handle the case where the text is so big that it
    // doesn't fit in the atlas. More generally, an atlasing approach would need
    // to create several atlas bitmaps when one bitmap is not large enough to
    // hold all the content required.

    if (bitmapWidth > m_d2dContext->GetMaximumBitmapSize() ||
        bitmapHeight > m_d2dContext->GetMaximumBitmapSize()
        )
    {
        DX::ThrowIfFailed(E_UNEXPECTED);
    }

    // Now that we know how big the atlas should be, create the atlas bitmap.
    // We use an A8 format since we are only storing text in this atlas and
    // don't need to store the color of the text to do this.

    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmap(
            D2D1::SizeU(bitmapWidth, bitmapHeight),
            nullptr,
            0,
            D2D1::BitmapProperties1(
                D2D1_BITMAP_OPTIONS_TARGET,
                D2D1::PixelFormat(DXGI_FORMAT_A8_UNORM, D2D1_ALPHA_MODE_STRAIGHT),
                m_dpi,
                m_dpi
                ),
            &m_textAtlasBitmap
            )
        );

    // Get the Dxgi device from the bitmap

    ComPtr<IDXGISurface> dxgiSurface;
    DX::ThrowIfFailed(
        m_textAtlasBitmap->GetSurface(&dxgiSurface)
        );

    DX::ThrowIfFailed(
        dxgiSurface->GetDevice(IID_PPV_ARGS(&m_dxgiDevice))
        );

    // Draw all the text into the atlas

    ComPtr<ID2D1Image> oldTarget;
    m_d2dContext->GetTarget(&oldTarget);

    m_d2dContext->SetTarget(m_textAtlasBitmap.Get());
    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black, 0.0f));

    m_d2dContext->DrawTextLayout(
        D2D1::Point2F(
            PixelsToDips(m_cachedStaticText.atlasRect.left - m_cachedStaticText.originOffset.x),
            PixelsToDips(m_cachedStaticText.atlasRect.top - m_cachedStaticText.originOffset.y)
            ),
        staticTextLayout.Get(),
        m_textBrush.Get()
        );

    for (uint32 i = 0; i < 10; i++)
    {
        m_d2dContext->DrawTextLayout(
            D2D1::Point2F(
                PixelsToDips(m_cachedDigits[i].atlasRect.left - m_cachedDigits[i].originOffset.x),
                PixelsToDips(m_cachedDigits[i].atlasRect.top - m_cachedDigits[i].originOffset.y)
                ),
            digitLayouts[i].Get(),
            m_textBrush.Get()
            );
    }

    m_d2dContext->SetTarget(oldTarget.Get());
}

float FPSCounter::PixelsToDips ( int value ) [private]

Definition at line 336 of file FPSCounter.cpp.

{
    return static_cast<float>(value) * 96.0f / m_dpi;
}

void FPSCounter::PositionAtlasText | ( | _In_ Platform::String^ | text,
 |  | _In_ D2D1_POINT_2U | offsetInAtlas,
 |  | _Outptr_ IDWriteTextLayout ** | layout,
 |  | _Out_ AtlasText * | atlasText |
 | ) |  |  | [private]

Definition at line 181 of file FPSCounter.cpp.

{
    // Create the text layout

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            text->Data(),
            text->Length(),
            m_textFormat.Get(),
            0.0f,
            0.0f,
            layout
            )
        );

    DX::ThrowIfFailed(
        (*layout)->SetWordWrapping(DWRITE_WORD_WRAPPING_NO_WRAP)
        );

    // Get the text metrics and compute the black box.

    DWRITE_TEXT_METRICS textMetrics;
    DX::ThrowIfFailed(
        (*layout)->GetMetrics(&textMetrics)
        );

    DWRITE_OVERHANG_METRICS overhangMetrics;
    DX::ThrowIfFailed(
        (*layout)->GetOverhangMetrics(&overhangMetrics)
        );

    // We use the overhang metrics here to determine the black box for the text.
    // The extra pixel of padding is added to make sure that we have enough
    // space reserved for an extra pixel of antialiasing falloff.
    D2D1_RECT_L blackBox = {
        DipsToPixelsRoundDown(-overhangMetrics.left) - 1,
        DipsToPixelsRoundDown(-overhangMetrics.top) - 1,
        DipsToPixelsRoundUp(overhangMetrics.right + textMetrics.layoutWidth) + 1,
        DipsToPixelsRoundUp(overhangMetrics.bottom + textMetrics.layoutHeight) + 1
    };

    // Fill in the atlas text position.

    atlasText->advanceWidth = DipsToPixelsRoundUp(textMetrics.widthIncludingTrailingWhitespace);

    atlasText->atlasRect = D2D1::RectU(
        offsetInAtlas.x,
        offsetInAtlas.y,
        offsetInAtlas.x + blackBox.right - blackBox.left,
        offsetInAtlas.y + blackBox.bottom - blackBox.top
        );

    atlasText->originOffset = D2D1::Point2L(
        blackBox.left,
        blackBox.top
        );
}

void FPSCounter::Render ( )

Definition at line 277 of file FPSCounter.cpp.

{
    // Calculate the FPS
    LARGE_INTEGER frequency;
    QueryPerformanceFrequency(&frequency);

    LARGE_INTEGER time;
    QueryPerformanceCounter(&time);

    if (m_times.size() == 50)
    {
        m_times.pop_front();
    }
    m_times.push_back(static_cast<int>(time.QuadPart));

    uint32 fps = 0;
    if (m_times.size() >= 2)
    {
        fps = static_cast<uint32>(
            0.5f +
            (static_cast<float>(m_times.size()-1) * static_cast<float>(frequency.QuadPart)) /
            static_cast<float>(m_times.back() - m_times.front())
            );
    }

    // Draw the static text

    D2D1_POINT_2F currentPosition = m_position;

    DrawAtlasText(m_cachedStaticText, currentPosition);
    currentPosition.x += m_firstDigitOffset.x;
    currentPosition.y += m_firstDigitOffset.y;

    // Draw the FPS number

    Platform::String^ fpsString = fps.ToString();

    for (uint32 i = 0; i < fpsString->Length(); i++)
    {
        uint32 digitIndex = fpsString->Data()[i] - '0';

        DrawAtlasText(m_cachedDigits[digitIndex], currentPosition);
        currentPosition.x += PixelsToDips(m_cachedDigits[digitIndex].advanceWidth);
    }
}

Member Data Documentation

internal FPSCounter::__pad0__

Definition at line 23 of file FPSCounter.h.

internal _In_ float FPSCounter::dpi

Definition at line 23 of file FPSCounter.h.

AtlasText FPSCounter::m_cachedDigits[10] [private]

Definition at line 73 of file FPSCounter.h.

AtlasText FPSCounter::m_cachedStaticText [private]

Definition at line 71 of file FPSCounter.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> FPSCounter::m_d2dContext [private]

Definition at line 61 of file FPSCounter.h.

float FPSCounter::m_dpi [private]

Definition at line 62 of file FPSCounter.h.

Microsoft::WRL::ComPtr<IDWriteFactory> FPSCounter::m_dwriteFactory [private]

Definition at line 64 of file FPSCounter.h.

Microsoft::WRL::ComPtr<IDXGIDevice2> FPSCounter::m_dxgiDevice [private]

Definition at line 63 of file FPSCounter.h.

D2D1_POINT_2U FPSCounter::m_firstDigitOffset [private]

Definition at line 72 of file FPSCounter.h.

D2D1_POINT_2F FPSCounter::m_position [private]

Definition at line 70 of file FPSCounter.h.

Platform::String FPSCounter::m_staticText [private]

Definition at line 65 of file FPSCounter.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap1> FPSCounter::m_textAtlasBitmap [private]

Definition at line 68 of file FPSCounter.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> FPSCounter::m_textBrush [private]

Definition at line 67 of file FPSCounter.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> FPSCounter::m_textFormat [private]

Definition at line 66 of file FPSCounter.h.

std::list<int> FPSCounter::m_times [private]

Definition at line 74 of file FPSCounter.h.

internal _In_ float _In_ Platform::String _In_ IDWriteTextFormat _In_ D2D1_POINT_2F FPSCounter::position

Definition at line 23 of file FPSCounter.h.

internal _In_ float _In_ Platform::String FPSCounter::text

Definition at line 23 of file FPSCounter.h.

internal _In_ float _In_ Platform::String _In_ IDWriteTextFormat* FPSCounter::textFormat

Definition at line 23 of file FPSCounter.h.

The documentation for this class was generated from the following files:
  • Direct2D geometry realization/C++/FPSCounter.h
  • Direct2D geometry realization/C++/FPSCounter.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FPSCounter::AtlasText Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • FPSCounter
  • FPSCounter::AtlasText
Public Attributes

FPSCounter::AtlasText Struct Reference

List of all members.

Public Attributes

uint32 | advanceWidth
D2D1_RECT_U | atlasRect
D2D1_POINT_2L | originOffset

Detailed Description

Definition at line 38 of file FPSCounter.h.

Member Data Documentation

uint32 FPSCounter::AtlasText::advanceWidth

Definition at line 42 of file FPSCounter.h.

D2D1_RECT_U FPSCounter::AtlasText::atlasRect

Definition at line 40 of file FPSCounter.h.

D2D1_POINT_2L FPSCounter::AtlasText::originOffset

Definition at line 41 of file FPSCounter.h.

The documentation for this struct was generated from the following file:
  • Direct2D geometry realization/C++/FPSCounter.h
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FractalBufferElement Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

FractalBufferElement Struct Reference

#include "DirectXFractal.h"

List of all members.

Public Attributes

int iteration

Detailed Description

Definition at line 90 of file DirectXFractal.h.

Member Data Documentation

int FractalBufferElement::iteration

Definition at line 92 of file DirectXFractal.h.

The documentation for this struct was generated from the following file:
  • Direct3D HLSL fractal generator/C++/DirectXFractal.h
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FractalVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

FractalVertex Struct Reference

#include "DirectXFractal.h"

List of all members.

Public Attributes

float2 bounds
float2 pos
float2 tex

Detailed Description

Definition at line 63 of file DirectXFractal.h.

Member Data Documentation

float2 FractalVertex::bounds

Definition at line 67 of file DirectXFractal.h.

float2 FractalVertex::pos

Definition at line 65 of file DirectXFractal.h.

float2 FractalVertex::tex

Definition at line 66 of file DirectXFractal.h.

The documentation for this struct was generated from the following file:
  • Direct3D HLSL fractal generator/C++/DirectXFractal.h
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FrameData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

FrameData Struct Reference

#include "FrameData.h"

List of all members.

Public Member Functions

FrameData ()

Public Attributes

int | m_BBP
int | m_colorPlanes
unsigned int | m_endHeight
unsigned int | m_endWidth
int | m_neighbourArea
byte * | m_pFrame
FrameProcessing * m_pFrameProcessor
int | m_phaseCount
int | m_pitch
int | m_size
unsigned int | m_startHeight
unsigned int | m_startWidth

Detailed Description

Definition at line 11 of file FrameData.h.

Constructor & Destructor Documentation

FrameData::FrameData ( ) [inline]

Definition at line 26 of file FrameData.h.

    {
        m_neighbourArea = 3;
        m_phaseCount = 0;
        m_size = 0;
        m_startWidth = 0;
        m_endWidth = 0;
        m_startHeight = 0;
        m_endHeight = 0;
        m_pitch = 0;
        m_BBP = 0;
        m_pFrame = nullptr;
        m_pFrameProcessor = nullptr;
        m_colorPlanes = 0;
    }

Member Data Documentation

int FrameData::m_BBP

Definition at line 19 of file FrameData.h.

int FrameData::m_colorPlanes

Definition at line 20 of file FrameData.h.

unsigned int FrameData::m_endHeight

Definition at line 17 of file FrameData.h.

unsigned int FrameData::m_endWidth

Definition at line 16 of file FrameData.h.

int FrameData::m_neighbourArea

Definition at line 23 of file FrameData.h.

byte* FrameData::m_pFrame

Definition at line 21 of file FrameData.h.

FrameProcessing* FrameData::m_pFrameProcessor

Definition at line 24 of file FrameData.h.

int FrameData::m_phaseCount

Definition at line 22 of file FrameData.h.

int FrameData::m_pitch

Definition at line 18 of file FrameData.h.

int FrameData::m_size

Definition at line 13 of file FrameData.h.

unsigned int FrameData::m_startHeight

Definition at line 15 of file FrameData.h.

unsigned int FrameData::m_startWidth

Definition at line 14 of file FrameData.h.

The documentation for this struct was generated from the following file:
  • Hilo C++/C++/CartoonEffect/FrameData.h
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FrameProcessing Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Static Private Member Functions | Private Attributes

FrameProcessing Class Reference

#include "FrameProcessing.h"

List of all members.

Public Member Functions

FrameProcessing ()
~FrameProcessing ()
void | ApplyFilters (int nPhases)
void | SetCancellationToken (concurrency::cancellation_token token)
void | SetCurrentFrame (byte *pFrame, int size, int width, int height, int pitch, int bpp, int clrPlanes)
void | SetNeighbourArea (unsigned int area)

Private Member Functions

void | ApplyColorSimplifier ()
void | ApplyColorSimplifier (int nPhases)
void | ApplyColorSimplifier (unsigned int startHeight, unsigned int endHeight, unsigned int startWidth, unsigned int endWidth)
void | ApplyEdgeDetection ()
void | ApplyEdgeDetectionParallel (unsigned int startHeight, unsigned int endHeight, unsigned int startWidth, unsigned int endWidth)
void | CalculateSobel (byte *pSource, int row, int column, float &dy, float &du, float &dv)
unsigned int | GetNeighbourArea ()
void | SimplifyIndexOptimized (byte *pFrame, int x, int y)
void | StopFilters ()

Static Private Member Functions

static COLORREF | GetPixel (byte *pFrame, int x, int y, int pitch, int bpp)
static void | SetPixel (byte *pFrame, int x, int y, int pitch, int bpp, COLORREF color)

Private Attributes

unsigned int | m_BPP
unsigned int | m_colorPlanes
unsigned int | m_height
unsigned int | m_neighborWindow
byte * | m_pBufferImage
byte * | m_pCurrentImage
int | m_pitch
unsigned int | m_size
concurrency::cancellation_token | m_token
unsigned int | m_width

Detailed Description

Definition at line 9 of file FrameProcessing.h.

Constructor & Destructor Documentation

FrameProcessing::FrameProcessing ( )

Definition at line 19 of file FrameProcessing.cpp.

    : m_size(0)
    , m_BPP(0)
    , m_pitch(0)
    , m_neighborWindow(3)
    , m_pCurrentImage(nullptr)
    , m_pBufferImage(nullptr)
    , m_token(cancellation_token::none())
{
}

FrameProcessing::~FrameProcessing ( )

Definition at line 30 of file FrameProcessing.cpp.

{
    if (m_pCurrentImage != nullptr)
    {
        concurrency::Free(m_pCurrentImage);
        m_pCurrentImage = nullptr;
    }
}

Member Function Documentation

void FrameProcessing::ApplyColorSimplifier ( ) [private]

Definition at line 83 of file FrameProcessing.cpp.

{
    unsigned int shift = m_neighborWindow / 2;
    ApplyColorSimplifier(shift, (m_height - shift), shift, (m_width - shift));
}

void FrameProcessing::ApplyColorSimplifier ( int nPhases ) [private]

Definition at line 89 of file FrameProcessing.cpp.

{
    for (int i = 0; i < nPhases; ++i)
    {
        ApplyColorSimplifier();
    }
}

void FrameProcessing::ApplyColorSimplifier | ( | unsigned int | startHeight,
 |  | unsigned int | endHeight,
 |  | unsigned int | startWidth,
 |  | unsigned int | endWidth |
 | ) |  |  | [private]

Definition at line 97 of file FrameProcessing.cpp.

{
    if (m_pBufferImage != nullptr)
    {
        run_with_cancellation_token([this, startHeight, endHeight, startWidth, endWidth]
        {
            parallel_for(startHeight, endHeight, [&](unsigned int j)
            {
                if (m_token.is_canceled()) return;
                for (unsigned int i = startWidth; i < endWidth; ++i)
                {
                    SimplifyIndexOptimized(m_pBufferImage, i, j);
                }
            });
        }, m_token);
    }
}

void FrameProcessing::ApplyEdgeDetection ( ) [private]

Definition at line 154 of file FrameProcessing.cpp.

{
    ApplyEdgeDetectionParallel(1, (m_height - 1), 1, (m_width - 1));
}

void FrameProcessing::ApplyEdgeDetectionParallel | ( | unsigned int | startHeight,
 |  | unsigned int | endHeight,
 |  | unsigned int | startWidth,
 |  | unsigned int | endWidth |
 | ) |  |  | [private]

Definition at line 159 of file FrameProcessing.cpp.

{
    const float alpha = 0.3f;
    const float beta = 0.8f;
    const float s0 = 0.054f;
    const float s1 = 0.064f;
    const float a0 = 0.3f;
    const float a1 = 0.7f;

    byte* pFrame = new byte[m_size];
    memcpy_s(pFrame, m_size, m_pBufferImage, m_size);

    run_with_cancellation_token([=]()
    {
        parallel_for(startHeight , endHeight, [&](int y)
        {
            if (m_token.is_canceled()) return;
            for(unsigned int x = startWidth; x < endWidth; ++x)
            {
                float Sy, Su, Sv;
                float Ay, Au, Av;

                CalculateSobel(m_pBufferImage, x, y, Sy, Su, Sv);
                CalculateSobel(m_pCurrentImage, x, y, Ay, Au, Av);

                float edgeS = (1 - alpha) * Sy + alpha * (Su + Sv) / 2;
                float edgeA = (1 - alpha) * Ay + alpha * (Au + Av) / 2;
                float i = (1 - beta) * Utils::SmoothStep(s0, s1, edgeS) + beta * Utils::SmoothStep(a0, a1, edgeA);

                float oneMinusi = 1 - i;
                COLORREF clr = this->GetPixel(m_pBufferImage, x, y, m_pitch, m_BPP);
                COLORREF newClr = RGB(GetRValue(clr) * oneMinusi, GetGValue(clr) * oneMinusi, GetBValue(clr) * oneMinusi);
                this->SetPixel(pFrame, x, y, m_pitch, m_BPP, newClr);
            }
        });
    }, m_token);

    memcpy_s(m_pBufferImage, m_size, pFrame, m_size);
    delete[] pFrame;
}

void FrameProcessing::ApplyFilters ( int nPhases )

Definition at line 54 of file FrameProcessing.cpp.

{
    ApplyColorSimplifier(nPhases);
    ApplyEdgeDetection();
}

void FrameProcessing::CalculateSobel | ( | byte * | pSource,
 |  | int | row,
 |  | int | column,
 |  | float & | dy,
 |  | float & | du,
 |  | float & | dv |
 | ) |  |  | [private]

Definition at line 200 of file FrameProcessing.cpp.

{
    int gx[3][3] = { { -1, 0, 1 }, { -2, 0, 2 }, { -1, 0, 1 } };
    int gy[3][3] = { { 1, 2, 1 }, { 0, 0, 0 }, { -1, -2, -1 } };

    float64 new_yX = 0;
    float64 new_yY = 0;
    float64 new_uX = 0;
    float64 new_uY = 0;
    float64 new_vX = 0;
    float64 new_vY = 0;
    for (int i = -1; i < 2; i++)
    {
        for (int j = -1; j < 2; j++)
        {
            const int gX = gx[i + 1][j + 1];
            const int gY = gy[i + 1][j + 1];
            float64 y;
            float64 u;
            float64 v;

            Utils::RGBToYUV(GetPixel(pSource, row + i, column + j, m_pitch, m_BPP), y, u, v);

            new_yX += gX * y;
            new_yY += gY * y;
            new_uX += gX * u;
            new_uY += gY * u;
            new_vX += gX * v;
            new_vY += gY * v;
        }
    }

    dy = (float)sqrt((new_yX * new_yX) + (new_yY * new_yY));
    du = (float)sqrt((new_uX * new_uX) + (new_uY * new_uY));
    dv = (float)sqrt((new_vX * new_vX) + (new_vY * new_vY));
}

unsigned int FrameProcessing::GetNeighbourArea ( ) [private]

Definition at line 49 of file FrameProcessing.cpp.

{
    return m_neighborWindow;
}

static COLORREF FrameProcessing::GetPixel | ( | byte * | pFrame,
 |  | int | x,
 |  | int | y,
 |  | int | pitch,
 |  | int | bpp |
 | ) |  |  | [inline, static, private]

Definition at line 42 of file FrameProcessing.h.

    {
        int width = abs((int)pitch);
        int bytesPerPixel = bpp / 8;
        int byteIndex = y * width + x * bytesPerPixel;
        return RGB(pFrame[byteIndex + 2],
            pFrame[byteIndex + 1],
            pFrame[byteIndex]);
    }

void FrameProcessing::SetCancellationToken ( concurrency::cancellation_token token )
void FrameProcessing::SetCurrentFrame | ( | byte * | pFrame,
 |  | int | size,
 |  | int | width,
 |  | int | height,
 |  | int | pitch,
 |  | int | bpp,
 |  | int | clrPlanes
 | ) |  |

Definition at line 60 of file FrameProcessing.cpp.

{
    m_width = width;
    m_height = height;
    m_pitch = pitch;
    m_BPP = bpp;
    m_colorPlanes = clrPlanes;

    if (m_pCurrentImage != nullptr)
    {
        concurrency::Free(m_pCurrentImage);
        m_pCurrentImage = nullptr;
    }
    if (m_pCurrentImage == nullptr)
    {
        m_pCurrentImage = (byte*)concurrency::Alloc(size);
    }

    memcpy(m_pCurrentImage, pFrame, size);
    m_pBufferImage = pFrame;
    m_size = size;
}

void FrameProcessing::SetNeighbourArea ( unsigned int area )

Definition at line 44 of file FrameProcessing.cpp.

{
    m_neighborWindow = area;
}

static void FrameProcessing::SetPixel | ( | byte * | pFrame,
 |  | int | x,
 |  | int | y,
 |  | int | pitch,
 |  | int | bpp,
 |  | COLORREF | color |
 | ) |  |  | [inline, static, private]

Definition at line 52 of file FrameProcessing.h.

    {
        int width = abs((int)pitch);
        int bytesPerPixel = bpp / 8;
        int byteIndex = y * width + x * bytesPerPixel;
        pFrame[byteIndex + 2] = GetRValue(color);
        pFrame[byteIndex + 1] = GetGValue(color);
        pFrame[byteIndex] = GetBValue(color);
    }

void FrameProcessing::SimplifyIndexOptimized | ( | byte * | pFrame,
 |  | int | x,
 |  | int | y |
 | ) |  |  | [private]

Definition at line 115 of file FrameProcessing.cpp.

{
    COLORREF orgClr =  GetPixel(pFrame, x, y, m_pitch, m_BPP);

    int shift = m_neighborWindow / 2;
    float64 sSum = 0;
    float64 partialSumR = 0;
    float64 partialSumG = 0;
    float64 partialSumB = 0;
    float64 standardDeviation = 0.025;

    for (int j = y - shift; j <= (y + shift); ++j)
    {
        for (int i = x - shift; i <= (x + shift); ++i)
        {
            // Don't apply filter to the requested index, only to the neighbors
            if (i != x ||  j != y)
            {
                COLORREF clr = GetPixel(pFrame, i, j, m_pitch, m_BPP);
                float64 distance = Utils::GetDistance(orgClr, clr);
                float64 sValue = pow(M_E, -0.5 * pow(distance / standardDeviation, 2));
                sSum += sValue;
                partialSumR += GetRValue(clr) * sValue;
                partialSumG += GetGValue(clr) * sValue;
                partialSumB += GetBValue(clr) * sValue;
            }
        }
    }

    COLORREF simplifiedClr;
    int simpleRed, simpleGreen, simpleBlue;

    simpleRed   = (int)min(max(partialSumR / sSum, 0), 255);
    simpleGreen = (int)min(max(partialSumG / sSum, 0), 255);
    simpleBlue  = (int)min(max(partialSumB / sSum, 0), 255);
    simplifiedClr = RGB(simpleRed, simpleGreen, simpleBlue);
    SetPixel(m_pBufferImage, x, y, m_pitch, m_BPP, simplifiedClr);
}

void FrameProcessing::StopFilters ( ) [private]

Member Data Documentation

unsigned int FrameProcessing::m_BPP [private]

Definition at line 28 of file FrameProcessing.h.

unsigned int FrameProcessing::m_colorPlanes [private]

Definition at line 29 of file FrameProcessing.h.

unsigned int FrameProcessing::m_height [private]

Definition at line 25 of file FrameProcessing.h.

unsigned int FrameProcessing::m_neighborWindow [private]

Definition at line 23 of file FrameProcessing.h.

byte* FrameProcessing::m_pBufferImage [private]

Definition at line 22 of file FrameProcessing.h.

byte* FrameProcessing::m_pCurrentImage [private]

Definition at line 21 of file FrameProcessing.h.

int FrameProcessing::m_pitch [private]

Definition at line 27 of file FrameProcessing.h.

unsigned int FrameProcessing::m_size [private]

Definition at line 26 of file FrameProcessing.h.

concurrency::cancellation_token FrameProcessing::m_token [private]

Definition at line 30 of file FrameProcessing.h.

unsigned int FrameProcessing::m_width [private]

Definition at line 24 of file FrameProcessing.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/CartoonEffect/FrameProcessing.h
  • Hilo C++/C++/CartoonEffect/FrameProcessing.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameConfig Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

GameConfig Struct Reference

#include "Simple3DGame.h"

List of all members.

Public Attributes

bool | autoFire
bool | backgroundAvailable [GameConstants::MaxBackgroundTextures]
bool | isTrial

Detailed Description

Definition at line 60 of file Simple3DGame.h.

Member Data Documentation

bool GameConfig::autoFire

Definition at line 63 of file Simple3DGame.h.

bool GameConfig::backgroundAvailable[GameConstants::MaxBackgroundTextures]

Definition at line 64 of file Simple3DGame.h.

bool GameConfig::isTrial

Definition at line 62 of file Simple3DGame.h.

The documentation for this struct was generated from the following file:
  • XAML DirectX 3D shooting game/C++/Simple3DGame.h
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameHud Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

GameHud Class Reference

#include "GameHud.h"

List of all members.

Public Member Functions

void | CreateDeviceIndependentResources (_In_ IDWriteFactory *dwriteFactory, _In_ IWICImagingFactory *wicFactory)
void | CreateDeviceIndependentResources (_In_ IDWriteFactory *dwriteFactory, _In_ IWICImagingFactory *wicFactory)
void | CreateDeviceResources (_In_ ID2D1DeviceContext *d2dContext)
void | CreateDeviceResources (_In_ ID2D1DeviceContext *d2dContext)
void | Render (_In_ Simple3DGame^game, _In_ ID2D1DeviceContext *d2dContext, _In_ Windows::Foundation::Rect windowBounds)
void | Render (_In_ Simple3DGame^game, _In_ ID2D1DeviceContext *d2dContext, _In_ Windows::Foundation::Rect windowBounds)
void | SetLicenseInfo (_In_ Platform::String^licenseInfo)
void | UpdateForWindowSizeChange (_In_ Windows::Foundation::Rect windowBounds)
void | UpdateForWindowSizeChange (_In_ Windows::Foundation::Rect windowBounds)

Public Attributes

internal | __pad0__: GameHud( _In_ Platform::String^ titleHeader
internal _In_ Platform::String | titleBody
internal _In_ Platform::String
_In_ Platform::String 		titleLicenseInfo

Private Attributes

Microsoft::WRL::ComPtr
< IDWriteFactory > 		m_dwriteFactory
Microsoft::WRL::ComPtr
< ID2D1Bitmap > 		m_logoBitmap
D2D1_SIZE_F | m_logoSize
D2D1_SIZE_F | m_maxTitleSize
bool | m_showTitle
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrushGrey
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormatBody
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormatBodySymbol
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormatTitleBody
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormatTitleHeader
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormatTitleLicense
Platform::String | m_titleBody
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_titleBodyLayout
float | m_titleBodyVerticalOffset
Platform::String | m_titleHeader
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_titleHeaderLayout
Platform::String | m_titleLicenseInfo
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_titleLicenseInfoLayout
float | m_titleLicenseVerticalOffset
Microsoft::WRL::ComPtr
< IWICImagingFactory > 		m_wicFactory

Detailed Description

Definition at line 21 of file GameHud.h.

Member Function Documentation

void GameHud::CreateDeviceIndependentResources | ( | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ IWICImagingFactory * | wicFactory
 | ) |  |

Definition at line 38 of file GameHud.cpp.

{
    m_dwriteFactory = dwriteFactory;
    m_wicFactory = wicFactory;

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            GameConstants::HudBodyPointSize,
            L"en-us",
            &m_textFormatBody
            )
        );
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI Symbol",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            GameConstants::HudBodyPointSize,
            L"en-us",
            &m_textFormatBodySymbol
            )
        );
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI Light",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            GameConstants::HudTitleHeaderPointSize,
            L"en-us",
            &m_textFormatTitleHeader
            )
        );
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI Light",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            GameConstants::HudTitleBodyPointSize,
            L"en-us",
            &m_textFormatTitleBody
            )
        );

    DX::ThrowIfFailed(m_textFormatBody->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
    DX::ThrowIfFailed(m_textFormatBody->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
    DX::ThrowIfFailed(m_textFormatBodySymbol->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
    DX::ThrowIfFailed(m_textFormatBodySymbol->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
    DX::ThrowIfFailed(m_textFormatTitleHeader->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
    DX::ThrowIfFailed(m_textFormatTitleHeader->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
    DX::ThrowIfFailed(m_textFormatTitleBody->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
    DX::ThrowIfFailed(m_textFormatTitleBody->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
}

void GameHud::CreateDeviceIndependentResources | ( | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ IWICImagingFactory * | wicFactory
 | ) |  |
void GameHud::CreateDeviceResources ( _In_ ID2D1DeviceContext * d2dContext )

Definition at line 107 of file GameHud.cpp.

{
    auto location = Package::Current->InstalledLocation;
    Platform::String^ path = Platform::String::Concat(location->Path, "\\");
    path = Platform::String::Concat(path, "windows-sdk.png");

    ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            path->Data(),
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &wicBitmapDecoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
    DX::ThrowIfFailed(
        wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
        );

    ComPtr<IWICFormatConverter> wicFormatConverter;
    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&wicFormatConverter)
        );

    DX::ThrowIfFailed(
        wicFormatConverter->Initialize(
            wicBitmapFrame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0,
            WICBitmapPaletteTypeCustom  // The BGRA format has no palette so this value is ignored.
            )
        );

    double dpiX = 96.0f;
    double dpiY = 96.0f;
    DX::ThrowIfFailed(
        wicFormatConverter->GetResolution(&dpiX, &dpiY)
        );

    // Create D2D Resources
    DX::ThrowIfFailed(
        d2dContext->CreateBitmapFromWicBitmap(
            wicFormatConverter.Get(),
            BitmapProperties(
                PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
                static_cast<float>(dpiX),
                static_cast<float>(dpiY)
                ),
            &m_logoBitmap
            )
        );

    m_logoSize = m_logoBitmap->GetSize();

    DX::ThrowIfFailed(
        d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_textBrush
            )
        );
}

void GameHud::CreateDeviceResources ( _In_ ID2D1DeviceContext * d2dContext )
void GameHud::Render | ( | _In_ Simple3DGame^ | game,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ Windows::Foundation::Rect | windowBounds
 | ) |  |
void GameHud::Render | ( | _In_ Simple3DGame^ | game,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ Windows::Foundation::Rect | windowBounds
 | ) |  |

Definition at line 229 of file GameHud.cpp.

{
    if (m_showTitle)
    {
        d2dContext->DrawBitmap(
            m_logoBitmap.Get(),
            D2D1::RectF(
                GameConstants::Margin,
                GameConstants::Margin,
                m_logoSize.width + GameConstants::Margin,
                m_logoSize.height + GameConstants::Margin
                )
            );
        d2dContext->DrawTextLayout(
            Point2F(m_logoSize.width + 2.0f * GameConstants::Margin, GameConstants::Margin),
            m_titleHeaderLayout.Get(),
            m_textBrush.Get()
            );
        d2dContext->DrawTextLayout(
            Point2F(GameConstants::Margin, m_titleBodyVerticalOffset),
            m_titleBodyLayout.Get(),
            m_textBrush.Get()
            );
    }

    if (game != nullptr)
    {
        // This section is only used after the game state has been initialized.
        static const int bufferLength = 256;
        static char16 wsbuffer[bufferLength];
        int length = swprintf_s(
            wsbuffer,
            bufferLength,
            L"Hits:\t%10d\nShots:\t%10d\nTime:\t%8.1f",
            game->TotalHits(),
            game->TotalShots(),
            game->TimeRemaining()
            );

        d2dContext->DrawText(
            wsbuffer,
            length,
            m_textFormatBody.Get(),
            D2D1::RectF(
                windowBounds.Width - GameConstants::HudRightOffset,
                GameConstants::HudTopOffset,
                windowBounds.Width,
                GameConstants::HudTopOffset + (GameConstants::HudBodyPointSize + GameConstants::Margin) * 3
                ),
            m_textBrush.Get()
            );

        // Using the unicode characters starting at 0x2780 ( ➀ ) for the consecutive levels of the game.
        // For completed levels start with 0x278A ( ➊ ) (This is 0x2780 + 10).
        uint32 levelCharacter[6];
        for (uint32 i = 0; i < 6; i++)
        {
            levelCharacter[i] = 0x2780 + i + ((static_cast<uint32>(game->LevelCompleted()) == i) ? 10 : 0);
        }
        length = swprintf_s(
            wsbuffer,
            bufferLength,
            L"%lc %lc %lc %lc %lc %lc",
            levelCharacter[0],
            levelCharacter[1],
            levelCharacter[2],
            levelCharacter[3],
            levelCharacter[4],
            levelCharacter[5]
            );
        d2dContext->DrawText(
            wsbuffer,
            length,
            m_textFormatBodySymbol.Get(),
            D2D1::RectF(
                windowBounds.Width - GameConstants::HudRightOffset,
                GameConstants::HudTopOffset + (GameConstants::HudBodyPointSize + GameConstants::Margin) * 3 + GameConstants::Margin,
                windowBounds.Width,
                GameConstants::HudTopOffset + (GameConstants::HudBodyPointSize+ GameConstants::Margin) * 4
                ),
            m_textBrush.Get()
            );

        if (game->IsActivePlay())
        {
            // Draw a rectangle for the touch input for the move control.
            d2dContext->DrawRectangle(
                D2D1::RectF(
                    0.0f,
                    windowBounds.Height - GameConstants::TouchRectangleSize,
                    GameConstants::TouchRectangleSize,
                    windowBounds.Height
                    ),
                m_textBrush.Get()
                );
            // Draw a rectangle for the touch input for the fire control.
            d2dContext->DrawRectangle(
                D2D1::RectF(
                    windowBounds.Width - GameConstants::TouchRectangleSize,
                    windowBounds.Height - GameConstants::TouchRectangleSize,
                    windowBounds.Width,
                    windowBounds.Height
                    ),
                m_textBrush.Get()
                );

            // Draw the cross hairs
            d2dContext->DrawLine(
                D2D1::Point2F(windowBounds.Width / 2.0f - GameConstants::CrossHairHalfSize, windowBounds.Height / 2.0f),
                D2D1::Point2F(windowBounds.Width / 2.0f + GameConstants::CrossHairHalfSize, windowBounds.Height / 2.0f),
                m_textBrush.Get(),
                3.0f
                );
            d2dContext->DrawLine(
                D2D1::Point2F(windowBounds.Width / 2.0f, windowBounds.Height / 2.0f - GameConstants::CrossHairHalfSize),
                D2D1::Point2F(windowBounds.Width / 2.0f, windowBounds.Height / 2.0f + GameConstants::CrossHairHalfSize),
                m_textBrush.Get(),
                3.0f
                );
        }
    }
}

void GameHud::SetLicenseInfo ( _In_ Platform::String^ licenseInfo )

Definition at line 268 of file GameHud.cpp.

{
    m_titleLicenseInfo = licenseInfo;

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            m_titleLicenseInfo->Data(),
            m_titleLicenseInfo->Length(),
            m_textFormatTitleLicense.Get(),
            m_maxTitleSize.width,
            m_maxTitleSize.height - m_titleLicenseVerticalOffset,
            &m_titleLicenseInfoLayout
            )
        );
}

void GameHud::UpdateForWindowSizeChange ( _In_ Windows::Foundation::Rect windowBounds )
void GameHud::UpdateForWindowSizeChange ( _In_ Windows::Foundation::Rect windowBounds )

Definition at line 176 of file GameHud.cpp.

{
    m_maxTitleSize.width = windowBounds.Width - GameConstants::HudSafeWidth;
    m_maxTitleSize.height = windowBounds.Height;

    float headerWidth = m_maxTitleSize.width - (m_logoSize.width + 2 * GameConstants::Margin);

    if (headerWidth > 0)
    {
        // Only resize the text layout for the Title area when there is enough space.
        m_showTitle = true;

        DX::ThrowIfFailed(
            m_dwriteFactory->CreateTextLayout(
                m_titleHeader->Data(),
                m_titleHeader->Length(),
                m_textFormatTitleHeader.Get(),
                headerWidth,
                m_maxTitleSize.height,
                &m_titleHeaderLayout
                )
            );

        DWRITE_TEXT_METRICS metrics = {0};
        DX::ThrowIfFailed(
            m_titleHeaderLayout->GetMetrics(&metrics)
            );

        // Compute the vertical size of the laid out Header and logo.  This could change
        // based on the window size and the layout of the text.  In some cases the text
        // may wrap.
        m_titleBodyVerticalOffset = max(m_logoSize.height + GameConstants::Margin * 2, metrics.height + 2 * GameConstants::Margin);

        DX::ThrowIfFailed(
            m_dwriteFactory->CreateTextLayout(
                m_titleBody->Data(),
                m_titleBody->Length(),
                m_textFormatTitleBody.Get(),
                m_maxTitleSize.width,
                m_maxTitleSize.height - m_titleBodyVerticalOffset,
                &m_titleBodyLayout
                )
            );
    }
    else
    {
        // Not enough horizontal space for the titles so just turn it off.
        m_showTitle = false;
    }
}

Member Data Documentation

internal GameHud::__pad0__

Definition at line 25 of file GameHud.h.

Microsoft::WRL::ComPtr< IDWriteFactory > GameHud::m_dwriteFactory [private]

Definition at line 43 of file GameHud.h.

Microsoft::WRL::ComPtr< ID2D1Bitmap > GameHud::m_logoBitmap [private]

Definition at line 52 of file GameHud.h.

D2D1_SIZE_F GameHud::m_logoSize [private]

Definition at line 61 of file GameHud.h.

D2D1_SIZE_F GameHud::m_maxTitleSize [private]

Definition at line 62 of file GameHud.h.

bool GameHud::m_showTitle [private]

Definition at line 56 of file GameHud.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > GameHud::m_textBrush [private]

Definition at line 46 of file GameHud.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> GameHud::m_textBrushGrey [private]

Definition at line 50 of file GameHud.h.

Microsoft::WRL::ComPtr< IDWriteTextFormat > GameHud::m_textFormatBody [private]

Definition at line 47 of file GameHud.h.

Microsoft::WRL::ComPtr< IDWriteTextFormat > GameHud::m_textFormatBodySymbol [private]

Definition at line 48 of file GameHud.h.

Microsoft::WRL::ComPtr< IDWriteTextFormat > GameHud::m_textFormatTitleBody [private]

Definition at line 51 of file GameHud.h.

Microsoft::WRL::ComPtr< IDWriteTextFormat > GameHud::m_textFormatTitleHeader [private]

Definition at line 50 of file GameHud.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> GameHud::m_textFormatTitleLicense [private]

Definition at line 56 of file GameHud.h.

Platform::String GameHud::m_titleBody [private]

Definition at line 58 of file GameHud.h.

Microsoft::WRL::ComPtr< IDWriteTextLayout > GameHud::m_titleBodyLayout [private]

Definition at line 54 of file GameHud.h.

float GameHud::m_titleBodyVerticalOffset [private]

Definition at line 60 of file GameHud.h.

Platform::String GameHud::m_titleHeader [private]

Definition at line 57 of file GameHud.h.

Microsoft::WRL::ComPtr< IDWriteTextLayout > GameHud::m_titleHeaderLayout [private]

Definition at line 53 of file GameHud.h.

Platform::String GameHud::m_titleLicenseInfo [private]

Definition at line 65 of file GameHud.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> GameHud::m_titleLicenseInfoLayout [private]

Definition at line 60 of file GameHud.h.

float GameHud::m_titleLicenseVerticalOffset [private]

Definition at line 68 of file GameHud.h.

Microsoft::WRL::ComPtr< IWICImagingFactory > GameHud::m_wicFactory [private]

Definition at line 44 of file GameHud.h.

internal _In_ Platform::String GameHud::titleBody

Definition at line 25 of file GameHud.h.

internal _In_ Platform::String _In_ Platform::String GameHud::titleLicenseInfo

Definition at line 25 of file GameHud.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/GameHud.h
  • XAML DirectX 3D shooting game/C++/GameHud.h
  • DirectX 3D shooting game/C++/GameHud.cpp
  • XAML DirectX 3D shooting game/C++/GameHud.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameInfoOverlay Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

GameInfoOverlay Class Reference

#include "GameInfoOverlay.h"

List of all members.

Public Member Functions

ID2D1Bitmap1 * | Bitmap ()
void | CreateDeviceIndependentResources (_In_ IDWriteFactory *dwriteFactory)
void | CreateDeviceResources (_In_ ID2D1DeviceContext *d2dContext)
void | CreateDpiDependentResources (float dpi)
void | HideGameInfoOverlay ()
void | SetAction (GameInfoOverlayCommand action)
void | SetGameLoading (uint32 dots)
void | SetGameOver (bool win, int maxLevel, int hitCount, int shotCount, int highScore)
void | SetGameStats (int maxLevel, int hitCount, int shotCount)
void | SetLevelStart (int level, Platform::String^objective, float timeLimit, float bonusTime)
void | SetPause ()
void | ShowGameInfoOverlay ()
bool | Visible ()

Public Attributes

internal | __pad0__: GameInfoOverlay()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_actionBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_backgroundBrush
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
float | m_dpi
Microsoft::WRL::ComPtr
< IDWriteFactory > 		m_dwriteFactory
Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_levelBitmap
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormatBody
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormatTitle
bool | m_visible

Detailed Description

Definition at line 41 of file GameInfoOverlay.h.

Member Function Documentation

ID2D1Bitmap1* GameInfoOverlay::Bitmap ( ) [inline]

Definition at line 59 of file GameInfoOverlay.h.

{ return m_levelBitmap.Get(); }

void GameInfoOverlay::CreateDeviceIndependentResources ( _In_ IDWriteFactory * dwriteFactory )

Definition at line 33 of file GameInfoOverlay.cpp.

{
    m_dwriteFactory = dwriteFactory;

    // Create D2D Resources
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_MEDIUM,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            32,         // font size
            L"en-us",   // locale
            &m_textFormatTitle
            )
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            24,         // font size
            L"en-us",   // locale
            &m_textFormatBody
            )
        );

    DX::ThrowIfFailed(
        m_textFormatTitle->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );
    DX::ThrowIfFailed(
        m_textFormatTitle->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );
    DX::ThrowIfFailed(
        m_textFormatBody->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );
    DX::ThrowIfFailed(
        m_textFormatBody->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );
}

void GameInfoOverlay::CreateDeviceResources ( _In_ ID2D1DeviceContext * d2dContext )

Definition at line 80 of file GameInfoOverlay.cpp.

{
    m_d2dContext = d2dContext;
    m_dpi = -1.0f;

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_textBrush
            )
        );
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_backgroundBrush
            )
        );
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(0xdb7100, 1.0f),
            &m_actionBrush
            )
        );
}

void GameInfoOverlay::CreateDpiDependentResources ( float dpi )

Definition at line 107 of file GameInfoOverlay.cpp.

{
    if (m_dpi == dpi)
    {
        return;
    }
    m_dpi = dpi;

    m_levelBitmap = nullptr;

    // Create a D2D Bitmap to be used for Game Info Overlay when waiting to
    // start a level or when display game statistics.
    D2D1_BITMAP_PROPERTIES1 properties;
    properties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
    properties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
    properties.dpiX = m_dpi;
    properties.dpiY = m_dpi;
    properties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET;
    properties.colorContext = nullptr;
    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmap(
            D2D1::SizeU(
                static_cast<UINT32>(GameInfoOverlayConstant::Width * m_dpi / 96.0f),
                static_cast<UINT32>(GameInfoOverlayConstant::Height * m_dpi / 96.0f)
                ),
            nullptr,
            0,
            &properties,
            &m_levelBitmap
            )
        );
    m_d2dContext->SetTarget(m_levelBitmap.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void GameInfoOverlay::HideGameInfoOverlay ( ) [inline]

Definition at line 56 of file GameInfoOverlay.h.

{ m_visible = false; };

void GameInfoOverlay::SetAction ( GameInfoOverlayCommand action )

Definition at line 397 of file GameInfoOverlay.cpp.

{
    Platform::String^ string;

    m_d2dContext->SetTarget(m_levelBitmap.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->FillRectangle(&actionRectangle, m_backgroundBrush.Get());

    switch (action)
    {
    case GameInfoOverlayCommand::PlayAgain:
        string = "Tap to play again ...";
        break;
    case GameInfoOverlayCommand::PleaseWait:
        string = "Level loading, please wait ...";
        break;
    case GameInfoOverlayCommand::TapToContinue:
        string = "Tap to continue ...";
        break;
    default:
        string = "";
        break;
    }
    if (action != GameInfoOverlayCommand::None)
    {
        m_d2dContext->DrawText(
            string->Data(),
            string->Length(),
            m_textFormatBody.Get(),
            actionRectangle,
            m_actionBrush.Get()
            );
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void GameInfoOverlay::SetGameLoading ( uint32 dots )

Definition at line 154 of file GameInfoOverlay.cpp.

{
    int length;
    Platform::String^ string = "Loading Resources";

    m_d2dContext->SetTarget(m_levelBitmap.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
    m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
    m_d2dContext->FillRectangle(&actionRectangle, m_backgroundBrush.Get());

    m_d2dContext->DrawText(
        string->Data(),
        string->Length(),
        m_textFormatTitle.Get(),
        titleRectangle,
        m_textBrush.Get()
        );

    dots = dots % 10;
    for (length = 0; length < 25; length++)
    {
        wsbuffer[length] = L' ';
    }
    for (uint32 i = 0; i < dots; i++)
    {
        wsbuffer[length++] = 0x25CF;   // This is a Dot character in the font.
        wsbuffer[length++] = L' ';
        wsbuffer[length++] = L' ';
        wsbuffer[length++] = L' ';
    }

    m_d2dContext->DrawText(
        wsbuffer,
        length,
        m_textFormatBody.Get(),
        bodyRectangle,
        m_actionBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void GameInfoOverlay::SetGameOver | ( | bool | win,
 |  | int | maxLevel,
 |  | int | hitCount,
 |  | int | shotCount,
 |  | int | highScore
 | ) |  |

Definition at line 253 of file GameInfoOverlay.cpp.

{
    int length;
    Platform::String^ string;

    m_d2dContext->SetTarget(m_levelBitmap.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
    m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
    if (win)
    {
        string = "You WON!";
    }
    else
    {
        string = "Game Over";
    }
    m_d2dContext->DrawText(
        string->Data(),
        string->Length(),
        m_textFormatTitle.Get(),
        titleRectangle,
        m_textBrush.Get()
        );
    length = swprintf_s(
        wsbuffer,
        bufferLength,
        L"Levels Completed %d\nTotal Points %d\nTotal Shots %d\n\nHigh Score %d\n",
        maxLevel,
        hitCount,
        shotCount,
        highScore
        );
    m_d2dContext->DrawText(
        wsbuffer,
        length,
        m_textFormatBody.Get(),
        bodyRectangle,
        m_textBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void GameInfoOverlay::SetGameStats | ( | int | maxLevel,
 |  | int | hitCount,
 |  | int | shotCount
 | ) |  |

Definition at line 206 of file GameInfoOverlay.cpp.

{
    int length;
    Platform::String^ string;

    m_d2dContext->SetTarget(m_levelBitmap.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
    m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
    string = "High Score";

    m_d2dContext->DrawText(
        string->Data(),
        string->Length(),
        m_textFormatTitle.Get(),
        titleRectangle,
        m_textBrush.Get()
        );
    length = swprintf_s(
        wsbuffer,
        bufferLength,
        L"Levels Completed %d\nTotal Points %d\nTotal Shots %d",
        maxLevel,
        hitCount,
        shotCount
        );
    string = ref new Platform::String(wsbuffer, length);
    m_d2dContext->DrawText(
        string->Data(),
        string->Length(),
        m_textFormatBody.Get(),
        bodyRectangle,
        m_textBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void GameInfoOverlay::SetLevelStart | ( | int | level,
 |  | Platform::String^ | objective,
 |  | float | timeLimit,
 |  | float | bonusTime
 | ) |  |

Definition at line 307 of file GameInfoOverlay.cpp.

{
    int length;
    Platform::String^ string;

    m_d2dContext->SetTarget(m_levelBitmap.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
    m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
    length = swprintf_s(wsbuffer, bufferLength, L"Level %d", level);
    m_d2dContext->DrawText(
        wsbuffer,
        length,
        m_textFormatTitle.Get(),
        titleRectangle,
        m_textBrush.Get()
        );

    if (bonusTime > 0.0f)
    {
        length = swprintf_s(
            wsbuffer,
            bufferLength,
            L"Objective: %s\nTime  Limit: %6.1f sec\nBonus Time: %6.1f sec\n",
            objective->Data(),
            timeLimit,
            bonusTime
            );
    }
    else
    {
        length = swprintf_s(
            wsbuffer,
            bufferLength,
            L"Objective: %s\nTime  Limit: %6.1f sec\n",
            objective->Data(),
            timeLimit
            );
    }
    string = ref new Platform::String(wsbuffer, length);
    m_d2dContext->DrawText(
        string->Data(),
        string->Length(),
        m_textFormatBody.Get(),
        bodyRectangle,
        m_textBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void GameInfoOverlay::SetPause ( )

Definition at line 367 of file GameInfoOverlay.cpp.

{
    Platform::String^ string;

    m_d2dContext->SetTarget(m_levelBitmap.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
    m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
    string = "Game Paused";

    m_d2dContext->DrawText(
        string->Data(),
        string->Length(),
        m_textFormatTitle.Get(),
        bodyRectangle,
        m_textBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void GameInfoOverlay::ShowGameInfoOverlay ( ) [inline]

Definition at line 57 of file GameInfoOverlay.h.

{ m_visible = true; };

bool GameInfoOverlay::Visible ( ) [inline]

Definition at line 58 of file GameInfoOverlay.h.

{ return m_visible; };

Member Data Documentation

internal GameInfoOverlay::__pad0__

Definition at line 44 of file GameInfoOverlay.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> GameInfoOverlay::m_actionBrush [private]

Definition at line 73 of file GameInfoOverlay.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> GameInfoOverlay::m_backgroundBrush [private]

Definition at line 72 of file GameInfoOverlay.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> GameInfoOverlay::m_d2dContext [private]

Definition at line 65 of file GameInfoOverlay.h.

float GameInfoOverlay::m_dpi [private]

Definition at line 62 of file GameInfoOverlay.h.

Microsoft::WRL::ComPtr<IDWriteFactory> GameInfoOverlay::m_dwriteFactory [private]

Definition at line 66 of file GameInfoOverlay.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap1> GameInfoOverlay::m_levelBitmap [private]

Definition at line 68 of file GameInfoOverlay.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> GameInfoOverlay::m_textBrush [private]

Definition at line 71 of file GameInfoOverlay.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> GameInfoOverlay::m_textFormatBody [private]

Definition at line 70 of file GameInfoOverlay.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> GameInfoOverlay::m_textFormatTitle [private]

Definition at line 69 of file GameInfoOverlay.h.

bool GameInfoOverlay::m_visible [private]

Definition at line 63 of file GameInfoOverlay.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/GameInfoOverlay.h
  • DirectX 3D shooting game/C++/GameInfoOverlay.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

GameObject Class Reference

#include "GameObject.h"

Inherited by Cylinder, Cylinder, Face, Face, Sphere, and Sphere.

List of all members.

Public Member Functions

void | Active (bool active)
bool | Active ()
void | Active (bool active)
bool | Active ()
Animate | AnimatePosition ()
void | AnimatePosition (_In_opt_ Animate^animate)
void | AnimatePosition (_In_opt_ Animate^animate)
Animate | AnimatePosition ()
bool | Hit ()
void | Hit (bool hit)
bool | Hit ()
void | Hit (bool hit)
void | HitMaterial (_In_ Material^material)
Material HitMaterial ()
void | HitMaterial (_In_ Material^material)
Material HitMaterial ()
void | HitSound (_In_ SoundEffect^hitSound)
SoundEffect HitSound ()
void | HitSound (_In_ SoundEffect^hitSound)
SoundEffect HitSound ()
void | HitTime (float t)
float | HitTime ()
void | HitTime (float t)
float | HitTime ()
virtual bool | IsTouching (DirectX::XMFLOAT3, float, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal)
virtual bool | IsTouching (DirectX::XMFLOAT3, float, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal)
void | Mesh (_In_ MeshObject^mesh)
void | Mesh (_In_ MeshObject^mesh)
DirectX::XMMATRIX | ModelMatrix ()
DirectX::XMMATRIX | ModelMatrix ()
Material NormalMaterial ()
void | NormalMaterial (_In_ Material^material)
Material NormalMaterial ()
void | NormalMaterial (_In_ Material^material)
void | OnGround (bool ground)
bool | OnGround ()
bool | OnGround ()
void | OnGround (bool ground)
void | PlaySound (float impactSpeed, DirectX::XMFLOAT3 eyePoint)
void | PlaySound (float impactSpeed, DirectX::XMFLOAT3 eyePoint)
DirectX::XMFLOAT3 | Position ()
void | Position (DirectX::XMVECTOR position)
void | Position (DirectX::XMFLOAT3 position)
void | Position (DirectX::XMFLOAT3 position)
DirectX::XMFLOAT3 | Position ()
void | Position (DirectX::XMVECTOR position)
void | Render (_In_ ID3D11DeviceContext *context, _In_ ID3D11Buffer *primitiveConstantBuffer)
void | Render (_In_ ID3D11DeviceContext *context, _In_ ID3D11Buffer *primitiveConstantBuffer)
bool | Target ()
void | Target (bool target)
bool | Target ()
void | Target (bool target)
int | TargetId ()
int | TargetId ()
void | TargetId (int targetId)
void | TargetId (int targetId)
DirectX::XMVECTOR | VectorPosition ()
DirectX::XMVECTOR | VectorPosition ()
DirectX::XMVECTOR | VectorVelocity ()
DirectX::XMVECTOR | VectorVelocity ()
DirectX::XMFLOAT3 | Velocity ()
void | Velocity (DirectX::XMVECTOR velocity)
void | Velocity (DirectX::XMVECTOR velocity)
void | Velocity (DirectX::XMFLOAT3 velocity)
DirectX::XMFLOAT3 | Velocity ()
void | Velocity (DirectX::XMFLOAT3 velocity)

Public Attributes

internal | __pad0__: GameObject()

Private Member Functions

virtual void | UpdatePosition ()
virtual void | UpdatePosition ()

Private Attributes

bool | m_active
Animate | m_animatePosition
DirectX::XMFLOAT3 | m_defaultXAxis
DirectX::XMFLOAT3 | m_defaultYAxis
DirectX::XMFLOAT3 | m_defaultZAxis
bool | m_ground
bool | m_hit
Material m_hitMaterial
SoundEffect m_hitSound
float | m_hitTime
MeshObject | m_mesh
DirectX::XMFLOAT4X4 | m_modelMatrix
Material m_normalMaterial
DirectX::XMFLOAT3 | m_position
bool | m_target
int | m_targetId
DirectX::XMFLOAT3 | m_velocity

Detailed Description

Definition at line 25 of file GameObject.h.

Member Function Documentation

__forceinline void GameObject::Active ( bool active )

Definition at line 115 of file GameObject.h.

{
    m_active = active;
}

__forceinline bool GameObject::Active ( )

Definition at line 120 of file GameObject.h.

{
    return m_active;
}

void GameObject::Active ( bool active )
bool GameObject::Active ( )
__forceinline Animate GameObject::AnimatePosition ( )

Definition at line 226 of file GameObject.h.

{
    return m_animatePosition;
}

__forceinline void GameObject::AnimatePosition ( _In_opt_ Animate^ animate )

Definition at line 221 of file GameObject.h.

{
    m_animatePosition = animate;
}

void GameObject::AnimatePosition ( _In_opt_ Animate^ animate )
Animate GameObject::AnimatePosition ( )
__forceinline bool GameObject::Hit ( )

Definition at line 140 of file GameObject.h.

{
    return m_hit;
}

void GameObject::Hit ( bool hit )
bool GameObject::Hit ( )
__forceinline void GameObject::Hit ( bool hit )

Definition at line 135 of file GameObject.h.

{
    m_hit = hit;
}

__forceinline void GameObject::HitMaterial ( _In_ Material^ material )

Definition at line 241 of file GameObject.h.

{
    m_hitMaterial = material;
}

__forceinline Material GameObject::HitMaterial ( )

Definition at line 246 of file GameObject.h.

{
    return m_hitMaterial;
}

void GameObject::HitMaterial ( _In_ Material^ material )
Material GameObject::HitMaterial ( )
__forceinline void GameObject::HitSound ( _In_ SoundEffect^ hitSound )

Definition at line 256 of file GameObject.h.

{
    m_hitSound = hitSound;
}

__forceinline SoundEffect GameObject::HitSound ( )

Definition at line 261 of file GameObject.h.

{
    return m_hitSound;
}

void GameObject::HitSound ( _In_ SoundEffect^ hitSound )
SoundEffect GameObject::HitSound ( )
void GameObject::HitTime ( float t )
__forceinline void GameObject::HitTime ( float t )

Definition at line 165 of file GameObject.h.

{
    m_hitTime = t;
}

float GameObject::HitTime ( )
__forceinline float GameObject::HitTime ( )

Definition at line 170 of file GameObject.h.

{
    return m_hitTime;
}

virtual bool GameObject::IsTouching | ( | DirectX::XMFLOAT3 | ,
 |  | float | ,
 |  | _Out_ DirectX::XMFLOAT3 * | contact,
 |  | _Out_ DirectX::XMFLOAT3 * | normal |
 | ) |  |  | [inline, virtual]

Reimplemented in Cylinder, Face, Sphere, Cylinder, Face, and Sphere.

Definition at line 31 of file GameObject.h.

    {
        *contact = DirectX::XMFLOAT3(0.0f, 0.0f, 0.0f);
        *normal = DirectX::XMFLOAT3(0.0f, 0.0f, 1.0f);
        return false;
    };

virtual bool GameObject::IsTouching | ( | DirectX::XMFLOAT3 | ,
 |  | float | ,
 |  | _Out_ DirectX::XMFLOAT3 * | contact,
 |  | _Out_ DirectX::XMFLOAT3 * | normal |
 | ) |  |  | [inline, virtual]

Reimplemented in Cylinder, Face, Sphere, Cylinder, Face, and Sphere.

Definition at line 31 of file GameObject.h.

    {
        *contact = DirectX::XMFLOAT3(0.0f, 0.0f, 0.0f);
        *normal = DirectX::XMFLOAT3(0.0f, 0.0f, 1.0f);
        return false;
    };

__forceinline void GameObject::Mesh ( _In_ MeshObject^ mesh )

Definition at line 251 of file GameObject.h.

{
    m_mesh = mesh;
}

void GameObject::Mesh ( _In_ MeshObject^ mesh )
__forceinline DirectX::XMMATRIX GameObject::ModelMatrix ( )

Definition at line 266 of file GameObject.h.

{
    return DirectX::XMLoadFloat4x4(&m_modelMatrix);
}

DirectX::XMMATRIX GameObject::ModelMatrix ( )
Material GameObject::NormalMaterial ( )
__forceinline void GameObject::NormalMaterial ( _In_ Material^ material )

Definition at line 231 of file GameObject.h.

{
    m_normalMaterial = material;
}

__forceinline Material GameObject::NormalMaterial ( )

Definition at line 236 of file GameObject.h.

{
    return m_normalMaterial;
}

void GameObject::NormalMaterial ( _In_ Material^ material )
__forceinline void GameObject::OnGround ( bool ground )

Definition at line 145 of file GameObject.h.

{
    m_ground = ground;
}

__forceinline bool GameObject::OnGround ( )

Definition at line 150 of file GameObject.h.

{
    return m_ground;
}

void GameObject::OnGround ( bool ground )
bool GameObject::OnGround ( )
void GameObject::PlaySound | ( | float | impactSpeed,
 |  | DirectX::XMFLOAT3 | eyePoint
 | ) |  |
void GameObject::PlaySound | ( | float | impactSpeed,
 |  | DirectX::XMFLOAT3 | eyePoint
 | ) |  |
__forceinline void GameObject::Position ( DirectX::XMVECTOR position )

Reimplemented in Sphere, and Sphere.

Definition at line 183 of file GameObject.h.

{
    XMStoreFloat3(&m_position, position);
    // Update any internal states that are dependent on the position.
    // UpdatePosition is a virtual function that is specific to the derived class.
    UpdatePosition();
}

DirectX::XMFLOAT3 GameObject::Position ( )
void GameObject::Position ( DirectX::XMVECTOR position )

Reimplemented in Sphere, and Sphere.

void GameObject::Position ( DirectX::XMFLOAT3 position )

Reimplemented in Sphere, and Sphere.

__forceinline void GameObject::Position ( DirectX::XMFLOAT3 position )

Reimplemented in Sphere, and Sphere.

Definition at line 175 of file GameObject.h.

{
    m_position = position;
    // Update any internal states that are dependent on the position.
    // UpdatePosition is a virtual function that is specific to the derived class.
    UpdatePosition();
}

__forceinline DirectX::XMFLOAT3 GameObject::Position ( )

Definition at line 191 of file GameObject.h.

{
    return m_position;
}

void GameObject::Render | ( | _In_ ID3D11DeviceContext * | context,
 |  | _In_ ID3D11Buffer * | primitiveConstantBuffer
 | ) |  |

Definition at line 41 of file GameObject.cpp.

{
    if (!m_active || (m_mesh == nullptr) || (m_normalMaterial == nullptr))
    {
        return;
    }

    ConstantBufferChangesEveryPrim constantBuffer;

    XMStoreFloat4x4(
        &constantBuffer.worldMatrix,
        XMMatrixTranspose(ModelMatrix())
        );

    if (m_hit && m_hitMaterial != nullptr)
    {
        m_hitMaterial->RenderSetup(context, &constantBuffer);
    }
    else
    {
        m_normalMaterial->RenderSetup(context, &constantBuffer);
    }
    context->UpdateSubresource(primitiveConstantBuffer, 0, nullptr, &constantBuffer, 0, 0);

    m_mesh->Render(context);
}

void GameObject::Render | ( | _In_ ID3D11DeviceContext * | context,
 |  | _In_ ID3D11Buffer * | primitiveConstantBuffer
 | ) |  |
void GameObject::Target ( bool target )
__forceinline void GameObject::Target ( bool target )

Definition at line 125 of file GameObject.h.

{
    m_target = target;
}

__forceinline bool GameObject::Target ( )

Definition at line 130 of file GameObject.h.

{
    return m_target;
}

bool GameObject::Target ( )
int GameObject::TargetId ( )
void GameObject::TargetId ( int targetId )
__forceinline int GameObject::TargetId ( )

Definition at line 160 of file GameObject.h.

{
    return m_targetId;
}

__forceinline void GameObject::TargetId ( int targetId )

Definition at line 155 of file GameObject.h.

{
    m_targetId = targetId;
}

virtual void GameObject::UpdatePosition ( ) [inline, private, virtual]

Reimplemented in Cylinder, Face, Cylinder, and Face.

Definition at line 87 of file GameObject.h.

{};

virtual void GameObject::UpdatePosition ( ) [inline, private, virtual]

Reimplemented in Cylinder, Face, Cylinder, and Face.

Definition at line 87 of file GameObject.h.

{};

DirectX::XMVECTOR GameObject::VectorPosition ( )
__forceinline DirectX::XMVECTOR GameObject::VectorPosition ( )

Definition at line 196 of file GameObject.h.

{
    return DirectX::XMLoadFloat3(&m_position);
}

DirectX::XMVECTOR GameObject::VectorVelocity ( )
__forceinline DirectX::XMVECTOR GameObject::VectorVelocity ( )

Definition at line 216 of file GameObject.h.

{
    return DirectX::XMLoadFloat3(&m_velocity);
}

__forceinline void GameObject::Velocity ( DirectX::XMFLOAT3 velocity )

Definition at line 201 of file GameObject.h.

{
    m_velocity = velocity;
}

__forceinline DirectX::XMFLOAT3 GameObject::Velocity ( )

Definition at line 211 of file GameObject.h.

{
    return m_velocity;
}

void GameObject::Velocity ( DirectX::XMVECTOR velocity )
DirectX::XMFLOAT3 GameObject::Velocity ( )
__forceinline void GameObject::Velocity ( DirectX::XMVECTOR velocity )

Definition at line 206 of file GameObject.h.

{
    XMStoreFloat3(&m_velocity, velocity);
}

void GameObject::Velocity ( DirectX::XMFLOAT3 velocity )

Member Data Documentation

internal GameObject::__pad0__

Reimplemented in Cylinder, Face, and Sphere.

Definition at line 28 of file GameObject.h.

bool GameObject::m_active [private]

Definition at line 87 of file GameObject.h.

Animate GameObject::m_animatePosition [private]

Definition at line 108 of file GameObject.h.

DirectX::XMFLOAT3 GameObject::m_defaultXAxis [private]

Definition at line 102 of file GameObject.h.

DirectX::XMFLOAT3 GameObject::m_defaultYAxis [private]

Definition at line 103 of file GameObject.h.

DirectX::XMFLOAT3 GameObject::m_defaultZAxis [private]

Definition at line 104 of file GameObject.h.

bool GameObject::m_ground [private]

Definition at line 93 of file GameObject.h.

bool GameObject::m_hit [private]

Definition at line 92 of file GameObject.h.

Material GameObject::m_hitMaterial [private]

Definition at line 100 of file GameObject.h.

SoundEffect GameObject::m_hitSound [private]

Definition at line 111 of file GameObject.h.

float GameObject::m_hitTime [private]

Definition at line 106 of file GameObject.h.

MeshObject GameObject::m_mesh [private]

Definition at line 109 of file GameObject.h.

DirectX::XMFLOAT4X4 GameObject::m_modelMatrix [private]

Definition at line 97 of file GameObject.h.

Material GameObject::m_normalMaterial [private]

Definition at line 99 of file GameObject.h.

DirectX::XMFLOAT3 GameObject::m_position [private]

Definition at line 95 of file GameObject.h.

bool GameObject::m_target [private]

Definition at line 90 of file GameObject.h.

int GameObject::m_targetId [private]

Definition at line 91 of file GameObject.h.

DirectX::XMFLOAT3 GameObject::m_velocity [private]

Definition at line 96 of file GameObject.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/GameObject.h
  • XAML DirectX 3D shooting game/C++/GameObject.h
  • DirectX 3D shooting game/C++/GameObject.cpp
  • XAML DirectX 3D shooting game/C++/GameObject.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

GameRenderer Class Reference

#include "GameRenderer.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateDeviceResources () override
concurrency::task< void > | CreateGameDeviceResourcesAsync (_In_ Simple3DGame^game)
concurrency::task< void > | CreateGameDeviceResourcesAsync (_In_ Simple3DGame^game)
void | FinalizeCreateGameDeviceResources ()
void | FinalizeCreateGameDeviceResources ()
void | FinalizeLoadLevelResources ()
void | FinalizeLoadLevelResources ()
DirectX::XMFLOAT2 | GameInfoOverlayLowerRight ()
DirectX::XMFLOAT2 | GameInfoOverlayUpperLeft ()
virtual void | HandleDeviceLost () override
virtual void | HandleDeviceLost () override
GameHud Hud ()
GameInfoOverlay InfoOverlay ()
virtual void | Initialize (_In_ Windows::UI::Core::CoreWindow^window, float dpi) override
virtual void | Initialize (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^swapChainPanel, float dpi) override
concurrency::task< void > | LoadLevelResourcesAsync ()
concurrency::task< void > | LoadLevelResourcesAsync ()
virtual void | Render () override
virtual void | Render () override
void | SetBackground (uint32 background)
virtual void | SetDpi (float dpi) override
virtual void | UpdateForWindowSizeChange () override
virtual void | UpdateForWindowSizeChange () override

Public Attributes

internal | __pad0__: GameRenderer()

Private Attributes

Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_ceilingTexture
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBufferChangeOnResize
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBufferChangesEveryFrame
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBufferChangesEveryPrim
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBufferNeverChanges
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_cylinderTexture
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_floorTexture
Simple3DGame m_game
GameHud m_gameHud
GameInfoOverlay m_gameInfoOverlay
bool | m_gameResourcesLoaded
bool | m_initialized
bool | m_levelResourcesLoaded
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShaderFlat
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_samplerLinear
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_sphereTexture
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_vertexLayout
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShaderFlat
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_wallsTexture

Detailed Description

Definition at line 57 of file GameRenderer.h.

Member Function Documentation

void GameRenderer::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 67 of file GameRenderer.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();
    m_gameHud->CreateDeviceIndependentResources(m_dwriteFactory.Get(), m_wicFactory.Get());
    m_gameInfoOverlay->CreateDeviceIndependentResources(m_dwriteFactory.Get());
}

virtual void GameRenderer::CreateDeviceIndependentResources ( ) [override, virtual]
virtual void GameRenderer::CreateDeviceResources ( ) [override, virtual]
void GameRenderer::CreateDeviceResources ( ) [override, virtual]

Definition at line 76 of file GameRenderer.cpp.

{
    m_gameResourcesLoaded = false;
    m_levelResourcesLoaded = false;

    DirectXBase::CreateDeviceResources();

    m_gameHud->CreateDeviceResources(m_d2dContext.Get());
    m_gameInfoOverlay->CreateDeviceResources(m_d2dContext.Get());
}

task< void > GameRenderer::CreateGameDeviceResourcesAsync ( _In_ Simple3DGame^ game )

Definition at line 134 of file GameRenderer.cpp.

{
    // Create the device dependent game resources.
    // Only the m_d3dDevice is used in this method.  It is expected
    // to not run on the same thread as the GameRenderer was created.
    // Create methods on the m_d3dDevice are free-threaded and are safe while any methods
    // in the m_d3dContext should only be used on a single thread and handled
    // in the FinalizeCreateGameDeviceResources method.
    m_game = game;

    D3D11_BUFFER_DESC bd;
    ZeroMemory(&bd, sizeof(bd));

    // Create the constant buffers.
    bd.Usage = D3D11_USAGE_DEFAULT;
    bd.BindFlags = D3D11_BIND_CONSTANT_BUFFER;
    bd.CPUAccessFlags = 0;
    bd.ByteWidth = (sizeof(ConstantBufferNeverChanges) + 15) / 16 * 16;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(&bd, nullptr, &m_constantBufferNeverChanges)
        );

    bd.ByteWidth = (sizeof(ConstantBufferChangeOnResize) + 15) / 16 * 16;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(&bd, nullptr, &m_constantBufferChangeOnResize)
        );

    bd.ByteWidth = (sizeof(ConstantBufferChangesEveryFrame) + 15) / 16 * 16;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(&bd, nullptr, &m_constantBufferChangesEveryFrame)
        );

    bd.ByteWidth = (sizeof(ConstantBufferChangesEveryPrim) + 15) / 16 * 16;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(&bd, nullptr, &m_constantBufferChangesEveryPrim)
        );

    D3D11_SAMPLER_DESC sampDesc;
    ZeroMemory(&sampDesc, sizeof(sampDesc));

    sampDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;
    sampDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    sampDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    sampDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    sampDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
    sampDesc.MinLOD = 0;
    sampDesc.MaxLOD = FLT_MAX;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(&sampDesc, &m_samplerLinear)
        );

    // Start the async tasks to load the shaders and textures.
    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    std::vector<task<void>> tasks;

    uint32 numElements = ARRAYSIZE(PNTVertexLayout);
    tasks.push_back(loader->LoadShaderAsync("VertexShader.cso", PNTVertexLayout, numElements, &m_vertexShader, &m_vertexLayout));
    tasks.push_back(loader->LoadShaderAsync("VertexShaderFlat.cso", nullptr, numElements, &m_vertexShaderFlat, nullptr));
    tasks.push_back(loader->LoadShaderAsync("PixelShader.cso", &m_pixelShader));
    tasks.push_back(loader->LoadShaderAsync("PixelShaderFlat.cso", &m_pixelShaderFlat));

    // Make sure the previous versions if any of the textures are released.
    m_sphereTexture = nullptr;
    m_cylinderTexture = nullptr;
    m_ceilingTexture = nullptr;
    m_floorTexture = nullptr;
    m_wallsTexture = nullptr;

    // Load Game specific textures.
    tasks.push_back(loader->LoadTextureAsync("seafloor.dds", nullptr, &m_sphereTexture));
    tasks.push_back(loader->LoadTextureAsync("metal_texture.dds", nullptr, &m_cylinderTexture));
    tasks.push_back(loader->LoadTextureAsync("cellceiling.dds", nullptr, &m_ceilingTexture));
    tasks.push_back(loader->LoadTextureAsync("cellfloor.dds", nullptr, &m_floorTexture));
    tasks.push_back(loader->LoadTextureAsync("cellwall.dds", nullptr, &m_wallsTexture));
    tasks.push_back(create_task([]()
    {
        // Simulate loading additional resources by introducing a delay.
        wait(GameConstants::InitialLoadingDelay);
    }));

    // Return the task group of all the async tasks for loading the shader and texture assets.
    return when_all(tasks.begin(), tasks.end());
}

concurrency::task<void> GameRenderer::CreateGameDeviceResourcesAsync ( _In_ Simple3DGame^ game )
void GameRenderer::FinalizeCreateGameDeviceResources ( )

Definition at line 221 of file GameRenderer.cpp.

{
    // All asynchronously loaded resources have completed loading.
    // Now associate all the resources with the appropriate game objects.
    // This method is expected to run in the same thread as the GameRenderer
    // was created. All work will happen behind the "Loading ..." screen after the
    // main loop has been entered.

    // Initialize the Constant buffer with the light positions
    // These are handled here to ensure that the d3dContext is only
    // used in one thread.

    ConstantBufferNeverChanges constantBufferNeverChanges;
    constantBufferNeverChanges.lightPosition[0] = XMFLOAT4( 3.5f, 2.5f,  5.5f, 1.0f);
    constantBufferNeverChanges.lightPosition[1] = XMFLOAT4( 3.5f, 2.5f, -5.5f, 1.0f);
    constantBufferNeverChanges.lightPosition[2] = XMFLOAT4(-3.5f, 2.5f, -5.5f, 1.0f);
    constantBufferNeverChanges.lightPosition[3] = XMFLOAT4( 3.5f, 2.5f,  5.5f, 1.0f);
    constantBufferNeverChanges.lightColor = XMFLOAT4(0.25f, 0.25f, 0.25f, 1.0f);
    m_d3dContext->UpdateSubresource(m_constantBufferNeverChanges.Get(), 0, nullptr, &constantBufferNeverChanges, 0, 0);

    // For the targets, there are two unique generated textures.
    // Each texture image includes the number of the texture.
    // Make sure the 2D rendering is occurring on the same thread
    // as the main rendering.

    TargetTexture^ textureGenerator = ref new TargetTexture(
        m_d3dDevice.Get(),
        m_d2dFactory.Get(),
        m_dwriteFactory.Get(),
        m_d2dContext.Get()
        );

    MeshObject^ cylinderMesh = ref new CylinderMesh(m_d3dDevice.Get(), 26);
    MeshObject^ targetMesh = ref new FaceMesh(m_d3dDevice.Get());
    MeshObject^ sphereMesh = ref new SphereMesh(m_d3dDevice.Get(), 26);

    Material^ cylinderMaterial = ref new Material(
        XMFLOAT4(0.8f, 0.8f, 0.8f, .5f),
        XMFLOAT4(0.8f, 0.8f, 0.8f, .5f),
        XMFLOAT4(1.0f, 1.0f, 1.0f, 1.0f),
        15.0f,
        m_cylinderTexture.Get(),
        m_vertexShader.Get(),
        m_pixelShader.Get()
        );

    Material^ sphereMaterial = ref new Material(
        XMFLOAT4(0.8f, 0.4f, 0.0f, 1.0f),
        XMFLOAT4(0.8f, 0.4f, 0.0f, 1.0f),
        XMFLOAT4(1.0f, 1.0f, 1.0f, 1.0f),
        50.0f,
        m_sphereTexture.Get(),
        m_vertexShader.Get(),
        m_pixelShader.Get()
        );

    auto objects = m_game->RenderObjects();

    // Attach the textures to the appropriate game objects.
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if ((*object)->TargetId() == GameConstants::WorldFloorId)
        {
            (*object)->NormalMaterial(
                ref new Material(
                    XMFLOAT4(0.5f, 0.5f, 0.5f, 1.0f),
                    XMFLOAT4(0.8f, 0.8f, 0.8f, 1.0f),
                    XMFLOAT4(0.3f, 0.3f, 0.3f, 1.0f),
                    150.0f,
                    m_floorTexture.Get(),
                    m_vertexShaderFlat.Get(),
                    m_pixelShaderFlat.Get()
                    )
                );
            (*object)->Mesh(ref new WorldFloorMesh(m_d3dDevice.Get()));
        }
        else if ((*object)->TargetId() == GameConstants::WorldCeilingId)
        {
            (*object)->NormalMaterial(
                ref new Material(
                    XMFLOAT4(0.5f, 0.5f, 0.5f, 1.0f),
                    XMFLOAT4(0.8f, 0.8f, 0.8f, 1.0f),
                    XMFLOAT4(0.3f, 0.3f, 0.3f, 1.0f),
                    150.0f,
                    m_ceilingTexture.Get(),
                    m_vertexShaderFlat.Get(),
                    m_pixelShaderFlat.Get()
                    )
                );
            (*object)->Mesh(ref new WorldCeilingMesh(m_d3dDevice.Get()));
        }
        else if ((*object)->TargetId() == GameConstants::WorldWallsId)
        {
            (*object)->NormalMaterial(
                ref new Material(
                    XMFLOAT4(0.5f, 0.5f, 0.5f, 1.0f),
                    XMFLOAT4(0.8f, 0.8f, 0.8f, 1.0f),
                    XMFLOAT4(0.3f, 0.3f, 0.3f, 1.0f),
                    150.0f,
                    m_wallsTexture.Get(),
                    m_vertexShaderFlat.Get(),
                    m_pixelShaderFlat.Get()
                    )
                );
            (*object)->Mesh(ref new WorldWallsMesh(m_d3dDevice.Get()));
        }
        else if (Cylinder^ cylinder = dynamic_cast<Cylinder^>(*object))
        {
            cylinder->Mesh(cylinderMesh);
            cylinder->NormalMaterial(cylinderMaterial);
        }
        else if (Face^ target = dynamic_cast<Face^>(*object))
        {
            const int bufferLength = 16;
            char16 str[bufferLength];
            int len = swprintf_s(str, bufferLength, L"%d", target->TargetId());
            Platform::String^ string = ref new Platform::String(str, len);

            ComPtr<ID3D11ShaderResourceView> texture;
            textureGenerator->CreateTextureResourceView(string, &texture);
            target->NormalMaterial(
                ref new Material(
                    XMFLOAT4(0.8f, 0.8f, 0.8f, 0.5f),
                    XMFLOAT4(0.8f, 0.8f, 0.8f, 0.5f),
                    XMFLOAT4(0.3f, 0.3f, 0.3f, 1.0f),
                    5.0f,
                    texture.Get(),
                    m_vertexShader.Get(),
                    m_pixelShader.Get()
                    )
                );

            textureGenerator->CreateHitTextureResourceView(string, &texture);
            target->HitMaterial(
                ref new Material(
                    XMFLOAT4(0.8f, 0.8f, 0.8f, 0.5f),
                    XMFLOAT4(0.8f, 0.8f, 0.8f, 0.5f),
                    XMFLOAT4(0.3f, 0.3f, 0.3f, 1.0f),
                    5.0f,
                    texture.Get(),
                    m_vertexShader.Get(),
                    m_pixelShader.Get()
                    )
                );

            target->Mesh(targetMesh);
        }
        else if (Sphere^ sphere = dynamic_cast<Sphere^>(*object))
        {
            sphere->Mesh(sphereMesh);
            sphere->NormalMaterial(sphereMaterial);
        }
    }

    // Ensure that the camera has been initialized with the right Projection
    // matrix.  The camera is not created at the time the first window resize event
    // occurs.
    m_game->GameCamera()->SetProjParams(
        XM_PI / 2,
        m_renderTargetSize.Width / m_renderTargetSize.Height,
        0.01f,
        100.0f
        );

    // Make sure that Projection matrix has been set in the constant buffer
    // now that all the resources are loaded.
    // DirectXBase is handling screen rotations directly to eliminate an unaligned
    // fullscreen copy.  As a result, it is necessary to post multiply the rotationTransform3D
    // matrix to the camera projection matrix.
    // The matrices are transposed due to the shader code expecting the matrices in the opposite
    // row/column order from the DirectX math library.
    ConstantBufferChangeOnResize changesOnResize;
    XMStoreFloat4x4(
        &changesOnResize.projection,
        XMMatrixMultiply(
            XMMatrixTranspose(m_game->GameCamera()->Projection()),
            XMMatrixTranspose(XMLoadFloat4x4(&m_rotationTransform3D))
            )
        );

    m_d3dContext->UpdateSubresource(
        m_constantBufferChangeOnResize.Get(),
        0,
        nullptr,
        &changesOnResize,
        0,
        0
        );

    m_gameResourcesLoaded = true;
}

void GameRenderer::FinalizeCreateGameDeviceResources ( )
void GameRenderer::FinalizeLoadLevelResources ( )

Definition at line 430 of file GameRenderer.cpp.

{
    // Once the level specific resources had been loaded, this method is
    // where D3D context specific actions would be handled.  This method
    // runs in the same thread context as the GameRenderer was created.

    m_levelResourcesLoaded = true;
}

void GameRenderer::FinalizeLoadLevelResources ( )
DirectX::XMFLOAT2 GameRenderer::GameInfoOverlayLowerRight ( ) [inline]

Definition at line 88 of file GameRenderer.h.

    {
        return DirectX::XMFLOAT2(
            (m_windowBounds.Width  - GameInfoOverlayConstant::Width) / 2.0f + GameInfoOverlayConstant::Width,
            (m_windowBounds.Height - GameInfoOverlayConstant::Height) / 2.0f + GameInfoOverlayConstant::Height
            );
    };

DirectX::XMFLOAT2 GameRenderer::GameInfoOverlayUpperLeft ( ) [inline]

Definition at line 81 of file GameRenderer.h.

    {
        return DirectX::XMFLOAT2(
            (m_windowBounds.Width  - GameInfoOverlayConstant::Width) / 2.0f,
            (m_windowBounds.Height - GameInfoOverlayConstant::Height) / 2.0f
            );
    };

virtual void GameRenderer::HandleDeviceLost ( ) [override, virtual]
void GameRenderer::HandleDeviceLost ( ) [override, virtual]

Definition at line 54 of file GameRenderer.cpp.

{
    // On device lost all the device resources are invalid.
    // Set the state of the renderer to not have a pointer to the
    // Simple3DGame object.  It will be reset as a part of the
    // game devices resources being recreated.
    m_game = nullptr;

    DirectXBase::HandleDeviceLost();
}

GameHud GameRenderer::Hud ( )

Definition at line 607 of file GameRenderer.cpp.

{
    return m_gameHud;
}

GameInfoOverlay GameRenderer::InfoOverlay ( ) [inline]

Definition at line 79 of file GameRenderer.h.

{ return m_gameInfoOverlay; };

virtual void GameRenderer::Initialize | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [override, virtual]
virtual void GameRenderer::Initialize | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^ | swapChainPanel,
 |  | float | dpi |
 | ) |  |  | [override, virtual]
task< void > GameRenderer::LoadLevelResourcesAsync ( )

Definition at line 415 of file GameRenderer.cpp.

{
    m_levelResourcesLoaded = false;

    return create_task([this]()
    {
        // This is where additional async loading of level specific resources
        // would be done.  Since there aren't any to load, just simulate
        // by delaying for some time.
        wait(GameConstants::LevelLoadingDelay);
    });
}

concurrency::task<void> GameRenderer::LoadLevelResourcesAsync ( )
virtual void GameRenderer::Render ( ) [override, virtual]
void GameRenderer::Render ( ) [override, virtual]

Definition at line 441 of file GameRenderer.cpp.

{
    int renderingPasses = 1;
    if (m_stereoEnabled)
    {
        renderingPasses = 2;
    }

    for (int i = 0; i < renderingPasses; i++)
    {
        // Iterate through the number of rendering passes to be completed.
        if (m_stereoEnabled && i > 0)
        {
            // Doing the Right Eye View.
            m_d3dContext->OMSetRenderTargets(1, m_d3dRenderTargetViewRight.GetAddressOf(), m_d3dDepthStencilView.Get());
            m_d3dContext->ClearDepthStencilView(m_d3dDepthStencilView.Get(), D3D11_CLEAR_DEPTH, 1.0f, 0);
            m_d2dContext->SetTarget(m_d2dTargetBitmapRight.Get());
        }
        else
        {
            // Doing the Mono or Left Eye View.
            m_d3dContext->OMSetRenderTargets(1, m_d3dRenderTargetView.GetAddressOf(), m_d3dDepthStencilView.Get());
            m_d3dContext->ClearDepthStencilView(m_d3dDepthStencilView.Get(), D3D11_CLEAR_DEPTH, 1.0f, 0);
            m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
        }

        if (m_game != nullptr && m_gameResourcesLoaded && m_levelResourcesLoaded)
        {
            // This section is only used after the game state has been initialized and all device
            // resources needed for the game have been created and associated with the game objects.
            if (m_stereoEnabled)
            {
                // When doing stereo, it is necessary to update the projection matrix once per rendering pass.
                ConstantBufferChangeOnResize changesOnResize;
                XMStoreFloat4x4(
                    &changesOnResize.projection,
                    XMMatrixMultiply(
                        XMMatrixTranspose(
                            i == 0 ?
                            m_game->GameCamera()->LeftEyeProjection() :
                            m_game->GameCamera()->RightEyeProjection()
                            ),
                        XMMatrixTranspose(XMLoadFloat4x4(&m_rotationTransform3D))
                        )
                    );

                m_d3dContext->UpdateSubresource(
                    m_constantBufferChangeOnResize.Get(),
                    0,
                    nullptr,
                    &changesOnResize,
                    0,
                    0
                    );
            }
            // Update variables that change once per frame.

            ConstantBufferChangesEveryFrame constantBufferChangesEveryFrame;
            XMStoreFloat4x4(
                &constantBufferChangesEveryFrame.view,
                XMMatrixTranspose(m_game->GameCamera()->View())
                );
            m_d3dContext->UpdateSubresource(
                m_constantBufferChangesEveryFrame.Get(),
                0,
                nullptr,
                &constantBufferChangesEveryFrame,
                0,
                0
                );

            // Setup the graphics pipeline. This sample uses the same InputLayout and set of
            // constant buffers for all shaders, so they only need to be set once per frame.

            m_d3dContext->IASetInputLayout(m_vertexLayout.Get());
            m_d3dContext->VSSetConstantBuffers(0, 1, m_constantBufferNeverChanges.GetAddressOf());
            m_d3dContext->VSSetConstantBuffers(1, 1, m_constantBufferChangeOnResize.GetAddressOf());
            m_d3dContext->VSSetConstantBuffers(2, 1, m_constantBufferChangesEveryFrame.GetAddressOf());
            m_d3dContext->VSSetConstantBuffers(3, 1, m_constantBufferChangesEveryPrim.GetAddressOf());

            m_d3dContext->PSSetConstantBuffers(2, 1, m_constantBufferChangesEveryFrame.GetAddressOf());
            m_d3dContext->PSSetConstantBuffers(3, 1, m_constantBufferChangesEveryPrim.GetAddressOf());
            m_d3dContext->PSSetSamplers(0, 1, m_samplerLinear.GetAddressOf());

            auto objects = m_game->RenderObjects();
            for (auto object = objects.begin(); object != objects.end(); object++)
            {
                (*object)->Render(m_d3dContext.Get(), m_constantBufferChangesEveryPrim.Get());
            }
        }
        else
        {
            const float ClearColor[4] = {0.1f, 0.1f, 0.1f, 1.0f};

            // Only need to clear the background when not rendering the full 3D scene since
            // the 3D world is a fully enclosed box and the dynamics prevents the camera from
            // moving outside this space.
            if (m_stereoEnabled && i > 0)
            {
                // Doing the Right Eye View.
                m_d3dContext->ClearRenderTargetView(m_d3dRenderTargetViewRight.Get(), ClearColor);
            }
            else
            {
                // Doing the Mono or Left Eye View.
                m_d3dContext->ClearRenderTargetView(m_d3dRenderTargetView.Get(), ClearColor);
            }
        }

        m_d2dContext->BeginDraw();

        // To handle the swapchain being pre-rotated, set the D2D transformation to include it.
        m_d2dContext->SetTransform(m_rotationTransform2D);

        if (m_game != nullptr && m_gameResourcesLoaded)
        {
            // This is only used after the game state has been initialized.
            m_gameHud->Render(m_game, m_d2dContext.Get(), m_windowBounds);
        }

        if (m_gameInfoOverlay->Visible())
        {
            m_d2dContext->DrawBitmap(
                m_gameInfoOverlay->Bitmap(),
                D2D1::RectF(
                    (m_windowBounds.Width - GameInfoOverlayConstant::Width)/2.0f,
                    (m_windowBounds.Height - GameInfoOverlayConstant::Height)/2.0f,
                    (m_windowBounds.Width - GameInfoOverlayConstant::Width)/2.0f + GameInfoOverlayConstant::Width,
                    (m_windowBounds.Height - GameInfoOverlayConstant::Height)/2.0f + GameInfoOverlayConstant::Height
                    )
                );
        }

        // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
        // is lost. It will be handled during the next call to Present.
        HRESULT hr = m_d2dContext->EndDraw();
        if (hr != D2DERR_RECREATE_TARGET)
        {
            DX::ThrowIfFailed(hr);
        }
    }
    Present();
}

void GameRenderer::SetBackground ( uint32 background )

Definition at line 442 of file GameRenderer.cpp.

{
    if (background < GameConstants::MaxBackgroundTextures)
    {
        if (m_ceilingTexture[background] != nullptr &&
            m_floorTexture[background] != nullptr &&
            m_wallsTexture[background] != nullptr)
        {
            auto objects = m_game->RenderObjects();

            // Attach the textures to the appropriate game objects.
            for (auto object = objects.begin(); object != objects.end(); object++)
            {
                if ((*object)->TargetId() == GameConstants::WorldFloorId)
                {
                    (*object)->NormalMaterial()->SetTexture(m_floorTexture[background].Get());
                }
                else if ((*object)->TargetId() == GameConstants::WorldCeilingId)
                {
                    (*object)->NormalMaterial()->SetTexture(m_ceilingTexture[background].Get());
                }
                else if ((*object)->TargetId() == GameConstants::WorldWallsId)
                {
                    (*object)->NormalMaterial()->SetTexture(m_wallsTexture[background].Get());
                }
            }
        }
    }
}

void GameRenderer::SetDpi ( float dpi ) [override, virtual]

Definition at line 125 of file GameRenderer.cpp.

{
    DirectXBase::SetDpi(dpi);

    m_gameInfoOverlay->CreateDpiDependentResources(dpi);
}

virtual void GameRenderer::UpdateForWindowSizeChange ( ) [override, virtual]
void GameRenderer::UpdateForWindowSizeChange ( ) [override, virtual]

Definition at line 89 of file GameRenderer.cpp.

{
    DirectXBase::UpdateForWindowSizeChange();

    m_gameHud->UpdateForWindowSizeChange(m_windowBounds);

    if (m_game != nullptr)
    {
        // Update the Projection Matrix and the associated Constant Buffer.
        m_game->GameCamera()->SetProjParams(
            XM_PI / 2, m_renderTargetSize.Width / m_renderTargetSize.Height,
            0.01f,
            100.0f
            );
        ConstantBufferChangeOnResize changesOnResize;
        XMStoreFloat4x4(
            &changesOnResize.projection,
            XMMatrixMultiply(
                XMMatrixTranspose(m_game->GameCamera()->Projection()),
                XMMatrixTranspose(XMLoadFloat4x4(&m_rotationTransform3D))
                )
            );

        m_d3dContext->UpdateSubresource(
            m_constantBufferChangeOnResize.Get(),
            0,
            nullptr,
            &changesOnResize,
            0,
            0
            );
    }
}

Member Data Documentation

internal GameRenderer::__pad0__

Definition at line 60 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11ShaderResourceView > GameRenderer::m_ceilingTexture [private]

Definition at line 110 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11Buffer > GameRenderer::m_constantBufferChangeOnResize [private]

Definition at line 115 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11Buffer > GameRenderer::m_constantBufferChangesEveryFrame [private]

Definition at line 116 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11Buffer > GameRenderer::m_constantBufferChangesEveryPrim [private]

Definition at line 117 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11Buffer > GameRenderer::m_constantBufferNeverChanges [private]

Definition at line 114 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11ShaderResourceView > GameRenderer::m_cylinderTexture [private]

Definition at line 109 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11ShaderResourceView > GameRenderer::m_floorTexture [private]

Definition at line 111 of file GameRenderer.h.

Simple3DGame GameRenderer::m_game [private]

Definition at line 106 of file GameRenderer.h.

GameHud GameRenderer::m_gameHud [private]

Definition at line 105 of file GameRenderer.h.

GameInfoOverlay GameRenderer::m_gameInfoOverlay [private]

Definition at line 104 of file GameRenderer.h.

bool GameRenderer::m_gameResourcesLoaded [private]

Definition at line 102 of file GameRenderer.h.

bool GameRenderer::m_initialized [private]

Definition at line 94 of file GameRenderer.h.

bool GameRenderer::m_levelResourcesLoaded [private]

Definition at line 103 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11PixelShader > GameRenderer::m_pixelShader [private]

Definition at line 121 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11PixelShader > GameRenderer::m_pixelShaderFlat [private]

Definition at line 122 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11SamplerState > GameRenderer::m_samplerLinear [private]

Definition at line 118 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11ShaderResourceView > GameRenderer::m_sphereTexture [private]

Definition at line 108 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11InputLayout > GameRenderer::m_vertexLayout [private]

Definition at line 123 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11VertexShader > GameRenderer::m_vertexShader [private]

Definition at line 119 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11VertexShader > GameRenderer::m_vertexShaderFlat [private]

Definition at line 120 of file GameRenderer.h.

Microsoft::WRL::ComPtr< ID3D11ShaderResourceView > GameRenderer::m_wallsTexture [private]

Definition at line 112 of file GameRenderer.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/GameRenderer.h
  • XAML DirectX 3D shooting game/C++/GameRenderer.h
  • DirectX 3D shooting game/C++/GameRenderer.cpp
  • XAML DirectX 3D shooting game/C++/GameRenderer.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameTimer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

GameTimer Class Reference

THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A //// PARTICULAR PURPOSE. //// //// Copyright (c) Microsoft Corporation. All rights reserved.

#include "GameTimer.h"

List of all members.

Public Member Functions

bool | Active ()
bool | Active ()
float | DeltaTime ()
float | DeltaTime ()
void | PlayingTime (float time)
float | PlayingTime ()
void | PlayingTime (float time)
float | PlayingTime ()
void | Reset ()
void | Reset ()
void | Start ()
void | Start ()
void | Stop ()
void | Stop ()
void | Update ()
void | Update ()

Public Attributes

internal | __pad0__: GameTimer()

Private Attributes

bool | m_active
LARGE_INTEGER | m_baseTime
LARGE_INTEGER | m_currentTime
float | m_deltaTime
LARGE_INTEGER | m_pausedTime
LARGE_INTEGER | m_previousTime
float | m_secondsPerCount
LARGE_INTEGER | m_stopTime

Detailed Description

Definition at line 10 of file GameTimer.h.

Member Function Documentation

bool GameTimer::Active ( ) [inline]

Definition at line 23 of file GameTimer.h.

{ return m_active; };

bool GameTimer::Active ( ) [inline]

Definition at line 23 of file GameTimer.h.

{ return m_active; };

float GameTimer::DeltaTime ( )

Definition at line 56 of file GameTimer.cpp.

{
    return m_deltaTime;
}

float GameTimer::DeltaTime ( )
void GameTimer::PlayingTime ( float time )

Definition at line 44 of file GameTimer.cpp.

{
    // Reset the internal state to reflect a PlayingTime of 'time'
    // Offset the baseTime by this 'time'.
    m_active = false;
    m_stopTime = m_currentTime;
    m_pausedTime.QuadPart = 0;

    m_baseTime.QuadPart = m_stopTime.QuadPart - static_cast<__int64>(time / m_secondsPerCount);
}

float GameTimer::PlayingTime ( )
void GameTimer::PlayingTime ( float time )
float GameTimer::PlayingTime ( )

Definition at line 26 of file GameTimer.cpp.

{
    if (m_active)
    {
        // The distance m_currentTime - m_baseTime includes paused time,
        // which we do not want to count.  To correct this, we can subtract
        // the paused time from m_currentTime:
        return static_cast<float>(((m_currentTime.QuadPart - m_pausedTime.QuadPart) - m_baseTime.QuadPart)*m_secondsPerCount);
    }
    else
    {
        // The clock is currently not running so don't count the time since
        // the clock was stopped
        return static_cast<float>(((m_stopTime.QuadPart - m_pausedTime.QuadPart) - m_baseTime.QuadPart)*m_secondsPerCount);
    }
}

void GameTimer::Reset ( )

Definition at line 61 of file GameTimer.cpp.

{
    LARGE_INTEGER currentTime;
    if (!QueryPerformanceCounter(&currentTime))
    {
        throw ref new Platform::FailureException();
    }
    m_baseTime = currentTime;
    m_previousTime = currentTime;
    m_stopTime = currentTime;
    m_currentTime = currentTime;
    m_pausedTime.QuadPart = 0;
    m_active = false;
}

void GameTimer::Reset ( )
void GameTimer::Start ( )
void GameTimer::Start ( )

Definition at line 76 of file GameTimer.cpp.

{
    LARGE_INTEGER startTime;
    if (!QueryPerformanceCounter(&startTime))
    {
        throw ref new Platform::FailureException();
    }
    if (!m_active)
    {
        // Accumulate the time elapsed between stop and start pairs.
        m_pausedTime.QuadPart += (startTime.QuadPart - m_stopTime.QuadPart);

        m_previousTime = startTime;
        m_stopTime.QuadPart = 0;
        m_active = true;
    }
}

void GameTimer::Stop ( )
void GameTimer::Stop ( )

Definition at line 94 of file GameTimer.cpp.

{
    if (m_active)
    {
        // Set the stop time to the time of the last update.
        m_stopTime = m_currentTime;
        m_active = false;
    }
}

void GameTimer::Update ( )

Definition at line 104 of file GameTimer.cpp.

{
    if (!m_active)
    {
        m_deltaTime = 0.0;
        return;
    }

    LARGE_INTEGER currentTime;
    if (!QueryPerformanceCounter(&currentTime))
    {
        throw ref new Platform::FailureException();
    }
    m_currentTime = currentTime;

    m_deltaTime = (m_currentTime.QuadPart - m_previousTime.QuadPart)*m_secondsPerCount;
    m_previousTime = m_currentTime;

    if (m_deltaTime < 0.0)
    {
        m_deltaTime = 0.0;
    }
}

void GameTimer::Update ( )

Member Data Documentation

internal GameTimer::__pad0__

Definition at line 13 of file GameTimer.h.

bool GameTimer::m_active [private]

Definition at line 35 of file GameTimer.h.

LARGE_INTEGER GameTimer::m_baseTime [private]

Definition at line 29 of file GameTimer.h.

LARGE_INTEGER GameTimer::m_currentTime [private]

Definition at line 33 of file GameTimer.h.

float GameTimer::m_deltaTime [private]

Definition at line 27 of file GameTimer.h.

LARGE_INTEGER GameTimer::m_pausedTime [private]

Definition at line 30 of file GameTimer.h.

LARGE_INTEGER GameTimer::m_previousTime [private]

Definition at line 32 of file GameTimer.h.

float GameTimer::m_secondsPerCount [private]

Definition at line 23 of file GameTimer.h.

LARGE_INTEGER GameTimer::m_stopTime [private]

Definition at line 31 of file GameTimer.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/GameTimer.h
  • XAML DirectX 3D shooting game/C++/GameTimer.h
  • DirectX 3D shooting game/C++/GameTimer.cpp
  • XAML DirectX 3D shooting game/C++/GameTimer.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GeometryRealization Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Member Functions | Static Protected Member Functions | Protected Attributes

GeometryRealization Class Reference

List of all members.

Public Member Functions

STDMETHOD() | Draw (ID2D1DeviceContext *deviceContext, ID2D1Brush *brush, REALIZATION_RENDER_MODE mode)
STDMETHOD() | Fill (ID2D1DeviceContext *deviceContext, ID2D1Brush *brush, REALIZATION_RENDER_MODE mode)
STDMETHOD() | QueryInterface (REFIID iid, void **ppvObject)
STDMETHOD_ (ULONG, AddRef)()
STDMETHOD_ (ULONG, Release)()
STDMETHOD() | Update (ID2D1Geometry *geometry, REALIZATION_CREATION_OPTIONS options, CONST D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle)

Static Public Member Functions

static HRESULT | Create (ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension, ID2D1Geometry *geometry, REALIZATION_CREATION_OPTIONS options, CONST D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle, IGeometryRealization **realization)

Protected Member Functions

GeometryRealization ()
~GeometryRealization ()
HRESULT | Initialize (ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension, ID2D1Geometry *geometry, REALIZATION_CREATION_OPTIONS options, CONST D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle)
HRESULT | RenderToTarget (bool fill, ID2D1DeviceContext *deviceContext, ID2D1Brush *brush, REALIZATION_RENDER_MODE mode)

Static Protected Member Functions

static HRESULT | GenerateOpacityMask (bool fill, ID2D1DeviceContext *baseRT, UINT maxRealizationDimension, ID2D1BitmapRenderTarget **bitmapRT, ID2D1Geometry *geometry, const D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle, D2D1_RECT_F *maskDestBounds, D2D1_RECT_F *maskSourceBounds)

Protected Attributes

ID2D1DeviceContext * | m_deviceContext
D2D1_RECT_F | m_fillMaskDestBounds
D2D1_RECT_F | m_fillMaskSourceBounds
ID2D1Mesh * | m_fillMesh
ID2D1BitmapRenderTarget * | m_fillRT
ID2D1Geometry * | m_geometry
UINT | m_maxRealizationDimension
D2D1::Matrix3x2F | m_realizationTransform
D2D1::Matrix3x2F | m_realizationTransformInv
bool | m_realizationTransformIsIdentity
ULONG volatile | m_ref
D2D1_RECT_F | m_strokeMaskDestBounds
D2D1_RECT_F | m_strokeMaskSourceBounds
ID2D1Mesh * | m_strokeMesh
ID2D1BitmapRenderTarget * | m_strokeRT
ID2D1StrokeStyle * | m_strokeStyle
float | m_strokeWidth
BOOL | m_swRT

Detailed Description

Definition at line 55 of file GeometryRealizationPackage.cpp.

Constructor & Destructor Documentation

GeometryRealization::GeometryRealization ( ) [protected]

Definition at line 454 of file GeometryRealizationPackage.cpp.

                                         :
    m_ref(1),
    m_fillMesh(nullptr),
    m_strokeMesh(nullptr),
    m_fillRT(nullptr),
    m_strokeRT(nullptr),
    m_geometry(nullptr),
    m_strokeStyle(nullptr),
    m_deviceContext(nullptr)
{
}

GeometryRealization::~GeometryRealization ( ) [protected]

Definition at line 472 of file GeometryRealizationPackage.cpp.

{
    SafeRelease(&m_fillMesh);
    SafeRelease(&m_strokeMesh);
    SafeRelease(&m_fillRT);
    SafeRelease(&m_strokeRT);
    SafeRelease(&m_geometry);
    SafeRelease(&m_strokeStyle);
    SafeRelease(&m_deviceContext);
}

Member Function Documentation

HRESULT GeometryRealization::Create | ( | ID2D1DeviceContext * | deviceContext,
 |  | UINT | maxRealizationDimension,
 |  | ID2D1Geometry * | geometry,
 |  | REALIZATION_CREATION_OPTIONS | options,
 |  | CONST D2D1_MATRIX_3X2_F * | worldTransform,
 |  | float | strokeWidth,
 |  | ID2D1StrokeStyle * | strokeStyle,
 |  | IGeometryRealization ** | realization |
 | ) |  |  | [static]

Definition at line 407 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    GeometryRealization *geometryRealization = nullptr;

    geometryRealization = new (std::nothrow) GeometryRealization();
    hr = geometryRealization ? S_OK : E_OUTOFMEMORY;
    if (SUCCEEDED(hr))
    {
        hr = geometryRealization->Initialize(
            deviceContext,
            maxRealizationDimension,
            geometry,
            options,
            worldTransform,
            strokeWidth,
            strokeStyle
            );
        if (SUCCEEDED(hr))
        {
            *realization = geometryRealization;
            (*realization)->AddRef();
        }

        geometryRealization->Release();
    }

    return hr;
}

STDMETHODIMP GeometryRealization::Draw | ( | ID2D1DeviceContext * | deviceContext,
 |  | ID2D1Brush * | brush,
 |  | REALIZATION_RENDER_MODE | mode
 | ) |  |

Definition at line 511 of file GeometryRealizationPackage.cpp.

{
    return RenderToTarget(
        false, // => stroke
        deviceContext,
        brush,
        mode
        );
}

STDMETHODIMP GeometryRealization::Fill | ( | ID2D1DeviceContext * | deviceContext,
 |  | ID2D1Brush * | brush,
 |  | REALIZATION_RENDER_MODE | mode
 | ) |  |

Definition at line 490 of file GeometryRealizationPackage.cpp.

{
    return RenderToTarget(
        true, // => fill
        deviceContext,
        brush,
        mode
        );
}

HRESULT GeometryRealization::GenerateOpacityMask | ( | bool | fill,
 |  | ID2D1DeviceContext * | baseRT,
 |  | UINT | maxRealizationDimension,
 |  | ID2D1BitmapRenderTarget ** | bitmapRT,
 |  | ID2D1Geometry * | geometry,
 |  | const D2D1_MATRIX_3X2_F * | worldTransform,
 |  | float | strokeWidth,
 |  | ID2D1StrokeStyle * | strokeStyle,
 |  | D2D1_RECT_F * | maskDestBounds,
 |  | D2D1_RECT_F * | maskSourceBounds |
 | ) |  |  | [static, protected]

Definition at line 950 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    D2D1_RECT_F bounds;
    D2D1_RECT_F inflatedPixelBounds;
    D2D1_SIZE_U inflatedIntegerPixelSize;
    D2D1_SIZE_U currentRTSize;
    D2D1_MATRIX_3X2_F translateMatrix;
    float dpiX, dpiY;
    float scaleX = 1.0f;
    float scaleY = 1.0f;

    ID2D1BitmapRenderTarget *compatRT = nullptr;
    SafeReplace(&compatRT, *bitmapRT);

    ID2D1SolidColorBrush *brush = nullptr;

    hr = baseRT->CreateSolidColorBrush(
        D2D1::ColorF(1.0f, 1.0f, 1.0f, 1.0f),
        &brush
        );
    if (SUCCEEDED(hr))
    {
        baseRT->GetDpi(&dpiX, &dpiY);
        if (fill)
        {
            hr = geometry->GetBounds(
                worldTransform,
                &bounds
                );
        }
        else
        {
            hr = geometry->GetWidenedBounds(
                strokeWidth,
                strokeStyle,
                worldTransform,
                &bounds
                );
        }

        if (SUCCEEDED(hr))
        {
            //
            // A rect where left > right is defined to be empty.
            //
            // The slightly baroque expression used below is an idiom that also
            // correctly handles NaNs (i.e., if any of the coordinates of the bounds is
            // a NaN, we want to treat the bounds as empty)
            //
            if (!(bounds.left <= bounds.right) ||
                !(bounds.top <= bounds.bottom)
                )
            {
                // Bounds are empty or ill-defined.

                // Make up a fake bounds
                inflatedPixelBounds.top = 0.0f;
                inflatedPixelBounds.left = 0.0f;
                inflatedPixelBounds.bottom = 1.0f;
                inflatedPixelBounds.right = 1.0f;
            }
            else
            {
                //
                // We inflate the pixel bounds by 1 in each direction to ensure we have
                // a border of completely transparent pixels around the geometry.  This
                // ensures that when the realization is stretched the alpha ramp still
                // smoothly falls off to 0 rather than being clipped by the rect.
                //
                inflatedPixelBounds.top = floorf(bounds.top*dpiY/96)-1.0f;
                inflatedPixelBounds.left = floorf(bounds.left*dpiX/96)-1.0f;
                inflatedPixelBounds.bottom = ceilf(bounds.bottom*dpiY/96)+1.0f;
                inflatedPixelBounds.right = ceilf(bounds.right*dpiX/96)+1.0f;
            }

            //
            // Compute the width and height of the underlying bitmap we will need.
            // Note: We round up the width and height to be a multiple of
            // sc_bitmapChunkSize. We do this primarily to ensure that we aren't
            // constantly reallocating bitmaps in the case where a realization is being
            // zoomed in on slowly and updated frequently.
            //

            inflatedIntegerPixelSize = D2D1::SizeU(
                static_cast<UINT>(inflatedPixelBounds.right - inflatedPixelBounds.left),
                static_cast<UINT>(inflatedPixelBounds.bottom - inflatedPixelBounds.top)
                );

            // Round up
            inflatedIntegerPixelSize.width =
                (inflatedIntegerPixelSize.width + sc_bitmapChunkSize - 1)/sc_bitmapChunkSize * sc_bitmapChunkSize;

            // Round up
            inflatedIntegerPixelSize.height =
                (inflatedIntegerPixelSize.height + sc_bitmapChunkSize - 1)/sc_bitmapChunkSize * sc_bitmapChunkSize;

            //
            // Compute the bounds we will pass to FillOpacityMask (which are in Device
            // Independent Pixels).
            //
            // Note: The DIP bounds do *not* use the rounded coordinates, since this
            // would cause us to render superfluous, fully-transparent pixels, which
            // would hurt fill rate.
            //
            D2D1_RECT_F inflatedDipBounds = D2D1::RectF(
                inflatedPixelBounds.left * 96/dpiX,
                inflatedPixelBounds.top * 96/dpiY,
                inflatedPixelBounds.right * 96/dpiX,
                inflatedPixelBounds.bottom * 96/dpiY
                );

            if (compatRT)
            {
                currentRTSize = compatRT->GetPixelSize();
            }
            else
            {
                // This will force the creation of a new target
                currentRTSize = D2D1::SizeU(0, 0);
            }

            //
            // We need to ensure that our desired render target size isn't larger than
            // the max allowable bitmap size. If it is, we need to scale the bitmap
            // down by the appropriate amount.
            //

            if (inflatedIntegerPixelSize.width > maxRealizationDimension)
            {
                scaleX = maxRealizationDimension/static_cast<float>(inflatedIntegerPixelSize.width);
                inflatedIntegerPixelSize.width = maxRealizationDimension;
            }

            if (inflatedIntegerPixelSize.height > maxRealizationDimension)
            {
                scaleY = maxRealizationDimension/static_cast<float>(inflatedIntegerPixelSize.height);
                inflatedIntegerPixelSize.height = maxRealizationDimension;
            }

            //
            // If the necessary pixel dimensions are less than half the existing
            // bitmap's dimensions (in either direction), force the bitmap to be
            // reallocated to save memory.
            //
            // Note: The fact that we use > rather than >= is important for a subtle
            // reason: We'd like to have the property that repeated small changes in
            // geometry size do not cause repeated reallocations of memory. >= does not
            // ensure this property in the case where the geometry size is close to
            // sc_bitmapChunkSize, but > does.
            //
            // Example:
            //
            // Assume sc_bitmapChunkSize is 64 and the initial geometry width is 63
            // pixels. This will get rounded up to 64, and we will allocate a bitmap
            // with width 64. Now, say, we zoom in slightly, so the new geometry width
            // becomes 65 pixels. This will get rounded up to 128 pixels, and a new
            // bitmap will be allocated. Now, say the geometry drops back down to 63
            // pixels. This will get rounded up to 64. If we used >=, this would cause
            // another reallocation.  Since we use >, on the other hand, the 128 pixel
            // bitmap will be reused.
            //

            if (currentRTSize.width > 2*inflatedIntegerPixelSize.width ||
                currentRTSize.height > 2*inflatedIntegerPixelSize.height
                )
            {
                SafeRelease(&compatRT);
                currentRTSize.width = currentRTSize.height = 0;
            }

            if (inflatedIntegerPixelSize.width > currentRTSize.width ||
                inflatedIntegerPixelSize.height > currentRTSize.height
                )
            {
                SafeRelease(&compatRT);
            }

            if (!compatRT)
            {
                //
                // Make sure our new rendertarget is strictly larger than before.
                //
                currentRTSize.width =
                    max(inflatedIntegerPixelSize.width, currentRTSize.width);

                currentRTSize.height =
                    max(inflatedIntegerPixelSize.height, currentRTSize.height);

                D2D1_PIXEL_FORMAT alphaOnlyFormat =
                    D2D1::PixelFormat(
                        DXGI_FORMAT_A8_UNORM,
                        D2D1_ALPHA_MODE_PREMULTIPLIED
                        );

                hr = baseRT->CreateCompatibleRenderTarget(
                    nullptr, // desiredSize
                    &currentRTSize,
                    &alphaOnlyFormat,
                    D2D1_COMPATIBLE_RENDER_TARGET_OPTIONS_NONE,
                    &compatRT
                    );
            }

            if (SUCCEEDED(hr))
            {
                //
                // Translate the geometry so it is flush against the left and top
                // sides of the render target.
                //

                translateMatrix =
                    D2D1::Matrix3x2F::Translation(
                        -inflatedDipBounds.left,
                        -inflatedDipBounds.top
                        ) *
                    D2D1::Matrix3x2F::Scale(
                        scaleX,
                        scaleY
                        );

                if (worldTransform)
                {
                    compatRT->SetTransform(
                        *worldTransform * translateMatrix
                        );
                }
                else
                {
                    compatRT->SetTransform(
                        translateMatrix
                        );
                }

                //
                // Render the geometry.
                //

                compatRT->BeginDraw();

                compatRT->Clear(
                    D2D1::ColorF(0.0f, 0.0f, 0.0f, 0.0f)
                    );

                if (fill)
                {
                    compatRT->FillGeometry(
                        geometry,
                        brush
                        );
                }
                else
                {
                    compatRT->DrawGeometry(
                        geometry,
                        brush,
                        strokeWidth,
                        strokeStyle
                        );
                }

                hr = compatRT->EndDraw();
                if (hr == D2DERR_RECREATE_TARGET)
                {
                    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
                    // is lost. It will be handled during the next call to Present.
                    hr = S_OK;
                }
                if (SUCCEEDED(hr))
                {
                    //
                    // Report back the source and dest bounds (to be used as input parameters
                    // to FillOpacityMask.
                    //
                    *maskDestBounds = inflatedDipBounds;

                    *maskSourceBounds = D2D1::Rect<float>(
                        0.0f,
                        0.0f,
                        static_cast<float>(inflatedDipBounds.right - inflatedDipBounds.left)*scaleX,
                        static_cast<float>(inflatedDipBounds.bottom - inflatedDipBounds.top)*scaleY
                        );

                    if (*bitmapRT != compatRT)
                    {
                        SafeReplace(bitmapRT, compatRT);
                    }
                }
            }
        }
        brush->Release();
    }

    SafeRelease(&compatRT);

    return hr;
}

HRESULT GeometryRealization::Initialize | ( | ID2D1DeviceContext * | deviceContext,
 |  | UINT | maxRealizationDimension,
 |  | ID2D1Geometry * | geometry,
 |  | REALIZATION_CREATION_OPTIONS | options,
 |  | CONST D2D1_MATRIX_3X2_F * | worldTransform,
 |  | float | strokeWidth,
 |  | ID2D1StrokeStyle * | strokeStyle |
 | ) |  |  | [protected]

Definition at line 896 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    m_deviceContext = deviceContext;
    m_deviceContext->AddRef();

    m_swRT = deviceContext->IsSupported(
        D2D1::RenderTargetProperties(D2D1_RENDER_TARGET_TYPE_SOFTWARE)
        );

    m_maxRealizationDimension = maxRealizationDimension;

    if (geometry)
    {
        hr = Update(
            geometry,
            options,
            worldTransform,
            strokeWidth,
            strokeStyle
            );
    }

    return hr;
}

STDMETHODIMP GeometryRealization::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppvObject
 | ) |  |

Definition at line 1363 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    if (__uuidof(IUnknown) == iid)
    {
        *object = static_cast<IUnknown*>(this);
        AddRef();
    }
    else if (__uuidof(IGeometryRealization) == iid)
    {
        *object = static_cast<IGeometryRealization*>(this);
        AddRef();
    }
    else
    {
        *object = nullptr;
        hr = E_NOINTERFACE;
    }

    return hr;
}

HRESULT GeometryRealization::RenderToTarget | ( | bool | fill,
 |  | ID2D1DeviceContext * | deviceContext,
 |  | ID2D1Brush * | brush,
 |  | REALIZATION_RENDER_MODE | mode |
 | ) |  |  | [protected]

Definition at line 734 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    D2D1_ANTIALIAS_MODE originalAAMode = pDeviceContext->GetAntialiasMode();
    D2D1_MATRIX_3X2_F originalTransform;

    if (((mode == REALIZATION_RENDER_MODE_DEFAULT) && m_swRT) ||
        (mode == REALIZATION_RENDER_MODE_FORCE_UNREALIZED)
        )
    {
        if (!m_geometry)
        {
            // We're being asked to render the geometry unrealized, but we
            // weren't created with REALIZATION_CREATION_OPTIONS_UNREALIZED.
            hr = E_FAIL;
        }
        if (SUCCEEDED(hr))
        {
            if (fill)
            {
                pDeviceContext->FillGeometry(
                    m_geometry,
                    pBrush
                    );
            }
            else
            {
                pDeviceContext->DrawGeometry(
                    m_geometry,
                    pBrush,
                    m_strokeWidth,
                    m_strokeStyle
                    );
            }
        }
    }
    else
    {
        if (originalAAMode != D2D1_ANTIALIAS_MODE_ALIASED)
        {
            pDeviceContext->SetAntialiasMode(D2D1_ANTIALIAS_MODE_ALIASED);
        }

        if (!m_realizationTransformIsIdentity)
        {
            pDeviceContext->GetTransform(&originalTransform);
            pDeviceContext->SetTransform(m_realizationTransformInv * originalTransform);
        }

        if (originalAAMode == D2D1_ANTIALIAS_MODE_PER_PRIMITIVE)
        {
            if (fill)
            {
                if (!m_fillRT)
                {
                    hr = E_FAIL;
                }
                if (SUCCEEDED(hr))
                {
                    ID2D1Bitmap *pBitmap = nullptr;
                    m_fillRT->GetBitmap(&pBitmap);

                    //
                    // Note: The antialias mode must be set to aliased prior to calling
                    // FillOpacityMask.
                    //
                    pDeviceContext->FillOpacityMask(
                        pBitmap,
                        pBrush,
                        D2D1_OPACITY_MASK_CONTENT_GRAPHICS,
                        &m_fillMaskDestBounds,
                        &m_fillMaskSourceBounds
                        );

                    pBitmap->Release();
                }
            }
            else
            {
                if (!m_strokeRT)
                {
                    hr = E_FAIL;
                }
                if (SUCCEEDED(hr))
                {
                    ID2D1Bitmap *pBitmap = nullptr;
                    m_strokeRT->GetBitmap(&pBitmap);

                    //
                    // Note: The antialias mode must be set to aliased prior to calling
                    // FillOpacityMask.
                    //
                    pDeviceContext->FillOpacityMask(
                        pBitmap,
                        pBrush,
                        D2D1_OPACITY_MASK_CONTENT_GRAPHICS,
                        &m_strokeMaskDestBounds,
                        &m_strokeMaskSourceBounds
                        );

                    pBitmap->Release();
                }
            }
        }
        else
        {
            if (fill)
            {
                if (!m_fillMesh)
                {
                    hr = E_FAIL;
                }
                if (SUCCEEDED(hr))
                {
                    pDeviceContext->FillMesh(
                        m_fillMesh,
                        pBrush
                        );
                }
            }
            else
            {
                if (!m_strokeMesh)
                {
                    hr = E_FAIL;
                }
                if (SUCCEEDED(hr))
                {
                    pDeviceContext->FillMesh(
                        m_strokeMesh,
                        pBrush
                        );
                }
            }
        }

        if (SUCCEEDED(hr))
        {
            pDeviceContext->SetAntialiasMode(originalAAMode);

            if (!m_realizationTransformIsIdentity)
            {
                pDeviceContext->SetTransform(originalTransform);
            }
        }
    }

    return hr;
}

GeometryRealization::STDMETHOD_ | ( | ULONG | ,
 |  | AddRef |
 | ) |  |
GeometryRealization::STDMETHOD_ | ( | ULONG | ,
 |  | Release |
 | ) |  |
STDMETHODIMP GeometryRealization::Update | ( | ID2D1Geometry * | geometry,
 |  | REALIZATION_CREATION_OPTIONS | options,
 |  | CONST D2D1_MATRIX_3X2_F * | worldTransform,
 |  | float | strokeWidth,
 |  | ID2D1StrokeStyle * | strokeStyle
 | ) |  |

Definition at line 548 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    if (worldTransform)
    {
        m_realizationTransform = *D2D1::Matrix3x2F::ReinterpretBaseType(worldTransform);
        m_realizationTransformIsIdentity = (m_realizationTransform.IsIdentity());
    }
    else
    {
        m_realizationTransform = D2D1::Matrix3x2F::Identity();
        m_realizationTransformIsIdentity = true;
    }

    //
    // We're about to create our realizations with the world transform applied
    // to them.  When we go to actually render the realization, though, we'll
    // want to "undo" this realization and instead apply the render target's
    // current transform.
    //
    // Note: we keep track to see if the passed in realization transform is the
    // identity.  This is a small optimization that saves us from having to
    // multiply matrices when we go to draw the realization.
    //

    m_realizationTransformInv = m_realizationTransform;
    m_realizationTransformInv.Invert();

    if ((options & REALIZATION_CREATION_OPTIONS_UNREALIZED) || m_swRT)
    {
        SafeReplace(&m_geometry, geometry);
        SafeReplace(&m_strokeStyle, strokeStyle);
        m_strokeWidth = strokeWidth;
    }

    if (options & REALIZATION_CREATION_OPTIONS_ANTI_ALIASED)
    {
        //
        // Antialiased realizations are implemented using opacity masks.
        //

        if (options & REALIZATION_CREATION_OPTIONS_FILLED)
        {
            hr = GenerateOpacityMask(
                true, // => filled
                m_deviceContext,
                m_maxRealizationDimension,
                IN OUT &m_fillRT,
                geometry,
                worldTransform,
                strokeWidth,
                strokeStyle,
                &m_fillMaskDestBounds,
                &m_fillMaskSourceBounds
                );
        }

        if (SUCCEEDED(hr) && options & REALIZATION_CREATION_OPTIONS_STROKED)
        {
            hr = GenerateOpacityMask(
                false, // => stroked
                m_deviceContext,
                m_maxRealizationDimension,
                IN OUT &m_strokeRT,
                geometry,
                worldTransform,
                strokeWidth,
                strokeStyle,
                &m_strokeMaskDestBounds,
                &m_strokeMaskSourceBounds
                );
        }
    }

    if (SUCCEEDED(hr) && options & REALIZATION_CREATION_OPTIONS_ALIASED)
    {
        //
        // Aliased realizations are implemented using meshes.
        //

        if (options & REALIZATION_CREATION_OPTIONS_FILLED)
        {
            ID2D1Mesh *pMesh = nullptr;
            hr = m_deviceContext->CreateMesh(&pMesh);
            if (SUCCEEDED(hr))
            {
                ID2D1TessellationSink *pSink = nullptr;
                hr = pMesh->Open(&pSink);
                if (SUCCEEDED(hr))
                {
                    hr = geometry->Tessellate(worldTransform, pSink);
                    if (SUCCEEDED(hr))
                    {
                        hr = pSink->Close();
                        if (SUCCEEDED(hr))
                        {
                            SafeReplace(&m_fillMesh, pMesh);
                        }
                    }
                    pSink->Release();
                }
                pMesh->Release();
            }
        }

        if (SUCCEEDED(hr) && options & REALIZATION_CREATION_OPTIONS_STROKED)
        {
            //
            // In order generate the mesh corresponding to the stroke of a
            // geometry, we first "widen" the geometry and then tessellate the
            // result.
            //

            ID2D1Factory *pFactory = nullptr;
            m_deviceContext->GetFactory(&pFactory);

            ID2D1PathGeometry *pPathGeometry = nullptr;
            hr = pFactory->CreatePathGeometry(&pPathGeometry);
            if (SUCCEEDED(hr))
            {
                ID2D1GeometrySink *pGeometrySink = nullptr;
                hr = pPathGeometry->Open(&pGeometrySink);
                if (SUCCEEDED(hr))
                {
                    hr = geometry->Widen(
                        strokeWidth,
                        strokeStyle,
                        worldTransform,
                        pGeometrySink
                        );

                    if (SUCCEEDED(hr))
                    {
                        hr = pGeometrySink->Close();
                        if (SUCCEEDED(hr))
                        {
                            ID2D1Mesh *pMesh = nullptr;
                            hr = m_deviceContext->CreateMesh(&pMesh);
                            if (SUCCEEDED(hr))
                            {
                                ID2D1TessellationSink *pSink = nullptr;
                                hr = pMesh->Open(&pSink);
                                if (SUCCEEDED(hr))
                                {
                                    hr = pPathGeometry->Tessellate(
                                        nullptr, // world transform (already handled in Widen)
                                        pSink
                                        );
                                    if (SUCCEEDED(hr))
                                    {
                                        hr = pSink->Close();
                                        if (SUCCEEDED(hr))
                                        {
                                            SafeReplace(&m_strokeMesh, pMesh);
                                        }
                                    }
                                    pSink->Release();
                                }
                                pMesh->Release();
                            }
                        }
                    }
                    pGeometrySink->Release();
                }
                pPathGeometry->Release();
            }
            pFactory->Release();
        }
    }

    return hr;
}

Member Data Documentation

ID2D1DeviceContext* GeometryRealization::m_deviceContext [protected]

Definition at line 139 of file GeometryRealizationPackage.cpp.

D2D1_RECT_F GeometryRealization::m_fillMaskDestBounds [protected]

Definition at line 133 of file GeometryRealizationPackage.cpp.

D2D1_RECT_F GeometryRealization::m_fillMaskSourceBounds [protected]

Definition at line 134 of file GeometryRealizationPackage.cpp.

ID2D1Mesh* GeometryRealization::m_fillMesh [protected]

Definition at line 123 of file GeometryRealizationPackage.cpp.

ID2D1BitmapRenderTarget* GeometryRealization::m_fillRT [protected]

Definition at line 126 of file GeometryRealizationPackage.cpp.

ID2D1Geometry* GeometryRealization::m_geometry [protected]

Definition at line 129 of file GeometryRealizationPackage.cpp.

UINT GeometryRealization::m_maxRealizationDimension [protected]

Definition at line 147 of file GeometryRealizationPackage.cpp.

D2D1::Matrix3x2F GeometryRealization::m_realizationTransform [protected]

Definition at line 142 of file GeometryRealizationPackage.cpp.

D2D1::Matrix3x2F GeometryRealization::m_realizationTransformInv [protected]

Definition at line 143 of file GeometryRealizationPackage.cpp.

bool GeometryRealization::m_realizationTransformIsIdentity [protected]

Definition at line 141 of file GeometryRealizationPackage.cpp.

ULONG volatile GeometryRealization::m_ref [protected]

Definition at line 149 of file GeometryRealizationPackage.cpp.

D2D1_RECT_F GeometryRealization::m_strokeMaskDestBounds [protected]

Definition at line 136 of file GeometryRealizationPackage.cpp.

D2D1_RECT_F GeometryRealization::m_strokeMaskSourceBounds [protected]

Definition at line 137 of file GeometryRealizationPackage.cpp.

ID2D1Mesh* GeometryRealization::m_strokeMesh [protected]

Definition at line 124 of file GeometryRealizationPackage.cpp.

ID2D1BitmapRenderTarget* GeometryRealization::m_strokeRT [protected]

Definition at line 127 of file GeometryRealizationPackage.cpp.

ID2D1StrokeStyle* GeometryRealization::m_strokeStyle [protected]

Definition at line 130 of file GeometryRealizationPackage.cpp.

float GeometryRealization::m_strokeWidth [protected]

Definition at line 131 of file GeometryRealizationPackage.cpp.

BOOL GeometryRealization::m_swRT [protected]

Definition at line 145 of file GeometryRealizationPackage.cpp.

The documentation for this class was generated from the following file:
  • Direct2D geometry realization/C++/GeometryRealizationPackage.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GeometryRealizationFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes

GeometryRealizationFactory Class Reference

List of all members.

Public Member Functions

STDMETHOD() | CreateGeometryRealization (IGeometryRealization **realization)
STDMETHOD() | CreateGeometryRealization (ID2D1Geometry *geometry, REALIZATION_CREATION_OPTIONS options, CONST D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle, IGeometryRealization **realization)
STDMETHOD() | QueryInterface (REFIID iid, void **object)
STDMETHOD_ (ULONG, AddRef)()
STDMETHOD_ (ULONG, Release)()

Static Public Member Functions

static HRESULT | Create (ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension, IGeometryRealizationFactory **factory)

Protected Member Functions

GeometryRealizationFactory ()
~GeometryRealizationFactory ()
HRESULT | Initialize (ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension)

Protected Attributes

ID2D1DeviceContext * | m_deviceContext
UINT | m_maxRealizationDimension
ULONG volatile | m_ref

Detailed Description

Definition at line 168 of file GeometryRealizationPackage.cpp.

Constructor & Destructor Documentation

GeometryRealizationFactory::GeometryRealizationFactory ( ) [protected]

Definition at line 298 of file GeometryRealizationPackage.cpp.

                                                       :
    m_ref(1),
    m_deviceContext(nullptr)
{
}

GeometryRealizationFactory::~GeometryRealizationFactory ( ) [protected]

Definition at line 310 of file GeometryRealizationPackage.cpp.

{
    SafeRelease(&m_deviceContext);
}

Member Function Documentation

HRESULT GeometryRealizationFactory::Create | ( | ID2D1DeviceContext * | deviceContext,
 |  | UINT | maxRealizationDimension,
 |  | IGeometryRealizationFactory ** | factory |
 | ) |  |  | [static]

Definition at line 264 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    GeometryRealizationFactory *realizationFactory = nullptr;
    realizationFactory = new (std::nothrow) GeometryRealizationFactory();
    hr = realizationFactory ? S_OK : E_OUTOFMEMORY;
    if (SUCCEEDED(hr))
    {
        hr = realizationFactory->Initialize(deviceContext, maxRealizationDimension);

        if (SUCCEEDED(hr))
        {
            *factory = realizationFactory;
            (*factory)->AddRef();
        }

        realizationFactory->Release();
    }

    return hr;
}

STDMETHODIMP GeometryRealizationFactory::CreateGeometryRealization | ( | ID2D1Geometry * | geometry,
 |  | REALIZATION_CREATION_OPTIONS | options,
 |  | CONST D2D1_MATRIX_3X2_F * | worldTransform,
 |  | float | strokeWidth,
 |  | ID2D1StrokeStyle * | strokeStyle,
 |  | IGeometryRealization ** | realization
 | ) |  |

Definition at line 357 of file GeometryRealizationPackage.cpp.

{
    return GeometryRealization::Create(
        m_deviceContext,
        m_maxRealizationDimension,
        geometry,
        options,
        worldTransform,
        strokeWidth,
        strokeStyle,
        realization
        );
}

STDMETHODIMP GeometryRealizationFactory::CreateGeometryRealization ( IGeometryRealization ** realization )

Definition at line 384 of file GeometryRealizationPackage.cpp.

{
    return GeometryRealization::Create(
        m_deviceContext,
        m_maxRealizationDimension,
        nullptr, // pGeometry
        REALIZATION_CREATION_OPTIONS_ALIASED, // ignored.
        nullptr,
        0.0f, // strokeWidth
        nullptr, // pIStrokeStyle
        realization
        );
}

HRESULT GeometryRealizationFactory::Initialize | ( | ID2D1DeviceContext * | deviceContext,
 |  | UINT | maxRealizationDimension |
 | ) |  |  | [protected]

Definition at line 321 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    if (maxRealizationDimension == 0)
    {
        //
        // 0-sized bitmaps aren't very useful for realizations, and
        // DXGI surface render targets don't support them, anyway.
        //
        hr = E_INVALIDARG;
    }

    if (SUCCEEDED(hr))
    {
        m_deviceContext = deviceContext;
        m_deviceContext->AddRef();

        m_maxRealizationDimension = min(
            deviceContext->GetMaximumBitmapSize(),
            maxRealizationDimension
            );
    }

    return hr;
}

STDMETHODIMP GeometryRealizationFactory::QueryInterface | ( | REFIID | iid,
 |  | void ** | object
 | ) |  |

Definition at line 1298 of file GeometryRealizationPackage.cpp.

{
    HRESULT hr = S_OK;

    if (__uuidof(IUnknown) == iid)
    {
        *object = static_cast<IUnknown*>(this);
        AddRef();
    }
    else if (__uuidof(IGeometryRealizationFactory) == iid)
    {
        *object = static_cast<IGeometryRealizationFactory*>(this);
        AddRef();
    }
    else
    {
        *object = nullptr;
        hr = E_NOINTERFACE;
    }

    return hr;
}

GeometryRealizationFactory::STDMETHOD_ | ( | ULONG | ,
 |  | AddRef |
 | ) |  |
GeometryRealizationFactory::STDMETHOD_ | ( | ULONG | ,
 |  | Release |
 | ) |  |

Member Data Documentation

ID2D1DeviceContext* GeometryRealizationFactory::m_deviceContext [protected]

Definition at line 210 of file GeometryRealizationPackage.cpp.

UINT GeometryRealizationFactory::m_maxRealizationDimension [protected]

Definition at line 214 of file GeometryRealizationPackage.cpp.

ULONG volatile GeometryRealizationFactory::m_ref [protected]

Definition at line 212 of file GeometryRealizationPackage.cpp.

The documentation for this class was generated from the following file:
  • Direct2D geometry realization/C++/GeometryRealizationPackage.cpp
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GeometryRealizationSample Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

GeometryRealizationSample Class Reference

#include "GeometryRealizationSample.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()
virtual void | UpdateForWindowSizeChange () override

Public Attributes

internal | __pad0__: GeometryRealizationSample()

Private Member Functions

void | CreateGeometries ()
void | DiscardGeometries ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnHolding (_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::HoldingEventArgs^args)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | RenderMainContent (float time)
void | ShowMenu (Windows::Foundation::Point position)
void | UpdateDisplayText ()
void | UpdateGeometryRendering (Windows::UI::Popups::IUICommand^command)

Private Attributes

D2D1_ANTIALIAS_MODE | m_antialiasMode
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
FPSCounter m_displayText
bool | m_drawStroke
Microsoft::WRL::ComPtr
< ID2D1Geometry > 		m_geometry
Platform::Agile
< Windows::UI::Input::GestureRecognizer > 		m_gestureRecognizer
uint32 | m_numberOfSquares
bool | m_paused
int64 | m_pausedTime
Microsoft::WRL::ComPtr
< IGeometryRealization > 		m_realization
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_solidColorBrush
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
int64 | m_timeDelta
bool | m_updateDisplayText
bool | m_updateRealization
bool | m_useRealizations
bool | m_windowClosed
bool | m_windowVisible

Detailed Description

Definition at line 17 of file GeometryRealizationSample.h.

Member Function Documentation

void GeometryRealizationSample::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 64 of file GeometryRealizationSample.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create a DirectWrite text format object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
        L"Segoe UI",
        nullptr,
        DWRITE_FONT_WEIGHT_LIGHT,
        DWRITE_FONT_STYLE_NORMAL,
        DWRITE_FONT_STRETCH_NORMAL,
        20.0f,
        L"en-US", // locale
        &m_textFormat
        )
        );
}

void GeometryRealizationSample::CreateDeviceResources ( ) [override, virtual]

Definition at line 83 of file GeometryRealizationSample.cpp.

{
    // DirectXBase creates a Direct2D device context that enables multithreaded optimizations.
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D geometry realization sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );

    ComPtr<IGeometryRealizationFactory> realizationFactory;
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_solidColorBrush
            )
        );

    DX::ThrowIfFailed(
        CreateGeometryRealizationFactory(
            m_d2dContext.Get(),
            maxRealizationDimension,
            &realizationFactory
            )
        );

    DX::ThrowIfFailed(
        realizationFactory->CreateGeometryRealization(&m_realization)
        );

    m_updateRealization = true;
    m_displayText = nullptr;
}

void GeometryRealizationSample::CreateGeometries ( ) [private]

Definition at line 138 of file GeometryRealizationSample.cpp.

{
    if (!m_geometry)
    {
        ComPtr<IGeometryRealizationFactory> realizationFactory;
        ComPtr<IGeometryRealization> realization;

        ComPtr<ID2D1TransformedGeometry>   geometry;
        ComPtr<ID2D1PathGeometry> pathGeometry;
        ComPtr<ID2D1GeometrySink> sink;

        float boardWidth = m_d2dContext->GetSize().width;
        float squareWidth = 0.5f * boardWidth / m_numberOfSquares;

        // Create the path geometry.
        DX::ThrowIfFailed(
            m_d2dFactory->CreatePathGeometry(&pathGeometry)
            );

        DX::ThrowIfFailed(
            pathGeometry->Open(&sink)
            );

        sink->SetFillMode(D2D1_FILL_MODE_ALTERNATE);

        sink->BeginFigure(
            D2D1::Point2F(0, 0),
            D2D1_FIGURE_BEGIN_FILLED
            );

        sink->AddLine(D2D1::Point2F(1.0f, 0));

        sink->AddBezier(
            D2D1::BezierSegment(
                D2D1::Point2F(0.75f, 0.25f),
                D2D1::Point2F(0.75f, 0.75f),
                D2D1::Point2F(1.0f, 1.0f)
                )
            );

        sink->AddLine(D2D1::Point2F(0, 1.0f));

        sink->AddBezier(
            D2D1::BezierSegment(
                D2D1::Point2F(0.25f, 0.75f),
                D2D1::Point2F(0.25f, 0.25f),
                D2D1::Point2F(0, 0)
                )
            );

        sink->EndFigure(D2D1_FIGURE_END_CLOSED);

        DX::ThrowIfFailed(
            sink->Close()
            );

        D2D1_MATRIX_3X2_F scale = D2D1::Matrix3x2F::Scale(squareWidth, squareWidth);
        D2D1_MATRIX_3X2_F translation = D2D1::Matrix3x2F::Translation(-squareWidth / 2, -squareWidth / 2);

        DX::ThrowIfFailed(
            m_d2dFactory->CreateTransformedGeometry(
                pathGeometry.Get(),
                scale * translation,
                &geometry
                )
            );
        // Transfer the reference.
        m_geometry = geometry;
    }
}

void GeometryRealizationSample::DiscardGeometries ( ) [private]

Definition at line 209 of file GeometryRealizationSample.cpp.

{
    m_geometry = nullptr;
    m_updateRealization = true;
}

virtual void GeometryRealizationSample::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void GeometryRealizationSample::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 551 of file GeometryRealizationSample.cpp.

{
    // Retrieve any stored variables from the LocalSettings collection.
    IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;

    if (settingsValues->HasKey("m_antialiasMode"))
    {
        m_antialiasMode = static_cast<D2D1_ANTIALIAS_MODE>(
            safe_cast<IPropertyValue^>(settingsValues->Lookup("m_antialiasMode"))->GetInt32()
            );
    }

    if (settingsValues->HasKey("m_useRealizations"))
    {
        m_useRealizations = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_useRealizations"))->GetBoolean();
    }

    if (settingsValues->HasKey("m_drawStroke"))
    {
        m_drawStroke = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_drawStroke"))->GetBoolean();
    }

    if (settingsValues->HasKey("m_numberOfSquares"))
    {
        m_numberOfSquares = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_numberOfSquares"))->GetUInt32();
    }

    if (settingsValues->HasKey("m_paused"))
    {
        m_paused = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_paused"))->GetBoolean();
    }

    if (settingsValues->HasKey("m_pausedTime"))
    {
        m_pausedTime = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_pausedTime"))->GetInt64();
    }

    if (settingsValues->HasKey("m_timeDelta"))
    {
        m_timeDelta = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_timeDelta"))->GetInt64();
    }
}

void GeometryRealizationSample::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::OnHolding | ( | _In_ Windows::UI::Input::GestureRecognizer^ | recognizer,
 |  | _In_ Windows::UI::Input::HoldingEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 635 of file GeometryRealizationSample.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    DiscardGeometries();
    Render();
    Present();
}

void GeometryRealizationSample::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | window,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]

Definition at line 707 of file GeometryRealizationSample.cpp.

{
}

void GeometryRealizationSample::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void GeometryRealizationSample::Render ( ) [override, virtual]

Definition at line 320 of file GeometryRealizationSample.cpp.

{
    LARGE_INTEGER time;
    LARGE_INTEGER frequency;
    QueryPerformanceCounter(&time);
    QueryPerformanceFrequency(&frequency);

    float floatTime;

    if (!m_paused)
    {
        floatTime = static_cast<float>(time.QuadPart + m_timeDelta) / static_cast<float>(frequency.QuadPart);
    }
    else
    {
        floatTime = static_cast<float>(m_pausedTime + m_timeDelta) / static_cast<float>(frequency.QuadPart);
    }

    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    CreateGeometries();
    RenderMainContent(floatTime);

    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    if (m_updateDisplayText)
    {
        UpdateDisplayText();
    }
    m_displayText->Render();

    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
        // is lost. It will be handled during the next call to Present.
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void GeometryRealizationSample::RenderMainContent ( float time ) [private]

Definition at line 215 of file GeometryRealizationSample.cpp.

{
    static DWORD dwTimeStart = 0;
    static DWORD dwTimeLast = 0;

    D2D1_SIZE_F rtSize = m_d2dContext->GetSize();

    float boardWidth = rtSize.width * 0.5f;
    float squareWidth = boardWidth / m_numberOfSquares;

    m_d2dContext->SetAntialiasMode(m_antialiasMode);

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));

    D2D1_MATRIX_3X2_F currentTransform;

    m_d2dContext->GetTransform(&currentTransform);

    D2D1_MATRIX_3X2_F worldTransform =
        D2D1::Matrix3x2F::Translation(
            0.5f * (rtSize.width - squareWidth * m_numberOfSquares),
            0.5f * (rtSize.height - squareWidth * m_numberOfSquares)
            ) * currentTransform;

    for (uint32 i = 0; i < m_numberOfSquares; ++i)
    {
        for (uint32 j = 0; j < m_numberOfSquares; ++j)
        {
            float dx = i + 0.5f - 0.5f * m_numberOfSquares;
            float dy = j + 0.5f - 0.5f * m_numberOfSquares;

            float length = sqrtf(2) * m_numberOfSquares;

            // The intensity variable determines the color and speed of rotation of the
            // realization instance. We choose a function that is rotationally
            // symmetric about the center of the grid, which produces a nice effect.
            float intensity =
                0.5f * (1 + sinf((0.2f * time + 10.0f * sqrtf(static_cast<float>(dx * dx + dy * dy)) / length)));

            D2D1_MATRIX_3X2_F rotateTransform =
                D2D1::Matrix3x2F::Rotation(
                    (intensity * rotationSpeed * time * 360.0f) * ((float) M_PI / 180.0f)
                    );

            D2D1_MATRIX_3X2_F newWorldTransform =
                rotateTransform *
                D2D1::Matrix3x2F::Translation(
                    (i + 0.5f) * squareWidth,
                    (j + 0.5f) * squareWidth
                    ) * worldTransform;

            if (m_updateRealization)
            {
                DX::ThrowIfFailed(
                    m_realization->Update(
                        m_geometry.Get(),
                        static_cast<REALIZATION_CREATION_OPTIONS>(
                            REALIZATION_CREATION_OPTIONS_ANTI_ALIASED |
                            REALIZATION_CREATION_OPTIONS_ALIASED |
                            REALIZATION_CREATION_OPTIONS_FILLED |
                            REALIZATION_CREATION_OPTIONS_STROKED |
                            REALIZATION_CREATION_OPTIONS_UNREALIZED
                            ),
                        &newWorldTransform,
                        strokeWidth,
                        nullptr // pIStrokeStyle
                        )
                    );

                m_updateRealization = false;
            }

            m_d2dContext->SetTransform(newWorldTransform);
            m_solidColorBrush->SetColor(
                D2D1::ColorF(0.0f, intensity, 1.0f - intensity)
                );

            DX::ThrowIfFailed(
                m_realization->Fill(
                    m_d2dContext.Get(),
                    m_solidColorBrush.Get(),
                    m_useRealizations ?
                        REALIZATION_RENDER_MODE_DEFAULT :
                        REALIZATION_RENDER_MODE_FORCE_UNREALIZED
                    )
                );

            if (m_drawStroke)
            {
                m_solidColorBrush->SetColor(D2D1::ColorF(D2D1::ColorF::White));

                DX::ThrowIfFailed(
                    m_realization->Draw(
                        m_d2dContext.Get(),
                        m_solidColorBrush.Get(),
                        m_useRealizations ?
                            REALIZATION_RENDER_MODE_DEFAULT :
                            REALIZATION_RENDER_MODE_FORCE_UNREALIZED
                        )
                    );
            }
        }
    }
}

void GeometryRealizationSample::Run ( ) [virtual]

Definition at line 596 of file GeometryRealizationSample.cpp.

{
    while (!m_windowClosed)
    {
        if (m_windowVisible)
        {
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
            Render();
            Present(); // This call is synchronized to the display frame rate.
        }
        else
        {
            m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
        }
    }
}

virtual void GeometryRealizationSample::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void GeometryRealizationSample::ShowMenu ( Windows::Foundation::Point position ) [private]
void GeometryRealizationSample::Uninitialize ( ) [virtual]

Definition at line 613 of file GeometryRealizationSample.cpp.

{
}

void GeometryRealizationSample::UpdateDisplayText ( ) [private]

Definition at line 365 of file GeometryRealizationSample.cpp.

{
    WCHAR textBuffer[400];
    LARGE_INTEGER frequency;

    QueryPerformanceFrequency(&frequency);

    uint32 numPrimitives = m_numberOfSquares * m_numberOfSquares;

    if (m_drawStroke)
    {
        numPrimitives *= 2;
    }

    StringCchPrintf(
        textBuffer,
        400,
        L"%s\n"
        L"%s\n"
        L"# primitives: %d x %d %s = %d\n"
        L"Fps: ",
        m_antialiasMode == D2D1_ANTIALIAS_MODE_ALIASED ? L"Aliased" : L"PerPrimitive",
        m_useRealizations ? L"Realized"  : L"Unrealized",
        m_numberOfSquares,
        m_numberOfSquares,
        m_drawStroke ? L" x 2" : L"",
        numPrimitives
        );

    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    m_solidColorBrush->SetColor(D2D1::ColorF(D2D1::ColorF::White));

    m_displayText = ref new FPSCounter(
        m_d2dContext.Get(),
        m_dpi,
        ref new Platform::String(textBuffer),
        m_textFormat.Get(),
        D2D1::Point2F(
            textInfoBox.left + textInfoBoxInset,
            textInfoBox.top + textInfoBoxInset
            )
        );
    m_displayText->Initialize();

    m_updateDisplayText = false;
}

void GeometryRealizationSample::UpdateForWindowSizeChange ( ) [override, virtual]

Definition at line 129 of file GeometryRealizationSample.cpp.

{
    DirectXBase::UpdateForWindowSizeChange();
    m_displayText = nullptr;
    m_updateDisplayText = true;
    DiscardGeometries();
    m_sampleOverlay->UpdateForWindowSizeChange();
}

void GeometryRealizationSample::UpdateGeometryRendering ( Windows::UI::Popups::IUICommand^ command ) [private]

Member Data Documentation

internal GeometryRealizationSample::__pad0__

Definition at line 20 of file GeometryRealizationSample.h.

D2D1_ANTIALIAS_MODE GeometryRealizationSample::m_antialiasMode [private]

Definition at line 110 of file GeometryRealizationSample.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> GeometryRealizationSample::m_blackBrush [private]

Definition at line 101 of file GeometryRealizationSample.h.

FPSCounter GeometryRealizationSample::m_displayText [private]

Definition at line 109 of file GeometryRealizationSample.h.

bool GeometryRealizationSample::m_drawStroke [private]

Definition at line 112 of file GeometryRealizationSample.h.

Microsoft::WRL::ComPtr<ID2D1Geometry> GeometryRealizationSample::m_geometry [private]

Definition at line 104 of file GeometryRealizationSample.h.

Platform::Agile<Windows::UI::Input::GestureRecognizer> GeometryRealizationSample::m_gestureRecognizer [private]

Definition at line 116 of file GeometryRealizationSample.h.

uint32 GeometryRealizationSample::m_numberOfSquares [private]

Definition at line 106 of file GeometryRealizationSample.h.

bool GeometryRealizationSample::m_paused [private]

Definition at line 113 of file GeometryRealizationSample.h.

int64 GeometryRealizationSample::m_pausedTime [private]

Definition at line 107 of file GeometryRealizationSample.h.

Microsoft::WRL::ComPtr<IGeometryRealization> GeometryRealizationSample::m_realization [private]

Definition at line 105 of file GeometryRealizationSample.h.

SampleOverlay GeometryRealizationSample::m_sampleOverlay [private]

Definition at line 98 of file GeometryRealizationSample.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> GeometryRealizationSample::m_solidColorBrush [private]

Definition at line 103 of file GeometryRealizationSample.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> GeometryRealizationSample::m_textFormat [private]

Definition at line 102 of file GeometryRealizationSample.h.

int64 GeometryRealizationSample::m_timeDelta [private]

Definition at line 108 of file GeometryRealizationSample.h.

bool GeometryRealizationSample::m_updateDisplayText [private]

Definition at line 115 of file GeometryRealizationSample.h.

bool GeometryRealizationSample::m_updateRealization [private]

Definition at line 114 of file GeometryRealizationSample.h.

bool GeometryRealizationSample::m_useRealizations [private]

Definition at line 111 of file GeometryRealizationSample.h.

bool GeometryRealizationSample::m_windowClosed [private]

Definition at line 117 of file GeometryRealizationSample.h.

bool GeometryRealizationSample::m_windowVisible [private]

Definition at line 118 of file GeometryRealizationSample.h.

The documentation for this class was generated from the following files:
  • Direct2D geometry realization/C++/GeometryRealizationSample.h
  • Direct2D geometry realization/C++/GeometryRealizationSample.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: handle_closer Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

handle_closer Struct Reference

#include "scoped.h"

List of all members.

Public Member Functions

void operator() (HANDLE h)

Detailed Description

Definition at line 29 of file scoped.h.

Member Function Documentation

void handle_closer::operator() ( HANDLE h ) [inline]

Definition at line 29 of file scoped.h.

{ void operator()(HANDLE h) { assert(h != INVALID_HANDLE_VALUE); if (h) CloseHandle(h); } };

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/scoped.h
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HighScoreEntry Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

HighScoreEntry Struct Reference

#include "Simple3DGame.h"

List of all members.

Public Attributes

float | elapsedTime
int | levelCompleted
Platform::String | tag
int | totalHits
int | totalShots
bool | wasJustAdded

Detailed Description

Definition at line 50 of file Simple3DGame.h.

Member Data Documentation

float HighScoreEntry::elapsedTime

Definition at line 190 of file UserInterface.h.

int HighScoreEntry::levelCompleted

Definition at line 55 of file Simple3DGame.h.

Platform::String HighScoreEntry::tag

Definition at line 52 of file Simple3DGame.h.

int HighScoreEntry::totalHits

Definition at line 53 of file Simple3DGame.h.

int HighScoreEntry::totalShots

Definition at line 54 of file Simple3DGame.h.

bool HighScoreEntry::wasJustAdded

Definition at line 191 of file UserInterface.h.

The documentation for this struct was generated from the following files:
  • DirectX 3D shooting game/C++/Simple3DGame.h
  • DirectX marble maze game/C++/UserInterface.h
  • XAML DirectX 3D shooting game/C++/Simple3DGame.h
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HighScoreTable Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes

HighScoreTable Class Reference

#include "UserInterface.h"

Inherits TextElement.

List of all members.

Public Member Functions

HighScoreTable ()
void | AddScoreToTable (HighScoreEntry &entry)
HighScoreEntries GetEntries ()
virtual void | Initialize ()
virtual void | Render ()
void | Reset ()
virtual void | Update (float timeTotal, float timeDelta)

Protected Member Functions

void | UpdateText ()

Protected Attributes

HighScoreEntries m_entries

Detailed Description

Definition at line 197 of file UserInterface.h.

Constructor & Destructor Documentation

HighScoreTable::HighScoreTable ( )

Definition at line 519 of file UserInterface.cpp.

{
}

Member Function Documentation

void HighScoreTable::AddScoreToTable ( HighScoreEntry & entry )

Definition at line 545 of file UserInterface.cpp.

{
    for (auto iter = m_entries.begin(); iter != m_entries.end(); ++iter)
    {
        iter->wasJustAdded = false;
    }

    entry.wasJustAdded = false;

    for (auto iter = m_entries.begin(); iter != m_entries.end(); ++iter)
    {
        if (entry.elapsedTime < iter->elapsedTime)
        {
            m_entries.insert(iter, entry);
            while (m_entries.size() > MAX_HIGH_SCORES)
                m_entries.pop_back();

            entry.wasJustAdded = true;
            UpdateText();
            return;
        }
    }

    if (m_entries.size() < MAX_HIGH_SCORES)
    {
        m_entries.push_back(entry);
        UpdateText();
        entry.wasJustAdded = true;
    }
}

HighScoreEntries HighScoreTable::GetEntries ( ) [inline]

Definition at line 207 of file UserInterface.h.

{ return m_entries; };

void HighScoreTable::Initialize ( ) [virtual]

Reimplemented from TextElement.

Definition at line 523 of file UserInterface.cpp.

{
    TextElement::Initialize();
    UpdateText();
}

void HighScoreTable::Render ( ) [virtual]

Reimplemented from TextElement.

Definition at line 540 of file UserInterface.cpp.

{
    TextElement::Render();
}

void HighScoreTable::Reset ( )

Definition at line 529 of file UserInterface.cpp.

{
    m_entries.clear();
    UpdateText();
}

void HighScoreTable::Update | ( | float | timeTotal,
 |  | float | timeDelta |
 | ) |  |  | [virtual]

Reimplemented from TextElement.

Definition at line 535 of file UserInterface.cpp.

{
    TextElement::Update(timeTotal, timeDelta);
}

void HighScoreTable::UpdateText ( ) [protected]

Definition at line 576 of file UserInterface.cpp.

{
    WCHAR formattedTime[32];
    WCHAR lines[1024] = { 0, };
    WCHAR buffer[128];

    swprintf_s(lines, L"High Scores:");
    for (unsigned int i = 0; i < MAX_HIGH_SCORES; ++i)
    {
        if (i < m_entries.size())
        {
            StopwatchTimer::GetFormattedTime(formattedTime, m_entries[i].elapsedTime);
            swprintf_s(
                buffer,
                (m_entries[i].wasJustAdded ? L"\n>> %s\t%s <<" : L"\n%s\t%s"),
                m_entries[i].tag->Data(),
                formattedTime
                );
            wcscat_s(lines, buffer);
        }
        else
        {
            wcscat_s(lines, L"\n-");
        }
    }

    SetText(lines);
}

Member Data Documentation

HighScoreEntries HighScoreTable::m_entries [protected]

Definition at line 211 of file UserInterface.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/UserInterface.h
  • DirectX marble maze game/C++/UserInterface.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::CalendarExtensions Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::CalendarExtensions
Static Public Member Functions | Static Private Member Functions

Hilo::CalendarExtensions Class Reference

#include "CalendarExtensions.h"

List of all members.

Static Public Member Functions

static Platform::String | CreateMonthRangeFromDate (const Windows::Foundation::DateTime date)
static Platform::String | CreateMonthRangeFromYearAndMonth (int year, int month)
static Platform::String | GetLocalizedAbbreviatedMonthName (int year, int month)
static Platform::String | GetLocalizedMonthAndYear (const Windows::Foundation::DateTime date)
static Platform::String | GetLocalizedYear (const Windows::Foundation::DateTime yearDate)
static int | GetNumberOfMonthsInYear (const Windows::Foundation::DateTime yearDate)
static int | GetNumericYear (const Windows::Foundation::DateTime yearDate)
static Platform::String | ResolvedGeographicRegion ()
static Platform::String | ResolvedLanguage ()
static void | WriteLocalizedYearAndMonth (const Windows::Foundation::DateTime date, int &yearResult, int &monthResult)

Static Private Member Functions

static Platform::String | CreateMonthRangeFromDate (Windows::Globalization::Calendar^cal)
static std::wstring | GetAqsFormattedDate (const Windows::Foundation::DateTime date)
static
Windows::Globalization::Calendar 		GetCalendar ()

Detailed Description

Definition at line 12 of file CalendarExtensions.h.

Member Function Documentation

static Platform::String Hilo::CalendarExtensions::CreateMonthRangeFromDate ( const Windows::Foundation::DateTime date ) [static]
static Platform::String Hilo::CalendarExtensions::CreateMonthRangeFromDate ( Windows::Globalization::Calendar^ cal ) [static, private]
String CalendarExtensions::CreateMonthRangeFromYearAndMonth | ( | int | year,
 |  | int | month |
 | ) |  |  | [static]

Definition at line 107 of file CalendarExtensions.cpp.

{
    auto cal = GetCalendar();

    cal->Year = year;
    cal->Month = month;
    cal->Day = cal->FirstDayInThisMonth;
    return CreateMonthRangeFromDate(cal);
}

static std::wstring Hilo::CalendarExtensions::GetAqsFormattedDate ( const Windows::Foundation::DateTime date ) [static, private]
Calendar CalendarExtensions::GetCalendar ( ) [static, private]

Definition at line 100 of file CalendarExtensions.cpp.

{
    return ref new Calendar();
}

String CalendarExtensions::GetLocalizedAbbreviatedMonthName | ( | int | year,
 |  | int | month |
 | ) |  |  | [static]

Definition at line 137 of file CalendarExtensions.cpp.

{
    auto cal = GetCalendar();
    cal->Year = year;
    cal->Month = month;
    cal->Day = cal->FirstDayInThisMonth;

    auto lang = ref new Vector<String^>();
    lang->Append(ResolvedLanguage());
    auto dtf = ref new DateTimeFormatter(
        YearFormat::None,
        MonthFormat::Abbreviated,
        DayFormat::None,
        DayOfWeekFormat::None,
        HourFormat::None,
        MinuteFormat::None,
        SecondFormat::None,
        lang, ResolvedGeographicRegion(), cal->GetCalendarSystem(), cal->GetClock());

    return dtf->Format(cal->GetDateTime());
}

static Platform::String Hilo::CalendarExtensions::GetLocalizedMonthAndYear ( const Windows::Foundation::DateTime date ) [static]
static Platform::String Hilo::CalendarExtensions::GetLocalizedYear ( const Windows::Foundation::DateTime yearDate ) [static]
static int Hilo::CalendarExtensions::GetNumberOfMonthsInYear ( const Windows::Foundation::DateTime yearDate ) [static]
int CalendarExtensions::GetNumericYear ( const Windows::Foundation::DateTime yearDate ) [static]

Definition at line 201 of file CalendarExtensions.cpp.

{
    auto cal = GetCalendar();

    cal->SetDateTime(yearDate);
    return cal->Year;
}

Platform::String CalendarExtensions::ResolvedGeographicRegion ( ) [static]

Definition at line 224 of file CalendarExtensions.cpp.

{
   return (ref new DateTimeFormatter("shortdate"))->ResolvedGeographicRegion;
}

Platform::String CalendarExtensions::ResolvedLanguage ( ) [static]

Definition at line 219 of file CalendarExtensions.cpp.

{
    return (ref new DateTimeFormatter("shortdate"))->ResolvedLanguage;
}

void CalendarExtensions::WriteLocalizedYearAndMonth | ( | const Windows::Foundation::DateTime | date,
 |  | int & | yearResult,
 |  | int & | monthResult |
 | ) |  |  | [static]

Definition at line 210 of file CalendarExtensions.cpp.

{
    auto cal = GetCalendar();

    cal->SetDateTime(date);
    yearResult = cal->Year;
    monthResult = cal->Month;
}

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/CalendarExtensions.h
  • Hilo C++/C++/Hilo/CalendarExtensions.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::Common::BindableBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Common
  • Hilo::Common::BindableBase
Public Member Functions | Public Attributes

Hilo::Common::BindableBase Class Reference

Implementation of INotifyPropertyChanged to simplify models.

#include "BindableBase.h"

Inherited by Hilo::ViewModelBase.

List of all members.

Public Member Functions

virtual
Windows::UI::Xaml::Data::ICustomProperty 		GetCustomProperty (Platform::String^name)
virtual
Windows::UI::Xaml::Data::ICustomProperty 		GetIndexedProperty (Platform::String^name, Windows::UI::Xaml::Interop::TypeName type)
virtual Platform::String GetStringRepresentation ()

Public Attributes

virtual event
Windows::UI::Xaml::Data::PropertyChangedEventHandler 		PropertyChanged

Detailed Description

Definition at line 17 of file BindableBase.h.

Member Function Documentation

Windows::UI::Xaml::Data::ICustomProperty BindableBase::GetCustomProperty ( Platform::String^ name ) [virtual]

Definition at line 24 of file BindableBase.cpp.

{
    return nullptr;
}

Windows::UI::Xaml::Data::ICustomProperty BindableBase::GetIndexedProperty | ( | Platform::String^ | name,
 |  | Windows::UI::Xaml::Interop::TypeName | type |
 | ) |  |  | [virtual]

Definition at line 29 of file BindableBase.cpp.

{
    return nullptr;
}

Platform::String BindableBase::GetStringRepresentation ( ) [virtual]

Definition at line 34 of file BindableBase.cpp.

{
    return this->ToString();
}

Member Data Documentation

virtual event Windows::UI::Xaml::Data::PropertyChangedEventHandler Hilo::Common::BindableBase::PropertyChanged

Reimplemented in Hilo::sealed.

Definition at line 20 of file BindableBase.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/Common/BindableBase.h
  • Hilo C++/C++/Hilo/Common/BindableBase.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Common
  • Hilo::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Hilo::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

#include "LayoutAwarePage.h"

Inherited by Hilo::HiloPage.

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | _acceleratorKeyEventToken
Platform::Collections::Map
< Platform::String^,
Platform::Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
bool | _navigationShortcutsRegistered
Platform::String | _pageKey
Windows::Foundation::EventRegistrationToken | _pointerPressedEventToken
LayoutAwarePage _this
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 36 of file LayoutAwarePage.h.

Member Function Documentation

void Hilo::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void Hilo::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
virtual Platform::String Hilo::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void Hilo::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void Hilo::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 356 of file LayoutAwarePage.cpp.

{
  if (_layoutAwareControls != nullptr)
  {
    String^ visualState = DetermineVisualState(ApplicationView::Value);
    auto controlIterator = _layoutAwareControls->First();
    while (controlIterator->HasCurrent)
    {
      auto control = controlIterator->Current;
      VisualStateManager::GoToState(control, visualState, false);
      controlIterator->MoveNext();
    }
  }
}

virtual void Hilo::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]

Reimplemented in Hilo::HiloPage.

void LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Invoked when the page is part of the visual tree.

Parameters:
sender | Instance that triggered the event.
e | Event data describing the conditions that led to the event.

Definition at line 82 of file LayoutAwarePage.cpp.

{
  this->StartLayoutUpdates(sender, e);

  // Keyboard and mouse navigation only apply when occupying the entire window
  if (this->ActualHeight == Window::Current->Bounds.Height &&
    this->ActualWidth == Window::Current->Bounds.Width)
  {
    // Listen to the window directly so focus isn't required
    _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
      ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
      &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
    _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
      ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
      &LayoutAwarePage::CoreWindow_PointerPressed);
    _navigationShortcutsRegistered = true;
  }
}

virtual void Hilo::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in Hilo::HiloPage.

virtual void Hilo::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in Hilo::HiloPage.

void LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Invoked when the page is removed from visual tree.

Parameters:
sender | Instance that triggered the event.
e | Event data describing the conditions that led to the event.

Definition at line 106 of file LayoutAwarePage.cpp.

{
  if (_navigationShortcutsRegistered)
  {
    Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
    Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
    _navigationShortcutsRegistered = false;
  }
  StopLayoutUpdates(sender, e);
}

virtual void Hilo::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]

Reimplemented in Hilo::HiloPage.

void Hilo::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void Hilo::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void Hilo::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal Hilo::Common::LayoutAwarePage::__pad0__

Reimplemented in Hilo::HiloPage.

Definition at line 39 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken Hilo::Common::LayoutAwarePage::_acceleratorKeyEventToken [private]

Definition at line 70 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Platform::Object^> Hilo::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 69 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> Hilo::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 72 of file LayoutAwarePage.h.

bool Hilo::Common::LayoutAwarePage::_navigationShortcutsRegistered [private]

Definition at line 68 of file LayoutAwarePage.h.

Platform::String Hilo::Common::LayoutAwarePage::_pageKey [private]

Definition at line 67 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken Hilo::Common::LayoutAwarePage::_pointerPressedEventToken [private]

Definition at line 70 of file LayoutAwarePage.h.

LayoutAwarePage Hilo::Common::LayoutAwarePage::_this [private]

Definition at line 80 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken Hilo::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 70 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/Common/LayoutAwarePage.h
  • Hilo C++/C++/Hilo/Common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::Common::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Common
  • Hilo::Common::sealed
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Static Private Member Functions | Private Attributes

Hilo::Common::sealed Class Reference

Value converter that translates true to false and vice versa. More...

#include "BooleanNegationConverter.h"

List of all members.

Public Member Functions

virtual Platform::Object | Convert (Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language)
virtual Platform::Object | Convert (Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language)
virtual Platform::Object | ConvertBack (Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language)
virtual Platform::Object | ConvertBack (Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language)
RichTextColumns ()

Static Public Member Functions

static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)

Public Attributes

internal Platform::String | sessionStateKey

Protected Member Functions

virtual Windows::Foundation::Size | ArrangeOverride (Windows::Foundation::Size finalSize) override
virtual Windows::Foundation::Size | MeasureOverride (Windows::Foundation::Size availableSize) override

Protected Attributes

internal | __pad0__: static void ResetOverflowLayout(Windows::UI::Xaml::DependencyObject^ d
internal
Windows::UI::Xaml::DependencyPropertyChangedEventArgs 		e

Static Private Member Functions

static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)

Private Attributes

Platform::Collections::Vector
< Windows::UI::Xaml::Controls::RichTextBlockOverflow^> 		_overflowColumns

Detailed Description

SuspensionManager captures global session state to simplify process lifetime management for an application.

Wrapper for RichTextBlock that creates as many additional overflow columns as needed to fit the available content.

Value converter that translates true to Visibility::Visible and false to Visibility::Collapsed.

The following creates a collection of 400-pixel wide columns spaced 50 pixels apart to contain arbitrary data-bound content: <RichTextColumns> <RichTextColumns.ColumnTemplate> <DataTemplate> <RichTextBlockOverflow width="400" margin="50,0,0,0"> </DataTemplate> </RichTextColumns.ColumnTemplate>

<RichTextBlock width="400"> <Paragraph> <Run text="{Binding Content}"> </Paragraph> </RichTextBlock> </RichTextColumns>

Typically used in a horizontally scrolling region where an unbounded amount of space allows for all needed columns to be created. When used in a vertically scrolling space there will never be any additional columns.

Note that session state will be automatically cleared under a variety of conditions and should only be used to store information that would be convenient to carry across sessions, but that should be disacarded when an application crashes or is upgraded.

Definition at line 17 of file BooleanNegationConverter.h.

Member Function Documentation

virtual Windows::Foundation::Size Hilo::Common::sealed::ArrangeOverride ( Windows::Foundation::Size finalSize ) [override, protected, virtual]
virtual Platform::Object Hilo::Common::sealed::Convert | ( | Platform::Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Platform::Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [virtual]
virtual Platform::Object Hilo::Common::sealed::Convert | ( | Platform::Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Platform::Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [virtual]
virtual Platform::Object Hilo::Common::sealed::ConvertBack | ( | Platform::Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Platform::Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [virtual]
virtual Platform::Object Hilo::Common::sealed::ConvertBack | ( | Platform::Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Platform::Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [virtual]
virtual Windows::Foundation::Size Hilo::Common::sealed::MeasureOverride ( Windows::Foundation::Size availableSize ) [override, protected, virtual]
static Concurrency::task<void> Hilo::Common::sealed::RestoreAsync ( void ) [static]
static void Hilo::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
Hilo::Common::sealed::RichTextColumns ( )
static Concurrency::task<void> Hilo::Common::sealed::SaveAsync ( void ) [static]
static void Hilo::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> Hilo::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void Hilo::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]

Member Data Documentation

internal sealed::__pad0__ [protected]

Definition at line 71 of file RichTextColumns.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::RichTextBlockOverflow^> Hilo::Common::sealed::_overflowColumns [private]

Definition at line 74 of file RichTextColumns.h.

internal Windows::UI::Xaml::DependencyPropertyChangedEventArgs Hilo::Common::sealed::e [protected]

Definition at line 71 of file RichTextColumns.h.

internal Platform::String Hilo::Common::sealed::sessionStateKey

Definition at line 30 of file SuspensionManager.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/Common/BooleanNegationConverter.h
  • Hilo C++/C++/Hilo/Common/RichTextColumns.h
  • Hilo C++/C++/Hilo/Common/SuspensionManager.h
  • Hilo C++/C++/Hilo/Common/BooleanToVisibilityConverter.h
  • Hilo C++/C++/Hilo/Common/SuspensionManager.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::DebugLoggingExceptionPolicy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::DebugLoggingExceptionPolicy
Public Member Functions

Hilo::DebugLoggingExceptionPolicy Class Reference

#include "DebugLoggingExceptionPolicy.h"

Inherits Hilo::ExceptionPolicy.

List of all members.

Public Member Functions

virtual void HandleException (Platform::Exception^exception)

Detailed Description

Definition at line 12 of file DebugLoggingExceptionPolicy.h.

Member Function Documentation

virtual void Hilo::DebugLoggingExceptionPolicy::HandleException ( Platform::Exception^ exception ) [virtual]

Implements Hilo::ExceptionPolicy.

The documentation for this class was generated from the following file:
  • Hilo C++/C++/Hilo/DebugLoggingExceptionPolicy.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ExceptionPolicy Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ExceptionPolicy
Public Member Functions

Hilo::ExceptionPolicy Class Reference

#include "ExceptionPolicy.h"

Inherited by Hilo::DebugLoggingExceptionPolicy.

List of all members.

Public Member Functions

virtual void HandleException (Platform::Exception^exception)=0

Detailed Description

Definition at line 11 of file ExceptionPolicy.h.

Member Function Documentation

virtual void Hilo::ExceptionPolicy::HandleException ( Platform::Exception^ exception ) [pure virtual]

Implemented in Hilo::DebugLoggingExceptionPolicy.

The documentation for this class was generated from the following file:
  • Hilo C++/C++/Hilo/ExceptionPolicy.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ExceptionPolicyFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ExceptionPolicyFactory
Static Public Member Functions | Static Public Attributes

Hilo::ExceptionPolicyFactory Class Reference

#include "ExceptionPolicyFactory.h"

List of all members.

Static Public Member Functions

static std::shared_ptr
< ExceptionPolicy > 		GetCurrentPolicy ()

Static Public Attributes

static std::shared_ptr
< ExceptionPolicy > 		m_policy

Detailed Description

Definition at line 13 of file ExceptionPolicyFactory.h.

Member Function Documentation

shared_ptr< ExceptionPolicy > ExceptionPolicyFactory::GetCurrentPolicy ( ) [static]

Definition at line 14 of file ExceptionPolicyFactory.cpp.

{
    return std::make_shared<DebugLoggingExceptionPolicy>();
}

Member Data Documentation

std::shared_ptr<ExceptionPolicy> Hilo::ExceptionPolicyFactory::m_policy [static]

Definition at line 18 of file ExceptionPolicyFactory.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/ExceptionPolicyFactory.h
  • Hilo C++/C++/Hilo/ExceptionPolicyFactory.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ExifExtensions Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ExifExtensions
Static Public Member Functions

Hilo::ExifExtensions Class Reference

#include "ExifExtensions.h"

List of all members.

Static Public Member Functions

static ExifRotations | ConvertDegreesRotationToExifOrientation (unsigned int angle)
static unsigned int | ConvertExifOrientationToDegreesRotation (ExifRotations exifOrientationFlag)
static Windows::Foundation::Rect | RotateClockwise (Windows::Foundation::Rect rect, Windows::Foundation::Rect bitmapSize, float64 degrees)

Detailed Description

Definition at line 22 of file ExifExtensions.h.

Member Function Documentation

ExifRotations ExifExtensions::ConvertDegreesRotationToExifOrientation ( unsigned int angle ) [static]

Definition at line 72 of file ExifExtensions.cpp.

{
    switch (angle)
    {
    case 0:
        return ExifRotations::NotRotated;
    case 90:
        return ExifRotations::RotatedLeft;
    case 180:
        return ExifRotations::RotatedDown;
    case 270:
        return ExifRotations::RotatedRight;
    default:
        // Ignore flip/mirroring values (2, 4, 5, 7)
        return ExifRotations::NotRotated;
    }

}

unsigned int ExifExtensions::ConvertExifOrientationToDegreesRotation ( ExifRotations exifOrientationFlag ) [static]

Definition at line 54 of file ExifExtensions.cpp.

{
    switch (exifOrientationFlag)
    {
    case ExifRotations::NotRotated:
        return 0;
    case ExifRotations::RotatedLeft:
        return 90;
    case ExifRotations::RotatedDown:
        return 180;
    case ExifRotations::RotatedRight:
        return 270;
    default:
        // Ignore flip/mirroring values (2, 4, 5, 7)
        return 0;
    }
}

static Windows::Foundation::Rect Hilo::ExifExtensions::RotateClockwise | ( | Windows::Foundation::Rect | rect,
 |  | Windows::Foundation::Rect | bitmapSize,
 |  | float64 | degrees |
 | ) |  |  | [static]
The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/ExifExtensions.h
  • Hilo C++/C++/Hilo/ExifExtensions.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::FileSystemRepository Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::FileSystemRepository
Public Member Functions | Private Member Functions | Private Attributes

Hilo::FileSystemRepository Class Reference

#include "FileSystemRepository.h"

Inherits Hilo::Repository.

List of all members.

Public Member Functions

FileSystemRepository (std::shared_ptr< ExceptionPolicy > exceptionPolicy)
virtual void | AddObserver (const std::function< void()> callback, PageType pageType)
virtual concurrency::task
< unsigned int > 		GetFolderPhotoCountAsync (Windows::Storage::Search::IStorageFolderQueryOperations^folderQuery)
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IPhotoGroup^>^> 		GetMonthGroupedPhotosWithCacheAsync (std::shared_ptr< Hilo::PhotoCache > photoCache, concurrency::cancellation_token token)
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IPhoto^>^> 		GetPhotoDataForMonthGroup (IPhotoGroup^photoGroup, Windows::Storage::Search::IStorageFolderQueryOperations^folderQuery, unsigned int maxNumberOfItems)
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IPhoto^>^> 		GetPhotosForDateRangeQueryAsync (Platform::String^dateRangeQuery)
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IPhoto^>^> 		GetPhotosForPictureHubGroupAsync (IPhotoGroup^photoGroup, unsigned int maxNumberOfItem)
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< Windows::Storage::StorageFile^>^> 		GetPhotoStorageFilesAsync (Platform::String^query, unsigned int maxNumberOfItems=25)
virtual concurrency::task< IPhoto^> | GetSinglePhotoAsync (Platform::String^photoPath)
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IYearGroup^>^> 		GetYearGroupedMonthsAsync (concurrency::cancellation_token token)
virtual concurrency::task< bool > | HasPhotosInRangeAsync (Platform::String^dateRangeQuery, Windows::Storage::Search::IStorageFolderQueryOperations^folderQuery)
virtual void | NotifyAllObservers ()
virtual void | RemoveObserver (PageType pageType)

Private Member Functions

Windows::Storage::Search::StorageFileQueryResult | CreateFileQuery (Windows::Storage::Search::IStorageFolderQueryOperations^folder, Platform::String^query, Windows::Storage::Search::IndexerOption option=Windows::Storage::Search::IndexerOption::UseIndexerWhenAvailable)
concurrency::task< YearGroup^> | GetDateTimeForYearFolderAsync (Windows::Storage::Search::IStorageFolderQueryOperations^folderQuery, std::shared_ptr< ExceptionPolicy > exceptionPolicy)

Private Attributes

QueryChange | m_allPhotosQueryChange
std::shared_ptr< ExceptionPolicy > | m_exceptionPolicy
std::function< void()> | m_hubViewModelCallback
std::function< void()> | m_imageBrowserViewModelCallback
std::function< void()> | m_imageViewModelCallback
QueryChange | m_monthQueryChange
QueryChange | m_pictureHubGroupQueryChange

Detailed Description

Definition at line 18 of file FileSystemRepository.h.

Constructor & Destructor Documentation

Hilo::FileSystemRepository::FileSystemRepository ( std::shared_ptr< ExceptionPolicy > exceptionPolicy )

Member Function Documentation

void FileSystemRepository::AddObserver | ( | const std::function< void()> | callback,
 |  | PageType | pageType |
 | ) |  |  | [virtual]

Implements Hilo::ObservableQuery.

Definition at line 57 of file FileSystemRepository.cpp.

{
    switch (pageType)
    {
    case PageType::Hub:
        m_hubViewModelCallback = callback;
        break;
    case PageType::Browse:
        m_imageBrowserViewModelCallback = callback;
        break;
    case PageType::Image:
        m_imageViewModelCallback = callback;
        break;
    default:
        assert(false);
    }
}

Windows::Storage::Search::StorageFileQueryResult Hilo::FileSystemRepository::CreateFileQuery | ( | Windows::Storage::Search::IStorageFolderQueryOperations^ | folder,
 |  | Platform::String^ | query,
 |  | Windows::Storage::Search::IndexerOption | option = Windows::Storage::Search::IndexerOption::UseIndexerWhenAvailable |
 | ) |  |  | [inline, private]
concurrency::task<YearGroup^> Hilo::FileSystemRepository::GetDateTimeForYearFolderAsync | ( | Windows::Storage::Search::IStorageFolderQueryOperations^ | folderQuery,
 |  | std::shared_ptr< ExceptionPolicy > | exceptionPolicy |
 | ) |  |  | [private]
virtual concurrency::task<unsigned int> Hilo::FileSystemRepository::GetFolderPhotoCountAsync ( Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery ) [virtual]

Implements Hilo::Repository.

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhotoGroup^>^> Hilo::FileSystemRepository::GetMonthGroupedPhotosWithCacheAsync | ( | std::shared_ptr< Hilo::PhotoCache > | photoCache,
 |  | concurrency::cancellation_token | token |
 | ) |  |  | [virtual]
virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> Hilo::FileSystemRepository::GetPhotoDataForMonthGroup | ( | IPhotoGroup^ | photoGroup,
 |  | Windows::Storage::Search::IStorageFolderQueryOperations^ | folderQuery,
 |  | unsigned int | maxNumberOfItems |
 | ) |  |  | [virtual]

Implements Hilo::Repository.

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> Hilo::FileSystemRepository::GetPhotosForDateRangeQueryAsync ( Platform::String^ dateRangeQuery ) [virtual]

Implements Hilo::Repository.

task< IVectorView< IPhoto^>^> FileSystemRepository::GetPhotosForPictureHubGroupAsync | ( | IPhotoGroup^ | photoGroup,
 |  | unsigned int | maxNumberOfItem |
 | ) |  |  | [virtual]

Implements Hilo::Repository.

Definition at line 230 of file FileSystemRepository.cpp.

{
    auto fileQuery = CreateFileQuery(KnownFolders::PicturesLibrary, "");
    auto fileInformationFactory = ref new FileInformationFactory(fileQuery, ThumbnailMode::PicturesView);
    m_pictureHubGroupQueryChange = (m_hubViewModelCallback != nullptr) ? ref new QueryChange(fileQuery, m_hubViewModelCallback) : nullptr;
    shared_ptr<ExceptionPolicy> policy = m_exceptionPolicy;
    return create_task(fileInformationFactory->GetFilesAsync(0, maxNumberOfItems)).then([photoGroup, policy](IVectorView<FileInformation^>^ files)
    {
        auto photos = ref new Vector<IPhoto^>();
        for (auto item : files)
        {
            auto photo = ref new Photo(item, photoGroup, policy);
            photos->Append(photo);
        }
        return photos->GetView();

    }, task_continuation_context::use_current());
}

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<Windows::Storage::StorageFile^>^> Hilo::FileSystemRepository::GetPhotoStorageFilesAsync | ( | Platform::String^ | query,
 |  | unsigned int | maxNumberOfItems = 25 |
 | ) |  |  | [inline, virtual]

Implements Hilo::Repository.

virtual concurrency::task<IPhoto^> Hilo::FileSystemRepository::GetSinglePhotoAsync ( Platform::String^ photoPath ) [virtual]

Implements Hilo::Repository.

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IYearGroup^>^> Hilo::FileSystemRepository::GetYearGroupedMonthsAsync ( concurrency::cancellation_token token ) [virtual]

Implements Hilo::Repository.

virtual concurrency::task<bool> Hilo::FileSystemRepository::HasPhotosInRangeAsync | ( | Platform::String^ | dateRangeQuery,
 |  | Windows::Storage::Search::IStorageFolderQueryOperations^ | folderQuery |
 | ) |  |  | [virtual]

Implements Hilo::Repository.

void FileSystemRepository::NotifyAllObservers ( ) [virtual]

Implements Hilo::Repository.

Definition at line 98 of file FileSystemRepository.cpp.

{
    if (m_hubViewModelCallback != nullptr)
    {
        m_hubViewModelCallback();
    }
    if (m_imageBrowserViewModelCallback != nullptr)
    {
        m_imageBrowserViewModelCallback();
    }
    if (m_imageViewModelCallback = nullptr)
    {
        m_imageViewModelCallback();
    }
}

void FileSystemRepository::RemoveObserver ( PageType pageType ) [virtual]

Implements Hilo::ObservableQuery.

Definition at line 75 of file FileSystemRepository.cpp.

{
    switch (pageType)
    {
    case PageType::Hub:
        m_pictureHubGroupQueryChange = nullptr;
        m_hubViewModelCallback = nullptr;
        break;
    case PageType::Browse:
        m_monthQueryChange = nullptr;
        m_imageBrowserViewModelCallback = nullptr;
        break;
    case PageType::Image:
        m_allPhotosQueryChange = nullptr;
        m_imageViewModelCallback = nullptr;
        break;
    default:
        assert(false);
    }
}

Member Data Documentation

QueryChange Hilo::FileSystemRepository::m_allPhotosQueryChange [private]

Definition at line 42 of file FileSystemRepository.h.

std::shared_ptr<ExceptionPolicy> Hilo::FileSystemRepository::m_exceptionPolicy [private]

Definition at line 38 of file FileSystemRepository.h.

std::function<void()> Hilo::FileSystemRepository::m_hubViewModelCallback [private]

Definition at line 39 of file FileSystemRepository.h.

std::function<void()> Hilo::FileSystemRepository::m_imageBrowserViewModelCallback [private]

Definition at line 40 of file FileSystemRepository.h.

std::function<void()> Hilo::FileSystemRepository::m_imageViewModelCallback [private]

Definition at line 41 of file FileSystemRepository.h.

QueryChange Hilo::FileSystemRepository::m_monthQueryChange [private]

Definition at line 44 of file FileSystemRepository.h.

QueryChange Hilo::FileSystemRepository::m_pictureHubGroupQueryChange [private]

Definition at line 43 of file FileSystemRepository.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/FileSystemRepository.h
  • Hilo C++/C++/Hilo/FileSystemRepository.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::HiloPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::HiloPage
Public Member Functions | Static Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Hilo::HiloPage Class Reference

#include "HiloPage.h"

Inherits Hilo::Common::LayoutAwarePage.

List of all members.

Public Member Functions

virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | NavigateHome ()
virtual void | NavigateToPage (PageType page, Platform::Object^parameter)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override

Static Public Member Functions

static void | OnHiloDataContextPropertyChanged (Windows::UI::Xaml::DependencyObject^element, Windows::UI::Xaml::DependencyPropertyChangedEventArgs^e)

Public Attributes

internal | __pad0__: HiloPage()
internal | __pad1__: static property bool IsSuspending

Private Member Functions

void | AttachNavigationHandlers (Hilo::ViewModelBase^viewModel)
void | DetachNavigationHandlers (Hilo::ViewModelBase^viewModel)

Private Attributes

bool | m_hasHandlers
Windows::Foundation::EventRegistrationToken | m_navigateBackEventToken
Windows::Foundation::EventRegistrationToken | m_navigateHomeEventToken
Windows::Foundation::EventRegistrationToken | m_navigateToPageEventToken

Detailed Description

Definition at line 25 of file HiloPage.h.

Member Function Documentation

void HiloPage::AttachNavigationHandlers ( Hilo::ViewModelBase^ viewModel ) [private]

Definition at line 161 of file HiloPage.cpp.

{
    if (nullptr == viewModel) return;

    // Only resusbcribe if our tokens are empty.

    if (!m_hasHandlers)
    {
        m_navigateBackEventToken = viewModel->NavigateBack::add(ref new NavigateEventHandler(this, &HiloPage::NavigateBack));
        m_navigateHomeEventToken = viewModel->NavigateHome::add(ref new NavigateEventHandler(this, &HiloPage::NavigateHome));
        m_navigateToPageEventToken = viewModel->NavigateToPage::add(ref new PageNavigateEventHandler(this, &HiloPage::NavigateToPage));
        m_hasHandlers = true;
    }
}

void HiloPage::DetachNavigationHandlers ( Hilo::ViewModelBase^ viewModel ) [private]

Definition at line 176 of file HiloPage.cpp.

{
    if (nullptr == viewModel) return;
    assert(!HiloPage::IsSuspending);

    if (m_hasHandlers)
    {
        viewModel->NavigateBack::remove(m_navigateBackEventToken);
        viewModel->NavigateHome::remove(m_navigateHomeEventToken);
        viewModel->NavigateToPage::remove(m_navigateToPageEventToken);
        m_hasHandlers = false;
    };
}

virtual void Hilo::HiloPage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, virtual]

Reimplemented from Hilo::Common::LayoutAwarePage.

void HiloPage::NavigateHome ( ) [virtual]

Definition at line 94 of file HiloPage.cpp.

{
    GoHome(nullptr, nullptr);
}

void HiloPage::NavigateToPage | ( | PageType | page,
 |  | Platform::Object^ | parameter |
 | ) |  |  | [virtual]

Definition at line 99 of file HiloPage.cpp.

{
    if (Frame != nullptr)
    {
        TypeName source = m_pages[page];
        Frame->Navigate(source, parameter);
    }
}

void HiloPage::OnHiloDataContextPropertyChanged | ( | Windows::UI::Xaml::DependencyObject^ | element,
 |  | Windows::UI::Xaml::DependencyPropertyChangedEventArgs^ | e |
 | ) |  |  | [static]

Definition at line 60 of file HiloPage.cpp.

{
    HiloPage^ page = static_cast<HiloPage^>(element);
    ViewModelBase^ oldViewModel = dynamic_cast<ViewModelBase^>(e->OldValue);
    page->DetachNavigationHandlers(oldViewModel);

    ViewModelBase^ newViewModel = dynamic_cast<ViewModelBase^>(e->NewValue);
    page->AttachNavigationHandlers(newViewModel);
}

void Hilo::HiloPage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::Common::LayoutAwarePage.

Definition at line 122 of file HiloPage.cpp.

{
    ViewModelBase^ viewModel = dynamic_cast<ViewModelBase^>(DataContext);
    if (!HiloPage::IsSuspending)
    {
        // Since we never receive destructs, this is the only place to unsubscribe.
        DetachNavigationHandlers(viewModel);
        viewModel->OnNavigatedFrom(e);
    }

   LayoutAwarePage::OnNavigatedFrom(e);
}

virtual void Hilo::HiloPage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::Common::LayoutAwarePage.

virtual void Hilo::HiloPage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, virtual]

Reimplemented from Hilo::Common::LayoutAwarePage.

Member Data Documentation

internal Hilo::HiloPage::__pad0__

Reimplemented from Hilo::Common::LayoutAwarePage.

Definition at line 28 of file HiloPage.h.

internal Hilo::HiloPage::__pad1__

Definition at line 49 of file HiloPage.h.

bool Hilo::HiloPage::m_hasHandlers [private]

Definition at line 57 of file HiloPage.h.

Windows::Foundation::EventRegistrationToken Hilo::HiloPage::m_navigateBackEventToken [private]

Definition at line 54 of file HiloPage.h.

Windows::Foundation::EventRegistrationToken Hilo::HiloPage::m_navigateHomeEventToken [private]

Definition at line 55 of file HiloPage.h.

Windows::Foundation::EventRegistrationToken Hilo::HiloPage::m_navigateToPageEventToken [private]

Definition at line 56 of file HiloPage.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/HiloPage.h
  • Hilo C++/C++/Hilo/HiloPage.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ImageBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ImageBase
Protected Member Functions | Protected Attributes

Hilo::ImageBase Class Reference

#include "ImageBase.h"

Inherits Hilo::ViewModelBase.

Inherited by Hilo::sealed, Hilo::sealed, and Hilo::sealed.

List of all members.

Protected Member Functions

concurrency::task
< Windows::Storage::StorageFile^> 		GetFileNameFromFileSavePickerAsync (Platform::String^fileType)
concurrency::task
< Windows::Storage::Streams::IRandomAccessStreamWithContentType^> 		GetStreamWithFailCheck ()
concurrency::task< void > | SaveImageAsync (Windows::Storage::StorageFile^file, Windows::Storage::Streams::IRandomAccessStream^ras)

Protected Attributes

internal | __pad0__: ImageBase(std::shared_ptr<ExceptionPolicy> exceptionPolicy)
IPhoto m_photo

Detailed Description

Definition at line 18 of file ImageBase.h.

Member Function Documentation

concurrency::task<Windows::Storage::StorageFile^> Hilo::ImageBase::GetFileNameFromFileSavePickerAsync ( Platform::String^ fileType ) [protected]
concurrency::task< IRandomAccessStreamWithContentType^> ImageBase::GetStreamWithFailCheck ( ) [protected]

Definition at line 25 of file ImageBase.cpp.

{
    return create_task(m_photo->OpenReadAsync())
        .then([this](task<IRandomAccessStreamWithContentType^> openTask)
    {
        assert(IsMainThread());
        try
        {
            auto stream = openTask.get();
            return stream;
        }
        catch(Platform::Exception^ ex)
        {
            switch(ex->HResult)
            {
            case HILO_PHOTO_FILE_NOT_FOUND:
                // Image has been removed, take the user home.
                GoHome();
                cancel_current_task();
                break;

            default:
                throw;
            }
        }
    }, task_continuation_context::use_current());
}

concurrency::task<void> Hilo::ImageBase::SaveImageAsync | ( | Windows::Storage::StorageFile^ | file,
 |  | Windows::Storage::Streams::IRandomAccessStream^ | ras |
 | ) |  |  | [protected]

Member Data Documentation

internal Hilo::ImageBase::__pad0__ [protected]

Reimplemented from Hilo::ViewModelBase.

Reimplemented in Hilo::sealed.

Definition at line 25 of file ImageBase.h.

IPhoto Hilo::ImageBase::m_photo [protected]

Reimplemented in Hilo::sealed.

Definition at line 22 of file ImageBase.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/ImageBase.h
  • Hilo C++/C++/Hilo/ImageBase.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ImageNavigationData Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ImageNavigationData
Public Member Functions | Private Attributes

Hilo::ImageNavigationData Class Reference

#include "ImageNavigationData.h"

List of all members.

Public Member Functions

ImageNavigationData (IPhoto^photo)
ImageNavigationData (Platform::String^serializationString)
Platform::String | GetDateQuery ()
Windows::Foundation::DateTime | GetFileDate () const
Platform::String | GetFilePath () const
Platform::String | SerializeToString ()

Private Attributes

Platform::String | m_dateQuery
Windows::Foundation::DateTime | m_fileDate
Platform::String | m_filePath

Detailed Description

Definition at line 14 of file ImageNavigationData.h.

Constructor & Destructor Documentation

ImageNavigationData::ImageNavigationData ( IPhoto^ photo )

Definition at line 19 of file ImageNavigationData.cpp.

{
    m_fileDate = photo->DateTaken;
    m_filePath = photo->Path;
}

Hilo::ImageNavigationData::ImageNavigationData ( Platform::String^ serializationString )

Member Function Documentation

String ImageNavigationData::GetDateQuery ( )

Definition at line 50 of file ImageNavigationData.cpp.

{
    if (nullptr == m_dateQuery)
    {
        m_dateQuery = CalendarExtensions::CreateMonthRangeFromDate(m_fileDate);
    }
    return m_dateQuery;
}

DateTime ImageNavigationData::GetFileDate ( ) const

Definition at line 40 of file ImageNavigationData.cpp.

{
    return m_fileDate;
}

String ImageNavigationData::GetFilePath ( ) const

Definition at line 45 of file ImageNavigationData.cpp.

{
    return m_filePath;
}

String ImageNavigationData::SerializeToString ( )

Definition at line 59 of file ImageNavigationData.cpp.

{
    wstringstream stringStream;
    stringStream << m_filePath->Data() << L"|" << m_fileDate.UniversalTime ;
    return ref new String(stringStream.str().c_str());
}

Member Data Documentation

Platform::String Hilo::ImageNavigationData::m_dateQuery [private]

Definition at line 27 of file ImageNavigationData.h.

Windows::Foundation::DateTime Hilo::ImageNavigationData::m_fileDate [private]

Definition at line 26 of file ImageNavigationData.h.

Platform::String Hilo::ImageNavigationData::m_filePath [private]

Definition at line 28 of file ImageNavigationData.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/ImageNavigationData.h
  • Hilo C++/C++/Hilo/ImageNavigationData.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::IMonthBlock Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::IMonthBlock

Hilo::IMonthBlock Interface Reference

#include "IMonthBlock.h"

Inherited by Hilo::sealed.

Detailed Description

Definition at line 16 of file IMonthBlock.h.

The documentation for this interface was generated from the following file:
  • Hilo C++/C++/Hilo/IMonthBlock.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::IPhoto Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::IPhoto
Public Member Functions

Hilo::IPhoto Interface Reference

#include "IPhoto.h"

Inherited by Hilo::sealed.

List of all members.

Public Member Functions

Windows::Foundation::IAsyncOperation
< Windows::Storage::Streams::IRandomAccessStreamWithContentType^> 		OpenReadAsync ()

Detailed Description

Definition at line 15 of file IPhoto.h.

Member Function Documentation

Windows::Foundation::IAsyncOperation<Windows::Storage::Streams::IRandomAccessStreamWithContentType^> Hilo::IPhoto::OpenReadAsync ( )
The documentation for this interface was generated from the following file:
  • Hilo C++/C++/Hilo/IPhoto.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::IPhotoGroup Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::IPhotoGroup

Hilo::IPhotoGroup Interface Reference

#include "IPhotoGroup.h"

Inherited by Hilo::NullPhotoGroup, Hilo::sealed, and Hilo::sealed.

Detailed Description

Definition at line 17 of file IPhotoGroup.h.

The documentation for this interface was generated from the following file:
  • Hilo C++/C++/Hilo/IPhotoGroup.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::IResizable Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::IResizable

Hilo::IResizable Interface Reference

#include "IResizable.h"

Inherited by Hilo::sealed, and Hilo::sealed.

Detailed Description

Definition at line 11 of file IResizable.h.

The documentation for this interface was generated from the following file:
  • Hilo C++/C++/Hilo/IResizable.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::IResourceLoader Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::IResourceLoader
Public Member Functions

Hilo::IResourceLoader Interface Reference

#include "IResourceLoader.h"

Inherited by Hilo::sealed.

List of all members.

Public Member Functions

Platform::String GetString (Platform::String^value)

Detailed Description

Definition at line 12 of file IResourceLoader.h.

Member Function Documentation

Platform::String Hilo::IResourceLoader::GetString ( Platform::String^ value )
The documentation for this interface was generated from the following file:
  • Hilo C++/C++/Hilo/IResourceLoader.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::IYearGroup Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::IYearGroup

Hilo::IYearGroup Interface Reference

#include "IYearGroup.h"

Inherited by Hilo::sealed.

Detailed Description

Definition at line 16 of file IYearGroup.h.

The documentation for this interface was generated from the following file:
  • Hilo C++/C++/Hilo/IYearGroup.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::NullPhotoGroup Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::NullPhotoGroup
Public Attributes

Hilo::NullPhotoGroup Class Reference

#include "NullPhotoGroup.h"

Inherits Hilo::IPhotoGroup.

List of all members.

Public Attributes

internal __pad0__: virtual operator Windows::Storage::IStorageFolder^ () { return nullptr

Detailed Description

Definition at line 16 of file NullPhotoGroup.h.

Member Data Documentation

internal Hilo::NullPhotoGroup::__pad0__

Definition at line 22 of file NullPhotoGroup.h.

The documentation for this class was generated from the following file:
  • Hilo C++/C++/Hilo/NullPhotoGroup.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ObservableQuery Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ObservableQuery
Public Member Functions

Hilo::ObservableQuery Class Reference

#include "ObservableQuery.h"

Inherited by Hilo::Repository.

List of all members.

Public Member Functions

virtual void | AddObserver (const std::function< void()> callback, PageType pageType)=0
virtual void | RemoveObserver (PageType pageType)=0

Detailed Description

Definition at line 14 of file ObservableQuery.h.

Member Function Documentation

virtual void Hilo::ObservableQuery::AddObserver | ( | const std::function< void()> | callback,
 |  | PageType | pageType |
 | ) |  |  | [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual void Hilo::ObservableQuery::RemoveObserver ( PageType pageType ) [pure virtual]

Implemented in Hilo::FileSystemRepository.

The documentation for this class was generated from the following file:
  • Hilo C++/C++/Hilo/ObservableQuery.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ObserveException< T > Struct Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ObserveException< T >
Public Member Functions | Private Attributes

Hilo::ObserveException< T > Struct Template Reference

#include "TaskExceptionsExtensions.h"

List of all members.

Public Member Functions

ObserveException (std::shared_ptr< ExceptionPolicy > handler)
template<>
concurrency::task< void > | operator() (concurrency::task< void > antecedent) const
concurrency::task< T > | operator() (concurrency::task< T > antecedent) const

Private Attributes

std::shared_ptr< ExceptionPolicy > | m_handler

Detailed Description

template<typename T>
struct Hilo::ObserveException< T >

Definition at line 13 of file TaskExceptionsExtensions.h.

Constructor & Destructor Documentation

template<typename T >
Hilo::ObserveException< T >::ObserveException ( std::shared_ptr< ExceptionPolicy > handler ) [inline]

Definition at line 15 of file TaskExceptionsExtensions.h.

                                                                 : m_handler(handler)
        {
        }

Member Function Documentation

template<typename T >
concurrency::task<T> Hilo::ObserveException< T >::operator() ( concurrency::task< T > antecedent ) const [inline]

Definition at line 19 of file TaskExceptionsExtensions.h.

        {
            T result;
            try
            {
                result = antecedent.get();
            }
            catch(const concurrency::task_canceled&)
            {
                // don't need to run canceled tasks through the policy
            }
            catch(const std::exception&)
            {
                auto translatedException = ref new Platform::FailureException();
                m_handler->HandleException(translatedException);
                throw;
            }
            catch(Platform::Exception^ ex)
            {
                m_handler->HandleException(ex);
                throw;
            }
            return antecedent;
        }

template<>
concurrency::task< void > Hilo::ObserveException< void >::operator() ( concurrency::task< void > antecedent ) const

Definition at line 49 of file TaskExceptionsExtensions.h.

    {
        try
        {
            antecedent.get();
        }
        catch(const concurrency::task_canceled&)
        {
            // don't need to run canceled tasks through the policy
        }
        catch(const std::exception&)
        {
            auto translatedException = ref new Platform::FailureException();
            m_handler->HandleException(translatedException);
            throw;
        }
        catch(Platform::Exception^ ex)
        {
            m_handler->HandleException(ex);
            throw;
        }

        return antecedent;
    }

Member Data Documentation

template<typename T >
std::shared_ptr<ExceptionPolicy> Hilo::ObserveException< T >::m_handler [private]

Definition at line 45 of file TaskExceptionsExtensions.h.

The documentation for this struct was generated from the following file:
  • Hilo C++/C++/Hilo/TaskExceptionsExtensions.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::PhotoCache Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::PhotoCache
Public Member Functions | Private Types | Private Attributes

Hilo::PhotoCache Class Reference

#include "PhotoCache.h"

List of all members.

Public Member Functions

void | Clear ()
IPhoto | GetForYearAndMonth (int year, int month)
void | InsertPhoto (IPhoto^photo)

Private Types

typedef std::map< int,
Platform::WeakReference > 		MonthPhoto

Private Attributes

std::map< int, MonthPhoto > | m_photoCache

Detailed Description

Definition at line 15 of file PhotoCache.h.

Member Typedef Documentation

typedef std::map<int, Platform::WeakReference> Hilo::PhotoCache::MonthPhoto [private]

Definition at line 23 of file PhotoCache.h.

Member Function Documentation

void PhotoCache::Clear ( )

Definition at line 16 of file PhotoCache.cpp.

{
    m_photoCache.clear();
}

IPhoto PhotoCache::GetForYearAndMonth | ( | int | year,
 |  | int | month
 | ) |  |

Definition at line 31 of file PhotoCache.cpp.

{
    auto &yearMap = m_photoCache[year];
    auto &weakRef = yearMap[month];

    if (nullptr != weakRef)
    {
        return weakRef.Resolve<IPhoto>();
    }
    return nullptr;
}

void PhotoCache::InsertPhoto ( IPhoto^ photo )

Definition at line 21 of file PhotoCache.cpp.

{
    int year, month;
    auto monthDate = photo->DateTaken;

    CalendarExtensions::WriteLocalizedYearAndMonth(monthDate, year, month);
    auto &yearPair = m_photoCache[year];
    yearPair[month] = WeakReference(photo);
}

Member Data Documentation

std::map<int, MonthPhoto> Hilo::PhotoCache::m_photoCache [private]

Definition at line 24 of file PhotoCache.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/PhotoCache.h
  • Hilo C++/C++/Hilo/PhotoCache.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::PhotoPathComparer Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::PhotoPathComparer
Public Member Functions

Hilo::PhotoPathComparer Struct Reference

#include "PhotoPathComparer.h"

List of all members.

Public Member Functions

bool operator() (IPhoto^left, IPhoto^right) const

Detailed Description

Definition at line 14 of file PhotoPathComparer.h.

Member Function Documentation

bool PhotoPathComparer::operator() | ( | IPhoto^ | left,
 |  | IPhoto^ | right |
 | ) |  |  | const

Definition at line 13 of file PhotoPathComparer.cpp.

{
    if (nullptr == left && nullptr == right)
    {
        return true;
    }
    if (nullptr == left || nullptr == right)
    {
        return false;
    }
    bool equal = left->Path == right->Path;
    return equal;
}

The documentation for this struct was generated from the following files:
  • Hilo C++/C++/Hilo/PhotoPathComparer.h
  • Hilo C++/C++/Hilo/PhotoPathComparer.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::RandomPhotoSelector Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::RandomPhotoSelector
Static Public Member Functions

Hilo::RandomPhotoSelector Class Reference

#include "RandomPhotoSelector.h"

List of all members.

Static Public Member Functions

static std::vector< unsigned int > CreateRandomizedVector (unsigned int vectorSize, unsigned int sampleSize)
static concurrency::task
< Windows::Foundation::Collections::IVector
< Windows::Storage::StorageFile^>^> 		SelectFilesAsync (Windows::Foundation::Collections::IVectorView< Windows::Storage::StorageFile^>^photos, unsigned int count)

Detailed Description

Definition at line 14 of file RandomPhotoSelector.h.

Member Function Documentation

vector< unsigned int > RandomPhotoSelector::CreateRandomizedVector | ( | unsigned int | vectorSize,
 |  | unsigned int | sampleSize |
 | ) |  |  | [static]

Definition at line 39 of file RandomPhotoSelector.cpp.

{
    // Seed the rand() function, which is used by random_shuffle.
    srand(static_cast<unsigned int>(time(nullptr)));

    // The resulting set of random numbers.
    vector<unsigned int> result(vectorSize);

    // Fill with [0..vectorSize).
    iota(begin(result), end(result), 0);

    // Shuffle the elements.
    random_shuffle(begin(result), end(result));

    // Trim the list to the first sampleSize elements if the collection size is greater than the sample size.
    if (vectorSize > sampleSize)
    {
        result.resize(sampleSize);
    }

    return result;
}

static concurrency::task<Windows::Foundation::Collections::IVector<Windows::Storage::StorageFile^>^> Hilo::RandomPhotoSelector::SelectFilesAsync | ( | Windows::Foundation::Collections::IVectorView< Windows::Storage::StorageFile^>^ | photos,
 |  | unsigned int | count |
 | ) |  |  | [static]
The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/RandomPhotoSelector.h
  • Hilo C++/C++/Hilo/RandomPhotoSelector.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::Repository Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::Repository
Public Member Functions

Hilo::Repository Class Reference

#include "Repository.h"

Inherits Hilo::ObservableQuery.

Inherited by Hilo::FileSystemRepository.

List of all members.

Public Member Functions

virtual concurrency::task
< unsigned int > 		GetFolderPhotoCountAsync (Windows::Storage::Search::IStorageFolderQueryOperations^folderQuery)=0
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IPhotoGroup^>^> 		GetMonthGroupedPhotosWithCacheAsync (std::shared_ptr< PhotoCache > photoCache, concurrency::cancellation_token token)=0
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IPhoto^>^> 		GetPhotoDataForMonthGroup (IPhotoGroup^photoGroup, Windows::Storage::Search::IStorageFolderQueryOperations^folderQuery, unsigned int maxNumberOfItems)=0
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IPhoto^>^> 		GetPhotosForDateRangeQueryAsync (Platform::String^dateRangeQuery)=0
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IPhoto^>^> 		GetPhotosForPictureHubGroupAsync (IPhotoGroup^photoGroup, unsigned int maxNumberOfItems)=0
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< Windows::Storage::StorageFile^>^> 		GetPhotoStorageFilesAsync (Platform::String^query, unsigned int maxNumberOfItems)=0
virtual concurrency::task< IPhoto^> | GetSinglePhotoAsync (Platform::String^photoPath)=0
virtual concurrency::task
< Windows::Foundation::Collections::IVectorView
< IYearGroup^>^> 		GetYearGroupedMonthsAsync (concurrency::cancellation_token token)=0
virtual concurrency::task< bool > | HasPhotosInRangeAsync (Platform::String^dateRangeQuery, Windows::Storage::Search::IStorageFolderQueryOperations^folderQuery)=0
virtual void | NotifyAllObservers ()=0

Detailed Description

Definition at line 20 of file Repository.h.

Member Function Documentation

virtual concurrency::task<unsigned int> Hilo::Repository::GetFolderPhotoCountAsync ( Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery ) [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhotoGroup^>^> Hilo::Repository::GetMonthGroupedPhotosWithCacheAsync | ( | std::shared_ptr< PhotoCache > | photoCache,
 |  | concurrency::cancellation_token | token |
 | ) |  |  | [pure virtual]
virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> Hilo::Repository::GetPhotoDataForMonthGroup | ( | IPhotoGroup^ | photoGroup,
 |  | Windows::Storage::Search::IStorageFolderQueryOperations^ | folderQuery,
 |  | unsigned int | maxNumberOfItems |
 | ) |  |  | [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> Hilo::Repository::GetPhotosForDateRangeQueryAsync ( Platform::String^ dateRangeQuery ) [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> Hilo::Repository::GetPhotosForPictureHubGroupAsync | ( | IPhotoGroup^ | photoGroup,
 |  | unsigned int | maxNumberOfItems |
 | ) |  |  | [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<Windows::Storage::StorageFile^>^> Hilo::Repository::GetPhotoStorageFilesAsync | ( | Platform::String^ | query,
 |  | unsigned int | maxNumberOfItems |
 | ) |  |  | [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual concurrency::task<IPhoto^> Hilo::Repository::GetSinglePhotoAsync ( Platform::String^ photoPath ) [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IYearGroup^>^> Hilo::Repository::GetYearGroupedMonthsAsync ( concurrency::cancellation_token token ) [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual concurrency::task<bool> Hilo::Repository::HasPhotosInRangeAsync | ( | Platform::String^ | dateRangeQuery,
 |  | Windows::Storage::Search::IStorageFolderQueryOperations^ | folderQuery |
 | ) |  |  | [pure virtual]

Implemented in Hilo::FileSystemRepository.

virtual void Hilo::Repository::NotifyAllObservers ( ) [pure virtual]

Implemented in Hilo::FileSystemRepository.

The documentation for this class was generated from the following file:
  • Hilo C++/C++/Hilo/Repository.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::sealed
Public Member Functions | Public Attributes | Protected Member Functions | Properties | Private Member Functions | Private Attributes

Hilo::sealed Class Reference

Provides application-specific behavior to supplement the default Application class.

#include "App.xaml.h"

Inherits Hilo::IYearGroup, Hilo::ImageBase, Hilo::IResizable, Hilo::IPhoto, Hilo::IPhotoGroup, Hilo::IMonthBlock, Hilo::ViewModelBase, Hilo::IResourceLoader, Hilo::ViewModelBase, Hilo::ViewModelBase, Hilo::IPhotoGroup, Hilo::IResizable, Hilo::ImageBase, and Hilo::ImageBase.

List of all members.

Public Member Functions

virtual | ~CartoonizeImageViewModel ()
virtual | ~HubPhotoGroup ()
virtual | ~ImageBrowserViewModel ()
virtual | ~ImageView ()
virtual | ~ImageViewModel ()
virtual | ~MainHubViewModel ()
virtual | ~Photo ()
virtual | ~QueryChange ()
App ()
Platform::String | BuildDateQuery ()
void | CalculateInitialCropOverlayPosition (Windows::UI::Xaml::Media::GeneralTransform^transform, float width, float height)
void | CancelCartoonize (Platform::Object^parameter)
void | CancelCrop (Platform::Object^parameter)
void | CancelMonthAndYearQueries ()
void | CancelRotate (Platform::Object^parameter)
virtual bool | CanExecute (Platform::Object^parameter)
bool | CanNavigateToPictures (Platform::Object^parameter)
bool | CanProcessImage (Object^parameter)
bool | CanProcessImage (Object^parameter)
bool | CanProcessImage (Platform::Object^parameter)
void | CartoonizeImage (Platform::Object^parameter)
void | CartoonizeImage (Platform::Object^parameter)
void | CartoonizeImage (Platform::Object^parameter)
void | CartoonizeImage (Platform::Object^parameter)
concurrency::task< void > | CartoonizeImageAmpAsync (concurrency::cancellation_token token)
concurrency::task< void > | CartoonizeImagePPLAsync (concurrency::cancellation_token token)
CartoonizeImageView ()
void | ChangeInProgress (bool value)
void | ChangeInProgress (bool value)
void | ChangeInProgress (bool value)
void | CheckForCancellation ()
unsigned int | CheckRotationAngle (unsigned int angle)
void | ClearCachedData ()
virtual void | ClearImageData ()
virtual Object | Convert (Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Object^parameter, Platform::String^language)
virtual Object | Convert (Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Object^parameter, Platform::String^language)
virtual Object | ConvertBack (Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Object^parameter, Platform::String^language)
virtual Object | ConvertBack (Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Object^parameter, Platform::String^language)
void | CopyAmpPixelArrayToPixelData (byte *destPixels, AmpPixel *newPixels, unsigned int width, unsigned int height)
AmpPixel * | CopyPixelDataToAmpPixelArray (byte *sourcePixels, unsigned int width, unsigned int height, const unsigned int size)
void | CopyPixelDataToPlatformArray (Windows::Storage::Streams::IBuffer^buffer, Platform::Array< unsigned char, 1 >^pixels, unsigned int width, unsigned int height)
void | CropImage (Platform::Object^parameter)
void | CropImage (Platform::Object^parameter)
void | CropImage (Platform::Object^parameter)
concurrency::task< void > | CropImageAsync (float64 actualWidth)
CropImageView ()
DelegateCommand (ExecuteDelegate^execute, CanExecuteDelegate^canExecute)
DesignTimeData ()
DesignTimeMonthBlock (bool hasPhotos)
DesignTimePhotoGroup (Platform::String^title)
DesignTimeYearGroup (Platform::String^title)
void | DoCrop (uint32_t xOffset, uint32_t yOffset, uint32_t newHeight, uint32_t newWidth, uint32_t oldWidth, byte *pSrcPixels, byte *pDestPixels)
concurrency::task
< Windows::Storage::Streams::IRandomAccessStream^> 		EncodeImageAsync (Windows::Storage::Streams::IRandomAccessStream^sourceStream)
concurrency::task
< Windows::Storage::Streams::IRandomAccessStream^> 		EncodeImageAsync (Windows::Storage::Streams::IRandomAccessStream^sourceStream)
concurrency::task
< Windows::Storage::Streams::IRandomAccessStream^> 		EncodeRotateImageToStream (ImageEncodingInformation decoderInfo, float64 rotationAngle, concurrency::task_continuation_context backgroundContext)
void | EndRotation ()
void | EvaluateCommands ()
virtual void | Execute (Platform::Object^parameter)
FileSizeConverter ()
FileSizeConverter (IResourceLoader^loader)
void | FinishMonthAndYearQueries ()
concurrency::task
< ImageEncodingInformation > 		GetDecoderInfo (Windows::Storage::Streams::IRandomAccessStream^source, concurrency::task_continuation_context backgroundContext)
concurrency::task< IPhoto^> | GetImagePhotoAsync ()
concurrency::task< IPhoto^> | GetImagePhotoAsync ()
concurrency::task< IPhoto^> | GetImagePhotoAsync ()
IPhoto | GetPhotoForYearAndMonth (unsigned int year, unsigned int month)
Windows::Foundation::DateTime | GetStateFileDate ()
Platform::String | GetStateFilePath ()
Platform::String | GetStateQuery ()
virtual Platform::String | GetString (Platform::String^value)
ImageBrowserView ()
ImageView ()
void | Initialize (Platform::String^photoPath)
void | Initialize (Platform::String^filePath, Windows::Foundation::DateTime fileDate, Platform::String^query)
void | Initialize (Platform::String^photoPath)
void | Initialize (Platform::String^photoPath)
bool | IsCartoonizing (Platform::Object^parameter)
virtual void | LoadState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) override
virtual void | LoadState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) override
virtual void | LoadState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) override
internal std::function< void()> | m_callback (callback)
MainHubView ()
void | NavigateToGroup (Platform::Object^parameter)
void | NavigateToPictures (Platform::Object^parameter)
void | ObserveFileChange ()
void | ObserveFileChange ()
void | OnDataChanged ()
void | OnDataChanged ()
void | OnDataChanged ()
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | OnPictureGroupPropertyChanged (Platform::Object^sender, Windows::UI::Xaml::Data::PropertyChangedEventArgs^e)
void | OnPropertyChanged (Platform::String^propertyName)
void | OnPropertyChanged (Platform::String^propertyName)
void | OnPropertyChanged (Platform::String^propertyName)
void | OnPropertyChanged (Platform::String^propertyName)
concurrency::task< void > | QueryPhotoCount ()
concurrency::task< void > | QueryPhotosAsync ()
concurrency::task< void > | QueryPhotosAsync ()
concurrency::task
< Windows::Foundation::DateTime > 		QueryPhotosAsync ()
concurrency::task< void > | QuerySinglePhotoAsync ()
void | Rotate90 (Platform::Object^parameter)
void | RotateImage (Platform::Object^parameter)
void | RotateImage (Platform::Object^parameter)
void | RotateImage (Platform::Object^parameter)
RotateImageView ()
concurrency::task
< Windows::Storage::Streams::IRandomAccessStream^> 		RotateImageViewModel::RotateImageAsync (Windows::Storage::Streams::IRandomAccessStream^sourceStream, float64 angle)
concurrency::task
< Windows::Graphics::Imaging::BitmapEncoder^> 		RotateImageViewModel::SetEncodingRotation (Windows::Graphics::Imaging::BitmapEncoder^encoder, std::shared_ptr< ImageEncodingInformation > decoderInfo, float64 rotationAngle, concurrency::task_continuation_context backgroundContext)
void | SaveImage (Platform::Object^parameter)
void | SaveImage (Platform::Object^parameter)
void | SaveImage (Platform::Object^parameter)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) override
bool | ScaleImageDimensions (unsigned int origWidth, unsigned int origHeight)
void | StartMonthAndYearQueries ()
void | StartMonthQuery (int queryId, concurrency::cancellation_token token)
void | StartYearQuery (int queryId, concurrency::cancellation_token token)
void | Unsnap (Platform::Object^parameter)
void | Unsnap (Platform::Object^parameter)
void | Unsnap (Platform::Object^parameter)
void | UpdateCropOverlayPostion (Windows::UI::Xaml::Controls::Primitives::Thumb^thumb, float64 verticalChange, float64 horizontalChange, float64 minWidth, float64 minHeight)
ViewModelLocator ()

Public Attributes

internal | __pad0__: std::shared_ptr<Repository> GetRepository() { return m_repository
internal std::function< void()> | callback: m_query(query)
virtual event
Windows::Foundation::EventHandler
< Platform::Object^> 		CanExecuteChanged
internal Platform::String | emptyTitle
internal IPhotoGroup
std::shared_ptr
< ExceptionPolicy > 		exceptionPolicy
internal std::shared_ptr
< ExceptionPolicy > 		exceptionPolicy
internal int
Windows::Storage::Search::IStorageFolderQueryOperations
std::shared_ptr< Repository >
std::shared_ptr
< ExceptionPolicy > 		exceptionPolicy
internal Platform::String
std::shared_ptr< Repository >
std::shared_ptr
< ExceptionPolicy > 		exceptionPolicy
internal
Windows::Storage::Search::IStorageFolderQueryOperations
std::shared_ptr< Repository >
std::shared_ptr
< ExceptionPolicy > 		exceptionPolicy
internal int
Windows::Storage::Search::IStorageFolderQueryOperations 		folderQuery
internal
Windows::Storage::Search::IStorageFolderQueryOperations 		folderQuery
internal int | month
internal IPhotoGroup | photoGroup
virtual event
Windows::UI::Xaml::Data::PropertyChangedEventHandler 		PropertyChanged
internal Platform::String
std::shared_ptr< Repository > 		repository
internal
Windows::Storage::Search::IStorageFolderQueryOperations
std::shared_ptr< Repository > 		repository
internal int
Windows::Storage::Search::IStorageFolderQueryOperations
std::shared_ptr< Repository > 		repository

Protected Member Functions

virtual void | OnManipulationCompleted (Windows::UI::Xaml::Input::ManipulationCompletedRoutedEventArgs^e) override
virtual void | OnManipulationDelta (Windows::UI::Xaml::Input::ManipulationDeltaRoutedEventArgs^e) override
virtual void | PrepareContainerForItemOverride (Windows::UI::Xaml::DependencyObject^element, Platform::Object^item) override

Properties

internal | __pad1__: concurrency::task<void> QueryPhotoImageAsync()
float64 | m_actualHeight
float64 | m_actualWidth
float64 | m_bottom
Windows::UI::Xaml::Input::ICommand | m_cancelCommand
concurrency::cancellation_token_source | m_cancellationTokenSource
Windows::UI::Xaml::Input::ICommand | m_cartoonizeCommand
Windows::UI::Xaml::Input::ICommand | m_cartoonizeImageCommand
bool | m_checkedForHardwareAcceleration
unsigned int | m_count
size_t | m_count
Windows::UI::Xaml::Input::ICommand | m_cropImageCommand
float64 | m_cropOverlayHeight
float64 | m_cropOverlayLeft
float64 | m_cropOverlayTop
float64 | m_cropOverlayWidth
unsigned int | m_cropX
unsigned int | m_cropY
concurrency::cancellation_token_source | m_cts
Mode | m_currentMode
int | m_currentQueryId
Windows::Foundation::DateTime | m_dateTimeForTitle
Platform::String | m_emptyTitle
Windows::Foundation::DateTime | m_fileDate
Platform::String | m_filePath
Windows::Storage::Search::IStorageFolderQueryOperations | m_folderQuery
bool | m_getPhotoAsyncIsRunning
Windows::UI::Xaml::Input::ICommand | m_groupCommand
bool | m_hasCount
bool | m_hasFileUpdateTask
Windows::UI::Xaml::Media::Imaging::WriteableBitmap | m_image
Windows::UI::Xaml::Thickness | m_imageMargin
concurrency::task< void > | m_initializationTask
bool | m_inProgress
bool | m_isAmpPixelArrayPopulated
bool | m_isCropOverlayVisible
bool | m_isSaving
bool | m_isSourcePixelsPopulated
ULONGLONG | m_lastFileChangeTime
float64 | m_left
int | m_month
Platform::Collections::Vector
< IPhotoGroup^> 		m_monthGroups
Platform::Collections::Vector
< IMonthBlock^> 		m_months
Platform::Collections::Vector
< DesignTimeMonthBlock^> 		m_months
Platform::String | m_name
Windows::UI::Xaml::Input::ICommand | m_navigateToPicturesCommand
float64 | m_neighborWindow
float64 | m_phases
IPhoto m_photo
std::shared_ptr< PhotoCache > | m_photoCache
concurrency::cancellation_token_source | m_photoCts
Platform::String | m_photoPath
Platform::Collections::Vector
< IPhoto^> 		m_photos
Platform::Collections::Vector
< IPhoto^, PhotoPathComparer > 		m_photos
concurrency::cancellation_token_source | m_photosCts
HubPhotoGroup | m_pictureGroup
Windows::Foundation::EventRegistrationToken | m_pictureGroupPropertyChangedToken
AmpPixel * m_pOriginalPixels
byte * | m_pSourcePixels
Platform::String | m_query
bool | m_receivedChangeWhileRunning
Windows::UI::Xaml::Input::ICommand | m_resumeCartoonizeCommand
Windows::UI::Xaml::Input::ICommand | m_resumeCropCommand
Windows::UI::Xaml::Input::ICommand | m_resumeRotateCommand
bool | m_retrievedPhotos
float64 | m_right
Windows::UI::Xaml::Input::ICommand | m_rotateCommand
Windows::UI::Xaml::Input::ICommand | m_rotateImageCommand
float64 | m_rotationAngle
int | m_rowSpan
bool | m_runningMonthQuery
bool | m_runningOperation
bool | m_runningQuery
bool | m_runningQueryPhotosAsync
bool | m_runningQuerySinglePhotoAsync
bool | m_runningYearQuery
bool | m_runOperation
Windows::UI::Xaml::Input::ICommand | m_saveCommand
unsigned int | m_scaledHeight
unsigned int | m_scaledWidth
float64 | m_top
bool | m_useHardwareAcceleration
std::weak_ptr< PhotoCache > | m_weakPhotoCache
int | m_year
Windows::Foundation::DateTime | m_yearDate
Platform::Collections::Vector
< IYearGroup^> 		m_yearGroups

Private Member Functions

void | App::OnResume (Object^sender, Platform::Object^e)
void | OnCropRectangleTapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | OnFileQueryContentsChanged (Windows::Storage::Search::IStorageQueryResultBase^sender, Platform::Object^e)
void | OnFilmStripLoaded (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnImageFailedToOpen (Platform::Object^sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^e)
void | OnImagePointerMoved (Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^e)
void | OnImagePointerPressed (Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^e)
void | OnImagePointerReleased (Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^e)
void | OnPhotoItemClicked (Platform::Object^sender, Windows::UI::Xaml::Controls::ItemClickEventArgs^e)
void | OnPhotoItemClicked (Platform::Object^sender, Windows::UI::Xaml::Controls::ItemClickEventArgs^e)
void | OnPropertyChanged (Platform::String^propertyName)
void | OnSizeChanged (Platform::Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^e)
void | OnThumbDragDelta (Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::DragDeltaEventArgs^e)
void | OnThumbnailUpdated (Windows::Storage::BulkAccess::IStorageItemInformation^sender, Platform::Object^e)
void | OnViewChangeCompleted (Platform::Object^sender, Windows::UI::Xaml::Controls::SemanticZoomViewChangedEventArgs^e)
void | OnZoomedOutGridPointerEntered (Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^e)
void | PhotoSizeChanged (Platform::Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
float64 | ToTwoDecimalPlaces (float64 value)

Private Attributes

std::function< void()> | m_callback
bool | m_canExecute
CanExecuteDelegate | m_canExecuteDelegate
int | m_columnSpan
CropImageViewModel | m_cropImageViewModel
std::shared_ptr< ExceptionPolicy > | m_exceptionPolicy
ExecuteDelegate | m_executeDelegate
Windows::Storage::BulkAccess::FileInformation | m_fileInfo
Windows::Foundation::EventRegistrationToken | m_filmStripLoadedToken
Windows::UI::Xaml::Media::Imaging::BitmapImage | m_image
Windows::Foundation::EventRegistrationToken | m_imageFailedEventToken
bool | m_isInvalidThumbnail
IResourceLoader m_loader
Windows::Foundation::Point | m_pointer
bool | m_pointerPressed
Windows::Storage::Search::IStorageQueryResultBase | m_query
bool | m_queryPhotoImageAsyncIsRunning
std::shared_ptr< Repository > | m_repository
bool | m_sizeChangedAttached
Windows::Foundation::EventRegistrationToken | m_thumbnailUpdatedEventToken
std::shared_ptr
< TileUpdateScheduler > 		m_tileUpdateScheduler
RotateImageViewModel | m_viewModel
Windows::Foundation::EventRegistrationToken | m_watchToken
Platform::WeakReference | m_weakPhotoGroup

Detailed Description

Definition at line 30 of file App.xaml.h.

Constructor & Destructor Documentation

virtual Hilo::sealed::~CartoonizeImageViewModel ( ) [virtual]
virtual Hilo::sealed::~HubPhotoGroup ( ) [virtual]
virtual Hilo::sealed::~ImageBrowserViewModel ( ) [virtual]
virtual Hilo::sealed::~ImageView ( ) [virtual]
virtual Hilo::sealed::~ImageViewModel ( ) [virtual]
virtual Hilo::sealed::~MainHubViewModel ( ) [virtual]
virtual Hilo::sealed::~Photo ( ) [virtual]
virtual Hilo::sealed::~QueryChange ( ) [inline, virtual]

Definition at line 22 of file QueryChange.h.

        {
            m_query->ContentsChanged::remove(m_watchToken);
        }

Member Function Documentation

Hilo::sealed::App ( )
void Hilo::sealed::App::OnResume | ( | Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
Platform::String Hilo::sealed::BuildDateQuery ( )
void Hilo::sealed::CalculateInitialCropOverlayPosition | ( | Windows::UI::Xaml::Media::GeneralTransform^ | transform,
 |  | float | width,
 |  | float | height
 | ) |  |
void Hilo::sealed::CancelCartoonize ( Platform::Object^ parameter )
void Hilo::sealed::CancelCrop ( Platform::Object^ parameter )
void Hilo::sealed::CancelMonthAndYearQueries ( )
void Hilo::sealed::CancelRotate ( Platform::Object^ parameter )
virtual bool Hilo::sealed::CanExecute ( Platform::Object^ parameter ) [virtual]
bool Hilo::sealed::CanNavigateToPictures ( Platform::Object^ parameter )
bool Hilo::sealed::CanProcessImage ( Object^ parameter )
bool Hilo::sealed::CanProcessImage ( Object^ parameter )
bool Hilo::sealed::CanProcessImage ( Platform::Object^ parameter )
void Hilo::sealed::CartoonizeImage ( Platform::Object^ parameter )
void Hilo::sealed::CartoonizeImage ( Platform::Object^ parameter )
void Hilo::sealed::CartoonizeImage ( Platform::Object^ parameter )
void Hilo::sealed::CartoonizeImage ( Platform::Object^ parameter )
concurrency::task<void> Hilo::sealed::CartoonizeImageAmpAsync ( concurrency::cancellation_token token )
concurrency::task<void> Hilo::sealed::CartoonizeImagePPLAsync ( concurrency::cancellation_token token )
Hilo::sealed::CartoonizeImageView ( )
void Hilo::sealed::ChangeInProgress ( bool value )
void Hilo::sealed::ChangeInProgress ( bool value )
void Hilo::sealed::ChangeInProgress ( bool value )
void Hilo::sealed::CheckForCancellation ( )
unsigned int Hilo::sealed::CheckRotationAngle ( unsigned int angle )
void Hilo::sealed::ClearCachedData ( )
virtual void Hilo::sealed::ClearImageData ( ) [virtual]
virtual Object Hilo::sealed::Convert | ( | Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [virtual]
virtual Object Hilo::sealed::Convert | ( | Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [virtual]
virtual Object Hilo::sealed::ConvertBack | ( | Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [virtual]
virtual Object Hilo::sealed::ConvertBack | ( | Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [virtual]
void Hilo::sealed::CopyAmpPixelArrayToPixelData | ( | byte * | destPixels,
 |  | AmpPixel * | newPixels,
 |  | unsigned int | width,
 |  | unsigned int | height
 | ) |  |
AmpPixel* Hilo::sealed::CopyPixelDataToAmpPixelArray | ( | byte * | sourcePixels,
 |  | unsigned int | width,
 |  | unsigned int | height,
 |  | const unsigned int | size
 | ) |  |
void Hilo::sealed::CopyPixelDataToPlatformArray | ( | Windows::Storage::Streams::IBuffer^ | buffer,
 |  | Platform::Array< unsigned char, 1 >^ | pixels,
 |  | unsigned int | width,
 |  | unsigned int | height
 | ) |  |
void Hilo::sealed::CropImage ( Platform::Object^ parameter )
void Hilo::sealed::CropImage ( Platform::Object^ parameter )
void Hilo::sealed::CropImage ( Platform::Object^ parameter )
concurrency::task<void> Hilo::sealed::CropImageAsync ( float64 actualWidth )
Hilo::sealed::CropImageView ( )
Hilo::sealed::DelegateCommand | ( | ExecuteDelegate^ | execute,
 |  | CanExecuteDelegate^ | canExecute
 | ) |  |
Hilo::sealed::DesignTimeData ( )
Hilo::sealed::DesignTimeMonthBlock ( bool hasPhotos )
Hilo::sealed::DesignTimePhotoGroup ( Platform::String^ title )
Hilo::sealed::DesignTimeYearGroup ( Platform::String^ title )
void Hilo::sealed::DoCrop | ( | uint32_t | xOffset,
 |  | uint32_t | yOffset,
 |  | uint32_t | newHeight,
 |  | uint32_t | newWidth,
 |  | uint32_t | oldWidth,
 |  | byte * | pSrcPixels,
 |  | byte * | pDestPixels
 | ) |  |
concurrency::task<Windows::Storage::Streams::IRandomAccessStream^> Hilo::sealed::EncodeImageAsync ( Windows::Storage::Streams::IRandomAccessStream^ sourceStream )
concurrency::task<Windows::Storage::Streams::IRandomAccessStream^> Hilo::sealed::EncodeImageAsync ( Windows::Storage::Streams::IRandomAccessStream^ sourceStream )
concurrency::task<Windows::Storage::Streams::IRandomAccessStream^> Hilo::sealed::EncodeRotateImageToStream | ( | ImageEncodingInformation | decoderInfo,
 |  | float64 | rotationAngle,
 |  | concurrency::task_continuation_context | backgroundContext
 | ) |  |
void Hilo::sealed::EndRotation ( )
void Hilo::sealed::EvaluateCommands ( )
virtual void Hilo::sealed::Execute ( Platform::Object^ parameter ) [virtual]
Hilo::sealed::FileSizeConverter ( )
Hilo::sealed::FileSizeConverter ( IResourceLoader^ loader )
void Hilo::sealed::FinishMonthAndYearQueries ( )
concurrency::task<ImageEncodingInformation> Hilo::sealed::GetDecoderInfo | ( | Windows::Storage::Streams::IRandomAccessStream^ | source,
 |  | concurrency::task_continuation_context | backgroundContext
 | ) |  |
concurrency::task<IPhoto^> Hilo::sealed::GetImagePhotoAsync ( )
concurrency::task<IPhoto^> Hilo::sealed::GetImagePhotoAsync ( )
concurrency::task<IPhoto^> Hilo::sealed::GetImagePhotoAsync ( )
IPhoto Hilo::sealed::GetPhotoForYearAndMonth | ( | unsigned int | year,
 |  | unsigned int | month
 | ) |  |
Windows::Foundation::DateTime Hilo::sealed::GetStateFileDate ( )
Platform::String Hilo::sealed::GetStateFilePath ( )
Platform::String Hilo::sealed::GetStateQuery ( )
virtual Platform::String Hilo::sealed::GetString ( Platform::String^ value ) [virtual]
Hilo::sealed::ImageBrowserView ( )
Hilo::sealed::ImageView ( )
void Hilo::sealed::Initialize ( Platform::String^ photoPath )
void Hilo::sealed::Initialize ( Platform::String^ photoPath )
void Hilo::sealed::Initialize ( Platform::String^ photoPath )
void Hilo::sealed::Initialize | ( | Platform::String^ | filePath,
 |  | Windows::Foundation::DateTime | fileDate,
 |  | Platform::String^ | query
 | ) |  |
bool Hilo::sealed::IsCartoonizing ( Platform::Object^ parameter )
virtual void Hilo::sealed::LoadState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ stateMap ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::LoadState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ stateMap ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::LoadState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ stateMap ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

internal std::function<void()> Hilo::sealed::m_callback ( callback ) [inline]

Definition at line 16 of file QueryChange.h.

                                                                                : m_query(query), m_callback(callback)
        {
            m_watchToken = m_query->ContentsChanged::add(ref new Windows::Foundation::TypedEventHandler<Windows::Storage::Search::IStorageQueryResultBase^, Object^>(this, &QueryChange::OnFileQueryContentsChanged));
        }

Hilo::sealed::MainHubView ( )
void Hilo::sealed::NavigateToGroup ( Platform::Object^ parameter )
void Hilo::sealed::NavigateToPictures ( Platform::Object^ parameter )
void Hilo::sealed::ObserveFileChange ( )
void Hilo::sealed::ObserveFileChange ( )
void Hilo::sealed::OnCropRectangleTapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnDataChanged ( )
void Hilo::sealed::OnDataChanged ( )
void Hilo::sealed::OnDataChanged ( )
void Hilo::sealed::OnFileQueryContentsChanged | ( | Windows::Storage::Search::IStorageQueryResultBase^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [inline, private]

Definition at line 32 of file QueryChange.h.

        {
            // Since OnFileQueryContentsChanged may be called on any thread, we must dispatch the callback to the app's main thread,
            // on the assumption that the callback will modify XAML structures.
            Windows::UI::Core::CoreWindow^ wnd = Windows::ApplicationModel::Core::CoreApplication::MainView->CoreWindow;
            Windows::UI::Core::CoreDispatcher^ dispatcher = wnd->Dispatcher;
            dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([this] ()
            {
                m_callback();
            }));
        }

void Hilo::sealed::OnFilmStripLoaded | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnImageFailedToOpen | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::ExceptionRoutedEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnImagePointerMoved | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnImagePointerPressed | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnImagePointerReleased | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void Hilo::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
virtual void Hilo::sealed::OnManipulationCompleted ( Windows::UI::Xaml::Input::ManipulationCompletedRoutedEventArgs^ e ) [override, protected, virtual]
virtual void Hilo::sealed::OnManipulationDelta ( Windows::UI::Xaml::Input::ManipulationDeltaRoutedEventArgs^ e ) [override, protected, virtual]
virtual void Hilo::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

void Hilo::sealed::OnPhotoItemClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::ItemClickEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnPhotoItemClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::ItemClickEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnPictureGroupPropertyChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Data::PropertyChangedEventArgs^ | e
 | ) |  |
void Hilo::sealed::OnPropertyChanged ( Platform::String^ propertyName )
void Hilo::sealed::OnPropertyChanged ( Platform::String^ propertyName ) [private]
void Hilo::sealed::OnPropertyChanged ( Platform::String^ propertyName )
void Hilo::sealed::OnPropertyChanged ( Platform::String^ propertyName )
void Hilo::sealed::OnPropertyChanged ( Platform::String^ propertyName )
void Hilo::sealed::OnSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnThumbDragDelta | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::DragDeltaEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnThumbnailUpdated | ( | Windows::Storage::BulkAccess::IStorageItemInformation^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnViewChangeCompleted | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SemanticZoomViewChangedEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::OnZoomedOutGridPointerEntered | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | e |
 | ) |  |  | [private]
void Hilo::sealed::PhotoSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
virtual void Hilo::sealed::PrepareContainerForItemOverride | ( | Windows::UI::Xaml::DependencyObject^ | element,
 |  | Platform::Object^ | item |
 | ) |  |  | [override, protected, virtual]
concurrency::task<void> Hilo::sealed::QueryPhotoCount ( )
concurrency::task<Windows::Foundation::DateTime> Hilo::sealed::QueryPhotosAsync ( )
concurrency::task<void> Hilo::sealed::QueryPhotosAsync ( )
concurrency::task<void> Hilo::sealed::QueryPhotosAsync ( )
concurrency::task<void> Hilo::sealed::QuerySinglePhotoAsync ( )
void Hilo::sealed::Rotate90 ( Platform::Object^ parameter )
void Hilo::sealed::RotateImage ( Platform::Object^ parameter )
void Hilo::sealed::RotateImage ( Platform::Object^ parameter )
void Hilo::sealed::RotateImage ( Platform::Object^ parameter )
Hilo::sealed::RotateImageView ( )
concurrency::task<Windows::Storage::Streams::IRandomAccessStream^> Hilo::sealed::RotateImageViewModel::RotateImageAsync | ( | Windows::Storage::Streams::IRandomAccessStream^ | sourceStream,
 |  | float64 | angle
 | ) |  |
concurrency::task<Windows::Graphics::Imaging::BitmapEncoder^> Hilo::sealed::RotateImageViewModel::SetEncodingRotation | ( | Windows::Graphics::Imaging::BitmapEncoder^ | encoder,
 |  | std::shared_ptr< ImageEncodingInformation > | decoderInfo,
 |  | float64 | rotationAngle,
 |  | concurrency::task_continuation_context | backgroundContext
 | ) |  |
void Hilo::sealed::SaveImage ( Platform::Object^ parameter )
void Hilo::sealed::SaveImage ( Platform::Object^ parameter )
void Hilo::sealed::SaveImage ( Platform::Object^ parameter )
virtual void Hilo::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ stateMap ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ stateMap ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

virtual void Hilo::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ stateMap ) [override, virtual]

Reimplemented from Hilo::ViewModelBase.

bool Hilo::sealed::ScaleImageDimensions | ( | unsigned int | origWidth,
 |  | unsigned int | origHeight
 | ) |  |
void Hilo::sealed::StartMonthAndYearQueries ( )
void Hilo::sealed::StartMonthQuery | ( | int | queryId,
 |  | concurrency::cancellation_token | token
 | ) |  |
void Hilo::sealed::StartYearQuery | ( | int | queryId,
 |  | concurrency::cancellation_token | token
 | ) |  |
float64 Hilo::sealed::ToTwoDecimalPlaces ( float64 value ) [private]
void Hilo::sealed::Unsnap ( Platform::Object^ parameter )
void Hilo::sealed::Unsnap ( Platform::Object^ parameter )
void Hilo::sealed::Unsnap ( Platform::Object^ parameter )
void Hilo::sealed::UpdateCropOverlayPostion | ( | Windows::UI::Xaml::Controls::Primitives::Thumb^ | thumb,
 |  | float64 | verticalChange,
 |  | float64 | horizontalChange,
 |  | float64 | minWidth,
 |  | float64 | minHeight
 | ) |  |
Hilo::sealed::ViewModelLocator ( )

Member Data Documentation

internal sealed::__pad0__

Reimplemented from Hilo::ImageBase.

Definition at line 37 of file App.xaml.h.

internal std::function<void()> Hilo::sealed::callback

Definition at line 16 of file QueryChange.h.

virtual event Windows::Foundation::EventHandler<Platform::Object^> Hilo::sealed::CanExecuteChanged

Definition at line 21 of file DelegateCommand.h.

internal Platform::String Hilo::sealed::emptyTitle

Definition at line 23 of file HubPhotoGroup.h.

internal Windows::Storage::Search::IStorageFolderQueryOperations std::shared_ptr< Repository > std::shared_ptr< ExceptionPolicy > sealed::exceptionPolicy

Definition at line 28 of file CartoonizeImageViewModel.h.

internal int Windows::Storage::Search::IStorageFolderQueryOperations std::shared_ptr<Repository> std::shared_ptr<ExceptionPolicy> Hilo::sealed::exceptionPolicy

Definition at line 26 of file MonthBlock.h.

internal Windows::Storage::Search::IStorageFolderQueryOperations std::shared_ptr<Repository> std::shared_ptr<ExceptionPolicy> Hilo::sealed::exceptionPolicy

Definition at line 24 of file MonthGroup.h.

internal Platform::String std::shared_ptr<Repository> std::shared_ptr<ExceptionPolicy> Hilo::sealed::exceptionPolicy

Definition at line 23 of file HubPhotoGroup.h.

internal IPhotoGroup std::shared_ptr<ExceptionPolicy> Hilo::sealed::exceptionPolicy

Definition at line 23 of file Photo.h.

internal Windows::Storage::Search::IStorageFolderQueryOperations sealed::folderQuery

Definition at line 26 of file MonthBlock.h.

internal Windows::Storage::Search::IStorageFolderQueryOperations Hilo::sealed::folderQuery

Definition at line 24 of file MonthGroup.h.

std::function<void()> Hilo::sealed::m_callback [private]

Definition at line 29 of file QueryChange.h.

bool Hilo::sealed::m_canExecute [private]

Definition at line 30 of file DelegateCommand.h.

CanExecuteDelegate Hilo::sealed::m_canExecuteDelegate [private]

Definition at line 29 of file DelegateCommand.h.

int Hilo::sealed::m_columnSpan [private]

Definition at line 125 of file Photo.h.

CropImageViewModel Hilo::sealed::m_cropImageViewModel [private]

Definition at line 30 of file CropImageView.xaml.h.

std::shared_ptr< ExceptionPolicy > sealed::m_exceptionPolicy [private]

Reimplemented from Hilo::ViewModelBase.

Definition at line 42 of file App.xaml.h.

ExecuteDelegate Hilo::sealed::m_executeDelegate [private]

Definition at line 28 of file DelegateCommand.h.

Windows::Storage::BulkAccess::FileInformation Hilo::sealed::m_fileInfo [private]

Definition at line 119 of file Photo.h.

Windows::Foundation::EventRegistrationToken Hilo::sealed::m_filmStripLoadedToken [private]

Definition at line 33 of file ImageView.xaml.h.

Windows::UI::Xaml::Media::Imaging::BitmapImage Hilo::sealed::m_image [private]

Definition at line 121 of file Photo.h.

Windows::Foundation::EventRegistrationToken Hilo::sealed::m_imageFailedEventToken [private]

Definition at line 124 of file Photo.h.

bool Hilo::sealed::m_isInvalidThumbnail [private]

Definition at line 128 of file Photo.h.

IResourceLoader Hilo::sealed::m_loader [private]

Definition at line 28 of file FileSizeConverter.h.

Windows::Foundation::Point Hilo::sealed::m_pointer [private]

Definition at line 35 of file ImageView.xaml.h.

bool Hilo::sealed::m_pointerPressed [private]

Definition at line 34 of file ImageView.xaml.h.

Windows::Storage::Search::IStorageQueryResultBase Hilo::sealed::m_query [private]

Definition at line 28 of file QueryChange.h.

bool Hilo::sealed::m_queryPhotoImageAsyncIsRunning [private]

Definition at line 127 of file Photo.h.

std::shared_ptr< Repository > sealed::m_repository [private]

Definition at line 44 of file App.xaml.h.

bool Hilo::sealed::m_sizeChangedAttached [private]

Definition at line 31 of file CropImageView.xaml.h.

Windows::Foundation::EventRegistrationToken Hilo::sealed::m_thumbnailUpdatedEventToken [private]

Definition at line 123 of file Photo.h.

std::shared_ptr<TileUpdateScheduler> Hilo::sealed::m_tileUpdateScheduler [private]

Definition at line 43 of file App.xaml.h.

RotateImageViewModel Hilo::sealed::m_viewModel [private]

Definition at line 33 of file RotateImageView.xaml.h.

Windows::Foundation::EventRegistrationToken Hilo::sealed::m_watchToken [private]

Definition at line 30 of file QueryChange.h.

Platform::WeakReference Hilo::sealed::m_weakPhotoGroup [private]

Definition at line 120 of file Photo.h.

internal int Hilo::sealed::month

Definition at line 26 of file MonthBlock.h.

internal IPhotoGroup Hilo::sealed::photoGroup

Definition at line 23 of file Photo.h.

event Windows::UI::Xaml::Data::PropertyChangedEventHandler sealed::PropertyChanged

Reimplemented from Hilo::Common::BindableBase.

Definition at line 29 of file HubPhotoGroup.h.

internal Windows::Storage::Search::IStorageFolderQueryOperations std::shared_ptr< Repository > sealed::repository

Definition at line 23 of file HubPhotoGroup.h.

internal Windows::Storage::Search::IStorageFolderQueryOperations std::shared_ptr<Repository> Hilo::sealed::repository

Definition at line 24 of file MonthGroup.h.

internal int Windows::Storage::Search::IStorageFolderQueryOperations std::shared_ptr<Repository> Hilo::sealed::repository

Definition at line 26 of file MonthBlock.h.

Property Documentation

internal Hilo::sealed::__pad1__

Definition at line 116 of file Photo.h.

float64 Hilo::sealed::m_actualHeight

Definition at line 84 of file CropImageViewModel.h.

float64 Hilo::sealed::m_actualWidth

Definition at line 85 of file CropImageViewModel.h.

float64 Hilo::sealed::m_bottom

Definition at line 78 of file CropImageViewModel.h.

Windows::UI::Xaml::Input::ICommand sealed::m_cancelCommand

Definition at line 90 of file CartoonizeImageViewModel.h.

concurrency::cancellation_token_source Hilo::sealed::m_cancellationTokenSource

Definition at line 107 of file ImageBrowserViewModel.h.

Windows::UI::Xaml::Input::ICommand Hilo::sealed::m_cartoonizeCommand

Definition at line 87 of file CartoonizeImageViewModel.h.

Windows::UI::Xaml::Input::ICommand sealed::m_cartoonizeImageCommand

Definition at line 98 of file ImageBrowserViewModel.h.

bool Hilo::sealed::m_checkedForHardwareAcceleration

Definition at line 77 of file CartoonizeImageViewModel.h.

unsigned int Hilo::sealed::m_count

Definition at line 59 of file MonthBlock.h.

size_t Hilo::sealed::m_count

Definition at line 58 of file MonthGroup.h.

Windows::UI::Xaml::Input::ICommand sealed::m_cropImageCommand

Definition at line 96 of file ImageBrowserViewModel.h.

float64 Hilo::sealed::m_cropOverlayHeight

Definition at line 82 of file CropImageViewModel.h.

float64 Hilo::sealed::m_cropOverlayLeft

Definition at line 80 of file CropImageViewModel.h.

float64 Hilo::sealed::m_cropOverlayTop

Definition at line 81 of file CropImageViewModel.h.

float64 Hilo::sealed::m_cropOverlayWidth

Definition at line 83 of file CropImageViewModel.h.

unsigned int Hilo::sealed::m_cropX

Definition at line 87 of file CropImageViewModel.h.

unsigned int Hilo::sealed::m_cropY

Definition at line 88 of file CropImageViewModel.h.

concurrency::cancellation_token_source Hilo::sealed::m_cts

Definition at line 79 of file CartoonizeImageViewModel.h.

Mode Hilo::sealed::m_currentMode

Definition at line 103 of file ImageBrowserViewModel.h.

int Hilo::sealed::m_currentQueryId

Definition at line 102 of file ImageBrowserViewModel.h.

Windows::Foundation::DateTime Hilo::sealed::m_dateTimeForTitle

Definition at line 51 of file MonthGroup.h.

Platform::String Hilo::sealed::m_emptyTitle

Definition at line 42 of file HubPhotoGroup.h.

Windows::Foundation::DateTime Hilo::sealed::m_fileDate

Definition at line 79 of file ImageViewModel.h.

Platform::String Hilo::sealed::m_filePath

Definition at line 80 of file ImageViewModel.h.

Windows::Storage::Search::IStorageFolderQueryOperations sealed::m_folderQuery

Definition at line 56 of file MonthBlock.h.

bool Hilo::sealed::m_getPhotoAsyncIsRunning

Definition at line 87 of file RotateImageViewModel.h.

Windows::UI::Xaml::Input::ICommand Hilo::sealed::m_groupCommand

Definition at line 95 of file ImageBrowserViewModel.h.

bool Hilo::sealed::m_hasCount

Definition at line 59 of file MonthGroup.h.

bool sealed::m_hasFileUpdateTask

Definition at line 50 of file HubPhotoGroup.h.

Windows::UI::Xaml::Media::Imaging::WriteableBitmap Hilo::sealed::m_image

Definition at line 65 of file CropImageViewModel.h.

Windows::UI::Xaml::Thickness Hilo::sealed::m_imageMargin

Definition at line 93 of file RotateImageViewModel.h.

concurrency::task<void> Hilo::sealed::m_initializationTask

Definition at line 69 of file CartoonizeImageViewModel.h.

bool sealed::m_inProgress

Definition at line 73 of file CartoonizeImageViewModel.h.

bool Hilo::sealed::m_isAmpPixelArrayPopulated

Definition at line 75 of file CartoonizeImageViewModel.h.

bool Hilo::sealed::m_isCropOverlayVisible

Definition at line 71 of file CropImageViewModel.h.

bool sealed::m_isSaving

Definition at line 74 of file CartoonizeImageViewModel.h.

bool Hilo::sealed::m_isSourcePixelsPopulated

Definition at line 76 of file CartoonizeImageViewModel.h.

ULONGLONG sealed::m_lastFileChangeTime

Definition at line 51 of file HubPhotoGroup.h.

float64 Hilo::sealed::m_left

Definition at line 75 of file CropImageViewModel.h.

int Hilo::sealed::m_month

Definition at line 53 of file MonthBlock.h.

Platform::Collections::Vector<IPhotoGroup^> Hilo::sealed::m_monthGroups

Definition at line 91 of file ImageBrowserViewModel.h.

Platform::Collections::Vector<IMonthBlock^> Hilo::sealed::m_months

Definition at line 49 of file YearGroup.h.

Platform::Collections::Vector<DesignTimeMonthBlock^> Hilo::sealed::m_months

Definition at line 121 of file DesignTimeData.h.

Platform::String Hilo::sealed::m_name

Definition at line 55 of file MonthBlock.h.

Windows::UI::Xaml::Input::ICommand Hilo::sealed::m_navigateToPicturesCommand

Definition at line 66 of file MainHubViewModel.h.

float64 Hilo::sealed::m_neighborWindow

Definition at line 80 of file CartoonizeImageViewModel.h.

float64 Hilo::sealed::m_phases

Definition at line 81 of file CartoonizeImageViewModel.h.

IPhoto sealed::m_photo

Reimplemented from Hilo::ImageBase.

Definition at line 109 of file ImageBrowserViewModel.h.

std::shared_ptr<PhotoCache> Hilo::sealed::m_photoCache

Definition at line 108 of file ImageBrowserViewModel.h.

concurrency::cancellation_token_source Hilo::sealed::m_photoCts

Definition at line 85 of file ImageViewModel.h.

Platform::String sealed::m_photoPath

Definition at line 72 of file CartoonizeImageViewModel.h.

Platform::Collections::Vector< IPhoto^> sealed::m_photos

Definition at line 46 of file HubPhotoGroup.h.

Platform::Collections::Vector<IPhoto^, PhotoPathComparer> Hilo::sealed::m_photos

Definition at line 83 of file ImageViewModel.h.

concurrency::cancellation_token_source Hilo::sealed::m_photosCts

Definition at line 84 of file ImageViewModel.h.

HubPhotoGroup Hilo::sealed::m_pictureGroup

Definition at line 72 of file MainHubViewModel.h.

Windows::Foundation::EventRegistrationToken Hilo::sealed::m_pictureGroupPropertyChangedToken

Definition at line 73 of file MainHubViewModel.h.

AmpPixel* Hilo::sealed::m_pOriginalPixels

Definition at line 82 of file CartoonizeImageViewModel.h.

byte* Hilo::sealed::m_pSourcePixels

Definition at line 83 of file CartoonizeImageViewModel.h.

Platform::String Hilo::sealed::m_query

Definition at line 81 of file ImageViewModel.h.

bool sealed::m_receivedChangeWhileRunning

Definition at line 48 of file HubPhotoGroup.h.

Windows::UI::Xaml::Input::ICommand Hilo::sealed::m_resumeCartoonizeCommand

Definition at line 88 of file CartoonizeImageViewModel.h.

Windows::UI::Xaml::Input::ICommand Hilo::sealed::m_resumeCropCommand

Definition at line 67 of file CropImageViewModel.h.

Windows::UI::Xaml::Input::ICommand Hilo::sealed::m_resumeRotateCommand

Definition at line 90 of file RotateImageViewModel.h.

bool Hilo::sealed::m_retrievedPhotos

Definition at line 47 of file HubPhotoGroup.h.

float64 Hilo::sealed::m_right

Definition at line 77 of file CropImageViewModel.h.

Windows::UI::Xaml::Input::ICommand Hilo::sealed::m_rotateCommand

Definition at line 89 of file RotateImageViewModel.h.

Windows::UI::Xaml::Input::ICommand sealed::m_rotateImageCommand

Definition at line 97 of file ImageBrowserViewModel.h.

float64 Hilo::sealed::m_rotationAngle

Definition at line 96 of file RotateImageViewModel.h.

int sealed::m_rowSpan

Definition at line 50 of file DesignTimeData.h.

bool Hilo::sealed::m_runningMonthQuery

Definition at line 100 of file ImageBrowserViewModel.h.

bool Hilo::sealed::m_runningOperation

Definition at line 61 of file MonthBlock.h.

bool sealed::m_runningQuery

Definition at line 49 of file HubPhotoGroup.h.

bool Hilo::sealed::m_runningQueryPhotosAsync

Definition at line 78 of file ImageViewModel.h.

bool Hilo::sealed::m_runningQuerySinglePhotoAsync

Definition at line 76 of file ImageViewModel.h.

bool Hilo::sealed::m_runningYearQuery

Definition at line 101 of file ImageBrowserViewModel.h.

bool Hilo::sealed::m_runOperation

Definition at line 60 of file MonthBlock.h.

Windows::UI::Xaml::Input::ICommand sealed::m_saveCommand

Definition at line 89 of file CartoonizeImageViewModel.h.

unsigned int Hilo::sealed::m_scaledHeight

Definition at line 85 of file CartoonizeImageViewModel.h.

unsigned int Hilo::sealed::m_scaledWidth

Definition at line 84 of file CartoonizeImageViewModel.h.

float64 Hilo::sealed::m_top

Definition at line 76 of file CropImageViewModel.h.

bool Hilo::sealed::m_useHardwareAcceleration

Definition at line 78 of file CartoonizeImageViewModel.h.

std::weak_ptr<PhotoCache> Hilo::sealed::m_weakPhotoCache

Definition at line 53 of file MonthGroup.h.

int Hilo::sealed::m_year

Definition at line 48 of file YearGroup.h.

Windows::Foundation::DateTime Hilo::sealed::m_yearDate

Definition at line 44 of file YearGroup.h.

Platform::Collections::Vector<IYearGroup^> Hilo::sealed::m_yearGroups

Definition at line 94 of file ImageBrowserViewModel.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/App.xaml.h
  • Hilo C++/C++/Hilo/CartoonizeImageViewModel.h
  • Hilo C++/C++/Hilo/CropImageView.xaml.h
  • Hilo C++/C++/Hilo/CropImageViewModel.h
  • Hilo C++/C++/Hilo/DelegateCommand.h
  • Hilo C++/C++/Hilo/DesignTimeData.h
  • Hilo C++/C++/Hilo/FileSizeConverter.h
  • Hilo C++/C++/Hilo/HubPhotoGroup.h
  • Hilo C++/C++/Hilo/ImageBrowserViewModel.h
  • Hilo C++/C++/Hilo/ImageView.xaml.h
  • Hilo C++/C++/Hilo/ImageViewModel.h
  • Hilo C++/C++/Hilo/MainHubViewModel.h
  • Hilo C++/C++/Hilo/MonthBlock.h
  • Hilo C++/C++/Hilo/MonthGroup.h
  • Hilo C++/C++/Hilo/Photo.h
  • Hilo C++/C++/Hilo/QueryChange.h
  • Hilo C++/C++/Hilo/RotateImageView.xaml.h
  • Hilo C++/C++/Hilo/RotateImageViewModel.h
  • Hilo C++/C++/Hilo/ViewModelLocator.h
  • Hilo C++/C++/Hilo/YearGroup.h
  • Hilo C++/C++/Hilo/BooleanToBrushConverter.h
  • Hilo C++/C++/Hilo/CartoonizeImageView.xaml.h
  • Hilo C++/C++/Hilo/ImageBrowserView.xaml.h
  • Hilo C++/C++/Hilo/LocalResourceLoader.h
  • Hilo C++/C++/Hilo/MainHubView.xaml.h
  • Hilo C++/C++/Hilo/VariableGridView.h
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ThumbnailGenerator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ThumbnailGenerator
Public Member Functions | Static Private Member Functions | Private Attributes

Hilo::ThumbnailGenerator Class Reference

#include "ThumbnailGenerator.h"

List of all members.

Public Member Functions

ThumbnailGenerator (std::shared_ptr< ExceptionPolicy > policy)
concurrency::task
< Platform::Collections::Vector
< Windows::Storage::StorageFile^>^> 		Generate (Windows::Foundation::Collections::IVector< Windows::Storage::StorageFile^>^files, Windows::Storage::StorageFolder^thumbnailsFolder)

Static Private Member Functions

static concurrency::task
< Windows::Storage::StorageFile^> 		CreateLocalThumbnailAsync (Windows::Storage::StorageFolder^folder, Windows::Storage::StorageFile^imageFile, Platform::String^localFileName, unsigned int thumbSize, std::shared_ptr< ExceptionPolicy > policy)
static concurrency::task
< Windows::Storage::Streams::InMemoryRandomAccessStream^> 		CreateThumbnailFromPictureFileAsync (Windows::Storage::StorageFile^sourceFile, unsigned int thumbSize)
static concurrency::task
< Windows::Storage::StorageFile^> 		InternalSaveToFile (Windows::Storage::StorageFolder^folder, Windows::Storage::Streams::InMemoryRandomAccessStream^stream, Platform::String^filename)

Private Attributes

std::shared_ptr< ExceptionPolicy > m_exceptionPolicy

Detailed Description

Definition at line 16 of file ThumbnailGenerator.h.

Constructor & Destructor Documentation

ThumbnailGenerator::ThumbnailGenerator ( std::shared_ptr< ExceptionPolicy > policy )

Definition at line 28 of file ThumbnailGenerator.cpp.

                                                                            : m_exceptionPolicy(policy)
{
}

Member Function Documentation

static concurrency::task<Windows::Storage::StorageFile^> Hilo::ThumbnailGenerator::CreateLocalThumbnailAsync | ( | Windows::Storage::StorageFolder^ | folder,
 |  | Windows::Storage::StorageFile^ | imageFile,
 |  | Platform::String^ | localFileName,
 |  | unsigned int | thumbSize,
 |  | std::shared_ptr< ExceptionPolicy > | policy |
 | ) |  |  | [static, private]
static concurrency::task<Windows::Storage::Streams::InMemoryRandomAccessStream^> Hilo::ThumbnailGenerator::CreateThumbnailFromPictureFileAsync | ( | Windows::Storage::StorageFile^ | sourceFile,
 |  | unsigned int | thumbSize |
 | ) |  |  | [static, private]
concurrency::task<Platform::Collections::Vector<Windows::Storage::StorageFile^>^> Hilo::ThumbnailGenerator::Generate | ( | Windows::Foundation::Collections::IVector< Windows::Storage::StorageFile^>^ | files,
 |  | Windows::Storage::StorageFolder^ | thumbnailsFolder
 | ) |  |
static concurrency::task<Windows::Storage::StorageFile^> Hilo::ThumbnailGenerator::InternalSaveToFile | ( | Windows::Storage::StorageFolder^ | folder,
 |  | Windows::Storage::Streams::InMemoryRandomAccessStream^ | stream,
 |  | Platform::String^ | filename |
 | ) |  |  | [static, private]

Member Data Documentation

std::shared_ptr<ExceptionPolicy> Hilo::ThumbnailGenerator::m_exceptionPolicy [private]

Definition at line 27 of file ThumbnailGenerator.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/ThumbnailGenerator.h
  • Hilo C++/C++/Hilo/ThumbnailGenerator.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::TileUpdateScheduler Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::TileUpdateScheduler
Public Member Functions | Private Member Functions

Hilo::TileUpdateScheduler Class Reference

#include "TileUpdateScheduler.h"

List of all members.

Public Member Functions

TileUpdateScheduler ()
concurrency::task< void > | TileUpdateScheduler::ScheduleUpdateAsync (std::shared_ptr< Repository > repository, std::shared_ptr< ExceptionPolicy > exceptionPolicy)

Private Member Functions

void | TileUpdateScheduler::UpdateTile (Windows::Foundation::Collections::IVector< Windows::Storage::StorageFile^>^files)

Detailed Description

Definition at line 17 of file TileUpdateScheduler.h.

Constructor & Destructor Documentation

TileUpdateScheduler::TileUpdateScheduler ( )

Definition at line 37 of file TileUpdateScheduler.cpp.

{
}

Member Function Documentation

concurrency::task<void> Hilo::TileUpdateScheduler::TileUpdateScheduler::ScheduleUpdateAsync | ( | std::shared_ptr< Repository > | repository,
 |  | std::shared_ptr< ExceptionPolicy > | exceptionPolicy
 | ) |  |
void Hilo::TileUpdateScheduler::TileUpdateScheduler::UpdateTile ( Windows::Foundation::Collections::IVector< Windows::Storage::StorageFile^>^ files ) [private]
The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/TileUpdateScheduler.h
  • Hilo C++/C++/Hilo/TileUpdateScheduler.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::ViewModelBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::ViewModelBase
Public Member Functions | Public Attributes | Properties

Hilo::ViewModelBase Class Reference

#include "ViewModelBase.h"

Inherits Hilo::Common::BindableBase.

Inherited by Hilo::ImageBase, Hilo::sealed, Hilo::sealed, and Hilo::sealed.

List of all members.

Public Member Functions

virtual void | GoHome ()
virtual void | GoToPage (PageType page, Platform::Object^parameter)
virtual void | LoadState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap)

Public Attributes

internal | __pad0__: ViewModelBase(std::shared_ptr<ExceptionPolicy> exceptionPolicy)
event NavigateEventHandler | NavigateBack
event NavigateEventHandler | NavigateHome
event PageNavigateEventHandler | NavigateToPage

Properties

std::shared_ptr< ExceptionPolicy > | m_exceptionPolicy
bool | m_isAppBarEnabled
bool | m_isAppBarOpen
bool | m_isAppBarSticky

Detailed Description

Definition at line 23 of file ViewModelBase.h.

Member Function Documentation

void ViewModelBase::GoHome ( ) [virtual]

Definition at line 85 of file ViewModelBase.cpp.

{
    NavigateHome();
}

virtual void Hilo::ViewModelBase::GoToPage | ( | PageType | page,
 |  | Platform::Object^ | parameter |
 | ) |  |  | [virtual]
virtual void Hilo::ViewModelBase::LoadState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ stateMap ) [virtual]

Reimplemented in Hilo::sealed, Hilo::sealed, and Hilo::sealed.

virtual void Hilo::ViewModelBase::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [virtual]

Reimplemented in Hilo::sealed, and Hilo::sealed.

virtual void Hilo::ViewModelBase::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [virtual]

Reimplemented in Hilo::sealed, Hilo::sealed, Hilo::sealed, Hilo::sealed, and Hilo::sealed.

virtual void Hilo::ViewModelBase::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ stateMap ) [virtual]

Reimplemented in Hilo::sealed, Hilo::sealed, and Hilo::sealed.

Member Data Documentation

internal Hilo::ViewModelBase::__pad0__

Reimplemented in Hilo::sealed, and Hilo::ImageBase.

Definition at line 26 of file ViewModelBase.h.

event NavigateEventHandler Hilo::ViewModelBase::NavigateBack

Definition at line 28 of file ViewModelBase.h.

event NavigateEventHandler Hilo::ViewModelBase::NavigateHome

Definition at line 29 of file ViewModelBase.h.

event PageNavigateEventHandler Hilo::ViewModelBase::NavigateToPage

Definition at line 30 of file ViewModelBase.h.

Property Documentation

std::shared_ptr<ExceptionPolicy> Hilo::ViewModelBase::m_exceptionPolicy

Reimplemented in Hilo::sealed.

Definition at line 51 of file ViewModelBase.h.

bool Hilo::ViewModelBase::m_isAppBarEnabled

Definition at line 47 of file ViewModelBase.h.

bool Hilo::ViewModelBase::m_isAppBarOpen

Definition at line 48 of file ViewModelBase.h.

bool Hilo::ViewModelBase::m_isAppBarSticky

Definition at line 49 of file ViewModelBase.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/ViewModelBase.h
  • Hilo C++/C++/Hilo/ViewModelBase.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::WideFiveImageTile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Hilo
  • Hilo::WideFiveImageTile
Public Member Functions | Private Member Functions | Private Attributes

Hilo::WideFiveImageTile Class Reference

#include "WideFiveImageTile.h"

List of all members.

Public Member Functions

WideFiveImageTile ()
WideFiveImageTile (IResourceLoader^loader)
Windows::UI::Notifications::TileNotification | GetTileNotification ()
void | SetImageFilePaths (const std::vector< std::wstring > &fileNames)

Private Member Functions

void | UpdateContentWithValues (Windows::Data::Xml::Dom::XmlDocument^content)

Private Attributes

std::vector< std::wstring > | m_fileNames
IResourceLoader m_loader

Detailed Description

Definition at line 16 of file WideFiveImageTile.h.

Constructor & Destructor Documentation

WideFiveImageTile::WideFiveImageTile ( )

Definition at line 20 of file WideFiveImageTile.cpp.

{
    m_loader = ref new LocalResourceLoader();
}

WideFiveImageTile::WideFiveImageTile ( Hilo::IResourceLoader^ loader )

Definition at line 25 of file WideFiveImageTile.cpp.

                                                                : m_loader(loader)
{
}

Member Function Documentation

TileNotification WideFiveImageTile::GetTileNotification ( )

Definition at line 29 of file WideFiveImageTile.cpp.

{
    auto content = TileUpdateManager::GetTemplateContent(TileTemplateType::TileWideImageCollection);

    UpdateContentWithValues(content);

    return ref new TileNotification(content);
}

void Hilo::WideFiveImageTile::SetImageFilePaths ( const std::vector< std::wstring > & fileNames )
void Hilo::WideFiveImageTile::UpdateContentWithValues ( Windows::Data::Xml::Dom::XmlDocument^ content ) [private]

Member Data Documentation

std::vector<std::wstring> Hilo::WideFiveImageTile::m_fileNames [private]

Definition at line 27 of file WideFiveImageTile.h.

IResourceLoader Hilo::WideFiveImageTile::m_loader [private]

Definition at line 26 of file WideFiveImageTile.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/Hilo/WideFiveImageTile.h
  • Hilo C++/C++/Hilo/WideFiveImageTile.cpp
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpRequestStringCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

HttpRequestStringCallback Class Reference

List of all members.

Public Member Functions

HttpRequestStringCallback (IXMLHTTPRequest2 *httpRequest, cancellation_token ct=concurrency::cancellation_token::none())
HttpRequestStringCallback (IXMLHTTPRequest2 *httpRequest, cancellation_token ct=concurrency::cancellation_token::none())
HttpRequestStringCallback (IXMLHTTPRequest2 *httpRequest, cancellation_token ct=concurrency::cancellation_token::none())
HttpRequestStringCallback (IXMLHTTPRequest2 *httpRequest, cancellation_token ct=concurrency::cancellation_token::none())
HttpRequestStringCallback (IXMLHTTPRequest2 *httpRequest, cancellation_token ct=concurrency::cancellation_token::none())
task_completion_event< tuple
< HRESULT, wstring > > const & 		GetCompletionEvent () const
task_completion_event< tuple
< HRESULT, wstring > > const & 		GetCompletionEvent () const
task_completion_event< tuple
< HRESULT, wstring > > const & 		GetCompletionEvent () const
task_completion_event< tuple
< HRESULT, wstring > > const & 		GetCompletionEvent () const
task_completion_event< tuple
< HRESULT, wstring > > const & 		GetCompletionEvent () const
wstring | GetReasonPhrase () const
wstring | GetReasonPhrase () const
wstring | GetReasonPhrase () const
wstring | GetReasonPhrase () const
wstring | GetReasonPhrase () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *)
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *)
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *)
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *)
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *, ISequentialStream *responseStream)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *, ISequentialStream *responseStream)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *, ISequentialStream *responseStream)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *, ISequentialStream *responseStream)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *, ISequentialStream *responseStream)
HRESULT | ReadUtf8StringFromSequentialStream (ISequentialStream *readStream, wstring &str)
HRESULT | ReadUtf8StringFromSequentialStream (ISequentialStream *readStream, wstring &str)
HRESULT | ReadUtf8StringFromSequentialStream (ISequentialStream *readStream, wstring &str)
HRESULT | ReadUtf8StringFromSequentialStream (ISequentialStream *readStream, wstring &str)
HRESULT | ReadUtf8StringFromSequentialStream (ISequentialStream *readStream, wstring &str)

Private Member Functions

~HttpRequestStringCallback ()
~HttpRequestStringCallback ()
~HttpRequestStringCallback ()
~HttpRequestStringCallback ()
~HttpRequestStringCallback ()

Private Attributes

cancellation_token | cancellationToken
task_completion_event< tuple
< HRESULT, wstring > > 		completionEvent
wstring | reasonPhrase
cancellation_token_registration | registrationToken
ComPtr< IXMLHTTPRequest2 > | request
int | statusCode

Detailed Description

Definition at line 26 of file HttpRequest.cpp.

Constructor & Destructor Documentation

HttpRequestStringCallback::HttpRequestStringCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 30 of file HttpRequest.cpp.

                                                                     :
        request(httpRequest), cancellationToken(ct)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }
    }

HttpRequestStringCallback::~HttpRequestStringCallback ( ) [inline, private]

Definition at line 222 of file HttpRequest.cpp.

    {
        // Unregister the callback.
        if (cancellationToken != cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

HttpRequestStringCallback::HttpRequestStringCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 30 of file HttpRequest.cpp.

                                                                     :
        request(httpRequest), cancellationToken(ct)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }
    }

HttpRequestStringCallback::~HttpRequestStringCallback ( ) [inline, private]

Definition at line 222 of file HttpRequest.cpp.

    {
        // Unregister the callback.
        if (cancellationToken != cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

HttpRequestStringCallback::HttpRequestStringCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 30 of file HttpRequest.cpp.

                                                                     :
        request(httpRequest), cancellationToken(ct)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }
    }

HttpRequestStringCallback::~HttpRequestStringCallback ( ) [inline, private]

Definition at line 222 of file HttpRequest.cpp.

    {
        // Unregister the callback.
        if (cancellationToken != cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

HttpRequestStringCallback::HttpRequestStringCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 29 of file HttpRequest.cpp.

                                                                     :
        request(httpRequest), cancellationToken(ct)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }
    }

HttpRequestStringCallback::~HttpRequestStringCallback ( ) [inline, private]

Definition at line 221 of file HttpRequest.cpp.

    {
        // Unregister the callback.
        if (cancellationToken != cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

HttpRequestStringCallback::HttpRequestStringCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 30 of file HttpRequest.cpp.

                                                                     :
        request(httpRequest), cancellationToken(ct)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }
    }

HttpRequestStringCallback::~HttpRequestStringCallback ( ) [inline, private]

Definition at line 222 of file HttpRequest.cpp.

    {
        // Unregister the callback.
        if (cancellationToken != cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

Member Function Documentation

task_completion_event<tuple<HRESULT, wstring> > const& HttpRequestStringCallback::GetCompletionEvent ( ) const [inline]

Definition at line 206 of file HttpRequest.cpp.

    {
        return completionEvent;
    }

task_completion_event<tuple<HRESULT, wstring> > const& HttpRequestStringCallback::GetCompletionEvent ( ) const [inline]

Definition at line 206 of file HttpRequest.cpp.

    {
        return completionEvent;
    }

task_completion_event<tuple<HRESULT, wstring> > const& HttpRequestStringCallback::GetCompletionEvent ( ) const [inline]

Definition at line 205 of file HttpRequest.cpp.

    {
        return completionEvent;
    }

task_completion_event<tuple<HRESULT, wstring> > const& HttpRequestStringCallback::GetCompletionEvent ( ) const [inline]

Definition at line 206 of file HttpRequest.cpp.

    {
        return completionEvent;
    }

task_completion_event<tuple<HRESULT, wstring> > const& HttpRequestStringCallback::GetCompletionEvent ( ) const [inline]

Definition at line 206 of file HttpRequest.cpp.

    {
        return completionEvent;
    }

wstring HttpRequestStringCallback::GetReasonPhrase ( ) const [inline]

Definition at line 216 of file HttpRequest.cpp.

    {
        return reasonPhrase;
    }

wstring HttpRequestStringCallback::GetReasonPhrase ( ) const [inline]

Definition at line 216 of file HttpRequest.cpp.

    {
        return reasonPhrase;
    }

wstring HttpRequestStringCallback::GetReasonPhrase ( ) const [inline]

Definition at line 215 of file HttpRequest.cpp.

    {
        return reasonPhrase;
    }

wstring HttpRequestStringCallback::GetReasonPhrase ( ) const [inline]

Definition at line 216 of file HttpRequest.cpp.

    {
        return reasonPhrase;
    }

wstring HttpRequestStringCallback::GetReasonPhrase ( ) const [inline]

Definition at line 216 of file HttpRequest.cpp.

    {
        return reasonPhrase;
    }

int HttpRequestStringCallback::GetStatusCode ( ) const [inline]

Definition at line 211 of file HttpRequest.cpp.

    {
        return statusCode;
    }

int HttpRequestStringCallback::GetStatusCode ( ) const [inline]

Definition at line 211 of file HttpRequest.cpp.

    {
        return statusCode;
    }

int HttpRequestStringCallback::GetStatusCode ( ) const [inline]

Definition at line 210 of file HttpRequest.cpp.

    {
        return statusCode;
    }

int HttpRequestStringCallback::GetStatusCode ( ) const [inline]

Definition at line 211 of file HttpRequest.cpp.

    {
        return statusCode;
    }

int HttpRequestStringCallback::GetStatusCode ( ) const [inline]

Definition at line 211 of file HttpRequest.cpp.

    {
        return statusCode;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * |  |
 | ) |  |  | [inline]

Definition at line 74 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * |  |
 | ) |  |  | [inline]

Definition at line 74 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * |  |
 | ) |  |  | [inline]

Definition at line 74 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * |  |
 | ) |  |  | [inline]

Definition at line 74 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * |  |
 | ) |  |  | [inline]

Definition at line 73 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 188 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hrError), wstring()));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 187 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hrError), wstring()));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 188 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hrError), wstring()));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 188 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hrError), wstring()));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 188 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hrError), wstring()));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 55 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 55 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 55 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 55 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 54 of file HttpRequest.cpp.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 49 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 49 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 49 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 49 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 48 of file HttpRequest.cpp.

    {
        return S_OK;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 80 of file HttpRequest.cpp.

    {
        wstring wstr;
        HRESULT hr = ReadUtf8StringFromSequentialStream(responseStream, wstr);

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hr), move(wstr)));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 80 of file HttpRequest.cpp.

    {
        wstring wstr;
        HRESULT hr = ReadUtf8StringFromSequentialStream(responseStream, wstr);

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hr), move(wstr)));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 80 of file HttpRequest.cpp.

    {
        wstring wstr;
        HRESULT hr = ReadUtf8StringFromSequentialStream(responseStream, wstr);

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hr), move(wstr)));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 80 of file HttpRequest.cpp.

    {
        wstring wstr;
        HRESULT hr = ReadUtf8StringFromSequentialStream(responseStream, wstr);

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hr), move(wstr)));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP HttpRequestStringCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 79 of file HttpRequest.cpp.

    {
        wstring wstr;
        HRESULT hr = ReadUtf8StringFromSequentialStream(responseStream, wstr);

        // We must not propagate exceptions back to IXHR2.
        try
        {
            completionEvent.set(make_tuple<HRESULT, wstring>(move(hr), move(wstr)));
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

HRESULT HttpRequestStringCallback::ReadUtf8StringFromSequentialStream | ( | ISequentialStream * | readStream,
 |  | wstring & | str |
 | ) |  |  | [inline]

Definition at line 100 of file HttpRequest.cpp.

    {
        // Convert the response to Unicode wstring.
        HRESULT hr;

        // Holds the response as a Unicode string.
        wstringstream ss;

        while (true)
        {
            ULONG cb;
            char buffer[4096];

            // Read the response as a UTF-8 string.  Since UTF-8 characters are 1-4 bytes long,
            // we need to make sure we only read an integral number of characters.  So we'll
            // start with 4093 bytes.
            hr = readStream->Read(buffer, sizeof(buffer) - 3, &cb);
            if (FAILED(hr) || (cb == 0))
            {
                break; // Error or no more data to process, exit loop.
            }

            if (cb == sizeof(buffer) - 3)
            {
                ULONG subsequentBytesRead;
                unsigned int i, cl;

                // Find the first byte of the last UTF-8 character in the buffer.
                for (i = cb - 1; (i >= 0) && ((buffer[i] & 0xC0) == 0x80); i--);

                // Calculate the number of subsequent bytes in the UTF-8 character.
                if (((unsigned char)buffer[i]) < 0x80)
                {
                    cl = 1;
                }
                else if (((unsigned char)buffer[i]) < 0xE0)
                {
                    cl = 2;
                }
                else if (((unsigned char)buffer[i]) < 0xF0)
                {
                    cl = 3;
                }
                else
                {
                    cl = 4;
                }

                // Read any remaining bytes.
                if (cb < i + cl)
                {
                    hr = readStream->Read(buffer + cb, i + cl - cb, &subsequentBytesRead);
                    if (FAILED(hr))
                    {
                        break; // Error, exit loop.
                    }
                    cb += subsequentBytesRead;
                }
            }

            // First determine the size required to store the Unicode string.
            int const sizeRequired = MultiByteToWideChar(CP_UTF8, 0, buffer, cb, nullptr, 0);
            if (sizeRequired == 0)
            {
                // Invalid UTF-8.
                hr = HRESULT_FROM_WIN32(GetLastError());
                break;
            }
            unique_ptr<char16[]> wstr(new(std::nothrow) char16[sizeRequired + 1]);
            if (wstr.get() == nullptr)
            {
                hr = E_OUTOFMEMORY;
                break;
            }

            // Convert the string from UTF-8 to UTF-16LE.  This can never fail, since
            // the previous call above succeeded.
            MultiByteToWideChar(CP_UTF8, 0, buffer, cb, wstr.get(), sizeRequired);
            wstr[sizeRequired] = L'\0'; // Terminate the string.
            ss << wstr.get(); // Write the string to the stream.
        }

        str = SUCCEEDED(hr) ? ss.str() : wstring();
        return (SUCCEEDED(hr)) ? S_OK : hr; // Don't return S_FALSE.
    }

HRESULT HttpRequestStringCallback::ReadUtf8StringFromSequentialStream | ( | ISequentialStream * | readStream,
 |  | wstring & | str |
 | ) |  |  | [inline]

Definition at line 101 of file HttpRequest.cpp.

    {
        // Convert the response to Unicode wstring.
        HRESULT hr;

        // Holds the response as a Unicode string.
        wstringstream ss;

        while (true)
        {
            ULONG cb;
            char buffer[4096];

            // Read the response as a UTF-8 string.  Since UTF-8 characters are 1-4 bytes long,
            // we need to make sure we only read an integral number of characters.  So we'll
            // start with 4093 bytes.
            hr = readStream->Read(buffer, sizeof(buffer) - 3, &cb);
            if (FAILED(hr) || (cb == 0))
            {
                break; // Error or no more data to process, exit loop.
            }

            if (cb == sizeof(buffer) - 3)
            {
                ULONG subsequentBytesRead;
                unsigned int i, cl;

                // Find the first byte of the last UTF-8 character in the buffer.
                for (i = cb - 1; (i >= 0) && ((buffer[i] & 0xC0) == 0x80); i--);

                // Calculate the number of subsequent bytes in the UTF-8 character.
                if (((unsigned char)buffer[i]) < 0x80)
                {
                    cl = 1;
                }
                else if (((unsigned char)buffer[i]) < 0xE0)
                {
                    cl = 2;
                }
                else if (((unsigned char)buffer[i]) < 0xF0)
                {
                    cl = 3;
                }
                else
                {
                    cl = 4;
                }

                // Read any remaining bytes.
                if (cb < i + cl)
                {
                    hr = readStream->Read(buffer + cb, i + cl - cb, &subsequentBytesRead);
                    if (FAILED(hr))
                    {
                        break; // Error, exit loop.
                    }
                    cb += subsequentBytesRead;
                }
            }

            // First determine the size required to store the Unicode string.
            int const sizeRequired = MultiByteToWideChar(CP_UTF8, 0, buffer, cb, nullptr, 0);
            if (sizeRequired == 0)
            {
                // Invalid UTF-8.
                hr = HRESULT_FROM_WIN32(GetLastError());
                break;
            }
            unique_ptr<char16[]> wstr(new(std::nothrow) char16[sizeRequired + 1]);
            if (wstr.get() == nullptr)
            {
                hr = E_OUTOFMEMORY;
                break;
            }

            // Convert the string from UTF-8 to UTF-16LE.  This can never fail, since
            // the previous call above succeeded.
            MultiByteToWideChar(CP_UTF8, 0, buffer, cb, wstr.get(), sizeRequired);
            wstr[sizeRequired] = L'\0'; // Terminate the string.
            ss << wstr.get(); // Write the string to the stream.
        }

        str = SUCCEEDED(hr) ? ss.str() : wstring();
        return (SUCCEEDED(hr)) ? S_OK : hr; // Don't return S_FALSE.
    }

HRESULT HttpRequestStringCallback::ReadUtf8StringFromSequentialStream | ( | ISequentialStream * | readStream,
 |  | wstring & | str |
 | ) |  |  | [inline]

Definition at line 101 of file HttpRequest.cpp.

    {
        // Convert the response to Unicode wstring.
        HRESULT hr;

        // Holds the response as a Unicode string.
        wstringstream ss;

        while (true)
        {
            ULONG cb;
            char buffer[4096];

            // Read the response as a UTF-8 string.  Since UTF-8 characters are 1-4 bytes long,
            // we need to make sure we only read an integral number of characters.  So we'll
            // start with 4093 bytes.
            hr = readStream->Read(buffer, sizeof(buffer) - 3, &cb);
            if (FAILED(hr) || (cb == 0))
            {
                break; // Error or no more data to process, exit loop.
            }

            if (cb == sizeof(buffer) - 3)
            {
                ULONG subsequentBytesRead;
                unsigned int i, cl;

                // Find the first byte of the last UTF-8 character in the buffer.
                for (i = cb - 1; (i >= 0) && ((buffer[i] & 0xC0) == 0x80); i--);

                // Calculate the number of subsequent bytes in the UTF-8 character.
                if (((unsigned char)buffer[i]) < 0x80)
                {
                    cl = 1;
                }
                else if (((unsigned char)buffer[i]) < 0xE0)
                {
                    cl = 2;
                }
                else if (((unsigned char)buffer[i]) < 0xF0)
                {
                    cl = 3;
                }
                else
                {
                    cl = 4;
                }

                // Read any remaining bytes.
                if (cb < i + cl)
                {
                    hr = readStream->Read(buffer + cb, i + cl - cb, &subsequentBytesRead);
                    if (FAILED(hr))
                    {
                        break; // Error, exit loop.
                    }
                    cb += subsequentBytesRead;
                }
            }

            // First determine the size required to store the Unicode string.
            int const sizeRequired = MultiByteToWideChar(CP_UTF8, 0, buffer, cb, nullptr, 0);
            if (sizeRequired == 0)
            {
                // Invalid UTF-8.
                hr = HRESULT_FROM_WIN32(GetLastError());
                break;
            }
            unique_ptr<char16[]> wstr(new(std::nothrow) char16[sizeRequired + 1]);
            if (wstr.get() == nullptr)
            {
                hr = E_OUTOFMEMORY;
                break;
            }

            // Convert the string from UTF-8 to UTF-16LE.  This can never fail, since
            // the previous call above succeeded.
            MultiByteToWideChar(CP_UTF8, 0, buffer, cb, wstr.get(), sizeRequired);
            wstr[sizeRequired] = L'\0'; // Terminate the string.
            ss << wstr.get(); // Write the string to the stream.
        }

        str = SUCCEEDED(hr) ? ss.str() : wstring();
        return (SUCCEEDED(hr)) ? S_OK : hr; // Don't return S_FALSE.
    }

HRESULT HttpRequestStringCallback::ReadUtf8StringFromSequentialStream | ( | ISequentialStream * | readStream,
 |  | wstring & | str |
 | ) |  |  | [inline]

Definition at line 101 of file HttpRequest.cpp.

    {
        // Convert the response to Unicode wstring.
        HRESULT hr;

        // Holds the response as a Unicode string.
        wstringstream ss;

        while (true)
        {
            ULONG cb;
            char buffer[4096];

            // Read the response as a UTF-8 string.  Since UTF-8 characters are 1-4 bytes long,
            // we need to make sure we only read an integral number of characters.  So we'll
            // start with 4093 bytes.
            hr = readStream->Read(buffer, sizeof(buffer) - 3, &cb);
            if (FAILED(hr) || (cb == 0))
            {
                break; // Error or no more data to process, exit loop.
            }

            if (cb == sizeof(buffer) - 3)
            {
                ULONG subsequentBytesRead;
                unsigned int i, cl;

                // Find the first byte of the last UTF-8 character in the buffer.
                for (i = cb - 1; (i >= 0) && ((buffer[i] & 0xC0) == 0x80); i--);

                // Calculate the number of subsequent bytes in the UTF-8 character.
                if (((unsigned char)buffer[i]) < 0x80)
                {
                    cl = 1;
                }
                else if (((unsigned char)buffer[i]) < 0xE0)
                {
                    cl = 2;
                }
                else if (((unsigned char)buffer[i]) < 0xF0)
                {
                    cl = 3;
                }
                else
                {
                    cl = 4;
                }

                // Read any remaining bytes.
                if (cb < i + cl)
                {
                    hr = readStream->Read(buffer + cb, i + cl - cb, &subsequentBytesRead);
                    if (FAILED(hr))
                    {
                        break; // Error, exit loop.
                    }
                    cb += subsequentBytesRead;
                }
            }

            // First determine the size required to store the Unicode string.
            int const sizeRequired = MultiByteToWideChar(CP_UTF8, 0, buffer, cb, nullptr, 0);
            if (sizeRequired == 0)
            {
                // Invalid UTF-8.
                hr = HRESULT_FROM_WIN32(GetLastError());
                break;
            }
            unique_ptr<char16[]> wstr(new(std::nothrow) char16[sizeRequired + 1]);
            if (wstr.get() == nullptr)
            {
                hr = E_OUTOFMEMORY;
                break;
            }

            // Convert the string from UTF-8 to UTF-16LE.  This can never fail, since
            // the previous call above succeeded.
            MultiByteToWideChar(CP_UTF8, 0, buffer, cb, wstr.get(), sizeRequired);
            wstr[sizeRequired] = L'\0'; // Terminate the string.
            ss << wstr.get(); // Write the string to the stream.
        }

        str = SUCCEEDED(hr) ? ss.str() : wstring();
        return (SUCCEEDED(hr)) ? S_OK : hr; // Don't return S_FALSE.
    }

HRESULT HttpRequestStringCallback::ReadUtf8StringFromSequentialStream | ( | ISequentialStream * | readStream,
 |  | wstring & | str |
 | ) |  |  | [inline]

Definition at line 101 of file HttpRequest.cpp.

    {
        // Convert the response to Unicode wstring.
        HRESULT hr;

        // Holds the response as a Unicode string.
        wstringstream ss;

        while (true)
        {
            ULONG cb;
            char buffer[4096];

            // Read the response as a UTF-8 string.  Since UTF-8 characters are 1-4 bytes long,
            // we need to make sure we only read an integral number of characters.  So we'll
            // start with 4093 bytes.
            hr = readStream->Read(buffer, sizeof(buffer) - 3, &cb);
            if (FAILED(hr) || (cb == 0))
            {
                break; // Error or no more data to process, exit loop.
            }

            if (cb == sizeof(buffer) - 3)
            {
                ULONG subsequentBytesRead;
                unsigned int i, cl;

                // Find the first byte of the last UTF-8 character in the buffer.
                for (i = cb - 1; (i >= 0) && ((buffer[i] & 0xC0) == 0x80); i--);

                // Calculate the number of subsequent bytes in the UTF-8 character.
                if (((unsigned char)buffer[i]) < 0x80)
                {
                    cl = 1;
                }
                else if (((unsigned char)buffer[i]) < 0xE0)
                {
                    cl = 2;
                }
                else if (((unsigned char)buffer[i]) < 0xF0)
                {
                    cl = 3;
                }
                else
                {
                    cl = 4;
                }

                // Read any remaining bytes.
                if (cb < i + cl)
                {
                    hr = readStream->Read(buffer + cb, i + cl - cb, &subsequentBytesRead);
                    if (FAILED(hr))
                    {
                        break; // Error, exit loop.
                    }
                    cb += subsequentBytesRead;
                }
            }

            // First determine the size required to store the Unicode string.
            int const sizeRequired = MultiByteToWideChar(CP_UTF8, 0, buffer, cb, nullptr, 0);
            if (sizeRequired == 0)
            {
                // Invalid UTF-8.
                hr = HRESULT_FROM_WIN32(GetLastError());
                break;
            }
            unique_ptr<char16[]> wstr(new(std::nothrow) char16[sizeRequired + 1]);
            if (wstr.get() == nullptr)
            {
                hr = E_OUTOFMEMORY;
                break;
            }

            // Convert the string from UTF-8 to UTF-16LE.  This can never fail, since
            // the previous call above succeeded.
            MultiByteToWideChar(CP_UTF8, 0, buffer, cb, wstr.get(), sizeRequired);
            wstr[sizeRequired] = L'\0'; // Terminate the string.
            ss << wstr.get(); // Write the string to the stream.
        }

        str = SUCCEEDED(hr) ? ss.str() : wstring();
        return (SUCCEEDED(hr)) ? S_OK : hr; // Don't return S_FALSE.
    }

Member Data Documentation

cancellation_token HttpRequestStringCallback::cancellationToken [private]

Definition at line 232 of file HttpRequest.cpp.

task_completion_event< tuple< HRESULT, wstring > > HttpRequestStringCallback::completionEvent [private]

Definition at line 242 of file HttpRequest.cpp.

wstring HttpRequestStringCallback::reasonPhrase [private]

Definition at line 245 of file HttpRequest.cpp.

cancellation_token_registration HttpRequestStringCallback::registrationToken [private]

Definition at line 235 of file HttpRequest.cpp.

ComPtr< IXMLHTTPRequest2 > HttpRequestStringCallback::request [private]

Definition at line 238 of file HttpRequest.cpp.

int HttpRequestStringCallback::statusCode [private]

Definition at line 244 of file HttpRequest.cpp.

The documentation for this class was generated from the following files:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.cpp
  • Certificate enrollment/C++/HttpRequest.cpp
  • HttpClient/C++/HttpRequest.cpp
  • Search contract/C++/HttpRequest.cpp
  • Windows account authorization/C++/HttpRequest.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IDWriteTextAnalysisSource1 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

IDWriteTextAnalysisSource1 Class Reference

Inherited by QiList< IDWriteTextAnalysisSource1, QiList< IDWriteTextAnalysisSink1, QiList< IUnknown > > >.

The documentation for this class was generated from the following file:
  • DirectWrite vertical text/C++/pch.h
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Image Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Image Class Reference

#include "Image.h"

Inherits Resource.

List of all members.

Public Member Functions

bool | DrawBitmap (_In_ Renderer^renderer, D2D1::Matrix3x2F const &transform, D2D1_RECT_F const &destinationBounds, D2D1_RECT_F const &bitmapBounds)
virtual bool | Initialize (_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override

Public Attributes

internal | __pad0__: Image()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Bitmap > 		m_bitmap
Microsoft::WRL::ComPtr< ImageFile > | m_file

Detailed Description

Definition at line 24 of file Image.h.

Member Function Documentation

bool Image::DrawBitmap | ( | _In_ Renderer^ | renderer,
 |  | D2D1::Matrix3x2F const & | transform,
 |  | D2D1_RECT_F const & | destinationBounds,
 |  | D2D1_RECT_F const & | bitmapBounds
 | ) |  |
virtual bool Image::Initialize | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::XmlElement^ | xmlElement |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Member Data Documentation

internal Image::__pad0__

Reimplemented from Resource.

Definition at line 27 of file Image.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap> Image::m_bitmap [private]

Definition at line 43 of file Image.h.

Microsoft::WRL::ComPtr<ImageFile> Image::m_file [private]

Definition at line 46 of file Image.h.

The documentation for this class was generated from the following file:
  • Direct2D magazine app/C++/Image.h
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ImageFile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

ImageFile Class Reference

#include "ImageFile.h"

List of all members.

Public Member Functions

ImageFile ()
virtual ULONG STDMETHODCALLTYPE | AddRef () override
virtual HRESULT STDMETHODCALLTYPE | Clone (_Outptr_ IStream **cloneStream) override
virtual HRESULT STDMETHODCALLTYPE | Commit (DWORD flags) override
virtual HRESULT STDMETHODCALLTYPE | CopyTo (_In_ IStream *destinationStream, ULARGE_INTEGER bytesToCopy, _Out_ ULARGE_INTEGER *bytesRead, _Out_ ULARGE_INTEGER *bytesWritten) override
void | LoadAsync (_In_ Windows::Storage::StorageFolder^location, _In_ Platform::String^fileName)
virtual HRESULT STDMETHODCALLTYPE | LockRegion (ULARGE_INTEGER bytesOffset, ULARGE_INTEGER bytesToLock, DWORD lockType) override
virtual HRESULT STDMETHODCALLTYPE | QueryInterface (REFIID uuid, _Outptr_ void **object) override
virtual HRESULT STDMETHODCALLTYPE | Read (_Out_writes_bytes_(bytesToRead) void *outputBuffer, ULONG bytesToRead, _Out_ ULONG *bytesRead) override
bool | Ready ()
virtual ULONG STDMETHODCALLTYPE | Release () override
virtual HRESULT STDMETHODCALLTYPE | Revert () override
virtual HRESULT STDMETHODCALLTYPE | Seek (LARGE_INTEGER distance, DWORD origin, _Out_ ULARGE_INTEGER *newLocation) override
virtual HRESULT STDMETHODCALLTYPE | SetSize (ULARGE_INTEGER) override
virtual HRESULT STDMETHODCALLTYPE | Stat (_Out_ STATSTG *statistics, DWORD flags) override
virtual HRESULT STDMETHODCALLTYPE | UnlockRegion (ULARGE_INTEGER bytesOffset, ULARGE_INTEGER bytesToLock, DWORD lockType) override
virtual HRESULT STDMETHODCALLTYPE | Write (_In_reads_bytes_(bytesToWrite) void const *inputBuffer, ULONG bytesToWrite, _Out_ ULONG *bytesWritten) override

Private Attributes

Platform::Array< byte > | m_data
ULONG | m_offset
ULONG | m_refCount

Detailed Description

Definition at line 14 of file ImageFile.h.

Constructor & Destructor Documentation

ImageFile::ImageFile ( )

Definition at line 15 of file ImageFile.cpp.

                     :
    m_refCount(0),
    m_offset(0),
    m_data(nullptr)
{
}

Member Function Documentation

ULONG STDMETHODCALLTYPE ImageFile::AddRef ( ) [override, virtual]

Definition at line 63 of file ImageFile.cpp.

{
    return static_cast<ULONG>(InterlockedIncrement(&m_refCount));
}

HRESULT STDMETHODCALLTYPE ImageFile::Clone ( _Outptr_ IStream ** cloneStream ) [override, virtual]

Definition at line 205 of file ImageFile.cpp.

{
    return E_NOTIMPL;
}

HRESULT STDMETHODCALLTYPE ImageFile::Commit ( DWORD flags ) [override, virtual]

Definition at line 177 of file ImageFile.cpp.

{
    return E_NOTIMPL;
}

HRESULT STDMETHODCALLTYPE ImageFile::CopyTo | ( | _In_ IStream * | destinationStream,
 |  | ULARGE_INTEGER | bytesToCopy,
 |  | _Out_ ULARGE_INTEGER * | bytesRead,
 |  | _Out_ ULARGE_INTEGER * | bytesWritten |
 | ) |  |  | [override, virtual]

Definition at line 167 of file ImageFile.cpp.

{
    return E_NOTIMPL;
}

void ImageFile::LoadAsync | ( | _In_ Windows::Storage::StorageFolder^ | location,
 |  | _In_ Platform::String^ | fileName
 | ) |  |
HRESULT STDMETHODCALLTYPE ImageFile::LockRegion | ( | ULARGE_INTEGER | bytesOffset,
 |  | ULARGE_INTEGER | bytesToLock,
 |  | DWORD | lockType |
 | ) |  |  | [override, virtual]

Definition at line 187 of file ImageFile.cpp.

{
    return E_NOTIMPL;
}

HRESULT STDMETHODCALLTYPE ImageFile::QueryInterface | ( | REFIID | uuid,
 |  | _Outptr_ void ** | object |
 | ) |  |  | [override, virtual]

Definition at line 40 of file ImageFile.cpp.

{
    *object = nullptr;

    if (    uuid == __uuidof(IUnknown)
        ||  uuid == __uuidof(IStream)
        ||  uuid == __uuidof(ISequentialStream)
        )
    {
        *object = static_cast<IStream*>(this);
        AddRef();
        return S_OK;
    }
    else
    {
        *object = nullptr;
        return E_NOINTERFACE;
    }
}

HRESULT STDMETHODCALLTYPE ImageFile::Read | ( | _Out_writes_bytes_(bytesToRead) void * | outputBuffer,
 |  | ULONG | bytesToRead,
 |  | _Out_ ULONG * | bytesRead |
 | ) |  |  | [override, virtual]

Definition at line 78 of file ImageFile.cpp.

{
    HRESULT hr = S_OK;

    if (m_offset + bytesToRead > m_data->Length)
    {
        bytesToRead = m_data->Length - m_offset;
        hr = S_FALSE;
    }

    if (bytesToRead > 0)
    {
        memcpy(outputBuffer, m_data->Data + m_offset, bytesToRead);
    }

    *bytesRead = bytesToRead;
    m_offset += bytesToRead;

    return hr;
}

bool ImageFile::Ready ( ) [inline]

Definition at line 83 of file ImageFile.h.

    {
        return m_data != nullptr;
    }

ULONG STDMETHODCALLTYPE ImageFile::Release ( ) [override, virtual]

Definition at line 68 of file ImageFile.cpp.

{
    ULONG newCount = static_cast<ULONG>(InterlockedDecrement(&m_refCount));

    if (newCount == 0)
        delete this;

    return newCount;
}

HRESULT STDMETHODCALLTYPE ImageFile::Revert ( ) [override, virtual]

Definition at line 182 of file ImageFile.cpp.

{
    return E_NOTIMPL;
}

HRESULT STDMETHODCALLTYPE ImageFile::Seek | ( | LARGE_INTEGER | distance,
 |  | DWORD | origin,
 |  | _Out_ ULARGE_INTEGER * | newLocation |
 | ) |  |  | [override, virtual]

Definition at line 103 of file ImageFile.cpp.

{
    ULONG offset = 0;

    switch (origin)
    {
        case STREAM_SEEK_CUR:
            offset = m_offset;

        case STREAM_SEEK_SET:
            if (    distance.HighPart != 0
                ||  distance.LowPart + offset > m_data->Length
                )
            {
                return STG_E_INVALIDFUNCTION;
            }

            offset += distance.LowPart;
            break;

        case STREAM_SEEK_END:
            if (    distance.HighPart != 0
                ||  distance.LowPart > m_data->Length
                )
            {
                return STG_E_INVALIDFUNCTION;
            }

            offset = m_data->Length - distance.LowPart;
            break;

        default:
            return STG_E_INVALIDFUNCTION;
    }

    m_offset = offset;

    if (newLocation)
    {
        newLocation->HighPart = 0;
        newLocation->LowPart = m_offset;
    }

    return S_OK;
}

HRESULT STDMETHODCALLTYPE ImageFile::SetSize ( ULARGE_INTEGER ) [override, virtual]

Definition at line 162 of file ImageFile.cpp.

{
    return E_NOTIMPL;
}

HRESULT STDMETHODCALLTYPE ImageFile::Stat | ( | _Out_ STATSTG * | statistics,
 |  | DWORD | flags |
 | ) |  |  | [override, virtual]

Definition at line 210 of file ImageFile.cpp.

{
    memset(statistics, 0, sizeof(*statistics));

    statistics->cbSize.LowPart = m_data->Length;
    statistics->cbSize.HighPart = 0;

    return S_OK;
}

HRESULT STDMETHODCALLTYPE ImageFile::UnlockRegion | ( | ULARGE_INTEGER | bytesOffset,
 |  | ULARGE_INTEGER | bytesToLock,
 |  | DWORD | lockType |
 | ) |  |  | [override, virtual]

Definition at line 196 of file ImageFile.cpp.

{
    return E_NOTIMPL;
}

HRESULT STDMETHODCALLTYPE ImageFile::Write | ( | _In_reads_bytes_(bytesToWrite) void const * | inputBuffer,
 |  | ULONG | bytesToWrite,
 |  | _Out_ ULONG * | bytesWritten |
 | ) |  |  | [override, virtual]

Definition at line 153 of file ImageFile.cpp.

{
    return E_NOTIMPL;
}

Member Data Documentation

Platform::Array<byte> ImageFile::m_data [private]

Definition at line 93 of file ImageFile.h.

ULONG ImageFile::m_offset [private]

Definition at line 96 of file ImageFile.h.

ULONG ImageFile::m_refCount [private]

Definition at line 90 of file ImageFile.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/ImageFile.h
  • Direct2D magazine app/C++/ImageFile.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ImageFrame Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

ImageFrame Class Reference

#include "ImageFrame.h"

Inherits Element.

List of all members.

Public Member Functions

virtual bool | BindResource (_In_ Element^rootElement) override
virtual bool | Draw (_In_ Document^document, D2D1::Matrix3x2F const &transform) override
virtual bool | Initialize (_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override
virtual void | Measure (_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override

Public Attributes

internal | __pad0__: ImageFrame()

Private Attributes

D2D1_RECT_F | m_bitmapPixelBounds
::Image m_sourceImage
Platform::String | m_sourceName

Detailed Description

Definition at line 29 of file ImageFrame.h.

Member Function Documentation

bool ImageFrame::BindResource ( _In_ Element^ rootElement ) [override, virtual]

Reimplemented from Element.

Definition at line 72 of file ImageFrame.cpp.

{
    if (rootElement != nullptr)
    {
        TreeIterator<Element> it(rootElement);

        // Traverse the tree looking for the source image
        do
        {
            ::Image^ image(dynamic_cast<::Image^>(it.GetCurrentNode()));

            if (    image != nullptr
                &&  image->GetName() == m_sourceName
                )
            {
                m_sourceImage = image;
                return true;
            }

        } while (++it);
    }

    return false;
}

bool ImageFrame::Draw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 116 of file ImageFrame.cpp.

{
    if (m_sourceImage != nullptr)
    {
        auto renderer = document->GetRenderer();

        return m_sourceImage->DrawBitmap(
            renderer,
            transform,
            D2D1::RectF(
                m_offset.x,
                m_offset.y,
                m_offset.x + m_size.width,
                m_offset.y + m_size.height
                ),
            m_bitmapPixelBounds
            );
    }

    return false;
}

virtual bool ImageFrame::Initialize | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::XmlElement^ | xmlElement |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

void ImageFrame::Measure | ( | _In_ Document^ | document,
 |  | D2D1_SIZE_F const & | parentSize,
 |  | _Out_ D2D1_RECT_F * | bounds |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 97 of file ImageFrame.cpp.

{
    if (m_size.width <= 0 && m_size.height <= 0)
    {
        m_size = D2D1::SizeF(parentSize.width - m_offset.x, parentSize.height - m_offset.y);
    }

    *bounds = D2D1::RectF(
        m_offset.x,
        m_offset.y,
        m_offset.x + m_size.width,
        m_offset.y + m_size.height
        );
}

Member Data Documentation

internal ImageFrame::__pad0__

Reimplemented from Element.

Definition at line 32 of file ImageFrame.h.

D2D1_RECT_F ImageFrame::m_bitmapPixelBounds [private]

Definition at line 60 of file ImageFrame.h.

::Image ImageFrame::m_sourceImage [private]

Definition at line 57 of file ImageFrame.h.

Platform::String ImageFrame::m_sourceName [private]

Definition at line 54 of file ImageFrame.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/ImageFrame.h
  • Direct2D magazine app/C++/ImageFrame.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ImageRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

ImageRenderer Class Reference

#include "ImageRenderer.h"

List of all members.

Public Member Functions

void | CreateDeviceResources (Microsoft::WRL::ComPtr< ID2D1DeviceContext > d2dContext)
void | CreateWindowSizeDependentResources (float dpi)
void | DrawImageAndEffects ()
void | LoadImage (Windows::Storage::Streams::IRandomAccessStream^randomAccessStream)
void | Reset ()
void | SetEffectIntensity (float value)

Public Attributes

internal | __pad0__: void CreateDeviceIndependentResources(Microsoft::WRL::ComPtr<IWICImagingFactory2> wicFactory)

Private Member Functions

void | UpdateImageZoom ()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_bitmapSourceEffect
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
float | m_dpi
D2D1_SIZE_U | m_imagePixelSize
D2D1_SIZE_F | m_imageSizeDips
float | m_imageZoomFactor
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_saturationEffect
Microsoft::WRL::ComPtr
< IWICImagingFactory2 > 		m_wicFactory

Detailed Description

Definition at line 9 of file ImageRenderer.h.

Member Function Documentation

void ImageRenderer::CreateDeviceResources ( Microsoft::WRL::ComPtr< ID2D1DeviceContext > d2dContext )
void ImageRenderer::CreateWindowSizeDependentResources ( float dpi )

Definition at line 66 of file ImageRenderer.cpp.

{
    // Save the shared DPI.
    m_dpi = dpi;

    UpdateImageZoom();
}

void ImageRenderer::DrawImageAndEffects ( )

Definition at line 74 of file ImageRenderer.cpp.

{
    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Set the context transform to center the image.
    m_d2dContext->SetTransform(
        D2D1::Matrix3x2F::Translation(
            (size.width - (m_imageSizeDips.width * m_imageZoomFactor)) / 2,
            (size.height - (m_imageSizeDips.height * m_imageZoomFactor)) / 2
            )
        );

    m_d2dContext->DrawImage(m_saturationEffect.Get());
}

void ImageRenderer::LoadImage ( Windows::Storage::Streams::IRandomAccessStream^ randomAccessStream )
void ImageRenderer::Reset ( )

Definition at line 189 of file ImageRenderer.cpp.

{
    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE, NULL)
        );

    DX::ThrowIfFailed(
        m_saturationEffect->SetValue(D2D1_SATURATION_PROP_SATURATION, FullSaturation)
        );
}

void ImageRenderer::SetEffectIntensity ( float value )

Definition at line 182 of file ImageRenderer.cpp.

{
    DX::ThrowIfFailed(
        m_saturationEffect->SetValue(D2D1_SATURATION_PROP_SATURATION, value)
        );
}

void ImageRenderer::UpdateImageZoom ( ) [private]

Definition at line 156 of file ImageRenderer.cpp.

{
    // Compute the minimum zoom to ensure the image fits on the screen.
    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // m_imageSize is in DIPs and changes depending on the app DPI.
    // This app ignores the source bitmap's DPI and assumes it is 96, in order to
    // display it at full resolution.
    m_imageSizeDips = D2D1::SizeF(
        m_imagePixelSize.width * 96.0f / m_dpi,
        m_imagePixelSize.height * 96.0f / m_dpi
        );

    m_imageZoomFactor = std::min<float>(
        size.width / m_imageSizeDips.width,
        size.height / m_imageSizeDips.height
        );

    DX::ThrowIfFailed(
        m_bitmapSourceEffect->SetValue(
            D2D1_BITMAPSOURCE_PROP_SCALE,
            D2D1::Vector2F(m_imageZoomFactor, m_imageZoomFactor)
            )
        );
}

Member Data Documentation

internal ImageRenderer::__pad0__

Definition at line 12 of file ImageRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> ImageRenderer::m_bitmapSourceEffect [private]

Definition at line 31 of file ImageRenderer.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> ImageRenderer::m_d2dContext [private]

Definition at line 27 of file ImageRenderer.h.

float ImageRenderer::m_dpi [private]

Definition at line 28 of file ImageRenderer.h.

D2D1_SIZE_U ImageRenderer::m_imagePixelSize [private]

Definition at line 32 of file ImageRenderer.h.

D2D1_SIZE_F ImageRenderer::m_imageSizeDips [private]

Definition at line 33 of file ImageRenderer.h.

float ImageRenderer::m_imageZoomFactor [private]

Definition at line 34 of file ImageRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Effect> ImageRenderer::m_saturationEffect [private]

Definition at line 36 of file ImageRenderer.h.

Microsoft::WRL::ComPtr<IWICImagingFactory2> ImageRenderer::m_wicFactory [private]

Definition at line 26 of file ImageRenderer.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/ImageRenderer.h
  • DirectX postcard app/C++/ImageRenderer.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IMFAsyncCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

IMFAsyncCallback Class Reference

Inherited by AsyncCallback< T >, AsyncCallback< T >, AsyncCallback< T >, AsyncCallback< CMPEG1Source >, AsyncCallback< CMPEG1Source >, and AsyncCallback< CMPEG1Source >.

The documentation for this class was generated from the following file:
  • Real-time communication/C++/MediaExtensions/Common/AsyncCB.h
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IMft0Vtbl Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

IMft0Vtbl Struct Reference

#include "SampleMft0.h"

List of all members.

Public Member Functions

BEGIN_INTERFACE | HRESULT (STDMETHODCALLTYPE *QueryInterface)(__RPC__in IMft0 *This
HRESULT (STDMETHODCALLTYPE *GetDspSetting)(__RPC__in IMft0 *This
HRESULT (STDMETHODCALLTYPE *Disable)(__RPC__in IMft0 *This)
HRESULT (STDMETHODCALLTYPE *UpdateDsp)(__RPC__in IMft0 *This
HRESULT (STDMETHODCALLTYPE *UpdateDsp)(__RPC__in IMft0 *This
BEGIN_INTERFACE | HRESULT (STDMETHODCALLTYPE *QueryInterface)(__RPC__in IMft0 *This
HRESULT (STDMETHODCALLTYPE *Enable)(__RPC__in IMft0 *This)
HRESULT (STDMETHODCALLTYPE *Disable)(__RPC__in IMft0 *This)
HRESULT (STDMETHODCALLTYPE *GetDspSetting)(__RPC__in IMft0 *This
HRESULT (STDMETHODCALLTYPE *Enable)(__RPC__in IMft0 *This)
ULONG (STDMETHODCALLTYPE *Release)(__RPC__in IMft0 *This)
ULONG (STDMETHODCALLTYPE *Release)(__RPC__in IMft0 *This)
ULONG (STDMETHODCALLTYPE *AddRef)(__RPC__in IMft0 *This)
ULONG (STDMETHODCALLTYPE *AddRef)(__RPC__in IMft0 *This)

Public Attributes

__RPC__out UINT __RPC__out BOOL * | pIsEnabled
BEGIN_INTERFACE __RPC__in
REFIID __RPC__deref_out
_Result_nullonfailure_ void ** 		ppvObject
__RPC__out UINT * | puiPercentOfScreen
BEGIN_INTERFACE __RPC__in REFIID | riid
UINT32 | uiPercentOfScreen

Detailed Description

Definition at line 104 of file SampleMft0.h.

Member Function Documentation

BEGIN_INTERFACE IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * QueryInterface )
IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * GetDspSetting )
IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * Disable )
IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * UpdateDsp )
IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * UpdateDsp )
BEGIN_INTERFACE IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * QueryInterface )
IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * Enable )
IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * Disable )
IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * GetDspSetting )
IMft0Vtbl::HRESULT ( STDMETHODCALLTYPE * Enable )
IMft0Vtbl::ULONG ( STDMETHODCALLTYPE * Release )
IMft0Vtbl::ULONG ( STDMETHODCALLTYPE * Release )
IMft0Vtbl::ULONG ( STDMETHODCALLTYPE * AddRef )
IMft0Vtbl::ULONG ( STDMETHODCALLTYPE * AddRef )

Member Data Documentation

__RPC__out UINT __RPC__out BOOL * IMft0Vtbl::pIsEnabled

Definition at line 132 of file SampleMft0.h.

BEGIN_INTERFACE __RPC__in REFIID __RPC__deref_out _Result_nullonfailure_ void ** IMft0Vtbl::ppvObject

Definition at line 110 of file SampleMft0.h.

__RPC__out UINT * IMft0Vtbl::puiPercentOfScreen

Definition at line 132 of file SampleMft0.h.

BEGIN_INTERFACE __RPC__in REFIID IMft0Vtbl::riid

Definition at line 110 of file SampleMft0.h.

UINT32 IMft0Vtbl::uiPercentOfScreen

Definition at line 122 of file SampleMft0.h.

The documentation for this struct was generated from the following files:
  • Windows Store device app for camera/C#,C++/Wrapper/SampleMft0.h
  • Windows Store device app for camera/C++/Wrapper/SampleMft0.h
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IndexTriplet Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

IndexTriplet Struct Reference

List of all members.

Public Attributes

unsigned short | norm
unsigned short | pos
unsigned short | tex

Detailed Description

Definition at line 24 of file obj2vbo.cpp.

Member Data Documentation

unsigned short IndexTriplet::norm

Definition at line 27 of file obj2vbo.cpp.

unsigned short IndexTriplet::pos

Definition at line 26 of file obj2vbo.cpp.

unsigned short IndexTriplet::tex

Definition at line 28 of file obj2vbo.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/obj2vbo/obj2vbo.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: InkRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

InkRenderer Class Reference

#include "InkRenderer.h"

List of all members.

Public Member Functions

void | CreateDeviceIndependentResources (Microsoft::WRL::ComPtr< ID2D1Factory1 > d2dFactory)
void | CreateDeviceResources (Microsoft::WRL::ComPtr< ID2D1DeviceContext > d2dContext)
void | CreateWindowSizeDependentResources (float dpi)
void | DrawInk ()
void | OnPointerMoved (_In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | Reset ()
void | StartSignature ()

Public Attributes

internal | __pad0__: InkRenderer(void)

Private Member Functions

void | ConvertStrokeToGeometry (_In_ Windows::UI::Input::Inking::IInkStroke^stroke, _Outptr_result_maybenull_ ID2D1PathGeometry **geometry)
void | DeleteAllStrokes ()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
std::vector< D2D1_POINT_2F > | m_currentStroke
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
float | m_dpi
Platform::Agile
< Windows::UI::Input::Inking::InkManager > 		m_inkManager
InkState m_inkState
uint32 | m_pointerId
std::vector
< Microsoft::WRL::ComPtr
< ID2D1PathGeometry > > 		m_strokes

Detailed Description

Definition at line 16 of file InkRenderer.h.

Member Function Documentation

void InkRenderer::ConvertStrokeToGeometry | ( | _In_ Windows::UI::Input::Inking::IInkStroke^ | stroke,
 |  | _Outptr_result_maybenull_ ID2D1PathGeometry ** | geometry |
 | ) |  |  | [private]
void InkRenderer::CreateDeviceIndependentResources ( Microsoft::WRL::ComPtr< ID2D1Factory1 > d2dFactory )
void InkRenderer::CreateDeviceResources ( Microsoft::WRL::ComPtr< ID2D1DeviceContext > d2dContext )
void InkRenderer::CreateWindowSizeDependentResources ( float dpi )

Definition at line 47 of file InkRenderer.cpp.

{
    // Save shared DPI.
    m_dpi = dpi;
}

void InkRenderer::DeleteAllStrokes ( ) [private]

Definition at line 159 of file InkRenderer.cpp.

{
    auto strokes = m_inkManager->GetStrokes();
    for (auto stroke : strokes)
    {
        stroke->Selected = true;
    }
    m_inkManager->DeleteSelected();
    m_strokes.clear();
    m_currentStroke.clear();
}

void InkRenderer::DrawInk ( )

Definition at line 53 of file InkRenderer.cpp.

{
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    // Render the strokes stored in the stroke geometry.
    if (!m_strokes.empty())
    {
        for (ComPtr<ID2D1PathGeometry> stroke : m_strokes)
        {
            m_d2dContext->DrawGeometry(
                stroke.Get(),
                m_blackBrush.Get(),
                5.0f    // Stroke width.
                );
        }
    }

    // Render the current stroke.
    if (!m_currentStroke.empty())
    {
        auto previousPoint = m_currentStroke.at(0);
        D2D1_POINT_2F currentPoint;
        for (auto i = m_currentStroke.begin() + 1; i != m_currentStroke.end(); i++)
        {
            currentPoint = *i;
            m_d2dContext->DrawLine(
                previousPoint,
                currentPoint,
                m_blackBrush.Get(),
                5.0f
                );
            previousPoint = currentPoint;
        }
    }
}

void InkRenderer::OnPointerMoved ( _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args )
void InkRenderer::OnPointerPressed ( _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args )
void InkRenderer::OnPointerReleased ( _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args )
void InkRenderer::Reset ( )

Definition at line 94 of file InkRenderer.cpp.

{
    DeleteAllStrokes();
    m_inkState = InkState::StrokeCompleted;
}

void InkRenderer::StartSignature ( )

Definition at line 89 of file InkRenderer.cpp.

{
    m_inkState = InkState::StrokeCompleted;
}

Member Data Documentation

internal InkRenderer::__pad0__

Definition at line 19 of file InkRenderer.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> InkRenderer::m_blackBrush [private]

Definition at line 50 of file InkRenderer.h.

std::vector<D2D1_POINT_2F> InkRenderer::m_currentStroke [private]

Definition at line 51 of file InkRenderer.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> InkRenderer::m_d2dContext [private]

Definition at line 43 of file InkRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Factory1> InkRenderer::m_d2dFactory [private]

Definition at line 42 of file InkRenderer.h.

float InkRenderer::m_dpi [private]

Definition at line 44 of file InkRenderer.h.

Platform::Agile<Windows::UI::Input::Inking::InkManager> InkRenderer::m_inkManager [private]

Definition at line 47 of file InkRenderer.h.

InkState InkRenderer::m_inkState [private]

Definition at line 48 of file InkRenderer.h.

uint32 InkRenderer::m_pointerId [private]

Definition at line 49 of file InkRenderer.h.

std::vector<Microsoft::WRL::ComPtr<ID2D1PathGeometry> > InkRenderer::m_strokes [private]

Definition at line 52 of file InkRenderer.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/InkRenderer.h
  • DirectX postcard app/C++/InkRenderer.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: InlineImage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

InlineImage Class Reference

#include "InlineImage.h"

List of all members.

Public Member Functions

InlineImage (Microsoft::WRL::ComPtr< ID2D1DeviceContext > deviceContext, Microsoft::WRL::ComPtr< IWICImagingFactory > IWICFactory, PCWSTR uri)
unsigned long STDMETHODCALLTYPE | AddRef ()
STDMETHOD() | Draw (_In_opt_ void *clientDrawingContext, IDWriteTextRenderer *renderer, FLOAT originX, FLOAT originY, BOOL isSideways, BOOL isRightToLeft, IUnknown *clientDrawingEffect)
STDMETHOD() | GetBreakConditions (_Out_ DWRITE_BREAK_CONDITION *breakConditionBefore, _Out_ DWRITE_BREAK_CONDITION *breakConditionAfter)
STDMETHOD() | GetMetrics (_Out_ DWRITE_INLINE_OBJECT_METRICS *metrics)
STDMETHOD() | GetOverhangMetrics (_Out_ DWRITE_OVERHANG_METRICS *overhangs)
HRESULT STDMETHODCALLTYPE | QueryInterface (IID const &riid, void **ppvObject)
unsigned long STDMETHODCALLTYPE | Release ()

Private Member Functions

HRESULT | LoadBitmapFromFile (Microsoft::WRL::ComPtr< ID2D1DeviceContext > deviceContext, Microsoft::WRL::ComPtr< IWICImagingFactory > IWICFactory, PCWSTR uri, _Outptr_ ID2D1Bitmap **ppBitmap)

Private Attributes

float | baseline
Microsoft::WRL::ComPtr
< ID2D1Bitmap > 		bitmap
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		deviceContext
D2D1_RECT_F | rect
unsigned long | refCount

Detailed Description

Definition at line 10 of file InlineImage.h.

Constructor & Destructor Documentation

InlineImage::InlineImage | ( | Microsoft::WRL::ComPtr< ID2D1DeviceContext > | deviceContext,
 |  | Microsoft::WRL::ComPtr< IWICImagingFactory > | IWICFactory,
 |  | PCWSTR | uri
 | ) |  |

Definition at line 11 of file InlineImage.cpp.

      :
    refCount(0)
{
    // Save the render target for later.
    this->deviceContext = deviceContext;

    // Load the bitmap from a file.
    LoadBitmapFromFile(
        deviceContext,
        IWICFactory,
        uri,
        &bitmap
        );
}

Member Function Documentation

unsigned long STDMETHODCALLTYPE InlineImage::AddRef ( )
HRESULT STDMETHODCALLTYPE InlineImage::Draw | ( | _In_opt_ void * | clientDrawingContext,
 |  | IDWriteTextRenderer * | renderer,
 |  | FLOAT | originX,
 |  | FLOAT | originY,
 |  | BOOL | isSideways,
 |  | BOOL | isRightToLeft,
 |  | IUnknown * | clientDrawingEffect
 | ) |  |

Definition at line 30 of file InlineImage.cpp.

{
    float height    = rect.bottom - rect.top;
    float width     = rect.right  - rect.left;
    D2D1_RECT_F destRect  = {originX, originY, originX + width, originY + height};

    deviceContext.Get()->DrawBitmap(bitmap.Get(), destRect);

    return S_OK;
}

HRESULT STDMETHODCALLTYPE InlineImage::GetBreakConditions | ( | _Out_ DWRITE_BREAK_CONDITION * | breakConditionBefore,
 |  | _Out_ DWRITE_BREAK_CONDITION * | breakConditionAfter
 | ) |  |

Definition at line 72 of file InlineImage.cpp.

{
    *breakConditionBefore = DWRITE_BREAK_CONDITION_NEUTRAL;
    *breakConditionAfter  = DWRITE_BREAK_CONDITION_NEUTRAL;
    return S_OK;
}

HRESULT STDMETHODCALLTYPE InlineImage::GetMetrics ( _Out_ DWRITE_INLINE_OBJECT_METRICS * metrics )

Definition at line 49 of file InlineImage.cpp.

{
    DWRITE_INLINE_OBJECT_METRICS inlineMetrics = {};
    inlineMetrics.width     = rect.right  - rect.left;
    inlineMetrics.height    = rect.bottom - rect.top;
    inlineMetrics.baseline  = baseline;
    *metrics = inlineMetrics;
    return S_OK;
}

HRESULT STDMETHODCALLTYPE InlineImage::GetOverhangMetrics ( _Out_ DWRITE_OVERHANG_METRICS * overhangs )

Definition at line 61 of file InlineImage.cpp.

{
    overhangs->left      = 0;
    overhangs->top       = 0;
    overhangs->right     = 0;
    overhangs->bottom    = 0;
    return S_OK;
}

HRESULT InlineImage::LoadBitmapFromFile | ( | Microsoft::WRL::ComPtr< ID2D1DeviceContext > | deviceContext,
 |  | Microsoft::WRL::ComPtr< IWICImagingFactory > | IWICFactory,
 |  | PCWSTR | uri,
 |  | _Outptr_ ID2D1Bitmap ** | ppBitmap |
 | ) |  |  | [private]

Definition at line 86 of file InlineImage.cpp.

{
    HRESULT hr = S_OK;

    Microsoft::WRL::ComPtr<IWICBitmapDecoder> decoder;
    Microsoft::WRL::ComPtr<IWICBitmapFrameDecode> source;
    Microsoft::WRL::ComPtr<IWICFormatConverter> converter;

    hr = IWICFactory->CreateDecoderFromFilename(
        uri, nullptr, GENERIC_READ, WICDecodeMetadataCacheOnLoad, &decoder
        );

    // Create the initial frame.
    if (SUCCEEDED(hr))
    {
        hr = decoder->GetFrame(0, &source);
    }

    // Store the image size for later use.
    UINT imageWidth = 0, imageHeight = 0;

    source->GetSize(&imageWidth, &imageHeight);

    rect.left      = 0;
    rect.top       = 0;
    rect.right     = static_cast<FLOAT>(imageWidth);
    rect.bottom    = static_cast<FLOAT>(imageHeight);

    baseline       = static_cast<FLOAT>(imageHeight);

    // Convert the image format to 32bppPBGRA -- which Direct2D expects.
    if (SUCCEEDED(hr))
    {
        hr = IWICFactory->CreateFormatConverter(&converter);
    }

    if (SUCCEEDED(hr))
    {
        hr = converter->Initialize(
            source.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.f,
            WICBitmapPaletteTypeMedianCut
            );
    }

    // Create a Direct2D bitmap from the WIC bitmap.
    if (SUCCEEDED(hr))
    {
        hr = deviceContext.Get()->CreateBitmapFromWicBitmap(
            converter.Get(),
            nullptr,
            ppBitmap
            );
    }

    return hr;
}

STDMETHODIMP InlineImage::QueryInterface | ( | IID const & | riid,
 |  | void ** | ppvObject
 | ) |  |

Definition at line 156 of file InlineImage.cpp.

{
    if (__uuidof(IDWriteInlineObject) == riid)
    {
        *ppvObject = dynamic_cast<IDWriteInlineObject*>(this);
    }
    else if (__uuidof(IUnknown) == riid)
    {
        *ppvObject = dynamic_cast<IUnknown*>(this);
    }
    else
    {
        *ppvObject = nullptr;
        return E_FAIL;
    }

    return S_OK;
}

unsigned long STDMETHODCALLTYPE InlineImage::Release ( )

Member Data Documentation

float InlineImage::baseline [private]

Definition at line 66 of file InlineImage.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap> InlineImage::bitmap [private]

Definition at line 62 of file InlineImage.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> InlineImage::deviceContext [private]

Definition at line 63 of file InlineImage.h.

D2D1_RECT_F InlineImage::rect [private]

Definition at line 65 of file InlineImage.h.

unsigned long InlineImage::refCount [private]

Definition at line 68 of file InlineImage.h.

The documentation for this class was generated from the following files:
  • DirectWrite inline object/C++/InlineImage.h
  • DirectWrite inline object/C++/InlineImage.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IRenderer Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

IRenderer Interface Reference

#include "ManipulatableObject.h"

List of all members.

Public Member Functions

virtual void | RequestRedraw ()=0
virtual Windows::Foundation::Size | ViewSize ()=0

Detailed Description

Definition at line 10 of file ManipulatableObject.h.

Member Function Documentation

virtual void IRenderer::RequestRedraw ( ) [pure virtual]
virtual Windows::Foundation::Size IRenderer::ViewSize ( ) [pure virtual]
The documentation for this interface was generated from the following file:
  • Input Manipulations and gestures (C++)/C++/ManipulatableObject.h
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LanguageFontCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LanguageFontCPP
  • LanguageFontCPP::sealed
Public Member Functions | Static Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

LanguageFontCPP::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
Platform::String | ConvertResolution (Windows::Graphics::Display::ResolutionScale scale)
Platform::String | ConvertViewState (Windows::UI::ViewManagement::ApplicationViewState state)
void | DoNavigation (Windows::UI::Xaml::Interop::TypeName inPageType, Windows::UI::Xaml::Controls::Frame^inFrame, Windows::UI::Xaml::Interop::TypeName outPageType, Windows::UI::Xaml::Controls::Frame^outFrame)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
void | Reset (Windows::UI::Xaml::Controls::TextBlock^textBlock)
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()
void | Set (Windows::UI::Xaml::Controls::TextBlock^textBlock)

Static Public Member Functions

static void | SetFont (Windows::UI::Xaml::Controls::TextBlock^textBlock, Windows::Globalization::Fonts::LanguageFont^languageFont)

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~MainPage ()
~ScenarioInput1 ()
~ScenarioInput2 ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
void | ApplyFont_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ApplyFont_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CheckResolutionAndViewState ()
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | inputFrameNavigated (Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | outputFrameNavigated (Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | Page_Loaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | SetFeatureName (Platform::String^strFeature)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::UI::Xaml::Media::FontFamily | _fontFamily
Windows::UI::Text::FontStretch | _fontStretch
Windows::UI::Text::FontStyle | _fontStyle
Windows::UI::Text::FontWeight | _fontWeight
Windows::Foundation::EventRegistrationToken | _frameLoadedToken
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _layoutHandlerToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
FontInfoLocal | _oriHeadingUI
FontInfoLocal | _oriTextUI
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
MainPage | rootPage

Detailed Description

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

LanguageFontCPP::sealed::~MainPage ( ) [private]
LanguageFontCPP::sealed::~ScenarioInput1 ( ) [private]
LanguageFontCPP::sealed::~ScenarioInput2 ( ) [private]
LanguageFontCPP::sealed::~ScenarioList ( ) [private]
LanguageFontCPP::sealed::~ScenarioOutput1 ( ) [private]
LanguageFontCPP::sealed::~ScenarioOutput2 ( ) [private]

Member Function Documentation

LanguageFontCPP::sealed::App ( )
void LanguageFontCPP::sealed::ApplyFont_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::ApplyFont_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::CheckResolutionAndViewState ( ) [private]
Platform::String LanguageFontCPP::sealed::ConvertResolution ( Windows::Graphics::Display::ResolutionScale scale )
Platform::String LanguageFontCPP::sealed::ConvertViewState ( Windows::UI::ViewManagement::ApplicationViewState state )
void LanguageFontCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void LanguageFontCPP::sealed::DoNavigation | ( | Windows::UI::Xaml::Interop::TypeName | inPageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | inFrame,
 |  | Windows::UI::Xaml::Interop::TypeName | outPageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | outFrame
 | ) |  |
void LanguageFontCPP::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
LanguageFontCPP::sealed::MainPage ( )
void LanguageFontCPP::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void LanguageFontCPP::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LanguageFontCPP::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void LanguageFontCPP::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::Reset ( Windows::UI::Xaml::Controls::TextBlock^ textBlock )
void LanguageFontCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void LanguageFontCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
LanguageFontCPP::sealed::ScenarioInput1 ( )
LanguageFontCPP::sealed::ScenarioInput2 ( )
LanguageFontCPP::sealed::ScenarioList ( )
LanguageFontCPP::sealed::ScenarioOutput1 ( )
LanguageFontCPP::sealed::ScenarioOutput2 ( )
void LanguageFontCPP::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void LanguageFontCPP::sealed::Set ( Windows::UI::Xaml::Controls::TextBlock^ textBlock )
void LanguageFontCPP::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
static void LanguageFontCPP::sealed::SetFont | ( | Windows::UI::Xaml::Controls::TextBlock^ | textBlock,
 |  | Windows::Globalization::Fonts::LanguageFont^ | languageFont |
 | ) |  |  | [static]

Member Data Documentation

Windows::Foundation::EventRegistrationToken LanguageFontCPP::sealed::_displayHandlerToken [private]

Definition at line 59 of file MainPage.xaml.h.

Windows::UI::Xaml::Media::FontFamily LanguageFontCPP::sealed::_fontFamily [private]

Definition at line 26 of file LocalCache.h.

Windows::UI::Text::FontStretch LanguageFontCPP::sealed::_fontStretch [private]

Definition at line 29 of file LocalCache.h.

Windows::UI::Text::FontStyle LanguageFontCPP::sealed::_fontStyle [private]

Definition at line 28 of file LocalCache.h.

Windows::UI::Text::FontWeight LanguageFontCPP::sealed::_fontWeight [private]

Definition at line 27 of file LocalCache.h.

Windows::Foundation::EventRegistrationToken sealed::_frameLoadedToken [private]

Definition at line 35 of file ScenarioInput1.xaml.h.

Windows::UI::Xaml::Controls::Frame LanguageFontCPP::sealed::_inputFrame [private]

Definition at line 56 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LanguageFontCPP::sealed::_inputFrameLoadedToken [private]

Definition at line 63 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LanguageFontCPP::sealed::_layoutHandlerToken [private]

Definition at line 60 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LanguageFontCPP::sealed::_logicalDpiChangedToken [private]

Definition at line 62 of file MainPage.xaml.h.

FontInfoLocal sealed::_oriHeadingUI [private]

Definition at line 37 of file ScenarioInput1.xaml.h.

FontInfoLocal sealed::_oriTextUI [private]

Definition at line 38 of file ScenarioInput1.xaml.h.

Windows::UI::Xaml::Controls::Frame LanguageFontCPP::sealed::_outputFrame [private]

Definition at line 57 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LanguageFontCPP::sealed::_outputFrameLoadedToken [private]

Definition at line 64 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LanguageFontCPP::sealed::_pageLoadedHandlerToken [private]

Definition at line 61 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame LanguageFontCPP::sealed::_scenariosFrame [private]

Definition at line 55 of file MainPage.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 32 of file ScenarioInput1.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> LanguageFontCPP::sealed::OutputFrameLoaded

Definition at line 45 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Language font mapping/C++/App.xaml.h
  • Language font mapping/C++/LocalCache.h
  • Language font mapping/C++/MainPage.xaml.h
  • Language font mapping/C++/ScenarioInput1.xaml.h
  • Language font mapping/C++/ScenarioInput2.xaml.h
  • Language font mapping/C++/ScenarioList.xaml.h
  • Language font mapping/C++/ScenarioOutput1.xaml.h
  • Language font mapping/C++/ScenarioOutput2.xaml.h
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Layer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Layer Class Reference

#include "Layer.h"

Inherits Element.

List of all members.

Public Member Functions

virtual bool | AcceptChildNode (_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override
virtual float | GetOpacity () override

Public Attributes

internal | __pad0__: Layer()

Private Attributes

float | m_currentOpacity
float | m_initialOpacity

Detailed Description

Definition at line 19 of file Layer.h.

Member Function Documentation

virtual bool Layer::AcceptChildNode | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::IXmlNode^ | childXmlNode |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

virtual float Layer::GetOpacity ( ) [inline, override, virtual]

Reimplemented from Element.

Definition at line 29 of file Layer.h.

    {
        return m_currentOpacity;
    }

Member Data Documentation

internal Layer::__pad0__

Reimplemented from Element.

Definition at line 22 of file Layer.h.

float Layer::m_currentOpacity [private]

Definition at line 39 of file Layer.h.

float Layer::m_initialOpacity [private]

Definition at line 36 of file Layer.h.

The documentation for this class was generated from the following file:
  • Direct2D magazine app/C++/Layer.h
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Level1 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Level1 Class Reference

#include "Level1.h"

Inherited by Level2, and Level2.

List of all members.

Public Member Functions

virtual void | Initialize (std::vector< GameObject^> objects) override
virtual void | Initialize (std::vector< GameObject^> objects) override

Public Attributes

internal | __pad0__: Level1()

Detailed Description

Definition at line 16 of file Level1.h.

Member Function Documentation

void Level1::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented in Level2, and Level2.

Definition at line 24 of file Level1.cpp.

{
    XMFLOAT3 position[] =
    {
        XMFLOAT3(-2.5f, -1.0f, -1.5f),
        XMFLOAT3(-1.0f,  1.0f, -3.0f),
        XMFLOAT3( 1.5f,  0.0f, -3.0f),
        XMFLOAT3(-2.5f, -1.0f, -5.5f),
        XMFLOAT3( 0.5f, -2.0f, -5.0f),
        XMFLOAT3( 1.5f, -2.0f, -5.5f),
        XMFLOAT3( 2.0f,  0.0f,  0.0f),
        XMFLOAT3( 0.0f,  0.0f,  0.0f),
        XMFLOAT3(-2.0f,  0.0f,  0.0f)
    };

    int targetCount = 0;
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if (Face^ target = dynamic_cast<Face^>(*object))
        {
            if (targetCount < 9)
            {
                target->Active(true);
                target->Target(true);
                target->Hit(false);
                target->AnimatePosition(nullptr);
                target->Position(position[targetCount]);
                targetCount++;
            }
            else
            {
                (*object)->Active(false);
            }
        }
        else
        {
            (*object)->Active(false);
        }
    }
}

virtual void Level1::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented in Level2, and Level2.

Member Data Documentation

internal Level1::__pad0__

Reimplemented in Level2.

Definition at line 19 of file Level1.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Level1.h
  • XAML DirectX 3D shooting game/C++/Level1.h
  • DirectX 3D shooting game/C++/Level1.cpp
  • XAML DirectX 3D shooting game/C++/Level1.cpp
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Level2 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Level2 Class Reference

#include "Level2.h"

Inherits Level1, and Level1.

List of all members.

Public Member Functions

virtual void | Initialize (std::vector< GameObject^> objects) override
virtual void | Initialize (std::vector< GameObject^> objects) override
virtual void | LoadState (PersistentState^state) override
virtual void | LoadState (PersistentState^state) override
virtual void | SaveState (PersistentState^state) override
virtual void | SaveState (PersistentState^state) override
virtual bool | Update (float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override
virtual bool | Update (float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override

Public Attributes

internal | __pad0__: Level2()

Private Attributes

int | m_nextId

Detailed Description

Definition at line 16 of file Level2.h.

Member Function Documentation

void Level2::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented from Level1.

Definition at line 22 of file Level2.cpp.

{
    Level1::Initialize(objects);

    int targetCount = 0;
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if (Face^ target = dynamic_cast<Face^>(*object))
        {
            if (targetCount < 9)
            {
                target->Target(targetCount == 0 ? true : false);
                targetCount++;
            }
        }
    }
    m_nextId = 1;
}

virtual void Level2::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented from Level1.

virtual void Level2::LoadState ( PersistentState^ state ) [override, virtual]
void Level2::LoadState ( PersistentState^ state ) [override, virtual]

Definition at line 82 of file Level2.cpp.

{
    m_nextId = state->LoadInt32(":NextTarget", 1);
}

virtual void Level2::SaveState ( PersistentState^ state ) [override, virtual]
void Level2::SaveState ( PersistentState^ state ) [override, virtual]

Definition at line 75 of file Level2.cpp.

{
    state->SaveInt32(":NextTarget", m_nextId);
}

bool Level2::Update | ( | float | time,
 |  | float | elapsedTime,
 |  | float | timeRemaining,
 |  | std::vector< GameObject^> | objects |
 | ) |  |  | [override, virtual]

Definition at line 43 of file Level2.cpp.

{
    int left = 0;
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if ((*object)->Active() && ((*object)->TargetId() > 0))
        {
            if ((*object)->Hit()  && ((*object)->TargetId() == m_nextId))
            {
                (*object)->Active(false);
                m_nextId++;
            }
            else
            {
                left++;
            }
        }
        if ((*object)->Active() && ((*object)->TargetId() == m_nextId))
        {
            (*object)->Target(true);
        }
    }
    return (left == 0);
}

virtual bool Level2::Update | ( | float | time,
 |  | float | elapsedTime,
 |  | float | timeRemaining,
 |  | std::vector< GameObject^> | objects |
 | ) |  |  | [override, virtual]

Member Data Documentation

internal Level2::__pad0__

Reimplemented from Level1.

Definition at line 19 of file Level2.h.

int Level2::m_nextId [private]

Definition at line 33 of file Level2.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Level2.h
  • XAML DirectX 3D shooting game/C++/Level2.h
  • DirectX 3D shooting game/C++/Level2.cpp
  • XAML DirectX 3D shooting game/C++/Level2.cpp
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Level3 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Level3 Class Reference

#include "Level3.h"

Inherited by Level4, Level4, Level5, and Level5.

List of all members.

Public Member Functions

virtual void | Initialize (std::vector< GameObject^> objects) override
virtual void | Initialize (std::vector< GameObject^> objects) override

Public Attributes

internal | __pad0__: Level3()

Detailed Description

Definition at line 17 of file Level3.h.

Member Function Documentation

void Level3::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented in Level4, Level5, Level4, and Level5.

Definition at line 25 of file Level3.cpp.

{
    XMFLOAT3 position[] =
    {
        XMFLOAT3(-2.5f, -1.0f, -1.5f),
        XMFLOAT3(-1.0f,  1.0f, -3.0f),
        XMFLOAT3( 1.5f,  0.0f, -5.5f),
        XMFLOAT3(-2.5f, -1.0f, -5.5f),
        XMFLOAT3( 0.5f, -2.0f, -5.0f),
        XMFLOAT3( 1.5f, -2.0f, -5.5f),
        XMFLOAT3( 0.0f, -3.6f,  0.0f),
        XMFLOAT3( 0.0f, -3.6f,  0.0f),
        XMFLOAT3( 0.0f, -3.6f,  0.0f)
    };
    XMFLOAT3 LineList1[] =
    {
        XMFLOAT3(-2.5f, -1.0f, -1.5f),
        XMFLOAT3(-0.5f,  1.0f,  1.0f),
        XMFLOAT3(-0.5f, -2.5f,  1.0f),
        XMFLOAT3(-2.5f, -1.0f, -1.5f),
    };
    XMFLOAT3 LineList2[] =
    {
        XMFLOAT3(-1.0f,  1.0f, -3.0f),
        XMFLOAT3(-2.0f,  2.0f, -1.5f),
        XMFLOAT3(-2.0f, -2.5f, -1.5f),
        XMFLOAT3( 1.5f, -2.5f, -1.5f),
        XMFLOAT3( 1.5f, -2.5f, -3.0f),
        XMFLOAT3(-1.0f,  1.0f, -3.0f),
    };
    XMFLOAT3 LineList3[] =
    {
        XMFLOAT3(1.5f,  0.0f, -5.5f),
        XMFLOAT3(1.5f,  1.0f, -5.5f),
        XMFLOAT3(1.5f, -2.5f, -5.5f),
        XMFLOAT3(1.5f,  0.0f, -5.5f),
    };
    XMFLOAT3 LineList4[] =
    {
        XMFLOAT3(-2.5f, -1.0f, -5.5f),
        XMFLOAT3( 1.0f, -1.0f, -5.5f),
        XMFLOAT3( 1.0f,  1.0f, -5.5f),
        XMFLOAT3(-2.5f,  1.0f, -5.5f),
        XMFLOAT3(-2.5f, -1.0f, -5.5f),
    };
    XMFLOAT3 LineList5[] =
    {
        XMFLOAT3( 0.5f, -2.0f, -5.0f),
        XMFLOAT3( 2.0f, -2.0f, -5.0f),
        XMFLOAT3( 2.0f,  1.0f, -5.0f),
        XMFLOAT3(-2.5f,  1.0f, -5.0f),
        XMFLOAT3(-2.5f, -2.0f, -5.0f),
        XMFLOAT3( 0.5f, -2.0f, -5.0f),
    };
    XMFLOAT3 LineList6[] =
    {
        XMFLOAT3( 1.5f, -2.0f, -5.5f),
        XMFLOAT3(-2.5f, -2.0f, -5.5f),
        XMFLOAT3(-2.5f,  1.0f, -5.5f),
        XMFLOAT3( 1.5f,  1.0f, -5.5f),
        XMFLOAT3( 1.5f, -2.0f, -5.5f),
    };

    int targetCount = 0;
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if (Face^ target = dynamic_cast<Face^>(*object))
        {
            if (targetCount < 9)
            {
                target->Active(true);
                target->Target(true);
                target->Hit(false);
                target->Position(position[targetCount]);
                switch (targetCount)
                {
                case 0:
                    target->AnimatePosition(ref new AnimateLineListPosition(4, LineList1, 10.0f, true));
                    break;
                case 1:
                    target->AnimatePosition(ref new AnimateLineListPosition(6, LineList2, 15.0f, true));
                    break;
                case 2:
                    target->AnimatePosition(ref new AnimateLineListPosition(4, LineList3, 15.0f, true));
                    break;
                case 3:
                    target->AnimatePosition(ref new AnimateLineListPosition(5, LineList4, 15.0f, true));
                    break;
                case 4:
                    target->AnimatePosition(ref new AnimateLineListPosition(6, LineList5, 15.0f, true));
                    break;
                case 5:
                    target->AnimatePosition(ref new AnimateLineListPosition(5, LineList6, 15.0f, true));
                    break;
                case 6:
                    target->AnimatePosition(
                        ref new AnimateCirclePosition(
                            XMFLOAT3(0.0f, -2.5f, 0.0f),
                            XMFLOAT3(0.0f, -3.6f, 0.0f),
                            XMFLOAT3(0.0f,  0.0f, 1.0f),
                            9.0f,
                            true,
                            true
                            )
                        );
                    break;
                case 7:
                    target->AnimatePosition(
                        ref new AnimateCirclePosition(
                            XMFLOAT3(0.0f, -2.5f, 0.0f),
                            XMFLOAT3(0.0f, -3.6f, 0.0f),
                            XMFLOAT3(0.0f,  0.0f, 1.0f),
                            9.0f,
                            true,
                            true
                            )
                        );
                    target->AnimatePosition()->Start(3.0f);
                    break;
                case 8:
                    target->AnimatePosition(
                        ref new AnimateCirclePosition(
                            XMFLOAT3(0.0f, -2.5f, 0.0f),
                            XMFLOAT3(0.0f, -3.6f, 0.0f),
                            XMFLOAT3(0.0f,  0.0f, 1.0f),
                            9.0f,
                            true,
                            true
                            )
                        );
                    target->AnimatePosition()->Start(6.0f);
                    break;
                }
                targetCount++;
            }
            else
            {
                target->Active(false);
            }
        }
        else
        {
            (*object)->Active(false);
        }
    }
}

virtual void Level3::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented in Level4, Level5, Level4, and Level5.

Member Data Documentation

internal Level3::__pad0__

Reimplemented in Level4, Level5, and Level6.

Definition at line 20 of file Level3.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Level3.h
  • XAML DirectX 3D shooting game/C++/Level3.h
  • DirectX 3D shooting game/C++/Level3.cpp
  • XAML DirectX 3D shooting game/C++/Level3.cpp
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Level4 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Level4 Class Reference

#include "Level4.h"

Inherits Level3, and Level3.

List of all members.

Public Member Functions

virtual void | Initialize (std::vector< GameObject^> objects) override
virtual void | Initialize (std::vector< GameObject^> objects) override
virtual void | LoadState (PersistentState^state) override
virtual void | LoadState (PersistentState^state) override
virtual void | SaveState (PersistentState^state) override
virtual void | SaveState (PersistentState^state) override
virtual bool | Update (float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override
virtual bool | Update (float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override

Public Attributes

internal | __pad0__: Level4()

Private Attributes

int | m_nextId

Detailed Description

Definition at line 16 of file Level4.h.

Member Function Documentation

void Level4::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented from Level3.

Definition at line 22 of file Level4.cpp.

{
    Level3::Initialize(objects);

    int targetCount = 0;
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if (Face^ target = dynamic_cast<Face^>(*object))
        {
            if (targetCount < 9)
            {
                target->Target(targetCount == 0 ? true : false);
                targetCount++;
            }
        }
    }
    m_nextId = 1;
}

virtual void Level4::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented from Level3.

virtual void Level4::LoadState ( PersistentState^ state ) [override, virtual]
void Level4::LoadState ( PersistentState^ state ) [override, virtual]

Definition at line 82 of file Level4.cpp.

{
    m_nextId = state->LoadInt32(":NextTarget", 1);
}

virtual void Level4::SaveState ( PersistentState^ state ) [override, virtual]
void Level4::SaveState ( PersistentState^ state ) [override, virtual]

Definition at line 75 of file Level4.cpp.

{
    state->SaveInt32(":NextTarget", m_nextId);
}

bool Level4::Update | ( | float | time,
 |  | float | elapsedTime,
 |  | float | timeRemaining,
 |  | std::vector< GameObject^> | objects |
 | ) |  |  | [override, virtual]

Definition at line 43 of file Level4.cpp.

{
    int left = 0;
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if ((*object)->Active() && ((*object)->TargetId() > 0))
        {
            if ((*object)->Hit() && ((*object)->TargetId() == m_nextId))
            {
                (*object)->Active(false);
                m_nextId++;
            }
            else
            {
                left++;
            }
        }
        if ((*object)->Active() && ((*object)->TargetId() == m_nextId))
        {
            (*object)->Target(true);
        }
    }
    return (left == 0);
}

virtual bool Level4::Update | ( | float | time,
 |  | float | elapsedTime,
 |  | float | timeRemaining,
 |  | std::vector< GameObject^> | objects |
 | ) |  |  | [override, virtual]

Member Data Documentation

internal Level4::__pad0__

Reimplemented from Level3.

Definition at line 19 of file Level4.h.

int Level4::m_nextId [private]

Definition at line 33 of file Level4.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Level4.h
  • XAML DirectX 3D shooting game/C++/Level4.h
  • DirectX 3D shooting game/C++/Level4.cpp
  • XAML DirectX 3D shooting game/C++/Level4.cpp
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Level5 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Level5 Class Reference

#include "Level5.h"

Inherits Level3, and Level3.

Inherited by Level6, and Level6.

List of all members.

Public Member Functions

virtual void | Initialize (std::vector< GameObject^> objects) override
virtual void | Initialize (std::vector< GameObject^> objects) override

Public Attributes

internal | __pad0__: Level5()

Detailed Description

Definition at line 17 of file Level5.h.

Member Function Documentation

void Level5::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented from Level3.

Definition at line 25 of file Level5.cpp.

{
    Level3::Initialize(objects);

    XMFLOAT3 obstacleStartPosition[] =
    {
        XMFLOAT3(-4.5f, -3.0f, 0.0f),
        XMFLOAT3(4.5f, -3.0f, 0.0f),
        XMFLOAT3(0.0f, 3.01f, -2.0f),
        XMFLOAT3(-1.5f, -3.0f, -6.5f),
        XMFLOAT3(1.5f, -3.0f, -6.5f)
    };
    XMFLOAT3 obstacleEndPosition[] =
    {
        XMFLOAT3(-2.0f, -3.0f, 0.0f),
        XMFLOAT3(2.0f, -3.0f, 0.0f),
        XMFLOAT3(0.0f, -3.0f, -2.0f),
        XMFLOAT3(-1.5f, -3.0f, -4.0f),
        XMFLOAT3(1.5f, -3.0f, -4.0f)
    };
    float obstacleStartTime[] =
    {
        2.0f,
        5.0f,
        8.0f,
        11.0f,
        14.0f
    };

    int obstacleCount = 0;
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if (Cylinder^ obstacle = dynamic_cast<Cylinder^>(*object))
        {
            if (obstacleCount < 5)
            {
                obstacle->Active(true);
                obstacle->Position(obstacleStartPosition[obstacleCount]);
                obstacle->AnimatePosition(
                    ref new AnimateLinePosition(
                        obstacleStartPosition[obstacleCount],
                        obstacleEndPosition[obstacleCount],
                        10.0,
                        false
                        )
                    );
                obstacle->AnimatePosition()->Start(obstacleStartTime[obstacleCount]);
                obstacleCount ++;
            }
        }
    }
}

virtual void Level5::Initialize ( std::vector< GameObject^> objects ) [override, virtual]

Reimplemented from Level3.

Member Data Documentation

internal Level5::__pad0__

Reimplemented from Level3.

Reimplemented in Level6.

Definition at line 20 of file Level5.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Level5.h
  • XAML DirectX 3D shooting game/C++/Level5.h
  • DirectX 3D shooting game/C++/Level5.cpp
  • XAML DirectX 3D shooting game/C++/Level5.cpp
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Level6 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Level6 Class Reference

#include "Level6.h"

Inherits Level5, and Level5.

List of all members.

Public Member Functions

virtual bool | Update (float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override
virtual bool | Update (float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override

Public Attributes

internal | __pad0__: Level6()

Detailed Description

Definition at line 18 of file Level6.h.

Member Function Documentation

bool Level6::Update | ( | float | time,
 |  | float | elapsedTime,
 |  | float | timeRemaining,
 |  | std::vector< GameObject^> | objects |
 | ) |  |  | [override, virtual]

Definition at line 21 of file Level6.cpp.

{
    for (auto object = objects.begin(); object != objects.end(); object++)
    {
        if ((*object)->Active() && (*object)->Target())
        {
            if ((*object)->Hit() && ((*object)->HitTime() < (time - 2.0f)))
            {
                (*object)->Hit(false);
            }
        }
    }
    return ((timeRemaining - elapsedTime) <= 0.0f);
}

virtual bool Level6::Update | ( | float | time,
 |  | float | elapsedTime,
 |  | float | timeRemaining,
 |  | std::vector< GameObject^> | objects |
 | ) |  |  | [override, virtual]

Member Data Documentation

internal Level6::__pad0__

Reimplemented from Level5.

Definition at line 21 of file Level6.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Level6.h
  • XAML DirectX 3D shooting game/C++/Level6.h
  • DirectX 3D shooting game/C++/Level6.cpp
  • XAML DirectX 3D shooting game/C++/Level6.cpp
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LinearAnimation< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions

LinearAnimation< T > Class Template Reference

#include "animation.h"

Inherits Animation< T >.

List of all members.

Public Member Functions

LinearAnimation (T start=0, T end=0, T duration=0)

Protected Member Functions

virtual T ComputeValue (T time)

Detailed Description

template<class T>
class LinearAnimation< T >

Definition at line 80 of file animation.h.

Constructor & Destructor Documentation

template<class T >
LinearAnimation< T >::LinearAnimation | ( | T | start = 0,
 |  | T | end = 0,
 |  | T | duration = 0 |
 | ) |  |  | [inline]

Definition at line 83 of file animation.h.

                                                            :
        Animation(start, end, duration)
    {
    }

Member Function Documentation

template<class T >
virtual T LinearAnimation< T >::ComputeValue ( T time ) [inline, protected, virtual]

Implements Animation< T >.

Definition at line 88 of file animation.h.

    {
        return m_Start + ((m_End - m_Start) * (time / m_Duration));
    }

The documentation for this class was generated from the following file:
  • Direct2D animation/C++/animation.h
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LineSegment Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

LineSegment Struct Reference

#include "Animate.h"

List of all members.

Public Attributes

float | length
DirectX::XMFLOAT3 | position
float | uLength
float | uStart

Detailed Description

Definition at line 71 of file Animate.h.

Member Data Documentation

float LineSegment::length

Definition at line 74 of file Animate.h.

DirectX::XMFLOAT3 LineSegment::position

Definition at line 73 of file Animate.h.

float LineSegment::uLength

Definition at line 76 of file Animate.h.

float LineSegment::uStart

Definition at line 75 of file Animate.h.

The documentation for this struct was generated from the following files:
  • DirectX 3D shooting game/C++/Animate.h
  • XAML DirectX 3D shooting game/C++/Animate.h
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: List< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Private Attributes

List< T > Class Template Reference

#include "List.h"

Inherits Rectangle.

List of all members.

Classes

struct | Node
class | POSITION

Public Member Functions

List ()
List ()
List ()
virtual | ~List ()
virtual | ~List ()
virtual | ~List ()
virtual bool | AcceptChildNode (_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override
template<class FN >
void | Clear (FN &clear_fn)
virtual void | Clear ()
template<class FN >
void | Clear (FN &clear_fn)
virtual void | Clear ()
template<class FN >
void | Clear (FN &clear_fn)
virtual void | Clear ()
virtual bool | Draw (_In_ Document^document, D2D1::Matrix3x2F const &transform) override
POSITION | EndPosition () const
POSITION | EndPosition () const
POSITION | EndPosition () const
POSITION FrontPosition ()
POSITION FrontPosition ()
POSITION FrontPosition ()
HRESULT | GetBack (T *ppItem)
HRESULT | GetBack (T *ppItem)
HRESULT | GetBack (T *ppItem)
DWORD | GetCount () const
DWORD | GetCount () const
DWORD | GetCount () const
HRESULT | GetFront (T *ppItem)
HRESULT | GetFront (T *ppItem)
HRESULT | GetFront (T *ppItem)
HRESULT | GetItemPos (POSITION pos, T *ppItem)
HRESULT | GetItemPos (POSITION pos, T *ppItem)
HRESULT | GetItemPos (POSITION pos, T *ppItem)
virtual bool | Initialize (_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override
HRESULT | InsertBack (T item)
HRESULT | InsertBack (T item)
HRESULT | InsertBack (T item)
HRESULT | InsertFront (T item)
HRESULT | InsertFront (T item)
HRESULT | InsertFront (T item)
HRESULT | InsertPos (POSITION pos, T item)
HRESULT | InsertPos (POSITION pos, T item)
HRESULT | InsertPos (POSITION pos, T item)
bool | IsEmpty () const
bool | IsEmpty () const
bool | IsEmpty () const
virtual void | Measure (_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override
POSITION | Next (const POSITION pos)
POSITION | Next (const POSITION pos)
POSITION | Next (const POSITION pos)
HRESULT | Remove (POSITION &pos, T *ppItem)
HRESULT | Remove (POSITION &pos, T *ppItem)
HRESULT | Remove (POSITION &pos, T *ppItem)
HRESULT | RemoveBack (T *ppItem)
HRESULT | RemoveBack (T *ppItem)
HRESULT | RemoveBack (T *ppItem)
HRESULT | RemoveFront (T *ppItem)
HRESULT | RemoveFront (T *ppItem)
HRESULT | RemoveFront (T *ppItem)

Public Attributes

internal | __pad0__: List()

Protected Member Functions

Node * | Back () const
Node * | Back () const
Node * | Back () const
Node * | Front () const
Node * | Front () const
Node * | Front () const
virtual HRESULT | GetItem (const Node *pNode, T *ppItem)
virtual HRESULT | GetItem (const Node *pNode, T *ppItem)
virtual HRESULT | GetItem (const Node *pNode, T *ppItem)
virtual HRESULT | InsertAfter (T item, Node *pBefore)
virtual HRESULT | InsertAfter (T item, Node *pBefore)
virtual HRESULT | InsertAfter (T item, Node *pBefore)
virtual HRESULT | RemoveItem (Node *pNode, T *ppItem)
virtual HRESULT | RemoveItem (Node *pNode, T *ppItem)
virtual HRESULT | RemoveItem (Node *pNode, T *ppItem)

Protected Attributes

Node m_anchor
DWORD | m_count

Private Attributes

float | m_margin

Detailed Description

template<class T>
class List< T >

Definition at line 22 of file List.h.

Constructor & Destructor Documentation

template<class T>
List< T >::List ( ) [inline]

Definition at line 189 of file LinkList.h.

    {
        m_anchor.next = &m_anchor;
        m_anchor.prev = &m_anchor;

        m_count = 0;
    }

template<class T>
virtual List< T >::~List ( ) [inline, virtual]

Definition at line 197 of file LinkList.h.

    {
        Clear();
    }

template<class T>
List< T >::List ( ) [inline]

Definition at line 189 of file LinkList.h.

    {
        m_anchor.next = &m_anchor;
        m_anchor.prev = &m_anchor;

        m_count = 0;
    }

template<class T>
virtual List< T >::~List ( ) [inline, virtual]

Definition at line 197 of file LinkList.h.

    {
        Clear();
    }

template<class T>
List< T >::List ( ) [inline]

Definition at line 189 of file LinkList.h.

    {
        m_anchor.next = &m_anchor;
        m_anchor.prev = &m_anchor;

        m_count = 0;
    }

template<class T>
virtual List< T >::~List ( ) [inline, virtual]

Definition at line 197 of file LinkList.h.

    {
        Clear();
    }

Member Function Documentation

template<class T>
virtual bool List< T >::AcceptChildNode | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::IXmlNode^ | childXmlNode |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

template<class T>
Node* List< T >::Back ( ) const [inline, protected]

Definition at line 107 of file LinkList.h.

    {
        return m_anchor.prev;
    }

template<class T>
Node* List< T >::Back ( ) const [inline, protected]

Definition at line 107 of file LinkList.h.

    {
        return m_anchor.prev;
    }

template<class T>
Node* List< T >::Back ( ) const [inline, protected]

Definition at line 107 of file LinkList.h.

    {
        return m_anchor.prev;
    }

template<class T>
template<class FN >
void List< T >::Clear ( FN & clear_fn ) [inline]

Definition at line 290 of file LinkList.h.

    {
        Node *n = m_anchor.next;

        // Delete the nodes
        while (n != &m_anchor)
        {
            clear_fn(n->item);

            Node *tmp = n->next;
            delete n;
            n = tmp;
        }

        // Reset the anchor to point at itself
        m_anchor.next = &m_anchor;
        m_anchor.prev = &m_anchor;

        m_count = 0;
    }

template<class T>
virtual void List< T >::Clear ( ) [inline, virtual]

Reimplemented in ComPtrList< T, NULLABLE >, ComPtrList< T, NULLABLE >, ComPtrList< T, NULLABLE >, ComPtrList< IUnknown, true >, ComPtrList< IUnknown, true >, ComPtrList< IUnknown, true >, ComPtrList< TOperation >, ComPtrList< TOperation >, ComPtrList< TOperation >, ComPtrList< SourceOp >, ComPtrList< SourceOp >, ComPtrList< SourceOp >, ComPtrList< IMFSample >, ComPtrList< IMFSample >, and ComPtrList< IMFSample >.

Definition at line 312 of file LinkList.h.

    {
        NoOp<T> clearOp;
        Clear<>(clearOp);
    }

template<class T>
template<class FN >
void List< T >::Clear ( FN & clear_fn ) [inline]

Definition at line 290 of file LinkList.h.

    {
        Node *n = m_anchor.next;

        // Delete the nodes
        while (n != &m_anchor)
        {
            clear_fn(n->item);

            Node *tmp = n->next;
            delete n;
            n = tmp;
        }

        // Reset the anchor to point at itself
        m_anchor.next = &m_anchor;
        m_anchor.prev = &m_anchor;

        m_count = 0;
    }

template<class T>
virtual void List< T >::Clear ( ) [inline, virtual]

Reimplemented in ComPtrList< T, NULLABLE >, ComPtrList< T, NULLABLE >, ComPtrList< T, NULLABLE >, ComPtrList< IUnknown, true >, ComPtrList< IUnknown, true >, ComPtrList< IUnknown, true >, ComPtrList< TOperation >, ComPtrList< TOperation >, ComPtrList< TOperation >, ComPtrList< SourceOp >, ComPtrList< SourceOp >, ComPtrList< SourceOp >, ComPtrList< IMFSample >, ComPtrList< IMFSample >, and ComPtrList< IMFSample >.

Definition at line 312 of file LinkList.h.

    {
        NoOp<T> clearOp;
        Clear<>(clearOp);
    }

template<class T>
template<class FN >
void List< T >::Clear ( FN & clear_fn ) [inline]

Definition at line 290 of file LinkList.h.

    {
        Node *n = m_anchor.next;

        // Delete the nodes
        while (n != &m_anchor)
        {
            clear_fn(n->item);

            Node *tmp = n->next;
            delete n;
            n = tmp;
        }

        // Reset the anchor to point at itself
        m_anchor.next = &m_anchor;
        m_anchor.prev = &m_anchor;

        m_count = 0;
    }

template<class T>
virtual void List< T >::Clear ( ) [inline, virtual]

Reimplemented in ComPtrList< T, NULLABLE >, ComPtrList< T, NULLABLE >, ComPtrList< T, NULLABLE >, ComPtrList< IUnknown, true >, ComPtrList< IUnknown, true >, ComPtrList< IUnknown, true >, ComPtrList< TOperation >, ComPtrList< TOperation >, ComPtrList< TOperation >, ComPtrList< SourceOp >, ComPtrList< SourceOp >, ComPtrList< SourceOp >, ComPtrList< IMFSample >, ComPtrList< IMFSample >, and ComPtrList< IMFSample >.

Definition at line 312 of file LinkList.h.

    {
        NoOp<T> clearOp;
        Clear<>(clearOp);
    }

template<class T>
bool List< T >::Draw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [override, virtual]

Reimplemented from Rectangle.

Definition at line 143 of file List.cpp.

{
    Rectangle::Draw(document, transform);

    float offsetY = 0;

    Element^ child = GetFirstChild();

    while (child)
    {
        if (child->Draw(
            document,
            D2D1::Matrix3x2F::Translation(m_offset.x + m_margin, m_offset.y + m_margin + offsetY) * transform
            ))
        {
            return true;
        }

        offsetY += child->GetSize().height;

        child = child->GetNextSibling();
    }

    return false;
}

template<class T>
POSITION List< T >::EndPosition ( ) const [inline]

Definition at line 333 of file LinkList.h.

    {
        return POSITION();
    }

template<class T>
POSITION List< T >::EndPosition ( ) const [inline]

Definition at line 333 of file LinkList.h.

    {
        return POSITION();
    }

template<class T>
POSITION List< T >::EndPosition ( ) const [inline]

Definition at line 333 of file LinkList.h.

    {
        return POSITION();
    }

template<class T>
Node* List< T >::Front ( ) const [inline, protected]

Definition at line 102 of file LinkList.h.

    {
        return m_anchor.next;
    }

template<class T>
Node* List< T >::Front ( ) const [inline, protected]

Definition at line 102 of file LinkList.h.

    {
        return m_anchor.next;
    }

template<class T>
Node* List< T >::Front ( ) const [inline, protected]

Definition at line 102 of file LinkList.h.

    {
        return m_anchor.next;
    }

template<class T>
POSITION List< T >::FrontPosition ( ) [inline]

Definition at line 321 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return POSITION(nullptr);
        }
        else
        {
            return POSITION(Front());
        }
    }

template<class T>
POSITION List< T >::FrontPosition ( ) [inline]

Definition at line 321 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return POSITION(nullptr);
        }
        else
        {
            return POSITION(Front());
        }
    }

template<class T>
POSITION List< T >::FrontPosition ( ) [inline]

Definition at line 321 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return POSITION(nullptr);
        }
        else
        {
            return POSITION(Front());
        }
    }

template<class T>
HRESULT List< T >::GetBack ( T * ppItem ) [inline]

Definition at line 253 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return GetItem(Back(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::GetBack ( T * ppItem ) [inline]

Definition at line 253 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return GetItem(Back(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::GetBack ( T * ppItem ) [inline]

Definition at line 253 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return GetItem(Back(), ppItem);
        }
    }

template<class T>
DWORD List< T >::GetCount ( ) const [inline]

Definition at line 280 of file LinkList.h.

{ return m_count; }

template<class T>
DWORD List< T >::GetCount ( ) const [inline]

Definition at line 280 of file LinkList.h.

{ return m_count; }

template<class T>
DWORD List< T >::GetCount ( ) const [inline]

Definition at line 280 of file LinkList.h.

{ return m_count; }

template<class T>
HRESULT List< T >::GetFront ( T * ppItem ) [inline]

Definition at line 266 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return GetItem(Front(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::GetFront ( T * ppItem ) [inline]

Definition at line 266 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return GetItem(Front(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::GetFront ( T * ppItem ) [inline]

Definition at line 266 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return GetItem(Front(), ppItem);
        }
    }

template<class T>
virtual HRESULT List< T >::GetItem | ( | const Node * | pNode,
 |  | T * | ppItem |
 | ) |  |  | [inline, protected, virtual]

Definition at line 138 of file LinkList.h.

    {
        if (pNode == nullptr || ppItem == nullptr)
        {
            return E_POINTER;
        }

        *ppItem = pNode->item;
        return S_OK;
    }

template<class T>
virtual HRESULT List< T >::GetItem | ( | const Node * | pNode,
 |  | T * | ppItem |
 | ) |  |  | [inline, protected, virtual]

Definition at line 138 of file LinkList.h.

    {
        if (pNode == nullptr || ppItem == nullptr)
        {
            return E_POINTER;
        }

        *ppItem = pNode->item;
        return S_OK;
    }

template<class T>
virtual HRESULT List< T >::GetItem | ( | const Node * | pNode,
 |  | T * | ppItem |
 | ) |  |  | [inline, protected, virtual]

Definition at line 138 of file LinkList.h.

    {
        if (pNode == nullptr || ppItem == nullptr)
        {
            return E_POINTER;
        }

        *ppItem = pNode->item;
        return S_OK;
    }

template<class T>
HRESULT List< T >::GetItemPos | ( | POSITION | pos,
 |  | T * | ppItem |
 | ) |  |  | [inline]

Definition at line 338 of file LinkList.h.

    {
        if (pos.pNode)
        {
            return GetItem(pos.pNode, ppItem);
        }
        else
        {
            return E_FAIL;
        }
    }

template<class T>
HRESULT List< T >::GetItemPos | ( | POSITION | pos,
 |  | T * | ppItem |
 | ) |  |  | [inline]

Definition at line 338 of file LinkList.h.

    {
        if (pos.pNode)
        {
            return GetItem(pos.pNode, ppItem);
        }
        else
        {
            return E_FAIL;
        }
    }

template<class T>
HRESULT List< T >::GetItemPos | ( | POSITION | pos,
 |  | T * | ppItem |
 | ) |  |  | [inline]

Definition at line 338 of file LinkList.h.

    {
        if (pos.pNode)
        {
            return GetItem(pos.pNode, ppItem);
        }
        else
        {
            return E_FAIL;
        }
    }

template<class T>
virtual bool List< T >::Initialize | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::XmlElement^ | xmlElement |
 | ) |  |  | [override, virtual]

Reimplemented from Rectangle.

template<class T>
virtual HRESULT List< T >::InsertAfter | ( | T | item,
 |  | Node * | pBefore |
 | ) |  |  | [inline, protected, virtual]

Definition at line 112 of file LinkList.h.

    {
        if (pBefore == nullptr)
        {
            return E_POINTER;
        }

        Node *pNode = new Node(item);
        if (pNode == nullptr)
        {
            return E_OUTOFMEMORY;
        }

        Node *pAfter = pBefore->next;

        pBefore->next = pNode;
        pAfter->prev = pNode;

        pNode->prev = pBefore;
        pNode->next = pAfter;

        m_count++;

        return S_OK;
    }

template<class T>
virtual HRESULT List< T >::InsertAfter | ( | T | item,
 |  | Node * | pBefore |
 | ) |  |  | [inline, protected, virtual]

Definition at line 112 of file LinkList.h.

    {
        if (pBefore == nullptr)
        {
            return E_POINTER;
        }

        Node *pNode = new Node(item);
        if (pNode == nullptr)
        {
            return E_OUTOFMEMORY;
        }

        Node *pAfter = pBefore->next;

        pBefore->next = pNode;
        pAfter->prev = pNode;

        pNode->prev = pBefore;
        pNode->next = pAfter;

        m_count++;

        return S_OK;
    }

template<class T>
virtual HRESULT List< T >::InsertAfter | ( | T | item,
 |  | Node * | pBefore |
 | ) |  |  | [inline, protected, virtual]

Definition at line 112 of file LinkList.h.

    {
        if (pBefore == nullptr)
        {
            return E_POINTER;
        }

        Node *pNode = new Node(item);
        if (pNode == nullptr)
        {
            return E_OUTOFMEMORY;
        }

        Node *pAfter = pBefore->next;

        pBefore->next = pNode;
        pAfter->prev = pNode;

        pNode->prev = pBefore;
        pNode->next = pAfter;

        m_count++;

        return S_OK;
    }

template<class T>
HRESULT List< T >::InsertBack ( T item ) [inline]

Definition at line 203 of file LinkList.h.

    {
        return InsertAfter(item, m_anchor.prev);
    }

template<class T>
HRESULT List< T >::InsertBack ( T item ) [inline]

Definition at line 203 of file LinkList.h.

    {
        return InsertAfter(item, m_anchor.prev);
    }

template<class T>
HRESULT List< T >::InsertBack ( T item ) [inline]

Definition at line 203 of file LinkList.h.

    {
        return InsertAfter(item, m_anchor.prev);
    }

template<class T>
HRESULT List< T >::InsertFront ( T item ) [inline]

Definition at line 209 of file LinkList.h.

    {
        return InsertAfter(item, &m_anchor);
    }

template<class T>
HRESULT List< T >::InsertFront ( T item ) [inline]

Definition at line 209 of file LinkList.h.

    {
        return InsertAfter(item, &m_anchor);
    }

template<class T>
HRESULT List< T >::InsertFront ( T item ) [inline]

Definition at line 209 of file LinkList.h.

    {
        return InsertAfter(item, &m_anchor);
    }

template<class T>
HRESULT List< T >::InsertPos | ( | POSITION | pos,
 |  | T | item |
 | ) |  |  | [inline]

Definition at line 214 of file LinkList.h.

    {
        if (pos.pNode == nullptr)
        {
            return InsertBack(item);
        }

        return InsertAfter(item, pos.pNode->prev);
    }

template<class T>
HRESULT List< T >::InsertPos | ( | POSITION | pos,
 |  | T | item |
 | ) |  |  | [inline]

Definition at line 214 of file LinkList.h.

    {
        if (pos.pNode == nullptr)
        {
            return InsertBack(item);
        }

        return InsertAfter(item, pos.pNode->prev);
    }

template<class T>
HRESULT List< T >::InsertPos | ( | POSITION | pos,
 |  | T | item |
 | ) |  |  | [inline]

Definition at line 214 of file LinkList.h.

    {
        if (pos.pNode == nullptr)
        {
            return InsertBack(item);
        }

        return InsertAfter(item, pos.pNode->prev);
    }

template<class T>
bool List< T >::IsEmpty ( ) const [inline]

Definition at line 282 of file LinkList.h.

    {
        return (GetCount() == 0);
    }

template<class T>
bool List< T >::IsEmpty ( ) const [inline]

Definition at line 282 of file LinkList.h.

    {
        return (GetCount() == 0);
    }

template<class T>
bool List< T >::IsEmpty ( ) const [inline]

Definition at line 282 of file LinkList.h.

    {
        return (GetCount() == 0);
    }

template<class T>
void List< T >::Measure | ( | _In_ Document^ | document,
 |  | D2D1_SIZE_F const & | parentSize,
 |  | _Out_ D2D1_RECT_F * | bounds |
 | ) |  |  | [override, virtual]

Reimplemented from Rectangle.

Definition at line 75 of file List.cpp.

{
    D2D1_SIZE_F size = m_size;

    if (size.width <= 0 && size.height <= 0)
    {
        // When no size is specified, assume its parent size.
        size = parentSize;
    }

    if (m_margin * 2 < size.width && m_margin * 2 < size.height)
    {
        // Compute the content area for child elements excluding list's designated margins
        size = D2D1::SizeF(size.width - 2 * m_margin, size.height - 2 * m_margin);
    }
    else
    {
        m_margin = 0;
    }

    D2D1_RECT_F maxBounds = D2D1::RectF(0, 0, size.width, 0);

    Element^ child = GetFirstChild();

    while (child)
    {
        D2D1_RECT_F childBounds = {0};

        child->Measure(document, size, &childBounds);

        if (maxBounds.bottom - maxBounds.top + childBounds.top < 0)
        {
            maxBounds.top = childBounds.top + maxBounds.bottom;
        }

        maxBounds.bottom += childBounds.bottom;

        if (childBounds.left < maxBounds.left)
        {
            maxBounds.left = childBounds.left;
        }

        if (childBounds.right > maxBounds.right)
        {
            maxBounds.right = childBounds.right;
        }

        // Update the list size for the next child
        size = D2D1::SizeF(size.width, size.height - childBounds.bottom + childBounds.top);

        child = child->GetNextSibling();
    }

    // List final size needs to accommodate all its children.
    m_size = D2D1::SizeF(maxBounds.right - maxBounds.left + 2 * m_margin, maxBounds.bottom - maxBounds.top + 2 * m_margin);

    *bounds = D2D1::RectF(
        m_offset.x,
        m_offset.y,
        m_offset.x + m_size.width,
        m_offset.y + m_size.height
        );
}

template<class T>
POSITION List< T >::Next ( const POSITION pos ) [inline]

Definition at line 350 of file LinkList.h.

    {
        if (pos.pNode && (pos.pNode->next != &m_anchor))
        {
            return POSITION(pos.pNode->next);
        }
        else
        {
            return POSITION(nullptr);
        }
    }

template<class T>
POSITION List< T >::Next ( const POSITION pos ) [inline]

Definition at line 350 of file LinkList.h.

    {
        if (pos.pNode && (pos.pNode->next != &m_anchor))
        {
            return POSITION(pos.pNode->next);
        }
        else
        {
            return POSITION(nullptr);
        }
    }

template<class T>
POSITION List< T >::Next ( const POSITION pos ) [inline]

Definition at line 350 of file LinkList.h.

    {
        if (pos.pNode && (pos.pNode->next != &m_anchor))
        {
            return POSITION(pos.pNode->next);
        }
        else
        {
            return POSITION(nullptr);
        }
    }

template<class T>
HRESULT List< T >::Remove | ( | POSITION & | pos,
 |  | T * | ppItem |
 | ) |  |  | [inline]

Definition at line 365 of file LinkList.h.

    {
        if (pos.pNode)
        {
            // Remove const-ness temporarily...
            Node *pNode = const_cast<Node*>(pos.pNode);

            pos = POSITION();

            return RemoveItem(pNode, ppItem);
        }
        else
        {
            return E_INVALIDARG;
        }
    }

template<class T>
HRESULT List< T >::Remove | ( | POSITION & | pos,
 |  | T * | ppItem |
 | ) |  |  | [inline]

Definition at line 365 of file LinkList.h.

    {
        if (pos.pNode)
        {
            // Remove const-ness temporarily...
            Node *pNode = const_cast<Node*>(pos.pNode);

            pos = POSITION();

            return RemoveItem(pNode, ppItem);
        }
        else
        {
            return E_INVALIDARG;
        }
    }

template<class T>
HRESULT List< T >::Remove | ( | POSITION & | pos,
 |  | T * | ppItem |
 | ) |  |  | [inline]

Definition at line 365 of file LinkList.h.

    {
        if (pos.pNode)
        {
            // Remove const-ness temporarily...
            Node *pNode = const_cast<Node*>(pos.pNode);

            pos = POSITION();

            return RemoveItem(pNode, ppItem);
        }
        else
        {
            return E_INVALIDARG;
        }
    }

template<class T>
HRESULT List< T >::RemoveBack ( T * ppItem ) [inline]

Definition at line 226 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return RemoveItem(Back(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::RemoveBack ( T * ppItem ) [inline]

Definition at line 226 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return RemoveItem(Back(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::RemoveBack ( T * ppItem ) [inline]

Definition at line 226 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return RemoveItem(Back(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::RemoveFront ( T * ppItem ) [inline]

Definition at line 240 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return RemoveItem(Front(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::RemoveFront ( T * ppItem ) [inline]

Definition at line 240 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return RemoveItem(Front(), ppItem);
        }
    }

template<class T>
HRESULT List< T >::RemoveFront ( T * ppItem ) [inline]

Definition at line 240 of file LinkList.h.

    {
        if (IsEmpty())
        {
            return E_FAIL;
        }
        else
        {
            return RemoveItem(Front(), ppItem);
        }
    }

template<class T>
virtual HRESULT List< T >::RemoveItem | ( | Node * | pNode,
 |  | T * | ppItem |
 | ) |  |  | [inline, protected, virtual]

Definition at line 152 of file LinkList.h.

    {
        if (pNode == nullptr)
        {
            return E_POINTER;
        }

        assert(pNode != &m_anchor); // We should never try to remove the anchor node.
        if (pNode == &m_anchor)
        {
            return E_INVALIDARG;
        }

        T item;

        // The next node's previous is this node's previous.
        pNode->next->prev = pNode->prev;

        // The previous node's next is this node's next.
        pNode->prev->next = pNode->next;

        item = pNode->item;
        delete pNode;

        m_count--;

        if (ppItem)
        {
            *ppItem = item;
        }

        return S_OK;
    }

template<class T>
virtual HRESULT List< T >::RemoveItem | ( | Node * | pNode,
 |  | T * | ppItem |
 | ) |  |  | [inline, protected, virtual]

Definition at line 152 of file LinkList.h.

    {
        if (pNode == nullptr)
        {
            return E_POINTER;
        }

        assert(pNode != &m_anchor); // We should never try to remove the anchor node.
        if (pNode == &m_anchor)
        {
            return E_INVALIDARG;
        }

        T item;

        // The next node's previous is this node's previous.
        pNode->next->prev = pNode->prev;

        // The previous node's next is this node's next.
        pNode->prev->next = pNode->next;

        item = pNode->item;
        delete pNode;

        m_count--;

        if (ppItem)
        {
            *ppItem = item;
        }

        return S_OK;
    }

template<class T>
virtual HRESULT List< T >::RemoveItem | ( | Node * | pNode,
 |  | T * | ppItem |
 | ) |  |  | [inline, protected, virtual]

Definition at line 152 of file LinkList.h.

    {
        if (pNode == nullptr)
        {
            return E_POINTER;
        }

        assert(pNode != &m_anchor); // We should never try to remove the anchor node.
        if (pNode == &m_anchor)
        {
            return E_INVALIDARG;
        }

        T item;

        // The next node's previous is this node's previous.
        pNode->next->prev = pNode->prev;

        // The previous node's next is this node's next.
        pNode->prev->next = pNode->next;

        item = pNode->item;
        delete pNode;

        m_count--;

        if (ppItem)
        {
            *ppItem = item;
        }

        return S_OK;
    }

Member Data Documentation

template<class T>
internal List< T >::__pad0__

Reimplemented from Rectangle.

Definition at line 25 of file List.h.

template<class T>
Node List< T >::m_anchor [protected]

Definition at line 99 of file LinkList.h.

template<class T>
DWORD List< T >::m_count [protected]

Definition at line 100 of file LinkList.h.

template<class T>
float List< T >::m_margin [private]

Definition at line 50 of file List.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/List.h
  • Media extensions/C#,C++/MediaExtensions/Common/LinkList.h
  • Media extensions/C++/MediaExtensions/Common/LinkList.h
  • Real-time communication/C++/MediaExtensions/Common/LinkList.h
  • Direct2D magazine app/C++/List.cpp
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: List< T >::Node Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • List< T >
  • List< T >::Node
Public Member Functions | Public Attributes

List< T >::Node Struct Reference

#include "LinkList.h"

List of all members.

Public Member Functions

Node ()
Node (T item)
Node ()
Node (T item)
Node (T item)
Node ()
T | Item () const
T | Item () const
T | Item () const

Public Attributes

T | item
Node * next
Node * prev

Detailed Description

template<class T>
struct List< T >::Node

Definition at line 50 of file LinkList.h.

Constructor & Destructor Documentation

template<class T>
List< T >::Node::Node ( ) [inline]

Definition at line 56 of file LinkList.h.

               : prev(nullptr), next(nullptr)
        {
        }

template<class T>
List< T >::Node::Node ( T item ) [inline]

Definition at line 60 of file LinkList.h.

                     : prev(nullptr), next(nullptr)
        {
            this->item = item;
        }

template<class T>
List< T >::Node::Node ( ) [inline]

Definition at line 56 of file LinkList.h.

               : prev(nullptr), next(nullptr)
        {
        }

template<class T>
List< T >::Node::Node ( T item ) [inline]

Definition at line 60 of file LinkList.h.

                     : prev(nullptr), next(nullptr)
        {
            this->item = item;
        }

template<class T>
List< T >::Node::Node ( ) [inline]

Definition at line 56 of file LinkList.h.

               : prev(nullptr), next(nullptr)
        {
        }

template<class T>
List< T >::Node::Node ( T item ) [inline]

Definition at line 60 of file LinkList.h.

                     : prev(nullptr), next(nullptr)
        {
            this->item = item;
        }

Member Function Documentation

template<class T>
T List< T >::Node::Item ( ) const [inline]

Definition at line 65 of file LinkList.h.

{ return item; }

template<class T>
T List< T >::Node::Item ( ) const [inline]

Definition at line 65 of file LinkList.h.

{ return item; }

template<class T>
T List< T >::Node::Item ( ) const [inline]

Definition at line 65 of file LinkList.h.

{ return item; }

Member Data Documentation

template<class T>
T List< T >::Node::item

Definition at line 54 of file LinkList.h.

template<class T>
Node * List< T >::Node::next

Definition at line 53 of file LinkList.h.

template<class T>
Node * List< T >::Node::prev

Definition at line 52 of file LinkList.h.

The documentation for this struct was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/LinkList.h
  • Media extensions/C++/MediaExtensions/Common/LinkList.h
  • Real-time communication/C++/MediaExtensions/Common/LinkList.h
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: List< T >::POSITION Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • List< T >
  • List< T >::POSITION
Public Member Functions | Private Member Functions | Private Attributes | Friends

List< T >::POSITION Class Reference

#include "LinkList.h"

List of all members.

Public Member Functions

POSITION ()
POSITION ()
POSITION ()
bool | operator!= (const POSITION &p) const
bool | operator!= (const POSITION &p) const
bool | operator!= (const POSITION &p) const
bool | operator== (const POSITION &p) const
bool | operator== (const POSITION &p) const
bool | operator== (const POSITION &p) const

Private Member Functions

POSITION (Node *p)
POSITION (Node *p)
POSITION (Node *p)

Private Attributes

const Node * | pNode

Friends

class | List< T >

Detailed Description

template<class T>
class List< T >::POSITION

Definition at line 71 of file LinkList.h.

Constructor & Destructor Documentation

template<class T>
List< T >::POSITION::POSITION ( ) [inline]

Definition at line 76 of file LinkList.h.

                   : pNode(nullptr)
        {
        }

template<class T>
List< T >::POSITION::POSITION ( Node * p ) [inline, private]

Definition at line 93 of file LinkList.h.

                          : pNode(p)
        {
        }

template<class T>
List< T >::POSITION::POSITION ( ) [inline]

Definition at line 76 of file LinkList.h.

                   : pNode(nullptr)
        {
        }

template<class T>
List< T >::POSITION::POSITION ( Node * p ) [inline, private]

Definition at line 93 of file LinkList.h.

                          : pNode(p)
        {
        }

template<class T>
List< T >::POSITION::POSITION ( ) [inline]

Definition at line 76 of file LinkList.h.

                   : pNode(nullptr)
        {
        }

template<class T>
List< T >::POSITION::POSITION ( Node * p ) [inline, private]

Definition at line 93 of file LinkList.h.

                          : pNode(p)
        {
        }

Member Function Documentation

template<class T>
bool List< T >::POSITION::operator!= ( const POSITION & p ) const [inline]

Definition at line 85 of file LinkList.h.

        {
            return pNode != p.pNode;
        }

template<class T>
bool List< T >::POSITION::operator!= ( const POSITION & p ) const [inline]

Definition at line 85 of file LinkList.h.

        {
            return pNode != p.pNode;
        }

template<class T>
bool List< T >::POSITION::operator!= ( const POSITION & p ) const [inline]

Definition at line 85 of file LinkList.h.

        {
            return pNode != p.pNode;
        }

template<class T>
bool List< T >::POSITION::operator== ( const POSITION & p ) const [inline]

Definition at line 80 of file LinkList.h.

        {
            return pNode == p.pNode;
        }

template<class T>
bool List< T >::POSITION::operator== ( const POSITION & p ) const [inline]

Definition at line 80 of file LinkList.h.

        {
            return pNode == p.pNode;
        }

template<class T>
bool List< T >::POSITION::operator== ( const POSITION & p ) const [inline]

Definition at line 80 of file LinkList.h.

        {
            return pNode == p.pNode;
        }

Friends And Related Function Documentation

template<class T>
friend class List< T > [friend]

Definition at line 73 of file LinkList.h.

Member Data Documentation

template<class T>
const Node * List< T >::POSITION::pNode [private]

Definition at line 91 of file LinkList.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/LinkList.h
  • Media extensions/C++/MediaExtensions/Common/LinkList.h
  • Real-time communication/C++/MediaExtensions/Common/LinkList.h
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LoadScreen Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

LoadScreen Class Reference

#include "LoadScreen.h"

List of all members.

Public Member Functions

void | Render ()
void | ResetDirectXResources ()
void | UpdateForWindowSizeChange ()

Public Attributes

internal | __pad0__: void Initialize( _In_ ID2D1Device* d2dDevice
internal _In_ ID2D1DeviceContext * | d2dContext
internal _In_
ID2D1DeviceContext _In_
IWICImagingFactory * 		wicFactory

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Bitmap > 		m_bitmap
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
Microsoft::WRL::ComPtr
< ID2D1Device > 		m_d2dDevice
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
D2D1_SIZE_F | m_imageSize
D2D1_SIZE_F | m_offset
Microsoft::WRL::ComPtr
< ID2D1DrawingStateBlock > 		m_stateBlock
D2D1_SIZE_F | m_totalSize
Microsoft::WRL::ComPtr
< IWICImagingFactory > 		m_wicFactory

Detailed Description

Definition at line 12 of file LoadScreen.h.

Member Function Documentation

void LoadScreen::Render ( )

Definition at line 103 of file LoadScreen.cpp.

{
    m_d2dContext->SaveDrawingState(m_stateBlock.Get());

    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->DrawBitmap(
        m_bitmap.Get(),
        D2D1::RectF(
            m_offset.width,
            m_offset.height,
            m_imageSize.width + m_offset.width,
            m_imageSize.height + m_offset.height)
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
}

void LoadScreen::ResetDirectXResources ( )

Definition at line 41 of file LoadScreen.cpp.

{
    ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"Media\\Textures\\loadscreen.png",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &wicBitmapDecoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
    DX::ThrowIfFailed(
        wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
        );

    ComPtr<IWICFormatConverter> wicFormatConverter;
    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&wicFormatConverter)
        );

    DX::ThrowIfFailed(
        wicFormatConverter->Initialize(
            wicBitmapFrame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0,
            WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
            )
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmapFromWicBitmap(
            wicFormatConverter.Get(),
            BitmapProperties(PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED)),
            &m_bitmap
            )
        );

    m_imageSize = m_bitmap->GetSize();

    DX::ThrowIfFailed(
        m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
        );

    UpdateForWindowSizeChange();
}

void LoadScreen::UpdateForWindowSizeChange ( )

Definition at line 92 of file LoadScreen.cpp.

{
    Windows::Foundation::Rect windowBounds = CoreWindow::GetForCurrentThread()->Bounds;

    m_offset.width = (windowBounds.Width - m_imageSize.width) / 2.0f;
    m_offset.height = (windowBounds.Height - m_imageSize.height) / 2.0f;

    m_totalSize.width = m_offset.width + m_imageSize.width;
    m_totalSize.height = m_offset.height + m_imageSize.height;
}

Member Data Documentation

internal LoadScreen::__pad0__

Definition at line 16 of file LoadScreen.h.

internal _In_ ID2D1DeviceContext* LoadScreen::d2dContext

Definition at line 16 of file LoadScreen.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap> LoadScreen::m_bitmap [private]

Definition at line 34 of file LoadScreen.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> LoadScreen::m_d2dContext [private]

Definition at line 30 of file LoadScreen.h.

Microsoft::WRL::ComPtr<ID2D1Device> LoadScreen::m_d2dDevice [private]

Definition at line 29 of file LoadScreen.h.

Microsoft::WRL::ComPtr<ID2D1Factory1> LoadScreen::m_d2dFactory [private]

Definition at line 28 of file LoadScreen.h.

D2D1_SIZE_F LoadScreen::m_imageSize [private]

Definition at line 36 of file LoadScreen.h.

D2D1_SIZE_F LoadScreen::m_offset [private]

Definition at line 37 of file LoadScreen.h.

Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock> LoadScreen::m_stateBlock [private]

Definition at line 31 of file LoadScreen.h.

D2D1_SIZE_F LoadScreen::m_totalSize [private]

Definition at line 38 of file LoadScreen.h.

Microsoft::WRL::ComPtr<IWICImagingFactory> LoadScreen::m_wicFactory [private]

Definition at line 33 of file LoadScreen.h.

internal _In_ ID2D1DeviceContext _In_ IWICImagingFactory* LoadScreen::wicFactory

Definition at line 16 of file LoadScreen.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/LoadScreen.h
  • DirectX marble maze game/C++/LoadScreen.cpp
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LockScreenAppsCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • LockScreenAppsCPP
  • LockScreenAppsCPP::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

LockScreenAppsCPP::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
Platform::String | ConvertResolution (Windows::Graphics::Display::ResolutionScale scale)
Platform::String | ConvertViewState (Windows::UI::ViewManagement::ApplicationViewState state)
void | DoNavigation (Windows::UI::Xaml::Interop::TypeName inPageType, Windows::UI::Xaml::Controls::Frame^inFrame, Windows::UI::Xaml::Interop::TypeName outPageType, Windows::UI::Xaml::Controls::Frame^outFrame)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioInput3 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()
ScenarioOutput3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~MainPage ()
~ScenarioInput1 ()
~ScenarioInput2 ()
~ScenarioInput3 ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
~ScenarioOutput3 ()
void | CheckResolutionAndViewState ()
void | ClearBadge_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ClearTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CreateBadgeAndTextTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CreateBadgeTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Windows::Foundation::Rect | GetElementRect (Windows::UI::Xaml::FrameworkElement^element)
void | inputFrameNavigated (Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | outputFrameNavigated (Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | Page_Loaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | QueryLockScreenAccess_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RemoveLockScreenAccess_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RequestLockScreenAccess_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendBadge_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendBadgeWithStringManipulation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendTileWithStringManipulation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetFeatureName (Platform::String^strFeature)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::Foundation::EventRegistrationToken | _resizeHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
MainPage | rootPage

Detailed Description

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

LockScreenAppsCPP::sealed::~MainPage ( ) [private]
LockScreenAppsCPP::sealed::~ScenarioInput1 ( ) [private]
LockScreenAppsCPP::sealed::~ScenarioInput2 ( ) [private]
LockScreenAppsCPP::sealed::~ScenarioInput3 ( ) [private]
LockScreenAppsCPP::sealed::~ScenarioList ( ) [private]
LockScreenAppsCPP::sealed::~ScenarioOutput1 ( ) [private]
LockScreenAppsCPP::sealed::~ScenarioOutput2 ( ) [private]
LockScreenAppsCPP::sealed::~ScenarioOutput3 ( ) [private]

Member Function Documentation

LockScreenAppsCPP::sealed::App ( )
void LockScreenAppsCPP::sealed::CheckResolutionAndViewState ( ) [private]
void LockScreenAppsCPP::sealed::ClearBadge_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::ClearTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Platform::String LockScreenAppsCPP::sealed::ConvertResolution ( Windows::Graphics::Display::ResolutionScale scale )
Platform::String LockScreenAppsCPP::sealed::ConvertViewState ( Windows::UI::ViewManagement::ApplicationViewState state )
void LockScreenAppsCPP::sealed::CreateBadgeAndTextTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::CreateBadgeTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void LockScreenAppsCPP::sealed::DoNavigation | ( | Windows::UI::Xaml::Interop::TypeName | inPageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | inFrame,
 |  | Windows::UI::Xaml::Interop::TypeName | outPageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | outFrame
 | ) |  |
void LockScreenAppsCPP::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Windows::Foundation::Rect LockScreenAppsCPP::sealed::GetElementRect ( Windows::UI::Xaml::FrameworkElement^ element ) [private]
void LockScreenAppsCPP::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
LockScreenAppsCPP::sealed::MainPage ( )
void LockScreenAppsCPP::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void LockScreenAppsCPP::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void LockScreenAppsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LockScreenAppsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LockScreenAppsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LockScreenAppsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void LockScreenAppsCPP::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void LockScreenAppsCPP::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::QueryLockScreenAccess_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::RemoveLockScreenAccess_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::RequestLockScreenAccess_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
LockScreenAppsCPP::sealed::ScenarioInput1 ( )
LockScreenAppsCPP::sealed::ScenarioInput2 ( )
LockScreenAppsCPP::sealed::ScenarioInput3 ( )
LockScreenAppsCPP::sealed::ScenarioList ( )
LockScreenAppsCPP::sealed::ScenarioOutput1 ( )
LockScreenAppsCPP::sealed::ScenarioOutput2 ( )
LockScreenAppsCPP::sealed::ScenarioOutput3 ( )
void LockScreenAppsCPP::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void LockScreenAppsCPP::sealed::SendBadge_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::SendBadgeWithStringManipulation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::SendTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::SendTileWithStringManipulation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LockScreenAppsCPP::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken LockScreenAppsCPP::sealed::_displayHandlerToken [private]

Definition at line 59 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame LockScreenAppsCPP::sealed::_inputFrame [private]

Definition at line 55 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LockScreenAppsCPP::sealed::_inputFrameLoadedToken [private]

Definition at line 62 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LockScreenAppsCPP::sealed::_logicalDpiChangedToken [private]

Definition at line 61 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame LockScreenAppsCPP::sealed::_outputFrame [private]

Definition at line 56 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LockScreenAppsCPP::sealed::_outputFrameLoadedToken [private]

Definition at line 63 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LockScreenAppsCPP::sealed::_pageLoadedHandlerToken [private]

Definition at line 60 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken LockScreenAppsCPP::sealed::_resizeHandlerToken [private]

Definition at line 58 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame LockScreenAppsCPP::sealed::_scenariosFrame [private]

Definition at line 54 of file MainPage.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 37 of file ScenarioInput1.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> LockScreenAppsCPP::sealed::OutputFrameLoaded

Definition at line 45 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/App.xaml.h
  • Lock screen apps/C#,C++/MainPage.xaml.h
  • Lock screen apps/C#,C++/ScenarioInput1.xaml.h
  • Lock screen apps/C#,C++/ScenarioInput2.xaml.h
  • Lock screen apps/C#,C++/ScenarioInput3.xaml.h
  • Lock screen apps/C#,C++/ScenarioList.xaml.h
  • Lock screen apps/C#,C++/ScenarioOutput1.xaml.h
  • Lock screen apps/C#,C++/ScenarioOutput2.xaml.h
  • Lock screen apps/C#,C++/ScenarioOutput3.xaml.h
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LonLatController Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Private Member Functions | Private Attributes

LonLatController Class Reference

#include "LonLatController.h"

List of all members.

Private Member Functions

float3 get_LookPoint ()
float3 get_LookPoint ()
float3 get_Position ()
float3 get_Position ()
void | Initialize (_In_ Windows::UI::Core::CoreWindow^window)
void | LoadInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | LoadInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyUp (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyUp (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerWheelChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | SaveInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | SaveInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | SetOrientation (_In_ float latitude, _In_ float longitude)
void | SetOrientation (_In_ float latitude, _In_ float longitude)
void | SetPosition (_In_ float3 pos)
void | SetPosition (_In_ float3 pos)
void | Update (_In_ Windows::UI::Core::CoreWindow^window)
void | Update ()

Private Attributes

internal | __pad0__: void Initialize(_In_ Windows::UI::Core::CoreWindow^ window)
internal _In_
Windows::UI::Core::PointerEventArgs 		args
bool | m_back
bool | m_down
bool | m_forward
float | m_lastDistance
float | m_latitude
bool | m_left
float | m_longitude
float3 m_lonLatCommand
BOOL | m_lonLatInUse
float2 m_lonLatLastDelta
float2 m_lonLatLastPoint
float2 m_lonLatLastPoint1
float2 m_lonLatLastPoint2
uint32 | m_lonLatPointerID
uint32 | m_lonLatPointerID1
uint32 | m_lonLatPointerID2
uint32 | m_numPointersDown
float3 m_position
float | m_radius
bool | m_right
bool | m_up

Detailed Description

Definition at line 17 of file LonLatController.h.

Member Function Documentation

float3 LonLatController::get_LookPoint ( ) [private]

Definition at line 193 of file LonLatController.cpp.

{
    return float3(0, 0, 0);
}

float3 LonLatController::get_LookPoint ( ) [private]
float3 LonLatController::get_Position ( ) [private]

Definition at line 182 of file LonLatController.cpp.

{
    float y = m_radius*sinf(m_latitude);    // up-down
    float r = m_radius*cosf(m_latitude);    // in the plane
    float z = r*cosf(m_longitude);          // fwd-back
    float x = r*sinf(m_longitude);          // left-right

    return float3(x, y, z);
}

float3 LonLatController::get_Position ( ) [private]
void LonLatController::Initialize ( _In_ Windows::UI::Core::CoreWindow^ window ) [private]
void LonLatController::LoadInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state ) [private]
void LonLatController::LoadInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state ) [private]
void LonLatController::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnKeyUp | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnKeyUp | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::OnPointerWheelChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void LonLatController::SaveInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state ) [private]
void LonLatController::SaveInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state ) [private]
void LonLatController::SetOrientation | ( | _In_ float | latitude,
 |  | _In_ float | longitude |
 | ) |  |  | [private]
void LonLatController::SetOrientation | ( | _In_ float | latitude,
 |  | _In_ float | longitude |
 | ) |  |  | [private]

Definition at line 172 of file LonLatController.cpp.

{
    m_latitude = latitude;
    m_longitude = longitude;
}

void LonLatController::SetPosition ( _In_ float3 pos ) [private]
void LonLatController::SetPosition ( _In_ float3 pos ) [private]

Definition at line 163 of file LonLatController.cpp.

{
    m_longitude = atan2f(pos.x, pos.z);
    float r = sqrtf(pos.x*pos.x + pos.z*pos.z);
    m_latitude = atan2f(pos.y, r);
    m_radius = sqrtf(pos.x*pos.x + pos.y*pos.y + pos.z*pos.z);
}

void LonLatController::Update ( _In_ Windows::UI::Core::CoreWindow^ window ) [private]
void LonLatController::Update ( ) [private]

Definition at line 224 of file LonLatController.cpp.

{
    // poll our state bits set by the keyboard input events
    if (m_forward)
    {
        m_lonLatCommand.y += 1.0f;
    }
    if (m_back)
    {
        m_lonLatCommand.y -= 1.0f;
    }

    if (m_left)
    {
        m_lonLatCommand.x -= 1.0f;
    }
    if (m_right)
    {
        m_lonLatCommand.x += 1.0f;
    }

    if (m_up)
    {
        m_lonLatCommand.z += 1.0f;
    }
    if (m_down)
    {
        m_lonLatCommand.z -= 1.0f;
    }

    // scale for sensitivity adjustment
    float3 command = m_lonLatCommand*LONLATKEY_GAIN;
    command.y *= m_radius * 0.5f; // logarithmic gain

    // update state with command input
    m_latitude  += command.z;
    m_longitude += command.x;
    m_radius    -= command.y; // fwd stick is down towards object

    // Limit lattitude to poles
    float limit = PI_F / 2.0f - 0.01f;
    m_latitude = (float) __max(-limit, m_latitude);
    m_latitude = (float) __min(+limit, m_latitude);

    // keep longitude in sane range by wrapping
    if (m_longitude >  PI_F)
    {
        m_longitude -= PI_F * 2.0f;
    }
    else if (m_longitude < -PI_F)
    {
        m_longitude += PI_F * 2.0f;
    }

    // limit us to positive radius
    m_radius = (float) __max(0.0, m_radius);

    // clear movement input accumulator for use during next frame
    m_lonLatCommand = float3(0.0f, 0.0f, 0.0f);
}

Member Data Documentation

internal LonLatController::__pad0__ [private]

Definition at line 70 of file LonLatController.h.

internal _In_ Windows::UI::Core::PointerEventArgs LonLatController::args [private]

Definition at line 39 of file LonLatController.h.

bool LonLatController::m_back [private]

Definition at line 32 of file LonLatController.h.

bool LonLatController::m_down [private]

Definition at line 34 of file LonLatController.h.

bool LonLatController::m_forward [private]

Definition at line 32 of file LonLatController.h.

float LonLatController::m_lastDistance [private]

Definition at line 35 of file LonLatController.h.

float LonLatController::m_latitude [private]

Definition at line 24 of file LonLatController.h.

bool LonLatController::m_left [private]

Definition at line 33 of file LonLatController.h.

float LonLatController::m_longitude [private]

Definition at line 23 of file LonLatController.h.

float3 LonLatController::m_lonLatCommand [private]

Definition at line 33 of file LonLatController.h.

BOOL LonLatController::m_lonLatInUse [private]

Definition at line 27 of file LonLatController.h.

float2 LonLatController::m_lonLatLastDelta [private]

Definition at line 30 of file LonLatController.h.

float2 LonLatController::m_lonLatLastPoint [private]

Definition at line 29 of file LonLatController.h.

float2 LonLatController::m_lonLatLastPoint1 [private]

Definition at line 30 of file LonLatController.h.

float2 LonLatController::m_lonLatLastPoint2 [private]

Definition at line 31 of file LonLatController.h.

uint32 LonLatController::m_lonLatPointerID [private]

Definition at line 28 of file LonLatController.h.

uint32 LonLatController::m_lonLatPointerID1 [private]

Definition at line 28 of file LonLatController.h.

uint32 LonLatController::m_lonLatPointerID2 [private]

Definition at line 29 of file LonLatController.h.

uint32 LonLatController::m_numPointersDown [private]

Definition at line 34 of file LonLatController.h.

float3 LonLatController::m_position [private]

Definition at line 21 of file LonLatController.h.

float LonLatController::m_radius [private]

Definition at line 22 of file LonLatController.h.

bool LonLatController::m_right [private]

Definition at line 33 of file LonLatController.h.

bool LonLatController::m_up [private]

Definition at line 34 of file LonLatController.h.

The documentation for this class was generated from the following files:
  • Direct3D bump mapping/C++/LonLatController.h
  • Direct3D resource loading/C++/LonLatController.h
  • Direct3D bump mapping/C++/LonLatController.cpp
  • Direct3D resource loading/C++/LonLatController.cpp
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Magazine::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Magazine
  • Magazine::sealed
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Magazine::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
void | LoadState (_In_ Windows::Foundation::Collections::IPropertySet^localSettings)
MainPage ()
virtual void | OnLaunched (_In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
void | SaveState (_In_ Windows::Foundation::Collections::IPropertySet^localSettings)
void | UpdateContent (_In_ Element^content)

Public Attributes

virtual event
Windows::UI::Xaml::Data::PropertyChangedEventHandler 		PropertyChanged

Private Member Functions

~App ()
void | DocumentLoaded (_In_ Document^document)
void | OnDeviceLost ()
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Platform::Object^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Private Attributes

Microsoft::WRL::ComPtr
< ContentImageSource > 		m_background
Microsoft::WRL::ComPtr
< ContentImageSource > 		m_content
Document m_document

Detailed Description

Definition at line 14 of file App.xaml.h.

Constructor & Destructor Documentation

Magazine::sealed::~App ( ) [private]

Member Function Documentation

Magazine::sealed::App ( )
void Magazine::sealed::DocumentLoaded ( _In_ Document^ document ) [private]
void Magazine::sealed::LoadState ( _In_ Windows::Foundation::Collections::IPropertySet^ localSettings )
Magazine::sealed::MainPage ( )
void Magazine::sealed::OnDeviceLost ( ) [private]
virtual void Magazine::sealed::OnLaunched ( _In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
void Magazine::sealed::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void Magazine::sealed::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void Magazine::sealed::OnWindowSizeChanged | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void Magazine::sealed::SaveState ( _In_ Windows::Foundation::Collections::IPropertySet^ localSettings )
void Magazine::sealed::UpdateContent ( _In_ Element^ content )

Member Data Documentation

Microsoft::WRL::ComPtr<ContentImageSource> Magazine::sealed::m_background [private]

Definition at line 81 of file PageModel.h.

Microsoft::WRL::ComPtr<ContentImageSource> Magazine::sealed::m_content [private]

Definition at line 78 of file PageModel.h.

Document Magazine::sealed::m_document [private]

Definition at line 38 of file MainPage.xaml.h.

virtual event Windows::UI::Xaml::Data::PropertyChangedEventHandler Magazine::sealed::PropertyChanged

Definition at line 34 of file PageModel.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/App.xaml.h
  • Direct2D magazine app/C++/MainPage.xaml.h
  • Direct2D magazine app/C++/PageModel.h
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ManipulatableObject Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

ManipulatableObject Class Reference

#include "ManipulatableObject.h"

Inherited by sealed, and sealed.

List of all members.

Public Member Functions

virtual void | Deserialize (_In_ Windows::Foundation::Collections::IPropertySet^properties)
Windows::UI::Input::ManipulationDelta | LimitManipulationScale (_In_ Windows::UI::Input::ManipulationDelta delta, _In_ float minScale, _In_ float maxScale)
D2D1::Matrix3x2F | LocalTransform ()
D2D1::Matrix3x2F | ManipulationTransform ()
ManipulatableObject Parent ()
D2D1::Matrix3x2F | ParentTransform ()
virtual void | Serialize (_In_ Windows::Foundation::Collections::IPropertySet^properties)
void | SetInitialPosition (_In_ D2D1_POINT_2F ptInit)
void | SetManipulationTransform (_In_ D2D1::Matrix3x2F mxManip)
Windows::Foundation::Point | SingleFingerRotation (_In_ Windows::UI::Input::GestureRecognizer^gestureRecognizer, _In_ Windows::Foundation::Point position, _In_ float pivotRadius)
void | UpdateManipulationTransform (_In_ Windows::UI::Input::ManipulationDelta delta, _In_ Windows::Foundation::Point position)

Public Attributes

internal | __pad0__: ManipulatableObject(_In_opt_ ManipulatableObject^ parent)
internal | __pad1__: virtual D2D1::Matrix3x2F Transform() { return LocalTransform() * ParentTransform()

Private Attributes

D2D1::Matrix3x2F | _mxManip
ManipulatableObject _parent
D2D1_POINT_2F | _ptInit

Detailed Description

Definition at line 16 of file ManipulatableObject.h.

Member Function Documentation

virtual void ManipulatableObject::Deserialize ( _In_ Windows::Foundation::Collections::IPropertySet^ properties ) [virtual]

Reimplemented in sealed.

Windows::UI::Input::ManipulationDelta ManipulatableObject::LimitManipulationScale | ( | _In_ Windows::UI::Input::ManipulationDelta | delta,
 |  | _In_ float | minScale,
 |  | _In_ float | maxScale
 | ) |  |
D2D1::Matrix3x2F ManipulatableObject::LocalTransform ( ) [inline]

Definition at line 53 of file ManipulatableObject.h.

{ return D2D1::Matrix3x2F::Translation(_ptInit.x, _ptInit.y) * _mxManip; }

D2D1::Matrix3x2F ManipulatableObject::ManipulationTransform ( ) [inline]

Definition at line 60 of file ManipulatableObject.h.

{ return _mxManip; }

ManipulatableObject ManipulatableObject::Parent ( ) [inline]

Definition at line 23 of file ManipulatableObject.h.

{ return _parent; }

D2D1::Matrix3x2F ManipulatableObject::ParentTransform ( ) [inline]

Definition at line 55 of file ManipulatableObject.h.

{ return _parent ? _parent->Transform() : D2D1::Matrix3x2F::Identity(); }

virtual void ManipulatableObject::Serialize ( _In_ Windows::Foundation::Collections::IPropertySet^ properties ) [virtual]

Reimplemented in sealed.

void ManipulatableObject::SetInitialPosition ( _In_ D2D1_POINT_2F ptInit ) [inline]

Definition at line 58 of file ManipulatableObject.h.

{ _ptInit = ptInit; }

void ManipulatableObject::SetManipulationTransform ( _In_ D2D1::Matrix3x2F mxManip ) [inline]

Definition at line 59 of file ManipulatableObject.h.

{ _mxManip = mxManip; }

Windows::Foundation::Point ManipulatableObject::SingleFingerRotation | ( | _In_ Windows::UI::Input::GestureRecognizer^ | gestureRecognizer,
 |  | _In_ Windows::Foundation::Point | position,
 |  | _In_ float | pivotRadius
 | ) |  |
void ManipulatableObject::UpdateManipulationTransform | ( | _In_ Windows::UI::Input::ManipulationDelta | delta,
 |  | _In_ Windows::Foundation::Point | position
 | ) |  |

Member Data Documentation

internal ManipulatableObject::__pad0__

Reimplemented in sealed.

Definition at line 19 of file ManipulatableObject.h.

internal ManipulatableObject::__pad1__

Definition at line 49 of file ManipulatableObject.h.

D2D1::Matrix3x2F ManipulatableObject::_mxManip [private]

Definition at line 64 of file ManipulatableObject.h.

ManipulatableObject ManipulatableObject::_parent [private]

Definition at line 63 of file ManipulatableObject.h.

D2D1_POINT_2F ManipulatableObject::_ptInit [private]

Definition at line 65 of file ManipulatableObject.h.

The documentation for this class was generated from the following file:
  • Input Manipulations and gestures (C++)/C++/ManipulatableObject.h
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MarbleMaze Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Types | Private Member Functions | Private Attributes

MarbleMaze Class Reference

#include "MarbleMaze.h"

List of all members.

Public Member Functions

void | AddTouch (int id, Windows::Foundation::Point point)
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | HandleDeviceLost () override
virtual void | Initialize (Windows::UI::Core::CoreWindow^window, float dpi) override
void | KeyDown (Windows::System::VirtualKey key)
void | KeyUp (Windows::System::VirtualKey key)
void | LoadDeferredResources (bool delay, bool deviceOnly)
void | OnFocusChange (bool active)
void | OnResuming ()
void | OnSuspending ()
void | OnViewChange (Windows::UI::ViewManagement::ApplicationViewState state)
void | RemoveTouch (int id)
virtual void | Render () override
void | Update (float timeTotal, float timeDelta)
void | UpdateTouch (int id, Windows::Foundation::Point point)

Public Attributes

internal | __pad0__: MarbleMaze()

Private Types

typedef std::vector< XMFLOAT3 > | Checkpoints
typedef std::queue< D2D1_POINT_2F > | PointQueue
typedef std::map< int, XMFLOAT2 > | TouchMap

Private Member Functions

HRESULT | ExtractTrianglesFromMesh (SDKMesh &mesh, const char *meshName, std::vector< Triangle > &triangles)
void | LoadState ()
void | ResetCheckpoints ()
void | SaveState ()
void | SetGameState (GameState nextState)
CheckpointState UpdateCheckpoints ()

Private Attributes

Windows::Devices::Sensors::Accelerometer | m_accelerometer
Audio m_audio
Microsoft::WRL::ComPtr
< ID3D11BlendState > 		m_blendState
Camera m_camera
Checkpoints m_checkpoints
TextElement m_checkpointText
Collision m_collision
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
size_t | m_currentCheckpoint
bool | m_deferredResourcesReady
GameState m_gameState
TextButton m_highScoreButton
HighScoreTable m_highScoreTable
bool | m_homeKeyActive
bool | m_homeKeyPressed
StopwatchTimer m_inGameStopwatchTimer
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
float | m_lightStrength
LoadScreen m_loadScreen
ConstantBuffer m_marbleConstantBufferData
SDKMesh m_marbleMesh
ConstantBuffer m_mazeConstantBufferData
SDKMesh m_mazeMesh
HighScoreEntry m_newHighScore
TextButton m_pausedText
bool | m_pauseKeyActive
bool | m_pauseKeyPressed
PersistentState m_persistentState
Physics m_physics
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
PointQueue m_pointQueue
CountdownTimer m_preGameCountdownTimer
bool | m_resetCamera
bool | m_resetMarbleRotation
TextElement m_resultsText
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
TextButton m_startGameButton
float | m_targetLightStrength
TouchMap m_touches
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader
unsigned int | m_vertexStride
Windows::UI::ViewManagement::ApplicationViewState | m_viewState
bool | m_windowActive

Detailed Description

Definition at line 53 of file MarbleMaze.h.

Member Typedef Documentation

typedef std::vector<XMFLOAT3> MarbleMaze::Checkpoints [private]

Definition at line 104 of file MarbleMaze.h.

typedef std::queue<D2D1_POINT_2F> MarbleMaze::PointQueue [private]

Definition at line 118 of file MarbleMaze.h.

typedef std::map<int, XMFLOAT2> MarbleMaze::TouchMap [private]

Definition at line 116 of file MarbleMaze.h.

Member Function Documentation

void MarbleMaze::AddTouch | ( | int | id,
 |  | Windows::Foundation::Point | point
 | ) |  |

Definition at line 1253 of file MarbleMaze.cpp.

{
    m_touches[id] = PointToTouch(point, m_windowBounds);

    m_pointQueue.push(D2D1::Point2F(point.X, point.Y));
}

void MarbleMaze::CreateDeviceResources ( ) [override, virtual]

Definition at line 86 of file MarbleMaze.cpp.

{
    DirectXBase::CreateDeviceResources();
    m_camera = ref new Camera();
    m_sampleOverlay = ref new SampleOverlay();
    m_loadScreen = ref new LoadScreen();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DirectX Marble Maze game sample"
        );

    m_loadScreen->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get()
        );

    UserInterface::GetInstance().Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get()
        );
}

void MarbleMaze::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 130 of file MarbleMaze.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // update the 3D projection matrix
    m_camera->SetProjectionParameters(
        40.0f,                                                  // use a 70-degree vertical field of view
        m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
        50.0f,                                                  // specify the nearest Z-distance at which to draw vertices
        500.0f                                                  // specify the farthest Z-distance at which to draw vertice
        );

    // MarbleMaze specific
    float4x4 projection;
    m_camera->GetProjectionMatrix(&projection);
    m_mazeConstantBufferData.projection = projection;
    m_marbleConstantBufferData.projection = projection;

    // user interface
    const float padding = 32.0f;
    D2D1_RECT_F clientRect = ConvertRect(m_windowBounds);
    InflateRect(clientRect, -padding, -padding);

    bool snapped = m_viewState == ApplicationViewState::Snapped;

    D2D1_RECT_F topHalfRect = clientRect;
    topHalfRect.bottom = ((clientRect.top + clientRect.bottom) / 2.0f) - (padding / 2.0f);
    D2D1_RECT_F bottomHalfRect = clientRect;
    bottomHalfRect.top = topHalfRect.bottom + padding;

    m_startGameButton.Initialize();
    m_startGameButton.SetAlignment(AlignCenter, AlignFar);
    m_startGameButton.SetContainer(topHalfRect);
    m_startGameButton.SetText(L"Start Game");
    m_startGameButton.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
    m_startGameButton.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
    if (snapped)
    {
        m_startGameButton.SetPadding(D2D1::SizeF(8.0f, 4.0f));
        m_startGameButton.GetTextStyle().SetFontSize(36.0f);
    }
    else
    {
        m_startGameButton.SetPadding(D2D1::SizeF(32.0f, 16.0f));
        m_startGameButton.GetTextStyle().SetFontSize(72.0f);
    }
    UserInterface::GetInstance().RegisterElement(&m_startGameButton);

    m_highScoreButton.Initialize();
    m_highScoreButton.SetAlignment(AlignCenter, AlignNear);
    m_highScoreButton.SetContainer(bottomHalfRect);
    m_highScoreButton.SetText(L"High Scores");
    m_highScoreButton.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
    m_highScoreButton.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
    if (snapped)
    {
        m_highScoreButton.SetPadding(D2D1::SizeF(8.0f, 4.0f));
        m_highScoreButton.GetTextStyle().SetFontSize(36.0f);
    }
    else
    {
        m_highScoreButton.SetPadding(D2D1::SizeF(32.0f, 16.0f));
        m_highScoreButton.GetTextStyle().SetFontSize(72.0f);
    }
    UserInterface::GetInstance().RegisterElement(&m_highScoreButton);

    m_highScoreTable.Initialize();
    m_highScoreTable.SetAlignment(AlignCenter, AlignCenter);
    m_highScoreTable.SetContainer(clientRect);
    m_highScoreTable.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
    m_highScoreTable.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BOLD);
    m_highScoreTable.GetTextStyle().SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER);
    if (snapped)
    {
        m_highScoreTable.GetTextStyle().SetFontSize(20.0f);
    }
    else
    {
        m_highScoreTable.GetTextStyle().SetFontSize(60.0f);
    }
    UserInterface::GetInstance().RegisterElement(&m_highScoreTable);

    m_preGameCountdownTimer.Initialize();
    m_preGameCountdownTimer.SetAlignment(AlignCenter, AlignCenter);
    m_preGameCountdownTimer.SetContainer(clientRect);
    m_preGameCountdownTimer.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
    m_preGameCountdownTimer.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
    if (snapped)
    {
        m_preGameCountdownTimer.GetTextStyle().SetFontSize(72.0f);
    }
    else
    {
        m_preGameCountdownTimer.GetTextStyle().SetFontSize(144.0f);
    }
    UserInterface::GetInstance().RegisterElement(&m_preGameCountdownTimer);

    m_inGameStopwatchTimer.Initialize();
    m_inGameStopwatchTimer.SetAlignment(AlignNear, AlignFar);
    m_inGameStopwatchTimer.SetContainer(clientRect);
    m_inGameStopwatchTimer.SetTextColor(D2D1::ColorF(D2D1::ColorF::White, 0.75f));
    m_inGameStopwatchTimer.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
    if (snapped)
    {
        m_inGameStopwatchTimer.GetTextStyle().SetFontSize(48.0f);
    }
    else
    {
        m_inGameStopwatchTimer.GetTextStyle().SetFontSize(96.0f);
    }
    UserInterface::GetInstance().RegisterElement(&m_inGameStopwatchTimer);

    m_checkpointText.Initialize();
    m_checkpointText.SetAlignment(AlignCenter, AlignCenter);
    m_checkpointText.SetContainer(clientRect);
    m_checkpointText.SetText(L"Checkpoint!");
    m_checkpointText.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
    m_checkpointText.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
    if (snapped)
    {
        m_checkpointText.GetTextStyle().SetFontSize(36.0f);
    }
    else
    {
        m_checkpointText.GetTextStyle().SetFontSize(72.0f);
    }
    UserInterface::GetInstance().RegisterElement(&m_checkpointText);

    m_pausedText.Initialize();
    m_pausedText.SetAlignment(AlignCenter, AlignCenter);
    m_pausedText.SetContainer(clientRect);
    m_pausedText.SetText(L"Paused");
    m_pausedText.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
    m_pausedText.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
    if (snapped)
    {
        m_pausedText.GetTextStyle().SetFontSize(36.0f);
    }
    else
    {
        m_pausedText.GetTextStyle().SetFontSize(72.0f);
    }
    UserInterface::GetInstance().RegisterElement(&m_pausedText);

    m_resultsText.Initialize();
    m_resultsText.SetAlignment(AlignCenter, AlignCenter);
    m_resultsText.SetContainer(clientRect);
    m_resultsText.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
    m_resultsText.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BOLD);
    m_resultsText.GetTextStyle().SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER);
    if (snapped)
    {
        m_resultsText.GetTextStyle().SetFontSize(36.0f);
    }
    else
    {
        m_resultsText.GetTextStyle().SetFontSize(72.0f);
    }
    UserInterface::GetInstance().RegisterElement(&m_resultsText);

    m_sampleOverlay->UpdateForWindowSizeChange();
    if ((!m_deferredResourcesReady) && m_loadScreen)
    {
        m_loadScreen->UpdateForWindowSizeChange();
    }
}

HRESULT MarbleMaze::ExtractTrianglesFromMesh | ( | SDKMesh & | mesh,
 |  | const char * | meshName,
 |  | std::vector< Triangle > & | triangles |
 | ) |  |  | [private]

Definition at line 1370 of file MarbleMaze.cpp.

{
    triangles.clear();

    int meshIndex = FindMeshIndexByName(mesh, meshName);
    if (meshIndex < 0)
    {
        return E_FAIL;
    }
    SDKMESH_MESH *currentmesh = mesh.GetMesh(meshIndex);

    for (UINT i = 0; i < currentmesh->NumSubsets; ++i)
    {
        SDKMESH_SUBSET *subsetmesh = mesh.GetSubset(meshIndex, i);

        USHORT *indices = (USHORT*)mesh.GetRawIndicesAt(currentmesh->IndexBuffer) + subsetmesh->IndexStart;
        BYTE *vertices = mesh.GetRawVerticesAt(currentmesh->VertexBuffers[0]) + (subsetmesh->VertexStart * m_vertexStride);
        for (UINT j = 0; j < subsetmesh->IndexCount; j += 3)
        {
            XMFLOAT3 a, b, c;
            memcpy(&a, vertices + (*(indices++) * m_vertexStride), sizeof(XMFLOAT3));
            memcpy(&b, vertices + (*(indices++) * m_vertexStride), sizeof(XMFLOAT3));
            memcpy(&c, vertices + (*(indices++) * m_vertexStride), sizeof(XMFLOAT3));
            triangles.push_back(Triangle(a, b, c));
        }
    }

    return S_OK;
}

void MarbleMaze::HandleDeviceLost ( ) [override, virtual]

Definition at line 66 of file MarbleMaze.cpp.

{
    m_deferredResourcesReady = false;

    m_d3dContext->OMSetRenderTargets(0, nullptr, nullptr);
    m_d3dDepthStencilView = nullptr;
    m_d3dRenderTargetView = nullptr;

    m_d2dContext->SetTarget(nullptr);
    m_d2dTargetBitmap = nullptr;
    m_d2dContext = nullptr;
    m_d2dDevice = nullptr;

    m_d3dContext->Flush();

    DirectXBase::HandleDeviceLost();

    LoadDeferredResources(false, true);
}

void MarbleMaze::Initialize | ( | Windows::UI::Core::CoreWindow^ | window,
 |  | float | dpi |
 | ) |  |  | [override, virtual]

Definition at line 47 of file MarbleMaze.cpp.

{
    // Apps must start processing events in 5 seconds or less,
    // so we only set up essential initial state and resources here.
    // Additional setup and resource loading happens in
    // LoadDeferredResources, which is typically called from
    // DirectXApp::Load().

    // Must happen before initializing base.
    m_audio.Initialize();

    // Returns accelerometer ref if there is one; nullptr otherwise.
    m_accelerometer = Windows::Devices::Sensors::Accelerometer::GetDefault();

    DirectXBase::Initialize(window, dpi);

    LoadState();
}

void MarbleMaze::KeyDown ( Windows::System::VirtualKey key )
void MarbleMaze::KeyUp ( Windows::System::VirtualKey key )
void MarbleMaze::LoadDeferredResources | ( | bool | delay,
 |  | bool | deviceOnly
 | ) |  |

Definition at line 297 of file MarbleMaze.cpp.

{
    BasicTimer^ loadingTimer = ref new BasicTimer;
    loadingTimer->Reset();

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    D3D11_INPUT_ELEMENT_DESC layoutDesc[] =
        {
            { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "NORMAL",   0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 24, D3D11_INPUT_PER_VERTEX_DATA, 0 },
            { "TANGENT",  0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 32, D3D11_INPUT_PER_VERTEX_DATA, 0 },
        };
    m_vertexStride = 44; // must set this to match the size of layoutDesc above

    loader->LoadShader(
        L"BasicVertexShader.cso",
        layoutDesc,
        ARRAYSIZE(layoutDesc),
        &m_vertexShader,
        &m_inputLayout
        );

    // create the constant buffer for updating model and camera data.
    D3D11_BUFFER_DESC constantBufferDesc = {0};
    constantBufferDesc.ByteWidth           = ((sizeof(ConstantBuffer) + 15) / 16) * 16; // multiple of 16 bytes
    constantBufferDesc.Usage               = D3D11_USAGE_DEFAULT;
    constantBufferDesc.BindFlags           = D3D11_BIND_CONSTANT_BUFFER;
    constantBufferDesc.CPUAccessFlags      = 0;
    constantBufferDesc.MiscFlags           = 0;
    // this will not be used as a structured buffer, so this parameter is ignored
    constantBufferDesc.StructureByteStride = 0;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &constantBufferDesc,
            nullptr,             // leave the buffer uninitialized
            &m_constantBuffer
            )
        );

    loader->LoadShader(
        L"BasicPixelShader.cso",
        &m_pixelShader
        );

    // create the blend state.
    D3D11_BLEND_DESC blendDesc = {0};
    blendDesc.RenderTarget[0].BlendEnable = TRUE;
    blendDesc.RenderTarget[0].SrcBlend = D3D11_BLEND_SRC_ALPHA;
    blendDesc.RenderTarget[0].DestBlend = D3D11_BLEND_INV_SRC_ALPHA;
    blendDesc.RenderTarget[0].BlendOp = D3D11_BLEND_OP_ADD;
    blendDesc.RenderTarget[0].SrcBlendAlpha = D3D11_BLEND_ONE;
    blendDesc.RenderTarget[0].DestBlendAlpha = D3D11_BLEND_ZERO;
    blendDesc.RenderTarget[0].BlendOpAlpha = D3D11_BLEND_OP_ADD;
    blendDesc.RenderTarget[0].RenderTargetWriteMask = D3D11_COLOR_WRITE_ENABLE_ALL;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateBlendState(
            &blendDesc,
            &m_blendState
            )
        );

    // create the sampler
    D3D11_SAMPLER_DESC samplerDesc;
    samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.MipLODBias = 0.0f;
    samplerDesc.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
    samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDesc.BorderColor[0] = 0.0f;
    samplerDesc.BorderColor[1] = 0.0f;
    samplerDesc.BorderColor[2] = 0.0f;
    samplerDesc.BorderColor[3] = 0.0f;
    // allow use of all mip levels
    samplerDesc.MinLOD = 0;
    samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDesc,
            &m_sampler
            )
        );

    // Load the meshes.
    DX::ThrowIfFailed(
        m_mazeMesh.Create(
            m_d3dDevice.Get(),
            L"Media\\Models\\maze1.sdkmesh",
            false
            )
        );

    DX::ThrowIfFailed(
        m_marbleMesh.Create(
            m_d3dDevice.Get(),
            L"Media\\Models\\marble2.sdkmesh",
            false
            )
        );

    // Extract mesh geometry for physics system.
    DX::ThrowIfFailed(
        ExtractTrianglesFromMesh(
            m_mazeMesh,
            "Mesh_walls",
            m_collision.m_wallTriList
            )
        );

    DX::ThrowIfFailed(
        ExtractTrianglesFromMesh(
            m_mazeMesh,
            "Mesh_Floor",
            m_collision.m_groundTriList
            )
        );

    DX::ThrowIfFailed(
        ExtractTrianglesFromMesh(
            m_mazeMesh,
            "Mesh_floorSides",
            m_collision.m_floorTriList
            )
        );

    m_physics.SetCollision(&m_collision);
    float radius = m_marbleMesh.GetMeshBoundingBoxExtents(0).x / 2;
    m_physics.SetRadius(radius);

    if (!deviceOnly)
    {
        // When handling device lost, we only need to recreate the graphics-device related
        // resources. All other delayed resources that only need to be created on app
        // startup go here.

        m_audio.CreateResources();
    }

    if (delay)
    {
        while (loadingTimer->Total < 3.5)
        {
            // MarbleMaze doesn't take long to load resources,
            // so we're simulating a longer load time to demonstrate
            // a more real world example
            loadingTimer->Update();
        }
    }

    m_deferredResourcesReady = true;
}

void MarbleMaze::LoadState ( ) [private]

Definition at line 1195 of file MarbleMaze.cpp.

{
    XMFLOAT3 position = m_persistentState->LoadXMFLOAT3(":Position", m_physics.GetPosition());
    XMFLOAT3 velocity = m_persistentState->LoadXMFLOAT3(":Velocity", m_physics.GetVelocity());
    float elapsedTime = m_persistentState->LoadSingle(":ElapsedTime", 0.0f);

    int gameState = m_persistentState->LoadInt32(":GameState", static_cast<int>(m_gameState));
    int currentCheckpoint = m_persistentState->LoadInt32(":Checkpoint", static_cast<int>(m_currentCheckpoint));

    switch (static_cast<GameState>(gameState))
    {
    case GameState::Initial:
        break;

    case GameState::MainMenu:
    case GameState::HighScoreDisplay:
    case GameState::PreGameCountdown:
    case GameState::PostGameResults:
        SetGameState(GameState::MainMenu);
        break;

    case GameState::InGameActive:
    case GameState::InGamePaused:
        m_inGameStopwatchTimer.SetVisible(true);
        m_inGameStopwatchTimer.SetElapsedTime(elapsedTime);
        m_physics.SetPosition(position);
        m_physics.SetVelocity(velocity);
        m_currentCheckpoint = currentCheckpoint;
        SetGameState(GameState::InGamePaused);
        break;
    }

    int count = m_persistentState->LoadInt32(":ScoreCount", 0);

    const int bufferLength = 16;
    char16 str[bufferLength];

    for (int i = 0; i < count; i++)
    {
        HighScoreEntry entry;
        int len = swprintf_s(str, bufferLength, L"%d", i);
        Platform::String^ string = ref new Platform::String(str, len);

        entry.elapsedTime = m_persistentState->LoadSingle(Platform::String::Concat(":ScoreTime", string), 0.0f);
        entry.tag = m_persistentState->LoadString(Platform::String::Concat(":ScoreTag", string), L"");
        m_highScoreTable.AddScoreToTable(entry);
    }
}

void MarbleMaze::OnFocusChange ( bool active )

Definition at line 1315 of file MarbleMaze.cpp.

{
    static bool lostFocusPause = false;

    if (m_deferredResourcesReady)
    {
        if (m_windowActive != active)
        {
            if (active)
            {
                m_audio.ResumeAudio();
                if ((m_gameState == GameState::InGamePaused) && lostFocusPause)
                {
                    SetGameState(GameState::InGameActive);
                }
            }
            else
            {
                m_audio.SuspendAudio();
                if (m_gameState == GameState::InGameActive)
                {
                    SetGameState(GameState::InGamePaused);
                    lostFocusPause = true;
                    SaveState();
                }
                else if (m_gameState == GameState::PreGameCountdown)
                {
                    SetGameState(GameState::MainMenu);
                    m_inGameStopwatchTimer.SetVisible(false);
                    m_preGameCountdownTimer.SetVisible(false);
                }
            }
            m_windowActive = active;
        }
    }
}

void MarbleMaze::OnResuming ( )

Definition at line 1310 of file MarbleMaze.cpp.

{
    m_audio.ResumeAudio();
}

void MarbleMaze::OnSuspending ( )

Definition at line 1304 of file MarbleMaze.cpp.

{
    SaveState();
    m_audio.SuspendAudio();
}

void MarbleMaze::OnViewChange ( Windows::UI::ViewManagement::ApplicationViewState state )
void MarbleMaze::RemoveTouch ( int id )

Definition at line 1266 of file MarbleMaze.cpp.

{
    m_touches.erase(id);
}

void MarbleMaze::Render ( ) [override, virtual]

Definition at line 455 of file MarbleMaze.cpp.

{
    // Bind the render targets.
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // Clear the render target and depth stencil to default values.
    const float clearColor[4] = { 0.0f, 0.0f, 0.0f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        clearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    if (!m_deferredResourcesReady)
    {
        // Only render the loading screen for now.

        m_loadScreen->Render();
        return;
    }

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    FLOAT blendFactors[4] = { 0, };
    m_d3dContext->OMSetBlendState(m_blendState.Get(), blendFactors, 0xffffffff);

    // Set the vertex shader stage state.
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),   // use this vertex shader
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    // Set the pixel shader stage state.
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),    // use this pixel shader
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->PSSetSamplers(
        0,                       // starting at the first sampler slot
        1,                       // set one sampler binding
        m_sampler.GetAddressOf() // to use this sampler
        );

#pragma region Rendering Maze

    // Update the constant buffer with the new data.
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_mazeConstantBufferData,
        0,
        0
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                // starting at the first constant buffer slot
        1,                // set one constant buffer binding
        m_constantBuffer.GetAddressOf() // to use this buffer
        );

    m_d3dContext->PSSetConstantBuffers(
        0,                // starting at the first constant buffer slot
        1,                // set one constant buffer binding
        m_constantBuffer.GetAddressOf() // to use this buffer
        );

    m_mazeMesh.Render(m_d3dContext.Get(), 0, INVALID_SAMPLER_SLOT, INVALID_SAMPLER_SLOT);

#pragma endregion

#pragma region Rendering Marble

    // update the constant buffer with the new data
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_marbleConstantBufferData,
        0,
        0
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                // starting at the first constant buffer slot
        1,                // set one constant buffer binding
        m_constantBuffer.GetAddressOf() // to use this buffer
        );

    m_d3dContext->PSSetConstantBuffers(
        0,                // starting at the first constant buffer slot
        1,                // set one constant buffer binding
        m_constantBuffer.GetAddressOf() // to use this buffer
        );

    m_marbleMesh.Render(m_d3dContext.Get(), 0, INVALID_SAMPLER_SLOT, INVALID_SAMPLER_SLOT);

#pragma endregion

    // Process audio.
    m_audio.Render();

    // Draw the user interface and the overlay.
    UserInterface::GetInstance().Render();

    m_sampleOverlay->Render();
}

void MarbleMaze::ResetCheckpoints ( ) [private]

Definition at line 670 of file MarbleMaze.cpp.

{
    m_currentCheckpoint = 0;
}

void MarbleMaze::SaveState ( ) [private]

Definition at line 1170 of file MarbleMaze.cpp.

{
    m_persistentState->SaveXMFLOAT3(":Position", m_physics.GetPosition());
    m_persistentState->SaveXMFLOAT3(":Velocity", m_physics.GetVelocity());
    m_persistentState->SaveSingle(":ElapsedTime", m_inGameStopwatchTimer.GetElapsedTime());

    m_persistentState->SaveInt32(":GameState", static_cast<int>(m_gameState));
    m_persistentState->SaveInt32(":Checkpoint", static_cast<int>(m_currentCheckpoint));

    int i = 0;
    HighScoreEntries entries = m_highScoreTable.GetEntries();
    const int bufferLength = 16;
    char16 str[bufferLength];

    m_persistentState->SaveInt32(":ScoreCount", static_cast<int>(entries.size()));
    for (auto iter = entries.begin(); iter != entries.end(); ++iter)
    {
        int len = swprintf_s(str, bufferLength, L"%d", i++);
        Platform::String^ string = ref new Platform::String(str, len);

        m_persistentState->SaveSingle(Platform::String::Concat(":ScoreTime", string), iter->elapsedTime);
        m_persistentState->SaveString(Platform::String::Concat(":ScoreTag", string), iter->tag);
    }
}

void MarbleMaze::SetGameState ( GameState nextState ) [private]

Definition at line 577 of file MarbleMaze.cpp.

{
    // previous state cleanup
    switch (m_gameState)
    {
    case GameState::MainMenu:
        m_startGameButton.SetVisible(false);
        m_highScoreButton.SetVisible(false);
        break;

    case GameState::HighScoreDisplay:
        m_highScoreTable.SetVisible(false);
        break;

    case GameState::PreGameCountdown:
        m_inGameStopwatchTimer.Reset();
        m_inGameStopwatchTimer.SetVisible(true);
        break;

    case GameState::PostGameResults:
        m_resultsText.SetVisible(false);
        break;
    }

    // next state setup
    switch (nextState)
    {
    case GameState::MainMenu:
        m_startGameButton.SetVisible(true);
        m_startGameButton.SetSelected(true);
        m_highScoreButton.SetVisible(true);
        m_highScoreButton.SetSelected(false);
        m_pausedText.SetVisible(false);

        m_resetCamera = true;
        m_resetMarbleRotation = true;
        m_physics.SetPosition(XMFLOAT3(305, -210, -43));
        m_targetLightStrength = 0.6f;
        break;

    case GameState::HighScoreDisplay:
        m_highScoreTable.SetVisible(true);
        break;

    case GameState::PreGameCountdown:
        m_inGameStopwatchTimer.SetVisible(false);
        m_preGameCountdownTimer.SetVisible(true);
        m_preGameCountdownTimer.StartCountdown(3);

        ResetCheckpoints();
        m_resetCamera = true;
        m_resetMarbleRotation = true;
        m_physics.SetPosition(m_checkpoints[0]);
        m_physics.SetVelocity(XMFLOAT3(0, 0, 0));
        m_targetLightStrength = 1.0f;
        break;

    case GameState::InGameActive:
        m_pausedText.SetVisible(false);
        m_inGameStopwatchTimer.Start();
        m_targetLightStrength = 1.0f;
        break;

    case GameState::InGamePaused:
        m_pausedText.SetVisible(true);
        m_inGameStopwatchTimer.Stop();
        m_targetLightStrength = 0.6f;
        break;

    case GameState::PostGameResults:
        m_inGameStopwatchTimer.Stop();
        m_inGameStopwatchTimer.SetVisible(false);
        m_resultsText.SetVisible(true);
        {
            WCHAR formattedTime[32];
            m_inGameStopwatchTimer.GetFormattedTime(formattedTime, m_newHighScore.elapsedTime);
            WCHAR buffer[64];
            swprintf_s(
                buffer,
                L"%s\nYour time: %s",
                (m_newHighScore.wasJustAdded ? L"New High Score!" : L"Finished!"),
                formattedTime
                );
            m_resultsText.SetText(buffer);
            m_resultsText.SetVisible(true);
        }
        m_targetLightStrength = 0.6f;
        break;
    }

    m_gameState = nextState;
}

void MarbleMaze::Update | ( | float | timeTotal,
 |  | float | timeDelta
 | ) |  |

Definition at line 717 of file MarbleMaze.cpp.

{
    // When the game is first loaded, we display a load screen
    // and load any deferred resources that might be too expensive
    // to load during initialization.
    if (!m_deferredResourcesReady)
    {
        // At this point we can draw a progress bar, or if we had
        // loaded audio, we could play audio during the loading process.

        return;
    }

    if (!m_audio.m_isAudioStarted)
    {
        m_audio.Start();
    }

    UserInterface::GetInstance().Update(timeTotal, timeDelta);

    if (m_gameState == GameState::Initial)
        SetGameState(GameState::MainMenu);

    switch (m_gameState)
    {
        case GameState::PreGameCountdown:
            if (m_preGameCountdownTimer.IsCountdownComplete())
                SetGameState(GameState::InGameActive);
            break;
    }

#pragma region Process Input

    float combinedTiltX = 0.0f;
    float combinedTiltY = 0.0f;

    // This array contains the constants from XINPUT that map to the
    // particular buttons that are used by the game.
    // The index of the array is used to associate the state of that button in
    // the wasButtonDown, isButtonDown, and combinedButtonPressed variables.

    static const WORD buttons[] =
    {
        XINPUT_GAMEPAD_A,
        XINPUT_GAMEPAD_START,
        XINPUT_GAMEPAD_DPAD_UP,
        XINPUT_GAMEPAD_DPAD_DOWN,
        XINPUT_GAMEPAD_DPAD_LEFT,
        XINPUT_GAMEPAD_DPAD_RIGHT,
        XINPUT_GAMEPAD_BACK,
    };

    static const int buttonCount = ARRAYSIZE(buttons);
    static bool wasButtonDown[XUSER_MAX_COUNT][buttonCount] = { false, };
    bool isButtonDown[XUSER_MAX_COUNT][buttonCount] = { false, };

    // Account for input on any connected controller.
    XINPUT_STATE inputState = {0};
    for (DWORD userIndex = 0; userIndex < XUSER_MAX_COUNT; ++userIndex)
    {
        DWORD result = XInputGetState(userIndex, &inputState);
        if (result != ERROR_SUCCESS)
            continue;

        SHORT thumbLeftX = inputState.Gamepad.sThumbLX;
        if (abs(thumbLeftX) < XINPUT_GAMEPAD_LEFT_THUMB_DEADZONE)
            thumbLeftX = 0;

        SHORT thumbLeftY = inputState.Gamepad.sThumbLY;
        if (abs(thumbLeftY) < XINPUT_GAMEPAD_LEFT_THUMB_DEADZONE)
            thumbLeftY = 0;

        combinedTiltX += static_cast<float>(thumbLeftX) / 32768.0f;
        combinedTiltY += static_cast<float>(thumbLeftY) / 32768.0f;

        for (int i = 0; i < buttonCount; ++i)
            isButtonDown[userIndex][i] = (inputState.Gamepad.wButtons & buttons[i]) == buttons[i];
    }

    bool combinedButtonPressed[buttonCount] = { false, };
    for (int i = 0; i < buttonCount; ++i)
    {
        for (DWORD userIndex = 0; userIndex < XUSER_MAX_COUNT; ++userIndex)
        {
            bool pressed = !wasButtonDown[userIndex][i] && isButtonDown[userIndex][i];
            combinedButtonPressed[i] = combinedButtonPressed[i] || pressed;
        }
    }

    // Check whether the user paused or resumed the game.
    // XINPUT_GAMEPAD_START
    if (combinedButtonPressed[1] || m_pauseKeyPressed)
    {
        m_pauseKeyPressed = false;
        if (m_gameState == GameState::InGameActive)
            SetGameState(GameState::InGamePaused);
        else if (m_gameState == GameState::InGamePaused)
            SetGameState(GameState::InGameActive);
    }

    // Check whether the user restarted the game or cleared the high score table.
    // XINPUT_GAMEPAD_BACK
    if (combinedButtonPressed[6] || m_homeKeyPressed)
    {
        m_homeKeyPressed = false;
        if (m_gameState == GameState::InGameActive ||
            m_gameState == GameState::InGamePaused ||
            m_gameState == GameState::PreGameCountdown)
        {
            SetGameState(GameState::MainMenu);
            m_inGameStopwatchTimer.SetVisible(false);
            m_preGameCountdownTimer.SetVisible(false);
        }
        else if (m_gameState == GameState::HighScoreDisplay)
        {
            m_highScoreTable.Reset();
        }
    }

    // Check whether the user chose a button from the UI.
    bool anyPoints = !m_pointQueue.empty();
    while (!m_pointQueue.empty())
    {
        UserInterface::GetInstance().HitTest(m_pointQueue.front());
        m_pointQueue.pop();
    }

    // Handle menu navigation.

    // XINPUT_GAMEPAD_A or XINPUT_GAMEPAD_START
    bool chooseSelection = (combinedButtonPressed[0] || combinedButtonPressed[1]);

    // XINPUT_GAMEPAD_DPAD_UP
    bool moveUp = combinedButtonPressed[2];

    // XINPUT_GAMEPAD_DPAD_DOWN
    bool moveDown = combinedButtonPressed[3];

    switch (m_gameState)
    {
    case GameState::MainMenu:
        if (chooseSelection)
        {
            m_audio.PlaySoundEffect(MenuSelectedEvent);

            if (m_startGameButton.GetSelected())
                m_startGameButton.SetPressed(true);

            if (m_highScoreButton.GetSelected())
                m_highScoreButton.SetPressed(true);
        }
        if (moveUp || moveDown)
        {
            m_startGameButton.SetSelected(!m_startGameButton.GetSelected());
            m_highScoreButton.SetSelected(!m_startGameButton.GetSelected());

            m_audio.PlaySoundEffect(MenuChangeEvent);
        }
        break;

    case GameState::HighScoreDisplay:
        if (chooseSelection || anyPoints)
            SetGameState(GameState::MainMenu);
        break;

    case GameState::PostGameResults:
        if (chooseSelection || anyPoints)
            SetGameState(GameState::HighScoreDisplay);
        break;

    case GameState::InGamePaused:
        if (m_pausedText.IsPressed())
        {
            m_pausedText.SetPressed(false);
            SetGameState(GameState::InGameActive);
        }
        break;
    }

    // Update button state for next frame.
    memcpy(wasButtonDown, isButtonDown, sizeof(wasButtonDown));

    // Update the game state if the user chose a menu option.
    if (m_startGameButton.IsPressed())
    {
        SetGameState(GameState::PreGameCountdown);
        m_startGameButton.SetPressed(false);
    }
    if (m_highScoreButton.IsPressed())
    {
        SetGameState(GameState::HighScoreDisplay);
        m_highScoreButton.SetPressed(false);
    }

    // Account for touch input.
    const float touchScalingFactor = 2.0f;
    for (TouchMap::const_iterator iter = m_touches.cbegin(); iter != m_touches.cend(); ++iter)
    {
        combinedTiltX += iter->second.x * touchScalingFactor;
        combinedTiltY += iter->second.y * touchScalingFactor;
    }

    // Account for sensors.
    const float acceleromterScalingFactor = 3.5f;
    if (m_accelerometer != nullptr)
    {
        Windows::Devices::Sensors::AccelerometerReading^ reading =
            m_accelerometer->GetCurrentReading();

        if (reading != nullptr)
        {
            combinedTiltX += static_cast<float>(reading->AccelerationX) * acceleromterScalingFactor;
            combinedTiltY += static_cast<float>(reading->AccelerationY) * acceleromterScalingFactor;
        }
    }

    // Clamp input.
    combinedTiltX = max(-1, min(1, combinedTiltX));
    combinedTiltY = max(-1, min(1, combinedTiltY));

    if (m_gameState != GameState::PreGameCountdown &&
        m_gameState != GameState::InGameActive &&
        m_gameState != GameState::InGamePaused)
    {
        // Ignore tilt when the menu is active.
        combinedTiltX = 0.0f;
        combinedTiltY = 0.0f;
    }

#pragma endregion

#pragma region Physics

    const float maxTilt = 1.0f / 8.0f;
    XMVECTOR gravity = XMVectorSet(combinedTiltX * maxTilt, combinedTiltY * maxTilt, 1.0f, 0.0f);
    gravity = XMVector3Normalize(gravity);

    XMFLOAT3 g;
    XMStoreFloat3(&g, gravity);
    m_physics.SetGravity(g);

    if (m_gameState == GameState::InGameActive)
    {
        // Only update physics when gameplay is active.
        m_physics.UpdatePhysicsSimulation(timeDelta);

        // Handle checkpoints.
        switch (UpdateCheckpoints())
        {
        case CheckpointState::Save:
            // Display checkpoint notice.
            m_checkpointText.SetVisible(true);
            m_checkpointText.SetTextOpacity(1.0f);
            m_checkpointText.FadeOut(2.0f);
            m_audio.PlaySoundEffect(CheckpointEvent);
            SaveState();
            break;

        case CheckpointState::Goal:
            m_inGameStopwatchTimer.Stop();
            m_newHighScore.elapsedTime = m_inGameStopwatchTimer.GetElapsedTime();
            SYSTEMTIME systemTime;
            GetLocalTime(&systemTime);
            WCHAR buffer[64];
            swprintf_s(buffer, L"%d/%d/%d", systemTime.wYear, systemTime.wMonth, systemTime.wDay);
            m_newHighScore.tag = ref new Platform::String(buffer);
            m_highScoreTable.AddScoreToTable(m_newHighScore);

            m_audio.PlaySoundEffect(CheckpointEvent);
            m_audio.StopSoundEffect(RollingEvent);

            // Display game results.
            SetGameState(GameState::PostGameResults);
            SaveState();
            break;
        }
    }

    float3 marblePosition;
    memcpy(&marblePosition, &m_physics.GetPosition(), sizeof(float3));
    static float3 oldMarblePosition = marblePosition;

    const float4x4 initialMarbleRotationMatrix = mul(rotationY(90.0f), rotationX(90.0f));
    static float4x4 marbleRotationMatrix = initialMarbleRotationMatrix;

    // Check whether the marble fell off of the maze.
    const float fadeOutDepth = 0.0f;
    const float resetDepth = 80.0f;
    if (marblePosition.z >= fadeOutDepth)
    {
        m_targetLightStrength = 0.0f;
    }
    if (marblePosition.z >= resetDepth)
    {
        // Reset marble.
        memcpy(&marblePosition, &m_checkpoints[m_currentCheckpoint], sizeof(XMFLOAT3));
        oldMarblePosition = marblePosition;
        m_physics.SetPosition((const XMFLOAT3&)marblePosition);
        m_physics.SetVelocity(XMFLOAT3(0, 0, 0));
        m_lightStrength = 0.0f;
        m_targetLightStrength = 1.0f;

        m_resetCamera = true;
        m_resetMarbleRotation = true;
        m_audio.PlaySoundEffect(FallingEvent);
    }

    float3 marbleRotation = (oldMarblePosition - marblePosition) / m_physics.GetRadius();
    oldMarblePosition = marblePosition;

    if (m_resetMarbleRotation)
    {
        marbleRotationMatrix = initialMarbleRotationMatrix;
        m_resetMarbleRotation = false;
    }
    else
    {
        marbleRotationMatrix = mul(rotationY(marbleRotation.x * 180.0f / 3.1415926535f), marbleRotationMatrix);
        marbleRotationMatrix = mul(rotationX(marbleRotation.y * -180.0f / 3.1415926535f), marbleRotationMatrix);
    }

#pragma endregion

#pragma region Update Camera

    static float eyeDistance = 200.0f;
    static float3 eyePosition = float3(0, 0, 0);

    // Gradually move the camera above the marble.
    float3 targetEyePosition = marblePosition - (eyeDistance * float3(g.x, g.y, g.z));
    if (m_resetCamera)
    {
        eyePosition = targetEyePosition;
        m_resetCamera = false;
    }
    else
    {
        eyePosition = eyePosition + ((targetEyePosition - eyePosition) * min(1, timeDelta * 8));
    }

    // Look at the marble.
    if ((m_gameState == GameState::MainMenu) || (m_gameState == GameState::HighScoreDisplay))
    {
        // Override camera position for menus.
        eyePosition = marblePosition + float3(75.0f, -150.0f, -75.0f);
        m_camera->SetViewParameters(eyePosition, marblePosition, float3(0.0f, 0.0f, -1.0f));
    }
    else
    {
        m_camera->SetViewParameters(eyePosition, marblePosition, float3(0.0f, 1.0f, 0.0f));
    }

#pragma endregion

#pragma region Update Constant Buffers

    // Update the model matrices based on the simulation.
    m_mazeConstantBufferData.model = identity();
    m_marbleConstantBufferData.model = mul(
        translation(marblePosition.x, marblePosition.y, marblePosition.z),
        marbleRotationMatrix
        );

    // Update the view matrix based on the camera.
    float4x4 view;
    m_camera->GetViewMatrix(&view);
    m_mazeConstantBufferData.view = view;
    m_marbleConstantBufferData.view = view;

    // Update lighting constants.
    m_lightStrength += (m_targetLightStrength - m_lightStrength) * min(1, timeDelta * 4);

    m_mazeConstantBufferData.marblePosition = marblePosition;
    m_mazeConstantBufferData.marbleRadius = m_physics.GetRadius();
    m_mazeConstantBufferData.lightStrength = m_lightStrength;
    m_marbleConstantBufferData.marblePosition = marblePosition;
    m_marbleConstantBufferData.marbleRadius = m_physics.GetRadius();
    m_marbleConstantBufferData.lightStrength = m_lightStrength;

#pragma endregion

#pragma region Update Audio

    if (! m_audio.HasEngineExperiencedCriticalError())
    {
        if (m_gameState == GameState::InGameActive)
        {
            float wallDistances[8];
            int returnedCount = m_physics.GetRoomDimensions(wallDistances, ARRAYSIZE(wallDistances));
            assert(returnedCount == ARRAYSIZE(wallDistances));
            m_audio.SetRoomSize(m_physics.GetRoomSize(), wallDistances);
            CollisionInfo ci = m_physics.GetCollisionInfo();

            // Calculate roll sound, and pitch according to velocity.
            XMFLOAT3 velocity = m_physics.GetVelocity();
            XMFLOAT3 position = m_physics.GetPosition();
            float volumeX = abs(velocity.x) / 200;
            if (volumeX > 1.0) volumeX = 1.0;
            if (volumeX < 0.0) volumeX = 0.0;
            float volumeY = abs(velocity.y) / 200;
            if (volumeY > 1.0) volumeY = 1.0;
            if (volumeY < 0.0) volumeY = 0.0;
            float volume = max(volumeX, volumeY);

            // Pitch of the rolling sound ranges from .85 to 1.05f,
            // increasing logarithmically.
            float pitch = .85f + (volume * volume / 5.0f);

            // Play the roll sound only if the marble is actually rolling.
            if (ci.isRollingOnFloor && volume > 0)
            {
                if (!m_audio.IsSoundEffectStarted(RollingEvent))
                {
                    m_audio.PlaySoundEffect(RollingEvent);
                }

                // Update the volume and pitch by the velocity.
                m_audio.SetSoundEffectVolume(RollingEvent, volume);
                m_audio.SetSoundEffectPitch(RollingEvent, pitch);

                // The rolling sound has at most 8000Hz sounds, so we linearly
                // ramp up the low-pass filter the faster we go.
                // We also reduce the Q-value of the filter, starting with a
                // relatively broad cutoff and get progressively tighter.
                m_audio.SetSoundEffectFilter(
                    RollingEvent,
                    600.0f + 8000.0f * volume,
                    XAUDIO2_MAX_FILTER_ONEOVERQ - volume*volume
                    );
            }
            else
            {
                m_audio.SetSoundEffectVolume(RollingEvent, 0);
            }

            if (ci.elasticCollision && ci.maxCollisionSpeed > 10)
            {
                m_audio.PlaySoundEffect(CollisionEvent);

                float collisionVolume = ci.maxCollisionSpeed/150.0f;
                collisionVolume = min(collisionVolume * collisionVolume, 1.0f);
                m_audio.SetSoundEffectVolume(CollisionEvent, collisionVolume);
            }
        }
        else
        {
            m_audio.SetSoundEffectVolume(RollingEvent, 0);
        }
    }
#pragma endregion

}

CheckpointState MarbleMaze::UpdateCheckpoints ( ) [private]

Definition at line 675 of file MarbleMaze.cpp.

{
    if (m_currentCheckpoint >= (m_checkpoints.size() - 1))
        return CheckpointState::None;

    const float checkpointRadius = 20.0f;
    float radius = m_physics.GetRadius();
    float horizDistSq = (radius + checkpointRadius) * (radius + checkpointRadius);
    XMVECTOR horizDistSqLimit = XMVectorSet(horizDistSq, horizDistSq, horizDistSq, horizDistSq);
    float vertDistSq = radius * radius;
    XMVECTOR vertDistSqLimit = XMVectorSet(vertDistSq, vertDistSq, vertDistSq, vertDistSq);

    XMVECTOR position = XMLoadFloat3(&m_physics.GetPosition());
    XMVECTOR up = XMVectorSet(0.0f, 0.0f, -1.0f, 0.0f);

    for (size_t i = m_currentCheckpoint + 1; i < m_checkpoints.size(); ++i)
    {
        XMVECTOR checkpointPos = XMLoadFloat3(&m_checkpoints[i]);
        XMVECTOR posCheckSpace = position - checkpointPos;
        XMVECTOR posVertical = up * XMVector3Dot(up, posCheckSpace);
        XMVECTOR posHorizontal = posCheckSpace - posVertical;
        XMVECTOR vHorizDistSq = XMVector3LengthSq(posHorizontal);
        XMVECTOR vVertDistSq = XMVector3LengthSq(posVertical);

        XMVECTOR check = XMVectorAndInt(
            XMVectorLessOrEqual(vHorizDistSq, horizDistSqLimit),
            XMVectorLessOrEqual(vVertDistSq, vertDistSqLimit)
            );
        if (XMVector3EqualInt(check, XMVectorTrueInt()))
        {
            m_currentCheckpoint = i;

            if (i == (m_checkpoints.size() - 1))
                return CheckpointState::Goal;
            else
                return CheckpointState::Save;
        }
    }

    return CheckpointState::None;
}

void MarbleMaze::UpdateTouch | ( | int | id,
 |  | Windows::Foundation::Point | point
 | ) |  |

Definition at line 1260 of file MarbleMaze.cpp.

{
    if (m_touches.find(id) != m_touches.end())
        m_touches[id] = PointToTouch(point, m_windowBounds);
}

Member Data Documentation

internal MarbleMaze::__pad0__

Definition at line 56 of file MarbleMaze.h.

Windows::Devices::Sensors::Accelerometer MarbleMaze::m_accelerometer [private]

Definition at line 88 of file MarbleMaze.h.

Audio MarbleMaze::m_audio [private]

Definition at line 100 of file MarbleMaze.h.

Microsoft::WRL::ComPtr<ID3D11BlendState> MarbleMaze::m_blendState [private]

Definition at line 86 of file MarbleMaze.h.

Camera MarbleMaze::m_camera [private]

Definition at line 90 of file MarbleMaze.h.

Checkpoints MarbleMaze::m_checkpoints [private]

Definition at line 105 of file MarbleMaze.h.

TextElement MarbleMaze::m_checkpointText [private]

Definition at line 112 of file MarbleMaze.h.

Collision MarbleMaze::m_collision [private]

Definition at line 98 of file MarbleMaze.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> MarbleMaze::m_constantBuffer [private]

Definition at line 85 of file MarbleMaze.h.

size_t MarbleMaze::m_currentCheckpoint [private]

Definition at line 106 of file MarbleMaze.h.

bool MarbleMaze::m_deferredResourcesReady [private]

Definition at line 125 of file MarbleMaze.h.

GameState MarbleMaze::m_gameState [private]

Definition at line 101 of file MarbleMaze.h.

TextButton MarbleMaze::m_highScoreButton [private]

Definition at line 108 of file MarbleMaze.h.

HighScoreTable MarbleMaze::m_highScoreTable [private]

Definition at line 109 of file MarbleMaze.h.

bool MarbleMaze::m_homeKeyActive [private]

Definition at line 122 of file MarbleMaze.h.

bool MarbleMaze::m_homeKeyPressed [private]

Definition at line 123 of file MarbleMaze.h.

StopwatchTimer MarbleMaze::m_inGameStopwatchTimer [private]

Definition at line 111 of file MarbleMaze.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> MarbleMaze::m_inputLayout [private]

Definition at line 81 of file MarbleMaze.h.

float MarbleMaze::m_lightStrength [private]

Definition at line 96 of file MarbleMaze.h.

LoadScreen MarbleMaze::m_loadScreen [private]

Definition at line 79 of file MarbleMaze.h.

ConstantBuffer MarbleMaze::m_marbleConstantBufferData [private]

Definition at line 93 of file MarbleMaze.h.

SDKMesh MarbleMaze::m_marbleMesh [private]

Definition at line 94 of file MarbleMaze.h.

ConstantBuffer MarbleMaze::m_mazeConstantBufferData [private]

Definition at line 91 of file MarbleMaze.h.

SDKMesh MarbleMaze::m_mazeMesh [private]

Definition at line 92 of file MarbleMaze.h.

HighScoreEntry MarbleMaze::m_newHighScore [private]

Definition at line 115 of file MarbleMaze.h.

TextButton MarbleMaze::m_pausedText [private]

Definition at line 113 of file MarbleMaze.h.

bool MarbleMaze::m_pauseKeyActive [private]

Definition at line 120 of file MarbleMaze.h.

bool MarbleMaze::m_pauseKeyPressed [private]

Definition at line 121 of file MarbleMaze.h.

PersistentState MarbleMaze::m_persistentState [private]

Definition at line 126 of file MarbleMaze.h.

Physics MarbleMaze::m_physics [private]

Definition at line 99 of file MarbleMaze.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> MarbleMaze::m_pixelShader [private]

Definition at line 83 of file MarbleMaze.h.

PointQueue MarbleMaze::m_pointQueue [private]

Definition at line 119 of file MarbleMaze.h.

CountdownTimer MarbleMaze::m_preGameCountdownTimer [private]

Definition at line 110 of file MarbleMaze.h.

bool MarbleMaze::m_resetCamera [private]

Definition at line 102 of file MarbleMaze.h.

bool MarbleMaze::m_resetMarbleRotation [private]

Definition at line 103 of file MarbleMaze.h.

TextElement MarbleMaze::m_resultsText [private]

Definition at line 114 of file MarbleMaze.h.

SampleOverlay MarbleMaze::m_sampleOverlay [private]

Definition at line 78 of file MarbleMaze.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> MarbleMaze::m_sampler [private]

Definition at line 84 of file MarbleMaze.h.

TextButton MarbleMaze::m_startGameButton [private]

Definition at line 107 of file MarbleMaze.h.

float MarbleMaze::m_targetLightStrength [private]

Definition at line 97 of file MarbleMaze.h.

TouchMap MarbleMaze::m_touches [private]

Definition at line 117 of file MarbleMaze.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> MarbleMaze::m_vertexShader [private]

Definition at line 82 of file MarbleMaze.h.

unsigned int MarbleMaze::m_vertexStride [private]

Definition at line 95 of file MarbleMaze.h.

Windows::UI::ViewManagement::ApplicationViewState MarbleMaze::m_viewState [private]

Definition at line 87 of file MarbleMaze.h.

bool MarbleMaze::m_windowActive [private]

Definition at line 124 of file MarbleMaze.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/MarbleMaze.h
  • DirectX marble maze game/C++/MarbleMaze.cpp
Generated on Sat Nov 23 2024 16:09:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Material Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Material Class Reference

#include "Material.h"

List of all members.

Public Member Functions

void | RenderSetup (_In_ ID3D11DeviceContext *context, _Inout_ ConstantBufferChangesEveryPrim *constantBuffer)
void | RenderSetup (_In_ ID3D11DeviceContext *context, _Inout_ ConstantBufferChangesEveryPrim *constantBuffer)
void | SetTexture (_In_ ID3D11ShaderResourceView *textureResourceView)
void | SetTexture (_In_ ID3D11ShaderResourceView *textureResourceView)

Public Attributes

internal | __pad0__: Material( DirectX::XMFLOAT4 meshColor
internal DirectX::XMFLOAT4 | diffuseColor
internal DirectX::XMFLOAT4
DirectX::XMFLOAT4 float _In_
ID3D11ShaderResourceView _In_
ID3D11VertexShader _In_
ID3D11PixelShader * 		pixelShader
internal DirectX::XMFLOAT4
DirectX::XMFLOAT4 		specularColor
internal DirectX::XMFLOAT4
DirectX::XMFLOAT4 float 		specularExponent
internal DirectX::XMFLOAT4
DirectX::XMFLOAT4 float _In_
ID3D11ShaderResourceView * 		textureResourceView
internal DirectX::XMFLOAT4
DirectX::XMFLOAT4 float _In_
ID3D11ShaderResourceView _In_
ID3D11VertexShader * 		vertexShader

Private Attributes

DirectX::XMFLOAT4 | m_diffuseColor
DirectX::XMFLOAT4 | m_hitColor
DirectX::XMFLOAT4 | m_meshColor
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
DirectX::XMFLOAT4 | m_specularColor
float | m_specularExponent
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureRV
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 21 of file Material.h.

Member Function Documentation

void Material::RenderSetup | ( | _In_ ID3D11DeviceContext * | context,
 |  | _Inout_ ConstantBufferChangesEveryPrim * | constantBuffer
 | ) |  |

Definition at line 38 of file Material.cpp.

{
    constantBuffer->meshColor = m_meshColor;
    constantBuffer->specularColor = m_specularColor;
    constantBuffer->specularPower = m_specularExponent;
    constantBuffer->diffuseColor = m_diffuseColor;

    context->PSSetShaderResources(0, 1, m_textureRV.GetAddressOf());
    context->VSSetShader(m_vertexShader.Get(), nullptr, 0);
    context->PSSetShader(m_pixelShader.Get(), nullptr, 0);
}

void Material::RenderSetup | ( | _In_ ID3D11DeviceContext * | context,
 |  | _Inout_ ConstantBufferChangesEveryPrim * | constantBuffer
 | ) |  |
void Material::SetTexture ( _In_ ID3D11ShaderResourceView * textureResourceView ) [inline]

Definition at line 39 of file Material.h.

    {
        m_textureRV = textureResourceView;
    }

void Material::SetTexture ( _In_ ID3D11ShaderResourceView * textureResourceView ) [inline]

Definition at line 39 of file Material.h.

    {
        m_textureRV = textureResourceView;
    }

Member Data Documentation

internal Material::__pad0__

Definition at line 25 of file Material.h.

internal DirectX::XMFLOAT4 Material::diffuseColor

Definition at line 25 of file Material.h.

DirectX::XMFLOAT4 Material::m_diffuseColor [private]

Definition at line 46 of file Material.h.

DirectX::XMFLOAT4 Material::m_hitColor [private]

Definition at line 47 of file Material.h.

DirectX::XMFLOAT4 Material::m_meshColor [private]

Definition at line 45 of file Material.h.

Microsoft::WRL::ComPtr< ID3D11PixelShader > Material::m_pixelShader [private]

Definition at line 52 of file Material.h.

DirectX::XMFLOAT4 Material::m_specularColor [private]

Definition at line 48 of file Material.h.

float Material::m_specularExponent [private]

Definition at line 49 of file Material.h.

Microsoft::WRL::ComPtr< ID3D11ShaderResourceView > Material::m_textureRV [private]

Definition at line 53 of file Material.h.

Microsoft::WRL::ComPtr< ID3D11VertexShader > Material::m_vertexShader [private]

Definition at line 51 of file Material.h.

internal DirectX::XMFLOAT4 DirectX::XMFLOAT4 float _In_ ID3D11ShaderResourceView _In_ ID3D11VertexShader _In_ ID3D11PixelShader * Material::pixelShader

Definition at line 25 of file Material.h.

internal DirectX::XMFLOAT4 DirectX::XMFLOAT4 Material::specularColor

Definition at line 25 of file Material.h.

internal DirectX::XMFLOAT4 DirectX::XMFLOAT4 float Material::specularExponent

Definition at line 25 of file Material.h.

internal DirectX::XMFLOAT4 DirectX::XMFLOAT4 float _In_ ID3D11ShaderResourceView * Material::textureResourceView

Definition at line 25 of file Material.h.

internal DirectX::XMFLOAT4 DirectX::XMFLOAT4 float _In_ ID3D11ShaderResourceView _In_ ID3D11VertexShader * Material::vertexShader

Definition at line 25 of file Material.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Material.h
  • XAML DirectX 3D shooting game/C++/Material.h
  • DirectX 3D shooting game/C++/Material.cpp
  • XAML DirectX 3D shooting game/C++/Material.cpp
Generated on Sat Nov 23 2024 16:09:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Matrix4x4< T > Struct Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Matrix4x4< T > Struct Template Reference

#include "BasicMath.h"

List of all members.

Public Member Functions

Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T value=0)
Matrix4x4 (T value=0)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44)
Matrix4x4 (T value=0)
Matrix4x4 (T value=0)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)
T * | operator[] (unsigned int index)

Public Attributes

union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};
union {
struct {
T _11
T _12
T _13
T _14
T _21
T _22
T _23
T _24
T _31
T _32
T _33
T _34
T _41
T _42
T _43
T _44
}
struct {
T _m00
T _m01
T _m02
T _m03
T _m10
T _m11
T _m12
T _m13
T _m20
T _m21
T _m22
T _m23
T _m30
T _m31
T _m32
T _m33
}
};

Detailed Description

template<class T>
struct Matrix4x4< T >

Definition at line 111 of file BasicMath.h.

Constructor & Destructor Documentation

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 ( T value = 0 ) [inline]

Definition at line 131 of file BasicMath.h.

    {
        _11 = _12 = _13 = _14 = value;
        _21 = _22 = _23 = _24 = value;
        _31 = _32 = _33 = _34 = value;
        _41 = _42 = _43 = _44 = value;
    }

template<class T>
Matrix4x4< T >::Matrix4x4 | ( | T | i11,
 |  | T | i12,
 |  | T | i13,
 |  | T | i14,
 |  | T | i21,
 |  | T | i22,
 |  | T | i23,
 |  | T | i24,
 |  | T | i31,
 |  | T | i32,
 |  | T | i33,
 |  | T | i34,
 |  | T | i41,
 |  | T | i42,
 |  | T | i43,
 |  | T | i44 |
 | ) |  |  | [inline]

Definition at line 139 of file BasicMath.h.

    {
        _11 = i11; _12 = i12; _13 = i13; _14 = i14;
        _21 = i21; _22 = i22; _23 = i23; _24 = i24;
        _31 = i31; _32 = i32; _33 = i33; _34 = i34;
        _41 = i41; _42 = i42; _43 = i43; _44 = i44;
    }

Member Function Documentation

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

template<class T>
T* Matrix4x4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 152 of file BasicMath.h.

    {
        return &(reinterpret_cast<T*>(this)[index*4]);
    }

Member Data Documentation

union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
template<class T>
T Matrix4x4< T >::_11

Definition at line 117 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_12

Definition at line 117 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_13

Definition at line 117 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_14

Definition at line 117 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_21

Definition at line 118 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_22

Definition at line 118 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_23

Definition at line 118 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_24

Definition at line 118 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_31

Definition at line 119 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_32

Definition at line 119 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_33

Definition at line 119 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_34

Definition at line 119 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_41

Definition at line 120 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_42

Definition at line 120 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_43

Definition at line 120 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_44

Definition at line 120 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m00

Definition at line 124 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m01

Definition at line 124 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m02

Definition at line 124 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m03

Definition at line 124 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m10

Definition at line 125 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m11

Definition at line 125 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m12

Definition at line 125 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m13

Definition at line 125 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m20

Definition at line 126 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m21

Definition at line 126 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m22

Definition at line 126 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m23

Definition at line 126 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m30

Definition at line 127 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m31

Definition at line 127 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m32

Definition at line 127 of file BasicMath.h.

template<class T>
T Matrix4x4< T >::_m33

Definition at line 127 of file BasicMath.h.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/BasicMath.h
  • Direct3D HLSL fractal generator/C++/BasicMath.h
  • Direct3D post-processing effects/C++/BasicMath.h
  • Direct3D resource loading/C++/BasicMath.h
  • Direct3D resource loading/C++/obj2vbo/BasicMath.h
  • Direct3D sprite/C++/BasicMath.h
  • Direct3D stereoscopic 3D/C++/BasicMath.h
  • Direct3D tutorial/C++/Lesson2.Triangles/BasicMath.h
  • Direct3D tutorial/C++/Lesson3.Cubes/BasicMath.h
  • Direct3D tutorial/C++/Lesson4.Textures/BasicMath.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicMath.h
  • Direct3D-Direct2D interop/C++/BasicMath.h
  • DirectX 3D shooting game/C++/BasicMath.h
  • DirectX marble maze game/C++/BasicMath.h
  • DirectX postcard app/C++/BasicMath.h
  • DirectX touch input/C++/BasicMath.h
  • DXGI offer and reclaim resources/C++/BasicMath.h
  • DXGI swap chain rotation/C++/BasicMath.h
  • XAML DirectX 3D shooting game/C++/BasicMath.h
  • XAudio2 audio file playback/C++/BasicMath.h
  • XAudio2 audio stream effect/C++/BasicMath.h
  • XInput audio controller playback/C++/BasicMath.h
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaCapture::AudioCapture Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaCapture
  • MediaCapture::AudioCapture
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

MediaCapture::AudioCapture Class Reference

An empty page that can be used on its own or navigated to within a Frame.

Inherits SDKTemplate::Common::LayoutAwarePage.

List of all members.

Public Member Functions

AudioCapture ()
void | Failed (Windows.Media.Capture.MediaCapture currentCaptureObject, MediaCaptureFailedEventArgs currentFailure)
async void | RecordLimitationExceeded (Windows.Media.Capture.MediaCapture currentCaptureObject)

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

internal async void | btnStartDevice_Click (Object sender, Windows.UI.Xaml.RoutedEventArgs e)
internal async void | btnStartStopRecord_Click (Object sender, Windows.UI.Xaml.RoutedEventArgs e)
void | EnableButton (bool enabled, String name)
async void | MediaControl_SoundLevelChanged (object sender, Object e)
void | ScenarioInit ()
void | ScenarioReset ()
void | ShowExceptionMessage (Exception ex)
void | ShowStatusMessage (String text)
void | SwitchRecordButtonContent ()

Private Attributes

readonly String | AUDIO_FILE_NAME = "audio.mp4"
bool | m_bRecording
bool | m_bSuspended
Windows.Media.Capture.MediaCapture | m_mediaCaptureMgr
Windows.Storage.StorageFile | m_recordStorageFile
EventHandler< Object > | m_soundLevelHandler
MainPage | rootPage = MainPage.Current

Detailed Description

Definition at line 23 of file AudioCapture.xaml.cs.

Constructor & Destructor Documentation

MediaCapture::AudioCapture::AudioCapture ( ) [inline]

Definition at line 37 of file AudioCapture.xaml.cs.

        {
            this.InitializeComponent();
            ScenarioInit();
            m_soundLevelHandler = new EventHandler<Object>(MediaControl_SoundLevelChanged);
        }

Member Function Documentation

internal async void MediaCapture::AudioCapture::btnStartDevice_Click | ( | Object | sender,
 |  | Windows.UI.Xaml.RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 153 of file AudioCapture.xaml.cs.

        {
            try
            {
                EnableButton(false, "StartDevice");
                ShowStatusMessage("Starting device");
                m_mediaCaptureMgr = new Windows.Media.Capture.MediaCapture();
                var settings = new Windows.Media.Capture.MediaCaptureInitializationSettings();
                settings.StreamingCaptureMode = Windows.Media.Capture.StreamingCaptureMode.Audio;
                await m_mediaCaptureMgr.InitializeAsync();

                EnableButton(true, "StartPreview");
                EnableButton(true, "StartStopRecord");
                EnableButton(true, "TakePhoto");
                ShowStatusMessage("Device initialized successful");
                m_mediaCaptureMgr.RecordLimitationExceeded += new Windows.Media.Capture.RecordLimitationExceededEventHandler(RecordLimitationExceeded); ;
                m_mediaCaptureMgr.Failed += new Windows.Media.Capture.MediaCaptureFailedEventHandler(Failed); ;

            }
            catch (Exception exception)
            {
                ShowExceptionMessage(exception);
            }
        }

internal async void MediaCapture::AudioCapture::btnStartStopRecord_Click | ( | Object | sender,
 |  | Windows.UI.Xaml.RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 178 of file AudioCapture.xaml.cs.

        {
            try
            {
                String fileName;
                EnableButton(false, "StartStopRecord");

                if (!m_bRecording)
                {
                    ShowStatusMessage("Starting Record");

                    fileName = AUDIO_FILE_NAME;

                    m_recordStorageFile = await Windows.Storage.KnownFolders.VideosLibrary.CreateFileAsync(fileName, Windows.Storage.CreationCollisionOption.GenerateUniqueName);

                    ShowStatusMessage("Create record file successful");

                    MediaEncodingProfile recordProfile = null;
                    recordProfile = MediaEncodingProfile.CreateM4a(Windows.Media.MediaProperties.AudioEncodingQuality.Auto);

                    await m_mediaCaptureMgr.StartRecordToStorageFileAsync(recordProfile, this.m_recordStorageFile);

                    m_bRecording = true;
                    SwitchRecordButtonContent();
                    EnableButton(true, "StartStopRecord");

                    ShowStatusMessage("Start Record successful");

                }
                else
                {
                    ShowStatusMessage("Stopping Record");

                    await m_mediaCaptureMgr.StopRecordAsync();

                    m_bRecording = false;
                    EnableButton(true, "StartStopRecord");
                    SwitchRecordButtonContent();

                    ShowStatusMessage("Stop record successful");
                    if (!m_bSuspended)
                    {
                        var stream = await m_recordStorageFile.OpenAsync(Windows.Storage.FileAccessMode.Read);

                        ShowStatusMessage("Record file opened");
                        ShowStatusMessage(this.m_recordStorageFile.Path);
                        playbackElement3.AutoPlay = true;
                        playbackElement3.SetSource(stream, this.m_recordStorageFile.FileType);
                        playbackElement3.Play();

                    }

                }
            }
            catch (Exception exception)
            {
                EnableButton(true, "StartStopRecord");
                ShowExceptionMessage(exception);
                m_bRecording = false;
            }
        }

void MediaCapture::AudioCapture::EnableButton | ( | bool | enabled,
 |  | String | name |
 | ) |  |  | [inline, private]

Definition at line 264 of file AudioCapture.xaml.cs.

        {
            if (name.Equals("StartDevice"))
            {
                btnStartDevice3.IsEnabled = enabled;
            }

            else if (name.Equals("StartStopRecord"))
            {
                btnStartStopRecord3.IsEnabled = enabled;
            }

        }

void MediaCapture::AudioCapture::Failed | ( | Windows.Media.Capture.MediaCapture | currentCaptureObject,
 |  | MediaCaptureFailedEventArgs | currentFailure |
 | ) |  |  | [inline]

Definition at line 129 of file AudioCapture.xaml.cs.

        {
            try
            {
                var ignored = Dispatcher.RunAsync(Windows.UI.Core.CoreDispatcherPriority.Normal, () =>
                {
                    try
                    {
                        ShowStatusMessage("Fatal error" + currentFailure.Message);

                    }
                    catch (Exception e)
                    {
                        ShowExceptionMessage(e);
                    }
                });
            }
            catch (Exception e)
            {
                ShowExceptionMessage(e);
            }
        }

async void MediaCapture::AudioCapture::MediaControl_SoundLevelChanged | ( | object | sender,
 |  | Object | e |
 | ) |  |  | [inline, private]

Definition at line 75 of file AudioCapture.xaml.cs.

        {
            await Dispatcher.RunAsync(Windows.UI.Core.CoreDispatcherPriority.Normal, async () =>
            {
                if (Windows.Media.MediaControl.SoundLevel != Windows.Media.SoundLevel.Muted)
                {
                    ScenarioReset();
                }
                else
                {
                    if (m_bRecording)
                    {
                        ShowStatusMessage("Stopping Record on invisibility");

                        await m_mediaCaptureMgr.StopRecordAsync();
                        m_bRecording = false;
                        EnableButton(true, "StartStopRecord");
                    }
                }
            });
        }

override void MediaCapture::AudioCapture::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 54 of file AudioCapture.xaml.cs.

        {
            Windows.Media.MediaControl.SoundLevelChanged -= m_soundLevelHandler;
        }

override void MediaCapture::AudioCapture::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 49 of file AudioCapture.xaml.cs.

        {
            Windows.Media.MediaControl.SoundLevelChanged += m_soundLevelHandler;
        }

async void MediaCapture::AudioCapture::RecordLimitationExceeded ( Windows.Media.Capture.MediaCapture currentCaptureObject ) [inline]

Definition at line 98 of file AudioCapture.xaml.cs.

        {
            try
            {
                if (m_bRecording)
                {
                    await Dispatcher.RunAsync(Windows.UI.Core.CoreDispatcherPriority.Normal, async () =>
                    {
                        try
                        {
                            ShowStatusMessage("Stopping Record on exceeding max record duration");
                            await m_mediaCaptureMgr.StopRecordAsync();
                            m_bRecording = false;
                            SwitchRecordButtonContent();
                            EnableButton(true, "StartStopRecord");
                            ShowStatusMessage("Stopped record on exceeding max record duration:" + m_recordStorageFile.Path);
                        }
                        catch (Exception e)
                        {
                            ShowExceptionMessage(e);
                        }

                    });
                }
            }
            catch (Exception e)
            {
                ShowExceptionMessage(e);
            }
        }

void MediaCapture::AudioCapture::ScenarioInit ( ) [inline, private]

Definition at line 59 of file AudioCapture.xaml.cs.

        {
            btnStartDevice3.IsEnabled = true;
            btnStartStopRecord3.IsEnabled = false;
            m_bRecording = false;
            playbackElement3.Source = null;
            m_bSuspended = false;
            ShowStatusMessage("");

        }

void MediaCapture::AudioCapture::ScenarioReset ( ) [inline, private]

Definition at line 70 of file AudioCapture.xaml.cs.

        {
            ScenarioInit();
        }

void MediaCapture::AudioCapture::ShowExceptionMessage ( Exception ex ) [inline, private]

Definition at line 245 of file AudioCapture.xaml.cs.

        {
            rootPage.NotifyUser(ex.Message, NotifyType.ErrorMessage);
        }

void MediaCapture::AudioCapture::ShowStatusMessage ( String text ) [inline, private]

Definition at line 240 of file AudioCapture.xaml.cs.

        {
            rootPage.NotifyUser(text, NotifyType.StatusMessage);
        }

void MediaCapture::AudioCapture::SwitchRecordButtonContent ( ) [inline, private]

Definition at line 250 of file AudioCapture.xaml.cs.

        {
            {
                if (m_bRecording)
                {
                    btnStartStopRecord3.Content = "StopRecord";
                }
                else
                {
                    btnStartStopRecord3.Content = "StartRecord";
                }
            }
        }

Member Data Documentation

readonly String MediaCapture::AudioCapture::AUDIO_FILE_NAME = "audio.mp4" [private]

Definition at line 31 of file AudioCapture.xaml.cs.

bool MediaCapture::AudioCapture::m_bRecording [private]

Definition at line 27 of file AudioCapture.xaml.cs.

bool MediaCapture::AudioCapture::m_bSuspended [private]

Definition at line 28 of file AudioCapture.xaml.cs.

Windows.Media.Capture.MediaCapture MediaCapture::AudioCapture::m_mediaCaptureMgr [private]

Definition at line 25 of file AudioCapture.xaml.cs.

Windows.Storage.StorageFile MediaCapture::AudioCapture::m_recordStorageFile [private]

Definition at line 26 of file AudioCapture.xaml.cs.

EventHandler<Object> MediaCapture::AudioCapture::m_soundLevelHandler [private]

Definition at line 29 of file AudioCapture.xaml.cs.

MainPage MediaCapture::AudioCapture::rootPage = MainPage.Current [private]

Definition at line 35 of file AudioCapture.xaml.cs.

The documentation for this class was generated from the following file:
  • Media capture using capture device/C#,C++/AudioCapture.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaCapture::BasicCapture Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaCapture
  • MediaCapture::BasicCapture
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

MediaCapture::BasicCapture Class Reference

An empty page that can be used on its own or navigated to within a Frame.

Inherits SDKTemplate::Common::LayoutAwarePage.

List of all members.

Public Member Functions

BasicCapture ()
async void | Failed (Windows.Media.Capture.MediaCapture currentCaptureObject, MediaCaptureFailedEventArgs currentFailure)
async void | RecordLimitationExceeded (Windows.Media.Capture.MediaCapture currentCaptureObject)

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

internal async void | btnStartDevice_Click (Object sender, Windows.UI.Xaml.RoutedEventArgs e)
internal async void | btnStartPreview_Click (Object sender, Windows.UI.Xaml.RoutedEventArgs e)
internal async void | btnStartStopRecord_Click (Object sender, Windows.UI.Xaml.RoutedEventArgs e)
internal async void | btnTakePhoto_Click (Object sender, Windows.UI.Xaml.RoutedEventArgs e)
void | EnableButton (bool enabled, String name)
async void | MediaControl_SoundLevelChanged (object sender, Object e)
void | ScenarioInit ()
void | ScenarioReset ()
void | SetupVideoDeviceControl (Windows.Media.Devices.MediaDeviceControl videoDeviceControl, Slider slider)
void | ShowExceptionMessage (Exception ex)
void | ShowStatusMessage (String text)
internal void | sldBrightness_ValueChanged (Object sender, Windows.UI.Xaml.Controls.Primitives.RangeBaseValueChangedEventArgs e)
internal void | sldContrast_ValueChanged (Object sender, Windows.UI.Xaml.Controls.Primitives.RangeBaseValueChangedEventArgs e)
void | SwitchRecordButtonContent ()

Private Attributes

bool | m_bPreviewing
bool | m_bRecording
bool | m_bSuspended
Windows.Media.Capture.MediaCapture | m_mediaCaptureMgr
Windows.Storage.StorageFile | m_photoStorageFile
Windows.Storage.StorageFile | m_recordStorageFile
EventHandler< Object > | m_soundLevelHandler
readonly String | PHOTO_FILE_NAME = "photo.jpg"
MainPage | rootPage = MainPage.Current
readonly String | VIDEO_FILE_NAME = "video.mp4"

Detailed Description

Definition at line 25 of file BasicCapture.xaml.cs.

Constructor & Destructor Documentation

MediaCapture::BasicCapture::BasicCapture ( ) [inline]

Definition at line 42 of file BasicCapture.xaml.cs.

        {
            this.InitializeComponent();
            ScenarioInit();
            m_soundLevelHandler = new EventHandler<Object>(MediaControl_SoundLevelChanged);
        }

Member Function Documentation

internal async void MediaCapture::BasicCapture::btnStartDevice_Click | ( | Object | sender,
 |  | Windows.UI.Xaml.RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 179 of file BasicCapture.xaml.cs.

        {
            try
            {
                EnableButton(false, "StartDevice");
                ShowStatusMessage("Starting device");
                m_mediaCaptureMgr = new Windows.Media.Capture.MediaCapture();
                await m_mediaCaptureMgr.InitializeAsync();

                EnableButton(true, "StartPreview");
                EnableButton(true, "StartStopRecord");
                EnableButton(true, "TakePhoto");
                ShowStatusMessage("Device initialized successful");

                m_mediaCaptureMgr.RecordLimitationExceeded += new Windows.Media.Capture.RecordLimitationExceededEventHandler(RecordLimitationExceeded); ;
                m_mediaCaptureMgr.Failed += new Windows.Media.Capture.MediaCaptureFailedEventHandler(Failed); ;

            }
            catch (Exception exception)
            {
                ShowExceptionMessage(exception);
            }
        }

internal async void MediaCapture::BasicCapture::btnStartPreview_Click | ( | Object | sender,
 |  | Windows.UI.Xaml.RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 203 of file BasicCapture.xaml.cs.

        {
            m_bPreviewing = false;
            try
            {
                ShowStatusMessage("Starting preview");
                EnableButton(false, "StartPreview");

                previewCanvas1.Visibility = Windows.UI.Xaml.Visibility.Visible;
                previewElement1.Source = m_mediaCaptureMgr;
                await m_mediaCaptureMgr.StartPreviewAsync();
                if ((m_mediaCaptureMgr.VideoDeviceController.Brightness != null) && m_mediaCaptureMgr.VideoDeviceController.Brightness.Capabilities.Supported)
                {
                    SetupVideoDeviceControl(m_mediaCaptureMgr.VideoDeviceController.Brightness, sldBrightness);
                }
                if ((m_mediaCaptureMgr.VideoDeviceController.Contrast != null) && m_mediaCaptureMgr.VideoDeviceController.Contrast.Capabilities.Supported)
                {
                    SetupVideoDeviceControl(m_mediaCaptureMgr.VideoDeviceController.Contrast, sldContrast);
                }
                m_bPreviewing = true;
                ShowStatusMessage("Start preview successful");

            }
            catch (Exception exception)
            {
                m_bPreviewing = false;
                previewElement1.Source = null;
                EnableButton(true, "StartPreview");
                ShowExceptionMessage(exception);
            }
        }

internal async void MediaCapture::BasicCapture::btnStartStopRecord_Click | ( | Object | sender,
 |  | Windows.UI.Xaml.RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 273 of file BasicCapture.xaml.cs.

        {
            try
            {
                String fileName;
                EnableButton(false, "StartStopRecord");

                if (!m_bRecording)
                {
                    ShowStatusMessage("Starting Record");

                    fileName = VIDEO_FILE_NAME;

                    m_recordStorageFile = await Windows.Storage.KnownFolders.VideosLibrary.CreateFileAsync(fileName, Windows.Storage.CreationCollisionOption.GenerateUniqueName);

                    ShowStatusMessage("Create record file successful");

                    MediaEncodingProfile recordProfile = null;
                    recordProfile = MediaEncodingProfile.CreateMp4(Windows.Media.MediaProperties.VideoEncodingQuality.Auto);

                    await m_mediaCaptureMgr.StartRecordToStorageFileAsync(recordProfile, m_recordStorageFile);
                    m_bRecording = true;
                    SwitchRecordButtonContent();
                    EnableButton(true, "StartStopRecord");

                    ShowStatusMessage("Start Record successful");

                }
                else
                {
                    ShowStatusMessage("Stopping Record");

                    await m_mediaCaptureMgr.StopRecordAsync();

                    m_bRecording = false;
                    EnableButton(true, "StartStopRecord");
                    SwitchRecordButtonContent();

                    ShowStatusMessage("Stop record successful");
                    if (!m_bSuspended)
                    {
                        var stream = await m_recordStorageFile.OpenAsync(Windows.Storage.FileAccessMode.Read);

                        ShowStatusMessage("Record file opened");
                        ShowStatusMessage(this.m_recordStorageFile.Path);
                        playbackElement1.AutoPlay = true;
                        playbackElement1.SetSource(stream, this.m_recordStorageFile.FileType);
                        playbackElement1.Play();

                    }

                }
            }
            catch (Exception ex)
            {
                ShowExceptionMessage(ex);
                m_bRecording = false;
                SwitchRecordButtonContent();
                EnableButton(true, "StartStopRecord");
            }

        }

internal async void MediaCapture::BasicCapture::btnTakePhoto_Click | ( | Object | sender,
 |  | Windows.UI.Xaml.RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 235 of file BasicCapture.xaml.cs.

        {
            try
            {
                ShowStatusMessage("Taking photo");
                EnableButton(false, "TakePhoto");

                m_photoStorageFile = await Windows.Storage.KnownFolders.PicturesLibrary.CreateFileAsync(PHOTO_FILE_NAME, Windows.Storage.CreationCollisionOption.GenerateUniqueName);

                ShowStatusMessage("Create photo file successful");
                ImageEncodingProperties imageProperties = ImageEncodingProperties.CreateJpeg();

                await m_mediaCaptureMgr.CapturePhotoToStorageFileAsync(imageProperties, m_photoStorageFile);

                EnableButton(true, "TakePhoto");
                ShowStatusMessage("Photo taken");

                var photoStream = await m_photoStorageFile.OpenAsync(Windows.Storage.FileAccessMode.Read);

                ShowStatusMessage("File open successful");
                var bmpimg = new BitmapImage();

                bmpimg.SetSource(photoStream);
                imageElement1.Source = bmpimg;
                ShowStatusMessage(this.m_photoStorageFile.Path);

            }
            catch (Exception exception)
            {
                ShowExceptionMessage(exception);
                EnableButton(true, "TakePhoto");
            }
        }

void MediaCapture::BasicCapture::EnableButton | ( | bool | enabled,
 |  | String | name |
 | ) |  |  | [inline, private]

Definition at line 423 of file BasicCapture.xaml.cs.

        {
            if (name.Equals("StartDevice"))
            {
                btnStartDevice1.IsEnabled = enabled;
            }
            else if (name.Equals("StartPreview"))
            {
                btnStartPreview1.IsEnabled = enabled;
            }
            else if (name.Equals("StartStopRecord"))
            {
                btnStartStopRecord1.IsEnabled = enabled;
            }
            else if (name.Equals("TakePhoto"))
            {
                btnTakePhoto1.IsEnabled = enabled;
            }
        }

async void MediaCapture::BasicCapture::Failed | ( | Windows.Media.Capture.MediaCapture | currentCaptureObject,
 |  | MediaCaptureFailedEventArgs | currentFailure |
 | ) |  |  | [inline]

Definition at line 156 of file BasicCapture.xaml.cs.

        {
            try
            {
                await Dispatcher.RunAsync(Windows.UI.Core.CoreDispatcherPriority.Normal, () =>
                {
                    ShowStatusMessage("Fatal error" + currentFailure.Message);
                });
            }
            catch (Exception e)
            {
                ShowExceptionMessage(e);
            }
        }

async void MediaCapture::BasicCapture::MediaControl_SoundLevelChanged | ( | object | sender,
 |  | Object | e |
 | ) |  |  | [inline, private]

Definition at line 85 of file BasicCapture.xaml.cs.

        {
            await Dispatcher.RunAsync(Windows.UI.Core.CoreDispatcherPriority.Normal, async () =>
            {
                try
                {
                    if (Windows.Media.MediaControl.SoundLevel != Windows.Media.SoundLevel.Muted)
                    {
                        ScenarioReset();
                    }
                    else
                    {
                        if (m_bRecording)
                        {
                            ShowStatusMessage("Stopping Record on invisibility");

                            await m_mediaCaptureMgr.StopRecordAsync();
                            m_bRecording = false;
                            EnableButton(true, "StartStopRecord");
                        }
                        if (m_bPreviewing)
                        {
                            ShowStatusMessage("Stopping Preview on invisibility");

                            await m_mediaCaptureMgr.StopPreviewAsync();
                            m_bPreviewing = false;
                            EnableButton(true, "StartPreview");
                            previewElement1.Source = null;
                        }
                    }
                }
                catch (Exception ex)
                {
                    ShowExceptionMessage(ex);
                }
            });
        }

override void MediaCapture::BasicCapture::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 59 of file BasicCapture.xaml.cs.

        {
            Windows.Media.MediaControl.SoundLevelChanged -= m_soundLevelHandler;
        }

override void MediaCapture::BasicCapture::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 54 of file BasicCapture.xaml.cs.

        {
            Windows.Media.MediaControl.SoundLevelChanged += m_soundLevelHandler;
        }

async void MediaCapture::BasicCapture::RecordLimitationExceeded ( Windows.Media.Capture.MediaCapture currentCaptureObject ) [inline]

Definition at line 123 of file BasicCapture.xaml.cs.

        {
            try
            {
                if (m_bRecording)
                {
                    await Dispatcher.RunAsync(Windows.UI.Core.CoreDispatcherPriority.Normal, async () =>
                    {
                        try
                        {
                            ShowStatusMessage("Stopping Record on exceeding max record duration");
                            await m_mediaCaptureMgr.StopRecordAsync();
                            m_bRecording = false;
                            SwitchRecordButtonContent();
                            EnableButton(true, "StartStopRecord");
                            ShowStatusMessage("Stopped record on exceeding max record duration:" + m_recordStorageFile.Path);
                        }
                        catch (Exception e)
                        {
                            ShowExceptionMessage(e);
                        }
                    });
                }
            }
            catch (Exception e)
            {
                ShowExceptionMessage(e);
                m_bRecording = false;
                SwitchRecordButtonContent();
                EnableButton(true, "StartStopRecord");
            }
        }

void MediaCapture::BasicCapture::ScenarioInit ( ) [inline, private]

Definition at line 64 of file BasicCapture.xaml.cs.

        {
            btnStartDevice1.IsEnabled = true;
            btnStartPreview1.IsEnabled = false;
            btnStartStopRecord1.IsEnabled = false;
            m_bRecording = false;
            m_bPreviewing = false;
            btnStartStopRecord1.Content = "StartRecord";
            btnTakePhoto1.IsEnabled = false;
            previewElement1.Source = null;
            playbackElement1.Source = null;
            imageElement1.Source = null;
            sldBrightness.IsEnabled = false;
            sldContrast.IsEnabled = false;
            m_bSuspended = false;
            previewCanvas1.Visibility = Windows.UI.Xaml.Visibility.Collapsed;

            ShowStatusMessage("");

        }

void MediaCapture::BasicCapture::ScenarioReset ( ) [inline, private]

Definition at line 171 of file BasicCapture.xaml.cs.

        {
            previewCanvas1.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            ScenarioInit();
        }

void MediaCapture::BasicCapture::SetupVideoDeviceControl | ( | Windows.Media.Devices.MediaDeviceControl | videoDeviceControl,
 |  | Slider | slider |
 | ) |  |  | [inline, private]

Definition at line 339 of file BasicCapture.xaml.cs.

        {
            try
            {
                if ((videoDeviceControl.Capabilities).Supported)
                {
                    slider.IsEnabled = true;
                    slider.Maximum = videoDeviceControl.Capabilities.Max;
                    slider.Minimum = videoDeviceControl.Capabilities.Min;
                    slider.StepFrequency = videoDeviceControl.Capabilities.Step;
                    double controlValue = 0;
                    if (videoDeviceControl.TryGetValue(out controlValue))
                    {
                        slider.Value = controlValue;
                    }
                }
                else
                {
                    slider.IsEnabled = false;
                }
            }
            catch (Exception e)
            {
                ShowExceptionMessage(e);
            }
        }

void MediaCapture::BasicCapture::ShowExceptionMessage ( Exception ex ) [inline, private]

Definition at line 404 of file BasicCapture.xaml.cs.

        {
            rootPage.NotifyUser(ex.Message, NotifyType.ErrorMessage);
        }

void MediaCapture::BasicCapture::ShowStatusMessage ( String text ) [inline, private]

Definition at line 399 of file BasicCapture.xaml.cs.

        {
            rootPage.NotifyUser(text, NotifyType.StatusMessage);
        }

internal void MediaCapture::BasicCapture::sldBrightness_ValueChanged | ( | Object | sender,
 |  | Windows.UI.Xaml.Controls.Primitives.RangeBaseValueChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 367 of file BasicCapture.xaml.cs.

        {
            try
            {
                bool succeeded = m_mediaCaptureMgr.VideoDeviceController.Brightness.TrySetValue(sldBrightness.Value);
                if (!succeeded)
                {
                    ShowStatusMessage("Set Brightness failed");
                }
            }
            catch (Exception exception)
            {
                ShowExceptionMessage(exception);
            }
        }

internal void MediaCapture::BasicCapture::sldContrast_ValueChanged | ( | Object | sender,
 |  | Windows.UI.Xaml.Controls.Primitives.RangeBaseValueChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 383 of file BasicCapture.xaml.cs.

        {
            try
            {
                bool succeeded = m_mediaCaptureMgr.VideoDeviceController.Contrast.TrySetValue(sldContrast.Value);
                if (!succeeded)
                {
                    ShowStatusMessage("Set Contrast failed");
                }
            }
            catch (Exception exception)
            {
                ShowExceptionMessage(exception);
            }
        }

void MediaCapture::BasicCapture::SwitchRecordButtonContent ( ) [inline, private]

Definition at line 409 of file BasicCapture.xaml.cs.

        {
            {
                if (m_bRecording)
                {
                    btnStartStopRecord1.Content = "StopRecord";
                }
                else
                {
                    btnStartStopRecord1.Content = "StartRecord";
                }
            }
        }

Member Data Documentation

bool MediaCapture::BasicCapture::m_bPreviewing [private]

Definition at line 32 of file BasicCapture.xaml.cs.

bool MediaCapture::BasicCapture::m_bRecording [private]

Definition at line 30 of file BasicCapture.xaml.cs.

bool MediaCapture::BasicCapture::m_bSuspended [private]

Definition at line 31 of file BasicCapture.xaml.cs.

Windows.Media.Capture.MediaCapture MediaCapture::BasicCapture::m_mediaCaptureMgr [private]

Definition at line 27 of file BasicCapture.xaml.cs.

Windows.Storage.StorageFile MediaCapture::BasicCapture::m_photoStorageFile [private]

Definition at line 28 of file BasicCapture.xaml.cs.

Windows.Storage.StorageFile MediaCapture::BasicCapture::m_recordStorageFile [private]

Definition at line 29 of file BasicCapture.xaml.cs.

EventHandler<Object> MediaCapture::BasicCapture::m_soundLevelHandler [private]

Definition at line 33 of file BasicCapture.xaml.cs.

readonly String MediaCapture::BasicCapture::PHOTO_FILE_NAME = "photo.jpg" [private]

Definition at line 35 of file BasicCapture.xaml.cs.

MainPage MediaCapture::BasicCapture::rootPage = MainPage.Current [private]

Definition at line 40 of file BasicCapture.xaml.cs.

readonly String MediaCapture::BasicCapture::VIDEO_FILE_NAME = "video.mp4" [private]

Definition at line 36 of file BasicCapture.xaml.cs.

The documentation for this class was generated from the following file:
  • Media capture using capture device/C#,C++/BasicCapture.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaEngineNotify Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

MediaEngineNotify Class Reference

List of all members.

Public Member Functions

MediaEngineNotify (Platform::Agile< Windows::UI::Core::CoreWindow > cWindow)
STDMETHODIMP | EventNotify (DWORD meEvent, DWORD_PTR param1, DWORD param2)
void | MediaEngineNotifyCallback (MediaEngineNotifyCallback^pCB)
STDMETHODIMP | QueryInterface (REFIID riid, void **ppv)
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (ULONG) Release()

Private Attributes

long | m_cRef
Platform::Agile
< Windows::UI::Core::CoreWindow > 		m_cWindow
MediaEngineNotifyCallback | m_pCB

Detailed Description

Definition at line 26 of file meplayer.cpp.

Constructor & Destructor Documentation

MediaEngineNotify::MediaEngineNotify ( Platform::Agile< Windows::UI::Core::CoreWindow > cWindow ) [inline]

Definition at line 33 of file meplayer.cpp.

                                                                      : m_cWindow(cWindow), m_cRef(1), m_pCB(nullptr)
    {
    }

Member Function Documentation

STDMETHODIMP MediaEngineNotify::EventNotify | ( | DWORD | meEvent,
 |  | DWORD_PTR | param1,
 |  | DWORD | param2 |
 | ) |  |  | [inline]

Definition at line 70 of file meplayer.cpp.

    {
        if (meEvent == MF_MEDIA_ENGINE_EVENT_NOTIFYSTABLESTATE)
        {
            SetEvent(reinterpret_cast<HANDLE>(param1));
        }
        else
        {
            m_pCB->OnMediaEngineEvent(meEvent);
        }

        return S_OK;
    }

void MediaEngineNotify::MediaEngineNotifyCallback ( MediaEngineNotifyCallback^ pCB ) [inline]

Definition at line 84 of file meplayer.cpp.

    {
        m_pCB = pCB;
    }

STDMETHODIMP MediaEngineNotify::QueryInterface | ( | REFIID | riid,
 |  | void ** | ppv |
 | ) |  |  | [inline]

Definition at line 37 of file meplayer.cpp.

    {
        if(__uuidof(IMFMediaEngineNotify) == riid)
        {
            *ppv = static_cast<IMFMediaEngineNotify*>(this);
        }
        else
        {
            *ppv = nullptr;
            return E_NOINTERFACE;
        }

        AddRef();

        return S_OK;
    }

MediaEngineNotify::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 59 of file meplayer.cpp.

    {
        LONG cRef = InterlockedDecrement(&m_cRef);
        if (cRef == 0)
        {
            delete this;
        }
        return cRef;
    }

MediaEngineNotify::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 54 of file meplayer.cpp.

    {
        return InterlockedIncrement(&m_cRef);
    }

Member Data Documentation

long MediaEngineNotify::m_cRef [private]

Definition at line 28 of file meplayer.cpp.

Platform::Agile<Windows::UI::Core::CoreWindow> MediaEngineNotify::m_cWindow [private]

Definition at line 29 of file meplayer.cpp.

MediaEngineNotifyCallback MediaEngineNotify::m_pCB [private]

Definition at line 30 of file meplayer.cpp.

The documentation for this class was generated from the following file:
  • Media engine native C++ video playback/C++/meplayer.cpp
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCPP::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCPP
  • MediaExtensionsCPP::App
Public Member Functions | Public Attributes

MediaExtensionsCPP::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()

Detailed Description

Definition at line 20 of file App.xaml.h.

Member Function Documentation

void App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]

Definition at line 41 of file App.xaml.cpp.

{

    if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
    {
        SuspensionManager::StartRestoreTask().then([=]()
        {
            auto rootFrame = ref new Frame();
            TypeName pageType = { "MediaExtensionsCPP.MainPage", TypeKind::Custom };
            rootFrame->Navigate(pageType);
            Window::Current->Content = rootFrame;
            Window::Current->Activate();
        });
    }
    else
    {
        auto rootFrame = ref new Frame();
        TypeName pageType = { "MediaExtensionsCPP.MainPage", TypeKind::Custom };
        rootFrame->Navigate(pageType);
        Window::Current->Content = rootFrame;
        Window::Current->Activate();
    }
}

void App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]

Definition at line 31 of file App.xaml.cpp.

{
    auto deferral = pArgs->SuspendingOperation->GetDeferral();
    SuspensionManager::StartSaveTask().then([=]()
    {
        deferral->Complete();
    });

}

Member Data Documentation

internal MediaExtensionsCPP::App::__pad0__

Definition at line 23 of file App.xaml.h.

The documentation for this class was generated from the following files:
  • Media extensions/C++/App.xaml.h
  • Media extensions/C++/App.xaml.cpp
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCPP
  • MediaExtensionsCPP::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

MediaExtensionsCPP::sealed Class Reference

#include "MainPage.xaml.h"

List of all members.

Public Member Functions

String | ConvertResolution (ResolutionScale scale)
String | ConvertViewState (ApplicationViewState state)
void | DoNavigation (TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame)
MainPage ()
void | NotifyUser (String^strMessage, NotifyType type)
void | PickSingleFileAndSet (Windows::Foundation::Collections::IVector< String^>^fileTypeFilters, Windows::Foundation::Collections::IVector< MediaElement^>^mediaElements)
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioInput3 ()
ScenarioInput4 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()
ScenarioOutput3 ()
ScenarioOutput4 ()
void | VideoOnError (Object^obj, ExceptionRoutedEventArgs^args)

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~MainPage ()
~ScenarioInput1 ()
~ScenarioInput2 ()
~ScenarioInput3 ()
~ScenarioInput4 ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
~ScenarioOutput3 ()
~ScenarioOutput4 ()
void | CheckResolutionAndViewState ()
void | Circle_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, RoutedEventArgs^e)
void | inputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | Open_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Open_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OpenFisheye_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OpenGrayscale_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OpenInvert_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OpenPinch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OpenVideoWithPolarEffect (String^effectName)
void | OpenWarp_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | outputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | Page_Loaded (Object^sender, RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | SetFeatureName (Platform::String^strFeature)
void | Square_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Stop_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Stop_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Stop_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Triangle_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::Media::MediaExtensionManager | _extensionManager
Windows::Foundation::EventRegistrationToken | _frameLoadedToken
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _layoutHandlerToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::Foundation::EventRegistrationToken | _mediaFailedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
Windows::Foundation::EventRegistrationToken | _stabilizedMediaFailedToken
MediaElement | outputVideo
Windows::UI::Xaml::Controls::MediaElement | outputVideo
Windows::UI::Xaml::Controls::MediaElement | outputVideoStabilized
MainPage | rootPage

Detailed Description

Definition at line 37 of file MainPage.xaml.h.

Constructor & Destructor Documentation

MediaExtensionsCPP::sealed::~MainPage ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioInput1 ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioInput2 ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioInput3 ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioInput4 ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioList ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioOutput1 ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioOutput2 ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioOutput3 ( ) [private]
MediaExtensionsCPP::sealed::~ScenarioOutput4 ( ) [private]

Member Function Documentation

void MediaExtensionsCPP::sealed::CheckResolutionAndViewState ( ) [private]
void MediaExtensionsCPP::sealed::Circle_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
String MediaExtensionsCPP::sealed::ConvertResolution ( ResolutionScale scale )
String MediaExtensionsCPP::sealed::ConvertViewState ( ApplicationViewState state )
void MediaExtensionsCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void MediaExtensionsCPP::sealed::DoNavigation | ( | TypeName | pageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | frame
 | ) |  |
void MediaExtensionsCPP::sealed::Footer_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
MediaExtensionsCPP::sealed::MainPage ( )
void MediaExtensionsCPP::sealed::NotifyUser | ( | String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void MediaExtensionsCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void MediaExtensionsCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void MediaExtensionsCPP::sealed::Open_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::Open_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::OpenFisheye_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::OpenGrayscale_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::OpenInvert_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::OpenPinch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::OpenVideoWithPolarEffect ( String^ effectName ) [private]
void MediaExtensionsCPP::sealed::OpenWarp_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::PickSingleFileAndSet | ( | Windows::Foundation::Collections::IVector< String^>^ | fileTypeFilters,
 |  | Windows::Foundation::Collections::IVector< MediaElement^>^ | mediaElements
 | ) |  |
void MediaExtensionsCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
MediaExtensionsCPP::sealed::ScenarioInput1 ( )
MediaExtensionsCPP::sealed::ScenarioInput2 ( )
MediaExtensionsCPP::sealed::ScenarioInput3 ( )
MediaExtensionsCPP::sealed::ScenarioInput4 ( )
MediaExtensionsCPP::sealed::ScenarioList ( )
MediaExtensionsCPP::sealed::ScenarioOutput1 ( )
MediaExtensionsCPP::sealed::ScenarioOutput2 ( )
MediaExtensionsCPP::sealed::ScenarioOutput3 ( )
MediaExtensionsCPP::sealed::ScenarioOutput4 ( )
void MediaExtensionsCPP::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void MediaExtensionsCPP::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
void MediaExtensionsCPP::sealed::Square_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::Stop_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::Stop_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::Stop_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::Triangle_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void MediaExtensionsCPP::sealed::VideoOnError | ( | Object^ | obj,
 |  | ExceptionRoutedEventArgs^ | args
 | ) |  |

Member Data Documentation

Windows::Foundation::EventRegistrationToken MediaExtensionsCPP::sealed::_displayHandlerToken [private]

Definition at line 76 of file MainPage.xaml.h.

Windows::Media::MediaExtensionManager MediaExtensionsCPP::sealed::_extensionManager [private]

Definition at line 90 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::_frameLoadedToken [private]

Definition at line 40 of file ScenarioInput1.xaml.h.

Windows::UI::Xaml::Controls::Frame MediaExtensionsCPP::sealed::_inputFrame [private]

Definition at line 73 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken MediaExtensionsCPP::sealed::_inputFrameLoadedToken [private]

Definition at line 80 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken MediaExtensionsCPP::sealed::_layoutHandlerToken [private]

Definition at line 77 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken MediaExtensionsCPP::sealed::_logicalDpiChangedToken [private]

Definition at line 79 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::_mediaFailedToken [private]

Definition at line 34 of file ScenarioOutput1.xaml.h.

Windows::UI::Xaml::Controls::Frame MediaExtensionsCPP::sealed::_outputFrame [private]

Definition at line 74 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken MediaExtensionsCPP::sealed::_outputFrameLoadedToken [private]

Definition at line 81 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken MediaExtensionsCPP::sealed::_pageLoadedHandlerToken [private]

Definition at line 78 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame MediaExtensionsCPP::sealed::_scenariosFrame [private]

Definition at line 72 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken MediaExtensionsCPP::sealed::_stabilizedMediaFailedToken [private]

Definition at line 38 of file ScenarioOutput3.xaml.h.

MediaElement sealed::outputVideo [private]

Definition at line 35 of file ScenarioInput1.xaml.h.

Windows::UI::Xaml::Controls::MediaElement MediaExtensionsCPP::sealed::outputVideo [private]

Definition at line 34 of file ScenarioInput2.xaml.h.

Windows::UI::Xaml::Controls::MediaElement MediaExtensionsCPP::sealed::outputVideoStabilized [private]

Definition at line 35 of file ScenarioInput3.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 34 of file ScenarioInput1.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> MediaExtensionsCPP::sealed::OutputFrameLoaded

Definition at line 59 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Media extensions/C++/MainPage.xaml.h
  • Media extensions/C++/ScenarioInput1.xaml.h
  • Media extensions/C++/ScenarioInput2.xaml.h
  • Media extensions/C++/ScenarioInput3.xaml.h
  • Media extensions/C++/ScenarioInput4.xaml.h
  • Media extensions/C++/ScenarioList.xaml.h
  • Media extensions/C++/ScenarioOutput1.xaml.h
  • Media extensions/C++/ScenarioOutput2.xaml.h
  • Media extensions/C++/ScenarioOutput3.xaml.h
  • Media extensions/C++/ScenarioOutput4.xaml.h
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::App
Public Member Functions | Protected Member Functions

MediaExtensionsCS::App Class Reference

List of all members.

Public Member Functions

App ()

Protected Member Functions

async override void | OnLaunched (LaunchActivatedEventArgs args)
async void | OnSuspending (object sender, SuspendingEventArgs args)

Detailed Description

Definition at line 18 of file App.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::App::App ( ) [inline]

Definition at line 20 of file App.xaml.cs.

        {
            InitializeComponent();
            this.Suspending += new SuspendingEventHandler(OnSuspending);
        }

Member Function Documentation

async override void MediaExtensionsCS::App::OnLaunched ( LaunchActivatedEventArgs args ) [inline, protected]

Definition at line 33 of file App.xaml.cs.

        {
            if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
            {
                //     Do an asynchronous restore
                await SuspensionManager.RestoreAsync();

            }
            var rootFrame = new Frame();
            rootFrame.Navigate(typeof(MainPage));
            Window.Current.Content = rootFrame;
            MainPage p = rootFrame.Content as MainPage;
            p.RootNamespace = this.GetType().Namespace;
            Window.Current.Activate();
        }

async void MediaExtensionsCS::App::OnSuspending | ( | object | sender,
 |  | SuspendingEventArgs | args |
 | ) |  |  | [inline, protected]

Definition at line 26 of file App.xaml.cs.

        {
            SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
            await SuspensionManager.SaveAsync();
            deferral.Complete();
        }

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/App.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioInput1 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioInput1
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

MediaExtensionsCS::ScenarioInput1 Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioInput1 ()

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

void | Open_Click (object sender, RoutedEventArgs e)
void | rootPage_OutputFrameLoaded (object sender, object e)
void | Stop_Click (object sender, RoutedEventArgs e)

Private Attributes

readonly Guid | MFVideoFormat_MPG1 = Guid.Parse("3147504d-0000-0010-8000-00aa00389b71")
MediaElement | outputVideo
MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioInput1.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioInput1::ScenarioInput1 ( ) [inline]

Definition at line 34 of file ScenarioInput1.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

override void MediaExtensionsCS::ScenarioInput1::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 52 of file ScenarioInput1.xaml.cs.

        {
            rootPage.OutputFrameLoaded -= new System.EventHandler(rootPage_OutputFrameLoaded);
        }

override void MediaExtensionsCS::ScenarioInput1::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 40 of file ScenarioInput1.xaml.cs.

        {
            // Get a pointer to our main page
            rootPage = e.Parameter as MainPage;

            // We want to be notified with the OutputFrame is loaded so we can get to the content.
            rootPage.OutputFrameLoaded += new System.EventHandler(rootPage_OutputFrameLoaded);

            rootPage.ExtensionManager.RegisterByteStreamHandler("MPEG1Source.MPEG1ByteStreamHandler", ".mpg", "video/mpeg");
            rootPage.ExtensionManager.RegisterVideoDecoder("MPEG1Decoder.MPEG1Decoder", MFVideoFormat_MPG1, Guid.Empty);
        }

void MediaExtensionsCS::ScenarioInput1::Open_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Open' button.

Parameters:
sender
e

Definition at line 77 of file ScenarioInput1.xaml.cs.

        {
            rootPage.PickSingleFileAndSet(new string[] { ".mpg" }, outputVideo);
        }

void MediaExtensionsCS::ScenarioInput1::rootPage_OutputFrameLoaded | ( | object | sender,
 |  | object | e |
 | ) |  |  | [inline, private]

Definition at line 60 of file ScenarioInput1.xaml.cs.

        {
            // At this point, we know that the Output Frame has been loaded and we can go ahead
            // and reference elements in the page contained in the Output Frame.

            // Get a pointer to the content within the OutputFrame.
            Page outputFrame = (Page)rootPage.OutputFrame.Content;

            // Go find the elements that we need for this scenario.
            outputVideo = outputFrame.FindName("Video") as MediaElement;
        }

void MediaExtensionsCS::ScenarioInput1::Stop_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Stop' button.

Parameters:
sender
e

Definition at line 88 of file ScenarioInput1.xaml.cs.

        {
            outputVideo.Source = null;
        }

Member Data Documentation

readonly Guid MediaExtensionsCS::ScenarioInput1::MFVideoFormat_MPG1 = Guid.Parse("3147504d-0000-0010-8000-00aa00389b71") [private]

Definition at line 28 of file ScenarioInput1.xaml.cs.

MediaElement MediaExtensionsCS::ScenarioInput1::outputVideo [private]

Definition at line 32 of file ScenarioInput1.xaml.cs.

MainPage MediaExtensionsCS::ScenarioInput1::rootPage = null [private]

Definition at line 31 of file ScenarioInput1.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioInput1.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioInput2 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioInput2
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

MediaExtensionsCS::ScenarioInput2 Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioInput2 ()

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

void | Circle_Click (object sender, RoutedEventArgs e)
void | rootPage_OutputFrameLoaded (object sender, object e)
void | Square_Click (object sender, RoutedEventArgs e)
void | Triangle_Click (object sender, RoutedEventArgs e)

Private Attributes

MediaElement | outputVideo
MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioInput2.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioInput2::ScenarioInput2 ( ) [inline]

Definition at line 32 of file ScenarioInput2.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

void MediaExtensionsCS::ScenarioInput2::Circle_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Circle' button.

Parameters:
sender
e

Definition at line 74 of file ScenarioInput2.xaml.cs.

        {
            outputVideo.Source = new Uri("myscheme://circle");
        }

override void MediaExtensionsCS::ScenarioInput2::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 49 of file ScenarioInput2.xaml.cs.

        {
            rootPage.OutputFrameLoaded -= new System.EventHandler(rootPage_OutputFrameLoaded);
        }

override void MediaExtensionsCS::ScenarioInput2::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 38 of file ScenarioInput2.xaml.cs.

        {
            // Get a pointer to our main page
            rootPage = e.Parameter as MainPage;

            // We want to be notified with the OutputFrame is loaded so we can get to the content.
            rootPage.OutputFrameLoaded += new System.EventHandler(rootPage_OutputFrameLoaded);

            rootPage.ExtensionManager.RegisterSchemeHandler("GeometricSource.GeometricSchemeHandler", "myscheme:");
        }

void MediaExtensionsCS::ScenarioInput2::rootPage_OutputFrameLoaded | ( | object | sender,
 |  | object | e |
 | ) |  |  | [inline, private]

Definition at line 57 of file ScenarioInput2.xaml.cs.

        {
            // At this point, we know that the Output Frame has been loaded and we can go ahead
            // and reference elements in the page contained in the Output Frame.

            // Get a pointer to the content within the OutputFrame.
            Page outputFrame = (Page)rootPage.OutputFrame.Content;

            // Go find the elements that we need for this scenario.
            outputVideo = outputFrame.FindName("Video") as MediaElement;
        }

void MediaExtensionsCS::ScenarioInput2::Square_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Square' button.

Parameters:
sender
e

Definition at line 85 of file ScenarioInput2.xaml.cs.

        {
            outputVideo.Source = new Uri("myscheme://square");
        }

void MediaExtensionsCS::ScenarioInput2::Triangle_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Triangle' button.

Parameters:
sender
e

Definition at line 95 of file ScenarioInput2.xaml.cs.

        {
            outputVideo.Source = new Uri("myscheme://triangle");
        }

Member Data Documentation

MediaElement MediaExtensionsCS::ScenarioInput2::outputVideo [private]

Definition at line 30 of file ScenarioInput2.xaml.cs.

MainPage MediaExtensionsCS::ScenarioInput2::rootPage = null [private]

Definition at line 29 of file ScenarioInput2.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioInput2.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioInput3 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioInput3
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

MediaExtensionsCS::ScenarioInput3 Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioInput3 ()

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

void | Open_Click (object sender, RoutedEventArgs e)
void | rootPage_OutputFrameLoaded (object sender, object e)
void | Stop_Click (object sender, RoutedEventArgs e)

Private Attributes

MediaElement | outputVideo
MediaElement | outputVideoStabilized
MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioInput3.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioInput3::ScenarioInput3 ( ) [inline]

Definition at line 33 of file ScenarioInput3.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

override void MediaExtensionsCS::ScenarioInput3::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 48 of file ScenarioInput3.xaml.cs.

        {
            rootPage.OutputFrameLoaded -= new System.EventHandler(rootPage_OutputFrameLoaded);
        }

override void MediaExtensionsCS::ScenarioInput3::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 39 of file ScenarioInput3.xaml.cs.

        {
            // Get a pointer to our main page
            rootPage = e.Parameter as MainPage;

            // We want to be notified with the OutputFrame is loaded so we can get to the content.
            rootPage.OutputFrameLoaded += new System.EventHandler(rootPage_OutputFrameLoaded);
        }

void MediaExtensionsCS::ScenarioInput3::Open_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Open' button.

Parameters:
sender
e

Definition at line 74 of file ScenarioInput3.xaml.cs.

        {
            outputVideoStabilized.RemoveAllEffects();
            outputVideoStabilized.AddVideoEffect(Windows.Media.VideoEffects.VideoStabilization, true, null);
            rootPage.PickSingleFileAndSet(new string[] { ".mp4", ".wmv", ".avi" }, outputVideo, outputVideoStabilized);
        }

void MediaExtensionsCS::ScenarioInput3::rootPage_OutputFrameLoaded | ( | object | sender,
 |  | object | e |
 | ) |  |  | [inline, private]

Definition at line 56 of file ScenarioInput3.xaml.cs.

        {
            // At this point, we know that the Output Frame has been loaded and we can go ahead
            // and reference elements in the page contained in the Output Frame.

            // Get a pointer to the content within the OutputFrame.
            Page outputFrame = (Page)rootPage.OutputFrame.Content;

            // Go find the elements that we need for this scenario.
            outputVideo = outputFrame.FindName("Video") as MediaElement;
            outputVideoStabilized = outputFrame.FindName("VideoStabilized") as MediaElement;
        }

void MediaExtensionsCS::ScenarioInput3::Stop_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Stop' button.

Parameters:
sender
e

Definition at line 87 of file ScenarioInput3.xaml.cs.

        {
            outputVideo.Source = null;
            outputVideoStabilized.Source = null;
        }

Member Data Documentation

MediaElement MediaExtensionsCS::ScenarioInput3::outputVideo [private]

Definition at line 30 of file ScenarioInput3.xaml.cs.

MediaElement MediaExtensionsCS::ScenarioInput3::outputVideoStabilized [private]

Definition at line 31 of file ScenarioInput3.xaml.cs.

MainPage MediaExtensionsCS::ScenarioInput3::rootPage = null [private]

Definition at line 29 of file ScenarioInput3.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioInput3.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioInput4 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioInput4
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

MediaExtensionsCS::ScenarioInput4 Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioInput4 ()

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

void | OpenFisheye_Click (object sender, RoutedEventArgs e)
void | OpenGrayscale_Click (object sender, RoutedEventArgs e)
void | OpenInvert_Click (object sender, RoutedEventArgs e)
void | OpenPinch_Click (object sender, RoutedEventArgs e)
void | OpenVideoWithPolarEffect (string effectName)
void | OpenWarp_Click (object sender, RoutedEventArgs e)
void | rootPage_OutputFrameLoaded (object sender, object e)
void | Stop_Click (object sender, RoutedEventArgs e)

Private Attributes

MediaElement | outputVideo
MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioInput4.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioInput4::ScenarioInput4 ( ) [inline]

Definition at line 32 of file ScenarioInput4.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

override void MediaExtensionsCS::ScenarioInput4::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 47 of file ScenarioInput4.xaml.cs.

        {
            rootPage.OutputFrameLoaded -= new System.EventHandler(rootPage_OutputFrameLoaded);
        }

override void MediaExtensionsCS::ScenarioInput4::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 38 of file ScenarioInput4.xaml.cs.

        {
            // Get a pointer to our main page
            rootPage = e.Parameter as MainPage;

            // We want to be notified with the OutputFrame is loaded so we can get to the content.
            rootPage.OutputFrameLoaded += new System.EventHandler(rootPage_OutputFrameLoaded);
        }

void MediaExtensionsCS::ScenarioInput4::OpenFisheye_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'OpenFisheye' button.

Parameters:
sender
e

Definition at line 85 of file ScenarioInput4.xaml.cs.

        {
            OpenVideoWithPolarEffect("Fisheye");
        }

void MediaExtensionsCS::ScenarioInput4::OpenGrayscale_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'OpenGrayscale' button.

Parameters:
sender
e

Definition at line 72 of file ScenarioInput4.xaml.cs.

        {
            outputVideo.RemoveAllEffects();
            outputVideo.AddVideoEffect("GrayscaleTransform.GrayscaleEffect", true, null);

            rootPage.PickSingleFileAndSet(new string[] { ".mp4", ".wmv", ".avi" }, outputVideo);
        }

void MediaExtensionsCS::ScenarioInput4::OpenInvert_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'OpenInvert' button.

Parameters:
sender
e

Definition at line 115 of file ScenarioInput4.xaml.cs.

        {
            outputVideo.RemoveAllEffects();
            outputVideo.AddVideoEffect("InvertTransform.InvertEffect", true, null);

            rootPage.PickSingleFileAndSet(new string[] { ".mp4", ".wmv", ".avi" }, outputVideo);
        }

void MediaExtensionsCS::ScenarioInput4::OpenPinch_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'OpenPinch' button.

Parameters:
sender
e

Definition at line 95 of file ScenarioInput4.xaml.cs.

        {
            OpenVideoWithPolarEffect("Pinch");
        }

void MediaExtensionsCS::ScenarioInput4::OpenVideoWithPolarEffect ( string effectName ) [inline, private]

Definition at line 134 of file ScenarioInput4.xaml.cs.

        {
            outputVideo.RemoveAllEffects();
            PropertySet configuration = new PropertySet();
            configuration.Add("effect", effectName);
            outputVideo.AddVideoEffect("PolarTransform.PolarEffect", true, configuration);

            rootPage.PickSingleFileAndSet(new string[] { ".mp4", ".wmv", ".avi" }, outputVideo);
        }

void MediaExtensionsCS::ScenarioInput4::OpenWarp_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'OpenWarp' button.

Parameters:
sender
e

Definition at line 105 of file ScenarioInput4.xaml.cs.

        {
            OpenVideoWithPolarEffect("Warp");
        }

void MediaExtensionsCS::ScenarioInput4::rootPage_OutputFrameLoaded | ( | object | sender,
 |  | object | e |
 | ) |  |  | [inline, private]

Definition at line 55 of file ScenarioInput4.xaml.cs.

        {
            // At this point, we know that the Output Frame has been loaded and we can go ahead
            // and reference elements in the page contained in the Output Frame.

            // Get a pointer to the content within the OutputFrame.
            Page outputFrame = (Page)rootPage.OutputFrame.Content;

            // Go find the elements that we need for this scenario.
            outputVideo = outputFrame.FindName("Video") as MediaElement;
        }

void MediaExtensionsCS::ScenarioInput4::Stop_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Stop' button.

Parameters:
sender
e

Definition at line 128 of file ScenarioInput4.xaml.cs.

        {
            outputVideo.Source = null;
        }

Member Data Documentation

MediaElement MediaExtensionsCS::ScenarioInput4::outputVideo [private]

Definition at line 30 of file ScenarioInput4.xaml.cs.

MainPage MediaExtensionsCS::ScenarioInput4::rootPage = null [private]

Definition at line 29 of file ScenarioInput4.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioInput4.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioList Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioList
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

MediaExtensionsCS::ScenarioList Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioList ()

Protected Member Functions

override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

void | Scenarios_SelectionChanged (object sender, SelectionChangedEventArgs e)

Private Attributes

MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioList.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioList::ScenarioList ( ) [inline]

Definition at line 31 of file ScenarioList.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

override void MediaExtensionsCS::ScenarioList::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 56 of file ScenarioList.xaml.cs.

        {
            rootPage = e.Parameter as MainPage;
            Scenarios.SelectionChanged += new SelectionChangedEventHandler(Scenarios_SelectionChanged);

            // Starting scenario is the first or based upon a previous selection.
            ListBoxItem startingScenario = null;
            if (SuspensionManager.SessionState.ContainsKey("SelectedScenario"))
            {
                String selectedScenarioName = SuspensionManager.SessionState["SelectedScenario"] as string;
                startingScenario = this.FindName(selectedScenarioName) as ListBoxItem;
            }

            Scenarios.SelectedItem = startingScenario != null ? startingScenario : Scenario1;
        }

void MediaExtensionsCS::ScenarioList::Scenarios_SelectionChanged | ( | object | sender,
 |  | SelectionChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 37 of file ScenarioList.xaml.cs.

        {
            if (Scenarios.SelectedItem != null)
            {
                rootPage.NotifyUser("", NotifyType.StatusMessage);

                ListBoxItem selectedListBoxItem = Scenarios.SelectedItem as ListBoxItem;
                SuspensionManager.SessionState["SelectedScenario"] = selectedListBoxItem.Name;

                if (rootPage.InputFrame != null && rootPage.OutputFrame != null)
                {
                    // Load the input and output pages for the current scenario into their respective frames.

                    rootPage.DoNavigation(Type.GetType(typeof(ScenarioList).Namespace + "." + "ScenarioInput" + ((Scenarios.SelectedIndex + 1).ToString())), rootPage.InputFrame);
                    rootPage.DoNavigation(Type.GetType(typeof(ScenarioList).Namespace + "." + "ScenarioOutput" + ((Scenarios.SelectedIndex + 1).ToString())), rootPage.OutputFrame);
                }
            }
        }

Member Data Documentation

MainPage MediaExtensionsCS::ScenarioList::rootPage = null [private]

Definition at line 29 of file ScenarioList.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioList.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioOutput1 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioOutput1
Public Member Functions | Protected Member Functions | Private Attributes

MediaExtensionsCS::ScenarioOutput1 Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioOutput1 ()

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Attributes

MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioOutput1.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioOutput1::ScenarioOutput1 ( ) [inline]

Definition at line 31 of file ScenarioOutput1.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

override void MediaExtensionsCS::ScenarioOutput1::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 45 of file ScenarioOutput1.xaml.cs.

        {
            Video.MediaFailed -= new ExceptionRoutedEventHandler(rootPage.VideoOnError);
            Video.Source = null;
        }

override void MediaExtensionsCS::ScenarioOutput1::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 37 of file ScenarioOutput1.xaml.cs.

        {
            // Get a pointer to our main page.
            rootPage = e.Parameter as MainPage;

            Video.MediaFailed += new ExceptionRoutedEventHandler(rootPage.VideoOnError);
        }

Member Data Documentation

MainPage MediaExtensionsCS::ScenarioOutput1::rootPage = null [private]

Definition at line 29 of file ScenarioOutput1.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioOutput1.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioOutput2 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioOutput2
Public Member Functions | Protected Member Functions | Private Attributes

MediaExtensionsCS::ScenarioOutput2 Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioOutput2 ()

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Attributes

MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioOutput2.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioOutput2::ScenarioOutput2 ( ) [inline]

Definition at line 31 of file ScenarioOutput2.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

override void MediaExtensionsCS::ScenarioOutput2::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 45 of file ScenarioOutput2.xaml.cs.

        {
            Video.MediaFailed -= new ExceptionRoutedEventHandler(rootPage.VideoOnError);
            Video.Source = null;
        }

override void MediaExtensionsCS::ScenarioOutput2::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 37 of file ScenarioOutput2.xaml.cs.

        {
            // Get a pointer to our main page.
            rootPage = e.Parameter as MainPage;

            Video.MediaFailed += new ExceptionRoutedEventHandler(rootPage.VideoOnError);
        }

Member Data Documentation

MainPage MediaExtensionsCS::ScenarioOutput2::rootPage = null [private]

Definition at line 29 of file ScenarioOutput2.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioOutput2.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioOutput3 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioOutput3
Public Member Functions | Protected Member Functions | Private Attributes

MediaExtensionsCS::ScenarioOutput3 Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioOutput3 ()

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Attributes

MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioOutput3.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioOutput3::ScenarioOutput3 ( ) [inline]

Definition at line 31 of file ScenarioOutput3.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

override void MediaExtensionsCS::ScenarioOutput3::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 46 of file ScenarioOutput3.xaml.cs.

        {
            Video.MediaFailed -= new ExceptionRoutedEventHandler(rootPage.VideoOnError);
            VideoStabilized.MediaFailed -= new ExceptionRoutedEventHandler(rootPage.VideoOnError);
            Video.Source = null;
            VideoStabilized.Source = null;
        }

override void MediaExtensionsCS::ScenarioOutput3::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 37 of file ScenarioOutput3.xaml.cs.

        {
            // Get a pointer to our main page.
            rootPage = e.Parameter as MainPage;

            Video.MediaFailed += new ExceptionRoutedEventHandler(rootPage.VideoOnError);
            VideoStabilized.MediaFailed += new ExceptionRoutedEventHandler(rootPage.VideoOnError);
        }

Member Data Documentation

MainPage MediaExtensionsCS::ScenarioOutput3::rootPage = null [private]

Definition at line 29 of file ScenarioOutput3.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioOutput3.xaml.cs
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS::ScenarioOutput4 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaExtensionsCS
  • MediaExtensionsCS::ScenarioOutput4
Public Member Functions | Protected Member Functions | Private Attributes

MediaExtensionsCS::ScenarioOutput4 Class Reference

Inherits Page.

List of all members.

Public Member Functions

ScenarioOutput4 ()

Protected Member Functions

override void | OnNavigatedFrom (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Private Attributes

MainPage | rootPage = null

Detailed Description

Definition at line 26 of file ScenarioOutput4.xaml.cs.

Constructor & Destructor Documentation

MediaExtensionsCS::ScenarioOutput4::ScenarioOutput4 ( ) [inline]

Definition at line 31 of file ScenarioOutput4.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

override void MediaExtensionsCS::ScenarioOutput4::OnNavigatedFrom ( NavigationEventArgs e ) [inline, protected]

Definition at line 45 of file ScenarioOutput4.xaml.cs.

        {
            Video.MediaFailed -= new ExceptionRoutedEventHandler(rootPage.VideoOnError);
            Video.Source = null;
        }

override void MediaExtensionsCS::ScenarioOutput4::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Definition at line 37 of file ScenarioOutput4.xaml.cs.

        {
            // Get a pointer to our main page.
            rootPage = e.Parameter as MainPage;

            Video.MediaFailed += new ExceptionRoutedEventHandler(rootPage.VideoOnError);
        }

Member Data Documentation

MainPage MediaExtensionsCS::ScenarioOutput4::rootPage = null [private]

Definition at line 29 of file ScenarioOutput4.xaml.cs.

The documentation for this class was generated from the following file:
  • Media extensions/C#,C++/ScenarioOutput4.xaml.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaReader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

MediaReader Class Reference

#include "MediaReader.h"

List of all members.

Public Member Functions

WAVEFORMATEX * | GetOutputWaveFormatEx ()
WAVEFORMATEX * | GetOutputWaveFormatEx ()
Platform::Array< byte > | LoadMedia (_In_ Platform::String^filename)
Platform::Array< byte > | LoadMedia (_In_ Platform::String^filename)

Public Attributes

internal | __pad0__: MediaReader()

Private Attributes

Windows::Storage::StorageFolder | m_installedLocation
Platform::String | m_installedLocationPath
WAVEFORMATEX | m_waveFormat

Detailed Description

Definition at line 15 of file MediaReader.h.

Member Function Documentation

WAVEFORMATEX * MediaReader::GetOutputWaveFormatEx ( )

Definition at line 25 of file MediaReader.cpp.

{
    return &m_waveFormat;
}

WAVEFORMATEX* MediaReader::GetOutputWaveFormatEx ( )
Platform::Array<byte> MediaReader::LoadMedia ( _In_ Platform::String^ filename )
Platform::Array< byte > MediaReader::LoadMedia ( _In_ Platform::String^ filename )

Definition at line 30 of file MediaReader.cpp.

{
    DX::ThrowIfFailed(
        MFStartup(MF_VERSION)
        );

    ComPtr<IMFSourceReader> reader;
    DX::ThrowIfFailed(
        MFCreateSourceReaderFromURL(
            Platform::String::Concat(m_installedLocationPath, filename)->Data(),
            nullptr,
            &reader
            )
        );

    // Set the decoded output format as PCM.
    // XAudio2 on Windows can process PCM and ADPCM-encoded buffers.
    // When using MediaFoundation, this sample always decodes into PCM.
    Microsoft::WRL::ComPtr<IMFMediaType> mediaType;
    DX::ThrowIfFailed(
        MFCreateMediaType(&mediaType)
        );

    DX::ThrowIfFailed(
        mediaType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Audio)
        );

    DX::ThrowIfFailed(
        mediaType->SetGUID(MF_MT_SUBTYPE, MFAudioFormat_PCM)
        );

    DX::ThrowIfFailed(
        reader->SetCurrentMediaType(static_cast<uint32>(MF_SOURCE_READER_FIRST_AUDIO_STREAM), 0, mediaType.Get())
        );

    // Get the complete WAVEFORMAT from the Media Type.
    Microsoft::WRL::ComPtr<IMFMediaType> outputMediaType;
    DX::ThrowIfFailed(
        reader->GetCurrentMediaType(static_cast<uint32>(MF_SOURCE_READER_FIRST_AUDIO_STREAM), &outputMediaType)
        );

    UINT32 size = 0;
    WAVEFORMATEX* waveFormat;
    DX::ThrowIfFailed(
        MFCreateWaveFormatExFromMFMediaType(outputMediaType.Get(), &waveFormat, &size)
        );

    CopyMemory(&m_waveFormat, waveFormat, sizeof(m_waveFormat));
    CoTaskMemFree(waveFormat);

    PROPVARIANT propVariant;
    DX::ThrowIfFailed(
        reader->GetPresentationAttribute(static_cast<uint32>(MF_SOURCE_READER_MEDIASOURCE), MF_PD_DURATION, &propVariant)
        );
    // 'duration' is in 100ns units; convert to seconds, and round up
    // to the nearest whole byte.
    LONGLONG duration = propVariant.uhVal.QuadPart;
    unsigned int maxStreamLengthInBytes =
        static_cast<unsigned int>(
            ((duration * static_cast<ULONGLONG>(m_waveFormat.nAvgBytesPerSec)) + 10000000) /
            10000000
            );

    Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(maxStreamLengthInBytes);

    ComPtr<IMFSample> sample;
    ComPtr<IMFMediaBuffer> mediaBuffer;
    DWORD flags = 0;

    int positionInData = 0;
    bool done = false;
    while (!done)
    {
        DX::ThrowIfFailed(
            reader->ReadSample(static_cast<uint32>(MF_SOURCE_READER_FIRST_AUDIO_STREAM), 0, nullptr, &flags, nullptr, &sample)
            );

        if (sample != nullptr)
        {
            DX::ThrowIfFailed(
                sample->ConvertToContiguousBuffer(&mediaBuffer)
                );

            BYTE *audioData = nullptr;
            DWORD sampleBufferLength = 0;
            DX::ThrowIfFailed(
                mediaBuffer->Lock(&audioData, nullptr, &sampleBufferLength)
                );

            for (DWORD i = 0; i < sampleBufferLength; i++)
            {
                fileData[positionInData++] = audioData[i];
            }
        }
        if (flags & MF_SOURCE_READERF_ENDOFSTREAM)
        {
            done = true;
        }
    }

    return fileData;
}

Member Data Documentation

internal MediaReader::__pad0__

Definition at line 18 of file MediaReader.h.

Windows::Storage::StorageFolder MediaReader::m_installedLocation [private]

Definition at line 24 of file MediaReader.h.

Platform::String MediaReader::m_installedLocationPath [private]

Definition at line 25 of file MediaReader.h.

WAVEFORMATEX MediaReader::m_waveFormat [private]

Definition at line 26 of file MediaReader.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/MediaReader.h
  • XAML DirectX 3D shooting game/C++/MediaReader.h
  • DirectX 3D shooting game/C++/MediaReader.cpp
  • XAML DirectX 3D shooting game/C++/MediaReader.cpp
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

MediaStreamer Class Reference

#include "MediaStreamer.h"

List of all members.

Public Member Functions

MediaStreamer ()
MediaStreamer (_In_ Platform::String^url)
MediaStreamer (_In_ Platform::String^url)
~MediaStreamer ()
UINT32 | GetMaxStreamLengthInBytes ()
uint32 | GetMaxStreamLengthInBytes () const
uint32 | GetMaxStreamLengthInBytes () const
std::vector< byte > | GetNextBuffer ()
std::vector< byte > | GetNextBuffer ()
bool | GetNextBuffer (uint8 *buffer, uint32 maxBufferSize, uint32 *bufferLength)
WAVEFORMATEX & | GetOutputWaveFormatEx ()
const WAVEFORMATEX & | GetOutputWaveFormatEx () const
const WAVEFORMATEX & | GetOutputWaveFormatEx () const
void | Initialize (_In_ const WCHAR *url)
std::vector< byte > | ReadAll ()
void | ReadAll (uint8 *buffer, uint32 maxBufferSize, uint32 *bufferLength)
std::vector< byte > | ReadAll ()
void | Restart ()
void | Restart ()
void | Restart ()

Public Attributes

Microsoft::WRL::ComPtr
< IMFMediaType > 		m_audioType
Microsoft::WRL::ComPtr
< IMFSourceReader > 		m_reader

Private Attributes

uint32 | m_maxStreamLengthInBytes
WAVEFORMATEX | m_waveFormat

Detailed Description

Definition at line 10 of file MediaStreamer.h.

Constructor & Destructor Documentation

MediaStreamer::MediaStreamer ( )

Definition at line 12 of file MediaStreamer.cpp.

{
    m_reader = nullptr;
    m_audioType = nullptr;
    ZeroMemory(&m_waveFormat, sizeof(m_waveFormat));
}

MediaStreamer::~MediaStreamer ( )

Definition at line 19 of file MediaStreamer.cpp.

{
}

MediaStreamer::MediaStreamer ( _In_ Platform::String^ url )

Definition at line 15 of file MediaStreamer.cpp.

{
    Microsoft::WRL::ComPtr<IMFMediaType> outputMediaType;
    Microsoft::WRL::ComPtr<IMFMediaType> mediaType;

    DX::ThrowIfFailed(
        MFStartup(MF_VERSION)
        );

    //
    // Build an attribute object to set MF_LOW_LATENCY
    // Each title should evaluate whether the latency v. power trade-off is appropriate
    // Longer running music tracks that are not latency sensitive may need this flag less than shorter sounds.
    // This sample is using the flag on a music track for demonstrative purposes.
    //
    Microsoft::WRL::ComPtr<IMFAttributes> lowLatencyAttribute;
    DX::ThrowIfFailed(
        MFCreateAttributes(&lowLatencyAttribute, 1)
        );

    DX::ThrowIfFailed(
        lowLatencyAttribute->SetUINT32(MF_LOW_LATENCY, TRUE)
        );

    //
    // Create the source reader on the url (file) with the low latency attributes
    //
    DX::ThrowIfFailed(
        MFCreateSourceReaderFromURL(url->Data(), lowLatencyAttribute.Get(), &m_reader)
        );

    // Set the decoded output format as PCM
    // XAudio2 on Windows can process PCM and ADPCM-encoded buffers.
    // When using MF, this sample always decodes into PCM.

    DX::ThrowIfFailed(
        MFCreateMediaType(&mediaType)
        );

    DX::ThrowIfFailed(
        mediaType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Audio)
        );

    DX::ThrowIfFailed(
        mediaType->SetGUID(MF_MT_SUBTYPE, MFAudioFormat_PCM)
        );

    DX::ThrowIfFailed(
        m_reader->SetCurrentMediaType(MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, mediaType.Get())
        );

    // Get the complete WAVEFORMAT from the Media Type
    DX::ThrowIfFailed(
        m_reader->GetCurrentMediaType(MF_SOURCE_READER_FIRST_AUDIO_STREAM, &outputMediaType)
        );

    uint32 formatByteCount = 0;
    WAVEFORMATEX* waveFormat;
    DX::ThrowIfFailed(
        MFCreateWaveFormatExFromMFMediaType(outputMediaType.Get(), &waveFormat, &formatByteCount)
        );
    CopyMemory(&m_waveFormat, waveFormat, sizeof(m_waveFormat));
    CoTaskMemFree(waveFormat);

    // Get the total length of the stream in bytes
    PROPVARIANT var;
    DX::ThrowIfFailed(
        m_reader->GetPresentationAttribute(MF_SOURCE_READER_MEDIASOURCE, MF_PD_DURATION, &var)
        );
    LONGLONG duration = var.uhVal.QuadPart;
    float64 durationInSeconds = (duration / (float64)(10000 * 1000));
    m_maxStreamLengthInBytes = (uint32)(durationInSeconds * m_waveFormat.nAvgBytesPerSec);
}

MediaStreamer::MediaStreamer ( _In_ Platform::String^ url )

Member Function Documentation

UINT32 MediaStreamer::GetMaxStreamLengthInBytes ( ) [inline]

Definition at line 29 of file MediaStreamer.h.

    {
        return m_maxStreamLengthInBytes;
    }

uint32 MediaStreamer::GetMaxStreamLengthInBytes ( ) const [inline]

Definition at line 29 of file MediaStreamer.h.

    {
        return m_maxStreamLengthInBytes;
    }

uint32 MediaStreamer::GetMaxStreamLengthInBytes ( ) const [inline]

Definition at line 30 of file MediaStreamer.h.

    {
        return m_maxStreamLengthInBytes;
    }

std::vector< byte > MediaStreamer::GetNextBuffer ( )

Definition at line 89 of file MediaStreamer.cpp.

{
    std::vector<byte> resultData;

    Microsoft::WRL::ComPtr<IMFSample> sample;
    Microsoft::WRL::ComPtr<IMFMediaBuffer> mediaBuffer;

    uint8* audioData = nullptr;
    uint32 sampleBufferLength = 0;
    uint32 flags = 0;

    DX::ThrowIfFailed(
        m_reader->ReadSample(MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, nullptr, reinterpret_cast<DWORD*>(&flags), nullptr, &sample)
        );

    // End of stream
    if (flags & MF_SOURCE_READERF_ENDOFSTREAM)
    {
        return resultData;
    }
    if (sample == nullptr)
    {
        throw ref new Platform::FailureException();
    }

    DX::ThrowIfFailed(
        sample->ConvertToContiguousBuffer(&mediaBuffer)
        );

    DX::ThrowIfFailed(
        mediaBuffer->Lock(&audioData, nullptr, reinterpret_cast<DWORD*>(&sampleBufferLength))
        );

    //
    // Prepare and return the resultant array of data
    //
    resultData.resize(sampleBufferLength);
    CopyMemory(&resultData[0], audioData, sampleBufferLength);

    // Release the lock
    DX::ThrowIfFailed(
        mediaBuffer->Unlock()
        );

    return resultData;
}

bool MediaStreamer::GetNextBuffer | ( | uint8 * | buffer,
 |  | uint32 | maxBufferSize,
 |  | uint32 * | bufferLength
 | ) |  |

Definition at line 85 of file MediaStreamer.cpp.

{
    Microsoft::WRL::ComPtr<IMFSample> sample;
    Microsoft::WRL::ComPtr<IMFMediaBuffer> mediaBuffer;
    BYTE *audioData = nullptr;
    DWORD sampleBufferLength = 0;
    DWORD flags = 0;

    *bufferLength = 0;

    if (m_reader == nullptr)
    {
        return false;
    }

    DX::ThrowIfFailed(
        m_reader->ReadSample(MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, nullptr, &flags, nullptr, &sample)
        );

    if (sample == nullptr)
    {
        if (flags & MF_SOURCE_READERF_ENDOFSTREAM)
        {
            return true;
        }
        else
        {
            return false;
        }
    }

    DX::ThrowIfFailed(
        sample->ConvertToContiguousBuffer(&mediaBuffer)
        );

    DX::ThrowIfFailed(
        mediaBuffer->Lock(&audioData, nullptr, &sampleBufferLength)
        );

    // Only copy the sample if the remaining buffer is large enough.
    if (sampleBufferLength <= maxBufferSize)
    {
        CopyMemory(buffer, audioData, sampleBufferLength);
        *bufferLength = sampleBufferLength;
    }

    if (flags & MF_SOURCE_READERF_ENDOFSTREAM)
    {
        return true;
    }
    else
    {
        return false;
    }
}

std::vector<byte> MediaStreamer::GetNextBuffer ( )
WAVEFORMATEX& MediaStreamer::GetOutputWaveFormatEx ( ) [inline]

Definition at line 24 of file MediaStreamer.h.

    {
        return m_waveFormat;
    }

const WAVEFORMATEX& MediaStreamer::GetOutputWaveFormatEx ( ) const [inline]

Definition at line 24 of file MediaStreamer.h.

    {
        return m_waveFormat;
    }

const WAVEFORMATEX& MediaStreamer::GetOutputWaveFormatEx ( ) const [inline]

Definition at line 25 of file MediaStreamer.h.

    {
        return m_waveFormat;
    }

void MediaStreamer::Initialize ( _In_ const WCHAR * url )

Definition at line 23 of file MediaStreamer.cpp.

{
    Microsoft::WRL::ComPtr<IMFMediaType> outputMediaType;
    Microsoft::WRL::ComPtr<IMFMediaType> mediaType;

    DX::ThrowIfFailed(
        MFStartup(MF_VERSION)
        );

    DX::ThrowIfFailed(
        MFCreateSourceReaderFromURL(url, nullptr, &m_reader)
        );

    // Set the decoded output format as PCM.
    // XAudio2 on Windows can process PCM and ADPCM-encoded buffers.
    // When this sample uses Media Foundation, it always decodes into PCM.

    DX::ThrowIfFailed(
        MFCreateMediaType(&mediaType)
        );

    DX::ThrowIfFailed(
        mediaType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Audio)
        );

    DX::ThrowIfFailed(
        mediaType->SetGUID(MF_MT_SUBTYPE, MFAudioFormat_PCM)
        );

    DX::ThrowIfFailed(
        m_reader->SetCurrentMediaType(MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, mediaType.Get())
        );

    // Get the complete WAVEFORMAT from the Media Type.
    DX::ThrowIfFailed(
        m_reader->GetCurrentMediaType(MF_SOURCE_READER_FIRST_AUDIO_STREAM, &outputMediaType)
        );

    uint32 formatSize = 0;
    WAVEFORMATEX* waveFormat;
    DX::ThrowIfFailed(
        MFCreateWaveFormatExFromMFMediaType(outputMediaType.Get(), &waveFormat, &formatSize)
        );
    CopyMemory(&m_waveFormat, waveFormat, sizeof(m_waveFormat));
    CoTaskMemFree(waveFormat);

    // Get the total length of the stream, in bytes.
    PROPVARIANT var;
    DX::ThrowIfFailed(
        m_reader->GetPresentationAttribute(MF_SOURCE_READER_MEDIASOURCE, MF_PD_DURATION, &var)
        );

    // duration is in 100ns units; convert to seconds, and round up
    // to the nearest whole byte.
    ULONGLONG duration = var.uhVal.QuadPart;
    m_maxStreamLengthInBytes =
        static_cast<unsigned int>(
            ((duration * static_cast<ULONGLONG>(m_waveFormat.nAvgBytesPerSec)) + 10000000) /
            10000000
            );
}

std::vector< byte > MediaStreamer::ReadAll ( )

Definition at line 136 of file MediaStreamer.cpp.

{
    std::vector<byte> resultData;

    // Make sure stream is set to start
    // Restart();

    for (;;)
    {
        std::vector<byte> nextBuffer = GetNextBuffer();
        if (nextBuffer.size() == 0)
        {
            break;
        }

        // Append the new buffer to the running total
        size_t lastBufferSize = resultData.size();
        resultData.resize(lastBufferSize + nextBuffer.size());
        CopyMemory(&resultData[lastBufferSize], &nextBuffer[0], nextBuffer.size());
    }

    return resultData;
}

void MediaStreamer::ReadAll | ( | uint8 * | buffer,
 |  | uint32 | maxBufferSize,
 |  | uint32 * | bufferLength
 | ) |  |

Definition at line 141 of file MediaStreamer.cpp.

{
    uint32 valuesWritten = 0;
    uint32 sampleBufferLength = 0;

    if (m_reader == nullptr)
    {
        return;
    }

    *bufferLength = 0;
    // If buffer isn't large enough, return
    if (maxBufferSize < m_maxStreamLengthInBytes)
    {
        return;
    }

    while (!GetNextBuffer(buffer + valuesWritten, maxBufferSize - valuesWritten, &sampleBufferLength))
    {
        valuesWritten += sampleBufferLength;
    }

    *bufferLength = valuesWritten + sampleBufferLength;
}

std::vector<byte> MediaStreamer::ReadAll ( )
void MediaStreamer::Restart ( )
void MediaStreamer::Restart ( )
void MediaStreamer::Restart ( )

Definition at line 166 of file MediaStreamer.cpp.

{
    if (m_reader == nullptr)
    {
        return;
    }

    PROPVARIANT var = {0};
    var.vt = VT_I8;

    DX::ThrowIfFailed(
        m_reader->SetCurrentPosition(GUID_NULL, var)
        );
}

Member Data Documentation

Microsoft::WRL::ComPtr<IMFMediaType> MediaStreamer::m_audioType

Definition at line 18 of file MediaStreamer.h.

uint32 MediaStreamer::m_maxStreamLengthInBytes [private]

Definition at line 14 of file MediaStreamer.h.

Microsoft::WRL::ComPtr< IMFSourceReader > MediaStreamer::m_reader

Definition at line 17 of file MediaStreamer.h.

WAVEFORMATEX MediaStreamer::m_waveFormat [private]

Definition at line 13 of file MediaStreamer.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/MediaStreamer.h
  • XAudio2 audio stream effect/C++/MediaStreamer.h
  • XInput audio controller playback/C++/MediaStreamer.h
  • DirectX marble maze game/C++/MediaStreamer.cpp
  • XAudio2 audio stream effect/C++/MediaStreamer.cpp
  • XInput audio controller playback/C++/MediaStreamer.cpp
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource::AudioSource Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaStreamSource
  • MediaStreamSource::AudioSource
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

MediaStreamSource::AudioSource Class Reference

An empty page that can be used on its own or navigated to within a Frame.

Inherits SDKTemplate::Common::LayoutAwarePage.

List of all members.

Public Member Functions

AudioSource ()

Protected Member Functions

override void | OnNavigatedTo (NavigationEventArgs e)

Private Member Functions

void | Start_Click (object sender, RoutedEventArgs e)
void | Stop_Click (object sender, RoutedEventArgs e)

Private Attributes

MainPage | rootPage = MainPage.Current

Detailed Description

Definition at line 22 of file AudioSource.xaml.cs.

Constructor & Destructor Documentation

MediaStreamSource::AudioSource::AudioSource ( ) [inline]

Definition at line 28 of file AudioSource.xaml.cs.

        {
            this.InitializeComponent();
        }

Member Function Documentation

override void MediaStreamSource::AudioSource::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 38 of file AudioSource.xaml.cs.

        {
        }

void MediaStreamSource::AudioSource::Start_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Default' button.

You would replace this with your own handler if you have a button or buttons on this page.

Parameters:
sender
e

Definition at line 48 of file AudioSource.xaml.cs.

        {
            MediaStreamSource.SetSource(Media, new PcmSource());
        }

void MediaStreamSource::AudioSource::Stop_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Other' button.

You would replace this with your own handler if you have a button or buttons on this page.

Parameters:
sender
e

Definition at line 59 of file AudioSource.xaml.cs.

        {
            MediaStreamSource.SetSource(Media, null);
        }

Member Data Documentation

MainPage MediaStreamSource::AudioSource::rootPage = MainPage.Current [private]

Definition at line 26 of file AudioSource.xaml.cs.

The documentation for this class was generated from the following file:
  • MediaStreamSource media extension/C#,C++/AudioSource.xaml.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource::PcmSource Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • MediaStreamSource
  • MediaStreamSource::PcmSource
Public Member Functions | Properties | Private Member Functions | Private Attributes

MediaStreamSource::PcmSource Class Reference

A simple media source generating audio wave. More...

Inherits MediaStreamSource.

List of all members.

Public Member Functions

PcmSource ()
override void | CloseMedia ()
override void | GetDiagnosticAsync (MediaStreamSourceDiagnosticKind diagnosticKind)
override void | GetSampleAsync (MediaStreamType mediaStreamType)
override void | OpenMediaAsync ()
override void | SeekAsync (long seekToTime)
override void | SwitchMediaStreamAsync (MediaStreamDescription mediaStreamDescription)

Properties

double | Frequency [get, set]

Private Member Functions

void | CreateSample ()

Private Attributes

byte[] | _pSample
const uint | BitsPerSample = 16
const uint | Channels = 1
long | nextTimestamp
const long | SampleDuration = 10000000
const uint | SampleRate = 44100

Detailed Description

Definition at line 25 of file PcmSource.cs.

Constructor & Destructor Documentation

MediaStreamSource::PcmSource::PcmSource ( ) [inline]

Contructor.

Definition at line 38 of file PcmSource.cs.

        {
            Frequency = 440;
        }

Member Function Documentation

override void MediaStreamSource::PcmSource::CloseMedia ( ) [inline]

Definition at line 43 of file PcmSource.cs.

        {
            _pSample = null;
        }

void MediaStreamSource::PcmSource::CreateSample ( ) [inline, private]

Creates a audio sample.

Definition at line 114 of file PcmSource.cs.

        {
            const uint size = SampleRate * Channels * BitsPerSample / 8;
            _pSample = new byte[size];
            double period = (double)SampleRate / Frequency;

            for (uint i = 0; i < size; i += 2)
            {
                double val = Math.IEEERemainder(i, period);

                val = 2 * Math.PI * val;
                short res = (short)(Math.Sin(val) * (double)short.MaxValue);

                _pSample[i] = (byte)(res & 0x00ff);
                _pSample[i] = (byte)((res >> 8) & 0x00ff);
            }
        }

override void MediaStreamSource::PcmSource::GetDiagnosticAsync ( MediaStreamSourceDiagnosticKind diagnosticKind ) [inline]

Definition at line 48 of file PcmSource.cs.

        {
            throw new NotImplementedException();
        }

override void MediaStreamSource::PcmSource::GetSampleAsync ( MediaStreamType mediaStreamType ) [inline]

Definition at line 53 of file PcmSource.cs.

        {
            Task.Run(() =>
            {
                MediaStreamSample sample;
                try
                {
                    IBuffer winrtbuf = System.Runtime.InteropServices.WindowsRuntime.WindowsRuntimeBuffer.Create(_pSample, 0, _pSample.Length, _pSample.Length);
                    sample = new MediaStreamSample(null, winrtbuf, 0, _pSample.Length, nextTimestamp, SampleDuration, null);
                    nextTimestamp += SampleDuration;
                }
                catch (Exception e)
                {
                    ErrorOccurred(e.Message);
                    return;
                }

                ReportGetSampleCompleted(sample);
            });
        }

override void MediaStreamSource::PcmSource::OpenMediaAsync ( ) [inline]

Definition at line 74 of file PcmSource.cs.

        {
            Task.Run(() =>
            {
                try
                {
                    CreateSample();
                }
                catch (Exception e)
                {
                    ErrorOccurred(e.Message);
                    return;
                }

                PropertySet sourceAttr = new Windows.Foundation.Collections.PropertySet();
                PropertySet streamAttr = new Windows.Foundation.Collections.PropertySet();

                streamAttr.Add("SampleRate", SampleRate);
                streamAttr.Add("Channels", Channels);
                streamAttr.Add("BitsPerSample", BitsPerSample);

                ReportOpenMediaCompleted(
                    sourceAttr,
                    new IPropertySet[] { streamAttr });
            });
        }

override void MediaStreamSource::PcmSource::SeekAsync ( long seekToTime ) [inline]

Definition at line 101 of file PcmSource.cs.

        {
            throw new NotImplementedException();
        }

override void MediaStreamSource::PcmSource::SwitchMediaStreamAsync ( MediaStreamDescription mediaStreamDescription ) [inline]

Definition at line 106 of file PcmSource.cs.

        {
            throw new NotImplementedException();
        }

Member Data Documentation

byte [] MediaStreamSource::PcmSource::_pSample [private]

Definition at line 27 of file PcmSource.cs.

const uint MediaStreamSource::PcmSource::BitsPerSample = 16 [private]

Definition at line 30 of file PcmSource.cs.

const uint MediaStreamSource::PcmSource::Channels = 1 [private]

Definition at line 29 of file PcmSource.cs.

long MediaStreamSource::PcmSource::nextTimestamp [private]

Definition at line 33 of file PcmSource.cs.

const long MediaStreamSource::PcmSource::SampleDuration = 10000000 [private]

Definition at line 31 of file PcmSource.cs.

const uint MediaStreamSource::PcmSource::SampleRate = 44100 [private]

Definition at line 28 of file PcmSource.cs.

Property Documentation

double MediaStreamSource::PcmSource::Frequency [get, set]

Definition at line 133 of file PcmSource.cs.

The documentation for this class was generated from the following file:
  • MediaStreamSource media extension/C#,C++/PcmSource.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MemDelete Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

MemDelete Class Reference

#include "LinkList.h"

List of all members.

Public Member Functions

void | operator() (void *p)
void | operator() (void *p)
void | operator() (void *p)

Detailed Description

Definition at line 403 of file LinkList.h.

Member Function Documentation

void MemDelete::operator() ( void * p ) [inline]

Definition at line 406 of file LinkList.h.

    {
        if (p)
        {
            delete p;
        }
    }

void MemDelete::operator() ( void * p ) [inline]

Definition at line 406 of file LinkList.h.

    {
        if (p)
        {
            delete p;
        }
    }

void MemDelete::operator() ( void * p ) [inline]

Definition at line 406 of file LinkList.h.

    {
        if (p)
        {
            delete p;
        }
    }

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/LinkList.h
  • Media extensions/C++/MediaExtensions/Common/LinkList.h
  • Real-time communication/C++/MediaExtensions/Common/LinkList.h
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MEPlayer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

MEPlayer Class Reference

#include "meplayer.h"

List of all members.

Public Member Functions

void | AutoPlay (BOOL autoPlay)
void | CloseFilePicker ()
void | CreateBackBuffers ()
void | CreateDX11Device ()
void | EnableVideoEffect (BOOL enable)
BOOL | ExitApp ()
void | FrameStep ()
void | GetDuration (double *pDuration, BOOL *pbCanSeek)
double | GetPlaybackPosition ()
void | Initialize (Windows::UI::Core::CoreWindow^window)
BOOL | IsPlaying ()
BOOL | IsSeeking ()
void | Loop ()
void | Mute (BOOL mute)
virtual void | OnMediaEngineEvent (DWORD meEvent) override
void | OnTimer ()
void | OpenFile ()
void | Pause ()
void | Play ()
DWORD | RealVSyncTimer ()
void | ResizeVideo (HWND hwnd)
void | SetBalance (float fBal)
void | SetBytestream (Windows::Storage::Streams::IRandomAccessStream^streamHandle)
void | SetPlaybackPosition (float pos)
void | SetURL (Platform::String^szURL)
void | SetVolume (float fVol)
void | Shutdown ()
void | StartTimer ()
void | StopTimer ()
void | UpdateForWindowSizeChange ()

Public Attributes

internal | __pad0__: MEPlayer()
MFARGB | m_bkgColor
BSTR | m_bstrURL
CRITICAL_SECTION | m_critSec
DXGI_FORMAT | m_d3dFormat
BOOL | m_fEOS
BOOL | m_fExitApp
BOOL | m_fInitSuccess
BOOL | m_fLoop
BOOL | m_fPlaying
BOOL | m_fStopTimer
BOOL | m_fUseDX
concurrency::task
< Windows::Storage::StorageFile^> 		m_pickFileTask
RECT | m_rcTarget
Microsoft::WRL::ComPtr
< ID3D11Device > 		m_spDX11Device
Microsoft::WRL::ComPtr
< ID3D11DeviceContext > 		m_spDX11DeviceContext
Microsoft::WRL::ComPtr
< IDXGISwapChain1 > 		m_spDX11SwapChain
Microsoft::WRL::ComPtr
< IMFDXGIDeviceManager > 		m_spDXGIManager
Microsoft::WRL::ComPtr
< IDXGIOutput > 		m_spDXGIOutput
Microsoft::WRL::ComPtr
< IMFMediaEngineEx > 		m_spEngineEx
Microsoft::WRL::ComPtr
< IMFMediaEngine > 		m_spMediaEngine
concurrency::cancellation_token_source | m_tcs
HANDLE | m_TimerThreadHandle

Private Member Functions

~MEPlayer ()

Private Attributes

Platform::Agile
< Windows::UI::Core::CoreWindow > 		m_window

Detailed Description

Definition at line 49 of file meplayer.h.

Constructor & Destructor Documentation

MEPlayer::~MEPlayer ( ) [private]

Definition at line 114 of file meplayer.cpp.

{
    Shutdown();

    MFShutdown();

    DeleteCriticalSection(&m_critSec);
}

Member Function Documentation

void MEPlayer::AutoPlay ( BOOL autoPlay ) [inline]

Definition at line 97 of file meplayer.h.

    {
        if (m_spMediaEngine)
        {
            m_spMediaEngine->SetAutoPlay(autoPlay);
        }
    }

void MEPlayer::CloseFilePicker ( ) [inline]

Definition at line 119 of file meplayer.h.

    {
        m_tcs.cancel();
    }

void MEPlayer::CreateBackBuffers ( )

Definition at line 202 of file meplayer.cpp.

{
    EnterCriticalSection(&m_critSec);

    // make sure everything is released first;
    if(m_spDX11Device)
    {
        // Acquire the DXGIdevice lock
        CAutoDXGILock DXGILock(m_spDXGIManager);

        ComPtr<ID3D11Device> spDevice;
        MEDIA::ThrowIfFailed(
            DXGILock.LockDevice(/*out*/spDevice)
            );

        // swap chain does not exist - so create it
        if (m_spDX11SwapChain == nullptr)
        {
            DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};

            // Don't use Multi-sampling
            swapChainDesc.SampleDesc.Count = 1;
            swapChainDesc.SampleDesc.Quality = 0;

            swapChainDesc.BufferUsage = DXGI_USAGE_BACK_BUFFER | DXGI_USAGE_RENDER_TARGET_OUTPUT;
            swapChainDesc.Scaling = DXGI_SCALING_NONE;
            swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL;

            // Use more than 1 buffer to enable Flip effect.
            swapChainDesc.BufferCount = 4;

            // Most common swapchain format is DXGI_FORMAT_R8G8B8A8-UNORM
            swapChainDesc.Format = m_d3dFormat;
            swapChainDesc.Width = m_rcTarget.right;
            swapChainDesc.Height = m_rcTarget.bottom;

            // long QI chain to get DXGIFactory from the device
            ComPtr<IDXGIDevice2> spDXGIDevice;
            MEDIA::ThrowIfFailed(
                spDevice.Get()->QueryInterface(IID_PPV_ARGS(&spDXGIDevice))
                );

            // Ensure that DXGI does not queue more than one frame at a time. This both reduces
            // latency and ensures that the application will only render after each VSync, minimizing
            // power consumption.
            MEDIA::ThrowIfFailed(
                spDXGIDevice->SetMaximumFrameLatency(1)
                );

            ComPtr<IDXGIAdapter> spDXGIAdapter;
            MEDIA::ThrowIfFailed(
                spDXGIDevice->GetParent(IID_PPV_ARGS(&spDXGIAdapter))
                );

            ComPtr<IDXGIFactory2> spDXGIFactory;
            MEDIA::ThrowIfFailed(
                spDXGIAdapter->GetParent(IID_PPV_ARGS(&spDXGIFactory))
                );

            // and then we pass the device to the factory...
            MEDIA::ThrowIfFailed(
                spDXGIFactory.Get()->CreateSwapChainForCoreWindow(spDevice.Get(), reinterpret_cast<IUnknown*>((Windows::UI::Core::CoreWindow^)m_window.Get()), &swapChainDesc, nullptr, &m_spDX11SwapChain)
                );
        }
        else
        {
            // otherwise just resize it
            MEDIA::ThrowIfFailed(m_spDX11SwapChain->ResizeBuffers(
                4,
                m_rcTarget.right,
                m_rcTarget.bottom,
                m_d3dFormat,
                0
                ));
        }
    }

    LeaveCriticalSection(&m_critSec);

    return;
}

void MEPlayer::CreateDX11Device ( )

Definition at line 130 of file meplayer.cpp.

{
    static const D3D_FEATURE_LEVEL levels[] = {
        D3D_FEATURE_LEVEL_11_1,
        D3D_FEATURE_LEVEL_11_0,
        D3D_FEATURE_LEVEL_10_1,
        D3D_FEATURE_LEVEL_10_0,
        D3D_FEATURE_LEVEL_9_3,
        D3D_FEATURE_LEVEL_9_2,
        D3D_FEATURE_LEVEL_9_1
    };

    D3D_FEATURE_LEVEL FeatureLevel;
    HRESULT hr = S_OK;

    if(m_fUseDX)
    {
        hr = D3D11CreateDevice(
            nullptr,
            D3D_DRIVER_TYPE_HARDWARE,
            nullptr,
            D3D11_CREATE_DEVICE_VIDEO_SUPPORT | D3D11_CREATE_DEVICE_BGRA_SUPPORT,
            levels,
            ARRAYSIZE(levels),
            D3D11_SDK_VERSION,
            &m_spDX11Device,
            &FeatureLevel,
            &m_spDX11DeviceContext
            );
    }

    //Failed to create DX11 Device (using VM?), create device using WARP
    if(FAILED(hr))
    {
        m_fUseDX = FALSE;
    }

    if(!m_fUseDX)
    {
        MEDIA::ThrowIfFailed(D3D11CreateDevice(
            nullptr,
            D3D_DRIVER_TYPE_WARP,
            nullptr,
            D3D11_CREATE_DEVICE_BGRA_SUPPORT,
            levels,
            ARRAYSIZE(levels),
            D3D11_SDK_VERSION,
            &m_spDX11Device,
            &FeatureLevel,
            &m_spDX11DeviceContext
            ));
    }

    if(m_fUseDX)
    {
        ComPtr<ID3D10Multithread> spMultithread;
        MEDIA::ThrowIfFailed(
            m_spDX11Device.Get()->QueryInterface(IID_PPV_ARGS(&spMultithread))
            );
        spMultithread->SetMultithreadProtected(TRUE);
    }

    return;
}

void MEPlayer::EnableVideoEffect ( BOOL enable )

Definition at line 715 of file meplayer.cpp.

{
    HRESULT hr = S_OK;

    if(m_spEngineEx)
    {
        MEDIA::ThrowIfFailed(m_spEngineEx->RemoveAllEffects());
        if(enable)
        {
            ComPtr<IMFActivate> spActivate;
            LPCWSTR szActivatableClassId = WindowsGetStringRawBuffer((HSTRING)Windows::Media::VideoEffects::VideoStabilization->Data(), nullptr);

            MEDIA::ThrowIfFailed(MFCreateMediaExtensionActivate(szActivatableClassId, nullptr, IID_PPV_ARGS(&spActivate)));

            MEDIA::ThrowIfFailed(m_spEngineEx->InsertVideoEffect(spActivate.Get(), FALSE));
        }
    }

    return;
}

BOOL MEPlayer::ExitApp ( )

Definition at line 886 of file meplayer.cpp.

{
    return m_fExitApp;
}

void MEPlayer::FrameStep ( )

Definition at line 634 of file meplayer.cpp.

{
    if (m_spEngineEx)
    {
        MEDIA::ThrowIfFailed(
            m_spEngineEx->FrameStep(TRUE)
            );
    }
    return;
}

void MEPlayer::GetDuration | ( | double * | pDuration,
 |  | BOOL * | pbCanSeek
 | ) |  |

Definition at line 646 of file meplayer.cpp.

{
    if (m_spMediaEngine)
    {
        double duration = m_spMediaEngine->GetDuration();

        // NOTE:
        // "duration != duration"
        // This tests if duration is NaN, because NaN != NaN

        if (duration != duration || duration == std::numeric_limits<float>::infinity())
        {
            *pDuration = 0;
            *pbCanSeek = FALSE;
        }
        else
        {
            *pDuration = duration;

            DWORD caps = 0;
            m_spEngineEx->GetResourceCharacteristics(&caps);
            *pbCanSeek = (caps & ME_CAN_SEEK) == ME_CAN_SEEK;
        }
    }
    else
    {
        MEDIA::ThrowIfFailed(E_FAIL);
    }

    return;
}

double MEPlayer::GetPlaybackPosition ( )

Definition at line 679 of file meplayer.cpp.

{
    if (m_spMediaEngine)
    {
        return m_spMediaEngine->GetCurrentTime();
    }
    else
    {
        return 0;
    }
}

void MEPlayer::Initialize ( Windows::UI::Core::CoreWindow^ window )

Definition at line 285 of file meplayer.cpp.

{
    ComPtr<IMFMediaEngineClassFactory> spFactory;
    ComPtr<IMFAttributes> spAttributes;
    ComPtr<MediaEngineNotify> spNotify;

    HRESULT hr = S_OK;

    m_window = window;

    // Get the bounding rectangle of the window.
    m_rcTarget.left = 0;
    m_rcTarget.top = 0;
    m_rcTarget.right = (LONG)m_window->Bounds.Width;
    m_rcTarget.bottom = (LONG)m_window->Bounds.Height;

    MEDIA::ThrowIfFailed(MFStartup(MF_VERSION));

    EnterCriticalSection(&m_critSec);

    try
    {

        // Create DX11 device.
        CreateDX11Device();

        UINT resetToken;
        MEDIA::ThrowIfFailed(
            MFCreateDXGIDeviceManager(&resetToken, &m_spDXGIManager)
            );

        MEDIA::ThrowIfFailed(
            m_spDXGIManager->ResetDevice(m_spDX11Device.Get(), resetToken)
            );

        // Create our event callback object.
        spNotify = new MediaEngineNotify(m_window);
        if (spNotify == nullptr)
        {
            MEDIA::ThrowIfFailed(E_OUTOFMEMORY);
        }

        spNotify->MediaEngineNotifyCallback(this);

        // Create the class factory for the Media Engine.
        MEDIA::ThrowIfFailed(
            CoCreateInstance(CLSID_MFMediaEngineClassFactory, nullptr, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&spFactory))
            );

        // Set configuration attribiutes.
        MEDIA::ThrowIfFailed(
            MFCreateAttributes(&spAttributes, 1)
            );

        MEDIA::ThrowIfFailed(
            spAttributes->SetUnknown(MF_MEDIA_ENGINE_DXGI_MANAGER, (IUnknown*) m_spDXGIManager.Get())
            );

        MEDIA::ThrowIfFailed(
            spAttributes->SetUnknown(MF_MEDIA_ENGINE_CALLBACK, (IUnknown*) spNotify.Get())
            );

        MEDIA::ThrowIfFailed(
            spAttributes->SetUINT32(MF_MEDIA_ENGINE_VIDEO_OUTPUT_FORMAT, m_d3dFormat)
            );

        // Create the Media Engine.
        const DWORD flags = MF_MEDIA_ENGINE_WAITFORSTABLE_STATE;
        MEDIA::ThrowIfFailed(
            spFactory->CreateInstance(flags, spAttributes.Get(), &m_spMediaEngine)
            );

        MEDIA::ThrowIfFailed(
            m_spMediaEngine.Get()->QueryInterface(__uuidof(IMFMediaEngine), (void**) &m_spEngineEx)
            );

        // Create/Update swap chain
        UpdateForWindowSizeChange();

        m_fInitSuccess = TRUE;

    }
    catch (Platform::Exception^)
    {
        CoreWindowDialog^ coreWindowDialog = ref new CoreWindowDialog( \
            "Failed to initialize DirectX device.");
        task<Windows::UI::Popups::IUICommand^> coreWindowDialogTask(coreWindowDialog->ShowAsync());

        coreWindowDialogTask.then([this](Windows::UI::Popups::IUICommand^ uiCommand){
            m_fExitApp = TRUE;
            });
    }

    LeaveCriticalSection(&m_critSec);

    return;
}

BOOL MEPlayer::IsPlaying ( ) [inline]

Definition at line 114 of file meplayer.h.

    {
        return m_fPlaying;
    }

BOOL MEPlayer::IsSeeking ( )

Definition at line 703 of file meplayer.cpp.

{
    if (m_spMediaEngine)
    {
        return m_spMediaEngine->IsSeeking();
    }
    else
    {
        return FALSE;
    }
}

void MEPlayer::Loop ( ) [inline]

Definition at line 105 of file meplayer.h.

    {
        if (m_spMediaEngine)
        {
            (m_fLoop) ? m_fLoop = FALSE : m_fLoop = TRUE;
            m_spMediaEngine->SetLoop(m_fLoop);
        }
    }

void MEPlayer::Mute ( BOOL mute )

Definition at line 622 of file meplayer.cpp.

{
    if (m_spMediaEngine)
    {
        MEDIA::ThrowIfFailed(
            m_spMediaEngine->SetMuted(mute)
            );
    }
    return;
}

void MEPlayer::OnMediaEngineEvent ( DWORD meEvent ) [override, virtual]

Definition at line 519 of file meplayer.cpp.

{
    switch (meEvent)
    {
    case MF_MEDIA_ENGINE_EVENT_LOADEDMETADATA:
        {
            m_fEOS = FALSE;
        }
        break;
    case MF_MEDIA_ENGINE_EVENT_CANPLAY:
        {
            // Start the Playback
            Play();
        }
        break;
    case MF_MEDIA_ENGINE_EVENT_PLAY:
        m_fPlaying = TRUE;
        break;
    case MF_MEDIA_ENGINE_EVENT_PAUSE:
        m_fPlaying = FALSE;
        break;
    case MF_MEDIA_ENGINE_EVENT_ENDED:

        if(m_spMediaEngine->HasVideo())
        {
            StopTimer();
        }
        m_fEOS = TRUE;
        break;
    case MF_MEDIA_ENGINE_EVENT_TIMEUPDATE:
        break;
    case MF_MEDIA_ENGINE_EVENT_ERROR:
        break;
    }

    return;
}

void MEPlayer::OnTimer ( )

Definition at line 847 of file meplayer.cpp.

{
    EnterCriticalSection(&m_critSec);

    if (m_spMediaEngine != nullptr)
    {
        LONGLONG pts;
        if (m_spMediaEngine->OnVideoStreamTick(&pts) == S_OK)
        {
            // new frame available at the media engine so get it
            ComPtr<ID3D11Texture2D> spTextureDst;
            MEDIA::ThrowIfFailed(
                m_spDX11SwapChain->GetBuffer(0, IID_PPV_ARGS(&spTextureDst))
                );

            MEDIA::ThrowIfFailed(
                m_spMediaEngine->TransferVideoFrame(spTextureDst.Get(), nullptr, &m_rcTarget, &m_bkgColor)
                );

            // and the present it to the screen
            MEDIA::ThrowIfFailed(
                m_spDX11SwapChain->Present(1, 0)
                );
        }
    }

    LeaveCriticalSection(&m_critSec);

    return;
}

void MEPlayer::OpenFile ( )

Definition at line 406 of file meplayer.cpp.

{
    if(m_fInitSuccess == FALSE)
    {
        return;
    }
    if(IsPlaying())
    {
        Pause();
    }
    if(m_fEOS)
    {
        StopTimer();
    }

    FileOpenPicker^ getVidFile = ref new FileOpenPicker();

    getVidFile->SuggestedStartLocation = PickerLocationId::VideosLibrary;
    getVidFile->ViewMode = PickerViewMode::Thumbnail;

    getVidFile->FileTypeFilter->Clear();
    getVidFile->FileTypeFilter->Append(".mp4");
    getVidFile->FileTypeFilter->Append(".m4v");
    getVidFile->FileTypeFilter->Append(".mts");
    getVidFile->FileTypeFilter->Append(".mov");
    getVidFile->FileTypeFilter->Append(".wmv");
    getVidFile->FileTypeFilter->Append(".avi");
    getVidFile->FileTypeFilter->Append(".asf");

    m_pickFileTask = task<StorageFile^>(getVidFile->PickSingleFileAsync(), m_tcs.get_token());

    m_pickFileTask.then([this](StorageFile^ fileHandle)
    {
        try
        {
            if(!fileHandle)
            {
                if(!m_spMediaEngine->HasVideo())
                {
                    m_fExitApp = TRUE;
                }
                return;
            }

            task<IRandomAccessStream^> fOpenStreamTask(fileHandle->OpenAsync(Windows::Storage::FileAccessMode::Read));

            SetURL(fileHandle->Path);

            auto vidPlayer = this;
            fOpenStreamTask.then([vidPlayer](IRandomAccessStream^ streamHandle)
            {
                try
                {
                    vidPlayer->SetBytestream(streamHandle);
                } catch(Platform::Exception^)
                {
                    MEDIA::ThrowIfFailed(E_UNEXPECTED);
                }
            });

        } catch(Platform::Exception^)
        {
            if(!m_spMediaEngine->HasVideo())
            {
                m_fExitApp = TRUE;
            }

        }
    });

    return;
}

void MEPlayer::Pause ( )

Definition at line 586 of file meplayer.cpp.

{
    if (m_spMediaEngine)
    {
        MEDIA::ThrowIfFailed(
            m_spMediaEngine->Pause()
            );
    }
    return;
}

void MEPlayer::Play ( )

Definition at line 558 of file meplayer.cpp.

{
    if (m_spMediaEngine)
    {
        if(m_spMediaEngine->HasVideo() && m_fStopTimer)
        {
            // Start the Timer thread
            StartTimer();
        }

        if(m_fEOS)
        {
            SetPlaybackPosition(0);
            m_fPlaying = TRUE;
        }
        else
        {
            MEDIA::ThrowIfFailed(
                m_spMediaEngine->Play()
                );
        }

        m_fEOS = FALSE;
    }
    return;
}

DWORD MEPlayer::RealVSyncTimer ( )

Definition at line 820 of file meplayer.cpp.

{
    for ( ;; )
    {
        if (m_fStopTimer)
        {
            break;
        }

        if (SUCCEEDED(m_spDXGIOutput->WaitForVBlank()))
        {
            OnTimer();
        }
        else break;
    }

    return 0;
}

void MEPlayer::ResizeVideo ( HWND hwnd )
void MEPlayer::SetBalance ( float fBal )

Definition at line 610 of file meplayer.cpp.

{
    if (m_spEngineEx)
    {
        MEDIA::ThrowIfFailed(
            m_spEngineEx->SetBalance(fBal)
            );
    }
    return;
}

void MEPlayer::SetBytestream ( Windows::Storage::Streams::IRandomAccessStream^ streamHandle )
void MEPlayer::SetPlaybackPosition ( float pos )

Definition at line 692 of file meplayer.cpp.

{
    if (m_spMediaEngine)
    {
        MEDIA::ThrowIfFailed(
            m_spMediaEngine->SetCurrentTime(pos)
            );
    }
}

void MEPlayer::SetURL ( Platform::String^ szURL )

Definition at line 481 of file meplayer.cpp.

{
    if(nullptr != m_bstrURL)
    {
        ::CoTaskMemFree(m_bstrURL);
        m_bstrURL = nullptr;
    }

    size_t cchAllocationSize = 1 + ::wcslen(szURL->Data());
    m_bstrURL = (LPWSTR)::CoTaskMemAlloc(sizeof(WCHAR)*(cchAllocationSize));

    if (m_bstrURL == 0)
    {
        MEDIA::ThrowIfFailed(E_OUTOFMEMORY);
    }

    StringCchCopyW(m_bstrURL, cchAllocationSize, szURL->Data());

    return;
}

void MEPlayer::SetVolume ( float fVol )

Definition at line 598 of file meplayer.cpp.

{
    if (m_spMediaEngine)
    {
        MEDIA::ThrowIfFailed(
            m_spMediaEngine->SetVolume(fVol)
            );
    }
    return;
}

void MEPlayer::Shutdown ( )

Definition at line 384 of file meplayer.cpp.

{
    EnterCriticalSection(&m_critSec);

    StopTimer();

    if (m_spMediaEngine)
    {
        m_spMediaEngine->Shutdown();
    }

    if(nullptr != m_bstrURL)
    {
        ::CoTaskMemFree(m_bstrURL);
    }

    LeaveCriticalSection(&m_critSec);

    return;
}

void MEPlayer::StartTimer ( )

Definition at line 767 of file meplayer.cpp.

{
    ComPtr<IDXGIFactory1> spFactory;
    MEDIA::ThrowIfFailed(
        CreateDXGIFactory1(IID_PPV_ARGS(&spFactory))
        );

    ComPtr<IDXGIAdapter> spAdapter;
    MEDIA::ThrowIfFailed(
        spFactory->EnumAdapters(0, &spAdapter)
        );

    ComPtr<IDXGIOutput> spOutput;
    MEDIA::ThrowIfFailed(
        spAdapter->EnumOutputs(0, &m_spDXGIOutput)
        );

    m_fStopTimer = FALSE;

    auto vidPlayer = this;
    task<void> workItem(ThreadPool::RunAsync(ref new WorkItemHandler([=](IAsyncAction^ /*sender*/){
        vidPlayer->RealVSyncTimer();
        }
        ),
        WorkItemPriority::High
        ));

    return;
}

void MEPlayer::StopTimer ( )

Definition at line 804 of file meplayer.cpp.

{
    m_fStopTimer = TRUE;
    m_fPlaying = FALSE;

    return;
}

void MEPlayer::UpdateForWindowSizeChange ( )

Definition at line 737 of file meplayer.cpp.

{
    if ((m_window->Bounds.Width  != m_rcTarget.right ||
        m_window->Bounds.Height != m_rcTarget.bottom) ||
        m_spDX11SwapChain == nullptr)
    {
        // Get the bounding rectangle of the window.
        m_rcTarget.left = 0;
        m_rcTarget.top = 0;
        m_rcTarget.right = (LONG)m_window->Bounds.Width;
        m_rcTarget.bottom = (LONG)m_window->Bounds.Height;

        if(m_spEngineEx)
        {
            CreateBackBuffers();
        }
    }

    return;
}

Member Data Documentation

internal MEPlayer::__pad0__

Definition at line 82 of file meplayer.h.

MFARGB MEPlayer::m_bkgColor

Definition at line 69 of file meplayer.h.

BSTR MEPlayer::m_bstrURL

Definition at line 62 of file meplayer.h.

CRITICAL_SECTION MEPlayer::m_critSec

Definition at line 72 of file meplayer.h.

DXGI_FORMAT MEPlayer::m_d3dFormat

Definition at line 68 of file meplayer.h.

BOOL MEPlayer::m_fEOS

Definition at line 65 of file meplayer.h.

BOOL MEPlayer::m_fExitApp

Definition at line 77 of file meplayer.h.

BOOL MEPlayer::m_fInitSuccess

Definition at line 76 of file meplayer.h.

BOOL MEPlayer::m_fLoop

Definition at line 64 of file meplayer.h.

BOOL MEPlayer::m_fPlaying

Definition at line 63 of file meplayer.h.

BOOL MEPlayer::m_fStopTimer

Definition at line 66 of file meplayer.h.

BOOL MEPlayer::m_fUseDX

Definition at line 78 of file meplayer.h.

concurrency::task<Windows::Storage::StorageFile^> MEPlayer::m_pickFileTask

Definition at line 74 of file meplayer.h.

RECT MEPlayer::m_rcTarget

Definition at line 67 of file meplayer.h.

Microsoft::WRL::ComPtr<ID3D11Device> MEPlayer::m_spDX11Device

Definition at line 52 of file meplayer.h.

Microsoft::WRL::ComPtr<ID3D11DeviceContext> MEPlayer::m_spDX11DeviceContext

Definition at line 53 of file meplayer.h.

Microsoft::WRL::ComPtr<IDXGISwapChain1> MEPlayer::m_spDX11SwapChain

Definition at line 55 of file meplayer.h.

Microsoft::WRL::ComPtr<IMFDXGIDeviceManager> MEPlayer::m_spDXGIManager

Definition at line 56 of file meplayer.h.

Microsoft::WRL::ComPtr<IDXGIOutput> MEPlayer::m_spDXGIOutput

Definition at line 54 of file meplayer.h.

Microsoft::WRL::ComPtr<IMFMediaEngineEx> MEPlayer::m_spEngineEx

Definition at line 60 of file meplayer.h.

Microsoft::WRL::ComPtr<IMFMediaEngine> MEPlayer::m_spMediaEngine

Definition at line 59 of file meplayer.h.

concurrency::cancellation_token_source MEPlayer::m_tcs

Definition at line 75 of file meplayer.h.

HANDLE MEPlayer::m_TimerThreadHandle

Definition at line 71 of file meplayer.h.

Platform::Agile<Windows::UI::Core::CoreWindow> MEPlayer::m_window [private]

Definition at line 160 of file meplayer.h.

The documentation for this class was generated from the following files:
  • Media engine native C++ video playback/C++/meplayer.h
  • Media engine native C++ video playback/C++/meplayer.cpp
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MoveLookController Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

MoveLookController Class Reference

#include "MoveLookController.h"

List of all members.

Public Member Functions

bool | Active ()
void | Active (_In_ bool active)
bool | Active ()
void | Active (_In_ bool active)
bool | AutoFire ()
void | AutoFire (_In_ bool AutoFire)
bool | AutoFire ()
void | AutoFire (_In_ bool AutoFire)
void | Initialize (_In_ Windows::UI::Core::CoreWindow^window)
void | Initialize (_In_ Windows::UI::Core::CoreWindow^window)
bool | IsFiring ()
bool | IsFiring ()
bool | IsPauseRequested ()
bool | IsPauseRequested ()
bool | IsPressComplete ()
bool | IsPressComplete ()
DirectX::XMFLOAT3 | LookDirection ()
DirectX::XMFLOAT3 | LookDirection ()
float | Pitch ()
void | Pitch (_In_ float pitch)
float | Pitch ()
void | Pitch (_In_ float pitch)
void | SetFireRect (_In_ DirectX::XMFLOAT2 upperLeft, _In_ DirectX::XMFLOAT2 lowerRight)
void | SetFireRect (_In_ DirectX::XMFLOAT2 upperLeft, _In_ DirectX::XMFLOAT2 lowerRight)
void | SetMoveRect (_In_ DirectX::XMFLOAT2 upperLeft, _In_ DirectX::XMFLOAT2 lowerRight)
void | SetMoveRect (_In_ DirectX::XMFLOAT2 upperLeft, _In_ DirectX::XMFLOAT2 lowerRight)
void | Update ()
void | Update ()
DirectX::XMFLOAT3 | Velocity ()
DirectX::XMFLOAT3 | Velocity ()
void | WaitForPress (_In_ DirectX::XMFLOAT2 UpperLeft, _In_ DirectX::XMFLOAT2 LowerRight)
void | WaitForPress ()
void | WaitForPress ()
void | WaitForPress (_In_ DirectX::XMFLOAT2 UpperLeft, _In_ DirectX::XMFLOAT2 LowerRight)
float | Yaw ()
float | Yaw ()
void | Yaw (_In_ float yaw)
void | Yaw (_In_ float yaw)

Public Attributes

internal | __pad0__: MoveLookController()

Protected Member Functions

void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyUp (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyUp (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnMouseMoved (_In_ Windows::Devices::Input::MouseDevice^mouseDevice, _In_ Windows::Devices::Input::MouseEventArgs^args)
void | OnMouseMoved (_In_ Windows::Devices::Input::MouseDevice^mouseDevice, _In_ Windows::Devices::Input::MouseEventArgs^args)
void | OnPointerExited (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerExited (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)

Private Member Functions

float3 GetLookPoint ()
float3 GetPosition ()
void | Initialize (_In_ Windows::UI::Core::CoreWindow^window)
void | LoadInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnKeyUp (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnMouseMoved (_In_ Windows::Devices::Input::MouseDevice^mouseDevice, _In_ Windows::Devices::Input::MouseEventArgs^args)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | ResetState ()
void | ResetState ()
void | SaveInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | SaveInternalValue (_In_ Windows::Foundation::Collections::IPropertySet^state, _In_ Platform::String^key, _In_ Platform::Object^value)
void | SetOrientation (_In_ float pitch, _In_ float yaw)
void | SetPosition (_In_ float3 pos)
void | Update (Windows::UI::Core::CoreWindow^window)
void | UpdateGameController ()
void | UpdateGameController ()

Private Attributes

internal _In_
Windows::UI::Core::PointerEventArgs 		args
bool | m_autoFire
bool | m_back
bool | m_buttonInUse
DirectX::XMFLOAT2 | m_buttonLowerRight
uint32 | m_buttonPointerID
bool | m_buttonPressed
DirectX::XMFLOAT2 | m_buttonUpperLeft
bool | m_down
bool | m_fireInUse
DirectX::XMFLOAT2 | m_fireLastPoint
DirectX::XMFLOAT2 | m_fireLowerRight
UINT32 | m_firePointerID
bool | m_firePressed
DirectX::XMFLOAT2 | m_fireUpperLeft
bool | m_forward
bool | m_isControllerConnected
bool | m_left
bool | m_lookInUse
float2 m_lookLastDelta
DirectX::XMFLOAT2 | m_lookLastDelta
float2 m_lookLastPoint
DirectX::XMFLOAT2 | m_lookLastPoint
uint32 | m_lookPointerID
bool | m_mouseInUse
DirectX::XMFLOAT2 | m_mouseLastPoint
bool | m_mouseLeftInUse
bool | m_mouseLookInUse
uint32 | m_mouseLookPointerID
uint32 | m_mousePointerID
bool | m_mouseRightInUse
float3 m_moveCommand
DirectX::XMFLOAT3 | m_moveCommand
DirectX::XMFLOAT2 | m_moveFirstDown
float2 m_moveFirstDown
bool | m_moveInUse
DirectX::XMFLOAT2 | m_moveLowerRight
uint32 | m_movePointerID
DirectX::XMFLOAT2 | m_movePointerPosition
float2 m_movePointerPosition
DirectX::XMFLOAT2 | m_moveUpperLeft
bool | m_pause
bool | m_pausePressed
float | m_pitch
float3 m_position
bool | m_right
MoveLookControllerState m_state
bool | m_up
DirectX::XMFLOAT3 | m_velocity
XINPUT_CAPABILITIES | m_xinputCaps
bool | m_xinputStartButtonInUse
XINPUT_STATE | m_xinputState
bool | m_xinputTriggerInUse
float | m_yaw

Detailed Description

Definition at line 84 of file MoveLookController.h.

Member Function Documentation

bool MoveLookController::Active ( )

Definition at line 766 of file MoveLookController.cpp.

{
    if (m_state == MoveLookControllerState::Active)
    {
        return true;
    }
    else
    {
        return false;
    }
}

void MoveLookController::Active ( _In_ bool active )

Definition at line 737 of file MoveLookController.cpp.

{
    ResetState();
#ifdef MOVELOOKCONTROLLER_TRACE
    DebugTrace(L"Active = %s\n", active ? L"true" : L"false");
#endif

    if (active)
    {
        m_state = MoveLookControllerState::Active;
        // Turn mouse cursor off (hidden).
        CoreWindow::GetForCurrentThread()->PointerCursor = nullptr;
    }
    else
    {
        m_state = MoveLookControllerState::None;
        // Turn mouse cursor on.
        auto window = CoreWindow::GetForCurrentThread();
        if (window)
        {
            // Protect case where there isn't a window associated with the current thread.
            // This happens on initialization.
            window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
        }
    }
}

bool MoveLookController::Active ( )
void MoveLookController::Active ( _In_ bool active )
bool MoveLookController::AutoFire ( )

Definition at line 787 of file MoveLookController.cpp.

{
    return m_autoFire;
}

void MoveLookController::AutoFire ( _In_ bool AutoFire )

Definition at line 780 of file MoveLookController.cpp.

{
    m_autoFire = autoFire;
}

bool MoveLookController::AutoFire ( )
void MoveLookController::AutoFire ( _In_ bool AutoFire )
float3 MoveLookController::GetLookPoint ( ) [private]

Definition at line 261 of file MoveLookController.cpp.

{
    float y = sinf(m_pitch);        // vertical
    float r = cosf(m_pitch);        // in the plane
    float z = r*cosf(m_yaw);        // fwd-back
    float x = r*sinf(m_yaw);        // left-right

    return m_position + float3(x, y, z);
}

float3 MoveLookController::GetPosition ( ) [private]

Definition at line 255 of file MoveLookController.cpp.

{
    return m_position;
}

void MoveLookController::Initialize ( _In_ Windows::UI::Core::CoreWindow^ window ) [private]
void MoveLookController::Initialize ( _In_ Windows::UI::Core::CoreWindow^ window )
void MoveLookController::Initialize ( _In_ Windows::UI::Core::CoreWindow^ window )
bool MoveLookController::IsFiring ( )
bool MoveLookController::IsFiring ( )

Definition at line 94 of file MoveLookController.cpp.

{
    if (m_state == MoveLookControllerState::Active)
    {
        if (m_autoFire)
        {
            return (m_fireInUse || (m_mouseInUse && m_mouseLeftInUse) || m_xinputTriggerInUse);
        }
        else
        {
            if (m_firePressed)
            {
                m_firePressed = false;
                return true;
            }
        }
    }
    return false;
}

bool MoveLookController::IsPauseRequested ( )

Definition at line 70 of file MoveLookController.cpp.

{
    switch (m_state)
    {
    case MoveLookControllerState::Active:
        UpdateGameController();
        if (m_pausePressed)
        {
#ifdef MOVELOOKCONTROLLER_TRACE
            DebugTrace(L"IsPauseRequested == true\n");
#endif
            m_pausePressed = false;
            return true;
        }
        else
        {
            return false;
        }
    }
    return false;
}

bool MoveLookController::IsPauseRequested ( )
bool MoveLookController::IsPressComplete ( )

Definition at line 116 of file MoveLookController.cpp.

{
    switch (m_state)
    {
    case MoveLookControllerState::WaitForInput:
        UpdateGameController();
        if (m_buttonPressed)
        {
#ifdef MOVELOOKCONTROLLER_TRACE
            DebugTrace(L"IsPressComplete == true\n");
#endif
            m_buttonPressed = false;
            return true;
        }
        else
        {
            return false;
        }
        break;
    }

    return false;
}

bool MoveLookController::IsPressComplete ( )
void MoveLookController::LoadInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state ) [private]
XMFLOAT3 MoveLookController::LookDirection ( )

Definition at line 695 of file MoveLookController.cpp.

{
    XMFLOAT3 lookDirection;

    float r = cosf(m_pitch);              // In the plane.
    lookDirection.y = sinf(m_pitch);      // Vertical.
    lookDirection.z = r * cosf(m_yaw);    // Fwd-back.
    lookDirection.x = r * sinf(m_yaw);    // Left-right.

    return lookDirection;
}

DirectX::XMFLOAT3 MoveLookController::LookDirection ( )
void MoveLookController::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void MoveLookController::OnKeyUp | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [private]
void MoveLookController::OnKeyUp | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnKeyUp | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnMouseMoved | ( | _In_ Windows::Devices::Input::MouseDevice^ | mouseDevice,
 |  | _In_ Windows::Devices::Input::MouseEventArgs^ | args |
 | ) |  |  | [private]
void MoveLookController::OnMouseMoved | ( | _In_ Windows::Devices::Input::MouseDevice^ | mouseDevice,
 |  | _In_ Windows::Devices::Input::MouseEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnMouseMoved | ( | _In_ Windows::Devices::Input::MouseDevice^ | mouseDevice,
 |  | _In_ Windows::Devices::Input::MouseEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnPointerExited | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnPointerExited | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void MoveLookController::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void MoveLookController::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void MoveLookController::Pitch ( _In_ float pitch )

Definition at line 716 of file MoveLookController.cpp.

{
    m_pitch = pitch;
}

float MoveLookController::Pitch ( )

Definition at line 709 of file MoveLookController.cpp.

{
    return m_pitch;
}

void MoveLookController::Pitch ( _In_ float pitch )
float MoveLookController::Pitch ( )
void MoveLookController::ResetState ( ) [private]
void MoveLookController::ResetState ( ) [private]

Definition at line 587 of file MoveLookController.cpp.

{
    // Reset the state of the controller.
    // Disable any active pointer IDs to stop all interaction.
    m_buttonPressed = false;
    m_pausePressed = false;
    m_buttonInUse = false;
    m_moveInUse = false;
    m_lookInUse = false;
    m_fireInUse = false;
    m_mouseInUse = false;
    m_mouseLeftInUse = false;
    m_mouseRightInUse = false;
    m_movePointerID = 0;
    m_lookPointerID = 0;
    m_firePointerID = 0;
    m_mousePointerID = 0;
    m_velocity = XMFLOAT3(0.0f, 0.0f, 0.0f);

    m_xinputStartButtonInUse = false;
    m_xinputTriggerInUse = false;

    m_moveCommand = XMFLOAT3(0.0f, 0.0f, 0.0f);
    m_forward = false;
    m_back = false;
    m_left = false;
    m_right = false;
    m_up = false;
    m_down = false;
    m_pause = false;
}

void MoveLookController::SaveInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state ) [private]
void MoveLookController::SaveInternalValue | ( | _In_ Windows::Foundation::Collections::IPropertySet^ | state,
 |  | _In_ Platform::String^ | key,
 |  | _In_ Platform::Object^ | value |
 | ) |  |  | [private]
void MoveLookController::SetFireRect | ( | _In_ DirectX::XMFLOAT2 | upperLeft,
 |  | _In_ DirectX::XMFLOAT2 | lowerRight
 | ) |  |
void MoveLookController::SetFireRect | ( | _In_ DirectX::XMFLOAT2 | upperLeft,
 |  | _In_ DirectX::XMFLOAT2 | lowerRight
 | ) |  |
void MoveLookController::SetMoveRect | ( | _In_ DirectX::XMFLOAT2 | upperLeft,
 |  | _In_ DirectX::XMFLOAT2 | lowerRight
 | ) |  |
void MoveLookController::SetMoveRect | ( | _In_ DirectX::XMFLOAT2 | upperLeft,
 |  | _In_ DirectX::XMFLOAT2 | lowerRight
 | ) |  |
void MoveLookController::SetOrientation | ( | _In_ float | pitch,
 |  | _In_ float | yaw |
 | ) |  |  | [private]

Definition at line 248 of file MoveLookController.cpp.

{
    m_pitch = pitch;
    m_yaw = yaw;
}

void MoveLookController::SetPosition ( _In_ float3 pos ) [private]

Definition at line 242 of file MoveLookController.cpp.

{
    m_position = pos;
}

void MoveLookController::Update ( )

Definition at line 794 of file MoveLookController.cpp.

{
    UpdateGameController();

    if (m_moveInUse)
    {
        // Move control.
        XMFLOAT2 pointerDelta;

        pointerDelta.x = m_movePointerPosition.x - m_moveFirstDown.x;
        pointerDelta.y = m_movePointerPosition.y - m_moveFirstDown.y;

        // Figure out the command from the virtual joystick.
        XMFLOAT3 commandDirection = XMFLOAT3(0.0f, 0.0f, 0.0f);
        if (fabsf(pointerDelta.x) > 16.0f)         // Leave 32 pixel-wide dead spot for being still.
            m_moveCommand.x -= pointerDelta.x/fabsf(pointerDelta.x);

        if (fabsf(pointerDelta.y) > 16.0f)
            m_moveCommand.y -= pointerDelta.y/fabsf(pointerDelta.y);
    }

    // Poll our state bits set by the keyboard input events.
    if (m_forward)
    {
        m_moveCommand.y += 1.0f;
    }
    if (m_back)
    {
        m_moveCommand.y -= 1.0f;
    }
    if (m_left)
    {
        m_moveCommand.x += 1.0f;
    }
    if (m_right)
    {
        m_moveCommand.x -= 1.0f;
    }
    if (m_up)
    {
        m_moveCommand.z += 1.0f;
    }
    if (m_down)
    {
        m_moveCommand.z -= 1.0f;
    }

    // Make sure that 45deg cases are not faster.
    if (fabsf(m_moveCommand.x) > 0.1f ||
        fabsf(m_moveCommand.y) > 0.1f ||
        fabsf(m_moveCommand.z) > 0.1f)
    {
        XMStoreFloat3(&m_moveCommand, XMVector3Normalize(XMLoadFloat3(&m_moveCommand)));
    }

    // Rotate command to align with our direction (world coordinates).
    XMFLOAT3 wCommand;
    wCommand.x =  m_moveCommand.x * cosf(m_yaw) - m_moveCommand.y * sinf(m_yaw);
    wCommand.y =  m_moveCommand.x * sinf(m_yaw) + m_moveCommand.y * cosf(m_yaw);
    wCommand.z =  m_moveCommand.z;

    // Scale for sensitivity adjustment.
    // Our velocity is based on the command. Y is up.
    m_velocity.x = -wCommand.x * MOVEMENT_GAIN;
    m_velocity.z =  wCommand.y * MOVEMENT_GAIN;
    m_velocity.y =  wCommand.z * MOVEMENT_GAIN;

    // Clear movement input accumulator for use during next frame.
    m_moveCommand = XMFLOAT3(0.0f, 0.0f, 0.0f);
}

void MoveLookController::Update ( Windows::UI::Core::CoreWindow^ window ) [private]
void MoveLookController::Update ( )
void MoveLookController::UpdateGameController ( ) [private]
void MoveLookController::UpdateGameController ( ) [private]

Definition at line 867 of file MoveLookController.cpp.

{
    if (!m_isControllerConnected)
    {
        // Check for controller connection by trying to get the capabilties.
        DWORD capsResult = XInputGetCapabilities(0, XINPUT_FLAG_GAMEPAD, &m_xinputCaps);
        if (capsResult != ERROR_SUCCESS)
        {
            return;
        }
        // Device is connected.
        m_isControllerConnected = true;
        m_xinputStartButtonInUse = false;
        m_xinputTriggerInUse = false;
    }

    DWORD stateResult = XInputGetState(0, &m_xinputState);
    if (stateResult != ERROR_SUCCESS)
    {
        // Device is no longer connected.
        m_isControllerConnected = false;
    }

    switch (m_state)
    {
    case MoveLookControllerState::WaitForInput:
        if (m_xinputState.Gamepad.wButtons & XINPUT_GAMEPAD_START)
        {
            m_xinputStartButtonInUse = true;
        }
        else if (m_xinputStartButtonInUse)
        {
            // Trigger once only on button release.
            m_xinputStartButtonInUse = false;
            m_buttonPressed = true;
        }
        break;

    case MoveLookControllerState::Active:
        if (m_xinputState.Gamepad.wButtons & XINPUT_GAMEPAD_START)
        {
            m_xinputStartButtonInUse = true;
        }
        else if (m_xinputStartButtonInUse)
        {
            // Trigger once only on button release.
            m_xinputStartButtonInUse = false;
            m_pausePressed = true;
        }
        // Use the Left Thumb joystick on the Xbox controller to control
        // the eye point position control.
        // The controller input goes from -32767 to 32767.  We will normalize
        // this from -1 to 1 and keep a dead spot in the middle to avoid drift.

        if (m_xinputState.Gamepad.sThumbLX > XINPUT_GAMEPAD_LEFT_THUMB_DEADZONE ||
            m_xinputState.Gamepad.sThumbLX < -XINPUT_GAMEPAD_LEFT_THUMB_DEADZONE)
        {
            float x = (float)m_xinputState.Gamepad.sThumbLX/32767.0f;
            m_moveCommand.x -= x / fabsf(x);
        }

        if (m_xinputState.Gamepad.sThumbLY > XINPUT_GAMEPAD_LEFT_THUMB_DEADZONE ||
            m_xinputState.Gamepad.sThumbLY < -XINPUT_GAMEPAD_LEFT_THUMB_DEADZONE)
        {
            float y = (float)m_xinputState.Gamepad.sThumbLY/32767.0f;
            m_moveCommand.y += y / fabsf(y);
        }

        // Use the Right Thumb Joystick on the Xbox controller to control
        // the look at control.
        // The controller input goes from -32767 to 32767.  We will normalize
        // this from -1 to 1 and keep a dead spot in the middle to avoid drift.
        XMFLOAT2 pointerDelta;
        if (m_xinputState.Gamepad.sThumbRX > XINPUT_GAMEPAD_RIGHT_THUMB_DEADZONE ||
            m_xinputState.Gamepad.sThumbRX < -XINPUT_GAMEPAD_RIGHT_THUMB_DEADZONE)
        {
            pointerDelta.x = (float)m_xinputState.Gamepad.sThumbRX/32767.0f;
            pointerDelta.x = pointerDelta.x * pointerDelta.x * pointerDelta.x;
        }
        else
        {
            pointerDelta.x = 0.0f;
        }
        if (m_xinputState.Gamepad.sThumbRY > XINPUT_GAMEPAD_RIGHT_THUMB_DEADZONE ||
            m_xinputState.Gamepad.sThumbRY < -XINPUT_GAMEPAD_RIGHT_THUMB_DEADZONE)
        {
            pointerDelta.y = (float)m_xinputState.Gamepad.sThumbRY/32767.0f;
            pointerDelta.y = pointerDelta.y * pointerDelta.y * pointerDelta.y;
        }
        else
        {
            pointerDelta.y = 0.0f;
        }

        XMFLOAT2 rotationDelta;
        rotationDelta.x = pointerDelta.x *  0.08f;       // Scale for control sensitivity.
        rotationDelta.y = pointerDelta.y *  0.08f;

        // Update our orientation based on the command.
        m_pitch += rotationDelta.y;
        m_yaw   += rotationDelta.x;

        // Limit pitch to straight up or straight down.
        m_pitch = __max(-XM_PI / 2.0f, m_pitch);
        m_pitch = __min(+XM_PI / 2.0f, m_pitch);

        // Check the state of the Right Trigger button.  This is used to indicate fire control.

        if (m_xinputState.Gamepad.bRightTrigger > XINPUT_GAMEPAD_TRIGGER_THRESHOLD)
        {
            if (!m_autoFire && !m_xinputTriggerInUse)
            {
                m_firePressed = true;
            }
            m_xinputTriggerInUse = true;
        }
        else
        {
            m_xinputTriggerInUse = false;
        }
        break;
    }
}

DirectX::XMFLOAT3 MoveLookController::Velocity ( )
XMFLOAT3 MoveLookController::Velocity ( )

Definition at line 688 of file MoveLookController.cpp.

{
    return m_velocity;
}

void MoveLookController::WaitForPress | ( | _In_ DirectX::XMFLOAT2 | UpperLeft,
 |  | _In_ DirectX::XMFLOAT2 | LowerRight
 | ) |  |
void MoveLookController::WaitForPress ( )

Definition at line 669 of file MoveLookController.cpp.

{
#ifdef MOVELOOKCONTROLLER_TRACE
    DebugTrace(L"WaitForPress (null rect)\n");
#endif

    ResetState();
    m_state = MoveLookControllerState::WaitForInput;
    m_buttonUpperLeft.x = 0.0f;
    m_buttonUpperLeft.y = 0.0f;
    m_buttonLowerRight.x = 0.0f;
    m_buttonLowerRight.y = 0.0f;

    // Turn on mouse cursor.
    CoreWindow::GetForCurrentThread()->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
}

void MoveLookController::WaitForPress ( )
void MoveLookController::WaitForPress | ( | _In_ DirectX::XMFLOAT2 | UpperLeft,
 |  | _In_ DirectX::XMFLOAT2 | LowerRight
 | ) |  |
float MoveLookController::Yaw ( )
void MoveLookController::Yaw ( _In_ float yaw )
float MoveLookController::Yaw ( )

Definition at line 723 of file MoveLookController.cpp.

{
    return m_yaw;
}

void MoveLookController::Yaw ( _In_ float yaw )

Definition at line 730 of file MoveLookController.cpp.

{
    m_yaw = yaw;
}

Member Data Documentation

internal MoveLookController::__pad0__

Definition at line 87 of file MoveLookController.h.

internal _In_ Windows::UI::Core::PointerEventArgs MoveLookController::args [private]

Definition at line 53 of file MoveLookController.h.

bool MoveLookController::m_autoFire [private]

Definition at line 181 of file MoveLookController.h.

bool MoveLookController::m_back [private]

Definition at line 212 of file MoveLookController.h.

bool MoveLookController::m_buttonInUse [private]

Definition at line 196 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_buttonLowerRight [private]

Definition at line 199 of file MoveLookController.h.

uint32 MoveLookController::m_buttonPointerID [private]

Definition at line 197 of file MoveLookController.h.

bool MoveLookController::m_buttonPressed [private]

Definition at line 200 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_buttonUpperLeft [private]

Definition at line 198 of file MoveLookController.h.

bool MoveLookController::m_down [private]

Definition at line 216 of file MoveLookController.h.

bool MoveLookController::m_fireInUse [private]

Definition at line 185 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_fireLastPoint [private]

Definition at line 187 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_fireLowerRight [private]

Definition at line 184 of file MoveLookController.h.

UINT32 MoveLookController::m_firePointerID [private]

Definition at line 186 of file MoveLookController.h.

bool MoveLookController::m_firePressed [private]

Definition at line 182 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_fireUpperLeft [private]

Definition at line 183 of file MoveLookController.h.

bool MoveLookController::m_forward [private]

Definition at line 211 of file MoveLookController.h.

bool MoveLookController::m_isControllerConnected [private]

Definition at line 204 of file MoveLookController.h.

bool MoveLookController::m_left [private]

Definition at line 213 of file MoveLookController.h.

bool MoveLookController::m_lookInUse [private]

Definition at line 175 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_lookLastDelta [private]

Definition at line 178 of file MoveLookController.h.

float2 MoveLookController::m_lookLastDelta [private]

Definition at line 43 of file MoveLookController.h.

float2 MoveLookController::m_lookLastPoint [private]

Definition at line 42 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_lookLastPoint [private]

Definition at line 177 of file MoveLookController.h.

uint32 MoveLookController::m_lookPointerID [private]

Definition at line 176 of file MoveLookController.h.

bool MoveLookController::m_mouseInUse [private]

Definition at line 190 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_mouseLastPoint [private]

Definition at line 192 of file MoveLookController.h.

bool MoveLookController::m_mouseLeftInUse [private]

Definition at line 193 of file MoveLookController.h.

bool MoveLookController::m_mouseLookInUse [private]

Definition at line 46 of file MoveLookController.h.

uint32 MoveLookController::m_mouseLookPointerID [private]

Definition at line 47 of file MoveLookController.h.

uint32 MoveLookController::m_mousePointerID [private]

Definition at line 191 of file MoveLookController.h.

bool MoveLookController::m_mouseRightInUse [private]

Definition at line 194 of file MoveLookController.h.

DirectX::XMFLOAT3 MoveLookController::m_moveCommand [private]

Definition at line 172 of file MoveLookController.h.

float3 MoveLookController::m_moveCommand [private]

Definition at line 37 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_moveFirstDown [private]

Definition at line 170 of file MoveLookController.h.

float2 MoveLookController::m_moveFirstDown [private]

Definition at line 35 of file MoveLookController.h.

bool MoveLookController::m_moveInUse [private]

Definition at line 168 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_moveLowerRight [private]

Definition at line 167 of file MoveLookController.h.

uint32 MoveLookController::m_movePointerID [private]

Definition at line 169 of file MoveLookController.h.

float2 MoveLookController::m_movePointerPosition [private]

Definition at line 36 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_movePointerPosition [private]

Definition at line 171 of file MoveLookController.h.

DirectX::XMFLOAT2 MoveLookController::m_moveUpperLeft [private]

Definition at line 166 of file MoveLookController.h.

bool MoveLookController::m_pause [private]

Definition at line 217 of file MoveLookController.h.

bool MoveLookController::m_pausePressed [private]

Definition at line 201 of file MoveLookController.h.

float MoveLookController::m_pitch [private]

Definition at line 162 of file MoveLookController.h.

float3 MoveLookController::m_position [private]

Definition at line 29 of file MoveLookController.h.

bool MoveLookController::m_right [private]

Definition at line 214 of file MoveLookController.h.

MoveLookControllerState MoveLookController::m_state [private]

Definition at line 160 of file MoveLookController.h.

bool MoveLookController::m_up [private]

Definition at line 215 of file MoveLookController.h.

DirectX::XMFLOAT3 MoveLookController::m_velocity [private]

Definition at line 161 of file MoveLookController.h.

XINPUT_CAPABILITIES MoveLookController::m_xinputCaps [private]

Definition at line 205 of file MoveLookController.h.

bool MoveLookController::m_xinputStartButtonInUse [private]

Definition at line 207 of file MoveLookController.h.

XINPUT_STATE MoveLookController::m_xinputState [private]

Definition at line 206 of file MoveLookController.h.

bool MoveLookController::m_xinputTriggerInUse [private]

Definition at line 208 of file MoveLookController.h.

float MoveLookController::m_yaw [private]

Definition at line 163 of file MoveLookController.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/MoveLookController.h
  • DirectX touch input/C++/MoveLookController.h
  • XAML DirectX 3D shooting game/C++/MoveLookController.h
  • DirectX 3D shooting game/C++/MoveLookController.cpp
  • DirectX touch input/C++/MoveLookController.cpp
  • XAML DirectX 3D shooting game/C++/MoveLookController.cpp
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MPEG1AudioFrameHeader Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

MPEG1AudioFrameHeader Struct Reference

#include "Parse.h"

List of all members.

Public Attributes

DWORD | dwBitRate
DWORD | dwSamplesPerSec
BYTE | emphasis
MPEG1AudioLayer layer
MPEG1AudioMode mode
BYTE | modeExtension
WORD | nBlockAlign
WORD | nChannels
WORD | wFlags

Detailed Description

Definition at line 158 of file Parse.h.

Member Data Documentation

DWORD MPEG1AudioFrameHeader::dwBitRate

Definition at line 161 of file Parse.h.

DWORD MPEG1AudioFrameHeader::dwSamplesPerSec

Definition at line 162 of file Parse.h.

BYTE MPEG1AudioFrameHeader::emphasis

Definition at line 167 of file Parse.h.

MPEG1AudioLayer MPEG1AudioFrameHeader::layer

Definition at line 160 of file Parse.h.

MPEG1AudioMode MPEG1AudioFrameHeader::mode

Definition at line 165 of file Parse.h.

BYTE MPEG1AudioFrameHeader::modeExtension

Definition at line 166 of file Parse.h.

WORD MPEG1AudioFrameHeader::nBlockAlign

Definition at line 163 of file Parse.h.

WORD MPEG1AudioFrameHeader::nChannels

Definition at line 164 of file Parse.h.

WORD MPEG1AudioFrameHeader::wFlags

Definition at line 168 of file Parse.h.

The documentation for this struct was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MPEG1PacketHeader Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

MPEG1PacketHeader Struct Reference

#include "Parse.h"

List of all members.

Public Attributes

BOOL | bHasPTS
DWORD | cbPacketSize
DWORD | cbPayload
BYTE | number
LONGLONG | PTS
BYTE | stream_id
StreamType type

Detailed Description

Definition at line 103 of file Parse.h.

Member Data Documentation

BOOL MPEG1PacketHeader::bHasPTS

Definition at line 110 of file Parse.h.

DWORD MPEG1PacketHeader::cbPacketSize

Definition at line 108 of file Parse.h.

DWORD MPEG1PacketHeader::cbPayload

Definition at line 109 of file Parse.h.

BYTE MPEG1PacketHeader::number

Definition at line 107 of file Parse.h.

LONGLONG MPEG1PacketHeader::PTS

Definition at line 111 of file Parse.h.

BYTE MPEG1PacketHeader::stream_id

Definition at line 105 of file Parse.h.

StreamType MPEG1PacketHeader::type

Definition at line 106 of file Parse.h.

The documentation for this struct was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MPEG1StreamHeader Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

MPEG1StreamHeader Struct Reference

#include "Parse.h"

List of all members.

Public Attributes

BYTE | number
DWORD | sizeBound
BYTE | stream_id
StreamType type

Detailed Description

Definition at line 78 of file Parse.h.

Member Data Documentation

BYTE MPEG1StreamHeader::number

Definition at line 82 of file Parse.h.

DWORD MPEG1StreamHeader::sizeBound

Definition at line 83 of file Parse.h.

BYTE MPEG1StreamHeader::stream_id

Definition at line 80 of file Parse.h.

StreamType MPEG1StreamHeader::type

Definition at line 81 of file Parse.h.

The documentation for this struct was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MPEG1SystemHeader Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

MPEG1SystemHeader Struct Reference

#include "Parse.h"

List of all members.

Public Attributes

BOOL | bAudioLock
BOOL | bCSPS
BOOL | bFixed
BOOL | bVideoLock
BYTE | cAudioBound
DWORD | cbSize
DWORD | cStreams
BYTE | cVideoBound
DWORD | rateBound
MPEG1StreamHeader | streams [1]

Detailed Description

Definition at line 89 of file Parse.h.

Member Data Documentation

BOOL MPEG1SystemHeader::bAudioLock

Definition at line 96 of file Parse.h.

BOOL MPEG1SystemHeader::bCSPS

Definition at line 95 of file Parse.h.

BOOL MPEG1SystemHeader::bFixed

Definition at line 94 of file Parse.h.

BOOL MPEG1SystemHeader::bVideoLock

Definition at line 97 of file Parse.h.

BYTE MPEG1SystemHeader::cAudioBound

Definition at line 93 of file Parse.h.

DWORD MPEG1SystemHeader::cbSize

Definition at line 91 of file Parse.h.

DWORD MPEG1SystemHeader::cStreams

Definition at line 99 of file Parse.h.

BYTE MPEG1SystemHeader::cVideoBound

Definition at line 98 of file Parse.h.

DWORD MPEG1SystemHeader::rateBound

Definition at line 92 of file Parse.h.

MPEG1StreamHeader MPEG1SystemHeader::streams

Definition at line 100 of file Parse.h.

The documentation for this struct was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MPEG1VideoSeqHeader Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

MPEG1VideoSeqHeader Struct Reference

#include "Parse.h"

List of all members.

Public Attributes

BOOL | bConstrained
DWORD | bitRate
DWORD | cbHeader
WORD | cbVBV_Buffer
MFRatio | frameRate
BYTE | header [MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE]
WORD | height
MFRatio | pixelAspectRatio
WORD | width

Detailed Description

Definition at line 116 of file Parse.h.

Member Data Documentation

BOOL MPEG1VideoSeqHeader::bConstrained

Definition at line 124 of file Parse.h.

DWORD MPEG1VideoSeqHeader::bitRate

Definition at line 122 of file Parse.h.

DWORD MPEG1VideoSeqHeader::cbHeader

Definition at line 125 of file Parse.h.

WORD MPEG1VideoSeqHeader::cbVBV_Buffer

Definition at line 123 of file Parse.h.

MFRatio MPEG1VideoSeqHeader::frameRate

Definition at line 121 of file Parse.h.

BYTE MPEG1VideoSeqHeader::header

Definition at line 126 of file Parse.h.

WORD MPEG1VideoSeqHeader::height

Definition at line 119 of file Parse.h.

MFRatio MPEG1VideoSeqHeader::pixelAspectRatio

Definition at line 120 of file Parse.h.

WORD MPEG1VideoSeqHeader::width

Definition at line 118 of file Parse.h.

The documentation for this struct was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NetworkStatusTask::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NetworkStatusTask
  • NetworkStatusTask::sealed
Public Member Functions | Private Member Functions

NetworkStatusTask::sealed Class Reference

#include "BackgroundTask.h"

List of all members.

Public Member Functions

BackgroundTask ()
void | OnCanceled (IBackgroundTaskInstance^taskInstance, BackgroundTaskCancellationReason reason)
virtual void | Run (IBackgroundTaskInstance^taskInstance)

Private Member Functions

~BackgroundTask ()

Detailed Description

Definition at line 10 of file BackgroundTask.h.

Constructor & Destructor Documentation

NetworkStatusTask::sealed::~BackgroundTask ( ) [private]

Member Function Documentation

NetworkStatusTask::sealed::BackgroundTask ( )
void NetworkStatusTask::sealed::OnCanceled | ( | IBackgroundTaskInstance^ | taskInstance,
 |  | BackgroundTaskCancellationReason | reason
 | ) |  |
virtual void NetworkStatusTask::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
The documentation for this class was generated from the following file:
  • Network status background/C++/NetworkStatusTask/BackgroundTask.h
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NoOp< T > Struct Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

NoOp< T > Struct Template Reference

#include "LinkList.h"

List of all members.

Public Member Functions

void | operator() (T &t)
void | operator() (T &t)
void | operator() (T &t)

Detailed Description

template<class T>
struct NoOp< T >

Definition at line 37 of file LinkList.h.

Member Function Documentation

template<class T>
void NoOp< T >::operator() ( T & t ) [inline]

Definition at line 39 of file LinkList.h.

    {
    }

template<class T>
void NoOp< T >::operator() ( T & t ) [inline]

Definition at line 39 of file LinkList.h.

    {
    }

template<class T>
void NoOp< T >::operator() ( T & t ) [inline]

Definition at line 39 of file LinkList.h.

    {
    }

The documentation for this struct was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/LinkList.h
  • Media extensions/C++/MediaExtensions/Common/LinkList.h
  • Real-time communication/C++/MediaExtensions/Common/LinkList.h
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • BadgeContent
  • NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
Public Member Functions | Properties | Private Attributes

NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent Class Reference

Notification content object to display a glyph on a tile's badge.

List of all members.

Public Member Functions

BadgeGlyphNotificationContent ()
BadgeGlyphNotificationContent (GlyphValue glyph)
BadgeGlyphNotificationContent (GlyphValue glyph)
BadgeGlyphNotificationContent ()
BadgeNotification | CreateNotification ()
BadgeNotification | CreateNotification ()
string | GetContent ()
string | GetContent ()
XmlDocument | GetXml ()
XmlDocument | GetXml ()
override string | ToString ()
override string | ToString ()

Properties

GlyphValue | Glyph [get, set]

Private Attributes

GlyphValue | m_Glyph = (GlyphValue)(-1)

Detailed Description

Definition at line 19 of file BadgeContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::BadgeGlyphNotificationContent ( ) [inline]

Default constructor to create a glyph badge content object.

Definition at line 24 of file BadgeContent.cs.

        {
        }

NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::BadgeGlyphNotificationContent ( GlyphValue glyph ) [inline]

Constructor to create a glyph badge content object with a glyph.

Parameters:
glyph The glyph to be displayed on the badge.

Definition at line 32 of file BadgeContent.cs.

        {
            m_Glyph = glyph;
        }

NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::BadgeGlyphNotificationContent ( ) [inline]

Default constructor to create a glyph badge content object.

Definition at line 24 of file BadgeContent.cs.

        {
        }

NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::BadgeGlyphNotificationContent ( GlyphValue glyph ) [inline]

Constructor to create a glyph badge content object with a glyph.

Parameters:
glyph The glyph to be displayed on the badge.

Definition at line 32 of file BadgeContent.cs.

        {
            m_Glyph = glyph;
        }

Member Function Documentation

BadgeNotification NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::CreateNotification ( ) [inline]

Creates a WinRT BadgeNotification object based on the content.

Returns:
A WinRT BadgeNotification object based on the content.

Definition at line 95 of file BadgeContent.cs.

        {
            XmlDocument xmlDoc = new XmlDocument();
            xmlDoc.LoadXml(GetContent());
            return new BadgeNotification(xmlDoc);
        }

BadgeNotification NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::CreateNotification ( ) [inline]

Creates a WinRT BadgeNotification object based on the content.

Returns:
A WinRT BadgeNotification object based on the content.

Definition at line 95 of file BadgeContent.cs.

        {
            XmlDocument xmlDoc = new XmlDocument();
            xmlDoc.LoadXml(GetContent());
            return new BadgeNotification(xmlDoc);
        }

string NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::GetContent ( ) [inline]

Retrieves the notification Xml content as a string.

Returns:
The notification Xml content as a string.

Definition at line 57 of file BadgeContent.cs.

        {
            if (!Enum.IsDefined(typeof(GlyphValue), m_Glyph))
            {
                throw new NotificationContentValidationException("The badge glyph property was left unset.");
            }

            string glyphString = m_Glyph.ToString();
            // lower case the first character of the enum value to match the Xml schema
            glyphString = String.Format("{0}{1}", Char.ToLowerInvariant(glyphString[0]), glyphString.Substring(1));
            return String.Format("<badge version='{0}' value='{1}'/>", Util.NOTIFICATION_CONTENT_VERSION, glyphString);
        }

string NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::GetContent ( ) [inline]

Retrieves the notification Xml content as a string.

Returns:
The notification Xml content as a string.

Definition at line 57 of file BadgeContent.cs.

        {
            if (!Enum.IsDefined(typeof(GlyphValue), m_Glyph))
            {
                throw new NotificationContentValidationException("The badge glyph property was left unset.");
            }

            string glyphString = m_Glyph.ToString();
            // lower case the first character of the enum value to match the Xml schema
            glyphString = String.Format("{0}{1}", Char.ToLowerInvariant(glyphString[0]), glyphString.Substring(1));
            return String.Format("<badge version='{0}' value='{1}'/>", Util.NOTIFICATION_CONTENT_VERSION, glyphString);
        }

XmlDocument NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::GetXml ( ) [inline]

Retrieves the notification Xml content as a WinRT Xml document.

Returns:
The notification Xml content as a WinRT Xml document.

Definition at line 84 of file BadgeContent.cs.

        {
            XmlDocument xml = new XmlDocument();
            xml.LoadXml(GetContent());
            return xml;
        }

XmlDocument NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::GetXml ( ) [inline]

Retrieves the notification Xml content as a WinRT Xml document.

Returns:
The notification Xml content as a WinRT Xml document.

Definition at line 84 of file BadgeContent.cs.

        {
            XmlDocument xml = new XmlDocument();
            xml.LoadXml(GetContent());
            return xml;
        }

override string NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::ToString ( ) [inline]

Retrieves the notification Xml content as a string.

Returns:
The notification Xml content as a string.

Definition at line 74 of file BadgeContent.cs.

        {
            return GetContent();
        }

override string NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::ToString ( ) [inline]

Retrieves the notification Xml content as a string.

Returns:
The notification Xml content as a string.

Definition at line 74 of file BadgeContent.cs.

        {
            return GetContent();
        }

Member Data Documentation

GlyphValue NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::m_Glyph = (GlyphValue)(-1) [private]

Definition at line 103 of file BadgeContent.cs.

Property Documentation

GlyphValue NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent::Glyph [get, set]

The glyph to be displayed on the badge.

Definition at line 41 of file BadgeContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/BadgeContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/BadgeContent.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • BadgeContent
  • NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
Public Member Functions | Properties | Private Attributes

NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent Class Reference

Notification content object to display a number on a tile's badge.

List of all members.

Public Member Functions

BadgeNumericNotificationContent ()
BadgeNumericNotificationContent (uint number)
BadgeNumericNotificationContent (uint number)
BadgeNumericNotificationContent ()
BadgeNotification | CreateNotification ()
BadgeNotification | CreateNotification ()
string | GetContent ()
string | GetContent ()
XmlDocument | GetXml ()
XmlDocument | GetXml ()
override string | ToString ()
override string | ToString ()

Properties

uint | Number [get, set]

Private Attributes

uint | m_Number = 0

Detailed Description

Definition at line 109 of file BadgeContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::BadgeNumericNotificationContent ( ) [inline]

Default constructor to create a numeric badge content object.

Definition at line 114 of file BadgeContent.cs.

        {
        }

NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::BadgeNumericNotificationContent ( uint number ) [inline]

Constructor to create a numeric badge content object with a number.

Parameters:
number The number that will appear on the badge. If the number is 0, the badge will be removed. The largest value that will appear on the badge is 99. Numbers greater than 99 are allowed, but will be displayed as "99+".

Definition at line 126 of file BadgeContent.cs.

        {
            m_Number = number;
        }

NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::BadgeNumericNotificationContent ( ) [inline]

Default constructor to create a numeric badge content object.

Definition at line 114 of file BadgeContent.cs.

        {
        }

NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::BadgeNumericNotificationContent ( uint number ) [inline]

Constructor to create a numeric badge content object with a number.

Parameters:
number The number that will appear on the badge. If the number is 0, the badge will be removed. The largest value that will appear on the badge is 99. Numbers greater than 99 are allowed, but will be displayed as "99+".

Definition at line 126 of file BadgeContent.cs.

        {
            m_Number = number;
        }

Member Function Documentation

BadgeNotification NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::CreateNotification ( ) [inline]

Creates a WinRT BadgeNotification object based on the content.

Returns:
A WinRT BadgeNotification object based on the content.

Definition at line 176 of file BadgeContent.cs.

        {
            XmlDocument xmlDoc = new XmlDocument();
            xmlDoc.LoadXml(GetContent());
            return new BadgeNotification(xmlDoc);
        }

BadgeNotification NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::CreateNotification ( ) [inline]

Creates a WinRT BadgeNotification object based on the content.

Returns:
A WinRT BadgeNotification object based on the content.

Definition at line 176 of file BadgeContent.cs.

        {
            XmlDocument xmlDoc = new XmlDocument();
            xmlDoc.LoadXml(GetContent());
            return new BadgeNotification(xmlDoc);
        }

string NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::GetContent ( ) [inline]

Retrieves the notification Xml content as a string.

Returns:
The notification Xml content as a string.

Definition at line 146 of file BadgeContent.cs.

        {
            return String.Format("<badge version='{0}' value='{1}'/>", Util.NOTIFICATION_CONTENT_VERSION, m_Number);
        }

string NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::GetContent ( ) [inline]

Retrieves the notification Xml content as a string.

Returns:
The notification Xml content as a string.

Definition at line 146 of file BadgeContent.cs.

        {
            return String.Format("<badge version='{0}' value='{1}'/>", Util.NOTIFICATION_CONTENT_VERSION, m_Number);
        }

XmlDocument NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::GetXml ( ) [inline]

Retrieves the notification Xml content as a WinRT Xml document.

Returns:
The notification Xml content as a WinRT Xml document.

Definition at line 165 of file BadgeContent.cs.

        {
            XmlDocument xml = new XmlDocument();
            xml.LoadXml(GetContent());
            return xml;
        }

XmlDocument NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::GetXml ( ) [inline]

Retrieves the notification Xml content as a WinRT Xml document.

Returns:
The notification Xml content as a WinRT Xml document.

Definition at line 165 of file BadgeContent.cs.

        {
            XmlDocument xml = new XmlDocument();
            xml.LoadXml(GetContent());
            return xml;
        }

override string NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::ToString ( ) [inline]

Retrieves the notification Xml content as a string.

Returns:
The notification Xml content as a string.

Definition at line 155 of file BadgeContent.cs.

        {
            return GetContent();
        }

override string NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::ToString ( ) [inline]

Retrieves the notification Xml content as a string.

Returns:
The notification Xml content as a string.

Definition at line 155 of file BadgeContent.cs.

        {
            return GetContent();
        }

Member Data Documentation

uint NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::m_Number = 0 [private]

Definition at line 184 of file BadgeContent.cs.

Property Documentation

uint NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent::Number [get, set]

The number that will appear on the badge.

If the number is 0, the badge will be removed. The largest value that will appear on the badge is 99. Numbers greater than 99 are allowed, but will be displayed as "99+".

Definition at line 137 of file BadgeContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/BadgeContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/BadgeContent.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::NotificationBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • NotificationsExtensions::NotificationBase
Public Member Functions | Protected Member Functions | Properties | Private Attributes

NotificationsExtensions::NotificationBase Class Reference

Base class for the notification content creation helper classes.

Inherited by NotificationsExtensions::TileContent::TileNotificationBase, NotificationsExtensions::TileContent::TileNotificationBase, NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

abstract string | GetContent ()
abstract string | GetContent ()
abstract string | GetContent ()
abstract string | GetContent ()
XmlDocument | GetXml ()
XmlDocument | GetXml ()
XmlDocument | GetXml ()
XmlDocument | GetXml ()
override string | ToString ()
override string | ToString ()
override string | ToString ()
override string | ToString ()

Protected Member Functions

NotificationBase (string templateName, int imageCount, int textCount)
NotificationBase (string templateName, int imageCount, int textCount)
NotificationBase (string templateName, int imageCount, int textCount)
NotificationBase (string templateName, int imageCount, int textCount)
string | SerializeProperties (string globalLang, string globalBaseUri, bool globalAddImageQuery)
string | SerializeProperties (string globalLang, string globalBaseUri, bool globalAddImageQuery)
string | SerializeProperties (string globalLang, string globalBaseUri, bool globalAddImageQuery)
string | SerializeProperties (string globalLang, string globalBaseUri, bool globalAddImageQuery)

Properties

bool | AddImageQuery [get, set]
bool | AddImageQueryNullable [get, set]
string | BaseUri [get, set]
INotificationContentImage[] | Images [get]
string | Lang [get, set]
bool | StrictValidation [get, set]
string | TemplateName [get]
INotificationContentText[] | TextFields [get]

Private Attributes

bool | m_AddImageQueryNullable
string | m_BaseUri
NotificationContentImage[] m_Images
string | m_Lang
bool | m_StrictValidation = true
string | m_TemplateName
INotificationContentText[] | m_TextFields

Detailed Description

Definition at line 95 of file Common.cs.

Constructor & Destructor Documentation

NotificationsExtensions::NotificationBase::NotificationBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline, protected]

Definition at line 100 of file Common.cs.

        {
            m_TemplateName = templateName;

            m_Images = new NotificationContentImage[imageCount];
            for (int i = 0; i < m_Images.Length; i++)
            {
                m_Images[i] = new NotificationContentImage();
            }

            m_TextFields = new INotificationContentText[textCount];
            for (int i = 0; i < m_TextFields.Length; i++)
            {
                m_TextFields[i] = new NotificationContentText();
            }
        }

NotificationsExtensions::NotificationBase::NotificationBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline, protected]

Definition at line 100 of file Common.cs.

        {
            m_TemplateName = templateName;

            m_Images = new NotificationContentImage[imageCount];
            for (int i = 0; i < m_Images.Length; i++)
            {
                m_Images[i] = new NotificationContentImage();
            }

            m_TextFields = new INotificationContentText[textCount];
            for (int i = 0; i < m_TextFields.Length; i++)
            {
                m_TextFields[i] = new NotificationContentText();
            }
        }

NotificationsExtensions::NotificationBase::NotificationBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline, protected]

Definition at line 100 of file Common.cs.

        {
            m_TemplateName = templateName;

            m_Images = new NotificationContentImage[imageCount];
            for (int i = 0; i < m_Images.Length; i++)
            {
                m_Images[i] = new NotificationContentImage();
            }

            m_TextFields = new INotificationContentText[textCount];
            for (int i = 0; i < m_TextFields.Length; i++)
            {
                m_TextFields[i] = new NotificationContentText();
            }
        }

NotificationsExtensions::NotificationBase::NotificationBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline, protected]

Definition at line 100 of file Common.cs.

        {
            m_TemplateName = templateName;

            m_Images = new NotificationContentImage[imageCount];
            for (int i = 0; i < m_Images.Length; i++)
            {
                m_Images[i] = new NotificationContentImage();
            }

            m_TextFields = new INotificationContentText[textCount];
            for (int i = 0; i < m_TextFields.Length; i++)
            {
                m_TextFields[i] = new NotificationContentText();
            }
        }

Member Function Documentation

abstract string NotificationsExtensions::NotificationBase::GetContent ( ) [pure virtual]

Implemented in NotificationsExtensions::TileContent::TileWideBase, NotificationsExtensions::ToastContent::ToastNotificationBase, NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

abstract string NotificationsExtensions::NotificationBase::GetContent ( ) [pure virtual]

Implemented in NotificationsExtensions::TileContent::TileWideBase, NotificationsExtensions::ToastContent::ToastNotificationBase, NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

abstract string NotificationsExtensions::NotificationBase::GetContent ( ) [pure virtual]

Implemented in NotificationsExtensions::TileContent::TileWideBase, NotificationsExtensions::ToastContent::ToastNotificationBase, NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

abstract string NotificationsExtensions::NotificationBase::GetContent ( ) [pure virtual]

Implemented in NotificationsExtensions::TileContent::TileWideBase, NotificationsExtensions::ToastContent::ToastNotificationBase, NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

XmlDocument NotificationsExtensions::NotificationBase::GetXml ( ) [inline]

Definition at line 130 of file Common.cs.

        {
            XmlDocument xml = new XmlDocument();
            xml.LoadXml(GetContent());
            return xml;
        }

XmlDocument NotificationsExtensions::NotificationBase::GetXml ( ) [inline]

Definition at line 130 of file Common.cs.

        {
            XmlDocument xml = new XmlDocument();
            xml.LoadXml(GetContent());
            return xml;
        }

XmlDocument NotificationsExtensions::NotificationBase::GetXml ( ) [inline]

Definition at line 130 of file Common.cs.

        {
            XmlDocument xml = new XmlDocument();
            xml.LoadXml(GetContent());
            return xml;
        }

XmlDocument NotificationsExtensions::NotificationBase::GetXml ( ) [inline]

Definition at line 130 of file Common.cs.

        {
            XmlDocument xml = new XmlDocument();
            xml.LoadXml(GetContent());
            return xml;
        }

string NotificationsExtensions::NotificationBase::SerializeProperties | ( | string | globalLang,
 |  | string | globalBaseUri,
 |  | bool | globalAddImageQuery |
 | ) |  |  | [inline, protected]

Definition at line 215 of file Common.cs.

        {
            globalLang = (globalLang != null) ? globalLang : String.Empty;
            globalBaseUri = String.IsNullOrWhiteSpace(globalBaseUri) ? null : globalBaseUri;

            StringBuilder builder = new StringBuilder(String.Empty);
            for (int i = 0; i < m_Images.Length; i++)
            {
                if (!String.IsNullOrEmpty(m_Images[i].Src))
                {
                    string escapedSrc = Util.HttpEncode(m_Images[i].Src);
                    if (!String.IsNullOrWhiteSpace(m_Images[i].Alt))
                    {
                        string escapedAlt = Util.HttpEncode(m_Images[i].Alt);
                        if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
                        {
                            builder.AppendFormat("<image id='{0}' src='{1}' alt='{2}'/>", i + 1, escapedSrc, escapedAlt);
                        }
                        else
                        {
                            builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}' alt='{3}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc, escapedAlt);
                        }
                    }
                    else
                    {
                        if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
                        {
                            builder.AppendFormat("<image id='{0}' src='{1}'/>", i + 1, escapedSrc);
                        }
                        else
                        {
                            builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc);
                        }
                    }
                }
            }

            for (int i = 0; i < m_TextFields.Length; i++)
            {
                if (!String.IsNullOrWhiteSpace(m_TextFields[i].Text))
                {
                    string escapedValue = Util.HttpEncode(m_TextFields[i].Text);
                    if (!String.IsNullOrWhiteSpace(m_TextFields[i].Lang) && !m_TextFields[i].Lang.Equals(globalLang))
                    {
                        string escapedLang = Util.HttpEncode(m_TextFields[i].Lang);
                        builder.AppendFormat("<text id='{0}' lang='{1}'>{2}</text>", i + 1, escapedLang, escapedValue);
                    }
                    else
                    {
                        builder.AppendFormat("<text id='{0}'>{1}</text>", i + 1, escapedValue);
                    }
                }
            }

            return builder.ToString();
        }

string NotificationsExtensions::NotificationBase::SerializeProperties | ( | string | globalLang,
 |  | string | globalBaseUri,
 |  | bool | globalAddImageQuery |
 | ) |  |  | [inline, protected]

Definition at line 215 of file Common.cs.

        {
            globalLang = (globalLang != null) ? globalLang : String.Empty;
            globalBaseUri = String.IsNullOrWhiteSpace(globalBaseUri) ? null : globalBaseUri;

            StringBuilder builder = new StringBuilder(String.Empty);
            for (int i = 0; i < m_Images.Length; i++)
            {
                if (!String.IsNullOrEmpty(m_Images[i].Src))
                {
                    string escapedSrc = Util.HttpEncode(m_Images[i].Src);
                    if (!String.IsNullOrWhiteSpace(m_Images[i].Alt))
                    {
                        string escapedAlt = Util.HttpEncode(m_Images[i].Alt);
                        if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
                        {
                            builder.AppendFormat("<image id='{0}' src='{1}' alt='{2}'/>", i + 1, escapedSrc, escapedAlt);
                        }
                        else
                        {
                            builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}' alt='{3}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc, escapedAlt);
                        }
                    }
                    else
                    {
                        if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
                        {
                            builder.AppendFormat("<image id='{0}' src='{1}'/>", i + 1, escapedSrc);
                        }
                        else
                        {
                            builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc);
                        }
                    }
                }
            }

            for (int i = 0; i < m_TextFields.Length; i++)
            {
                if (!String.IsNullOrWhiteSpace(m_TextFields[i].Text))
                {
                    string escapedValue = Util.HttpEncode(m_TextFields[i].Text);
                    if (!String.IsNullOrWhiteSpace(m_TextFields[i].Lang) && !m_TextFields[i].Lang.Equals(globalLang))
                    {
                        string escapedLang = Util.HttpEncode(m_TextFields[i].Lang);
                        builder.AppendFormat("<text id='{0}' lang='{1}'>{2}</text>", i + 1, escapedLang, escapedValue);
                    }
                    else
                    {
                        builder.AppendFormat("<text id='{0}'>{1}</text>", i + 1, escapedValue);
                    }
                }
            }

            return builder.ToString();
        }

string NotificationsExtensions::NotificationBase::SerializeProperties | ( | string | globalLang,
 |  | string | globalBaseUri,
 |  | bool | globalAddImageQuery |
 | ) |  |  | [inline, protected]

Definition at line 215 of file Common.cs.

        {
            globalLang = (globalLang != null) ? globalLang : String.Empty;
            globalBaseUri = String.IsNullOrWhiteSpace(globalBaseUri) ? null : globalBaseUri;

            StringBuilder builder = new StringBuilder(String.Empty);
            for (int i = 0; i < m_Images.Length; i++)
            {
                if (!String.IsNullOrEmpty(m_Images[i].Src))
                {
                    string escapedSrc = Util.HttpEncode(m_Images[i].Src);
                    if (!String.IsNullOrWhiteSpace(m_Images[i].Alt))
                    {
                        string escapedAlt = Util.HttpEncode(m_Images[i].Alt);
                        if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
                        {
                            builder.AppendFormat("<image id='{0}' src='{1}' alt='{2}'/>", i + 1, escapedSrc, escapedAlt);
                        }
                        else
                        {
                            builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}' alt='{3}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc, escapedAlt);
                        }
                    }
                    else
                    {
                        if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
                        {
                            builder.AppendFormat("<image id='{0}' src='{1}'/>", i + 1, escapedSrc);
                        }
                        else
                        {
                            builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc);
                        }
                    }
                }
            }

            for (int i = 0; i < m_TextFields.Length; i++)
            {
                if (!String.IsNullOrWhiteSpace(m_TextFields[i].Text))
                {
                    string escapedValue = Util.HttpEncode(m_TextFields[i].Text);
                    if (!String.IsNullOrWhiteSpace(m_TextFields[i].Lang) && !m_TextFields[i].Lang.Equals(globalLang))
                    {
                        string escapedLang = Util.HttpEncode(m_TextFields[i].Lang);
                        builder.AppendFormat("<text id='{0}' lang='{1}'>{2}</text>", i + 1, escapedLang, escapedValue);
                    }
                    else
                    {
                        builder.AppendFormat("<text id='{0}'>{1}</text>", i + 1, escapedValue);
                    }
                }
            }

            return builder.ToString();
        }

string NotificationsExtensions::NotificationBase::SerializeProperties | ( | string | globalLang,
 |  | string | globalBaseUri,
 |  | bool | globalAddImageQuery |
 | ) |  |  | [inline, protected]

Definition at line 215 of file Common.cs.

        {
            globalLang = (globalLang != null) ? globalLang : String.Empty;
            globalBaseUri = String.IsNullOrWhiteSpace(globalBaseUri) ? null : globalBaseUri;

            StringBuilder builder = new StringBuilder(String.Empty);
            for (int i = 0; i < m_Images.Length; i++)
            {
                if (!String.IsNullOrEmpty(m_Images[i].Src))
                {
                    string escapedSrc = Util.HttpEncode(m_Images[i].Src);
                    if (!String.IsNullOrWhiteSpace(m_Images[i].Alt))
                    {
                        string escapedAlt = Util.HttpEncode(m_Images[i].Alt);
                        if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
                        {
                            builder.AppendFormat("<image id='{0}' src='{1}' alt='{2}'/>", i + 1, escapedSrc, escapedAlt);
                        }
                        else
                        {
                            builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}' alt='{3}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc, escapedAlt);
                        }
                    }
                    else
                    {
                        if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
                        {
                            builder.AppendFormat("<image id='{0}' src='{1}'/>", i + 1, escapedSrc);
                        }
                        else
                        {
                            builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc);
                        }
                    }
                }
            }

            for (int i = 0; i < m_TextFields.Length; i++)
            {
                if (!String.IsNullOrWhiteSpace(m_TextFields[i].Text))
                {
                    string escapedValue = Util.HttpEncode(m_TextFields[i].Text);
                    if (!String.IsNullOrWhiteSpace(m_TextFields[i].Lang) && !m_TextFields[i].Lang.Equals(globalLang))
                    {
                        string escapedLang = Util.HttpEncode(m_TextFields[i].Lang);
                        builder.AppendFormat("<text id='{0}' lang='{1}'>{2}</text>", i + 1, escapedLang, escapedValue);
                    }
                    else
                    {
                        builder.AppendFormat("<text id='{0}'>{1}</text>", i + 1, escapedValue);
                    }
                }
            }

            return builder.ToString();
        }

override string NotificationsExtensions::NotificationBase::ToString ( ) [inline]

Definition at line 124 of file Common.cs.

        {
            return GetContent();
        }

override string NotificationsExtensions::NotificationBase::ToString ( ) [inline]

Definition at line 124 of file Common.cs.

        {
            return GetContent();
        }

override string NotificationsExtensions::NotificationBase::ToString ( ) [inline]

Definition at line 124 of file Common.cs.

        {
            return GetContent();
        }

override string NotificationsExtensions::NotificationBase::ToString ( ) [inline]

Definition at line 124 of file Common.cs.

        {
            return GetContent();
        }

Member Data Documentation

bool NotificationsExtensions::NotificationBase::m_AddImageQueryNullable [private]

Definition at line 281 of file Common.cs.

string NotificationsExtensions::NotificationBase::m_BaseUri [private]

Definition at line 279 of file Common.cs.

NotificationContentImage [] NotificationsExtensions::NotificationBase::m_Images [private]

Definition at line 275 of file Common.cs.

string NotificationsExtensions::NotificationBase::m_Lang [private]

Definition at line 278 of file Common.cs.

bool NotificationsExtensions::NotificationBase::m_StrictValidation = true [private]

Definition at line 274 of file Common.cs.

string NotificationsExtensions::NotificationBase::m_TemplateName [private]

Definition at line 280 of file Common.cs.

INotificationContentText [] NotificationsExtensions::NotificationBase::m_TextFields [private]

Definition at line 276 of file Common.cs.

Property Documentation

bool NotificationsExtensions::NotificationBase::AddImageQuery [get, set]

Definition at line 194 of file Common.cs.

bool NotificationsExtensions::NotificationBase::AddImageQueryNullable [get, set]

Definition at line 210 of file Common.cs.

string NotificationsExtensions::NotificationBase::BaseUri [get, set]

The base Uri path that should be used for all image references in the notification.

Definition at line 158 of file Common.cs.

INotificationContentImage [] NotificationsExtensions::NotificationBase::Images [get]

Retrieves the list of images that can be manipulated on the notification content.

Definition at line 142 of file Common.cs.

string NotificationsExtensions::NotificationBase::Lang [get, set]

Definition at line 188 of file Common.cs.

bool NotificationsExtensions::NotificationBase::StrictValidation [get, set]

Definition at line 118 of file Common.cs.

string NotificationsExtensions::NotificationBase::TemplateName [get]

Definition at line 272 of file Common.cs.

INotificationContentText [] NotificationsExtensions::NotificationBase::TextFields [get]

Retrieves the list of text fields that can be manipulated on the notification content.

Definition at line 150 of file Common.cs.

The documentation for this class was generated from the following files:
  • App tiles and badges/C#,C++/NotificationsExtensions/Common.cs
  • Lock screen apps/C#,C++/NotificationsExtensions/Common.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/Common.cs
  • Toast notifications/C#,C++/NotificationsExtensions/Common.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::NotificationContentImage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • NotificationsExtensions::NotificationContentImage
Properties | Private Member Functions | Private Attributes

NotificationsExtensions::NotificationContentImage Class Reference

List of all members.

Properties

bool | AddImageQuery [get, set]
bool | AddImageQueryNullable [get, set]
string | Alt [get, set]
string | Src [get, set]

Private Member Functions

internal | NotificationContentImage ()
internal | NotificationContentImage ()
internal | NotificationContentImage ()
internal | NotificationContentImage ()

Private Attributes

bool | m_AddImageQueryNullable
string | m_Alt
string | m_Src

Detailed Description

Definition at line 38 of file Common.cs.

Constructor & Destructor Documentation

internal NotificationsExtensions::NotificationContentImage::NotificationContentImage ( ) [inline, private]

Definition at line 40 of file Common.cs.

{ }

internal NotificationsExtensions::NotificationContentImage::NotificationContentImage ( ) [inline, private]

Definition at line 40 of file Common.cs.

{ }

internal NotificationsExtensions::NotificationContentImage::NotificationContentImage ( ) [inline, private]

Definition at line 40 of file Common.cs.

{ }

internal NotificationsExtensions::NotificationContentImage::NotificationContentImage ( ) [inline, private]

Definition at line 40 of file Common.cs.

{ }

Member Data Documentation

bool NotificationsExtensions::NotificationContentImage::m_AddImageQueryNullable [private]

Definition at line 78 of file Common.cs.

string NotificationsExtensions::NotificationContentImage::m_Alt [private]

Definition at line 77 of file Common.cs.

string NotificationsExtensions::NotificationContentImage::m_Src [private]

Definition at line 76 of file Common.cs.

Property Documentation

bool NotificationsExtensions::NotificationContentImage::AddImageQuery [get, set]

Definition at line 55 of file Common.cs.

bool NotificationsExtensions::NotificationContentImage::AddImageQueryNullable [get, set]

Definition at line 71 of file Common.cs.

string NotificationsExtensions::NotificationContentImage::Alt [get, set]

Definition at line 49 of file Common.cs.

string NotificationsExtensions::NotificationContentImage::Src [get, set]

Definition at line 43 of file Common.cs.

The documentation for this class was generated from the following files:
  • App tiles and badges/C#,C++/NotificationsExtensions/Common.cs
  • Lock screen apps/C#,C++/NotificationsExtensions/Common.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/Common.cs
  • Toast notifications/C#,C++/NotificationsExtensions/Common.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::NotificationContentText Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • NotificationsExtensions::NotificationContentText
Properties | Private Member Functions | Private Attributes

NotificationsExtensions::NotificationContentText Class Reference

List of all members.

Properties

string | Lang [get, set]
string | Text [get, set]

Private Member Functions

internal | NotificationContentText ()
internal | NotificationContentText ()
internal | NotificationContentText ()
internal | NotificationContentText ()

Private Attributes

string | m_Lang
string | m_Text

Detailed Description

Definition at line 18 of file Common.cs.

Constructor & Destructor Documentation

internal NotificationsExtensions::NotificationContentText::NotificationContentText ( ) [inline, private]

Definition at line 20 of file Common.cs.

{ }

internal NotificationsExtensions::NotificationContentText::NotificationContentText ( ) [inline, private]

Definition at line 20 of file Common.cs.

{ }

internal NotificationsExtensions::NotificationContentText::NotificationContentText ( ) [inline, private]

Definition at line 20 of file Common.cs.

{ }

internal NotificationsExtensions::NotificationContentText::NotificationContentText ( ) [inline, private]

Definition at line 20 of file Common.cs.

{ }

Member Data Documentation

string NotificationsExtensions::NotificationContentText::m_Lang [private]

Definition at line 35 of file Common.cs.

string NotificationsExtensions::NotificationContentText::m_Text [private]

Definition at line 34 of file Common.cs.

Property Documentation

string NotificationsExtensions::NotificationContentText::Lang [get, set]

Definition at line 29 of file Common.cs.

string NotificationsExtensions::NotificationContentText::Text [get, set]

Definition at line 23 of file Common.cs.

The documentation for this class was generated from the following files:
  • App tiles and badges/C#,C++/NotificationsExtensions/Common.cs
  • Lock screen apps/C#,C++/NotificationsExtensions/Common.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/Common.cs
  • Toast notifications/C#,C++/NotificationsExtensions/Common.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::NotificationContentValidationException Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • NotificationsExtensions::NotificationContentValidationException
Public Member Functions

NotificationsExtensions::NotificationContentValidationException Class Reference

Exception returned when invalid notification content is provided.

List of all members.

Public Member Functions

NotificationContentValidationException (string message)
NotificationContentValidationException (string message)
NotificationContentValidationException (string message)
NotificationContentValidationException (string message)

Detailed Description

Definition at line 287 of file Common.cs.

Constructor & Destructor Documentation

NotificationsExtensions::NotificationContentValidationException::NotificationContentValidationException ( string message ) [inline]

Definition at line 289 of file Common.cs.

            : base(message, unchecked((int)0x80070057))
        {
        }

NotificationsExtensions::NotificationContentValidationException::NotificationContentValidationException ( string message ) [inline]

Definition at line 289 of file Common.cs.

            : base(message, unchecked((int)0x80070057))
        {
        }

NotificationsExtensions::NotificationContentValidationException::NotificationContentValidationException ( string message ) [inline]

Definition at line 289 of file Common.cs.

            : base(message, unchecked((int)0x80070057))
        {
        }

NotificationsExtensions::NotificationContentValidationException::NotificationContentValidationException ( string message ) [inline]

Definition at line 289 of file Common.cs.

            : base(message, unchecked((int)0x80070057))
        {
        }

The documentation for this class was generated from the following files:
  • App tiles and badges/C#,C++/NotificationsExtensions/Common.cs
  • Lock screen apps/C#,C++/NotificationsExtensions/Common.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/Common.cs
  • Toast notifications/C#,C++/NotificationsExtensions/Common.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::ISquareTileInternal Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::ISquareTileInternal
Public Member Functions

NotificationsExtensions::TileContent::ISquareTileInternal Interface Reference

Inherited by NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

string | SerializeBinding (string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery)
string | SerializeBinding (string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery)

Detailed Description

Definition at line 48 of file TileContent.cs.

Member Function Documentation

string NotificationsExtensions::TileContent::ISquareTileInternal::SerializeBinding | ( | string | globalLang,
 |  | string | globalBaseUri,
 |  | TileBranding | globalBranding,
 |  | bool | globalAddImageQuery
 | ) |  |

Implemented in NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

string NotificationsExtensions::TileContent::ISquareTileInternal::SerializeBinding | ( | string | globalLang,
 |  | string | globalBaseUri,
 |  | TileBranding | globalBranding,
 |  | bool | globalAddImageQuery
 | ) |  |

Implemented in NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

The documentation for this interface was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileContentFactory Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileContentFactory
Static Public Member Functions

NotificationsExtensions::TileContent::TileContentFactory Class Reference

A factory which creates tile content objects for all of the toast template types.

List of all members.

Static Public Member Functions

static ITileSquareBlock | CreateTileSquareBlock ()
static ITileSquareBlock | CreateTileSquareBlock ()
static ITileSquareImage | CreateTileSquareImage ()
static ITileSquareImage | CreateTileSquareImage ()
static
ITileSquarePeekImageAndText01 		CreateTileSquarePeekImageAndText01 ()
static
ITileSquarePeekImageAndText01 		CreateTileSquarePeekImageAndText01 ()
static
ITileSquarePeekImageAndText02 		CreateTileSquarePeekImageAndText02 ()
static
ITileSquarePeekImageAndText02 		CreateTileSquarePeekImageAndText02 ()
static
ITileSquarePeekImageAndText03 		CreateTileSquarePeekImageAndText03 ()
static
ITileSquarePeekImageAndText03 		CreateTileSquarePeekImageAndText03 ()
static
ITileSquarePeekImageAndText04 		CreateTileSquarePeekImageAndText04 ()
static
ITileSquarePeekImageAndText04 		CreateTileSquarePeekImageAndText04 ()
static ITileSquareText01 | CreateTileSquareText01 ()
static ITileSquareText01 | CreateTileSquareText01 ()
static ITileSquareText02 | CreateTileSquareText02 ()
static ITileSquareText02 | CreateTileSquareText02 ()
static ITileSquareText03 | CreateTileSquareText03 ()
static ITileSquareText03 | CreateTileSquareText03 ()
static ITileSquareText04 | CreateTileSquareText04 ()
static ITileSquareText04 | CreateTileSquareText04 ()
static ITileWideBlockAndText01 | CreateTileWideBlockAndText01 ()
static ITileWideBlockAndText01 | CreateTileWideBlockAndText01 ()
static ITileWideBlockAndText02 | CreateTileWideBlockAndText02 ()
static ITileWideBlockAndText02 | CreateTileWideBlockAndText02 ()
static ITileWideImage | CreateTileWideImage ()
static ITileWideImage | CreateTileWideImage ()
static ITileWideImageAndText01 | CreateTileWideImageAndText01 ()
static ITileWideImageAndText01 | CreateTileWideImageAndText01 ()
static ITileWideImageAndText02 | CreateTileWideImageAndText02 ()
static ITileWideImageAndText02 | CreateTileWideImageAndText02 ()
static ITileWideImageCollection | CreateTileWideImageCollection ()
static ITileWideImageCollection | CreateTileWideImageCollection ()
static ITileWidePeekImage01 | CreateTileWidePeekImage01 ()
static ITileWidePeekImage01 | CreateTileWidePeekImage01 ()
static ITileWidePeekImage02 | CreateTileWidePeekImage02 ()
static ITileWidePeekImage02 | CreateTileWidePeekImage02 ()
static ITileWidePeekImage03 | CreateTileWidePeekImage03 ()
static ITileWidePeekImage03 | CreateTileWidePeekImage03 ()
static ITileWidePeekImage04 | CreateTileWidePeekImage04 ()
static ITileWidePeekImage04 | CreateTileWidePeekImage04 ()
static ITileWidePeekImage05 | CreateTileWidePeekImage05 ()
static ITileWidePeekImage05 | CreateTileWidePeekImage05 ()
static ITileWidePeekImage06 | CreateTileWidePeekImage06 ()
static ITileWidePeekImage06 | CreateTileWidePeekImage06 ()
static ITileWidePeekImageAndText01 | CreateTileWidePeekImageAndText01 ()
static ITileWidePeekImageAndText01 | CreateTileWidePeekImageAndText01 ()
static ITileWidePeekImageAndText02 | CreateTileWidePeekImageAndText02 ()
static ITileWidePeekImageAndText02 | CreateTileWidePeekImageAndText02 ()
static
ITileWidePeekImageCollection01 		CreateTileWidePeekImageCollection01 ()
static
ITileWidePeekImageCollection01 		CreateTileWidePeekImageCollection01 ()
static
ITileWidePeekImageCollection02 		CreateTileWidePeekImageCollection02 ()
static
ITileWidePeekImageCollection02 		CreateTileWidePeekImageCollection02 ()
static
ITileWidePeekImageCollection03 		CreateTileWidePeekImageCollection03 ()
static
ITileWidePeekImageCollection03 		CreateTileWidePeekImageCollection03 ()
static
ITileWidePeekImageCollection04 		CreateTileWidePeekImageCollection04 ()
static
ITileWidePeekImageCollection04 		CreateTileWidePeekImageCollection04 ()
static
ITileWidePeekImageCollection05 		CreateTileWidePeekImageCollection05 ()
static
ITileWidePeekImageCollection05 		CreateTileWidePeekImageCollection05 ()
static
ITileWidePeekImageCollection06 		CreateTileWidePeekImageCollection06 ()
static
ITileWidePeekImageCollection06 		CreateTileWidePeekImageCollection06 ()
static ITileWideSmallImageAndText01 | CreateTileWideSmallImageAndText01 ()
static ITileWideSmallImageAndText01 | CreateTileWideSmallImageAndText01 ()
static ITileWideSmallImageAndText02 | CreateTileWideSmallImageAndText02 ()
static ITileWideSmallImageAndText02 | CreateTileWideSmallImageAndText02 ()
static ITileWideSmallImageAndText03 | CreateTileWideSmallImageAndText03 ()
static ITileWideSmallImageAndText03 | CreateTileWideSmallImageAndText03 ()
static ITileWideSmallImageAndText04 | CreateTileWideSmallImageAndText04 ()
static ITileWideSmallImageAndText04 | CreateTileWideSmallImageAndText04 ()
static ITileWideSmallImageAndText05 | CreateTileWideSmallImageAndText05 ()
static ITileWideSmallImageAndText05 | CreateTileWideSmallImageAndText05 ()
static ITileWideText01 | CreateTileWideText01 ()
static ITileWideText01 | CreateTileWideText01 ()
static ITileWideText02 | CreateTileWideText02 ()
static ITileWideText02 | CreateTileWideText02 ()
static ITileWideText03 | CreateTileWideText03 ()
static ITileWideText03 | CreateTileWideText03 ()
static ITileWideText04 | CreateTileWideText04 ()
static ITileWideText04 | CreateTileWideText04 ()
static ITileWideText05 | CreateTileWideText05 ()
static ITileWideText05 | CreateTileWideText05 ()
static ITileWideText06 | CreateTileWideText06 ()
static ITileWideText06 | CreateTileWideText06 ()
static ITileWideText07 | CreateTileWideText07 ()
static ITileWideText07 | CreateTileWideText07 ()
static ITileWideText08 | CreateTileWideText08 ()
static ITileWideText08 | CreateTileWideText08 ()
static ITileWideText09 | CreateTileWideText09 ()
static ITileWideText09 | CreateTileWideText09 ()
static ITileWideText10 | CreateTileWideText10 ()
static ITileWideText10 | CreateTileWideText10 ()
static ITileWideText11 | CreateTileWideText11 ()
static ITileWideText11 | CreateTileWideText11 ()

Detailed Description

Definition at line 785 of file TileContent.cs.

Member Function Documentation

static ITileSquareBlock NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareBlock ( ) [inline, static]

Creates a tile content object for the TileSquareBlock template.

Returns:
A tile content object for the TileSquareBlock template.

Definition at line 791 of file TileContent.cs.

        {
            return new TileSquareBlock();
        }

static ITileSquareBlock NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareBlock ( ) [inline, static]

Creates a tile content object for the TileSquareBlock template.

Returns:
A tile content object for the TileSquareBlock template.

Definition at line 791 of file TileContent.cs.

        {
            return new TileSquareBlock();
        }

static ITileSquareImage NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareImage ( ) [inline, static]

Creates a tile content object for the TileSquareImage template.

Returns:
A tile content object for the TileSquareImage template.

Definition at line 800 of file TileContent.cs.

        {
            return new TileSquareImage();
        }

static ITileSquareImage NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareImage ( ) [inline, static]

Creates a tile content object for the TileSquareImage template.

Returns:
A tile content object for the TileSquareImage template.

Definition at line 800 of file TileContent.cs.

        {
            return new TileSquareImage();
        }

static ITileSquarePeekImageAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquarePeekImageAndText01 ( ) [inline, static]

Creates a tile content object for the TileSquarePeekImageAndText01 template.

Returns:
A tile content object for the TileSquarePeekImageAndText01 template.

Definition at line 809 of file TileContent.cs.

        {
            return new TileSquarePeekImageAndText01();
        }

static ITileSquarePeekImageAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquarePeekImageAndText01 ( ) [inline, static]

Creates a tile content object for the TileSquarePeekImageAndText01 template.

Returns:
A tile content object for the TileSquarePeekImageAndText01 template.

Definition at line 809 of file TileContent.cs.

        {
            return new TileSquarePeekImageAndText01();
        }

static ITileSquarePeekImageAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquarePeekImageAndText02 ( ) [inline, static]

Creates a tile content object for the TileSquarePeekImageAndText02 template.

Returns:
A tile content object for the TileSquarePeekImageAndText02 template.

Definition at line 818 of file TileContent.cs.

        {
            return new TileSquarePeekImageAndText02();
        }

static ITileSquarePeekImageAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquarePeekImageAndText02 ( ) [inline, static]

Creates a tile content object for the TileSquarePeekImageAndText02 template.

Returns:
A tile content object for the TileSquarePeekImageAndText02 template.

Definition at line 818 of file TileContent.cs.

        {
            return new TileSquarePeekImageAndText02();
        }

static ITileSquarePeekImageAndText03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquarePeekImageAndText03 ( ) [inline, static]

Creates a tile content object for the TileSquarePeekImageAndText03 template.

Returns:
A tile content object for the TileSquarePeekImageAndText03 template.

Definition at line 827 of file TileContent.cs.

        {
            return new TileSquarePeekImageAndText03();
        }

static ITileSquarePeekImageAndText03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquarePeekImageAndText03 ( ) [inline, static]

Creates a tile content object for the TileSquarePeekImageAndText03 template.

Returns:
A tile content object for the TileSquarePeekImageAndText03 template.

Definition at line 827 of file TileContent.cs.

        {
            return new TileSquarePeekImageAndText03();
        }

static ITileSquarePeekImageAndText04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquarePeekImageAndText04 ( ) [inline, static]

Creates a tile content object for the TileSquarePeekImageAndText04 template.

Returns:
A tile content object for the TileSquarePeekImageAndText04 template.

Definition at line 836 of file TileContent.cs.

        {
            return new TileSquarePeekImageAndText04();
        }

static ITileSquarePeekImageAndText04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquarePeekImageAndText04 ( ) [inline, static]

Creates a tile content object for the TileSquarePeekImageAndText04 template.

Returns:
A tile content object for the TileSquarePeekImageAndText04 template.

Definition at line 836 of file TileContent.cs.

        {
            return new TileSquarePeekImageAndText04();
        }

static ITileSquareText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareText01 ( ) [inline, static]

Creates a tile content object for the TileSquareText01 template.

Returns:
A tile content object for the TileSquareText01 template.

Definition at line 845 of file TileContent.cs.

        {
            return new TileSquareText01();
        }

static ITileSquareText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareText01 ( ) [inline, static]

Creates a tile content object for the TileSquareText01 template.

Returns:
A tile content object for the TileSquareText01 template.

Definition at line 845 of file TileContent.cs.

        {
            return new TileSquareText01();
        }

static ITileSquareText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareText02 ( ) [inline, static]

Creates a tile content object for the TileSquareText02 template.

Returns:
A tile content object for the TileSquareText02 template.

Definition at line 854 of file TileContent.cs.

        {
            return new TileSquareText02();
        }

static ITileSquareText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareText02 ( ) [inline, static]

Creates a tile content object for the TileSquareText02 template.

Returns:
A tile content object for the TileSquareText02 template.

Definition at line 854 of file TileContent.cs.

        {
            return new TileSquareText02();
        }

static ITileSquareText03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareText03 ( ) [inline, static]

Creates a tile content object for the TileSquareText03 template.

Returns:
A tile content object for the TileSquareText03 template.

Definition at line 863 of file TileContent.cs.

        {
            return new TileSquareText03();
        }

static ITileSquareText03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareText03 ( ) [inline, static]

Creates a tile content object for the TileSquareText03 template.

Returns:
A tile content object for the TileSquareText03 template.

Definition at line 863 of file TileContent.cs.

        {
            return new TileSquareText03();
        }

static ITileSquareText04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareText04 ( ) [inline, static]

Creates a tile content object for the TileSquareText04 template.

Returns:
A tile content object for the TileSquareText04 template.

Definition at line 872 of file TileContent.cs.

        {
            return new TileSquareText04();
        }

static ITileSquareText04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileSquareText04 ( ) [inline, static]

Creates a tile content object for the TileSquareText04 template.

Returns:
A tile content object for the TileSquareText04 template.

Definition at line 872 of file TileContent.cs.

        {
            return new TileSquareText04();
        }

static ITileWideBlockAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideBlockAndText01 ( ) [inline, static]

Creates a tile content object for the TileWideBlockAndText01 template.

Returns:
A tile content object for the TileWideBlockAndText01 template.

Definition at line 881 of file TileContent.cs.

        {
            return new TileWideBlockAndText01();
        }

static ITileWideBlockAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideBlockAndText01 ( ) [inline, static]

Creates a tile content object for the TileWideBlockAndText01 template.

Returns:
A tile content object for the TileWideBlockAndText01 template.

Definition at line 881 of file TileContent.cs.

        {
            return new TileWideBlockAndText01();
        }

static ITileWideBlockAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideBlockAndText02 ( ) [inline, static]

Creates a tile content object for the TileWideBlockAndText02 template.

Returns:
A tile content object for the TileWideBlockAndText02 template.

Definition at line 890 of file TileContent.cs.

        {
            return new TileWideBlockAndText02();
        }

static ITileWideBlockAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideBlockAndText02 ( ) [inline, static]

Creates a tile content object for the TileWideBlockAndText02 template.

Returns:
A tile content object for the TileWideBlockAndText02 template.

Definition at line 890 of file TileContent.cs.

        {
            return new TileWideBlockAndText02();
        }

static ITileWideImage NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideImage ( ) [inline, static]

Creates a tile content object for the TileWideImage template.

Returns:
A tile content object for the TileWideImage template.

Definition at line 899 of file TileContent.cs.

        {
            return new TileWideImage();
        }

static ITileWideImage NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideImage ( ) [inline, static]

Creates a tile content object for the TileWideImage template.

Returns:
A tile content object for the TileWideImage template.

Definition at line 899 of file TileContent.cs.

        {
            return new TileWideImage();
        }

static ITileWideImageAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideImageAndText01 ( ) [inline, static]

Creates a tile content object for the TileWideImageAndText01 template.

Returns:
A tile content object for the TileWideImageAndText01 template.

Definition at line 908 of file TileContent.cs.

        {
            return new TileWideImageAndText01();
        }

static ITileWideImageAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideImageAndText01 ( ) [inline, static]

Creates a tile content object for the TileWideImageAndText01 template.

Returns:
A tile content object for the TileWideImageAndText01 template.

Definition at line 908 of file TileContent.cs.

        {
            return new TileWideImageAndText01();
        }

static ITileWideImageAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideImageAndText02 ( ) [inline, static]

Creates a tile content object for the TileWideImageAndText02 template.

Returns:
A tile content object for the TileWideImageAndText02 template.

Definition at line 917 of file TileContent.cs.

        {
            return new TileWideImageAndText02();
        }

static ITileWideImageAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideImageAndText02 ( ) [inline, static]

Creates a tile content object for the TileWideImageAndText02 template.

Returns:
A tile content object for the TileWideImageAndText02 template.

Definition at line 917 of file TileContent.cs.

        {
            return new TileWideImageAndText02();
        }

static ITileWideImageCollection NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideImageCollection ( ) [inline, static]

Creates a tile content object for the TileWideImageCollection template.

Returns:
A tile content object for the TileWideImageCollection template.

Definition at line 926 of file TileContent.cs.

        {
            return new TileWideImageCollection();
        }

static ITileWideImageCollection NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideImageCollection ( ) [inline, static]

Creates a tile content object for the TileWideImageCollection template.

Returns:
A tile content object for the TileWideImageCollection template.

Definition at line 926 of file TileContent.cs.

        {
            return new TileWideImageCollection();
        }

static ITileWidePeekImage01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage01 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage01 template.

Returns:
A tile content object for the TileWidePeekImage01 template.

Definition at line 935 of file TileContent.cs.

        {
            return new TileWidePeekImage01();
        }

static ITileWidePeekImage01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage01 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage01 template.

Returns:
A tile content object for the TileWidePeekImage01 template.

Definition at line 935 of file TileContent.cs.

        {
            return new TileWidePeekImage01();
        }

static ITileWidePeekImage02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage02 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage02 template.

Returns:
A tile content object for the TileWidePeekImage02 template.

Definition at line 944 of file TileContent.cs.

        {
            return new TileWidePeekImage02();
        }

static ITileWidePeekImage02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage02 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage02 template.

Returns:
A tile content object for the TileWidePeekImage02 template.

Definition at line 944 of file TileContent.cs.

        {
            return new TileWidePeekImage02();
        }

static ITileWidePeekImage03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage03 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage03 template.

Returns:
A tile content object for the TileWidePeekImage03 template.

Definition at line 953 of file TileContent.cs.

        {
            return new TileWidePeekImage03();
        }

static ITileWidePeekImage03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage03 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage03 template.

Returns:
A tile content object for the TileWidePeekImage03 template.

Definition at line 953 of file TileContent.cs.

        {
            return new TileWidePeekImage03();
        }

static ITileWidePeekImage04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage04 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage04 template.

Returns:
A tile content object for the TileWidePeekImage04 template.

Definition at line 962 of file TileContent.cs.

        {
            return new TileWidePeekImage04();
        }

static ITileWidePeekImage04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage04 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage04 template.

Returns:
A tile content object for the TileWidePeekImage04 template.

Definition at line 962 of file TileContent.cs.

        {
            return new TileWidePeekImage04();
        }

static ITileWidePeekImage05 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage05 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage05 template.

Returns:
A tile content object for the TileWidePeekImage05 template.

Definition at line 971 of file TileContent.cs.

        {
            return new TileWidePeekImage05();
        }

static ITileWidePeekImage05 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage05 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage05 template.

Returns:
A tile content object for the TileWidePeekImage05 template.

Definition at line 971 of file TileContent.cs.

        {
            return new TileWidePeekImage05();
        }

static ITileWidePeekImage06 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage06 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage06 template.

Returns:
A tile content object for the TileWidePeekImage06 template.

Definition at line 980 of file TileContent.cs.

        {
            return new TileWidePeekImage06();
        }

static ITileWidePeekImage06 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImage06 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImage06 template.

Returns:
A tile content object for the TileWidePeekImage06 template.

Definition at line 980 of file TileContent.cs.

        {
            return new TileWidePeekImage06();
        }

static ITileWidePeekImageAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageAndText01 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageAndText01 template.

Returns:
A tile content object for the TileWidePeekImageAndText01 template.

Definition at line 989 of file TileContent.cs.

        {
            return new TileWidePeekImageAndText01();
        }

static ITileWidePeekImageAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageAndText01 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageAndText01 template.

Returns:
A tile content object for the TileWidePeekImageAndText01 template.

Definition at line 989 of file TileContent.cs.

        {
            return new TileWidePeekImageAndText01();
        }

static ITileWidePeekImageAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageAndText02 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageAndText02 template.

Returns:
A tile content object for the TileWidePeekImageAndText02 template.

Definition at line 998 of file TileContent.cs.

        {
            return new TileWidePeekImageAndText02();
        }

static ITileWidePeekImageAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageAndText02 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageAndText02 template.

Returns:
A tile content object for the TileWidePeekImageAndText02 template.

Definition at line 998 of file TileContent.cs.

        {
            return new TileWidePeekImageAndText02();
        }

static ITileWidePeekImageCollection01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection01 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection01 template.

Returns:
A tile content object for the TileWidePeekImageCollection01 template.

Definition at line 1007 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection01();
        }

static ITileWidePeekImageCollection01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection01 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection01 template.

Returns:
A tile content object for the TileWidePeekImageCollection01 template.

Definition at line 1007 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection01();
        }

static ITileWidePeekImageCollection02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection02 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection02 template.

Returns:
A tile content object for the TileWidePeekImageCollection02 template.

Definition at line 1016 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection02();
        }

static ITileWidePeekImageCollection02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection02 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection02 template.

Returns:
A tile content object for the TileWidePeekImageCollection02 template.

Definition at line 1016 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection02();
        }

static ITileWidePeekImageCollection03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection03 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection03 template.

Returns:
A tile content object for the TileWidePeekImageCollection03 template.

Definition at line 1025 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection03();
        }

static ITileWidePeekImageCollection03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection03 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection03 template.

Returns:
A tile content object for the TileWidePeekImageCollection03 template.

Definition at line 1025 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection03();
        }

static ITileWidePeekImageCollection04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection04 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection04 template.

Returns:
A tile content object for the TileWidePeekImageCollection04 template.

Definition at line 1034 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection04();
        }

static ITileWidePeekImageCollection04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection04 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection04 template.

Returns:
A tile content object for the TileWidePeekImageCollection04 template.

Definition at line 1034 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection04();
        }

static ITileWidePeekImageCollection05 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection05 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection05 template.

Returns:
A tile content object for the TileWidePeekImageCollection05 template.

Definition at line 1043 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection05();
        }

static ITileWidePeekImageCollection05 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection05 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection05 template.

Returns:
A tile content object for the TileWidePeekImageCollection05 template.

Definition at line 1043 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection05();
        }

static ITileWidePeekImageCollection06 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection06 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection06 template.

Returns:
A tile content object for the TileWidePeekImageCollection06 template.

Definition at line 1052 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection06();
        }

static ITileWidePeekImageCollection06 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWidePeekImageCollection06 ( ) [inline, static]

Creates a tile content object for the TileWidePeekImageCollection06 template.

Returns:
A tile content object for the TileWidePeekImageCollection06 template.

Definition at line 1052 of file TileContent.cs.

        {
            return new TileWidePeekImageCollection06();
        }

static ITileWideSmallImageAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText01 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText01 template.

Returns:
A tile content object for the TileWideSmallImageAndText01 template.

Definition at line 1061 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText01();
        }

static ITileWideSmallImageAndText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText01 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText01 template.

Returns:
A tile content object for the TileWideSmallImageAndText01 template.

Definition at line 1061 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText01();
        }

static ITileWideSmallImageAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText02 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText02 template.

Returns:
A tile content object for the TileWideSmallImageAndText02 template.

Definition at line 1070 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText02();
        }

static ITileWideSmallImageAndText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText02 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText02 template.

Returns:
A tile content object for the TileWideSmallImageAndText02 template.

Definition at line 1070 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText02();
        }

static ITileWideSmallImageAndText03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText03 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText03 template.

Returns:
A tile content object for the TileWideSmallImageAndText03 template.

Definition at line 1080 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText03();
        }

static ITileWideSmallImageAndText03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText03 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText03 template.

Returns:
A tile content object for the TileWideSmallImageAndText03 template.

Definition at line 1080 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText03();
        }

static ITileWideSmallImageAndText04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText04 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText04 template.

Returns:
A tile content object for the TileWideSmallImageAndText04 template.

Definition at line 1089 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText04();
        }

static ITileWideSmallImageAndText04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText04 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText04 template.

Returns:
A tile content object for the TileWideSmallImageAndText04 template.

Definition at line 1089 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText04();
        }

static ITileWideSmallImageAndText05 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText05 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText05 template.

Returns:
A tile content object for the TileWideSmallImageAndText05 template.

Definition at line 1098 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText05();
        }

static ITileWideSmallImageAndText05 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideSmallImageAndText05 ( ) [inline, static]

Creates a tile content object for the TileWideSmallImageAndText05 template.

Returns:
A tile content object for the TileWideSmallImageAndText05 template.

Definition at line 1098 of file TileContent.cs.

        {
            return new TileWideSmallImageAndText05();
        }

static ITileWideText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText01 ( ) [inline, static]

Creates a tile content object for the TileWideText01 template.

Returns:
A tile content object for the TileWideText01 template.

Definition at line 1107 of file TileContent.cs.

        {
            return new TileWideText01();
        }

static ITileWideText01 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText01 ( ) [inline, static]

Creates a tile content object for the TileWideText01 template.

Returns:
A tile content object for the TileWideText01 template.

Definition at line 1107 of file TileContent.cs.

        {
            return new TileWideText01();
        }

static ITileWideText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText02 ( ) [inline, static]

Creates a tile content object for the TileWideText02 template.

Returns:
A tile content object for the TileWideText02 template.

Definition at line 1116 of file TileContent.cs.

        {
            return new TileWideText02();
        }

static ITileWideText02 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText02 ( ) [inline, static]

Creates a tile content object for the TileWideText02 template.

Returns:
A tile content object for the TileWideText02 template.

Definition at line 1116 of file TileContent.cs.

        {
            return new TileWideText02();
        }

static ITileWideText03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText03 ( ) [inline, static]

Creates a tile content object for the TileWideText03 template.

Returns:
A tile content object for the TileWideText03 template.

Definition at line 1125 of file TileContent.cs.

        {
            return new TileWideText03();
        }

static ITileWideText03 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText03 ( ) [inline, static]

Creates a tile content object for the TileWideText03 template.

Returns:
A tile content object for the TileWideText03 template.

Definition at line 1125 of file TileContent.cs.

        {
            return new TileWideText03();
        }

static ITileWideText04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText04 ( ) [inline, static]

Creates a tile content object for the TileWideText04 template.

Returns:
A tile content object for the TileWideText04 template.

Definition at line 1134 of file TileContent.cs.

        {
            return new TileWideText04();
        }

static ITileWideText04 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText04 ( ) [inline, static]

Creates a tile content object for the TileWideText04 template.

Returns:
A tile content object for the TileWideText04 template.

Definition at line 1134 of file TileContent.cs.

        {
            return new TileWideText04();
        }

static ITileWideText05 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText05 ( ) [inline, static]

Creates a tile content object for the TileWideText05 template.

Returns:
A tile content object for the TileWideText05 template.

Definition at line 1143 of file TileContent.cs.

        {
            return new TileWideText05();
        }

static ITileWideText05 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText05 ( ) [inline, static]

Creates a tile content object for the TileWideText05 template.

Returns:
A tile content object for the TileWideText05 template.

Definition at line 1143 of file TileContent.cs.

        {
            return new TileWideText05();
        }

static ITileWideText06 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText06 ( ) [inline, static]

Creates a tile content object for the TileWideText06 template.

Returns:
A tile content object for the TileWideText06 template.

Definition at line 1152 of file TileContent.cs.

        {
            return new TileWideText06();
        }

static ITileWideText06 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText06 ( ) [inline, static]

Creates a tile content object for the TileWideText06 template.

Returns:
A tile content object for the TileWideText06 template.

Definition at line 1152 of file TileContent.cs.

        {
            return new TileWideText06();
        }

static ITileWideText07 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText07 ( ) [inline, static]

Creates a tile content object for the TileWideText07 template.

Returns:
A tile content object for the TileWideText07 template.

Definition at line 1161 of file TileContent.cs.

        {
            return new TileWideText07();
        }

static ITileWideText07 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText07 ( ) [inline, static]

Creates a tile content object for the TileWideText07 template.

Returns:
A tile content object for the TileWideText07 template.

Definition at line 1161 of file TileContent.cs.

        {
            return new TileWideText07();
        }

static ITileWideText08 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText08 ( ) [inline, static]

Creates a tile content object for the TileWideText08 template.

Returns:
A tile content object for the TileWideText08 template.

Definition at line 1170 of file TileContent.cs.

        {
            return new TileWideText08();
        }

static ITileWideText08 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText08 ( ) [inline, static]

Creates a tile content object for the TileWideText08 template.

Returns:
A tile content object for the TileWideText08 template.

Definition at line 1170 of file TileContent.cs.

        {
            return new TileWideText08();
        }

static ITileWideText09 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText09 ( ) [inline, static]

Creates a tile content object for the TileWideText09 template.

Returns:
A tile content object for the TileWideText09 template.

Definition at line 1179 of file TileContent.cs.

        {
            return new TileWideText09();
        }

static ITileWideText09 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText09 ( ) [inline, static]

Creates a tile content object for the TileWideText09 template.

Returns:
A tile content object for the TileWideText09 template.

Definition at line 1179 of file TileContent.cs.

        {
            return new TileWideText09();
        }

static ITileWideText10 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText10 ( ) [inline, static]

Creates a tile content object for the TileWideText10 template.

Returns:
A tile content object for the TileWideText10 template.

Definition at line 1188 of file TileContent.cs.

        {
            return new TileWideText10();
        }

static ITileWideText10 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText10 ( ) [inline, static]

Creates a tile content object for the TileWideText10 template.

Returns:
A tile content object for the TileWideText10 template.

Definition at line 1188 of file TileContent.cs.

        {
            return new TileWideText10();
        }

static ITileWideText11 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText11 ( ) [inline, static]

Creates a tile content object for the TileWideText11 template.

Returns:
A tile content object for the TileWideText11 template.

Definition at line 1197 of file TileContent.cs.

        {
            return new TileWideText11();
        }

static ITileWideText11 NotificationsExtensions::TileContent::TileContentFactory::CreateTileWideText11 ( ) [inline, static]

Creates a tile content object for the TileWideText11 template.

Returns:
A tile content object for the TileWideText11 template.

Definition at line 1197 of file TileContent.cs.

        {
            return new TileWideText11();
        }

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileNotificationBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileNotificationBase
Public Member Functions | Properties | Private Attributes

NotificationsExtensions::TileContent::TileNotificationBase Class Reference

Inherits NotificationsExtensions::NotificationBase, and NotificationsExtensions::NotificationBase.

Inherited by NotificationsExtensions::TileContent::TileSquareBase, NotificationsExtensions::TileContent::TileSquareBase, NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileNotificationBase (string templateName, int imageCount, int textCount)
TileNotificationBase (string templateName, int imageCount, int textCount)
TileNotification | CreateNotification ()
TileNotification | CreateNotification ()

Properties

TileBranding | Branding [get, set]

Private Attributes

TileBranding | m_Branding = TileBranding.Logo

Detailed Description

Definition at line 17 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileNotificationBase::TileNotificationBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline]

Definition at line 19 of file TileContent.cs.

                                                                                : base(templateName, imageCount, textCount)
        {
        }

NotificationsExtensions::TileContent::TileNotificationBase::TileNotificationBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline]

Definition at line 19 of file TileContent.cs.

                                                                                : base(templateName, imageCount, textCount)
        {
        }

Member Function Documentation

TileNotification NotificationsExtensions::TileContent::TileNotificationBase::CreateNotification ( ) [inline]

Definition at line 37 of file TileContent.cs.

        {
            XmlDocument xmlDoc = new XmlDocument();
            xmlDoc.LoadXml(GetContent());
            return new TileNotification(xmlDoc);
        }

TileNotification NotificationsExtensions::TileContent::TileNotificationBase::CreateNotification ( ) [inline]

Definition at line 37 of file TileContent.cs.

        {
            XmlDocument xmlDoc = new XmlDocument();
            xmlDoc.LoadXml(GetContent());
            return new TileNotification(xmlDoc);
        }

Member Data Documentation

TileBranding NotificationsExtensions::TileContent::TileNotificationBase::m_Branding = TileBranding.Logo [private]

Definition at line 45 of file TileContent.cs.

Property Documentation

TileBranding NotificationsExtensions::TileContent::TileNotificationBase::Branding [get, set]

Definition at line 24 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquareBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquareBase
Public Member Functions

NotificationsExtensions::TileContent::TileSquareBase Class Reference

Inherits NotificationsExtensions::TileContent::TileNotificationBase, NotificationsExtensions::TileContent::ISquareTileInternal, NotificationsExtensions::TileContent::TileNotificationBase, and NotificationsExtensions::TileContent::ISquareTileInternal.

Inherited by NotificationsExtensions::TileContent::TileSquareBlock, NotificationsExtensions::TileContent::TileSquareBlock, NotificationsExtensions::TileContent::TileSquareImage, NotificationsExtensions::TileContent::TileSquareImage, NotificationsExtensions::TileContent::TileSquarePeekImageAndText01, NotificationsExtensions::TileContent::TileSquarePeekImageAndText01, NotificationsExtensions::TileContent::TileSquarePeekImageAndText02, NotificationsExtensions::TileContent::TileSquarePeekImageAndText02, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03, NotificationsExtensions::TileContent::TileSquarePeekImageAndText04, NotificationsExtensions::TileContent::TileSquarePeekImageAndText04, NotificationsExtensions::TileContent::TileSquareText01, NotificationsExtensions::TileContent::TileSquareText01, NotificationsExtensions::TileContent::TileSquareText02, NotificationsExtensions::TileContent::TileSquareText02, NotificationsExtensions::TileContent::TileSquareText03, NotificationsExtensions::TileContent::TileSquareText03, NotificationsExtensions::TileContent::TileSquareText04, and NotificationsExtensions::TileContent::TileSquareText04.

List of all members.

Public Member Functions

TileSquareBase (string templateName, int imageCount, int textCount)
TileSquareBase (string templateName, int imageCount, int textCount)
override string | GetContent ()
override string | GetContent ()
string | SerializeBinding (string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery)
string | SerializeBinding (string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery)

Detailed Description

Definition at line 53 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquareBase::TileSquareBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline]

Definition at line 55 of file TileContent.cs.

                                                                                : base(templateName, imageCount, textCount)
        {
        }

NotificationsExtensions::TileContent::TileSquareBase::TileSquareBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline]

Definition at line 55 of file TileContent.cs.

                                                                                : base(templateName, imageCount, textCount)
        {
        }

Member Function Documentation

override string NotificationsExtensions::TileContent::TileSquareBase::GetContent ( ) [inline]

Definition at line 59 of file TileContent.cs.

        {
            StringBuilder builder = new StringBuilder(String.Empty);
            builder.AppendFormat("<tile><visual version='{0}'", Util.NOTIFICATION_CONTENT_VERSION);
            if (!String.IsNullOrWhiteSpace(Lang))
            {
                builder.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
            }
            if (Branding != TileBranding.Logo)
            {
                builder.AppendFormat(" branding='{0}'", Branding.ToString().ToLowerInvariant());
            }
            if (!String.IsNullOrWhiteSpace(BaseUri))
            {
                builder.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
            }
            if (AddImageQuery)
            {
                builder.AppendFormat(" addImageQuery='true'");
            }
            builder.Append(">");
            builder.Append(SerializeBinding(Lang, BaseUri, Branding, AddImageQuery));
            builder.Append("</visual></tile>");
            return builder.ToString();
        }

override string NotificationsExtensions::TileContent::TileSquareBase::GetContent ( ) [inline]

Definition at line 59 of file TileContent.cs.

        {
            StringBuilder builder = new StringBuilder(String.Empty);
            builder.AppendFormat("<tile><visual version='{0}'", Util.NOTIFICATION_CONTENT_VERSION);
            if (!String.IsNullOrWhiteSpace(Lang))
            {
                builder.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
            }
            if (Branding != TileBranding.Logo)
            {
                builder.AppendFormat(" branding='{0}'", Branding.ToString().ToLowerInvariant());
            }
            if (!String.IsNullOrWhiteSpace(BaseUri))
            {
                builder.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
            }
            if (AddImageQuery)
            {
                builder.AppendFormat(" addImageQuery='true'");
            }
            builder.Append(">");
            builder.Append(SerializeBinding(Lang, BaseUri, Branding, AddImageQuery));
            builder.Append("</visual></tile>");
            return builder.ToString();
        }

string NotificationsExtensions::TileContent::TileSquareBase::SerializeBinding | ( | string | globalLang,
 |  | string | globalBaseUri,
 |  | TileBranding | globalBranding,
 |  | bool | globalAddImageQuery |
 | ) |  |  | [inline]

Implements NotificationsExtensions::TileContent::ISquareTileInternal.

Definition at line 85 of file TileContent.cs.

        {
            StringBuilder bindingNode = new StringBuilder(String.Empty);
            bindingNode.AppendFormat("<binding template='{0}'", TemplateName);
            if (!String.IsNullOrWhiteSpace(Lang) && !Lang.Equals(globalLang))
            {
                bindingNode.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
                globalLang = Lang;
            }
            if (Branding != TileBranding.Logo && Branding != globalBranding)
            {
                bindingNode.AppendFormat(" branding='{0}'", Branding.ToString().ToLowerInvariant());
            }
            if (!String.IsNullOrWhiteSpace(BaseUri) && !BaseUri.Equals(globalBaseUri))
            {
                bindingNode.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
                globalBaseUri = BaseUri;
            }
            if (AddImageQueryNullable != null && AddImageQueryNullable != globalAddImageQuery)
            {
                bindingNode.AppendFormat(" addImageQuery='{0}'", AddImageQuery.ToString().ToLowerInvariant());
                globalAddImageQuery = AddImageQuery;
            }
            bindingNode.AppendFormat(">{0}</binding>", SerializeProperties(globalLang, globalBaseUri, globalAddImageQuery));

            return bindingNode.ToString();
        }

string NotificationsExtensions::TileContent::TileSquareBase::SerializeBinding | ( | string | globalLang,
 |  | string | globalBaseUri,
 |  | TileBranding | globalBranding,
 |  | bool | globalAddImageQuery |
 | ) |  |  | [inline]

Implements NotificationsExtensions::TileContent::ISquareTileInternal.

Definition at line 85 of file TileContent.cs.

        {
            StringBuilder bindingNode = new StringBuilder(String.Empty);
            bindingNode.AppendFormat("<binding template='{0}'", TemplateName);
            if (!String.IsNullOrWhiteSpace(Lang) && !Lang.Equals(globalLang))
            {
                bindingNode.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
                globalLang = Lang;
            }
            if (Branding != TileBranding.Logo && Branding != globalBranding)
            {
                bindingNode.AppendFormat(" branding='{0}'", Branding.ToString().ToLowerInvariant());
            }
            if (!String.IsNullOrWhiteSpace(BaseUri) && !BaseUri.Equals(globalBaseUri))
            {
                bindingNode.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
                globalBaseUri = BaseUri;
            }
            if (AddImageQueryNullable != null && AddImageQueryNullable != globalAddImageQuery)
            {
                bindingNode.AppendFormat(" addImageQuery='{0}'", AddImageQuery.ToString().ToLowerInvariant());
                globalAddImageQuery = AddImageQuery;
            }
            bindingNode.AppendFormat(">{0}</binding>", SerializeProperties(globalLang, globalBaseUri, globalAddImageQuery));

            return bindingNode.ToString();
        }

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquareBlock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquareBlock
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquareBlock Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquareBlock ()
TileSquareBlock ()

Properties

INotificationContentText | TextBlock [get]
INotificationContentText | TextSubBlock [get]

Detailed Description

Definition at line 181 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquareBlock::TileSquareBlock ( ) [inline]

Definition at line 183 of file TileContent.cs.

                                 : base(templateName: "TileSquareBlock", imageCount: 0, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileSquareBlock::TileSquareBlock ( ) [inline]

Definition at line 183 of file TileContent.cs.

                                 : base(templateName: "TileSquareBlock", imageCount: 0, textCount: 2)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileSquareBlock::TextBlock [get]

Definition at line 187 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquareBlock::TextSubBlock [get]

Definition at line 188 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquareImage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquareImage
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquareImage Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquareImage ()
TileSquareImage ()

Properties

INotificationContentImage Image [get]

Detailed Description

Definition at line 191 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquareImage::TileSquareImage ( ) [inline]

Definition at line 193 of file TileContent.cs.

                                 : base(templateName: "TileSquareImage", imageCount: 1, textCount: 0)
        {
        }

NotificationsExtensions::TileContent::TileSquareImage::TileSquareImage ( ) [inline]

Definition at line 193 of file TileContent.cs.

                                 : base(templateName: "TileSquareImage", imageCount: 1, textCount: 0)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileSquareImage::Image [get]

Definition at line 197 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquarePeekImageAndText01 ()
TileSquarePeekImageAndText01 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 200 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquarePeekImageAndText01::TileSquarePeekImageAndText01 ( ) [inline]

Definition at line 202 of file TileContent.cs.

                                              : base(templateName: "TileSquarePeekImageAndText01", imageCount: 1, textCount: 4)
        {
        }

NotificationsExtensions::TileContent::TileSquarePeekImageAndText01::TileSquarePeekImageAndText01 ( ) [inline]

Definition at line 202 of file TileContent.cs.

                                              : base(templateName: "TileSquarePeekImageAndText01", imageCount: 1, textCount: 4)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileSquarePeekImageAndText01::Image [get]

Definition at line 206 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText01::TextBody1 [get]

Definition at line 209 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText01::TextBody2 [get]

Definition at line 210 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText01::TextBody3 [get]

Definition at line 211 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText01::TextHeading [get]

Definition at line 208 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquarePeekImageAndText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquarePeekImageAndText02 Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquarePeekImageAndText02 ()
TileSquarePeekImageAndText02 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 214 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquarePeekImageAndText02::TileSquarePeekImageAndText02 ( ) [inline]

Definition at line 216 of file TileContent.cs.

                                              : base(templateName: "TileSquarePeekImageAndText02", imageCount: 1, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileSquarePeekImageAndText02::TileSquarePeekImageAndText02 ( ) [inline]

Definition at line 216 of file TileContent.cs.

                                              : base(templateName: "TileSquarePeekImageAndText02", imageCount: 1, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileSquarePeekImageAndText02::Image [get]

Definition at line 220 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText02::TextBodyWrap [get]

Definition at line 223 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText02::TextHeading [get]

Definition at line 222 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquarePeekImageAndText03 ()
TileSquarePeekImageAndText03 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]

Detailed Description

Definition at line 226 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquarePeekImageAndText03::TileSquarePeekImageAndText03 ( ) [inline]

Definition at line 228 of file TileContent.cs.

                                              : base(templateName: "TileSquarePeekImageAndText03", imageCount: 1, textCount: 4)
        {
        }

NotificationsExtensions::TileContent::TileSquarePeekImageAndText03::TileSquarePeekImageAndText03 ( ) [inline]

Definition at line 228 of file TileContent.cs.

                                              : base(templateName: "TileSquarePeekImageAndText03", imageCount: 1, textCount: 4)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileSquarePeekImageAndText03::Image [get]

Definition at line 232 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText03::TextBody1 [get]

Definition at line 234 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText03::TextBody2 [get]

Definition at line 235 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText03::TextBody3 [get]

Definition at line 236 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText03::TextBody4 [get]

Definition at line 237 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquarePeekImageAndText04 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquarePeekImageAndText04 Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquarePeekImageAndText04 ()
TileSquarePeekImageAndText04 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]

Detailed Description

Definition at line 240 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquarePeekImageAndText04::TileSquarePeekImageAndText04 ( ) [inline]

Definition at line 242 of file TileContent.cs.

                                              : base(templateName: "TileSquarePeekImageAndText04", imageCount: 1, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileSquarePeekImageAndText04::TileSquarePeekImageAndText04 ( ) [inline]

Definition at line 242 of file TileContent.cs.

                                              : base(templateName: "TileSquarePeekImageAndText04", imageCount: 1, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileSquarePeekImageAndText04::Image [get]

Definition at line 246 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquarePeekImageAndText04::TextBodyWrap [get]

Definition at line 248 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquareText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquareText01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquareText01 Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquareText01 ()
TileSquareText01 ()

Properties

INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 251 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquareText01::TileSquareText01 ( ) [inline]

Definition at line 253 of file TileContent.cs.

                                  : base(templateName: "TileSquareText01", imageCount: 0, textCount: 4)
        {
        }

NotificationsExtensions::TileContent::TileSquareText01::TileSquareText01 ( ) [inline]

Definition at line 253 of file TileContent.cs.

                                  : base(templateName: "TileSquareText01", imageCount: 0, textCount: 4)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileSquareText01::TextBody1 [get]

Definition at line 258 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquareText01::TextBody2 [get]

Definition at line 259 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquareText01::TextBody3 [get]

Definition at line 260 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquareText01::TextHeading [get]

Definition at line 257 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquareText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquareText02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquareText02 Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquareText02 ()
TileSquareText02 ()

Properties

INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 263 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquareText02::TileSquareText02 ( ) [inline]

Definition at line 265 of file TileContent.cs.

                                  : base(templateName: "TileSquareText02", imageCount: 0, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileSquareText02::TileSquareText02 ( ) [inline]

Definition at line 265 of file TileContent.cs.

                                  : base(templateName: "TileSquareText02", imageCount: 0, textCount: 2)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileSquareText02::TextBodyWrap [get]

Definition at line 270 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquareText02::TextHeading [get]

Definition at line 269 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquareText03 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquareText03
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquareText03 Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquareText03 ()
TileSquareText03 ()

Properties

INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]

Detailed Description

Definition at line 273 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquareText03::TileSquareText03 ( ) [inline]

Definition at line 275 of file TileContent.cs.

                                  : base(templateName: "TileSquareText03", imageCount: 0, textCount: 4)
        {
        }

NotificationsExtensions::TileContent::TileSquareText03::TileSquareText03 ( ) [inline]

Definition at line 275 of file TileContent.cs.

                                  : base(templateName: "TileSquareText03", imageCount: 0, textCount: 4)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileSquareText03::TextBody1 [get]

Definition at line 279 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquareText03::TextBody2 [get]

Definition at line 280 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquareText03::TextBody3 [get]

Definition at line 281 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileSquareText03::TextBody4 [get]

Definition at line 282 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileSquareText04 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileSquareText04
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileSquareText04 Class Reference

Inherits NotificationsExtensions::TileContent::TileSquareBase, and NotificationsExtensions::TileContent::TileSquareBase.

List of all members.

Public Member Functions

TileSquareText04 ()
TileSquareText04 ()

Properties

INotificationContentText TextBodyWrap [get]

Detailed Description

Definition at line 285 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileSquareText04::TileSquareText04 ( ) [inline]

Definition at line 287 of file TileContent.cs.

                                  : base(templateName: "TileSquareText04", imageCount: 0, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileSquareText04::TileSquareText04 ( ) [inline]

Definition at line 287 of file TileContent.cs.

                                  : base(templateName: "TileSquareText04", imageCount: 0, textCount: 1)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileSquareText04::TextBodyWrap [get]

Definition at line 291 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideBase
Public Member Functions | Properties | Private Attributes

NotificationsExtensions::TileContent::TileWideBase Class Reference

Inherits NotificationsExtensions::TileContent::TileNotificationBase, and NotificationsExtensions::TileContent::TileNotificationBase.

Inherited by NotificationsExtensions::TileContent::TileWideBlockAndText01, NotificationsExtensions::TileContent::TileWideBlockAndText01, NotificationsExtensions::TileContent::TileWideBlockAndText02, NotificationsExtensions::TileContent::TileWideBlockAndText02, NotificationsExtensions::TileContent::TileWideImage, NotificationsExtensions::TileContent::TileWideImage, NotificationsExtensions::TileContent::TileWideImageAndText01, NotificationsExtensions::TileContent::TileWideImageAndText01, NotificationsExtensions::TileContent::TileWideImageAndText02, NotificationsExtensions::TileContent::TileWideImageAndText02, NotificationsExtensions::TileContent::TileWideImageCollection, NotificationsExtensions::TileContent::TileWideImageCollection, NotificationsExtensions::TileContent::TileWidePeekImage01, NotificationsExtensions::TileContent::TileWidePeekImage01, NotificationsExtensions::TileContent::TileWidePeekImage02, NotificationsExtensions::TileContent::TileWidePeekImage02, NotificationsExtensions::TileContent::TileWidePeekImage03, NotificationsExtensions::TileContent::TileWidePeekImage03, NotificationsExtensions::TileContent::TileWidePeekImage04, NotificationsExtensions::TileContent::TileWidePeekImage04, NotificationsExtensions::TileContent::TileWidePeekImage05, NotificationsExtensions::TileContent::TileWidePeekImage05, NotificationsExtensions::TileContent::TileWidePeekImage06, NotificationsExtensions::TileContent::TileWidePeekImage06, NotificationsExtensions::TileContent::TileWidePeekImageAndText01, NotificationsExtensions::TileContent::TileWidePeekImageAndText01, NotificationsExtensions::TileContent::TileWidePeekImageAndText02, NotificationsExtensions::TileContent::TileWidePeekImageAndText02, NotificationsExtensions::TileContent::TileWidePeekImageCollection01, NotificationsExtensions::TileContent::TileWidePeekImageCollection01, NotificationsExtensions::TileContent::TileWidePeekImageCollection02, NotificationsExtensions::TileContent::TileWidePeekImageCollection02, NotificationsExtensions::TileContent::TileWidePeekImageCollection03, NotificationsExtensions::TileContent::TileWidePeekImageCollection03, NotificationsExtensions::TileContent::TileWidePeekImageCollection04, NotificationsExtensions::TileContent::TileWidePeekImageCollection04, NotificationsExtensions::TileContent::TileWidePeekImageCollection05, NotificationsExtensions::TileContent::TileWidePeekImageCollection05, NotificationsExtensions::TileContent::TileWidePeekImageCollection06, NotificationsExtensions::TileContent::TileWidePeekImageCollection06, NotificationsExtensions::TileContent::TileWideSmallImageAndText01, NotificationsExtensions::TileContent::TileWideSmallImageAndText01, NotificationsExtensions::TileContent::TileWideSmallImageAndText02, NotificationsExtensions::TileContent::TileWideSmallImageAndText02, NotificationsExtensions::TileContent::TileWideSmallImageAndText03, NotificationsExtensions::TileContent::TileWideSmallImageAndText03, NotificationsExtensions::TileContent::TileWideSmallImageAndText04, NotificationsExtensions::TileContent::TileWideSmallImageAndText04, NotificationsExtensions::TileContent::TileWideSmallImageAndText05, NotificationsExtensions::TileContent::TileWideSmallImageAndText05, NotificationsExtensions::TileContent::TileWideText01, NotificationsExtensions::TileContent::TileWideText01, NotificationsExtensions::TileContent::TileWideText02, NotificationsExtensions::TileContent::TileWideText02, NotificationsExtensions::TileContent::TileWideText03, NotificationsExtensions::TileContent::TileWideText03, NotificationsExtensions::TileContent::TileWideText04, NotificationsExtensions::TileContent::TileWideText04, NotificationsExtensions::TileContent::TileWideText05, NotificationsExtensions::TileContent::TileWideText05, NotificationsExtensions::TileContent::TileWideText06, NotificationsExtensions::TileContent::TileWideText06, NotificationsExtensions::TileContent::TileWideText07, NotificationsExtensions::TileContent::TileWideText07, NotificationsExtensions::TileContent::TileWideText08, NotificationsExtensions::TileContent::TileWideText08, NotificationsExtensions::TileContent::TileWideText09, NotificationsExtensions::TileContent::TileWideText09, NotificationsExtensions::TileContent::TileWideText10, NotificationsExtensions::TileContent::TileWideText10, NotificationsExtensions::TileContent::TileWideText11, and NotificationsExtensions::TileContent::TileWideText11.

List of all members.

Public Member Functions

TileWideBase (string templateName, int imageCount, int textCount)
TileWideBase (string templateName, int imageCount, int textCount)
override string | GetContent ()
override string | GetContent ()

Properties

bool | RequireSquareContent [get, set]
ISquareTileNotificationContent | SquareContent [get, set]

Private Attributes

bool | m_RequireSquareContent = true
ISquareTileNotificationContent | m_SquareContent = null

Detailed Description

Definition at line 114 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideBase::TileWideBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline]

Definition at line 116 of file TileContent.cs.

                                                                                : base(templateName, imageCount, textCount)
        {
        }

NotificationsExtensions::TileContent::TileWideBase::TileWideBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline]

Definition at line 116 of file TileContent.cs.

                                                                                : base(templateName, imageCount, textCount)
        {
        }

Member Function Documentation

override string NotificationsExtensions::TileContent::TileWideBase::GetContent ( ) [inline, virtual]

Implements NotificationsExtensions::NotificationBase.

Definition at line 132 of file TileContent.cs.

        {
            if (RequireSquareContent && SquareContent == null)
            {
                throw new NotificationContentValidationException(
                    "Square tile content should be included with each wide tile. " +
                    "If this behavior is undesired, use the RequireSquareContent property.");
            }

            StringBuilder visualNode = new StringBuilder(String.Empty);
            visualNode.AppendFormat("<visual version='{0}'", Util.NOTIFICATION_CONTENT_VERSION);
            if (!String.IsNullOrWhiteSpace(Lang))
            {
                visualNode.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
            }
            if (Branding != TileBranding.Logo)
            {
                visualNode.AppendFormat(" branding='{0}'", Branding.ToString().ToLowerInvariant());
            }
            if (!String.IsNullOrWhiteSpace(BaseUri))
            {
                visualNode.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
            }
            if (AddImageQuery)
            {
                visualNode.AppendFormat(" addImageQuery='true'");
            }
            visualNode.Append(">");

            StringBuilder builder = new StringBuilder(String.Empty);
            builder.AppendFormat("<tile>{0}<binding template='{1}'>{2}</binding>", visualNode, TemplateName, SerializeProperties(Lang, BaseUri, AddImageQuery));
            if (SquareContent != null)
            {
                ISquareTileInternal squareBase = SquareContent as ISquareTileInternal;
                if (squareBase == null)
                {
                    throw new NotificationContentValidationException("The provided square tile content class is unsupported.");
                }
                builder.Append(squareBase.SerializeBinding(Lang, BaseUri, Branding, AddImageQuery));
            }
            builder.Append("</visual></tile>");

            return builder.ToString();
        }

override string NotificationsExtensions::TileContent::TileWideBase::GetContent ( ) [inline, virtual]

Implements NotificationsExtensions::NotificationBase.

Definition at line 132 of file TileContent.cs.

        {
            if (RequireSquareContent && SquareContent == null)
            {
                throw new NotificationContentValidationException(
                    "Square tile content should be included with each wide tile. " +
                    "If this behavior is undesired, use the RequireSquareContent property.");
            }

            StringBuilder visualNode = new StringBuilder(String.Empty);
            visualNode.AppendFormat("<visual version='{0}'", Util.NOTIFICATION_CONTENT_VERSION);
            if (!String.IsNullOrWhiteSpace(Lang))
            {
                visualNode.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
            }
            if (Branding != TileBranding.Logo)
            {
                visualNode.AppendFormat(" branding='{0}'", Branding.ToString().ToLowerInvariant());
            }
            if (!String.IsNullOrWhiteSpace(BaseUri))
            {
                visualNode.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
            }
            if (AddImageQuery)
            {
                visualNode.AppendFormat(" addImageQuery='true'");
            }
            visualNode.Append(">");

            StringBuilder builder = new StringBuilder(String.Empty);
            builder.AppendFormat("<tile>{0}<binding template='{1}'>{2}</binding>", visualNode, TemplateName, SerializeProperties(Lang, BaseUri, AddImageQuery));
            if (SquareContent != null)
            {
                ISquareTileInternal squareBase = SquareContent as ISquareTileInternal;
                if (squareBase == null)
                {
                    throw new NotificationContentValidationException("The provided square tile content class is unsupported.");
                }
                builder.Append(squareBase.SerializeBinding(Lang, BaseUri, Branding, AddImageQuery));
            }
            builder.Append("</visual></tile>");

            return builder.ToString();
        }

Member Data Documentation

bool NotificationsExtensions::TileContent::TileWideBase::m_RequireSquareContent = true [private]

Definition at line 178 of file TileContent.cs.

ISquareTileNotificationContent NotificationsExtensions::TileContent::TileWideBase::m_SquareContent = null [private]

Definition at line 177 of file TileContent.cs.

Property Documentation

bool NotificationsExtensions::TileContent::TileWideBase::RequireSquareContent [get, set]

Definition at line 127 of file TileContent.cs.

ISquareTileNotificationContent NotificationsExtensions::TileContent::TileWideBase::SquareContent [get, set]

Definition at line 121 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideBlockAndText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideBlockAndText01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideBlockAndText01 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideBlockAndText01 ()
TileWideBlockAndText01 ()

Properties

INotificationContentText | TextBlock [get]
INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]
INotificationContentText | TextSubBlock [get]

Detailed Description

Definition at line 294 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideBlockAndText01::TileWideBlockAndText01 ( ) [inline]

Definition at line 296 of file TileContent.cs.

                                        : base(templateName: "TileWideBlockAndText01", imageCount: 0, textCount: 6)
        {
        }

NotificationsExtensions::TileContent::TileWideBlockAndText01::TileWideBlockAndText01 ( ) [inline]

Definition at line 296 of file TileContent.cs.

                                        : base(templateName: "TileWideBlockAndText01", imageCount: 0, textCount: 6)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText01::TextBlock [get]

Definition at line 304 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText01::TextBody1 [get]

Definition at line 300 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText01::TextBody2 [get]

Definition at line 301 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText01::TextBody3 [get]

Definition at line 302 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText01::TextBody4 [get]

Definition at line 303 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText01::TextSubBlock [get]

Definition at line 305 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideBlockAndText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideBlockAndText02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideBlockAndText02 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideBlockAndText02 ()
TileWideBlockAndText02 ()

Properties

INotificationContentText | TextBlock [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextSubBlock [get]

Detailed Description

Definition at line 308 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideBlockAndText02::TileWideBlockAndText02 ( ) [inline]

Definition at line 310 of file TileContent.cs.

                                        : base(templateName: "TileWideBlockAndText02", imageCount: 0, textCount: 6)
        {
        }

NotificationsExtensions::TileContent::TileWideBlockAndText02::TileWideBlockAndText02 ( ) [inline]

Definition at line 310 of file TileContent.cs.

                                        : base(templateName: "TileWideBlockAndText02", imageCount: 0, textCount: 6)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText02::TextBlock [get]

Definition at line 315 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText02::TextBodyWrap [get]

Definition at line 314 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideBlockAndText02::TextSubBlock [get]

Definition at line 316 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideImage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideImage
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideImage Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideImage ()
TileWideImage ()

Properties

INotificationContentImage Image [get]

Detailed Description

Definition at line 319 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideImage::TileWideImage ( ) [inline]

Definition at line 321 of file TileContent.cs.

                               : base(templateName: "TileWideImage", imageCount: 1, textCount: 0)
        {
        }

NotificationsExtensions::TileContent::TileWideImage::TileWideImage ( ) [inline]

Definition at line 321 of file TileContent.cs.

                               : base(templateName: "TileWideImage", imageCount: 1, textCount: 0)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideImage::Image [get]

Definition at line 325 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideImageAndText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideImageAndText01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideImageAndText01 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideImageAndText01 ()
TileWideImageAndText01 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextCaptionWrap [get]

Detailed Description

Definition at line 328 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideImageAndText01::TileWideImageAndText01 ( ) [inline]

Definition at line 330 of file TileContent.cs.

                                        : base(templateName: "TileWideImageAndText01", imageCount: 1, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWideImageAndText01::TileWideImageAndText01 ( ) [inline]

Definition at line 330 of file TileContent.cs.

                                        : base(templateName: "TileWideImageAndText01", imageCount: 1, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideImageAndText01::Image [get]

Definition at line 334 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideImageAndText01::TextCaptionWrap [get]

Definition at line 336 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideImageAndText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideImageAndText02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideImageAndText02 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideImageAndText02 ()
TileWideImageAndText02 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextCaption1 [get]
INotificationContentText | TextCaption2 [get]

Detailed Description

Definition at line 339 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideImageAndText02::TileWideImageAndText02 ( ) [inline]

Definition at line 341 of file TileContent.cs.

                                        : base(templateName: "TileWideImageAndText02", imageCount: 1, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileWideImageAndText02::TileWideImageAndText02 ( ) [inline]

Definition at line 341 of file TileContent.cs.

                                        : base(templateName: "TileWideImageAndText02", imageCount: 1, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideImageAndText02::Image [get]

Definition at line 345 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideImageAndText02::TextCaption1 [get]

Definition at line 347 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideImageAndText02::TextCaption2 [get]

Definition at line 348 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideImageCollection Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideImageCollection
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideImageCollection Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideImageCollection ()
TileWideImageCollection ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSmallColumn1Row1 [get]
INotificationContentImage | ImageSmallColumn1Row2 [get]
INotificationContentImage | ImageSmallColumn2Row1 [get]
INotificationContentImage | ImageSmallColumn2Row2 [get]

Detailed Description

Definition at line 351 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideImageCollection::TileWideImageCollection ( ) [inline]

Definition at line 353 of file TileContent.cs.

                                         : base(templateName: "TileWideImageCollection", imageCount: 5, textCount: 0)
        {
        }

NotificationsExtensions::TileContent::TileWideImageCollection::TileWideImageCollection ( ) [inline]

Definition at line 353 of file TileContent.cs.

                                         : base(templateName: "TileWideImageCollection", imageCount: 5, textCount: 0)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideImageCollection::ImageMain [get]

Definition at line 357 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWideImageCollection::ImageSmallColumn1Row1 [get]

Definition at line 358 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWideImageCollection::ImageSmallColumn1Row2 [get]

Definition at line 360 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWideImageCollection::ImageSmallColumn2Row1 [get]

Definition at line 359 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWideImageCollection::ImageSmallColumn2Row2 [get]

Definition at line 361 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImage01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImage01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImage01 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImage01 ()
TileWidePeekImage01 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 364 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImage01::TileWidePeekImage01 ( ) [inline]

Definition at line 366 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage01", imageCount: 1, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImage01::TileWidePeekImage01 ( ) [inline]

Definition at line 366 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage01", imageCount: 1, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImage01::Image [get]

Definition at line 370 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage01::TextBodyWrap [get]

Definition at line 373 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage01::TextHeading [get]

Definition at line 372 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImage02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImage02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImage02 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImage02 ()
TileWidePeekImage02 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 376 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImage02::TileWidePeekImage02 ( ) [inline]

Definition at line 378 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage02", imageCount: 1, textCount: 5)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImage02::TileWidePeekImage02 ( ) [inline]

Definition at line 378 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage02", imageCount: 1, textCount: 5)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImage02::Image [get]

Definition at line 382 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage02::TextBody1 [get]

Definition at line 385 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage02::TextBody2 [get]

Definition at line 386 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage02::TextBody3 [get]

Definition at line 387 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage02::TextBody4 [get]

Definition at line 388 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage02::TextHeading [get]

Definition at line 384 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImage03 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImage03
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImage03 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImage03 ()
TileWidePeekImage03 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextHeadingWrap [get]

Detailed Description

Definition at line 391 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImage03::TileWidePeekImage03 ( ) [inline]

Definition at line 393 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage03", imageCount: 1, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImage03::TileWidePeekImage03 ( ) [inline]

Definition at line 393 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage03", imageCount: 1, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImage03::Image [get]

Definition at line 397 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage03::TextHeadingWrap [get]

Definition at line 399 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImage04 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImage04
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImage04 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImage04 ()
TileWidePeekImage04 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]

Detailed Description

Definition at line 402 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImage04::TileWidePeekImage04 ( ) [inline]

Definition at line 404 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage04", imageCount: 1, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImage04::TileWidePeekImage04 ( ) [inline]

Definition at line 404 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage04", imageCount: 1, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImage04::Image [get]

Definition at line 408 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage04::TextBodyWrap [get]

Definition at line 410 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImage05 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImage05
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImage05 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImage05 ()
TileWidePeekImage05 ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSecondary [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 413 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImage05::TileWidePeekImage05 ( ) [inline]

Definition at line 415 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage05", imageCount: 2, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImage05::TileWidePeekImage05 ( ) [inline]

Definition at line 415 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage05", imageCount: 2, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImage05::ImageMain [get]

Definition at line 419 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImage05::ImageSecondary [get]

Definition at line 420 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage05::TextBodyWrap [get]

Definition at line 423 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage05::TextHeading [get]

Definition at line 422 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImage06 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImage06
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImage06 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImage06 ()
TileWidePeekImage06 ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSecondary [get]
INotificationContentText | TextHeadingWrap [get]

Detailed Description

Definition at line 426 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImage06::TileWidePeekImage06 ( ) [inline]

Definition at line 428 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage06", imageCount: 2, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImage06::TileWidePeekImage06 ( ) [inline]

Definition at line 428 of file TileContent.cs.

                                     : base(templateName: "TileWidePeekImage06", imageCount: 2, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImage06::ImageMain [get]

Definition at line 432 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImage06::ImageSecondary [get]

Definition at line 433 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImage06::TextHeadingWrap [get]

Definition at line 435 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImageAndText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImageAndText01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImageAndText01 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImageAndText01 ()
TileWidePeekImageAndText01 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]

Detailed Description

Definition at line 438 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImageAndText01::TileWidePeekImageAndText01 ( ) [inline]

Definition at line 440 of file TileContent.cs.

                                            : base(templateName: "TileWidePeekImageAndText01", imageCount: 1, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImageAndText01::TileWidePeekImageAndText01 ( ) [inline]

Definition at line 440 of file TileContent.cs.

                                            : base(templateName: "TileWidePeekImageAndText01", imageCount: 1, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageAndText01::Image [get]

Definition at line 444 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageAndText01::TextBodyWrap [get]

Definition at line 446 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImageAndText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImageAndText02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImageAndText02 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImageAndText02 ()
TileWidePeekImageAndText02 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]
INotificationContentText | TextBody5 [get]

Detailed Description

Definition at line 449 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImageAndText02::TileWidePeekImageAndText02 ( ) [inline]

Definition at line 451 of file TileContent.cs.

                                            : base(templateName: "TileWidePeekImageAndText02", imageCount: 1, textCount: 5)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImageAndText02::TileWidePeekImageAndText02 ( ) [inline]

Definition at line 451 of file TileContent.cs.

                                            : base(templateName: "TileWidePeekImageAndText02", imageCount: 1, textCount: 5)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageAndText02::Image [get]

Definition at line 455 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageAndText02::TextBody1 [get]

Definition at line 457 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageAndText02::TextBody2 [get]

Definition at line 458 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageAndText02::TextBody3 [get]

Definition at line 459 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageAndText02::TextBody4 [get]

Definition at line 460 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageAndText02::TextBody5 [get]

Definition at line 461 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImageCollection01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImageCollection01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImageCollection01 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImageCollection01 ()
TileWidePeekImageCollection01 ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSmallColumn1Row1 [get]
INotificationContentImage | ImageSmallColumn1Row2 [get]
INotificationContentImage | ImageSmallColumn2Row1 [get]
INotificationContentImage | ImageSmallColumn2Row2 [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 464 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImageCollection01::TileWidePeekImageCollection01 ( ) [inline]

Definition at line 466 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection01", imageCount: 5, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImageCollection01::TileWidePeekImageCollection01 ( ) [inline]

Definition at line 466 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection01", imageCount: 5, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection01::ImageMain [get]

Definition at line 470 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection01::ImageSmallColumn1Row1 [get]

Definition at line 471 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection01::ImageSmallColumn1Row2 [get]

Definition at line 473 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection01::ImageSmallColumn2Row1 [get]

Definition at line 472 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection01::ImageSmallColumn2Row2 [get]

Definition at line 474 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection01::TextBodyWrap [get]

Definition at line 477 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection01::TextHeading [get]

Definition at line 476 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImageCollection02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImageCollection02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImageCollection02 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImageCollection02 ()
TileWidePeekImageCollection02 ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSmallColumn1Row1 [get]
INotificationContentImage | ImageSmallColumn1Row2 [get]
INotificationContentImage | ImageSmallColumn2Row1 [get]
INotificationContentImage | ImageSmallColumn2Row2 [get]
INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 480 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImageCollection02::TileWidePeekImageCollection02 ( ) [inline]

Definition at line 482 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection02", imageCount: 5, textCount: 5)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImageCollection02::TileWidePeekImageCollection02 ( ) [inline]

Definition at line 482 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection02", imageCount: 5, textCount: 5)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection02::ImageMain [get]

Definition at line 486 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection02::ImageSmallColumn1Row1 [get]

Definition at line 487 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection02::ImageSmallColumn1Row2 [get]

Definition at line 489 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection02::ImageSmallColumn2Row1 [get]

Definition at line 488 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection02::ImageSmallColumn2Row2 [get]

Definition at line 490 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection02::TextBody1 [get]

Definition at line 493 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection02::TextBody2 [get]

Definition at line 494 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection02::TextBody3 [get]

Definition at line 495 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection02::TextBody4 [get]

Definition at line 496 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection02::TextHeading [get]

Definition at line 492 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImageCollection03 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImageCollection03
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImageCollection03 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImageCollection03 ()
TileWidePeekImageCollection03 ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSmallColumn1Row1 [get]
INotificationContentImage | ImageSmallColumn1Row2 [get]
INotificationContentImage | ImageSmallColumn2Row1 [get]
INotificationContentImage | ImageSmallColumn2Row2 [get]
INotificationContentText | TextHeadingWrap [get]

Detailed Description

Definition at line 499 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImageCollection03::TileWidePeekImageCollection03 ( ) [inline]

Definition at line 501 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection03", imageCount: 5, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImageCollection03::TileWidePeekImageCollection03 ( ) [inline]

Definition at line 501 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection03", imageCount: 5, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection03::ImageMain [get]

Definition at line 505 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection03::ImageSmallColumn1Row1 [get]

Definition at line 506 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection03::ImageSmallColumn1Row2 [get]

Definition at line 508 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection03::ImageSmallColumn2Row1 [get]

Definition at line 507 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection03::ImageSmallColumn2Row2 [get]

Definition at line 509 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection03::TextHeadingWrap [get]

Definition at line 511 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImageCollection04 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImageCollection04
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImageCollection04 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImageCollection04 ()
TileWidePeekImageCollection04 ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSmallColumn1Row1 [get]
INotificationContentImage | ImageSmallColumn1Row2 [get]
INotificationContentImage | ImageSmallColumn2Row1 [get]
INotificationContentImage | ImageSmallColumn2Row2 [get]
INotificationContentText | TextBodyWrap [get]

Detailed Description

Definition at line 514 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImageCollection04::TileWidePeekImageCollection04 ( ) [inline]

Definition at line 516 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection04", imageCount: 5, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImageCollection04::TileWidePeekImageCollection04 ( ) [inline]

Definition at line 516 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection04", imageCount: 5, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection04::ImageMain [get]

Definition at line 520 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection04::ImageSmallColumn1Row1 [get]

Definition at line 521 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection04::ImageSmallColumn1Row2 [get]

Definition at line 523 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection04::ImageSmallColumn2Row1 [get]

Definition at line 522 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection04::ImageSmallColumn2Row2 [get]

Definition at line 524 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection04::TextBodyWrap [get]

Definition at line 526 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImageCollection05 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImageCollection05
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImageCollection05 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImageCollection05 ()
TileWidePeekImageCollection05 ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSecondary [get]
INotificationContentImage | ImageSmallColumn1Row1 [get]
INotificationContentImage | ImageSmallColumn1Row2 [get]
INotificationContentImage | ImageSmallColumn2Row1 [get]
INotificationContentImage | ImageSmallColumn2Row2 [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 529 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImageCollection05::TileWidePeekImageCollection05 ( ) [inline]

Definition at line 531 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection05", imageCount: 6, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImageCollection05::TileWidePeekImageCollection05 ( ) [inline]

Definition at line 531 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection05", imageCount: 6, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection05::ImageMain [get]

Definition at line 535 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection05::ImageSecondary [get]

Definition at line 540 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection05::ImageSmallColumn1Row1 [get]

Definition at line 536 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection05::ImageSmallColumn1Row2 [get]

Definition at line 538 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection05::ImageSmallColumn2Row1 [get]

Definition at line 537 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection05::ImageSmallColumn2Row2 [get]

Definition at line 539 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection05::TextBodyWrap [get]

Definition at line 543 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection05::TextHeading [get]

Definition at line 542 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWidePeekImageCollection06 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWidePeekImageCollection06
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWidePeekImageCollection06 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWidePeekImageCollection06 ()
TileWidePeekImageCollection06 ()

Properties

INotificationContentImage | ImageMain [get]
INotificationContentImage | ImageSecondary [get]
INotificationContentImage | ImageSmallColumn1Row1 [get]
INotificationContentImage | ImageSmallColumn1Row2 [get]
INotificationContentImage | ImageSmallColumn2Row1 [get]
INotificationContentImage | ImageSmallColumn2Row2 [get]
INotificationContentText | TextHeadingWrap [get]

Detailed Description

Definition at line 546 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWidePeekImageCollection06::TileWidePeekImageCollection06 ( ) [inline]

Definition at line 548 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection06", imageCount: 6, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWidePeekImageCollection06::TileWidePeekImageCollection06 ( ) [inline]

Definition at line 548 of file TileContent.cs.

                                               : base(templateName: "TileWidePeekImageCollection06", imageCount: 6, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection06::ImageMain [get]

Definition at line 552 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection06::ImageSecondary [get]

Definition at line 557 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection06::ImageSmallColumn1Row1 [get]

Definition at line 553 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection06::ImageSmallColumn1Row2 [get]

Definition at line 555 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection06::ImageSmallColumn2Row1 [get]

Definition at line 554 of file TileContent.cs.

INotificationContentImage NotificationsExtensions::TileContent::TileWidePeekImageCollection06::ImageSmallColumn2Row2 [get]

Definition at line 556 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWidePeekImageCollection06::TextHeadingWrap [get]

Definition at line 559 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideSmallImageAndText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideSmallImageAndText01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideSmallImageAndText01 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideSmallImageAndText01 ()
TileWideSmallImageAndText01 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextHeadingWrap [get]

Detailed Description

Definition at line 562 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideSmallImageAndText01::TileWideSmallImageAndText01 ( ) [inline]

Definition at line 564 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText01", imageCount: 1, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWideSmallImageAndText01::TileWideSmallImageAndText01 ( ) [inline]

Definition at line 564 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText01", imageCount: 1, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideSmallImageAndText01::Image [get]

Definition at line 568 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText01::TextHeadingWrap [get]

Definition at line 570 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideSmallImageAndText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideSmallImageAndText02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideSmallImageAndText02 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideSmallImageAndText02 ()
TileWideSmallImageAndText02 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 573 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideSmallImageAndText02::TileWideSmallImageAndText02 ( ) [inline]

Definition at line 575 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText02", imageCount: 1, textCount: 5)
        {
        }

NotificationsExtensions::TileContent::TileWideSmallImageAndText02::TileWideSmallImageAndText02 ( ) [inline]

Definition at line 575 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText02", imageCount: 1, textCount: 5)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideSmallImageAndText02::Image [get]

Definition at line 579 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText02::TextBody1 [get]

Definition at line 582 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText02::TextBody2 [get]

Definition at line 583 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText02::TextBody3 [get]

Definition at line 584 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText02::TextBody4 [get]

Definition at line 585 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText02::TextHeading [get]

Definition at line 581 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideSmallImageAndText03 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideSmallImageAndText03
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideSmallImageAndText03 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideSmallImageAndText03 ()
TileWideSmallImageAndText03 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]

Detailed Description

Definition at line 588 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideSmallImageAndText03::TileWideSmallImageAndText03 ( ) [inline]

Definition at line 590 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText03", imageCount: 1, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWideSmallImageAndText03::TileWideSmallImageAndText03 ( ) [inline]

Definition at line 590 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText03", imageCount: 1, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideSmallImageAndText03::Image [get]

Definition at line 594 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText03::TextBodyWrap [get]

Definition at line 596 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideSmallImageAndText04 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideSmallImageAndText04
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideSmallImageAndText04 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideSmallImageAndText04 ()
TileWideSmallImageAndText04 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 599 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideSmallImageAndText04::TileWideSmallImageAndText04 ( ) [inline]

Definition at line 601 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText04", imageCount: 1, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileWideSmallImageAndText04::TileWideSmallImageAndText04 ( ) [inline]

Definition at line 601 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText04", imageCount: 1, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideSmallImageAndText04::Image [get]

Definition at line 605 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText04::TextBodyWrap [get]

Definition at line 608 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText04::TextHeading [get]

Definition at line 607 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideSmallImageAndText05 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideSmallImageAndText05
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideSmallImageAndText05 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideSmallImageAndText05 ()
TileWideSmallImageAndText05 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 611 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideSmallImageAndText05::TileWideSmallImageAndText05 ( ) [inline]

Definition at line 613 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText05", imageCount: 1, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileWideSmallImageAndText05::TileWideSmallImageAndText05 ( ) [inline]

Definition at line 613 of file TileContent.cs.

                                             : base(templateName: "TileWideSmallImageAndText05", imageCount: 1, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::TileContent::TileWideSmallImageAndText05::Image [get]

Definition at line 617 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText05::TextBodyWrap [get]

Definition at line 620 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideSmallImageAndText05::TextHeading [get]

Definition at line 619 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText01
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText01 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText01 ()
TileWideText01 ()

Properties

INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 623 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText01::TileWideText01 ( ) [inline]

Definition at line 625 of file TileContent.cs.

                                : base(templateName: "TileWideText01", imageCount: 0, textCount: 5)
        {
        }

NotificationsExtensions::TileContent::TileWideText01::TileWideText01 ( ) [inline]

Definition at line 625 of file TileContent.cs.

                                : base(templateName: "TileWideText01", imageCount: 0, textCount: 5)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText01::TextBody1 [get]

Definition at line 630 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText01::TextBody2 [get]

Definition at line 631 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText01::TextBody3 [get]

Definition at line 632 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText01::TextBody4 [get]

Definition at line 633 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText01::TextHeading [get]

Definition at line 629 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText02
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText02 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText02 ()
TileWideText02 ()

Properties

INotificationContentText | TextColumn1Row1 [get]
INotificationContentText | TextColumn1Row2 [get]
INotificationContentText | TextColumn1Row3 [get]
INotificationContentText | TextColumn1Row4 [get]
INotificationContentText | TextColumn2Row1 [get]
INotificationContentText | TextColumn2Row2 [get]
INotificationContentText | TextColumn2Row3 [get]
INotificationContentText | TextColumn2Row4 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 636 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText02::TileWideText02 ( ) [inline]

Definition at line 638 of file TileContent.cs.

                                : base(templateName: "TileWideText02", imageCount: 0, textCount: 9)
        {
        }

NotificationsExtensions::TileContent::TileWideText02::TileWideText02 ( ) [inline]

Definition at line 638 of file TileContent.cs.

                                : base(templateName: "TileWideText02", imageCount: 0, textCount: 9)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextColumn1Row1 [get]

Definition at line 643 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextColumn1Row2 [get]

Definition at line 645 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextColumn1Row3 [get]

Definition at line 647 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextColumn1Row4 [get]

Definition at line 649 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextColumn2Row1 [get]

Definition at line 644 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextColumn2Row2 [get]

Definition at line 646 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextColumn2Row3 [get]

Definition at line 648 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextColumn2Row4 [get]

Definition at line 650 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText02::TextHeading [get]

Definition at line 642 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText03 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText03
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText03 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText03 ()
TileWideText03 ()

Properties

INotificationContentText TextHeadingWrap [get]

Detailed Description

Definition at line 653 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText03::TileWideText03 ( ) [inline]

Definition at line 655 of file TileContent.cs.

                                : base(templateName: "TileWideText03", imageCount: 0, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWideText03::TileWideText03 ( ) [inline]

Definition at line 655 of file TileContent.cs.

                                : base(templateName: "TileWideText03", imageCount: 0, textCount: 1)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText03::TextHeadingWrap [get]

Definition at line 659 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText04 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText04
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText04 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText04 ()
TileWideText04 ()

Properties

INotificationContentText TextBodyWrap [get]

Detailed Description

Definition at line 662 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText04::TileWideText04 ( ) [inline]

Definition at line 664 of file TileContent.cs.

                                : base(templateName: "TileWideText04", imageCount: 0, textCount: 1)
        {
        }

NotificationsExtensions::TileContent::TileWideText04::TileWideText04 ( ) [inline]

Definition at line 664 of file TileContent.cs.

                                : base(templateName: "TileWideText04", imageCount: 0, textCount: 1)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText04::TextBodyWrap [get]

Definition at line 668 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText05 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText05
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText05 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText05 ()
TileWideText05 ()

Properties

INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextBody3 [get]
INotificationContentText | TextBody4 [get]
INotificationContentText | TextBody5 [get]

Detailed Description

Definition at line 671 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText05::TileWideText05 ( ) [inline]

Definition at line 673 of file TileContent.cs.

                                : base(templateName: "TileWideText05", imageCount: 0, textCount: 5)
        {
        }

NotificationsExtensions::TileContent::TileWideText05::TileWideText05 ( ) [inline]

Definition at line 673 of file TileContent.cs.

                                : base(templateName: "TileWideText05", imageCount: 0, textCount: 5)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText05::TextBody1 [get]

Definition at line 677 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText05::TextBody2 [get]

Definition at line 678 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText05::TextBody3 [get]

Definition at line 679 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText05::TextBody4 [get]

Definition at line 680 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText05::TextBody5 [get]

Definition at line 681 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText06 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText06
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText06 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText06 ()
TileWideText06 ()

Properties

INotificationContentText | TextColumn1Row1 [get]
INotificationContentText | TextColumn1Row2 [get]
INotificationContentText | TextColumn1Row3 [get]
INotificationContentText | TextColumn1Row4 [get]
INotificationContentText | TextColumn1Row5 [get]
INotificationContentText | TextColumn2Row1 [get]
INotificationContentText | TextColumn2Row2 [get]
INotificationContentText | TextColumn2Row3 [get]
INotificationContentText | TextColumn2Row4 [get]
INotificationContentText | TextColumn2Row5 [get]

Detailed Description

Definition at line 684 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText06::TileWideText06 ( ) [inline]

Definition at line 686 of file TileContent.cs.

                                : base(templateName: "TileWideText06", imageCount: 0, textCount: 10)
        {
        }

NotificationsExtensions::TileContent::TileWideText06::TileWideText06 ( ) [inline]

Definition at line 686 of file TileContent.cs.

                                : base(templateName: "TileWideText06", imageCount: 0, textCount: 10)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn1Row1 [get]

Definition at line 690 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn1Row2 [get]

Definition at line 692 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn1Row3 [get]

Definition at line 694 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn1Row4 [get]

Definition at line 696 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn1Row5 [get]

Definition at line 698 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn2Row1 [get]

Definition at line 691 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn2Row2 [get]

Definition at line 693 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn2Row3 [get]

Definition at line 695 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn2Row4 [get]

Definition at line 697 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText06::TextColumn2Row5 [get]

Definition at line 699 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText07 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText07
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText07 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText07 ()
TileWideText07 ()

Properties

INotificationContentText | TextColumn2Row1 [get]
INotificationContentText | TextColumn2Row2 [get]
INotificationContentText | TextColumn2Row3 [get]
INotificationContentText | TextColumn2Row4 [get]
INotificationContentText | TextHeading [get]
INotificationContentText | TextShortColumn1Row1 [get]
INotificationContentText | TextShortColumn1Row2 [get]
INotificationContentText | TextShortColumn1Row3 [get]
INotificationContentText | TextShortColumn1Row4 [get]

Detailed Description

Definition at line 702 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText07::TileWideText07 ( ) [inline]

Definition at line 704 of file TileContent.cs.

                                : base(templateName: "TileWideText07", imageCount: 0, textCount: 9)
        {
        }

NotificationsExtensions::TileContent::TileWideText07::TileWideText07 ( ) [inline]

Definition at line 704 of file TileContent.cs.

                                : base(templateName: "TileWideText07", imageCount: 0, textCount: 9)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextColumn2Row1 [get]

Definition at line 710 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextColumn2Row2 [get]

Definition at line 712 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextColumn2Row3 [get]

Definition at line 714 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextColumn2Row4 [get]

Definition at line 716 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextHeading [get]

Definition at line 708 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextShortColumn1Row1 [get]

Definition at line 709 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextShortColumn1Row2 [get]

Definition at line 711 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextShortColumn1Row3 [get]

Definition at line 713 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText07::TextShortColumn1Row4 [get]

Definition at line 715 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText08 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText08
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText08 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText08 ()
TileWideText08 ()

Properties

INotificationContentText | TextColumn2Row1 [get]
INotificationContentText | TextColumn2Row2 [get]
INotificationContentText | TextColumn2Row3 [get]
INotificationContentText | TextColumn2Row4 [get]
INotificationContentText | TextColumn2Row5 [get]
INotificationContentText | TextShortColumn1Row1 [get]
INotificationContentText | TextShortColumn1Row2 [get]
INotificationContentText | TextShortColumn1Row3 [get]
INotificationContentText | TextShortColumn1Row4 [get]
INotificationContentText | TextShortColumn1Row5 [get]

Detailed Description

Definition at line 719 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText08::TileWideText08 ( ) [inline]

Definition at line 721 of file TileContent.cs.

                                : base(templateName: "TileWideText08", imageCount: 0, textCount: 10)
        {
        }

NotificationsExtensions::TileContent::TileWideText08::TileWideText08 ( ) [inline]

Definition at line 721 of file TileContent.cs.

                                : base(templateName: "TileWideText08", imageCount: 0, textCount: 10)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextColumn2Row1 [get]

Definition at line 726 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextColumn2Row2 [get]

Definition at line 728 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextColumn2Row3 [get]

Definition at line 730 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextColumn2Row4 [get]

Definition at line 732 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextColumn2Row5 [get]

Definition at line 734 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextShortColumn1Row1 [get]

Definition at line 725 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextShortColumn1Row2 [get]

Definition at line 727 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextShortColumn1Row3 [get]

Definition at line 729 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextShortColumn1Row4 [get]

Definition at line 731 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText08::TextShortColumn1Row5 [get]

Definition at line 733 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText09 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText09
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText09 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText09 ()
TileWideText09 ()

Properties

INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 737 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText09::TileWideText09 ( ) [inline]

Definition at line 739 of file TileContent.cs.

                                : base(templateName: "TileWideText09", imageCount: 0, textCount: 2)
        {
        }

NotificationsExtensions::TileContent::TileWideText09::TileWideText09 ( ) [inline]

Definition at line 739 of file TileContent.cs.

                                : base(templateName: "TileWideText09", imageCount: 0, textCount: 2)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText09::TextBodyWrap [get]

Definition at line 744 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText09::TextHeading [get]

Definition at line 743 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText10 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText10
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText10 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText10 ()
TileWideText10 ()

Properties

INotificationContentText | TextColumn2Row1 [get]
INotificationContentText | TextColumn2Row2 [get]
INotificationContentText | TextColumn2Row3 [get]
INotificationContentText | TextColumn2Row4 [get]
INotificationContentText | TextHeading [get]
INotificationContentText | TextPrefixColumn1Row1 [get]
INotificationContentText | TextPrefixColumn1Row2 [get]
INotificationContentText | TextPrefixColumn1Row3 [get]
INotificationContentText | TextPrefixColumn1Row4 [get]

Detailed Description

Definition at line 747 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText10::TileWideText10 ( ) [inline]

Definition at line 749 of file TileContent.cs.

                                : base(templateName: "TileWideText10", imageCount: 0, textCount: 9)
        {
        }

NotificationsExtensions::TileContent::TileWideText10::TileWideText10 ( ) [inline]

Definition at line 749 of file TileContent.cs.

                                : base(templateName: "TileWideText10", imageCount: 0, textCount: 9)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextColumn2Row1 [get]

Definition at line 755 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextColumn2Row2 [get]

Definition at line 757 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextColumn2Row3 [get]

Definition at line 759 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextColumn2Row4 [get]

Definition at line 761 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextHeading [get]

Definition at line 753 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextPrefixColumn1Row1 [get]

Definition at line 754 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextPrefixColumn1Row2 [get]

Definition at line 756 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextPrefixColumn1Row3 [get]

Definition at line 758 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText10::TextPrefixColumn1Row4 [get]

Definition at line 760 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent::TileWideText11 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • TileContent
  • NotificationsExtensions::TileContent::TileWideText11
Public Member Functions | Properties

NotificationsExtensions::TileContent::TileWideText11 Class Reference

Inherits NotificationsExtensions::TileContent::TileWideBase, and NotificationsExtensions::TileContent::TileWideBase.

List of all members.

Public Member Functions

TileWideText11 ()
TileWideText11 ()

Properties

INotificationContentText | TextColumn2Row1 [get]
INotificationContentText | TextColumn2Row2 [get]
INotificationContentText | TextColumn2Row3 [get]
INotificationContentText | TextColumn2Row4 [get]
INotificationContentText | TextColumn2Row5 [get]
INotificationContentText | TextPrefixColumn1Row1 [get]
INotificationContentText | TextPrefixColumn1Row2 [get]
INotificationContentText | TextPrefixColumn1Row3 [get]
INotificationContentText | TextPrefixColumn1Row4 [get]
INotificationContentText | TextPrefixColumn1Row5 [get]

Detailed Description

Definition at line 764 of file TileContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::TileContent::TileWideText11::TileWideText11 ( ) [inline]

Definition at line 766 of file TileContent.cs.

                                : base(templateName: "TileWideText11", imageCount: 0, textCount: 10)
        {
        }

NotificationsExtensions::TileContent::TileWideText11::TileWideText11 ( ) [inline]

Definition at line 766 of file TileContent.cs.

                                : base(templateName: "TileWideText11", imageCount: 0, textCount: 10)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextColumn2Row1 [get]

Definition at line 771 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextColumn2Row2 [get]

Definition at line 773 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextColumn2Row3 [get]

Definition at line 775 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextColumn2Row4 [get]

Definition at line 777 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextColumn2Row5 [get]

Definition at line 779 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextPrefixColumn1Row1 [get]

Definition at line 770 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextPrefixColumn1Row2 [get]

Definition at line 772 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextPrefixColumn1Row3 [get]

Definition at line 774 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextPrefixColumn1Row4 [get]

Definition at line 776 of file TileContent.cs.

INotificationContentText NotificationsExtensions::TileContent::TileWideText11::TextPrefixColumn1Row5 [get]

Definition at line 778 of file TileContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastAudio Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastAudio
Properties | Private Member Functions | Private Attributes

NotificationsExtensions::ToastContent::ToastAudio Class Reference

List of all members.

Properties

ToastAudioContent | Content [get, set]
bool | Loop [get, set]

Private Member Functions

internal | ToastAudio ()
internal | ToastAudio ()

Private Attributes

ToastAudioContent | m_Content = ToastAudioContent.Default
bool | m_Loop = false

Detailed Description

Definition at line 17 of file ToastContent.cs.

Constructor & Destructor Documentation

internal NotificationsExtensions::ToastContent::ToastAudio::ToastAudio ( ) [inline, private]

Definition at line 19 of file ToastContent.cs.

{ }

internal NotificationsExtensions::ToastContent::ToastAudio::ToastAudio ( ) [inline, private]

Definition at line 19 of file ToastContent.cs.

{ }

Member Data Documentation

ToastAudioContent NotificationsExtensions::ToastContent::ToastAudio::m_Content = ToastAudioContent.Default [private]

Definition at line 40 of file ToastContent.cs.

bool NotificationsExtensions::ToastContent::ToastAudio::m_Loop = false [private]

Definition at line 41 of file ToastContent.cs.

Property Documentation

ToastAudioContent NotificationsExtensions::ToastContent::ToastAudio::Content [get, set]

Definition at line 22 of file ToastContent.cs.

bool NotificationsExtensions::ToastContent::ToastAudio::Loop [get, set]

Definition at line 35 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastImageAndText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastImageAndText01
Public Member Functions | Properties

NotificationsExtensions::ToastContent::ToastImageAndText01 Class Reference

Inherits NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

ToastImageAndText01 ()
ToastImageAndText01 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]

Detailed Description

Definition at line 209 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastImageAndText01::ToastImageAndText01 ( ) [inline]

Definition at line 211 of file ToastContent.cs.

                                     : base(templateName: "ToastImageAndText01", imageCount: 1, textCount: 1)
        {
        }

NotificationsExtensions::ToastContent::ToastImageAndText01::ToastImageAndText01 ( ) [inline]

Definition at line 211 of file ToastContent.cs.

                                     : base(templateName: "ToastImageAndText01", imageCount: 1, textCount: 1)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::ToastContent::ToastImageAndText01::Image [get]

Definition at line 215 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastImageAndText01::TextBodyWrap [get]

Definition at line 217 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastImageAndText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastImageAndText02
Public Member Functions | Properties

NotificationsExtensions::ToastContent::ToastImageAndText02 Class Reference

Inherits NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

ToastImageAndText02 ()
ToastImageAndText02 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 220 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastImageAndText02::ToastImageAndText02 ( ) [inline]

Definition at line 222 of file ToastContent.cs.

                                     : base(templateName: "ToastImageAndText02", imageCount: 1, textCount: 2)
        {
        }

NotificationsExtensions::ToastContent::ToastImageAndText02::ToastImageAndText02 ( ) [inline]

Definition at line 222 of file ToastContent.cs.

                                     : base(templateName: "ToastImageAndText02", imageCount: 1, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::ToastContent::ToastImageAndText02::Image [get]

Definition at line 226 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastImageAndText02::TextBodyWrap [get]

Definition at line 229 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastImageAndText02::TextHeading [get]

Definition at line 228 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastImageAndText03 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastImageAndText03
Public Member Functions | Properties

NotificationsExtensions::ToastContent::ToastImageAndText03 Class Reference

Inherits NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

ToastImageAndText03 ()
ToastImageAndText03 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBody [get]
INotificationContentText | TextHeadingWrap [get]

Detailed Description

Definition at line 232 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastImageAndText03::ToastImageAndText03 ( ) [inline]

Definition at line 234 of file ToastContent.cs.

                                     : base(templateName: "ToastImageAndText03", imageCount: 1, textCount: 2)
        {
        }

NotificationsExtensions::ToastContent::ToastImageAndText03::ToastImageAndText03 ( ) [inline]

Definition at line 234 of file ToastContent.cs.

                                     : base(templateName: "ToastImageAndText03", imageCount: 1, textCount: 2)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::ToastContent::ToastImageAndText03::Image [get]

Definition at line 238 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastImageAndText03::TextBody [get]

Definition at line 241 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastImageAndText03::TextHeadingWrap [get]

Definition at line 240 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastImageAndText04 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastImageAndText04
Public Member Functions | Properties

NotificationsExtensions::ToastContent::ToastImageAndText04 Class Reference

Inherits NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

ToastImageAndText04 ()
ToastImageAndText04 ()

Properties

INotificationContentImage | Image [get]
INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 244 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastImageAndText04::ToastImageAndText04 ( ) [inline]

Definition at line 246 of file ToastContent.cs.

                                     : base(templateName: "ToastImageAndText04", imageCount: 1, textCount: 3)
        {
        }

NotificationsExtensions::ToastContent::ToastImageAndText04::ToastImageAndText04 ( ) [inline]

Definition at line 246 of file ToastContent.cs.

                                     : base(templateName: "ToastImageAndText04", imageCount: 1, textCount: 3)
        {
        }

Property Documentation

INotificationContentImage NotificationsExtensions::ToastContent::ToastImageAndText04::Image [get]

Definition at line 250 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastImageAndText04::TextBody1 [get]

Definition at line 253 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastImageAndText04::TextBody2 [get]

Definition at line 254 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastImageAndText04::TextHeading [get]

Definition at line 252 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastNotificationBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastNotificationBase
Public Member Functions | Properties | Private Member Functions | Private Attributes

NotificationsExtensions::ToastContent::ToastNotificationBase Class Reference

Inherits NotificationsExtensions::NotificationBase, and NotificationsExtensions::NotificationBase.

Inherited by NotificationsExtensions::ToastContent::ToastImageAndText01, NotificationsExtensions::ToastContent::ToastImageAndText01, NotificationsExtensions::ToastContent::ToastImageAndText02, NotificationsExtensions::ToastContent::ToastImageAndText02, NotificationsExtensions::ToastContent::ToastImageAndText03, NotificationsExtensions::ToastContent::ToastImageAndText03, NotificationsExtensions::ToastContent::ToastImageAndText04, NotificationsExtensions::ToastContent::ToastImageAndText04, NotificationsExtensions::ToastContent::ToastText01, NotificationsExtensions::ToastContent::ToastText01, NotificationsExtensions::ToastContent::ToastText02, NotificationsExtensions::ToastContent::ToastText02, NotificationsExtensions::ToastContent::ToastText03, NotificationsExtensions::ToastContent::ToastText03, NotificationsExtensions::ToastContent::ToastText04, and NotificationsExtensions::ToastContent::ToastText04.

List of all members.

Public Member Functions

ToastNotificationBase (string templateName, int imageCount, int textCount)
ToastNotificationBase (string templateName, int imageCount, int textCount)
ToastNotification | CreateNotification ()
ToastNotification | CreateNotification ()
override string | GetContent ()
override string | GetContent ()

Properties

IToastAudio | Audio [get]
ToastDuration | Duration [get, set]
string | Launch [get, set]

Private Member Functions

void | AppendAudioTag (StringBuilder builder)
void | AppendAudioTag (StringBuilder builder)
bool | AudioSrcIsLooping ()
bool | AudioSrcIsLooping ()
void | ValidateAudio ()
void | ValidateAudio ()

Private Attributes

IToastAudio | m_Audio = new ToastAudio()
ToastDuration | m_Duration = ToastDuration.Short
string | m_Launch

Detailed Description

Definition at line 44 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastNotificationBase::ToastNotificationBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline]

Definition at line 46 of file ToastContent.cs.

                                                                                : base(templateName, imageCount, textCount)
        {
        }

NotificationsExtensions::ToastContent::ToastNotificationBase::ToastNotificationBase | ( | string | templateName,
 |  | int | imageCount,
 |  | int | textCount |
 | ) |  |  | [inline]

Definition at line 46 of file ToastContent.cs.

                                                                                : base(templateName, imageCount, textCount)
        {
        }

Member Function Documentation

void NotificationsExtensions::ToastContent::ToastNotificationBase::AppendAudioTag ( StringBuilder builder ) [inline, private]

Definition at line 77 of file ToastContent.cs.

        {
            if (Audio.Content != ToastAudioContent.Default)
            {
                builder.Append("<audio");
                if (Audio.Content == ToastAudioContent.Silent)
                {
                    builder.Append(" silent='true'/>");
                }
                else
                {
                    if (Audio.Loop == true)
                    {
                        builder.Append(" loop='true'");
                    }

                    // The default looping sound is LoopingCall - save size by not adding it
                    if (Audio.Content != ToastAudioContent.LoopingCall)
                    {
                        string audioSrc = null;
                        switch (Audio.Content)
                        {
                            case ToastAudioContent.IM:
                                audioSrc = "ms-winsoundevent:Notification.IM";
                                break;
                            case ToastAudioContent.Mail:
                                audioSrc = "ms-winsoundevent:Notification.Mail";
                                break;
                            case ToastAudioContent.Reminder:
                                audioSrc = "ms-winsoundevent:Notification.Reminder";
                                break;
                            case ToastAudioContent.SMS:
                                audioSrc = "ms-winsoundevent:Notification.SMS";
                                break;
                            case ToastAudioContent.LoopingAlarm:
                                audioSrc = "ms-winsoundevent:Notification.Looping.Alarm";
                                break;
                            case ToastAudioContent.LoopingAlarm2:
                                audioSrc = "ms-winsoundevent:Notification.Looping.Alarm2";
                                break;
                            case ToastAudioContent.LoopingCall:
                                audioSrc = "ms-winsoundevent:Notification.Looping.Call";
                                break;
                            case ToastAudioContent.LoopingCall2:
                                audioSrc = "ms-winsoundevent:Notification.Looping.Call2";
                                break;
                        }
                        builder.AppendFormat(" src='{0}'", audioSrc);
                    }
                }
                builder.Append("/>");
            }
        }

void NotificationsExtensions::ToastContent::ToastNotificationBase::AppendAudioTag ( StringBuilder builder ) [inline, private]

Definition at line 77 of file ToastContent.cs.

        {
            if (Audio.Content != ToastAudioContent.Default)
            {
                builder.Append("<audio");
                if (Audio.Content == ToastAudioContent.Silent)
                {
                    builder.Append(" silent='true'/>");
                }
                else
                {
                    if (Audio.Loop == true)
                    {
                        builder.Append(" loop='true'");
                    }

                    // The default looping sound is LoopingCall - save size by not adding it
                    if (Audio.Content != ToastAudioContent.LoopingCall)
                    {
                        string audioSrc = null;
                        switch (Audio.Content)
                        {
                            case ToastAudioContent.IM:
                                audioSrc = "ms-winsoundevent:Notification.IM";
                                break;
                            case ToastAudioContent.Mail:
                                audioSrc = "ms-winsoundevent:Notification.Mail";
                                break;
                            case ToastAudioContent.Reminder:
                                audioSrc = "ms-winsoundevent:Notification.Reminder";
                                break;
                            case ToastAudioContent.SMS:
                                audioSrc = "ms-winsoundevent:Notification.SMS";
                                break;
                            case ToastAudioContent.LoopingAlarm:
                                audioSrc = "ms-winsoundevent:Notification.Looping.Alarm";
                                break;
                            case ToastAudioContent.LoopingAlarm2:
                                audioSrc = "ms-winsoundevent:Notification.Looping.Alarm2";
                                break;
                            case ToastAudioContent.LoopingCall:
                                audioSrc = "ms-winsoundevent:Notification.Looping.Call";
                                break;
                            case ToastAudioContent.LoopingCall2:
                                audioSrc = "ms-winsoundevent:Notification.Looping.Call2";
                                break;
                        }
                        builder.AppendFormat(" src='{0}'", audioSrc);
                    }
                }
                builder.Append("/>");
            }
        }

bool NotificationsExtensions::ToastContent::ToastNotificationBase::AudioSrcIsLooping ( ) [inline, private]

Definition at line 50 of file ToastContent.cs.

        {
            return (Audio.Content == ToastAudioContent.LoopingAlarm) || (Audio.Content == ToastAudioContent.LoopingAlarm2) ||
                (Audio.Content == ToastAudioContent.LoopingCall) || (Audio.Content == ToastAudioContent.LoopingCall2);
        }

bool NotificationsExtensions::ToastContent::ToastNotificationBase::AudioSrcIsLooping ( ) [inline, private]

Definition at line 50 of file ToastContent.cs.

        {
            return (Audio.Content == ToastAudioContent.LoopingAlarm) || (Audio.Content == ToastAudioContent.LoopingAlarm2) ||
                (Audio.Content == ToastAudioContent.LoopingCall) || (Audio.Content == ToastAudioContent.LoopingCall2);
        }

ToastNotification NotificationsExtensions::ToastContent::ToastNotificationBase::CreateNotification ( ) [inline]

Definition at line 172 of file ToastContent.cs.

        {
            XmlDocument xmlDoc = new XmlDocument();
            xmlDoc.LoadXml(GetContent());
            return new ToastNotification(xmlDoc);
        }

ToastNotification NotificationsExtensions::ToastContent::ToastNotificationBase::CreateNotification ( ) [inline]

Definition at line 172 of file ToastContent.cs.

        {
            XmlDocument xmlDoc = new XmlDocument();
            xmlDoc.LoadXml(GetContent());
            return new ToastNotification(xmlDoc);
        }

override string NotificationsExtensions::ToastContent::ToastNotificationBase::GetContent ( ) [inline, virtual]

Implements NotificationsExtensions::NotificationBase.

Definition at line 131 of file ToastContent.cs.

        {
            ValidateAudio();

            StringBuilder builder = new StringBuilder("<toast");
            if (!String.IsNullOrEmpty(Launch))
            {
                builder.AppendFormat(" launch='{0}'", Util.HttpEncode(Launch));
            }
            if (Duration != ToastDuration.Short)
            {
                builder.AppendFormat(" duration='{0}'", Duration.ToString().ToLowerInvariant());
            }
            builder.Append(">");

            builder.AppendFormat("<visual version='{0}'", Util.NOTIFICATION_CONTENT_VERSION);
            if (!String.IsNullOrWhiteSpace(Lang))
            {
                builder.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
            }
            if (!String.IsNullOrWhiteSpace(BaseUri))
            {
                builder.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
            }
            if (AddImageQuery)
            {
                builder.AppendFormat(" addImageQuery='true'");
            }
            builder.Append(">");

            builder.AppendFormat("<binding template='{0}'>{1}</binding>", TemplateName, SerializeProperties(Lang, BaseUri, AddImageQuery));
            builder.Append("</visual>");

            AppendAudioTag(builder);

            builder.Append("</toast>");

            return builder.ToString();
        }

override string NotificationsExtensions::ToastContent::ToastNotificationBase::GetContent ( ) [inline, virtual]

Implements NotificationsExtensions::NotificationBase.

Definition at line 131 of file ToastContent.cs.

        {
            ValidateAudio();

            StringBuilder builder = new StringBuilder("<toast");
            if (!String.IsNullOrEmpty(Launch))
            {
                builder.AppendFormat(" launch='{0}'", Util.HttpEncode(Launch));
            }
            if (Duration != ToastDuration.Short)
            {
                builder.AppendFormat(" duration='{0}'", Duration.ToString().ToLowerInvariant());
            }
            builder.Append(">");

            builder.AppendFormat("<visual version='{0}'", Util.NOTIFICATION_CONTENT_VERSION);
            if (!String.IsNullOrWhiteSpace(Lang))
            {
                builder.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
            }
            if (!String.IsNullOrWhiteSpace(BaseUri))
            {
                builder.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
            }
            if (AddImageQuery)
            {
                builder.AppendFormat(" addImageQuery='true'");
            }
            builder.Append(">");

            builder.AppendFormat("<binding template='{0}'>{1}</binding>", TemplateName, SerializeProperties(Lang, BaseUri, AddImageQuery));
            builder.Append("</visual>");

            AppendAudioTag(builder);

            builder.Append("</toast>");

            return builder.ToString();
        }

void NotificationsExtensions::ToastContent::ToastNotificationBase::ValidateAudio ( ) [inline, private]

Definition at line 56 of file ToastContent.cs.

        {
            if (StrictValidation)
            {
                if (Audio.Loop && Duration != ToastDuration.Long)
                {
                    throw new NotificationContentValidationException("Looping audio is only available for long duration toasts.");
                }
                if (Audio.Loop && !AudioSrcIsLooping())
                {
                    throw new NotificationContentValidationException(
                        "A looping audio src must be chosen if the looping audio property is set.");
                }
                if (!Audio.Loop && AudioSrcIsLooping())
                {
                    throw new NotificationContentValidationException(
                        "The looping audio property needs to be set if a looping audio src is chosen.");
                }
            }
        }

void NotificationsExtensions::ToastContent::ToastNotificationBase::ValidateAudio ( ) [inline, private]

Definition at line 56 of file ToastContent.cs.

        {
            if (StrictValidation)
            {
                if (Audio.Loop && Duration != ToastDuration.Long)
                {
                    throw new NotificationContentValidationException("Looping audio is only available for long duration toasts.");
                }
                if (Audio.Loop && !AudioSrcIsLooping())
                {
                    throw new NotificationContentValidationException(
                        "A looping audio src must be chosen if the looping audio property is set.");
                }
                if (!Audio.Loop && AudioSrcIsLooping())
                {
                    throw new NotificationContentValidationException(
                        "The looping audio property needs to be set if a looping audio src is chosen.");
                }
            }
        }

Member Data Documentation

IToastAudio NotificationsExtensions::ToastContent::ToastNotificationBase::m_Audio = new ToastAudio() [private]

Definition at line 205 of file ToastContent.cs.

ToastDuration NotificationsExtensions::ToastContent::ToastNotificationBase::m_Duration = ToastDuration.Short [private]

Definition at line 206 of file ToastContent.cs.

string NotificationsExtensions::ToastContent::ToastNotificationBase::m_Launch [private]

Definition at line 204 of file ToastContent.cs.

Property Documentation

IToastAudio NotificationsExtensions::ToastContent::ToastNotificationBase::Audio [get]

Definition at line 181 of file ToastContent.cs.

ToastDuration NotificationsExtensions::ToastContent::ToastNotificationBase::Duration [get, set]

Definition at line 192 of file ToastContent.cs.

string NotificationsExtensions::ToastContent::ToastNotificationBase::Launch [get, set]

Definition at line 186 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastText01 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastText01
Public Member Functions | Properties

NotificationsExtensions::ToastContent::ToastText01 Class Reference

Inherits NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

ToastText01 ()
ToastText01 ()

Properties

INotificationContentText TextBodyWrap [get]

Detailed Description

Definition at line 257 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastText01::ToastText01 ( ) [inline]

Definition at line 259 of file ToastContent.cs.

                             : base(templateName: "ToastText01", imageCount: 0, textCount: 1)
        {
        }

NotificationsExtensions::ToastContent::ToastText01::ToastText01 ( ) [inline]

Definition at line 259 of file ToastContent.cs.

                             : base(templateName: "ToastText01", imageCount: 0, textCount: 1)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::ToastContent::ToastText01::TextBodyWrap [get]

Definition at line 263 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastText02 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastText02
Public Member Functions | Properties

NotificationsExtensions::ToastContent::ToastText02 Class Reference

Inherits NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

ToastText02 ()
ToastText02 ()

Properties

INotificationContentText | TextBodyWrap [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 266 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastText02::ToastText02 ( ) [inline]

Definition at line 268 of file ToastContent.cs.

                             : base(templateName: "ToastText02", imageCount: 0, textCount: 2)
        {
        }

NotificationsExtensions::ToastContent::ToastText02::ToastText02 ( ) [inline]

Definition at line 268 of file ToastContent.cs.

                             : base(templateName: "ToastText02", imageCount: 0, textCount: 2)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::ToastContent::ToastText02::TextBodyWrap [get]

Definition at line 273 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastText02::TextHeading [get]

Definition at line 272 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastText03 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastText03
Public Member Functions | Properties

NotificationsExtensions::ToastContent::ToastText03 Class Reference

Inherits NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

ToastText03 ()
ToastText03 ()

Properties

INotificationContentText | TextBody [get]
INotificationContentText | TextHeadingWrap [get]

Detailed Description

Definition at line 276 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastText03::ToastText03 ( ) [inline]

Definition at line 278 of file ToastContent.cs.

                             : base(templateName: "ToastText03", imageCount: 0, textCount: 2)
        {
        }

NotificationsExtensions::ToastContent::ToastText03::ToastText03 ( ) [inline]

Definition at line 278 of file ToastContent.cs.

                             : base(templateName: "ToastText03", imageCount: 0, textCount: 2)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::ToastContent::ToastText03::TextBody [get]

Definition at line 283 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastText03::TextHeadingWrap [get]

Definition at line 282 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent::ToastText04 Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • NotificationsExtensions
  • ToastContent
  • NotificationsExtensions::ToastContent::ToastText04
Public Member Functions | Properties

NotificationsExtensions::ToastContent::ToastText04 Class Reference

Inherits NotificationsExtensions::ToastContent::ToastNotificationBase, and NotificationsExtensions::ToastContent::ToastNotificationBase.

List of all members.

Public Member Functions

ToastText04 ()
ToastText04 ()

Properties

INotificationContentText | TextBody1 [get]
INotificationContentText | TextBody2 [get]
INotificationContentText | TextHeading [get]

Detailed Description

Definition at line 286 of file ToastContent.cs.

Constructor & Destructor Documentation

NotificationsExtensions::ToastContent::ToastText04::ToastText04 ( ) [inline]

Definition at line 288 of file ToastContent.cs.

                             : base(templateName: "ToastText04", imageCount: 0, textCount: 3)
        {
        }

NotificationsExtensions::ToastContent::ToastText04::ToastText04 ( ) [inline]

Definition at line 288 of file ToastContent.cs.

                             : base(templateName: "ToastText04", imageCount: 0, textCount: 3)
        {
        }

Property Documentation

INotificationContentText NotificationsExtensions::ToastContent::ToastText04::TextBody1 [get]

Definition at line 293 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastText04::TextBody2 [get]

Definition at line 294 of file ToastContent.cs.

INotificationContentText NotificationsExtensions::ToastContent::ToastText04::TextHeading [get]

Definition at line 292 of file ToastContent.cs.

The documentation for this class was generated from the following files:
  • Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs
  • Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OfferReclaimAPI Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

OfferReclaimAPI Class Reference

#include "OfferReclaimAPI.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
void | OnResuming ()
void | OnSuspending ()
virtual void | Render () override
void | Update (float TimeTotal, float TimeDelta)

Public Attributes

internal | __pad0__: OfferReclaimAPI()

Private Attributes

BasicCamera m_Camera
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
unsigned int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_texture
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureSRV
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 23 of file OfferReclaimAPI.h.

Member Function Documentation

void OfferReclaimAPI::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 25 of file OfferReclaimAPI.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();
}

void OfferReclaimAPI::CreateDeviceResources ( ) [override, virtual]

Definition at line 30 of file OfferReclaimAPI.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        L"DXGI resource offer and reclaim sample"
        );

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    loader->LoadShader(
        L"SimpleVertexShader.cso",
        nullptr,
        0,
        &m_vertexShader,
        &m_inputLayout
        );

    // Create the vertex and index buffers for drawing the cube.

    BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());

    shapes->CreateCube(
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // Create the constant buffer for updating model and camera data.
    CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &constantBufferDescription,
            nullptr,             // leave the buffer uninitialized
            &m_constantBuffer
            )
        );

    loader->LoadShader(
        L"SimplePixelShader.cso",
        &m_pixelShader
        );

    loader->LoadTexture(
        L"texture.dds",
        &m_texture,
        &m_textureSRV
        );

    // Create the sampler.
    D3D11_SAMPLER_DESC samplerDescription;
    ZeroMemory(&samplerDescription, sizeof(D3D11_SAMPLER_DESC));
    samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.MipLODBias = 0.0f;
    samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
    samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDescription.BorderColor[0] = 0.0f;
    samplerDescription.BorderColor[1] = 0.0f;
    samplerDescription.BorderColor[2] = 0.0f;
    samplerDescription.BorderColor[3] = 0.0f;
    // allow use of all mip levels
    samplerDescription.MinLOD = 0;
    samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDescription,
            &m_sampler)
        );

    m_Camera = ref new BasicCamera();

    // To test the Reclaim code, force the discard of the allocation by setting the flag - D3D11_DEBUG_FEATURE_ALWAYS_DISCARD_OFFERED_RESOURCE
    // Also, enable Debug Layers by passing in the D3D11_CREATE_DEVICE_DEBUG flag into "creationFlags" in the CreateDevice call (see DirectXBase.cpp)
#ifdef _DEBUG
    ComPtr<ID3D11Debug> pDebug;
    DX::ThrowIfFailed(m_d3dDevice.As(&pDebug));
    pDebug->SetFeatureMask(D3D11_DEBUG_FEATURE_ALWAYS_DISCARD_OFFERED_RESOURCE);
#endif

}

void OfferReclaimAPI::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 122 of file OfferReclaimAPI.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // update the 3D projection matrix
    m_Camera->SetProjectionParameters(
        70.0f,                                                  // use a 70-degree vertical field of view
        m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
        0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
        100.0f                                                  // specify the farthest Z-distance at which to draw vertices
        );

    // save the new projection matrix to the constant buffer data struct
    m_Camera->GetProjectionMatrix(&m_constantBufferData.projection);

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void OfferReclaimAPI::OnResuming ( )

Definition at line 270 of file OfferReclaimAPI.cpp.

{
    static BOOL swapTexture = 1;
    ComPtr<IDXGIDevice2> pDXGIDevice;
    DX::ThrowIfFailed(m_d3dDevice.As(&pDXGIDevice));

    ComPtr<IDXGIResource> pDXGIResource;
    DX::ThrowIfFailed(m_texture.As(&pDXGIResource));

    // Call ReclaimResources API on the resource
    BOOL discarded;
    DX::ThrowIfFailed(pDXGIDevice->ReclaimResources(1, pDXGIResource.GetAddressOf(), &discarded));

    // Usage of ReclaimResources: check for BOOL discarded.
    // If discarded is 0, then it means that the texture resource is still around and we were able to reclaim it.
    // If discarded is 1, then we need to recreate the texture resource.

    if (discarded)
    {
        // Regenerate the texture as it has been discarded.
        BasicLoader^ loader = ref new BasicLoader (m_d3dDevice.Get());
        // Swap the texture on every discard in resume.
        if (swapTexture)
        {
            loader->LoadTexture("texture2.dds", &m_texture, &m_textureSRV);
        }
        else
        {
            loader->LoadTexture("texture.dds", &m_texture, &m_textureSRV);
        }
        swapTexture = !swapTexture;
    }
}

void OfferReclaimAPI::OnSuspending ( )

Definition at line 257 of file OfferReclaimAPI.cpp.

{
    ComPtr<IDXGIDevice2> pDXGIDevice;
    ComPtr<IDXGIResource> pDXGIResource;

    DX::ThrowIfFailed(m_d3dDevice.As(&pDXGIDevice));
    DX::ThrowIfFailed(m_texture.As(&pDXGIResource));

    // Call OfferResources on the resource
    DX::ThrowIfFailed(pDXGIDevice->OfferResources(1, pDXGIResource.GetAddressOf(), DXGI_OFFER_RESOURCE_PRIORITY_NORMAL));
}

void OfferReclaimAPI::Render ( ) [override, virtual]

Definition at line 140 of file OfferReclaimAPI.cpp.

{
    UINT stride = sizeof(BasicVertex);
    UINT offset = 0;

    // bind the render targets
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // clear both the render target and depth stencil to default values
    const float ClearColor[4] = {0.071f, 0.040f, 0.561f, 1.0f};

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        ClearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    // set the vertex and index buffers, and specify the way they define geometry
    m_d3dContext->IASetVertexBuffers(
        0,                              // starting at the first vertex buffer slot
        1,                              // set one vertex buffer binding
        m_vertexBuffer.GetAddressOf(),
        &stride,                        // specify the size in bytes of a single vertex
        &offset                         // specify the base vertex in the buffer
        );

    // set the index buffer
    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,   // unsigned short index format
        0                       // specify the base index in the buffer
        );

    // specify the way the vertex and index buffers define geometry
    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    // set the vertex shader stage state
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                              // starting at the first constant buffer slot
        1,                              // set one constant buffer binding
        m_constantBuffer.GetAddressOf()
        );

    // set the pixel shader stage state
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->PSSetShaderResources(
        0,                          // starting at the first shader resource slot
        1,                          // set one shader resource binding
        m_textureSRV.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,                          // starting at the first sampler slot
        1,                          // set one sampler binding
        m_sampler.GetAddressOf()
        );

    // draw the cube
    m_d3dContext->DrawIndexed(
        m_indexCount,   // draw all created vertices
        0,              // starting with the first vertex
        0               // and the first index
        );

    m_sampleOverlay->Render();
}

void OfferReclaimAPI::Update | ( | float | TimeTotal,
 |  | float | TimeDelta
 | ) |  |

Definition at line 230 of file OfferReclaimAPI.cpp.

{
    // update the model matrix based on the time
    m_constantBufferData.model = rotationY(-TimeTotal * 60.0f);

    // update the view matrix based on the camera position
    // note that for this sample, the camera position is fixed
    m_Camera->SetViewParameters(
        float3(0, 1.0f, 2.0f),
        float3(0, 0, 0),
        float3(0, 1, 0)
        );

    m_Camera->GetViewMatrix(&m_constantBufferData.view);

    // update the constant buffer with the new data
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_constantBufferData,
        0,
        0
        );
}

Member Data Documentation

internal OfferReclaimAPI::__pad0__

Definition at line 26 of file OfferReclaimAPI.h.

BasicCamera OfferReclaimAPI::m_Camera [private]

Definition at line 52 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> OfferReclaimAPI::m_constantBuffer [private]

Definition at line 48 of file OfferReclaimAPI.h.

ConstantBuffer OfferReclaimAPI::m_constantBufferData [private]

Definition at line 51 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> OfferReclaimAPI::m_indexBuffer [private]

Definition at line 42 of file OfferReclaimAPI.h.

unsigned int OfferReclaimAPI::m_indexCount [private]

Definition at line 50 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> OfferReclaimAPI::m_inputLayout [private]

Definition at line 40 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> OfferReclaimAPI::m_pixelShader [private]

Definition at line 44 of file OfferReclaimAPI.h.

SampleOverlay OfferReclaimAPI::m_sampleOverlay [private]

Definition at line 38 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> OfferReclaimAPI::m_sampler [private]

Definition at line 47 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> OfferReclaimAPI::m_texture [private]

Definition at line 45 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> OfferReclaimAPI::m_textureSRV [private]

Definition at line 46 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> OfferReclaimAPI::m_vertexBuffer [private]

Definition at line 41 of file OfferReclaimAPI.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> OfferReclaimAPI::m_vertexShader [private]

Definition at line 43 of file OfferReclaimAPI.h.

The documentation for this class was generated from the following files:
  • DXGI offer and reclaim resources/C++/OfferReclaimAPI.h
  • DXGI offer and reclaim resources/C++/OfferReclaimAPI.cpp
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OpQueue< T, TOperation > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Protected Member Functions | Protected Attributes

OpQueue< T, TOperation > Class Template Reference

#include "OpQueue.h"

List of all members.

Public Types

typedef ComPtrList< TOperation > | OpList
typedef ComPtrList< TOperation > | OpList
typedef ComPtrList< TOperation > | OpList

Public Member Functions

HRESULT | QueueOperation (TOperation *pOp)
HRESULT | QueueOperation (TOperation *pOp)
HRESULT | QueueOperation (TOperation *pOp)

Protected Member Functions

OpQueue (CRITICAL_SECTION &critsec)
OpQueue (CRITICAL_SECTION &critsec)
OpQueue (CRITICAL_SECTION &critsec)
virtual | ~OpQueue ()
virtual | ~OpQueue ()
virtual | ~OpQueue ()
virtual HRESULT | DispatchOperation (TOperation *pOp)=0
virtual HRESULT | DispatchOperation (TOperation *pOp)=0
virtual HRESULT | DispatchOperation (TOperation *pOp)=0
HRESULT | ProcessQueue ()
HRESULT | ProcessQueue ()
HRESULT | ProcessQueue ()
HRESULT | ProcessQueueAsync (IMFAsyncResult *pResult)
HRESULT | ProcessQueueAsync (IMFAsyncResult *pResult)
HRESULT | ProcessQueueAsync (IMFAsyncResult *pResult)
virtual HRESULT | ValidateOperation (TOperation *pOp)=0
virtual HRESULT | ValidateOperation (TOperation *pOp)=0
virtual HRESULT | ValidateOperation (TOperation *pOp)=0

Protected Attributes

CRITICAL_SECTION & | m_critsec
AsyncCallback< T > | m_OnProcessQueue
OpList m_OpQueue

Detailed Description

template<class T, class TOperation>
class OpQueue< T, TOperation >

Definition at line 99 of file OpQueue.h.

Member Typedef Documentation

template<class T, class TOperation>
typedef ComPtrList<TOperation> OpQueue< T, TOperation >::OpList

Definition at line 100 of file OpQueue.h.

template<class T, class TOperation>
typedef ComPtrList<TOperation> OpQueue< T, TOperation >::OpList

Definition at line 100 of file OpQueue.h.

template<class T, class TOperation>
typedef ComPtrList<TOperation> OpQueue< T, TOperation >::OpList

Definition at line 100 of file OpQueue.h.

Constructor & Destructor Documentation

template<class T, class TOperation>
OpQueue< T, TOperation >::OpQueue ( CRITICAL_SECTION & critsec ) [inline, protected]

Definition at line 112 of file OpQueue.h.

        : m_OnProcessQueue(static_cast<T *>(this), &OpQueue::ProcessQueueAsync),

template<class T, class TOperation>
virtual OpQueue< T, TOperation >::~OpQueue ( ) [inline, protected, virtual]

Definition at line 118 of file OpQueue.h.

    {
    }

template<class T, class TOperation>
OpQueue< T, TOperation >::OpQueue ( CRITICAL_SECTION & critsec ) [inline, protected]

Definition at line 112 of file OpQueue.h.

        : m_OnProcessQueue(static_cast<T *>(this), &OpQueue::ProcessQueueAsync),

template<class T, class TOperation>
virtual OpQueue< T, TOperation >::~OpQueue ( ) [inline, protected, virtual]

Definition at line 118 of file OpQueue.h.

    {
    }

template<class T, class TOperation>
OpQueue< T, TOperation >::OpQueue ( CRITICAL_SECTION & critsec ) [inline, protected]

Definition at line 112 of file OpQueue.h.

        : m_OnProcessQueue(static_cast<T *>(this), &OpQueue::ProcessQueueAsync),

template<class T, class TOperation>
virtual OpQueue< T, TOperation >::~OpQueue ( ) [inline, protected, virtual]

Definition at line 118 of file OpQueue.h.

    {
    }

Member Function Documentation

template<class T, class TOperation>
virtual HRESULT OpQueue< T, TOperation >::DispatchOperation ( TOperation * pOp ) [protected, pure virtual]

Implemented in CMPEG1Source, and CMPEG1Source.

template<class T, class TOperation>
virtual HRESULT OpQueue< T, TOperation >::DispatchOperation ( TOperation * pOp ) [protected, pure virtual]

Implemented in CMPEG1Source, and CMPEG1Source.

template<class T, class TOperation>
virtual HRESULT OpQueue< T, TOperation >::DispatchOperation ( TOperation * pOp ) [protected, pure virtual]

Implemented in CMPEG1Source, and CMPEG1Source.

template<class T , class TOperation >
HRESULT OpQueue< T, TOperation >::ProcessQueue ( ) [protected]

Definition at line 164 of file OpQueue.h.

{
    HRESULT hr = S_OK;
    if (m_OpQueue.GetCount() > 0)
    {
        hr = MFPutWorkItem2(
            MFASYNC_CALLBACK_QUEUE_STANDARD,    // Use the standard work queue.
            0,                                  // Default priority
            &m_OnProcessQueue,                  // Callback method.
            nullptr                             // State object.
            );
    }
    return hr;
}

template<class T, class TOperation>
HRESULT OpQueue< T, TOperation >::ProcessQueue ( ) [protected]
template<class T, class TOperation>
HRESULT OpQueue< T, TOperation >::ProcessQueue ( ) [protected]
template<class T, class TOperation>
HRESULT OpQueue< T, TOperation >::ProcessQueueAsync ( IMFAsyncResult * pResult ) [protected]
template<class T, class TOperation>
HRESULT OpQueue< T, TOperation >::ProcessQueueAsync ( IMFAsyncResult * pResult ) [protected]
template<class T , class TOperation >
HRESULT OpQueue< T, TOperation >::ProcessQueueAsync ( IMFAsyncResult * pResult ) [protected]

Definition at line 188 of file OpQueue.h.

{
    HRESULT hr = S_OK;
    TOperation *pOp = nullptr;

    EnterCriticalSection(&m_critsec);

    if (m_OpQueue.GetCount() > 0)
    {
        hr = m_OpQueue.GetFront(&pOp);

        if (SUCCEEDED(hr))
        {
            hr = ValidateOperation(pOp);
        }
        if (SUCCEEDED(hr))
        {
            hr = m_OpQueue.RemoveFront(nullptr);
        }
        if (SUCCEEDED(hr))
        {
            (void)DispatchOperation(pOp);
        }
    }

    if (pOp != nullptr)
    {
        pOp->Release();
    }

    LeaveCriticalSection(&m_critsec);
    return hr;
}

template<class T , class TOperation>
HRESULT OpQueue< T, TOperation >::QueueOperation ( TOperation * pOp )

Definition at line 139 of file OpQueue.h.

{
    HRESULT hr = S_OK;

    EnterCriticalSection(&m_critsec);

    hr = m_OpQueue.InsertBack(pOp);
    if (SUCCEEDED(hr))
    {
        hr = ProcessQueue();
    }

    LeaveCriticalSection(&m_critsec);
    return hr;
}

template<class T, class TOperation>
HRESULT OpQueue< T, TOperation >::QueueOperation ( TOperation * pOp )
template<class T, class TOperation>
HRESULT OpQueue< T, TOperation >::QueueOperation ( TOperation * pOp )
template<class T, class TOperation>
virtual HRESULT OpQueue< T, TOperation >::ValidateOperation ( TOperation * pOp ) [protected, pure virtual]

Implemented in CMPEG1Source, and CMPEG1Source.

template<class T, class TOperation>
virtual HRESULT OpQueue< T, TOperation >::ValidateOperation ( TOperation * pOp ) [protected, pure virtual]

Implemented in CMPEG1Source, and CMPEG1Source.

template<class T, class TOperation>
virtual HRESULT OpQueue< T, TOperation >::ValidateOperation ( TOperation * pOp ) [protected, pure virtual]

Implemented in CMPEG1Source, and CMPEG1Source.

Member Data Documentation

template<class T, class TOperation>
CRITICAL_SECTION & OpQueue< T, TOperation >::m_critsec [protected]

Definition at line 124 of file OpQueue.h.

template<class T, class TOperation>
AsyncCallback< T > OpQueue< T, TOperation >::m_OnProcessQueue [protected]

Definition at line 125 of file OpQueue.h.

template<class T, class TOperation>
OpList OpQueue< T, TOperation >::m_OpQueue [protected]

Definition at line 123 of file OpQueue.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/OpQueue.h
  • Media extensions/C++/MediaExtensions/Common/OpQueue.h
  • Real-time communication/C++/MediaExtensions/Common/OpQueue.h
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OutlineRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Private Member Functions | Private Attributes

OutlineRenderer Class Reference

#include "OutlineRenderer.h"

List of all members.

Public Member Functions

STDMETHOD() | DrawGlyphRun (void *, FLOAT baselineOriginX, FLOAT baselineOriginY, DWRITE_MEASURING_MODE, DWRITE_GLYPH_RUN const *glyphRun, DWRITE_GLYPH_RUN_DESCRIPTION const *, IUnknown *)
STDMETHOD() | DrawInlineObject (void *, FLOAT, FLOAT, IDWriteInlineObject *, BOOL, BOOL, IUnknown *)
STDMETHOD() | DrawStrikethrough (void *, FLOAT, FLOAT, DWRITE_STRIKETHROUGH const *, IUnknown *)
STDMETHOD() | DrawUnderline (void *, FLOAT, FLOAT, DWRITE_UNDERLINE const *, IUnknown *)
STDMETHOD() | GetCurrentTransform (void *, DWRITE_MATRIX *transform)
void | GetGeometry (ID2D1Geometry **ppGeometry)
STDMETHOD() | GetPixelsPerDip (void *, FLOAT *pixelsPerDip)
STDMETHOD() | IsPixelSnappingDisabled (void *, BOOL *isDisabled)
STDMETHOD() | QueryInterface (REFIID riid, _Outptr_ void **object) override
STDMETHOD_ (ULONG, Release)() override
STDMETHOD_ (ULONG, AddRef)() override

Static Public Member Functions

static void | CreateOutlineRenderer (_In_ ID2D1Factory *pFactory, _Outptr_ OutlineRenderer **ppOutlineRenderer)

Private Member Functions

OutlineRenderer (_In_ ID2D1Factory *pFactory)
void | AddGeometry (ID2D1Geometry *pGeometry)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Factory > 		m_pFactory
Microsoft::WRL::ComPtr
< ID2D1Geometry > 		m_pGeometry
ULONG | m_ref

Detailed Description

Definition at line 12 of file OutlineRenderer.h.

Constructor & Destructor Documentation

OutlineRenderer::OutlineRenderer ( _In_ ID2D1Factory * pFactory ) [private]

Definition at line 24 of file OutlineRenderer.cpp.

                                                            :
    m_pFactory(pFactory),
    m_ref(0)
{
}

Member Function Documentation

void OutlineRenderer::AddGeometry ( ID2D1Geometry * pGeometry ) [private]

Definition at line 185 of file OutlineRenderer.cpp.

{
    if (m_pGeometry == nullptr)
    {
        // Just save the geometry.
        m_pGeometry = ComPtr<ID2D1Geometry>(pGeometry);
    }
    else
    {
        // Combine the provided geometry with the saved geometry.

        ComPtr<ID2D1Factory> pFactory;
        m_pGeometry->GetFactory(&pFactory);

        ComPtr<ID2D1PathGeometry> pPathGeometry;
        DX::ThrowIfFailed(
            pFactory->CreatePathGeometry(&pPathGeometry)
            );

        ComPtr<ID2D1GeometrySink> pSink;
        DX::ThrowIfFailed(
            pPathGeometry->Open(&pSink)
            );

        DX::ThrowIfFailed(
            m_pGeometry->CombineWithGeometry(
                pGeometry,
                D2D1_COMBINE_MODE_UNION,
                nullptr, // world transform
                pSink.Get()
                )
            );

        DX::ThrowIfFailed(
            pSink->Close()
            );

        m_pGeometry = pPathGeometry;
    }
}

void OutlineRenderer::CreateOutlineRenderer | ( | _In_ ID2D1Factory * | pFactory,
 |  | _Outptr_ OutlineRenderer ** | ppOutlineRenderer |
 | ) |  |  | [static]

Definition at line 15 of file OutlineRenderer.cpp.

{
    *ppOutlineRenderer = new OutlineRenderer(pFactory);
    (*ppOutlineRenderer)->AddRef();
}

HRESULT OutlineRenderer::DrawGlyphRun | ( | void * | ,
 |  | FLOAT | baselineOriginX,
 |  | FLOAT | baselineOriginY,
 |  | DWRITE_MEASURING_MODE | ,
 |  | DWRITE_GLYPH_RUN const * | glyphRun,
 |  | DWRITE_GLYPH_RUN_DESCRIPTION const * | ,
 |  | IUnknown * |
 | ) |  |

Definition at line 30 of file OutlineRenderer.cpp.

{
    HRESULT hr;

    ComPtr<ID2D1PathGeometry> pPathGeometry;

    hr = m_pFactory->CreatePathGeometry(&pPathGeometry);

    if (SUCCEEDED(hr))
    {
        ComPtr<ID2D1GeometrySink> pSink;

        hr = pPathGeometry->Open(&pSink);

        if (SUCCEEDED(hr))
        {
            hr = glyphRun->fontFace->GetGlyphRunOutline(
                glyphRun->fontEmSize,
                glyphRun->glyphIndices,
                glyphRun->glyphAdvances,
                glyphRun->glyphOffsets,
                glyphRun->glyphCount,
                glyphRun->isSideways,
                (glyphRun->bidiLevel % 2) == 1,
                pSink.Get()
                );

            if (SUCCEEDED(hr))
            {
                hr = pSink->Close();

                if (SUCCEEDED(hr))
                {
                    ComPtr<ID2D1TransformedGeometry> pTransformedGeometry;

                    hr = m_pFactory->CreateTransformedGeometry(
                        pPathGeometry.Get(),
                        D2D1::Matrix3x2F::Translation(baselineOriginX, baselineOriginY),
                        &pTransformedGeometry
                        );

                    if (SUCCEEDED(hr))
                    {
                        AddGeometry(pTransformedGeometry.Get());
                    }
                }
            }
        }
    }

    return hr;
}

HRESULT OutlineRenderer::DrawInlineObject | ( | void * | ,
 |  | FLOAT | ,
 |  | FLOAT | ,
 |  | IDWriteInlineObject * | ,
 |  | BOOL | ,
 |  | BOOL | ,
 |  | IUnknown * |
 | ) |  |

Definition at line 115 of file OutlineRenderer.cpp.

{
    // Implement this to add support for inline objects.
    return E_NOTIMPL;
}

HRESULT OutlineRenderer::DrawStrikethrough | ( | void * | ,
 |  | FLOAT | ,
 |  | FLOAT | ,
 |  | DWRITE_STRIKETHROUGH const * | ,
 |  | IUnknown * |
 | ) |  |

Definition at line 103 of file OutlineRenderer.cpp.

{
    // Implement this to add support for strikethroughs.
    return E_NOTIMPL;
}

HRESULT OutlineRenderer::DrawUnderline | ( | void * | ,
 |  | FLOAT | ,
 |  | FLOAT | ,
 |  | DWRITE_UNDERLINE const * | ,
 |  | IUnknown * |
 | ) |  |

Definition at line 91 of file OutlineRenderer.cpp.

{
    // Implement this to add support for underlines.
    return E_NOTIMPL;
}

HRESULT OutlineRenderer::GetCurrentTransform | ( | void * | ,
 |  | DWRITE_MATRIX * | transform
 | ) |  |

Definition at line 138 of file OutlineRenderer.cpp.

{
    DWRITE_MATRIX matrix = {1, 0, 0, 1, 0, 0};
    *transform = matrix;
    return S_OK;
}

void OutlineRenderer::GetGeometry ( ID2D1Geometry ** ppGeometry )

Definition at line 157 of file OutlineRenderer.cpp.

{
    if (m_pGeometry)
    {
        *ppGeometry = m_pGeometry.Get();
        (*ppGeometry)->AddRef();
    }
    else
    {
        ComPtr<ID2D1PathGeometry> pGeometry;
        DX::ThrowIfFailed(
            m_pFactory->CreatePathGeometry(&pGeometry)
            );

        ComPtr<ID2D1GeometrySink> pSink;
        DX::ThrowIfFailed(
            pGeometry->Open(&pSink)
            );

        DX::ThrowIfFailed(
            pSink->Close()
            );

        *ppGeometry = pGeometry.Get();
        (*ppGeometry)->AddRef();
    }
}

HRESULT OutlineRenderer::GetPixelsPerDip | ( | void * | ,
 |  | FLOAT * | pixelsPerDip
 | ) |  |

Definition at line 148 of file OutlineRenderer.cpp.

{
    *pixelsPerDip = 1.0f;
    return S_OK;
}

HRESULT OutlineRenderer::IsPixelSnappingDisabled | ( | void * | ,
 |  | BOOL * | isDisabled
 | ) |  |

Definition at line 129 of file OutlineRenderer.cpp.

{
    *isDisabled = TRUE;
    return S_OK;
}

HRESULT OutlineRenderer::QueryInterface | ( | REFIID | riid,
 |  | _Outptr_ void ** | object |
 | ) |  |  | [override]

Definition at line 232 of file OutlineRenderer.cpp.

{
    *object = nullptr;
    return E_NOTIMPL;
}

OutlineRenderer::STDMETHOD_ | ( | ULONG | ,
 |  | AddRef |  |
 | ) |  |  | [override]
OutlineRenderer::STDMETHOD_ | ( | ULONG | ,
 |  | Release |  |
 | ) |  |  | [override]

Member Data Documentation

Microsoft::WRL::ComPtr<ID2D1Factory> OutlineRenderer::m_pFactory [private]

Definition at line 84 of file OutlineRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Geometry> OutlineRenderer::m_pGeometry [private]

Definition at line 85 of file OutlineRenderer.h.

ULONG OutlineRenderer::m_ref [private]

Definition at line 87 of file OutlineRenderer.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/OutlineRenderer.h
  • DirectX postcard app/C++/OutlineRenderer.cpp
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Page Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

Page Class Reference

#include "Page.h"

Inherits Element.

Inherited by MediaExtensionsCS::ScenarioInput1, MediaExtensionsCS::ScenarioInput2, MediaExtensionsCS::ScenarioInput3, MediaExtensionsCS::ScenarioInput4, MediaExtensionsCS::ScenarioList, MediaExtensionsCS::ScenarioOutput1, MediaExtensionsCS::ScenarioOutput2, MediaExtensionsCS::ScenarioOutput3, MediaExtensionsCS::ScenarioOutput4, PrintSample::BasePrintPage, SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, and SDKTemplateCS::MainPage.

List of all members.

Public Member Functions

virtual bool AcceptChildNode (_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override

Detailed Description

Definition at line 16 of file Page.h.

Member Function Documentation

virtual bool Page::AcceptChildNode | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::IXmlNode^ | childXmlNode |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

The documentation for this class was generated from the following file:
  • Direct2D magazine app/C++/Page.h
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PageRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

PageRenderer Class Reference

#include "D2DPageRenderer.h"

List of all members.

Public Member Functions

HRESULT | ClosePrintControl ()
HRESULT | ClosePrintControl ()
virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateDeviceResources () override
void | CreatePrintControl (_In_ IPrintDocumentPackageTarget *docPackageTarget, _In_ D2D1_PRINT_CONTROL_PROPERTIES *printControlProperties)
void | CreatePrintControl (_In_ IPrintDocumentPackageTarget *docPackageTarget, _In_ D2D1_PRINT_CONTROL_PROPERTIES *printControlProperties)
void | DrawPreviewSurface (_In_ float width, _In_ float height, _In_ float scale, _In_ D2D1_RECT_F contentBox, _In_ uint32 desiredJobPage, _In_ IPrintPreviewDxgiPackageTarget *previewTarget)
void | DrawPreviewSurface (_In_ float width, _In_ float height, _In_ float scale, _In_ D2D1_RECT_F contentBox, _In_ uint32 desiredJobPage, _In_ IPrintPreviewDxgiPackageTarget *previewTarget)
IDWriteTextFormat * | GetMessageFormatNoRef ()
IDWriteTextFormat * | GetMessageFormatNoRef ()
IWICBitmapSource * | GetOriginalWicBitmapSourceNoRef ()
IDWriteTextFormat * | GetTextFormatNoRef ()
IDWriteTextFormat * | GetTextFormatNoRef ()
IWICBitmapSource * | GetWicBitmapSourceWithEmbeddedColorContextNoRef ()
IWICColorContext * | GetWicColorContextNoRef ()
void | PrintPage (_In_ uint32 pageNumber, _In_ D2D1_RECT_F imageableArea, _In_ D2D1_SIZE_F pageSize, _In_opt_ IStream *pagePrintTicketStream)
void | PrintPage (_In_ uint32 pageNumber, _In_ D2D1_RECT_F imageableArea, _In_ D2D1_SIZE_F pageSize, _In_opt_ IStream *pagePrintTicketStream)
virtual void | Render () override
virtual void | Render () override
void | SetSnappedMode (_In_ bool isSnapped)
void | SetSnappedMode (_In_ bool isSnapped)
virtual void | UpdateForWindowSizeChange () override
virtual void | UpdateForWindowSizeChange () override

Public Attributes

internal | __pad0__: PageRenderer()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1PrintControl > 		m_d2dPrintControl
PageRendererContext m_displayPageRendererContext
bool | m_isSnapped
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_messageFormat
Microsoft::WRL::ComPtr
< IWICBitmapFrameDecode > 		m_profiledWicBitmap
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< IWICColorContext > 		m_wicColorContext
Microsoft::WRL::ComPtr
< IWICFormatConverter > 		m_wicConvertedSource

Detailed Description

Definition at line 21 of file D2DPageRenderer.h.

Member Function Documentation

HRESULT PageRenderer::ClosePrintControl ( )

Definition at line 421 of file D2DPageRenderer.cpp.

{
    return (m_d2dPrintControl == nullptr) ? S_OK : m_d2dPrintControl->Close();
}

HRESULT PageRenderer::ClosePrintControl ( )
void PageRenderer::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 24 of file D2DPageRenderer.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create a DirectWrite text format object for the sample's content.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            40.0f,
            L"en-us", // locale
            &m_textFormat
            )
        );

    // Align the text horizontally.
    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    // Create a DirectWrite text format object for status messages.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            20.0f,
            L"en-us", // locale
            &m_messageFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_messageFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_messageFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    // Load the source bitmap file into a WIC bitmap source.
    ComPtr<IWICBitmapDecoder> decoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"test.jpg",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &decoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> frame;
    DX::ThrowIfFailed(
        decoder->GetFrame(0, &frame)
        );

    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&m_wicConvertedSource)
        );

    DX::ThrowIfFailed(
        m_wicConvertedSource->Initialize(
            frame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0f,
            WICBitmapPaletteTypeCustom  // Premultiplied BGRA has no paletting, so this is ignored.
            )
        );

    // Load the source color profile.
    DX::ThrowIfFailed(
        m_wicFactory->CreateColorContext(&m_wicColorContext)
        );

    DX::ThrowIfFailed(
        m_wicColorContext->InitializeFromFilename(L"profile.icm")
        );

    // Create another BitmapSource effect, for printing only.
    // We first encode the WIC bitmap source and the WIC color context to an
    // in-memory stream, then create a new WIC bitmap source from that stream,
    // and finally create a BitmapSource effect based on the newly created WIC
    // bitmap source. By doing so, we pass the original WIC bitmap source and
    // the WIC color context (both embedded in that stream) directly to the
    // print path, and achieve better performance and fidelity with delayed
    // color conversion.

    // Step 1: Encode both the WIC bitmap source and the color context to an
    // in-memory stream.
    ComPtr<IStream> stream;
    DX::ThrowIfFailed(
        CreateStreamOnHGlobal(
            nullptr, // To allocate a new memory handle.
            true,    // The underlying handle should be automatically freed when the stream object is released.
            &stream
            )
        );

    ComPtr<IWICBitmapEncoder> wicBitmapEncoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateEncoder(
            GUID_ContainerFormatPng,    // Encode as PNG.
            nullptr,    // No preferred codec vendor.
            &wicBitmapEncoder
            )
        );

    DX::ThrowIfFailed(
        wicBitmapEncoder->Initialize(
            stream.Get(),
            WICBitmapEncoderNoCache
            )
        );

    ComPtr<IWICBitmapFrameEncode> wicFrameEncode;
    DX::ThrowIfFailed(
        wicBitmapEncoder->CreateNewFrame(
            &wicFrameEncode,
            nullptr     // No encoder options.
            )
        );

    DX::ThrowIfFailed(
        wicFrameEncode->Initialize(nullptr)
        );

    // Set color context to the frame.
    IWICColorContext* contexts[1];
    contexts[0] = m_wicColorContext.Get();
    DX::ThrowIfFailed(
        wicFrameEncode->SetColorContexts(1, contexts)
        );

    DX::ThrowIfFailed(
        wicFrameEncode->WriteSource(
            m_wicConvertedSource.Get(),
            nullptr     // Write the whole bitmap.
            )
        );

    DX::ThrowIfFailed(
        wicFrameEncode->Commit()
        );

    DX::ThrowIfFailed(
        wicBitmapEncoder->Commit()
        );

    // Step 2: Decode the newly created image stream.
    ComPtr<IWICBitmapDecoder> bitmapDecoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromStream(
            stream.Get(),
            nullptr,    // No preferred codec vendor.
            WICDecodeMetadataCacheOnLoad,
            &bitmapDecoder
            )
        );

    // Get the initial frame as the new WIC bitmap source.
    DX::ThrowIfFailed(
        bitmapDecoder->GetFrame(0, &m_profiledWicBitmap)
        );
}

virtual void PageRenderer::CreateDeviceIndependentResources ( ) [override, virtual]
void PageRenderer::CreateDeviceResources ( ) [override, virtual]

Definition at line 204 of file D2DPageRenderer.cpp.

{
    DirectXBase::CreateDeviceResources();

    // Create and initialize sample overlay for sample title.
    m_sampleOverlay = ref new SampleOverlay();
    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D image and effect printing sample"
        );

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Exclude sample title from imageable area for image drawing.
    float titleHeight = m_sampleOverlay->GetTitleHeightInDips();

    // Create and initialize the page renderer context for display.
    m_displayPageRendererContext =
        ref new PageRendererContext(
            D2D1::RectF(0, titleHeight, size.width, size.height),
            m_d2dContext.Get(),
            DrawTypes::Rendering,
            this
            );
}

virtual void PageRenderer::CreateDeviceResources ( ) [override, virtual]
void PageRenderer::CreatePrintControl | ( | _In_ IPrintDocumentPackageTarget * | docPackageTarget,
 |  | _In_ D2D1_PRINT_CONTROL_PROPERTIES * | printControlProperties
 | ) |  |

Definition at line 403 of file D2DPageRenderer.cpp.

{
    // Explicitly release existing D2D print control.
    m_d2dPrintControl = nullptr;

    DX::ThrowIfFailed(
        m_d2dDevice->CreatePrintControl(
            m_wicFactory.Get(),
            docPackageTarget,
            printControlProperties,
            &m_d2dPrintControl
            )
        );
}

void PageRenderer::CreatePrintControl | ( | _In_ IPrintDocumentPackageTarget * | docPackageTarget,
 |  | _In_ D2D1_PRINT_CONTROL_PROPERTIES * | printControlProperties
 | ) |  |
void PageRenderer::DrawPreviewSurface | ( | _In_ float | width,
 |  | _In_ float | height,
 |  | _In_ float | scale,
 |  | _In_ D2D1_RECT_F | contentBox,
 |  | _In_ uint32 | desiredJobPage,
 |  | _In_ IPrintPreviewDxgiPackageTarget * | previewTarget
 | ) |  |
void PageRenderer::DrawPreviewSurface | ( | _In_ float | width,
 |  | _In_ float | height,
 |  | _In_ float | scale,
 |  | _In_ D2D1_RECT_F | contentBox,
 |  | _In_ uint32 | desiredJobPage,
 |  | _In_ IPrintPreviewDxgiPackageTarget * | previewTarget
 | ) |  |

Definition at line 292 of file D2DPageRenderer.cpp.

{
    // We are accessing D3D resources directly without D2D's knowledge, so we
    // must manually acquire the D2D factory lock.
    //
    // Note: it's absolutely critical that the factory lock be released upon
    // exiting this function, or else the entire app will deadlock. This is
    // ensured via the following RAII class.
    D2DFactoryLock factoryLock(m_d2dFactory.Get());

    CD3D11_TEXTURE2D_DESC textureDesc(
        DXGI_FORMAT_B8G8R8A8_UNORM,
        static_cast<uint32>(ceil(width  * m_dpi / 96)),
        static_cast<uint32>(ceil(height * m_dpi / 96)),
        1,
        1,
        D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE
        );

    ComPtr<ID3D11Texture2D> texture;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateTexture2D(
            &textureDesc,
            nullptr,
            &texture
            )
        );

    // Create a preview DXGI surface with given size.
    ComPtr<IDXGISurface> dxgiSurface;
    DX::ThrowIfFailed(
        texture.As<IDXGISurface>(&dxgiSurface)
        );

    // Create a new D2D device context for rendering the preview surface.
    // D2D device contexts are stateful, and hence a unique device must be
    // used on each thread.
    ComPtr<ID2D1DeviceContext> d2dContext;
    DX::ThrowIfFailed(
        m_d2dDevice->CreateDeviceContext(
            D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
            &d2dContext
            )
        );

    // Update DPI for preview surface as well.
    d2dContext->SetDpi(m_dpi, m_dpi);

    // Recommend using the screen DPI for better fidelity and better performance in the print preview
    D2D1_BITMAP_PROPERTIES1 bitmapProperties =
        D2D1::BitmapProperties1(
            D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
            D2D1::PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED)
            );

    // Create surface bitmap on which page content is drawn.
    ComPtr<ID2D1Bitmap1> d2dSurfaceBitmap;
    DX::ThrowIfFailed(
        d2dContext->CreateBitmapFromDxgiSurface(
            dxgiSurface.Get(),
            &bitmapProperties,
            &d2dSurfaceBitmap
            )
        );

    d2dContext->SetTarget(d2dSurfaceBitmap.Get());

    // Create and initialize the page renderer context for preview.
    PageRendererContext^ previewPageRendererContext =
        ref new PageRendererContext(
            contentBox,
            d2dContext.Get(),
            DrawTypes::Preview,
            this
            );

    d2dContext->BeginDraw();

    // Draw page content on the preview surface.
    // Here contentBox is smaller than the real page size and the scale
    // indicates the proportion. It is faster to draw content on a smaller
    // surface. Set a global transform of 1/scale, allowing Draw to draw to a
    // virtual target box without accounting for the scale factor.
    d2dContext->SetTransform(D2D1::Matrix3x2F(1.0f / scale, 0.0f, 0.0f, 1.0f / scale, 0.0f, 0.0f));

    previewPageRendererContext->Draw();

    // The document source handles D2DERR_RECREATETARGET, so it is okay to throw this error
    // here.
    DX::ThrowIfFailed(
        d2dContext->EndDraw()
        );

    // Must pass the same DPI as used to create the DXGI surface for the correct print preview.
    DX::ThrowIfFailed(
        previewTarget->DrawPage(
            desiredJobPage,
            dxgiSurface.Get(),
            m_dpi,
            m_dpi
            )
        );
}

IDWriteTextFormat* PageRenderer::GetMessageFormatNoRef ( )
IDWriteTextFormat * PageRenderer::GetMessageFormatNoRef ( )

Definition at line 505 of file D2DPageRenderer.cpp.

{
    return m_messageFormat.Get();
}

IWICBitmapSource * PageRenderer::GetOriginalWicBitmapSourceNoRef ( )

Definition at line 490 of file D2DPageRenderer.cpp.

{
    return m_wicConvertedSource.Get();
}

IDWriteTextFormat * PageRenderer::GetTextFormatNoRef ( )

Definition at line 500 of file D2DPageRenderer.cpp.

{
    return m_textFormat.Get();
}

IDWriteTextFormat* PageRenderer::GetTextFormatNoRef ( )
IWICBitmapSource * PageRenderer::GetWicBitmapSourceWithEmbeddedColorContextNoRef ( )

Definition at line 495 of file D2DPageRenderer.cpp.

{
    return m_profiledWicBitmap.Get();
}

IWICColorContext * PageRenderer::GetWicColorContextNoRef ( )

Definition at line 485 of file D2DPageRenderer.cpp.

{
    return m_wicColorContext.Get();
}

void PageRenderer::PrintPage | ( | _In_ uint32 | pageNumber,
 |  | _In_ D2D1_RECT_F | imageableArea,
 |  | _In_ D2D1_SIZE_F | pageSize,
 |  | _In_opt_ IStream * | pagePrintTicketStream
 | ) |  |

Definition at line 428 of file D2DPageRenderer.cpp.

{
    // Create a new D2D device context for generating the print command list.
    // D2D device contexts are stateful, and hence a unique device context must
    // be used on each thread.
    ComPtr<ID2D1DeviceContext> d2dContext;
    DX::ThrowIfFailed(
        m_d2dDevice->CreateDeviceContext(
            D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
            &d2dContext
            )
        );

    ComPtr<ID2D1CommandList> printCommandList;
    DX::ThrowIfFailed(
        d2dContext->CreateCommandList(&printCommandList)
        );

    d2dContext->SetTarget(printCommandList.Get());

    // Create and initialize the page renderer context for print.
    // In this case, we want to use the bitmap source that already has
    // the color context embedded in it. Thus, we pass NULL for the
    // color context parameter.
    PageRendererContext^ printPageRendererContext =
        ref new PageRendererContext(
            imageableArea,
            d2dContext.Get(),
            DrawTypes::Printing,
            this
            );

    d2dContext->BeginDraw();

    // Draw page content on a command list.
    printPageRendererContext->Draw();

    // The document source handles D2DERR_RECREATETARGET, so it is okay to throw this error
    // here.
    DX::ThrowIfFailed(
        d2dContext->EndDraw()
        );

    DX::ThrowIfFailed(
        printCommandList->Close()
        );

    DX::ThrowIfFailed(
        m_d2dPrintControl->AddPage(printCommandList.Get(), pageSize, pagePrintTicketStream)
        );
}

void PageRenderer::PrintPage | ( | _In_ uint32 | pageNumber,
 |  | _In_ D2D1_RECT_F | imageableArea,
 |  | _In_ D2D1_SIZE_F | pageSize,
 |  | _In_opt_ IStream * | pagePrintTicketStream
 | ) |  |
void PageRenderer::Render ( ) [override, virtual]

Definition at line 250 of file D2DPageRenderer.cpp.

{
    m_d2dContext->BeginDraw();

    if (m_isSnapped)
    {
        m_displayPageRendererContext->DrawMessage("This sample does not support snapped view.");
    }
    else
    {
        // Render page context (i.e. images).
        m_displayPageRendererContext->Draw();
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    // Render sample title.
    m_sampleOverlay->Render();

    // We are accessing D3D resources directly in Present() without D2D's knowledge,
    // so we must manually acquire the D2D factory lock.
    //
    // Note: it's absolutely critical that the factory lock be released upon
    // exiting this function, or else the entire app will deadlock. This is
    // ensured via the following RAII class.
    {
        D2DFactoryLock factoryLock(m_d2dFactory.Get());
        Present();
    }
}

virtual void PageRenderer::Render ( ) [override, virtual]
void PageRenderer::SetSnappedMode ( _In_ bool isSnapped )
void PageRenderer::SetSnappedMode ( _In_ bool isSnapped )

Definition at line 287 of file D2DPageRenderer.cpp.

{
    m_isSnapped = isSnapped;
}

virtual void PageRenderer::UpdateForWindowSizeChange ( ) [override, virtual]
void PageRenderer::UpdateForWindowSizeChange ( ) [override, virtual]

Definition at line 233 of file D2DPageRenderer.cpp.

{
    DirectXBase::UpdateForWindowSizeChange();
    m_sampleOverlay->UpdateForWindowSizeChange();

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Exclude sample title from imageable area for image drawing.
    float titleHeight = m_sampleOverlay->GetTitleHeightInDips();

    D2D1_RECT_F contentBox = D2D1::RectF(0, titleHeight, size.width, size.height);
    m_displayPageRendererContext->UpdateTargetBox(
        contentBox
        );
}

Member Data Documentation

internal PageRenderer::__pad0__

Definition at line 24 of file D2DPageRenderer.h.

Microsoft::WRL::ComPtr< ID2D1PrintControl > PageRenderer::m_d2dPrintControl [private]

Definition at line 68 of file D2DPageRenderer.h.

PageRendererContext PageRenderer::m_displayPageRendererContext [private]

Definition at line 78 of file D2DPageRenderer.h.

bool PageRenderer::m_isSnapped [private]

Definition at line 74 of file D2DPageRenderer.h.

Microsoft::WRL::ComPtr< IDWriteTextFormat > PageRenderer::m_messageFormat [private]

Definition at line 85 of file D2DPageRenderer.h.

Microsoft::WRL::ComPtr<IWICBitmapFrameDecode> PageRenderer::m_profiledWicBitmap [private]

Definition at line 83 of file D2DPageRenderer.h.

SampleOverlay PageRenderer::m_sampleOverlay [private]

Definition at line 71 of file D2DPageRenderer.h.

Microsoft::WRL::ComPtr< IDWriteTextFormat > PageRenderer::m_textFormat [private]

Definition at line 84 of file D2DPageRenderer.h.

Microsoft::WRL::ComPtr<IWICColorContext> PageRenderer::m_wicColorContext [private]

Definition at line 82 of file D2DPageRenderer.h.

Microsoft::WRL::ComPtr<IWICFormatConverter> PageRenderer::m_wicConvertedSource [private]

Definition at line 81 of file D2DPageRenderer.h.

The documentation for this class was generated from the following files:
  • Direct2D printing images and effects/C++/D2DPageRenderer.h
  • Direct2Dapp printing/C++/D2DPageRenderer.h
  • Direct2D printing images and effects/C++/D2DPageRenderer.cpp
  • Direct2Dapp printing/C++/D2DPageRenderer.cpp
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PageRendererContext Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

PageRendererContext Class Reference

#include "D2DPageRendererContext.h"

List of all members.

Public Member Functions

void | Draw (_In_ float scale)
void | DrawMessage (_In_ Platform::String^string)
void | UpdateTargetBox (_In_ D2D1_RECT_F &targetBox)

Public Attributes

internal | __pad0__: PageRendererContext( _In_ D2D1_RECT_F targetBox
internal _In_ ID2D1DeviceContext * | d2dContext
internal _In_
ID2D1DeviceContext _In_
DrawTypes _In_ PageRenderer 		pageRenderer
internal _In_
ID2D1DeviceContext _In_
DrawTypes 		type

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
float | m_margin
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_messageFormat
D2D1_RECT_F | m_targetBox
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
DrawTypes m_type

Detailed Description

Definition at line 53 of file D2DPageRendererContext.h.

Member Function Documentation

void PageRendererContext::Draw ( _In_ float scale )

Definition at line 52 of file D2DPageRendererContext.cpp.

{
    // Clear rendering background with CornflowerBlue and clear preview
    // background with white color. For the printing case (command list), it
    // is recommended not to clear because the surface is clean when created.
    if (m_type == DrawTypes::Rendering)
    {
        m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    }
    else if (m_type == DrawTypes::Preview)
    {
        m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::White));
    }

    // We use scale matrix to shrink the text size and scale is only available
    // for preview.  For on-screen rendering or printing, scale is 1.f, that
    // is, the Identity is the transform matrix.
    m_d2dContext->SetTransform(D2D1::Matrix3x2F(1/scale, 0, 0, 1/scale, 0, 0));

    D2D1_RECT_F textBox =
        D2D1::RectF(
            m_targetBox.left + m_margin,
            m_targetBox.top + m_margin,
            m_targetBox.right - m_margin,
            m_targetBox.bottom - m_margin
            );

    const char16 textString[] = L"\
        Lorem ipsum dolor sit amet, consectetur adipisicing elit, \
sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. \
Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris \
nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in \
reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla\
pariatur. Excepteur sint occaecat cupidatat non proident, sunt in \
culpa qui officia deserunt mollit anim id est laborum.";

    m_d2dContext->DrawText(
        textString,
        ARRAYSIZE(textString) - 1,
        m_textFormat.Get(),
        textBox,
        m_blackBrush.Get()
        );
}

void PageRendererContext::DrawMessage ( _In_ Platform::String^ string )

Definition at line 98 of file D2DPageRendererContext.cpp.

{
    // Clear rendering background with CornflowerBlue.
    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));

    m_d2dContext->DrawText(
        string->Data(),
        string->Length(),
        m_messageFormat.Get(),
        m_targetBox,
        m_blackBrush.Get()
        );
}

void PageRendererContext::UpdateTargetBox ( _In_ D2D1_RECT_F & targetBox )

Definition at line 46 of file D2DPageRendererContext.cpp.

{
    m_targetBox = targetBox;
}

Member Data Documentation

internal PageRendererContext::__pad0__

Definition at line 57 of file D2DPageRendererContext.h.

internal _In_ ID2D1DeviceContext* PageRendererContext::d2dContext

Definition at line 57 of file D2DPageRendererContext.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> PageRendererContext::m_blackBrush [private]

Definition at line 73 of file D2DPageRendererContext.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> PageRendererContext::m_d2dContext [private]

Definition at line 70 of file D2DPageRendererContext.h.

float PageRendererContext::m_margin [private]

Definition at line 75 of file D2DPageRendererContext.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> PageRendererContext::m_messageFormat [private]

Definition at line 72 of file D2DPageRendererContext.h.

D2D1_RECT_F PageRendererContext::m_targetBox [private]

Definition at line 77 of file D2DPageRendererContext.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> PageRendererContext::m_textFormat [private]

Definition at line 71 of file D2DPageRendererContext.h.

DrawTypes PageRendererContext::m_type [private]

Definition at line 79 of file D2DPageRendererContext.h.

internal _In_ ID2D1DeviceContext _In_ DrawTypes _In_ PageRenderer PageRendererContext::pageRenderer

Definition at line 57 of file D2DPageRendererContext.h.

internal _In_ ID2D1DeviceContext _In_ DrawTypes PageRendererContext::type

Definition at line 57 of file D2DPageRendererContext.h.

The documentation for this class was generated from the following files:
  • Direct2Dapp printing/C++/D2DPageRendererContext.h
  • Direct2Dapp printing/C++/D2DPageRendererContext.cpp
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PageRoll Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

PageRoll Class Reference

#include "PageRoll.h"

Inherits Element.

List of all members.

Public Member Functions

virtual void | Measure (_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override

Public Attributes

internal | __pad0__: virtual bool AcceptChildNode( _In_ Document^ document
internal _In_
Windows::Data::Xml::Dom::IXmlNode
childXmlNode 		override

Detailed Description

Definition at line 19 of file PageRoll.h.

Member Function Documentation

void PageRoll::Measure | ( | _In_ Document^ | document,
 |  | D2D1_SIZE_F const & | parentSize,
 |  | _Out_ D2D1_RECT_F * | bounds |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 45 of file PageRoll.cpp.

{
    D2D1_SIZE_F size = m_size;

    if (size.width <= 0 && size.height <= 0)
    {
        // When no size is specified, assume its parent size.
        size = parentSize;
    }

    D2D1_RECT_F maxBounds = {0};

    Element^ child = GetFirstChild();

    while (child)
    {
        D2D1_RECT_F childBounds = {0};

        child->Measure(document, size, &childBounds);

        if (maxBounds.right + childBounds.left < maxBounds.left)
        {
            // Accommodate child placed left to all other previous children.
            maxBounds.left = childBounds.left;
        }

        // The current child is laid next to the right of the previous child.
        maxBounds.right += childBounds.right;

        if (childBounds.top < maxBounds.top)
        {
            maxBounds.top = childBounds.top;
        }

        if (childBounds.bottom > maxBounds.bottom)
        {
            maxBounds.bottom = childBounds.bottom;
        }

        child = child->GetNextSibling();
    }

    m_size = D2D1::SizeF(maxBounds.right - maxBounds.left, maxBounds.bottom - maxBounds.top);

    *bounds = D2D1::RectF(
        maxBounds.left + m_offset.x,
        maxBounds.top + m_offset.y,
        maxBounds.right + m_offset.x,
        maxBounds.bottom + m_offset.y
        );
}

Member Data Documentation

internal PageRoll::__pad0__

Reimplemented from Element.

Definition at line 23 of file PageRoll.h.

internal _In_ Windows::Data::Xml::Dom::IXmlNode childXmlNode PageRoll::override

Definition at line 23 of file PageRoll.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/PageRoll.h
  • Direct2D magazine app/C++/PageRoll.cpp
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PaperFragment Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

PaperFragment Class Reference

#include "PaperFragment.h"

List of all members.

Public Member Functions

void | Draw ()
PaperFragment | GetExclusionWith (D2D1_POINT_2F point, ID2D1Geometry *pGeometry)
PaperFragment | GetIntersectionWith (D2D1_POINT_2F point, ID2D1Geometry *pGeometry)
D2D1_POINT_2F | GetPosition ()
bool | HitTest (D2D1_POINT_2F point)
bool | HitTestWithGeometry (D2D1_POINT_2F point, ID2D1Geometry *pGeometry)
void | SetPosition (D2D1_POINT_2F position)

Public Attributes

internal | __pad0__: PaperFragment( Microsoft::WRL::ComPtr<ID2D1DeviceContext> d2dContext
internal ID2D1Geometry
D2D1_COLOR_F & 		color
internal ID2D1Geometry * | pGeometry

Private Member Functions

void | GeneratePaperBitmap ()
PaperFragment | GetMergeWith (D2D1_POINT_2F point, ID2D1Geometry *pGeometry, D2D1_COMBINE_MODE mode)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_bitmap
D2D1_POINT_2F | m_bitmapOffset
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_brush
D2D1_COLOR_F | m_color
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
Microsoft::WRL::ComPtr
< ID2D1Geometry > 		m_geometry
D2D1_POINT_2F | m_position

Detailed Description

Definition at line 12 of file PaperFragment.h.

Member Function Documentation

void PaperFragment::Draw ( )

Definition at line 387 of file PaperFragment.cpp.

{
    D2D1::Matrix3x2F originalTransform;
    m_d2dContext->GetTransform(&originalTransform);

    {
        D2D1::Matrix3x2F offsetTransform =
            D2D1::Matrix3x2F::Translation(
                m_bitmapOffset.x + m_position.x,
                m_bitmapOffset.y + m_position.y
                ) * originalTransform;

        m_d2dContext->SetTransform(&offsetTransform);

        m_d2dContext->DrawBitmap(m_bitmap.Get());
    }

    m_d2dContext->SetTransform(&originalTransform);
}

void PaperFragment::GeneratePaperBitmap ( ) [private]

Definition at line 39 of file PaperFragment.cpp.

{
    ComPtr<ID2D1Device> spDevice;
    m_d2dContext->GetDevice(&spDevice);

    ComPtr<ID2D1Effect> spEdgeTurbulance;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1Turbulence,
            &spEdgeTurbulance
            )
        );

    {
        D2D1_VECTOR_2F offset = {-100000, -100000};
        DX::ThrowIfFailed(
            spEdgeTurbulance->SetValue(D2D1_TURBULENCE_PROP_OFFSET, offset)
            );

        D2D1_VECTOR_2F size = {200000, 200000};
        DX::ThrowIfFailed(
            spEdgeTurbulance->SetValue(D2D1_TURBULENCE_PROP_SIZE, size)
            );

        D2D1_VECTOR_2F baseFrequency = {0.3f, 0.3f};
        DX::ThrowIfFailed(
            spEdgeTurbulance->SetValue(D2D1_TURBULENCE_PROP_BASE_FREQUENCY, baseFrequency)
            );

        DX::ThrowIfFailed(
            spEdgeTurbulance->SetValue(D2D1_TURBULENCE_PROP_SEED, 42)
            );
    }

    ComPtr<ID2D1Effect> spEdgeTurbulanceColorMatrix;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1ColorMatrix,
            &spEdgeTurbulanceColorMatrix
            )
        );

    {
        D2D_MATRIX_5X4_F colorMatrix =
        {
            2, 0, 0, 0,
            0, 2, 0, 0,
            0, 0, 2, 0,
            0, 0, 0, 1,
            0, 0, 0, 0
        };

        DX::ThrowIfFailed(
            spEdgeTurbulanceColorMatrix->SetValue(D2D1_COLORMATRIX_PROP_COLOR_MATRIX, colorMatrix)
            );
    }

    ComPtr<ID2D1Effect> spEdgeErode;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1Morphology,
            &spEdgeErode
            )
        );

    {
        DX::ThrowIfFailed(
            spEdgeErode->SetValue(D2D1_MORPHOLOGY_PROP_WIDTH, 10)
            );

        DX::ThrowIfFailed(
            spEdgeErode->SetValue(D2D1_MORPHOLOGY_PROP_HEIGHT, 10)
            );
    }

    ComPtr<ID2D1Effect> spEdgeDisplacement;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1DisplacementMap,
            &spEdgeDisplacement
            )
        );

    {
        DX::ThrowIfFailed(
            spEdgeDisplacement->SetValue(D2D1_DISPLACEMENTMAP_PROP_SCALE, 10.0f)
            );

        DX::ThrowIfFailed(
            spEdgeDisplacement->SetValue(
                D2D1_DISPLACEMENTMAP_PROP_X_CHANNEL_SELECT,
                D2D1_CHANNEL_SELECTOR_R
                )
            );

        DX::ThrowIfFailed(
            spEdgeDisplacement->SetValue(
                D2D1_DISPLACEMENTMAP_PROP_Y_CHANNEL_SELECT,
                D2D1_CHANNEL_SELECTOR_G
                )
            );
    }

    ComPtr<ID2D1Effect> spBumpTurbulance;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1Turbulence,
            &spBumpTurbulance
            )
        );

    {
        D2D1_VECTOR_2F offset = {-100000, -100000};
        DX::ThrowIfFailed(
            spBumpTurbulance->SetValue(D2D1_TURBULENCE_PROP_OFFSET, offset)
            );

        D2D1_VECTOR_2F size = {200000, 200000};
        DX::ThrowIfFailed(
            spBumpTurbulance->SetValue(D2D1_TURBULENCE_PROP_SIZE, size)
            );

        D2D1_VECTOR_2F baseFrequency = {0.3f, 0.3f};
        DX::ThrowIfFailed(
            spBumpTurbulance->SetValue(D2D1_TURBULENCE_PROP_BASE_FREQUENCY, baseFrequency)
            );

        DX::ThrowIfFailed(
            spBumpTurbulance->SetValue(D2D1_TURBULENCE_PROP_SEED, 42)
            );
    }

    ComPtr<ID2D1Effect> spBumpDiffuse;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1DistantSpecular,
            &spBumpDiffuse
            )
        );

    {
        DX::ThrowIfFailed(
            spBumpDiffuse->SetValue(D2D1_DISTANTSPECULAR_PROP_SURFACE_SCALE, 0.25f)
            );
    }

    ComPtr<ID2D1Effect> spBumpComposite;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1ArithmeticComposite,
            &spBumpComposite
            )
        );

    {
        D2D1_VECTOR_4F coefficients = {1.3f, 0, 0, 0};
        DX::ThrowIfFailed(
            spBumpComposite->SetValue(D2D1_ARITHMETICCOMPOSITE_PROP_COEFFICIENTS, coefficients)
            );
    }

    ComPtr<ID2D1Effect> spShadow;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1Shadow,
            &spShadow
            )
        );

    {
        DX::ThrowIfFailed(
            spShadow->SetValue(D2D1_SHADOW_PROP_BLUR_STANDARD_DEVIATION, 3.0f)
            );
    }

    ComPtr<ID2D1Effect> spShadowOffset;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D12DAffineTransform,
            &spShadowOffset
            )
        );

    {
        DX::ThrowIfFailed(
            spShadowOffset->SetValue(
                D2D1_2DAFFINETRANSFORM_PROP_TRANSFORM_MATRIX,
                D2D1::Matrix3x2F::Translation(3, 3)
                )
            );
    }

    ComPtr<ID2D1Effect> spShadowComposite;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1Composite,
            &spShadowComposite
            )
        );

    ComPtr<ID2D1Effect> spEdgeDisplacementColorMatrix;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1ColorMatrix,
            &spEdgeDisplacementColorMatrix
            )
        );

    {
        D2D_MATRIX_5X4_F colorMatrix =
        {
            0, 0, 0, 0,
            0, 0, 0, 0,
            0, 0, 0, 0,
            0, 0, 0, 1,
            1, 1, 1, 0
        };

        DX::ThrowIfFailed(
            spEdgeDisplacementColorMatrix->SetValue(
                D2D1_COLORMATRIX_PROP_COLOR_MATRIX,
                colorMatrix
                )
            );
    }

    ComPtr<ID2D1Effect> spEdgeDisplacementComposite;
    DX::ThrowIfFailed(
        m_d2dContext->CreateEffect(
            CLSID_D2D1ArithmeticComposite,
            &spEdgeDisplacementComposite
            )
        );

    ComPtr<ID2D1CommandList> spCommandList;
    DX::ThrowIfFailed(
        m_d2dContext->CreateCommandList(&spCommandList)
        );

    ComPtr<ID2D1Image> oldTarget;
    m_d2dContext->GetTarget(&oldTarget);

    m_d2dContext->SetTarget(spCommandList.Get());

    D2D1_MATRIX_3X2_F oldTransform;
    m_d2dContext->GetTransform(&oldTransform);

    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    m_d2dContext->BeginDraw();

    m_d2dContext->FillGeometry(
        m_geometry.Get(),
        m_brush.Get()
        );

    DX::ThrowIfFailed(
        m_d2dContext->EndDraw()
        );

    DX::ThrowIfFailed(
        spCommandList->Close()
        );

    spEdgeErode->SetInput(0, spCommandList.Get());

    spEdgeTurbulanceColorMatrix->SetInputEffect(0, spEdgeTurbulance.Get());

    spEdgeDisplacement->SetInputEffect(0, spEdgeErode.Get());
    spEdgeDisplacement->SetInputEffect(1, spEdgeTurbulanceColorMatrix.Get());

    spEdgeDisplacementColorMatrix->SetInputEffect(0, spEdgeDisplacement.Get());

    spShadow->SetInputEffect(0, spEdgeDisplacement.Get());

    spShadowOffset->SetInputEffect(0, spShadow.Get());

    spEdgeDisplacementComposite->SetInputEffect(0, spEdgeDisplacementColorMatrix.Get());
    spEdgeDisplacementComposite->SetInput(1, spCommandList.Get());

    spBumpDiffuse->SetInputEffect(0, spBumpTurbulance.Get());

    spBumpComposite->SetInputEffect(0, spEdgeDisplacementComposite.Get());
    spBumpComposite->SetInputEffect(1, spBumpDiffuse.Get());

    spShadowComposite->SetInputEffect(0, spShadowOffset.Get());
    spShadowComposite->SetInputEffect(1, spBumpComposite.Get());

    D2D1_RECT_F bounds;

    ComPtr<ID2D1Image> spOutputImage;
    spShadowComposite->GetOutput(&spOutputImage);

    DX::ThrowIfFailed(
        m_d2dContext->GetImageLocalBounds(
            spOutputImage.Get(),
            &bounds
            )
        );

    m_bitmapOffset = D2D1::Point2F(
        static_cast<float>(bounds.left),
        static_cast<float>(bounds.top)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmap(
            D2D1::SizeU(
                static_cast<uint32>(bounds.right - bounds.left),
                static_cast<uint32>(bounds.bottom - bounds.top)
                ),
            nullptr,    // sourceData
            0,          // pitch
            D2D1::BitmapProperties1(
                D2D1_BITMAP_OPTIONS_TARGET,
                D2D1::PixelFormat(
                    DXGI_FORMAT_B8G8R8A8_UNORM,
                    D2D1_ALPHA_MODE_PREMULTIPLIED
                    )
                ),
            &m_bitmap
            )
        );

    m_d2dContext->SetTarget(m_bitmap.Get());

    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(0, 0, 0, 0));

    m_d2dContext->SetTransform(
        D2D1::Matrix3x2F::Translation(
            -m_bitmapOffset.x,
            -m_bitmapOffset.y
            )
        );

    m_d2dContext->DrawImage(spShadowComposite.Get());

    DX::ThrowIfFailed(
        m_d2dContext->EndDraw()
        );

    m_d2dContext->SetTarget(oldTarget.Get());

    m_d2dContext->SetTransform(oldTransform);
}

PaperFragment PaperFragment::GetExclusionWith | ( | D2D1_POINT_2F | point,
 |  | ID2D1Geometry * | pGeometry
 | ) |  |

Definition at line 526 of file PaperFragment.cpp.

{
    return GetMergeWith(
        point,
        pGeometry,
        D2D1_COMBINE_MODE_EXCLUDE
        );
}

PaperFragment PaperFragment::GetIntersectionWith | ( | D2D1_POINT_2F | point,
 |  | ID2D1Geometry * | pGeometry
 | ) |  |

Definition at line 514 of file PaperFragment.cpp.

{
    return GetMergeWith(
        point,
        pGeometry,
        D2D1_COMBINE_MODE_INTERSECT
        );
}

PaperFragment PaperFragment::GetMergeWith | ( | D2D1_POINT_2F | point,
 |  | ID2D1Geometry * | pGeometry,
 |  | D2D1_COMBINE_MODE | mode |
 | ) |  |  | [private]

Definition at line 453 of file PaperFragment.cpp.

{
    ComPtr<ID2D1Factory> spFactory;
    ComPtr<ID2D1TransformedGeometry> spTransformedGeometry;

    m_geometry->GetFactory(&spFactory);

    DX::ThrowIfFailed(
        spFactory->CreateTransformedGeometry(
            m_geometry.Get(),
            D2D1::Matrix3x2F::Translation(
                m_position.x,
                m_position.y
                ),
            &spTransformedGeometry
            )
        );

    ComPtr<ID2D1PathGeometry> spPathGeometry;
    ComPtr<ID2D1GeometrySink> spGeometrySink;

    DX::ThrowIfFailed(
        spFactory->CreatePathGeometry(&spPathGeometry)
        );

    DX::ThrowIfFailed(
        spPathGeometry->Open(&spGeometrySink)
        );

    DX::ThrowIfFailed(
        spTransformedGeometry->CombineWithGeometry(
            pGeometry,
            mode,
            D2D1::Matrix3x2F::Translation(
                point.x,
                point.y
                ),
            spGeometrySink.Get()
            )
        );

    DX::ThrowIfFailed(
        spGeometrySink->Close()
        );

    PaperFragment^ spNewFragment =
        ref new PaperFragment(
            m_d2dContext,
            spPathGeometry.Get(),
            m_color
            );

    spNewFragment->SetPosition(D2D1::Point2F(0, 0));

    return spNewFragment;
}

D2D1_POINT_2F PaperFragment::GetPosition ( )

Definition at line 407 of file PaperFragment.cpp.

{
    return m_position;
}

bool PaperFragment::HitTest ( D2D1_POINT_2F point )

Definition at line 417 of file PaperFragment.cpp.

{
    BOOL contains;

    DX::ThrowIfFailed(
        m_geometry->FillContainsPoint(
            point,
            D2D1::Matrix3x2F::Translation(
                m_position.x,
                m_position.y
                ),
            &contains
            )
        );

    return (contains ? true : false);
}

bool PaperFragment::HitTestWithGeometry | ( | D2D1_POINT_2F | point,
 |  | ID2D1Geometry * | pGeometry
 | ) |  |

Definition at line 435 of file PaperFragment.cpp.

{
    D2D1_GEOMETRY_RELATION relation;

    DX::ThrowIfFailed(
        m_geometry->CompareWithGeometry(
            pGeometry,
            D2D1::Matrix3x2F::Translation(
                point.x - m_position.x,
                point.y - m_position.y
                ),
            &relation
            )
        );

    return (relation != D2D1_GEOMETRY_RELATION_DISJOINT);
}

void PaperFragment::SetPosition ( D2D1_POINT_2F position )

Definition at line 412 of file PaperFragment.cpp.

{
    m_position = position;
}

Member Data Documentation

internal PaperFragment::__pad0__

Definition at line 16 of file PaperFragment.h.

internal ID2D1Geometry D2D1_COLOR_F& PaperFragment::color

Definition at line 16 of file PaperFragment.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap1> PaperFragment::m_bitmap [private]

Definition at line 60 of file PaperFragment.h.

D2D1_POINT_2F PaperFragment::m_bitmapOffset [private]

Definition at line 64 of file PaperFragment.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> PaperFragment::m_brush [private]

Definition at line 59 of file PaperFragment.h.

D2D1_COLOR_F PaperFragment::m_color [private]

Definition at line 62 of file PaperFragment.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> PaperFragment::m_d2dContext [private]

Definition at line 57 of file PaperFragment.h.

Microsoft::WRL::ComPtr<ID2D1Geometry> PaperFragment::m_geometry [private]

Definition at line 58 of file PaperFragment.h.

D2D1_POINT_2F PaperFragment::m_position [private]

Definition at line 63 of file PaperFragment.h.

internal ID2D1Geometry* PaperFragment::pGeometry

Definition at line 16 of file PaperFragment.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/PaperFragment.h
  • DirectX postcard app/C++/PaperFragment.cpp
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PaperRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

PaperRenderer Class Reference

#include "PaperRenderer.h"

List of all members.

Public Member Functions

void | AddPaper ()
void | CreateDeviceIndependentResources (Microsoft::WRL::ComPtr< ID2D1Factory1 > d2dFactory)
void | CreateDeviceResources (Microsoft::WRL::ComPtr< ID2D1DeviceContext > d2dContext)
void | CreateWindowSizeDependentResources (float dpi)
void | DrawPaper ()
void | MovePaper ()
void | OnManipulationCompleted (Windows::UI::Xaml::Input::ManipulationCompletedRoutedEventArgs^args)
void | OnManipulationDelta (Windows::UI::Xaml::Input::ManipulationDeltaRoutedEventArgs^args)
void | OnManipulationStarted (Windows::UI::Xaml::Input::ManipulationStartedRoutedEventArgs^args)
void | OnTapped (Windows::Foundation::Point position)
void | RemovePaper ()
void | Reset ()
void | StampPaper ()

Public Attributes

internal | __pad0__: PaperRenderer()

Private Member Functions

PaperFragment | HitTestFragmentsWithPosition (D2D1_POINT_2F position)
float | RandomFloat ()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
float | m_dpi
std::list< PaperFragment^> | m_paperFragmentList
PaperMode m_paperMode
PaperFragment m_selectedFragment
Microsoft::WRL::ComPtr
< ID2D1Geometry > 		m_starStampGeometry

Detailed Description

Definition at line 19 of file PaperRenderer.h.

Member Function Documentation

void PaperRenderer::AddPaper ( )

Definition at line 107 of file PaperRenderer.cpp.

{
    m_paperMode = PaperMode::Moving;

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    // Create a rectangular geometry for the piece of paper.

    ComPtr<ID2D1RectangleGeometry> paperGeometry;

    D2D1_RECT_F paperRect = D2D1::RectF(-300, -225, 300, 225);

    DX::ThrowIfFailed(
        m_d2dFactory->CreateRectangleGeometry(
            &paperRect,
            &paperGeometry
            )
        );

    // Create a rotated version of the geometry.

    ComPtr<ID2D1TransformedGeometry> rotatedPaperGeometry;

    D2D_MATRIX_3X2_F translation = D2D1::Matrix3x2F::Translation(
        (size.width / 4) + (RandomFloat() * (size.width / 2)),
        (size.height / 4) + (RandomFloat() * (size.height / 2))
        );

    D2D_MATRIX_3X2_F rotation = D2D1::Matrix3x2F::Rotation(
        RandomFloat() * 30.0f - 15.0f
        );

    DX::ThrowIfFailed(
        m_d2dFactory->CreateTransformedGeometry(
            paperGeometry.Get(),
            &(rotation * translation),
            &rotatedPaperGeometry
            )
        );

    // Create a new paper fragment from the rotated geometry.

    PaperFragment^ paperFragment =
        ref new PaperFragment(
            m_d2dContext,
            rotatedPaperGeometry.Get(),
            D2D1::ColorF(
                0.5f + 0.5f*RandomFloat(),
                0.5f + 0.5f*RandomFloat(),
                0.5f + 0.5f*RandomFloat(),
                1.0f
                )
            );

    paperFragment->SetPosition(D2D1::Point2F(0, 0));

    m_paperFragmentList.push_back(paperFragment);
}

void PaperRenderer::CreateDeviceIndependentResources ( Microsoft::WRL::ComPtr< ID2D1Factory1 > d2dFactory )
void PaperRenderer::CreateDeviceResources ( Microsoft::WRL::ComPtr< ID2D1DeviceContext > d2dContext )
void PaperRenderer::CreateWindowSizeDependentResources ( float dpi )

Definition at line 89 of file PaperRenderer.cpp.

{
    // Save shared DPI.
    m_dpi = dpi;
}

void PaperRenderer::DrawPaper ( )

Definition at line 95 of file PaperRenderer.cpp.

{
    D2D1_SIZE_F size = m_d2dContext->GetSize();

    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    for (PaperFragment^ fragment : m_paperFragmentList)
    {
        fragment->Draw();
    }
}

PaperFragment PaperRenderer::HitTestFragmentsWithPosition ( D2D1_POINT_2F position ) [private]

Definition at line 255 of file PaperRenderer.cpp.

{
    PaperFragment^ chosenFragment = nullptr;
    for (PaperFragment^ fragment : m_paperFragmentList)
    {
        if (fragment->HitTest(position))
        {
            chosenFragment = fragment;
        }
    };
    return chosenFragment;
}

void PaperRenderer::MovePaper ( )

Definition at line 171 of file PaperRenderer.cpp.

{
    m_paperMode = PaperMode::Moving;
}

void PaperRenderer::OnManipulationCompleted ( Windows::UI::Xaml::Input::ManipulationCompletedRoutedEventArgs^ args )
void PaperRenderer::OnManipulationDelta ( Windows::UI::Xaml::Input::ManipulationDeltaRoutedEventArgs^ args )
void PaperRenderer::OnManipulationStarted ( Windows::UI::Xaml::Input::ManipulationStartedRoutedEventArgs^ args )
void PaperRenderer::OnTapped ( Windows::Foundation::Point position )
float PaperRenderer::RandomFloat ( ) [private]

Definition at line 268 of file PaperRenderer.cpp.

{
    return static_cast<float>(rand()) / static_cast<float>(RAND_MAX);
}

void PaperRenderer::RemovePaper ( )

Definition at line 166 of file PaperRenderer.cpp.

{
    m_paperMode = PaperMode::Deleting;
}

void PaperRenderer::Reset ( )

Definition at line 181 of file PaperRenderer.cpp.

{
    m_paperMode = PaperMode::Moving;
    m_paperFragmentList.clear();
    m_selectedFragment = nullptr;
}

void PaperRenderer::StampPaper ( )

Definition at line 176 of file PaperRenderer.cpp.

{
    m_paperMode = PaperMode::Stamping;
}

Member Data Documentation

internal PaperRenderer::__pad0__

Definition at line 22 of file PaperRenderer.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> PaperRenderer::m_blackBrush [private]

Definition at line 51 of file PaperRenderer.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> PaperRenderer::m_d2dContext [private]

Definition at line 47 of file PaperRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Factory1> PaperRenderer::m_d2dFactory [private]

Definition at line 46 of file PaperRenderer.h.

float PaperRenderer::m_dpi [private]

Definition at line 48 of file PaperRenderer.h.

std::list<PaperFragment^> PaperRenderer::m_paperFragmentList [private]

Definition at line 53 of file PaperRenderer.h.

PaperMode PaperRenderer::m_paperMode [private]

Definition at line 55 of file PaperRenderer.h.

PaperFragment PaperRenderer::m_selectedFragment [private]

Definition at line 54 of file PaperRenderer.h.

Microsoft::WRL::ComPtr<ID2D1Geometry> PaperRenderer::m_starStampGeometry [private]

Definition at line 52 of file PaperRenderer.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/PaperRenderer.h
  • DirectX postcard app/C++/PaperRenderer.cpp
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Parser Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

Parser Class Reference

#include "Parse.h"

List of all members.

Public Member Functions

Parser ()
Parser ()
~Parser ()
~Parser ()
void | ClearPacket ()
void | ClearPacket ()
HRESULT | GetSystemHeader (MPEG1SystemHeader **ppHeader)
HRESULT | GetSystemHeader (MPEG1SystemHeader **ppHeader)
BOOL | HasPacket () const
BOOL | HasPacket () const
BOOL | HasSystemHeader () const
BOOL | HasSystemHeader () const
BOOL | IsEndOfStream () const
BOOL | IsEndOfStream () const
const MPEG1PacketHeader & | PacketHeader ()
const MPEG1PacketHeader & | PacketHeader ()
HRESULT | ParseBytes (const BYTE *pData, DWORD cbLen, DWORD *pAte)
HRESULT | ParseBytes (const BYTE *pData, DWORD cbLen, DWORD *pAte)
DWORD | PayloadSize () const
DWORD | PayloadSize () const

Private Member Functions

HRESULT | FindNextStartCode (const BYTE *pData, DWORD cbLen, DWORD *pAte)
HRESULT | FindNextStartCode (const BYTE *pData, DWORD cbLen, DWORD *pAte)
HRESULT | OnEndOfStream ()
HRESULT | OnEndOfStream ()
HRESULT | ParsePacketHeader (const BYTE *pData, DWORD cbLen, DWORD *pAte)
HRESULT | ParsePacketHeader (const BYTE *pData, DWORD cbLen, DWORD *pAte)
HRESULT | ParsePackHeader (const BYTE *pData, DWORD cbLen, DWORD *pAte)
HRESULT | ParsePackHeader (const BYTE *pData, DWORD cbLen, DWORD *pAte)
HRESULT | ParseSystemHeader (const BYTE *pData, DWORD cbLen, DWORD *pAte)
HRESULT | ParseSystemHeader (const BYTE *pData, DWORD cbLen, DWORD *pAte)

Private Attributes

BOOL | m_bEOS
BOOL | m_bHasPacketHeader
MPEG1PacketHeader m_curPacketHeader
DWORD | m_muxRate
MPEG1SystemHeader * m_pHeader
LONGLONG | m_SCR

Detailed Description

Definition at line 221 of file Parse.h.

Constructor & Destructor Documentation

Parser::Parser ( )

Definition at line 299 of file Parse.cpp.

               : m_SCR(0), m_muxRate(0), m_pHeader(NULL), m_bHasPacketHeader(FALSE), m_bEOS(FALSE)
{
    ZeroMemory(&m_curPacketHeader, sizeof(m_curPacketHeader));
}

Parser::~Parser ( )

Definition at line 304 of file Parse.cpp.

{
    CoTaskMemFree(m_pHeader);
}

Parser::Parser ( )
Parser::~Parser ( )

Member Function Documentation

void Parser::ClearPacket ( ) [inline]

Definition at line 237 of file Parse.h.

{ m_bHasPacketHeader = FALSE; }

void Parser::ClearPacket ( ) [inline]

Definition at line 237 of file Parse.h.

{ m_bHasPacketHeader = FALSE; }

HRESULT Parser::FindNextStartCode | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte |
 | ) |  |  | [private]

Definition at line 427 of file Parse.cpp.

{
    HRESULT hr = S_FALSE;

    DWORD cbLeft = cbLen;

    while (cbLeft > 4)
    {
        if ( (MAKE_DWORD_HOSTORDER(pData) & 0x00FFFFFF) == 0x00010000 )
        {
            hr = S_OK;
            break;
        }

        cbLeft -= 4;
        pData += 4;
    }
    *pAte = (cbLen - cbLeft);
    return hr;
}

HRESULT Parser::FindNextStartCode | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte |
 | ) |  |  | [private]
HRESULT Parser::GetSystemHeader ( MPEG1SystemHeader ** ppHeader )
HRESULT Parser::GetSystemHeader ( MPEG1SystemHeader ** ppHeader )

Definition at line 319 of file Parse.cpp.

{
    if (ppHeader == NULL)
    {
        return E_POINTER;
    }

    if (!HasSystemHeader())
    {
        return E_FAIL;
    }

    assert(m_pHeader->cbSize > 0);

    MPEG1SystemHeader *pHeader = (MPEG1SystemHeader*)CoTaskMemAlloc(m_pHeader->cbSize);
    if (pHeader == NULL)
    {
        return E_OUTOFMEMORY;
    }

    CopyMemory(pHeader, m_pHeader, m_pHeader->cbSize);

    *ppHeader = pHeader;
    return S_OK;
}

BOOL Parser::HasPacket ( ) const [inline]

Definition at line 233 of file Parse.h.

{ return m_bHasPacketHeader; }

BOOL Parser::HasPacket ( ) const [inline]

Definition at line 233 of file Parse.h.

{ return m_bHasPacketHeader; }

BOOL Parser::HasSystemHeader ( ) const [inline]

Definition at line 230 of file Parse.h.

{ return m_pHeader != NULL; }

BOOL Parser::HasSystemHeader ( ) const [inline]

Definition at line 230 of file Parse.h.

{ return m_pHeader != NULL; }

BOOL Parser::IsEndOfStream ( ) const [inline]

Definition at line 239 of file Parse.h.

{ return m_bEOS; }

BOOL Parser::IsEndOfStream ( ) const [inline]

Definition at line 239 of file Parse.h.

{ return m_bEOS; }

HRESULT Parser::OnEndOfStream ( ) [private]

Definition at line 778 of file Parse.cpp.

{
    m_bEOS = TRUE;
    ClearPacket();

    return S_OK;
}

HRESULT Parser::OnEndOfStream ( ) [private]
const MPEG1PacketHeader& Parser::PacketHeader ( ) [inline]

Definition at line 234 of file Parse.h.

{ assert(m_bHasPacketHeader); return m_curPacketHeader; }

const MPEG1PacketHeader& Parser::PacketHeader ( ) [inline]

Definition at line 234 of file Parse.h.

{ assert(m_bHasPacketHeader); return m_curPacketHeader; }

HRESULT Parser::ParseBytes | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte
 | ) |  |

Definition at line 360 of file Parse.cpp.

{
    *pAte = 0;

    if (cbLen < 4)
    {
        return S_FALSE;
    }

    HRESULT hr = S_OK;
    DWORD cbLengthToStartCode = 0;  // How much we skip to reach the next start code.
    DWORD cbParsed = 0;             // How much we parse after the start code.

    m_bHasPacketHeader = FALSE;

    hr = FindNextStartCode(pData, cbLen, &cbLengthToStartCode);

    if (hr == S_OK)
    {
        cbLen -= cbLengthToStartCode;
        pData += cbLengthToStartCode;

        switch (MAKE_DWORD(pData))
        {
        case MPEG1_PACK_START_CODE:
            // Start of pack.
            hr = ParsePackHeader(pData, cbLen, &cbParsed);
            break;

        case MPEG1_SYSTEM_HEADER_CODE:
            // Start of system header.
            hr = ParseSystemHeader(pData, cbLen, &cbParsed);
            break;

        case MPEG1_STOP_CODE:
            // Stop code, end of stream.
            cbParsed = sizeof(DWORD);
            hr = OnEndOfStream();
            break;

        default:
            // Start of packet.
            hr = ParsePacketHeader(pData, cbLen, &cbParsed);
            break;

        }
    }

    if (hr == S_OK)
    {
        *pAte = cbLengthToStartCode + cbParsed;
    }
    return hr;
};

HRESULT Parser::ParseBytes | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte
 | ) |  |
HRESULT Parser::ParsePacketHeader | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte |
 | ) |  |  | [private]

Definition at line 621 of file Parse.cpp.

{
    if (!HasSystemHeader())
    {
        return E_FAIL; // We should not get a packet before the first system header.
    }

    if (cbLen < MPEG1_PACKET_HEADER_MIN_SIZE)
    {
        return S_FALSE; // Not enough data yet.
    }

    // Before we parse anything else in the packet header, look for the header length.
    DWORD cbPacketLen = MAKE_WORD(pData[4], pData[5]) + MPEG1_PACKET_HEADER_MIN_SIZE;

    // We want enough data for the maximum packet header OR the total packet size, whichever is less.
    if (cbLen < cbPacketLen && cbLen < MPEG1_PACKET_HEADER_MAX_SIZE)
    {
        return S_FALSE; // Not enough data yet.
    }

    // Make sure the start code is 0x000001xx
    if ((MAKE_DWORD(pData) & 0xFFFFFF00) != MPEG1_START_CODE_PREFIX)
    {
        return E_FAIL;
    }

    HRESULT hr = S_OK;
    BYTE id = 0;
    StreamType type = StreamType_Unknown;
    BYTE num = 0;
    BOOL bHasPTS = FALSE;

    ZeroMemory(&m_curPacketHeader, sizeof(m_curPacketHeader));

    // Find the stream ID.
    id = pData[3];
    hr = ParseStreamId(id, &type, &num);
    if (FAILED(hr))
    {
        return hr;
    }

    DWORD cbLeft = cbPacketLen - MPEG1_PACKET_HEADER_MIN_SIZE;
    pData = pData + MPEG1_PACKET_HEADER_MIN_SIZE;
    DWORD cbPadding = 0;
    LONGLONG pts = 0;

    // Go past the stuffing bytes.
    while ((cbLeft > 0) && (*pData == 0xFF))
    {
        AdvanceBufferPointer(pData, cbLeft, 1);
        ++cbPadding;
    }

    // Check for invalid number of stuffing bytes.
    if (cbPadding > MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE)
    {
        hr = E_FAIL;
    }

    // The next bits are:
    // (optional) STD buffer size (2 bytes)
    // union
    // {
    //      PTS (5 bytes)
    //      PTS + DTS (10 bytes)
    //      '0000 1111' (1 bytes)
    // }

    if (SUCCEEDED(hr))
    {
        hr = ValidateBufferSize(cbLeft, 1);
    }

    if (SUCCEEDED(hr))
    {
        if ((*pData & 0xC0) == 0x40)
        {
            // Skip STD buffer size.
            hr = AdvanceBufferPointer(pData, cbLeft, 2);
        }
    }

    if (SUCCEEDED(hr))
    {
        hr = ValidateBufferSize(cbLeft, 1);
    }

    if (SUCCEEDED(hr))
    {
        if ((*pData & 0xF1) == 0x21)
        {
            // PTS
            hr = ValidateBufferSize(cbLeft, 5);

            if (SUCCEEDED(hr))
            {
                ParsePTS(pData, &pts);
                bHasPTS = TRUE;

                hr = AdvanceBufferPointer(pData, cbLeft, 5);
            }
        }
        else if ((*pData & 0xF1) == 0x31)
        {
            // PTS + DTS
            hr = ValidateBufferSize(cbLeft, 10);

            // Parse PTS but skip DTS.
            if (SUCCEEDED(hr))
            {
                ParsePTS(pData, &pts);
                bHasPTS = TRUE;

                hr = AdvanceBufferPointer(pData, cbLeft, 10);
            }
        }
        else if ((*pData) == 0x0F)
        {
            hr = AdvanceBufferPointer(pData, cbLeft, 1);
        }
        else
        {
            hr = E_FAIL; // Unexpected bit field
        }
    }

    if (SUCCEEDED(hr))
    {
        m_curPacketHeader.stream_id = id;
        m_curPacketHeader.type = type;
        m_curPacketHeader.number = num;
        m_curPacketHeader.cbPacketSize = cbPacketLen;
        m_curPacketHeader.cbPayload = cbLeft;
        m_curPacketHeader.bHasPTS = bHasPTS;
        m_curPacketHeader.PTS = pts;

        // Client can read the packet now.
        m_bHasPacketHeader = TRUE;

        *pAte = cbPacketLen - cbLeft;
    }

    return hr;
}

HRESULT Parser::ParsePacketHeader | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte |
 | ) |  |  | [private]
HRESULT Parser::ParsePackHeader | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte |
 | ) |  |  | [private]

Definition at line 454 of file Parse.cpp.

{
    assert( MAKE_DWORD(pData) == MPEG1_PACK_START_CODE );

    if (cbLen < MPEG1_PACK_HEADER_SIZE)
    {
        return S_FALSE; // Not enough data yet.
    }

    // Check marker bits
    if ( ((pData[4] & 0xF1) != 0x21) ||
        ((pData[6] & 0x01) != 0x01) ||
        ((pData[8] & 0x01) != 0x01) ||
        ((pData[9] & 0x80) != 0x80) ||
        ((pData[11] & 0x01) != 0x01) )
    {
        return E_FAIL;
    }

    // Calculate the SCR.
    LONGLONG scr = ( (pData[8] & 0xFE) >> 1) |
        ( (pData[7]) << 7) |
        ( (pData[6] & 0xFE) << 14) |
        ( (pData[5]) << 22) |
        ( (pData[4] & 0x0E) << 29);

    DWORD muxRate = ( (pData[11] & 0xFE) >> 1) |
        ( (pData[10]) << 7) |
        ( (pData[9] & 0x7F) << 15);

    m_SCR = scr;
    m_muxRate = muxRate;

    *pAte = MPEG1_PACK_HEADER_SIZE;

    return S_OK;
}

HRESULT Parser::ParsePackHeader | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte |
 | ) |  |  | [private]
HRESULT Parser::ParseSystemHeader | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte |
 | ) |  |  | [private]
HRESULT Parser::ParseSystemHeader | ( | const BYTE * | pData,
 |  | DWORD | cbLen,
 |  | DWORD * | pAte |
 | ) |  |  | [private]

Definition at line 505 of file Parse.cpp.

{
    assert( MAKE_DWORD(pData) == MPEG1_SYSTEM_HEADER_CODE );

    if (cbLen < MPEG1_SYSTEM_HEADER_MIN_SIZE)
    {
        return S_FALSE; // Not enough data yet.
    }

    // Find the total header length.
    DWORD cbHeaderLen = MPEG1_SYSTEM_HEADER_PREFIX +  MAKE_WORD(pData[4], pData[5]);

    if (cbHeaderLen < MPEG1_SYSTEM_HEADER_MIN_SIZE - MPEG1_SYSTEM_HEADER_PREFIX)
    {
        return E_FAIL;  // Invalid value.
    }

    if (cbLen < cbHeaderLen)
    {
        return S_FALSE; // Not enough data yet.
    }

    // We have enough data to parse the header.

    HRESULT hr = S_OK;

    // Did we already see a system header?
    if (!HasSystemHeader())
    {
        // This is the first time we've seen the header. Parse it.

        // Calculate the number of stream info's in the header.
        DWORD cStreamInfo = (cbHeaderLen - MPEG1_SYSTEM_HEADER_MIN_SIZE) / MPEG1_SYSTEM_HEADER_STREAM;

        // Calculate the structure size.
        DWORD cbSize = sizeof(MPEG1SystemHeader);
        if (cStreamInfo > 1)
        {
            cbSize += sizeof(MPEG1StreamHeader) * (cStreamInfo - 1);
        }

        // Allocate room for the header.
        m_pHeader = (MPEG1SystemHeader*)CoTaskMemAlloc(cbSize);
        if (m_pHeader == NULL)
        {
            hr = E_OUTOFMEMORY;
        }

        if (SUCCEEDED(hr))
        {
            m_pHeader->cbSize = cbSize;
        }

        // Check marker bits
        if (SUCCEEDED(hr))
        {
            if ( ((pData[6] & 0x80) != 0x80) ||
                ((pData[8] & 0x01) != 0x01) ||
                ((pData[10] & 0x20) != 0x20) ||
                (pData[11] != 0xFF) )
            {
                hr = E_FAIL;  // Invalid bits.
            }
        }

        if (SUCCEEDED(hr))
        {
            m_pHeader->rateBound = ((pData[6] & 0x7F) << 16) | (pData[7] << 8) | (pData[8] >> 1);
            m_pHeader->cAudioBound = pData[9] >> 2;
            m_pHeader->bFixed = HAS_FLAG(pData[9], 0x02);
            m_pHeader->bCSPS = HAS_FLAG(pData[9], 0x01);
            m_pHeader->bAudioLock = HAS_FLAG(pData[10], 0x80);
            m_pHeader->bVideoLock = HAS_FLAG(pData[10], 0x40);
            m_pHeader->cVideoBound = pData[10] & 0x1F;
            m_pHeader->cStreams = cStreamInfo;

            // Parse the stream information.
            const BYTE *pStreamInfo = pData + MPEG1_SYSTEM_HEADER_MIN_SIZE;

            for (DWORD i = 0; i < cStreamInfo; i++)
            {
                hr = ParseStreamData(pStreamInfo, m_pHeader->streams[i]);

                if (FAILED(hr))
                {
                    break;
                }

                pStreamInfo += MPEG1_SYSTEM_HEADER_STREAM;
            }
        }
    }

    if (SUCCEEDED(hr))
    {
        *pAte = cbHeaderLen;
    }

    if (FAILED(hr))
    {
        CoTaskMemFree(m_pHeader);
        m_pHeader = NULL;
    }

    return hr;
}

DWORD Parser::PayloadSize ( ) const [inline]

Definition at line 236 of file Parse.h.

{ assert(m_bHasPacketHeader); return m_curPacketHeader.cbPayload; }

DWORD Parser::PayloadSize ( ) const [inline]

Definition at line 236 of file Parse.h.

{ assert(m_bHasPacketHeader); return m_curPacketHeader.cbPayload; }

Member Data Documentation

BOOL Parser::m_bEOS [private]

Definition at line 260 of file Parse.h.

BOOL Parser::m_bHasPacketHeader [private]

Definition at line 257 of file Parse.h.

MPEG1PacketHeader Parser::m_curPacketHeader [private]

Definition at line 258 of file Parse.h.

DWORD Parser::m_muxRate [private]

Definition at line 252 of file Parse.h.

MPEG1SystemHeader * Parser::m_pHeader [private]

Definition at line 254 of file Parse.h.

LONGLONG Parser::m_SCR [private]

Definition at line 251 of file Parse.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.cpp
  • Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.cpp
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ParticleData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ParticleData Struct Reference

#include "SimpleSprites.h"

List of all members.

Public Attributes

float2 pos
float2 vel

Detailed Description

Definition at line 42 of file SimpleSprites.h.

Member Data Documentation

float2 ParticleData::pos

Definition at line 44 of file SimpleSprites.h.

float2 ParticleData::vel

Definition at line 45 of file SimpleSprites.h.

The documentation for this struct was generated from the following file:
  • Direct3D sprite/C++/SimpleSprites.h
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PersistentState Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

PersistentState Class Reference

#include "PersistentState.h"

List of all members.

Public Member Functions

bool | LoadBool (Platform::String^key, bool defaultValue)
bool | LoadBool (Platform::String^key, bool defaultValue)
bool | LoadBool (Platform::String^key, bool defaultValue)
bool | LoadBool (Platform::String^key, bool defaultValue)
int | LoadInt32 (Platform::String^key, int defaultValue)
int | LoadInt32 (Platform::String^key, int defaultValue)
int | LoadInt32 (Platform::String^key, int defaultValue)
int | LoadInt32 (Platform::String^key, int defaultValue)
float | LoadSingle (Platform::String^key, float defaultValue)
float | LoadSingle (Platform::String^key, float defaultValue)
float | LoadSingle (Platform::String^key, float defaultValue)
float | LoadSingle (Platform::String^key, float defaultValue)
Platform::String | LoadString (Platform::String^key, Platform::String^defaultValue)
Platform::String | LoadString (Platform::String^key, Platform::String^defaultValue)
Platform::String | LoadString (Platform::String^key, Platform::String^defaultValue)
Platform::String | LoadString (Platform::String^key, Platform::String^defaultValue)
DirectX::XMFLOAT3 | LoadXMFLOAT3 (Platform::String^key, DirectX::XMFLOAT3 defaultValue)
DirectX::XMFLOAT3 | LoadXMFLOAT3 (Platform::String^key, DirectX::XMFLOAT3 defaultValue)
DirectX::XMFLOAT3 | LoadXMFLOAT3 (Platform::String^key, DirectX::XMFLOAT3 defaultValue)
DirectX::XMFLOAT3 | LoadXMFLOAT3 (Platform::String^key, DirectX::XMFLOAT3 defaultValue)
void | SaveBool (Platform::String^key, bool value)
void | SaveBool (Platform::String^key, bool value)
void | SaveBool (Platform::String^key, bool value)
void | SaveBool (Platform::String^key, bool value)
void | SaveInt32 (Platform::String^key, int value)
void | SaveInt32 (Platform::String^key, int value)
void | SaveInt32 (Platform::String^key, int value)
void | SaveInt32 (Platform::String^key, int value)
void | SaveSingle (Platform::String^key, float value)
void | SaveSingle (Platform::String^key, float value)
void | SaveSingle (Platform::String^key, float value)
void | SaveSingle (Platform::String^key, float value)
void | SaveString (Platform::String^key, Platform::String^string)
void | SaveString (Platform::String^key, Platform::String^string)
void | SaveString (Platform::String^key, Platform::String^string)
void | SaveString (Platform::String^key, Platform::String^string)
void | SaveXMFLOAT3 (Platform::String^key, DirectX::XMFLOAT3 value)
void | SaveXMFLOAT3 (Platform::String^key, DirectX::XMFLOAT3 value)
void | SaveXMFLOAT3 (Platform::String^key, DirectX::XMFLOAT3 value)
void | SaveXMFLOAT3 (Platform::String^key, DirectX::XMFLOAT3 value)

Public Attributes

internal | __pad0__: void Initialize( _In_ Windows::Foundation::Collections::IPropertySet^ settingsValues
internal _In_ Platform::String | key

Private Attributes

Platform::String | m_keyName
Windows::Foundation::Collections::IPropertySet | m_settingsValues

Detailed Description

Definition at line 13 of file PersistentState.h.

Member Function Documentation

bool PersistentState::LoadBool | ( | Platform::String^ | key,
 |  | bool | defaultValue
 | ) |  |

Definition at line 81 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        int state = safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetInt32();
        return state ? true : false;
    }
    return defaultValue;
}

bool PersistentState::LoadBool | ( | Platform::String^ | key,
 |  | bool | defaultValue
 | ) |  |
bool PersistentState::LoadBool | ( | Platform::String^ | key,
 |  | bool | defaultValue
 | ) |  |
bool PersistentState::LoadBool | ( | Platform::String^ | key,
 |  | bool | defaultValue
 | ) |  |
int PersistentState::LoadInt32 | ( | Platform::String^ | key,
 |  | int | defaultValue
 | ) |  |
int PersistentState::LoadInt32 | ( | Platform::String^ | key,
 |  | int | defaultValue
 | ) |  |
int PersistentState::LoadInt32 | ( | Platform::String^ | key,
 |  | int | defaultValue
 | ) |  |

Definition at line 92 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        return safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetInt32();
    }
    return defaultValue;
}

int PersistentState::LoadInt32 | ( | Platform::String^ | key,
 |  | int | defaultValue
 | ) |  |
float PersistentState::LoadSingle | ( | Platform::String^ | key,
 |  | float | defaultValue
 | ) |  |

Definition at line 102 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        return safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetSingle();
    }
    return defaultValue;
}

float PersistentState::LoadSingle | ( | Platform::String^ | key,
 |  | float | defaultValue
 | ) |  |
float PersistentState::LoadSingle | ( | Platform::String^ | key,
 |  | float | defaultValue
 | ) |  |
float PersistentState::LoadSingle | ( | Platform::String^ | key,
 |  | float | defaultValue
 | ) |  |
Platform::String PersistentState::LoadString | ( | Platform::String^ | key,
 |  | Platform::String^ | defaultValue
 | ) |  |

Definition at line 128 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        return safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetString();
    }
    return defaultValue;
}

Platform::String PersistentState::LoadString | ( | Platform::String^ | key,
 |  | Platform::String^ | defaultValue
 | ) |  |
Platform::String PersistentState::LoadString | ( | Platform::String^ | key,
 |  | Platform::String^ | defaultValue
 | ) |  |
Platform::String PersistentState::LoadString | ( | Platform::String^ | key,
 |  | Platform::String^ | defaultValue
 | ) |  |
XMFLOAT3 PersistentState::LoadXMFLOAT3 | ( | Platform::String^ | key,
 |  | DirectX::XMFLOAT3 | defaultValue
 | ) |  |

Definition at line 112 of file PersistentState.cpp.

{
    XMFLOAT3 value;
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        Platform::Array<float>^ array3;
        safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetSingleArray(&array3);
        value.x = array3[0];
        value.y = array3[1];
        value.z = array3[2];
        return value;
    }
    return defaultValue;
}

DirectX::XMFLOAT3 PersistentState::LoadXMFLOAT3 | ( | Platform::String^ | key,
 |  | DirectX::XMFLOAT3 | defaultValue
 | ) |  |
DirectX::XMFLOAT3 PersistentState::LoadXMFLOAT3 | ( | Platform::String^ | key,
 |  | DirectX::XMFLOAT3 | defaultValue
 | ) |  |
DirectX::XMFLOAT3 PersistentState::LoadXMFLOAT3 | ( | Platform::String^ | key,
 |  | DirectX::XMFLOAT3 | defaultValue
 | ) |  |
void PersistentState::SaveBool | ( | Platform::String^ | key,
 |  | bool | value
 | ) |  |
void PersistentState::SaveBool | ( | Platform::String^ | key,
 |  | bool | value
 | ) |  |
void PersistentState::SaveBool | ( | Platform::String^ | key,
 |  | bool | value
 | ) |  |

Definition at line 27 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        m_settingsValues->Remove(fullKey);
    }
    m_settingsValues->Insert(fullKey, PropertyValue::CreateInt32(value ? 1 : 0));
}

void PersistentState::SaveBool | ( | Platform::String^ | key,
 |  | bool | value
 | ) |  |
void PersistentState::SaveInt32 | ( | Platform::String^ | key,
 |  | int | value
 | ) |  |
void PersistentState::SaveInt32 | ( | Platform::String^ | key,
 |  | int | value
 | ) |  |

Definition at line 37 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        m_settingsValues->Remove(fullKey);
    }
    m_settingsValues->Insert(fullKey, PropertyValue::CreateInt32(value));
}

void PersistentState::SaveInt32 | ( | Platform::String^ | key,
 |  | int | value
 | ) |  |
void PersistentState::SaveInt32 | ( | Platform::String^ | key,
 |  | int | value
 | ) |  |
void PersistentState::SaveSingle | ( | Platform::String^ | key,
 |  | float | value
 | ) |  |
void PersistentState::SaveSingle | ( | Platform::String^ | key,
 |  | float | value
 | ) |  |

Definition at line 47 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        m_settingsValues->Remove(fullKey);
    }
    m_settingsValues->Insert(fullKey, PropertyValue::CreateSingle(value));
}

void PersistentState::SaveSingle | ( | Platform::String^ | key,
 |  | float | value
 | ) |  |
void PersistentState::SaveSingle | ( | Platform::String^ | key,
 |  | float | value
 | ) |  |
void PersistentState::SaveString | ( | Platform::String^ | key,
 |  | Platform::String^ | string
 | ) |  |

Definition at line 71 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        m_settingsValues->Remove(fullKey);
    }
    m_settingsValues->Insert(fullKey, PropertyValue::CreateString(string));
}

void PersistentState::SaveString | ( | Platform::String^ | key,
 |  | Platform::String^ | string
 | ) |  |
void PersistentState::SaveString | ( | Platform::String^ | key,
 |  | Platform::String^ | string
 | ) |  |
void PersistentState::SaveString | ( | Platform::String^ | key,
 |  | Platform::String^ | string
 | ) |  |
void PersistentState::SaveXMFLOAT3 | ( | Platform::String^ | key,
 |  | DirectX::XMFLOAT3 | value
 | ) |  |
void PersistentState::SaveXMFLOAT3 | ( | Platform::String^ | key,
 |  | DirectX::XMFLOAT3 | value
 | ) |  |
void PersistentState::SaveXMFLOAT3 | ( | Platform::String^ | key,
 |  | DirectX::XMFLOAT3 | value
 | ) |  |

Definition at line 57 of file PersistentState.cpp.

{
    Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
    if (m_settingsValues->HasKey(fullKey))
    {
        m_settingsValues->Remove(fullKey);
    }
    Platform::Array<float>^ array3 = ref new Platform::Array<float>(3);
    array3[0] = value.x;
    array3[1] = value.y;
    array3[2] = value.z;
    m_settingsValues->Insert(fullKey, PropertyValue::CreateSingleArray(array3));
}

void PersistentState::SaveXMFLOAT3 | ( | Platform::String^ | key,
 |  | DirectX::XMFLOAT3 | value
 | ) |  |

Member Data Documentation

internal PersistentState::__pad0__

Definition at line 17 of file PersistentState.h.

internal _In_ Platform::String PersistentState::key

Definition at line 17 of file PersistentState.h.

Platform::String PersistentState::m_keyName [private]

Definition at line 34 of file PersistentState.h.

Windows::Foundation::Collections::IPropertySet PersistentState::m_settingsValues [private]

Definition at line 35 of file PersistentState.h.

The documentation for this class was generated from the following files:
  • Direct2D 3D transform effect/C++/PersistentState.h
  • DirectX 3D shooting game/C++/PersistentState.h
  • DirectX marble maze game/C++/PersistentState.h
  • XAML DirectX 3D shooting game/C++/PersistentState.h
  • Direct2D 3D transform effect/C++/PersistentState.cpp
  • DirectX 3D shooting game/C++/PersistentState.cpp
  • DirectX marble maze game/C++/PersistentState.cpp
  • XAML DirectX 3D shooting game/C++/PersistentState.cpp
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Physics Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

Physics Class Reference

#include "Physics.h"

List of all members.

Public Member Functions

Physics ()
void | DebugReset ()
const XMFLOAT3 & | GetAcceleration () const
Collision * GetCollisionEngine ()
CollisionInfo | GetCollisionInfo () const
const XMFLOAT3 & | GetPosition () const
const XMFLOAT3 & | GetPreviousPosition ()
float | GetRadius () const
int | GetRoomDimensions (float *wallDistances, int size)
float | GetRoomSize ()
const XMFLOAT3 & | GetVelocity () const
BOOL | IsMoving () const
void | SetCollision (Collision *collision)
void | SetGravity (const XMFLOAT3 &gravityUnitNormal)
void | SetPosition (const XMFLOAT3 &position)
void | SetRadius (float radius)
void | SetVelocity (const XMFLOAT3 &velocity)
void | UpdatePhysicsSimulation (float deltaT)

Private Member Functions

void | ApplyForces ()
void | CalculateCurrentRoomSize ()
BOOL | FindInitialCollisions (float deltaT)
void | HandleCollisions (float deltaT)
void | IntegrateSimulation (float deltaT)

Private Attributes

XMFLOAT3 | m_acceleration
float | m_accumulatedTime
Collision * m_collision
float | m_currentRoomSize
XMFLOAT3 | m_gravity
XMFLOAT3 | m_maxCollisionSpeed
XMFLOAT3 | m_maxRollingSpeed
XMFLOAT3 | m_position
XMFLOAT3 | m_previousPosition
float | m_radius
XMFLOAT3 | m_velDueToAccel
XMFLOAT3 | m_velocity
float | m_wallDistances [8]

Detailed Description

Definition at line 33 of file Physics.h.

Constructor & Destructor Documentation

Physics::Physics ( )

Definition at line 60 of file Physics.cpp.

{
    ZeroMemory(&m_velDueToAccel, sizeof(XMFLOAT3));
    ZeroMemory(&m_position, sizeof(m_position));
    ZeroMemory(&m_velocity, sizeof(m_velocity));
    ZeroMemory(&m_velDueToAccel, sizeof(m_velDueToAccel));
    ZeroMemory(&m_acceleration, sizeof(m_acceleration));
    ZeroMemory(&m_gravity, sizeof(m_gravity));
    ZeroMemory(&m_maxCollisionSpeed, sizeof(m_maxCollisionSpeed));
    ZeroMemory(&m_maxRollingSpeed, sizeof(m_maxRollingSpeed));

    m_radius = 0.0f;
    m_accumulatedTime = 0.0f;

    // Default the room size in case room size is static.
    m_currentRoomSize = 300.0f;
}

Member Function Documentation

void Physics::ApplyForces ( ) [private]

Definition at line 50 of file Physics.cpp.

{
    const XMVECTOR gravity = XMLoadFloat3(&m_gravity);

    // We only have gravity acting on the ball - so this step is really simple.
    // More forces could be added here on a per-frame basis.

    XMStoreFloat3(&m_acceleration, gravity);
}

void Physics::CalculateCurrentRoomSize ( ) [private]

Definition at line 233 of file Physics.cpp.

{
#if !defined(DISABLE_RAYCAST_REVERB)
    static BOOL squarePattern = true;
    float wallDistances[4] = {FLT_MAX, FLT_MAX, FLT_MAX, FLT_MAX};
    XMVECTOR position = XMLoadFloat3(&m_position);
    size_t triCount = m_collision->m_wallTriList.size();
    XMVECTOR rayDirections[4];
    if (squarePattern)
    {
        rayDirections[0] = XMVectorSet( 0.0f,  1.0f, 0.0f, 0.0f);    // North
        rayDirections[1] = XMVectorSet( 0.0f, -1.0f, 0.0f, 0.0f);    // South
        rayDirections[2] = XMVectorSet(-1.0f,  0.0f, 0.0f, 0.0f);    // East
        rayDirections[3] = XMVectorSet( 1.0f,  0.0f, 0.0f, 0.0f);    // West
    }
    else
    {
        rayDirections[0] = XMVectorSet( 0.5f, -0.5f, 0.0f, 0.0f);    // NE
        rayDirections[1] = XMVectorSet( 0.5f,  0.5f, 0.0f, 0.0f);    // NW
        rayDirections[2] = XMVectorSet(-0.5f, -0.5f, 0.0f, 0.0f);    // SE
        rayDirections[3] = XMVectorSet(-0.5f,  0.5f, 0.0f, 0.0f);    // SW
    }
    float distance = 0.0f;

    // Loop through all triangles in the mesh, looking for intersections with a cast ray.
    for (size_t i = 0; i < triCount; ++i)
    {
        XMVECTOR A = XMLoadFloat3(&m_collision->m_wallTriList[i].A);
        XMVECTOR B = XMLoadFloat3(&m_collision->m_wallTriList[i].B);
        XMVECTOR C = XMLoadFloat3(&m_collision->m_wallTriList[i].C);

        // Loop through the cardinal directions, testing this triangle to see if it's in the path of a cast ray.
        for (int j = 0; j < 4; j++)
        {
            if (IntersectRayTriangle(position, rayDirections[j], A, B, C, &distance))
            {
                if (wallDistances[j] > distance)
                {
                    wallDistances[j] = distance;
                }
            }

        }
    }

    if (squarePattern)
    {
        memcpy(&m_wallDistances, wallDistances, 4*sizeof(float));
    }
    else
    {
        memcpy(&m_wallDistances[4], wallDistances, 4*sizeof(float));
    }

    // Default the room size to 1000.0f
    float roomSize = 1000.0f;
    for (int i = 0; i < 8; i++)
    {
        if (m_wallDistances[i] == FLT_MAX) // Some walls will not exist if the marble is outside.
        {
            m_wallDistances[i] = 1000.0f;
        }
    }

    // Calculate the size of the room, averaging the rectangular with the diagonal measurments.
    roomSize = sqrt(
        ((m_wallDistances[0] + m_wallDistances[1]) * (m_wallDistances[2]+m_wallDistances[3]) +
         (m_wallDistances[4] + m_wallDistances[5]) * (m_wallDistances[6]+m_wallDistances[7]))
        / 2.0f
        );

    if (roomSize > 1000.0f)
    {
        roomSize = 1000.0f;
    }

    m_currentRoomSize = roomSize;
    squarePattern = !squarePattern;
#endif
}

void Physics::DebugReset ( ) [inline]

Definition at line 53 of file Physics.h.

    {
        ZeroMemory(&m_velocity, sizeof(XMFLOAT3));
        ZeroMemory(&m_velDueToAccel, sizeof(XMFLOAT3));
        ZeroMemory(&m_acceleration, sizeof(XMFLOAT3));

        SetPosition(XMFLOAT3(286.39178f, -191.74507f, -42.355251f));
    }

BOOL Physics::FindInitialCollisions ( float deltaT ) [private]

Definition at line 136 of file Physics.cpp.

{
    XMVECTOR velocity = XMLoadFloat3(&m_velocity);
    Sphere bounds(m_position, m_radius);
    return m_collision->BuildCollisionListForSphere(bounds, velocity);
}

const XMFLOAT3& Physics::GetAcceleration ( ) const [inline]

Definition at line 153 of file Physics.h.

    {
        return m_acceleration;
    }

Collision* Physics::GetCollisionEngine ( ) [inline]

Definition at line 76 of file Physics.h.

    {
        return m_collision;
    }

CollisionInfo Physics::GetCollisionInfo ( ) const [inline]

Definition at line 63 of file Physics.h.

    {
        CollisionInfo ci;
        float maxRoll = m_maxRollingSpeed.x;
        float maxColl = m_maxCollisionSpeed.x;
        ci.maxRollingSpeed = maxRoll;
        ci.maxCollisionSpeed = maxColl;
        ci.isRollingOnFloor = maxRoll > MinVelocity;
        ci.elasticCollision = maxColl > MinAudibleCollisionSpeed;
        return ci;
    }

const XMFLOAT3& Physics::GetPosition ( ) const [inline]

Definition at line 128 of file Physics.h.

    {
        return m_position;
    }

const XMFLOAT3& Physics::GetPreviousPosition ( ) [inline]

Definition at line 134 of file Physics.h.

    {
        return m_previousPosition;
    }

float Physics::GetRadius ( ) const [inline]

Definition at line 108 of file Physics.h.

    {
        return m_radius;
    }

int Physics::GetRoomDimensions | ( | float * | wallDistances,
 |  | int | size |
 | ) |  |  | [inline]

Definition at line 88 of file Physics.h.

    {
        int returnedCount = min(ARRAYSIZE(m_wallDistances), size);
        memcpy(wallDistances, m_wallDistances, returnedCount*sizeof(float));
        return returnedCount;
    }

float Physics::GetRoomSize ( ) [inline]

Definition at line 82 of file Physics.h.

    {
        return m_currentRoomSize;
    }

const XMFLOAT3& Physics::GetVelocity ( ) const [inline]

Definition at line 147 of file Physics.h.

    {
        return m_velocity;
    }

void Physics::HandleCollisions ( float deltaT ) [private]

Definition at line 146 of file Physics.cpp.

{
    XMVECTOR velDueToGrav = XMLoadFloat3(&m_velDueToAccel);
    XMVECTOR velocity = XMLoadFloat3(&m_velocity);
    XMVECTOR position = XMLoadFloat3(&m_position);
    XMVECTOR radius = XMVectorReplicatePtr(&m_radius);
    XMVECTOR maxRollingSpeed = XMVectorZero();
    XMVECTOR maxCollisionSpeed = XMVectorZero();
    XMVECTOR deltaTime = XMVectorReplicate(deltaT);

    const size_t MAX_COLLISION_ITERATIONS = 8;
    for (size_t i = 0; i < MAX_COLLISION_ITERATIONS; ++i)
    {
        // Find the collision with the biggest intrusion into the mesh, that is facing in the opposite direction to the
        // way the ball is moving (i.e. has a positive closing velocity).
        Contact* contact = m_collision->FindWorstInterpenetration();
        if (contact == nullptr)
            break;

        XMVECTOR surfaceNormal = contact->GetSurfaceNormal();

        XMVECTOR velocityDotNormal = XMVector3Dot(surfaceNormal, velocity);
        XMVECTOR velGravDotNormal = XMVector3Dot(surfaceNormal, velDueToGrav);

        // Estimate how much the ball would have fallen into the mesh due to gravity this frame, if it started out
        // resting against it. If it's almost the same as the actual penetration, we must have been resting to start
        // with, so we can immediately cancel out this contribution.
        XMVECTOR penetrationDistance = XMVectorReplicatePtr(&contact->penetrationDistance);
        XMVECTOR distDueToGrav = velGravDotNormal * deltaTime;
        const XMVECTOR tolerance = XMVectorSet(0.1f, 0.1f, 0.1f, 0.1f);
        if (XMVector3NearEqual(penetrationDistance, distDueToGrav, tolerance))
        {
            // Contact

            // Kill velocity in surface-normal direction entirely.
            velocity = velocity - surfaceNormal * velocityDotNormal;

            XMVECTOR speed = XMVector3Length(velocity);
            XMVECTOR velocityDir = XMVector3Normalize(velocity); // could optimize...

            // Find acceleration into surface
            XMVECTOR accel = XMLoadFloat3(&m_acceleration);
            XMVECTOR ADotN = XMVector3Dot(accel, surfaceNormal);
            XMVECTOR select = XMVectorLessOrEqual(ADotN, XMVectorZero());
            XMVECTOR accelSurface = XMVectorSelect(XMVectorZero(), -ADotN, select);

            // Handle friction
            XMVECTOR frictionResponse =  accelSurface * wallFrictionCoeff * deltaTime;
            velocity = velocity - velocityDir * XMVectorMin(speed, frictionResponse);

            maxRollingSpeed = XMVectorMax(XMVector3LengthSq(velocityDir * velocity), maxRollingSpeed);

            // Make sure we're no longer in the mesh.
            position = contact->Resolve(position, radius);
        }
        else
        {
            // Elastic collision - reflect our velocity in the direction of the normal.
            float negRestitutionScalar = - (1.0f + WallRestitutionCoefficient);
            XMVECTOR negRestitution = XMVectorReplicate(negRestitutionScalar);

            // Keep track of max collision speed for the audio sim.
            maxCollisionSpeed = XMVectorMax(maxCollisionSpeed, velocityDotNormal * velocityDotNormal);

            // Update the velocity.
            velocity = velocity + (negRestitution * velocityDotNormal * surfaceNormal);

            // Make sure we're no longer in the mesh.
            position = contact->Resolve(position, radius);
        }

        // Remove this contact from consideration for this iteration.
        contact->Invalidate();

        // Update the penetration of the ball.
        m_collision->UpdateInterpenetrations(position, radius, velocity);
    }

    XMStoreFloat3(&m_velocity, velocity);
    XMStoreFloat3(&m_position, position);
    XMStoreFloat3(&m_maxRollingSpeed, XMVectorSqrt(maxRollingSpeed));
    XMStoreFloat3(&m_maxCollisionSpeed, XMVectorSqrt(maxCollisionSpeed));
}

void Physics::IntegrateSimulation ( float deltaT ) [private]

Definition at line 79 of file Physics.cpp.

{
    XMVECTOR deltaTime = XMVectorReplicate(deltaT);
    XMVECTOR position = XMLoadFloat3(&m_position);
    XMVECTOR velocity = XMLoadFloat3(&m_velocity);
    XMVECTOR acceleration = XMLoadFloat3(&m_acceleration);

    // Calculate new velocity due to acceleration for the time-slice.

    XMVECTOR velDueToAccel =  acceleration * deltaTime;
    XMStoreFloat3(&m_velDueToAccel, velDueToAccel);
    velocity = velocity + velDueToAccel;

    // const XMVECTOR vHalf = {0.5f, 0.5f, 0.5f, 0.5f};
    XMVECTOR newPosition = position + velocity * deltaTime;
    XMStoreFloat3(&m_position, newPosition);

    // Damping & stabilization

#if defined(ENABLE_VELOCITY_DAMPING)

    // Continuously drain energy from the ball.

    XMVECTOR speed = XMVector3Length(velocity);

    const XMVECTOR velDampAmount = XMVectorReplicate(Damping);
    XMVECTOR velUnit = XMVector3Normalize(velocity);

    XMVECTOR dampTotal = XMVectorMin(velDampAmount, speed);
    velocity = velocity - (dampTotal * velUnit);

#endif // defined(ENABLE_VELOCITY_DAMPING)

    // Make sure velocity stays within a safe range and doesn't spiral off, by clamping it.
    XMVECTOR velSpeed = XMVector3Length(velocity);

    const XMVECTOR maxVelocity = XMVectorReplicate(MaxVelocity);
    velSpeed = XMVectorMin(maxVelocity, velSpeed);
    velocity = velSpeed * XMVector3Normalize(velocity);

#if defined(ENABLE_VELOCITY_CLAMP_TO_ZERO)

    // If velocity is small enough (-1 <= v <= 1), set it to 0.

    const XMVECTOR velSq = XMVector3LengthSq(velocity);

    const XMVECTOR minVelocitySq = XMVectorReplicate(MinVelocity * MinVelocity);

    const XMVECTOR select = XMVectorLess(velSq, minVelocitySq);
    velocity = XMVectorSelect(velocity, XMVectorZero(), select);

#endif // defined(ENABLE_VELOCITY_CLAMP_TO_ZERO)

    XMStoreFloat3(&m_velocity, velocity);
}

BOOL Physics::IsMoving ( ) const [inline]

Definition at line 160 of file Physics.h.

    {
        return !XMVector3InBounds(XMLoadFloat3(&m_velocity), XMVectorReplicate(FLT_EPSILON));
    }

void Physics::SetCollision ( Collision * collision ) [inline]

Definition at line 96 of file Physics.h.

    {
        m_collision = collision;
    }

void Physics::SetGravity ( const XMFLOAT3 & gravityUnitNormal ) [inline]

Definition at line 114 of file Physics.h.

    {
        const XMVECTOR gravityMagnitude = XMVectorReplicate(Gravity);
        XMStoreFloat3(&m_gravity, XMLoadFloat3(&gravityUnitNormal) * gravityMagnitude);
    }

void Physics::SetPosition ( const XMFLOAT3 & position ) [inline]

Definition at line 121 of file Physics.h.

    {
        m_position = position;
        m_previousPosition = position;
    }

void Physics::SetRadius ( float radius ) [inline]

Definition at line 102 of file Physics.h.

    {
        m_radius = radius;
    }

void Physics::SetVelocity ( const XMFLOAT3 & velocity ) [inline]

Definition at line 140 of file Physics.h.

    {
        m_velocity = velocity;
        m_velDueToAccel = XMFLOAT3(0.0f, 0.0f, 0.0f);
    }

void Physics::UpdatePhysicsSimulation ( float deltaT )

Definition at line 20 of file Physics.cpp.

{
    // If the simulation is not advancing, do nothing.
    if (deltaT >= 0.0f && deltaT <= FLT_EPSILON)
    {
        return;
    }

    // Clamp the maximum timestep in case we're debugging.
    deltaT = min(deltaT, MaxPhysicsTimestep);

    // Keep the previous position
    m_previousPosition = m_position;

    // Update physics with fixed timestep, multiple iterations up to MaxPhysicsTimestep total
    m_accumulatedTime += deltaT;

    while (m_accumulatedTime >= PhysicsTimestep)
    {
        m_accumulatedTime -= PhysicsTimestep;
        ApplyForces();  // Gravity.
        IntegrateSimulation(PhysicsTimestep);    // Integrate for this frame.
        FindInitialCollisions(PhysicsTimestep);
        HandleCollisions(PhysicsTimestep);
    }

    CalculateCurrentRoomSize();
}

Member Data Documentation

XMFLOAT3 Physics::m_acceleration [private]

Definition at line 40 of file Physics.h.

float Physics::m_accumulatedTime [private]

Definition at line 47 of file Physics.h.

Collision* Physics::m_collision [private]

Definition at line 35 of file Physics.h.

float Physics::m_currentRoomSize [private]

Definition at line 45 of file Physics.h.

XMFLOAT3 Physics::m_gravity [private]

Definition at line 41 of file Physics.h.

XMFLOAT3 Physics::m_maxCollisionSpeed [private]

Definition at line 44 of file Physics.h.

XMFLOAT3 Physics::m_maxRollingSpeed [private]

Definition at line 43 of file Physics.h.

XMFLOAT3 Physics::m_position [private]

Definition at line 37 of file Physics.h.

XMFLOAT3 Physics::m_previousPosition [private]

Definition at line 36 of file Physics.h.

float Physics::m_radius [private]

Definition at line 42 of file Physics.h.

XMFLOAT3 Physics::m_velDueToAccel [private]

Definition at line 39 of file Physics.h.

XMFLOAT3 Physics::m_velocity [private]

Definition at line 38 of file Physics.h.

float Physics::m_wallDistances[8] [private]

Definition at line 46 of file Physics.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/Physics.h
  • DirectX marble maze game/C++/Physics.cpp
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PNTVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

PNTVertex Struct Reference

#include "ConstantBuffers.h"

List of all members.

Public Attributes

DirectX::XMFLOAT3 | normal
DirectX::XMFLOAT3 | position
DirectX::XMFLOAT2 | textureCoordinate

Detailed Description

Definition at line 10 of file ConstantBuffers.h.

Member Data Documentation

DirectX::XMFLOAT3 PNTVertex::normal

Definition at line 13 of file ConstantBuffers.h.

DirectX::XMFLOAT3 PNTVertex::position

Definition at line 12 of file ConstantBuffers.h.

DirectX::XMFLOAT2 PNTVertex::textureCoordinate

Definition at line 14 of file ConstantBuffers.h.

The documentation for this struct was generated from the following files:
  • DirectX 3D shooting game/C++/ConstantBuffers.h
  • XAML DirectX 3D shooting game/C++/ConstantBuffers.h
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PointSnapper Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Static Public Member Functions

PointSnapper Class Reference

#include "PointSnapper.h"

List of all members.

Classes

class | PointSnappingSink

Static Public Member Functions

static float | SnapCoordinate (float x)
static void | SnapGeometry (ID2D1Geometry *pGeometry, ID2D1Geometry **ppGeometry)
static D2D1_POINT_2F | SnapPoint (D2D1_POINT_2F pt)
static float2 | SnapPoint (float2 pt)

Detailed Description

Definition at line 12 of file PointSnapper.h.

Member Function Documentation

float PointSnapper::SnapCoordinate ( float x ) [static]

Definition at line 54 of file PointSnapper.cpp.

{
    return floorf((16.0f * x) + 0.5f) / 16.0f;
}

void PointSnapper::SnapGeometry | ( | ID2D1Geometry * | pGeometry,
 |  | ID2D1Geometry ** | ppGeometry |
 | ) |  |  | [static]

Definition at line 17 of file PointSnapper.cpp.

{
    ComPtr<ID2D1Factory> pFactory;
    pGeometry->GetFactory(&pFactory);

    ComPtr<ID2D1PathGeometry> pPathGeometry;
    DX::ThrowIfFailed(
        pFactory->CreatePathGeometry(&pPathGeometry)
        );

    ComPtr<ID2D1GeometrySink> pSink;
    DX::ThrowIfFailed(
        pPathGeometry->Open(&pSink)
        );

    ComPtr<PointSnappingSink> snapper;
    PointSnappingSink::CreatePointSnappingSink(
        pSink.Get(),
        &snapper
        );

    DX::ThrowIfFailed(
        pGeometry->Simplify(
            D2D1_GEOMETRY_SIMPLIFICATION_OPTION_LINES,
            nullptr, // world transform
            snapper.Get()
            )
        );

    DX::ThrowIfFailed(
        snapper->Close()
        );

    *ppGeometry = pPathGeometry.Get();
    (*ppGeometry)->AddRef();
}

D2D1_POINT_2F PointSnapper::SnapPoint ( D2D1_POINT_2F pt ) [static]

Definition at line 59 of file PointSnapper.cpp.

{
    return D2D1::Point2F(
        SnapCoordinate(pt.x),
        SnapCoordinate(pt.y)
        );
}

float2 PointSnapper::SnapPoint ( float2 pt ) [static]

Definition at line 67 of file PointSnapper.cpp.

{
    return float2(
        SnapCoordinate(pt.x),
        SnapCoordinate(pt.y)
        );
}

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/PointSnapper.h
  • DirectX postcard app/C++/PointSnapper.cpp
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PointSnapper::PointSnappingSink Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PointSnapper
  • PointSnapper::PointSnappingSink
Public Member Functions | Static Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

PointSnapper::PointSnappingSink Class Reference

List of all members.

Public Member Functions

STDMETHOD() | Close ()
STDMETHOD() | QueryInterface (REFIID riid, _Outptr_ void **object) override
STDMETHOD_ (ULONG, AddRef)() override
STDMETHOD_ (void, EndFigure)(D2D1_FIGURE_END figureEnd)
STDMETHOD_ (void, BeginFigure)(D2D1_POINT_2F startPoint
STDMETHOD_ (void, SetSegmentFlags)(D2D1_PATH_SEGMENT vertexFlags)
STDMETHOD_ (void, SetFillMode)(D2D1_FILL_MODE fillMode)
STDMETHOD_ (void, AddLines)(const D2D1_POINT_2F *points
STDMETHOD_ (void, AddBeziers)(const D2D1_BEZIER_SEGMENT *
STDMETHOD_ (ULONG, Release)() override

Static Public Member Functions

static void | CreatePointSnappingSink (_In_ ID2D1SimplifiedGeometrySink *pSink, _Outptr_ PointSnappingSink **ppPointSnappingSink)

Public Attributes

D2D1_FIGURE_BEGIN | figureBegin
UINT pointsCount
UINT

Private Member Functions

PointSnappingSink (_In_ ID2D1SimplifiedGeometrySink *pSink)

Private Attributes

ID2D1SimplifiedGeometrySink * | m_pSinkNoRef
ULONG | m_ref

Detailed Description

Definition at line 21 of file PointSnapper.h.

Constructor & Destructor Documentation

PointSnapper::PointSnappingSink::PointSnappingSink ( _In_ ID2D1SimplifiedGeometrySink * pSink ) [private]

Definition at line 87 of file PointSnapper.cpp.

                                                                                :
    m_pSinkNoRef(pSink),
    m_ref(0)
{
}

Member Function Documentation

HRESULT PointSnapper::PointSnappingSink::Close ( )

Definition at line 133 of file PointSnapper.cpp.

{
    return m_pSinkNoRef->Close();
}

void PointSnapper::PointSnappingSink::CreatePointSnappingSink | ( | _In_ ID2D1SimplifiedGeometrySink * | pSink,
 |  | _Outptr_ PointSnappingSink ** | ppPointSnappingSink |
 | ) |  |  | [static]

Definition at line 78 of file PointSnapper.cpp.

{
    *ppPointSnappingSink = new PointSnappingSink(pSink);
    (*ppPointSnappingSink)->AddRef();
}

HRESULT PointSnapper::PointSnappingSink::QueryInterface | ( | REFIID | riid,
 |  | _Outptr_ void ** | object |
 | ) |  |  | [override]

Definition at line 144 of file PointSnapper.cpp.

{
    *object = nullptr;
    return E_NOTIMPL;
}

PointSnapper::PointSnappingSink::STDMETHOD_ | ( | void | ,
 |  | AddBeziers |  |
 | ) |  |  | const
PointSnapper::PointSnappingSink::STDMETHOD_ | ( | void | ,
 |  | BeginFigure |
 | ) |  |
PointSnapper::PointSnappingSink::STDMETHOD_ | ( | void | ,
 |  | SetSegmentFlags |
 | ) |  |
PointSnapper::PointSnappingSink::STDMETHOD_ | ( | void | ,
 |  | SetFillMode |
 | ) |  |
PointSnapper::PointSnappingSink::STDMETHOD_ | ( | void | ,
 |  | EndFigure |
 | ) |  |
PointSnapper::PointSnappingSink::STDMETHOD_ | ( | ULONG | ,
 |  | Release |  |
 | ) |  |  | [override]
PointSnapper::PointSnappingSink::STDMETHOD_ | ( | void | ,
 |  | AddLines |  |
 | ) |  |  | const
PointSnapper::PointSnappingSink::STDMETHOD_ | ( | ULONG | ,
 |  | AddRef |  |
 | ) |  |  | [override]

Member Data Documentation

D2D1_FIGURE_BEGIN PointSnapper::PointSnappingSink::figureBegin

Definition at line 32 of file PointSnapper.h.

ID2D1SimplifiedGeometrySink* PointSnapper::PointSnappingSink::m_pSinkNoRef [private]

Definition at line 47 of file PointSnapper.h.

ULONG PointSnapper::PointSnappingSink::m_ref [private]

Definition at line 48 of file PointSnapper.h.

UINT PointSnapper::PointSnappingSink::pointsCount

Definition at line 31 of file PointSnapper.h.

PointSnapper::PointSnappingSink::UINT

Definition at line 30 of file PointSnapper.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/PointSnapper.h
  • DirectX postcard app/C++/PointSnapper.cpp
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Polygon Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

Polygon Struct Reference

#include "Shape.h"

List of all members.

Public Attributes

bool | isRect
int | numPoints
Windows::Foundation::Point | points [MAX_POLY_VERTICES]
Windows::Foundation::Rect | rcBound

Detailed Description

Definition at line 17 of file Shape.h.

Member Data Documentation

bool Polygon::isRect

Definition at line 19 of file Shape.h.

int Polygon::numPoints

Definition at line 20 of file Shape.h.

Windows::Foundation::Point Polygon::points[MAX_POLY_VERTICES]

Definition at line 21 of file Shape.h.

Windows::Foundation::Rect Polygon::rcBound

Definition at line 22 of file Shape.h.

The documentation for this struct was generated from the following file:
  • Input Touch hit testing/C++/Shape.h
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Postcard::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Postcard
  • Postcard::sealed
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Postcard::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
void | EffectIntensitySliderChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
EffectsFlyout ()
MainPage ()
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
PaperFlyout ()
SignatureFlyout ()
TextFlyout ()

Public Attributes

event ButtonClickedHandler | AddPaperClicked
event EffectIntensityChangedHandler | EffectIntensityChanged
event SignatureButtonClickedHandler | EraseClicked
event ButtonClickedHandler | MovePaperClicked
event ButtonClickedHandler | RemovePaperClicked
event SignatureButtonClickedHandler | SignClicked
event ButtonClickedHandler | StampPaperClicked
event TextSubmittedHandler | TextSubmitted

Private Member Functions

void | AddButtonClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | AddConstructionPaperClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | AddEffectsClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | AddImage ()
void | AddSignatureClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | AddTextClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | EffectIntensitySliderChanged (Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | EraseButtonClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | EraseClicked ()
void | GotFocusHandler (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Hide ()
void | Hide ()
void | LostFocusHandler (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | MoveButtonClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLogicalDpiChanged (Platform::Object^sender)
void | OnPointerMoved (Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnPointerPressed (Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnPointerReleased (Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnWindowSizeChanged (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | PaperFlyoutAddPaperClicked ()
void | PaperFlyoutDeletePaperClicked ()
void | PaperFlyoutMoveClicked ()
void | PaperFlyoutStampClicked ()
void | RemoveButtonClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ResetClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SaveClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShareClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SignButtonCicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SignClicked ()
void | StampButtonClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TextBoxKeyUp (Platform::Object^sender, Windows::UI::Xaml::Input::KeyRoutedEventArgs^e)
void | TextSubmitted (Platform::String^text)

Private Attributes

bool | m_atStartScreen
MainPage | m_mainPage
PostcardRenderer m_renderer

Detailed Description

Definition at line 16 of file App.xaml.h.

Member Function Documentation

void Postcard::sealed::AddButtonClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::AddConstructionPaperClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::AddEffectsClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::AddImage ( ) [private]
void Postcard::sealed::AddSignatureClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::AddTextClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Postcard::sealed::App ( )
void Postcard::sealed::EffectIntensitySliderChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e
 | ) |  |
void Postcard::sealed::EffectIntensitySliderChanged ( Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e ) [private]
Postcard::sealed::EffectsFlyout ( )
void Postcard::sealed::EraseButtonClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::EraseClicked ( ) [private]
void Postcard::sealed::GotFocusHandler | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::Hide ( ) [private]
void Postcard::sealed::Hide ( ) [private]
void Postcard::sealed::LostFocusHandler | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Postcard::sealed::MainPage ( )
void Postcard::sealed::MoveButtonClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void Postcard::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
void Postcard::sealed::OnLogicalDpiChanged ( Platform::Object^ sender ) [private]
void Postcard::sealed::OnPointerMoved | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | args |
 | ) |  |  | [private]
void Postcard::sealed::OnPointerPressed | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | args |
 | ) |  |  | [private]
void Postcard::sealed::OnPointerReleased | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | args |
 | ) |  |  | [private]
void Postcard::sealed::OnWindowSizeChanged | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
Postcard::sealed::PaperFlyout ( )
void Postcard::sealed::PaperFlyoutAddPaperClicked ( ) [private]
void Postcard::sealed::PaperFlyoutDeletePaperClicked ( ) [private]
void Postcard::sealed::PaperFlyoutMoveClicked ( ) [private]
void Postcard::sealed::PaperFlyoutStampClicked ( ) [private]
void Postcard::sealed::RemoveButtonClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::ResetClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::SaveClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::ShareClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Postcard::sealed::SignatureFlyout ( )
void Postcard::sealed::SignButtonCicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::SignClicked ( ) [private]
void Postcard::sealed::StampButtonClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void Postcard::sealed::TextBoxKeyUp | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::KeyRoutedEventArgs^ | e |
 | ) |  |  | [private]
Postcard::sealed::TextFlyout ( )
void Postcard::sealed::TextSubmitted ( Platform::String^ text ) [private]

Member Data Documentation

event ButtonClickedHandler Postcard::sealed::AddPaperClicked

Definition at line 22 of file PaperFlyout.xaml.h.

event EffectIntensityChangedHandler Postcard::sealed::EffectIntensityChanged

Definition at line 25 of file EffectsFlyout.xaml.h.

event SignatureButtonClickedHandler Postcard::sealed::EraseClicked

Definition at line 23 of file SignatureFlyout.xaml.h.

bool Postcard::sealed::m_atStartScreen [private]

Definition at line 59 of file MainPage.xaml.h.

MainPage Postcard::sealed::m_mainPage [private]

Definition at line 26 of file App.xaml.h.

PostcardRenderer Postcard::sealed::m_renderer [private]

Definition at line 58 of file MainPage.xaml.h.

event ButtonClickedHandler Postcard::sealed::MovePaperClicked

Definition at line 24 of file PaperFlyout.xaml.h.

event ButtonClickedHandler Postcard::sealed::RemovePaperClicked

Definition at line 23 of file PaperFlyout.xaml.h.

event SignatureButtonClickedHandler Postcard::sealed::SignClicked

Definition at line 22 of file SignatureFlyout.xaml.h.

event ButtonClickedHandler Postcard::sealed::StampPaperClicked

Definition at line 25 of file PaperFlyout.xaml.h.

event TextSubmittedHandler Postcard::sealed::TextSubmitted

Definition at line 21 of file TextFlyout.xaml.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/App.xaml.h
  • DirectX postcard app/C++/EffectsFlyout.xaml.h
  • DirectX postcard app/C++/MainPage.xaml.h
  • DirectX postcard app/C++/PaperFlyout.xaml.h
  • DirectX postcard app/C++/SignatureFlyout.xaml.h
  • DirectX postcard app/C++/TextFlyout.xaml.h
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PostcardRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

PostcardRenderer Class Reference

#include "PostcardRenderer.h"

List of all members.

Public Member Functions

void | AddPaper ()
virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
void | LoadImage (Windows::Storage::Streams::IRandomAccessStream^randomAccessStream)
void | MovePaper ()
void | OnDataRequested (_In_ Windows::ApplicationModel::DataTransfer::DataTransferManager^sender, _In_ Windows::ApplicationModel::DataTransfer::DataRequestedEventArgs^args)
void | OnManipulationCompleted (_In_ Platform::Object^, _In_ Windows::UI::Xaml::Input::ManipulationCompletedRoutedEventArgs^args)
void | OnManipulationDelta (_In_ Platform::Object^, _In_ Windows::UI::Xaml::Input::ManipulationDeltaRoutedEventArgs^args)
void | OnManipulationStarted (_In_ Platform::Object^, _In_ Windows::UI::Xaml::Input::ManipulationStartedRoutedEventArgs^args)
void | OnPointerMoved (_In_ Platform::Object^, _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnPointerPressed (_In_ Platform::Object^, _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnPointerReleased (_In_ Platform::Object^, _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)
void | OnTapped (_In_ Platform::Object^, _In_ Windows::UI::Xaml::Input::TappedRoutedEventArgs^args)
void | RemovePaper ()
virtual void | Render () override
void | ResetPostcard ()
void | ResetSignature ()
void | SavePostcard (Windows::Storage::Streams::IRandomAccessStream^randomAccessStream, GUID wicFormat)
void | SetEffectIntensity (float value)
void | SetExtrudedText (Platform::String^text)
void | SetSampleMode (SampleMode mode)
void | StampPaper ()
void | StartSignature ()
void | UpdateForViewStateChanged (Windows::UI::ViewManagement::ApplicationViewState state)
virtual void | UpdateForWindowSizeChange () override

Public Attributes

internal | __pad0__: PostcardRenderer()

Private Member Functions

void | SaveBitmapToStream (_In_ ID2D1Bitmap1 *d2dBitmap, _In_ IWICImagingFactory2 *wicFactory2, _In_ ID2D1DeviceContext *d2dContext, _In_ REFGUID wicFormat, _In_ IStream *stream)

Private Attributes

ExtrudedTextRenderer m_extrudedTextRenderer
ImageRenderer m_imageRenderer
InkRenderer m_inkRenderer
PaperRenderer m_paperRenderer
SampleMode m_sampleMode
Windows::UI::Xaml::Controls::SwapChainBackgroundPanel | m_swapChainPanel
Windows::UI::ViewManagement::ApplicationViewState | m_windowState

Detailed Description

Definition at line 29 of file PostcardRenderer.h.

Member Function Documentation

void PostcardRenderer::AddPaper ( )

Definition at line 279 of file PostcardRenderer.cpp.

{
    m_paperRenderer->AddPaper();
    Render();
    Present();
}

void PostcardRenderer::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 40 of file PostcardRenderer.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    m_imageRenderer->CreateDeviceIndependentResources(m_wicFactory);
    m_paperRenderer->CreateDeviceIndependentResources(m_d2dFactory);
    m_extrudedTextRenderer->CreateDeviceIndependentResources(m_d2dFactory, m_dwriteFactory);
    m_inkRenderer->CreateDeviceIndependentResources(m_d2dFactory);
}

void PostcardRenderer::CreateDeviceResources ( ) [override, virtual]

Definition at line 50 of file PostcardRenderer.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_imageRenderer->CreateDeviceResources(m_d2dContext);
    m_paperRenderer->CreateDeviceResources(m_d2dContext);
    m_extrudedTextRenderer->CreateDeviceResources(m_d3dDevice, m_d3dContext);
    m_inkRenderer->CreateDeviceResources(m_d2dContext);
}

void PostcardRenderer::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 60 of file PostcardRenderer.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // Create a descriptor for the depth/stencil buffer.
    CD3D11_TEXTURE2D_DESC depthStencilDesc(
        DXGI_FORMAT_D24_UNORM_S8_UINT,
        static_cast<uint32>(m_renderTargetSize.Width),
        static_cast<uint32>(m_renderTargetSize.Height),
        1,
        1,
        D3D11_BIND_DEPTH_STENCIL
        );

    // Allocate a 2-D surface as the depth/stencil buffer.
    ComPtr<ID3D11Texture2D> depthStencil;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateTexture2D(
            &depthStencilDesc,
            nullptr,
            &depthStencil
            )
        );

    // Create a DepthStencil view on this surface to use on bind.
    DX::ThrowIfFailed(
        m_d3dDevice->CreateDepthStencilView(
            depthStencil.Get(),
            &CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D),
            &m_d3dDepthStencilView
            )
        );

    m_imageRenderer->CreateWindowSizeDependentResources(m_dpi);

    m_paperRenderer->CreateWindowSizeDependentResources(m_dpi);

    m_extrudedTextRenderer->CreateWindowSizeDependentResources(
        m_dpi,
        m_d3dRenderTargetView,
        m_d3dDepthStencilView,
        m_renderTargetSize
        );

    m_inkRenderer->CreateWindowSizeDependentResources(m_dpi);
}

void PostcardRenderer::LoadImage ( Windows::Storage::Streams::IRandomAccessStream^ randomAccessStream )
void PostcardRenderer::MovePaper ( )

Definition at line 291 of file PostcardRenderer.cpp.

{
    m_paperRenderer->MovePaper();
}

void PostcardRenderer::OnDataRequested | ( | _In_ Windows::ApplicationModel::DataTransfer::DataTransferManager^ | sender,
 |  | _In_ Windows::ApplicationModel::DataTransfer::DataRequestedEventArgs^ | args
 | ) |  |
void PostcardRenderer::OnManipulationCompleted | ( | _In_ Platform::Object^ | ,
 |  | _In_ Windows::UI::Xaml::Input::ManipulationCompletedRoutedEventArgs^ | args
 | ) |  |
void PostcardRenderer::OnManipulationDelta | ( | _In_ Platform::Object^ | ,
 |  | _In_ Windows::UI::Xaml::Input::ManipulationDeltaRoutedEventArgs^ | args
 | ) |  |
void PostcardRenderer::OnManipulationStarted | ( | _In_ Platform::Object^ | ,
 |  | _In_ Windows::UI::Xaml::Input::ManipulationStartedRoutedEventArgs^ | args
 | ) |  |
void PostcardRenderer::OnPointerMoved | ( | _In_ Platform::Object^ | ,
 |  | _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | args
 | ) |  |
void PostcardRenderer::OnPointerPressed | ( | _In_ Platform::Object^ | ,
 |  | _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | args
 | ) |  |
void PostcardRenderer::OnPointerReleased | ( | _In_ Platform::Object^ | ,
 |  | _In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | args
 | ) |  |
void PostcardRenderer::OnTapped | ( | _In_ Platform::Object^ | ,
 |  | _In_ Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | args
 | ) |  |
void PostcardRenderer::RemovePaper ( )

Definition at line 286 of file PostcardRenderer.cpp.

{
    m_paperRenderer->RemovePaper();
}

void PostcardRenderer::Render ( ) [override, virtual]

Definition at line 116 of file PostcardRenderer.cpp.

{
    m_d2dContext->BeginDraw();
    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));

    if (m_windowState != ApplicationViewState::Snapped)
    {
        // Render each part of the postcard in order.
        m_imageRenderer->DrawImageAndEffects();
        m_paperRenderer->DrawPaper();
        m_d2dContext->EndDraw(); // Ignore any HRESULT. It will be dealt with after the next EndDraw().

        // The extruded text renderer does not draw between a BeginDraw and
        // EndDraw because it uses Direct3D. It is inappropriate to perform
        // Direct3D operations while Direct2D is active.
        m_extrudedTextRenderer->DrawExtrudedText();

        m_d2dContext->BeginDraw();
        m_inkRenderer->DrawInk();
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void PostcardRenderer::ResetPostcard ( )

Definition at line 334 of file PostcardRenderer.cpp.

{
    m_imageRenderer->Reset();
    m_paperRenderer->Reset();
    m_extrudedTextRenderer->Reset();
    m_inkRenderer->Reset();

    Render();
    Present();
}

void PostcardRenderer::ResetSignature ( )

Definition at line 327 of file PostcardRenderer.cpp.

{
    m_inkRenderer->Reset();
    Render();
    Present();
}

void PostcardRenderer::SaveBitmapToStream | ( | _In_ ID2D1Bitmap1 * | d2dBitmap,
 |  | _In_ IWICImagingFactory2 * | wicFactory2,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ REFGUID | wicFormat,
 |  | _In_ IStream * | stream |
 | ) |  |  | [private]

Definition at line 206 of file PostcardRenderer.cpp.

{
    // Create and initialize WIC bitmap encoder.
    ComPtr<IWICBitmapEncoder> wicBitmapEncoder;
    DX::ThrowIfFailed(
        wicFactory2->CreateEncoder(
            wicFormat,
            nullptr,
            &wicBitmapEncoder
            )
        );

    DX::ThrowIfFailed(
        wicBitmapEncoder->Initialize(
            stream,
            WICBitmapEncoderNoCache
            )
        );

    // Create and initialize WIC frame encoder.
    ComPtr<IWICBitmapFrameEncode> wicFrameEncode;
    DX::ThrowIfFailed(
        wicBitmapEncoder->CreateNewFrame(
            &wicFrameEncode,
            nullptr     // No encoder options.
            )
        );

    DX::ThrowIfFailed(
        wicFrameEncode->Initialize(nullptr)
        );

    // Retrieve Direct2D device.
    ComPtr<ID2D1Device> d2dDevice;
    d2dContext->GetDevice(&d2dDevice);

    // Create WIC image encoder.
    ComPtr<IWICImageEncoder> imageEncoder;
    DX::ThrowIfFailed(
        wicFactory2->CreateImageEncoder(
            d2dDevice.Get(),
            &imageEncoder
            )
        );

    DX::ThrowIfFailed(
        imageEncoder->WriteFrame(
            d2dBitmap,
            wicFrameEncode.Get(),
            nullptr     // Use default options.
            )
        );

    DX::ThrowIfFailed(
        wicFrameEncode->Commit()
        );

    DX::ThrowIfFailed(
        wicBitmapEncoder->Commit()
        );

    // Flush all memory buffers to the next-level storage object.
    DX::ThrowIfFailed(
        stream->Commit(STGC_DEFAULT)
        );
}

void PostcardRenderer::SavePostcard | ( | Windows::Storage::Streams::IRandomAccessStream^ | randomAccessStream,
 |  | GUID | wicFormat
 | ) |  |
void PostcardRenderer::SetEffectIntensity ( float value )

Definition at line 308 of file PostcardRenderer.cpp.

{
    m_imageRenderer->SetEffectIntensity(value);
    Render();
    Present();
}

void PostcardRenderer::SetExtrudedText ( Platform::String^ text )
void PostcardRenderer::SetSampleMode ( SampleMode mode )

Definition at line 447 of file PostcardRenderer.cpp.

{
    m_sampleMode = mode;
}

void PostcardRenderer::StampPaper ( )

Definition at line 296 of file PostcardRenderer.cpp.

{
    m_paperRenderer->StampPaper();
}

void PostcardRenderer::StartSignature ( )

Definition at line 322 of file PostcardRenderer.cpp.

{
    m_inkRenderer->StartSignature();
}

void PostcardRenderer::UpdateForViewStateChanged ( Windows::UI::ViewManagement::ApplicationViewState state )
void PostcardRenderer::UpdateForWindowSizeChange ( ) [override, virtual]

Definition at line 107 of file PostcardRenderer.cpp.

{
    // Release extra references to Direct3D resources before attempting
    // to resize the swap chain.
    m_extrudedTextRenderer->ReleaseBufferResources();

    DirectXBase::UpdateForWindowSizeChange();
}

Member Data Documentation

internal PostcardRenderer::__pad0__

Definition at line 32 of file PostcardRenderer.h.

ExtrudedTextRenderer PostcardRenderer::m_extrudedTextRenderer [private]

Definition at line 112 of file PostcardRenderer.h.

ImageRenderer PostcardRenderer::m_imageRenderer [private]

Definition at line 110 of file PostcardRenderer.h.

InkRenderer PostcardRenderer::m_inkRenderer [private]

Definition at line 113 of file PostcardRenderer.h.

PaperRenderer PostcardRenderer::m_paperRenderer [private]

Definition at line 111 of file PostcardRenderer.h.

SampleMode PostcardRenderer::m_sampleMode [private]

Definition at line 108 of file PostcardRenderer.h.

Windows::UI::Xaml::Controls::SwapChainBackgroundPanel PostcardRenderer::m_swapChainPanel [private]

Definition at line 115 of file PostcardRenderer.h.

Windows::UI::ViewManagement::ApplicationViewState PostcardRenderer::m_windowState [private]

Definition at line 116 of file PostcardRenderer.h.

The documentation for this class was generated from the following files:
  • DirectX postcard app/C++/PostcardRenderer.h
  • DirectX postcard app/C++/PostcardRenderer.cpp
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PrintSample::BasePrintPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PrintSample
  • PrintSample::BasePrintPage
Public Member Functions | Protected Member Functions | Private Attributes

PrintSample::BasePrintPage Class Reference

#include "BasePrintPage.h"

Inherits Page.

List of all members.

Public Member Functions

virtual void | OnNavigatedFrom (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override

Protected Member Functions

virtual RichTextBlockOverflow | AddOnePrintPreviewPage (RichTextBlockOverflow^lastRTBOAdded, Windows::Graphics::Printing::PrintPageDescription printPageDescription)
virtual void | AddPrintPages (Object^sender, AddPagesEventArgs^e)
virtual void | CreatePrintPreviewPages (Object^sender, PaginateEventArgs^e)
virtual void | GetPrintPreviewPage (Object^sender, GetPreviewPageEventArgs^e)
virtual void | OnContentCreated ()
virtual void | PrintTaskRequested (Windows::Graphics::Printing::PrintManager^sender, Windows::Graphics::Printing::PrintTaskRequestedEventArgs^e)
void | RegisterForPrinting ()
void | RegisterForPrintingButtonClick (Object^sender, RoutedEventArgs^e)
void | RemovePageFromPrintPreviewCollection (int pageNumber)
void | UnregisterForPrinting ()

Private Attributes

LONG | m_currentPage
FrameworkElement | m_firstPage
bool | m_isRegisteredForPrinting
PrintDocument | m_printDocument
Windows::Graphics::Printing::IPrintDocumentSource | m_printDocumentSource
std::vector< UIElement^> | m_printPreviewPages
EventRegistrationToken | m_printTaskRequestedEventToken
MainPage | m_rootPage

Detailed Description

Definition at line 21 of file BasePrintPage.h.

Member Function Documentation

virtual RichTextBlockOverflow PrintSample::BasePrintPage::AddOnePrintPreviewPage | ( | RichTextBlockOverflow^ | lastRTBOAdded,
 |  | Windows::Graphics::Printing::PrintPageDescription | printPageDescription |
 | ) |  |  | [protected, virtual]

This function creates and adds one print preview page to the internal cache of print preview pages stored in m_printPreviewPages.

Parameters:
lastRTBOAdded | Last RichTextBlockOverflow element added in the current content
printPageDescription | Printer's page description
void BasePrintPage::AddPrintPages | ( | Object^ | sender,
 |  | AddPagesEventArgs^ | e |
 | ) |  |  | [protected, virtual]

This is the event handler for PrintDocument.AddPages.

It provides all pages to be printed, in the form of UIElements, to an instance of PrintDocument. PrintDocument subsequently converts the UIElements into a pages that the Windows print system can deal with.

Parameters:
sender
e Add page event arguments containing a print task options reference

Definition at line 198 of file BasePrintPage.cpp.

{
    PrintDocument^ printDocument = safe_cast<PrintDocument^>(sender);

    // Loop over all of the preview pages and add each one to  add each page to be printied
    for (size_t i = 0; i < m_printPreviewPages.size(); i++)
    {
        printDocument->AddPage(m_printPreviewPages[i]);
    }

    // Indicate that all of the print pages have been provided
    printDocument->AddPagesComplete();
}

void BasePrintPage::CreatePrintPreviewPages | ( | Object^ | sender,
 |  | PaginateEventArgs^ | e |
 | ) |  |  | [protected, virtual]

This is the event handler for PrintDocument.Paginate.

It creates print preview pages for the app.

Parameters:
sender | PrintDocument
e | Paginate Event Arguments

Definition at line 149 of file BasePrintPage.cpp.

{
    // Clear the cache of preview pages
    m_printPreviewPages.clear();

    // Clear the printing root of preview pages
    PrintingRoot->Children->Clear();

    // This variable keeps track of the last RichTextBlockOverflow element that was added to a page which will be printed
    RichTextBlockOverflow^ lastRTBOOnPage;

    // Get the PrintTaskOptions
    PrintTaskOptions^ printingOptions = safe_cast<PrintTaskOptions^>(e->PrintTaskOptions);

    // Get the page description to deterimine how big the page is
    PrintPageDescription pageDescription = printingOptions->GetPageDescription(0);

    // We know there is at least one page to be printed. passing null as the first parameter to
    // AddOnePrintPreviewPage tells the function to add the first page.
    lastRTBOOnPage = AddOnePrintPreviewPage(nullptr, pageDescription);

    // We know there are more pages to be added as long as the last RichTextBoxOverflow added to a print preview
    // page has extra content
    while (lastRTBOOnPage->HasOverflowContent && lastRTBOOnPage->Visibility == Windows::UI::Xaml::Visibility::Visible)
    {
        lastRTBOOnPage = AddOnePrintPreviewPage(lastRTBOOnPage, pageDescription);
    }

    OnContentCreated();

    PrintDocument^ printDocument = safe_cast<PrintDocument^>(sender);

    // Report the number of preview pages created
    printDocument->SetPreviewPageCount(static_cast<int>(m_printPreviewPages.size()), PreviewPageCountType::Intermediate);
}

void BasePrintPage::GetPrintPreviewPage | ( | Object^ | sender,
 |  | GetPreviewPageEventArgs^ | e |
 | ) |  |  | [protected, virtual]

This is the event handler for PrintDocument.GetPrintPreviewPage.

It provides a specific print preview page, in the form of an UIElement, to an instance of PrintDocument. PrintDocument subsequently converts the UIElement into a page that the Windows print system can deal with.

Parameters:
sender | The Print Document
e | Arguments containing the preview requested page

Definition at line 185 of file BasePrintPage.cpp.

{
    PrintDocument^ localprintDocument = safe_cast<PrintDocument^>(sender);
    localprintDocument->SetPreviewPage(e->PageNumber, m_printPreviewPages[e->PageNumber - 1]);
}

virtual void PrintSample::BasePrintPage::OnContentCreated ( ) [inline, protected, virtual]

Definition at line 194 of file BasePrintPage.h.

{};

void BasePrintPage::OnNavigatedFrom ( NavigationEventArgs^ e ) [override, virtual]

Definition at line 289 of file BasePrintPage.cpp.

{
    UnregisterForPrinting() ;
}

void BasePrintPage::OnNavigatedTo ( NavigationEventArgs^ e ) [override, virtual]

Definition at line 283 of file BasePrintPage.cpp.

{
    // Get a pointer to our main page.
    m_rootPage = safe_cast<MainPage^>(e->Parameter);
}

virtual void PrintSample::BasePrintPage::PrintTaskRequested | ( | Windows::Graphics::Printing::PrintManager^ | sender,
 |  | Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ | e |
 | ) |  |  | [protected, virtual]

This is the event handler for PrintManager.PrintTaskRequested.

In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified by PrintTaskRequestedEventArgs->Request->Deadline. Therefore, we use this handler to only create the print task. The print settings customization can be done when the print document source is requested.

Parameters:
sender | PrintManager
e | PrintTaskRequestedEventArgs
void BasePrintPage::RegisterForPrinting ( ) [protected]

This function registers the app for printing with Windows and sets up the necessary event handlers for the print process.

Definition at line 71 of file BasePrintPage.cpp.

{
    // Create the PrintDocument.
    m_printDocument = ref new PrintDocument();

    // Save the DocumentSource.
    m_printDocumentSource = m_printDocument->DocumentSource;

    // Add an event handler which creates preview pages.
    m_printDocument->Paginate += ref new Windows::UI::Xaml::Printing::PaginateEventHandler(this, &BasePrintPage::CreatePrintPreviewPages);

    // Add an event handler which provides a specified preview page.
    m_printDocument->GetPreviewPage += ref new Windows::UI::Xaml::Printing::GetPreviewPageEventHandler(this, &BasePrintPage::GetPrintPreviewPage);

    // Add an event handler which provides all final print pages.
    m_printDocument->AddPages += ref new Windows::UI::Xaml::Printing::AddPagesEventHandler(this, &BasePrintPage::AddPrintPages);

    // Create a PrintManager and add a handler for printing initialization.
    PrintManager^ printMan = PrintManager::GetForCurrentView();

    m_printTaskRequestedEventToken = printMan->PrintTaskRequested += ref new TypedEventHandler<PrintManager^, PrintTaskRequestedEventArgs^>(this, &BasePrintPage::PrintTaskRequested);

    // Initialize print content for this scenario
    PreparetPrintContent();
}

void BasePrintPage::RegisterForPrintingButtonClick | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [protected]

The percent of app's margin width, content is set at 85% (0.85) of the area's width.

This is the click handler for the 'Register' button.

Register for print button handler

Parameters:
sender
e

Definition at line 39 of file BasePrintPage.cpp.

{
    Button^ clickedButton = safe_cast<Button^>(sender);

    // check to see if the application is registered for printing
    if (m_isRegisteredForPrinting)
    {
        // unregister for printing
        UnregisterForPrinting();

        // change the text on the button
        clickedButton->Content = "Register";

        // tell the user that the print contract has been unregistered
        m_rootPage->NotifyUser("Print contract unregistered.", NotifyType::StatusMessage);
    }
    else
    {
        // register for printing
        RegisterForPrinting();

        // change the text on the button
        clickedButton->Content = "Unregister";

        // tell the user that the print contract has been registered
        m_rootPage->NotifyUser("Print contract registered, use the Charms Bar to print.", NotifyType::StatusMessage);
    }

    // toggel the value of isRegisteredForPrinting
    m_isRegisteredForPrinting = !m_isRegisteredForPrinting;
}

void BasePrintPage::RemovePageFromPrintPreviewCollection ( int pageNumber ) [protected]

Removes a page from the printprreview collection (generated content).

Parameters:
pageNumber The page number to remove

Definition at line 278 of file BasePrintPage.cpp.

{
    m_printPreviewPages.erase(m_printPreviewPages.begin() + pageNumber);
}

void BasePrintPage::UnregisterForPrinting ( ) [protected]

This function unregisters the app for printing with Windows.

Definition at line 97 of file BasePrintPage.cpp.

{
    // Remove the handler for printing initialization.
    PrintManager^ printMan = PrintManager::GetForCurrentView();

    printMan->PrintTaskRequested -= m_printTaskRequestedEventToken;

    PrintingRoot->Children->Clear();
}

Member Data Documentation

LONG PrintSample::BasePrintPage::m_currentPage [private]

Current requeted page for preview.

Definition at line 59 of file BasePrintPage.h.

FrameworkElement PrintSample::BasePrintPage::m_firstPage [private]

First page in the printing-content series From this "virtual sized" paged content is split(text is flowing) to "printing pages".

Definition at line 65 of file BasePrintPage.h.

bool PrintSample::BasePrintPage::m_isRegisteredForPrinting [private]

a boolean which tracks whether the app has been registered for printing

Definition at line 32 of file BasePrintPage.h.

PrintDocument PrintSample::BasePrintPage::m_printDocument [private]

PrintDocument is used to prepare the pages for printing.

Prepare the pages to print in the handlers for the Paginate, GetPreviewPage, and AddPages events.

Definition at line 43 of file BasePrintPage.h.

Windows::Graphics::Printing::IPrintDocumentSource PrintSample::BasePrintPage::m_printDocumentSource [private]

Marker interface for document source.

Definition at line 48 of file BasePrintPage.h.

std::vector<UIElement^> PrintSample::BasePrintPage::m_printPreviewPages [private]

A list of UIElements used to store the print preview pages.

This gives easy access to any desired preview page.

Definition at line 54 of file BasePrintPage.h.

EventRegistrationToken PrintSample::BasePrintPage::m_printTaskRequestedEventToken [private]

Print task requested event registration token.

Definition at line 27 of file BasePrintPage.h.

MainPage PrintSample::BasePrintPage::m_rootPage [private]

A pointer back to the main page which is used to gain access to the input and output frames and their content.

Definition at line 37 of file BasePrintPage.h.

The documentation for this class was generated from the following files:
  • Print/C++/BasePrintPage.h
  • Print/C++/BasePrintPage.cpp
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PrintSample::InvalidPageException Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PrintSample
  • PrintSample::InvalidPageException
Public Member Functions | Private Attributes

PrintSample::InvalidPageException Class Reference

#include "ScenarioInput5.xaml.h"

List of all members.

Public Member Functions

InvalidPageException (std::wstring &message)
~InvalidPageException ()
std::wstring | get_DisplayMessage ()

Private Attributes

std::wstring | m_displayMessage

Detailed Description

Definition at line 25 of file ScenarioInput5.xaml.h.

Constructor & Destructor Documentation

PrintSample::InvalidPageException::InvalidPageException ( std::wstring & message ) [inline]

Definition at line 32 of file ScenarioInput5.xaml.h.

        {
            m_displayMessage = message;
        }

PrintSample::InvalidPageException::~InvalidPageException ( ) [inline]

Definition at line 37 of file ScenarioInput5.xaml.h.

        {
        }

Member Function Documentation

std::wstring PrintSample::InvalidPageException::get_DisplayMessage ( ) [inline]

Definition at line 41 of file ScenarioInput5.xaml.h.

        {
            return m_displayMessage;
        }

Member Data Documentation

std::wstring PrintSample::InvalidPageException::m_displayMessage [private]

Definition at line 28 of file ScenarioInput5.xaml.h.

The documentation for this class was generated from the following file:
  • Print/C++/ScenarioInput5.xaml.h
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PrintSample::PageDescription Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PrintSample
  • PrintSample::PageDescription
Public Attributes | Friends

PrintSample::PageDescription Class Reference

Printable page description. More...

#include "ScenarioInput6.xaml.h"

List of all members.

Public Attributes

bool | IsContentCropped
Size | Margin
Size | PageSize
Size | PictureViewSize
Size | ViewablePageSize

Friends

bool | operator!= (PageDescription pageDescriptiopn1, PageDescription pageDescription2)
bool | operator== (PageDescription pageDescriptiopn1, PageDescription pageDescription2)

Detailed Description

Definition at line 48 of file ScenarioInput6.xaml.h.

Friends And Related Function Documentation

bool operator!= | ( | PageDescription | pageDescriptiopn1,
 |  | PageDescription | pageDescription2 |
 | ) |  |  | [friend]

Definition at line 86 of file ScenarioInput6.xaml.h.

        {
            return !(pageDescriptiopn1 == pageDescription2);
        }

bool operator== | ( | PageDescription | pageDescriptiopn1,
 |  | PageDescription | pageDescription2 |
 | ) |  |  | [friend]

Definition at line 57 of file ScenarioInput6.xaml.h.

        {
            // Detect if PageSize changed
            bool equal = (std::abs(pageDescriptiopn1.PageSize.Width - pageDescription2.PageSize.Width) < FLT_EPSILON) &&
                         (std::abs(pageDescriptiopn1.PageSize.Height - pageDescription2.PageSize.Height) < FLT_EPSILON);

            // Detect if ViewablePageSize changed
            if (equal)
            {
                equal = (std::abs(pageDescriptiopn1.ViewablePageSize.Width - pageDescription2.ViewablePageSize.Width) < FLT_EPSILON) &&
                        (std::abs(pageDescriptiopn1.ViewablePageSize.Height - pageDescription2.ViewablePageSize.Height) < FLT_EPSILON);
            }

            // Detect if PictureViewSize changed
            if (equal)
            {
                equal = (std::abs(pageDescriptiopn1.PictureViewSize.Width - pageDescription2.PictureViewSize.Width) < FLT_EPSILON) &&
                        (std::abs(pageDescriptiopn1.PictureViewSize.Height - pageDescription2.PictureViewSize.Height) < FLT_EPSILON);
            }

            // Detect if cropping changed
            if (equal)
            {
                equal = pageDescriptiopn1.IsContentCropped == pageDescription2.IsContentCropped;
            }

            return equal;
        }

Member Data Documentation

bool PrintSample::PageDescription::IsContentCropped

Definition at line 55 of file ScenarioInput6.xaml.h.

Size PrintSample::PageDescription::Margin

Definition at line 51 of file ScenarioInput6.xaml.h.

Size PrintSample::PageDescription::PageSize

Definition at line 52 of file ScenarioInput6.xaml.h.

Size PrintSample::PageDescription::PictureViewSize

Definition at line 54 of file ScenarioInput6.xaml.h.

Size PrintSample::PageDescription::ViewablePageSize

Definition at line 53 of file ScenarioInput6.xaml.h.

The documentation for this class was generated from the following file:
  • Print/C++/ScenarioInput6.xaml.h
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PrintSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • PrintSample
  • PrintSample::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Static Private Member Functions | Private Attributes | Static Private Attributes

PrintSample::sealed Class Reference

A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
ContinuationPage ()
ContinuationPage (Windows::UI::Xaml::Controls::RichTextBlockOverflow^textLinkContainer)
String | ConvertResolution (ResolutionScale scale)
String | ConvertViewState (ApplicationViewState state)
void | DoNavigation (TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame)
MainPage ()
void | NotifyUser (String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnNavigatedFrom (NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
PreviewUnavailable ()
PreviewUnavailable (Windows::Foundation::Size paperSize, Windows::Foundation::Size printableSize)
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioInput3 ()
ScenarioInput4 ()
ScenarioInput5 ()
ScenarioInput6 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()
ScenarioOutput3 ()
ScenarioOutput4 ()
ScenarioOutput5 ()
ScenarioOutput6 ()

Protected Member Functions

virtual RichTextBlockOverflow | AddOnePrintPreviewPage (RichTextBlockOverflow^lastRTBOAdded, Windows::Graphics::Printing::PrintPageDescription printPageDescription) override
virtual RichTextBlockOverflow | AddOnePrintPreviewPage (RichTextBlockOverflow^lastRTBOAdded, Windows::Graphics::Printing::PrintPageDescription printPageDescription) override
virtual void | AddPrintPages (Object^sender, AddPagesEventArgs^e) override
void | ClearPageCollection ()
virtual void | CreatePrintPreviewPages (Object^sender, PaginateEventArgs^e) override
virtual void | CreatePrintPreviewPages (Object^sender, PaginateEventArgs^e) override
virtual void | GetPrintPreviewPage (Object^sender, GetPreviewPageEventArgs^e) override
virtual void | OnContentCreated () override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | PreparetPrintContent () override
virtual void | PreparetPrintContent () override
virtual void | PreparetPrintContent () override
virtual void | PreparetPrintContent () override
virtual void | PreparetPrintContent () override
void | PrintDetailedOptionsOptionChanged (Windows::Graphics::Printing::OptionDetails::PrintTaskOptionDetails^sender, Windows::Graphics::Printing::OptionDetails::PrintTaskOptionChangedEventArgs^args)
virtual void | PrintTaskRequested (Windows::Graphics::Printing::PrintManager^sender, Windows::Graphics::Printing::PrintTaskRequestedEventArgs^e) override
virtual void | PrintTaskRequested (Windows::Graphics::Printing::PrintManager^sender, Windows::Graphics::Printing::PrintTaskRequestedEventArgs^e) override
virtual void | PrintTaskRequested (Windows::Graphics::Printing::PrintManager^sender, Windows::Graphics::Printing::PrintTaskRequestedEventArgs^e) override
virtual void | PrintTaskRequested (Windows::Graphics::Printing::PrintManager^sender, Windows::Graphics::Printing::PrintTaskRequestedEventArgs^e) override
void | RefreshPreview ()
void | Scenarios_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~App ()
~MainPage ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
~ScenarioOutput3 ()
~ScenarioOutput4 ()
~ScenarioOutput6 ()
void | CheckResolutionAndViewState ()
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, RoutedEventArgs^e)
void | GetPagesInRange (String^pageRange)
void | inputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | InvokePrintButtonClick (Object^sender, RoutedEventArgs^e)
concurrency::task
< Windows::UI::Xaml::Media::Imaging::WriteableBitmap^> 		LoadBitmap (Windows::Foundation::Uri^source, bool landscape)
void | outputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | Page_Loaded (Object^sender, RoutedEventArgs^e)
void | Page_SizeChanged (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | printDetailedOptions_OptionChanged (Windows::Graphics::Printing::OptionDetails::PrintTaskOptionDetails^sender, Windows::Graphics::Printing::OptionDetails::PrintTaskOptionChangedEventArgs^args)
void | RefreshPreview ()
void | RefreshPreview ()
void | RegisterForPrintingButtonClick (Object^sender, RoutedEventArgs^e)
void | RemovePageRangeEdit (Windows::Graphics::Printing::OptionDetails::PrintTaskOptionDetails^printTaskOptionDetails)
concurrency::task< UIElement^> | ScenarioInput6::GeneratePage (int photoNumber, PageDescription pageDescription)
void | SetFeatureName (Platform::String^strFeature)
void | ShowContent (String^selectionText)
void | SplitString (String^string, wchar_t delimiter, std::vector< std::wstring > &words)

Static Private Member Functions

template<class T >
static void | Swap (T &v1, T &v2)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
Windows::Foundation::EventRegistrationToken | _sizeChangedHandlerToken
concurrency::critical_section | m_csPrintSync
PageDescription m_currentPageDescription
DisplayContent m_imageText
std::map< int, UIElement^> | m_pageCollection
std::vector< int > | m_pageList
bool | m_pageRangeEditVisible
Scaling m_photoScale
PhotoSize m_photoSize
LONGLONG | m_requestCount
bool | m_selectionMode
size_t | m_totalPages
MainPage | rootPage

Static Private Attributes

static const int | DPI96 = 96
static const int | NumberOfPhotos = 9

Detailed Description

An empty page that can be used on its own or navigated to within a Frame.

Photo printing scenario.

Scenario that demos a page range implementation.

Scenario that demos how to add custom options (specific for the application).

Scenario that demos how to add customizations in the displayed options list.

Scenario that demos how to call the Print UI on demand.

Basic scenario for modern printing (how to register).

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

PrintSample::sealed::~App ( ) [private]
PrintSample::sealed::~MainPage ( ) [private]
PrintSample::sealed::~ScenarioList ( ) [private]
PrintSample::sealed::~ScenarioOutput1 ( ) [private]
PrintSample::sealed::~ScenarioOutput2 ( ) [private]
PrintSample::sealed::~ScenarioOutput3 ( ) [private]
PrintSample::sealed::~ScenarioOutput4 ( ) [private]
PrintSample::sealed::~ScenarioOutput6 ( ) [private]

Member Function Documentation

virtual RichTextBlockOverflow PrintSample::sealed::AddOnePrintPreviewPage | ( | RichTextBlockOverflow^ | lastRTBOAdded,
 |  | Windows::Graphics::Printing::PrintPageDescription | printPageDescription |
 | ) |  |  | [override, protected, virtual]

This function creates and adds one print preview page to the internal cache of print preview pages stored in m_printPreviewPages.

Parameters:
lastRTBOAdded | Last RichTextBlockOverflow element added in the current content
printPageDescription | Printer's page description
virtual RichTextBlockOverflow PrintSample::sealed::AddOnePrintPreviewPage | ( | RichTextBlockOverflow^ | lastRTBOAdded,
 |  | Windows::Graphics::Printing::PrintPageDescription | printPageDescription |
 | ) |  |  | [override, protected, virtual]

This function creates and adds one print preview page to the internal cache of print preview pages stored in m_printPreviewPages.

Parameters:
lastRTBOAdded | Last RichTextBlockOverflow element added in the current content
printPageDescription | Printer's page description
virtual void PrintSample::sealed::AddPrintPages | ( | Object^ | sender,
 |  | AddPagesEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]

This is the event handler for PrintDocument.AddPages.

It provides all pages to be printed, in the form of UIElements, to an instance of PrintDocument. PrintDocument subsequently converts the UIElements into a pages that the Windows print system can deal with.

Parameters:
sender | The print document.
e | Add page event arguments containing a print task options reference
PrintSample::sealed::App ( )
void PrintSample::sealed::CheckResolutionAndViewState ( ) [private]
void PrintSample::sealed::ClearPageCollection ( ) [protected]

Helper function that clears the page collection and also the pages attached to the "visual root".

PrintSample::sealed::ContinuationPage ( )
PrintSample::sealed::ContinuationPage ( Windows::UI::Xaml::Controls::RichTextBlockOverflow^ textLinkContainer )

Creates a continuation page and links text-flow to a text flow container.

Parameters:
textLinkContainer Text link container which will flow text into this page
String PrintSample::sealed::ConvertResolution ( ResolutionScale scale )
String PrintSample::sealed::ConvertViewState ( ApplicationViewState state )
virtual void PrintSample::sealed::CreatePrintPreviewPages | ( | Object^ | sender,
 |  | PaginateEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]

This is the event handler for PrintDocument.Paginate.

It creates print preview pages for the app.

Parameters:
sender
e Paginate Event Arguments
virtual void PrintSample::sealed::CreatePrintPreviewPages | ( | Object^ | sender,
 |  | PaginateEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]

This is the event handler for Pagination.

Parameters:
sender | The document for which pagination occurs.
e | The pagination event arguments containing the print options.
void PrintSample::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void PrintSample::sealed::DoNavigation | ( | TypeName | pageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | frame
 | ) |  |
void PrintSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void PrintSample::sealed::GetPagesInRange ( String^ pageRange ) [private]

This is where we parse the range field.

Parameters:
pageRange the page range value
virtual void PrintSample::sealed::GetPrintPreviewPage | ( | Object^ | sender,
 |  | GetPreviewPageEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]

This is the event handler for PrintDocument.GetPrintPreviewPage.

It provides a specific print preview page, in the form of an UIElement, to an instance of PrintDocument. PrintDocument subsequently converts the UIElement into a page that the Windows print system can deal with.

Parameters:
sender | The print document.
e | Arguments containing the preview requested page.
void PrintSample::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
void PrintSample::sealed::InvokePrintButtonClick | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]

button click handlers

concurrency::task<Windows::UI::Xaml::Media::Imaging::WriteableBitmap^> PrintSample::sealed::LoadBitmap | ( | Windows::Foundation::Uri^ | source,
 |  | bool | landscape |
 | ) |  |  | [private]

Loads an image from an uri source and performs a rotation based on the print target aspect.

Parameters:
source | The location of the image.
landscape | A flag that indicates if the target(printer page) is in landscape mode.
PrintSample::sealed::MainPage ( )
void PrintSample::sealed::NotifyUser | ( | String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void PrintSample::sealed::OnContentCreated ( ) [override, protected, virtual]

Removes pages that are not in the given range.

Parameters:
sender The list of preview pages
e

<note> Handling preview for page range Developers have the control over how the preview should look when the user specifies a valid page range. There are three common ways to handle this: 1) Preview remains unaffected by the page range and all the pages are shown independent of the specified page range. 2) Preview is changed and only the pages specified in the range are shown to the user. 3) Preview is changed, showing all the pages and graying out the pages not in page range. We chose option (2) for this sample, developers can choose their preview option. </note>

virtual void PrintSample::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedFrom ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedFrom ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedFrom ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedFrom ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedFrom ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void PrintSample::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void PrintSample::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, virtual]
virtual void PrintSample::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void PrintSample::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
void PrintSample::sealed::Page_Loaded | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void PrintSample::sealed::Page_SizeChanged | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
virtual void PrintSample::sealed::PreparetPrintContent ( ) [override, protected, virtual]
virtual void PrintSample::sealed::PreparetPrintContent ( ) [override, protected, virtual]
virtual void PrintSample::sealed::PreparetPrintContent ( ) [override, protected, virtual]
virtual void PrintSample::sealed::PreparetPrintContent ( ) [override, protected, virtual]
virtual void PrintSample::sealed::PreparetPrintContent ( ) [override, protected, virtual]
PrintSample::sealed::PreviewUnavailable ( )
PrintSample::sealed::PreviewUnavailable | ( | Windows::Foundation::Size | paperSize,
 |  | Windows::Foundation::Size | printableSize
 | ) |  |

Preview unavailable page constructor.

Parameters:
paperSize | The printing page paper size
printableSize | The usable/"printable" area on the page
void PrintSample::sealed::printDetailedOptions_OptionChanged | ( | Windows::Graphics::Printing::OptionDetails::PrintTaskOptionDetails^ | sender,
 |  | Windows::Graphics::Printing::OptionDetails::PrintTaskOptionChangedEventArgs^ | args |
 | ) |  |  | [private]

Option change event handler.

Parameters:
sender | PrintTaskOptionsDetails object
args | the event arguments containing the changed option id
void PrintSample::sealed::PrintDetailedOptionsOptionChanged | ( | Windows::Graphics::Printing::OptionDetails::PrintTaskOptionDetails^ | sender,
 |  | Windows::Graphics::Printing::OptionDetails::PrintTaskOptionChangedEventArgs^ | args |
 | ) |  |  | [protected]

Option change event handler.

Parameters:
sender | The print task option details for which an option changed.
args | The event arguments containing the id of the option changed.
virtual void PrintSample::sealed::PrintTaskRequested | ( | Windows::Graphics::Printing::PrintManager^ | sender,
 |  | Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]

This is the event handler for PrintManager.PrintTaskRequested.

In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified by PrintTaskRequestedEventArgs->Request->Deadline. Therefore, we use this handler to only create the print task. The print settings customization can be done when the print document source is requested.

Parameters:
sender | PrintManager
e | PrintTaskRequestedEventArgs
virtual void PrintSample::sealed::PrintTaskRequested | ( | Windows::Graphics::Printing::PrintManager^ | sender,
 |  | Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]

This is the event handler for PrintManager.PrintTaskRequested.

In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified by PrintTaskRequestedEventArgs->Request->Deadline. Therefore, we use this handler to only create the print task. The print settings customization can be done when the print document source is requested.

Parameters:
sender | PrintManager
e | PrintTaskRequestedEventArgs
virtual void PrintSample::sealed::PrintTaskRequested | ( | Windows::Graphics::Printing::PrintManager^ | sender,
 |  | Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]

This is the event handler for PrintManager.PrintTaskRequested.

In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified by PrintTaskRequestedEventArgs->Request->Deadline. Therefore, we use this handler to only create the print task. The print settings customization can be done when the print document source is requested.

Parameters:
sender | PrintManager
e | PrintTaskRequestedEventArgs
virtual void PrintSample::sealed::PrintTaskRequested | ( | Windows::Graphics::Printing::PrintManager^ | sender,
 |  | Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]

This is the event handler for PrintManager.PrintTaskRequested.

In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified by PrintTaskRequestedEventArgs->Request->Deadline. Therefore, we use this handler to only create the print task. The print settings customization can be done when the print document source is requested.

Parameters:
sender | The print manager for which a print task request was made.
e | The print taks request associated arguments.
void PrintSample::sealed::RefreshPreview ( ) [protected]

Helper function used to triger a preview refresh.

void PrintSample::sealed::RefreshPreview ( ) [private]

Helper getter for image showing.

Helper function used to triger a preview refresh

void PrintSample::sealed::RefreshPreview ( ) [private]

Helper function used to triger a preview refresh.

void PrintSample::sealed::RegisterForPrintingButtonClick | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]

Register for print button handler.

void PrintSample::sealed::RemovePageRangeEdit ( Windows::Graphics::Printing::OptionDetails::PrintTaskOptionDetails^ printTaskOptionDetails ) [private]

Removes the PageRange edit from the charm window.

Parameters:
printTaskOptionDetails Details regarding PrintTaskOptions
PrintSample::sealed::ScenarioInput1 ( )
PrintSample::sealed::ScenarioInput2 ( )
PrintSample::sealed::ScenarioInput3 ( )
PrintSample::sealed::ScenarioInput4 ( )
PrintSample::sealed::ScenarioInput5 ( )
PrintSample::sealed::ScenarioInput6 ( )
concurrency::task<UIElement^> PrintSample::sealed::ScenarioInput6::GeneratePage | ( | int | photoNumber,
 |  | PageDescription | pageDescription |
 | ) |  |  | [private]

Generates a page containing a photo.

The image will be rotated if detected that there is a gain from that regarding size (try to maximize photo size).

Parameters:
photoNumber | The photo number.
pageDescription | The description of the printer page.
Returns:
A task that will produce the page.
PrintSample::sealed::ScenarioList ( )
PrintSample::sealed::ScenarioOutput1 ( )
PrintSample::sealed::ScenarioOutput2 ( )
PrintSample::sealed::ScenarioOutput3 ( )
PrintSample::sealed::ScenarioOutput4 ( )
PrintSample::sealed::ScenarioOutput5 ( )
PrintSample::sealed::ScenarioOutput6 ( )
void PrintSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void PrintSample::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
void PrintSample::sealed::ShowContent ( String^ selectionText ) [private]
void PrintSample::sealed::SplitString | ( | String^ | string,
 |  | wchar_t | delimiter,
 |  | std::vector< std::wstring > & | words |
 | ) |  |  | [private]

Helper function used to split a string based on some delimiters.

Parameters:
string | String to be splited
delimiter | Delimiter character used to split the string
words | Splited (output)words
template<class T >
static void PrintSample::sealed::Swap | ( | T & | v1,
 |  | T & | v2 |
 | ) |  |  | [static, private]

Generic swap of 2 values.

Template Parameters:
T typename
Parameters:
v1 | Value 1
v2 | Value 2

Member Data Documentation

Windows::Foundation::EventRegistrationToken PrintSample::sealed::_displayHandlerToken [private]

Definition at line 69 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame PrintSample::sealed::_inputFrame [private]

Definition at line 66 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken PrintSample::sealed::_inputFrameLoadedToken [private]

Definition at line 73 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken PrintSample::sealed::_logicalDpiChangedToken [private]

Definition at line 72 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame PrintSample::sealed::_outputFrame [private]

Definition at line 67 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken PrintSample::sealed::_outputFrameLoadedToken [private]

Definition at line 74 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken PrintSample::sealed::_pageLoadedHandlerToken [private]

Definition at line 71 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame PrintSample::sealed::_scenariosFrame [private]

Definition at line 65 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken PrintSample::sealed::_sizeChangedHandlerToken [private]

Definition at line 70 of file MainPage.xaml.h.

const int PrintSample::sealed::DPI96 = 96 [static, private]

Constant for 96 DPI.

Definition at line 113 of file ScenarioInput6.xaml.h.

concurrency::critical_section PrintSample::sealed::m_csPrintSync [private]

Synchronization object used to secure access to the page collection and the visual root(printingRoot).

Definition at line 123 of file ScenarioInput6.xaml.h.

PageDescription PrintSample::sealed::m_currentPageDescription [private]

The current printer's page description used to create the content (size, margins, printable area).

Definition at line 138 of file ScenarioInput6.xaml.h.

DisplayContent PrintSample::sealed::m_imageText [private]

A flag that determines if text & images are to be shown.

Definition at line 66 of file ScenarioInput4.xaml.h.

std::map<int,UIElement^> PrintSample::sealed::m_pageCollection [private]

A map of UIElements used to store the print preview pages.

Definition at line 118 of file ScenarioInput6.xaml.h.

std::vector<int> PrintSample::sealed::m_pageList [private]

Collection used to hold the pages in the specified range option.

Definition at line 105 of file ScenarioInput5.xaml.h.

bool PrintSample::sealed::m_pageRangeEditVisible [private]

Determines if the Page Range Edit option is visible.

Definition at line 100 of file ScenarioInput5.xaml.h.

Scaling PrintSample::sealed::m_photoScale [private]

Current scale settings for the image.

Definition at line 133 of file ScenarioInput6.xaml.h.

PhotoSize PrintSample::sealed::m_photoSize [private]

Current size settings for the image.

Definition at line 128 of file ScenarioInput6.xaml.h.

LONGLONG PrintSample::sealed::m_requestCount [private]

A request "number" used to describe a Paginate - GetPreviewPage session.

It is used by GetPreviewPage to determine, before calling SetPreviewPage, if the page content is out of date. Flow: Paginate will increment the request count and all subsequent GetPreviewPage calls will store a local copy and verify it before calling SetPreviewPage. If another Paginate event is triggered while some GetPreviewPage workers are still executing asynchronously their results will be discarded(ignored) because their request number is expired (the photo page description changed).

Definition at line 148 of file ScenarioInput6.xaml.h.

bool PrintSample::sealed::m_selectionMode [private]

Flag used to determine if content selection mode is on.

Definition at line 115 of file ScenarioInput5.xaml.h.

size_t PrintSample::sealed::m_totalPages [private]

Number of total pages determined by the current combination of settings (without page range).

Definition at line 110 of file ScenarioInput5.xaml.h.

const int PrintSample::sealed::NumberOfPhotos = 9 [static, private]

The app's number of photos.

Definition at line 108 of file ScenarioInput6.xaml.h.

MainPage PrintSample::sealed::rootPage [private]

Definition at line 36 of file ScenarioList.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> PrintSample::sealed::OutputFrameLoaded

Definition at line 55 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Print/C++/App.xaml.h
  • Print/C++/MainPage.xaml.h
  • Print/C++/ScenarioInput4.xaml.h
  • Print/C++/ScenarioInput5.xaml.h
  • Print/C++/ScenarioInput6.xaml.h
  • Print/C++/ScenarioList.xaml.h
  • Print/C++/ContinuationPage.xaml.h
  • Print/C++/PreviewUnavailable.xaml.h
  • Print/C++/ScenarioInput1.xaml.h
  • Print/C++/ScenarioInput2.xaml.h
  • Print/C++/ScenarioInput3.xaml.h
  • Print/C++/ScenarioOutput1.xaml.h
  • Print/C++/ScenarioOutput2.xaml.h
  • Print/C++/ScenarioOutput3.xaml.h
  • Print/C++/ScenarioOutput4.xaml.h
  • Print/C++/ScenarioOutput5.xaml.h
  • Print/C++/ScenarioOutput6.xaml.h
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Program Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Program Class Reference

#include "Program.h"

List of all members.

Public Member Functions

void | CreateWindowSizeDependentResources ()
void | Initialize (_In_ Windows::UI::Core::CoreWindow^window)
void | OnPointerMoved (_In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::PointerEventArgs^args)
void | RenderObjects ()
void | SetD2DContext (_In_ ID2D1DeviceContext *d2dContext)

Public Attributes

internal | __pad0__: Program()

Private Member Functions

~Program ()
void | AddShape (_In_reads_(numPoints) Windows::Foundation::Point const *points, _In_ int numPoints, _In_ D2D1::ColorF color)
void | DrawBackward (_In_ std::shared_ptr< ShapeRecord > const &shapeRec)
void | MoveToFront (_Inout_ std::shared_ptr< ShapeRecord > &shapeRec)
void | OnTouchHitTesting (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::TouchHitTestingEventArgs^args)
std::shared_ptr< ShapeRecord > | PointHitTest (_In_ Windows::Foundation::Point pt)
void | SetupControls ()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
float | m_height
std::shared_ptr< ShapeRecord > | m_shapes
float | m_width
Platform::Agile
< Windows::UI::Core::CoreWindow > 		m_window

Detailed Description

Definition at line 22 of file Program.h.

Constructor & Destructor Documentation

Program::~Program ( ) [private]

Definition at line 32 of file Program.cpp.

{
}

Member Function Documentation

void Program::AddShape | ( | _In_reads_(numPoints) Windows::Foundation::Point const * | points,
 |  | _In_ int | numPoints,
 |  | _In_ D2D1::ColorF | color |
 | ) |  |  | [private]

Definition at line 37 of file Program.cpp.

{
    // Create new record for this shape
    std::shared_ptr<ShapeRecord> shapeRecord = std::shared_ptr<ShapeRecord>(new ShapeRecord());
    shapeRecord->shape = std::shared_ptr<Shape>(new Shape());
    shapeRecord->shape->InitializeObject(points, numPoints, color);
    shapeRecord->next = nullptr;
    shapeRecord->cursorId = CURSOR_ID_NONE;

    if (m_shapes == nullptr)
    {
        // The first entry
        m_shapes = shapeRecord;
    }
    else
    {
        // Add to top
        shapeRecord->next = m_shapes;
        m_shapes = shapeRecord;
    }
}

void Program::CreateWindowSizeDependentResources ( )

Definition at line 140 of file Program.cpp.

{
    m_width = m_window->Bounds.Width;
    m_height = m_window->Bounds.Height;

    // Scaling factor
    float minWH = m_width > m_height ? m_height : m_width;
    float scale = minWH / (2 * CONTROLS_AREA_SIZE);

    // Origin of the objects
    Windows::Foundation::Point orig;

    orig.X = (m_width  - CONTROLS_AREA_SIZE * scale) / 2.0F;
    orig.Y = (m_height - CONTROLS_AREA_SIZE * scale) / 2.0F;

    // Assign the setup defined above to each of the core objects
    std::shared_ptr<ShapeRecord> shapeRec = m_shapes;
    while (shapeRec != nullptr)
    {
        shapeRec->shape->ResetState(orig.X, orig.Y, m_width, m_height, scale);
        shapeRec = shapeRec->next;
    }
}

void Program::DrawBackward ( _In_ std::shared_ptr< ShapeRecord > const & shapeRec ) [private]

Definition at line 125 of file Program.cpp.

{
    if (shapeRec != nullptr)
    {
        DrawBackward(shapeRec->next);
        shapeRec->shape->Paint(m_d2dContext.Get());
    }
}

void Program::Initialize ( _In_ Windows::UI::Core::CoreWindow^ window )

Definition at line 110 of file Program.cpp.

{
    m_window = window;

    // Enable Touch Hit Test
    window->TouchHitTesting +=
        ref new TypedEventHandler<CoreWindow^, TouchHitTestingEventArgs^>(this, &Program::OnTouchHitTesting);

    // Create and initialize core objects
    SetupControls();
}

void Program::MoveToFront ( _Inout_ std::shared_ptr< ShapeRecord > & shapeRec ) [private]

Definition at line 61 of file Program.cpp.

{
    // Find previos shape
    std::shared_ptr<ShapeRecord> shapeRecPrev = m_shapes;
    while (shapeRecPrev != nullptr && (shapeRecPrev->next != shapeRec))
    {
        shapeRecPrev = shapeRecPrev->next;
    }

    if (shapeRecPrev != nullptr)
    {
        // It's not on top yet, move it to front
        shapeRecPrev->next = shapeRec->next;
        shapeRec->next = m_shapes;
        m_shapes = shapeRec;
    }
}

void Program::OnPointerMoved ( _In_ Windows::UI::Core::PointerEventArgs^ args )

Definition at line 201 of file Program.cpp.

{
    // find object held with this cursor
    std::shared_ptr<ShapeRecord> shapeRec = m_shapes;
    while (shapeRec != nullptr && (shapeRec->cursorId != args->CurrentPoint->PointerId))
    {
        shapeRec = shapeRec->next;
    }

    // move object
    if (shapeRec != nullptr)
    {
        // move the object
        shapeRec->shape->OnPointerEvent(args->CurrentPoint->Position, true);
    }
}

void Program::OnPointerPressed ( _In_ Windows::UI::Core::PointerEventArgs^ args )

Definition at line 187 of file Program.cpp.

{
    std::shared_ptr<ShapeRecord> shapeRec = PointHitTest(args->CurrentPoint->Position);
    if (shapeRec != nullptr)
    {
        shapeRec->cursorId = args->CurrentPoint->PointerId;
        shapeRec->shape->OnPointerEvent(args->CurrentPoint->Position, false);

        MoveToFront(shapeRec);
    }
}

void Program::OnPointerReleased ( _In_ Windows::UI::Core::PointerEventArgs^ args )

Definition at line 219 of file Program.cpp.

{
    // find object held with this cursor
    std::shared_ptr<ShapeRecord> shapeRec = m_shapes;
    while (shapeRec != nullptr && (shapeRec->cursorId != args->CurrentPoint->PointerId))
    {
        shapeRec = shapeRec->next;
    }

    if (shapeRec != nullptr)
    {
        shapeRec->shape->OnPointerEvent(args->CurrentPoint->Position, true);

        // Release cursor from shape
        shapeRec->cursorId = CURSOR_ID_NONE;
    }
}

void Program::OnTouchHitTesting | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::TouchHitTestingEventArgs^ | args |
 | ) |  |  | [private]

Definition at line 239 of file Program.cpp.

{
    // Current and best Touch Hit Test results
    Windows::UI::Core::CoreProximityEvaluation bestResult;
    Windows::UI::Core::CoreProximityEvaluation currentResult;

    // Initialize best result from input arguments.
    // In theory there may be more than one listener to this event.
    bestResult = touchHitTestingArgs->ProximityEvaluation;

    // Best Touch Hit Test target
    std::shared_ptr<Shape> bestTarget = nullptr;

    bestResult.AdjustedPoint = touchHitTestingArgs->Point;

    // Iterate through all shapes by their z-order (starting from shape with highest z-order)
    // Stop early if there's no chance to find better target.
    std::shared_ptr<ShapeRecord> shapeRec = m_shapes;
    while (shapeRec != nullptr && bestResult.Score > static_cast<int>(Windows::UI::Core::CoreProximityEvaluationScore::Closest))
    {
        Polygon* poly = shapeRec->shape->GetPolygon();

        // Hit test current shape
        if (poly->isRect)
        {
            currentResult = touchHitTestingArgs->EvaluateProximity(poly->rcBound);
        }
        else
        {
            // Create correctly sized array of Points
            auto controlVertices = ref new Platform::Array<Windows::Foundation::Point>(poly->points, poly->numPoints);
            currentResult = touchHitTestingArgs->EvaluateProximity(controlVertices);
        }

        // Does the shape intersect touch contact and is it the best target so far?
        if (currentResult.Score < bestResult.Score)
        {
            // Even if this shape has better score than the score of the shape with higher z-order,
            // don't select this shape if previous adjusted point belongs to this shape.
            // In other words, if this shape overlaps shape with higher z-order, favor the shape with
            // higher z-order.
            if (bestTarget == nullptr || !shapeRec->shape->InRegion(currentResult.AdjustedPoint))
            {
                // Finally, don't select target if adjusted touch point is not on the control.
                // That may happen if another shape with higher z-order overlaps this shape at adjusted touch
                // point.
                if (PointHitTest(currentResult.AdjustedPoint) == shapeRec)
                {
                    // This is the best touch target so far.
                    bestTarget = shapeRec->shape;
                    bestResult = currentResult;
                }
            }
        }

        // Evaluate next shape.
        shapeRec = shapeRec->next;
    }

    // Set best target
    touchHitTestingArgs->ProximityEvaluation = bestResult;

    // Event is handled
    touchHitTestingArgs->Handled = true;
}

std::shared_ptr< ShapeRecord > Program::PointHitTest ( _In_ Windows::Foundation::Point pt ) [private]

Definition at line 170 of file Program.cpp.

{
    std::shared_ptr<ShapeRecord> shapeRec = m_shapes;
    while (shapeRec != nullptr)
    {
        if (shapeRec->shape->InRegion(pt))
        {
            return shapeRec;
        }
        shapeRec = shapeRec->next;
    }

    return nullptr;
}

void Program::RenderObjects ( )

Definition at line 135 of file Program.cpp.

{
    DrawBackward(m_shapes);
}

void Program::SetD2DContext ( _In_ ID2D1DeviceContext * d2dContext )

Definition at line 164 of file Program.cpp.

{
    m_d2dContext = d2dContext;
}

void Program::SetupControls ( ) [private]

Definition at line 80 of file Program.cpp.

{
    Windows::Foundation::Point poly[MAX_POLY_VERTICES];

    // Drawing parameters
    // Triangle side
    float triangleSide = CONTROLS_AREA_SIZE;
    // Triangle height
    float triangleHeight = triangleSide * 87 / 100;

    // 1st control
    // rectangle
    poly[0].X = triangleSide   / 3;
    poly[0].Y = triangleHeight * 2 / 3;
    poly[1].X = triangleSide   * 2 / 3;
    poly[1].Y = triangleHeight;
    AddShape(poly, 2, D2D1::ColorF::Blue);

    // 2nd control
    // Triangle
    poly[0].X = triangleSide   / 3;
    poly[0].Y = triangleHeight * 2 / 3;
    poly[1].X = triangleSide   * 2 / 3;
    poly[1].Y = triangleHeight * 2 / 3;
    poly[2].X = triangleSide   / 2;
    poly[2].Y = triangleHeight / 3;
    AddShape(poly, 3, D2D1::ColorF::Orange);
}

Member Data Documentation

internal Program::__pad0__

Definition at line 25 of file Program.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> Program::m_d2dContext [private]

Definition at line 62 of file Program.h.

float Program::m_height [private]

Definition at line 66 of file Program.h.

std::shared_ptr<ShapeRecord> Program::m_shapes [private]

Definition at line 50 of file Program.h.

float Program::m_width [private]

Definition at line 65 of file Program.h.

Platform::Agile<Windows::UI::Core::CoreWindow> Program::m_window [private]

Definition at line 61 of file Program.h.

The documentation for this class was generated from the following files:
  • Input Touch hit testing/C++/Program.h
  • Input Touch hit testing/C++/Program.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ProximityCPP::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ProximityCPP
  • Common
  • ProximityCPP::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

ProximityCPP::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
bool | _useFilledStateForNarrowWindow
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 26 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String ProximityCPP::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void ProximityCPP::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 211 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void ProximityCPP::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void ProximityCPP::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 142 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal ProximityCPP::Common::LayoutAwarePage::__pad0__

Definition at line 29 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> ProximityCPP::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 52 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> ProximityCPP::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 54 of file LayoutAwarePage.h.

bool ProximityCPP::Common::LayoutAwarePage::_useFilledStateForNarrowWindow [private]

Definition at line 51 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken ProximityCPP::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 53 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Proximity/C++/common/LayoutAwarePage.h
  • Proximity/C++/common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ProximityCPP::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ProximityCPP
  • ProximityCPP::MainPage

ProximityCPP::MainPage Class Reference

#include "Constants.h"

Detailed Description

Definition at line 23 of file Constants.h.

The documentation for this class was generated from the following file:
  • Proximity/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ProximityCPP::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ProximityCPP
  • ProximityCPP::Scenario
Public Attributes

ProximityCPP::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String ProximityCPP::Scenario::ClassName

Definition at line 20 of file Constants.h.

Platform::String ProximityCPP::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • Proximity/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ProximityCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ProximityCPP
  • ProximityCPP::sealed
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes

ProximityCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
void | ClearLog (Windows::UI::Xaml::Controls::TextBlock^textBlock)
void | DeviceArrived (Windows::Networking::Proximity::ProximityDevice^device)
void | DeviceDeparted (Windows::Networking::Proximity::ProximityDevice^device)
bool | IsLaunchedByTap ()
void | LoadScenario (Platform::String^scenarioName)
void | LogInfo (Platform::String^strMessage, Windows::UI::Xaml::Controls::TextBlock^textBlock)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
PeerFinderScenario ()
ProximityDeviceEvents ()
ProximityDeviceScenario ()

Protected Member Functions

void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MessageReceived (Windows::Networking::Proximity::ProximityDevice^device, Windows::Networking::Proximity::ProximityMessage^message)
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
void | ProximityDevice_PublishMessage (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ProximityDevice_SubscribeForMessage (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Protected Attributes

internal | __pad0__: static MainPage^ Current
bool | m_IsLaunchedByTap

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

~MainPage ()
void | CloseSocket ()
void | ConnectionRequestedEventHandler (Object^sender, Windows::Networking::Proximity::ConnectionRequestedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateSize ()
void | InvalidateViewState ()
void | PeerFinder_Accept (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PeerFinder_BrowsePeers (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PeerFinder_Connect (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PeerFinder_Send (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PeerFinder_StartFindingPeers (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PeerFinder_StartReader (Windows::Storage::Streams::DataReader^socketReader)
void | PeerFinder_StartSendReceive (Windows::Networking::Sockets::StreamSocket^socket)
void | PeerFinderInit ()
void | PeerFinderReset ()
void | PopulateScenarios ()
void | Scenario2Reset ()
void | SetFeatureName (Platform::String^strFeature)
void | SetupWindowing (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs)
void | SocketError (Platform::String^errMessage)
void | TriggeredConnectionStateChangedEventHandler (Object^sender, Windows::Networking::Proximity::TriggeredConnectionStateChangedEventArgs^e)

Private Attributes

bool | autoSizeInputSectionWhenSnapped
Windows::UI::Xaml::Controls::Frame | HiddenFrame
Windows::Foundation::EventRegistrationToken | m_arrivedToken
bool | m_browseConnectSupported
Windows::Foundation::EventRegistrationToken | m_connectionRequestedToken
Platform::Collections::Vector
< Platform::String^> 		m_ConnectStateArray
Windows::UI::Core::CoreDispatcher | m_coreDispatcher
Windows::Storage::Streams::DataWriter | m_dataWriter
Windows::Foundation::EventRegistrationToken | m_departedToken
bool | m_peerFinderStarted
Windows::Foundation::Collections::IVectorView
< Windows::Networking::Proximity::PeerInformation^> 		m_peerInformationList
Windows::Networking::Proximity::ProximityDevice | m_proximityDevice
long long | m_publishedMessageId
Windows::Networking::Proximity::PeerInformation | m_requestingPeer
MainPage m_rootPage
Windows::Networking::Sockets::StreamSocket | m_socket
bool | m_socketClosed
bool | m_startPeerFinderImmediately
long long | m_subscribedMessageId
bool | m_triggeredConnectSupported
Windows::Foundation::EventRegistrationToken | m_triggerToken
Platform::Collections::Vector
< Object^> 		ScenarioList

Detailed Description

Definition at line 24 of file App.xaml.h.

Constructor & Destructor Documentation

ProximityCPP::sealed::~MainPage ( ) [private]

Member Function Documentation

ProximityCPP::sealed::App ( )
void ProximityCPP::sealed::ClearLog ( Windows::UI::Xaml::Controls::TextBlock^ textBlock )
void ProximityCPP::sealed::CloseSocket ( ) [private]
void ProximityCPP::sealed::ConnectionRequestedEventHandler | ( | Object^ | sender,
 |  | Windows::Networking::Proximity::ConnectionRequestedEventArgs^ | e |
 | ) |  |  | [private]
void ProximityCPP::sealed::DeviceArrived ( Windows::Networking::Proximity::ProximityDevice^ device )
void ProximityCPP::sealed::DeviceDeparted ( Windows::Networking::Proximity::ProximityDevice^ device )
void ProximityCPP::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ProximityCPP::sealed::InvalidateSize ( ) [private]
void ProximityCPP::sealed::InvalidateViewState ( ) [private]
bool ProximityCPP::sealed::IsLaunchedByTap ( )
void ProximityCPP::sealed::LoadScenario ( Platform::String^ scenarioName )
void ProximityCPP::sealed::LogInfo | ( | Platform::String^ | strMessage,
 |  | Windows::UI::Xaml::Controls::TextBlock^ | textBlock
 | ) |  |
ProximityCPP::sealed::MainPage ( )
void ProximityCPP::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void ProximityCPP::sealed::MessageReceived | ( | Windows::Networking::Proximity::ProximityDevice^ | device,
 |  | Windows::Networking::Proximity::ProximityMessage^ | message |
 | ) |  |  | [protected]
void ProximityCPP::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void ProximityCPP::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void ProximityCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ProximityCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ProximityCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ProximityCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ProximityCPP::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void ProximityCPP::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void ProximityCPP::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void ProximityCPP::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void ProximityCPP::sealed::PeerFinder_Accept | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ProximityCPP::sealed::PeerFinder_BrowsePeers | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ProximityCPP::sealed::PeerFinder_Connect | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ProximityCPP::sealed::PeerFinder_Send | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ProximityCPP::sealed::PeerFinder_StartFindingPeers | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ProximityCPP::sealed::PeerFinder_StartReader ( Windows::Storage::Streams::DataReader^ socketReader ) [private]
void ProximityCPP::sealed::PeerFinder_StartSendReceive ( Windows::Networking::Sockets::StreamSocket^ socket ) [private]
void ProximityCPP::sealed::PeerFinderInit ( ) [private]
void ProximityCPP::sealed::PeerFinderReset ( ) [private]
ProximityCPP::sealed::PeerFinderScenario ( )
void ProximityCPP::sealed::PopulateScenarios ( ) [private]
void ProximityCPP::sealed::ProximityDevice_PublishMessage | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
void ProximityCPP::sealed::ProximityDevice_SubscribeForMessage | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
ProximityCPP::sealed::ProximityDeviceEvents ( )
ProximityCPP::sealed::ProximityDeviceScenario ( )
void ProximityCPP::sealed::Scenario2Reset ( ) [private]
void ProximityCPP::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void ProximityCPP::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
void ProximityCPP::sealed::SetupWindowing ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [private]
void ProximityCPP::sealed::SocketError ( Platform::String^ errMessage ) [private]
void ProximityCPP::sealed::TriggeredConnectionStateChangedEventHandler | ( | Object^ | sender,
 |  | Windows::Networking::Proximity::TriggeredConnectionStateChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal ProximityCPP::sealed::__pad0__ [protected]

Definition at line 99 of file MainPage.xaml.h.

bool ProximityCPP::sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 90 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame ProximityCPP::sealed::HiddenFrame [private]

Definition at line 88 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ProximityCPP::sealed::m_arrivedToken [private]

Definition at line 40 of file ProximityDeviceEvents.xaml.h.

bool ProximityCPP::sealed::m_browseConnectSupported [private]

Definition at line 63 of file PeerFinderScenario.xaml.h.

Windows::Foundation::EventRegistrationToken ProximityCPP::sealed::m_connectionRequestedToken [private]

Definition at line 67 of file PeerFinderScenario.xaml.h.

Platform::Collections::Vector<Platform::String^> ProximityCPP::sealed::m_ConnectStateArray [private]

Definition at line 70 of file PeerFinderScenario.xaml.h.

Windows::UI::Core::CoreDispatcher ProximityCPP::sealed::m_coreDispatcher [private]

Definition at line 56 of file PeerFinderScenario.xaml.h.

Windows::Storage::Streams::DataWriter ProximityCPP::sealed::m_dataWriter [private]

Definition at line 61 of file PeerFinderScenario.xaml.h.

Windows::Foundation::EventRegistrationToken ProximityCPP::sealed::m_departedToken [private]

Definition at line 41 of file ProximityDeviceEvents.xaml.h.

bool ProximityCPP::sealed::m_IsLaunchedByTap [protected]

Definition at line 100 of file MainPage.xaml.h.

bool ProximityCPP::sealed::m_peerFinderStarted [private]

Definition at line 57 of file PeerFinderScenario.xaml.h.

Windows::Foundation::Collections::IVectorView<Windows::Networking::Proximity::PeerInformation^> ProximityCPP::sealed::m_peerInformationList [private]

Definition at line 58 of file PeerFinderScenario.xaml.h.

Windows::Networking::Proximity::ProximityDevice sealed::m_proximityDevice [private]

Definition at line 42 of file ProximityDeviceEvents.xaml.h.

long long ProximityCPP::sealed::m_publishedMessageId [private]

Definition at line 43 of file ProximityDeviceScenario.xaml.h.

Windows::Networking::Proximity::PeerInformation ProximityCPP::sealed::m_requestingPeer [private]

Definition at line 59 of file PeerFinderScenario.xaml.h.

MainPage sealed::m_rootPage [private]

Definition at line 55 of file PeerFinderScenario.xaml.h.

Windows::Networking::Sockets::StreamSocket ProximityCPP::sealed::m_socket [private]

Definition at line 60 of file PeerFinderScenario.xaml.h.

bool ProximityCPP::sealed::m_socketClosed [private]

Definition at line 65 of file PeerFinderScenario.xaml.h.

bool ProximityCPP::sealed::m_startPeerFinderImmediately [private]

Definition at line 64 of file PeerFinderScenario.xaml.h.

long long ProximityCPP::sealed::m_subscribedMessageId [private]

Definition at line 45 of file ProximityDeviceScenario.xaml.h.

bool ProximityCPP::sealed::m_triggeredConnectSupported [private]

Definition at line 62 of file PeerFinderScenario.xaml.h.

Windows::Foundation::EventRegistrationToken ProximityCPP::sealed::m_triggerToken [private]

Definition at line 66 of file PeerFinderScenario.xaml.h.

Platform::Collections::Vector<Object^> ProximityCPP::sealed::ScenarioList [private]

Definition at line 87 of file MainPage.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> ProximityCPP::sealed::MainPageResized

Definition at line 78 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> ProximityCPP::sealed::ScenarioLoaded

Definition at line 77 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Proximity/C++/App.xaml.h
  • Proximity/C++/MainPage.xaml.h
  • Proximity/C++/PeerFinderScenario.xaml.h
  • Proximity/C++/ProximityDeviceEvents.xaml.h
  • Proximity/C++/ProximityDeviceScenario.xaml.h
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: QiList< InterfaceName, InterfaceChain > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

QiList< InterfaceName, InterfaceChain > Class Template Reference

#include "pch.h"

List of all members.

Public Member Functions

void QueryInterfaceInternal (IID const &iid, OUT void **ppObject)

Detailed Description

template<typename InterfaceName, typename InterfaceChain = QiListNil>
class QiList< InterfaceName, InterfaceChain >

Definition at line 163 of file pch.h.

Member Function Documentation

template<typename InterfaceName, typename InterfaceChain = QiListNil>
void QiList< InterfaceName, InterfaceChain >::QueryInterfaceInternal | ( | IID const & | iid,
 |  | OUT void ** | ppObject |
 | ) |  |  | [inline]

Definition at line 166 of file pch.h.

    {
        if (iid != __uuidof(InterfaceName))
            return InterfaceChain::QueryInterfaceInternal(iid, ppObject);

        *ppObject = static_cast<InterfaceName*>(this);
    }

The documentation for this class was generated from the following file:
  • DirectWrite vertical text/C++/pch.h
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: QiList< InterfaceName, QiListNil > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

QiList< InterfaceName, QiListNil > Class Template Reference

#include "pch.h"

List of all members.

Public Member Functions

void QueryInterfaceInternal (IID const &iid, OUT void **ppObject)

Detailed Description

template<typename InterfaceName>
class QiList< InterfaceName, QiListNil >

Definition at line 177 of file pch.h.

Member Function Documentation

template<typename InterfaceName >
void QiList< InterfaceName, QiListNil >::QueryInterfaceInternal | ( | IID const & | iid,
 |  | OUT void ** | ppObject |
 | ) |  |  | [inline]

Definition at line 180 of file pch.h.

    {
        if (iid != __uuidof(InterfaceName))
            return;

        *ppObject = static_cast<InterfaceName*>(this);
    }

The documentation for this class was generated from the following file:
  • DirectWrite vertical text/C++/pch.h
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: QiListNil Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

QiListNil Struct Reference

#include "pch.h"

Detailed Description

Definition at line 141 of file pch.h.

The documentation for this struct was generated from the following file:
  • DirectWrite vertical text/C++/pch.h
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: QiListSelf< InterfaceName, InterfaceChain > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

QiListSelf< InterfaceName, InterfaceChain > Class Template Reference

#include "pch.h"

List of all members.

Public Member Functions

void QueryInterfaceInternal (IID const &iid, OUT void **ppObject)

Detailed Description

template<typename InterfaceName, typename InterfaceChain>
class QiListSelf< InterfaceName, InterfaceChain >

Definition at line 149 of file pch.h.

Member Function Documentation

template<typename InterfaceName , typename InterfaceChain >
void QiListSelf< InterfaceName, InterfaceChain >::QueryInterfaceInternal | ( | IID const & | iid,
 |  | OUT void ** | ppObject |
 | ) |  |  | [inline]

Definition at line 152 of file pch.h.

    {
        if (iid != __uuidof(InterfaceName))
            return InterfaceChain::QueryInterfaceInternal(iid, ppObject);

        *ppObject = static_cast<InterfaceName*>(this);
    }

The documentation for this class was generated from the following file:
  • DirectWrite vertical text/C++/pch.h
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: RandomAccessReader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

RandomAccessReader Class Reference

#include "RandomAccessReader.h"

List of all members.

Public Member Functions

uint64 | GetFileSize ()
uint64 | GetPosition ()
Platform::Array< byte > | Read (_In_ size_t bytesToRead)
void | SeekAbsolute (_In_ int64 position)
void | SeekRelative (_In_ int64 offset)
void | SeekToEnd ()
void | SeekToStart ()

Public Attributes

internal | __pad0__: RandomAccessReader(_In_ Platform::String^ fileName)

Private Attributes

Microsoft::WRL::Wrappers::FileHandle | m_file

Detailed Description

Definition at line 11 of file RandomAccessReader.h.

Member Function Documentation

uint64 RandomAccessReader::GetFileSize ( )

Definition at line 60 of file RandomAccessReader.cpp.

{
    FILE_STANDARD_INFO fileStandardInfo = { 0 };
    BOOL result = ::GetFileInformationByHandleEx(
        m_file.Get(),
        FileStandardInfo,
        &fileStandardInfo,
        sizeof(fileStandardInfo)
        );

    if ((result == 0) || (fileStandardInfo.AllocationSize.QuadPart < 0))
    {
        throw ref new Platform::FailureException();
    }

    return fileStandardInfo.AllocationSize.QuadPart;
}

uint64 RandomAccessReader::GetPosition ( )

Definition at line 78 of file RandomAccessReader.cpp.

{
    LARGE_INTEGER position = { 0 };
    LARGE_INTEGER zero = { 0 };
    BOOL result = ::SetFilePointerEx(m_file.Get(), zero, &position, FILE_CURRENT);
    if ((result == 0) || (position.QuadPart < 0))
    {
        throw ref new Platform::FailureException();
    }

    return position.QuadPart;
}

Platform::Array< byte > RandomAccessReader::Read ( _In_ size_t bytesToRead )

Definition at line 40 of file RandomAccessReader.cpp.

{
    Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(static_cast<uint>(bytesToRead));

    if (!ReadFile(
        m_file.Get(),
        fileData->Data,
        fileData->Length,
        nullptr,
        nullptr
        ))
    {
        throw ref new Platform::FailureException();
    }

    return fileData;
}

void RandomAccessReader::SeekAbsolute ( _In_ int64 position )

Definition at line 102 of file RandomAccessReader.cpp.

{
    if (position < 0)
    {
        throw ref new Platform::FailureException();
    }

    LARGE_INTEGER pos;
    pos.QuadPart = position;
    BOOL result = ::SetFilePointerEx(m_file.Get(), pos, nullptr, FILE_BEGIN);
    if (result == 0)
    {
        throw ref new Platform::FailureException();
    }
}

void RandomAccessReader::SeekRelative ( _In_ int64 offset )

Definition at line 91 of file RandomAccessReader.cpp.

{
    LARGE_INTEGER position;
    position.QuadPart = offset;
    BOOL result = ::SetFilePointerEx(m_file.Get(), position, nullptr, FILE_CURRENT);
    if (result == 0)
    {
        throw ref new Platform::FailureException();
    }
}

void RandomAccessReader::SeekToEnd ( )

Definition at line 129 of file RandomAccessReader.cpp.

{
    LARGE_INTEGER zero = { 0 };
    BOOL result = ::SetFilePointerEx(m_file.Get(), zero, nullptr, FILE_END);
    if (result == 0)
    {
        throw ref new Platform::FailureException();
    }
}

void RandomAccessReader::SeekToStart ( )

Definition at line 119 of file RandomAccessReader.cpp.

{
    LARGE_INTEGER zero = { 0 };
    BOOL result = ::SetFilePointerEx(m_file.Get(), zero, nullptr, FILE_BEGIN);
    if (result == 0)
    {
        throw ref new Platform::FailureException();
    }
}

Member Data Documentation

internal RandomAccessReader::__pad0__

Definition at line 14 of file RandomAccessReader.h.

Microsoft::WRL::Wrappers::FileHandle RandomAccessReader::m_file [private]

Definition at line 27 of file RandomAccessReader.h.

The documentation for this class was generated from the following files:
  • XAudio2 audio file playback/C++/RandomAccessReader.h
  • XAudio2 audio file playback/C++/RandomAccessReader.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: RawNotificationsSampleCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • RawNotificationsSampleCPP
  • RawNotificationsSampleCPP::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

RawNotificationsSampleCPP::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
void | CheckResolutionAndViewState ()
String | ConvertResolution (ResolutionScale scale)
String | ConvertViewState (ApplicationViewState state)
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | DoNavigation (TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame)
void | Footer_Click (Object^sender, RoutedEventArgs^e)
void | inputFrameNavigated (Object^sender, NavigationEventArgs^e)
MainPage ()
void | NotifyUser (String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
void | outputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | Page_Loaded (Object^sender, RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()
void | SetFeatureName (Platform::String^strFeature)

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)

Properties

Windows::Networking::PushNotifications::PushNotificationChannel | _channel
Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _layoutHandlerToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~ScenarioInput1 ()
~ScenarioInput2 ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
void | BackgroundTaskCompleted (Windows::ApplicationModel::Background::BackgroundTaskRegistration^sender, Windows::ApplicationModel::Background::BackgroundTaskCompletedEventArgs^args)
void | OnPushNotificationReceived (Windows::Networking::PushNotifications::PushNotificationChannel^sender, Windows::Networking::PushNotifications::PushNotificationReceivedEventArgs^e)
void | OpenChannelAndRegisterTask ()
void | OutputFrameLoaded (Object^sender, Object^e)
void | OutputToTextBox (Platform::String^text)
void | RegisterBackgroundTask ()
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | Scenario1Open_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario1Unregister_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario2AddListener_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario2RemoveListener_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
bool | UnregisterBackgroundTask ()
bool | UpdateListener (bool add)

Private Attributes

Windows::UI::Core::CoreDispatcher | _dispatcher
Windows::Foundation::EventRegistrationToken | _frameLoadedToken
EventRegistrationToken | _frameLoadedToken
Windows::Foundation::EventRegistrationToken | pushToken
MainPage | rootPage

Detailed Description

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

RawNotificationsSampleCPP::sealed::~ScenarioInput1 ( ) [private]
RawNotificationsSampleCPP::sealed::~ScenarioInput2 ( ) [private]
RawNotificationsSampleCPP::sealed::~ScenarioList ( ) [private]
RawNotificationsSampleCPP::sealed::~ScenarioOutput1 ( ) [private]
RawNotificationsSampleCPP::sealed::~ScenarioOutput2 ( ) [private]

Member Function Documentation

RawNotificationsSampleCPP::sealed::App ( )
void RawNotificationsSampleCPP::sealed::BackgroundTaskCompleted | ( | Windows::ApplicationModel::Background::BackgroundTaskRegistration^ | sender,
 |  | Windows::ApplicationModel::Background::BackgroundTaskCompletedEventArgs^ | args |
 | ) |  |  | [private]
void RawNotificationsSampleCPP::sealed::CheckResolutionAndViewState ( )
String RawNotificationsSampleCPP::sealed::ConvertResolution ( ResolutionScale scale )
String RawNotificationsSampleCPP::sealed::ConvertViewState ( ApplicationViewState state )
void RawNotificationsSampleCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender )
void RawNotificationsSampleCPP::sealed::DoNavigation | ( | TypeName | pageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | frame
 | ) |  |
void RawNotificationsSampleCPP::sealed::Footer_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e
 | ) |  |
void RawNotificationsSampleCPP::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e
 | ) |  |
RawNotificationsSampleCPP::sealed::MainPage ( )
void RawNotificationsSampleCPP::sealed::NotifyUser | ( | String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void RawNotificationsSampleCPP::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void RawNotificationsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void RawNotificationsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void RawNotificationsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void RawNotificationsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void RawNotificationsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void RawNotificationsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void RawNotificationsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void RawNotificationsSampleCPP::sealed::OnPushNotificationReceived | ( | Windows::Networking::PushNotifications::PushNotificationChannel^ | sender,
 |  | Windows::Networking::PushNotifications::PushNotificationReceivedEventArgs^ | e |
 | ) |  |  | [private]
virtual void RawNotificationsSampleCPP::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void RawNotificationsSampleCPP::sealed::OpenChannelAndRegisterTask ( ) [private]
void RawNotificationsSampleCPP::sealed::OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void RawNotificationsSampleCPP::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e
 | ) |  |
void RawNotificationsSampleCPP::sealed::OutputToTextBox ( Platform::String^ text ) [private]
void RawNotificationsSampleCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e
 | ) |  |
void RawNotificationsSampleCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e
 | ) |  |
void RawNotificationsSampleCPP::sealed::RegisterBackgroundTask ( ) [private]
void RawNotificationsSampleCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void RawNotificationsSampleCPP::sealed::Scenario1Open_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void RawNotificationsSampleCPP::sealed::Scenario1Unregister_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void RawNotificationsSampleCPP::sealed::Scenario2AddListener_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void RawNotificationsSampleCPP::sealed::Scenario2RemoveListener_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
RawNotificationsSampleCPP::sealed::ScenarioInput1 ( )
RawNotificationsSampleCPP::sealed::ScenarioInput2 ( )
RawNotificationsSampleCPP::sealed::ScenarioList ( )
RawNotificationsSampleCPP::sealed::ScenarioOutput1 ( )
RawNotificationsSampleCPP::sealed::ScenarioOutput2 ( )
void RawNotificationsSampleCPP::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void RawNotificationsSampleCPP::sealed::SetFeatureName ( Platform::String^ strFeature )
bool RawNotificationsSampleCPP::sealed::UnregisterBackgroundTask ( ) [private]
bool RawNotificationsSampleCPP::sealed::UpdateListener ( bool add ) [private]

Member Data Documentation

Windows::UI::Core::CoreDispatcher sealed::_dispatcher [private]

Definition at line 40 of file ScenarioInput1.xaml.h.

Windows::Foundation::EventRegistrationToken RawNotificationsSampleCPP::sealed::_frameLoadedToken [private]

Definition at line 35 of file ScenarioOutput1.xaml.h.

EventRegistrationToken RawNotificationsSampleCPP::sealed::_frameLoadedToken [private]

Definition at line 41 of file ScenarioInput1.xaml.h.

Windows::Foundation::EventRegistrationToken RawNotificationsSampleCPP::sealed::pushToken [private]

Definition at line 36 of file ScenarioInput2.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 34 of file ScenarioInput1.xaml.h.

Property Documentation

Windows::Networking::PushNotifications::PushNotificationChannel RawNotificationsSampleCPP::sealed::_channel

Definition at line 89 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken RawNotificationsSampleCPP::sealed::_displayHandlerToken

Definition at line 75 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame RawNotificationsSampleCPP::sealed::_inputFrame

Definition at line 72 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken RawNotificationsSampleCPP::sealed::_inputFrameLoadedToken

Definition at line 79 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken RawNotificationsSampleCPP::sealed::_layoutHandlerToken

Definition at line 76 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken RawNotificationsSampleCPP::sealed::_logicalDpiChangedToken

Definition at line 78 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame RawNotificationsSampleCPP::sealed::_outputFrame

Definition at line 73 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken RawNotificationsSampleCPP::sealed::_outputFrameLoadedToken

Definition at line 80 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken RawNotificationsSampleCPP::sealed::_pageLoadedHandlerToken

Definition at line 77 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame RawNotificationsSampleCPP::sealed::_scenariosFrame

Definition at line 70 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> RawNotificationsSampleCPP::sealed::OutputFrameLoaded

Definition at line 55 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Raw notifications/C++/MainAppSample/App.xaml.h
  • Raw notifications/C++/MainAppSample/MainPage.xaml.h
  • Raw notifications/C++/MainAppSample/ScenarioInput1.xaml.h
  • Raw notifications/C++/MainAppSample/ScenarioInput2.xaml.h
  • Raw notifications/C++/MainAppSample/ScenarioList.xaml.h
  • Raw notifications/C++/MainAppSample/ScenarioOutput1.xaml.h
  • Raw notifications/C++/MainAppSample/ScenarioOutput2.xaml.h
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ReadStreamTask Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Private Attributes | Static Private Attributes

ReadStreamTask Class Reference

#include "CompressionUtils.h"

List of all members.

Classes

struct | ReadStreamTaskImpl

Public Member Functions

ReadStreamTask (Windows::Storage::Streams::IInputStream^Stream, std::vector< byte > &Destination)
ReadStreamTask (const ReadStreamTask &Task)
concurrency::task< size_t > | GetTask ()
ReadStreamTask & | operator= (const ReadStreamTask &Task)

Private Attributes

ReadStreamTaskImpl * _Impl

Static Private Attributes

static const unsigned int | MinReadChunkSize = 0x10000

Detailed Description

Definition at line 10 of file CompressionUtils.h.

Constructor & Destructor Documentation

ReadStreamTask::ReadStreamTask | ( | Windows::Storage::Streams::IInputStream^ | Stream,
 |  | std::vector< byte > & | Destination
 | ) |  |
ReadStreamTask::ReadStreamTask ( const ReadStreamTask & Task )

Definition at line 108 of file CompressionUtils.cpp.

                                                        :
    _Impl(Task._Impl)
{
}

Member Function Documentation

task< size_t > ReadStreamTask::GetTask ( )

Definition at line 119 of file CompressionUtils.cpp.

{
    return _Impl->_Task;
}

ReadStreamTask & ReadStreamTask::operator= ( const ReadStreamTask & Task )

Definition at line 113 of file CompressionUtils.cpp.

{
    _Impl = Task._Impl;
    return *this;
}

Member Data Documentation

ReadStreamTaskImpl* ReadStreamTask::_Impl [private]

Definition at line 22 of file CompressionUtils.h.

const unsigned int ReadStreamTask::MinReadChunkSize = 0x10000 [static, private]

Definition at line 20 of file CompressionUtils.h.

The documentation for this class was generated from the following files:
  • Compression/C++/CompressionUtils.h
  • Compression/C++/CompressionUtils.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ReadStreamTask::ReadStreamTaskImpl Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ReadStreamTask
  • ReadStreamTask::ReadStreamTaskImpl
Public Member Functions | Public Attributes

ReadStreamTask::ReadStreamTaskImpl Struct Reference

List of all members.

Public Member Functions

ReadStreamTaskImpl (IInputStream^Stream, std::vector< byte > &Destination)
void | ReadChunk ()

Public Attributes

task_completion_event< void > | _CompletionEvent
std::vector< byte > & | _Destination
DataReader | _Reader
std::vector< byte > | _StreamData
task< size_t > | _Task

Detailed Description

Definition at line 15 of file CompressionUtils.cpp.

Constructor & Destructor Documentation

ReadStreamTask::ReadStreamTaskImpl::ReadStreamTaskImpl | ( | IInputStream^ | Stream,
 |  | std::vector< byte > & | Destination |
 | ) |  |  | [inline]

Definition at line 16 of file CompressionUtils.cpp.

                                                                          :
        _Destination(Destination),
        _Reader(ref new DataReader(Stream)),
        _CompletionEvent()
    {
        _Task = create_task(_CompletionEvent).then([this]
        {
            // Schedule resource deallocation
            std::unique_ptr<ReadStreamTaskImpl> thisHolder(this);

            // Prevent user provided stream from being closed
            _Reader->DetachStream();

            // Move data out
            _Destination = std::move(_StreamData);

            return _Destination.size();
        });

        // Start recursive reading
        ReadChunk();
    }

Member Function Documentation

void ReadStreamTask::ReadStreamTaskImpl::ReadChunk ( ) [inline]

Definition at line 39 of file CompressionUtils.cpp.

    {
        // LoadAsync itself could throw exception if IAsyncOperation couldn't be created with
        // given parameters in a current state
        try
        {
            // Read data into the data reader
            _StreamData.reserve(_StreamData.size() + MinReadChunkSize);
            create_task(_Reader->LoadAsync(static_cast<unsigned int>(_StreamData.capacity() - _StreamData.size())))

            // Then store it to the result vector
            .then([this](task<unsigned int> BytesRead)
            {
                try
                {
                    // exception is thrown here if LoadAsync operation has been completed with an error
                    auto bytesRead = BytesRead.get();
                    if (bytesRead)
                    {
                        // Store chunk of data in the result vector.
                        auto newData = ref new Platform::Array<byte>(bytesRead);
                        _Reader->ReadBytes(newData);

                        _StreamData.insert(_StreamData.end(), newData->begin(), newData->end());

                        // Then recurse to read next chunk.
                        ReadChunk();
                    }
                    else
                    {
                        // End of stream is reached - complete top level task with the data we've read so far

                        // make sure that _CompletionEvent outlives continuation which deletes this ReadStreamTaskImpl
                        auto completionEvent = _CompletionEvent;
                        completionEvent.set();
                    }
                }
                catch (...)
                {
                    // Schedule resource deallocation
                    std::unique_ptr<ReadStreamTaskImpl> thisHolder(this);

                    _CompletionEvent.set_exception(std::current_exception());
                }
            });
        }
        catch (...)
        {
            // Schedule resource deallocation
            std::unique_ptr<ReadStreamTaskImpl> thisHolder(this);

            _CompletionEvent.set_exception(std::current_exception());
        }
    }

Member Data Documentation

task_completion_event<void> ReadStreamTask::ReadStreamTaskImpl::_CompletionEvent

Definition at line 99 of file CompressionUtils.cpp.

std::vector<byte>& ReadStreamTask::ReadStreamTaskImpl::_Destination

Definition at line 95 of file CompressionUtils.cpp.

DataReader ReadStreamTask::ReadStreamTaskImpl::_Reader

Definition at line 96 of file CompressionUtils.cpp.

std::vector<byte> ReadStreamTask::ReadStreamTaskImpl::_StreamData

Definition at line 97 of file CompressionUtils.cpp.

task<size_t> ReadStreamTask::ReadStreamTaskImpl::_Task

Definition at line 100 of file CompressionUtils.cpp.

The documentation for this struct was generated from the following file:
  • Compression/C++/CompressionUtils.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Rectangle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Rectangle Class Reference

#include "Rectangle.h"

Inherits Element.

Inherited by List< T >, List< Control >, List< IMFSample * >, List< IUnknown * >, List< Scenario >, List< SourceOp * >, List< T * >, and List< TOperation * >.

List of all members.

Public Member Functions

virtual bool | Draw (_In_ Document^document, D2D1::Matrix3x2F const &transform) override
virtual float | GetOpacity () override
virtual bool | Initialize (_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override
virtual void | Measure (_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override

Public Attributes

internal | __pad0__: Rectangle()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Brush > 		m_brush
uint32 | m_color
float | m_opacity

Detailed Description

Definition at line 20 of file Rectangle.h.

Member Function Documentation

bool Rectangle::Draw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Reimplemented in List< T >, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

Definition at line 64 of file Rectangle.cpp.

{
    ComPtr<ID2D1DeviceContext> d2dDeviceContext;
    document->GetRenderer()->GetD2DDeviceContext(&d2dDeviceContext);

    if (m_brush == nullptr)
    {
        ComPtr<ID2D1SolidColorBrush> solidColorBrush;

        DX::ThrowIfFailed(
            d2dDeviceContext->CreateSolidColorBrush(
                D2D1::ColorF(m_color, m_opacity),
                D2D1::BrushProperties(),
                &solidColorBrush
                )
            );

        m_brush = solidColorBrush;
    }

    d2dDeviceContext->SetTransform(transform);

    d2dDeviceContext->FillRectangle(
        D2D1::RectF(
            m_offset.x,
            m_offset.y,
            m_offset.x + m_size.width,
            m_offset.y + m_size.height
            ),
        m_brush.Get()
        );

    return false;
}

virtual float Rectangle::GetOpacity ( ) [inline, override, virtual]

Reimplemented from Element.

Definition at line 41 of file Rectangle.h.

    {
        return m_opacity;
    }

virtual bool Rectangle::Initialize | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::XmlElement^ | xmlElement |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Reimplemented in List< T >, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

void Rectangle::Measure | ( | _In_ Document^ | document,
 |  | D2D1_SIZE_F const & | parentSize,
 |  | _Out_ D2D1_RECT_F * | bounds |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Reimplemented in List< T >, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

Definition at line 50 of file Rectangle.cpp.

{
    *bounds = D2D1::RectF(
        m_offset.x,
        m_offset.y,
        m_offset.x + m_size.width,
        m_offset.y + m_size.height
        );
}

Member Data Documentation

internal Rectangle::__pad0__

Reimplemented from Element.

Reimplemented in List< T >, List< T * >, List< IUnknown * >, List< SourceOp * >, List< IMFSample * >, List< Scenario >, List< TOperation * >, and List< Control >.

Definition at line 23 of file Rectangle.h.

Microsoft::WRL::ComPtr<ID2D1Brush> Rectangle::m_brush [private]

Definition at line 54 of file Rectangle.h.

uint32 Rectangle::m_color [private]

Definition at line 48 of file Rectangle.h.

float Rectangle::m_opacity [private]

Definition at line 51 of file Rectangle.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/Rectangle.h
  • Direct2D magazine app/C++/Rectangle.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: RenderBuffer Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

RenderBuffer Struct Reference

#include "Common.h"

List of all members.

Public Member Functions

RenderBuffer ()
~RenderBuffer ()

Public Attributes

BYTE * | Buffer
UINT32 | BufferSize
UINT32 | BytesFilled
RenderBuffer * Next

Detailed Description

Definition at line 134 of file Common.h.

Constructor & Destructor Documentation

RenderBuffer::RenderBuffer ( ) [inline]

Definition at line 141 of file Common.h.

                   :
        BufferSize(0),
        BytesFilled(0),
        Buffer( nullptr ),
        Next( nullptr )
    {
    }

RenderBuffer::~RenderBuffer ( ) [inline]

Definition at line 149 of file Common.h.

    {
        SAFE_ARRAYDELETE( Buffer );
    }

Member Data Documentation

BYTE* RenderBuffer::Buffer

Definition at line 138 of file Common.h.

UINT32 RenderBuffer::BufferSize

Definition at line 136 of file Common.h.

UINT32 RenderBuffer::BytesFilled

Definition at line 137 of file Common.h.

RenderBuffer* RenderBuffer::Next

Definition at line 139 of file Common.h.

The documentation for this struct was generated from the following file:
  • Windows Audio Session (WASAPI)/C++/Common.h
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Renderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Renderer Class Reference

#include "Renderer.h"

List of all members.

Public Member Functions

void | GetD2DDeviceContext (_Outptr_ ID2D1DeviceContext **d2dDeviceContext)
float | GetDisplayHeight ()
D2D1_SIZE_F | GetDisplaySize ()
float | GetDisplayWidth ()
void | GetDXGIDevice (_Outptr_ IDXGIDevice **dxgiDevice)
void | GetWICImagingFactory (_Outptr_ IWICImagingFactory2 **wicFactory)
void | HandleDeviceLost ()
bool | IsOrientationLandscape ()
void | SetDpi (float dpi)
void | UpdateWindowSize ()

Public Attributes

internal | __pad0__: Renderer( Windows::Foundation::Rect windowBounds
event DeviceLostEventHandler | DeviceLost
internal float | dpi

Private Member Functions

void | CreateDeviceIndependentResources ()
void | CreateDeviceResources ()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1Device > 		m_d2dDevice
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dDeviceContext
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
float | m_dpi
Microsoft::WRL::ComPtr
< IDXGIDevice > 		m_dxgiDevice
D3D_FEATURE_LEVEL | m_featureLevel
Microsoft::WRL::ComPtr
< IWICImagingFactory2 > 		m_wicFactory
Windows::Foundation::Rect | m_windowBounds

Detailed Description

Definition at line 22 of file Renderer.h.

Member Function Documentation

void Renderer::CreateDeviceIndependentResources ( ) [private]

Definition at line 40 of file Renderer.cpp.

{
    D2D1_FACTORY_OPTIONS options;
    ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));

#if defined(_DEBUG)
    // If the project is in a debug build, enable Direct2D debugging via Direct2D SDK layer.
    // Enabling SDK debug layer can help catch coding mistakes such as invalid calls and
    // resource leaking that needs to be fixed during the development cycle.
    options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
#endif

    DX::ThrowIfFailed(
        D2D1CreateFactory(
            D2D1_FACTORY_TYPE_SINGLE_THREADED,
            __uuidof(ID2D1Factory1),
            &options,
            &m_d2dFactory
            )
        );

    DX::ThrowIfFailed(
        CoCreateInstance(
            CLSID_WICImagingFactory,
            nullptr,
            CLSCTX_INPROC_SERVER,
            IID_PPV_ARGS(&m_wicFactory)
            )
        );
}

void Renderer::CreateDeviceResources ( ) [private]

Definition at line 72 of file Renderer.cpp.

{
    // This flag adds support for surfaces with a different color channel ordering than the API default.
    // It is recommended usage, and is required for compatibility with Direct2D.
    UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;

#if defined(_DEBUG)
    // If the project is in a debug build, enable debugging via SDK Layers with this flag.
    creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
#endif

    // This array defines the set of DirectX hardware feature levels this app will support.
    // Note the ordering should be preserved.
    D3D_FEATURE_LEVEL featureLevels[] =
    {
        D3D_FEATURE_LEVEL_11_1,
        D3D_FEATURE_LEVEL_11_0,
        D3D_FEATURE_LEVEL_10_1,
        D3D_FEATURE_LEVEL_10_0,
        D3D_FEATURE_LEVEL_9_3,
        D3D_FEATURE_LEVEL_9_2,
        D3D_FEATURE_LEVEL_9_1
    };

    // Create the D3D11 API device object, and get a corresponding context.
    ComPtr<ID3D11Device> d3dDevice;
    ComPtr<ID3D11DeviceContext> d3dContext;
    DX::ThrowIfFailed(
        D3D11CreateDevice(
            nullptr,                    // specify null to use the default adapter
            D3D_DRIVER_TYPE_HARDWARE,
            0,                          // leave as 0 unless software device
            creationFlags,              // optionally set debug and Direct2D compatibility flags
            featureLevels,              // list of feature levels this app can support
            ARRAYSIZE(featureLevels),   // number of entries in above list
            D3D11_SDK_VERSION,          // always set this to D3D11_SDK_VERSION for Metro style apps
            &d3dDevice,                 // returns the Direct3D device created
            &m_featureLevel,            // returns feature level of device created
            &d3dContext                 // returns the device immediate context
            )
        );

    // Obtain the underlying DXGI device of the Direct3D11.1 device.
    DX::ThrowIfFailed(
        d3dDevice.As(&m_dxgiDevice)
        );

    // Obtain the Direct2D device for 2-D rendering.
    DX::ThrowIfFailed(
        m_d2dFactory->CreateDevice(m_dxgiDevice.Get(), &m_d2dDevice)
        );

    // And get its corresponding device context object.
    DX::ThrowIfFailed(
        m_d2dDevice->CreateDeviceContext(
            D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
            &m_d2dDeviceContext
            )
        );

    // Since this device context will be used to draw content onto XAML surface image source,
    // it needs to operate as pixels. Setting pixel unit mode is a way to tell Direct2D to treat
    // the incoming coordinates and vectors, typically as DIPs, as in pixels.
    m_d2dDeviceContext->SetUnitMode(D2D1_UNIT_MODE_PIXELS);

    // Despite treating incoming values as pixels, it is still very important to tell Direct2D
    // the logical DPI the application operates on. Direct2D uses the DPI value as a hint to
    // optimize internal rendering policy such as to determine when is appropriate to enable
    // symmetric text rendering modes. Not specifying the appropriate DPI in this case will hurt
    // application performance.
    m_d2dDeviceContext->SetDpi(m_dpi, m_dpi);

    // When an application performs animation or image composition of graphics content, it is important
    // to use Direct2D grayscale text rendering mode rather than ClearType. The ClearType technique
    // operates on the color channels and not the alpha channel, and therefore unable to correctly perform
    // image composition or sub-pixel animation of text. ClearType is still a method of choice when it
    // comes to direct rendering of text to the destination surface with no subsequent composition required.
    m_d2dDeviceContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
}

void Renderer::GetD2DDeviceContext ( _Outptr_ ID2D1DeviceContext ** d2dDeviceContext )

Definition at line 168 of file Renderer.cpp.

{
    *d2dDeviceContext = ComPtr<ID2D1DeviceContext>(m_d2dDeviceContext).Detach();
}

float Renderer::GetDisplayHeight ( ) [inline]

Definition at line 49 of file Renderer.h.

    {
        return m_windowBounds.Height;
    }

D2D1_SIZE_F Renderer::GetDisplaySize ( ) [inline]

Definition at line 54 of file Renderer.h.

    {
        return D2D1::SizeF(GetDisplayWidth(), GetDisplayHeight());
    }

float Renderer::GetDisplayWidth ( ) [inline]

Definition at line 44 of file Renderer.h.

    {
        return m_windowBounds.Width;
    }

void Renderer::GetDXGIDevice ( _Outptr_ IDXGIDevice ** dxgiDevice )

Definition at line 173 of file Renderer.cpp.

{
    *dxgiDevice = ComPtr<IDXGIDevice>(m_dxgiDevice).Detach();
}

void Renderer::GetWICImagingFactory ( _Outptr_ IWICImagingFactory2 ** wicFactory )

Definition at line 178 of file Renderer.cpp.

{
    *wicFactory = ComPtr<IWICImagingFactory2>(m_wicFactory).Detach();
}

void Renderer::HandleDeviceLost ( )

Definition at line 33 of file Renderer.cpp.

{
    CreateDeviceResources();
    DeviceLost();
}

bool Renderer::IsOrientationLandscape ( ) [inline]

Definition at line 59 of file Renderer.h.

    {
        return GetDisplayWidth() >= GetDisplayHeight();
    }

void Renderer::SetDpi ( float dpi )

Definition at line 153 of file Renderer.cpp.

{
    if (dpi != m_dpi)
    {
        m_dpi = dpi;

        m_d2dDeviceContext->SetDpi(m_dpi, m_dpi);
    }
}

void Renderer::UpdateWindowSize ( )

Definition at line 163 of file Renderer.cpp.

{
    m_windowBounds = Window::Current->Bounds;
}

Member Data Documentation

internal Renderer::__pad0__

Definition at line 26 of file Renderer.h.

event DeviceLostEventHandler Renderer::DeviceLost

Definition at line 30 of file Renderer.h.

internal float Renderer::dpi

Definition at line 26 of file Renderer.h.

Microsoft::WRL::ComPtr<ID2D1Device> Renderer::m_d2dDevice [private]

Definition at line 70 of file Renderer.h.

Microsoft::WRL::ComPtr<ID2D1DeviceContext> Renderer::m_d2dDeviceContext [private]

Definition at line 71 of file Renderer.h.

Microsoft::WRL::ComPtr<ID2D1Factory1> Renderer::m_d2dFactory [private]

Definition at line 69 of file Renderer.h.

float Renderer::m_dpi [private]

Definition at line 85 of file Renderer.h.

Microsoft::WRL::ComPtr<IDXGIDevice> Renderer::m_dxgiDevice [private]

Definition at line 77 of file Renderer.h.

D3D_FEATURE_LEVEL Renderer::m_featureLevel [private]

Definition at line 80 of file Renderer.h.

Microsoft::WRL::ComPtr<IWICImagingFactory2> Renderer::m_wicFactory [private]

Definition at line 74 of file Renderer.h.

Windows::Foundation::Rect Renderer::m_windowBounds [private]

Definition at line 83 of file Renderer.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/Renderer.h
  • Direct2D magazine app/C++/Renderer.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Resource Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Resource Class Reference

#include "Resource.h"

Inherits Element.

Inherited by Image, and Text.

List of all members.

Public Member Functions

virtual bool | Draw (_In_ Document^document, D2D1::Matrix3x2F const &transform) override
virtual void | Measure (_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override
virtual bool | PrepareToDraw (_In_ Document^document, D2D1::Matrix3x2F const &transform) override

Public Attributes

internal | __pad0__: virtual bool AcceptChildNode( _In_ Document^ document
internal _In_
Windows::Data::Xml::Dom::IXmlNode
childXmlNode 		override

Detailed Description

Definition at line 17 of file Resource.h.

Member Function Documentation

bool Resource::Draw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 66 of file Resource.cpp.

{
    // Resource doesn't draw.
    return false;
}

void Resource::Measure | ( | _In_ Document^ | document,
 |  | D2D1_SIZE_F const & | parentSize,
 |  | _Out_ D2D1_RECT_F * | bounds |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 47 of file Resource.cpp.

{
    // Resource has no bounds of its own.
    *bounds = D2D1::RectF();
}

bool Resource::PrepareToDraw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 57 of file Resource.cpp.

{
    // Resource doesn't draw.
    return false;
}

Member Data Documentation

internal Resource::__pad0__

Reimplemented from Element.

Reimplemented in Image, and Text.

Definition at line 21 of file Resource.h.

internal _In_ Windows::Data::Xml::Dom::IXmlNode childXmlNode Resource::override

Definition at line 21 of file Resource.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/Resource.h
  • Direct2D magazine app/C++/Resource.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ResourceLoading Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

ResourceLoading Class Reference

#include "ResourceLoading.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
void | LoadInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
virtual void | Render () override
void | SaveInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | Update (float timeTotal, float timeDelta)

Public Attributes

internal | __pad0__: ResourceLoading()

Private Attributes

BasicCamera m_camera
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
LonLatController m_controller
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
uint32 | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
bool | m_loadingComplete
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureSRV
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 24 of file ResourceLoading.h.

Member Function Documentation

void ResourceLoading::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 22 of file ResourceLoading.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    m_camera = ref new BasicCamera();

    m_controller = ref new LonLatController();
    m_controller->Initialize(m_window.Get());
    m_controller->SetPosition(float3(0.7f, 0.7f, 0.7f));
}

void ResourceLoading::CreateDeviceResources ( ) [override, virtual]

Definition at line 33 of file ResourceLoading.cpp.

{
    DirectXBase::CreateDeviceResources();

    // Create the SampleOverlay, which synchronously loads its required resources.
    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct3D resource loading sample"
        );

    // This flag will keep track of whether or not all application
    // resources have been loaded.  Until all resources are loaded,
    // only the sample overlay will be drawn on the screen.
    m_loadingComplete = false;

    // Create a BasicLoader, and use it to asynchronously load all
    // application resources.  When an output value becomes non-null,
    // this indicates that the asynchronous operation has completed.
    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    auto loadVertexShaderTask = loader->LoadShaderAsync(
        "SimpleVertexShader.cso",
        nullptr,
        0,
        &m_vertexShader,
        &m_inputLayout
        );

    auto loadPixelShaderTask = loader->LoadShaderAsync(
        "SimplePixelShader.cso",
        &m_pixelShader
        );

    auto loadTextureTask = loader->LoadTextureAsync(
        "reftexture.dds",
        nullptr,
        &m_textureSRV
        );

    auto loadMeshTask = loader->LoadMeshAsync(
        "refmesh.vbo",
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // The && operator can be used to create a single task that represents
    // a group of multiple tasks. The new task's completed handler will only
    // be called once all associated tasks have completed. In this case, the
    // new task represents a task to load various assets from the package.
    (loadVertexShaderTask && loadPixelShaderTask && loadTextureTask && loadMeshTask).then([=]()
    {
        m_loadingComplete = true;
    });

    CD3D11_BUFFER_DESC constantBufferDesc(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &constantBufferDesc,
            nullptr,
            &m_constantBuffer
            )
        );

    CD3D11_SAMPLER_DESC samplerDesc(
        D3D11_FILTER_ANISOTROPIC,
        D3D11_TEXTURE_ADDRESS_WRAP,
        D3D11_TEXTURE_ADDRESS_WRAP,
        D3D11_TEXTURE_ADDRESS_WRAP,
        0.0f,
        m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2,
        D3D11_COMPARISON_NEVER,
        nullptr,
        0,
        D3D11_FLOAT32_MAX
        );
    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDesc,
            &m_sampler
            )
        );

    m_constantBufferData.model = identity();
}

void ResourceLoading::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 125 of file ResourceLoading.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    m_camera->SetProjectionParameters(
        70.0f,
        m_renderTargetSize.Width / m_renderTargetSize.Height,
        0.01f,
        100.0f
        );

    m_camera->GetProjectionMatrix(&m_constantBufferData.projection);

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void ResourceLoading::LoadInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state )
void ResourceLoading::Render ( ) [override, virtual]

Definition at line 154 of file ResourceLoading.cpp.

{
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    const float clearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        clearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    // Only render objects if all required resources have been loaded.
    if (m_loadingComplete)
    {
        m_d3dContext->UpdateSubresource(
            m_constantBuffer.Get(),
            0,
            nullptr,
            &m_constantBufferData,
            0,
            0
            );

        UINT stride = sizeof(BasicVertex);
        UINT offset = 0;
        m_d3dContext->IASetVertexBuffers(
            0,
            1,
            m_vertexBuffer.GetAddressOf(),
            &stride,
            &offset
            );

        m_d3dContext->IASetIndexBuffer(
            m_indexBuffer.Get(),
            DXGI_FORMAT_R16_UINT,
            0
            );

        m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

        m_d3dContext->IASetInputLayout(m_inputLayout.Get());

        m_d3dContext->VSSetShader(
            m_vertexShader.Get(),
            nullptr,
            0
            );

        m_d3dContext->VSSetConstantBuffers(
            0,
            1,
            m_constantBuffer.GetAddressOf()
            );

        m_d3dContext->PSSetShader(
            m_pixelShader.Get(),
            nullptr,
            0
            );

        m_d3dContext->PSSetShaderResources(
            0,
            1,
            m_textureSRV.GetAddressOf()
            );

        m_d3dContext->PSSetSamplers(
            0,
            1,
            m_sampler.GetAddressOf()
            );

        m_d3dContext->DrawIndexed(
            m_indexCount,
            0,
            0
            );
    }

    m_sampleOverlay->Render();
}

void ResourceLoading::SaveInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state )
void ResourceLoading::Update | ( | float | timeTotal,
 |  | float | timeDelta
 | ) |  |

Definition at line 141 of file ResourceLoading.cpp.

{
    m_controller->Update();

    m_camera->SetViewParameters(
        m_controller->get_Position(),
        m_controller->get_LookPoint(),
        float3(0, 1, 0)
        );

    m_camera->GetViewMatrix(&m_constantBufferData.view);
}

Member Data Documentation

internal ResourceLoading::__pad0__

Definition at line 27 of file ResourceLoading.h.

BasicCamera ResourceLoading::m_camera [private]

Definition at line 51 of file ResourceLoading.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> ResourceLoading::m_constantBuffer [private]

Definition at line 47 of file ResourceLoading.h.

ConstantBuffer ResourceLoading::m_constantBufferData [private]

Definition at line 50 of file ResourceLoading.h.

LonLatController ResourceLoading::m_controller [private]

Definition at line 52 of file ResourceLoading.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> ResourceLoading::m_indexBuffer [private]

Definition at line 42 of file ResourceLoading.h.

uint32 ResourceLoading::m_indexCount [private]

Definition at line 49 of file ResourceLoading.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> ResourceLoading::m_inputLayout [private]

Definition at line 40 of file ResourceLoading.h.

bool ResourceLoading::m_loadingComplete [private]

Definition at line 54 of file ResourceLoading.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> ResourceLoading::m_pixelShader [private]

Definition at line 44 of file ResourceLoading.h.

SampleOverlay ResourceLoading::m_sampleOverlay [private]

Definition at line 38 of file ResourceLoading.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> ResourceLoading::m_sampler [private]

Definition at line 46 of file ResourceLoading.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> ResourceLoading::m_textureSRV [private]

Definition at line 45 of file ResourceLoading.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> ResourceLoading::m_vertexBuffer [private]

Definition at line 41 of file ResourceLoading.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> ResourceLoading::m_vertexShader [private]

Definition at line 43 of file ResourceLoading.h.

The documentation for this class was generated from the following files:
  • Direct3D resource loading/C++/ResourceLoading.h
  • Direct3D resource loading/C++/ResourceLoading.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: RippleEffect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Private Member Functions | Static Private Member Functions | Private Attributes

RippleEffect Class Reference

#include "RippleEffect.h"

List of all members.

Public Member Functions

float | GetAmplitude () const
D2D1_POINT_2F | GetCenter () const
float | GetFrequency () const
float | GetPhase () const
float | GetSpread () const
IFACEMETHODIMP_ (UINT32) GetInputCount() const
IFACEMETHODIMP_ (ULONG) AddRef()
IFACEMETHODIMP_ (ULONG) Release()
IFACEMETHODIMP | Initialize (_In_ ID2D1EffectContext *pContextInternal, _In_ ID2D1TransformGraph *pTransformGraph)
IFACEMETHODIMP | MapInputRectsToOutputRect (_In_reads_(inputRectCount) CONST D2D1_RECT_L *pInputRects, _In_reads_(inputRectCount) CONST D2D1_RECT_L *pInputOpaqueSubRects, UINT32 inputRectCount, _Out_ D2D1_RECT_L *pOutputRect, _Out_ D2D1_RECT_L *pOutputOpaqueSubRect)
IFACEMETHODIMP | MapInvalidRect (UINT32 inputIndex, D2D1_RECT_L invalidInputRect, _Out_ D2D1_RECT_L *pInvalidOutputRect) const
IFACEMETHODIMP | MapOutputRectToInputRects (_In_ const D2D1_RECT_L *pOutputRect, _Out_writes_(inputRectCount) D2D1_RECT_L *pInputRects, UINT32 inputRectCount) const
IFACEMETHODIMP | PrepareForRender (D2D1_CHANGE_TYPE changeType)
IFACEMETHODIMP | QueryInterface (_In_ REFIID riid, _Outptr_ void **ppOutput)
HRESULT | SetAmplitude (float amplitude)
HRESULT | SetCenter (D2D1_POINT_2F center)
IFACEMETHODIMP | SetDrawInfo (_In_ ID2D1DrawInfo *pRenderInfo)
HRESULT | SetFrequency (float frequency)
IFACEMETHODIMP | SetGraph (_In_ ID2D1TransformGraph *pGraph)
HRESULT | SetPhase (float phase)
HRESULT | SetSpread (float spread)

Static Public Member Functions

static HRESULT __stdcall | CreateRippleImpl (_Outptr_ IUnknown **ppEffectImpl)
static HRESULT | Register (_In_ ID2D1Factory1 *pFactory)

Private Member Functions

RippleEffect ()
HRESULT | UpdateConstants ()

Static Private Member Functions

static float | Clamp (float v, float low, float high)
static float | Round (float v)
static long | SafeAdd (long base, long valueToAdd)

Private Attributes

struct {
float amplitude
D2D1_POINT_2F center
float dpi
float frequency
float phase
float spread
} m_constants
float | m_dpi
Microsoft::WRL::ComPtr
< ID2D1DrawInfo > 		m_drawInfo
Microsoft::WRL::ComPtr
< ID2D1EffectContext > 		m_effectContext
D2D1_RECT_L | m_inputRect
LONG | m_refCount

Detailed Description

Definition at line 22 of file RippleEffect.h.

Constructor & Destructor Documentation

RippleEffect::RippleEffect ( ) [private]

Definition at line 15 of file RippleEffect.cpp.

                           :
    m_refCount(1)
{
    m_constants.amplitude = 0;
    m_constants.center = D2D1::Point2F(0, 0);
    m_constants.frequency = 0;
    m_constants.phase = 0;
    m_constants.spread = 0;
}

Member Function Documentation

static float RippleEffect::Clamp | ( | float | v,
 |  | float | low,
 |  | float | high |
 | ) |  |  | [inline, static, private]

Definition at line 92 of file RippleEffect.h.

    {
        return (v < low) ? low : (v > high) ? high : v;
    }

HRESULT __stdcall RippleEffect::CreateRippleImpl ( _Outptr_ IUnknown ** ppEffectImpl ) [static]

Definition at line 25 of file RippleEffect.cpp.

{
    // Since the object's refcount is initialized to 1, we don't need to AddRef here.
    *ppEffectImpl = static_cast<ID2D1EffectImpl*>(new (std::nothrow) RippleEffect());

    if (*ppEffectImpl == nullptr)
    {
        return E_OUTOFMEMORY;
    }
    else
    {
        return S_OK;
    }
}

float RippleEffect::GetAmplitude ( ) const

Definition at line 192 of file RippleEffect.cpp.

{
    return m_constants.amplitude;
}

D2D1_POINT_2F RippleEffect::GetCenter ( ) const

Definition at line 204 of file RippleEffect.cpp.

{
    return m_constants.center;
}

float RippleEffect::GetFrequency ( ) const

Definition at line 156 of file RippleEffect.cpp.

{
    return m_constants.frequency;
}

float RippleEffect::GetPhase ( ) const

Definition at line 168 of file RippleEffect.cpp.

{
    return m_constants.phase;
}

float RippleEffect::GetSpread ( ) const

Definition at line 180 of file RippleEffect.cpp.

{
    return m_constants.spread;
}

RippleEffect::IFACEMETHODIMP_ ( UINT32 ) const
RippleEffect::IFACEMETHODIMP_ ( ULONG )
RippleEffect::IFACEMETHODIMP_ ( ULONG )
IFACEMETHODIMP RippleEffect::Initialize | ( | _In_ ID2D1EffectContext * | pContextInternal,
 |  | _In_ ID2D1TransformGraph * | pTransformGraph
 | ) |  |

Definition at line 110 of file RippleEffect.cpp.

{
    // To maintain consistency across different DPIs, this effect needs to cover more pixels at
    // higher than normal DPIs. The context is saved here so the effect can later retrieve the DPI.
    m_effectContext = pEffectContext;

    BasicReaderWriter^ reader = ref new BasicReaderWriter();
    Platform::Array<unsigned char, 1U>^ data;

    try
    {
        data = reader->ReadData("RippleEffect.cso");
    }
    catch (Platform::Exception^ e)
    {
        // Return error if file can not be read.
        return e->HResult;
    }

    HRESULT hr = pEffectContext->LoadPixelShader(GUID_RipplePixelShader, data->Data, data->Length);

    // This loads the shader into the Direct2D image effects system and associates it with the GUID passed in.
    // If this method is called more than once (say by other instances of the effect) with the same GUID,
    // the system will simply do nothing, ensuring that only one instance of a shader is stored regardless of how
    // many time it is used.
    if (SUCCEEDED(hr))
    {
        // The graph consists of a single transform. In fact, this class is the transform,
        // reducing the complexity of implementing an effect when all we need to
        // do is use a single pixel shader.
        hr = pTransformGraph->SetSingleTransformNode(this);
    }

    return hr;
}

IFACEMETHODIMP RippleEffect::MapInputRectsToOutputRect | ( | _In_reads_(inputRectCount) CONST D2D1_RECT_L * | pInputRects,
 |  | _In_reads_(inputRectCount) CONST D2D1_RECT_L * | pInputOpaqueSubRects,
 |  | UINT32 | inputRectCount,
 |  | _Out_ D2D1_RECT_L * | pOutputRect,
 |  | _Out_ D2D1_RECT_L * | pOutputOpaqueSubRect
 | ) |  |

Definition at line 267 of file RippleEffect.cpp.

{
    // This effect has exactly one input, so if there is more than one input rect,
    // something is wrong.
    if (inputRectCount != 1)
    {
        return E_INVALIDARG;
    }

    *pOutputRect = pInputRects[0];
    m_inputRect = pInputRects[0];

    // Indicate that entire output might contain transparency.
    ZeroMemory(pOutputOpaqueSubRect, sizeof(*pOutputOpaqueSubRect));

    return S_OK;
}

IFACEMETHODIMP RippleEffect::MapInvalidRect | ( | UINT32 | inputIndex,
 |  | D2D1_RECT_L | invalidInputRect,
 |  | _Out_ D2D1_RECT_L * | pInvalidOutputRect |
 | ) |  |  | const

Definition at line 291 of file RippleEffect.cpp.

{
    HRESULT hr = S_OK;

    // Indicate that the entire output may be invalid.
    *pInvalidOutputRect = m_inputRect;

    return hr;
}

IFACEMETHODIMP RippleEffect::MapOutputRectToInputRects | ( | _In_ const D2D1_RECT_L * | pOutputRect,
 |  | _Out_writes_(inputRectCount) D2D1_RECT_L * | pInputRects,
 |  | UINT32 | inputRectCount |
 | ) |  |  | const

Definition at line 242 of file RippleEffect.cpp.

{
    // This effect has exactly one input, so if there is more than one input rect,
    // something is wrong.
    if (inputRectCount != 1)
    {
        return E_INVALIDARG;
    }

    long expansion = static_cast<long>(Round(m_constants.amplitude));

    // Expand the rect out by the amplitude of the ripple animation. SafeAdd
    // is a helper function that prevents long over/underflows.
    pInputRects[0].left    = SafeAdd(pOutputRect->left, -expansion);
    pInputRects[0].top     = SafeAdd(pOutputRect->top, -expansion);
    pInputRects[0].right   = SafeAdd(pOutputRect->right, expansion);
    pInputRects[0].bottom  = SafeAdd(pOutputRect->bottom, expansion);

    return S_OK;
}

IFACEMETHODIMP RippleEffect::PrepareForRender ( D2D1_CHANGE_TYPE changeType )

Definition at line 218 of file RippleEffect.cpp.

{
    return UpdateConstants();
}

IFACEMETHODIMP RippleEffect::QueryInterface | ( | _In_ REFIID | riid,
 |  | _Outptr_ void ** | ppOutput
 | ) |  |

Definition at line 337 of file RippleEffect.cpp.

{
    *ppOutput = nullptr;
    HRESULT hr = S_OK;

    if (riid == __uuidof(ID2D1EffectImpl))
    {
        *ppOutput = reinterpret_cast<ID2D1EffectImpl*>(this);
    }
    else if (riid == __uuidof(ID2D1DrawTransform))
    {
        *ppOutput = static_cast<ID2D1DrawTransform*>(this);
    }
    else if (riid == __uuidof(ID2D1Transform))
    {
        *ppOutput = static_cast<ID2D1Transform*>(this);
    }
    else if (riid == __uuidof(ID2D1TransformNode))
    {
        *ppOutput = static_cast<ID2D1TransformNode*>(this);
    }
    else if (riid == __uuidof(IUnknown))
    {
        *ppOutput = this;
    }
    else
    {
        hr = E_NOINTERFACE;
    }

    if (*ppOutput != nullptr)
    {
        AddRef();
    }

    return hr;
}

HRESULT RippleEffect::Register ( _In_ ID2D1Factory1 * pFactory ) [static]

Definition at line 40 of file RippleEffect.cpp.

{
    // The inspectable metadata of an effect is defined in XML. This can be passed in from an external source
    // as well, however for simplicity we just inline the XML.
    PCWSTR pszXml =
        XML(
            <?xml version='1.0'?>
            <Effect>
                <!-- System Properties -->
                <Property name='DisplayName' type='string' value='Ripple'/>
                <Property name='Author' type='string' value='Microsoft Corporation'/>
                <Property name='Category' type='string' value='Stylize'/>
                <Property name='Description' type='string' value='Adds a ripple effect that can be animated'/>
                <Inputs>
                    <Input name='Source'/>
                </Inputs>
                <!-- Custom Properties go here -->
                <Property name='Frequency' type='float'>
                    <Property name='DisplayName' type='string' value='Frequency'/>
                    <Property name='Min' type='float' value='0.0' />
                    <Property name='Max' type='float' value='1000.0' />
                    <Property name='Default' type='float' value='0.0' />
                </Property>
                <Property name='Phase' type='float'>
                    <Property name='DisplayName' type='string' value='Phase'/>
                    <Property name='Min' type='float' value='-100.0' />
                    <Property name='Max' type='float' value='100.0' />
                    <Property name='Default' type='float' value='0.0' />
                </Property>
                <Property name='Amplitude' type='float'>
                    <Property name='DisplayName' type='string' value='Amplitude'/>
                    <Property name='Min' type='float' value='0.0001' />
                    <Property name='Max' type='float' value='1000.0' />
                    <Property name='Default' type='float' value='0.0' />
                </Property>
                <Property name='Spread' type='float'>
                    <Property name='DisplayName' type='string' value='Spread'/>
                    <Property name='Min' type='float' value='0.0001' />
                    <Property name='Max' type='float' value='1000.0' />
                    <Property name='Default' type='float' value='0.0' />
                </Property>
                <Property name='Center' type='vector2'>
                    <Property name='DisplayName' type='string' value='Center'/>
                    <Property name='Default' type='vector2' value='(0.0, 0.0)' />
                </Property>
            </Effect>
            );

    // This defines the bindings from specific properties to the callback functions
    // on the class that ID2D1Effect::SetValue() & GetValue() will call.
    const D2D1_PROPERTY_BINDING bindings[] =
    {
        D2D1_VALUE_TYPE_BINDING(L"Frequency", &SetFrequency, &GetFrequency),
        D2D1_VALUE_TYPE_BINDING(L"Phase", &SetPhase, &GetPhase),
        D2D1_VALUE_TYPE_BINDING(L"Amplitude", &SetAmplitude, &GetAmplitude),
        D2D1_VALUE_TYPE_BINDING(L"Spread", &SetSpread, &GetSpread),
        D2D1_VALUE_TYPE_BINDING(L"Center", &SetCenter, &GetCenter),
    };

    // This registers the effect with the factory, which will make the effect
    // instantiatable.
    return pFactory->RegisterEffectFromString(
        CLSID_CustomRippleEffect,
        pszXml,
        bindings,
        ARRAYSIZE(bindings),
        CreateRippleImpl
        );
}

static float RippleEffect::Round ( float v ) [inline, static, private]

Definition at line 97 of file RippleEffect.h.

    {
        return floor(v + 0.5f);
    }

static long RippleEffect::SafeAdd | ( | long | base,
 |  | long | valueToAdd |
 | ) |  |  | [inline, static, private]

Definition at line 103 of file RippleEffect.h.

    {
        if (valueToAdd >= 0)
        {
            return ((base + valueToAdd) >= base) ? (base + valueToAdd) : LONG_MAX;
        }
        else
        {
            return ((base + valueToAdd) <= base) ? (base + valueToAdd) : LONG_MIN;
        }
    }

HRESULT RippleEffect::SetAmplitude ( float amplitude )

Definition at line 173 of file RippleEffect.cpp.

{
    // Limit to the published possible values in the XML.
    m_constants.amplitude = Clamp(amplitude, 0.0001f, 1000.0f);
    return S_OK;
}

HRESULT RippleEffect::SetCenter ( D2D1_POINT_2F center )

Definition at line 197 of file RippleEffect.cpp.

{
    // The valid range is all possible point positions, so no clamping is needed.
    m_constants.center = center;
    return S_OK;
}

IFACEMETHODIMP RippleEffect::SetDrawInfo ( _In_ ID2D1DrawInfo * pRenderInfo )

Definition at line 232 of file RippleEffect.cpp.

{
    m_drawInfo = pDrawInfo;

    return m_drawInfo->SetPixelShader(GUID_RipplePixelShader);
}

HRESULT RippleEffect::SetFrequency ( float frequency )

Definition at line 149 of file RippleEffect.cpp.

{
    // Limit to the published possible values in the XML.
    m_constants.frequency = Clamp(frequency, 0.0f, 1000.0f);
    return S_OK;
}

IFACEMETHODIMP RippleEffect::SetGraph ( _In_ ID2D1TransformGraph * pGraph )

Definition at line 225 of file RippleEffect.cpp.

{
    return E_NOTIMPL;
}

HRESULT RippleEffect::SetPhase ( float phase )

Definition at line 161 of file RippleEffect.cpp.

{
    // Limit to the published possible values in the XML.
    m_constants.phase = Clamp(phase, -100.0f, 100.0f);
    return S_OK;
}

HRESULT RippleEffect::SetSpread ( float spread )

Definition at line 185 of file RippleEffect.cpp.

{
    // Limit to the published possible values in the XML.
    m_constants.spread = Clamp(spread, 0.0001f, 1000.0f);
    return S_OK;
}

HRESULT RippleEffect::UpdateConstants ( ) [private]

Definition at line 209 of file RippleEffect.cpp.

{
    // Update the DPI if it has changed. This allows the effect to scale across different DPIs automatically.
    m_effectContext->GetDpi(&m_dpi, &m_dpi);
    m_constants.dpi = m_dpi;

    return m_drawInfo->SetPixelShaderConstantBuffer(reinterpret_cast<BYTE*>(&m_constants), sizeof(m_constants));
}

Member Data Documentation

float RippleEffect::amplitude

Definition at line 120 of file RippleEffect.h.

D2D1_POINT_2F RippleEffect::center

Definition at line 122 of file RippleEffect.h.

float RippleEffect::dpi

Definition at line 123 of file RippleEffect.h.

float RippleEffect::frequency

Definition at line 118 of file RippleEffect.h.

struct { ... } RippleEffect::m_constants [private]
float RippleEffect::m_dpi [private]

Definition at line 130 of file RippleEffect.h.

Microsoft::WRL::ComPtr<ID2D1DrawInfo> RippleEffect::m_drawInfo [private]

Definition at line 126 of file RippleEffect.h.

Microsoft::WRL::ComPtr<ID2D1EffectContext> RippleEffect::m_effectContext [private]

Definition at line 127 of file RippleEffect.h.

D2D1_RECT_L RippleEffect::m_inputRect [private]

Definition at line 129 of file RippleEffect.h.

LONG RippleEffect::m_refCount [private]

Definition at line 128 of file RippleEffect.h.

float RippleEffect::phase

Definition at line 119 of file RippleEffect.h.

float RippleEffect::spread

Definition at line 121 of file RippleEffect.h.

The documentation for this class was generated from the following files:
  • Direct2D custom image effects/C++/PixelShader/RippleEffect.h
  • Direct2D custom image effects/C++/PixelShader/RippleEffect.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SampleOverlay Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

SampleOverlay Class Reference

#include "SampleOverlay.h"

List of all members.

Public Member Functions

float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
float | GetTitleHeightInDips ()
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption)
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render (D2D1::Matrix3x2F &transform)
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | Render ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | ResetDirectXResources ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()
void | UpdateForWindowSizeChange ()

Public Attributes

internal | __pad0__: SampleOverlay()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
Microsoft::WRL::ComPtr
< ID2D1Device > 		m_d2dDevice
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
bool | m_drawOverlay
Microsoft::WRL::ComPtr
< IDWriteFactory > 		m_dwriteFactory
UINT | m_idIncrement
Microsoft::WRL::ComPtr
< ID2D1Bitmap > 		m_logoBitmap
D2D1_SIZE_F | m_logoSize
float | m_overlayWidth
float | m_padding
Platform::String | m_sampleName
Microsoft::WRL::ComPtr
< ID2D1DrawingStateBlock > 		m_stateBlock
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
float | m_textVerticalOffset
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush
Microsoft::WRL::ComPtr
< IWICImagingFactory > 		m_wicFactory

Detailed Description

Definition at line 14 of file SampleOverlay.h.

Member Function Documentation

float SampleOverlay::GetTitleHeightInDips ( )

Definition at line 199 of file SampleOverlay.cpp.

{
    return m_logoSize.height;
}

float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
float SampleOverlay::GetTitleHeightInDips ( )
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |

Definition at line 23 of file SampleOverlay.cpp.

{
    m_wicFactory = wicFactory;
    m_dwriteFactory = dwriteFactory;
    m_sampleName = caption;
    m_d2dDevice = d2dDevice;
    m_d2dContext = d2dContext;
    m_padding = 3.0f;
    m_textVerticalOffset = 5.0f;
    m_logoSize = D2D1::SizeF(0.0f, 0.0f);
    m_overlayWidth = 0.0f;

    ComPtr<ID2D1Factory> factory;
    d2dDevice->GetFactory(&factory);

    DX::ThrowIfFailed(
        factory.As(&m_d2dFactory)
        );

    ResetDirectXResources();
}

void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory,
 |  | _In_ Platform::String^ | caption
 | ) |  |
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )

Definition at line 168 of file SampleOverlay.cpp.

{
    if (m_drawOverlay)
    {
        m_d2dContext->SaveDrawingState(m_stateBlock.Get());

        m_d2dContext->BeginDraw();
        m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
        m_d2dContext->DrawBitmap(
            m_logoBitmap.Get(),
            D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
            );

        m_d2dContext->DrawTextLayout(
            Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
            m_textLayout.Get(),
            m_whiteBrush.Get()
            );

        // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
        // is lost. It will be handled during the next call to Present.
        HRESULT hr = m_d2dContext->EndDraw();
        if (hr != D2DERR_RECREATE_TARGET)
        {
            DX::ThrowIfFailed(hr);
        }

        m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
    }
}

void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( D2D1::Matrix3x2F & transform )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::Render ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )

Definition at line 51 of file SampleOverlay.cpp.

{
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
        );

    ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
    DX::ThrowIfFailed(
        m_wicFactory->CreateDecoderFromFilename(
            L"windowsbig-sdk.png",
            nullptr,
            GENERIC_READ,
            WICDecodeMetadataCacheOnDemand,
            &wicBitmapDecoder
            )
        );

    ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
    DX::ThrowIfFailed(
        wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
        );

    ComPtr<IWICFormatConverter> wicFormatConverter;
    DX::ThrowIfFailed(
        m_wicFactory->CreateFormatConverter(&wicFormatConverter)
        );

    DX::ThrowIfFailed(
        wicFormatConverter->Initialize(
            wicBitmapFrame.Get(),
            GUID_WICPixelFormat32bppPBGRA,
            WICBitmapDitherTypeNone,
            nullptr,
            0.0,
            WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
            )
        );

    double dpiX = 96.0f;
    double dpiY = 96.0f;
    DX::ThrowIfFailed(
        wicFormatConverter->GetResolution(&dpiX, &dpiY)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmapFromWicBitmap(
            wicFormatConverter.Get(),
            BitmapProperties(
                PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
                static_cast<float>(dpiX),
                static_cast<float>(dpiY)
                ),
            &m_logoBitmap
            )
        );

    m_logoSize = m_logoBitmap->GetSize();

    ComPtr<IDWriteTextFormat> nameTextFormat;
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            36.0f,
            L"en-US",
            &nameTextFormat
            )
        );

    DX::ThrowIfFailed(
        nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );

    DX::ThrowIfFailed(
        nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            m_sampleName->Data(),
            m_sampleName->Length(),
            nameTextFormat.Get(),
            4096.0f,
            4096.0f,
            &m_textLayout
            )
        );

    DWRITE_TEXT_METRICS metrics = {0};
    DX::ThrowIfFailed(
        m_textLayout->GetMetrics(&metrics)
        );

    m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;

    DX::ThrowIfFailed(
        m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
        );

    UpdateForWindowSizeChange();
}

void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::ResetDirectXResources ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )

Definition at line 156 of file SampleOverlay.cpp.

{
    if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
    {
        m_drawOverlay = false;
    }
    else
    {
        m_drawOverlay = true;
    }
}

void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )
void SampleOverlay::UpdateForWindowSizeChange ( )

Member Data Documentation

internal SampleOverlay::__pad0__

Definition at line 17 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< ID2D1DeviceContext > SampleOverlay::m_d2dContext [private]

Definition at line 39 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< ID2D1Device > SampleOverlay::m_d2dDevice [private]

Definition at line 38 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< ID2D1Factory1 > SampleOverlay::m_d2dFactory [private]

Definition at line 37 of file SampleOverlay.h.

bool SampleOverlay::m_drawOverlay [private]

Definition at line 49 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< IDWriteFactory > SampleOverlay::m_dwriteFactory [private]

Definition at line 40 of file SampleOverlay.h.

UINT SampleOverlay::m_idIncrement [private]

Definition at line 48 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< ID2D1Bitmap > SampleOverlay::m_logoBitmap [private]

Definition at line 45 of file SampleOverlay.h.

D2D1_SIZE_F SampleOverlay::m_logoSize [private]

Definition at line 53 of file SampleOverlay.h.

float SampleOverlay::m_overlayWidth [private]

Definition at line 54 of file SampleOverlay.h.

float SampleOverlay::m_padding [private]

Definition at line 51 of file SampleOverlay.h.

Platform::String SampleOverlay::m_sampleName [private]

Definition at line 50 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< ID2D1DrawingStateBlock > SampleOverlay::m_stateBlock [private]

Definition at line 42 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< IDWriteTextLayout > SampleOverlay::m_textLayout [private]

Definition at line 46 of file SampleOverlay.h.

float SampleOverlay::m_textVerticalOffset [private]

Definition at line 52 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > SampleOverlay::m_whiteBrush [private]

Definition at line 41 of file SampleOverlay.h.

Microsoft::WRL::ComPtr< IWICImagingFactory > SampleOverlay::m_wicFactory [private]

Definition at line 44 of file SampleOverlay.h.

The documentation for this class was generated from the following files:
  • Direct2D animated text/C++/SampleOverlay.h
  • Direct2D animation/C++/SampleOverlay.h
  • Direct2D basic image effects/C++/SampleOverlay.h
  • Direct2D command list/C++/SampleOverlay.h
  • Direct2D composite effect modes/C++/SampleOverlay.h
  • Direct2D convolve matrix effect/C++/SampleOverlay.h
  • Direct2D custom image effects/C++/ComputeShader/SampleOverlay.h
  • Direct2D custom image effects/C++/PixelShader/SampleOverlay.h
  • Direct2D custom image effects/C++/VertexShader/SampleOverlay.h
  • Direct2D effects on primitives/C++/SampleOverlay.h
  • Direct2D geometry realization/C++/SampleOverlay.h
  • Direct2D interpolation modes/C++/SampleOverlay.h
  • Direct2D perspective transform/C++/SampleOverlay.h
  • Direct2D printing images and effects/C++/SampleOverlay.h
  • Direct2D save to image file/C++/SampleOverlay.h
  • Direct2Dapp printing/C++/SampleOverlay.h
  • Direct3D bump mapping/C++/SampleOverlay.h
  • Direct3D HLSL fractal generator/C++/SampleOverlay.h
  • Direct3D post-processing effects/C++/SampleOverlay.h
  • Direct3D resource loading/C++/SampleOverlay.h
  • Direct3D sprite/C++/SampleOverlay.h
  • Direct3D stereoscopic 3D/C++/SampleOverlay.h
  • Direct3D tutorial/C++/Lesson5.Components/SampleOverlay.h
  • Direct3D-Direct2D interop/C++/SampleOverlay.h
  • DirectWrite custom text renderer/C++/SampleOverlay.h
  • DirectWrite hello world/C++/SampleOverlay.h
  • DirectWrite hit testing/C++/SampleOverlay.h
  • DirectWrite inline object/C++/SampleOverlay.h
  • DirectWrite paragraph text/C++/SampleOverlay.h
  • DirectWrite vertical text/C++/SampleOverlay.h
  • DirectX marble maze game/C++/SampleOverlay.h
  • DirectX swap chain implementation/C++/SampleOverlay.h
  • DirectX touch input/C++/SampleOverlay.h
  • DXGI offer and reclaim resources/C++/SampleOverlay.h
  • DXGI swap chain rotation/C++/SampleOverlay.h
  • Input Touch hit testing/C++/SampleOverlay.h
  • XAudio2 audio file playback/C++/SampleOverlay.h
  • XAudio2 audio stream effect/C++/SampleOverlay.h
  • XInput audio controller playback/C++/SampleOverlay.h
  • XInput game controller/C++/SampleOverlay.h
  • Direct2D animated text/C++/SampleOverlay.cpp
  • Direct2D animation/C++/SampleOverlay.cpp
  • Direct2D basic image effects/C++/SampleOverlay.cpp
  • Direct2D command list/C++/SampleOverlay.cpp
  • Direct2D composite effect modes/C++/SampleOverlay.cpp
  • Direct2D convolve matrix effect/C++/SampleOverlay.cpp
  • Direct2D custom image effects/C++/PixelShader/SampleOverlay.cpp
  • Direct2D custom image effects/C++/VertexShader/SampleOverlay.cpp
  • Direct2D effects on primitives/C++/SampleOverlay.cpp
  • Direct2D geometry realization/C++/SampleOverlay.cpp
  • Direct2D interpolation modes/C++/SampleOverlay.cpp
  • Direct2D perspective transform/C++/SampleOverlay.cpp
  • Direct2D printing images and effects/C++/SampleOverlay.cpp
  • Direct2D save to image file/C++/SampleOverlay.cpp
  • Direct2Dapp printing/C++/SampleOverlay.cpp
  • Direct3D bump mapping/C++/SampleOverlay.cpp
  • Direct3D HLSL fractal generator/C++/SampleOverlay.cpp
  • Direct3D post-processing effects/C++/SampleOverlay.cpp
  • Direct3D resource loading/C++/SampleOverlay.cpp
  • Direct3D sprite/C++/SampleOverlay.cpp
  • Direct3D stereoscopic 3D/C++/SampleOverlay.cpp
  • Direct3D tutorial/C++/Lesson5.Components/SampleOverlay.cpp
  • Direct3D-Direct2D interop/C++/SampleOverlay.cpp
  • DirectWrite custom text renderer/C++/SampleOverlay.cpp
  • DirectWrite hello world/C++/SampleOverlay.cpp
  • DirectWrite hit testing/C++/SampleOverlay.cpp
  • DirectWrite inline object/C++/SampleOverlay.cpp
  • DirectWrite paragraph text/C++/SampleOverlay.cpp
  • DirectWrite vertical text/C++/SampleOverlay.cpp
  • DirectX marble maze game/C++/SampleOverlay.cpp
  • DirectX swap chain implementation/C++/SampleOverlay.cpp
  • DirectX touch input/C++/SampleOverlay.cpp
  • DXGI offer and reclaim resources/C++/SampleOverlay.cpp
  • DXGI swap chain rotation/C++/SampleOverlay.cpp
  • Input Touch hit testing/C++/SampleOverlay.cpp
  • XAudio2 audio file playback/C++/SampleOverlay.cpp
  • XAudio2 audio stream effect/C++/SampleOverlay.cpp
  • XInput audio controller playback/C++/SampleOverlay.cpp
  • XInput game controller/C++/SampleOverlay.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Samples::Devices::DeviceControlResult Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Samples
  • Devices
  • Samples::Devices::DeviceControlResult
Public Member Functions | Public Attributes

Samples::Devices::DeviceControlResult Struct Reference

#include "support.h"

List of all members.

Public Member Functions

DeviceControlResult ()
DeviceControlResult (HRESULT Hr, DWORD Cb)
DeviceControlResult ()
DeviceControlResult (HRESULT Hr, DWORD Cb)
DeviceControlResult ()
DeviceControlResult (HRESULT Hr, DWORD Cb)

Public Attributes

ULONG | BytesTransferred
HRESULT | Result

Detailed Description

Definition at line 29 of file support.h.

Constructor & Destructor Documentation

Samples::Devices::DeviceControlResult::DeviceControlResult ( ) [inline]

Definition at line 33 of file support.h.

                                  : Result(E_NOT_SET),
                                    BytesTransferred(0)
            {
                return;
            }

Samples::Devices::DeviceControlResult::DeviceControlResult | ( | HRESULT | Hr,
 |  | DWORD | Cb |
 | ) |  |  | [inline]

Definition at line 39 of file support.h.

                                                      : Result(Hr),
                                                        BytesTransferred(Cb)
            {
                return;
            }

Samples::Devices::DeviceControlResult::DeviceControlResult ( ) [inline]

Definition at line 33 of file support.h.

                                  : Result(E_NOT_SET),
                                    BytesTransferred(0)
            {
                return;
            }

Samples::Devices::DeviceControlResult::DeviceControlResult | ( | HRESULT | Hr,
 |  | DWORD | Cb |
 | ) |  |  | [inline]

Definition at line 39 of file support.h.

                                                      : Result(Hr),
                                                        BytesTransferred(Cb)
            {
                return;
            }

Samples::Devices::DeviceControlResult::DeviceControlResult ( ) [inline]

Definition at line 33 of file support.h.

                                  : Result(E_NOT_SET),
                                    BytesTransferred(0)
            {
                return;
            }

Samples::Devices::DeviceControlResult::DeviceControlResult | ( | HRESULT | Hr,
 |  | DWORD | Cb |
 | ) |  |  | [inline]

Definition at line 39 of file support.h.

                                                      : Result(Hr),
                                                        BytesTransferred(Cb)
            {
                return;
            }

Member Data Documentation

ULONG Samples::Devices::DeviceControlResult::BytesTransferred

Definition at line 31 of file support.h.

HRESULT Samples::Devices::DeviceControlResult::Result

Definition at line 30 of file support.h.

The documentation for this struct was generated from the following files:
  • Custom driver access/C#,C++/DLL/support.h
  • Custom driver access/C++/DLL/support.h
  • Custom driver access/C++,JavaScript/DLL/support.h
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Samples::Devices::Fx2::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Samples
  • Devices
  • Fx2
  • Samples::Devices::Fx2::sealed
Public Member Functions | Static Public Member Functions | Private Member Functions | Private Attributes

Samples::Devices::Fx2::sealed Class Reference

The device projection for an OSR Fx2 device. More...

#include "fx2device.h"

List of all members.

Public Member Functions

BarGraphDisplayResult ()
BarGraphDisplayResult ()
BarGraphDisplayResult ()
IAsyncOperation
< BarGraphDisplayResult^> 		GetBarGraphDisplayAsync (void)
IAsyncOperation
< BarGraphDisplayResult^> 		GetBarGraphDisplayAsync (void)
IAsyncOperation
< BarGraphDisplayResult^> 		GetBarGraphDisplayAsync (void)

Static Public Member Functions

static Fx2Device | FromId (__in String^InterfacePath)
static Fx2Device | FromId (__in String^InterfacePath)
static Fx2Device | FromId (__in String^InterfacePath)
static String | GetDeviceSelector ()
static String | GetDeviceSelector ()
static String | GetDeviceSelector ()

Private Member Functions

~Fx2Device ()
~Fx2Device ()
~Fx2Device ()
void | CheckResult (void)
void | CheckResult (void)
void | CheckResult (void)
Fx2Device (__in IDeviceIoControl *DeviceControl, __in String^Id)
Fx2Device (__in IDeviceIoControl *DeviceControl, __in String^Id)
Fx2Device (__in IDeviceIoControl *DeviceControl, __in String^Id)
void | StartEventLoop ()
void | StartEventLoop ()
void | StartEventLoop ()
void | StopEventLoop ()
void | StopEventLoop ()
void | StopEventLoop ()
SwitchStateChangedEventArgs (__in SWITCH_STATE State)
SwitchStateChangedEventArgs (__in HRESULT Hr)
SwitchStateChangedEventArgs (__in HRESULT Hr)
SwitchStateChangedEventArgs (__in HRESULT Hr)
SwitchStateChangedEventArgs (__in SWITCH_STATE State)
SwitchStateChangedEventArgs (__in SWITCH_STATE State)
void | UpdateBars ()
void | UpdateBars ()
void | UpdateBars ()

Private Attributes

Array< bool > | m_Bars
ULONG_PTR | m_CancelToken
ComPtr< IDeviceIoControl > | m_DeviceIoControl
HRESULT | m_Hr
String | m_Id
BAR_GRAPH_STATE m_State
SWITCH_STATE m_State
Array< bool > | m_Switches
struct {
SWITCH_STATE Buffer
ULONG_PTR CancelContext
ULONG FailureCount
LONG ListenerCount
Repeater Repeater
} m_SwitchState
struct {
SWITCH_STATE Buffer
ULONG_PTR CancelContext
ULONG FailureCount
LONG ListenerCount
Repeater Repeater
} m_SwitchState
struct {
SWITCH_STATE Buffer
ULONG_PTR CancelContext
ULONG FailureCount
LONG ListenerCount
Repeater Repeater
} m_SwitchState
event SwitchStateChangedHandler | m_SwitchStateChangedEvent

Detailed Description

Definition at line 60 of file fx2device.h.

Constructor & Destructor Documentation

Samples::Devices::Fx2::sealed::~Fx2Device ( ) [private]
Samples::Devices::Fx2::sealed::~Fx2Device ( ) [private]
Samples::Devices::Fx2::sealed::~Fx2Device ( ) [private]

Member Function Documentation

Samples::Devices::Fx2::sealed::BarGraphDisplayResult ( ) [inline]

Definition at line 160 of file fx2device.h.

                                        : m_CancelToken(0) {
                    m_Bars = ref new Array<bool>(c_NumBarsInGraph);
                    ZeroMemory(&m_State, sizeof(m_State));
                }

Samples::Devices::Fx2::sealed::BarGraphDisplayResult ( ) [inline]

Definition at line 160 of file fx2device.h.

                                        : m_CancelToken(0) {
                    m_Bars = ref new Array<bool>(c_NumBarsInGraph);
                    ZeroMemory(&m_State, sizeof(m_State));
                }

Samples::Devices::Fx2::sealed::BarGraphDisplayResult ( ) [inline]

Definition at line 160 of file fx2device.h.

                                        : m_CancelToken(0) {
                    m_Bars = ref new Array<bool>(c_NumBarsInGraph);
                    ZeroMemory(&m_State, sizeof(m_State));
                }

void Samples::Devices::Fx2::sealed::CheckResult ( void ) [inline, private]

Definition at line 133 of file fx2device.h.

                                       {
                    if (m_Hr != S_OK) {
                        throw Platform::Exception::CreateException(m_Hr, "Error requesting switch state");
                    }
                }

void Samples::Devices::Fx2::sealed::CheckResult ( void ) [inline, private]

Definition at line 133 of file fx2device.h.

                                       {
                    if (m_Hr != S_OK) {
                        throw Platform::Exception::CreateException(m_Hr, "Error requesting switch state");
                    }
                }

void Samples::Devices::Fx2::sealed::CheckResult ( void ) [inline, private]

Definition at line 133 of file fx2device.h.

                                       {
                    if (m_Hr != S_OK) {
                        throw Platform::Exception::CreateException(m_Hr, "Error requesting switch state");
                    }
                }

static Fx2Device Samples::Devices::Fx2::sealed::FromId ( __in String^ InterfacePath ) [static]
static Fx2Device Samples::Devices::Fx2::sealed::FromId ( __in String^ InterfacePath ) [static]
static Fx2Device Samples::Devices::Fx2::sealed::FromId ( __in String^ InterfacePath ) [static]
Samples::Devices::Fx2::sealed::Fx2Device | ( | __in IDeviceIoControl * | DeviceControl,
 |  | __in String^ | Id |
 | ) |  |  | [private]
Samples::Devices::Fx2::sealed::Fx2Device | ( | __in IDeviceIoControl * | DeviceControl,
 |  | __in String^ | Id |
 | ) |  |  | [private]
Samples::Devices::Fx2::sealed::Fx2Device | ( | __in IDeviceIoControl * | DeviceControl,
 |  | __in String^ | Id |
 | ) |  |  | [private]
IAsyncOperation<BarGraphDisplayResult^> Samples::Devices::Fx2::sealed::GetBarGraphDisplayAsync ( void )
IAsyncOperation<BarGraphDisplayResult^> Samples::Devices::Fx2::sealed::GetBarGraphDisplayAsync ( void )
IAsyncOperation<BarGraphDisplayResult^> Samples::Devices::Fx2::sealed::GetBarGraphDisplayAsync ( void )
static String Samples::Devices::Fx2::sealed::GetDeviceSelector ( ) [static]

Returns the device selector that an app should use to locate Fx2 devices.

Returns:
The selector string for the Fx2 device interface
static String Samples::Devices::Fx2::sealed::GetDeviceSelector ( ) [static]

Returns the device selector that an app should use to locate Fx2 devices.

Returns:
The selector string for the Fx2 device interface
static String Samples::Devices::Fx2::sealed::GetDeviceSelector ( ) [static]

Returns the device selector that an app should use to locate Fx2 devices.

Returns:
The selector string for the Fx2 device interface
void Samples::Devices::Fx2::sealed::StartEventLoop ( ) [private]
void Samples::Devices::Fx2::sealed::StartEventLoop ( ) [private]
void Samples::Devices::Fx2::sealed::StartEventLoop ( ) [private]
void Samples::Devices::Fx2::sealed::StopEventLoop ( ) [private]
void Samples::Devices::Fx2::sealed::StopEventLoop ( ) [private]
void Samples::Devices::Fx2::sealed::StopEventLoop ( ) [private]
Samples::Devices::Fx2::sealed::SwitchStateChangedEventArgs ( __in SWITCH_STATE State ) [inline, private]

Definition at line 124 of file fx2device.h.

                                                                     {
                    m_Hr = S_OK;
                    m_Switches = ref new Array<bool>(c_NumSwitches);
                    m_State = State;
                    for(int i = 0; i < c_NumSwitches; i += 1) {
                        m_Switches[i] = ((State.SwitchesAsUChar & (1 << i)) != 0);
                    }
                }

Samples::Devices::Fx2::sealed::SwitchStateChangedEventArgs ( __in HRESULT Hr ) [inline, private]

Definition at line 118 of file fx2device.h.

                                                             {
                    m_Hr = Hr;
                    m_Switches = nullptr;
                    ZeroMemory(&m_State, sizeof(m_State));
                }

Samples::Devices::Fx2::sealed::SwitchStateChangedEventArgs ( __in HRESULT Hr ) [inline, private]

Definition at line 118 of file fx2device.h.

                                                             {
                    m_Hr = Hr;
                    m_Switches = nullptr;
                    ZeroMemory(&m_State, sizeof(m_State));
                }

Samples::Devices::Fx2::sealed::SwitchStateChangedEventArgs ( __in HRESULT Hr ) [inline, private]

Definition at line 118 of file fx2device.h.

                                                             {
                    m_Hr = Hr;
                    m_Switches = nullptr;
                    ZeroMemory(&m_State, sizeof(m_State));
                }

Samples::Devices::Fx2::sealed::SwitchStateChangedEventArgs ( __in SWITCH_STATE State ) [inline, private]

Definition at line 124 of file fx2device.h.

                                                                     {
                    m_Hr = S_OK;
                    m_Switches = ref new Array<bool>(c_NumSwitches);
                    m_State = State;
                    for(int i = 0; i < c_NumSwitches; i += 1) {
                        m_Switches[i] = ((State.SwitchesAsUChar & (1 << i)) != 0);
                    }
                }

Samples::Devices::Fx2::sealed::SwitchStateChangedEventArgs ( __in SWITCH_STATE State ) [inline, private]

Definition at line 124 of file fx2device.h.

                                                                     {
                    m_Hr = S_OK;
                    m_Switches = ref new Array<bool>(c_NumSwitches);
                    m_State = State;
                    for(int i = 0; i < c_NumSwitches; i += 1) {
                        m_Switches[i] = ((State.SwitchesAsUChar & (1 << i)) != 0);
                    }
                }

void Samples::Devices::Fx2::sealed::UpdateBars ( ) [inline, private]

Definition at line 153 of file fx2device.h.

                                  {
                    for(int i = 0; i < c_NumBarsInGraph; i += 1) {
                        m_Bars[i] = ((m_State.BarsAsUChar & (1 << i)) != 0);
                    }
                }

void Samples::Devices::Fx2::sealed::UpdateBars ( ) [inline, private]

Definition at line 153 of file fx2device.h.

                                  {
                    for(int i = 0; i < c_NumBarsInGraph; i += 1) {
                        m_Bars[i] = ((m_State.BarsAsUChar & (1 << i)) != 0);
                    }
                }

void Samples::Devices::Fx2::sealed::UpdateBars ( ) [inline, private]

Definition at line 153 of file fx2device.h.

                                  {
                    for(int i = 0; i < c_NumBarsInGraph; i += 1) {
                        m_Bars[i] = ((m_State.BarsAsUChar & (1 << i)) != 0);
                    }
                }

Member Data Documentation

SWITCH_STATE Samples::Devices::Fx2::sealed::Buffer

Definition at line 75 of file fx2device.h.

ULONG_PTR Samples::Devices::Fx2::sealed::CancelContext

Definition at line 76 of file fx2device.h.

ULONG Samples::Devices::Fx2::sealed::FailureCount

Definition at line 77 of file fx2device.h.

LONG Samples::Devices::Fx2::sealed::ListenerCount

Definition at line 72 of file fx2device.h.

Array< bool > sealed::m_Bars [private]

Definition at line 146 of file fx2device.h.

ULONG_PTR sealed::m_CancelToken [private]

Definition at line 151 of file fx2device.h.

ComPtr< IDeviceIoControl > sealed::m_DeviceIoControl [private]

Definition at line 66 of file fx2device.h.

HRESULT sealed::m_Hr [private]

Definition at line 111 of file fx2device.h.

String sealed::m_Id [private]

Definition at line 64 of file fx2device.h.

BAR_GRAPH_STATE sealed::m_State [private]

Definition at line 116 of file fx2device.h.

BAR_GRAPH_STATE Samples::Devices::Fx2::sealed::m_State [private]

Definition at line 150 of file fx2device.h.

Array< bool > sealed::m_Switches [private]

Definition at line 115 of file fx2device.h.

struct { ... } Samples::Devices::Fx2::sealed::m_SwitchState [private]
struct { ... } Samples::Devices::Fx2::sealed::m_SwitchState [private]
struct { ... } Samples::Devices::Fx2::sealed::m_SwitchState [private]
event SwitchStateChangedHandler sealed::m_SwitchStateChangedEvent [private]

Definition at line 79 of file fx2device.h.

Repeater Samples::Devices::Fx2::sealed::Repeater

Definition at line 73 of file fx2device.h.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/DLL/fx2device.h
  • Custom driver access/C++/DLL/fx2device.h
  • Custom driver access/C++,JavaScript/DLL/fx2device.h
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Samples::Devices::Repeater Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Samples
  • Devices
  • Samples::Devices::Repeater
Public Types | Public Member Functions | Private Types | Private Member Functions | Private Attributes

Samples::Devices::Repeater Class Reference

#include "repeater.h"

List of all members.

Public Types

enum RepeaterState {
Stopped, Running, Stopping, Stopped,
Running, Stopping, Stopped, Running,
Stopping
}
enum RepeaterState {
Stopped, Running, Stopping, Stopped,
Running, Stopping, Stopped, Running,
Stopping
}
enum RepeaterState {
Stopped, Running, Stopping, Stopped,
Running, Stopping, Stopped, Running,
Stopping
}

Public Member Functions

Repeater ()
Repeater ()
Repeater ()
~Repeater ()
~Repeater ()
~Repeater ()
RepeaterState | GetState (void)
RepeaterState | GetState (void)
RepeaterState | GetState (void)
void | Start (Details::StartRepeaterTaskFunction StartTaskFunction, concurrency::task_continuation_context Context=concurrency::task_continuation_context::use_current())
void | Start (Details::StartRepeaterTaskFunction StartTaskFunction, concurrency::task_continuation_context Context=concurrency::task_continuation_context::use_current())
void | Start (Details::StartRepeaterTaskFunction StartTaskFunction, concurrency::task_continuation_context Context=concurrency::task_continuation_context::use_current())
bool | Stop (Details::RepeaterStoppedFunction *callback=nullptr)
bool | Stop (Details::RepeaterStoppedFunction *callback=nullptr)
bool | Stop (Details::RepeaterStoppedFunction *callback=nullptr)

Private Types

typedef std::unique_lock
< std::mutex > 		mlt
typedef std::unique_lock
< std::mutex > 		mlt
typedef std::unique_lock
< std::mutex > 		mlt

Private Member Functions

void | RestartTask (concurrency::task_continuation_context context, bool Continue)
void | RestartTask (concurrency::task_continuation_context context, bool Continue)
void | RestartTask (concurrency::task_continuation_context context, bool Continue)
void | StartTask (concurrency::task_continuation_context context)
void | StartTask (concurrency::task_continuation_context context)
void | StartTask (concurrency::task_continuation_context context)

Private Attributes

concurrency::cancellation_token_source | m_Canceller
std::mutex | m_Lock
Details::RepeaterStoppedFunction m_RepeaterStoppedFunction
Details::StartRepeaterTaskFunction m_StartTaskFunction
RepeaterState m_State

Detailed Description

Definition at line 31 of file repeater.h.

Member Typedef Documentation

typedef std::unique_lock<std::mutex> Samples::Devices::Repeater::mlt [private]

Definition at line 56 of file repeater.h.

typedef std::unique_lock<std::mutex> Samples::Devices::Repeater::mlt [private]

Definition at line 56 of file repeater.h.

typedef std::unique_lock<std::mutex> Samples::Devices::Repeater::mlt [private]

Definition at line 56 of file repeater.h.

Member Enumeration Documentation

enum Samples::Devices::Repeater::RepeaterState
Enumerator:
Stopped
Running
Stopping
Stopped
Running
Stopping
Stopped
Running
Stopping

Definition at line 35 of file repeater.h.

                                     {
                Stopped,
                Running,
                Stopping
            };

enum Samples::Devices::Repeater::RepeaterState
Enumerator:
Stopped
Running
Stopping
Stopped
Running
Stopping
Stopped
Running
Stopping

Definition at line 35 of file repeater.h.

                                     {
                Stopped,
                Running,
                Stopping
            };

enum Samples::Devices::Repeater::RepeaterState
Enumerator:
Stopped
Running
Stopping
Stopped
Running
Stopping
Stopped
Running
Stopping

Definition at line 35 of file repeater.h.

                                     {
                Stopped,
                Running,
                Stopping
            };

Constructor & Destructor Documentation

Samples::Devices::Repeater::Repeater ( ) [inline]

Definition at line 63 of file repeater.h.

                       : m_StartTaskFunction(nullptr),
                         m_State(RepeaterState::Stopped),
                         m_RepeaterStoppedFunction(nullptr)
            {
                return;
            }

Samples::Devices::Repeater::~Repeater ( ) [inline]

Definition at line 70 of file repeater.h.

            {
                // TODO: Move the core of the repeater to an allocated
                //       object that i can let run down on its own on destruction.  For now
                //       !! don't delete a repeater that's still running !!
                assert(m_State == RepeaterState::Stopped);
            }

Samples::Devices::Repeater::Repeater ( ) [inline]

Definition at line 63 of file repeater.h.

                       : m_StartTaskFunction(nullptr),
                         m_State(RepeaterState::Stopped),
                         m_RepeaterStoppedFunction(nullptr)
            {
                return;
            }

Samples::Devices::Repeater::~Repeater ( ) [inline]

Definition at line 70 of file repeater.h.

            {
                // TODO: Move the core of the repeater to an allocated
                //       object that i can let run down on its own on destruction.  For now
                //       !! don't delete a repeater that's still running !!
                assert(m_State == RepeaterState::Stopped);
            }

Samples::Devices::Repeater::Repeater ( ) [inline]

Definition at line 63 of file repeater.h.

                       : m_StartTaskFunction(nullptr),
                         m_State(RepeaterState::Stopped),
                         m_RepeaterStoppedFunction(nullptr)
            {
                return;
            }

Samples::Devices::Repeater::~Repeater ( ) [inline]

Definition at line 70 of file repeater.h.

            {
                // TODO: Move the core of the repeater to an allocated
                //       object that i can let run down on its own on destruction.  For now
                //       !! don't delete a repeater that's still running !!
                assert(m_State == RepeaterState::Stopped);
            }

Member Function Documentation

RepeaterState Samples::Devices::Repeater::GetState ( void ) [inline]

Definition at line 136 of file repeater.h.

            {
                return m_State;
            }

RepeaterState Samples::Devices::Repeater::GetState ( void ) [inline]

Definition at line 136 of file repeater.h.

            {
                return m_State;
            }

RepeaterState Samples::Devices::Repeater::GetState ( void ) [inline]

Definition at line 136 of file repeater.h.

            {
                return m_State;
            }

void Samples::Devices::Repeater::RestartTask | ( | concurrency::task_continuation_context | context,
 |  | bool | Continue |
 | ) |  |  | [inline, private]

Definition at line 157 of file repeater.h.

                                                                                {
                // Check and see if the task is still running
                mlt lock(m_Lock);

                if (Continue == false) {
                    m_State = RepeaterState::Stopping;
                }
                if (m_State == RepeaterState::Running) {
                    StartTask(context);
                } else if (m_State == RepeaterState::Stopping) {
                    m_State = RepeaterState::Stopped;
                    if (m_RepeaterStoppedFunction != nullptr) {
                        Details::RepeaterStoppedFunction callback = m_RepeaterStoppedFunction;
                        m_RepeaterStoppedFunction = nullptr;
                        lock.release();
                        callback();
                    }
                }
            }

void Samples::Devices::Repeater::RestartTask | ( | concurrency::task_continuation_context | context,
 |  | bool | Continue |
 | ) |  |  | [inline, private]

Definition at line 157 of file repeater.h.

                                                                                {
                // Check and see if the task is still running
                mlt lock(m_Lock);

                if (Continue == false) {
                    m_State = RepeaterState::Stopping;
                }
                if (m_State == RepeaterState::Running) {
                    StartTask(context);
                } else if (m_State == RepeaterState::Stopping) {
                    m_State = RepeaterState::Stopped;
                    if (m_RepeaterStoppedFunction != nullptr) {
                        Details::RepeaterStoppedFunction callback = m_RepeaterStoppedFunction;
                        m_RepeaterStoppedFunction = nullptr;
                        lock.release();
                        callback();
                    }
                }
            }

void Samples::Devices::Repeater::RestartTask | ( | concurrency::task_continuation_context | context,
 |  | bool | Continue |
 | ) |  |  | [inline, private]

Definition at line 157 of file repeater.h.

                                                                                {
                // Check and see if the task is still running
                mlt lock(m_Lock);

                if (Continue == false) {
                    m_State = RepeaterState::Stopping;
                }
                if (m_State == RepeaterState::Running) {
                    StartTask(context);
                } else if (m_State == RepeaterState::Stopping) {
                    m_State = RepeaterState::Stopped;
                    if (m_RepeaterStoppedFunction != nullptr) {
                        Details::RepeaterStoppedFunction callback = m_RepeaterStoppedFunction;
                        m_RepeaterStoppedFunction = nullptr;
                        lock.release();
                        callback();
                    }
                }
            }

void Samples::Devices::Repeater::Start | ( | Details::StartRepeaterTaskFunction | StartTaskFunction,
 |  | concurrency::task_continuation_context | Context = concurrency::task_continuation_context::use_current() |
 | ) |  |  | [inline]

Definition at line 81 of file repeater.h.

            {
                // lock the mutex
                mlt lock(m_Lock);

                assert(m_State == RepeaterState::Stopped);

                if (m_State == RepeaterState::Stopped) {
                    m_StartTaskFunction = StartTaskFunction;
                    m_RepeaterStoppedFunction = nullptr;

                    // Get a new canceller before we start the tasks
                    auto c = concurrency::cancellation_token_source();
                    m_Canceller = std::move(c);

                    // Update task state before starting the task so that it can
                    // restart itself properly.
                    m_State = RepeaterState::Running;
                    StartTask(Context);
                }
            }

void Samples::Devices::Repeater::Start | ( | Details::StartRepeaterTaskFunction | StartTaskFunction,
 |  | concurrency::task_continuation_context | Context = concurrency::task_continuation_context::use_current() |
 | ) |  |  | [inline]

Definition at line 81 of file repeater.h.

            {
                // lock the mutex
                mlt lock(m_Lock);

                assert(m_State == RepeaterState::Stopped);

                if (m_State == RepeaterState::Stopped) {
                    m_StartTaskFunction = StartTaskFunction;
                    m_RepeaterStoppedFunction = nullptr;

                    // Get a new canceller before we start the tasks
                    auto c = concurrency::cancellation_token_source();
                    m_Canceller = std::move(c);

                    // Update task state before starting the task so that it can
                    // restart itself properly.
                    m_State = RepeaterState::Running;
                    StartTask(Context);
                }
            }

void Samples::Devices::Repeater::Start | ( | Details::StartRepeaterTaskFunction | StartTaskFunction,
 |  | concurrency::task_continuation_context | Context = concurrency::task_continuation_context::use_current() |
 | ) |  |  | [inline]

Definition at line 81 of file repeater.h.

            {
                // lock the mutex
                mlt lock(m_Lock);

                assert(m_State == RepeaterState::Stopped);

                if (m_State == RepeaterState::Stopped) {
                    m_StartTaskFunction = StartTaskFunction;
                    m_RepeaterStoppedFunction = nullptr;

                    // Get a new canceller before we start the tasks
                    auto c = concurrency::cancellation_token_source();
                    m_Canceller = std::move(c);

                    // Update task state before starting the task so that it can
                    // restart itself properly.
                    m_State = RepeaterState::Running;
                    StartTask(Context);
                }
            }

void Samples::Devices::Repeater::StartTask ( concurrency::task_continuation_context context ) [inline, private]

Definition at line 144 of file repeater.h.

                                                                         {
                // start the caller's task and add a restart task onto
                // the end.
                m_StartTaskFunction(m_Canceller.get_token(), context).
                    then([this, context](bool b) {
                        RestartTask(context, b);
                    }
                );
            }

void Samples::Devices::Repeater::StartTask ( concurrency::task_continuation_context context ) [inline, private]

Definition at line 144 of file repeater.h.

                                                                         {
                // start the caller's task and add a restart task onto
                // the end.
                m_StartTaskFunction(m_Canceller.get_token(), context).
                    then([this, context](bool b) {
                        RestartTask(context, b);
                    }
                );
            }

void Samples::Devices::Repeater::StartTask ( concurrency::task_continuation_context context ) [inline, private]

Definition at line 144 of file repeater.h.

                                                                         {
                // start the caller's task and add a restart task onto
                // the end.
                m_StartTaskFunction(m_Canceller.get_token(), context).
                    then([this, context](bool b) {
                        RestartTask(context, b);
                    }
                );
            }

bool Samples::Devices::Repeater::Stop ( Details::RepeaterStoppedFunction * callback = nullptr ) [inline]

Definition at line 109 of file repeater.h.

            {
                mlt lock(m_Lock);
                bool active;

                if (m_State == RepeaterState::Running) {
                    m_State = RepeaterState::Stopping;
                    m_Canceller.cancel();

                    active = true;
                } else if (m_State == RepeaterState::Stopping) {
                    active = true;
                } else {
                    active = false;
                }

                if (callback) {
                    if (active == true) {
                        m_RepeaterStoppedFunction = *callback;
                        lock.release();
                    }
                }

                return active;
            }

bool Samples::Devices::Repeater::Stop ( Details::RepeaterStoppedFunction * callback = nullptr ) [inline]

Definition at line 109 of file repeater.h.

            {
                mlt lock(m_Lock);
                bool active;

                if (m_State == RepeaterState::Running) {
                    m_State = RepeaterState::Stopping;
                    m_Canceller.cancel();

                    active = true;
                } else if (m_State == RepeaterState::Stopping) {
                    active = true;
                } else {
                    active = false;
                }

                if (callback) {
                    if (active == true) {
                        m_RepeaterStoppedFunction = *callback;
                        lock.release();
                    }
                }

                return active;
            }

bool Samples::Devices::Repeater::Stop ( Details::RepeaterStoppedFunction * callback = nullptr ) [inline]

Definition at line 109 of file repeater.h.

            {
                mlt lock(m_Lock);
                bool active;

                if (m_State == RepeaterState::Running) {
                    m_State = RepeaterState::Stopping;
                    m_Canceller.cancel();

                    active = true;
                } else if (m_State == RepeaterState::Stopping) {
                    active = true;
                } else {
                    active = false;
                }

                if (callback) {
                    if (active == true) {
                        m_RepeaterStoppedFunction = *callback;
                        lock.release();
                    }
                }

                return active;
            }

Member Data Documentation

concurrency::cancellation_token_source Samples::Devices::Repeater::m_Canceller [private]

Definition at line 46 of file repeater.h.

std::mutex Samples::Devices::Repeater::m_Lock [private]

Definition at line 53 of file repeater.h.

Details::RepeaterStoppedFunction Samples::Devices::Repeater::m_RepeaterStoppedFunction [private]

Definition at line 60 of file repeater.h.

Details::StartRepeaterTaskFunction Samples::Devices::Repeater::m_StartTaskFunction [private]

Definition at line 43 of file repeater.h.

RepeaterState Samples::Devices::Repeater::m_State [private]

Definition at line 49 of file repeater.h.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/DLL/repeater.h
  • Custom driver access/C++/DLL/repeater.h
  • Custom driver access/C++,JavaScript/DLL/repeater.h
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SaveAsImageFile Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Static Private Member Functions | Private Attributes

SaveAsImageFile Class Reference

#include "SaveAsImageFileSample.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Render () override
virtual void | Run ()
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | Uninitialize ()

Public Attributes

internal | __pad0__: SaveAsImageFile()

Private Member Functions

void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | SaveBitmapToFile ()

Static Private Member Functions

static void | SaveBitmapToStream (_In_ Microsoft::WRL::ComPtr< ID2D1Bitmap1 > d2dBitmap, _In_ Microsoft::WRL::ComPtr< IWICImagingFactory2 > wicFactory2, _In_ Microsoft::WRL::ComPtr< ID2D1DeviceContext > d2dContext, _In_ REFGUID wicFormat, _In_ IStream *stream)

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Platform::String | m_imageFileName
bool | m_isSnapped
SampleOverlay m_sampleOverlay
ScreenSavingState m_screenSavingState
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_snappedViewFormat
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat

Detailed Description

Definition at line 20 of file SaveAsImageFileSample.h.

Member Function Documentation

void SaveAsImageFile::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 29 of file SaveAsImageFileSample.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create a DirectWrite text format object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",                // font family name
            nullptr,                    // system font collection
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            64,                         // font size
            L"en-US",                   // locale
            &m_textFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    // Create a DirectWrite text format object for the snapped view message.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",                // font family name
            nullptr,                    // system font collection
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            20,                         // font size
            L"en-US",                   // locale
            &m_snappedViewFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        m_snappedViewFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        m_snappedViewFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );
}

void SaveAsImageFile::CreateDeviceResources ( ) [override, virtual]

Definition at line 82 of file SaveAsImageFileSample.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct2D save to image file sample"
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::Black),
            &m_blackBrush
            )
        );
}

virtual void SaveAsImageFile::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void SaveAsImageFile::Load ( _In_ Platform::String^ entryPoint ) [virtual]

Definition at line 341 of file SaveAsImageFileSample.cpp.

{
}

void SaveAsImageFile::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void SaveAsImageFile::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]

Definition at line 382 of file SaveAsImageFileSample.cpp.

{
    // Ensure the D3D Device is available for rendering.
    ValidateDevice();

    Render();
    Present();
}

void SaveAsImageFile::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]

Definition at line 373 of file SaveAsImageFileSample.cpp.

{
    SetDpi(DisplayProperties::LogicalDpi);
    Render();
    Present();
}

void SaveAsImageFile::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SaveAsImageFile::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void SaveAsImageFile::Render ( ) [override, virtual]

Definition at line 104 of file SaveAsImageFileSample.cpp.

{
    m_d2dContext->BeginDraw();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    Platform::String^ string;
    IDWriteTextFormat *format;

    if (m_isSnapped)
    {
        string = "This sample does not support snapped view.";
        format = m_snappedViewFormat.Get();
    }
    else if (m_screenSavingState == ScreenSavingState::NotSaved || m_screenSavingState == ScreenSavingState::Saving)
    {
        string = "Tap to save screen.";
        format = m_textFormat.Get();
    }
    else
    {
        string = Platform::String::Concat("Screen saved to ", m_imageFileName);
        format = m_textFormat.Get();
    }

    D2D1_SIZE_F size = m_d2dContext->GetSize();

    m_d2dContext->DrawText(
        string->Data(),
        string->Length(),
        format,
        D2D1::RectF(0, 0, size.width, size.height),
        m_blackBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();
}

void SaveAsImageFile::Run ( ) [virtual]

Definition at line 347 of file SaveAsImageFileSample.cpp.

{
    Render();
    Present();

    m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
}

void SaveAsImageFile::SaveBitmapToFile ( ) [private]

Definition at line 152 of file SaveAsImageFileSample.cpp.

{
    if (m_isSnapped || m_screenSavingState != ScreenSavingState::NotSaved || m_d2dTargetBitmap == nullptr)
    {
        return;
    }

    // Set state to Saving to block another copy of this function being called before saving completes.
    m_screenSavingState = ScreenSavingState::Saving;
    Render();
    Present();

    // Prepare a file picker for customers to input image file name.
    Pickers::FileSavePicker^ savePicker = ref new Pickers::FileSavePicker();
    auto pngExtensions = ref new Platform::Collections::Vector<Platform::String^>();
    pngExtensions->Append(".png");
    savePicker->FileTypeChoices->Insert("PNG file", pngExtensions);
    auto jpgExtensions = ref new Platform::Collections::Vector<Platform::String^>();
    jpgExtensions->Append(".jpg");
    savePicker->FileTypeChoices->Insert("JPEG file", jpgExtensions);
    auto bmpExtensions = ref new Platform::Collections::Vector<Platform::String^>();
    bmpExtensions->Append(".bmp");
    savePicker->FileTypeChoices->Insert("BMP file", bmpExtensions);
    savePicker->DefaultFileExtension = ".png";
    savePicker->SuggestedFileName = "SaveScreen";
    savePicker->SuggestedStartLocation = Pickers::PickerLocationId::PicturesLibrary;

    std::shared_ptr<GUID> wicFormat = std::make_shared<GUID>(GUID_ContainerFormatPng);

    create_task(savePicker->PickSaveFileAsync()).then([=](StorageFile^ file)
    {
        if (file == nullptr)
        {
            // If user clicks "Cancel", reset the saving state, then cancel the current task.
            m_screenSavingState = ScreenSavingState::NotSaved;
            cancel_current_task();
        }

        m_imageFileName = file->Name;
        if (file->FileType == ".bmp")
        {
            *wicFormat = GUID_ContainerFormatBmp;
        }
        else if (file->FileType == ".jpg")
        {
            *wicFormat = GUID_ContainerFormatJpeg;
        }
        return file->OpenAsync(FileAccessMode::ReadWrite);

    }).then([=](Streams::IRandomAccessStream^ randomAccessStream)
    {
        // Convert the RandomAccessStream to an IStream.
        ComPtr<IStream> stream;
        DX::ThrowIfFailed(
            CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(&stream))
            );

        // Render the screen contents to an off-screen bitmap and then save that bitmap to a file.
        ComPtr<ID2D1Bitmap1> targetBitmap;
        D2D1_SIZE_U pixelSize = m_d2dContext->GetPixelSize();

        DX::ThrowIfFailed(
            m_d2dContext->CreateBitmap(
                pixelSize,
                nullptr,
                pixelSize.width * 4,    // pitch = width * size of pixel (4 bytes for B8G8R8A8)
                D2D1::BitmapProperties1(
                    D2D1_BITMAP_OPTIONS_TARGET,
                    D2D1::PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED)
                    ),
                &targetBitmap
                )
            );

        m_d2dContext->SetTarget(targetBitmap.Get());
        Render();
        m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());

        SaveBitmapToStream(targetBitmap, m_wicFactory, m_d2dContext, *wicFormat, stream.Get());

        m_screenSavingState = ScreenSavingState::Saved;
        Render();
        Present();
    });
}

static void SaveAsImageFile::SaveBitmapToStream | ( | _In_ Microsoft::WRL::ComPtr< ID2D1Bitmap1 > | d2dBitmap,
 |  | _In_ Microsoft::WRL::ComPtr< IWICImagingFactory2 > | wicFactory2,
 |  | _In_ Microsoft::WRL::ComPtr< ID2D1DeviceContext > | d2dContext,
 |  | _In_ REFGUID | wicFormat,
 |  | _In_ IStream * | stream |
 | ) |  |  | [static, private]
virtual void SaveAsImageFile::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
void SaveAsImageFile::Uninitialize ( ) [virtual]

Definition at line 355 of file SaveAsImageFileSample.cpp.

{
}

Member Data Documentation

internal SaveAsImageFile::__pad0__

Definition at line 23 of file SaveAsImageFileSample.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> SaveAsImageFile::m_blackBrush [private]

Definition at line 74 of file SaveAsImageFileSample.h.

Platform::String SaveAsImageFile::m_imageFileName [private]

Definition at line 78 of file SaveAsImageFileSample.h.

bool SaveAsImageFile::m_isSnapped [private]

Definition at line 79 of file SaveAsImageFileSample.h.

SampleOverlay SaveAsImageFile::m_sampleOverlay [private]

Definition at line 73 of file SaveAsImageFileSample.h.

ScreenSavingState SaveAsImageFile::m_screenSavingState [private]

Definition at line 77 of file SaveAsImageFileSample.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> SaveAsImageFile::m_snappedViewFormat [private]

Definition at line 76 of file SaveAsImageFileSample.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> SaveAsImageFile::m_textFormat [private]

Definition at line 75 of file SaveAsImageFileSample.h.

The documentation for this class was generated from the following files:
  • Direct2D save to image file/C++/SaveAsImageFileSample.h
  • Direct2D save to image file/C++/SaveAsImageFileSample.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ScenarioContext Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ScenarioContext Struct Reference

#include "CompressionUtils.h"

List of all members.

Public Attributes

std::vector< byte > | compressedData
Windows::Storage::Compression::Compressor | compressor
std::vector< byte > | decompressedData
std::vector< byte > | originalData
Windows::Storage::Streams::InMemoryRandomAccessStream | raStream
Windows::Storage::Streams::DataWriter | writer

Detailed Description

Definition at line 27 of file CompressionUtils.h.

Member Data Documentation

std::vector<byte> ScenarioContext::compressedData

Definition at line 33 of file CompressionUtils.h.

Windows::Storage::Compression::Compressor ScenarioContext::compressor

Definition at line 30 of file CompressionUtils.h.

std::vector<byte> ScenarioContext::decompressedData

Definition at line 34 of file CompressionUtils.h.

std::vector<byte> ScenarioContext::originalData

Definition at line 32 of file CompressionUtils.h.

Windows::Storage::Streams::InMemoryRandomAccessStream ScenarioContext::raStream

Definition at line 29 of file CompressionUtils.h.

Windows::Storage::Streams::DataWriter ScenarioContext::writer

Definition at line 31 of file CompressionUtils.h.

The documentation for this struct was generated from the following file:
  • Compression/C++/CompressionUtils.h
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ScheduledNotificationsSampleCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ScheduledNotificationsSampleCPP
  • ScheduledNotificationsSampleCPP::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

ScheduledNotificationsSampleCPP::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
Platform::String | ConvertResolution (Windows::Graphics::Display::ResolutionScale scale)
Platform::String | ConvertViewState (Windows::UI::ViewManagement::ApplicationViewState state)
void | DoNavigation (Windows::UI::Xaml::Interop::TypeName inPageType, Windows::UI::Xaml::Controls::Frame^inFrame, Windows::UI::Xaml::Interop::TypeName outPageType, Windows::UI::Xaml::Controls::Frame^outFrame)
void | LoadData ()
MainPage ()
NotificationData (void)
NotificationDataSource ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
void | Refresh ()
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()
void | set_IsTile (bool isTile)

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | OnPropertyChanged (Platform::String^propertyName)
void | Scenarios_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded
event
Windows::UI::Xaml::Data::PropertyChangedEventHandler 		PropertyChanged

Private Member Functions

~MainPage ()
~ScenarioInput2 ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
void | AddItem (Platform::String^itemType, Platform::String^itemId, Platform::String^dueTime, Platform::String^inputString, bool isTile)
void | CheckResolutionAndViewState ()
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | inputFrameNavigated (Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | outputFrameNavigated (Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | Page_Loaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | RefreshList_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RefreshListView ()
void | Remove_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Schedule_Click (Object^, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScheduleTile (Platform::String^updateString, Windows::Foundation::DateTime dueTime, Platform::String^idNumberString)
void | ScheduleTileWithStringManipulation (Platform::String^updateString, Windows::Foundation::DateTime dueTime, Platform::String^idNumberString)
void | ScheduleToast (Platform::String^updateString, Windows::Foundation::DateTime dueTime, Platform::String^idNumberString)
void | ScheduleToastWithStringManipulation (Platform::String^updateString, Windows::Foundation::DateTime dueTime, Platform::String^idNumberString)
void | SetFeatureName (Platform::String^strFeature)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Platform::String | _dueTime
Windows::Globalization::DateTimeFormatting::DateTimeFormatter | _formatter
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Platform::String | _inputString
bool | _isTile
Platform::String | _itemId
Platform::Collections::Vector
< Object^> 		_items
Platform::String | _itemType
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::Foundation::EventRegistrationToken | _resizeHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
MainPage | rootPage
NotificationDataSource | scheduledNotificationsBinding

Detailed Description

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

ScheduledNotificationsSampleCPP::sealed::~MainPage ( ) [private]
ScheduledNotificationsSampleCPP::sealed::~ScenarioInput2 ( ) [private]
ScheduledNotificationsSampleCPP::sealed::~ScenarioList ( ) [private]
ScheduledNotificationsSampleCPP::sealed::~ScenarioOutput1 ( ) [private]
ScheduledNotificationsSampleCPP::sealed::~ScenarioOutput2 ( ) [private]

Member Function Documentation

void ScheduledNotificationsSampleCPP::sealed::AddItem | ( | Platform::String^ | itemType,
 |  | Platform::String^ | itemId,
 |  | Platform::String^ | dueTime,
 |  | Platform::String^ | inputString,
 |  | bool | isTile |
 | ) |  |  | [private]
ScheduledNotificationsSampleCPP::sealed::App ( )
void ScheduledNotificationsSampleCPP::sealed::CheckResolutionAndViewState ( ) [private]
Platform::String ScheduledNotificationsSampleCPP::sealed::ConvertResolution ( Windows::Graphics::Display::ResolutionScale scale )
Platform::String ScheduledNotificationsSampleCPP::sealed::ConvertViewState ( Windows::UI::ViewManagement::ApplicationViewState state )
void ScheduledNotificationsSampleCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void ScheduledNotificationsSampleCPP::sealed::DoNavigation | ( | Windows::UI::Xaml::Interop::TypeName | inPageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | inFrame,
 |  | Windows::UI::Xaml::Interop::TypeName | outPageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | outFrame
 | ) |  |
void ScheduledNotificationsSampleCPP::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::LoadData ( )
ScheduledNotificationsSampleCPP::sealed::MainPage ( )
ScheduledNotificationsSampleCPP::sealed::NotificationData ( void )
ScheduledNotificationsSampleCPP::sealed::NotificationDataSource ( )
void ScheduledNotificationsSampleCPP::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void ScheduledNotificationsSampleCPP::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void ScheduledNotificationsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ScheduledNotificationsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ScheduledNotificationsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void ScheduledNotificationsSampleCPP::sealed::OnPropertyChanged ( Platform::String^ propertyName ) [protected]
virtual void ScheduledNotificationsSampleCPP::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void ScheduledNotificationsSampleCPP::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::Refresh ( )
void ScheduledNotificationsSampleCPP::sealed::RefreshList_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::RefreshListView ( ) [private]
void ScheduledNotificationsSampleCPP::sealed::Remove_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
ScheduledNotificationsSampleCPP::sealed::ScenarioInput1 ( )
ScheduledNotificationsSampleCPP::sealed::ScenarioInput2 ( )
ScheduledNotificationsSampleCPP::sealed::ScenarioList ( )
ScheduledNotificationsSampleCPP::sealed::ScenarioOutput1 ( )
ScheduledNotificationsSampleCPP::sealed::ScenarioOutput2 ( )
void ScheduledNotificationsSampleCPP::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void ScheduledNotificationsSampleCPP::sealed::Schedule_Click | ( | Object^ | ,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::ScheduleTile | ( | Platform::String^ | updateString,
 |  | Windows::Foundation::DateTime | dueTime,
 |  | Platform::String^ | idNumberString |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::ScheduleTileWithStringManipulation | ( | Platform::String^ | updateString,
 |  | Windows::Foundation::DateTime | dueTime,
 |  | Platform::String^ | idNumberString |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::ScheduleToast | ( | Platform::String^ | updateString,
 |  | Windows::Foundation::DateTime | dueTime,
 |  | Platform::String^ | idNumberString |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::ScheduleToastWithStringManipulation | ( | Platform::String^ | updateString,
 |  | Windows::Foundation::DateTime | dueTime,
 |  | Platform::String^ | idNumberString |
 | ) |  |  | [private]
void ScheduledNotificationsSampleCPP::sealed::set_IsTile ( bool isTile )
void ScheduledNotificationsSampleCPP::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken ScheduledNotificationsSampleCPP::sealed::_displayHandlerToken [private]

Definition at line 59 of file MainPage.xaml.h.

Platform::String ScheduledNotificationsSampleCPP::sealed::_dueTime [private]

Definition at line 29 of file NotificationData.h.

Windows::Globalization::DateTimeFormatting::DateTimeFormatter ScheduledNotificationsSampleCPP::sealed::_formatter [private]

Definition at line 48 of file NotificationData.h.

Windows::UI::Xaml::Controls::Frame ScheduledNotificationsSampleCPP::sealed::_inputFrame [private]

Definition at line 56 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ScheduledNotificationsSampleCPP::sealed::_inputFrameLoadedToken [private]

Definition at line 62 of file MainPage.xaml.h.

Platform::String ScheduledNotificationsSampleCPP::sealed::_inputString [private]

Definition at line 30 of file NotificationData.h.

bool ScheduledNotificationsSampleCPP::sealed::_isTile [private]

Definition at line 31 of file NotificationData.h.

Platform::String ScheduledNotificationsSampleCPP::sealed::_itemId [private]

Definition at line 28 of file NotificationData.h.

Platform::Collections::Vector<Object^> ScheduledNotificationsSampleCPP::sealed::_items [private]

Definition at line 47 of file NotificationData.h.

Platform::String ScheduledNotificationsSampleCPP::sealed::_itemType [private]

Definition at line 27 of file NotificationData.h.

Windows::Foundation::EventRegistrationToken ScheduledNotificationsSampleCPP::sealed::_logicalDpiChangedToken [private]

Definition at line 61 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame ScheduledNotificationsSampleCPP::sealed::_outputFrame [private]

Definition at line 57 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ScheduledNotificationsSampleCPP::sealed::_outputFrameLoadedToken [private]

Definition at line 63 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ScheduledNotificationsSampleCPP::sealed::_pageLoadedHandlerToken [private]

Definition at line 60 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ScheduledNotificationsSampleCPP::sealed::_resizeHandlerToken [private]

Definition at line 64 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame ScheduledNotificationsSampleCPP::sealed::_scenariosFrame [private]

Definition at line 55 of file MainPage.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 32 of file ScenarioInput1.xaml.h.

NotificationDataSource ScheduledNotificationsSampleCPP::sealed::scheduledNotificationsBinding [private]

Definition at line 34 of file ScenarioInput2.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> ScheduledNotificationsSampleCPP::sealed::OutputFrameLoaded

Definition at line 45 of file MainPage.xaml.h.

event Windows::UI::Xaml::Data::PropertyChangedEventHandler ScheduledNotificationsSampleCPP::sealed::PropertyChanged

Definition at line 21 of file NotificationData.h.

The documentation for this class was generated from the following files:
  • Scheduled notifications/C#,C++/App.xaml.h
  • Scheduled notifications/C#,C++/MainPage.xaml.h
  • Scheduled notifications/C#,C++/NotificationData.h
  • Scheduled notifications/C#,C++/ScenarioInput1.xaml.h
  • Scheduled notifications/C#,C++/ScenarioInput2.xaml.h
  • Scheduled notifications/C#,C++/ScenarioList.xaml.h
  • Scheduled notifications/C#,C++/ScenarioOutput1.xaml.h
  • Scheduled notifications/C#,C++/ScenarioOutput2.xaml.h
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SConversion Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SConversion Struct Reference

List of all members.

Public Attributes

SConversion * pNext
WCHAR | szDest [MAX_PATH]
WCHAR | szSrc [MAX_PATH]

Detailed Description

Definition at line 42 of file Texconv.cpp.

Member Data Documentation

SConversion* SConversion::pNext

Definition at line 47 of file Texconv.cpp.

WCHAR SConversion::szDest[MAX_PATH]

Definition at line 45 of file Texconv.cpp.

WCHAR SConversion::szSrc[MAX_PATH]

Definition at line 44 of file Texconv.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/Texconv.cpp
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ScopedObject< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

ScopedObject< T > Class Template Reference

#include "scoped.h"

List of all members.

Public Member Functions

ScopedObject (T *p=0)
~ScopedObject ()
T * | Get () const
bool | IsNull () const
T ** | operator& ()
T & | operator* ()
T * | operator-> ()
void | Reset (T *p=0)

Private Member Functions

ScopedObject (const ScopedObject &)
ScopedObject & | operator= (const ScopedObject &)

Private Attributes

T * | _pointer

Detailed Description

template<class T>
class ScopedObject< T >

Definition at line 37 of file scoped.h.

Constructor & Destructor Documentation

template<class T>
ScopedObject< T >::ScopedObject ( T * p = 0 ) [inline, explicit]

Definition at line 40 of file scoped.h.

: _pointer(p) {}

template<class T>
ScopedObject< T >::~ScopedObject ( ) [inline]

Definition at line 41 of file scoped.h.

    {
        if ( _pointer )
        {
            _pointer->Release();
            _pointer = nullptr;
        }
    }

template<class T>
ScopedObject< T >::ScopedObject ( const ScopedObject< T > & ) [private]

Member Function Documentation

template<class T>
T* ScopedObject< T >::Get ( ) const [inline]

Definition at line 58 of file scoped.h.

{ return _pointer; }

template<class T>
bool ScopedObject< T >::IsNull ( ) const [inline]

Definition at line 50 of file scoped.h.

{ return (!_pointer); }

template<class T>
T** ScopedObject< T >::operator& ( ) [inline]

Definition at line 54 of file scoped.h.

{ return &_pointer; }

template<class T>
T& ScopedObject< T >::operator* ( ) [inline]

Definition at line 52 of file scoped.h.

{ return *_pointer; }

template<class T>
T* ScopedObject< T >::operator-> ( ) [inline]

Definition at line 53 of file scoped.h.

{ return _pointer; }

template<class T>
ScopedObject& ScopedObject< T >::operator= ( const ScopedObject< T > & ) [private]
template<class T>
void ScopedObject< T >::Reset ( T * p = 0 ) [inline]

Definition at line 56 of file scoped.h.

{ if ( _pointer ) { _pointer->Release(); } _pointer = p; }

Member Data Documentation

template<class T>
T* ScopedObject< T >::_pointer [private]

Definition at line 64 of file scoped.h.

The documentation for this class was generated from the following file:
  • Direct3D resource loading/C++/texconv/scoped.h
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ScreenQuadVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ScreenQuadVertex Struct Reference

#include "D3DPostProcessing.h"

List of all members.

Public Attributes

float4 pos
float2 tex

Detailed Description

Definition at line 26 of file D3DPostProcessing.h.

Member Data Documentation

float4 ScreenQuadVertex::pos

Definition at line 28 of file D3DPostProcessing.h.

float2 ScreenQuadVertex::tex

Definition at line 29 of file D3DPostProcessing.h.

The documentation for this struct was generated from the following file:
  • Direct3D post-processing effects/C++/D3DPostProcessing.h
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ScreenVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ScreenVertex Struct Reference

List of all members.

Public Attributes

FLOAT | pos [4]
FLOAT | tex [2]

Detailed Description

Definition at line 5 of file InvertModule.cpp.

Member Data Documentation

FLOAT ScreenVertex::pos

Definition at line 7 of file InvertModule.cpp.

FLOAT ScreenVertex::tex

Definition at line 8 of file InvertModule.cpp.

The documentation for this struct was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Invert/InvertModule.cpp
  • Media extensions/C++/MediaExtensions/Invert/InvertModule.cpp
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKANIMATION_DATA Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKANIMATION_DATA Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

XMFLOAT4 | Orientation
XMFLOAT3 | Scaling
XMFLOAT3 | Translation

Detailed Description

Definition at line 259 of file SDKMesh.h.

Member Data Documentation

XMFLOAT4 SDKANIMATION_DATA::Orientation

Definition at line 262 of file SDKMesh.h.

XMFLOAT3 SDKANIMATION_DATA::Scaling

Definition at line 263 of file SDKMesh.h.

XMFLOAT3 SDKANIMATION_DATA::Translation

Definition at line 261 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKANIMATION_FILE_HEADER Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKANIMATION_FILE_HEADER Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

UINT64 | AnimationDataOffset
UINT64 | AnimationDataSize
UINT | AnimationFPS
UINT | FrameTransformType
BYTE | IsBigEndian
UINT | NumAnimationKeys
UINT | NumFrames
UINT | Version

Detailed Description

Definition at line 247 of file SDKMesh.h.

Member Data Documentation

UINT64 SDKANIMATION_FILE_HEADER::AnimationDataOffset

Definition at line 256 of file SDKMesh.h.

UINT64 SDKANIMATION_FILE_HEADER::AnimationDataSize

Definition at line 255 of file SDKMesh.h.

UINT SDKANIMATION_FILE_HEADER::AnimationFPS

Definition at line 254 of file SDKMesh.h.

UINT SDKANIMATION_FILE_HEADER::FrameTransformType

Definition at line 251 of file SDKMesh.h.

BYTE SDKANIMATION_FILE_HEADER::IsBigEndian

Definition at line 250 of file SDKMesh.h.

UINT SDKANIMATION_FILE_HEADER::NumAnimationKeys

Definition at line 253 of file SDKMesh.h.

UINT SDKANIMATION_FILE_HEADER::NumFrames

Definition at line 252 of file SDKMesh.h.

UINT SDKANIMATION_FILE_HEADER::Version

Definition at line 249 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKANIMATION_FRAME_DATA Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKANIMATION_FRAME_DATA Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

union {
SDKANIMATION_DATA * AnimationData
UINT64 DataOffset
};
char FrameName [MAX_FRAME_NAME]

Detailed Description

Definition at line 266 of file SDKMesh.h.

Member Data Documentation

union { ... }
SDKANIMATION_DATA* SDKANIMATION_FRAME_DATA::AnimationData

Definition at line 272 of file SDKMesh.h.

UINT64 SDKANIMATION_FRAME_DATA::DataOffset

Definition at line 271 of file SDKMesh.h.

char SDKANIMATION_FRAME_DATA::FrameName[MAX_FRAME_NAME]

Definition at line 268 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKMesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Member Functions | Protected Attributes | Private Attributes

SDKMesh Class Reference

#include "SDKMesh.h"

List of all members.

Public Member Functions

SDKMesh ()
virtual | ~SDKMesh ()
bool | CheckLoadDone ()
virtual HRESULT | Create (ID3D11Device *d3dDevice, byte *data, uint32 byteCount, bool createAdjacencyIndices=false, bool copyStatic=false)
virtual HRESULT | Create (ID3D11Device *d3dDevice, WCHAR *filename, bool createAdjacencyIndices=false)
virtual void | Destroy ()
SDKMESH_FRAME * | FindFrame (char *name)
ID3D11Buffer * | GetAdjacencyIndexBuffer (uint32 mesh)
uint32 | GetAnimationKeyFromTime (double time)
bool | GetAnimationProperties (uint32 *numKeys, float *frameTime)
SDKMESH_FRAME * | GetFrame (uint32 frame)
ID3D11Buffer * | GetIndexBuffer (uint32 mesh)
ID3D11Buffer * | GetIndexBufferAt (uint32 indexBuffer)
DXGI_FORMAT | GetIndexBufferFormat (uint32 mesh)
SDKMeshIndexType | GetIndexType (uint32 mesh)
const CXMMATRIX | GetInfluenceMatrix (uint32 frameIndex)
SDKMESH_MATERIAL * | GetMaterial (uint32 material)
SDKMESH_MESH * | GetMesh (uint32 mesh)
XMFLOAT3 | GetMeshBoundingBoxCenter (uint32 mesh)
XMFLOAT3 | GetMeshBoundingBoxExtents (uint32 mesh)
const CXMMATRIX | GetMeshInfluenceMatrix (uint32 mesh, uint32 influence)
WCHAR * | GetMeshPath ()
uint32 | GetNumFrames ()
uint32 | GetNumIndexBuffers ()
uint64 | GetNumIndices (uint32 mesh)
uint32 | GetNumInfluences (uint32 mesh)
uint32 | GetNumMaterials ()
uint32 | GetNumMeshes ()
uint32 | GetNumSubsets (uint32 mesh)
uint32 | GetNumVertexBuffers ()
uint64 | GetNumVertices (uint32 mesh, uint32 vertexBuffer)
uint32 | GetOutstandingBufferResources ()
uint32 | GetOutstandingResources ()
byte * | GetRawIndicesAt (uint32 indexBuffer)
byte * | GetRawVerticesAt (uint32 vertexBuffer)
SDKMESH_SUBSET * | GetSubset (uint32 mesh, uint32 subset)
ID3D11Buffer * | GetVertexBuffer (uint32 mesh, uint32 vertexBuffer)
ID3D11Buffer * | GetVertexBufferAt (uint32 vertexBuffer)
uint32 | GetVertexStride (uint32 mesh, uint32 vertexBuffer)
const CXMMATRIX | GetWorldMatrix (uint32 frameIndex)
bool | HadLoadingError ()
bool | IsLoaded ()
bool | IsLoading ()
virtual HRESULT | LoadAnimation (WCHAR *filename)
virtual void | Render (ID3D11DeviceContext *d3dContext, UINT diffuseSlot=INVALID_SAMPLER_SLOT, UINT normalSlot=INVALID_SAMPLER_SLOT, UINT specularSlot=INVALID_SAMPLER_SLOT)
virtual void | RenderAdjacent (ID3D11DeviceContext *d3dContext, uint32 diffuseSlot=INVALID_SAMPLER_SLOT, uint32 normalSlot=INVALID_SAMPLER_SLOT, uint32 specularSlot=INVALID_SAMPLER_SLOT)
void | SetLoading (bool loading)
void | TransformBindPose (CXMMATRIX world)
void | TransformMesh (CXMMATRIX world, double time)

Static Public Member Functions

static D3D11_PRIMITIVE_TOPOLOGY | GetPrimitiveType (SDKMeshPrimitiveType primitiveType)

Protected Member Functions

virtual HRESULT | CreateFromFile (ID3D11Device *d3dDevice, WCHAR *filename, bool createAdjacencyIndices)
virtual HRESULT | CreateFromMemory (ID3D11Device *d3dDevice, byte *data, uint32 byteCount, bool createAdjacencyIndices, bool copyStatic)
HRESULT | CreateIndexBuffer (ID3D11Device *d3dDevice, SDKMESH_INDEX_BUFFER_HEADER *header, void *indices)
HRESULT | CreateVertexBuffer (ID3D11Device *d3dDevice, SDKMESH_VERTEX_BUFFER_HEADER *header, void *vertices)
void | LoadMaterials (ID3D11Device *d3dDevice, _In_reads_(numMaterials) SDKMESH_MATERIAL *materials, uint32 numMaterials)
void | RenderFrame (uint32 frame, bool adjacent, ID3D11DeviceContext *d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot)
void | RenderMesh (uint32 meshIndex, bool adjacent, ID3D11DeviceContext *d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot)
void | TransformBindPoseFrame (uint32 frame, CXMMATRIX parentWorld)
void | TransformFrame (uint32 frame, CXMMATRIX parentWorld, double time)
void | TransformFrameAbsolute (uint32 frame, double time)

Protected Attributes

SDKMESH_INDEX_BUFFER_HEADER * m_adjacencyIndexBufferArray
BYTE * | m_animationData
SDKANIMATION_FRAME_DATA * m_animationFrameData
SDKANIMATION_FILE_HEADER * m_animationHeader
XMMATRIX * | m_bindPoseFrameMatrices
SDKMESH_FRAME * m_frameArray
BYTE * | m_heapData
SDKMESH_INDEX_BUFFER_HEADER * m_indexBufferArray
BYTE ** | m_indices
SDKMESH_MATERIAL * m_materialArray
SDKMESH_MESH * m_meshArray
SDKMESH_HEADER * m_meshHeader
WCHAR | m_path [MAX_PATH]
BYTE * | m_staticMeshData
SDKMESH_SUBSET * m_subsetArray
XMMATRIX * | m_transformedFrameMatrices
SDKMESH_VERTEX_BUFFER_HEADER * m_vertexBufferArray
BYTE ** | m_vertices
XMMATRIX * | m_worldPoseFrameMatrices

Private Attributes

ID3D11DeviceContext * | m_d3dContext
ID3D11Device * | m_d3dDevice
HANDLE | m_hFile
HANDLE | m_hFileMappingObject
bool | m_loading
UINT | m_numOutstandingResources

Detailed Description

Definition at line 281 of file SDKMesh.h.

Constructor & Destructor Documentation

SDKMesh::SDKMesh ( )

Definition at line 632 of file SDKMesh.cpp.

                 : m_numOutstandingResources(0),
    m_loading(false),
    m_hFile(0),
    m_hFileMappingObject(0),
    m_meshHeader(nullptr),
    m_staticMeshData(nullptr),
    m_heapData(nullptr),
    m_adjacencyIndexBufferArray(nullptr),
    m_animationData(nullptr),
    m_animationHeader(nullptr),
    m_vertices(nullptr),
    m_indices(nullptr),
    m_bindPoseFrameMatrices(nullptr),
    m_transformedFrameMatrices(nullptr),
    m_worldPoseFrameMatrices(nullptr),
    m_d3dDevice(nullptr)
{
}

SDKMesh::~SDKMesh ( ) [virtual]

Definition at line 651 of file SDKMesh.cpp.

{
    Destroy();
}

Member Function Documentation

bool SDKMesh::CheckLoadDone ( )

Definition at line 1131 of file SDKMesh.cpp.

{
    if (0 == GetOutstandingResources())
    {
        m_loading = false;
        return true;
    }

    return false;
}

HRESULT SDKMesh::Create | ( | ID3D11Device * | d3dDevice,
 |  | WCHAR * | filename,
 |  | bool | createAdjacencyIndices = false |
 | ) |  |  | [virtual]

Definition at line 656 of file SDKMesh.cpp.

{
    Destroy();
    return CreateFromFile(d3dDevice, filename, createAdjacencyIndices);
}

HRESULT SDKMesh::Create | ( | ID3D11Device * | d3dDevice,
 |  | byte * | data,
 |  | uint32 | byteCount,
 |  | bool | createAdjacencyIndices = false,
 |  | bool | copyStatic = false |
 | ) |  |  | [virtual]

Definition at line 662 of file SDKMesh.cpp.

{
    Destroy();
    return CreateFromMemory(d3dDevice, data, byteCount, createAdjacencyIndices, copyStatic);
}

HRESULT SDKMesh::CreateFromFile | ( | ID3D11Device * | d3dDevice,
 |  | WCHAR * | filename,
 |  | bool | createAdjacencyIndices |
 | ) |  |  | [protected, virtual]

Definition at line 92 of file SDKMesh.cpp.

{
    HRESULT hr = S_OK;

    m_hFile = CreateFile2(filename, GENERIC_READ, FILE_SHARE_READ, OPEN_EXISTING, nullptr);

    if (INVALID_HANDLE_VALUE == m_hFile)
    {
        DWORD errorCode = GetLastError();
        const int msgSize = 512;
        WCHAR message[msgSize];

        DWORD result = FormatMessage(
            FORMAT_MESSAGE_FROM_SYSTEM | FORMAT_MESSAGE_IGNORE_INSERTS,
            nullptr,
            errorCode,
            MAKELANGID(LANG_NEUTRAL, SUBLANG_DEFAULT),
            message,
            msgSize,
            nullptr
            );
        if ((result > 0) && (result < msgSize))
        {
            OutputDebugString(message);
        }

        return E_FAIL;
    }

    // Store the directory path without the filename
    wcsncpy_s(m_path, MAX_PATH, filename, wcslen(filename));
    WCHAR* lastBSlash = wcsrchr(m_path, L'\\');
    if (lastBSlash)
    {
        *(lastBSlash + 1) = L'\0';
    }
    else
    {
        *m_path = L'\0';
    }

    // Get the file size
    FILE_STANDARD_INFO fileInfo = {0};
    if (!GetFileInformationByHandleEx(m_hFile, FileStandardInfo, &fileInfo, sizeof(fileInfo)))
    {
        throw ref new Platform::FailureException();
    }

    if (fileInfo.EndOfFile.HighPart != 0)
    {
        throw ref new Platform::OutOfMemoryException();
    }

    uint32 byteCount = fileInfo.EndOfFile.LowPart;

    // Allocate memory
    m_staticMeshData = new byte[byteCount];
    if (!m_staticMeshData)
    {
        CloseHandle(m_hFile);
        return E_OUTOFMEMORY;
    }

    // Read in the file
    DWORD bytesRead;
    if (!ReadFile(m_hFile, m_staticMeshData, byteCount, &bytesRead, nullptr))
    {
        hr = E_FAIL;
    }

    CloseHandle(m_hFile);

    if (SUCCEEDED(hr))
    {
        hr = CreateFromMemory(d3dDevice, m_staticMeshData, byteCount, createAdjacencyIndices, false);
        if (FAILED(hr))
        {
            delete[] m_staticMeshData;
        }
    }

    return hr;
}

HRESULT SDKMesh::CreateFromMemory | ( | ID3D11Device * | d3dDevice,
 |  | byte * | data,
 |  | uint32 | byteCount,
 |  | bool | createAdjacencyIndices,
 |  | bool | copyStatic |
 | ) |  |  | [protected, virtual]

Definition at line 176 of file SDKMesh.cpp.

{
    HRESULT hr = E_FAIL;
    XMFLOAT3 lower;
    XMFLOAT3 upper;

    m_d3dDevice = d3dDevice;

    m_numOutstandingResources = 0;

    if (copyStatic)
    {
        SDKMESH_HEADER* header = (SDKMESH_HEADER*)data;

        size_t staticSize = static_cast<size_t>(header->HeaderSize + header->NonBufferDataSize);
        m_heapData = new BYTE[staticSize];
        if (m_heapData == nullptr)
        {
            return hr;
        }
        m_staticMeshData = m_heapData;
        CopyMemory(m_staticMeshData, data, staticSize);
    }
    else
    {
        m_heapData = data;
        m_staticMeshData = data;
    }

    // Pointer fixup
    m_meshHeader = (SDKMESH_HEADER*)m_staticMeshData;
    m_vertexBufferArray = (SDKMESH_VERTEX_BUFFER_HEADER*)(m_staticMeshData + m_meshHeader->VertexStreamHeadersOffset);
    m_indexBufferArray = (SDKMESH_INDEX_BUFFER_HEADER*)(m_staticMeshData + m_meshHeader->IndexStreamHeadersOffset);
    m_meshArray = (SDKMESH_MESH*)(m_staticMeshData + m_meshHeader->MeshDataOffset);
    m_subsetArray = (SDKMESH_SUBSET*)(m_staticMeshData + m_meshHeader->SubsetDataOffset);
    m_frameArray = (SDKMESH_FRAME*)(m_staticMeshData + m_meshHeader->FrameDataOffset);
    m_materialArray = (SDKMESH_MATERIAL*)(m_staticMeshData + m_meshHeader->MaterialDataOffset);

    // Setup subsets
    for (uint32 i = 0; i < m_meshHeader->NumMeshes; i++)
    {
        m_meshArray[i].Subsets = (uint32*)(m_staticMeshData + m_meshArray[i].SubsetOffset);
        m_meshArray[i].FrameInfluences = (uint32*)(m_staticMeshData + m_meshArray[i].FrameInfluenceOffset);
    }

    // error condition
    if (m_meshHeader->Version != SDKMESH_FILE_VERSION)
    {
        hr = E_NOINTERFACE;
        goto Error;
    }

    // Setup buffer data pointer
    byte* bufferData = data + m_meshHeader->HeaderSize + m_meshHeader->NonBufferDataSize;

    // Get the start of the buffer data
    uint64 bufferDataStart = m_meshHeader->HeaderSize + m_meshHeader->NonBufferDataSize;

    // Create vertex buffers
    m_vertices = new byte*[m_meshHeader->NumVertexBuffers];
    for (uint32 i = 0; i < m_meshHeader->NumVertexBuffers; i++)
    {
        byte* vertices = nullptr;
        vertices = (byte*)(bufferData + (m_vertexBufferArray[i].DataOffset - bufferDataStart));
        CreateVertexBuffer(d3dDevice, &m_vertexBufferArray[i], vertices);
        m_vertices[i] = vertices;
    }

    // Create index buffers
    m_indices = new byte*[m_meshHeader->NumIndexBuffers];
    for (uint32 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
    {
        byte* indices = nullptr;
        indices = (byte*)(bufferData + (m_indexBufferArray[i].DataOffset - bufferDataStart));
        CreateIndexBuffer(d3dDevice, &m_indexBufferArray[i], indices);
        m_indices[i] = indices;
    }

    // Load Materials
    if (d3dDevice)
    {
        LoadMaterials(d3dDevice, m_materialArray, m_meshHeader->NumMaterials);
    }

    // Create a place to store our bind pose frame matrices
    m_bindPoseFrameMatrices = new XMMATRIX[m_meshHeader->NumFrames];
    if (!m_bindPoseFrameMatrices)
    {
        goto Error;
    }

    // Create a place to store our transformed frame matrices
    m_transformedFrameMatrices = new XMMATRIX[m_meshHeader->NumFrames];
    if (!m_transformedFrameMatrices)
    {
        goto Error;
    }
    m_worldPoseFrameMatrices = new XMMATRIX[m_meshHeader->NumFrames];
    if (!m_worldPoseFrameMatrices)
    {
        goto Error;
    }

    SDKMESH_SUBSET* subset = nullptr;
    D3D11_PRIMITIVE_TOPOLOGY primitiveType;

    // update bounding volume
    SDKMESH_MESH* currentMesh = &m_meshArray[0];
    int tris = 0;
    for (uint32 mesh = 0; mesh < m_meshHeader->NumMeshes; ++mesh)
    {
        lower.x = XMVectorGetX(g_XMFltMax); lower.y = XMVectorGetX(g_XMFltMax); lower.z = XMVectorGetX(g_XMFltMax);
        upper.x = -XMVectorGetX(g_XMFltMax); upper.y = -XMVectorGetX(g_XMFltMax); upper.z = -XMVectorGetX(g_XMFltMax);
        currentMesh = GetMesh(mesh);

        int indsize;
        if (m_indexBufferArray[currentMesh->IndexBuffer].IndexType == static_cast<uint32>(SDKMeshIndexType::Bits16))
        {
            indsize = 2;
        }
        else
        {
            indsize = 4;
        }

        for (uint32 subsetIndex = 0; subsetIndex < currentMesh->NumSubsets; subsetIndex++)
        {
            subset = GetSubset(mesh, subsetIndex); // &m_pSubsetArray[currentMesh->pSubsets[subset]];

            primitiveType = GetPrimitiveType(static_cast<SDKMeshPrimitiveType>(subset->PrimitiveType));
            assert(primitiveType == D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST); // only triangle lists are handled.

            uint32 indexCount = (uint32)subset->IndexCount;
            uint32 indexStart = (uint32)subset->IndexStart;

            uint32* ind = (uint32*)m_indices[currentMesh->IndexBuffer];
            float* verts = (float*)m_vertices[currentMesh->VertexBuffers[0]];
            uint32 stride = (uint32)m_vertexBufferArray[currentMesh->VertexBuffers[0]].StrideBytes;
            assert (stride % 4 == 0);
            stride /= 4;
            for (uint32 vertind = indexStart; vertind < indexStart + indexCount; ++vertind)
            {
                uint32 currentIndex = 0;
                if (indsize == 2)
                {
                    uint32 ind_div2 = vertind / 2;
                    currentIndex = ind[ind_div2];
                    if ((vertind % 2) == 0)
                    {
                        currentIndex = currentIndex << 16;
                        currentIndex = currentIndex >> 16;
                    }
                    else
                    {
                        currentIndex = currentIndex >> 16;
                    }
                }
                else
                {
                    currentIndex = ind[vertind];
                }
                tris++;
                XMFLOAT3* pt = (XMFLOAT3*)&(verts[stride * currentIndex]);
                if (pt->x < lower.x)
                {
                    lower.x = pt->x;
                }
                if (pt->y < lower.y)
                {
                    lower.y = pt->y;
                }
                if (pt->z < lower.z)
                {
                    lower.z = pt->z;
                }
                if (pt->x > upper.x)
                {
                    upper.x = pt->x;
                }
                if (pt->y > upper.y)
                {
                    upper.y = pt->y;
                }
                if (pt->z > upper.z)
                {
                    upper.z = pt->z;
                }
            }
        }
        XMVECTOR u = XMLoadFloat3(&upper);
        XMVECTOR l = XMLoadFloat3(&lower);
        XMVECTOR half = XMVectorSubtract(u, l);
        XMVectorScale(half, 0.5f);
        XMStoreFloat3(&currentMesh->BoundingBoxExtents, half);
        half = XMVectorAdd(l, half);
        XMStoreFloat3(&currentMesh->BoundingBoxCenter, half);
    }
    // Update
    hr = S_OK;
Error:
    return hr;
}

HRESULT SDKMesh::CreateIndexBuffer | ( | ID3D11Device * | d3dDevice,
 |  | SDKMESH_INDEX_BUFFER_HEADER * | header,
 |  | void * | indices |
 | ) |  |  | [protected]

Definition at line 72 of file SDKMesh.cpp.

{
    HRESULT hr = S_OK;
    header->DataOffset = 0;

    // Index Buffer
    D3D11_BUFFER_DESC bufferDesc;
    bufferDesc.ByteWidth = static_cast<uint32>(header->SizeBytes);
    bufferDesc.Usage = D3D11_USAGE_DEFAULT;
    bufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
    bufferDesc.CPUAccessFlags = 0;
    bufferDesc.MiscFlags = 0;

    D3D11_SUBRESOURCE_DATA initData;
    initData.pSysMem = indices;
    hr = d3dDevice->CreateBuffer(&bufferDesc, &initData, &header->IndexBuffer);

    return hr;
}

HRESULT SDKMesh::CreateVertexBuffer | ( | ID3D11Device * | d3dDevice,
 |  | SDKMESH_VERTEX_BUFFER_HEADER * | header,
 |  | void * | vertices |
 | ) |  |  | [protected]

Definition at line 52 of file SDKMesh.cpp.

{
    HRESULT hr = S_OK;
    header->DataOffset = 0;

    // Vertex Buffer
    D3D11_BUFFER_DESC bufferDesc;
    bufferDesc.ByteWidth = static_cast<uint32>(header->SizeBytes);
    bufferDesc.Usage = D3D11_USAGE_DEFAULT;
    bufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
    bufferDesc.CPUAccessFlags = 0;
    bufferDesc.MiscFlags = 0;

    D3D11_SUBRESOURCE_DATA initData;
    initData.pSysMem = vertices;
    hr = d3dDevice->CreateBuffer(&bufferDesc, &initData, &header->VertexBuffer);

    return hr;
}

void SDKMesh::Destroy ( ) [virtual]

Definition at line 728 of file SDKMesh.cpp.

{
    if (m_staticMeshData != nullptr)
    {
        if (m_materialArray != nullptr)
        {
            for (uint64 m = 0; m < m_meshHeader->NumMaterials; m++)
            {
                ID3D11Resource* resource = nullptr;
                if (m_materialArray[m].DiffuseRV && !IsErrorResource(m_materialArray[m].DiffuseRV))
                {
                    m_materialArray[m].DiffuseRV->GetResource(&resource);
                    SAFE_RELEASE(resource);
                    SAFE_RELEASE(m_materialArray[m].DiffuseRV);
                }
                if (m_materialArray[m].NormalRV && !IsErrorResource(m_materialArray[m].NormalRV))
                {
                    m_materialArray[m].NormalRV->GetResource(&resource);
                    SAFE_RELEASE(resource);
                    SAFE_RELEASE(m_materialArray[m].NormalRV);
                }
                if (m_materialArray[m].SpecularRV && !IsErrorResource(m_materialArray[m].SpecularRV))
                {
                    m_materialArray[m].SpecularRV->GetResource(&resource);
                    SAFE_RELEASE(resource);
                    SAFE_RELEASE(m_materialArray[m].SpecularRV);
                }
            }
        }
    }

    if (m_adjacencyIndexBufferArray != nullptr)
    {
        for (uint64 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
        {
            SAFE_RELEASE(m_adjacencyIndexBufferArray[i].IndexBuffer);
        }
    }

    if (m_indexBufferArray != nullptr)
    {
        for (uint64 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
        {
            SAFE_RELEASE(m_indexBufferArray[i].IndexBuffer);
        }
    }

    if (m_vertexBufferArray != nullptr)
    {
        for (uint64 i = 0; i < m_meshHeader->NumVertexBuffers; i++)
        {
            SAFE_RELEASE(m_vertexBufferArray[i].VertexBuffer);
        }
    }

    SAFE_DELETE_ARRAY(m_adjacencyIndexBufferArray);
    SAFE_DELETE_ARRAY(m_heapData);

    m_staticMeshData = nullptr;

    SAFE_DELETE_ARRAY(m_animationData);
    SAFE_DELETE_ARRAY(m_bindPoseFrameMatrices);
    SAFE_DELETE_ARRAY(m_transformedFrameMatrices);
    SAFE_DELETE_ARRAY(m_worldPoseFrameMatrices);
    SAFE_DELETE_ARRAY(m_vertices);
    SAFE_DELETE_ARRAY(m_indices);

    m_meshHeader = nullptr;
    m_vertexBufferArray = nullptr;
    m_indexBufferArray = nullptr;
    m_meshArray = nullptr;
    m_subsetArray = nullptr;
    m_frameArray = nullptr;
    m_materialArray = nullptr;
    m_animationHeader = nullptr;
    m_animationFrameData = nullptr;
    m_d3dDevice = nullptr;
}

SDKMESH_FRAME * SDKMesh::FindFrame ( char * name )

Definition at line 1028 of file SDKMesh.cpp.

{
    for (uint32 i = 0; i < m_meshHeader->NumFrames; i++)
    {
        if (_stricmp(m_frameArray[i].Name, name) == 0)
        {
            return &m_frameArray[i];
        }
    }

    return nullptr;
}

ID3D11Buffer * SDKMesh::GetAdjacencyIndexBuffer ( uint32 mesh )

Definition at line 916 of file SDKMesh.cpp.

{
    return m_adjacencyIndexBufferArray[m_meshArray[mesh].IndexBuffer].IndexBuffer;
}

uint32 SDKMesh::GetAnimationKeyFromTime ( double time )

Definition at line 1191 of file SDKMesh.cpp.

{
    if (m_animationHeader == nullptr)
    {
        return 0;
    }

    uint32 tick = static_cast<uint32>(m_animationHeader->AnimationFPS * time);

    tick = tick % (m_animationHeader->NumAnimationKeys - 1);
    tick++;

    return tick;
}

bool SDKMesh::GetAnimationProperties | ( | uint32 * | numKeys,
 |  | float * | frameTime
 | ) |  |

Definition at line 1206 of file SDKMesh.cpp.

{
    if (m_animationHeader == nullptr)
    {
        return false;
    }

    *numKeys = m_animationHeader->NumAnimationKeys;
    *frameTime = 1.0f / static_cast<float>(m_animationHeader->AnimationFPS);

    return true;
}

SDKMESH_FRAME * SDKMesh::GetFrame ( uint32 frame )

Definition at line 1016 of file SDKMesh.cpp.

{
    assert(frame < m_meshHeader->NumFrames);

    if (frame < m_meshHeader->NumFrames)
    {
        return &m_frameArray[frame];
    }

    return nullptr;
}

ID3D11Buffer * SDKMesh::GetIndexBuffer ( uint32 mesh )

Definition at line 906 of file SDKMesh.cpp.

{
    return m_indexBufferArray[m_meshArray[mesh].IndexBuffer].IndexBuffer;
}

ID3D11Buffer * SDKMesh::GetIndexBufferAt ( uint32 indexBuffer )

Definition at line 971 of file SDKMesh.cpp.

{
    return m_indexBufferArray[indexBuffer].IndexBuffer;
}

DXGI_FORMAT SDKMesh::GetIndexBufferFormat ( uint32 mesh )

Definition at line 888 of file SDKMesh.cpp.

{
    switch (m_indexBufferArray[m_meshArray[mesh].IndexBuffer].IndexType)
    {
        case SDKMeshIndexType::Bits16:
            return DXGI_FORMAT_R16_UINT;
        case SDKMeshIndexType::Bits32:
            return DXGI_FORMAT_R32_UINT;
    };

    return DXGI_FORMAT_R16_UINT;
}

SDKMeshIndexType SDKMesh::GetIndexType ( uint32 mesh )

Definition at line 911 of file SDKMesh.cpp.

{
    return static_cast<SDKMeshIndexType>(m_indexBufferArray[m_meshArray[mesh].IndexBuffer].IndexType);
}

const CXMMATRIX SDKMesh::GetInfluenceMatrix ( uint32 frameIndex )

Definition at line 1230 of file SDKMesh.cpp.

{
    return m_transformedFrameMatrices[frameIndex];
}

SDKMESH_MATERIAL * SDKMesh::GetMaterial ( uint32 material )

Definition at line 986 of file SDKMesh.cpp.

{
    return &m_materialArray[material];
}

SDKMESH_MESH * SDKMesh::GetMesh ( uint32 mesh )

Definition at line 991 of file SDKMesh.cpp.

{
    return &m_meshArray[mesh];
}

XMFLOAT3 SDKMesh::GetMeshBoundingBoxCenter ( uint32 mesh )

Definition at line 1051 of file SDKMesh.cpp.

{
    return m_meshArray[mesh].BoundingBoxCenter;
}

XMFLOAT3 SDKMesh::GetMeshBoundingBoxExtents ( uint32 mesh )

Definition at line 1056 of file SDKMesh.cpp.

{
    return m_meshArray[mesh].BoundingBoxExtents;
}

const CXMMATRIX SDKMesh::GetMeshInfluenceMatrix | ( | uint32 | mesh,
 |  | uint32 | influence
 | ) |  |

Definition at line 1219 of file SDKMesh.cpp.

{
    uint32 frame = m_meshArray[mesh].FrameInfluences[influence];
    return m_transformedFrameMatrices[frame];
}

WCHAR * SDKMesh::GetMeshPath ( )

Definition at line 921 of file SDKMesh.cpp.

{
    return m_path;
}

uint32 SDKMesh::GetNumFrames ( )

Definition at line 1011 of file SDKMesh.cpp.

{
    return m_meshHeader->NumFrames;
}

uint32 SDKMesh::GetNumIndexBuffers ( )

Definition at line 956 of file SDKMesh.cpp.

{
    if (!m_meshHeader)
    {
        return 0;
    }

    return m_meshHeader->NumIndexBuffers;
}

uint64 SDKMesh::GetNumIndices ( uint32 mesh )

Definition at line 1046 of file SDKMesh.cpp.

{
    return m_indexBufferArray[m_meshArray[mesh].IndexBuffer].NumIndices;
}

uint32 SDKMesh::GetNumInfluences ( uint32 mesh )

Definition at line 1186 of file SDKMesh.cpp.

{
    return m_meshArray[mesh].NumFrameInfluences;
}

uint32 SDKMesh::GetNumMaterials ( )

Definition at line 936 of file SDKMesh.cpp.

{
    if (!m_meshHeader)
    {
        return 0;
    }

    return m_meshHeader->NumMaterials;
}

uint32 SDKMesh::GetNumMeshes ( )

Definition at line 926 of file SDKMesh.cpp.

{
    if (!m_meshHeader)
    {
        return 0;
    }

    return m_meshHeader->NumMeshes;
}

uint32 SDKMesh::GetNumSubsets ( uint32 mesh )

Definition at line 996 of file SDKMesh.cpp.

{
    return m_meshArray[mesh].NumSubsets;
}

uint32 SDKMesh::GetNumVertexBuffers ( )

Definition at line 946 of file SDKMesh.cpp.

{
    if (!m_meshHeader)
    {
        return 0;
    }

    return m_meshHeader->NumVertexBuffers;
}

uint64 SDKMesh::GetNumVertices | ( | uint32 | mesh,
 |  | uint32 | vertexBuffer
 | ) |  |

Definition at line 1041 of file SDKMesh.cpp.

{
    return m_vertexBufferArray[m_meshArray[mesh].VertexBuffers[vertexBuffer]].NumVertices;
}

uint32 SDKMesh::GetOutstandingBufferResources ( )

Definition at line 1104 of file SDKMesh.cpp.

{
    uint32 outstandingResources = 0;
    if (m_meshHeader == nullptr)
    {
        return 1;
    }

    for (uint32 i = 0; i < m_meshHeader->NumVertexBuffers; i++)
    {
        if ((m_vertexBufferArray[i].VertexBuffer == nullptr) && !IsErrorResource(m_vertexBufferArray[i].VertexBuffer))
        {
            outstandingResources++;
        }
    }

    for (uint32 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
    {
        if ((m_indexBufferArray[i].IndexBuffer == nullptr) && !IsErrorResource(m_indexBufferArray[i].IndexBuffer))
        {
            outstandingResources++;
        }
    }

    return outstandingResources;
}

uint32 SDKMesh::GetOutstandingResources ( )

Definition at line 1061 of file SDKMesh.cpp.

{
    uint32 outstandingResources = 0;
    if (m_meshHeader == nullptr)
    {
        return 1;
    }

    outstandingResources += GetOutstandingBufferResources();

    if (m_d3dDevice != nullptr)
    {
        for (uint32 i = 0; i < m_meshHeader->NumMaterials; i++)
        {
            if (m_materialArray[i].DiffuseTextureName[0] != 0)
            {
                if (!m_materialArray[i].DiffuseRV && !IsErrorResource(m_materialArray[i].DiffuseRV))
                {
                    outstandingResources++;
                }
            }

            if (m_materialArray[i].NormalTextureName[0] != 0)
            {
                if (!m_materialArray[i].NormalRV && !IsErrorResource(m_materialArray[i].NormalRV))
                {
                    outstandingResources++;
                }
            }

            if (m_materialArray[i].SpecularTextureName[0] != 0)
            {
                if (!m_materialArray[i].SpecularRV && !IsErrorResource(m_materialArray[i].SpecularRV))
                {
                    outstandingResources++;
                }
            }
        }
    }

    return outstandingResources;
}

D3D11_PRIMITIVE_TOPOLOGY SDKMesh::GetPrimitiveType ( SDKMeshPrimitiveType primitiveType ) [static]

Definition at line 850 of file SDKMesh.cpp.

{
    D3D11_PRIMITIVE_TOPOLOGY returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST;

    switch (primitiveType)
    {
        case SDKMeshPrimitiveType::TriangleList:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST;
            break;
        case SDKMeshPrimitiveType::TriangleStrip:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP;
            break;
        case SDKMeshPrimitiveType::LineList:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_LINELIST;
            break;
        case SDKMeshPrimitiveType::LineStrip:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_LINESTRIP;
            break;
        case SDKMeshPrimitiveType::PointList:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_POINTLIST;
            break;
        case SDKMeshPrimitiveType::TriangleListAdjacent:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST_ADJ;
            break;
        case SDKMeshPrimitiveType::TriangleStripAdjacent:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP_ADJ;
            break;
        case SDKMeshPrimitiveType::LineListAdjacent:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_LINELIST_ADJ;
            break;
        case SDKMeshPrimitiveType::LineStripAdjacent:
            returnType = D3D11_PRIMITIVE_TOPOLOGY_LINESTRIP_ADJ;
            break;
    };

    return returnType;
}

byte * SDKMesh::GetRawIndicesAt ( uint32 indexBuffer )

Definition at line 981 of file SDKMesh.cpp.

{
    return m_indices[indexBuffer];
}

byte * SDKMesh::GetRawVerticesAt ( uint32 vertexBuffer )

Definition at line 976 of file SDKMesh.cpp.

{
    return m_vertices[vertexBuffer];
}

SDKMESH_SUBSET * SDKMesh::GetSubset | ( | uint32 | mesh,
 |  | uint32 | subset
 | ) |  |

Definition at line 1001 of file SDKMesh.cpp.

{
    return &m_subsetArray[m_meshArray[mesh].Subsets[subset]];
}

ID3D11Buffer * SDKMesh::GetVertexBuffer | ( | uint32 | mesh,
 |  | uint32 | vertexBuffer
 | ) |  |

Definition at line 901 of file SDKMesh.cpp.

{
    return m_vertexBufferArray[m_meshArray[mesh].VertexBuffers[vertexBuffer]].VertexBuffer;
}

ID3D11Buffer * SDKMesh::GetVertexBufferAt ( uint32 vertexBuffer )

Definition at line 966 of file SDKMesh.cpp.

{
    return m_vertexBufferArray[vertexBuffer].VertexBuffer;
}

uint32 SDKMesh::GetVertexStride | ( | uint32 | mesh,
 |  | uint32 | vertexBuffer
 | ) |  |

Definition at line 1006 of file SDKMesh.cpp.

{
    return static_cast<uint32>(m_vertexBufferArray[m_meshArray[mesh].VertexBuffers[vertexBuffer]].StrideBytes);
}

const CXMMATRIX SDKMesh::GetWorldMatrix ( uint32 frameIndex )

Definition at line 1225 of file SDKMesh.cpp.

{
    return m_worldPoseFrameMatrices[frameIndex];
}

bool SDKMesh::HadLoadingError ( )

Definition at line 1162 of file SDKMesh.cpp.

{
    if (m_meshHeader != nullptr)
    {
        for (uint32 i = 0; i < m_meshHeader->NumVertexBuffers; i++)
        {
            if (IsErrorResource(m_vertexBufferArray[i].VertexBuffer))
            {
                return true;
            }
        }

        for (uint32 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
        {
            if (IsErrorResource(m_indexBufferArray[i].IndexBuffer))
            {
                return true;
            }
        }
    }

    return false;
}

bool SDKMesh::IsLoaded ( )

Definition at line 1142 of file SDKMesh.cpp.

{
    if (m_staticMeshData && !m_loading)
    {
        return true;
    }

    return false;
}

bool SDKMesh::IsLoading ( )

Definition at line 1152 of file SDKMesh.cpp.

{
    return m_loading;
}

HRESULT SDKMesh::LoadAnimation ( WCHAR * filename ) [virtual]

Definition at line 668 of file SDKMesh.cpp.

{
    HRESULT hr = E_FAIL;
    DWORD bytesRead = 0;
    LARGE_INTEGER move;
    HANDLE fileHandle = CreateFile2(filename, GENERIC_READ, FILE_SHARE_READ, OPEN_EXISTING, nullptr);

    if (INVALID_HANDLE_VALUE == fileHandle)
    {
        return E_FAIL;
    }

    SDKANIMATION_FILE_HEADER fileHeader;
    if (!ReadFile(fileHandle, &fileHeader, sizeof(SDKANIMATION_FILE_HEADER), &bytesRead, nullptr))
    {
        goto Error;
    }

    SAFE_DELETE_ARRAY(m_animationData);
    m_animationData = new BYTE[static_cast<size_t>((sizeof(SDKANIMATION_FILE_HEADER) + fileHeader.AnimationDataSize))];
    if (m_animationData == nullptr)
    {
        hr = E_OUTOFMEMORY;
        goto Error;
    }

    move.QuadPart = 0;
    if (!SetFilePointerEx(fileHandle, move, nullptr, FILE_BEGIN))
    {
        goto Error;
    }

    if (!ReadFile(fileHandle, m_animationData, static_cast<DWORD>(sizeof(SDKANIMATION_FILE_HEADER) + fileHeader.AnimationDataSize),
            &bytesRead, nullptr))
    {
        goto Error;
    }

    // pointer fixup
    m_animationHeader = (SDKANIMATION_FILE_HEADER*)m_animationData;
    m_animationFrameData = (SDKANIMATION_FRAME_DATA*)(m_animationData + m_animationHeader->AnimationDataOffset);

    uint64 baseOffset = sizeof(SDKANIMATION_FILE_HEADER);
    for (uint32 i = 0; i < m_animationHeader->NumFrames; i++)
    {
        m_animationFrameData[i].AnimationData = (SDKANIMATION_DATA*)(m_animationData + m_animationFrameData[i].DataOffset + baseOffset);
        SDKMESH_FRAME* frame = FindFrame(m_animationFrameData[i].FrameName);
        if (frame)
        {
            frame->AnimationDataIndex = i;
        }
    }

    hr = S_OK;

Error:
    CloseHandle(fileHandle);
    return hr;
}

void SDKMesh::LoadMaterials | ( | ID3D11Device * | d3dDevice,
 |  | _In_reads_(numMaterials) SDKMESH_MATERIAL * | materials,
 |  | uint32 | numMaterials |
 | ) |  |  | [protected]

Definition at line 23 of file SDKMesh.cpp.

{
    BasicLoader^ loader = ref new BasicLoader(d3dDevice);

    wchar_t path[MAX_PATH];
    wchar_t texturePath[MAX_PATH];
    size_t convertedChars = 0;

        // This is a simple Mesh format that doesn't reuse texture data
        for (uint32 m = 0; m < numMaterials; m++)
        {
            materials[m].DiffuseTexture = nullptr;
            materials[m].NormalTexture = nullptr;
            materials[m].SpecularTexture = nullptr;
            materials[m].DiffuseRV = nullptr;
            materials[m].NormalRV = nullptr;
            materials[m].SpecularRV = nullptr;

            // load textures
            if (materials[m].DiffuseTextureName[0] != 0)
            {
                size_t size = strlen(materials[m].DiffuseTextureName) + 1;
                mbstowcs_s(&convertedChars, texturePath, size, materials[m].DiffuseTextureName, _TRUNCATE);
                swprintf_s(path, MAX_PATH, L"Media\\Textures\\%s", texturePath);
                loader->LoadTexture(ref new Platform::String(path), nullptr, &materials[m].DiffuseRV);
            }
        }
}

virtual void SDKMesh::Render | ( | ID3D11DeviceContext * | d3dContext,
 |  | UINT | diffuseSlot = INVALID_SAMPLER_SLOT,
 |  | UINT | normalSlot = INVALID_SAMPLER_SLOT,
 |  | UINT | specularSlot = INVALID_SAMPLER_SLOT |
 | ) |  |  | [virtual]
void SDKMesh::RenderAdjacent | ( | ID3D11DeviceContext * | d3dContext,
 |  | uint32 | diffuseSlot = INVALID_SAMPLER_SLOT,
 |  | uint32 | normalSlot = INVALID_SAMPLER_SLOT,
 |  | uint32 | specularSlot = INVALID_SAMPLER_SLOT |
 | ) |  |  | [virtual]

Definition at line 845 of file SDKMesh.cpp.

{
    RenderFrame(0, true, d3dContext, diffuseSlot, normalSlot, specularSlot);
}

void SDKMesh::RenderFrame | ( | uint32 | frame,
 |  | bool | adjacent,
 |  | ID3D11DeviceContext * | d3dContext,
 |  | uint32 | diffuseSlot,
 |  | uint32 | normalSlot,
 |  | uint32 | specularSlot |
 | ) |  |  | [protected]

Definition at line 607 of file SDKMesh.cpp.

{
    if (!m_staticMeshData || !m_frameArray)
    {
        return;
    }

    if (m_frameArray[frame].Mesh != INVALID_MESH)
    {
        RenderMesh(m_frameArray[frame].Mesh, adjacent, d3dContext, diffuseSlot, normalSlot, specularSlot);
    }

    // Render our children
    if (m_frameArray[frame].ChildFrame != INVALID_FRAME)
    {
        RenderFrame(m_frameArray[frame].ChildFrame, adjacent, d3dContext, diffuseSlot, normalSlot, specularSlot);
    }

    // Render our siblings
    if (m_frameArray[frame].SiblingFrame != INVALID_FRAME)
    {
        RenderFrame(m_frameArray[frame].SiblingFrame, adjacent, d3dContext, diffuseSlot, normalSlot, specularSlot);
    }
}

void SDKMesh::RenderMesh | ( | uint32 | meshIndex,
 |  | bool | adjacent,
 |  | ID3D11DeviceContext * | d3dContext,
 |  | uint32 | diffuseSlot,
 |  | uint32 | normalSlot,
 |  | uint32 | specularSlot |
 | ) |  |  | [protected]

Definition at line 496 of file SDKMesh.cpp.

{
    if (0 < GetOutstandingBufferResources())
    {
        return;
    }

    SDKMESH_MESH* mesh = &m_meshArray[meshIndex];
    uint32 strides[MAX_D3D11_VERTEX_STREAMS];
    uint32 offsets[MAX_D3D11_VERTEX_STREAMS];
    ID3D11Buffer* vertexBuffer[MAX_D3D11_VERTEX_STREAMS];

    ZeroMemory(strides, sizeof(uint32) * MAX_D3D11_VERTEX_STREAMS);
    ZeroMemory(offsets, sizeof(uint32) * MAX_D3D11_VERTEX_STREAMS);
    ZeroMemory(vertexBuffer, sizeof(ID3D11Buffer*) * MAX_D3D11_VERTEX_STREAMS);

    if (mesh->NumVertexBuffers > MAX_D3D11_VERTEX_STREAMS)
    {
        return;
    }

    for (uint64 i = 0; i < mesh->NumVertexBuffers; i++)
    {
        vertexBuffer[i] = m_vertexBufferArray[mesh->VertexBuffers[i]].VertexBuffer;
        strides[i] = static_cast<uint32>(m_vertexBufferArray[mesh->VertexBuffers[i]].StrideBytes);
        offsets[i] = 0;
    }

    SDKMESH_INDEX_BUFFER_HEADER* indexBufferArray;
    if (adjacent)
    {
        indexBufferArray = m_adjacencyIndexBufferArray;
    }
    else
    {
        indexBufferArray = m_indexBufferArray;
    }

    ID3D11Buffer* indexBuffer = indexBufferArray[mesh->IndexBuffer].IndexBuffer;
    DXGI_FORMAT indexBufferFormat = DXGI_FORMAT_R16_UINT;
    switch (indexBufferArray[mesh->IndexBuffer].IndexType)
    {
        case SDKMeshIndexType::Bits16:
            indexBufferFormat = DXGI_FORMAT_R16_UINT;
            break;
        case SDKMeshIndexType::Bits32:
            indexBufferFormat = DXGI_FORMAT_R32_UINT;
            break;
    };

    d3dContext->IASetVertexBuffers(0, mesh->NumVertexBuffers, vertexBuffer, strides, offsets);
    d3dContext->IASetIndexBuffer(indexBuffer, indexBufferFormat, 0);

    SDKMESH_SUBSET* subset = nullptr;
    SDKMESH_MATERIAL* material = nullptr;
    D3D11_PRIMITIVE_TOPOLOGY primitiveType;

    for (uint32 i = 0; i < mesh->NumSubsets; i++)
    {
        subset = &m_subsetArray[mesh->Subsets[i]];

        primitiveType = GetPrimitiveType(static_cast<SDKMeshPrimitiveType>(subset->PrimitiveType));
        if (adjacent)
        {
            switch (primitiveType)
            {
            case D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST:
                primitiveType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST_ADJ;
                break;
            case D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP:
                primitiveType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP_ADJ;
                break;
            case D3D11_PRIMITIVE_TOPOLOGY_LINELIST:
                primitiveType = D3D11_PRIMITIVE_TOPOLOGY_LINELIST_ADJ;
                break;
            case D3D11_PRIMITIVE_TOPOLOGY_LINESTRIP:
                primitiveType = D3D11_PRIMITIVE_TOPOLOGY_LINESTRIP_ADJ;
                break;
            }
        }

        d3dContext->IASetPrimitiveTopology(primitiveType);

        material = &m_materialArray[subset->MaterialID];
        if (diffuseSlot != INVALID_SAMPLER_SLOT && !IsErrorResource(material->DiffuseRV))
        {
            d3dContext->PSSetShaderResources(diffuseSlot, 1, &material->DiffuseRV);
        }
        if (normalSlot != INVALID_SAMPLER_SLOT && !IsErrorResource(material->NormalRV))
        {
            d3dContext->PSSetShaderResources(normalSlot, 1, &material->NormalRV);
        }
        if (specularSlot != INVALID_SAMPLER_SLOT && !IsErrorResource(material->SpecularRV))
        {
            d3dContext->PSSetShaderResources(specularSlot, 1, &material->SpecularRV);
        }

        uint32 indexCount = (uint32)subset->IndexCount;
        uint32 indexStart = (uint32)subset->IndexStart;
        uint32 vertexStart = (uint32)subset->VertexStart;

        if (adjacent)
        {
            indexCount *= 2;
            indexStart *= 2;
        }

        d3dContext->DrawIndexed(indexCount, indexStart, vertexStart);
    }
}

void SDKMesh::SetLoading ( bool loading )

Definition at line 1157 of file SDKMesh.cpp.

{
    m_loading = loading;
}

void SDKMesh::TransformBindPose ( CXMMATRIX world )

Definition at line 808 of file SDKMesh.cpp.

{
    TransformBindPoseFrame(0, world);
}

void SDKMesh::TransformBindPoseFrame | ( | uint32 | frame,
 |  | CXMMATRIX | parentWorld |
 | ) |  |  | [protected]

Definition at line 380 of file SDKMesh.cpp.

{
    if (m_bindPoseFrameMatrices == nullptr)
    {
        return;
    }

    // Transform ourselves
    XMMATRIX localWorld = XMMatrixMultiply(XMLoadFloat4x4(&m_frameArray[frame].Matrix), parentWorld);
    m_bindPoseFrameMatrices[frame] = localWorld;

    // Transform our siblings
    if (m_frameArray[frame].SiblingFrame != INVALID_FRAME)
    {
        TransformBindPoseFrame(m_frameArray[frame].SiblingFrame, parentWorld);
    }

    // Transform our children
    if (m_frameArray[frame].ChildFrame != INVALID_FRAME)
    {
        TransformBindPoseFrame(m_frameArray[frame].ChildFrame, localWorld);
    }
}

void SDKMesh::TransformFrame | ( | uint32 | frame,
 |  | CXMMATRIX | parentWorld,
 |  | double | time |
 | ) |  |  | [protected]

Definition at line 405 of file SDKMesh.cpp.

{
    // Get the tick data
    XMMATRIX localTransform;
    uint32 tick = GetAnimationKeyFromTime(time);

    if (INVALID_ANIMATION_DATA != m_frameArray[frame].AnimationDataIndex)
    {
        SDKANIMATION_FRAME_DATA* frameData = &m_animationFrameData[m_frameArray[frame].AnimationDataIndex];
        SDKANIMATION_DATA* data = &frameData->AnimationData[tick];

        // turn it into a matrix (ignore scaling for now)
        XMMATRIX translate = XMMatrixTranslation(data->Translation.x, data->Translation.y, data->Translation.z);
        XMVECTOR quatVector;
        XMMATRIX quatMatrix;

        if (data->Orientation.w == 0 && data->Orientation.x == 0 && data->Orientation.y == 0 && data->Orientation.z == 0)
        {
            quatVector = XMQuaternionIdentity();
        }
        else
        {
            quatVector = XMLoadFloat4(&data->Orientation);
            quatVector = XMVectorSwizzle(quatVector, 3, 0, 1, 2);
        }

        quatVector = XMQuaternionNormalize(quatVector);
        quatMatrix = XMMatrixRotationQuaternion(quatVector);
        localTransform = (quatMatrix * translate);
    }
    else
    {
        localTransform = XMLoadFloat4x4(&m_frameArray[frame].Matrix);
    }

    // Transform ourselves
    XMMATRIX localWorld = XMMatrixMultiply(localTransform, parentWorld);
    m_transformedFrameMatrices[frame] = localWorld;
    m_worldPoseFrameMatrices[frame] = localWorld;

    // Transform our siblings
    if (m_frameArray[frame].SiblingFrame != INVALID_FRAME)
    {
        TransformFrame(m_frameArray[frame].SiblingFrame, parentWorld, time);
    }

    // Transform our children
    if (m_frameArray[frame].ChildFrame != INVALID_FRAME)
    {
        TransformFrame(m_frameArray[frame].ChildFrame, localWorld, time);
    }
}

void SDKMesh::TransformFrameAbsolute | ( | uint32 | frame,
 |  | double | time |
 | ) |  |  | [protected]

Definition at line 459 of file SDKMesh.cpp.

{
    XMMATRIX trans1;
    XMMATRIX trans2;
    XMMATRIX rot1;
    XMMATRIX rot2;
    XMVECTOR quat1;
    XMVECTOR quat2;
    XMMATRIX to;
    XMMATRIX invTo;
    XMMATRIX from;

    uint32 tick = GetAnimationKeyFromTime(time);

    if (INVALID_ANIMATION_DATA != m_frameArray[frame].AnimationDataIndex)
    {
        SDKANIMATION_FRAME_DATA* frameData = &m_animationFrameData[m_frameArray[frame].AnimationDataIndex];
        SDKANIMATION_DATA* data = &frameData->AnimationData[tick];
        SDKANIMATION_DATA* dataOrig = &frameData->AnimationData[0];

        trans1 = XMMatrixTranslation(-dataOrig->Translation.x, -dataOrig->Translation.y, -dataOrig->Translation.z);
        trans2 = XMMatrixTranslation(data->Translation.x, data->Translation.y, data->Translation.z);
        quat1 = XMLoadFloat4(&dataOrig->Orientation);
        quat1 = XMQuaternionInverse(quat1);
        rot1 = XMMatrixRotationQuaternion(quat1);
        invTo = trans1 * rot1;

        quat2 = XMLoadFloat4(&data->Orientation);
        rot2 = XMMatrixRotationQuaternion(quat2);
        from = rot2 * trans2;

        XMMATRIX output = invTo * from;
        m_transformedFrameMatrices[frame] = output;
    }
}

void SDKMesh::TransformMesh | ( | CXMMATRIX | world,
 |  | double | time
 | ) |  |

Definition at line 814 of file SDKMesh.cpp.

{
    if (m_animationHeader == nullptr || FrameTransformType::Relative == static_cast<FrameTransformType>(m_animationHeader->FrameTransformType))
    {
        TransformFrame(0, world, time);

        // For each frame, move the transform to the bind pose, then
        // move it to the final position
        XMMATRIX invBindPose;
        XMMATRIX final;
        for (uint32 i = 0; i < m_meshHeader->NumFrames; i++)
        {
            XMVECTOR determinant;
            invBindPose = XMMatrixInverse(&determinant, m_bindPoseFrameMatrices[i]);

            final = invBindPose * m_transformedFrameMatrices[i];
            m_transformedFrameMatrices[i] = final;
        }
    }
    else if (FrameTransformType::Absolute == static_cast<FrameTransformType>(m_animationHeader->FrameTransformType))
    {
        for (uint32 i = 0; i < m_animationHeader->NumFrames; i++)
            TransformFrameAbsolute(i, time);
    }
}

Member Data Documentation

SDKMESH_INDEX_BUFFER_HEADER* SDKMesh::m_adjacencyIndexBufferArray [protected]

Definition at line 312 of file SDKMesh.h.

BYTE* SDKMesh::m_animationData [protected]

Definition at line 295 of file SDKMesh.h.

SDKANIMATION_FRAME_DATA* SDKMesh::m_animationFrameData [protected]

Definition at line 316 of file SDKMesh.h.

SDKANIMATION_FILE_HEADER* SDKMesh::m_animationHeader [protected]

Definition at line 315 of file SDKMesh.h.

XMMATRIX* SDKMesh::m_bindPoseFrameMatrices [protected]

Definition at line 317 of file SDKMesh.h.

ID3D11DeviceContext* SDKMesh::m_d3dContext [private]

Definition at line 289 of file SDKMesh.h.

ID3D11Device* SDKMesh::m_d3dDevice [private]

Definition at line 288 of file SDKMesh.h.

SDKMESH_FRAME* SDKMesh::m_frameArray [protected]

Definition at line 308 of file SDKMesh.h.

BYTE* SDKMesh::m_heapData [protected]

Definition at line 294 of file SDKMesh.h.

HANDLE SDKMesh::m_hFile [private]

Definition at line 286 of file SDKMesh.h.

HANDLE SDKMesh::m_hFileMappingObject [private]

Definition at line 287 of file SDKMesh.h.

SDKMESH_INDEX_BUFFER_HEADER* SDKMesh::m_indexBufferArray [protected]

Definition at line 305 of file SDKMesh.h.

BYTE** SDKMesh::m_indices [protected]

Definition at line 297 of file SDKMesh.h.

bool SDKMesh::m_loading [private]

Definition at line 285 of file SDKMesh.h.

SDKMESH_MATERIAL* SDKMesh::m_materialArray [protected]

Definition at line 309 of file SDKMesh.h.

SDKMESH_MESH* SDKMesh::m_meshArray [protected]

Definition at line 306 of file SDKMesh.h.

SDKMESH_HEADER* SDKMesh::m_meshHeader [protected]

Definition at line 303 of file SDKMesh.h.

UINT SDKMesh::m_numOutstandingResources [private]

Definition at line 284 of file SDKMesh.h.

WCHAR SDKMesh::m_path[MAX_PATH] [protected]

Definition at line 300 of file SDKMesh.h.

BYTE* SDKMesh::m_staticMeshData [protected]

Definition at line 293 of file SDKMesh.h.

SDKMESH_SUBSET* SDKMesh::m_subsetArray [protected]

Definition at line 307 of file SDKMesh.h.

XMMATRIX* SDKMesh::m_transformedFrameMatrices [protected]

Definition at line 318 of file SDKMesh.h.

SDKMESH_VERTEX_BUFFER_HEADER* SDKMesh::m_vertexBufferArray [protected]

Definition at line 304 of file SDKMesh.h.

BYTE** SDKMesh::m_vertices [protected]

Definition at line 296 of file SDKMesh.h.

XMMATRIX* SDKMesh::m_worldPoseFrameMatrices [protected]

Definition at line 319 of file SDKMesh.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/SDKMesh.h
  • DirectX marble maze game/C++/SDKMesh.cpp
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKMESH_FRAME Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKMESH_FRAME Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

UINT | AnimationDataIndex
UINT | ChildFrame
XMFLOAT4X4 | Matrix
UINT | Mesh
char | Name [MAX_FRAME_NAME]
UINT | ParentFrame
UINT | SiblingFrame

Detailed Description

Definition at line 185 of file SDKMesh.h.

Member Data Documentation

UINT SDKMESH_FRAME::AnimationDataIndex

Definition at line 193 of file SDKMesh.h.

UINT SDKMESH_FRAME::ChildFrame

Definition at line 190 of file SDKMesh.h.

XMFLOAT4X4 SDKMESH_FRAME::Matrix

Definition at line 192 of file SDKMesh.h.

UINT SDKMESH_FRAME::Mesh

Definition at line 188 of file SDKMesh.h.

char SDKMESH_FRAME::Name[MAX_FRAME_NAME]

Definition at line 187 of file SDKMesh.h.

UINT SDKMESH_FRAME::ParentFrame

Definition at line 189 of file SDKMesh.h.

UINT SDKMESH_FRAME::SiblingFrame

Definition at line 191 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKMESH_HEADER Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKMESH_HEADER Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

UINT64 | BufferDataSize
UINT64 | FrameDataOffset
UINT64 | HeaderSize
UINT64 | IndexStreamHeadersOffset
BYTE | IsBigEndian
UINT64 | MaterialDataOffset
UINT64 | MeshDataOffset
UINT64 | NonBufferDataSize
UINT | NumFrames
UINT | NumIndexBuffers
UINT | NumMaterials
UINT | NumMeshes
UINT | NumTotalSubsets
UINT | NumVertexBuffers
UINT64 | SubsetDataOffset
UINT | Version
UINT64 | VertexStreamHeadersOffset

Detailed Description

Definition at line 89 of file SDKMesh.h.

Member Data Documentation

UINT64 SDKMESH_HEADER::BufferDataSize

Definition at line 96 of file SDKMesh.h.

UINT64 SDKMESH_HEADER::FrameDataOffset

Definition at line 111 of file SDKMesh.h.

UINT64 SDKMESH_HEADER::HeaderSize

Definition at line 94 of file SDKMesh.h.

UINT64 SDKMESH_HEADER::IndexStreamHeadersOffset

Definition at line 108 of file SDKMesh.h.

BYTE SDKMESH_HEADER::IsBigEndian

Definition at line 93 of file SDKMesh.h.

UINT64 SDKMESH_HEADER::MaterialDataOffset

Definition at line 112 of file SDKMesh.h.

UINT64 SDKMESH_HEADER::MeshDataOffset

Definition at line 109 of file SDKMesh.h.

UINT64 SDKMESH_HEADER::NonBufferDataSize

Definition at line 95 of file SDKMesh.h.

UINT SDKMESH_HEADER::NumFrames

Definition at line 103 of file SDKMesh.h.

UINT SDKMESH_HEADER::NumIndexBuffers

Definition at line 100 of file SDKMesh.h.

UINT SDKMESH_HEADER::NumMaterials

Definition at line 104 of file SDKMesh.h.

UINT SDKMESH_HEADER::NumMeshes

Definition at line 101 of file SDKMesh.h.

UINT SDKMESH_HEADER::NumTotalSubsets

Definition at line 102 of file SDKMesh.h.

UINT SDKMESH_HEADER::NumVertexBuffers

Definition at line 99 of file SDKMesh.h.

UINT64 SDKMESH_HEADER::SubsetDataOffset

Definition at line 110 of file SDKMesh.h.

UINT SDKMESH_HEADER::Version

Definition at line 92 of file SDKMesh.h.

UINT64 SDKMESH_HEADER::VertexStreamHeadersOffset

Definition at line 107 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKMESH_INDEX_BUFFER_HEADER Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKMESH_INDEX_BUFFER_HEADER Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

union {
UINT64 DataOffset
ID3D11Buffer * IndexBuffer
};
UINT32 | IndexType
UINT64 | NumIndices
UINT64 | SizeBytes

Detailed Description

Definition at line 138 of file SDKMesh.h.

Member Data Documentation

union { ... }
UINT64 SDKMESH_INDEX_BUFFER_HEADER::DataOffset

Definition at line 145 of file SDKMesh.h.

ID3D11Buffer* SDKMESH_INDEX_BUFFER_HEADER::IndexBuffer

Definition at line 146 of file SDKMesh.h.

UINT32 SDKMESH_INDEX_BUFFER_HEADER::IndexType

Definition at line 142 of file SDKMesh.h.

UINT64 SDKMESH_INDEX_BUFFER_HEADER::NumIndices

Definition at line 140 of file SDKMesh.h.

UINT64 SDKMESH_INDEX_BUFFER_HEADER::SizeBytes

Definition at line 141 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKMESH_MATERIAL Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKMESH_MATERIAL Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

union {
ID3D11Texture2D * DiffuseTexture
UINT64 Force64_1
};
union {
UINT64 Force64_2
ID3D11Texture2D * NormalTexture
};
union {
UINT64 Force64_3
ID3D11Texture2D * SpecularTexture
};
union {
ID3D11ShaderResourceView * DiffuseRV
UINT64 Force64_4
};
union {
UINT64 Force64_5
ID3D11ShaderResourceView * NormalRV
};
union {
UINT64 Force64_6
ID3D11ShaderResourceView * SpecularRV
};
XMFLOAT4 | Ambient
XMFLOAT4 | Diffuse
char | DiffuseTextureName [MAX_TEXTURE_NAME]
XMFLOAT4 | Emissive
char | MaterialInstancePath [MAX_MATERIAL_PATH]
char | Name [MAX_MATERIAL_NAME]
char | NormalTextureName [MAX_TEXTURE_NAME]
FLOAT | Power
XMFLOAT4 | Specular
char | SpecularTextureName [MAX_TEXTURE_NAME]

Detailed Description

Definition at line 196 of file SDKMesh.h.

Member Data Documentation

union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
XMFLOAT4 SDKMESH_MATERIAL::Ambient

Definition at line 209 of file SDKMesh.h.

XMFLOAT4 SDKMESH_MATERIAL::Diffuse

Definition at line 208 of file SDKMesh.h.

ID3D11ShaderResourceView* SDKMESH_MATERIAL::DiffuseRV

Definition at line 233 of file SDKMesh.h.

ID3D11Texture2D* SDKMESH_MATERIAL::DiffuseTexture

Definition at line 217 of file SDKMesh.h.

char SDKMESH_MATERIAL::DiffuseTextureName[MAX_TEXTURE_NAME]

Definition at line 204 of file SDKMesh.h.

XMFLOAT4 SDKMESH_MATERIAL::Emissive

Definition at line 211 of file SDKMesh.h.

UINT64 SDKMESH_MATERIAL::Force64_1

Definition at line 216 of file SDKMesh.h.

UINT64 SDKMESH_MATERIAL::Force64_2

Definition at line 221 of file SDKMesh.h.

UINT64 SDKMESH_MATERIAL::Force64_3

Definition at line 226 of file SDKMesh.h.

UINT64 SDKMESH_MATERIAL::Force64_4

Definition at line 232 of file SDKMesh.h.

UINT64 SDKMESH_MATERIAL::Force64_5

Definition at line 237 of file SDKMesh.h.

UINT64 SDKMESH_MATERIAL::Force64_6

Definition at line 242 of file SDKMesh.h.

char SDKMESH_MATERIAL::MaterialInstancePath[MAX_MATERIAL_PATH]

Definition at line 201 of file SDKMesh.h.

char SDKMESH_MATERIAL::Name[MAX_MATERIAL_NAME]

Definition at line 198 of file SDKMesh.h.

ID3D11ShaderResourceView* SDKMESH_MATERIAL::NormalRV

Definition at line 238 of file SDKMesh.h.

ID3D11Texture2D* SDKMESH_MATERIAL::NormalTexture

Definition at line 222 of file SDKMesh.h.

char SDKMESH_MATERIAL::NormalTextureName[MAX_TEXTURE_NAME]

Definition at line 205 of file SDKMesh.h.

FLOAT SDKMESH_MATERIAL::Power

Definition at line 212 of file SDKMesh.h.

XMFLOAT4 SDKMESH_MATERIAL::Specular

Definition at line 210 of file SDKMesh.h.

ID3D11ShaderResourceView* SDKMESH_MATERIAL::SpecularRV

Definition at line 243 of file SDKMesh.h.

ID3D11Texture2D* SDKMESH_MATERIAL::SpecularTexture

Definition at line 227 of file SDKMesh.h.

char SDKMESH_MATERIAL::SpecularTextureName[MAX_TEXTURE_NAME]

Definition at line 206 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKMESH_MESH Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKMESH_MESH Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

union {
UINT64 SubsetOffset
UINT * Subsets
};
union {
UINT64 FrameInfluenceOffset
UINT * FrameInfluences
};
XMFLOAT3 | BoundingBoxCenter
XMFLOAT3 | BoundingBoxExtents
UINT | IndexBuffer
char | Name [MAX_MESH_NAME]
UINT | NumFrameInfluences
UINT | NumSubsets
BYTE | NumVertexBuffers
UINT | VertexBuffers [MAX_VERTEX_STREAMS]

Detailed Description

Definition at line 150 of file SDKMesh.h.

Member Data Documentation

union { ... }
union { ... }
XMFLOAT3 SDKMESH_MESH::BoundingBoxCenter

Definition at line 159 of file SDKMesh.h.

XMFLOAT3 SDKMESH_MESH::BoundingBoxExtents

Definition at line 160 of file SDKMesh.h.

UINT64 SDKMESH_MESH::FrameInfluenceOffset

Definition at line 169 of file SDKMesh.h.

UINT* SDKMESH_MESH::FrameInfluences

Definition at line 170 of file SDKMesh.h.

UINT SDKMESH_MESH::IndexBuffer

Definition at line 155 of file SDKMesh.h.

char SDKMESH_MESH::Name[MAX_MESH_NAME]

Definition at line 152 of file SDKMesh.h.

UINT SDKMESH_MESH::NumFrameInfluences

Definition at line 157 of file SDKMesh.h.

UINT SDKMESH_MESH::NumSubsets

Definition at line 156 of file SDKMesh.h.

BYTE SDKMESH_MESH::NumVertexBuffers

Definition at line 153 of file SDKMesh.h.

UINT64 SDKMESH_MESH::SubsetOffset

Definition at line 164 of file SDKMesh.h.

UINT* SDKMESH_MESH::Subsets

Definition at line 165 of file SDKMesh.h.

UINT SDKMESH_MESH::VertexBuffers[MAX_VERTEX_STREAMS]

Definition at line 154 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKMESH_SUBSET Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKMESH_SUBSET Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

UINT64 | IndexCount
UINT64 | IndexStart
UINT | MaterialID
char | Name [MAX_SUBSET_NAME]
UINT | PrimitiveType
UINT64 | VertexCount
UINT64 | VertexStart

Detailed Description

Definition at line 174 of file SDKMesh.h.

Member Data Documentation

UINT64 SDKMESH_SUBSET::IndexCount

Definition at line 180 of file SDKMesh.h.

UINT64 SDKMESH_SUBSET::IndexStart

Definition at line 179 of file SDKMesh.h.

UINT SDKMESH_SUBSET::MaterialID

Definition at line 177 of file SDKMesh.h.

char SDKMESH_SUBSET::Name[MAX_SUBSET_NAME]

Definition at line 176 of file SDKMesh.h.

UINT SDKMESH_SUBSET::PrimitiveType

Definition at line 178 of file SDKMesh.h.

UINT64 SDKMESH_SUBSET::VertexCount

Definition at line 182 of file SDKMesh.h.

UINT64 SDKMESH_SUBSET::VertexStart

Definition at line 181 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKMESH_VERTEX_BUFFER_HEADER Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SDKMESH_VERTEX_BUFFER_HEADER Struct Reference

#include "SDKMesh.h"

List of all members.

Public Attributes

union {
UINT64 DataOffset
ID3D11Buffer * VertexBuffer
};
SDKMESHVERTEXELEMENT | Decl [MAX_VERTEX_ELEMENTS]
UINT64 | NumVertices
UINT64 | SizeBytes
UINT64 | StrideBytes

Detailed Description

Definition at line 125 of file SDKMesh.h.

Member Data Documentation

union { ... }
UINT64 SDKMESH_VERTEX_BUFFER_HEADER::DataOffset

Definition at line 133 of file SDKMesh.h.

SDKMESHVERTEXELEMENT SDKMESH_VERTEX_BUFFER_HEADER::Decl[MAX_VERTEX_ELEMENTS]

Definition at line 130 of file SDKMesh.h.

UINT64 SDKMESH_VERTEX_BUFFER_HEADER::NumVertices

Definition at line 127 of file SDKMesh.h.

UINT64 SDKMESH_VERTEX_BUFFER_HEADER::SizeBytes

Definition at line 128 of file SDKMesh.h.

UINT64 SDKMESH_VERTEX_BUFFER_HEADER::StrideBytes

Definition at line 129 of file SDKMesh.h.

ID3D11Buffer* SDKMESH_VERTEX_BUFFER_HEADER::VertexBuffer

Definition at line 134 of file SDKMesh.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/SDKMesh.h
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::AccelerometerCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • AccelerometerCPP
  • SDKSample::AccelerometerCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::AccelerometerCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisplayCurrentReading (Platform::Object^sender, Platform::Object^e)
void | ReadingChanged (Windows::Devices::Sensors::Accelerometer^sender, Windows::Devices::Sensors::AccelerometerReadingChangedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Shaken (Windows::Devices::Sensors::Accelerometer^sender, Windows::Devices::Sensors::AccelerometerShakenEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)

Private Attributes

Windows::Devices::Sensors::Accelerometer | accelerometer
uint32 | desiredReportInterval
Windows::UI::Core::CoreDispatcher | dispatcher
Windows::UI::Xaml::DispatcherTimer | dispatcherTimer
Windows::Foundation::EventRegistrationToken | readingToken
MainPage rootPage
uint16 | shakeCounter
Windows::Foundation::EventRegistrationToken | shakenToken
Windows::Foundation::EventRegistrationToken | visibilityToken

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::AccelerometerCPP::sealed::DisplayCurrentReading | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::AccelerometerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AccelerometerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AccelerometerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AccelerometerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AccelerometerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AccelerometerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::AccelerometerCPP::sealed::ReadingChanged | ( | Windows::Devices::Sensors::Accelerometer^ | sender,
 |  | Windows::Devices::Sensors::AccelerometerReadingChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::AccelerometerCPP::sealed::Scenario1 ( )
SDKSample::AccelerometerCPP::sealed::Scenario2 ( )
SDKSample::AccelerometerCPP::sealed::Scenario3 ( )
void SDKSample::AccelerometerCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::Shaken | ( | Windows::Devices::Sensors::Accelerometer^ | sender,
 |  | Windows::Devices::Sensors::AccelerometerShakenEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AccelerometerCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Devices::Sensors::Accelerometer sealed::accelerometer [private]

Definition at line 41 of file Scenario1.xaml.h.

uint32 sealed::desiredReportInterval [private]

Definition at line 44 of file Scenario1.xaml.h.

Windows::UI::Core::CoreDispatcher sealed::dispatcher [private]

Definition at line 41 of file Scenario2.xaml.h.

Windows::UI::Xaml::DispatcherTimer SDKSample::AccelerometerCPP::sealed::dispatcherTimer [private]

Definition at line 45 of file Scenario3.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::AccelerometerCPP::sealed::readingToken [private]

Definition at line 43 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

uint16 SDKSample::AccelerometerCPP::sealed::shakeCounter [private]

Definition at line 45 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::AccelerometerCPP::sealed::shakenToken [private]

Definition at line 44 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::visibilityToken [private]

Definition at line 42 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Accelerometer sensor/C++/Scenario1.xaml.h
  • Accelerometer sensor/C++/Scenario2.xaml.h
  • Accelerometer sensor/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Accessibility::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Accessibility
  • SDKSample::Accessibility::sealed
Public Member Functions | Static Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Accessibility::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

MediaContainerAP (MediaElementContainer^owner, MediaElement^mediaElement)
MediaElementContainer (Windows::UI::Xaml::Controls::Panel^parent)
Person (Platform::String^firstName, Platform::String^lastName, Platform::String^id, int age, Platform::String^name)
Person ()
Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()

Static Public Member Functions

static
Windows::Foundation::Collections::IVector
< Person^> 		GeneratePersonNamesSource ()

Public Attributes

FrameworkElement | _labeledBy
MediaElement | _mediaElement
Windows::UI::Xaml::Controls::MediaElement | mediaElement

Protected Member Functions

virtual AutomationControlType | GetAutomationControlTypeCore () override
virtual Platform::String | GetClassNameCore () override
virtual Platform::String | GetLocalizedControlTypeCore () override
virtual Object | GetPatternCore (PatternInterface patternInterface) override
virtual AutomationPeer | OnCreateAutomationPeer () override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | PrepareContainerForItemOverride (Windows::UI::Xaml::DependencyObject^element, Platform::Object^item) override

Private Member Functions

void | GiveControlFocus (Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^args)

Private Attributes

int | _age
Platform::String | automationId
Platform::String | automationName
Platform::String | firstName
Platform::String | lastName
MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

static Windows::Foundation::Collections::IVector<Person^> SDKSample::Accessibility::sealed::GeneratePersonNamesSource ( ) [inline, static]

Definition at line 139 of file Scenario4.xaml.h.

        {
          Platform::Collections::Vector<Person^>^ ds = ref new Platform::Collections::Vector<Person^>();
          ds->Append(ref new Person("George", "Washington", "ListItemId1", 25, "ListItemName1"));
          ds->Append(ref new Person("John", "Adams", "ListItemId2", 30, "ListItemName2"));
          ds->Append(ref new Person("Thomas", "Jefferson", "ListItemId3", 45, "ListItemName3"));
          ds->Append(ref new Person("James", "Madison", "ListItemId4", 55, "ListItemName4"));
          ds->Append(ref new Person("James", "Monroe", "ListItemId5", 30, "ListItemName5"));
          ds->Append(ref new Person("John", "Adams", "ListItemId6", 25, "ListItemName6"));
          ds->Append(ref new Person("Andrew", "Jackson", "ListItemId7", 55, "ListItemName7"));
          ds->Append(ref new Person("Martin", "Van Buren", "ListItemId8", 56, "ListItemName8"));
          ds->Append(ref new Person("William", "Harrison", "ListItemId9", 40, "ListItemName9"));
          ds->Append(ref new Person("John", "Tyler", "ListItemId10", 42, "ListItemName10"));
          ds->Append(ref new Person("James", "Polk", "ListItemId11", 60, "ListItemName11"));
          ds->Append(ref new Person("Zachary", "Taylor", "ListItemId12", 65, "ListItemName12"));
          ds->Append(ref new Person("Millard", "Fillmore", "ListItemId13", 25, "ListItemName13"));
          ds->Append(ref new Person("Franklin", "Pierce", "ListItemId14", 35, "ListItemName14"));
          ds->Append(ref new Person("James", "Buchanan", "ListItemId15", 43, "ListItemName15"));
          ds->Append(ref new Person("Abraham", "Lincoln", "ListItemId16", 23, "ListItemName16"));
          ds->Append(ref new Person("Andrew", "Johnson", "ListItemId17", 21, "ListItemName17"));
          ds->Append(ref new Person("Rutherford", "Hayes", "ListItemId18", 25, "ListItemName18"));
          ds->Append(ref new Person("James", "Garfield", "ListItemId19", 30, "ListItemName19"));
          ds->Append(ref new Person("Chester", "Arthur", "ListItemId20", 34, "ListItemName20"));
          ds->Append(ref new Person("Grover", "Cleveland", "ListItemId21", 55, "ListItemName21"));

          return ds;
        }

virtual AutomationControlType SDKSample::Accessibility::sealed::GetAutomationControlTypeCore ( ) [inline, override, protected, virtual]

Definition at line 77 of file Scenario3.xaml.h.

            {
                return  AutomationControlType::Group;
            }

virtual Platform::String SDKSample::Accessibility::sealed::GetClassNameCore ( ) [inline, override, protected, virtual]

Definition at line 89 of file Scenario3.xaml.h.

            {
                return "MediaElementContainer";
            }

virtual Platform::String SDKSample::Accessibility::sealed::GetLocalizedControlTypeCore ( ) [inline, override, protected, virtual]

Definition at line 83 of file Scenario3.xaml.h.

            {
                return "Video";
            }

virtual Object SDKSample::Accessibility::sealed::GetPatternCore ( PatternInterface patternInterface ) [inline, override, protected, virtual]

Definition at line 63 of file Scenario3.xaml.h.

            {
                if (patternInterface == PatternInterface::RangeValue)
                {
                    return this;
                }
                else if (patternInterface == PatternInterface::Toggle)
                {
                    return this;
                }
                return nullptr;
            }

void SDKSample::Accessibility::sealed::GiveControlFocus | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::PointerRoutedEventArgs^ | args |
 | ) |  |  | [private]
SDKSample::Accessibility::sealed::MediaContainerAP | ( | MediaElementContainer^ | owner,
 |  | MediaElement^ | mediaElement
 | ) |  |
SDKSample::Accessibility::sealed::MediaElementContainer ( Windows::UI::Xaml::Controls::Panel^ parent ) [inline]

Definition at line 220 of file Scenario3.xaml.h.

            {
                parent->Children->Append(this);
                mediaElement = ref new Windows::UI::Xaml::Controls::MediaElement();
                mediaElement->Width = 200;
                this->Content = mediaElement;
                Windows::Foundation::Uri^ uri = ref new Windows::Foundation::Uri("ms-appx:///Media/video.wmv");
                mediaElement->Source = uri;
                this->IsTabStop = true;
                AutomationProperties::SetAutomationId(mediaElement, "MediaElement1");
                AutomationProperties::SetName(mediaElement, "MediaElement");
            }

virtual AutomationPeer SDKSample::Accessibility::sealed::OnCreateAutomationPeer ( ) [inline, override, protected, virtual]

Definition at line 233 of file Scenario3.xaml.h.

            {
                return ref new MediaContainerAP(this, mediaElement);
            }

virtual void SDKSample::Accessibility::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Accessibility::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Accessibility::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Accessibility::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::Accessibility::sealed::Person ( ) [inline]

Definition at line 62 of file Scenario4.xaml.h.

        {
        }

SDKSample::Accessibility::sealed::Person | ( | Platform::String^ | firstName,
 |  | Platform::String^ | lastName,
 |  | Platform::String^ | id,
 |  | int | age,
 |  | Platform::String^ | name |
 | ) |  |  | [inline]

Definition at line 65 of file Scenario4.xaml.h.

        {
          FirstName = firstName;
          LastName = lastName;
          AutomationId = id;
          Age = age;
          AutomationName = name;
        }

virtual void SDKSample::Accessibility::sealed::PrepareContainerForItemOverride | ( | Windows::UI::Xaml::DependencyObject^ | element,
 |  | Platform::Object^ | item |
 | ) |  |  | [inline, override, protected, virtual]

Definition at line 38 of file Scenario4.xaml.h.

        {
          Windows::UI::Xaml::Controls::ListView::PrepareContainerForItemOverride(element, item);
                    FrameworkElement^ source = safe_cast<FrameworkElement^>(element);
                    Binding^ idBinding = ref new Binding;
                    Binding^ nameBinding = ref new Binding;
                    idBinding->Path = ref new PropertyPath("AutomationId");
                    source->SetBinding(AutomationProperties::AutomationIdProperty, idBinding);
                    nameBinding->Path = ref new PropertyPath("AutomationName");
                    source->SetBinding(AutomationProperties::NameProperty, nameBinding);
        }

SDKSample::Accessibility::sealed::Scenario1 ( )
SDKSample::Accessibility::sealed::Scenario2 ( )
SDKSample::Accessibility::sealed::Scenario3 ( )
SDKSample::Accessibility::sealed::Scenario4 ( )

Member Data Documentation

int SDKSample::Accessibility::sealed::_age [private]

Definition at line 59 of file Scenario4.xaml.h.

FrameworkElement SDKSample::Accessibility::sealed::_labeledBy

Definition at line 57 of file Scenario3.xaml.h.

MediaElement SDKSample::Accessibility::sealed::_mediaElement

Definition at line 56 of file Scenario3.xaml.h.

Platform::String SDKSample::Accessibility::sealed::automationId [private]

Definition at line 58 of file Scenario4.xaml.h.

Platform::String SDKSample::Accessibility::sealed::automationName [private]

Definition at line 57 of file Scenario4.xaml.h.

Platform::String SDKSample::Accessibility::sealed::firstName [private]

Definition at line 55 of file Scenario4.xaml.h.

Platform::String SDKSample::Accessibility::sealed::lastName [private]

Definition at line 56 of file Scenario4.xaml.h.

Windows::UI::Xaml::Controls::MediaElement SDKSample::Accessibility::sealed::mediaElement

Definition at line 217 of file Scenario3.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML accessibility/C++/Scenario1.xaml.h
  • XAML accessibility/C++/Scenario2.xaml.h
  • XAML accessibility/C++/Scenario3.xaml.h
  • XAML accessibility/C++/Scenario4.xaml.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Animation::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Animation
  • SDKSample::Animation::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Animation::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | PlotEasingFunctionGraph (Windows::UI::Xaml::Media::Animation::EasingFunctionBase^easingFunction, double samplingInterval)
void | Scenario2ToggleStoryboard_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario3EasingFunctionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | ToggleScenario2 (bool startScenario)

Private Attributes

bool | isScenario2StoryboardRunning
MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

virtual void SDKSample::Animation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Animation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Animation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Animation::sealed::PlotEasingFunctionGraph | ( | Windows::UI::Xaml::Media::Animation::EasingFunctionBase^ | easingFunction,
 |  | double | samplingInterval |
 | ) |  |  | [private]
SDKSample::Animation::sealed::Scenario1 ( )
SDKSample::Animation::sealed::Scenario2 ( )
void SDKSample::Animation::sealed::Scenario2ToggleStoryboard_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Animation::sealed::Scenario3 ( )
void SDKSample::Animation::sealed::Scenario3EasingFunctionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Animation::sealed::ToggleScenario2 ( bool startScenario ) [private]

Member Data Documentation

bool SDKSample::Animation::sealed::isScenario2StoryboardRunning [private]

Definition at line 39 of file Scenario2.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML animation library/C++/Scenario1.xaml.h
  • XAML animation library/C++/Scenario2.xaml.h
  • XAML animation library/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::AnimationMetrics::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • AnimationMetrics
  • SDKSample::AnimationMetrics::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::AnimationMetrics::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Animations_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | DisplayMetrics (Windows::UI::Core::AnimationMetrics::AnimationEffect effect, Windows::UI::Core::AnimationMetrics::AnimationEffectTarget target)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::AnimationMetrics::sealed::Animations_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AnimationMetrics::sealed::DisplayMetrics | ( | Windows::UI::Core::AnimationMetrics::AnimationEffect | effect,
 |  | Windows::UI::Core::AnimationMetrics::AnimationEffectTarget | target |
 | ) |  |  | [private]
virtual void SDKSample::AnimationMetrics::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::AnimationMetrics::sealed::Scenario1 ( )

Member Data Documentation

MainPage SDKSample::AnimationMetrics::sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following file:
  • Animation metrics/C++/Scenario1.xaml.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::App
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnActivated (Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override
virtual void | OnFileActivated (Windows::ApplicationModel::Activation::FileActivatedEventArgs^args) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()
Windows::ApplicationModel::Activation::LaunchActivatedEventArgs | LaunchArgs

Protected Member Functions

virtual void | OnCachedFileUpdaterActivated (Windows::ApplicationModel::Activation::CachedFileUpdaterActivatedEventArgs^pArgs) override
virtual void | OnFileOpenPickerActivated (Windows::ApplicationModel::Activation::FileOpenPickerActivatedEventArgs^pArgs) override
virtual void | OnFileSavePickerActivated (Windows::ApplicationModel::Activation::FileSavePickerActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
void | OnQuerySubmitted (Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneQuerySubmittedEventArgs^args)
virtual void | OnSearchActivated (Windows::ApplicationModel::Activation::SearchActivatedEventArgs^pArgs) override
virtual void | OnWindowCreated (Windows::UI::Xaml::WindowCreatedEventArgs^pArgs) override
virtual void | OnWindowCreated (Windows::UI::Xaml::WindowCreatedEventArgs^pArgs) override

Private Member Functions

void | App::EnsureMainPageActivated (Windows::ApplicationModel::Activation::IActivatedEventArgs^pArgs)
void | App::EnsureMainPageActivated (Windows::ApplicationModel::Activation::IActivatedEventArgs^pArgs)

Private Attributes

Windows::UI::Xaml::Controls::Frame | rootFrame

Detailed Description

Definition at line 24 of file App.xaml.h.

Member Function Documentation

void SDKSample::App::App::EnsureMainPageActivated ( Windows::ApplicationModel::Activation::IActivatedEventArgs^ pArgs ) [private]
void SDKSample::App::App::EnsureMainPageActivated ( Windows::ApplicationModel::Activation::IActivatedEventArgs^ pArgs ) [private]
void App::OnActivated ( Windows::ApplicationModel::Activation::IActivatedEventArgs^ args ) [override, virtual]

Invoked when the application is activated.

This is the entry point for Device Autoplay when a device is attached to the PC. Other activation kinds (such as search and protocol activation) may also be handled here.

Parameters:
args Details about the activation request.

Definition at line 86 of file Constants.cpp.

{
    if (args->Kind == ActivationKind::Device)
    {
        Frame^ rootFrame = nullptr;
        if (Window::Current->Content == nullptr)
        {
            rootFrame = ref new Frame();
            TypeName pageType = { "SDKSample.MainPage", TypeKind::Custom };
            rootFrame->Navigate(pageType);
            Window::Current->Content = rootFrame;
        }
        else
        {
            rootFrame = safe_cast<Frame^>(Window::Current->Content);
        }
        Window::Current->Activate();
        MainPage^ mainPage = safe_cast<MainPage^>(rootFrame->Content);

        // Launched from Autoplay for device, receiving the device information identifier.
        DeviceActivatedEventArgs^ deviceArgs = dynamic_cast<DeviceActivatedEventArgs^>(args);
        if (deviceArgs != nullptr)
        {
            mainPage->AutoplayNonFileSystemDeviceId = deviceArgs->DeviceInformationId;

            // Clear any saved drive or file so we always use the latest connected device
            mainPage->AutoplayFileSystemDeviceFolder = nullptr;
            mainPage->FileActivationFiles = nullptr;

            // Select the Autoplay scenario
            mainPage->LoadAutoplayScenario();
        }
    }
}

virtual void SDKSample::App::OnCachedFileUpdaterActivated ( Windows::ApplicationModel::Activation::CachedFileUpdaterActivatedEventArgs^ pArgs ) [override, protected, virtual]
void App::OnFileActivated ( Windows::ApplicationModel::Activation::FileActivatedEventArgs^ args ) [override, virtual]

Invoked when the application is launched to open a specific file or to access specific content.

This is the entry point for Content Autoplay when camera memory is attached to the PC.

Parameters:
args Details about the file activation request.

Definition at line 41 of file Constants.cpp.

{
    Frame^ rootFrame = nullptr;
    if (Window::Current->Content == nullptr)
    {
        rootFrame = ref new Frame();
        TypeName pageType = { "SDKSample.MainPage", TypeKind::Custom };
        rootFrame->Navigate(pageType);
        Window::Current->Content = rootFrame;
    }
    else
    {
        rootFrame = safe_cast<Frame^>(Window::Current->Content);
    }
    Window::Current->Activate();
    MainPage^ mainPage = safe_cast<MainPage^>(rootFrame->Content);

    // Clear any device id so we always use the latest connected device
    mainPage->AutoplayNonFileSystemDeviceId = nullptr;

    if (args->Verb == "storageDevice")
    {
        // Launched from Autoplay for content. This will return a single storage folder
        // representing that file system device.
        mainPage->AutoplayFileSystemDeviceFolder = safe_cast<StorageFolder^>(args->Files->GetAt(0));
        mainPage->FileActivationFiles = nullptr;
    }
    else
    {
        // Launched to handle a file type.  This will return a list of image files that the user
        // requests for this application to handle.
        mainPage->FileActivationFiles = args->Files;
        mainPage->AutoplayFileSystemDeviceFolder = nullptr;
    }

    // Select the Autoplay scenario
    mainPage->LoadAutoplayScenario();
}

virtual void SDKSample::App::OnFileOpenPickerActivated ( Windows::ApplicationModel::Activation::FileOpenPickerActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnFileSavePickerActivated ( Windows::ApplicationModel::Activation::FileSavePickerActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
void App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]

Invoked when the application is launched normally by the end user.

Other entry points will be used when the application is launched to open a specific file, to display search results, and so forth.

Parameters:
pArgs Details about the launch request and process.

Definition at line 71 of file App.xaml.cpp.

{
    EnsureMainPageActivated(pArgs);
}

virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, protected, virtual]
void SDKSample::App::OnQuerySubmitted | ( | Windows::ApplicationModel::Search::SearchPane^ | sender,
 |  | Windows::ApplicationModel::Search::SearchPaneQuerySubmittedEventArgs^ | args |
 | ) |  |  | [protected]
void App::OnSearchActivated ( Windows::ApplicationModel::Activation::SearchActivatedEventArgs^ pArgs ) [override, protected, virtual]

Definition at line 121 of file App.xaml.cpp.

{
    EnsureMainPageActivated(pArgs);
    if (pArgs->QueryText == "")
    {
        // navigate to landing page.
    }
    else
    {
        // display search results.
        MainPage::Current->ProcessQueryText(pArgs->QueryText);
    }
}

virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
virtual void SDKSample::App::OnWindowCreated ( Windows::UI::Xaml::WindowCreatedEventArgs^ pArgs ) [override, protected, virtual]
virtual void SDKSample::App::OnWindowCreated ( Windows::UI::Xaml::WindowCreatedEventArgs^ pArgs ) [override, protected, virtual]

Member Data Documentation

internal SDKSample::App::__pad0__

Definition at line 27 of file App.xaml.h.

Windows::ApplicationModel::Activation::LaunchActivatedEventArgs SDKSample::App::LaunchArgs

Definition at line 29 of file App.xaml.h.

Windows::UI::Xaml::Controls::Frame SDKSample::App::rootFrame [private]

Definition at line 33 of file App.xaml.h.

The documentation for this class was generated from the following files:
  • Accelerometer sensor/C++/App.xaml.h
  • Animation metrics/C++/App.xaml.h
  • App package information/C++/App.xaml.h
  • App settings/C++/App.xaml.h
  • App tiles and badges/C#,C++/App.xaml.h
  • Application data/C++/App.xaml.h
  • Application resources and localization/C++/App.xaml.h
  • AtomPub/C++/App.xaml.h
  • Background task/C++/BackgroundTask/App.xaml.h
  • Background Transfer/C++/App.xaml.h
  • Bluetooth call control/C++/App.xaml.h
  • Calendar details and math/C++/App.xaml.h
  • CameraCaptureUI/C++/App.xaml.h
  • CameraOptionsUI/C++/App.xaml.h
  • Certificate enrollment/C++/App.xaml.h
  • Check if current session is remote/C++/App.xaml.h
  • Compass sensor/C++/App.xaml.h
  • Compression/C++/App.xaml.h
  • Configure keys for media/C++/App.xaml.h
  • Connecting with WebSockets/C++/App.xaml.h
  • Context menu/C++/App.xaml.h
  • Credential locker/C++/App.xaml.h
  • CryptoWinRT/C++/App.xaml.h
  • Custom driver access/C++/app_cpp/App.xaml.h
  • Date and time formatting/C++/App.xaml.h
  • Device auto rotation preferences/C++/App.xaml.h
  • Device enumeration/C++/App.xaml.h
  • Display orientation/C++/App.xaml.h
  • EAS policies for mail clients/C++/App.xaml.h
  • Extended Linguistic Services (ELS)/C++/App.xaml.h
  • File access/C++/App.xaml.h
  • File and folder thumbnail/C++/App.xaml.h
  • File picker/C++/App.xaml.h
  • File picker contracts/C++/App.xaml.h
  • Folder enumeration/C++/App.xaml.h
  • Geolocation/C++/App.xaml.h
  • Globalization preferences/C++/App.xaml.h
  • Gyrometer sensor/C++/App.xaml.h
  • HomeGroup app/C++/App.xaml.h
  • HttpClient/C++/App.xaml.h
  • Inclinometer sensor/C++/App.xaml.h
  • Input Device capabilities/C++/App.xaml.h
  • Input Touch keyboard/C++/App.xaml.h
  • Input Touch keyboard text input/C++/App.xaml.h
  • IXmlReader and IXmlWriter XML data readwrite/C++/App.xaml.h
  • LightSensor/C++/App.xaml.h
  • Lock screen personalization/C++/App.xaml.h
  • Media capture using capture device/C++/App.xaml.h
  • Media Play To/C++/App.xaml.h
  • Media Server client/C++/App.xaml.h
  • Message dialog/C++/App.xaml.h
  • Mobile broadband account provisioning/C++/App.xaml.h
  • Network information/C++/App.xaml.h
  • Network status background/C++/NetworkStatusApp/App.xaml.h
  • Number formatting and parsing/C++/App.xaml.h
  • OrientationSensor/C++/App.xaml.h
  • Playback Manager Companion/C++/App.xaml.h
  • Playback Manager msAudioCategory/C++/App.xaml.h
  • Playlist/C++/App.xaml.h
  • PlayToReceiver/C++/App.xaml.h
  • Portable device API/C++/App.xaml.h
  • Programmatic file search/C++/App.xaml.h
  • Push and periodic notifications client-side/C++/App.xaml.h
  • Reading and writing data/C++/App.xaml.h
  • Removable storage/C++/App.xaml.h
  • Scaling according to DPI/C++/App.xaml.h
  • Search contract/C++/App.xaml.h
  • Sharing content source app/C++/App.xaml.h
  • SimpleOrientationSensor/C++/App.xaml.h
  • SMS background task/C++/SmsBackgroundTaskSample/App.xaml.h
  • SMS message send, receive, and SIM management/C++/App.xaml.h
  • Snap/C++/App.xaml.h
  • Splash screen/C++/App.xaml.h
  • StorageDataSource and GetVirtualizedFilesVector/C++/App.xaml.h
  • Syndication/C++/App.xaml.h
  • Thread pool/C++/App.xaml.h
  • Transcoding media/C++/App.xaml.h
  • Trial app and in-app purchase/C++/App.xaml.h
  • UI contrast and settings/C++/App.xaml.h
  • User domain name/C++/App.xaml.h
  • USSD message management/C++/App.xaml.h
  • Web authentication broker/C++/App.xaml.h
  • Windows account authorization/C++/App.xaml.h
  • Windows Audio Session (WASAPI)/C++/App.xaml.h
  • XAML accessibility/C++/App.xaml.h
  • XAML animation library/C++/App.xaml.h
  • XAML data binding/C++/App.xaml.h
  • XAML FlipView control/C++/App.xaml.h
  • XAML high contrast style/C++/App.xaml.h
  • XAML images/C++/App.xaml.h
  • XAML ListView and GridView essentials/C++/App.xaml.h
  • XAML personality animations/C++/App.xaml.h
  • XAML Popup/C++/App.xaml.h
  • XAML scrolling, panning, and zooming/C++/App.xaml.h
  • XAML text display/C++/App.xaml.h
  • XAML text editing/C++/App.xaml.h
  • XAML two-dimensional transforms/C++/App.xaml.h
  • XAML user and custom controls/C++/App.xaml.h
  • XAML vector-based drawing/C++/App.xaml.h
  • XAML WebView control/C++/App.xaml.h
  • Removable storage/C++/Constants.h
  • File picker contracts/C++/App.xaml.cpp
  • Removable storage/C++/Constants.cpp
  • Search contract/C++/App.xaml.cpp
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ApplicationDataSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ApplicationDataSample
  • SDKSample::ApplicationDataSample::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ApplicationDataSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "ClearScenario.xaml.h"

List of all members.

Public Member Functions

ClearScenario ()
CompositeSettings ()
DataChangedEvent ()
Files ()
HighPriority ()
Msappdata ()
SettingContainer ()
Settings ()
SetVersion ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override

Private Member Functions

void | Clear_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Concurrency::task< void > | CopyFile (Windows::Foundation::Uri^sourceUri, Windows::Storage::StorageFolder^destFolder, Platform::String^destFilename)
void | CreateContainer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DataChangedHandler (Windows::Storage::ApplicationData^appData, Object^)
void | DataChangedHandler (Windows::Storage::ApplicationData^appData, Object^)
void | DeleteCompositeSetting_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DeleteContainer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DeleteSetting_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DeleteSetting_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayOutput ()
void | DisplayOutput ()
void | DisplayOutput ()
void | DisplayOutput ()
void | DisplayOutput ()
void | DisplayOutput ()
void | DisplayOutput (bool remoteUpdate)
void | Increment_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | IncrementHighPriority_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ReadCounter ()
void | SetVersion0_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetVersion1_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetVersionHandler0 (Windows::Storage::SetVersionRequest^request)
void | SetVersionHandler1 (Windows::Storage::SetVersionRequest^request)
void | SimulateRoaming_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WriteCompositeSetting_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WriteOutputText ()
void | WriteSetting_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WriteSetting_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::Storage::ApplicationData | appData
Windows::Storage::ApplicationData | applicationData
int | counter
Windows::Storage::ApplicationDataContainer | localSettings
Windows::Storage::StorageFolder | roamingFolder
Windows::Storage::ApplicationDataContainer | roamingSettings
MainPage rootPage

Detailed Description

Definition at line 30 of file ClearScenario.xaml.h.

Member Function Documentation

void SDKSample::ApplicationDataSample::sealed::Clear_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationDataSample::sealed::ClearScenario ( )
SDKSample::ApplicationDataSample::sealed::CompositeSettings ( )
Concurrency::task<void> SDKSample::ApplicationDataSample::sealed::CopyFile | ( | Windows::Foundation::Uri^ | sourceUri,
 |  | Windows::Storage::StorageFolder^ | destFolder,
 |  | Platform::String^ | destFilename |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::CreateContainer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationDataSample::sealed::DataChangedEvent ( )
void SDKSample::ApplicationDataSample::sealed::DataChangedHandler | ( | Windows::Storage::ApplicationData^ | appData,
 |  | Object^ |  |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::DataChangedHandler | ( | Windows::Storage::ApplicationData^ | appData,
 |  | Object^ |  |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::DeleteCompositeSetting_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::DeleteContainer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::DeleteSetting_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::DeleteSetting_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::DisplayOutput ( ) [private]
void SDKSample::ApplicationDataSample::sealed::DisplayOutput ( ) [private]
void SDKSample::ApplicationDataSample::sealed::DisplayOutput ( ) [private]
void SDKSample::ApplicationDataSample::sealed::DisplayOutput ( ) [private]
void SDKSample::ApplicationDataSample::sealed::DisplayOutput ( ) [private]
void SDKSample::ApplicationDataSample::sealed::DisplayOutput ( bool remoteUpdate ) [private]
void SDKSample::ApplicationDataSample::sealed::DisplayOutput ( ) [private]
SDKSample::ApplicationDataSample::sealed::Files ( )
SDKSample::ApplicationDataSample::sealed::HighPriority ( )
void SDKSample::ApplicationDataSample::sealed::Increment_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::IncrementHighPriority_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationDataSample::sealed::Msappdata ( )
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationDataSample::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
void SDKSample::ApplicationDataSample::sealed::ReadCounter ( ) [private]
SDKSample::ApplicationDataSample::sealed::SettingContainer ( )
SDKSample::ApplicationDataSample::sealed::Settings ( )
SDKSample::ApplicationDataSample::sealed::SetVersion ( )
void SDKSample::ApplicationDataSample::sealed::SetVersion0_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::SetVersion1_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::SetVersionHandler0 ( Windows::Storage::SetVersionRequest^ request ) [private]
void SDKSample::ApplicationDataSample::sealed::SetVersionHandler1 ( Windows::Storage::SetVersionRequest^ request ) [private]
void SDKSample::ApplicationDataSample::sealed::SimulateRoaming_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::WriteCompositeSetting_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::WriteOutputText ( ) [private]
void SDKSample::ApplicationDataSample::sealed::WriteSetting_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ApplicationDataSample::sealed::WriteSetting_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Storage::ApplicationData SDKSample::ApplicationDataSample::sealed::appData [private]

Definition at line 39 of file SetVersion.xaml.h.

Windows::Storage::ApplicationData SDKSample::ApplicationDataSample::sealed::applicationData [private]

Definition at line 39 of file DataChangedEvent.xaml.h.

int SDKSample::ApplicationDataSample::sealed::counter [private]

Definition at line 40 of file Files.xaml.h.

Windows::Storage::ApplicationDataContainer sealed::localSettings [private]

Definition at line 39 of file SettingContainer.xaml.h.

Windows::Storage::StorageFolder SDKSample::ApplicationDataSample::sealed::roamingFolder [private]

Definition at line 39 of file Files.xaml.h.

Windows::Storage::ApplicationDataContainer sealed::roamingSettings [private]

Definition at line 39 of file CompositeSettings.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file ClearScenario.xaml.h.

The documentation for this class was generated from the following files:
  • Application data/C++/ClearScenario.xaml.h
  • Application data/C++/CompositeSettings.xaml.h
  • Application data/C++/DataChangedEvent.xaml.h
  • Application data/C++/Files.xaml.h
  • Application data/C++/HighPriority.xaml.h
  • Application data/C++/Msappdata.xaml.h
  • Application data/C++/SettingContainer.xaml.h
  • Application data/C++/Settings.xaml.h
  • Application data/C++/SetVersion.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ApplicationResources::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ApplicationResources
  • SDKSample::ApplicationResources::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ApplicationResources::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario10 ()
Scenario11 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()
Scenario6 ()
Scenario7 ()
Scenario8 ()
Scenario9 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ContextChanged (Windows::Foundation::Collections::IObservableMap< Platform::String^, Platform::String^>^sender, Windows::Foundation::Collections::IMapChangedEventArgs< Platform::String^>^eventArg)
void | Scenario10_SearchMultipleResourceIds (Windows::ApplicationModel::Resources::Core::ResourceContext^context, Platform::Collections::Vector< Platform::String^>^resourceIds)
void | Scenario10_ShowCandidates (Platform::String^resourceId, Windows::Foundation::Collections::IVectorView< Windows::ApplicationModel::Resources::Core::ResourceCandidate^>^resourceCandidates)
void | Scenario10Button_Show_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario11Button_Show_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario3StringLoad_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario5Button_Show_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario6Button_Show_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario7Button_Show_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario8Button_Show_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario9Button_Show_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | eventToken
MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::ApplicationResources::sealed::ContextChanged | ( | Windows::Foundation::Collections::IObservableMap< Platform::String^, Platform::String^>^ | sender,
 |  | Windows::Foundation::Collections::IMapChangedEventArgs< Platform::String^>^ | eventArg |
 | ) |  |  | [private]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationResources::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::ApplicationResources::sealed::Scenario1 ( )
SDKSample::ApplicationResources::sealed::Scenario10 ( )
void SDKSample::ApplicationResources::sealed::Scenario10_SearchMultipleResourceIds | ( | Windows::ApplicationModel::Resources::Core::ResourceContext^ | context,
 |  | Platform::Collections::Vector< Platform::String^>^ | resourceIds |
 | ) |  |  | [private]
void SDKSample::ApplicationResources::sealed::Scenario10_ShowCandidates | ( | Platform::String^ | resourceId,
 |  | Windows::Foundation::Collections::IVectorView< Windows::ApplicationModel::Resources::Core::ResourceCandidate^>^ | resourceCandidates |
 | ) |  |  | [private]
void SDKSample::ApplicationResources::sealed::Scenario10Button_Show_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationResources::sealed::Scenario11 ( )
void SDKSample::ApplicationResources::sealed::Scenario11Button_Show_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationResources::sealed::Scenario2 ( )
SDKSample::ApplicationResources::sealed::Scenario3 ( )
void SDKSample::ApplicationResources::sealed::Scenario3StringLoad_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationResources::sealed::Scenario4 ( )
SDKSample::ApplicationResources::sealed::Scenario5 ( )
void SDKSample::ApplicationResources::sealed::Scenario5Button_Show_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationResources::sealed::Scenario6 ( )
void SDKSample::ApplicationResources::sealed::Scenario6Button_Show_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationResources::sealed::Scenario7 ( )
void SDKSample::ApplicationResources::sealed::Scenario7Button_Show_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationResources::sealed::Scenario8 ( )
void SDKSample::ApplicationResources::sealed::Scenario8Button_Show_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationResources::sealed::Scenario9 ( )
void SDKSample::ApplicationResources::sealed::Scenario9Button_Show_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken SDKSample::ApplicationResources::sealed::eventToken [private]

Definition at line 43 of file Scenario7.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Application resources and localization/C++/Scenario1.xaml.h
  • Application resources and localization/C++/Scenario10.xaml.h
  • Application resources and localization/C++/Scenario11.xaml.h
  • Application resources and localization/C++/Scenario2.xaml.h
  • Application resources and localization/C++/Scenario3.xaml.h
  • Application resources and localization/C++/Scenario4.xaml.h
  • Application resources and localization/C++/Scenario5.xaml.h
  • Application resources and localization/C++/Scenario6.xaml.h
  • Application resources and localization/C++/Scenario7.xaml.h
  • Application resources and localization/C++/Scenario8.xaml.h
  • Application resources and localization/C++/Scenario9.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ApplicationSettings::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ApplicationSettings
  • SDKSample::ApplicationSettings::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ApplicationSettings::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "AddSettingsScenario.xaml.h"

List of all members.

Public Member Functions

AddSettingsScenario ()
DefaultScenario ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | addSettingsScenarioAdd_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | onCommandsRequested (Windows::UI::ApplicationSettings::SettingsPane^settingsPane, Windows::UI::ApplicationSettings::SettingsPaneCommandsRequestedEventArgs^eventArgs)
void | onSettingsCommand (Windows::UI::Popups::IUICommand^command)

Private Attributes

Windows::Foundation::EventRegistrationToken | commandsRequestedEventRegistrationToken
bool | isEventRegistered
MainPage rootPage

Detailed Description

Definition at line 30 of file AddSettingsScenario.xaml.h.

Member Function Documentation

SDKSample::ApplicationSettings::sealed::AddSettingsScenario ( )
void SDKSample::ApplicationSettings::sealed::addSettingsScenarioAdd_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ApplicationSettings::sealed::DefaultScenario ( )
void SDKSample::ApplicationSettings::sealed::onCommandsRequested | ( | Windows::UI::ApplicationSettings::SettingsPane^ | settingsPane,
 |  | Windows::UI::ApplicationSettings::SettingsPaneCommandsRequestedEventArgs^ | eventArgs |
 | ) |  |  | [private]
virtual void SDKSample::ApplicationSettings::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationSettings::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ApplicationSettings::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::ApplicationSettings::sealed::onSettingsCommand ( Windows::UI::Popups::IUICommand^ command ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken SDKSample::ApplicationSettings::sealed::commandsRequestedEventRegistrationToken [private]

Definition at line 44 of file AddSettingsScenario.xaml.h.

bool SDKSample::ApplicationSettings::sealed::isEventRegistered [private]

Definition at line 43 of file AddSettingsScenario.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file AddSettingsScenario.xaml.h.

The documentation for this class was generated from the following files:
  • App settings/C++/AddSettingsScenario.xaml.h
  • App settings/C++/DefaultScenario.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::AtomPub::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • AtomPub
  • SDKSample::AtomPub::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::AtomPub::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()

Protected Member Functions

virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatingFrom (NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (NavigatingCancelEventArgs^e) override

Private Member Functions

void | DeleteItem_Click (Object^sender, RoutedEventArgs^e)
void | DisplayItem ()
void | DisplayItem ()
void | DisplayItem ()
Uri | FindEditUri (ServiceDocument^serviceDocument)
void | GetFeed_Click (Object^sender, RoutedEventArgs^e)
void | GetFeed_Click (Object^sender, RoutedEventArgs^e)
void | GetFeed_Click (Object^sender, RoutedEventArgs^e)
void | NextItem_Click (Object^sender, RoutedEventArgs^e)
void | NextItem_Click (Object^sender, RoutedEventArgs^e)
void | NextItem_Click (Object^sender, RoutedEventArgs^e)
void | PasswordField_PasswordChanged (Object^sender, RoutedEventArgs^e)
void | PasswordField_PasswordChanged (Object^sender, RoutedEventArgs^e)
void | PasswordField_PasswordChanged (Object^sender, RoutedEventArgs^e)
void | PasswordField_PasswordChanged (Object^sender, RoutedEventArgs^e)
void | PreviousItem_Click (Object^sender, RoutedEventArgs^e)
void | PreviousItem_Click (Object^sender, RoutedEventArgs^e)
void | PreviousItem_Click (Object^sender, RoutedEventArgs^e)
void | SubmitItem_Click (Object^sender, RoutedEventArgs^e)
void | UpdateItem_Click (Object^sender, RoutedEventArgs^e)
void | UserNameField_TextChanged (Object^sender, TextChangedEventArgs^e)
void | UserNameField_TextChanged (Object^sender, TextChangedEventArgs^e)
void | UserNameField_TextChanged (Object^sender, TextChangedEventArgs^e)
void | UserNameField_TextChanged (Object^sender, TextChangedEventArgs^e)

Private Attributes

SyndicationItemIterator | feedIterator
MainPage rootPage

Detailed Description

Definition at line 34 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::AtomPub::sealed::DeleteItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::DisplayItem ( ) [private]
void SDKSample::AtomPub::sealed::DisplayItem ( ) [private]
void SDKSample::AtomPub::sealed::DisplayItem ( ) [private]
Uri SDKSample::AtomPub::sealed::FindEditUri ( ServiceDocument^ serviceDocument ) [private]
void SDKSample::AtomPub::sealed::GetFeed_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::GetFeed_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::GetFeed_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::NextItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::NextItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::NextItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::AtomPub::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AtomPub::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AtomPub::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AtomPub::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AtomPub::sealed::OnNavigatingFrom ( NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AtomPub::sealed::OnNavigatingFrom ( NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AtomPub::sealed::OnNavigatingFrom ( NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::AtomPub::sealed::OnNavigatingFrom ( NavigatingCancelEventArgs^ e ) [override, protected, virtual]
void SDKSample::AtomPub::sealed::PasswordField_PasswordChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::PasswordField_PasswordChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::PasswordField_PasswordChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::PasswordField_PasswordChanged | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::PreviousItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::PreviousItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::PreviousItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::AtomPub::sealed::Scenario1 ( )
SDKSample::AtomPub::sealed::Scenario2 ( )
SDKSample::AtomPub::sealed::Scenario3 ( )
SDKSample::AtomPub::sealed::Scenario4 ( )
void SDKSample::AtomPub::sealed::SubmitItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::UpdateItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::UserNameField_TextChanged | ( | Object^ | sender,
 |  | TextChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::UserNameField_TextChanged | ( | Object^ | sender,
 |  | TextChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::UserNameField_TextChanged | ( | Object^ | sender,
 |  | TextChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::AtomPub::sealed::UserNameField_TextChanged | ( | Object^ | sender,
 |  | TextChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

SyndicationItemIterator sealed::feedIterator [private]

Definition at line 45 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 44 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • AtomPub/C++/Scenario1.xaml.h
  • AtomPub/C++/Scenario2.xaml.h
  • AtomPub/C++/Scenario3.xaml.h
  • AtomPub/C++/Scenario4.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::BackgroundTask::BackgroundTaskSample Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • BackgroundTask
  • SDKSample::BackgroundTask::BackgroundTaskSample
Static Public Member Functions | Static Public Attributes

SDKSample::BackgroundTask::BackgroundTaskSample Class Reference

#include "Constants.h"

List of all members.

Static Public Member Functions

static String | GetBackgroundTaskStatus (Platform::String^name)
static void | InitializeBackgroundTaskStatus ()
static BackgroundTaskRegistration | RegisterBackgroundTask (String^taskEntryPoint, String^name, IBackgroundTrigger^trigger, IBackgroundCondition^condition)
static void | RegisterServicingCompleteBackgroundTask ()
static void | UnregisterBackgroundTasks (String^name)
static void | UpdateBackgroundTaskStatus (Platform::String^name, bool registered)

Static Public Attributes

static String | SampleBackgroundTaskProgress = ""
static bool | SampleBackgroundTaskRegistered = false
static String | SampleBackgroundTaskWithConditionProgress = ""
static bool | SampleBackgroundTaskWithConditionRegistered = false
static String | ServicingCompleteTaskProgress = ""
static bool | ServicingCompleteTaskRegistered = false
static String | TimeTriggeredTaskProgress = ""
static bool | TimeTriggeredTaskRegistered = false

Detailed Description

Definition at line 58 of file Constants.h.

Member Function Documentation

String BackgroundTaskSample::GetBackgroundTaskStatus ( Platform::String^ name ) [static]

Definition at line 40 of file Constants.cpp.

{
    auto registered = false;
    if (name == SampleBackgroundTaskName)
    {
        registered = BackgroundTaskSample::SampleBackgroundTaskRegistered;
    }
    else if (name == SampleBackgroundTaskWithConditionName)
    {
        registered = BackgroundTaskSample::SampleBackgroundTaskWithConditionRegistered;
    }
    else if (name == ServicingCompleteTaskName)
    {
        registered = BackgroundTaskSample::ServicingCompleteTaskRegistered;
    }
    else if (name == TimeTriggeredTaskName)
    {
        registered = BackgroundTaskSample::TimeTriggeredTaskRegistered;
    }

    String^ status = registered ? "Registered" : "Unregistered";

    auto settings = ApplicationData::Current->LocalSettings->Values;
    if (settings->HasKey(name))
    {
        status += " - " + dynamic_cast<String^>(settings->Lookup(name));
    }

    return status;
}

void BackgroundTaskSample::InitializeBackgroundTaskStatus ( ) [static]

Definition at line 74 of file Constants.cpp.

{
    auto iter = BackgroundTaskRegistration::AllTasks->First();
    auto hascur = iter->HasCurrent;
    while (hascur)
    {
        auto cur = iter->Current->Value;
        UpdateBackgroundTaskStatus(cur->Name, true);
        hascur = iter->MoveNext();
    }
}

BackgroundTaskRegistration BackgroundTaskSample::RegisterBackgroundTask | ( | String^ | taskEntryPoint,
 |  | String^ | name,
 |  | IBackgroundTrigger^ | trigger,
 |  | IBackgroundCondition^ | condition |
 | ) |  |  | [static]

Definition at line 86 of file Constants.cpp.

{
    auto builder = ref new BackgroundTaskBuilder();

    builder->Name = name;
    builder->TaskEntryPoint = taskEntryPoint;
    builder->SetTrigger(trigger);

    if (condition != nullptr)
    {
        builder->AddCondition(condition);
    }

    auto task = builder->Register();

    UpdateBackgroundTaskStatus(name, true);

    //
    // Remove previous completion status from local settings.
    //
    auto settings = ApplicationData::Current->LocalSettings->Values;
    settings->Remove(name);

    return task;
}

void BackgroundTaskSample::RegisterServicingCompleteBackgroundTask ( ) [static]

Definition at line 115 of file Constants.cpp.

{
    //
    // Check whether the servicing-complete background task is already registered.
    //
    auto iter = BackgroundTaskRegistration::AllTasks->First();
    auto hascur = iter->HasCurrent;
    while (hascur)
    {
        auto cur = iter->Current->Value;

        if (cur->Name == ServicingCompleteTaskName)
        {
            //
            // The task is already registered.
            //
            return;
        }

        hascur = iter->MoveNext();
    }

    //
    // The servicing-complete background task is not already registered.
    //
    RegisterBackgroundTask(ServicingCompleteTaskEntryPoint,
                           ServicingCompleteTaskName,
                           ref new SystemTrigger(SystemTriggerType::ServicingComplete, false),
                           nullptr);
}

void BackgroundTaskSample::UnregisterBackgroundTasks ( String^ name ) [static]

Definition at line 149 of file Constants.cpp.

{
    //
    // Loop through all background tasks and unregister any that have a name that matches
    // the name passed into this function.
    //
    auto iter = BackgroundTaskRegistration::AllTasks->First();
    auto hascur = iter->HasCurrent;
    while (hascur)
    {
        auto cur = iter->Current->Value;

        if(cur->Name == name)
        {
            cur->Unregister(true);
            UpdateBackgroundTaskStatus(name, false);
        }

        hascur = iter->MoveNext();
    }
}

void BackgroundTaskSample::UpdateBackgroundTaskStatus | ( | Platform::String^ | name,
 |  | bool | registered |
 | ) |  |  | [static]

Definition at line 171 of file Constants.cpp.

{
    if (name == SampleBackgroundTaskName)
    {
        BackgroundTaskSample::SampleBackgroundTaskRegistered = registered;
    }
    else if (name == SampleBackgroundTaskWithConditionName)
    {
        BackgroundTaskSample::SampleBackgroundTaskWithConditionRegistered = registered;
    }
    else if (name == ServicingCompleteTaskName)
    {
        BackgroundTaskSample::ServicingCompleteTaskRegistered = registered;
    }
    else if (name == TimeTriggeredTaskName)
    {
        BackgroundTaskSample::TimeTriggeredTaskRegistered = registered;
    }
}

Member Data Documentation

String BackgroundTaskSample::SampleBackgroundTaskProgress = "" [static]

Definition at line 68 of file Constants.h.

bool BackgroundTaskSample::SampleBackgroundTaskRegistered = false [static]

Definition at line 69 of file Constants.h.

String BackgroundTaskSample::SampleBackgroundTaskWithConditionProgress = "" [static]

Definition at line 71 of file Constants.h.

bool BackgroundTaskSample::SampleBackgroundTaskWithConditionRegistered = false [static]

Definition at line 72 of file Constants.h.

String BackgroundTaskSample::ServicingCompleteTaskProgress = "" [static]

Definition at line 74 of file Constants.h.

bool BackgroundTaskSample::ServicingCompleteTaskRegistered = false [static]

Definition at line 75 of file Constants.h.

String BackgroundTaskSample::TimeTriggeredTaskProgress = "" [static]

Definition at line 77 of file Constants.h.

bool BackgroundTaskSample::TimeTriggeredTaskRegistered = false [static]

Definition at line 78 of file Constants.h.

The documentation for this class was generated from the following files:
  • Background task/C++/BackgroundTask/Constants.h
  • Background task/C++/BackgroundTask/Constants.cpp
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::BackgroundTask::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • BackgroundTask
  • SDKSample::BackgroundTask::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::BackgroundTask::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "SampleBackgroundTask.xaml.h"

List of all members.

Public Member Functions

SampleBackgroundTask ()
ServicingCompleteTask ()
TimeTriggeredTask ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | AttachProgressAndCompletedHandlers (Windows::ApplicationModel::Background::IBackgroundTaskRegistration^task)
void | AttachProgressAndCompletedHandlers (Windows::ApplicationModel::Background::IBackgroundTaskRegistration^task)
void | AttachProgressAndCompletedHandlers (Windows::ApplicationModel::Background::IBackgroundTaskRegistration^task)
void | RegisterBackgroundTask (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RegisterBackgroundTask (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RegisterBackgroundTask (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UnregisterBackgroundTask (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UnregisterBackgroundTask (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UnregisterBackgroundTask (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateUI ()
void | UpdateUI ()
void | UpdateUI ()

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file SampleBackgroundTask.xaml.h.

Member Function Documentation

void SDKSample::BackgroundTask::sealed::AttachProgressAndCompletedHandlers ( Windows::ApplicationModel::Background::IBackgroundTaskRegistration^ task ) [private]
void SDKSample::BackgroundTask::sealed::AttachProgressAndCompletedHandlers ( Windows::ApplicationModel::Background::IBackgroundTaskRegistration^ task ) [private]
void SDKSample::BackgroundTask::sealed::AttachProgressAndCompletedHandlers ( Windows::ApplicationModel::Background::IBackgroundTaskRegistration^ task ) [private]
virtual void SDKSample::BackgroundTask::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::BackgroundTask::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::BackgroundTask::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::BackgroundTask::sealed::RegisterBackgroundTask | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTask::sealed::RegisterBackgroundTask | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTask::sealed::RegisterBackgroundTask | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::BackgroundTask::sealed::SampleBackgroundTask ( )
SDKSample::BackgroundTask::sealed::ServicingCompleteTask ( )
SDKSample::BackgroundTask::sealed::TimeTriggeredTask ( )
void SDKSample::BackgroundTask::sealed::UnregisterBackgroundTask | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTask::sealed::UnregisterBackgroundTask | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTask::sealed::UnregisterBackgroundTask | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTask::sealed::UpdateUI ( ) [private]
void SDKSample::BackgroundTask::sealed::UpdateUI ( ) [private]
void SDKSample::BackgroundTask::sealed::UpdateUI ( ) [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file SampleBackgroundTask.xaml.h.

The documentation for this class was generated from the following files:
  • Background task/C++/BackgroundTask/SampleBackgroundTask.xaml.h
  • Background task/C++/BackgroundTask/ServicingCompleteTask.xaml.h
  • Background task/C++/BackgroundTask/TimeTriggeredTask.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::BackgroundTaskSample Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::BackgroundTaskSample
Static Public Member Functions | Static Public Attributes

SDKSample::BackgroundTaskSample Class Reference

#include "Constants.h"

List of all members.

Static Public Member Functions

static BackgroundTaskRegistration | RegisterBackgroundTask (String^taskEntryPoint, String^name, IBackgroundTrigger^trigger, IBackgroundCondition^condition)
static void | UnregisterBackgroundTasks (String^name)
static void | UpdateBackgroundTaskStatus (Platform::String^name, bool registered)

Static Public Attributes

static bool | SampleBackgroundTaskWithConditionRegistered = false

Detailed Description

Definition at line 52 of file Constants.h.

Member Function Documentation

BackgroundTaskRegistration BackgroundTaskSample::RegisterBackgroundTask | ( | String^ | taskEntryPoint,
 |  | String^ | name,
 |  | IBackgroundTrigger^ | trigger,
 |  | IBackgroundCondition^ | condition |
 | ) |  |  | [static]

Definition at line 27 of file Constants.cpp.

{
    auto builder = ref new BackgroundTaskBuilder();

    builder->Name = name;
    builder->TaskEntryPoint = taskEntryPoint;
    builder->SetTrigger(trigger);

    if (condition != nullptr)
    {
        builder->AddCondition(condition);
    }

    auto task = builder->Register();

    UpdateBackgroundTaskStatus(name, true);

    return task;
}

void BackgroundTaskSample::UnregisterBackgroundTasks ( String^ name ) [static]

Definition at line 51 of file Constants.cpp.

{
    //
    // Loop through all background tasks and unregister any that have a name that matches
    // the name passed into this function.
    //
    auto iter = BackgroundTaskRegistration::AllTasks->First();
    auto hascur = iter->HasCurrent;
    while (hascur)
    {
        auto cur = iter->Current->Value;

        if(cur->Name == name)
        {
            cur->Unregister(true);
            UpdateBackgroundTaskStatus(name, false);
        }

        hascur = iter->MoveNext();
    }
}

void BackgroundTaskSample::UpdateBackgroundTaskStatus | ( | Platform::String^ | name,
 |  | bool | registered |
 | ) |  |  | [static]

Definition at line 73 of file Constants.cpp.

{
    if (name == SampleBackgroundTaskWithConditionName)
    {
        BackgroundTaskSample::SampleBackgroundTaskWithConditionRegistered = registered;
    }
}

Member Data Documentation

bool BackgroundTaskSample::SampleBackgroundTaskWithConditionRegistered = false [static]

Definition at line 59 of file Constants.h.

The documentation for this class was generated from the following files:
  • Network status background/C++/NetworkStatusApp/Constants.h
  • Network status background/C++/NetworkStatusApp/Constants.cpp
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::BackgroundTransfer::GuidComparer Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • BackgroundTransfer
  • SDKSample::BackgroundTransfer::GuidComparer
Public Member Functions

SDKSample::BackgroundTransfer::GuidComparer Struct Reference

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

bool operator() (const Platform::Guid &lhs, const Platform::Guid &rhs) const

Detailed Description

Definition at line 26 of file Scenario1.xaml.h.

Member Function Documentation

bool SDKSample::BackgroundTransfer::GuidComparer::operator() | ( | const Platform::Guid & | lhs,
 |  | const Platform::Guid & | rhs |
 | ) |  |  | const [inline]

Definition at line 28 of file Scenario1.xaml.h.

          {
              return false;
          }

The documentation for this struct was generated from the following file:
  • Background Transfer/C++/Scenario1.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::BackgroundTransfer::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • BackgroundTransfer
  • SDKSample::BackgroundTransfer::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::BackgroundTransfer::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

~Scenario1 ()
~Scenario2 ()
void | CancelAll_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CancelAll_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DiscoverActiveDownloads ()
void | DiscoverActiveUploads ()
void | DownloadProgress (Windows::Foundation::IAsyncOperationWithProgress< Windows::Networking::BackgroundTransfer::DownloadOperation^, Windows::Networking::BackgroundTransfer::DownloadOperation^>^operation, Windows::Networking::BackgroundTransfer::DownloadOperation^)
void | HandleDownloadAsync (Windows::Networking::BackgroundTransfer::DownloadOperation^download, boolean start)
void | HandleUploadAsync (Windows::Networking::BackgroundTransfer::UploadOperation^upload, bool start)
void | Log (Platform::String^message)
void | Log (Platform::String^message)
void | LogException (Platform::String^title, Platform::Exception^ex)
void | LogException (Platform::String^title, Platform::Exception^ex)
void | LogStatus (Platform::String^message, NotifyType type)
void | LogStatus (Platform::String^message, NotifyType type)
void | MarshalLog (Platform::String^value)
void | MarshalLog (Platform::String^value)
void | PauseAll_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ResumeAll_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartDownload_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartMultipartUpload_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartUpload_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UploadProgress (Windows::Foundation::IAsyncOperationWithProgress< Windows::Networking::BackgroundTransfer::UploadOperation^, Windows::Networking::BackgroundTransfer::UploadOperation^>^operation, Windows::Networking::BackgroundTransfer::UploadOperation^)

Private Attributes

std::map< int,
Windows::Networking::BackgroundTransfer::DownloadOperation^> 		activeDownloads
Concurrency::cancellation_token_source * | cancellationToken
MainPage rootPage

Detailed Description

Definition at line 38 of file Scenario1.xaml.h.

Constructor & Destructor Documentation

SDKSample::BackgroundTransfer::sealed::~Scenario1 ( ) [private]
SDKSample::BackgroundTransfer::sealed::~Scenario2 ( ) [private]

Member Function Documentation

void SDKSample::BackgroundTransfer::sealed::CancelAll_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::CancelAll_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::DiscoverActiveDownloads ( ) [private]
void SDKSample::BackgroundTransfer::sealed::DiscoverActiveUploads ( ) [private]
void SDKSample::BackgroundTransfer::sealed::DownloadProgress | ( | Windows::Foundation::IAsyncOperationWithProgress< Windows::Networking::BackgroundTransfer::DownloadOperation^, Windows::Networking::BackgroundTransfer::DownloadOperation^>^ | operation,
 |  | Windows::Networking::BackgroundTransfer::DownloadOperation^ |  |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::HandleDownloadAsync | ( | Windows::Networking::BackgroundTransfer::DownloadOperation^ | download,
 |  | boolean | start |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::HandleUploadAsync | ( | Windows::Networking::BackgroundTransfer::UploadOperation^ | upload,
 |  | bool | start |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::Log ( Platform::String^ message ) [private]
void SDKSample::BackgroundTransfer::sealed::Log ( Platform::String^ message ) [private]
void SDKSample::BackgroundTransfer::sealed::LogException | ( | Platform::String^ | title,
 |  | Platform::Exception^ | ex |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::LogException | ( | Platform::String^ | title,
 |  | Platform::Exception^ | ex |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::LogStatus | ( | Platform::String^ | message,
 |  | NotifyType | type |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::LogStatus | ( | Platform::String^ | message,
 |  | NotifyType | type |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::MarshalLog ( Platform::String^ value ) [private]
void SDKSample::BackgroundTransfer::sealed::MarshalLog ( Platform::String^ value ) [private]
virtual void SDKSample::BackgroundTransfer::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::BackgroundTransfer::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::BackgroundTransfer::sealed::PauseAll_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::ResumeAll_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::BackgroundTransfer::sealed::Scenario1 ( )
SDKSample::BackgroundTransfer::sealed::Scenario2 ( )
void SDKSample::BackgroundTransfer::sealed::StartDownload_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::StartMultipartUpload_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::StartUpload_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::BackgroundTransfer::sealed::UploadProgress | ( | Windows::Foundation::IAsyncOperationWithProgress< Windows::Networking::BackgroundTransfer::UploadOperation^, Windows::Networking::BackgroundTransfer::UploadOperation^>^ | operation,
 |  | Windows::Networking::BackgroundTransfer::UploadOperation^ |  |
 | ) |  |  | [private]

Member Data Documentation

std::map<int , Windows::Networking::BackgroundTransfer::DownloadOperation^> SDKSample::BackgroundTransfer::sealed::activeDownloads [private]

Definition at line 49 of file Scenario1.xaml.h.

Concurrency::cancellation_token_source * sealed::cancellationToken [private]

Definition at line 48 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 47 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Background Transfer/C++/Scenario1.xaml.h
  • Background Transfer/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CalendarSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CalendarSample
  • SDKSample::CalendarSample::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::CalendarSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "CalendarEnumerationAndMath.xaml.h"

List of all members.

Public Member Functions

CalendarEnumerationAndMath ()
DisplayCalendarData ()
DisplayCalendarStatistics ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file CalendarEnumerationAndMath.xaml.h.

Member Function Documentation

SDKSample::CalendarSample::sealed::CalendarEnumerationAndMath ( )
void SDKSample::CalendarSample::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CalendarSample::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CalendarSample::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::CalendarSample::sealed::DisplayCalendarData ( )
SDKSample::CalendarSample::sealed::DisplayCalendarStatistics ( )
virtual void SDKSample::CalendarSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CalendarSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CalendarSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file CalendarEnumerationAndMath.xaml.h.

The documentation for this class was generated from the following files:
  • Calendar details and math/C++/CalendarEnumerationAndMath.xaml.h
  • Calendar details and math/C++/DisplayCalendarData.xaml.h
  • Calendar details and math/C++/DisplayCalendarStatistics.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CallControl::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CallControl
  • SDKSample::CallControl::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::CallControl::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "PhoneCall.xaml.h"

List of all members.

Public Member Functions

PhoneCall ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ButtonHangUp_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ButtonInitialize_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ButtonRing_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CallControlError (String^ErrorText)
void | CallControls_AnswerRequested (Devices::CallControl^sender)
void | CallControls_AudioTransferRequested (Devices::CallControl^sender)
void | CallControls_DialRequested (Devices::CallControl^sender, Devices::DialRequestedEventArgs^e)
void | CallControls_HangUpRequested (Devices::CallControl^sender)
void | CallControls_RedialRequested (Devices::CallControl^sender, Devices::RedialRequestedEventArgs^e)
void | CallControlStatus (String^StatusText)
void | disableHangUpButton ()
void | disableIncomingCallButton ()
void | disableInitializeButton ()
void | enableHangUpButton ()
void | enableIncomingCallButton ()
void | enableInitializeButton ()
void | PauseAudio ()
void | PlayAudio ()
void | SetAudioSource ()
void | StopAudio ()

Private Attributes

Windows::UI::Core::CoreDispatcher | _dispatcher
Devices::CallControl | CallControls
unsigned long long | CallToken
MainPage rootPage

Detailed Description

Definition at line 34 of file PhoneCall.xaml.h.

Member Function Documentation

void SDKSample::CallControl::sealed::ButtonHangUp_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CallControl::sealed::ButtonInitialize_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CallControl::sealed::ButtonRing_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CallControl::sealed::CallControlError ( String^ ErrorText ) [private]
void SDKSample::CallControl::sealed::CallControls_AnswerRequested ( Devices::CallControl^ sender ) [private]
void SDKSample::CallControl::sealed::CallControls_AudioTransferRequested ( Devices::CallControl^ sender ) [private]
void SDKSample::CallControl::sealed::CallControls_DialRequested | ( | Devices::CallControl^ | sender,
 |  | Devices::DialRequestedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CallControl::sealed::CallControls_HangUpRequested ( Devices::CallControl^ sender ) [private]
void SDKSample::CallControl::sealed::CallControls_RedialRequested | ( | Devices::CallControl^ | sender,
 |  | Devices::RedialRequestedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CallControl::sealed::CallControlStatus ( String^ StatusText ) [private]
void SDKSample::CallControl::sealed::disableHangUpButton ( ) [private]
void SDKSample::CallControl::sealed::disableIncomingCallButton ( ) [private]
void SDKSample::CallControl::sealed::disableInitializeButton ( ) [private]
void SDKSample::CallControl::sealed::enableHangUpButton ( ) [private]
void SDKSample::CallControl::sealed::enableIncomingCallButton ( ) [private]
void SDKSample::CallControl::sealed::enableInitializeButton ( ) [private]
virtual void SDKSample::CallControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::CallControl::sealed::PauseAudio ( ) [private]
SDKSample::CallControl::sealed::PhoneCall ( )
void SDKSample::CallControl::sealed::PlayAudio ( ) [private]
void SDKSample::CallControl::sealed::SetAudioSource ( ) [private]
void SDKSample::CallControl::sealed::StopAudio ( ) [private]

Member Data Documentation

Windows::UI::Core::CoreDispatcher SDKSample::CallControl::sealed::_dispatcher [private]

Definition at line 70 of file PhoneCall.xaml.h.

Devices::CallControl SDKSample::CallControl::sealed::CallControls [private]

Definition at line 69 of file PhoneCall.xaml.h.

unsigned long long SDKSample::CallControl::sealed::CallToken [private]

Definition at line 71 of file PhoneCall.xaml.h.

MainPage SDKSample::CallControl::sealed::rootPage [private]

Definition at line 42 of file PhoneCall.xaml.h.

The documentation for this class was generated from the following file:
  • Bluetooth call control/C++/PhoneCall.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CameraCapture::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CameraCapture
  • SDKSample::CameraCapture::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::CameraCapture::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "CapturePhoto.xaml.h"

List of all members.

Public Member Functions

CapturePhoto ()
CaptureVideo ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CapturePhoto_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CaptureVideo_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LoadPhoto (Platform::String^filepath)
void | LoadVideo (Platform::String^filePath)
void | Reset_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Reset_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::Foundation::Collections::IPropertySet | appSettings
MainPage rootPage

Detailed Description

Definition at line 30 of file CapturePhoto.xaml.h.

Member Function Documentation

SDKSample::CameraCapture::sealed::CapturePhoto ( )
void SDKSample::CameraCapture::sealed::CapturePhoto_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::CameraCapture::sealed::CaptureVideo ( )
void SDKSample::CameraCapture::sealed::CaptureVideo_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CameraCapture::sealed::LoadPhoto ( Platform::String^ filepath ) [private]
void SDKSample::CameraCapture::sealed::LoadVideo ( Platform::String^ filePath ) [private]
virtual void SDKSample::CameraCapture::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CameraCapture::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::CameraCapture::sealed::Reset_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CameraCapture::sealed::Reset_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Foundation::Collections::IPropertySet sealed::appSettings [private]

Definition at line 43 of file CapturePhoto.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file CapturePhoto.xaml.h.

The documentation for this class was generated from the following files:
  • CameraCaptureUI/C++/CapturePhoto.xaml.h
  • CameraCaptureUI/C++/CaptureVideo.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CameraOptions::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CameraOptions
  • SDKSample::CameraOptions::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::CameraOptions::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "ShowOptionsUI.xaml.h"

List of all members.

Public Member Functions

ShowOptionsUI ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | MediaControl_SoundLevelChanged (Platform::Object^sender, Platform::Object^e)
void | ShowSettings_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartPreview_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::UI::Core::CoreDispatcher | dispatcher
Platform::Agile
< Windows::Media::Capture::MediaCapture > 		mediaCaptureMgr
bool | previewStarted
MainPage rootPage

Detailed Description

Definition at line 31 of file ShowOptionsUI.xaml.h.

Member Function Documentation

void SDKSample::CameraOptions::sealed::MediaControl_SoundLevelChanged | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::CameraOptions::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::CameraOptions::sealed::ShowOptionsUI ( )
void SDKSample::CameraOptions::sealed::ShowSettings_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CameraOptions::sealed::StartPreview_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::UI::Core::CoreDispatcher SDKSample::CameraOptions::sealed::dispatcher [private]

Definition at line 48 of file ShowOptionsUI.xaml.h.

Platform::Agile<Windows::Media::Capture::MediaCapture> SDKSample::CameraOptions::sealed::mediaCaptureMgr [private]

Definition at line 45 of file ShowOptionsUI.xaml.h.

bool SDKSample::CameraOptions::sealed::previewStarted [private]

Definition at line 46 of file ShowOptionsUI.xaml.h.

MainPage SDKSample::CameraOptions::sealed::rootPage [private]

Definition at line 40 of file ShowOptionsUI.xaml.h.

The documentation for this class was generated from the following file:
  • CameraOptionsUI/C++/ShowOptionsUI.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CertificateEnrollment::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CertificateEnrollment
  • SDKSample::CertificateEnrollment::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::CertificateEnrollment::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario_Enroll.xaml.h"

List of all members.

Public Member Functions

Scenario_Enroll ()
Scenario_Import ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CreateRequest_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ImportPfx_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InstallCertifiate_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SubmitCertificateRequestAndGetResponse (Platform::String^certificateRequest, Platform::String^url)

Private Attributes

Platform::String | certificateRequest
Web::HttpRequest httpRequest
MainPage rootPage

Detailed Description

Definition at line 31 of file Scenario_Enroll.xaml.h.

Member Function Documentation

void SDKSample::CertificateEnrollment::sealed::CreateRequest_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CertificateEnrollment::sealed::ImportPfx_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CertificateEnrollment::sealed::InstallCertifiate_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::CertificateEnrollment::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CertificateEnrollment::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::CertificateEnrollment::sealed::Scenario_Enroll ( )
SDKSample::CertificateEnrollment::sealed::Scenario_Import ( )
void SDKSample::CertificateEnrollment::sealed::SubmitCertificateRequestAndGetResponse | ( | Platform::String^ | certificateRequest,
 |  | Platform::String^ | url |
 | ) |  |  | [private]

Member Data Documentation

Platform::String SDKSample::CertificateEnrollment::sealed::certificateRequest [private]

Definition at line 40 of file Scenario_Enroll.xaml.h.

Web::HttpRequest SDKSample::CertificateEnrollment::sealed::httpRequest [private]

Definition at line 42 of file Scenario_Enroll.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 39 of file Scenario_Enroll.xaml.h.

The documentation for this class was generated from the following files:
  • Certificate enrollment/C++/Scenario_Enroll.xaml.h
  • Certificate enrollment/C++/Scenario_Import.xaml.h
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Common
  • SDKSample::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

SDKSample::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

#include "LayoutAwarePage.h"

Inherited by SDKSample::Common::SharePage.

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual void | GoForward (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreDispatcher_AcceleratorKeyActivated (Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | CoreWindow_PointerPressed (Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnLoaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnUnloaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | WindowSizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | _acceleratorKeyEventToken
Platform::Collections::Map
< Platform::String^,
Platform::Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
bool | _navigationShortcutsRegistered
Platform::String | _pageKey
Windows::Foundation::EventRegistrationToken | _pointerPressedEventToken
LayoutAwarePage _this
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 40 of file LayoutAwarePage.h.

Member Function Documentation

void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated | ( | Windows::UI::Core::CoreDispatcher^ | sender,
 |  | Windows::UI::Core::AcceleratorKeyEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::CoreWindow_PointerPressed | ( | Windows::UI::Core::CoreWindow^ | sender,
 |  | Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [private]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual Platform::String SDKSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::GoForward | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 359 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
void SDKSample::Common::LayoutAwarePage::InvalidateVisualState ( )
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
virtual void SDKSample::Common::LayoutAwarePage::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [virtual]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Invoked when the page is part of the visual tree.

Parameters:
sender | Instance that triggered the event.
e | Event data describing the conditions that led to the event.

Definition at line 86 of file LayoutAwarePage.cpp.

{
  this->StartLayoutUpdates(sender, e);

  // Keyboard and mouse navigation only apply when occupying the entire window
  if (this->ActualHeight == Window::Current->Bounds.Height &&
    this->ActualWidth == Window::Current->Bounds.Width)
  {
    // Listen to the window directly so focus isn't required
    _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
      ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
      &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
    _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
      ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
      &LayoutAwarePage::CoreWindow_PointerPressed);
    _navigationShortcutsRegistered = true;
  }
}

void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnLoaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

virtual void SDKSample::Common::LayoutAwarePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]

Reimplemented in SDKSample::Common::SharePage.

void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Invoked when the page is removed from visual tree.

Parameters:
sender | Instance that triggered the event.
e | Event data describing the conditions that led to the event.

Definition at line 110 of file LayoutAwarePage.cpp.

{
  if (_navigationShortcutsRegistered)
  {
    Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
    Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
    _navigationShortcutsRegistered = false;
  }
  StopLayoutUpdates(sender, e);
}

void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::OnUnloaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
virtual void SDKSample::Common::LayoutAwarePage::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [virtual]
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Common::LayoutAwarePage::WindowSizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal SDKSample::Common::LayoutAwarePage::__pad0__

Definition at line 43 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken SDKSample::Common::LayoutAwarePage::_acceleratorKeyEventToken [private]

Definition at line 74 of file LayoutAwarePage.h.

Platform::Collections::Map< Platform::String^, Platform::Object^> SDKSample::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 73 of file LayoutAwarePage.h.

Platform::Collections::Vector< Windows::UI::Xaml::Controls::Control^> SDKSample::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 76 of file LayoutAwarePage.h.

bool SDKSample::Common::LayoutAwarePage::_navigationShortcutsRegistered [private]

Definition at line 72 of file LayoutAwarePage.h.

Platform::String SDKSample::Common::LayoutAwarePage::_pageKey [private]

Definition at line 71 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken SDKSample::Common::LayoutAwarePage::_pointerPressedEventToken [private]

Definition at line 74 of file LayoutAwarePage.h.

LayoutAwarePage SDKSample::Common::LayoutAwarePage::_this [private]

Definition at line 85 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken SDKSample::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 74 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Accelerometer sensor/C++/common/LayoutAwarePage.h
  • Animation metrics/C++/common/LayoutAwarePage.h
  • App package information/C++/common/LayoutAwarePage.h
  • App settings/C++/common/LayoutAwarePage.h
  • App tiles and badges/C#,C++/common/LayoutAwarePage.h
  • Application data/C++/common/LayoutAwarePage.h
  • AtomPub/C++/common/LayoutAwarePage.h
  • Background task/C++/BackgroundTask/common/LayoutAwarePage.h
  • Background Transfer/C++/common/LayoutAwarePage.h
  • Bluetooth call control/C++/common/LayoutAwarePage.h
  • Calendar details and math/C++/common/LayoutAwarePage.h
  • CameraCaptureUI/C++/common/LayoutAwarePage.h
  • CameraOptionsUI/C++/common/LayoutAwarePage.h
  • Certificate enrollment/C++/common/LayoutAwarePage.h
  • Check if current session is remote/C++/common/LayoutAwarePage.h
  • Compass sensor/C++/common/LayoutAwarePage.h
  • Compression/C++/common/LayoutAwarePage.h
  • Configure keys for media/C++/common/LayoutAwarePage.h
  • Connecting with WebSockets/C++/common/LayoutAwarePage.h
  • Context menu/C++/common/LayoutAwarePage.h
  • Credential locker/C++/common/LayoutAwarePage.h
  • CryptoWinRT/C++/common/LayoutAwarePage.h
  • Custom driver access/C++/app_cpp/common/LayoutAwarePage.h
  • Date and time formatting/C++/common/LayoutAwarePage.h
  • Device auto rotation preferences/C++/common/LayoutAwarePage.h
  • Device enumeration/C++/common/LayoutAwarePage.h
  • Display orientation/C++/common/LayoutAwarePage.h
  • EAS policies for mail clients/C++/common/LayoutAwarePage.h
  • Extended Linguistic Services (ELS)/C++/common/LayoutAwarePage.h
  • File access/C++/common/LayoutAwarePage.h
  • File and folder thumbnail/C++/common/LayoutAwarePage.h
  • File picker/C++/common/LayoutAwarePage.h
  • File picker contracts/C++/common/LayoutAwarePage.h
  • Folder enumeration/C++/common/LayoutAwarePage.h
  • Geolocation/C++/common/LayoutAwarePage.h
  • Globalization preferences/C++/common/LayoutAwarePage.h
  • Gyrometer sensor/C++/common/LayoutAwarePage.h
  • HomeGroup app/C++/common/LayoutAwarePage.h
  • HttpClient/C++/common/LayoutAwarePage.h
  • Inclinometer sensor/C++/common/LayoutAwarePage.h
  • Input Device capabilities/C++/common/LayoutAwarePage.h
  • Input Touch keyboard/C++/common/LayoutAwarePage.h
  • Input Touch keyboard text input/C++/common/LayoutAwarePage.h
  • LightSensor/C++/common/LayoutAwarePage.h
  • Lock screen personalization/C++/common/LayoutAwarePage.h
  • Media capture using capture device/C++/common/LayoutAwarePage.h
  • Media Play To/C++/common/LayoutAwarePage.h
  • Media Server client/C++/common/LayoutAwarePage.h
  • Message dialog/C++/common/LayoutAwarePage.h
  • Network information/C++/common/LayoutAwarePage.h
  • Number formatting and parsing/C++/common/LayoutAwarePage.h
  • OrientationSensor/C++/common/LayoutAwarePage.h
  • Playback Manager Companion/C++/common/LayoutAwarePage.h
  • Playback Manager msAudioCategory/C++/common/LayoutAwarePage.h
  • Playlist/C++/common/LayoutAwarePage.h
  • PlayToReceiver/C++/common/LayoutAwarePage.h
  • Portable device API/C++/common/LayoutAwarePage.h
  • Programmatic file search/C++/common/LayoutAwarePage.h
  • Reading and writing data/C++/common/LayoutAwarePage.h
  • Removable storage/C++/common/LayoutAwarePage.h
  • Scaling according to DPI/C++/common/LayoutAwarePage.h
  • Search contract/C++/common/LayoutAwarePage.h
  • Sharing content source app/C++/common/LayoutAwarePage.h
  • SimpleOrientationSensor/C++/common/LayoutAwarePage.h
  • Snap/C++/common/LayoutAwarePage.h
  • Splash screen/C++/common/LayoutAwarePage.h
  • Syndication/C++/common/LayoutAwarePage.h
  • Thread pool/C++/common/LayoutAwarePage.h
  • Transcoding media/C++/common/LayoutAwarePage.h
  • Trial app and in-app purchase/C++/common/LayoutAwarePage.h
  • UI contrast and settings/C++/common/LayoutAwarePage.h
  • User domain name/C++/common/LayoutAwarePage.h
  • USSD message management/C++/common/LayoutAwarePage.h
  • Web authentication broker/C++/common/LayoutAwarePage.h
  • Windows account authorization/C++/common/LayoutAwarePage.h
  • Windows Audio Session (WASAPI)/C++/common/LayoutAwarePage.h
  • XAML accessibility/C++/common/LayoutAwarePage.h
  • XAML animation library/C++/common/LayoutAwarePage.h
  • XAML data binding/C++/Common/LayoutAwarePage.h
  • XAML FlipView control/C++/common/LayoutAwarePage.h
  • XAML high contrast style/C++/common/LayoutAwarePage.h
  • XAML images/C++/common/LayoutAwarePage.h
  • XAML personality animations/C++/common/LayoutAwarePage.h
  • XAML Popup/C++/common/LayoutAwarePage.h
  • XAML text display/C++/Common/LayoutAwarePage.h
  • XAML text editing/C++/Common/LayoutAwarePage.h
  • XAML two-dimensional transforms/C++/common/LayoutAwarePage.h
  • XAML user and custom controls/C++/common/LayoutAwarePage.h
  • XAML vector-based drawing/C++/common/LayoutAwarePage.h
  • XAML WebView control/C++/common/LayoutAwarePage.h
  • Accelerometer sensor/C++/common/LayoutAwarePage.cpp
  • Animation metrics/C++/common/LayoutAwarePage.cpp
  • App package information/C++/common/LayoutAwarePage.cpp
  • App settings/C++/common/LayoutAwarePage.cpp
  • App tiles and badges/C#,C++/common/LayoutAwarePage.cpp
  • Application data/C++/common/LayoutAwarePage.cpp
  • AtomPub/C++/common/LayoutAwarePage.cpp
  • Background task/C++/BackgroundTask/common/LayoutAwarePage.cpp
  • Background Transfer/C++/common/LayoutAwarePage.cpp
  • Bluetooth call control/C++/common/LayoutAwarePage.cpp
  • Calendar details and math/C++/common/LayoutAwarePage.cpp
  • CameraCaptureUI/C++/common/LayoutAwarePage.cpp
  • CameraOptionsUI/C++/common/LayoutAwarePage.cpp
  • Certificate enrollment/C++/common/LayoutAwarePage.cpp
  • Compass sensor/C++/common/LayoutAwarePage.cpp
  • Compression/C++/common/LayoutAwarePage.cpp
  • Configure keys for media/C++/common/LayoutAwarePage.cpp
  • Connecting with WebSockets/C++/common/LayoutAwarePage.cpp
  • Context menu/C++/common/LayoutAwarePage.cpp
  • Credential locker/C++/common/LayoutAwarePage.cpp
  • CryptoWinRT/C++/common/LayoutAwarePage.cpp
  • Custom driver access/C++/app_cpp/common/LayoutAwarePage.cpp
  • Date and time formatting/C++/common/LayoutAwarePage.cpp
  • Device auto rotation preferences/C++/common/LayoutAwarePage.cpp
  • Device enumeration/C++/common/LayoutAwarePage.cpp
  • Display orientation/C++/common/LayoutAwarePage.cpp
  • EAS policies for mail clients/C++/common/LayoutAwarePage.cpp
  • File access/C++/common/LayoutAwarePage.cpp
  • File and folder thumbnail/C++/common/LayoutAwarePage.cpp
  • File picker/C++/common/LayoutAwarePage.cpp
  • File picker contracts/C++/common/LayoutAwarePage.cpp
  • Folder enumeration/C++/common/LayoutAwarePage.cpp
  • Geolocation/C++/common/LayoutAwarePage.cpp
  • Globalization preferences/C++/common/LayoutAwarePage.cpp
  • Gyrometer sensor/C++/common/LayoutAwarePage.cpp
  • HomeGroup app/C++/common/LayoutAwarePage.cpp
  • HttpClient/C++/common/LayoutAwarePage.cpp
  • Inclinometer sensor/C++/common/LayoutAwarePage.cpp
  • Input Device capabilities/C++/common/LayoutAwarePage.cpp
  • Input Touch keyboard/C++/common/LayoutAwarePage.cpp
  • Input Touch keyboard text input/C++/common/LayoutAwarePage.cpp
  • LightSensor/C++/common/LayoutAwarePage.cpp
  • Lock screen personalization/C++/common/LayoutAwarePage.cpp
  • Media Play To/C++/common/LayoutAwarePage.cpp
  • Media Server client/C++/common/LayoutAwarePage.cpp
  • Message dialog/C++/common/LayoutAwarePage.cpp
  • Network information/C++/common/LayoutAwarePage.cpp
  • Number formatting and parsing/C++/common/LayoutAwarePage.cpp
  • OrientationSensor/C++/common/LayoutAwarePage.cpp
  • Playback Manager Companion/C++/common/LayoutAwarePage.cpp
  • Playback Manager msAudioCategory/C++/common/LayoutAwarePage.cpp
  • Playlist/C++/common/LayoutAwarePage.cpp
  • PlayToReceiver/C++/common/LayoutAwarePage.cpp
  • Portable device API/C++/common/LayoutAwarePage.cpp
  • Programmatic file search/C++/common/LayoutAwarePage.cpp
  • Reading and writing data/C++/common/LayoutAwarePage.cpp
  • Removable storage/C++/common/LayoutAwarePage.cpp
  • Scaling according to DPI/C++/common/LayoutAwarePage.cpp
  • Search contract/C++/common/LayoutAwarePage.cpp
  • Sharing content source app/C++/common/LayoutAwarePage.cpp
  • SimpleOrientationSensor/C++/common/LayoutAwarePage.cpp
  • Snap/C++/common/LayoutAwarePage.cpp
  • Splash screen/C++/common/LayoutAwarePage.cpp
  • Syndication/C++/common/LayoutAwarePage.cpp
  • Thread pool/C++/common/LayoutAwarePage.cpp
  • Transcoding media/C++/common/LayoutAwarePage.cpp
  • Trial app and in-app purchase/C++/common/LayoutAwarePage.cpp
  • UI contrast and settings/C++/common/LayoutAwarePage.cpp
  • User domain name/C++/common/LayoutAwarePage.cpp
  • USSD message management/C++/common/LayoutAwarePage.cpp
  • Web authentication broker/C++/common/LayoutAwarePage.cpp
  • Windows account authorization/C++/common/LayoutAwarePage.cpp
  • Windows Audio Session (WASAPI)/C++/common/LayoutAwarePage.cpp
  • XAML accessibility/C++/common/LayoutAwarePage.cpp
  • XAML animation library/C++/common/LayoutAwarePage.cpp
  • XAML data binding/C++/Common/LayoutAwarePage.cpp
  • XAML FlipView control/C++/common/LayoutAwarePage.cpp
  • XAML high contrast style/C++/common/LayoutAwarePage.cpp
  • XAML images/C++/common/LayoutAwarePage.cpp
  • XAML personality animations/C++/common/LayoutAwarePage.cpp
  • XAML Popup/C++/common/LayoutAwarePage.cpp
  • XAML text display/C++/Common/LayoutAwarePage.cpp
  • XAML text editing/C++/Common/LayoutAwarePage.cpp
  • XAML two-dimensional transforms/C++/common/LayoutAwarePage.cpp
  • XAML user and custom controls/C++/common/LayoutAwarePage.cpp
  • XAML vector-based drawing/C++/common/LayoutAwarePage.cpp
  • XAML WebView control/C++/common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Common::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Common
  • SDKSample::Common::sealed
Static Public Member Functions | Public Attributes | Static Private Member Functions

SDKSample::Common::sealed Class Reference

SuspensionManager captures global session state to simplify process lifetime management for an application. More...

#include "suspensionmanager.h"

List of all members.

Static Public Member Functions

static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | RestoreAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static Concurrency::task< void > | SaveAsync (void)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static
Windows::Foundation::Collections::IMap
< Platform::String^,
Platform::Object^> 		SessionStateForFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)
static void | UnregisterFrame (Windows::UI::Xaml::Controls::Frame^frame)

Public Attributes

internal | __pad0__: static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame
internal Platform::String | sessionStateKey

Static Private Member Functions

static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | RestoreFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)
static void | SaveFrameNavigationState (Windows::UI::Xaml::Controls::Frame^frame)

Detailed Description

Note that session state will be automatically cleared under a variety of conditions and should only be used to store information that would be convenient to carry across sessions, but that should be disacarded when an application crashes or is upgraded.

Definition at line 31 of file suspensionmanager.h.

Member Function Documentation

static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::RestoreAsync ( void ) [static]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::RestoreFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static Concurrency::task<void> SDKSample::Common::sealed::SaveAsync ( void ) [static]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static void SDKSample::Common::sealed::SaveFrameNavigationState ( Windows::UI::Xaml::Controls::Frame^ frame ) [static, private]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^> SDKSample::Common::sealed::SessionStateForFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]
static void SDKSample::Common::sealed::UnregisterFrame ( Windows::UI::Xaml::Controls::Frame^ frame ) [static]

Member Data Documentation

internal sealed::__pad0__

Definition at line 34 of file suspensionmanager.h.

internal Platform::String sealed::sessionStateKey

Definition at line 34 of file suspensionmanager.h.

The documentation for this class was generated from the following files:
  • Accelerometer sensor/C++/common/suspensionmanager.h
  • Animation metrics/C++/common/suspensionmanager.h
  • App package information/C++/common/suspensionmanager.h
  • App settings/C++/common/suspensionmanager.h
  • App tiles and badges/C#,C++/common/suspensionmanager.h
  • Application data/C++/common/suspensionmanager.h
  • AtomPub/C++/common/suspensionmanager.h
  • Background task/C++/BackgroundTask/common/suspensionmanager.h
  • Background Transfer/C++/common/suspensionmanager.h
  • Bluetooth call control/C++/common/suspensionmanager.h
  • Calendar details and math/C++/common/suspensionmanager.h
  • CameraCaptureUI/C++/common/suspensionmanager.h
  • CameraOptionsUI/C++/common/suspensionmanager.h
  • Certificate enrollment/C++/common/suspensionmanager.h
  • Compass sensor/C++/common/suspensionmanager.h
  • Compression/C++/common/suspensionmanager.h
  • Configure keys for media/C++/common/suspensionmanager.h
  • Connecting with WebSockets/C++/common/suspensionmanager.h
  • Context menu/C++/common/suspensionmanager.h
  • Credential locker/C++/common/suspensionmanager.h
  • CryptoWinRT/C++/common/suspensionmanager.h
  • Custom driver access/C++/app_cpp/common/suspensionmanager.h
  • Date and time formatting/C++/common/suspensionmanager.h
  • Device auto rotation preferences/C++/common/suspensionmanager.h
  • Device enumeration/C++/common/suspensionmanager.h
  • Display orientation/C++/common/suspensionmanager.h
  • EAS policies for mail clients/C++/common/suspensionmanager.h
  • File access/C++/common/suspensionmanager.h
  • File and folder thumbnail/C++/common/suspensionmanager.h
  • File picker/C++/common/suspensionmanager.h
  • File picker contracts/C++/common/suspensionmanager.h
  • Folder enumeration/C++/common/suspensionmanager.h
  • Geolocation/C++/common/SuspensionManager.h
  • Globalization preferences/C++/common/suspensionmanager.h
  • Gyrometer sensor/C++/common/suspensionmanager.h
  • HomeGroup app/C++/common/suspensionmanager.h
  • HttpClient/C++/common/suspensionmanager.h
  • Inclinometer sensor/C++/common/suspensionmanager.h
  • Input Device capabilities/C++/common/suspensionmanager.h
  • Input Touch keyboard/C++/common/suspensionmanager.h
  • Input Touch keyboard text input/C++/common/suspensionmanager.h
  • LightSensor/C++/common/suspensionmanager.h
  • Lock screen personalization/C++/common/suspensionmanager.h
  • Media Play To/C++/common/suspensionmanager.h
  • Media Server client/C++/common/suspensionmanager.h
  • Message dialog/C++/common/suspensionmanager.h
  • Network information/C++/common/suspensionmanager.h
  • Number formatting and parsing/C++/common/suspensionmanager.h
  • OrientationSensor/C++/common/suspensionmanager.h
  • Playback Manager Companion/C++/common/suspensionmanager.h
  • Playback Manager msAudioCategory/C++/common/suspensionmanager.h
  • Playlist/C++/common/suspensionmanager.h
  • PlayToReceiver/C++/common/suspensionmanager.h
  • Portable device API/C++/common/SuspensionManager.h
  • Programmatic file search/C++/common/suspensionmanager.h
  • Reading and writing data/C++/common/suspensionmanager.h
  • Removable storage/C++/common/SuspensionManager.h
  • Scaling according to DPI/C++/common/suspensionmanager.h
  • Search contract/C++/common/suspensionmanager.h
  • Sharing content source app/C++/common/suspensionmanager.h
  • SimpleOrientationSensor/C++/common/suspensionmanager.h
  • Snap/C++/common/suspensionmanager.h
  • Splash screen/C++/common/suspensionmanager.h
  • Syndication/C++/common/suspensionmanager.h
  • Thread pool/C++/common/suspensionmanager.h
  • Transcoding media/C++/common/suspensionmanager.h
  • Trial app and in-app purchase/C++/common/suspensionmanager.h
  • UI contrast and settings/C++/common/suspensionmanager.h
  • User domain name/C++/common/suspensionmanager.h
  • USSD message management/C++/common/suspensionmanager.h
  • Web authentication broker/C++/common/suspensionmanager.h
  • Windows account authorization/C++/common/suspensionmanager.h
  • Windows Audio Session (WASAPI)/C++/common/suspensionmanager.h
  • XAML accessibility/C++/common/suspensionmanager.h
  • XAML animation library/C++/common/suspensionmanager.h
  • XAML data binding/C++/Common/suspensionmanager.h
  • XAML FlipView control/C++/common/suspensionmanager.h
  • XAML high contrast style/C++/common/suspensionmanager.h
  • XAML images/C++/common/suspensionmanager.h
  • XAML personality animations/C++/common/suspensionmanager.h
  • XAML Popup/C++/common/suspensionmanager.h
  • XAML text display/C++/Common/suspensionmanager.h
  • XAML text editing/C++/Common/suspensionmanager.h
  • XAML two-dimensional transforms/C++/common/suspensionmanager.h
  • XAML user and custom controls/C++/common/suspensionmanager.h
  • XAML vector-based drawing/C++/common/suspensionmanager.h
  • XAML WebView control/C++/common/suspensionmanager.h
  • Animation metrics/C++/common/suspensionmanager.cpp
  • App package information/C++/common/suspensionmanager.cpp
  • App settings/C++/common/suspensionmanager.cpp
  • App tiles and badges/C#,C++/common/suspensionmanager.cpp
  • Application data/C++/common/suspensionmanager.cpp
  • AtomPub/C++/common/suspensionmanager.cpp
  • Background task/C++/BackgroundTask/common/suspensionmanager.cpp
  • Background Transfer/C++/common/suspensionmanager.cpp
  • Bluetooth call control/C++/common/suspensionmanager.cpp
  • Calendar details and math/C++/common/suspensionmanager.cpp
  • CameraCaptureUI/C++/common/suspensionmanager.cpp
  • CameraOptionsUI/C++/common/suspensionmanager.cpp
  • Certificate enrollment/C++/common/suspensionmanager.cpp
  • Compass sensor/C++/common/suspensionmanager.cpp
  • Compression/C++/common/suspensionmanager.cpp
  • Configure keys for media/C++/common/suspensionmanager.cpp
  • Connecting with WebSockets/C++/common/suspensionmanager.cpp
  • Context menu/C++/common/suspensionmanager.cpp
  • Credential locker/C++/common/suspensionmanager.cpp
  • CryptoWinRT/C++/common/suspensionmanager.cpp
  • Custom driver access/C++/app_cpp/common/suspensionmanager.cpp
  • Date and time formatting/C++/common/suspensionmanager.cpp
  • Device enumeration/C++/common/suspensionmanager.cpp
  • Display orientation/C++/common/suspensionmanager.cpp
  • EAS policies for mail clients/C++/common/suspensionmanager.cpp
  • File access/C++/common/suspensionmanager.cpp
  • File and folder thumbnail/C++/common/suspensionmanager.cpp
  • File picker/C++/common/suspensionmanager.cpp
  • File picker contracts/C++/common/suspensionmanager.cpp
  • Folder enumeration/C++/common/suspensionmanager.cpp
  • Geolocation/C++/common/SuspensionManager.cpp
  • Globalization preferences/C++/common/suspensionmanager.cpp
  • Gyrometer sensor/C++/common/suspensionmanager.cpp
  • HomeGroup app/C++/common/suspensionmanager.cpp
  • HttpClient/C++/common/suspensionmanager.cpp
  • Inclinometer sensor/C++/common/suspensionmanager.cpp
  • Input Device capabilities/C++/common/suspensionmanager.cpp
  • Input Touch keyboard/C++/common/suspensionmanager.cpp
  • Input Touch keyboard text input/C++/common/suspensionmanager.cpp
  • LightSensor/C++/common/suspensionmanager.cpp
  • Lock screen personalization/C++/common/suspensionmanager.cpp
  • Media Play To/C++/common/suspensionmanager.cpp
  • Media Server client/C++/common/suspensionmanager.cpp
  • Message dialog/C++/common/suspensionmanager.cpp
  • Network information/C++/common/suspensionmanager.cpp
  • Number formatting and parsing/C++/common/suspensionmanager.cpp
  • OrientationSensor/C++/common/suspensionmanager.cpp
  • Playback Manager Companion/C++/common/suspensionmanager.cpp
  • Playlist/C++/common/suspensionmanager.cpp
  • PlayToReceiver/C++/common/suspensionmanager.cpp
  • Portable device API/C++/common/SuspensionManager.cpp
  • Programmatic file search/C++/common/suspensionmanager.cpp
  • Reading and writing data/C++/common/suspensionmanager.cpp
  • Removable storage/C++/common/SuspensionManager.cpp
  • Scaling according to DPI/C++/common/suspensionmanager.cpp
  • Search contract/C++/common/suspensionmanager.cpp
  • Sharing content source app/C++/common/suspensionmanager.cpp
  • SimpleOrientationSensor/C++/common/suspensionmanager.cpp
  • Snap/C++/common/suspensionmanager.cpp
  • Splash screen/C++/common/suspensionmanager.cpp
  • Syndication/C++/common/suspensionmanager.cpp
  • Thread pool/C++/common/suspensionmanager.cpp
  • Transcoding media/C++/common/suspensionmanager.cpp
  • Trial app and in-app purchase/C++/common/suspensionmanager.cpp
  • UI contrast and settings/C++/common/suspensionmanager.cpp
  • User domain name/C++/common/suspensionmanager.cpp
  • USSD message management/C++/common/suspensionmanager.cpp
  • Web authentication broker/C++/common/suspensionmanager.cpp
  • Windows account authorization/C++/common/suspensionmanager.cpp
  • Windows Audio Session (WASAPI)/C++/common/suspensionmanager.cpp
  • XAML accessibility/C++/common/suspensionmanager.cpp
  • XAML animation library/C++/common/suspensionmanager.cpp
  • XAML data binding/C++/Common/suspensionmanager.cpp
  • XAML FlipView control/C++/common/suspensionmanager.cpp
  • XAML high contrast style/C++/common/suspensionmanager.cpp
  • XAML images/C++/common/suspensionmanager.cpp
  • XAML personality animations/C++/common/suspensionmanager.cpp
  • XAML Popup/C++/common/suspensionmanager.cpp
  • XAML text display/C++/Common/suspensionmanager.cpp
  • XAML text editing/C++/Common/suspensionmanager.cpp
  • XAML two-dimensional transforms/C++/common/suspensionmanager.cpp
  • XAML user and custom controls/C++/common/suspensionmanager.cpp
  • XAML vector-based drawing/C++/common/suspensionmanager.cpp
  • XAML WebView control/C++/common/suspensionmanager.cpp
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Common::SharePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Common
  • SDKSample::Common::SharePage
Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Common::SharePage Class Reference

#include "SharePage.h"

Inherits SDKSample::Common::LayoutAwarePage.

List of all members.

Protected Member Functions

virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | ShowUIButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Member Functions

void | OnDataRequested (Windows::ApplicationModel::DataTransfer::DataTransferManager^sender, Windows::ApplicationModel::DataTransfer::DataRequestedEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | dataRequestedToken

Detailed Description

Definition at line 26 of file SharePage.h.

Member Function Documentation

virtual bool SDKSample::Common::SharePage::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [protected, virtual]
void SDKSample::Common::SharePage::OnDataRequested | ( | Windows::ApplicationModel::DataTransfer::DataTransferManager^ | sender,
 |  | Windows::ApplicationModel::DataTransfer::DataRequestedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::Common::SharePage::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]

Reimplemented from SDKSample::Common::LayoutAwarePage.

virtual void SDKSample::Common::SharePage::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]

Reimplemented from SDKSample::Common::LayoutAwarePage.

void SharePage::ShowUIButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]

Definition at line 55 of file SharePage.cpp.

{
    // If the user clicks the share button, invoke the share flow programatically.
    Windows::ApplicationModel::DataTransfer::DataTransferManager::ShowShareUI();
}

Member Data Documentation

Windows::Foundation::EventRegistrationToken SDKSample::Common::SharePage::dataRequestedToken [private]

Definition at line 35 of file SharePage.h.

The documentation for this class was generated from the following files:
  • Sharing content source app/C++/SharePage.h
  • Sharing content source app/C++/SharePage.cpp
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CompassCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CompassCPP
  • SDKSample::CompassCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::CompassCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisplayCurrentReading (Platform::Object^sender, Platform::Object^e)
void | ReadingChanged (Windows::Devices::Sensors::Compass^sender, Windows::Devices::Sensors::CompassReadingChangedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)

Private Attributes

Windows::Devices::Sensors::Compass | compass
uint32 | desiredReportInterval
Windows::UI::Core::CoreDispatcher | dispatcher
Windows::UI::Xaml::DispatcherTimer | dispatcherTimer
Windows::Foundation::EventRegistrationToken | readingToken
MainPage rootPage
Windows::Foundation::EventRegistrationToken | visibilityToken

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::CompassCPP::sealed::DisplayCurrentReading | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::CompassCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CompassCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CompassCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CompassCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::CompassCPP::sealed::ReadingChanged | ( | Windows::Devices::Sensors::Compass^ | sender,
 |  | Windows::Devices::Sensors::CompassReadingChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::CompassCPP::sealed::Scenario1 ( )
SDKSample::CompassCPP::sealed::Scenario2 ( )
void SDKSample::CompassCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CompassCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CompassCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CompassCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CompassCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CompassCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Devices::Sensors::Compass sealed::compass [private]

Definition at line 41 of file Scenario1.xaml.h.

uint32 sealed::desiredReportInterval [private]

Definition at line 44 of file Scenario1.xaml.h.

Windows::UI::Core::CoreDispatcher SDKSample::CompassCPP::sealed::dispatcher [private]

Definition at line 41 of file Scenario2.xaml.h.

Windows::UI::Xaml::DispatcherTimer SDKSample::CompassCPP::sealed::dispatcherTimer [private]

Definition at line 45 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::CompassCPP::sealed::readingToken [private]

Definition at line 43 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::visibilityToken [private]

Definition at line 42 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Compass sensor/C++/Scenario1.xaml.h
  • Compass sensor/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Compression::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Compression
  • SDKSample::Compression::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Compression::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoScenario (Windows::Storage::Compression::CompressAlgorithm Algorithm)
void | DoScenario (Windows::Storage::Compression::CompressAlgorithm Algorithm)
void | DoScenario (Windows::Storage::Compression::CompressAlgorithm Algorithm)
void | Lzms_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Lzms_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Lzms_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Mszip_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Mszip_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Mszip_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Xpress_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Xpress_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Xpress_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | XpressHuff_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | XpressHuff_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | XpressHuff_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::Compression::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::DoScenario ( Windows::Storage::Compression::CompressAlgorithm Algorithm ) [private]
void SDKSample::Compression::sealed::DoScenario ( Windows::Storage::Compression::CompressAlgorithm Algorithm ) [private]
void SDKSample::Compression::sealed::DoScenario ( Windows::Storage::Compression::CompressAlgorithm Algorithm ) [private]
void SDKSample::Compression::sealed::Lzms_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Lzms_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Lzms_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Mszip_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Mszip_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Mszip_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::Compression::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Compression::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Compression::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::Compression::sealed::Scenario1 ( )
SDKSample::Compression::sealed::Scenario2 ( )
SDKSample::Compression::sealed::Scenario3 ( )
void SDKSample::Compression::sealed::Xpress_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Xpress_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::Xpress_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::XpressHuff_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::XpressHuff_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Compression::sealed::XpressHuff_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Compression/C++/Scenario1.xaml.h
  • Compression/C++/Scenario2.xaml.h
  • Compression/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ContextMenu::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ContextMenu
  • SDKSample::ContextMenu::sealed
Public Member Functions | Private Member Functions | Private Attributes

SDKSample::ContextMenu::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Private Member Functions

void | AttachmentImage_RightTapped (Platform::Object^sender, Windows::UI::Xaml::Input::RightTappedRoutedEventArgs^e)
void | ReadOnlyTextBox_ContextMenuOpening (Platform::Object^sender, Windows::UI::Xaml::Controls::ContextMenuEventArgs^e)
Windows::Foundation::Rect | Scenario1::GetElementRect (Windows::UI::Xaml::FrameworkElement^element)
Windows::Foundation::Rect | Scenario2::GetTextboxSelectionRect (Windows::UI::Xaml::Controls::TextBox^textbox)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 29 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::ContextMenu::sealed::AttachmentImage_RightTapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::RightTappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ContextMenu::sealed::ReadOnlyTextBox_ContextMenuOpening | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::ContextMenuEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ContextMenu::sealed::Scenario1 ( )
Windows::Foundation::Rect SDKSample::ContextMenu::sealed::Scenario1::GetElementRect ( Windows::UI::Xaml::FrameworkElement^ element ) [private]
SDKSample::ContextMenu::sealed::Scenario2 ( )
Windows::Foundation::Rect SDKSample::ContextMenu::sealed::Scenario2::GetTextboxSelectionRect ( Windows::UI::Xaml::Controls::TextBox^ textbox ) [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 35 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Context menu/C++/Scenario1.xaml.h
  • Context menu/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CoTaskMemFreeArray Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::CoTaskMemFreeArray
Public Member Functions | Public Attributes

SDKSample::CoTaskMemFreeArray Class Reference

#include "Constants.h"

List of all members.

Public Member Functions

CoTaskMemFreeArray (_Inout_updates_(count) void **ptr, size_t count)
~CoTaskMemFreeArray ()

Public Attributes

size_t | _count
void ** | _ptr

Detailed Description

Definition at line 71 of file Constants.h.

Constructor & Destructor Documentation

SDKSample::CoTaskMemFreeArray::CoTaskMemFreeArray | ( | _Inout_updates_(count) void ** | ptr,
 |  | size_t | count |
 | ) |  |  | [inline]

Definition at line 74 of file Constants.h.

                                                                            :
          _ptr(ptr), _count(count)
        {
        }

SDKSample::CoTaskMemFreeArray::~CoTaskMemFreeArray ( ) [inline]

Definition at line 79 of file Constants.h.

        {
            for (size_t i=0; i<_count; i++)
            {
                CoTaskMemFree(_ptr[i]);
            }
        }

Member Data Documentation

size_t SDKSample::CoTaskMemFreeArray::_count

Definition at line 88 of file Constants.h.

void** SDKSample::CoTaskMemFreeArray::_ptr

Definition at line 87 of file Constants.h.

The documentation for this class was generated from the following file:
  • Portable device API/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CoTaskMemFreeStruct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::CoTaskMemFreeStruct
Public Member Functions

SDKSample::CoTaskMemFreeStruct Struct Reference

#include "Constants.h"

List of all members.

Public Member Functions

void operator() (void *ptr) const

Detailed Description

Definition at line 51 of file Constants.h.

Member Function Documentation

void SDKSample::CoTaskMemFreeStruct::operator() ( void * ptr ) const [inline]

Definition at line 53 of file Constants.h.

        {
            CoTaskMemFree(ptr);
        }

The documentation for this struct was generated from the following file:
  • Portable device API/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CryptoWinRT::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CryptoWinRT
  • SDKSample::CryptoWinRT::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::CryptoWinRT::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario10 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()
Scenario6 ()
Scenario7 ()
Scenario8 ()
Scenario9 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Windows::Storage::Streams::IBuffer | GetNonce ()
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RunSample_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage
Platform::Array< byte > | TestVectorNonce

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::CryptoWinRT::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Windows::Storage::Streams::IBuffer SDKSample::CryptoWinRT::sealed::GetNonce ( ) [private]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CryptoWinRT::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CryptoWinRT::sealed::RunSample_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::CryptoWinRT::sealed::Scenario1 ( )
SDKSample::CryptoWinRT::sealed::Scenario10 ( )
SDKSample::CryptoWinRT::sealed::Scenario2 ( )
SDKSample::CryptoWinRT::sealed::Scenario3 ( )
SDKSample::CryptoWinRT::sealed::Scenario4 ( )
SDKSample::CryptoWinRT::sealed::Scenario5 ( )
SDKSample::CryptoWinRT::sealed::Scenario6 ( )
SDKSample::CryptoWinRT::sealed::Scenario7 ( )
SDKSample::CryptoWinRT::sealed::Scenario8 ( )
SDKSample::CryptoWinRT::sealed::Scenario9 ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

Platform::Array<byte> SDKSample::CryptoWinRT::sealed::TestVectorNonce [private]

Definition at line 39 of file Scenario6.xaml.h.

The documentation for this class was generated from the following files:
  • CryptoWinRT/C++/Scenario1.xaml.h
  • CryptoWinRT/C++/Scenario10.xaml.h
  • CryptoWinRT/C++/Scenario2.xaml.h
  • CryptoWinRT/C++/Scenario3.xaml.h
  • CryptoWinRT/C++/Scenario4.xaml.h
  • CryptoWinRT/C++/Scenario5.xaml.h
  • CryptoWinRT/C++/Scenario6.xaml.h
  • CryptoWinRT/C++/Scenario7.xaml.h
  • CryptoWinRT/C++/Scenario8.xaml.h
  • CryptoWinRT/C++/Scenario9.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CustomDeviceAccess::DeviceList Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CustomDeviceAccess
  • SDKSample::CustomDeviceAccess::DeviceList
Public Member Functions | Static Public Member Functions | Properties | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::CustomDeviceAccess::DeviceList Class Reference

#include "DeviceList.h"

List of all members.

Public Member Functions

void | StartFx2Watcher ()
void | StopFx2Watcher ()

Static Public Member Functions

static void | CreateBooleanTable (Windows::UI::Xaml::Documents::InlineCollection^Table, const Platform::Array< bool >^NewValues, const Platform::Array< bool >^OldValues, Platform::String^IndexTitle, Platform::String^ValueTitle, Platform::String^TrueValue, Platform::String^FalseValue)

Properties

event DeviceClosingHandler | DeviceClosing

Private Member Functions

DeviceList ()
DeviceListEntry | FindDevice (Platform::String^Id)
void | InitDeviceWatcher ()
void | OnFx2Added (Windows::Devices::Enumeration::DeviceWatcher^Sender, Windows::Devices::Enumeration::DeviceInformation^DevInformation)
void | OnFx2EnumerationComplete (Windows::Devices::Enumeration::DeviceWatcher^Sender, Object^Args)
void | OnFx2Removed (Windows::Devices::Enumeration::DeviceWatcher^Sender, Windows::Devices::Enumeration::DeviceInformationUpdate^DevInformation)
void | ResumeDeviceWatcher (Object^Sender, Object^Args)
void | SuspendDeviceWatcher (Object^Sender, Windows::ApplicationModel::SuspendingEventArgs^Args)

Private Attributes

Samples::Devices::Fx2::Fx2Device | m_Fx2Device
Windows::Devices::Enumeration::DeviceWatcher | m_Fx2Watcher
Platform::Collections::Vector
< DeviceListEntry^> 		m_List
bool | m_WatcherStarted
bool | m_WatcherSuspended

Static Private Attributes

static DeviceList | _Current = nullptr

Detailed Description

Definition at line 35 of file DeviceList.h.

Constructor & Destructor Documentation

DeviceList::DeviceList ( ) [private]

Definition at line 28 of file DeviceList.cpp.

                       : m_WatcherStarted(false), m_WatcherSuspended(false)
{
    m_Fx2Watcher = nullptr;
    m_List = ref new Vector<DeviceListEntry^>();
    InitDeviceWatcher();

    // Register for app suspend/resume handlers
    App::Current->Suspending += ref new SuspendingEventHandler(this, &DeviceList::SuspendDeviceWatcher);
    App::Current->Resuming += ref new EventHandler<Object^>(this, &DeviceList::ResumeDeviceWatcher);
}

Member Function Documentation

static void SDKSample::CustomDeviceAccess::DeviceList::CreateBooleanTable | ( | Windows::UI::Xaml::Documents::InlineCollection^ | Table,
 |  | const Platform::Array< bool >^ | NewValues,
 |  | const Platform::Array< bool >^ | OldValues,
 |  | Platform::String^ | IndexTitle,
 |  | Platform::String^ | ValueTitle,
 |  | Platform::String^ | TrueValue,
 |  | Platform::String^ | FalseValue |
 | ) |  |  | [static]
DeviceListEntry SDKSample::CustomDeviceAccess::DeviceList::FindDevice ( Platform::String^ Id ) [private]
void DeviceList::InitDeviceWatcher ( ) [private]

Definition at line 39 of file DeviceList.cpp.

{
    // Define the selector to enumerate all of the fx2 device interface class instances
    auto selector = Samples::Devices::Fx2::Fx2Device::GetDeviceSelector();

    // Set of properties to retrieve
    auto properties = ref new Vector<String^>(1, "System.Devices.DeviceInstanceId");

    // Create a device watcher to look for instances of the fx2 device interface
    m_Fx2Watcher = DeviceInformation::CreateWatcher(selector, properties);

    m_Fx2Watcher->Added += ref new TypedEventHandler<DeviceWatcher^, DeviceInformation^>(this, &DeviceList::OnFx2Added);
    m_Fx2Watcher->Removed += ref new TypedEventHandler<DeviceWatcher^, DeviceInformationUpdate^>(this, &DeviceList::OnFx2Removed);
    m_Fx2Watcher->EnumerationCompleted += ref new TypedEventHandler<DeviceWatcher^,Object^>(this, &DeviceList::OnFx2EnumerationComplete);
}

void SDKSample::CustomDeviceAccess::DeviceList::OnFx2Added | ( | Windows::Devices::Enumeration::DeviceWatcher^ | Sender,
 |  | Windows::Devices::Enumeration::DeviceInformation^ | DevInformation |
 | ) |  |  | [private]
void SDKSample::CustomDeviceAccess::DeviceList::OnFx2EnumerationComplete | ( | Windows::Devices::Enumeration::DeviceWatcher^ | Sender,
 |  | Object^ | Args |
 | ) |  |  | [private]
void SDKSample::CustomDeviceAccess::DeviceList::OnFx2Removed | ( | Windows::Devices::Enumeration::DeviceWatcher^ | Sender,
 |  | Windows::Devices::Enumeration::DeviceInformationUpdate^ | DevInformation |
 | ) |  |  | [private]
void DeviceList::ResumeDeviceWatcher | ( | Object^ | Sender,
 |  | Object^ | Args |
 | ) |  |  | [private]

Definition at line 220 of file DeviceList.cpp.

{
    if (m_WatcherSuspended) {
        m_WatcherSuspended = false;
        StartFx2Watcher();
    }
}

void DeviceList::StartFx2Watcher ( )

Definition at line 55 of file DeviceList.cpp.

                                 {
    MainPage::Current->NotifyUser("starting device watcher", NotifyType::StatusMessage);
    std::for_each(
        begin(m_List),
        end(m_List),
        [](DeviceListEntry^ Entry) {
            Entry->Matched = false;
        }
    );
    WatcherStarted = true;
    m_Fx2Watcher->Start();
}

void DeviceList::StopFx2Watcher ( )

Definition at line 68 of file DeviceList.cpp.

                                {
    MainPage::Current->NotifyUser("stopping fx2 watcher", NotifyType::StatusMessage);
    m_Fx2Watcher->Stop();
    WatcherStarted = false;
}

void SDKSample::CustomDeviceAccess::DeviceList::SuspendDeviceWatcher | ( | Object^ | Sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | Args |
 | ) |  |  | [private]

Member Data Documentation

DeviceList DeviceList::_Current = nullptr [static, private]

Definition at line 85 of file DeviceList.h.

Samples::Devices::Fx2::Fx2Device SDKSample::CustomDeviceAccess::DeviceList::m_Fx2Device [private]

Definition at line 88 of file DeviceList.h.

Windows::Devices::Enumeration::DeviceWatcher SDKSample::CustomDeviceAccess::DeviceList::m_Fx2Watcher [private]

Definition at line 86 of file DeviceList.h.

Platform::Collections::Vector<DeviceListEntry^> SDKSample::CustomDeviceAccess::DeviceList::m_List [private]

Definition at line 87 of file DeviceList.h.

bool SDKSample::CustomDeviceAccess::DeviceList::m_WatcherStarted [private]

Definition at line 90 of file DeviceList.h.

bool SDKSample::CustomDeviceAccess::DeviceList::m_WatcherSuspended [private]

Definition at line 89 of file DeviceList.h.

Property Documentation

event DeviceClosingHandler SDKSample::CustomDeviceAccess::DeviceList::DeviceClosing

Definition at line 82 of file DeviceList.h.

The documentation for this class was generated from the following files:
  • Custom driver access/C++/app_cpp/DeviceList.h
  • Custom driver access/C++/app_cpp/DeviceList.cpp
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CustomDeviceAccess::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • CustomDeviceAccess
  • SDKSample::CustomDeviceAccess::sealed
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::CustomDeviceAccess::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "DeviceList.h"

List of all members.

Public Member Functions

DeviceAsync ()
DeviceConnect ()
DeviceEvents ()
DeviceListEntry (Windows::Devices::Enumeration::DeviceInformation^DeviceInterface)

Public Attributes

Windows::Devices::Enumeration::DeviceInformation | m_Device

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ClearBarGraphTable (void)
void | ClearSwitchStateTable ()
void | CloseFx2Device (void)
void | Current_DeviceClosing (Platform::Object^sender, Samples::Devices::Fx2::Fx2Device^device)
void | deviceAsyncGet_Click_1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | deviceAsyncSet_Click_1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | deviceConnectDevices_SelectionChanged_1 (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | deviceConnectStart_Click_1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | deviceConnectStop_Click_1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | deviceEventsGet_Click_1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | deviceEventsRegister_Click_1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnSwitchStateChangedEvent (Samples::Devices::Fx2::Fx2Device^sender, Samples::Devices::Fx2::SwitchStateChangedEventArgs^e)
void | OpenFx2Device (Platform::String^Id)
void | RegisterForSwitchStateChangedEvent (bool r)
void | UpdateBarGraphTable (Platform::Array< bool >^BarGraphArray)
void | UpdateRegisterButton (void)
void | UpdateStartStopButtons (void)
void | UpdateSwitchStateTable (Platform::Array< bool >^SwitchStateArray)

Private Attributes

Windows::Foundation::EventRegistrationToken | deviceClosingHandler
Platform::Array< bool > | previousSwitchValues
MainPage rootPage
Windows::Foundation::EventRegistrationToken | switchChangedEventsHandler
bool | switchChangedEventsRegistered

Detailed Description

Definition at line 6 of file DeviceList.h.

Member Function Documentation

void SDKSample::CustomDeviceAccess::sealed::ClearBarGraphTable ( void ) [private]
void SDKSample::CustomDeviceAccess::sealed::ClearSwitchStateTable ( ) [private]
void SDKSample::CustomDeviceAccess::sealed::CloseFx2Device ( void ) [private]
void SDKSample::CustomDeviceAccess::sealed::Current_DeviceClosing | ( | Platform::Object^ | sender,
 |  | Samples::Devices::Fx2::Fx2Device^ | device |
 | ) |  |  | [private]
SDKSample::CustomDeviceAccess::sealed::DeviceAsync ( )
void SDKSample::CustomDeviceAccess::sealed::deviceAsyncGet_Click_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CustomDeviceAccess::sealed::deviceAsyncSet_Click_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::CustomDeviceAccess::sealed::DeviceConnect ( )
void SDKSample::CustomDeviceAccess::sealed::deviceConnectDevices_SelectionChanged_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CustomDeviceAccess::sealed::deviceConnectStart_Click_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CustomDeviceAccess::sealed::deviceConnectStop_Click_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::CustomDeviceAccess::sealed::DeviceEvents ( )
void SDKSample::CustomDeviceAccess::sealed::deviceEventsGet_Click_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CustomDeviceAccess::sealed::deviceEventsRegister_Click_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::CustomDeviceAccess::sealed::DeviceListEntry ( Windows::Devices::Enumeration::DeviceInformation^ DeviceInterface ) [inline]

Definition at line 27 of file DeviceList.h.

                                                                                {
                m_Device = DeviceInterface;
                Matched = true;
            }

virtual void SDKSample::CustomDeviceAccess::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CustomDeviceAccess::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CustomDeviceAccess::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::CustomDeviceAccess::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::CustomDeviceAccess::sealed::OnSwitchStateChangedEvent | ( | Samples::Devices::Fx2::Fx2Device^ | sender,
 |  | Samples::Devices::Fx2::SwitchStateChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::CustomDeviceAccess::sealed::OpenFx2Device ( Platform::String^ Id ) [private]
void SDKSample::CustomDeviceAccess::sealed::RegisterForSwitchStateChangedEvent ( bool r ) [private]
void SDKSample::CustomDeviceAccess::sealed::UpdateBarGraphTable ( Platform::Array< bool >^ BarGraphArray ) [private]
void SDKSample::CustomDeviceAccess::sealed::UpdateRegisterButton ( void ) [private]
void SDKSample::CustomDeviceAccess::sealed::UpdateStartStopButtons ( void ) [private]
void SDKSample::CustomDeviceAccess::sealed::UpdateSwitchStateTable ( Platform::Array< bool >^ SwitchStateArray ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken SDKSample::CustomDeviceAccess::sealed::deviceClosingHandler [private]

Definition at line 40 of file Scenario3_DeviceEvents.xaml.h.

Windows::Devices::Enumeration::DeviceInformation SDKSample::CustomDeviceAccess::sealed::m_Device

Definition at line 9 of file DeviceList.h.

Platform::Array<bool> SDKSample::CustomDeviceAccess::sealed::previousSwitchValues [private]

Definition at line 44 of file Scenario3_DeviceEvents.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1_DeviceConnect.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::CustomDeviceAccess::sealed::switchChangedEventsHandler [private]

Definition at line 43 of file Scenario3_DeviceEvents.xaml.h.

bool SDKSample::CustomDeviceAccess::sealed::switchChangedEventsRegistered [private]

Definition at line 42 of file Scenario3_DeviceEvents.xaml.h.

The documentation for this class was generated from the following files:
  • Custom driver access/C++/app_cpp/DeviceList.h
  • Custom driver access/C++/app_cpp/Scenario1_DeviceConnect.xaml.h
  • Custom driver access/C++/app_cpp/Scenario3_DeviceEvents.xaml.h
  • Custom driver access/C++/app_cpp/Scenario4_DeviceAsync.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DataBinding::GeneratorIncrementalLoadingClass Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • DataBinding
  • SDKSample::DataBinding::GeneratorIncrementalLoadingClass
Public Member Functions | Public Attributes | Private Member Functions

SDKSample::DataBinding::GeneratorIncrementalLoadingClass Class Reference

#include "GeneratorIncrementalLoadingClass.h"

Inherits SDKSample::DataBinding::IncrementalLoadingBase.

List of all members.

Public Member Functions

virtual bool | HasMoreItemsOverride () override
virtual Concurrency::task
< Windows::Foundation::Collections::IVector
< Platform::Object^>^> 		LoadMoreItemsOverride (Concurrency::cancellation_token c, unsigned int count) override

Public Attributes

internal | __pad0__: unsigned int _count
internal | __pad1__: GeneratorIncrementalLoadingClass(unsigned int maxCount) { _maxCount = maxCount
_count = 0
unsigned int | _maxCount

Private Member Functions

Platform::Object | Generator (int count)

Detailed Description

Definition at line 27 of file GeneratorIncrementalLoadingClass.h.

Member Function Documentation

Platform::Object SDKSample::DataBinding::GeneratorIncrementalLoadingClass::Generator ( int count ) [inline, private]

Definition at line 81 of file GeneratorIncrementalLoadingClass.h.

            {
                auto employee = ref new Employee();
                employee->Name = "Name" + count;
                employee->Organization = "Organization" + count;
                return employee;
            }

virtual bool SDKSample::DataBinding::GeneratorIncrementalLoadingClass::HasMoreItemsOverride ( ) [inline, override, virtual]

Definition at line 75 of file GeneratorIncrementalLoadingClass.h.

            {
                return _count < _maxCount;
            }

virtual Concurrency::task<Windows::Foundation::Collections::IVector<Platform::Object^>^> SDKSample::DataBinding::GeneratorIncrementalLoadingClass::LoadMoreItemsOverride | ( | Concurrency::cancellation_token | c,
 |  | unsigned int | count |
 | ) |  |  | [inline, override, virtual]

Replace this section with your code to load more items

Note that Platform::Collections::Vector<Platform::Object^> can be returned as Windows::Foundation::Collections::IVector<Platform::Object^>

end Replace this section with your code to load more items

Definition at line 42 of file GeneratorIncrementalLoadingClass.h.

            {
                return Concurrency::task<Windows::Foundation::Collections::IVector<Platform::Object^>^>(
                    [=]() -> Windows::Foundation::Collections::IVector<Platform::Object^>^ {
                        unsigned int toGenerate = _maxCount - _count;

                        ///
                        ///  Replace this section with your code to load more items
                        ///
                        Concurrency::wait(10);

                        if (count < toGenerate)
                        {
                            toGenerate = count;
                        }

                        /// Note that Platform::Collections::Vector<Platform::Object^> can be returned as Windows::Foundation::Collections::IVector<Platform::Object^>
                        auto items = ref new Platform::Collections::Vector<Platform::Object^>();
                        for(unsigned int i=0; i < toGenerate; i++)
                        {
                            auto item = this->Generator(this->_count++);
                            items->Append(item);
                        }

                        return items;

                        ///
                        /// end Replace this section with your code to load more items
                        ///
                    }
                );
            }

Member Data Documentation

internal SDKSample::DataBinding::GeneratorIncrementalLoadingClass::__pad0__

Reimplemented from SDKSample::DataBinding::IncrementalLoadingBase.

Definition at line 31 of file GeneratorIncrementalLoadingClass.h.

internal SDKSample::DataBinding::GeneratorIncrementalLoadingClass::__pad1__

Definition at line 38 of file GeneratorIncrementalLoadingClass.h.

SDKSample::DataBinding::GeneratorIncrementalLoadingClass::_count = 0

Definition at line 39 of file GeneratorIncrementalLoadingClass.h.

unsigned int SDKSample::DataBinding::GeneratorIncrementalLoadingClass::_maxCount

Definition at line 32 of file GeneratorIncrementalLoadingClass.h.

The documentation for this class was generated from the following file:
  • XAML data binding/C++/GeneratorIncrementalLoadingClass.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DataBinding::IncrementalLoadingBase Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • DataBinding
  • SDKSample::DataBinding::IncrementalLoadingBase
Public Member Functions | Public Attributes

SDKSample::DataBinding::IncrementalLoadingBase Class Reference

#include "IncrementalLoadingBase.h"

Inherited by SDKSample::DataBinding::GeneratorIncrementalLoadingClass.

List of all members.

Public Member Functions

void | _storageVectorChanged (Windows::Foundation::Collections::IObservableVector< Platform::Object^>^sender, Windows::Foundation::Collections::IVectorChangedEventArgs^e)

Public Attributes

internal | __pad0__: Concurrency::task<Windows::UI::Xaml::Data::LoadMoreItemsResult> LoadMoreItemsAsync(Concurrency::cancellation_token c
bool | _busy
bool | _isVectorChangedObserved
event
Windows::UI::Xaml::Interop::BindableVectorChangedEventHandler 		_privateVectorChanged

Detailed Description

Definition at line 25 of file IncrementalLoadingBase.h.

Member Function Documentation

void SDKSample::DataBinding::IncrementalLoadingBase::_storageVectorChanged | ( | Windows::Foundation::Collections::IObservableVector< Platform::Object^>^ | sender,
 |  | Windows::Foundation::Collections::IVectorChangedEventArgs^ | e |
 | ) |  |  | [inline]
Parameters:
e IVectorChangedEventArgs

Definition at line 223 of file IncrementalLoadingBase.h.

        {
          if (_isVectorChangedObserved)
          {
            VectorChanged(this, e);
          }
        }

Member Data Documentation

internal SDKSample::DataBinding::IncrementalLoadingBase::__pad0__

Reimplemented in SDKSample::DataBinding::GeneratorIncrementalLoadingClass.

Definition at line 32 of file IncrementalLoadingBase.h.

bool SDKSample::DataBinding::IncrementalLoadingBase::_busy

Definition at line 32 of file IncrementalLoadingBase.h.

bool SDKSample::DataBinding::IncrementalLoadingBase::_isVectorChangedObserved

Definition at line 216 of file IncrementalLoadingBase.h.

event Windows::UI::Xaml::Interop::BindableVectorChangedEventHandler SDKSample::DataBinding::IncrementalLoadingBase::_privateVectorChanged

Definition at line 217 of file IncrementalLoadingBase.h.

The documentation for this class was generated from the following file:
  • XAML data binding/C++/IncrementalLoadingBase.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DataBinding::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • DataBinding
  • SDKSample::DataBinding::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

SDKSample::DataBinding::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame. More...

#include "Employee.h"

List of all members.

Public Member Functions

virtual Object | Convert (Object^value, TypeName targetType, Object^parameter, String^language)
virtual Object | ConvertBack (Object^value, TypeName targetType, Object^parameter, String^language)
Employee ()
Platform::Object | First ()
Platform::Object | First ()
Platform::Object | GetView ()
Platform::Object | GetView ()
virtual bool | HasKey (Platform::String^key)
virtual bool | HasKey (Platform::String^key)
virtual bool | Insert (Platform::String^key, Platform::Object^value)
virtual bool | Insert (Platform::String^key, Platform::Object^value)
virtual Object | Lookup (Platform::String^key)
virtual Platform::Object | Lookup (Platform::String^key)
virtual void | Remove (Platform::String^key)
virtual void | Remove (Platform::String^key)
S2Formatter ()
Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()
Scenario6 ()
Scenario7 ()
Scenario8 ()
Team ()
TeamDataSource ()
TeamGroup (Platform::String^name)
Teams ()

Protected Member Functions

void | BindableVectorChanged (Windows::UI::Xaml::Interop::IBindableObservableVector^sender, Object^e)
void | BtnRemoveTeam_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnPropertyChanged (String^propertyName)
void | Scenario7Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario8Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | VectorChanged (Windows::Foundation::Collections::IObservableVector< Object^>^sender, Windows::Foundation::Collections::IVectorChangedEventArgs^e)

Properties

Employee | _employee
Teams | _observableTeams
Platform::String | _organization

Private Member Functions

~S2Formatter ()
void | employeeChanged (Object^sender, PropertyChangedEventArgs^e)
void | Scenario1Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario2Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario3Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario4Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario5Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario6Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Platform::String | _city
Windows::UI::Xaml::Media::SolidColorBrush | _color
bool | _isPropertyChangedObserved
Platform::Collections::Vector
< Platform::Object^> 		_items
Platform::String | _name
event
Windows::UI::Xaml::Data::PropertyChangedEventHandler 		_privatePropertyChanged
Windows::Foundation::Collections::PropertySet | _propBag
GeneratorIncrementalLoadingClass employees
MainPage rootPage
Windows::Foundation::EventRegistrationToken | vectorChangedHandlerToken

Detailed Description

Creates a collection of groups and items.

Generic group data model.

Definition at line 21 of file Employee.h.

Constructor & Destructor Documentation

SDKSample::DataBinding::sealed::~S2Formatter ( ) [private]

Member Function Documentation

void SDKSample::DataBinding::sealed::BindableVectorChanged | ( | Windows::UI::Xaml::Interop::IBindableObservableVector^ | sender,
 |  | Object^ | e |
 | ) |  |  | [protected]
void SDKSample::DataBinding::sealed::BtnRemoveTeam_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
virtual Object SDKSample::DataBinding::sealed::Convert | ( | Object^ | value,
 |  | TypeName | targetType,
 |  | Object^ | parameter,
 |  | String^ | language |
 | ) |  |  | [virtual]
virtual Object SDKSample::DataBinding::sealed::ConvertBack | ( | Object^ | value,
 |  | TypeName | targetType,
 |  | Object^ | parameter,
 |  | String^ | language |
 | ) |  |  | [virtual]
SDKSample::DataBinding::sealed::Employee ( ) [inline]

Definition at line 73 of file Employee.h.

            {
                _isPropertyChangedObserved = false;
            }

void SDKSample::DataBinding::sealed::employeeChanged | ( | Object^ | sender,
 |  | PropertyChangedEventArgs^ | e |
 | ) |  |  | [private]
Platform::Object SDKSample::DataBinding::sealed::First ( ) [inline, virtual]

Definition at line 93 of file Team.h.

        {
          return _propBag->First();
        }

Platform::Object SDKSample::DataBinding::sealed::First ( ) [inline, virtual]

Definition at line 152 of file Team.h.

        {
          return _propBag->First();
        }

Platform::Object SDKSample::DataBinding::sealed::GetView ( ) [inline]

Definition at line 125 of file Team.h.

        {
          return _propBag->GetView();
        }

Platform::Object SDKSample::DataBinding::sealed::GetView ( ) [inline]

Definition at line 66 of file Team.h.

        {
          return _propBag->GetView();
        }

virtual bool SDKSample::DataBinding::sealed::HasKey ( Platform::String^ key ) [inline, virtual]

Definition at line 129 of file Team.h.

        {
          return _propBag->HasKey(key);
        }

virtual bool SDKSample::DataBinding::sealed::HasKey ( Platform::String^ key ) [inline, virtual]

Definition at line 70 of file Team.h.

        {
          return _propBag->HasKey(key);
        }

virtual bool SDKSample::DataBinding::sealed::Insert | ( | Platform::String^ | key,
 |  | Platform::Object^ | value |
 | ) |  |  | [inline, virtual]

Definition at line 133 of file Team.h.

        {
          return _propBag->Insert(key, value);
        }

virtual bool SDKSample::DataBinding::sealed::Insert | ( | Platform::String^ | key,
 |  | Platform::Object^ | value |
 | ) |  |  | [inline, virtual]

Definition at line 74 of file Team.h.

        {
          return _propBag->Insert(key, value);
        }

virtual Platform::Object SDKSample::DataBinding::sealed::Lookup ( Platform::String^ key ) [inline, virtual]

Definition at line 137 of file Team.h.

        {
          return _propBag->Lookup(key);
        }

virtual Object SDKSample::DataBinding::sealed::Lookup ( Platform::String^ key ) [inline, virtual]

Definition at line 78 of file Team.h.

        {
          return _propBag->Lookup(key);
        }

void SDKSample::DataBinding::sealed::OnPropertyChanged ( String^ propertyName ) [inline, protected]

Notifies listeners that a property value has changed.

Parameters:
propertyName Name of the property used to notify listeners.

Definition at line 64 of file Employee.h.

            {
                if (_isPropertyChangedObserved)
                {
                    PropertyChanged(this, ref new PropertyChangedEventArgs(propertyName));
                }
            }

virtual void SDKSample::DataBinding::sealed::Remove ( Platform::String^ key ) [inline, virtual]

Definition at line 141 of file Team.h.

        {
          return _propBag->Remove(key);
        }

virtual void SDKSample::DataBinding::sealed::Remove ( Platform::String^ key ) [inline, virtual]

Definition at line 82 of file Team.h.

        {
          return _propBag->Remove(key);
        }

SDKSample::DataBinding::sealed::S2Formatter ( )
SDKSample::DataBinding::sealed::Scenario1 ( )
void SDKSample::DataBinding::sealed::Scenario1Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DataBinding::sealed::Scenario2 ( )
void SDKSample::DataBinding::sealed::Scenario2Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DataBinding::sealed::Scenario3 ( )
void SDKSample::DataBinding::sealed::Scenario3Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DataBinding::sealed::Scenario4 ( )
void SDKSample::DataBinding::sealed::Scenario4Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DataBinding::sealed::Scenario5 ( )
void SDKSample::DataBinding::sealed::Scenario5Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DataBinding::sealed::Scenario6 ( )
void SDKSample::DataBinding::sealed::Scenario6Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DataBinding::sealed::Scenario7 ( )
void SDKSample::DataBinding::sealed::Scenario7Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
SDKSample::DataBinding::sealed::Scenario8 ( )
void SDKSample::DataBinding::sealed::Scenario8Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
SDKSample::DataBinding::sealed::Team ( )
SDKSample::DataBinding::sealed::TeamDataSource ( )
SDKSample::DataBinding::sealed::TeamGroup ( Platform::String^ name )
SDKSample::DataBinding::sealed::Teams ( )
void SDKSample::DataBinding::sealed::VectorChanged | ( | Windows::Foundation::Collections::IObservableVector< Object^>^ | sender,
 |  | Windows::Foundation::Collections::IVectorChangedEventArgs^ | e |
 | ) |  |  | [protected]

Member Data Documentation

Platform::String SDKSample::DataBinding::sealed::_city [private]

Definition at line 100 of file Team.h.

Windows::UI::Xaml::Media::SolidColorBrush SDKSample::DataBinding::sealed::_color [private]

Definition at line 101 of file Team.h.

bool SDKSample::DataBinding::sealed::_isPropertyChangedObserved [private]

Definition at line 56 of file Employee.h.

Platform::Collections::Vector< Platform::Object^> sealed::_items [private]

Definition at line 159 of file Team.h.

Platform::String SDKSample::DataBinding::sealed::_name [private]

Definition at line 99 of file Team.h.

event Windows::UI::Xaml::Data::PropertyChangedEventHandler SDKSample::DataBinding::sealed::_privatePropertyChanged [private]

Definition at line 57 of file Employee.h.

Windows::Foundation::Collections::PropertySet sealed::_propBag [private]

Definition at line 102 of file Team.h.

GeneratorIncrementalLoadingClass SDKSample::DataBinding::sealed::employees [private]

Definition at line 43 of file Scenario8.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 34 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::DataBinding::sealed::vectorChangedHandlerToken [private]

Definition at line 44 of file Scenario8.xaml.h.

Property Documentation

Employee SDKSample::DataBinding::sealed::_employee [private]

Definition at line 35 of file Scenario3.xaml.h.

Teams sealed::_observableTeams

Definition at line 35 of file Scenario7.xaml.h.

Platform::String SDKSample::DataBinding::sealed::_organization

Definition at line 51 of file Employee.h.

The documentation for this class was generated from the following files:
  • XAML data binding/C++/Employee.h
  • XAML data binding/C++/Scenario1.xaml.h
  • XAML data binding/C++/Scenario2.xaml.h
  • XAML data binding/C++/Scenario3.xaml.h
  • XAML data binding/C++/Scenario4.xaml.h
  • XAML data binding/C++/Scenario5.xaml.h
  • XAML data binding/C++/Scenario6.xaml.h
  • XAML data binding/C++/Scenario7.xaml.h
  • XAML data binding/C++/Scenario8.xaml.h
  • XAML data binding/C++/Team.h
  • XAML data binding/C++/S2Formatter.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DataReaderWriter::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • DataReaderWriter
  • SDKSample::DataReaderWriter::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::DataReaderWriter::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "ReadBytes.xaml.h"

List of all members.

Public Member Functions

ReadBytes ()
WriteReadStream ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

Platform::String | GetAddress (int i)
void | HexDump (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PrintRow (Platform::Array< byte >^bytes, int i)
void | ReadLoop (Windows::Storage::Streams::DataReader^dataReader)
Platform::String | ToHex (byte value)
void | TransferData (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

int | currChunk
MainPage rootPage

Static Private Attributes

static int const | bytesPerRow = 16
static int const | bytesPerSegment = 2
static int const | chunkSize = 4096

Detailed Description

Definition at line 31 of file ReadBytes.xaml.h.

Member Function Documentation

Platform::String SDKSample::DataReaderWriter::sealed::GetAddress ( int i ) [private]
void SDKSample::DataReaderWriter::sealed::HexDump | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::DataReaderWriter::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DataReaderWriter::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::DataReaderWriter::sealed::PrintRow | ( | Platform::Array< byte >^ | bytes,
 |  | int | i |
 | ) |  |  | [private]
SDKSample::DataReaderWriter::sealed::ReadBytes ( )
void SDKSample::DataReaderWriter::sealed::ReadLoop ( Windows::Storage::Streams::DataReader^ dataReader ) [private]
Platform::String SDKSample::DataReaderWriter::sealed::ToHex ( byte value ) [private]
void SDKSample::DataReaderWriter::sealed::TransferData | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DataReaderWriter::sealed::WriteReadStream ( )

Member Data Documentation

int const SDKSample::DataReaderWriter::sealed::bytesPerRow = 16 [static, private]

Definition at line 45 of file ReadBytes.xaml.h.

int const SDKSample::DataReaderWriter::sealed::bytesPerSegment = 2 [static, private]

Definition at line 46 of file ReadBytes.xaml.h.

int const SDKSample::DataReaderWriter::sealed::chunkSize = 4096 [static, private]

Definition at line 47 of file ReadBytes.xaml.h.

int SDKSample::DataReaderWriter::sealed::currChunk [private]

Definition at line 48 of file ReadBytes.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 39 of file ReadBytes.xaml.h.

The documentation for this class was generated from the following files:
  • Reading and writing data/C++/ReadBytes.xaml.h
  • Reading and writing data/C++/WriteReadStream.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DateTimeFormatting::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • DateTimeFormatting
  • SDKSample::DateTimeFormatting::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::DateTimeFormatting::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "LongAndShortFormats.xaml.h"

List of all members.

Public Member Functions

LongAndShortFormats ()
OverrideSettings ()
ParametrizedTemplate ()
StringTemplate ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file LongAndShortFormats.xaml.h.

Member Function Documentation

void SDKSample::DateTimeFormatting::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::DateTimeFormatting::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::DateTimeFormatting::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::DateTimeFormatting::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DateTimeFormatting::sealed::LongAndShortFormats ( )
virtual void SDKSample::DateTimeFormatting::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DateTimeFormatting::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DateTimeFormatting::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DateTimeFormatting::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::DateTimeFormatting::sealed::OverrideSettings ( )
SDKSample::DateTimeFormatting::sealed::ParametrizedTemplate ( )
SDKSample::DateTimeFormatting::sealed::StringTemplate ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file LongAndShortFormats.xaml.h.

The documentation for this class was generated from the following files:
  • Date and time formatting/C++/LongAndShortFormats.xaml.h
  • Date and time formatting/C++/OverrideSettings.xaml.h
  • Date and time formatting/C++/ParametrizedTemplate.xaml.h
  • Date and time formatting/C++/StringTemplate.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DeviceCaps::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • DeviceCaps
  • SDKSample::DeviceCaps::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::DeviceCaps::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Keyboard.xaml.h"

List of all members.

Public Member Functions

Keyboard ()
Mouse ()
Pointer ()
Touch ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | KeyboardGetSettings_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | MouseGetSettings_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PointerGetSettings_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Platform::String | PointerType (Windows::Devices::Input::PointerDevice^pointerDevice)
void | TouchGetSettings_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Keyboard.xaml.h.

Member Function Documentation

SDKSample::DeviceCaps::sealed::Keyboard ( )
void SDKSample::DeviceCaps::sealed::KeyboardGetSettings_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DeviceCaps::sealed::Mouse ( )
void SDKSample::DeviceCaps::sealed::MouseGetSettings_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::DeviceCaps::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DeviceCaps::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DeviceCaps::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DeviceCaps::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::DeviceCaps::sealed::Pointer ( )
void SDKSample::DeviceCaps::sealed::PointerGetSettings_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Platform::String SDKSample::DeviceCaps::sealed::PointerType ( Windows::Devices::Input::PointerDevice^ pointerDevice ) [private]
SDKSample::DeviceCaps::sealed::Touch ( )
void SDKSample::DeviceCaps::sealed::TouchGetSettings_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Keyboard.xaml.h.

The documentation for this class was generated from the following files:
  • Input Device capabilities/C++/Keyboard.xaml.h
  • Input Device capabilities/C++/Mouse.xaml.h
  • Input Device capabilities/C++/Pointer.xaml.h
  • Input Device capabilities/C++/Touch.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DeviceEnumeration::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • DeviceEnumeration
  • SDKSample::DeviceEnumeration::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

SDKSample::DeviceEnumeration::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Containers.xaml.h"

List of all members.

Public Member Functions

ContainerDisplayItem (String^id, String^name, String^properties)
Containers ()
InterfaceDisplayItem (String^id, String^name, String^isEnabled)
Interfaces ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Properties

BitmapImage | glyphThumbnail
String | isEnabled
String | name
String | properties
BitmapImage | thumbnail

Private Member Functions

void | DisplayDeviceContainer (PnpObject^container)
void | DisplayDeviceInterface (DeviceInformation^deviceInterface)
void | EnumerateDeviceContainers (Object^sender, RoutedEventArgs^eventArgs)
void | EnumerateDeviceInterfaces (Object^sender, RoutedEventArgs^eventArgs)
void | InterfaceClasses_SelectionChanged (Object^sender, SelectionChangedEventArgs^eventArgs)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 39 of file Containers.xaml.h.

Member Function Documentation

SDKSample::DeviceEnumeration::sealed::ContainerDisplayItem | ( | String^ | id,
 |  | String^ | name,
 |  | String^ | properties |
 | ) |  |  | [inline]

Definition at line 56 of file Containers.xaml.h.

                                                                                :
                    id(id), name(name), properties(properties) {}

SDKSample::DeviceEnumeration::sealed::Containers ( )
void SDKSample::DeviceEnumeration::sealed::DisplayDeviceContainer ( PnpObject^ container ) [private]
void SDKSample::DeviceEnumeration::sealed::DisplayDeviceInterface ( DeviceInformation^ deviceInterface ) [private]
void SDKSample::DeviceEnumeration::sealed::EnumerateDeviceContainers | ( | Object^ | sender,
 |  | RoutedEventArgs^ | eventArgs |
 | ) |  |  | [private]
void SDKSample::DeviceEnumeration::sealed::EnumerateDeviceInterfaces | ( | Object^ | sender,
 |  | RoutedEventArgs^ | eventArgs |
 | ) |  |  | [private]
void SDKSample::DeviceEnumeration::sealed::InterfaceClasses_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | eventArgs |
 | ) |  |  | [private]
SDKSample::DeviceEnumeration::sealed::InterfaceDisplayItem | ( | String^ | id,
 |  | String^ | name,
 |  | String^ | isEnabled |
 | ) |  |  | [inline]

Definition at line 58 of file Interfaces.xaml.h.

                                                                                :
                    id(id), name(name), isEnabled(isEnabled), thumbnail(ref new BitmapImage), glyphThumbnail(ref new BitmapImage) {}

SDKSample::DeviceEnumeration::sealed::Interfaces ( )
virtual void SDKSample::DeviceEnumeration::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DeviceEnumeration::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 47 of file Containers.xaml.h.

Property Documentation

BitmapImage SDKSample::DeviceEnumeration::sealed::glyphThumbnail

Definition at line 72 of file Interfaces.xaml.h.

String SDKSample::DeviceEnumeration::sealed::isEnabled

Definition at line 70 of file Interfaces.xaml.h.

String sealed::name

Definition at line 64 of file Containers.xaml.h.

String SDKSample::DeviceEnumeration::sealed::properties

Definition at line 66 of file Containers.xaml.h.

BitmapImage SDKSample::DeviceEnumeration::sealed::thumbnail

Definition at line 71 of file Interfaces.xaml.h.

The documentation for this class was generated from the following files:
  • Device enumeration/C++/Containers.xaml.h
  • Device enumeration/C++/Interfaces.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DisplayOrientation::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • DisplayOrientation
  • SDKSample::DisplayOrientation::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::DisplayOrientation::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CalculateDeviceRotation (Windows::Devices::Sensors::Accelerometer^sender, Windows::Devices::Sensors::AccelerometerReadingChangedEventArgs^args)
void | CalculateDeviceRotation (Windows::Devices::Sensors::Accelerometer^sender, Windows::Devices::Sensors::AccelerometerReadingChangedEventArgs^args)
void | OnOrientationChanged (Platform::Object^sender)
void | Scenario2Button_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateArrowForRotation ()
void | UpdateArrowForRotation ()

Private Attributes

Windows::Devices::Sensors::Accelerometer | accelerometer
Windows::Foundation::EventRegistrationToken | orientationChangedEventToken
Windows::Foundation::EventRegistrationToken | readingChangedEventToken
double | rotationAngle

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::DisplayOrientation::sealed::CalculateDeviceRotation | ( | Windows::Devices::Sensors::Accelerometer^ | sender,
 |  | Windows::Devices::Sensors::AccelerometerReadingChangedEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::DisplayOrientation::sealed::CalculateDeviceRotation | ( | Windows::Devices::Sensors::Accelerometer^ | sender,
 |  | Windows::Devices::Sensors::AccelerometerReadingChangedEventArgs^ | args |
 | ) |  |  | [private]
virtual void SDKSample::DisplayOrientation::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DisplayOrientation::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DisplayOrientation::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DisplayOrientation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DisplayOrientation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::DisplayOrientation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::DisplayOrientation::sealed::OnOrientationChanged ( Platform::Object^ sender ) [private]
SDKSample::DisplayOrientation::sealed::Scenario1 ( )
SDKSample::DisplayOrientation::sealed::Scenario2 ( )
void SDKSample::DisplayOrientation::sealed::Scenario2Button_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::DisplayOrientation::sealed::Scenario3 ( )
void SDKSample::DisplayOrientation::sealed::UpdateArrowForRotation ( ) [private]
void SDKSample::DisplayOrientation::sealed::UpdateArrowForRotation ( ) [private]

Member Data Documentation

Windows::Devices::Sensors::Accelerometer sealed::accelerometer [private]

Definition at line 48 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::DisplayOrientation::sealed::orientationChangedEventToken [private]

Definition at line 42 of file Scenario3.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::readingChangedEventToken [private]

Definition at line 49 of file Scenario1.xaml.h.

double sealed::rotationAngle [private]

Definition at line 47 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Display orientation/C++/Scenario1.xaml.h
  • Display orientation/C++/Scenario2.xaml.h
  • Display orientation/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Drawing::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Drawing
  • SDKSample::Drawing::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Drawing::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ColorOffsetValueChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs e)
void | ColorSelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | FillSelection_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | LoadGradient ()
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StrokeWidthSelection_ValueChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::Drawing::sealed::ColorOffsetValueChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs | e |
 | ) |  |  | [private]
void SDKSample::Drawing::sealed::ColorSelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs | e |
 | ) |  |  | [private]
void SDKSample::Drawing::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Drawing::sealed::FillSelection_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Drawing::sealed::LoadGradient ( ) [private]
virtual void SDKSample::Drawing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Drawing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Drawing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Drawing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Drawing::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Drawing::sealed::Scenario1 ( )
SDKSample::Drawing::sealed::Scenario2 ( )
SDKSample::Drawing::sealed::Scenario3 ( )
SDKSample::Drawing::sealed::Scenario4 ( )
void SDKSample::Drawing::sealed::StrokeWidthSelection_ValueChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML vector-based drawing/C++/Scenario1.xaml.h
  • XAML vector-based drawing/C++/Scenario2.xaml.h
  • XAML vector-based drawing/C++/Scenario3.xaml.h
  • XAML vector-based drawing/C++/Scenario4.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::EAS::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • EAS
  • SDKSample::EAS::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::EAS::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Launch_Click1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Launch_Click2 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Launch_Click3 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Reset_Click1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Reset_Click2 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Reset_Click3 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::EAS::sealed::Launch_Click1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::EAS::sealed::Launch_Click2 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::EAS::sealed::Launch_Click3 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::EAS::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::EAS::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::EAS::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::EAS::sealed::Reset_Click1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::EAS::sealed::Reset_Click2 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::EAS::sealed::Reset_Click3 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::EAS::sealed::Scenario1 ( )
SDKSample::EAS::sealed::Scenario2 ( )
SDKSample::EAS::sealed::Scenario3 ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • EAS policies for mail clients/C++/Scenario1.xaml.h
  • EAS policies for mail clients/C++/Scenario2.xaml.h
  • EAS policies for mail clients/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ELS::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ELS
  • SDKSample::ELS::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ELS::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "LanguageDetection.xaml.h"

List of all members.

Public Member Functions

LanguageDetection ()
ScriptDetection ()
Transliteration ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file LanguageDetection.xaml.h.

Member Function Documentation

void SDKSample::ELS::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ELS::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ELS::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ELS::sealed::LanguageDetection ( )
virtual void SDKSample::ELS::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ELS::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ELS::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::ELS::sealed::ScriptDetection ( )
SDKSample::ELS::sealed::Transliteration ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 39 of file LanguageDetection.xaml.h.

The documentation for this class was generated from the following files:
  • Extended Linguistic Services (ELS)/C++/LanguageDetection.xaml.h
  • Extended Linguistic Services (ELS)/C++/ScriptDetection.xaml.h
  • Extended Linguistic Services (ELS)/C++/Transliteration.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Errors Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::Errors
Static Public Attributes

SDKSample::Errors Class Reference

#include "Constants.h"

List of all members.

Static Public Attributes

static Platform::String | Cancel = "No result (operation cancelled, no item selected)"
static Platform::String | FileGroupEmpty = "No result (unexpected error: retrieved file group was null)"
static Platform::String | FileGroupLocation = "File groups are only available for library locations, please select a folder from one of your libraries"
static Platform::String | NoAlbumArt = "No result (no album art available for this song)"
static Platform::String | NoExifThumbnail = "No result (no EXIF thumbnail or cached thumbnail available for fast retrieval)"
static Platform::String | NoIcon = "No result (no icon available for this document type)"
static Platform::String | NoImages = "No result (no thumbnail could be obtained from the selected folder - make sure that the folder contains images)"
static Platform::String | NoThumbnail = "No result (no thumbnail could be obtained from the selected file)"

Detailed Description

Definition at line 23 of file Constants.h.

Member Data Documentation

String Errors::Cancel = "No result (operation cancelled, no item selected)" [static]

Definition at line 33 of file Constants.h.

String Errors::FileGroupEmpty = "No result (unexpected error: retrieved file group was null)" [static]

Definition at line 31 of file Constants.h.

String Errors::FileGroupLocation = "File groups are only available for library locations, please select a folder from one of your libraries" [static]

Definition at line 32 of file Constants.h.

String Errors::NoAlbumArt = "No result (no album art available for this song)" [static]

Definition at line 28 of file Constants.h.

String Errors::NoExifThumbnail = "No result (no EXIF thumbnail or cached thumbnail available for fast retrieval)" [static]

Definition at line 26 of file Constants.h.

String Errors::NoIcon = "No result (no icon available for this document type)" [static]

Definition at line 29 of file Constants.h.

String Errors::NoImages = "No result (no thumbnail could be obtained from the selected folder - make sure that the folder contains images)" [static]

Definition at line 30 of file Constants.h.

String Errors::NoThumbnail = "No result (no thumbnail could be obtained from the selected file)" [static]

Definition at line 27 of file Constants.h.

The documentation for this class was generated from the following files:
  • File and folder thumbnail/C++/Constants.h
  • File and folder thumbnail/C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ExpressionBlendSampleDataSampleDataSource
  • SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
Public Member Functions | Public Attributes | Private Attributes

SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "SampleDataSource.h"

List of all members.

Public Member Functions

void | Add (Item^item)
Item ()
ItemCollection ()
MessageData ()
void | OnPropertyChanged (Platform::String^propertyName)

Public Attributes

Windows::UI::Xaml::Interop::IBindableObservableVector | _items

Private Attributes

Platform::String | _Category
Platform::String | _Content
Platform::String | _Description
ImageSource | _Image
Platform::String | _Link
event PropertyChangedEventHandler | _PropertyChanged
Platform::String | _Subtitle
Platform::String | _Title
Platform::Collections::Vector
< Item^> 		itemCollection

Detailed Description

Definition at line 23 of file SampleDataSource.h.

Member Function Documentation

void SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::Add ( Item^ item ) [inline]

Definition at line 167 of file SampleDataSource.h.

      {
        itemCollection->Append(item);
      }

SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::Item ( )
SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::ItemCollection ( ) [inline]

Definition at line 162 of file SampleDataSource.h.

      {
          itemCollection = ref new Platform::Collections::Vector<Item^>();
      };

SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::MessageData ( ) [inline]

Definition at line 180 of file SampleDataSource.h.

      {
        _items = ref new Platform::Collections::Vector<Item^>();
        Windows::Foundation::Uri^ _baseUri = ref new Windows::Foundation::Uri("ms-appx:///");

        Item^ item;
        item = ref new Item();
        item->Title="New Flavors out this week!";
        item->Subtitle="Adam Barr";
        item->SetImage(_baseUri, "SampleData/Images/image1.jpg");
        item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum";
        _items->Append(item);

        item = ref new Item();
        item->Title="Check out this topping!";
        item->Subtitle="David Alexander";
        item->SetImage(_baseUri, "SampleData/Images/image2.jpg");
        item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue";
        _items->Append(item);

        item = ref new Item();
        item->Title="Come to the Ice Cream Party";
        item->Subtitle="Josh Bailey";
        item->SetImage(_baseUri, "SampleData/Images/image3.jpg");
        item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse";
        _items->Append(item);

        item = ref new Item();
        item->Title="How about gluten free?";
        item->Subtitle="Chris Berry";
        item->SetImage(_baseUri, "SampleData/Images/image4.jpg");
        item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
        _items->Append(item);

        item = ref new Item();
        item->Title= "Summer promotion - BYGO";
        item->Subtitle="Sean Bentley";
        item->SetImage(_baseUri, "SampleData/Images/image5.jpg");
        item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat";
        _items->Append(item);

        item = ref new Item();
        item->Title="Awesome flavor combination";
        item->Subtitle="Adrian Lannin";
        item->SetImage(_baseUri, "SampleData/Images/image6.jpg");
        item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer";
        _items->Append(item);
      }

void SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::OnPropertyChanged ( Platform::String^ propertyName ) [inline]

Definition at line 40 of file SampleDataSource.h.

      {
        PropertyChangedEventArgs^ pcea = ref new  PropertyChangedEventArgs(propertyName);
        _PropertyChanged(this,pcea);
      }

Member Data Documentation

Platform::String SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_Category [private]

Definition at line 32 of file SampleDataSource.h.

Platform::String SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_Content [private]

Definition at line 34 of file SampleDataSource.h.

Platform::String SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_Description [private]

Definition at line 33 of file SampleDataSource.h.

ImageSource SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_Image [private]

Definition at line 35 of file SampleDataSource.h.

Windows::UI::Xaml::Interop::IBindableObservableVector SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_items

Definition at line 177 of file SampleDataSource.h.

Platform::String SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_Link [private]

Definition at line 31 of file SampleDataSource.h.

event PropertyChangedEventHandler SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_PropertyChanged [private]

Definition at line 36 of file SampleDataSource.h.

Platform::String SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_Subtitle [private]

Definition at line 30 of file SampleDataSource.h.

Platform::String SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::_Title [private]

Definition at line 29 of file SampleDataSource.h.

Platform::Collections::Vector<Item^> SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed::itemCollection [private]

Definition at line 159 of file SampleDataSource.h.

The documentation for this class was generated from the following file:
  • XAML personality animations/C++/SampleData/SampleDataSource.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FileAccess::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • FileAccess
  • SDKSample::FileAccess::sealed
Public Member Functions | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::FileAccess::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()
Scenario6 ()
Scenario7 ()
Scenario8 ()

Private Member Functions

void | AddToListButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CopyFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CreateFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DeleteFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Windows::Storage::Streams::IBuffer | GetBufferFromString (Platform::String^str)
void | OpenFromListButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ReadBytesButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ReadFromStreamButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ReadTextButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowListButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowPropertiesButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WriteBytesButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WriteTextButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WriteToStreamButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Static Private Attributes

static Platform::String | dateAccessedProperty
static
Windows::Globalization::DateTimeFormatting::DateTimeFormatter 		dateFormat
static Platform::String | fileOwnerProperty
static
Windows::Globalization::DateTimeFormatting::DateTimeFormatter 		timeFormat

Detailed Description

Definition at line 29 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::FileAccess::sealed::AddToListButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::CopyFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::CreateFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::DeleteFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Windows::Storage::Streams::IBuffer SDKSample::FileAccess::sealed::GetBufferFromString ( Platform::String^ str ) [private]
void SDKSample::FileAccess::sealed::OpenFromListButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::ReadBytesButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::ReadFromStreamButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::ReadTextButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::FileAccess::sealed::Scenario1 ( )
SDKSample::FileAccess::sealed::Scenario2 ( )
SDKSample::FileAccess::sealed::Scenario3 ( )
SDKSample::FileAccess::sealed::Scenario4 ( )
SDKSample::FileAccess::sealed::Scenario5 ( )
SDKSample::FileAccess::sealed::Scenario6 ( )
SDKSample::FileAccess::sealed::Scenario7 ( )
SDKSample::FileAccess::sealed::Scenario8 ( )
void SDKSample::FileAccess::sealed::ShowListButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::ShowPropertiesButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::WriteBytesButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::WriteTextButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileAccess::sealed::WriteToStreamButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Platform::String SDKSample::FileAccess::sealed::dateAccessedProperty [static, private]

Definition at line 37 of file Scenario5.xaml.h.

Windows::Globalization::DateTimeFormatting::DateTimeFormatter SDKSample::FileAccess::sealed::dateFormat [static, private]

Definition at line 35 of file Scenario5.xaml.h.

Platform::String SDKSample::FileAccess::sealed::fileOwnerProperty [static, private]

Definition at line 38 of file Scenario5.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 35 of file Scenario1.xaml.h.

Windows::Globalization::DateTimeFormatting::DateTimeFormatter SDKSample::FileAccess::sealed::timeFormat [static, private]

Definition at line 36 of file Scenario5.xaml.h.

The documentation for this class was generated from the following files:
  • File access/C++/Scenario1.xaml.h
  • File access/C++/Scenario2.xaml.h
  • File access/C++/Scenario3.xaml.h
  • File access/C++/Scenario4.xaml.h
  • File access/C++/Scenario5.xaml.h
  • File access/C++/Scenario6.xaml.h
  • File access/C++/Scenario7.xaml.h
  • File access/C++/Scenario8.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FileExtensions Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::FileExtensions
Static Public Attributes

SDKSample::FileExtensions Class Reference

#include "Constants.h"

List of all members.

Static Public Attributes

static Platform::Array
< Platform::String^> 		Document
static Platform::Array
< Platform::String^> 		Image
static Platform::Array
< Platform::String^> 		Music

Detailed Description

Definition at line 36 of file Constants.h.

Member Data Documentation

Array< String^> FileExtensions::Document [static]
Initial value:
 ref new Array<String^>
{
    ".doc",
    ".docx",
    ".xls",
    ".xlsx",
    ".ppt",
    ".pptx",
    ".pdf",
    ".txt",
    ".rtf",
}

Definition at line 39 of file Constants.h.

Array< String^> FileExtensions::Image [static]
Initial value:
 ref new Array<String^>
{
    ".jpg",
    ".png",
    ".bmp",
    ".gif",
    ".tif",
}

Definition at line 40 of file Constants.h.

Array< String^> FileExtensions::Music [static]
Initial value:
 ref new Array<String^>
{
    ".mp3",
    ".wma",
    ".m4a",
    ".aac",
}

Definition at line 41 of file Constants.h.

The documentation for this class was generated from the following files:
  • File and folder thumbnail/C++/Constants.h
  • File and folder thumbnail/C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FilePicker::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • FilePicker
  • SDKSample::FilePicker::sealed
Public Member Functions | Private Member Functions | Private Attributes

SDKSample::FilePicker::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()
Scenario6 ()

Private Member Functions

void | OutputFileAsync (Windows::Storage::StorageFile^file)
void | OutputFileAsync (Windows::Storage::StorageFile^file)
void | OutputFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickAFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickFilesButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickFolderButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SaveFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SaveFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WriteFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Platform::String | fileToken
MainPage rootPage

Detailed Description

Definition at line 29 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::FilePicker::sealed::OutputFileAsync ( Windows::Storage::StorageFile^ file ) [private]
void SDKSample::FilePicker::sealed::OutputFileAsync ( Windows::Storage::StorageFile^ file ) [private]
void SDKSample::FilePicker::sealed::OutputFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePicker::sealed::PickAFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePicker::sealed::PickFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePicker::sealed::PickFilesButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePicker::sealed::PickFolderButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePicker::sealed::SaveFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePicker::sealed::SaveFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::FilePicker::sealed::Scenario1 ( )
SDKSample::FilePicker::sealed::Scenario2 ( )
SDKSample::FilePicker::sealed::Scenario3 ( )
SDKSample::FilePicker::sealed::Scenario4 ( )
SDKSample::FilePicker::sealed::Scenario5 ( )
SDKSample::FilePicker::sealed::Scenario6 ( )
void SDKSample::FilePicker::sealed::WriteFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Platform::String sealed::fileToken [private]

Definition at line 36 of file Scenario5.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 35 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • File picker/C++/Scenario1.xaml.h
  • File picker/C++/Scenario2.xaml.h
  • File picker/C++/Scenario3.xaml.h
  • File picker/C++/Scenario4.xaml.h
  • File picker/C++/Scenario5.xaml.h
  • File picker/C++/Scenario6.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FilePickerContracts::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • FilePickerContracts
  • SDKSample::FilePickerContracts::sealed
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::FilePickerContracts::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "CachedFileUpdater_Local.xaml.h"

List of all members.

Public Member Functions

void | Activate (Windows::ApplicationModel::Activation::CachedFileUpdaterActivatedEventArgs^e)
void | Activate (Windows::ApplicationModel::Activation::FileSavePickerActivatedEventArgs^e)
void | Activate (Windows::ApplicationModel::Activation::FileOpenPickerActivatedEventArgs^e)
CachedFileUpdater_Local ()
CachedFileUpdater_Remote ()
CachedFileUpdaterPage ()
FileOpenPicker_PickAppFile ()
FileOpenPicker_PickCachedFile ()
FileOpenPicker_PickURLFile ()
FileOpenPickerPage ()
FileSavePicker_FailToSave ()
FileSavePicker_SaveToAppStorage ()
FileSavePicker_SaveToCachedFile ()
FileSavePickerPage ()
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
MainPage_CachedFile ()
MainPage_PickFile ()
MainPage_SaveFile ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
void | NotifyUser (Platform::String^strMessage, NotifyType type)
void | NotifyUser (Platform::String^strMessage, NotifyType type)
void | ResetScenarioOutput (Windows::UI::Xaml::Controls::TextBlock^textblock)
void | ResetScenarioOutput (Windows::UI::Xaml::Controls::TextBlock^textblock)
void | ResetScenarioOutput (Windows::UI::Xaml::Controls::TextBlock^textblock)

Public Attributes

event
Windows::Foundation::EventHandler
< PageSizeChangedEventArgs^> 		PageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Protected Member Functions

void | CachedFileUpdaterPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | FileOpenPickerPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | FileSavePickerPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Protected Attributes

Windows::Storage::Pickers::Provider::FileOpenPickerUI | fileOpenPickerUI
Windows::Storage::Pickers::Provider::FileSavePickerUI | fileSavePickerUI

Private Member Functions

void | AddFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | AddLocalFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | AddURLFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | FileIsCurrentButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | OnFileRemoved (Windows::Storage::Pickers::Provider::FileOpenPickerUI^sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^e)
void | OnFileRemoved (Windows::Storage::Pickers::Provider::FileOpenPickerUI^sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^e)
void | OnFileRemoved (Windows::Storage::Pickers::Provider::FileOpenPickerUI^sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^e)
void | OnFileUpdateRequested (Windows::Storage::Provider::CachedFileUpdaterUI^sender, Windows::Storage::Provider::FileUpdateRequestedEventArgs^e)
void | OnTargetFileRequested (Windows::Storage::Pickers::Provider::FileSavePickerUI^sender, Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^e)
void | OnTargetFileRequested (Windows::Storage::Pickers::Provider::FileSavePickerUI^sender, Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^e)
void | OnTargetFileRequested (Windows::Storage::Pickers::Provider::FileSavePickerUI^sender, Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^e)
void | OnUIRequested (Windows::Storage::Provider::CachedFileUpdaterUI^sender, Platform::Object^e)
void | OutputFileAsync (Windows::Storage::StorageFile^file)
void | OutputFileAsync (Windows::Storage::StorageFile^file)
void | OverwriteButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | ProvideUpdatedVersionButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RemoveFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RemoveLocalFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RemoveURLFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RenameButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SaveFileButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateButtonState (bool fileInBasket)
void | UpdateButtonState (bool fileInBasket)
void | UpdateButtonState (bool fileInBasket)
void | UpdateUI (Windows::Storage::Provider::UIStatus uiStatus)
void | UpdateUI (Windows::Storage::Provider::UIStatus uiStatus)

Private Attributes

internal | __pad0__: static CachedFileUpdaterPage^ Current
bool | autoSizeInputSectionWhenSnapped
Windows::Storage::Provider::CachedFileUpdaterUI | cachedFileUpdaterUI
Platform::String | fileID
Windows::Storage::Provider::FileUpdateRequest | fileUpdateRequest
Windows::Storage::Provider::FileUpdateRequestDeferral | fileUpdateRequestDeferral
Windows::UI::Xaml::Controls::Frame | HiddenFrame
Platform::Collections::Vector
< Object^> 		ScenarioList
Windows::Foundation::EventRegistrationToken | token

Static Private Attributes

static Platform::Array< Scenario > | localScenariosInner
static Platform::Array< Scenario > | remoteScenariosInner
static Platform::Array< Scenario > | scenariosInner

Detailed Description

Definition at line 28 of file CachedFileUpdater_Local.xaml.h.

Member Function Documentation

void SDKSample::FilePickerContracts::sealed::Activate ( Windows::ApplicationModel::Activation::CachedFileUpdaterActivatedEventArgs^ e )
void SDKSample::FilePickerContracts::sealed::Activate ( Windows::ApplicationModel::Activation::FileSavePickerActivatedEventArgs^ e )
void SDKSample::FilePickerContracts::sealed::Activate ( Windows::ApplicationModel::Activation::FileOpenPickerActivatedEventArgs^ e )
void SDKSample::FilePickerContracts::sealed::AddFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::AddLocalFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::AddURLFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::FilePickerContracts::sealed::CachedFileUpdater_Local ( )
SDKSample::FilePickerContracts::sealed::CachedFileUpdater_Remote ( )
SDKSample::FilePickerContracts::sealed::CachedFileUpdaterPage ( )
void SDKSample::FilePickerContracts::sealed::CachedFileUpdaterPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::FilePickerContracts::sealed::FileIsCurrentButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::FilePickerContracts::sealed::FileOpenPicker_PickAppFile ( )
SDKSample::FilePickerContracts::sealed::FileOpenPicker_PickCachedFile ( )
SDKSample::FilePickerContracts::sealed::FileOpenPicker_PickURLFile ( )
SDKSample::FilePickerContracts::sealed::FileOpenPickerPage ( )
void SDKSample::FilePickerContracts::sealed::FileOpenPickerPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
SDKSample::FilePickerContracts::sealed::FileSavePicker_FailToSave ( )
SDKSample::FilePickerContracts::sealed::FileSavePicker_SaveToAppStorage ( )
SDKSample::FilePickerContracts::sealed::FileSavePicker_SaveToCachedFile ( )
SDKSample::FilePickerContracts::sealed::FileSavePickerPage ( )
void SDKSample::FilePickerContracts::sealed::FileSavePickerPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::FilePickerContracts::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::InvalidateSize ( ) [private]
void SDKSample::FilePickerContracts::sealed::InvalidateSize ( ) [private]
void SDKSample::FilePickerContracts::sealed::InvalidateSize ( ) [private]
void SDKSample::FilePickerContracts::sealed::InvalidateViewState ( ) [private]
void SDKSample::FilePickerContracts::sealed::InvalidateViewState ( ) [private]
void SDKSample::FilePickerContracts::sealed::InvalidateViewState ( ) [private]
void SDKSample::FilePickerContracts::sealed::LoadScenario ( Platform::String^ scenarioName )
void SDKSample::FilePickerContracts::sealed::LoadScenario ( Platform::String^ scenarioName )
void SDKSample::FilePickerContracts::sealed::LoadScenario ( Platform::String^ scenarioName )
virtual void SDKSample::FilePickerContracts::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
SDKSample::FilePickerContracts::sealed::MainPage_CachedFile ( )
SDKSample::FilePickerContracts::sealed::MainPage_PickFile ( )
SDKSample::FilePickerContracts::sealed::MainPage_SaveFile ( )
void SDKSample::FilePickerContracts::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void SDKSample::FilePickerContracts::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void SDKSample::FilePickerContracts::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void SDKSample::FilePickerContracts::sealed::OnFileRemoved | ( | Windows::Storage::Pickers::Provider::FileOpenPickerUI^ | sender,
 |  | Windows::Storage::Pickers::Provider::FileRemovedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::OnFileRemoved | ( | Windows::Storage::Pickers::Provider::FileOpenPickerUI^ | sender,
 |  | Windows::Storage::Pickers::Provider::FileRemovedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::OnFileRemoved | ( | Windows::Storage::Pickers::Provider::FileOpenPickerUI^ | sender,
 |  | Windows::Storage::Pickers::Provider::FileRemovedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::OnFileUpdateRequested | ( | Windows::Storage::Provider::CachedFileUpdaterUI^ | sender,
 |  | Windows::Storage::Provider::FileUpdateRequestedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::FilePickerContracts::sealed::OnTargetFileRequested | ( | Windows::Storage::Pickers::Provider::FileSavePickerUI^ | sender,
 |  | Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::OnTargetFileRequested | ( | Windows::Storage::Pickers::Provider::FileSavePickerUI^ | sender,
 |  | Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::OnTargetFileRequested | ( | Windows::Storage::Pickers::Provider::FileSavePickerUI^ | sender,
 |  | Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::OnUIRequested | ( | Windows::Storage::Provider::CachedFileUpdaterUI^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::OutputFileAsync ( Windows::Storage::StorageFile^ file ) [private]
void SDKSample::FilePickerContracts::sealed::OutputFileAsync ( Windows::Storage::StorageFile^ file ) [private]
void SDKSample::FilePickerContracts::sealed::OverwriteButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::PickFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::PopulateScenarios ( ) [private]
void SDKSample::FilePickerContracts::sealed::PopulateScenarios ( ) [private]
void SDKSample::FilePickerContracts::sealed::PopulateScenarios ( ) [private]
void SDKSample::FilePickerContracts::sealed::ProvideUpdatedVersionButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::RemoveFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::RemoveLocalFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::RemoveURLFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::RenameButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FilePickerContracts::sealed::ResetScenarioOutput ( Windows::UI::Xaml::Controls::TextBlock^ textblock )
void SDKSample::FilePickerContracts::sealed::ResetScenarioOutput ( Windows::UI::Xaml::Controls::TextBlock^ textblock )
void SDKSample::FilePickerContracts::sealed::ResetScenarioOutput ( Windows::UI::Xaml::Controls::TextBlock^ textblock )
void SDKSample::FilePickerContracts::sealed::SaveFileButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::FilePickerContracts::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::FilePickerContracts::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
void SDKSample::FilePickerContracts::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::FilePickerContracts::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::FilePickerContracts::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::FilePickerContracts::sealed::UpdateButtonState ( bool fileInBasket ) [private]
void SDKSample::FilePickerContracts::sealed::UpdateButtonState ( bool fileInBasket ) [private]
void SDKSample::FilePickerContracts::sealed::UpdateButtonState ( bool fileInBasket ) [private]
void SDKSample::FilePickerContracts::sealed::UpdateUI ( Windows::Storage::Provider::UIStatus uiStatus ) [private]
void SDKSample::FilePickerContracts::sealed::UpdateUI ( Windows::Storage::Provider::UIStatus uiStatus ) [private]

Member Data Documentation

internal sealed::__pad0__ [private]

Definition at line 110 of file CachedFileUpdaterPage.xaml.h.

bool sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 94 of file CachedFileUpdaterPage.xaml.h.

Windows::Storage::Provider::CachedFileUpdaterUI SDKSample::FilePickerContracts::sealed::cachedFileUpdaterUI [private]

Definition at line 113 of file CachedFileUpdaterPage.xaml.h.

Platform::String sealed::fileID [private]

Definition at line 42 of file FileOpenPicker_PickAppFile.xaml.h.

Windows::Storage::Pickers::Provider::FileOpenPickerUI SDKSample::FilePickerContracts::sealed::fileOpenPickerUI [protected]

Definition at line 99 of file FileOpenPickerPage.xaml.h.

Windows::Storage::Pickers::Provider::FileSavePickerUI SDKSample::FilePickerContracts::sealed::fileSavePickerUI [protected]

Definition at line 99 of file FileSavePickerPage.xaml.h.

Windows::Storage::Provider::FileUpdateRequest SDKSample::FilePickerContracts::sealed::fileUpdateRequest [private]

Definition at line 111 of file CachedFileUpdaterPage.xaml.h.

Windows::Storage::Provider::FileUpdateRequestDeferral SDKSample::FilePickerContracts::sealed::fileUpdateRequestDeferral [private]

Definition at line 112 of file CachedFileUpdaterPage.xaml.h.

Windows::UI::Xaml::Controls::Frame sealed::HiddenFrame [private]

Definition at line 93 of file CachedFileUpdaterPage.xaml.h.

Platform::Array<Scenario> SDKSample::FilePickerContracts::sealed::localScenariosInner [static, private]

Definition at line 95 of file CachedFileUpdaterPage.xaml.h.

event Windows::Foundation::EventHandler< PageSizeChangedEventArgs^> sealed::PageResized

Definition at line 84 of file CachedFileUpdaterPage.xaml.h.

Platform::Array<Scenario> SDKSample::FilePickerContracts::sealed::remoteScenariosInner [static, private]

Definition at line 96 of file CachedFileUpdaterPage.xaml.h.

Platform::Collections::Vector< Object^> sealed::ScenarioList [private]

Definition at line 92 of file CachedFileUpdaterPage.xaml.h.

event Windows::Foundation::EventHandler< Platform::Object^> sealed::ScenarioLoaded

Definition at line 83 of file CachedFileUpdaterPage.xaml.h.

static Platform::Array< Scenario > sealed::scenariosInner [static, private]

Definition at line 88 of file FileOpenPickerPage.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::token [private]

Definition at line 43 of file FileOpenPicker_PickAppFile.xaml.h.

The documentation for this class was generated from the following files:
  • File picker contracts/C++/CachedFileUpdater_Local.xaml.h
  • File picker contracts/C++/CachedFileUpdaterPage.xaml.h
  • File picker contracts/C++/FileOpenPicker_PickAppFile.xaml.h
  • File picker contracts/C++/FileOpenPicker_PickCachedFile.xaml.h
  • File picker contracts/C++/FileOpenPicker_PickURLFile.xaml.h
  • File picker contracts/C++/FileOpenPickerPage.xaml.h
  • File picker contracts/C++/FileSavePicker_FailToSave.xaml.h
  • File picker contracts/C++/FileSavePicker_SaveToAppStorage.xaml.h
  • File picker contracts/C++/FileSavePicker_SaveToCachedFile.xaml.h
  • File picker contracts/C++/FileSavePickerPage.xaml.h
  • File picker contracts/C++/CachedFileUpdater_Remote.xaml.h
  • File picker contracts/C++/MainPage_CachedFile.xaml.h
  • File picker contracts/C++/MainPage_PickFile.xaml.h
  • File picker contracts/C++/MainPage_SaveFile.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FileSearch::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • FileSearch
  • SDKSample::FileSearch::sealed
Public Member Functions | Private Member Functions

SDKSample::FileSearch::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()

Private Member Functions

void SearchButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Detailed Description

Definition at line 29 of file Scenario1.xaml.h.

Member Function Documentation

SDKSample::FileSearch::sealed::Scenario1 ( )
void SDKSample::FileSearch::sealed::SearchButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
The documentation for this class was generated from the following file:
  • Programmatic file search/C++/Scenario1.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FileThumbnails::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • FileThumbnails
  • SDKSample::FileThumbnails::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::FileThumbnails::sealed Class Reference

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | GetThumbnailButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetThumbnailButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetThumbnailButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetThumbnailButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetThumbnailButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 27 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::FileThumbnails::sealed::GetThumbnailButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileThumbnails::sealed::GetThumbnailButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileThumbnails::sealed::GetThumbnailButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileThumbnails::sealed::GetThumbnailButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FileThumbnails::sealed::GetThumbnailButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::FileThumbnails::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FileThumbnails::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FileThumbnails::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FileThumbnails::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FileThumbnails::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::FileThumbnails::sealed::Scenario1 ( )
SDKSample::FileThumbnails::sealed::Scenario2 ( )
SDKSample::FileThumbnails::sealed::Scenario3 ( )
SDKSample::FileThumbnails::sealed::Scenario4 ( )
SDKSample::FileThumbnails::sealed::Scenario5 ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 36 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • File and folder thumbnail/C++/Scenario1.xaml.h
  • File and folder thumbnail/C++/Scenario2.xaml.h
  • File and folder thumbnail/C++/Scenario3.xaml.h
  • File and folder thumbnail/C++/Scenario4.xaml.h
  • File and folder thumbnail/C++/Scenario5.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Finally Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::Finally
Public Member Functions | Private Attributes

SDKSample::Finally Class Reference

#include "Constants.h"

List of all members.

Public Member Functions

Finally (std::function< void()> f)
~Finally ()

Private Attributes

std::function< void()> finallyClause

Detailed Description

Definition at line 52 of file Constants.h.

Constructor & Destructor Documentation

SDKSample::Finally::Finally ( std::function< void()> f ) [inline]

Definition at line 55 of file Constants.h.

: finallyClause(f) {}

SDKSample::Finally::~Finally ( ) [inline]

Definition at line 56 of file Constants.h.

        {
            finallyClause();
        }

Member Data Documentation

std::function<void()> SDKSample::Finally::finallyClause [private]

Definition at line 62 of file Constants.h.

The documentation for this class was generated from the following file:
  • Search contract/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FlipViewCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • FlipViewCPP
  • SDKSample::FlipViewCPP::sealed
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::FlipViewCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()

Public Attributes

internal | __pad0__: static Scenario3^ Current

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Orientation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
virtual
Windows::UI::Xaml::DataTemplate 		SelectTemplateCore (Platform::Object^item, Windows::UI::Xaml::DependencyObject^container) override

Private Member Functions

void | Orientation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TOCButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

bool | bHorizontal
MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

virtual void SDKSample::FlipViewCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FlipViewCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FlipViewCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FlipViewCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::FlipViewCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::FlipViewCPP::sealed::Orientation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::FlipViewCPP::sealed::Orientation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::FlipViewCPP::sealed::Scenario1 ( )
SDKSample::FlipViewCPP::sealed::Scenario2 ( )
SDKSample::FlipViewCPP::sealed::Scenario3 ( )
SDKSample::FlipViewCPP::sealed::Scenario4 ( )
SDKSample::FlipViewCPP::sealed::Scenario5 ( )
virtual Windows::UI::Xaml::DataTemplate SDKSample::FlipViewCPP::sealed::SelectTemplateCore | ( | Platform::Object^ | item,
 |  | Windows::UI::Xaml::DependencyObject^ | container |
 | ) |  |  | [inline, override, protected, virtual]

Definition at line 51 of file Scenario3.xaml.h.

      {
        using namespace Windows::UI::Xaml;
        using namespace FlipViewData;

        DataTemplate^ itemTemplate = dynamic_cast<DataTemplate^>(Scenario3::Current->Resources->Lookup("ImageTemplate"));
        DataTemplate^ tocTemplate =  dynamic_cast<DataTemplate^>(Scenario3::Current->Resources->Lookup("TOCTemplate"));

        SampleDataItem^ dataItem = dynamic_cast<SampleDataItem^>(item);

        if (dataItem != nullptr)
        {
          return itemTemplate;
        }
        else
        {
          return tocTemplate;
        }
      }

void SDKSample::FlipViewCPP::sealed::TOCButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal SDKSample::FlipViewCPP::sealed::__pad0__

Definition at line 37 of file Scenario3.xaml.h.

bool sealed::bHorizontal [private]

Definition at line 41 of file Scenario2.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML FlipView control/C++/Scenario1.xaml.h
  • XAML FlipView control/C++/Scenario2.xaml.h
  • XAML FlipView control/C++/Scenario3.xaml.h
  • XAML FlipView control/C++/Scenario4.xaml.h
  • XAML FlipView control/C++/Scenario5.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FlipViewData::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • FlipViewData
  • SDKSample::FlipViewData::sealed
Public Member Functions | Public Attributes | Static Public Attributes | Private Attributes

SDKSample::FlipViewData::sealed Class Reference

Creates a collection of groups and items with hard-coded content.

#include "SampleDataSource.h"

List of all members.

Public Member Functions

void | Add (SampleDataItem^item)
UINT | GetCollectionCount ()
SampleDataItem | GetItemAt (UINT i)
ItemCollection ()
void | OnPropertyChanged (Platform::String^propertyName)
SampleDataItem (Platform::String^title, Platform::String^type, Platform::String^picture)
SampleDataSource ()

Public Attributes

ImageSource | _image
Windows::UI::Xaml::Interop::IBindableObservableVector | _items
Platform::String | _picture
event PropertyChangedEventHandler | _PropertyChanged
Platform::String | _title
Platform::String | _type

Static Public Attributes

static Uri | _baseUri

Private Attributes

UINT | count
Windows::Foundation::Collections::IObservableVector
< SampleDataItem^> 		itemCollection

Detailed Description

Definition at line 26 of file SampleDataSource.h.

Member Function Documentation

void SDKSample::FlipViewData::sealed::Add ( SampleDataItem^ item ) [inline]

Definition at line 122 of file SampleDataSource.h.

            {
                itemCollection->Append(item);
                count++;
            }

UINT SDKSample::FlipViewData::sealed::GetCollectionCount ( ) [inline]

Definition at line 133 of file SampleDataSource.h.

            {
                return count;
            }

SampleDataItem SDKSample::FlipViewData::sealed::GetItemAt ( UINT i ) [inline]

Definition at line 128 of file SampleDataSource.h.

            {
                return itemCollection->GetAt(i);
            }

SDKSample::FlipViewData::sealed::ItemCollection ( ) [inline]

Definition at line 117 of file SampleDataSource.h.

                            :count(0)
            {
                itemCollection = ref new Platform::Collections::Vector<SampleDataItem^>();
            };

void SDKSample::FlipViewData::sealed::OnPropertyChanged ( Platform::String^ propertyName ) [inline]

Definition at line 39 of file SampleDataSource.h.

            {
                PropertyChangedEventArgs^ pcea = ref new  PropertyChangedEventArgs(propertyName);
                _PropertyChanged(this,pcea);
            }

SDKSample::FlipViewData::sealed::SampleDataItem | ( | Platform::String^ | title,
 |  | Platform::String^ | type,
 |  | Platform::String^ | picture
 | ) |  |
SDKSample::FlipViewData::sealed::SampleDataSource ( ) [inline]

Definition at line 148 of file SampleDataSource.h.

            {
                _items = ref new Platform::Collections::Vector<Object^>();

                SampleDataItem^ item;
                item = ref new SampleDataItem("Cliff", "item", "Assets/Cliff.jpg");
                _items->Append(item);

                item = ref new SampleDataItem("Grapes", "item", "Assets/Grapes.jpg");
                _items->Append(item);

                item = ref new SampleDataItem("Rainier", "item", "Assets/Rainier.jpg");
                _items->Append(item);

                item = ref new SampleDataItem("Sunset", "item", "Assets/Sunset.jpg");
                _items->Append(item);

                item = ref new SampleDataItem("Valley", "item", "Assets/Valley.jpg");
                _items->Append(item);
            }

Member Data Documentation

Uri SDKSample::FlipViewData::sealed::_baseUri [static]

Definition at line 32 of file SampleDataSource.h.

ImageSource SDKSample::FlipViewData::sealed::_image

Definition at line 31 of file SampleDataSource.h.

Windows::UI::Xaml::Interop::IBindableObservableVector SDKSample::FlipViewData::sealed::_items

Definition at line 145 of file SampleDataSource.h.

Platform::String SDKSample::FlipViewData::sealed::_picture

Definition at line 30 of file SampleDataSource.h.

event PropertyChangedEventHandler SDKSample::FlipViewData::sealed::_PropertyChanged

Definition at line 34 of file SampleDataSource.h.

Platform::String SDKSample::FlipViewData::sealed::_title

Definition at line 28 of file SampleDataSource.h.

Platform::String SDKSample::FlipViewData::sealed::_type

Definition at line 29 of file SampleDataSource.h.

UINT SDKSample::FlipViewData::sealed::count [private]

Definition at line 114 of file SampleDataSource.h.

Windows::Foundation::Collections::IObservableVector<SampleDataItem^> SDKSample::FlipViewData::sealed::itemCollection [private]

Definition at line 113 of file SampleDataSource.h.

The documentation for this class was generated from the following file:
  • XAML FlipView control/C++/SampleDataSource.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FolderEnumeration::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • FolderEnumeration
  • SDKSample::FolderEnumeration::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Static Private Attributes

SDKSample::FolderEnumeration::sealed Class Reference

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

Windows::UI::Xaml::Controls::TextBlock | CreateHeaderTextBlock (Platform::String^contents)
Windows::UI::Xaml::Controls::TextBlock | CreateLineItemTextBlock ()
void | GetFilesButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Platform::String | GetPropertyDisplayValue (Platform::Object^property)

Private Member Functions

Windows::UI::Xaml::Controls::TextBlock | CreateHeaderTextBlock (Platform::String^contents)
Windows::UI::Xaml::Controls::TextBlock | CreateLineItemTextBlock (Platform::String^contents)
void | GetFilesAndFolderButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GroupByHelper (Windows::Storage::Search::QueryOptions^queryOptions)
void | GroupByMonthButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GroupByRatingButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GroupByTagButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Static Private Attributes

static Platform::String | ColorSpaceProperty
static Platform::String | CopyrightProperty

Detailed Description

Definition at line 26 of file Scenario1.xaml.h.

Member Function Documentation

Windows::UI::Xaml::Controls::TextBlock SDKSample::FolderEnumeration::sealed::CreateHeaderTextBlock ( Platform::String^ contents ) [private]
Windows::UI::Xaml::Controls::TextBlock SDKSample::FolderEnumeration::sealed::CreateHeaderTextBlock ( Platform::String^ contents ) [protected]
Windows::UI::Xaml::Controls::TextBlock SDKSample::FolderEnumeration::sealed::CreateLineItemTextBlock ( Platform::String^ contents ) [private]
Windows::UI::Xaml::Controls::TextBlock SDKSample::FolderEnumeration::sealed::CreateLineItemTextBlock ( ) [protected]
void SDKSample::FolderEnumeration::sealed::GetFilesAndFolderButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FolderEnumeration::sealed::GetFilesButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
Platform::String SDKSample::FolderEnumeration::sealed::GetPropertyDisplayValue ( Platform::Object^ property ) [protected]
void SDKSample::FolderEnumeration::sealed::GroupByHelper ( Windows::Storage::Search::QueryOptions^ queryOptions ) [private]
void SDKSample::FolderEnumeration::sealed::GroupByMonthButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FolderEnumeration::sealed::GroupByRatingButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::FolderEnumeration::sealed::GroupByTagButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::FolderEnumeration::sealed::Scenario1 ( )
SDKSample::FolderEnumeration::sealed::Scenario2 ( )
SDKSample::FolderEnumeration::sealed::Scenario3 ( )

Member Data Documentation

Platform::String SDKSample::FolderEnumeration::sealed::ColorSpaceProperty [static, private]

Definition at line 40 of file Scenario3.xaml.h.

Platform::String SDKSample::FolderEnumeration::sealed::CopyrightProperty [static, private]

Definition at line 39 of file Scenario3.xaml.h.

The documentation for this class was generated from the following files:
  • Folder enumeration/C++/Scenario1.xaml.h
  • Folder enumeration/C++/Scenario3.xaml.h
  • Folder enumeration/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::GeolocationCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • GeolocationCPP
  • SDKSample::GeolocationCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::GeolocationCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1_TrackPosition.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CancelGetGeolocation (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetGeolocation (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetGeopositionAsync ()
void | OnCompleted (Windows::ApplicationModel::Background::BackgroundTaskRegistration^sender, Windows::ApplicationModel::Background::BackgroundTaskCompletedEventArgs^e)
void | OnPositionChanged (Windows::Devices::Geolocation::Geolocator^sender, Windows::Devices::Geolocation::PositionChangedEventArgs^e)
void | OnStatusChanged (Windows::Devices::Geolocation::Geolocator^sender, Windows::Devices::Geolocation::StatusChangedEventArgs^e)
void | RegisterBackgroundTask (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartTracking (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopTracking (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UnregisterBackgroundTask (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::Devices::Geolocation::Geolocator | geolocator
Windows::ApplicationModel::Background::BackgroundTaskRegistration | geolocTask
concurrency::cancellation_token_source | geopositionTaskTokenSource
Windows::Foundation::EventRegistrationToken | positionToken
MainPage rootPage
Platform::String | sampleBackgroundTaskEntryPoint
Platform::String | sampleBackgroundTaskName
Windows::Foundation::EventRegistrationToken | statusToken
Windows::Foundation::EventRegistrationToken | taskCompletedToken

Detailed Description

Definition at line 30 of file Scenario1_TrackPosition.xaml.h.

Member Function Documentation

void SDKSample::GeolocationCPP::sealed::CancelGetGeolocation | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GeolocationCPP::sealed::GetGeolocation | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GeolocationCPP::sealed::GetGeopositionAsync ( ) [private]
void SDKSample::GeolocationCPP::sealed::OnCompleted | ( | Windows::ApplicationModel::Background::BackgroundTaskRegistration^ | sender,
 |  | Windows::ApplicationModel::Background::BackgroundTaskCompletedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::GeolocationCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GeolocationCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GeolocationCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GeolocationCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GeolocationCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GeolocationCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::GeolocationCPP::sealed::OnPositionChanged | ( | Windows::Devices::Geolocation::Geolocator^ | sender,
 |  | Windows::Devices::Geolocation::PositionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GeolocationCPP::sealed::OnStatusChanged | ( | Windows::Devices::Geolocation::Geolocator^ | sender,
 |  | Windows::Devices::Geolocation::StatusChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GeolocationCPP::sealed::RegisterBackgroundTask | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::GeolocationCPP::sealed::Scenario1 ( )
SDKSample::GeolocationCPP::sealed::Scenario2 ( )
SDKSample::GeolocationCPP::sealed::Scenario3 ( )
void SDKSample::GeolocationCPP::sealed::StartTracking | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GeolocationCPP::sealed::StopTracking | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GeolocationCPP::sealed::UnregisterBackgroundTask | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Devices::Geolocation::Geolocator sealed::geolocator [private]

Definition at line 41 of file Scenario1_TrackPosition.xaml.h.

Windows::ApplicationModel::Background::BackgroundTaskRegistration SDKSample::GeolocationCPP::sealed::geolocTask [private]

Definition at line 43 of file Scenario3_BackgroundTask.xaml.h.

concurrency::cancellation_token_source sealed::geopositionTaskTokenSource [private]

Definition at line 42 of file Scenario2_GetPosition.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::GeolocationCPP::sealed::positionToken [private]

Definition at line 42 of file Scenario1_TrackPosition.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1_TrackPosition.xaml.h.

Platform::String SDKSample::GeolocationCPP::sealed::sampleBackgroundTaskEntryPoint [private]

Definition at line 42 of file Scenario3_BackgroundTask.xaml.h.

Platform::String SDKSample::GeolocationCPP::sealed::sampleBackgroundTaskName [private]

Definition at line 41 of file Scenario3_BackgroundTask.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::GeolocationCPP::sealed::statusToken [private]

Definition at line 43 of file Scenario1_TrackPosition.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::GeolocationCPP::sealed::taskCompletedToken [private]

Definition at line 44 of file Scenario3_BackgroundTask.xaml.h.

The documentation for this class was generated from the following files:
  • Geolocation/C++/Scenario1_TrackPosition.xaml.h
  • Geolocation/C++/Scenario2_GetPosition.xaml.h
  • Geolocation/C++/Scenario3_BackgroundTask.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::GlobalizationPreferencesSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • GlobalizationPreferencesSample
  • SDKSample::GlobalizationPreferencesSample::sealed
Public Member Functions | Static Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::GlobalizationPreferencesSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame. More...

#include "CurrentInputLanguage.xaml.h"

List of all members.

Public Member Functions

CurrentInputLanguage ()
GeographicRegionScenario ()
LanguageScenario ()
UserPreferences ()

Static Public Member Functions

static Platform::String | VectorViewToString (Windows::Foundation::Collections::IVectorView< Platform::String^>^data)

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Contains common code used by several scenarios of the sample.

Definition at line 30 of file CurrentInputLanguage.xaml.h.

Member Function Documentation

SDKSample::GlobalizationPreferencesSample::sealed::CurrentInputLanguage ( )
void SDKSample::GlobalizationPreferencesSample::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GlobalizationPreferencesSample::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GlobalizationPreferencesSample::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GlobalizationPreferencesSample::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::GlobalizationPreferencesSample::sealed::GeographicRegionScenario ( )
SDKSample::GlobalizationPreferencesSample::sealed::LanguageScenario ( )
virtual void SDKSample::GlobalizationPreferencesSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GlobalizationPreferencesSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GlobalizationPreferencesSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GlobalizationPreferencesSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::GlobalizationPreferencesSample::sealed::UserPreferences ( )
static Platform::String SDKSample::GlobalizationPreferencesSample::sealed::VectorViewToString ( Windows::Foundation::Collections::IVectorView< Platform::String^>^ data ) [static]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file CurrentInputLanguage.xaml.h.

The documentation for this class was generated from the following files:
  • Globalization preferences/C++/CurrentInputLanguage.xaml.h
  • Globalization preferences/C++/GeographicRegion.xaml.h
  • Globalization preferences/C++/Language.xaml.h
  • Globalization preferences/C++/UserPreferences.xaml.h
  • Globalization preferences/C++/Utilities.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::GyrometerCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • GyrometerCPP
  • SDKSample::GyrometerCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::GyrometerCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisplayCurrentReading (Platform::Object^sender, Platform::Object^e)
void | ReadingChanged (Windows::Devices::Sensors::Gyrometer^sender, Windows::Devices::Sensors::GyrometerReadingChangedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)

Private Attributes

uint32 | desiredReportInterval
Windows::UI::Core::CoreDispatcher | dispatcher
Windows::UI::Xaml::DispatcherTimer | dispatcherTimer
Windows::Devices::Sensors::Gyrometer | gyrometer
Windows::Foundation::EventRegistrationToken | readingToken
MainPage rootPage
Windows::Foundation::EventRegistrationToken | visibilityToken

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::GyrometerCPP::sealed::DisplayCurrentReading | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::GyrometerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GyrometerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GyrometerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::GyrometerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::GyrometerCPP::sealed::ReadingChanged | ( | Windows::Devices::Sensors::Gyrometer^ | sender,
 |  | Windows::Devices::Sensors::GyrometerReadingChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::GyrometerCPP::sealed::Scenario1 ( )
SDKSample::GyrometerCPP::sealed::Scenario2 ( )
void SDKSample::GyrometerCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GyrometerCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GyrometerCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GyrometerCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GyrometerCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::GyrometerCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

uint32 sealed::desiredReportInterval [private]

Definition at line 44 of file Scenario1.xaml.h.

Windows::UI::Core::CoreDispatcher SDKSample::GyrometerCPP::sealed::dispatcher [private]

Definition at line 41 of file Scenario2.xaml.h.

Windows::UI::Xaml::DispatcherTimer SDKSample::GyrometerCPP::sealed::dispatcherTimer [private]

Definition at line 45 of file Scenario2.xaml.h.

Windows::Devices::Sensors::Gyrometer sealed::gyrometer [private]

Definition at line 41 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::GyrometerCPP::sealed::readingToken [private]

Definition at line 43 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::visibilityToken [private]

Definition at line 42 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Gyrometer sensor/C++/Scenario1.xaml.h
  • Gyrometer sensor/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Helpers Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::Helpers
Public Types | Static Public Member Functions

SDKSample::Helpers Class Reference

#include "Constants.h"

List of all members.

Public Types

enum | NotifyType { StatusMessage, ErrorMessage }

Static Public Member Functions

static void | ReplaceAll (std::wstring &value, _In_z_ const char16 *from, _In_z_ const char16 *to)
static void | ScenarioCompleted (Windows::UI::Xaml::Controls::Button^startButton, Windows::UI::Xaml::Controls::Button^cancelButton)
static void | ScenarioStarted (Windows::UI::Xaml::Controls::Button^startButton, Windows::UI::Xaml::Controls::Button^cancelButton)
static Platform::String | Trim (Platform::String^s)

Detailed Description

Definition at line 67 of file Constants.h.

Member Enumeration Documentation

enum SDKSample::Helpers::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 111 of file Constants.h.

        {
            StatusMessage,
            ErrorMessage
        };

Member Function Documentation

static void SDKSample::Helpers::ReplaceAll | ( | std::wstring & | value,
 |  | _In_z_ const char16 * | from,
 |  | _In_z_ const char16 * | to |
 | ) |  |  | [inline, static]

Definition at line 100 of file Constants.h.

        {
            auto fromLength = wcslen(from);
            std::wstring::size_type offset;

            for (offset = value.find(from); offset != std::wstring::npos; offset = value.find(from, offset))
            {
                value.replace(offset, fromLength, to);
            }
        }

static void SDKSample::Helpers::ScenarioCompleted | ( | Windows::UI::Xaml::Controls::Button^ | startButton,
 |  | Windows::UI::Xaml::Controls::Button^ | cancelButton |
 | ) |  |  | [inline, static]

Definition at line 76 of file Constants.h.

        {
            startButton->IsEnabled = true;
            cancelButton->IsEnabled = false;
        }

static void SDKSample::Helpers::ScenarioStarted | ( | Windows::UI::Xaml::Controls::Button^ | startButton,
 |  | Windows::UI::Xaml::Controls::Button^ | cancelButton |
 | ) |  |  | [inline, static]

Definition at line 70 of file Constants.h.

        {
            startButton->IsEnabled = false;
            cancelButton->IsEnabled = true;
        }

static Platform::String SDKSample::Helpers::Trim ( Platform::String^ s ) [inline, static]

Definition at line 82 of file Constants.h.

        {
            const char16* first = s->Begin();
            const char16* last = s->End();

            while (first != last && iswspace(*first))
            {
                ++first;
            }

            while (first != last && iswspace(last[-1]))
            {
                --last;
            }

            return ref new Platform::String(first, (int)(last - first));
        }

The documentation for this class was generated from the following file:
  • HttpClient/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::HighContrast::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • HighContrast
  • SDKSample::HighContrast::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::HighContrast::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Accessibility.xaml.h"

List of all members.

Public Member Functions

Accessibility ()
Scenario1 ()
Scenario2 ()
Scenario3 ()
TargetButton ()
UI ()

Protected Member Functions

virtual void | OnApplyTemplate () override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | AccessibilityGetSettings_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoSomething_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UIGetSettings_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Accessibility.xaml.h.

Member Function Documentation

SDKSample::HighContrast::sealed::Accessibility ( )
void SDKSample::HighContrast::sealed::AccessibilityGetSettings_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HighContrast::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HighContrast::sealed::DoSomething_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HighContrast::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::HighContrast::sealed::OnApplyTemplate ( ) [override, protected, virtual]
virtual void SDKSample::HighContrast::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HighContrast::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [protected, virtual]
virtual void SDKSample::HighContrast::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HighContrast::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HighContrast::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HighContrast::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::HighContrast::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::HighContrast::sealed::Scenario1 ( )
SDKSample::HighContrast::sealed::Scenario2 ( )
SDKSample::HighContrast::sealed::Scenario3 ( )
SDKSample::HighContrast::sealed::TargetButton ( )
SDKSample::HighContrast::sealed::UI ( )
void SDKSample::HighContrast::sealed::UIGetSettings_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Accessibility.xaml.h.

The documentation for this class was generated from the following files:
  • UI contrast and settings/C++/Accessibility.xaml.h
  • UI contrast and settings/C++/UI.xaml.h
  • XAML high contrast style/C++/Scenario1.xaml.h
  • XAML high contrast style/C++/Scenario2.xaml.h
  • XAML high contrast style/C++/Scenario3.xaml.h
  • XAML high contrast style/C++/TargetButton.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::HomeGroup::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • HomeGroup
  • SDKSample::HomeGroup::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::HomeGroup::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "HomeGroupAdvancedSearch.xaml.h"

List of all members.

Public Member Functions

HomeGroupAdvancedSearch ()
HomeGroupPicker ()
HomeGroupVideoStream ()
SearchHomeGroup ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetButtons ()

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file HomeGroupAdvancedSearch.xaml.h.

Member Function Documentation

void SDKSample::HomeGroup::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HomeGroup::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HomeGroup::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HomeGroup::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::HomeGroup::sealed::HomeGroupAdvancedSearch ( )
SDKSample::HomeGroup::sealed::HomeGroupPicker ( )
SDKSample::HomeGroup::sealed::HomeGroupVideoStream ( )
virtual void SDKSample::HomeGroup::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HomeGroup::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HomeGroup::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HomeGroup::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::HomeGroup::sealed::SearchHomeGroup ( )
void SDKSample::HomeGroup::sealed::SetButtons ( ) [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file HomeGroupAdvancedSearch.xaml.h.

The documentation for this class was generated from the following files:
  • HomeGroup app/C++/HomeGroupAdvancedSearch.xaml.h
  • HomeGroup app/C++/HomeGroupPickerScenario.xaml.h
  • HomeGroup app/C++/HomeGroupVideoStream.xaml.h
  • HomeGroup app/C++/SearchHomeGroup.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::HttpClientSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • HttpClientSample
  • SDKSample::HttpClientSample::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::HttpClientSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame. More...

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Cancel_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Cancel_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Cancel_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Cancel_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Cancel_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayTextResult (const std::wstring &response, Windows::UI::Xaml::Controls::TextBox^output)
void | DisplayTextResult (const std::wstring &response, Windows::UI::Xaml::Controls::TextBox^output)
void | DisplayTextResult (const std::wstring &response, Windows::UI::Xaml::Controls::TextBox^output)
void | DisplayTextResult (const std::wstring &response, Windows::UI::Xaml::Controls::TextBox^output)
IStream * | GenerateSampleStream (unsigned int size)
concurrency::task< void > | Scenario2ReadData ()
void | Start_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Start_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Start_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Start_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Start_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

concurrency::cancellation_token_source | cancellationTokenSource
Web::HttpRequest httpRequest
Windows::Storage::Streams::IBuffer | readBuffer
MainPage rootPage

Detailed Description

Definition at line 31 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::HttpClientSample::sealed::Cancel_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::Cancel_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::Cancel_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::Cancel_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::Cancel_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::DisplayTextResult | ( | const std::wstring & | response,
 |  | Windows::UI::Xaml::Controls::TextBox^ | output |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::DisplayTextResult | ( | const std::wstring & | response,
 |  | Windows::UI::Xaml::Controls::TextBox^ | output |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::DisplayTextResult | ( | const std::wstring & | response,
 |  | Windows::UI::Xaml::Controls::TextBox^ | output |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::DisplayTextResult | ( | const std::wstring & | response,
 |  | Windows::UI::Xaml::Controls::TextBox^ | output |
 | ) |  |  | [private]
IStream* SDKSample::HttpClientSample::sealed::GenerateSampleStream ( unsigned int size ) [private]
virtual void SDKSample::HttpClientSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HttpClientSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HttpClientSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HttpClientSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::HttpClientSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::HttpClientSample::sealed::Scenario1 ( )
SDKSample::HttpClientSample::sealed::Scenario2 ( )
concurrency::task<void> SDKSample::HttpClientSample::sealed::Scenario2ReadData ( ) [private]
SDKSample::HttpClientSample::sealed::Scenario3 ( )
SDKSample::HttpClientSample::sealed::Scenario4 ( )
SDKSample::HttpClientSample::sealed::Scenario5 ( )
void SDKSample::HttpClientSample::sealed::Start_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::Start_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::Start_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::Start_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::HttpClientSample::sealed::Start_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

concurrency::cancellation_token_source sealed::cancellationTokenSource [private]

Definition at line 42 of file Scenario1.xaml.h.

Web::HttpRequest sealed::httpRequest [private]

Definition at line 41 of file Scenario1.xaml.h.

Windows::Storage::Streams::IBuffer SDKSample::HttpClientSample::sealed::readBuffer [private]

Definition at line 43 of file Scenario2.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • HttpClient/C++/Scenario1.xaml.h
  • HttpClient/C++/Scenario2.xaml.h
  • HttpClient/C++/Scenario3.xaml.h
  • HttpClient/C++/Scenario4.xaml.h
  • HttpClient/C++/Scenario5.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Images::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Images
  • SDKSample::Images::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Images::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Scenario2Button1_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

int | decodePixelHeight
int | decodePixelWidth
MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

virtual void SDKSample::Images::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Images::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Images::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::Images::sealed::Scenario1 ( )
SDKSample::Images::sealed::Scenario2 ( )
void SDKSample::Images::sealed::Scenario2Button1_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Images::sealed::Scenario3 ( )

Member Data Documentation

int SDKSample::Images::sealed::decodePixelHeight [private]

Definition at line 38 of file Scenario2.xaml.h.

int SDKSample::Images::sealed::decodePixelWidth [private]

Definition at line 39 of file Scenario2.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML images/C++/Scenario1.xaml.h
  • XAML images/C++/Scenario2.xaml.h
  • XAML images/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::InclinometerCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • InclinometerCPP
  • SDKSample::InclinometerCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::InclinometerCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisplayCurrentReading (Platform::Object^sender, Platform::Object^e)
void | ReadingChanged (Windows::Devices::Sensors::Inclinometer^sender, Windows::Devices::Sensors::InclinometerReadingChangedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)

Private Attributes

uint32 | desiredReportInterval
Windows::UI::Core::CoreDispatcher | dispatcher
Windows::UI::Xaml::DispatcherTimer | dispatcherTimer
Windows::Devices::Sensors::Inclinometer | inclinometer
Windows::Foundation::EventRegistrationToken | readingToken
MainPage rootPage
Windows::Foundation::EventRegistrationToken | visibilityToken

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::InclinometerCPP::sealed::DisplayCurrentReading | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::InclinometerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::InclinometerCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::InclinometerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::InclinometerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::InclinometerCPP::sealed::ReadingChanged | ( | Windows::Devices::Sensors::Inclinometer^ | sender,
 |  | Windows::Devices::Sensors::InclinometerReadingChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::InclinometerCPP::sealed::Scenario1 ( )
SDKSample::InclinometerCPP::sealed::Scenario2 ( )
void SDKSample::InclinometerCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::InclinometerCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::InclinometerCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::InclinometerCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::InclinometerCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::InclinometerCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

uint32 sealed::desiredReportInterval [private]

Definition at line 44 of file Scenario1.xaml.h.

Windows::UI::Core::CoreDispatcher SDKSample::InclinometerCPP::sealed::dispatcher [private]

Definition at line 41 of file Scenario2.xaml.h.

Windows::UI::Xaml::DispatcherTimer SDKSample::InclinometerCPP::sealed::dispatcherTimer [private]

Definition at line 45 of file Scenario2.xaml.h.

Windows::Devices::Sensors::Inclinometer sealed::inclinometer [private]

Definition at line 41 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::InclinometerCPP::sealed::readingToken [private]

Definition at line 43 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::visibilityToken [private]

Definition at line 42 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Inclinometer sensor/C++/Scenario1.xaml.h
  • Inclinometer sensor/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::IsRemoteSession::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • IsRemoteSession
  • SDKSample::IsRemoteSession::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::IsRemoteSession::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "RemoteSession.xaml.h"

List of all members.

Public Member Functions

RemoteSession ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file RemoteSession.xaml.h.

Member Function Documentation

void SDKSample::IsRemoteSession::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::IsRemoteSession::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::IsRemoteSession::sealed::RemoteSession ( )

Member Data Documentation

MainPage SDKSample::IsRemoteSession::sealed::rootPage [private]

Definition at line 38 of file RemoteSession.xaml.h.

The documentation for this class was generated from the following file:
  • Check if current session is remote/C++/RemoteSession.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::LightSensorCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • LightSensorCPP
  • SDKSample::LightSensorCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::LightSensorCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisplayCurrentReading (Platform::Object^sender, Platform::Object^e)
void | ReadingChanged (Windows::Devices::Sensors::LightSensor^sender, Windows::Devices::Sensors::LightSensorReadingChangedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)

Private Attributes

uint32 | desiredReportInterval
Windows::UI::Core::CoreDispatcher | dispatcher
Windows::UI::Xaml::DispatcherTimer | dispatcherTimer
Windows::Foundation::EventRegistrationToken | readingToken
MainPage rootPage
Windows::Devices::Sensors::LightSensor | sensor
Windows::Foundation::EventRegistrationToken | visibilityToken

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::LightSensorCPP::sealed::DisplayCurrentReading | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::LightSensorCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::LightSensorCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::LightSensorCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::LightSensorCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::LightSensorCPP::sealed::ReadingChanged | ( | Windows::Devices::Sensors::LightSensor^ | sender,
 |  | Windows::Devices::Sensors::LightSensorReadingChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::LightSensorCPP::sealed::Scenario1 ( )
SDKSample::LightSensorCPP::sealed::Scenario2 ( )
void SDKSample::LightSensorCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::LightSensorCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::LightSensorCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::LightSensorCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::LightSensorCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::LightSensorCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

uint32 sealed::desiredReportInterval [private]

Definition at line 44 of file Scenario1.xaml.h.

Windows::UI::Core::CoreDispatcher SDKSample::LightSensorCPP::sealed::dispatcher [private]

Definition at line 41 of file Scenario2.xaml.h.

Windows::UI::Xaml::DispatcherTimer SDKSample::LightSensorCPP::sealed::dispatcherTimer [private]

Definition at line 45 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::LightSensorCPP::sealed::readingToken [private]

Definition at line 43 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

Windows::Devices::Sensors::LightSensor sealed::sensor [private]

Definition at line 41 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::visibilityToken [private]

Definition at line 42 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • LightSensor/C++/Scenario1.xaml.h
  • LightSensor/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ListViewSampleDataSource::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ListViewSampleDataSource
  • SDKSample::ListViewSampleDataSource::sealed
Public Member Functions | Public Attributes

SDKSample::ListViewSampleDataSource::sealed Class Reference

#include "SampleDataSource.h"

List of all members.

Public Member Functions

Item ()
void | OnPropertyChanged (Platform::String^propertyName)
StoreData ()

Public Attributes

Platform::String | _Category
Platform::String | _Content
Platform::String | _Description
ImageSource | _Image
Windows::UI::Xaml::Interop::IBindableObservableVector | _items
Platform::String | _Link
event PropertyChangedEventHandler | _PropertyChanged
Platform::String | _Subtitle
Platform::String | _Title

Detailed Description

Definition at line 27 of file SampleDataSource.h.

Member Function Documentation

SDKSample::ListViewSampleDataSource::sealed::Item ( )
void SDKSample::ListViewSampleDataSource::sealed::OnPropertyChanged ( Platform::String^ propertyName ) [inline]

Definition at line 42 of file SampleDataSource.h.

      {
        PropertyChangedEventArgs^ pcea = ref new  PropertyChangedEventArgs(propertyName);
        _PropertyChanged(this,pcea);
      }

SDKSample::ListViewSampleDataSource::sealed::StoreData ( ) [inline]

Definition at line 162 of file SampleDataSource.h.

      {
        _items = ref new Platform::Collections::Vector<Item^>();
        Windows::Foundation::Uri^ _baseUri = ref new Windows::Foundation::Uri("ms-appx:///");
        Platform::String^ LONG_LOREM_IPSUM = "";//"Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";

        Item^ item;
        item = ref new Item();
        item->Title="Banana Blast Frozen Yogurt";
        item->Subtitle="Maecenas class nam praesent cras aenean mauris aliquam nullam aptent accumsan duis nunc curae donec integer auctor sed congue amet";
        item->SetImage(_baseUri, "SampleData/Images/60Banana.png");
        item->Link = "http://www.adatum.com/";
        item->Category = "Low-fat frozen yogurt";
        item->Description = "Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
        item->Content = LONG_LOREM_IPSUM;
        _items->Append(item);

        item = ref new Item();
        item->Title = "Lavish Lemon Ice";
        item->Subtitle = "Quisque vivamus bibendum cursus dictum dictumst dis aliquam aliquet etiam lectus eleifend fusce libero ante facilisi ligula est";
        item->SetImage(_baseUri, "SampleData/Images/60Lemon.png");
        item->Link = "http://www.adventure-works.com/";
        item->Category = "Sorbet";
        item->Description = "Enim cursus nascetur dictum habitasse hendrerit nec gravida vestibulum pellentesque vestibulum adipiscing iaculis erat consectetuer pellentesque parturient lacinia himenaeos pharetra condimentum non sollicitudin eros dolor vestibulum per lectus pellentesque nibh imperdiet laoreet consectetuer placerat libero malesuada pellentesque fames penatibus ligula scelerisque litora nisi luctus vestibulum nisl ullamcorper sed sem natoque suspendisse felis sit condimentum pulvinar nunc posuere magnis vel scelerisque sagittis porttitor potenti tincidunt mattis ipsum adipiscing sollicitudin parturient mauris nam senectus ullamcorper mollis tristique sociosqu suspendisse ultricies montes sed condimentum dis nostra suscipit justo ornare pretium odio pellentesque lacus lorem torquent orci";
        item->Content = LONG_LOREM_IPSUM;
        _items->Append(item);

        item = ref new Item();
        item->Title = "Marvelous Mint";
        item->Subtitle = "Litora luctus magnis arcu lorem morbi blandit faucibus mattis commodo hac habitant inceptos conubia cubilia nulla mauris diam proin augue eget dolor mollis interdum lobortis";
        item->SetImage(_baseUri, "SampleData/Images/60Mint.png");
        item->Link = "http://www.adventure-works.com/";
        item->Category = "Gelato";
        item->Description = "Vestibulum vestibulum magna scelerisque ultrices consectetuer vehicula rhoncus pellentesque massa adipiscing platea primis sodales parturient metus sollicitudin morbi vestibulum pellentesque consectetuer pellentesque volutpat rutrum sollicitudin sapien pellentesque vestibulum venenatis consectetuer viverra est aliquam semper hac maecenas integer adipiscing sociis vulputate ullamcorper curabitur pellentesque parturient praesent neque sollicitudin pellentesque vestibulum suspendisse consectetuer leo quisque phasellus pede vestibulum quam pellentesque sollicitudin quis mus adipiscing parturient pellentesque vestibulum";
        item->Content = LONG_LOREM_IPSUM;
        _items->Append(item);

        item = ref new Item();
        item->Title = "Creamy Orange";
        item->Subtitle = "Leo mus nec nascetur dapibus non fames per felis ipsum pharetra egestas montes elit nostra placerat euismod enim justo ornare feugiat platea pulvinar sed sagittis";
        item->SetImage(_baseUri, "SampleData/Images/60Orange.png");
        item->Link = "http://www.alpineskihouse.com/";
        item->Category = "Sorbet";
        item->Description = "Consequat condimentum consectetuer vivamus urna vestibulum netus pellentesque cras nec taciti non scelerisque adipiscing parturient tellus sollicitudin per vestibulum pellentesque aliquam convallis ullamcorper nulla porta aliquet accumsan suspendisse duis bibendum nunc condimentum consectetuer pellentesque scelerisque tempor sed dictumst eleifend amet vestibulum sem tempus facilisi ullamcorper adipiscing tortor ante purus parturient sit dignissim vel nam turpis sed sollicitudin elementum arcu vestibulum risus blandit suspendisse faucibus pellentesque commodo dis condimentum consectetuer varius aenean conubia cubilia facilisis velit mauris nullam aptent dapibus habitant";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Succulent Strawberry";
        item->Subtitle = "Senectus sem lacus erat sociosqu eros suscipit primis nibh nisi nisl gravida torquent";
        item->SetImage(_baseUri, "SampleData/Images/60Strawberry.png");
        item->Link = "http://www.baldwinmuseumofscience.com/";
        item->Category = "Sorbet";
        item->Description = "Est auctor inceptos congue interdum egestas scelerisque pellentesque fermentum ullamcorper cursus dictum lectus suspendisse condimentum libero vitae vestibulum lobortis ligula fringilla euismod class scelerisque feugiat habitasse diam litora adipiscing sollicitudin parturient hendrerit curae himenaeos imperdiet ullamcorper suspendisse nascetur hac gravida pharetra eget donec leo mus nec non malesuada vestibulum pellentesque elit penatibus vestibulum per condimentum porttitor sed adipiscing scelerisque ullamcorper etiam iaculis enim tincidunt erat parturient sem vestibulum eros";
        item->Content = LONG_LOREM_IPSUM;
        _items->Append(item);

        item = ref new Item();
        item->Title = "Very Vanilla";
        item->Subtitle = "Ultrices rutrum sapien vehicula semper lorem volutpat sociis sit maecenas praesent taciti magna nunc odio orci vel tellus nam sed accumsan iaculis dis est";
        item->SetImage(_baseUri, "SampleData/Images/60Vanilla.png");
        item->Link = "http://www.blueyonderairlines.com/";
        item->Category = "Ice Cream";
        item->Description = "Consectetuer lacinia vestibulum tristique sit adipiscing laoreet fusce nibh suspendisse natoque placerat pulvinar ultricies condimentum scelerisque nisi ullamcorper nisl parturient vel suspendisse nam venenatis nunc lorem sed dis sagittis pellentesque luctus sollicitudin morbi posuere vestibulum potenti magnis pellentesque vulputate mattis mauris mollis consectetuer pellentesque pretium montes vestibulum condimentum nulla adipiscing sollicitudin scelerisque ullamcorper pellentesque odio orci rhoncus pede sodales suspendisse parturient viverra curabitur proin aliquam integer augue quam condimentum quisque senectus quis urna scelerisque nostra phasellus ullamcorper cras duis suspendisse sociosqu dolor vestibulum condimentum consectetuer vivamus est fames felis suscipit hac";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Creamy Caramel Frozen Yogurt";
        item->Subtitle = "Maecenas class nam praesent cras aenean mauris aliquam nullam aptent accumsan duis nunc curae donec integer auctor sed congue amet";
        item->SetImage(_baseUri, "SampleData/Images/60SauceCaramel.png");
        item->Link = "http://www.adatum.com/";
        item->Category = "Low-fat frozen yogurt";
        item->Description = "Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Chocolate Lovers Frozen Yougurt";
        item->Subtitle = "Quisque vivamus bibendum cursus dictum dictumst dis aliquam aliquet etiam lectus eleifend fusce libero ante facilisi ligula est";
        item->SetImage(_baseUri, "SampleData/Images/60SauceChocolate.png");
        item->Link = "http://www.adventure-works.com/";
        item->Category = "Low-fat frozen yogurt";
        item->Description = "Enim cursus nascetur dictum habitasse hendrerit nec gravida vestibulum pellentesque vestibulum adipiscing iaculis erat consectetuer pellentesque parturient lacinia himenaeos pharetra condimentum non sollicitudin eros dolor vestibulum per lectus pellentesque nibh imperdiet laoreet consectetuer placerat libero malesuada pellentesque fames penatibus ligula scelerisque litora nisi luctus vestibulum nisl ullamcorper sed sem natoque suspendisse felis sit condimentum pulvinar nunc posuere magnis vel scelerisque sagittis porttitor potenti tincidunt mattis ipsum adipiscing sollicitudin parturient mauris nam senectus ullamcorper mollis tristique sociosqu suspendisse ultricies montes sed condimentum dis nostra suscipit justo ornare pretium odio pellentesque lacus lorem torquent orci";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Roma Strawberry";
        item->Subtitle = "Litora luctus magnis arcu lorem morbi blandit faucibus mattis commodo hac habitant inceptos conubia cubilia nulla mauris diam proin augue eget dolor mollis interdum lobortis";
        item->SetImage(_baseUri, "SampleData/Images/60Strawberry.png");
        item->Link = "http://www.adventure-works.com/";
        item->Category = "Gelato";
        item->Description = "Vestibulum vestibulum magna scelerisque ultrices consectetuer vehicula rhoncus pellentesque massa adipiscing platea primis sodales parturient metus sollicitudin morbi vestibulum pellentesque consectetuer pellentesque volutpat rutrum sollicitudin sapien pellentesque vestibulum venenatis consectetuer viverra est aliquam semper hac maecenas integer adipiscing sociis vulputate ullamcorper curabitur pellentesque parturient praesent neque sollicitudin pellentesque vestibulum suspendisse consectetuer leo quisque phasellus pede vestibulum quam pellentesque sollicitudin quis mus adipiscing parturient pellentesque vestibulum";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Italian Rainbow";
        item->Subtitle = "Leo mus nec nascetur dapibus non fames per felis ipsum pharetra egestas montes elit nostra placerat euismod enim justo ornare feugiat platea pulvinar sed sagittis";
        item->SetImage(_baseUri, "SampleData/Images/60SprinklesRainbow.png");
        item->Link = "http://www.alpineskihouse.com/";
        item->Category = "Gelato";
        item->Description = "Consequat condimentum consectetuer vivamus urna vestibulum netus pellentesque cras nec taciti non scelerisque adipiscing parturient tellus sollicitudin per vestibulum pellentesque aliquam convallis ullamcorper nulla porta aliquet accumsan suspendisse duis bibendum nunc condimentum consectetuer pellentesque scelerisque tempor sed dictumst eleifend amet vestibulum sem tempus facilisi ullamcorper adipiscing tortor ante purus parturient sit dignissim vel nam turpis sed sollicitudin elementum arcu vestibulum risus blandit suspendisse faucibus pellentesque commodo dis condimentum consectetuer varius aenean conubia cubilia facilisis velit mauris nullam aptent dapibus habitant";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Straweberry";
        item->Subtitle = "Ultrices rutrum sapien vehicula semper lorem volutpat sociis sit maecenas praesent taciti magna nunc odio orci vel tellus nam sed accumsan iaculis dis est";
        item->SetImage(_baseUri, "SampleData/Images/60Strawberry.png");
        item->Link = "http://www.blueyonderairlines.com/";
        item->Category = "Ice Cream";
        item->Description = "Consectetuer lacinia vestibulum tristique sit adipiscing laoreet fusce nibh suspendisse natoque placerat pulvinar ultricies condimentum scelerisque nisi ullamcorper nisl parturient vel suspendisse nam venenatis nunc lorem sed dis sagittis pellentesque luctus sollicitudin morbi posuere vestibulum potenti magnis pellentesque vulputate mattis mauris mollis consectetuer pellentesque pretium montes vestibulum condimentum nulla adipiscing sollicitudin scelerisque ullamcorper pellentesque odio orci rhoncus pede sodales suspendisse parturient viverra curabitur proin aliquam integer augue quam condimentum quisque senectus quis urna scelerisque nostra phasellus ullamcorper cras duis suspendisse sociosqu dolor vestibulum condimentum consectetuer vivamus est fames felis suscipit hac";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Strawberry Frozen Yogurt";
        item->Subtitle = "Maecenas class nam praesent cras aenean mauris aliquam nullam aptent accumsan duis nunc curae donec integer auctor sed congue amet";
        item->SetImage(_baseUri, "SampleData/Images/60Strawberry.png");
        item->Link = "http://www.adatum.com/";
        item->Category = "Low-fat frozen yogurt";
        item->Description = "Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Bongo Banana";
        item->Subtitle = "Quisque vivamus bibendum cursus dictum dictumst dis aliquam aliquet etiam lectus eleifend fusce libero ante facilisi ligula est";
        item->SetImage(_baseUri, "SampleData/Images/60Banana.png");
        item->Link = "http://www.adventure-works.com/";
        item->Category = "Sorbet";
        item->Description = "Enim cursus nascetur dictum habitasse hendrerit nec gravida vestibulum pellentesque vestibulum adipiscing iaculis erat consectetuer pellentesque parturient lacinia himenaeos pharetra condimentum non sollicitudin eros dolor vestibulum per lectus pellentesque nibh imperdiet laoreet consectetuer placerat libero malesuada pellentesque fames penatibus ligula scelerisque litora nisi luctus vestibulum nisl ullamcorper sed sem natoque suspendisse felis sit condimentum pulvinar nunc posuere magnis vel scelerisque sagittis porttitor potenti tincidunt mattis ipsum adipiscing sollicitudin parturient mauris nam senectus ullamcorper mollis tristique sociosqu suspendisse ultricies montes sed condimentum dis nostra suscipit justo ornare pretium odio pellentesque lacus lorem torquent orci";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Firenze Vanilla";
        item->Subtitle = "Litora luctus magnis arcu lorem morbi blandit faucibus mattis commodo hac habitant inceptos conubia cubilia nulla mauris diam proin augue eget dolor mollis interdum lobortis";
        item->SetImage(_baseUri, "SampleData/Images/60Vanilla.png");
        item->Link = "http://www.adventure-works.com/";
        item->Category = "Gelato";
        item->Description = "Vestibulum vestibulum magna scelerisque ultrices consectetuer vehicula rhoncus pellentesque massa adipiscing platea primis sodales parturient metus sollicitudin morbi vestibulum pellentesque consectetuer pellentesque volutpat rutrum sollicitudin sapien pellentesque vestibulum venenatis consectetuer viverra est aliquam semper hac maecenas integer adipiscing sociis vulputate ullamcorper curabitur pellentesque parturient praesent neque sollicitudin pellentesque vestibulum suspendisse consectetuer leo quisque phasellus pede vestibulum quam pellentesque sollicitudin quis mus adipiscing parturient pellentesque vestibulum";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Choco-wocko";
        item->Subtitle = "Leo mus nec nascetur dapibus non fames per felis ipsum pharetra egestas montes elit nostra placerat euismod enim justo ornare feugiat platea pulvinar sed sagittis";
        item->SetImage(_baseUri, "SampleData/Images/60SauceChocolate.png");
        item->Link = "http://www.alpineskihouse.com/";
        item->Category = "Sorbet";
        item->Description = "Consequat condimentum consectetuer vivamus urna vestibulum netus pellentesque cras nec taciti non scelerisque adipiscing parturient tellus sollicitudin per vestibulum pellentesque aliquam convallis ullamcorper nulla porta aliquet accumsan suspendisse duis bibendum nunc condimentum consectetuer pellentesque scelerisque tempor sed dictumst eleifend amet vestibulum sem tempus facilisi ullamcorper adipiscing tortor ante purus parturient sit dignissim vel nam turpis sed sollicitudin elementum arcu vestibulum risus blandit suspendisse faucibus pellentesque commodo dis condimentum consectetuer varius aenean conubia cubilia facilisis velit mauris nullam aptent dapibus habitant";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

        item = ref new Item();
        item->Title = "Chocolate";
        item->Subtitle = "Ultrices rutrum sapien vehicula semper lorem volutpat sociis sit maecenas praesent taciti magna nunc odio orci vel tellus nam sed accumsan iaculis dis est";
        item->SetImage(_baseUri, "SampleData/Images/60SauceChocolate.png");
        item->Link = "http://www.blueyonderairlines.com/";
        item->Category = "Ice Cream";
        item->Description = "Consectetuer lacinia vestibulum tristique sit adipiscing laoreet fusce nibh suspendisse natoque placerat pulvinar ultricies condimentum scelerisque nisi ullamcorper nisl parturient vel suspendisse nam venenatis nunc lorem sed dis sagittis pellentesque luctus sollicitudin morbi posuere vestibulum potenti magnis pellentesque vulputate mattis mauris mollis consectetuer pellentesque pretium montes vestibulum condimentum nulla adipiscing sollicitudin scelerisque ullamcorper pellentesque odio orci rhoncus pede sodales suspendisse parturient viverra curabitur proin aliquam integer augue quam condimentum quisque senectus quis urna scelerisque nostra phasellus ullamcorper cras duis suspendisse sociosqu dolor vestibulum condimentum consectetuer vivamus est fames felis suscipit hac";
        item->Content = LONG_LOREM_IPSUM;
         _items->Append(item);

      }

Member Data Documentation

Platform::String SDKSample::ListViewSampleDataSource::sealed::_Category

Definition at line 32 of file SampleDataSource.h.

Platform::String SDKSample::ListViewSampleDataSource::sealed::_Content

Definition at line 34 of file SampleDataSource.h.

Platform::String SDKSample::ListViewSampleDataSource::sealed::_Description

Definition at line 33 of file SampleDataSource.h.

ImageSource SDKSample::ListViewSampleDataSource::sealed::_Image

Definition at line 35 of file SampleDataSource.h.

Windows::UI::Xaml::Interop::IBindableObservableVector SDKSample::ListViewSampleDataSource::sealed::_items

Definition at line 159 of file SampleDataSource.h.

Platform::String SDKSample::ListViewSampleDataSource::sealed::_Link

Definition at line 31 of file SampleDataSource.h.

event PropertyChangedEventHandler SDKSample::ListViewSampleDataSource::sealed::_PropertyChanged

Definition at line 36 of file SampleDataSource.h.

Platform::String SDKSample::ListViewSampleDataSource::sealed::_Subtitle

Definition at line 30 of file SampleDataSource.h.

Platform::String SDKSample::ListViewSampleDataSource::sealed::_Title

Definition at line 29 of file SampleDataSource.h.

The documentation for this class was generated from the following file:
  • XAML ListView and GridView essentials/C++/SampleDataSource.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ListViewSimple::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ListViewSimple
  • SDKSample::ListViewSimple::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ListViewSimple::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoSomething_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ItemClickHandler (Platform::Object^sender, Windows::UI::Xaml::Controls::ItemClickEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage
ListViewSampleDataSource::StoreData | storeData

Detailed Description

Definition at line 31 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::ListViewSimple::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ListViewSimple::sealed::DoSomething_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ListViewSimple::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ListViewSimple::sealed::ItemClickHandler | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::ItemClickEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::ListViewSimple::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ListViewSimple::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ListViewSimple::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::ListViewSimple::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ListViewSimple::sealed::Scenario1 ( )
SDKSample::ListViewSimple::sealed::Scenario2 ( )
SDKSample::ListViewSimple::sealed::Scenario3 ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

ListViewSampleDataSource::StoreData sealed::storeData [private]

Definition at line 41 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML ListView and GridView essentials/C++/Scenario1.xaml.h
  • XAML ListView and GridView essentials/C++/Scenario2.xaml.h
  • XAML ListView and GridView essentials/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::MainPage
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::MainPage Class Reference

#include "Constants.h"

List of all members.

Public Member Functions

void | HandleFileNotFoundException (Platform::COMException^e)
void | NotifyUserFileNotExist ()
void | ResetOutput (Windows::UI::Xaml::Controls::Image^image, Windows::UI::Xaml::Controls::TextBlock^output, Windows::UI::Xaml::Controls::TextBlock^outputDetails)
void | ResetScenarioOutput (Windows::UI::Xaml::Controls::TextBlock^textblock)

Static Public Member Functions

static Windows::UI::Color | ConvertIndexToColor (int index)
static void | DisplayResult (Windows::UI::Xaml::Controls::Image^image, Windows::UI::Xaml::Controls::TextBlock^textBlock, Platform::String^thumbnailModeName, size_t size, Windows::Storage::IStorageItem^item, Windows::Storage::FileProperties::StorageItemThumbnail^thumbnail, bool isGroup)
static bool | EnsureUnsnapped ()
static task< Playlist^> | PickPlaylist ()
static Platform::String | ReplaceUrlSearchTerms (Platform::String^strUrl, Platform::String^queryText)

Public Attributes

Windows::Storage::StorageFolder | autoplayFileSystemDeviceFolder
Platform::String | autoplayNonFileSystemDeviceId
Windows::Networking::PushNotifications::PushNotificationChannel | channel
Windows::Foundation::Collections::IVectorView
< Windows::Storage::IStorageItem^> 		fileActivationFiles
PushNotificationsHelper::Notifier | notifier
Windows::Foundation::EventRegistrationToken | token

Static Public Attributes

static int | autoplayScenarioIndex = 3
static const int | SearchPaneMaxSuggestions = 5

Private Member Functions

Windows::UI::Xaml::Media::Imaging::BitmapImage | GetPlaceHolderImage ()
void | Initialize ()
void | ValidateFile (Platform::String^scenarioName)

Private Attributes

Windows::UI::Xaml::Media::Imaging::BitmapImage | _placeholder
Platform::String | falToken
Platform::String | mruToken
Windows::Storage::StorageFile | sampleFile

Static Private Attributes

static Array< String^> | audioExtensionsInner
static Array< String^> | playlistExtensionsInner
static Playlist | playlistInner = nullptr
static Platform::Array< Scenario > | scenariosInner
static Array< Scenario > | scenariosInner

Detailed Description

Definition at line 23 of file Constants.h.

Member Function Documentation

static Windows::UI::Color SDKSample::MainPage::ConvertIndexToColor ( int index ) [inline, static]

Definition at line 26 of file Constants.h.

    {
      // Converts between ComboBox indices and colors
        switch (index)
        {
          case 0:
            return Windows::UI::Colors::Red;
          case 1:
            return Windows::UI::Colors::Green;
          case 2:
            return Windows::UI::Colors::Blue;
          case 3:
            return Windows::UI::Colors::Gray;
          default:
            return Windows::UI::Colors::White;
        }
    }

static void SDKSample::MainPage::DisplayResult | ( | Windows::UI::Xaml::Controls::Image^ | image,
 |  | Windows::UI::Xaml::Controls::TextBlock^ | textBlock,
 |  | Platform::String^ | thumbnailModeName,
 |  | size_t | size,
 |  | Windows::Storage::IStorageItem^ | item,
 |  | Windows::Storage::FileProperties::StorageItemThumbnail^ | thumbnail,
 |  | bool | isGroup |
 | ) |  |  | [static]
bool MainPage::EnsureUnsnapped ( ) [static]

Definition at line 31 of file Constants.cpp.

{
    // FilePicker APIs will not work if the application is in a snapped state. If an app wants to show a FilePicker while snapped,
    // it must attempt to unsnap first.
    return ((ApplicationView::Value != ApplicationViewState::Snapped) || ApplicationView::TryUnsnap());
}

BitmapImage MainPage::GetPlaceHolderImage ( ) [private]

Definition at line 73 of file Constants.cpp.

{
    if (_placeholder == nullptr)
    {
        _placeholder = ref new BitmapImage(ref new Uri(BaseUri->AbsoluteUri, "Assets/placeholder-sdk.png"));
    }

    return _placeholder;
}

void MainPage::HandleFileNotFoundException ( Platform::COMException^ e )

Definition at line 74 of file Constants.cpp.

{
    if (e->HResult == 0x80070002) // Catch FileNotExistException
    {
        NotifyUserFileNotExist();
    }
    else
    {
        throw e;
    }
}

void MainPage::Initialize ( ) [private]

Definition at line 34 of file Constants.cpp.

{
    sampleFile = nullptr;
    mruToken = nullptr;
    falToken = nullptr;
    create_task(KnownFolders::DocumentsLibrary->GetFileAsync(Filename)).then([this](task<StorageFile^> getFileTask)
    {
        try
        {
            sampleFile = getFileTask.get();
        }
        catch (Platform::Exception^)
        {
            // sample file doesn't exist so scenario one must be run first.
        }
    });
}

void MainPage::NotifyUserFileNotExist ( )

Definition at line 69 of file Constants.cpp.

{
    NotifyUser("The file '" + Filename + "' does not exist. Use scenario one to create this file.", NotifyType::ErrorMessage);
}

task< Playlist^> MainPage::PickPlaylist ( ) [static]

Definition at line 54 of file Constants.cpp.

{
    // Pick a file, then load it as a playlist.
    FileOpenPicker^ picker = MainPage::CreateFilePicker(MainPage::playlistExtensions);
    return task<StorageFile^>(picker->PickSingleFileAsync()).then([](StorageFile^ file)
    {
        return Playlist::LoadAsync(file);
    });
}

static Platform::String SDKSample::MainPage::ReplaceUrlSearchTerms | ( | Platform::String^ | strUrl,
 |  | Platform::String^ | queryText |
 | ) |  |  | [static]
void SDKSample::MainPage::ResetOutput | ( | Windows::UI::Xaml::Controls::Image^ | image,
 |  | Windows::UI::Xaml::Controls::TextBlock^ | output,
 |  | Windows::UI::Xaml::Controls::TextBlock^ | outputDetails
 | ) |  |
void SDKSample::MainPage::ResetScenarioOutput ( Windows::UI::Xaml::Controls::TextBlock^ textblock )
void SDKSample::MainPage::ValidateFile ( Platform::String^ scenarioName ) [private]

Member Data Documentation

Windows::UI::Xaml::Media::Imaging::BitmapImage SDKSample::MainPage::_placeholder [private]

Definition at line 74 of file Constants.h.

Array< String^> MainPage::audioExtensionsInner [static, private]
Initial value:
 ref new Array<String^>
{
    L".wma",  L".mp3",  L".mp2",  L".aac", L".adt", L".adts", L".m4a"
}

Definition at line 83 of file Constants.h.

Windows::Storage::StorageFolder SDKSample::MainPage::autoplayFileSystemDeviceFolder

Definition at line 98 of file Constants.h.

Platform::String SDKSample::MainPage::autoplayNonFileSystemDeviceId

Definition at line 102 of file Constants.h.

int MainPage::autoplayScenarioIndex = 3 [static]

Definition at line 89 of file Constants.h.

Windows::Networking::PushNotifications::PushNotificationChannel SDKSample::MainPage::channel

Definition at line 62 of file Constants.h.

Platform::String SDKSample::MainPage::falToken [private]

Definition at line 98 of file Constants.h.

Windows::Foundation::Collections::IVectorView<Windows::Storage::IStorageItem^> SDKSample::MainPage::fileActivationFiles

Definition at line 94 of file Constants.h.

Platform::String SDKSample::MainPage::mruToken [private]

Definition at line 97 of file Constants.h.

PushNotificationsHelper::Notifier SDKSample::MainPage::notifier

Definition at line 64 of file Constants.h.

Array< String^> MainPage::playlistExtensionsInner [static, private]
Initial value:
 ref new Array<String^>
{
    L".m3u", L".wpl", L".zpl"
}

Definition at line 84 of file Constants.h.

Playlist MainPage::playlistInner = nullptr [static, private]

Definition at line 85 of file Constants.h.

Windows::Storage::StorageFile SDKSample::MainPage::sampleFile [private]

Definition at line 96 of file Constants.h.

Platform::Array< Scenario > MainPage::scenariosInner [static, private]
Initial value:
 ref new Platform::Array<Scenario>
{
    { "Accelerometer data events", "SDKSample.AccelerometerCPP.Scenario1" },
    { "Accelerometer shake events", "SDKSample.AccelerometerCPP.Scenario2" },
    { "Poll accelerometer readings", "SDKSample.AccelerometerCPP.Scenario3" }
}

Definition at line 43 of file Constants.h.

Array<Scenario> SDKSample::MainPage::scenariosInner [static, private]

Definition at line 82 of file Constants.h.

const int SDKSample::MainPage::SearchPaneMaxSuggestions = 5 [static]

Definition at line 45 of file Constants.h.

Windows::Foundation::EventRegistrationToken SDKSample::MainPage::token

Definition at line 46 of file Constants.h.

The documentation for this class was generated from the following files:
  • Accelerometer sensor/C++/Constants.h
  • App tiles and badges/C#,C++/Constants.h
  • File access/C++/Constants.h
  • File and folder thumbnail/C++/Constants.h
  • File picker/C++/Constants.h
  • HomeGroup app/C++/Constants.h
  • Lock screen personalization/C++/Constants.h
  • Playlist/C++/Constants.h
  • Portable device API/C++/Constants.h
  • Push and periodic notifications client-side/C++/Constants.h
  • Removable storage/C++/Constants.h
  • Search contract/C++/Constants.h
  • Sharing content source app/C++/Constants.h
  • XAML vector-based drawing/C++/Constants.h
  • Accelerometer sensor/C++/Constants.cpp
  • Animation metrics/C++/Constants.cpp
  • App package information/C++/Constants.cpp
  • App settings/C++/Constants.cpp
  • App tiles and badges/C#,C++/Constants.cpp
  • Application data/C++/Constants.cpp
  • Application resources and localization/C++/Constants.cpp
  • AtomPub/C++/Constants.cpp
  • Background task/C++/BackgroundTask/Constants.cpp
  • Background Transfer/C++/Constants.cpp
  • Bluetooth call control/C++/Constants.cpp
  • Calendar details and math/C++/Constants.cpp
  • CameraCaptureUI/C++/Constants.cpp
  • CameraOptionsUI/C++/Constants.cpp
  • Certificate enrollment/C++/Constants.cpp
  • Check if current session is remote/C++/Constants.cpp
  • Compass sensor/C++/Constants.cpp
  • Compression/C++/Constants.cpp
  • Configure keys for media/C++/Constants.cpp
  • Connecting with WebSockets/C++/Constants.cpp
  • Context menu/C++/Constants.cpp
  • Credential locker/C++/Constants.cpp
  • CryptoWinRT/C++/Constants.cpp
  • Custom driver access/C++/app_cpp/Constants.cpp
  • Date and time formatting/C++/Constants.cpp
  • Device auto rotation preferences/C++/Constants.cpp
  • Device enumeration/C++/Constants.cpp
  • Display orientation/C++/Constants.cpp
  • EAS policies for mail clients/C++/Constants.cpp
  • Extended Linguistic Services (ELS)/C++/Constants.cpp
  • File access/C++/Constants.cpp
  • File and folder thumbnail/C++/Constants.cpp
  • File picker/C++/Constants.cpp
  • File picker contracts/C++/Constants.cpp
  • File picker contracts/C++/MainPage.xaml.cpp
  • Folder enumeration/C++/Constants.cpp
  • Geolocation/C++/Constants.cpp
  • Globalization preferences/C++/Constants.cpp
  • Gyrometer sensor/C++/Constants.cpp
  • HomeGroup app/C++/Constants.cpp
  • HttpClient/C++/Constants.cpp
  • Inclinometer sensor/C++/Constants.cpp
  • Input Device capabilities/C++/Constants.cpp
  • Input Touch keyboard/C++/Constants.cpp
  • Input Touch keyboard text input/C++/Constants.cpp
  • IXmlReader and IXmlWriter XML data readwrite/C++/Constants.cpp
  • LightSensor/C++/Constants.cpp
  • Lock screen personalization/C++/Constants.cpp
  • Media capture using capture device/C++/Constants.cpp
  • Media Play To/C++/Constants.cpp
  • Media Server client/C++/Constants.cpp
  • Message dialog/C++/Constants.cpp
  • Mobile broadband account provisioning/C++/Constants.cpp
  • Network information/C++/Constants.cpp
  • Network status background/C++/NetworkStatusApp/Constants.cpp
  • Number formatting and parsing/C++/Constants.cpp
  • OrientationSensor/C++/Constants.cpp
  • Playback Manager Companion/C++/Constants.cpp
  • Playback Manager msAudioCategory/C++/Constants.cpp
  • Playlist/C++/Constants.cpp
  • PlayToReceiver/C++/Constants.cpp
  • Portable device API/C++/Constants.cpp
  • Programmatic file search/C++/Constants.cpp
  • Push and periodic notifications client-side/C++/Constants.cpp
  • Reading and writing data/C++/Constants.cpp
  • Removable storage/C++/Constants.cpp
  • Scaling according to DPI/C++/Constants.cpp
  • Search contract/C++/Constants.cpp
  • Sharing content source app/C++/Constants.cpp
  • SimpleOrientationSensor/C++/Constants.cpp
  • SMS background task/C++/SmsBackgroundTaskSample/Constants.cpp
  • SMS message send, receive, and SIM management/C++/Constants.cpp
  • Snap/C++/Constants.cpp
  • Splash screen/C++/Constants.cpp
  • Syndication/C++/Constants.cpp
  • Thread pool/C++/Constants.cpp
  • Transcoding media/C++/Constants.cpp
  • Trial app and in-app purchase/C++/Constants.cpp
  • UI contrast and settings/C++/Constants.cpp
  • User domain name/C++/Constants.cpp
  • USSD message management/C++/Constants.cpp
  • Web authentication broker/C++/Constants.cpp
  • Windows account authorization/C++/Constants.cpp
  • Windows Audio Session (WASAPI)/C++/Constants.cpp
  • XAML accessibility/C++/Constants.cpp
  • XAML animation library/C++/Constants.cpp
  • XAML data binding/C++/Constants.cpp
  • XAML FlipView control/C++/Constants.cpp
  • XAML high contrast style/C++/Constants.cpp
  • XAML images/C++/Constants.cpp
  • XAML ListView and GridView essentials/C++/Constants.cpp
  • XAML personality animations/C++/Constants.cpp
  • XAML Popup/C++/Constants.cpp
  • XAML scrolling, panning, and zooming/C++/Constants.cpp
  • XAML text display/C++/Constants.cpp
  • XAML text editing/C++/Constants.cpp
  • XAML two-dimensional transforms/C++/Constants.cpp
  • XAML user and custom controls/C++/Constants.cpp
  • XAML vector-based drawing/C++/Constants.cpp
  • XAML WebView control/C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MediaButtons::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • MediaButtons
  • SDKSample::MediaButtons::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

SDKSample::MediaButtons::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "mediabuttons.xaml.h"

List of all members.

Public Member Functions

mediabuttons ()
Song (StorageFile^file)

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Properties

String | artistInner
String | trackInner

Private Member Functions

void | ChannelDown (Object^sender, Object^e)
void | ChannelUp (Object^sender, Object^e)
void | CreatePlaylist (Windows::Foundation::Collections::IVectorView< StorageFile^>^files)
void | DisplayStatus (Platform::String^text)
void | FastForward (Object^sender, Object^e)
Platform::String | GetTimeStampedMessage (Platform::String^EventCalled)
void | MediaElement_CurrentStateChanged (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | MediaElement_MediaEnded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | MediaElement_MediaOpened (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | NextTrack (Object^sender, Object^e)
void | Pause (Object^sender, Object^e)
void | Play (Object^sender, Object^e)
void | Play_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PlayPause (Object^sender, Object^e)
void | PrevTrack (Object^sender, Object^e)
void | Record (Object^sender, Object^e)
void | Rewind (Object^sender, Object^e)
void | SelectFiles_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetCurrentPlayingAsync (int playlistIndex)
void | SetMediaElementSourceAsync (Song^song)
void | Stop (Object^sender, Object^e)

Private Attributes

int | _currentSongIndex
Windows::UI::Core::CoreDispatcher | _dispatcher
EventRegistrationToken | _nextTrackPressedEventToken
Platform::Collections::Vector
< Song^> 		_playlist
int | _playlistCount
EventRegistrationToken | _prevTrackPressedEventToken
bool | _wasPlaying
bool | IsInitialized
MainPage rootPage

Detailed Description

Definition at line 32 of file mediabuttons.xaml.h.

Member Function Documentation

void SDKSample::MediaButtons::sealed::ChannelDown | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::ChannelUp | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::CreatePlaylist ( Windows::Foundation::Collections::IVectorView< StorageFile^>^ files ) [private]
void SDKSample::MediaButtons::sealed::DisplayStatus ( Platform::String^ text ) [private]
void SDKSample::MediaButtons::sealed::FastForward | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
Platform::String SDKSample::MediaButtons::sealed::GetTimeStampedMessage ( Platform::String^ EventCalled ) [private]
SDKSample::MediaButtons::sealed::mediabuttons ( )
void SDKSample::MediaButtons::sealed::MediaElement_CurrentStateChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::MediaElement_MediaEnded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::MediaElement_MediaOpened | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::NextTrack | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::MediaButtons::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::MediaButtons::sealed::Pause | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::Play | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::Play_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::PlayPause | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::PrevTrack | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::Record | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::Rewind | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::SelectFiles_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaButtons::sealed::SetCurrentPlayingAsync ( int playlistIndex ) [private]
void SDKSample::MediaButtons::sealed::SetMediaElementSourceAsync ( Song^ song ) [private]
SDKSample::MediaButtons::sealed::Song ( StorageFile^ file ) [inline]

Definition at line 35 of file mediabuttons.xaml.h.

            {
                fileInner = file;
            }

void SDKSample::MediaButtons::sealed::Stop | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]

Member Data Documentation

int SDKSample::MediaButtons::sealed::_currentSongIndex [private]

Definition at line 112 of file mediabuttons.xaml.h.

Windows::UI::Core::CoreDispatcher SDKSample::MediaButtons::sealed::_dispatcher [private]

Definition at line 109 of file mediabuttons.xaml.h.

EventRegistrationToken SDKSample::MediaButtons::sealed::_nextTrackPressedEventToken [private]

Definition at line 114 of file mediabuttons.xaml.h.

Platform::Collections::Vector<Song^> SDKSample::MediaButtons::sealed::_playlist [private]

Definition at line 116 of file mediabuttons.xaml.h.

int SDKSample::MediaButtons::sealed::_playlistCount [private]

Definition at line 113 of file mediabuttons.xaml.h.

EventRegistrationToken SDKSample::MediaButtons::sealed::_prevTrackPressedEventToken [private]

Definition at line 115 of file mediabuttons.xaml.h.

bool SDKSample::MediaButtons::sealed::_wasPlaying [private]

Definition at line 111 of file mediabuttons.xaml.h.

bool SDKSample::MediaButtons::sealed::IsInitialized [private]

Definition at line 108 of file mediabuttons.xaml.h.

MainPage SDKSample::MediaButtons::sealed::rootPage [private]

Definition at line 81 of file mediabuttons.xaml.h.

Property Documentation

String SDKSample::MediaButtons::sealed::artistInner

Definition at line 63 of file mediabuttons.xaml.h.

String SDKSample::MediaButtons::sealed::trackInner

Definition at line 65 of file mediabuttons.xaml.h.

The documentation for this class was generated from the following file:
  • Configure keys for media/C++/mediabuttons.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MediaCapture::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • MediaCapture
  • SDKSample::MediaCapture::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::MediaCapture::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "AdvancedCapture.xaml.h"

List of all members.

Public Member Functions

AdvancedCapture ()
AudioCapture ()
BasicCapture ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | AddEffectToImageStream ()
void | btnStartDevice_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartDevice_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartDevice_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartPreview_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartPreview_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartPreview_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartStopRecord_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartStopRecord_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartStopRecord_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnTakePhoto_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnTakePhoto_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | chkAddRemoveEffect_Checked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | chkAddRemoveEffect_Unchecked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayProperties_OrientationChanged (Platform::Object^sender)
void | EnableButton (bool enabled, Platform::String^name)
void | EnableButton (bool enabled, Platform::String^name)
void | EnableButton (bool enabled, Platform::String^name)
void | EnumerateWebcamsAsync ()
void | Failed (Windows::Media::Capture::MediaCapture^mediaCapture, Windows::Media::Capture::MediaCaptureFailedEventArgs^args)
void | Failed (Windows::Media::Capture::MediaCapture^mediaCapture, Windows::Media::Capture::MediaCaptureFailedEventArgs^args)
void | Failed (Windows::Media::Capture::MediaCapture^mediaCapture, Windows::Media::Capture::MediaCaptureFailedEventArgs^args)
Windows::Storage::FileProperties::PhotoOrientation | GetCurrentPhotoRotation ()
void | lstEnumedDevices_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
Windows::Storage::FileProperties::PhotoOrientation | PhotoRotationLookup (Windows::Graphics::Display::DisplayOrientations displayOrientation, bool counterclockwise)
void | PrepareForVideoRecording ()
void | RecordLimitationExceeded (Windows::Media::Capture::MediaCapture^mediaCapture)
void | RecordLimitationExceeded (Windows::Media::Capture::MediaCapture^mediaCapture)
void | RecordLimitationExceeded (Windows::Media::Capture::MediaCapture^mediaCapture)
task
< Windows::Storage::StorageFile^> 		ReencodePhotoAsync (Windows::Storage::StorageFile^tempStorageFile, Windows::Storage::FileProperties::PhotoOrientation photoRotation)
void | Resuming (Object^sender, Object^e)
void | ScenarioInit ()
void | ScenarioInit ()
void | ScenarioInit ()
void | ScenarioReset ()
void | ScenarioReset ()
void | ScenarioReset ()
void | SetupVideoDeviceControl (Windows::Media::Devices::MediaDeviceControl^videoDeviceControl, Slider^slider)
void | ShowExceptionMessage (Platform::Exception^ex)
void | ShowExceptionMessage (Platform::Exception^ex)
void | ShowExceptionMessage (Platform::Exception^ex)
void | ShowStatusMessage (Platform::String^text)
void | ShowStatusMessage (Platform::String^text)
void | ShowStatusMessage (Platform::String^text)
void | sldBrightness_ValueChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | sldContrast_ValueChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | SoundLevelChanged (Object^sender, Object^e)
void | SoundLevelChanged (Object^sender, Object^e)
void | SoundLevelChanged (Object^sender, Object^e)
void | Suspending (Object^sender, Windows::ApplicationModel::SuspendingEventArgs^e)
void | SwitchRecordButtonContent ()
void | SwitchRecordButtonContent ()
void | SwitchRecordButtonContent ()
Windows::Media::Capture::VideoRotation | VideoRotationLookup (Windows::Graphics::Display::DisplayOrientations displayOrientation, bool counterclockwise)

Private Attributes

bool | m_bEffectAdded
bool | m_bEffectAddedToPhoto
bool | m_bEffectAddedToRecord
bool | m_bPreviewing
bool | m_bRecording
bool | m_bReversePreviewRotation
bool | m_bRotateVideoOnOrientationChange
bool | m_bSuspended
bool | m_currentScenarioLoaded
DeviceInformationCollection | m_devInfoCollection
Windows::Foundation::EventRegistrationToken | m_eventRegistrationToken
Platform::Agile
< Windows::Media::Capture::MediaCapture > 		m_mediaCaptureMgr
Windows::Foundation::EventRegistrationToken | m_orientationChangedEventToken
Windows::Storage::StorageFile | m_photoStorageFile
Windows::Storage::StorageFile | m_recordStorageFile
Windows::UI::Xaml::WindowVisibilityChangedEventHandler | m_visbilityHandler
MainPage rootPage

Detailed Description

Definition at line 38 of file AdvancedCapture.xaml.h.

Member Function Documentation

void SDKSample::MediaCapture::sealed::AddEffectToImageStream ( ) [private]
SDKSample::MediaCapture::sealed::AdvancedCapture ( )
SDKSample::MediaCapture::sealed::AudioCapture ( )
SDKSample::MediaCapture::sealed::BasicCapture ( )
void SDKSample::MediaCapture::sealed::btnStartDevice_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnStartDevice_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnStartDevice_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnStartPreview_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnStartPreview_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnStartPreview_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnStartStopRecord_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnStartStopRecord_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnStartStopRecord_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnTakePhoto_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::btnTakePhoto_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::chkAddRemoveEffect_Checked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::chkAddRemoveEffect_Unchecked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::DisplayProperties_OrientationChanged ( Platform::Object^ sender ) [private]
void SDKSample::MediaCapture::sealed::EnableButton | ( | bool | enabled,
 |  | Platform::String^ | name |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::EnableButton | ( | bool | enabled,
 |  | Platform::String^ | name |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::EnableButton | ( | bool | enabled,
 |  | Platform::String^ | name |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::EnumerateWebcamsAsync ( ) [private]
void SDKSample::MediaCapture::sealed::Failed | ( | Windows::Media::Capture::MediaCapture^ | mediaCapture,
 |  | Windows::Media::Capture::MediaCaptureFailedEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::Failed | ( | Windows::Media::Capture::MediaCapture^ | mediaCapture,
 |  | Windows::Media::Capture::MediaCaptureFailedEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::Failed | ( | Windows::Media::Capture::MediaCapture^ | mediaCapture,
 |  | Windows::Media::Capture::MediaCaptureFailedEventArgs^ | args |
 | ) |  |  | [private]
Windows::Storage::FileProperties::PhotoOrientation SDKSample::MediaCapture::sealed::GetCurrentPhotoRotation ( ) [private]
void SDKSample::MediaCapture::sealed::lstEnumedDevices_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::MediaCapture::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::MediaCapture::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::MediaCapture::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::MediaCapture::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::MediaCapture::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::MediaCapture::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
Windows::Storage::FileProperties::PhotoOrientation SDKSample::MediaCapture::sealed::PhotoRotationLookup | ( | Windows::Graphics::Display::DisplayOrientations | displayOrientation,
 |  | bool | counterclockwise |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::PrepareForVideoRecording ( ) [private]
void SDKSample::MediaCapture::sealed::RecordLimitationExceeded ( Windows::Media::Capture::MediaCapture^ mediaCapture ) [private]
void SDKSample::MediaCapture::sealed::RecordLimitationExceeded ( Windows::Media::Capture::MediaCapture^ mediaCapture ) [private]
void SDKSample::MediaCapture::sealed::RecordLimitationExceeded ( Windows::Media::Capture::MediaCapture^ mediaCapture ) [private]
task<Windows::Storage::StorageFile^> SDKSample::MediaCapture::sealed::ReencodePhotoAsync | ( | Windows::Storage::StorageFile^ | tempStorageFile,
 |  | Windows::Storage::FileProperties::PhotoOrientation | photoRotation |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::Resuming | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::ScenarioInit ( ) [private]
void SDKSample::MediaCapture::sealed::ScenarioInit ( ) [private]
void SDKSample::MediaCapture::sealed::ScenarioInit ( ) [private]
void SDKSample::MediaCapture::sealed::ScenarioReset ( ) [private]
void SDKSample::MediaCapture::sealed::ScenarioReset ( ) [private]
void SDKSample::MediaCapture::sealed::ScenarioReset ( ) [private]
void SDKSample::MediaCapture::sealed::SetupVideoDeviceControl | ( | Windows::Media::Devices::MediaDeviceControl^ | videoDeviceControl,
 |  | Slider^ | slider |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::ShowExceptionMessage ( Platform::Exception^ ex ) [private]
void SDKSample::MediaCapture::sealed::ShowExceptionMessage ( Platform::Exception^ ex ) [private]
void SDKSample::MediaCapture::sealed::ShowExceptionMessage ( Platform::Exception^ ex ) [private]
void SDKSample::MediaCapture::sealed::ShowStatusMessage ( Platform::String^ text ) [private]
void SDKSample::MediaCapture::sealed::ShowStatusMessage ( Platform::String^ text ) [private]
void SDKSample::MediaCapture::sealed::ShowStatusMessage ( Platform::String^ text ) [private]
void SDKSample::MediaCapture::sealed::sldBrightness_ValueChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::sldContrast_ValueChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::SoundLevelChanged | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::SoundLevelChanged | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::SoundLevelChanged | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::Suspending | ( | Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaCapture::sealed::SwitchRecordButtonContent ( ) [private]
void SDKSample::MediaCapture::sealed::SwitchRecordButtonContent ( ) [private]
void SDKSample::MediaCapture::sealed::SwitchRecordButtonContent ( ) [private]
Windows::Media::Capture::VideoRotation SDKSample::MediaCapture::sealed::VideoRotationLookup | ( | Windows::Graphics::Display::DisplayOrientations | displayOrientation,
 |  | bool | counterclockwise |
 | ) |  |  | [private]

Member Data Documentation

bool sealed::m_bEffectAdded [private]

Definition at line 91 of file AdvancedCapture.xaml.h.

bool SDKSample::MediaCapture::sealed::m_bEffectAddedToPhoto [private]

Definition at line 93 of file AdvancedCapture.xaml.h.

bool SDKSample::MediaCapture::sealed::m_bEffectAddedToRecord [private]

Definition at line 92 of file AdvancedCapture.xaml.h.

bool sealed::m_bPreviewing [private]

Definition at line 95 of file AdvancedCapture.xaml.h.

bool sealed::m_bRecording [private]

Definition at line 90 of file AdvancedCapture.xaml.h.

bool SDKSample::MediaCapture::sealed::m_bReversePreviewRotation [private]

Definition at line 99 of file AdvancedCapture.xaml.h.

bool SDKSample::MediaCapture::sealed::m_bRotateVideoOnOrientationChange [private]

Definition at line 98 of file AdvancedCapture.xaml.h.

bool sealed::m_bSuspended [private]

Definition at line 94 of file AdvancedCapture.xaml.h.

bool SDKSample::MediaCapture::sealed::m_currentScenarioLoaded [private]

Definition at line 85 of file BasicCapture.xaml.h.

DeviceInformationCollection SDKSample::MediaCapture::sealed::m_devInfoCollection [private]

Definition at line 96 of file AdvancedCapture.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::m_eventRegistrationToken [private]

Definition at line 97 of file AdvancedCapture.xaml.h.

Platform::Agile< Windows::Media::Capture::MediaCapture > sealed::m_mediaCaptureMgr [private]

Definition at line 88 of file AdvancedCapture.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::MediaCapture::sealed::m_orientationChangedEventToken [private]

Definition at line 100 of file AdvancedCapture.xaml.h.

Windows::Storage::StorageFile sealed::m_photoStorageFile [private]

Definition at line 63 of file AudioCapture.xaml.h.

Windows::Storage::StorageFile sealed::m_recordStorageFile [private]

Definition at line 89 of file AdvancedCapture.xaml.h.

Windows::UI::Xaml::WindowVisibilityChangedEventHandler SDKSample::MediaCapture::sealed::m_visbilityHandler [private]

Definition at line 83 of file BasicCapture.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 48 of file AdvancedCapture.xaml.h.

The documentation for this class was generated from the following files:
  • Media capture using capture device/C++/AdvancedCapture.xaml.h
  • Media capture using capture device/C++/AudioCapture.xaml.h
  • Media capture using capture device/C++/BasicCapture.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MediaServerClient::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • MediaServerClient
  • SDKSample::MediaServerClient::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::MediaServerClient::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "LocateVideo.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | dmsRefreshButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | dmsSelect_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | InitializeMediaServers ()
void | LoadMediaFiles ()
void | localVideo_CurrentStateChanged (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | localVideo_MediaFailed (Platform::Object^sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^e)
void | mediaSelect_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Private Attributes

StorageFile | mediaFile
IVectorView< StorageFile^> | mediaFiles
IVectorView< StorageFolder^> | mediaServers
IRandomAccessStream | mediaStream
MainPage rootPage

Detailed Description

Definition at line 34 of file LocateVideo.xaml.h.

Member Function Documentation

void SDKSample::MediaServerClient::sealed::dmsRefreshButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaServerClient::sealed::dmsSelect_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaServerClient::sealed::InitializeMediaServers ( ) [private]
void SDKSample::MediaServerClient::sealed::LoadMediaFiles ( ) [private]
void SDKSample::MediaServerClient::sealed::localVideo_CurrentStateChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaServerClient::sealed::localVideo_MediaFailed | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::ExceptionRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MediaServerClient::sealed::mediaSelect_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::MediaServerClient::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::MediaServerClient::sealed::Scenario1 ( )

Member Data Documentation

StorageFile SDKSample::MediaServerClient::sealed::mediaFile [private]

Definition at line 49 of file LocateVideo.xaml.h.

IVectorView<StorageFile^> SDKSample::MediaServerClient::sealed::mediaFiles [private]

Definition at line 48 of file LocateVideo.xaml.h.

IVectorView<StorageFolder^> SDKSample::MediaServerClient::sealed::mediaServers [private]

Definition at line 47 of file LocateVideo.xaml.h.

IRandomAccessStream SDKSample::MediaServerClient::sealed::mediaStream [private]

Definition at line 50 of file LocateVideo.xaml.h.

MainPage SDKSample::MediaServerClient::sealed::rootPage [private]

Definition at line 42 of file LocateVideo.xaml.h.

The documentation for this class was generated from the following file:
  • Media Server client/C++/LocateVideo.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MessageDialogSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • MessageDialogSample
  • SDKSample::MessageDialogSample::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::MessageDialogSample::sealed Class Reference

#include "CancelCommand.xaml.h"

List of all members.

Public Member Functions

CancelCommand ()
CompletedCallback ()
CustomCommand ()
DefaultCloseCommand ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CancelCommandButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CommandInvokedHandler (Windows::UI::Popups::IUICommand^command)
void | CompletedCallbackButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CustomCommandButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DefaultCloseCommandButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 27 of file CancelCommand.xaml.h.

Member Function Documentation

SDKSample::MessageDialogSample::sealed::CancelCommand ( )
void SDKSample::MessageDialogSample::sealed::CancelCommandButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MessageDialogSample::sealed::CommandInvokedHandler ( Windows::UI::Popups::IUICommand^ command ) [private]
SDKSample::MessageDialogSample::sealed::CompletedCallback ( )
void SDKSample::MessageDialogSample::sealed::CompletedCallbackButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::MessageDialogSample::sealed::CustomCommand ( )
void SDKSample::MessageDialogSample::sealed::CustomCommandButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::MessageDialogSample::sealed::DefaultCloseCommand ( )
void SDKSample::MessageDialogSample::sealed::DefaultCloseCommandButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::MessageDialogSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::MessageDialogSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::MessageDialogSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::MessageDialogSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 35 of file CancelCommand.xaml.h.

The documentation for this class was generated from the following files:
  • Message dialog/C++/CancelCommand.xaml.h
  • Message dialog/C++/CompletedCallback.xaml.h
  • Message dialog/C++/CustomCommand.xaml.h
  • Message dialog/C++/DefaultCloseCommand.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MicrosoftAccount::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • MicrosoftAccount
  • SDKSample::MicrosoftAccount::sealed
Public Member Functions | Private Member Functions | Private Attributes

SDKSample::MicrosoftAccount::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "DelegationTickets.xaml.h"

List of all members.

Public Member Functions

DelegationTickets ()

Private Member Functions

void | SignInButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SignOutButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Platform::String | accessTicket
Windows::Security::Authentication::OnlineId::OnlineIdAuthenticator | authenticator
concurrency::cancellation_token_source | cancellationTokenSource
Web::HttpRequest httpRequest
MainPage rootPage

Detailed Description

Definition at line 33 of file DelegationTickets.xaml.h.

Member Function Documentation

SDKSample::MicrosoftAccount::sealed::DelegationTickets ( )
void SDKSample::MicrosoftAccount::sealed::SignInButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::MicrosoftAccount::sealed::SignOutButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Platform::String SDKSample::MicrosoftAccount::sealed::accessTicket [private]

Definition at line 75 of file DelegationTickets.xaml.h.

Windows::Security::Authentication::OnlineId::OnlineIdAuthenticator SDKSample::MicrosoftAccount::sealed::authenticator [private]

Definition at line 69 of file DelegationTickets.xaml.h.

concurrency::cancellation_token_source SDKSample::MicrosoftAccount::sealed::cancellationTokenSource [private]

Definition at line 77 of file DelegationTickets.xaml.h.

Web::HttpRequest SDKSample::MicrosoftAccount::sealed::httpRequest [private]

Definition at line 76 of file DelegationTickets.xaml.h.

MainPage SDKSample::MicrosoftAccount::sealed::rootPage [private]

Definition at line 74 of file DelegationTickets.xaml.h.

The documentation for this class was generated from the following file:
  • Windows account authorization/C++/DelegationTickets.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::NetworkInformationApi::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • NetworkInformationApi
  • SDKSample::NetworkInformationApi::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::NetworkInformationApi::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "ConnectionProfileList.xaml.h"

List of all members.

Public Member Functions

ConnectionProfileList ()
InternetConnectionProfile ()
LanId ()
NetworkStatusChange ()
ProfileLocalUsageData ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ConnectionProfileList_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayLanIdentifierData (LanIdentifier^lanIdentifier)
String | GetConnectionCostInfo (Windows::Networking::Connectivity::ConnectionCost^connectionCost)
String | GetConnectionCostInfo (Windows::Networking::Connectivity::ConnectionCost^connectionCost)
String | GetConnectionCostInfo (Windows::Networking::Connectivity::ConnectionCost^connectionCost)
String | GetConnectionProfile (Windows::Networking::Connectivity::ConnectionProfile^connectionProfile)
String | GetConnectionProfile (Windows::Networking::Connectivity::ConnectionProfile^connectionProfile)
String | GetConnectionProfile (Windows::Networking::Connectivity::ConnectionProfile^connectionProfile)
String | GetCostBasedSuggestions (Windows::Networking::Connectivity::ConnectionCost^connectionCost)
String | GetCostBasedSuggestions (Windows::Networking::Connectivity::ConnectionCost^connectionCost)
String | GetCostBasedSuggestions (Windows::Networking::Connectivity::ConnectionCost^connectionCost)
String | GetDataPlanStatusInfo (Windows::Networking::Connectivity::DataPlanStatus^dataPlan)
String | GetDataPlanStatusInfo (Windows::Networking::Connectivity::DataPlanStatus^dataPlan)
String | GetDataPlanStatusInfo (Windows::Networking::Connectivity::DataPlanStatus^dataPlan)
String | GetNetworkSecuritySettingsInfo (Windows::Networking::Connectivity::NetworkSecuritySettings^netSecuritySettings)
String | GetNetworkSecuritySettingsInfo (Windows::Networking::Connectivity::NetworkSecuritySettings^netSecuritySettings)
String | GetNetworkSecuritySettingsInfo (Windows::Networking::Connectivity::NetworkSecuritySettings^netSecuritySettings)
void | InternetConnectionProfile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LanId_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | NetworkStatusChange_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnNetworkStatusChange (Object^sender)
void | ProfileLocalUsageData_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UnRegisterForNetworkStatusChangeNotif ()

Private Attributes

String | connectionProfileInfo
Windows::Foundation::EventRegistrationToken | cookie
String | internetProfileInfo
String | lanIdInfo
Windows::Networking::Connectivity::NetworkInformation | networkInfo
Windows::Networking::Connectivity::NetworkStatusChangedEventHandler | networkStatusCallback
bool | registeredNetworkStatusNotif
MainPage rootPage

Detailed Description

Definition at line 39 of file ConnectionProfileList.xaml.h.

Member Function Documentation

SDKSample::NetworkInformationApi::sealed::ConnectionProfileList ( )
void SDKSample::NetworkInformationApi::sealed::ConnectionProfileList_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::NetworkInformationApi::sealed::DisplayLanIdentifierData ( LanIdentifier^ lanIdentifier ) [private]
String SDKSample::NetworkInformationApi::sealed::GetConnectionCostInfo ( Windows::Networking::Connectivity::ConnectionCost^ connectionCost ) [private]
String SDKSample::NetworkInformationApi::sealed::GetConnectionCostInfo ( Windows::Networking::Connectivity::ConnectionCost^ connectionCost ) [private]
String SDKSample::NetworkInformationApi::sealed::GetConnectionCostInfo ( Windows::Networking::Connectivity::ConnectionCost^ connectionCost ) [private]
String SDKSample::NetworkInformationApi::sealed::GetConnectionProfile ( Windows::Networking::Connectivity::ConnectionProfile^ connectionProfile ) [private]
String SDKSample::NetworkInformationApi::sealed::GetConnectionProfile ( Windows::Networking::Connectivity::ConnectionProfile^ connectionProfile ) [private]
String SDKSample::NetworkInformationApi::sealed::GetConnectionProfile ( Windows::Networking::Connectivity::ConnectionProfile^ connectionProfile ) [private]
String SDKSample::NetworkInformationApi::sealed::GetCostBasedSuggestions ( Windows::Networking::Connectivity::ConnectionCost^ connectionCost ) [private]
String SDKSample::NetworkInformationApi::sealed::GetCostBasedSuggestions ( Windows::Networking::Connectivity::ConnectionCost^ connectionCost ) [private]
String SDKSample::NetworkInformationApi::sealed::GetCostBasedSuggestions ( Windows::Networking::Connectivity::ConnectionCost^ connectionCost ) [private]
String SDKSample::NetworkInformationApi::sealed::GetDataPlanStatusInfo ( Windows::Networking::Connectivity::DataPlanStatus^ dataPlan ) [private]
String SDKSample::NetworkInformationApi::sealed::GetDataPlanStatusInfo ( Windows::Networking::Connectivity::DataPlanStatus^ dataPlan ) [private]
String SDKSample::NetworkInformationApi::sealed::GetDataPlanStatusInfo ( Windows::Networking::Connectivity::DataPlanStatus^ dataPlan ) [private]
String SDKSample::NetworkInformationApi::sealed::GetNetworkSecuritySettingsInfo ( Windows::Networking::Connectivity::NetworkSecuritySettings^ netSecuritySettings ) [private]
String SDKSample::NetworkInformationApi::sealed::GetNetworkSecuritySettingsInfo ( Windows::Networking::Connectivity::NetworkSecuritySettings^ netSecuritySettings ) [private]
String SDKSample::NetworkInformationApi::sealed::GetNetworkSecuritySettingsInfo ( Windows::Networking::Connectivity::NetworkSecuritySettings^ netSecuritySettings ) [private]
SDKSample::NetworkInformationApi::sealed::InternetConnectionProfile ( )
void SDKSample::NetworkInformationApi::sealed::InternetConnectionProfile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::NetworkInformationApi::sealed::LanId ( )
void SDKSample::NetworkInformationApi::sealed::LanId_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::NetworkInformationApi::sealed::NetworkStatusChange ( )
void SDKSample::NetworkInformationApi::sealed::NetworkStatusChange_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::NetworkInformationApi::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::NetworkInformationApi::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::NetworkInformationApi::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::NetworkInformationApi::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::NetworkInformationApi::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::NetworkInformationApi::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::NetworkInformationApi::sealed::OnNetworkStatusChange ( Object^ sender ) [private]
SDKSample::NetworkInformationApi::sealed::ProfileLocalUsageData ( )
void SDKSample::NetworkInformationApi::sealed::ProfileLocalUsageData_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::NetworkInformationApi::sealed::UnRegisterForNetworkStatusChangeNotif ( ) [private]

Member Data Documentation

String SDKSample::NetworkInformationApi::sealed::connectionProfileInfo [private]

Definition at line 51 of file ConnectionProfileList.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::NetworkInformationApi::sealed::cookie [private]

Definition at line 50 of file NetworkStatusChange.xaml.h.

String SDKSample::NetworkInformationApi::sealed::internetProfileInfo [private]

Definition at line 51 of file NetworkStatusChange.xaml.h.

String SDKSample::NetworkInformationApi::sealed::lanIdInfo [private]

Definition at line 48 of file LanId.xaml.h.

Windows::Networking::Connectivity::NetworkInformation sealed::networkInfo [private]

Definition at line 50 of file ConnectionProfileList.xaml.h.

Windows::Networking::Connectivity::NetworkStatusChangedEventHandler SDKSample::NetworkInformationApi::sealed::networkStatusCallback [private]

Definition at line 53 of file NetworkStatusChange.xaml.h.

bool SDKSample::NetworkInformationApi::sealed::registeredNetworkStatusNotif [private]

Definition at line 49 of file NetworkStatusChange.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 47 of file ConnectionProfileList.xaml.h.

The documentation for this class was generated from the following files:
  • Network information/C++/ConnectionProfileList.xaml.h
  • Network information/C++/InternetConnectionProfile.xaml.h
  • Network information/C++/LanId.xaml.h
  • Network information/C++/NetworkStatusChange.xaml.h
  • Network information/C++/ProfileLocalUsageData.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::NumberFormatting::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • NumberFormatting
  • SDKSample::NumberFormatting::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::NumberFormatting::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "CurrencyFormatting.xaml.h"

List of all members.

Public Member Functions

CurrencyFormatting ()
DecimalFormatting ()
NumberParsing ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Display_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file CurrencyFormatting.xaml.h.

Member Function Documentation

SDKSample::NumberFormatting::sealed::CurrencyFormatting ( )
SDKSample::NumberFormatting::sealed::DecimalFormatting ( )
void SDKSample::NumberFormatting::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::NumberFormatting::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::NumberFormatting::sealed::Display_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::NumberFormatting::sealed::NumberParsing ( )
virtual void SDKSample::NumberFormatting::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::NumberFormatting::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::NumberFormatting::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file CurrencyFormatting.xaml.h.

The documentation for this class was generated from the following files:
  • Number formatting and parsing/C++/CurrencyFormatting.xaml.h
  • Number formatting and parsing/C++/DecimalFormatting.xaml.h
  • Number formatting and parsing/C++/NumberParsing.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::OrientationSensorCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • OrientationSensorCPP
  • SDKSample::OrientationSensorCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::OrientationSensorCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisplayCurrentReading (Platform::Object^sender, Platform::Object^e)
void | ReadingChanged (Windows::Devices::Sensors::OrientationSensor^sender, Windows::Devices::Sensors::OrientationSensorReadingChangedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)

Private Attributes

uint32 | desiredReportInterval
Windows::UI::Core::CoreDispatcher | dispatcher
Windows::UI::Xaml::DispatcherTimer | dispatcherTimer
Windows::Foundation::EventRegistrationToken | readingToken
MainPage rootPage
Windows::Devices::Sensors::OrientationSensor | sensor
Windows::Foundation::EventRegistrationToken | visibilityToken

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::OrientationSensorCPP::sealed::DisplayCurrentReading | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::OrientationSensorCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::OrientationSensorCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::OrientationSensorCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::OrientationSensorCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::OrientationSensorCPP::sealed::ReadingChanged | ( | Windows::Devices::Sensors::OrientationSensor^ | sender,
 |  | Windows::Devices::Sensors::OrientationSensorReadingChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::OrientationSensorCPP::sealed::Scenario1 ( )
SDKSample::OrientationSensorCPP::sealed::Scenario2 ( )
void SDKSample::OrientationSensorCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::OrientationSensorCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::OrientationSensorCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::OrientationSensorCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::OrientationSensorCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::OrientationSensorCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

uint32 sealed::desiredReportInterval [private]

Definition at line 44 of file Scenario1.xaml.h.

Windows::UI::Core::CoreDispatcher SDKSample::OrientationSensorCPP::sealed::dispatcher [private]

Definition at line 41 of file Scenario2.xaml.h.

Windows::UI::Xaml::DispatcherTimer SDKSample::OrientationSensorCPP::sealed::dispatcherTimer [private]

Definition at line 45 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::OrientationSensorCPP::sealed::readingToken [private]

Definition at line 43 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

Windows::Devices::Sensors::OrientationSensor sealed::sensor [private]

Definition at line 41 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::visibilityToken [private]

Definition at line 42 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • OrientationSensor/C++/Scenario1.xaml.h
  • OrientationSensor/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PackageSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PackageSample
  • SDKSample::PackageSample::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::PackageSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

Platform::String | ArchitectureString (Windows::System::ProcessorArchitecture architecture)
void | GetDependencies_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetInstalledLocation_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetPackage_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Platform::String | VersionString (Windows::ApplicationModel::PackageVersion version)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

Platform::String SDKSample::PackageSample::sealed::ArchitectureString ( Windows::System::ProcessorArchitecture architecture ) [private]
void SDKSample::PackageSample::sealed::GetDependencies_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PackageSample::sealed::GetInstalledLocation_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PackageSample::sealed::GetPackage_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::PackageSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PackageSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PackageSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::PackageSample::sealed::Scenario1 ( )
SDKSample::PackageSample::sealed::Scenario2 ( )
SDKSample::PackageSample::sealed::Scenario3 ( )
Platform::String SDKSample::PackageSample::sealed::VersionString ( Windows::ApplicationModel::PackageVersion version ) [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • App package information/C++/Scenario1.xaml.h
  • App package information/C++/Scenario2.xaml.h
  • App package information/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PasswordVaultCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PasswordVaultCPP
  • SDKSample::PasswordVaultCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::PasswordVaultCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ChangeUser_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ChangeUser_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ChangeUser_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoSomething_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Windows::Foundation::IAsyncAction | InitializeVaultAsync ()
void | Launch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Launch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Launch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Reset_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Reset_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Reset_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioButtonDelete_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SelectResource_Click (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | SelectUser_Click (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | SelectUser_Click (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Signin_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Signin_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Signin_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WelcomeMessage_TextChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::TextChangedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::PasswordVaultCPP::sealed::ChangeUser_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::ChangeUser_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::ChangeUser_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::DoSomething_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Windows::Foundation::IAsyncAction SDKSample::PasswordVaultCPP::sealed::InitializeVaultAsync ( ) [private]
void SDKSample::PasswordVaultCPP::sealed::Launch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Launch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Launch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::PasswordVaultCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PasswordVaultCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PasswordVaultCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PasswordVaultCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::PasswordVaultCPP::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Reset_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Reset_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Reset_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::PasswordVaultCPP::sealed::Scenario1 ( )
SDKSample::PasswordVaultCPP::sealed::Scenario2 ( )
SDKSample::PasswordVaultCPP::sealed::Scenario3 ( )
SDKSample::PasswordVaultCPP::sealed::Scenario4 ( )
void SDKSample::PasswordVaultCPP::sealed::ScenarioButtonDelete_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::SelectResource_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::SelectUser_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::SelectUser_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Signin_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Signin_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::Signin_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PasswordVaultCPP::sealed::WelcomeMessage_TextChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::TextChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Credential locker/C++/Scenario1.xaml.h
  • Credential locker/C++/Scenario2.xaml.h
  • Credential locker/C++/Scenario3.xaml.h
  • Credential locker/C++/Scenario4.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PersonalityAnimations::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PersonalityAnimations
  • SDKSample::PersonalityAnimations::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::PersonalityAnimations::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Page1.xaml.h"

List of all members.

Public Member Functions

Page1 ()
Page2 ()
Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | PopInClick (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PopOutClick (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario3_ClickHandler1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario3_ClickHandler2 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Member Functions

void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MessageData | messageData
MainPage rootPage

Detailed Description

Definition at line 20 of file Page1.xaml.h.

Member Function Documentation

void SDKSample::PersonalityAnimations::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::PersonalityAnimations::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PersonalityAnimations::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PersonalityAnimations::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PersonalityAnimations::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::PersonalityAnimations::sealed::Page1 ( )
SDKSample::PersonalityAnimations::sealed::Page2 ( )
void SDKSample::PersonalityAnimations::sealed::PopInClick | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::PersonalityAnimations::sealed::PopOutClick | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
SDKSample::PersonalityAnimations::sealed::Scenario1 ( )
SDKSample::PersonalityAnimations::sealed::Scenario2 ( )
SDKSample::PersonalityAnimations::sealed::Scenario3 ( )
void SDKSample::PersonalityAnimations::sealed::Scenario3_ClickHandler1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::PersonalityAnimations::sealed::Scenario3_ClickHandler2 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]

Member Data Documentation

MessageData sealed::messageData [private]

Definition at line 29 of file Page1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML personality animations/C++/Page1.xaml.h
  • XAML personality animations/C++/Page2.xaml.h
  • XAML personality animations/C++/Scenario1.xaml.h
  • XAML personality animations/C++/Scenario2.xaml.h
  • XAML personality animations/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Personalization::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Personalization
  • SDKSample::Personalization::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Personalization::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "SetLockscreenImage.xaml.h"

List of all members.

Public Member Functions

SetLockscreenImage ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | PickAndSetButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file SetLockscreenImage.xaml.h.

Member Function Documentation

virtual void SDKSample::Personalization::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Personalization::sealed::PickAndSetButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Personalization::sealed::SetLockscreenImage ( )

Member Data Documentation

MainPage SDKSample::Personalization::sealed::rootPage [private]

Definition at line 39 of file SetLockscreenImage.xaml.h.

The documentation for this class was generated from the following file:
  • Lock screen personalization/C++/SetLockscreenImage.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PlaybackManager2::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PlaybackManager2
  • SDKSample::PlaybackManager2::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::PlaybackManager2::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "PlaybackControl.xaml.h"

List of all members.

Public Member Functions

void | Pause ()
void | Play ()
PlaybackControl ()
void | SelectFile ()
void | SetAudioCategory (Windows::UI::Xaml::Media::AudioCategory category)
void | SetAudioDeviceType (Windows::UI::Xaml::Media::AudioDeviceType devicetype)
void | Stop ()
StreamTypeAlert ()
StreamTypeCommunications ()
StreamTypeMedia ()
StreamTypeOther ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | AppMuted ()
void | AppUnmuted ()
void | Button_Pause_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Button_Play_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Button_Stop_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayStatus (Platform::String^text)
Platform::String | GetTimeStampedMessage (Platform::String^EventCalled)
void | MediaControl_PausePressed (Platform::Object^sender, Platform::Object^e)
void | MediaControl_PlayPauseTogglePressed (Platform::Object^sender, Platform::Object^e)
void | MediaControl_PlayPressed (Platform::Object^sender, Platform::Object^e)
void | MediaControl_SoundLevelChanged (Platform::Object^sender, Platform::Object^e)
void | MediaControl_StopPressed (Platform::Object^sender, Platform::Object^e)
Platform::String | SoundLevelToString (Windows::Media::SoundLevel level)

Private Attributes

Playback | _playback
Platform::Agile
< Windows::UI::Core::CoreWindow > 		cw
bool | IsPlaying
MainPage rootPage

Static Private Attributes

static bool | IsRegistered
static
Windows::Foundation::EventRegistrationToken 		PausePressedToken
static
Windows::Foundation::EventRegistrationToken 		PlayPauseTogglePressedToken
static
Windows::Foundation::EventRegistrationToken 		PlayPressedToken
static
Windows::Foundation::EventRegistrationToken 		SoundLevelChangedToken
static
Windows::Foundation::EventRegistrationToken 		StopPressedToken

Detailed Description

Definition at line 31 of file PlaybackControl.xaml.h.

Member Function Documentation

void SDKSample::PlaybackManager2::sealed::AppMuted ( ) [private]
void SDKSample::PlaybackManager2::sealed::AppUnmuted ( ) [private]
void SDKSample::PlaybackManager2::sealed::Button_Pause_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::Button_Play_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::Button_Stop_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::DisplayStatus ( Platform::String^ text ) [private]
Platform::String SDKSample::PlaybackManager2::sealed::GetTimeStampedMessage ( Platform::String^ EventCalled ) [private]
void SDKSample::PlaybackManager2::sealed::MediaControl_PausePressed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::MediaControl_PlayPauseTogglePressed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::MediaControl_PlayPressed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::MediaControl_SoundLevelChanged | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager2::sealed::MediaControl_StopPressed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::PlaybackManager2::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PlaybackManager2::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PlaybackManager2::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PlaybackManager2::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::PlaybackManager2::sealed::Pause ( )
void SDKSample::PlaybackManager2::sealed::Play ( )
SDKSample::PlaybackManager2::sealed::PlaybackControl ( )
void SDKSample::PlaybackManager2::sealed::SelectFile ( )
void SDKSample::PlaybackManager2::sealed::SetAudioCategory ( Windows::UI::Xaml::Media::AudioCategory category )
void SDKSample::PlaybackManager2::sealed::SetAudioDeviceType ( Windows::UI::Xaml::Media::AudioDeviceType devicetype )
Platform::String SDKSample::PlaybackManager2::sealed::SoundLevelToString ( Windows::Media::SoundLevel level ) [private]
void SDKSample::PlaybackManager2::sealed::Stop ( )
SDKSample::PlaybackManager2::sealed::StreamTypeAlert ( )
SDKSample::PlaybackManager2::sealed::StreamTypeCommunications ( )
SDKSample::PlaybackManager2::sealed::StreamTypeMedia ( )
SDKSample::PlaybackManager2::sealed::StreamTypeOther ( )

Member Data Documentation

Playback SDKSample::PlaybackManager2::sealed::_playback [private]

Definition at line 40 of file StreamTypeMedia.xaml.h.

Platform::Agile<Windows::UI::Core::CoreWindow> SDKSample::PlaybackManager2::sealed::cw [private]

Definition at line 59 of file PlaybackControl.xaml.h.

bool SDKSample::PlaybackManager2::sealed::IsPlaying [private]

Definition at line 58 of file PlaybackControl.xaml.h.

bool SDKSample::PlaybackManager2::sealed::IsRegistered [static, private]

Definition at line 61 of file PlaybackControl.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager2::sealed::PausePressedToken [static, private]

Definition at line 65 of file PlaybackControl.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager2::sealed::PlayPauseTogglePressedToken [static, private]

Definition at line 63 of file PlaybackControl.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager2::sealed::PlayPressedToken [static, private]

Definition at line 64 of file PlaybackControl.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 39 of file StreamTypeAlert.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager2::sealed::SoundLevelChangedToken [static, private]

Definition at line 62 of file PlaybackControl.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager2::sealed::StopPressedToken [static, private]

Definition at line 66 of file PlaybackControl.xaml.h.

The documentation for this class was generated from the following files:
  • Playback Manager Companion/C++/PlaybackControl.xaml.h
  • Playback Manager Companion/C++/StreamTypeAlert.xaml.h
  • Playback Manager Companion/C++/StreamTypeCommunications.xaml.h
  • Playback Manager Companion/C++/StreamTypeMedia.xaml.h
  • Playback Manager Companion/C++/StreamTypeOther.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PlaybackManager::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PlaybackManager
  • SDKSample::PlaybackManager::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::PlaybackManager::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "PlaybackControl.xaml.h"

List of all members.

Public Member Functions

void | Pause ()
void | Play ()
PlaybackControl ()
void | SelectFile ()
void | SetAudioCategory (Windows::UI::Xaml::Media::AudioCategory category)
void | SetAudioDeviceType (Windows::UI::Xaml::Media::AudioDeviceType devicetype)
void | Stop ()
StreamTypeAlert ()
StreamTypeMedia ()
StreamTypeOther ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | AppMuted ()
void | AppUnmuted ()
void | Button_Pause_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Button_Play_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Button_Stop_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayStatus (Platform::String^text)
Platform::String | GetTimeStampedMessage (Platform::String^EventCalled)
void | MediaControl_PausePressed (Platform::Object^sender, Platform::Object^e)
void | MediaControl_PlayPauseTogglePressed (Platform::Object^sender, Platform::Object^e)
void | MediaControl_PlayPressed (Platform::Object^sender, Platform::Object^e)
void | MediaControl_SoundLevelChanged (Platform::Object^sender, Platform::Object^e)
void | MediaControl_StopPressed (Platform::Object^sender, Platform::Object^e)
Platform::String | SoundLevelToString (Windows::Media::SoundLevel level)

Private Attributes

Playback | _playback
Platform::Agile
< Windows::UI::Core::CoreWindow > 		cw
bool | IsPlaying
MainPage rootPage

Static Private Attributes

static bool | IsRegistered
static
Windows::Foundation::EventRegistrationToken 		PausePressedToken
static
Windows::Foundation::EventRegistrationToken 		PlayPauseTogglePressedToken
static
Windows::Foundation::EventRegistrationToken 		PlayPressedToken
static
Windows::Foundation::EventRegistrationToken 		SoundLevelChangedToken
static
Windows::Foundation::EventRegistrationToken 		StopPressedToken

Detailed Description

Definition at line 31 of file PlaybackControl.xaml.h.

Member Function Documentation

void SDKSample::PlaybackManager::sealed::AppMuted ( ) [private]
void SDKSample::PlaybackManager::sealed::AppUnmuted ( ) [private]
void SDKSample::PlaybackManager::sealed::Button_Pause_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::Button_Play_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::Button_Stop_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::DisplayStatus ( Platform::String^ text ) [private]
Platform::String SDKSample::PlaybackManager::sealed::GetTimeStampedMessage ( Platform::String^ EventCalled ) [private]
void SDKSample::PlaybackManager::sealed::MediaControl_PausePressed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::MediaControl_PlayPauseTogglePressed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::MediaControl_PlayPressed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::MediaControl_SoundLevelChanged | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlaybackManager::sealed::MediaControl_StopPressed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
virtual void SDKSample::PlaybackManager::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PlaybackManager::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PlaybackManager::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::PlaybackManager::sealed::Pause ( )
void SDKSample::PlaybackManager::sealed::Play ( )
SDKSample::PlaybackManager::sealed::PlaybackControl ( )
void SDKSample::PlaybackManager::sealed::SelectFile ( )
void SDKSample::PlaybackManager::sealed::SetAudioCategory ( Windows::UI::Xaml::Media::AudioCategory category )
void SDKSample::PlaybackManager::sealed::SetAudioDeviceType ( Windows::UI::Xaml::Media::AudioDeviceType devicetype )
Platform::String SDKSample::PlaybackManager::sealed::SoundLevelToString ( Windows::Media::SoundLevel level ) [private]
void SDKSample::PlaybackManager::sealed::Stop ( )
SDKSample::PlaybackManager::sealed::StreamTypeAlert ( )
SDKSample::PlaybackManager::sealed::StreamTypeMedia ( )
SDKSample::PlaybackManager::sealed::StreamTypeOther ( )

Member Data Documentation

Playback SDKSample::PlaybackManager::sealed::_playback [private]

Definition at line 40 of file StreamTypeMedia.xaml.h.

Platform::Agile<Windows::UI::Core::CoreWindow> SDKSample::PlaybackManager::sealed::cw [private]

Definition at line 59 of file PlaybackControl.xaml.h.

bool SDKSample::PlaybackManager::sealed::IsPlaying [private]

Definition at line 58 of file PlaybackControl.xaml.h.

bool SDKSample::PlaybackManager::sealed::IsRegistered [static, private]

Definition at line 61 of file PlaybackControl.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager::sealed::PausePressedToken [static, private]

Definition at line 65 of file PlaybackControl.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager::sealed::PlayPauseTogglePressedToken [static, private]

Definition at line 63 of file PlaybackControl.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager::sealed::PlayPressedToken [static, private]

Definition at line 64 of file PlaybackControl.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 39 of file StreamTypeAlert.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager::sealed::SoundLevelChangedToken [static, private]

Definition at line 62 of file PlaybackControl.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlaybackManager::sealed::StopPressedToken [static, private]

Definition at line 66 of file PlaybackControl.xaml.h.

The documentation for this class was generated from the following files:
  • Playback Manager msAudioCategory/C++/PlaybackControl.xaml.h
  • Playback Manager msAudioCategory/C++/StreamTypeAlert.xaml.h
  • Playback Manager msAudioCategory/C++/StreamTypeMedia.xaml.h
  • Playback Manager msAudioCategory/C++/StreamTypeOther.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Playlists::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Playlists
  • SDKSample::Playlists::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Playlists::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Add.xaml.h"

List of all members.

Public Member Functions

Add ()
Clear ()
Create ()
Display ()
Remove ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | PickAudioButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickAudioButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickPlaylistButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickPlaylistButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickPlaylistButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickPlaylistButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Add.xaml.h.

Member Function Documentation

SDKSample::Playlists::sealed::Add ( )
SDKSample::Playlists::sealed::Clear ( )
SDKSample::Playlists::sealed::Create ( )
SDKSample::Playlists::sealed::Display ( )
virtual void SDKSample::Playlists::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Playlists::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Playlists::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Playlists::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Playlists::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Playlists::sealed::PickAudioButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Playlists::sealed::PickAudioButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Playlists::sealed::PickPlaylistButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Playlists::sealed::PickPlaylistButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Playlists::sealed::PickPlaylistButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Playlists::sealed::PickPlaylistButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Playlists::sealed::Remove ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Add.xaml.h.

The documentation for this class was generated from the following files:
  • Playlist/C++/Add.xaml.h
  • Playlist/C++/Clear.xaml.h
  • Playlist/C++/Create.xaml.h
  • Playlist/C++/Display.xaml.h
  • Playlist/C++/Remove.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PlayTo::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PlayTo
  • SDKSample::PlayTo::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::PlayTo::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | nextItem_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | pauseButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | pauseSlideshow_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | playButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Playlist_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | playListPlayNext ()
void | playlistTimer_Tick (Platform::Object^sender, Platform::Object^e)
void | playSlideshow_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | playToManager_SourceRequested (Windows::Media::PlayTo::PlayToManager^sender, Windows::Media::PlayTo::PlayToSourceRequestedEventArgs^e)
void | playToManager_SourceRequested (Windows::Media::PlayTo::PlayToManager^sender, Windows::Media::PlayTo::PlayToSourceRequestedEventArgs^e)
void | previousItem_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | videoFile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | webContent_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::UI::Core::CoreDispatcher | dispatcher
Windows::Storage::StorageFile | localFile
Windows::UI::Xaml::DispatcherTimer | playlistTimer
Windows::Media::PlayTo::PlayToManager | playToManager
MainPage rootPage
Windows::Foundation::EventRegistrationToken | sourceRequestedToken
Windows::Foundation::EventRegistrationToken | timerTickToken

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::PlayTo::sealed::nextItem_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::PlayTo::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PlayTo::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PlayTo::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PlayTo::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::PlayTo::sealed::pauseButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::pauseSlideshow_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::playButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::Playlist_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::playListPlayNext ( ) [private]
void SDKSample::PlayTo::sealed::playlistTimer_Tick | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::playSlideshow_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::playToManager_SourceRequested | ( | Windows::Media::PlayTo::PlayToManager^ | sender,
 |  | Windows::Media::PlayTo::PlayToSourceRequestedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::playToManager_SourceRequested | ( | Windows::Media::PlayTo::PlayToManager^ | sender,
 |  | Windows::Media::PlayTo::PlayToSourceRequestedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::previousItem_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::PlayTo::sealed::Scenario1 ( )
SDKSample::PlayTo::sealed::Scenario2 ( )
void SDKSample::PlayTo::sealed::videoFile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayTo::sealed::webContent_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::UI::Core::CoreDispatcher sealed::dispatcher [private]

Definition at line 40 of file Scenario1.xaml.h.

Windows::Storage::StorageFile SDKSample::PlayTo::sealed::localFile [private]

Definition at line 42 of file Scenario1.xaml.h.

Windows::UI::Xaml::DispatcherTimer SDKSample::PlayTo::sealed::playlistTimer [private]

Definition at line 41 of file Scenario2.xaml.h.

Windows::Media::PlayTo::PlayToManager sealed::playToManager [private]

Definition at line 41 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 39 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::sourceRequestedToken [private]

Definition at line 43 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::PlayTo::sealed::timerTickToken [private]

Definition at line 44 of file Scenario2.xaml.h.

The documentation for this class was generated from the following files:
  • Media Play To/C++/Scenario1.xaml.h
  • Media Play To/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PlayToreceiver::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PlayToreceiver
  • SDKSample::PlayToreceiver::sealed
Public Member Functions | Protected Member Functions | Private Types | Private Member Functions | Private Attributes

SDKSample::PlayToreceiver::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "audiovideoptr.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Types

enum | MediaType { None, Image, AudioVisual }

Private Member Functions

void | btmapImage_ImageOpened (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | dmrImage_ImageFailed_1 (Platform::Object^sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^e)
void | dmrVideo_CurrentStateChanged (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | dmrVideo_DownloadProgressChanged_1 (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | dmrVideo_MediaEnded (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | dmrVideo_MediaFailed (Platform::Object^sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^e)
void | dmrVideo_MediaOpened (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | dmrVideo_RateChanged (Platform::Object^sender, Windows::UI::Xaml::Media::RateChangedRoutedEventArgs^e)
void | dmrVideo_SeekCompleted (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | dmrVideo_VolumeChanged (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InitialisePlayToReceiver ()
void | receiver_CurrentTimeChangeRequested (PlayToReceiver^, CurrentTimeChangeRequestedEventArgs^)
void | receiver_MuteChangeRequested (PlayToReceiver^, MuteChangeRequestedEventArgs^)
void | receiver_PauseRequested (PlayToReceiver^, Object^)
void | receiver_PlaybackRateChangeRequested (PlayToReceiver^, PlaybackRateChangeRequestedEventArgs^)
void | receiver_PlayRequested (PlayToReceiver^, Object^)
void | receiver_SourceChangeRequested (PlayToReceiver^, SourceChangeRequestedEventArgs^)
void | receiver_StopRequested (PlayToReceiver^, Object^)
void | receiver_TimeUpdateRequested (PlayToReceiver^, Object^)
void | receiver_VolumeChangeRequestedEvent (PlayToReceiver^, VolumeChangeRequestedEventArgs^)
void | startPlayToReceiver (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | stopPlayToReceiver (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

double | bufferedPlaybackRate
MediaType currentType
BitmapImage | imageRecd
bool | IsMediaJustLoaded
bool | IsPlayReceivedPreMediaLoaded
bool | IsReceiverStarted
bool | IsSeeking
Platform::Agile
< Windows::Media::PlayTo::PlayToReceiver > 		receiver
MainPage rootPage

Detailed Description

Definition at line 31 of file audiovideoptr.xaml.h.

Member Enumeration Documentation

enum SDKSample::PlayToreceiver::sealed::MediaType [private]
Enumerator:
None
Image
AudioVisual

Definition at line 46 of file audiovideoptr.xaml.h.

{ None, Image, AudioVisual};

Member Function Documentation

void SDKSample::PlayToreceiver::sealed::btmapImage_ImageOpened | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrImage_ImageFailed_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::ExceptionRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrVideo_CurrentStateChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrVideo_DownloadProgressChanged_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrVideo_MediaEnded | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrVideo_MediaFailed | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::ExceptionRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrVideo_MediaOpened | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrVideo_RateChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Media::RateChangedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrVideo_SeekCompleted | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::dmrVideo_VolumeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::InitialisePlayToReceiver ( ) [private]
virtual void SDKSample::PlayToreceiver::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::PlayToreceiver::sealed::receiver_CurrentTimeChangeRequested | ( | PlayToReceiver^ | ,
 |  | CurrentTimeChangeRequestedEventArgs^ |  |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::receiver_MuteChangeRequested | ( | PlayToReceiver^ | ,
 |  | MuteChangeRequestedEventArgs^ |  |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::receiver_PauseRequested | ( | PlayToReceiver^ | ,
 |  | Object^ |  |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::receiver_PlaybackRateChangeRequested | ( | PlayToReceiver^ | ,
 |  | PlaybackRateChangeRequestedEventArgs^ |  |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::receiver_PlayRequested | ( | PlayToReceiver^ | ,
 |  | Object^ |  |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::receiver_SourceChangeRequested | ( | PlayToReceiver^ | ,
 |  | SourceChangeRequestedEventArgs^ |  |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::receiver_StopRequested | ( | PlayToReceiver^ | ,
 |  | Object^ |  |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::receiver_TimeUpdateRequested | ( | PlayToReceiver^ | ,
 |  | Object^ |  |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::receiver_VolumeChangeRequestedEvent | ( | PlayToReceiver^ | ,
 |  | VolumeChangeRequestedEventArgs^ |  |
 | ) |  |  | [private]
SDKSample::PlayToreceiver::sealed::Scenario1 ( )
void SDKSample::PlayToreceiver::sealed::startPlayToReceiver | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PlayToreceiver::sealed::stopPlayToReceiver | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

double SDKSample::PlayToreceiver::sealed::bufferedPlaybackRate [private]

Definition at line 45 of file audiovideoptr.xaml.h.

MediaType SDKSample::PlayToreceiver::sealed::currentType [private]

Definition at line 47 of file audiovideoptr.xaml.h.

BitmapImage SDKSample::PlayToreceiver::sealed::imageRecd [private]

Definition at line 48 of file audiovideoptr.xaml.h.

bool SDKSample::PlayToreceiver::sealed::IsMediaJustLoaded [private]

Definition at line 43 of file audiovideoptr.xaml.h.

bool SDKSample::PlayToreceiver::sealed::IsPlayReceivedPreMediaLoaded [private]

Definition at line 44 of file audiovideoptr.xaml.h.

bool SDKSample::PlayToreceiver::sealed::IsReceiverStarted [private]

Definition at line 41 of file audiovideoptr.xaml.h.

bool SDKSample::PlayToreceiver::sealed::IsSeeking [private]

Definition at line 42 of file audiovideoptr.xaml.h.

Platform::Agile<Windows::Media::PlayTo::PlayToReceiver> SDKSample::PlayToreceiver::sealed::receiver [private]

Definition at line 40 of file audiovideoptr.xaml.h.

MainPage SDKSample::PlayToreceiver::sealed::rootPage [private]

Definition at line 39 of file audiovideoptr.xaml.h.

The documentation for this class was generated from the following file:
  • PlayToReceiver/C++/audiovideoptr.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PortableDeviceCPP::EventCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PortableDeviceCPP
  • SDKSample::PortableDeviceCPP::EventCallback
Public Member Functions | Private Attributes

SDKSample::PortableDeviceCPP::EventCallback Class Reference

#include "EventCallback.h"

List of all members.

Public Member Functions

EventCallback (EventReceived^eventReceived)
~EventCallback ()
IFACEMETHODIMP | OnEvent (_In_ IPortableDeviceValues *eventParameters)

Private Attributes

EventReceived | _eventReceived

Detailed Description

Definition at line 25 of file EventCallback.h.

Constructor & Destructor Documentation

SDKSample::PortableDeviceCPP::EventCallback::EventCallback ( EventReceived^ eventReceived ) [inline]

Definition at line 30 of file EventCallback.h.

: _eventReceived(eventReceived) {}

SDKSample::PortableDeviceCPP::EventCallback::~EventCallback ( ) [inline]

Definition at line 32 of file EventCallback.h.

{}

Member Function Documentation

IFACEMETHODIMP SDKSample::PortableDeviceCPP::EventCallback::OnEvent ( _In_ IPortableDeviceValues * eventParameters ) [inline]

Definition at line 34 of file EventCallback.h.

            {
                if (eventParameters != nullptr && _eventReceived != nullptr)
                {
                    // Extract event data. For simplicity, we'll just display the event type and some basic data.
                    GUID eventId;
                    if (SUCCEEDED(eventParameters->GetGuidValue(WPD_EVENT_PARAMETER_EVENT_ID, &eventId)))
                    {
                        Platform::String^ eventData;
                        if (eventId == WPD_EVENT_OBJECT_ADDED)
                        {
                            eventData = "Object Added";
                            PWSTR newObjectId = nullptr;
                            if (SUCCEEDED(eventParameters->GetStringValue(WPD_OBJECT_ID, &newObjectId)))
                            {
                                CoTaskMemString newObjectIdPtr(newObjectId);
                                eventData += ", Object id: " + ref new Platform::String(newObjectId);
                            }
                        }
                        else if (eventId == WPD_EVENT_OBJECT_REMOVED)
                        {
                            eventData = "Object Removed";
                            PWSTR removedObjectId = nullptr;
                            if (SUCCEEDED(eventParameters->GetStringValue(WPD_OBJECT_ID, &removedObjectId)))
                            {
                                CoTaskMemString removedObjectIdPtr(removedObjectId);
                                eventData += ", Object id: " + ref new Platform::String(removedObjectId);
                            }
                        }
                        else if (eventId == WPD_EVENT_OBJECT_UPDATED)
                        {
                            eventData = "Object Updated";
                            PWSTR updatedObjectId = nullptr;
                            if (SUCCEEDED(eventParameters->GetStringValue(WPD_OBJECT_ID, &updatedObjectId)))
                            {
                                CoTaskMemString updatedObjectIdPtr(updatedObjectId);
                                eventData += ", Object id: " + ref new Platform::String(updatedObjectId);
                            }
                        }
                        else
                        {
                            // Handle more events as needed
                            eventData = "Other event";
                        }

                        PWSTR deviceId = nullptr;
                        if (SUCCEEDED(eventParameters->GetStringValue(WPD_EVENT_PARAMETER_PNP_DEVICE_ID, &deviceId)))
                        {
                            //  Invoke the delegate
                            CoTaskMemString deviceIdPtr(deviceId);
                            _eventReceived(ref new Platform::String(deviceId), eventData);
                        }
                    }
                }
                return S_OK;
            }

Member Data Documentation

EventReceived SDKSample::PortableDeviceCPP::EventCallback::_eventReceived [private]

Definition at line 92 of file EventCallback.h.

The documentation for this class was generated from the following file:
  • Portable device API/C++/EventCallback.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PortableDeviceCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • PortableDeviceCPP
  • SDKSample::PortableDeviceCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::PortableDeviceCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "S1_DeviceProperties.xaml.h"

List of all members.

Public Member Functions

S1_DeviceProperties ()
S2_Enumeration ()
S3_SendToDevice ()
S4_GetFromDevice ()
S5_Events ()
S6_DeviceStatus ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CreateAndThenDeleteFolderOnDeviceAsync ()
void | DeviceList_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | DeviceList_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | DeviceList_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | DeviceList_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | DeviceList_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | DeviceList_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | DisplayDeviceProperties (Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement)
void | DisplayDeviceStatusAsync (Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement)
void | DisplayDeviceStatusServiceProperties (_In_ IPortableDeviceService *service)
void | EnumerateObjects (Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement)
Microsoft::WRL::ComPtr
< IPortableDeviceValues > 		FillInPropertiesForFolder (Platform::String^parentId)
Microsoft::WRL::ComPtr
< IPortableDeviceValues > 		FillInPropertiesForImage (Windows::Storage::StorageFile^file, Platform::String^parentId, ULONGLONG size)
void | FindAndTransferFirstImageFileFromDevice (_In_ IPortableDevice *device)
void | GetContentFromDeviceAsync (Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement)
bool | IsRegisteredForDeviceEvents ()
void | OnDeviceEventReceived (Platform::String^senderDeviceId, Platform::String^eventData)
void | RegisterForDeviceEvents (Windows::Devices::Enumeration::DeviceInformation^deviceInfo)
void | Run_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Run_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Run_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Run_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Run_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Run_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendContentToDeviceAsync (Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement)
void | ShowDeviceSelectorAsync ()
void | ShowDeviceSelectorAsync ()
void | ShowDeviceSelectorAsync ()
void | ShowDeviceSelectorAsync ()
void | ShowDeviceSelectorAsync ()
void | ShowDeviceSelectorAsync ()
void | TransferFileFromDeviceToAppLocalFolderAsync (_In_ IPortableDevice *device, Platform::String^sourceObjectId, Platform::String^desiredFilename)
void | TransferFileToDeviceAsync (Windows::Storage::StorageFile^file, _In_ IPortableDevice *device)
void | Trigger_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UnregisterForDeviceEvents ()

Private Attributes

Platform::String | _deviceEventCookie
Microsoft::WRL::ComPtr
< IPortableDevice > 		_deviceEventSource
Windows::Devices::Enumeration::DeviceInformationCollection | _deviceInfoCollection
MainPage rootPage

Detailed Description

Definition at line 30 of file S1_DeviceProperties.xaml.h.

Member Function Documentation

void SDKSample::PortableDeviceCPP::sealed::CreateAndThenDeleteFolderOnDeviceAsync ( ) [private]
void SDKSample::PortableDeviceCPP::sealed::DeviceList_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::DeviceList_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::DeviceList_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::DeviceList_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::DeviceList_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::DeviceList_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::DisplayDeviceProperties ( Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement ) [private]
void SDKSample::PortableDeviceCPP::sealed::DisplayDeviceStatusAsync ( Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement ) [private]
void SDKSample::PortableDeviceCPP::sealed::DisplayDeviceStatusServiceProperties ( _In_ IPortableDeviceService * service ) [private]
void SDKSample::PortableDeviceCPP::sealed::EnumerateObjects ( Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement ) [private]
Microsoft::WRL::ComPtr<IPortableDeviceValues> SDKSample::PortableDeviceCPP::sealed::FillInPropertiesForFolder ( Platform::String^ parentId ) [private]
Microsoft::WRL::ComPtr<IPortableDeviceValues> SDKSample::PortableDeviceCPP::sealed::FillInPropertiesForImage | ( | Windows::Storage::StorageFile^ | file,
 |  | Platform::String^ | parentId,
 |  | ULONGLONG | size |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::FindAndTransferFirstImageFileFromDevice ( _In_ IPortableDevice * device ) [private]
void SDKSample::PortableDeviceCPP::sealed::GetContentFromDeviceAsync ( Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement ) [private]
bool SDKSample::PortableDeviceCPP::sealed::IsRegisteredForDeviceEvents ( ) [inline, private]

Definition at line 46 of file S5_Events.xaml.h.

            {
                return ((_deviceEventSource != nullptr) && (_deviceEventCookie != nullptr));
            }

void SDKSample::PortableDeviceCPP::sealed::OnDeviceEventReceived | ( | Platform::String^ | senderDeviceId,
 |  | Platform::String^ | eventData |
 | ) |  |  | [private]
virtual void SDKSample::PortableDeviceCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PortableDeviceCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PortableDeviceCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PortableDeviceCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PortableDeviceCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PortableDeviceCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::PortableDeviceCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::PortableDeviceCPP::sealed::RegisterForDeviceEvents ( Windows::Devices::Enumeration::DeviceInformation^ deviceInfo ) [private]
void SDKSample::PortableDeviceCPP::sealed::Run_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::Run_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::Run_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::Run_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::Run_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::Run_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::PortableDeviceCPP::sealed::S1_DeviceProperties ( )
SDKSample::PortableDeviceCPP::sealed::S2_Enumeration ( )
SDKSample::PortableDeviceCPP::sealed::S3_SendToDevice ( )
SDKSample::PortableDeviceCPP::sealed::S4_GetFromDevice ( )
SDKSample::PortableDeviceCPP::sealed::S5_Events ( )
SDKSample::PortableDeviceCPP::sealed::S6_DeviceStatus ( )
void SDKSample::PortableDeviceCPP::sealed::SendContentToDeviceAsync ( Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement ) [private]
void SDKSample::PortableDeviceCPP::sealed::ShowDeviceSelectorAsync ( ) [private]
void SDKSample::PortableDeviceCPP::sealed::ShowDeviceSelectorAsync ( ) [private]
void SDKSample::PortableDeviceCPP::sealed::ShowDeviceSelectorAsync ( ) [private]
void SDKSample::PortableDeviceCPP::sealed::ShowDeviceSelectorAsync ( ) [private]
void SDKSample::PortableDeviceCPP::sealed::ShowDeviceSelectorAsync ( ) [private]
void SDKSample::PortableDeviceCPP::sealed::ShowDeviceSelectorAsync ( ) [private]
void SDKSample::PortableDeviceCPP::sealed::TransferFileFromDeviceToAppLocalFolderAsync | ( | _In_ IPortableDevice * | device,
 |  | Platform::String^ | sourceObjectId,
 |  | Platform::String^ | desiredFilename |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::TransferFileToDeviceAsync | ( | Windows::Storage::StorageFile^ | file,
 |  | _In_ IPortableDevice * | device |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::Trigger_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::PortableDeviceCPP::sealed::UnregisterForDeviceEvents ( ) [private]

Member Data Documentation

Platform::String SDKSample::PortableDeviceCPP::sealed::_deviceEventCookie [private]

Definition at line 58 of file S5_Events.xaml.h.

Microsoft::WRL::ComPtr<IPortableDevice> SDKSample::PortableDeviceCPP::sealed::_deviceEventSource [private]

Definition at line 60 of file S5_Events.xaml.h.

Windows::Devices::Enumeration::DeviceInformationCollection sealed::_deviceInfoCollection [private]

Definition at line 46 of file S1_DeviceProperties.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 44 of file S1_DeviceProperties.xaml.h.

The documentation for this class was generated from the following files:
  • Portable device API/C++/S1_DeviceProperties.xaml.h
  • Portable device API/C++/S2_Enumeration.xaml.h
  • Portable device API/C++/S3_SendToDevice.xaml.h
  • Portable device API/C++/S4_GetFromDevice.xaml.h
  • Portable device API/C++/S5_Events.xaml.h
  • Portable device API/C++/S6_DeviceStatus.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PropVariantClearStruct Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::PropVariantClearStruct
Public Member Functions

SDKSample::PropVariantClearStruct Struct Reference

#include "Constants.h"

List of all members.

Public Member Functions

void operator() (PROPVARIANT *pvPtr) const

Detailed Description

Definition at line 61 of file Constants.h.

Member Function Documentation

void SDKSample::PropVariantClearStruct::operator() ( PROPVARIANT * pvPtr ) const [inline]

Definition at line 63 of file Constants.h.

        {
            PropVariantClear(pvPtr);
        }

The documentation for this struct was generated from the following file:
  • Portable device API/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ProvisioningAgent::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ProvisioningAgent
  • SDKSample::ProvisioningAgent::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ProvisioningAgent::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "ProvisionMno.xaml.h"

List of all members.

Public Member Functions

String | ParseErrorCode (String^errorCode)
String | ParseResultXML (String^resultsXml)
String | PrintExceptionCode (Exception^error)
ProvisionMno ()
UpdateCost ()
UpdateUsage ()
Util ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | MediaType_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)
void | MediaType_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)
void | NetworkCostCategory_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)
void | ProvisionMno_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateCost_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateUsage_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::Networking::Connectivity::NetworkCostType | networkCostType
Windows::Networking::NetworkOperators::ProfileMediaType | profileMediaType
MainPage rootPage
Util | util

Detailed Description

Definition at line 31 of file ProvisionMno.xaml.h.

Member Function Documentation

void SDKSample::ProvisioningAgent::sealed::MediaType_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ProvisioningAgent::sealed::MediaType_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ProvisioningAgent::sealed::NetworkCostCategory_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::ProvisioningAgent::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ProvisioningAgent::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ProvisioningAgent::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
String SDKSample::ProvisioningAgent::sealed::ParseErrorCode ( String^ errorCode )
String SDKSample::ProvisioningAgent::sealed::ParseResultXML ( String^ resultsXml )
String SDKSample::ProvisioningAgent::sealed::PrintExceptionCode ( Exception^ error )
SDKSample::ProvisioningAgent::sealed::ProvisionMno ( )
void SDKSample::ProvisioningAgent::sealed::ProvisionMno_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ProvisioningAgent::sealed::UpdateCost ( )
void SDKSample::ProvisioningAgent::sealed::UpdateCost_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ProvisioningAgent::sealed::UpdateUsage ( )
void SDKSample::ProvisioningAgent::sealed::UpdateUsage_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ProvisioningAgent::sealed::Util ( )

Member Data Documentation

Windows::Networking::Connectivity::NetworkCostType SDKSample::ProvisioningAgent::sealed::networkCostType [private]

Definition at line 48 of file UpdateCost.xaml.h.

Windows::Networking::NetworkOperators::ProfileMediaType sealed::profileMediaType [private]

Definition at line 47 of file UpdateCost.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 39 of file ProvisionMno.xaml.h.

Util sealed::util [private]

Definition at line 40 of file ProvisionMno.xaml.h.

The documentation for this class was generated from the following files:
  • Mobile broadband account provisioning/C++/ProvisionMno.xaml.h
  • Mobile broadband account provisioning/C++/UpdateCost.xaml.h
  • Mobile broadband account provisioning/C++/UpdateUsage.xaml.h
  • Mobile broadband account provisioning/C++/Util.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::RemovableStorageCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • RemovableStorageCPP
  • SDKSample::RemovableStorageCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::RemovableStorageCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "S1_ListStorages.xaml.h"

List of all members.

Public Member Functions

S1_ListStorages ()
S2_SendToStorage ()
S3_GetFromStorage ()
S4_Autoplay ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CopyFileToFolderOnStorageAsync (Windows::Storage::StorageFile^sourceFile, Windows::Storage::StorageFolder^storage)
void | DeviceList_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | DeviceList_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | DisplayImageAsync (Windows::Storage::StorageFile^imageFile)
void | DisplayImageAsync (Windows::Storage::StorageFile^imageFile)
void | GetFirstImageFromStorageAsync (Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement)
void | GetFirstImageFromStorageAsync (Windows::Storage::StorageFolder^storage)
void | GetImage_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetImage_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ListStorages_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendImage_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendImageFileToStorageAsync (Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement)
void | ShowDeviceSelectorAsync ()
void | ShowDeviceSelectorAsync ()

Private Attributes

Windows::Devices::Enumeration::DeviceInformationCollection | _deviceInfoCollection
MainPage rootPage

Detailed Description

Definition at line 29 of file S1_ListStorages.xaml.h.

Member Function Documentation

void SDKSample::RemovableStorageCPP::sealed::CopyFileToFolderOnStorageAsync | ( | Windows::Storage::StorageFile^ | sourceFile,
 |  | Windows::Storage::StorageFolder^ | storage |
 | ) |  |  | [private]
void SDKSample::RemovableStorageCPP::sealed::DeviceList_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::RemovableStorageCPP::sealed::DeviceList_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::RemovableStorageCPP::sealed::DisplayImageAsync ( Windows::Storage::StorageFile^ imageFile ) [private]
void SDKSample::RemovableStorageCPP::sealed::DisplayImageAsync ( Windows::Storage::StorageFile^ imageFile ) [private]
void SDKSample::RemovableStorageCPP::sealed::GetFirstImageFromStorageAsync ( Windows::Storage::StorageFolder^ storage ) [private]
void SDKSample::RemovableStorageCPP::sealed::GetFirstImageFromStorageAsync ( Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement ) [private]
void SDKSample::RemovableStorageCPP::sealed::GetImage_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::RemovableStorageCPP::sealed::GetImage_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::RemovableStorageCPP::sealed::ListStorages_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::RemovableStorageCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::RemovableStorageCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::RemovableStorageCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::RemovableStorageCPP::sealed::S1_ListStorages ( )
SDKSample::RemovableStorageCPP::sealed::S2_SendToStorage ( )
SDKSample::RemovableStorageCPP::sealed::S3_GetFromStorage ( )
SDKSample::RemovableStorageCPP::sealed::S4_Autoplay ( )
void SDKSample::RemovableStorageCPP::sealed::SendImage_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::RemovableStorageCPP::sealed::SendImageFileToStorageAsync ( Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement ) [private]
void SDKSample::RemovableStorageCPP::sealed::ShowDeviceSelectorAsync ( ) [private]
void SDKSample::RemovableStorageCPP::sealed::ShowDeviceSelectorAsync ( ) [private]

Member Data Documentation

Windows::Devices::Enumeration::DeviceInformationCollection sealed::_deviceInfoCollection [private]

Definition at line 47 of file S2_SendToStorage.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 36 of file S1_ListStorages.xaml.h.

The documentation for this class was generated from the following files:
  • Removable storage/C++/S1_ListStorages.xaml.h
  • Removable storage/C++/S2_SendToStorage.xaml.h
  • Removable storage/C++/S3_GetFromStorage.xaml.h
  • Removable storage/C++/S4_Autoplay.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Rotation::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Rotation
  • SDKSample::Rotation::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Rotation::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Landscape.xaml.h"

List of all members.

Public Member Functions

Landscape ()
LandscapeFlipped ()
None ()
Portrait ()
PortraitFlipped ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ClearPreference_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetLandscape_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetLandscapeFlipped_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetPortrait_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetPortraitFlipped_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Landscape.xaml.h.

Member Function Documentation

void SDKSample::Rotation::sealed::ClearPreference_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Rotation::sealed::Landscape ( )
SDKSample::Rotation::sealed::LandscapeFlipped ( )
SDKSample::Rotation::sealed::None ( )
virtual void SDKSample::Rotation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Rotation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Rotation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Rotation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Rotation::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::Rotation::sealed::Portrait ( )
SDKSample::Rotation::sealed::PortraitFlipped ( )
void SDKSample::Rotation::sealed::SetLandscape_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Rotation::sealed::SetLandscapeFlipped_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Rotation::sealed::SetPortrait_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Rotation::sealed::SetPortraitFlipped_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Landscape.xaml.h.

The documentation for this class was generated from the following files:
  • Device auto rotation preferences/C++/Landscape.xaml.h
  • Device auto rotation preferences/C++/LandscapeFlipped.xaml.h
  • Device auto rotation preferences/C++/None.xaml.h
  • Device auto rotation preferences/C++/Portrait.xaml.h
  • Device auto rotation preferences/C++/PortraitFlipped.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Scaling::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Scaling
  • SDKSample::Scaling::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::Scaling::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisplayProperties_LogicalDpiChanged (Platform::Object^sender)
void | DisplayProperties_LogicalDpiChanged (Platform::Object^sender)
Platform::String | GetMinDPI ()
Platform::String | GetMinResolution ()
void | OutputSettings (double scaleFactor, Windows::UI::Xaml::FrameworkElement^rectangle, Windows::UI::Xaml::Controls::TextBlock^relativePxText, Windows::UI::Xaml::Controls::TextBlock^physicalPxText, Windows::UI::Xaml::Controls::TextBlock^fontTextBlock)
double | PtFromPx (double pixel)
double | PxFromPt (double pt)
void | ResetOutput ()
void | ResetOutput ()
void | SetManualLoadImage ()
void | SetOverrideRectSize (double sizeInPhysicalPx, double scaleFactor)
void | SetOverrideTextFont (double size, Windows::UI::Xaml::Media::FontFamily^fontFamily)
Platform::String | StringFromDouble (double)

Private Attributes

Windows::UI::Xaml::Media::FontFamily | defaultFontFamily
Windows::UI::Xaml::Media::Imaging::BitmapImage | image100
Windows::UI::Xaml::Media::Imaging::BitmapImage | image140
Windows::UI::Xaml::Media::Imaging::BitmapImage | image180
Windows::UI::Xaml::Media::FontFamily | overrideFontFamily

Static Private Attributes

static const int | DEFAULT_LOGICALPPI = 96
static const int | PERCENT = 100

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::Scaling::sealed::DisplayProperties_LogicalDpiChanged ( Platform::Object^ sender ) [private]
void SDKSample::Scaling::sealed::DisplayProperties_LogicalDpiChanged ( Platform::Object^ sender ) [private]
Platform::String SDKSample::Scaling::sealed::GetMinDPI ( ) [private]
Platform::String SDKSample::Scaling::sealed::GetMinResolution ( ) [private]
virtual void SDKSample::Scaling::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Scaling::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Scaling::sealed::OutputSettings | ( | double | scaleFactor,
 |  | Windows::UI::Xaml::FrameworkElement^ | rectangle,
 |  | Windows::UI::Xaml::Controls::TextBlock^ | relativePxText,
 |  | Windows::UI::Xaml::Controls::TextBlock^ | physicalPxText,
 |  | Windows::UI::Xaml::Controls::TextBlock^ | fontTextBlock |
 | ) |  |  | [private]
double SDKSample::Scaling::sealed::PtFromPx ( double pixel ) [private]
double SDKSample::Scaling::sealed::PxFromPt ( double pt ) [private]
void SDKSample::Scaling::sealed::ResetOutput ( ) [private]
void SDKSample::Scaling::sealed::ResetOutput ( ) [private]
SDKSample::Scaling::sealed::Scenario1 ( )
SDKSample::Scaling::sealed::Scenario2 ( )
void SDKSample::Scaling::sealed::SetManualLoadImage ( ) [private]
void SDKSample::Scaling::sealed::SetOverrideRectSize | ( | double | sizeInPhysicalPx,
 |  | double | scaleFactor |
 | ) |  |  | [private]
void SDKSample::Scaling::sealed::SetOverrideTextFont | ( | double | size,
 |  | Windows::UI::Xaml::Media::FontFamily^ | fontFamily |
 | ) |  |  | [private]
Platform::String SDKSample::Scaling::sealed::StringFromDouble ( double ) [private]

Member Data Documentation

const int SDKSample::Scaling::sealed::DEFAULT_LOGICALPPI = 96 [static, private]

Definition at line 39 of file Scenario1.xaml.h.

Windows::UI::Xaml::Media::FontFamily SDKSample::Scaling::sealed::defaultFontFamily [private]

Definition at line 51 of file Scenario2.xaml.h.

Windows::UI::Xaml::Media::Imaging::BitmapImage SDKSample::Scaling::sealed::image100 [private]

Definition at line 42 of file Scenario1.xaml.h.

Windows::UI::Xaml::Media::Imaging::BitmapImage SDKSample::Scaling::sealed::image140 [private]

Definition at line 43 of file Scenario1.xaml.h.

Windows::UI::Xaml::Media::Imaging::BitmapImage SDKSample::Scaling::sealed::image180 [private]

Definition at line 44 of file Scenario1.xaml.h.

Windows::UI::Xaml::Media::FontFamily SDKSample::Scaling::sealed::overrideFontFamily [private]

Definition at line 52 of file Scenario2.xaml.h.

const int SDKSample::Scaling::sealed::PERCENT = 100 [static, private]

Definition at line 40 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Scaling according to DPI/C++/Scenario1.xaml.h
  • Scaling according to DPI/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::Scenario
Public Attributes

SDKSample::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
String | ClassName
String | Title
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String SDKSample::Scenario::ClassName

Definition at line 20 of file Constants.h.

String SDKSample::Scenario::ClassName

Definition at line 28 of file Constants.h.

String SDKSample::Scenario::Title

Definition at line 27 of file Constants.h.

Platform::String SDKSample::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following files:
  • Accelerometer sensor/C++/Constants.h
  • Animation metrics/C++/Constants.h
  • App package information/C++/Constants.h
  • App settings/C++/Constants.h
  • App tiles and badges/C#,C++/Constants.h
  • Application data/C++/Constants.h
  • Application resources and localization/C++/Constants.h
  • AtomPub/C++/Constants.h
  • Background task/C++/BackgroundTask/Constants.h
  • Background Transfer/C++/Constants.h
  • Bluetooth call control/C++/Constants.h
  • Calendar details and math/C++/Constants.h
  • CameraCaptureUI/C++/Constants.h
  • CameraOptionsUI/C++/Constants.h
  • Certificate enrollment/C++/Constants.h
  • Check if current session is remote/C++/Constants.h
  • Compass sensor/C++/Constants.h
  • Compression/C++/Constants.h
  • Configure keys for media/C++/Constants.h
  • Connecting with WebSockets/C++/Constants.h
  • Context menu/C++/Constants.h
  • Credential locker/C++/Constants.h
  • CryptoWinRT/C++/Constants.h
  • Custom driver access/C++/app_cpp/Constants.h
  • Date and time formatting/C++/Constants.h
  • Device auto rotation preferences/C++/Constants.h
  • Device enumeration/C++/Constants.h
  • Display orientation/C++/Constants.h
  • EAS policies for mail clients/C++/Constants.h
  • Extended Linguistic Services (ELS)/C++/Constants.h
  • File access/C++/Constants.h
  • File and folder thumbnail/C++/Constants.h
  • File picker/C++/Constants.h
  • File picker contracts/C++/Constants.h
  • Folder enumeration/C++/Constants.h
  • Geolocation/C++/Constants.h
  • Globalization preferences/C++/Constants.h
  • Gyrometer sensor/C++/Constants.h
  • HomeGroup app/C++/Constants.h
  • HttpClient/C++/Constants.h
  • Inclinometer sensor/C++/Constants.h
  • Input Device capabilities/C++/Constants.h
  • Input Touch keyboard/C++/Constants.h
  • Input Touch keyboard text input/C++/Constants.h
  • IXmlReader and IXmlWriter XML data readwrite/C++/Constants.h
  • LightSensor/C++/Constants.h
  • Lock screen personalization/C++/Constants.h
  • Media capture using capture device/C++/Constants.h
  • Media Play To/C++/Constants.h
  • Media Server client/C++/Constants.h
  • Message dialog/C++/Constants.h
  • Mobile broadband account provisioning/C++/Constants.h
  • Network information/C++/Constants.h
  • Network status background/C++/NetworkStatusApp/Constants.h
  • Number formatting and parsing/C++/Constants.h
  • OrientationSensor/C++/Constants.h
  • Playback Manager Companion/C++/Constants.h
  • Playback Manager msAudioCategory/C++/Constants.h
  • Playlist/C++/Constants.h
  • PlayToReceiver/C++/Constants.h
  • Portable device API/C++/Constants.h
  • Programmatic file search/C++/Constants.h
  • Push and periodic notifications client-side/C++/Constants.h
  • Reading and writing data/C++/Constants.h
  • Removable storage/C++/Constants.h
  • Scaling according to DPI/C++/Constants.h
  • Search contract/C++/Constants.h
  • Sharing content source app/C++/Constants.h
  • SimpleOrientationSensor/C++/Constants.h
  • SMS background task/C++/SmsBackgroundTaskSample/Constants.h
  • SMS message send, receive, and SIM management/C++/Constants.h
  • Snap/C++/Constants.h
  • Splash screen/C++/Constants.h
  • StorageDataSource and GetVirtualizedFilesVector/C++/Constants.h
  • Syndication/C++/Constants.h
  • Thread pool/C++/Constants.h
  • Transcoding media/C++/Constants.h
  • Trial app and in-app purchase/C++/Constants.h
  • UI contrast and settings/C++/Constants.h
  • User domain name/C++/Constants.h
  • USSD message management/C++/Constants.h
  • Web authentication broker/C++/Constants.h
  • Windows account authorization/C++/Constants.h
  • Windows Audio Session (WASAPI)/C++/Constants.h
  • XAML accessibility/C++/Constants.h
  • XAML animation library/C++/Constants.h
  • XAML data binding/C++/Constants.h
  • XAML FlipView control/C++/Constants.h
  • XAML high contrast style/C++/Constants.h
  • XAML images/C++/Constants.h
  • XAML ListView and GridView essentials/C++/Constants.h
  • XAML personality animations/C++/Constants.h
  • XAML Popup/C++/Constants.h
  • XAML scrolling, panning, and zooming/C++/Constants.h
  • XAML text display/C++/Constants.h
  • XAML text editing/C++/Constants.h
  • XAML two-dimensional transforms/C++/Constants.h
  • XAML user and custom controls/C++/Constants.h
  • XAML vector-based drawing/C++/Constants.h
  • XAML WebView control/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ScrollViewerCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ScrollViewerCPP
  • SDKSample::ScrollViewerCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ScrollViewerCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CheckBox_Checked_HorizontalRailed (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CheckBox_Checked_VerticalRailed (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CheckBox_Unchecked_HorizontalRailed (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CheckBox_Unchecked_VerticalRailed (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ComboBox_SelectionChanged_1 (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | hsbvCombo_SelectionChanged_1 (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | hsmCombo_SelectionChanged_1 (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenario1Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario1Reset ()
void | Scenario2Reset ()
void | Scenario2Reset (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | vsbvCombo_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | vsmCombo_SelectionChanged_1 (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::ScrollViewerCPP::sealed::CheckBox_Checked_HorizontalRailed | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::CheckBox_Checked_VerticalRailed | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::CheckBox_Unchecked_HorizontalRailed | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::CheckBox_Unchecked_VerticalRailed | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::ComboBox_SelectionChanged_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::hsbvCombo_SelectionChanged_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::hsmCombo_SelectionChanged_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::ScrollViewerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ScrollViewerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ScrollViewerCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::ScrollViewerCPP::sealed::Scenario1 ( )
void SDKSample::ScrollViewerCPP::sealed::Scenario1Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::Scenario1Reset ( ) [private]
SDKSample::ScrollViewerCPP::sealed::Scenario2 ( )
void SDKSample::ScrollViewerCPP::sealed::Scenario2Reset | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::Scenario2Reset ( ) [private]
SDKSample::ScrollViewerCPP::sealed::Scenario3 ( )
void SDKSample::ScrollViewerCPP::sealed::vsbvCombo_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ScrollViewerCPP::sealed::vsmCombo_SelectionChanged_1 | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML scrolling, panning, and zooming/C++/Scenario1.xaml.h
  • XAML scrolling, panning, and zooming/C++/Scenario2.xaml.h
  • XAML scrolling, panning, and zooming/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SDKTemplate::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKTemplate
  • SDKSample::SDKTemplate::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::SDKTemplate::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | AddCallback_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
bool | AddURIIfValid (Windows::Foundation::Collections::IVector< Windows::Foundation::Uri^>^vectorToReceive, Platform::String^polledUrl)
void | CloseChannel_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
Windows::ApplicationModel::Background::IBackgroundTaskRegistration | GetRegisteredTask ()
void | OnPushNotificationReceived (Windows::Networking::PushNotifications::PushNotificationChannel^sender, Windows::Networking::PushNotifications::PushNotificationReceivedEventArgs^e)
void | OpenChannel_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RegisterTaskButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RemoveCallback_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | RenewChannelsButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartBadgePolling_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StartTilePolling_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopBadgePolling_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopTilePolling_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UnregisterTaskButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
bool | UpdateListener (bool add)

Private Attributes

Windows::Foundation::EventRegistrationToken | pushReceivedToken
MainPage rootPage

Detailed Description

Definition at line 25 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::SDKTemplate::sealed::AddCallback_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
bool SDKSample::SDKTemplate::sealed::AddURIIfValid | ( | Windows::Foundation::Collections::IVector< Windows::Foundation::Uri^>^ | vectorToReceive,
 |  | Platform::String^ | polledUrl |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::CloseChannel_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
Windows::ApplicationModel::Background::IBackgroundTaskRegistration SDKSample::SDKTemplate::sealed::GetRegisteredTask ( ) [private]
virtual void SDKSample::SDKTemplate::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SDKTemplate::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SDKTemplate::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SDKTemplate::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SDKTemplate::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SDKTemplate::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::SDKTemplate::sealed::OnPushNotificationReceived | ( | Windows::Networking::PushNotifications::PushNotificationChannel^ | sender,
 |  | Windows::Networking::PushNotifications::PushNotificationReceivedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::OpenChannel_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::RegisterTaskButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::RemoveCallback_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::RenewChannelsButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::SDKTemplate::sealed::Scenario1 ( )
SDKSample::SDKTemplate::sealed::Scenario2 ( )
SDKSample::SDKTemplate::sealed::Scenario3 ( )
SDKSample::SDKTemplate::sealed::Scenario4 ( )
SDKSample::SDKTemplate::sealed::Scenario5 ( )
void SDKSample::SDKTemplate::sealed::StartBadgePolling_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::StartTilePolling_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::StopBadgePolling_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::StopTilePolling_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SDKTemplate::sealed::UnregisterTaskButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
bool SDKSample::SDKTemplate::sealed::UpdateListener ( bool add ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken SDKSample::SDKTemplate::sealed::pushReceivedToken [private]

Definition at line 40 of file Scenario3.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 33 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Push and periodic notifications client-side/C++/Scenario1.xaml.h
  • Push and periodic notifications client-side/C++/Scenario2.xaml.h
  • Push and periodic notifications client-side/C++/Scenario3.xaml.h
  • Push and periodic notifications client-side/C++/Scenario4.xaml.h
  • Push and periodic notifications client-side/C++/Scenario5.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::sealed
Public Member Functions | Static Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::sealed Class Reference

#include "MainPage.xaml.h"

List of all members.

Public Member Functions

void | AttachFeed (SyndicationFeed^feed)
BindableNode (String^nodeName, String^nodeNamespace, String^nodeValue)
Platform::String | GetContent ()
Uri | GetEditUri ()
Platform::String | GetIndexDescription ()
SyndicationItem | GetSyndicationItem ()
Platform::String | GetTitle ()
bool | HasElements ()
void | LoadScenario (Platform::String^scenarioName)
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
void | MoveNext ()
void | MovePrevious ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
void | ResetScenarioOutput (Windows::UI::Xaml::Controls::TextBlock^textblock)
SyndicationItemIterator ()

Static Public Member Functions

static AtomPubClient | GetClient ()
static void | Restore (Page^inputFrame)
static void | Save (Platform::String^baseUri, Platform::String^user, Platform::String^password)

Public Attributes

event
Windows::Foundation::EventHandler
< PageSizeChangedEventArgs^> 		PageResized

Static Public Attributes

static Platform::String | editUri
static Platform::String | feedUri
static Platform::String | password
static Platform::String | serviceDocUri
static Platform::String | user

Protected Member Functions

void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
void | LoadScenario (Platform::String^scenarioName)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | NotifyUser (Platform::String^strMessage, NotifyType type)
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)
void | set (bool value)

Protected Attributes

internal | __pad0__: property bool AutoSizeInputSectionWhenSnapped { bool get() { return autoSizeInputSectionWhenSnapped

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
String | nodeNamespace
String | nodeValue
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Private Attributes

internal | __pad1__: static MainPage^ Current
bool | autoSizeInputSectionWhenSnapped
bool | Dismissed
SyndicationFeed | feed
Windows::UI::Xaml::Controls::Frame | HiddenFrame
unsigned int | index
Platform::Collections::Vector
< Object^> 		ScenarioList
Windows::Foundation::Rect | SplashImageRect

Static Private Attributes

static Platform::Array< Scenario > | scenariosInner

Detailed Description

Definition at line 31 of file MainPage.xaml.h.

Member Function Documentation

void SDKSample::sealed::AttachFeed ( SyndicationFeed^ feed ) [inline]

Definition at line 234 of file Constants.h.

        {
            this->feed = feed;
            this->index = 0;
        }

SDKSample::sealed::BindableNode | ( | String^ | nodeName,
 |  | String^ | nodeNamespace,
 |  | String^ | nodeValue |
 | ) |  |  | [inline]

Definition at line 95 of file Constants.h.

        {
            this->NodeName = nodeName;
            this->NodeNamespace = nodeNamespace;
            this->NodeValue = nodeValue;
        }

void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
static AtomPubClient SDKSample::sealed::GetClient ( ) [inline, static]

Definition at line 164 of file Constants.h.

        {
            AtomPubClient^ client;

            client = ref new AtomPubClient();
            client->BypassCacheOnRetrieve = true;

            if ((user != nullptr) && (password != nullptr))
            {
                client->ServerCredential = ref new PasswordCredential();
                client->ServerCredential->UserName = user;
                client->ServerCredential->Password = password;
            }
            else
            {
                client->ServerCredential = nullptr;
            }

            return client;
        }

Platform::String SDKSample::sealed::GetContent ( ) [inline]

Definition at line 277 of file Constants.h.

        {
            // Nothing to return yet.
            if (!HasElements())
            {
                return "(no value)";
            }

            if ((feed->Items->GetAt(index)->Content != nullptr) && (feed->Items->GetAt(index)->Content->Text != nullptr))
            {
                return feed->Items->GetAt(index)->Content->Text;
            }

            return "(no value)";
        }

Uri SDKSample::sealed::GetEditUri ( ) [inline]

Definition at line 304 of file Constants.h.

        {
            // Nothing to return yet.
            if (!HasElements())
            {
                return nullptr;
            }

            return feed->Items->GetAt(index)->EditUri;
        }

Platform::String SDKSample::sealed::GetIndexDescription ( ) [inline]

Definition at line 293 of file Constants.h.

        {
            // Nothing to return yet.
            if (!HasElements())
            {
                return "0 of 0";
            }

            return (index + 1).ToString() + " of " + feed->Items->Size.ToString();
        }

SyndicationItem SDKSample::sealed::GetSyndicationItem ( ) [inline]

Definition at line 315 of file Constants.h.

        {
            // Nothing to return yet.
            if (!HasElements())
            {
                return nullptr;
            }

            return feed->Items->GetAt(index);
        }

Platform::String SDKSample::sealed::GetTitle ( ) [inline]

Definition at line 261 of file Constants.h.

        {
            // Nothing to return yet.
            if (!HasElements())
            {
                return "(no title)";
            }

            if (feed->Items->GetAt(index)->Title != nullptr)
            {
                return HtmlUtilities::ConvertToText(feed->Items->GetAt(index)->Title->Text);
            }

            return "(no title)";
        }

bool SDKSample::sealed::HasElements ( ) [inline]

Definition at line 256 of file Constants.h.

        {
            return feed != nullptr && feed->Items->Size > 0;
        }

void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateSize ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::InvalidateViewState ( ) [private]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName )
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
void SDKSample::sealed::LoadScenario ( Platform::String^ scenarioName ) [protected]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SDKSample::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
SDKSample::sealed::MainPage ( )
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::MoveNext ( ) [inline]

Definition at line 240 of file Constants.h.

        {
            if (feed != nullptr && index < feed->Items->Size - 1)
            {
                index++;
            }
        }

void SDKSample::sealed::MovePrevious ( ) [inline]

Definition at line 248 of file Constants.h.

        {
            if (feed != nullptr && index > 0)
            {
                index--;
            }
        }

void SDKSample::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void SDKSample::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type |
 | ) |  |  | [protected]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::PopulateScenarios ( ) [private]
void SDKSample::sealed::ResetScenarioOutput ( Windows::UI::Xaml::Controls::TextBlock^ textblock )
static void SDKSample::sealed::Restore ( Page^ inputFrame ) [inline, static]

Definition at line 148 of file Constants.h.

        {
            // Set authentication fields.
            ((TextBox^)inputFrame->FindName("ServiceAddressField"))->Text = baseUri;
            ((TextBox^)inputFrame->FindName("UserNameField"))->Text = user;
            ((PasswordBox^)inputFrame->FindName("PasswordField"))->Password = password;
        }

static void SDKSample::sealed::Save | ( | Platform::String^ | baseUri,
 |  | Platform::String^ | user,
 |  | Platform::String^ | password |
 | ) |  |  | [inline, static]

Definition at line 156 of file Constants.h.

        {
            // Keep values of authentication fields.
            CommonData::baseUri = baseUri;
            CommonData::user = user;
            CommonData::password = password;
        }

virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
virtual void SDKSample::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 70 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

void SDKSample::sealed::set ( bool value ) [inline, protected]

Definition at line 69 of file MainPage.xaml.h.

            {
                autoSizeInputSectionWhenSnapped = value;
            }

SDKSample::sealed::SyndicationItemIterator ( ) [inline]

Definition at line 228 of file Constants.h.

        {
            this->feed = nullptr;
            this->index = 0;
        }

Member Data Documentation

internal sealed::__pad0__ [protected]

Definition at line 66 of file MainPage.xaml.h.

internal sealed::__pad1__ [private]

Definition at line 102 of file MainPage.xaml.h.

bool sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 96 of file MainPage.xaml.h.

bool SDKSample::sealed::Dismissed [private]

Definition at line 106 of file MainPage.xaml.h.

Platform::String SDKSample::sealed::editUri [static]

Definition at line 215 of file Constants.h.

SyndicationFeed SDKSample::sealed::feed [private]

Definition at line 224 of file Constants.h.

Platform::String SDKSample::sealed::feedUri [static]

Definition at line 217 of file Constants.h.

Windows::UI::Xaml::Controls::Frame sealed::HiddenFrame [private]

Definition at line 94 of file MainPage.xaml.h.

unsigned int SDKSample::sealed::index [private]

Definition at line 225 of file Constants.h.

event Windows::Foundation::EventHandler<PageSizeChangedEventArgs^> SDKSample::sealed::PageResized

Definition at line 73 of file MainPage.xaml.h.

Platform::String SDKSample::sealed::password [static]

Definition at line 212 of file Constants.h.

Platform::Collections::Vector< Object^> sealed::ScenarioList [private]

Definition at line 93 of file MainPage.xaml.h.

Platform::Array<Scenario> SDKSample::sealed::scenariosInner [static, private]

Definition at line 84 of file MainPage.xaml.h.

Platform::String SDKSample::sealed::serviceDocUri [static]

Definition at line 216 of file Constants.h.

Windows::Foundation::Rect SDKSample::sealed::SplashImageRect [private]

Definition at line 105 of file MainPage.xaml.h.

Platform::String SDKSample::sealed::user [static]

Definition at line 210 of file Constants.h.

Property Documentation

event Windows::Foundation::EventHandler< MainPageSizeChangedEventArgs^> sealed::MainPageResized [protected]

Definition at line 86 of file MainPage.xaml.h.

String SDKSample::sealed::nodeNamespace

Definition at line 139 of file Constants.h.

String SDKSample::sealed::nodeValue

Definition at line 141 of file Constants.h.

event Windows::Foundation::EventHandler< Platform::Object^> sealed::ScenarioLoaded [protected]

Definition at line 85 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Accelerometer sensor/C++/MainPage.xaml.h
  • Animation metrics/C++/MainPage.xaml.h
  • App package information/C++/MainPage.xaml.h
  • App settings/C++/MainPage.xaml.h
  • App tiles and badges/C#,C++/MainPage.xaml.h
  • Application data/C++/MainPage.xaml.h
  • Application resources and localization/C++/MainPage.xaml.h
  • AtomPub/C++/Constants.h
  • AtomPub/C++/MainPage.xaml.h
  • Background task/C++/BackgroundTask/MainPage.xaml.h
  • Background Transfer/C++/MainPage.xaml.h
  • Bluetooth call control/C++/MainPage.xaml.h
  • Calendar details and math/C++/MainPage.xaml.h
  • CameraCaptureUI/C++/MainPage.xaml.h
  • CameraOptionsUI/C++/MainPage.xaml.h
  • Certificate enrollment/C++/MainPage.xaml.h
  • Check if current session is remote/C++/MainPage.xaml.h
  • Compass sensor/C++/MainPage.xaml.h
  • Compression/C++/MainPage.xaml.h
  • Configure keys for media/C++/MainPage.xaml.h
  • Connecting with WebSockets/C++/MainPage.xaml.h
  • Context menu/C++/MainPage.xaml.h
  • Credential locker/C++/MainPage.xaml.h
  • CryptoWinRT/C++/MainPage.xaml.h
  • Custom driver access/C++/app_cpp/MainPage.xaml.h
  • Date and time formatting/C++/MainPage.xaml.h
  • Device auto rotation preferences/C++/MainPage.xaml.h
  • Device enumeration/C++/MainPage.xaml.h
  • Display orientation/C++/MainPage.xaml.h
  • EAS policies for mail clients/C++/MainPage.xaml.h
  • Extended Linguistic Services (ELS)/C++/MainPage.xaml.h
  • File access/C++/MainPage.xaml.h
  • File and folder thumbnail/C++/MainPage.xaml.h
  • File picker/C++/MainPage.xaml.h
  • File picker contracts/C++/MainPage.xaml.h
  • Folder enumeration/C++/MainPage.xaml.h
  • Geolocation/C++/MainPage.xaml.h
  • Globalization preferences/C++/MainPage.xaml.h
  • Gyrometer sensor/C++/MainPage.xaml.h
  • HomeGroup app/C++/MainPage.xaml.h
  • HttpClient/C++/MainPage.xaml.h
  • Inclinometer sensor/C++/MainPage.xaml.h
  • Input Device capabilities/C++/MainPage.xaml.h
  • Input Touch keyboard/C++/MainPage.xaml.h
  • Input Touch keyboard text input/C++/MainPage.xaml.h
  • IXmlReader and IXmlWriter XML data readwrite/C++/MainPage.xaml.h
  • LightSensor/C++/MainPage.xaml.h
  • Lock screen personalization/C++/MainPage.xaml.h
  • Media capture using capture device/C++/MainPage.xaml.h
  • Media Play To/C++/MainPage.xaml.h
  • Media Server client/C++/MainPage.xaml.h
  • Message dialog/C++/MainPage.xaml.h
  • Mobile broadband account provisioning/C++/MainPage.xaml.h
  • Network information/C++/MainPage.xaml.h
  • Network status background/C++/NetworkStatusApp/MainPage.xaml.h
  • Number formatting and parsing/C++/MainPage.xaml.h
  • OrientationSensor/C++/MainPage.xaml.h
  • Playback Manager Companion/C++/MainPage.xaml.h
  • Playback Manager msAudioCategory/C++/MainPage.xaml.h
  • Playlist/C++/MainPage.xaml.h
  • PlayToReceiver/C++/MainPage.xaml.h
  • Portable device API/C++/MainPage.xaml.h
  • Programmatic file search/C++/MainPage.xaml.h
  • Push and periodic notifications client-side/C++/MainPage.xaml.h
  • Reading and writing data/C++/MainPage.xaml.h
  • Removable storage/C++/MainPage.xaml.h
  • Scaling according to DPI/C++/MainPage.xaml.h
  • Search contract/C++/MainPage.xaml.h
  • Sharing content source app/C++/MainPage.xaml.h
  • SimpleOrientationSensor/C++/MainPage.xaml.h
  • SMS background task/C++/SmsBackgroundTaskSample/MainPage.xaml.h
  • Snap/C++/MainPage.xaml.h
  • Splash screen/C++/MainPage.xaml.h
  • Syndication/C++/Constants.h
  • Syndication/C++/MainPage.xaml.h
  • Thread pool/C++/MainPage.xaml.h
  • Transcoding media/C++/MainPage.xaml.h
  • Trial app and in-app purchase/C++/MainPage.xaml.h
  • UI contrast and settings/C++/MainPage.xaml.h
  • User domain name/C++/MainPage.xaml.h
  • USSD message management/C++/MainPage.xaml.h
  • Web authentication broker/C++/MainPage.xaml.h
  • Windows account authorization/C++/MainPage.xaml.h
  • Windows Audio Session (WASAPI)/C++/MainPage.xaml.h
  • XAML accessibility/C++/MainPage.xaml.h
  • XAML animation library/C++/MainPage.xaml.h
  • XAML data binding/C++/MainPage.xaml.h
  • XAML FlipView control/C++/MainPage.xaml.h
  • XAML high contrast style/C++/MainPage.xaml.h
  • XAML images/C++/MainPage.xaml.h
  • XAML ListView and GridView essentials/C++/MainPage.xaml.h
  • XAML personality animations/C++/MainPage.xaml.h
  • XAML Popup/C++/MainPage.xaml.h
  • XAML scrolling, panning, and zooming/C++/MainPage.xaml.h
  • XAML text display/C++/MainPage.xaml.h
  • XAML text editing/C++/MainPage.xaml.h
  • XAML two-dimensional transforms/C++/MainPage.xaml.h
  • XAML user and custom controls/C++/MainPage.xaml.h
  • XAML vector-based drawing/C++/MainPage.xaml.h
  • XAML WebView control/C++/MainPage.xaml.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SearchContract::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SearchContract
  • SDKSample::SearchContract::sealed
Public Member Functions | Protected Member Functions | Private Attributes

SDKSample::SearchContract::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()
Scenario6 ()
Scenario7 ()

Protected Member Functions

void | AddSuggestionFromNode (Windows::Data::Xml::Dom::IXmlNode^node, Windows::ApplicationModel::Search::SearchSuggestionCollection^suggestions)
void | GetSuggestions (Windows::Data::Xml::Dom::XmlDocument^doc, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequest^request)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | OnResultSuggestionChosen (Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneResultSuggestionChosenEventArgs^e)
void | OnSearchPaneSuggestionsRequested (Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^e)
void | OnSearchPaneSuggestionsRequested (Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^e)
void | OnSearchPaneSuggestionsRequested (Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^e)
void | OnSearchPaneSuggestionsRequested (Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^e)
void | SetLocalContentSuggestions (bool isLocal)

Private Attributes

concurrency::cancellation_token_source | cts
Web::HttpRequest httpRequest
Windows::Foundation::EventRegistrationToken | resultSuggestionChosenToken
Windows::ApplicationModel::Search::SearchPane | searchPane
Windows::Foundation::EventRegistrationToken | suggestionsRequestedToken
Windows::Foundation::EventRegistrationToken | token

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::SearchContract::sealed::AddSuggestionFromNode | ( | Windows::Data::Xml::Dom::IXmlNode^ | node,
 |  | Windows::ApplicationModel::Search::SearchSuggestionCollection^ | suggestions |
 | ) |  |  | [protected]
void SDKSample::SearchContract::sealed::GetSuggestions | ( | Windows::Data::Xml::Dom::XmlDocument^ | doc,
 |  | Windows::ApplicationModel::Search::SearchPaneSuggestionsRequest^ | request |
 | ) |  |  | [protected]
virtual void SDKSample::SearchContract::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SearchContract::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::SearchContract::sealed::OnResultSuggestionChosen | ( | Windows::ApplicationModel::Search::SearchPane^ | sender,
 |  | Windows::ApplicationModel::Search::SearchPaneResultSuggestionChosenEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::SearchContract::sealed::OnSearchPaneSuggestionsRequested | ( | Windows::ApplicationModel::Search::SearchPane^ | sender,
 |  | Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::SearchContract::sealed::OnSearchPaneSuggestionsRequested | ( | Windows::ApplicationModel::Search::SearchPane^ | sender,
 |  | Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::SearchContract::sealed::OnSearchPaneSuggestionsRequested | ( | Windows::ApplicationModel::Search::SearchPane^ | sender,
 |  | Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^ | e |
 | ) |  |  | [protected]
void SDKSample::SearchContract::sealed::OnSearchPaneSuggestionsRequested | ( | Windows::ApplicationModel::Search::SearchPane^ | sender,
 |  | Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^ | e |
 | ) |  |  | [protected]
SDKSample::SearchContract::sealed::Scenario1 ( )
SDKSample::SearchContract::sealed::Scenario2 ( )
SDKSample::SearchContract::sealed::Scenario3 ( )
SDKSample::SearchContract::sealed::Scenario4 ( )
SDKSample::SearchContract::sealed::Scenario5 ( )
SDKSample::SearchContract::sealed::Scenario6 ( )
SDKSample::SearchContract::sealed::Scenario7 ( )
void SDKSample::SearchContract::sealed::SetLocalContentSuggestions ( bool isLocal ) [protected]

Member Data Documentation

concurrency::cancellation_token_source sealed::cts [private]

Definition at line 46 of file Scenario5.xaml.h.

Web::HttpRequest SDKSample::SearchContract::sealed::httpRequest [private]

Definition at line 47 of file Scenario5.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::SearchContract::sealed::resultSuggestionChosenToken [private]

Definition at line 47 of file Scenario6.xaml.h.

Windows::ApplicationModel::Search::SearchPane sealed::searchPane [private]

Definition at line 43 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::SearchContract::sealed::suggestionsRequestedToken [private]

Definition at line 47 of file Scenario6.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::token [private]

Definition at line 44 of file Scenario2.xaml.h.

The documentation for this class was generated from the following files:
  • Search contract/C++/Scenario1.xaml.h
  • Search contract/C++/Scenario2.xaml.h
  • Search contract/C++/Scenario3.xaml.h
  • Search contract/C++/Scenario4.xaml.h
  • Search contract/C++/Scenario5.xaml.h
  • Search contract/C++/Scenario6.xaml.h
  • Search contract/C++/Scenario7.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ShareSource::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ShareSource
  • SDKSample::ShareSource::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ShareSource::sealed Class Reference

#include "SetErrorMessage.xaml.h"

List of all members.

Public Member Functions

SetErrorMessage ()
ShareCustomData ()
ShareDelayRenderedFiles ()
ShareFiles ()
ShareHtml ()
ShareImage ()
ShareLink ()
ShareText ()

Protected Member Functions

virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request) override
virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request) override
virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request) override
virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request) override
virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request) override
virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request) override
virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request) override
virtual bool | GetShareContent (Windows::ApplicationModel::DataTransfer::DataRequest^request) override

Private Member Functions

void | OnDeferredImageRequestedHandler (Windows::ApplicationModel::DataTransfer::DataProviderRequest^request)
void | SelectFilesButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SelectImageButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SelectImageButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShareWebView_LoadCompleted (Platform::Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
Windows::Foundation::Uri | ValidateAndGetUri (Platform::String^uriString)

Private Attributes

Windows::Storage::StorageFile | imageFile
MainPage rootPage
Windows::Foundation::Collections::IVectorView
< Windows::Storage::StorageFile^> 		storageItems

Detailed Description

Definition at line 28 of file SetErrorMessage.xaml.h.

Member Function Documentation

virtual bool SDKSample::ShareSource::sealed::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [override, protected, virtual]
virtual bool SDKSample::ShareSource::sealed::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [override, protected, virtual]
virtual bool SDKSample::ShareSource::sealed::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [override, protected, virtual]
virtual bool SDKSample::ShareSource::sealed::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [override, protected, virtual]
virtual bool SDKSample::ShareSource::sealed::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [override, protected, virtual]
virtual bool SDKSample::ShareSource::sealed::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [override, protected, virtual]
virtual bool SDKSample::ShareSource::sealed::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [override, protected, virtual]
virtual bool SDKSample::ShareSource::sealed::GetShareContent ( Windows::ApplicationModel::DataTransfer::DataRequest^ request ) [override, protected, virtual]
void SDKSample::ShareSource::sealed::OnDeferredImageRequestedHandler ( Windows::ApplicationModel::DataTransfer::DataProviderRequest^ request ) [private]
void SDKSample::ShareSource::sealed::SelectFilesButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ShareSource::sealed::SelectImageButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ShareSource::sealed::SelectImageButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ShareSource::sealed::SetErrorMessage ( )
SDKSample::ShareSource::sealed::ShareCustomData ( )
SDKSample::ShareSource::sealed::ShareDelayRenderedFiles ( )
SDKSample::ShareSource::sealed::ShareFiles ( )
SDKSample::ShareSource::sealed::ShareHtml ( )
SDKSample::ShareSource::sealed::ShareImage ( )
SDKSample::ShareSource::sealed::ShareLink ( )
SDKSample::ShareSource::sealed::ShareText ( )
void SDKSample::ShareSource::sealed::ShareWebView_LoadCompleted | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
Windows::Foundation::Uri SDKSample::ShareSource::sealed::ValidateAndGetUri ( Platform::String^ uriString ) [private]

Member Data Documentation

Windows::Storage::StorageFile sealed::imageFile [private]

Definition at line 38 of file ShareDelayRenderedFiles.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 37 of file ShareDelayRenderedFiles.xaml.h.

Windows::Foundation::Collections::IVectorView<Windows::Storage::StorageFile^> SDKSample::ShareSource::sealed::storageItems [private]

Definition at line 37 of file ShareFiles.xaml.h.

The documentation for this class was generated from the following files:
  • Sharing content source app/C++/SetErrorMessage.xaml.h
  • Sharing content source app/C++/ShareDelayRenderedFiles.xaml.h
  • Sharing content source app/C++/ShareFiles.xaml.h
  • Sharing content source app/C++/ShareImage.xaml.h
  • Sharing content source app/C++/ShareLink.xaml.h
  • Sharing content source app/C++/ShareCustomData.xaml.h
  • Sharing content source app/C++/ShareHtml.xaml.h
  • Sharing content source app/C++/ShareText.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SimpleOrientationSensorCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SimpleOrientationSensorCPP
  • SDKSample::SimpleOrientationSensorCPP::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::SimpleOrientationSensorCPP::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisplayOrientation (Windows::Devices::Sensors::SimpleOrientation orientation)
void | DisplayOrientation (Windows::Devices::Sensors::SimpleOrientation orientation)
void | OrientationChanged (Windows::Devices::Sensors::SimpleOrientationSensor^sender, Windows::Devices::Sensors::SimpleOrientationSensorOrientationChangedEventArgs^e)
void | ScenarioDisable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioEnable (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ScenarioGet (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | VisibilityChanged (Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | orientationToken
MainPage rootPage
Windows::Devices::Sensors::SimpleOrientationSensor | sensor
Windows::Foundation::EventRegistrationToken | visibilityToken

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::SimpleOrientationSensorCPP::sealed::DisplayOrientation ( Windows::Devices::Sensors::SimpleOrientation orientation ) [private]
void SDKSample::SimpleOrientationSensorCPP::sealed::DisplayOrientation ( Windows::Devices::Sensors::SimpleOrientation orientation ) [private]
virtual void SDKSample::SimpleOrientationSensorCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SimpleOrientationSensorCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SimpleOrientationSensorCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::SimpleOrientationSensorCPP::sealed::OrientationChanged | ( | Windows::Devices::Sensors::SimpleOrientationSensor^ | sender,
 |  | Windows::Devices::Sensors::SimpleOrientationSensorOrientationChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::SimpleOrientationSensorCPP::sealed::Scenario1 ( )
SDKSample::SimpleOrientationSensorCPP::sealed::Scenario2 ( )
void SDKSample::SimpleOrientationSensorCPP::sealed::ScenarioDisable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SimpleOrientationSensorCPP::sealed::ScenarioEnable | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SimpleOrientationSensorCPP::sealed::ScenarioGet | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SimpleOrientationSensorCPP::sealed::VisibilityChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken SDKSample::SimpleOrientationSensorCPP::sealed::orientationToken [private]

Definition at line 43 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

Windows::Devices::Sensors::SimpleOrientationSensor sealed::sensor [private]

Definition at line 41 of file Scenario1.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::SimpleOrientationSensorCPP::sealed::visibilityToken [private]

Definition at line 42 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • SimpleOrientationSensor/C++/Scenario1.xaml.h
  • SimpleOrientationSensor/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SnapSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SnapSample
  • SDKSample::SnapSample::sealed
Public Member Functions | Private Member Functions | Private Attributes

SDKSample::SnapSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()

Private Member Functions

Platform::String | ConvertViewState (Windows::UI::ViewManagement::ApplicationViewState state)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | UnsnapButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateForViewState ()

Private Attributes

Windows::Foundation::EventRegistrationToken | _layoutHandlerToken

Detailed Description

Definition at line 29 of file Scenario1.xaml.h.

Member Function Documentation

Platform::String SDKSample::SnapSample::sealed::ConvertViewState ( Windows::UI::ViewManagement::ApplicationViewState state ) [private]
void SDKSample::SnapSample::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::SnapSample::sealed::Scenario1 ( )
void SDKSample::SnapSample::sealed::UnsnapButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SnapSample::sealed::UpdateForViewState ( ) [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken SDKSample::SnapSample::sealed::_layoutHandlerToken [private]

Definition at line 40 of file Scenario1.xaml.h.

The documentation for this class was generated from the following file:
  • Snap/C++/Scenario1.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SplashScreen::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SplashScreen
  • SDKSample::SplashScreen::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::SplashScreen::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "ExtendedSplash.xaml.h"

List of all members.

Public Member Functions

ExtendedSplash (Windows::ApplicationModel::Activation::SplashScreen^splash, bool loadState)
Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DismissedEventHandler (Windows::ApplicationModel::Activation::SplashScreen^sender, Object^e)
void | ExtendedSplash_OnResize (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | LearnMoreButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PositionImage ()

Private Attributes

internal | __pad0__: Windows::Foundation::Rect splashImageRect
bool | dismissed
Windows::UI::Xaml::Controls::Frame | rootFrame
Windows::ApplicationModel::Activation::SplashScreen | splash

Detailed Description

Definition at line 19 of file ExtendedSplash.xaml.h.

Member Function Documentation

void SDKSample::SplashScreen::sealed::DismissedEventHandler | ( | Windows::ApplicationModel::Activation::SplashScreen^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
SDKSample::SplashScreen::sealed::ExtendedSplash | ( | Windows::ApplicationModel::Activation::SplashScreen^ | splash,
 |  | bool | loadState
 | ) |  |
void SDKSample::SplashScreen::sealed::ExtendedSplash_OnResize | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::SplashScreen::sealed::LearnMoreButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::SplashScreen::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::SplashScreen::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::SplashScreen::sealed::PositionImage ( ) [private]
SDKSample::SplashScreen::sealed::Scenario1 ( )
SDKSample::SplashScreen::sealed::Scenario2 ( )

Member Data Documentation

internal SDKSample::SplashScreen::sealed::__pad0__ [private]

Definition at line 32 of file ExtendedSplash.xaml.h.

bool SDKSample::SplashScreen::sealed::dismissed [private]

Definition at line 33 of file ExtendedSplash.xaml.h.

Windows::UI::Xaml::Controls::Frame SDKSample::SplashScreen::sealed::rootFrame [private]

Definition at line 34 of file ExtendedSplash.xaml.h.

Windows::ApplicationModel::Activation::SplashScreen SDKSample::SplashScreen::sealed::splash [private]

Definition at line 25 of file ExtendedSplash.xaml.h.

The documentation for this class was generated from the following files:
  • Splash screen/C++/ExtendedSplash.xaml.h
  • Splash screen/C++/Scenario1.xaml.h
  • Splash screen/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Status Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::Status
Static Public Attributes

SDKSample::Status Class Reference

#include "Constants.h"

List of all members.

Static Public Attributes

static Platform::String | FileAdded = "File added to the basket."
static Platform::String | FileAddFailed = "Couldn't add file to the basket."
static Platform::String | FileRemoved = "File removed from the basket."

Detailed Description

Definition at line 28 of file Constants.h.

Member Data Documentation

String Status::FileAdded = "File added to the basket." [static]

Definition at line 31 of file Constants.h.

String Status::FileAddFailed = "Couldn't add file to the basket." [static]

Definition at line 33 of file Constants.h.

String Status::FileRemoved = "File removed from the basket." [static]

Definition at line 32 of file Constants.h.

The documentation for this class was generated from the following files:
  • File picker contracts/C++/Constants.h
  • File picker contracts/C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::StoreSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • StoreSample
  • SDKSample::StoreSample::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::StoreSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "AppListingUri.xaml.h"

List of all members.

Public Member Functions

AppListingUri ()
ExpiringProduct ()
InAppPurchase ()
Receipt ()
TrialMode ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override

Private Member Functions

void | AppListingUriRefreshScenario ()
void | BuyProduct1Button_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | BuyProduct2_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ConvertTrial_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisplayLink_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ExpiringProductRefreshScenario ()
void | FullProduct_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InAppPurchaseRefreshScenario ()
void | LoadAppListingUriProxyFile ()
void | LoadExpiringProductProxyFile ()
void | LoadInAppPurchaseProxyFile ()
void | LoadReceiptProxyFile ()
void | LoadTrialModeProxyFile ()
void | ReceiptRefreshScenario ()
void | ShowReceipt_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TrialModeRefreshScenario ()
void | TrialProduct_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TrialTime_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TryProduct1_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TryProduct2_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | eventRegistrationToken
MainPage rootPage

Detailed Description

Definition at line 30 of file AppListingUri.xaml.h.

Member Function Documentation

SDKSample::StoreSample::sealed::AppListingUri ( )
void SDKSample::StoreSample::sealed::AppListingUriRefreshScenario ( ) [private]
void SDKSample::StoreSample::sealed::BuyProduct1Button_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::StoreSample::sealed::BuyProduct2_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::StoreSample::sealed::ConvertTrial_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::StoreSample::sealed::DisplayLink_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::StoreSample::sealed::ExpiringProduct ( )
void SDKSample::StoreSample::sealed::ExpiringProductRefreshScenario ( ) [private]
void SDKSample::StoreSample::sealed::FullProduct_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::StoreSample::sealed::InAppPurchase ( )
void SDKSample::StoreSample::sealed::InAppPurchaseRefreshScenario ( ) [private]
void SDKSample::StoreSample::sealed::LoadAppListingUriProxyFile ( ) [private]
void SDKSample::StoreSample::sealed::LoadExpiringProductProxyFile ( ) [private]
void SDKSample::StoreSample::sealed::LoadInAppPurchaseProxyFile ( ) [private]
void SDKSample::StoreSample::sealed::LoadReceiptProxyFile ( ) [private]
void SDKSample::StoreSample::sealed::LoadTrialModeProxyFile ( ) [private]
virtual void SDKSample::StoreSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::StoreSample::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
SDKSample::StoreSample::sealed::Receipt ( )
void SDKSample::StoreSample::sealed::ReceiptRefreshScenario ( ) [private]
void SDKSample::StoreSample::sealed::ShowReceipt_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::StoreSample::sealed::TrialMode ( )
void SDKSample::StoreSample::sealed::TrialModeRefreshScenario ( ) [private]
void SDKSample::StoreSample::sealed::TrialProduct_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::StoreSample::sealed::TrialTime_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::StoreSample::sealed::TryProduct1_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::StoreSample::sealed::TryProduct2_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken sealed::eventRegistrationToken [private]

Definition at line 40 of file AppListingUri.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 39 of file AppListingUri.xaml.h.

The documentation for this class was generated from the following files:
  • Trial app and in-app purchase/C++/AppListingUri.xaml.h
  • Trial app and in-app purchase/C++/ExpiringProduct.xaml.h
  • Trial app and in-app purchase/C++/InAppPurchase.xaml.h
  • Trial app and in-app purchase/C++/Receipt.xaml.h
  • Trial app and in-app purchase/C++/TrialMode.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::StringHelper Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::StringHelper
Static Public Member Functions

SDKSample::StringHelper Class Reference

#include "Constants.h"

List of all members.

Static Public Member Functions

static Platform::String | Join (Platform::String^separator, Windows::Foundation::Collections::IVectorView< Platform::String^>^iv)
static Platform::String | Trim (Platform::String^s)

Detailed Description

Definition at line 102 of file Constants.h.

Member Function Documentation

static Platform::String SDKSample::StringHelper::Join | ( | Platform::String^ | separator,
 |  | Windows::Foundation::Collections::IVectorView< Platform::String^>^ | iv |
 | ) |  |  | [inline, static]

Definition at line 123 of file Constants.h.

        {
            const std::wstring sep(separator->Begin(), separator->End());
            std::wstring ret;

            for (unsigned int i = 0, n = iv->Size; i < n; ++i)
            {
                if (i > 0)
                {
                    ret += sep;
                }

                Platform::String^ elem = iv->GetAt(i);

                ret.append(elem->Begin(), elem->End());
            }

            return ref new Platform::String(ret.data(), ret.size());
        }

static Platform::String SDKSample::StringHelper::Trim ( Platform::String^ s ) [inline, static]

Definition at line 105 of file Constants.h.

        {
            const WCHAR* first = s->Begin();
            const WCHAR* last = s->End();

            while (first != last && iswspace(*first))
            {
                ++first;
            }

            while (first != last && iswspace(last[-1]))
            {
                --last;
            }

            return ref new Platform::String(first, last - first);
        }

The documentation for this class was generated from the following file:
  • AtomPub/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::StringTrimmer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • SDKSample::StringTrimmer
Static Public Member Functions

SDKSample::StringTrimmer Class Reference

#include "Constants.h"

List of all members.

Static Public Member Functions

static Platform::String | Trim (Platform::String^s)
static Platform::String | Trim (Platform::String^s)
static Platform::String | Trim (Platform::String^s)

Detailed Description

Definition at line 67 of file Constants.h.

Member Function Documentation

static Platform::String SDKSample::StringTrimmer::Trim ( Platform::String^ s ) [inline, static]

Definition at line 70 of file Constants.h.

        {
            const WCHAR* first = s->Begin();
            const WCHAR* last = s->End();

            while (first != last && iswspace(*first))
            {
                ++first;
            }

            while (first != last && iswspace(last[-1]))
            {
                --last;
            }

            return ref new Platform::String(first, last - first);
        }

static Platform::String SDKSample::StringTrimmer::Trim ( Platform::String^ s ) [inline, static]

Definition at line 72 of file Constants.h.

        {
            const WCHAR* first = s->Begin();
            const WCHAR* last = s->End();

            while (first != last && iswspace(*first))
            {
                ++first;
            }

            while (first != last && iswspace(last[-1]))
            {
                --last;
            }

            return ref new Platform::String(first, last - first);
        }

static Platform::String SDKSample::StringTrimmer::Trim ( Platform::String^ s ) [inline, static]

Definition at line 96 of file Constants.h.

        {
            const WCHAR* first = s->Begin();
            const WCHAR* last = s->End();

            while (first != last && iswspace(*first))
            {
                ++first;
            }

            while (first != last && iswspace(last[-1]))
            {
                --last;
            }

            return ref new Platform::String(first, last - first);
        }

The documentation for this class was generated from the following files:
  • Background Transfer/C++/Constants.h
  • Connecting with WebSockets/C++/Constants.h
  • Syndication/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Syndication::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Syndication
  • SDKSample::Syndication::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Syndication::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()

Protected Member Functions

virtual void | OnNavigatedTo (NavigationEventArgs^e) override

Private Member Functions

void | DisplayCurrentItem ()
void | DisplayFeed ()
void | GetFeed_Click (Object^sender, RoutedEventArgs^e)
void | LinkField_Click (Object^sender, RoutedEventArgs^e)
void | NextItem_Click (Object^sender, RoutedEventArgs^e)
void | PreviousItem_Click (Object^sender, RoutedEventArgs^e)

Private Attributes

SyndicationFeed | currentFeed
unsigned int | currentItemIndex
MainPage rootPage

Detailed Description

Definition at line 35 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::Syndication::sealed::DisplayCurrentItem ( ) [private]
void SDKSample::Syndication::sealed::DisplayFeed ( ) [private]
void SDKSample::Syndication::sealed::GetFeed_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Syndication::sealed::LinkField_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Syndication::sealed::NextItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::Syndication::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Syndication::sealed::PreviousItem_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Syndication::sealed::Scenario1 ( )

Member Data Documentation

SyndicationFeed SDKSample::Syndication::sealed::currentFeed [private]

Definition at line 44 of file Scenario1.xaml.h.

unsigned int SDKSample::Syndication::sealed::currentItemIndex [private]

Definition at line 45 of file Scenario1.xaml.h.

MainPage SDKSample::Syndication::sealed::rootPage [private]

Definition at line 43 of file Scenario1.xaml.h.

The documentation for this class was generated from the following file:
  • Syndication/C++/Scenario1.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::TextDisplay::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • TextDisplay
  • SDKSample::TextDisplay::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::TextDisplay::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoSomething_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::TextDisplay::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextDisplay::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextDisplay::sealed::DoSomething_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextDisplay::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::TextDisplay::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextDisplay::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextDisplay::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextDisplay::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::TextDisplay::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextDisplay::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::TextDisplay::sealed::Scenario1 ( )
SDKSample::TextDisplay::sealed::Scenario2 ( )
SDKSample::TextDisplay::sealed::Scenario3 ( )
SDKSample::TextDisplay::sealed::Scenario4 ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML text display/C++/Scenario1.xaml.h
  • XAML text display/C++/Scenario2.xaml.h
  • XAML text display/C++/Scenario3.xaml.h
  • XAML text display/C++/Scenario4.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::TextEditing::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • TextEditing
  • SDKSample::TextEditing::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::TextEditing::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()
Scenario6 ()
Scenario7 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | BoldButtonClick (Object^sender, RoutedEventArgs^e)
void | ClearAllHighlightedWords ()
void | ColorButtonClick (Object^sender, RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoSomething_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | FindAndHighlightText (String^textToFind)
void | FindBoxGotFocus (Object^sender, RoutedEventArgs^e)
void | FindBoxLostFocus (Object^sender, RoutedEventArgs^e)
void | FindBoxTextChanged (Object^sender, Windows::UI::Xaml::Controls::TextChangedEventArgs^e)
void | FontColorButtonClick (Object^sender, RoutedEventArgs^e)
void | FontColorButtonLostFocus (Object^sender, RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ItalicButtonClick (Object^sender, RoutedEventArgs^e)
void | LoadContentAsync ()
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

vector< ITextRange^> | m_highlightedWords
MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::TextEditing::sealed::BoldButtonClick | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::ClearAllHighlightedWords ( ) [private]
void SDKSample::TextEditing::sealed::ColorButtonClick | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::DoSomething_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::FindAndHighlightText ( String^ textToFind ) [private]
void SDKSample::TextEditing::sealed::FindBoxGotFocus | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::FindBoxLostFocus | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::FindBoxTextChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::TextChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::FontColorButtonClick | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::FontColorButtonLostFocus | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::ItalicButtonClick | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::LoadContentAsync ( ) [private]
virtual void SDKSample::TextEditing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextEditing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextEditing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextEditing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextEditing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextEditing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TextEditing::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::TextEditing::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::TextEditing::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::TextEditing::sealed::Scenario1 ( )
SDKSample::TextEditing::sealed::Scenario2 ( )
SDKSample::TextEditing::sealed::Scenario3 ( )
SDKSample::TextEditing::sealed::Scenario4 ( )
SDKSample::TextEditing::sealed::Scenario5 ( )
SDKSample::TextEditing::sealed::Scenario6 ( )
SDKSample::TextEditing::sealed::Scenario7 ( )

Member Data Documentation

vector<ITextRange^> SDKSample::TextEditing::sealed::m_highlightedWords [private]

Definition at line 64 of file Scenario6.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML text editing/C++/Scenario1.xaml.h
  • XAML text editing/C++/Scenario2.xaml.h
  • XAML text editing/C++/Scenario3.xaml.h
  • XAML text editing/C++/Scenario4.xaml.h
  • XAML text editing/C++/Scenario5.xaml.h
  • XAML text editing/C++/Scenario6.xaml.h
  • XAML text editing/C++/Scenario7.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ThreadPool::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ThreadPool
  • SDKSample::ThreadPool::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::ThreadPool::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "DelayTimerScenario.xaml.h"

List of all members.

Public Member Functions

DelayTimerScenario ()
PeriodicTimerScenario ()
void | UpdateUI (ThreadPool::Status status)
void | UpdateUI (ThreadPool::Status status)
void | UpdateUI (ThreadPool::Status status)
void | UpdateWorkItemProgressUI (int percentComplete)
WorkItemScenario ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CancelDelayTimer (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CancelPeriodicTimer (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CancelThreadPoolWorkItem (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CreateDelayTimer (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CreatePeriodicTimer (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CreateThreadPoolWorkItem (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 31 of file DelayTimerScenario.xaml.h.

Member Function Documentation

void SDKSample::ThreadPool::sealed::CancelDelayTimer | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ThreadPool::sealed::CancelPeriodicTimer | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ThreadPool::sealed::CancelThreadPoolWorkItem | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ThreadPool::sealed::CreateDelayTimer | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ThreadPool::sealed::CreatePeriodicTimer | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::ThreadPool::sealed::CreateThreadPoolWorkItem | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::ThreadPool::sealed::DelayTimerScenario ( )
virtual void SDKSample::ThreadPool::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ThreadPool::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ThreadPool::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ThreadPool::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ThreadPool::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::ThreadPool::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::ThreadPool::sealed::PeriodicTimerScenario ( )
void SDKSample::ThreadPool::sealed::UpdateUI ( ThreadPool::Status status )
void SDKSample::ThreadPool::sealed::UpdateUI ( ThreadPool::Status status )
void SDKSample::ThreadPool::sealed::UpdateUI ( ThreadPool::Status status )
void SDKSample::ThreadPool::sealed::UpdateWorkItemProgressUI ( int percentComplete )
SDKSample::ThreadPool::sealed::WorkItemScenario ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 41 of file DelayTimerScenario.xaml.h.

The documentation for this class was generated from the following files:
  • Thread pool/C++/DelayTimerScenario.xaml.h
  • Thread pool/C++/PeriodicTimerScenario.xaml.h
  • Thread pool/C++/WorkItemScenario.xaml.h
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ThreadPool::ThreadPoolSample Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • ThreadPool
  • SDKSample::ThreadPool::ThreadPoolSample
Static Public Member Functions

SDKSample::ThreadPool::ThreadPoolSample Struct Reference

#include "Constants.h"

List of all members.

Static Public Member Functions

static Platform::String GetStatusString (ThreadPool::Status status)
static
Windows::Foundation::TimeSpan 		MillisecondsToTimeSpan (long milliseconds)

Detailed Description

Definition at line 54 of file Constants.h.

Member Function Documentation

Platform::String ThreadPoolSample::GetStatusString ( ThreadPool::Status status ) [static]

Definition at line 35 of file Constants.cpp.

{
    switch (status)
    {
    case SDKSample::ThreadPool::Status::Unregistered:
        return "Unregistered";
        break;
    case SDKSample::ThreadPool::Status::Started:
        return "Started";
        break;
    case SDKSample::ThreadPool::Status::Canceled:
        return "Canceled";
        break;
    case SDKSample::ThreadPool::Status::Completed:
        return "Completed";
        break;
    default:
        return "Error";
        break;
    }
}

Windows::Foundation::TimeSpan ThreadPoolSample::MillisecondsToTimeSpan ( long milliseconds ) [static]

Definition at line 57 of file Constants.cpp.

{
    Windows::Foundation::TimeSpan time;
    time.Duration = milliseconds * 10000;
    return time;
}

The documentation for this struct was generated from the following files:
  • Thread pool/C++/Constants.h
  • Thread pool/C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Tiles::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Tiles
  • SDKSample::Tiles::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Tiles::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "EnableNotificationQueue.xaml.h"

List of all members.

Public Member Functions

EnableNotificationQueue ()
Globalization ()
ImageProtocols ()
NotificationExpiration ()
SendBadge ()
SendLocalImageTile ()
SendTextTile ()
SendWebImageTile ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ClearBadge_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ClearTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ClearTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ClearTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ClearTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DisableNotificationQueue_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | EnableNotificationQueue_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | NumberOrGlyph_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | PickImage_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ProtocolList_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | SendTileNotification_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendTileNotificationImage_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendTileNotificationText_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendTileNotificationWithQueryStrings_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateBadge_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateBadgeWithGlyph (int glyphIndex)
void | UpdateBadgeWithGlyphWithStringManipulation ()
void | UpdateBadgeWithNumber (int number)
void | UpdateBadgeWithNumberWithStringManipulation (int number)
void | UpdateTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateTileExpiring_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateTileWithImage_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateTileWithImageWithStringManipulation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateTileWithText_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateTileWithTextWithStringManipulation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateTileWithWebImage_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateTileWithWebImageWithStringManipulation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ViewCurrentResources_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Platform::String | imageRelativePath
MainPage rootPage

Detailed Description

Definition at line 30 of file EnableNotificationQueue.xaml.h.

Member Function Documentation

void SDKSample::Tiles::sealed::ClearBadge_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::ClearTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::ClearTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::ClearTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::ClearTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::DisableNotificationQueue_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Tiles::sealed::EnableNotificationQueue ( )
void SDKSample::Tiles::sealed::EnableNotificationQueue_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Tiles::sealed::Globalization ( )
SDKSample::Tiles::sealed::ImageProtocols ( )
SDKSample::Tiles::sealed::NotificationExpiration ( )
void SDKSample::Tiles::sealed::NumberOrGlyph_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::Tiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Tiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Tiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Tiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Tiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Tiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Tiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Tiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Tiles::sealed::PickImage_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::ProtocolList_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Tiles::sealed::SendBadge ( )
SDKSample::Tiles::sealed::SendLocalImageTile ( )
SDKSample::Tiles::sealed::SendTextTile ( )
void SDKSample::Tiles::sealed::SendTileNotification_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::SendTileNotificationImage_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::SendTileNotificationText_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::SendTileNotificationWithQueryStrings_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Tiles::sealed::SendWebImageTile ( )
void SDKSample::Tiles::sealed::UpdateBadge_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::UpdateBadgeWithGlyph ( int glyphIndex ) [private]
void SDKSample::Tiles::sealed::UpdateBadgeWithGlyphWithStringManipulation ( ) [private]
void SDKSample::Tiles::sealed::UpdateBadgeWithNumber ( int number ) [private]
void SDKSample::Tiles::sealed::UpdateBadgeWithNumberWithStringManipulation ( int number ) [private]
void SDKSample::Tiles::sealed::UpdateTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::UpdateTileExpiring_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::UpdateTileWithImage_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::UpdateTileWithImageWithStringManipulation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::UpdateTileWithText_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::UpdateTileWithTextWithStringManipulation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::UpdateTileWithWebImage_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::UpdateTileWithWebImageWithStringManipulation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Tiles::sealed::ViewCurrentResources_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Platform::String SDKSample::Tiles::sealed::imageRelativePath [private]

Definition at line 39 of file ImageProtocols.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file EnableNotificationQueue.xaml.h.

The documentation for this class was generated from the following files:
  • App tiles and badges/C#,C++/EnableNotificationQueue.xaml.h
  • App tiles and badges/C#,C++/Globalization.xaml.h
  • App tiles and badges/C#,C++/ImageProtocols.xaml.h
  • App tiles and badges/C#,C++/NotificationExpiration.xaml.h
  • App tiles and badges/C#,C++/SendBadge.xaml.h
  • App tiles and badges/C#,C++/SendLocalImageTile.xaml.h
  • App tiles and badges/C#,C++/SendTextTile.xaml.h
  • App tiles and badges/C#,C++/SendWebImageTile.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::TouchKeyboard::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • TouchKeyboard
  • SDKSample::TouchKeyboard::sealed
Public Member Functions | Public Attributes | Protected Member Functions | Private Attributes

SDKSample::TouchKeyboard::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame. More...

#include "Launch.xaml.h"

List of all members.

Public Member Functions

virtual void | AddToSelection ()
virtual
Windows::UI::Xaml::Automation::Provider::ITextRangeProvider 		Clone ()
virtual bool | Compare (Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^textRangeProvider)
virtual int | CompareEndpoints (Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint endpoint, Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^textRangeProvider, Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint targetEndpoint)
CustomTextBox ()
virtual void | ExpandToEnclosingUnit (Windows::UI::Xaml::Automation::Text::TextUnit unit)
virtual
Windows::UI::Xaml::Automation::Provider::ITextRangeProvider 		FindAttribute (int attributeId, Platform::Object^value, bool backward)
virtual
Windows::UI::Xaml::Automation::Provider::ITextRangeProvider 		FindText (Platform::String^text, bool backward, bool ignoreCase)
virtual Platform::Object | GetAttributeValue (int attributeId)
virtual void | GetBoundingRectangles (Platform::Array< double >^*returnValue)
virtual Platform::Array
< Windows::UI::Xaml::Automation::Provider::IRawElementProviderSimple^> 		GetChildren ()
virtual
Windows::UI::Xaml::Automation::Provider::IRawElementProviderSimple 		GetEnclosingElement ()
virtual Platform::String | GetText (int maxLength)
Launch ()
virtual int | Move (Windows::UI::Xaml::Automation::Text::TextUnit unit, int count)
virtual void | MoveEndpointByRange (Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint endpoint, Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^textRangeProvider, Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint targetEndpoint)
virtual int | MoveEndpointByUnit (Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint endpoint, Windows::UI::Xaml::Automation::Text::TextUnit unit, int count)
NonTouchableTextBlock ()
NonTouchableTextBlockAutomationPeer (NonTouchableTextBlock^owner)
virtual void | RemoveFromSelection ()
virtual void | ScrollIntoView (bool alignToTop)
virtual void | Select ()
void | set (Platform::String^text)
TouchableTextBlock ()
TouchableTextBlockAutomationPeer (TouchableTextBlock^owner)
TouchableTextBlockRangeProvider (Platform::String^text, TouchableTextBlockAutomationPeer^peer)

Public Attributes

internal | __pad0__: virtual property Platform::String^ ContentText { Platform::String^ get() {return contentText

Protected Member Functions

virtual String | GetClassNameCore () override
virtual String | GetClassNameCore () override
virtual Object | GetPatternCore (PatternInterface patternInterface) override
virtual
Windows::UI::Xaml::Automation::Peers::AutomationPeer 		OnCreateAutomationPeer () override
virtual
Windows::UI::Xaml::Automation::Peers::AutomationPeer 		OnCreateAutomationPeer () override
virtual void | OnGotFocus (Windows::UI::Xaml::RoutedEventArgs^e) override
virtual void | OnGotFocus (Windows::UI::Xaml::RoutedEventArgs^e) override
virtual void | OnKeyDown (Windows::UI::Xaml::Input::KeyRoutedEventArgs^e) override
virtual void | OnKeyDown (Windows::UI::Xaml::Input::KeyRoutedEventArgs^e) override
virtual void | OnLostFocus (Windows::UI::Xaml::RoutedEventArgs^e) override
virtual void | OnLostFocus (Windows::UI::Xaml::RoutedEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnTapped (Windows::UI::Xaml::Input::TappedRoutedEventArgs^e) override
virtual void | OnTapped (Windows::UI::Xaml::Input::TappedRoutedEventArgs^e) override

Private Attributes

TouchableTextBlockAutomationPeer | _peer
Platform::String | _text
String | accClass
Platform::String | contentText
MainPage rootPage
NonTouchableTextBlock | textBlock

Detailed Description

A minimal implementation of ITextRangeProvider, used by TouchableTextBlockAutomationPeer A real implementation is beyond the scope of this sample.

Automation Peer class for TouchableTextBlock.

Automation Peer class for NonTouchableTextBlock.

Custom Text box control derived from Textbox class.

Note: The difference between this and TouchableTextBlockAutomationPeer is that this one does not implement Text Pattern (ITextProvider) and Value Pattern (IValuePattern) interfaces. So Touch keyboard does not show automatically when user taps on the control with Touch or Pen.

Note: The difference between this and NonTouchableTextBlockAutomationPeer is that this one implements Text Pattern (ITextProvider) and Value Pattern (IValuePattern) interfaces. So Touch keyboard shows automatically when user taps on the control with Touch or Pen.

Definition at line 30 of file Launch.xaml.h.

Member Function Documentation

virtual void SDKSample::TouchKeyboard::sealed::AddToSelection ( ) [virtual]
virtual Windows::UI::Xaml::Automation::Provider::ITextRangeProvider SDKSample::TouchKeyboard::sealed::Clone ( ) [virtual]
virtual bool SDKSample::TouchKeyboard::sealed::Compare ( Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ textRangeProvider ) [virtual]
virtual int SDKSample::TouchKeyboard::sealed::CompareEndpoints | ( | Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint | endpoint,
 |  | Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ | textRangeProvider,
 |  | Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint | targetEndpoint |
 | ) |  |  | [virtual]
SDKSample::TouchKeyboard::sealed::CustomTextBox ( ) [inline]

Definition at line 47 of file Launch.xaml.h.

            {
                this->Background = ref new Windows::UI::Xaml::Media::SolidColorBrush(Windows::UI::Colors::Coral);
                this->BorderThickness = Windows::UI::Xaml::Thickness(1);
                this->HorizontalAlignment = Windows::UI::Xaml::HorizontalAlignment::Center;
            }

virtual void SDKSample::TouchKeyboard::sealed::ExpandToEnclosingUnit ( Windows::UI::Xaml::Automation::Text::TextUnit unit ) [virtual]
virtual Windows::UI::Xaml::Automation::Provider::ITextRangeProvider SDKSample::TouchKeyboard::sealed::FindAttribute | ( | int | attributeId,
 |  | Platform::Object^ | value,
 |  | bool | backward |
 | ) |  |  | [virtual]
virtual Windows::UI::Xaml::Automation::Provider::ITextRangeProvider SDKSample::TouchKeyboard::sealed::FindText | ( | Platform::String^ | text,
 |  | bool | backward,
 |  | bool | ignoreCase |
 | ) |  |  | [virtual]
virtual Platform::Object SDKSample::TouchKeyboard::sealed::GetAttributeValue ( int attributeId ) [virtual]
virtual void SDKSample::TouchKeyboard::sealed::GetBoundingRectangles ( Platform::Array< double >^* returnValue ) [virtual]
virtual Platform::Array<Windows::UI::Xaml::Automation::Provider::IRawElementProviderSimple^> SDKSample::TouchKeyboard::sealed::GetChildren ( ) [virtual]
virtual String SDKSample::TouchKeyboard::sealed::GetClassNameCore ( ) [inline, override, protected, virtual]

Override GetClassNameCore and set the name of the class that defines the type associated with this control.

Returns:
The name of the control class

Definition at line 57 of file NonTouchableTextBlock.xaml.cpp.

        {
          return this->accClass;
        }

virtual String SDKSample::TouchKeyboard::sealed::GetClassNameCore ( ) [inline, override, protected, virtual]

Override GetClassNameCore and set the name of the class that defines the type associated with this control.

Returns:
The name of the control class

Definition at line 79 of file TouchableTextBlock.xaml.cpp.

        {
          return this->accClass;
        }

virtual Windows::UI::Xaml::Automation::Provider::IRawElementProviderSimple SDKSample::TouchKeyboard::sealed::GetEnclosingElement ( ) [virtual]
virtual Object SDKSample::TouchKeyboard::sealed::GetPatternCore ( PatternInterface patternInterface ) [inline, override, protected, virtual]

Override GetPatternCore to return the object that supports the specified pattern.

In this case the Value pattern, Text patter and any base class patterns.

Parameters:
patternInterface
Returns:
the object that supports the specified pattern

Definition at line 62 of file TouchableTextBlock.xaml.cpp.

        {
          if (patternInterface == PatternInterface::Value)
          {
            return this;
          }
          else if (patternInterface == PatternInterface::Text)
          {
            return this;
          }
          return FrameworkElementAutomationPeer::GetPatternCore(patternInterface);
        }

virtual Platform::String SDKSample::TouchKeyboard::sealed::GetText ( int maxLength ) [virtual]
SDKSample::TouchKeyboard::sealed::Launch ( )
virtual int SDKSample::TouchKeyboard::sealed::Move | ( | Windows::UI::Xaml::Automation::Text::TextUnit | unit,
 |  | int | count |
 | ) |  |  | [virtual]
virtual void SDKSample::TouchKeyboard::sealed::MoveEndpointByRange | ( | Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint | endpoint,
 |  | Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ | textRangeProvider,
 |  | Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint | targetEndpoint |
 | ) |  |  | [virtual]
virtual int SDKSample::TouchKeyboard::sealed::MoveEndpointByUnit | ( | Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint | endpoint,
 |  | Windows::UI::Xaml::Automation::Text::TextUnit | unit,
 |  | int | count |
 | ) |  |  | [virtual]
SDKSample::TouchKeyboard::sealed::NonTouchableTextBlock ( )
SDKSample::TouchKeyboard::sealed::NonTouchableTextBlockAutomationPeer ( NonTouchableTextBlock^ owner ) [inline]

Definition at line 46 of file NonTouchableTextBlock.xaml.cpp.

          : FrameworkElementAutomationPeer(owner)
        {
          this->textBlock = owner;
          this->accClass = "NonTouchableTextBlock";
        }

virtual Windows::UI::Xaml::Automation::Peers::AutomationPeer SDKSample::TouchKeyboard::sealed::OnCreateAutomationPeer ( ) [override, protected, virtual]
virtual Windows::UI::Xaml::Automation::Peers::AutomationPeer SDKSample::TouchKeyboard::sealed::OnCreateAutomationPeer ( ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnGotFocus ( Windows::UI::Xaml::RoutedEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnGotFocus ( Windows::UI::Xaml::RoutedEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnKeyDown ( Windows::UI::Xaml::Input::KeyRoutedEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnKeyDown ( Windows::UI::Xaml::Input::KeyRoutedEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnLostFocus ( Windows::UI::Xaml::RoutedEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnLostFocus ( Windows::UI::Xaml::RoutedEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnTapped ( Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::OnTapped ( Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::TouchKeyboard::sealed::RemoveFromSelection ( ) [virtual]
virtual void SDKSample::TouchKeyboard::sealed::ScrollIntoView ( bool alignToTop ) [virtual]
virtual void SDKSample::TouchKeyboard::sealed::Select ( ) [virtual]
void SDKSample::TouchKeyboard::sealed::set ( Platform::String^ text ) [inline]

Definition at line 29 of file TouchableTextBlock.xaml.h.

{contentText = text;}

SDKSample::TouchKeyboard::sealed::TouchableTextBlock ( )
SDKSample::TouchKeyboard::sealed::TouchableTextBlockAutomationPeer ( TouchableTextBlock^ owner ) [inline]

Definition at line 49 of file TouchableTextBlock.xaml.cpp.

          : FrameworkElementAutomationPeer(owner)
        {
          this->textBlock = owner;
          this->accClass = "TouchableTextBlock";
        }

SDKSample::TouchKeyboard::sealed::TouchableTextBlockRangeProvider | ( | Platform::String^ | text,
 |  | TouchableTextBlockAutomationPeer^ | peer
 | ) |  |

Member Data Documentation

internal SDKSample::TouchKeyboard::sealed::__pad0__

Definition at line 28 of file TouchableTextBlock.xaml.h.

TouchableTextBlockAutomationPeer SDKSample::TouchKeyboard::sealed::_peer [private]

Definition at line 86 of file TouchableTextBlock.xaml.h.

Platform::String SDKSample::TouchKeyboard::sealed::_text [private]

Definition at line 85 of file TouchableTextBlock.xaml.h.

String sealed::accClass [private]

Definition at line 64 of file NonTouchableTextBlock.xaml.cpp.

Platform::String SDKSample::TouchKeyboard::sealed::contentText [private]

Definition at line 42 of file TouchableTextBlock.xaml.h.

MainPage SDKSample::TouchKeyboard::sealed::rootPage [private]

Definition at line 38 of file Launch.xaml.h.

NonTouchableTextBlock SDKSample::TouchKeyboard::sealed::textBlock [private]

Definition at line 63 of file NonTouchableTextBlock.xaml.cpp.

The documentation for this class was generated from the following files:
  • Input Touch keyboard/C++/Launch.xaml.h
  • Input Touch keyboard/C++/NonTouchableTextBlock.xaml.cpp
  • Input Touch keyboard/C++/TouchableTextBlock.xaml.cpp
  • Input Touch keyboard/C++/TouchableTextBlock.xaml.h
  • Input Touch keyboard/C++/NonTouchableTextBlock.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::TouchKeyboardTextInput::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • TouchKeyboardTextInput
  • SDKSample::TouchKeyboardTextInput::sealed
Public Member Functions | Protected Member Functions | Private Attributes

SDKSample::TouchKeyboardTextInput::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "ScopedViews.xaml.h"

List of all members.

Public Member Functions

ScopedViews ()

Protected Member Functions

virtual void OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file ScopedViews.xaml.h.

Member Function Documentation

virtual void SDKSample::TouchKeyboardTextInput::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::TouchKeyboardTextInput::sealed::ScopedViews ( )

Member Data Documentation

MainPage SDKSample::TouchKeyboardTextInput::sealed::rootPage [private]

Definition at line 38 of file ScopedViews.xaml.h.

The documentation for this class was generated from the following file:
  • Input Touch keyboard text input/C++/ScopedViews.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Transcode::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Transcode
  • SDKSample::Transcode::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Transcode::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Custom.xaml.h"

List of all members.

Public Member Functions

Custom ()
Presets ()
Trim ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | DisableButtons ()
void | DisableButtons ()
void | DisableButtons ()
void | EnableButtons ()
void | EnableButtons ()
void | EnableButtons ()
void | GetCustomProfile ()
void | GetPresetProfile (Windows::UI::Xaml::Controls::ComboBox^comboBox)
void | GetPresetProfile (Windows::UI::Xaml::Controls::ComboBox^comboBox)
void | InputPauseButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InputPauseButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InputPauseButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InputPlayButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InputPlayButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InputPlayButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InputStopButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InputStopButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InputStopButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | MarkIn (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | MarkOut (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnTargetFormatChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | OnTargetFormatChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | OnTargetFormatChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | OutputPauseButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OutputPauseButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OutputPauseButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OutputPlayButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OutputPlayButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OutputPlayButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OutputStopButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OutputStopButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OutputStopButton_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickFile (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickFile (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PickFile (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PlayFile (Windows::Storage::StorageFile^MediaFile)
void | PlayFile (Windows::Storage::StorageFile^MediaFile)
void | PlayFile (Windows::Storage::StorageFile^MediaFile)
void | SetCancelButton (bool isEnabled)
void | SetCancelButton (bool isEnabled)
void | SetCancelButton (bool isEnabled)
void | SetPickFileButton (bool isEnabled)
void | SetPickFileButton (bool isEnabled)
void | SetPickFileButton (bool isEnabled)
void | StopPlayers ()
void | StopPlayers ()
void | StopPlayers ()
void | TranscodeCancel (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TranscodeCancel (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TranscodeCancel (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TranscodeComplete (Windows::Foundation::IAsyncActionWithProgress< double >^asyncInfo, Windows::Foundation::AsyncStatus status)
void | TranscodeCustom (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TranscodeError (Platform::String^error)
void | TranscodeError (Platform::String^error)
void | TranscodeError (Platform::String^error)
void | TranscodeFailure (Windows::Media::Transcoding::TranscodeFailureReason reason)
void | TranscodeFailure (Windows::Media::Transcoding::TranscodeFailureReason reason)
void | TranscodeFailure (Windows::Media::Transcoding::TranscodeFailureReason reason)
void | TranscodePreset (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | TranscodeProgress (Windows::Foundation::IAsyncActionWithProgress< double >^asyncInfo, double percent)
void | TranscodeProgress (Windows::Foundation::IAsyncActionWithProgress< double >^asyncInfo, double percent)
void | TranscodeProgress (Windows::Foundation::IAsyncActionWithProgress< double >^asyncInfo, double percent)
void | TranscodeTrim (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Concurrency::cancellation_token_source | _CTS
Windows::Storage::StorageFile | _InputFile
Windows::Storage::StorageFile | _OutputFile
Platform::String | _OutputFileName
Windows::Media::MediaProperties::MediaEncodingProfile | _Profile
Windows::Foundation::TimeSpan | _start
Windows::Foundation::TimeSpan | _stop
Windows::Media::Transcoding::MediaTranscoder | _Transcoder
boolean | _UseMp4
bool | _UseMp4
MainPage rootPage

Detailed Description

Definition at line 38 of file Custom.xaml.h.

Member Function Documentation

SDKSample::Transcode::sealed::Custom ( )
void SDKSample::Transcode::sealed::DisableButtons ( ) [private]
void SDKSample::Transcode::sealed::DisableButtons ( ) [private]
void SDKSample::Transcode::sealed::DisableButtons ( ) [private]
void SDKSample::Transcode::sealed::EnableButtons ( ) [private]
void SDKSample::Transcode::sealed::EnableButtons ( ) [private]
void SDKSample::Transcode::sealed::EnableButtons ( ) [private]
void SDKSample::Transcode::sealed::GetCustomProfile ( ) [private]
void SDKSample::Transcode::sealed::GetPresetProfile ( Windows::UI::Xaml::Controls::ComboBox^ comboBox ) [private]
void SDKSample::Transcode::sealed::GetPresetProfile ( Windows::UI::Xaml::Controls::ComboBox^ comboBox ) [private]
void SDKSample::Transcode::sealed::InputPauseButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::InputPauseButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::InputPauseButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::InputPlayButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::InputPlayButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::InputPlayButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::InputStopButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::InputStopButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::InputStopButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::MarkIn | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::MarkOut | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::Transcode::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Transcode::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Transcode::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Transcode::sealed::OnTargetFormatChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OnTargetFormatChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OnTargetFormatChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputPauseButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputPauseButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputPauseButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputPlayButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputPlayButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputPlayButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputStopButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputStopButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::OutputStopButton_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::PickFile | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::PickFile | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::PickFile | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::PlayFile ( Windows::Storage::StorageFile^ MediaFile ) [private]
void SDKSample::Transcode::sealed::PlayFile ( Windows::Storage::StorageFile^ MediaFile ) [private]
void SDKSample::Transcode::sealed::PlayFile ( Windows::Storage::StorageFile^ MediaFile ) [private]
SDKSample::Transcode::sealed::Presets ( )
void SDKSample::Transcode::sealed::SetCancelButton ( bool isEnabled ) [private]
void SDKSample::Transcode::sealed::SetCancelButton ( bool isEnabled ) [private]
void SDKSample::Transcode::sealed::SetCancelButton ( bool isEnabled ) [private]
void SDKSample::Transcode::sealed::SetPickFileButton ( bool isEnabled ) [private]
void SDKSample::Transcode::sealed::SetPickFileButton ( bool isEnabled ) [private]
void SDKSample::Transcode::sealed::SetPickFileButton ( bool isEnabled ) [private]
void SDKSample::Transcode::sealed::StopPlayers ( ) [private]
void SDKSample::Transcode::sealed::StopPlayers ( ) [private]
void SDKSample::Transcode::sealed::StopPlayers ( ) [private]
void SDKSample::Transcode::sealed::TranscodeCancel | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeCancel | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeCancel | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeComplete | ( | Windows::Foundation::IAsyncActionWithProgress< double >^ | asyncInfo,
 |  | Windows::Foundation::AsyncStatus | status |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeCustom | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeError ( Platform::String^ error ) [private]
void SDKSample::Transcode::sealed::TranscodeError ( Platform::String^ error ) [private]
void SDKSample::Transcode::sealed::TranscodeError ( Platform::String^ error ) [private]
void SDKSample::Transcode::sealed::TranscodeFailure ( Windows::Media::Transcoding::TranscodeFailureReason reason ) [private]
void SDKSample::Transcode::sealed::TranscodeFailure ( Windows::Media::Transcoding::TranscodeFailureReason reason ) [private]
void SDKSample::Transcode::sealed::TranscodeFailure ( Windows::Media::Transcoding::TranscodeFailureReason reason ) [private]
void SDKSample::Transcode::sealed::TranscodePreset | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeProgress | ( | Windows::Foundation::IAsyncActionWithProgress< double >^ | asyncInfo,
 |  | double | percent |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeProgress | ( | Windows::Foundation::IAsyncActionWithProgress< double >^ | asyncInfo,
 |  | double | percent |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeProgress | ( | Windows::Foundation::IAsyncActionWithProgress< double >^ | asyncInfo,
 |  | double | percent |
 | ) |  |  | [private]
void SDKSample::Transcode::sealed::TranscodeTrim | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Transcode::sealed::Trim ( )

Member Data Documentation

Concurrency::cancellation_token_source sealed::_CTS [private]

Definition at line 77 of file Custom.xaml.h.

Windows::Storage::StorageFile sealed::_InputFile [private]

Definition at line 74 of file Custom.xaml.h.

Windows::Storage::StorageFile sealed::_OutputFile [private]

Definition at line 75 of file Custom.xaml.h.

Platform::String sealed::_OutputFileName [private]

Definition at line 72 of file Custom.xaml.h.

Windows::Media::MediaProperties::MediaEncodingProfile sealed::_Profile [private]

Definition at line 73 of file Custom.xaml.h.

Windows::Foundation::TimeSpan SDKSample::Transcode::sealed::_start [private]

Definition at line 74 of file Trim.xaml.h.

Windows::Foundation::TimeSpan SDKSample::Transcode::sealed::_stop [private]

Definition at line 75 of file Trim.xaml.h.

Windows::Media::Transcoding::MediaTranscoder sealed::_Transcoder [private]

Definition at line 76 of file Custom.xaml.h.

bool sealed::_UseMp4 [private]

Definition at line 79 of file Custom.xaml.h.

bool SDKSample::Transcode::sealed::_UseMp4 [private]

Definition at line 69 of file Presets.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 81 of file Custom.xaml.h.

The documentation for this class was generated from the following files:
  • Transcoding media/C++/Custom.xaml.h
  • Transcoding media/C++/Presets.xaml.h
  • Transcoding media/C++/Trim.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Transforms::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • Transforms
  • SDKSample::Transforms::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::Transforms::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | rootPage_MainPageResized (Platform::Object^sender, MainPageSizeChangedEventArgs^e)
void | SetUpBinding (Windows::UI::Xaml::Controls::Slider^slider, Windows::UI::Xaml::DependencyProperty^dp)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

virtual void SDKSample::Transforms::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::Transforms::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::Transforms::sealed::rootPage_MainPageResized | ( | Platform::Object^ | sender,
 |  | MainPageSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::Transforms::sealed::Scenario1 ( )
SDKSample::Transforms::sealed::Scenario2 ( )
void SDKSample::Transforms::sealed::SetUpBinding | ( | Windows::UI::Xaml::Controls::Slider^ | slider,
 |  | Windows::UI::Xaml::DependencyProperty^ | dp |
 | ) |  |  | [private]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML two-dimensional transforms/C++/Scenario1.xaml.h
  • XAML two-dimensional transforms/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::UserAndCustomControls::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • UserAndCustomControls
  • SDKSample::UserAndCustomControls::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes | Static Private Attributes

SDKSample::UserAndCustomControls::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "BasicCustomControl.h"

List of all members.

Public Member Functions

BasicCustomControl ()
BasicUserControl ()
ImageWithLabelControl ()
Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | ClickMeButtonClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoSomething_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | NavigateDPHelp (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | NavigateToLink (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Static Private Attributes

static DependencyProperty | _ImagePathProperty
static DependencyProperty | _LabelProperty

Detailed Description

Definition at line 14 of file BasicCustomControl.h.

Member Function Documentation

SDKSample::UserAndCustomControls::sealed::BasicCustomControl ( )
SDKSample::UserAndCustomControls::sealed::BasicUserControl ( )
void SDKSample::UserAndCustomControls::sealed::ClickMeButtonClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::UserAndCustomControls::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::UserAndCustomControls::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::UserAndCustomControls::sealed::DoSomething_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::UserAndCustomControls::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::UserAndCustomControls::sealed::ImageWithLabelControl ( )
void SDKSample::UserAndCustomControls::sealed::NavigateDPHelp | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::UserAndCustomControls::sealed::NavigateToLink | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::UserAndCustomControls::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::UserAndCustomControls::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::UserAndCustomControls::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::UserAndCustomControls::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::UserAndCustomControls::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::UserAndCustomControls::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::UserAndCustomControls::sealed::Scenario1 ( )
SDKSample::UserAndCustomControls::sealed::Scenario2 ( )
SDKSample::UserAndCustomControls::sealed::Scenario3 ( )
SDKSample::UserAndCustomControls::sealed::Scenario4 ( )

Member Data Documentation

DependencyProperty SDKSample::UserAndCustomControls::sealed::_ImagePathProperty [static, private]

Definition at line 24 of file ImageWithLabelControl.h.

DependencyProperty SDKSample::UserAndCustomControls::sealed::_LabelProperty [static, private]

Definition at line 23 of file ImageWithLabelControl.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML user and custom controls/C++/BasicCustomControl.h
  • XAML user and custom controls/C++/ImageWithLabelControl.h
  • XAML user and custom controls/C++/Scenario1.xaml.h
  • XAML user and custom controls/C++/Scenario2.xaml.h
  • XAML user and custom controls/C++/Scenario3.xaml.h
  • XAML user and custom controls/C++/Scenario4.xaml.h
  • XAML user and custom controls/C++/BasicUserControl.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::UserDomainName::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • UserDomainName
  • SDKSample::UserDomainName::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::UserDomainName::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "GetDomainName.xaml.h"

List of all members.

Public Member Functions

GetDomainName ()
GetPrincipalName ()
GetSIPUri ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | GetDNSDomain_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetPrincipalName_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | GetUri_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file GetDomainName.xaml.h.

Member Function Documentation

void SDKSample::UserDomainName::sealed::GetDNSDomain_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::UserDomainName::sealed::GetDomainName ( )
SDKSample::UserDomainName::sealed::GetPrincipalName ( )
void SDKSample::UserDomainName::sealed::GetPrincipalName_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::UserDomainName::sealed::GetSIPUri ( )
void SDKSample::UserDomainName::sealed::GetUri_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::UserDomainName::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::UserDomainName::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::UserDomainName::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file GetDomainName.xaml.h.

The documentation for this class was generated from the following files:
  • User domain name/C++/GetDomainName.xaml.h
  • User domain name/C++/GetPrincipalName.xaml.h
  • User domain name/C++/GetSIPUri.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::UssdApi::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • UssdApi
  • SDKSample::UssdApi::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::UssdApi::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "RequestResponse.xaml.h"

List of all members.

Public Member Functions

RequestResponse ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | SendButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file RequestResponse.xaml.h.

Member Function Documentation

virtual void SDKSample::UssdApi::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::UssdApi::sealed::RequestResponse ( )
void SDKSample::UssdApi::sealed::SendButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

MainPage SDKSample::UssdApi::sealed::rootPage [private]

Definition at line 38 of file RequestResponse.xaml.h.

The documentation for this class was generated from the following file:
  • USSD message management/C++/RequestResponse.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WASAPIAudio::DEVICEPROPS Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WASAPIAudio
  • SDKSample::WASAPIAudio::DEVICEPROPS
Public Attributes

SDKSample::WASAPIAudio::DEVICEPROPS Struct Reference

#include "WASAPIRenderer.h"

List of all members.

Public Attributes

IRandomAccessStream | ContentStream
DWORD | Frequency
REFERENCE_TIME | hnsBufferDuration
Platform::Boolean | IsBackground
Platform::Boolean | IsHWOffload
Platform::Boolean | IsTonePlayback

Detailed Description

Definition at line 37 of file WASAPIRenderer.h.

Member Data Documentation

IRandomAccessStream SDKSample::WASAPIAudio::DEVICEPROPS::ContentStream

Definition at line 44 of file WASAPIRenderer.h.

DWORD SDKSample::WASAPIAudio::DEVICEPROPS::Frequency

Definition at line 43 of file WASAPIRenderer.h.

REFERENCE_TIME SDKSample::WASAPIAudio::DEVICEPROPS::hnsBufferDuration

Definition at line 42 of file WASAPIRenderer.h.

Platform::Boolean SDKSample::WASAPIAudio::DEVICEPROPS::IsBackground

Definition at line 41 of file WASAPIRenderer.h.

Platform::Boolean SDKSample::WASAPIAudio::DEVICEPROPS::IsHWOffload

Definition at line 39 of file WASAPIRenderer.h.

Platform::Boolean SDKSample::WASAPIAudio::DEVICEPROPS::IsTonePlayback

Definition at line 40 of file WASAPIRenderer.h.

The documentation for this struct was generated from the following file:
  • Windows Audio Session (WASAPI)/C++/WASAPIRenderer.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WASAPIAudio::MFSampleGenerator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WASAPIAudio
  • SDKSample::WASAPIAudio::MFSampleGenerator
Public Types | Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

SDKSample::WASAPIAudio::MFSampleGenerator Class Reference

#include "MFSampleGenerator.h"

List of all members.

Public Types

enum | ReaderState { ReaderStateStopped, ReaderStatePreRoll, ReaderStatePlaying, ReaderStateEOS }

Public Member Functions

MFSampleGenerator ()
HRESULT | FillSampleBuffer (UINT32 BytesToRead, BYTE *Data, UINT32 *cbWritten)
void | Flush ()
HRESULT | Initialize (IRandomAccessStream^stream, UINT32 FramesPerPeriod, WAVEFORMATEX *wfx)
Platform::Boolean | IsEOF ()
void | Shutdown ()
HRESULT | StartSource ()
STDMETHODIMP_ (ULONG) Release()
STDMETHODIMP_ (HRESULT) OnReadSample(_In_ HRESULT hrStatus
STDMETHODIMP_ (HRESULT) QueryInterface(const IID &riid
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (HRESULT) OnFlush(_In_ DWORD dwStreamIndex)
void | StopSource ()

Public Attributes

_In_ DWORD _In_ DWORD | dwStreamFlags
_In_ DWORD | dwStreamIndex
_In_ DWORD _In_ DWORD _In_ LONGLONG | llTimestamp
_In_ DWORD _In_ DWORD _In_
LONGLONG _In_opt_ IMFSample * 		pSample

Private Member Functions

~MFSampleGenerator ()
HRESULT | AddSamplesToQueue (IMFSample *MFSample)
HRESULT | ConfigureStreams ()
HRESULT | CreateAudioType (IMFMediaType **MediaType)
Platform::Boolean | IsPreRollFilled ()

Private Attributes

IMFMediaType * | m_AudioMT
UINT32 | m_BytesPerPeriod
IRandomAccessStream | m_ContentStream
Platform::Boolean | m_IsInitialized
IMFSourceReader * | m_MFSourceReader
WAVEFORMATEX * | m_MixFormat
ReaderState m_ReaderState
volatile ULONG | m_Ref
RenderBuffer * m_SampleQueue
RenderBuffer ** m_SampleQueueTail

Detailed Description

Definition at line 33 of file MFSampleGenerator.h.

Member Enumeration Documentation

enum SDKSample::WASAPIAudio::MFSampleGenerator::ReaderState
Enumerator:
ReaderStateStopped
ReaderStatePreRoll
ReaderStatePlaying
ReaderStateEOS

Definition at line 37 of file MFSampleGenerator.h.

            {
                ReaderStateStopped,
                ReaderStatePreRoll,
                ReaderStatePlaying,
                ReaderStateEOS
            };

Constructor & Destructor Documentation

MFSampleGenerator::MFSampleGenerator ( )

Definition at line 23 of file MFSampleGenerator.cpp.

                                     :
    m_Ref( 1 ),
    m_IsInitialized( false ),
    m_BytesPerPeriod( 0 ),
    m_ReaderState( ReaderStateStopped ),
    m_MFSourceReader( nullptr ),
    m_AudioMT( nullptr ),
    m_SampleQueue( nullptr ),
    m_SampleQueueTail( &m_SampleQueue )
{
}

MFSampleGenerator::~MFSampleGenerator ( ) [private]

Definition at line 38 of file MFSampleGenerator.cpp.

{
    Shutdown();
}

Member Function Documentation

HRESULT MFSampleGenerator::AddSamplesToQueue ( IMFSample * MFSample ) [private]

Definition at line 466 of file MFSampleGenerator.cpp.

{
    if (nullptr == MFSample)
    {
        return E_INVALIDARG;
    }

    HRESULT hr = S_OK;
    IMFMediaBuffer *MediaBuffer = nullptr;
    BYTE *AudioData = nullptr;
    DWORD cbAudioData = 0;

    // Since we are storing the raw byte data, convert this to a single buffer
    hr = MFSample->ConvertToContiguousBuffer( &MediaBuffer );
    if (FAILED( hr ))
    {
        goto exit;
    }

    // Lock the sample
    hr = MediaBuffer->Lock( &AudioData, NULL, &cbAudioData );
    if ( (FAILED( hr )) || (cbAudioData == 0) )
    {
        goto exit;
    }

    DWORD cbBytesCopied = 0;

    // First fill up any partial buffers from the previous sample
    if ( (*m_SampleQueueTail != nullptr) &&
         ((*m_SampleQueueTail)->BytesFilled < m_BytesPerPeriod) )
    {
        RenderBuffer *PartialBuffer = *m_SampleQueueTail;

        DWORD cbBytesRemaining = m_BytesPerPeriod - PartialBuffer->BytesFilled;
        DWORD cbBytesToCopy = min( cbAudioData, cbBytesRemaining );

        CopyMemory( PartialBuffer->Buffer + PartialBuffer->BytesFilled, AudioData, cbBytesToCopy );

        PartialBuffer->BytesFilled += cbBytesToCopy;
        cbBytesCopied += cbBytesToCopy;

        // Move the tail pointer only if we have filled the sample
        if (PartialBuffer->BytesFilled == m_BytesPerPeriod)
        {
            m_SampleQueueTail = &PartialBuffer->Next;
        }
    }

    // Create buffers for the remainder of the samples
    while( cbBytesCopied < cbAudioData )
    {
        RenderBuffer *SampleBuffer = new (std::nothrow) RenderBuffer();
        if (nullptr == SampleBuffer)
        {
            hr = E_OUTOFMEMORY;
            goto exit;
        }

        DWORD cbBytesRemaining = cbAudioData - cbBytesCopied;
        DWORD cbBufferLengthInBytes = min( m_BytesPerPeriod, cbBytesRemaining );

        SampleBuffer->Buffer = new (std::nothrow) BYTE[ m_BytesPerPeriod ];
        if (nullptr == SampleBuffer->Buffer)
        {
            SAFE_DELETE( SampleBuffer );
            hr = E_OUTOFMEMORY;
            goto exit;
        }

        SampleBuffer->BufferSize = m_BytesPerPeriod;
        SampleBuffer->BytesFilled = 0;

        ZeroMemory( SampleBuffer->Buffer, m_BytesPerPeriod );
        CopyMemory( SampleBuffer->Buffer, AudioData + cbBytesCopied, cbBufferLengthInBytes );

        SampleBuffer->BytesFilled += cbBufferLengthInBytes;
        cbBytesCopied += cbBufferLengthInBytes;

        *m_SampleQueueTail = SampleBuffer;

        // Move the tail pointer only if we have filled the sample otherwise will get filled the
        // next time we add sample data to the queue
        if (SampleBuffer->BytesFilled == m_BytesPerPeriod)
        {
            m_SampleQueueTail = &SampleBuffer->Next;
        }
    }

exit:
    // Unlock the buffer
    hr = MediaBuffer->Unlock();
    AudioData = nullptr;

    SAFE_RELEASE( MediaBuffer );
    return hr;
}

HRESULT MFSampleGenerator::ConfigureStreams ( ) [private]

Definition at line 196 of file MFSampleGenerator.cpp.

{
    HRESULT hr = S_OK;
    IMFMediaType *UncompressedMT = nullptr;
    IMFMediaType *PartialMT = nullptr;

    // Disable all streams
    hr = m_MFSourceReader->SetStreamSelection( MF_SOURCE_READER_ALL_STREAMS, false );
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    // Enable first audio stream
    hr = m_MFSourceReader->SetStreamSelection( MF_SOURCE_READER_FIRST_AUDIO_STREAM, true );
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    hr = CreateAudioType( &PartialMT );
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    // Set type on source reader so necessary converters / decoders will be added
    hr = m_MFSourceReader->SetCurrentMediaType( MF_SOURCE_READER_FIRST_AUDIO_STREAM, nullptr, PartialMT );
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    // Verify the media type on stream
    hr = m_MFSourceReader->GetCurrentMediaType( MF_SOURCE_READER_FIRST_AUDIO_STREAM, &UncompressedMT );
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    WAVEFORMATEX *pwfx = NULL;
    UINT32 cbFormat = 0;
    MFCreateWaveFormatExFromMFMediaType( UncompressedMT, &pwfx, &cbFormat );

    CoTaskMemFree( pwfx );

    m_AudioMT = UncompressedMT;
    m_AudioMT->AddRef();

exit:
    SAFE_RELEASE( UncompressedMT );
    SAFE_RELEASE( PartialMT );

    return hr;
}

HRESULT MFSampleGenerator::CreateAudioType ( IMFMediaType ** MediaType ) [private]

Definition at line 257 of file MFSampleGenerator.cpp.

{
    HRESULT hr = S_OK;
    IMFMediaType *MT = nullptr;

    // Create a partial media type for our mix format (PCM or IEEE Float)
    hr = MFCreateMediaType( &MT );
    if (FAILED( hr ))
    {
        goto exit;
    }

    // Set media type attributes
    hr = MT->SetGUID( MF_MT_MAJOR_TYPE, MFMediaType_Audio );
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    if (RenderSampleType::SampleType16BitPCM == CalculateMixFormatType( m_MixFormat ))
    {
        hr = MT->SetGUID( MF_MT_SUBTYPE, MFAudioFormat_PCM );
    }
    else
    {
        hr = MT->SetGUID( MF_MT_SUBTYPE, MFAudioFormat_Float );
    }

    if (FAILED( hr ))
    {
        goto exit;
    }

    hr = MT->SetUINT32( MF_MT_AUDIO_NUM_CHANNELS, m_MixFormat->nChannels );
    if (FAILED( hr ))
    {
        goto exit;
    }

    hr = MT->SetUINT32( MF_MT_AUDIO_SAMPLES_PER_SECOND, m_MixFormat->nSamplesPerSec );
    if (FAILED( hr ))
    {
        goto exit;
    }

    hr = MT->SetUINT32( MF_MT_AUDIO_BLOCK_ALIGNMENT, m_MixFormat->nBlockAlign );
    if (FAILED( hr ))
    {
        goto exit;
    }

    hr = MT->SetUINT32( MF_MT_AUDIO_AVG_BYTES_PER_SECOND, m_MixFormat->nAvgBytesPerSec );
    if (FAILED( hr ))
    {
        goto exit;
    }

    hr = MT->SetUINT32( MF_MT_AUDIO_BITS_PER_SAMPLE, m_MixFormat->wBitsPerSample );
    if (FAILED( hr ))
    {
        goto exit;
    }

    hr = MT->SetUINT32( MF_MT_ALL_SAMPLES_INDEPENDENT, true );
    if (FAILED( hr ))
    {
        goto exit;
    }

    *MediaType = MT;
    (*MediaType)->AddRef();

exit:
    SAFE_RELEASE( MT );
    return hr;
}

HRESULT MFSampleGenerator::FillSampleBuffer | ( | UINT32 | BytesToRead,
 |  | BYTE * | Data,
 |  | UINT32 * | cbWritten
 | ) |  |

Definition at line 405 of file MFSampleGenerator.cpp.

{
    HRESULT hr = S_OK;
    *cbWritten = 0;

    if (nullptr == Data)
    {
        return E_POINTER;
    }

    if (!m_IsInitialized)
    {
        return E_UNEXPECTED;
    }

    // Not going to return any data here while in a pre-roll state.
    if (m_ReaderState == ReaderStatePreRoll)
        return S_OK;

    RenderBuffer *SampleBuffer = m_SampleQueue;
    if (nullptr == SampleBuffer)
    {
        if (m_ReaderState == ReaderStateEOS)
        {
            // We are EOS, should be set from OnReadSample() and the client should check for EOS before
            // calling FillSampleBuffer()
            hr = S_FALSE;
        }
        else
        {
            // There shouldn't be a situation where we get here unless the reader has
            // somehow gotten into the wrong state
            hr = E_FAIL;
        }
    }
    else
    {
        if (SampleBuffer->BufferSize > BytesToRead)
        {
            // We don't have enough data in the client audio buffer this pass
            // Do nothing and wait for the next sample period
            hr = S_OK;
        }
        else
        {
            CopyMemory( Data, SampleBuffer->Buffer, SampleBuffer->BufferSize );

            *cbWritten = SampleBuffer->BufferSize;
            m_SampleQueue = m_SampleQueue->Next;
            hr = S_OK;
        }
    }

    return hr;
}

void MFSampleGenerator::Flush ( )

Definition at line 46 of file MFSampleGenerator.cpp.

{
    while( m_SampleQueue != nullptr )
    {
        RenderBuffer *SampleBuffer = m_SampleQueue;
        m_SampleQueue = SampleBuffer->Next;
        SAFE_DELETE( SampleBuffer );
    }
}

HRESULT MFSampleGenerator::Initialize | ( | IRandomAccessStream^ | stream,
 |  | UINT32 | FramesPerPeriod,
 |  | WAVEFORMATEX * | wfx
 | ) |  |

Definition at line 117 of file MFSampleGenerator.cpp.

{
    HRESULT hr = S_OK;

    m_ContentStream = stream;
    m_MixFormat = wfx;
    IMFByteStream *ByteStream = nullptr;
    IMFAttributes *Attributes = nullptr;

    SAFE_RELEASE( m_AudioMT );
    SAFE_RELEASE( m_MFSourceReader );

    hr = MFCreateAttributes( &Attributes, 3 );
    if (FAILED( hr ))
    {
        goto exit;
    }

    // Specify Source Reader Attributes
    Attributes->SetUnknown( MF_SOURCE_READER_ASYNC_CALLBACK, static_cast<IMFSourceReaderCallback *>(this) );
    if (FAILED( hr ))
    {
        goto exit;
    }

    Attributes->SetString( MF_READWRITE_MMCSS_CLASS_AUDIO, L"Audio" );
    if (FAILED( hr ))
    {
        goto exit;
    }

    Attributes->SetUINT32( MF_READWRITE_MMCSS_PRIORITY_AUDIO, 0 );
    if (FAILED( hr ))
    {
        goto exit;
    }

    // Create a stream from IRandomAccessStream
    hr = MFCreateMFByteStreamOnStreamEx( reinterpret_cast<IUnknown*>(m_ContentStream), &ByteStream );
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    // Create source reader
    hr = MFCreateSourceReaderFromByteStream( ByteStream, Attributes, &m_MFSourceReader );
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    // Configures media types
    hr = ConfigureStreams();
    if ( FAILED( hr ) )
    {
        goto exit;
    }

    m_BytesPerPeriod = FramesPerPeriod * m_MixFormat->nBlockAlign;
    m_IsInitialized = true;

exit:
    if ( FAILED( hr ) )
    {
        SAFE_RELEASE( m_AudioMT );
        SAFE_RELEASE( m_MFSourceReader );
    }

    SAFE_RELEASE( Attributes );
    SAFE_RELEASE( ByteStream );

    return hr;
}

Platform::Boolean SDKSample::WASAPIAudio::MFSampleGenerator::IsEOF ( ) [inline]

Definition at line 94 of file MFSampleGenerator.h.

            {
                if ( ( m_SampleQueue == nullptr ) &&
                     ( m_ReaderState == ReaderStateEOS ) )
                    return true;

                return false;
            }

Platform::Boolean MFSampleGenerator::IsPreRollFilled ( ) [private]

Definition at line 569 of file MFSampleGenerator.cpp.

{
    DWORD TotalBufferSize = 0;

    RenderBuffer *SampleBuffer = m_SampleQueue;
    while( SampleBuffer != nullptr )
    {
        TotalBufferSize += SampleBuffer->BufferSize;

        // For uncompressed formats, nAvgBytesPerSec should equal nSamplesPerSecond * nBlockAlign
        if (TotalBufferSize >= (m_MixFormat->nAvgBytesPerSec * PREROLL_DURATION_SEC))
        {
            return true;
        }

        SampleBuffer = SampleBuffer->Next;
    }

    return false;
}

void MFSampleGenerator::Shutdown ( )

Definition at line 59 of file MFSampleGenerator.cpp.

{
    if (m_IsInitialized)
    {
        SAFE_RELEASE( m_AudioMT );
        SAFE_RELEASE( m_MFSourceReader );

        Flush();

        m_IsInitialized = false;
    }
}

HRESULT MFSampleGenerator::StartSource ( )

Definition at line 77 of file MFSampleGenerator.cpp.

{
    if (!m_IsInitialized)
        return E_UNEXPECTED;

    // We can be in EOS if this is a resume from pause
    if ( (m_ReaderState == ReaderStatePreRoll) ||
         (m_ReaderState == ReaderStatePlaying) ||
         (m_ReaderState == ReaderStateEOS) )
        return S_FALSE;

    HRESULT hr = S_OK;

    // This will start the source reader and asynchronously call OnReadSample
    hr = m_MFSourceReader->ReadSample( MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, nullptr, nullptr, nullptr, nullptr );
    if (SUCCEEDED( hr ))
    {
        m_ReaderState = ReaderStatePreRoll;
    }

    return hr;
}

SDKSample::WASAPIAudio::MFSampleGenerator::STDMETHODIMP_ ( HRESULT )
SDKSample::WASAPIAudio::MFSampleGenerator::STDMETHODIMP_ ( HRESULT ) const
SDKSample::WASAPIAudio::MFSampleGenerator::STDMETHODIMP_ ( HRESULT )
SDKSample::WASAPIAudio::MFSampleGenerator::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 53 of file MFSampleGenerator.h.

            {
                LONG ref = InterlockedDecrement(&m_Ref);

                if (ref == 0)
                {
                    delete this;
                }

                return ref;
            }

SDKSample::WASAPIAudio::MFSampleGenerator::STDMETHODIMP_ ( ULONG ) [inline]

Definition at line 48 of file MFSampleGenerator.h.

            {
                return InterlockedIncrement(&m_Ref);
            }

void MFSampleGenerator::StopSource ( )

Definition at line 105 of file MFSampleGenerator.cpp.

{
    // We only really need this if Source is still reading samples, otherwise
    // we should be in an EOS state and parsing existing samples in the queue
    m_ReaderState = ReaderStateStopped;
}

Member Data Documentation

_In_ DWORD _In_ DWORD SDKSample::WASAPIAudio::MFSampleGenerator::dwStreamFlags

Definition at line 83 of file MFSampleGenerator.h.

_In_ DWORD SDKSample::WASAPIAudio::MFSampleGenerator::dwStreamIndex

Definition at line 83 of file MFSampleGenerator.h.

_In_ DWORD _In_ DWORD _In_ LONGLONG SDKSample::WASAPIAudio::MFSampleGenerator::llTimestamp

Definition at line 83 of file MFSampleGenerator.h.

IMFMediaType* SDKSample::WASAPIAudio::MFSampleGenerator::m_AudioMT [private]

Definition at line 119 of file MFSampleGenerator.h.

UINT32 SDKSample::WASAPIAudio::MFSampleGenerator::m_BytesPerPeriod [private]

Definition at line 115 of file MFSampleGenerator.h.

IRandomAccessStream SDKSample::WASAPIAudio::MFSampleGenerator::m_ContentStream [private]

Definition at line 113 of file MFSampleGenerator.h.

Platform::Boolean SDKSample::WASAPIAudio::MFSampleGenerator::m_IsInitialized [private]

Definition at line 116 of file MFSampleGenerator.h.

IMFSourceReader* SDKSample::WASAPIAudio::MFSampleGenerator::m_MFSourceReader [private]

Definition at line 118 of file MFSampleGenerator.h.

WAVEFORMATEX* SDKSample::WASAPIAudio::MFSampleGenerator::m_MixFormat [private]

Definition at line 114 of file MFSampleGenerator.h.

ReaderState SDKSample::WASAPIAudio::MFSampleGenerator::m_ReaderState [private]

Definition at line 120 of file MFSampleGenerator.h.

volatile ULONG SDKSample::WASAPIAudio::MFSampleGenerator::m_Ref [private]

Definition at line 112 of file MFSampleGenerator.h.

RenderBuffer* SDKSample::WASAPIAudio::MFSampleGenerator::m_SampleQueue [private]

Definition at line 122 of file MFSampleGenerator.h.

RenderBuffer** SDKSample::WASAPIAudio::MFSampleGenerator::m_SampleQueueTail [private]

Definition at line 123 of file MFSampleGenerator.h.

_In_ DWORD _In_ DWORD _In_ LONGLONG _In_opt_ IMFSample* SDKSample::WASAPIAudio::MFSampleGenerator::pSample

Definition at line 83 of file MFSampleGenerator.h.

The documentation for this class was generated from the following files:
  • Windows Audio Session (WASAPI)/C++/MFSampleGenerator.h
  • Windows Audio Session (WASAPI)/C++/MFSampleGenerator.cpp
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WASAPIAudio::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WASAPIAudio
  • SDKSample::WASAPIAudio::sealed
Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Properties | Private Member Functions | Private Attributes

SDKSample::WASAPIAudio::sealed Class Reference

#include "DeviceState.h"

List of all members.

Public Member Functions

DeviceStateChangedEvent ()
DeviceState GetState ()
internal HRESULT | m_hr (hr)
internal UINT32 | m_Size (size)
PlotDataReadyEvent ()
Scenario1 ()
Scenario2 ()
Scenario3 ()

Public Attributes

internal | __pad0__: DeviceStateChangedEventArgs( DeviceState newState
internal HRESULT | hr: m_DeviceState( newState )
internal Platform::Array< int, 1 > | points
internal | points
internal UINT32 | size: m_PointArray( points )

Static Public Attributes

static event
DeviceStateChangedHandler 		StateChangedEvent

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Properties

HRESULT | m_hr

Private Member Functions

~Scenario2 ()
~Scenario3 ()
void | btnFilePicker_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnPause_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnPlay_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnPlayPause_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStartCapture_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStop_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | btnStopCapture_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Enumerate_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | EnumerateAudioDevicesAsync ()
void | InitializeCapture (Object^sender, Object^e)
void | InitializeDevice ()
void | OnDeviceStateChange (Object^sender, DeviceStateChangedEventArgs^e)
void | OnDeviceStateChange (Object^sender, DeviceStateChangedEventArgs^e)
void | OnPickFileAsync ()
void | OnPlotDataReady (Object^sender, PlotDataReadyEventArgs^e)
void | OnSetVolume (UINT32 volume)
void | PauseDevice (Object^sender, Object^e)
void | PlayPauseToggle (Object^sender, Object^e)
void | radioFile_Checked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | radioTone_Checked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowStatusMessage (Platform::String^str, NotifyType messageType)
void | ShowStatusMessage (Platform::String^str, NotifyType messageType)
void | ShowStatusMessage (Platform::String^str, NotifyType messageType)
void | sliderFrequency_ValueChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | sliderVolume_ValueChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
void | StartDevice (Object^sender, Object^e)
void | StopCapture (Object^sender, Object^e)
void | StopDevice (Object^sender, Object^e)
void | UpdateContentProps (Platform::String^str)
void | UpdateContentUI (Platform::Boolean disableAll)
void | UpdateMediaControlUI (DeviceState deviceState)
void | UpdateMediaControlUI (DeviceState deviceState)

Private Attributes

IRandomAccessStream | m_ContentStream
ContentType m_ContentType
Windows::UI::Core::CoreDispatcher | m_CoreDispatcher
Windows::UI::Xaml::Controls::ListBox | m_DevicesList
DeviceState m_DeviceState
Windows::Foundation::EventRegistrationToken | m_deviceStateChangeToken
int | m_DiscontinuityCount
Platform::Boolean | m_IsMFLoaded
Windows::Foundation::EventRegistrationToken | m_MediaControlPauseToken
Windows::Foundation::EventRegistrationToken | m_MediaControlPlayPauseToken
Windows::Foundation::EventRegistrationToken | m_MediaControlPlayToken
Windows::Foundation::EventRegistrationToken | m_MediaControlStopToken
Windows::UI::Xaml::Shapes::Polyline | m_Oscilliscope
Windows::Foundation::EventRegistrationToken | m_plotDataReadyToken
Platform::Array< int, 1 > | m_PointArray
UINT32 | m_Size
ComPtr< WASAPICapture > | m_spCapture
ComPtr< WASAPIRenderer > | m_spRenderer
DeviceStateChangedEvent | m_StateChangedEvent
MainPage rootPage

Detailed Description

Definition at line 45 of file DeviceState.h.

Constructor & Destructor Documentation

SDKSample::WASAPIAudio::sealed::~Scenario2 ( ) [private]
SDKSample::WASAPIAudio::sealed::~Scenario3 ( ) [private]

Member Function Documentation

void SDKSample::WASAPIAudio::sealed::btnFilePicker_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::btnPause_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::btnPlay_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::btnPlayPause_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::btnStartCapture_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::btnStop_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::btnStopCapture_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::WASAPIAudio::sealed::DeviceStateChangedEvent ( ) [inline]

Definition at line 75 of file DeviceState.h.

                                      :
                m_DeviceState( DeviceState::DeviceStateUnInitialized )
            {};

void SDKSample::WASAPIAudio::sealed::Enumerate_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::EnumerateAudioDevicesAsync ( ) [private]
DeviceState SDKSample::WASAPIAudio::sealed::GetState ( void ) [inline]

Definition at line 79 of file DeviceState.h.

{ return m_DeviceState; };

void SDKSample::WASAPIAudio::sealed::InitializeCapture | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::InitializeDevice ( ) [private]
internal HRESULT SDKSample::WASAPIAudio::sealed::m_hr ( hr ) [inline]

Definition at line 50 of file DeviceState.h.

            {};

internal UINT32 SDKSample::WASAPIAudio::sealed::m_Size ( size ) [inline]

Definition at line 31 of file PlotData.h.

            {};

void SDKSample::WASAPIAudio::sealed::OnDeviceStateChange | ( | Object^ | sender,
 |  | DeviceStateChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::OnDeviceStateChange | ( | Object^ | sender,
 |  | DeviceStateChangedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::WASAPIAudio::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WASAPIAudio::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WASAPIAudio::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WASAPIAudio::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WASAPIAudio::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::WASAPIAudio::sealed::OnPickFileAsync ( ) [private]
void SDKSample::WASAPIAudio::sealed::OnPlotDataReady | ( | Object^ | sender,
 |  | PlotDataReadyEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::OnSetVolume ( UINT32 volume ) [private]
void SDKSample::WASAPIAudio::sealed::PauseDevice | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::PlayPauseToggle | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
SDKSample::WASAPIAudio::sealed::PlotDataReadyEvent ( ) [inline]

Definition at line 56 of file PlotData.h.

{};

void SDKSample::WASAPIAudio::sealed::radioFile_Checked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::radioTone_Checked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::WASAPIAudio::sealed::Scenario1 ( )
SDKSample::WASAPIAudio::sealed::Scenario2 ( )
SDKSample::WASAPIAudio::sealed::Scenario3 ( )
void SDKSample::WASAPIAudio::sealed::ShowStatusMessage | ( | Platform::String^ | str,
 |  | NotifyType | messageType |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::ShowStatusMessage | ( | Platform::String^ | str,
 |  | NotifyType | messageType |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::ShowStatusMessage | ( | Platform::String^ | str,
 |  | NotifyType | messageType |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::sliderFrequency_ValueChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::sliderVolume_ValueChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::StartDevice | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::StopCapture | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::StopDevice | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void SDKSample::WASAPIAudio::sealed::UpdateContentProps ( Platform::String^ str ) [private]
void SDKSample::WASAPIAudio::sealed::UpdateContentUI ( Platform::Boolean disableAll ) [private]
void SDKSample::WASAPIAudio::sealed::UpdateMediaControlUI ( DeviceState deviceState ) [private]
void SDKSample::WASAPIAudio::sealed::UpdateMediaControlUI ( DeviceState deviceState ) [private]

Member Data Documentation

internal sealed::__pad0__

Definition at line 48 of file DeviceState.h.

internal HRESULT sealed::hr

Definition at line 48 of file DeviceState.h.

IRandomAccessStream SDKSample::WASAPIAudio::sealed::m_ContentStream [private]

Definition at line 86 of file Scenario2.xaml.h.

ContentType SDKSample::WASAPIAudio::sealed::m_ContentType [private]

Definition at line 87 of file Scenario2.xaml.h.

Windows::UI::Core::CoreDispatcher sealed::m_CoreDispatcher [private]

Definition at line 78 of file Scenario2.xaml.h.

Windows::UI::Xaml::Controls::ListBox SDKSample::WASAPIAudio::sealed::m_DevicesList [private]

Definition at line 47 of file Scenario1.xaml.h.

DeviceState SDKSample::WASAPIAudio::sealed::m_DeviceState [private]

Definition at line 99 of file DeviceState.h.

Windows::Foundation::EventRegistrationToken sealed::m_deviceStateChangeToken [private]

Definition at line 79 of file Scenario2.xaml.h.

int SDKSample::WASAPIAudio::sealed::m_DiscontinuityCount [private]

Definition at line 70 of file Scenario3.xaml.h.

Platform::Boolean sealed::m_IsMFLoaded [private]

Definition at line 85 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::WASAPIAudio::sealed::m_MediaControlPauseToken [private]

Definition at line 81 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::WASAPIAudio::sealed::m_MediaControlPlayPauseToken [private]

Definition at line 83 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::WASAPIAudio::sealed::m_MediaControlPlayToken [private]

Definition at line 80 of file Scenario2.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::WASAPIAudio::sealed::m_MediaControlStopToken [private]

Definition at line 82 of file Scenario2.xaml.h.

Windows::UI::Xaml::Shapes::Polyline SDKSample::WASAPIAudio::sealed::m_Oscilliscope [private]

Definition at line 65 of file Scenario3.xaml.h.

Windows::Foundation::EventRegistrationToken SDKSample::WASAPIAudio::sealed::m_plotDataReadyToken [private]

Definition at line 68 of file Scenario3.xaml.h.

Platform::Array<int,1> SDKSample::WASAPIAudio::sealed::m_PointArray [private]

Definition at line 32 of file PlotData.h.

UINT32 SDKSample::WASAPIAudio::sealed::m_Size [private]

Definition at line 46 of file PlotData.h.

ComPtr<WASAPICapture> SDKSample::WASAPIAudio::sealed::m_spCapture [private]

Definition at line 73 of file Scenario3.xaml.h.

ComPtr<WASAPIRenderer> SDKSample::WASAPIAudio::sealed::m_spRenderer [private]

Definition at line 89 of file Scenario2.xaml.h.

DeviceStateChangedEvent sealed::m_StateChangedEvent [private]

Definition at line 88 of file Scenario2.xaml.h.

internal Platform::Array<int, 1> SDKSample::WASAPIAudio::sealed::points

Definition at line 56 of file PlotData.h.

internal SDKSample::WASAPIAudio::sealed::points

Definition at line 29 of file PlotData.h.

MainPage sealed::rootPage [private]

Definition at line 46 of file Scenario1.xaml.h.

internal UINT32 SDKSample::WASAPIAudio::sealed::size

Definition at line 29 of file PlotData.h.

event DeviceStateChangedHandler SDKSample::WASAPIAudio::sealed::StateChangedEvent [static]

Definition at line 79 of file DeviceState.h.

Property Documentation

HRESULT SDKSample::WASAPIAudio::sealed::m_hr

Definition at line 51 of file DeviceState.h.

The documentation for this class was generated from the following files:
  • Windows Audio Session (WASAPI)/C++/DeviceState.h
  • Windows Audio Session (WASAPI)/C++/PlotData.h
  • Windows Audio Session (WASAPI)/C++/Scenario1.xaml.h
  • Windows Audio Session (WASAPI)/C++/Scenario2.xaml.h
  • Windows Audio Session (WASAPI)/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WASAPIAudio::ToneSampleGenerator Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WASAPIAudio
  • SDKSample::WASAPIAudio::ToneSampleGenerator
Public Member Functions | Private Member Functions | Private Attributes

SDKSample::WASAPIAudio::ToneSampleGenerator Class Reference

#include "ToneSampleGenerator.h"

List of all members.

Public Member Functions

ToneSampleGenerator ()
~ToneSampleGenerator ()
HRESULT | FillSampleBuffer (UINT32 BytesToRead, BYTE *Data)
void | Flush ()
HRESULT | GenerateSampleBuffer (DWORD Frequency, UINT32 FramesPerPeriod, WAVEFORMATEX *wfx)
UINT32 | GetBufferLength ()
Platform::Boolean | IsEOF ()

Private Member Functions

template<typename T >
void | GenerateSineSamples (BYTE *Buffer, size_t BufferLength, DWORD Frequency, WORD ChannelCount, DWORD SamplesPerSecond, double Amplitude, double *InitialTheta)

Private Attributes

RenderBuffer * m_SampleQueue
RenderBuffer ** m_SampleQueueTail

Detailed Description

Definition at line 28 of file ToneSampleGenerator.h.

Constructor & Destructor Documentation

ToneSampleGenerator::ToneSampleGenerator ( )

Definition at line 41 of file ToneSampleGenerator.cpp.

{
    m_SampleQueue = nullptr;
    m_SampleQueueTail = &m_SampleQueue;
}

ToneSampleGenerator::~ToneSampleGenerator ( )

Definition at line 50 of file ToneSampleGenerator.cpp.

{
    // Flush unused samples
    Flush();
}

Member Function Documentation

HRESULT ToneSampleGenerator::FillSampleBuffer | ( | UINT32 | BytesToRead,
 |  | BYTE * | Data
 | ) |  |

Definition at line 148 of file ToneSampleGenerator.cpp.

{
    if (nullptr == Data)
    {
        return E_POINTER;
    }

    RenderBuffer *SampleBuffer = m_SampleQueue;

    if (BytesToRead > SampleBuffer->BufferSize)
    {
        return E_INVALIDARG;
    }

    CopyMemory( Data, SampleBuffer->Buffer, BytesToRead );

    m_SampleQueue = m_SampleQueue->Next;

    return S_OK;
}

void ToneSampleGenerator::Flush ( )

Definition at line 174 of file ToneSampleGenerator.cpp.

{
    while( m_SampleQueue != nullptr )
    {
        RenderBuffer *SampleBuffer = m_SampleQueue;
        m_SampleQueue = SampleBuffer->Next;
        SAFE_DELETE( SampleBuffer );
    }
}

HRESULT ToneSampleGenerator::GenerateSampleBuffer | ( | DWORD | Frequency,
 |  | UINT32 | FramesPerPeriod,
 |  | WAVEFORMATEX * | wfx
 | ) |  |

Definition at line 61 of file ToneSampleGenerator.cpp.

{
    HRESULT hr = S_OK;

    UINT32 renderBufferSizeInBytes = FramesPerPeriod * wfx->nBlockAlign;
    UINT64 renderDataLength = ( wfx->nSamplesPerSec * TONE_DURATION_SEC * wfx->nBlockAlign ) + ( renderBufferSizeInBytes - 1 );
    UINT64 renderBufferCount = renderDataLength / renderBufferSizeInBytes;

    double theta = 0;

    for( UINT64 i = 0; i < renderBufferCount; i++ )
    {
        RenderBuffer *SampleBuffer = new (std::nothrow) RenderBuffer();
        if (nullptr == SampleBuffer)
        {
            return E_OUTOFMEMORY;
        }

        SampleBuffer->BufferSize = renderBufferSizeInBytes;
        SampleBuffer->BytesFilled = renderBufferSizeInBytes;
        SampleBuffer->Buffer = new (std::nothrow) BYTE[ renderBufferSizeInBytes ];
        if (nullptr == SampleBuffer->Buffer)
        {
            return E_OUTOFMEMORY;
        }

        switch( CalculateMixFormatType( wfx ) )
        {
        case RenderSampleType::SampleType16BitPCM:
            GenerateSineSamples<short>( SampleBuffer->Buffer, SampleBuffer->BufferSize, Frequency, wfx->nChannels, wfx->nSamplesPerSec, TONE_AMPLITUDE, &theta);
            break;

        case RenderSampleType::SampleTypeFloat:
            GenerateSineSamples<float>( SampleBuffer->Buffer, SampleBuffer->BufferSize, Frequency, wfx->nChannels, wfx->nSamplesPerSec, TONE_AMPLITUDE, &theta);
            break;

        default:
            return E_UNEXPECTED;
            break;
        }

        *m_SampleQueueTail = SampleBuffer;
        m_SampleQueueTail = &SampleBuffer->Next;
    }
    return hr;
}

template<typename T >
void ToneSampleGenerator::GenerateSineSamples | ( | BYTE * | Buffer,
 |  | size_t | BufferLength,
 |  | DWORD | Frequency,
 |  | WORD | ChannelCount,
 |  | DWORD | SamplesPerSecond,
 |  | double | Amplitude,
 |  | double * | InitialTheta |
 | ) |  |  | [private]

Definition at line 121 of file ToneSampleGenerator.cpp.

{
    double sampleIncrement = (Frequency * (M_PI*2)) / (double)SamplesPerSecond;
    T *dataBuffer = reinterpret_cast<T *>(Buffer);
    double theta = (InitialTheta != NULL ? *InitialTheta : 0);

    for (size_t i = 0 ; i < BufferLength / sizeof(T) ; i += ChannelCount)
    {
        double sinValue = Amplitude * sin( theta );
        for(size_t j = 0 ;j < ChannelCount; j++)
        {
            dataBuffer[i+j] = Convert<T>(sinValue);
        }
        theta += sampleIncrement;
    }

    if (InitialTheta != NULL)
    {
        *InitialTheta = theta;
    }
}

UINT32 SDKSample::WASAPIAudio::ToneSampleGenerator::GetBufferLength ( ) [inline]

Definition at line 35 of file ToneSampleGenerator.h.

{ return ( m_SampleQueue != nullptr ? m_SampleQueue->BufferSize : 0 ); };

Platform::Boolean SDKSample::WASAPIAudio::ToneSampleGenerator::IsEOF ( ) [inline]

Definition at line 34 of file ToneSampleGenerator.h.

{ return (m_SampleQueue == nullptr); };

Member Data Documentation

RenderBuffer* SDKSample::WASAPIAudio::ToneSampleGenerator::m_SampleQueue [private]

Definition at line 46 of file ToneSampleGenerator.h.

RenderBuffer** SDKSample::WASAPIAudio::ToneSampleGenerator::m_SampleQueueTail [private]

Definition at line 47 of file ToneSampleGenerator.h.

The documentation for this class was generated from the following files:
  • Windows Audio Session (WASAPI)/C++/ToneSampleGenerator.h
  • Windows Audio Session (WASAPI)/C++/ToneSampleGenerator.cpp
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WASAPIAudio::WASAPICapture Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WASAPIAudio
  • SDKSample::WASAPIAudio::WASAPICapture
Public Member Functions | Private Member Functions | Private Attributes

SDKSample::WASAPIAudio::WASAPICapture Class Reference

#include "WASAPICapture.h"

List of all members.

Public Member Functions

WASAPICapture ()
STDMETHOD() | ActivateCompleted (IActivateAudioInterfaceAsyncOperation *operation)
HRESULT | FinishCaptureAsync ()
DeviceStateChangedEvent | GetDeviceStateEvent ()
HRESULT | InitializeAudioDeviceAsync ()
METHODASYNCCALLBACK (WASAPICapture, SampleReady, OnSampleReady)
METHODASYNCCALLBACK (WASAPICapture, StartCapture, OnStartCapture)
METHODASYNCCALLBACK (WASAPICapture, StopCapture, OnStopCapture)
METHODASYNCCALLBACK (WASAPICapture, SendScopeData, OnSendScopeData)
METHODASYNCCALLBACK (WASAPICapture, FinishCapture, OnFinishCapture)
HRESULT | StartCaptureAsync ()
HRESULT | StopCaptureAsync ()

Private Member Functions

~WASAPICapture ()
HRESULT | CreateWAVFile ()
HRESULT | FixWAVHeader ()
HRESULT | InitializeScopeData ()
HRESULT | OnAudioSampleRequested (Platform::Boolean IsSilence=false)
HRESULT | OnFinishCapture (IMFAsyncResult *pResult)
HRESULT | OnSampleReady (IMFAsyncResult *pResult)
HRESULT | OnSendScopeData (IMFAsyncResult *pResult)
HRESULT | OnStartCapture (IMFAsyncResult *pResult)
HRESULT | OnStopCapture (IMFAsyncResult *pResult)
HRESULT | ProcessScopeData (BYTE *pData, DWORD cbBytes)

Private Attributes

IAudioCaptureClient * | m_AudioCaptureClient
IAudioClient * | m_AudioClient
UINT32 | m_BufferFrames
DWORD | m_cbDataSize
DWORD | m_cbFlushCounter
DWORD | m_cbHeaderSize
IRandomAccessStream | m_ContentStream
UINT32 | m_cPlotDataFilled
UINT32 | m_cPlotDataMax
CRITICAL_SECTION | m_CritSec
Platform::String | m_DeviceIdString
DeviceStateChangedEvent | m_DeviceStateChanged
DWORD | m_dwQueueID
BOOL | m_fWriting
WAVEFORMATEX * | m_MixFormat
IOutputStream | m_OutputStream
Platform::Array< int, 1 > | m_PlotData
IMFAsyncResult * | m_SampleReadyAsyncResult
HANDLE | m_SampleReadyEvent
MFWORKITEM_KEY | m_SampleReadyKey
DataWriter | m_WAVDataWriter

Detailed Description

Definition at line 39 of file WASAPICapture.h.

Constructor & Destructor Documentation

WASAPICapture::WASAPICapture ( )

Definition at line 26 of file WASAPICapture.cpp.

                             :
    m_BufferFrames( 0 ),
    m_cbDataSize( 0 ),
    m_cbHeaderSize( 0 ),
    m_cbFlushCounter( 0 ),
    m_dwQueueID( 0 ),
    m_DeviceStateChanged( nullptr ),
    m_AudioClient( nullptr ),
    m_AudioCaptureClient( nullptr ),
    m_SampleReadyAsyncResult( nullptr ),
    m_ContentStream( nullptr ),
    m_OutputStream( nullptr ),
    m_WAVDataWriter( nullptr ),
    m_PlotData( nullptr ),
    m_fWriting( false )
{
    // Create events for sample ready or user stop
    m_SampleReadyEvent = CreateEventEx( nullptr, nullptr, 0, EVENT_ALL_ACCESS );
    if (nullptr == m_SampleReadyEvent)
    {
        ThrowIfFailed( HRESULT_FROM_WIN32( GetLastError() ) );
    }

    if (!InitializeCriticalSectionEx( &m_CritSec, 0, 0 ))
    {
        ThrowIfFailed( HRESULT_FROM_WIN32( GetLastError() ) );
    }

    m_DeviceStateChanged = ref new DeviceStateChangedEvent();
    if (nullptr == m_DeviceStateChanged)
    {
        ThrowIfFailed( E_OUTOFMEMORY );
    }

    // Register MMCSS work queue
    HRESULT hr = S_OK;
    DWORD dwTaskID = 0;

    hr = MFLockSharedWorkQueue( L"Capture", 0, &dwTaskID, &m_dwQueueID );
    if (FAILED( hr ))
    {
        ThrowIfFailed( hr );
    }

    // Set the capture event work queue to use the MMCSS queue
    m_xSampleReady.SetQueueID( m_dwQueueID );
}

WASAPICapture::~WASAPICapture ( ) [private]

Definition at line 77 of file WASAPICapture.cpp.

{
    SAFE_RELEASE( m_AudioClient );
    SAFE_RELEASE( m_AudioCaptureClient );
    SAFE_RELEASE( m_SampleReadyAsyncResult );
    SAFE_DELETE( m_DeviceStateChanged );

    if (INVALID_HANDLE_VALUE != m_SampleReadyEvent)
    {
        CloseHandle( m_SampleReadyEvent );
        m_SampleReadyEvent = INVALID_HANDLE_VALUE;
    }

    MFUnlockWorkQueue( m_dwQueueID );

    m_ContentStream = nullptr;
    m_OutputStream = nullptr;
    m_WAVDataWriter = nullptr;

    m_PlotData = nullptr;

    DeleteCriticalSection( &m_CritSec );
}

Member Function Documentation

HRESULT WASAPICapture::ActivateCompleted ( IActivateAudioInterfaceAsyncOperation * operation )

Definition at line 133 of file WASAPICapture.cpp.

{
    HRESULT hr = S_OK;
    HRESULT hrActivateResult = S_OK;
    IUnknown *punkAudioInterface = nullptr;

    // Check for a successful activation result
    hr = operation->GetActivateResult( &hrActivateResult, &punkAudioInterface );
    if (SUCCEEDED( hr ) && SUCCEEDED( hrActivateResult ))
    {
        // Get the pointer for the Audio Client
        punkAudioInterface->QueryInterface( IID_PPV_ARGS(&m_AudioClient) );
        if (nullptr == m_AudioClient)
        {
            hr = E_FAIL;
            goto exit;
        }

        hr = m_AudioClient->GetMixFormat( &m_MixFormat );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // convert from Float to PCM and from WAVEFORMATEXTENSIBLE to WAVEFORMATEX
        if ( (m_MixFormat->wFormatTag == WAVE_FORMAT_IEEE_FLOAT) ||
             ( (m_MixFormat->wFormatTag == WAVE_FORMAT_EXTENSIBLE) &&
               (reinterpret_cast<WAVEFORMATEXTENSIBLE *>(m_MixFormat)->SubFormat == KSDATAFORMAT_SUBTYPE_IEEE_FLOAT) ) )
        {
            m_MixFormat->wFormatTag = WAVE_FORMAT_PCM;
            m_MixFormat->wBitsPerSample = 16;
            m_MixFormat->nBlockAlign = m_MixFormat->nChannels * 2;    // (nChannels * wBitsPerSample) / 8
            m_MixFormat->nAvgBytesPerSec = m_MixFormat->nSamplesPerSec * m_MixFormat->nBlockAlign;
            m_MixFormat->cbSize = 0;
        }

        // Initialize the AudioClient in Shared Mode with the user specified buffer
        hr = m_AudioClient->Initialize( AUDCLNT_SHAREMODE_SHARED,
                                        AUDCLNT_STREAMFLAGS_EVENTCALLBACK,
                                        200000,
                                        0,
                                        m_MixFormat,
                                        nullptr );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Get the maximum size of the AudioClient Buffer
        hr = m_AudioClient->GetBufferSize( &m_BufferFrames );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Get the capture client
        hr = m_AudioClient->GetService( __uuidof(IAudioCaptureClient), (void**) &m_AudioCaptureClient );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Create Async callback for sample events
        hr = MFCreateAsyncResult( nullptr, &m_xSampleReady, nullptr, &m_SampleReadyAsyncResult );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Sets the event handle that the system signals when an audio buffer is ready to be processed by the client
        hr = m_AudioClient->SetEventHandle( m_SampleReadyEvent );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Create the visualization array
        hr = InitializeScopeData();
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Creates the WAV file.  If successful, will set the Initialized event
        hr = CreateWAVFile();
        if (FAILED( hr ))
        {
            goto exit;
        }
    }

exit:
    SAFE_RELEASE( punkAudioInterface );

    if (FAILED( hr ))
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
        SAFE_RELEASE( m_AudioClient );
        SAFE_RELEASE( m_AudioCaptureClient );
        SAFE_RELEASE( m_SampleReadyAsyncResult );
    }

    // Need to return S_OK
    return S_OK;
}

HRESULT WASAPICapture::CreateWAVFile ( ) [private]

Definition at line 244 of file WASAPICapture.cpp.

{
    // Create the WAV file, appending a number if file already exists
    concurrency::task<StorageFile^>( KnownFolders::MusicLibrary->CreateFileAsync( AUDIO_FILE_NAME, CreationCollisionOption::GenerateUniqueName )).then(
        [this]( StorageFile^ file )
    {
        if (nullptr == file)
        {
            ThrowIfFailed( E_INVALIDARG );
        }

        return file->OpenAsync( FileAccessMode::ReadWrite );
    })

    // Then create a RandomAccessStream
    .then([this]( IRandomAccessStream^ stream )
    {
        if (nullptr == stream)
        {
            ThrowIfFailed( E_INVALIDARG );
        }

        // Get the OutputStream for the file
        m_ContentStream = stream;
        m_OutputStream = m_ContentStream->GetOutputStreamAt(0);

        // Create the DataWriter
        m_WAVDataWriter = ref new DataWriter( m_OutputStream );
        if (nullptr == m_WAVDataWriter)
        {
            ThrowIfFailed( E_OUTOFMEMORY );
        }

        // Create the WAV header
        DWORD header[] = {
            FCC('RIFF'),        // RIFF header
            0,                  // Total size of WAV (will be filled in later)
            FCC('WAVE'),        // WAVE FourCC
            FCC('fmt '),        // Start of 'fmt ' chunk
            sizeof(WAVEFORMATEX) + m_MixFormat->cbSize      // Size of fmt chunk
        };

        DWORD data[] = { FCC('data'), 0 };  // Start of 'data' chunk

        auto headerBytes = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>(header), sizeof(header) );
        auto formatBytes = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>(m_MixFormat), sizeof(WAVEFORMATEX) );
        auto dataBytes = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>(data), sizeof(data) );

        if ( (nullptr == headerBytes) || (nullptr == formatBytes) || (nullptr == dataBytes) )
        {
            ThrowIfFailed( E_OUTOFMEMORY );
        }

        // Write the header
        m_WAVDataWriter->WriteBytes( headerBytes );
        m_WAVDataWriter->WriteBytes( formatBytes );
        m_WAVDataWriter->WriteBytes( dataBytes );

        return m_WAVDataWriter->StoreAsync();
    })

    // Wait for file data to be written to file
    .then([this]( unsigned int BytesWritten )
    {
        m_cbHeaderSize = BytesWritten;
        return m_WAVDataWriter->FlushAsync();
    })

    // Our file is ready to go, so we can now signal that initialziation is finished
    .then([this]( bool f )
    {
        try
        {
            m_DeviceStateChanged->SetState( DeviceState::DeviceStateInitialized, S_OK, true );
        }
        catch (Platform::Exception ^e)
        {
            m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, e->HResult, true );
        }
    });

    return S_OK;
}

HRESULT WASAPICapture::FinishCaptureAsync ( )

Definition at line 503 of file WASAPICapture.cpp.

{
    // We should be flushing when this is called
    if (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateFlushing)
    {
        return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xFinishCapture, nullptr );
    }

    // We are in the wrong state
    return E_NOT_VALID_STATE;
}

HRESULT WASAPICapture::FixWAVHeader ( ) [private]

Definition at line 333 of file WASAPICapture.cpp.

{
    auto DataSizeByte = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>( &m_cbDataSize ), sizeof(DWORD) );

    // Write the size of the 'data' chunk first
    IOutputStream^ OutputStream = m_ContentStream->GetOutputStreamAt( m_cbHeaderSize - sizeof(DWORD) );
    m_WAVDataWriter = ref new DataWriter( OutputStream );
    m_WAVDataWriter->WriteBytes( DataSizeByte );

    concurrency::task<unsigned int>( m_WAVDataWriter->StoreAsync()).then(
        [this]( unsigned int BytesWritten )
    {
        DWORD cbTotalSize = m_cbDataSize + m_cbHeaderSize - 8;
        auto TotalSizeByte = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>( &cbTotalSize ), sizeof(DWORD) );

        // Write the total file size, minus RIFF chunk and size
        IOutputStream^ OutputStream = m_ContentStream->GetOutputStreamAt( sizeof(DWORD) );  // sizeof(DWORD) == sizeof(FOURCC)
        m_WAVDataWriter = ref new DataWriter( OutputStream );
        m_WAVDataWriter->WriteBytes( TotalSizeByte );

        concurrency::task<unsigned int>( m_WAVDataWriter->StoreAsync()).then(
            [this]( unsigned int BytesWritten )
        {
            return m_WAVDataWriter->FlushAsync();
        })

        .then(
            [this]( bool f )
        {
            m_DeviceStateChanged->SetState( DeviceState::DeviceStateStopped, S_OK, true );
        });
    });

    return S_OK;
}

DeviceStateChangedEvent SDKSample::WASAPIAudio::WASAPICapture::GetDeviceStateEvent ( ) [inline]

Definition at line 50 of file WASAPICapture.h.

{ return m_DeviceStateChanged; };

HRESULT WASAPICapture::InitializeAudioDeviceAsync ( )

Definition at line 107 of file WASAPICapture.cpp.

{
    IActivateAudioInterfaceAsyncOperation *asyncOp;
    HRESULT hr = S_OK;

    // Get a string representing the Default Audio Capture Device
    m_DeviceIdString = MediaDevice::GetDefaultAudioCaptureId( Windows::Media::Devices::AudioDeviceRole::Default );

    // This call must be made on the main UI thread.  Async operation will call back to
    // IActivateAudioInterfaceCompletionHandler::ActivateCompleted, which must be an agile interface implementation
    hr = ActivateAudioInterfaceAsync( m_DeviceIdString->Data(), __uuidof(IAudioClient2), nullptr, this, &asyncOp );
    if (FAILED( hr ))
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
    }

    SAFE_RELEASE( asyncOp );
    return hr;
}

HRESULT WASAPICapture::InitializeScopeData ( ) [private]

Definition at line 374 of file WASAPICapture.cpp.

{
    HRESULT hr = S_OK;

    m_cPlotDataFilled = 0;
    m_cPlotDataMax = (MILLISECONDS_TO_VISUALIZE * m_MixFormat->nSamplesPerSec) / 1000;

    m_PlotData = ref new Platform::Array<int, 1>( m_cPlotDataMax + 1 );
    if (nullptr == m_PlotData)
    {
        return E_OUTOFMEMORY;
    }

    // Only Support 16 bit Audio for now
    if (m_MixFormat->wBitsPerSample == 16)
    {
        m_PlotData[ m_cPlotDataMax ] = -32768;  // INT16_MAX
    }
    else
    {
        m_PlotData = nullptr;
        hr = S_FALSE;
    }

    return hr;
}

SDKSample::WASAPIAudio::WASAPICapture::METHODASYNCCALLBACK | ( | WASAPICapture | ,
 |  | SendScopeData | ,
 |  | OnSendScopeData |
 | ) |  |
SDKSample::WASAPIAudio::WASAPICapture::METHODASYNCCALLBACK | ( | WASAPICapture | ,
 |  | SampleReady | ,
 |  | OnSampleReady |
 | ) |  |
SDKSample::WASAPIAudio::WASAPICapture::METHODASYNCCALLBACK | ( | WASAPICapture | ,
 |  | FinishCapture | ,
 |  | OnFinishCapture |
 | ) |  |
SDKSample::WASAPIAudio::WASAPICapture::METHODASYNCCALLBACK | ( | WASAPICapture | ,
 |  | StartCapture | ,
 |  | OnStartCapture |
 | ) |  |
SDKSample::WASAPIAudio::WASAPICapture::METHODASYNCCALLBACK | ( | WASAPICapture | ,
 |  | StopCapture | ,
 |  | OnStopCapture |
 | ) |  |
HRESULT WASAPICapture::OnAudioSampleRequested ( Platform::Boolean IsSilence = false ) [private]

Definition at line 559 of file WASAPICapture.cpp.

{
    HRESULT hr = S_OK;
    UINT32 FramesAvailable = 0;
    BYTE *Data = nullptr;
    DWORD dwCaptureFlags;
    UINT64 u64DevicePosition = 0;
    UINT64 u64QPCPosition = 0;
    DWORD cbBytesToCapture = 0;

    EnterCriticalSection( &m_CritSec );

    // If this flag is set, we have already queued up the async call to finialize the WAV header
    // So we don't want to grab or write any more data that would possibly give us an invalid size
    if ( (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateStopping) ||
         (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateFlushing) )
    {
        goto exit;
    }

    // This should equal the buffer size when GetBuffer() is called
    hr = m_AudioCaptureClient->GetNextPacketSize( &FramesAvailable );
    if (FAILED( hr ))
    {
        goto exit;
    }

    if (FramesAvailable > 0)
    {
        cbBytesToCapture = FramesAvailable * m_MixFormat->nBlockAlign;

        // WAV files have a 4GB (0xFFFFFFFF) size limit, so likely we have hit that limit when we
        // overflow here.  Time to stop the capture
        if ( (m_cbDataSize + cbBytesToCapture) < m_cbDataSize )
        {
            StopCaptureAsync();
            goto exit;
        }

        // Get sample buffer
        hr = m_AudioCaptureClient->GetBuffer( &Data, &FramesAvailable, &dwCaptureFlags, &u64DevicePosition, &u64QPCPosition );
        if (FAILED( hr ))
        {
            goto exit;
        }

        if (dwCaptureFlags & AUDCLNT_BUFFERFLAGS_DATA_DISCONTINUITY)
        {
            // Pass down a discontinuity flag in case the app is interested and reset back to capturing
            m_DeviceStateChanged->SetState( DeviceState::DeviceStateDiscontinutity, S_OK, true );
            m_DeviceStateChanged->SetState( DeviceState::DeviceStateCapturing, S_OK, false );
        }

        // Zero out sample if silence
        if ( (dwCaptureFlags & AUDCLNT_BUFFERFLAGS_SILENT) || IsSilence )
        {
            memset( Data, 0, FramesAvailable * m_MixFormat->nBlockAlign );
        }

        // Store data in array
        auto dataByte = ref new Platform::Array<BYTE, 1>( Data, cbBytesToCapture );

        // Release buffer back
        m_AudioCaptureClient->ReleaseBuffer( FramesAvailable );

        // Update plotter data
        ProcessScopeData( Data, cbBytesToCapture );

        // Write File and async store
        m_WAVDataWriter->WriteBytes( dataByte );

        // Increase the size of our 'data' chunk and flush counter.  m_cbDataSize needs to be accurate
        // Its OK if m_cbFlushCounter is an approximation
        m_cbDataSize += cbBytesToCapture;
        m_cbFlushCounter += cbBytesToCapture;

        if ( (m_cbFlushCounter > ( m_MixFormat->nAvgBytesPerSec * FLUSH_INTERVAL_SEC )) && !m_fWriting )
        {
            // Set this flag when about to commit the async storage operation.  We don't want to
            // accidently call stop and finalize the WAV header or run into a scenario where the
            // store operation takes longer than FLUSH_INTERVAL_SEC as multiple concurrent calls
            // to StoreAsync() can cause an exception
            m_fWriting = true;

            // Reset the counter now since we can process more samples during the async callback
            m_cbFlushCounter = 0;

            concurrency::task<unsigned int>( m_WAVDataWriter->StoreAsync()).then(
                [this]( unsigned int BytesWritten )
            {
                m_fWriting = false;

                // We need to check for StopCapture while we are flusing the file.  If it has come through, then we
                // can go ahead and call FinisheCaptureAsync() to write the WAV header
                if (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateStopping)
                {
                    m_DeviceStateChanged->SetState( DeviceState::DeviceStateFlushing, S_OK, true );
                    FinishCaptureAsync();
                }
            });
        }
    }

exit:
    LeaveCriticalSection( &m_CritSec );

    return hr;
}

HRESULT WASAPICapture::OnFinishCapture ( IMFAsyncResult * pResult ) [private]

Definition at line 521 of file WASAPICapture.cpp.

{
    // FixWAVHeader will set the DeviceStateStopped when all async tasks are complete
    return FixWAVHeader();
}

HRESULT WASAPICapture::OnSampleReady ( IMFAsyncResult * pResult ) [private]

Definition at line 532 of file WASAPICapture.cpp.

{
    HRESULT hr = S_OK;

    hr = OnAudioSampleRequested( false );

    if (SUCCEEDED( hr ))
    {
        // Re-queue work item for next sample
        if (m_DeviceStateChanged->GetState() ==  DeviceState::DeviceStateCapturing)
        {
            hr = MFPutWaitingWorkItem( m_SampleReadyEvent, 0, m_SampleReadyAsyncResult, &m_SampleReadyKey );
        }
    }
    else
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
    }

    return hr;
}

HRESULT WASAPICapture::OnSendScopeData ( IMFAsyncResult * pResult ) [private]

Definition at line 720 of file WASAPICapture.cpp.

{
    HRESULT hr = S_OK;
    CAsyncState *pState = nullptr;

    hr = pResult->GetState( reinterpret_cast<IUnknown**>(&pState) );
    if (SUCCEEDED( hr ))
    {
        PlotDataReadyEvent::SendEvent( reinterpret_cast<Platform::Object^>(this), pState->m_Data , pState->m_Size );
    }

    SAFE_RELEASE( pState );

    return S_OK;
}

HRESULT WASAPICapture::OnStartCapture ( IMFAsyncResult * pResult ) [private]

Definition at line 426 of file WASAPICapture.cpp.

{
    HRESULT hr = S_OK;

    // Start the capture
    hr = m_AudioClient->Start();
    if (SUCCEEDED( hr ))
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateCapturing, S_OK, true );
        MFPutWaitingWorkItem( m_SampleReadyEvent, 0, m_SampleReadyAsyncResult, &m_SampleReadyKey );
    }
    else
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
    }

    return S_OK;
}

HRESULT WASAPICapture::OnStopCapture ( IMFAsyncResult * pResult ) [private]

Definition at line 468 of file WASAPICapture.cpp.

{
    // Stop capture by cancelling Work Item
    // Cancel the queued work item (if any)
    if (0 != m_SampleReadyKey)
    {
        MFCancelWorkItem( m_SampleReadyKey );
        m_SampleReadyKey = 0;
    }

    m_AudioClient->Stop();
    SAFE_RELEASE( m_SampleReadyAsyncResult );

    // If this is set, it means we writing from the memory buffer to the actual file asynchronously
    // Since a second call to StoreAsync() can cause an exception, don't queue this now, but rather
    // let the async operation completion handle the call.
    if (!m_fWriting)
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateFlushing, S_OK, true );

        concurrency::task<unsigned int>( m_WAVDataWriter->StoreAsync()).then(
            [this]( unsigned int BytesWritten )
        {
            FinishCaptureAsync();
        });
    }

    return S_OK;
}

HRESULT WASAPICapture::ProcessScopeData | ( | BYTE * | pData,
 |  | DWORD | cbBytes |
 | ) |  |  | [private]

Definition at line 673 of file WASAPICapture.cpp.

{
    HRESULT hr = S_OK;

    // We don't have a valid pointer array, so return.  This could be the case if we aren't
    // dealing with 16-bit audio
    if (m_PlotData == nullptr)
    {
        return S_FALSE;
    }

    DWORD dwNumPoints = cbBytes / m_MixFormat->nChannels / (m_MixFormat->wBitsPerSample / 8);

    // Read the 16-bit samples from channel 0
    INT16 *pi16 = (INT16*)pData;

    for ( DWORD i = 0; m_cPlotDataFilled < m_cPlotDataMax && i < dwNumPoints; i++ )
    {
        m_PlotData[ m_cPlotDataFilled ] = *pi16;
        pi16 += m_MixFormat->nChannels;

        m_cPlotDataFilled++;
    }

    // Send off the event and get ready for the next set of samples
    if (m_cPlotDataFilled == m_cPlotDataMax)
    {
        ComPtr<IUnknown> spUnknown;
        ComPtr<CAsyncState> spState = Make<CAsyncState>( m_PlotData, m_cPlotDataMax + 1 );

        hr = spState.As( &spUnknown );
        if (SUCCEEDED( hr ))
        {
            MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xSendScopeData, spUnknown.Get() );
        }

        m_cPlotDataFilled = 0;
    }

    return hr;
}

HRESULT WASAPICapture::StartCaptureAsync ( )

Definition at line 406 of file WASAPICapture.cpp.

{
    HRESULT hr = S_OK;

    // We should be in the initialzied state if this is the first time through getting ready to capture.
    if (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateInitialized)
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateStarting, S_OK, true );
        return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xStartCapture, nullptr );
    }

    // We are in the wrong state
    return E_NOT_VALID_STATE;
}

HRESULT WASAPICapture::StopCaptureAsync ( )

Definition at line 450 of file WASAPICapture.cpp.

{
    if ( (m_DeviceStateChanged->GetState() != DeviceState::DeviceStateCapturing) &&
         (m_DeviceStateChanged->GetState() != DeviceState::DeviceStateInError) )
    {
        return E_NOT_VALID_STATE;
    }

    m_DeviceStateChanged->SetState( DeviceState::DeviceStateStopping, S_OK, true );

    return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xStopCapture, nullptr );
}

Member Data Documentation

IAudioCaptureClient* SDKSample::WASAPIAudio::WASAPICapture::m_AudioCaptureClient [private]

Definition at line 94 of file WASAPICapture.h.

IAudioClient* SDKSample::WASAPIAudio::WASAPICapture::m_AudioClient [private]

Definition at line 93 of file WASAPICapture.h.

UINT32 SDKSample::WASAPIAudio::WASAPICapture::m_BufferFrames [private]

Definition at line 78 of file WASAPICapture.h.

DWORD SDKSample::WASAPIAudio::WASAPICapture::m_cbDataSize [private]

Definition at line 85 of file WASAPICapture.h.

DWORD SDKSample::WASAPIAudio::WASAPICapture::m_cbFlushCounter [private]

Definition at line 86 of file WASAPICapture.h.

DWORD SDKSample::WASAPIAudio::WASAPICapture::m_cbHeaderSize [private]

Definition at line 84 of file WASAPICapture.h.

IRandomAccessStream SDKSample::WASAPIAudio::WASAPICapture::m_ContentStream [private]

Definition at line 89 of file WASAPICapture.h.

UINT32 SDKSample::WASAPIAudio::WASAPICapture::m_cPlotDataFilled [private]

Definition at line 101 of file WASAPICapture.h.

UINT32 SDKSample::WASAPIAudio::WASAPICapture::m_cPlotDataMax [private]

Definition at line 100 of file WASAPICapture.h.

CRITICAL_SECTION SDKSample::WASAPIAudio::WASAPICapture::m_CritSec [private]

Definition at line 81 of file WASAPICapture.h.

Platform::String SDKSample::WASAPIAudio::WASAPICapture::m_DeviceIdString [private]

Definition at line 77 of file WASAPICapture.h.

DeviceStateChangedEvent SDKSample::WASAPIAudio::WASAPICapture::m_DeviceStateChanged [private]

Definition at line 97 of file WASAPICapture.h.

DWORD SDKSample::WASAPIAudio::WASAPICapture::m_dwQueueID [private]

Definition at line 82 of file WASAPICapture.h.

BOOL SDKSample::WASAPIAudio::WASAPICapture::m_fWriting [private]

Definition at line 87 of file WASAPICapture.h.

WAVEFORMATEX* SDKSample::WASAPIAudio::WASAPICapture::m_MixFormat [private]

Definition at line 92 of file WASAPICapture.h.

IOutputStream SDKSample::WASAPIAudio::WASAPICapture::m_OutputStream [private]

Definition at line 90 of file WASAPICapture.h.

Platform::Array<int, 1> SDKSample::WASAPIAudio::WASAPICapture::m_PlotData [private]

Definition at line 99 of file WASAPICapture.h.

IMFAsyncResult* SDKSample::WASAPIAudio::WASAPICapture::m_SampleReadyAsyncResult [private]

Definition at line 95 of file WASAPICapture.h.

HANDLE SDKSample::WASAPIAudio::WASAPICapture::m_SampleReadyEvent [private]

Definition at line 79 of file WASAPICapture.h.

MFWORKITEM_KEY SDKSample::WASAPIAudio::WASAPICapture::m_SampleReadyKey [private]

Definition at line 80 of file WASAPICapture.h.

DataWriter SDKSample::WASAPIAudio::WASAPICapture::m_WAVDataWriter [private]

Definition at line 91 of file WASAPICapture.h.

The documentation for this class was generated from the following files:
  • Windows Audio Session (WASAPI)/C++/WASAPICapture.h
  • Windows Audio Session (WASAPI)/C++/WASAPICapture.cpp
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WASAPIAudio::WASAPIRenderer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WASAPIAudio
  • SDKSample::WASAPIAudio::WASAPIRenderer
Public Member Functions | Private Member Functions | Private Attributes

SDKSample::WASAPIAudio::WASAPIRenderer Class Reference

#include "WASAPIRenderer.h"

List of all members.

Public Member Functions

WASAPIRenderer ()
STDMETHOD() | ActivateCompleted (IActivateAudioInterfaceAsyncOperation *operation)
DeviceStateChangedEvent | GetDeviceStateEvent ()
HRESULT | InitializeAudioDeviceAsync ()
METHODASYNCCALLBACK (WASAPIRenderer, StartPlayback, OnStartPlayback)
METHODASYNCCALLBACK (WASAPIRenderer, StopPlayback, OnStopPlayback)
METHODASYNCCALLBACK (WASAPIRenderer, PausePlayback, OnPausePlayback)
METHODASYNCCALLBACK (WASAPIRenderer, SampleReady, OnSampleReady)
HRESULT | PausePlaybackAsync ()
HRESULT | SetProperties (DEVICEPROPS props)
HRESULT | SetVolumeOnSession (UINT32 volume)
HRESULT | StartPlaybackAsync ()
HRESULT | StopPlaybackAsync ()

Private Member Functions

~WASAPIRenderer ()
HRESULT | ConfigureDeviceInternal ()
HRESULT | ConfigureSource ()
UINT32 | GetBufferFramesPerPeriod ()
HRESULT | GetMFSample (UINT32 FramesAvailable)
HRESULT | GetToneSample (UINT32 FramesAvailable)
HRESULT | OnAudioSampleRequested (Platform::Boolean IsSilence=false)
HRESULT | OnPausePlayback (IMFAsyncResult *pResult)
HRESULT | OnSampleReady (IMFAsyncResult *pResult)
HRESULT | OnStartPlayback (IMFAsyncResult *pResult)
HRESULT | OnStopPlayback (IMFAsyncResult *pResult)
HRESULT | ValidateBufferValue ()

Private Attributes

IAudioClient2 * | m_AudioClient
IAudioRenderClient * | m_AudioRenderClient
UINT32 | m_BufferFrames
CRITICAL_SECTION | m_CritSec
Platform::String | m_DeviceIdString
DEVICEPROPS m_DeviceProps
DeviceStateChangedEvent | m_DeviceStateChanged
MFSampleGenerator * m_MFSource
WAVEFORMATEX * | m_MixFormat
IMFAsyncResult * | m_SampleReadyAsyncResult
HANDLE | m_SampleReadyEvent
MFWORKITEM_KEY | m_SampleReadyKey
ToneSampleGenerator * m_ToneSource

Detailed Description

Definition at line 48 of file WASAPIRenderer.h.

Constructor & Destructor Documentation

WASAPIRenderer::WASAPIRenderer ( )

Definition at line 24 of file WASAPIRenderer.cpp.

                               :
    m_BufferFrames( 0 ),
    m_DeviceStateChanged( nullptr ),
    m_AudioClient( nullptr ),
    m_AudioRenderClient( nullptr ),
    m_SampleReadyAsyncResult( nullptr ),
    m_ToneSource( nullptr ),
    m_MFSource( nullptr )
{
    // Create events for sample ready or user stop
    m_SampleReadyEvent = CreateEventEx( nullptr, nullptr, 0, EVENT_ALL_ACCESS );
    if (nullptr == m_SampleReadyEvent)
    {
        ThrowIfFailed( HRESULT_FROM_WIN32( GetLastError() ) );
    }

    if (!InitializeCriticalSectionEx( &m_CritSec, 0, 0 ))
    {
        ThrowIfFailed( HRESULT_FROM_WIN32( GetLastError() ) );
    }

    m_DeviceStateChanged = ref new DeviceStateChangedEvent();
    if (nullptr == m_DeviceStateChanged)
    {
        ThrowIfFailed( E_OUTOFMEMORY );
    }
}

WASAPIRenderer::~WASAPIRenderer ( ) [private]

Definition at line 55 of file WASAPIRenderer.cpp.

{
    SAFE_RELEASE( m_AudioClient );
    SAFE_RELEASE( m_AudioRenderClient );
    SAFE_RELEASE( m_SampleReadyAsyncResult );
    SAFE_RELEASE( m_MFSource );
    SAFE_DELETE( m_ToneSource );
    SAFE_DELETE( m_DeviceStateChanged );

    if (INVALID_HANDLE_VALUE != m_SampleReadyEvent)
    {
        CloseHandle( m_SampleReadyEvent );
        m_SampleReadyEvent = INVALID_HANDLE_VALUE;
    }

    DeleteCriticalSection( &m_CritSec );
}

Member Function Documentation

HRESULT WASAPIRenderer::ActivateCompleted ( IActivateAudioInterfaceAsyncOperation * operation )

Definition at line 106 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;
    HRESULT hrActivateResult = S_OK;
    IUnknown *punkAudioInterface = nullptr;

    if (m_DeviceStateChanged->GetState() != DeviceState::DeviceStateUnInitialized)
    {
        hr = E_NOT_VALID_STATE;
        goto exit;
    }

    // Check for a successful activation result
    hr = operation->GetActivateResult( &hrActivateResult, &punkAudioInterface );
    if (SUCCEEDED( hr ) && SUCCEEDED( hrActivateResult ))
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateActivated, S_OK, false );

        // Get the pointer for the Audio Client
        punkAudioInterface->QueryInterface( IID_PPV_ARGS(&m_AudioClient) );
        if( nullptr == m_AudioClient )
        {
            hr = E_FAIL;
            goto exit;
        }

        // Configure user defined properties
        hr = ConfigureDeviceInternal();
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Initialize the AudioClient in Shared Mode with the user specified buffer
        hr = m_AudioClient->Initialize( AUDCLNT_SHAREMODE_SHARED,
                                        AUDCLNT_STREAMFLAGS_EVENTCALLBACK | AUDCLNT_STREAMFLAGS_NOPERSIST,
                                        m_DeviceProps.hnsBufferDuration,
                                        m_DeviceProps.hnsBufferDuration,
                                        m_MixFormat,
                                        nullptr );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Get the maximum size of the AudioClient Buffer
        hr = m_AudioClient->GetBufferSize( &m_BufferFrames );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Get the render client
        hr = m_AudioClient->GetService( __uuidof(IAudioRenderClient), (void**) &m_AudioRenderClient );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Create Async callback for sample events
        hr = MFCreateAsyncResult( nullptr, &m_xSampleReady, nullptr, &m_SampleReadyAsyncResult );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Sets the event handle that the system signals when an audio buffer is ready to be processed by the client
        hr = m_AudioClient->SetEventHandle( m_SampleReadyEvent );
        if (FAILED( hr ))
        {
            goto exit;
        }

        // Everything succeeded
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInitialized, S_OK, true );

    }

exit:
    SAFE_RELEASE( punkAudioInterface );

    if (FAILED( hr ))
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
        SAFE_RELEASE( m_AudioClient );
        SAFE_RELEASE( m_AudioRenderClient );
        SAFE_RELEASE( m_SampleReadyAsyncResult );
    }

    // Need to return S_OK
    return S_OK;
}

HRESULT WASAPIRenderer::ConfigureDeviceInternal ( ) [private]

Definition at line 242 of file WASAPIRenderer.cpp.

{
    if (m_DeviceStateChanged->GetState() != DeviceState::DeviceStateActivated)
    {
        return E_NOT_VALID_STATE;
    }

    HRESULT hr = S_OK;

    // Opt into HW Offloading.  If the endpoint does not support offload it will return AUDCLNT_E_ENDPOINT_OFFLOAD_NOT_CAPABLE
    AudioClientProperties audioProps;
    audioProps.cbSize = sizeof( AudioClientProperties );
    audioProps.bIsOffload = m_DeviceProps.IsHWOffload;
    audioProps.eCategory = ( m_DeviceProps.IsBackground ? AudioCategory_BackgroundCapableMedia : AudioCategory_ForegroundOnlyMedia );

    hr = m_AudioClient->SetClientProperties( &audioProps );
    if (FAILED( hr ))
    {
        return hr;
    }

    // This sample opens the device is shared mode so we need to find the supported WAVEFORMATEX mix format
    hr = m_AudioClient->GetMixFormat( &m_MixFormat );
    if (FAILED( hr ))
    {
        return hr;
    }

    // Verify the user defined value for hardware buffer
    hr = ValidateBufferValue();

    return hr;
}

HRESULT WASAPIRenderer::ConfigureSource ( ) [private]

Definition at line 348 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;
    UINT32 FramesPerPeriod = GetBufferFramesPerPeriod();

    if (m_DeviceProps.IsTonePlayback)
    {
        // Generate the sine wave sample buffer
        m_ToneSource = new ToneSampleGenerator();
        if (m_ToneSource)
        {
            hr = m_ToneSource->GenerateSampleBuffer( m_DeviceProps.Frequency, FramesPerPeriod, m_MixFormat );
        }
        else
        {
            hr = E_OUTOFMEMORY;
        }
    }
    else
    {
        m_MFSource = new MFSampleGenerator();
        if (m_MFSource)
        {
            hr = m_MFSource->Initialize( m_DeviceProps.ContentStream, FramesPerPeriod, m_MixFormat );
        }
        else
        {
            hr = E_OUTOFMEMORY;
        }
    }

    return hr;
}

UINT32 WASAPIRenderer::GetBufferFramesPerPeriod ( ) [private]

Definition at line 215 of file WASAPIRenderer.cpp.

{
    REFERENCE_TIME defaultDevicePeriod = 0;
    REFERENCE_TIME minimumDevicePeriod = 0;

    if (m_DeviceProps.IsHWOffload)
    {
        return m_BufferFrames;
    }

    // Get the audio device period
    HRESULT hr = m_AudioClient->GetDevicePeriod( &defaultDevicePeriod, &minimumDevicePeriod);
    if (FAILED( hr ))
    {
        return 0;
    }

    double devicePeriodInSeconds = defaultDevicePeriod / (10000.0*1000.0);

    return static_cast<UINT32>( m_MixFormat->nSamplesPerSec * devicePeriodInSeconds + 0.5 );
}

DeviceStateChangedEvent SDKSample::WASAPIAudio::WASAPIRenderer::GetDeviceStateEvent ( ) [inline]

Definition at line 61 of file WASAPIRenderer.h.

{ return m_DeviceStateChanged; };

HRESULT WASAPIRenderer::GetMFSample ( UINT32 FramesAvailable ) [private]

Definition at line 704 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;
    BYTE *Data = nullptr;

    // Post-Roll Silence
    if (m_MFSource->IsEOF())
    {
        hr = m_AudioRenderClient->GetBuffer( FramesAvailable, &Data );
        if (SUCCEEDED( hr ))
        {
            // Ignore the return
            hr = m_AudioRenderClient->ReleaseBuffer( FramesAvailable, AUDCLNT_BUFFERFLAGS_SILENT );
        }

        StopPlaybackAsync();
    }
    else
    {
        UINT32 ActualBytesRead = 0;
        UINT32 ActualBytesToRead = FramesAvailable * m_MixFormat->nBlockAlign;

        hr = m_AudioRenderClient->GetBuffer( FramesAvailable, &Data );
        if (SUCCEEDED( hr ))
        {
            hr = m_MFSource->FillSampleBuffer( ActualBytesToRead, Data, &ActualBytesRead );
            if (hr == S_FALSE)
            {
                // Hit EOS
                hr = m_AudioRenderClient->ReleaseBuffer( FramesAvailable, AUDCLNT_BUFFERFLAGS_SILENT );
                StopPlaybackAsync();
            }
            else if (SUCCEEDED( hr ))
            {
                // This can happen if we are pre-rolling so just insert silence
                if (0 == ActualBytesRead)
                {
                    hr = m_AudioRenderClient->ReleaseBuffer( FramesAvailable, AUDCLNT_BUFFERFLAGS_SILENT );
                }
                else
                {
                    hr = m_AudioRenderClient->ReleaseBuffer( ( ActualBytesRead / m_MixFormat->nBlockAlign ), 0 );
                }
            }
        }
    }

    return hr;
}

HRESULT WASAPIRenderer::GetToneSample ( UINT32 FramesAvailable ) [private]

Definition at line 663 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;
    BYTE *Data;

    // Post-Roll Silence
    if (m_ToneSource->IsEOF())
    {
        hr = m_AudioRenderClient->GetBuffer( FramesAvailable, &Data );
        if (SUCCEEDED( hr ))
        {
            // Ignore the return
            hr = m_AudioRenderClient->ReleaseBuffer( FramesAvailable, AUDCLNT_BUFFERFLAGS_SILENT );
        }

        StopPlaybackAsync();
    }
    else if (m_ToneSource->GetBufferLength() <= ( FramesAvailable * m_MixFormat->nBlockAlign ))
    {
        UINT32 ActualFramesToRead = m_ToneSource->GetBufferLength() / m_MixFormat->nBlockAlign;
        UINT32 ActualBytesToRead = ActualFramesToRead * m_MixFormat->nBlockAlign;

        hr = m_AudioRenderClient->GetBuffer( ActualFramesToRead, &Data );
        if (SUCCEEDED( hr ))
        {
            hr = m_ToneSource->FillSampleBuffer( ActualBytesToRead, Data );
            if (SUCCEEDED( hr ))
            {
                hr = m_AudioRenderClient->ReleaseBuffer( ActualFramesToRead, 0 );
            }
        }
    }

    return hr;
}

HRESULT WASAPIRenderer::InitializeAudioDeviceAsync ( )

Definition at line 79 of file WASAPIRenderer.cpp.

{
    IActivateAudioInterfaceAsyncOperation *asyncOp;
    HRESULT hr = S_OK;

    // Get a string representing the Default Audio Device Renderer
    m_DeviceIdString = MediaDevice::GetDefaultAudioRenderId( Windows::Media::Devices::AudioDeviceRole::Default );

    // This call must be made on the main UI thread.  Async operation will call back to
    // IActivateAudioInterfaceCompletionHandler::ActivateCompleted, which must be an agile interface implementation
    hr = ActivateAudioInterfaceAsync( m_DeviceIdString->Data(), __uuidof(IAudioClient2), nullptr, this, &asyncOp );
    if (FAILED( hr ))
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
    }

    SAFE_RELEASE( asyncOp );

    return hr;
}

SDKSample::WASAPIAudio::WASAPIRenderer::METHODASYNCCALLBACK | ( | WASAPIRenderer | ,
 |  | StartPlayback | ,
 |  | OnStartPlayback |
 | ) |  |
SDKSample::WASAPIAudio::WASAPIRenderer::METHODASYNCCALLBACK | ( | WASAPIRenderer | ,
 |  | StopPlayback | ,
 |  | OnStopPlayback |
 | ) |  |
SDKSample::WASAPIAudio::WASAPIRenderer::METHODASYNCCALLBACK | ( | WASAPIRenderer | ,
 |  | PausePlayback | ,
 |  | OnPausePlayback |
 | ) |  |
SDKSample::WASAPIAudio::WASAPIRenderer::METHODASYNCCALLBACK | ( | WASAPIRenderer | ,
 |  | SampleReady | ,
 |  | OnSampleReady |
 | ) |  |
HRESULT WASAPIRenderer::OnAudioSampleRequested ( Platform::Boolean IsSilence = false ) [private]

Definition at line 578 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;
    UINT32 PaddingFrames = 0;
    UINT32 FramesAvailable = 0;

    EnterCriticalSection( &m_CritSec );

    // Get padding in existing buffer
    hr = m_AudioClient->GetCurrentPadding( &PaddingFrames );
    if (FAILED( hr ))
    {
        goto exit;
    }

    // Audio frames available in buffer
    if (m_DeviceProps.IsHWOffload)
    {
        // In HW mode, GetCurrentPadding returns the number of available frames in the
        // buffer, so we can just use that directly
        FramesAvailable = PaddingFrames;
    }
    else
    {
        // In non-HW shared mode, GetCurrentPadding represents the number of queued frames
        // so we can subtract that from the overall number of frames we have
        FramesAvailable = m_BufferFrames - PaddingFrames;
    }

    // Only continue if we have buffer to write data
    if (FramesAvailable > 0)
    {
        if (IsSilence)
        {
            BYTE *Data;

            // Fill the buffer with silence
            hr = m_AudioRenderClient->GetBuffer( FramesAvailable, &Data );
            if (FAILED( hr ))
            {
                goto exit;
            }

            hr = m_AudioRenderClient->ReleaseBuffer( FramesAvailable, AUDCLNT_BUFFERFLAGS_SILENT );
            goto exit;
        }

        // Even if we cancel a work item, this may still fire due to the async
        // nature of things.  There should be a queued work item already to handle
        // the process of stopping or stopped
        if (m_DeviceStateChanged->GetState() == DeviceState::DeviceStatePlaying)
        {
            // Fill the buffer with a playback sample
            if (m_DeviceProps.IsTonePlayback)
            {
                hr = GetToneSample( FramesAvailable );
            }
            else
            {
                hr = GetMFSample( FramesAvailable );
            }
        }
    }

exit:
    LeaveCriticalSection( &m_CritSec );

    if (AUDCLNT_E_RESOURCES_INVALIDATED == hr)
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateUnInitialized, hr, false );
        SAFE_RELEASE( m_AudioClient );
        SAFE_RELEASE( m_AudioRenderClient );
        SAFE_RELEASE( m_SampleReadyAsyncResult );

        hr = InitializeAudioDeviceAsync();
    }

    return hr;
}

HRESULT WASAPIRenderer::OnPausePlayback ( IMFAsyncResult * pResult ) [private]

Definition at line 539 of file WASAPIRenderer.cpp.

{
    m_AudioClient->Stop();
    m_DeviceStateChanged->SetState( DeviceState::DeviceStatePaused, S_OK, true );
    return S_OK;
}

HRESULT WASAPIRenderer::OnSampleReady ( IMFAsyncResult * pResult ) [private]

Definition at line 551 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;

    hr = OnAudioSampleRequested( false );

    if (SUCCEEDED( hr ))
    {
        // Re-queue work item for next sample
        if (m_DeviceStateChanged->GetState() ==  DeviceState::DeviceStatePlaying)
        {
            hr = MFPutWaitingWorkItem( m_SampleReadyEvent, 0, m_SampleReadyAsyncResult, &m_SampleReadyKey );
        }
    }
    else
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
    }

    return hr;
}

HRESULT WASAPIRenderer::OnStartPlayback ( IMFAsyncResult * pResult ) [private]

Definition at line 421 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;

    // Pre-Roll the buffer with silence
    hr = OnAudioSampleRequested( true );
    if (FAILED( hr ))
    {
        goto exit;
    }

    // For MF Source playback, need to start the source reader
    if (!m_DeviceProps.IsTonePlayback)
    {
        hr = m_MFSource->StartSource();
        if (FAILED( hr ))
        {
            goto exit;
        }
    }

    // Actually start the playback
    hr = m_AudioClient->Start();
    if (SUCCEEDED( hr ))
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStatePlaying, S_OK, true );
        hr = MFPutWaitingWorkItem( m_SampleReadyEvent, 0, m_SampleReadyAsyncResult, &m_SampleReadyKey );
    }

exit:
    if (FAILED( hr ))
    {
        m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
    }

    return S_OK;
}

HRESULT WASAPIRenderer::OnStopPlayback ( IMFAsyncResult * pResult ) [private]

Definition at line 483 of file WASAPIRenderer.cpp.

{
    // Stop playback by cancelling Work Item
    // Cancel the queued work item (if any)
    if (0 != m_SampleReadyKey)
    {
        MFCancelWorkItem( m_SampleReadyKey );
        m_SampleReadyKey = 0;
    }

    // Flush anything left in buffer with silence
    OnAudioSampleRequested( true );

    m_AudioClient->Stop();
    SAFE_RELEASE( m_SampleReadyAsyncResult );

    if (m_DeviceProps.IsTonePlayback)
    {
        // Flush remaining buffers
        m_ToneSource->Flush();
    }
    else
    {
        // Stop Source and Flush remaining buffers
        m_MFSource->StopSource();
        m_MFSource->Shutdown();
    }

    m_DeviceStateChanged->SetState( DeviceState::DeviceStateStopped, S_OK, true );
    return S_OK;
}

HRESULT WASAPIRenderer::PausePlaybackAsync ( )

Definition at line 520 of file WASAPIRenderer.cpp.

{
    if ( (m_DeviceStateChanged->GetState() !=  DeviceState::DeviceStatePlaying) &&
         (m_DeviceStateChanged->GetState() != DeviceState::DeviceStateInError) )
    {
        return E_NOT_VALID_STATE;
    }

    // Change state to stop automatic queueing of samples
    m_DeviceStateChanged->SetState( DeviceState::DeviceStatePausing, S_OK, false );
    return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xPausePlayback, nullptr );

}

HRESULT WASAPIRenderer::SetProperties ( DEVICEPROPS props )

Definition at line 204 of file WASAPIRenderer.cpp.

{
    m_DeviceProps = props;
    return S_OK;
}

HRESULT WASAPIRenderer::SetVolumeOnSession ( UINT32 volume )

Definition at line 316 of file WASAPIRenderer.cpp.

{
    if (volume > 100)
    {
        return E_INVALIDARG;
    }

    HRESULT hr = S_OK;
    ISimpleAudioVolume *SessionAudioVolume = nullptr;
    float ChannelVolume = 0.0;

    hr = m_AudioClient->GetService( __uuidof(ISimpleAudioVolume), reinterpret_cast<void**>(&SessionAudioVolume) );
    if (FAILED( hr ))
    {
        goto exit;
    }

    ChannelVolume = volume / (float)100.0;

    // Set the session volume on the endpoint
    hr = SessionAudioVolume->SetMasterVolume( ChannelVolume, nullptr );

exit:
    SAFE_RELEASE( SessionAudioVolume );
    return hr;
}

HRESULT WASAPIRenderer::StartPlaybackAsync ( )

Definition at line 387 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;

    // We should be stopped if the user stopped playback, or we should be
    // initialzied if this is the first time through getting ready to playback.
    if ( (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateStopped) ||
         (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateInitialized) )
    {
        // Setup either ToneGeneration or File Playback
        hr = ConfigureSource();
        if (FAILED( hr ))
        {
            m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
            return hr;
        }

        m_DeviceStateChanged->SetState( DeviceState::DeviceStateStarting, S_OK, true );
        return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xStartPlayback, nullptr );
    }
    else if (m_DeviceStateChanged->GetState() == DeviceState::DeviceStatePaused)
    {
        return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xStartPlayback, nullptr );
    }

    // Otherwise something else happened
    return E_FAIL;
}

HRESULT WASAPIRenderer::StopPlaybackAsync ( )

Definition at line 464 of file WASAPIRenderer.cpp.

{
    if ( (m_DeviceStateChanged->GetState() != DeviceState::DeviceStatePlaying) &&
         (m_DeviceStateChanged->GetState() != DeviceState::DeviceStatePaused) &&
         (m_DeviceStateChanged->GetState() != DeviceState::DeviceStateInError) )
    {
        return E_NOT_VALID_STATE;
    }

    m_DeviceStateChanged->SetState( DeviceState::DeviceStateStopping, S_OK, true );

    return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xStopPlayback, nullptr );
}

HRESULT WASAPIRenderer::ValidateBufferValue ( ) [private]

Definition at line 281 of file WASAPIRenderer.cpp.

{
    HRESULT hr = S_OK;

    if (!m_DeviceProps.IsHWOffload)
    {
        // If we aren't using HW Offload, set this to 0 to use the default value
        m_DeviceProps.hnsBufferDuration = 0;
        return hr;
    }

    REFERENCE_TIME hnsMinBufferDuration;
    REFERENCE_TIME hnsMaxBufferDuration;

    hr = m_AudioClient->GetBufferSizeLimits( m_MixFormat, true, &hnsMinBufferDuration, &hnsMaxBufferDuration );
    if (SUCCEEDED( hr ))
    {
        if (m_DeviceProps.hnsBufferDuration < hnsMinBufferDuration)
        {
            // using MINIMUM size instead
            m_DeviceProps.hnsBufferDuration = hnsMinBufferDuration;
        }
        else if (hnsMinBufferDuration > hnsMaxBufferDuration)
        {
            // using MAXIMUM size instead
            m_DeviceProps.hnsBufferDuration = hnsMaxBufferDuration;
        }
    }

    return hr;
}

Member Data Documentation

IAudioClient2* SDKSample::WASAPIAudio::WASAPIRenderer::m_AudioClient [private]

Definition at line 96 of file WASAPIRenderer.h.

IAudioRenderClient* SDKSample::WASAPIAudio::WASAPIRenderer::m_AudioRenderClient [private]

Definition at line 97 of file WASAPIRenderer.h.

UINT32 SDKSample::WASAPIAudio::WASAPIRenderer::m_BufferFrames [private]

Definition at line 90 of file WASAPIRenderer.h.

CRITICAL_SECTION SDKSample::WASAPIAudio::WASAPIRenderer::m_CritSec [private]

Definition at line 93 of file WASAPIRenderer.h.

Platform::String SDKSample::WASAPIAudio::WASAPIRenderer::m_DeviceIdString [private]

Definition at line 89 of file WASAPIRenderer.h.

DEVICEPROPS SDKSample::WASAPIAudio::WASAPIRenderer::m_DeviceProps [private]

Definition at line 101 of file WASAPIRenderer.h.

DeviceStateChangedEvent SDKSample::WASAPIAudio::WASAPIRenderer::m_DeviceStateChanged [private]

Definition at line 100 of file WASAPIRenderer.h.

MFSampleGenerator* SDKSample::WASAPIAudio::WASAPIRenderer::m_MFSource [private]

Definition at line 104 of file WASAPIRenderer.h.

WAVEFORMATEX* SDKSample::WASAPIAudio::WASAPIRenderer::m_MixFormat [private]

Definition at line 95 of file WASAPIRenderer.h.

IMFAsyncResult* SDKSample::WASAPIAudio::WASAPIRenderer::m_SampleReadyAsyncResult [private]

Definition at line 98 of file WASAPIRenderer.h.

HANDLE SDKSample::WASAPIAudio::WASAPIRenderer::m_SampleReadyEvent [private]

Definition at line 91 of file WASAPIRenderer.h.

MFWORKITEM_KEY SDKSample::WASAPIAudio::WASAPIRenderer::m_SampleReadyKey [private]

Definition at line 92 of file WASAPIRenderer.h.

ToneSampleGenerator* SDKSample::WASAPIAudio::WASAPIRenderer::m_ToneSource [private]

Definition at line 103 of file WASAPIRenderer.h.

The documentation for this class was generated from the following files:
  • Windows Audio Session (WASAPI)/C++/WASAPIRenderer.h
  • Windows Audio Session (WASAPI)/C++/WASAPIRenderer.cpp
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WebAuthentication::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WebAuthentication
  • SDKSample::WebAuthentication::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::WebAuthentication::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Launch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Launch_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

MainPage rootPage

Detailed Description

Definition at line 30 of file Scenario1.xaml.h.

Member Function Documentation

void SDKSample::WebAuthentication::sealed::Launch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebAuthentication::sealed::Launch_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::WebAuthentication::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebAuthentication::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::WebAuthentication::sealed::Scenario1 ( )
SDKSample::WebAuthentication::sealed::Scenario2 ( )

Member Data Documentation

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • Web authentication broker/C++/Scenario1.xaml.h
  • Web authentication broker/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WebSocket::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WebSocket
  • SDKSample::WebSocket::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::WebSocket::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "Scenario1.xaml.h"

List of all members.

Public Member Functions

Scenario1 ()
Scenario2 ()

Protected Member Functions

virtual void | OnNavigatedTo (NavigationEventArgs^e) override
virtual void | OnNavigatedTo (NavigationEventArgs^e) override

Private Member Functions

~Scenario1 ()
~Scenario2 ()
void | Close_Click (Object^sender, RoutedEventArgs^e)
void | Closed (IWebSocket^sender, WebSocketClosedEventArgs^args)
void | HandleException (Exception^exception)
void | HandleException (Exception^exception)
void | MarshalText (TextBox^output, String^value, bool append)
void | MarshalText (TextBox^output, String^value)
void | MarshalText (TextBox^output, String^value, bool append)
void | MarshalText (TextBox^output, String^value)
void | MessageReceived (MessageWebSocket^sender, MessageWebSocketMessageReceivedEventArgs^args)
void | Scenario2Closed (IWebSocket^sender, WebSocketClosedEventArgs^args)
void | Scenario2ReceiveData ()
void | Scenario2SendData ()
void | SendMessage ()
void | Start_Click (Object^sender, RoutedEventArgs^e)
void | Start_Click (Object^sender, RoutedEventArgs^e)
void | Stop_Click (Object^sender, RoutedEventArgs^e)

Private Attributes

int | bytesReceived
CRITICAL_SECTION | criticalSection
int | dataSent
MessageWebSocket | messageWebSocket
DataWriter | messageWriter
IBuffer | readBuffer
MainPage rootPage
IBuffer | sendBuffer
StreamWebSocket | streamWebSocket

Detailed Description

Definition at line 39 of file Scenario1.xaml.h.

Constructor & Destructor Documentation

SDKSample::WebSocket::sealed::~Scenario1 ( ) [private]
SDKSample::WebSocket::sealed::~Scenario2 ( ) [private]

Member Function Documentation

void SDKSample::WebSocket::sealed::Close_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::Closed | ( | IWebSocket^ | sender,
 |  | WebSocketClosedEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::HandleException ( Exception^ exception ) [private]
void SDKSample::WebSocket::sealed::HandleException ( Exception^ exception ) [private]
void SDKSample::WebSocket::sealed::MarshalText | ( | TextBox^ | output,
 |  | String^ | value |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::MarshalText | ( | TextBox^ | output,
 |  | String^ | value,
 |  | bool | append |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::MarshalText | ( | TextBox^ | output,
 |  | String^ | value |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::MarshalText | ( | TextBox^ | output,
 |  | String^ | value,
 |  | bool | append |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::MessageReceived | ( | MessageWebSocket^ | sender,
 |  | MessageWebSocketMessageReceivedEventArgs^ | args |
 | ) |  |  | [private]
virtual void SDKSample::WebSocket::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebSocket::sealed::OnNavigatedTo ( NavigationEventArgs^ e ) [override, protected, virtual]
SDKSample::WebSocket::sealed::Scenario1 ( )
SDKSample::WebSocket::sealed::Scenario2 ( )
void SDKSample::WebSocket::sealed::Scenario2Closed | ( | IWebSocket^ | sender,
 |  | WebSocketClosedEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::Scenario2ReceiveData ( ) [private]
void SDKSample::WebSocket::sealed::Scenario2SendData ( ) [private]
void SDKSample::WebSocket::sealed::SendMessage ( ) [private]
void SDKSample::WebSocket::sealed::Start_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::Start_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebSocket::sealed::Stop_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

int SDKSample::WebSocket::sealed::bytesReceived [private]

Definition at line 53 of file Scenario2.xaml.h.

CRITICAL_SECTION sealed::criticalSection [private]

Definition at line 52 of file Scenario1.xaml.h.

int SDKSample::WebSocket::sealed::dataSent [private]

Definition at line 54 of file Scenario2.xaml.h.

MessageWebSocket SDKSample::WebSocket::sealed::messageWebSocket [private]

Definition at line 50 of file Scenario1.xaml.h.

DataWriter SDKSample::WebSocket::sealed::messageWriter [private]

Definition at line 51 of file Scenario1.xaml.h.

IBuffer SDKSample::WebSocket::sealed::readBuffer [private]

Definition at line 51 of file Scenario2.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 49 of file Scenario1.xaml.h.

IBuffer SDKSample::WebSocket::sealed::sendBuffer [private]

Definition at line 52 of file Scenario2.xaml.h.

StreamWebSocket SDKSample::WebSocket::sealed::streamWebSocket [private]

Definition at line 50 of file Scenario2.xaml.h.

The documentation for this class was generated from the following files:
  • Connecting with WebSockets/C++/Scenario1.xaml.h
  • Connecting with WebSockets/C++/Scenario2.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WebViewControl::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • WebViewControl
  • SDKSample::WebViewControl::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::WebViewControl::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "PageWithAppBar.xaml.h"

List of all members.

Public Member Functions

PageWithAppBar ()
Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()
Scenario5 ()
Scenario6 ()
Scenario7 ()
Scenario8 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | Address_KeyUp (Platform::Object^sender, Windows::UI::Xaml::Input::KeyRoutedEventArgs^e)
void | BottomAppBar_Closed (Platform::Object^sender, Platform::Object^obj)
void | BottomAppBar_Opened (Platform::Object^sender, Platform::Object^obj)
void | ComboBox1_DropDownClosed (Platform::Object^sender, Platform::Object^e)
void | ComboBox1_DropDownOpened (Platform::Object^sender, Platform::Object^e)
void | dataTransferManager_DataRequested (Windows::ApplicationModel::DataTransfer::DataTransferManager^sender, Windows::ApplicationModel::DataTransfer::DataRequestedEventArgs^args)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Default_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoSomething_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | FireScript_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Go_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Home_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Load_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Load_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Nav_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | NavigateButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | NavToString_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Other_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Script_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Share_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowMe_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Solution_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | WebView1_LoadCompleted (Platform::Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | WebView4_ScriptNotify (Platform::Object^sender, Windows::UI::Xaml::Controls::NotifyEventArgs^e)
void | WebView5_LoadCompleted (Platform::Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)
void | WebView5_ScriptNotify (Platform::Object^sender, Windows::UI::Xaml::Controls::NotifyEventArgs^e)
void | WebView7_LoadCompleted (Platform::Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | dataRequestedToken
Platform::Agile
< Windows::ApplicationModel::DataTransfer::DataTransferManager > 		dataTransferManager
MainPage rootPage

Detailed Description

Definition at line 30 of file PageWithAppBar.xaml.h.

Member Function Documentation

void SDKSample::WebViewControl::sealed::Address_KeyUp | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::KeyRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::BottomAppBar_Closed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | obj |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::BottomAppBar_Opened | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | obj |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::ComboBox1_DropDownClosed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::ComboBox1_DropDownOpened | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::dataTransferManager_DataRequested | ( | Windows::ApplicationModel::DataTransfer::DataTransferManager^ | sender,
 |  | Windows::ApplicationModel::DataTransfer::DataRequestedEventArgs^ | args |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Default_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::DoSomething_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::FireScript_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Go_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Home_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Load_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Load_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Nav_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::NavigateButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::NavToString_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::WebViewControl::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::WebViewControl::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Other_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SDKSample::WebViewControl::sealed::PageWithAppBar ( )
SDKSample::WebViewControl::sealed::Scenario1 ( )
SDKSample::WebViewControl::sealed::Scenario2 ( )
SDKSample::WebViewControl::sealed::Scenario3 ( )
SDKSample::WebViewControl::sealed::Scenario4 ( )
SDKSample::WebViewControl::sealed::Scenario5 ( )
SDKSample::WebViewControl::sealed::Scenario6 ( )
SDKSample::WebViewControl::sealed::Scenario7 ( )
SDKSample::WebViewControl::sealed::Scenario8 ( )
void SDKSample::WebViewControl::sealed::Script_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Share_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::ShowMe_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::Solution_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::WebView1_LoadCompleted | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::WebView4_ScriptNotify | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::NotifyEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::WebView5_LoadCompleted | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::WebView5_ScriptNotify | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::NotifyEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::WebViewControl::sealed::WebView7_LoadCompleted | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Navigation::NavigationEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken SDKSample::WebViewControl::sealed::dataRequestedToken [private]

Definition at line 44 of file Scenario7.xaml.h.

Platform::Agile<Windows::ApplicationModel::DataTransfer::DataTransferManager> SDKSample::WebViewControl::sealed::dataTransferManager [private]

Definition at line 40 of file Scenario7.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 39 of file PageWithAppBar.xaml.h.

The documentation for this class was generated from the following files:
  • XAML WebView control/C++/PageWithAppBar.xaml.h
  • XAML WebView control/C++/Scenario1.xaml.h
  • XAML WebView control/C++/Scenario2.xaml.h
  • XAML WebView control/C++/Scenario3.xaml.h
  • XAML WebView control/C++/Scenario4.xaml.h
  • XAML WebView control/C++/Scenario5.xaml.h
  • XAML WebView control/C++/Scenario6.xaml.h
  • XAML WebView control/C++/Scenario7.xaml.h
  • XAML WebView control/C++/Scenario8.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::XAMLPopup::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKSample
  • XAMLPopup
  • SDKSample::XAMLPopup::sealed
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SDKSample::XAMLPopup::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "PopupInputContent.xaml.h"

List of all members.

Public Member Functions

PopupInputContent ()
Scenario1 ()
Scenario2 ()
Scenario3 ()

Protected Member Functions

virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override

Private Member Functions

void | CloseAnimatedPopupClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ClosePopupClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ClosePopupClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | CloseSettingsPopupClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | DoSomething_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnPopupClosed (Platform::Object^sender, Platform::Object^args)
void | ShowPopupAnimationClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowPopupLightDismissClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowPopupOffsetClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowPopupSettingsClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowPopupWithoutParentClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ShowPopupWithParentClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SimulateSaveClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::UI::Xaml::Controls::Primitives::Popup | nonParentPopup
MainPage rootPage

Detailed Description

Definition at line 14 of file PopupInputContent.xaml.h.

Member Function Documentation

void SDKSample::XAMLPopup::sealed::CloseAnimatedPopupClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::ClosePopupClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::ClosePopupClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::CloseSettingsPopupClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::DoSomething_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SDKSample::XAMLPopup::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::XAMLPopup::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SDKSample::XAMLPopup::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SDKSample::XAMLPopup::sealed::OnPopupClosed | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | args |
 | ) |  |  | [private]
SDKSample::XAMLPopup::sealed::PopupInputContent ( )
SDKSample::XAMLPopup::sealed::Scenario1 ( )
SDKSample::XAMLPopup::sealed::Scenario2 ( )
SDKSample::XAMLPopup::sealed::Scenario3 ( )
void SDKSample::XAMLPopup::sealed::ShowPopupAnimationClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::ShowPopupLightDismissClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::ShowPopupOffsetClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::ShowPopupSettingsClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::ShowPopupWithoutParentClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::ShowPopupWithParentClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SDKSample::XAMLPopup::sealed::SimulateSaveClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::UI::Xaml::Controls::Primitives::Popup SDKSample::XAMLPopup::sealed::nonParentPopup [private]

Definition at line 40 of file Scenario2.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file Scenario1.xaml.h.

The documentation for this class was generated from the following files:
  • XAML Popup/C++/PopupInputContent.xaml.h
  • XAML Popup/C++/Scenario1.xaml.h
  • XAML Popup/C++/Scenario2.xaml.h
  • XAML Popup/C++/Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplate
  • SDKTemplate::App
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions

SDKTemplate::App Class Reference

Provides application-specific behavior to supplement the default Application class.

List of all members.

Public Member Functions

App ()
App ()
App ()
App ()
App ()

Public Attributes

LaunchActivatedEventArgs | LaunchArgs

Protected Member Functions

override void | OnActivated (IActivatedEventArgs args)
async override void | OnLaunched (LaunchActivatedEventArgs args)
async override void | OnLaunched (LaunchActivatedEventArgs args)
async override void | OnLaunched (LaunchActivatedEventArgs args)
async override void | OnLaunched (LaunchActivatedEventArgs args)
async override void | OnLaunched (LaunchActivatedEventArgs args)

Private Member Functions

async void | OnSuspending (object sender, SuspendingEventArgs args)
async void | OnSuspending (object sender, SuspendingEventArgs args)
async void | OnSuspending (object sender, SuspendingEventArgs args)
async void | OnSuspending (object sender, SuspendingEventArgs args)
async void | OnSuspending (object sender, SuspendingEventArgs args)

Detailed Description

Definition at line 23 of file App.xaml.cs.

Constructor & Destructor Documentation

SDKTemplate::App::App ( ) [inline]

Initializes the singleton application object.

This is the first line of authored code executed, and as such is the logical equivalent of main() or WinMain().

Definition at line 31 of file App.xaml.cs.

        {
            this.InitializeComponent();
            this.Suspending += new SuspendingEventHandler(OnSuspending);
        }

SDKTemplate::App::App ( ) [inline]

Initializes the singleton application object.

This is the first line of authored code executed, and as such is the logical equivalent of main() or WinMain().

Definition at line 31 of file App.xaml.cs.

        {
            this.InitializeComponent();
            this.Suspending += new SuspendingEventHandler(OnSuspending);
        }

SDKTemplate::App::App ( ) [inline]

Initializes the singleton application object.

This is the first line of authored code executed, and as such is the logical equivalent of main() or WinMain().

Definition at line 31 of file App.xaml.cs.

        {
            this.InitializeComponent();
            this.Suspending += new SuspendingEventHandler(OnSuspending);
        }

SDKTemplate::App::App ( ) [inline]

Initializes the singleton application object.

This is the first line of authored code executed, and as such is the logical equivalent of main() or WinMain().

Definition at line 31 of file App.xaml.cs.

        {
            this.InitializeComponent();
            this.Suspending += new SuspendingEventHandler(OnSuspending);
        }

SDKTemplate::App::App ( ) [inline]

Initializes the singleton application object.

This is the first line of authored code executed, and as such is the logical equivalent of main() or WinMain().

Definition at line 29 of file App.xaml.cs.

        {
            this.InitializeComponent();
            this.Suspending += new SuspendingEventHandler(OnSuspending);
        }

Member Function Documentation

override void SDKTemplate::App::OnActivated ( IActivatedEventArgs args ) [inline, protected]

Invoked when the application is activated.

Parameters:
args Details about the activated request and process.

Definition at line 71 of file App.xaml.cs.

        {
            if (args.Kind == ActivationKind.CameraSettings)
            {
                base.OnActivated(args);
                DeviceAppPage page = new DeviceAppPage();
                Window.Current.Content = page;
                page.Initialize((CameraSettingsActivatedEventArgs)args);

                Window.Current.Activate();
            }
        }

async override void SDKTemplate::App::OnLaunched ( LaunchActivatedEventArgs args ) [inline, protected]

Invoked when the application is launched normally by the end user.

Other entry points will be used when the application is launched to open a specific file, to display search results, and so forth.

Parameters:
args Details about the launch request and process.

Definition at line 49 of file App.xaml.cs.

        {
            if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
            {
                // Do an asynchronous restore
                await SuspensionManager.RestoreAsync();

            }
            if (Window.Current.Content == null)
            {
                var rootFrame = new Frame();
                rootFrame.Navigate(typeof(MainPage));
                ((MainPage)rootFrame.Content).LaunchArgs = args;
                Window.Current.Content = rootFrame;
            }
            Window.Current.Activate();
        }

async override void SDKTemplate::App::OnLaunched ( LaunchActivatedEventArgs args ) [inline, protected]

Invoked when the application is launched normally by the end user.

Other entry points will be used when the application is launched to open a specific file, to display search results, and so forth.

Parameters:
args Details about the launch request and process.

Definition at line 50 of file App.xaml.cs.

        {
            this.LaunchArgs = args;

            Frame rootFrame = null;
            if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
            {
                // Do an asynchronous restore
                await SuspensionManager.RestoreAsync();
            }
            if (Window.Current.Content == null)
            {
                rootFrame = new Frame();
                rootFrame.Navigate(typeof(MainPage));
                Window.Current.Content = rootFrame;
            }
            Window.Current.Activate();
        }

async override void SDKTemplate::App::OnLaunched ( LaunchActivatedEventArgs args ) [inline, protected]

Invoked when the application is launched normally by the end user.

Other entry points will be used when the application is launched to open a specific file, to display search results, and so forth.

Parameters:
args Details about the launch request and process.

Definition at line 50 of file App.xaml.cs.

        {
            this.LaunchArgs = args;

            Frame rootFrame = null;
            if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
            {
                // Do an asynchronous restore
                await SuspensionManager.RestoreAsync();
            }
            if (Window.Current.Content == null)
            {
                rootFrame = new Frame();
                rootFrame.Navigate(typeof(MainPage));
                Window.Current.Content = rootFrame;
            }
            Window.Current.Activate();
        }

async override void SDKTemplate::App::OnLaunched ( LaunchActivatedEventArgs args ) [inline, protected]

Invoked when the application is launched normally by the end user.

Other entry points will be used when the application is launched to open a specific file, to display search results, and so forth.

Parameters:
args Details about the launch request and process.

Definition at line 50 of file App.xaml.cs.

        {
            this.LaunchArgs = args;

            Frame rootFrame = null;
            if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
            {
                // Do an asynchronous restore
                await SuspensionManager.RestoreAsync();
            }
            if (Window.Current.Content == null)
            {
                rootFrame = new Frame();
                rootFrame.Navigate(typeof(MainPage));
                Window.Current.Content = rootFrame;
            }
            Window.Current.Activate();
        }

async override void SDKTemplate::App::OnLaunched ( LaunchActivatedEventArgs args ) [inline, protected]

Invoked when the application is launched normally by the end user.

Other entry points will be used when the application is launched to open a specific file, to display search results, and so forth.

Parameters:
args Details about the launch request and process.

Definition at line 50 of file App.xaml.cs.

        {
            this.LaunchArgs = args;

            Frame rootFrame = null;
            if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
            {
                // Do an asynchronous restore
                await SuspensionManager.RestoreAsync();
            }
            if (Window.Current.Content == null)
            {
                rootFrame = new Frame();
                rootFrame.Navigate(typeof(MainPage));
                Window.Current.Content = rootFrame;
            }
            Window.Current.Activate();
        }

async void SDKTemplate::App::OnSuspending | ( | object | sender,
 |  | SuspendingEventArgs | args |
 | ) |  |  | [inline, private]

Definition at line 37 of file App.xaml.cs.

        {
            SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
            await SuspensionManager.SaveAsync();
            deferral.Complete();
        }

async void SDKTemplate::App::OnSuspending | ( | object | sender,
 |  | SuspendingEventArgs | args |
 | ) |  |  | [inline, private]

Definition at line 35 of file App.xaml.cs.

       {
           SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
           await SuspensionManager.SaveAsync();
           deferral.Complete();
       }

async void SDKTemplate::App::OnSuspending | ( | object | sender,
 |  | SuspendingEventArgs | args |
 | ) |  |  | [inline, private]

Definition at line 37 of file App.xaml.cs.

        {
            SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
            await SuspensionManager.SaveAsync();
            deferral.Complete();
        }

async void SDKTemplate::App::OnSuspending | ( | object | sender,
 |  | SuspendingEventArgs | args |
 | ) |  |  | [inline, private]

Definition at line 37 of file App.xaml.cs.

        {
            SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
            await SuspensionManager.SaveAsync();
            deferral.Complete();
        }

async void SDKTemplate::App::OnSuspending | ( | object | sender,
 |  | SuspendingEventArgs | args |
 | ) |  |  | [inline, private]

Definition at line 37 of file App.xaml.cs.

        {
            SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
            await SuspensionManager.SaveAsync();
            deferral.Complete();
        }

Member Data Documentation

LaunchActivatedEventArgs SDKTemplate::App::LaunchArgs

Definition at line 25 of file App.xaml.cs.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/app_cs/App.xaml.cs
  • Media capture using capture device/C#,C++/App.xaml.cs
  • MediaStreamSource media extension/C#,C++/App.xaml.cs
  • Real-time communication/C#,C++/App.xaml.cs
  • Windows Store device app for camera/C#,C++/App.xaml.cs
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplate
  • Common
  • SDKTemplate::Common::LayoutAwarePage
Classes | Public Member Functions | Static Public Attributes | Protected Member Functions | Properties | Private Member Functions | Private Attributes

SDKTemplate::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

Inherits Page, and Page.

Inherited by CustomDeviceAccess::DeviceAsync, MediaCapture::AudioCapture, MediaCapture::BasicCapture, MediaStreamSource::AudioSource, SDKTemplate::MainPage, SDKTemplate::MainPage, SDKTemplate::MainPage, SDKTemplate::MainPage, SDKTemplate::MainPage, SDKTemplate::MainPage, SDKTemplate::MainPage, SDKTemplate::MainPage, SDKTemplate::MainPage, SDKTemplate::MainPage, SimpleCommunication::LowLatency, and SimpleCommunication::VideoChat.

List of all members.

Classes

class | ObservableDictionary-g
Implementation of IObservableMap that supports reentrancy for use as a default view model. More...

Public Member Functions

LayoutAwarePage ()
LayoutAwarePage ()
void | InvalidateVisualState ()
void | InvalidateVisualState ()
void | StartLayoutUpdates (object sender, RoutedEventArgs e)
void | StartLayoutUpdates (object sender, RoutedEventArgs e)
void | StopLayoutUpdates (object sender, RoutedEventArgs e)
void | StopLayoutUpdates (object sender, RoutedEventArgs e)

Static Public Attributes

static readonly DependencyProperty | DefaultViewModelProperty

Protected Member Functions

virtual string | DetermineVisualState (ApplicationViewState viewState)
virtual string | DetermineVisualState (ApplicationViewState viewState)
virtual void | GoBack (object sender, RoutedEventArgs e)
virtual void | GoBack (object sender, RoutedEventArgs e)
virtual void | GoHome (object sender, RoutedEventArgs e)
virtual void | GoHome (object sender, RoutedEventArgs e)

Properties

IObservableMap< String, Object > | DefaultViewModel [get, set]

Private Member Functions

void | WindowSizeChanged (object sender, Windows.UI.Core.WindowSizeChangedEventArgs e)
void | WindowSizeChanged (object sender, Windows.UI.Core.WindowSizeChangedEventArgs e)

Private Attributes

List< Control > | _layoutAwareControls

Detailed Description

Definition at line 29 of file LayoutAwarePage.cs.

Constructor & Destructor Documentation

SDKTemplate::Common::LayoutAwarePage::LayoutAwarePage ( ) [inline]

Initializes a new instance of the LayoutAwarePage class.

Definition at line 43 of file LayoutAwarePage.cs.

        {
            if (Windows.ApplicationModel.DesignMode.DesignModeEnabled) return;

            // Create an empty default view model
            this.DefaultViewModel = new ObservableDictionary<String, Object>();

            // Map application view state to visual state for this page when it is part of the visual tree
            this.Loaded += this.StartLayoutUpdates;
            this.Unloaded += this.StopLayoutUpdates;
        }

SDKTemplate::Common::LayoutAwarePage::LayoutAwarePage ( ) [inline]

Initializes a new instance of the LayoutAwarePage class.

Definition at line 43 of file LayoutAwarePage.cs.

        {
            if (Windows.ApplicationModel.DesignMode.DesignModeEnabled) return;

            // Create an empty default view model
            this.DefaultViewModel = new ObservableDictionary<String, Object>();

            // Map application view state to visual state for this page when it is part of the visual tree
            this.Loaded += this.StartLayoutUpdates;
            this.Unloaded += this.StopLayoutUpdates;
        }

Member Function Documentation

virtual string SDKTemplate::Common::LayoutAwarePage::DetermineVisualState ( ApplicationViewState viewState ) [inline, protected, virtual]

Translates ApplicationViewState values into strings for visual state management within the page.

The default implementation uses the names of enum values. Subclasses may override this method to control the mapping scheme used.

Parameters:
viewState View state for which a visual state is desired.
Returns:
Visual state name used to drive the VisualStateManager
See also:
InvalidateVisualState

Definition at line 170 of file LayoutAwarePage.cs.

        {
            return viewState.ToString();
        }

virtual string SDKTemplate::Common::LayoutAwarePage::DetermineVisualState ( ApplicationViewState viewState ) [inline, protected, virtual]

Translates ApplicationViewState values into strings for visual state management within the page.

The default implementation uses the names of enum values. Subclasses may override this method to control the mapping scheme used.

Parameters:
viewState View state for which a visual state is desired.
Returns:
Visual state name used to drive the VisualStateManager
See also:
InvalidateVisualState

Definition at line 170 of file LayoutAwarePage.cs.

        {
            return viewState.ToString();
        }

virtual void SDKTemplate::Common::LayoutAwarePage::GoBack | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected, virtual]

Invoked as an event handler to navigate backward in the page's associated Frame to go back one step on the navigation stack.

Parameters:
sender | Instance that triggered the event.
e | Event data describing the conditions that led to the event.

Definition at line 94 of file LayoutAwarePage.cs.

        {
            // Use the navigation frame to return to the previous page
            if (this.Frame != null && this.Frame.CanGoBack) this.Frame.GoBack();
        }

virtual void SDKTemplate::Common::LayoutAwarePage::GoBack | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected, virtual]

Invoked as an event handler to navigate backward in the page's associated Frame to go back one step on the navigation stack.

Parameters:
sender | Instance that triggered the event.
e | Event data describing the conditions that led to the event.

Definition at line 94 of file LayoutAwarePage.cs.

        {
            // Use the navigation frame to return to the previous page
            if (this.Frame != null && this.Frame.CanGoBack) this.Frame.GoBack();
        }

virtual void SDKTemplate::Common::LayoutAwarePage::GoHome | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected, virtual]

Invoked as an event handler to navigate backward in the page's associated Frame until it reaches the top of the navigation stack.

Parameters:
sender | Instance that triggered the event.
e | Event data describing the conditions that led to the event.

Definition at line 78 of file LayoutAwarePage.cs.

        {
            // Use the navigation frame to return to the topmost page
            if (this.Frame != null)
            {
                while (this.Frame.CanGoBack) this.Frame.GoBack();
            }
        }

virtual void SDKTemplate::Common::LayoutAwarePage::GoHome | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected, virtual]

Invoked as an event handler to navigate backward in the page's associated Frame until it reaches the top of the navigation stack.

Parameters:
sender | Instance that triggered the event.
e | Event data describing the conditions that led to the event.

Definition at line 78 of file LayoutAwarePage.cs.

        {
            // Use the navigation frame to return to the topmost page
            if (this.Frame != null)
            {
                while (this.Frame.CanGoBack) this.Frame.GoBack();
            }
        }

void SDKTemplate::Common::LayoutAwarePage::InvalidateVisualState ( ) [inline]

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 184 of file LayoutAwarePage.cs.

        {
            if (this._layoutAwareControls != null)
            {
                string visualState = DetermineVisualState(ApplicationView.Value);
                foreach (var layoutAwareControl in this._layoutAwareControls)
                {
                    VisualStateManager.GoToState(layoutAwareControl, visualState, false);
                }
            }
        }

void SDKTemplate::Common::LayoutAwarePage::InvalidateVisualState ( ) [inline]

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 184 of file LayoutAwarePage.cs.

        {
            if (this._layoutAwareControls != null)
            {
                string visualState = DetermineVisualState(ApplicationView.Value);
                foreach (var layoutAwareControl in this._layoutAwareControls)
                {
                    VisualStateManager.GoToState(layoutAwareControl, visualState, false);
                }
            }
        }

void SDKTemplate::Common::LayoutAwarePage::StartLayoutUpdates | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline]

Invoked as an event handler, typically on the Loaded event of a Control within the page, to indicate that the sender should start receiving visual state management changes that correspond to application view state changes.

Parameters:
sender | Instance of Control that supports visual state management corresponding to view states.
e | Event data that describes how the request was made.

The current view state will immediately be used to set the corresponding visual state when layout updates are requested. A corresponding Unloaded event handler connected to StopLayoutUpdates is strongly encouraged. Instances of LayoutAwarePage automatically invoke these handlers in their Loaded and Unloaded events.

See also:
DetermineVisualState, InvalidateVisualState

Definition at line 116 of file LayoutAwarePage.cs.

        {
            var control = sender as Control;
            if (control == null) return;
            if (this._layoutAwareControls == null)
            {
                // Start listening to view state changes when there are controls interested in updates
                Window.Current.SizeChanged += this.WindowSizeChanged;
                this._layoutAwareControls = new List<Control>();
            }
            this._layoutAwareControls.Add(control);

            // Set the initial visual state of the control
            VisualStateManager.GoToState(control, DetermineVisualState(ApplicationView.Value), false);
        }

void SDKTemplate::Common::LayoutAwarePage::StartLayoutUpdates | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline]

Invoked as an event handler, typically on the Loaded event of a Control within the page, to indicate that the sender should start receiving visual state management changes that correspond to application view state changes.

Parameters:
sender | Instance of Control that supports visual state management corresponding to view states.
e | Event data that describes how the request was made.

The current view state will immediately be used to set the corresponding visual state when layout updates are requested. A corresponding Unloaded event handler connected to StopLayoutUpdates is strongly encouraged. Instances of LayoutAwarePage automatically invoke these handlers in their Loaded and Unloaded events.

See also:
DetermineVisualState, InvalidateVisualState

Definition at line 116 of file LayoutAwarePage.cs.

        {
            var control = sender as Control;
            if (control == null) return;
            if (this._layoutAwareControls == null)
            {
                // Start listening to view state changes when there are controls interested in updates
                Window.Current.SizeChanged += this.WindowSizeChanged;
                this._layoutAwareControls = new List<Control>();
            }
            this._layoutAwareControls.Add(control);

            // Set the initial visual state of the control
            VisualStateManager.GoToState(control, DetermineVisualState(ApplicationView.Value), false);
        }

void SDKTemplate::Common::LayoutAwarePage::StopLayoutUpdates | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline]

Invoked as an event handler, typically on the Unloaded event of a Control, to indicate that the sender should start receiving visual state management changes that correspond to application view state changes.

Parameters:
sender | Instance of Control that supports visual state management corresponding to view states.
e | Event data that describes how the request was made.

The current view state will immediately be used to set the corresponding visual state when layout updates are requested.

See also:
StartLayoutUpdates

Definition at line 148 of file LayoutAwarePage.cs.

        {
            var control = sender as Control;
            if (control == null || this._layoutAwareControls == null) return;
            this._layoutAwareControls.Remove(control);
            if (this._layoutAwareControls.Count == 0)
            {
                // Stop listening to view state changes when no controls are interested in updates
                this._layoutAwareControls = null;
                Window.Current.SizeChanged -= this.WindowSizeChanged;
            }
        }

void SDKTemplate::Common::LayoutAwarePage::StopLayoutUpdates | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline]

Invoked as an event handler, typically on the Unloaded event of a Control, to indicate that the sender should start receiving visual state management changes that correspond to application view state changes.

Parameters:
sender | Instance of Control that supports visual state management corresponding to view states.
e | Event data that describes how the request was made.

The current view state will immediately be used to set the corresponding visual state when layout updates are requested.

See also:
StartLayoutUpdates

Definition at line 148 of file LayoutAwarePage.cs.

        {
            var control = sender as Control;
            if (control == null || this._layoutAwareControls == null) return;
            this._layoutAwareControls.Remove(control);
            if (this._layoutAwareControls.Count == 0)
            {
                // Stop listening to view state changes when no controls are interested in updates
                this._layoutAwareControls = null;
                Window.Current.SizeChanged -= this.WindowSizeChanged;
            }
        }

void SDKTemplate::Common::LayoutAwarePage::WindowSizeChanged | ( | object | sender,
 |  | Windows.UI.Core.WindowSizeChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 132 of file LayoutAwarePage.cs.

        {
            this.InvalidateVisualState();
        }

void SDKTemplate::Common::LayoutAwarePage::WindowSizeChanged | ( | object | sender,
 |  | Windows.UI.Core.WindowSizeChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 132 of file LayoutAwarePage.cs.

        {
            this.InvalidateVisualState();
        }

Member Data Documentation

List< Control > SDKTemplate::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 38 of file LayoutAwarePage.cs.

static readonly DependencyProperty SDKTemplate::Common::LayoutAwarePage::DefaultViewModelProperty [static]
Initial value:
            DependencyProperty.Register("DefaultViewModel", typeof(IObservableMap<String, Object>),
            typeof(LayoutAwarePage), null)

Identifies the DefaultViewModel dependency property.

Definition at line 34 of file LayoutAwarePage.cs.

Property Documentation

IObservableMap< String, Object > SDKTemplate::Common::LayoutAwarePage::DefaultViewModel [get, set, protected]

An implementation of IObservableMap&lt;String, Object&gt; designed to be used as a trivial view model.

Definition at line 60 of file LayoutAwarePage.cs.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/app_cs/common/LayoutAwarePage.cs
  • Real-time communication/C#,C++/Common/LayoutAwarePage.cs
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplate
  • Common
  • SDKTemplate::Common::LayoutAwarePage
  • SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
Classes | Public Member Functions | Properties | Events | Private Member Functions | Private Attributes

SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > Class Template Reference

Implementation of IObservableMap that supports reentrancy for use as a default view model.

List of all members.

Classes

class | ObservableDictionaryChangedEventArgs

Public Member Functions

void | Add (K key, V value)
void | Add (KeyValuePair< K, V > item)
void | Add (K key, V value)
void | Add (KeyValuePair< K, V > item)
void | Clear ()
void | Clear ()
bool | Contains (KeyValuePair< K, V > item)
bool | Contains (KeyValuePair< K, V > item)
bool | ContainsKey (K key)
bool | ContainsKey (K key)
void | CopyTo (KeyValuePair< K, V >[] array, int arrayIndex)
void | CopyTo (KeyValuePair< K, V >[] array, int arrayIndex)
IEnumerator< KeyValuePair< K, V > > | GetEnumerator ()
IEnumerator< KeyValuePair< K, V > > | GetEnumerator ()
bool | Remove (K key)
bool | Remove (KeyValuePair< K, V > item)
bool | Remove (K key)
bool | Remove (KeyValuePair< K, V > item)
bool | TryGetValue (K key, out V value)
bool | TryGetValue (K key, out V value)

Properties

int | Count [get]
bool | IsReadOnly [get]
ICollection< K > | Keys [get]
V | this [K key] [get, set]
ICollection< V > | Values [get]

Events

MapChangedEventHandler< K, V > | MapChanged

Private Member Functions

System.Collections.IEnumerator
System.Collections.IEnumerable. 		GetEnumerator ()
System.Collections.IEnumerator
System.Collections.IEnumerable. 		GetEnumerator ()
void | InvokeMapChanged (CollectionChange change, K key)
void | InvokeMapChanged (CollectionChange change, K key)

Private Attributes

Dictionary< K, V > | _dictionary = new Dictionary<K, V>()

Detailed Description

template<K, V>
class SDKTemplate::Common::LayoutAwarePage::ObservableDictionary-g< K, V >

Definition at line 200 of file LayoutAwarePage.cs.

Member Function Documentation

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Add | ( | K | key,
 |  | V | value |
 | ) |  |  | [inline]

Definition at line 226 of file LayoutAwarePage.cs.

            {
                this._dictionary.Add(key, value);
                this.InvokeMapChanged(CollectionChange.ItemInserted, key);
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Add ( KeyValuePair< K, V > item ) [inline]

Definition at line 232 of file LayoutAwarePage.cs.

            {
                this.Add(item.Key, item.Value);
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Add | ( | K | key,
 |  | V | value |
 | ) |  |  | [inline]

Definition at line 226 of file LayoutAwarePage.cs.

            {
                this._dictionary.Add(key, value);
                this.InvokeMapChanged(CollectionChange.ItemInserted, key);
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Add ( KeyValuePair< K, V > item ) [inline]

Definition at line 232 of file LayoutAwarePage.cs.

            {
                this.Add(item.Key, item.Value);
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Clear ( ) [inline]

Definition at line 272 of file LayoutAwarePage.cs.

            {
                var priorKeys = this._dictionary.Keys.ToArray();
                this._dictionary.Clear();
                foreach (var key in priorKeys)
                {
                    this.InvokeMapChanged(CollectionChange.ItemRemoved, key);
                }
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Clear ( ) [inline]

Definition at line 272 of file LayoutAwarePage.cs.

            {
                var priorKeys = this._dictionary.Keys.ToArray();
                this._dictionary.Clear();
                foreach (var key in priorKeys)
                {
                    this.InvokeMapChanged(CollectionChange.ItemRemoved, key);
                }
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Contains ( KeyValuePair< K, V > item ) [inline]

Definition at line 302 of file LayoutAwarePage.cs.

            {
                return this._dictionary.Contains(item);
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Contains ( KeyValuePair< K, V > item ) [inline]

Definition at line 302 of file LayoutAwarePage.cs.

            {
                return this._dictionary.Contains(item);
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ContainsKey ( K key ) [inline]

Definition at line 287 of file LayoutAwarePage.cs.

            {
                return this._dictionary.ContainsKey(key);
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ContainsKey ( K key ) [inline]

Definition at line 287 of file LayoutAwarePage.cs.

            {
                return this._dictionary.ContainsKey(key);
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::CopyTo | ( | KeyValuePair< K, V >[] | array,
 |  | int | arrayIndex |
 | ) |  |  | [inline]

Definition at line 327 of file LayoutAwarePage.cs.

            {
                int arraySize = array.Length;
                foreach (var pair in this._dictionary)
                {
                    if (arrayIndex >= arraySize) break;
                    array[arrayIndex++] = pair;
                }
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::CopyTo | ( | KeyValuePair< K, V >[] | array,
 |  | int | arrayIndex |
 | ) |  |  | [inline]

Definition at line 327 of file LayoutAwarePage.cs.

            {
                int arraySize = array.Length;
                foreach (var pair in this._dictionary)
                {
                    if (arrayIndex >= arraySize) break;
                    array[arrayIndex++] = pair;
                }
            }

template<K , V >
IEnumerator<KeyValuePair<K, V> > SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::GetEnumerator ( ) [inline]

Definition at line 317 of file LayoutAwarePage.cs.

            {
                return this._dictionary.GetEnumerator();
            }

template<K , V >
System.Collections.IEnumerator System.Collections.IEnumerable. SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::GetEnumerator ( ) [inline, private]

Definition at line 322 of file LayoutAwarePage.cs.

            {
                return this._dictionary.GetEnumerator();
            }

template<K , V >
IEnumerator<KeyValuePair<K, V> > SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::GetEnumerator ( ) [inline]

Definition at line 317 of file LayoutAwarePage.cs.

            {
                return this._dictionary.GetEnumerator();
            }

template<K , V >
System.Collections.IEnumerator System.Collections.IEnumerable. SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::GetEnumerator ( ) [inline, private]

Definition at line 322 of file LayoutAwarePage.cs.

            {
                return this._dictionary.GetEnumerator();
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::InvokeMapChanged | ( | CollectionChange | change,
 |  | K | key |
 | ) |  |  | [inline, private]

Definition at line 217 of file LayoutAwarePage.cs.

            {
                var eventHandler = MapChanged;
                if (eventHandler != null)
                {
                    eventHandler(this, new ObservableDictionaryChangedEventArgs(CollectionChange.ItemInserted, key));
                }
            }

template<K , V >
void SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::InvokeMapChanged | ( | CollectionChange | change,
 |  | K | key |
 | ) |  |  | [inline, private]

Definition at line 217 of file LayoutAwarePage.cs.

            {
                var eventHandler = MapChanged;
                if (eventHandler != null)
                {
                    eventHandler(this, new ObservableDictionaryChangedEventArgs(CollectionChange.ItemInserted, key));
                }
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Remove ( K key ) [inline]

Definition at line 237 of file LayoutAwarePage.cs.

            {
                if (this._dictionary.Remove(key))
                {
                    this.InvokeMapChanged(CollectionChange.ItemRemoved, key);
                    return true;
                }
                return false;
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Remove ( K key ) [inline]

Definition at line 237 of file LayoutAwarePage.cs.

            {
                if (this._dictionary.Remove(key))
                {
                    this.InvokeMapChanged(CollectionChange.ItemRemoved, key);
                    return true;
                }
                return false;
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Remove ( KeyValuePair< K, V > item ) [inline]

Definition at line 247 of file LayoutAwarePage.cs.

            {
                V currentValue;
                if (this._dictionary.TryGetValue(item.Key, out currentValue) &&
                    Object.Equals(item.Value, currentValue) && this._dictionary.Remove(item.Key))
                {
                    this.InvokeMapChanged(CollectionChange.ItemRemoved, item.Key);
                    return true;
                }
                return false;
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Remove ( KeyValuePair< K, V > item ) [inline]

Definition at line 247 of file LayoutAwarePage.cs.

            {
                V currentValue;
                if (this._dictionary.TryGetValue(item.Key, out currentValue) &&
                    Object.Equals(item.Value, currentValue) && this._dictionary.Remove(item.Key))
                {
                    this.InvokeMapChanged(CollectionChange.ItemRemoved, item.Key);
                    return true;
                }
                return false;
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::TryGetValue | ( | K | key,
 |  | out V | value |
 | ) |  |  | [inline]

Definition at line 292 of file LayoutAwarePage.cs.

            {
                return this._dictionary.TryGetValue(key, out value);
            }

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::TryGetValue | ( | K | key,
 |  | out V | value |
 | ) |  |  | [inline]

Definition at line 292 of file LayoutAwarePage.cs.

            {
                return this._dictionary.TryGetValue(key, out value);
            }

Member Data Documentation

template<K , V >
Dictionary< K, V > SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::_dictionary = new Dictionary<K, V>() [private]

Definition at line 214 of file LayoutAwarePage.cs.

Property Documentation

template<K , V >
int SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Count [get]

Definition at line 308 of file LayoutAwarePage.cs.

template<K , V >
bool SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::IsReadOnly [get]

Definition at line 313 of file LayoutAwarePage.cs.

template<K , V >
ICollection< K > SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Keys [get]

Definition at line 283 of file LayoutAwarePage.cs.

template<K , V >
V SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::this [get, set]

Definition at line 260 of file LayoutAwarePage.cs.

template<K , V >
ICollection< V > SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::Values [get]

Definition at line 298 of file LayoutAwarePage.cs.

Event Documentation

template<K , V >
MapChangedEventHandler< K, V > SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::MapChanged

Definition at line 215 of file LayoutAwarePage.cs.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/app_cs/common/LayoutAwarePage.cs
  • Real-time communication/C#,C++/Common/LayoutAwarePage.cs
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplate
  • Common
  • SDKTemplate::Common::LayoutAwarePage
  • SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
Public Member Functions | Properties

SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs Class Reference

List of all members.

Public Member Functions

ObservableDictionaryChangedEventArgs (CollectionChange change, K key)
ObservableDictionaryChangedEventArgs (CollectionChange change, K key)

Properties

CollectionChange | CollectionChange [get, set]
K | Key [get, set]

Detailed Description

template<K, V>
class SDKTemplate::Common::LayoutAwarePage::ObservableDictionary-g< K, V >::ObservableDictionaryChangedEventArgs

Definition at line 202 of file LayoutAwarePage.cs.

Constructor & Destructor Documentation

template<K , V >
SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs::ObservableDictionaryChangedEventArgs | ( | CollectionChange | change,
 |  | K | key |
 | ) |  |  | [inline]

Definition at line 204 of file LayoutAwarePage.cs.

                {
                    this.CollectionChange = change;
                    this.Key = key;
                }

template<K , V >
SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs::ObservableDictionaryChangedEventArgs | ( | CollectionChange | change,
 |  | K | key |
 | ) |  |  | [inline]

Definition at line 204 of file LayoutAwarePage.cs.

                {
                    this.CollectionChange = change;
                    this.Key = key;
                }

Property Documentation

template<K , V >
CollectionChange SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs::CollectionChange [get, set]

Definition at line 210 of file LayoutAwarePage.cs.

template<K , V >
K SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs::Key [get, set]

Definition at line 211 of file LayoutAwarePage.cs.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/app_cs/common/LayoutAwarePage.cs
  • Real-time communication/C#,C++/Common/LayoutAwarePage.cs
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::DeviceAppPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplate
  • SDKTemplate::DeviceAppPage
Public Member Functions | Protected Member Functions | Private Attributes

SDKTemplate::DeviceAppPage Class Reference

List of all members.

Public Member Functions

DeviceAppPage ()
void | Initialize (CameraSettingsActivatedEventArgs args)

Protected Member Functions

void | OnBrtAutoToggleChanged (object sender, RoutedEventArgs e)
void | OnBrtSliderValueChanged (object sender, RoutedEventArgs e)
void | OnCrtAutoToggleChanged (object sender, RoutedEventArgs e)
void | OnCrtSliderValueChanged (object sender, RoutedEventArgs e)
void | OnEffectEnabledToggleChanged (object sender, RoutedEventArgs e)
void | OnEffectSliderValueChanged (object sender, RoutedEventArgs e)
void | OnExpAutoToggleChanged (object sender, RoutedEventArgs e)
void | OnExpSliderValueChanged (object sender, RoutedEventArgs e)
void | OnFocusAutoToggleChanged (object sender, RoutedEventArgs e)
void | OnFocusSliderValueChanged (object sender, RoutedEventArgs e)

Private Attributes

Wrapper.WinRTComponent | lcWrapper = null
VideoDeviceController | videoDevController = null

Detailed Description

Definition at line 21 of file DeviceAppPage.xaml.cs.

Constructor & Destructor Documentation

SDKTemplate::DeviceAppPage::DeviceAppPage ( ) [inline]

Definition at line 26 of file DeviceAppPage.xaml.cs.

        {
            InitializeComponent();
        }

Member Function Documentation

void SDKTemplate::DeviceAppPage::Initialize ( CameraSettingsActivatedEventArgs args ) [inline]

Definition at line 31 of file DeviceAppPage.xaml.cs.

        {
            videoDevController = (VideoDeviceController)args.VideoDeviceController;

            if (args.VideoDeviceExtension != null)
            {
                lcWrapper = new WinRTComponent();
                lcWrapper.Initialize(args.VideoDeviceExtension);
            }

            bool bAuto = false;
            double value = 0.0;

            if (videoDevController.Brightness.Capabilities.Step != 0)
            {
                slBrt.Minimum = videoDevController.Brightness.Capabilities.Min;
                slBrt.Maximum = videoDevController.Brightness.Capabilities.Max;
                slBrt.StepFrequency = videoDevController.Brightness.Capabilities.Step;
                videoDevController.Brightness.TryGetValue(out value);
                slBrt.Value = value;
            }
            else
            {
                slBrt.IsEnabled = false;
            }
            if (videoDevController.Brightness.Capabilities.AutoModeSupported)
            {
                videoDevController.Brightness.TryGetAuto(out bAuto);
                tsBrtAuto.IsOn = bAuto;
            }
            else
            {
                tsBrtAuto.IsOn = false;
                tsBrtAuto.IsEnabled = false;
            }

            if (videoDevController.Contrast.Capabilities.Step != 0)
            {
                slCrt.Minimum = videoDevController.Contrast.Capabilities.Min;
                slCrt.Maximum = videoDevController.Contrast.Capabilities.Max;
                slCrt.StepFrequency = videoDevController.Contrast.Capabilities.Step;
                videoDevController.Contrast.TryGetValue(out value);
                slCrt.Value = value;
            }
            else
            {
                slCrt.IsEnabled = false;
            }
            if (videoDevController.Contrast.Capabilities.AutoModeSupported)
            {
                videoDevController.Contrast.TryGetAuto(out bAuto);
                tsCrtAuto.IsOn = bAuto;
            }
            else
            {
                tsCrtAuto.IsOn = false;
                tsCrtAuto.IsEnabled = false;
            }

            if (videoDevController.Focus.Capabilities.Step != 0)
            {
                slFocus.Minimum = videoDevController.Focus.Capabilities.Min;
                slFocus.Maximum = videoDevController.Focus.Capabilities.Max;
                slFocus.StepFrequency = videoDevController.Focus.Capabilities.Step;
                videoDevController.Focus.TryGetValue(out value);
                slFocus.Value = value;
            }
            else
            {
                slFocus.IsEnabled = false;
            }
            if (videoDevController.Focus.Capabilities.AutoModeSupported)
            {
                videoDevController.Focus.TryGetAuto(out bAuto);
                tsFocusAuto.IsOn = bAuto;
            }
            else
            {
                tsFocusAuto.IsOn = false;
                tsFocusAuto.IsEnabled = false;
            }

            if (videoDevController.Exposure.Capabilities.Step != 0)
            {
                slExp.Minimum = videoDevController.Exposure.Capabilities.Min;
                slExp.Maximum = videoDevController.Exposure.Capabilities.Max;
                slExp.StepFrequency = videoDevController.Exposure.Capabilities.Step;
                videoDevController.Exposure.TryGetValue(out value);
                slExp.Value = value;
            }
            else
            {
                slExp.IsEnabled = false;
            }
            if (videoDevController.Exposure.Capabilities.AutoModeSupported)
            {
                videoDevController.Exposure.TryGetAuto(out bAuto);
                tsExpAuto.IsOn = bAuto;
            }
            else
            {
                tsExpAuto.IsOn = false;
                tsExpAuto.IsEnabled = false;
            }

            if (lcWrapper != null)
            {
                slEffect.Minimum = 0;
                slEffect.Maximum = 100;
                slEffect.StepFrequency = 1;

                DspSettings dspSettings = lcWrapper.GetDspSetting();
                slEffect.Value = dspSettings.percentOfScreen;

                if (dspSettings.isEnabled == 1)
                {
                    tsEffectEnabled.IsOn = true;
                }
                else
                {
                    tsEffectEnabled.IsOn = false;
                    slEffect.IsEnabled = false;
                }
            }
            else
            {
                tsEffectEnabled.IsEnabled = false;
                slEffect.IsEnabled = false;
            }
        }

void SDKTemplate::DeviceAppPage::OnBrtAutoToggleChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 162 of file DeviceAppPage.xaml.cs.

        {
            videoDevController.Brightness.TrySetAuto(tsBrtAuto.IsOn);
            slBrt.IsEnabled = !tsBrtAuto.IsOn;
        }

void SDKTemplate::DeviceAppPage::OnBrtSliderValueChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 168 of file DeviceAppPage.xaml.cs.

        {
            videoDevController.Brightness.TrySetValue(slBrt.Value);
        }

void SDKTemplate::DeviceAppPage::OnCrtAutoToggleChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 173 of file DeviceAppPage.xaml.cs.

        {
            videoDevController.Contrast.TrySetAuto(tsCrtAuto.IsOn);
            slCrt.IsEnabled = !tsCrtAuto.IsOn;
        }

void SDKTemplate::DeviceAppPage::OnCrtSliderValueChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 179 of file DeviceAppPage.xaml.cs.

        {
            videoDevController.Contrast.TrySetValue(slCrt.Value);
        }

void SDKTemplate::DeviceAppPage::OnEffectEnabledToggleChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 206 of file DeviceAppPage.xaml.cs.

        {
            if (tsEffectEnabled.IsOn)
            {
                lcWrapper.Enable();
            }
            else
            {
                lcWrapper.Disable();
            }
            slEffect.IsEnabled = tsEffectEnabled.IsOn;
        }

void SDKTemplate::DeviceAppPage::OnEffectSliderValueChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 219 of file DeviceAppPage.xaml.cs.

        {
            lcWrapper.UpdateDsp(Convert.ToInt32(slEffect.Value));
        }

void SDKTemplate::DeviceAppPage::OnExpAutoToggleChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 195 of file DeviceAppPage.xaml.cs.

        {
            videoDevController.Exposure.TrySetAuto(tsExpAuto.IsOn);
            slExp.IsEnabled = !tsExpAuto.IsOn;
        }

void SDKTemplate::DeviceAppPage::OnExpSliderValueChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 201 of file DeviceAppPage.xaml.cs.

        {
            videoDevController.Exposure.TrySetValue(slExp.Value);
        }

void SDKTemplate::DeviceAppPage::OnFocusAutoToggleChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 184 of file DeviceAppPage.xaml.cs.

        {
            videoDevController.Focus.TrySetAuto(tsFocusAuto.IsOn);
            slFocus.IsEnabled = !tsFocusAuto.IsOn;
        }

void SDKTemplate::DeviceAppPage::OnFocusSliderValueChanged | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, protected]

Definition at line 190 of file DeviceAppPage.xaml.cs.

        {
            videoDevController.Focus.TrySetValue(slFocus.Value);
        }

Member Data Documentation

Wrapper.WinRTComponent SDKTemplate::DeviceAppPage::lcWrapper = null [private]

Definition at line 24 of file DeviceAppPage.xaml.cs.

VideoDeviceController SDKTemplate::DeviceAppPage::videoDevController = null [private]

Definition at line 23 of file DeviceAppPage.xaml.cs.

The documentation for this class was generated from the following file:
  • Windows Store device app for camera/C#,C++/DeviceAppPage.xaml.cs
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplate
  • SDKTemplate::MainPage
Public Member Functions | Public Attributes | Static Public Attributes | Protected Member Functions | Properties | Events | Private Member Functions | Private Attributes

SDKTemplate::MainPage Class Reference

An empty page that can be used on its own or navigated to within a Frame.

Inherits SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, SDKTemplate::Common::LayoutAwarePage, and SDKTemplate::Common::LayoutAwarePage.

List of all members.

Public Member Functions

MainPage ()
MainPage ()
MainPage ()
MainPage ()
MainPage ()
void | EnsureMediaExtensionManager ()
void | LoadScenario (Type scenarioClass)
void | LoadScenario (Type scenarioClass)
void | LoadScenario (Type scenarioClass)
void | LoadScenario (Type scenarioClass)
void | NotifyUser (string strMessage, NotifyType type)
void | NotifyUser (string strMessage, NotifyType type)
void | NotifyUser (string strMessage, NotifyType type)
void | NotifyUser (string strMessage, NotifyType type)

Public Attributes

bool | AutoSizeInputSectionWhenSnapped = true
bool | CameraFound = false
bool | DeviceChecked = false
const string | FEATURE_NAME = "Custom Device Access"

Static Public Attributes

static MainPage | Current

Protected Member Functions

override void | OnNavigatedTo (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)
override void | OnNavigatedTo (NavigationEventArgs e)

Properties

Windows.ApplicationModel.Activation.LaunchActivatedEventArgs | LaunchArgs [get]

Events

EventHandler
< MainPageSizeChangedEventArgs > 		MainPageResized
System.EventHandler | ScenarioLoaded

Private Member Functions

async void | Footer_Click (object sender, RoutedEventArgs e)
async void | Footer_Click (object sender, RoutedEventArgs e)
async void | Footer_Click (object sender, RoutedEventArgs e)
async void | Footer_Click (object sender, RoutedEventArgs e)
async void | Footer_Click (object sender, RoutedEventArgs e)
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateSize ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | InvalidateViewState ()
void | MainPage_SizeChanged (object sender, SizeChangedEventArgs e)
void | MainPage_SizeChanged (object sender, SizeChangedEventArgs e)
void | MainPage_SizeChanged (object sender, SizeChangedEventArgs e)
void | MainPage_SizeChanged (object sender, SizeChangedEventArgs e)
void | MainPage_SizeChanged (object sender, SizeChangedEventArgs e)
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | PopulateScenarios ()
void | Scenarios_SelectionChanged (object sender, SelectionChangedEventArgs e)
void | Scenarios_SelectionChanged (object sender, SelectionChangedEventArgs e)
void | Scenarios_SelectionChanged (object sender, SelectionChangedEventArgs e)
void | Scenarios_SelectionChanged (object sender, SelectionChangedEventArgs e)
void | SetFeatureName (string str)
void | SetFeatureName (string str)
void | SetFeatureName (string str)
void | SetFeatureName (string str)
void | SetFeatureName (string str)

Private Attributes

Frame | HiddenFrame = null
Windows.Media.MediaExtensionManager | mediaExtensionMgr
List< Scenario > scenarios

Detailed Description

Definition at line 16 of file Constants.cs.

Constructor & Destructor Documentation

SDKTemplate::MainPage::MainPage ( ) [inline]

Definition at line 42 of file MainPage.xaml.cs.

        {
            this.InitializeComponent();

            // This is a static public property that will allow downstream pages to get
            // a handle to the MainPage instance in order to call methods that are in this class.
            Current = this;

            // This frame is hidden, meaning it is never shown.  It is simply used to load
            // each scenario page and then pluck out the input and output sections and
            // place them into the UserControls on the main page.
            HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
            HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            ContentRoot.Children.Add(HiddenFrame);

            // Populate the sample title from the constant in the Constants.cs file.
            SetFeatureName(FEATURE_NAME);
            Scenarios.SelectionChanged += Scenarios_SelectionChanged;
            SizeChanged += MainPage_SizeChanged;
        }

SDKTemplate::MainPage::MainPage ( ) [inline]

Definition at line 42 of file MainPage.xaml.cs.

        {
            this.InitializeComponent();

            // This is a static public property that will allow downstream pages to get
            // a handle to the MainPage instance in order to call methods that are in this class.
            Current = this;

            // This frame is hidden, meaning it is never shown.  It is simply used to load
            // each scenario page and then pluck out the input and output sections and
            // place them into the UserControls on the main page.
            HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
            HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            ContentRoot.Children.Add(HiddenFrame);

            // Populate the sample title from the constant in the Constants.cs file.
            SetFeatureName(FEATURE_NAME);
            Scenarios.SelectionChanged += Scenarios_SelectionChanged;
            SizeChanged += MainPage_SizeChanged;
        }

SDKTemplate::MainPage::MainPage ( ) [inline]

Definition at line 42 of file MainPage.xaml.cs.

        {
            this.InitializeComponent();

            // This is a static public property that will allow downstream pages to get
            // a handle to the MainPage instance in order to call methods that are in this class.
            Current = this;

            // This frame is hidden, meaning it is never shown.  It is simply used to load
            // each scenario page and then pluck out the input and output sections and
            // place them into the UserControls on the main page.
            HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
            HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            ContentRoot.Children.Add(HiddenFrame);

            // Populate the sample title from the constant in the Constants.cs file.
            SetFeatureName(FEATURE_NAME);
            Scenarios.SelectionChanged += Scenarios_SelectionChanged;
            SizeChanged += MainPage_SizeChanged;
        }

SDKTemplate::MainPage::MainPage ( ) [inline]

Definition at line 42 of file MainPage.xaml.cs.

        {
            this.InitializeComponent();

            // This is a static public property that will allow downstream pages to get
            // a handle to the MainPage instance in order to call methods that are in this class.
            Current = this;

            // This frame is hidden, meaning it is never shown.  It is simply used to load
            // each scenario page and then pluck out the input and output sections and
            // place them into the UserControls on the main page.
            HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
            HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            ContentRoot.Children.Add(HiddenFrame);

            // Populate the sample title from the constant in the Constants.cs file.
            SetFeatureName(FEATURE_NAME);
            Scenarios.SelectionChanged += Scenarios_SelectionChanged;
            SizeChanged += MainPage_SizeChanged;
        }

SDKTemplate::MainPage::MainPage ( ) [inline]

Definition at line 32 of file MainPage.xaml.cs.

        {
            this.InitializeComponent();

            // This is a static public property that will allow downstream pages to get
            // a handle to the MainPage instance in order to call methods that are in this class.
            Current = this;

            // This frame is hidden, meaning it is never shown.  It is simply used to load
            // each scenario page and then pluck out the input and output sections and
            // place them into the UserControls on the main page.
            HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
            HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            LayoutRoot.Children.Add(HiddenFrame);

            // Populate the sample title from the constant in the GlobalVariables.cs file.
            SetFeatureName(FEATURE_NAME);

            SizeChanged += MainPage_SizeChanged;

        }

Member Function Documentation

void SDKTemplate::MainPage::EnsureMediaExtensionManager ( ) [inline]

Definition at line 38 of file Constants.cs.

        {
            if (mediaExtensionMgr == null)
            {
                mediaExtensionMgr = new Windows.Media.MediaExtensionManager();
                mediaExtensionMgr.RegisterSchemeHandler("Microsoft.Samples.SimpleCommunication.StspSchemeHandler", "stsp:");
            }
        }

async void SDKTemplate::MainPage::Footer_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 294 of file MainPage.xaml.cs.

        {
            await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
        }

async void SDKTemplate::MainPage::Footer_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 294 of file MainPage.xaml.cs.

        {
            await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
        }

async void SDKTemplate::MainPage::Footer_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 120 of file MainPage.xaml.cs.

        {
            await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
        }

async void SDKTemplate::MainPage::Footer_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 294 of file MainPage.xaml.cs.

        {
            await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
        }

async void SDKTemplate::MainPage::Footer_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 294 of file MainPage.xaml.cs.

        {
            await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
        }

void SDKTemplate::MainPage::InvalidateSize ( ) [inline, private]

Definition at line 85 of file MainPage.xaml.cs.

        {
            // Get the window width
            double windowWidth = this.ActualWidth;
            if (windowWidth != 0.0)
            {
                // Get the width of the ListBox.
                double listBoxWidth = Scenarios.ActualWidth;

                // Is the ListBox using any margins that we need to consider?
                double listBoxMarginLeft = Scenarios.Margin.Left;
                double listBoxMarginRight = Scenarios.Margin.Right;

                // Figure out how much room is left after considering the list box width
                double availableWidth = windowWidth - listBoxWidth;

                // Is the top most child using margins?
                double layoutRootMarginLeft = ContentRoot.Margin.Left;
                double layoutRootMarginRight = ContentRoot.Margin.Right;

                // We have different widths to use depending on the view state
                if (ApplicationView.Value != ApplicationViewState.Snapped)
                {
                    // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
                    // and the LayoutRoot's margins
                    InputSection.Width = availableWidth - (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
                }
                else
                {
                    // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
                    if (AutoSizeInputSectionWhenSnapped)
                    {
                        InputSection.Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
                    }
                }
            }
            InvalidateViewState();
        }

void SDKTemplate::MainPage::InvalidateSize ( ) [inline, private]

Definition at line 85 of file MainPage.xaml.cs.

        {
            // Get the window width
            double windowWidth = this.ActualWidth;
            if (windowWidth != 0.0)
            {
                // Get the width of the ListBox.
                double listBoxWidth = Scenarios.ActualWidth;

                // Is the ListBox using any margins that we need to consider?
                double listBoxMarginLeft = Scenarios.Margin.Left;
                double listBoxMarginRight = Scenarios.Margin.Right;

                // Figure out how much room is left after considering the list box width
                double availableWidth = windowWidth - listBoxWidth;

                // Is the top most child using margins?
                double layoutRootMarginLeft = ContentRoot.Margin.Left;
                double layoutRootMarginRight = ContentRoot.Margin.Right;

                // We have different widths to use depending on the view state
                if (ApplicationView.Value != ApplicationViewState.Snapped)
                {
                    // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
                    // and the LayoutRoot's margins
                    InputSection.Width = availableWidth - (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
                }
                else
                {
                    // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
                    if (AutoSizeInputSectionWhenSnapped)
                    {
                        InputSection.Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
                    }
                }
            }
            InvalidateViewState();
        }

void SDKTemplate::MainPage::InvalidateSize ( ) [inline, private]

Definition at line 85 of file MainPage.xaml.cs.

        {
            // Get the window width
            double windowWidth = this.ActualWidth;
            if (windowWidth != 0.0)
            {
                // Get the width of the ListBox.
                double listBoxWidth = Scenarios.ActualWidth;

                // Is the ListBox using any margins that we need to consider?
                double listBoxMarginLeft = Scenarios.Margin.Left;
                double listBoxMarginRight = Scenarios.Margin.Right;

                // Figure out how much room is left after considering the list box width
                double availableWidth = windowWidth - listBoxWidth;

                // Is the top most child using margins?
                double layoutRootMarginLeft = ContentRoot.Margin.Left;
                double layoutRootMarginRight = ContentRoot.Margin.Right;

                // We have different widths to use depending on the view state
                if (ApplicationView.Value != ApplicationViewState.Snapped)
                {
                    // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
                    // and the LayoutRoot's margins
                    InputSection.Width = availableWidth - (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
                }
                else
                {
                    // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
                    if (AutoSizeInputSectionWhenSnapped)
                    {
                        InputSection.Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
                    }
                }
            }
            InvalidateViewState();
        }

void SDKTemplate::MainPage::InvalidateSize ( ) [inline, private]

Definition at line 69 of file MainPage.xaml.cs.

        {
            // Get the window width
            double windowWidth = this.ActualWidth;

            if (windowWidth != 0.0)
            {
                // Get the width of the ContentPanel.
                double contentPanelWidth = ContentPanel.ActualWidth;

                // Is the ContentPanel using any margins that we need to consider?
                double contentPanelMarginLeft = ContentPanel.Margin.Left;
                double contentPanelMarginRight = ContentPanel.Margin.Right;

                // Figure out how much room is left
                double availableWidth = windowWidth;

                // Is the top most child using margins?
                double layoutRootMarginLeft = ContentRoot.Margin.Left;
                double layoutRootMarginRight = ContentRoot.Margin.Right;

                // We have different widths to use depending on the view state
                if (ApplicationView.Value != ApplicationViewState.Snapped)
                {
                    // Make us as big as the the left over space
                    ContentPanel.Width = ((availableWidth) - (layoutRootMarginLeft + layoutRootMarginRight + contentPanelMarginLeft + contentPanelMarginRight));
                }
                else
                {
                    // Make us as big as the left over space
                    ContentPanel.Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
                }
            }
            InvalidateViewState();
        }

void SDKTemplate::MainPage::InvalidateSize ( ) [inline, private]

Definition at line 85 of file MainPage.xaml.cs.

        {
            // Get the window width
            double windowWidth = this.ActualWidth;
            if (windowWidth != 0.0)
            {
                // Get the width of the ListBox.
                double listBoxWidth = Scenarios.ActualWidth;

                // Is the ListBox using any margins that we need to consider?
                double listBoxMarginLeft = Scenarios.Margin.Left;
                double listBoxMarginRight = Scenarios.Margin.Right;

                // Figure out how much room is left after considering the list box width
                double availableWidth = windowWidth - listBoxWidth;

                // Is the top most child using margins?
                double layoutRootMarginLeft = ContentRoot.Margin.Left;
                double layoutRootMarginRight = ContentRoot.Margin.Right;

                // We have different widths to use depending on the view state
                if (ApplicationView.Value != ApplicationViewState.Snapped)
                {
                    // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
                    // and the LayoutRoot's margins
                    InputSection.Width = availableWidth - (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
                }
                else
                {
                    // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
                    if (AutoSizeInputSectionWhenSnapped)
                    {
                        InputSection.Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
                    }
                }
            }
            InvalidateViewState();
        }

void SDKTemplate::MainPage::InvalidateViewState ( ) [inline, private]

Definition at line 124 of file MainPage.xaml.cs.

        {
            if (ApplicationView.Value == ApplicationViewState.Snapped)
            {
                Grid.SetRow(DescriptionText, 3);
                Grid.SetColumn(DescriptionText, 0);

                Grid.SetRow(InputSection, 4);
                Grid.SetColumn(InputSection, 0);

                Grid.SetRow(FooterPanel, 2);
                Grid.SetColumn(FooterPanel, 0);
            }
            else
            {
                Grid.SetRow(DescriptionText, 1);
                Grid.SetColumn(DescriptionText, 1);

                Grid.SetRow(InputSection, 2);
                Grid.SetColumn(InputSection, 1);

                Grid.SetRow(FooterPanel, 1);
                Grid.SetColumn(FooterPanel, 1);
            }

            // Since we don't load the scenario page in the traditional manner (we just pluck out the
            // input and output sections from the page) we need to ensure that any VSM code used
            // by the scenario's input and output sections is fired.
            VisualStateManager.GoToState((Control)InputSection, "Input" + ApplicationView.Value.ToString(), false);
            VisualStateManager.GoToState((Control)OutputSection, "Output" + ApplicationView.Value.ToString(), false);
        }

void SDKTemplate::MainPage::InvalidateViewState ( ) [inline, private]

Definition at line 124 of file MainPage.xaml.cs.

        {
            if (ApplicationView.Value == ApplicationViewState.Snapped)
            {
                Grid.SetRow(DescriptionText, 3);
                Grid.SetColumn(DescriptionText, 0);

                Grid.SetRow(InputSection, 4);
                Grid.SetColumn(InputSection, 0);

                Grid.SetRow(FooterPanel, 2);
                Grid.SetColumn(FooterPanel, 0);
            }
            else
            {
                Grid.SetRow(DescriptionText, 1);
                Grid.SetColumn(DescriptionText, 1);

                Grid.SetRow(InputSection, 2);
                Grid.SetColumn(InputSection, 1);

                Grid.SetRow(FooterPanel, 1);
                Grid.SetColumn(FooterPanel, 1);
            }

            // Since we don't load the scenario page in the traditional manner (we just pluck out the
            // input and output sections from the page) we need to ensure that any VSM code used
            // by the scenario's input and output sections is fired.
            VisualStateManager.GoToState((Control)InputSection, "Input" + ApplicationView.Value.ToString(), false);
            VisualStateManager.GoToState((Control)OutputSection, "Output" + ApplicationView.Value.ToString(), false);
        }

void SDKTemplate::MainPage::InvalidateViewState ( ) [inline, private]

Definition at line 105 of file MainPage.xaml.cs.

        {

            if (ApplicationView.Value == ApplicationViewState.Snapped)
            {
                Grid.SetRow(FooterPanel, 2);
                Grid.SetColumn(FooterPanel, 0);
            }
            else
            {
                Grid.SetRow(FooterPanel, 1);
                Grid.SetColumn(FooterPanel, 1);
            }
        }

void SDKTemplate::MainPage::InvalidateViewState ( ) [inline, private]

Definition at line 124 of file MainPage.xaml.cs.

        {
            if (ApplicationView.Value == ApplicationViewState.Snapped)
            {
                Grid.SetRow(DescriptionText, 3);
                Grid.SetColumn(DescriptionText, 0);

                Grid.SetRow(InputSection, 4);
                Grid.SetColumn(InputSection, 0);

                Grid.SetRow(FooterPanel, 2);
                Grid.SetColumn(FooterPanel, 0);
            }
            else
            {
                Grid.SetRow(DescriptionText, 1);
                Grid.SetColumn(DescriptionText, 1);

                Grid.SetRow(InputSection, 2);
                Grid.SetColumn(InputSection, 1);

                Grid.SetRow(FooterPanel, 1);
                Grid.SetColumn(FooterPanel, 1);
            }

            // Since we don't load the scenario page in the traditional manner (we just pluck out the
            // input and output sections from the page) we need to ensure that any VSM code used
            // by the scenario's input and output sections is fired.
            VisualStateManager.GoToState((Control)InputSection, "Input" + ApplicationView.Value.ToString(), false);
            VisualStateManager.GoToState((Control)OutputSection, "Output" + ApplicationView.Value.ToString(), false);
        }

void SDKTemplate::MainPage::InvalidateViewState ( ) [inline, private]

Definition at line 124 of file MainPage.xaml.cs.

        {
            if (ApplicationView.Value == ApplicationViewState.Snapped)
            {
                Grid.SetRow(DescriptionText, 3);
                Grid.SetColumn(DescriptionText, 0);

                Grid.SetRow(InputSection, 4);
                Grid.SetColumn(InputSection, 0);

                Grid.SetRow(FooterPanel, 2);
                Grid.SetColumn(FooterPanel, 0);
            }
            else
            {
                Grid.SetRow(DescriptionText, 1);
                Grid.SetColumn(DescriptionText, 1);

                Grid.SetRow(InputSection, 2);
                Grid.SetColumn(InputSection, 1);

                Grid.SetRow(FooterPanel, 1);
                Grid.SetColumn(FooterPanel, 1);
            }

            // Since we don't load the scenario page in the traditional manner (we just pluck out the
            // input and output sections from the page) we need to ensure that any VSM code used
            // by the scenario's input and output sections is fired.
            VisualStateManager.GoToState((Control)InputSection, "Input" + ApplicationView.Value.ToString(), false);
            VisualStateManager.GoToState((Control)OutputSection, "Output" + ApplicationView.Value.ToString(), false);
        }

void SDKTemplate::MainPage::LoadScenario ( Type scenarioClass ) [inline]

This method is responsible for loading the individual input and output sections for each scenario.

This is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input and output sections into the respective UserControl on the main page.

Parameters:
scenarioName

Definition at line 192 of file MainPage.xaml.cs.

        {
            AutoSizeInputSectionWhenSnapped = true;

            // Load the ScenarioX.xaml file into the Frame.
            HiddenFrame.Navigate(scenarioClass, this);

            // Get the top element, the Page, so we can look up the elements
            // that represent the input and output sections of the ScenarioX file.
            Page hiddenPage = HiddenFrame.Content as Page;

            // Get each element.
            UIElement input = hiddenPage.FindName("Input") as UIElement;
            UIElement output = hiddenPage.FindName("Output") as UIElement;

            if (input == null)
            {
                // Malformed input section.
                NotifyUser(String.Format(
                    "Cannot load scenario input section for {0}.  Make sure root of input section markup has x:Name of 'Input'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
                return;
            }

            if (output == null)
            {
                // Malformed output section.
                NotifyUser(String.Format(
                    "Cannot load scenario output section for {0}.  Make sure root of output section markup has x:Name of 'Output'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
                return;
            }

            // Find the LayoutRoot which parents the input and output sections in the main page.
            Panel panel = hiddenPage.FindName("LayoutRoot") as Panel;

            if (panel != null)
            {
                // Get rid of the content that is currently in the intput and output sections.
                panel.Children.Remove(input);
                panel.Children.Remove(output);

                // Populate the input and output sections with the newly loaded content.
                InputSection.Content = input;
                OutputSection.Content = output;
            }
            else
            {
                // Malformed Scenario file.
                NotifyUser(String.Format(
                    "Cannot load scenario: '{0}'.  Make sure root tag in the '{0}' file has an x:Name of 'LayoutRoot'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
            }
        }

void SDKTemplate::MainPage::LoadScenario ( Type scenarioClass ) [inline]

This method is responsible for loading the individual input and output sections for each scenario.

This is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input and output sections into the respective UserControl on the main page.

Parameters:
scenarioName

Definition at line 192 of file MainPage.xaml.cs.

        {
            AutoSizeInputSectionWhenSnapped = true;

            // Load the ScenarioX.xaml file into the Frame.
            HiddenFrame.Navigate(scenarioClass, this);

            // Get the top element, the Page, so we can look up the elements
            // that represent the input and output sections of the ScenarioX file.
            Page hiddenPage = HiddenFrame.Content as Page;

            // Get each element.
            UIElement input = hiddenPage.FindName("Input") as UIElement;
            UIElement output = hiddenPage.FindName("Output") as UIElement;

            if (input == null)
            {
                // Malformed input section.
                NotifyUser(String.Format(
                    "Cannot load scenario input section for {0}.  Make sure root of input section markup has x:Name of 'Input'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
                return;
            }

            if (output == null)
            {
                // Malformed output section.
                NotifyUser(String.Format(
                    "Cannot load scenario output section for {0}.  Make sure root of output section markup has x:Name of 'Output'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
                return;
            }

            // Find the LayoutRoot which parents the input and output sections in the main page.
            Panel panel = hiddenPage.FindName("LayoutRoot") as Panel;

            if (panel != null)
            {
                // Get rid of the content that is currently in the intput and output sections.
                panel.Children.Remove(input);
                panel.Children.Remove(output);

                // Populate the input and output sections with the newly loaded content.
                InputSection.Content = input;
                OutputSection.Content = output;
            }
            else
            {
                // Malformed Scenario file.
                NotifyUser(String.Format(
                    "Cannot load scenario: '{0}'.  Make sure root tag in the '{0}' file has an x:Name of 'LayoutRoot'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
            }
        }

void SDKTemplate::MainPage::LoadScenario ( Type scenarioClass ) [inline]

This method is responsible for loading the individual input and output sections for each scenario.

This is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input and output sections into the respective UserControl on the main page.

Parameters:
scenarioName

Definition at line 192 of file MainPage.xaml.cs.

        {
            AutoSizeInputSectionWhenSnapped = true;

            // Load the ScenarioX.xaml file into the Frame.
            HiddenFrame.Navigate(scenarioClass, this);

            // Get the top element, the Page, so we can look up the elements
            // that represent the input and output sections of the ScenarioX file.
            Page hiddenPage = HiddenFrame.Content as Page;

            // Get each element.
            UIElement input = hiddenPage.FindName("Input") as UIElement;
            UIElement output = hiddenPage.FindName("Output") as UIElement;

            if (input == null)
            {
                // Malformed input section.
                NotifyUser(String.Format(
                    "Cannot load scenario input section for {0}.  Make sure root of input section markup has x:Name of 'Input'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
                return;
            }

            if (output == null)
            {
                // Malformed output section.
                NotifyUser(String.Format(
                    "Cannot load scenario output section for {0}.  Make sure root of output section markup has x:Name of 'Output'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
                return;
            }

            // Find the LayoutRoot which parents the input and output sections in the main page.
            Panel panel = hiddenPage.FindName("LayoutRoot") as Panel;

            if (panel != null)
            {
                // Get rid of the content that is currently in the intput and output sections.
                panel.Children.Remove(input);
                panel.Children.Remove(output);

                // Populate the input and output sections with the newly loaded content.
                InputSection.Content = input;
                OutputSection.Content = output;
            }
            else
            {
                // Malformed Scenario file.
                NotifyUser(String.Format(
                    "Cannot load scenario: '{0}'.  Make sure root tag in the '{0}' file has an x:Name of 'LayoutRoot'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
            }
        }

void SDKTemplate::MainPage::LoadScenario ( Type scenarioClass ) [inline]

This method is responsible for loading the individual input and output sections for each scenario.

This is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input and output sections into the respective UserControl on the main page.

Parameters:
scenarioName

Definition at line 192 of file MainPage.xaml.cs.

        {
            AutoSizeInputSectionWhenSnapped = true;

            // Load the ScenarioX.xaml file into the Frame.
            HiddenFrame.Navigate(scenarioClass, this);

            // Get the top element, the Page, so we can look up the elements
            // that represent the input and output sections of the ScenarioX file.
            Page hiddenPage = HiddenFrame.Content as Page;

            // Get each element.
            UIElement input = hiddenPage.FindName("Input") as UIElement;
            UIElement output = hiddenPage.FindName("Output") as UIElement;

            if (input == null)
            {
                // Malformed input section.
                NotifyUser(String.Format(
                    "Cannot load scenario input section for {0}.  Make sure root of input section markup has x:Name of 'Input'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
                return;
            }

            if (output == null)
            {
                // Malformed output section.
                NotifyUser(String.Format(
                    "Cannot load scenario output section for {0}.  Make sure root of output section markup has x:Name of 'Output'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
                return;
            }

            // Find the LayoutRoot which parents the input and output sections in the main page.
            Panel panel = hiddenPage.FindName("LayoutRoot") as Panel;

            if (panel != null)
            {
                // Get rid of the content that is currently in the intput and output sections.
                panel.Children.Remove(input);
                panel.Children.Remove(output);

                // Populate the input and output sections with the newly loaded content.
                InputSection.Content = input;
                OutputSection.Content = output;
            }
            else
            {
                // Malformed Scenario file.
                NotifyUser(String.Format(
                    "Cannot load scenario: '{0}'.  Make sure root tag in the '{0}' file has an x:Name of 'LayoutRoot'",
                    scenarioClass.Name), NotifyType.ErrorMessage);
            }
        }

void SDKTemplate::MainPage::MainPage_SizeChanged | ( | object | sender,
 |  | SizeChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 63 of file MainPage.xaml.cs.

        {
            InvalidateSize();
            if (MainPageResized != null)
            {
                MainPageSizeChangedEventArgs args = new MainPageSizeChangedEventArgs();
                args.ViewState = ApplicationView.Value;
                MainPageResized(this, args);
            }
        }

void SDKTemplate::MainPage::MainPage_SizeChanged | ( | object | sender,
 |  | SizeChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 63 of file MainPage.xaml.cs.

        {
            InvalidateSize();
            if (MainPageResized != null)
            {
                MainPageSizeChangedEventArgs args = new MainPageSizeChangedEventArgs();
                args.ViewState = ApplicationView.Value;
                MainPageResized(this, args);
            }
        }

void SDKTemplate::MainPage::MainPage_SizeChanged | ( | object | sender,
 |  | SizeChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 63 of file MainPage.xaml.cs.

        {
            InvalidateSize();
            if (MainPageResized != null)
            {
                MainPageSizeChangedEventArgs args = new MainPageSizeChangedEventArgs();
                args.ViewState = ApplicationView.Value;
                MainPageResized(this, args);
            }
        }

void SDKTemplate::MainPage::MainPage_SizeChanged | ( | object | sender,
 |  | SizeChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 54 of file MainPage.xaml.cs.

        {
            InvalidateSize();
        }

void SDKTemplate::MainPage::MainPage_SizeChanged | ( | object | sender,
 |  | SizeChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 63 of file MainPage.xaml.cs.

        {
            InvalidateSize();
            if (MainPageResized != null)
            {
                MainPageSizeChangedEventArgs args = new MainPageSizeChangedEventArgs();
                args.ViewState = ApplicationView.Value;
                MainPageResized(this, args);
            }
        }

void SDKTemplate::MainPage::NotifyUser | ( | string | strMessage,
 |  | NotifyType | type |
 | ) |  |  | [inline]

Definition at line 268 of file MainPage.xaml.cs.

        {
            switch (type)
            {
                // Use the status message style.
                case NotifyType.StatusMessage:
                    StatusBlock.Style = Resources["StatusStyle"] as Style;
                    break;
                // Use the error message style.
                case NotifyType.ErrorMessage:
                    StatusBlock.Style = Resources["ErrorStyle"] as Style;
                    break;
            }
            StatusBlock.Text = strMessage;

            // Collapse the StatusBlock if it has no text to conserve real estate.
            if (StatusBlock.Text != String.Empty)
            {
                StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Visible;
            }
            else
            {
                StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            }
        }

void SDKTemplate::MainPage::NotifyUser | ( | string | strMessage,
 |  | NotifyType | type |
 | ) |  |  | [inline]

Definition at line 268 of file MainPage.xaml.cs.

        {
            switch (type)
            {
                // Use the status message style.
                case NotifyType.StatusMessage:
                    StatusBlock.Style = Resources["StatusStyle"] as Style;
                    break;
                // Use the error message style.
                case NotifyType.ErrorMessage:
                    StatusBlock.Style = Resources["ErrorStyle"] as Style;
                    break;
            }
            StatusBlock.Text = strMessage;

            // Collapse the StatusBlock if it has no text to conserve real estate.
            if (StatusBlock.Text != String.Empty)
            {
                StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Visible;
            }
            else
            {
                StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            }
        }

void SDKTemplate::MainPage::NotifyUser | ( | string | strMessage,
 |  | NotifyType | type |
 | ) |  |  | [inline]

Definition at line 268 of file MainPage.xaml.cs.

        {
            switch (type)
            {
                // Use the status message style.
                case NotifyType.StatusMessage:
                    StatusBlock.Style = Resources["StatusStyle"] as Style;
                    break;
                // Use the error message style.
                case NotifyType.ErrorMessage:
                    StatusBlock.Style = Resources["ErrorStyle"] as Style;
                    break;
            }
            StatusBlock.Text = strMessage;

            // Collapse the StatusBlock if it has no text to conserve real estate.
            if (StatusBlock.Text != String.Empty)
            {
                StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Visible;
            }
            else
            {
                StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            }
        }

void SDKTemplate::MainPage::NotifyUser | ( | string | strMessage,
 |  | NotifyType | type |
 | ) |  |  | [inline]

Definition at line 268 of file MainPage.xaml.cs.

        {
            switch (type)
            {
                // Use the status message style.
                case NotifyType.StatusMessage:
                    StatusBlock.Style = Resources["StatusStyle"] as Style;
                    break;
                // Use the error message style.
                case NotifyType.ErrorMessage:
                    StatusBlock.Style = Resources["ErrorStyle"] as Style;
                    break;
            }
            StatusBlock.Text = strMessage;

            // Collapse the StatusBlock if it has no text to conserve real estate.
            if (StatusBlock.Text != String.Empty)
            {
                StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Visible;
            }
            else
            {
                StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
            }
        }

override void SDKTemplate::MainPage::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 79 of file MainPage.xaml.cs.

        {
            PopulateScenarios();
            InvalidateViewState();
        }

override void SDKTemplate::MainPage::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 79 of file MainPage.xaml.cs.

        {
            PopulateScenarios();
            InvalidateViewState();
        }

override void SDKTemplate::MainPage::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 79 of file MainPage.xaml.cs.

        {
            PopulateScenarios();
            InvalidateViewState();
        }

override void SDKTemplate::MainPage::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 79 of file MainPage.xaml.cs.

        {
            PopulateScenarios();
            InvalidateViewState();
        }

override void SDKTemplate::MainPage::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 64 of file MainPage.xaml.cs.

        {
            InvalidateViewState();
        }

void SDKTemplate::MainPage::PopulateScenarios ( ) [inline, private]

Definition at line 156 of file MainPage.xaml.cs.

        {
            System.Collections.ObjectModel.ObservableCollection<object> ScenarioList = new System.Collections.ObjectModel.ObservableCollection<object>();
            int i = 0;

            // Populate the ListBox with the list of scenarios as defined in Constants.cs.
            foreach (Scenario s in scenarios)
            {
                ListBoxItem item = new ListBoxItem();
                s.Title = (++i).ToString() + ") " + s.Title;
                item.Content = s;
                item.Name = s.ClassType.FullName;
                ScenarioList.Add(item);
            }

            // Bind the ListBox to the scenario list.
            Scenarios.ItemsSource = ScenarioList;

            // Starting scenario is the first or based upon a previous selection.
            int startingScenarioIndex = -1;

            if (SuspensionManager.SessionState.ContainsKey("SelectedScenarioIndex"))
            {
                int selectedScenarioIndex = Convert.ToInt32(SuspensionManager.SessionState["SelectedScenarioIndex"]);
                startingScenarioIndex = selectedScenarioIndex;
            }
            Scenarios.SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
            Scenarios.ScrollIntoView(Scenarios.SelectedItem);
        }

void SDKTemplate::MainPage::PopulateScenarios ( ) [inline, private]

Definition at line 156 of file MainPage.xaml.cs.

        {
            System.Collections.ObjectModel.ObservableCollection<object> ScenarioList = new System.Collections.ObjectModel.ObservableCollection<object>();
            int i = 0;

            // Populate the ListBox with the list of scenarios as defined in Constants.cs.
            foreach (Scenario s in scenarios)
            {
                ListBoxItem item = new ListBoxItem();
                s.Title = (++i).ToString() + ") " + s.Title;
                item.Content = s;
                item.Name = s.ClassType.FullName;
                ScenarioList.Add(item);
            }

            // Bind the ListBox to the scenario list.
            Scenarios.ItemsSource = ScenarioList;

            // Starting scenario is the first or based upon a previous selection.
            int startingScenarioIndex = -1;

            if (SuspensionManager.SessionState.ContainsKey("SelectedScenarioIndex"))
            {
                int selectedScenarioIndex = Convert.ToInt32(SuspensionManager.SessionState["SelectedScenarioIndex"]);
                startingScenarioIndex = selectedScenarioIndex;
            }
            Scenarios.SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
            Scenarios.ScrollIntoView(Scenarios.SelectedItem);
        }

void SDKTemplate::MainPage::PopulateScenarios ( ) [inline, private]

Definition at line 156 of file MainPage.xaml.cs.

        {
            System.Collections.ObjectModel.ObservableCollection<object> ScenarioList = new System.Collections.ObjectModel.ObservableCollection<object>();
            int i = 0;

            // Populate the ListBox with the list of scenarios as defined in Constants.cs.
            foreach (Scenario s in scenarios)
            {
                ListBoxItem item = new ListBoxItem();
                s.Title = (++i).ToString() + ") " + s.Title;
                item.Content = s;
                item.Name = s.ClassType.FullName;
                ScenarioList.Add(item);
            }

            // Bind the ListBox to the scenario list.
            Scenarios.ItemsSource = ScenarioList;

            // Starting scenario is the first or based upon a previous selection.
            int startingScenarioIndex = -1;

            if (SuspensionManager.SessionState.ContainsKey("SelectedScenarioIndex"))
            {
                int selectedScenarioIndex = Convert.ToInt32(SuspensionManager.SessionState["SelectedScenarioIndex"]);
                startingScenarioIndex = selectedScenarioIndex;
            }
            Scenarios.SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
            Scenarios.ScrollIntoView(Scenarios.SelectedItem);
        }

void SDKTemplate::MainPage::PopulateScenarios ( ) [inline, private]

Definition at line 156 of file MainPage.xaml.cs.

        {
            System.Collections.ObjectModel.ObservableCollection<object> ScenarioList = new System.Collections.ObjectModel.ObservableCollection<object>();
            int i = 0;

            // Populate the ListBox with the list of scenarios as defined in Constants.cs.
            foreach (Scenario s in scenarios)
            {
                ListBoxItem item = new ListBoxItem();
                s.Title = (++i).ToString() + ") " + s.Title;
                item.Content = s;
                item.Name = s.ClassType.FullName;
                ScenarioList.Add(item);
            }

            // Bind the ListBox to the scenario list.
            Scenarios.ItemsSource = ScenarioList;

            // Starting scenario is the first or based upon a previous selection.
            int startingScenarioIndex = -1;

            if (SuspensionManager.SessionState.ContainsKey("SelectedScenarioIndex"))
            {
                int selectedScenarioIndex = Convert.ToInt32(SuspensionManager.SessionState["SelectedScenarioIndex"]);
                startingScenarioIndex = selectedScenarioIndex;
            }
            Scenarios.SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
            Scenarios.ScrollIntoView(Scenarios.SelectedItem);
        }

void SDKTemplate::MainPage::Scenarios_SelectionChanged | ( | object | sender,
 |  | SelectionChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 247 of file MainPage.xaml.cs.

        {
            if (Scenarios.SelectedItem != null)
            {
                NotifyUser("", NotifyType.StatusMessage);

                ListBoxItem selectedListBoxItem = Scenarios.SelectedItem as ListBoxItem;
                SuspensionManager.SessionState["SelectedScenarioIndex"] = Scenarios.SelectedIndex;

                Scenario scenario = selectedListBoxItem.Content as Scenario;
                LoadScenario(scenario.ClassType);
                InvalidateSize();

                // Fire the ScenarioLoaded event since we know that everything is loaded now.
                if (ScenarioLoaded != null)
                {
                    ScenarioLoaded(this, new EventArgs());
                }
            }
        }

void SDKTemplate::MainPage::Scenarios_SelectionChanged | ( | object | sender,
 |  | SelectionChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 247 of file MainPage.xaml.cs.

        {
            if (Scenarios.SelectedItem != null)
            {
                NotifyUser("", NotifyType.StatusMessage);

                ListBoxItem selectedListBoxItem = Scenarios.SelectedItem as ListBoxItem;
                SuspensionManager.SessionState["SelectedScenarioIndex"] = Scenarios.SelectedIndex;

                Scenario scenario = selectedListBoxItem.Content as Scenario;
                LoadScenario(scenario.ClassType);
                InvalidateSize();

                // Fire the ScenarioLoaded event since we know that everything is loaded now.
                if (ScenarioLoaded != null)
                {
                    ScenarioLoaded(this, new EventArgs());
                }
            }
        }

void SDKTemplate::MainPage::Scenarios_SelectionChanged | ( | object | sender,
 |  | SelectionChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 247 of file MainPage.xaml.cs.

        {
            if (Scenarios.SelectedItem != null)
            {
                NotifyUser("", NotifyType.StatusMessage);

                ListBoxItem selectedListBoxItem = Scenarios.SelectedItem as ListBoxItem;
                SuspensionManager.SessionState["SelectedScenarioIndex"] = Scenarios.SelectedIndex;

                Scenario scenario = selectedListBoxItem.Content as Scenario;
                LoadScenario(scenario.ClassType);
                InvalidateSize();

                // Fire the ScenarioLoaded event since we know that everything is loaded now.
                if (ScenarioLoaded != null)
                {
                    ScenarioLoaded(this, new EventArgs());
                }
            }
        }

void SDKTemplate::MainPage::Scenarios_SelectionChanged | ( | object | sender,
 |  | SelectionChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 247 of file MainPage.xaml.cs.

        {
            if (Scenarios.SelectedItem != null)
            {
                NotifyUser("", NotifyType.StatusMessage);

                ListBoxItem selectedListBoxItem = Scenarios.SelectedItem as ListBoxItem;
                SuspensionManager.SessionState["SelectedScenarioIndex"] = Scenarios.SelectedIndex;

                Scenario scenario = selectedListBoxItem.Content as Scenario;
                LoadScenario(scenario.ClassType);
                InvalidateSize();

                // Fire the ScenarioLoaded event since we know that everything is loaded now.
                if (ScenarioLoaded != null)
                {
                    ScenarioLoaded(this, new EventArgs());
                }
            }
        }

void SDKTemplate::MainPage::SetFeatureName ( string str ) [inline, private]

Definition at line 299 of file MainPage.xaml.cs.

        {
            FeatureName.Text = str;
        }

void SDKTemplate::MainPage::SetFeatureName ( string str ) [inline, private]

Definition at line 125 of file MainPage.xaml.cs.

        {
            FeatureName.Text = str;
        }

void SDKTemplate::MainPage::SetFeatureName ( string str ) [inline, private]

Definition at line 299 of file MainPage.xaml.cs.

        {
            FeatureName.Text = str;
        }

void SDKTemplate::MainPage::SetFeatureName ( string str ) [inline, private]

Definition at line 299 of file MainPage.xaml.cs.

        {
            FeatureName.Text = str;
        }

void SDKTemplate::MainPage::SetFeatureName ( string str ) [inline, private]

Definition at line 299 of file MainPage.xaml.cs.

        {
            FeatureName.Text = str;
        }

Member Data Documentation

bool SDKTemplate::MainPage::AutoSizeInputSectionWhenSnapped = true

Definition at line 28 of file MainPage.xaml.cs.

bool SDKTemplate::MainPage::CameraFound = false

Definition at line 23 of file Constants.cs.

static MainPage SDKTemplate::MainPage::Current [static]

Definition at line 38 of file MainPage.xaml.cs.

bool SDKTemplate::MainPage::DeviceChecked = false

Definition at line 22 of file Constants.cs.

const string SDKTemplate::MainPage::FEATURE_NAME = "Custom Device Access"

Definition at line 20 of file Constants.cs.

Frame SDKTemplate::MainPage::HiddenFrame = null [private]

Definition at line 40 of file MainPage.xaml.cs.

Windows.Media.MediaExtensionManager SDKTemplate::MainPage::mediaExtensionMgr [private]

Definition at line 25 of file Constants.cs.

List< Scenario > SDKTemplate::MainPage::scenarios [private]
Initial value:
 new List<Scenario>
        {
            new Scenario() { Title = "Connecting to the Fx2 Device", ClassType = typeof(CustomDeviceAccess.DeviceConnect) },
            new Scenario() { Title = "Getting and Setting device properties", ClassType = typeof(CustomDeviceAccess.DeviceProperties) },
            new Scenario() { Title = "Registering for device events", ClassType = typeof(CustomDeviceAccess.DeviceEvents) },
            new Scenario() { Title = "Invoking asynchronous device methods", ClassType = typeof(CustomDeviceAccess.DeviceAsync) }
        }

Definition at line 27 of file Constants.cs.

Property Documentation

Windows ApplicationModel Activation LaunchActivatedEventArgs SDKTemplate::MainPage::LaunchArgs [get]

Definition at line 31 of file MainPage.xaml.cs.

Event Documentation

EventHandler< MainPageSizeChangedEventArgs > SDKTemplate::MainPage::MainPageResized

Definition at line 27 of file MainPage.xaml.cs.

System EventHandler SDKTemplate::MainPage::ScenarioLoaded

Definition at line 26 of file MainPage.xaml.cs.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/app_cs/Constants.cs
  • Custom driver access/C#,C++/app_cs/MainPage.xaml.cs
  • Media capture using capture device/C#,C++/Constants.cs
  • Media capture using capture device/C#,C++/MainPage.xaml.cs
  • MediaStreamSource media extension/C#,C++/Constants.cs
  • MediaStreamSource media extension/C#,C++/MainPage.xaml.cs
  • Real-time communication/C#,C++/Constants.cs
  • Real-time communication/C#,C++/MainPage.xaml.cs
  • Windows Store device app for camera/C#,C++/Constants.cs
  • Windows Store device app for camera/C#,C++/MainPage.xaml.cs
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::MainPageSizeChangedEventArgs Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplate
  • SDKTemplate::MainPageSizeChangedEventArgs
Properties | Private Attributes

SDKTemplate::MainPageSizeChangedEventArgs Class Reference

List of all members.

Properties

ApplicationViewState | ViewState [get, set]

Private Attributes

ApplicationViewState | viewState

Detailed Description

Definition at line 305 of file MainPage.xaml.cs.

Member Data Documentation

ApplicationViewState SDKTemplate::MainPageSizeChangedEventArgs::viewState [private]

Definition at line 307 of file MainPage.xaml.cs.

Property Documentation

ApplicationViewState SDKTemplate::MainPageSizeChangedEventArgs::ViewState [get, set]

Definition at line 310 of file MainPage.xaml.cs.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/app_cs/MainPage.xaml.cs
  • Media capture using capture device/C#,C++/MainPage.xaml.cs
  • MediaStreamSource media extension/C#,C++/MainPage.xaml.cs
  • Real-time communication/C#,C++/MainPage.xaml.cs
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::Scenario Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplate
  • SDKTemplate::Scenario
Public Member Functions | Properties

SDKTemplate::Scenario Class Reference

List of all members.

Public Member Functions

override string | ToString ()
override string | ToString ()
override string | ToString ()
override string | ToString ()
override string | ToString ()

Properties

Type | ClassType [get, set]
string | Title [get, set]

Detailed Description

Definition at line 36 of file Constants.cs.

Member Function Documentation

override string SDKTemplate::Scenario::ToString ( ) [inline]

Definition at line 42 of file Constants.cs.

        {
            return Title;
        }

override string SDKTemplate::Scenario::ToString ( ) [inline]

Definition at line 30 of file Constants.cs.

        {
            return Title;
        }

override string SDKTemplate::Scenario::ToString ( ) [inline]

Definition at line 54 of file Constants.cs.

        {
            return Title;
        }

override string SDKTemplate::Scenario::ToString ( ) [inline]

Definition at line 40 of file Constants.cs.

        {
            return Title;
        }

override string SDKTemplate::Scenario::ToString ( ) [inline]

Definition at line 43 of file Constants.cs.

        {
            return Title;
        }

Property Documentation

Type SDKTemplate::Scenario::ClassType [get, set]

Definition at line 40 of file Constants.cs.

string SDKTemplate::Scenario::Title [get, set]

Definition at line 38 of file Constants.cs.

The documentation for this class was generated from the following files:
  • Custom driver access/C#,C++/app_cs/Constants.cs
  • Media capture using capture device/C#,C++/Constants.cs
  • MediaStreamSource media extension/C#,C++/Constants.cs
  • Real-time communication/C#,C++/Constants.cs
  • Windows Store device app for camera/C#,C++/Constants.cs
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplateCS::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SDKTemplateCS
  • SDKTemplateCS::MainPage
Public Member Functions | Public Attributes | Properties | Events | Private Member Functions | Private Attributes

SDKTemplateCS::MainPage Class Reference

Inherits Page.

List of all members.

Public Member Functions

MainPage ()
void | DoNavigation (Type pageType, Frame frame)
void | NotifyUser (string strMessage, NotifyType type)
async void | PickSingleFileAndSet (string[] fileTypeFilter, params MediaElement[] mediaElements)
void | VideoOnError (Object obj, ExceptionRoutedEventArgs args)

Public Attributes

const string | FEATURE_NAME = "Media Extensions"

Properties

MediaExtensionManager | ExtensionManager [get]
Frame | InputFrame [get, set]
Frame | OutputFrame [get, set]
string | RootNamespace [get, set]
Frame | ScenariosFrame [get, set]

Events

System.EventHandler | InputFrameLoaded
System.EventHandler | OutputFrameLoaded

Private Member Functions

void | CheckResolutionAndViewState ()
void | DisplayProperties_LogicalDpiChanged (object sender)
async void | Footer_Click (object sender, RoutedEventArgs e)
void | MainPage_Loaded (object sender, RoutedEventArgs e)
void | MainPage_SizeChanged (Object sender, Windows.UI.Core.WindowSizeChangedEventArgs args)
void | SetFeatureName (string str)

Private Attributes

MediaExtensionManager | _extensionManager = new MediaExtensionManager()
Frame | _inputFrame
Frame | _outputFrame
string | _rootNamespace
Frame | _scenariosFrame

Detailed Description

Definition at line 29 of file MainPage.xaml.cs.

Constructor & Destructor Documentation

SDKTemplateCS::MainPage::MainPage ( ) [inline]

Definition at line 80 of file MainPage.xaml.cs.

        {
            InitializeComponent();

            _scenariosFrame = ScenarioList;
            _inputFrame = ScenarioInput;
            _outputFrame = ScenarioOutput;

            SetFeatureName(FEATURE_NAME);

            Loaded += new RoutedEventHandler(MainPage_Loaded);
            Window.Current.SizeChanged += new WindowSizeChangedEventHandler(MainPage_SizeChanged);
            DisplayProperties.LogicalDpiChanged += new DisplayPropertiesEventHandler(DisplayProperties_LogicalDpiChanged);

            NavigationCacheMode = Windows.UI.Xaml.Navigation.NavigationCacheMode.Required;
        }

Member Function Documentation

void SDKTemplateCS::MainPage::CheckResolutionAndViewState ( ) [inline, private]

Definition at line 113 of file MainPage.xaml.cs.

        {
            VisualStateManager.GoToState(this, ApplicationView.Value.ToString() + DisplayProperties.ResolutionScale.ToString(), false);
        }

void SDKTemplateCS::MainPage::DisplayProperties_LogicalDpiChanged ( object sender ) [inline, private]

Definition at line 108 of file MainPage.xaml.cs.

        {
            CheckResolutionAndViewState();
        }

void SDKTemplateCS::MainPage::DoNavigation | ( | Type | pageType,
 |  | Frame | frame |
 | ) |  |  | [inline]

Definition at line 149 of file MainPage.xaml.cs.

        {
            frame.Navigate(pageType, this);
            if (pageType.Name.Contains("Input"))
            {
                // Raise InputFrameLoaded so downstream pages know that the input frame content has been loaded.
                if (InputFrameLoaded != null)
                {
                    InputFrameLoaded(this, new EventArgs());
                }
            }
            else
            {
                // Raise OutputFrameLoaded so downstream pages know that the output frame content has been loaded.
                if (OutputFrameLoaded != null)
                {
                    OutputFrameLoaded(this, new EventArgs());
                }
            }
        }

async void SDKTemplateCS::MainPage::Footer_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 130 of file MainPage.xaml.cs.

        {
            await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
        }

void SDKTemplateCS::MainPage::MainPage_Loaded | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 97 of file MainPage.xaml.cs.

        {
            // Figure out what resolution and orientation we are in and respond appropriately
            CheckResolutionAndViewState();

            // Load the ScenarioList page into the proper frame
            ScenarioList.Navigate(Type.GetType(_rootNamespace + ".ScenarioList"), this);
        }

void SDKTemplateCS::MainPage::MainPage_SizeChanged | ( | Object | sender,
 |  | Windows.UI.Core.WindowSizeChangedEventArgs | args |
 | ) |  |  | [inline, private]

Definition at line 118 of file MainPage.xaml.cs.

        {
            CheckResolutionAndViewState();
        }

void SDKTemplateCS::MainPage::NotifyUser | ( | string | strMessage,
 |  | NotifyType | type |
 | ) |  |  | [inline]

Definition at line 135 of file MainPage.xaml.cs.

        {
            switch (type)
            {
                case NotifyType.StatusMessage:
                    StatusBlock.Style = Resources["StatusStyle"] as Style;
                    break;
                case NotifyType.ErrorMessage:
                    StatusBlock.Style = Resources["ErrorStyle"] as Style;
                    break;
            }
            StatusBlock.Text = strMessage;
        }

async void SDKTemplateCS::MainPage::PickSingleFileAndSet | ( | string[] | fileTypeFilter,
 |  | params MediaElement[] | mediaElements |
 | ) |  |  | [inline]

Definition at line 175 of file MainPage.xaml.cs.

        {
            var currentState = Windows.UI.ViewManagement.ApplicationView.Value;
            if (currentState == Windows.UI.ViewManagement.ApplicationViewState.Snapped &&
                !Windows.UI.ViewManagement.ApplicationView.TryUnsnap())
            {
                // File picker cannot be used in the snapped state.
                NotifyUser("File picker cannot be used when application is in the snapped state.", NotifyType.StatusMessage);
                return;
            }

            CoreDispatcher dispatcher = Window.Current.Dispatcher;

            var picker = new Windows.Storage.Pickers.FileOpenPicker();
            picker.SuggestedStartLocation = Windows.Storage.Pickers.PickerLocationId.VideosLibrary;
            foreach (string filter in fileTypeFilter)
            {
                picker.FileTypeFilter.Add(filter);
            }
            StorageFile file = await picker.PickSingleFileAsync();

            if (file != null)
            {
                try
                {
                    var stream = await file.OpenAsync(FileAccessMode.Read);

                    for (int i = 0; i < mediaElements.Length; ++i)
                    {
                        MediaElement me = mediaElements[i];
                        me.Stop();
                        if (i + 1 < mediaElements.Length)
                        {
                            me.SetSource(stream.CloneStream(), file.ContentType);
                        }
                        else
                        {
                            me.SetSource(stream, file.ContentType);
                        }
                    }
                }
                catch (Exception ex)
                {
                    NotifyUser("Cannot open video file - error: " + ex.Message, NotifyType.ErrorMessage);
                }
            }
        }

void SDKTemplateCS::MainPage::SetFeatureName ( string str ) [inline, private]

Definition at line 125 of file MainPage.xaml.cs.

        {
            FeatureName.Text = str;
        }

void SDKTemplateCS::MainPage::VideoOnError | ( | Object | obj,
 |  | ExceptionRoutedEventArgs | args |
 | ) |  |  | [inline]

Definition at line 223 of file MainPage.xaml.cs.

        {
            NotifyUser("Cannot open video file - error: " + args.ErrorMessage, NotifyType.ErrorMessage);
        }

Member Data Documentation

MediaExtensionManager SDKTemplateCS::MainPage::_extensionManager = new MediaExtensionManager() [private]

Definition at line 65 of file MainPage.xaml.cs.

Frame SDKTemplateCS::MainPage::_inputFrame [private]

Definition at line 41 of file MainPage.xaml.cs.

Frame SDKTemplateCS::MainPage::_outputFrame [private]

Definition at line 49 of file MainPage.xaml.cs.

string SDKTemplateCS::MainPage::_rootNamespace [private]

Definition at line 57 of file MainPage.xaml.cs.

Frame SDKTemplateCS::MainPage::_scenariosFrame [private]

Definition at line 33 of file MainPage.xaml.cs.

const string SDKTemplateCS::MainPage::FEATURE_NAME = "Media Extensions"

Definition at line 18 of file Constants.cs.

Property Documentation

MediaExtensionManager SDKTemplateCS::MainPage::ExtensionManager [get]

Definition at line 68 of file MainPage.xaml.cs.

Frame SDKTemplateCS::MainPage::InputFrame [get, set]

Definition at line 44 of file MainPage.xaml.cs.

Frame SDKTemplateCS::MainPage::OutputFrame [get, set]

Definition at line 52 of file MainPage.xaml.cs.

string SDKTemplateCS::MainPage::RootNamespace [get, set]

Definition at line 60 of file MainPage.xaml.cs.

Frame SDKTemplateCS::MainPage::ScenariosFrame [get, set]

Definition at line 36 of file MainPage.xaml.cs.

Event Documentation

System.EventHandler SDKTemplateCS::MainPage::InputFrameLoaded

Definition at line 75 of file MainPage.xaml.cs.

System.EventHandler SDKTemplateCS::MainPage::OutputFrameLoaded

Definition at line 76 of file MainPage.xaml.cs.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MainPage.xaml.cs
  • Media extensions/C#,C++/Sample-Utils/Constants.cs
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Protected Member Functions | Protected Attributes | Private Member Functions | Static Private Member Functions | Private Attributes

sealed Class Reference

Wrap a WeakReference as a reference object for use in a collection.

#include "BackgroundObject.h"

Inherits UiaCoreWindowProvider::ITriColorControlInternal, ManipulatableObject, and ManipulatableObject.

List of all members.

Public Member Functions

virtual | ~ReencodeState ()
void | Attach (_In_ Windows::UI::Input::GestureRecognizer^gestureRecognizer)
void | Attach (_In_ Windows::UI::Input::GestureRecognizer^gestureRecognizer)
BackgroundObject (_In_opt_ ManipulatableObject^parent, _In_ IRenderer^renderer)
virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateDeviceResources () override
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual
Windows::ApplicationModel::Core::IFrameworkView 		CreateView ()
virtual void | CreateWindowSizeDependentResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | CreateWindowSizeDependentResources () override
CTriColorWindow ()
virtual void | Deserialize (_In_ Windows::Foundation::Collections::IPropertySet^properties) override
void | Detach (_In_ Windows::UI::Input::GestureRecognizer^gestureRecognizer)
void | Detach (_In_ Windows::UI::Input::GestureRecognizer^gestureRecognizer)
void | Draw (_In_ ID2D1DeviceContext *deviceContext, _In_ ID2D1SolidColorBrush *brush)
void | DrawBackground (_In_ ID2D1DeviceContext *deviceContext, _In_ ID2D1SolidColorBrush *brush)
DrawingObject (_In_opt_ ManipulatableObject^parent, _In_ IRenderer^renderer)
void | DrawOverlay (_In_ ID2D1DeviceContext *deviceContext, _In_ IDWriteTextFormat *textFormat, _In_ ID2D1SolidColorBrush *brush)
void | DrawOverlay (_In_ ID2D1DeviceContext *deviceContext, _In_ IDWriteTextFormat *textFormat, _In_ ID2D1SolidColorBrush *brush)
FrameworkView ()
FrameworkViewSource ()
virtual Platform::Object | GetAppWindowProvider ()
Color | GetColor ()
virtual Platform::Object | GetTriColorControlProvider ()
virtual Platform::Object | GetTriColorFragmentProvider (_In_ UiaCoreWindowProvider::TriColorValue value)
bool | HitTest (_In_ Windows::Foundation::Point position)
void | Initialize ()
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Initialize (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
void | Initialize (_In_ Color color, _In_ float x, _In_ float y, _In_ float dx, _In_ float dy)
virtual void | Initialize (Windows::ApplicationModel::Core::CoreApplicationView^applicationView)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (Platform::String^entryPoint)
virtual void | Load (_In_ Platform::String^entryPoint)
virtual void | Load (Platform::String^entryPoint)
ManipulatableObjectTransform (_In_opt_ ManipulatableObject^referentObject)
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
virtual void | Present () override
ReencodeState ()
virtual void | Render () override
virtual void | Render () override
virtual void | Render () override
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Run ()
virtual void | Serialize (_In_ Windows::Foundation::Collections::IPropertySet^properties) override
void | SetDevice (_In_opt_ Windows::Devices::Input::IPointerDevice^pointerDevice)
virtual void | SetWindow (Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
virtual void | SetWindow (_In_ Windows::UI::Core::CoreWindow^window)
ShapesPuzzle ()
simpleInk ()
virtual Windows::Foundation::Rect | TransformBounds (_In_ Windows::Foundation::Rect rect)
virtual bool | TryTransform (_In_ Windows::Foundation::Point inPoint, _Out_ Windows::Foundation::Point *outPoint)
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual void | Uninitialize ()
virtual
UiaCoreWindowProvider::TriColorValue 		ValueFromPoint (_In_ Windows::Foundation::Point pt)

Public Attributes

internal | Blue
Windows::Graphics::Imaging::BitmapDecoder | Decoder
Windows::Graphics::Imaging::BitmapEncoder | Encoder
internal | Green = First
internal | MaxCount
internal | Orange
Windows::Storage::Streams::IRandomAccessStream | OutputStream
Windows::Storage::StorageFile | PhotoStorage
internal | Purple
internal | Red
internal | Yellow

Protected Member Functions

void | BezierRender ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnChangeDrawingAttributes ()
void | OnChangeRecognizer ()
void | OnCharacterReceived (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CharacterReceivedEventArgs^args)
void | OnCopyTextToClipboard ()
void | OnCopyToClipboard ()
void | OnDelete ()
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLoad ()
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnPasteFromClipboard ()
void | OnPointerMoved (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnRecognize ()
void | OnSave ()
void | OnSelectAll ()
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)

Protected Attributes

internal _Outptr_
ID2D1PathGeometry ** 		geometry

Private Member Functions

~BackgroundObject ()
~CTriColorWindow ()
~DrawingObject ()
void | CreateThemeSpecificResources ()
void | DiscardThemeSpecificResources ()
void | EnsureAppWindowProviderCreated ()
void | EnsureControlProviderCreated ()
void | EnsureFragmentProviderCreated (_In_ UiaCoreWindowProvider::TriColorValue value)
void | GetDeviceDescription ()
Windows::Foundation::Rect | GetGreenRect ()
void | GetObjectDescription ()
Windows::Foundation::Rect | GetRedRect ()
Windows::Foundation::Rect | GetYellowRect ()
void | OnActivated (_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args)
void | OnAutomationProviderRequested (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::AutomationProviderRequestedEventArgs^e)
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnHighContrastChanged (_In_ Windows::UI::ViewManagement::AccessibilitySettings^sender, _In_ Platform::Object^e)
void | OnHolding (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::HoldingEventArgs^args)
void | OnHolding (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::HoldingEventArgs^args)
void | OnKeyDown (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^e)
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnManipulationCompleted (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationCompletedEventArgs^args)
void | OnManipulationCompleted (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationCompletedEventArgs^args)
void | OnManipulationInertiaStarting (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationInertiaStartingEventArgs^args)
void | OnManipulationInertiaStarting (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationInertiaStartingEventArgs^args)
void | OnManipulationStarted (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationStartedEventArgs^args)
void | OnManipulationStarted (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationStartedEventArgs^args)
void | OnManipulationUpdated (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args)
void | OnManipulationUpdated (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args)
void | OnPointerReleased (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^e)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnRightTapped (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::RightTappedEventArgs^args)
void | OnRightTapped (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::RightTappedEventArgs^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnTapped (_In_ Windows::UI::Input::GestureRecognizer^sender, _In_ Windows::UI::Input::TappedEventArgs^args)
void | OnWindowActivated (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowActivatedEventArgs^e)
void | OnWindowClosed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^e)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | SetValue (_In_ UiaCoreWindowProvider::TriColorValue newValue)
HRESULT | ValueFromPoint (_In_ Windows::Foundation::Point pt, _Out_ UiaCoreWindowProvider::TriColorValue *value)

Static Private Member Functions

static bool | PointInRect (_In_ Windows::Foundation::Rect rect, _In_ Windows::Foundation::Point pt)

Private Attributes

internal | __pad0__: WeakFrame(Frame^ frame) { _frameReference = frame
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		_backgroundBrush
Windows::UI::Color | _backgroundColor
Color | _color
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		_currentBuffer
Windows::Foundation::Point | _descPosition
WCHAR | _descText [128]
WCHAR | _deviceDesc [1024]
Windows::UI::Input::Inking::InkDrawingAttributes | _drawingAttributes
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		_eventTextFormat
WeakReference | _frameReference
Color | _initColor
float | _initDX
float | _initDY
float | _initX
float | _initY
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		_inkBrush
Microsoft::WRL::ComPtr
< ID2D1StrokeStyle > 		_inkStyle
Windows::UI::Input::Inking::InkManipulationMode | _manipulationMode
Windows::Foundation::Collections::IVector
< Windows::Foundation::Point > 		_manipulationPoints
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		_messageBrush
Windows::Devices::Input::IPointerDevice | _pointerDevice
int | _pointerId
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		_previousBuffer
Platform::String | _recognitionText
Windows::UI::Input::Inking::InkRecognizer | _recognizer
Windows::UI::Input::Inking::InkRecognizerContainer | _recognizerContainer
unsigned int | _recognizerId
IRenderer _renderer
RenderingMode _renderingMode
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		_selectionBrush
Microsoft::WRL::ComPtr
< ID2D1StrokeStyle > 		_selectionStyle
Platform::String | _statusMessage
Windows::UI::Input::Inking::InkStrokeBuilder | _strokeBuilder
Windows::UI::Input::Inking::InkStrokeContainer | _strokeContainer
Windows::Foundation::EventRegistrationToken | _tokenHolding
Windows::Foundation::EventRegistrationToken | _tokenManipulationCompleted
Windows::Foundation::EventRegistrationToken | _tokenManipulationInertiaStarting
Windows::Foundation::EventRegistrationToken | _tokenManipulationStarted
Windows::Foundation::EventRegistrationToken | _tokenManipulationUpdated
Windows::Foundation::EventRegistrationToken | _tokenRightTapped
Windows::Foundation::EventRegistrationToken | _tokenTapped
Windows::UI::ViewManagement::AccessibilitySettings | m_accSettings
bool | m_activated
ActivationEntryPoint m_activationEntryPoint
Platform::Agile
< Windows::ApplicationModel::Core::CoreApplicationView > 		m_applicationView
Platform::Object | m_appWindowProvider
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Platform::Object | m_controlProvider
Windows::Foundation::Rect | m_controlRect
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_greenBrush
Platform::Object | m_greenProvider
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_labelFormat
Program m_program
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_redBrush
Platform::Object | m_redProvider
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_titleFormat
Windows::UI::ViewManagement::UISettings | m_uiSettings
UiaCoreWindowProvider::TriColorValue m_value
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush
Platform::Agile
< Windows::UI::Core::CoreWindow > 		m_window
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_windowTextBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_yellowBrush
Platform::Object | m_yellowProvider

Detailed Description

Definition at line 61 of file suspensionmanager.cpp.

Constructor & Destructor Documentation

sealed::~BackgroundObject ( ) [private]
sealed::~DrawingObject ( ) [private]
virtual sealed::~ReencodeState ( ) [inline, virtual]

Definition at line 47 of file AdvancedCapture.xaml.cpp.

    {
        if (InputStream != nullptr)
        {
            delete InputStream;
        }
        if (OutputStream != nullptr)
        {
            delete OutputStream;
        }
    }

sealed::~CTriColorWindow ( ) [private]

Member Function Documentation

void sealed::Attach ( _In_ Windows::UI::Input::GestureRecognizer^ gestureRecognizer )
void sealed::Attach ( _In_ Windows::UI::Input::GestureRecognizer^ gestureRecognizer )
sealed::BackgroundObject | ( | _In_opt_ ManipulatableObject^ | parent,
 |  | _In_ IRenderer^ | renderer
 | ) |  |
void sealed::BezierRender ( ) [protected]
virtual void sealed::CreateDeviceIndependentResources ( ) [override, virtual]
virtual void sealed::CreateDeviceIndependentResources ( ) [override, virtual]
virtual void sealed::CreateDeviceResources ( ) [override, virtual]
virtual void sealed::CreateDeviceResources ( ) [override, virtual]
virtual void sealed::CreateDeviceResources ( ) [override, virtual]
void sealed::CreateThemeSpecificResources ( ) [private]
virtual Windows::ApplicationModel::Core::IFrameworkView sealed::CreateView ( ) [virtual]
virtual Windows::ApplicationModel::Core::IFrameworkView sealed::CreateView ( ) [inline, virtual]

Definition at line 33 of file frameworkview.h.

    {
        return ref new FrameworkView();
    }

virtual void sealed::CreateWindowSizeDependentResources ( ) [override, virtual]
virtual void sealed::CreateWindowSizeDependentResources ( ) [override, virtual]
virtual void sealed::CreateWindowSizeDependentResources ( ) [override, virtual]
sealed::CTriColorWindow ( )
virtual void sealed::Deserialize ( _In_ Windows::Foundation::Collections::IPropertySet^ properties ) [override, virtual]

Reimplemented from ManipulatableObject.

void sealed::Detach ( _In_ Windows::UI::Input::GestureRecognizer^ gestureRecognizer )
void sealed::Detach ( _In_ Windows::UI::Input::GestureRecognizer^ gestureRecognizer )
void sealed::DiscardThemeSpecificResources ( ) [private]
void sealed::Draw | ( | _In_ ID2D1DeviceContext * | deviceContext,
 |  | _In_ ID2D1SolidColorBrush * | brush
 | ) |  |
void sealed::DrawBackground | ( | _In_ ID2D1DeviceContext * | deviceContext,
 |  | _In_ ID2D1SolidColorBrush * | brush
 | ) |  |
sealed::DrawingObject | ( | _In_opt_ ManipulatableObject^ | parent,
 |  | _In_ IRenderer^ | renderer
 | ) |  |
void sealed::DrawOverlay | ( | _In_ ID2D1DeviceContext * | deviceContext,
 |  | _In_ IDWriteTextFormat * | textFormat,
 |  | _In_ ID2D1SolidColorBrush * | brush
 | ) |  |
void sealed::DrawOverlay | ( | _In_ ID2D1DeviceContext * | deviceContext,
 |  | _In_ IDWriteTextFormat * | textFormat,
 |  | _In_ ID2D1SolidColorBrush * | brush
 | ) |  |
void sealed::EnsureAppWindowProviderCreated ( ) [private]
void sealed::EnsureControlProviderCreated ( ) [private]
void sealed::EnsureFragmentProviderCreated ( _In_ UiaCoreWindowProvider::TriColorValue value ) [private]
sealed::FrameworkView ( )
sealed::FrameworkViewSource ( ) [inline]

Definition at line 32 of file frameworkview.h.

{}

virtual Platform::Object sealed::GetAppWindowProvider ( ) [virtual]
Color sealed::GetColor ( ) [inline]

Definition at line 44 of file DrawingObject.h.

{ return _color; }

void sealed::GetDeviceDescription ( ) [private]
Windows::Foundation::Rect sealed::GetGreenRect ( ) [private]
void sealed::GetObjectDescription ( ) [private]
Windows::Foundation::Rect sealed::GetRedRect ( ) [private]
virtual Platform::Object sealed::GetTriColorControlProvider ( ) [virtual]
virtual Platform::Object sealed::GetTriColorFragmentProvider ( _In_ UiaCoreWindowProvider::TriColorValue value ) [virtual]
Windows::Foundation::Rect sealed::GetYellowRect ( ) [private]
bool sealed::HitTest ( _In_ Windows::Foundation::Point position )
void sealed::Initialize ( )
virtual void sealed::Initialize ( Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void sealed::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
void sealed::Initialize | ( | _In_ Color | color,
 |  | _In_ float | x,
 |  | _In_ float | y,
 |  | _In_ float | dx,
 |  | _In_ float | dy
 | ) |  |
virtual void sealed::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void sealed::Initialize ( _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView ) [virtual]
virtual void sealed::Load ( Platform::String^ entryPoint ) [virtual]
virtual void sealed::Load ( _In_ Platform::String^ entryPoint ) [virtual]
virtual void sealed::Load ( Platform::String^ entryPoint ) [virtual]
virtual void sealed::Load ( _In_ Platform::String^ entryPoint ) [virtual]
sealed::ManipulatableObjectTransform ( _In_opt_ ManipulatableObject^ referentObject )
void sealed::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args
 | ) |  |
void sealed::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [protected]
void sealed::OnActivated | ( | _In_ Windows::ApplicationModel::Core::CoreApplicationView^ | applicationView,
 |  | _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnAutomationProviderRequested | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::AutomationProviderRequestedEventArgs^ | e |
 | ) |  |  | [private]
void sealed::OnChangeDrawingAttributes ( ) [protected]
void sealed::OnChangeRecognizer ( ) [protected]
void sealed::OnCharacterReceived | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CharacterReceivedEventArgs^ | args |
 | ) |  |  | [protected]
void sealed::OnCopyTextToClipboard ( ) [protected]
void sealed::OnCopyToClipboard ( ) [protected]
void sealed::OnDelete ( ) [protected]
void sealed::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender )
void sealed::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [protected]
void sealed::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]
void sealed::OnHighContrastChanged | ( | _In_ Windows::UI::ViewManagement::AccessibilitySettings^ | sender,
 |  | _In_ Platform::Object^ | e |
 | ) |  |  | [private]
void sealed::OnHolding | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::HoldingEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnHolding | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::HoldingEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnKeyDown | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | e |
 | ) |  |  | [private]
void sealed::OnLoad ( ) [protected]
void sealed::OnLogicalDpiChanged ( _In_ Platform::Object^ sender )
void sealed::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [protected]
void sealed::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void sealed::OnManipulationCompleted | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationCompletedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnManipulationCompleted | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationCompletedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnManipulationInertiaStarting | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationInertiaStartingEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnManipulationInertiaStarting | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationInertiaStartingEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnManipulationStarted | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationStartedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnManipulationStarted | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationStartedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnManipulationUpdated | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnManipulationUpdated | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnPasteFromClipboard ( ) [protected]
void sealed::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args
 | ) |  |
void sealed::OnPointerMoved | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void sealed::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args
 | ) |  |
void sealed::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void sealed::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args |
 | ) |  |  | [protected]
void sealed::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | e |
 | ) |  |  | [private]
void sealed::OnPointerReleased | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args
 | ) |  |
void sealed::OnRecognize ( ) [protected]
void sealed::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args
 | ) |  |
void sealed::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void sealed::OnRightTapped | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::RightTappedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnRightTapped | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::RightTappedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnSave ( ) [protected]
void sealed::OnSelectAll ( ) [protected]
void sealed::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args
 | ) |  |
void sealed::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnTapped | ( | _In_ Windows::UI::Input::GestureRecognizer^ | sender,
 |  | _In_ Windows::UI::Input::TappedEventArgs^ | args |
 | ) |  |  | [private]
void sealed::OnWindowActivated | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowActivatedEventArgs^ | e |
 | ) |  |  | [private]
void sealed::OnWindowClosed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::CoreWindowEventArgs^ | e |
 | ) |  |  | [private]
void sealed::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args
 | ) |  |
void sealed::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [protected]
void sealed::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
static bool sealed::PointInRect | ( | _In_ Windows::Foundation::Rect | rect,
 |  | _In_ Windows::Foundation::Point | pt |
 | ) |  |  | [static, private]
virtual void sealed::Present ( ) [override, virtual]
sealed::ReencodeState ( ) [inline]

Definition at line 43 of file AdvancedCapture.xaml.cpp.

    {
    }

virtual void sealed::Render ( ) [override, virtual]
virtual void sealed::Render ( ) [override, virtual]
virtual void sealed::Render ( ) [override, virtual]
virtual void sealed::Run ( ) [virtual]
virtual void sealed::Run ( ) [virtual]
virtual void sealed::Run ( ) [virtual]
virtual void sealed::Run ( ) [virtual]
virtual void sealed::Serialize ( _In_ Windows::Foundation::Collections::IPropertySet^ properties ) [override, virtual]

Reimplemented from ManipulatableObject.

void sealed::SetDevice ( _In_opt_ Windows::Devices::Input::IPointerDevice^ pointerDevice )
void sealed::SetValue ( _In_ UiaCoreWindowProvider::TriColorValue newValue ) [private]
virtual void sealed::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void sealed::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void sealed::SetWindow ( _In_ Windows::UI::Core::CoreWindow^ window ) [virtual]
virtual void sealed::SetWindow ( Windows::UI::Core::CoreWindow^ window ) [virtual]
sealed::ShapesPuzzle ( )
sealed::simpleInk ( )
virtual Windows::Foundation::Rect sealed::TransformBounds ( _In_ Windows::Foundation::Rect rect ) [virtual]
virtual bool sealed::TryTransform | ( | _In_ Windows::Foundation::Point | inPoint,
 |  | _Out_ Windows::Foundation::Point * | outPoint |
 | ) |  |  | [virtual]
virtual void sealed::Uninitialize ( ) [virtual]
virtual void sealed::Uninitialize ( ) [virtual]
virtual void sealed::Uninitialize ( ) [virtual]
virtual void sealed::Uninitialize ( ) [virtual]
virtual UiaCoreWindowProvider::TriColorValue sealed::ValueFromPoint ( _In_ Windows::Foundation::Point pt ) [virtual]
HRESULT sealed::ValueFromPoint | ( | _In_ Windows::Foundation::Point | pt,
 |  | _Out_ UiaCoreWindowProvider::TriColorValue * | value |
 | ) |  |  | [private]

Member Data Documentation

internal sealed::__pad0__ [private]

Reimplemented from ManipulatableObject.

Definition at line 67 of file suspensionmanager.cpp.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::_backgroundBrush [private]

Definition at line 96 of file simpleInk.h.

Windows::UI::Color sealed::_backgroundColor [private]

Definition at line 103 of file simpleInk.h.

Color sealed::_color [private]

Definition at line 89 of file DrawingObject.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> sealed::_currentBuffer [private]

Definition at line 93 of file simpleInk.h.

Windows::Foundation::Point sealed::_descPosition [private]

Definition at line 96 of file DrawingObject.h.

WCHAR sealed::_descText[128] [private]

Definition at line 95 of file DrawingObject.h.

WCHAR sealed::_deviceDesc[1024] [private]

Definition at line 71 of file BackgroundObject.h.

Windows::UI::Input::Inking::InkDrawingAttributes sealed::_drawingAttributes [private]

Definition at line 110 of file simpleInk.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> sealed::_eventTextFormat [private]

Definition at line 95 of file simpleInk.h.

WeakReference sealed::_frameReference [private]

Definition at line 64 of file suspensionmanager.cpp.

Color sealed::_initColor [private]

Definition at line 90 of file DrawingObject.h.

float sealed::_initDX [private]

Definition at line 93 of file DrawingObject.h.

float sealed::_initDY [private]

Definition at line 94 of file DrawingObject.h.

float sealed::_initX [private]

Definition at line 91 of file DrawingObject.h.

float sealed::_initY [private]

Definition at line 92 of file DrawingObject.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::_inkBrush [private]

Definition at line 98 of file simpleInk.h.

Microsoft::WRL::ComPtr<ID2D1StrokeStyle> sealed::_inkStyle [private]

Definition at line 100 of file simpleInk.h.

Windows::UI::Input::Inking::InkManipulationMode sealed::_manipulationMode [private]

Definition at line 122 of file simpleInk.h.

Windows::Foundation::Collections::IVector<Windows::Foundation::Point> sealed::_manipulationPoints [private]

Definition at line 121 of file simpleInk.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::_messageBrush [private]

Definition at line 97 of file simpleInk.h.

Windows::Devices::Input::IPointerDevice sealed::_pointerDevice [private]

Definition at line 70 of file BackgroundObject.h.

int sealed::_pointerId [private]

Definition at line 119 of file simpleInk.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> sealed::_previousBuffer [private]

Definition at line 94 of file simpleInk.h.

Platform::String sealed::_recognitionText [private]

Definition at line 113 of file simpleInk.h.

Windows::UI::Input::Inking::InkRecognizer sealed::_recognizer [private]

Definition at line 109 of file simpleInk.h.

Windows::UI::Input::Inking::InkRecognizerContainer sealed::_recognizerContainer [private]

Definition at line 108 of file simpleInk.h.

unsigned int sealed::_recognizerId [private]

Definition at line 112 of file simpleInk.h.

IRenderer sealed::_renderer [private]

Definition at line 67 of file BackgroundObject.h.

RenderingMode sealed::_renderingMode [private]

Definition at line 124 of file simpleInk.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::_selectionBrush [private]

Definition at line 99 of file simpleInk.h.

Microsoft::WRL::ComPtr<ID2D1StrokeStyle> sealed::_selectionStyle [private]

Definition at line 101 of file simpleInk.h.

Platform::String sealed::_statusMessage [private]

Definition at line 114 of file simpleInk.h.

Windows::UI::Input::Inking::InkStrokeBuilder sealed::_strokeBuilder [private]

Definition at line 106 of file simpleInk.h.

Windows::UI::Input::Inking::InkStrokeContainer sealed::_strokeContainer [private]

Definition at line 107 of file simpleInk.h.

Windows::Foundation::EventRegistrationToken sealed::_tokenHolding [private]

Definition at line 75 of file BackgroundObject.h.

Windows::Foundation::EventRegistrationToken sealed::_tokenManipulationCompleted [private]

Definition at line 79 of file BackgroundObject.h.

Windows::Foundation::EventRegistrationToken sealed::_tokenManipulationInertiaStarting [private]

Definition at line 78 of file BackgroundObject.h.

Windows::Foundation::EventRegistrationToken sealed::_tokenManipulationStarted [private]

Definition at line 76 of file BackgroundObject.h.

Windows::Foundation::EventRegistrationToken sealed::_tokenManipulationUpdated [private]

Definition at line 77 of file BackgroundObject.h.

Windows::Foundation::EventRegistrationToken sealed::_tokenRightTapped [private]

Definition at line 74 of file BackgroundObject.h.

Windows::Foundation::EventRegistrationToken sealed::_tokenTapped [private]

Definition at line 99 of file DrawingObject.h.

internal sealed::Blue

Definition at line 32 of file DrawingObject.h.

Windows::Graphics::Imaging::BitmapDecoder sealed::Decoder

Definition at line 63 of file AdvancedCapture.xaml.cpp.

Windows::Graphics::Imaging::BitmapEncoder sealed::Encoder

Definition at line 64 of file AdvancedCapture.xaml.cpp.

internal _Outptr_ ID2D1PathGeometry** sealed::geometry [protected]

Definition at line 88 of file simpleInk.h.

internal sealed::Green = First

Definition at line 32 of file DrawingObject.h.

Windows::UI::ViewManagement::AccessibilitySettings sealed::m_accSettings [private]

Definition at line 143 of file TriColorWindow.h.

bool sealed::m_activated [private]

Definition at line 163 of file TriColorWindow.h.

ActivationEntryPoint sealed::m_activationEntryPoint [private]

Definition at line 24 of file frameworkview.h.

Platform::Agile<Windows::ApplicationModel::Core::CoreApplicationView> sealed::m_applicationView [private]

Definition at line 26 of file frameworkview.h.

Platform::Object sealed::m_appWindowProvider [private]

Definition at line 146 of file TriColorWindow.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::m_blackBrush [private]

Definition at line 153 of file TriColorWindow.h.

Platform::Object sealed::m_controlProvider [private]

Definition at line 147 of file TriColorWindow.h.

Windows::Foundation::Rect sealed::m_controlRect [private]

Definition at line 161 of file TriColorWindow.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::m_greenBrush [private]

Definition at line 157 of file TriColorWindow.h.

Platform::Object sealed::m_greenProvider [private]

Definition at line 150 of file TriColorWindow.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> sealed::m_labelFormat [private]

Definition at line 159 of file TriColorWindow.h.

Program sealed::m_program [private]

Definition at line 78 of file ShapesPuzzle.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::m_redBrush [private]

Definition at line 155 of file TriColorWindow.h.

Platform::Object sealed::m_redProvider [private]

Definition at line 148 of file TriColorWindow.h.

SampleOverlay sealed::m_sampleOverlay [private]

Definition at line 76 of file ShapesPuzzle.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> sealed::m_titleFormat [private]

Definition at line 158 of file TriColorWindow.h.

Windows::UI::ViewManagement::UISettings sealed::m_uiSettings [private]

Definition at line 144 of file TriColorWindow.h.

UiaCoreWindowProvider::TriColorValue sealed::m_value [private]

Definition at line 162 of file TriColorWindow.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::m_whiteBrush [private]

Definition at line 154 of file TriColorWindow.h.

Platform::Agile<Windows::UI::Core::CoreWindow> sealed::m_window [private]

Definition at line 25 of file frameworkview.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::m_windowTextBrush [private]

Definition at line 152 of file TriColorWindow.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> sealed::m_yellowBrush [private]

Definition at line 156 of file TriColorWindow.h.

Platform::Object sealed::m_yellowProvider [private]

Definition at line 149 of file TriColorWindow.h.

internal sealed::MaxCount

Definition at line 32 of file DrawingObject.h.

internal sealed::Orange

Definition at line 32 of file DrawingObject.h.

Windows::Storage::Streams::IRandomAccessStream sealed::OutputStream

Definition at line 61 of file AdvancedCapture.xaml.cpp.

Windows::Storage::StorageFile sealed::PhotoStorage

Definition at line 62 of file AdvancedCapture.xaml.cpp.

internal sealed::Purple

Definition at line 32 of file DrawingObject.h.

internal sealed::Red

Definition at line 32 of file DrawingObject.h.

internal sealed::Yellow

Definition at line 32 of file DrawingObject.h.

The documentation for this class was generated from the following files:
  • Accelerometer sensor/C++/common/suspensionmanager.cpp
  • Animation metrics/C++/common/suspensionmanager.cpp
  • App package information/C++/common/suspensionmanager.cpp
  • App settings/C++/common/suspensionmanager.cpp
  • App tiles and badges/C#,C++/common/suspensionmanager.cpp
  • Application data/C++/common/suspensionmanager.cpp
  • AtomPub/C++/common/suspensionmanager.cpp
  • Background task/C++/BackgroundTask/common/suspensionmanager.cpp
  • Background Transfer/C++/common/suspensionmanager.cpp
  • Bluetooth call control/C++/common/suspensionmanager.cpp
  • Calendar details and math/C++/common/suspensionmanager.cpp
  • CameraCaptureUI/C++/common/suspensionmanager.cpp
  • CameraOptionsUI/C++/common/suspensionmanager.cpp
  • Certificate enrollment/C++/common/suspensionmanager.cpp
  • Compass sensor/C++/common/suspensionmanager.cpp
  • Compression/C++/common/suspensionmanager.cpp
  • Configure keys for media/C++/common/suspensionmanager.cpp
  • Connecting with WebSockets/C++/common/suspensionmanager.cpp
  • Context menu/C++/common/suspensionmanager.cpp
  • Credential locker/C++/common/suspensionmanager.cpp
  • CryptoWinRT/C++/common/suspensionmanager.cpp
  • Custom driver access/C++/app_cpp/common/suspensionmanager.cpp
  • Date and time formatting/C++/common/suspensionmanager.cpp
  • Device enumeration/C++/common/suspensionmanager.cpp
  • Display orientation/C++/common/suspensionmanager.cpp
  • EAS policies for mail clients/C++/common/suspensionmanager.cpp
  • File access/C++/common/suspensionmanager.cpp
  • File and folder thumbnail/C++/common/suspensionmanager.cpp
  • File picker/C++/common/suspensionmanager.cpp
  • File picker contracts/C++/common/suspensionmanager.cpp
  • Folder enumeration/C++/common/suspensionmanager.cpp
  • Geolocation/C++/common/SuspensionManager.cpp
  • Globalization preferences/C++/common/suspensionmanager.cpp
  • Gyrometer sensor/C++/common/suspensionmanager.cpp
  • Hilo C++/C++/Hilo/Common/SuspensionManager.cpp
  • HomeGroup app/C++/common/suspensionmanager.cpp
  • HttpClient/C++/common/suspensionmanager.cpp
  • Inclinometer sensor/C++/common/suspensionmanager.cpp
  • Input Device capabilities/C++/common/suspensionmanager.cpp
  • Input Manipulations and gestures (C++)/C++/BackgroundObject.h
  • Input Manipulations and gestures (C++)/C++/DrawingObject.h
  • Input Simplified ink/C++/simpleInk.h
  • Input Touch hit testing/C++/ShapesPuzzle.h
  • Input Touch keyboard/C++/common/suspensionmanager.cpp
  • Input Touch keyboard text input/C++/common/suspensionmanager.cpp
  • LightSensor/C++/common/suspensionmanager.cpp
  • Lock screen personalization/C++/common/suspensionmanager.cpp
  • Media capture using capture device/C++/AdvancedCapture.xaml.cpp
  • Media engine native C++ video playback/C++/frameworkview.h
  • Media Play To/C++/common/suspensionmanager.cpp
  • Media Server client/C++/common/suspensionmanager.cpp
  • Message dialog/C++/common/suspensionmanager.cpp
  • Network information/C++/common/suspensionmanager.cpp
  • Number formatting and parsing/C++/common/suspensionmanager.cpp
  • OrientationSensor/C++/common/suspensionmanager.cpp
  • Playback Manager Companion/C++/common/suspensionmanager.cpp
  • Playlist/C++/common/suspensionmanager.cpp
  • PlayToReceiver/C++/common/suspensionmanager.cpp
  • Portable device API/C++/common/SuspensionManager.cpp
  • Programmatic file search/C++/common/suspensionmanager.cpp
  • Reading and writing data/C++/common/suspensionmanager.cpp
  • Removable storage/C++/common/SuspensionManager.cpp
  • Scaling according to DPI/C++/common/suspensionmanager.cpp
  • Search contract/C++/common/suspensionmanager.cpp
  • Sharing content source app/C++/common/suspensionmanager.cpp
  • SimpleOrientationSensor/C++/common/suspensionmanager.cpp
  • Snap/C++/common/suspensionmanager.cpp
  • Splash screen/C++/common/suspensionmanager.cpp
  • Syndication/C++/common/suspensionmanager.cpp
  • Thread pool/C++/common/suspensionmanager.cpp
  • Transcoding media/C++/common/suspensionmanager.cpp
  • Trial app and in-app purchase/C++/common/suspensionmanager.cpp
  • UI Automation core window provider/C++/TriColorWindow.h
  • UI contrast and settings/C++/common/suspensionmanager.cpp
  • User domain name/C++/common/suspensionmanager.cpp
  • USSD message management/C++/common/suspensionmanager.cpp
  • Web authentication broker/C++/common/suspensionmanager.cpp
  • Windows account authorization/C++/common/suspensionmanager.cpp
  • Windows Audio Session (WASAPI)/C++/common/suspensionmanager.cpp
  • XAML accessibility/C++/common/suspensionmanager.cpp
  • XAML animation library/C++/common/suspensionmanager.cpp
  • XAML data binding/C++/Common/suspensionmanager.cpp
  • XAML FlipView control/C++/common/suspensionmanager.cpp
  • XAML high contrast style/C++/common/suspensionmanager.cpp
  • XAML images/C++/common/suspensionmanager.cpp
  • XAML personality animations/C++/common/suspensionmanager.cpp
  • XAML Popup/C++/common/suspensionmanager.cpp
  • XAML text display/C++/Common/suspensionmanager.cpp
  • XAML text editing/C++/Common/suspensionmanager.cpp
  • XAML two-dimensional transforms/C++/common/suspensionmanager.cpp
  • XAML user and custom controls/C++/common/suspensionmanager.cpp
  • XAML vector-based drawing/C++/common/suspensionmanager.cpp
  • XAML WebView control/C++/common/suspensionmanager.cpp
  • Input Manipulations and gestures (C++)/C++/ManipulatableObject.h
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SecondaryTiles::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SecondaryTiles
  • Common
  • SecondaryTiles::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

SecondaryTiles::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 26 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String SecondaryTiles::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void SecondaryTiles::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 186 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void SecondaryTiles::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SecondaryTiles::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 127 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal SecondaryTiles::Common::LayoutAwarePage::__pad0__

Definition at line 29 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> SecondaryTiles::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 51 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> SecondaryTiles::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 53 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken SecondaryTiles::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 52 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Secondary tiles/C#,C++/common/LayoutAwarePage.h
  • Secondary tiles/C#,C++/common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SecondaryTiles::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SecondaryTiles
  • SecondaryTiles::MainPage
Static Private Attributes

SecondaryTiles::MainPage Class Reference

#include "Constants.h"

List of all members.

Static Private Attributes

static Platform::Array< Scenario > scenariosInner

Detailed Description

Definition at line 23 of file Constants.h.

Member Data Documentation

Platform::Array< Scenario > MainPage::scenariosInner [static, private]
Initial value:
 ref new Platform::Array<Scenario>
{
    { "Pin Tile",                           "SecondaryTiles.PinTile" },
    { "Unpin Tile",                         "SecondaryTiles.UnpinTile" },
    { "Enumerate Tiles",                    "SecondaryTiles.EnumerateTiles" },
    { "Is Tile Pinned?",                    "SecondaryTiles.TilePinned" },
    { "Show Activation Arguments",          "SecondaryTiles.LaunchedFromSecondaryTile" },
    { "Secondary Tile Notifications",       "SecondaryTiles.SecondaryTileNotification" },
    { "Pin/Unpin Through Appbar",           "SecondaryTiles.PinFromAppbar" },
    { "Update Secondary Tile Default Logo", "SecondaryTiles.UpdateAsync" }
}

Definition at line 66 of file Constants.h.

The documentation for this class was generated from the following files:
  • Secondary tiles/C#,C++/Constants.h
  • Secondary tiles/C#,C++/Constants.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SecondaryTiles::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SecondaryTiles
  • SecondaryTiles::Scenario
Public Attributes

SecondaryTiles::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | className
Platform::String | title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String SecondaryTiles::Scenario::className

Definition at line 20 of file Constants.h.

Platform::String SecondaryTiles::Scenario::title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • Secondary tiles/C#,C++/Constants.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SecondaryTiles::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SecondaryTiles
  • SecondaryTiles::sealed
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes

SecondaryTiles::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
EnumerateTiles ()
LaunchedFromSecondaryTile ()
void | LoadScenario (Platform::String^scenarioName)
MainPage ()
void | NavigateToLaunchedFromSecondaryTile ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
PinFromAppbar ()
PinTile ()
SecondaryTileNotification ()
TilePinned ()
UnpinTile ()
UpdateAsync ()

Protected Member Functions

void | MainPage_Loaded (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Protected Attributes

internal | __pad0__: static MainPage^ current

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

~MainPage ()
void | BottomAppBar_Opened (Platform::Object^sender, Platform::Object^e)
void | Button_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | EnumerateSecondaryTiles_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Init ()
void | InvalidateSize ()
void | InvalidateViewState ()
void | PinButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PinLiveTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | PopulateScenarios ()
void | SendBadgeNotification_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendBadgeNotificationWithStringManipulation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendTileNotification_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SendTileNotificationWithStringManipulation_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetSecondaryTiles (Platform::String^strFeature)
void | TileExists_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ToggleAppBarButton (bool showPinButton)
void | ToggleButtons (bool isEnabled)
void | UnpinSecondaryTile_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | UpdateDefaultLogo_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::UI::Xaml::Controls::AppBar | appBar
Windows::Foundation::EventRegistrationToken | appBarOpenedToken
bool | autoSizeInputSectionWhenSnapped
Windows::Foundation::EventRegistrationToken | buttonClickToken
Windows::UI::Xaml::Controls::Frame | hiddenFrame
Windows::UI::Xaml::Controls::Button | pinToAppBar
Windows::UI::Xaml::Controls::StackPanel | rightPanel
Windows::UI::Xaml::Controls::Frame | rootFrame
MainPage rootPage
Platform::Collections::Vector
< Object^> 		scenarioList

Detailed Description

Definition at line 24 of file App.xaml.h.

Constructor & Destructor Documentation

SecondaryTiles::sealed::~MainPage ( ) [private]

Member Function Documentation

SecondaryTiles::sealed::App ( )
void SecondaryTiles::sealed::BottomAppBar_Opened | ( | Platform::Object^ | sender,
 |  | Platform::Object^ | e |
 | ) |  |  | [private]
void SecondaryTiles::sealed::Button_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SecondaryTiles::sealed::EnumerateSecondaryTiles_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SecondaryTiles::sealed::EnumerateTiles ( )
void SecondaryTiles::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SecondaryTiles::sealed::Init ( ) [private]
void SecondaryTiles::sealed::InvalidateSize ( ) [private]
void SecondaryTiles::sealed::InvalidateViewState ( ) [private]
SecondaryTiles::sealed::LaunchedFromSecondaryTile ( )
void SecondaryTiles::sealed::LoadScenario ( Platform::String^ scenarioName )
SecondaryTiles::sealed::MainPage ( )
void SecondaryTiles::sealed::MainPage_Loaded | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]
void SecondaryTiles::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void SecondaryTiles::sealed::NavigateToLaunchedFromSecondaryTile ( )
void SecondaryTiles::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void SecondaryTiles::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SecondaryTiles::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void SecondaryTiles::sealed::PinButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SecondaryTiles::sealed::PinFromAppbar ( )
void SecondaryTiles::sealed::PinLiveTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SecondaryTiles::sealed::PinTile ( )
void SecondaryTiles::sealed::PopulateScenarios ( ) [private]
void SecondaryTiles::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
SecondaryTiles::sealed::SecondaryTileNotification ( )
void SecondaryTiles::sealed::SendBadgeNotification_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SecondaryTiles::sealed::SendBadgeNotificationWithStringManipulation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SecondaryTiles::sealed::SendTileNotification_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SecondaryTiles::sealed::SendTileNotificationWithStringManipulation_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SecondaryTiles::sealed::SetSecondaryTiles ( Platform::String^ strFeature ) [private]
void SecondaryTiles::sealed::TileExists_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SecondaryTiles::sealed::TilePinned ( )
void SecondaryTiles::sealed::ToggleAppBarButton ( bool showPinButton ) [private]
void SecondaryTiles::sealed::ToggleButtons ( bool isEnabled ) [private]
void SecondaryTiles::sealed::UnpinSecondaryTile_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SecondaryTiles::sealed::UnpinTile ( )
SecondaryTiles::sealed::UpdateAsync ( )
void SecondaryTiles::sealed::UpdateDefaultLogo_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal SecondaryTiles::sealed::__pad0__ [protected]

Definition at line 97 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::AppBar sealed::appBar [private]

Definition at line 39 of file EnumerateTiles.xaml.h.

Windows::Foundation::EventRegistrationToken SecondaryTiles::sealed::appBarOpenedToken [private]

Definition at line 45 of file PinFromAppbar.xaml.h.

bool SecondaryTiles::sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 88 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken SecondaryTiles::sealed::buttonClickToken [private]

Definition at line 46 of file PinFromAppbar.xaml.h.

Windows::UI::Xaml::Controls::Frame SecondaryTiles::sealed::hiddenFrame [private]

Definition at line 86 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Button SecondaryTiles::sealed::pinToAppBar [private]

Definition at line 39 of file PinFromAppbar.xaml.h.

Windows::UI::Xaml::Controls::StackPanel SecondaryTiles::sealed::rightPanel [private]

Definition at line 40 of file PinFromAppbar.xaml.h.

Windows::UI::Xaml::Controls::Frame SecondaryTiles::sealed::rootFrame [private]

Definition at line 32 of file App.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 38 of file EnumerateTiles.xaml.h.

Platform::Collections::Vector<Object^> SecondaryTiles::sealed::scenarioList [private]

Definition at line 85 of file MainPage.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> SecondaryTiles::sealed::MainPageResized

Definition at line 75 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> SecondaryTiles::sealed::ScenarioLoaded

Definition at line 74 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Secondary tiles/C#,C++/App.xaml.h
  • Secondary tiles/C#,C++/EnumerateTiles.xaml.h
  • Secondary tiles/C#,C++/LaunchedFromSecondaryTile.xaml.h
  • Secondary tiles/C#,C++/MainPage.xaml.h
  • Secondary tiles/C#,C++/PinFromAppbar.xaml.h
  • Secondary tiles/C#,C++/PinTile.xaml.h
  • Secondary tiles/C#,C++/SecondaryTileNotification.xaml.h
  • Secondary tiles/C#,C++/TilePinned.xaml.h
  • Secondary tiles/C#,C++/UnpinTile.xaml.h
  • Secondary tiles/C#,C++/UpdateAsync.xaml.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SetRateOp Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

SetRateOp Class Reference

#include "MPEG1Src.h"

Inherits SourceOp, and SourceOp.

List of all members.

Public Member Functions

SetRateOp (BOOL fThin, float flRate)
SetRateOp (BOOL fThin, float flRate)
~SetRateOp ()
~SetRateOp ()
float | GetRate () const
float | GetRate () const
BOOL | IsThin () const
BOOL | IsThin () const

Private Attributes

float | m_flRate
BOOL | m_fThin

Detailed Description

Definition at line 230 of file MPEG1Src.h.

Constructor & Destructor Documentation

SetRateOp::SetRateOp | ( | BOOL | fThin,
 |  | float | flRate
 | ) |  |

Definition at line 2368 of file MPEG1Src.cpp.

: SourceOp(SourceOp::OP_SETRATE)
, m_fThin(fThin)
, m_flRate(flRate)
{
}

SetRateOp::~SetRateOp ( )

Definition at line 2375 of file MPEG1Src.cpp.

{
}

SetRateOp::SetRateOp | ( | BOOL | fThin,
 |  | float | flRate
 | ) |  |
SetRateOp::~SetRateOp ( )

Member Function Documentation

float SetRateOp::GetRate ( ) const [inline]

Definition at line 237 of file MPEG1Src.h.

{return m_flRate;}

float SetRateOp::GetRate ( ) const [inline]

Definition at line 237 of file MPEG1Src.h.

{return m_flRate;}

BOOL SetRateOp::IsThin ( ) const [inline]

Definition at line 236 of file MPEG1Src.h.

{return m_fThin;}

BOOL SetRateOp::IsThin ( ) const [inline]

Definition at line 236 of file MPEG1Src.h.

{return m_fThin;}

Member Data Documentation

float SetRateOp::m_flRate [private]

Definition at line 241 of file MPEG1Src.h.

BOOL SetRateOp::m_fThin [private]

Definition at line 240 of file MPEG1Src.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Shape Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Member Functions | Private Attributes

Shape Class Reference

#include "Shape.h"

List of all members.

Public Member Functions

Shape ()
~Shape ()
Polygon * GetPolygon ()
void | InitializeObject (_In_reads_(numPoints) Windows::Foundation::Point const *points, _In_ int numPoints, _In_ D2D1::ColorF color)
bool | InRegion (Windows::Foundation::Point pt)
void | OnPointerEvent (_In_ Windows::Foundation::Point pt, bool shouldMove)
void | Paint (_In_ ID2D1DeviceContext *d2dDeviceContext)
void | ResetState (_In_ float startX, _In_ float startY, _In_ float width, _In_ float height, _In_ float scale)

Private Member Functions

void | EnsureVisible ()
void | Translate (_In_ float fdx, _In_ float fdy)
D2D1_POINT_2F | UnscaledToClient (_In_ Windows::Foundation::Point ptUnscaled)
void | UnscaledToClient (_In_ Windows::Foundation::Rect rcUnscaled, _Inout_ Windows::Foundation::Rect *prcClient)
void | UnscaledToClient (_In_ Windows::Foundation::Point ptUnscaled, _Inout_ Windows::Foundation::Point *pptClient)
D2D1_RECT_F | UnscaledToClient (_In_ Windows::Foundation::Rect rcUnscaled)

Private Attributes

D2D1::ColorF | m_color
float | m_height
Microsoft::WRL::ComPtr
< ID2D1PathGeometry > 		m_pathGeometry
Polygon m_polygonAbsolute
Polygon m_polygonRelative
Windows::Foundation::Point | m_ptPointerPosition
float | m_scale
float | m_topLeftX
float | m_topLeftY
float | m_width

Detailed Description

Definition at line 33 of file Shape.h.

Constructor & Destructor Documentation

Shape::Shape ( )

Definition at line 14 of file Shape.cpp.

             :
    m_color(D2D1::ColorF::Blue)
{
}

Shape::~Shape ( )

Definition at line 20 of file Shape.cpp.

{
}

Member Function Documentation

void Shape::EnsureVisible ( ) [private]

Definition at line 174 of file Shape.cpp.

{
    // Initialize width height of object
    float width  = m_polygonRelative.rcBound.Width  * m_scale;
    float height = m_polygonRelative.rcBound.Height * m_scale;

    float x = m_topLeftX + (m_polygonRelative.rcBound.Left * m_scale);
    x = max(0, min(x, m_width - width));
    m_topLeftX = x - (m_polygonRelative.rcBound.Left * m_scale);

    float y = m_topLeftY + (m_polygonRelative.rcBound.Top * m_scale);
    y = max(0, min(y, m_height - height));
    m_topLeftY = y - (m_polygonRelative.rcBound.Top * m_scale);
}

Polygon * Shape::GetPolygon ( )

Definition at line 168 of file Shape.cpp.

{
    return &m_polygonAbsolute;
}

void Shape::InitializeObject | ( | _In_reads_(numPoints) Windows::Foundation::Point const * | points,
 |  | _In_ int | numPoints,
 |  | _In_ D2D1::ColorF | color
 | ) |  |

Definition at line 25 of file Shape.cpp.

{
    m_polygonRelative.numPoints = numPoints;
    m_color = color;

    if (numPoints == 2)
    {
        m_polygonRelative.isRect = true;
        m_polygonRelative.rcBound.X = points[0].X;
        m_polygonRelative.rcBound.Y = points[0].Y;
        m_polygonRelative.rcBound.Width = points[1].X - points[0].X;
        m_polygonRelative.rcBound.Height = points[1].Y - points[0].Y;

        // Initialize points
        m_polygonRelative.points[0] = points[0];
        m_polygonRelative.points[1].X = points[1].X;
        m_polygonRelative.points[1].Y = points[0].Y;
        m_polygonRelative.points[2] = points[1];
        m_polygonRelative.points[3].X = points[0].X;
        m_polygonRelative.points[3].Y = points[1].Y;
        m_polygonRelative.points[4] = points[0];
        m_polygonRelative.numPoints = 5;
    }
    else
    {
        m_polygonRelative.isRect = false;

        // calculate width and height
        if (numPoints > 0)
        {
            m_polygonRelative.points[0] = points[0];

            // Copy polygon points to m_polygonRelative object and calculate polygon bounding box
            float left, right, top, bottom;
            left = right = points[0].X;
            top = bottom = points[0].Y;
            for (int i = 1; i < numPoints; i++)
            {
                m_polygonRelative.points[i] = points[i];
                left = min(left, points[i].X);
                top = min(top, points[i].Y);
                right = max(right, points[i].X);
                bottom = max(bottom, points[i].Y);
            }
            m_polygonRelative.rcBound.X = left;
            m_polygonRelative.rcBound.Y = top;
            m_polygonRelative.rcBound.Width = right - left;
            m_polygonRelative.rcBound.Height = bottom - top;
        }
    }
    m_polygonAbsolute = m_polygonRelative;
}

bool Shape::InRegion ( Windows::Foundation::Point pt )

Definition at line 137 of file Shape.cpp.

{
    BOOL b = FALSE;
    // The adjusted point returned from TouchHitTesting isn't quite equal to
    // the point passed to the corresponding PointerPressed, due to conversion
    // between DIPs and screen pixels. To compensate for this difference, it's
    // necessary to increase the tolerance passed to FillContainsPoint(). 1.5F
    // works for this sample, but some testing is needed to determine the best
    // value for other scenarios.
    m_pathGeometry->FillContainsPoint(
        D2D1::Point2F(pt.X, pt.Y),
        D2D1::Matrix3x2F::Identity(),
        1.5F,
        &b
    );

    return !!b;
}

void Shape::OnPointerEvent | ( | _In_ Windows::Foundation::Point | pt,
 |  | bool | shouldMove
 | ) |  |

Definition at line 157 of file Shape.cpp.

{
    if (shouldMove)
    {
        Translate(pt.X - m_ptPointerPosition.X, pt.Y - m_ptPointerPosition.Y);
    }

    m_ptPointerPosition = pt;
}

void Shape::Paint ( _In_ ID2D1DeviceContext * d2dDeviceContext )

Definition at line 98 of file Shape.cpp.

{
    Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> brush;
    Microsoft::WRL::ComPtr<ID2D1Factory> d2dFactory;
    DX::ThrowIfFailed(d2dDeviceContext->CreateSolidColorBrush(D2D1::ColorF(m_color), brush.GetAddressOf()));
    d2dDeviceContext->GetFactory(d2dFactory.GetAddressOf());

    // Create path to draw
    m_pathGeometry = nullptr;
    DX::ThrowIfFailed(d2dFactory->CreatePathGeometry(&m_pathGeometry));

    Microsoft::WRL::ComPtr<ID2D1GeometrySink> sink;
    DX::ThrowIfFailed(m_pathGeometry->Open(&sink));

    sink->BeginFigure(
        UnscaledToClient(m_polygonRelative.points[0]),
        D2D1_FIGURE_BEGIN_FILLED);

    // Draw polygon
    for (int i = 1; i < m_polygonRelative.numPoints; i++)
    {
        sink->AddLine(UnscaledToClient(m_polygonRelative.points[i]));
    }

    sink->EndFigure(D2D1_FIGURE_END_CLOSED);
    sink->Close();

    // Fill the geometry that was created
    d2dDeviceContext->FillGeometry(m_pathGeometry.Get(), brush.Get());

    // Create absolute polygon
    for (int i = 0; i < m_polygonRelative.numPoints; i++)
    {
        UnscaledToClient(m_polygonRelative.points[i], &m_polygonAbsolute.points[i]);
    }
    UnscaledToClient(m_polygonRelative.rcBound, &m_polygonAbsolute.rcBound);
}

void Shape::ResetState | ( | _In_ float | startX,
 |  | _In_ float | startY,
 |  | _In_ float | width,
 |  | _In_ float | height,
 |  | _In_ float | scale
 | ) |  |

Definition at line 80 of file Shape.cpp.

{
    // Set width and height of the client area
    // must adjust for dpi aware
    m_width = width;
    m_height = height;

    // Set coordinates used for rendering
    m_topLeftX = startX;
    m_topLeftY = startY;

    // scaling factor
    m_scale = scale;
}

void Shape::Translate | ( | _In_ float | fdx,
 |  | _In_ float | fdy |
 | ) |  |  | [private]

Definition at line 190 of file Shape.cpp.

{
    m_topLeftX += dx;
    m_topLeftY += dy;

    // Make sure object stays on screen
    EnsureVisible();
}

void Shape::UnscaledToClient | ( | _In_ Windows::Foundation::Rect | rcUnscaled,
 |  | _Inout_ Windows::Foundation::Rect * | prcClient |
 | ) |  |  | [private]

Definition at line 207 of file Shape.cpp.

{
    prcClient->X = m_topLeftX + (rcUnscaled.X * m_scale);
    prcClient->Y = m_topLeftY + (rcUnscaled.Y * m_scale);
    prcClient->Width  = rcUnscaled.Width      * m_scale;
    prcClient->Height = rcUnscaled.Height     * m_scale;
}

D2D1_RECT_F Shape::UnscaledToClient ( _In_ Windows::Foundation::Rect rcUnscaled ) [private]

Definition at line 222 of file Shape.cpp.

{
    return D2D1::RectF(
        m_topLeftX + rcUnscaled.Left   * m_scale,
        m_topLeftY + rcUnscaled.Top    * m_scale,
        m_topLeftX + rcUnscaled.Right  * m_scale,
        m_topLeftY + rcUnscaled.Bottom * m_scale
    );
}

void Shape::UnscaledToClient | ( | _In_ Windows::Foundation::Point | ptUnscaled,
 |  | _Inout_ Windows::Foundation::Point * | pptClient |
 | ) |  |  | [private]

Definition at line 200 of file Shape.cpp.

{
    pptClient->X = m_topLeftX + (ptUnscaled.X * m_scale);
    pptClient->Y = m_topLeftY + (ptUnscaled.Y * m_scale);
}

D2D1_POINT_2F Shape::UnscaledToClient ( _In_ Windows::Foundation::Point ptUnscaled ) [private]

Definition at line 216 of file Shape.cpp.

{
    return D2D1::Point2F(m_topLeftX + ptUnscaled.X * m_scale, m_topLeftY + ptUnscaled.Y * m_scale);
}

Member Data Documentation

D2D1::ColorF Shape::m_color [private]

Definition at line 81 of file Shape.h.

float Shape::m_height [private]

Definition at line 70 of file Shape.h.

Microsoft::WRL::ComPtr<ID2D1PathGeometry> Shape::m_pathGeometry [private]

Definition at line 62 of file Shape.h.

Polygon Shape::m_polygonAbsolute [private]

Definition at line 78 of file Shape.h.

Polygon Shape::m_polygonRelative [private]

Definition at line 76 of file Shape.h.

Windows::Foundation::Point Shape::m_ptPointerPosition [private]

Definition at line 84 of file Shape.h.

float Shape::m_scale [private]

Definition at line 73 of file Shape.h.

float Shape::m_topLeftX [private]

Definition at line 65 of file Shape.h.

float Shape::m_topLeftY [private]

Definition at line 66 of file Shape.h.

float Shape::m_width [private]

Definition at line 69 of file Shape.h.

The documentation for this class was generated from the following files:
  • Input Touch hit testing/C++/Shape.h
  • Input Touch hit testing/C++/Shape.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ShapeRecord Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ShapeRecord Struct Reference

#include "Program.h"

List of all members.

Public Attributes

int | cursorId
std::shared_ptr< ShapeRecord > | next
std::shared_ptr< Shape > | shape

Detailed Description

Definition at line 15 of file Program.h.

Member Data Documentation

int ShapeRecord::cursorId

Definition at line 18 of file Program.h.

std::shared_ptr<ShapeRecord> ShapeRecord::next

Definition at line 19 of file Program.h.

std::shared_ptr<Shape> ShapeRecord::shape

Definition at line 17 of file Program.h.

The documentation for this struct was generated from the following file:
  • Input Touch hit testing/C++/Program.h
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ShareTarget::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ShareTarget
  • Common
  • ShareTarget::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

ShareTarget::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
bool | _useFilledStateForNarrowWindow
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 26 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String ShareTarget::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void ShareTarget::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 212 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void ShareTarget::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void ShareTarget::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 143 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal ShareTarget::Common::LayoutAwarePage::__pad0__

Definition at line 29 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> ShareTarget::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 52 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> ShareTarget::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 54 of file LayoutAwarePage.h.

bool ShareTarget::Common::LayoutAwarePage::_useFilledStateForNarrowWindow [private]

Definition at line 51 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken ShareTarget::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 53 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Sharing content target app/C++/common/LayoutAwarePage.h
  • Sharing content target app/C++/common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ShareTarget::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ShareTarget
  • ShareTarget::sealed
Public Member Functions | Private Member Functions | Private Attributes

ShareTarget::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
DefaultPage ()
MainPage ()
void | NotifyUser (Platform::String^strmessage, NotifyType type)
void | NotifyUserBackgroundThread (Platform::String^message, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnShareTargetActivated (Windows::ApplicationModel::Activation::ShareTargetActivatedEventArgs^args) override

Private Member Functions

~MainPage ()
void | AddContentValue (Platform::String^title, Platform::String^description)
void | AddContentValue (Platform::String^title)
void | AddQuickLink_Checked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | AddQuickLink_Unchecked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ExpandLongRunningShareSection_Checked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ExpandLongRunningShareSection_Unchecked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LongRunningShareLabel_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | QuickLinkSectionLabel_Tapped (Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e)
void | ReportCompleted_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ReportDataRetrieved_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ReportErrorButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ReportStarted_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ReportSubmittedBackgroundTask_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

Windows::Storage::Streams::IRandomAccessStreamReference | sharedBitmapStreamRef
Platform::String | sharedCustomData
Platform::String | sharedDataDescription
Platform::String | sharedDataTitle
Platform::String | sharedHtmlFormat
Windows::Foundation::Collections::IMapView
< Platform::String^,
Windows::Storage::Streams::RandomAccessStreamReference^> 		sharedResourceMap
Windows::Foundation::Collections::IVectorView
< Windows::Storage::IStorageItem^> 		sharedStorageItems
Platform::String | sharedText
Windows::Storage::Streams::IRandomAccessStreamReference | sharedThumbnailStreamRef
Windows::Foundation::Uri | sharedUri
Platform::Agile
< Windows::ApplicationModel::DataTransfer::ShareTarget::ShareOperation > 		shareOperation
Platform::String | shareQuickLinkId

Detailed Description

Definition at line 20 of file App.xaml.h.

Constructor & Destructor Documentation

ShareTarget::sealed::~MainPage ( ) [private]

Member Function Documentation

void ShareTarget::sealed::AddContentValue ( Platform::String^ title ) [private]
void ShareTarget::sealed::AddContentValue | ( | Platform::String^ | title,
 |  | Platform::String^ | description |
 | ) |  |  | [private]
void ShareTarget::sealed::AddQuickLink_Checked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::AddQuickLink_Unchecked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
ShareTarget::sealed::App ( )
ShareTarget::sealed::DefaultPage ( )
void ShareTarget::sealed::ExpandLongRunningShareSection_Checked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::ExpandLongRunningShareSection_Unchecked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::Footer_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::Footer_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::LongRunningShareLabel_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
ShareTarget::sealed::MainPage ( )
void ShareTarget::sealed::NotifyUser | ( | Platform::String^ | strmessage,
 |  | NotifyType | type
 | ) |  |
void ShareTarget::sealed::NotifyUserBackgroundThread | ( | Platform::String^ | message,
 |  | NotifyType | type
 | ) |  |
virtual void ShareTarget::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void ShareTarget::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, virtual]
virtual void ShareTarget::sealed::OnShareTargetActivated ( Windows::ApplicationModel::Activation::ShareTargetActivatedEventArgs^ args ) [override, virtual]
void ShareTarget::sealed::QuickLinkSectionLabel_Tapped | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::ReportCompleted_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::ReportDataRetrieved_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::ReportErrorButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::ReportStarted_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ShareTarget::sealed::ReportSubmittedBackgroundTask_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Storage::Streams::IRandomAccessStreamReference ShareTarget::sealed::sharedBitmapStreamRef [private]

Definition at line 52 of file MainPage.xaml.h.

Platform::String ShareTarget::sealed::sharedCustomData [private]

Definition at line 49 of file MainPage.xaml.h.

Platform::String ShareTarget::sealed::sharedDataDescription [private]

Definition at line 44 of file MainPage.xaml.h.

Platform::String ShareTarget::sealed::sharedDataTitle [private]

Definition at line 43 of file MainPage.xaml.h.

Platform::String ShareTarget::sealed::sharedHtmlFormat [private]

Definition at line 50 of file MainPage.xaml.h.

Windows::Foundation::Collections::IMapView<Platform::String^, Windows::Storage::Streams::RandomAccessStreamReference^> ShareTarget::sealed::sharedResourceMap [private]

Definition at line 51 of file MainPage.xaml.h.

Windows::Foundation::Collections::IVectorView<Windows::Storage::IStorageItem^> ShareTarget::sealed::sharedStorageItems [private]

Definition at line 48 of file MainPage.xaml.h.

Platform::String ShareTarget::sealed::sharedText [private]

Definition at line 46 of file MainPage.xaml.h.

Windows::Storage::Streams::IRandomAccessStreamReference ShareTarget::sealed::sharedThumbnailStreamRef [private]

Definition at line 53 of file MainPage.xaml.h.

Windows::Foundation::Uri ShareTarget::sealed::sharedUri [private]

Definition at line 47 of file MainPage.xaml.h.

Platform::Agile<Windows::ApplicationModel::DataTransfer::ShareTarget::ShareOperation> ShareTarget::sealed::shareOperation [private]

Definition at line 42 of file MainPage.xaml.h.

Platform::String ShareTarget::sealed::shareQuickLinkId [private]

Definition at line 45 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Sharing content target app/C++/App.xaml.h
  • Sharing content target app/C++/MainPage.xaml.h
  • Sharing content target app/C++/DefaultPage.xaml.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Simple3DGame Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Simple3DGame Class Reference

#include "Simple3DGame.h"

List of all members.

Public Member Functions

float | BonusTime ()
float | BonusTime ()
void | ContinueGame ()
void | ContinueGame ()
Level | CurrentLevel ()
Level | CurrentLevel ()
void | CycleBackground ()
void | FinalizeLoadLevel ()
void | FinalizeLoadLevel ()
bool | GameActive ()
bool | GameActive ()
Camera GameCamera ()
Camera GameCamera ()
HighScoreEntry HighScore ()
HighScoreEntry HighScore ()
void | Initialize (_In_ MoveLookController^controller, _In_ GameRenderer^renderer)
void | Initialize (_In_ MoveLookController^controller, _In_ GameRenderer^renderer)
bool | IsActivePlay ()
bool | IsActivePlay ()
bool | IsTrial ()
bool | LevelActive ()
bool | LevelActive ()
int | LevelCompleted ()
int | LevelCompleted ()
void | LoadGame ()
void | LoadGame ()
concurrency::task< void > | LoadLevelAsync ()
concurrency::task< void > | LoadLevelAsync ()
void | OnResuming ()
void | OnResuming ()
void | OnSuspending ()
void | OnSuspending ()
void | PauseGame ()
void | PauseGame ()
std::vector< GameObject^> | RenderObjects ()
std::vector< GameObject^> | RenderObjects ()
GameState RunGame ()
GameState RunGame ()
void | SetBackground (uint32 background)
void | SetCurrentLevelToSavedState ()
void | SetCurrentLevelToSavedState ()
void | StartLevel ()
void | StartLevel ()
float | TimeRemaining ()
float | TimeRemaining ()
int | TotalHits ()
int | TotalHits ()
int | TotalShots ()
int | TotalShots ()
void | UpdateGameConfig (Windows::ApplicationModel::Store::LicenseInformation^licenseInformation)

Public Attributes

internal | __pad0__: Simple3DGame()

Private Member Functions

void | InitializeAmmo ()
void | InitializeAmmo ()
void | InitializeGameConfig ()
void | LoadHighScore ()
void | LoadHighScore ()
void | LoadState ()
void | LoadState ()
void | SaveHighScore ()
void | SaveHighScore ()
void | SaveState ()
void | SaveState ()
void | UpdateDynamics ()
void | UpdateDynamics ()

Private Attributes

uint32 | m_activeBackground
std::vector< Sphere^> | m_ammo
uint32 | m_ammoCount
uint32 | m_ammoNext
Audio m_audioController
Camera m_camera
MoveLookController m_controller
uint32 | m_currentLevel
bool | m_gameActive
GameConfig m_gameConfig
std::vector< Level^> | m_level
bool | m_levelActive
float | m_levelBonusTime
uint32 | m_levelCount
float | m_levelDuration
float | m_levelTimeRemaining
DirectX::XMFLOAT3 | m_maxBound
DirectX::XMFLOAT3 | m_minBound
std::vector< GameObject^> | m_objects
Sphere m_player
GameRenderer m_renderer
std::vector< GameObject^> | m_renderObjects
PersistentState m_savedState
GameTimer m_timer
HighScoreEntry m_topScore
int | m_totalHits
int | m_totalShots

Detailed Description

Definition at line 64 of file Simple3DGame.h.

Member Function Documentation

float Simple3DGame::BonusTime ( ) [inline]

Definition at line 90 of file Simple3DGame.h.

{ return m_levelBonusTime; };

float Simple3DGame::BonusTime ( ) [inline]

Definition at line 98 of file Simple3DGame.h.

{ return m_levelBonusTime; };

void Simple3DGame::ContinueGame ( )
void Simple3DGame::ContinueGame ( )

Definition at line 326 of file Simple3DGame.cpp.

{
    m_timer->Start();
    m_controller->Active(true);
}

Level Simple3DGame::CurrentLevel ( ) [inline]

Definition at line 94 of file Simple3DGame.h.

{ return m_level[m_currentLevel]; };

Level Simple3DGame::CurrentLevel ( ) [inline]

Definition at line 102 of file Simple3DGame.h.

{ return m_level[m_currentLevel]; };

void Simple3DGame::CycleBackground ( )

Definition at line 1174 of file Simple3DGame.cpp.

{
    // There may be gaps in the background textures list that are available for use because the
    // user has not purchased all them in order or at all.
    // Cycle through the list looking for the next one that is valid.  This may require wrapping
    // back to the beginning.

    unsigned int newBackground = m_activeBackground;

    while (newBackground < GameConstants::MaxBackgroundTextures)
    {
        newBackground++;
        if (newBackground >= GameConstants::MaxBackgroundTextures)
        {
            newBackground = 0;
            break;
        }
        else if (m_gameConfig.backgroundAvailable[newBackground])
        {
            break;
        }
    }

    if (newBackground != m_activeBackground)
    {
        m_activeBackground = newBackground;
        m_renderer->SetBackground(newBackground);
    }
}

void Simple3DGame::FinalizeLoadLevel ( )
void Simple3DGame::FinalizeLoadLevel ( )

Definition at line 293 of file Simple3DGame.cpp.

{
    // This method is called on the main thread, so Direct3D 11 DeviceContext
    // method calls are allowable here.

    // Finalize the Level loading.
    m_renderer->FinalizeLoadLevelResources();
}

bool Simple3DGame::GameActive ( ) [inline]

Definition at line 91 of file Simple3DGame.h.

{ return m_gameActive; };

bool Simple3DGame::GameActive ( ) [inline]

Definition at line 99 of file Simple3DGame.h.

{ return m_gameActive; };

Camera Simple3DGame::GameCamera ( ) [inline]

Definition at line 96 of file Simple3DGame.h.

{ return m_camera; };

Camera Simple3DGame::GameCamera ( ) [inline]

Definition at line 104 of file Simple3DGame.h.

{ return m_camera; };

HighScoreEntry Simple3DGame::HighScore ( ) [inline]

Definition at line 93 of file Simple3DGame.h.

{ return m_topScore; };

HighScoreEntry Simple3DGame::HighScore ( ) [inline]

Definition at line 101 of file Simple3DGame.h.

{ return m_topScore; };

void Simple3DGame::Initialize | ( | _In_ MoveLookController^ | controller,
 |  | _In_ GameRenderer^ | renderer
 | ) |  |

Definition at line 51 of file Simple3DGame.cpp.

{
    // This method is expected to be called as an asynchronous task.
    // Care should be taken to not call rendering methods on the
    // m_renderer as this would result in the D3D Context being
    // used in multiple threads, which is not allowed.

    m_controller = controller;
    m_renderer = renderer;

    m_audioController = ref new Audio;
    m_audioController->CreateDeviceIndependentResources();

    m_ammo = std::vector<Sphere^>(GameConstants::MaxAmmo);
    m_objects = std::vector<GameObject^>();
    m_renderObjects = std::vector<GameObject^>();
    m_level = std::vector<Level^>();

    m_savedState = ref new PersistentState();
    m_savedState->Initialize(ApplicationData::Current->LocalSettings->Values, "Game");

    m_timer = ref new GameTimer();

    // Create a sphere primitive to represent the player.
    // The sphere will be used to handle collisions and constrain the player in the world.
    // It is not rendered so it is not added to the list of render objects.
    // It is added to the object list so it will be included in intersection calculations.
    m_player = ref new Sphere(XMFLOAT3(0.0f, -1.3f, 4.0f), 0.2f);
    m_objects.push_back(m_player);
    m_player->Active(true);

    m_camera = ref new Camera;
    m_camera->SetProjParams(XM_PI / 2, 1.0f, 0.01f, 100.0f);
    m_camera->SetViewParams(
        m_player->Position(),            // Eye point in world coordinates.
        XMFLOAT3 (0.0f, 0.7f, 0.0f),     // Look at point in world coordinates.
        XMFLOAT3 (0.0f, 1.0f, 0.0f)      // The Up vector for the camera.
        );

    m_controller->Pitch(m_camera->Pitch());
    m_controller->Yaw(m_camera->Yaw());

    // Instantiate a set of primitives to represent the containing world. These objects
    // maintain the geometry and material properties of the walls, floor and ceiling.
    // The TargetId is used to identify the world objects so that the right geometry
    // and textures can be associated with them later after those resources have
    // been created.
    GameObject^ world = ref new GameObject();
    world->TargetId(GameConstants::WorldFloorId);
    world->Active(true);
    m_renderObjects.push_back(world);

    world = ref new GameObject();
    world->TargetId(GameConstants::WorldCeilingId);
    world->Active(true);
    m_renderObjects.push_back(world);

    world = ref new GameObject();
    world->TargetId(GameConstants::WorldWallsId);
    world->Active(true);
    m_renderObjects.push_back(world);

    // Min and max Bound are defining the world space of the game.
    // All camera motion and dynamics are confined to this space.
    m_minBound = XMFLOAT3(-4.0f, -3.0f, -6.0f);
    m_maxBound = XMFLOAT3(4.0f, 3.0f, 6.0f);

    // Instantiate the Cylinders for use in the various game levels.
    // Each cylinder has a different initial position, radius and direction vector,
    // but share a common set of material properties.
    for (int a = 0; a < GameConstants::MaxCylinders; a++)
    {
        Cylinder^ cylinder;
        switch (a)
        {
        case 0:
            cylinder = ref new Cylinder(XMFLOAT3(-2.0f, -3.0f, 0.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
            break;
        case 1:
            cylinder = ref new Cylinder(XMFLOAT3(2.0f, -3.0f, 0.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
            break;
        case 2:
            cylinder = ref new Cylinder(XMFLOAT3(0.0f, -3.0f, -2.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
            break;
        case 3:
            cylinder = ref new Cylinder(XMFLOAT3(-1.5f, -3.0f, -4.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
            break;
        case 4:
            cylinder = ref new Cylinder(XMFLOAT3(1.5f, -3.0f, -4.0f), 0.50f, XMFLOAT3(0.0f, 6.0f, 0.0f));
            break;
        }
        cylinder->Active(true);
        m_objects.push_back(cylinder);
        m_renderObjects.push_back(cylinder);
    }

    MediaReader^ mediaReader = ref new MediaReader;
    auto targetHitSound = mediaReader->LoadMedia("hit.wav");

    // Instantiate the targets for use in the game.
    // Each target has a different initial position, size and orientation,
    // but share a common set of material properties.
    // The target is defined by a position and two vectors that define both
    // the plane of the target in world space and the size of the parallelogram
    // based on the lengths of the vectors.
    // Each target is assigned a number for identification purposes.
    // The Target ID number is 1 based.
    // All targets have the same material properties.
    for (int a = 1; a < GameConstants::MaxTargets; a++)
    {
        Face^ target;
        switch (a)
        {
        case 1:
            target = ref new Face(XMFLOAT3(-2.5f, -1.0f, -1.5f), XMFLOAT3(-1.5f, -1.0f, -2.0f), XMFLOAT3(-2.5f, 1.0f, -1.5f));
            break;
        case 2:
            target = ref new Face(XMFLOAT3(-1.0f, 1.0f, -3.0f), XMFLOAT3(0.0f, 1.0f, -3.0f), XMFLOAT3(-1.0f, 2.0f, -3.0f));
            break;
        case 3:
            target = ref new Face(XMFLOAT3(1.5f, 0.0f, -3.0f), XMFLOAT3(2.5f, 0.0f, -2.0f), XMFLOAT3(1.5f, 2.0f, -3.0f));
            break;
        case 4:
            target = ref new Face(XMFLOAT3(-2.5f, -1.0f, -5.5f), XMFLOAT3(-0.5f, -1.0f, -5.5f), XMFLOAT3(-2.5f, 1.0f, -5.5f));
            break;
        case 5:
            target = ref new Face(XMFLOAT3(0.5f, -2.0f, -5.0f), XMFLOAT3(1.5f, -2.0f, -5.0f), XMFLOAT3(0.5f, 0.0f, -5.0f));
            break;
        case 6:
            target = ref new Face(XMFLOAT3(1.5f, -2.0f, -5.5f), XMFLOAT3(2.5f, -2.0f, -5.0f), XMFLOAT3(1.5f, 0.0f, -5.5f));
            break;
        case 7:
            target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
            break;
        case 8:
            target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
            break;
        case 9:
            target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
            break;
        }

        target->Target(true);
        target->TargetId(a);
        target->Active(true);
        target->HitSound(ref new SoundEffect());
        target->HitSound()->Initialize(
            m_audioController->SoundEffectEngine(),
            mediaReader->GetOutputWaveFormatEx(),
            targetHitSound
            );

        m_objects.push_back(target);
        m_renderObjects.push_back(target);
    }

    // Instantiate a set of spheres to be used as ammunition for the game
    // and set the material properties of the spheres.
    auto ammoHitSound = mediaReader->LoadMedia("bounce.wav");

    for (int a = 0; a < GameConstants::MaxAmmo; a++)
    {
        m_ammo[a] = ref new Sphere;
        m_ammo[a]->Radius(GameConstants::AmmoRadius);
        m_ammo[a]->HitSound(ref new SoundEffect());
        m_ammo[a]->HitSound()->Initialize(
            m_audioController->SoundEffectEngine(),
            mediaReader->GetOutputWaveFormatEx(),
            ammoHitSound
            );
        m_ammo[a]->Active(false);
        m_renderObjects.push_back(m_ammo[a]);
    }

    // Instantiate each of the game levels. The Level class contains methods
    // that initialize the objects in the world for the given level and also
    // define any motion paths for the objects in that level.

    m_level.push_back(ref new Level1);
    m_level.push_back(ref new Level2);
    m_level.push_back(ref new Level3);
    m_level.push_back(ref new Level4);
    m_level.push_back(ref new Level5);
    m_level.push_back(ref new Level6);
    m_levelCount = static_cast<uint32>(m_level.size());

    // Load the top score from disk if it exists.
    LoadHighScore();

    // Load the currentScore for saved state if it exists.
    LoadState();

    m_controller->Active(false);
}

void Simple3DGame::Initialize | ( | _In_ MoveLookController^ | controller,
 |  | _In_ GameRenderer^ | renderer
 | ) |  |
void Simple3DGame::InitializeAmmo ( ) [private]

Definition at line 1057 of file Simple3DGame.cpp.

{
    m_ammoCount = 0;
    m_ammoNext = 0;
    for (uint32 i = 0; i < GameConstants::MaxAmmo; i++)
    {
        m_ammo[i]->Active(false);
    }
}

void Simple3DGame::InitializeAmmo ( ) [private]
void Simple3DGame::InitializeGameConfig ( ) [private]

Definition at line 1085 of file Simple3DGame.cpp.

{
    m_gameConfig.isTrial = true;
    m_gameConfig.autoFire = false;
    m_controller->AutoFire(false);
    m_activeBackground = 0;
    m_gameConfig.backgroundAvailable[0] = true;
    for (int i = 1; i < GameConstants::MaxBackgroundTextures; i++)
    {
        m_gameConfig.backgroundAvailable[i] = false;
    }
}

bool Simple3DGame::IsActivePlay ( ) [inline]

Definition at line 93 of file Simple3DGame.h.

{ return m_timer->Active(); }

bool Simple3DGame::IsActivePlay ( ) [inline]

Definition at line 86 of file Simple3DGame.h.

{ return m_timer->Active(); }

bool Simple3DGame::IsTrial ( ) [inline]

Definition at line 94 of file Simple3DGame.h.

{ return m_gameConfig.isTrial; }

bool Simple3DGame::LevelActive ( ) [inline]

Definition at line 92 of file Simple3DGame.h.

{ return m_levelActive; };

bool Simple3DGame::LevelActive ( ) [inline]

Definition at line 100 of file Simple3DGame.h.

{ return m_levelActive; };

int Simple3DGame::LevelCompleted ( ) [inline]

Definition at line 95 of file Simple3DGame.h.

{ return m_currentLevel; };

int Simple3DGame::LevelCompleted ( ) [inline]

Definition at line 87 of file Simple3DGame.h.

{ return m_currentLevel; };

void Simple3DGame::LoadGame ( )

Definition at line 251 of file Simple3DGame.cpp.

{
    m_player->Position(XMFLOAT3 (0.0f, -1.3f, 4.0f));

    m_camera->SetViewParams(
        m_player->Position(),            // Eye point in world coordinates.
        XMFLOAT3 (0.0f, 0.7f, 0.0f),     // Look at point in world coordinates.
        XMFLOAT3 (0.0f, 1.0f, 0.0f)      // The Up vector for the camera.
        );

    m_controller->Pitch(m_camera->Pitch());
    m_controller->Yaw(m_camera->Yaw());
    m_currentLevel = 0;
    m_levelTimeRemaining = 0.0f;
    m_levelBonusTime = m_levelTimeRemaining;
    m_levelDuration = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime;
    InitializeAmmo();
    m_totalHits = 0;
    m_totalShots = 0;
    m_gameActive = false;
    m_levelActive = false;
    m_timer->Reset();
}

void Simple3DGame::LoadGame ( )
void Simple3DGame::LoadHighScore ( ) [private]
void Simple3DGame::LoadHighScore ( ) [private]

Definition at line 1048 of file Simple3DGame.cpp.

{
    m_topScore.levelCompleted = m_savedState->LoadInt32(":HighScore:LevelCompleted", 0);
    m_topScore.totalShots = m_savedState->LoadInt32(":HighScore:TotalShots", 0);
    m_topScore.totalHits = m_savedState->LoadInt32(":HighScore:TotalHits", 0);
}

concurrency::task<void> Simple3DGame::LoadLevelAsync ( )
task< void > Simple3DGame::LoadLevelAsync ( )

Definition at line 277 of file Simple3DGame.cpp.

{
    // Initialize the level and spin up the async loading of the rendering
    // resources for the level.
    // This will run in a separate thread, so for Direct3D 11, only Device
    // methods are allowed.  Any DeviceContext method calls need to be
    // done in FinalizeLoadLevel.

    m_level[m_currentLevel]->Initialize(m_objects);
    m_levelDuration = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime;

    return m_renderer->LoadLevelResourcesAsync();
}

void Simple3DGame::LoadState ( ) [private]

Definition at line 910 of file Simple3DGame.cpp.

{
    m_gameActive = m_savedState->LoadBool(":GameActive", m_gameActive);
    m_levelActive = m_savedState->LoadBool(":LevelActive", m_levelActive);

    if (m_gameActive)
    {
        // Loading from the last known state means the game wasn't finished when it was last played,
        // so set the current level.

        m_totalShots = m_savedState->LoadInt32(":TotalShots", 0);
        m_totalHits = m_savedState->LoadInt32(":TotalHits", 0);
        m_currentLevel = m_savedState->LoadInt32(":LevelCompleted", 0);
        m_levelBonusTime = m_savedState->LoadSingle(":BonusRoundTime", 0.0f);

        m_levelTimeRemaining = m_levelBonusTime;

        // Reload the current player position and set both the camera and the controller
        // with the current Look Direction.
        m_player->Position(
            m_savedState->LoadXMFLOAT3(":PlayerPosition", XMFLOAT3(0.0f, 0.0f, 0.0f))
            );
        m_camera->Eye(m_player->Position());
        m_camera->LookDirection(
            m_savedState->LoadXMFLOAT3(":PlayerLookDirection", XMFLOAT3(0.0f, 0.0f, 1.0f))
            );
        m_controller->Pitch(m_camera->Pitch());
        m_controller->Yaw(m_camera->Yaw());
    }
    else
    {
        // The game was not being played when it was last saved, so initialize to the beginning.
        m_currentLevel = 0;
        m_levelBonusTime = 0;
    }
}

void Simple3DGame::LoadState ( ) [private]
void Simple3DGame::OnResuming ( )

Definition at line 426 of file Simple3DGame.cpp.

{
    m_audioController->ResumeAudio();
}

void Simple3DGame::OnResuming ( )
void Simple3DGame::OnSuspending ( )
void Simple3DGame::OnSuspending ( )

Definition at line 419 of file Simple3DGame.cpp.

{
    m_audioController->SuspendAudio();
}

void Simple3DGame::PauseGame ( )
void Simple3DGame::PauseGame ( )

Definition at line 318 of file Simple3DGame.cpp.

{
    m_timer->Stop();
    SaveState();
}

std::vector<GameObject^> Simple3DGame::RenderObjects ( ) [inline]

Definition at line 97 of file Simple3DGame.h.

{ return m_renderObjects; };

std::vector<GameObject^> Simple3DGame::RenderObjects ( ) [inline]

Definition at line 105 of file Simple3DGame.h.

{ return m_renderObjects; };

GameState Simple3DGame::RunGame ( )

Definition at line 334 of file Simple3DGame.cpp.

{
    // This method is called to execute a single time interval for active game play.
    // It returns the resulting state of game play after the interval has been executed.

    m_timer->Update();

    m_levelTimeRemaining = m_levelDuration - m_timer->PlayingTime();

    if (m_levelTimeRemaining <= 0.0f)
    {
        // Time expired, so the game is over.
        m_levelTimeRemaining = 0.0f;
        InitializeAmmo();
        m_timer->Reset();
        m_gameActive = false;
        m_levelActive = false;
        SaveState();

        if (m_totalHits > m_topScore.totalHits)
        {
            // There is a new high score so save it.
            m_topScore.totalHits = m_totalHits;
            m_topScore.totalShots = m_totalShots;
            m_topScore.levelCompleted = m_currentLevel;

            SaveHighScore();
        }
        return GameState::TimeExpired;
    }
    else
    {
        // Time has not expired, so run one frame of game play.
        m_player->Velocity(m_controller->Velocity());
        m_camera->LookDirection(m_controller->LookDirection());

        UpdateDynamics();

        // Update the Camera with the player position updates from the dynamics calculations.
        m_camera->Eye(m_player->Position());
        m_camera->LookDirection(m_controller->LookDirection());

        if (m_level[m_currentLevel]->Update(m_timer->PlayingTime(), m_timer->DeltaTime(), m_levelTimeRemaining, m_objects))
        {
            // The level has been completed.
            m_levelActive = false;
            InitializeAmmo();

            if (m_currentLevel < m_levelCount-1)
            {
                // More levels to go so increment the level number.
                // Actual level loading will occur in the LoadLevelAsync / FinalizeLoadLevel
                // methods.
                m_timer->Reset();
                m_currentLevel++;
                m_levelBonusTime = m_levelTimeRemaining;
                SaveState();
                return GameState::LevelComplete;
            }
            else
            {
                // All levels have been completed.
                m_timer->Reset();
                m_gameActive = false;
                m_levelActive = false;
                SaveState();

                if (m_totalHits > m_topScore.totalHits)
                {
                    // There is a new high score so save it.
                    m_topScore.totalHits = m_totalHits;
                    m_topScore.totalShots = m_totalShots;
                    m_topScore.levelCompleted = m_currentLevel;

                    SaveHighScore();
                }
                return GameState::GameComplete;
            }
        }
    }
    return GameState::Active;
}

GameState Simple3DGame::RunGame ( )
void Simple3DGame::SaveHighScore ( ) [private]

Definition at line 1039 of file Simple3DGame.cpp.

{
    m_savedState->SaveInt32(":HighScore:LevelCompleted", m_topScore.levelCompleted);
    m_savedState->SaveInt32(":HighScore:TotalShots", m_topScore.totalShots);
    m_savedState->SaveInt32(":HighScore:TotalHits", m_topScore.totalHits);
}

void Simple3DGame::SaveHighScore ( ) [private]
void Simple3DGame::SaveState ( ) [private]
void Simple3DGame::SaveState ( ) [private]

Definition at line 857 of file Simple3DGame.cpp.

{
    // Save basic state of the game.
    m_savedState->SaveBool(":GameActive", m_gameActive);
    m_savedState->SaveBool(":LevelActive", m_levelActive);
    m_savedState->SaveInt32(":LevelCompleted", m_currentLevel);
    m_savedState->SaveInt32(":TotalShots", m_totalShots);
    m_savedState->SaveInt32(":TotalHits", m_totalHits);
    m_savedState->SaveSingle(":BonusRoundTime", m_levelBonusTime);
    m_savedState->SaveXMFLOAT3(":PlayerPosition", m_player->Position());
    m_savedState->SaveXMFLOAT3(":PlayerLookDirection", m_controller->LookDirection());

    if (m_levelActive)
    {
        // The game is currently in the middle of a level, so save the extended state of
        // the game.
        m_savedState->SaveSingle(":LevelDuration", m_levelDuration);
        m_savedState->SaveSingle(":LevelPlayingTime", m_timer->PlayingTime());

        m_savedState->SaveInt32(":AmmoCount", m_ammoCount);
        m_savedState->SaveInt32(":AmmoNext", m_ammoNext);

        const int bufferLength = 16;
        char16 str[bufferLength];

        for (uint32 i = 0; i < m_ammoCount; i++)
        {
            int len = swprintf_s(str, bufferLength, L"%d", i);
            Platform::String^ string = ref new Platform::String(str, len);

            m_savedState->SaveBool(Platform::String::Concat(":AmmoActive", string), m_ammo[i]->Active());
            m_savedState->SaveXMFLOAT3(Platform::String::Concat(":AmmoPosition", string), m_ammo[i]->Position());
            m_savedState->SaveXMFLOAT3(Platform::String::Concat(":AmmoVelocity", string), m_ammo[i]->Velocity());
        }

        m_savedState->SaveInt32(":ObjectCount", static_cast<int>(m_objects.size()));

        for (uint32 i = 0; i < m_objects.size(); i++)
        {
            int len = swprintf_s(str, bufferLength, L"%d", i);
            Platform::String^ string = ref new Platform::String(str, len);

            m_savedState->SaveBool(Platform::String::Concat(":ObjectActive", string), m_objects[i]->Active());
            m_savedState->SaveBool(Platform::String::Concat(":ObjectTarget", string), m_objects[i]->Target());
            m_savedState->SaveXMFLOAT3(Platform::String::Concat(":ObjectPosition", string), m_objects[i]->Position());
        }

        m_level[m_currentLevel]->SaveState(m_savedState);
    }
}

void Simple3DGame::SetBackground ( uint32 background )

Definition at line 1160 of file Simple3DGame.cpp.

{
    if (background < GameConstants::MaxBackgroundTextures)
    {
        if (m_gameConfig.backgroundAvailable[background])
        {
            m_activeBackground = background;
            m_renderer->SetBackground(background);
        }
    }
}

void Simple3DGame::SetCurrentLevelToSavedState ( )

Definition at line 949 of file Simple3DGame.cpp.

{
    if (m_gameActive)
    {
        if (m_levelActive)
        {
            // Middle of a level so restart where left off.
            m_levelDuration = m_savedState->LoadSingle(":LevelDuration", 0.0f);

            m_timer->Reset();
            m_timer->PlayingTime(m_savedState->LoadSingle(":LevelPlayingTime", 0.0f));

            m_ammoCount = m_savedState->LoadInt32(":AmmoCount", 0);

            m_ammoNext = m_savedState->LoadInt32(":AmmoNext", 0);

            const int bufferLength = 16;
            char16 str[bufferLength];

            for (uint32 i = 0; i < m_ammoCount; i++)
            {
                int len = swprintf_s(str, bufferLength, L"%d", i);
                Platform::String^ string = ref new Platform::String(str, len);

                m_ammo[i]->Active(
                    m_savedState->LoadBool(
                        Platform::String::Concat(":AmmoActive", string),
                        m_ammo[i]->Active()
                        )
                    );
                if (m_ammo[i]->Active())
                {
                    m_ammo[i]->OnGround(false);
                }

                m_ammo[i]->Position(
                    m_savedState->LoadXMFLOAT3(
                        Platform::String::Concat(":AmmoPosition", string),
                        m_ammo[i]->Position()
                        )
                    );

                m_ammo[i]->Velocity(
                    m_savedState->LoadXMFLOAT3(
                        Platform::String::Concat(":AmmoVelocity", string),
                        m_ammo[i]->Velocity()
                        )
                    );
            }

            int storedObjectCount = 0;
            storedObjectCount = m_savedState->LoadInt32(":ObjectCount", 0);

            storedObjectCount = min(storedObjectCount, static_cast<int>(m_objects.size()));

            for (int i = 0; i < storedObjectCount; i++)
            {
                int len = swprintf_s(str, bufferLength, L"%d", i);
                Platform::String^ string = ref new Platform::String(str, len);

                m_objects[i]->Active(
                    m_savedState->LoadBool(
                        Platform::String::Concat(":ObjectActive", string),
                        m_objects[i]->Active()
                        )
                    );

                m_objects[i]->Target(
                    m_savedState->LoadBool(
                        Platform::String::Concat(":ObjectTarget", string),
                        m_objects[i]->Target()
                        )
                    );

                m_objects[i]->Position(
                    m_savedState->LoadXMFLOAT3(
                        Platform::String::Concat(":ObjectPosition", string),
                        m_objects[i]->Position()
                        )
                    );
            }

            m_level[m_currentLevel]->LoadState(m_savedState);
            m_levelTimeRemaining = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime - m_timer->PlayingTime();
        }
    }
}

void Simple3DGame::SetCurrentLevelToSavedState ( )
void Simple3DGame::StartLevel ( )
void Simple3DGame::StartLevel ( )

Definition at line 304 of file Simple3DGame.cpp.

{
    m_timer->Reset();
    m_timer->Start();
    if (m_currentLevel == 0)
    {
        m_gameActive = true;
    }
    m_levelActive = true;
    m_controller->Active(true);
}

float Simple3DGame::TimeRemaining ( ) [inline]

Definition at line 95 of file Simple3DGame.h.

{ return m_levelTimeRemaining; };

float Simple3DGame::TimeRemaining ( ) [inline]

Definition at line 103 of file Simple3DGame.h.

{ return m_levelTimeRemaining; };

int Simple3DGame::TotalHits ( ) [inline]

Definition at line 89 of file Simple3DGame.h.

{ return m_totalHits; };

int Simple3DGame::TotalHits ( ) [inline]

Definition at line 97 of file Simple3DGame.h.

{ return m_totalHits; };

int Simple3DGame::TotalShots ( ) [inline]

Definition at line 88 of file Simple3DGame.h.

{ return m_totalShots; };

int Simple3DGame::TotalShots ( ) [inline]

Definition at line 96 of file Simple3DGame.h.

{ return m_totalShots; };

void Simple3DGame::UpdateDynamics ( ) [private]

Definition at line 433 of file Simple3DGame.cpp.

{
    float timeTotal = m_timer->PlayingTime();
    float timeFrame = m_timer->DeltaTime();
    bool fire = m_controller->IsFiring();

#pragma region Shoot Ammo
    // Shoot ammo.
    if (fire)
    {
        static float lastFired;  // Timestamp of last ammo fired.

        if (timeTotal < lastFired)
        {
            // timeTotal is not guarenteed to be monotomically increasing because it is
            // reset at each level.
            lastFired = timeTotal - GameConstants::Physics::AutoFireDelay;
        }

        if (timeTotal - lastFired >= GameConstants::Physics::AutoFireDelay)
        {
            // Get inverse view matrix.
            XMMATRIX invView;
            XMVECTOR det;
            invView = XMMatrixInverse(&det, m_camera->View());

            // Compute initial velocity in world space from camera space.
            XMFLOAT4 initialVelocity(0.0f, 0.0f, 15.0f, 0.0f);
            m_ammo[m_ammoNext]->Velocity(XMVector4Transform(XMLoadFloat4(&initialVelocity), invView));

            // Set the initial position of the ammo to be fired. The position is offset from the player
            // to avoid an initial collision with the player object.
            XMFLOAT4 initialPosition(0.0f, -0.15f, m_player->Radius() + GameConstants::AmmoSize, 1.0f);
            m_ammo[m_ammoNext]->Position(XMVector4Transform(XMLoadFloat4(&initialPosition), invView));

            // Initially not laying on ground.
            m_ammo[m_ammoNext]->OnGround(false);
            m_ammo[m_ammoNext]->Active(true);

            // Set position in array of next Ammo to use.
            // We will re-use ammo taking the least recently used once we have hit the
            // MaxAmmo in use.
            m_ammoNext = (m_ammoNext + 1) % GameConstants::MaxAmmo;
            m_ammoCount = min(m_ammoCount + 1, GameConstants::MaxAmmo);

            lastFired = timeTotal;
            m_totalShots++;
        }
    }
#pragma endregion

#pragma region Animate Objects
    // Walk the list of objects looking for any objects that have an animation associated with it.
    // Update the position of the object based on evaluating the animation object with the current time.
    // Once the current time (timeTotal) is past the end of the animation time remove
    // the animation object since it is no longer needed.
    for (uint32 i = 0; i < m_objects.size(); i++)
    {
        if (m_objects[i]->AnimatePosition())
        {
            m_objects[i]->Position(m_objects[i]->AnimatePosition()->Evaluate(timeTotal));
            if (m_objects[i]->AnimatePosition()->IsFinished(timeTotal))
            {
                m_objects[i]->AnimatePosition(nullptr);
            }
        }
    }
#pragma endregion

    // If the elapsed time is too long, we slice up the time and handle physics over several
    // smaller time steps to avoid missing collisions.
    float timeLeft = timeFrame;
    float elapsedFrameTime;
    while (timeLeft > 0.0f)
    {
        elapsedFrameTime = min(timeLeft, GameConstants::Physics::FrameLength);
        timeLeft -= elapsedFrameTime;

        // Update the player position.
        m_player->Position(m_player->VectorPosition() + m_player->VectorVelocity() * elapsedFrameTime);

        // Do m_player / object intersections.
        for (uint32 a = 0; a < m_objects.size(); a++)
        {
            if (m_objects[a]->Active() && m_objects[a] != m_player)
            {
                XMFLOAT3 contact;
                XMFLOAT3 normal;

                if (m_objects[a]->IsTouching(m_player->Position(), m_player->Radius(), &contact, &normal))
                {
                    // Player is in contact with m_objects[a].
                    XMVECTOR oneToTwo;
                    oneToTwo = -XMLoadFloat3(&normal);

                    float impact = XMVectorGetX(
                        XMVector3Dot (oneToTwo, m_player->VectorVelocity())
                        );
                    // Make sure that the player is actually headed towards the object. At grazing angles there
                    // could appear to be an impact when the player is actually already hit and moving away.
                    if (impact > 0.0f)
                    {
                        // Compute the normal and tangential components of the player's velocity.
                        XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, m_player->VectorVelocity()) * oneToTwo;
                        XMVECTOR velocityOneTangent = m_player->VectorVelocity() - velocityOneNormal;

                        // Compute post-collision velocity.
                        m_player->Velocity(velocityOneTangent - velocityOneNormal);

                        // Fix the positions so that the player is just touching the object.
                        float distanceToMove = m_player->Radius();
                        m_player->Position(XMLoadFloat3(&contact) - (oneToTwo * distanceToMove));
                    }
                }
            }
        }
        {
            // Do collision detection of the player with the bounding world.
            XMFLOAT3 position = m_player->Position();
            XMFLOAT3 velocity = m_player->Velocity();
            float radius = m_player->Radius();

            // Check for player collisions with the walls floor or ceiling and adjust the position.
            float limit = m_minBound.x + radius;
            if (position.x < limit)
            {
                position.x = limit;
                velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
            }
            limit = m_maxBound.x - radius;
            if (position.x > limit)
            {
                position.x = limit;
                velocity.x = -velocity.x + GameConstants::Physics::GroundRestitution;
            }
            limit = m_minBound.y + radius;
            if (position.y < limit)
            {
                position.y = limit;
                velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
            }
            limit = m_maxBound.y - radius;
            if (position.y > limit)
            {
                position.y = limit;
                velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
            }
            limit = m_minBound.z + radius;
            if (position.z < limit)
            {
                position.z = limit;
                velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
            }
            limit = m_maxBound.z - radius;
            if (position.z > limit)
            {
                position.z = limit;
                velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
            }
            m_player->Position(position);
            m_player->Velocity(velocity);
        }

        // Animate the ammo.
        if (m_ammoCount > 0)
        {
            // Check for collisions between ammo.
#pragma region inter-ammo collision detection
            if (m_ammoCount > 1)
            {
                for (uint32 one = 0; one < m_ammoCount; one++)
                {
                    for (uint32 two = (one + 1); two < m_ammoCount; two++)
                    {
                        // Check collision between instances One and Two.
                        // OneToTwo is the vector between the centers of the two ammo that are being checked.
                        XMVECTOR oneToTwo;
                        oneToTwo = m_ammo[two]->VectorPosition() - m_ammo[one]->VectorPosition();
                        float distanceSquared;
                        distanceSquared = XMVectorGetX(
                            XMVector3LengthSq(oneToTwo)
                            );
                        if (distanceSquared < (GameConstants::AmmoSize * GameConstants::AmmoSize))
                        {
                            // The two ammo are intersecting.
                            oneToTwo = XMVector3Normalize(oneToTwo);

                            // Check if the two instances are already moving away from each other.
                            // If so, skip collision.  This can happen when a lot of instances are
                            // bunched up next to each other.
                            float impact;
                            impact = XMVectorGetX(
                                XMVector3Dot(oneToTwo, m_ammo[one]->VectorVelocity()) -
                                XMVector3Dot(oneToTwo, m_ammo[two]->VectorVelocity())
                                );
                            if (impact > 0.0f)
                            {
                                // Compute the normal and tangential components of one's velocity.
                                XMVECTOR velocityOne = (1 - GameConstants::Physics::BounceLost) * m_ammo[one]->VectorVelocity();
                                XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, velocityOne) * oneToTwo;
                                XMVECTOR velocityOneTangent = velocityOne - velocityOneNormal;
                                // Compute the normal and tangential components of two's velocity.
                                XMVECTOR velocityTwo = (1 - GameConstants::Physics::BounceLost) * m_ammo[two]->VectorVelocity();
                                XMVECTOR velocityTwoNormal = XMVector3Dot(oneToTwo, velocityTwo) * oneToTwo;
                                XMVECTOR velocityTwoTangent = velocityTwo - velocityTwoNormal;

                                // Compute the post-collision velocities.
                                m_ammo[one]->Velocity(velocityOneTangent - velocityOneNormal * (1 - GameConstants::Physics::BounceTransfer) +
                                    velocityTwoNormal * GameConstants::Physics::BounceTransfer
                                    );
                                m_ammo[two]->Velocity(velocityTwoTangent - velocityTwoNormal * (1 - GameConstants::Physics::BounceTransfer) +
                                    velocityOneNormal * GameConstants::Physics::BounceTransfer
                                    );

                                // Fix the positions so that the two balls are exactly GameConstants::AmmoSize apart.
                                float distanceToMove = (GameConstants::AmmoSize - sqrtf(distanceSquared)) * 0.5f;
                                m_ammo[one]->Position(m_ammo[one]->VectorPosition() - (oneToTwo * distanceToMove));
                                m_ammo[two]->Position(m_ammo[two]->VectorPosition() + (oneToTwo * distanceToMove));

                                // Flag the two instances so that they are not laying on ground.
                                m_ammo[one]->OnGround(false);
                                m_ammo[two]->OnGround(false);

                                // Start playing the sounds for the impact between the two balls.
                                m_ammo[one]->PlaySound(impact, m_player->Position());
                                m_ammo[two]->PlaySound(impact, m_player->Position());
                            }
                        }
                    }
                }
            }
#pragma endregion

#pragma region Ammo-Object intersections
            // Check for intersections between the ammo and the other objects in the scene.
            for (uint32 one = 0; one < m_ammoCount; one++)
            {
                if (m_objects.size() > 0)
                {
                    if (!m_ammo[one]->OnGround())
                    {
                        for (uint32 i = 0; i < m_objects.size(); i++)
                        {
                            if (m_objects[i]->Active())
                            {
                                // The object is currently active in the scene. There may be objects in the list
                                // that are currently inactive, so those are skipped.
                                XMFLOAT3 contact;
                                XMFLOAT3 normal;

                                if (m_objects[i]->IsTouching(m_ammo[one]->Position(), GameConstants::AmmoRadius, &contact, &normal))
                                {
                                    // Ball is in contact with Object.
                                    XMVECTOR oneToTwo;
                                    oneToTwo = -XMLoadFloat3(&normal);

                                    float impact;
                                    impact = XMVectorGetX(
                                        XMVector3Dot (oneToTwo, m_ammo[one]->VectorVelocity())
                                        );
                                    // Make sure that the ball is actually headed towards the object. At grazing angles there
                                    // could appear to be an impact when the ball is actually already hit and moving away.
                                    if (impact > 0.0f)
                                    {
                                        // Compute the normal and tangential components of the ammo's velocity.
                                        XMVECTOR velocityOne = (1 - GameConstants::Physics::BounceLost) * m_ammo[one]->VectorVelocity();
                                        XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, velocityOne) * oneToTwo;
                                        XMVECTOR velocityOneTangent = velocityOne - velocityOneNormal;

                                        // Compute post-collision velocity of the ammo.
                                        m_ammo[one]->Velocity(velocityOneTangent - velocityOneNormal * (1 - GameConstants::Physics::BounceTransfer));

                                        // Fix the position so that the ball is exactly GameConstants::AmmoRadius from target.
                                        float distanceToMove = GameConstants::AmmoSize;
                                        m_ammo[one]->Position(XMLoadFloat3(&contact) - (oneToTwo * distanceToMove));

                                        // Flag the Ammo as not laying on ground.
                                        m_ammo[one]->OnGround(false);

                                        // Play the sound associated with the Ammo hitting something.
                                        m_ammo[one]->PlaySound(impact, m_player->Position());

                                        if (m_objects[i]->Target() && !m_objects[i]->Hit())
                                        {
                                            // The object is a target and isn't currently hit, so mark it as hit and
                                            // play the sound associated with the impact.
                                            m_objects[i]->Hit(true);
                                            m_objects[i]->HitTime(timeTotal);
                                            m_totalHits++;

                                            m_objects[i]->PlaySound(impact, m_player->Position());
                                        }
                                    }
                                }
                            }
                        }
                    }
                }
            }
#pragma endregion

#pragma region Apply Gravity and world intersection
            // Apply gravity and check for collision against enclosing volume.
            for (uint32 i = 0; i < m_ammoCount; i++)
            {
                // Update the position and velocity of the ammo instance.
                m_ammo[i]->Position(m_ammo[i]->VectorPosition() + m_ammo[i]->VectorVelocity() * elapsedFrameTime);

                XMFLOAT3 velocity = m_ammo[i]->Velocity();
                XMFLOAT3 position = m_ammo[i]->Position();

                velocity.x -= velocity.x * 0.1f * elapsedFrameTime;
                velocity.z -= velocity.z * 0.1f * elapsedFrameTime;
                if (!m_ammo[i]->OnGround())
                {
                    // Apply gravity if the ammo instance is not already resting on the ground.
                    velocity.y -= GameConstants::Physics::Gravity * elapsedFrameTime;
                }

                if (!m_ammo[i]->OnGround())
                {
                    float limit = m_minBound.y + GameConstants::AmmoRadius;
                    if (position.y < limit)
                    {
                        // The ammo instance hit the ground.
                        // Align the ammo instance to the ground, invert the Y component of the velocity and
                        // play the impact sound. The X and Z velocity components will be reduced
                        // because of friction.
                        position.y = limit;
                        m_ammo[i]->PlaySound(-velocity.y, m_player->Position());

                        velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
                        velocity.x *= GameConstants::Physics::Friction;
                        velocity.z *= GameConstants::Physics::Friction;
                    }
                }
                else
                {
                    // The ammo instance is resting or rolling on ground.
                    // X and Z velocity components are reduced because of friction.
                    velocity.x *= GameConstants::Physics::Friction;
                    velocity.z *= GameConstants::Physics::Friction;
                }

                float limit = m_maxBound.y - GameConstants::AmmoRadius;
                if (position.y > limit)
                {
                    // The ammo instance hit the ceiling.
                    // Align the ammo instance to the ceiling, invert the Y component of the velocity and
                    // play the impact sound. The X and Z velocity components will be reduced
                    // because of friction.
                    position.y = limit;
                    m_ammo[i]->PlaySound(-velocity.y, m_player->Position());

                    velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
                    velocity.x *= GameConstants::Physics::Friction;
                    velocity.z *= GameConstants::Physics::Friction;
                }

                limit = m_minBound.y + GameConstants::AmmoRadius;
                if ((GameConstants::Physics::Gravity * (position.y - limit) + 0.5f * velocity.y * velocity.y) < GameConstants::Physics::RestThreshold)
                {
                    // The Y velocity component is below the resting threshold so flag the instance as
                    // laying on the ground and set the Y velocity component to zero.
                    position.y = limit;
                    velocity.y = 0.0f;
                    m_ammo[i]->OnGround(true);
                }

                limit = m_minBound.z + GameConstants::AmmoRadius;
                if (position.z < limit)
                {
                    // The ammo instance hit the a wall in the min Z direction.
                    // Align the ammo instance to the wall, invert the Z component of the velocity and
                    // play the impact sound.
                    position.z = limit;
                    m_ammo[i]->PlaySound(-velocity.z, m_player->Position());
                    velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
                }

                limit = m_maxBound.z - GameConstants::AmmoRadius;
                if (position.z > limit)
                {
                    // The ammo instance hit the a wall in the max Z direction.
                    // Align the ammo instance to the wall, invert the Z component of the velocity and
                    // play the impact sound.
                    position.z = limit;
                    m_ammo[i]->PlaySound(-velocity.z, m_player->Position());
                    velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
                }

                limit = m_minBound.x + GameConstants::AmmoRadius;
                if (position.x < limit)
                {
                    // The ammo instance hit the a wall in the min X direction.
                    // Align the ammo instance to the wall, invert the X component of the velocity and
                    // play the impact sound.
                    position.x = limit;
                    m_ammo[i]->PlaySound(-velocity.x, m_player->Position());
                    velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
                }

                limit = m_maxBound.x - GameConstants::AmmoRadius;
                if (position.x > limit)
                {
                    // The ammo instance hit the a wall in the max X direction.
                    // Align the ammo instance to the wall, invert the X component of the velocity and
                    // play the impact sound.
                    position.x = limit;
                    m_ammo[i]->PlaySound(-velocity.x, m_player->Position());
                    velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
                }

                // Save the updated velocity and position for the ammo instance.
                m_ammo[i]->Velocity(velocity);
                m_ammo[i]->Position(position);
            }
        }
    }
#pragma endregion
}

void Simple3DGame::UpdateDynamics ( ) [private]
void Simple3DGame::UpdateGameConfig ( Windows::ApplicationModel::Store::LicenseInformation^ licenseInformation )

Member Data Documentation

internal Simple3DGame::__pad0__

Definition at line 67 of file Simple3DGame.h.

uint32 Simple3DGame::m_activeBackground [private]

Definition at line 147 of file Simple3DGame.h.

std::vector< Sphere^> Simple3DGame::m_ammo [private]

Definition at line 113 of file Simple3DGame.h.

uint32 Simple3DGame::m_ammoCount [private]

Definition at line 114 of file Simple3DGame.h.

uint32 Simple3DGame::m_ammoNext [private]

Definition at line 115 of file Simple3DGame.h.

Audio Simple3DGame::m_audioController [private]

Definition at line 111 of file Simple3DGame.h.

Camera Simple3DGame::m_camera [private]

Definition at line 109 of file Simple3DGame.h.

MoveLookController Simple3DGame::m_controller [private]

Definition at line 107 of file Simple3DGame.h.

uint32 Simple3DGame::m_currentLevel [private]

Definition at line 130 of file Simple3DGame.h.

bool Simple3DGame::m_gameActive [private]

Definition at line 121 of file Simple3DGame.h.

GameConfig Simple3DGame::m_gameConfig [private]

Definition at line 146 of file Simple3DGame.h.

std::vector< Level^> Simple3DGame::m_level [private]

Definition at line 128 of file Simple3DGame.h.

bool Simple3DGame::m_levelActive [private]

Definition at line 122 of file Simple3DGame.h.

float Simple3DGame::m_levelBonusTime [private]

Definition at line 126 of file Simple3DGame.h.

uint32 Simple3DGame::m_levelCount [private]

Definition at line 129 of file Simple3DGame.h.

float Simple3DGame::m_levelDuration [private]

Definition at line 125 of file Simple3DGame.h.

float Simple3DGame::m_levelTimeRemaining [private]

Definition at line 127 of file Simple3DGame.h.

DirectX::XMFLOAT3 Simple3DGame::m_maxBound [private]

Definition at line 137 of file Simple3DGame.h.

DirectX::XMFLOAT3 Simple3DGame::m_minBound [private]

Definition at line 136 of file Simple3DGame.h.

std::vector< GameObject^> Simple3DGame::m_objects [private]

Definition at line 133 of file Simple3DGame.h.

Sphere Simple3DGame::m_player [private]

Definition at line 132 of file Simple3DGame.h.

GameRenderer Simple3DGame::m_renderer [private]

Definition at line 108 of file Simple3DGame.h.

std::vector< GameObject^> Simple3DGame::m_renderObjects [private]

Definition at line 134 of file Simple3DGame.h.

PersistentState Simple3DGame::m_savedState [private]

Definition at line 118 of file Simple3DGame.h.

GameTimer Simple3DGame::m_timer [private]

Definition at line 120 of file Simple3DGame.h.

HighScoreEntry Simple3DGame::m_topScore [private]

Definition at line 117 of file Simple3DGame.h.

int Simple3DGame::m_totalHits [private]

Definition at line 123 of file Simple3DGame.h.

int Simple3DGame::m_totalShots [private]

Definition at line 124 of file Simple3DGame.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Simple3DGame.h
  • XAML DirectX 3D shooting game/C++/Simple3DGame.h
  • DirectX 3D shooting game/C++/Simple3DGame.cpp
  • XAML DirectX 3D shooting game/C++/Simple3DGame.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Simple3DGameXaml::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Simple3DGameXaml
  • Simple3DGameXaml::sealed
Public Member Functions | Public Attributes | Protected Member Functions | Private Member Functions | Private Attributes

Simple3DGameXaml::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
void | CycleBackground ()
Windows::UI::Xaml::Controls::SwapChainBackgroundPanel | GetSwapChainBackgroundPanel ()
void | HideGameInfoOverlay ()
void | HideSnapped ()
void | LicenseChanged (Windows::ApplicationModel::Store::ListingInformation^listing, Windows::ApplicationModel::Store::LicenseInformation^license)
MainPage ()
virtual void | OnLaunched (_In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
void | OnWindowSizeChanged ()
void | PauseRequested ()
void | PressComplete ()
void | ResetGame ()
void | ResetLicense ()
void | SetAction (GameInfoOverlayCommand action)
void | SetApp (App^app)
void | SetBackground (unsigned int background)
void | SetGameLoading ()
void | SetGameOver (bool win, int maxLevel, int hitCount, int shotCount, int highScore)
void | SetGameStats (int maxLevel, int hitCount, int shotCount)
void | SetLevelStart (int level, Platform::String^objective, float timeLimit, float bonusTime)
void | SetPause (int level, int hitCount, int shotCount, float timeRemaining)
void | SetProductItems (Windows::ApplicationModel::Store::ListingInformation^listing, Windows::ApplicationModel::Store::LicenseInformation^license)
void | SetSnapped ()
void | ShowGameInfoOverlay ()
void | UpdateContent (Windows::ApplicationModel::Store::ListingInformation^listing)

Public Attributes

internal | __pad0__: ProductItem( Windows::ApplicationModel::Store::ListingInformation^ listing
internal
Windows::ApplicationModel::Store::LicenseInformation
Platform::String bool 		isApp
internal
Windows::ApplicationModel::Store::LicenseInformation 		license
internal
Windows::ApplicationModel::Store::LicenseInformation
Platform::String 		productId
virtual event
Windows::UI::Xaml::Data::PropertyChangedEventHandler 		PropertyChanged

Protected Member Functions

void | OnAppBarOpened (Object^sender, Object^args)
void | OnBuyAppButtonTapped (Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^args)
void | OnBuySelectorClicked (Object^sender, Windows::UI::Xaml::RoutedEventArgs^args)
void | OnChangeBackgroundButtonClicked (Object^sender, Windows::UI::Xaml::RoutedEventArgs^args)
void | OnGameInfoOverlayTapped (Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^args)
void | OnLoadStoreClicked (Object^sender, Windows::UI::Xaml::RoutedEventArgs^args)
void | OnPlayButtonClicked (Object^sender, Windows::UI::Xaml::RoutedEventArgs^args)
void | OnResetButtonClicked (Object^sender, Windows::UI::Xaml::RoutedEventArgs^args)
void | OnResetLicenseButtonClicked (Object^sender, Windows::UI::Xaml::RoutedEventArgs^args)
void | OnStoreReturnClicked (Object^sender, Windows::UI::Xaml::RoutedEventArgs^args)
void | OptionalTrialUpgrade ()
void | ShowStoreFlyout ()

Private Member Functions

~App ()
void | HideGameInfoOverlay ()
void | HideSnapped ()
void | InitializeGameState ()
void | InitializeLicense ()
void | InitializeLicenseCore ()
void | OnDeviceLost ()
void | OnDeviceReset ()
void | OnDisplayContentsInvalidated (_In_ Platform::Object^sender)
void | OnLicenseChanged ()
void | OnLogicalDpiChanged (_In_ Platform::Object^sender)
void | OnRendering (_In_ Object^sender, _In_ Object^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnVisibilityChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args)
void | OnWindowActivationChanged (_In_ Platform::Object^sender, _In_ Windows::UI::Core::WindowActivatedEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | SetAction (GameInfoOverlayCommand command)
void | SetGameInfoOverlay (GameInfoOverlayState state)
void | SetSnapped ()
void | SetStatus (Windows::ApplicationModel::Store::LicenseInformation^license)
void | ShowGameInfoOverlay ()
void | Update ()
void | UpdateViewState ()

Private Attributes

App | m_app
MoveLookController m_controller
Platform::String | m_foreground
Platform::String | m_formattedPrice
Simple3DGame m_game
GameInfoOverlayState m_gameInfoOverlayState
bool | m_haveFocus
bool | m_isApp
bool | m_isAppActive
bool | m_isAppTrial
bool | m_isAvailableForPurchase
bool | m_isProductActive
bool | m_isTrial
Windows::ApplicationModel::Store::LicenseInformation | m_licenseInformation
PersistentState m_licenseState
Windows::ApplicationModel::Store::ListingInformation | m_listingInformation
MainPage | m_mainPage
Windows::Foundation::EventRegistrationToken | m_onRenderingEventToken
bool | m_pauseRequested
bool | m_possiblePurchaseUpgrade
bool | m_pressComplete
PressResultState m_pressResult
Platform::String | m_productId
GameRenderer m_renderer
bool | m_renderNeeded
Platform::String | m_status
Platform::String | m_title
UpdateEngineState m_updateState
UpdateEngineState m_updateStateNext
bool | m_visible

Detailed Description

Definition at line 91 of file App.xaml.h.

Constructor & Destructor Documentation

Simple3DGameXaml::sealed::~App ( ) [private]

Member Function Documentation

Simple3DGameXaml::sealed::App ( )
void Simple3DGameXaml::sealed::CycleBackground ( )
Windows::UI::Xaml::Controls::SwapChainBackgroundPanel Simple3DGameXaml::sealed::GetSwapChainBackgroundPanel ( ) [inline]

Definition at line 52 of file MainPage.xaml.h.

{ return DXSwapChainPanel; };

void Simple3DGameXaml::sealed::HideGameInfoOverlay ( )
void Simple3DGameXaml::sealed::HideGameInfoOverlay ( ) [private]
void Simple3DGameXaml::sealed::HideSnapped ( )
void Simple3DGameXaml::sealed::HideSnapped ( ) [private]
void Simple3DGameXaml::sealed::InitializeGameState ( ) [private]
void Simple3DGameXaml::sealed::InitializeLicense ( ) [private]
void Simple3DGameXaml::sealed::InitializeLicenseCore ( ) [private]
void Simple3DGameXaml::sealed::LicenseChanged | ( | Windows::ApplicationModel::Store::ListingInformation^ | listing,
 |  | Windows::ApplicationModel::Store::LicenseInformation^ | license
 | ) |  |
Simple3DGameXaml::sealed::MainPage ( )
void Simple3DGameXaml::sealed::OnAppBarOpened | ( | Object^ | sender,
 |  | Object^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnBuyAppButtonTapped | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnBuySelectorClicked | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnChangeBackgroundButtonClicked | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnDeviceLost ( ) [private]
void Simple3DGameXaml::sealed::OnDeviceReset ( ) [private]
void Simple3DGameXaml::sealed::OnDisplayContentsInvalidated ( _In_ Platform::Object^ sender ) [private]
void Simple3DGameXaml::sealed::OnGameInfoOverlayTapped | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Input::TappedRoutedEventArgs^ | args |
 | ) |  |  | [protected]
virtual void Simple3DGameXaml::sealed::OnLaunched ( _In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
void Simple3DGameXaml::sealed::OnLicenseChanged ( ) [private]
void Simple3DGameXaml::sealed::OnLoadStoreClicked | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnLogicalDpiChanged ( _In_ Platform::Object^ sender ) [private]
void Simple3DGameXaml::sealed::OnPlayButtonClicked | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnRendering | ( | _In_ Object^ | sender,
 |  | _In_ Object^ | args |
 | ) |  |  | [private]
void Simple3DGameXaml::sealed::OnResetButtonClicked | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnResetLicenseButtonClicked | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args |
 | ) |  |  | [private]
void Simple3DGameXaml::sealed::OnStoreReturnClicked | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | args |
 | ) |  |  | [protected]
void Simple3DGameXaml::sealed::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args |
 | ) |  |  | [private]
void Simple3DGameXaml::sealed::OnVisibilityChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::VisibilityChangedEventArgs^ | args |
 | ) |  |  | [private]
void Simple3DGameXaml::sealed::OnWindowActivationChanged | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::UI::Core::WindowActivatedEventArgs^ | args |
 | ) |  |  | [private]
void Simple3DGameXaml::sealed::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args |
 | ) |  |  | [private]
void Simple3DGameXaml::sealed::OnWindowSizeChanged ( )
void Simple3DGameXaml::sealed::OptionalTrialUpgrade ( ) [protected]
void Simple3DGameXaml::sealed::PauseRequested ( ) [inline]

Definition at line 100 of file App.xaml.h.

{ if (m_updateState == UpdateEngineState::Dynamics) m_pauseRequested = true; };

void Simple3DGameXaml::sealed::PressComplete ( ) [inline]

Definition at line 101 of file App.xaml.h.

{ if (m_updateState == UpdateEngineState::WaitingForPress) m_pressComplete = true; };

void Simple3DGameXaml::sealed::ResetGame ( )
void Simple3DGameXaml::sealed::ResetLicense ( )
void Simple3DGameXaml::sealed::SetAction ( GameInfoOverlayCommand action )
void Simple3DGameXaml::sealed::SetAction ( GameInfoOverlayCommand command ) [private]
void Simple3DGameXaml::sealed::SetApp ( App^ app )
void Simple3DGameXaml::sealed::SetBackground ( unsigned int background )
void Simple3DGameXaml::sealed::SetGameInfoOverlay ( GameInfoOverlayState state ) [private]
void Simple3DGameXaml::sealed::SetGameLoading ( )
void Simple3DGameXaml::sealed::SetGameOver | ( | bool | win,
 |  | int | maxLevel,
 |  | int | hitCount,
 |  | int | shotCount,
 |  | int | highScore
 | ) |  |
void Simple3DGameXaml::sealed::SetGameStats | ( | int | maxLevel,
 |  | int | hitCount,
 |  | int | shotCount
 | ) |  |
void Simple3DGameXaml::sealed::SetLevelStart | ( | int | level,
 |  | Platform::String^ | objective,
 |  | float | timeLimit,
 |  | float | bonusTime
 | ) |  |
void Simple3DGameXaml::sealed::SetPause | ( | int | level,
 |  | int | hitCount,
 |  | int | shotCount,
 |  | float | timeRemaining
 | ) |  |
void Simple3DGameXaml::sealed::SetProductItems | ( | Windows::ApplicationModel::Store::ListingInformation^ | listing,
 |  | Windows::ApplicationModel::Store::LicenseInformation^ | license
 | ) |  |
void Simple3DGameXaml::sealed::SetSnapped ( )
void Simple3DGameXaml::sealed::SetSnapped ( ) [private]
void Simple3DGameXaml::sealed::SetStatus ( Windows::ApplicationModel::Store::LicenseInformation^ license ) [private]
void Simple3DGameXaml::sealed::ShowGameInfoOverlay ( )
void Simple3DGameXaml::sealed::ShowGameInfoOverlay ( ) [private]
void Simple3DGameXaml::sealed::ShowStoreFlyout ( ) [protected]
void Simple3DGameXaml::sealed::Update ( ) [private]
void Simple3DGameXaml::sealed::UpdateContent ( Windows::ApplicationModel::Store::ListingInformation^ listing )
void Simple3DGameXaml::sealed::UpdateViewState ( ) [private]

Member Data Documentation

internal Simple3DGameXaml::sealed::__pad0__

Definition at line 19 of file ProductItem.h.

internal Windows::ApplicationModel::Store::LicenseInformation Platform::String bool Simple3DGameXaml::sealed::isApp

Definition at line 19 of file ProductItem.h.

internal Windows::ApplicationModel::Store::LicenseInformation Simple3DGameXaml::sealed::license

Definition at line 19 of file ProductItem.h.

App Simple3DGameXaml::sealed::m_app [private]

Definition at line 70 of file MainPage.xaml.h.

MoveLookController Simple3DGameXaml::sealed::m_controller [private]

Definition at line 176 of file App.xaml.h.

Platform::String Simple3DGameXaml::sealed::m_foreground [private]

Definition at line 87 of file ProductItem.h.

Platform::String Simple3DGameXaml::sealed::m_formattedPrice [private]

Definition at line 84 of file ProductItem.h.

Simple3DGame Simple3DGameXaml::sealed::m_game [private]

Definition at line 178 of file App.xaml.h.

GameInfoOverlayState Simple3DGameXaml::sealed::m_gameInfoOverlayState [private]

Definition at line 183 of file App.xaml.h.

bool Simple3DGameXaml::sealed::m_haveFocus [private]

Definition at line 172 of file App.xaml.h.

bool Simple3DGameXaml::sealed::m_isApp [private]

Definition at line 88 of file ProductItem.h.

bool Simple3DGameXaml::sealed::m_isAppActive [private]

Definition at line 89 of file ProductItem.h.

bool Simple3DGameXaml::sealed::m_isAppTrial [private]

Definition at line 90 of file ProductItem.h.

bool Simple3DGameXaml::sealed::m_isAvailableForPurchase [private]

Definition at line 92 of file ProductItem.h.

bool Simple3DGameXaml::sealed::m_isProductActive [private]

Definition at line 91 of file ProductItem.h.

bool Simple3DGameXaml::sealed::m_isTrial [private]

Definition at line 188 of file App.xaml.h.

Windows::ApplicationModel::Store::LicenseInformation sealed::m_licenseInformation [private]

Definition at line 184 of file App.xaml.h.

PersistentState Simple3DGameXaml::sealed::m_licenseState [private]

Definition at line 187 of file App.xaml.h.

Windows::ApplicationModel::Store::ListingInformation sealed::m_listingInformation [private]

Definition at line 185 of file App.xaml.h.

MainPage Simple3DGameXaml::sealed::m_mainPage [private]

Definition at line 175 of file App.xaml.h.

Windows::Foundation::EventRegistrationToken Simple3DGameXaml::sealed::m_onRenderingEventToken [private]

Definition at line 168 of file App.xaml.h.

bool Simple3DGameXaml::sealed::m_pauseRequested [private]

Definition at line 169 of file App.xaml.h.

bool Simple3DGameXaml::sealed::m_possiblePurchaseUpgrade [private]

Definition at line 73 of file MainPage.xaml.h.

bool Simple3DGameXaml::sealed::m_pressComplete [private]

Definition at line 170 of file App.xaml.h.

PressResultState Simple3DGameXaml::sealed::m_pressResult [private]

Definition at line 182 of file App.xaml.h.

Platform::String Simple3DGameXaml::sealed::m_productId [private]

Definition at line 85 of file ProductItem.h.

GameRenderer Simple3DGameXaml::sealed::m_renderer [private]

Definition at line 177 of file App.xaml.h.

bool Simple3DGameXaml::sealed::m_renderNeeded [private]

Definition at line 171 of file App.xaml.h.

Platform::String Simple3DGameXaml::sealed::m_status [private]

Definition at line 86 of file ProductItem.h.

Platform::String Simple3DGameXaml::sealed::m_title [private]

Definition at line 83 of file ProductItem.h.

UpdateEngineState Simple3DGameXaml::sealed::m_updateState [private]

Definition at line 180 of file App.xaml.h.

UpdateEngineState Simple3DGameXaml::sealed::m_updateStateNext [private]

Definition at line 181 of file App.xaml.h.

bool Simple3DGameXaml::sealed::m_visible [private]

Definition at line 173 of file App.xaml.h.

internal Windows::ApplicationModel::Store::LicenseInformation Platform::String Simple3DGameXaml::sealed::productId

Definition at line 19 of file ProductItem.h.

virtual event Windows::UI::Xaml::Data::PropertyChangedEventHandler Simple3DGameXaml::sealed::PropertyChanged

Definition at line 26 of file ProductItem.h.

The documentation for this class was generated from the following files:
  • XAML DirectX 3D shooting game/C++/App.xaml.h
  • XAML DirectX 3D shooting game/C++/MainPage.xaml.h
  • XAML DirectX 3D shooting game/C++/ProductItem.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Simple3DTouch Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

Simple3DTouch Class Reference

#include "Simple3DTouch.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
void | LoadInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
virtual void | Render () override
void | SaveInternalState (_In_ Windows::Foundation::Collections::IPropertySet^state)
void | Update (float TimeTotal, float TimeDelta)

Public Attributes

internal | __pad0__: Simple3DTouch()

Private Attributes

BasicCamera m_camera
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
MoveLookController m_controller
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
unsigned int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_lookControlLayout
DWRITE_TEXT_METRICS | m_lookMetrics
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_moveControlLayout
DWRITE_TEXT_METRICS | m_moveMetrics
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_texture
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureSRV
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 27 of file Simple3DTouch.h.

Member Function Documentation

void Simple3DTouch::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 22 of file Simple3DTouch.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Allocate and initialize a controller object
    m_controller = ref new MoveLookController();
    m_controller->Initialize(m_window.Get());
    m_controller->SetPosition(START_POSITION);

    // Create a TextFormat for use in displaying the text to delineate the move / look control areas.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            15.0f,
            L"en-us",
            &m_textFormat
            )
        );

    DX::ThrowIfFailed(m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
    DX::ThrowIfFailed(m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
}

void Simple3DTouch::CreateDeviceResources ( ) [override, virtual]

Definition at line 49 of file Simple3DTouch.cpp.

{
    DirectXBase::CreateDeviceResources();

    // Allocate and initialize the sample header
    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "DirectX touch input sample"
        );

    // Create D2D brush for drawing the overlay to show the Move control box.
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &m_textBrush
            )
        );

    // Start loading assets
    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    loader->LoadShader(
        L"SimpleVertexShader.cso",
        nullptr,
        0,
        &m_vertexShader,
        &m_inputLayout
        );

    // create the vertex and index buffers for drawing the cube

    BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());

    shapes->CreateBox(
        ROOM_BOUNDS,
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // create the constant buffer for updating model and camera data
    CD3D11_BUFFER_DESC constantBufferDesc(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
        &constantBufferDesc,
        nullptr,             // leave the buffer uninitialized
        &m_constantBuffer
        )
        );

    loader->LoadShader(
        L"SimplePixelShader.cso",
        &m_pixelShader
        );

    loader->LoadTexture(
        L"texture.dds",
        &m_texture,
        &m_textureSRV
        );

    // create the sampler
    D3D11_SAMPLER_DESC samplerDesc;
    ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
    samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDesc.MipLODBias = 0.0f;
    samplerDesc.MaxAnisotropy = m_featureLevel >= D3D_FEATURE_LEVEL_9_2 ? 4 : 2;
    samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDesc.BorderColor[0] = 0.0f;
    samplerDesc.BorderColor[1] = 0.0f;
    samplerDesc.BorderColor[2] = 0.0f;
    samplerDesc.BorderColor[3] = 0.0f;
    // allow use of all mip levels
    samplerDesc.MinLOD = 0;
    samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
        &samplerDesc,
        &m_sampler)
        );

    // create the scene camera
    m_camera = ref new BasicCamera();

}

void Simple3DTouch::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 145 of file Simple3DTouch.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // Initialize

    // allocate and initialize the scene camera
    m_camera = ref new BasicCamera();

    // specify the 3D projection matrix
    m_camera->SetProjectionParameters(
        70.0f,                                                  // use a 70-degree vertical field of view
        m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
        0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
        100.0f                                                  // specify the farthest Z-distance at which to draw vertices
        );

    // save the new projection matrix to the constant buffer data struct
    m_camera->GetProjectionMatrix(&m_constantBufferData.projection);

    m_sampleOverlay->UpdateForWindowSizeChange();

    // Create the text layouts for the strings to delineate the move / look control areas.
    static Platform::String^ moveString = "Move Touch Control Area";
    static Platform::String^ lookString = "Look Touch Control Area";

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            moveString->Data(),
            moveString->Length(),
            m_textFormat.Get(),
            m_windowBounds.Width,
            m_windowBounds.Height,
            &m_moveControlLayout
            )
        );
    DX::ThrowIfFailed(
        m_moveControlLayout->GetMetrics(&m_moveMetrics)
        );

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextLayout(
            lookString->Data(),
            lookString->Length(),
            m_textFormat.Get(),
            m_windowBounds.Width,
            m_windowBounds.Height,
            &m_lookControlLayout
            )
        );
    DX::ThrowIfFailed(
        m_lookControlLayout->GetMetrics(&m_lookMetrics)
        );
}

void Simple3DTouch::LoadInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state )
void Simple3DTouch::Render ( ) [override, virtual]

Definition at line 200 of file Simple3DTouch.cpp.

{
    UINT stride = sizeof(BasicVertex);
    UINT offset = 0;

    // bind the render targets
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get());

    // clear both the render target and depth stencil to default values
    const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        ClearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    // set the vertex and index buffers, and specify the way they define geometry
    m_d3dContext->IASetVertexBuffers(
        0,                              // starting at the first vertex buffer slot
        1,                              // set one vertex buffer binding
        m_vertexBuffer.GetAddressOf(),
        &stride,                        // specify the size in bytes of a single vertex
        &offset                         // specify the base vertex in the buffer
        );

    // set the index buffer
    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,   // unsigned short index format
        0                       // specify the base index in the buffer
        );

    // specify the way the vertex and index buffers define geometry
    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    // set the vertex shader stage state
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                              // starting at the first constant buffer slot
        1,                              // set one constant buffer binding
        m_constantBuffer.GetAddressOf()
        );

    // set the pixel shader stage state
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->PSSetShaderResources(
        0,                          // starting at the first shader resource slot
        1,                          // set one shader resource binding
        m_textureSRV.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,                          // starting at the first sampler slot
        1,                          // set one sampler binding
        m_sampler.GetAddressOf()
        );

    // draw the cube
    m_d3dContext->DrawIndexed(
        m_indexCount,   // draw all created vertices
        0,              // starting with the first vertex
        0               // and the first index
        );

    m_d2dContext->BeginDraw();
    // Draw the text to delineate the move / look control areas.

    D2D1_POINT_2F moveTextPosition;
    D2D1_POINT_2F lookTextPosition;

    if (m_windowBounds.Width < MoveLookControllerConstants::MoveMaxXCoordinate)
    {
        // The move control spans across the bottom so center the text
        // and stack it.
        moveTextPosition.x = (m_windowBounds.Width - m_moveMetrics.width) / 2.0f;
        moveTextPosition.y = m_windowBounds.Height - (m_moveMetrics.height + 5.0f);

        lookTextPosition.x = (m_windowBounds.Width - m_lookMetrics.width) / 2.0f;
        lookTextPosition.y = MoveLookControllerConstants::MoveMinYCoordinate - (m_lookMetrics.height + 5.0f);
    }
    else
    {
        // Draw the text on the bottom edge centered in each region.
        moveTextPosition.x = (MoveLookControllerConstants::MoveMaxXCoordinate - m_moveMetrics.width) / 2.0f;
        moveTextPosition.y = m_windowBounds.Height - (m_moveMetrics.height + 5.0f);

        lookTextPosition.x = MoveLookControllerConstants::MoveMaxXCoordinate + (m_windowBounds.Width - MoveLookControllerConstants::MoveMaxXCoordinate - m_lookMetrics.width) / 2.0f;
        lookTextPosition.y = m_windowBounds.Height - (m_lookMetrics.height + 5.0f);
    }

    m_d2dContext->DrawTextLayout(
        moveTextPosition,
        m_moveControlLayout.Get(),
        m_textBrush.Get()
        );

    m_d2dContext->DrawTextLayout(
        lookTextPosition,
        m_lookControlLayout.Get(),
        m_textBrush.Get()
        );

    // Draw a rectangle for the touch input for the move control.
    m_d2dContext->DrawRectangle(
        D2D1::RectF(
            0.0f,
            MoveLookControllerConstants::MoveMinYCoordinate,
            MoveLookControllerConstants::MoveMaxXCoordinate,
            m_windowBounds.Height
            ),
        m_textBrush.Get()
        );

    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        // The D2DERR_RECREATE_TARGET indicates there has been a problem with the underlying
        // D3D device.  All subsequent rendering will be ignored until the device is recreated.
        // This error will be propagated and the appropriate D3D error will be returned from the
        // swapchain->Present(...) call.   At that point the sample will recreate the device
        // and all associated resources.  As a result the D2DERR_RECREATE_TARGET doesn't
        // need to be handled here.
        DX::ThrowIfFailed(hr);
    }

    m_sampleOverlay->Render();

}

void Simple3DTouch::SaveInternalState ( _In_ Windows::Foundation::Collections::IPropertySet^ state )
void Simple3DTouch::Update | ( | float | TimeTotal,
 |  | float | TimeDelta
 | ) |  |

Definition at line 351 of file Simple3DTouch.cpp.

{

    // update the model matrix based on the time
    m_constantBufferData.model = identity(); // rotationY(-TimeTotal * 60.0f);

    m_controller->Update(m_window.Get());

    float3 camPosition = m_controller->GetPosition();

    // limit position to inside cell to keep from getting lost
    float3 halfBound = ROOM_BOUNDS;
    float3 radius = float3(0.1f, 0.1f, 0.1f);
    halfBound = halfBound - radius;

    if (camPosition.x > halfBound.x)
    {
        camPosition.x = halfBound.x;
    }
    else if (camPosition.x < -halfBound.x)
    {
        camPosition.x = -halfBound.x;
    }

    if (camPosition.y > halfBound.y)
    {
        camPosition.y = halfBound.y;
    }
    else if (camPosition.y < -halfBound.y)
    {
        camPosition.y = -halfBound.y;
    }

    if (camPosition.z > halfBound.z)
    {
        camPosition.z = halfBound.z;
    }
    else if (camPosition.z < -halfBound.z)
    {
        camPosition.z = -halfBound.z;
    }

    // notify controller that we clamped its result
    m_controller->SetPosition(camPosition);

    // update the view matrix based on the camera position
    m_camera->SetViewParameters(
        m_controller->GetPosition(),        // point we are at
        m_controller->GetLookPoint(),       // point to look towards
        float3(0, 1, 0)                     // up-vector
        );

    // get the camera transform for transmission to the GPU
    m_camera->GetViewMatrix(&m_constantBufferData.view);

    // update the constant buffer with the new data
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_constantBufferData,
        0,
        0
        );
}

Member Data Documentation

internal Simple3DTouch::__pad0__

Definition at line 30 of file Simple3DTouch.h.

BasicCamera Simple3DTouch::m_camera [private]

Definition at line 58 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> Simple3DTouch::m_constantBuffer [private]

Definition at line 54 of file Simple3DTouch.h.

ConstantBuffer Simple3DTouch::m_constantBufferData [private]

Definition at line 57 of file Simple3DTouch.h.

MoveLookController Simple3DTouch::m_controller [private]

Definition at line 59 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> Simple3DTouch::m_indexBuffer [private]

Definition at line 48 of file Simple3DTouch.h.

unsigned int Simple3DTouch::m_indexCount [private]

Definition at line 56 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> Simple3DTouch::m_inputLayout [private]

Definition at line 46 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> Simple3DTouch::m_lookControlLayout [private]

Definition at line 66 of file Simple3DTouch.h.

DWRITE_TEXT_METRICS Simple3DTouch::m_lookMetrics [private]

Definition at line 67 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> Simple3DTouch::m_moveControlLayout [private]

Definition at line 64 of file Simple3DTouch.h.

DWRITE_TEXT_METRICS Simple3DTouch::m_moveMetrics [private]

Definition at line 65 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> Simple3DTouch::m_pixelShader [private]

Definition at line 50 of file Simple3DTouch.h.

SampleOverlay Simple3DTouch::m_sampleOverlay [private]

Definition at line 44 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> Simple3DTouch::m_sampler [private]

Definition at line 53 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> Simple3DTouch::m_textBrush [private]

Definition at line 61 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> Simple3DTouch::m_textFormat [private]

Definition at line 62 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> Simple3DTouch::m_texture [private]

Definition at line 51 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> Simple3DTouch::m_textureSRV [private]

Definition at line 52 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> Simple3DTouch::m_vertexBuffer [private]

Definition at line 47 of file Simple3DTouch.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> Simple3DTouch::m_vertexShader [private]

Definition at line 49 of file Simple3DTouch.h.

The documentation for this class was generated from the following files:
  • DirectX touch input/C++/Simple3DTouch.h
  • DirectX touch input/C++/Simple3DTouch.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleBlogReader::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleBlogReader
  • SimpleBlogReader::sealed
Public Member Functions | Static Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

SimpleBlogReader::sealed Class Reference

Provides application-specific behavior to supplement the default Application class. More...

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
virtual Platform::Object | Convert (Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language)
virtual Platform::Object | ConvertBack (Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language)
FeedData (void)
FeedDataSource ()
FeedItem (void)
ItemsPage ()
MainPage ()
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
SplitPage ()

Static Public Member Functions

static
Windows::Foundation::IAsyncOperation
< FeedData^> 		GetFeedAsync (Platform::String^title)
static FeedItem | GetFeedItem (FeedData^fd, Platform::String^uniqueiD)

Protected Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState) override
virtual void | GoBack (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) override
virtual void | ItemView_ItemClick (Platform::Object^sender, Windows::UI::Xaml::Controls::ItemClickEventArgs^e)
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | LoadState (Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | SaveState (Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override
void | ViewDetail_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Properties

Platform::String | Author
Platform::String | Content
Platform::String | CurrentFeedUri
Windows::Foundation::Uri | Link
Windows::Foundation::DateTime | PubDate
Platform::String | Title
Platform::String | Uri

Private Member Functions

~FeedData (void)
~FeedItem (void)
FeedData | GetFeedData (Platform::String^feedUri, Windows::Web::Syndication::SyndicationFeed^feed)
void | GetFeedData (Platform::String^feedUriString)
void | ItemListView_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | ItemListView_SelectionChanged (Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^e)
void | PageLoadedHandler (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
bool | UsingLogicalPageNavigation (Windows::UI::ViewManagement::ApplicationViewState viewState)
bool | UsingLogicalPageNavigation ()

Private Attributes

FeedData | feedData
std::map< Platform::String^,
concurrency::task_completion_event
< FeedData^> > 		m_feedCompletionEvents
Platform::Collections::Vector
< FeedData^> 		m_feeds
Platform::Collections::Vector
< FeedItem^> 		m_items

Detailed Description

A page that displays a group title, a list of items within the group, and details for the currently selected item.

An empty page that can be used on its own or navigated to within a Frame.

A page that displays a collection of item previews.

In the Split Application this page is used to display and select one of the available groups.

Definition at line 22 of file App.xaml.h.

Constructor & Destructor Documentation

SimpleBlogReader::sealed::~FeedItem ( void ) [inline, private]

Definition at line 34 of file FeedData.h.

{}

SimpleBlogReader::sealed::~FeedData ( void ) [inline, private]

Definition at line 61 of file FeedData.h.

{}

Member Function Documentation

SimpleBlogReader::sealed::App ( )
virtual Platform::Object SimpleBlogReader::sealed::Convert | ( | Platform::Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Platform::Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [inline, virtual]

Definition at line 19 of file DateConverter.h.

        {
            if (value == nullptr)
            {
                throw ref new Platform::InvalidArgumentException();
            }
            Windows::Foundation::DateTime dt = (Windows::Foundation::DateTime) value;
            Platform::String^ param = safe_cast<Platform::String^>(parameter);
            Platform::String^ result;

            // This is called by the items page which requires simple formatting.
            if (param == nullptr)
            {
                Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ dtf =
                        Windows::Globalization::DateTimeFormatting::DateTimeFormatter::ShortDate::get();
                result = dtf->Format(dt);
            }

            // These are called by the split page to format each date element separately:
            else if (wcscmp(param->Data(), L"month") == 0)
            {
                Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ month =
                    ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("{month.abbreviated(3)}");
                result = month->Format(dt);
            }
            else if (wcscmp(param->Data(), L"day") == 0)
            {
                Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ month =
                    ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("{day.integer(2)}");
                result = month->Format(dt);
            }
            else if (wcscmp(param->Data(), L"year") == 0)
            {
                Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ month =
                    ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("{year.full}");
                result = month->Format(dt);
            }
            else
            {
                // We don't handle other format types currently.
                throw ref new Platform::InvalidArgumentException();
            }

            return result;
        }

virtual Platform::Object SimpleBlogReader::sealed::ConvertBack | ( | Platform::Object^ | value,
 |  | Windows::UI::Xaml::Interop::TypeName | targetType,
 |  | Platform::Object^ | parameter,
 |  | Platform::String^ | language |
 | ) |  |  | [inline, virtual]

Definition at line 68 of file DateConverter.h.

        {
            // Not needed in SimpleBlogReader. Left as an exercise.
            throw ref new Platform::NotImplementedException();
        }

virtual Platform::String SimpleBlogReader::sealed::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [override, protected, virtual]
SimpleBlogReader::sealed::FeedData ( void ) [inline]

Definition at line 43 of file FeedData.h.

        {
            m_items = ref new Platform::Collections::Vector<FeedItem^>();
        }

SimpleBlogReader::sealed::FeedDataSource ( )
SimpleBlogReader::sealed::FeedItem ( void ) [inline]

Definition at line 25 of file FeedData.h.

{}

static Windows::Foundation::IAsyncOperation<FeedData^> SimpleBlogReader::sealed::GetFeedAsync ( Platform::String^ title ) [static]
void SimpleBlogReader::sealed::GetFeedData ( Platform::String^ feedUriString ) [private]
FeedData SimpleBlogReader::sealed::GetFeedData | ( | Platform::String^ | feedUri,
 |  | Windows::Web::Syndication::SyndicationFeed^ | feed |
 | ) |  |  | [private]
static FeedItem SimpleBlogReader::sealed::GetFeedItem | ( | FeedData^ | fd,
 |  | Platform::String^ | uniqueiD |
 | ) |  |  | [static]
virtual void SimpleBlogReader::sealed::GoBack | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [override, protected, virtual]
void SimpleBlogReader::sealed::ItemListView_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
void SimpleBlogReader::sealed::ItemListView_SelectionChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [private]
SimpleBlogReader::sealed::ItemsPage ( )
virtual void SimpleBlogReader::sealed::ItemView_ItemClick | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::Controls::ItemClickEventArgs^ | e |
 | ) |  |  | [protected, virtual]
virtual void SimpleBlogReader::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
virtual void SimpleBlogReader::sealed::LoadState | ( | Platform::Object^ | navigationParameter,
 |  | Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ | pageState |
 | ) |  |  | [override, protected, virtual]
SimpleBlogReader::sealed::MainPage ( )
virtual void SimpleBlogReader::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]
virtual void SimpleBlogReader::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void SimpleBlogReader::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | e |
 | ) |  |  | [private]
void SimpleBlogReader::sealed::PageLoadedHandler | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
virtual void SimpleBlogReader::sealed::SaveState ( Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^ pageState ) [override, protected, virtual]
SimpleBlogReader::sealed::SplitPage ( )
bool SimpleBlogReader::sealed::UsingLogicalPageNavigation ( ) [private]
bool SimpleBlogReader::sealed::UsingLogicalPageNavigation ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [private]
void SimpleBlogReader::sealed::ViewDetail_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [protected]

Member Data Documentation

FeedData SimpleBlogReader::sealed::feedData [private]

Definition at line 38 of file MainPage.xaml.h.

std::map<Platform::String^, concurrency::task_completion_event<FeedData^> > SimpleBlogReader::sealed::m_feedCompletionEvents [private]

Definition at line 76 of file FeedData.h.

Platform::Collections::Vector<FeedData^> SimpleBlogReader::sealed::m_feeds [private]

Definition at line 75 of file FeedData.h.

Platform::Collections::Vector<FeedItem^> SimpleBlogReader::sealed::m_items [private]

Definition at line 63 of file FeedData.h.

Property Documentation

Platform::String SimpleBlogReader::sealed::Author

Definition at line 28 of file FeedData.h.

Platform::String SimpleBlogReader::sealed::Content

Definition at line 29 of file FeedData.h.

Platform::String SimpleBlogReader::sealed::CurrentFeedUri

Definition at line 27 of file App.xaml.h.

Windows::Foundation::Uri SimpleBlogReader::sealed::Link

Definition at line 31 of file FeedData.h.

Windows::Foundation::DateTime sealed::PubDate

Definition at line 30 of file FeedData.h.

Platform::String sealed::Title

Definition at line 27 of file FeedData.h.

Platform::String SimpleBlogReader::sealed::Uri

Definition at line 58 of file FeedData.h.

The documentation for this class was generated from the following files:
  • Getting started with C++ simple blog reader/C++/App.xaml.h
  • Getting started with C++ simple blog reader/C++/FeedData.h
  • Getting started with C++ simple blog reader/C++/MainPage.xaml.h
  • Getting started with C++ simple blog reader/C++/DateConverter.h
  • Getting started with C++ simple blog reader/C++/ItemsPage.xaml.h
  • Getting started with C++ simple blog reader/C++/SplitPage.xaml.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::App
Public Member Functions | Public Attributes | Private Member Functions

SimpleCommunication::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()

Private Member Functions

void | SetupWindowing (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs)

Detailed Description

Definition at line 24 of file App.xaml.h.

Member Function Documentation

void App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]

Definition at line 44 of file App.xaml.cpp.

{
    if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
    {
        SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
        {
            try
            {
                restoreTask.get();
            }
            catch(Platform::Exception^)
            {
                // If restore fails, the app should proceed as though there was no restored state.
            }

            SetupWindowing(pArgs);
        });
    }
    else
    {
        SetupWindowing(pArgs);
    }
}

void App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]

Definition at line 35 of file App.xaml.cpp.

{
    auto deferral = pArgs->SuspendingOperation->GetDeferral();
    SuspensionManager::StartSaveTask().then([=]()
    {
        deferral->Complete();
    });
}

void App::SetupWindowing ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [private]

Definition at line 68 of file App.xaml.cpp.

{
    if (Window::Current->Content == nullptr)
    {
        auto rootFrame = ref new Frame();
        TypeName pageType = { "SimpleCommunication.MainPage", TypeKind::Custom };
        rootFrame->Navigate(pageType);
        Window::Current->Content = rootFrame;
    }
    Window::Current->Activate();
}

Member Data Documentation

internal SimpleCommunication::App::__pad0__

Definition at line 27 of file App.xaml.h.

The documentation for this class was generated from the following files:
  • Real-time communication/C++/App.xaml.h
  • Real-time communication/C++/App.xaml.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::CaptureFailedEventArgs Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::CaptureFailedEventArgs
Public Member Functions | Public Attributes | Properties

SimpleCommunication::CaptureFailedEventArgs Class Reference

#include "Utils.h"

List of all members.

Public Member Functions

internal Platform::String | _message (message)

Public Attributes

internal | __pad0__: CaptureFailedEventArgs(HRESULT code
internal Platform::String | message: _code(code)

Properties

Platform::String | _message

Detailed Description

Definition at line 20 of file Utils.h.

Member Function Documentation

internal Platform::String SimpleCommunication::CaptureFailedEventArgs::_message ( message ) [inline]

Definition at line 25 of file Utils.h.

        {
        }

Member Data Documentation

internal SimpleCommunication::CaptureFailedEventArgs::__pad0__

Definition at line 23 of file Utils.h.

internal Platform::String SimpleCommunication::CaptureFailedEventArgs::message

Definition at line 23 of file Utils.h.

Property Documentation

Platform::String SimpleCommunication::CaptureFailedEventArgs::_message

Definition at line 40 of file Utils.h.

The documentation for this class was generated from the following file:
  • Real-time communication/C++/Utils.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::Common::CaptureDevice Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • Common
  • SimpleCommunication::Common::CaptureDevice
Public Member Functions | Static Public Member Functions | Properties | Events | Private Member Functions | Private Attributes

SimpleCommunication::Common::CaptureDevice Class Reference

List of all members.

Public Member Functions

CaptureDevice ()
async Task | CleanUpAsync ()
async Task | InitializeAsync ()
async Task
< IMediaEncodingProperties > 		SelectPreferredCameraStreamSettingAsync (MediaStreamType mediaStreamType, Func< IMediaEncodingProperties, bool > filterSettings)
async Task | StartRecordingAsync (MediaEncodingProfile encodingProfile)
async Task | StopRecordingAsync ()

Static Public Member Functions

static async Task< bool > | CheckForRecordingDeviceAsync ()

Properties

MediaCapture | CaptureSource [get]

Events

EventHandler
< MediaCaptureFailedEventArgs > 		CaptureFailed
EventHandler
< IncomingConnectionEventArgs > 		IncomingConnectionArrived

Private Member Functions

void | CleanupSink ()
void | DoCleanup ()
void | mediaCapture_Failed (MediaCapture sender, MediaCaptureFailedEventArgs errorEventArgs)
void | mediaSink_IncomingConnectionEvent (StspMediaSink sender, IncomingConnectionEventArgs args)

Private Attributes

bool | forwardEvents = false
MediaCapture | mediaCapture
StspMediaSink | mediaSink
bool | recordingStarted = false

Detailed Description

Definition at line 14 of file CaptureDevice.cs.

Constructor & Destructor Documentation

SimpleCommunication::Common::CaptureDevice::CaptureDevice ( ) [inline]

Definition at line 28 of file CaptureDevice.cs.

{ }

Member Function Documentation

static async Task<bool> SimpleCommunication::Common::CaptureDevice::CheckForRecordingDeviceAsync ( ) [inline, static]

Definition at line 224 of file CaptureDevice.cs.

        {
            var cameraFound = false;

            var devices = await DeviceInformation.FindAllAsync(DeviceClass.VideoCapture);
            if (devices.Count > 0)
            {
                cameraFound = true;
            }

            return cameraFound;
        }

async Task SimpleCommunication::Common::CaptureDevice::CleanUpAsync ( ) [inline]

Asynchronous method cleaning up resources and stopping recording if necessary.

Definition at line 99 of file CaptureDevice.cs.

        {
            try
            {
                forwardEvents = true;

                if (mediaCapture == null && mediaSink == null) return;

                if (recordingStarted)
                {
                    await mediaCapture.StopRecordAsync();
                }

                DoCleanup();
            }
            catch (Exception)
            {
                DoCleanup();
            }
        }

void SimpleCommunication::Common::CaptureDevice::CleanupSink ( ) [inline, private]

Cleans up the resources.

Definition at line 51 of file CaptureDevice.cs.

        {
            if (mediaSink != null)
            {
                mediaSink.IncomingConnectionEvent -= mediaSink_IncomingConnectionEvent;
                mediaSink.Close();
                mediaSink = null;
                recordingStarted = false;
            }
        }

void SimpleCommunication::Common::CaptureDevice::DoCleanup ( ) [inline, private]

Definition at line 62 of file CaptureDevice.cs.

        {
            if (mediaCapture != null)
            {
                mediaCapture.Failed -= mediaCapture_Failed;
                mediaCapture = null;
            }

            CleanupSink();
        }

async Task SimpleCommunication::Common::CaptureDevice::InitializeAsync ( ) [inline]

Definition at line 73 of file CaptureDevice.cs.

        {
            try
            {
                forwardEvents = true;

                if (mediaCapture != null)
                {
                    throw new InvalidOperationException("Camera is already initialized");
                }

                mediaCapture = new MediaCapture();
                mediaCapture.Failed += mediaCapture_Failed;

                await mediaCapture.InitializeAsync();
            }
            catch (Exception e)
            {
                DoCleanup();
                throw e;
            }
        }

void SimpleCommunication::Common::CaptureDevice::mediaCapture_Failed | ( | MediaCapture | sender,
 |  | MediaCaptureFailedEventArgs | errorEventArgs |
 | ) |  |  | [inline, private]

Handler for the wrapped MediaCapture object's Failed event.

It just wraps and forward's MediaCapture's Failed event as own CaptureFailed event

Definition at line 34 of file CaptureDevice.cs.

        {
            if (CaptureFailed != null && forwardEvents) CaptureFailed(this, errorEventArgs);
        }

void SimpleCommunication::Common::CaptureDevice::mediaSink_IncomingConnectionEvent | ( | StspMediaSink | sender,
 |  | IncomingConnectionEventArgs | args |
 | ) |  |  | [inline, private]

Handler for the wrapped media sink object's IncomingConnectionEvent.

Expose the wrapped event to listeners as own IncomingConnectionArrived event.

Definition at line 43 of file CaptureDevice.cs.

        {
            if (IncomingConnectionArrived != null && forwardEvents) IncomingConnectionArrived(sender, args);
        }

async Task<IMediaEncodingProperties> SimpleCommunication::Common::CaptureDevice::SelectPreferredCameraStreamSettingAsync | ( | MediaStreamType | mediaStreamType,
 |  | Func< IMediaEncodingProperties, bool > | filterSettings |
 | ) |  |  | [inline]

Allow selection of camera settings.

Parameters:
mediaStreamType | Type of a the media stream.
filterSettings | A predicate function, which will be called to filter the correct settings.

Definition at line 137 of file CaptureDevice.cs.

        {
            IMediaEncodingProperties previewEncodingProperties = null;

            if (mediaStreamType == MediaStreamType.Audio || mediaStreamType == MediaStreamType.Photo)
            {
                throw new ArgumentException("mediaStreamType value of MediaStreamType.Audio or MediaStreamType.Photo is not supported", "mediaStreamType");
            }
            if (filterSettings == null)
            {
                throw new ArgumentNullException("filterSettings");
            }

            var properties = mediaCapture.VideoDeviceController.GetAvailableMediaStreamProperties(mediaStreamType);
            var filterredProperties = properties.Where(filterSettings);
            var preferredSettings = filterredProperties.ToArray();

            Array.Sort<IMediaEncodingProperties>(preferredSettings, (x, y) =>
            {
                return (int)(((x as VideoEncodingProperties).Width) -
                    (y as VideoEncodingProperties).Width);
            });

            if (preferredSettings.Length > 0)
            {
                previewEncodingProperties = preferredSettings[0];
                await mediaCapture.VideoDeviceController.SetMediaStreamPropertiesAsync(mediaStreamType, preferredSettings[0]);
            }

            return previewEncodingProperties;
        }

async Task SimpleCommunication::Common::CaptureDevice::StartRecordingAsync ( MediaEncodingProfile encodingProfile ) [inline]

Starts media recording asynchronously.

Parameters:
encodingProfile Encoding profile used for the recording session

Definition at line 175 of file CaptureDevice.cs.

        {
            try
            {
                // We cannot start recording twice.
                if (mediaSink != null && recordingStarted)
                {
                    throw new InvalidOperationException("Recording already started.");
                }

                // Release sink if there is one already.
                CleanupSink();

                // Create new sink
                mediaSink = new StspMediaSink();
                mediaSink.IncomingConnectionEvent += mediaSink_IncomingConnectionEvent;

                await mediaSink.InitializeAsync(encodingProfile.Audio, encodingProfile.Video);
                await mediaCapture.StartRecordToCustomSinkAsync(encodingProfile, mediaSink);

                recordingStarted = true;
            }
            catch (Exception e)
            {
                CleanupSink();
                throw e;
            }
        }

async Task SimpleCommunication::Common::CaptureDevice::StopRecordingAsync ( ) [inline]

Stops recording asynchronously.

Definition at line 207 of file CaptureDevice.cs.

        {
            if (recordingStarted)
            {
                try
                {
                    await mediaCapture.StopRecordAsync();
                    CleanupSink();
                }
                catch (Exception e)
                {
                    CleanupSink();
                    throw e;
                }
            }
        }

Member Data Documentation

bool SimpleCommunication::Common::CaptureDevice::forwardEvents = false [private]

Definition at line 22 of file CaptureDevice.cs.

MediaCapture SimpleCommunication::Common::CaptureDevice::mediaCapture [private]

Definition at line 17 of file CaptureDevice.cs.

StspMediaSink SimpleCommunication::Common::CaptureDevice::mediaSink [private]

Definition at line 19 of file CaptureDevice.cs.

bool SimpleCommunication::Common::CaptureDevice::recordingStarted = false [private]

Definition at line 21 of file CaptureDevice.cs.

Property Documentation

MediaCapture SimpleCommunication::Common::CaptureDevice::CaptureSource [get]

Creates url object from MediaCapture.

Definition at line 124 of file CaptureDevice.cs.

Event Documentation

EventHandler<MediaCaptureFailedEventArgs> SimpleCommunication::Common::CaptureDevice::CaptureFailed

Definition at line 26 of file CaptureDevice.cs.

EventHandler<IncomingConnectionEventArgs> SimpleCommunication::Common::CaptureDevice::IncomingConnectionArrived

Definition at line 25 of file CaptureDevice.cs.

The documentation for this class was generated from the following file:
  • Real-time communication/C#,C++/Common/CaptureDevice.cs
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • Common
  • SimpleCommunication::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

SimpleCommunication::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
bool | _useFilledStateForNarrowWindow
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 26 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String SimpleCommunication::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void SimpleCommunication::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 211 of file LayoutAwarePage.cpp.

{
  if (_layoutAwareControls != nullptr)
  {
    String^ visualState = DetermineVisualState(ApplicationView::Value);
    auto controlIterator = _layoutAwareControls->First();
    while (controlIterator->HasCurrent)
    {
      auto control = controlIterator->Current;
      VisualStateManager::GoToState(control, visualState, false);
      controlIterator->MoveNext();
    }
  }
}

void SimpleCommunication::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void SimpleCommunication::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 142 of file LayoutAwarePage.cpp.

{
  InvalidateVisualState();
}

Member Data Documentation

internal SimpleCommunication::Common::LayoutAwarePage::__pad0__

Definition at line 29 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> SimpleCommunication::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 52 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> SimpleCommunication::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 54 of file LayoutAwarePage.h.

bool SimpleCommunication::Common::LayoutAwarePage::_useFilledStateForNarrowWindow [private]

Definition at line 51 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken SimpleCommunication::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 53 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • Real-time communication/C++/common/LayoutAwarePage.h
  • Real-time communication/C++/common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::LowLatency Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::LowLatency
Public Member Functions | Protected Member Functions | Properties | Private Types | Private Member Functions | Private Attributes

SimpleCommunication::LowLatency Class Reference

An empty page that can be used on its own or navigated to within a Frame.

Inherits SDKTemplate::Common::LayoutAwarePage.

List of all members.

Public Member Functions

LowLatency ()

Protected Member Functions

async override void | OnNavigatedTo (NavigationEventArgs e)
async override void | OnNavigatingFrom (NavigatingCancelEventArgs e)

Properties

MediaElement | LocalhostVideo [get]

Private Types

enum | LatencyMode { NormalLatency, LowLatency }
enum State {
Initializing, Waiting, Previewing, Streaming,
End
}

Private Member Functions

async Task | CleanupAsync ()
void | device_CaptureFailed (object sender, MediaCaptureFailedEventArgs e)
void | device_IncomingConnectionArrived (object sender, IncomingConnectionEventArgs e)
async Task | InitializeAsync (CancellationToken cancel=default(CancellationToken))
async void | LatencyModeToggle_Toggled (object sender, RoutedEventArgs e)
async void | LoopbackClient_Click (object sender, RoutedEventArgs e)
async void | Preview_Click (object sender, RoutedEventArgs e)
async Task | Previewing_PreviewButtonClicked ()
void | PreviewSetupCompleted ()
async Task | StartRecordingToCustomSink ()
async Task | Streaming_PreviewButtonClicked ()
async Task | Waiting_PreviewButtonClicked ()
async void | Window_VisibilityChanged (object sender, Windows.UI.Core.VisibilityChangedEventArgs e)

Private Attributes

State | currentState = null
LatencyMode | defaultMode = LatencyMode.NormalLatency
CaptureDevice | device = null
LatencyMode | mode = null
VideoEncodingProperties | previewEncodingProperties = null
State | previousState = null
MainPage | rootPage = MainPage.Current

Detailed Description

Definition at line 28 of file LowLatency.xaml.cs.

Member Enumeration Documentation

enum SimpleCommunication::LowLatency::LatencyMode [private]
Enumerator:
NormalLatency
LowLatency

Definition at line 39 of file LowLatency.xaml.cs.

        {
            NormalLatency,
            LowLatency
        }

enum SimpleCommunication::LowLatency::State [private]
Enumerator:
Initializing
Waiting
Previewing
Streaming
End

Definition at line 30 of file LowLatency.xaml.cs.

        {
            Initializing,
            Waiting,
            Previewing,
            Streaming,
            End
        }

Constructor & Destructor Documentation

LowLatency::LowLatency ( ) [inline]

Definition at line 56 of file LowLatency.xaml.cs.

        {
            this.InitializeComponent();

            rootPage.EnsureMediaExtensionManager();

            mode = LatencyMode.NormalLatency;
            LatencyModeToggle.IsOn = (mode == LatencyMode.LowLatency);
            rootPage.NotifyUser("Initializing...Please wait.", NotifyType.StatusMessage);
        }

Member Function Documentation

async Task SimpleCommunication::LowLatency::CleanupAsync ( ) [inline, private]

Definition at line 337 of file LowLatency.xaml.cs.

        {
            if (currentState == State.Previewing || currentState == State.Streaming)
            {
                await device.CaptureSource.StopPreviewAsync();

                if (currentState == State.Streaming)
                {
                    LocalhostVideo.Stop();

                    LocalhostVideo.Visibility = Visibility.Collapsed;
                    LocalHostPoster.Visibility = Visibility.Visible;
                }
            }

            await device.CleanUpAsync();
            LocalhostVideo.Source = null;
        }

void SimpleCommunication::LowLatency::device_CaptureFailed | ( | object | sender,
 |  | MediaCaptureFailedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 132 of file LowLatency.xaml.cs.

        {
            rootPage.NotifyUser(e.Message, NotifyType.ErrorMessage);
        }

void SimpleCommunication::LowLatency::device_IncomingConnectionArrived | ( | object | sender,
 |  | IncomingConnectionEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 127 of file LowLatency.xaml.cs.

        {
            e.Accept();
        }

async Task SimpleCommunication::LowLatency::InitializeAsync ( CancellationToken cancel = default(CancellationToken) ) [inline, private]

Initializes the scenario.

Returns:

Definition at line 82 of file LowLatency.xaml.cs.

        {
            var streamFilteringCriteria = new
            {
                //AspectRatio = 1.333333333333333,
                HorizontalResolution = (uint)480,
                SubType = "YUY2"
            };
            currentState = State.Initializing;
            device = new CaptureDevice();

            CameraPreview.Visibility = Visibility.Collapsed;
            PreviewPoster.Visibility = Visibility.Visible;
            Preview.Content = "Start Preview";
            LoopbackClient.IsEnabled = false;

            LatencyModeToggle.IsOn = (defaultMode == LatencyMode.LowLatency);
            LatencyModeToggle.IsEnabled = false;

            await device.InitializeAsync();
            var setting = await device.SelectPreferredCameraStreamSettingAsync(MediaStreamType.VideoPreview, ((x) =>
            {
                var previewStreamEncodingProperty = x as Windows.Media.MediaProperties.VideoEncodingProperties;

                return (previewStreamEncodingProperty.Width >= streamFilteringCriteria.HorizontalResolution &&
                    previewStreamEncodingProperty.Subtype == streamFilteringCriteria.SubType);
            }));

            previewEncodingProperties = setting as VideoEncodingProperties;

            PreviewSetupCompleted();
        }

async void SimpleCommunication::LowLatency::LatencyModeToggle_Toggled | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 319 of file LowLatency.xaml.cs.

        {
            if (currentState == State.Streaming)
            {
                var foregroundVideo = LocalhostVideo;
                foregroundVideo.Stop();

                await device.StopRecordingAsync();
                mode = (mode == LatencyMode.NormalLatency) ? LatencyMode.LowLatency : LatencyMode.NormalLatency;
                await StartRecordingToCustomSink();

                foregroundVideo.Source = null;
                LocalhostVideo.Source = new Uri("stsp://localhost");
                foregroundVideo.Visibility = Visibility.Collapsed;
                LocalhostVideo.Visibility = Visibility.Visible;
            }
        }

async void SimpleCommunication::LowLatency::LoopbackClient_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'LoopbackClient' button.

It displays captured video recieved over the localhost network interface using a custom network media sink and media sources via a custom scheme

Parameters:
sender | The LoopbackClient button
e | The button click routed event arguments

Definition at line 283 of file LowLatency.xaml.cs.

        {
            Button b = sender as Button;
            if (b != null)
            {
                previousState = currentState;
                await StartRecordingToCustomSink();

                if (currentState == State.Previewing)
                {
                    LocalhostVideo.Source = new Uri("stsp://localhost");
                    LatencyModeToggle.IsEnabled = true;
                    LoopbackClient.IsEnabled = false;
                    LocalHostPoster.Visibility = Visibility.Collapsed;
                    LocalhostVideo.Visibility = Visibility.Visible;

                    currentState = State.Streaming;
                }
            }
        }

async override void SimpleCommunication::LowLatency::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 167 of file LowLatency.xaml.cs.

        {
            var cameraEnumTask = CaptureDevice.CheckForRecordingDeviceAsync();

            var cameraFound = await cameraEnumTask;

            if (cameraFound)
            {
                try
                {
                    await InitializeAsync();

                    Window.Current.VisibilityChanged += Window_VisibilityChanged;
                }
                catch (Exception err)
                {
                    rootPage.NotifyUser("Camera initialization error: " + err.Message + "\n Try restarting the sample.", NotifyType.ErrorMessage);
                }
            }
            else
            {
                rootPage.NotifyUser("A machine with a camera and a microphone is required to run this sample.", NotifyType.ErrorMessage);
            }
        }

async override void SimpleCommunication::LowLatency::OnNavigatingFrom ( NavigatingCancelEventArgs e ) [inline, protected]

Definition at line 192 of file LowLatency.xaml.cs.

        {
            Window.Current.VisibilityChanged -= Window_VisibilityChanged;
            try
            {
                await CleanupAsync();
            }
            catch (Exception)
            {
            }
            base.OnNavigatingFrom(e);
        }

async void SimpleCommunication::LowLatency::Preview_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Preview' button.

It starts or stops camera preview and streaming

Parameters:
sender
e

Definition at line 211 of file LowLatency.xaml.cs.

        {
            Button b = sender as Button;
            if (b != null && device != null)
            {
                previousState = currentState;
                switch (currentState)
                {
                    case State.Waiting:
                        await Waiting_PreviewButtonClicked();
                        break;
                    case State.Previewing:
                        await Previewing_PreviewButtonClicked();
                        break;
                    case State.Streaming:
                        await Streaming_PreviewButtonClicked();
                        break;
                    default:
                        break;
                }
            }
        }

async Task SimpleCommunication::LowLatency::Previewing_PreviewButtonClicked ( ) [inline, private]

Definition at line 234 of file LowLatency.xaml.cs.

        {
            Task stopPreviewTask = device.CaptureSource.StopPreviewAsync().AsTask();

            CameraPreview.Visibility = Visibility.Collapsed;
            PreviewPoster.Visibility = Visibility.Visible;
            Preview.Content = "Start Preview";
            LoopbackClient.IsEnabled = false;

            await stopPreviewTask;
            currentState = State.Waiting;
        }

void SimpleCommunication::LowLatency::PreviewSetupCompleted ( ) [inline, private]

Definition at line 115 of file LowLatency.xaml.cs.

        {
            device.CaptureFailed += device_CaptureFailed;
            device.IncomingConnectionArrived += device_IncomingConnectionArrived;
            previousState = currentState;
            Preview.IsEnabled = true;
            rootPage.NotifyUser("Done. Tap or click 'Start Preview' button to start webcam preview", NotifyType.StatusMessage);

            currentState = State.Waiting;
        }

task< void > LowLatency::StartRecordingToCustomSink ( ) [inline, private]

Definition at line 304 of file LowLatency.xaml.cs.

        {
            // Use the MP4 preset to an obtain H.264 video encoding profile
            var mep = MediaEncodingProfile.CreateMp4(VideoEncodingQuality.Vga);
            mep.Audio = null;
            mep.Container = null;
            if (previewEncodingProperties != null)
            {
                mep.Video.Width = previewEncodingProperties.Width;
                mep.Video.Height = previewEncodingProperties.Height;
            }

            await device.StartRecordingAsync(mep);
        }

async Task SimpleCommunication::LowLatency::Streaming_PreviewButtonClicked ( ) [inline, private]

Definition at line 261 of file LowLatency.xaml.cs.

        {
            LocalhostVideo.Visibility = Visibility.Collapsed;
            LocalHostPoster.Visibility = Visibility.Visible;

            LocalhostVideo.Stop();
            await device.StopRecordingAsync();
            LocalhostVideo.Source = null;
            await Previewing_PreviewButtonClicked();

            mode = defaultMode;
            LatencyModeToggle.IsOn = (defaultMode == LatencyMode.LowLatency);
            LatencyModeToggle.IsEnabled = false;
        }

async Task SimpleCommunication::LowLatency::Waiting_PreviewButtonClicked ( ) [inline, private]

Definition at line 247 of file LowLatency.xaml.cs.

        {
            rootPage.NotifyUser("", NotifyType.StatusMessage);
            CameraPreview.Source = device.CaptureSource;
            await device.CaptureSource.StartPreviewAsync();

            PreviewPoster.Visibility = Visibility.Collapsed;
            CameraPreview.Visibility = Visibility.Visible;
            Preview.Content = "Stop Preview";
            LoopbackClient.IsEnabled = true;

            currentState = State.Previewing;
        }

async void SimpleCommunication::LowLatency::Window_VisibilityChanged | ( | object | sender,
 |  | Windows.UI.Core.VisibilityChangedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 137 of file LowLatency.xaml.cs.

        {
            if (!e.Visible)
            {
                try
                {
                    await CleanupAsync();
                }
                catch (Exception)
                {
                }
            }
            else
            {
                try
                {
                    await InitializeAsync();
                }
                catch (Exception err)
                {
                    rootPage.NotifyUser("Camera initialization error: " + err.Message + "\n Try restarting the sample.", NotifyType.ErrorMessage);
                }
            }
        }

Member Data Documentation

State SimpleCommunication::LowLatency::currentState = null [private]

Definition at line 50 of file LowLatency.xaml.cs.

LatencyMode SimpleCommunication::LowLatency::defaultMode = LatencyMode.NormalLatency [private]

Definition at line 54 of file LowLatency.xaml.cs.

CaptureDevice SimpleCommunication::LowLatency::device = null [private]

Definition at line 49 of file LowLatency.xaml.cs.

LatencyMode SimpleCommunication::LowLatency::mode = null [private]

Definition at line 53 of file LowLatency.xaml.cs.

VideoEncodingProperties SimpleCommunication::LowLatency::previewEncodingProperties = null [private]

Definition at line 52 of file LowLatency.xaml.cs.

State SimpleCommunication::LowLatency::previousState = null [private]

Definition at line 51 of file LowLatency.xaml.cs.

MainPage SimpleCommunication::LowLatency::rootPage = MainPage.Current [private]

Definition at line 47 of file LowLatency.xaml.cs.

Property Documentation

MediaElement SimpleCommunication::LowLatency::LocalhostVideo [get, private]

The media element visible in the local host client area.

Definition at line 71 of file LowLatency.xaml.cs.

The documentation for this class was generated from the following files:
  • Real-time communication/C#,C++/LowLatency.xaml.cs
  • Real-time communication/C++/LowLatency.xaml.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::MainPage

SimpleCommunication::MainPage Class Reference

#include "Constants.h"

Detailed Description

Definition at line 23 of file Constants.h.

The documentation for this class was generated from the following file:
  • Real-time communication/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::Scenario
Public Attributes

SimpleCommunication::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String SimpleCommunication::Scenario::ClassName

Definition at line 20 of file Constants.h.

Platform::String SimpleCommunication::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • Real-time communication/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::SdkSample Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::SdkSample
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

SimpleCommunication::SdkSample Class Reference

#include "Utils.h"

List of all members.

Public Member Functions

void | ClearLastStatus ()
void | Deinitialize ()
void | DisplayError (Platform::String^msg)
void | DisplayStatus (Platform::String^msg)
void | FormatError (CaptureFailedEventArgs^e, Platform::String^prefix)
void | FormatError (HResult err, Platform::String^msg, Platform::String^prefix)

Public Attributes

internal | __pad0__: void Initialize(Windows::UI::Xaml::Controls::TextBlock^ statusMessage
internal
Windows::UI::Core::CoreDispatcher 		dispatcher

Private Member Functions

void | Log (Platform::String^message)
void | Log (Platform::String^message, Platform::String^tag, Platform::String^type)

Private Attributes

Windows::UI::Core::CoreDispatcher | _dispatcher
Windows::UI::Xaml::Controls::TextBlock | _statusMessage

Detailed Description

Definition at line 44 of file Utils.h.

Member Function Documentation

void SdkSample::ClearLastStatus ( )

Definition at line 83 of file Utils.cpp.

{
    Log("");
}

void SdkSample::Deinitialize ( )

Definition at line 29 of file Utils.cpp.

{
    _statusMessage = nullptr;
    _dispatcher = nullptr;
}

void SdkSample::DisplayError ( Platform::String^ msg )

Definition at line 42 of file Utils.cpp.

{
    Log(msg, nullptr, "error");
}

void SdkSample::DisplayStatus ( Platform::String^ msg )

Definition at line 36 of file Utils.cpp.

{
    Log(msg);
}

void SdkSample::FormatError | ( | CaptureFailedEventArgs^ | e,
 |  | Platform::String^ | prefix
 | ) |  |

Definition at line 75 of file Utils.cpp.

{
    HResult hr;
    hr.Value = e->Code;
    FormatError(hr, e->Message, prefix);
}

void SdkSample::FormatError | ( | HResult | err,
 |  | Platform::String^ | msg,
 |  | Platform::String^ | prefix
 | ) |  |

Definition at line 48 of file Utils.cpp.

{
    if (err.Value)
    {
        WCHAR dst[33];
        _ultow_s(err.Value, dst, ARRAYSIZE(dst), 16);
        Log(
            prefix +
            msg +
            ", Error code: " +
            ref new Platform::String(dst),
            nullptr,
            "error"
            );
    }
    else
    {
        Log(
            prefix +
            msg,
            nullptr,
            "error"
            );
    }
}

void SdkSample::Log ( Platform::String^ message ) [private]

Definition at line 89 of file Utils.cpp.

{
    Log(message, nullptr, "status");
}

void SdkSample::Log | ( | Platform::String^ | message,
 |  | Platform::String^ | tag,
 |  | Platform::String^ | type |
 | ) |  |  | [private]

Definition at line 95 of file Utils.cpp.

{
    auto isError = (type == "error");
    auto isStatus = (type == "status");

    if (isError || isStatus)
    {
        if (_statusMessage && _dispatcher)
        {
            _dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal,
                ref new Windows::UI::Core::DispatchedHandler([this, message, isError]()
            {
                _statusMessage->Text = message;
                if (isError)
                {
                    _statusMessage->Foreground = ref new Windows::UI::Xaml::Media::SolidColorBrush(Windows::UI::Colors::Blue);
                }
                else
                {
                    _statusMessage->Foreground = ref new Windows::UI::Xaml::Media::SolidColorBrush(Windows::UI::Colors::Green);
                }
            }));
        }
    }
}

Member Data Documentation

internal SimpleCommunication::SdkSample::__pad0__

Definition at line 47 of file Utils.h.

Windows::UI::Core::CoreDispatcher SimpleCommunication::SdkSample::_dispatcher [private]

Definition at line 61 of file Utils.h.

Windows::UI::Xaml::Controls::TextBlock SimpleCommunication::SdkSample::_statusMessage [private]

Definition at line 60 of file Utils.h.

internal Windows::UI::Core::CoreDispatcher SimpleCommunication::SdkSample::dispatcher

Definition at line 47 of file Utils.h.

The documentation for this class was generated from the following files:
  • Real-time communication/C++/Utils.h
  • Real-time communication/C++/Utils.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::sealed
Classes | Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Private Types | Private Member Functions | Private Attributes

SimpleCommunication::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "LowLatency.xaml.h"

List of all members.

Classes

struct | StreamFilteringCriteria

Public Member Functions

void | LoadScenario (Platform::String^scenarioName)
void | LockScenarioChange ()
LowLatency ()
MainPage ()
bool | NavigatingPrevented ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
void | SetCurrentScenario (Platform::String^scenario)
void | UnlockScenarioChange ()
VideoChat ()

Protected Member Functions

void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
virtual void | OnNavigatingFrom (Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)
void | VisibilityChanged (Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e)

Protected Attributes

internal | __pad0__: static MainPage^ Current

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Types

enum | LatencyModes { uninitialized, highLatency, lowLatency }
enum | Role { uninitialized, active, passive }
enum ScenarioOneStates {
uninitialized, initializing, waiting, previewing,
streaming, end
}

Private Member Functions

~MainPage ()
~VideoChat ()
delegate IAsyncAction | ActionTransition ()
void | CallButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
CaptureDevice ()
task< void > | Cleanup ()
task< void > | CleanUp ()
task< void > | CleanupAsync ()
void | CleanupSink ()
task< void > | Deactivate ()
void | DoCleanup ()
task< void > | EndCall ()
void | EndCallButton_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
task< void > | Initialize ()
task< void > | Initialize ()
task< void > | InitializeAsync ()
void | InitializeUIControls ()
IAsyncAction | initializing_previewSetupCompleted ()
void | InvalidateSize ()
void | InvalidateViewState ()
void | LatencyModeToggled (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | LocalClientButtonClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | OnCaptureFailed (Windows::Media::Capture::MediaCapture^sender, Windows::Media::Capture::MediaCaptureFailedEventArgs^errorEventArgs)
void | OnIncomingConnection (Microsoft::Samples::SimpleCommunication::StspMediaSink^sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^args)
void | OnIncomingConnection (Microsoft::Samples::SimpleCommunication::StspMediaSink^sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^args)
void | OnIncomingConnection (Microsoft::Samples::SimpleCommunication::StspMediaSink^sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^args)
task< void > | OnInitializeCompleted (Windows::Foundation::HResult hr)
void | OnInitializeCompletedDispatchedHandler ()
void | OnMediaCaptureFailed (CaptureDevice^sender, CaptureFailedEventArgs^errorEventArgs)
void | OnMediaCaptureFailed (CaptureDevice^sender, CaptureFailedEventArgs^errorEventArgs)
void | PopulateScenarios ()
void | PreviewButtonClicked (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
IAsyncAction | previewing_localClientButtonClicked ()
IAsyncAction | previewing_previewButtonClicked ()
IAsyncAction | previewing_recordingStarted ()
void | Reset ()
task< void > | SelectPreferredCameraStreamSettingAsync (Windows::Media::Capture::MediaStreamType mediaStreamType, VideoSettingsFilter^settingsFilterFunc)
void | SetFeatureName (Platform::String^strFeature)
task< void > | StartRecordingAsync (Windows::Media::MediaProperties::MediaEncodingProfile^mediaEncodingProfile)
task< void > | StartRecordingToCustomSink ()
task< void > | StartRecordingToCustomSinkAsync ()
task< void > | StopRecordingAsync ()
IAsyncAction | streaming_latencyModeToggled ()
IAsyncAction | streaming_previewButtonClicked ()
IAsyncAction | streaming_recordingStarted ()
void | UpdateLocalClientWindow ()
void | VideoPlaybackErrorHandler (Platform::Object^sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^e)
IAsyncAction | waiting_previewButtonClicked ()

Private Attributes

bool | _active
Platform::String | _currentScenario
ScenarioOneStates _currentState
CaptureDevice | _device
Windows::UI::Core::CoreDispatcher | _dispatcher
Windows::Foundation::EventRegistrationToken | _incomingConnectionEventRegistrationToken
bool | _initialization
bool | _initialized
bool | _isTerminator
LatencyModes _latencyMode
std::map< LatencyModes,
Windows::UI::Xaml::Controls::MediaElement^> 		_localHostVideo
Platform::Agile
< Windows::Media::Capture::MediaCapture > 		_mediaCapture
Windows::Foundation::EventRegistrationToken | _mediaCaptureFailedEventRegistrationToken
Windows::Foundation::EventRegistrationToken | _mediaElementFailedEventRegistrationToken
Windows::Media::MediaExtensionManager | _mediaExtensionMgr
Microsoft::Samples::SimpleCommunication::StspMediaSink | _mediaSink
Windows::Foundation::EventRegistrationToken | _mediaSinkIncomingConnectionEventRegistrationToken
long volatile | _navigationDisabled
ScenarioOneStates _previousState
bool | _recordingStarted
Role _role
MainPage _rootPage
SdkSample _sdkSample
StreamFilteringCriteria _streamFilteringCriteria
VideoSettingsFilter | _videoSettingsFilter
std::map< ScenarioOneStates,
std::array< ActionTransition^, 5 > > 		actionTransitionFunctions
bool | autoSizeInputSectionWhenSnapped
Windows::UI::Xaml::Controls::Frame | HiddenFrame
event
IncomingconnectioneventHandler 		Incomingconnectionevent
Windows::Foundation::EventRegistrationToken | m_visibilityEventRegistrationToken
Platform::Collections::Vector
< Object^> 		ScenarioList

Detailed Description

Definition at line 29 of file LowLatency.xaml.h.

Member Enumeration Documentation

enum SimpleCommunication::sealed::LatencyModes [private]
Enumerator:
uninitialized
highLatency
lowLatency

Definition at line 80 of file LowLatency.xaml.h.

        {
            uninitialized,
            highLatency,
            lowLatency,
        };

enum SimpleCommunication::sealed::Role [private]
Enumerator:
uninitialized
active
passive

Definition at line 67 of file VideoChat.xaml.h.

        {
            uninitialized,
            active,
            passive,
        };

enum SimpleCommunication::sealed::ScenarioOneStates [private]
Enumerator:
uninitialized
initializing
waiting
previewing
streaming
end

Definition at line 56 of file LowLatency.xaml.h.

        {
            uninitialized,
            initializing,
            waiting,
            previewing,
            streaming,
            end,
        };

Constructor & Destructor Documentation

SimpleCommunication::sealed::~MainPage ( ) [private]
SimpleCommunication::sealed::~VideoChat ( ) [private]

Member Function Documentation

delegate IAsyncAction SimpleCommunication::sealed::ActionTransition ( ) [private]

This is the FSM encapsulating the state table (states and actions) of the scenario.

void SimpleCommunication::sealed::CallButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
SimpleCommunication::sealed::CaptureDevice ( ) [private]
task<void> SimpleCommunication::sealed::Cleanup ( ) [private]
task<void> SimpleCommunication::sealed::CleanUp ( ) [private]
task<void> SimpleCommunication::sealed::CleanupAsync ( ) [private]

Asynchronous method cleaning up resources and stopping recording if necessary.

void SimpleCommunication::sealed::CleanupSink ( ) [private]

Cleaning up the sink.

task<void> SimpleCommunication::sealed::Deactivate ( ) [private]
void SimpleCommunication::sealed::DoCleanup ( ) [private]

Cleans up the resources.

task<void> SimpleCommunication::sealed::EndCall ( ) [private]
void SimpleCommunication::sealed::EndCallButton_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SimpleCommunication::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
task<void> SimpleCommunication::sealed::Initialize ( ) [private]
task<void> SimpleCommunication::sealed::Initialize ( ) [private]
task<void> SimpleCommunication::sealed::InitializeAsync ( ) [private]

Initialization of the device.

void SimpleCommunication::sealed::InitializeUIControls ( ) [private]
IAsyncAction SimpleCommunication::sealed::initializing_previewSetupCompleted ( ) [private]
void SimpleCommunication::sealed::InvalidateSize ( ) [private]
void SimpleCommunication::sealed::InvalidateViewState ( ) [private]
void SimpleCommunication::sealed::LatencyModeToggled | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SimpleCommunication::sealed::LoadScenario ( Platform::String^ scenarioName )
void SimpleCommunication::sealed::LocalClientButtonClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void SimpleCommunication::sealed::LockScenarioChange ( )
SimpleCommunication::sealed::LowLatency ( )
SimpleCommunication::sealed::MainPage ( )
void SimpleCommunication::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
bool SimpleCommunication::sealed::NavigatingPrevented ( )
void SimpleCommunication::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void SimpleCommunication::sealed::OnCaptureFailed | ( | Windows::Media::Capture::MediaCapture^ | sender,
 |  | Windows::Media::Capture::MediaCaptureFailedEventArgs^ | errorEventArgs |
 | ) |  |  | [inline, private]

Capture has failed.

Definition at line 140 of file Utils.h.

        {
            // Forward the error to listeners.
            Failed(this, ref new CaptureFailedEventArgs(errorEventArgs->Code, errorEventArgs->Message));
        }

void SimpleCommunication::sealed::OnIncomingConnection | ( | Microsoft::Samples::SimpleCommunication::StspMediaSink^ | sender,
 |  | Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ | args |
 | ) |  |  | [private]
void SimpleCommunication::sealed::OnIncomingConnection | ( | Microsoft::Samples::SimpleCommunication::StspMediaSink^ | sender,
 |  | Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ | args |
 | ) |  |  | [inline, private]

There is an incoming connection.

Definition at line 149 of file Utils.h.

        {
            // Forward the event to listeners.
            Incomingconnectionevent(sender, args);
        }

void SimpleCommunication::sealed::OnIncomingConnection | ( | Microsoft::Samples::SimpleCommunication::StspMediaSink^ | sender,
 |  | Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ | args |
 | ) |  |  | [private]
task<void> SimpleCommunication::sealed::OnInitializeCompleted ( Windows::Foundation::HResult hr ) [private]
void SimpleCommunication::sealed::OnInitializeCompletedDispatchedHandler ( ) [private]
void SimpleCommunication::sealed::OnMediaCaptureFailed | ( | CaptureDevice^ | sender,
 |  | CaptureFailedEventArgs^ | errorEventArgs |
 | ) |  |  | [private]
void SimpleCommunication::sealed::OnMediaCaptureFailed | ( | CaptureDevice^ | sender,
 |  | CaptureFailedEventArgs^ | errorEventArgs |
 | ) |  |  | [private]
virtual void SimpleCommunication::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SimpleCommunication::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SimpleCommunication::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SimpleCommunication::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SimpleCommunication::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void SimpleCommunication::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
virtual void SimpleCommunication::sealed::OnNavigatingFrom ( Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e ) [override, protected, virtual]
void SimpleCommunication::sealed::PopulateScenarios ( ) [private]
void SimpleCommunication::sealed::PreviewButtonClicked | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
IAsyncAction SimpleCommunication::sealed::previewing_localClientButtonClicked ( ) [private]
IAsyncAction SimpleCommunication::sealed::previewing_previewButtonClicked ( ) [private]
IAsyncAction SimpleCommunication::sealed::previewing_recordingStarted ( ) [private]
void SimpleCommunication::sealed::Reset ( ) [private]
void SimpleCommunication::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
task<void> SimpleCommunication::sealed::SelectPreferredCameraStreamSettingAsync | ( | Windows::Media::Capture::MediaStreamType | mediaStreamType,
 |  | VideoSettingsFilter^ | settingsFilterFunc |
 | ) |  |  | [private]

Function allows to select camera settings.

Parameters:
mediaStreamType | Type of a the media stream.
mediaStreamType | Function which will be called to filter the correct settings.
void SimpleCommunication::sealed::SetCurrentScenario ( Platform::String^ scenario )
void SimpleCommunication::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
task<void> SimpleCommunication::sealed::StartRecordingAsync ( Windows::Media::MediaProperties::MediaEncodingProfile^ mediaEncodingProfile ) [private]

Begins recording.

Parameters:
mediaEncodingProfile Encoding profile which should be used for the recording session.
task<void> SimpleCommunication::sealed::StartRecordingToCustomSink ( ) [private]
task<void> SimpleCommunication::sealed::StartRecordingToCustomSinkAsync ( ) [private]
task<void> SimpleCommunication::sealed::StopRecordingAsync ( ) [private]

Stops recording.

IAsyncAction SimpleCommunication::sealed::streaming_latencyModeToggled ( ) [private]
IAsyncAction SimpleCommunication::sealed::streaming_previewButtonClicked ( ) [private]
IAsyncAction SimpleCommunication::sealed::streaming_recordingStarted ( ) [private]
void SimpleCommunication::sealed::UnlockScenarioChange ( )
void SimpleCommunication::sealed::UpdateLocalClientWindow ( ) [private]
SimpleCommunication::sealed::VideoChat ( )
void SimpleCommunication::sealed::VideoPlaybackErrorHandler | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::ExceptionRoutedEventArgs^ | e |
 | ) |  |  | [private]
void SimpleCommunication::sealed::VisibilityChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::VisibilityChangedEventArgs^ | e |
 | ) |  |  | [protected]
IAsyncAction SimpleCommunication::sealed::waiting_previewButtonClicked ( ) [private]

Member Data Documentation

internal sealed::__pad0__ [protected]

Definition at line 106 of file MainPage.xaml.h.

bool SimpleCommunication::sealed::_active [private]

Definition at line 65 of file VideoChat.xaml.h.

Platform::String SimpleCommunication::sealed::_currentScenario [private]

Definition at line 95 of file MainPage.xaml.h.

ScenarioOneStates SimpleCommunication::sealed::_currentState [private]

Definition at line 65 of file LowLatency.xaml.h.

CaptureDevice sealed::_device [private]

Definition at line 98 of file LowLatency.xaml.h.

Windows::UI::Core::CoreDispatcher sealed::_dispatcher [private]

Definition at line 106 of file LowLatency.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::_incomingConnectionEventRegistrationToken [private]

Definition at line 51 of file LowLatency.xaml.h.

bool SimpleCommunication::sealed::_initialization [private]

Definition at line 63 of file VideoChat.xaml.h.

bool SimpleCommunication::sealed::_initialized [private]

Definition at line 97 of file LowLatency.xaml.h.

bool SimpleCommunication::sealed::_isTerminator [private]

Definition at line 62 of file VideoChat.xaml.h.

LatencyModes SimpleCommunication::sealed::_latencyMode [private]

Definition at line 86 of file LowLatency.xaml.h.

std::map<LatencyModes, Windows::UI::Xaml::Controls::MediaElement^> SimpleCommunication::sealed::_localHostVideo [private]

Definition at line 87 of file LowLatency.xaml.h.

Platform::Agile<Windows::Media::Capture::MediaCapture> SimpleCommunication::sealed::_mediaCapture [private]

Definition at line 76 of file Utils.h.

Windows::Foundation::EventRegistrationToken sealed::_mediaCaptureFailedEventRegistrationToken [private]

Definition at line 52 of file LowLatency.xaml.h.

Windows::Foundation::EventRegistrationToken SimpleCommunication::sealed::_mediaElementFailedEventRegistrationToken [private]

Definition at line 57 of file VideoChat.xaml.h.

Windows::Media::MediaExtensionManager SimpleCommunication::sealed::_mediaExtensionMgr [private]

Definition at line 98 of file MainPage.xaml.h.

Microsoft::Samples::SimpleCommunication::StspMediaSink SimpleCommunication::sealed::_mediaSink [private]

Definition at line 78 of file Utils.h.

Windows::Foundation::EventRegistrationToken SimpleCommunication::sealed::_mediaSinkIncomingConnectionEventRegistrationToken [private]

Definition at line 80 of file Utils.h.

long volatile SimpleCommunication::sealed::_navigationDisabled [private]

Definition at line 94 of file MainPage.xaml.h.

ScenarioOneStates SimpleCommunication::sealed::_previousState [private]

Definition at line 66 of file LowLatency.xaml.h.

bool SimpleCommunication::sealed::_recordingStarted [private]

Definition at line 85 of file Utils.h.

Role SimpleCommunication::sealed::_role [private]

Definition at line 73 of file VideoChat.xaml.h.

MainPage sealed::_rootPage [private]

Definition at line 100 of file LowLatency.xaml.h.

SdkSample sealed::_sdkSample [private]

Definition at line 105 of file LowLatency.xaml.h.

StreamFilteringCriteria SimpleCommunication::sealed::_streamFilteringCriteria [private]

Definition at line 95 of file LowLatency.xaml.h.

VideoSettingsFilter SimpleCommunication::sealed::_videoSettingsFilter [private]

Definition at line 49 of file LowLatency.xaml.h.

std::map<ScenarioOneStates, std::array<ActionTransition^, 5> > SimpleCommunication::sealed::actionTransitionFunctions [private]

Definition at line 70 of file LowLatency.xaml.h.

bool SimpleCommunication::sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 92 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame SimpleCommunication::sealed::HiddenFrame [private]

Definition at line 90 of file MainPage.xaml.h.

event IncomingconnectioneventHandler SimpleCommunication::sealed::Incomingconnectionevent [private]

Definition at line 89 of file Utils.h.

Windows::Foundation::EventRegistrationToken SimpleCommunication::sealed::m_visibilityEventRegistrationToken [private]

Definition at line 107 of file LowLatency.xaml.h.

Platform::Collections::Vector<Object^> SimpleCommunication::sealed::ScenarioList [private]

Definition at line 89 of file MainPage.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> SimpleCommunication::sealed::MainPageResized

Definition at line 75 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> SimpleCommunication::sealed::ScenarioLoaded

Definition at line 74 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Real-time communication/C++/LowLatency.xaml.h
  • Real-time communication/C++/VideoChat.xaml.h
  • Real-time communication/C++/MainPage.xaml.h
  • Real-time communication/C++/Utils.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::sealed::StreamFilteringCriteria Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::sealed
  • SimpleCommunication::sealed::StreamFilteringCriteria
Public Attributes

SimpleCommunication::sealed::StreamFilteringCriteria Struct Reference

List of all members.

Public Attributes

Platform::String | aspectRatio
int | horizontalResolution
Platform::String | subType

Detailed Description

Definition at line 89 of file LowLatency.xaml.h.

Member Data Documentation

Platform::String SimpleCommunication::sealed::StreamFilteringCriteria::aspectRatio

Definition at line 91 of file LowLatency.xaml.h.

int SimpleCommunication::sealed::StreamFilteringCriteria::horizontalResolution

Definition at line 92 of file LowLatency.xaml.h.

Platform::String SimpleCommunication::sealed::StreamFilteringCriteria::subType

Definition at line 93 of file LowLatency.xaml.h.

The documentation for this struct was generated from the following file:
  • Real-time communication/C++/LowLatency.xaml.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::VideoChat Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • SimpleCommunication
  • SimpleCommunication::VideoChat
Public Member Functions | Protected Member Functions | Private Member Functions | Private Attributes

SimpleCommunication::VideoChat Class Reference

An empty page that can be used on its own or navigated to within a Frame.

Inherits SDKTemplate::Common::LayoutAwarePage.

List of all members.

Public Member Functions

VideoChat ()

Protected Member Functions

async override void | OnNavigatedTo (NavigationEventArgs e)
async override void | OnNavigatingFrom (NavigatingCancelEventArgs e)

Private Member Functions

void | Call_Click (object sender, RoutedEventArgs e)
async void | device_CaptureFailed (object sender, Windows.Media.Capture.MediaCaptureFailedEventArgs e)
async void | device_IncomingConnectionArrived (object sender, IncomingConnectionEventArgs e)
async void | EndCall_Click (object sender, RoutedEventArgs e)
async Task | EndCallAsync ()
async Task | InitializeAsync (CancellationToken cancel=default(CancellationToken))
async void | RemoteVideo_MediaFailed (object sender, ExceptionRoutedEventArgs e)
async Task | StartRecordToCustomSink ()

Private Attributes

bool | activated = false
CaptureDevice | device = null
int | isTerminator = 0
bool | roleIsActive = null
MainPage | rootPage = MainPage.Current

Detailed Description

Definition at line 29 of file VideoChat.xaml.cs.

Constructor & Destructor Documentation

VideoChat::VideoChat ( ) [inline]

Definition at line 40 of file VideoChat.xaml.cs.

        {
            this.InitializeComponent();

            rootPage.EnsureMediaExtensionManager();
        }

Member Function Documentation

void SimpleCommunication::VideoChat::Call_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Default' button.

You would replace this with your own handler if you have a button or buttons on this page.

Parameters:
sender
e

Definition at line 170 of file VideoChat.xaml.cs.

        {
            Button b = sender as Button;
            var address = HostName.Text;

            if (b != null && !String.IsNullOrEmpty(address))
            {
                roleIsActive = true;
                RemoteVideo.Source = new Uri("stsp://" + address);
                HostName.IsEnabled = Call.IsEnabled = false;
                rootPage.NotifyUser("Initiating connection... Please wait.", NotifyType.StatusMessage);
            }
        }

async void SimpleCommunication::VideoChat::device_CaptureFailed | ( | object | sender,
 |  | Windows.Media.Capture.MediaCaptureFailedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 145 of file VideoChat.xaml.cs.

        {
            if (Interlocked.CompareExchange(ref isTerminator, 1, 0) == 0)
            {
                await EndCallAsync();
            }
        }

async void SimpleCommunication::VideoChat::device_IncomingConnectionArrived | ( | object | sender,
 |  | IncomingConnectionEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 119 of file VideoChat.xaml.cs.

        {
            e.Accept();

            await Dispatcher.RunAsync(Windows.UI.Core.CoreDispatcherPriority.Normal, (() =>
            {
                activated = true;
                CallPoster.Visibility = Visibility.Collapsed;
                RemoteVideo.Visibility = Visibility.Visible;

                var remoteAddress = e.RemoteUrl;
                EndCall.IsEnabled = true;
                Interlocked.Exchange(ref isTerminator, 0);

                if (!((bool)roleIsActive))
                {
                    // Passive client
                    RemoteVideo.Source = new Uri(remoteAddress);
                    HostName.IsEnabled = Call.IsEnabled = false;
                }

                remoteAddress = remoteAddress.Replace("stsp://", "");
                rootPage.NotifyUser("Connected. Remote machine address: " + remoteAddress, NotifyType.StatusMessage);
            }));
        }

async void SimpleCommunication::VideoChat::EndCall_Click | ( | object | sender,
 |  | RoutedEventArgs | e |
 | ) |  |  | [inline, private]

This is the click handler for the 'Other' button.

You would replace this with your own handler if you have a button or buttons on this page.

Parameters:
sender
e

Definition at line 190 of file VideoChat.xaml.cs.

        {
            Button b = sender as Button;
            if (b != null && Interlocked.CompareExchange(ref isTerminator, 1, 0) == 0)
            {
                await EndCallAsync();
            }
        }

async Task SimpleCommunication::VideoChat::EndCallAsync ( ) [inline, private]

Definition at line 199 of file VideoChat.xaml.cs.

        {
            await device.CleanUpAsync();

            // end the call session
            await Dispatcher.RunAsync(CoreDispatcherPriority.Normal, (() =>
            {
                RemoteVideo.Visibility = Visibility.Collapsed;
                CallPoster.Visibility = Visibility.Visible;
                RemoteVideo.Stop();
                RemoteVideo.Source = null;
            }));

            // Start waiting for a new call
            await InitializeAsync();
        }

async Task SimpleCommunication::VideoChat::InitializeAsync ( CancellationToken cancel = default(CancellationToken) ) [inline, private]

Definition at line 84 of file VideoChat.xaml.cs.

        {
            rootPage.NotifyUser("Initializing...", NotifyType.StatusMessage);

            try
            {
                await device.InitializeAsync();
                await StartRecordToCustomSink();

                HostName.IsEnabled = Call.IsEnabled = true;
                EndCall.IsEnabled = false;
                RemoteVideo.Source = null;
                RemoteVideo.Height = (RemoteVideo.Parent as Grid).ActualHeight;

                // Each client starts out as passive
                roleIsActive = false;
                Interlocked.Exchange(ref isTerminator, 0);

                rootPage.NotifyUser("Tap 'Call' button to start call", NotifyType.StatusMessage);
            }
            catch (Exception)
            {
                rootPage.NotifyUser("Initialization error. Restart the sample to try again.", NotifyType.ErrorMessage);
            }

        }

async override void SimpleCommunication::VideoChat::OnNavigatedTo ( NavigationEventArgs e ) [inline, protected]

Invoked when this page is about to be displayed in a Frame.

Parameters:
e Event data that describes how this page was reached. The Parameter property is typically used to configure the page.

Definition at line 52 of file VideoChat.xaml.cs.

        {
            var cameraFound = await CaptureDevice.CheckForRecordingDeviceAsync();

            if (cameraFound)
            {
                device = new CaptureDevice();
                await InitializeAsync();
                device.IncomingConnectionArrived += device_IncomingConnectionArrived;
                device.CaptureFailed += device_CaptureFailed;
                RemoteVideo.MediaFailed += RemoteVideo_MediaFailed;
            }
            else
            {
                rootPage.NotifyUser("A machine with a camera and a microphone is required to run this sample.", NotifyType.ErrorMessage);
            }
        }

async override void SimpleCommunication::VideoChat::OnNavigatingFrom ( NavigatingCancelEventArgs e ) [inline, protected]

Definition at line 70 of file VideoChat.xaml.cs.

        {
            base.OnNavigatingFrom(e);

            if (activated)
            {
                RemoteVideo.Stop();
                RemoteVideo.Source = null;
            }

            await device.CleanUpAsync();
            device = null;
        }

async void SimpleCommunication::VideoChat::RemoteVideo_MediaFailed | ( | object | sender,
 |  | ExceptionRoutedEventArgs | e |
 | ) |  |  | [inline, private]

Definition at line 111 of file VideoChat.xaml.cs.

        {
            if (Interlocked.CompareExchange(ref isTerminator, 1, 0) == 0)
            {
                await EndCallAsync();
            }
        }

async Task SimpleCommunication::VideoChat::StartRecordToCustomSink ( ) [inline, private]

Definition at line 153 of file VideoChat.xaml.cs.

        {
            MediaEncodingProfile mep = MediaEncodingProfile.CreateMp4(VideoEncodingQuality.Qvga);

            mep.Video.FrameRate.Numerator = 15;
            mep.Video.FrameRate.Denominator = 1;
            mep.Container = null;

            await device.StartRecordingAsync(mep);
        }

Member Data Documentation

bool SimpleCommunication::VideoChat::activated = false [private]

Definition at line 38 of file VideoChat.xaml.cs.

CaptureDevice SimpleCommunication::VideoChat::device = null [private]

Definition at line 35 of file VideoChat.xaml.cs.

int SimpleCommunication::VideoChat::isTerminator = 0 [private]

Definition at line 37 of file VideoChat.xaml.cs.

bool SimpleCommunication::VideoChat::roleIsActive = null [private]

Definition at line 36 of file VideoChat.xaml.cs.

MainPage SimpleCommunication::VideoChat::rootPage = MainPage.Current [private]

Definition at line 33 of file VideoChat.xaml.cs.

The documentation for this class was generated from the following files:
  • Real-time communication/C#,C++/VideoChat.xaml.cs
  • Real-time communication/C++/VideoChat.xaml.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleController Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

SimpleController Class Reference

#include "SimpleController.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Render () override
void | Update (float timeTotal, float timeDelta)

Public Attributes

internal | __pad0__: SimpleController()

Private Member Functions

void | DrawButtonText (uint16 buttons, const D2D1_RECT_F &loc)
void | DrawHeader (const wchar_t *pText, const D2D1_RECT_F &loc)
void | DrawText (uint8 value, const D2D1_RECT_F &loc)
void | DrawText (const wchar_t *pText, const D2D1_RECT_F &loc)
void | DrawText (uint32 value, const D2D1_RECT_F &loc)
void | DrawText (int16 value, const D2D1_RECT_F &loc)
void | FetchControllerInput ()
void | RenderControllerInput ()

Private Attributes

Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_dataTextFormat
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_headerTextFormat
bool | m_isControllerConnected
uint64 | m_lastEnumTime
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush
XINPUT_CAPABILITIES | m_xinputCaps
XINPUT_STATE | m_xinputState

Detailed Description

Definition at line 13 of file SimpleController.h.

Member Function Documentation

void SimpleController::CreateDeviceResources ( ) [override, virtual]

Definition at line 60 of file SimpleController.cpp.

{
    DirectXBase::CreateDeviceResources();

    //
    // Create and initialize the default Sample graphics object
    //
    m_sampleOverlay = ref new SampleOverlay();
    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        ref new Platform::String(APPLICATION_TITLE)
        );

    //
    // Setup the local graphics objects
    //
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            FONT_NAME,
            nullptr,
            DWRITE_FONT_WEIGHT_SEMI_BOLD,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            FONT_SIZE_HEADER,
            FONT_LOCAL,
            &m_headerTextFormat
            )
        );
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            FONT_NAME,
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            FONT_SIZE_TEXT,
            FONT_LOCAL,
            &m_dataTextFormat
            )
        );

    DX::ThrowIfFailed(
        m_headerTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );
    DX::ThrowIfFailed(
        m_headerTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );
    DX::ThrowIfFailed(
        m_dataTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );
    DX::ThrowIfFailed(
        m_dataTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::White), &m_textBrush)
        );
}

void SimpleController::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 122 of file SimpleController.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();
    m_sampleOverlay->UpdateForWindowSizeChange();
}

void SimpleController::DrawButtonText | ( | uint16 | buttons,
 |  | const D2D1_RECT_F & | loc |
 | ) |  |  | [private]

Definition at line 339 of file SimpleController.cpp.

{
    char16 text[64];
    size_t where = 0;
    if (buttons & XINPUT_GAMEPAD_A)
    {
        text[where++] = L'A';
    }
    if (buttons & XINPUT_GAMEPAD_B)
    {
        text[where++] = L'B';
    }
    if (buttons & XINPUT_GAMEPAD_X)
    {
        text[where++] = L'X';
    }
    if (buttons & XINPUT_GAMEPAD_Y)
    {
        text[where++] = L'Y';
    }
    if (where != 0)
    {
        text[where++] = L' ';
    }

    size_t groupStart = where;
    if (buttons & XINPUT_GAMEPAD_DPAD_UP)
    {
        text[where++] = L'U';
    }
    if (buttons & XINPUT_GAMEPAD_DPAD_DOWN)
    {
        text[where++] = L'D';
    }
    if (buttons & XINPUT_GAMEPAD_DPAD_LEFT)
    {
        text[where++] = L'L';
    }
    if (buttons & XINPUT_GAMEPAD_DPAD_RIGHT)
    {
        text[where++] = L'R';
    }
    if (where != groupStart)
    {
        text[where++] = L' ';
    }

    if (buttons & XINPUT_GAMEPAD_LEFT_THUMB)
    {
        text[where++] = L'L';
        text[where++] = L'T';
        text[where++] = L' ';
    }
    if (buttons & XINPUT_GAMEPAD_RIGHT_THUMB)
    {
        text[where++] = L'R';
        text[where++] = L'T';
        text[where++] = L' ';
    }
    if (buttons & XINPUT_GAMEPAD_LEFT_SHOULDER)
    {
        text[where++] = L'L';
        text[where++] = L'S';
        text[where++] = L' ';
    }
    if (buttons & XINPUT_GAMEPAD_RIGHT_SHOULDER)
    {
        text[where++] = L'R';
        text[where++] = L'S';
        text[where++] = L' ';
    }
    if (buttons & XINPUT_GAMEPAD_START)
    {
        text[where++] = L'S';
        text[where++] = L't';
        text[where++] = L'a';
        text[where++] = L'r';
        text[where++] = L't';
        text[where++] = L' ';
    }
    if (buttons & XINPUT_GAMEPAD_BACK)
    {
        text[where++] = L'B';
        text[where++] = L'a';
        text[where++] = L'c';
        text[where++] = L'k';
    }
    text[where] = L'\0';

    DrawText(text, loc);
}

void SimpleController::DrawHeader | ( | const wchar_t * | pText,
 |  | const D2D1_RECT_F & | loc |
 | ) |  |  | [private]
void SimpleController::DrawText | ( | const wchar_t * | pText,
 |  | const D2D1_RECT_F & | loc |
 | ) |  |  | [private]
void SimpleController::DrawText | ( | uint32 | value,
 |  | const D2D1_RECT_F & | loc |
 | ) |  |  | [private]

Definition at line 318 of file SimpleController.cpp.

{
    char16 text[16];
    ::_snwprintf_s(text, sizeof(text)/sizeof(char16), L"0x%08X", value);
    DrawText(text, loc);
}

void SimpleController::DrawText | ( | int16 | value,
 |  | const D2D1_RECT_F & | loc |
 | ) |  |  | [private]

Definition at line 325 of file SimpleController.cpp.

{
    char16 text[16];
    ::_snwprintf_s(text, sizeof(text)/sizeof(char16), L"%05d", value);
    DrawText(text, loc);
}

void SimpleController::DrawText | ( | uint8 | value,
 |  | const D2D1_RECT_F & | loc |
 | ) |  |  | [private]

Definition at line 332 of file SimpleController.cpp.

{
    char16 text[8];
    ::_snwprintf_s(text, sizeof(text)/sizeof(char16), L"0x%02X", value);
    DrawText(text, loc);
}

void SimpleController::FetchControllerInput ( ) [private]

Definition at line 146 of file SimpleController.cpp.

{
    if (!m_isControllerConnected)
    {
        //
        // Ennumerating for XInput devices takes 'time' on the order of milliseconds.
        // Any time a device is not currently known as connected (not yet called XInput, or calling
        // an XInput function after a failure) ennumeration happens.
        // An app should avoid repeatedly calling XInput functions if there are no known devices connected
        // as this can slow down application performance.
        // This sample takes the simple approach of not calling XInput functions after failure
        // until a specified timeout has passed.
        //
        uint64 currentTime = ::GetTickCount64();
        if (currentTime - m_lastEnumTime < XINPUT_ENUM_TIMEOUT_MS)
        {
            return;
        }
        m_lastEnumTime = currentTime;

        // Check for controller connection by trying to get the capabilties
        uint32 capsResult = XInputGetCapabilities(0, XINPUT_FLAG_GAMEPAD, &m_xinputCaps);
        if (capsResult != ERROR_SUCCESS)
        {
            return;
        }

        // Device is connected
        m_isControllerConnected = true;
    }

    uint32 stateResult = XInputGetState(0, &m_xinputState);
    if (stateResult != ERROR_SUCCESS)
    {
        // Device is no longer connected
        m_isControllerConnected = false;
        m_lastEnumTime = ::GetTickCount64();
    }
}

void SimpleController::Render ( ) [override, virtual]

Definition at line 128 of file SimpleController.cpp.

{
    // Bind the render target
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get());

    // Clear the render target
    m_d3dContext->ClearRenderTargetView(m_d3dRenderTargetView.Get(), CLEAR_COLOR);

    // Render the default sample header
    m_sampleOverlay->Render();

    // Render the controller data
    RenderControllerInput();
}

void SimpleController::RenderControllerInput ( ) [private]

Definition at line 186 of file SimpleController.cpp.

{
    D2D1_SIZE_F size = m_d2dContext->GetSize();
    D2D1_RECT_F pos = D2D1::RectF(INFORMATION_START_X, INFORMATION_START_Y, size.width, size.height);

    m_d2dContext->BeginDraw();

    if (!m_isControllerConnected)
    {
        //
        // Display message instructing user to connect a controller.
        //
        DrawText(MSG_NEED_CONTROLLER, pos);
    }
    else
    {
        //
        // Display State information
        //

        // Labels
        DrawHeader(STATE_HEADER, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_STATE_PACKET_NUMBER, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_STATE_LEFT_TRIGGER, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_STATE_RIGHT_TRIGGER, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_STATE_LEFT_THUMB_X, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_STATE_LEFT_THUMB_Y, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_STATE_RIGHT_THUMB_X, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_STATE_RIGHT_THUMB_Y, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_STATE_BUTTONS, pos);

        // Values
        pos.top = INFORMATION_START_Y + LINE_HEIGHT;
        pos.left = INPUT_DATA_START;
        DrawText(static_cast<uint32>(m_xinputState.dwPacketNumber), pos);
        pos.top += LINE_HEIGHT;
        DrawText(m_xinputState.Gamepad.bLeftTrigger, pos);
        pos.top += LINE_HEIGHT;
        DrawText(m_xinputState.Gamepad.bRightTrigger, pos);
        pos.top += LINE_HEIGHT;
        DrawText(m_xinputState.Gamepad.sThumbLX, pos);
        pos.top += LINE_HEIGHT;
        DrawText(m_xinputState.Gamepad.sThumbLY, pos);
        pos.top += LINE_HEIGHT;
        DrawText(m_xinputState.Gamepad.sThumbRX, pos);
        pos.top += LINE_HEIGHT;
        DrawText(m_xinputState.Gamepad.sThumbRY, pos);
        pos.top += LINE_HEIGHT;
        DrawButtonText(m_xinputState.Gamepad.wButtons, pos);

        //
        // Display Capabilties
        //

        // Labels
        pos.top = INFORMATION_START_Y;
        pos.left = CAPS_LABEL_START;
        DrawHeader(CAPS_HEADER, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_CAPS_TYPE, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_CAPS_SUBTYPE, pos);
        pos.top += LINE_HEIGHT;
        DrawText(LABEL_CAPS_FLAGS, pos);

        // Values
        pos.top = INFORMATION_START_Y + LINE_HEIGHT;
        pos.left = CAPS_DATA_START;
        DrawText(m_xinputCaps.Type, pos);
        pos.top += LINE_HEIGHT;
        DrawText(m_xinputCaps.SubType, pos);
        pos.top += LINE_HEIGHT;
        if (m_xinputCaps.Flags & XINPUT_CAPS_WIRELESS)
        {
            DrawText(VALUE_CAPS_WIRELESS, pos);
        }
        else
        {
            DrawText(VALUE_CAPS_WIRED, pos);
        }
        if (m_xinputCaps.Flags & XINPUT_CAPS_VOICE_SUPPORTED)
        {
            pos.top += LINE_HEIGHT;
            DrawText(VALUE_CAPS_VOICE_SUPPORT, pos);
        }
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void SimpleController::Update | ( | float | timeTotal,
 |  | float | timeDelta
 | ) |  |

Definition at line 290 of file SimpleController.cpp.

{
    FetchControllerInput();
}

Member Data Documentation

internal SimpleController::__pad0__

Definition at line 16 of file SimpleController.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> SimpleController::m_dataTextFormat [private]

Definition at line 49 of file SimpleController.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> SimpleController::m_headerTextFormat [private]

Definition at line 48 of file SimpleController.h.

bool SimpleController::m_isControllerConnected [private]

Definition at line 42 of file SimpleController.h.

uint64 SimpleController::m_lastEnumTime [private]

Definition at line 45 of file SimpleController.h.

SampleOverlay SimpleController::m_sampleOverlay [private]

Definition at line 39 of file SimpleController.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> SimpleController::m_textBrush [private]

Definition at line 50 of file SimpleController.h.

XINPUT_CAPABILITIES SimpleController::m_xinputCaps [private]

Definition at line 43 of file SimpleController.h.

XINPUT_STATE SimpleController::m_xinputState [private]

Definition at line 44 of file SimpleController.h.

The documentation for this class was generated from the following files:
  • XInput game controller/C++/SimpleController.h
  • XInput game controller/C++/SimpleController.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCubeVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SimpleCubeVertex Struct Reference

List of all members.

Public Attributes

float3 color
float3 pos

Detailed Description

Definition at line 19 of file Main.cpp.

Member Data Documentation

float3 SimpleCubeVertex::color

Definition at line 22 of file Main.cpp.

float3 SimpleCubeVertex::pos

Definition at line 21 of file Main.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D tutorial/C++/Lesson3.Cubes/Main.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleSprites Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

SimpleSprites Class Reference

#include "SimpleSprites.h"

List of all members.

Public Member Functions

void | AddRepulsor (_In_ uint32 id, _In_ float2 position)
virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
void | MoveRepulsor (_In_ uint32 id, _In_ float2 position)
void | RemoveRepulsor (_In_ uint32 id)
virtual void | Render () override
void | Update (float timeTotal, float timeDelta)

Public Attributes

internal | __pad0__: SimpleSprites()

Private Member Functions

float | RandFloat (float min, float max)

Private Attributes

Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_asteroid
std::vector< AsteroidData > | m_asteroidData
AutoThrottle m_autoThrottle
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_background
int | m_numParticlesToDraw
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_particle
std::vector< ParticleData > | m_particleData
std::map< uint32, float2 > | m_repulsors
SampleOverlay m_sampleOverlay
BasicSprites::SpriteBatch m_spriteBatch

Detailed Description

Definition at line 48 of file SimpleSprites.h.

Member Function Documentation

void SimpleSprites::AddRepulsor | ( | _In_ uint32 | id,
 |  | _In_ float2 | position
 | ) |  |

Definition at line 354 of file SimpleSprites.cpp.

{
    m_repulsors[id] = position;
}

void SimpleSprites::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 24 of file SimpleSprites.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create the performance throttler.

    m_autoThrottle = ref new AutoThrottle(SampleSettings::Performance::TargetFrameTime);
}

void SimpleSprites::CreateDeviceResources ( ) [override, virtual]

Definition at line 33 of file SimpleSprites.cpp.

{
    DirectXBase::CreateDeviceResources();

    // Create the sprite batch.

    m_spriteBatch = ref new SpriteBatch();
    unsigned int capacity = SampleSettings::Performance::ParticleCountMax + SampleSettings::NumAsteroids + 1;
    if (m_featureLevel < D3D_FEATURE_LEVEL_9_3)
    {
        capacity = min(Parameters::MaximumCapacityCompatible, capacity);
    }
    m_spriteBatch->Initialize(
        m_d3dDevice.Get(),
        capacity
        );

    // Load the sprite textures.

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get(), m_wicFactory.Get());

    loader->LoadTexture(
        "m31.png",
        &m_background,
        nullptr
        );
    m_spriteBatch->AddTexture(m_background.Get());

    loader->LoadTexture(
        "ida.dds",
        &m_asteroid,
        nullptr
        );
    m_spriteBatch->AddTexture(m_asteroid.Get());

    loader->LoadTexture(
        "particle.dds",
        &m_particle,
        nullptr
        );
    m_spriteBatch->AddTexture(m_particle.Get());

    // Create the Sample Overlay.

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct3D SpriteBatch sample"
        );
}

void SimpleSprites::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 88 of file SimpleSprites.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // Randomly generate some non-interactive asteroids to fit the screen.

    m_asteroidData.clear();
    for (int i = 0; i < SampleSettings::NumAsteroids; i++)
    {
        AsteroidData data;
        data.pos.x = RandFloat(0.0f, m_windowBounds.Width);
        data.pos.y = RandFloat(0.0f, m_windowBounds.Height);
        float tempRot = RandFloat(-PI_F, PI_F);
        float tempMag = RandFloat(0.0f, 17.0f);
        data.vel.x = tempMag * cosf(tempRot);
        data.vel.y = tempMag * sinf(tempRot);
        data.rot = RandFloat(-PI_F, PI_F);
        data.scale = RandFloat(0.1f, 1.0f);
        data.rotVel = RandFloat(-PI_F, PI_F) / (7.0f + 3.0f * data.scale);
        m_asteroidData.push_back(data);
    }

    if (m_particleData.size() == 0)
    {
        // Initialize the interactive particle buffer to fill the window if it is empty.

        for (int i = 0; i < SampleSettings::Performance::ParticleCountMax; i++)
        {
            ParticleData data;
            data.pos.x = RandFloat(0.0f, m_windowBounds.Width);
            data.pos.y = RandFloat(0.0f, m_windowBounds.Height);
            data.vel = float2(0.0f, 0.0f);
            m_particleData.push_back(data);
        }
    }
    else
    {
        // Otherwise, move the interactive particles to fit within the screen.

        for (auto particle = m_particleData.begin(); particle != m_particleData.end(); particle++)
        {
            if (particle->pos.x > m_windowBounds.Width)
            {
                particle->pos.x = m_windowBounds.Width;
            }
            if (particle->pos.y > m_windowBounds.Height)
            {
                particle->pos.y = m_windowBounds.Height;
            }
        }
    }

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void SimpleSprites::MoveRepulsor | ( | _In_ uint32 | id,
 |  | _In_ float2 | position
 | ) |  |

Definition at line 359 of file SimpleSprites.cpp.

{
    m_repulsors[id] = position;
}

float SimpleSprites::RandFloat | ( | float | min,
 |  | float | max |
 | ) |  |  | [private]

Definition at line 349 of file SimpleSprites.cpp.

{
    return (static_cast<float>(rand() % RAND_MAX) / static_cast<float>(RAND_MAX)) * (max - min) + min;
}

void SimpleSprites::RemoveRepulsor ( _In_ uint32 id )

Definition at line 364 of file SimpleSprites.cpp.

{
    m_repulsors.erase(id);
}

void SimpleSprites::Render ( ) [override, virtual]

Definition at line 285 of file SimpleSprites.cpp.

{
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        nullptr
        );

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        reinterpret_cast<float*>(&D2D1::ColorF(D2D1::ColorF::MidnightBlue))
        );

    m_spriteBatch->Begin();

    // Draw the background.

    m_spriteBatch->Draw(
        m_background.Get(),
        float2(0.5f, 0.5f),
        PositionUnits::Normalized,
        float2(1.0f, 1.0f),
        SizeUnits::Normalized
        );

    // Draw the non-interactive asteroids.

    for (auto asteroid = m_asteroidData.begin(); asteroid != m_asteroidData.end(); asteroid++)
    {
        m_spriteBatch->Draw(
            m_asteroid.Get(),
            asteroid->pos,
            PositionUnits::DIPs,
            float2(1.0f, 1.0f) * asteroid->scale,
            SizeUnits::Normalized,
            float4(0.8f, 0.8f, 1.0f, 1.0f),
            asteroid->rot
            );
    }

    // Draw the interactive particles.

    for (auto particle = m_particleData.begin(); particle != m_particleData.begin() + m_numParticlesToDraw; particle++)
    {
        float alpha = length(particle->vel) / 200.0f;
        m_spriteBatch->Draw(
            m_particle.Get(),
            particle->pos,
            PositionUnits::DIPs,
            float2(32.0f, 32.0f),
            SizeUnits::DIPs,
            float4(0.1f, 0.02f, 0.0f, alpha),
            0.0f,
            BlendMode::Additive
            );
    }

    m_spriteBatch->End();

    // Render the Sample Overlay.

    m_sampleOverlay->Render();
}

void SimpleSprites::Update | ( | float | timeTotal,
 |  | float | timeDelta
 | ) |  |

Definition at line 144 of file SimpleSprites.cpp.

{
    // Update the performance throttler.

    auto control = m_autoThrottle->Update(timeDelta);

    if (control == FrameWorkload::Increase)
    {
        m_numParticlesToDraw += SampleSettings::Performance::ParticleCountDelta;
    }
    if (control == FrameWorkload::Decrease)
    {
        m_numParticlesToDraw -= SampleSettings::Performance::ParticleCountDelta;
    }
    if (control != FrameWorkload::Maintain)
    {
        m_numParticlesToDraw = max(SampleSettings::Performance::ParticleCountMin, min(SampleSettings::Performance::ParticleCountMax, m_numParticlesToDraw));
        if (m_featureLevel < D3D_FEATURE_LEVEL_9_3)
        {
            m_numParticlesToDraw = min(static_cast<int>(Parameters::MaximumCapacityCompatible - SampleSettings::NumAsteroids - 1), m_numParticlesToDraw);
        }
    }

    // Update the non-interactive asteroids.
    // Their behavior is to drift across the window with a fixed translational and rotational
    // velocity.  Upon crossing a boundary outside the window, their position wraps.

    for (auto asteroid = m_asteroidData.begin(); asteroid != m_asteroidData.end(); asteroid++)
    {
        static const float border = 100.0f;
        asteroid->pos = asteroid->pos + asteroid->vel * timeDelta;
        if (asteroid->vel.x < 0)
        {
            if (asteroid->pos.x < -border)
            {
                asteroid->pos.x = m_windowBounds.Width + border;
            }
        }
        else
        {
            if (asteroid->pos.x > m_windowBounds.Width + border)
            {
                asteroid->pos.x = -border;
            }
        }
        if (asteroid->vel.y < 0)
        {
            if (asteroid->pos.y < -border)
            {
                asteroid->pos.y = m_windowBounds.Height + border;
            }
        }
        else
        {
            if (asteroid->pos.y > m_windowBounds.Height + border)
            {
                asteroid->pos.y = -border;
            }
        }

        asteroid->rot += asteroid->rotVel * timeDelta;
        if (asteroid->rot > PI_F)
        {
            asteroid->rot -= 2.0f * PI_F;
        }
        if (asteroid->rot < -PI_F)
        {
            asteroid->rot += 2.0f * PI_F;
        }
    }

    // Update the interactive particles.
    // Their behavior is to be gravitationally attracted to two oscillating gravity
    // wells and repelled by any pressed pointer points.  Upon reaching the edge of
    // the window, the particles bounce.

    // Add two gravity wells that move throughout the window.
    float2 wellPositions[] =
    {
        float2(
            (1.0f + 0.8f * cosf(timeTotal / (2.0f * PI_F) + 3.0f)) * m_windowBounds.Width / 2.0f,
            (1.0f + 0.8f * sinf(timeTotal / 5.0f)) * m_windowBounds.Height / 2.0f
            ),
        float2(
            (1.0f + 0.8f * cosf(timeTotal / (PI_F * PI_F) + 1.0f)) * m_windowBounds.Width / 2.0f,
            (1.0f + 0.8f * sinf(timeTotal / PI_F)) * m_windowBounds.Height / 2.0f
            )
    };

    for (auto particle = m_particleData.begin(); particle != m_particleData.begin() + m_numParticlesToDraw; particle++)
    {
        if (particle->pos.x < 0)
        {
            particle->vel.x = abs(particle->vel.x);
        }
        if (particle->pos.x > m_windowBounds.Width)
        {
            particle->vel.x = -abs(particle->vel.x);
        }
        if (particle->pos.y < 0)
        {
            particle->vel.y = abs(particle->vel.y);
        }
        if (particle->pos.y > m_windowBounds.Height)
        {
            particle->vel.y = -abs(particle->vel.y);
        }

        for (auto repulsor = m_repulsors.begin(); repulsor != m_repulsors.end(); repulsor++)
        {
            float2 delta = particle->pos - repulsor->second;
            float deltaLength = length(delta) + 24.0f; // Offset length to avoid division by zero.
            float deltaLengthCubed = deltaLength * deltaLength * deltaLength;
            particle->vel = particle->vel + SampleSettings::Physics::Gravity * timeDelta * delta / deltaLengthCubed;
        }

        for (int i = 0; i < ARRAYSIZE(wellPositions); i++)
        {
            float gravitySign = 1.0f;
            if ((static_cast<int>(timeTotal / 2.0f) + 1) % 10 == 0)
            {
                // Every 20 seconds, "explode" the gravity wells for 2 seconds.
                gravitySign = -1.0f;
            }
            float2 delta = wellPositions[i] - particle->pos;
            float deltaLength = length(delta) + 24.0f;
            float deltaLengthCubed = deltaLength * deltaLength * deltaLength;
            particle->vel = particle->vel + gravitySign * 0.2f * SampleSettings::Physics::Gravity * timeDelta * delta / deltaLengthCubed;
        }

        particle->vel = particle->vel * (1.0f - SampleSettings::Physics::Damping);

        // Add random noise to the velocity to prevent particles from locking together.

        particle->vel.x += RandFloat(-0.5f, 0.5f);
        particle->vel.y += RandFloat(-0.5f, 0.5f);

        particle->pos = particle->pos + particle->vel * timeDelta;
    }
}

Member Data Documentation

internal SimpleSprites::__pad0__

Definition at line 51 of file SimpleSprites.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> SimpleSprites::m_asteroid [private]

Definition at line 67 of file SimpleSprites.h.

std::vector<AsteroidData> SimpleSprites::m_asteroidData [private]

Definition at line 69 of file SimpleSprites.h.

AutoThrottle SimpleSprites::m_autoThrottle [private]

Definition at line 64 of file SimpleSprites.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> SimpleSprites::m_background [private]

Definition at line 66 of file SimpleSprites.h.

int SimpleSprites::m_numParticlesToDraw [private]

Definition at line 72 of file SimpleSprites.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> SimpleSprites::m_particle [private]

Definition at line 68 of file SimpleSprites.h.

std::vector<ParticleData> SimpleSprites::m_particleData [private]

Definition at line 70 of file SimpleSprites.h.

std::map<uint32, float2> SimpleSprites::m_repulsors [private]

Definition at line 71 of file SimpleSprites.h.

SampleOverlay SimpleSprites::m_sampleOverlay [private]

Definition at line 63 of file SimpleSprites.h.

BasicSprites::SpriteBatch SimpleSprites::m_spriteBatch [private]

Definition at line 65 of file SimpleSprites.h.

The documentation for this class was generated from the following files:
  • Direct3D sprite/C++/SimpleSprites.h
  • Direct3D sprite/C++/SimpleSprites.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SimpleVertex Struct Reference

#include "Extruder.h"

List of all members.

Public Attributes

float3 Norm
float3 Pos

Detailed Description

Definition at line 13 of file Extruder.h.

Member Data Documentation

float3 SimpleVertex::Norm

Definition at line 16 of file Extruder.h.

float3 SimpleVertex::Pos

Definition at line 15 of file Extruder.h.

The documentation for this struct was generated from the following file:
  • DirectX postcard app/C++/Extruder.h
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SoundEffect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

SoundEffect Class Reference

#include "SoundEffect.h"

List of all members.

Public Member Functions

void | Initialize (_In_ IXAudio2 *masteringEngine, _In_ WAVEFORMATEX *sourceFormat, _In_ Platform::Array< byte >^soundData)
void | Initialize (_In_ IXAudio2 *masteringEngine, _In_ WAVEFORMATEX *sourceFormat, _In_ Platform::Array< byte >^soundData)
void | PlaySound (_In_ float volume)
void | PlaySound (_In_ float volume)

Public Attributes

internal | __pad0__: SoundEffect()

Private Attributes

bool | m_audioAvailable
Platform::Array< byte > | m_soundData
IXAudio2SourceVoice * | m_sourceVoice

Detailed Description

Definition at line 15 of file SoundEffect.h.

Member Function Documentation

void SoundEffect::Initialize | ( | _In_ IXAudio2 * | masteringEngine,
 |  | _In_ WAVEFORMATEX * | sourceFormat,
 |  | _In_ Platform::Array< byte >^ | soundData
 | ) |  |

Definition at line 19 of file SoundEffect.cpp.

{
    m_soundData = soundData;

    if (masteringEngine == nullptr)
    {
        // Audio is not available so just return.
        m_audioAvailable = false;
        return;
    }

    // Create a source voice for this sound effect.
    DX::ThrowIfFailed(
        masteringEngine->CreateSourceVoice(
            &m_sourceVoice,
            sourceFormat
            )
        );
    m_audioAvailable = true;
}

void SoundEffect::Initialize | ( | _In_ IXAudio2 * | masteringEngine,
 |  | _In_ WAVEFORMATEX * | sourceFormat,
 |  | _In_ Platform::Array< byte >^ | soundData
 | ) |  |
void SoundEffect::PlaySound ( _In_ float volume )
void SoundEffect::PlaySound ( _In_ float volume )

Definition at line 45 of file SoundEffect.cpp.

{
    XAUDIO2_BUFFER buffer = {0};

    if (!m_audioAvailable)
    {
        // Audio is not available so just return.
        return;
    }

    // Interrupt sound effect if it is currently playing.
    DX::ThrowIfFailed(
        m_sourceVoice->Stop()
        );
    DX::ThrowIfFailed(
        m_sourceVoice->FlushSourceBuffers()
        );

    // Queue the memory buffer for playback and start the voice.
    buffer.AudioBytes = m_soundData->Length;
    buffer.pAudioData = m_soundData->Data;
    buffer.Flags = XAUDIO2_END_OF_STREAM;

    DX::ThrowIfFailed(
        m_sourceVoice->SetVolume(volume)
        );
    DX::ThrowIfFailed(
        m_sourceVoice->SubmitSourceBuffer(&buffer)
        );
    DX::ThrowIfFailed(
        m_sourceVoice->Start()
        );
}

Member Data Documentation

internal SoundEffect::__pad0__

Definition at line 18 of file SoundEffect.h.

bool SoundEffect::m_audioAvailable [private]

Definition at line 29 of file SoundEffect.h.

Platform::Array< byte > SoundEffect::m_soundData [private]

Definition at line 31 of file SoundEffect.h.

IXAudio2SourceVoice * SoundEffect::m_sourceVoice [private]

Definition at line 30 of file SoundEffect.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/SoundEffect.h
  • XAML DirectX 3D shooting game/C++/SoundEffect.h
  • DirectX 3D shooting game/C++/SoundEffect.cpp
  • XAML DirectX 3D shooting game/C++/SoundEffect.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SoundEffectData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SoundEffectData Struct Reference

#include "Audio.h"

List of all members.

Public Attributes

XAUDIO2_BUFFER | m_audioBuffer
byte * | m_soundEffectBufferData
uint32 | m_soundEffectBufferLength
uint32 | m_soundEffectSampleRate
IXAudio2SourceVoice * | m_soundEffectSourceVoice
bool | m_soundEffectStarted
SoundEvent m_soundEventType

Detailed Description

Definition at line 30 of file Audio.h.

Member Data Documentation

XAUDIO2_BUFFER SoundEffectData::m_audioBuffer

Definition at line 34 of file Audio.h.

byte* SoundEffectData::m_soundEffectBufferData

Definition at line 35 of file Audio.h.

uint32 SoundEffectData::m_soundEffectBufferLength

Definition at line 36 of file Audio.h.

uint32 SoundEffectData::m_soundEffectSampleRate

Definition at line 37 of file Audio.h.

IXAudio2SourceVoice* SoundEffectData::m_soundEffectSourceVoice

Definition at line 33 of file Audio.h.

bool SoundEffectData::m_soundEffectStarted

Definition at line 38 of file Audio.h.

SoundEvent SoundEffectData::m_soundEventType

Definition at line 32 of file Audio.h.

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/Audio.h
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SoundFileReader Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

SoundFileReader Class Reference

#include "SoundFileReader.h"

List of all members.

Public Member Functions

SoundFileReader (_In_ Platform::String^soundFileName)
Platform::Array< byte > | GetSoundData () const
WAVEFORMATEX * | GetSoundFormat () const

Private Attributes

Platform::Array< byte > | m_soundData
Platform::Array< byte > | m_soundFormat

Detailed Description

Definition at line 10 of file SoundFileReader.h.

Constructor & Destructor Documentation

SoundFileReader::SoundFileReader ( _In_ Platform::String^ soundFileName )

Definition at line 84 of file SoundFileReader.cpp.

{
    //
    // Open the file for random read access
    //
    RandomAccessReader^ riffFile = ref new RandomAccessReader(fileName);
    uint64 fileSize = riffFile->GetFileSize();

    //
    // Locate, read and validate the RIFF chunk
    //
    uint64 riffLoc = FindChunk(riffFile, FOURCC_RIFF_TAG, 0, fileSize);

    // Read beyond the riff header.
    ChunkHeader chunkHeader;
    ReadHeader(riffFile, riffLoc, chunkHeader);

    uint32 tag = 0;
    Platform::Array<byte>^ riffData = riffFile->Read(sizeof(tag));
    tag = *reinterpret_cast<uint32*>(riffData->Data);
    if (tag != FOURCC_WAVE_FILE_TAG)
    {
        // Only support .wav files
        throw ref new Platform::FailureException();
    }
    uint64 riffChildrenStart = riffLoc + sizeof(chunkHeader) + sizeof(tag);
    uint64 riffChildrenEnd   = riffLoc + sizeof(chunkHeader) + chunkHeader.size;

    //
    // Find, read and validate the format chunk (a child within the RIFF chunk)
    //
    uint64 formatLoc = FindChunk(riffFile, FOURCC_FORMAT_TAG, riffChildrenStart, riffChildrenEnd);
    ReadHeader(riffFile, formatLoc, chunkHeader);
    if (chunkHeader.size < sizeof(WAVEFORMATEX))
    {
        // Format data of unsupported size; must be unsupported format
        throw ref new Platform::FailureException();
    }
    m_soundFormat = riffFile->Read(chunkHeader.size);
    WAVEFORMATEX format = *reinterpret_cast<WAVEFORMATEX*>(m_soundFormat->Data);
    if (format.wFormatTag != WAVE_FORMAT_PCM
        && format.wFormatTag != WAVE_FORMAT_ADPCM)
    {
        // This is not PCM or ADPCM, which is all we support
        throw ref new Platform::FailureException();
    }

    //
    // Locate, the PCM data in the data chunk
    //
    uint64 dataChunkStart = FindChunk(riffFile, FOURCC_DATA_TAG, riffChildrenStart, riffChildrenEnd);
    ReadHeader(riffFile, dataChunkStart, chunkHeader);

    //
    // Now read the PCM data and setup the buffer
    //
    m_soundData = riffFile->Read(chunkHeader.size);
}

Member Function Documentation

Platform::Array< byte > SoundFileReader::GetSoundData ( ) const

Definition at line 149 of file SoundFileReader.cpp.

{
    return m_soundData;
}

WAVEFORMATEX * SoundFileReader::GetSoundFormat ( ) const

Definition at line 158 of file SoundFileReader.cpp.

{
    return reinterpret_cast<WAVEFORMATEX*>(m_soundFormat->Data);
}

Member Data Documentation

Platform::Array<byte> SoundFileReader::m_soundData [private]

Definition at line 19 of file SoundFileReader.h.

Platform::Array<byte> SoundFileReader::m_soundFormat [private]

Definition at line 20 of file SoundFileReader.h.

The documentation for this class was generated from the following files:
  • XAudio2 audio file playback/C++/SoundFileReader.h
  • XAudio2 audio file playback/C++/SoundFileReader.cpp
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SourceOp Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Types | Public Member Functions | Static Public Member Functions | Protected Attributes

SourceOp Class Reference

#include "MPEG1Src.h"

Inherited by SetRateOp, SetRateOp, StartOp, and StartOp.

List of all members.

Public Types

enum Operation {
OP_START, OP_PAUSE, OP_STOP, OP_SETRATE,
OP_REQUEST_DATA, OP_END_OF_STREAM, OP_START, OP_PAUSE,
OP_STOP, OP_SETRATE, OP_REQUEST_DATA, OP_END_OF_STREAM
}
enum Operation {
OP_START, OP_PAUSE, OP_STOP, OP_SETRATE,
OP_REQUEST_DATA, OP_END_OF_STREAM, OP_START, OP_PAUSE,
OP_STOP, OP_SETRATE, OP_REQUEST_DATA, OP_END_OF_STREAM
}

Public Member Functions

SourceOp (Operation op)
SourceOp (Operation op)
virtual | ~SourceOp ()
virtual | ~SourceOp ()
const PROPVARIANT & | Data ()
const PROPVARIANT & | Data ()
Operation | Op () const
Operation | Op () const
STDMETHODIMP | QueryInterface (REFIID iid, void **ppv)
STDMETHODIMP | QueryInterface (REFIID iid, void **ppv)
HRESULT | SetData (const PROPVARIANT &var)
HRESULT | SetData (const PROPVARIANT &var)
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (ULONG) Release()
STDMETHODIMP_ (ULONG) AddRef()
STDMETHODIMP_ (ULONG) Release()

Static Public Member Functions

static HRESULT | CreateOp (Operation op, SourceOp **ppOp)
static HRESULT | CreateOp (Operation op, SourceOp **ppOp)
static HRESULT | CreateSetRateOp (BOOL fThin, float flRate, SourceOp **ppOp)
static HRESULT | CreateSetRateOp (BOOL fThin, float flRate, SourceOp **ppOp)
static HRESULT | CreateStartOp (IMFPresentationDescriptor *pPD, SourceOp **ppOp)
static HRESULT | CreateStartOp (IMFPresentationDescriptor *pPD, SourceOp **ppOp)

Protected Attributes

long | m_cRef
PROPVARIANT | m_data
Operation m_op

Detailed Description

Definition at line 180 of file MPEG1Src.h.

Member Enumeration Documentation

enum SourceOp::Operation
Enumerator:
OP_START
OP_PAUSE
OP_STOP
OP_SETRATE
OP_REQUEST_DATA
OP_END_OF_STREAM
OP_START
OP_PAUSE
OP_STOP
OP_SETRATE
OP_REQUEST_DATA
OP_END_OF_STREAM

Definition at line 184 of file MPEG1Src.h.

    {
        OP_START,
        OP_PAUSE,
        OP_STOP,
        OP_SETRATE,
        OP_REQUEST_DATA,
        OP_END_OF_STREAM
    };

enum SourceOp::Operation
Enumerator:
OP_START
OP_PAUSE
OP_STOP
OP_SETRATE
OP_REQUEST_DATA
OP_END_OF_STREAM
OP_START
OP_PAUSE
OP_STOP
OP_SETRATE
OP_REQUEST_DATA
OP_END_OF_STREAM

Definition at line 184 of file MPEG1Src.h.

    {
        OP_START,
        OP_PAUSE,
        OP_STOP,
        OP_SETRATE,
        OP_REQUEST_DATA,
        OP_END_OF_STREAM
    };

Constructor & Destructor Documentation

SourceOp::SourceOp ( Operation op )

Definition at line 2323 of file MPEG1Src.cpp.

                               : m_cRef(1), m_op(op)
{
    ZeroMemory(&m_data, sizeof(m_data));
}

SourceOp::~SourceOp ( ) [virtual]

Definition at line 2328 of file MPEG1Src.cpp.

{
    PropVariantClear(&m_data);
}

SourceOp::SourceOp ( Operation op )
virtual SourceOp::~SourceOp ( ) [virtual]

Member Function Documentation

HRESULT SourceOp::CreateOp | ( | SourceOp::Operation | op,
 |  | SourceOp ** | ppOp |
 | ) |  |  | [static]

Definition at line 2220 of file MPEG1Src.cpp.

{
    if (ppOp == NULL)
    {
        return E_POINTER;
    }

    SourceOp *pOp = new (std::nothrow) SourceOp(op);
    if (pOp  == NULL)
    {
        return E_OUTOFMEMORY;
    }
    *ppOp = pOp;

    return S_OK;
}

static HRESULT SourceOp::CreateOp | ( | Operation | op,
 |  | SourceOp ** | ppOp |
 | ) |  |  | [static]
HRESULT SourceOp::CreateSetRateOp | ( | BOOL | fThin,
 |  | float | flRate,
 |  | SourceOp ** | ppOp |
 | ) |  |  | [static]

Definition at line 2273 of file MPEG1Src.cpp.

{
    if (ppOp == NULL)
    {
        return E_POINTER;
    }

    SourceOp *pOp = new (std::nothrow) SetRateOp(fThin, flRate);
    if (pOp == NULL)
    {
        return E_OUTOFMEMORY;
    }

    *ppOp = pOp;
    return S_OK;
}

static HRESULT SourceOp::CreateSetRateOp | ( | BOOL | fThin,
 |  | float | flRate,
 |  | SourceOp ** | ppOp |
 | ) |  |  | [static]
HRESULT SourceOp::CreateStartOp | ( | IMFPresentationDescriptor * | pPD,
 |  | SourceOp ** | ppOp |
 | ) |  |  | [static]

Definition at line 2246 of file MPEG1Src.cpp.

{
    if (ppOp == NULL)
    {
        return E_POINTER;
    }

    SourceOp *pOp = new (std::nothrow) StartOp(pPD);
    if (pOp == NULL)
    {
        return E_OUTOFMEMORY;
    }

    *ppOp = pOp;
    return S_OK;
}

static HRESULT SourceOp::CreateStartOp | ( | IMFPresentationDescriptor * | pPD,
 |  | SourceOp ** | ppOp |
 | ) |  |  | [static]
const PROPVARIANT& SourceOp::Data ( ) [inline]

Definition at line 209 of file MPEG1Src.h.

{ return m_data;}

const PROPVARIANT& SourceOp::Data ( ) [inline]

Definition at line 209 of file MPEG1Src.h.

{ return m_data;}

Operation SourceOp::Op ( ) const [inline]

Definition at line 208 of file MPEG1Src.h.

{ return m_op; }

Operation SourceOp::Op ( ) const [inline]

Definition at line 208 of file MPEG1Src.h.

{ return m_op; }

HRESULT SourceOp::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppv
 | ) |  |

Definition at line 2305 of file MPEG1Src.cpp.

{
    if (ppv == nullptr)
    {
        return E_POINTER;
    }

    HRESULT hr = E_NOINTERFACE;
    if (riid == IID_IUnknown)
    {
        (*ppv) = static_cast<IUnknown *>(this);
        AddRef();
        hr = S_OK;
    }

    return hr;
}

STDMETHODIMP SourceOp::QueryInterface | ( | REFIID | iid,
 |  | void ** | ppv
 | ) |  |
HRESULT SourceOp::SetData ( const PROPVARIANT & var )
HRESULT SourceOp::SetData ( const PROPVARIANT & var )

Definition at line 2333 of file MPEG1Src.cpp.

{
    return PropVariantCopy(&m_data, &var);
}

SourceOp::STDMETHODIMP_ ( ULONG )
SourceOp::STDMETHODIMP_ ( ULONG )
SourceOp::STDMETHODIMP_ ( ULONG )
SourceOp::STDMETHODIMP_ ( ULONG )

Member Data Documentation

long SourceOp::m_cRef [protected]

Definition at line 212 of file MPEG1Src.h.

PROPVARIANT SourceOp::m_data [protected]

Definition at line 214 of file MPEG1Src.h.

Operation SourceOp::m_op [protected]

Definition at line 213 of file MPEG1Src.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sphere Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Sphere Class Reference

#include "Sphere.h"

Inherits GameObject, and GameObject.

List of all members.

Public Member Functions

Sphere (DirectX::XMFLOAT3 pos, float radius)
Sphere ()
Sphere (const XMFLOAT3 &centerIn, FLOAT radius)
Sphere (float x, float y, float z, float radius)
Sphere (DirectX::XMFLOAT3 pos, float radius)
virtual bool | IsTouching (DirectX::XMFLOAT3 point, float radius, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal) override
virtual bool | IsTouching (DirectX::XMFLOAT3 point, float radius, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal) override
void | Position (DirectX::XMFLOAT3 position)
void | Position (DirectX::XMVECTOR position)
void | Position (DirectX::XMFLOAT3 position)
void | Position (DirectX::XMVECTOR position)
float | Radius ()
void | Radius (float radius)
float | Radius ()
FORCEINLINE float | Radius () const
void | Radius (float radius)

Public Attributes

internal | __pad0__: Sphere()
XMFLOAT4 | center

Private Member Functions

void | Update ()
void | Update ()

Private Attributes

float | m_radius

Detailed Description

Definition at line 16 of file Sphere.h.

Constructor & Destructor Documentation

Sphere::Sphere | ( | DirectX::XMFLOAT3 | pos,
 |  | float | radius
 | ) |  |

Definition at line 24 of file Sphere.cpp.

{
    m_position = position;
    m_radius = radius;
    Update();
}

Sphere::Sphere ( ) [inline]

Definition at line 106 of file Primitives.h.

    {
    }

Sphere::Sphere | ( | const XMFLOAT3 & | centerIn,
 |  | FLOAT | radius |
 | ) |  |  | [inline, explicit]

Definition at line 110 of file Primitives.h.

    {
        center = XMFLOAT4(centerIn.x, centerIn.y, centerIn.z, radius);
    }

Sphere::Sphere | ( | float | x,
 |  | float | y,
 |  | float | z,
 |  | float | radius |
 | ) |  |  | [inline, explicit]

Definition at line 115 of file Primitives.h.

    {
        center = XMFLOAT4(x, y, z, radius);
    }

Sphere::Sphere | ( | DirectX::XMFLOAT3 | pos,
 |  | float | radius
 | ) |  |

Member Function Documentation

virtual bool Sphere::IsTouching | ( | DirectX::XMFLOAT3 | point,
 |  | float | radius,
 |  | _Out_ DirectX::XMFLOAT3 * | contact,
 |  | _Out_ DirectX::XMFLOAT3 * | normal |
 | ) |  |  | [override, virtual]

Reimplemented from GameObject.

virtual bool Sphere::IsTouching | ( | DirectX::XMFLOAT3 | point,
 |  | float | radius,
 |  | _Out_ DirectX::XMFLOAT3 * | contact,
 |  | _Out_ DirectX::XMFLOAT3 * | normal |
 | ) |  |  | [override, virtual]

Reimplemented from GameObject.

__forceinline void Sphere::Position ( DirectX::XMFLOAT3 position )

Reimplemented from GameObject.

Definition at line 41 of file Sphere.h.

{
    m_position = position;
    Update();
}

void Sphere::Position ( DirectX::XMFLOAT3 position )

Reimplemented from GameObject.

void Sphere::Position ( DirectX::XMVECTOR position )

Reimplemented from GameObject.

__forceinline void Sphere::Position ( DirectX::XMVECTOR position )

Reimplemented from GameObject.

Definition at line 47 of file Sphere.h.

{
    DirectX::XMStoreFloat3(&m_position, position);
    Update();
}

float Sphere::Radius ( )
FORCEINLINE float Sphere::Radius ( ) const [inline]

Definition at line 101 of file Primitives.h.

    {
        return center.w;
    }

__forceinline float Sphere::Radius ( )

Definition at line 59 of file Sphere.h.

{
    return m_radius;
}

void Sphere::Radius ( float radius )
__forceinline void Sphere::Radius ( float radius )

Definition at line 53 of file Sphere.h.

{
    m_radius = radius;
    Update();
}

void Sphere::Update ( ) [private]

Definition at line 36 of file Sphere.cpp.

{
    XMStoreFloat4x4(
        &m_modelMatrix,
        XMMatrixScaling(m_radius, m_radius, m_radius) *
        XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
        );
}

void Sphere::Update ( ) [private]

Member Data Documentation

internal Sphere::__pad0__

Reimplemented from GameObject.

Definition at line 19 of file Sphere.h.

XMFLOAT4 Sphere::center

Definition at line 99 of file Primitives.h.

float Sphere::m_radius [private]

Definition at line 37 of file Sphere.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/Sphere.h
  • DirectX marble maze game/C++/Primitives.h
  • XAML DirectX 3D shooting game/C++/Sphere.h
  • DirectX 3D shooting game/C++/Sphere.cpp
  • XAML DirectX 3D shooting game/C++/Sphere.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SphereMesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SphereMesh Class Reference

#include "SphereMesh.h"

List of all members.

Public Attributes

internal | __pad0__: SphereMesh(_In_ ID3D11Device *device
internal uint32 | segments

Detailed Description

Definition at line 17 of file SphereMesh.h.

Member Data Documentation

internal SphereMesh::__pad0__

Definition at line 20 of file SphereMesh.h.

internal uint32 SphereMesh::segments

Definition at line 20 of file SphereMesh.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/SphereMesh.h
  • XAML DirectX 3D shooting game/C++/SphereMesh.h
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StartOp Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Attributes

StartOp Class Reference

#include "MPEG1Src.h"

Inherits SourceOp, and SourceOp.

List of all members.

Public Member Functions

StartOp (IMFPresentationDescriptor *pPD)
StartOp (IMFPresentationDescriptor *pPD)
~StartOp ()
~StartOp ()
HRESULT | GetPresentationDescriptor (IMFPresentationDescriptor **ppPD)
HRESULT | GetPresentationDescriptor (IMFPresentationDescriptor **ppPD)

Protected Attributes

IMFPresentationDescriptor * | m_pPD

Detailed Description

Definition at line 217 of file MPEG1Src.h.

Constructor & Destructor Documentation

StartOp::StartOp ( IMFPresentationDescriptor * pPD )

Definition at line 2339 of file MPEG1Src.cpp.

                                               : SourceOp(SourceOp::OP_START), m_pPD(pPD)
{
    if (m_pPD)
    {
        m_pPD->AddRef();
    }
}

StartOp::~StartOp ( )

Definition at line 2347 of file MPEG1Src.cpp.

{
    SafeRelease(&m_pPD);
}

StartOp::StartOp ( IMFPresentationDescriptor * pPD )
StartOp::~StartOp ( )

Member Function Documentation

HRESULT StartOp::GetPresentationDescriptor ( IMFPresentationDescriptor ** ppPD )

Definition at line 2353 of file MPEG1Src.cpp.

{
    if (ppPD == NULL)
    {
        return E_POINTER;
    }
    if (m_pPD == NULL)
    {
        return MF_E_INVALIDREQUEST;
    }
    *ppPD = m_pPD;
    (*ppPD)->AddRef();
    return S_OK;
}

HRESULT StartOp::GetPresentationDescriptor ( IMFPresentationDescriptor ** ppPD )

Member Data Documentation

IMFPresentationDescriptor * StartOp::m_pPD [protected]

Definition at line 226 of file MPEG1Src.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: STEREO_PARAMETERS Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

STEREO_PARAMETERS Struct Reference

#include "StereoProjection.h"

List of all members.

Public Attributes

float | displaySizeInches
float | pixelResolutionHeight
float | pixelResolutionWidth
float | stereoExaggerationFactor
float | stereoSeparationFactor
float | viewerDistanceInches

Detailed Description

Definition at line 10 of file StereoProjection.h.

Member Data Documentation

float STEREO_PARAMETERS::displaySizeInches

Definition at line 13 of file StereoProjection.h.

float STEREO_PARAMETERS::pixelResolutionHeight

Definition at line 15 of file StereoProjection.h.

float STEREO_PARAMETERS::pixelResolutionWidth

Definition at line 14 of file StereoProjection.h.

float STEREO_PARAMETERS::stereoExaggerationFactor

Definition at line 17 of file StereoProjection.h.

float STEREO_PARAMETERS::stereoSeparationFactor

Definition at line 16 of file StereoProjection.h.

float STEREO_PARAMETERS::viewerDistanceInches

Definition at line 12 of file StereoProjection.h.

The documentation for this struct was generated from the following files:
  • DirectX 3D shooting game/C++/StereoProjection.h
  • XAML DirectX 3D shooting game/C++/StereoProjection.h
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StereoParameters Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

StereoParameters Struct Reference

#include "Stereo3DMatrixHelper.h"

List of all members.

Public Attributes

float | interocularDistance
float | viewerDistance
float | viewportHeight
float | viewportWidth

Detailed Description

Definition at line 11 of file Stereo3DMatrixHelper.h.

Member Data Documentation

float StereoParameters::interocularDistance

Definition at line 16 of file Stereo3DMatrixHelper.h.

float StereoParameters::viewerDistance

Definition at line 15 of file Stereo3DMatrixHelper.h.

float StereoParameters::viewportHeight

Definition at line 14 of file Stereo3DMatrixHelper.h.

float StereoParameters::viewportWidth

Definition at line 13 of file Stereo3DMatrixHelper.h.

The documentation for this struct was generated from the following file:
  • Direct3D stereoscopic 3D/C++/Stereo3DMatrixHelper.h
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StereoSimpleD3D Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

StereoSimpleD3D Class Reference

#include "StereoSimpleD3D.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
float | GetStereoExaggeration ()
virtual void | Render () override
void | RenderEye (_In_ unsigned int eyeIndex)
void | SetStereoExaggeration (_In_ float currentExaggeration)
void | Update (_In_ unsigned int eyeIndex, _In_ float timeTotal, _In_ float timeDelta)

Public Attributes

internal | __pad0__: StereoSimpleD3D()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_brush
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
float | m_farZ
float | m_heightInInches
Platform::String | m_hintMessage
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
unsigned int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
float | m_nearZ
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
float | m_projAspect
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
float | m_stereoExaggerationFactor
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureShaderResourceView
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader
float | m_widthInInches
float | m_worldScale

Detailed Description

Definition at line 24 of file StereoSimpleD3D.h.

Member Function Documentation

void StereoSimpleD3D::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 31 of file StereoSimpleD3D.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    // Create a DirectWrite text format object.
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Segoe UI",                    // font family name
            nullptr,                        // system font collection
            DWRITE_FONT_WEIGHT_SEMI_BOLD,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            40.0f,                          // font size
            L"en-US",                       // locale
            &m_textFormat
            )
        );

    // Align the text horizontally.
    DX::ThrowIfFailed(
        m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );

    // Align the text vertically.
    DX::ThrowIfFailed(
        m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );
}

void StereoSimpleD3D::CreateDeviceResources ( ) [override, virtual]

Definition at line 60 of file StereoSimpleD3D.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        "Direct3D stereoscopic 3D sample"
        );

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    loader->LoadShader(
        L"SimpleVertexShader.cso",
        nullptr,
        0,
        &m_vertexShader,
        &m_inputLayout
        );

    // Create the vertex and index buffers for drawing the cube.
    BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());

    shapes->CreateCube(
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // Create the constant buffer for updating model and camera data.
    CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &constantBufferDescription,
            nullptr, // Leave the buffer uninitialized.
            &m_constantBuffer
            )
        );

    loader->LoadShader(
        L"SimplePixelShader.cso",
        &m_pixelShader
        );

    loader->LoadTexture(
        L"texture.dds",
        nullptr,
        &m_textureShaderResourceView
        );

    // Create the sampler.
    D3D11_SAMPLER_DESC samplerDescription;
    ZeroMemory(&samplerDescription, sizeof(samplerDescription));
    samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.MipLODBias = 0.0f;
    samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
    samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDescription.BorderColor[0] = 0.0f;
    samplerDescription.BorderColor[1] = 0.0f;
    samplerDescription.BorderColor[2] = 0.0f;
    samplerDescription.BorderColor[3] = 0.0f;
    samplerDescription.MinLOD = 0; // Allow use of all MIP levels.
    samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDescription,
            &m_sampler
            )
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White, 0.5f),
            &m_brush
            )
        );
}

void StereoSimpleD3D::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 147 of file StereoSimpleD3D.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    if (m_stereoEnabled)
    {
        m_hintMessage = "Press up/down arrow keys to adjust stereo 3D exaggeration effect";
    }
    else
    {
        m_hintMessage = "Stereo 3D is not enabled on your system";
    }

    m_projAspect = static_cast<float>(m_renderTargetSize.Width) / static_cast<float>(m_renderTargetSize.Height);
    m_nearZ = 0.01f;
    m_farZ = 100.0f;

    // Initialize the view matrix.
    XMFLOAT3 Eye = XMFLOAT3(0.0f, 2.0f, 5.0f);
    XMFLOAT3 At = XMFLOAT3(0.0f, 0.0f, 0.0f);
    XMFLOAT3 Up = XMFLOAT3 (0.0f, 1.0f, 0.0f);
    XMStoreFloat4x4(
        &m_constantBufferData.view,
        XMMatrixLookAtRH(XMLoadFloat3(&Eye), XMLoadFloat3(&At), XMLoadFloat3(&Up))
        );

    // Set camera parameters.
    m_widthInInches = m_renderTargetSize.Width / m_dpi;
    m_heightInInches = m_renderTargetSize.Height / m_dpi;

    // Create the projection matrix parameters and set up the initial/mono projection matrix.
    StereoParameters params = CreateDefaultStereoParameters(m_widthInInches, m_heightInInches, m_worldScale, 0); // Mono uses zero exaggeration.
    XMStoreFloat4x4(
        &m_constantBufferData.projection,
        StereoProjectionFieldOfViewRightHand(params, m_nearZ, m_farZ, false) // Channel parameter doesn't matter for mono.
        );

    m_sampleOverlay->UpdateForWindowSizeChange();
}

float StereoSimpleD3D::GetStereoExaggeration ( )

Definition at line 375 of file StereoSimpleD3D.cpp.

{
    return m_stereoExaggerationFactor;
}

void StereoSimpleD3D::Render ( ) [override, virtual]

Definition at line 189 of file StereoSimpleD3D.cpp.

{
}

void StereoSimpleD3D::RenderEye ( _In_ unsigned int eyeIndex )

Definition at line 194 of file StereoSimpleD3D.cpp.

{
    ComPtr<ID3D11RenderTargetView> currentRenderTargetView;

    // If eyeIndex == 1, set right render target view. Otherwise, set left render target view.
    currentRenderTargetView = eyeIndex ? m_d3dRenderTargetViewRight : m_d3dRenderTargetView;

    // Bind the render targets.
    m_d3dContext->OMSetRenderTargets(
        1,
        currentRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // Clear both the render target and depth stencil to default values.
    const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        currentRenderTargetView.Get(),
        ClearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    // Set the vertex and index buffers.
    UINT stride = sizeof(BasicVertex);
    UINT offset = 0;
    m_d3dContext->IASetVertexBuffers(
        0,                              // Start at the first vertex buffer slot.
        1,                              // Set one vertex buffer binding.
        m_vertexBuffer.GetAddressOf(),
        &stride,                        // Specify the size in bytes of a single vertex.
        &offset                         // Specify the base vertex in the buffer.
        );

    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,   // Specify unsigned short index format.
        0                       // Specify the base index in the buffer.
        );

    // Specify the way the vertex and index buffers define geometry.
    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    // Set the vertex shader stage state.
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,                // Don't use shader linkage.
        0                       // Don't use shader linkage.
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                          // Start at the first constant buffer slot.
        1,                          // Set one constant buffer binding.
        m_constantBuffer.GetAddressOf()
        );

    // Set the pixel shader stage state.
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,                // Don't use shader linkage.
        0                       // Don't use shader linkage.
        );

    m_d3dContext->PSSetShaderResources(
        0,                          // Start at the first shader resource slot.
        1,                          // Set one shader resource binding.
        m_textureShaderResourceView.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,                          // Starting at the first sampler slot.
        1,                          // Set one sampler binding.
        m_sampler.GetAddressOf()
        );

    // Draw the cube.
    m_d3dContext->DrawIndexed(
        m_indexCount,   // Draw all created vertices.
        0,              // Start with the first vertex.
        0               // Start with the first index.
        );

    // Set the left/right Direct2D target bitmap.
    if (eyeIndex == 0)
    {
        m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
    }
    else
    {
        m_d2dContext->SetTarget(m_d2dTargetBitmapRight.Get());
    }

    m_sampleOverlay->Render();

    // Render the hint message text with different margins depending on the view state.
    D2D1_RECT_F hintMessageRect;
    if (ApplicationView::Value == ApplicationViewState::Snapped)
    {
        hintMessageRect = D2D1::RectF(10.0f, 10.0f, m_windowBounds.Width - 10.0f, 500.0f);
    }
    else
    {
        hintMessageRect = D2D1::RectF(100.0f, 100.0f, 550.0f, 380.0f);
    }

    m_d2dContext->BeginDraw();
    m_d2dContext->DrawText(
        m_hintMessage->Data(),
        m_hintMessage->Length(),
        m_textFormat.Get(),
        hintMessageRect,
        m_brush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }
}

void StereoSimpleD3D::SetStereoExaggeration ( _In_ float currentExaggeration )

Definition at line 380 of file StereoSimpleD3D.cpp.

{
    currentExaggeration = min(currentExaggeration, 2.0f);
    currentExaggeration = max(currentExaggeration, 0.0f);
    m_stereoExaggerationFactor = currentExaggeration;
}

void StereoSimpleD3D::Update | ( | _In_ unsigned int | eyeIndex,
 |  | _In_ float | timeTotal,
 |  | _In_ float | timeDelta
 | ) |  |

Definition at line 326 of file StereoSimpleD3D.cpp.

{
    // Rotate the cube.
    XMStoreFloat4x4(
        &m_constantBufferData.model,
        XMMatrixRotationY(timeTotal)
        );

    if (m_stereoEnabled)
    {
        StereoParameters parameters = CreateDefaultStereoParameters(m_widthInInches, m_heightInInches, m_worldScale, m_stereoExaggerationFactor);
        if (eyeIndex == 0)
        {
            XMStoreFloat4x4(
                &m_constantBufferData.projection,
                StereoProjectionFieldOfViewRightHand(parameters, m_nearZ, m_farZ, false)
                );
        }
        else
        {
            XMStoreFloat4x4(
                &m_constantBufferData.projection,
                StereoProjectionFieldOfViewRightHand(parameters, m_nearZ, m_farZ, true)
                );
        }
    }

    // Transpose the matrices in the constant buffer.
    ConstantBuffer constantBuffer;
    XMStoreFloat4x4(
        &constantBuffer.model,
        XMMatrixTranspose(XMLoadFloat4x4(&m_constantBufferData.model))
        );
    XMStoreFloat4x4(
        &constantBuffer.view,
        XMMatrixTranspose(XMLoadFloat4x4(&m_constantBufferData.view))
        );
    XMStoreFloat4x4(
        &constantBuffer.projection,
        XMMatrixTranspose(XMLoadFloat4x4(&m_constantBufferData.projection))
        );

    m_d3dContext->UpdateSubresource(m_constantBuffer.Get(), 0, nullptr, &constantBuffer, 0, 0);
}

Member Data Documentation

internal StereoSimpleD3D::__pad0__

Definition at line 27 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> StereoSimpleD3D::m_brush [private]

Definition at line 52 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> StereoSimpleD3D::m_constantBuffer [private]

Definition at line 51 of file StereoSimpleD3D.h.

ConstantBuffer StereoSimpleD3D::m_constantBufferData [private]

Definition at line 56 of file StereoSimpleD3D.h.

float StereoSimpleD3D::m_farZ [private]

Definition at line 59 of file StereoSimpleD3D.h.

float StereoSimpleD3D::m_heightInInches [private]

Definition at line 61 of file StereoSimpleD3D.h.

Platform::String StereoSimpleD3D::m_hintMessage [private]

Definition at line 63 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> StereoSimpleD3D::m_indexBuffer [private]

Definition at line 46 of file StereoSimpleD3D.h.

unsigned int StereoSimpleD3D::m_indexCount [private]

Definition at line 55 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> StereoSimpleD3D::m_inputLayout [private]

Definition at line 44 of file StereoSimpleD3D.h.

float StereoSimpleD3D::m_nearZ [private]

Definition at line 58 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> StereoSimpleD3D::m_pixelShader [private]

Definition at line 48 of file StereoSimpleD3D.h.

float StereoSimpleD3D::m_projAspect [private]

Definition at line 57 of file StereoSimpleD3D.h.

SampleOverlay StereoSimpleD3D::m_sampleOverlay [private]

Definition at line 43 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> StereoSimpleD3D::m_sampler [private]

Definition at line 50 of file StereoSimpleD3D.h.

float StereoSimpleD3D::m_stereoExaggerationFactor [private]

Definition at line 62 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> StereoSimpleD3D::m_textFormat [private]

Definition at line 53 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> StereoSimpleD3D::m_textureShaderResourceView [private]

Definition at line 49 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> StereoSimpleD3D::m_vertexBuffer [private]

Definition at line 45 of file StereoSimpleD3D.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> StereoSimpleD3D::m_vertexShader [private]

Definition at line 47 of file StereoSimpleD3D.h.

float StereoSimpleD3D::m_widthInInches [private]

Definition at line 60 of file StereoSimpleD3D.h.

float StereoSimpleD3D::m_worldScale [private]

Definition at line 64 of file StereoSimpleD3D.h.

The documentation for this class was generated from the following files:
  • Direct3D stereoscopic 3D/C++/StereoSimpleD3D.h
  • Direct3D stereoscopic 3D/C++/StereoSimpleD3D.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StopwatchTimer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Protected Attributes

StopwatchTimer Class Reference

#include "UserInterface.h"

Inherits TextElement.

List of all members.

Public Member Functions

StopwatchTimer ()
float | GetElapsedTime () const
template<size_t _Len>
void | GetFormattedTime (WCHAR(&buffer)[_Len]) const
void | GetFormattedTime (WCHAR *buffer, int length) const
virtual void | Initialize ()
virtual void | Render ()
void | Reset ()
void | SetElapsedTime (float time)
void | Start ()
void | Stop ()
virtual void | Update (float timeTotal, float timeDelta)

Static Public Member Functions

static void | GetFormattedTime (WCHAR *buffer, int length, float time)
template<size_t _Len>
static void | GetFormattedTime (WCHAR(&buffer)[_Len], float time)

Protected Attributes

bool | m_active
float | m_elapsedTime

Detailed Description

Definition at line 133 of file UserInterface.h.

Constructor & Destructor Documentation

StopwatchTimer::StopwatchTimer ( )

Definition at line 396 of file UserInterface.cpp.

                              :
    m_active(false),
    m_elapsedTime(0.0f)
{
}

Member Function Documentation

float StopwatchTimer::GetElapsedTime ( ) const [inline]

Definition at line 146 of file UserInterface.h.

{ return m_elapsedTime; };

void StopwatchTimer::GetFormattedTime | ( | WCHAR * | buffer,
 |  | int | length |
 | ) |  |  | const

Definition at line 441 of file UserInterface.cpp.

{
    GetFormattedTime(buffer, length, m_elapsedTime);
}

template<size_t _Len>
void StopwatchTimer::GetFormattedTime ( WCHAR(&) buffer[_Len] ) const [inline]

Definition at line 151 of file UserInterface.h.

{ GetFormattedTime(buffer, _Len); }

void StopwatchTimer::GetFormattedTime | ( | WCHAR * | buffer,
 |  | int | length,
 |  | float | time |
 | ) |  |  | [static]

Definition at line 446 of file UserInterface.cpp.

{
    int partial = (int)floor(fmodf(time * 10.0f, 10.0f));
    int seconds = (int)floor(fmodf(time, 60.0f));
    int minutes = (int)floor(time / 60.0f);
    swprintf_s(buffer, length, L"%02d:%02d.%01d", minutes, seconds, partial);
}

template<size_t _Len>
static void StopwatchTimer::GetFormattedTime | ( | WCHAR(&) | buffer[_Len],
 |  | float | time |
 | ) |  |  | [inline, static]

Definition at line 155 of file UserInterface.h.

{ GetFormattedTime(buffer, _Len, time); }

void StopwatchTimer::Initialize ( ) [virtual]

Reimplemented from TextElement.

Definition at line 402 of file UserInterface.cpp.

{
    TextElement::Initialize();
}

void StopwatchTimer::Render ( ) [virtual]

Reimplemented from TextElement.

Definition at line 421 of file UserInterface.cpp.

{
    TextElement::Render();
}

void StopwatchTimer::Reset ( )

Definition at line 436 of file UserInterface.cpp.

{
    m_elapsedTime = 0.0f;
}

void StopwatchTimer::SetElapsedTime ( float time ) [inline]

Definition at line 147 of file UserInterface.h.

{ m_elapsedTime = time; };

void StopwatchTimer::Start ( )

Definition at line 426 of file UserInterface.cpp.

{
    m_active = true;
}

void StopwatchTimer::Stop ( )

Definition at line 431 of file UserInterface.cpp.

{
    m_active = false;
}

void StopwatchTimer::Update | ( | float | timeTotal,
 |  | float | timeDelta |
 | ) |  |  | [virtual]

Reimplemented from TextElement.

Definition at line 407 of file UserInterface.cpp.

{
    if (m_active)
    {
        m_elapsedTime += timeDelta;

        WCHAR buffer[16];
        GetFormattedTime(buffer);
        SetText(buffer);
    }

    TextElement::Update(timeTotal, timeDelta);
}

Member Data Documentation

bool StopwatchTimer::m_active [protected]

Definition at line 158 of file UserInterface.h.

float StopwatchTimer::m_elapsedTime [protected]

Definition at line 159 of file UserInterface.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/UserInterface.h
  • DirectX marble maze game/C++/UserInterface.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Story Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Story Class Reference

#include "Story.h"

Inherits Element.

List of all members.

Public Member Functions

Design | GetDesign (D2D1_SIZE_F displaySize)

Public Attributes

internal | __pad0__: virtual bool AcceptChildNode( _In_ Document^ document
internal _In_
Windows::Data::Xml::Dom::IXmlNode
childXmlNode 		override

Detailed Description

Definition at line 21 of file Story.h.

Member Function Documentation

Design Story::GetDesign ( D2D1_SIZE_F displaySize )

Definition at line 48 of file Story.cpp.

{
    float displayAspectRatio = displaySize.width / displaySize.height;
    float leastDeviation = FLT_MAX;

    Design^ chosenDesign = nullptr;

    Element^ child = GetFirstChild();

    while (child != nullptr)
    {
        Design^ design = dynamic_cast<Design^>(child);

        if (design != nullptr)
        {
            D2D1_SIZE_F pageSize = design->GetPageSize();

            float deviation = abs(pageSize.width / pageSize.height - displayAspectRatio);

            if (deviation < leastDeviation)
            {
                leastDeviation = deviation;
                chosenDesign = design;
            }
        }

        child = child->GetNextSibling();
    }

    return chosenDesign;
}

Member Data Documentation

internal Story::__pad0__

Reimplemented from Element.

Definition at line 25 of file Story.h.

internal _In_ Windows::Data::Xml::Dom::IXmlNode childXmlNode Story::override

Definition at line 25 of file Story.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/Story.h
  • Direct2D magazine app/C++/Story.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamEffect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

StreamEffect Class Reference

#include "StreamEffect.h"

List of all members.

Public Member Functions

void | CreateAudioResources ()
virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
bool | IsAudioSetup ()
void | OnResuming ()
void | OnSuspending ()
void | ReleaseAudioResources ()
virtual void | Render () override
void | RenderAudio ()
void | Update (float TimeTotal, float TimeDelta)

Public Attributes

internal | __pad0__: StreamEffect()

Private Member Functions

~StreamEffect ()

Private Attributes

std::vector< byte > | m_audioBuffers [3]
size_t | m_currentBuffer
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_dataTextFormat
bool | m_isAudioStarted
IXAudio2 * | m_musicEngine
IXAudio2MasteringVoice * | m_musicMasteringVoice
IXAudio2SourceVoice * | m_musicSourceVoice
std::unique_ptr< MediaStreamer > | m_musicStreamer
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textBrush

Detailed Description

Definition at line 16 of file StreamEffect.h.

Constructor & Destructor Documentation

StreamEffect::~StreamEffect ( ) [private]

Definition at line 38 of file StreamEffect.cpp.

{
    ReleaseAudioResources();
}

Member Function Documentation

void StreamEffect::CreateAudioResources ( )

Definition at line 93 of file StreamEffect.cpp.

{
    UINT32 flags = 0;

    // Load the wave into a buffer using Media Foundation.
    // Media Foundation is a convenient way to get both file I/O and format decode for audio assets.
    // Games are welcome to replace the streamer in this sample with their own file I/O and decode routines

    m_musicStreamer.reset(new MediaStreamer(ref new Platform::String(MUSIC_FILE)));
    uint32 streamSampleRate = m_musicStreamer->GetOutputWaveFormatEx().nSamplesPerSec;

    // Create XAudio2 and a single mastering voice on the default audio device

    // NOTE: The method for creating XAudio2 is changing for Win8 (and will be different than
    // what you can read on MSDN today.) Changes include:
    //    * XAudio2Create is a flat Win32 API and does not require CoCreateInstance
    //    * There is no device enumeration on IXAudio2 - GetDeviceCount and GetDeviceDetails are removed
    //    * CreateMasteringVoice now takes a device id string instead of index, requiring you to enumerate devices using
    //      the new Metro style device enumeration APIs in Windows or the desktop MMDevice enumeration APIs
    //      (Only the default device is supported for //BUILD.)
    //    * CreateMasteringVoice has an additional parameter to tag the category of the output stream

    DX::ThrowIfFailed(
        XAudio2Create(&m_musicEngine, flags)
        );

    // This sample plays the equivalent of background music, which we tag on the mastering voice as AudioCategory_GameMedia.
    // In ordinary usage, if we were playing the music track with no effects, we could route it entirely through
    // Media Foundation. Here we are using XAudio2 to apply a reverb effect to the music, so we use Media Foundation to
    // decode the data then we feed it through the XAudio2 pipeline as a separate Mastering Voice, so that we can tag it
    // as Game Media.

    HRESULT hr = m_musicEngine->CreateMasteringVoice(
        &m_musicMasteringVoice,
        XAUDIO2_DEFAULT_CHANNELS,
        streamSampleRate,
        0,
        nullptr,    // Use the default audio device
        nullptr,    // No effect chain on the mastering voice
        AudioCategory_GameMedia
        );
    if (FAILED(hr))
    {
        //
        // Unable to create the mastering voice
        // This happens if there are no audio devices
        //
        m_musicMasteringVoice = nullptr;
        return;
    }

    // Set up Reverb effect

    const WAVEFORMATEX& waveFormat = m_musicStreamer->GetOutputWaveFormatEx();

    Microsoft::WRL::ComPtr<IUnknown> pXAPO;
    DX::ThrowIfFailed(
        XAudio2CreateReverb(&pXAPO)
        );
    XAUDIO2_EFFECT_DESCRIPTOR descriptor;
    descriptor.InitialState = true;
    descriptor.OutputChannels = waveFormat.nChannels;
    descriptor.pEffect = pXAPO.Get();
    XAUDIO2_EFFECT_CHAIN chain;
    chain.EffectCount = 1;
    chain.pEffectDescriptors = &descriptor;

    // Create the source voice and start it
    DX::ThrowIfFailed(
        m_musicEngine->CreateSourceVoice(&m_musicSourceVoice, &waveFormat, 0, 1.0f, nullptr, nullptr, &chain)
        );

    XAUDIO2FX_REVERB_PARAMETERS reverbParameters;
    reverbParameters.ReflectionsDelay = XAUDIO2FX_REVERB_DEFAULT_REFLECTIONS_DELAY;
    reverbParameters.ReverbDelay = XAUDIO2FX_REVERB_DEFAULT_REVERB_DELAY;
    reverbParameters.RearDelay = XAUDIO2FX_REVERB_DEFAULT_REAR_DELAY;
    reverbParameters.PositionLeft = XAUDIO2FX_REVERB_DEFAULT_POSITION;
    reverbParameters.PositionRight = XAUDIO2FX_REVERB_DEFAULT_POSITION;
    reverbParameters.PositionMatrixLeft = XAUDIO2FX_REVERB_DEFAULT_POSITION_MATRIX;
    reverbParameters.PositionMatrixRight = XAUDIO2FX_REVERB_DEFAULT_POSITION_MATRIX;
    reverbParameters.EarlyDiffusion = XAUDIO2FX_REVERB_DEFAULT_EARLY_DIFFUSION;
    reverbParameters.LateDiffusion = XAUDIO2FX_REVERB_DEFAULT_LATE_DIFFUSION;
    reverbParameters.LowEQGain = XAUDIO2FX_REVERB_DEFAULT_LOW_EQ_GAIN;
    reverbParameters.LowEQCutoff = XAUDIO2FX_REVERB_DEFAULT_LOW_EQ_CUTOFF;
    reverbParameters.HighEQGain = XAUDIO2FX_REVERB_DEFAULT_HIGH_EQ_GAIN;
    reverbParameters.HighEQCutoff = XAUDIO2FX_REVERB_DEFAULT_HIGH_EQ_CUTOFF;
    reverbParameters.RoomFilterFreq = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_FREQ;
    reverbParameters.RoomFilterMain = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_MAIN;
    reverbParameters.RoomFilterHF = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_HF;
    reverbParameters.ReflectionsGain = XAUDIO2FX_REVERB_DEFAULT_REFLECTIONS_GAIN;
    reverbParameters.ReverbGain = XAUDIO2FX_REVERB_DEFAULT_REVERB_GAIN;
    reverbParameters.DecayTime = XAUDIO2FX_REVERB_DEFAULT_DECAY_TIME;
    reverbParameters.Density = XAUDIO2FX_REVERB_DEFAULT_DENSITY;
    reverbParameters.RoomSize = XAUDIO2FX_REVERB_DEFAULT_ROOM_SIZE;
    reverbParameters.WetDryMix = XAUDIO2FX_REVERB_DEFAULT_WET_DRY_MIX;
    reverbParameters.DisableLateField = FALSE;

    DX::ThrowIfFailed(
        m_musicSourceVoice->SetEffectParameters(0, &reverbParameters, sizeof(reverbParameters))
        );

    DX::ThrowIfFailed(
        m_musicSourceVoice->EnableEffect(0)
        );
}

void StreamEffect::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 43 of file StreamEffect.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();

    CreateAudioResources();
}

void StreamEffect::CreateDeviceResources ( ) [override, virtual]

Definition at line 50 of file StreamEffect.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        ref new Platform::String(APPLICATION_TITLE)
        );

    //
    // Setup the graphics objects related to drawing text
    //
    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            FONT_NAME,
            nullptr,
            DWRITE_FONT_WEIGHT_NORMAL,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            FONT_SIZE_TEXT,
            FONT_LOCALE,
            &m_dataTextFormat
            )
        );

    DX::ThrowIfFailed(
        m_dataTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
        );
    DX::ThrowIfFailed(
        m_dataTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::White), &m_textBrush)
        );

}

void StreamEffect::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 218 of file StreamEffect.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();
    m_sampleOverlay->UpdateForWindowSizeChange();
}

bool StreamEffect::IsAudioSetup ( )

Definition at line 334 of file StreamEffect.cpp.

{
    return ((m_musicEngine != nullptr) &&
            (m_musicMasteringVoice != nullptr) &&
            (m_musicSourceVoice != nullptr)
            );
}

void StreamEffect::OnResuming ( )

Definition at line 280 of file StreamEffect.cpp.

{
    DX::ThrowIfFailed(
        m_musicEngine->StartEngine()
        );
}

void StreamEffect::OnSuspending ( )

Definition at line 275 of file StreamEffect.cpp.

{
    m_musicEngine->StopEngine();
}

void StreamEffect::ReleaseAudioResources ( )

Definition at line 199 of file StreamEffect.cpp.

{
    if (m_musicSourceVoice != nullptr)
    {
        m_musicSourceVoice->DestroyVoice();
        m_musicSourceVoice    = nullptr;
    }
    if (m_musicMasteringVoice != nullptr)
    {
        m_musicMasteringVoice->DestroyVoice();
        m_musicMasteringVoice = nullptr;
    }
    if (m_musicEngine != nullptr)
    {
        m_musicEngine->Release();
        m_musicEngine = nullptr;
    }
}

void StreamEffect::Render ( ) [override, virtual]

Definition at line 224 of file StreamEffect.cpp.

{
    // bind the render targets
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // clear both the render target and depth stencil to default values
    const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        ClearColor
        );

    m_sampleOverlay->Render();

    if (IsAudioSetup())
    {
        RenderAudio();
    }
    else
    {
        //
        // No audio, render a message indicating setup failure
        //
        D2D1_SIZE_F size = m_d2dContext->GetSize();
        D2D1_RECT_F pos = D2D1::RectF(INFORMATION_START_X, INFORMATION_START_Y, size.width, size.height);

        // Display a message when controller is not connected
        m_d2dContext->BeginDraw();
        m_d2dContext->DrawText(
            MSG_NEED_AUDIO,
            static_cast<uint32>(::wcslen(MSG_NEED_AUDIO)),
            m_dataTextFormat.Get(),
            pos,
            m_textBrush.Get()
            );

        // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
        // is lost. It will be handled during the next call to Present.
        HRESULT hr = m_d2dContext->EndDraw();
        if (hr != D2DERR_RECREATE_TARGET)
        {
            DX::ThrowIfFailed(hr);
        }
    }
}

void StreamEffect::RenderAudio ( )

Definition at line 292 of file StreamEffect.cpp.

{
    if (IsAudioSetup() == false)
    {
        return;
    }

    // Find the current state of the playing buffers
    XAUDIO2_VOICE_STATE state;
    m_musicSourceVoice->GetState(&state);

    // Have any of the buffer completed
    while (state.BuffersQueued < BUFFER_COUNT)
    {
        // Retreive the next buffer to stream from MF Music Streamer
        m_audioBuffers[m_currentBuffer] = m_musicStreamer->GetNextBuffer();
        if (m_audioBuffers[m_currentBuffer].size() == 0)
        {
            // Audio file has been fully read, restart the reader to re-loop the audio
            m_musicStreamer->Restart();
            break;
        }

        //
        // Submit the new buffer
        //
        XAUDIO2_BUFFER buf = {0};
        buf.AudioBytes = static_cast<uint32>(m_audioBuffers[m_currentBuffer].size());
        buf.pAudioData = &m_audioBuffers[m_currentBuffer][0];
        DX::ThrowIfFailed(
            m_musicSourceVoice->SubmitSourceBuffer(&buf)
            );

        // Advance the buffer index
        m_currentBuffer = ++m_currentBuffer % BUFFER_COUNT;

        // Get the updated state
        m_musicSourceVoice->GetState(&state);
    }
}

void StreamEffect::Update | ( | float | TimeTotal,
 |  | float | TimeDelta
 | ) |  |

Definition at line 343 of file StreamEffect.cpp.

{
    if (!m_isAudioStarted && (m_musicSourceVoice != nullptr))
    {
        DX::ThrowIfFailed(
            m_musicSourceVoice->Start(0)
            );

        m_isAudioStarted = true;
    }
}

Member Data Documentation

internal StreamEffect::__pad0__

Definition at line 21 of file StreamEffect.h.

std::vector<byte> StreamEffect::m_audioBuffers[3] [private]

Definition at line 50 of file StreamEffect.h.

size_t StreamEffect::m_currentBuffer [private]

Definition at line 52 of file StreamEffect.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> StreamEffect::m_dataTextFormat [private]

Definition at line 55 of file StreamEffect.h.

bool StreamEffect::m_isAudioStarted [private]

Definition at line 46 of file StreamEffect.h.

IXAudio2* StreamEffect::m_musicEngine [private]

Definition at line 47 of file StreamEffect.h.

IXAudio2MasteringVoice* StreamEffect::m_musicMasteringVoice [private]

Definition at line 48 of file StreamEffect.h.

IXAudio2SourceVoice* StreamEffect::m_musicSourceVoice [private]

Definition at line 49 of file StreamEffect.h.

std::unique_ptr<MediaStreamer> StreamEffect::m_musicStreamer [private]

Definition at line 51 of file StreamEffect.h.

SampleOverlay StreamEffect::m_sampleOverlay [private]

Definition at line 43 of file StreamEffect.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> StreamEffect::m_textBrush [private]

Definition at line 56 of file StreamEffect.h.

The documentation for this class was generated from the following files:
  • XAudio2 audio stream effect/C++/StreamEffect.h
  • XAudio2 audio stream effect/C++/StreamEffect.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamingVoiceContext Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions

StreamingVoiceContext Struct Reference

#include "Audio.h"

List of all members.

Public Member Functions

StreamingVoiceContext ()
virtual ~StreamingVoiceContext ()
STDMETHOD_ (void, OnBufferStart)(void *)
STDMETHOD_ (void, OnVoiceError)(void *
STDMETHOD_ (void, OnLoopEnd)(void *)
STDMETHOD_ (void, OnBufferEnd)(void *pContext)
STDMETHOD_ (void, OnVoiceProcessingPassStart)(UINT32)
STDMETHOD_ (void, OnStreamEnd)()
STDMETHOD_ (void, OnVoiceProcessingPassEnd)()

Detailed Description

Definition at line 41 of file Audio.h.

Constructor & Destructor Documentation

StreamingVoiceContext::StreamingVoiceContext ( ) [inline]

Definition at line 61 of file Audio.h.

                            : hBufferEndEvent(CreateEventEx(NULL, FALSE, FALSE, NULL))
    {
    }

virtual StreamingVoiceContext::~StreamingVoiceContext ( ) [inline, virtual]

Definition at line 64 of file Audio.h.

    {
        CloseHandle(hBufferEndEvent);
    }

Member Function Documentation

StreamingVoiceContext::STDMETHOD_ | ( | void | ,
 |  | OnVoiceProcessingPassStart |  |
 | ) |  |  | [inline]

Definition at line 43 of file Audio.h.

{}

StreamingVoiceContext::STDMETHOD_ | ( | void | ,
 |  | OnVoiceError |
 | ) |  |
StreamingVoiceContext::STDMETHOD_ | ( | void | ,
 |  | OnLoopEnd |  |
 | ) |  |  | [inline]

Definition at line 57 of file Audio.h.

{}

StreamingVoiceContext::STDMETHOD_ | ( | void | ,
 |  | OnBufferEnd |  |
 | ) |  |  | [inline]

Definition at line 50 of file Audio.h.

    {
        // Trigger the event for the music stream.
        if (pContext == 0) {
            SetEvent(hBufferEndEvent);
        }
    }

StreamingVoiceContext::STDMETHOD_ | ( | void | ,
 |  | OnBufferStart |  |
 | ) |  |  | [inline]

Definition at line 46 of file Audio.h.

    {
        ResetEvent(hBufferEndEvent);
    }

StreamingVoiceContext::STDMETHOD_ | ( | void | ,
 |  | OnStreamEnd |  |
 | ) |  |  | [inline]

Definition at line 45 of file Audio.h.

{}

StreamingVoiceContext::STDMETHOD_ | ( | void | ,
 |  | OnVoiceProcessingPassEnd |  |
 | ) |  |  | [inline]

Definition at line 44 of file Audio.h.

{}

The documentation for this struct was generated from the following file:
  • DirectX marble maze game/C++/Audio.h
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamList Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

StreamList Class Reference

#include "MPEG1Src.h"

List of all members.

Public Member Functions

StreamList ()
StreamList ()
~StreamList ()
~StreamList ()
HRESULT | AddStream (BYTE id, CMPEG1Stream *pStream)
HRESULT | AddStream (BYTE id, CMPEG1Stream *pStream)
void | Clear ()
void | Clear ()
CMPEG1Stream * | Find (BYTE id)
CMPEG1Stream * | Find (BYTE id)
UINT32 | GetCount () const
UINT32 | GetCount () const
CMPEG1Stream *const | operator[] (DWORD index) const
CMPEG1Stream * | operator[] (DWORD index)
CMPEG1Stream *const | operator[] (DWORD index) const
CMPEG1Stream * | operator[] (DWORD index)

Private Attributes

UINT32 | m_count
BYTE | m_id [MAX_STREAMS]
CMPEG1Stream * m_streams [MAX_STREAMS]

Detailed Description

Definition at line 86 of file MPEG1Src.h.

Constructor & Destructor Documentation

StreamList::StreamList ( ) [inline]

Definition at line 93 of file MPEG1Src.h.

                 : m_count(0)
    {
        ZeroMemory(m_streams, sizeof(m_streams));
    }

StreamList::~StreamList ( ) [inline]

Definition at line 97 of file MPEG1Src.h.

    {
        Clear();
    }

StreamList::StreamList ( ) [inline]

Definition at line 93 of file MPEG1Src.h.

                 : m_count(0)
    {
        ZeroMemory(m_streams, sizeof(m_streams));
    }

StreamList::~StreamList ( ) [inline]

Definition at line 97 of file MPEG1Src.h.

    {
        Clear();
    }

Member Function Documentation

HRESULT StreamList::AddStream | ( | BYTE | id,
 |  | CMPEG1Stream * | pStream |
 | ) |  |  | [inline]

Definition at line 113 of file MPEG1Src.h.

    {
        if (GetCount() >= MAX_STREAMS)
        {
            return E_FAIL;
        }

        m_streams[m_count] = pStream;
        pStream->AddRef();

        m_id[m_count] = id;

        m_count++;

        return S_OK;
    }

HRESULT StreamList::AddStream | ( | BYTE | id,
 |  | CMPEG1Stream * | pStream |
 | ) |  |  | [inline]

Definition at line 113 of file MPEG1Src.h.

    {
        if (GetCount() >= MAX_STREAMS)
        {
            return E_FAIL;
        }

        m_streams[m_count] = pStream;
        pStream->AddRef();

        m_id[m_count] = id;

        m_count++;

        return S_OK;
    }

void StreamList::Clear ( ) [inline]

Definition at line 104 of file MPEG1Src.h.

    {
        for (UINT32 i = 0; i < MAX_STREAMS; i++)
        {
            SafeRelease(&m_streams[i]);
        }
        m_count = 0;
    }

void StreamList::Clear ( ) [inline]

Definition at line 104 of file MPEG1Src.h.

    {
        for (UINT32 i = 0; i < MAX_STREAMS; i++)
        {
            SafeRelease(&m_streams[i]);
        }
        m_count = 0;
    }

CMPEG1Stream* StreamList::Find ( BYTE id ) [inline]

Definition at line 130 of file MPEG1Src.h.

    {

        // This method can return NULL if the source did not create a
        // stream for this ID. In particular, this can happen if:
        //
        // 1) The stream type is not supported. See IsStreamTypeSupported().
        // 2) The source is still opening.
        //
        // Note: This method does not AddRef the stream object. The source
        // uses this method to access the streams. If the source hands out
        // a stream pointer (e.g. in the MENewStream event), the source
        // must AddRef the stream object.

        CMPEG1Stream* pStream = NULL;
        for (UINT32 i = 0; i < m_count; i++)
        {
            if (m_id[i] == id)
            {
                pStream = m_streams[i];
                break;
            }
        }
        return pStream;
    }

CMPEG1Stream* StreamList::Find ( BYTE id ) [inline]

Definition at line 130 of file MPEG1Src.h.

    {

        // This method can return NULL if the source did not create a
        // stream for this ID. In particular, this can happen if:
        //
        // 1) The stream type is not supported. See IsStreamTypeSupported().
        // 2) The source is still opening.
        //
        // Note: This method does not AddRef the stream object. The source
        // uses this method to access the streams. If the source hands out
        // a stream pointer (e.g. in the MENewStream event), the source
        // must AddRef the stream object.

        CMPEG1Stream* pStream = NULL;
        for (UINT32 i = 0; i < m_count; i++)
        {
            if (m_id[i] == id)
            {
                pStream = m_streams[i];
                break;
            }
        }
        return pStream;
    }

UINT32 StreamList::GetCount ( ) const [inline]

Definition at line 102 of file MPEG1Src.h.

{ return m_count; }

UINT32 StreamList::GetCount ( ) const [inline]

Definition at line 102 of file MPEG1Src.h.

{ return m_count; }

CMPEG1Stream* const StreamList::operator[] ( DWORD index ) const [inline]

Definition at line 164 of file MPEG1Src.h.

    {
        assert(index < m_count);
        return m_streams[index];
    }

CMPEG1Stream* StreamList::operator[] ( DWORD index ) [inline]

Definition at line 157 of file MPEG1Src.h.

    {
        assert(index < m_count);
        return m_streams[index];
    }

CMPEG1Stream* const StreamList::operator[] ( DWORD index ) const [inline]

Definition at line 164 of file MPEG1Src.h.

    {
        assert(index < m_count);
        return m_streams[index];
    }

CMPEG1Stream* StreamList::operator[] ( DWORD index ) [inline]

Definition at line 157 of file MPEG1Src.h.

    {
        assert(index < m_count);
        return m_streams[index];
    }

Member Data Documentation

UINT32 StreamList::m_count [private]

Definition at line 90 of file MPEG1Src.h.

BYTE StreamList::m_id [private]

Definition at line 89 of file MPEG1Src.h.

CMPEG1Stream * StreamList::m_streams [private]

Definition at line 88 of file MPEG1Src.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
  • Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.h
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocketSample::App Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • StreamSocketSample
  • StreamSocketSample::App
Public Member Functions | Public Attributes | Private Attributes

StreamSocketSample::App Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)

Public Attributes

internal | __pad0__: App()

Private Attributes

Windows::UI::Xaml::Controls::Frame | rootFrame

Detailed Description

Definition at line 24 of file App.xaml.h.

Member Function Documentation

void App::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs ) [override, virtual]

Definition at line 43 of file App.xaml.cpp.

{
    if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
    {
        SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
        {
            try
            {
                restoreTask.get();
            }
            catch (Platform::Exception^)
            {
                // If restore fails, the app should proceed as though there was no restored state.
            }
        });
    }
    if (Window::Current->Content == nullptr)
    {
        rootFrame = ref new Frame();
        TypeName pageType = { "StreamSocketSample.MainPage", TypeKind::Custom };
        rootFrame->Navigate(pageType);
        Window::Current->Content = rootFrame;
    }
    MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
    p->LaunchArgs = pArgs;
    Window::Current->Activate();
}

void App::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]

Definition at line 34 of file App.xaml.cpp.

{
    auto deferral = pArgs->SuspendingOperation->GetDeferral();
    SuspensionManager::StartSaveTask().then([=]()
    {
        deferral->Complete();
    });
}

Member Data Documentation

internal StreamSocketSample::App::__pad0__

Definition at line 27 of file App.xaml.h.

Windows::UI::Xaml::Controls::Frame StreamSocketSample::App::rootFrame [private]

Definition at line 32 of file App.xaml.h.

The documentation for this class was generated from the following files:
  • StreamSocket/C++/App.xaml.h
  • StreamSocket/C++/App.xaml.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocketSample::Common::LayoutAwarePage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • StreamSocketSample
  • Common
  • StreamSocketSample::Common::LayoutAwarePage
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

StreamSocketSample::Common::LayoutAwarePage Class Reference

Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model.

#include "LayoutAwarePage.h"

List of all members.

Public Member Functions

virtual Platform::String | DetermineVisualState (Windows::UI::ViewManagement::ApplicationViewState viewState)
virtual void | GoBack (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateVisualState ()
void | StartLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | StopLayoutUpdates (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Public Attributes

internal | __pad0__: LayoutAwarePage()

Private Member Functions

void | WindowSizeChanged (Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)

Private Attributes

Platform::Collections::Map
< Platform::String^, Object^> 		_defaultViewModel
Platform::Collections::Vector
< Windows::UI::Xaml::Controls::Control^> 		_layoutAwareControls
Windows::Foundation::EventRegistrationToken | _windowSizeEventToken

Detailed Description

Definition at line 30 of file LayoutAwarePage.h.

Member Function Documentation

virtual Platform::String StreamSocketSample::Common::LayoutAwarePage::DetermineVisualState ( Windows::UI::ViewManagement::ApplicationViewState viewState ) [virtual]
virtual void StreamSocketSample::Common::LayoutAwarePage::GoBack | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [virtual]
void LayoutAwarePage::InvalidateVisualState ( )

Updates all controls that are listening for visual state changes with the correct visual state.

Typically used in conjunction with overriding DetermineVisualState to signal that a different value may be returned even though the view state has not changed.

Definition at line 186 of file LayoutAwarePage.cpp.

{
    if (_layoutAwareControls != nullptr)
    {
        String^ visualState = DetermineVisualState(ApplicationView::Value);
        auto controlIterator = _layoutAwareControls->First();
        while (controlIterator->HasCurrent)
        {
            auto control = controlIterator->Current;
            VisualStateManager::GoToState(control, visualState, false);
            controlIterator->MoveNext();
        }
    }
}

void StreamSocketSample::Common::LayoutAwarePage::StartLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void StreamSocketSample::Common::LayoutAwarePage::StopLayoutUpdates | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e
 | ) |  |
void LayoutAwarePage::WindowSizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]

Definition at line 127 of file LayoutAwarePage.cpp.

{
    InvalidateVisualState();
}

Member Data Documentation

internal StreamSocketSample::Common::LayoutAwarePage::__pad0__

Definition at line 33 of file LayoutAwarePage.h.

Platform::Collections::Map<Platform::String^, Object^> StreamSocketSample::Common::LayoutAwarePage::_defaultViewModel [private]

Definition at line 54 of file LayoutAwarePage.h.

Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^> StreamSocketSample::Common::LayoutAwarePage::_layoutAwareControls [private]

Definition at line 56 of file LayoutAwarePage.h.

Windows::Foundation::EventRegistrationToken StreamSocketSample::Common::LayoutAwarePage::_windowSizeEventToken [private]

Definition at line 55 of file LayoutAwarePage.h.

The documentation for this class was generated from the following files:
  • StreamSocket/C++/Common/LayoutAwarePage.h
  • StreamSocket/C++/Common/LayoutAwarePage.cpp
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocketSample::MainPage Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • StreamSocketSample
  • StreamSocketSample::MainPage

StreamSocketSample::MainPage Class Reference

#include "Constants.h"

Detailed Description

Definition at line 23 of file Constants.h.

The documentation for this class was generated from the following file:
  • StreamSocket/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocketSample::Scenario Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • StreamSocketSample
  • StreamSocketSample::Scenario
Public Attributes

StreamSocketSample::Scenario Struct Reference

#include "Constants.h"

List of all members.

Public Attributes

Platform::String | ClassName
Platform::String | Title

Detailed Description

Definition at line 17 of file Constants.h.

Member Data Documentation

Platform::String StreamSocketSample::Scenario::ClassName

Definition at line 20 of file Constants.h.

Platform::String StreamSocketSample::Scenario::Title

Definition at line 19 of file Constants.h.

The documentation for this struct was generated from the following file:
  • StreamSocket/C++/Constants.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocketSample::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • StreamSocketSample
  • StreamSocketSample::sealed
Public Member Functions | Protected Member Functions | Protected Attributes | Properties | Private Member Functions | Private Attributes

StreamSocketSample::sealed Class Reference

An empty page that can be used on its own or navigated to within a Frame.

#include "MainPage.xaml.h"

List of all members.

Public Member Functions

ListenerContext (MainPage^rootPage, StreamSocketListener^listener)
void | LoadScenario (Platform::String^scenarioName)
MainPage ()
void | NotifyUser (Platform::String^strMessage, NotifyType type)
void | OnConnection (StreamSocketListener^listener, StreamSocketListenerConnectionReceivedEventArgs^object)
Scenario1 ()
Scenario2 ()
Scenario3 ()
Scenario4 ()

Protected Member Functions

void | MainPage_SizeChanged (Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e)
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e)

Protected Attributes

internal | __pad0__: static MainPage^ Current

Properties

event
Windows::Foundation::EventHandler
< MainPageSizeChangedEventArgs^> 		MainPageResized
event
Windows::Foundation::EventHandler
< Platform::Object^> 		ScenarioLoaded

Private Member Functions

~ListenerContext ()
~MainPage ()
void | CloseSockets_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | ConnectSocket_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Footer_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | InvalidateSize ()
void | InvalidateViewState ()
void | NotifyUserFromAsyncThread (String^message, NotifyType type)
void | PopulateScenarios ()
void | ReceiveStringLoop (DataReader^reader, StreamSocket^socket)
void | SendHello_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | SetFeatureName (Platform::String^strFeature)
void | StartListener_Click (Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)

Private Attributes

bool | autoSizeInputSectionWhenSnapped
Windows::UI::Xaml::Controls::Frame | HiddenFrame
StreamSocketListener | listener
MainPage rootPage
Platform::Collections::Vector
< Object^> 		ScenarioList

Detailed Description

Definition at line 32 of file MainPage.xaml.h.

Constructor & Destructor Documentation

StreamSocketSample::sealed::~MainPage ( ) [private]
StreamSocketSample::sealed::~ListenerContext ( ) [private]

Member Function Documentation

void StreamSocketSample::sealed::CloseSockets_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void StreamSocketSample::sealed::ConnectSocket_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void StreamSocketSample::sealed::Footer_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void StreamSocketSample::sealed::InvalidateSize ( ) [private]
void StreamSocketSample::sealed::InvalidateViewState ( ) [private]
StreamSocketSample::sealed::ListenerContext | ( | MainPage^ | rootPage,
 |  | StreamSocketListener^ | listener
 | ) |  |
void StreamSocketSample::sealed::LoadScenario ( Platform::String^ scenarioName )
StreamSocketSample::sealed::MainPage ( )
void StreamSocketSample::sealed::MainPage_SizeChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::SizeChangedEventArgs^ | e |
 | ) |  |  | [protected]
void StreamSocketSample::sealed::NotifyUser | ( | Platform::String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
void StreamSocketSample::sealed::NotifyUserFromAsyncThread | ( | String^ | message,
 |  | NotifyType | type |
 | ) |  |  | [private]
void StreamSocketSample::sealed::OnConnection | ( | StreamSocketListener^ | listener,
 |  | StreamSocketListenerConnectionReceivedEventArgs^ | object
 | ) |  |
virtual void StreamSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void StreamSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void StreamSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void StreamSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void StreamSocketSample::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
void StreamSocketSample::sealed::PopulateScenarios ( ) [private]
void StreamSocketSample::sealed::ReceiveStringLoop | ( | DataReader^ | reader,
 |  | StreamSocket^ | socket |
 | ) |  |  | [private]
StreamSocketSample::sealed::Scenario1 ( )
StreamSocketSample::sealed::Scenario2 ( )
StreamSocketSample::sealed::Scenario3 ( )
StreamSocketSample::sealed::Scenario4 ( )
void StreamSocketSample::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void StreamSocketSample::sealed::SendHello_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void StreamSocketSample::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
void StreamSocketSample::sealed::StartListener_Click | ( | Platform::Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

internal StreamSocketSample::sealed::__pad0__ [protected]

Definition at line 96 of file MainPage.xaml.h.

bool StreamSocketSample::sealed::autoSizeInputSectionWhenSnapped [private]

Definition at line 88 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame StreamSocketSample::sealed::HiddenFrame [private]

Definition at line 86 of file MainPage.xaml.h.

StreamSocketListener StreamSocketSample::sealed::listener [private]

Definition at line 53 of file Scenario1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 40 of file Scenario1.xaml.h.

Platform::Collections::Vector<Object^> StreamSocketSample::sealed::ScenarioList [private]

Definition at line 85 of file MainPage.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^> StreamSocketSample::sealed::MainPageResized

Definition at line 76 of file MainPage.xaml.h.

event Windows::Foundation::EventHandler<Platform::Object^> StreamSocketSample::sealed::ScenarioLoaded

Definition at line 75 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • StreamSocket/C++/MainPage.xaml.h
  • StreamSocket/C++/Scenario1.xaml.h
  • StreamSocket/C++/Scenario2.xaml.h
  • StreamSocket/C++/Scenario3.xaml.h
  • StreamSocket/C++/Scenario4.xaml.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SuspensionManager Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Static Public Member Functions | Properties | Private Attributes | Static Private Attributes

SuspensionManager Class Reference

List of all members.

Static Public Member Functions

static async Task | RestoreAsync ()
static async Task | RestoreAsync ()
static async Task | RestoreAsync ()
static async Task | SaveAsync ()
static async Task | SaveAsync ()
static async Task | SaveAsync ()

Properties

static List< Type > | KnownTypes [get]
static Dictionary< string, object > | SessionState [get]

Private Attributes

const string | filename = "_sessionState.xml"

Static Private Attributes

static List< Type > | knownTypes_ = new List<Type>()
static Dictionary< string, object > | sessionState_ = new Dictionary<string, object>()

Detailed Description

Definition at line 22 of file SuspensionManager.cs.

Member Function Documentation

task< void > SuspensionManager::RestoreAsync ( void ) [inline, static]

Restores previously saved SessionState.

Any Frame instances registered with RegisterFrame will also restore their prior navigation state, which in turn gives their active Page an opportunity restore its state.

Parameters:
version A version identifer compared to the session state to prevent incompatible versions of session state from reaching app code. Saved state with a different version will be ignored, resulting in an empty SessionState dictionary.
Returns:
An asynchronous task that reflects when session state has been read. The content of SessionState should not be relied upon until this task completes.

Definition at line 55 of file SuspensionManager.cs.

    {
        // Get the input stream for the SessionState file.
        try
        {
            StorageFile file = await ApplicationData.Current.LocalFolder.GetFileAsync(filename);
            if (file == null) return;
            using (IInputStream inStream = await file.OpenSequentialReadAsync())
            {
                // Deserialize the Session State.
                DataContractSerializer serializer = new DataContractSerializer(typeof(Dictionary<string, object>), knownTypes_);
                sessionState_ = (Dictionary<string, object>)serializer.ReadObject(inStream.AsStreamForRead());
            }
        }
        catch (Exception)
        {
            // Restoring state is best-effort.  If it fails, the app will just come up with a new session.
        }
    }

static async Task SuspensionManager::RestoreAsync ( void ) [inline, static]

Definition at line 55 of file SuspensionManager.cs.

    {
        // Get the input stream for the SessionState file.
        try
        {
            StorageFile file = await ApplicationData.Current.LocalFolder.GetFileAsync(filename);
            if (file == null) return;
            using (IInputStream inStream = await file.OpenSequentialReadAsync())
            {
                // Deserialize the Session State.
                DataContractSerializer serializer = new DataContractSerializer(typeof(Dictionary<string, object>), knownTypes_);
                sessionState_ = (Dictionary<string, object>)serializer.ReadObject(inStream.AsStreamForRead());
            }
        }
        catch (Exception)
        {
            // Restoring state is best-effort.  If it fails, the app will just come up with a new session.
        }
    }

static async Task SuspensionManager::RestoreAsync ( void ) [inline, static]

Definition at line 55 of file SuspensionManager.cs.

    {
        // Get the input stream for the SessionState file.
        try
        {
            StorageFile file = await ApplicationData.Current.LocalFolder.GetFileAsync(filename);
            if (file == null) return;
            using (IInputStream inStream = await file.OpenSequentialReadAsync())
            {
                // Deserialize the Session State.
                DataContractSerializer serializer = new DataContractSerializer(typeof(Dictionary<string, object>), knownTypes_);
                sessionState_ = (Dictionary<string, object>)serializer.ReadObject(inStream.AsStreamForRead());
            }
        }
        catch (Exception)
        {
            // Restoring state is best-effort.  If it fails, the app will just come up with a new session.
        }
    }

task< void > SuspensionManager::SaveAsync ( void ) [inline, static]

Save the current SessionState.

Any Frame instances registered with RegisterFrame will also preserve their current navigation stack, which in turn gives their active Page an opportunity to save its state.

Returns:
An asynchronous task that reflects when session state has been saved.

Definition at line 41 of file SuspensionManager.cs.

    {
        // Get the output stream for the SessionState file.
        StorageFile file = await ApplicationData.Current.LocalFolder.CreateFileAsync(filename, CreationCollisionOption.ReplaceExisting);
        using (StorageStreamTransaction transaction = await file.OpenTransactedWriteAsync())
        {
            // Serialize the Session State.
            DataContractSerializer serializer = new DataContractSerializer(typeof(Dictionary<string, object>), knownTypes_);
            serializer.WriteObject(transaction.Stream.AsStreamForWrite(), sessionState_);
            await transaction.CommitAsync();
        }
    }

static async Task SuspensionManager::SaveAsync ( void ) [inline, static]

Definition at line 41 of file SuspensionManager.cs.

    {
        // Get the output stream for the SessionState file.
        StorageFile file = await ApplicationData.Current.LocalFolder.CreateFileAsync(filename, CreationCollisionOption.ReplaceExisting);
        using (StorageStreamTransaction transaction = await file.OpenTransactedWriteAsync())
        {
            // Serialize the Session State.
            DataContractSerializer serializer = new DataContractSerializer(typeof(Dictionary<string, object>), knownTypes_);
            serializer.WriteObject(transaction.Stream.AsStreamForWrite(), sessionState_);
            await transaction.CommitAsync();
        }
    }

static async Task SuspensionManager::SaveAsync ( void ) [inline, static]

Definition at line 41 of file SuspensionManager.cs.

    {
        // Get the output stream for the SessionState file.
        StorageFile file = await ApplicationData.Current.LocalFolder.CreateFileAsync(filename, CreationCollisionOption.ReplaceExisting);
        using (StorageStreamTransaction transaction = await file.OpenTransactedWriteAsync())
        {
            // Serialize the Session State.
            DataContractSerializer serializer = new DataContractSerializer(typeof(Dictionary<string, object>), knownTypes_);
            serializer.WriteObject(transaction.Stream.AsStreamForWrite(), sessionState_);
            await transaction.CommitAsync();
        }
    }

Member Data Documentation

const string SuspensionManager::filename = "_sessionState.xml" [private]

Definition at line 26 of file SuspensionManager.cs.

static List< Type > SuspensionManager::knownTypes_ = new List<Type>() [static, private]

Definition at line 25 of file SuspensionManager.cs.

static Dictionary< string, object > SuspensionManager::sessionState_ = new Dictionary<string, object>() [static, private]

Definition at line 24 of file SuspensionManager.cs.

Property Documentation

static List< Type > SuspensionManager::KnownTypes [static, get]

Definition at line 36 of file SuspensionManager.cs.

static Dictionary< string, object > SuspensionManager::SessionState [static, get]

Definition at line 30 of file SuspensionManager.cs.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/Sample-Utils/SuspensionManager.cs
  • Real-time communication/C#,C++/sample-utils/SuspensionManager.cs
  • Real-time communication/C#,C++/SuspensionManager.cs
  • Accelerometer sensor/C++/common/suspensionmanager.cpp
  • Animation metrics/C++/common/suspensionmanager.cpp
  • App package information/C++/common/suspensionmanager.cpp
  • App settings/C++/common/suspensionmanager.cpp
  • App tiles and badges/C#,C++/common/suspensionmanager.cpp
  • Application data/C++/common/suspensionmanager.cpp
  • AtomPub/C++/common/suspensionmanager.cpp
  • Background task/C++/BackgroundTask/common/suspensionmanager.cpp
  • Background Transfer/C++/common/suspensionmanager.cpp
  • Bluetooth call control/C++/common/suspensionmanager.cpp
  • Calendar details and math/C++/common/suspensionmanager.cpp
  • CameraCaptureUI/C++/common/suspensionmanager.cpp
  • CameraOptionsUI/C++/common/suspensionmanager.cpp
  • Certificate enrollment/C++/common/suspensionmanager.cpp
  • Compass sensor/C++/common/suspensionmanager.cpp
  • Compression/C++/common/suspensionmanager.cpp
  • Configure keys for media/C++/common/suspensionmanager.cpp
  • Connecting with WebSockets/C++/common/suspensionmanager.cpp
  • Context menu/C++/common/suspensionmanager.cpp
  • Credential locker/C++/common/suspensionmanager.cpp
  • CryptoWinRT/C++/common/suspensionmanager.cpp
  • Custom driver access/C++/app_cpp/common/suspensionmanager.cpp
  • Date and time formatting/C++/common/suspensionmanager.cpp
  • Device enumeration/C++/common/suspensionmanager.cpp
  • Display orientation/C++/common/suspensionmanager.cpp
  • EAS policies for mail clients/C++/common/suspensionmanager.cpp
  • File access/C++/common/suspensionmanager.cpp
  • File and folder thumbnail/C++/common/suspensionmanager.cpp
  • File picker/C++/common/suspensionmanager.cpp
  • File picker contracts/C++/common/suspensionmanager.cpp
  • Folder enumeration/C++/common/suspensionmanager.cpp
  • Geolocation/C++/common/SuspensionManager.cpp
  • Globalization preferences/C++/common/suspensionmanager.cpp
  • Gyrometer sensor/C++/common/suspensionmanager.cpp
  • Hilo C++/C++/Hilo/Common/SuspensionManager.cpp
  • HomeGroup app/C++/common/suspensionmanager.cpp
  • HttpClient/C++/common/suspensionmanager.cpp
  • Inclinometer sensor/C++/common/suspensionmanager.cpp
  • Input Device capabilities/C++/common/suspensionmanager.cpp
  • Input Touch keyboard/C++/common/suspensionmanager.cpp
  • Input Touch keyboard text input/C++/common/suspensionmanager.cpp
  • LightSensor/C++/common/suspensionmanager.cpp
  • Lock screen personalization/C++/common/suspensionmanager.cpp
  • Media Play To/C++/common/suspensionmanager.cpp
  • Media Server client/C++/common/suspensionmanager.cpp
  • Message dialog/C++/common/suspensionmanager.cpp
  • Network information/C++/common/suspensionmanager.cpp
  • Number formatting and parsing/C++/common/suspensionmanager.cpp
  • OrientationSensor/C++/common/suspensionmanager.cpp
  • Playback Manager Companion/C++/common/suspensionmanager.cpp
  • Playlist/C++/common/suspensionmanager.cpp
  • PlayToReceiver/C++/common/suspensionmanager.cpp
  • Portable device API/C++/common/SuspensionManager.cpp
  • Programmatic file search/C++/common/suspensionmanager.cpp
  • Reading and writing data/C++/common/suspensionmanager.cpp
  • Removable storage/C++/common/SuspensionManager.cpp
  • Scaling according to DPI/C++/common/suspensionmanager.cpp
  • Search contract/C++/common/suspensionmanager.cpp
  • Sharing content source app/C++/common/suspensionmanager.cpp
  • SimpleOrientationSensor/C++/common/suspensionmanager.cpp
  • Snap/C++/common/suspensionmanager.cpp
  • Splash screen/C++/common/suspensionmanager.cpp
  • Syndication/C++/common/suspensionmanager.cpp
  • Thread pool/C++/common/suspensionmanager.cpp
  • Transcoding media/C++/common/suspensionmanager.cpp
  • Trial app and in-app purchase/C++/common/suspensionmanager.cpp
  • UI contrast and settings/C++/common/suspensionmanager.cpp
  • User domain name/C++/common/suspensionmanager.cpp
  • USSD message management/C++/common/suspensionmanager.cpp
  • Web authentication broker/C++/common/suspensionmanager.cpp
  • Windows account authorization/C++/common/suspensionmanager.cpp
  • Windows Audio Session (WASAPI)/C++/common/suspensionmanager.cpp
  • XAML accessibility/C++/common/suspensionmanager.cpp
  • XAML animation library/C++/common/suspensionmanager.cpp
  • XAML data binding/C++/Common/suspensionmanager.cpp
  • XAML FlipView control/C++/common/suspensionmanager.cpp
  • XAML high contrast style/C++/common/suspensionmanager.cpp
  • XAML images/C++/common/suspensionmanager.cpp
  • XAML personality animations/C++/common/suspensionmanager.cpp
  • XAML Popup/C++/common/suspensionmanager.cpp
  • XAML text display/C++/Common/suspensionmanager.cpp
  • XAML text editing/C++/Common/suspensionmanager.cpp
  • XAML two-dimensional transforms/C++/common/suspensionmanager.cpp
  • XAML user and custom controls/C++/common/suspensionmanager.cpp
  • XAML vector-based drawing/C++/common/suspensionmanager.cpp
  • XAML WebView control/C++/common/suspensionmanager.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SValue Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

SValue Struct Reference

List of all members.

Public Attributes

DWORD | dwValue
LPCWSTR | pName

Detailed Description

Definition at line 50 of file Texconv.cpp.

Member Data Documentation

DWORD SValue::dwValue

Definition at line 53 of file Texconv.cpp.

LPCWSTR SValue::pName

Definition at line 52 of file Texconv.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/Texconv.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TangentVertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TangentVertex Struct Reference

#include "BasicShapes.h"

List of all members.

Public Attributes

float3 pos
float2 tex
float3 uTan
float3 vTan

Detailed Description

Definition at line 21 of file BasicShapes.h.

Member Data Documentation

float3 TangentVertex::pos

Definition at line 23 of file BasicShapes.h.

float2 TangentVertex::tex

Definition at line 24 of file BasicShapes.h.

float3 TangentVertex::uTan

Definition at line 25 of file BasicShapes.h.

float3 TangentVertex::vTan

Definition at line 26 of file BasicShapes.h.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/BasicShapes.h
  • Direct3D HLSL fractal generator/C++/BasicShapes.h
  • Direct3D post-processing effects/C++/BasicShapes.h
  • Direct3D resource loading/C++/BasicShapes.h
  • Direct3D sprite/C++/BasicShapes.h
  • Direct3D stereoscopic 3D/C++/BasicShapes.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicShapes.h
  • Direct3D-Direct2D interop/C++/BasicShapes.h
  • DirectX 3D shooting game/C++/BasicShapes.h
  • DirectX marble maze game/C++/BasicShapes.h
  • DirectX postcard app/C++/BasicShapes.h
  • DirectX touch input/C++/BasicShapes.h
  • DXGI offer and reclaim resources/C++/BasicShapes.h
  • DXGI swap chain rotation/C++/BasicShapes.h
  • XAML DirectX 3D shooting game/C++/BasicShapes.h
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TargetTexture Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

TargetTexture Class Reference

#include "TargetTexture.h"

List of all members.

Public Member Functions

void | CreateHitTextureResourceView (_In_ Platform::String^name, _Out_ ID3D11ShaderResourceView **textureResourceView)
void | CreateHitTextureResourceView (_In_ Platform::String^name, _Out_ ID3D11ShaderResourceView **textureResourceView)
void | CreateTextureResourceView (_In_ Platform::String^name, _Out_ ID3D11ShaderResourceView **textureResourceView)
void | CreateTextureResourceView (_In_ Platform::String^name, _Out_ ID3D11ShaderResourceView **textureResourceView)

Public Attributes

internal | __pad0__: TargetTexture( _In_ ID3D11Device1* d3dDevice
internal _In_ ID2D1Factory1
_In_ IDWriteFactory1 _In_
ID2D1DeviceContext * 		d2dContext
internal _In_ ID2D1Factory1 * | d2dFactory
internal _In_ ID2D1Factory1
_In_ IDWriteFactory1 * 		dwriteFactory

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blackBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_blueBrush
Microsoft::WRL::ComPtr
< ID2D1EllipseGeometry > 		m_circleGeometry1
Microsoft::WRL::ComPtr
< ID2D1EllipseGeometry > 		m_circleGeometry2
Microsoft::WRL::ComPtr
< ID2D1EllipseGeometry > 		m_circleGeometry3
Microsoft::WRL::ComPtr
< ID2D1EllipseGeometry > 		m_circleGeometry4
Microsoft::WRL::ComPtr
< ID2D1EllipseGeometry > 		m_circleGeometry5
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_clearBrush
Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
Microsoft::WRL::ComPtr
< ID3D11Device1 > 		m_d3dDevice
Microsoft::WRL::ComPtr
< IDWriteFactory1 > 		m_dwriteFactory
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_greenBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_redBrush
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_whiteBrush
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_yellowBrush

Detailed Description

Definition at line 17 of file TargetTexture.h.

Member Function Documentation

void TargetTexture::CreateHitTextureResourceView | ( | _In_ Platform::String^ | name,
 |  | _Out_ ID3D11ShaderResourceView ** | textureResourceView
 | ) |  |

Definition at line 255 of file TargetTexture.cpp.

{
    // Allocate a offscreen D3D surface for D2D to render our 2D content into
    D3D11_TEXTURE2D_DESC texDesc;
    texDesc.ArraySize = 1;
    texDesc.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
    texDesc.CPUAccessFlags = 0;
    texDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
    texDesc.Height = 512;
    texDesc.Width = 512;
    texDesc.MipLevels = 1;
    texDesc.MiscFlags = 0;
    texDesc.SampleDesc.Count = 1;
    texDesc.SampleDesc.Quality = 0;
    texDesc.Usage = D3D11_USAGE_DEFAULT;

    ComPtr<ID3D11Texture2D> offscreenTexture;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateTexture2D(&texDesc, nullptr, &offscreenTexture)
        );

    // Convert the Direct2D texture into a Shader Resource View
    ComPtr<ID3D11ShaderResourceView> texture;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateShaderResourceView(offscreenTexture.Get(), nullptr, &texture)
        );
#if defined(_DEBUG)
    {
        char debugName[100];
        int l = sprintf_s(debugName, sizeof(debugName) / sizeof(debugName[0]), "Simple3DGame HitTarget %ls", name->Data());
        DX::ThrowIfFailed(
            texture->SetPrivateData(WKPDID_D3DDebugObjectName, l, debugName)
            );
    }
#endif

    ComPtr<IDXGISurface> dxgiSurface;
    DX::ThrowIfFailed(
        offscreenTexture.As(&dxgiSurface)
        );

    // Create a D2D render target which can draw into our offscreen D3D
    // surface. Given that we use a constant size for the texture, we
    // fix the DPI at 96.

    D2D1_BITMAP_PROPERTIES1 properties;
    properties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
    properties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
    properties.dpiX = 96;
    properties.dpiY = 96;
    properties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
    properties.colorContext = nullptr;

    ComPtr<ID2D1Bitmap1> renderTarget;
    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmapFromDxgiSurface(
            dxgiSurface.Get(),
            &properties,
            &renderTarget
            )
        );

    m_d2dContext->SetTarget(renderTarget.Get());
    float saveDpiX;
    float saveDpiY;

    m_d2dContext->GetDpi(&saveDpiX, &saveDpiY);
    m_d2dContext->SetDpi(96.0f, 96.0f);

    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    D2D1_SIZE_F renderTargetSize = renderTarget->GetSize();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));
    m_d2dContext->FillGeometry(m_circleGeometry5.Get(), m_yellowBrush.Get());
    m_d2dContext->FillGeometry(m_circleGeometry4.Get(), m_greenBrush.Get());
    m_d2dContext->FillGeometry(m_circleGeometry3.Get(), m_blueBrush.Get());
    m_d2dContext->FillGeometry(m_circleGeometry2.Get(), m_redBrush.Get());
    m_d2dContext->FillGeometry(m_circleGeometry1.Get(), m_whiteBrush.Get());
    m_d2dContext->DrawText(
        name->Data(),
        name->Length(),
        m_textFormat.Get(),
        D2D1::RectF(0, 0, renderTargetSize.width, renderTargetSize.height),
        m_blackBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_d2dContext->SetTarget(nullptr);
    m_d2dContext->SetDpi(saveDpiX, saveDpiY);

    *textureResourceView = texture.Detach();
}

void TargetTexture::CreateHitTextureResourceView | ( | _In_ Platform::String^ | name,
 |  | _Out_ ID3D11ShaderResourceView ** | textureResourceView
 | ) |  |
void TargetTexture::CreateTextureResourceView | ( | _In_ Platform::String^ | name,
 |  | _Out_ ID3D11ShaderResourceView ** | textureResourceView
 | ) |  |
void TargetTexture::CreateTextureResourceView | ( | _In_ Platform::String^ | name,
 |  | _Out_ ID3D11ShaderResourceView ** | textureResourceView
 | ) |  |

Definition at line 150 of file TargetTexture.cpp.

{
    // Allocate a offscreen D3D surface for D2D to render our 2D content into
    D3D11_TEXTURE2D_DESC texDesc;
    texDesc.ArraySize = 1;
    texDesc.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
    texDesc.CPUAccessFlags = 0;
    texDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
    texDesc.Height = 512;
    texDesc.Width = 512;
    texDesc.MipLevels = 1;
    texDesc.MiscFlags = 0;
    texDesc.SampleDesc.Count = 1;
    texDesc.SampleDesc.Quality = 0;
    texDesc.Usage = D3D11_USAGE_DEFAULT;

    ComPtr<ID3D11Texture2D> offscreenTexture;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateTexture2D(&texDesc, nullptr, &offscreenTexture)
        );

    // Convert the Direct2D texture into a Shader Resource View
    ComPtr<ID3D11ShaderResourceView> texture;
    DX::ThrowIfFailed(
        m_d3dDevice->CreateShaderResourceView(offscreenTexture.Get(), nullptr, &texture)
        );
#if defined(_DEBUG)
    {
        char debugName[100];
        int l = sprintf_s(debugName, sizeof(debugName) / sizeof(debugName[0]), "Simple3DGame Target %ls", name->Data());
        DX::ThrowIfFailed(
            texture->SetPrivateData(WKPDID_D3DDebugObjectName, l, debugName)
            );
    }
#endif

    ComPtr<IDXGISurface> dxgiSurface;
    DX::ThrowIfFailed(
        offscreenTexture.As(&dxgiSurface)
        );

    // Create a D2D render target which can draw into our offscreen D3D
    // surface. Given that we use a constant size for the texture, we
    // fix the DPI at 96.

    D2D1_BITMAP_PROPERTIES1 properties;
    properties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
    properties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
    properties.dpiX = 96;
    properties.dpiY = 96;
    properties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
    properties.colorContext = nullptr;

    ComPtr<ID2D1Bitmap1> renderTarget;
    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmapFromDxgiSurface(
            dxgiSurface.Get(),
            &properties,
            &renderTarget
            )
        );

    m_d2dContext->SetTarget(renderTarget.Get());
    float saveDpiX;
    float saveDpiY;

    m_d2dContext->GetDpi(&saveDpiX, &saveDpiY);
    m_d2dContext->SetDpi(96.0f, 96.0f);

    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    D2D1_SIZE_F renderTargetSize = renderTarget->GetSize();

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::White));
    m_d2dContext->FillGeometry(m_circleGeometry5.Get(), m_redBrush.Get());
    m_d2dContext->FillGeometry(m_circleGeometry4.Get(), m_blueBrush.Get());
    m_d2dContext->FillGeometry(m_circleGeometry3.Get(), m_greenBrush.Get());
    m_d2dContext->FillGeometry(m_circleGeometry2.Get(), m_yellowBrush.Get());
    m_d2dContext->FillGeometry(m_circleGeometry1.Get(), m_blackBrush.Get());
    m_d2dContext->DrawText(
        name->Data(),
        name->Length(),
        m_textFormat.Get(),
        D2D1::RectF(0, 0, renderTargetSize.width, renderTargetSize.height),
        m_whiteBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_d2dContext->SetTarget(nullptr);
    m_d2dContext->SetDpi(saveDpiX, saveDpiY);

    *textureResourceView = texture.Detach();
}

Member Data Documentation

internal TargetTexture::__pad0__

Definition at line 21 of file TargetTexture.h.

internal _In_ ID2D1Factory1 _In_ IDWriteFactory1 _In_ ID2D1DeviceContext * TargetTexture::d2dContext

Definition at line 21 of file TargetTexture.h.

internal _In_ ID2D1Factory1 * TargetTexture::d2dFactory

Definition at line 21 of file TargetTexture.h.

internal _In_ ID2D1Factory1 _In_ IDWriteFactory1 * TargetTexture::dwriteFactory

Definition at line 21 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > TargetTexture::m_blackBrush [private]

Definition at line 46 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > TargetTexture::m_blueBrush [private]

Definition at line 43 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1EllipseGeometry > TargetTexture::m_circleGeometry1 [private]

Definition at line 50 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1EllipseGeometry > TargetTexture::m_circleGeometry2 [private]

Definition at line 51 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1EllipseGeometry > TargetTexture::m_circleGeometry3 [private]

Definition at line 52 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1EllipseGeometry > TargetTexture::m_circleGeometry4 [private]

Definition at line 53 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1EllipseGeometry > TargetTexture::m_circleGeometry5 [private]

Definition at line 54 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > TargetTexture::m_clearBrush [private]

Definition at line 48 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1DeviceContext > TargetTexture::m_d2dContext [private]

Definition at line 39 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1Factory1 > TargetTexture::m_d2dFactory [private]

Definition at line 38 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID3D11Device1 > TargetTexture::m_d3dDevice [private]

Definition at line 37 of file TargetTexture.h.

Microsoft::WRL::ComPtr< IDWriteFactory1 > TargetTexture::m_dwriteFactory [private]

Definition at line 40 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > TargetTexture::m_greenBrush [private]

Definition at line 44 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > TargetTexture::m_redBrush [private]

Definition at line 42 of file TargetTexture.h.

Microsoft::WRL::ComPtr< IDWriteTextFormat > TargetTexture::m_textFormat [private]

Definition at line 56 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > TargetTexture::m_whiteBrush [private]

Definition at line 45 of file TargetTexture.h.

Microsoft::WRL::ComPtr< ID2D1SolidColorBrush > TargetTexture::m_yellowBrush [private]

Definition at line 47 of file TargetTexture.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/TargetTexture.h
  • XAML DirectX 3D shooting game/C++/TargetTexture.h
  • DirectX 3D shooting game/C++/TargetTexture.cpp
  • XAML DirectX 3D shooting game/C++/TargetTexture.cpp
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Tasks::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Tasks
  • Tasks::sealed
Public Member Functions | Private Member Functions | Private Attributes

Tasks::sealed Class Reference

#include "SampleBackgroundTask.h"

List of all members.

Public Member Functions

void | OnCanceled (IBackgroundTaskInstance^taskInstance, BackgroundTaskCancellationReason reason)
void | OnCanceled (IBackgroundTaskInstance^taskInstance, BackgroundTaskCancellationReason reason)
virtual void | Run (IBackgroundTaskInstance^taskInstance)
virtual void | Run (IBackgroundTaskInstance^taskInstance)
SampleBackgroundTask ()
ServicingComplete ()

Private Member Functions

~SampleBackgroundTask ()
~ServicingComplete ()

Private Attributes

volatile bool | CancelRequested
Platform::Agile
< Windows::ApplicationModel::Background::BackgroundTaskDeferral > 		Deferral
ThreadPoolTimer | PeriodicTimer
unsigned int | Progress
IBackgroundTaskInstance | TaskInstance

Detailed Description

Definition at line 12 of file SampleBackgroundTask.h.

Constructor & Destructor Documentation

Tasks::sealed::~SampleBackgroundTask ( ) [private]
Tasks::sealed::~ServicingComplete ( ) [private]

Member Function Documentation

void Tasks::sealed::OnCanceled | ( | IBackgroundTaskInstance^ | taskInstance,
 |  | BackgroundTaskCancellationReason | reason
 | ) |  |
void Tasks::sealed::OnCanceled | ( | IBackgroundTaskInstance^ | taskInstance,
 |  | BackgroundTaskCancellationReason | reason
 | ) |  |
virtual void Tasks::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
virtual void Tasks::sealed::Run ( IBackgroundTaskInstance^ taskInstance ) [virtual]
Tasks::sealed::SampleBackgroundTask ( )
Tasks::sealed::ServicingComplete ( )

Member Data Documentation

volatile bool sealed::CancelRequested [private]

Definition at line 24 of file SampleBackgroundTask.h.

Platform::Agile<Windows::ApplicationModel::Background::BackgroundTaskDeferral> Tasks::sealed::Deferral [private]

Definition at line 25 of file SampleBackgroundTask.h.

ThreadPoolTimer Tasks::sealed::PeriodicTimer [private]

Definition at line 26 of file SampleBackgroundTask.h.

unsigned int Tasks::sealed::Progress [private]

Definition at line 27 of file SampleBackgroundTask.h.

IBackgroundTaskInstance Tasks::sealed::TaskInstance [private]

Definition at line 28 of file SampleBackgroundTask.h.

The documentation for this class was generated from the following files:
  • Background task/C++/Tasks/SampleBackgroundTask.h
  • Background task/C++/Tasks/ServicingComplete.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Text Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Member Functions | Private Attributes

Text Class Reference

#include "Text.h"

Inherits Resource.

List of all members.

Public Member Functions

virtual bool | AcceptChildNode (_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override
size_t | GetLength ()
void | GetTextLayout (_Outptr_ IDWriteTextLayout **textLayout)
virtual bool | Initialize (_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override

Public Attributes

internal | __pad0__: Text()

Private Member Functions

Platform::String | GetText (_In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode)

Private Attributes

Microsoft::WRL::ComPtr
< IDWriteTextLayout1 > 		m_textLayout
size_t | m_textLength
size_t | m_textPosition

Detailed Description

Definition at line 31 of file Text.h.

Member Function Documentation

virtual bool Text::AcceptChildNode | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::IXmlNode^ | childXmlNode |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

size_t Text::GetLength ( ) [inline]

Definition at line 48 of file Text.h.

    {
        return m_textLength;
    }

Platform::String Text::GetText ( _In_ Windows::Data::Xml::Dom::IXmlNode^ xmlNode ) [private]
void Text::GetTextLayout ( _Outptr_ IDWriteTextLayout ** textLayout )
virtual bool Text::Initialize | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::XmlElement^ | xmlElement |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Member Data Documentation

internal Text::__pad0__

Reimplemented from Resource.

Definition at line 34 of file Text.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout1> Text::m_textLayout [private]

Definition at line 57 of file Text.h.

size_t Text::m_textLength [private]

Definition at line 63 of file Text.h.

size_t Text::m_textPosition [private]

Definition at line 60 of file Text.h.

The documentation for this class was generated from the following file:
  • Direct2D magazine app/C++/Text.h
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextAnalysis Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Protected Member Functions | Protected Attributes

TextAnalysis Class Reference

#include "TextAnalysis.h"

Inherits ComBase< QiList< IDWriteTextAnalysisSource1, QiList< IDWriteTextAnalysisSink1, QiList< IUnknown > > > >.

List of all members.

Classes

struct | LinkedRun
struct | Run

Public Member Functions

TextAnalysis (const wchar_t *text, UINT32 textLength, const wchar_t *localeName, IDWriteNumberSubstitution *numberSubstitution, ReadingDirection readingDirection, GlyphOrientationMode glyphOrientationMode)
STDMETHODIMP | AnalyzeBidi (Microsoft::WRL::ComPtr< IDWriteTextAnalyzer1 > textAnalyzer, IDWriteTextAnalysisSource1 *analysisSource, UINT32 firstPosition, UINT32 textLength, IDWriteTextAnalysisSink1 *analysisSink)
STDMETHODIMP | AnalyzeGlyphOrientation (Microsoft::WRL::ComPtr< IDWriteTextAnalyzer1 > textAnalyzer, IDWriteTextAnalysisSource1 *analysisSource, UINT32 textPosition, UINT32 textLength, IDWriteTextAnalysisSink1 *analysisSink)
STDMETHODIMP | GenerateResults (Microsoft::WRL::ComPtr< IDWriteTextAnalyzer1 > textAnalyzer, _Out_ std::vector< Run > &runs, _Out_ std::vector< DWRITE_LINE_BREAKPOINT > &breakpoints_)
IFACEMETHODIMP | GetLocaleName (UINT32 textPosition, _Out_ UINT32 *textLength, _Out_ WCHAR const **localeName)
IFACEMETHODIMP | GetNumberSubstitution (UINT32 textPosition, _Out_ UINT32 *textLength, _Out_ IDWriteNumberSubstitution **numberSubstitution)
IFACEMETHODIMP | GetTextAtPosition (UINT32 textPosition, _Out_ WCHAR const **textString, _Out_ UINT32 *textLength)
IFACEMETHODIMP | GetTextBeforePosition (UINT32 textPosition, _Out_ WCHAR const **textString, _Out_ UINT32 *textLength)
IFACEMETHODIMP | GetVerticalGlyphOrientation (UINT32 textPosition, _Out_ UINT32 *textLength, _Out_ DWRITE_VERTICAL_GLYPH_ORIENTATION *glyphOrientation, _Out_ UINT8 *bidiLevel)
IFACEMETHODIMP_ (DWRITE_READING_DIRECTION) GetParagraphReadingDirection()
IFACEMETHODIMP | SetBidiLevel (UINT32 textPosition, UINT32 textLength, UINT8 explicitLevel, UINT8 resolvedLevel)
IFACEMETHODIMP | SetGlyphOrientation (UINT32 textPosition, UINT32 textLength, DWRITE_GLYPH_ORIENTATION_ANGLE glyphOrientationAngle, UINT8 adjustedBidiLevel, BOOL isSideways, BOOL isRightToLeft)
IFACEMETHODIMP | SetLineBreakpoints (UINT32 textPosition, UINT32 textLength, const DWRITE_LINE_BREAKPOINT *lineBreakpoints)
IFACEMETHODIMP | SetNumberSubstitution (UINT32 textPosition, UINT32 textLength, IDWriteNumberSubstitution *numberSubstitution)
IFACEMETHODIMP | SetScriptAnalysis (UINT32 textPosition, UINT32 textLength, DWRITE_SCRIPT_ANALYSIS const *scriptAnalysis)

Protected Member Functions

LinkedRun & | FetchNextRun (_Inout_ UINT32 *textLength)
void | SetCurrentRun (UINT32 textPosition)
void | SplitCurrentRun (UINT32 splitPosition)

Protected Attributes

std::vector
< DWRITE_LINE_BREAKPOINT > 		m_breakpoints
UINT32 | m_currentPosition
UINT32 | m_currentRunIndex
GlyphOrientationMode m_glyphOrientationMode
const wchar_t * | m_localeName
IDWriteNumberSubstitution * | m_numberSubstitution
ReadingDirection m_readingDirection
std::vector< LinkedRun > | m_runs
const wchar_t * | m_text
UINT32 | m_textLength

Detailed Description

Definition at line 88 of file TextAnalysis.h.

Constructor & Destructor Documentation

TextAnalysis::TextAnalysis | ( | const wchar_t * | text,
 |  | UINT32 | textLength,
 |  | const wchar_t * | localeName,
 |  | IDWriteNumberSubstitution * | numberSubstitution,
 |  | ReadingDirection | readingDirection,
 |  | GlyphOrientationMode | glyphOrientationMode
 | ) |  |

Definition at line 14 of file TextAnalysis.cpp.

:   m_text(text),
    m_textLength(textLength),
    m_localeName(localeName),
    m_readingDirection(readingDirection),
    m_numberSubstitution(numberSubstitution),
    m_glyphOrientationMode(glyphOrientationMode),
    m_currentPosition(0),
    m_currentRunIndex(0)
{
}

Member Function Documentation

STDMETHODIMP TextAnalysis::AnalyzeBidi | ( | Microsoft::WRL::ComPtr< IDWriteTextAnalyzer1 > | textAnalyzer,
 |  | IDWriteTextAnalysisSource1 * | analysisSource,
 |  | UINT32 | firstPosition,
 |  | UINT32 | textLength,
 |  | IDWriteTextAnalysisSink1 * | analysisSink
 | ) |  |

Definition at line 370 of file TextAnalysis.cpp.

{
    if (firstPosition + textLength < firstPosition)
    {
        return E_INVALIDARG;
    }

    if (textLength == 0)
    {
        return S_OK;
    }

    textAnalyzer->AnalyzeBidi(analysisSource, firstPosition, textLength, analysisSink);

    return S_OK;
}

STDMETHODIMP TextAnalysis::AnalyzeGlyphOrientation | ( | Microsoft::WRL::ComPtr< IDWriteTextAnalyzer1 > | textAnalyzer,
 |  | IDWriteTextAnalysisSource1 * | analysisSource,
 |  | UINT32 | textPosition,
 |  | UINT32 | textLength,
 |  | IDWriteTextAnalysisSink1 * | analysisSink
 | ) |  |

Definition at line 338 of file TextAnalysis.cpp.

{
    if (firstPosition + textLength < firstPosition)
    {
        return E_INVALIDARG;
    }

    if (textLength == 0)
    {
        return S_OK;
    }

    if ((m_readingDirection & ReadingDirectionPrimaryAxis) != 0) // if vertical direction
    {
        switch (m_glyphOrientationMode)
        {
        case GlyphOrientationModeDefault:
        case GlyphOrientationModeStacked:
            textAnalyzer->AnalyzeVerticalGlyphOrientation(analysisSource, firstPosition, textLength, analysisSink);
            break;
        }
    }

    return S_OK;
}

TextAnalysis::LinkedRun & TextAnalysis::FetchNextRun ( _Inout_ UINT32 * textLength ) [protected]

Definition at line 394 of file TextAnalysis.cpp.

{
    // Used by the sink setters, this returns a reference to the next run.
    // Position and length are adjusted to now point after the current run
    // being returned.
    UINT32 runIndex      = m_currentRunIndex;
    UINT32 runTextLength = m_runs[m_currentRunIndex].textLength;

    // Split the tail if needed (the length remaining is less than the
    // current run's size).
    if (*textLength < runTextLength)
    {
        runTextLength       = *textLength; // Limit to what's actually left.
        UINT32 runTextStart = m_runs[m_currentRunIndex].textStart;

        SplitCurrentRun(runTextStart + runTextLength);
    }
    else
    {
        // Just advance the current run.
        m_currentRunIndex = m_runs[m_currentRunIndex].nextRunIndex;
    }
    *textLength -= runTextLength;

    // Return a reference to the run that was just current.
    return m_runs[runIndex];
}

STDMETHODIMP TextAnalysis::GenerateResults | ( | Microsoft::WRL::ComPtr< IDWriteTextAnalyzer1 > | textAnalyzer,
 |  | _Out_ std::vector< Run > & | runs,
 |  | _Out_ std::vector< DWRITE_LINE_BREAKPOINT > & | breakpoints_
 | ) |  |
IFACEMETHODIMP TextAnalysis::GetLocaleName | ( | UINT32 | textPosition,
 |  | _Out_ UINT32 * | textLength,
 |  | _Out_ WCHAR const ** | localeName
 | ) |  |

Definition at line 141 of file TextAnalysis.cpp.

{
    // The pointer returned should remain valid until the next call,
    // or until analysis ends. Since only one locale name is supported,
    // the text length is valid from the current position forward to
    // the end of the string.

    *localeName = m_localeName;
    *textLength = m_textLength - textPosition;

    return S_OK;
}

IFACEMETHODIMP TextAnalysis::GetNumberSubstitution | ( | UINT32 | textPosition,
 |  | _Out_ UINT32 * | textLength,
 |  | _Out_ IDWriteNumberSubstitution ** | numberSubstitution
 | ) |  |

Definition at line 158 of file TextAnalysis.cpp.

{
    if (m_numberSubstitution != nullptr)
    {
        m_numberSubstitution->AddRef();
    }

    *numberSubstitution = m_numberSubstitution;
    *textLength = m_textLength - textPosition;

    return S_OK;
}

IFACEMETHODIMP TextAnalysis::GetTextAtPosition | ( | UINT32 | textPosition,
 |  | _Out_ WCHAR const ** | textString,
 |  | _Out_ UINT32 * | textLength
 | ) |  |

Definition at line 85 of file TextAnalysis.cpp.

{
    if (textPosition >= m_textLength)
    {
        // Return no text if a query comes for a position at the end of
        // the range. Note that is not an error and we should not return
        // a failing HRESULT. Although the application is not expected
        // to return any text that is outside of the given range, the
        // analyzers may probe the ends to see if text exists.
        *textString = nullptr;
        *textLength = 0;
    }
    else
    {
        *textString = &m_text[textPosition];
        *textLength = m_textLength - textPosition;
    }
    return S_OK;
}

IFACEMETHODIMP TextAnalysis::GetTextBeforePosition | ( | UINT32 | textPosition,
 |  | _Out_ WCHAR const ** | textString,
 |  | _Out_ UINT32 * | textLength
 | ) |  |

Definition at line 109 of file TextAnalysis.cpp.

{
    if (textPosition == 0 || textPosition > m_textLength)
    {
        // Return no text if a query comes for a position at the end of
        // the range. Note that is not an error and we should not return
        // a failing HRESULT. Although the application is not expected
        // to return any text that is outside of the given range, the
        // analyzers may probe the ends to see if text exists.
        *textString = nullptr;
        *textLength = 0;
    }
    else
    {
        *textString = &m_text[0];
        *textLength = textPosition - 0; // text length is valid from current position backward
    }
    return S_OK;
}

STDMETHODIMP TextAnalysis::GetVerticalGlyphOrientation | ( | UINT32 | textPosition,
 |  | _Out_ UINT32 * | textLength,
 |  | _Out_ DWRITE_VERTICAL_GLYPH_ORIENTATION * | glyphOrientation,
 |  | _Out_ UINT8 * | bidiLevel
 | ) |  |

Definition at line 175 of file TextAnalysis.cpp.

{
    SetCurrentRun(textPosition);
    const LinkedRun& run    = m_runs[m_currentRunIndex];
    *bidiLevel              = run.bidiLevel;
    *glyphOrientation       = DWRITE_VERTICAL_GLYPH_ORIENTATION_DEFAULT;

    // Find the next range where a bidi level changes.

    const size_t totalRuns = m_runs.size();
    UINT32 lastRunPosition = textPosition;
    UINT32 nextRunIndex = m_currentRunIndex;

    do
    {
        const LinkedRun& nextRun = m_runs[nextRunIndex];
        if (nextRun.bidiLevel != run.bidiLevel)
        {
            break;
        }
        lastRunPosition = nextRun.textStart + nextRun.textLength;
        nextRunIndex = nextRun.nextRunIndex;
    }
    while (nextRunIndex < totalRuns && nextRunIndex != 0);

    *textLength = lastRunPosition - textPosition;

    return S_OK;
}

TextAnalysis::IFACEMETHODIMP_ ( DWRITE_READING_DIRECTION )
IFACEMETHODIMP TextAnalysis::SetBidiLevel | ( | UINT32 | textPosition,
 |  | UINT32 | textLength,
 |  | UINT8 | explicitLevel,
 |  | UINT8 | resolvedLevel
 | ) |  |

Definition at line 250 of file TextAnalysis.cpp.

{
    try
    {
        SetCurrentRun(textPosition);
        SplitCurrentRun(textPosition);
        while (textLength > 0)
        {
            LinkedRun& run  = FetchNextRun(&textLength);
            run.bidiLevel   = resolvedLevel;
            run.isReversed  = !!(resolvedLevel & 1);
        }
    }
    catch (...)
    {
        return E_FAIL; // Unknown error, probably out of memory.
    }

    return S_OK;
}

void TextAnalysis::SetCurrentRun ( UINT32 textPosition ) [protected]

Definition at line 425 of file TextAnalysis.cpp.

{
    // Move the current run to the given position.
    // Since the analyzers generally return results in a forward manner,
    // this will usually just return early. If not, find the
    // corresponding run for the text position.
    if (m_currentRunIndex < m_runs.size()
        &&  m_runs[m_currentRunIndex].ContainsTextPosition(textPosition))
    {
        return;
    }

    m_currentRunIndex = static_cast<UINT32>(
        std::find(m_runs.begin(), m_runs.end(), textPosition)
        - m_runs.begin()
        );
}

IFACEMETHODIMP TextAnalysis::SetGlyphOrientation | ( | UINT32 | textPosition,
 |  | UINT32 | textLength,
 |  | DWRITE_GLYPH_ORIENTATION_ANGLE | glyphOrientationAngle,
 |  | UINT8 | adjustedBidiLevel,
 |  | BOOL | isSideways,
 |  | BOOL | isRightToLeft
 | ) |  |

Definition at line 300 of file TextAnalysis.cpp.

{
    try
    {
        // Mapping from angle down to small orientation.
        const static UINT8 glyphOrientations[] = {
            GlyphOrientationCW0,
            GlyphOrientationCW90,
            GlyphOrientationCW180,
            GlyphOrientationCW270,
        };

        SetCurrentRun(textPosition);
        SplitCurrentRun(textPosition);
        while (textLength > 0)
        {
            LinkedRun& run          = FetchNextRun(&textLength);
            run.glyphOrientation    = glyphOrientations[glyphOrientationAngle & 3];
            run.isSideways          = !!isSideways;
            run.isReversed          = !!isRightToLeft;
            run.bidiLevel           = adjustedBidiLevel;
        }
    }
    catch (...)
    {
        return E_FAIL; // Unknown error, probably out of memory.
    }

    return S_OK;
}

IFACEMETHODIMP TextAnalysis::SetLineBreakpoints | ( | UINT32 | textPosition,
 |  | UINT32 | textLength,
 |  | const DWRITE_LINE_BREAKPOINT * | lineBreakpoints
 | ) |  |

Definition at line 213 of file TextAnalysis.cpp.

{
    if (textLength > 0)
    {
        memcpy(&m_breakpoints[textPosition], lineBreakpoints, textLength * sizeof(lineBreakpoints[0]));
    }
    return S_OK;
}

IFACEMETHODIMP TextAnalysis::SetNumberSubstitution | ( | UINT32 | textPosition,
 |  | UINT32 | textLength,
 |  | IDWriteNumberSubstitution * | numberSubstitution
 | ) |  |

Definition at line 276 of file TextAnalysis.cpp.

{
    try
    {
        SetCurrentRun(textPosition);
        SplitCurrentRun(textPosition);
        while (textLength > 0)
        {
            LinkedRun& run          = FetchNextRun(&textLength);
            run.isNumberSubstituted = (numberSubstitution != nullptr);
        }
    }
    catch (...)
    {
        return E_FAIL; // Unknown error, probably out of memory.
    }

    return S_OK;
}

IFACEMETHODIMP TextAnalysis::SetScriptAnalysis | ( | UINT32 | textPosition,
 |  | UINT32 | textLength,
 |  | DWRITE_SCRIPT_ANALYSIS const * | scriptAnalysis
 | ) |  |

Definition at line 226 of file TextAnalysis.cpp.

{
    try
    {
        SetCurrentRun(textPosition);
        SplitCurrentRun(textPosition);
        while (textLength > 0)
        {
            LinkedRun& run  = FetchNextRun(&textLength);
            run.script      = *scriptAnalysis;
        }
    }
    catch (...)
    {
        return E_FAIL; // Unknown error, probably out of memory.
    }

    return S_OK;
}

void TextAnalysis::SplitCurrentRun ( UINT32 splitPosition ) [protected]

Definition at line 443 of file TextAnalysis.cpp.

{
    // Splits the current run and adjusts the run values accordingly.

    UINT32 runTextStart = m_runs[m_currentRunIndex].textStart;

    if (splitPosition <= runTextStart)
    {
        return; // no change
    }

    // Grow runs by one.
    size_t totalRuns = m_runs.size();
    try
    {
        m_runs.resize(totalRuns + 1);
    }
    catch (...)
    {
        return; // Can't increase size. Return same run.
    }

    // Copy the old run to the end.
    LinkedRun& frontHalf = m_runs[m_currentRunIndex];
    LinkedRun& backHalf  = m_runs.back();
    backHalf             = frontHalf;

    // Adjust runs' text positions and lengths.
    UINT32 splitPoint       = splitPosition - runTextStart;
    backHalf.textStart     += splitPoint;
    backHalf.textLength    -= splitPoint;
    frontHalf.textLength    = splitPoint;
    frontHalf.nextRunIndex  = static_cast<UINT32>(totalRuns);
    m_currentRunIndex       = static_cast<UINT32>(totalRuns);
}

Member Data Documentation

std::vector<DWRITE_LINE_BREAKPOINT> TextAnalysis::m_breakpoints [protected]

Definition at line 272 of file TextAnalysis.h.

UINT32 TextAnalysis::m_currentPosition [protected]

Definition at line 267 of file TextAnalysis.h.

UINT32 TextAnalysis::m_currentRunIndex [protected]

Definition at line 268 of file TextAnalysis.h.

GlyphOrientationMode TextAnalysis::m_glyphOrientationMode [protected]

Definition at line 264 of file TextAnalysis.h.

const wchar_t* TextAnalysis::m_localeName [protected]

Definition at line 261 of file TextAnalysis.h.

IDWriteNumberSubstitution* TextAnalysis::m_numberSubstitution [protected]

Definition at line 262 of file TextAnalysis.h.

ReadingDirection TextAnalysis::m_readingDirection [protected]

Definition at line 263 of file TextAnalysis.h.

std::vector<LinkedRun> TextAnalysis::m_runs [protected]

Definition at line 271 of file TextAnalysis.h.

const wchar_t* TextAnalysis::m_text [protected]

Definition at line 260 of file TextAnalysis.h.

UINT32 TextAnalysis::m_textLength [protected]

Definition at line 259 of file TextAnalysis.h.

The documentation for this class was generated from the following files:
  • DirectWrite vertical text/C++/TextAnalysis.h
  • DirectWrite vertical text/C++/TextAnalysis.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextAnalysis::LinkedRun Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • TextAnalysis
  • TextAnalysis::LinkedRun
Public Member Functions | Public Attributes

TextAnalysis::LinkedRun Struct Reference

#include "TextAnalysis.h"

Inherits TextAnalysis::Run.

List of all members.

Public Member Functions

LinkedRun ()

Public Attributes

UINT32 nextRunIndex

Detailed Description

Definition at line 137 of file TextAnalysis.h.

Constructor & Destructor Documentation

TextAnalysis::LinkedRun::LinkedRun ( ) [inline]

Definition at line 139 of file TextAnalysis.h.

        :   nextRunIndex(0)
        { }

Member Data Documentation

UINT32 TextAnalysis::LinkedRun::nextRunIndex

Definition at line 143 of file TextAnalysis.h.

The documentation for this struct was generated from the following file:
  • DirectWrite vertical text/C++/TextAnalysis.h
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextAnalysis::Run Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • TextAnalysis
  • TextAnalysis::Run
Public Member Functions | Public Attributes

TextAnalysis::Run Struct Reference

#include "TextAnalysis.h"

Inherited by TextAnalysis::LinkedRun.

List of all members.

Public Member Functions

Run ()
bool | ContainsTextPosition (UINT32 desiredTextPosition) const
bool | operator== (UINT32 desiredTextPosition) const

Public Attributes

UINT8 | bidiLevel
UINT32 | glyphCount
UINT8 | glyphOrientation
UINT32 | glyphStart
bool | isNumberSubstituted
bool | isReversed
bool | isSideways
DWRITE_SCRIPT_ANALYSIS | script
UINT32 | textLength
UINT32 | textStart

Detailed Description

Definition at line 97 of file TextAnalysis.h.

Constructor & Destructor Documentation

TextAnalysis::Run::Run ( ) [inline]

Definition at line 99 of file TextAnalysis.h.

        :   textStart(),
            textLength(),
            glyphStart(),
            glyphCount(),
            bidiLevel(),
            script(),
            glyphOrientation(),
            isNumberSubstituted(),
            isSideways(),
            isReversed()
        { }

Member Function Documentation

bool TextAnalysis::Run::ContainsTextPosition ( UINT32 desiredTextPosition ) const [inline]

Definition at line 123 of file TextAnalysis.h.

        {
            return desiredTextPosition >= textStart
                && desiredTextPosition <  textStart + textLength;
        }

bool TextAnalysis::Run::operator== ( UINT32 desiredTextPosition ) const [inline]

Definition at line 129 of file TextAnalysis.h.

        {
            // Allows search by text position using std::find
            return ContainsTextPosition(desiredTextPosition);
        }

Member Data Documentation

UINT8 TextAnalysis::Run::bidiLevel

Definition at line 117 of file TextAnalysis.h.

UINT32 TextAnalysis::Run::glyphCount

Definition at line 115 of file TextAnalysis.h.

UINT8 TextAnalysis::Run::glyphOrientation

Definition at line 118 of file TextAnalysis.h.

UINT32 TextAnalysis::Run::glyphStart

Definition at line 114 of file TextAnalysis.h.

bool TextAnalysis::Run::isNumberSubstituted

Definition at line 119 of file TextAnalysis.h.

bool TextAnalysis::Run::isReversed

Definition at line 121 of file TextAnalysis.h.

bool TextAnalysis::Run::isSideways

Definition at line 120 of file TextAnalysis.h.

DWRITE_SCRIPT_ANALYSIS TextAnalysis::Run::script

Definition at line 116 of file TextAnalysis.h.

UINT32 TextAnalysis::Run::textLength

Definition at line 113 of file TextAnalysis.h.

UINT32 TextAnalysis::Run::textStart

Definition at line 112 of file TextAnalysis.h.

The documentation for this struct was generated from the following file:
  • DirectWrite vertical text/C++/TextAnalysis.h
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextButton Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes

TextButton Class Reference

#include "UserInterface.h"

Inherits TextElement.

List of all members.

Public Member Functions

TextButton ()
bool | GetSelected () const
virtual void | Initialize ()
bool | IsPressed () const
virtual void | Render ()
void | SetPadding (D2D1_SIZE_F padding)
void | SetPressed (bool pressed)
void | SetSelected (bool selected)
virtual void | Update (float timeTotal, float timeDelta)

Protected Member Functions

virtual void | CalculateSize ()

Protected Attributes

D2D1_SIZE_F | m_padding
bool | m_pressed
bool | m_selected

Detailed Description

Definition at line 162 of file UserInterface.h.

Constructor & Destructor Documentation

TextButton::TextButton ( )

Definition at line 458 of file UserInterface.cpp.

                      :
    m_selected(false)
{
}

Member Function Documentation

void TextButton::CalculateSize ( ) [protected, virtual]

Reimplemented from TextElement.

Definition at line 506 of file UserInterface.cpp.

{
    TextElement::CalculateSize();
    m_textExtents.left -= m_padding.width;
    m_textExtents.top -= m_padding.height;
    m_size.width += m_padding.width * 2;
    m_size.height += m_padding.height * 2;
}

bool TextButton::GetSelected ( ) const [inline]

Definition at line 174 of file UserInterface.h.

{ return m_selected; }

void TextButton::Initialize ( ) [virtual]

Reimplemented from TextElement.

Definition at line 463 of file UserInterface.cpp.

{
    TextElement::Initialize();
}

bool TextButton::IsPressed ( ) const [inline]

Definition at line 177 of file UserInterface.h.

{ return m_pressed; }

void TextButton::Render ( ) [virtual]

Reimplemented from TextElement.

Definition at line 473 of file UserInterface.cpp.

{
    ID2D1DeviceContext* d2dContext = UserInterface::GetD2DContext();

    if (m_selected)
    {
        D2D1_RECT_F bounds = GetBounds();

        d2dContext->DrawRectangle(
            bounds,
            m_textColorBrush.Get(),
            4.0f
            );
    }

    TextElement::Render();
}

void TextButton::SetPadding ( D2D1_SIZE_F padding )

Definition at line 491 of file UserInterface.cpp.

{
    m_padding = padding;
}

void TextButton::SetPressed ( bool pressed )

Definition at line 501 of file UserInterface.cpp.

{
    m_pressed = pressed;
}

void TextButton::SetSelected ( bool selected )

Definition at line 496 of file UserInterface.cpp.

{
    m_selected = selected;
}

void TextButton::Update | ( | float | timeTotal,
 |  | float | timeDelta |
 | ) |  |  | [virtual]

Reimplemented from TextElement.

Definition at line 468 of file UserInterface.cpp.

{
    TextElement::Update(timeTotal, timeDelta);
}

Member Data Documentation

D2D1_SIZE_F TextButton::m_padding [protected]

Definition at line 182 of file UserInterface.h.

bool TextButton::m_pressed [protected]

Definition at line 184 of file UserInterface.h.

bool TextButton::m_selected [protected]

Definition at line 183 of file UserInterface.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/UserInterface.h
  • DirectX marble maze game/C++/UserInterface.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextElement Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Protected Member Functions | Protected Attributes

TextElement Class Reference

#include "UserInterface.h"

Inherits ElementBase.

Inherited by CountdownTimer, HighScoreTable, StopwatchTimer, and TextButton.

List of all members.

Public Member Functions

TextElement ()
void | FadeOut (float fadeOutTime)
TextStyle & GetTextStyle ()
virtual void | Initialize ()
virtual void | Render ()
void | SetText (Platform::String^text)
void | SetText (__nullterminated WCHAR *text)
void | SetTextColor (const D2D1_COLOR_F &textColor)
void | SetTextOpacity (float textOpacity)
virtual void | Update (float timeTotal, float timeDelta)

Protected Member Functions

virtual void | CalculateSize ()
void | CreateTextLayout ()

Protected Attributes

float | m_fadeOutTime
float | m_fadeOutTimeElapsed
float | m_fadeStartingOpacity
bool | m_isFadingOut
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_shadowColorBrush
Platform::String | m_text
Microsoft::WRL::ComPtr
< ID2D1SolidColorBrush > 		m_textColorBrush
D2D1_RECT_F | m_textExtents
Microsoft::WRL::ComPtr
< IDWriteTextLayout > 		m_textLayout
TextStyle m_textStyle

Detailed Description

Definition at line 76 of file UserInterface.h.

Constructor & Destructor Documentation

TextElement::TextElement ( )

Definition at line 179 of file UserInterface.cpp.

                        :
    m_isFadingOut(false)
{
}

Member Function Documentation

void TextElement::CalculateSize ( ) [protected, virtual]

Reimplemented from ElementBase.

Reimplemented in TextButton.

Definition at line 279 of file UserInterface.cpp.

{
    CreateTextLayout();

    DWRITE_TEXT_METRICS metrics;
    DWRITE_OVERHANG_METRICS overhangMetrics;
    DX::ThrowIfFailed(
        m_textLayout->GetMetrics(&metrics)
        );
    DX::ThrowIfFailed(
        m_textLayout->GetOverhangMetrics(&overhangMetrics)
        );

    m_textExtents = RectF(
        -overhangMetrics.left,
        -overhangMetrics.top,
        overhangMetrics.right + metrics.layoutWidth,
        overhangMetrics.bottom + metrics.layoutHeight
        );

    m_size = SizeF(
        m_textExtents.right - m_textExtents.left,
        m_textExtents.bottom - m_textExtents.top
        );
}

void TextElement::CreateTextLayout ( ) [protected]

Definition at line 305 of file UserInterface.cpp.

{
    if ((m_textLayout == nullptr) || m_textStyle.HasTextFormatChanged())
    {
        m_textLayout = nullptr;

        IDWriteFactory* dwriteFactory = UserInterface::GetDWriteFactory();

        DX::ThrowIfFailed(
            dwriteFactory->CreateTextLayout(
                m_text->Data(),
                m_text->Length(),
                m_textStyle.GetTextFormat(),
                m_container.right - m_container.left,
                m_container.bottom - m_container.top,
                &m_textLayout
                )
            );
    }
}

void TextElement::FadeOut ( float fadeOutTime )

Definition at line 271 of file UserInterface.cpp.

{
    m_fadeStartingOpacity = m_textColorBrush->GetOpacity();
    m_fadeOutTime = fadeOutTime;
    m_fadeOutTimeElapsed = 0.0f;
    m_isFadingOut = true;
}

TextStyle& TextElement::GetTextStyle ( ) [inline]

Definition at line 91 of file UserInterface.h.

{ return m_textStyle; }

void TextElement::Initialize ( ) [virtual]

Reimplemented from ElementBase.

Reimplemented in CountdownTimer, StopwatchTimer, TextButton, and HighScoreTable.

Definition at line 184 of file UserInterface.cpp.

{
    ID2D1DeviceContext* d2dContext = UserInterface::GetD2DContext();

    DX::ThrowIfFailed(
        d2dContext->CreateSolidColorBrush(
            ColorF(ColorF::White),
            &m_textColorBrush
            )
        );

    DX::ThrowIfFailed(
        d2dContext->CreateSolidColorBrush(
            ColorF(ColorF::Black),
            &m_shadowColorBrush
            )
        );
}

void TextElement::Render ( ) [virtual]

Reimplemented from ElementBase.

Reimplemented in CountdownTimer, StopwatchTimer, TextButton, and HighScoreTable.

Definition at line 220 of file UserInterface.cpp.

{
    ID2D1DeviceContext* d2dContext = UserInterface::GetD2DContext();

    D2D1_RECT_F bounds = GetBounds();
    D2D1_POINT_2F origin = Point2F(
        bounds.left - m_textExtents.left,
        bounds.top - m_textExtents.top
        );

    m_shadowColorBrush->SetOpacity(m_textColorBrush->GetOpacity() * 0.5f);

    d2dContext->DrawTextLayout(
        Point2F(origin.x + 4.0f, origin.y + 4.0f),
        m_textLayout.Get(),
        m_shadowColorBrush.Get(),
        D2D1_DRAW_TEXT_OPTIONS_NO_SNAP
        );

    d2dContext->DrawTextLayout(
        origin,
        m_textLayout.Get(),
        m_textColorBrush.Get(),
        D2D1_DRAW_TEXT_OPTIONS_NO_SNAP
        );
}

void TextElement::SetText ( __nullterminated WCHAR * text )

Definition at line 257 of file UserInterface.cpp.

{
    SetText(ref new Platform::String(text));
}

void TextElement::SetText ( Platform::String^ text )

Definition at line 262 of file UserInterface.cpp.

{
    if (!m_text->Equals(text))
    {
        m_text = text;
        m_textLayout = nullptr;
    }
}

void TextElement::SetTextColor ( const D2D1_COLOR_F & textColor )

Definition at line 247 of file UserInterface.cpp.

{
    m_textColorBrush->SetColor(textColor);
}

void TextElement::SetTextOpacity ( float textOpacity )

Definition at line 252 of file UserInterface.cpp.

{
    m_textColorBrush->SetOpacity(textOpacity);
}

void TextElement::Update | ( | float | timeTotal,
 |  | float | timeDelta |
 | ) |  |  | [virtual]

Reimplemented from ElementBase.

Reimplemented in CountdownTimer, StopwatchTimer, TextButton, and HighScoreTable.

Definition at line 203 of file UserInterface.cpp.

{
    if (m_isFadingOut)
    {
        m_fadeOutTimeElapsed += timeDelta;

        float delta = min(1.0f, m_fadeOutTimeElapsed / m_fadeOutTime);
        SetTextOpacity((1.0f - delta) * m_fadeStartingOpacity);

        if (m_fadeOutTimeElapsed >= m_fadeOutTime)
        {
            m_isFadingOut = false;
            SetVisible(false);
        }
    }
}

Member Data Documentation

float TextElement::m_fadeOutTime [protected]

Definition at line 105 of file UserInterface.h.

float TextElement::m_fadeOutTimeElapsed [protected]

Definition at line 106 of file UserInterface.h.

float TextElement::m_fadeStartingOpacity [protected]

Definition at line 104 of file UserInterface.h.

bool TextElement::m_isFadingOut [protected]

Definition at line 103 of file UserInterface.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> TextElement::m_shadowColorBrush [protected]

Definition at line 109 of file UserInterface.h.

Platform::String TextElement::m_text [protected]

Definition at line 98 of file UserInterface.h.

Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> TextElement::m_textColorBrush [protected]

Definition at line 108 of file UserInterface.h.

D2D1_RECT_F TextElement::m_textExtents [protected]

Definition at line 99 of file UserInterface.h.

Microsoft::WRL::ComPtr<IDWriteTextLayout> TextElement::m_textLayout [protected]

Definition at line 110 of file UserInterface.h.

TextStyle TextElement::m_textStyle [protected]

Definition at line 101 of file UserInterface.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/UserInterface.h
  • DirectX marble maze game/C++/UserInterface.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextFrame Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

TextFrame Class Reference

#include "TextFrame.h"

Inherits Element.

List of all members.

Public Member Functions

virtual bool | BindResource (_In_ Element^rootElement) override
virtual bool | Draw (_In_ Document^document, D2D1::Matrix3x2F const &transform) override
virtual float | GetOpacity () override
virtual bool | Initialize (_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override
virtual void | Measure (_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override
virtual bool | PrepareToDraw (_In_ Document^document, D2D1::Matrix3x2F const &transform) override

Public Attributes

internal | __pad0__: TextFrame()

Private Attributes

float | m_baseline
float | m_bottomMargin
Microsoft::WRL::ComPtr
< ID2D1Brush > 		m_brush
uint32 | m_color
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_compositeEffect
Microsoft::WRL::ComPtr
< ID2D1Bitmap1 > 		m_contentBitmap
D2D1_SIZE_F | m_displaySize
float | m_fontSize
Microsoft::WRL::ComPtr
< ID2D1Effect > 		m_glowEffect
float | m_leading
float | m_opacity
Platform::String | m_sourceName
::Text m_sourceText
DWRITE_TEXT_ALIGNMENT | m_textAlign
float | m_topMargin

Detailed Description

Definition at line 43 of file TextFrame.h.

Member Function Documentation

bool TextFrame::BindResource ( _In_ Element^ rootElement ) [override, virtual]

Reimplemented from Element.

Definition at line 179 of file TextFrame.cpp.

{
    if (rootElement != nullptr)
    {
        TreeIterator<Element> it(rootElement);

        // Traverse the tree looking for the source image
        do
        {
            ::Text^ text(dynamic_cast<::Text^>(it.GetCurrentNode()));

            if (text != nullptr && text->GetName() == m_sourceName)
            {
                m_sourceText = text;
                return true;
            }

        } while (++it);
    }

    return false;
}

bool TextFrame::Draw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 383 of file TextFrame.cpp.

{
    auto renderer = document->GetRenderer();

    ComPtr<ID2D1DeviceContext> d2dDeviceContext;
    renderer->GetD2DDeviceContext(&d2dDeviceContext);

    ComPtr<IDWriteTextLayout> textLayout;
    m_sourceText->GetTextLayout(&textLayout);

    if (m_glowEffect == nullptr || m_compositeEffect == nullptr)
    {
        d2dDeviceContext->SetTransform(transform);

        d2dDeviceContext->DrawTextLayout(
            D2D1::Point2F(m_offset.x, m_offset.y + m_topMargin),
            textLayout.Get(),
            m_brush.Get(),
            D2D1_DRAW_TEXT_OPTIONS_NONE
            );
    }
    else if (m_contentBitmap != nullptr)
    {
        // Set input bitmap for the glow effect, then set the second
        // input to the composite effect as the input bitmap to create
        // the final result where the original text is composited over
        // the glow.
        m_glowEffect->SetInput(
            0,
            m_contentBitmap.Get()
            );

        m_compositeEffect->SetInput(
            1,
            m_contentBitmap.Get()
            );

        ComPtr<ID2D1Image> image;
        m_compositeEffect->GetOutput(&image);

        // Remove the scaling factor as the local bitmap is drawn to the render target.
        d2dDeviceContext->SetTransform(
            D2D1::Matrix3x2F::Translation(
                transform._31 + transform._11 * m_offset.x,
                transform._32 + transform._22 * m_offset.y
                )
            );

        // Execute the effect graph and draw the final result onto the
        // original view target.
        d2dDeviceContext->DrawImage(
            image.Get(),
            &m_offset,
            nullptr,
            D2D1_INTERPOLATION_MODE_HIGH_QUALITY_CUBIC,
            D2D1_COMPOSITE_MODE_SOURCE_OVER
            );
    }

    return false;
}

virtual float TextFrame::GetOpacity ( ) [inline, override, virtual]

Reimplemented from Element.

Definition at line 71 of file TextFrame.h.

    {
        return m_opacity;
    }

virtual bool TextFrame::Initialize | ( | _In_ Document^ | document,
 |  | _In_ Windows::Data::Xml::Dom::XmlElement^ | xmlElement |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

void TextFrame::Measure | ( | _In_ Document^ | document,
 |  | D2D1_SIZE_F const & | parentSize,
 |  | _Out_ D2D1_RECT_F * | bounds |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 202 of file TextFrame.cpp.

{
    ComPtr<IDWriteTextLayout> textLayout;
    m_sourceText->GetTextLayout(&textLayout);

    if (m_fontSize != 0)
    {
        DWRITE_TEXT_RANGE range = {0};
        range.length = static_cast<uint32>(m_sourceText->GetLength());

        DX::ThrowIfFailed(
            textLayout->SetFontSize(m_fontSize, range)
            );
    }

    if (m_size.width <= 0 && m_size.height <= 0)
    {
        // When no size is specified, assume its parent width and height
        m_size = D2D1::SizeF(parentSize.width, parentSize.height);
    }

    D2D1_SIZE_F size = D2D1::SizeF(m_size.width, FLT_MAX);

    if (m_topMargin + m_bottomMargin < size.height)
    {
        size = D2D1::SizeF(size.width, size.height - m_topMargin - m_bottomMargin);
    }
    else
    {
        m_topMargin = m_bottomMargin = 0;
    }

    // Set layout max width and height for text
    DX::ThrowIfFailed(
        textLayout->SetMaxWidth(size.width)
        );

    DX::ThrowIfFailed(
        textLayout->SetMaxHeight(size.height)
        );

    // Set proper horizontal alignment and line spacing
    DX::ThrowIfFailed(
        textLayout->SetTextAlignment(m_textAlign)
        );

    if (m_leading != 0)
    {
        DX::ThrowIfFailed(
            textLayout->SetLineSpacing(
                DWRITE_LINE_SPACING_METHOD_UNIFORM,
                m_leading,
                m_baseline
                )
            );
    }
    else
    {
        DX::ThrowIfFailed(
            textLayout->SetLineSpacing(
                DWRITE_LINE_SPACING_METHOD_DEFAULT,
                m_leading,
                m_baseline
                )
            );
    }

    // Calculate the text layout metrics
    DWRITE_TEXT_METRICS textMetrics = {0};

    DX::ThrowIfFailed(
        textLayout->GetMetrics(&textMetrics)
        );

    // The final height is the text layout height plus top and bottom margin.
    m_size = D2D1::SizeF(textMetrics.width, textMetrics.height + m_topMargin + m_bottomMargin);

    *bounds = D2D1::RectF(
        m_offset.x,
        m_offset.y,
        m_offset.x + m_size.width,
        m_offset.y + m_size.height
        );
}

bool TextFrame::PrepareToDraw | ( | _In_ Document^ | document,
 |  | D2D1::Matrix3x2F const & | transform |
 | ) |  |  | [override, virtual]

Reimplemented from Element.

Definition at line 291 of file TextFrame.cpp.

{
    auto renderer = document->GetRenderer();

    ComPtr<ID2D1DeviceContext> d2dDeviceContext;
    renderer->GetD2DDeviceContext(&d2dDeviceContext);

    if (m_brush == nullptr)
    {
        ComPtr<ID2D1SolidColorBrush> solidColorBrush;

        DX::ThrowIfFailed(
            d2dDeviceContext->CreateSolidColorBrush(
                D2D1::ColorF(m_color, m_opacity),
                D2D1::BrushProperties(),
                &solidColorBrush
                )
            );

        m_brush = solidColorBrush;
    }

    if (    m_glowEffect != nullptr
        &&  m_compositeEffect != nullptr
        &&  (   m_contentBitmap == nullptr
            ||  m_displaySize.width != renderer->GetDisplayWidth()
            ||  m_displaySize.height != renderer->GetDisplayHeight()
            )
        )
    {
        ComPtr<IDWriteTextLayout> textLayout;
        m_sourceText->GetTextLayout(&textLayout);

        D2D1_SIZE_U bitmapPixelSize = D2D1::SizeU(
            static_cast<uint32>(transform._11 * m_size.width),
            static_cast<uint32>(transform._22 * m_size.height)
            );

        // Create intermediate bitmap as input to the effects.
        // The bitmap size is specified in pixels.
        DX::ThrowIfFailed(
            d2dDeviceContext->CreateBitmap(
                bitmapPixelSize,
                nullptr,
                0,
                D2D1::BitmapProperties1(
                    D2D1_BITMAP_OPTIONS_TARGET,
                    D2D1::PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
                    96.0,
                    96.0
                    ),
                &m_contentBitmap
                )
            );

        // Keep track of what display size the cached content is for.
        m_displaySize = renderer->GetDisplaySize();

        // Preserve pre-existing target
        ComPtr<ID2D1Image> oldTarget;

        d2dDeviceContext->GetTarget(&oldTarget);

        // Set the view target to an intermediate bitmap
        d2dDeviceContext->SetTarget(m_contentBitmap.Get());

        d2dDeviceContext->Clear(D2D1::ColorF(0, 0));

        // Only set the scale transform and leave the translation
        // as we're drawing only this element to an intermediate.
        d2dDeviceContext->SetTransform(
            D2D1::Matrix3x2F::Scale(transform._11, transform._22)
            );

        // Draw text onto an intermediate bitmap
        d2dDeviceContext->DrawTextLayout(
            D2D1::Point2F(0, m_topMargin),
            textLayout.Get(),
            m_brush.Get(),
            D2D1_DRAW_TEXT_OPTIONS_NONE
            );

        // Restore the previous target
        d2dDeviceContext->SetTarget(oldTarget.Get());
    }

    return false;
}

Member Data Documentation

internal TextFrame::__pad0__

Reimplemented from Element.

Definition at line 46 of file TextFrame.h.

float TextFrame::m_baseline [private]

Definition at line 109 of file TextFrame.h.

float TextFrame::m_bottomMargin [private]

Definition at line 103 of file TextFrame.h.

Microsoft::WRL::ComPtr<ID2D1Brush> TextFrame::m_brush [private]

Definition at line 84 of file TextFrame.h.

uint32 TextFrame::m_color [private]

Definition at line 115 of file TextFrame.h.

Microsoft::WRL::ComPtr<ID2D1Effect> TextFrame::m_compositeEffect [private]

Definition at line 90 of file TextFrame.h.

Microsoft::WRL::ComPtr<ID2D1Bitmap1> TextFrame::m_contentBitmap [private]

Definition at line 94 of file TextFrame.h.

D2D1_SIZE_F TextFrame::m_displaySize [private]

Definition at line 97 of file TextFrame.h.

float TextFrame::m_fontSize [private]

Definition at line 121 of file TextFrame.h.

Microsoft::WRL::ComPtr<ID2D1Effect> TextFrame::m_glowEffect [private]

Definition at line 87 of file TextFrame.h.

float TextFrame::m_leading [private]

Definition at line 106 of file TextFrame.h.

float TextFrame::m_opacity [private]

Definition at line 118 of file TextFrame.h.

Platform::String TextFrame::m_sourceName [private]

Definition at line 78 of file TextFrame.h.

::Text TextFrame::m_sourceText [private]

Definition at line 81 of file TextFrame.h.

DWRITE_TEXT_ALIGNMENT TextFrame::m_textAlign [private]

Definition at line 112 of file TextFrame.h.

float TextFrame::m_topMargin [private]

Definition at line 100 of file TextFrame.h.

The documentation for this class was generated from the following files:
  • Direct2D magazine app/C++/TextFrame.h
  • Direct2D magazine app/C++/TextFrame.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextInterop Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

TextInterop Class Reference

#include "TextInterop.h"

List of all members.

Public Member Functions

virtual void | CreateDeviceIndependentResources () override
virtual void | CreateDeviceResources () override
virtual void | CreateWindowSizeDependentResources () override
virtual void | Render () override
void | Update (float TimeTotal, float TimeDelta)

Public Attributes

internal | __pad0__: TextInterop()

Private Attributes

BasicCamera m_camera
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_constantBuffer
ConstantBuffer m_constantBufferData
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_indexBuffer
unsigned int | m_indexCount
Microsoft::WRL::ComPtr
< ID3D11InputLayout > 		m_inputLayout
Microsoft::WRL::ComPtr
< ID3D11PixelShader > 		m_pixelShader
SampleOverlay m_sampleOverlay
Microsoft::WRL::ComPtr
< ID3D11SamplerState > 		m_sampler
Microsoft::WRL::ComPtr
< ID3D11Texture2D > 		m_texture
Microsoft::WRL::ComPtr
< ID3D11ShaderResourceView > 		m_textureShaderResourceView
Microsoft::WRL::ComPtr
< ID3D11Buffer > 		m_vertexBuffer
Microsoft::WRL::ComPtr
< ID3D11VertexShader > 		m_vertexShader

Detailed Description

Definition at line 23 of file TextInterop.h.

Member Function Documentation

void TextInterop::CreateDeviceIndependentResources ( ) [override, virtual]

Definition at line 22 of file TextInterop.cpp.

{
    DirectXBase::CreateDeviceIndependentResources();
}

void TextInterop::CreateDeviceResources ( ) [override, virtual]

Definition at line 27 of file TextInterop.cpp.

{
    DirectXBase::CreateDeviceResources();

    m_sampleOverlay = ref new SampleOverlay();

    String^ title = "Direct3D-Direct2D interop sample";

    m_sampleOverlay->Initialize(
        m_d2dDevice.Get(),
        m_d2dContext.Get(),
        m_wicFactory.Get(),
        m_dwriteFactory.Get(),
        title
        );

    BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());

    loader->LoadShader(
        L"SimpleVertexShader.cso",
        nullptr,
        0,
        &m_vertexShader,
        &m_inputLayout
        );

    // create the vertex and index buffers for drawing the cube

    BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());

    shapes->CreateCube(
        &m_vertexBuffer,
        &m_indexBuffer,
        nullptr,
        &m_indexCount
        );

    // create the constant buffer for updating model and camera data
    CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
    DX::ThrowIfFailed(
        m_d3dDevice->CreateBuffer(
            &constantBufferDescription,
            nullptr,             // leave the buffer uninitialized
            &m_constantBuffer
            )
        );

    loader->LoadShader(
        L"SimplePixelShader.cso",
        &m_pixelShader
        );

    // Create a Direct3D texture and view, which will be used to texture a spinning cube.

    CD3D11_TEXTURE2D_DESC textureDesc(
        DXGI_FORMAT_B8G8R8A8_UNORM,
        512,        // Width
        512,        // Height
        1,          // MipLevels
        1,          // ArraySize
        D3D11_BIND_SHADER_RESOURCE | D3D11_BIND_RENDER_TARGET
        );

    DX::ThrowIfFailed(
        m_d3dDevice->CreateTexture2D(
            &textureDesc,
            nullptr,
            &m_texture
            )
        );

    CD3D11_SHADER_RESOURCE_VIEW_DESC shaderResourceViewDesc(
        m_texture.Get(),
        D3D11_SRV_DIMENSION_TEXTURE2D
        );

    DX::ThrowIfFailed(
        m_d3dDevice->CreateShaderResourceView(
            m_texture.Get(),
            &shaderResourceViewDesc,
            &m_textureShaderResourceView
            )
        );

    // Use D2D to attach to and draw some text to the cube texture.  Note that the cube
    // texture is DPI-independent, so when drawing content to it using D2D, a fixed DPI
    // value should be used.

    const float dxgiDpi = 96.0f;

    m_d2dContext->SetDpi(dxgiDpi, dxgiDpi);

    D2D1_BITMAP_PROPERTIES1 bitmapProperties =
        D2D1::BitmapProperties1(
            D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
            D2D1::PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
            dxgiDpi,
            dxgiDpi
            );

    ComPtr<ID2D1Bitmap1> cubeTextureTarget;
    ComPtr<IDXGISurface> cubeTextureSurface;
    DX::ThrowIfFailed(
        m_texture.As(&cubeTextureSurface)
        );

    DX::ThrowIfFailed(
        m_d2dContext->CreateBitmapFromDxgiSurface(
            cubeTextureSurface.Get(),
            &bitmapProperties,
            &cubeTextureTarget
            )
        );

    m_d2dContext->SetTarget(cubeTextureTarget.Get());

    ComPtr<ID2D1SolidColorBrush> whiteBrush;
    DX::ThrowIfFailed(
        m_d2dContext->CreateSolidColorBrush(
            D2D1::ColorF(D2D1::ColorF::White),
            &whiteBrush
            )
        );

    D2D1_SIZE_F renderTargetSize = m_d2dContext->GetSize();

    m_d2dContext->BeginDraw();

    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());

    m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Red));

    ComPtr<IDWriteTextFormat> textFormat;

    DX::ThrowIfFailed(
        m_dwriteFactory->CreateTextFormat(
            L"Verdana",
            nullptr,
            DWRITE_FONT_WEIGHT_LIGHT,
            DWRITE_FONT_STYLE_NORMAL,
            DWRITE_FONT_STRETCH_NORMAL,
            52,
            L"en-US", // locale
            &textFormat
            )
        );

    // Center the text horizontally.
    DX::ThrowIfFailed(
        textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
        );

    // Center the text vertically.
    DX::ThrowIfFailed(
        textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
        );

    m_d2dContext->DrawText(
        title->Data(),
        title->Length(),
        textFormat.Get(),
        D2D1::RectF(0.0f, 0.0f, renderTargetSize.width, renderTargetSize.height),
        whiteBrush.Get()
        );

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    // create the sampler
    D3D11_SAMPLER_DESC samplerDescription;
    ZeroMemory(&samplerDescription, sizeof(D3D11_SAMPLER_DESC));
    samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
    samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
    samplerDescription.MipLODBias = 0.0f;
    samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
    samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
    samplerDescription.BorderColor[0] = 0.0f;
    samplerDescription.BorderColor[1] = 0.0f;
    samplerDescription.BorderColor[2] = 0.0f;
    samplerDescription.BorderColor[3] = 0.0f;
    // allow use of all mip levels
    samplerDescription.MinLOD = 0;
    samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;

    DX::ThrowIfFailed(
        m_d3dDevice->CreateSamplerState(
            &samplerDescription,
            &m_sampler
            )
        );

    m_camera = ref new BasicCamera();
}

void TextInterop::CreateWindowSizeDependentResources ( ) [override, virtual]

Definition at line 228 of file TextInterop.cpp.

{
    DirectXBase::CreateWindowSizeDependentResources();

    // update the 3D projection matrix
    m_camera->SetProjectionParameters(
        70.0f,                                                  // use a 70-degree vertical field of view
        m_renderTargetSize.Width / m_renderTargetSize.Height,  // specify the aspect ratio of the window
        0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
        100.0f                                                  // specify the farthest Z-distance at which to draw vertices
        );

    // save the new projection matrix to the constant buffer data struct
    m_camera->GetProjectionMatrix(&m_constantBufferData.projection);

    m_sampleOverlay->UpdateForWindowSizeChange();
}

void TextInterop::Render ( ) [override, virtual]

Definition at line 246 of file TextInterop.cpp.

{
    // bind the render targets
    m_d3dContext->OMSetRenderTargets(
        1,
        m_d3dRenderTargetView.GetAddressOf(),
        m_d3dDepthStencilView.Get()
        );

    // clear both the render target and depth stencil to default values
    const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };

    m_d3dContext->ClearRenderTargetView(
        m_d3dRenderTargetView.Get(),
        ClearColor
        );

    m_d3dContext->ClearDepthStencilView(
        m_d3dDepthStencilView.Get(),
        D3D11_CLEAR_DEPTH,
        1.0f,
        0
        );

    m_d3dContext->IASetInputLayout(m_inputLayout.Get());

    // set the vertex and index buffers, and specify the way they define geometry
    UINT stride = sizeof(BasicVertex);
    UINT offset = 0;
    m_d3dContext->IASetVertexBuffers(
        0,
        1,
        m_vertexBuffer.GetAddressOf(),
        &stride,
        &offset
        );

    // set the index buffer
    m_d3dContext->IASetIndexBuffer(
        m_indexBuffer.Get(),
        DXGI_FORMAT_R16_UINT,   // unsigned short index format
        0                       // specify the base index in the buffer
        );

    // specify the way the vertex and index buffers define geometry
    m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);

    // set the vertex shader stage state
    m_d3dContext->VSSetShader(
        m_vertexShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->VSSetConstantBuffers(
        0,                              // starting at the first constant buffer slot
        1,                              // set one constant buffer binding
        m_constantBuffer.GetAddressOf()
        );

    // set the pixel shader stage state
    m_d3dContext->PSSetShader(
        m_pixelShader.Get(),
        nullptr,                // don't use shader linkage
        0                       // don't use shader linkage
        );

    m_d3dContext->PSSetShaderResources(
        0,                          // starting at the first shader resource slot
        1,                          // set one shader resource binding
        m_textureShaderResourceView.GetAddressOf()
        );

    m_d3dContext->PSSetSamplers(
        0,                          // starting at the first sampler slot
        1,                          // set one sampler binding
        m_sampler.GetAddressOf()
        );

    // draw the cube
    m_d3dContext->DrawIndexed(
        m_indexCount,   // draw all created vertices
        0,              // starting with the first vertex
        0               // and the first index
        );

    m_sampleOverlay->Render();
}

void TextInterop::Update | ( | float | TimeTotal,
 |  | float | TimeDelta
 | ) |  |

Definition at line 335 of file TextInterop.cpp.

{
    // update the model matrix based on the time
    m_constantBufferData.model = rotationY(-timeTotal * 60.0f);

    // update the view matrix based on the camera position
    // note that for this sample, the camera position is fixed
    m_camera->SetViewParameters(
        float3(0, 1.0f, 2.0f),
        float3(0, 0, 0),
        float3(0, 1, 0)
        );

    m_camera->GetViewMatrix(&m_constantBufferData.view);

    // update the constant buffer with the new data
    m_d3dContext->UpdateSubresource(
        m_constantBuffer.Get(),
        0,
        nullptr,
        &m_constantBufferData,
        0,
        0
        );
}

Member Data Documentation

internal TextInterop::__pad0__

Definition at line 26 of file TextInterop.h.

BasicCamera TextInterop::m_camera [private]

Definition at line 51 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> TextInterop::m_constantBuffer [private]

Definition at line 47 of file TextInterop.h.

ConstantBuffer TextInterop::m_constantBufferData [private]

Definition at line 50 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> TextInterop::m_indexBuffer [private]

Definition at line 41 of file TextInterop.h.

unsigned int TextInterop::m_indexCount [private]

Definition at line 49 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11InputLayout> TextInterop::m_inputLayout [private]

Definition at line 39 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11PixelShader> TextInterop::m_pixelShader [private]

Definition at line 43 of file TextInterop.h.

SampleOverlay TextInterop::m_sampleOverlay [private]

Definition at line 37 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11SamplerState> TextInterop::m_sampler [private]

Definition at line 46 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11Texture2D> TextInterop::m_texture [private]

Definition at line 44 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> TextInterop::m_textureShaderResourceView [private]

Definition at line 45 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11Buffer> TextInterop::m_vertexBuffer [private]

Definition at line 40 of file TextInterop.h.

Microsoft::WRL::ComPtr<ID3D11VertexShader> TextInterop::m_vertexShader [private]

Definition at line 42 of file TextInterop.h.

The documentation for this class was generated from the following files:
  • Direct3D-Direct2D interop/C++/TextInterop.h
  • Direct3D-Direct2D interop/C++/TextInterop.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextStyle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

TextStyle Class Reference

#include "UserInterface.h"

List of all members.

Public Member Functions

TextStyle ()
IDWriteTextFormat * | GetTextFormat ()
bool | HasTextFormatChanged ()
void | SetFontName (Platform::String^fontName)
void | SetFontSize (float fontSize)
void | SetFontStyle (DWRITE_FONT_STYLE fontStyle)
void | SetFontWeight (DWRITE_FONT_WEIGHT fontWeight)
void | SetTextAlignment (DWRITE_TEXT_ALIGNMENT textAlignment)

Private Attributes

Platform::String | m_fontName
float | m_fontSize
DWRITE_FONT_STYLE | m_fontStyle
DWRITE_FONT_WEIGHT | m_fontWeight
DWRITE_TEXT_ALIGNMENT | m_textAlignment
Microsoft::WRL::ComPtr
< IDWriteTextFormat > 		m_textFormat

Detailed Description

Definition at line 10 of file UserInterface.h.

Constructor & Destructor Documentation

TextStyle::TextStyle ( )

Definition at line 20 of file UserInterface.cpp.

{
    m_fontName = L"Segoe UI";
    m_fontSize = 24.0f;
    m_fontWeight = DWRITE_FONT_WEIGHT_NORMAL;
    m_fontStyle = DWRITE_FONT_STYLE_NORMAL;
    m_textAlignment = DWRITE_TEXT_ALIGNMENT_LEADING;
}

Member Function Documentation

IDWriteTextFormat * TextStyle::GetTextFormat ( )

Definition at line 74 of file UserInterface.cpp.

{
    if (m_textFormat == nullptr)
    {
        IDWriteFactory* dwriteFactory = UserInterface::GetDWriteFactory();

        DX::ThrowIfFailed(
            dwriteFactory->CreateTextFormat(
                m_fontName->Data(),
                nullptr,
                m_fontWeight,
                m_fontStyle,
                DWRITE_FONT_STRETCH_NORMAL,
                m_fontSize,
                L"en-US",
                &m_textFormat
                )
            );

        DX::ThrowIfFailed(
            m_textFormat->SetTextAlignment(m_textAlignment)
            );

        DX::ThrowIfFailed(
            m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
            );
    }

    return m_textFormat.Get();
}

bool TextStyle::HasTextFormatChanged ( ) [inline]

Definition at line 23 of file UserInterface.h.

{ return (m_textFormat == nullptr); }

void TextStyle::SetFontName ( Platform::String^ fontName )

Definition at line 29 of file UserInterface.cpp.

{
    if (!m_fontName->Equals(fontName))
    {
        m_fontName = fontName;
        m_textFormat = nullptr;
    }
}

void TextStyle::SetFontSize ( float fontSize )

Definition at line 38 of file UserInterface.cpp.

{
    if (m_fontSize != fontSize)
    {
        m_fontSize = fontSize;
        m_textFormat = nullptr;
    }
}

void TextStyle::SetFontStyle ( DWRITE_FONT_STYLE fontStyle )

Definition at line 56 of file UserInterface.cpp.

{
    if (m_fontStyle != fontStyle)
    {
        m_fontStyle = fontStyle;
        m_textFormat = nullptr;
    }
}

void TextStyle::SetFontWeight ( DWRITE_FONT_WEIGHT fontWeight )

Definition at line 47 of file UserInterface.cpp.

{
    if (m_fontWeight != fontWeight)
    {
        m_fontWeight = fontWeight;
        m_textFormat = nullptr;
    }
}

void TextStyle::SetTextAlignment ( DWRITE_TEXT_ALIGNMENT textAlignment )

Definition at line 65 of file UserInterface.cpp.

{
    if (m_textAlignment != textAlignment)
    {
        m_textAlignment = textAlignment;
        m_textFormat = nullptr;
    }
}

Member Data Documentation

Platform::String TextStyle::m_fontName [private]

Definition at line 26 of file UserInterface.h.

float TextStyle::m_fontSize [private]

Definition at line 27 of file UserInterface.h.

DWRITE_FONT_STYLE TextStyle::m_fontStyle [private]

Definition at line 29 of file UserInterface.h.

DWRITE_FONT_WEIGHT TextStyle::m_fontWeight [private]

Definition at line 28 of file UserInterface.h.

DWRITE_TEXT_ALIGNMENT TextStyle::m_textAlignment [private]

Definition at line 30 of file UserInterface.h.

Microsoft::WRL::ComPtr<IDWriteTextFormat> TextStyle::m_textFormat [private]

Definition at line 32 of file UserInterface.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/UserInterface.h
  • DirectX marble maze game/C++/UserInterface.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TextureLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

TextureLock Class Reference

#include "TextureLock.h"

List of all members.

Public Member Functions

TextureLock (ID3D11DeviceContext *pContext, ID3D11Texture2D *pTex)
TextureLock (ID3D11DeviceContext *pContext, ID3D11Texture2D *pTex)
~TextureLock ()
~TextureLock ()
HRESULT | Map (UINT uiIndex, D3D11_MAP mapType, UINT mapFlags)
HRESULT | Map (UINT uiIndex, D3D11_MAP mapType, UINT mapFlags)

Public Attributes

D3D11_MAPPED_SUBRESOURCE | map

Private Attributes

bool | _bLocked
ComPtr< ID3D11DeviceContext > | _pContext
ComPtr< ID3D11Texture2D > | _pTex
UINT | _uiIndex

Detailed Description

Definition at line 8 of file TextureLock.h.

Constructor & Destructor Documentation

TextureLock::TextureLock | ( | ID3D11DeviceContext * | pContext,
 |  | ID3D11Texture2D * | pTex |
 | ) |  |  | [inline]

Definition at line 11 of file TextureLock.h.

: _pTex(pTex), _pContext(pContext), _bLocked(false) {}

TextureLock::~TextureLock ( ) [inline]

Definition at line 13 of file TextureLock.h.

  {
    assert(_pContext);
    assert(_pTex);
    if (_pTex && _bLocked)
    {

      _pContext->Unmap(_pTex.Get(), _uiIndex);
      _bLocked = false;
    }
  }

TextureLock::TextureLock | ( | ID3D11DeviceContext * | pContext,
 |  | ID3D11Texture2D * | pTex |
 | ) |  |  | [inline]

Definition at line 11 of file TextureLock.h.

: _pTex(pTex), _pContext(pContext), _bLocked(false) {}

TextureLock::~TextureLock ( ) [inline]

Definition at line 13 of file TextureLock.h.

  {
    assert(_pContext);
    assert(_pTex);
    if (_pTex && _bLocked)
    {

      _pContext->Unmap(_pTex.Get(), _uiIndex);
      _bLocked = false;
    }
  }

Member Function Documentation

HRESULT TextureLock::Map | ( | UINT | uiIndex,
 |  | D3D11_MAP | mapType,
 |  | UINT | mapFlags |
 | ) |  |  | [inline]

Definition at line 25 of file TextureLock.h.

  {
    HRESULT hr = S_OK;
    assert(_pTex);
    assert(_pContext);
    assert(!_bLocked);

    hr = _pContext->Map(_pTex.Get(), uiIndex, mapType, mapFlags, &map);
    _bLocked = SUCCEEDED(hr);
    _uiIndex = uiIndex;
    return hr;
  }

HRESULT TextureLock::Map | ( | UINT | uiIndex,
 |  | D3D11_MAP | mapType,
 |  | UINT | mapFlags |
 | ) |  |  | [inline]

Definition at line 25 of file TextureLock.h.

  {
    HRESULT hr = S_OK;
    assert(_pTex);
    assert(_pContext);
    assert(!_bLocked);

    hr = _pContext->Map(_pTex.Get(), uiIndex, mapType, mapFlags, &map);
    _bLocked = SUCCEEDED(hr);
    _uiIndex = uiIndex;
    return hr;
  }

Member Data Documentation

bool TextureLock::_bLocked [private]

Definition at line 44 of file TextureLock.h.

ComPtr< ID3D11DeviceContext > TextureLock::_pContext [private]

Definition at line 42 of file TextureLock.h.

ComPtr< ID3D11Texture2D > TextureLock::_pTex [private]

Definition at line 41 of file TextureLock.h.

UINT TextureLock::_uiIndex [private]

Definition at line 43 of file TextureLock.h.

D3D11_MAPPED_SUBRESOURCE TextureLock::map

Definition at line 38 of file TextureLock.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Invert/TextureLock.h
  • Media extensions/C++/MediaExtensions/Invert/TextureLock.h
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TGA_EXTENSION Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TGA_EXTENSION Struct Reference

List of all members.

Public Attributes

uint8_t | bAttributesType
uint8_t | bVersionLetter
uint32_t | dwColorOffset
uint32_t | dwKeyColor
uint32_t | dwScanOffset
uint32_t | dwStampOffset
char | szAuthorComment [324]
char | szAuthorName [41]
char | szJobName [41]
char | szSoftwareId [41]
uint16_t | wGammaDenominator
uint16_t | wGammaNumerator
uint16_t | wJobHour
uint16_t | wJobMinute
uint16_t | wJobSecond
uint16_t | wPixelDenominator
uint16_t | wPixelNumerator
uint16_t | wSize
uint16_t | wStampDay
uint16_t | wStampHour
uint16_t | wStampMinute
uint16_t | wStampMonth
uint16_t | wStampSecond
uint16_t | wStampYear
uint16_t | wVersionNumber

Detailed Description

Definition at line 69 of file DirectXTexTGA.cpp.

Member Data Documentation

uint8_t TGA_EXTENSION::bAttributesType

Definition at line 95 of file DirectXTexTGA.cpp.

uint8_t TGA_EXTENSION::bVersionLetter

Definition at line 86 of file DirectXTexTGA.cpp.

uint32_t TGA_EXTENSION::dwColorOffset

Definition at line 92 of file DirectXTexTGA.cpp.

uint32_t TGA_EXTENSION::dwKeyColor

Definition at line 87 of file DirectXTexTGA.cpp.

uint32_t TGA_EXTENSION::dwScanOffset

Definition at line 94 of file DirectXTexTGA.cpp.

uint32_t TGA_EXTENSION::dwStampOffset

Definition at line 93 of file DirectXTexTGA.cpp.

char TGA_EXTENSION::szAuthorComment[324]

Definition at line 73 of file DirectXTexTGA.cpp.

char TGA_EXTENSION::szAuthorName[41]

Definition at line 72 of file DirectXTexTGA.cpp.

char TGA_EXTENSION::szJobName[41]

Definition at line 80 of file DirectXTexTGA.cpp.

char TGA_EXTENSION::szSoftwareId[41]

Definition at line 84 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wGammaDenominator

Definition at line 91 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wGammaNumerator

Definition at line 90 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wJobHour

Definition at line 81 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wJobMinute

Definition at line 82 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wJobSecond

Definition at line 83 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wPixelDenominator

Definition at line 89 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wPixelNumerator

Definition at line 88 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wSize

Definition at line 71 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wStampDay

Definition at line 75 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wStampHour

Definition at line 77 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wStampMinute

Definition at line 78 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wStampMonth

Definition at line 74 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wStampSecond

Definition at line 79 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wStampYear

Definition at line 76 of file DirectXTexTGA.cpp.

uint16_t TGA_EXTENSION::wVersionNumber

Definition at line 85 of file DirectXTexTGA.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTexTGA.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TGA_FOOTER Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TGA_FOOTER Struct Reference

List of all members.

Public Attributes

uint16_t | dwDeveloperOffset
uint16_t | dwExtensionOffset
char | Signature [18]

Detailed Description

Definition at line 62 of file DirectXTexTGA.cpp.

Member Data Documentation

uint16_t TGA_FOOTER::dwDeveloperOffset

Definition at line 65 of file DirectXTexTGA.cpp.

uint16_t TGA_FOOTER::dwExtensionOffset

Definition at line 64 of file DirectXTexTGA.cpp.

char TGA_FOOTER::Signature[18]

Definition at line 66 of file DirectXTexTGA.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTexTGA.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TGA_HEADER Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

TGA_HEADER Struct Reference

List of all members.

Public Attributes

uint8_t | bBitsPerPixel
uint8_t | bColorMapSize
uint8_t | bColorMapType
uint8_t | bDescriptor
uint8_t | bIDLength
uint8_t | bImageType
uint16_t | wColorMapFirst
uint16_t | wColorMapLength
uint16_t | wHeight
uint16_t | wWidth
uint16_t | wXOrigin
uint16_t | wYOrigin

Detailed Description

Definition at line 46 of file DirectXTexTGA.cpp.

Member Data Documentation

uint8_t TGA_HEADER::bBitsPerPixel

Definition at line 58 of file DirectXTexTGA.cpp.

uint8_t TGA_HEADER::bColorMapSize

Definition at line 53 of file DirectXTexTGA.cpp.

uint8_t TGA_HEADER::bColorMapType

Definition at line 49 of file DirectXTexTGA.cpp.

uint8_t TGA_HEADER::bDescriptor

Definition at line 59 of file DirectXTexTGA.cpp.

uint8_t TGA_HEADER::bIDLength

Definition at line 48 of file DirectXTexTGA.cpp.

uint8_t TGA_HEADER::bImageType

Definition at line 50 of file DirectXTexTGA.cpp.

uint16_t TGA_HEADER::wColorMapFirst

Definition at line 51 of file DirectXTexTGA.cpp.

uint16_t TGA_HEADER::wColorMapLength

Definition at line 52 of file DirectXTexTGA.cpp.

uint16_t TGA_HEADER::wHeight

Definition at line 57 of file DirectXTexTGA.cpp.

uint16_t TGA_HEADER::wWidth

Definition at line 56 of file DirectXTexTGA.cpp.

uint16_t TGA_HEADER::wXOrigin

Definition at line 54 of file DirectXTexTGA.cpp.

uint16_t TGA_HEADER::wYOrigin

Definition at line 55 of file DirectXTexTGA.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTexTGA.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ToastsSampleCPP::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • ToastsSampleCPP
  • ToastsSampleCPP::sealed
Public Member Functions | Protected Member Functions | Properties | Private Member Functions | Private Attributes

ToastsSampleCPP::sealed Class Reference

#include "App.xaml.h"

List of all members.

Public Member Functions

App ()
String | ConvertResolution (ResolutionScale scale)
String | ConvertViewState (ApplicationViewState state)
void | DoNavigation (TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame)
MainPage ()
MainPageAndContext (ToastsSampleCPP::MainPage^mainPage, Platform::String^toastContext)
void | NotifyUser (String^strMessage, NotifyType type)
virtual void | OnLaunched (Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override
virtual void | OnSuspending (Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs)
ScenarioInput1 ()
ScenarioInput2 ()
ScenarioInput3 ()
ScenarioInput4 ()
ScenarioInput5 ()
ScenarioInput6 ()
ScenarioList ()
ScenarioOutput1 ()
ScenarioOutput2 ()
ScenarioOutput3 ()
ScenarioOutput4 ()
ScenarioOutput5 ()
ScenarioOutput6 ()

Protected Member Functions

virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedFrom (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
virtual void | OnNavigatedTo (Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override
void | Scenarios_SelectionChanged (Object^sender, SelectionChangedEventArgs^e)

Properties

event
Windows::Foundation::EventHandler
< Platform::Object^> 		OutputFrameLoaded

Private Member Functions

~MainPage ()
~ScenarioInput1 ()
~ScenarioInput2 ()
~ScenarioInput3 ()
~ScenarioInput4 ()
~ScenarioInput5 ()
~ScenarioInput6 ()
~ScenarioList ()
~ScenarioOutput1 ()
~ScenarioOutput2 ()
~ScenarioOutput3 ()
~ScenarioOutput4 ()
~ScenarioOutput5 ()
~ScenarioOutput6 ()
void | CheckResolutionAndViewState ()
void | CheckResolutionAndViewState ()
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | DisplayProperties_LogicalDpiChanged (Object^sender)
void | Footer_Click (Object^sender, RoutedEventArgs^e)
void | inputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | outputFrameNavigated (Object^sender, NavigationEventArgs^e)
void | OutputText (Platform::String^text)
void | OutputText (Platform::String^text)
void | OutputText (Platform::String^text)
void | OutputText (Platform::String^text)
void | OutputText (Platform::String^text)
void | OutputText (Platform::String^text)
void | Page_Loaded (Object^sender, RoutedEventArgs^e)
void | Page_Loaded (Object^sender, RoutedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | Page_SizeChanged (Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_InputFrameLoaded (Object^sender, Object^e)
void | rootPage_OutputFrameLoaded (Object^sender, Object^e)
void | Scenario1DisplayToast (Windows::UI::Notifications::ToastTemplateType templateType)
void | Scenario1DisplayToastWithStringManipulation (Windows::UI::Notifications::ToastTemplateType templateType)
void | Scenario2DisplayToast (Windows::UI::Notifications::ToastTemplateType templateType)
void | Scenario2DisplayToastWithStringManipulation (Windows::UI::Notifications::ToastTemplateType templateType)
void | Scenario3DisplayToast (Windows::UI::Notifications::ToastTemplateType templateType)
void | Scenario3DisplayToastWithStringManipulation (Windows::UI::Notifications::ToastTemplateType templateType)
void | Scenario4DisplayToastWithSound (NotificationsExtensions::ToastContent::ToastAudioContent audioContent, Platform::String^audioSrc)
void | Scenario4DisplayToastWithSoundWithStringManipulation (NotificationsExtensions::ToastContent::ToastAudioContent audioContent, Platform::String^audioSrc)
void | Scenario5DisplayToastWithCallbacks_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario5HideToast_Click (Object^sender, Windows::UI::Xaml::RoutedEventArgs^e)
void | Scenario6DisplayLongToast (bool loopAudio)
void | Scenario6DisplayLongToastWithStringManipulation (bool loopAudio)
void | SetFeatureName (Platform::String^strFeature)
void | toast_Dismissed (Windows::UI::Notifications::ToastNotification^sender, Windows::UI::Notifications::ToastDismissedEventArgs^e)
void | toast_Failed (Windows::UI::Notifications::ToastNotification^sender, Windows::UI::Notifications::ToastFailedEventArgs^e)

Private Attributes

Windows::Foundation::EventRegistrationToken | _displayHandlerToken
Windows::Foundation::EventRegistrationToken | _frameLoadedToken
Windows::UI::Xaml::Controls::Frame | _inputFrame
Windows::Foundation::EventRegistrationToken | _inputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _layoutHandlerToken
Windows::Foundation::EventRegistrationToken | _logicalDpiChangedToken
Windows::UI::Xaml::Controls::Frame | _outputFrame
Windows::Foundation::EventRegistrationToken | _outputFrameLoadedToken
Windows::Foundation::EventRegistrationToken | _pageLoadedHandlerToken
Windows::UI::Xaml::Controls::Frame | _scenariosFrame
Windows::UI::Notifications::ToastNotification | _toast
Platform::String | _toastContext
Windows::UI::Core::CoreDispatcher | dispatcher
Windows::UI::Xaml::Controls::TextBlock | outputText
MainPage | rootPage
Platform::String | toastContext

Detailed Description

Definition at line 21 of file App.xaml.h.

Constructor & Destructor Documentation

ToastsSampleCPP::sealed::~MainPage ( ) [private]
ToastsSampleCPP::sealed::~ScenarioInput1 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioInput2 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioInput3 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioInput4 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioInput5 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioInput6 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioList ( ) [private]
ToastsSampleCPP::sealed::~ScenarioOutput1 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioOutput2 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioOutput3 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioOutput4 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioOutput5 ( ) [private]
ToastsSampleCPP::sealed::~ScenarioOutput6 ( ) [private]

Member Function Documentation

ToastsSampleCPP::sealed::App ( )
void ToastsSampleCPP::sealed::CheckResolutionAndViewState ( ) [private]
void ToastsSampleCPP::sealed::CheckResolutionAndViewState ( ) [private]
String ToastsSampleCPP::sealed::ConvertResolution ( ResolutionScale scale )
String ToastsSampleCPP::sealed::ConvertViewState ( ApplicationViewState state )
void ToastsSampleCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void ToastsSampleCPP::sealed::DisplayProperties_LogicalDpiChanged ( Object^ sender ) [private]
void ToastsSampleCPP::sealed::DoNavigation | ( | TypeName | pageType,
 |  | Windows::UI::Xaml::Controls::Frame^ | frame
 | ) |  |
void ToastsSampleCPP::sealed::Footer_Click | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::inputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
ToastsSampleCPP::sealed::MainPage ( )
ToastsSampleCPP::sealed::MainPageAndContext | ( | ToastsSampleCPP::MainPage^ | mainPage,
 |  | Platform::String^ | toastContext |
 | ) |  |  | [inline]

Definition at line 94 of file MainPage.xaml.h.

        {
            _mainPage = mainPage;
            _toastContext = toastContext;
        }

void ToastsSampleCPP::sealed::NotifyUser | ( | String^ | strMessage,
 |  | NotifyType | type
 | ) |  |
virtual void ToastsSampleCPP::sealed::OnLaunched ( Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args ) [override, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedFrom ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnNavigatedTo ( Windows::UI::Xaml::Navigation::NavigationEventArgs^ e ) [override, protected, virtual]
virtual void ToastsSampleCPP::sealed::OnSuspending | ( | Platform::Object^ | sender,
 |  | Windows::ApplicationModel::SuspendingEventArgs^ | pArgs |
 | ) |  |  | [virtual]
void ToastsSampleCPP::sealed::outputFrameNavigated | ( | Object^ | sender,
 |  | NavigationEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::OutputText ( Platform::String^ text ) [private]
void ToastsSampleCPP::sealed::OutputText ( Platform::String^ text ) [private]
void ToastsSampleCPP::sealed::OutputText ( Platform::String^ text ) [private]
void ToastsSampleCPP::sealed::OutputText ( Platform::String^ text ) [private]
void ToastsSampleCPP::sealed::OutputText ( Platform::String^ text ) [private]
void ToastsSampleCPP::sealed::OutputText ( Platform::String^ text ) [private]
void ToastsSampleCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::Page_Loaded | ( | Object^ | sender,
 |  | RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::Page_SizeChanged | ( | Platform::Object^ | sender,
 |  | Windows::UI::Core::WindowSizeChangedEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::rootPage_InputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::rootPage_OutputFrameLoaded | ( | Object^ | sender,
 |  | Object^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::Scenario1DisplayToast ( Windows::UI::Notifications::ToastTemplateType templateType ) [private]
void ToastsSampleCPP::sealed::Scenario1DisplayToastWithStringManipulation ( Windows::UI::Notifications::ToastTemplateType templateType ) [private]
void ToastsSampleCPP::sealed::Scenario2DisplayToast ( Windows::UI::Notifications::ToastTemplateType templateType ) [private]
void ToastsSampleCPP::sealed::Scenario2DisplayToastWithStringManipulation ( Windows::UI::Notifications::ToastTemplateType templateType ) [private]
void ToastsSampleCPP::sealed::Scenario3DisplayToast ( Windows::UI::Notifications::ToastTemplateType templateType ) [private]
void ToastsSampleCPP::sealed::Scenario3DisplayToastWithStringManipulation ( Windows::UI::Notifications::ToastTemplateType templateType ) [private]
void ToastsSampleCPP::sealed::Scenario4DisplayToastWithSound | ( | NotificationsExtensions::ToastContent::ToastAudioContent | audioContent,
 |  | Platform::String^ | audioSrc |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::Scenario4DisplayToastWithSoundWithStringManipulation | ( | NotificationsExtensions::ToastContent::ToastAudioContent | audioContent,
 |  | Platform::String^ | audioSrc |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::Scenario5DisplayToastWithCallbacks_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::Scenario5HideToast_Click | ( | Object^ | sender,
 |  | Windows::UI::Xaml::RoutedEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::Scenario6DisplayLongToast ( bool loopAudio ) [private]
void ToastsSampleCPP::sealed::Scenario6DisplayLongToastWithStringManipulation ( bool loopAudio ) [private]
ToastsSampleCPP::sealed::ScenarioInput1 ( )
ToastsSampleCPP::sealed::ScenarioInput2 ( )
ToastsSampleCPP::sealed::ScenarioInput3 ( )
ToastsSampleCPP::sealed::ScenarioInput4 ( )
ToastsSampleCPP::sealed::ScenarioInput5 ( )
ToastsSampleCPP::sealed::ScenarioInput6 ( )
ToastsSampleCPP::sealed::ScenarioList ( )
ToastsSampleCPP::sealed::ScenarioOutput1 ( )
ToastsSampleCPP::sealed::ScenarioOutput2 ( )
ToastsSampleCPP::sealed::ScenarioOutput3 ( )
ToastsSampleCPP::sealed::ScenarioOutput4 ( )
ToastsSampleCPP::sealed::ScenarioOutput5 ( )
ToastsSampleCPP::sealed::ScenarioOutput6 ( )
void ToastsSampleCPP::sealed::Scenarios_SelectionChanged | ( | Object^ | sender,
 |  | SelectionChangedEventArgs^ | e |
 | ) |  |  | [protected]
void ToastsSampleCPP::sealed::SetFeatureName ( Platform::String^ strFeature ) [private]
void ToastsSampleCPP::sealed::toast_Dismissed | ( | Windows::UI::Notifications::ToastNotification^ | sender,
 |  | Windows::UI::Notifications::ToastDismissedEventArgs^ | e |
 | ) |  |  | [private]
void ToastsSampleCPP::sealed::toast_Failed | ( | Windows::UI::Notifications::ToastNotification^ | sender,
 |  | Windows::UI::Notifications::ToastFailedEventArgs^ | e |
 | ) |  |  | [private]

Member Data Documentation

Windows::Foundation::EventRegistrationToken ToastsSampleCPP::sealed::_displayHandlerToken [private]

Definition at line 73 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken sealed::_frameLoadedToken [private]

Definition at line 44 of file ScenarioInput5.xaml.h.

Windows::UI::Xaml::Controls::Frame ToastsSampleCPP::sealed::_inputFrame [private]

Definition at line 70 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ToastsSampleCPP::sealed::_inputFrameLoadedToken [private]

Definition at line 77 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ToastsSampleCPP::sealed::_layoutHandlerToken [private]

Definition at line 74 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ToastsSampleCPP::sealed::_logicalDpiChangedToken [private]

Definition at line 76 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame ToastsSampleCPP::sealed::_outputFrame [private]

Definition at line 71 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ToastsSampleCPP::sealed::_outputFrameLoadedToken [private]

Definition at line 78 of file MainPage.xaml.h.

Windows::Foundation::EventRegistrationToken ToastsSampleCPP::sealed::_pageLoadedHandlerToken [private]

Definition at line 75 of file MainPage.xaml.h.

Windows::UI::Xaml::Controls::Frame ToastsSampleCPP::sealed::_scenariosFrame [private]

Definition at line 69 of file MainPage.xaml.h.

Windows::UI::Notifications::ToastNotification ToastsSampleCPP::sealed::_toast [private]

Definition at line 49 of file ScenarioInput5.xaml.h.

Platform::String sealed::_toastContext [private]

Definition at line 87 of file MainPage.xaml.h.

Windows::UI::Core::CoreDispatcher ToastsSampleCPP::sealed::dispatcher [private]

Definition at line 46 of file ScenarioInput5.xaml.h.

Windows::UI::Xaml::Controls::TextBlock sealed::outputText [private]

Definition at line 40 of file ScenarioInput1.xaml.h.

MainPage sealed::rootPage [private]

Definition at line 35 of file ScenarioInput1.xaml.h.

Platform::String ToastsSampleCPP::sealed::toastContext [private]

Definition at line 47 of file ScenarioInput5.xaml.h.

Property Documentation

event Windows::Foundation::EventHandler<Platform::Object^> ToastsSampleCPP::sealed::OutputFrameLoaded

Definition at line 55 of file MainPage.xaml.h.

The documentation for this class was generated from the following files:
  • Toast notifications/C#,C++/App.xaml.h
  • Toast notifications/C#,C++/MainPage.xaml.h
  • Toast notifications/C#,C++/ScenarioInput1.xaml.h
  • Toast notifications/C#,C++/ScenarioInput2.xaml.h
  • Toast notifications/C#,C++/ScenarioInput3.xaml.h
  • Toast notifications/C#,C++/ScenarioInput4.xaml.h
  • Toast notifications/C#,C++/ScenarioInput5.xaml.h
  • Toast notifications/C#,C++/ScenarioInput6.xaml.h
  • Toast notifications/C#,C++/ScenarioList.xaml.h
  • Toast notifications/C#,C++/ScenarioOutput1.xaml.h
  • Toast notifications/C#,C++/ScenarioOutput2.xaml.h
  • Toast notifications/C#,C++/ScenarioOutput3.xaml.h
  • Toast notifications/C#,C++/ScenarioOutput4.xaml.h
  • Toast notifications/C#,C++/ScenarioOutput5.xaml.h
  • Toast notifications/C#,C++/ScenarioOutput6.xaml.h
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TreeIterator< T > Class Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

TreeIterator< T > Class Template Reference

#include "TreeIterator.h"

List of all members.

Public Member Functions

TreeIterator (T^rootNode)
T | GetCurrentNode ()
size_t | operator++ ()

Private Attributes

T | m_currentNode

Detailed Description

template<typename T>
class TreeIterator< T >

Definition at line 11 of file TreeIterator.h.

Constructor & Destructor Documentation

template<typename T>
TreeIterator< T >::TreeIterator ( T^ rootNode ) [inline]

Definition at line 14 of file TreeIterator.h.

        : m_currentNode(rootNode)
    {}

Member Function Documentation

template<typename T>
T TreeIterator< T >::GetCurrentNode ( ) [inline]

Definition at line 18 of file TreeIterator.h.

    {
        return m_currentNode;
    }

template<typename T>
size_t TreeIterator< T >::operator++ ( ) [inline]

Definition at line 23 of file TreeIterator.h.

    {
        if (m_currentNode == nullptr)
        {
            return 0;
        }

        T^ nextNode = m_currentNode->GetFirstChild();

        if (nextNode != nullptr)
        {
            // Go to the first child if exists.
            m_currentNode = nextNode;
        }
        else
        {
            nextNode = m_currentNode->GetNextSibling();

            if (nextNode != nullptr)
            {
                // It's a leaf node, go to the next sibling.
                m_currentNode = nextNode;
            }
            else
            {
                // It's the last leaf node, find a parent with a sibling
                // and go to that sibling.
                T^ node = m_currentNode;

                do
                {
                    node = node->GetParent();

                    if (node == nullptr)
                    {
                        return 0;
                    }

                    nextNode = node->GetNextSibling();

                } while (nextNode == nullptr);

                m_currentNode = nextNode;
            }
        }

        return 1;
    }

Member Data Documentation

template<typename T>
T TreeIterator< T >::m_currentNode [private]

Definition at line 74 of file TreeIterator.h.

The documentation for this class was generated from the following file:
  • Direct2D magazine app/C++/TreeIterator.h
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Triangle Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Triangle Class Reference

#include "Primitives.h"

List of all members.

Public Member Functions

Triangle (const Triangle &rhs)
Triangle (const XMFLOAT3 &V0, const XMFLOAT3 &V1, const XMFLOAT3 &V2)
FORCEINLINE void | CheckSharesVertsOrCoplanar (FXMVECTOR V0, FXMVECTOR V1, FXMVECTOR V2, CXMVECTOR planeIn, BOOL &sharesEdgeOut, BOOL &coplanar) const
FORCEINLINE BOOL | IsDegenerate () const
FORCEINLINE XMVECTOR | Normal () const

Public Attributes

XMFLOAT3 | A
XMFLOAT3 | B
XMFLOAT3 | C
XMFLOAT4 | plane

Detailed Description

Definition at line 10 of file Primitives.h.

Constructor & Destructor Documentation

Triangle::Triangle ( const Triangle & rhs ) [inline]

Definition at line 18 of file Primitives.h.

    {
        A = rhs.A;
        B = rhs.B;
        C = rhs.C;
        plane = rhs.plane;
    }

Triangle::Triangle | ( | const XMFLOAT3 & | V0,
 |  | const XMFLOAT3 & | V1,
 |  | const XMFLOAT3 & | V2 |
 | ) |  |  | [inline]

Definition at line 26 of file Primitives.h.

                                                                         :
        A(V0),
        B(V1),
        C(V2)
    {
        XMStoreFloat4(&plane, XMPlaneFromPoints(XMLoadFloat3(&V0), XMLoadFloat3(&V1), XMLoadFloat3(&V2)));
    }

Member Function Documentation

FORCEINLINE void Triangle::CheckSharesVertsOrCoplanar | ( | FXMVECTOR | V0,
 |  | FXMVECTOR | V1,
 |  | FXMVECTOR | V2,
 |  | CXMVECTOR | planeIn,
 |  | BOOL & | sharesEdgeOut,
 |  | BOOL & | coplanar |
 | ) |  |  | const [inline]

Definition at line 42 of file Primitives.h.

    {
        const XMVECTOR VA = XMLoadFloat3(&A);
        XMVECTOR sharesEdge = XMVectorOrInt(
            XMVectorOrInt(
                XMVectorEqual(V0, VA),
                XMVectorEqual(V1, VA)
                ),
            XMVectorEqual(V2, VA)
            );
        const XMVECTOR VB = XMLoadFloat3(&B);
        sharesEdge = XMVectorOrInt(
            sharesEdge,
            XMVectorOrInt(
                XMVectorOrInt(
                    XMVectorEqual(V0, VB),
                    XMVectorEqual(V1, VB)
                    ),
                XMVectorEqual(V2, VB)
                )
            );
        const XMVECTOR VC = XMLoadFloat3(&C);
        sharesEdge = XMVectorOrInt(
            sharesEdge,
            XMVectorOrInt(
                XMVectorOrInt(
                    XMVectorEqual(V0, VC),
                    XMVectorEqual(V1, VC)
                    ),
                XMVectorEqual(V2, VC)
                )
            );

        sharesEdgeOut = XMVector3EqualInt(sharesEdge, XMVectorTrueInt());

        const XMVECTOR VP = XMLoadFloat3((XMFLOAT3*)&plane);
        coplanar = XMVector3Equal(VP, planeIn);
    }

FORCEINLINE BOOL Triangle::IsDegenerate ( ) const [inline]

Definition at line 35 of file Primitives.h.

    {
        XMVECTOR planeNormal = XMLoadFloat3((XMFLOAT3*)&plane);
        return XMVector3Equal(planeNormal, XMVectorZero());
    }

FORCEINLINE XMVECTOR Triangle::Normal ( ) const [inline]

Definition at line 89 of file Primitives.h.

    {
        return XMLoadFloat3((XMFLOAT3*)&plane);
    }

Member Data Documentation

XMFLOAT3 Triangle::A

Definition at line 13 of file Primitives.h.

XMFLOAT3 Triangle::B

Definition at line 14 of file Primitives.h.

XMFLOAT3 Triangle::C

Definition at line 15 of file Primitives.h.

XMFLOAT4 Triangle::plane

Definition at line 16 of file Primitives.h.

The documentation for this class was generated from the following file:
  • DirectX marble maze game/C++/Primitives.h
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TriColorValueHelper Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Static Public Member Functions

TriColorValueHelper Class Reference

#include "TriColorValue.h"

List of all members.

Static Public Member Functions

static bool | IsFirst (TriColorValue value)
static bool | IsLast (TriColorValue value)
static TriColorValue | NextValue (TriColorValue value)
static TriColorValue | PreviousValue (TriColorValue value)
static HRESULT | ValueToString (TriColorValue value, _Out_ BSTR *pszValue)

Detailed Description

Definition at line 17 of file TriColorValue.h.

Member Function Documentation

static bool TriColorValueHelper::IsFirst ( TriColorValue value ) [inline, static]

Definition at line 20 of file TriColorValue.h.

    {
        return (value == TriColorValue::Red);
    }

static bool TriColorValueHelper::IsLast ( TriColorValue value ) [inline, static]

Definition at line 25 of file TriColorValue.h.

    {
        return (value == TriColorValue::Green);
    }

static TriColorValue TriColorValueHelper::NextValue ( TriColorValue value ) [inline, static]

Definition at line 30 of file TriColorValue.h.

    {
        return (TriColorValue)((int)value + 1);
    }

static TriColorValue TriColorValueHelper::PreviousValue ( TriColorValue value ) [inline, static]

Definition at line 35 of file TriColorValue.h.

    {
        return (TriColorValue)((int)value - 1);
    }

static HRESULT TriColorValueHelper::ValueToString | ( | TriColorValue | value,
 |  | _Out_ BSTR * | pszValue |
 | ) |  |  | [inline, static]

Definition at line 40 of file TriColorValue.h.

    {
        switch (value)
        {
        case TriColorValue::Red: *pszValue = SysAllocString(L"Red"); break;
        case TriColorValue::Green: *pszValue = SysAllocString(L"Green"); break;
        case TriColorValue::Yellow: *pszValue = SysAllocString(L"Yellow"); break;
        default: *pszValue = SysAllocString(L"Unknown Value"); break;
        }
        return (*pszValue != nullptr) ? S_OK : E_OUTOFMEMORY;
    }

The documentation for this class was generated from the following file:
  • UI Automation core window provider/C++/TriColorValue.h
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TripOptimizerComponent::Details::TripOptimizerImpl Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • TripOptimizerComponent
  • Details
  • TripOptimizerComponent::Details::TripOptimizerImpl
Classes | Public Member Functions | Private Member Functions | Private Attributes

TripOptimizerComponent::Details::TripOptimizerImpl Class Reference

#include "TripOptimizerImpl.h"

List of all members.

Classes

struct | OptimizeTripParams

Public Member Functions

Windows::Foundation::IAsyncOperationWithProgress
< Windows::Foundation::Collections::IMap
< Platform::String^,
Windows::Foundation::Collections::IVector
< Platform::String^>
^>^, Platform::String^> 		OptimizeTripAsync (Windows::Foundation::Collections::IVector< Platform::String^>^waypoints, Platform::String^travelMode, Platform::String^optimize, Platform::String^bingMapsKey, double alpha, double beta, double rho, unsigned int iterations, bool parallel)

Private Member Functions

void | CreateGraph (const std::vector< std::wstring > &waypoints, std::vector< std::shared_ptr< AntSystem::Node >> &nodes, std::vector< std::shared_ptr< AntSystem::Edge >> &edges)
concurrency::task
< Windows::Foundation::Collections::IMap
< Platform::String^,
Windows::Foundation::Collections::IVector
< Platform::String^>^>^> 		InternalOptimizeTripAsync (std::shared_ptr< OptimizeTripParams > params, concurrency::cancellation_token cancellationToken, concurrency::progress_reporter< Platform::String^> reporter)
void | ProcessLocation (std::shared_ptr< AntSystem::Node > node, Windows::Data::Xml::Dom::XmlDocument^data, concurrency::concurrent_vector< std::shared_ptr< AntSystem::Node >> &unresolvedLocations)
void | ProcessRoute (std::shared_ptr< AntSystem::Edge > edge, Windows::Data::Xml::Dom::XmlDocument^data)
std::vector< concurrency::task
< void > > 		RetrieveLocationsAsync (std::shared_ptr< OptimizeTripParams > params, concurrency::cancellation_token cancellationToken, concurrency::progress_reporter< Platform::String^> reporter)
std::vector< concurrency::task
< void > > 		RetrieveRoutesAsync (std::shared_ptr< OptimizeTripParams > params, concurrency::cancellation_token cancellationToken, concurrency::progress_reporter< Platform::String^> reporter)

Private Attributes

concurrency::cancellation_token_source | m_cancellationTokenSource

Detailed Description

Definition at line 21 of file TripOptimizerImpl.h.

Member Function Documentation

void TripOptimizerComponent::Details::TripOptimizerImpl::CreateGraph | ( | const std::vector< std::wstring > & | waypoints,
 |  | std::vector< std::shared_ptr< AntSystem::Node >> & | nodes,
 |  | std::vector< std::shared_ptr< AntSystem::Edge >> & | edges |
 | ) |  |  | [private]
concurrency::task<Windows::Foundation::Collections::IMap<Platform::String^, Windows::Foundation::Collections::IVector<Platform::String^>^>^> TripOptimizerComponent::Details::TripOptimizerImpl::InternalOptimizeTripAsync | ( | std::shared_ptr< OptimizeTripParams > | params,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | concurrency::progress_reporter< Platform::String^> | reporter |
 | ) |  |  | [private]
Windows::Foundation::IAsyncOperationWithProgress< Windows::Foundation::Collections::IMap<Platform::String^, Windows::Foundation::Collections::IVector<Platform::String^>^>^, Platform::String^> TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripAsync | ( | Windows::Foundation::Collections::IVector< Platform::String^>^ | waypoints,
 |  | Platform::String^ | travelMode,
 |  | Platform::String^ | optimize,
 |  | Platform::String^ | bingMapsKey,
 |  | double | alpha,
 |  | double | beta,
 |  | double | rho,
 |  | unsigned int | iterations,
 |  | bool | parallel
 | ) |  |
void TripOptimizerComponent::Details::TripOptimizerImpl::ProcessLocation | ( | std::shared_ptr< AntSystem::Node > | node,
 |  | Windows::Data::Xml::Dom::XmlDocument^ | data,
 |  | concurrency::concurrent_vector< std::shared_ptr< AntSystem::Node >> & | unresolvedLocations |
 | ) |  |  | [private]
void TripOptimizerComponent::Details::TripOptimizerImpl::ProcessRoute | ( | std::shared_ptr< AntSystem::Edge > | edge,
 |  | Windows::Data::Xml::Dom::XmlDocument^ | data |
 | ) |  |  | [private]
std::vector<concurrency::task<void> > TripOptimizerComponent::Details::TripOptimizerImpl::RetrieveLocationsAsync | ( | std::shared_ptr< OptimizeTripParams > | params,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | concurrency::progress_reporter< Platform::String^> | reporter |
 | ) |  |  | [private]
std::vector<concurrency::task<void> > TripOptimizerComponent::Details::TripOptimizerImpl::RetrieveRoutesAsync | ( | std::shared_ptr< OptimizeTripParams > | params,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | concurrency::progress_reporter< Platform::String^> | reporter |
 | ) |  |  | [private]

Member Data Documentation

concurrency::cancellation_token_source TripOptimizerComponent::Details::TripOptimizerImpl::m_cancellationTokenSource [private]

Definition at line 123 of file TripOptimizerImpl.h.

The documentation for this class was generated from the following file:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizerImpl.h
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • TripOptimizerComponent
  • Details
  • TripOptimizerComponent::Details::TripOptimizerImpl
  • TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Public Attributes

TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams Struct Reference

List of all members.

Public Attributes

double | Alpha
double | Beta
std::wstring | BingMapsKey
std::vector< std::shared_ptr
< AntSystem::Edge > > 		Edges
ULONGLONG | HttpTime
unsigned long | Iterations
std::vector< std::shared_ptr
< AntSystem::Node > > 		Nodes
std::wstring | Optimize
bool | Parallel
long | RequestsPending
double | Rho
ULONGLONG | SimulationTime
ULONGLONG | TotalTime
std::wstring | TravelMode
concurrency::concurrent_vector
< std::shared_ptr
< AntSystem::Node > > 		UnresolvedLocations
std::vector< std::wstring > | Waypoints

Detailed Description

Definition at line 41 of file TripOptimizerImpl.h.

Member Data Documentation

double TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Alpha

Definition at line 50 of file TripOptimizerImpl.h.

double TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Beta

Definition at line 51 of file TripOptimizerImpl.h.

std::wstring TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::BingMapsKey

Definition at line 49 of file TripOptimizerImpl.h.

std::vector<std::shared_ptr<AntSystem::Edge> > TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Edges

Definition at line 75 of file TripOptimizerImpl.h.

ULONGLONG TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::HttpTime

Definition at line 63 of file TripOptimizerImpl.h.

unsigned long TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Iterations

Definition at line 53 of file TripOptimizerImpl.h.

std::vector<std::shared_ptr<AntSystem::Node> > TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Nodes

Definition at line 71 of file TripOptimizerImpl.h.

std::wstring TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Optimize

Definition at line 48 of file TripOptimizerImpl.h.

bool TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Parallel

Definition at line 54 of file TripOptimizerImpl.h.

long TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::RequestsPending

Definition at line 78 of file TripOptimizerImpl.h.

double TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Rho

Definition at line 52 of file TripOptimizerImpl.h.

ULONGLONG TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::SimulationTime

Definition at line 65 of file TripOptimizerImpl.h.

ULONGLONG TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::TotalTime

Definition at line 61 of file TripOptimizerImpl.h.

std::wstring TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::TravelMode

Definition at line 47 of file TripOptimizerImpl.h.

concurrency::concurrent_vector<std::shared_ptr<AntSystem::Node> > TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::UnresolvedLocations

Definition at line 81 of file TripOptimizerImpl.h.

std::vector<std::wstring> TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams::Waypoints

Definition at line 46 of file TripOptimizerImpl.h.

The documentation for this struct was generated from the following file:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizerImpl.h
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TripOptimizerComponent::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • TripOptimizerComponent
  • TripOptimizerComponent::sealed
Public Member Functions | Private Member Functions | Private Attributes

TripOptimizerComponent::sealed Class Reference

#include "TripOptimizer.h"

List of all members.

Public Member Functions

Windows::Foundation::IAsyncOperationWithProgress
< Windows::Foundation::Collections::IMap
< Platform::String^,
Windows::Foundation::Collections::IVector
< Platform::String^>
^>^, Platform::String^> 		OptimizeTripAsync (Windows::Foundation::Collections::IVector< Platform::String^>^waypoints, Platform::String^travelMode, Platform::String^optimize, Platform::String^bingMapsKey, double alpha, double beta, double rho, unsigned int iterations, bool parallel)
TripOptimizer ()

Private Member Functions

~TripOptimizer ()

Private Attributes

std::unique_ptr
< Details::TripOptimizerImpl > 		m_impl

Detailed Description

Definition at line 23 of file TripOptimizer.h.

Constructor & Destructor Documentation

TripOptimizerComponent::sealed::~TripOptimizer ( ) [private]

Member Function Documentation

Windows::Foundation::IAsyncOperationWithProgress< Windows::Foundation::Collections::IMap< Platform::String^, Windows::Foundation::Collections::IVector<Platform::String^>^>^, Platform::String^> TripOptimizerComponent::sealed::OptimizeTripAsync | ( | Windows::Foundation::Collections::IVector< Platform::String^>^ | waypoints,
 |  | Platform::String^ | travelMode,
 |  | Platform::String^ | optimize,
 |  | Platform::String^ | bingMapsKey,
 |  | double | alpha,
 |  | double | beta,
 |  | double | rho,
 |  | unsigned int | iterations,
 |  | bool | parallel
 | ) |  |
TripOptimizerComponent::sealed::TripOptimizer ( )

Member Data Documentation

std::unique_ptr<Details::TripOptimizerImpl> TripOptimizerComponent::sealed::m_impl [private]

Definition at line 44 of file TripOptimizer.h.

The documentation for this class was generated from the following file:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizer.h
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UiaCoreWindowProvider::IAppWindowProvider Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • UiaCoreWindowProvider
  • UiaCoreWindowProvider::IAppWindowProvider
Public Member Functions

UiaCoreWindowProvider::IAppWindowProvider Interface Reference

import "InternalInterfaces.idl";

List of all members.

Public Member Functions

HRESULT Initialize ([in] ITriColorControlInternal *pControl,[in] IInspectable *pWindow)

Detailed Description

Definition at line 53 of file InternalInterfaces.idl.

Member Function Documentation

HRESULT UiaCoreWindowProvider::IAppWindowProvider::Initialize | ( | [in] ITriColorControlInternal * | pControl,
 |  | [in] IInspectable * | pWindow
 | ) |  |
The documentation for this interface was generated from the following file:
  • UI Automation core window provider/C++/InternalInterfaces.idl
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UiaCoreWindowProvider::IDisconnectableProvider Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • UiaCoreWindowProvider
  • UiaCoreWindowProvider::IDisconnectableProvider
Public Member Functions

UiaCoreWindowProvider::IDisconnectableProvider Interface Reference

import "InternalInterfaces.idl";

List of all members.

Public Member Functions

HRESULT Disconnect ()

Detailed Description

Definition at line 47 of file InternalInterfaces.idl.

Member Function Documentation

HRESULT UiaCoreWindowProvider::IDisconnectableProvider::Disconnect ( )
The documentation for this interface was generated from the following file:
  • UI Automation core window provider/C++/InternalInterfaces.idl
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UiaCoreWindowProvider::ITriColorControlInternal Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • UiaCoreWindowProvider
  • UiaCoreWindowProvider::ITriColorControlInternal
Public Member Functions

UiaCoreWindowProvider::ITriColorControlInternal Interface Reference

import "InternalInterfaces.idl";

Inherited by sealed.

List of all members.

Public Member Functions

HRESULT | ControlRect ([out, retval] Windows.Foundation.Rect *prc)
HRESULT | ControlValue ([in] TriColorValue value)
HRESULT | ControlValue ([out, retval] TriColorValue *pvalue)
HRESULT | GetAppWindowProvider ([out, retval] IInspectable **provider)
HRESULT | GetTriColorControlProvider ([out, retval] IInspectable **provider)
HRESULT | GetTriColorFragmentProvider ([in] TriColorValue value,[out, retval] IInspectable **provider)
HRESULT | HasFocus ([out, retval] VARIANT_BOOL *hasFocus)
HRESULT | RectFromValue ([in] TriColorValue value,[out, retval] Windows.Foundation.Rect *prc)
HRESULT | ValueFromPoint ([in] Windows.Foundation.Point pt,[out, retval] TriColorValue *value)

Detailed Description

Definition at line 27 of file InternalInterfaces.idl.

Member Function Documentation

HRESULT UiaCoreWindowProvider::ITriColorControlInternal::ControlRect ( [out, retval] Windows.Foundation.Rect * prc ) [get]
HRESULT UiaCoreWindowProvider::ITriColorControlInternal::ControlValue ( [in] TriColorValue value ) [set]
HRESULT UiaCoreWindowProvider::ITriColorControlInternal::ControlValue ( [out, retval] TriColorValue * pvalue ) [get]
HRESULT UiaCoreWindowProvider::ITriColorControlInternal::GetAppWindowProvider ( [out, retval] IInspectable ** provider )
HRESULT UiaCoreWindowProvider::ITriColorControlInternal::GetTriColorControlProvider ( [out, retval] IInspectable ** provider )
HRESULT UiaCoreWindowProvider::ITriColorControlInternal::GetTriColorFragmentProvider | ( | [in] TriColorValue | value,
 |  | [out, retval] IInspectable ** | provider
 | ) |  |
HRESULT UiaCoreWindowProvider::ITriColorControlInternal::HasFocus ( [out, retval] VARIANT_BOOL * hasFocus ) [get]
HRESULT UiaCoreWindowProvider::ITriColorControlInternal::RectFromValue | ( | [in] TriColorValue | value,
 |  | [out, retval] Windows.Foundation.Rect * | prc
 | ) |  |
HRESULT UiaCoreWindowProvider::ITriColorControlInternal::ValueFromPoint | ( | [in] Windows.Foundation.Point | pt,
 |  | [out, retval] TriColorValue * | value
 | ) |  |
The documentation for this interface was generated from the following file:
  • UI Automation core window provider/C++/InternalInterfaces.idl
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UiaCoreWindowProvider::ITriColorControlProvider Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • UiaCoreWindowProvider
  • UiaCoreWindowProvider::ITriColorControlProvider
Public Member Functions

UiaCoreWindowProvider::ITriColorControlProvider Interface Reference

import "InternalInterfaces.idl";

List of all members.

Public Member Functions

HRESULT Initialize ([in] ITriColorControlInternal *pControl)

Detailed Description

Definition at line 61 of file InternalInterfaces.idl.

Member Function Documentation

HRESULT UiaCoreWindowProvider::ITriColorControlProvider::Initialize ( [in] ITriColorControlInternal * pControl )
The documentation for this interface was generated from the following file:
  • UI Automation core window provider/C++/InternalInterfaces.idl
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UiaCoreWindowProvider::ITriColorFragmentProvider Interface Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • UiaCoreWindowProvider
  • UiaCoreWindowProvider::ITriColorFragmentProvider
Public Member Functions

UiaCoreWindowProvider::ITriColorFragmentProvider Interface Reference

import "InternalInterfaces.idl";

List of all members.

Public Member Functions

HRESULT Initialize ([in] ITriColorControlInternal *pControl,[in] TriColorValue value)

Detailed Description

Definition at line 68 of file InternalInterfaces.idl.

Member Function Documentation

HRESULT UiaCoreWindowProvider::ITriColorFragmentProvider::Initialize | ( | [in] ITriColorControlInternal * | pControl,
 |  | [in] TriColorValue | value
 | ) |  |
The documentation for this interface was generated from the following file:
  • UI Automation core window provider/C++/InternalInterfaces.idl
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UserInterface Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Static Public Member Functions | Private Member Functions | Private Attributes | Static Private Attributes

UserInterface Class Reference

#include "UserInterface.h"

List of all members.

Public Member Functions

void | HitTest (D2D1_POINT_2F point)
void | Initialize (_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory)
void | RegisterElement (ElementBase *element)
void | Render ()
void | UnregisterElement (ElementBase *element)
void | Update (float timeTotal, float timeDelta)

Static Public Member Functions

static ID2D1DeviceContext * | GetD2DContext ()
static IDWriteFactory * | GetDWriteFactory ()
static UserInterface & | GetInstance ()

Private Member Functions

UserInterface ()
~UserInterface ()

Private Attributes

Microsoft::WRL::ComPtr
< ID2D1DeviceContext > 		m_d2dContext
Microsoft::WRL::ComPtr
< ID2D1Device > 		m_d2dDevice
Microsoft::WRL::ComPtr
< ID2D1Factory1 > 		m_d2dFactory
Microsoft::WRL::ComPtr
< IDWriteFactory > 		m_dwriteFactory
ElementSet m_elements
Microsoft::WRL::ComPtr
< ID2D1DrawingStateBlock > 		m_stateBlock
Microsoft::WRL::ComPtr
< IWICImagingFactory > 		m_wicFactory

Static Private Attributes

static UserInterface | m_instance

Detailed Description

Definition at line 216 of file UserInterface.h.

Constructor & Destructor Documentation

UserInterface::UserInterface ( ) [inline, private]

Definition at line 240 of file UserInterface.h.

{ }

UserInterface::~UserInterface ( ) [inline, private]

Definition at line 241 of file UserInterface.h.

{ }

Member Function Documentation

static ID2D1DeviceContext* UserInterface::GetD2DContext ( ) [inline, static]

Definition at line 222 of file UserInterface.h.

{ return m_instance.m_d2dContext.Get(); }

static IDWriteFactory* UserInterface::GetDWriteFactory ( ) [inline, static]

Definition at line 221 of file UserInterface.h.

{ return m_instance.m_dwriteFactory.Get(); }

static UserInterface& UserInterface::GetInstance ( ) [inline, static]

Definition at line 219 of file UserInterface.h.

{ return m_instance; }

void UserInterface::HitTest ( D2D1_POINT_2F point )

Definition at line 694 of file UserInterface.cpp.

{
    for (auto iter = m_elements.begin(); iter != m_elements.end(); ++iter)
    {
        if (!(*iter)->IsVisible())
            continue;

        TextButton* textButton = dynamic_cast<TextButton*>(*iter);
        if (textButton != nullptr)
        {
            D2D1_RECT_F bounds = (*iter)->GetBounds();
            textButton->SetPressed(PointInRect(point, bounds));
        }
    }
}

void UserInterface::Initialize | ( | _In_ ID2D1Device * | d2dDevice,
 |  | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ IWICImagingFactory * | wicFactory,
 |  | _In_ IDWriteFactory * | dwriteFactory
 | ) |  |

Definition at line 611 of file UserInterface.cpp.

{
    m_wicFactory = wicFactory;
    m_dwriteFactory = dwriteFactory;
    m_d2dDevice = d2dDevice;
    m_d2dContext = d2dContext;

    ComPtr<ID2D1Factory> factory;
    d2dDevice->GetFactory(&factory);

    DX::ThrowIfFailed(
        factory.As(&m_d2dFactory)
        );

    DX::ThrowIfFailed(
        m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
        );
}

void UserInterface::RegisterElement ( ElementBase * element )

Definition at line 667 of file UserInterface.cpp.

{
    m_elements.insert(element);
}

void UserInterface::Render ( )

Definition at line 643 of file UserInterface.cpp.

{
    m_d2dContext->SaveDrawingState(m_stateBlock.Get());
    m_d2dContext->BeginDraw();
    m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
    m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);

    for (auto iter = m_elements.begin(); iter != m_elements.end(); ++iter)
    {
        if ((*iter)->IsVisible())
            (*iter)->Render();
    }

    // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
    // is lost. It will be handled during the next call to Present.
    HRESULT hr = m_d2dContext->EndDraw();
    if (hr != D2DERR_RECREATE_TARGET)
    {
        DX::ThrowIfFailed(hr);
    }

    m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
}

void UserInterface::UnregisterElement ( ElementBase * element )

Definition at line 672 of file UserInterface.cpp.

{
    auto iter = m_elements.find(element);
    if (iter != m_elements.end())
    {
        m_elements.erase(iter);
    }
}

void UserInterface::Update | ( | float | timeTotal,
 |  | float | timeDelta
 | ) |  |

Definition at line 635 of file UserInterface.cpp.

{
    for (auto iter = m_elements.begin(); iter != m_elements.end(); ++iter)
    {
        (*iter)->Update(timeTotal, timeDelta);
    }
}

Member Data Documentation

Microsoft::WRL::ComPtr<ID2D1DeviceContext> UserInterface::m_d2dContext [private]

Definition at line 247 of file UserInterface.h.

Microsoft::WRL::ComPtr<ID2D1Device> UserInterface::m_d2dDevice [private]

Definition at line 246 of file UserInterface.h.

Microsoft::WRL::ComPtr<ID2D1Factory1> UserInterface::m_d2dFactory [private]

Definition at line 245 of file UserInterface.h.

Microsoft::WRL::ComPtr<IDWriteFactory> UserInterface::m_dwriteFactory [private]

Definition at line 248 of file UserInterface.h.

ElementSet UserInterface::m_elements [private]

Definition at line 252 of file UserInterface.h.

UserInterface UserInterface::m_instance [static, private]

Definition at line 243 of file UserInterface.h.

Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock> UserInterface::m_stateBlock [private]

Definition at line 249 of file UserInterface.h.

Microsoft::WRL::ComPtr<IWICImagingFactory> UserInterface::m_wicFactory [private]

Definition at line 250 of file UserInterface.h.

The documentation for this class was generated from the following files:
  • DirectX marble maze game/C++/UserInterface.h
  • DirectX marble maze game/C++/UserInterface.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Utils Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Static Public Member Functions | Static Public Attributes

Utils Class Reference

#include "Utils.h"

List of all members.

Static Public Member Functions

static float64 | GetDistance (COLORREF color1, COLORREF color2)
static void | RGBToYUV (COLORREF color, float64 &y, float64 &u, float64 &v)
static float | SmoothStep (float a, float b, float x)

Static Public Attributes

static const float64 | Wb = 0.114
static const float64 | Wg = 1 - Utils::Wr - Utils::Wb
static const float64 | Wr = 0.299

Detailed Description

Definition at line 9 of file Utils.h.

Member Function Documentation

static float64 Utils::GetDistance | ( | COLORREF | color1,
 |  | COLORREF | color2 |
 | ) |  |  | [inline, static]

Definition at line 27 of file Utils.h.

    {
        float64 y1, u1, v1, y2, u2, v2;
        RGBToYUV(color1, y1, u1, v1);
        RGBToYUV(color2, y2, u2, v2);

        return sqrt(pow(u1 - u2, 2) + pow(v1 - v2, 2));
    }

static void Utils::RGBToYUV | ( | COLORREF | color,
 |  | float64 & | y,
 |  | float64 & | u,
 |  | float64 & | v |
 | ) |  |  | [inline, static]

Definition at line 16 of file Utils.h.

    {
        float64 r = GetRValue(color) / 255.0;
        float64 g = GetGValue(color) / 255.0;
        float64 b = GetBValue(color) / 255.0;

        y = Wr * r + Wb * b + Wg * g;
        u = 0.436 * (b - y) / (1 - Wb);
        v = 0.615 * (r - y) / (1 - Wr);
    }

static float Utils::SmoothStep | ( | float | a,
 |  | float | b,
 |  | float | x |
 | ) |  |  | [inline, static]

Definition at line 36 of file Utils.h.

    {
        if (x < a) return 0.0f;
        else if (x >= b) return 1.0f;

        x = (x - a) / (b - a);
        return (x * x * (3.0f - 2.0f * x));
    }

Member Data Documentation

const float64 Utils::Wb = 0.114 [static]

Definition at line 13 of file Utils.h.

const float64 Utils::Wg = 1 - Utils::Wr - Utils::Wb [static]

Definition at line 14 of file Utils.h.

const float64 Utils::Wr = 0.299 [static]

Definition at line 12 of file Utils.h.

The documentation for this class was generated from the following files:
  • Hilo C++/C++/CartoonEffect/Utils.h
  • Hilo C++/C++/CartoonEffect/FrameProcessing.cpp
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Vector2< T > Struct Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Vector2< T > Struct Template Reference

#include "BasicMath.h"

List of all members.

Public Member Functions

Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
Vector2 (T _x=0, T _y=0)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)

Public Attributes

union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};
union {
struct {
T x
T y
}
struct {
T g
T r
}
struct {
T u
T v
}
};

Detailed Description

template<class T>
struct Vector2< T >

Definition at line 22 of file BasicMath.h.

Constructor & Destructor Documentation

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

template<class T>
Vector2< T >::Vector2 | ( | T | _x = 0,
 |  | T | _y = 0 |
 | ) |  |  | [inline]

Definition at line 48 of file BasicMath.h.

: x(_x), y(_y) { }

Member Function Documentation

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector2< T >::operator[] ( unsigned int index ) [inline]

Definition at line 43 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

Member Data Documentation

union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
template<class T>
T Vector2< T >::g

Definition at line 34 of file BasicMath.h.

template<class T>
T Vector2< T >::r

Definition at line 33 of file BasicMath.h.

template<class T>
T Vector2< T >::u

Definition at line 38 of file BasicMath.h.

template<class T>
T Vector2< T >::v

Definition at line 39 of file BasicMath.h.

template<class T>
T Vector2< T >::x

Definition at line 28 of file BasicMath.h.

template<class T>
T Vector2< T >::y

Definition at line 29 of file BasicMath.h.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/BasicMath.h
  • Direct3D HLSL fractal generator/C++/BasicMath.h
  • Direct3D post-processing effects/C++/BasicMath.h
  • Direct3D resource loading/C++/BasicMath.h
  • Direct3D resource loading/C++/obj2vbo/BasicMath.h
  • Direct3D sprite/C++/BasicMath.h
  • Direct3D stereoscopic 3D/C++/BasicMath.h
  • Direct3D tutorial/C++/Lesson2.Triangles/BasicMath.h
  • Direct3D tutorial/C++/Lesson3.Cubes/BasicMath.h
  • Direct3D tutorial/C++/Lesson4.Textures/BasicMath.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicMath.h
  • Direct3D-Direct2D interop/C++/BasicMath.h
  • DirectX 3D shooting game/C++/BasicMath.h
  • DirectX marble maze game/C++/BasicMath.h
  • DirectX postcard app/C++/BasicMath.h
  • DirectX touch input/C++/BasicMath.h
  • DXGI offer and reclaim resources/C++/BasicMath.h
  • DXGI swap chain rotation/C++/BasicMath.h
  • XAML DirectX 3D shooting game/C++/BasicMath.h
  • XAudio2 audio file playback/C++/BasicMath.h
  • XAudio2 audio stream effect/C++/BasicMath.h
  • XInput audio controller playback/C++/BasicMath.h
Generated on Sat Nov 23 2024 16:09:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Vector3< T > Struct Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Vector3< T > Struct Template Reference

#include "BasicMath.h"

List of all members.

Public Member Functions

Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
Vector3 (T _x=0, T _y=0, T _z=0)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)

Public Attributes

union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
struct {
T u
T v
T w
}
};
union {
struct {
T u
T v
T w
}
struct {
T x
T y
T z
}
struct {
T b
T g
T r
}
};

Detailed Description

template<class T>
struct Vector3< T >

Definition at line 51 of file BasicMath.h.

Constructor & Destructor Documentation

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

template<class T>
Vector3< T >::Vector3 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0 |
 | ) |  |  | [inline]

Definition at line 80 of file BasicMath.h.

: x(_x), y(_y), z(_z) { }

Member Function Documentation

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector3< T >::operator[] ( unsigned int index ) [inline]

Definition at line 75 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

Member Data Documentation

union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
template<class T>
T Vector3< T >::b

Definition at line 65 of file BasicMath.h.

template<class T>
T Vector3< T >::g

Definition at line 64 of file BasicMath.h.

template<class T>
T Vector3< T >::r

Definition at line 63 of file BasicMath.h.

template<class T>
T Vector3< T >::u

Definition at line 69 of file BasicMath.h.

template<class T>
T Vector3< T >::v

Definition at line 70 of file BasicMath.h.

template<class T>
T Vector3< T >::w

Definition at line 71 of file BasicMath.h.

template<class T>
T Vector3< T >::x

Definition at line 57 of file BasicMath.h.

template<class T>
T Vector3< T >::y

Definition at line 58 of file BasicMath.h.

template<class T>
T Vector3< T >::z

Definition at line 59 of file BasicMath.h.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/BasicMath.h
  • Direct3D HLSL fractal generator/C++/BasicMath.h
  • Direct3D post-processing effects/C++/BasicMath.h
  • Direct3D resource loading/C++/BasicMath.h
  • Direct3D resource loading/C++/obj2vbo/BasicMath.h
  • Direct3D sprite/C++/BasicMath.h
  • Direct3D stereoscopic 3D/C++/BasicMath.h
  • Direct3D tutorial/C++/Lesson2.Triangles/BasicMath.h
  • Direct3D tutorial/C++/Lesson3.Cubes/BasicMath.h
  • Direct3D tutorial/C++/Lesson4.Textures/BasicMath.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicMath.h
  • Direct3D-Direct2D interop/C++/BasicMath.h
  • DirectX 3D shooting game/C++/BasicMath.h
  • DirectX marble maze game/C++/BasicMath.h
  • DirectX postcard app/C++/BasicMath.h
  • DirectX touch input/C++/BasicMath.h
  • DXGI offer and reclaim resources/C++/BasicMath.h
  • DXGI swap chain rotation/C++/BasicMath.h
  • XAML DirectX 3D shooting game/C++/BasicMath.h
  • XAudio2 audio file playback/C++/BasicMath.h
  • XAudio2 audio stream effect/C++/BasicMath.h
  • XInput audio controller playback/C++/BasicMath.h
Generated on Sat Nov 23 2024 16:09:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Vector4< T > Struct Template Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes

Vector4< T > Struct Template Reference

#include "BasicMath.h"

List of all members.

Public Member Functions

Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
Vector4 (T _x=0, T _y=0, T _z=0, T _w=0)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)
T & | operator[] (unsigned int index)

Public Attributes

union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};
union {
struct {
T w
T x
T y
T z
}
struct {
T a
T b
T g
T r
}
};

Detailed Description

template<class T>
struct Vector4< T >

Definition at line 83 of file BasicMath.h.

Constructor & Destructor Documentation

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

template<class T>
Vector4< T >::Vector4 | ( | T | _x = 0,
 |  | T | _y = 0,
 |  | T | _z = 0,
 |  | T | _w = 0 |
 | ) |  |  | [inline]

Definition at line 108 of file BasicMath.h.

: x(_x), y(_y), z(_z), w(_w) { }

Member Function Documentation

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

template<class T>
T& Vector4< T >::operator[] ( unsigned int index ) [inline]

Definition at line 103 of file BasicMath.h.

    {
        return static_cast<T*>(this)[index];
    }

Member Data Documentation

union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
union { ... }
template<class T>
T Vector4< T >::a

Definition at line 99 of file BasicMath.h.

template<class T>
T Vector4< T >::b

Definition at line 98 of file BasicMath.h.

template<class T>
T Vector4< T >::g

Definition at line 97 of file BasicMath.h.

template<class T>
T Vector4< T >::r

Definition at line 96 of file BasicMath.h.

template<class T>
T Vector4< T >::w

Definition at line 92 of file BasicMath.h.

template<class T>
T Vector4< T >::x

Definition at line 89 of file BasicMath.h.

template<class T>
T Vector4< T >::y

Definition at line 90 of file BasicMath.h.

template<class T>
T Vector4< T >::z

Definition at line 91 of file BasicMath.h.

The documentation for this struct was generated from the following files:
  • Direct3D bump mapping/C++/BasicMath.h
  • Direct3D HLSL fractal generator/C++/BasicMath.h
  • Direct3D post-processing effects/C++/BasicMath.h
  • Direct3D resource loading/C++/BasicMath.h
  • Direct3D resource loading/C++/obj2vbo/BasicMath.h
  • Direct3D sprite/C++/BasicMath.h
  • Direct3D stereoscopic 3D/C++/BasicMath.h
  • Direct3D tutorial/C++/Lesson2.Triangles/BasicMath.h
  • Direct3D tutorial/C++/Lesson3.Cubes/BasicMath.h
  • Direct3D tutorial/C++/Lesson4.Textures/BasicMath.h
  • Direct3D tutorial/C++/Lesson5.Components/BasicMath.h
  • Direct3D-Direct2D interop/C++/BasicMath.h
  • DirectX 3D shooting game/C++/BasicMath.h
  • DirectX marble maze game/C++/BasicMath.h
  • DirectX postcard app/C++/BasicMath.h
  • DirectX touch input/C++/BasicMath.h
  • DXGI offer and reclaim resources/C++/BasicMath.h
  • DXGI swap chain rotation/C++/BasicMath.h
  • XAML DirectX 3D shooting game/C++/BasicMath.h
  • XAudio2 audio file playback/C++/BasicMath.h
  • XAudio2 audio stream effect/C++/BasicMath.h
  • XInput audio controller playback/C++/BasicMath.h
Generated on Sat Nov 23 2024 16:09:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: VideoBufferLock Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Private Attributes

VideoBufferLock Class Reference

#include "BufferLock.h"

List of all members.

Public Member Functions

VideoBufferLock (IMFMediaBuffer *pBuffer)
VideoBufferLock ()
VideoBufferLock (IMFMediaBuffer *pBuffer)
VideoBufferLock ()
~VideoBufferLock ()
~VideoBufferLock ()
~VideoBufferLock ()
~VideoBufferLock ()
BYTE * | GetData ()
BYTE * | GetData ()
LONG | GetStride ()
LONG | GetStride ()
HRESULT | Lock (__in IMFMediaBuffer *pBuffer, __in MF2DBuffer_LockFlags flags, __in UINT uiMinSize, __in LONG lDefaultStride)
HRESULT | Lock (__in IMFMediaBuffer *pBuffer, __in MF2DBuffer_LockFlags flags, __in UINT uiMinSize, __in LONG lDefaultStride)
HRESULT | LockBuffer (LONG lDefaultStride, DWORD dwHeightInPixels, BYTE **ppbScanLine0, LONG *plStride)
HRESULT | LockBuffer (LONG lDefaultStride, DWORD dwHeightInPixels, BYTE **ppbScanLine0, LONG *plStride)
HRESULT | Unlock ()
HRESULT | Unlock ()
HRESULT | UnlockBuffer ()
HRESULT | UnlockBuffer ()

Private Attributes

BOOL | _bLocked2D
BOOL | _bLocked2D2
BOOL | _bLockedBuffer
LONG | _lPitch
BYTE * | _pData
ComPtr< IMFMediaBuffer > | _pInputBuffer
ComPtr< IMF2DBuffer > | _pInputBuffer2D
ComPtr< IMF2DBuffer2 > | _pInputBuffer2D2
IMF2DBuffer * | m_p2DBuffer
IMFMediaBuffer * | m_pBuffer

Detailed Description

Definition at line 20 of file BufferLock.h.

Constructor & Destructor Documentation

VideoBufferLock::VideoBufferLock ( IMFMediaBuffer * pBuffer ) [inline]

Definition at line 23 of file BufferLock.h.

                                             : m_p2DBuffer(NULL)
    {
        m_pBuffer = pBuffer;
        m_pBuffer->AddRef();

        // Query for the 2-D buffer interface. OK if this fails.
        m_pBuffer->QueryInterface(IID_PPV_ARGS(&m_p2DBuffer));
    }

VideoBufferLock::~VideoBufferLock ( ) [inline]

Definition at line 32 of file BufferLock.h.

    {
        UnlockBuffer();
        SafeRelease(&m_pBuffer);
        SafeRelease(&m_p2DBuffer);
    }

VideoBufferLock::VideoBufferLock ( ) [inline]

Definition at line 13 of file VideoBufferLock.h.

: _bLockedBuffer(FALSE), _bLocked2D(FALSE), _bLocked2D2(FALSE), _pData(NULL), _lPitch(0) {}

VideoBufferLock::~VideoBufferLock ( ) [inline]

Definition at line 86 of file VideoBufferLock.h.

{ Unlock(); }

VideoBufferLock::VideoBufferLock ( IMFMediaBuffer * pBuffer ) [inline]

Definition at line 23 of file BufferLock.h.

                                             : m_p2DBuffer(NULL)
    {
        m_pBuffer = pBuffer;
        m_pBuffer->AddRef();

        // Query for the 2-D buffer interface. OK if this fails.
        m_pBuffer->QueryInterface(IID_PPV_ARGS(&m_p2DBuffer));
    }

VideoBufferLock::~VideoBufferLock ( ) [inline]

Definition at line 32 of file BufferLock.h.

    {
        UnlockBuffer();
        SafeRelease(&m_pBuffer);
        SafeRelease(&m_p2DBuffer);
    }

VideoBufferLock::VideoBufferLock ( ) [inline]

Definition at line 13 of file VideoBufferLock.h.

: _bLockedBuffer(FALSE), _bLocked2D(FALSE), _bLocked2D2(FALSE), _pData(NULL), _lPitch(0) {}

VideoBufferLock::~VideoBufferLock ( ) [inline]

Definition at line 86 of file VideoBufferLock.h.

{ Unlock(); }

Member Function Documentation

BYTE* VideoBufferLock::GetData ( ) [inline]

Definition at line 113 of file VideoBufferLock.h.

{ return _pData; }

BYTE* VideoBufferLock::GetData ( ) [inline]

Definition at line 113 of file VideoBufferLock.h.

{ return _pData; }

LONG VideoBufferLock::GetStride ( ) [inline]

Definition at line 114 of file VideoBufferLock.h.

{ return _lPitch; }

LONG VideoBufferLock::GetStride ( ) [inline]

Definition at line 114 of file VideoBufferLock.h.

{ return _lPitch; }

HRESULT VideoBufferLock::Lock | ( | __in IMFMediaBuffer * | pBuffer,
 |  | __in MF2DBuffer_LockFlags | flags,
 |  | __in UINT | uiMinSize,
 |  | __in LONG | lDefaultStride |
 | ) |  |  | [inline]

Definition at line 15 of file VideoBufferLock.h.

    {
        HRESULT hr = S_OK;
        DWORD dwBufferCount = 0;
        DWORD maxSize = 0;
        BYTE *pbBufferStart = NULL;
        DWORD dwBufferLength = 0;

        assert(pBuffer);

        // if the lock is already locked, assert
        assert(!(_bLocked2D || _bLocked2D2 || _bLockedBuffer));
        _pInputBuffer = pBuffer;

        hr = _pInputBuffer.As(&_pInputBuffer2D2);
        if (SUCCEEDED(hr))
        {
            hr = _pInputBuffer2D2->Lock2DSize( flags, &_pData, &_lPitch, &pbBufferStart, &dwBufferLength );
            if (SUCCEEDED(hr))
            {
                if (dwBufferLength < uiMinSize || abs(_lPitch) < abs(lDefaultStride))
                {
                    _pInputBuffer2D2->Unlock2D();
                    hr = MF_E_BUFFERTOOSMALL;
                    goto done;
                }
                _bLocked2D2 = TRUE;
            }
        }

        if(!_bLocked2D2)
        {
            hr = _pInputBuffer.As(&_pInputBuffer2D);
            if (SUCCEEDED(hr))
            {
                hr = _pInputBuffer2D->Lock2D(&_pData, &_lPitch);
                if (SUCCEEDED(hr))
                {
                    if (abs(_lPitch) < abs(lDefaultStride))
                    {
                        _pInputBuffer2D->Unlock2D();
                        hr = MF_E_BUFFERTOOSMALL;
                        goto done;
                    }
                    _bLocked2D = TRUE;
                }
            }
        }

        if (!(_bLocked2D2 || _bLocked2D))
        {
            hr = _pInputBuffer->Lock(&_pData, &maxSize, NULL);

            if (SUCCEEDED(hr))
            {
                if (maxSize < uiMinSize)
                {
                    _pInputBuffer->Unlock();
                    hr = MF_E_BUFFERTOOSMALL;
                    goto done;
                }

                _bLockedBuffer = TRUE;
                _lPitch = lDefaultStride;
            }
        }

    done:
        return hr;
    }

HRESULT VideoBufferLock::Lock | ( | __in IMFMediaBuffer * | pBuffer,
 |  | __in MF2DBuffer_LockFlags | flags,
 |  | __in UINT | uiMinSize,
 |  | __in LONG | lDefaultStride |
 | ) |  |  | [inline]

Definition at line 15 of file VideoBufferLock.h.

    {
        HRESULT hr = S_OK;
        DWORD dwBufferCount = 0;
        DWORD maxSize = 0;
        BYTE *pbBufferStart = NULL;
        DWORD dwBufferLength = 0;

        assert(pBuffer);

        // if the lock is already locked, assert
        assert(!(_bLocked2D || _bLocked2D2 || _bLockedBuffer));
        _pInputBuffer = pBuffer;

        hr = _pInputBuffer.As(&_pInputBuffer2D2);
        if (SUCCEEDED(hr))
        {
            hr = _pInputBuffer2D2->Lock2DSize( flags, &_pData, &_lPitch, &pbBufferStart, &dwBufferLength );
            if (SUCCEEDED(hr))
            {
                if (dwBufferLength < uiMinSize || abs(_lPitch) < abs(lDefaultStride))
                {
                    _pInputBuffer2D2->Unlock2D();
                    hr = MF_E_BUFFERTOOSMALL;
                    goto done;
                }
                _bLocked2D2 = TRUE;
            }
        }

        if(!_bLocked2D2)
        {
            hr = _pInputBuffer.As(&_pInputBuffer2D);
            if (SUCCEEDED(hr))
            {
                hr = _pInputBuffer2D->Lock2D(&_pData, &_lPitch);
                if (SUCCEEDED(hr))
                {
                    if (abs(_lPitch) < abs(lDefaultStride))
                    {
                        _pInputBuffer2D->Unlock2D();
                        hr = MF_E_BUFFERTOOSMALL;
                        goto done;
                    }
                    _bLocked2D = TRUE;
                }
            }
        }

        if (!(_bLocked2D2 || _bLocked2D))
        {
            hr = _pInputBuffer->Lock(&_pData, &maxSize, NULL);

            if (SUCCEEDED(hr))
            {
                if (maxSize < uiMinSize)
                {
                    _pInputBuffer->Unlock();
                    hr = MF_E_BUFFERTOOSMALL;
                    goto done;
                }

                _bLockedBuffer = TRUE;
                _lPitch = lDefaultStride;
            }
        }

    done:
        return hr;
    }

HRESULT VideoBufferLock::LockBuffer | ( | LONG | lDefaultStride,
 |  | DWORD | dwHeightInPixels,
 |  | BYTE ** | ppbScanLine0,
 |  | LONG * | plStride |
 | ) |  |  | [inline]

Definition at line 46 of file BufferLock.h.

    {
        HRESULT hr = S_OK;

        // Use the 2-D version if available.
        if (m_p2DBuffer)
        {
            hr = m_p2DBuffer->Lock2D(ppbScanLine0, plStride);
        }
        else
        {
            // Use non-2D version.
            BYTE *pData = NULL;

            hr = m_pBuffer->Lock(&pData, NULL, NULL);
            if (SUCCEEDED(hr))
            {
                *plStride = lDefaultStride;
                if (lDefaultStride < 0)
                {
                    // Bottom-up orientation. Return a pointer to the start of the
                    // last row *in memory* which is the top row of the image.
                    *ppbScanLine0 = pData + abs(lDefaultStride) * (dwHeightInPixels - 1);
                }
                else
                {
                    // Top-down orientation. Return a pointer to the start of the
                    // buffer.
                    *ppbScanLine0 = pData;
                }
            }
        }
        return hr;
    }

HRESULT VideoBufferLock::LockBuffer | ( | LONG | lDefaultStride,
 |  | DWORD | dwHeightInPixels,
 |  | BYTE ** | ppbScanLine0,
 |  | LONG * | plStride |
 | ) |  |  | [inline]

Definition at line 46 of file BufferLock.h.

    {
        HRESULT hr = S_OK;

        // Use the 2-D version if available.
        if (m_p2DBuffer)
        {
            hr = m_p2DBuffer->Lock2D(ppbScanLine0, plStride);
        }
        else
        {
            // Use non-2D version.
            BYTE *pData = NULL;

            hr = m_pBuffer->Lock(&pData, NULL, NULL);
            if (SUCCEEDED(hr))
            {
                *plStride = lDefaultStride;
                if (lDefaultStride < 0)
                {
                    // Bottom-up orientation. Return a pointer to the start of the
                    // last row *in memory* which is the top row of the image.
                    *ppbScanLine0 = pData + abs(lDefaultStride) * (dwHeightInPixels - 1);
                }
                else
                {
                    // Top-down orientation. Return a pointer to the start of the
                    // buffer.
                    *ppbScanLine0 = pData;
                }
            }
        }
        return hr;
    }

HRESULT VideoBufferLock::Unlock ( ) [inline]

Definition at line 88 of file VideoBufferLock.h.

    {
        HRESULT hr = S_OK;

        if(_bLockedBuffer && _pInputBuffer)
        {
            hr = _pInputBuffer->Unlock();
            _bLockedBuffer = FALSE;
            _pInputBuffer = nullptr;
        }
        if(_bLocked2D && _pInputBuffer2D)
        {
            hr = _pInputBuffer2D->Unlock2D();
            _bLocked2D = FALSE;
            _pInputBuffer2D = nullptr;
        }
        if(_bLocked2D2 && _pInputBuffer2D2)
        {
            hr = _pInputBuffer2D2->Unlock2D();
            _bLocked2D2 = FALSE;
            _pInputBuffer2D2 = nullptr;
        }
        return hr;
    }

HRESULT VideoBufferLock::Unlock ( ) [inline]

Definition at line 88 of file VideoBufferLock.h.

    {
        HRESULT hr = S_OK;

        if(_bLockedBuffer && _pInputBuffer)
        {
            hr = _pInputBuffer->Unlock();
            _bLockedBuffer = FALSE;
            _pInputBuffer = nullptr;
        }
        if(_bLocked2D && _pInputBuffer2D)
        {
            hr = _pInputBuffer2D->Unlock2D();
            _bLocked2D = FALSE;
            _pInputBuffer2D = nullptr;
        }
        if(_bLocked2D2 && _pInputBuffer2D2)
        {
            hr = _pInputBuffer2D2->Unlock2D();
            _bLocked2D2 = FALSE;
            _pInputBuffer2D2 = nullptr;
        }
        return hr;
    }

HRESULT VideoBufferLock::UnlockBuffer ( ) [inline]

Definition at line 86 of file BufferLock.h.

    {
        if (m_p2DBuffer)
        {
            return m_p2DBuffer->Unlock2D();
        }
        else
        {
            return m_pBuffer->Unlock();
        }
    }

HRESULT VideoBufferLock::UnlockBuffer ( ) [inline]

Definition at line 86 of file BufferLock.h.

    {
        if (m_p2DBuffer)
        {
            return m_p2DBuffer->Unlock2D();
        }
        else
        {
            return m_pBuffer->Unlock();
        }
    }

Member Data Documentation

BOOL VideoBufferLock::_bLocked2D [private]

Definition at line 121 of file VideoBufferLock.h.

BOOL VideoBufferLock::_bLocked2D2 [private]

Definition at line 124 of file VideoBufferLock.h.

BOOL VideoBufferLock::_bLockedBuffer [private]

Definition at line 118 of file VideoBufferLock.h.

LONG VideoBufferLock::_lPitch [private]

Definition at line 127 of file VideoBufferLock.h.

BYTE * VideoBufferLock::_pData [private]

Definition at line 126 of file VideoBufferLock.h.

ComPtr< IMFMediaBuffer > VideoBufferLock::_pInputBuffer [private]

Definition at line 117 of file VideoBufferLock.h.

ComPtr< IMF2DBuffer > VideoBufferLock::_pInputBuffer2D [private]

Definition at line 120 of file VideoBufferLock.h.

ComPtr< IMF2DBuffer2 > VideoBufferLock::_pInputBuffer2D2 [private]

Definition at line 123 of file VideoBufferLock.h.

IMF2DBuffer * VideoBufferLock::m_p2DBuffer [private]

Definition at line 100 of file BufferLock.h.

IMFMediaBuffer * VideoBufferLock::m_pBuffer [private]

Definition at line 99 of file BufferLock.h.

The documentation for this class was generated from the following files:
  • Media extensions/C#,C++/MediaExtensions/Common/BufferLock.h
  • Media extensions/C#,C++/MediaExtensions/Invert/VideoBufferLock.h
  • Media extensions/C++/MediaExtensions/Common/BufferLock.h
  • Media extensions/C++/MediaExtensions/Invert/VideoBufferLock.h
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: VideoView Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Member Functions | Public Attributes | Private Attributes

VideoView Class Reference

#include "videoview.h"

List of all members.

Public Member Functions

void | Initialize (_In_ Platform::Agile< Windows::UI::Core::CoreWindow > window, _In_ Platform::Agile< Windows::ApplicationModel::Core::CoreApplicationView > applicationView)
void | OnKeyPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args)
void | OnPointerPressed (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args)
void | OnResuming (_In_ Platform::Object^sender, _In_ Platform::Object^args)
void | OnSuspending (_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args)
void | OnWindowSizeChanged (_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args)
void | Run ()

Public Attributes

internal | __pad0__: VideoView()

Private Attributes

Platform::Agile
< Windows::ApplicationModel::Core::CoreApplicationView > 		m_applicationView
MEPlayer m_player
Platform::Agile
< Windows::UI::Core::CoreWindow > 		m_window

Detailed Description

Definition at line 5 of file videoview.h.

Member Function Documentation

void VideoView::Initialize | ( | _In_ Platform::Agile< Windows::UI::Core::CoreWindow > | window,
 |  | _In_ Platform::Agile< Windows::ApplicationModel::Core::CoreApplicationView > | applicationView
 | ) |  |
void VideoView::OnKeyPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::KeyEventArgs^ | args
 | ) |  |

Definition at line 108 of file videoview.cpp.

{
    Windows::System::VirtualKey vKey = args->VirtualKey;

    if(VirtualKey::Space == vKey)
    {
        if(m_player->IsPlaying())
        {
            m_player->Pause();
        }
        else
        {
            m_player->Play();
        }
    }
    else if(VirtualKey::V == vKey)
    {
        m_player->EnableVideoEffect(TRUE);
    }
    else if(VirtualKey::O == vKey)
    {
        m_player->OpenFile();
    }
  else if(VirtualKey::L == vKey)
    {
        m_player->Loop();
    }
}

void VideoView::OnPointerPressed | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::PointerEventArgs^ | args
 | ) |  |

Definition at line 73 of file videoview.cpp.

{
    Windows::UI::Input::PointerPoint^ pPoint = args->CurrentPoint;

    if(pPoint)
    {
        Windows::UI::Input::PointerPointProperties^ pPointProperties = pPoint->Properties;

        if(pPointProperties)
        {
            bool fMiddleButtonPressed = pPointProperties->IsMiddleButtonPressed;
            bool fRightButtonPressed = pPointProperties->IsRightButtonPressed;

            if(fMiddleButtonPressed)
            {
                if(m_player->IsPlaying())
                {
                    m_player->Pause();
                }
                else
                {
                    m_player->Play();
                }
            }
            else if(fRightButtonPressed)
            {
                m_player->OpenFile();
            }
        }
    }
}

void VideoView::OnResuming | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Platform::Object^ | args
 | ) |  |

Definition at line 140 of file videoview.cpp.

{
    // When this application is suspended, it stores the drawing state.
    // This code attempts to restore the saved state.
    IPropertySet^ set = ApplicationData::Current->LocalSettings->Values;
    // an int called StereoExaggerationFactor is used as a key
    if (set->HasKey("MEPlaybackState"))
    {
        BOOL bMEPlaybackState = (safe_cast<IPropertyValue^>(set->Lookup("MEPlaybackState")))->GetInt32();

        if(bMEPlaybackState)
        {
            m_player->Play();
        }
    }
    else
    {
        MEDIA::ThrowIfFailed(E_UNEXPECTED);
    }
}

void VideoView::OnSuspending | ( | _In_ Platform::Object^ | sender,
 |  | _In_ Windows::ApplicationModel::SuspendingEventArgs^ | args
 | ) |  |
void VideoView::OnWindowSizeChanged | ( | _In_ Windows::UI::Core::CoreWindow^ | sender,
 |  | _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ | args
 | ) |  |

Definition at line 65 of file videoview.cpp.

{
    m_player->UpdateForWindowSizeChange();
}

void VideoView::Run ( )

Definition at line 48 of file videoview.cpp.

{
    // Activate the application window, making it visible and enabling it to receive events.
    m_window->Activate();

    // Open the media file using File Picker
    m_player->OpenFile();

    while (!m_player->ExitApp())
    {
        //Because of the CPU overhead involved in the video renderering we will only use
        //ProcessOneAndAllPending for events because it will throttle back the render loop to
        //only execute when an event occurs.
        m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
    }
}

Member Data Documentation

internal VideoView::__pad0__

Definition at line 8 of file videoview.h.

Platform::Agile<Windows::ApplicationModel::Core::CoreApplicationView> VideoView::m_applicationView [private]

Definition at line 45 of file videoview.h.

MEPlayer VideoView::m_player [private]

Definition at line 48 of file videoview.h.

Platform::Agile<Windows::UI::Core::CoreWindow> VideoView::m_window [private]

Definition at line 44 of file videoview.h.

The documentation for this class was generated from the following files:
  • Media engine native C++ video playback/C++/videoview.h
  • Media engine native C++ video playback/C++/videoview.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ViewTransform Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

ViewTransform Struct Reference

#include "DirectXFractal.h"

List of all members.

Public Attributes

double | rotation
double | scale
double | translationX
double | translationY

Detailed Description

Definition at line 55 of file DirectXFractal.h.

Member Data Documentation

double ViewTransform::rotation

Definition at line 58 of file DirectXFractal.h.

double ViewTransform::scale

Definition at line 57 of file DirectXFractal.h.

double ViewTransform::translationX

Definition at line 59 of file DirectXFractal.h.

double ViewTransform::translationY

Definition at line 60 of file DirectXFractal.h.

The documentation for this struct was generated from the following file:
  • Direct3D HLSL fractal generator/C++/DirectXFractal.h
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: WaveEffect Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Static Public Member Functions | Private Member Functions | Static Private Member Functions | Private Attributes

WaveEffect Class Reference

#include "WaveEffect.h"

List of all members.

Classes

struct | Vertex

Public Member Functions

float | GetSkewX () const
float | GetSkewY () const
float | GetWaveOffset () const
IFACEMETHODIMP_ (ULONG) Release()
IFACEMETHODIMP_ (UINT32) GetInputCount() const
IFACEMETHODIMP_ (ULONG) AddRef()
IFACEMETHODIMP | Initialize (_In_ ID2D1EffectContext *pEffectContext, _In_ ID2D1TransformGraph *pTransformGraph)
IFACEMETHODIMP | MapInputRectsToOutputRect (_In_reads_(inputRectCount) CONST D2D1_RECT_L *pInputRects, _In_reads_(inputRectCount) CONST D2D1_RECT_L *pInputOpaqueSubRects, UINT32 inputRectCount, _Out_ D2D1_RECT_L *pOutputRect, _Out_ D2D1_RECT_L *pOutputOpaqueSubRect)
IFACEMETHODIMP | MapInvalidRect (UINT32 inputIndex, D2D1_RECT_L invalidInputRect, _Out_ D2D1_RECT_L *pInvalidOutputRect) const
IFACEMETHODIMP | MapOutputRectToInputRects (_In_ const D2D1_RECT_L *pOutputRect, _Out_writes_(inputRectCount) D2D1_RECT_L *pInputRects, UINT32 inputRectCount) const
IFACEMETHODIMP | PrepareForRender (D2D1_CHANGE_TYPE changeType)
IFACEMETHODIMP | QueryInterface (_In_ REFIID riid, _Outptr_ void **ppOutput)
IFACEMETHODIMP | SetDrawInfo (_In_ ID2D1DrawInfo *pDrawInfo)
IFACEMETHODIMP | SetGraph (_In_ ID2D1TransformGraph *pTransformGraph)
HRESULT | SetSkewX (float skew)
HRESULT | SetSkewY (float skew)
HRESULT | SetWaveOffset (float waveOffset)

Static Public Member Functions

static HRESULT __stdcall | CreateWaveImpl (_Outptr_ IUnknown **ppEffectImpl)
static HRESULT | Register (_In_ ID2D1Factory1 *pFactory)

Private Member Functions

WaveEffect ()
HRESULT | GenerateMesh (_Outptr_ Vertex **ppMesh)
HRESULT | UpdateConstants ()

Static Private Member Functions

static float | Clamp (float v, float low, float high)

Private Attributes

struct {
D2D_MATRIX_4X4_F matrix
float sizeX
float sizeY
float skewX
float skewY
float waveOffset
} m_constants
Microsoft::WRL::ComPtr
< ID2D1DrawInfo > 		m_drawInfo
D2D_RECT_L | m_inputRect
UINT | m_numVertices
LONG | m_refCount
float | m_sizeX
float | m_sizeY
float | m_skewX
float | m_skewY
Microsoft::WRL::ComPtr
< ID2D1VertexBuffer > 		m_vertexBuffer
float | m_waveOffset

Detailed Description

Definition at line 29 of file WaveEffect.h.

Constructor & Destructor Documentation

WaveEffect::WaveEffect ( ) [private]

Definition at line 94 of file WaveEffect.cpp.

                       :
    m_refCount(1),
    m_waveOffset(0),
    m_skewX(0),
    m_skewY(0),
    m_sizeX(0),
    m_sizeY(0)
{
}

Member Function Documentation

static float WaveEffect::Clamp | ( | float | v,
 |  | float | low,
 |  | float | high |
 | ) |  |  | [inline, static, private]

Definition at line 95 of file WaveEffect.h.

    {
        return (v < low) ? low : (v > high) ? high : v;
    }

HRESULT __stdcall WaveEffect::CreateWaveImpl ( _Outptr_ IUnknown ** ppEffectImpl ) [static]

Definition at line 23 of file WaveEffect.cpp.

{
    *ppEffectImpl = static_cast<ID2D1EffectImpl*>(new (std::nothrow) WaveEffect());

    if (*ppEffectImpl == nullptr)
    {
        return E_OUTOFMEMORY;
    }
    else
    {
        return S_OK;
    }
}

HRESULT WaveEffect::GenerateMesh ( _Outptr_ Vertex ** ppMesh ) [private]

Definition at line 186 of file WaveEffect.cpp.

{
    m_numVertices = 6 * TessellationAmount * TessellationAmount;

    Vertex *mesh = new (std::nothrow) Vertex[m_numVertices];

    if (mesh == nullptr)
    {
        return E_OUTOFMEMORY;
    }

    float offset = 1.0f / TessellationAmount;

    for (int i = 0; i < TessellationAmount; i++)
    {
        for (int j = TessellationAmount - 1; j >= 0; j--)
        {
            int index = (i * TessellationAmount + j) * 6;

            // This mesh consists of pairs of triangles forming squares. Each square contains
            // six vertices, three for each triangle. 'offset' represents the distance between each vertice
            // in the triangles. In this mesh, we only set the x and y coordinates of the vertices, since
            // they are the only variable part of the geometry. In the vertex shader, z is generated
            // based on x, and w is defined to be '1'. The actual coordinates here range from 0 to 1,
            // these values are scaled up based on the size of the image in the vertex shader.

            mesh[index].x     = i * offset;
            mesh[index].y     = j * offset;
            mesh[index + 1].x = i * offset;
            mesh[index + 1].y = j * offset + offset;
            mesh[index + 2].x = i * offset + offset;
            mesh[index + 2].y = j * offset;
            mesh[index + 3].x = i * offset + offset;
            mesh[index + 3].y = j * offset;
            mesh[index + 4].x = i * offset;
            mesh[index + 4].y = j * offset + offset;
            mesh[index + 5].x = i * offset + offset;
            mesh[index + 5].y = j * offset + offset;
        }
    }

    *ppMesh = mesh;

    return S_OK;
}

float WaveEffect::GetSkewX ( ) const

Definition at line 261 of file WaveEffect.cpp.

{
    return m_skewX;
}

float WaveEffect::GetSkewY ( ) const

Definition at line 266 of file WaveEffect.cpp.

{
    return m_skewY;
}

float WaveEffect::GetWaveOffset ( ) const

Definition at line 271 of file WaveEffect.cpp.

{
    return m_waveOffset;
}

WaveEffect::IFACEMETHODIMP_ ( UINT32 ) const [inline]

Definition at line 85 of file WaveEffect.h.

{ return 1; }

WaveEffect::IFACEMETHODIMP_ ( ULONG )
WaveEffect::IFACEMETHODIMP_ ( ULONG )
HRESULT WaveEffect::Initialize | ( | _In_ ID2D1EffectContext * | pEffectContext,
 |  | _In_ ID2D1TransformGraph * | pTransformGraph
 | ) |  |

Definition at line 109 of file WaveEffect.cpp.

{
    BasicReaderWriter^ reader = ref new BasicReaderWriter();

    // Read compiled shader data instructions. Visual Studio automatically generates
    // the cso (Compiled Shader Object) file at compile time from the HLSL.

    Platform::Array<unsigned char, 1U>^ data;

    try
    {
        data = reader->ReadData("WaveEffect.cso");
    }
    catch (Platform::Exception^ e)
    {
        // Return error if file can not be read.
        return e->HResult;
    }

    HRESULT hr = pEffectContext->LoadVertexShader(GUID_WaveTransformVertexShader, data->Data, data->Length);

    if (SUCCEEDED(hr))
    {
        // Only generate the vertex buffer if it has not already been initialized.
        pEffectContext->FindVertexBuffer(&GUID_WaveTransformVertexBuffer, &m_vertexBuffer);
        if (m_vertexBuffer == nullptr)
        {
            Vertex* mesh;
            hr = GenerateMesh(&mesh);

            if (SUCCEEDED(hr))
            {
                // Updating geometry every time the effect is rendered can be costly, so it is
                // recommended that vertex buffer remain static if possible (which it is in this
                // sample effect).
                D2D1_VERTEX_BUFFER_PROPERTIES vbProp = {0};
                vbProp.byteWidth = sizeof(Vertex) * m_numVertices;
                vbProp.data = reinterpret_cast<BYTE*>(mesh);
                vbProp.inputCount = 1;
                vbProp.usage =  D2D1_VERTEX_USAGE_STATIC;

                static const D2D1_INPUT_ELEMENT_DESC vertexLayout[] =
                {
                    {"MESH_POSITION", 0, DXGI_FORMAT_R32G32_FLOAT, 0, 0},
                };

                D2D1_CUSTOM_VERTEX_BUFFER_PROPERTIES cvbProp = {0};
                cvbProp.elementCount = ARRAYSIZE(vertexLayout);
                cvbProp.inputElements = vertexLayout;
                cvbProp.stride = sizeof(Vertex);
                cvbProp.shaderBufferWithInputSignature = data->Data;
                cvbProp.shaderBufferSize = data->Length;

                // The GUID is optional, and is provided here to register the geometry globally.
                // As mentioned above, this avoids duplication if multiple versions of the effect
                // are created.
                hr = pEffectContext->CreateVertexBuffer(
                    &vbProp,
                    &GUID_WaveTransformVertexBuffer,
                    &cvbProp,
                    &m_vertexBuffer
                    );
            }

            // Since mesh has already been transferred to GPU, it can be removed.
            delete[] mesh;
        }
    }

    hr = pTransformGraph->SetSingleTransformNode(this);

    return hr;
}

IFACEMETHODIMP WaveEffect::MapInputRectsToOutputRect | ( | _In_reads_(inputRectCount) CONST D2D1_RECT_L * | pInputRects,
 |  | _In_reads_(inputRectCount) CONST D2D1_RECT_L * | pInputOpaqueSubRects,
 |  | UINT32 | inputRectCount,
 |  | _Out_ D2D1_RECT_L * | pOutputRect,
 |  | _Out_ D2D1_RECT_L * | pOutputOpaqueSubRect
 | ) |  |

Definition at line 308 of file WaveEffect.cpp.

{
    HRESULT hr = S_OK;

    if (inputRectCount != 1)
    {
        return E_FAIL;
    }

    m_inputRect = pInputRects[0];

    // Store the size of the rect so we can pass it into the vertex shader later.
    int newSizeX = pInputRects[0].right - pInputRects[0].left;
    int newSizeY = pInputRects[0].bottom - pInputRects[0].top;

    if (m_sizeX != newSizeX || m_sizeY != newSizeY)
    {
        m_sizeX = static_cast<float>(newSizeX);
        m_sizeY = static_cast<float>(newSizeY);
        hr = UpdateConstants();
    }

    if (SUCCEEDED(hr))
    {
        // Based on how the vertex shader is deforming the image, we can adjust the output rect to
        // avoid unnecessary rendering/blending. While simply setting the output rect to the input
        // rect is the simplest solution, there will be rendering errors if the custom effect is
        // subsequently transformed such that content that was previously outside screen bounds
        // should now be visible (i.e. a translation). If no geometric transformation is done to
        // an image, the outputRect can simply be assigned to the inputRect (*outputRect = m_inputRect)

        long inputRectHeight = m_inputRect.bottom - m_inputRect.top;
        long inputRectWidth = m_inputRect.right - m_inputRect.left;

        // These values are based on the transforms done in the vertex shader itself.

        // SkewOffset is the point where the wave is perpendicular to the screen.
        if (m_skewY > SkewOffset)
        {
            pOutputRect->top    = static_cast<long>(m_inputRect.top +    (inputRectHeight * WaveMarginTop) - WaveHeight);
            pOutputRect->bottom = static_cast<long>(m_inputRect.bottom - (inputRectHeight * WaveMarginBottom) + WaveHeight + (inputRectHeight * m_skewY));
        }
        else
        {
            pOutputRect->top    = static_cast<long>(m_inputRect.top + (inputRectHeight * WaveMarginTop) - WaveHeight + (inputRectHeight * (m_skewY - SkewOffset)));
            pOutputRect->bottom = static_cast<long>(m_inputRect.top + (inputRectHeight * WaveMarginTop) + WaveHeight);
        }

        if (m_skewX > 0)
        {
            pOutputRect->left  = static_cast<long>(m_inputRect.left   + (inputRectWidth * WaveMarginLeft));
            pOutputRect->right = static_cast<long>(m_inputRect.right  - (inputRectWidth * WaveMarginRight) + (inputRectWidth * m_skewX));
        }
        else
        {
            pOutputRect->left  = static_cast<long>(m_inputRect.left  + (inputRectWidth * WaveMarginLeft) + (inputRectWidth * m_skewX));
            pOutputRect->right = static_cast<long>(m_inputRect.right - (inputRectWidth * WaveMarginRight));
        }

        // Indicate that entire output might contain transparency
        ZeroMemory(pOutputOpaqueSubRect, sizeof(*pOutputOpaqueSubRect));
    }

    return hr;
}

IFACEMETHODIMP WaveEffect::MapInvalidRect | ( | UINT32 | inputIndex,
 |  | D2D1_RECT_L | invalidInputRect,
 |  | _Out_ D2D1_RECT_L * | pInvalidOutputRect |
 | ) |  |  | const

Definition at line 380 of file WaveEffect.cpp.

{
    // Indicate that the entire output may be invalid.
    *pInvalidOutputRect = m_inputRect;

    return S_OK;
}

IFACEMETHODIMP WaveEffect::MapOutputRectToInputRects | ( | _In_ const D2D1_RECT_L * | pOutputRect,
 |  | _Out_writes_(inputRectCount) D2D1_RECT_L * | pInputRects,
 |  | UINT32 | inputRectCount |
 | ) |  |  | const

Definition at line 292 of file WaveEffect.cpp.

{
    if (inputRectCount != 1)
    {
        return E_FAIL;
    }

    pInputRects[0] = m_inputRect;

    return S_OK;
}

IFACEMETHODIMP WaveEffect::PrepareForRender ( D2D1_CHANGE_TYPE changeType )

Definition at line 233 of file WaveEffect.cpp.

{
    return UpdateConstants();
}

IFACEMETHODIMP WaveEffect::QueryInterface | ( | _In_ REFIID | riid,
 |  | _Outptr_ void ** | ppOutput
 | ) |  |

Definition at line 438 of file WaveEffect.cpp.

{
    *ppOutput = nullptr;
    HRESULT hr = S_OK;

    if (riid == __uuidof(ID2D1EffectImpl))
    {
        *ppOutput = reinterpret_cast<ID2D1EffectImpl*>(this);
    }
    else if (riid == __uuidof(ID2D1DrawTransform))
    {
        *ppOutput = static_cast<ID2D1DrawTransform*>(this);
    }
    else if (riid == __uuidof(ID2D1Transform))
    {
        *ppOutput = static_cast<ID2D1Transform*>(this);
    }
    else if (riid == __uuidof(ID2D1TransformNode))
    {
        *ppOutput = static_cast<ID2D1TransformNode*>(this);
    }
    else if (riid == __uuidof(IUnknown))
    {
        *ppOutput = this;
    }
    else
    {
        hr = E_NOINTERFACE;
    }

    if (*ppOutput != nullptr)
    {
        AddRef();
    }

    return hr;
}

HRESULT WaveEffect::Register ( _In_ ID2D1Factory1 * pFactory ) [static]

Definition at line 37 of file WaveEffect.cpp.

{
    PCWSTR propertyXml =
        XML(
            <?xml version='1.0'?>
            <Effect>
                <!-- System Properties -->
                <Property name='DisplayName' type='string' value='Wave Effect'/>
                <Property name='Author' type='string' value='Microsoft Corporation'/>
                <Property name='Category' type='string' value='Sample'/>
                <Property name='Description' type='string' value='Animation of a wave.'/>
                <Inputs>
                    <Input name='Source'/>
                </Inputs>
                <!-- Effect-specific Properties -->
                <Property name='WaveOffset' type='float' value='0'>
                    <Property name='DisplayName' type='string' value='Wave Offset'/>
                    <Property name='Default' type='float' value='0.0'/>
                </Property>
                <Property name='SkewX' type='float' value='0'>
                    <Property name='DisplayName' type='string' value='Skew (X-Axis)'/>
                    <Property name='Min' type='float' value='-5.0'/>
                    <Property name='Max' type='float' value='5.0'/>
                    <Property name='Default' type='float' value='0.0'/>
                </Property>
                <Property name='SkewY' type='float' value='0'>
                    <Property name='DisplayName' type='string' value='Skew (Y-Axis)'/>
                    <Property name='Min' type='float' value='-5.0'/>
                    <Property name='Max' type='float' value='5.0'/>
                    <Property name='Default' type='float' value='0.0'/>
                </Property>
            </Effect>
            );

    // Property bindings are performed automatically for the system properties.
    // For effect-specific properties (i.e. WaveOffset), you must direct
    // Direct2D to the specific method in your implementation for manipulating
    // the property. This is done by assigning each property a 'setter' and 'getter'
    // in this table. Direct2D provides a set of helpers for doing this in
    // D2D1EffectHelpers.h, such as D2D1_VALUE_TYPE_BINDING used here.
    D2D1_PROPERTY_BINDING bindings[] =
    {
        D2D1_VALUE_TYPE_BINDING(L"WaveOffset",  &SetWaveOffset,  &GetWaveOffset),
        D2D1_VALUE_TYPE_BINDING(L"SkewX",  &SetSkewX,  &GetSkewX),
        D2D1_VALUE_TYPE_BINDING(L"SkewY",  &SetSkewY,  &GetSkewY)
    };

    // Register the effect using the data defined above.
    return pFactory->RegisterEffectFromString(
        CLSID_CustomWaveEffect,
        propertyXml,
        bindings,
        ARRAYSIZE(bindings),
        CreateWaveImpl
        );
}

IFACEMETHODIMP WaveEffect::SetDrawInfo ( _In_ ID2D1DrawInfo * pDrawInfo )

Definition at line 392 of file WaveEffect.cpp.

{
    m_drawInfo = pDrawInfo;

    D2D1_VERTEX_RANGE range;
    range.startVertex = 0;
    range.vertexCount = m_numVertices;

    return m_drawInfo->SetVertexProcessing(
        m_vertexBuffer.Get(),
        D2D1_VERTEX_OPTIONS_USE_DEPTH_BUFFER,
        nullptr, // Setting the blend description to nullptr draws the geometry using a simple source-over blend.
        &range,
        &GUID_WaveTransformVertexShader
        );
}

IFACEMETHODIMP WaveEffect::SetGraph ( _In_ ID2D1TransformGraph * pTransformGraph ) [inline]

Definition at line 54 of file WaveEffect.h.

    {
        return E_NOTIMPL; // There's no need to implement this on effects with static input counts.
    }

HRESULT WaveEffect::SetSkewX ( float skew )

Definition at line 242 of file WaveEffect.cpp.

{
    m_skewX = Clamp(skew, -5.0f, 5.0f);
    return S_OK;
}

HRESULT WaveEffect::SetSkewY ( float skew )

Definition at line 248 of file WaveEffect.cpp.

{
    m_skewY = Clamp(skew, -5.0f, 5.0f);
    return S_OK;
}

HRESULT WaveEffect::SetWaveOffset ( float waveOffset )

Definition at line 255 of file WaveEffect.cpp.

{
    m_waveOffset = waveOffset;
    return S_OK;
}

HRESULT WaveEffect::UpdateConstants ( ) [private]

Definition at line 276 of file WaveEffect.cpp.

{
    // Update constant buffer 1 (the first constant buffer available to the effect)
    // with the progress, skew, and size values.

    m_constants.matrix = D2D1::Matrix4x4F::RotationX(3);
    m_constants.sizeX = m_sizeX;
    m_constants.sizeY = m_sizeY;
    m_constants.waveOffset = m_waveOffset;
    m_constants.skewX = m_skewX;
    m_constants.skewY = m_skewY;

    return m_drawInfo->SetVertexShaderConstantBuffer(reinterpret_cast<const BYTE*>(&m_constants), sizeof(m_constants));

}

Member Data Documentation

struct { ... } WaveEffect::m_constants [private]
Microsoft::WRL::ComPtr<ID2D1DrawInfo> WaveEffect::m_drawInfo [private]

Definition at line 120 of file WaveEffect.h.

D2D_RECT_L WaveEffect::m_inputRect [private]

Definition at line 122 of file WaveEffect.h.

UINT WaveEffect::m_numVertices [private]

Definition at line 121 of file WaveEffect.h.

LONG WaveEffect::m_refCount [private]

Definition at line 124 of file WaveEffect.h.

float WaveEffect::m_sizeX [private]

Definition at line 114 of file WaveEffect.h.

float WaveEffect::m_sizeY [private]

Definition at line 115 of file WaveEffect.h.

float WaveEffect::m_skewX [private]

Definition at line 116 of file WaveEffect.h.

float WaveEffect::m_skewY [private]

Definition at line 117 of file WaveEffect.h.

Microsoft::WRL::ComPtr<ID2D1VertexBuffer> WaveEffect::m_vertexBuffer [private]

Definition at line 119 of file WaveEffect.h.

float WaveEffect::m_waveOffset [private]

Definition at line 113 of file WaveEffect.h.

D2D_MATRIX_4X4_F WaveEffect::matrix

Definition at line 129 of file WaveEffect.h.

float WaveEffect::sizeX

Definition at line 130 of file WaveEffect.h.

float WaveEffect::sizeY

Definition at line 131 of file WaveEffect.h.

float WaveEffect::skewX

Definition at line 133 of file WaveEffect.h.

float WaveEffect::skewY

Definition at line 134 of file WaveEffect.h.

float WaveEffect::waveOffset

Definition at line 132 of file WaveEffect.h.

The documentation for this class was generated from the following files:
  • Direct2D custom image effects/C++/VertexShader/WaveEffect.h
  • Direct2D custom image effects/C++/VertexShader/WaveEffect.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: WaveEffect::Vertex Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • WaveEffect
  • WaveEffect::Vertex
Public Attributes

WaveEffect::Vertex Struct Reference

List of all members.

Public Attributes

float | x
float | y

Detailed Description

Definition at line 100 of file WaveEffect.h.

Member Data Documentation

float WaveEffect::Vertex::x

Definition at line 102 of file WaveEffect.h.

float WaveEffect::Vertex::y

Definition at line 103 of file WaveEffect.h.

The documentation for this struct was generated from the following file:
  • Direct2D custom image effects/C++/VertexShader/WaveEffect.h
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web::Details::HttpRequestBuffersCallback Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Web
  • Details
  • Web::Details::HttpRequestBuffersCallback
Public Member Functions | Private Member Functions | Private Attributes

Web::Details::HttpRequestBuffersCallback Class Reference

#include "HttpRequest.h"

List of all members.

Public Member Functions

HttpRequestBuffersCallback (IXMLHTTPRequest2 *httpRequest, concurrency::cancellation_token ct=concurrency::cancellation_token::none())
HttpRequestBuffersCallback (IXMLHTTPRequest2 *httpRequest, concurrency::cancellation_token ct=concurrency::cancellation_token::none())
HttpRequestBuffersCallback (IXMLHTTPRequest2 *httpRequest, concurrency::cancellation_token ct=concurrency::cancellation_token::none())
HttpRequestBuffersCallback (IXMLHTTPRequest2 *httpRequest, concurrency::cancellation_token ct=concurrency::cancellation_token::none())
HttpRequestBuffersCallback (IXMLHTTPRequest2 *httpRequest, concurrency::cancellation_token ct=concurrency::cancellation_token::none())
concurrency::task< void > | CreateDataTask ()
concurrency::task< void > | CreateDataTask ()
concurrency::task< void > | CreateDataTask ()
concurrency::task< void > | CreateDataTask ()
concurrency::task< void > | CreateDataTask ()
HRESULT | GetError () const
HRESULT | GetError () const
HRESULT | GetError () const
HRESULT | GetError () const
HRESULT | GetError () const
std::wstring const & | GetReasonPhrase () const
std::wstring const & | GetReasonPhrase () const
std::wstring const & | GetReasonPhrase () const
std::wstring const & | GetReasonPhrase () const
std::wstring const & | GetReasonPhrase () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
bool | IsResponseReceived () const
bool | IsResponseReceived () const
bool | IsResponseReceived () const
bool | IsResponseReceived () const
bool | IsResponseReceived () const
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *stream)
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *stream)
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *stream)
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *stream)
IFACEMETHODIMP | OnDataAvailable (IXMLHTTPRequest2 *, ISequentialStream *stream)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnError (IXMLHTTPRequest2 *, HRESULT hrError)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnHeadersAvailable (IXMLHTTPRequest2 *, DWORD statusCode, PCWSTR reasonPhrase)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnRedirect (IXMLHTTPRequest2 *, PCWSTR)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *xhr, ISequentialStream *responseStream)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *xhr, ISequentialStream *responseStream)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *xhr, ISequentialStream *responseStream)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *xhr, ISequentialStream *responseStream)
IFACEMETHODIMP | OnResponseReceived (IXMLHTTPRequest2 *xhr, ISequentialStream *responseStream)
unsigned int | ReadData (_Out_writes_(outputBufferSize) byte *outputBuffer, unsigned int outputBufferSize)
unsigned int | ReadData (_Out_writes_(outputBufferSize) byte *outputBuffer, unsigned int outputBufferSize)
unsigned int | ReadData (_Out_writes_(outputBufferSize) byte *outputBuffer, unsigned int outputBufferSize)
unsigned int | ReadData (_Out_writes_(outputBufferSize) byte *outputBuffer, unsigned int outputBufferSize)
unsigned int | ReadData (_Out_writes_(outputBufferSize) byte *outputBuffer, unsigned int outputBufferSize)

Private Member Functions

~HttpRequestBuffersCallback ()
~HttpRequestBuffersCallback ()
~HttpRequestBuffersCallback ()
~HttpRequestBuffersCallback ()
~HttpRequestBuffersCallback ()

Private Attributes

concurrency::cancellation_token | cancellationToken
concurrency::task_completion_event
< void > 		dataEvent
concurrency::critical_section | dataEventLock
HRESULT | dataHResult
Microsoft::WRL::ComPtr
< ISequentialStream > 		dataStream
std::wstring | reasonPhrase
concurrency::cancellation_token_registration | registrationToken
Microsoft::WRL::ComPtr
< IXMLHTTPRequest2 > 		request
bool | responseReceived
int | statusCode

Detailed Description

Definition at line 34 of file HttpRequest.h.

Constructor & Destructor Documentation

Web::Details::HttpRequestBuffersCallback::HttpRequestBuffersCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | concurrency::cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 41 of file HttpRequest.h.

                                                                                :
        request(httpRequest), cancellationToken(ct), responseReceived(false), dataHResult(S_OK), statusCode(200)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != concurrency::cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }

        dataEvent = concurrency::task_completion_event<void>();
    }

Web::Details::HttpRequestBuffersCallback::~HttpRequestBuffersCallback ( ) [inline, private]

Definition at line 169 of file HttpRequest.h.

    {
        // Unregister the callback.
        if (cancellationToken != concurrency::cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

Web::Details::HttpRequestBuffersCallback::HttpRequestBuffersCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | concurrency::cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 41 of file HttpRequest.h.

                                                                                :
        request(httpRequest), cancellationToken(ct), responseReceived(false), dataHResult(S_OK), statusCode(200)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != concurrency::cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }

        dataEvent = concurrency::task_completion_event<void>();
    }

Web::Details::HttpRequestBuffersCallback::~HttpRequestBuffersCallback ( ) [inline, private]

Definition at line 169 of file HttpRequest.h.

    {
        // Unregister the callback.
        if (cancellationToken != concurrency::cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

Web::Details::HttpRequestBuffersCallback::HttpRequestBuffersCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | concurrency::cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 41 of file HttpRequest.h.

                                                                                :
        request(httpRequest), cancellationToken(ct), responseReceived(false), dataHResult(S_OK), statusCode(200)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != concurrency::cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }

        dataEvent = concurrency::task_completion_event<void>();
    }

Web::Details::HttpRequestBuffersCallback::~HttpRequestBuffersCallback ( ) [inline, private]

Definition at line 169 of file HttpRequest.h.

    {
        // Unregister the callback.
        if (cancellationToken != concurrency::cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

Web::Details::HttpRequestBuffersCallback::HttpRequestBuffersCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | concurrency::cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 38 of file HttpRequest.h.

                                                                                :
                request(httpRequest), cancellationToken(ct), responseReceived(false), dataHResult(S_OK), statusCode(200)
            {
                // Register a callback function that aborts the HTTP operation when
                // the cancellation token is canceled.
                if (cancellationToken != concurrency::cancellation_token::none())
                {
                    registrationToken = cancellationToken.register_callback([this]()
                    {
                        if (request != nullptr)
                        {
                            request->Abort();
                        }
                    });
                }

                dataEvent = concurrency::task_completion_event<void>();
            }

Web::Details::HttpRequestBuffersCallback::~HttpRequestBuffersCallback ( ) [inline, private]

Definition at line 166 of file HttpRequest.h.

            {
                // Unregister the callback.
                if (cancellationToken != concurrency::cancellation_token::none())
                {
                    cancellationToken.deregister_callback(registrationToken);
                }
            }

Web::Details::HttpRequestBuffersCallback::HttpRequestBuffersCallback | ( | IXMLHTTPRequest2 * | httpRequest,
 |  | concurrency::cancellation_token | ct = concurrency::cancellation_token::none() |
 | ) |  |  | [inline]

Definition at line 41 of file HttpRequest.h.

                                                                                :
        request(httpRequest), cancellationToken(ct), responseReceived(false), dataHResult(S_OK), statusCode(200)
    {
        // Register a callback function that aborts the HTTP operation when
        // the cancellation token is canceled.
        if (cancellationToken != concurrency::cancellation_token::none())
        {
            registrationToken = cancellationToken.register_callback([this]()
            {
                if (request != nullptr)
                {
                    request->Abort();
                }
            });
        }

        dataEvent = concurrency::task_completion_event<void>();
    }

Web::Details::HttpRequestBuffersCallback::~HttpRequestBuffersCallback ( ) [inline, private]

Definition at line 169 of file HttpRequest.h.

    {
        // Unregister the callback.
        if (cancellationToken != concurrency::cancellation_token::none())
        {
            cancellationToken.deregister_callback(registrationToken);
        }
    }

Member Function Documentation

task< void > Web::Details::HttpRequestBuffersCallback::CreateDataTask ( )

Definition at line 270 of file HttpRequest.cpp.

{
    concurrency::critical_section::scoped_lock lock(dataEventLock);
    return create_task(dataEvent, cancellationToken);
}

concurrency::task<void> Web::Details::HttpRequestBuffersCallback::CreateDataTask ( )
concurrency::task<void> Web::Details::HttpRequestBuffersCallback::CreateDataTask ( )
concurrency::task<void> Web::Details::HttpRequestBuffersCallback::CreateDataTask ( )
concurrency::task<void> Web::Details::HttpRequestBuffersCallback::CreateDataTask ( )
HRESULT Web::Details::HttpRequestBuffersCallback::GetError ( ) const [inline]

Definition at line 142 of file HttpRequest.h.

    {
        return dataHResult;
    }

HRESULT Web::Details::HttpRequestBuffersCallback::GetError ( ) const [inline]

Definition at line 139 of file HttpRequest.h.

            {
                return dataHResult;
            }

HRESULT Web::Details::HttpRequestBuffersCallback::GetError ( ) const [inline]

Definition at line 142 of file HttpRequest.h.

    {
        return dataHResult;
    }

HRESULT Web::Details::HttpRequestBuffersCallback::GetError ( ) const [inline]

Definition at line 142 of file HttpRequest.h.

    {
        return dataHResult;
    }

HRESULT Web::Details::HttpRequestBuffersCallback::GetError ( ) const [inline]

Definition at line 142 of file HttpRequest.h.

    {
        return dataHResult;
    }

std::wstring const& Web::Details::HttpRequestBuffersCallback::GetReasonPhrase ( ) const [inline]

Definition at line 152 of file HttpRequest.h.

    {
        return reasonPhrase;
    }

std::wstring const& Web::Details::HttpRequestBuffersCallback::GetReasonPhrase ( ) const [inline]

Definition at line 152 of file HttpRequest.h.

    {
        return reasonPhrase;
    }

std::wstring const& Web::Details::HttpRequestBuffersCallback::GetReasonPhrase ( ) const [inline]

Definition at line 149 of file HttpRequest.h.

            {
                return reasonPhrase;
            }

std::wstring const& Web::Details::HttpRequestBuffersCallback::GetReasonPhrase ( ) const [inline]

Definition at line 152 of file HttpRequest.h.

    {
        return reasonPhrase;
    }

std::wstring const& Web::Details::HttpRequestBuffersCallback::GetReasonPhrase ( ) const [inline]

Definition at line 152 of file HttpRequest.h.

    {
        return reasonPhrase;
    }

int Web::Details::HttpRequestBuffersCallback::GetStatusCode ( ) const [inline]

Definition at line 147 of file HttpRequest.h.

    {
        return statusCode;
    }

int Web::Details::HttpRequestBuffersCallback::GetStatusCode ( ) const [inline]

Definition at line 147 of file HttpRequest.h.

    {
        return statusCode;
    }

int Web::Details::HttpRequestBuffersCallback::GetStatusCode ( ) const [inline]

Definition at line 144 of file HttpRequest.h.

            {
                return statusCode;
            }

int Web::Details::HttpRequestBuffersCallback::GetStatusCode ( ) const [inline]

Definition at line 147 of file HttpRequest.h.

    {
        return statusCode;
    }

int Web::Details::HttpRequestBuffersCallback::GetStatusCode ( ) const [inline]

Definition at line 147 of file HttpRequest.h.

    {
        return statusCode;
    }

bool Web::Details::HttpRequestBuffersCallback::IsResponseReceived ( ) const [inline]

Definition at line 157 of file HttpRequest.h.

    {
        return responseReceived;
    }

bool Web::Details::HttpRequestBuffersCallback::IsResponseReceived ( ) const [inline]

Definition at line 157 of file HttpRequest.h.

    {
        return responseReceived;
    }

bool Web::Details::HttpRequestBuffersCallback::IsResponseReceived ( ) const [inline]

Definition at line 157 of file HttpRequest.h.

    {
        return responseReceived;
    }

bool Web::Details::HttpRequestBuffersCallback::IsResponseReceived ( ) const [inline]

Definition at line 157 of file HttpRequest.h.

    {
        return responseReceived;
    }

bool Web::Details::HttpRequestBuffersCallback::IsResponseReceived ( ) const [inline]

Definition at line 154 of file HttpRequest.h.

            {
                return responseReceived;
            }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | stream |
 | ) |  |  | [inline]

Definition at line 86 of file HttpRequest.h.

            {
                HRESULT hr = S_OK;

                // We must not propagate exceptions back to IXHR2.
                try
                {
                    // Store a reference on the stream so it can be accessed by the task.
                    dataStream = stream;

                    // The work must be done as fast as possible, and must not block this thread,
                    // for example, waiting on another event object.  Here we simply set an event
                    // that can be processed by another thread.
                    concurrency::critical_section::scoped_lock lock(dataEventLock);
                    dataEvent.set();
                }
                catch (std::bad_alloc&)
                {
                    hr = E_OUTOFMEMORY;
                }
                return hr;
            }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | stream |
 | ) |  |  | [inline]

Definition at line 89 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            // Store a reference on the stream so it can be accessed by the task.
            dataStream = stream;

            // The work must be done as fast as possible, and must not block this thread,
            // for example, waiting on another event object.  Here we simply set an event
            // that can be processed by another thread.
            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }
        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | stream |
 | ) |  |  | [inline]

Definition at line 89 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            // Store a reference on the stream so it can be accessed by the task.
            dataStream = stream;

            // The work must be done as fast as possible, and must not block this thread,
            // for example, waiting on another event object.  Here we simply set an event
            // that can be processed by another thread.
            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }
        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | stream |
 | ) |  |  | [inline]

Definition at line 89 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            // Store a reference on the stream so it can be accessed by the task.
            dataStream = stream;

            // The work must be done as fast as possible, and must not block this thread,
            // for example, waiting on another event object.  Here we simply set an event
            // that can be processed by another thread.
            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }
        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnDataAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | ISequentialStream * | stream |
 | ) |  |  | [inline]

Definition at line 89 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            // Store a reference on the stream so it can be accessed by the task.
            dataStream = stream;

            // The work must be done as fast as possible, and must not block this thread,
            // for example, waiting on another event object.  Here we simply set an event
            // that can be processed by another thread.
            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }
        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 120 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataHResult = hrError;
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 120 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataHResult = hrError;
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 117 of file HttpRequest.h.

            {
                HRESULT hr = S_OK;

                // We must not propagate exceptions back to IXHR2.
                try
                {
                    concurrency::critical_section::scoped_lock lock(dataEventLock);
                    dataHResult = hrError;
                    dataEvent.set();
                }
                catch (std::bad_alloc&)
                {
                    hr = E_OUTOFMEMORY;
                }

                return hr;
            }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 120 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataHResult = hrError;
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnError | ( | IXMLHTTPRequest2 * | ,
 |  | HRESULT | hrError |
 | ) |  |  | [inline]

Definition at line 120 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataHResult = hrError;
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }

        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 68 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;

            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }
        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 65 of file HttpRequest.h.

            {
                HRESULT hr = S_OK;

                // We must not propagate exceptions back to IXHR2.
                try
                {
                    this->statusCode = statusCode;
                    this->reasonPhrase = reasonPhrase;

                    concurrency::critical_section::scoped_lock lock(dataEventLock);
                    dataEvent.set();
                }
                catch (std::bad_alloc&)
                {
                    hr = E_OUTOFMEMORY;
                }
                return hr;
            }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 68 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;

            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }
        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 68 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;

            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }
        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnHeadersAvailable | ( | IXMLHTTPRequest2 * | ,
 |  | DWORD | statusCode,
 |  | PCWSTR | reasonPhrase |
 | ) |  |  | [inline]

Definition at line 68 of file HttpRequest.h.

    {
        HRESULT hr = S_OK;

        // We must not propagate exceptions back to IXHR2.
        try
        {
            this->statusCode = statusCode;
            this->reasonPhrase = reasonPhrase;

            concurrency::critical_section::scoped_lock lock(dataEventLock);
            dataEvent.set();
        }
        catch (std::bad_alloc&)
        {
            hr = E_OUTOFMEMORY;
        }
        return hr;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 59 of file HttpRequest.h.

            {
                return S_OK;
            }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 62 of file HttpRequest.h.

    {
        return S_OK;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 62 of file HttpRequest.h.

    {
        return S_OK;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 62 of file HttpRequest.h.

    {
        return S_OK;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnRedirect | ( | IXMLHTTPRequest2 * | ,
 |  | PCWSTR |  |
 | ) |  |  | [inline]

Definition at line 62 of file HttpRequest.h.

    {
        return S_OK;
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | xhr,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 110 of file HttpRequest.h.

            {
                responseReceived = true;
                return OnDataAvailable(xhr, responseStream);
            }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | xhr,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 113 of file HttpRequest.h.

    {
        responseReceived = true;
        return OnDataAvailable(xhr, responseStream);
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | xhr,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 113 of file HttpRequest.h.

    {
        responseReceived = true;
        return OnDataAvailable(xhr, responseStream);
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | xhr,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 113 of file HttpRequest.h.

    {
        responseReceived = true;
        return OnDataAvailable(xhr, responseStream);
    }

IFACEMETHODIMP Web::Details::HttpRequestBuffersCallback::OnResponseReceived | ( | IXMLHTTPRequest2 * | xhr,
 |  | ISequentialStream * | responseStream |
 | ) |  |  | [inline]

Definition at line 113 of file HttpRequest.h.

    {
        responseReceived = true;
        return OnDataAvailable(xhr, responseStream);
    }

unsigned int Web::Details::HttpRequestBuffersCallback::ReadData | ( | _Out_writes_(outputBufferSize) byte * | outputBuffer,
 |  | unsigned int | outputBufferSize
 | ) |  |

Definition at line 250 of file HttpRequest.cpp.

{
    // Lock the data event while doing the read, to ensure that any bytes we don't read will
    // result in the correct event getting triggered.
    concurrency::critical_section::scoped_lock lock(dataEventLock);

    ULONG bytesRead;
    CheckHResult(dataStream.Get()->Read(outputBuffer, outputBufferSize, &bytesRead));
    if (bytesRead < outputBufferSize)
    {
        // We need to reset the data event, which we can only do by creating a new one.
        dataEvent = task_completion_event<void>();
    }

    return bytesRead;
}

unsigned int Web::Details::HttpRequestBuffersCallback::ReadData | ( | _Out_writes_(outputBufferSize) byte * | outputBuffer,
 |  | unsigned int | outputBufferSize
 | ) |  |
unsigned int Web::Details::HttpRequestBuffersCallback::ReadData | ( | _Out_writes_(outputBufferSize) byte * | outputBuffer,
 |  | unsigned int | outputBufferSize
 | ) |  |
unsigned int Web::Details::HttpRequestBuffersCallback::ReadData | ( | _Out_writes_(outputBufferSize) byte * | outputBuffer,
 |  | unsigned int | outputBufferSize
 | ) |  |
unsigned int Web::Details::HttpRequestBuffersCallback::ReadData | ( | _Out_writes_(outputBufferSize) byte * | outputBuffer,
 |  | unsigned int | outputBufferSize
 | ) |  |

Member Data Documentation

concurrency::cancellation_token Web::Details::HttpRequestBuffersCallback::cancellationToken [private]

Definition at line 179 of file HttpRequest.h.

concurrency::task_completion_event< void > Web::Details::HttpRequestBuffersCallback::dataEvent [private]

Definition at line 188 of file HttpRequest.h.

concurrency::critical_section Web::Details::HttpRequestBuffersCallback::dataEventLock [private]

Definition at line 189 of file HttpRequest.h.

HRESULT Web::Details::HttpRequestBuffersCallback::dataHResult [private]

Definition at line 193 of file HttpRequest.h.

Microsoft::WRL::ComPtr< ISequentialStream > Web::Details::HttpRequestBuffersCallback::dataStream [private]

Definition at line 196 of file HttpRequest.h.

std::wstring Web::Details::HttpRequestBuffersCallback::reasonPhrase [private]

Definition at line 200 of file HttpRequest.h.

concurrency::cancellation_token_registration Web::Details::HttpRequestBuffersCallback::registrationToken [private]

Definition at line 182 of file HttpRequest.h.

Microsoft::WRL::ComPtr< IXMLHTTPRequest2 > Web::Details::HttpRequestBuffersCallback::request [private]

Definition at line 185 of file HttpRequest.h.

bool Web::Details::HttpRequestBuffersCallback::responseReceived [private]

Definition at line 203 of file HttpRequest.h.

int Web::Details::HttpRequestBuffersCallback::statusCode [private]

Definition at line 199 of file HttpRequest.h.

The documentation for this class was generated from the following files:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.h
  • Certificate enrollment/C++/HttpRequest.h
  • HttpClient/C++/HttpRequest.h
  • Search contract/C++/HttpRequest.h
  • Windows account authorization/C++/HttpRequest.h
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.cpp
  • Certificate enrollment/C++/HttpRequest.cpp
  • HttpClient/C++/HttpRequest.cpp
  • Search contract/C++/HttpRequest.cpp
  • Windows account authorization/C++/HttpRequest.cpp
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web::HttpRequest Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Web
  • Web::HttpRequest
Public Member Functions | Static Public Member Functions | Private Member Functions | Private Attributes

Web::HttpRequest Class Reference

#include "HttpRequest.h"

List of all members.

Public Member Functions

HttpRequest ()
HttpRequest ()
HttpRequest ()
HttpRequest ()
HttpRequest ()
concurrency::task< std::wstring > | GetAsync (Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | GetAsync (Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | GetAsync (Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | GetAsync (Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | GetAsync (Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
std::wstring const & | GetReasonPhrase () const
std::wstring const & | GetReasonPhrase () const
std::wstring const & | GetReasonPhrase () const
std::wstring const & | GetReasonPhrase () const
std::wstring const & | GetReasonPhrase () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
int | GetStatusCode () const
concurrency::task< std::wstring > | HttpRequest::PostAsync (Windows::Foundation::Uri^uri, PCWSTR contentType, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
bool | IsResponseComplete () const
bool | IsResponseComplete () const
bool | IsResponseComplete () const
bool | IsResponseComplete () const
bool | IsResponseComplete () const
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< std::wstring > | PostAsync (Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< void > | ReadAsync (Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead)
concurrency::task< void > | ReadAsync (Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead)
concurrency::task< void > | ReadAsync (Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead)
concurrency::task< void > | ReadAsync (Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead)
concurrency::task< void > | ReadAsync (Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead)
concurrency::task< void > | SendAsync (const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< void > | SendAsync (const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< void > | SendAsync (const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< void > | SendAsync (const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())
concurrency::task< void > | SendAsync (const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none())

Static Public Member Functions

static void | CreateMemoryStream (IStream **stream)
static void | CreateMemoryStream (IStream **stream)
static void | CreateMemoryStream (IStream **stream)
static void | CreateMemoryStream (IStream **stream)
static void | CreateMemoryStream (IStream **stream)

Private Member Functions

concurrency::task< std::wstring > | DownloadAsync (PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend)
concurrency::task< std::wstring > | DownloadAsync (PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend)
concurrency::task< std::wstring > | DownloadAsync (PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend)
concurrency::task< std::wstring > | DownloadAsync (PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend)
concurrency::task< std::wstring > | DownloadAsync (PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend)

Private Attributes

Microsoft::WRL::ComPtr
< Details::HttpRequestBuffersCallback > 		buffersCallback
std::wstring | reasonPhrase
bool | responseComplete
int | statusCode

Detailed Description

Definition at line 210 of file HttpRequest.h.

Constructor & Destructor Documentation

HttpRequest::HttpRequest ( )

Definition at line 276 of file HttpRequest.cpp.

                         : responseComplete(true), statusCode(200)
{
}

Web::HttpRequest::HttpRequest ( )
Web::HttpRequest::HttpRequest ( )
Web::HttpRequest::HttpRequest ( )
Web::HttpRequest::HttpRequest ( )

Member Function Documentation

void HttpRequest::CreateMemoryStream ( IStream ** stream ) [static]

Definition at line 335 of file HttpRequest.cpp.

{
    auto randomAccessStream = ref new Windows::Storage::Streams::InMemoryRandomAccessStream();
    CheckHResult(CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(stream)));
}

static void Web::HttpRequest::CreateMemoryStream ( IStream ** stream ) [static]
static void Web::HttpRequest::CreateMemoryStream ( IStream ** stream ) [static]
static void Web::HttpRequest::CreateMemoryStream ( IStream ** stream ) [static]
static void Web::HttpRequest::CreateMemoryStream ( IStream ** stream ) [static]
concurrency::task<std::wstring> Web::HttpRequest::DownloadAsync | ( | PCWSTR | httpMethod,
 |  | PCWSTR | uri,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamBytesToSend |
 | ) |  |  | [private]
concurrency::task<std::wstring> Web::HttpRequest::DownloadAsync | ( | PCWSTR | httpMethod,
 |  | PCWSTR | uri,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamBytesToSend |
 | ) |  |  | [private]
concurrency::task<std::wstring> Web::HttpRequest::DownloadAsync | ( | PCWSTR | httpMethod,
 |  | PCWSTR | uri,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamBytesToSend |
 | ) |  |  | [private]
concurrency::task<std::wstring> Web::HttpRequest::DownloadAsync | ( | PCWSTR | httpMethod,
 |  | PCWSTR | uri,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamBytesToSend |
 | ) |  |  | [private]
concurrency::task<std::wstring> Web::HttpRequest::DownloadAsync | ( | PCWSTR | httpMethod,
 |  | PCWSTR | uri,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamBytesToSend |
 | ) |  |  | [private]
concurrency::task<std::wstring> Web::HttpRequest::GetAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::GetAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::GetAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::GetAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::GetAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
std::wstring const& Web::HttpRequest::GetReasonPhrase ( ) const [inline]

Definition at line 220 of file HttpRequest.h.

    {
        return reasonPhrase;
    }

std::wstring const& Web::HttpRequest::GetReasonPhrase ( ) const [inline]

Definition at line 217 of file HttpRequest.h.

        {
            return reasonPhrase;
        }

std::wstring const& Web::HttpRequest::GetReasonPhrase ( ) const [inline]

Definition at line 220 of file HttpRequest.h.

    {
        return reasonPhrase;
    }

std::wstring const& Web::HttpRequest::GetReasonPhrase ( ) const [inline]

Definition at line 220 of file HttpRequest.h.

    {
        return reasonPhrase;
    }

std::wstring const& Web::HttpRequest::GetReasonPhrase ( ) const [inline]

Definition at line 220 of file HttpRequest.h.

    {
        return reasonPhrase;
    }

int Web::HttpRequest::GetStatusCode ( ) const [inline]

Definition at line 212 of file HttpRequest.h.

        {
            return statusCode;
        }

int Web::HttpRequest::GetStatusCode ( ) const [inline]

Definition at line 215 of file HttpRequest.h.

    {
        return statusCode;
    }

int Web::HttpRequest::GetStatusCode ( ) const [inline]

Definition at line 215 of file HttpRequest.h.

    {
        return statusCode;
    }

int Web::HttpRequest::GetStatusCode ( ) const [inline]

Definition at line 215 of file HttpRequest.h.

    {
        return statusCode;
    }

int Web::HttpRequest::GetStatusCode ( ) const [inline]

Definition at line 215 of file HttpRequest.h.

    {
        return statusCode;
    }

concurrency::task<std::wstring> Web::HttpRequest::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | PCWSTR | contentType,
 |  | const std::wstring & | str,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
bool Web::HttpRequest::IsResponseComplete ( ) const [inline]

Definition at line 223 of file HttpRequest.h.

        {
            return responseComplete;
        }

bool Web::HttpRequest::IsResponseComplete ( ) const [inline]

Definition at line 226 of file HttpRequest.h.

    {
        return responseComplete;
    }

bool Web::HttpRequest::IsResponseComplete ( ) const [inline]

Definition at line 226 of file HttpRequest.h.

    {
        return responseComplete;
    }

bool Web::HttpRequest::IsResponseComplete ( ) const [inline]

Definition at line 226 of file HttpRequest.h.

    {
        return responseComplete;
    }

bool Web::HttpRequest::IsResponseComplete ( ) const [inline]

Definition at line 226 of file HttpRequest.h.

    {
        return responseComplete;
    }

concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | const std::wstring & | str,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | const std::wstring & | str,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamSizeToSend,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamSizeToSend,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | const std::wstring & | str,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamSizeToSend,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamSizeToSend,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | const std::wstring & | str,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | const std::wstring & | str,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<std::wstring> Web::HttpRequest::PostAsync | ( | Windows::Foundation::Uri^ | uri,
 |  | PCWSTR | contentType,
 |  | IStream * | postStream,
 |  | uint64 | postStreamSizeToSend,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<void> Web::HttpRequest::ReadAsync | ( | Windows::Storage::Streams::IBuffer^ | readBuffer,
 |  | unsigned int | offsetInBuffer,
 |  | unsigned int | requestedBytesToRead
 | ) |  |
concurrency::task<void> Web::HttpRequest::ReadAsync | ( | Windows::Storage::Streams::IBuffer^ | readBuffer,
 |  | unsigned int | offsetInBuffer,
 |  | unsigned int | requestedBytesToRead
 | ) |  |
task< void > HttpRequest::ReadAsync | ( | Windows::Storage::Streams::IBuffer^ | readBuffer,
 |  | unsigned int | offsetInBuffer,
 |  | unsigned int | requestedBytesToRead
 | ) |  |

Definition at line 438 of file HttpRequest.cpp.

{
    if (offsetInBuffer + requestedBytesToRead > readBuffer->Capacity)
    {
        throw ref new InvalidArgumentException();
    }

    // Return a task that completes when a read completes.
    // We pass the callback to the continuation because the lifetime of the
    // callback must exceed the operation to ensure that cancellation
    // works correctly.
    return buffersCallback->CreateDataTask().then([this, readBuffer, offsetInBuffer, requestedBytesToRead]()
    {
        CheckHResult(buffersCallback->GetError());

        // Get a pointer to the location to copy data into.
        ComPtr<IBufferByteAccess> bufferByteAccess;
        CheckHResult(reinterpret_cast<IUnknown*>(readBuffer)->QueryInterface(IID_PPV_ARGS(&bufferByteAccess)));
        byte* outputBuffer; // Returned internal pointer, do not free this value.
        CheckHResult(bufferByteAccess->Buffer(&outputBuffer));

        // Copy bytes from the sequential stream into the buffer provided until
        // we reach the end of one or the other.
        readBuffer->Length = buffersCallback->ReadData(outputBuffer + offsetInBuffer, requestedBytesToRead);
        if (buffersCallback->IsResponseReceived() && (readBuffer->Length < requestedBytesToRead))
        {
            responseComplete = true;
        }
    });
}

concurrency::task<void> Web::HttpRequest::ReadAsync | ( | Windows::Storage::Streams::IBuffer^ | readBuffer,
 |  | unsigned int | offsetInBuffer,
 |  | unsigned int | requestedBytesToRead
 | ) |  |
concurrency::task<void> Web::HttpRequest::ReadAsync | ( | Windows::Storage::Streams::IBuffer^ | readBuffer,
 |  | unsigned int | offsetInBuffer,
 |  | unsigned int | requestedBytesToRead
 | ) |  |
concurrency::task<void> Web::HttpRequest::SendAsync | ( | const std::wstring & | httpMethod,
 |  | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<void> Web::HttpRequest::SendAsync | ( | const std::wstring & | httpMethod,
 |  | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<void> Web::HttpRequest::SendAsync | ( | const std::wstring & | httpMethod,
 |  | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<void> Web::HttpRequest::SendAsync | ( | const std::wstring & | httpMethod,
 |  | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |
concurrency::task<void> Web::HttpRequest::SendAsync | ( | const std::wstring & | httpMethod,
 |  | Windows::Foundation::Uri^ | uri,
 |  | concurrency::cancellation_token | cancellationToken = concurrency::cancellation_token::none()
 | ) |  |

Member Data Documentation

Microsoft::WRL::ComPtr< Details::HttpRequestBuffersCallback > Web::HttpRequest::buffersCallback [private]

Definition at line 282 of file HttpRequest.h.

std::wstring Web::HttpRequest::reasonPhrase [private]

Definition at line 285 of file HttpRequest.h.

bool Web::HttpRequest::responseComplete [private]

Definition at line 288 of file HttpRequest.h.

int Web::HttpRequest::statusCode [private]

Definition at line 284 of file HttpRequest.h.

The documentation for this class was generated from the following files:
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.h
  • Certificate enrollment/C++/HttpRequest.h
  • HttpClient/C++/HttpRequest.h
  • Search contract/C++/HttpRequest.h
  • Windows account authorization/C++/HttpRequest.h
  • Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.cpp
  • Certificate enrollment/C++/HttpRequest.cpp
  • HttpClient/C++/HttpRequest.cpp
  • Search contract/C++/HttpRequest.cpp
  • Windows account authorization/C++/HttpRequest.cpp
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: WICConvert Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

WICConvert Struct Reference

List of all members.

Public Attributes

GUID | source
GUID | target

Detailed Description

Definition at line 20 of file DirectXTexWIC.cpp.

Member Data Documentation

GUID WICConvert::source

Definition at line 22 of file DirectXTexWIC.cpp.

GUID WICConvert::target

Definition at line 23 of file DirectXTexWIC.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTexWIC.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: WICTranslate Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

WICTranslate Struct Reference

List of all members.

Public Attributes

DXGI_FORMAT | format
GUID | wic

Detailed Description

Definition at line 19 of file DirectXTexUtil.cpp.

Member Data Documentation

DXGI_FORMAT WICTranslate::format

Definition at line 22 of file DirectXTexUtil.cpp.

GUID WICTranslate::wic

Definition at line 21 of file DirectXTexUtil.cpp.

The documentation for this struct was generated from the following file:
  • Direct3D resource loading/C++/texconv/DirectXTexUtil.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: WorldCeilingMesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

WorldCeilingMesh Class Reference

#include "WorldMesh.h"

List of all members.

Public Attributes

internal __pad0__: WorldCeilingMesh(_In_ ID3D11Device *device)

Detailed Description

Definition at line 19 of file WorldMesh.h.

Member Data Documentation

internal WorldCeilingMesh::__pad0__

Definition at line 22 of file WorldMesh.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/WorldMesh.h
  • XAML DirectX 3D shooting game/C++/WorldMesh.h
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: WorldFloorMesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

WorldFloorMesh Class Reference

#include "WorldMesh.h"

List of all members.

Public Attributes

internal __pad0__: WorldFloorMesh(_In_ ID3D11Device *device)

Detailed Description

Definition at line 30 of file WorldMesh.h.

Member Data Documentation

internal WorldFloorMesh::__pad0__

Definition at line 33 of file WorldMesh.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/WorldMesh.h
  • XAML DirectX 3D shooting game/C++/WorldMesh.h
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: WorldWallsMesh Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Public Attributes

WorldWallsMesh Class Reference

#include "WorldMesh.h"

List of all members.

Public Attributes

internal __pad0__: WorldWallsMesh(_In_ ID3D11Device *device)

Detailed Description

Definition at line 41 of file WorldMesh.h.

Member Data Documentation

internal WorldWallsMesh::__pad0__

Definition at line 44 of file WorldMesh.h.

The documentation for this class was generated from the following files:
  • DirectX 3D shooting game/C++/WorldMesh.h
  • XAML DirectX 3D shooting game/C++/WorldMesh.h
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Wrapper::DspSettings Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Wrapper
  • Wrapper::DspSettings
Public Attributes

Wrapper::DspSettings Struct Reference

#include "WinRTComponent.h"

List of all members.

Public Attributes

BOOL | isEnabled
unsigned int | percentOfScreen

Detailed Description

Definition at line 15 of file WinRTComponent.h.

Member Data Documentation

BOOL Wrapper::DspSettings::isEnabled

Definition at line 18 of file WinRTComponent.h.

unsigned int Wrapper::DspSettings::percentOfScreen

Definition at line 17 of file WinRTComponent.h.

The documentation for this struct was generated from the following file:
  • Windows Store device app for camera/C++/Wrapper/WinRTComponent.h
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Wrapper::sealed Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • Wrapper
  • Wrapper::sealed
Public Member Functions | Private Member Functions | Private Attributes

Wrapper::sealed Class Reference

#include "WinRTComponent.h"

List of all members.

Public Member Functions

void | Disable ()
void | Enable ()
DspSettings GetDspSetting ()
bool | Initialize (Object^o)
void | UpdateDsp (int percentOfScreen)
WinRTComponent ()

Private Member Functions

~WinRTComponent ()

Private Attributes

Microsoft::WRL::ComPtr< IMft0 > | m_spImpl

Detailed Description

Definition at line 21 of file WinRTComponent.h.

Constructor & Destructor Documentation

Wrapper::sealed::~WinRTComponent ( ) [private]

Member Function Documentation

void Wrapper::sealed::Disable ( )
void Wrapper::sealed::Enable ( )
DspSettings Wrapper::sealed::GetDspSetting ( )
bool Wrapper::sealed::Initialize ( Object^ o )
void Wrapper::sealed::UpdateDsp ( int percentOfScreen )
Wrapper::sealed::WinRTComponent ( )

Member Data Documentation

Microsoft::WRL::ComPtr<IMft0> Wrapper::sealed::m_spImpl [private]

Definition at line 35 of file WinRTComponent.h.

The documentation for this class was generated from the following file:
  • Windows Store device app for camera/C++/Wrapper/WinRTComponent.h
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2SoundPlayer Class Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
Classes | Public Member Functions | Private Attributes

XAudio2SoundPlayer Class Reference

#include "XAudio2SoundPlayer.h"

List of all members.

Classes

struct | ImplData

Public Member Functions

XAudio2SoundPlayer (uint32 sampleRate)
~XAudio2SoundPlayer ()
size_t | AddSound (_In_ WAVEFORMATEX *format, _In_ Platform::Array< byte >^data)
size_t | GetSoundCount () const
bool | IsSoundPlaying (size_t index) const
bool | PlaySound (size_t index)
void | Resume ()
bool | StopSound (size_t index)
void | Suspend ()

Private Attributes

interface IXAudio2 * | m_audioEngine
interface IXAudio2MasteringVoice * | m_masteringVoice
std::vector< std::shared_ptr
< ImplData > > 		m_soundList

Detailed Description

Definition at line 17 of file XAudio2SoundPlayer.h.

Constructor & Destructor Documentation

XAudio2SoundPlayer::XAudio2SoundPlayer ( uint32 sampleRate )

Definition at line 107 of file XAudio2SoundPlayer.cpp.

                                                        :
    m_soundList()
{
    // Create the XAudio2 Engine
    UINT32 flags = 0;
    DX::ThrowIfFailed(
        XAudio2Create(&m_audioEngine, flags)
        );

    // Create the mastering voice
    DX::ThrowIfFailed(
        m_audioEngine->CreateMasteringVoice(
            &m_masteringVoice,
            XAUDIO2_DEFAULT_CHANNELS,
            sampleRate
            )
        );
}

XAudio2SoundPlayer::~XAudio2SoundPlayer ( )

Definition at line 132 of file XAudio2SoundPlayer.cpp.

{
    if (m_masteringVoice != nullptr)
    {
        m_masteringVoice->DestroyVoice();
        m_masteringVoice = nullptr;
    }

    if (m_audioEngine != nullptr)
    {
        m_audioEngine->Release();
        m_audioEngine = nullptr;
    }
}

Member Function Documentation

size_t XAudio2SoundPlayer::AddSound | ( | _In_ WAVEFORMATEX * | format,
 |  | _In_ Platform::Array< byte >^ | data
 | ) |  |

Definition at line 151 of file XAudio2SoundPlayer.cpp.

{
    //
    // Allocate the implementation data
    //
    std::shared_ptr<ImplData> implData(new ImplData(data));

    //
    // Create the source voice
    //
    DX::ThrowIfFailed(
        m_audioEngine->CreateSourceVoice(
            &implData->sourceVoice,
            format,
            0,
            XAUDIO2_DEFAULT_FREQ_RATIO,
            reinterpret_cast<IXAudio2VoiceCallback*>(&implData->callbackHander),
            nullptr,
            nullptr
            )
        );

    //
    // Add to the list and return its index
    //
    m_soundList.push_back(implData);
    return (m_soundList.size() - 1);
}

size_t XAudio2SoundPlayer::GetSoundCount ( ) const

Definition at line 250 of file XAudio2SoundPlayer.cpp.

{
    return m_soundList.size();
}

bool XAudio2SoundPlayer::IsSoundPlaying ( size_t index ) const

Definition at line 241 of file XAudio2SoundPlayer.cpp.

{
    return m_soundList[index]->isPlaying;
}

bool XAudio2SoundPlayer::PlaySound ( size_t index )

Definition at line 187 of file XAudio2SoundPlayer.cpp.

{
    //
    // Setup buffer
    //
    XAUDIO2_BUFFER playBuffer = { 0 };
    std::shared_ptr<ImplData> soundData = m_soundList[index];
    playBuffer.AudioBytes = soundData->playData->Length;
    playBuffer.pAudioData = soundData->playData->Data;
    playBuffer.Flags = XAUDIO2_END_OF_STREAM;

    //
    // In case it is playing, stop it and flush the buffers.
    //
    HRESULT hr = soundData->sourceVoice->Stop();
    if (SUCCEEDED(hr))
    {
        hr = soundData->sourceVoice->FlushSourceBuffers();
    }

    //
    // Submit the sound buffer and (re)start (ignore any 'stop' failures)
    //
    hr = soundData->sourceVoice->SubmitSourceBuffer(&playBuffer);
    if (SUCCEEDED(hr))
    {
        hr = soundData->sourceVoice->Start(0, XAUDIO2_COMMIT_NOW);
    }

    return SUCCEEDED(hr);
}

void XAudio2SoundPlayer::Resume ( )

Definition at line 268 of file XAudio2SoundPlayer.cpp.

{
    DX::ThrowIfFailed(
        m_audioEngine->StartEngine()
        );
}

bool XAudio2SoundPlayer::StopSound ( size_t index )

Definition at line 223 of file XAudio2SoundPlayer.cpp.

{
    std::shared_ptr<ImplData> soundData = m_soundList[index];

    HRESULT hr = soundData->sourceVoice->Stop();
    if (SUCCEEDED(hr))
    {
        hr = soundData->sourceVoice->FlushSourceBuffers();
    }

    return SUCCEEDED(hr);
}

void XAudio2SoundPlayer::Suspend ( )

Definition at line 259 of file XAudio2SoundPlayer.cpp.

{
    m_audioEngine->StopEngine();
}

Member Data Documentation

interface IXAudio2* XAudio2SoundPlayer::m_audioEngine [private]

Definition at line 35 of file XAudio2SoundPlayer.h.

interface IXAudio2MasteringVoice* XAudio2SoundPlayer::m_masteringVoice [private]

Definition at line 36 of file XAudio2SoundPlayer.h.

std::vector<std::shared_ptr<ImplData> > XAudio2SoundPlayer::m_soundList [private]

Definition at line 37 of file XAudio2SoundPlayer.h.

The documentation for this class was generated from the following files:
  • XAudio2 audio file playback/C++/XAudio2SoundPlayer.h
  • XAudio2 audio file playback/C++/XAudio2SoundPlayer.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2SoundPlayer::ImplData Struct Reference

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • XAudio2SoundPlayer
  • XAudio2SoundPlayer::ImplData
Public Member Functions | Public Attributes

XAudio2SoundPlayer::ImplData Struct Reference

List of all members.

Public Member Functions

~ImplData ()
ImplData::ImplData (Platform::Array< byte >^data)

Public Attributes

SoundCallbackHander | callbackHander
bool | isPlaying
Platform::Array< byte > | playData
IXAudio2SourceVoice * | sourceVoice

Detailed Description

Definition at line 75 of file XAudio2SoundPlayer.cpp.

Constructor & Destructor Documentation

XAudio2SoundPlayer::ImplData::~ImplData ( ) [inline]

Definition at line 85 of file XAudio2SoundPlayer.cpp.

    {
        if (sourceVoice)
        {
            sourceVoice->DestroyVoice();
            sourceVoice = nullptr;
        }
    }

Member Function Documentation

XAudio2SoundPlayer::ImplData::ImplData::ImplData ( Platform::Array< byte >^ data ) [inline]

Definition at line 77 of file XAudio2SoundPlayer.cpp.

                                                :
        sourceVoice(nullptr),
        playData(data),
        isPlaying(false),
        callbackHander(&isPlaying)
    {
    }

Member Data Documentation

SoundCallbackHander XAudio2SoundPlayer::ImplData::callbackHander

Definition at line 97 of file XAudio2SoundPlayer.cpp.

bool XAudio2SoundPlayer::ImplData::isPlaying

Definition at line 96 of file XAudio2SoundPlayer.cpp.

Platform::Array<byte> XAudio2SoundPlayer::ImplData::playData

Definition at line 95 of file XAudio2SoundPlayer.cpp.

IXAudio2SourceVoice* XAudio2SoundPlayer::ImplData::sourceVoice

Definition at line 94 of file XAudio2SoundPlayer.cpp.

The documentation for this struct was generated from the following file:
  • XAudio2 audio file playback/C++/XAudio2SoundPlayer.cpp
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hierarchical Index

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Class Hierarchy

This inheritance list is sorted roughly, but not completely, alphabetically:
  • _BAR_GRAPH_STATE
  • _FILE_PLAYBACK
  • _SDKMESHVERTEXELEMENT
  • _SWITCH_STATE
  • abstract
  • AccountPictureName::App
  • AccountPictureName::Common::LayoutAwarePage
  • AccountPictureName::MainPage
  • AccountPictureName::Scenario
  • AccountPictureName::sealed
  • aligned_deleter
  • Alignment
  • AmpPixel
  • AnimateCirclePosition
  • AnimateLineListPosition
  • AnimateLinePosition
  • Animation< T >
    • EaseInExponentialAnimation< T >
    • EaseInOutExponentialAnimation< T >
    • EaseOutExponentialAnimation< T >
    • LinearAnimation< T >
  • anonymous_namespace{SoundFileReader.cpp}::ChunkHeader
  • anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • AntSystem::Ant
  • AntSystem::Edge
  • AntSystem::LatLong
  • AntSystem::Node
  • AppBarControl::App
  • AppBarControl::Common::LayoutAwarePage
  • AppBarControl::MainPage
  • AppBarControl::Scenario
  • AppBarControl::sealed
  • AssociationLaunching::sealed
  • AsteroidData
  • Audio
  • AudioController
  • AudioEngineCallbacks
  • AutoLock
  • AutoThrottle
  • Background::sealed
  • BackgroundTask::sealed
  • BackgroundTasks::sealed
  • BasicCamera
  • BasicLoader
  • BasicReaderWriter
  • BasicShapes
  • BasicSound
  • BasicSprites::InstanceData
  • BasicSprites::InstancingVertex
  • BasicSprites::ReplicationVertex
  • BasicSprites::SpriteBatch
  • BasicSprites::SpriteRunInfo
  • BasicSprites::TextureMapElement
  • BasicTimer
  • BasicVertex
  • Buffer
  • BumpMapping
  • Camera
  • CAppWindowProvider
  • CAsyncState
  • CAutoDXDevLockBase< DevManager, DevInterface >
  • CAutoDXDevLockBase< IMFDXGIDeviceManager, ID3D11Device >
    • CAutoDXGILock
  • DirectX::CBits< 16 >
    • DirectX::D3DX_BC6H
    • DirectX::D3DX_BC7
  • CCopyModule
  • CDecoder
  • CDocumentSource
  • CGrayscale
  • CInvert
  • CInvertModule
  • Clipboard::App
  • Clipboard::Common::LayoutAwarePage
  • Clipboard::MainPage
  • Clipboard::Scenario
  • Clipboard::sealed
  • CMPEG1Stream
  • CMPEG1Stream::SourceLock
  • Collision
  • CollisionInfo
  • ComAutoRelease
  • ComBase< InterfaceChain >
  • CommandListRenderer
  • CompositeModes
  • ComputeCB
  • ComputeDoubleCB
  • ConstantBuffer
  • ConstantBufferChangeOnResize
  • ConstantBufferChangesEveryFrame
  • ConstantBufferChangesEveryPrim
  • ConstantBufferLayoutForDX9BrightPassPixelShader
  • ConstantBufferLayoutForGlowPixelShader
  • ConstantBufferNeverChanges
  • Contact
  • ContactPicker::App
  • ContactPicker::Common::LayoutAwarePage
  • ContactPicker::MainPage
  • ContactPicker::MainPagePicker
  • ContactPicker::Scenario
  • ContactPicker::sealed
  • ContactPicker::sealed::SampleContact
  • ContentImageSource
  • ContentImageSource::ImageSourceDrawHelper
  • ConvolveMatrixEffect
  • CoreWindowEvents
  • CPolarEffect
  • CppSamplesUtils::SuspensionManager
  • CredentialPickerCPP::sealed
  • CritSec
  • CStreamState
  • CTriColorWindowFactory
  • CustomDeviceAccess::DeviceList
  • CustomDeviceAccess::DeviceListEntry
  • CustomTextRenderer
  • CylinderMesh
  • D2D3DTransforms::sealed
  • D2D3DTransformsRenderer
  • D2DBasicAnimation
  • D2DEffectsHelloWorld
  • D2DEffectsOnPrimitives
  • D2DFactoryLock
  • D2DInterpolationModes
  • D2DLightingEffects::sealed
  • D2DLightingEffectsRenderer
  • D2DPerspectiveTransform
  • D2DTextAnimation
  • D3DPostProcessing
  • DatagramSocketSample::Common::LayoutAwarePage
  • DatagramSocketSample::MainPage
  • DatagramSocketSample::Scenario
  • DatagramSocketSample::sealed
  • DDS_HEADER
  • DDS_HEADER_DXT10
  • DDS_PIXELFORMAT
  • DeviceAppForPrinters::App
  • DeviceAppForPrinters::MainPage
  • DeviceAppForPrinters::Scenario
  • DeviceAppForWebcam::Common::LayoutAwarePage
  • DeviceAppForWebcam::MainPage
  • DeviceAppForWebcam::sealed
  • Direct3DTutorial
  • Direct3DTutorialFrameworkView
  • Direct3DTutorialFrameworkViewSource
  • DirectX::BC4_SNORM
  • DirectX::BC4_UNORM
  • DirectX::Blob
  • DirectX::CBits< SizeInBytes >
  • DirectX::ConvertData
  • DirectX::D3DX_BC1
  • DirectX::D3DX_BC2
  • DirectX::D3DX_BC3
  • DirectX::D3DX_BC6H::EncodeParams
  • DirectX::D3DX_BC6H::ModeDescriptor
  • DirectX::D3DX_BC6H::ModeInfo
  • DirectX::D3DX_BC7::EncodeParams
  • DirectX::D3DX_BC7::ModeInfo
  • DirectX::DDS_HEADER
  • DirectX::DDS_HEADER_DXT10
  • DirectX::DDS_PIXELFORMAT
  • DirectX::HDRColorA
  • DirectX::HDREndPntPair
  • DirectX::Image
  • DirectX::INTColor
  • DirectX::INTEndPntPair
  • DirectX::LDRColorA
  • DirectX::LDREndPntPair
  • DirectX::LegacyDDS
  • DirectX::Rect
  • DirectX::ScratchImage
  • DirectX::TexMetadata
  • DirectXApp
  • DirectXAppSource
  • DirectXFractal
  • Document
  • DrawRectCB
  • DWriteCustomTextRenderer
  • DWriteHelloWorld
  • DWriteHitTesting
  • DWriteInlineObject
  • DWriteParagraphText
  • DWriteVerticalText
  • DxgiRotation
  • EdgeGestureSample::sealed
  • Element
    • Design
    • ImageFrame
    • Layer
    • Page
      • MediaExtensionsCS::ScenarioInput1
      • MediaExtensionsCS::ScenarioInput2
      • MediaExtensionsCS::ScenarioInput3
      • MediaExtensionsCS::ScenarioInput4
      • MediaExtensionsCS::ScenarioList
      • MediaExtensionsCS::ScenarioOutput1
      • MediaExtensionsCS::ScenarioOutput2
      • MediaExtensionsCS::ScenarioOutput3
      • MediaExtensionsCS::ScenarioOutput4
      • PrintSample::BasePrintPage
      • SDKTemplate::Common::LayoutAwarePage
        • CustomDeviceAccess::DeviceAsync
        • MediaCapture::AudioCapture
        • MediaCapture::BasicCapture
        • MediaStreamSource::AudioSource
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SDKTemplate::MainPage
        • SimpleCommunication::LowLatency
        • SimpleCommunication::VideoChat
      • SDKTemplate::Common::LayoutAwarePage
      • SDKTemplateCS::MainPage
    • PageRoll
    • Rectangle
      • List< T >
      • List< SourceOp * >
        • ComPtrList< SourceOp >
        • ComPtrList< SourceOp >
        • ComPtrList< SourceOp >
      • List< T * >
        • ComPtrList< T, NULLABLE >
        • ComPtrList< T, NULLABLE >
        • ComPtrList< T, NULLABLE >
    • Resource
      • Image
      • Text
    • Story
    • TextFrame
  • ElementBase
    • TextElement
      • CountdownTimer
      • HighScoreTable
      • StopwatchTimer
      • TextButton
  • ExtrudedTextRenderer
  • Extruder
  • Extruder::ExtrudingSink
  • Extruder::ExtrudingSink::Vertex2D
  • FaceMesh
  • FontEnumeration::sealed
  • FontFileStream
  • FontLoader
  • FPSCounter
  • FPSCounter::AtlasText
  • FractalBufferElement
  • FractalVertex
  • FrameData
  • FrameProcessing
  • GameConfig
  • GameHud
  • GameInfoOverlay
  • GameObject
    • Cylinder
    • Cylinder
    • Face
    • Face
    • Sphere
    • Sphere
  • GameRenderer
  • GameTimer
  • GeometryRealization
  • GeometryRealizationFactory
  • GeometryRealizationSample
  • handle_closer
  • HighScoreEntry
  • Hilo::CalendarExtensions
  • Hilo::Common::BindableBase
    • Hilo::ViewModelBase
      • Hilo::ImageBase
        • Hilo::sealed
        • Hilo::sealed
        • Hilo::sealed
      • Hilo::sealed
      • Hilo::sealed
      • Hilo::sealed
  • Hilo::Common::LayoutAwarePage
    • Hilo::HiloPage
  • Hilo::Common::sealed
  • Hilo::ExceptionPolicy
    • Hilo::DebugLoggingExceptionPolicy
  • Hilo::ExceptionPolicyFactory
  • Hilo::ExifExtensions
  • Hilo::ImageNavigationData
  • Hilo::IMonthBlock
    • Hilo::sealed
  • Hilo::IPhoto
    • Hilo::sealed
  • Hilo::IPhotoGroup
    • Hilo::NullPhotoGroup
    • Hilo::sealed
    • Hilo::sealed
  • Hilo::IResizable
    • Hilo::sealed
    • Hilo::sealed
  • Hilo::IResourceLoader
    • Hilo::sealed
  • Hilo::IYearGroup
    • Hilo::sealed
  • Hilo::ObservableQuery
    • Hilo::Repository
      • Hilo::FileSystemRepository
  • Hilo::ObserveException< T >
  • Hilo::PhotoCache
  • Hilo::PhotoPathComparer
  • Hilo::RandomPhotoSelector
  • Hilo::ThumbnailGenerator
  • Hilo::TileUpdateScheduler
  • Hilo::WideFiveImageTile
  • HttpRequestStringCallback
  • IDWriteTextAnalysisSource1
    • QiList< IDWriteTextAnalysisSource1, QiList< IDWriteTextAnalysisSink1, QiList< IUnknown > > >
      • ComBase< QiList< IDWriteTextAnalysisSource1, QiList< IDWriteTextAnalysisSink1, QiList< IUnknown > > > >
        • TextAnalysis
  • ImageFile
  • ImageRenderer
  • IMFAsyncCallback
    • AsyncCallback< T >
    • AsyncCallback< T >
    • AsyncCallback< T >
    • AsyncCallback< CMPEG1Source >
    • AsyncCallback< CMPEG1Source >
    • AsyncCallback< CMPEG1Source >
  • IMft0Vtbl
  • IndexTriplet
  • InkRenderer
  • InlineImage
  • IRenderer
  • LanguageFontCPP::sealed
  • Level1
    • Level2
    • Level2
  • Level3
    • Level4
    • Level4
    • Level5
      • Level6
      • Level6
    • Level5
  • LineSegment
  • List< T >::Node
  • List< T >::POSITION
  • LoadScreen
  • LockScreenAppsCPP::sealed
  • LonLatController
  • Magazine::sealed
  • ManipulatableObject
    • sealed
    • sealed
  • MarbleMaze
  • Material
  • Matrix4x4< T >
  • MediaEngineNotify
  • MediaExtensionsCPP::App
  • MediaExtensionsCPP::sealed
  • MediaExtensionsCS::App
  • MediaReader
  • MediaStreamer
  • MediaStreamSource::PcmSource
  • MemDelete
  • MEPlayer
  • MoveLookController
  • MPEG1AudioFrameHeader
  • MPEG1PacketHeader
  • MPEG1StreamHeader
  • MPEG1SystemHeader
  • MPEG1VideoSeqHeader
  • NetworkStatusTask::sealed
  • NoOp< T >
  • NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
  • NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
  • NotificationsExtensions::NotificationBase
    • NotificationsExtensions::TileContent::TileNotificationBase
      • NotificationsExtensions::TileContent::TileSquareBase
        • NotificationsExtensions::TileContent::TileSquareBlock
        • NotificationsExtensions::TileContent::TileSquareBlock
        • NotificationsExtensions::TileContent::TileSquareImage
        • NotificationsExtensions::TileContent::TileSquareImage
        • NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
        • NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
        • NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
        • NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
        • NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
        • NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
        • NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
        • NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
        • NotificationsExtensions::TileContent::TileSquareText01
        • NotificationsExtensions::TileContent::TileSquareText01
        • NotificationsExtensions::TileContent::TileSquareText02
        • NotificationsExtensions::TileContent::TileSquareText02
        • NotificationsExtensions::TileContent::TileSquareText03
        • NotificationsExtensions::TileContent::TileSquareText03
        • NotificationsExtensions::TileContent::TileSquareText04
        • NotificationsExtensions::TileContent::TileSquareText04
      • NotificationsExtensions::TileContent::TileSquareBase
      • NotificationsExtensions::TileContent::TileWideBase
        • NotificationsExtensions::TileContent::TileWideBlockAndText01
        • NotificationsExtensions::TileContent::TileWideBlockAndText01
        • NotificationsExtensions::TileContent::TileWideBlockAndText02
        • NotificationsExtensions::TileContent::TileWideBlockAndText02
        • NotificationsExtensions::TileContent::TileWideImage
        • NotificationsExtensions::TileContent::TileWideImage
        • NotificationsExtensions::TileContent::TileWideImageAndText01
        • NotificationsExtensions::TileContent::TileWideImageAndText01
        • NotificationsExtensions::TileContent::TileWideImageAndText02
        • NotificationsExtensions::TileContent::TileWideImageAndText02
        • NotificationsExtensions::TileContent::TileWideImageCollection
        • NotificationsExtensions::TileContent::TileWideImageCollection
        • NotificationsExtensions::TileContent::TileWidePeekImage01
        • NotificationsExtensions::TileContent::TileWidePeekImage01
        • NotificationsExtensions::TileContent::TileWidePeekImage02
        • NotificationsExtensions::TileContent::TileWidePeekImage02
        • NotificationsExtensions::TileContent::TileWidePeekImage03
        • NotificationsExtensions::TileContent::TileWidePeekImage03
        • NotificationsExtensions::TileContent::TileWidePeekImage04
        • NotificationsExtensions::TileContent::TileWidePeekImage04
        • NotificationsExtensions::TileContent::TileWidePeekImage05
        • NotificationsExtensions::TileContent::TileWidePeekImage05
        • NotificationsExtensions::TileContent::TileWidePeekImage06
        • NotificationsExtensions::TileContent::TileWidePeekImage06
        • NotificationsExtensions::TileContent::TileWidePeekImageAndText01
        • NotificationsExtensions::TileContent::TileWidePeekImageAndText01
        • NotificationsExtensions::TileContent::TileWidePeekImageAndText02
        • NotificationsExtensions::TileContent::TileWidePeekImageAndText02
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection01
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection01
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection02
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection02
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection03
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection03
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection04
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection04
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection05
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection05
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection06
        • NotificationsExtensions::TileContent::TileWidePeekImageCollection06
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText01
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText01
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText02
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText02
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText03
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText03
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText04
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText04
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText05
        • NotificationsExtensions::TileContent::TileWideSmallImageAndText05
        • NotificationsExtensions::TileContent::TileWideText01
        • NotificationsExtensions::TileContent::TileWideText01
        • NotificationsExtensions::TileContent::TileWideText02
        • NotificationsExtensions::TileContent::TileWideText02
        • NotificationsExtensions::TileContent::TileWideText03
        • NotificationsExtensions::TileContent::TileWideText03
        • NotificationsExtensions::TileContent::TileWideText04
        • NotificationsExtensions::TileContent::TileWideText04
        • NotificationsExtensions::TileContent::TileWideText05
        • NotificationsExtensions::TileContent::TileWideText05
        • NotificationsExtensions::TileContent::TileWideText06
        • NotificationsExtensions::TileContent::TileWideText06
        • NotificationsExtensions::TileContent::TileWideText07
        • NotificationsExtensions::TileContent::TileWideText07
        • NotificationsExtensions::TileContent::TileWideText08
        • NotificationsExtensions::TileContent::TileWideText08
        • NotificationsExtensions::TileContent::TileWideText09
        • NotificationsExtensions::TileContent::TileWideText09
        • NotificationsExtensions::TileContent::TileWideText10
        • NotificationsExtensions::TileContent::TileWideText10
        • NotificationsExtensions::TileContent::TileWideText11
        • NotificationsExtensions::TileContent::TileWideText11
      • NotificationsExtensions::TileContent::TileWideBase
    • NotificationsExtensions::TileContent::TileNotificationBase
    • NotificationsExtensions::ToastContent::ToastNotificationBase
      • NotificationsExtensions::ToastContent::ToastImageAndText01
      • NotificationsExtensions::ToastContent::ToastImageAndText01
      • NotificationsExtensions::ToastContent::ToastImageAndText02
      • NotificationsExtensions::ToastContent::ToastImageAndText02
      • NotificationsExtensions::ToastContent::ToastImageAndText03
      • NotificationsExtensions::ToastContent::ToastImageAndText03
      • NotificationsExtensions::ToastContent::ToastImageAndText04
      • NotificationsExtensions::ToastContent::ToastImageAndText04
      • NotificationsExtensions::ToastContent::ToastText01
      • NotificationsExtensions::ToastContent::ToastText01
      • NotificationsExtensions::ToastContent::ToastText02
      • NotificationsExtensions::ToastContent::ToastText02
      • NotificationsExtensions::ToastContent::ToastText03
      • NotificationsExtensions::ToastContent::ToastText03
      • NotificationsExtensions::ToastContent::ToastText04
      • NotificationsExtensions::ToastContent::ToastText04
    • NotificationsExtensions::ToastContent::ToastNotificationBase
  • NotificationsExtensions::NotificationContentImage
  • NotificationsExtensions::NotificationContentText
  • NotificationsExtensions::NotificationContentValidationException
  • NotificationsExtensions::TileContent::ISquareTileInternal
    • NotificationsExtensions::TileContent::TileSquareBase
    • NotificationsExtensions::TileContent::TileSquareBase
  • NotificationsExtensions::TileContent::TileContentFactory
  • NotificationsExtensions::ToastContent::ToastAudio
  • OfferReclaimAPI
  • OpQueue< T, TOperation >
  • OpQueue< CMPEG1Source, SourceOp >
    • CMPEG1Source
    • CMPEG1Source
  • OutlineRenderer
  • PageRenderer
  • PageRendererContext
  • PaperFragment
  • PaperRenderer
  • Parser
  • ParticleData
  • PersistentState
  • Physics
  • PNTVertex
  • PointSnapper
  • PointSnapper::PointSnappingSink
  • Polygon
  • Postcard::sealed
  • PostcardRenderer
  • PrintSample::InvalidPageException
  • PrintSample::PageDescription
  • PrintSample::sealed
  • Program
  • ProximityCPP::Common::LayoutAwarePage
  • ProximityCPP::MainPage
  • ProximityCPP::Scenario
  • ProximityCPP::sealed
  • QiList< InterfaceName, InterfaceChain >
  • QiList< InterfaceName, QiListNil >
  • QiListNil
  • QiListSelf< InterfaceName, InterfaceChain >
  • RandomAccessReader
  • RawNotificationsSampleCPP::sealed
  • ReadStreamTask
  • ReadStreamTask::ReadStreamTaskImpl
  • RenderBuffer
  • Renderer
  • ResourceLoading
  • RippleEffect
  • SampleOverlay
  • Samples::Devices::DeviceControlResult
  • Samples::Devices::Fx2::sealed
  • Samples::Devices::Repeater
  • SaveAsImageFile
  • ScenarioContext
  • ScheduledNotificationsSampleCPP::sealed
  • SConversion
  • ScopedObject< T >
  • ScreenQuadVertex
  • ScreenVertex
  • SDKANIMATION_DATA
  • SDKANIMATION_FILE_HEADER
  • SDKANIMATION_FRAME_DATA
  • SDKMesh
  • SDKMESH_FRAME
  • SDKMESH_HEADER
  • SDKMESH_INDEX_BUFFER_HEADER
  • SDKMESH_MATERIAL
  • SDKMESH_MESH
  • SDKMESH_SUBSET
  • SDKMESH_VERTEX_BUFFER_HEADER
  • SDKSample::AccelerometerCPP::sealed
  • SDKSample::Accessibility::sealed
  • SDKSample::Animation::sealed
  • SDKSample::AnimationMetrics::sealed
  • SDKSample::App
  • SDKSample::ApplicationDataSample::sealed
  • SDKSample::ApplicationResources::sealed
  • SDKSample::ApplicationSettings::sealed
  • SDKSample::AtomPub::sealed
  • SDKSample::BackgroundTask::BackgroundTaskSample
  • SDKSample::BackgroundTask::sealed
  • SDKSample::BackgroundTaskSample
  • SDKSample::BackgroundTransfer::GuidComparer
  • SDKSample::BackgroundTransfer::sealed
  • SDKSample::CalendarSample::sealed
  • SDKSample::CallControl::sealed
  • SDKSample::CameraCapture::sealed
  • SDKSample::CameraOptions::sealed
  • SDKSample::CertificateEnrollment::sealed
  • SDKSample::Common::LayoutAwarePage
    • SDKSample::Common::SharePage
  • SDKSample::Common::sealed
  • SDKSample::CompassCPP::sealed
  • SDKSample::Compression::sealed
  • SDKSample::ContextMenu::sealed
  • SDKSample::CoTaskMemFreeArray
  • SDKSample::CoTaskMemFreeStruct
  • SDKSample::CryptoWinRT::sealed
  • SDKSample::CustomDeviceAccess::DeviceList
  • SDKSample::CustomDeviceAccess::sealed
  • SDKSample::DataBinding::IncrementalLoadingBase
    • SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • SDKSample::DataBinding::sealed
  • SDKSample::DataReaderWriter::sealed
  • SDKSample::DateTimeFormatting::sealed
  • SDKSample::DeviceCaps::sealed
  • SDKSample::DeviceEnumeration::sealed
  • SDKSample::DisplayOrientation::sealed
  • SDKSample::Drawing::sealed
  • SDKSample::EAS::sealed
  • SDKSample::ELS::sealed
  • SDKSample::Errors
  • SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • SDKSample::FileAccess::sealed
  • SDKSample::FileExtensions
  • SDKSample::FilePicker::sealed
  • SDKSample::FilePickerContracts::sealed
  • SDKSample::FileSearch::sealed
  • SDKSample::FileThumbnails::sealed
  • SDKSample::Finally
  • SDKSample::FlipViewCPP::sealed
  • SDKSample::FlipViewData::sealed
  • SDKSample::FolderEnumeration::sealed
  • SDKSample::GeolocationCPP::sealed
  • SDKSample::GlobalizationPreferencesSample::sealed
  • SDKSample::GyrometerCPP::sealed
  • SDKSample::Helpers
  • SDKSample::HighContrast::sealed
  • SDKSample::HomeGroup::sealed
  • SDKSample::HttpClientSample::sealed
  • SDKSample::Images::sealed
  • SDKSample::InclinometerCPP::sealed
  • SDKSample::IsRemoteSession::sealed
  • SDKSample::LightSensorCPP::sealed
  • SDKSample::ListViewSampleDataSource::sealed
  • SDKSample::ListViewSimple::sealed
  • SDKSample::MainPage
  • SDKSample::MediaButtons::sealed
  • SDKSample::MediaCapture::sealed
  • SDKSample::MediaServerClient::sealed
  • SDKSample::MessageDialogSample::sealed
  • SDKSample::MicrosoftAccount::sealed
  • SDKSample::NetworkInformationApi::sealed
  • SDKSample::NumberFormatting::sealed
  • SDKSample::OrientationSensorCPP::sealed
  • SDKSample::PackageSample::sealed
  • SDKSample::PasswordVaultCPP::sealed
  • SDKSample::PersonalityAnimations::sealed
  • SDKSample::Personalization::sealed
  • SDKSample::PlaybackManager2::sealed
  • SDKSample::PlaybackManager::sealed
  • SDKSample::Playlists::sealed
  • SDKSample::PlayTo::sealed
  • SDKSample::PlayToreceiver::sealed
  • SDKSample::PortableDeviceCPP::EventCallback
  • SDKSample::PortableDeviceCPP::sealed
  • SDKSample::PropVariantClearStruct
  • SDKSample::ProvisioningAgent::sealed
  • SDKSample::RemovableStorageCPP::sealed
  • SDKSample::Rotation::sealed
  • SDKSample::Scaling::sealed
  • SDKSample::Scenario
  • SDKSample::ScrollViewerCPP::sealed
  • SDKSample::SDKTemplate::sealed
  • SDKSample::sealed
  • SDKSample::SearchContract::sealed
  • SDKSample::ShareSource::sealed
  • SDKSample::SimpleOrientationSensorCPP::sealed
  • SDKSample::SnapSample::sealed
  • SDKSample::SplashScreen::sealed
  • SDKSample::Status
  • SDKSample::StoreSample::sealed
  • SDKSample::StringHelper
  • SDKSample::StringTrimmer
  • SDKSample::Syndication::sealed
  • SDKSample::TextDisplay::sealed
  • SDKSample::TextEditing::sealed
  • SDKSample::ThreadPool::sealed
  • SDKSample::ThreadPool::ThreadPoolSample
  • SDKSample::Tiles::sealed
  • SDKSample::TouchKeyboard::sealed
  • SDKSample::TouchKeyboardTextInput::sealed
  • SDKSample::Transcode::sealed
  • SDKSample::Transforms::sealed
  • SDKSample::UserAndCustomControls::sealed
  • SDKSample::UserDomainName::sealed
  • SDKSample::UssdApi::sealed
  • SDKSample::WASAPIAudio::DEVICEPROPS
  • SDKSample::WASAPIAudio::MFSampleGenerator
  • SDKSample::WASAPIAudio::sealed
  • SDKSample::WASAPIAudio::ToneSampleGenerator
  • SDKSample::WASAPIAudio::WASAPICapture
  • SDKSample::WASAPIAudio::WASAPIRenderer
  • SDKSample::WebAuthentication::sealed
  • SDKSample::WebSocket::sealed
  • SDKSample::WebViewControl::sealed
  • SDKSample::XAMLPopup::sealed
  • SDKTemplate::App
  • SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
  • SDKTemplate::DeviceAppPage
  • SDKTemplate::MainPageSizeChangedEventArgs
  • SDKTemplate::Scenario
  • SecondaryTiles::Common::LayoutAwarePage
  • SecondaryTiles::MainPage
  • SecondaryTiles::Scenario
  • SecondaryTiles::sealed
  • Shape
  • ShapeRecord
  • ShareTarget::Common::LayoutAwarePage
  • ShareTarget::sealed
  • Simple3DGame
  • Simple3DGameXaml::sealed
  • Simple3DTouch
  • SimpleBlogReader::sealed
  • SimpleCommunication::App
  • SimpleCommunication::CaptureFailedEventArgs
  • SimpleCommunication::Common::CaptureDevice
  • SimpleCommunication::Common::LayoutAwarePage
  • SimpleCommunication::MainPage
  • SimpleCommunication::Scenario
  • SimpleCommunication::SdkSample
  • SimpleCommunication::sealed
  • SimpleCommunication::sealed::StreamFilteringCriteria
  • SimpleController
  • SimpleCubeVertex
  • SimpleSprites
  • SimpleVertex
  • SoundEffect
  • SoundEffectData
  • SoundFileReader
  • SourceOp
    • SetRateOp
    • SetRateOp
    • StartOp
    • StartOp
  • SphereMesh
  • STEREO_PARAMETERS
  • StereoParameters
  • StereoSimpleD3D
  • StreamEffect
  • StreamingVoiceContext
  • StreamList
  • StreamSocketSample::App
  • StreamSocketSample::Common::LayoutAwarePage
  • StreamSocketSample::MainPage
  • StreamSocketSample::Scenario
  • StreamSocketSample::sealed
  • SuspensionManager
  • SValue
  • TangentVertex
  • TargetTexture
  • Tasks::sealed
  • TextAnalysis::Run
    • TextAnalysis::LinkedRun
  • TextInterop
  • TextStyle
  • TextureLock
  • TGA_EXTENSION
  • TGA_FOOTER
  • TGA_HEADER
  • ToastsSampleCPP::sealed
  • TreeIterator< T >
  • Triangle
  • TriColorValueHelper
  • TripOptimizerComponent::Details::TripOptimizerImpl
  • TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • TripOptimizerComponent::sealed
  • UiaCoreWindowProvider::IAppWindowProvider
  • UiaCoreWindowProvider::IDisconnectableProvider
  • UiaCoreWindowProvider::ITriColorControlInternal
    • sealed
  • UiaCoreWindowProvider::ITriColorControlProvider
  • UiaCoreWindowProvider::ITriColorFragmentProvider
  • UserInterface
  • Utils
  • Vector2< T >
  • Vector3< T >
  • Vector4< T >
  • VideoBufferLock
  • VideoView
  • ViewTransform
  • WaveEffect
  • WaveEffect::Vertex
  • Web::Details::HttpRequestBuffersCallback
  • Web::HttpRequest
  • WICConvert
  • WICTranslate
  • WorldCeilingMesh
  • WorldFloorMesh
  • WorldWallsMesh
  • Wrapper::DspSettings
  • Wrapper::sealed
  • XAudio2SoundPlayer
  • XAudio2SoundPlayer::ImplData
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- _ -

  • _11 : Matrix4x4< T >
  • _12 : Matrix4x4< T >
  • _13 : Matrix4x4< T >
  • _14 : Matrix4x4< T >
  • _21 : Matrix4x4< T >
  • _22 : Matrix4x4< T >
  • _23 : Matrix4x4< T >
  • _24 : Matrix4x4< T >
  • _31 : Matrix4x4< T >
  • _32 : Matrix4x4< T >
  • _33 : Matrix4x4< T >
  • _34 : Matrix4x4< T >
  • _41 : Matrix4x4< T >
  • _42 : Matrix4x4< T >
  • _43 : Matrix4x4< T >
  • _44 : Matrix4x4< T >
  • __pad0__ : DatagramSocketSample::Common::LayoutAwarePage , PageRenderer , Simple3DTouch , OfferReclaimAPI , DirectXApp , DxgiRotation , SDKSample::FilePickerContracts::sealed , DeviceAppForPrinters::App , SaveAsImageFile , AmpPixel , Hilo::sealed , PageRendererContext , Hilo::Common::LayoutAwarePage , Hilo::Common::sealed , SDKSample::App , D2D3DTransformsRenderer , BasicCamera , Hilo::HiloPage , Hilo::ImageBase , BasicLoader , Hilo::NullPhotoGroup , Hilo::ViewModelBase , abstract , BasicReaderWriter , ManipulatableObject , Program , BasicShapes , SDKSample::TouchKeyboard::sealed , MEPlayer , SDKSample::Common::LayoutAwarePage , PersistentState , BumpMapping , VideoView , MediaExtensionsCPP::App , LonLatController , ProximityCPP::Common::LayoutAwarePage , ProximityCPP::sealed , D2DTextAnimation , AutoThrottle , SimpleCommunication::App , SimpleCommunication::Common::LayoutAwarePage , DirectXFractal , SimpleCommunication::sealed , SimpleCommunication::CaptureFailedEventArgs , sealed , SampleOverlay , D3DPostProcessing , SimpleCommunication::SdkSample , SecondaryTiles::Common::LayoutAwarePage , ResourceLoading , SecondaryTiles::sealed , ShareTarget::Common::LayoutAwarePage , D2DBasicAnimation , BasicSprites::SpriteBatch , SDKSample::SplashScreen::sealed , StreamSocketSample::App , SimpleSprites , StreamSocketSample::Common::LayoutAwarePage , StreamSocketSample::sealed , SDKSample::Common::sealed , D2DEffectsHelloWorld , StereoSimpleD3D , SDKSample::WASAPIAudio::sealed , DeviceAppForWebcam::Common::LayoutAwarePage , Direct3DTutorial , DeviceAppForWebcam::sealed , AppBarControl::App , BasicTimer , TextInterop , AppBarControl::Common::LayoutAwarePage , AppBarControl::sealed , DWriteCustomTextRenderer , SDKSample::DataBinding::GeneratorIncrementalLoadingClass , SDKSample::DataBinding::IncrementalLoadingBase , SDKSample::sealed , CommandListRenderer , DWriteHelloWorld , D2DLightingEffectsRenderer , Simple3DGameXaml::sealed , DWriteHitTesting , SDKSample::FlipViewCPP::sealed , BasicSound , CompositeModes , DWriteInlineObject , RandomAccessReader , StreamEffect , DWriteParagraphText , AudioController , SimpleController , AccountPictureName::App , ConvolveMatrixEffect , DWriteVerticalText , AnimateLinePosition , D2DEffectsOnPrimitives , AnimateLineListPosition , AnimateCirclePosition , AccountPictureName::Common::LayoutAwarePage , FPSCounter , Audio , Camera , GeometryRealizationSample , Cylinder , CylinderMesh , AccountPictureName::sealed , D2DInterpolationModes , Face , FaceMesh , Design , GameHud , GameInfoOverlay , Clipboard::App , Document , GameObject , GameRenderer , Element , GameTimer , Level1 , Clipboard::Common::LayoutAwarePage , Image , Level2 , Level3 , ImageFrame , Level4 , Level5 , Clipboard::sealed , Layer , Level6 , Material , List< T > , MediaReader , MoveLookController , ContactPicker::App , PageRoll , Simple3DGame , SoundEffect , Rectangle , Sphere , SphereMesh , ContactPicker::Common::LayoutAwarePage , Renderer , TargetTexture , WorldCeilingMesh , Resource , WorldFloorMesh , WorldWallsMesh , ContactPicker::sealed , Story , LoadScreen , MarbleMaze , Text , ExtrudedTextRenderer , ImageRenderer , DatagramSocketSample::sealed , TextFrame , InkRenderer , PaperFragment , D2DPerspectiveTransform , PaperRenderer , PostcardRenderer
  • __pad1__
: SDKSample::sealed
, Hilo::HiloPage
, Hilo::sealed
, ManipulatableObject
, SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • _acceleratorKeyEventToken : SDKSample::Common::LayoutAwarePage , Hilo::Common::LayoutAwarePage
  • _Acquires_lock_() : CritSec , AutoLock , CMPEG1Source , CritSec , AutoLock , CMPEG1Source , CMPEG1Stream::SourceLock , CritSec , AutoLock
  • _active : SimpleCommunication::sealed
  • _age : SDKSample::Accessibility::sealed
  • _backgroundBrush : sealed
  • _backgroundColor : sealed
  • _baseUri : SDKSample::FlipViewData::sealed
  • _bLocked : TextureLock
  • _bLocked2D : VideoBufferLock
  • _bLocked2D2 : VideoBufferLock
  • _bLockedBuffer : VideoBufferLock
  • _buffer : DirectX::Blob
  • _busy : SDKSample::DataBinding::IncrementalLoadingBase
  • _Category : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _channel : RawNotificationsSampleCPP::sealed
  • _city : SDKSample::DataBinding::sealed
  • _color : sealed , SDKSample::DataBinding::sealed
  • _CompletionEvent : ReadStreamTask::ReadStreamTaskImpl
  • _Content : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _count : SDKSample::CoTaskMemFreeArray , SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • _CTS : SDKSample::Transcode::sealed
  • _Current : SDKSample::CustomDeviceAccess::DeviceList
  • _currentBuffer : sealed
  • _currentScenario : SimpleCommunication::sealed
  • _currentSongIndex : SDKSample::MediaButtons::sealed
  • _currentState : SimpleCommunication::sealed
  • _defaultViewModel
: SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
  • _descPosition : sealed
  • _Description : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _descText : sealed
  • _Destination : ReadStreamTask::ReadStreamTaskImpl
  • _device : SimpleCommunication::sealed
  • _deviceDesc : sealed
  • _deviceEventCookie : SDKSample::PortableDeviceCPP::sealed
  • _deviceEventSource : SDKSample::PortableDeviceCPP::sealed
  • _deviceInfoCollection : SDKSample::PortableDeviceCPP::sealed , SDKSample::RemovableStorageCPP::sealed
  • _dictionary : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • _dispatcher
: SDKSample::CallControl::sealed
, SDKSample::MediaButtons::sealed
, RawNotificationsSampleCPP::sealed
, SimpleCommunication::sealed
, SimpleCommunication::SdkSample
  • _displayHandlerToken
: PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
  • _drawingAttributes : sealed
  • _dueTime : ScheduledNotificationsSampleCPP::sealed
  • _employee : SDKSample::DataBinding::sealed
  • _eventReceived : SDKSample::PortableDeviceCPP::EventCallback
  • _eventTextFormat : sealed
  • _extensionManager : SDKTemplateCS::MainPage , MediaExtensionsCPP::sealed
  • _fileEventArgs : AssociationLaunching::sealed
  • _fontFamily : LanguageFontCPP::sealed
  • _fontStretch : LanguageFontCPP::sealed
  • _fontStyle : LanguageFontCPP::sealed
  • _fontWeight : LanguageFontCPP::sealed
  • _formatter : ScheduledNotificationsSampleCPP::sealed
  • _frameLoadedToken
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, MediaExtensionsCPP::sealed
, RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • _frameReference : sealed
  • _Image : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _image : DirectX::ScratchImage , SDKSample::FlipViewData::sealed
  • _ImagePathProperty : SDKSample::UserAndCustomControls::sealed
  • _Impl : ReadStreamTask
  • _incomingConnectionEventRegistrationToken : SimpleCommunication::sealed
  • _initColor : sealed
  • _initDX : sealed
  • _initDY : sealed
  • _initialization : SimpleCommunication::sealed
  • _initialized : SimpleCommunication::sealed
  • _initX : sealed
  • _initY : sealed
  • _inkBrush : sealed
  • _inkStyle : sealed
  • _InputFile : SDKSample::Transcode::sealed
  • _inputFrame
: CredentialPickerCPP::sealed
, SDKTemplateCS::MainPage
, AssociationLaunching::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • _inputFrameLoadedToken
: EdgeGestureSample::sealed
, AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, PrintSample::sealed
  • _inputString : ScheduledNotificationsSampleCPP::sealed
  • _isPropertyChangedObserved : SDKSample::DataBinding::sealed
  • _isTerminator : SimpleCommunication::sealed
  • _isTile : ScheduledNotificationsSampleCPP::sealed
  • _isVectorChangedObserved : SDKSample::DataBinding::IncrementalLoadingBase
  • _itemId : ScheduledNotificationsSampleCPP::sealed
  • _items
: ScheduledNotificationsSampleCPP::sealed
, SDKSample::DataBinding::sealed
, SDKSample::ListViewSampleDataSource::sealed
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, SDKSample::FlipViewData::sealed
  • _itemType : ScheduledNotificationsSampleCPP::sealed
  • _labeledBy : SDKSample::Accessibility::sealed
  • _LabelProperty : SDKSample::UserAndCustomControls::sealed
  • _latencyMode : SimpleCommunication::sealed
  • _layoutAwareControls
: SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
  • _layoutHandlerToken
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, MediaExtensionsCPP::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::SnapSample::sealed
, ToastsSampleCPP::sealed
, LanguageFontCPP::sealed
  • _Link : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _localHostVideo : SimpleCommunication::sealed
  • _logicalDpiChangedToken
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, LockScreenAppsCPP::sealed
, AssociationLaunching::sealed
  • _lPitch : VideoBufferLock
  • _m00 : Matrix4x4< T >
  • _m01 : Matrix4x4< T >
  • _m02 : Matrix4x4< T >
  • _m03 : Matrix4x4< T >
  • _m10 : Matrix4x4< T >
  • _m11 : Matrix4x4< T >
  • _m12 : Matrix4x4< T >
  • _m13 : Matrix4x4< T >
  • _m20 : Matrix4x4< T >
  • _m21 : Matrix4x4< T >
  • _m22 : Matrix4x4< T >
  • _m23 : Matrix4x4< T >
  • _m30 : Matrix4x4< T >
  • _m31 : Matrix4x4< T >
  • _m32 : Matrix4x4< T >
  • _m33 : Matrix4x4< T >
  • _manipulationMode : sealed
  • _manipulationPoints : sealed
  • _maxCount : SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • _mediaCapture : SimpleCommunication::sealed
  • _mediaCaptureFailedEventRegistrationToken : SimpleCommunication::sealed
  • _mediaElement : SDKSample::Accessibility::sealed
  • _mediaElementFailedEventRegistrationToken : SimpleCommunication::sealed
  • _mediaExtensionMgr : SimpleCommunication::sealed
  • _mediaFailedToken : MediaExtensionsCPP::sealed
  • _mediaSink : SimpleCommunication::sealed
  • _mediaSinkIncomingConnectionEventRegistrationToken : SimpleCommunication::sealed
  • _memory : DirectX::ScratchImage
  • _message() : SimpleCommunication::CaptureFailedEventArgs
  • _messageBrush : sealed
  • _metadata : DirectX::ScratchImage
  • _mxManip : ManipulatableObject
  • _name : SDKSample::DataBinding::sealed
  • _navigationDisabled : SimpleCommunication::sealed
  • _navigationShortcutsRegistered : Hilo::Common::LayoutAwarePage , SDKSample::Common::LayoutAwarePage
  • _nextTrackPressedEventToken : SDKSample::MediaButtons::sealed
  • _nimages : DirectX::ScratchImage
  • _observableTeams : SDKSample::DataBinding::sealed
  • _organization : SDKSample::DataBinding::sealed
  • _oriHeadingUI : LanguageFontCPP::sealed
  • _oriTextUI : LanguageFontCPP::sealed
  • _OutputFile : SDKSample::Transcode::sealed
  • _OutputFileName : SDKSample::Transcode::sealed
  • _outputFrame
: PrintSample::sealed
, LanguageFontCPP::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, SDKTemplateCS::MainPage
, ScheduledNotificationsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
, AssociationLaunching::sealed
, ToastsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, LockScreenAppsCPP::sealed
  • _outputFrameLoadedToken
: ScheduledNotificationsSampleCPP::sealed
, AssociationLaunching::sealed
, EdgeGestureSample::sealed
, LockScreenAppsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
  • _overflowColumns : Hilo::Common::sealed
  • _pageKey : Hilo::Common::LayoutAwarePage , SDKSample::Common::LayoutAwarePage
  • _pageLoadedHandlerToken
: LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, AssociationLaunching::sealed
, ToastsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, EdgeGestureSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, CredentialPickerCPP::sealed
  • _parent : ManipulatableObject
  • _pContext : TextureLock
  • _pData : VideoBufferLock
  • _peer : SDKSample::TouchKeyboard::sealed
  • _picture : SDKSample::FlipViewData::sealed
  • _pInputBuffer : VideoBufferLock
  • _pInputBuffer2D : VideoBufferLock
  • _pInputBuffer2D2 : VideoBufferLock
  • _placeholder : SDKSample::MainPage
  • _playback : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • _playlist : SDKSample::MediaButtons::sealed
  • _playlistCount : SDKSample::MediaButtons::sealed
  • _pointer : ScopedObject< T >
  • _pointerDevice : sealed
  • _pointerId : sealed
  • _pointerPressedEventToken : SDKSample::Common::LayoutAwarePage , Hilo::Common::LayoutAwarePage
  • _previousBuffer : sealed
  • _previousState : SimpleCommunication::sealed
  • _prevTrackPressedEventToken : SDKSample::MediaButtons::sealed
  • _privatePropertyChanged : SDKSample::DataBinding::sealed
  • _privateVectorChanged : SDKSample::DataBinding::IncrementalLoadingBase
  • _Profile : SDKSample::Transcode::sealed
  • _propBag : SDKSample::DataBinding::sealed
  • _PropertyChanged
: SDKSample::FlipViewData::sealed
, SDKSample::ListViewSampleDataSource::sealed
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _protocolEventArgs : AssociationLaunching::sealed , AccountPictureName::sealed
  • _pSample : MediaStreamSource::PcmSource
  • _pTex : TextureLock
  • _ptInit : ManipulatableObject
  • _ptr : SDKSample::CoTaskMemFreeArray
  • _Reader : ReadStreamTask::ReadStreamTaskImpl
  • _recognitionText : sealed
  • _recognizer : sealed
  • _recognizerContainer : sealed
  • _recognizerId : sealed
  • _recordingStarted : SimpleCommunication::sealed
  • _Releases_lock_() : AutoLock , CMPEG1Source , CritSec , AutoLock , CritSec , CMPEG1Stream::SourceLock , CMPEG1Source , CritSec , AutoLock
  • _renderer : sealed
  • _renderingMode : sealed
  • _resizeHandlerToken : LockScreenAppsCPP::sealed , ScheduledNotificationsSampleCPP::sealed
  • _role : SimpleCommunication::sealed
  • _rootNamespace : SDKTemplateCS::MainPage
  • _rootPage : SimpleCommunication::sealed
  • _scenariosFrame
: PrintSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, ToastsSampleCPP::sealed
, SDKTemplateCS::MainPage
, EdgeGestureSample::sealed
, CredentialPickerCPP::sealed
, RawNotificationsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, AssociationLaunching::sealed
, ScheduledNotificationsSampleCPP::sealed
  • _sdkSample : SimpleCommunication::sealed
  • _selectionBrush : sealed
  • _selectionStyle : sealed
  • _size : DirectX::ScratchImage , DirectX::Blob
  • _sizeChangedHandlerToken : PrintSample::sealed
  • _stabilizedMediaFailedToken : MediaExtensionsCPP::sealed
  • _start : SDKSample::Transcode::sealed
  • _statusMessage : SimpleCommunication::SdkSample , sealed
  • _stop : SDKSample::Transcode::sealed
  • _storageVectorChanged() : SDKSample::DataBinding::IncrementalLoadingBase
  • _StreamData : ReadStreamTask::ReadStreamTaskImpl
  • _streamFilteringCriteria : SimpleCommunication::sealed
  • _strokeBuilder : sealed
  • _strokeContainer : sealed
  • _Subtitle : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _Task : ReadStreamTask::ReadStreamTaskImpl
  • _text : SDKSample::TouchKeyboard::sealed
  • _this : SDKSample::Common::LayoutAwarePage , Hilo::Common::LayoutAwarePage
  • _Title : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _title : SDKSample::FlipViewData::sealed
  • _toast : ToastsSampleCPP::sealed
  • _toastContext : ToastsSampleCPP::sealed
  • _tokenHolding : sealed
  • _tokenManipulationCompleted : sealed
  • _tokenManipulationInertiaStarting : sealed
  • _tokenManipulationStarted : sealed
  • _tokenManipulationUpdated : sealed
  • _tokenRightTapped : sealed
  • _tokenTapped : sealed
  • _Transcoder : SDKSample::Transcode::sealed
  • _type : SDKSample::FlipViewData::sealed
  • _uiIndex : TextureLock
  • _useFilledStateForNarrowWindow
: SimpleCommunication::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
  • _UseMp4 : SDKSample::Transcode::sealed
  • _videoSettingsFilter : SimpleCommunication::sealed
  • _wasPlaying : SDKSample::MediaButtons::sealed
  • _windowSizeEventToken
: DatagramSocketSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Namespace Index

  • Namespace List
  • Namespace Members

Namespace List

Here is a list of all namespaces with brief descriptions:
AccountPictureName
AccountPictureName::Common
anonymous_namespace{AudioController.cpp}
anonymous_namespace{BasicSound.cpp}
anonymous_namespace{FlowLayout.cpp}
anonymous_namespace{SimpleController.cpp}
anonymous_namespace{SoundFileReader.cpp}
anonymous_namespace{StreamEffect.cpp}
anonymous_namespace{SuspensionManager.cpp}
anonymous_namespace{suspensionmanager.cpp}
anonymous_namespace{XAudio2SoundPlayer.cpp}
AntSystem
AppBarControl
AppBarControl::Common
AssociationLaunching
Background
BackgroundTask
BackgroundTasks
BasicSprites
BasicSprites::Parameters
Clipboard
Clipboard::Common
ContactPicker
ContactPicker::Common
ConvolutionKernels
CppSamplesUtils
CppSamplesUtils::Details
CredentialPickerCPP
CustomDeviceAccess
D2D3DTransforms
D2DLightingEffects
DatagramSocketSample
DatagramSocketSample::Common
DeviceAppForPrinters
DeviceAppForWebcam
DeviceAppForWebcam::Common
DirectX
DX
EdgeGestureSample
FontEnumeration
GameConstants
GameConstants::Physics
GameConstants::Sound
GameInfoOverlayConstant
Hilo
Hilo::Common
InvertTransform
LanguageFontCPP
LockScreenAppsCPP
Magazine
MEDIA
MediaCapture
MediaExtensionsCPP
MediaExtensionsCS
MediaStreamSource
Microsoft
Microsoft::Samples
MoveLookControllerConstants
MPEG1Source
NetworkStatusTask
NotificationsExtensions
NotificationsExtensions::BadgeContent
NotificationsExtensions::TileContent
NotificationsExtensions::ToastContent
PolarTransform
Postcard
PrintSample
ProximityCPP
ProximityCPP::Common
RawNotificationsSampleCPP
Samples
Samples::Devices
Samples::Devices::Details
Samples::Devices::Fx2
SampleSettings
SampleSettings::DirectCompute
SampleSettings::Manipulation
SampleSettings::Performance
SampleSettings::Physics
SampleSettings::ThreePhase
ScheduledNotificationsSampleCPP
SDKSample
SDKSample::AccelerometerCPP
SDKSample::Accessibility
SDKSample::Animation
SDKSample::AnimationMetrics
SDKSample::ApplicationDataSample
SDKSample::ApplicationResources
SDKSample::ApplicationSettings
SDKSample::AtomPub
SDKSample::BackgroundTask
SDKSample::BackgroundTransfer
SDKSample::CalendarSample
SDKSample::CallControl
SDKSample::CameraCapture
SDKSample::CameraOptions
SDKSample::CertificateEnrollment
SDKSample::Common
SDKSample::CompassCPP
SDKSample::Compression
SDKSample::ContextMenu
SDKSample::CryptoWinRT
SDKSample::CustomDeviceAccess
SDKSample::DataBinding
SDKSample::DataReaderWriter
SDKSample::DateTimeFormatting
SDKSample::DeviceCaps
SDKSample::DeviceEnumeration
SDKSample::DisplayOrientation
SDKSample::Drawing
SDKSample::EAS
SDKSample::ELS
SDKSample::ELS::Private
SDKSample::ExpressionBlendSampleDataSampleDataSource
SDKSample::FileAccess
SDKSample::FilePicker
SDKSample::FilePickerContracts
SDKSample::FileSearch
SDKSample::FileThumbnails
SDKSample::FlipViewCPP
SDKSample::FlipViewData
SDKSample::FolderEnumeration
SDKSample::GeolocationCPP
SDKSample::GlobalizationPreferencesSample
SDKSample::GyrometerCPP
SDKSample::HighContrast
SDKSample::HomeGroup
SDKSample::HttpClientSample
SDKSample::Images
SDKSample::InclinometerCPP
SDKSample::IsRemoteSession
SDKSample::LightSensorCPP
SDKSample::ListViewSampleDataSource
SDKSample::ListViewSimple
SDKSample::MediaButtons
SDKSample::MediaCapture
SDKSample::MediaServerClient
SDKSample::MessageDialogSample
SDKSample::MicrosoftAccount
SDKSample::NetworkInformationApi
SDKSample::NumberFormatting
SDKSample::OrientationSensorCPP
SDKSample::PackageSample
SDKSample::PasswordVaultCPP
SDKSample::PersonalityAnimations
SDKSample::Personalization
SDKSample::PlaybackManager
SDKSample::PlaybackManager2
SDKSample::Playlists
SDKSample::PlayTo
SDKSample::PlayToreceiver
SDKSample::PortableDeviceCPP
SDKSample::ProvisioningAgent
SDKSample::RemovableStorageCPP
SDKSample::Rotation
SDKSample::Scaling
SDKSample::ScrollViewerCPP
SDKSample::SDKTemplate
SDKSample::SearchContract
SDKSample::ShareSource
SDKSample::SimpleOrientationSensorCPP
SDKSample::SnapSample
SDKSample::SplashScreen
SDKSample::StoreSample
SDKSample::Syndication
SDKSample::TextDisplay
SDKSample::TextEditing
SDKSample::ThreadPool
SDKSample::Tiles
SDKSample::TouchKeyboard
SDKSample::TouchKeyboardTextInput
SDKSample::Transcode
SDKSample::Transforms
SDKSample::UserAndCustomControls
SDKSample::UserDomainName
SDKSample::UssdApi
SDKSample::WASAPIAudio
SDKSample::WebAuthentication
SDKSample::WebSocket
SDKSample::WebViewControl
SDKSample::XAMLPopup
SDKTemplate
SDKTemplate::Common
SDKTemplateCS
SecondaryTiles
SecondaryTiles::Common
ShareTarget
ShareTarget::Common
Simple3DGameXaml
SimpleBlogReader
SimpleCommunication
SimpleCommunication::Common
StreamSocketSample
StreamSocketSample::Common
Tasks
ToastsSampleCPP
TripOptimizerComponent
TripOptimizerComponent::Details
UiaCoreWindowProvider
Web
Web::Details
Wrapper
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AccountPictureName Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

AccountPictureName Namespace Reference

Namespaces

namespace | Common

Classes

class | App
class | MainPage
struct | Scenario
class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum AccountPictureName::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 25 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AccountPictureName::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • AccountPictureName
  • Common
Classes

AccountPictureName::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{AudioController.cpp} Namespace Reference

  • Namespace List
  • Namespace Members
Variables

anonymous_namespace{AudioController.cpp} Namespace Reference

Variables

const char16 | APPLICATION_TITLE [] = "XInput audio controller playback sample"
const char16 | FONT_LOCAL [] = "en-US"
const char16 | FONT_NAME [] = "Segoe UI"
const float | FONT_SIZE_TEXT = 18.0f
const float | INFORMATION_START_X = 32.0f
const float | INFORMATION_START_Y = 150.0f
const char16 | MSG_INSTRUCTIONS [] = "Press the A button to play a sound."
const char16 | MSG_NEED_CONTROLLER [] = "Please insert an Xbox 360 common controller device and attach a headset."
const char16 | MSG_NEED_HEADSET [] = "Please attach a headset to the Xbox 360 common controller device."
const char16 | SOUND_FILE [] = "media\\wavs\\pow.wav"
const uint64 | XINPUT_ENUM_TIMEOUT_MS = 2000
const uint64 | XINPUT_HEADSET_CHECK_TIMEOUT_MS = 2000

Variable Documentation

const char16 anonymous_namespace{AudioController.cpp}::APPLICATION_TITLE[] = "XInput audio controller playback sample"

Definition at line 11 of file AudioController.cpp.

const char16 anonymous_namespace{AudioController.cpp}::FONT_LOCAL[] = "en-US"

Definition at line 14 of file AudioController.cpp.

const char16 anonymous_namespace{AudioController.cpp}::FONT_NAME[] = "Segoe UI"

Definition at line 15 of file AudioController.cpp.

const float anonymous_namespace{AudioController.cpp}::FONT_SIZE_TEXT = 18.0f

Definition at line 16 of file AudioController.cpp.

const float anonymous_namespace{AudioController.cpp}::INFORMATION_START_X = 32.0f

Definition at line 22 of file AudioController.cpp.

const float anonymous_namespace{AudioController.cpp}::INFORMATION_START_Y = 150.0f

Definition at line 23 of file AudioController.cpp.

const char16 anonymous_namespace{AudioController.cpp}::MSG_INSTRUCTIONS[] = "Press the A button to play a sound."

Definition at line 20 of file AudioController.cpp.

const char16 anonymous_namespace{AudioController.cpp}::MSG_NEED_CONTROLLER[] = "Please insert an Xbox 360 common controller device and attach a headset."

Definition at line 18 of file AudioController.cpp.

const char16 anonymous_namespace{AudioController.cpp}::MSG_NEED_HEADSET[] = "Please attach a headset to the Xbox 360 common controller device."

Definition at line 19 of file AudioController.cpp.

const char16 anonymous_namespace{AudioController.cpp}::SOUND_FILE[] = "media\\wavs\\pow.wav"

Definition at line 12 of file AudioController.cpp.

const uint64 anonymous_namespace{AudioController.cpp}::XINPUT_ENUM_TIMEOUT_MS = 2000

Definition at line 25 of file AudioController.cpp.

const uint64 anonymous_namespace{AudioController.cpp}::XINPUT_HEADSET_CHECK_TIMEOUT_MS = 2000

Definition at line 26 of file AudioController.cpp.

Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{BasicSound.cpp} Namespace Reference

  • Namespace List
  • Namespace Members
Variables

anonymous_namespace{BasicSound.cpp} Namespace Reference

Variables

const char16 * | APPLICATION_TITLE = "XAudio2 sound playback sample"
const char16 | FONT_LOCALE [] = "en-US"
const char16 | FONT_NAME [] = "Segoe UI"
const float | FONT_SIZE_TEXT = 18.0f
const float | INFORMATION_START_X = 32.0f
const float | INFORMATION_START_Y = 150.0f
const char16 | MSG_NEED_AUDIO [] = "No usable audio devices were found; install an audio device and restart the sample."
const char16 * | SOUND_FILE_LIST []
const uint32 | SOUND_SAMPLE_RATE = 48000
const float | TITLE_MARGIN = 100.0f

Variable Documentation

const char16* anonymous_namespace{BasicSound.cpp}::APPLICATION_TITLE = "XAudio2 sound playback sample"

Definition at line 20 of file BasicSound.cpp.

const char16 anonymous_namespace{BasicSound.cpp}::FONT_LOCALE[] = "en-US"

Definition at line 43 of file BasicSound.cpp.

const char16 anonymous_namespace{BasicSound.cpp}::FONT_NAME[] = "Segoe UI"

Definition at line 44 of file BasicSound.cpp.

const float anonymous_namespace{BasicSound.cpp}::FONT_SIZE_TEXT = 18.0f

Definition at line 45 of file BasicSound.cpp.

const float anonymous_namespace{BasicSound.cpp}::INFORMATION_START_X = 32.0f

Definition at line 40 of file BasicSound.cpp.

const float anonymous_namespace{BasicSound.cpp}::INFORMATION_START_Y = 150.0f

Definition at line 41 of file BasicSound.cpp.

const char16 anonymous_namespace{BasicSound.cpp}::MSG_NEED_AUDIO[] = "No usable audio devices were found; install an audio device and restart the sample."

Definition at line 39 of file BasicSound.cpp.

const char16* anonymous_namespace{BasicSound.cpp}::SOUND_FILE_LIST[]
Initial value:
 {
            L"media\\wavs\\counting_adpcm.wav",
            L"media\\wavs\\electro_adpcm.wav",
            L"media\\wavs\\heli_adpcm.wav",
            L"media\\wavs\\hiphoppy_adpcm.wav",
            L"media\\wavs\\musicmono_adpcm.wav",
            L"media\\wavs\\pow_adpcm.wav",
            L"media\\wavs\\techno_adpcm.wav",
            nullptr
    }

Definition at line 24 of file BasicSound.cpp.

const uint32 anonymous_namespace{BasicSound.cpp}::SOUND_SAMPLE_RATE = 48000

Definition at line 35 of file BasicSound.cpp.

const float anonymous_namespace{BasicSound.cpp}::TITLE_MARGIN = 100.0f

Definition at line 21 of file BasicSound.cpp.

Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{FlowLayout.cpp} Namespace Reference

  • Namespace List
  • Namespace Members
Functions

anonymous_namespace{FlowLayout.cpp} Namespace Reference

Functions

UINT32 | EstimateGlyphCount (UINT32 textLength)
HRESULT | GetGlyphMetrics (IDWriteFontFace *fontFace, DWRITE_MEASURING_MODE measuringMode, float fontEmSize, bool isSideways, UINT32 glyphCount, _In_reads_(glyphCount) UINT16 *glyphIds, _Out_writes_(glyphCount) DWRITE_GLYPH_METRICS *glyphRunMetrics)

Function Documentation

UINT32 anonymous_namespace{FlowLayout.cpp}::EstimateGlyphCount ( UINT32 textLength )

Definition at line 19 of file FlowLayout.cpp.

    {
        return 3 * textLength / 2 + 16;
    }

HRESULT anonymous_namespace{FlowLayout.cpp}::GetGlyphMetrics | ( | IDWriteFontFace * | fontFace,
 |  | DWRITE_MEASURING_MODE | measuringMode,
 |  | float | fontEmSize,
 |  | bool | isSideways,
 |  | UINT32 | glyphCount,
 |  | _In_reads_(glyphCount) UINT16 * | glyphIds,
 |  | _Out_writes_(glyphCount) DWRITE_GLYPH_METRICS * | glyphRunMetrics
 | ) |  |

Definition at line 24 of file FlowLayout.cpp.

    {
        // Call the right function depending on the measuring mode.
        switch (measuringMode)
        {
        case DWRITE_MEASURING_MODE_GDI_CLASSIC:
        case DWRITE_MEASURING_MODE_GDI_NATURAL:
            return fontFace->GetGdiCompatibleGlyphMetrics(
                fontEmSize,
                1.0,
                nullptr,
                measuringMode == DWRITE_MEASURING_MODE_GDI_NATURAL,
                glyphIds,
                glyphCount,
                glyphRunMetrics,
                isSideways
                );

        case DWRITE_MEASURING_MODE_NATURAL:
        default:
            return fontFace->GetDesignGlyphMetrics(glyphIds, glyphCount, glyphRunMetrics, isSideways);
        }
    }

Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{SimpleController.cpp} Namespace Reference

  • Namespace List
  • Namespace Members
Variables

anonymous_namespace{SimpleController.cpp} Namespace Reference

Variables

const char16 | APPLICATION_TITLE [] = "XInput game controller sample"
const float | CAPS_DATA_START = INFORMATION_START_X + 400.0f
const char16 | CAPS_HEADER [] = "XInput Capabilties"
const float | CAPS_LABEL_START = INFORMATION_START_X + 300.0f
const float | CLEAR_COLOR [4] = { 0.071f, 0.040f, 0.561f, 1.0f }
const char16 | FONT_LOCAL [] = "en-US"
const char16 | FONT_NAME [] = "Segoe UI"
const float | FONT_SIZE_HEADER = 18.0f
const float | FONT_SIZE_TEXT = 18.0f
const float | INFORMATION_START_X = 32.0f
const float | INFORMATION_START_Y = 150.0f
const float | INPUT_DATA_START = INFORMATION_START_X + 132.0f
const float | INPUT_LABEL_START = INFORMATION_START_X
const char16 | LABEL_CAPS_FLAGS [] = "Flags"
const char16 | LABEL_CAPS_SUBTYPE [] = "Subtype"
const char16 | LABEL_CAPS_TYPE [] = "Type"
const char16 | LABEL_STATE_BUTTONS [] = "Buttons"
const char16 | LABEL_STATE_LEFT_THUMB_X [] = "Left Thumb X"
const char16 | LABEL_STATE_LEFT_THUMB_Y [] = "Left Thumb Y"
const char16 | LABEL_STATE_LEFT_TRIGGER [] = "Left Trigger"
const char16 | LABEL_STATE_PACKET_NUMBER [] = "Packet Number"
const char16 | LABEL_STATE_RIGHT_THUMB_X [] = "Right Thumb X"
const char16 | LABEL_STATE_RIGHT_THUMB_Y [] = "Right Thumb Y"
const char16 | LABEL_STATE_RIGHT_TRIGGER [] = "Right Trigger"
const float | LINE_HEIGHT = FONT_SIZE_HEADER * 1.5f
const char16 | MSG_NEED_CONTROLLER [] = "Please attach an Xbox 360 common controller device."
const char16 | STATE_HEADER [] = "XInput State"
const char16 | VALUE_CAPS_VOICE_SUPPORT [] = "Voice Support"
const char16 | VALUE_CAPS_WIRED [] = "Wired"
const char16 | VALUE_CAPS_WIRELESS [] = "Wireless"
const uint64 | XINPUT_ENUM_TIMEOUT_MS = 2000

Variable Documentation

const char16 anonymous_namespace{SimpleController.cpp}::APPLICATION_TITLE[] = "XInput game controller sample"

Definition at line 14 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::CAPS_DATA_START = INFORMATION_START_X + 400.0f

Definition at line 30 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::CAPS_HEADER[] = "XInput Capabilties"

Definition at line 45 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::CAPS_LABEL_START = INFORMATION_START_X + 300.0f

Definition at line 29 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::CLEAR_COLOR[4] = { 0.071f, 0.040f, 0.561f, 1.0f }

Definition at line 16 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::FONT_LOCAL[] = "en-US"

Definition at line 18 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::FONT_NAME[] = "Segoe UI"

Definition at line 19 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::FONT_SIZE_HEADER = 18.0f

Definition at line 20 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::FONT_SIZE_TEXT = 18.0f

Definition at line 21 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::INFORMATION_START_X = 32.0f

Definition at line 23 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::INFORMATION_START_Y = 150.0f

Definition at line 24 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::INPUT_DATA_START = INFORMATION_START_X + 132.0f

Definition at line 28 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::INPUT_LABEL_START = INFORMATION_START_X

Definition at line 27 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_CAPS_FLAGS[] = "Flags"

Definition at line 48 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_CAPS_SUBTYPE[] = "Subtype"

Definition at line 47 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_CAPS_TYPE[] = "Type"

Definition at line 46 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_STATE_BUTTONS[] = "Buttons"

Definition at line 43 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_STATE_LEFT_THUMB_X[] = "Left Thumb X"

Definition at line 39 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_STATE_LEFT_THUMB_Y[] = "Left Thumb Y"

Definition at line 40 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_STATE_LEFT_TRIGGER[] = "Left Trigger"

Definition at line 37 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_STATE_PACKET_NUMBER[] = "Packet Number"

Definition at line 36 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_STATE_RIGHT_THUMB_X[] = "Right Thumb X"

Definition at line 41 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_STATE_RIGHT_THUMB_Y[] = "Right Thumb Y"

Definition at line 42 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::LABEL_STATE_RIGHT_TRIGGER[] = "Right Trigger"

Definition at line 38 of file SimpleController.cpp.

const float anonymous_namespace{SimpleController.cpp}::LINE_HEIGHT = FONT_SIZE_HEADER * 1.5f

Definition at line 25 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::MSG_NEED_CONTROLLER[] = "Please attach an Xbox 360 common controller device."

Definition at line 32 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::STATE_HEADER[] = "XInput State"

Definition at line 35 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::VALUE_CAPS_VOICE_SUPPORT[] = "Voice Support"

Definition at line 51 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::VALUE_CAPS_WIRED[] = "Wired"

Definition at line 49 of file SimpleController.cpp.

const char16 anonymous_namespace{SimpleController.cpp}::VALUE_CAPS_WIRELESS[] = "Wireless"

Definition at line 50 of file SimpleController.cpp.

const uint64 anonymous_namespace{SimpleController.cpp}::XINPUT_ENUM_TIMEOUT_MS = 2000

Definition at line 33 of file SimpleController.cpp.

Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{SoundFileReader.cpp} Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions | Variables

anonymous_namespace{SoundFileReader.cpp} Namespace Reference

Classes

struct | ChunkHeader

Functions

uint64 | FindChunk (RandomAccessReader^file, uint32 tag, uint64 startLoc, uint64 endLoc)
void | ReadHeader (RandomAccessReader^file, uint64 loc, ChunkHeader &header)

Variables

const uint32 | FOURCC_DATA_TAG = 'atad'
const uint32 | FOURCC_FORMAT_TAG = ' tmf'
const uint32 | FOURCC_RIFF_TAG = 'FFIR'
const uint32 | FOURCC_WAVE_FILE_TAG = 'EVAW'

Function Documentation

uint64 anonymous_namespace{SoundFileReader.cpp}::FindChunk | ( | RandomAccessReader^ | file,
 |  | uint32 | tag,
 |  | uint64 | startLoc,
 |  | uint64 | endLoc
 | ) |  |

Definition at line 35 of file SoundFileReader.cpp.

    {
        // Move to start of search
        file->SeekAbsolute(startLoc);

        uint64 newLoc = startLoc;
        while (endLoc > (newLoc + sizeof(ChunkHeader)))
        {
            Platform::Array<byte>^ headerBytes = file->Read(sizeof(ChunkHeader));
            ChunkHeader* header = reinterpret_cast<ChunkHeader*>(headerBytes->Data);
            if (header->tag == tag)
            {
                // Found the requested tag
                return newLoc;
            }
            file->SeekRelative(static_cast<int64>(header->size));
            newLoc += header->size + sizeof(*header);
        }

        // Chunk with sent tag was not found
        throw ref new Platform::FailureException();
    }

void anonymous_namespace{SoundFileReader.cpp}::ReadHeader | ( | RandomAccessReader^ | file,
 |  | uint64 | loc,
 |  | ChunkHeader & | header
 | ) |  |

Definition at line 66 of file SoundFileReader.cpp.

    {
        // Move to read location
        file->SeekAbsolute(loc);
        Platform::Array<byte>^ headerBytes = file->Read(sizeof(ChunkHeader));
        header = *reinterpret_cast<ChunkHeader*>(headerBytes->Data);
    }

Variable Documentation

const uint32 anonymous_namespace{SoundFileReader.cpp}::FOURCC_DATA_TAG = 'atad'

Definition at line 19 of file SoundFileReader.cpp.

const uint32 anonymous_namespace{SoundFileReader.cpp}::FOURCC_FORMAT_TAG = ' tmf'

Definition at line 18 of file SoundFileReader.cpp.

const uint32 anonymous_namespace{SoundFileReader.cpp}::FOURCC_RIFF_TAG = 'FFIR'

Definition at line 17 of file SoundFileReader.cpp.

const uint32 anonymous_namespace{SoundFileReader.cpp}::FOURCC_WAVE_FILE_TAG = 'EVAW'

Definition at line 20 of file SoundFileReader.cpp.

Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{StreamEffect.cpp} Namespace Reference

  • Namespace List
  • Namespace Members
Variables

anonymous_namespace{StreamEffect.cpp} Namespace Reference

Variables

const char16 | APPLICATION_TITLE [] = "XAudio2 audio stream playback sample"
const size_t | BUFFER_COUNT = 3
const char16 | FONT_LOCALE [] = "en-US"
const char16 | FONT_NAME [] = "Segoe UI"
const float | FONT_SIZE_TEXT = 18.0f
const float | INFORMATION_START_X = 32.0f
const float | INFORMATION_START_Y = 150.0f
const char16 | MSG_NEED_AUDIO [] = "No usable audio devices were found; install an audio device and restart the sample."
const char16 | MUSIC_FILE [] = "Media\\Wavs\\becky.wma"

Variable Documentation

const char16 anonymous_namespace{StreamEffect.cpp}::APPLICATION_TITLE[] = "XAudio2 audio stream playback sample"

Definition at line 14 of file StreamEffect.cpp.

const size_t anonymous_namespace{StreamEffect.cpp}::BUFFER_COUNT = 3

Definition at line 17 of file StreamEffect.cpp.

const char16 anonymous_namespace{StreamEffect.cpp}::FONT_LOCALE[] = "en-US"

Definition at line 23 of file StreamEffect.cpp.

const char16 anonymous_namespace{StreamEffect.cpp}::FONT_NAME[] = "Segoe UI"

Definition at line 24 of file StreamEffect.cpp.

const float anonymous_namespace{StreamEffect.cpp}::FONT_SIZE_TEXT = 18.0f

Definition at line 25 of file StreamEffect.cpp.

const float anonymous_namespace{StreamEffect.cpp}::INFORMATION_START_X = 32.0f

Definition at line 20 of file StreamEffect.cpp.

const float anonymous_namespace{StreamEffect.cpp}::INFORMATION_START_Y = 150.0f

Definition at line 21 of file StreamEffect.cpp.

const char16 anonymous_namespace{StreamEffect.cpp}::MSG_NEED_AUDIO[] = "No usable audio devices were found; install an audio device and restart the sample."

Definition at line 19 of file StreamEffect.cpp.

const char16 anonymous_namespace{StreamEffect.cpp}::MUSIC_FILE[] = "Media\\Wavs\\becky.wma"

Definition at line 15 of file StreamEffect.cpp.

Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{SuspensionManager.cpp} Namespace Reference

  • Namespace List
  • Namespace Members
Enumerations | Functions | Variables

anonymous_namespace{SuspensionManager.cpp} Namespace Reference

Enumerations

enum StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}
enum StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}
enum StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}
enum StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

Functions

Platform::Object | ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | ReadObject (DataReader^reader)
String | ReadString (DataReader^reader)
IMap< String^, Object^> | ReadStringToObjectMap (DataReader^reader)
void | WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | WriteObject (DataWriter^writer, Object^object)
void | WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | WriteString (DataWriter^writer, String^string)
void | WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)

Variables

std::vector< WeakFrame^> | _registeredFrames
Map< String^, Object^> | _sessionState = ref new Map<String^, Object^>()
DependencyProperty | FrameSessionStateKeyProperty
DependencyProperty | FrameSessionStateProperty
String | sessionStateFilename = "_sessionState.dat"

Enumeration Type Documentation

enum anonymous_namespace{SuspensionManager.cpp}::StreamTypes
Enumerator:
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker

Definition at line 298 of file SuspensionManager.cpp.

                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };

enum anonymous_namespace{SuspensionManager.cpp}::StreamTypes
Enumerator:
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker

Definition at line 298 of file SuspensionManager.cpp.

                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };

enum anonymous_namespace{SuspensionManager.cpp}::StreamTypes
Enumerator:
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker

Definition at line 298 of file SuspensionManager.cpp.

                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };

enum anonymous_namespace{SuspensionManager.cpp}::StreamTypes
Enumerator:
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker
NullPtrType
UInt8Type
UInt16Type
UInt32Type
UInt64Type
Int16Type
Int32Type
Int64Type
SingleType
DoubleType
BooleanType
Char16Type
GuidType
StringType
StringToObjectMapType
MapEndMarker

Definition at line 294 of file SuspensionManager.cpp.

                   {
    NullPtrType = 0,

    // Supported IPropertyValue types
    UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
    SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

    // Additional supported types
    StringToObjectMapType,

    // Marker values used to ensure stream integrity
    MapEndMarker
  };

Function Documentation

Platform::Object anonymous_namespace{SuspensionManager.cpp}::ReadObject ( Windows::Storage::Streams::DataReader^ reader )
Object anonymous_namespace{SuspensionManager.cpp}::ReadObject ( DataReader^ reader )

Definition at line 440 of file SuspensionManager.cpp.

    {
        auto type = reader->ReadByte();
        switch (type)
        {
        case NullPtrType:
            return nullptr;
        case UInt8Type:
            return reader->ReadByte();
        case UInt16Type:
            return reader->ReadUInt16();
        case UInt32Type:
            return reader->ReadUInt32();
        case UInt64Type:
            return reader->ReadUInt64();
        case Int16Type:
            return reader->ReadInt16();
        case Int32Type:
            return reader->ReadInt32();
        case Int64Type:
            return reader->ReadInt64();
        case SingleType:
            return reader->ReadSingle();
        case DoubleType:
            return reader->ReadDouble();
        case BooleanType:
            return reader->ReadBoolean();
        case Char16Type:
            return (char16_t)reader->ReadUInt16();
        case GuidType:
            return reader->ReadGuid();
        case StringType:
            return ReadString(reader);
        case StringToObjectMapType:
            return ReadStringToObjectMap(reader);
        default:
            throw ref new InvalidArgumentException("Unsupported property type");
        }
    }

String anonymous_namespace{SuspensionManager.cpp}::ReadString ( DataReader^ reader )

Definition at line 416 of file SuspensionManager.cpp.

    {
        int length = reader->ReadUInt32();
        String^ string = reader->ReadString(length);
        return string;
    }

IMap< String^, Object^> anonymous_namespace{SuspensionManager.cpp}::ReadStringToObjectMap ( DataReader^ reader )

Definition at line 423 of file SuspensionManager.cpp.

    {
        auto map = ref new Map<String^, Object^>();
        auto size = reader->ReadUInt32();
        for (unsigned int index = 0; index < size; index++)
        {
            auto key = safe_cast<String^>(ReadObject(reader));
            auto value = ReadObject(reader);
            map->Insert(key, value);
        }
        if (reader->ReadByte() != MapEndMarker)
        {
            throw ref new InvalidArgumentException("Invalid stream");
        }
        return map;
    }

void anonymous_namespace{SuspensionManager.cpp}::WriteObject | ( | Windows::Storage::Streams::DataWriter^ | writer,
 |  | Platform::Object^ | object
 | ) |  |
void anonymous_namespace{SuspensionManager.cpp}::WriteObject | ( | DataWriter^ | writer,
 |  | Object^ | object
 | ) |  |

Definition at line 391 of file SuspensionManager.cpp.

    {
        if (object == nullptr)
        {
            writer->WriteByte(NullPtrType);
            return;
        }

        auto propertyObject = dynamic_cast<IPropertyValue^>(object);
        if (propertyObject != nullptr)
        {
            WriteProperty(writer, propertyObject);
            return;
        }

        auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
        if (mapObject != nullptr)
        {
            WriteStringToObjectMap(writer, mapObject);
            return;
        }

        throw ref new InvalidArgumentException("Unsupported data type");
    }

void anonymous_namespace{SuspensionManager.cpp}::WriteProperty | ( | DataWriter^ | writer,
 |  | IPropertyValue^ | propertyValue
 | ) |  |

Definition at line 319 of file SuspensionManager.cpp.

    {
        switch (propertyValue->Type)
        {
        case PropertyType::UInt8:
            writer->WriteByte(UInt8Type);
            writer->WriteByte(propertyValue->GetUInt8());
            return;
        case PropertyType::UInt16:
            writer->WriteByte(UInt16Type);
            writer->WriteUInt16(propertyValue->GetUInt16());
            return;
        case PropertyType::UInt32:
            writer->WriteByte(UInt32Type);
            writer->WriteUInt32(propertyValue->GetUInt32());
            return;
        case PropertyType::UInt64:
            writer->WriteByte(UInt64Type);
            writer->WriteUInt64(propertyValue->GetUInt64());
            return;
        case PropertyType::Int16:
            writer->WriteByte(Int16Type);
            writer->WriteUInt16(propertyValue->GetInt16());
            return;
        case PropertyType::Int32:
            writer->WriteByte(Int32Type);
            writer->WriteUInt32(propertyValue->GetInt32());
            return;
        case PropertyType::Int64:
            writer->WriteByte(Int64Type);
            writer->WriteUInt64(propertyValue->GetInt64());
            return;
        case PropertyType::Single:
            writer->WriteByte(SingleType);
            writer->WriteSingle(propertyValue->GetSingle());
            return;
        case PropertyType::Double:
            writer->WriteByte(DoubleType);
            writer->WriteDouble(propertyValue->GetDouble());
            return;
        case PropertyType::Boolean:
            writer->WriteByte(BooleanType);
            writer->WriteBoolean(propertyValue->GetBoolean());
            return;
        case PropertyType::Char16:
            writer->WriteByte(Char16Type);
            writer->WriteUInt16(propertyValue->GetChar16());
            return;
        case PropertyType::Guid:
            writer->WriteByte(GuidType);
            writer->WriteGuid(propertyValue->GetGuid());
            return;
        case PropertyType::String:
            WriteString(writer, propertyValue->GetString());
            return;
        default:
            throw ref new InvalidArgumentException("Unsupported property type");
        }
    }

void anonymous_namespace{SuspensionManager.cpp}::WriteString | ( | DataWriter^ | writer,
 |  | String^ | string
 | ) |  |

Definition at line 312 of file SuspensionManager.cpp.

    {
        writer->WriteByte(StringType);
        writer->WriteUInt32(writer->MeasureString(string));
        writer->WriteString(string);
    }

void anonymous_namespace{SuspensionManager.cpp}::WriteStringToObjectMap | ( | DataWriter^ | writer,
 |  | IMap< String^, Object^>^ | map
 | ) |  |

Definition at line 379 of file SuspensionManager.cpp.

    {
        writer->WriteByte(StringToObjectMapType);
        writer->WriteUInt32(map->Size);
        for (auto&& pair : map)
        {
            WriteObject(writer, pair->Key);
            WriteObject(writer, pair->Value);
        }
        writer->WriteByte(MapEndMarker);
    }

Variable Documentation

std::vector< WeakFrame^> anonymous_namespace{SuspensionManager.cpp}::_registeredFrames

Definition at line 76 of file SuspensionManager.cpp.

Map< String^, Object^> anonymous_namespace{SuspensionManager.cpp}::_sessionState = ref new Map<String^, Object^>()

Definition at line 38 of file SuspensionManager.cpp.

DependencyProperty anonymous_namespace{SuspensionManager.cpp}::FrameSessionStateKeyProperty
Initial value:
        DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
        TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr)

Definition at line 77 of file SuspensionManager.cpp.

DependencyProperty anonymous_namespace{SuspensionManager.cpp}::FrameSessionStateProperty
Initial value:
        DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
        TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr)

Definition at line 80 of file SuspensionManager.cpp.

String anonymous_namespace{SuspensionManager.cpp}::sessionStateFilename = "_sessionState.dat"

Definition at line 39 of file SuspensionManager.cpp.

Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: anonymous_namespace{suspensionmanager.cpp} Namespace Reference

Main Page

Namespaces

Classes

Files

Directories

Namespace List

Namespace Members

Enumerations | Functions | Variables

anonymous_namespace{suspensionmanager.cpp} Namespace Reference

Enumerations

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

enum

StreamTypes {
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker,
NullPtrType = 0, UInt8Type, UInt16Type, UInt32Type,
UInt64Type, Int16Type, Int32Type, Int64Type,
SingleType, DoubleType, BooleanType, Char16Type,
GuidType, StringType, StringToObjectMapType, MapEndMarker
}

Functions

Platform::Object

ReadObject (Windows::Storage::Streams::DataReader^reader)

Object

ReadObject (DataReader^reader)

String

ReadString (DataReader^reader)

IMap< String^, Object^>

ReadStringToObjectMap (DataReader^reader)

void

WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)

void

WriteObject (DataWriter^writer, Object^object)

void

WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)

void

WriteString (DataWriter^writer, String^string)

void

WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)

Variables

std::vector< WeakFrame^>

_registeredFrames

Map< String^, Object^>

_sessionState = ref new Map<String^, Object^>()

DependencyProperty

FrameSessionStateKeyProperty

DependencyProperty

FrameSessionStateProperty

String

sessionStateFilename = "_sessionState.dat"

Enumeration Type Documentation

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes

Enumerator:

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

NullPtrType

UInt8Type

UInt16Type

UInt32Type

UInt64Type

Int16Type

Int32Type

Int64Type

SingleType

DoubleType

BooleanType

Char16Type

GuidType

StringType

StringToObjectMapType

MapEndMarker

Definition at line 298 of file suspensionmanager.cpp.
                     {
        NullPtrType = 0,

        // Supported IPropertyValue types
        UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
        SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,

        // Additional supported types
        StringToObjectMapType,

        // Marker values used to ensure stream integrity
        MapEndMarker
    };
Function Documentation

Platform::Object anonymous_namespace{suspensionmanager.cpp}::ReadObject

(

Windows::Storage::Streams::DataReader^

reader

)

Object anonymous_namespace{suspensionmanager.cpp}::ReadObject

(

DataReader^

reader

)

Definition at line 440 of file suspensionmanager.cpp.
    {
        auto type = reader->ReadByte();
        switch (type)
        {
        case NullPtrType:
            return nullptr;
        case UInt8Type:
            return reader->ReadByte();
        case UInt16Type:
            return reader->ReadUInt16();
        case UInt32Type:
            return reader->ReadUInt32();
        case UInt64Type:
            return reader->ReadUInt64();
        case Int16Type:
            return reader->ReadInt16();
        case Int32Type:
            return reader->ReadInt32();
        case Int64Type:
            return reader->ReadInt64();
        case SingleType:
            return reader->ReadSingle();
        case DoubleType:
            return reader->ReadDouble();
        case BooleanType:
            return reader->ReadBoolean();
        case Char16Type:
            return (char16_t)reader->ReadUInt16();
        case GuidType:
            return reader->ReadGuid();
        case StringType:
            return ReadString(reader);
        case StringToObjectMapType:
            return ReadStringToObjectMap(reader);
        default:
            throw ref new InvalidArgumentException("Unsupported property type");
        }
    }
String anonymous_namespace{suspensionmanager.cpp}::ReadString

(

DataReader^

reader

)

Definition at line 416 of file suspensionmanager.cpp.
    {
        int length = reader->ReadUInt32();
        String^ string = reader->ReadString(length);
        return string;
    }
IMap< String^, Object^> anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap

(

DataReader^

reader

)

Definition at line 423 of file suspensionmanager.cpp.
    {
        auto map = ref new Map<String^, Object^>();
        auto size = reader->ReadUInt32();
        for (unsigned int index = 0; index < size; index++)
        {
            auto key = safe_cast<String^>(ReadObject(reader));
            auto value = ReadObject(reader);
            map->Insert(key, value);
        }
        if (reader->ReadByte() != MapEndMarker)
        {
            throw ref new InvalidArgumentException("Invalid stream");
        }
        return map;
    }
void anonymous_namespace{suspensionmanager.cpp}::WriteObject

(

Windows::Storage::Streams::DataWriter^

writer,

Platform::Object^

object

)

void anonymous_namespace{suspensionmanager.cpp}::WriteObject

(

DataWriter^

writer,

Object^

object

)

Definition at line 391 of file suspensionmanager.cpp.
    {
        if (object == nullptr)
        {
            writer->WriteByte(NullPtrType);
            return;
        }

        auto propertyObject = dynamic_cast<IPropertyValue^>(object);
        if (propertyObject != nullptr)
        {
            WriteProperty(writer, propertyObject);
            return;
        }

        auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
        if (mapObject != nullptr)
        {
            WriteStringToObjectMap(writer, mapObject);
            return;
        }

        throw ref new InvalidArgumentException("Unsupported data type");
    }
void anonymous_namespace{suspensionmanager.cpp}::WriteProperty

(

DataWriter^

writer,

IPropertyValue^

propertyValue

)

Definition at line 319 of file suspensionmanager.cpp.
    {
        switch (propertyValue->Type)
        {
        case PropertyType::UInt8:
            writer->WriteByte(UInt8Type);
            writer->WriteByte(propertyValue->GetUInt8());
            return;
        case PropertyType::UInt16:
            writer->WriteByte(UInt16Type);
            writer->WriteUInt16(propertyValue->GetUInt16());
            return;
        case PropertyType::UInt32:
            writer->WriteByte(UInt32Type);
            writer->WriteUInt32(propertyValue->GetUInt32());
            return;
        case PropertyType::UInt64:
            writer->WriteByte(UInt64Type);
            writer->WriteUInt64(propertyValue->GetUInt64());
            return;
        case PropertyType::Int16:
            writer->WriteByte(Int16Type);
            writer->WriteUInt16(propertyValue->GetInt16());
            return;
        case PropertyType::Int32:
            writer->WriteByte(Int32Type);
            writer->WriteUInt32(propertyValue->GetInt32());
            return;
        case PropertyType::Int64:
            writer->WriteByte(Int64Type);
            writer->WriteUInt64(propertyValue->GetInt64());
            return;
        case PropertyType::Single:
            writer->WriteByte(SingleType);
            writer->WriteSingle(propertyValue->GetSingle());
            return;
        case PropertyType::Double:
            writer->WriteByte(DoubleType);
            writer->WriteDouble(propertyValue->GetDouble());
            return;
        case PropertyType::Boolean:
            writer->WriteByte(BooleanType);
            writer->WriteBoolean(propertyValue->GetBoolean());
            return;
        case PropertyType::Char16:
            writer->WriteByte(Char16Type);
            writer->WriteUInt16(propertyValue->GetChar16());
            return;
        case PropertyType::Guid:
            writer->WriteByte(GuidType);
            writer->WriteGuid(propertyValue->GetGuid());
            return;
        case PropertyType::String:
            WriteString(writer, propertyValue->GetString());
            return;
        default:
            throw ref new InvalidArgumentException("Unsupported property type");
        }
    }
void anonymous_namespace{suspensionmanager.cpp}::WriteString

(

DataWriter^

writer,

String^

string

)

Definition at line 312 of file suspensionmanager.cpp.
    {
        writer->WriteByte(StringType);
        writer->WriteUInt32(writer->MeasureString(string));
        writer->WriteString(string);
    }
void anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap

(

DataWriter^

writer,

IMap< String^, Object^>^

map

)

Definition at line 379 of file suspensionmanager.cpp.
    {
        writer->WriteByte(StringToObjectMapType);
        writer->WriteUInt32(map->Size);
        for (auto&& pair : map)
        {
            WriteObject(writer, pair->Key);
            WriteObject(writer, pair->Value);
        }
        writer->WriteByte(MapEndMarker);
    }
Variable Documentation

std::vector< WeakFrame^> anonymous_namespace{suspensionmanager.cpp}::_registeredFrames

Definition at line 76 of file suspensionmanager.cpp.

Map< String^, Object^> anonymous_namespace{suspensionmanager.cpp}::_sessionState = ref new Map<String^, Object^>()

Definition at line 38 of file suspensionmanager.cpp.

DependencyProperty anonymous_namespace{suspensionmanager.cpp}::FrameSessionStateKeyProperty

Initial value:
        DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
        TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr)
Definition at line 77 of file suspensionmanager.cpp.

DependencyProperty anonymous_namespace{suspensionmanager.cpp}::FrameSessionStateProperty

Initial value:
        DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
        TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr)
Definition at line 80 of file suspensionmanager.cpp.

String anonymous_namespace{suspensionmanager.cpp}::sessionStateFilename = "_sessionState.dat"

Definition at line 39 of file suspensionmanager.cpp.

Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by 1.7.1


Win8-Examples: anonymous_namespace{XAudio2SoundPlayer.cpp} Namespace Reference

  • Namespace List
  • Namespace Members
Classes

anonymous_namespace{XAudio2SoundPlayer.cpp} Namespace Reference

Classes

class SoundCallbackHander
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AntSystem Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions

AntSystem Namespace Reference

Classes

class | Ant
struct | Edge
struct | LatLong
struct | Node

Functions

double | ComputeHeuristicShortestDistance (const vector< shared_ptr< Node >> &nodes, const vector< shared_ptr< Edge >> &edges)
double | ComputeLengthOfRoute (const vector< shared_ptr< Node >> &nodes, const vector< size_t > &indices, const vector< shared_ptr< Edge >> &edges)
template<typename IterType >
IterType::value_type | FindEdge (IterType firstEdge, IterType lastEdge, const shared_ptr< Node > pointA, const shared_ptr< Node > pointB)
std::vector< size_t > | OptimizeRoute (std::vector< std::shared_ptr< Node >> &nodes, std::vector< std::shared_ptr< Edge >> &edges, double alpha, double beta, double rho, unsigned int iterations, concurrency::cancellation_token cancellationToken, std::function< void(unsigned int)> *progressCallback=nullptr, bool parallel=true)
vector< size_t > | OptimizeRoute (vector< shared_ptr< Node >> &nodes, vector< shared_ptr< Edge >> &edges, double alpha, double beta, double rho, unsigned int iterations, cancellation_token cancellationToken, function< void(unsigned int)> *progressCallback, bool parallel)

Function Documentation

double AntSystem::ComputeHeuristicShortestDistance | ( | const vector< shared_ptr< Node >> & | nodes,
 |  | const vector< shared_ptr< Edge >> & | edges
 | ) |  |

Definition at line 62 of file AntSystem.cpp.

    {
        // Hold index of each node that we visit during the tour.
        vector<size_t> heuristicBestRoute;

        //
        // Use the nearest neighbor algorithm to compute the shortest tour.
        // http://en.wikipedia.org/wiki/Nearest_neighbour_algorithm
        //

        size_t S = 0;
        size_t C = 0;
        size_t V = 0;

        list<size_t> visited;
        visited.push_back(C);

        heuristicBestRoute.push_back(C);

        while (visited.size() < nodes.size())
        {
            double closestDistance = -1.0;

            for (size_t i = 0; i < nodes.size(); ++i)
            {
                if (find(begin(visited), end(visited), i) == end(visited))
                {
                    double c = FindEdge(begin(edges), end(edges), nodes[C], nodes[i])->TravelDistance;
                    if (closestDistance < 0 || c < closestDistance)
                    {
                        closestDistance = c;
                        V = i;
                    }
                }
            }
            C = V;
            heuristicBestRoute.push_back(C);
            visited.push_back(V);
        }
        heuristicBestRoute.push_back(S);

        // Return the length of the tour.
        return ComputeLengthOfRoute(nodes, heuristicBestRoute, edges);
    }

double AntSystem::ComputeLengthOfRoute | ( | const vector< shared_ptr< Node >> & | nodes,
 |  | const vector< size_t > & | indices,
 |  | const vector< shared_ptr< Edge >> & | edges
 | ) |  |

Definition at line 39 of file AntSystem.cpp.

    {
        double length = 0.0;

        auto index_start = begin(indices);
        auto index_end = index_start + 1;

        while (index_end != end(indices))
        {
            length += FindEdge(begin(edges), end(edges),
                nodes[*index_start], nodes[*index_end])->TravelDistance;

            index_start++;
            index_end++;
        }
        return length;
    }

template<typename IterType >
IterType::value_type AntSystem::FindEdge | ( | IterType | firstEdge,
 |  | IterType | lastEdge,
 |  | const shared_ptr< Node > | pointA,
 |  | const shared_ptr< Node > | pointB
 | ) |  |

Definition at line 23 of file AntSystem.cpp.

    {
        typedef IterType::value_type EdgeType;
        auto result = find_if(firstEdge, lastEdge, [&pointA, &pointB](EdgeType edge)
        {
            return (edge->PointA == pointA && edge->PointB == pointB) ||
                (edge->PointA == pointB && edge->PointB == pointA);
        });
        return result != lastEdge ? (*result) : nullptr;
    }

std::vector<size_t> AntSystem::OptimizeRoute | ( | std::vector< std::shared_ptr< Node >> & | nodes,
 |  | std::vector< std::shared_ptr< Edge >> & | edges,
 |  | double | alpha,
 |  | double | beta,
 |  | double | rho,
 |  | unsigned int | iterations,
 |  | concurrency::cancellation_token | cancellationToken,
 |  | std::function< void(unsigned int)> * | progressCallback = nullptr,
 |  | bool | parallel = true
 | ) |  |
vector<size_t> AntSystem::OptimizeRoute | ( | vector< shared_ptr< Node >> & | nodes,
 |  | vector< shared_ptr< Edge >> & | edges,
 |  | double | alpha,
 |  | double | beta,
 |  | double | rho,
 |  | unsigned int | iterations,
 |  | cancellation_token | cancellationToken,
 |  | function< void(unsigned int)> * | progressCallback,
 |  | bool | parallel
 | ) |  |

Definition at line 273 of file AntSystem.cpp.

    {
        // Compute the estimated shortest tour through the graph.
        double Q = ComputeHeuristicShortestDistance(nodes, edges);

        //
        // Place a small amount of pheromone on each edge.

        // The initial amount of pheromone is inversely proportional to the
        // number of locations.
        const double initialPheromone = 1.0 / nodes.size();
        for_each(begin(edges), end(edges), [initialPheromone](shared_ptr<AntSystem::Edge> edge)
        {
            edge->Pheromone = initialPheromone;
        });

        //
        // Place an ant on each node.
        vector<Ant> ants;

        for (size_t index = 0; index < nodes.size(); ++index)
        {
            ants.push_back(Ant(nodes, edges, index, Q, alpha, beta));
        }

        // Perform the simulation several times.
        auto startTime = GetTickCount64();
        for (unsigned int i = 0; i < iterations; ++i)
        {
            // Occasionally check for cancellation.
            auto time = GetTickCount64();
            if (time - startTime > 100)
            {
                if (cancellationToken.is_canceled())
                {
                    // Return the empty collection.
                    return vector<size_t>();
                }
                startTime = time;
            }

            // Send progress.
            if (progressCallback != nullptr)
            {
                (*progressCallback)(i);
            }

            //
            // Allow each ant to perform a tour of the graph.
            // Note that this operation can be performed in parallel because each ant acts independently.
            // This step contains no shared data or dependent computations.
            if (parallel)
            {
                parallel_for_each(begin(ants), end(ants), [&](Ant& blitz)
                {
                    blitz.Explore();
                });
            }
            else
            {
                for_each(begin(ants), end(ants), [&](Ant& blitz)
                {
                    blitz.Explore();
                });
            }

            //
            // Evaporate pheromone.
            for_each(begin(edges), end(edges), [rho](shared_ptr<Edge> edge)
            {
                edge->Pheromone *= (1.0 - rho);
            });

            //
            // Allow each ant to backtrack through the graph and drop pheromone on
            // each edge.
            //
            // Note that this operation is NOT performed in parallel because
            // the ants update the pherone value of each edge.
            // Because the backtrack operation is not relatively lengthy, the
            // overhead that is required to synchronize access to the edges would
            // likely outweigh any benefits of parallel processing.
            for_each(begin(ants), end(ants), [&](Ant& blitz)
            {
                blitz.Backtrack();
            });
        }

        // Determine the best route.
        double bestCost = 0.0;
        vector<size_t> bestTour;
        for_each(begin(ants), end(ants), [&bestCost, &bestTour, &nodes, &edges](Ant& ant)
        {
            vector<size_t> tour;
            double tourLength;
            ant.GetTour(tour, tourLength);

            if (bestTour.empty() || tourLength < bestCost)
            {
                bestTour = tour;
                bestCost = tourLength;
            }
        });
        return bestTour;
    }

Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AppBarControl Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

AppBarControl Namespace Reference

Namespaces

namespace | Common

Classes

class | App
class | MainPage
struct | Scenario
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum AppBarControl::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 25 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AppBarControl::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • AppBarControl
  • Common
Classes

AppBarControl::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AssociationLaunching Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

AssociationLaunching Namespace Reference

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum AssociationLaunching::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 30 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Namespace Reference

  • Namespace List
  • Namespace Members
Classes

Background Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BackgroundTask Namespace Reference

  • Namespace List
  • Namespace Members
Classes

BackgroundTask Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BackgroundTasks Namespace Reference

  • Namespace List
  • Namespace Members
Classes

BackgroundTasks Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSprites Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

BasicSprites Namespace Reference

Namespaces

namespace | Parameters

Classes

struct | InstanceData
struct | InstancingVertex
struct | ReplicationVertex
class | SpriteBatch
struct | SpriteRunInfo
struct | TextureMapElement

Enumerations

enum | BlendMode { Alpha, Additive }
enum PositionUnits {
DIPs, Pixels, Normalized, UniformWidth,
UniformHeight
}
enum | RenderTechnique { Replication, Instancing, GeometryShader }
enum | SizeUnits { DIPs, Pixels, Normalized }

Enumeration Type Documentation

enum BasicSprites::BlendMode
Enumerator:
Alpha
Additive

Definition at line 40 of file BasicSprites.h.

    {
        Alpha,   // Use alpha blending (out = old * (1 - new.a) + new * new.a).
        Additive // Use additive blending (out = old + new * new.a).
    };

enum BasicSprites::PositionUnits
Enumerator:
DIPs
Pixels
Normalized
UniformWidth
UniformHeight

Definition at line 24 of file BasicSprites.h.

    {
        DIPs,         // Interpret position as device-independent pixel values.
        Pixels,       // Interpret position as pixel values.
        Normalized,   // Interpret position as a fraction of the render target dimensions.
        UniformWidth, // Interpret position as a fraction of the render target width.
        UniformHeight // Interpret position as a fraction of the render target height.
    };

enum BasicSprites::RenderTechnique
Enumerator:
Replication
Instancing
GeometryShader

Definition at line 46 of file BasicSprites.h.

    {
        Replication,
        Instancing,
        GeometryShader
    };

enum BasicSprites::SizeUnits
Enumerator:
DIPs
Pixels
Normalized

Definition at line 33 of file BasicSprites.h.

    {
        DIPs,      // Interpret size as device-independent pixel values.
        Pixels,    // Interpret size as pixel values.
        Normalized // Interpret size as a multiplier of the pixel size of the sprite.
    };

Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: BasicSprites::Parameters Namespace Reference

  • Namespace List
  • Namespace Members
  • BasicSprites
  • Parameters

BasicSprites::Parameters Namespace Reference

Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

Clipboard Namespace Reference

Namespaces

namespace | Common

Classes

class | App
class | MainPage
struct | Scenario
class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum Clipboard::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 25 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • Clipboard
  • Common
Classes

Clipboard::Common Namespace Reference

Classes

class LayoutAwarePage
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

ContactPicker Namespace Reference

Namespaces

namespace | Common

Classes

class | App
class | MainPage
class | MainPagePicker
struct | Scenario
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum ContactPicker::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 23 of file Constants.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ContactPicker::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • ContactPicker
  • Common
Classes

ContactPicker::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ConvolutionKernels Namespace Reference

  • Namespace List
  • Namespace Members

ConvolutionKernels Namespace Reference

Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CppSamplesUtils Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes

CppSamplesUtils Namespace Reference

Namespaces

namespace | Details

Classes

class | SuspensionManager
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CppSamplesUtils::Details Namespace Reference

  • Namespace List
  • Namespace Members
  • CppSamplesUtils
  • Details
Functions

CppSamplesUtils::Details Namespace Reference

Functions

Platform::String | ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | FromHexStringTo (Platform::String^str)
template<class T >
T | FromStringTo (Platform::String^str)
template<>
Platform::Guid | FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | ToString (T value)

Function Documentation

Platform::String CppSamplesUtils::Details::ConvertPropertyValueToString ( Windows::Foundation::IPropertyValue^ pv ) [inline]

Definition at line 175 of file CppSamplesUtils.h.

        {
            using namespace Platform;
            using namespace Windows::Foundation;

            String^ valueString;

            switch (pv->Type)
            {
            case PropertyType::String:
                valueString = pv->GetString();
                break;

            case PropertyType::UInt8:
            case PropertyType::UInt16:
            case PropertyType::UInt32:
            case PropertyType::UInt64:
                valueString = ToString(pv->GetUInt64());
                break;

            case PropertyType::Int16:
            case PropertyType::Int32:
            case PropertyType::Int64:
                valueString = ToString(pv->GetInt64());
                break;

            case PropertyType::Single:
                valueString = ToString(pv->GetSingle());
                break;

            case PropertyType::Double:
                valueString = ToString(pv->GetDouble());
                break;

            case PropertyType::Boolean:
                valueString = ToString(pv->GetBoolean());
                break;

            case PropertyType::Char16:
                wchar_t buffer[2];
                buffer[0] = pv->GetChar16();
                buffer[1] = 0;
                valueString = ref new String(buffer);
                break;

            case PropertyType::Guid:
                valueString = pv->GetGuid().ToString();
                break;

            default:
                throw ref new InvalidCastException;
            }

            return valueString;
        }

Platform::Object CppSamplesUtils::Details::ConvertStringToObject | ( | Windows::Foundation::PropertyType | type,
 |  | Platform::String^ | str |
 | ) |  |  | [inline]

Definition at line 134 of file CppSamplesUtils.h.

        {
            using namespace Platform;
            using namespace Windows::Foundation;

            if (type == PropertyType::String)
            {
                return PropertyValue::CreateString(str);
            }

            switch (type)
            {
            case PropertyType::UInt8:
                return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
            case PropertyType::UInt16:
                return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
            case PropertyType::UInt32:
                return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
            case PropertyType::UInt64:
                return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
            case PropertyType::Int16:
                return PropertyValue::CreateInt16(FromStringTo<short>(str));
            case PropertyType::Int32:
                return PropertyValue::CreateInt32(FromStringTo<int>(str));
            case PropertyType::Int64:
                return PropertyValue::CreateInt64(FromStringTo<long long>(str));
            case PropertyType::Single:
                return PropertyValue::CreateSingle(FromStringTo<float>(str));
            case PropertyType::Double:
                return PropertyValue::CreateDouble(FromStringTo<double>(str));
            case PropertyType::Boolean:
                return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
            case PropertyType::Char16:
                return PropertyValue::CreateChar16(str->Data()[0]);
            case PropertyType::Guid:
                return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
            default:
                throw ref new Platform::InvalidCastException;
            }
        }

Windows::Data::Xml::Dom::XmlElement CppSamplesUtils::Details::CreateXmlElementFromObject | ( | Windows::Data::Xml::Dom::XmlDocument^ | doc,
 |  | Platform::String^ | name,
 |  | Platform::Object^ | value |
 | ) |  |  | [inline]

Definition at line 231 of file CppSamplesUtils.h.

        {
            using namespace Platform;
            using namespace Windows::Foundation;
            using namespace Windows::Data::Xml::Dom;

            XmlElement^ element = doc->CreateElement("item");
            element->SetAttribute("name", name);

            IPropertyValue^ pv = (IPropertyValue^)value;
            element->SetAttribute("type", ToString((int)pv->Type));
            element->SetAttribute("value", ConvertPropertyValueToString(pv));

            return element;
        }

concurrency::task< void > CppSamplesUtils::Details::DeserializeSessionState ( Windows::Storage::IStorageFile^ file ) [inline]

Definition at line 272 of file CppSamplesUtils.h.

        {
            using namespace Platform;
            using namespace Windows::Foundation;
            using namespace Windows::Data::Xml::Dom;
            namespace WFC = Windows::Foundation::Collections;

            concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
            return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
            {
                try
                {
                    auto doc = docTask.get();
                    auto items = doc->SelectNodes("/items/item");
                    auto sessionState = SuspensionManager::SessionState();

                    std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
                    {
                        auto element = (IXmlElement^)node;
                        String^ name = element->GetAttribute("name");
                        String^ value = element->GetAttribute("value");
                        PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));

                        Object^ valueObject = ConvertStringToObject(type, value);
                        sessionState->Insert(name, valueObject);
                    });

                }
                catch (Platform::Exception^)
                {
                    // Restoring is best effort
                }
            });
        }

template<class T >
T CppSamplesUtils::Details::FromHexStringTo ( Platform::String^ str ) [inline]

Definition at line 97 of file CppSamplesUtils.h.

        {
            std::wistringstream wiss(str->Data());
            T value = 0;
            wiss >> std::hex >> value;
            return value;
        }

template<class T >
T CppSamplesUtils::Details::FromStringTo ( Platform::String^ str ) [inline]

Definition at line 88 of file CppSamplesUtils.h.

        {
            std::wistringstream wiss(str->Data());
            T value = 0;
            wiss >> value;
            return value;
        }

template<>
Platform::Guid CppSamplesUtils::Details::FromStringTo< Platform::Guid > ( Platform::String^ str ) [inline]
Windows::Foundation::PropertyType CppSamplesUtils::Details::PropertyTypeFromString ( Platform::String^ str ) [inline]

Definition at line 266 of file CppSamplesUtils.h.

        {
            int value = FromStringTo<int>(str);
            return (Windows::Foundation::PropertyType)value;
        }

concurrency::task< void > CppSamplesUtils::Details::SerializeSessionState ( Windows::Storage::IStorageFile^ file ) [inline]

Definition at line 247 of file CppSamplesUtils.h.

        {
            using namespace Windows::Data::Xml::Dom;
            using namespace Windows::Foundation;
            namespace WFC = Windows::Foundation::Collections;
            typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;

            XmlDocument^ doc = ref new XmlDocument;
            doc->AppendChild(doc->CreateElement("items"));
            auto sessionState = SuspensionManager::SessionState();

            std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
            {
                doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
            });

            return concurrency::task<void>(doc->SaveToFileAsync(file));
        }

template<class T >
Platform::String CppSamplesUtils::Details::ToString ( T value ) [inline]

Definition at line 80 of file CppSamplesUtils.h.

        {
            std::wstringstream wss;
            wss << value;
            return ref new Platform::String(wss.str().c_str());
        }

Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CredentialPickerCPP Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

CredentialPickerCPP Namespace Reference

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum CredentialPickerCPP::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 20 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CustomDeviceAccess Namespace Reference

  • Namespace List
  • Namespace Members
Classes

CustomDeviceAccess Namespace Reference

Classes

class | DeviceAsync
An empty page that can be used on its own or navigated to within a Frame. More...
class | DeviceList
class | DeviceListEntry
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2D3DTransforms Namespace Reference

  • Namespace List
  • Namespace Members
Classes

D2D3DTransforms Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: D2DLightingEffects Namespace Reference

  • Namespace List
  • Namespace Members
Classes

D2DLightingEffects Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocketSample Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

DatagramSocketSample Namespace Reference

Namespaces

namespace | Common

Classes

class | MainPage
struct | Scenario
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum DatagramSocketSample::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 25 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocketSample::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • DatagramSocketSample
  • Common
Classes

DatagramSocketSample::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForPrinters Namespace Reference

  • Namespace List
  • Namespace Members
Classes

DeviceAppForPrinters Namespace Reference

Classes

class | App
class | MainPage
struct | Scenario
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForWebcam Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes

DeviceAppForWebcam Namespace Reference

Namespaces

namespace | Common

Classes

class | MainPage
class | sealed
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DeviceAppForWebcam::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • DeviceAppForWebcam
  • Common
Classes

DeviceAppForWebcam::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Functions | Variables

DirectX Namespace Reference

Classes

struct | BC4_SNORM
struct | BC4_UNORM
class | Blob
class | CBits
struct | ConvertData
struct | D3DX_BC1
struct | D3DX_BC2
struct | D3DX_BC3
class | D3DX_BC6H
class | D3DX_BC7
struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT
class | HDRColorA
struct | HDREndPntPair
struct | Image
class | INTColor
struct | INTEndPntPair
class | LDRColorA
struct | LDREndPntPair
struct | LegacyDDS
struct | Rect
class | ScratchImage
struct | TexMetadata

Typedefs

typedef void(* | BC_DECODE )(XMVECTOR *pColor, const uint8_t *pBC)
typedef void(* | BC_ENCODE )(uint8_t *pDXT, const XMVECTOR *pColor, DWORD flags)
typedef enum
DirectX::DDS_RESOURCE_DIMENSION 		DDS_RESOURCE_DIMENSION
typedef enum
DirectX::DDS_RESOURCE_MISC_FLAG 		DDS_RESOURCE_MISC_FLAG

Enumerations

enum | BC_FLAGS { BC_FLAGS_NONE = 0x0, BC_FLAGS_DITHER_RGB = 0x10000, BC_FLAGS_DITHER_A = 0x20000, BC_FLAGS_UNIFORM = 0x40000 }
enum CNMAP_FLAGS {
CNMAP_DEFAULT = 0, CNMAP_CHANNEL_RED = 0x1, CNMAP_CHANNEL_GREEN = 0x2, CNMAP_CHANNEL_BLUE = 0x3,
CNMAP_CHANNEL_ALPHA = 0x4, CNMAP_CHANNEL_LUMINANCE = 0x5, CNMAP_MIRROR_U = 0x1000, CNMAP_MIRROR_V = 0x2000,
CNMAP_MIRROR = 0x3000, CNMAP_INVERT_SIGN = 0x4000, CNMAP_COMPUTE_OCCLUSION = 0x8000
}
enum CONVERSION_FLAGS {
CONV_FLAGS_NONE = 0x0, CONV_FLAGS_EXPAND = 0x1, CONV_FLAGS_NOALPHA = 0x2, CONV_FLAGS_SWIZZLE = 0x4,
CONV_FLAGS_PAL8 = 0x8, CONV_FLAGS_888 = 0x10, CONV_FLAGS_565 = 0x20, CONV_FLAGS_5551 = 0x40,
CONV_FLAGS_4444 = 0x80, CONV_FLAGS_44 = 0x100, CONV_FLAGS_332 = 0x200, CONV_FLAGS_8332 = 0x400,
CONV_FLAGS_A8P8 = 0x800, CONV_FLAGS_DX10 = 0x10000
}
enum CONVERT_FLAGS {
CONVF_FLOAT = 0x1, CONVF_UNORM = 0x2, CONVF_UINT = 0x4, CONVF_SNORM = 0x8,
CONVF_SINT = 0x10, CONVF_DEPTH = 0x20, CONVF_STENCIL = 0x40, CONVF_SHAREDEXP = 0x80,
CONVF_BGR = 0x100, CONVF_X2 = 0x200, CONVF_PACKED = 0x400, CONVF_BC = 0x800,
CONVF_R = 0x10000, CONVF_G = 0x20000, CONVF_B = 0x40000, CONVF_A = 0x80000,
CONVF_RGB_MASK = 0x70000, CONVF_RGBA_MASK = 0xF0000
}
enum CP_FLAGS {
CP_FLAGS_NONE = 0x0, CP_FLAGS_LEGACY_DWORD = 0x1, CP_FLAGS_24BPP = 0x10000, CP_FLAGS_16BPP = 0x20000,
CP_FLAGS_8BPP = 0x40000
}
enum DDS_FLAGS {
DDS_FLAGS_NONE = 0x0, DDS_FLAGS_LEGACY_DWORD = 0x1, DDS_FLAGS_NO_LEGACY_EXPANSION = 0x2, DDS_FLAGS_NO_R10B10G10A2_FIXUP = 0x4,
DDS_FLAGS_FORCE_RGB = 0x8, DDS_FLAGS_NO_16BPP = 0x10, DDS_FLAGS_FORCE_DX10_EXT = 0x10000
}
enum | DDS_RESOURCE_DIMENSION { DDS_DIMENSION_TEXTURE1D = 2, DDS_DIMENSION_TEXTURE2D = 3, DDS_DIMENSION_TEXTURE3D = 4 }
enum | DDS_RESOURCE_MISC_FLAG { DDS_RESOURCE_MISC_TEXTURECUBE = 0x4L }
enum TEX_COMPRESS_FLAGS {
TEX_COMPRESS_DEFAULT = 0, TEX_COMPRESS_RGB_DITHER = 0x10000, TEX_COMPRESS_A_DITHER = 0x20000, TEX_COMPRESS_DITHER = 0x30000,
TEX_COMPRESS_UNIFORM = 0x40000, TEX_COMPRESS_PARALLEL = 0x10000000
}
enum | TEX_DIMENSION { TEX_DIMENSION_TEXTURE1D = 2, TEX_DIMENSION_TEXTURE2D = 3, TEX_DIMENSION_TEXTURE3D = 4 }
enum TEX_FILTER_FLAGS {
TEX_FILTER_DEFAULT = 0, TEX_FILTER_SEPARATE_ALPHA = 0x100, TEX_FILTER_DITHER = 0x10000, TEX_FILTER_DITHER_DIFFUSION = 0x20000,
TEX_FILTER_POINT = 0x100000, TEX_FILTER_LINEAR = 0x200000, TEX_FILTER_CUBIC = 0x300000, TEX_FILTER_FANT = 0x400000,
TEX_FILTER_SRGB_IN = 0x1000000, TEX_FILTER_SRGB_OUT = 0x2000000, TEX_FILTER_SRGB = 0x3000000
}
enum TEX_FR_FLAGS {
TEX_FR_ROTATE0 = 0x0, TEX_FR_ROTATE90 = 0x1, TEX_FR_ROTATE180 = 0x2, TEX_FR_ROTATE270 = 0x3,
TEX_FR_FLIP_HORIZONTAL = 0x08, TEX_FR_FLIP_VERTICAL = 0x10
}
enum | TEX_MISC_FLAG { TEX_MISC_TEXTURECUBE = 0x4L }
enum TEXP_LEGACY_FORMAT {
TEXP_LEGACY_UNKNOWN = 0, TEXP_LEGACY_R8G8B8, TEXP_LEGACY_R3G3B2, TEXP_LEGACY_A8R3G3B2,
TEXP_LEGACY_P8, TEXP_LEGACY_A8P8, TEXP_LEGACY_A4L4, TEXP_LEGACY_B4G4R4A4
}
enum | TEXP_SCANLINE_FLAGS { TEXP_SCANLINE_NONE = 0, TEXP_SCANLINE_SETALPHA = 0x1, TEXP_SCANLINE_LEGACY = 0x2 }
enum WIC_FLAGS {
WIC_FLAGS_NONE = 0x0, WIC_FLAGS_FORCE_RGB = 0x1, WIC_FLAGS_NO_X2_BIAS = 0x2, WIC_FLAGS_NO_16BPP = 0x4,
WIC_FLAGS_ALLOW_MONO = 0x8, WIC_FLAGS_ALL_FRAMES = 0x10, WIC_FLAGS_DITHER = 0x10000, WIC_FLAGS_DITHER_DIFFUSION = 0x20000,
WIC_FLAGS_FILTER_POINT = 0x100000, WIC_FLAGS_FILTER_LINEAR = 0x200000, WIC_FLAGS_FILTER_CUBIC = 0x300000, WIC_FLAGS_FILTER_FANT = 0x400000
}
enum WICCodecs {
WIC_CODEC_BMP = 1, WIC_CODEC_JPEG, WIC_CODEC_PNG, WIC_CODEC_TIFF,
WIC_CODEC_GIF, WIC_CODEC_WMP, WIC_CODEC_ICO
}

Functions

__declspec (selectany) const DDS_PIXELFORMAT DDSPF_DXT1
bool | _CalculateMipLevels (_In_ size_t width, _In_ size_t height, _Inout_ size_t &mipLevels)
bool | _CalculateMipLevels3D (_In_ size_t width, _In_ size_t height, _In_ size_t depth, _Inout_ size_t &mipLevels)
_Use_decl_annotations_ HRESULT | _ConvertFromR32G32B32A32 (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DXGI_FORMAT format, ScratchImage &result)
_Use_decl_annotations_ HRESULT | _ConvertFromR32G32B32A32 (const Image &srcImage, const Image &destImage)
_Use_decl_annotations_ HRESULT | _ConvertFromR32G32B32A32 (const Image &srcImage, DXGI_FORMAT format, ScratchImage &image)
HRESULT | _ConvertFromR32G32B32A32 (_In_ const Image &srcImage, _In_ const Image &destImage)
HRESULT | _ConvertFromR32G32B32A32 (_In_ const Image &srcImage, _In_ DXGI_FORMAT format, _Inout_ ScratchImage &image)
HRESULT | _ConvertFromR32G32B32A32 (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DXGI_FORMAT format, _Out_ ScratchImage &result)
_Use_decl_annotations_ void | _ConvertScanline (XMVECTOR *pBuffer, size_t count, DXGI_FORMAT outFormat, DXGI_FORMAT inFormat, DWORD flags)
void | _ConvertScanline (_Inout_updates_all_(count) XMVECTOR *pBuffer, _In_ size_t count, _In_ DXGI_FORMAT outFormat, _In_ DXGI_FORMAT inFormat, _In_ DWORD flags)
_Use_decl_annotations_ HRESULT | _ConvertToR32G32B32A32 (const Image &srcImage, ScratchImage &image)
HRESULT | _ConvertToR32G32B32A32 (_In_ const Image &srcImage, _Inout_ ScratchImage &image)
void | _CopyScanline (_When_(pDestination==pSource, _Inout_updates_bytes_(outSize)) _When_(pDestination!=pSource, _Out_writes_bytes_(outSize)) LPVOID pDestination, _In_ size_t outSize, _In_reads_bytes_(inSize) LPCVOID pSource, _In_ size_t inSize, _In_ DXGI_FORMAT format, _In_ DWORD flags)
_Use_decl_annotations_ void | _DetermineImageArray (const TexMetadata &metadata, DWORD cpFlags, size_t &nImages, size_t &pixelSize)
void | _DetermineImageArray (_In_ const TexMetadata &metadata, _In_ DWORD cpFlags, _Out_ size_t &nImages, _Out_ size_t &pixelSize)
bool | _DXGIToWIC (_In_ DXGI_FORMAT format, _Out_ GUID &guid)
_Use_decl_annotations_ bool | _DXGIToWIC (DXGI_FORMAT format, GUID &guid)
_Use_decl_annotations_ HRESULT | _EncodeDDSHeader (const TexMetadata &metadata, DWORD flags, LPVOID pDestination, size_t maxsize, size_t &required)
HRESULT | _EncodeDDSHeader (_In_ const TexMetadata &metadata, DWORD flags, _Out_writes_bytes_to_opt_(maxsize, required) LPVOID pDestination, _In_ size_t maxsize, _Out_ size_t &required)
_Use_decl_annotations_ bool | _ExpandScanline (LPVOID pDestination, size_t outSize, DXGI_FORMAT outFormat, LPCVOID pSource, size_t inSize, DXGI_FORMAT inFormat, DWORD flags)
_Use_decl_annotations_ DWORD | _GetConvertFlags (DXGI_FORMAT format)
DWORD | _GetConvertFlags (_In_ DXGI_FORMAT format)
IWICImagingFactory * | _GetWIC ()
WICBitmapDitherType | _GetWICDither (_In_ DWORD flags)
WICBitmapInterpolationMode | _GetWICInterp (_In_ DWORD flags)
_In_ size_t _In_ DXGI_FORMAT | _In_reads_ (count) const XMVECTOR *pSource
size_t _In_ DXGI_FORMAT | _In_reads_bytes_ (inSize) LPCVOID pSource
_In_ size_t | _In_reads_bytes_ (size) LPCVOID pSource
size_t _In_ DXGI_FORMAT size_t
_In_ TEXP_LEGACY_FORMAT 		_In_reads_opt_ (256) const uint32_t *pal8
_Use_decl_annotations_ bool | _LoadScanline (XMVECTOR *pDestination, size_t count, LPCVOID pSource, size_t size, DXGI_FORMAT format)
_In_ size_t _In_ const
TexMetadata _In_ DWORD 		_Out_writes_ (nImages) Image *images
HRESULT | _ResizeSeparateColorAndAlpha (_In_ IWICImagingFactory *pWIC, _In_ IWICBitmap *original, _In_ size_t newWidth, _In_ size_t newHeight, _In_ DWORD filter, _Inout_ const Image *img)
_Use_decl_annotations_ bool | _SetupImageArray (uint8_t *pMemory, size_t pixelSize, const TexMetadata &metadata, DWORD cpFlags, Image *images, size_t nImages)
_Use_decl_annotations_ bool | _StoreScanline (LPVOID pDestination, size_t size, DXGI_FORMAT format, const XMVECTOR *pSource, size_t count)
_Success_ (return!=false) static bool _LegacyExpandScanline(_Out_writes_bytes_(outSize) LPVOID pDestination
_Use_decl_annotations_ void | _SwizzleScanline (LPVOID pDestination, size_t outSize, LPCVOID pSource, size_t inSize, DXGI_FORMAT format, DWORD flags)
void | _SwizzleScanline (_When_(pDestination==pSource, _In_) _When_(pDestination!=pSource, _Out_writes_bytes_(outSize)) LPVOID pDestination, _In_ size_t outSize, _In_reads_bytes_(inSize) LPCVOID pSource, _In_ size_t inSize, _In_ DXGI_FORMAT format, _In_ DWORD flags)
size_t | _WICBitsPerPixel (_In_ REFGUID targetGuid)
_Use_decl_annotations_ size_t | _WICBitsPerPixel (REFGUID targetGuid)
DXGI_FORMAT | _WICToDXGI (_In_ const GUID &guid)
_Use_decl_annotations_ DXGI_FORMAT | _WICToDXGI (const GUID &guid)
size_t | BitsPerPixel (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ size_t | BitsPerPixel (DXGI_FORMAT fmt)
_Use_decl_annotations_ HRESULT | CaptureTexture (ID3D11Device *pDevice, ID3D11DeviceContext *pContext, ID3D11Resource *pSource, ScratchImage &result)
HRESULT | CaptureTexture (_In_ ID3D11Device *pDevice, _In_ ID3D11DeviceContext *pContext, _In_ ID3D11Resource *pSource, _Out_ ScratchImage &result)
_Use_decl_annotations_ HRESULT | Compress (const Image &srcImage, DXGI_FORMAT format, DWORD compress, float alphaRef, ScratchImage &image)
_Use_decl_annotations_ HRESULT | Compress (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DXGI_FORMAT format, DWORD compress, float alphaRef, ScratchImage &cImages)
HRESULT | Compress (_In_ const Image &srcImage, _In_ DXGI_FORMAT format, _In_ DWORD compress, _In_ float alphaRef, _Out_ ScratchImage &cImage)
HRESULT | Compress (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DXGI_FORMAT format, _In_ DWORD compress, _In_ float alphaRef, _Out_ ScratchImage &cImages)
_Use_decl_annotations_ HRESULT | ComputeMSE (const Image &image1, const Image &image2, float &mse, float *mseV)
HRESULT | ComputeMSE (_In_ const Image &image1, _In_ const Image &image2, _Out_ float &mse, _Out_writes_opt_(4) float *mseV)
HRESULT | ComputeNormalMap (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD flags, _In_ float amplitude, _In_ DXGI_FORMAT format, _Out_ ScratchImage &normalMaps)
_Use_decl_annotations_ HRESULT | ComputeNormalMap (const Image &srcImage, DWORD flags, float amplitude, DXGI_FORMAT format, ScratchImage &normalMap)
_Use_decl_annotations_ HRESULT | ComputeNormalMap (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DWORD flags, float amplitude, DXGI_FORMAT format, ScratchImage &normalMaps)
HRESULT | ComputeNormalMap (_In_ const Image &srcImage, _In_ DWORD flags, _In_ float amplitude, _In_ DXGI_FORMAT format, _Out_ ScratchImage &normalMap)
void | ComputePitch (_In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _Out_ size_t &rowPitch, _Out_ size_t &slicePitch, _In_ DWORD flags=CP_FLAGS_NONE)
_Use_decl_annotations_ void | ComputePitch (DXGI_FORMAT fmt, size_t width, size_t height, size_t &rowPitch, size_t &slicePitch, DWORD flags)
_Use_decl_annotations_ size_t | ComputeScanlines (DXGI_FORMAT fmt, size_t height)
size_t | ComputeScanlines (_In_ DXGI_FORMAT fmt, _In_ size_t height)
_Use_decl_annotations_ HRESULT | Convert (const Image &srcImage, DXGI_FORMAT format, DWORD filter, float threshold, ScratchImage &image)
_Use_decl_annotations_ HRESULT | Convert (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DXGI_FORMAT format, DWORD filter, float threshold, ScratchImage &result)
HRESULT | Convert (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DXGI_FORMAT format, _In_ DWORD filter, _In_ float threshold, _Out_ ScratchImage &result)
HRESULT | Convert (_In_ const Image &srcImage, _In_ DXGI_FORMAT format, _In_ DWORD filter, _In_ float threshold, _Out_ ScratchImage &image)
HRESULT | CopyRectangle (_In_ const Image &srcImage, _In_ const Rect &srcRect, _In_ const Image &dstImage, _In_ DWORD filter, _In_ size_t xOffset, _In_ size_t yOffset)
_Use_decl_annotations_ HRESULT | CopyRectangle (const Image &srcImage, const Rect &srcRect, const Image &dstImage, DWORD filter, size_t xOffset, size_t yOffset)
_Use_decl_annotations_ HRESULT | CreateShaderResourceView (ID3D11Device *pDevice, const Image *srcImages, size_t nimages, const TexMetadata &metadata, ID3D11ShaderResourceView **ppSRV)
HRESULT | CreateShaderResourceView (_In_ ID3D11Device *pDevice, _In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _Outptr_ ID3D11ShaderResourceView **ppSRV)
_Use_decl_annotations_ HRESULT | CreateTexture (ID3D11Device *pDevice, const Image *srcImages, size_t nimages, const TexMetadata &metadata, ID3D11Resource **ppResource)
HRESULT | CreateTexture (_In_ ID3D11Device *pDevice, _In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _Outptr_ ID3D11Resource **ppResource)
_Use_decl_annotations_ void | D3DXDecodeBC1 (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC1 (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(8) const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC2 (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC2 (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | D3DXDecodeBC3 (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC3 (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC4S (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(8) const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC4S (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC4U (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(8) const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC4U (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC5S (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC5S (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC5U (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC5U (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC6HS (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC6HS (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC6HU (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC6HU (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | D3DXDecodeBC7 (XMVECTOR *pColor, const uint8_t *pBC)
void | D3DXDecodeBC7 (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | D3DXEncodeBC1 (_Out_writes_(8) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ float alphaRef, _In_ DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC1 (uint8_t *pBC, const XMVECTOR *pColor, float alphaRef, DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC2 (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
void | D3DXEncodeBC2 (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC3 (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
void | D3DXEncodeBC3 (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | D3DXEncodeBC4S (_Out_writes_(8) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC4S (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC4U (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
void | D3DXEncodeBC4U (_Out_writes_(8) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | D3DXEncodeBC5S (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC5S (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC5U (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
void | D3DXEncodeBC5U (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC6HS (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
void | D3DXEncodeBC6HS (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC6HU (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
void | D3DXEncodeBC6HU (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | D3DXEncodeBC7 (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
_Use_decl_annotations_ void | D3DXEncodeBC7 (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ HRESULT | Decompress (const Image &cImage, DXGI_FORMAT format, ScratchImage &image)
_Use_decl_annotations_ HRESULT | Decompress (const Image *cImages, size_t nimages, const TexMetadata &metadata, DXGI_FORMAT format, ScratchImage &images)
HRESULT | Decompress (_In_ const Image &cImage, _In_ DXGI_FORMAT format, _Out_ ScratchImage &image)
HRESULT | Decompress (_In_reads_(nimages) const Image *cImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DXGI_FORMAT format, _Out_ ScratchImage &images)
HRESULT | FlipRotate (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD flags, _Out_ ScratchImage &result)
HRESULT | FlipRotate (_In_ const Image &srcImage, _In_ DWORD flags, _Out_ ScratchImage &image)
_Use_decl_annotations_ HRESULT | FlipRotate (const Image &srcImage, DWORD flags, ScratchImage &image)
_Use_decl_annotations_ HRESULT | FlipRotate (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DWORD flags, ScratchImage &result)
HRESULT | GenerateMipMaps (_In_ const Image &baseImage, _In_ DWORD filter, _In_ size_t levels, _Inout_ ScratchImage &mipChain, _In_ bool allow1D=false)
_Use_decl_annotations_ HRESULT | GenerateMipMaps (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DWORD filter, size_t levels, ScratchImage &mipChain)
_Use_decl_annotations_ HRESULT | GenerateMipMaps (const Image &baseImage, DWORD filter, size_t levels, ScratchImage &mipChain, bool allow1D)
HRESULT | GenerateMipMaps (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD filter, _In_ size_t levels, _Inout_ ScratchImage &mipChain)
_Use_decl_annotations_ HRESULT | GenerateMipMaps3D (const Image *baseImages, size_t depth, DWORD filter, size_t levels, ScratchImage &mipChain)
_Use_decl_annotations_ HRESULT | GenerateMipMaps3D (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DWORD filter, size_t levels, ScratchImage &mipChain)
HRESULT | GenerateMipMaps3D (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD filter, _In_ size_t levels, _Out_ ScratchImage &mipChain)
HRESULT | GenerateMipMaps3D (_In_reads_(depth) const Image *baseImages, _In_ size_t depth, _In_ DWORD filter, _In_ size_t levels, _Out_ ScratchImage &mipChain)
HRESULT | GetMetadataFromDDSFile (_In_ LPCWSTR szFile, _In_ DWORD flags, _Out_ TexMetadata &metadata)
HRESULT | GetMetadataFromDDSMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags, _Out_ TexMetadata &metadata)
_Use_decl_annotations_ HRESULT | GetMetadataFromTGAFile (LPCWSTR szFile, TexMetadata &metadata)
HRESULT | GetMetadataFromTGAFile (_In_ LPCWSTR szFile, _Out_ TexMetadata &metadata)
HRESULT | GetMetadataFromTGAMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _Out_ TexMetadata &metadata)
_Use_decl_annotations_ HRESULT | GetMetadataFromTGAMemory (LPCVOID pSource, size_t size, TexMetadata &metadata)
HRESULT | GetMetadataFromWICFile (_In_ LPCWSTR szFile, _In_ DWORD flags, _Out_ TexMetadata &metadata)
_Use_decl_annotations_ HRESULT | GetMetadataFromWICFile (LPCWSTR szFile, DWORD flags, TexMetadata &metadata)
HRESULT | GetMetadataFromWICMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags, _Out_ TexMetadata &metadata)
_Use_decl_annotations_ HRESULT | GetMetadataFromWICMemory (LPCVOID pSource, size_t size, DWORD flags, TexMetadata &metadata)
REFGUID | GetWICCodec (_In_ WICCodecs codec)
_Use_decl_annotations_ REFGUID | GetWICCodec (WICCodecs codec)
HDRColorA * | HDRColorALerp (_Out_ HDRColorA *pOut, _In_ const HDRColorA *pC1, _In_ const HDRColorA *pC2, _In_ float s)
_Use_decl_annotations_ bool | IsCompressed (DXGI_FORMAT fmt)
bool | IsCompressed (_In_ DXGI_FORMAT fmt)
bool | IsPacked (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsPacked (DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsSRGB (DXGI_FORMAT fmt)
bool | IsSRGB (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsSupportedTexture (ID3D11Device *pDevice, const TexMetadata &metadata)
bool | IsSupportedTexture (_In_ ID3D11Device *pDevice, _In_ const TexMetadata &metadata)
bool | IsTypeless (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsTypeless (DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsValid (DXGI_FORMAT fmt)
bool | IsValid (_In_ DXGI_FORMAT fmt)
bool | IsVideo (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsVideo (DXGI_FORMAT fmt)
HRESULT | LoadFromDDSFile (_In_ LPCWSTR szFile, _In_ DWORD flags, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
HRESULT | LoadFromDDSMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
HRESULT | LoadFromTGAFile (_In_ LPCWSTR szFile, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
_Use_decl_annotations_ HRESULT | LoadFromTGAFile (LPCWSTR szFile, TexMetadata *metadata, ScratchImage &image)
HRESULT | LoadFromTGAMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
_Use_decl_annotations_ HRESULT | LoadFromTGAMemory (LPCVOID pSource, size_t size, TexMetadata *metadata, ScratchImage &image)
HRESULT | LoadFromWICFile (_In_ LPCWSTR szFile, _In_ DWORD flags, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
_Use_decl_annotations_ HRESULT | LoadFromWICFile (LPCWSTR szFile, DWORD flags, TexMetadata *metadata, ScratchImage &image)
_Use_decl_annotations_ HRESULT | LoadFromWICMemory (LPCVOID pSource, size_t size, DWORD flags, TexMetadata *metadata, ScratchImage &image)
HRESULT | LoadFromWICMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
_Use_decl_annotations_ DXGI_FORMAT | MakeSRGB (DXGI_FORMAT fmt)
DXGI_FORMAT | MakeSRGB (_In_ DXGI_FORMAT fmt)
template<bool bRange>
void | OptimizeAlpha (float *pX, float *pY, const float *pPoints, size_t cSteps)
_Use_decl_annotations_ HRESULT | Resize (const Image &srcImage, size_t width, size_t height, DWORD filter, ScratchImage &image)
HRESULT | Resize (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ size_t width, _In_ size_t height, _In_ DWORD filter, _Out_ ScratchImage &result)
_Use_decl_annotations_ HRESULT | Resize (const Image *srcImages, size_t nimages, const TexMetadata &metadata, size_t width, size_t height, DWORD filter, ScratchImage &result)
HRESULT | Resize (_In_ const Image &srcImage, _In_ size_t width, _In_ size_t height, _In_ DWORD filter, _Out_ ScratchImage &image)
HRESULT | SaveToDDSFile (_In_ const Image &image, _In_ DWORD flags, _In_ LPCWSTR szFile)
HRESULT | SaveToDDSFile (_In_reads_(nimages) const Image *images, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD flags, _In_ LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | SaveToDDSFile (const Image &image, DWORD flags, LPCWSTR szFile)
HRESULT | SaveToDDSMemory (_In_reads_(nimages) const Image *images, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD flags, _Out_ Blob &blob)
HRESULT | SaveToDDSMemory (_In_ const Image &image, _In_ DWORD flags, _Out_ Blob &blob)
_Use_decl_annotations_ HRESULT | SaveToDDSMemory (const Image &image, DWORD flags, Blob &blob)
HRESULT | SaveToTGAFile (_In_ const Image &image, _In_ LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | SaveToTGAFile (const Image &image, LPCWSTR szFile)
HRESULT | SaveToTGAMemory (_In_ const Image &image, _Out_ Blob &blob)
_Use_decl_annotations_ HRESULT | SaveToTGAMemory (const Image &image, Blob &blob)
_Use_decl_annotations_ HRESULT | SaveToWICFile (const Image &image, DWORD flags, REFGUID guidContainerFormat, LPCWSTR szFile)
HRESULT | SaveToWICFile (_In_reads_(nimages) const Image *images, _In_ size_t nimages, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _In_ LPCWSTR szFile)
HRESULT | SaveToWICFile (_In_ const Image &image, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _In_ LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | SaveToWICFile (const Image *images, size_t nimages, DWORD flags, REFGUID guidContainerFormat, LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | SaveToWICMemory (const Image *images, size_t nimages, DWORD flags, REFGUID guidContainerFormat, Blob &blob)
HRESULT | SaveToWICMemory (_In_ const Image &image, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _Out_ Blob &blob)
HRESULT | SaveToWICMemory (_In_reads_(nimages) const Image *images, _In_ size_t nimages, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _Out_ Blob &blob)
_Use_decl_annotations_ HRESULT | SaveToWICMemory (const Image &image, DWORD flags, REFGUID guidContainerFormat, Blob &blob)

Variables

const uint32_t | BC67_WEIGHT_MAX = 64
const uint32_t | BC67_WEIGHT_ROUND = 32
const uint32_t | BC67_WEIGHT_SHIFT = 6
const size_t | BC6H_MAX_SHAPES = 32
const size_t | BC6H_NUM_CHANNELS = 3
const size_t | BC7_MAX_SHAPES = 64
const size_t | BC7_NUM_CHANNELS = 4
_In_ size_t | count
_In_ size_t _In_ const
TexMetadata _In_ DWORD 		cpFlags
const uint32_t | DDS_MAGIC = 0x20534444
const uint16_t | F16EM_MASK = 0x7fff
const uint16_t | F16MAX = 0x7bff
const uint16_t | F16S_MASK = 0x8000
_In_ size_t _In_ DXGI_FORMAT
_In_ size_t _In_ DXGI_FORMAT
_In_ DWORD 		flags
_In_ size_t _In_ size_t _In_
DXGI_FORMAT 		format
const int | g_aWeights2 [4] = {0, 21, 43, 64}
const int | g_aWeights3 [8] = {0, 9, 18, 27, 37, 46, 55, 64}
const int | g_aWeights4 [16] = {0, 4, 9, 13, 17, 21, 26, 30, 34, 38, 43, 47, 51, 55, 60, 64}
const LegacyDDS | g_LegacyDDSMap []
size_t _In_ DXGI_FORMAT size_t
_In_ TEXP_LEGACY_FORMAT 		inFormat
size_t _In_ DXGI_FORMAT size_t | inSize
_In_ size_t _In_ const
TexMetadata & 		metadata
_In_ size_t _In_ const
TexMetadata _In_ DWORD _In_
size_t 		nImages
size_t _In_ DXGI_FORMAT | outFormat
size_t | outSize
_In_ size_t | pixelSize
_In_ size_t _In_ size_t | size

Typedef Documentation

typedef void(* DirectX::BC_DECODE)(XMVECTOR *pColor, const uint8_t *pBC)

Definition at line 856 of file BC.h.

typedef void(* DirectX::BC_ENCODE)(uint8_t *pDXT, const XMVECTOR *pColor, DWORD flags)

Definition at line 857 of file BC.h.

typedef enum DirectX::DDS_RESOURCE_DIMENSION DirectX::DDS_RESOURCE_DIMENSION
typedef enum DirectX::DDS_RESOURCE_MISC_FLAG DirectX::DDS_RESOURCE_MISC_FLAG

Enumeration Type Documentation

enum DirectX::BC_FLAGS
Enumerator:
BC_FLAGS_NONE
BC_FLAGS_DITHER_RGB
BC_FLAGS_DITHER_A
BC_FLAGS_UNIFORM

Definition at line 62 of file BC.h.

{
    BC_FLAGS_NONE       = 0x0,
    BC_FLAGS_DITHER_RGB = 0x10000,  // Enables dithering for RGB colors for BC1-3
    BC_FLAGS_DITHER_A   = 0x20000,  // Enables dithering for Alpha channel for BC1-3
    BC_FLAGS_UNIFORM    = 0x40000,  // By default, uses perceptual weighting for BC1-3; this flag makes it a uniform weighting
};

enum DirectX::CNMAP_FLAGS
Enumerator:
CNMAP_DEFAULT
CNMAP_CHANNEL_RED
CNMAP_CHANNEL_GREEN
CNMAP_CHANNEL_BLUE
CNMAP_CHANNEL_ALPHA
CNMAP_CHANNEL_LUMINANCE
CNMAP_MIRROR_U
CNMAP_MIRROR_V
CNMAP_MIRROR
CNMAP_INVERT_SIGN
CNMAP_COMPUTE_OCCLUSION

Definition at line 398 of file DirectXTex.h.

    {
        CNMAP_DEFAULT           = 0,

        CNMAP_CHANNEL_RED       = 0x1,
        CNMAP_CHANNEL_GREEN     = 0x2,
        CNMAP_CHANNEL_BLUE      = 0x3,
        CNMAP_CHANNEL_ALPHA     = 0x4,
        CNMAP_CHANNEL_LUMINANCE = 0x5,
            // Channel selection when evaluting color value for height
            // Luminance is a combination of red, green, and blue

        CNMAP_MIRROR_U          = 0x1000,
        CNMAP_MIRROR_V          = 0x2000,
        CNMAP_MIRROR            = 0x3000,
            // Use mirror semantics for scanline references (defaults to wrap)

        CNMAP_INVERT_SIGN       = 0x4000,
            // Inverts normal sign

        CNMAP_COMPUTE_OCCLUSION = 0x8000,
            // Computes a crude occlusion term stored in the alpha channel
    };

enum DirectX::CONVERSION_FLAGS
Enumerator:
CONV_FLAGS_NONE
CONV_FLAGS_EXPAND
CONV_FLAGS_NOALPHA
CONV_FLAGS_SWIZZLE
CONV_FLAGS_PAL8
CONV_FLAGS_888
CONV_FLAGS_565
CONV_FLAGS_5551
CONV_FLAGS_4444
CONV_FLAGS_44
CONV_FLAGS_332
CONV_FLAGS_8332
CONV_FLAGS_A8P8
CONV_FLAGS_DX10

Definition at line 22 of file DirectXTexDDS.cpp.

{
    CONV_FLAGS_NONE     = 0x0,
    CONV_FLAGS_EXPAND   = 0x1,      // Conversion requires expanded pixel size
    CONV_FLAGS_NOALPHA  = 0x2,      // Conversion requires setting alpha to known value
    CONV_FLAGS_SWIZZLE  = 0x4,      // BGR/RGB order swizzling required
    CONV_FLAGS_PAL8     = 0x8,      // Has an 8-bit palette
    CONV_FLAGS_888      = 0x10,     // Source is an 8:8:8 (24bpp) format
    CONV_FLAGS_565      = 0x20,     // Source is a 5:6:5 (16bpp) format
    CONV_FLAGS_5551     = 0x40,     // Source is a 5:5:5:1 (16bpp) format
    CONV_FLAGS_4444     = 0x80,     // Source is a 4:4:4:4 (16bpp) format
    CONV_FLAGS_44       = 0x100,    // Source is a 4:4 (8bpp) format
    CONV_FLAGS_332      = 0x200,    // Source is a 3:3:2 (8bpp) format
    CONV_FLAGS_8332     = 0x400,    // Source is a 8:3:3:2 (16bpp) format
    CONV_FLAGS_A8P8     = 0x800,    // Has an 8-bit palette with an alpha channel

enum DirectX::CONVERT_FLAGS
Enumerator:
CONVF_FLOAT
CONVF_UNORM
CONVF_UINT
CONVF_SNORM
CONVF_SINT
CONVF_DEPTH
CONVF_STENCIL
CONVF_SHAREDEXP
CONVF_BGR
CONVF_X2
CONVF_PACKED
CONVF_BC
CONVF_R
CONVF_G
CONVF_B
CONVF_A
CONVF_RGB_MASK
CONVF_RGBA_MASK

Definition at line 124 of file DirectXTexP.h.

    {
        CONVF_FLOAT     = 0x1,
        CONVF_UNORM     = 0x2,
        CONVF_UINT      = 0x4,
        CONVF_SNORM     = 0x8,
        CONVF_SINT      = 0x10,
        CONVF_DEPTH     = 0x20,
        CONVF_STENCIL   = 0x40,
        CONVF_SHAREDEXP = 0x80,
        CONVF_BGR       = 0x100,
        CONVF_X2        = 0x200,
        CONVF_PACKED    = 0x400,
        CONVF_BC        = 0x800,
        CONVF_R         = 0x10000,
        CONVF_G         = 0x20000,
        CONVF_B         = 0x40000,
        CONVF_A         = 0x80000,
        CONVF_RGB_MASK  = 0x70000,
        CONVF_RGBA_MASK = 0xF0000,
    };

enum DirectX::CP_FLAGS
Enumerator:
CP_FLAGS_NONE
CP_FLAGS_LEGACY_DWORD
CP_FLAGS_24BPP
CP_FLAGS_16BPP
CP_FLAGS_8BPP

Definition at line 46 of file DirectXTex.h.

    {
        CP_FLAGS_NONE               = 0x0,      // Normal operation
        CP_FLAGS_LEGACY_DWORD       = 0x1,      // Assume pitch is DWORD aligned instead of BYTE aligned
        CP_FLAGS_24BPP              = 0x10000,  // Override with a legacy 24 bits-per-pixel format size
        CP_FLAGS_16BPP              = 0x20000,  // Override with a legacy 16 bits-per-pixel format size
        CP_FLAGS_8BPP               = 0x40000,  // Override with a legacy 8 bits-per-pixel format size
    };

enum DirectX::DDS_FLAGS
Enumerator:
DDS_FLAGS_NONE
DDS_FLAGS_LEGACY_DWORD
DDS_FLAGS_NO_LEGACY_EXPANSION
DDS_FLAGS_NO_R10B10G10A2_FIXUP
DDS_FLAGS_FORCE_RGB
DDS_FLAGS_NO_16BPP
DDS_FLAGS_FORCE_DX10_EXT

Definition at line 93 of file DirectXTex.h.

    {
        DDS_FLAGS_NONE                  = 0x0,

        DDS_FLAGS_LEGACY_DWORD          = 0x1,
            // Assume pitch is DWORD aligned instead of BYTE aligned (used by some legacy DDS files)

        DDS_FLAGS_NO_LEGACY_EXPANSION   = 0x2,
            // Do not implicitly convert legacy formats that result in larger pixel sizes (24 bpp, 3:3:2, A8L8, A4L4, P8, A8P8)

        DDS_FLAGS_NO_R10B10G10A2_FIXUP  = 0x4,
            // Do not use work-around for long-standing D3DX DDS file format issue which reversed the 10:10:10:2 color order masks

        DDS_FLAGS_FORCE_RGB             = 0x8,
            // Convert DXGI 1.1 BGR formats to DXGI_FORMAT_R8G8B8A8_UNORM to avoid use of optional WDDM 1.1 formats

        DDS_FLAGS_NO_16BPP              = 0x10,
            // Conversions avoid use of 565, 5551, and 4444 formats and instead expand to 8888 to avoid use of optional WDDM 1.2 formats

        DDS_FLAGS_FORCE_DX10_EXT        = 0x10000,
            // Always use the 'DX10' header extension for DDS writer (i.e. don't try to write DX9 compatible DDS files)
    };

enum DirectX::DDS_RESOURCE_DIMENSION
Enumerator:
DDS_DIMENSION_TEXTURE1D
DDS_DIMENSION_TEXTURE2D
DDS_DIMENSION_TEXTURE3D

Definition at line 170 of file DDS.h.

{
    DDS_DIMENSION_TEXTURE1D = 2,
    DDS_DIMENSION_TEXTURE2D = 3,
    DDS_DIMENSION_TEXTURE3D = 4,
} DDS_RESOURCE_DIMENSION;

enum DirectX::DDS_RESOURCE_MISC_FLAG
Enumerator:
DDS_RESOURCE_MISC_TEXTURECUBE

Definition at line 178 of file DDS.h.

{
   DDS_RESOURCE_MISC_TEXTURECUBE = 0x4L,
} DDS_RESOURCE_MISC_FLAG;

enum DirectX::TEX_COMPRESS_FLAGS
Enumerator:
TEX_COMPRESS_DEFAULT
TEX_COMPRESS_RGB_DITHER
TEX_COMPRESS_A_DITHER
TEX_COMPRESS_DITHER
TEX_COMPRESS_UNIFORM
TEX_COMPRESS_PARALLEL

Definition at line 365 of file DirectXTex.h.

    {
        TEX_COMPRESS_DEFAULT        = 0,

        TEX_COMPRESS_RGB_DITHER     = 0x10000,
            // Enables dithering RGB colors for BC1-3 compression

        TEX_COMPRESS_A_DITHER       = 0x20000,
            // Enables dithering alpha for BC1-3 compression

        TEX_COMPRESS_DITHER         = 0x30000,
            // Enables both RGB and alpha dithering for BC1-3 compression

        TEX_COMPRESS_UNIFORM        = 0x40000,
            // Uniform color weighting for BC1-3 compression; by default uses perceptual weighting

        TEX_COMPRESS_PARALLEL       = 0x10000000,
            // Compress is free to use multithreading to improve performance (by default it does not use multithreading)
    };

enum DirectX::TEX_DIMENSION
Enumerator:
TEX_DIMENSION_TEXTURE1D
TEX_DIMENSION_TEXTURE2D
TEX_DIMENSION_TEXTURE3D

Definition at line 64 of file DirectXTex.h.

    {
        TEX_DIMENSION_TEXTURE1D = 2,
        TEX_DIMENSION_TEXTURE2D = 3,
        TEX_DIMENSION_TEXTURE3D = 4,
    };

enum DirectX::TEX_FILTER_FLAGS
Enumerator:
TEX_FILTER_DEFAULT
TEX_FILTER_SEPARATE_ALPHA
TEX_FILTER_DITHER
TEX_FILTER_DITHER_DIFFUSION
TEX_FILTER_POINT
TEX_FILTER_LINEAR
TEX_FILTER_CUBIC
TEX_FILTER_FANT
TEX_FILTER_SRGB_IN
TEX_FILTER_SRGB_OUT
TEX_FILTER_SRGB

Definition at line 310 of file DirectXTex.h.

    {
        TEX_FILTER_DEFAULT          = 0,

        // Clamp filtering only

        TEX_FILTER_SEPARATE_ALPHA   = 0x100,
            // Resize color and alpha channel independently

        TEX_FILTER_DITHER           = 0x10000,
            // Use ordered 4x4 dithering for any required conversions
        TEX_FILTER_DITHER_DIFFUSION = 0x20000,
            // Use error-diffusion dithering for any required conversions

        TEX_FILTER_POINT            = 0x100000,
        TEX_FILTER_LINEAR           = 0x200000,
        TEX_FILTER_CUBIC            = 0x300000,
        TEX_FILTER_FANT             = 0x400000, // Equiv to Box filtering for mipmap generation
            // Filtering mode to use for any required image resizing

        TEX_FILTER_SRGB_IN          = 0x1000000,
        TEX_FILTER_SRGB_OUT         = 0x2000000,
        TEX_FILTER_SRGB             = 0x3000000,
            // sRGB <-> RGB for use in conversion operations
            // if the input format type is IsSRGB(), then SRGB_IN is on by default
            // if the output format type is IsSRGB(), then SRGB_OUT is on by default
    };

enum DirectX::TEX_FR_FLAGS
Enumerator:
TEX_FR_ROTATE0
TEX_FR_ROTATE90
TEX_FR_ROTATE180
TEX_FR_ROTATE270
TEX_FR_FLIP_HORIZONTAL
TEX_FR_FLIP_VERTICAL

Definition at line 295 of file DirectXTex.h.

    {
        TEX_FR_ROTATE0          = 0x0,
        TEX_FR_ROTATE90         = 0x1,
        TEX_FR_ROTATE180        = 0x2,
        TEX_FR_ROTATE270        = 0x3,
        TEX_FR_FLIP_HORIZONTAL  = 0x08,
        TEX_FR_FLIP_VERTICAL    = 0x10,
    };

enum DirectX::TEX_MISC_FLAG
Enumerator:
TEX_MISC_TEXTURECUBE

Definition at line 72 of file DirectXTex.h.

    {
        TEX_MISC_TEXTURECUBE = 0x4L,
    };

enum DirectX::TEXP_LEGACY_FORMAT
Enumerator:
TEXP_LEGACY_UNKNOWN
TEXP_LEGACY_R8G8B8
TEXP_LEGACY_R3G3B2
TEXP_LEGACY_A8R3G3B2
TEXP_LEGACY_P8
TEXP_LEGACY_A8P8
TEXP_LEGACY_A4L4
TEXP_LEGACY_B4G4R4A4

Definition at line 617 of file DirectXTexDDS.cpp.

{
    TEXP_LEGACY_UNKNOWN     = 0,
    TEXP_LEGACY_R8G8B8,
    TEXP_LEGACY_R3G3B2,
    TEXP_LEGACY_A8R3G3B2,
    TEXP_LEGACY_P8,
    TEXP_LEGACY_A8P8,
    TEXP_LEGACY_A4L4,

enum DirectX::TEXP_SCANLINE_FLAGS
Enumerator:
TEXP_SCANLINE_NONE
TEXP_SCANLINE_SETALPHA
TEXP_SCANLINE_LEGACY

Definition at line 117 of file DirectXTexP.h.

    {
        TEXP_SCANLINE_NONE          = 0,
        TEXP_SCANLINE_SETALPHA      = 0x1,  // Set alpha channel to known opaque value
        TEXP_SCANLINE_LEGACY        = 0x2,  // Enables specific legacy format conversion cases
    };

enum DirectX::WIC_FLAGS
Enumerator:
WIC_FLAGS_NONE
WIC_FLAGS_FORCE_RGB
WIC_FLAGS_NO_X2_BIAS
WIC_FLAGS_NO_16BPP
WIC_FLAGS_ALLOW_MONO
WIC_FLAGS_ALL_FRAMES
WIC_FLAGS_DITHER
WIC_FLAGS_DITHER_DIFFUSION
WIC_FLAGS_FILTER_POINT
WIC_FLAGS_FILTER_LINEAR
WIC_FLAGS_FILTER_CUBIC
WIC_FLAGS_FILTER_FANT

Definition at line 116 of file DirectXTex.h.

    {
        WIC_FLAGS_NONE                  = 0x0,

        WIC_FLAGS_FORCE_RGB             = 0x1,
            // Loads DXGI 1.1 BGR formats as DXGI_FORMAT_R8G8B8A8_UNORM to avoid use of optional WDDM 1.1 formats

        WIC_FLAGS_NO_X2_BIAS            = 0x2,
            // Loads DXGI 1.1 X2 10:10:10:2 format as DXGI_FORMAT_R10G10B10A2_UNORM

        WIC_FLAGS_NO_16BPP              = 0x4,
            // Loads 565, 5551, and 4444 formats as 8888 to avoid use of optional WDDM 1.2 formats

        WIC_FLAGS_ALLOW_MONO            = 0x8,
            // Loads 1-bit monochrome (black & white) as R1_UNORM rather than 8-bit greyscale

        WIC_FLAGS_ALL_FRAMES            = 0x10,
            // Loads all images in a multi-frame file, converting/resizing to match the first frame as needed, defaults to 0th frame otherwise

        WIC_FLAGS_DITHER                = 0x10000,
            // Use ordered 4x4 dithering for any required conversions

        WIC_FLAGS_DITHER_DIFFUSION      = 0x20000,
            // Use error-diffusion dithering for any required conversions

        WIC_FLAGS_FILTER_POINT          = 0x100000,
        WIC_FLAGS_FILTER_LINEAR         = 0x200000,
        WIC_FLAGS_FILTER_CUBIC          = 0x300000,
        WIC_FLAGS_FILTER_FANT           = 0x400000, // Combination of Linear and Box filter
            // Filtering mode to use for any required image resizing (only needed when loading arrays of differently sized images; defaults to Fant)
    };

enum DirectX::WICCodecs
Enumerator:
WIC_CODEC_BMP
WIC_CODEC_JPEG
WIC_CODEC_PNG
WIC_CODEC_TIFF
WIC_CODEC_GIF
WIC_CODEC_WMP
WIC_CODEC_ICO

Definition at line 279 of file DirectXTex.h.

    {
        WIC_CODEC_BMP       =1,     // Windows Bitmap (.bmp)
        WIC_CODEC_JPEG,             // Joint Photographic Experts Group (.jpg, .jpeg)
        WIC_CODEC_PNG,              // Portable Network Graphics (.png)
        WIC_CODEC_TIFF,             // Tagged Image File Format  (.tif, .tiff)
        WIC_CODEC_GIF,              // Graphics Interchange Format  (.gif)
        WIC_CODEC_WMP,              // Windows Media Photo / HD Photo / JPEG XR (.hdp, .jxr, .wdp)
        WIC_CODEC_ICO,              // Windows Icon (.ico)
    };

Function Documentation

DirectX::__declspec ( selectany ) const
Initial value:
    { sizeof(DDS_PIXELFORMAT), DDS_FOURCC, MAKEFOURCC('D','X','T','2'), 0, 0, 0, 0, 0 }

bool DirectX::_CalculateMipLevels | ( | _In_ size_t | width,
 |  | _In_ size_t | height,
 |  | _Inout_ size_t & | mipLevels
 | ) |  |

Definition at line 48 of file DirectXTexMipmaps.cpp.

{
    if ( mipLevels > 1 )
    {
        size_t maxMips = _CountMips(width,height);
        if ( mipLevels > maxMips )
            return false;
    }
    else if ( mipLevels == 0 )
    {
        mipLevels = _CountMips(width,height);
    }
    else
    {
        mipLevels = 1;
    }
    return true;
}

bool DirectX::_CalculateMipLevels3D | ( | _In_ size_t | width,
 |  | _In_ size_t | height,
 |  | _In_ size_t | depth,
 |  | _Inout_ size_t & | mipLevels
 | ) |  |

Definition at line 88 of file DirectXTexMipmaps.cpp.

{
    if ( mipLevels > 1 )
    {
        if ( !ispow2(width) || !ispow2(height) || !ispow2(depth) )
            return false;

        size_t maxMips = _CountMips3D(width,height,depth);
        if ( mipLevels > maxMips )
            return false;
    }
    else if ( mipLevels == 0 && ispow2(width) && ispow2(height) && ispow2(depth) )
    {
        mipLevels = _CountMips3D(width,height,depth);
    }
    else
    {
        mipLevels = 1;
    }
    return true;
}

_Use_decl_annotations_ HRESULT DirectX::_ConvertFromR32G32B32A32 | ( | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | DXGI_FORMAT | format,
 |  | ScratchImage & | result
 | ) |  |

Definition at line 1523 of file DirectXTexConvert.cpp.

{
    if ( !srcImages )
        return E_POINTER;

    result.Release();

    assert( metadata.format == DXGI_FORMAT_R32G32B32A32_FLOAT );

    TexMetadata mdata2 = metadata;
    mdata2.format = format;
    HRESULT hr = result.Initialize( mdata2 );
    if ( FAILED(hr) )
        return hr;

    if ( nimages != result.GetImageCount() )
    {
        result.Release();
        return E_FAIL;
    }

    const Image* dest = result.GetImages();
    if ( !dest )
    {
        result.Release();
        return E_POINTER;
    }

    for( size_t index=0; index < nimages; ++index )
    {
        const Image& src = srcImages[ index ];
        const Image& dst = dest[ index ];

        assert( src.format == DXGI_FORMAT_R32G32B32A32_FLOAT );
        assert( dst.format == format );

        if ( src.width != dst.width || src.height != dst.height )
        {
            result.Release();
            return E_FAIL;
        }

        const uint8_t* pSrc = src.pixels;
        uint8_t* pDest = dst.pixels;
        if ( !pSrc || !pDest )
        {
            result.Release();
            return E_POINTER;
        }

        for( size_t h=0; h < src.height; ++h )
        {
            if ( !_StoreScanline( pDest, dst.rowPitch, format, reinterpret_cast<const XMVECTOR*>(pSrc), src.width ) )
            {
                result.Release();
                return E_FAIL;
            }

            pSrc += src.rowPitch;
            pDest += dst.rowPitch;
        }
    }

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::_ConvertFromR32G32B32A32 | ( | const Image & | srcImage,
 |  | const Image & | destImage
 | ) |  |

Definition at line 1470 of file DirectXTexConvert.cpp.

{
    assert( srcImage.format == DXGI_FORMAT_R32G32B32A32_FLOAT );

    if ( !srcImage.pixels || !destImage.pixels )
        return E_POINTER;

    if ( srcImage.width != destImage.width || srcImage.height != destImage.height )
        return E_FAIL;

    const uint8_t *pSrc = srcImage.pixels;
    uint8_t* pDest = destImage.pixels;

    for( size_t h = 0; h < srcImage.height; ++h )
    {
        if ( !_StoreScanline( pDest, destImage.rowPitch, destImage.format, reinterpret_cast<const XMVECTOR*>(pSrc), srcImage.width ) )
            return E_FAIL;

        pSrc += srcImage.rowPitch;
        pDest += destImage.rowPitch;
    }

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::_ConvertFromR32G32B32A32 | ( | const Image & | srcImage,
 |  | DXGI_FORMAT | format,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 1496 of file DirectXTexConvert.cpp.

{
    if ( !srcImage.pixels )
        return E_POINTER;

    HRESULT hr = image.Initialize2D( format, srcImage.width, srcImage.height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    const Image *img = image.GetImage( 0, 0, 0 );
    if ( !img )
    {
        image.Release();
        return E_POINTER;
    }

    hr = _ConvertFromR32G32B32A32( srcImage, *img );
    if ( FAILED(hr) )
    {
        image.Release();
        return hr;
    }

    return S_OK;
}

HRESULT DirectX::_ConvertFromR32G32B32A32 | ( | _In_ const Image & | srcImage,
 |  | _In_ const Image & | destImage
 | ) |  |
HRESULT DirectX::_ConvertFromR32G32B32A32 | ( | _In_ const Image & | srcImage,
 |  | _In_ DXGI_FORMAT | format,
 |  | _Inout_ ScratchImage & | image
 | ) |  |
HRESULT DirectX::_ConvertFromR32G32B32A32 | ( | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DXGI_FORMAT | format,
 |  | _Out_ ScratchImage & | result
 | ) |  |
_Use_decl_annotations_ void DirectX::_ConvertScanline | ( | XMVECTOR * | pBuffer,
 |  | size_t | count,
 |  | DXGI_FORMAT | outFormat,
 |  | DXGI_FORMAT | inFormat,
 |  | DWORD | flags
 | ) |  |

Definition at line 1834 of file DirectXTexConvert.cpp.

{
    assert( pBuffer && count > 0 && (((uintptr_t)pBuffer & 0xF) == 0) );
    assert( IsValid(outFormat) && !IsVideo(outFormat) && !IsTypeless(outFormat) );
    assert( IsValid(inFormat) && !IsVideo(inFormat) && !IsTypeless(inFormat) );

    if ( !pBuffer )
        return;

#ifdef _DEBUG
    // Ensure conversion table is in ascending order
    assert( _countof(g_ConvertTable) > 0 );
    DXGI_FORMAT lastvalue = g_ConvertTable[0].format;
    for( size_t index=1; index < _countof(g_ConvertTable); ++index )
    {
        assert( g_ConvertTable[index].format > lastvalue );
        lastvalue = g_ConvertTable[index].format;
    }
#endif

    // Determine conversion details about source and dest formats
    ConvertData key = { inFormat, 0 };
    const ConvertData* in = (const ConvertData*) bsearch_s( &key, g_ConvertTable, _countof(g_ConvertTable), sizeof(ConvertData),
                                                            _ConvertCompare, 0 );
    key.format = outFormat;
    const ConvertData* out = (const ConvertData*) bsearch_s( &key, g_ConvertTable, _countof(g_ConvertTable), sizeof(ConvertData),
                                                            _ConvertCompare, 0 );
    if ( !in || !out )
    {
        assert(false);
        return;
    }

    assert( _GetConvertFlags( inFormat ) == in->flags );
    assert( _GetConvertFlags( outFormat ) == out->flags );

    // Handle SRGB filtering modes
    if ( IsSRGB( inFormat ) )
        flags |= TEX_FILTER_SRGB_IN;

    if ( IsSRGB( outFormat ) )
        flags |= TEX_FILTER_SRGB_OUT;

    if ( in->flags & CONVF_SNORM )
        flags &= ~TEX_FILTER_SRGB_IN;

    if ( out->flags & CONVF_SNORM )
        flags &= ~TEX_FILTER_SRGB_OUT;

    if ( (flags & (TEX_FILTER_SRGB_IN|TEX_FILTER_SRGB_OUT)) == (TEX_FILTER_SRGB_IN|TEX_FILTER_SRGB_OUT) )
    {
        flags &= ~(TEX_FILTER_SRGB_IN|TEX_FILTER_SRGB_OUT);
    }

    // sRGB input processing (sRGB -> RGB)
    if ( flags & TEX_FILTER_SRGB_IN )
    {
        if ( (in->flags & CONVF_FLOAT) || (in->flags & CONVF_UNORM) )
        {
            XMVECTOR* ptr = pBuffer;
            for( size_t i=0; i < count; ++i )
            {
                // rgb = rgb^(2.2); a=a
                XMVECTOR v = *ptr;
                XMVECTOR v1 = _TableDecodeGamma22( v );
                *ptr++ = XMVectorSelect( v, v1, g_XMSelect1110 );
            }
        }
    }

    // Handle conversion special cases
    DWORD diffFlags = in->flags ^ out->flags;
    if ( diffFlags != 0)
    {
        if ( out->flags & CONVF_UNORM )
        {
            if ( in->flags & CONVF_SNORM )
            {
                // SNORM -> UNORM
                XMVECTOR* ptr = pBuffer;
                for( size_t i=0; i < count; ++i )
                {
                    XMVECTOR v = *ptr;
                    *ptr++ = XMVectorMultiplyAdd( v, g_XMOneHalf, g_XMOneHalf );
                }
            }
            else if ( in->flags & CONVF_FLOAT )
            {
                // FLOAT -> UNORM
                XMVECTOR* ptr = pBuffer;
                for( size_t i=0; i < count; ++i )
                {
                    XMVECTOR v = *ptr;
                    *ptr++ = XMVectorSaturate( v );
                }
            }
        }
        else if ( out->flags & CONVF_SNORM )
        {
            if ( in->flags & CONVF_UNORM )
            {
                // UNORM -> SNORM
                static XMVECTORF32 two = { 2.0f, 2.0f, 2.0f, 2.0f };
                XMVECTOR* ptr = pBuffer;
                for( size_t i=0; i < count; ++i )
                {
                    XMVECTOR v = *ptr;
                    *ptr++ = XMVectorMultiplyAdd( v, two, g_XMNegativeOne );
                }
            }
            else if ( in->flags & CONVF_FLOAT )
            {
                // FLOAT -> SNORM
                XMVECTOR* ptr = pBuffer;
                for( size_t i=0; i < count; ++i )
                {
                    XMVECTOR v = *ptr;
                    *ptr++ = XMVectorClamp( v, g_XMNegativeOne, g_XMOne );
                }
            }
        }

        // !CONVF_A -> CONVF_A is handled because LoadScanline ensures alpha defaults to 1.0 for no-alpha formats

        // CONVF_PACKED cases are handled because LoadScanline/StoreScanline handles packing/unpacking

        if ( ((out->flags & CONVF_RGBA_MASK) == CONVF_A) && !(in->flags & CONVF_A) )
        {
            // !CONVF_A -> A format
            XMVECTOR* ptr = pBuffer;
            for( size_t i=0; i < count; ++i )
            {
                XMVECTOR v = *ptr;
                *ptr++ = XMVectorSplatX( v );
            }
        }
        else if ( ((in->flags & CONVF_RGBA_MASK) == CONVF_A) && !(out->flags & CONVF_A) )
        {
            // A format -> !CONVF_A
            XMVECTOR* ptr = pBuffer;
            for( size_t i=0; i < count; ++i )
            {
                XMVECTOR v = *ptr;
                *ptr++ = XMVectorSplatW( v );
            }
        }
        else if ( ((in->flags & CONVF_RGB_MASK) == CONVF_R) && ((out->flags & CONVF_RGB_MASK) == (CONVF_R|CONVF_G|CONVF_B)) )
        {
            // R format -> RGB format
            XMVECTOR* ptr = pBuffer;
            for( size_t i=0; i < count; ++i )
            {
                XMVECTOR v = *ptr;
                XMVECTOR v1 = XMVectorSplatX( v );
                *ptr++ = XMVectorSelect( v, v1, g_XMSelect1110 );
            }
        }
    }

    // sRGB output processing (RGB -> sRGB)
    if ( flags & TEX_FILTER_SRGB_OUT )
    {
        if ( (out->flags & CONVF_FLOAT) || (out->flags & CONVF_UNORM) )
        {
            XMVECTOR* ptr = pBuffer;
            for( size_t i=0; i < count; ++i )
            {
                // rgb = rgb^(1/2.2); a=a
                XMVECTOR v = *ptr;
                XMVECTOR v1 = _TableEncodeGamma22( v );
                *ptr++ = XMVectorSelect( v, v1, g_XMSelect1110 );
            }
        }
    }
}

void DirectX::_ConvertScanline | ( | _Inout_updates_all_(count) XMVECTOR * | pBuffer,
 |  | _In_ size_t | count,
 |  | _In_ DXGI_FORMAT | outFormat,
 |  | _In_ DXGI_FORMAT | inFormat,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::_ConvertToR32G32B32A32 | ( | const Image & | srcImage,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 1430 of file DirectXTexConvert.cpp.

{
    if ( !srcImage.pixels )
        return E_POINTER;

    HRESULT hr = image.Initialize2D( DXGI_FORMAT_R32G32B32A32_FLOAT, srcImage.width, srcImage.height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    const Image *img = image.GetImage( 0, 0, 0 );
    if ( !img )
    {
        image.Release();
        return E_POINTER;
    }

    uint8_t* pDest = img->pixels;
    if ( !pDest )
    {
        image.Release();
        return E_POINTER;
    }

    const uint8_t *pSrc = srcImage.pixels;
    for( size_t h = 0; h < srcImage.height; ++h )
    {
        if ( !_LoadScanline( reinterpret_cast<XMVECTOR*>(pDest), srcImage.width, pSrc, srcImage.rowPitch, srcImage.format ) )
        {
            image.Release();
            return E_FAIL;
        }

        pSrc += srcImage.rowPitch;
        pDest += img->rowPitch;
    }

    return S_OK;
}

HRESULT DirectX::_ConvertToR32G32B32A32 | ( | _In_ const Image & | srcImage,
 |  | _Inout_ ScratchImage & | image
 | ) |  |
void DirectX::_CopyScanline | ( | _When_(pDestination==pSource, _Inout_updates_bytes_(outSize)) _When_(pDestination!=pSource, _Out_writes_bytes_(outSize)) LPVOID | pDestination,
 |  | _In_ size_t | outSize,
 |  | _In_reads_bytes_(inSize) LPCVOID | pSource,
 |  | _In_ size_t | inSize,
 |  | _In_ DXGI_FORMAT | format,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ void DirectX::_DetermineImageArray | ( | const TexMetadata & | metadata,
 |  | DWORD | cpFlags,
 |  | size_t & | nImages,
 |  | size_t & | pixelSize
 | ) |  |

Definition at line 26 of file DirectXTexImage.cpp.

{
    assert( metadata.width > 0 && metadata.height > 0 && metadata.depth > 0 );
    assert( metadata.arraySize > 0 );
    assert( metadata.mipLevels > 0 );

    size_t _pixelSize = 0;
    size_t _nimages = 0;

    switch( metadata.dimension )
    {
    case TEX_DIMENSION_TEXTURE1D:
    case TEX_DIMENSION_TEXTURE2D:
        for( size_t item = 0; item < metadata.arraySize; ++item )
        {
            size_t w = metadata.width;
            size_t h = metadata.height;

            for( size_t level=0; level < metadata.mipLevels; ++level )
            {
                size_t rowPitch, slicePitch;
                ComputePitch( metadata.format, w, h, rowPitch, slicePitch, cpFlags );

                _pixelSize += slicePitch;
                ++_nimages;

                if ( h > 1 )
                    h >>= 1;

                if ( w > 1 )
                    w >>= 1;
            }
        }
        break;

    case TEX_DIMENSION_TEXTURE3D:
        {
            size_t w = metadata.width;
            size_t h = metadata.height;
            size_t d = metadata.depth;

            for( size_t level=0; level < metadata.mipLevels; ++level )
            {
                size_t rowPitch, slicePitch;
                ComputePitch( metadata.format, w, h, rowPitch, slicePitch, cpFlags );

                for( size_t slice=0; slice < d; ++slice )
                {
                    _pixelSize += slicePitch;
                    ++_nimages;
                }

                if ( h > 1 )
                    h >>= 1;

                if ( w > 1 )
                    w >>= 1;

                if ( d > 1 )
                    d >>= 1;
            }
        }
        break;

    default:
        assert( false );
        break;
    }

    nImages = _nimages;
    pixelSize = _pixelSize;
}

void DirectX::_DetermineImageArray | ( | _In_ const TexMetadata & | metadata,
 |  | _In_ DWORD | cpFlags,
 |  | _Out_ size_t & | nImages,
 |  | _Out_ size_t & | pixelSize
 | ) |  |
bool DirectX::_DXGIToWIC | ( | _In_ DXGI_FORMAT | format,
 |  | _Out_ GUID & | guid
 | ) |  |
_Use_decl_annotations_ bool DirectX::_DXGIToWIC | ( | DXGI_FORMAT | format,
 |  | GUID & | guid
 | ) |  |

Definition at line 77 of file DirectXTexUtil.cpp.

{
    for( size_t i=0; i < _countof(g_WICFormats); ++i )
    {
        if ( g_WICFormats[i].format == format )
        {
            memcpy( &guid, &g_WICFormats[i].wic, sizeof(GUID) );
            return true;
        }
    }

    // Special cases
    switch( format )
    {
    case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
        memcpy( &guid, &GUID_WICPixelFormat32bppRGBA, sizeof(GUID) );
        return true;

    case DXGI_FORMAT_D32_FLOAT:
        memcpy( &guid, &GUID_WICPixelFormat32bppGrayFloat, sizeof(GUID) );
        return true;

    case DXGI_FORMAT_D16_UNORM:
        memcpy( &guid, &GUID_WICPixelFormat16bppGray, sizeof(GUID) );
        return true;

    case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
        memcpy( &guid, &GUID_WICPixelFormat32bppBGRA, sizeof(GUID) );
        return true;

    case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
        memcpy( &guid, &GUID_WICPixelFormat32bppBGR, sizeof(GUID) );
        return true;
    }

    memcpy( &guid, &GUID_NULL, sizeof(GUID) );
    return false;
}

_Use_decl_annotations_ HRESULT DirectX::_EncodeDDSHeader | ( | const TexMetadata & | metadata,
 |  | DWORD | flags,
 |  | LPVOID | pDestination,
 |  | size_t | maxsize,
 |  | size_t & | required
 | ) |  |

Definition at line 405 of file DirectXTexDDS.cpp.

{
    assert( IsValid( metadata.format ) && !IsVideo( metadata.format ) );

    if ( metadata.arraySize > 1 )
    {
        if ( (metadata.arraySize != 6) || (metadata.dimension != TEX_DIMENSION_TEXTURE2D) || !(metadata.miscFlags & TEX_MISC_TEXTURECUBE) )
        {
            flags |= DDS_FLAGS_FORCE_DX10_EXT;
        }
    }

    DDS_PIXELFORMAT ddpf = { 0 };
    if ( !(flags & DDS_FLAGS_FORCE_DX10_EXT) )
    {
        switch( metadata.format )
        {
        case DXGI_FORMAT_R8G8B8A8_UNORM:        memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_A8B8G8R8, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_R16G16_UNORM:          memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_G16R16, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_R8G8_UNORM:            memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_A8L8, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_R16_UNORM:             memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_L16, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_R8_UNORM:              memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_L8, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_A8_UNORM:              memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_A8, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_R8G8_B8G8_UNORM:       memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_R8G8_B8G8, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_G8R8_G8B8_UNORM:       memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_G8R8_G8B8, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_BC1_UNORM:             memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_DXT1, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_BC2_UNORM:             memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_DXT3, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_BC3_UNORM:             memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_DXT5, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_BC4_UNORM:             memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_BC4_UNORM, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_BC4_SNORM:             memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_BC4_SNORM, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_BC5_UNORM:             memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_BC5_UNORM, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_BC5_SNORM:             memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_BC5_SNORM, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_B5G6R5_UNORM:          memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_R5G6B5, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_B5G5R5A1_UNORM:        memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_A1R5G5B5, sizeof(DDS_PIXELFORMAT) ); break;
        case DXGI_FORMAT_B8G8R8A8_UNORM:        memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_A8R8G8B8, sizeof(DDS_PIXELFORMAT) ); break; // DXGI 1.1
        case DXGI_FORMAT_B8G8R8X8_UNORM:        memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_X8R8G8B8, sizeof(DDS_PIXELFORMAT) ); break; // DXGI 1.1
        case DXGI_FORMAT_B4G4R4A4_UNORM:        memcpy_s( &ddpf, sizeof(ddpf), &DDSPF_A4R4G4B4, sizeof(DDS_PIXELFORMAT) ); break;

        // Legacy D3DX formats using D3DFMT enum value as FourCC
        case DXGI_FORMAT_R32G32B32A32_FLOAT:
            ddpf.dwSize = sizeof(DDS_PIXELFORMAT); ddpf.dwFlags = DDS_FOURCC; ddpf.dwFourCC = 116;  // D3DFMT_A32B32G32R32F
            break;
        case DXGI_FORMAT_R16G16B16A16_FLOAT:
            ddpf.dwSize = sizeof(DDS_PIXELFORMAT); ddpf.dwFlags = DDS_FOURCC; ddpf.dwFourCC = 113;  // D3DFMT_A16B16G16R16F
            break;
        case DXGI_FORMAT_R16G16B16A16_UNORM:
            ddpf.dwSize = sizeof(DDS_PIXELFORMAT); ddpf.dwFlags = DDS_FOURCC; ddpf.dwFourCC = 36;  // D3DFMT_A16B16G16R16
            break;
        case DXGI_FORMAT_R16G16B16A16_SNORM:
            ddpf.dwSize = sizeof(DDS_PIXELFORMAT); ddpf.dwFlags = DDS_FOURCC; ddpf.dwFourCC = 110;  // D3DFMT_Q16W16V16U16
            break;
        case DXGI_FORMAT_R32G32_FLOAT:
            ddpf.dwSize = sizeof(DDS_PIXELFORMAT); ddpf.dwFlags = DDS_FOURCC; ddpf.dwFourCC = 115;  // D3DFMT_G32R32F
            break;
       case DXGI_FORMAT_R16G16_FLOAT:
            ddpf.dwSize = sizeof(DDS_PIXELFORMAT); ddpf.dwFlags = DDS_FOURCC; ddpf.dwFourCC = 112;  // D3DFMT_G16R16F
            break;
        case DXGI_FORMAT_R32_FLOAT:
            ddpf.dwSize = sizeof(DDS_PIXELFORMAT); ddpf.dwFlags = DDS_FOURCC; ddpf.dwFourCC = 114;  // D3DFMT_R32F
            break;
        case DXGI_FORMAT_R16_FLOAT:
            ddpf.dwSize = sizeof(DDS_PIXELFORMAT); ddpf.dwFlags = DDS_FOURCC; ddpf.dwFourCC = 111;  // D3DFMT_R16F
            break;
        }
    }

    required = sizeof(uint32_t) + sizeof(DDS_HEADER);

    if ( ddpf.dwSize == 0 )
        required += sizeof(DDS_HEADER_DXT10);

    if ( !pDestination )
        return S_OK;

    if ( maxsize < required )
        return E_NOT_SUFFICIENT_BUFFER;

    *reinterpret_cast<uint32_t*>(pDestination) = DDS_MAGIC;

    DDS_HEADER* header = reinterpret_cast<DDS_HEADER*>( reinterpret_cast<uint8_t*>(pDestination) + sizeof(uint32_t) );
    assert( header );

    memset( header, 0, sizeof(DDS_HEADER ) );
    header->dwSize = sizeof( DDS_HEADER );
    header->dwFlags = DDS_HEADER_FLAGS_TEXTURE;
    header->dwCaps = DDS_SURFACE_FLAGS_TEXTURE;

    if (metadata.mipLevels > 0)
    {
        header->dwFlags |= DDS_HEADER_FLAGS_MIPMAP;

#ifdef _AMD64_
        if ( metadata.mipLevels > 0xFFFFFFFF )
            return E_INVALIDARG;
#endif

        header->dwMipMapCount = static_cast<uint32_t>( metadata.mipLevels );

        if ( header->dwMipMapCount > 1 )
            header->dwCaps |= DDS_SURFACE_FLAGS_MIPMAP;
    }

    switch( metadata.dimension )
    {
    case TEX_DIMENSION_TEXTURE1D:
#ifdef _AMD64_
        if ( metadata.height > 0xFFFFFFFF )
            return E_INVALIDARG;
#endif

        header->dwHeight = static_cast<uint32_t>( metadata.height );
        header->dwWidth = header->dwDepth = 1;
        break;

    case TEX_DIMENSION_TEXTURE2D:
#ifdef _AMD64_
        if ( metadata.height > 0xFFFFFFFF
             || metadata.width > 0xFFFFFFFF)
            return E_INVALIDARG;
#endif

        header->dwHeight = static_cast<uint32_t>( metadata.height );
        header->dwWidth = static_cast<uint32_t>( metadata.width );
        header->dwDepth = 1;

        if ( metadata.miscFlags & TEX_MISC_TEXTURECUBE )
        {
            header->dwCaps |= DDS_SURFACE_FLAGS_CUBEMAP;
            header->dwCaps2 |= DDS_CUBEMAP_ALLFACES;
        }
        break;

    case TEX_DIMENSION_TEXTURE3D:
#ifdef _AMD64_
        if ( metadata.height > 0xFFFFFFFF
             || metadata.width > 0xFFFFFFFF
             || metadata.depth > 0xFFFFFFFF )
            return E_INVALIDARG;
#endif

        header->dwFlags |= DDS_HEADER_FLAGS_VOLUME;
        header->dwCaps2 |= DDS_FLAGS_VOLUME;
        header->dwHeight = static_cast<uint32_t>( metadata.height );
        header->dwWidth = static_cast<uint32_t>( metadata.width );
        header->dwDepth = static_cast<uint32_t>( metadata.depth );
        break;

    default:
        return E_FAIL;
    }

    size_t rowPitch, slicePitch;
    ComputePitch( metadata.format, metadata.width, metadata.height, rowPitch, slicePitch, CP_FLAGS_NONE );

#ifdef _AMD64_
    if ( slicePitch > 0xFFFFFFFF
         || rowPitch > 0xFFFFFFFF )
        return E_FAIL;
#endif

    if ( IsCompressed( metadata.format ) )
    {
        header->dwFlags |= DDS_HEADER_FLAGS_LINEARSIZE;
        header->dwPitchOrLinearSize = static_cast<uint32_t>( slicePitch );
    }
    else
    {
        header->dwFlags |= DDS_HEADER_FLAGS_PITCH;
        header->dwPitchOrLinearSize = static_cast<uint32_t>( rowPitch );
    }

    if ( ddpf.dwSize == 0 )
    {
        memcpy_s( &header->ddspf, sizeof(header->ddspf), &DDSPF_DX10, sizeof(DDS_PIXELFORMAT) );

        DDS_HEADER_DXT10* ext = reinterpret_cast<DDS_HEADER_DXT10*>( reinterpret_cast<uint8_t*>(header) + sizeof(DDS_HEADER) );
        assert( ext );

        memset( ext, 0, sizeof(DDS_HEADER_DXT10) );
        ext->dxgiFormat = metadata.format;
        ext->resourceDimension = metadata.dimension;

#ifdef _AMD64_
        if ( metadata.arraySize > 0xFFFFFFFF )
            return E_INVALIDARG;
#endif

        if ( metadata.miscFlags & TEX_MISC_TEXTURECUBE )
        {
            ext->miscFlag |= TEX_MISC_TEXTURECUBE;
            assert( (metadata.arraySize % 6) == 0 );
            ext->arraySize = static_cast<UINT>( metadata.arraySize / 6 );
        }
        else
        {
            ext->arraySize = static_cast<UINT>( metadata.arraySize );
        }
    }
    else
    {
        memcpy_s( &header->ddspf, sizeof(header->ddspf), &ddpf, sizeof(ddpf) );
    }

HRESULT DirectX::_EncodeDDSHeader | ( | _In_ const TexMetadata & | metadata,
 |  | DWORD | flags,
 |  | _Out_writes_bytes_to_opt_(maxsize, required) LPVOID | pDestination,
 |  | _In_ size_t | maxsize,
 |  | _Out_ size_t & | required
 | ) |  |
_Use_decl_annotations_ bool DirectX::_ExpandScanline | ( | LPVOID | pDestination,
 |  | size_t | outSize,
 |  | DXGI_FORMAT | outFormat,
 |  | LPCVOID | pSource,
 |  | size_t | inSize,
 |  | DXGI_FORMAT | inFormat,
 |  | DWORD | flags
 | ) |  |

Definition at line 364 of file DirectXTexConvert.cpp.

{
    assert( pDestination && outSize > 0 );
    assert( pSource && inSize > 0 );
    assert( IsValid(outFormat) && !IsVideo(outFormat) );
    assert( IsValid(inFormat) && !IsVideo(inFormat) );

    switch( inFormat )
    {
    case DXGI_FORMAT_B5G6R5_UNORM:
        if ( outFormat != DXGI_FORMAT_R8G8B8A8_UNORM )
            return false;

        // DXGI_FORMAT_B5G6R5_UNORM -> DXGI_FORMAT_R8G8B8A8_UNORM
        {
            const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
            uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);

            for( size_t ocount = 0, icount = 0; ((icount < inSize) && (ocount < outSize)); icount += 2, ocount += 4 )
            {
                uint16_t t = *(sPtr++);

                uint32_t t1 = ((t & 0xf800) >> 8) | ((t & 0xe000) >> 13);
                uint32_t t2 = ((t & 0x07e0) << 5) | ((t & 0x0600) >> 5);
                uint32_t t3 = ((t & 0x001f) << 19) | ((t & 0x001c) << 14);

                *(dPtr++) = t1 | t2 | t3 | 0xff000000;
            }
        }
        return true;

    case DXGI_FORMAT_B5G5R5A1_UNORM:
        if ( outFormat != DXGI_FORMAT_R8G8B8A8_UNORM )
            return false;

        // DXGI_FORMAT_B5G5R5A1_UNORM -> DXGI_FORMAT_R8G8B8A8_UNORM
        {
            const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
            uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);

            for( size_t ocount = 0, icount = 0; ((icount < inSize) && (ocount < outSize)); icount += 2, ocount += 4 )
            {
                uint16_t t = *(sPtr++);

                uint32_t t1 = ((t & 0x7c00) >> 7) | ((t & 0x7000) >> 12);
                uint32_t t2 = ((t & 0x03e0) << 6) | ((t & 0x0380) << 1);
                uint32_t t3 = ((t & 0x001f) << 19) | ((t & 0x001c) << 14);
                uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xff000000 : ((t & 0x8000) ? 0xff000000 : 0);

                *(dPtr++) = t1 | t2 | t3 | ta;
            }
        }
        return true;

    case DXGI_FORMAT_B4G4R4A4_UNORM:
        if ( outFormat != DXGI_FORMAT_R8G8B8A8_UNORM )
            return false;

        // DXGI_FORMAT_B4G4R4A4_UNORM -> DXGI_FORMAT_R8G8B8A8_UNORM
        {
            const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
            uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);

            for( size_t ocount = 0, icount = 0; ((icount < inSize) && (ocount < outSize)); icount += 2, ocount += 4 )
            {
                uint16_t t = *(sPtr++);

                uint32_t t1 = ((t & 0x0f00) >> 4) | ((t & 0x0f00) >> 8);
                uint32_t t2 = ((t & 0x00f0) << 8) | ((t & 0x00f0) << 4);
                uint32_t t3 = ((t & 0x000f) << 20) | ((t & 0x000f) << 16);
                uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xff000000 : (((t & 0xf000) << 16) | ((t & 0xf000) << 12));

                *(dPtr++) = t1 | t2 | t3 | ta;
            }
        }
        return true;
    }

    return false;
}

_Use_decl_annotations_ DWORD DirectX::_GetConvertFlags ( DXGI_FORMAT format )

Definition at line 1814 of file DirectXTexConvert.cpp.

{
#ifdef _DEBUG
    // Ensure conversion table is in ascending order
    assert( _countof(g_ConvertTable) > 0 );
    DXGI_FORMAT lastvalue = g_ConvertTable[0].format;
    for( size_t index=1; index < _countof(g_ConvertTable); ++index )
    {
        assert( g_ConvertTable[index].format > lastvalue );
        lastvalue = g_ConvertTable[index].format;
    }
#endif

    ConvertData key = { format, 0 };
    const ConvertData* in = (const ConvertData*) bsearch_s( &key, g_ConvertTable, _countof(g_ConvertTable), sizeof(ConvertData),
                                                            _ConvertCompare, 0 );
    return (in) ? in->flags : 0;
}

DWORD DirectX::_GetConvertFlags ( _In_ DXGI_FORMAT format )
IWICImagingFactory * DirectX::_GetWIC ( )

Definition at line 145 of file DirectXTexUtil.cpp.

{
    static IWICImagingFactory* s_Factory = nullptr;

    if ( s_Factory )
        return s_Factory;

    HRESULT hr = CoCreateInstance(
        CLSID_WICImagingFactory,
        nullptr,
        CLSCTX_INPROC_SERVER,
        __uuidof(IWICImagingFactory),
        (LPVOID*)&s_Factory
        );

    if ( FAILED(hr) )
    {
        s_Factory = nullptr;
        return nullptr;
    }

    return s_Factory;
}

WICBitmapDitherType DirectX::_GetWICDither ( _In_ DWORD flags ) [inline]

Definition at line 58 of file DirectXTexP.h.

    {
        static_assert( TEX_FILTER_DITHER == 0x10000, "TEX_FILTER_DITHER* flag values don't match mask" );

        static_assert( TEX_FILTER_DITHER == WIC_FLAGS_DITHER, "TEX_FILTER_DITHER* should match WIC_FLAGS_DITHER*" );
        static_assert( TEX_FILTER_DITHER_DIFFUSION == WIC_FLAGS_DITHER_DIFFUSION, "TEX_FILTER_DITHER* should match WIC_FLAGS_DITHER*" );

        switch( flags & 0xF0000 )
        {
        case TEX_FILTER_DITHER:
            return WICBitmapDitherTypeOrdered4x4;

        case TEX_FILTER_DITHER_DIFFUSION:
            return WICBitmapDitherTypeErrorDiffusion;

        default:
            return WICBitmapDitherTypeNone;
        }
    }

WICBitmapInterpolationMode DirectX::_GetWICInterp ( _In_ DWORD flags ) [inline]

Definition at line 78 of file DirectXTexP.h.

    {
        static_assert( TEX_FILTER_POINT == 0x100000, "TEX_FILTER_ flag values don't match TEX_FILTER_MASK" );

        static_assert( TEX_FILTER_POINT == WIC_FLAGS_FILTER_POINT, "TEX_FILTER_* flags should match WIC_FLAGS_FILTER_*" );
        static_assert( TEX_FILTER_LINEAR == WIC_FLAGS_FILTER_LINEAR, "TEX_FILTER_* flags should match WIC_FLAGS_FILTER_*"  );
        static_assert( TEX_FILTER_CUBIC == WIC_FLAGS_FILTER_CUBIC, "TEX_FILTER_* flags should match WIC_FLAGS_FILTER_*"  );
        static_assert( TEX_FILTER_FANT == WIC_FLAGS_FILTER_FANT, "TEX_FILTER_* flags should match WIC_FLAGS_FILTER_*"  );

        switch( flags & TEX_FILTER_MASK )
        {
        case TEX_FILTER_POINT:
            return WICBitmapInterpolationModeNearestNeighbor;

        case TEX_FILTER_LINEAR:
            return WICBitmapInterpolationModeLinear;

        case TEX_FILTER_CUBIC:
            return WICBitmapInterpolationModeCubic;

        case TEX_FILTER_FANT:
        default:
            return WICBitmapInterpolationModeFant;
        }
    }

_In_ size_t _In_ DXGI_FORMAT DirectX::_In_reads_ ( count ) const
_In_ size_t _In_ DXGI_FORMAT DirectX::_In_reads_bytes_ ( inSize )
_In_ size_t DirectX::_In_reads_bytes_ ( size )
size_t _In_ DXGI_FORMAT size_t _In_ TEXP_LEGACY_FORMAT DirectX::_In_reads_opt_ ( 256 ) const
_Use_decl_annotations_ bool DirectX::_LoadScanline | ( | XMVECTOR * | pDestination,
 |  | size_t | count,
 |  | LPCVOID | pSource,
 |  | size_t | size,
 |  | DXGI_FORMAT | format
 | ) |  |

Definition at line 492 of file DirectXTexConvert.cpp.

{
    assert( pDestination && count > 0 && (((uintptr_t)pDestination & 0xF) == 0) );
    assert( pSource && size > 0 );
    assert( IsValid(format) && !IsVideo(format) && !IsTypeless(format) && !IsCompressed(format) );

    XMVECTOR* __restrict dPtr = pDestination;
    if ( !dPtr )
        return false;

    const XMVECTOR* ePtr = pDestination + count;

    switch( format )
    {
    case DXGI_FORMAT_R32G32B32A32_FLOAT:
        {
            size_t msize = (size > (sizeof(XMVECTOR)*count)) ? (sizeof(XMVECTOR)*count) : size;
            memcpy_s( dPtr, sizeof(XMVECTOR)*count, pSource, msize );
        }
        return true;

    case DXGI_FORMAT_R32G32B32A32_UINT:
        LOAD_SCANLINE( XMUINT4, XMLoadUInt4 )

    case DXGI_FORMAT_R32G32B32A32_SINT:
        LOAD_SCANLINE( XMINT4, XMLoadSInt4 )

    case DXGI_FORMAT_R32G32B32_FLOAT:
        LOAD_SCANLINE3( XMFLOAT3, XMLoadFloat3, g_XMIdentityR3 )

    case DXGI_FORMAT_R32G32B32_UINT:
        LOAD_SCANLINE3( XMUINT3, XMLoadUInt3, g_XMIdentityR3 )

    case DXGI_FORMAT_R32G32B32_SINT:
        LOAD_SCANLINE3( XMINT3, XMLoadSInt3, g_XMIdentityR3 )

    case DXGI_FORMAT_R16G16B16A16_FLOAT:
        LOAD_SCANLINE( XMHALF4, XMLoadHalf4 )

    case DXGI_FORMAT_R16G16B16A16_UNORM:
        LOAD_SCANLINE( XMUSHORTN4, XMLoadUShortN4 )

    case DXGI_FORMAT_R16G16B16A16_UINT:
        LOAD_SCANLINE( XMUSHORT4, XMLoadUShort4 )

    case DXGI_FORMAT_R16G16B16A16_SNORM:
        LOAD_SCANLINE( XMSHORTN4, XMLoadShortN4 )

    case DXGI_FORMAT_R16G16B16A16_SINT:
        LOAD_SCANLINE( XMSHORT4, XMLoadShort4 )

    case DXGI_FORMAT_R32G32_FLOAT:
        LOAD_SCANLINE2( XMFLOAT2, XMLoadFloat2, g_XMIdentityR3 )

    case DXGI_FORMAT_R32G32_UINT:
        LOAD_SCANLINE2( XMUINT2, XMLoadUInt2, g_XMIdentityR3 )

    case DXGI_FORMAT_R32G32_SINT:
        LOAD_SCANLINE2( XMINT2, XMLoadSInt2, g_XMIdentityR3 )

    case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
        if ( size >= (sizeof(float)+sizeof(uint32_t)) )
        {
            const float * sPtr = reinterpret_cast<const float*>(pSource);
            for( size_t icount = 0; icount < size; icount += (sizeof(float)+sizeof(uint32_t)) )
            {
                const uint8_t* ps8 = reinterpret_cast<const uint8_t*>( &sPtr[1] );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( sPtr[0], static_cast<float>( *ps8 ), 0.f, 1.f );
                sPtr += 2;
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R10G10B10A2_UNORM:
    case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
        LOAD_SCANLINE( XMUDECN4, XMLoadUDecN4 );

    case DXGI_FORMAT_R10G10B10A2_UINT:
        LOAD_SCANLINE( XMUDEC4, XMLoadUDec4 );

    case DXGI_FORMAT_R11G11B10_FLOAT:
        LOAD_SCANLINE3( XMFLOAT3PK, XMLoadFloat3PK, g_XMIdentityR3 );

    case DXGI_FORMAT_R8G8B8A8_UNORM:
    case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
        LOAD_SCANLINE( XMUBYTEN4, XMLoadUByteN4 )

    case DXGI_FORMAT_R8G8B8A8_UINT:
        LOAD_SCANLINE( XMUBYTE4, XMLoadUByte4 )

    case DXGI_FORMAT_R8G8B8A8_SNORM:
        LOAD_SCANLINE( XMBYTEN4, XMLoadByteN4 )

    case DXGI_FORMAT_R8G8B8A8_SINT:
        LOAD_SCANLINE( XMBYTE4, XMLoadByte4 )

    case DXGI_FORMAT_R16G16_FLOAT:
        LOAD_SCANLINE2( XMHALF2, XMLoadHalf2, g_XMIdentityR3 )

    case DXGI_FORMAT_R16G16_UNORM:
        LOAD_SCANLINE2( XMUSHORTN2, XMLoadUShortN2, g_XMIdentityR3 )

    case DXGI_FORMAT_R16G16_UINT:
        LOAD_SCANLINE2( XMUSHORT2, XMLoadUShort2, g_XMIdentityR3 )

    case DXGI_FORMAT_R16G16_SNORM:
        LOAD_SCANLINE2( XMSHORTN2, XMLoadShortN2, g_XMIdentityR3 )

    case DXGI_FORMAT_R16G16_SINT:
        LOAD_SCANLINE2( XMSHORT2, XMLoadShort2, g_XMIdentityR3 )

    case DXGI_FORMAT_D32_FLOAT:
    case DXGI_FORMAT_R32_FLOAT:
        if ( size >= sizeof(float) )
        {
            const float* __restrict sPtr = reinterpret_cast<const float*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(float) )
            {
                XMVECTOR v = XMLoadFloat( sPtr++ );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1000 );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R32_UINT:
        if ( size >= sizeof(uint32_t) )
        {
            const uint32_t* __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
            {
                XMVECTOR v = XMLoadInt( sPtr++ );
                v = XMConvertVectorUIntToFloat( v, 0 );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1000 );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R32_SINT:
        if ( size >= sizeof(int32_t) )
        {
            const int32_t * __restrict sPtr = reinterpret_cast<const int32_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(int32_t) )
            {
                XMVECTOR v = XMLoadInt( reinterpret_cast<const uint32_t*> (sPtr++) );
                v = XMConvertVectorIntToFloat( v, 0 );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1000 );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_D24_UNORM_S8_UINT:
        if ( size >= sizeof(uint32_t) )
        {
            const uint32_t * sPtr = reinterpret_cast<const uint32_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
            {
                float d = static_cast<float>( *sPtr & 0xFFFFFF ) / 16777215.f;
                float s = static_cast<float>( ( *sPtr & 0xFF000000 ) >> 24 );
                ++sPtr;
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( d, s, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R8G8_UNORM:
        LOAD_SCANLINE2( XMUBYTEN2, XMLoadUByteN2, g_XMIdentityR3 )

    case DXGI_FORMAT_R8G8_UINT:
        LOAD_SCANLINE2( XMUBYTE2, XMLoadUByte2, g_XMIdentityR3 )

    case DXGI_FORMAT_R8G8_SNORM:
        LOAD_SCANLINE2( XMBYTEN2, XMLoadByteN2, g_XMIdentityR3 )

    case DXGI_FORMAT_R8G8_SINT:
        LOAD_SCANLINE2( XMBYTE2, XMLoadByte2, g_XMIdentityR3 )

    case DXGI_FORMAT_R16_FLOAT:
        if ( size >= sizeof(HALF) )
        {
            const HALF * __restrict sPtr = reinterpret_cast<const HALF*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(HALF) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( XMConvertHalfToFloat(*sPtr++), 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_D16_UNORM:
    case DXGI_FORMAT_R16_UNORM:
        if ( size >= sizeof(uint16_t) )
        {
            const uint16_t* __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(uint16_t) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++) / 65535.f, 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R16_UINT:
        if ( size >= sizeof(uint16_t) )
        {
            const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(uint16_t) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++), 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R16_SNORM:
        if ( size >= sizeof(int16_t) )
        {
            const int16_t * __restrict sPtr = reinterpret_cast<const int16_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++) / 32767.f, 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R16_SINT:
        if ( size >= sizeof(int16_t) )
        {
            const int16_t * __restrict sPtr = reinterpret_cast<const int16_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++), 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R8_UNORM:
        if ( size >= sizeof(uint8_t) )
        {
            const uint8_t * __restrict sPtr = reinterpret_cast<const uint8_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++) / 255.f, 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R8_UINT:
        if ( size >= sizeof(uint8_t) )
        {
            const uint8_t * __restrict sPtr = reinterpret_cast<const uint8_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++), 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R8_SNORM:
        if ( size >= sizeof(char) )
        {
            const char * __restrict sPtr = reinterpret_cast<const char*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(char) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++) / 127.f, 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R8_SINT:
        if ( size >= sizeof(char) )
        {
            const char * __restrict sPtr = reinterpret_cast<const char*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(char) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++), 0.f, 0.f, 1.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_A8_UNORM:
        if ( size >= sizeof(uint8_t) )
        {
            const uint8_t * __restrict sPtr = reinterpret_cast<const uint8_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
            {
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSet( 0.f, 0.f, 0.f, static_cast<float>(*sPtr++) / 255.f );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R1_UNORM:
        if ( size >= sizeof(uint8_t) )
        {
            const uint8_t * __restrict sPtr = reinterpret_cast<const uint8_t*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
            {
                for( size_t bcount = 0; bcount < 8; ++bcount )
                {
                    if ( dPtr >= ePtr ) break;
                    *(dPtr++) = XMVectorSet( (((*sPtr >> bcount) & 0x1) ? 1.f : 0.f), 0.f, 0.f, 1.f );
                }

                ++sPtr;
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
        LOAD_SCANLINE3( XMFLOAT3SE, XMLoadFloat3SE, g_XMIdentityR3 )

    case DXGI_FORMAT_R8G8_B8G8_UNORM:
        if ( size >= sizeof(XMUBYTEN4) )
        {
            const XMUBYTEN4 * __restrict sPtr = reinterpret_cast<const XMUBYTEN4*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
            {
                XMVECTOR v = XMLoadUByteN4( sPtr++ );
                XMVECTOR v1 = XMVectorSwizzle<0, 3, 2, 1>( v );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1110 );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v1, g_XMSelect1110 );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_G8R8_G8B8_UNORM:
        if ( size >= sizeof(XMUBYTEN4) )
        {
            const XMUBYTEN4 * __restrict sPtr = reinterpret_cast<const XMUBYTEN4*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
            {
                XMVECTOR v = XMLoadUByteN4( sPtr++ );
                XMVECTOR v0 = XMVectorSwizzle<1, 0, 3, 2>( v );
                XMVECTOR v1 = XMVectorSwizzle<1, 2, 3, 0>( v );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v0, g_XMSelect1110 );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v1, g_XMSelect1110 );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_B5G6R5_UNORM:
        if ( size >= sizeof(XMU565) )
        {
            static XMVECTORF32 s_Scale = { 1.f/31.f, 1.f/63.f, 1.f/31.f, 1.f };
            const XMU565 * __restrict sPtr = reinterpret_cast<const XMU565*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(XMU565) )
            {
                XMVECTOR v = XMLoadU565( sPtr++ );
                v = XMVectorMultiply( v, s_Scale );
                v = XMVectorSwizzle<2, 1, 0, 3>( v );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1110 );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_B5G5R5A1_UNORM:
        if ( size >= sizeof(XMU555) )
        {
            static XMVECTORF32 s_Scale = { 1.f/31.f, 1.f/31.f, 1.f/31.f, 1.f };
            const XMU555 * __restrict sPtr = reinterpret_cast<const XMU555*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(XMU555) )
            {
                XMVECTOR v = XMLoadU555( sPtr++ );
                v = XMVectorMultiply( v, s_Scale );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSwizzle<2, 1, 0, 3>( v );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_B8G8R8A8_UNORM:
    case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
        if ( size >= sizeof(XMUBYTEN4) )
        {
            const XMUBYTEN4 * __restrict sPtr = reinterpret_cast<const XMUBYTEN4*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
            {
                XMVECTOR v = XMLoadUByteN4( sPtr++ );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSwizzle<2, 1, 0, 3>( v );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_B8G8R8X8_UNORM:
    case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
        if ( size >= sizeof(XMUBYTEN4) )
        {
            const XMUBYTEN4 * __restrict sPtr = reinterpret_cast<const XMUBYTEN4*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
            {
                XMVECTOR v = XMLoadUByteN4( sPtr++ );
                v = XMVectorSwizzle<2, 1, 0, 3>( v );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1110 );
            }
            return true;
        }
        return false;

    case DXGI_FORMAT_B4G4R4A4_UNORM:
        if ( size >= sizeof(XMUNIBBLE4) )
        {
            static XMVECTORF32 s_Scale = { 1.f/15.f, 1.f/15.f, 1.f/15.f, 1.f/15.f };
            const XMUNIBBLE4 * __restrict sPtr = reinterpret_cast<const XMUNIBBLE4*>(pSource);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUNIBBLE4) )
            {
                XMVECTOR v = XMLoadUNibble4( sPtr++ );
                v = XMVectorMultiply( v, s_Scale );
                if ( dPtr >= ePtr ) break;
                *(dPtr++) = XMVectorSwizzle<2, 1, 0, 3>( v );
            }
            return true;
        }
        return false;

    // we don't support the video formats ( see IsVideo function )

    default:
        return false;
    }
}

_In_ size_t _In_ const TexMetadata _In_ DWORD DirectX::_Out_writes_ ( nImages )
HRESULT DirectX::_ResizeSeparateColorAndAlpha | ( | _In_ IWICImagingFactory * | pWIC,
 |  | _In_ IWICBitmap * | original,
 |  | _In_ size_t | newWidth,
 |  | _In_ size_t | newHeight,
 |  | _In_ DWORD | filter,
 |  | _Inout_ const Image * | img
 | ) |  |
_Use_decl_annotations_ bool DirectX::_SetupImageArray | ( | uint8_t * | pMemory,
 |  | size_t | pixelSize,
 |  | const TexMetadata & | metadata,
 |  | DWORD | cpFlags,
 |  | Image * | images,
 |  | size_t | nImages
 | ) |  |

Definition at line 105 of file DirectXTexImage.cpp.

{
    assert( pMemory );
    assert( pixelSize > 0 );
    assert( nImages > 0 );

    if ( !images )
        return false;

    size_t index = 0;
    uint8_t* pixels = pMemory;
    const uint8_t* pEndBits = pMemory + pixelSize;

    switch( metadata.dimension )
    {
    case TEX_DIMENSION_TEXTURE1D:
    case TEX_DIMENSION_TEXTURE2D:
        if (metadata.arraySize == 0 || metadata.mipLevels == 0)
        {
            return false;
        }

        for( size_t item = 0; item < metadata.arraySize; ++item )
        {
            size_t w = metadata.width;
            size_t h = metadata.height;

            for( size_t level=0; level < metadata.mipLevels; ++level )
            {
                if ( index >= nImages )
                {
                    return false;
                }

                size_t rowPitch, slicePitch;
                ComputePitch( metadata.format, w, h, rowPitch, slicePitch, cpFlags );

                images[index].width = w;
                images[index].height = h;
                images[index].format = metadata.format;
                images[index].rowPitch = rowPitch;
                images[index].slicePitch = slicePitch;
                images[index].pixels = pixels;
                ++index;

                pixels += slicePitch;
                if ( pixels > pEndBits )
                {
                    return false;
                }

                if ( h > 1 )
                    h >>= 1;

                if ( w > 1 )
                    w >>= 1;
            }
        }
        return true;

    case TEX_DIMENSION_TEXTURE3D:
        {
            if (metadata.mipLevels == 0 || metadata.depth == 0)
            {
                return false;
            }

            size_t w = metadata.width;
            size_t h = metadata.height;
            size_t d = metadata.depth;

            for( size_t level=0; level < metadata.mipLevels; ++level )
            {
                size_t rowPitch, slicePitch;
                ComputePitch( metadata.format, w, h, rowPitch, slicePitch, cpFlags );

                for( size_t slice=0; slice < d; ++slice )
                {
                    if ( index >= nImages )
                    {
                        return false;
                    }

                    // We use the same memory organization that Direct3D 11 needs for D3D11_SUBRESOURCE_DATA
                    // with all slices of a given miplevel being continuous in memory
                    images[index].width = w;
                    images[index].height = h;
                    images[index].format = metadata.format;
                    images[index].rowPitch = rowPitch;
                    images[index].slicePitch = slicePitch;
                    images[index].pixels = pixels;
                    ++index;

                    pixels += slicePitch;
                    if ( pixels > pEndBits )
                    {
                        return false;
                    }
                }

                if ( h > 1 )
                    h >>= 1;

                if ( w > 1 )
                    w >>= 1;

                if ( d > 1 )
                    d >>= 1;
            }
        }
        return true;

    default:
        return false;
    }
}

_Use_decl_annotations_ bool DirectX::_StoreScanline | ( | LPVOID | pDestination,
 |  | size_t | size,
 |  | DXGI_FORMAT | format,
 |  | const XMVECTOR * | pSource,
 |  | size_t | count
 | ) |  |

Definition at line 970 of file DirectXTexConvert.cpp.

{
    assert( pDestination && size > 0 );
    assert( pSource && count > 0 && (((uintptr_t)pSource & 0xF) == 0) );
    assert( IsValid(format) && !IsVideo(format) && !IsTypeless(format) && !IsCompressed(format) );

    const XMVECTOR* __restrict sPtr = pSource;
    if ( !sPtr )
        return false;

    const XMVECTOR* ePtr = pSource + count;

    switch( format )
    {
    case DXGI_FORMAT_R32G32B32A32_FLOAT:
        STORE_SCANLINE( XMFLOAT4, XMStoreFloat4 )

    case DXGI_FORMAT_R32G32B32A32_UINT:
        STORE_SCANLINE( XMUINT4, XMStoreUInt4 )

    case DXGI_FORMAT_R32G32B32A32_SINT:
        STORE_SCANLINE( XMINT4, XMStoreSInt4 )

    case DXGI_FORMAT_R32G32B32_FLOAT:
        STORE_SCANLINE( XMFLOAT3, XMStoreFloat3 )

    case DXGI_FORMAT_R32G32B32_UINT:
        STORE_SCANLINE( XMUINT3, XMStoreUInt3 )

    case DXGI_FORMAT_R32G32B32_SINT:
        STORE_SCANLINE( XMINT3, XMStoreSInt3 )

    case DXGI_FORMAT_R16G16B16A16_FLOAT:
        STORE_SCANLINE( XMHALF4, XMStoreHalf4 )

    case DXGI_FORMAT_R16G16B16A16_UNORM:
        STORE_SCANLINE( XMUSHORTN4, XMStoreUShortN4 )

    case DXGI_FORMAT_R16G16B16A16_UINT:
        STORE_SCANLINE( XMUSHORT4, XMStoreUShort4 )

    case DXGI_FORMAT_R16G16B16A16_SNORM:
        STORE_SCANLINE( XMSHORTN4, XMStoreShortN4 )

    case DXGI_FORMAT_R16G16B16A16_SINT:
        STORE_SCANLINE( XMSHORT4, XMStoreShort4 )

    case DXGI_FORMAT_R32G32_FLOAT:
        STORE_SCANLINE( XMFLOAT2, XMStoreFloat2 )

    case DXGI_FORMAT_R32G32_UINT:
        STORE_SCANLINE( XMUINT2, XMStoreUInt2 )

    case DXGI_FORMAT_R32G32_SINT:
        STORE_SCANLINE( XMINT2, XMStoreSInt2 )

    case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
        if ( size >= (sizeof(float)+sizeof(uint32_t)) )
        {
            float *dPtr = reinterpret_cast<float*>(pDestination);
            for( size_t icount = 0; icount < size; icount += (sizeof(float)+sizeof(uint32_t)) )
            {
                if ( sPtr >= ePtr ) break;
                XMFLOAT4 f;
                XMStoreFloat4( &f, *sPtr++ );
                dPtr[0] = f.x;
                uint8_t* ps8 = reinterpret_cast<uint8_t*>( &dPtr[1] );
                ps8[0] = static_cast<uint8_t>( std::min<float>( 255.f, std::max<float>( 0.f, f.y ) ) );
                ps8[1] = ps8[2] = ps8[3] = 0;
                dPtr += 2;
            }
        }
        return true;

    case DXGI_FORMAT_R10G10B10A2_UNORM:
    case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
        STORE_SCANLINE( XMUDECN4, XMStoreUDecN4 );

    case DXGI_FORMAT_R10G10B10A2_UINT:
        STORE_SCANLINE( XMUDEC4, XMStoreUDec4 );

    case DXGI_FORMAT_R11G11B10_FLOAT:
        STORE_SCANLINE( XMFLOAT3PK, XMStoreFloat3PK );

    case DXGI_FORMAT_R8G8B8A8_UNORM:
    case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
        STORE_SCANLINE( XMUBYTEN4, XMStoreUByteN4 )

    case DXGI_FORMAT_R8G8B8A8_UINT:
        STORE_SCANLINE( XMUBYTE4, XMStoreUByte4 )

    case DXGI_FORMAT_R8G8B8A8_SNORM:
        STORE_SCANLINE( XMBYTEN4, XMStoreByteN4 )

    case DXGI_FORMAT_R8G8B8A8_SINT:
        STORE_SCANLINE( XMBYTE4, XMStoreByte4 )

    case DXGI_FORMAT_R16G16_FLOAT:
        STORE_SCANLINE( XMHALF2, XMStoreHalf2 )

    case DXGI_FORMAT_R16G16_UNORM:
        STORE_SCANLINE( XMUSHORTN2, XMStoreUShortN2 )

    case DXGI_FORMAT_R16G16_UINT:
        STORE_SCANLINE( XMUSHORT2, XMStoreUShort2 )

    case DXGI_FORMAT_R16G16_SNORM:
        STORE_SCANLINE( XMSHORTN2, XMStoreShortN2 )

    case DXGI_FORMAT_R16G16_SINT:
        STORE_SCANLINE( XMSHORT2, XMStoreShort2 )

    case DXGI_FORMAT_D32_FLOAT:
    case DXGI_FORMAT_R32_FLOAT:
        if ( size >= sizeof(float) )
        {
            float * __restrict dPtr = reinterpret_cast<float*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(float) )
            {
                if ( sPtr >= ePtr ) break;
                XMStoreFloat( dPtr++, *(sPtr++) );
            }
        }
        return true;

    case DXGI_FORMAT_R32_UINT:
        if ( size >= sizeof(uint32_t) )
        {
            uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v = XMConvertVectorFloatToUInt( *(sPtr++), 0 );
                XMStoreInt( dPtr++, v );
            }
        }
        return true;

    case DXGI_FORMAT_R32_SINT:
        if ( size >= sizeof(uint32_t) )
        {
            uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v = XMConvertVectorFloatToInt( *(sPtr++), 0 );
                XMStoreInt( dPtr++, v );
            }
        }
        return true;

    case DXGI_FORMAT_D24_UNORM_S8_UINT:
        if ( size >= sizeof(uint32_t) )
        {
            static const XMVECTORF32 clamp = { 1.f, 255.f, 0.f, 0.f };
            XMVECTOR zero = XMVectorZero();
            uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
            {
                if ( sPtr >= ePtr ) break;
                XMFLOAT4 f;
                XMStoreFloat4( &f, XMVectorClamp( *sPtr++, zero, clamp ) );
                *dPtr++ = (static_cast<uint32_t>( f.x * 16777215.f ) & 0xFFFFFF)
                          | ((static_cast<uint32_t>( f.y ) & 0xFF) << 24);
            }
        }
        return true;

    case DXGI_FORMAT_R8G8_UNORM:
        STORE_SCANLINE( XMUBYTEN2, XMStoreUByteN2 )

    case DXGI_FORMAT_R8G8_UINT:
        STORE_SCANLINE( XMUBYTE2, XMStoreUByte2 )

    case DXGI_FORMAT_R8G8_SNORM:
        STORE_SCANLINE( XMBYTEN2, XMStoreByteN2 )

    case DXGI_FORMAT_R8G8_SINT:
        STORE_SCANLINE( XMBYTE2, XMStoreByte2 )

    case DXGI_FORMAT_R16_FLOAT:
        if ( size >= sizeof(HALF) )
        {
            HALF * __restrict dPtr = reinterpret_cast<HALF*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(HALF) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                *(dPtr++) = XMConvertFloatToHalf(v);
            }
        }
        return true;

    case DXGI_FORMAT_D16_UNORM:
    case DXGI_FORMAT_R16_UNORM:
        if ( size >= sizeof(int16_t) )
        {
            int16_t * __restrict dPtr = reinterpret_cast<int16_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 1.f ), 0.f );
                *(dPtr++) = static_cast<uint16_t>( v*65535.f + 0.5f );
            }
        }
        return true;

    case DXGI_FORMAT_R16_UINT:
        if ( size >= sizeof(uint16_t) )
        {
            uint16_t * __restrict dPtr = reinterpret_cast<uint16_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(uint16_t) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 65535.f ), 0.f );
                *(dPtr++) = static_cast<uint16_t>(v);
            }
        }
        return true;

    case DXGI_FORMAT_R16_SNORM:
        if ( size >= sizeof(int16_t) )
        {
            int16_t * __restrict dPtr = reinterpret_cast<int16_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 1.f ), -1.f );
                *(dPtr++) = static_cast<uint16_t>( v * 32767.f );
            }
        }
        return true;

    case DXGI_FORMAT_R16_SINT:
        if ( size >= sizeof(int16_t) )
        {
            int16_t * __restrict dPtr = reinterpret_cast<int16_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 32767.f ), -32767.f );
                *(dPtr++) = static_cast<int16_t>(v);
            }
        }
        return true;

    case DXGI_FORMAT_R8_UNORM:
        if ( size >= sizeof(uint8_t) )
        {
            uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 1.f ), 0.f );
                *(dPtr++) = static_cast<uint8_t>( v * 255.f);
            }
        }
        return true;

    case DXGI_FORMAT_R8_UINT:
        if ( size >= sizeof(uint8_t) )
        {
            uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 255.f ), 0.f );
                *(dPtr++) = static_cast<uint8_t>(v);
            }
        }
        return true;

    case DXGI_FORMAT_R8_SNORM:
        if ( size >= sizeof(char) )
        {
            char * __restrict dPtr = reinterpret_cast<char*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(char) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 1.f ), -1.f );
                *(dPtr++) = static_cast<char>( v * 127.f );
            }
        }
        return true;

    case DXGI_FORMAT_R8_SINT:
        if ( size >= sizeof(char) )
        {
            char * __restrict dPtr = reinterpret_cast<char*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(char) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetX( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 127.f ), -127.f );
                *(dPtr++) = static_cast<char>( v );
            }
        }
        return true;

    case DXGI_FORMAT_A8_UNORM:
        if ( size >= sizeof(uint8_t) )
        {
            uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
            {
                if ( sPtr >= ePtr ) break;
                float v = XMVectorGetW( *sPtr++ );
                v = std::max<float>( std::min<float>( v, 1.f ), 0.f );
                *(dPtr++) = static_cast<uint8_t>( v * 255.f);
            }
        }
        return true;

    case DXGI_FORMAT_R1_UNORM:
        if ( size >= sizeof(uint8_t) )
        {
            uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
            {
                uint8_t pixels = 0;
                for( size_t bcount = 0; bcount < 8; ++bcount )
                {
                    if ( sPtr >= ePtr ) break;
                    float v = XMVectorGetX( *sPtr++ );
                    if ( v > 0.5f )
                        pixels |= 1 << bcount;
                }
                *(dPtr++) = pixels;
            }
        }
        return true;

    case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
        STORE_SCANLINE( XMFLOAT3SE, XMStoreFloat3SE )

    case DXGI_FORMAT_R8G8_B8G8_UNORM:
        if ( size >= sizeof(XMUBYTEN4) )
        {
            XMUBYTEN4 * __restrict dPtr = reinterpret_cast<XMUBYTEN4*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v0 = *sPtr++;
                XMVECTOR v1 = (sPtr < ePtr) ? XMVectorSplatY( *sPtr++ ) : XMVectorZero();
                XMVECTOR v = XMVectorSelect( v1, v0, g_XMSelect1110 );
                XMStoreUByteN4( dPtr++, v );
            }
        }
        return true;

    case DXGI_FORMAT_G8R8_G8B8_UNORM:
        if ( size >= sizeof(XMUBYTEN4) )
        {
            static XMVECTORI32 select1101 = {XM_SELECT_1, XM_SELECT_1, XM_SELECT_0, XM_SELECT_1};

            XMUBYTEN4 * __restrict dPtr = reinterpret_cast<XMUBYTEN4*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v0 = XMVectorSwizzle<1, 0, 3, 2>( *sPtr++ );
                XMVECTOR v1 = (sPtr < ePtr) ? XMVectorSplatY( *sPtr++ ) : XMVectorZero();
                XMVECTOR v = XMVectorSelect( v1, v0, select1101 );
                XMStoreUByteN4( dPtr++, v );
            }
        }
        return true;

    case DXGI_FORMAT_B5G6R5_UNORM:
        if ( size >= sizeof(XMU565) )
        {
            static XMVECTORF32 s_Scale = { 31.f, 63.f, 31.f, 1.f };
            XMU565 * __restrict dPtr = reinterpret_cast<XMU565*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(XMU565) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v = XMVectorSwizzle<2, 1, 0, 3>( *sPtr++ );
                v = XMVectorMultiply( v, s_Scale );
                XMStoreU565( dPtr++, v );
            }
        }
        return true;

    case DXGI_FORMAT_B5G5R5A1_UNORM:
        if ( size >= sizeof(XMU555) )
        {
            static XMVECTORF32 s_Scale = { 31.f, 31.f, 31.f, 1.f };
            XMU555 * __restrict dPtr = reinterpret_cast<XMU555*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(XMU555) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v = XMVectorSwizzle<2, 1, 0, 3>( *sPtr++ );
                v = XMVectorMultiply( v, s_Scale );
                XMStoreU555( dPtr++, v );
            }
        }
        return true;

    case DXGI_FORMAT_B8G8R8A8_UNORM:
    case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
        if ( size >= sizeof(XMUBYTEN4) )
        {
            XMUBYTEN4 * __restrict dPtr = reinterpret_cast<XMUBYTEN4*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v = XMVectorSwizzle<2, 1, 0, 3>( *sPtr++ );
                XMStoreUByteN4( dPtr++, v );
            }
        }
        return true;

    case DXGI_FORMAT_B8G8R8X8_UNORM:
    case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
        if ( size >= sizeof(XMUBYTEN4) )
        {
            XMUBYTEN4 * __restrict dPtr = reinterpret_cast<XMUBYTEN4*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v = XMVectorPermute<XM_PERMUTE_0Z, XM_PERMUTE_0Y, XM_PERMUTE_0X, XM_PERMUTE_1W>( *sPtr++, g_XMIdentityR3 );
                XMStoreUByteN4( dPtr++, v );
            }
        }
        return true;

    case DXGI_FORMAT_B4G4R4A4_UNORM:
        if ( size >= sizeof(XMUNIBBLE4) )
        {
            static XMVECTORF32 s_Scale = { 15.f, 15.f, 15.f, 15.f };
            XMUNIBBLE4 * __restrict dPtr = reinterpret_cast<XMUNIBBLE4*>(pDestination);
            for( size_t icount = 0; icount < size; icount += sizeof(XMUNIBBLE4) )
            {
                if ( sPtr >= ePtr ) break;
                XMVECTOR v = XMVectorSwizzle<2, 1, 0, 3>( *sPtr++ );
                v = XMVectorMultiply( v, s_Scale );
                XMStoreUNibble4( dPtr++, v );
            }
        }
        return true;

    // We don't support the video formats ( see IsVideo function )

    default:
        return false;
    }
}

DirectX::_Success_ ( return! = false )
_Use_decl_annotations_ void DirectX::_SwizzleScanline | ( | LPVOID | pDestination,
 |  | size_t | outSize,
 |  | LPCVOID | pSource,
 |  | size_t | inSize,
 |  | DXGI_FORMAT | format,
 |  | DWORD | flags
 | ) |  |

Definition at line 251 of file DirectXTexConvert.cpp.

{
    assert( pDestination && outSize > 0 );
    assert( pSource && inSize > 0 );
    assert( IsValid(format) && !IsVideo(format) );

    switch( format )
    {
    //---------------------------------------------------------------------------------
    case DXGI_FORMAT_R10G10B10A2_TYPELESS:
    case DXGI_FORMAT_R10G10B10A2_UNORM:
    case DXGI_FORMAT_R10G10B10A2_UINT:
    case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
        if ( flags & TEXP_SCANLINE_LEGACY )
        {
            // Swap Red (R) and Blue (B) channel (used for D3DFMT_A2R10G10B10 legacy sources)
            if ( pDestination == pSource )
            {
                uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
                for( size_t count = 0; count < outSize; count += 4 )
                {
#pragma warning(suppress: 6001 6101) // PREFast doesn't properly understand the aliasing here.
                    uint32_t t = *dPtr;

                    uint32_t t1 = (t & 0x3ff00000) >> 20;
                    uint32_t t2 = (t & 0x000003ff) << 20;
                    uint32_t t3 = (t & 0x000ffc00);
                    uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xC0000000 : (t & 0xC0000000);

                    *(dPtr++) = t1 | t2 | t3 | ta;
                }
            }
            else
            {
                const uint32_t * __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
                uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
                size_t size = std::min<size_t>( outSize, inSize );
                for( size_t count = 0; count < size; count += 4 )
                {
                    uint32_t t = *(sPtr++);

                    uint32_t t1 = (t & 0x3ff00000) >> 20;
                    uint32_t t2 = (t & 0x000003ff) << 20;
                    uint32_t t3 = (t & 0x000ffc00);
                    uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xC0000000 : (t & 0xC0000000);

                    *(dPtr++) = t1 | t2 | t3 | ta;
                }
            }
            return;
        }
        break;

    //---------------------------------------------------------------------------------
    case DXGI_FORMAT_R8G8B8A8_TYPELESS:
    case DXGI_FORMAT_R8G8B8A8_UNORM:
    case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
    case DXGI_FORMAT_B8G8R8A8_UNORM:
    case DXGI_FORMAT_B8G8R8X8_UNORM:
    case DXGI_FORMAT_B8G8R8A8_TYPELESS:
    case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
    case DXGI_FORMAT_B8G8R8X8_TYPELESS:
    case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
        // Swap Red (R) and Blue (B) channels (used to convert from DXGI 1.1 BGR formats to DXGI 1.0 RGB)
        if ( pDestination == pSource )
        {
            uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
            for( size_t count = 0; count < outSize; count += 4 )
            {
                uint32_t t = *dPtr;

                uint32_t t1 = (t & 0x00ff0000) >> 16;
                uint32_t t2 = (t & 0x000000ff) << 16;
                uint32_t t3 = (t & 0x0000ff00);
                uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xff000000 : (t & 0xFF000000);

                *(dPtr++) = t1 | t2 | t3 | ta;
            }
        }
        else
        {
            const uint32_t * __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
            uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
            size_t size = std::min<size_t>( outSize, inSize );
            for( size_t count = 0; count < size; count += 4 )
            {
                uint32_t t = *(sPtr++);

                uint32_t t1 = (t & 0x00ff0000) >> 16;
                uint32_t t2 = (t & 0x000000ff) << 16;
                uint32_t t3 = (t & 0x0000ff00);
                uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xff000000 : (t & 0xFF000000);

                *(dPtr++) = t1 | t2 | t3 | ta;
            }
        }
        return;
    }

    // Fall-through case is to just use memcpy (assuming this is not an in-place operation)
    if ( pDestination == pSource )
        return;

    size_t size = std::min<size_t>( outSize, inSize );
    memcpy_s( pDestination, outSize, pSource, size );
}

void DirectX::_SwizzleScanline | ( | _When_(pDestination==pSource, _In_) _When_(pDestination!=pSource, _Out_writes_bytes_(outSize)) LPVOID | pDestination,
 |  | _In_ size_t | outSize,
 |  | _In_reads_bytes_(inSize) LPCVOID | pSource,
 |  | _In_ size_t | inSize,
 |  | _In_ DXGI_FORMAT | format,
 |  | _In_ DWORD | flags
 | ) |  |
size_t DirectX::_WICBitsPerPixel ( _In_ REFGUID targetGuid )
_Use_decl_annotations_ size_t DirectX::_WICBitsPerPixel ( REFGUID targetGuid )

Definition at line 117 of file DirectXTexUtil.cpp.

{
    IWICImagingFactory* pWIC = _GetWIC();
    if ( !pWIC )
        return 0;

    ScopedObject<IWICComponentInfo> cinfo;
    if ( FAILED( pWIC->CreateComponentInfo( targetGuid, &cinfo ) ) )
        return 0;

    WICComponentType type;
    if ( FAILED( cinfo->GetComponentType( &type ) ) )
        return 0;

    if ( type != WICPixelFormat )
        return 0;

    ScopedObject<IWICPixelFormatInfo> pfinfo;
    if ( FAILED( cinfo->QueryInterface( __uuidof(IWICPixelFormatInfo), reinterpret_cast<void**>( &pfinfo )  ) ) )
        return 0;

    UINT bpp;
    if ( FAILED( pfinfo->GetBitsPerPixel( &bpp ) ) )
        return 0;

    return bpp;
}

DXGI_FORMAT DirectX::_WICToDXGI ( _In_ const GUID & guid )
_Use_decl_annotations_ DXGI_FORMAT DirectX::_WICToDXGI ( const GUID & guid )

Definition at line 65 of file DirectXTexUtil.cpp.

{
    for( size_t i=0; i < _countof(g_WICFormats); ++i )
    {
        if ( memcmp( &g_WICFormats[i].wic, &guid, sizeof(GUID) ) == 0 )
            return g_WICFormats[i].format;
    }

    return DXGI_FORMAT_UNKNOWN;
}

size_t DirectX::BitsPerPixel ( _In_ DXGI_FORMAT fmt )
_Use_decl_annotations_ size_t DirectX::BitsPerPixel ( DXGI_FORMAT fmt )

Definition at line 213 of file DirectXTexUtil.cpp.

{
    switch( fmt )
    {
    case DXGI_FORMAT_R32G32B32A32_TYPELESS:
    case DXGI_FORMAT_R32G32B32A32_FLOAT:
    case DXGI_FORMAT_R32G32B32A32_UINT:
    case DXGI_FORMAT_R32G32B32A32_SINT:
        return 128;

    case DXGI_FORMAT_R32G32B32_TYPELESS:
    case DXGI_FORMAT_R32G32B32_FLOAT:
    case DXGI_FORMAT_R32G32B32_UINT:
    case DXGI_FORMAT_R32G32B32_SINT:
        return 96;

    case DXGI_FORMAT_R16G16B16A16_TYPELESS:
    case DXGI_FORMAT_R16G16B16A16_FLOAT:
    case DXGI_FORMAT_R16G16B16A16_UNORM:
    case DXGI_FORMAT_R16G16B16A16_UINT:
    case DXGI_FORMAT_R16G16B16A16_SNORM:
    case DXGI_FORMAT_R16G16B16A16_SINT:
    case DXGI_FORMAT_R32G32_TYPELESS:
    case DXGI_FORMAT_R32G32_FLOAT:
    case DXGI_FORMAT_R32G32_UINT:
    case DXGI_FORMAT_R32G32_SINT:
    case DXGI_FORMAT_R32G8X24_TYPELESS:
    case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
    case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
    case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
        return 64;

    case DXGI_FORMAT_R10G10B10A2_TYPELESS:
    case DXGI_FORMAT_R10G10B10A2_UNORM:
    case DXGI_FORMAT_R10G10B10A2_UINT:
    case DXGI_FORMAT_R11G11B10_FLOAT:
    case DXGI_FORMAT_R8G8B8A8_TYPELESS:
    case DXGI_FORMAT_R8G8B8A8_UNORM:
    case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
    case DXGI_FORMAT_R8G8B8A8_UINT:
    case DXGI_FORMAT_R8G8B8A8_SNORM:
    case DXGI_FORMAT_R8G8B8A8_SINT:
    case DXGI_FORMAT_R16G16_TYPELESS:
    case DXGI_FORMAT_R16G16_FLOAT:
    case DXGI_FORMAT_R16G16_UNORM:
    case DXGI_FORMAT_R16G16_UINT:
    case DXGI_FORMAT_R16G16_SNORM:
    case DXGI_FORMAT_R16G16_SINT:
    case DXGI_FORMAT_R32_TYPELESS:
    case DXGI_FORMAT_D32_FLOAT:
    case DXGI_FORMAT_R32_FLOAT:
    case DXGI_FORMAT_R32_UINT:
    case DXGI_FORMAT_R32_SINT:
    case DXGI_FORMAT_R24G8_TYPELESS:
    case DXGI_FORMAT_D24_UNORM_S8_UINT:
    case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
    case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
    case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
    case DXGI_FORMAT_R8G8_B8G8_UNORM:
    case DXGI_FORMAT_G8R8_G8B8_UNORM:
    case DXGI_FORMAT_B8G8R8A8_UNORM:
    case DXGI_FORMAT_B8G8R8X8_UNORM:
    case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
    case DXGI_FORMAT_B8G8R8A8_TYPELESS:
    case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
    case DXGI_FORMAT_B8G8R8X8_TYPELESS:
    case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
        return 32;

    case DXGI_FORMAT_R8G8_TYPELESS:
    case DXGI_FORMAT_R8G8_UNORM:
    case DXGI_FORMAT_R8G8_UINT:
    case DXGI_FORMAT_R8G8_SNORM:
    case DXGI_FORMAT_R8G8_SINT:
    case DXGI_FORMAT_R16_TYPELESS:
    case DXGI_FORMAT_R16_FLOAT:
    case DXGI_FORMAT_D16_UNORM:
    case DXGI_FORMAT_R16_UNORM:
    case DXGI_FORMAT_R16_UINT:
    case DXGI_FORMAT_R16_SNORM:
    case DXGI_FORMAT_R16_SINT:
    case DXGI_FORMAT_B5G6R5_UNORM:
    case DXGI_FORMAT_B5G5R5A1_UNORM:
        return 16;

    case DXGI_FORMAT_R8_TYPELESS:
    case DXGI_FORMAT_R8_UNORM:
    case DXGI_FORMAT_R8_UINT:
    case DXGI_FORMAT_R8_SNORM:
    case DXGI_FORMAT_R8_SINT:
    case DXGI_FORMAT_A8_UNORM:
        return 8;

    case DXGI_FORMAT_R1_UNORM:
        return 1;

    case DXGI_FORMAT_BC1_TYPELESS:
    case DXGI_FORMAT_BC1_UNORM:
    case DXGI_FORMAT_BC1_UNORM_SRGB:
    case DXGI_FORMAT_BC4_TYPELESS:
    case DXGI_FORMAT_BC4_UNORM:
    case DXGI_FORMAT_BC4_SNORM:
        return 4;

    case DXGI_FORMAT_BC2_TYPELESS:
    case DXGI_FORMAT_BC2_UNORM:
    case DXGI_FORMAT_BC2_UNORM_SRGB:
    case DXGI_FORMAT_BC3_TYPELESS:
    case DXGI_FORMAT_BC3_UNORM:
    case DXGI_FORMAT_BC3_UNORM_SRGB:
    case DXGI_FORMAT_BC5_TYPELESS:
    case DXGI_FORMAT_BC5_UNORM:
    case DXGI_FORMAT_BC5_SNORM:
    case DXGI_FORMAT_BC6H_TYPELESS:
    case DXGI_FORMAT_BC6H_UF16:
    case DXGI_FORMAT_BC6H_SF16:
    case DXGI_FORMAT_BC7_TYPELESS:
    case DXGI_FORMAT_BC7_UNORM:
    case DXGI_FORMAT_BC7_UNORM_SRGB:
        return 8;

    case DXGI_FORMAT_B4G4R4A4_UNORM:
        return 16;

    // We don't support the video formats ( see IsVideo function )

    default:
        return 0;
    }
}

_Use_decl_annotations_ HRESULT DirectX::CaptureTexture | ( | ID3D11Device * | pDevice,
 |  | ID3D11DeviceContext * | pContext,
 |  | ID3D11Resource * | pSource,
 |  | ScratchImage & | result
 | ) |  |

Definition at line 609 of file DirectXTexD3D11.cpp.

{
    if ( !pDevice || !pContext || !pSource )
        return E_INVALIDARG;

    D3D11_RESOURCE_DIMENSION resType = D3D11_RESOURCE_DIMENSION_UNKNOWN;
    pSource->GetType( &resType );

    HRESULT hr;

    switch( resType )
    {
    case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
        {
            ScopedObject<ID3D11Texture1D> pTexture;
            hr = pSource->QueryInterface( __uuidof(ID3D11Texture1D), (void**) &pTexture );
            if ( FAILED(hr) )
                break;

            assert( pTexture.Get() );

            D3D11_TEXTURE1D_DESC desc;
            pTexture->GetDesc( &desc );

            desc.BindFlags = 0;
            desc.MiscFlags = 0;
            desc.CPUAccessFlags = D3D11_CPU_ACCESS_READ;
            desc.Usage = D3D11_USAGE_STAGING;

            ScopedObject<ID3D11Texture1D> pStaging;
            hr = pDevice->CreateTexture1D( &desc, 0, &pStaging );
            if ( FAILED(hr) )
                break;

            assert( pStaging.Get() );

            pContext->CopyResource( pStaging.Get(), pSource );

            TexMetadata mdata;
            mdata.width = desc.Width;
            mdata.height = mdata.depth = 1;
            mdata.arraySize = desc.ArraySize;
            mdata.mipLevels = desc.MipLevels;
            mdata.miscFlags = 0;
            mdata.format = desc.Format;
            mdata.dimension = TEX_DIMENSION_TEXTURE1D;

            hr = result.Initialize( mdata );
            if ( FAILED(hr) )
                break;

            hr = _Capture( pContext, pStaging.Get(), mdata, result );
        }
        break;

    case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
        {
            ScopedObject<ID3D11Texture2D> pTexture;
            hr = pSource->QueryInterface( __uuidof(ID3D11Texture2D), (void**) &pTexture );
            if ( FAILED(hr) )
                break;

            assert( pTexture.Get() );

            D3D11_TEXTURE2D_DESC desc;
            pTexture->GetDesc( &desc );

            ScopedObject<ID3D11Texture2D> pStaging;
            if ( desc.SampleDesc.Count > 1 )
            {
                desc.SampleDesc.Count = 1;
                desc.SampleDesc.Quality = 0;

                ScopedObject<ID3D11Texture2D> pTemp;
                hr = pDevice->CreateTexture2D( &desc, 0, &pTemp );
                if ( FAILED(hr) )
                    break;

                assert( pTemp.Get() );

                for( UINT item = 0; item < desc.ArraySize; ++item )
                {
                    for( UINT level = 0; level < desc.MipLevels; ++level )
                    {
                        UINT index = D3D11CalcSubresource( level, item, desc.MipLevels );
                        pContext->ResolveSubresource( pTemp.Get(), index, pSource, index, desc.Format );
                    }
                }

                desc.BindFlags = 0;
                desc.MiscFlags &= D3D11_RESOURCE_MISC_TEXTURECUBE;
                desc.CPUAccessFlags = D3D11_CPU_ACCESS_READ;
                desc.Usage = D3D11_USAGE_STAGING;

                hr = pDevice->CreateTexture2D( &desc, 0, &pStaging );
                if ( FAILED(hr) )
                    break;

                assert( pStaging.Get() );

                pContext->CopyResource( pStaging.Get(), pTemp.Get() );
            }
            else
            {
                desc.BindFlags = 0;
                desc.MiscFlags &= D3D11_RESOURCE_MISC_TEXTURECUBE;
                desc.CPUAccessFlags = D3D11_CPU_ACCESS_READ;
                desc.Usage = D3D11_USAGE_STAGING;

                hr = pDevice->CreateTexture2D( &desc, 0, &pStaging );
                if ( FAILED(hr) )
                    break;

                assert( pStaging.Get() );

                pContext->CopyResource( pStaging.Get(), pSource );
            }

            TexMetadata mdata;
            mdata.width = desc.Width;
            mdata.height = desc.Height;
            mdata.depth = 1;
            mdata.arraySize = desc.ArraySize;
            mdata.mipLevels = desc.MipLevels;
            mdata.miscFlags = (desc.MiscFlags & D3D11_RESOURCE_MISC_TEXTURECUBE) ? TEX_MISC_TEXTURECUBE : 0;
            mdata.format = desc.Format;
            mdata.dimension = TEX_DIMENSION_TEXTURE2D;

            hr = result.Initialize( mdata );
            if ( FAILED(hr) )
                break;

            hr = _Capture( pContext, pStaging.Get(), mdata, result );
        }
        break;

    case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
        {
            ScopedObject<ID3D11Texture3D> pTexture;
            hr = pSource->QueryInterface( __uuidof(ID3D11Texture3D), (void**) &pTexture );
            if ( FAILED(hr) )
                break;

            assert( pTexture.Get() );

            D3D11_TEXTURE3D_DESC desc;
            pTexture->GetDesc( &desc );

            desc.BindFlags = 0;
            desc.MiscFlags = 0;
            desc.CPUAccessFlags = D3D11_CPU_ACCESS_READ;
            desc.Usage = D3D11_USAGE_STAGING;

            ScopedObject<ID3D11Texture3D> pStaging;
            hr = pDevice->CreateTexture3D( &desc, 0, &pStaging );
            if ( FAILED(hr) )
                break;

            assert( pStaging.Get() );

            pContext->CopyResource( pStaging.Get(), pSource );

            TexMetadata mdata;
            mdata.width = desc.Width;
            mdata.height = desc.Height;
            mdata.depth = desc.Depth;
            mdata.arraySize = 1;
            mdata.mipLevels = desc.MipLevels;
            mdata.miscFlags = 0;
            mdata.format = desc.Format;
            mdata.dimension = TEX_DIMENSION_TEXTURE3D;

            hr = result.Initialize( mdata );
            if ( FAILED(hr) )
                break;

            hr = _Capture( pContext, pStaging.Get(), mdata, result );
        }
        break;

    default:
        hr = E_FAIL;
        break;
    }

    if ( FAILED(hr) )
    {
        result.Release();
        return hr;
    }

    return S_OK;
}

HRESULT DirectX::CaptureTexture | ( | _In_ ID3D11Device * | pDevice,
 |  | _In_ ID3D11DeviceContext * | pContext,
 |  | _In_ ID3D11Resource * | pSource,
 |  | _Out_ ScratchImage & | result
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::Compress | ( | const Image & | srcImage,
 |  | DXGI_FORMAT | format,
 |  | DWORD | compress,
 |  | float | alphaRef,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 432 of file DirectXTexCompress.cpp.

{
    if ( IsCompressed(srcImage.format) || !IsCompressed(format) || IsTypeless(format) )
        return E_INVALIDARG;

    // Image size must be a multiple of 4 (degenerate cases for mipmaps are allowed)
    bool degenerate = false;

    size_t width = srcImage.width;
    if ( (width % 4) != 0 )
    {
        if ( width != 1 && width != 2 )
            return E_INVALIDARG;

        degenerate = true;
    }

    size_t height = srcImage.height;
    if ( (height % 4) != 0 )
    {
        if ( height != 1 && height != 2 )
            return E_INVALIDARG;

        degenerate = true;
    }

    // Create compressed image
    HRESULT hr = image.Initialize2D( format, width, height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    const Image *img = image.GetImage( 0, 0, 0 );
    if ( !img )
    {
        image.Release();
        return E_POINTER;
    }

    // Compress single image
    if ( (compress & TEX_COMPRESS_PARALLEL) && !degenerate )
    {
#ifndef _OPENMP
        return E_NOTIMPL;
#else
        hr = _CompressBC_Parallel( srcImage, *img, _GetBCFlags( compress ), alphaRef );
#endif // _OPENMP
    }
    else
    {
        hr = _CompressBC( srcImage, *img, _GetBCFlags( compress ), alphaRef, degenerate );
    }

    if ( FAILED(hr) )
        image.Release();

_Use_decl_annotations_ HRESULT DirectX::Compress | ( | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | DXGI_FORMAT | format,
 |  | DWORD | compress,
 |  | float | alphaRef,
 |  | ScratchImage & | cImages
 | ) |  |

Definition at line 491 of file DirectXTexCompress.cpp.

{
    if ( !srcImages || !nimages )
        return E_INVALIDARG;

    if ( !IsCompressed(format) || IsTypeless(format) )
        return E_INVALIDARG;

    // Image size must be a multiple of 4 (degenerate cases for mipmaps are allowed)
    size_t width = srcImages[0].width;
    if ( (width % 4) != 0 )
    {
        if ( width != 1 && width != 2 )
            return E_INVALIDARG;
    }

    size_t height = srcImages[0].height;
    if ( (height % 4) != 0 )
    {
        if ( height != 1 && height != 2 )
            return E_INVALIDARG;
    }

    cImages.Release();

    TexMetadata mdata2 = metadata;
    mdata2.format = format;
    HRESULT hr = cImages.Initialize( mdata2 );
    if ( FAILED(hr) )
        return hr;

    if ( nimages != cImages.GetImageCount() )
    {
        cImages.Release();
        return E_FAIL;
    }

    const Image* dest = cImages.GetImages();
    if ( !dest  )
    {
        cImages.Release();
        return E_POINTER;
    }

    for( size_t index=0; index < nimages; ++index )
    {
        assert( dest[ index ].format == format );

        const Image& src = srcImages[ index ];

        height = src.height;
        width = src.width;
        if ( width != dest[ index ].width || height != dest[ index ].height )
        {
            cImages.Release();
            return E_FAIL;
        }

        bool degenerate = ((height < 4) || (width < 4)) != 0;

        if ( (compress & TEX_COMPRESS_PARALLEL) && !degenerate)
        {
#ifndef _OPENMP
            return E_NOTIMPL;
#else
            if ( compress & TEX_COMPRESS_PARALLEL )
            {
                hr = _CompressBC_Parallel( src, dest[ index ], _GetBCFlags( compress ), alphaRef );
                if ( FAILED(hr) )
                {
                    cImages.Release();
                    return  hr;
                }
            }
#endif // _OPENMP
        }
        else
        {
            hr = _CompressBC( src, dest[ index ], _GetBCFlags( compress ), alphaRef, degenerate );
            if ( FAILED(hr) )
            {
                cImages.Release();
                return hr;
            }
        }
    }

HRESULT DirectX::Compress | ( | _In_ const Image & | srcImage,
 |  | _In_ DXGI_FORMAT | format,
 |  | _In_ DWORD | compress,
 |  | _In_ float | alphaRef,
 |  | _Out_ ScratchImage & | cImage
 | ) |  |
HRESULT DirectX::Compress | ( | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DXGI_FORMAT | format,
 |  | _In_ DWORD | compress,
 |  | _In_ float | alphaRef,
 |  | _Out_ ScratchImage & | cImages
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::ComputeMSE | ( | const Image & | image1,
 |  | const Image & | image2,
 |  | float & | mse,
 |  | float * | mseV
 | ) |  |

Definition at line 196 of file DirectXTexMisc.cpp.

{
    if ( !image1.pixels || !image2.pixels )
        return E_POINTER;

    if ( image1.width != image2.width || image1.height != image2.height )
        return E_INVALIDARG;

    if ( IsCompressed(image1.format) )
    {
        if ( IsCompressed(image2.format) )
        {
            // Case 1: both images are compressed, expand to RGBA32F
            ScratchImage temp1;
            HRESULT hr = Decompress( image1, DXGI_FORMAT_R32G32B32A32_FLOAT, temp1 );
            if ( FAILED(hr) )
                return hr;

            ScratchImage temp2;
            hr = Decompress(  image2, DXGI_FORMAT_R32G32B32A32_FLOAT, temp2 );
            if ( FAILED(hr) )
                return hr;

            const Image* img1 = temp1.GetImage(0,0,0);
            const Image* img2 = temp2.GetImage(0,0,0);
            if ( !img1 || !img2 )
                return E_POINTER;

            return _ComputeMSE( *img1, *img2, mse, mseV );
        }
        else
        {
            // Case 2: image1 is compressed, expand to RGBA32F
            ScratchImage temp;
            HRESULT hr = Decompress( image1, DXGI_FORMAT_R32G32B32A32_FLOAT, temp );
            if ( FAILED(hr) )
                return hr;

            const Image* img = temp.GetImage(0,0,0);
            if ( !img )
                return E_POINTER;

            return _ComputeMSE( *img, image2, mse, mseV );
        }
    }
    else
    {
        if ( IsCompressed(image2.format) )
        {
            // Case 3: image2 is compressed, expand to RGBA32F
            ScratchImage temp;
            HRESULT hr = Decompress( image2, DXGI_FORMAT_R32G32B32A32_FLOAT, temp );
            if ( FAILED(hr) )
                return hr;

            const Image* img = temp.GetImage(0,0,0);
            if ( !img )
                return E_POINTER;

            return _ComputeMSE( image1, *img, mse, mseV );
        }
        else
        {
            // Case 4: neither image is compressed
            return _ComputeMSE( image1, image2, mse, mseV );
        }
    }
}

HRESULT DirectX::ComputeMSE | ( | _In_ const Image & | image1,
 |  | _In_ const Image & | image2,
 |  | _Out_ float & | mse,
 |  | _Out_writes_opt_(4) float * | mseV
 | ) |  |
HRESULT DirectX::ComputeNormalMap | ( | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DWORD | flags,
 |  | _In_ float | amplitude,
 |  | _In_ DXGI_FORMAT | format,
 |  | _Out_ ScratchImage & | normalMaps
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::ComputeNormalMap | ( | const Image & | srcImage,
 |  | DWORD | flags,
 |  | float | amplitude,
 |  | DXGI_FORMAT | format,
 |  | ScratchImage & | normalMap
 | ) |  |

Definition at line 255 of file DirectXTexNormalMaps.cpp.

{
    if ( !srcImage.pixels || !IsValid(format) || IsCompressed( format ) || IsTypeless( format ) )
        return E_INVALIDARG;

    static_assert( CNMAP_CHANNEL_RED == 0x1, "CNMAP_CHANNEL_ flag values don't match mask" );
    switch( flags & 0xf )
    {
    case 0:
    case CNMAP_CHANNEL_RED:
    case CNMAP_CHANNEL_GREEN:
    case CNMAP_CHANNEL_BLUE:
    case CNMAP_CHANNEL_ALPHA:
    case CNMAP_CHANNEL_LUMINANCE:
        break;

    default:
        return E_INVALIDARG;
    }

    if ( IsCompressed( srcImage.format ) || IsTypeless( srcImage.format ) )
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );

    // Setup target image
    normalMap.Release();

    HRESULT hr = normalMap.Initialize2D( format, srcImage.width, srcImage.height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    const Image *img = normalMap.GetImage( 0, 0, 0 );
    if ( !img )
    {
        normalMap.Release();
        return E_POINTER;
    }

    hr = _ComputeNMap( srcImage, flags, amplitude, format, *img );
    if ( FAILED(hr) )
    {
        normalMap.Release();
        return hr;
    }

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::ComputeNormalMap | ( | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | DWORD | flags,
 |  | float | amplitude,
 |  | DXGI_FORMAT | format,
 |  | ScratchImage & | normalMaps
 | ) |  |

Definition at line 304 of file DirectXTexNormalMaps.cpp.

{
    if ( !srcImages || !nimages )
        return E_INVALIDARG;

    if ( !IsValid(format) || IsCompressed(format) || IsTypeless(format) )
        return E_INVALIDARG;

    static_assert( CNMAP_CHANNEL_RED == 0x1, "CNMAP_CHANNEL_ flag values don't match mask" );
    switch( flags & 0xf )
    {
    case 0:
    case CNMAP_CHANNEL_RED:
    case CNMAP_CHANNEL_GREEN:
    case CNMAP_CHANNEL_BLUE:
    case CNMAP_CHANNEL_ALPHA:
    case CNMAP_CHANNEL_LUMINANCE:
        break;

    default:
        return E_INVALIDARG;
    }

    normalMaps.Release();

    TexMetadata mdata2 = metadata;
    mdata2.format = format;
    HRESULT hr = normalMaps.Initialize( mdata2 );
    if ( FAILED(hr) )
        return hr;

    if ( nimages != normalMaps.GetImageCount() )
    {
        normalMaps.Release();
        return E_FAIL;
    }

    const Image* dest = normalMaps.GetImages();
    if ( !dest )
    {
        normalMaps.Release();
        return E_POINTER;
    }

    for( size_t index=0; index < nimages; ++index )
    {
        assert( dest[ index ].format == format );

        const Image& src = srcImages[ index ];
        if ( IsCompressed( src.format ) || IsTypeless( src.format ) )
        {
            normalMaps.Release();
            return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
        }

        if ( src.width != dest[ index ].width || src.height != dest[ index ].height )
        {
            normalMaps.Release();
            return E_FAIL;
        }

        hr = _ComputeNMap( src, flags, amplitude, format, dest[ index ] );
        if ( FAILED(hr) )
        {
            normalMaps.Release();
            return hr;
        }
    }

    return S_OK;
}

HRESULT DirectX::ComputeNormalMap | ( | _In_ const Image & | srcImage,
 |  | _In_ DWORD | flags,
 |  | _In_ float | amplitude,
 |  | _In_ DXGI_FORMAT | format,
 |  | _Out_ ScratchImage & | normalMap
 | ) |  |
void DirectX::ComputePitch | ( | _In_ DXGI_FORMAT | fmt,
 |  | _In_ size_t | width,
 |  | _In_ size_t | height,
 |  | _Out_ size_t & | rowPitch,
 |  | _Out_ size_t & | slicePitch,
 |  | _In_ DWORD | flags = CP_FLAGS_NONE
 | ) |  |
_Use_decl_annotations_ void DirectX::ComputePitch | ( | DXGI_FORMAT | fmt,
 |  | size_t | width,
 |  | size_t | height,
 |  | size_t & | rowPitch,
 |  | size_t & | slicePitch,
 |  | DWORD | flags
 | ) |  |

Definition at line 350 of file DirectXTexUtil.cpp.

{
    assert( IsValid(fmt) && !IsVideo(fmt) );

    if ( IsCompressed(fmt) )
    {
        size_t bpb = ( fmt == DXGI_FORMAT_BC1_TYPELESS
                     || fmt == DXGI_FORMAT_BC1_UNORM
                     || fmt == DXGI_FORMAT_BC1_UNORM_SRGB
                     || fmt == DXGI_FORMAT_BC4_TYPELESS
                     || fmt == DXGI_FORMAT_BC4_UNORM
                     || fmt == DXGI_FORMAT_BC4_SNORM) ? 8 : 16;
        size_t nbw = std::max<size_t>( 1, (width + 3) / 4 );
        size_t nbh = std::max<size_t>( 1, (height + 3) / 4 );
        rowPitch = nbw * bpb;

        slicePitch = rowPitch * nbh;
    }
    else if ( IsPacked(fmt) )
    {
        rowPitch = ( ( width + 1 ) >> 1) * 4;

        slicePitch = rowPitch * height;
    }
    else
    {
        size_t bpp;

        if ( flags & CP_FLAGS_24BPP )
            bpp = 24;
        else if ( flags & CP_FLAGS_16BPP )
            bpp = 16;
        else if ( flags & CP_FLAGS_8BPP )
            bpp = 8;
        else
            bpp = BitsPerPixel( fmt );

        if ( flags & CP_FLAGS_LEGACY_DWORD )
        {
            // Special computation for some incorrectly created DDS files based on
            // legacy DirectDraw assumptions about pitch alignment
            rowPitch = ( ( width * bpp + 31 ) / 32 ) * sizeof(uint32_t);
            slicePitch = rowPitch * height;
        }
        else
        {
            rowPitch = ( width * bpp + 7 ) / 8;
            slicePitch = rowPitch * height;
        }
    }
}

_Use_decl_annotations_ size_t DirectX::ComputeScanlines | ( | DXGI_FORMAT | fmt,
 |  | size_t | height |
 | ) |  |  | [inline]

Definition at line 158 of file DirectXTex.h.

    {
        size_t      width;
        size_t      height;
        DXGI_FORMAT format;
        size_t      rowPitch;
        size_t      slicePitch;
        uint8_t*    pixels;
    };

    class ScratchImage
    {
    public:
        ScratchImage() : _nimages(0), _size(0), _image(0), _memory(0) {}
        ~ScratchImage() { Release(); }

        HRESULT Initialize( _In_ const TexMetadata& mdata );

        HRESULT Initialize1D( _In_ DXGI_FORMAT fmt, _In_ size_t length, _In_ size_t arraySize, _In_ size_t mipLevels );
        HRESULT Initialize2D( _In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t arraySize, _In_ size_t mipLevels );
        HRESULT Initialize3D( _In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t depth, _In_ size_t mipLevels );
        HRESULT InitializeCube( _In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t nCubes, _In_ size_t mipLevels );

        HRESULT InitializeFromImage( _In_ const Image& srcImage, _In_ bool allow1D = false );

size_t DirectX::ComputeScanlines | ( | _In_ DXGI_FORMAT | fmt,
 |  | _In_ size_t | height
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::Convert | ( | const Image & | srcImage,
 |  | DXGI_FORMAT | format,
 |  | DWORD | filter,
 |  | float | threshold,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 2247 of file DirectXTexConvert.cpp.

{
    if ( (srcImage.format == format) || !IsValid( format ) )
        return E_INVALIDARG;

    if ( !srcImage.pixels )
        return E_POINTER;

    if ( IsCompressed(srcImage.format) || IsCompressed(format)
         || IsVideo(srcImage.format) || IsVideo(format)
         || IsTypeless(srcImage.format) || IsTypeless(format) )
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );

#ifdef _AMD64_
    if ( (srcImage.width > 0xFFFFFFFF) || (srcImage.height > 0xFFFFFFFF) )
        return E_INVALIDARG;
#endif

    HRESULT hr = image.Initialize2D( format, srcImage.width, srcImage.height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    const Image *rimage = image.GetImage( 0, 0, 0 );
    if ( !rimage )
    {
        image.Release();
        return E_POINTER;
    }

    WICPixelFormatGUID pfGUID;
    if ( _DXGIToWIC( srcImage.format, pfGUID ) )
    {
        WICPixelFormatGUID targetGUID;
        if ( _DXGIToWIC( format, targetGUID ) )
        {
            // Case 1: Both source and target formats are WIC supported
            hr = _ConvertUsingWIC( srcImage, pfGUID, targetGUID, filter, threshold, *rimage );
        }
        else
        {
            // Case 2: Source format is supported by WIC, but not the target format
            hr = _ConvertFromWIC( srcImage, pfGUID, filter, threshold, *rimage );
        }
    }
    else
    {
        WICPixelFormatGUID targetGUID;
        if ( _DXGIToWIC( format, targetGUID ) )
        {
            // Case 3: Source format is not supported by WIC, but does support the target format
            hr = _ConvertToWIC( srcImage, targetGUID, filter, threshold, *rimage );
        }
        else
        {
            // Case 4: Both source and target format are not supported by WIC
            hr = _Convert( srcImage, filter, *rimage );
        }
    }

    if ( FAILED(hr) )
    {
        image.Release();
        return hr;
    }

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::Convert | ( | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | DXGI_FORMAT | format,
 |  | DWORD | filter,
 |  | float | threshold,
 |  | ScratchImage & | result
 | ) |  |

Definition at line 2320 of file DirectXTexConvert.cpp.

{
    if ( !srcImages || !nimages || (metadata.format == format) || !IsValid(format) )
        return E_INVALIDARG;

    if ( IsCompressed(metadata.format) || IsCompressed(format)
         || IsVideo(metadata.format) || IsVideo(format)
         || IsTypeless(metadata.format) || IsTypeless(format) )
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );

#ifdef _AMD64_
    if ( (metadata.width > 0xFFFFFFFF) || (metadata.height > 0xFFFFFFFF) )
        return E_INVALIDARG;
#endif

    TexMetadata mdata2 = metadata;
    mdata2.format = format;
    HRESULT hr = result.Initialize( mdata2 );
    if ( FAILED(hr) )
        return hr;

    if ( nimages != result.GetImageCount() )
    {
        result.Release();
        return E_FAIL;
    }

    const Image* dest = result.GetImages();
    if ( !dest )
    {
        result.Release();
        return E_POINTER;
    }

    WICPixelFormatGUID pfGUID, targetGUID;
    bool wicpf = _DXGIToWIC( metadata.format, pfGUID );
    bool wictargetpf = _DXGIToWIC( format, targetGUID );

    for( size_t index=0; index < nimages; ++index )
    {
        const Image& src = srcImages[ index ];
        if ( src.format != metadata.format )
        {
            result.Release();
            return E_FAIL;
        }

#ifdef _AMD64_
        if ( (src.width > 0xFFFFFFFF) || (src.height > 0xFFFFFFFF) )
            return E_FAIL;
#endif

        const Image& dst = dest[ index ];
        assert( dst.format == format );

        if ( src.width != dst.width || src.height != dst.height )
        {
            result.Release();
            return E_FAIL;
        }

        if ( wicpf )
        {
            if ( wictargetpf )
            {
                // Case 1: Both source and target formats are WIC supported
                hr = _ConvertUsingWIC( src, pfGUID, targetGUID, filter, threshold, dst );
            }
            else
            {
                // Case 2: Source format is supported by WIC, but not the target format
                hr = _ConvertFromWIC( src, pfGUID, filter, threshold, dst );
            }
        }
        else
        {
            if ( wictargetpf )
            {
                // Case 3: Source format is not supported by WIC, but does support the target format
                hr = _ConvertToWIC( src, targetGUID, filter, threshold, dst );
            }
            else
            {
                // Case 4: Both source and target format are not supported by WIC
                hr = _Convert( src, filter, dst );
            }
        }

        if ( FAILED(hr) )
        {
            result.Release();
            return hr;
        }
    }

    return S_OK;
}

HRESULT DirectX::Convert | ( | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DXGI_FORMAT | format,
 |  | _In_ DWORD | filter,
 |  | _In_ float | threshold,
 |  | _Out_ ScratchImage & | result
 | ) |  |
HRESULT DirectX::Convert | ( | _In_ const Image & | srcImage,
 |  | _In_ DXGI_FORMAT | format,
 |  | _In_ DWORD | filter,
 |  | _In_ float | threshold,
 |  | _Out_ ScratchImage & | image
 | ) |  |
HRESULT DirectX::CopyRectangle | ( | _In_ const Image & | srcImage,
 |  | _In_ const Rect & | srcRect,
 |  | _In_ const Image & | dstImage,
 |  | _In_ DWORD | filter,
 |  | _In_ size_t | xOffset,
 |  | _In_ size_t | yOffset
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::CopyRectangle | ( | const Image & | srcImage,
 |  | const Rect & | srcRect,
 |  | const Image & | dstImage,
 |  | DWORD | filter,
 |  | size_t | xOffset,
 |  | size_t | yOffset
 | ) |  |

Definition at line 91 of file DirectXTexMisc.cpp.

{
    if ( !srcImage.pixels || !dstImage.pixels )
        return E_POINTER;

    if ( IsCompressed( srcImage.format ) || IsCompressed( dstImage.format ) )
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );

    // Validate rectangle/offset
    if ( !srcRect.w || !srcRect.h || ( (srcRect.x + srcRect.w) > srcImage.width ) || ( (srcRect.y + srcRect.h) > srcImage.height ) )
    {
        return E_INVALIDARG;
    }

    if ( ( (xOffset + srcRect.w) > dstImage.width ) || ( (yOffset + srcRect.h) > dstImage.height ) )
    {
        return E_INVALIDARG;
    }

    // Compute source bytes-per-pixel
    size_t sbpp = BitsPerPixel( srcImage.format );
    if ( !sbpp )
        return E_FAIL;

    if ( sbpp < 8 )
    {
        // We don't support monochrome (DXGI_FORMAT_R1_UNORM)
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
    }

    const uint8_t* pEndSrc = srcImage.pixels + srcImage.rowPitch*srcImage.height;
    const uint8_t* pEndDest = dstImage.pixels + dstImage.rowPitch*dstImage.height;

    // Round to bytes
    sbpp = ( sbpp + 7 ) / 8;

    const uint8_t* pSrc = srcImage.pixels + (srcRect.y * srcImage.rowPitch) + (srcRect.x * sbpp);

    if ( srcImage.format == dstImage.format )
    {
        // Direct copy case (avoid intermediate conversions)
        uint8_t* pDest = dstImage.pixels + (yOffset * dstImage.rowPitch) + (xOffset * sbpp);
        const size_t copyW = srcRect.w * sbpp;
        for( size_t h=0; h < srcRect.h; ++h )
        {
            if ( ( (pSrc+copyW) > pEndSrc ) || (pDest > pEndDest) )
                return E_FAIL;

            memcpy_s( pDest, pEndDest - pDest, pSrc, copyW );

            pSrc += srcImage.rowPitch;
            pDest += dstImage.rowPitch;
        }

        return S_OK;
    }

    // Compute destination bytes-per-pixel (not the same format as source)
    size_t dbpp = BitsPerPixel( dstImage.format );
    if ( !dbpp )
        return E_FAIL;

    if ( dbpp < 8 )
    {
        // We don't support monochrome (DXGI_FORMAT_R1_UNORM)
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
    }

    // Round to bytes
    dbpp = ( dbpp + 7 ) / 8;

    uint8_t* pDest = dstImage.pixels + (yOffset * dstImage.rowPitch) + (xOffset * dbpp);

    ScopedAlignedArrayXMVECTOR scanline( reinterpret_cast<XMVECTOR*>( _aligned_malloc( (sizeof(XMVECTOR)*srcRect.w), 16 ) ) );
    if ( !scanline )
        return E_OUTOFMEMORY;

    const size_t copyS = srcRect.w * sbpp;
    const size_t copyD = srcRect.w * dbpp;

    for( size_t h=0; h < srcRect.h; ++h )
    {
        if ( ( (pSrc+copyS) > pEndSrc) || ((pDest+copyD) > pEndDest) )
            return E_FAIL;

        if ( !_LoadScanline( scanline.get(), srcRect.w, pSrc, copyS, srcImage.format ) )
            return E_FAIL;

        _ConvertScanline( scanline.get(), srcRect.w, dstImage.format, srcImage.format, filter );

        if ( !_StoreScanline( pDest, copyD, dstImage.format, scanline.get(), srcRect.w ) )
            return E_FAIL;

        pSrc += srcImage.rowPitch;
        pDest += dstImage.rowPitch;
    }

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::CreateShaderResourceView | ( | ID3D11Device * | pDevice,
 |  | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | ID3D11ShaderResourceView ** | ppSRV
 | ) |  |

Definition at line 523 of file DirectXTexD3D11.cpp.

{
    if ( !ppSRV )
        return E_INVALIDARG;

    ScopedObject<ID3D11Resource> resource;
    HRESULT hr = CreateTexture( pDevice, srcImages, nimages, metadata, &resource );
    if ( FAILED(hr) )
        return hr;

    assert( !resource.IsNull() );

    D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
    memset( &SRVDesc, 0, sizeof(SRVDesc) );
    SRVDesc.Format = metadata.format;

    switch ( metadata.dimension )
    {
    case TEX_DIMENSION_TEXTURE1D:
        if ( metadata.arraySize > 1 )
        {
            SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
            SRVDesc.Texture1DArray.MipLevels = static_cast<UINT>( metadata.mipLevels );
            SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>( metadata.arraySize );
        }
        else
        {
            SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
            SRVDesc.Texture1D.MipLevels = static_cast<UINT>( metadata.mipLevels );
        }
        break;

    case TEX_DIMENSION_TEXTURE2D:
        if ( metadata.miscFlags & TEX_MISC_TEXTURECUBE )
        {
            if (metadata.arraySize > 6)
            {
                assert( (metadata.arraySize % 6) == 0 );
                SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
                SRVDesc.TextureCubeArray.MipLevels = static_cast<UINT>( metadata.mipLevels );
                SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>( metadata.arraySize / 6 );
            }
            else
            {
                SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
                SRVDesc.TextureCube.MipLevels = static_cast<UINT>( metadata.mipLevels );
            }
        }
        else if ( metadata.arraySize > 1 )
        {
            SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
            SRVDesc.Texture2DArray.MipLevels = static_cast<UINT>( metadata.mipLevels );
            SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>( metadata.arraySize );
        }
        else
        {
            SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
            SRVDesc.Texture2D.MipLevels = static_cast<UINT>( metadata.mipLevels );
        }
        break;

    case TEX_DIMENSION_TEXTURE3D:
        assert( metadata.arraySize == 1 );
        SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
        SRVDesc.Texture3D.MipLevels = static_cast<UINT>( metadata.mipLevels );
        break;

    default:
        return E_FAIL;
    }

    hr = pDevice->CreateShaderResourceView( resource.Get(), &SRVDesc, ppSRV );
    if ( FAILED(hr) )
        return hr;

    assert( *ppSRV );

    return S_OK;
}

HRESULT DirectX::CreateShaderResourceView | ( | _In_ ID3D11Device * | pDevice,
 |  | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _Outptr_ ID3D11ShaderResourceView ** | ppSRV
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::CreateTexture | ( | ID3D11Device * | pDevice,
 |  | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | ID3D11Resource ** | ppResource
 | ) |  |

Definition at line 340 of file DirectXTexD3D11.cpp.

{
    if ( !pDevice || !srcImages || !nimages || !ppResource )
        return E_INVALIDARG;

    if ( !metadata.mipLevels || !metadata.arraySize )
        return E_INVALIDARG;

#ifdef _AMD64_
    if ( (metadata.width > 0xFFFFFFFF) || (metadata.height > 0xFFFFFFFF)
         || (metadata.mipLevels > 0xFFFFFFFF) || (metadata.arraySize > 0xFFFFFFFF) )
        return E_INVALIDARG;
#endif

    std::unique_ptr<D3D11_SUBRESOURCE_DATA[]> initData( new D3D11_SUBRESOURCE_DATA[ metadata.mipLevels * metadata.arraySize ] );
    if ( !initData )
        return E_OUTOFMEMORY;

    // Fill out subresource array
    if ( metadata.dimension == TEX_DIMENSION_TEXTURE3D )
    {
        //--- Volume case -------------------------------------------------------------
        if ( !metadata.depth )
            return E_INVALIDARG;

#ifdef _AMD64_
        if ( metadata.depth > 0xFFFFFFFF )
            return E_INVALIDARG;
#endif

        if ( metadata.arraySize > 1 )
            // Direct3D 11 doesn't support arrays of 3D textures
            return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );

        size_t depth = metadata.depth;

        size_t idx = 0;
        for( size_t level = 0; level < metadata.mipLevels; ++level )
        {
            size_t index = metadata.ComputeIndex( level, 0, 0 );
            if ( index >= nimages )
                return E_FAIL;

            const Image& img = srcImages[ index ];

            if ( img.format != metadata.format )
                return E_FAIL;

            if ( !img.pixels )
                return E_POINTER;

            // Verify pixels in image 1 .. (depth-1) are exactly image->slicePitch apart
            // For 3D textures, this relies on all slices of the same miplevel being continous in memory
            // (this is how ScratchImage lays them out), which is why we just give the 0th slice to Direct3D 11
            const uint8_t* pSlice = img.pixels + img.slicePitch;
            for( size_t slice = 1; slice < depth; ++slice )
            {
                size_t tindex = metadata.ComputeIndex( level, 0, slice );
                if ( tindex >= nimages )
                    return E_FAIL;

                const Image& timg = srcImages[ tindex ];

                if ( !timg.pixels )
                    return E_POINTER;

                if ( timg.pixels != pSlice
                     || timg.format != metadata.format
                     || timg.rowPitch != img.rowPitch
                     || timg.slicePitch != img.slicePitch )
                    return E_FAIL;

                pSlice = timg.pixels + img.slicePitch;
            }

            assert( idx < (metadata.mipLevels * metadata.arraySize) );

            initData[idx].pSysMem = img.pixels;
            initData[idx].SysMemPitch = static_cast<DWORD>( img.rowPitch );
            initData[idx].SysMemSlicePitch = static_cast<DWORD>( img.slicePitch );
            ++idx;

            if ( depth > 1 )
                depth >>= 1;
        }
    }
    else
    {
        //--- 1D or 2D texture case ---------------------------------------------------
        size_t idx = 0;
        for( size_t item = 0; item < metadata.arraySize; ++item )
        {
            for( size_t level = 0; level < metadata.mipLevels; ++level )
            {
                size_t index = metadata.ComputeIndex( level, item, 0 );
                if ( index >= nimages )
                    return E_FAIL;

                const Image& img = srcImages[ index ];

                if ( img.format != metadata.format )
                    return E_FAIL;

                if ( !img.pixels )
                    return E_POINTER;

                assert( idx < (metadata.mipLevels * metadata.arraySize) );

                initData[idx].pSysMem = img.pixels;
                initData[idx].SysMemPitch = static_cast<DWORD>( img.rowPitch );
                initData[idx].SysMemSlicePitch = static_cast<DWORD>( img.slicePitch );
                ++idx;
            }
        }
    }

    // Create texture using static initialization data
    HRESULT hr = E_FAIL;

    switch ( metadata.dimension )
    {
    case TEX_DIMENSION_TEXTURE1D:
        {
            D3D11_TEXTURE1D_DESC desc;
            desc.Width = static_cast<UINT>( metadata.width );
            desc.MipLevels = static_cast<UINT>( metadata.mipLevels );
            desc.ArraySize = static_cast<UINT>( metadata.arraySize );
            desc.Format = metadata.format;
            desc.Usage = D3D11_USAGE_DEFAULT;
            desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
            desc.CPUAccessFlags = 0;
            desc.MiscFlags = 0;

            hr = pDevice->CreateTexture1D( &desc, initData.get(), reinterpret_cast<ID3D11Texture1D**>(ppResource) );
        }
        break;

    case TEX_DIMENSION_TEXTURE2D:
        {
            D3D11_TEXTURE2D_DESC desc;
            desc.Width = static_cast<UINT>( metadata.width );
            desc.Height = static_cast<UINT>( metadata.height );
            desc.MipLevels = static_cast<UINT>( metadata.mipLevels );
            desc.ArraySize = static_cast<UINT>( metadata.arraySize );
            desc.Format = metadata.format;
            desc.SampleDesc.Count = 1;
            desc.SampleDesc.Quality = 0;
            desc.Usage = D3D11_USAGE_DEFAULT;
            desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
            desc.CPUAccessFlags = 0;
            desc.MiscFlags = (metadata.miscFlags & TEX_MISC_TEXTURECUBE) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;

            hr = pDevice->CreateTexture2D( &desc, initData.get(), reinterpret_cast<ID3D11Texture2D**>(ppResource) );
        }
        break;

    case TEX_DIMENSION_TEXTURE3D:
        {
            D3D11_TEXTURE3D_DESC desc;
            desc.Width = static_cast<UINT>( metadata.width );
            desc.Height = static_cast<UINT>( metadata.height );
            desc.Depth = static_cast<UINT>( metadata.depth );
            desc.MipLevels = static_cast<UINT>( metadata.mipLevels );
            desc.Format = metadata.format;
            desc.Usage = D3D11_USAGE_DEFAULT;
            desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
            desc.CPUAccessFlags = 0;
            desc.MiscFlags = 0;

            hr = pDevice->CreateTexture3D( &desc, initData.get(), reinterpret_cast<ID3D11Texture3D**>(ppResource) );
        }
        break;
    }

    return hr;
}

HRESULT DirectX::CreateTexture | ( | _In_ ID3D11Device * | pDevice,
 |  | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _Outptr_ ID3D11Resource ** | ppResource
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC1 | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 717 of file BC.cpp.

{
    const D3DX_BC1 *pBC1 = reinterpret_cast<const D3DX_BC1 *>(pBC);

void DirectX::D3DXDecodeBC1 | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(8) const uint8_t * | pBC
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC2 | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 789 of file BC.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(D3DX_BC2) == 16, "D3DX_BC2 should be 16 bytes" );

    const D3DX_BC2 *pBC2 = reinterpret_cast<const D3DX_BC2 *>(pBC);

    // RGB part
    DecodeBC1(pColor, &pBC2->bc1);

    // 4-bit alpha part
    DWORD dw = pBC2->bitmap[0];

    for(size_t i = 0; i < 8; ++i, dw >>= 4)
        pColor[i] = XMVectorSetW( pColor[i], (float) (dw & 0xf) * (1.0f / 15.0f) );

    dw = pBC2->bitmap[1];

    for(size_t i = 8; i < NUM_PIXELS_PER_BLOCK; ++i, dw >>= 4)

void DirectX::D3DXDecodeBC2 | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(16) const uint8_t * | pBC
 | ) |  |
void DirectX::D3DXDecodeBC3 | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(16) const uint8_t * | pBC
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC3 | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 889 of file BC.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(D3DX_BC3) == 16, "D3DX_BC3 should be 16 bytes" );

    const D3DX_BC3 *pBC3 = reinterpret_cast<const D3DX_BC3 *>(pBC);

    // RGB part
    DecodeBC1(pColor, &pBC3->bc1);

    // Adaptive 3-bit alpha part
    float fAlpha[8];

    fAlpha[0] = ((float) pBC3->alpha[0]) * (1.0f / 255.0f);
    fAlpha[1] = ((float) pBC3->alpha[1]) * (1.0f / 255.0f);

    if(pBC3->alpha[0] > pBC3->alpha[1])
    {
        for(size_t i = 1; i < 7; ++i)
            fAlpha[i + 1] = (fAlpha[0] * (7 - i) + fAlpha[1] * i) * (1.0f / 7.0f);
    }
    else
    {
        for(size_t i = 1; i < 5; ++i)
            fAlpha[i + 1] = (fAlpha[0] * (5 - i) + fAlpha[1] * i) * (1.0f / 5.0f);

        fAlpha[6] = 0.0f;
        fAlpha[7] = 1.0f;
    }

    DWORD dw = pBC3->bitmap[0] | (pBC3->bitmap[1] << 8) | (pBC3->bitmap[2] << 16);

    for(size_t i = 0; i < 8; ++i, dw >>= 3)
        pColor[i] = XMVectorSetW( pColor[i], fAlpha[dw & 0x7] );

    dw = pBC3->bitmap[3] | (pBC3->bitmap[4] << 8) | (pBC3->bitmap[5] << 16);

    for(size_t i = 8; i < NUM_PIXELS_PER_BLOCK; ++i, dw >>= 3)

void DirectX::D3DXDecodeBC4S | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(8) const uint8_t * | pBC
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC4S | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 383 of file BC4BC5.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(BC4_SNORM) == 8, "BC4_SNORM should be 8 bytes" );

    const BC4_SNORM * pBC4 = reinterpret_cast<const BC4_SNORM*>(pBC);

    for (size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        pColor[i] = XMVectorSet( pBC4->R(i), 0, 0, 1.0f);
    }
}

void DirectX::D3DXDecodeBC4U | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(8) const uint8_t * | pBC
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC4U | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 369 of file BC4BC5.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(BC4_UNORM) == 8, "BC4_UNORM should be 8 bytes" );

    const BC4_UNORM * pBC4 = reinterpret_cast<const BC4_UNORM*>(pBC);

    for (size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        pColor[i] = XMVectorSet( pBC4->R(i), 0, 0, 1.0f);
    }
}

void DirectX::D3DXDecodeBC5S | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(16) const uint8_t * | pBC
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC5S | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 458 of file BC4BC5.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(BC4_SNORM) == 8, "BC4_SNORM should be 8 bytes" );

    const BC4_SNORM * pBCR = reinterpret_cast<const BC4_SNORM*>(pBC);
    const BC4_SNORM * pBCG = reinterpret_cast<const BC4_SNORM*>(pBC+sizeof(BC4_SNORM));

    for (size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        pColor[i] = XMVectorSet(pBCR->R(i), pBCG->R(i), 0, 1.0f);
    }
}

void DirectX::D3DXDecodeBC5U | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(16) const uint8_t * | pBC
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC5U | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 443 of file BC4BC5.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(BC4_UNORM) == 8, "BC4_UNORM should be 8 bytes" );

    const BC4_UNORM * pBCR = reinterpret_cast<const BC4_UNORM*>(pBC);
    const BC4_UNORM * pBCG = reinterpret_cast<const BC4_UNORM*>(pBC+sizeof(BC4_UNORM));

    for (size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        pColor[i] = XMVectorSet(pBCR->R(i), pBCG->R(i), 0, 1.0f);
    }
}

void DirectX::D3DXDecodeBC6HS | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(16) const uint8_t * | pBC
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC6HS | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 2804 of file BC6HBC7.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(D3DX_BC6H) == 16, "D3DX_BC6H should be 16 bytes" );
    reinterpret_cast< const D3DX_BC6H* >( pBC )->Decode(true, reinterpret_cast<HDRColorA*>(pColor));
}

void DirectX::D3DXDecodeBC6HU | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(16) const uint8_t * | pBC
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXDecodeBC6HU | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 2796 of file BC6HBC7.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(D3DX_BC6H) == 16, "D3DX_BC6H should be 16 bytes" );
    reinterpret_cast< const D3DX_BC6H* >( pBC )->Decode(false, reinterpret_cast<HDRColorA*>(pColor));
}

_Use_decl_annotations_ void DirectX::D3DXDecodeBC7 | ( | XMVECTOR * | pColor,
 |  | const uint8_t * | pBC
 | ) |  |

Definition at line 2834 of file BC6HBC7.cpp.

{
    assert( pColor && pBC );
    static_assert( sizeof(D3DX_BC7) == 16, "D3DX_BC7 should be 16 bytes" );
    reinterpret_cast< const D3DX_BC7* >( pBC )->Decode(reinterpret_cast<HDRColorA*>(pColor));
}

void DirectX::D3DXDecodeBC7 | ( | _Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR * | pColor,
 |  | _In_reads_(16) const uint8_t * | pBC
 | ) |  |
void DirectX::D3DXEncodeBC1 | ( | _Out_writes_(8) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ float | alphaRef,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXEncodeBC1 | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | float | alphaRef,
 |  | DWORD | flags
 | ) |  |

Definition at line 724 of file BC.cpp.

{
    assert( pBC && pColor );

    HDRColorA Color[NUM_PIXELS_PER_BLOCK];

    if (flags & BC_FLAGS_DITHER_A)
    {
        float fError[NUM_PIXELS_PER_BLOCK];
        memset(fError, 0x00, NUM_PIXELS_PER_BLOCK * sizeof(float));

        for(size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
        {
            HDRColorA clr;
            XMStoreFloat4( reinterpret_cast<XMFLOAT4*>( &clr ), pColor[i] );

            float fAlph = clr.a + fError[i];

            Color[i].r = clr.r;
            Color[i].g = clr.g;
            Color[i].b = clr.b;
            Color[i].a = (float) static_cast<int32_t>(clr.a + fError[i] + 0.5f);

            float fDiff = fAlph - Color[i].a;

            if(3 != (i & 3))
            {
                assert( i < 15 );
                _Analysis_assume_( i < 15 );
                fError[i + 1] += fDiff * (7.0f / 16.0f);
            }

            if(i < 12)
            {
                if(i & 3)
                    fError[i + 3] += fDiff * (3.0f / 16.0f);

                fError[i + 4] += fDiff * (5.0f / 16.0f);

                if(3 != (i & 3))
                {
                    assert( i < 11 );
                    _Analysis_assume_( i < 11 );
                    fError[i + 5] += fDiff * (1.0f / 16.0f);
                }
            }
        }
    }
    else
    {
        for(size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
        {
            XMStoreFloat4( reinterpret_cast<XMFLOAT4*>( &Color[i] ), pColor[i] );
        }
    }

    D3DX_BC1 *pBC1 = reinterpret_cast<D3DX_BC1 *>(pBC);

_Use_decl_annotations_ void DirectX::D3DXEncodeBC2 | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 812 of file BC.cpp.

{
    assert( pBC && pColor );
    static_assert( sizeof(D3DX_BC2) == 16, "D3DX_BC2 should be 16 bytes" );

    HDRColorA Color[NUM_PIXELS_PER_BLOCK];
    for(size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        XMStoreFloat4( reinterpret_cast<XMFLOAT4*>( &Color[i] ), pColor[i] );
    }

    D3DX_BC2 *pBC2 = reinterpret_cast<D3DX_BC2 *>(pBC);

    // 4-bit alpha part.  Dithered using Floyd Stienberg error diffusion.
    pBC2->bitmap[0] = 0;
    pBC2->bitmap[1] = 0;

    float fError[NUM_PIXELS_PER_BLOCK];
    if (flags & BC_FLAGS_DITHER_A)
        memset(fError, 0x00, NUM_PIXELS_PER_BLOCK * sizeof(float));

    for(size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        float fAlph = Color[i].a;
        if (flags & BC_FLAGS_DITHER_A)
            fAlph += fError[i];

        uint32_t u = (uint32_t) static_cast<int32_t>(fAlph * 15.0f + 0.5f);

        pBC2->bitmap[i >> 3] >>= 4;
        pBC2->bitmap[i >> 3] |= (u << 28);

        if (flags & BC_FLAGS_DITHER_A)
        {
            float fDiff = fAlph - (float) u * (1.0f / 15.0f);

            if(3 != (i & 3))
            {
                assert( i < 15 );
                _Analysis_assume_( i < 15 );
                fError[i + 1] += fDiff * (7.0f / 16.0f);
            }

            if(i < 12)
            {
                if(i & 3)
                    fError[i + 3] += fDiff * (3.0f / 16.0f);

                fError[i + 4] += fDiff * (5.0f / 16.0f);

                if(3 != (i & 3))
                {
                    assert( i < 11 );
                    _Analysis_assume_( i < 11 );
                    fError[i + 5] += fDiff * (1.0f / 16.0f);
                }
            }
        }
    }

    // RGB part
#ifdef COLOR_WEIGHTS
    if(!pBC2->bitmap[0] && !pBC2->bitmap[1])
    {
        EncodeSolidBC1(pBC2->dxt1, Color);
        return;
    }
#endif // COLOR_WEIGHTS

void DirectX::D3DXEncodeBC2 | ( | _Out_writes_(16) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXEncodeBC3 | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 931 of file BC.cpp.

{
    assert( pBC && pColor );
    static_assert( sizeof(D3DX_BC3) == 16, "D3DX_BC3 should be 16 bytes" );

    HDRColorA Color[NUM_PIXELS_PER_BLOCK];
    for(size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        XMStoreFloat4( reinterpret_cast<XMFLOAT4*>( &Color[i] ), pColor[i] );
    }

    D3DX_BC3 *pBC3 = reinterpret_cast<D3DX_BC3 *>(pBC);

    // Quantize block to A8, using Floyd Stienberg error diffusion.  This
    // increases the chance that colors will map directly to the quantized
    // axis endpoints.
    float fAlpha[NUM_PIXELS_PER_BLOCK];
    float fError[NUM_PIXELS_PER_BLOCK];

    float fMinAlpha = Color[0].a;
    float fMaxAlpha = Color[0].a;

    if (flags & BC_FLAGS_DITHER_A)
        memset(fError, 0x00, NUM_PIXELS_PER_BLOCK * sizeof(float));

    for(size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        float fAlph = Color[i].a;
        if (flags & BC_FLAGS_DITHER_A)
            fAlph += fError[i];

        fAlpha[i] = static_cast<int32_t>(fAlph * 255.0f + 0.5f) * (1.0f / 255.0f);

        if(fAlpha[i] < fMinAlpha)
            fMinAlpha = fAlpha[i];
        else if(fAlpha[i] > fMaxAlpha)
            fMaxAlpha = fAlpha[i];

        if (flags & BC_FLAGS_DITHER_A)
        {
            float fDiff = fAlph - fAlpha[i];

            if(3 != (i & 3))
            {
                assert( i < 15 );
                _Analysis_assume_( i < 15 );
                fError[i + 1] += fDiff * (7.0f / 16.0f);
            }

            if(i < 12)
            {
                if(i & 3)
                    fError[i + 3] += fDiff * (3.0f / 16.0f);

                fError[i + 4] += fDiff * (5.0f / 16.0f);

                if(3 != (i & 3))
                {
                    assert( i < 11 );
                    _Analysis_assume_( i < 11 );
                    fError[i + 5] += fDiff * (1.0f / 16.0f);
                }
            }
        }
    }

#ifdef COLOR_WEIGHTS
    if(0.0f == fMaxAlpha)
    {
        EncodeSolidBC1(&pBC3->dxt1, Color);
        pBC3->alpha[0] = 0x00;
        pBC3->alpha[1] = 0x00;
        memset(pBC3->bitmap, 0x00, 6);
    }
#endif

    // RGB part
    EncodeBC1(&pBC3->bc1, Color, false, 0.f, flags);

    // Alpha part
    if(1.0f == fMinAlpha)
    {
        pBC3->alpha[0] = 0xff;
        pBC3->alpha[1] = 0xff;
        memset(pBC3->bitmap, 0x00, 6);
        return;
    }

    // Optimize and Quantize Min and Max values
    size_t uSteps = ((0.0f == fMinAlpha) || (1.0f == fMaxAlpha)) ? 6 : 8;

    float fAlphaA, fAlphaB;
    OptimizeAlpha<false>(&fAlphaA, &fAlphaB, fAlpha, uSteps);

    uint8_t bAlphaA = (uint8_t) static_cast<int32_t>(fAlphaA * 255.0f + 0.5f);
    uint8_t bAlphaB = (uint8_t) static_cast<int32_t>(fAlphaB * 255.0f + 0.5f);

    fAlphaA = (float) bAlphaA * (1.0f / 255.0f);
    fAlphaB = (float) bAlphaB * (1.0f / 255.0f);

    // Setup block
    if((8 == uSteps) && (bAlphaA == bAlphaB))
    {
        pBC3->alpha[0] = bAlphaA;
        pBC3->alpha[1] = bAlphaB;
        memset(pBC3->bitmap, 0x00, 6);
        return;
    }

    static const size_t pSteps6[] = { 0, 2, 3, 4, 5, 1 };
    static const size_t pSteps8[] = { 0, 2, 3, 4, 5, 6, 7, 1 };

    const size_t *pSteps;
    float fStep[8];

    if(6 == uSteps)
    {
        pBC3->alpha[0] = bAlphaA;
        pBC3->alpha[1] = bAlphaB;

        fStep[0] = fAlphaA;
        fStep[1] = fAlphaB;

        for(size_t i = 1; i < 5; ++i)
            fStep[i + 1] = (fStep[0] * (5 - i) + fStep[1] * i) * (1.0f / 5.0f);

        fStep[6] = 0.0f;
        fStep[7] = 1.0f;

        pSteps = pSteps6;
    }
    else
    {
        pBC3->alpha[0] = bAlphaB;
        pBC3->alpha[1] = bAlphaA;

        fStep[0] = fAlphaB;
        fStep[1] = fAlphaA;

        for(size_t i = 1; i < 7; ++i)
            fStep[i + 1] = (fStep[0] * (7 - i) + fStep[1] * i) * (1.0f / 7.0f);

        pSteps = pSteps8;
    }

    // Encode alpha bitmap
    float fSteps = (float) (uSteps - 1);
    float fScale = (fStep[0] != fStep[1]) ? (fSteps / (fStep[1] - fStep[0])) : 0.0f;

    if (flags & BC_FLAGS_DITHER_A)
        memset(fError, 0x00, NUM_PIXELS_PER_BLOCK * sizeof(float));

    for(size_t iSet = 0; iSet < 2; iSet++)
    {
        uint32_t dw = 0;

        size_t iMin = iSet * 8;
        size_t iLim = iMin + 8;

        for(size_t i = iMin; i < iLim; ++i)
        {
            float fAlph = Color[i].a;
            if (flags & BC_FLAGS_DITHER_A)
                fAlph += fError[i];
            float fDot = (fAlph - fStep[0]) * fScale;

            uint32_t iStep;
            if(fDot <= 0.0f)
                iStep = ((6 == uSteps) && (fAlph <= fStep[0] * 0.5f)) ? 6 : 0;
            else if(fDot >= fSteps)
                iStep = ((6 == uSteps) && (fAlph >= (fStep[1] + 1.0f) * 0.5f)) ? 7 : 1;
            else
                iStep = static_cast<uint32_t>( pSteps[static_cast<size_t>(fDot + 0.5f)] );

            dw = (iStep << 21) | (dw >> 3);

            if (flags & BC_FLAGS_DITHER_A)
            {
                float fDiff = (fAlph - fStep[iStep]);

                if(3 != (i & 3))
                    fError[i + 1] += fDiff * (7.0f / 16.0f);

                if(i < 12)
                {
                    if(i & 3)
                        fError[i + 3] += fDiff * (3.0f / 16.0f);

                    fError[i + 4] += fDiff * (5.0f / 16.0f);

                    if(3 != (i & 3))
                        fError[i + 5] += fDiff * (1.0f / 16.0f);
                }
            }
        }

        pBC3->bitmap[0 + iSet * 3] = ((uint8_t *) &dw)[0];
        pBC3->bitmap[1 + iSet * 3] = ((uint8_t *) &dw)[1];
        pBC3->bitmap[2 + iSet * 3] = ((uint8_t *) &dw)[2];

void DirectX::D3DXEncodeBC3 | ( | _Out_writes_(16) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
void DirectX::D3DXEncodeBC4S | ( | _Out_writes_(8) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXEncodeBC4S | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 418 of file BC4BC5.cpp.

{
    UNREFERENCED_PARAMETER( flags );

    assert( pBC && pColor );
    static_assert( sizeof(BC4_SNORM) == 8, "BC4_SNORM should be 8 bytes" );

    memset(pBC, 0, sizeof(BC4_UNORM));
    BC4_SNORM * pBC4 = reinterpret_cast<BC4_SNORM*>(pBC);
    float theTexelsU[NUM_PIXELS_PER_BLOCK];

    for (size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        theTexelsU[i] = XMVectorGetX( pColor[i] );
    }

    FindEndPointsBC4S(theTexelsU, pBC4->red_0, pBC4->red_1);
    FindClosestSNORM(pBC4, theTexelsU);
}

_Use_decl_annotations_ void DirectX::D3DXEncodeBC4U | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 397 of file BC4BC5.cpp.

{
    UNREFERENCED_PARAMETER( flags );

    assert( pBC && pColor );
    static_assert( sizeof(BC4_UNORM) == 8, "BC4_UNORM should be 8 bytes" );

    memset(pBC, 0, sizeof(BC4_UNORM));
    BC4_UNORM * pBC4 = reinterpret_cast<BC4_UNORM*>(pBC);
    float theTexelsU[NUM_PIXELS_PER_BLOCK];

    for (size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        theTexelsU[i] = XMVectorGetX( pColor[i] );
    }

    FindEndPointsBC4U(theTexelsU, pBC4->red_0, pBC4->red_1);
    FindClosestUNORM(pBC4, theTexelsU);
}

void DirectX::D3DXEncodeBC4U | ( | _Out_writes_(8) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
void DirectX::D3DXEncodeBC5S | ( | _Out_writes_(16) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXEncodeBC5S | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 507 of file BC4BC5.cpp.

{
    UNREFERENCED_PARAMETER( flags );

    assert( pBC && pColor );
    static_assert( sizeof(BC4_SNORM) == 8, "BC4_SNORM should be 8 bytes" );

    memset(pBC, 0, sizeof(BC4_UNORM)*2);
    BC4_SNORM * pBCR = reinterpret_cast<BC4_SNORM*>(pBC);
    BC4_SNORM * pBCG = reinterpret_cast<BC4_SNORM*>(pBC+sizeof(BC4_SNORM));
    float theTexelsU[NUM_PIXELS_PER_BLOCK];
    float theTexelsV[NUM_PIXELS_PER_BLOCK];

    for (size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        XMFLOAT4A clr;
        XMStoreFloat4A( &clr, pColor[i] );
        theTexelsU[i] = clr.x;
        theTexelsV[i] = clr.y;
    }

    FindEndPointsBC5S(
        theTexelsU,
        theTexelsV,
        pBCR->red_0,
        pBCR->red_1,
        pBCG->red_0,
        pBCG->red_1);

    FindClosestSNORM(pBCR, theTexelsU);
    FindClosestSNORM(pBCG, theTexelsV);
}

_Use_decl_annotations_ void DirectX::D3DXEncodeBC5U | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 473 of file BC4BC5.cpp.

{
    UNREFERENCED_PARAMETER( flags );

    assert( pBC && pColor );
    static_assert( sizeof(BC4_UNORM) == 8, "BC4_UNORM should be 8 bytes" );

    memset(pBC, 0, sizeof(BC4_UNORM)*2);
    BC4_UNORM * pBCR = reinterpret_cast<BC4_UNORM*>(pBC);
    BC4_UNORM * pBCG = reinterpret_cast<BC4_UNORM*>(pBC+sizeof(BC4_UNORM));
    float theTexelsU[NUM_PIXELS_PER_BLOCK];
    float theTexelsV[NUM_PIXELS_PER_BLOCK];

    for (size_t i = 0; i < NUM_PIXELS_PER_BLOCK; ++i)
    {
        XMFLOAT4A clr;
        XMStoreFloat4A( &clr, pColor[i] );
        theTexelsU[i] = clr.x;
        theTexelsV[i] = clr.y;
    }

    FindEndPointsBC5U(
        theTexelsU,
        theTexelsV,
        pBCR->red_0,
        pBCR->red_1,
        pBCG->red_0,
        pBCG->red_1);

    FindClosestUNORM(pBCR, theTexelsU);
    FindClosestUNORM(pBCG, theTexelsV);
}

void DirectX::D3DXEncodeBC5U | ( | _Out_writes_(16) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXEncodeBC6HS | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 2821 of file BC6HBC7.cpp.

{
    UNREFERENCED_PARAMETER(flags);
    assert( pBC && pColor );
    static_assert( sizeof(D3DX_BC6H) == 16, "D3DX_BC6H should be 16 bytes" );
    reinterpret_cast< D3DX_BC6H* >( pBC )->Encode(true, reinterpret_cast<const HDRColorA*>(pColor));
}

void DirectX::D3DXEncodeBC6HS | ( | _Out_writes_(16) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXEncodeBC6HU | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 2812 of file BC6HBC7.cpp.

{
    UNREFERENCED_PARAMETER(flags);
    assert( pBC && pColor );
    static_assert( sizeof(D3DX_BC6H) == 16, "D3DX_BC6H should be 16 bytes" );
    reinterpret_cast< D3DX_BC6H* >( pBC )->Encode(false, reinterpret_cast<const HDRColorA*>(pColor));
}

void DirectX::D3DXEncodeBC6HU | ( | _Out_writes_(16) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
void DirectX::D3DXEncodeBC7 | ( | _Out_writes_(16) uint8_t * | pBC,
 |  | _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR * | pColor,
 |  | _In_ DWORD | flags
 | ) |  |
_Use_decl_annotations_ void DirectX::D3DXEncodeBC7 | ( | uint8_t * | pBC,
 |  | const XMVECTOR * | pColor,
 |  | DWORD | flags
 | ) |  |

Definition at line 2842 of file BC6HBC7.cpp.

{
    UNREFERENCED_PARAMETER(flags);
    assert( pBC && pColor );
    static_assert( sizeof(D3DX_BC7) == 16, "D3DX_BC7 should be 16 bytes" );
    reinterpret_cast< D3DX_BC7* >( pBC )->Encode(reinterpret_cast<const HDRColorA*>(pColor));
}

_Use_decl_annotations_ HRESULT DirectX::Decompress | ( | const Image & | cImage,
 |  | DXGI_FORMAT | format,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 587 of file DirectXTexCompress.cpp.

{
    if ( IsCompressed(format) || IsTypeless(format) )
        return E_INVALIDARG;

    if ( format == DXGI_FORMAT_UNKNOWN )
    {
        // Pick a default decompressed format based on BC input format
        format = _DefaultDecompress( cImage.format );
        if ( format == DXGI_FORMAT_UNKNOWN )
        {
            // Input is not a compressed format
            return E_INVALIDARG;
        }
    }
    else if ( !IsCompressed(cImage.format) || !IsValid(format) )
        return E_INVALIDARG;

    // Create decompressed image
    HRESULT hr = image.Initialize2D( format, cImage.width, cImage.height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    const Image *img = image.GetImage( 0, 0, 0 );
    if ( !img )
    {
        image.Release();
        return E_POINTER;
    }

    // Decompress single image
    hr = _DecompressBC( cImage, *img );
    if ( FAILED(hr) )
        image.Release();

_Use_decl_annotations_ HRESULT DirectX::Decompress | ( | const Image * | cImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | DXGI_FORMAT | format,
 |  | ScratchImage & | images
 | ) |  |

Definition at line 626 of file DirectXTexCompress.cpp.

{
    if ( !cImages || !nimages )
        return E_INVALIDARG;

    if ( IsCompressed(format) || IsTypeless(format) )
        return E_INVALIDARG;

    if ( format == DXGI_FORMAT_UNKNOWN )
    {
        // Pick a default decompressed format based on BC input format
        format = _DefaultDecompress( cImages[0].format );
        if ( format == DXGI_FORMAT_UNKNOWN )
        {
            // Input is not a compressed format
            return E_FAIL;
        }
    }
    else if ( !IsValid(format) )
        return E_INVALIDARG;

    images.Release();

    TexMetadata mdata2 = metadata;
    mdata2.format = format;
    HRESULT hr = images.Initialize( mdata2 );
    if ( FAILED(hr) )
        return hr;

    if ( nimages != images.GetImageCount() )
    {
        images.Release();
        return E_FAIL;
    }

    const Image* dest = images.GetImages();
    if ( !dest )
    {
        images.Release();
        return E_POINTER;
    }

    for( size_t index=0; index < nimages; ++index )
    {
        assert( dest[ index ].format == format );

        const Image& src = cImages[ index ];
        if ( !IsCompressed( src.format ) )
        {
            images.Release();
            return E_FAIL;
        }

        if ( src.width != dest[ index ].width || src.height != dest[ index ].height )
        {
            images.Release();
            return E_FAIL;
        }

        hr = _DecompressBC( src, dest[ index ] );
        if ( FAILED(hr) )
        {
            images.Release();
            return hr;
        }
    }

HRESULT DirectX::Decompress | ( | _In_ const Image & | cImage,
 |  | _In_ DXGI_FORMAT | format,
 |  | _Out_ ScratchImage & | image
 | ) |  |
HRESULT DirectX::Decompress | ( | _In_reads_(nimages) const Image * | cImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DXGI_FORMAT | format,
 |  | _Out_ ScratchImage & | images
 | ) |  |
HRESULT DirectX::FlipRotate | ( | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DWORD | flags,
 |  | _Out_ ScratchImage & | result
 | ) |  |
HRESULT DirectX::FlipRotate | ( | _In_ const Image & | srcImage,
 |  | _In_ DWORD | flags,
 |  | _Out_ ScratchImage & | image
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::FlipRotate | ( | const Image & | srcImage,
 |  | DWORD | flags,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 128 of file DirectXTexFlipRotate.cpp.

{
    if ( !srcImage.pixels )
        return E_POINTER;

    if ( !flags )
        return E_INVALIDARG;

#ifdef _AMD64_
    if ( (srcImage.width > 0xFFFFFFFF) || (srcImage.height > 0xFFFFFFFF) )
        return E_INVALIDARG;
#endif

    if ( IsCompressed( srcImage.format ) )
    {
        // We don't support flip/rotate operations on compressed images
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
    }

    static_assert( TEX_FR_ROTATE0 == WICBitmapTransformRotate0, "TEX_FR_ROTATE0 no longer matches WIC" );
    static_assert( TEX_FR_ROTATE90 == WICBitmapTransformRotate90, "TEX_FR_ROTATE90 no longer matches WIC" );
    static_assert( TEX_FR_ROTATE180 == WICBitmapTransformRotate180, "TEX_FR_ROTATE180 no longer matches WIC" );
    static_assert( TEX_FR_ROTATE270 == WICBitmapTransformRotate270, "TEX_FR_ROTATE270 no longer matches WIC" );
    static_assert( TEX_FR_FLIP_HORIZONTAL == WICBitmapTransformFlipHorizontal, "TEX_FR_FLIP_HORIZONTAL no longer matches WIC" );
    static_assert( TEX_FR_FLIP_VERTICAL == WICBitmapTransformFlipVertical, "TEX_FR_FLIP_VERTICAL no longer matches WIC" );

    // Only supports 90, 180, 270, or no rotation flags... not a combination of rotation flags
    switch ( flags & (TEX_FR_ROTATE90|TEX_FR_ROTATE180|TEX_FR_ROTATE270) )
    {
    case 0:
    case TEX_FR_ROTATE90:
    case TEX_FR_ROTATE180:
    case TEX_FR_ROTATE270:
        break;

    default:
        return E_INVALIDARG;
    }

    size_t nwidth = srcImage.width;
    size_t nheight = srcImage.height;

    if (flags & (TEX_FR_ROTATE90|TEX_FR_ROTATE270))
    {
        nwidth = srcImage.height;
        nheight = srcImage.width;
    }

    HRESULT hr = image.Initialize2D( srcImage.format, nwidth, nheight, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    const Image *rimage = image.GetImage( 0, 0, 0 );
    if ( !rimage )
        return E_POINTER;

    WICPixelFormatGUID pfGUID;
    if ( _DXGIToWIC( srcImage.format, pfGUID ) )
    {
        // Case 1: Source format is supported by Windows Imaging Component
        hr = _PerformFlipRotateUsingWIC( srcImage, flags, pfGUID, *rimage );
    }
    else
    {
        // Case 2: Source format is not supported by WIC, so we have to convert, flip/rotate, and convert back
        hr = _PerformFlipRotateViaF32( srcImage, flags, *rimage );
    }

    if ( FAILED(hr) )
    {
        image.Release();
        return hr;
    }

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::FlipRotate | ( | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | DWORD | flags,
 |  | ScratchImage & | result
 | ) |  |

Definition at line 210 of file DirectXTexFlipRotate.cpp.

{
    if ( !srcImages || !nimages )
        return E_INVALIDARG;

    if ( IsCompressed( metadata.format ) )
    {
        // We don't support flip/rotate operations on compressed images
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
    }

    static_assert( TEX_FR_ROTATE0 == WICBitmapTransformRotate0, "TEX_FR_ROTATE0 no longer matches WIC" );
    static_assert( TEX_FR_ROTATE90 == WICBitmapTransformRotate90, "TEX_FR_ROTATE90 no longer matches WIC" );
    static_assert( TEX_FR_ROTATE180 == WICBitmapTransformRotate180, "TEX_FR_ROTATE180 no longer matches WIC" );
    static_assert( TEX_FR_ROTATE270 == WICBitmapTransformRotate270, "TEX_FR_ROTATE270 no longer matches WIC" );
    static_assert( TEX_FR_FLIP_HORIZONTAL == WICBitmapTransformFlipHorizontal, "TEX_FR_FLIP_HORIZONTAL no longer matches WIC" );
    static_assert( TEX_FR_FLIP_VERTICAL == WICBitmapTransformFlipVertical, "TEX_FR_FLIP_VERTICAL no longer matches WIC" );

    // Only supports 90, 180, 270, or no rotation flags... not a combination of rotation flags
    switch ( flags & (TEX_FR_ROTATE90|TEX_FR_ROTATE180|TEX_FR_ROTATE270) )
    {
    case 0:
    case TEX_FR_ROTATE90:
    case TEX_FR_ROTATE180:
    case TEX_FR_ROTATE270:
        break;

    default:
        return E_INVALIDARG;
    }

    TexMetadata mdata2 = metadata;

    bool flipwh = false;
    if (flags & (TEX_FR_ROTATE90|TEX_FR_ROTATE270))
    {
        flipwh = true;
        mdata2.width = metadata.height;
        mdata2.height = metadata.width;
    }

    HRESULT hr = result.Initialize( mdata2 );
    if ( FAILED(hr) )
        return hr;

    if ( nimages != result.GetImageCount() )
    {
        result.Release();
        return E_FAIL;
    }

    const Image* dest = result.GetImages();
    if ( !dest )
    {
        result.Release();
        return E_POINTER;
    }

    WICPixelFormatGUID pfGUID;
    bool wicpf = _DXGIToWIC( metadata.format, pfGUID );

    for( size_t index=0; index < nimages; ++index )
    {
        const Image& src = srcImages[ index ];
        if ( src.format != metadata.format )
        {
            result.Release();
            return E_FAIL;
        }

#ifdef _AMD64_
        if ( (src.width > 0xFFFFFFFF) || (src.height > 0xFFFFFFFF) )
            return E_FAIL;
#endif

        const Image& dst = dest[ index ];
        assert( dst.format == metadata.format );

        if ( flipwh )
        {
            if ( src.width != dst.height || src.height != dst.width )
            {
                result.Release();
                return E_FAIL;
            }
        }
        else
        {
            if ( src.width != dst.width || src.height != dst.height )
            {
                result.Release();
                return E_FAIL;
            }
        }

        if (wicpf)
        {
            // Case 1: Source format is supported by Windows Imaging Component
            hr = _PerformFlipRotateUsingWIC( src, flags, pfGUID, dst );
        }
        else
        {
            // Case 2: Source format is not supported by WIC, so we have to convert, flip/rotate, and convert back
            hr = _PerformFlipRotateViaF32( src, flags, dst );
        }

        if ( FAILED(hr) )
        {
            result.Release();
            return hr;
        }
    }

    return S_OK;
}

HRESULT DirectX::GenerateMipMaps | ( | _In_ const Image & | baseImage,
 |  | _In_ DWORD | filter,
 |  | _In_ size_t | levels,
 |  | _Inout_ ScratchImage & | mipChain,
 |  | _In_ bool | allow1D = false
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::GenerateMipMaps | ( | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | DWORD | filter,
 |  | size_t | levels,
 |  | ScratchImage & | mipChain
 | ) |  |

Definition at line 905 of file DirectXTexMipmaps.cpp.

{
    if ( !srcImages || !nimages || !IsValid(metadata.format) )
        return E_INVALIDARG;

    if ( metadata.dimension == TEX_DIMENSION_TEXTURE3D
         || IsCompressed( metadata.format ) || IsVideo( metadata.format ) )
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );

    if ( !_CalculateMipLevels(metadata.width, metadata.height, levels) )
        return E_INVALIDARG;

    static_assert( TEX_FILTER_POINT == 0x100000, "TEX_FILTER_ flag values don't match TEX_FILTER_MASK" );
    switch(filter & TEX_FILTER_MASK)
    {
    case 0:
    case TEX_FILTER_POINT:
    case TEX_FILTER_FANT: // Equivalent to Box filter
    case TEX_FILTER_LINEAR:
    case TEX_FILTER_CUBIC:
        {
            WICPixelFormatGUID pfGUID;
            if ( _DXGIToWIC( metadata.format, pfGUID ) )
            {
                // Case 1: Base image format is supported by Windows Imaging Component
                TexMetadata mdata2 = metadata;
                mdata2.mipLevels = levels;
                HRESULT hr = mipChain.Initialize( mdata2 );
                if ( FAILED(hr) )
                    return hr;

                for( size_t item = 0; item < metadata.arraySize; ++item )
                {
                    size_t index = metadata.ComputeIndex( 0, item, 0 );
                    if ( index >= nimages )
                    {
                        mipChain.Release();
                        return E_FAIL;
                    }

                    const Image& baseImage = srcImages[ index ];

                    hr = _GenerateMipMapsUsingWIC( baseImage, filter, levels, pfGUID, mipChain, item );
                    if ( FAILED(hr) )
                    {
                        mipChain.Release();
                        return hr;
                    }
                }

                return S_OK;
            }
            else
            {
                // Case 2: Base image format is not supported by WIC, so we have to convert, generate, and convert back
                assert( metadata.format != DXGI_FORMAT_R32G32B32A32_FLOAT );

                TexMetadata mdata2 = metadata;
                mdata2.mipLevels = levels;
                mdata2.format = DXGI_FORMAT_R32G32B32A32_FLOAT;
                ScratchImage tMipChain;
                HRESULT hr = tMipChain.Initialize( mdata2 );
                if ( FAILED(hr) )
                    return hr;

                for( size_t item = 0; item < metadata.arraySize; ++item )
                {
                    size_t index = metadata.ComputeIndex( 0, item, 0 );
                    if ( index >= nimages )
                        return E_FAIL;

                    const Image& baseImage = srcImages[ index ];

                    ScratchImage temp;
                    hr = _ConvertToR32G32B32A32( baseImage, temp );
                    if ( FAILED(hr) )
                        return hr;

                    const Image *timg = temp.GetImage( 0, 0, 0 );
                    if ( !timg )
                        return E_POINTER;

                    hr = _GenerateMipMapsUsingWIC( *timg, filter, levels, GUID_WICPixelFormat128bppRGBAFloat, tMipChain, item );
                    if ( FAILED(hr) )
                        return hr;
                }

                return _ConvertFromR32G32B32A32( tMipChain.GetImages(), tMipChain.GetImageCount(), tMipChain.GetMetadata(), metadata.format, mipChain );
            }
        }
        break;

    default:
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );;
    }
}

_Use_decl_annotations_ HRESULT DirectX::GenerateMipMaps | ( | const Image & | baseImage,
 |  | DWORD | filter,
 |  | size_t | levels,
 |  | ScratchImage & | mipChain,
 |  | bool | allow1D
 | ) |  |

Definition at line 837 of file DirectXTexMipmaps.cpp.

{
    if ( !IsValid( baseImage.format ) )
        return E_INVALIDARG;

    if ( !baseImage.pixels )
        return E_POINTER;

    if ( !_CalculateMipLevels(baseImage.width, baseImage.height, levels) )
        return E_INVALIDARG;

    if ( IsCompressed( baseImage.format ) || IsVideo( baseImage.format ) )
    {
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
    }

    static_assert( TEX_FILTER_POINT == 0x100000, "TEX_FILTER_ flag values don't match TEX_FILTER_MASK" );
    switch(filter & TEX_FILTER_MASK)
    {
    case 0:
    case TEX_FILTER_POINT:
    case TEX_FILTER_FANT: // Equivalent to Box filter
    case TEX_FILTER_LINEAR:
    case TEX_FILTER_CUBIC:
        {
            WICPixelFormatGUID pfGUID;
            if ( _DXGIToWIC( baseImage.format, pfGUID ) )
            {
                // Case 1: Base image format is supported by Windows Imaging Component
                HRESULT hr = (baseImage.height > 1 || !allow1D)
                             ? mipChain.Initialize2D( baseImage.format, baseImage.width, baseImage.height, 1, levels )
                             : mipChain.Initialize1D( baseImage.format, baseImage.width, 1, levels );
                if ( FAILED(hr) )
                    return hr;

                return _GenerateMipMapsUsingWIC( baseImage, filter, levels, pfGUID, mipChain, 0 );
            }
            else
            {
                // Case 2: Base image format is not supported by WIC, so we have to convert, generate, and convert back
                assert( baseImage.format != DXGI_FORMAT_R32G32B32A32_FLOAT );
                ScratchImage temp;
                HRESULT hr = _ConvertToR32G32B32A32( baseImage, temp );
                if ( FAILED(hr) )
                    return hr;

                const Image *timg = temp.GetImage( 0, 0, 0 );
                if ( !timg )
                    return E_POINTER;

                ScratchImage tMipChain;
                hr = _GenerateMipMapsUsingWIC( *timg, filter, levels, GUID_WICPixelFormat128bppRGBAFloat, tMipChain, 0 );
                if ( FAILED(hr) )
                    return hr;

                temp.Release();

                return _ConvertFromR32G32B32A32( tMipChain.GetImages(), tMipChain.GetImageCount(), tMipChain.GetMetadata(), baseImage.format, mipChain );
            }
        }
        break;

    default:
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
    }
}

HRESULT DirectX::GenerateMipMaps | ( | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DWORD | filter,
 |  | _In_ size_t | levels,
 |  | _Inout_ ScratchImage & | mipChain
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::GenerateMipMaps3D | ( | const Image * | baseImages,
 |  | size_t | depth,
 |  | DWORD | filter,
 |  | size_t | levels,
 |  | ScratchImage & | mipChain
 | ) |  |

Definition at line 1008 of file DirectXTexMipmaps.cpp.

{
    if ( !baseImages || !depth )
        return E_INVALIDARG;

    DXGI_FORMAT format = baseImages[0].format;
    size_t width = baseImages[0].width;
    size_t height = baseImages[0].height;

    if ( !ispow2(width) || !ispow2(height) || !ispow2(depth) )
        return E_INVALIDARG;

    if ( !_CalculateMipLevels3D(width, height, depth, levels) )
        return E_INVALIDARG;

    for( size_t slice=0; slice < depth; ++slice )
    {
        if ( !baseImages[slice].pixels )
            return E_POINTER;

        if ( baseImages[slice].format != format || baseImages[slice].width != width || baseImages[slice].height != height )
        {
            // All base images must be the same format, width, and height
            return E_FAIL;
        }
    }

    if ( IsCompressed( format ) )
    {
        // We don't support generating mipmaps from compressed images, as those should be generated before compression
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
    }

    HRESULT hr;

    static_assert( TEX_FILTER_POINT == 0x100000, "TEX_FILTER_ flag values don't match TEX_FILTER_MASK" );
    switch( filter & TEX_FILTER_MASK )
    {
    case 0:
    case TEX_FILTER_FANT:
        hr = _Setup3DMips( baseImages, depth, levels, mipChain );
        if ( FAILED(hr) )
            return hr;

        // For decimation, Fant is equivalent to a Box filter
        hr = _Generate3DMipsBoxFilter( depth, levels, mipChain );
        if ( FAILED(hr) )
            mipChain.Release();
        return hr;

    case WIC_FLAGS_FILTER_POINT:
        hr = _Setup3DMips( baseImages, depth, levels, mipChain );
        if ( FAILED(hr) )
            return hr;

        hr = _Generate3DMipsPointFilter( depth, levels, mipChain );
        if ( FAILED(hr) )
            mipChain.Release();
        return hr;

    case WIC_FLAGS_FILTER_LINEAR:
        // Need to implement a 3D bi-linear filter (2x2x2)
        return E_NOTIMPL;

    case WIC_FLAGS_FILTER_CUBIC:
        // Need to implement a 3D bi-cubic filter (3x3x3)
        return E_NOTIMPL;

    default:
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );;
    }
}

_Use_decl_annotations_ HRESULT DirectX::GenerateMipMaps3D | ( | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | DWORD | filter,
 |  | size_t | levels,
 |  | ScratchImage & | mipChain
 | ) |  |

Definition at line 1082 of file DirectXTexMipmaps.cpp.

{
    if ( !srcImages || !nimages || !IsValid(metadata.format)
         || !ispow2(metadata.width) || !ispow2(metadata.height) || !ispow2(metadata.depth) )
        return E_INVALIDARG;

    if ( metadata.dimension != TEX_DIMENSION_TEXTURE3D
         || IsCompressed( metadata.format ) || IsVideo( metadata.format ) )
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );

    if ( !_CalculateMipLevels3D(metadata.width, metadata.height, metadata.depth, levels) )
        return E_INVALIDARG;

    std::vector<const Image> baseImages;
    baseImages.reserve( metadata.depth );
    for( size_t slice=0; slice < metadata.depth; ++slice )
    {
        size_t index = metadata.ComputeIndex( 0, 0, slice );
        if ( index >= nimages )
            return E_FAIL;

        const Image& src = srcImages[ index ];
        if ( !src.pixels )
            return E_POINTER;

        if ( src.format != metadata.format || src.width != metadata.width || src.height != metadata.height )
        {
            // All base images must be the same format, width, and height
            return E_FAIL;
        }

        baseImages.push_back( src );
    }

    assert( baseImages.size() == metadata.depth );

    HRESULT hr;

    static_assert( TEX_FILTER_POINT == 0x100000, "TEX_FILTER_ flag values don't match TEX_FILTER_MASK" );
    switch( filter & TEX_FILTER_MASK )
    {
    case 0:
    case TEX_FILTER_FANT:
        hr = _Setup3DMips( &baseImages[0], metadata.depth, levels, mipChain );
        if ( FAILED(hr) )
            return hr;

        // For decimation, Fant is equivalent to a Box filter
        hr = _Generate3DMipsBoxFilter( metadata.depth, levels, mipChain );
        if ( FAILED(hr) )
            mipChain.Release();
        return hr;

    case WIC_FLAGS_FILTER_POINT:
        hr = _Setup3DMips( &baseImages[0], metadata.depth, levels, mipChain );
        if ( FAILED(hr) )
            return hr;

        hr = _Generate3DMipsPointFilter( metadata.depth, levels, mipChain );
        if ( FAILED(hr) )
            mipChain.Release();
        return hr;

    case WIC_FLAGS_FILTER_LINEAR:
        // Need to implement a 3D bi-linear filter (2x2x2)
        return E_NOTIMPL;

    case WIC_FLAGS_FILTER_CUBIC:
        // Need to implement a 3D bi-cubic filter (3x3x3)
        return E_NOTIMPL;

    default:
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );;
    }
}

HRESULT DirectX::GenerateMipMaps3D | ( | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DWORD | filter,
 |  | _In_ size_t | levels,
 |  | _Out_ ScratchImage & | mipChain
 | ) |  |
HRESULT DirectX::GenerateMipMaps3D | ( | _In_reads_(depth) const Image * | baseImages,
 |  | _In_ size_t | depth,
 |  | _In_ DWORD | filter,
 |  | _In_ size_t | levels,
 |  | _Out_ ScratchImage & | mipChain
 | ) |  |
HRESULT DirectX::GetMetadataFromDDSFile | ( | _In_ LPCWSTR | szFile,
 |  | _In_ DWORD | flags,
 |  | _Out_ TexMetadata & | metadata
 | ) |  |
HRESULT DirectX::GetMetadataFromDDSMemory | ( | _In_reads_bytes_(size) LPCVOID | pSource,
 |  | _In_ size_t | size,
 |  | _In_ DWORD | flags,
 |  | _Out_ TexMetadata & | metadata
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::GetMetadataFromTGAFile | ( | LPCWSTR | szFile,
 |  | TexMetadata & | metadata
 | ) |  |

Definition at line 849 of file DirectXTexTGA.cpp.

{
    if ( !szFile )
        return E_INVALIDARG;

#if (_WIN32_WINNT >= _WIN32_WINNT_WIN8)
    ScopedHandle hFile( safe_handle( CreateFile2( szFile, GENERIC_READ, FILE_SHARE_READ, OPEN_EXISTING, 0 ) ) );
#else
    ScopedHandle hFile( safe_handle( CreateFileW( szFile, GENERIC_READ, FILE_SHARE_READ, 0, OPEN_EXISTING,
                                     FILE_FLAG_SEQUENTIAL_SCAN, 0 ) ) );
#endif
    if ( !hFile )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }

    // Get the file size
    LARGE_INTEGER fileSize = {0};

#if (_WIN32_WINNT >= _WIN32_WINNT_VISTA)
    FILE_STANDARD_INFO fileInfo;
    if ( !GetFileInformationByHandleEx( hFile.get(), FileStandardInfo, &fileInfo, sizeof(fileInfo) ) )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }
    fileSize = fileInfo.EndOfFile;
#else
    if ( !GetFileSizeEx( hFile.get(), &fileSize ) )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }
#endif

    // File is too big for 32-bit allocation, so reject read (4 GB should be plenty large enough for a valid TGA file)
    if ( fileSize.HighPart > 0 )
    {
        return HRESULT_FROM_WIN32( ERROR_FILE_TOO_LARGE );
    }

    // Need at least enough data to fill the standard header to be a valid TGA
    if ( fileSize.LowPart < ( sizeof(TGA_HEADER) ) )
    {
        return E_FAIL;
    }

    // Read the standard header (we don't need the file footer to parse the file)
    uint8_t header[sizeof(TGA_HEADER)];
    DWORD bytesRead = 0;
    if ( !ReadFile( hFile.get(), header, sizeof(TGA_HEADER), &bytesRead, 0 ) )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }

    size_t offset;
    return _DecodeTGAHeader( header, bytesRead, metadata, offset, 0 );
}

HRESULT DirectX::GetMetadataFromTGAFile | ( | _In_ LPCWSTR | szFile,
 |  | _Out_ TexMetadata & | metadata
 | ) |  |
HRESULT DirectX::GetMetadataFromTGAMemory | ( | _In_reads_bytes_(size) LPCVOID | pSource,
 |  | _In_ size_t | size,
 |  | _Out_ TexMetadata & | metadata
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::GetMetadataFromTGAMemory | ( | LPCVOID | pSource,
 |  | size_t | size,
 |  | TexMetadata & | metadata
 | ) |  |

Definition at line 839 of file DirectXTexTGA.cpp.

{
    if ( !pSource || size == 0 )
        return E_INVALIDARG;

    size_t offset;
    return _DecodeTGAHeader( pSource, size, metadata, offset, 0 );
}

HRESULT DirectX::GetMetadataFromWICFile | ( | _In_ LPCWSTR | szFile,
 |  | _In_ DWORD | flags,
 |  | _Out_ TexMetadata & | metadata
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::GetMetadataFromWICFile | ( | LPCWSTR | szFile,
 |  | DWORD | flags,
 |  | TexMetadata & | metadata
 | ) |  |

Definition at line 633 of file DirectXTexWIC.cpp.

{
    if ( !szFile )
        return E_INVALIDARG;

    IWICImagingFactory* pWIC = _GetWIC();
    if ( !pWIC )
        return E_NOINTERFACE;

    // Initialize WIC
    ScopedObject<IWICBitmapDecoder> decoder;
    HRESULT hr = pWIC->CreateDecoderFromFilename( szFile, 0, GENERIC_READ, WICDecodeMetadataCacheOnDemand, &decoder );
    if ( FAILED(hr) )
        return hr;

    ScopedObject<IWICBitmapFrameDecode> frame;
    hr = decoder->GetFrame( 0, &frame );
    if ( FAILED(hr) )
        return hr;

    // Get metadata
    hr = _DecodeMetadata( flags, decoder.Get(), frame.Get(), metadata, 0 );
    if ( FAILED(hr) )
        return hr;

    return S_OK;
}

HRESULT DirectX::GetMetadataFromWICMemory | ( | _In_reads_bytes_(size) LPCVOID | pSource,
 |  | _In_ size_t | size,
 |  | _In_ DWORD | flags,
 |  | _Out_ TexMetadata & | metadata
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::GetMetadataFromWICMemory | ( | LPCVOID | pSource,
 |  | size_t | size,
 |  | DWORD | flags,
 |  | TexMetadata & | metadata
 | ) |  |

Definition at line 584 of file DirectXTexWIC.cpp.

{
    if ( !pSource || size == 0 )
        return E_INVALIDARG;

#ifdef _AMD64_
    if ( size > 0xFFFFFFFF )
        return HRESULT_FROM_WIN32( ERROR_FILE_TOO_LARGE );
#endif

    IWICImagingFactory* pWIC = _GetWIC();
    if ( !pWIC )
        return E_NOINTERFACE;

    // Create input stream for memory
    ScopedObject<IWICStream> stream;
    HRESULT hr = pWIC->CreateStream( &stream );
    if ( FAILED(hr) )
        return hr;

    hr = stream->InitializeFromMemory( reinterpret_cast<BYTE*>( const_cast<void*>( pSource ) ),
                                       static_cast<UINT>( size ) );
    if ( FAILED(hr) )
        return hr;

    // Initialize WIC
    ScopedObject<IWICBitmapDecoder> decoder;
    hr = pWIC->CreateDecoderFromStream( stream.Get(), 0, WICDecodeMetadataCacheOnDemand, &decoder );
    if ( FAILED(hr) )
        return hr;

    ScopedObject<IWICBitmapFrameDecode> frame;
    hr = decoder->GetFrame( 0, &frame );
    if ( FAILED(hr) )
        return hr;

    // Get metadata
    hr = _DecodeMetadata( flags, decoder.Get(), frame.Get(), metadata, 0 );
    if ( FAILED(hr) )
        return hr;

    return S_OK;
}

REFGUID DirectX::GetWICCodec ( _In_ WICCodecs codec )
_Use_decl_annotations_ REFGUID DirectX::GetWICCodec ( WICCodecs codec )

Definition at line 174 of file DirectXTexUtil.cpp.

{
    switch( codec )
    {
    case WIC_CODEC_BMP:
        return GUID_ContainerFormatBmp;

    case WIC_CODEC_JPEG:
        return GUID_ContainerFormatJpeg;

    case WIC_CODEC_PNG:
        return GUID_ContainerFormatPng;

    case WIC_CODEC_TIFF:
        return GUID_ContainerFormatTiff;

    case WIC_CODEC_GIF:
        return GUID_ContainerFormatGif;

    case WIC_CODEC_WMP:
        return GUID_ContainerFormatWmp;

    case WIC_CODEC_ICO:
        return GUID_ContainerFormatIco;

    default:
        return GUID_NULL;
    }
}

HDRColorA* DirectX::HDRColorALerp | ( | _Out_ HDRColorA * | pOut,
 |  | _In_ const HDRColorA * | pC1,
 |  | _In_ const HDRColorA * | pC2,
 |  | _In_ float | s |
 | ) |  |  | [inline]

Definition at line 274 of file BC.h.

{
    pOut->r = pC1->r + s * (pC2->r - pC1->r);
    pOut->g = pC1->g + s * (pC2->g - pC1->g);
    pOut->b = pC1->b + s * (pC2->b - pC1->b);
    pOut->a = pC1->a + s * (pC2->a - pC1->a);
    return pOut;
}

_Use_decl_annotations_ bool DirectX::IsCompressed ( DXGI_FORMAT fmt ) [inline]

Definition at line 30 of file DirectXTex.h.

{

    //---------------------------------------------------------------------------------
    // DXGI Format Utilities
    bool IsValid( _In_ DXGI_FORMAT fmt );
    bool IsCompressed( _In_ DXGI_FORMAT fmt );
    bool IsPacked( _In_ DXGI_FORMAT fmt );
    bool IsVideo( _In_ DXGI_FORMAT fmt );
    bool IsSRGB( _In_ DXGI_FORMAT fmt );
    bool IsTypeless( _In_ DXGI_FORMAT fmt );

    size_t BitsPerPixel( _In_ DXGI_FORMAT fmt );

    enum CP_FLAGS
    {
        CP_FLAGS_NONE               = 0x0,      // Normal operation
        CP_FLAGS_LEGACY_DWORD       = 0x1,      // Assume pitch is DWORD aligned instead of BYTE aligned
        CP_FLAGS_24BPP              = 0x10000,  // Override with a legacy 24 bits-per-pixel format size
        CP_FLAGS_16BPP              = 0x20000,  // Override with a legacy 16 bits-per-pixel format size
        CP_FLAGS_8BPP               = 0x40000,  // Override with a legacy 8 bits-per-pixel format size
    };

    void ComputePitch( _In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height,
                       _Out_ size_t& rowPitch, _Out_ size_t& slicePitch, _In_ DWORD flags = CP_FLAGS_NONE );

    size_t ComputeScanlines( _In_ DXGI_FORMAT fmt, _In_ size_t height );

    DXGI_FORMAT MakeSRGB( _In_ DXGI_FORMAT fmt );

bool DirectX::IsCompressed ( _In_ DXGI_FORMAT fmt )
bool DirectX::IsPacked ( _In_ DXGI_FORMAT fmt )
_Use_decl_annotations_ bool DirectX::IsPacked ( DXGI_FORMAT fmt ) [inline]

Definition at line 63 of file DirectXTex.h.

    {

_Use_decl_annotations_ bool DirectX::IsSRGB ( DXGI_FORMAT fmt ) [inline]

Definition at line 101 of file DirectXTex.h.

                                                                                :3:2, A8L8, A4L4, P8, A8P8)

        DDS_FLAGS_NO_R10B10G10A2_FIXUP  = 0x4,
            // Do not use work-around for long-standing D3DX DDS file format issue which reversed the 10:10:10:2 color order masks

        DDS_FLAGS_FORCE_RGB             = 0x8,
            // Convert DXGI 1.1 BGR formats to DXGI_FORMAT_R8G8B8A8_UNORM to avoid use of optional WDDM 1.1 formats

        DDS_FLAGS_NO_16BPP              = 0x10,
            // Conversions avoid use of 565, 5551, and 4444 formats and instead expand to 8888 to avoid use of optional WDDM 1.2 formats

        DDS_FLAGS_FORCE_DX10_EXT        = 0x10000,
            // Always use the 'DX10' header extension for DDS writer (i.e. don't try to write DX9 compatible DDS files)
    };

    enum WIC_FLAGS
    {

bool DirectX::IsSRGB ( _In_ DXGI_FORMAT fmt )
_Use_decl_annotations_ bool DirectX::IsSupportedTexture | ( | ID3D11Device * | pDevice,
 |  | const TexMetadata & | metadata
 | ) |  |

Definition at line 153 of file DirectXTexD3D11.cpp.

{
    if ( !pDevice )
        return false;

    D3D_FEATURE_LEVEL fl = pDevice->GetFeatureLevel();

    // Validate format
    DXGI_FORMAT fmt = metadata.format;

    if ( !IsValid( fmt ) )
        return false;

    if ( IsVideo(fmt) )
        return false;

    switch( fmt )
    {
    case DXGI_FORMAT_BC4_TYPELESS:
    case DXGI_FORMAT_BC4_UNORM:
    case DXGI_FORMAT_BC4_SNORM:
    case DXGI_FORMAT_BC5_TYPELESS:
    case DXGI_FORMAT_BC5_UNORM:
    case DXGI_FORMAT_BC5_SNORM:
        if ( fl < D3D_FEATURE_LEVEL_10_0 )
            return false;
        break;

    case DXGI_FORMAT_BC6H_TYPELESS:
    case DXGI_FORMAT_BC6H_UF16:
    case DXGI_FORMAT_BC6H_SF16:
    case DXGI_FORMAT_BC7_TYPELESS:
    case DXGI_FORMAT_BC7_UNORM:
    case DXGI_FORMAT_BC7_UNORM_SRGB:
        if ( fl < D3D_FEATURE_LEVEL_11_0 )
            return false;
        break;
    }

    // Validate miplevel count
    if ( metadata.mipLevels > D3D11_REQ_MIP_LEVELS )
        return false;

    // Validate array size, dimension, and width/height
    size_t arraySize = metadata.arraySize;
    size_t iWidth = metadata.width;
    size_t iHeight = metadata.height;
    size_t iDepth = metadata.depth;

    // Most cases are known apriori based on feature level, but we use this for robustness to handle the few optional cases
    UINT formatSupport = 0;
    pDevice->CheckFormatSupport( fmt, &formatSupport );

    switch ( metadata.dimension )
    {
    case TEX_DIMENSION_TEXTURE1D:
        if ( !(formatSupport & D3D11_FORMAT_SUPPORT_TEXTURE1D) )
            return false;

        if ( (arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION)
             || (iWidth > D3D11_REQ_TEXTURE1D_U_DIMENSION) )
            return false;

        if ( fl < D3D_FEATURE_LEVEL_11_0 )
        {
            if ( (arraySize > D3D10_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION)
                 || (iWidth > D3D10_REQ_TEXTURE1D_U_DIMENSION) )
                return false;

            if ( fl < D3D_FEATURE_LEVEL_10_0 )
            {
                if ( (arraySize > 1) || (iWidth > D3D_FL9_3_REQ_TEXTURE1D_U_DIMENSION) )
                    return false;

                if ( (fl < D3D_FEATURE_LEVEL_9_3) && (iWidth > D3D_FL9_1_REQ_TEXTURE1D_U_DIMENSION ) )
                    return false;
            }
        }
        break;

    case TEX_DIMENSION_TEXTURE2D:
        if ( metadata.miscFlags & TEX_MISC_TEXTURECUBE )
        {
            if ( !(formatSupport & D3D11_FORMAT_SUPPORT_TEXTURECUBE) )
                return false;

            if ( (arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION)
                 || (iWidth > D3D11_REQ_TEXTURECUBE_DIMENSION)
                 || (iHeight > D3D11_REQ_TEXTURECUBE_DIMENSION))
                return false;

            if ( fl < D3D_FEATURE_LEVEL_11_0 )
            {
                if ( (arraySize > D3D10_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION)
                     || (iWidth > D3D10_REQ_TEXTURECUBE_DIMENSION)
                     || (iHeight > D3D10_REQ_TEXTURECUBE_DIMENSION))
                    return false;

                if ( (fl < D3D_FEATURE_LEVEL_10_1) && (arraySize != 6) )
                    return false;

                if ( fl < D3D_FEATURE_LEVEL_10_0 )
                {
                    if ( (iWidth > D3D_FL9_3_REQ_TEXTURECUBE_DIMENSION )
                         || (iHeight > D3D_FL9_3_REQ_TEXTURECUBE_DIMENSION ) )
                        return false;

                    if ( (fl < D3D_FEATURE_LEVEL_9_3)
                         && ( (iWidth > D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION)
                              || (iHeight > D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION) ) )
                        return false;
                }
            }
        }
        else // Not a cube map
        {
            if ( !(formatSupport & D3D11_FORMAT_SUPPORT_TEXTURE2D) )
                return false;

            if ( (arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION)
                 || (iWidth > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION)
                 || (iHeight > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
                return false;

            if ( fl < D3D_FEATURE_LEVEL_11_0 )
            {
                if ( (arraySize > D3D10_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION)
                     || (iWidth > D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION)
                     || (iHeight > D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION))
                    return false;

                if ( fl < D3D_FEATURE_LEVEL_10_0 )
                {
                    if ( (arraySize > 1)
                         || (iWidth > D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION)
                         || (iHeight > D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION) )
                        return false;

                    if ( (fl < D3D_FEATURE_LEVEL_9_3)
                         && ( (iWidth > D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION)
                              || (iHeight > D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION) ) )
                        return false;
                }
            }
        }
        break;

    case TEX_DIMENSION_TEXTURE3D:
        if ( !(formatSupport & D3D11_FORMAT_SUPPORT_TEXTURE3D) )
            return false;

        if ( (arraySize > 1)
             || (iWidth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION)
             || (iHeight > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION)
             || (iDepth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) )
            return false;

        if ( fl < D3D_FEATURE_LEVEL_11_0 )
        {
            if ( (iWidth > D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION)
                 || (iHeight > D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION)
                 || (iDepth > D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) )
                return false;

            if ( fl < D3D_FEATURE_LEVEL_10_0 )
            {
                if ( (iWidth > D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION)
                     || (iHeight > D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION)
                     || (iDepth > D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) )
                    return false;
            }
        }
        break;

    default:
        // Not a supported dimension
        return false;
    }

    return true;
}

bool DirectX::IsSupportedTexture | ( | _In_ ID3D11Device * | pDevice,
 |  | _In_ const TexMetadata & | metadata
 | ) |  |
bool DirectX::IsTypeless ( _In_ DXGI_FORMAT fmt )
_Use_decl_annotations_ bool DirectX::IsTypeless ( DXGI_FORMAT fmt ) [inline]

Definition at line 120 of file DirectXTex.h.

                                   :10:10:2 format as DXGI_FORMAT_R10G10B10A2_UNORM

        WIC_FLAGS_NO_16BPP              = 0x4,
            // Loads 565, 5551, and 4444 formats as 8888 to avoid use of optional WDDM 1.2 formats

        WIC_FLAGS_ALLOW_MONO            = 0x8,
            // Loads 1-bit monochrome (black & white) as R1_UNORM rather than 8-bit greyscale

        WIC_FLAGS_ALL_FRAMES            = 0x10,
            // Loads all images in a multi-frame file, converting/resizing to match the first frame as needed, defaults to 0th frame otherwise

        WIC_FLAGS_DITHER                = 0x10000,
            // Use ordered 4x4 dithering for any required conversions

        WIC_FLAGS_DITHER_DIFFUSION      = 0x20000,
            // Use error-diffusion dithering for any required conversions

        WIC_FLAGS_FILTER_POINT          = 0x100000,
        WIC_FLAGS_FILTER_LINEAR         = 0x200000,
        WIC_FLAGS_FILTER_CUBIC          = 0x300000,
        WIC_FLAGS_FILTER_FANT           = 0x400000, // Combination of Linear and Box filter
            // Filtering mode to use for any required image resizing (only needed when loading arrays of differently sized images; defaults to Fant)
    };

    HRESULT GetMetadataFromDDSMemory( _In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags,
                                      _Out_ TexMetadata& metadata );
    HRESULT GetMetadataFromDDSFile( _In_ LPCWSTR szFile, _In_ DWORD flags,
                                    _Out_ TexMetadata& metadata );

    HRESULT GetMetadataFromTGAMemory( _In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size,
                                      _Out_ TexMetadata& metadata );
    HRESULT GetMetadataFromTGAFile( _In_ LPCWSTR szFile,

_Use_decl_annotations_ bool DirectX::IsValid ( DXGI_FORMAT fmt ) [inline]

Definition at line 24 of file DirectXTex.h.

{

bool DirectX::IsValid ( _In_ DXGI_FORMAT fmt )
bool DirectX::IsVideo ( _In_ DXGI_FORMAT fmt )
_Use_decl_annotations_ bool DirectX::IsVideo ( DXGI_FORMAT fmt ) [inline]

Definition at line 70 of file DirectXTex.h.

    {
        TEX_MISC_TEXTURECUBE = 0x4L,
    };

    struct TexMetadata
    {
        size_t          width;
        size_t          height;     // Should be 1 for 1D textures
        size_t          depth;      // Should be 1 for 1D or 2D textures
        size_t          arraySize;  // For cubemap, this is a multiple of 6
        size_t          mipLevels;
        uint32_t        miscFlags;
        DXGI_FORMAT     format;
        TEX_DIMENSION   dimension;

        size_t ComputeIndex( _In_ size_t mip, _In_ size_t item, _In_ size_t slice ) const;
            // Returns size_t(-1) to indicate an out-of-range error
    };

    enum DDS_FLAGS
    {
        DDS_FLAGS_NONE                  = 0x0,

        DDS_FLAGS_LEGACY_DWORD          = 0x1,
            // Assume pitch is DWORD aligned instead of BYTE aligned (used by some legacy DDS files)

HRESULT DirectX::LoadFromDDSFile | ( | _In_ LPCWSTR | szFile,
 |  | _In_ DWORD | flags,
 |  | _Out_opt_ TexMetadata * | metadata,
 |  | _Out_ ScratchImage & | image
 | ) |  |
HRESULT DirectX::LoadFromDDSMemory | ( | _In_reads_bytes_(size) LPCVOID | pSource,
 |  | _In_ size_t | size,
 |  | _In_ DWORD | flags,
 |  | _Out_opt_ TexMetadata * | metadata,
 |  | _Out_ ScratchImage & | image
 | ) |  |
HRESULT DirectX::LoadFromTGAFile | ( | _In_ LPCWSTR | szFile,
 |  | _Out_opt_ TexMetadata * | metadata,
 |  | _Out_ ScratchImage & | image
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::LoadFromTGAFile | ( | LPCWSTR | szFile,
 |  | TexMetadata * | metadata,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 964 of file DirectXTexTGA.cpp.

{
    if ( !szFile )
        return E_INVALIDARG;

    image.Release();

#if (_WIN32_WINNT >= _WIN32_WINNT_WIN8)
    ScopedHandle hFile( safe_handle( CreateFile2( szFile, GENERIC_READ, FILE_SHARE_READ, OPEN_EXISTING, 0 ) ) );
#else
    ScopedHandle hFile( safe_handle( CreateFileW( szFile, GENERIC_READ, FILE_SHARE_READ, 0, OPEN_EXISTING,
                                                  FILE_FLAG_SEQUENTIAL_SCAN, 0 ) ) );
#endif
    if ( !hFile )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }

    // Get the file size
    LARGE_INTEGER fileSize = {0};

#if (_WIN32_WINNT >= _WIN32_WINNT_VISTA)
    FILE_STANDARD_INFO fileInfo;
    if ( !GetFileInformationByHandleEx( hFile.get(), FileStandardInfo, &fileInfo, sizeof(fileInfo) ) )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }
    fileSize = fileInfo.EndOfFile;
#else
    if ( !GetFileSizeEx( hFile.get(), &fileSize ) )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }
#endif

    // File is too big for 32-bit allocation, so reject read (4 GB should be plenty large enough for a valid TGA file)
    if ( fileSize.HighPart > 0 )
    {
        return HRESULT_FROM_WIN32( ERROR_FILE_TOO_LARGE );
    }

    // Need at least enough data to fill the header to be a valid TGA
    if ( fileSize.LowPart < sizeof(TGA_HEADER) )
    {
        return E_FAIL;
    }

    // Read the header
    uint8_t header[sizeof(TGA_HEADER)];
    DWORD bytesRead = 0;
    if ( !ReadFile( hFile.get(), header, sizeof(TGA_HEADER), &bytesRead, 0 ) )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }

    size_t offset;
    DWORD convFlags = 0;
    TexMetadata mdata;
    HRESULT hr = _DecodeTGAHeader( header, bytesRead, mdata, offset, &convFlags );
    if ( FAILED(hr) )
        return hr;

    // Read the pixels
    DWORD remaining = static_cast<DWORD>( fileSize.LowPart - offset );
    if ( remaining == 0 )
        return E_FAIL;

    if ( offset > sizeof(TGA_HEADER) )
    {
        // Skip past the id string
        LARGE_INTEGER filePos = { static_cast<DWORD>(offset), 0 };
        if ( !SetFilePointerEx( hFile.get(), filePos, 0, FILE_BEGIN ) )
        {
            return HRESULT_FROM_WIN32( GetLastError() );
        }
    }

    hr = image.Initialize2D( mdata.format, mdata.width, mdata.height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    assert( image.GetPixels() );

    if ( !(convFlags & (CONV_FLAGS_RLE | CONV_FLAGS_EXPAND | CONV_FLAGS_INVERTX)) && (convFlags & CONV_FLAGS_INVERTY) )
    {
        // This case we can read directly into the image buffer in place
        if ( !ReadFile( hFile.get(), image.GetPixels(), static_cast<DWORD>( image.GetPixelsSize() ), &bytesRead, 0 ) )
        {
            image.Release();
            return HRESULT_FROM_WIN32( GetLastError() );
        }

        if ( bytesRead != image.GetPixelsSize() )
        {
            image.Release();
            return E_FAIL;
        }

        switch( mdata.format  )
        {
        case DXGI_FORMAT_R8G8B8A8_UNORM:
            {
                // TGA stores 32-bit data in BGRA form, need to swizzle to RGBA
                assert( image.GetImageCount() == 1 );
                const Image* img = image.GetImage(0,0,0);
                if ( !img )
                    return E_POINTER;

                uint8_t *pPixels = img->pixels;
                if ( !pPixels )
                    return E_POINTER;

                size_t rowPitch = img->rowPitch;

                // Scan for non-zero alpha channel
                bool nonzeroa = false;

                for( size_t h = 0; h < img->height; ++h )
                {
                    const uint32_t* sPtr = reinterpret_cast<const uint32_t*>( pPixels );

                    for( size_t x=0; x < img->width; ++x )
                    {
                        if ( (*sPtr) & 0xff000000 )
                        {
                            nonzeroa = true;
                            break;
                        }

                        ++sPtr;
                    }

                    if ( nonzeroa )
                        break;

                    pPixels += rowPitch;
                }

                DWORD tflags = ( !nonzeroa ) ? TEXP_SCANLINE_SETALPHA : TEXP_SCANLINE_NONE;

                // Swizzle scanlines
                pPixels = img->pixels;

                for( size_t h = 0; h < img->height; ++h )
                {
                    _SwizzleScanline( pPixels, rowPitch, pPixels, rowPitch, mdata.format, tflags );
                    pPixels += rowPitch;
                }
            }
            break;

        // If we start using DXGI_FORMAT_B8G8R8X8_UNORM or DXGI_FORMAT_B8G8R8A8_UNORM we need to check for a fully 0 alpha channel

        case DXGI_FORMAT_B5G5R5A1_UNORM:
            {
                assert( image.GetImageCount() == 1 );
                const Image* img = image.GetImage(0,0,0);
                if ( !img )
                    return E_POINTER;

                // Scan for non-zero alpha channel
                bool nonzeroa = false;

                const uint8_t *pPixels = img->pixels;
                if ( !pPixels )
                    return E_POINTER;

                size_t rowPitch = img->rowPitch;

                for( size_t h = 0; h < img->height; ++h )
                {
                    const uint16_t* sPtr = reinterpret_cast<const uint16_t*>( pPixels );

                    for( size_t x=0; x < img->width; ++x )
                    {
                        if ( *sPtr & 0x8000 )
                        {
                            nonzeroa = true;
                            break;
                        }

                        ++sPtr;
                    }

                    if ( nonzeroa )
                        break;

                    pPixels += rowPitch;
                }

                // If there are no non-zero alpha channel entries, we'll assume alpha is not used and force it to opaque
                if ( !nonzeroa )
                {
                    hr = _SetAlphaChannelToOpaque( img );
                    if ( FAILED(hr) )
                        return hr;
                }
            }
            break;
        }
    }
    else // RLE || EXPAND || INVERTX || !INVERTY
    {
        std::unique_ptr<uint8_t[]> temp( new uint8_t[ remaining ] );
        if ( !temp )
        {
            image.Release();
            return E_OUTOFMEMORY;
        }

        if ( !ReadFile( hFile.get(), temp.get(), remaining, &bytesRead, 0 ) )
        {
            image.Release();
            return HRESULT_FROM_WIN32( GetLastError() );
        }

        if ( bytesRead != remaining )
        {
            image.Release();
            return E_FAIL;
        }

        if ( convFlags & CONV_FLAGS_RLE )
        {
            hr = _UncompressPixels( temp.get(), remaining, image.GetImage(0,0,0), convFlags );
        }
        else
        {
            hr = _CopyPixels( temp.get(), remaining, image.GetImage(0,0,0), convFlags );
        }

        if ( FAILED(hr) )
        {
            image.Release();
            return hr;
        }
    }

    if ( metadata )
        memcpy( metadata, &mdata, sizeof(TexMetadata) );

    return S_OK;
}

HRESULT DirectX::LoadFromTGAMemory | ( | _In_reads_bytes_(size) LPCVOID | pSource,
 |  | _In_ size_t | size,
 |  | _Out_opt_ TexMetadata * | metadata,
 |  | _Out_ ScratchImage & | image
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::LoadFromTGAMemory | ( | LPCVOID | pSource,
 |  | size_t | size,
 |  | TexMetadata * | metadata,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 910 of file DirectXTexTGA.cpp.

{
    if ( !pSource || size == 0 )
        return E_INVALIDARG;

    image.Release();

    size_t offset;
    DWORD convFlags = 0;
    TexMetadata mdata;
    HRESULT hr = _DecodeTGAHeader( pSource, size, mdata, offset, &convFlags );
    if ( FAILED(hr) )
        return hr;

    if ( offset > size )
        return E_FAIL;

    LPCVOID pPixels = reinterpret_cast<LPCVOID>( reinterpret_cast<const uint8_t*>(pSource) + offset );
    assert( pPixels );

    size_t remaining = size - offset;
    if ( remaining == 0 )
        return E_FAIL;

    hr = image.Initialize2D( mdata.format, mdata.width, mdata.height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    if ( convFlags & CONV_FLAGS_RLE )
    {
        hr = _UncompressPixels( pPixels, remaining, image.GetImage(0,0,0), convFlags );
    }
    else
    {
        hr = _CopyPixels( pPixels, remaining, image.GetImage(0,0,0), convFlags );
    }

    if ( FAILED(hr) )
    {
        image.Release();
        return hr;
    }

    if ( metadata )
        memcpy( metadata, &mdata, sizeof(TexMetadata) );

    return S_OK;
}

HRESULT DirectX::LoadFromWICFile | ( | _In_ LPCWSTR | szFile,
 |  | _In_ DWORD | flags,
 |  | _Out_opt_ TexMetadata * | metadata,
 |  | _Out_ ScratchImage & | image
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::LoadFromWICFile | ( | LPCWSTR | szFile,
 |  | DWORD | flags,
 |  | TexMetadata * | metadata,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 736 of file DirectXTexWIC.cpp.

{
    if ( !szFile )
        return E_INVALIDARG;

    IWICImagingFactory* pWIC = _GetWIC();
    if ( !pWIC )
        return E_NOINTERFACE;

    image.Release();

    // Initialize WIC
    ScopedObject<IWICBitmapDecoder> decoder;
    HRESULT hr = pWIC->CreateDecoderFromFilename( szFile, 0, GENERIC_READ, WICDecodeMetadataCacheOnDemand, &decoder );
    if ( FAILED(hr) )
        return hr;

    ScopedObject<IWICBitmapFrameDecode> frame;
    hr = decoder->GetFrame( 0, &frame );
    if ( FAILED(hr) )
        return hr;

    // Get metadata
    TexMetadata mdata;
    WICPixelFormatGUID convertGUID = {0};
    hr = _DecodeMetadata( flags, decoder.Get(), frame.Get(), mdata, &convertGUID );
    if ( FAILED(hr) )
        return hr;

    if ( (mdata.arraySize > 1) && (flags & WIC_FLAGS_ALL_FRAMES) )
    {
        hr = _DecodeMultiframe( flags, mdata, decoder.Get(), image );
    }
    else
    {
        hr = _DecodeSingleFrame( flags, mdata, convertGUID, frame.Get(), image );
    }

    if ( FAILED(hr) )
    {
        image.Release();
        return hr;
    }

    if ( metadata )
        memcpy( metadata, &mdata, sizeof(TexMetadata) );

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::LoadFromWICMemory | ( | LPCVOID | pSource,
 |  | size_t | size,
 |  | DWORD | flags,
 |  | TexMetadata * | metadata,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 666 of file DirectXTexWIC.cpp.

{
    if ( !pSource || size == 0 )
        return E_INVALIDARG;

#ifdef _AMD64_
    if ( size > 0xFFFFFFFF )
        return HRESULT_FROM_WIN32( ERROR_FILE_TOO_LARGE );
#endif

    IWICImagingFactory* pWIC = _GetWIC();
    if ( !pWIC )
        return E_NOINTERFACE;

    image.Release();

    // Create input stream for memory
    ScopedObject<IWICStream> stream;
    HRESULT hr = pWIC->CreateStream( &stream );
    if ( FAILED(hr) )
        return hr;

    hr = stream->InitializeFromMemory( reinterpret_cast<uint8_t*>( const_cast<void*>( pSource ) ), static_cast<DWORD>( size ) );
    if ( FAILED(hr) )
        return hr;

    // Initialize WIC
    ScopedObject<IWICBitmapDecoder> decoder;
    hr = pWIC->CreateDecoderFromStream( stream.Get(), 0, WICDecodeMetadataCacheOnDemand, &decoder );
    if ( FAILED(hr) )
        return hr;

    ScopedObject<IWICBitmapFrameDecode> frame;
    hr = decoder->GetFrame( 0, &frame );
    if ( FAILED(hr) )
        return hr;

    // Get metadata
    TexMetadata mdata;
    WICPixelFormatGUID convertGUID = {0};
    hr = _DecodeMetadata( flags, decoder.Get(), frame.Get(), mdata, &convertGUID );
    if ( FAILED(hr) )
        return hr;

    if ( (mdata.arraySize > 1) && (flags & WIC_FLAGS_ALL_FRAMES) )
    {
        hr = _DecodeMultiframe( flags, mdata, decoder.Get(), image );
    }
    else
    {
        hr = _DecodeSingleFrame( flags, mdata, convertGUID, frame.Get(), image );
    }

    if ( FAILED(hr) )
    {
        image.Release();
        return hr;
    }

    if ( metadata )
        memcpy( metadata, &mdata, sizeof(TexMetadata) );

    return S_OK;
}

HRESULT DirectX::LoadFromWICMemory | ( | _In_reads_bytes_(size) LPCVOID | pSource,
 |  | _In_ size_t | size,
 |  | _In_ DWORD | flags,
 |  | _Out_opt_ TexMetadata * | metadata,
 |  | _Out_ ScratchImage & | image
 | ) |  |
_Use_decl_annotations_ DXGI_FORMAT DirectX::MakeSRGB ( DXGI_FORMAT fmt )

Definition at line 408 of file DirectXTexUtil.cpp.

{
    switch( fmt )
    {
    case DXGI_FORMAT_R8G8B8A8_UNORM:
        return DXGI_FORMAT_R8G8B8A8_UNORM_SRGB;

    case DXGI_FORMAT_BC1_UNORM:
        return DXGI_FORMAT_BC1_UNORM_SRGB;

    case DXGI_FORMAT_BC2_UNORM:
        return DXGI_FORMAT_BC2_UNORM_SRGB;

    case DXGI_FORMAT_BC3_UNORM:
        return DXGI_FORMAT_BC3_UNORM_SRGB;

    case DXGI_FORMAT_B8G8R8A8_UNORM:
        return DXGI_FORMAT_B8G8R8A8_UNORM_SRGB;

    case DXGI_FORMAT_B8G8R8X8_UNORM:
        return DXGI_FORMAT_B8G8R8X8_UNORM_SRGB;

    case DXGI_FORMAT_BC7_UNORM:
        return DXGI_FORMAT_BC7_UNORM_SRGB;

    default:
        return fmt;
    }
}

DXGI_FORMAT DirectX::MakeSRGB ( _In_ DXGI_FORMAT fmt )
template<bool bRange>
void DirectX::OptimizeAlpha | ( | float * | pX,
 |  | float * | pY,
 |  | const float * | pPoints,
 |  | size_t | cSteps
 | ) |  |

Definition at line 719 of file BC.h.

{
    static const float pC6[] = { 5.0f/5.0f, 4.0f/5.0f, 3.0f/5.0f, 2.0f/5.0f, 1.0f/5.0f, 0.0f/5.0f };
    static const float pD6[] = { 0.0f/5.0f, 1.0f/5.0f, 2.0f/5.0f, 3.0f/5.0f, 4.0f/5.0f, 5.0f/5.0f };
    static const float pC8[] = { 7.0f/7.0f, 6.0f/7.0f, 5.0f/7.0f, 4.0f/7.0f, 3.0f/7.0f, 2.0f/7.0f, 1.0f/7.0f, 0.0f/7.0f };
    static const float pD8[] = { 0.0f/7.0f, 1.0f/7.0f, 2.0f/7.0f, 3.0f/7.0f, 4.0f/7.0f, 5.0f/7.0f, 6.0f/7.0f, 7.0f/7.0f };

    const float *pC = (6 == cSteps) ? pC6 : pC8;
    const float *pD = (6 == cSteps) ? pD6 : pD8;

    float MAX_VALUE = 1.0f;
    float MIN_VALUE;
    if (bRange)
    {
        MIN_VALUE = -1.0f;
    }
    else
    {
        MIN_VALUE = 0.0f;
    }

    // Find Min and Max points, as starting point
    float fX = MAX_VALUE;
    float fY = MIN_VALUE;

    if(8 == cSteps)
    {
        for(size_t iPoint = 0; iPoint < NUM_PIXELS_PER_BLOCK; iPoint++)
        {
            if(pPoints[iPoint] < fX)
                fX = pPoints[iPoint];

            if(pPoints[iPoint] > fY)
                fY = pPoints[iPoint];
        }
    }
    else
    {
        for(size_t iPoint = 0; iPoint < NUM_PIXELS_PER_BLOCK; iPoint++)
        {
            if(pPoints[iPoint] < fX && pPoints[iPoint] > MIN_VALUE)
                fX = pPoints[iPoint];

            if(pPoints[iPoint] > fY && pPoints[iPoint] < MAX_VALUE)
                fY = pPoints[iPoint];
        }

        if (fX == fY)
        {
            fY = MAX_VALUE;
        }
    }

    // Use Newton's Method to find local minima of sum-of-squares error.
    float fSteps = (float) (cSteps - 1);

    for(size_t iIteration = 0; iIteration < 8; iIteration++)
    {
        float fScale;

        if((fY - fX) < (1.0f / 256.0f))
            break;

        fScale = fSteps / (fY - fX);

        // Calculate new steps
        float pSteps[8];

        for(size_t iStep = 0; iStep < cSteps; iStep++)
            pSteps[iStep] = pC[iStep] * fX + pD[iStep] * fY;

        if(6 == cSteps)
        {
            pSteps[6] = MIN_VALUE;
            pSteps[7] = MAX_VALUE;
        }

        // Evaluate function, and derivatives
        float dX  = 0.0f;
        float dY  = 0.0f;
        float d2X = 0.0f;
        float d2Y = 0.0f;

        for(size_t iPoint = 0; iPoint < NUM_PIXELS_PER_BLOCK; iPoint++)
        {
            float fDot = (pPoints[iPoint] - fX) * fScale;

            size_t iStep;

            if(fDot <= 0.0f)
                iStep = ((6 == cSteps) && (pPoints[iPoint] <= fX * 0.5f)) ? 6 : 0;
            else if(fDot >= fSteps)
                iStep = ((6 == cSteps) && (pPoints[iPoint] >= (fY + 1.0f) * 0.5f)) ? 7 : (cSteps - 1);
            else
                iStep = static_cast<int32_t>(fDot + 0.5f);

            if(iStep < cSteps)
            {
                // D3DX had this computation backwards (pPoints[iPoint] - pSteps[iStep])
                // this fix improves RMS of the alpha component
                float fDiff = pSteps[iStep] - pPoints[iPoint];

                dX  += pC[iStep] * fDiff;
                d2X += pC[iStep] * pC[iStep];

                dY  += pD[iStep] * fDiff;
                d2Y += pD[iStep] * pD[iStep];
            }
        }

        // Move endpoints
        if(d2X > 0.0f)
            fX -= dX / d2X;

        if(d2Y > 0.0f)
            fY -= dY / d2Y;

        if(fX > fY)
        {
            float f = fX; fX = fY; fY = f;
        }

        if((dX * dX < (1.0f / 64.0f)) && (dY * dY < (1.0f / 64.0f)))
            break;
    }

    *pX = (fX < MIN_VALUE) ? MIN_VALUE : (fX > MAX_VALUE) ? MAX_VALUE : fX;
    *pY = (fY < MIN_VALUE) ? MIN_VALUE : (fY > MAX_VALUE) ? MAX_VALUE : fY;
}

_Use_decl_annotations_ HRESULT DirectX::Resize | ( | const Image & | srcImage,
 |  | size_t | width,
 |  | size_t | height,
 |  | DWORD | filter,
 |  | ScratchImage & | image
 | ) |  |

Definition at line 161 of file DirectXTexResize.cpp.

{
    if ( width == 0 || height == 0 )
        return E_INVALIDARG;

#ifdef _AMD64_
    if ( (srcImage.width > 0xFFFFFFFF) || (srcImage.height > 0xFFFFFFFF) )
        return E_INVALIDARG;

    if ( (width > 0xFFFFFFFF) || (height > 0xFFFFFFFF) )
        return E_INVALIDARG;
#endif

    if ( !srcImage.pixels )
        return E_POINTER;

    if ( IsCompressed( srcImage.format ) )
    {
        // We don't support resizing compressed images
        return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
    }

    HRESULT hr = image.Initialize2D( srcImage.format, width, height, 1, 1 );
    if ( FAILED(hr) )
        return hr;

    const Image *rimage = image.GetImage( 0, 0, 0 );
    if ( !rimage )
        return E_POINTER;

    // WIC only supports CLAMP

    WICPixelFormatGUID pfGUID;
    if ( _DXGIToWIC( srcImage.format, pfGUID ) )
    {
        // Case 1: Source format is supported by Windows Imaging Component
        hr = _PerformResizeUsingWIC( srcImage, filter, pfGUID, *rimage );
    }
    else
    {
        // Case 2: Source format is not supported by WIC, so we have to convert, resize, and convert back
        hr = _PerformResizeViaF32( srcImage, filter, *rimage );
    }

    if ( FAILED(hr) )
    {
        image.Release();
        return hr;
    }

    return S_OK;
}

HRESULT DirectX::Resize | ( | _In_reads_(nimages) const Image * | srcImages,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ size_t | width,
 |  | _In_ size_t | height,
 |  | _In_ DWORD | filter,
 |  | _Out_ ScratchImage & | result
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::Resize | ( | const Image * | srcImages,
 |  | size_t | nimages,
 |  | const TexMetadata & | metadata,
 |  | size_t | width,
 |  | size_t | height,
 |  | DWORD | filter,
 |  | ScratchImage & | result
 | ) |  |

Definition at line 219 of file DirectXTexResize.cpp.

{
    if ( !srcImages || !nimages || width == 0 || height == 0 )
        return E_INVALIDARG;

#ifdef _AMD64_
    if ( (width > 0xFFFFFFFF) || (height > 0xFFFFFFFF) )
        return E_INVALIDARG;
#endif

    TexMetadata mdata2 = metadata;
    mdata2.width = width;
    mdata2.height = height;
    mdata2.mipLevels = 1;
    HRESULT hr = result.Initialize( mdata2 );
    if ( FAILED(hr) )
        return hr;

    WICPixelFormatGUID pfGUID;
    bool wicpf = _DXGIToWIC( metadata.format, pfGUID );

    switch ( metadata.dimension )
    {
    case TEX_DIMENSION_TEXTURE1D:
    case TEX_DIMENSION_TEXTURE2D:
        assert( metadata.depth == 1 );

        for( size_t item = 0; item < metadata.arraySize; ++item )
        {
            size_t srcIndex = metadata.ComputeIndex( 0, item, 0 );
            if ( srcIndex >= nimages )
            {
                result.Release();
                return E_FAIL;
            }

            const Image* srcimg = &srcImages[ srcIndex ];
            const Image* destimg = result.GetImage( 0, item, 0 );
            if ( !srcimg || !destimg )
            {
                result.Release();
                return E_POINTER;
            }

            if ( srcimg->format != metadata.format )
            {
                result.Release();
                return E_FAIL;
            }

#ifdef _AMD64_
            if ( (srcimg->width > 0xFFFFFFFF) || (srcimg->height > 0xFFFFFFFF) )
            {
                result.Release();
                return E_FAIL;
            }
#endif

            if ( wicpf )
            {
                // Case 1: Source format is supported by Windows Imaging Component
                hr = _PerformResizeUsingWIC( *srcimg, filter, pfGUID, *destimg );
            }
            else
            {
                // Case 2: Source format is not supported by WIC, so we have to convert, resize, and convert back
                hr = _PerformResizeViaF32( *srcimg, filter, *destimg );
            }

            if ( FAILED(hr) )
            {
                result.Release();
                return hr;
            }
        }
        break;

    case TEX_DIMENSION_TEXTURE3D:
        assert( metadata.arraySize == 1 );

        for( size_t slice = 0; slice < metadata.depth; ++slice )
        {
            size_t srcIndex = metadata.ComputeIndex( 0, 0, slice );
            if ( srcIndex >= nimages )
            {
                result.Release();
                return E_FAIL;
            }

            const Image* srcimg = &srcImages[ srcIndex ];
            const Image* destimg = result.GetImage( 0, 0, slice );
            if ( !srcimg || !destimg )
            {
                result.Release();
                return E_POINTER;
            }

            if ( srcimg->format != metadata.format )
            {
                result.Release();
                return E_FAIL;
            }

#ifdef _AMD64_
            if ( (srcimg->width > 0xFFFFFFFF) || (srcimg->height > 0xFFFFFFFF) )
            {
                result.Release();
                return E_FAIL;
            }
#endif

            if ( wicpf )
            {
                // Case 1: Source format is supported by Windows Imaging Component
                hr = _PerformResizeUsingWIC( *srcimg, filter, pfGUID, *destimg );
            }
            else
            {
                // Case 2: Source format is not supported by WIC, so we have to convert, resize, and convert back
                hr = _PerformResizeViaF32( *srcimg, filter, *destimg );
            }

            if ( FAILED(hr) )
            {
                result.Release();
                return hr;
            }
        }
        break;

    default:
        result.Release();
        return E_FAIL;
    }

    return S_OK;
}

HRESULT DirectX::Resize | ( | _In_ const Image & | srcImage,
 |  | _In_ size_t | width,
 |  | _In_ size_t | height,
 |  | _In_ DWORD | filter,
 |  | _Out_ ScratchImage & | image
 | ) |  |
HRESULT DirectX::SaveToDDSFile | ( | _In_ const Image & | image,
 |  | _In_ DWORD | flags,
 |  | _In_ LPCWSTR | szFile
 | ) |  |
HRESULT DirectX::SaveToDDSFile | ( | _In_reads_(nimages) const Image * | images,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DWORD | flags,
 |  | _In_ LPCWSTR | szFile
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::SaveToDDSFile | ( | const Image & | image,
 |  | DWORD | flags,
 |  | LPCWSTR | szFile |
 | ) |  |  | [inline]

Definition at line 210 of file DirectXTex.h.

    {
    public:
        Blob() : _buffer(0), _size(0) {}
        ~Blob() { Release(); }

HRESULT DirectX::SaveToDDSMemory | ( | _In_reads_(nimages) const Image * | images,
 |  | _In_ size_t | nimages,
 |  | _In_ const TexMetadata & | metadata,
 |  | _In_ DWORD | flags,
 |  | _Out_ Blob & | blob
 | ) |  |
HRESULT DirectX::SaveToDDSMemory | ( | _In_ const Image & | image,
 |  | _In_ DWORD | flags,
 |  | _Out_ Blob & | blob
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::SaveToDDSMemory | ( | const Image & | image,
 |  | DWORD | flags,
 |  | Blob & | blob |
 | ) |  |  | [inline]

Definition at line 194 of file DirectXTex.h.

                                               { return _metadata; }
        const Image* GetImage(_In_ size_t mip, _In_ size_t item, _In_ size_t slice) const;

        const Image* GetImages() const { return _image; }
        size_t GetImageCount() const { return _nimages; }

        uint8_t* GetPixels() const { return _memory; }
        size_t GetPixelsSize() const { return _size; }

    private:
        size_t      _nimages;
        size_t      _size;
        TexMetadata _metadata;

HRESULT DirectX::SaveToTGAFile | ( | _In_ const Image & | image,
 |  | _In_ LPCWSTR | szFile
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::SaveToTGAFile | ( | const Image & | image,
 |  | LPCWSTR | szFile
 | ) |  |

Definition at line 1277 of file DirectXTexTGA.cpp.

{
    if ( !szFile )
        return E_INVALIDARG;

    if ( !image.pixels )
        return E_POINTER;

    TGA_HEADER tga_header;
    DWORD convFlags = 0;
    HRESULT hr = _EncodeTGAHeader( image, tga_header, convFlags );
    if ( FAILED(hr) )
        return hr;

    // Create file and write header
#if (_WIN32_WINNT >= _WIN32_WINNT_WIN8)
    ScopedHandle hFile( safe_handle( CreateFile2( szFile, GENERIC_WRITE, 0, CREATE_ALWAYS, 0 ) ) );
#else
    ScopedHandle hFile( safe_handle( CreateFileW( szFile, GENERIC_WRITE, 0, 0, CREATE_ALWAYS, 0, 0 ) ) );
#endif
    if ( !hFile )
    {
        return HRESULT_FROM_WIN32( GetLastError() );
    }

    // Determine size for TGA pixel data
    size_t rowPitch, slicePitch;
    if ( convFlags & CONV_FLAGS_888 )
    {
        rowPitch = image.width * 3;
        slicePitch = image.height * rowPitch;
    }
    else
    {
        ComputePitch( image.format, image.width, image.height, rowPitch, slicePitch, CP_FLAGS_NONE );
    }

    if ( slicePitch < 65535 )
    {
        // For small images, it is better to create an in-memory file and write it out
        Blob blob;

        hr = SaveToTGAMemory( image, blob );
        if ( FAILED(hr) )
            return hr;

        // Write blob
        const DWORD bytesToWrite = static_cast<DWORD>( blob.GetBufferSize() );
        DWORD bytesWritten;
        if ( !WriteFile( hFile.get(), blob.GetBufferPointer(), bytesToWrite,
                         &bytesWritten, 0 ) )
        {
            return HRESULT_FROM_WIN32( GetLastError() );
        }

        if ( bytesWritten != bytesToWrite )
        {
            return E_FAIL;
        }
    }
    else
    {
        // Otherwise, write the image one scanline at a time...
        std::unique_ptr<uint8_t[]> temp( new uint8_t[ rowPitch ] );
        if ( !temp )
            return E_OUTOFMEMORY;

        // Write header
        DWORD bytesWritten;
        if ( !WriteFile( hFile.get(), &tga_header, sizeof(TGA_HEADER), &bytesWritten, 0 ) )
        {
            return HRESULT_FROM_WIN32( GetLastError() );
        }

        if ( bytesWritten != sizeof(TGA_HEADER) )
            return E_FAIL;

        // Write pixels
        const uint8_t* pPixels = reinterpret_cast<const uint8_t*>( image.pixels );

        for( size_t y = 0; y < image.height; ++y )
        {
            // Copy pixels
            if ( convFlags & CONV_FLAGS_888 )
            {
                _Copy24bppScanline( temp.get(), rowPitch, pPixels, image.rowPitch );
            }
            else if ( convFlags & CONV_FLAGS_SWIZZLE )
            {
                _SwizzleScanline( temp.get(), rowPitch, pPixels, image.rowPitch, image.format, TEXP_SCANLINE_NONE );
            }
            else
            {
                _CopyScanline( temp.get(), rowPitch, pPixels, image.rowPitch, image.format, TEXP_SCANLINE_NONE );
            }

            pPixels += image.rowPitch;

            if ( !WriteFile( hFile.get(), temp.get(), static_cast<DWORD>( rowPitch ), &bytesWritten, 0 ) )
            {
                return HRESULT_FROM_WIN32( GetLastError() );
            }

            if ( bytesWritten != rowPitch )
                return E_FAIL;
        }
    }

    return S_OK;
}

HRESULT DirectX::SaveToTGAMemory | ( | _In_ const Image & | image,
 |  | _Out_ Blob & | blob
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::SaveToTGAMemory | ( | const Image & | image,
 |  | Blob & | blob
 | ) |  |

Definition at line 1211 of file DirectXTexTGA.cpp.

{
    if ( !image.pixels )
        return E_POINTER;

    TGA_HEADER tga_header;
    DWORD convFlags = 0;
    HRESULT hr = _EncodeTGAHeader( image, tga_header, convFlags );
    if ( FAILED(hr) )
        return hr;

    blob.Release();

    // Determine memory required for image data
    size_t rowPitch, slicePitch;
    if ( convFlags & CONV_FLAGS_888 )
    {
        rowPitch = image.width * 3;
        slicePitch = image.height * rowPitch;
    }
    else
    {
        ComputePitch( image.format, image.width, image.height, rowPitch, slicePitch, CP_FLAGS_NONE );
    }

    hr = blob.Initialize( sizeof(TGA_HEADER) + slicePitch );
    if ( FAILED(hr) )
        return hr;

    // Copy header
    uint8_t* dPtr = reinterpret_cast<uint8_t*>( blob.GetBufferPointer() );
    assert( dPtr != 0 );
    memcpy_s( dPtr, blob.GetBufferSize(), &tga_header, sizeof(TGA_HEADER) );
    dPtr += sizeof(TGA_HEADER);

    const uint8_t* pPixels = reinterpret_cast<const uint8_t*>( image.pixels );
    assert( pPixels );

    for( size_t y = 0; y < image.height; ++y )
    {
        // Copy pixels
        if ( convFlags & CONV_FLAGS_888 )
        {
            _Copy24bppScanline( dPtr, rowPitch, pPixels, image.rowPitch );
        }
        else if ( convFlags & CONV_FLAGS_SWIZZLE )
        {
            _SwizzleScanline( dPtr, rowPitch, pPixels, image.rowPitch, image.format, TEXP_SCANLINE_NONE );
        }
        else
        {
            _CopyScanline( dPtr, rowPitch, pPixels, image.rowPitch, image.format, TEXP_SCANLINE_NONE );
        }

        dPtr += rowPitch;
        pPixels += image.rowPitch;
    }

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::SaveToWICFile | ( | const Image & | image,
 |  | DWORD | flags,
 |  | REFGUID | guidContainerFormat,
 |  | LPCWSTR | szFile
 | ) |  |

Definition at line 891 of file DirectXTexWIC.cpp.

{
    if ( !szFile )
        return E_INVALIDARG;

    if ( !image.pixels )
        return E_POINTER;

    IWICImagingFactory* pWIC = _GetWIC();
    if ( !pWIC )
        return E_NOINTERFACE;

    ScopedObject<IWICStream> stream;
    HRESULT hr = pWIC->CreateStream( &stream );
    if ( FAILED(hr) )
        return hr;

    hr = stream->InitializeFromFilename( szFile, GENERIC_WRITE );
    if ( FAILED(hr) )
        return hr;

    hr = _EncodeSingleFrame( image, flags, guidContainerFormat, stream.Get() );
    if ( FAILED(hr) )
        return hr;

    return S_OK;
}

HRESULT DirectX::SaveToWICFile | ( | _In_reads_(nimages) const Image * | images,
 |  | _In_ size_t | nimages,
 |  | _In_ DWORD | flags,
 |  | _In_ REFGUID | guidContainerFormat,
 |  | _In_ LPCWSTR | szFile
 | ) |  |
HRESULT DirectX::SaveToWICFile | ( | _In_ const Image & | image,
 |  | _In_ DWORD | flags,
 |  | _In_ REFGUID | guidContainerFormat,
 |  | _In_ LPCWSTR | szFile
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::SaveToWICFile | ( | const Image * | images,
 |  | size_t | nimages,
 |  | DWORD | flags,
 |  | REFGUID | guidContainerFormat,
 |  | LPCWSTR | szFile
 | ) |  |

Definition at line 920 of file DirectXTexWIC.cpp.

{
    if ( !szFile || !images || nimages == 0 )
        return E_INVALIDARG;

    IWICImagingFactory* pWIC = _GetWIC();
    if ( !pWIC )
        return E_NOINTERFACE;

    ScopedObject<IWICStream> stream;
    HRESULT hr = pWIC->CreateStream( &stream );
    if ( FAILED(hr) )
        return hr;

    hr = stream->InitializeFromFilename( szFile, GENERIC_WRITE );
    if ( FAILED(hr) )
        return hr;

    if ( nimages > 1 )
        hr = _EncodeMultiframe( images, nimages, flags, guidContainerFormat, stream.Get() );
    else
        hr = _EncodeSingleFrame( images[0], flags, guidContainerFormat, stream.Get() );

    if ( FAILED(hr) )
        return hr;

    return S_OK;
}

_Use_decl_annotations_ HRESULT DirectX::SaveToWICMemory | ( | const Image * | images,
 |  | size_t | nimages,
 |  | DWORD | flags,
 |  | REFGUID | guidContainerFormat,
 |  | Blob & | blob
 | ) |  |

Definition at line 837 of file DirectXTexWIC.cpp.

{
    if ( !images || nimages == 0 )
        return E_INVALIDARG;

    blob.Release();

    ScopedObject<IStream> stream;
    HRESULT hr = CreateStreamOnHGlobal( 0, TRUE, &stream );
    if ( FAILED(hr) )
        return hr;

    if ( nimages > 1 )
        hr = _EncodeMultiframe( images, nimages, flags, guidContainerFormat, stream.Get() );
    else
        hr = _EncodeSingleFrame( images[0], flags, guidContainerFormat, stream.Get() );

    if ( FAILED(hr) )
        return hr;

    // Copy stream data into blob
    STATSTG stat;
    hr = stream->Stat( &stat, STATFLAG_NONAME );
    if ( FAILED(hr) )
        return hr;

    if ( stat.cbSize.HighPart > 0 )
        return HRESULT_FROM_WIN32( ERROR_FILE_TOO_LARGE );

    hr = blob.Initialize( stat.cbSize.LowPart );
    if ( FAILED(hr) )
        return hr;

    LARGE_INTEGER li = { 0 };
    hr = stream->Seek( li, STREAM_SEEK_SET, 0 );
    if ( FAILED(hr) )
        return hr;

    DWORD bytesRead;
    hr = stream->Read( blob.GetBufferPointer(), static_cast<ULONG>( blob.GetBufferSize() ), &bytesRead );
    if ( FAILED(hr) )
        return hr;

    if ( bytesRead != blob.GetBufferSize() )
        return E_FAIL;

    return S_OK;
}

HRESULT DirectX::SaveToWICMemory | ( | _In_ const Image & | image,
 |  | _In_ DWORD | flags,
 |  | _In_ REFGUID | guidContainerFormat,
 |  | _Out_ Blob & | blob
 | ) |  |
HRESULT DirectX::SaveToWICMemory | ( | _In_reads_(nimages) const Image * | images,
 |  | _In_ size_t | nimages,
 |  | _In_ DWORD | flags,
 |  | _In_ REFGUID | guidContainerFormat,
 |  | _Out_ Blob & | blob
 | ) |  |
_Use_decl_annotations_ HRESULT DirectX::SaveToWICMemory | ( | const Image & | image,
 |  | DWORD | flags,
 |  | REFGUID | guidContainerFormat,
 |  | Blob & | blob
 | ) |  |

Definition at line 791 of file DirectXTexWIC.cpp.

{
    if ( !image.pixels )
        return E_POINTER;

    blob.Release();

    ScopedObject<IStream> stream;
    HRESULT hr = CreateStreamOnHGlobal( 0, TRUE, &stream );
    if ( FAILED(hr) )
        return hr;

    hr = _EncodeSingleFrame( image, flags, guidContainerFormat, stream.Get() );
    if ( FAILED(hr) )
        return hr;

    // Copy stream data into blob
    STATSTG stat;
    hr = stream->Stat( &stat, STATFLAG_NONAME );
    if ( FAILED(hr) )
        return hr;

    if ( stat.cbSize.HighPart > 0 )
        return HRESULT_FROM_WIN32( ERROR_FILE_TOO_LARGE );

    hr = blob.Initialize( stat.cbSize.LowPart );
    if ( FAILED(hr) )
        return hr;

    LARGE_INTEGER li = { 0 };
    hr = stream->Seek( li, STREAM_SEEK_SET, 0 );
    if ( FAILED(hr) )
        return hr;

    DWORD bytesRead;
    hr = stream->Read( blob.GetBufferPointer(), static_cast<ULONG>( blob.GetBufferSize() ), &bytesRead );
    if ( FAILED(hr) )
        return hr;

    if ( bytesRead != blob.GetBufferSize() )
        return E_FAIL;

    return S_OK;
}

Variable Documentation

const uint32_t DirectX::BC67_WEIGHT_MAX = 64

Definition at line 54 of file BC.h.

const uint32_t DirectX::BC67_WEIGHT_ROUND = 32

Definition at line 56 of file BC.h.

const uint32_t DirectX::BC67_WEIGHT_SHIFT = 6

Definition at line 55 of file BC.h.

const size_t DirectX::BC6H_MAX_SHAPES = 32

Definition at line 49 of file BC.h.

const size_t DirectX::BC6H_NUM_CHANNELS = 3

Definition at line 48 of file BC.h.

const size_t DirectX::BC7_MAX_SHAPES = 64

Definition at line 52 of file BC.h.

const size_t DirectX::BC7_NUM_CHANNELS = 4

Definition at line 51 of file BC.h.

_In_ size_t _In_ DXGI_FORMAT _In_ size_t DirectX::count

Definition at line 167 of file DirectXTexP.h.

_In_ size_t _In_ const TexMetadata _In_ DWORD DirectX::cpFlags

Definition at line 110 of file DirectXTexP.h.

const uint32_t DirectX::DDS_MAGIC = 0x20534444

Definition at line 35 of file DDS.h.

const uint16_t DirectX::F16EM_MASK = 0x7fff

Definition at line 36 of file BC.h.

const uint16_t DirectX::F16MAX = 0x7bff

Definition at line 37 of file BC.h.

const uint16_t DirectX::F16S_MASK = 0x8000

Definition at line 35 of file BC.h.

_In_ size_t _In_ DXGI_FORMAT _In_ size_t _In_ DXGI_FORMAT _In_ DWORD DirectX::flags

Definition at line 163 of file DirectXTexP.h.

_In_ size_t _In_ DXGI_FORMAT DirectX::format

Definition at line 168 of file DirectXTexP.h.

const int DirectX::g_aWeights2 = {0, 21, 43, 64}

Definition at line 31 of file BC6HBC7.cpp.

const int DirectX::g_aWeights3 = {0, 9, 18, 27, 37, 46, 55, 64}

Definition at line 32 of file BC6HBC7.cpp.

const int DirectX::g_aWeights4 = {0, 4, 9, 13, 17, 21, 26, 30, 34, 38, 43, 47, 51, 55, 60, 64}

Definition at line 33 of file BC6HBC7.cpp.

const LegacyDDS DirectX::g_LegacyDDSMap[]

Definition at line 47 of file DirectXTexDDS.cpp.

_In_ size_t _In_ DXGI_FORMAT _In_ size_t _In_ DXGI_FORMAT DirectX::inFormat

Definition at line 653 of file DirectXTexDDS.cpp.

_In_ size_t _In_ DXGI_FORMAT _In_ size_t DirectX::inSize

Definition at line 653 of file DirectXTexDDS.cpp.

_In_ size_t _In_ const TexMetadata& DirectX::metadata

Definition at line 110 of file DirectXTexP.h.

_In_ size_t _In_ const TexMetadata _In_ DWORD _In_ size_t DirectX::nImages

Definition at line 112 of file DirectXTexP.h.

_In_ size_t _In_ DXGI_FORMAT DirectX::outFormat

Definition at line 652 of file DirectXTexDDS.cpp.

_In_ size_t DirectX::outSize

Definition at line 652 of file DirectXTexDDS.cpp.

_In_ size_t DirectX::pixelSize

Definition at line 110 of file DirectXTexP.h.

_In_ size_t DirectX::size

Definition at line 168 of file DirectXTexP.h.

Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DX Namespace Reference

  • Namespace List
  • Namespace Members
Functions

DX Namespace Reference

Functions

void ThrowIfFailed (HRESULT hr)

Function Documentation

void DX::ThrowIfFailed ( HRESULT hr ) [inline]

Definition at line 13 of file DirectXSample.h.

    {
        if (FAILED(hr))
        {
            // Set a breakpoint on this line to catch DX API errors.
            throw Platform::Exception::CreateException(hr);
        }
    }

Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EdgeGestureSample Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

EdgeGestureSample Namespace Reference

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum EdgeGestureSample::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 32 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: FontEnumeration Namespace Reference

  • Namespace List
  • Namespace Members
Classes

FontEnumeration Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameConstants Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces

GameConstants Namespace Reference

Namespaces

namespace | Physics
namespace | Sound
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameConstants::Physics Namespace Reference

  • Namespace List
  • Namespace Members
  • GameConstants
  • Physics

GameConstants::Physics Namespace Reference

Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameConstants::Sound Namespace Reference

  • Namespace List
  • Namespace Members
  • GameConstants
  • Sound

GameConstants::Sound Namespace Reference

Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: GameInfoOverlayConstant Namespace Reference

  • Namespace List
  • Namespace Members

GameInfoOverlayConstant Namespace Reference

Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations | Functions

Hilo Namespace Reference

Namespaces

namespace | Common

Classes

class | CalendarExtensions
class | DebugLoggingExceptionPolicy
class | ExceptionPolicy
class | ExceptionPolicyFactory
class | ExifExtensions
class | FileSystemRepository
class | HiloPage
class | ImageBase
class | ImageNavigationData
interface | IMonthBlock
interface | IPhoto
interface | IPhotoGroup
interface | IResizable
interface | IResourceLoader
interface | IYearGroup
class | NullPhotoGroup
class | ObservableQuery
struct | ObserveException
class | PhotoCache
struct | PhotoPathComparer
class | RandomPhotoSelector
class | Repository
class | sealed
Provides application-specific behavior to supplement the default Application class. More...
class | ThumbnailGenerator
class | TileUpdateScheduler
class | ViewModelBase
class | WideFiveImageTile

Enumerations

enum | ExifRotations { NotRotated = 1, RotatedDown = 3, RotatedLeft = 6, RotatedRight = 8 }
enum | HubGroupType { Pictures, Favorites }
enum PageType {
Hub, Browse, Image, Crop,
Rotate, Cartoonize
}

Functions

public delegate bool | CanExecuteDelegate (Platform::Object^parameter)
concurrency::task< void > | create_empty_task ()
template<typename Result >
concurrency::task< Result > | create_task_from_result (Result result)
public delegate void | ExecuteDelegate (Platform::Object^parameter)
public delegate void | NavigateEventHandler ()
public delegate void | PageNavigateEventHandler (PageType page, Platform::Object^parameter)
void | run_async_non_interactive (std::function< void()> &&action)

Enumeration Type Documentation

enum Hilo::ExifRotations
Enumerator:
NotRotated
RotatedDown
RotatedLeft
RotatedRight

Definition at line 12 of file ExifExtensions.h.

    {
        NotRotated = 1,
        RotatedDown = 3,
        RotatedLeft = 6,
        RotatedRight = 8
    };

enum Hilo::HubGroupType
Enumerator:
Pictures
Favorites

Definition at line 11 of file HubGroupType.h.

    {
        Pictures,
        Favorites
    };

enum Hilo::PageType
Enumerator:
Hub
Browse
Image
Crop
Rotate
Cartoonize

Definition at line 11 of file PageType.h.

    {
        Hub,
        Browse,
        Image,
        Crop,
        Rotate,
        Cartoonize
    };

Function Documentation

public delegate bool Hilo::CanExecuteDelegate ( Platform::Object^ parameter )
concurrency::task<void> Hilo::create_empty_task ( ) [inline]

Definition at line 19 of file TaskExtensions.h.

    {
        return concurrency::create_task([]{});
    }

template<typename Result >
concurrency::task<Result> Hilo::create_task_from_result ( Result result ) [inline]

Definition at line 13 of file TaskExtensions.h.

    {
        return concurrency::create_task([result]() -> Result { return result; });
    }

public delegate void Hilo::ExecuteDelegate ( Platform::Object^ parameter )
public delegate void Hilo::NavigateEventHandler ( )
public delegate void Hilo::PageNavigateEventHandler | ( | PageType | page,
 |  | Platform::Object^ | parameter
 | ) |  |
void Hilo::run_async_non_interactive ( std::function< void()> && action )
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • Hilo
  • Common
Classes

Hilo::Common Namespace Reference

Classes

class | BindableBase
Implementation of INotifyPropertyChanged to simplify models. More...
class | LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...
class | sealed
Value converter that translates true to false and vice versa. More...
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: InvertTransform Namespace Reference

  • Namespace List
  • Namespace Members

InvertTransform Namespace Reference

Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LanguageFontCPP Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

LanguageFontCPP Namespace Reference

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum LanguageFontCPP::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 20 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LockScreenAppsCPP Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

LockScreenAppsCPP Namespace Reference

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum LockScreenAppsCPP::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 20 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Magazine Namespace Reference

  • Namespace List
  • Namespace Members
Classes

Magazine Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MEDIA Namespace Reference

  • Namespace List
  • Namespace Members
Functions

MEDIA Namespace Reference

Functions

void ThrowIfFailed (HRESULT hr)

Function Documentation

void MEDIA::ThrowIfFailed ( HRESULT hr ) [inline]

Definition at line 25 of file meplayer.h.

    {
        if (FAILED(hr))
        {
            // Set a breakpoint on this line to catch DirectX API errors
            throw Platform::Exception::CreateException(hr);
        }
    }

Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaCapture Namespace Reference

  • Namespace List
  • Namespace Members
Classes

MediaCapture Namespace Reference

Classes

class | AudioCapture
An empty page that can be used on its own or navigated to within a Frame. More...
class | BasicCapture
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCPP Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

MediaExtensionsCPP Namespace Reference

Classes

class | App
class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum MediaExtensionsCPP::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 30 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaExtensionsCS Namespace Reference

  • Namespace List
  • Namespace Members
Classes

MediaExtensionsCS Namespace Reference

Classes

class | App
class | ScenarioInput1
class | ScenarioInput2
class | ScenarioInput3
class | ScenarioInput4
class | ScenarioList
class | ScenarioOutput1
class | ScenarioOutput2
class | ScenarioOutput3
class | ScenarioOutput4
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource Namespace Reference

  • Namespace List
  • Namespace Members
Classes

MediaStreamSource Namespace Reference

Classes

class | AudioSource
An empty page that can be used on its own or navigated to within a Frame. More...
class | PcmSource
A simple media source generating audio wave. More...
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Microsoft Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces

Microsoft Namespace Reference

Namespaces

namespace Samples
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Microsoft::Samples Namespace Reference

  • Namespace List
  • Namespace Members
  • Microsoft
  • Samples
Functions

Microsoft::Samples Namespace Reference

Functions

ActivatableClass (CGrayscale)
ActivatableClass (CGeometricSchemeHandler)
ActivatableClass (CPolarEffect)
ActivatableClass (CMPEG1ByteStreamHandler)
ActivatableClass (CDecoder)
ActivatableClass (CInvert)

Function Documentation

Microsoft::Samples::ActivatableClass ( CGrayscale )
Microsoft::Samples::ActivatableClass ( CGeometricSchemeHandler )
Microsoft::Samples::ActivatableClass ( CPolarEffect )
Microsoft::Samples::ActivatableClass ( CMPEG1ByteStreamHandler )
Microsoft::Samples::ActivatableClass ( CDecoder )
Microsoft::Samples::ActivatableClass ( CInvert )
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MoveLookControllerConstants Namespace Reference

  • Namespace List
  • Namespace Members

MoveLookControllerConstants Namespace Reference

Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MPEG1Source Namespace Reference

  • Namespace List
  • Namespace Members

MPEG1Source Namespace Reference

Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NetworkStatusTask Namespace Reference

  • Namespace List
  • Namespace Members
Classes

NetworkStatusTask Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes

NotificationsExtensions Namespace Reference

Namespaces

namespace | BadgeContent
namespace | TileContent
namespace | ToastContent

Classes

class | NotificationBase
Base class for the notification content creation helper classes. More...
class | NotificationContentImage
class | NotificationContentText
class | NotificationContentValidationException
Exception returned when invalid notification content is provided. More...
class | Util
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::BadgeContent Namespace Reference

  • Namespace List
  • Namespace Members
  • NotificationsExtensions
  • BadgeContent
Classes

NotificationsExtensions::BadgeContent Namespace Reference

Classes

class | BadgeGlyphNotificationContent
Notification content object to display a glyph on a tile's badge. More...
class | BadgeNumericNotificationContent
Notification content object to display a number on a tile's badge. More...
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::TileContent Namespace Reference

  • Namespace List
  • Namespace Members
  • NotificationsExtensions
  • TileContent
Classes

NotificationsExtensions::TileContent Namespace Reference

Classes

interface | ISquareTileInternal
class | TileContentFactory
A factory which creates tile content objects for all of the toast template types. More...
class | TileNotificationBase
class | TileSquareBase
class | TileSquareBlock
class | TileSquareImage
class | TileSquarePeekImageAndText01
class | TileSquarePeekImageAndText02
class | TileSquarePeekImageAndText03
class | TileSquarePeekImageAndText04
class | TileSquareText01
class | TileSquareText02
class | TileSquareText03
class | TileSquareText04
class | TileWideBase
class | TileWideBlockAndText01
class | TileWideBlockAndText02
class | TileWideImage
class | TileWideImageAndText01
class | TileWideImageAndText02
class | TileWideImageCollection
class | TileWidePeekImage01
class | TileWidePeekImage02
class | TileWidePeekImage03
class | TileWidePeekImage04
class | TileWidePeekImage05
class | TileWidePeekImage06
class | TileWidePeekImageAndText01
class | TileWidePeekImageAndText02
class | TileWidePeekImageCollection01
class | TileWidePeekImageCollection02
class | TileWidePeekImageCollection03
class | TileWidePeekImageCollection04
class | TileWidePeekImageCollection05
class | TileWidePeekImageCollection06
class | TileWideSmallImageAndText01
class | TileWideSmallImageAndText02
class | TileWideSmallImageAndText03
class | TileWideSmallImageAndText04
class | TileWideSmallImageAndText05
class | TileWideText01
class | TileWideText02
class | TileWideText03
class | TileWideText04
class | TileWideText05
class | TileWideText06
class | TileWideText07
class | TileWideText08
class | TileWideText09
class | TileWideText10
class | TileWideText11
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: NotificationsExtensions::ToastContent Namespace Reference

  • Namespace List
  • Namespace Members
  • NotificationsExtensions
  • ToastContent
Classes

NotificationsExtensions::ToastContent Namespace Reference

Classes

class | ToastAudio
class | ToastContentFactory
A factory which creates toast content objects for all of the toast template types.
class | ToastImageAndText01
class | ToastImageAndText02
class | ToastImageAndText03
class | ToastImageAndText04
class | ToastNotificationBase
class | ToastText01
class | ToastText02
class | ToastText03
class | ToastText04
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PolarTransform Namespace Reference

  • Namespace List
  • Namespace Members

PolarTransform Namespace Reference

Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Postcard Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Functions

Postcard Namespace Reference

Classes

class | sealed

Functions

public delegate void | ButtonClickedHandler (void)
public delegate void | EffectIntensityChangedHandler (Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
public delegate void | SignatureButtonClickedHandler (void)
public delegate void | TextSubmittedHandler (Platform::String^)

Function Documentation

public delegate void Postcard::ButtonClickedHandler ( void )
public delegate void Postcard::EffectIntensityChangedHandler ( Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e )
public delegate void Postcard::SignatureButtonClickedHandler ( void )
public delegate void Postcard::TextSubmittedHandler ( Platform::String^ )
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PrintSample Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

PrintSample Namespace Reference

Classes

class | BasePrintPage
class | InvalidPageException
class | PageDescription
Printable page description. More...
class | sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Enumerations

enum | DisplayContent { Text = 1, Images = 2, TextAndImages = 3 }
enum | NotifyType { StatusMessage, ErrorMessage }
enum | PhotoSize { psFullPage, ps4x6, ps5x7, ps8x10 }
enum | Scaling { sShrinkToFit, sCrop }

Enumeration Type Documentation

enum PrintSample::DisplayContent
Enumerator:
Text

Show only text.

Images

Show only images.

TextAndImages

Show a combination of images and text.

Definition at line 13 of file DisplayContent.h.

    {
        /// <summary>
        /// Show only text
        /// </summary>
        Text = 1,

        /// <summary>
        /// Show only images
        /// </summary>
        Images = 2,

        /// <summary>
        /// Show a combination of images and text
        /// </summary>
        TextAndImages = 3
    };

enum PrintSample::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 30 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

enum PrintSample::PhotoSize

Photo size options.

Enumerator:
psFullPage
ps4x6
ps5x7
ps8x10

Definition at line 28 of file ScenarioInput6.xaml.h.

                   : byte
    {
        psFullPage,
        ps4x6,
        ps5x7,
        ps8x10
    };

enum PrintSample::Scaling

Photo scaling options.

Enumerator:
sShrinkToFit
sCrop

Definition at line 39 of file ScenarioInput6.xaml.h.

                 : byte
    {
        sShrinkToFit,
        sCrop
    };

Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ProximityCPP Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

ProximityCPP Namespace Reference

Namespaces

namespace | Common

Classes

class | MainPage
struct | Scenario
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum ProximityCPP::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 25 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ProximityCPP::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • ProximityCPP
  • Common
Classes

ProximityCPP::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: RawNotificationsSampleCPP Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

RawNotificationsSampleCPP Namespace Reference

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum RawNotificationsSampleCPP::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 30 of file MainPage.xaml.h.

  {
    StatusMessage,
    ErrorMessage
  };

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Samples Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces

Samples Namespace Reference

Namespaces

namespace Devices
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Samples::Devices Namespace Reference

  • Namespace List
  • Namespace Members
  • Samples
  • Devices
Namespaces | Classes | Functions

Samples::Devices Namespace Reference

Namespaces

namespace | Details
namespace | Fx2

Classes

struct | DeviceControlResult
class | Repeater

Functions

delegate void | OnIoComplete (HRESULT Result, DWORD BytesReturned)
concurrency::task
< DeviceControlResult > 		StartIoctl (_In_ IDeviceIoControl *Device, _In_ ULONG DeviceControlCode, _In_reads_bytes_opt_(InputBufferCb) PUCHAR InputBuffer, _In_ ULONG InputBufferCb, _Out_writes_bytes_opt_(OutputBufferCb) PUCHAR OutputBuffer, _In_ ULONG OutputBufferCb, _Out_opt_ ULONG_PTR *CancelToken=NULL)

Function Documentation

delegate void Samples::Devices::OnIoComplete | ( | HRESULT | Result,
 |  | DWORD | BytesReturned
 | ) |  |

summary>wrapper class for the result of an IOCTL

concurrency::task< DeviceControlResult > Samples::Devices::StartIoctl | ( | _In_ IDeviceIoControl * | Device,
 |  | _In_ ULONG | DeviceControlCode,
 |  | _In_reads_bytes_opt_(InputBufferCb) PUCHAR | InputBuffer,
 |  | _In_ ULONG | InputBufferCb,
 |  | _Out_writes_bytes_opt_(OutputBufferCb) PUCHAR | OutputBuffer,
 |  | _In_ ULONG | OutputBufferCb,
 |  | _Out_opt_ ULONG_PTR * | CancelToken = NULL |
 | ) |  |  | [inline]

Definition at line 52 of file support.h.

        {
            concurrency::task_completion_event<DeviceControlResult> tce;
            concurrency::task<DeviceControlResult> t(tce);

            auto callback = ref new OnIoComplete(
                [tce](HRESULT Hr, DWORD Cb) {
                    tce.set(DeviceControlResult(Hr, Cb));
                }
            );

            auto cb2 = (IDeviceRequestCompletionCallback*) callback;

            HRESULT hr= Device->DeviceIoControlAsync(
                                    DeviceControlCode,
                                    InputBuffer,
                                    InputBufferCb,
                                    OutputBuffer,
                                    OutputBufferCb,
                                    cb2,
                                    CancelToken
                                    );

            if (hr != S_OK) {
                tce.set(DeviceControlResult(hr, 0));
            }

            return t;
        }

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Samples::Devices::Details Namespace Reference

  • Namespace List
  • Namespace Members
  • Samples
  • Devices
  • Details
Typedefs

Samples::Devices::Details Namespace Reference

Typedefs

typedef std::function< void(void)> | RepeaterStoppedFunction
typedef concurrency::task< bool > | RepeaterTaskType
typedef std::function
< RepeaterTaskType(concurrency::cancellation_token,
concurrency::task_continuation_context)> 		StartRepeaterTaskFunction

Typedef Documentation

typedef std::function< void(void)> Samples::Devices::Details::RepeaterStoppedFunction

Definition at line 25 of file repeater.h.

typedef concurrency::task< bool > Samples::Devices::Details::RepeaterTaskType

Definition at line 18 of file repeater.h.

typedef std::function< RepeaterTaskType(concurrency::cancellation_token, concurrency::task_continuation_context)> Samples::Devices::Details::StartRepeaterTaskFunction

Definition at line 22 of file repeater.h.

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Samples::Devices::Fx2 Namespace Reference

  • Namespace List
  • Namespace Members
  • Samples
  • Devices
  • Fx2
Classes | Functions

Samples::Devices::Fx2 Namespace Reference

Classes

class | sealed
The device projection for an OSR Fx2 device. More...

Functions

public delegate void | SwitchStateChangedHandler (Fx2Device^Sender, SwitchStateChangedEventArgs^EventArgs)

Function Documentation

public delegate void Samples::Devices::Fx2::SwitchStateChangedHandler | ( | Fx2Device^ | Sender,
 |  | SwitchStateChangedEventArgs^ | EventArgs
 | ) |  |
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SampleSettings Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces

SampleSettings Namespace Reference

Namespaces

namespace | DirectCompute
namespace | Manipulation
namespace | Performance
namespace | Physics
namespace | ThreePhase
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SampleSettings::DirectCompute Namespace Reference

  • Namespace List
  • Namespace Members
  • SampleSettings
  • DirectCompute

SampleSettings::DirectCompute Namespace Reference

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SampleSettings::Manipulation Namespace Reference

  • Namespace List
  • Namespace Members
  • SampleSettings
  • Manipulation

SampleSettings::Manipulation Namespace Reference

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SampleSettings::Performance Namespace Reference

  • Namespace List
  • Namespace Members
  • SampleSettings
  • Performance

SampleSettings::Performance Namespace Reference

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SampleSettings::Physics Namespace Reference

  • Namespace List
  • Namespace Members
  • SampleSettings
  • Physics

SampleSettings::Physics Namespace Reference

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SampleSettings::ThreePhase Namespace Reference

  • Namespace List
  • Namespace Members
  • SampleSettings
  • ThreePhase

SampleSettings::ThreePhase Namespace Reference

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ScheduledNotificationsSampleCPP Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

ScheduledNotificationsSampleCPP Namespace Reference

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum ScheduledNotificationsSampleCPP::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 20 of file MainPage.xaml.h.

  {
    StatusMessage,
    ErrorMessage
  };

Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample Namespace Reference

Main Page

Namespaces

Classes

Files

Directories

Namespace List

Namespace Members

Namespaces | Classes | Typedefs | Enumerations | Functions

SDKSample Namespace Reference

Namespaces

namespace

AccelerometerCPP

namespace

Accessibility

namespace

Animation

namespace

AnimationMetrics

namespace

ApplicationDataSample

namespace

ApplicationResources

namespace

ApplicationSettings

namespace

AtomPub

namespace

BackgroundTask

namespace

BackgroundTransfer

namespace

CalendarSample

namespace

CallControl

namespace

CameraCapture

namespace

CameraOptions

namespace

CertificateEnrollment

namespace

Common

namespace

CompassCPP

namespace

Compression

namespace

ContextMenu

namespace

CryptoWinRT

namespace

CustomDeviceAccess

namespace

DataBinding

namespace

DataReaderWriter

namespace

DateTimeFormatting

namespace

DeviceCaps

namespace

DeviceEnumeration

namespace

DisplayOrientation

namespace

Drawing

namespace

EAS

namespace

ELS

namespace

ExpressionBlendSampleDataSampleDataSource

namespace

FileAccess

namespace

FilePicker

namespace

FilePickerContracts

namespace

FileSearch

namespace

FileThumbnails

namespace

FlipViewCPP

namespace

FlipViewData

namespace

FolderEnumeration

namespace

GeolocationCPP

namespace

GlobalizationPreferencesSample

namespace

GyrometerCPP

namespace

HighContrast

namespace

HomeGroup

namespace

HttpClientSample

namespace

Images

namespace

InclinometerCPP

namespace

IsRemoteSession

namespace

LightSensorCPP

namespace

ListViewSampleDataSource

namespace

ListViewSimple

namespace

MediaButtons

namespace

MediaCapture

namespace

MediaServerClient

namespace

MessageDialogSample

namespace

MicrosoftAccount

namespace

NetworkInformationApi

namespace

NumberFormatting

namespace

OrientationSensorCPP

namespace

PackageSample

namespace

PasswordVaultCPP

namespace

PersonalityAnimations

namespace

Personalization

namespace

PlaybackManager

namespace

PlaybackManager2

namespace

Playlists

namespace

PlayTo

namespace

PlayToreceiver

namespace

PortableDeviceCPP

namespace

ProvisioningAgent

namespace

RemovableStorageCPP

namespace

Rotation

namespace

Scaling

namespace

ScrollViewerCPP

namespace

SDKTemplate

namespace

SearchContract

namespace

ShareSource

namespace

SimpleOrientationSensorCPP

namespace

SnapSample

namespace

SplashScreen

namespace

StoreSample

namespace

Syndication

namespace

TextDisplay

namespace

TextEditing

namespace

ThreadPool

namespace

Tiles

namespace

TouchKeyboard

namespace

TouchKeyboardTextInput

namespace

Transcode

namespace

Transforms

namespace

UserAndCustomControls

namespace

UserDomainName

namespace

UssdApi

namespace

WASAPIAudio

namespace

WebAuthentication

namespace

WebSocket

namespace

WebViewControl

namespace

XAMLPopup

Classes

class

App

class

BackgroundTaskSample

class

CoTaskMemFreeArray

struct

CoTaskMemFreeStruct

class

Errors

class

FileExtensions

class

Finally

class

Helpers

class

MainPage

struct

PropVariantClearStruct

struct

Scenario

class

sealed

class

Status

class

StringHelper

class

StringTrimmer

Typedefs

typedef std::unique_ptr
< wchar_t, CoTaskMemFreeStruct >

CoTaskMemString

typedef std::unique_ptr
< PROPVARIANT,
PropVariantClearStruct >

PropVariantPtr

Enumerations

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

enum

NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

Functions

Microsoft::WRL::ComPtr
< IPortableDeviceValues >

GetClientInfo ()

Platform::String

GetFirstStorageId (_In_ IPortableDevice *device)

ULONGLONG

StreamCopy (_In_ IStream *destStream, _In_ IStream *sourceStream, DWORD transferSizeBytes)

void

ThrowIfFailed (HRESULT hr)

Typedef Documentation

typedef std::unique_ptr<wchar_t, CoTaskMemFreeStruct> SDKSample::CoTaskMemString

Definition at line 58 of file Constants.h.

typedef std::unique_ptr<PROPVARIANT, PropVariantClearStruct> SDKSample::PropVariantPtr

Definition at line 68 of file Constants.h.

Enumeration Type Documentation

enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 16 of file Constants.h.
    {
        StatusMessage,
        ErrorMessage,
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
enum SDKSample::NotifyType

Enumerator:

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

StatusMessage

ErrorMessage

Definition at line 25 of file MainPage.xaml.h.
    {
        StatusMessage,
        ErrorMessage
    };
Function Documentation

ComPtr< IPortableDeviceValues > SDKSample::GetClientInfo

(

)

Returns an IPortableDeviceValues containing information about this client app.

Returns:

The client information.

Definition at line 54 of file Constants.cpp.
{
    ComPtr<IPortableDeviceValues> result;

    ThrowIfFailed(CoCreateInstance(CLSID_PortableDeviceValues, nullptr, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&result)));

    result->SetStringValue(WPD_CLIENT_NAME, MainPage::FEATURE_NAME->Begin());
    result->SetUnsignedIntegerValue(WPD_CLIENT_MAJOR_VERSION, 1);
    result->SetUnsignedIntegerValue(WPD_CLIENT_MINOR_VERSION, 0);
    result->SetUnsignedIntegerValue(WPD_CLIENT_REVISION, 0);
    return result;
}
String SDKSample::GetFirstStorageId

(

_In_ IPortableDevice *

device

)

Returns the first storage object identifier for a portable device.

Parameters:

device

Pointer to the IPortableDevice for a portable device.

Returns:

Object identifier string for the first storage on the device.

Definition at line 72 of file Constants.cpp.
{
    PROPVARIANT value = {};
    PropVariantPtr valuePtr(&value);
    DWORD storageCount = 0;
    String^ storageId = nullptr;
    ComPtr<IPortableDeviceCapabilities> capabilities;
    ComPtr<IPortableDevicePropVariantCollection> storageIds;

    ThrowIfFailed(device->Capabilities(&capabilities));
    if (SUCCEEDED(capabilities->GetFunctionalObjects(WPD_FUNCTIONAL_CATEGORY_STORAGE, &storageIds)))
    {
        ThrowIfFailed(storageIds->GetCount(&storageCount));
        if (storageCount > 0)
        {
            ThrowIfFailed(storageIds->GetAt(0, &value));
            storageId = ref new String(value.pwszVal);
        }
    }
    return storageId;
}
ULONGLONG SDKSample::StreamCopy

(

_In_ IStream *

destStream,

_In_ IStream *

sourceStream,

DWORD

transferSizeBytes

)

Copies data from a source stream to a destination stream using the specified transferSizeBytes as the temporary buffer size.

Parameters:

destStream

Pointer to the destination IStream.

sourceStream

Pointer to the source IStream.

transferSizeBytes

The temporary buffer size to use during the copy.

Returns:

The total number of bytes copied to the destination stream.

Definition at line 102 of file Constants.cpp.
{
    HRESULT hr = S_OK;
    DWORD bytesRead = 0;
    ULONGLONG totalBytesWritten = 0;

    // Allocate a temporary buffer (of Optimal transfer size) for the read results to be written to.
    std::unique_ptr<BYTE[]> objectData(new BYTE[transferSizeBytes]);

    // Read until the number of bytes returned from the source stream is 0, or
    // an error occured during transfer.
    do
    {
        // Read object data from the source stream
        hr = sourceStream->Read(objectData.get(), transferSizeBytes, &bytesRead);
        if (SUCCEEDED(hr))
        {
            // Write object data to the destination stream
            DWORD bytesWritten = 0;
            hr = destStream->Write(objectData.get(), bytesRead, &bytesWritten);
            if (SUCCEEDED(hr))
            {
                totalBytesWritten += bytesWritten;
            }
        }

    } while (SUCCEEDED(hr) && (bytesRead > 0));

    return totalBytesWritten;
}
void SDKSample::ThrowIfFailed

(

HRESULT

hr

)

[inline]

Definition at line 96 of file Constants.h.
    {
        if (FAILED(hr))
        {
            // Set a breakpoint on the line below to catch errors from the Portable Device APIs.
            throw Platform::Exception::CreateException(hr);
        }
    }
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by 1.7.1


Win8-Examples: SDKSample::AccelerometerCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • AccelerometerCPP
Classes

SDKSample::AccelerometerCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Accessibility Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Accessibility
Classes

SDKSample::Accessibility Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Animation Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Animation
Classes

SDKSample::Animation Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::AnimationMetrics Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • AnimationMetrics
Classes

SDKSample::AnimationMetrics Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ApplicationDataSample Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ApplicationDataSample
Classes

SDKSample::ApplicationDataSample Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ApplicationResources Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ApplicationResources
Classes

SDKSample::ApplicationResources Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ApplicationSettings Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ApplicationSettings
Classes

SDKSample::ApplicationSettings Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::AtomPub Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • AtomPub
Classes

SDKSample::AtomPub Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::BackgroundTask Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • BackgroundTask
Classes

SDKSample::BackgroundTask Namespace Reference

Classes

class | BackgroundTaskSample
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::BackgroundTransfer Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • BackgroundTransfer
Classes

SDKSample::BackgroundTransfer Namespace Reference

Classes

struct | GuidComparer
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CalendarSample Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • CalendarSample
Classes

SDKSample::CalendarSample Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CallControl Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • CallControl
Classes

SDKSample::CallControl Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CameraCapture Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • CameraCapture
Classes

SDKSample::CameraCapture Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CameraOptions Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • CameraOptions
Classes

SDKSample::CameraOptions Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CertificateEnrollment Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • CertificateEnrollment
Classes

SDKSample::CertificateEnrollment Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Common
Classes

SDKSample::Common Namespace Reference

Classes

class | LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...
class | sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...
class | SharePage
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CompassCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • CompassCPP
Classes

SDKSample::CompassCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Compression Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Compression
Classes

SDKSample::Compression Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ContextMenu Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ContextMenu
Classes

SDKSample::ContextMenu Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CryptoWinRT Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • CryptoWinRT
Classes

SDKSample::CryptoWinRT Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::CustomDeviceAccess Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • CustomDeviceAccess
Classes | Typedefs

SDKSample::CustomDeviceAccess Namespace Reference

Classes

class | DeviceList
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Typedefs

typedef
Windows::Foundation::EventHandler
< Samples::Devices::Fx2::Fx2Device^> 		DeviceClosingHandler

Typedef Documentation

typedef Windows::Foundation::EventHandler<Samples::Devices::Fx2::Fx2Device^> SDKSample::CustomDeviceAccess::DeviceClosingHandler

Definition at line 33 of file DeviceList.h.

Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DataBinding Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • DataBinding
Classes

SDKSample::DataBinding Namespace Reference

Classes

class | GeneratorIncrementalLoadingClass
class | IncrementalLoadingBase
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DataReaderWriter Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • DataReaderWriter
Classes

SDKSample::DataReaderWriter Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DateTimeFormatting Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • DateTimeFormatting
Classes

SDKSample::DateTimeFormatting Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DeviceCaps Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • DeviceCaps
Classes

SDKSample::DeviceCaps Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DeviceEnumeration Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • DeviceEnumeration
Classes

SDKSample::DeviceEnumeration Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::DisplayOrientation Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • DisplayOrientation
Classes

SDKSample::DisplayOrientation Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Drawing Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Drawing
Classes

SDKSample::Drawing Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::EAS Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • EAS
Classes

SDKSample::EAS Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ELS Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ELS
Namespaces | Classes | Functions

SDKSample::ELS Namespace Reference

Namespaces

namespace | Private

Classes

class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Functions

std::wstring | RecognizeTextLanguages (_In_ PCWSTR text)
std::wstring | RecognizeTextScripts (_In_ PCWSTR text)
std::wstring | TransliterateFromCyrillicToLatin (_In_ PCWSTR text)

Function Documentation

std::wstring SDKSample::ELS::RecognizeTextLanguages ( _In_ PCWSTR text ) [inline]

Definition at line 34 of file elsutil.h.

    {
      auto pService = Private::GetSingleELSServiceWithNoOptions(ELS_GUID_LANGUAGE_DETECTION);
      std::wstring ret;
      if (nullptr != pService)
      {
        MAPPING_PROPERTY_BAG bag = {};
        bag.Size = sizeof(bag);

        HRESULT hr = MappingRecognizeText(pService, text, static_cast<DWORD>(wcslen(text)), 0, nullptr, &bag);
        if (SUCCEEDED(hr))
        {
          for (auto pos = reinterpret_cast<wchar_t*>(bag.prgResultRanges[0].pData); *pos; pos += (wcslen(pos) + 1))
          {
            ret += pos;
            ret += L"\n";
          }
          MappingFreePropertyBag(&bag);
        }
        MappingFreeServices(pService);
      }

      return ret;
    }

std::wstring SDKSample::ELS::RecognizeTextScripts ( _In_ PCWSTR text ) [inline]

Definition at line 59 of file elsutil.h.

{
  auto pService = Private::GetSingleELSServiceWithNoOptions(ELS_GUID_SCRIPT_DETECTION);
  std::wstring ret;
  if (nullptr != pService)
  {
    MAPPING_PROPERTY_BAG bag = {};
    bag.Size = sizeof(bag);

    HRESULT hr = MappingRecognizeText(pService, text, static_cast<DWORD>(wcslen(text)), 0, nullptr, &bag);
    if (SUCCEEDED(hr))
    {
      std::wstringstream output(std::wstringstream::out);
      for (DWORD rangeIndex = 0; rangeIndex < bag.dwRangesCount; ++rangeIndex)
      {
        output << L"Range from " << bag.prgResultRanges[rangeIndex].dwStartIndex << L" to " << bag.prgResultRanges[rangeIndex].dwEndIndex << L": ";
        output << reinterpret_cast<wchar_t*>(bag.prgResultRanges[rangeIndex].pData) << L" script\n";
      }

      ret = output.str();
      MappingFreePropertyBag(&bag);
    }
    MappingFreeServices(pService);
  }

  return ret;
}

std::wstring SDKSample::ELS::TransliterateFromCyrillicToLatin ( _In_ PCWSTR text ) [inline]

Definition at line 87 of file elsutil.h.

{
  auto pService = Private::GetSingleELSServiceWithNoOptions(ELS_GUID_TRANSLITERATION_CYRILLIC_TO_LATIN);
  std::wstring ret;
  if (nullptr != pService)
  {
    MAPPING_PROPERTY_BAG bag = {};
    bag.Size = sizeof(bag);
    HRESULT hr = MappingRecognizeText(pService, text, static_cast<DWORD>(wcslen(text) + 1), 0, nullptr, &bag); // wcslen(text) + 1 to account for a null terminator also
    if (SUCCEEDED(hr))
    {
      ret = reinterpret_cast<wchar_t*>(bag.prgResultRanges[0].pData);
      MappingFreePropertyBag(&bag);
    }
    MappingFreeServices(pService);
  }

  return ret;
}

Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ELS::Private Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ELS
  • Private
Functions

SDKSample::ELS::Private Namespace Reference

Functions

MAPPING_SERVICE_INFO * GetSingleELSServiceWithNoOptions (const GUID &serviceGUID)

Function Documentation

MAPPING_SERVICE_INFO* SDKSample::ELS::Private::GetSingleELSServiceWithNoOptions ( const GUID & serviceGUID ) [inline]

Definition at line 16 of file elsutil.h.

      {
        MAPPING_ENUM_OPTIONS EnumOptions = {};
        EnumOptions.Size = sizeof(EnumOptions);
        EnumOptions.pGuid = const_cast<GUID*>(&serviceGUID);

        DWORD dwServicesCount = 0;
        MAPPING_SERVICE_INFO* pService;
        HRESULT hr = MappingGetServices(&EnumOptions, &pService, &dwServicesCount);
        if (FAILED(hr))
        {
          pService = nullptr;
        }

        return pService;
      }

Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ExpressionBlendSampleDataSampleDataSource Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ExpressionBlendSampleDataSampleDataSource
Classes

SDKSample::ExpressionBlendSampleDataSampleDataSource Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FileAccess Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • FileAccess
Classes

SDKSample::FileAccess Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FilePicker Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • FilePicker
Classes

SDKSample::FilePicker Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FilePickerContracts Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • FilePickerContracts
Classes

SDKSample::FilePickerContracts Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FileSearch Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • FileSearch
Classes

SDKSample::FileSearch Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FileThumbnails Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • FileThumbnails
Classes

SDKSample::FileThumbnails Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FlipViewCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • FlipViewCPP
Classes

SDKSample::FlipViewCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FlipViewData Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • FlipViewData
Classes

SDKSample::FlipViewData Namespace Reference

Classes

class sealed
Creates a collection of groups and items with hard-coded content. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::FolderEnumeration Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • FolderEnumeration
Classes

SDKSample::FolderEnumeration Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::GeolocationCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • GeolocationCPP
Classes

SDKSample::GeolocationCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::GlobalizationPreferencesSample Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • GlobalizationPreferencesSample
Classes

SDKSample::GlobalizationPreferencesSample Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::GyrometerCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • GyrometerCPP
Classes

SDKSample::GyrometerCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::HighContrast Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • HighContrast
Classes

SDKSample::HighContrast Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::HomeGroup Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • HomeGroup
Classes

SDKSample::HomeGroup Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::HttpClientSample Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • HttpClientSample
Classes

SDKSample::HttpClientSample Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Images Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Images
Classes

SDKSample::Images Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::InclinometerCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • InclinometerCPP
Classes

SDKSample::InclinometerCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::IsRemoteSession Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • IsRemoteSession
Classes

SDKSample::IsRemoteSession Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::LightSensorCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • LightSensorCPP
Classes

SDKSample::LightSensorCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ListViewSampleDataSource Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ListViewSampleDataSource
Classes

SDKSample::ListViewSampleDataSource Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ListViewSimple Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ListViewSimple
Classes

SDKSample::ListViewSimple Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MediaButtons Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • MediaButtons
Classes

SDKSample::MediaButtons Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MediaCapture Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • MediaCapture
Classes

SDKSample::MediaCapture Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MediaServerClient Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • MediaServerClient
Classes

SDKSample::MediaServerClient Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MessageDialogSample Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • MessageDialogSample
Classes

SDKSample::MessageDialogSample Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::MicrosoftAccount Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • MicrosoftAccount
Classes

SDKSample::MicrosoftAccount Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::NetworkInformationApi Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • NetworkInformationApi
Classes

SDKSample::NetworkInformationApi Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::NumberFormatting Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • NumberFormatting
Classes

SDKSample::NumberFormatting Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::OrientationSensorCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • OrientationSensorCPP
Classes

SDKSample::OrientationSensorCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PackageSample Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • PackageSample
Classes

SDKSample::PackageSample Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PasswordVaultCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • PasswordVaultCPP
Classes

SDKSample::PasswordVaultCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PersonalityAnimations Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • PersonalityAnimations
Classes

SDKSample::PersonalityAnimations Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Personalization Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Personalization
Classes

SDKSample::Personalization Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PlaybackManager Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • PlaybackManager
Classes

SDKSample::PlaybackManager Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PlaybackManager2 Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • PlaybackManager2
Classes

SDKSample::PlaybackManager2 Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Playlists Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Playlists
Classes

SDKSample::Playlists Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PlayTo Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • PlayTo
Classes

SDKSample::PlayTo Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PlayToreceiver Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • PlayToreceiver
Classes

SDKSample::PlayToreceiver Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::PortableDeviceCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • PortableDeviceCPP
Classes | Functions

SDKSample::PortableDeviceCPP Namespace Reference

Classes

class | EventCallback
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Functions

public delegate void | EventReceived (Platform::String^deviceId, Platform::String^eventData)
delegate void | OnServiceOpenComplete (HRESULT result)

Function Documentation

public delegate void SDKSample::PortableDeviceCPP::EventReceived | ( | Platform::String^ | deviceId,
 |  | Platform::String^ | eventData
 | ) |  |
delegate void SDKSample::PortableDeviceCPP::OnServiceOpenComplete ( HRESULT result )
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ProvisioningAgent Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ProvisioningAgent
Classes

SDKSample::ProvisioningAgent Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::RemovableStorageCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • RemovableStorageCPP
Classes

SDKSample::RemovableStorageCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Rotation Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Rotation
Classes

SDKSample::Rotation Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Scaling Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Scaling
Classes

SDKSample::Scaling Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ScrollViewerCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ScrollViewerCPP
Classes

SDKSample::ScrollViewerCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SDKTemplate Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • SDKTemplate
Classes

SDKSample::SDKTemplate Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SearchContract Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • SearchContract
Classes

SDKSample::SearchContract Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ShareSource Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ShareSource
Classes

SDKSample::ShareSource Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SimpleOrientationSensorCPP Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • SimpleOrientationSensorCPP
Classes

SDKSample::SimpleOrientationSensorCPP Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SnapSample Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • SnapSample
Classes

SDKSample::SnapSample Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::SplashScreen Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • SplashScreen
Classes

SDKSample::SplashScreen Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::StoreSample Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • StoreSample
Classes

SDKSample::StoreSample Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Syndication Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Syndication
Classes

SDKSample::Syndication Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::TextDisplay Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • TextDisplay
Classes

SDKSample::TextDisplay Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::TextEditing Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • TextEditing
Classes

SDKSample::TextEditing Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::ThreadPool Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • ThreadPool
Classes | Enumerations

SDKSample::ThreadPool Namespace Reference

Classes

class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...
struct | ThreadPoolSample

Enumerations

enum | Status { Unregistered = 0, Started = 1, Canceled = 2, Completed = 3 }

Enumeration Type Documentation

enum SDKSample::ThreadPool::Status
Enumerator:
Unregistered
Started
Canceled
Completed

Definition at line 46 of file Constants.h.

        {
            Unregistered = 0,
            Started = 1,
            Canceled = 2,
            Completed = 3
        };

Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Tiles Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Tiles
Classes

SDKSample::Tiles Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::TouchKeyboard Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • TouchKeyboard
Classes

SDKSample::TouchKeyboard Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::TouchKeyboardTextInput Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • TouchKeyboardTextInput
Classes

SDKSample::TouchKeyboardTextInput Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Transcode Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Transcode
Classes

SDKSample::Transcode Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::Transforms Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • Transforms
Classes

SDKSample::Transforms Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::UserAndCustomControls Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • UserAndCustomControls
Classes

SDKSample::UserAndCustomControls Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::UserDomainName Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • UserDomainName
Classes

SDKSample::UserDomainName Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::UssdApi Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • UssdApi
Classes

SDKSample::UssdApi Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WASAPIAudio Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • WASAPIAudio
Classes | Enumerations | Functions

SDKSample::WASAPIAudio Namespace Reference

Classes

struct | DEVICEPROPS
class | MFSampleGenerator
class | sealed
class | ToneSampleGenerator
class | WASAPICapture
class | WASAPIRenderer

Enumerations

enum | ContentType { ContentTypeTone, ContentTypeFile }
enum DeviceState {
DeviceStateUnInitialized, DeviceStateInError, DeviceStateDiscontinutity, DeviceStateFlushing,
DeviceStateActivated, DeviceStateInitialized, DeviceStateStarting, DeviceStatePlaying,
DeviceStateCapturing, DeviceStatePausing, DeviceStatePaused, DeviceStateStopping,
DeviceStateStopped
}

Functions

public delegate void | DeviceStateChangedHandler (Platform::Object^sender, DeviceStateChangedEventArgs^e)
public delegate void | PlotDataReadyHandler (Platform::Object^sender, PlotDataReadyEventArgs^e)

Enumeration Type Documentation

enum SDKSample::WASAPIAudio::ContentType
Enumerator:
ContentTypeTone
ContentTypeFile

Definition at line 27 of file Scenario2.xaml.h.

        {
            ContentTypeTone,
            ContentTypeFile
        };

enum SDKSample::WASAPIAudio::DeviceState
Enumerator:
DeviceStateUnInitialized
DeviceStateInError
DeviceStateDiscontinutity
DeviceStateFlushing
DeviceStateActivated
DeviceStateInitialized
DeviceStateStarting
DeviceStatePlaying
DeviceStateCapturing
DeviceStatePausing
DeviceStatePaused
DeviceStateStopping
DeviceStateStopped

Definition at line 27 of file DeviceState.h.

        {
            DeviceStateUnInitialized,
            DeviceStateInError,
            DeviceStateDiscontinutity,
            DeviceStateFlushing,
            DeviceStateActivated,
            DeviceStateInitialized,
            DeviceStateStarting,
            DeviceStatePlaying,
            DeviceStateCapturing,
            DeviceStatePausing,
            DeviceStatePaused,
            DeviceStateStopping,
            DeviceStateStopped
        };

Function Documentation

public delegate void SDKSample::WASAPIAudio::DeviceStateChangedHandler | ( | Platform::Object^ | sender,
 |  | DeviceStateChangedEventArgs^ | e
 | ) |  |
public delegate void SDKSample::WASAPIAudio::PlotDataReadyHandler | ( | Platform::Object^ | sender,
 |  | PlotDataReadyEventArgs^ | e
 | ) |  |
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WebAuthentication Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • WebAuthentication
Classes

SDKSample::WebAuthentication Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WebSocket Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • WebSocket
Classes

SDKSample::WebSocket Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::WebViewControl Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • WebViewControl
Classes

SDKSample::WebViewControl Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKSample::XAMLPopup Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKSample
  • XAMLPopup
Classes

SDKSample::XAMLPopup Namespace Reference

Classes

class sealed
An empty page that can be used on its own or navigated to within a Frame. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

SDKTemplate Namespace Reference

Namespaces

namespace | Common

Classes

class | App
Provides application-specific behavior to supplement the default Application class. More...
class | DeviceAppPage
class | MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | MainPageSizeChangedEventArgs
class | Scenario

Enumerations

enum NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}
enum NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}
enum NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}
enum NotifyType {
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage,
StatusMessage, ErrorMessage, StatusMessage, ErrorMessage
}

Enumeration Type Documentation

enum SDKTemplate::NotifyType
Enumerator:
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage

Definition at line 316 of file MainPage.xaml.cs.

    {
        StatusMessage,
        ErrorMessage
    };

enum SDKTemplate::NotifyType
Enumerator:
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage

Definition at line 316 of file MainPage.xaml.cs.

    {
        StatusMessage,
        ErrorMessage
    };

enum SDKTemplate::NotifyType
Enumerator:
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage

Definition at line 316 of file MainPage.xaml.cs.

    {
        StatusMessage,
        ErrorMessage
    };

enum SDKTemplate::NotifyType
Enumerator:
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage
StatusMessage
ErrorMessage

Definition at line 316 of file MainPage.xaml.cs.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplate::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • SDKTemplate
  • Common
Classes

SDKTemplate::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SDKTemplateCS Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

SDKTemplateCS Namespace Reference

Classes

class | MainPage

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum SDKTemplateCS::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 229 of file MainPage.xaml.cs.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SecondaryTiles Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

SecondaryTiles Namespace Reference

Namespaces

namespace | Common

Classes

class | MainPage
struct | Scenario
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum SecondaryTiles::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 25 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SecondaryTiles::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • SecondaryTiles
  • Common
Classes

SecondaryTiles::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ShareTarget Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

ShareTarget Namespace Reference

Namespaces

namespace | Common

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum ShareTarget::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 24 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ShareTarget::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • ShareTarget
  • Common
Classes

ShareTarget::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Simple3DGameXaml Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

Simple3DGameXaml Namespace Reference

Classes

class | sealed

Enumerations

enum | GameInfoOverlayCommand { None, TapToContinue, PleaseWait, PlayAgain }
enum GameInfoOverlayState {
Loading, GameStats, GameOverExpired, GameOverCompleted,
LevelStart, Pause, Snapped
}
enum | PressResultState { LoadGame, PlayLevel, ContinueLevel }
enum UpdateEngineState {
WaitingForResources, ResourcesLoaded, WaitingForPress, Dynamics,
Snapped, Suspended, Deactivated
}

Enumeration Type Documentation

enum Simple3DGameXaml::GameInfoOverlayCommand
Enumerator:
None
TapToContinue
PleaseWait
PlayAgain

Definition at line 17 of file MainPage.xaml.h.

    {
        None,
        TapToContinue,
        PleaseWait,
        PlayAgain,
    };

enum Simple3DGameXaml::GameInfoOverlayState
Enumerator:
Loading
GameStats
GameOverExpired
GameOverCompleted
LevelStart
Pause
Snapped

Definition at line 79 of file App.xaml.h.

    {
        Loading,
        GameStats,
        GameOverExpired,
        GameOverCompleted,
        LevelStart,
        Pause,
        Snapped,
    };

enum Simple3DGameXaml::PressResultState
Enumerator:
LoadGame
PlayLevel
ContinueLevel

Definition at line 72 of file App.xaml.h.

    {
        LoadGame,
        PlayLevel,
        ContinueLevel,
    };

enum Simple3DGameXaml::UpdateEngineState
Enumerator:
WaitingForResources
ResourcesLoaded
WaitingForPress
Dynamics
Snapped
Suspended
Deactivated

Definition at line 61 of file App.xaml.h.

    {
        WaitingForResources,
        ResourcesLoaded,
        WaitingForPress,
        Dynamics,
        Snapped,
        Suspended,
        Deactivated,
    };

Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleBlogReader Namespace Reference

  • Namespace List
  • Namespace Members
Classes

SimpleBlogReader Namespace Reference

Classes

class sealed
Provides application-specific behavior to supplement the default Application class. More...
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations | Functions

SimpleCommunication Namespace Reference

Namespaces

namespace | Common

Classes

class | App
class | CaptureFailedEventArgs
class | LowLatency
An empty page that can be used on its own or navigated to within a Frame. More...
class | MainPage
struct | Scenario
class | SdkSample
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | VideoChat
An empty page that can be used on its own or navigated to within a Frame. More...

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Functions

delegate void | CaptureFailedHandler (CaptureDevice^sender, CaptureFailedEventArgs^errorEventArgs)
delegate void | IncomingconnectioneventHandler (Microsoft::Samples::SimpleCommunication::StspMediaSink^sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^args)
delegate bool | VideoSettingsFilter (Windows::Media::MediaProperties::IMediaEncodingProperties^, unsigned int)

Enumeration Type Documentation

enum SimpleCommunication::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 25 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Function Documentation

delegate void SimpleCommunication::CaptureFailedHandler | ( | CaptureDevice^ | sender,
 |  | CaptureFailedEventArgs^ | errorEventArgs
 | ) |  |
delegate void SimpleCommunication::IncomingconnectioneventHandler | ( | Microsoft::Samples::SimpleCommunication::StspMediaSink^ | sender,
 |  | Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ | args
 | ) |  |
delegate bool SimpleCommunication::VideoSettingsFilter | ( | Windows::Media::MediaProperties::IMediaEncodingProperties^ | ,
 |  | unsigned | int
 | ) |  |
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleCommunication::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • SimpleCommunication
  • Common
Classes

SimpleCommunication::Common Namespace Reference

Classes

class | CaptureDevice
class | LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocketSample Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes | Enumerations

StreamSocketSample Namespace Reference

Namespaces

namespace | Common

Classes

class | App
class | MainPage
struct | Scenario
class | sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum StreamSocketSample::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 25 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocketSample::Common Namespace Reference

  • Namespace List
  • Namespace Members
  • StreamSocketSample
  • Common
Classes

StreamSocketSample::Common Namespace Reference

Classes

class LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Tasks Namespace Reference

  • Namespace List
  • Namespace Members
Classes

Tasks Namespace Reference

Classes

class sealed
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ToastsSampleCPP Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Enumerations

ToastsSampleCPP Namespace Reference

Classes

class | sealed

Enumerations

enum | NotifyType { StatusMessage, ErrorMessage }

Enumeration Type Documentation

enum ToastsSampleCPP::NotifyType
Enumerator:
StatusMessage
ErrorMessage

Definition at line 30 of file MainPage.xaml.h.

    {
        StatusMessage,
        ErrorMessage
    };

Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TripOptimizerComponent Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes

TripOptimizerComponent Namespace Reference

Namespaces

namespace | Details

Classes

class | sealed
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: TripOptimizerComponent::Details Namespace Reference

  • Namespace List
  • Namespace Members
  • TripOptimizerComponent
  • Details
Classes

TripOptimizerComponent::Details Namespace Reference

Classes

class TripOptimizerImpl
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UiaCoreWindowProvider Namespace Reference

  • Namespace List
  • Namespace Members
Classes | Typedefs | Enumerations | Functions

UiaCoreWindowProvider Namespace Reference

Classes

interface | IAppWindowProvider
interface | IDisconnectableProvider
interface | ITriColorControlInternal
interface | ITriColorControlProvider
interface | ITriColorFragmentProvider

Typedefs

typedef enum
UiaCoreWindowProvider::TriColorValue 		TriColorValue

Enumerations

enum | TriColorValue { Red, Yellow, Green }

Functions

activatable (NTDDI_WIN8)] runtimeclass TriColorControlProvider

Typedef Documentation

typedef enum UiaCoreWindowProvider::TriColorValue UiaCoreWindowProvider::TriColorValue

Enumeration Type Documentation

enum UiaCoreWindowProvider::TriColorValue
Enumerator:
Red
Yellow
Green

Definition at line 18 of file InternalInterfaces.idl.

    {
        Red,
        Yellow,
        Green
    } TriColorValue;

Function Documentation

UiaCoreWindowProvider::activatable ( NTDDI_WIN8 )

Definition at line 80 of file InternalInterfaces.idl.

    {
        [default] interface ITriColorControlProvider;
    }

Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web Namespace Reference

  • Namespace List
  • Namespace Members
Namespaces | Classes

Web Namespace Reference

Namespaces

namespace | Details

Classes

class | HttpRequest
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web::Details Namespace Reference

  • Namespace List
  • Namespace Members
  • Web
  • Details
Classes

Web::Details Namespace Reference

Classes

class HttpRequestBuffersCallback
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Wrapper Namespace Reference

  • Namespace List
  • Namespace Members
Classes

Wrapper Namespace Reference

Classes

struct | DspSettings
class | sealed
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- _ -

  • __declspec() : DirectX
  • _CalculateMipLevels() : DirectX
  • _CalculateMipLevels3D() : DirectX
  • _ConvertFromR32G32B32A32() : DirectX
  • _ConvertScanline() : DirectX
  • _ConvertToR32G32B32A32() : DirectX
  • _CopyScanline() : DirectX
  • _DetermineImageArray() : DirectX
  • _DXGIToWIC() : DirectX
  • _EncodeDDSHeader() : DirectX
  • _ExpandScanline() : DirectX
  • _GetConvertFlags() : DirectX
  • _GetWIC() : DirectX
  • _GetWICDither() : DirectX
  • _GetWICInterp() : DirectX
  • _In_reads_() : DirectX
  • _In_reads_bytes_() : DirectX
  • _In_reads_opt_() : DirectX
  • _LoadScanline() : DirectX
  • _Out_writes_() : DirectX
  • _registeredFrames : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • _ResizeSeparateColorAndAlpha() : DirectX
  • _sessionState : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • _SetupImageArray() : DirectX
  • _StoreScanline() : DirectX
  • _Success_() : DirectX
  • _SwizzleScanline() : DirectX
  • _WICBitsPerPixel() : DirectX
  • _WICToDXGI() : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File Index

  • File List
  • File Members

File List

Here is a list of all files with brief descriptions:
Accelerometer sensor/C++/App.xaml.cpp [code]
Accelerometer sensor/C++/App.xaml.h [code]
Accelerometer sensor/C++/Constants.cpp [code]
Accelerometer sensor/C++/Constants.h [code]
Accelerometer sensor/C++/MainPage.xaml.cpp [code]
Accelerometer sensor/C++/MainPage.xaml.h [code]
Accelerometer sensor/C++/pch.cpp [code]
Accelerometer sensor/C++/pch.h [code]
Accelerometer sensor/C++/Scenario1.xaml.cpp [code]
Accelerometer sensor/C++/Scenario1.xaml.h [code]
Accelerometer sensor/C++/Scenario2.xaml.cpp [code]
Accelerometer sensor/C++/Scenario2.xaml.h [code]
Accelerometer sensor/C++/Scenario3.xaml.cpp [code]
Accelerometer sensor/C++/Scenario3.xaml.h [code]
Accelerometer sensor/C++/common/LayoutAwarePage.cpp [code]
Accelerometer sensor/C++/common/LayoutAwarePage.h [code]
Accelerometer sensor/C++/common/suspensionmanager.cpp [code]
Accelerometer sensor/C++/common/suspensionmanager.h [code]
Account picture name/C++/App.xaml.cpp [code]
Account picture name/C++/App.xaml.h [code]
Account picture name/C++/Constants.cpp [code]
Account picture name/C++/Constants.h [code]
Account picture name/C++/GetAccountPicture.xaml.cpp [code]
Account picture name/C++/GetAccountPicture.xaml.h [code]
Account picture name/C++/GetUserDisplayName.xaml.cpp [code]
Account picture name/C++/GetUserDisplayName.xaml.h [code]
Account picture name/C++/GetUserFirstAndLastName.xaml.cpp [code]
Account picture name/C++/GetUserFirstAndLastName.xaml.h [code]
Account picture name/C++/MainPage.xaml.cpp [code]
Account picture name/C++/MainPage.xaml.h [code]
Account picture name/C++/pch.cpp [code]
Account picture name/C++/pch.h [code]
Account picture name/C++/SetAccountPicture.xaml.cpp [code]
Account picture name/C++/SetAccountPicture.xaml.h [code]
Account picture name/C++/common/LayoutAwarePage.cpp [code]
Account picture name/C++/common/LayoutAwarePage.h [code]
Account picture name/C++/sample-utils/CppSamplesUtils.h [code]
Animation metrics/C++/App.xaml.cpp [code]
Animation metrics/C++/App.xaml.h [code]
Animation metrics/C++/Constants.cpp [code]
Animation metrics/C++/Constants.h [code]
Animation metrics/C++/MainPage.xaml.cpp [code]
Animation metrics/C++/MainPage.xaml.h [code]
Animation metrics/C++/pch.cpp [code]
Animation metrics/C++/pch.h [code]
Animation metrics/C++/Scenario1.xaml.cpp [code]
Animation metrics/C++/Scenario1.xaml.h [code]
Animation metrics/C++/common/LayoutAwarePage.cpp [code]
Animation metrics/C++/common/LayoutAwarePage.h [code]
Animation metrics/C++/common/suspensionmanager.cpp [code]
Animation metrics/C++/common/suspensionmanager.h [code]
App package information/C++/App.xaml.cpp [code]
App package information/C++/App.xaml.h [code]
App package information/C++/Constants.cpp [code]
App package information/C++/Constants.h [code]
App package information/C++/MainPage.xaml.cpp [code]
App package information/C++/MainPage.xaml.h [code]
App package information/C++/pch.cpp [code]
App package information/C++/pch.h [code]
App package information/C++/Scenario1.xaml.cpp [code]
App package information/C++/Scenario1.xaml.h [code]
App package information/C++/Scenario2.xaml.cpp [code]
App package information/C++/Scenario2.xaml.h [code]
App package information/C++/Scenario3.xaml.cpp [code]
App package information/C++/Scenario3.xaml.h [code]
App package information/C++/common/LayoutAwarePage.cpp [code]
App package information/C++/common/LayoutAwarePage.h [code]
App package information/C++/common/suspensionmanager.cpp [code]
App package information/C++/common/suspensionmanager.h [code]
App settings/C++/AddSettingsScenario.xaml.cpp [code]
App settings/C++/AddSettingsScenario.xaml.h [code]
App settings/C++/App.xaml.cpp [code]
App settings/C++/App.xaml.h [code]
App settings/C++/Constants.cpp [code]
App settings/C++/Constants.h [code]
App settings/C++/DefaultScenario.xaml.cpp [code]
App settings/C++/DefaultScenario.xaml.h [code]
App settings/C++/MainPage.xaml.cpp [code]
App settings/C++/MainPage.xaml.h [code]
App settings/C++/pch.cpp [code]
App settings/C++/pch.h [code]
App settings/C++/common/LayoutAwarePage.cpp [code]
App settings/C++/common/LayoutAwarePage.h [code]
App settings/C++/common/suspensionmanager.cpp [code]
App settings/C++/common/suspensionmanager.h [code]
App tiles and badges/C#,C++/App.xaml.cpp [code]
App tiles and badges/C#,C++/App.xaml.h [code]
App tiles and badges/C#,C++/Constants.cpp [code]
App tiles and badges/C#,C++/Constants.h [code]
App tiles and badges/C#,C++/EnableNotificationQueue.xaml.cpp [code]
App tiles and badges/C#,C++/EnableNotificationQueue.xaml.h [code]
App tiles and badges/C#,C++/Globalization.xaml.cpp [code]
App tiles and badges/C#,C++/Globalization.xaml.h [code]
App tiles and badges/C#,C++/ImageProtocols.xaml.cpp [code]
App tiles and badges/C#,C++/ImageProtocols.xaml.h [code]
App tiles and badges/C#,C++/MainPage.xaml.cpp [code]
App tiles and badges/C#,C++/MainPage.xaml.h [code]
App tiles and badges/C#,C++/NotificationExpiration.xaml.cpp [code]
App tiles and badges/C#,C++/NotificationExpiration.xaml.h [code]
App tiles and badges/C#,C++/pch.cpp [code]
App tiles and badges/C#,C++/pch.h [code]
App tiles and badges/C#,C++/SendBadge.xaml.cpp [code]
App tiles and badges/C#,C++/SendBadge.xaml.h [code]
App tiles and badges/C#,C++/SendLocalImageTile.xaml.cpp [code]
App tiles and badges/C#,C++/SendLocalImageTile.xaml.h [code]
App tiles and badges/C#,C++/SendTextTile.xaml.cpp [code]
App tiles and badges/C#,C++/SendTextTile.xaml.h [code]
App tiles and badges/C#,C++/SendWebImageTile.xaml.cpp [code]
App tiles and badges/C#,C++/SendWebImageTile.xaml.h [code]
App tiles and badges/C#,C++/common/LayoutAwarePage.cpp [code]
App tiles and badges/C#,C++/common/LayoutAwarePage.h [code]
App tiles and badges/C#,C++/common/suspensionmanager.cpp [code]
App tiles and badges/C#,C++/common/suspensionmanager.h [code]
App tiles and badges/C#,C++/NotificationsExtensions/Common.cs [code]
Application data/C++/App.xaml.cpp [code]
Application data/C++/App.xaml.h [code]
Application data/C++/ClearScenario.xaml.cpp [code]
Application data/C++/ClearScenario.xaml.h [code]
Application data/C++/CompositeSettings.xaml.cpp [code]
Application data/C++/CompositeSettings.xaml.h [code]
Application data/C++/Constants.cpp [code]
Application data/C++/Constants.h [code]
Application data/C++/DataChangedEvent.xaml.cpp [code]
Application data/C++/DataChangedEvent.xaml.h [code]
Application data/C++/Files.xaml.cpp [code]
Application data/C++/Files.xaml.h [code]
Application data/C++/HighPriority.xaml.cpp [code]
Application data/C++/HighPriority.xaml.h [code]
Application data/C++/MainPage.xaml.cpp [code]
Application data/C++/MainPage.xaml.h [code]
Application data/C++/Msappdata.xaml.cpp [code]
Application data/C++/Msappdata.xaml.h [code]
Application data/C++/pch.cpp [code]
Application data/C++/pch.h [code]
Application data/C++/SettingContainer.xaml.cpp [code]
Application data/C++/SettingContainer.xaml.h [code]
Application data/C++/Settings.xaml.cpp [code]
Application data/C++/Settings.xaml.h [code]
Application data/C++/SetVersion.xaml.cpp [code]
Application data/C++/SetVersion.xaml.h [code]
Application data/C++/common/LayoutAwarePage.cpp [code]
Application data/C++/common/LayoutAwarePage.h [code]
Application data/C++/common/suspensionmanager.cpp [code]
Application data/C++/common/suspensionmanager.h [code]
Application resources and localization/C++/App.xaml.cpp [code]
Application resources and localization/C++/App.xaml.h [code]
Application resources and localization/C++/Constants.cpp [code]
Application resources and localization/C++/Constants.h [code]
Application resources and localization/C++/CppSamplesUtils.h [code]
Application resources and localization/C++/MainPage.xaml.cpp [code]
Application resources and localization/C++/MainPage.xaml.h [code]
Application resources and localization/C++/pch.cpp [code]
Application resources and localization/C++/pch.h [code]
Application resources and localization/C++/Scenario1.xaml.cpp [code]
Application resources and localization/C++/Scenario1.xaml.h [code]
Application resources and localization/C++/Scenario10.xaml.cpp [code]
Application resources and localization/C++/Scenario10.xaml.h [code]
Application resources and localization/C++/Scenario11.xaml.cpp [code]
Application resources and localization/C++/Scenario11.xaml.h [code]
Application resources and localization/C++/Scenario2.xaml.cpp [code]
Application resources and localization/C++/Scenario2.xaml.h [code]
Application resources and localization/C++/Scenario3.xaml.cpp [code]
Application resources and localization/C++/Scenario3.xaml.h [code]
Application resources and localization/C++/Scenario4.xaml.cpp [code]
Application resources and localization/C++/Scenario4.xaml.h [code]
Application resources and localization/C++/Scenario5.xaml.cpp [code]
Application resources and localization/C++/Scenario5.xaml.h [code]
Application resources and localization/C++/Scenario6.xaml.cpp [code]
Application resources and localization/C++/Scenario6.xaml.h [code]
Application resources and localization/C++/Scenario7.xaml.cpp [code]
Application resources and localization/C++/Scenario7.xaml.h [code]
Application resources and localization/C++/Scenario8.xaml.cpp [code]
Application resources and localization/C++/Scenario8.xaml.h [code]
Application resources and localization/C++/Scenario9.xaml.cpp [code]
Application resources and localization/C++/Scenario9.xaml.h [code]
Association launching/C++/App.xaml.cpp [code]
Association launching/C++/App.xaml.h [code]
Association launching/C++/CppSamplesUtils.h [code]
Association launching/C++/LaunchFileInput.xaml.cpp [code]
Association launching/C++/LaunchFileInput.xaml.h [code]
Association launching/C++/LaunchFileOutput.xaml.cpp [code]
Association launching/C++/LaunchFileOutput.xaml.h [code]
Association launching/C++/LaunchUriInput.xaml.cpp [code]
Association launching/C++/LaunchUriInput.xaml.h [code]
Association launching/C++/LaunchUriOutput.xaml.cpp [code]
Association launching/C++/LaunchUriOutput.xaml.h [code]
Association launching/C++/MainPage.xaml.cpp [code]
Association launching/C++/MainPage.xaml.h [code]
Association launching/C++/pch.cpp [code]
Association launching/C++/pch.h [code]
Association launching/C++/ReceiveFileInput.xaml.cpp [code]
Association launching/C++/ReceiveFileInput.xaml.h [code]
Association launching/C++/ReceiveFileOutput.xaml.cpp [code]
Association launching/C++/ReceiveFileOutput.xaml.h [code]
Association launching/C++/ReceiveUriInput.xaml.cpp [code]
Association launching/C++/ReceiveUriInput.xaml.h [code]
Association launching/C++/ReceiveUriOutput.xaml.cpp [code]
Association launching/C++/ReceiveUriOutput.xaml.h [code]
Association launching/C++/ScenarioList.xaml.cpp [code]
Association launching/C++/ScenarioList.xaml.h [code]
AtomPub/C++/App.xaml.cpp [code]
AtomPub/C++/App.xaml.h [code]
AtomPub/C++/Constants.cpp [code]
AtomPub/C++/Constants.h [code]
AtomPub/C++/MainPage.xaml.cpp [code]
AtomPub/C++/MainPage.xaml.h [code]
AtomPub/C++/pch.cpp [code]
AtomPub/C++/pch.h [code]
AtomPub/C++/Scenario1.xaml.cpp [code]
AtomPub/C++/Scenario1.xaml.h [code]
AtomPub/C++/Scenario2.xaml.cpp [code]
AtomPub/C++/Scenario2.xaml.h [code]
AtomPub/C++/Scenario3.xaml.cpp [code]
AtomPub/C++/Scenario3.xaml.h [code]
AtomPub/C++/Scenario4.xaml.cpp [code]
AtomPub/C++/Scenario4.xaml.h [code]
AtomPub/C++/common/LayoutAwarePage.cpp [code]
AtomPub/C++/common/LayoutAwarePage.h [code]
AtomPub/C++/common/suspensionmanager.cpp [code]
AtomPub/C++/common/suspensionmanager.h [code]
Background task/C++/BackgroundTask/App.xaml.cpp [code]
Background task/C++/BackgroundTask/App.xaml.h [code]
Background task/C++/BackgroundTask/Constants.cpp [code]
Background task/C++/BackgroundTask/Constants.h [code]
Background task/C++/BackgroundTask/MainPage.xaml.cpp [code]
Background task/C++/BackgroundTask/MainPage.xaml.h [code]
Background task/C++/BackgroundTask/pch.cpp [code]
Background task/C++/BackgroundTask/pch.h [code]
Background task/C++/BackgroundTask/SampleBackgroundTask.xaml.cpp [code]
Background task/C++/BackgroundTask/SampleBackgroundTask.xaml.h [code]
Background task/C++/BackgroundTask/ServicingCompleteTask.xaml.h [code]
Background task/C++/BackgroundTask/TimeTriggeredTask.xaml.cpp [code]
Background task/C++/BackgroundTask/TimeTriggeredTask.xaml.h [code]
Background task/C++/BackgroundTask/common/LayoutAwarePage.cpp [code]
Background task/C++/BackgroundTask/common/LayoutAwarePage.h [code]
Background task/C++/BackgroundTask/common/suspensionmanager.cpp [code]
Background task/C++/BackgroundTask/common/suspensionmanager.h [code]
Background task/C++/Tasks/pch.cpp [code]
Background task/C++/Tasks/pch.h [code]
Background task/C++/Tasks/SampleBackgroundTask.cpp [code]
Background task/C++/Tasks/SampleBackgroundTask.h [code]
Background task/C++/Tasks/ServicingComplete.cpp [code]
Background task/C++/Tasks/ServicingComplete.h [code]
Background Transfer/C++/App.xaml.cpp [code]
Background Transfer/C++/App.xaml.h [code]
Background Transfer/C++/Constants.cpp [code]
Background Transfer/C++/Constants.h [code]
Background Transfer/C++/MainPage.xaml.cpp [code]
Background Transfer/C++/MainPage.xaml.h [code]
Background Transfer/C++/pch.cpp [code]
Background Transfer/C++/pch.h [code]
Background Transfer/C++/Scenario1.xaml.cpp [code]
Background Transfer/C++/Scenario1.xaml.h [code]
Background Transfer/C++/Scenario2.xaml.cpp [code]
Background Transfer/C++/Scenario2.xaml.h [code]
Background Transfer/C++/common/LayoutAwarePage.cpp [code]
Background Transfer/C++/common/LayoutAwarePage.h [code]
Background Transfer/C++/common/suspensionmanager.cpp [code]
Background Transfer/C++/common/suspensionmanager.h [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/AntSystem.cpp [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/AntSystem.h [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.cpp [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.h [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/pch.cpp [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/pch.h [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizer.cpp [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizer.h [code]
Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizerImpl.h [code]
Bluetooth call control/C++/App.xaml.cpp [code]
Bluetooth call control/C++/App.xaml.h [code]
Bluetooth call control/C++/Constants.cpp [code]
Bluetooth call control/C++/Constants.h [code]
Bluetooth call control/C++/MainPage.xaml.cpp [code]
Bluetooth call control/C++/MainPage.xaml.h [code]
Bluetooth call control/C++/pch.cpp [code]
Bluetooth call control/C++/pch.h [code]
Bluetooth call control/C++/PhoneCall.xaml.cpp [code]
Bluetooth call control/C++/PhoneCall.xaml.h [code]
Bluetooth call control/C++/common/LayoutAwarePage.cpp [code]
Bluetooth call control/C++/common/LayoutAwarePage.h [code]
Bluetooth call control/C++/common/suspensionmanager.cpp [code]
Bluetooth call control/C++/common/suspensionmanager.h [code]
Calendar details and math/C++/App.xaml.cpp [code]
Calendar details and math/C++/App.xaml.h [code]
Calendar details and math/C++/CalendarEnumerationAndMath.xaml.h [code]
Calendar details and math/C++/Constants.cpp [code]
Calendar details and math/C++/Constants.h [code]
Calendar details and math/C++/DisplayCalendarData.xaml.cpp [code]
Calendar details and math/C++/DisplayCalendarData.xaml.h [code]
Calendar details and math/C++/DisplayCalendarStatistics.xaml.cpp [code]
Calendar details and math/C++/DisplayCalendarStatistics.xaml.h [code]
Calendar details and math/C++/MainPage.xaml.cpp [code]
Calendar details and math/C++/MainPage.xaml.h [code]
Calendar details and math/C++/pch.cpp [code]
Calendar details and math/C++/pch.h [code]
Calendar details and math/C++/common/LayoutAwarePage.cpp [code]
Calendar details and math/C++/common/LayoutAwarePage.h [code]
Calendar details and math/C++/common/suspensionmanager.cpp [code]
Calendar details and math/C++/common/suspensionmanager.h [code]
CameraCaptureUI/C++/App.xaml.cpp [code]
CameraCaptureUI/C++/App.xaml.h [code]
CameraCaptureUI/C++/CapturePhoto.xaml.cpp [code]
CameraCaptureUI/C++/CapturePhoto.xaml.h [code]
CameraCaptureUI/C++/CaptureVideo.xaml.cpp [code]
CameraCaptureUI/C++/CaptureVideo.xaml.h [code]
CameraCaptureUI/C++/Constants.cpp [code]
CameraCaptureUI/C++/Constants.h [code]
CameraCaptureUI/C++/MainPage.xaml.cpp [code]
CameraCaptureUI/C++/MainPage.xaml.h [code]
CameraCaptureUI/C++/pch.cpp [code]
CameraCaptureUI/C++/pch.h [code]
CameraCaptureUI/C++/common/LayoutAwarePage.cpp [code]
CameraCaptureUI/C++/common/LayoutAwarePage.h [code]
CameraCaptureUI/C++/common/suspensionmanager.cpp [code]
CameraCaptureUI/C++/common/suspensionmanager.h [code]
CameraOptionsUI/C++/App.xaml.cpp [code]
CameraOptionsUI/C++/App.xaml.h [code]
CameraOptionsUI/C++/Constants.cpp [code]
CameraOptionsUI/C++/Constants.h [code]
CameraOptionsUI/C++/MainPage.xaml.cpp [code]
CameraOptionsUI/C++/MainPage.xaml.h [code]
CameraOptionsUI/C++/pch.cpp [code]
CameraOptionsUI/C++/pch.h [code]
CameraOptionsUI/C++/ShowOptionsUI.xaml.cpp [code]
CameraOptionsUI/C++/ShowOptionsUI.xaml.h [code]
CameraOptionsUI/C++/common/LayoutAwarePage.cpp [code]
CameraOptionsUI/C++/common/LayoutAwarePage.h [code]
CameraOptionsUI/C++/common/suspensionmanager.cpp [code]
CameraOptionsUI/C++/common/suspensionmanager.h [code]
Certificate enrollment/C++/App.xaml.cpp [code]
Certificate enrollment/C++/App.xaml.h [code]
Certificate enrollment/C++/Constants.cpp [code]
Certificate enrollment/C++/Constants.h [code]
Certificate enrollment/C++/HttpRequest.cpp [code]
Certificate enrollment/C++/HttpRequest.h [code]
Certificate enrollment/C++/MainPage.xaml.cpp [code]
Certificate enrollment/C++/MainPage.xaml.h [code]
Certificate enrollment/C++/pch.cpp [code]
Certificate enrollment/C++/pch.h [code]
Certificate enrollment/C++/Scenario_Enroll.xaml.cpp [code]
Certificate enrollment/C++/Scenario_Enroll.xaml.h [code]
Certificate enrollment/C++/Scenario_Import.xaml.cpp [code]
Certificate enrollment/C++/Scenario_Import.xaml.h [code]
Certificate enrollment/C++/common/LayoutAwarePage.cpp [code]
Certificate enrollment/C++/common/LayoutAwarePage.h [code]
Certificate enrollment/C++/common/suspensionmanager.cpp [code]
Certificate enrollment/C++/common/suspensionmanager.h [code]
Check if current session is remote/C++/App.xaml.cpp [code]
Check if current session is remote/C++/App.xaml.h [code]
Check if current session is remote/C++/Constants.cpp [code]
Check if current session is remote/C++/Constants.h [code]
Check if current session is remote/C++/MainPage.xaml.cpp [code]
Check if current session is remote/C++/MainPage.xaml.h [code]
Check if current session is remote/C++/pch.cpp [code]
Check if current session is remote/C++/pch.h [code]
Check if current session is remote/C++/RemoteSession.xaml.cpp [code]
Check if current session is remote/C++/RemoteSession.xaml.h [code]
Check if current session is remote/C++/common/LayoutAwarePage.h [code]
Clipboard app/C++/App.xaml.cpp [code]
Clipboard app/C++/App.xaml.h [code]
Clipboard app/C++/constants.cpp [code]
Clipboard app/C++/constants.h [code]
Clipboard app/C++/CopyFiles.xaml.cpp [code]
Clipboard app/C++/CopyFiles.xaml.h [code]
Clipboard app/C++/CopyImage.xaml.cpp [code]
Clipboard app/C++/CopyImage.xaml.h [code]
Clipboard app/C++/CopyText.xaml.cpp [code]
Clipboard app/C++/CopyText.xaml.h [code]
Clipboard app/C++/CppSamplesUtils.h [code]
Clipboard app/C++/MainPage.xaml.cpp [code]
Clipboard app/C++/MainPage.xaml.h [code]
Clipboard app/C++/Others.xaml.cpp [code]
Clipboard app/C++/Others.xaml.h [code]
Clipboard app/C++/pch.cpp [code]
Clipboard app/C++/pch.h [code]
Clipboard app/C++/common/LayoutAwarePage.cpp [code]
Clipboard app/C++/common/LayoutAwarePage.h [code]
Clipboard app/C++/sample-utils/CppSamplesUtils.h [code]
Compass sensor/C++/App.xaml.cpp [code]
Compass sensor/C++/App.xaml.h [code]
Compass sensor/C++/Constants.cpp [code]
Compass sensor/C++/Constants.h [code]
Compass sensor/C++/MainPage.xaml.cpp [code]
Compass sensor/C++/MainPage.xaml.h [code]
Compass sensor/C++/pch.cpp [code]
Compass sensor/C++/pch.h [code]
Compass sensor/C++/Scenario1.xaml.cpp [code]
Compass sensor/C++/Scenario1.xaml.h [code]
Compass sensor/C++/Scenario2.xaml.cpp [code]
Compass sensor/C++/Scenario2.xaml.h [code]
Compass sensor/C++/common/LayoutAwarePage.cpp [code]
Compass sensor/C++/common/LayoutAwarePage.h [code]
Compass sensor/C++/common/suspensionmanager.cpp [code]
Compass sensor/C++/common/suspensionmanager.h [code]
Compression/C++/App.xaml.cpp [code]
Compression/C++/App.xaml.h [code]
Compression/C++/CompressionUtils.cpp [code]
Compression/C++/CompressionUtils.h [code]
Compression/C++/Constants.cpp [code]
Compression/C++/Constants.h [code]
Compression/C++/MainPage.xaml.cpp [code]
Compression/C++/MainPage.xaml.h [code]
Compression/C++/pch.cpp [code]
Compression/C++/pch.h [code]
Compression/C++/Scenario1.xaml.cpp [code]
Compression/C++/Scenario1.xaml.h [code]
Compression/C++/Scenario2.xaml.cpp [code]
Compression/C++/Scenario2.xaml.h [code]
Compression/C++/Scenario3.xaml.cpp [code]
Compression/C++/Scenario3.xaml.h [code]
Compression/C++/common/LayoutAwarePage.cpp [code]
Compression/C++/common/LayoutAwarePage.h [code]
Compression/C++/common/suspensionmanager.cpp [code]
Compression/C++/common/suspensionmanager.h [code]
Configure keys for media/C++/App.xaml.cpp [code]
Configure keys for media/C++/App.xaml.h [code]
Configure keys for media/C++/Constants.cpp [code]
Configure keys for media/C++/Constants.h [code]
Configure keys for media/C++/MainPage.xaml.cpp [code]
Configure keys for media/C++/MainPage.xaml.h [code]
Configure keys for media/C++/mediabuttons.xaml.cpp [code]
Configure keys for media/C++/mediabuttons.xaml.h [code]
Configure keys for media/C++/pch.cpp [code]
Configure keys for media/C++/pch.h [code]
Configure keys for media/C++/common/LayoutAwarePage.cpp [code]
Configure keys for media/C++/common/LayoutAwarePage.h [code]
Configure keys for media/C++/common/suspensionmanager.cpp [code]
Configure keys for media/C++/common/suspensionmanager.h [code]
Configure keys for media/C++/sample-utils/CppSamplesUtils.h [code]
Connecting with WebSockets/C++/App.xaml.cpp [code]
Connecting with WebSockets/C++/App.xaml.h [code]
Connecting with WebSockets/C++/Constants.cpp [code]
Connecting with WebSockets/C++/Constants.h [code]
Connecting with WebSockets/C++/MainPage.xaml.cpp [code]
Connecting with WebSockets/C++/MainPage.xaml.h [code]
Connecting with WebSockets/C++/pch.cpp [code]
Connecting with WebSockets/C++/pch.h [code]
Connecting with WebSockets/C++/Scenario1.xaml.cpp [code]
Connecting with WebSockets/C++/Scenario1.xaml.h [code]
Connecting with WebSockets/C++/Scenario2.xaml.cpp [code]
Connecting with WebSockets/C++/Scenario2.xaml.h [code]
Connecting with WebSockets/C++/common/LayoutAwarePage.cpp [code]
Connecting with WebSockets/C++/common/LayoutAwarePage.h [code]
Connecting with WebSockets/C++/common/suspensionmanager.cpp [code]
Connecting with WebSockets/C++/common/suspensionmanager.h [code]
Contact Picker app/C++/App.xaml.cpp [code]
Contact Picker app/C++/App.xaml.h [code]
Contact Picker app/C++/Constants.cpp [code]
Contact Picker app/C++/Constants.h [code]
Contact Picker app/C++/ContactPickerPage.xaml.cpp [code]
Contact Picker app/C++/ContactPickerPage.xaml.h [code]
Contact Picker app/C++/MainPage.xaml.cpp [code]
Contact Picker app/C++/MainPage.xaml.h [code]
Contact Picker app/C++/MainPagePicker.xaml.cpp [code]
Contact Picker app/C++/MainPagePicker.xaml.h [code]
Contact Picker app/C++/pch.cpp [code]
Contact Picker app/C++/pch.h [code]
Contact Picker app/C++/ScenarioMultiple.xaml.cpp [code]
Contact Picker app/C++/ScenarioMultiple.xaml.h [code]
Contact Picker app/C++/ScenarioSingle.xaml.cpp [code]
Contact Picker app/C++/ScenarioSingle.xaml.h [code]
Contact Picker app/C++/Common/LayoutAwarePage.cpp [code]
Contact Picker app/C++/Common/LayoutAwarePage.h [code]
Contact Picker app/C++/Sample-Utils/CppSamplesUtils.h [code]
Context menu/C++/App.xaml.cpp [code]
Context menu/C++/App.xaml.h [code]
Context menu/C++/Constants.cpp [code]
Context menu/C++/Constants.h [code]
Context menu/C++/MainPage.xaml.cpp [code]
Context menu/C++/MainPage.xaml.h [code]
Context menu/C++/pch.cpp [code]
Context menu/C++/pch.h [code]
Context menu/C++/Scenario1.xaml.cpp [code]
Context menu/C++/Scenario1.xaml.h [code]
Context menu/C++/Scenario2.xaml.cpp [code]
Context menu/C++/Scenario2.xaml.h [code]
Context menu/C++/common/LayoutAwarePage.cpp [code]
Context menu/C++/common/LayoutAwarePage.h [code]
Context menu/C++/common/suspensionmanager.cpp [code]
Context menu/C++/common/suspensionmanager.h [code]
ControlChannelTrigger StreamSocket/C++/Background/Background.cpp [code]
ControlChannelTrigger StreamSocket/C++/Background/Background.h [code]
ControlChannelTrigger StreamSocket/C++/Background/pch.cpp [code]
ControlChannelTrigger StreamSocket/C++/Background/pch.h [code]
ControlChannelTrigger StreamWebSocket/C++/Background/pch.cpp [code]
ControlChannelTrigger StreamWebSocket/C++/Background/pch.h [code]
ControlChannelTrigger XMLHTTPRequest/C++/Background/Background.h [code]
ControlChannelTrigger XMLHTTPRequest/C++/Background/pch.cpp [code]
ControlChannelTrigger XMLHTTPRequest/C++/Background/pch.h [code]
Credential locker/C++/App.xaml.cpp [code]
Credential locker/C++/App.xaml.h [code]
Credential locker/C++/Constants.cpp [code]
Credential locker/C++/Constants.h [code]
Credential locker/C++/MainPage.xaml.cpp [code]
Credential locker/C++/MainPage.xaml.h [code]
Credential locker/C++/pch.cpp [code]
Credential locker/C++/pch.h [code]
Credential locker/C++/Scenario1.xaml.cpp [code]
Credential locker/C++/Scenario1.xaml.h [code]
Credential locker/C++/Scenario2.xaml.cpp [code]
Credential locker/C++/Scenario2.xaml.h [code]
Credential locker/C++/Scenario3.xaml.cpp [code]
Credential locker/C++/Scenario3.xaml.h [code]
Credential locker/C++/Scenario4.xaml.cpp [code]
Credential locker/C++/Scenario4.xaml.h [code]
Credential locker/C++/common/LayoutAwarePage.cpp [code]
Credential locker/C++/common/LayoutAwarePage.h [code]
Credential locker/C++/common/suspensionmanager.cpp [code]
Credential locker/C++/common/suspensionmanager.h [code]
Credential picker/C++/App.xaml.cpp [code]
Credential picker/C++/App.xaml.h [code]
Credential picker/C++/CppSamplesUtils.h [code]
Credential picker/C++/MainPage.xaml.cpp [code]
Credential picker/C++/MainPage.xaml.h [code]
Credential picker/C++/pch.cpp [code]
Credential picker/C++/pch.h [code]
Credential picker/C++/ScenarioInput1.xaml.cpp [code]
Credential picker/C++/ScenarioInput1.xaml.h [code]
Credential picker/C++/ScenarioInput2.xaml.cpp [code]
Credential picker/C++/ScenarioInput2.xaml.h [code]
Credential picker/C++/ScenarioInput3.xaml.cpp [code]
Credential picker/C++/ScenarioInput3.xaml.h [code]
Credential picker/C++/ScenarioList.xaml.cpp [code]
Credential picker/C++/ScenarioList.xaml.h [code]
Credential picker/C++/ScenarioOutput1.xaml.cpp [code]
Credential picker/C++/ScenarioOutput1.xaml.h [code]
Credential picker/C++/ScenarioOutput2.xaml.cpp [code]
Credential picker/C++/ScenarioOutput2.xaml.h [code]
Credential picker/C++/ScenarioOutput3.xaml.cpp [code]
Credential picker/C++/ScenarioOutput3.xaml.h [code]
CryptoWinRT/C++/App.xaml.cpp [code]
CryptoWinRT/C++/App.xaml.h [code]
CryptoWinRT/C++/Constants.cpp [code]
CryptoWinRT/C++/Constants.h [code]
CryptoWinRT/C++/MainPage.xaml.cpp [code]
CryptoWinRT/C++/MainPage.xaml.h [code]
CryptoWinRT/C++/pch.cpp [code]
CryptoWinRT/C++/pch.h [code]
CryptoWinRT/C++/Scenario1.xaml.cpp [code]
CryptoWinRT/C++/Scenario1.xaml.h [code]
CryptoWinRT/C++/Scenario10.xaml.cpp [code]
CryptoWinRT/C++/Scenario10.xaml.h [code]
CryptoWinRT/C++/Scenario2.xaml.cpp [code]
CryptoWinRT/C++/Scenario2.xaml.h [code]
CryptoWinRT/C++/Scenario3.xaml.cpp [code]
CryptoWinRT/C++/Scenario3.xaml.h [code]
CryptoWinRT/C++/Scenario4.xaml.cpp [code]
CryptoWinRT/C++/Scenario4.xaml.h [code]
CryptoWinRT/C++/Scenario5.xaml.cpp [code]
CryptoWinRT/C++/Scenario5.xaml.h [code]
CryptoWinRT/C++/Scenario6.xaml.cpp [code]
CryptoWinRT/C++/Scenario6.xaml.h [code]
CryptoWinRT/C++/Scenario7.xaml.cpp [code]
CryptoWinRT/C++/Scenario7.xaml.h [code]
CryptoWinRT/C++/Scenario8.xaml.cpp [code]
CryptoWinRT/C++/Scenario8.xaml.h [code]
CryptoWinRT/C++/Scenario9.xaml.cpp [code]
CryptoWinRT/C++/Scenario9.xaml.h [code]
CryptoWinRT/C++/common/LayoutAwarePage.cpp [code]
CryptoWinRT/C++/common/LayoutAwarePage.h [code]
CryptoWinRT/C++/common/suspensionmanager.cpp [code]
CryptoWinRT/C++/common/suspensionmanager.h [code]
Custom driver access/C#,C++/app_cs/App.xaml.cs [code]
Custom driver access/C#,C++/app_cs/Constants.cs [code]
Custom driver access/C#,C++/app_cs/DeviceList.cs [code]
Custom driver access/C#,C++/app_cs/MainPage.xaml.cs [code]
Custom driver access/C#,C++/app_cs/Scenario4_DeviceAsync.xaml.cs [code]
Custom driver access/C#,C++/app_cs/common/LayoutAwarePage.cs [code]
Custom driver access/C#,C++/app_cs/Properties/AssemblyInfo.cs [code]
Custom driver access/C#,C++/DLL/fx2device.cpp [code]
Custom driver access/C#,C++/DLL/fx2device.h [code]
Custom driver access/C#,C++/DLL/public.h [code]
Custom driver access/C#,C++/DLL/repeater.h [code]
Custom driver access/C#,C++/DLL/support.h [code]
Custom driver access/C#,C++/DLL/WUDFOsrUsbPublic.h [code]
Custom driver access/C++,JavaScript/DLL/fx2device.cpp [code]
Custom driver access/C++,JavaScript/DLL/fx2device.h [code]
Custom driver access/C++,JavaScript/DLL/public.h [code]
Custom driver access/C++,JavaScript/DLL/repeater.h [code]
Custom driver access/C++,JavaScript/DLL/support.h [code]
Custom driver access/C++,JavaScript/DLL/WUDFOsrUsbPublic.h [code]
Custom driver access/C++/app_cpp/App.xaml.cpp [code]
Custom driver access/C++/app_cpp/App.xaml.h [code]
Custom driver access/C++/app_cpp/Constants.cpp [code]
Custom driver access/C++/app_cpp/Constants.h [code]
Custom driver access/C++/app_cpp/DeviceList.cpp [code]
Custom driver access/C++/app_cpp/DeviceList.h [code]
Custom driver access/C++/app_cpp/MainPage.xaml.cpp [code]
Custom driver access/C++/app_cpp/MainPage.xaml.h [code]
Custom driver access/C++/app_cpp/pch.cpp [code]
Custom driver access/C++/app_cpp/pch.h [code]
Custom driver access/C++/app_cpp/Scenario1_DeviceConnect.xaml.h [code]
Custom driver access/C++/app_cpp/Scenario3_DeviceEvents.xaml.cpp [code]
Custom driver access/C++/app_cpp/Scenario3_DeviceEvents.xaml.h [code]
Custom driver access/C++/app_cpp/Scenario4_DeviceAsync.xaml.cpp [code]
Custom driver access/C++/app_cpp/Scenario4_DeviceAsync.xaml.h [code]
Custom driver access/C++/app_cpp/common/LayoutAwarePage.cpp [code]
Custom driver access/C++/app_cpp/common/LayoutAwarePage.h [code]
Custom driver access/C++/app_cpp/common/suspensionmanager.cpp [code]
Custom driver access/C++/app_cpp/common/suspensionmanager.h [code]
Custom driver access/C++/DLL/fx2device.cpp [code]
Custom driver access/C++/DLL/fx2device.h [code]
Custom driver access/C++/DLL/public.h [code]
Custom driver access/C++/DLL/repeater.h [code]
Custom driver access/C++/DLL/support.h [code]
Custom driver access/C++/DLL/WUDFOsrUsbPublic.h [code]
DatagramSocket/C++/App.xaml.cpp [code]
DatagramSocket/C++/App.xaml.h [code]
DatagramSocket/C++/Constants.cpp [code]
DatagramSocket/C++/Constants.h [code]
DatagramSocket/C++/MainPage.xaml.cpp [code]
DatagramSocket/C++/MainPage.xaml.h [code]
DatagramSocket/C++/pch.cpp [code]
DatagramSocket/C++/pch.h [code]
DatagramSocket/C++/Scenario1.xaml.cpp [code]
DatagramSocket/C++/Scenario1.xaml.h [code]
DatagramSocket/C++/Scenario2.xaml.cpp [code]
DatagramSocket/C++/Scenario2.xaml.h [code]
DatagramSocket/C++/Scenario3.xaml.cpp [code]
DatagramSocket/C++/Scenario3.xaml.h [code]
DatagramSocket/C++/Scenario4.xaml.cpp [code]
DatagramSocket/C++/Scenario4.xaml.h [code]
DatagramSocket/C++/Common/LayoutAwarePage.cpp [code]
DatagramSocket/C++/Common/LayoutAwarePage.h [code]
DatagramSocket/C++/sample-utils/CppSamplesUtils.h [code]
Date and time formatting/C++/App.xaml.cpp [code]
Date and time formatting/C++/App.xaml.h [code]
Date and time formatting/C++/Constants.cpp [code]
Date and time formatting/C++/Constants.h [code]
Date and time formatting/C++/LongAndShortFormats.xaml.cpp [code]
Date and time formatting/C++/LongAndShortFormats.xaml.h [code]
Date and time formatting/C++/MainPage.xaml.cpp [code]
Date and time formatting/C++/MainPage.xaml.h [code]
Date and time formatting/C++/OverrideSettings.xaml.cpp [code]
Date and time formatting/C++/OverrideSettings.xaml.h [code]
Date and time formatting/C++/ParametrizedTemplate.xaml.cpp [code]
Date and time formatting/C++/ParametrizedTemplate.xaml.h [code]
Date and time formatting/C++/pch.cpp [code]
Date and time formatting/C++/pch.h [code]
Date and time formatting/C++/StringTemplate.xaml.cpp [code]
Date and time formatting/C++/StringTemplate.xaml.h [code]
Date and time formatting/C++/common/LayoutAwarePage.cpp [code]
Date and time formatting/C++/common/LayoutAwarePage.h [code]
Date and time formatting/C++/common/suspensionmanager.cpp [code]
Date and time formatting/C++/common/suspensionmanager.h [code]
Device app for printers SDK/C++/BackgroundTask/pch.cpp [code]
Device app for printers SDK/C++/BackgroundTask/pch.h [code]
Device app for printers SDK/C++/DeviceAppForPrinters/App.xaml.h [code]
Device app for printers SDK/C++/DeviceAppForPrinters/Constants.h [code]
Device app for printers SDK/C++/DeviceAppForPrinters/pch.cpp [code]
Device app for printers SDK/C++/DeviceAppForPrinters/pch.h [code]
Device auto rotation preferences/C++/App.xaml.cpp [code]
Device auto rotation preferences/C++/App.xaml.h [code]
Device auto rotation preferences/C++/Constants.cpp [code]
Device auto rotation preferences/C++/Constants.h [code]
Device auto rotation preferences/C++/Landscape.xaml.cpp [code]
Device auto rotation preferences/C++/Landscape.xaml.h [code]
Device auto rotation preferences/C++/LandscapeFlipped.xaml.cpp [code]
Device auto rotation preferences/C++/LandscapeFlipped.xaml.h [code]
Device auto rotation preferences/C++/MainPage.xaml.cpp [code]
Device auto rotation preferences/C++/MainPage.xaml.h [code]
Device auto rotation preferences/C++/None.xaml.cpp [code]
Device auto rotation preferences/C++/None.xaml.h [code]
Device auto rotation preferences/C++/pch.cpp [code]
Device auto rotation preferences/C++/pch.h [code]
Device auto rotation preferences/C++/Portrait.xaml.cpp [code]
Device auto rotation preferences/C++/Portrait.xaml.h [code]
Device auto rotation preferences/C++/PortraitFlipped.xaml.cpp [code]
Device auto rotation preferences/C++/PortraitFlipped.xaml.h [code]
Device auto rotation preferences/C++/common/LayoutAwarePage.cpp [code]
Device auto rotation preferences/C++/common/LayoutAwarePage.h [code]
Device auto rotation preferences/C++/common/suspensionmanager.h [code]
Device enumeration/C++/App.xaml.cpp [code]
Device enumeration/C++/App.xaml.h [code]
Device enumeration/C++/Constants.cpp [code]
Device enumeration/C++/Constants.h [code]
Device enumeration/C++/Containers.xaml.cpp [code]
Device enumeration/C++/Containers.xaml.h [code]
Device enumeration/C++/Interfaces.xaml.cpp [code]
Device enumeration/C++/Interfaces.xaml.h [code]
Device enumeration/C++/MainPage.xaml.cpp [code]
Device enumeration/C++/MainPage.xaml.h [code]
Device enumeration/C++/pch.cpp [code]
Device enumeration/C++/pch.h [code]
Device enumeration/C++/common/LayoutAwarePage.cpp [code]
Device enumeration/C++/common/LayoutAwarePage.h [code]
Device enumeration/C++/common/suspensionmanager.cpp [code]
Device enumeration/C++/common/suspensionmanager.h [code]
Direct2D 3D transform effect/C++/App.xaml.cpp [code]
Direct2D 3D transform effect/C++/App.xaml.h [code]
Direct2D 3D transform effect/C++/D2D3DTransformsRenderer.cpp [code]
Direct2D 3D transform effect/C++/D2D3DTransformsRenderer.h [code]
Direct2D 3D transform effect/C++/DirectXBase.cpp [code]
Direct2D 3D transform effect/C++/DirectXBase.h [code]
Direct2D 3D transform effect/C++/DirectXSample.h [code]
Direct2D 3D transform effect/C++/MainPage.xaml.cpp [code]
Direct2D 3D transform effect/C++/MainPage.xaml.h [code]
Direct2D 3D transform effect/C++/pch.cpp [code]
Direct2D 3D transform effect/C++/pch.h [code]
Direct2D 3D transform effect/C++/PersistentState.cpp [code]
Direct2D 3D transform effect/C++/PersistentState.h [code]
Direct2D and DirectWrite animated text on a path/C++/pch.cpp [code]
Direct2D and DirectWrite animated text on a path/C++/pch.h [code]
Direct2D animated text/C++/D2DTextAnimation.cpp [code]
Direct2D animated text/C++/D2DTextAnimation.h [code]
Direct2D animated text/C++/DirectXBase.cpp [code]
Direct2D animated text/C++/DirectXBase.h [code]
Direct2D animated text/C++/DirectXSample.h [code]
Direct2D animated text/C++/pch.cpp [code]
Direct2D animated text/C++/pch.h [code]
Direct2D animated text/C++/SampleOverlay.cpp [code]
Direct2D animated text/C++/SampleOverlay.h [code]
Direct2D animation/C++/animation.h [code]
Direct2D animation/C++/D2DBasicAnimation.cpp [code]
Direct2D animation/C++/D2DBasicAnimation.h [code]
Direct2D animation/C++/DirectXBase.cpp [code]
Direct2D animation/C++/DirectXBase.h [code]
Direct2D animation/C++/DirectXSample.h [code]
Direct2D animation/C++/pch.cpp [code]
Direct2D animation/C++/pch.h [code]
Direct2D animation/C++/SampleOverlay.cpp [code]
Direct2D animation/C++/SampleOverlay.h [code]
Direct2D basic image effects/C++/D2DEffectsHelloWorld.cpp [code]
Direct2D basic image effects/C++/D2DEffectsHelloWorld.h [code]
Direct2D basic image effects/C++/DirectXBase.cpp [code]
Direct2D basic image effects/C++/DirectXBase.h [code]
Direct2D basic image effects/C++/DirectXSample.h [code]
Direct2D basic image effects/C++/pch.cpp [code]
Direct2D basic image effects/C++/pch.h [code]
Direct2D basic image effects/C++/SampleOverlay.cpp [code]
Direct2D basic image effects/C++/SampleOverlay.h [code]
Direct2D command list/C++/BasicTimer.cpp [code]
Direct2D command list/C++/BasicTimer.h [code]
Direct2D command list/C++/CommandListSample.cpp [code]
Direct2D command list/C++/CommandListSample.h [code]
Direct2D command list/C++/DirectXBase.cpp [code]
Direct2D command list/C++/DirectXBase.h [code]
Direct2D command list/C++/DirectXSample.h [code]
Direct2D command list/C++/pch.cpp [code]
Direct2D command list/C++/pch.h [code]
Direct2D command list/C++/SampleOverlay.cpp [code]
Direct2D command list/C++/SampleOverlay.h [code]
Direct2D composite effect modes/C++/CompositeModes.cpp [code]
Direct2D composite effect modes/C++/CompositeModes.h [code]
Direct2D composite effect modes/C++/DirectXBase.cpp [code]
Direct2D composite effect modes/C++/DirectXBase.h [code]
Direct2D composite effect modes/C++/DirectXSample.h [code]
Direct2D composite effect modes/C++/pch.cpp [code]
Direct2D composite effect modes/C++/pch.h [code]
Direct2D composite effect modes/C++/SampleOverlay.cpp [code]
Direct2D composite effect modes/C++/SampleOverlay.h [code]
Direct2D convolve matrix effect/C++/ConvolutionKernels.h [code]
Direct2D convolve matrix effect/C++/ConvolveMatrixEffect.cpp [code]
Direct2D convolve matrix effect/C++/ConvolveMatrixEffect.h [code]
Direct2D convolve matrix effect/C++/DirectXBase.cpp [code]
Direct2D convolve matrix effect/C++/DirectXBase.h [code]
Direct2D convolve matrix effect/C++/DirectXSample.h [code]
Direct2D convolve matrix effect/C++/pch.cpp [code]
Direct2D convolve matrix effect/C++/pch.h [code]
Direct2D convolve matrix effect/C++/SampleOverlay.cpp [code]
Direct2D convolve matrix effect/C++/SampleOverlay.h [code]
Direct2D custom image effects/C++/ComputeShader/DirectXBase.cpp [code]
Direct2D custom image effects/C++/ComputeShader/DirectXBase.h [code]
Direct2D custom image effects/C++/ComputeShader/DirectXSample.h [code]
Direct2D custom image effects/C++/ComputeShader/pch.cpp [code]
Direct2D custom image effects/C++/ComputeShader/pch.h [code]
Direct2D custom image effects/C++/ComputeShader/SampleOverlay.h [code]
Direct2D custom image effects/C++/PixelShader/BasicTimer.cpp [code]
Direct2D custom image effects/C++/PixelShader/BasicTimer.h [code]
Direct2D custom image effects/C++/PixelShader/DirectXBase.cpp [code]
Direct2D custom image effects/C++/PixelShader/DirectXBase.h [code]
Direct2D custom image effects/C++/PixelShader/DirectXSample.h [code]
Direct2D custom image effects/C++/PixelShader/pch.cpp [code]
Direct2D custom image effects/C++/PixelShader/pch.h [code]
Direct2D custom image effects/C++/PixelShader/RippleEffect.cpp [code]
Direct2D custom image effects/C++/PixelShader/RippleEffect.h [code]
Direct2D custom image effects/C++/PixelShader/SampleOverlay.cpp [code]
Direct2D custom image effects/C++/PixelShader/SampleOverlay.h [code]
Direct2D custom image effects/C++/VertexShader/BasicTimer.cpp [code]
Direct2D custom image effects/C++/VertexShader/BasicTimer.h [code]
Direct2D custom image effects/C++/VertexShader/DirectXBase.cpp [code]
Direct2D custom image effects/C++/VertexShader/DirectXBase.h [code]
Direct2D custom image effects/C++/VertexShader/DirectXSample.h [code]
Direct2D custom image effects/C++/VertexShader/pch.cpp [code]
Direct2D custom image effects/C++/VertexShader/pch.h [code]
Direct2D custom image effects/C++/VertexShader/SampleOverlay.cpp [code]
Direct2D custom image effects/C++/VertexShader/SampleOverlay.h [code]
Direct2D custom image effects/C++/VertexShader/WaveEffect.cpp [code]
Direct2D custom image effects/C++/VertexShader/WaveEffect.h [code]
Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.cpp [code]
Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.h [code]
Direct2D effects on primitives/C++/DirectXBase.cpp [code]
Direct2D effects on primitives/C++/DirectXBase.h [code]
Direct2D effects on primitives/C++/DirectXSample.h [code]
Direct2D effects on primitives/C++/pch.cpp [code]
Direct2D effects on primitives/C++/pch.h [code]
Direct2D effects on primitives/C++/SampleOverlay.cpp [code]
Direct2D effects on primitives/C++/SampleOverlay.h [code]
Direct2D geometry realization/C++/DirectXBase.cpp [code]
Direct2D geometry realization/C++/DirectXBase.h [code]
Direct2D geometry realization/C++/DirectXSample.h [code]
Direct2D geometry realization/C++/FPSCounter.cpp [code]
Direct2D geometry realization/C++/FPSCounter.h [code]
Direct2D geometry realization/C++/GeometryRealizationPackage.cpp [code]
Direct2D geometry realization/C++/GeometryRealizationPackage.h [code]
Direct2D geometry realization/C++/GeometryRealizationSample.cpp [code]
Direct2D geometry realization/C++/GeometryRealizationSample.h [code]
Direct2D geometry realization/C++/pch.cpp [code]
Direct2D geometry realization/C++/pch.h [code]
Direct2D geometry realization/C++/SampleOverlay.cpp [code]
Direct2D geometry realization/C++/SampleOverlay.h [code]
Direct2D interpolation modes/C++/BasicTimer.cpp [code]
Direct2D interpolation modes/C++/BasicTimer.h [code]
Direct2D interpolation modes/C++/D2DInterpolationModes.cpp [code]
Direct2D interpolation modes/C++/D2DInterpolationModes.h [code]
Direct2D interpolation modes/C++/DirectXBase.cpp [code]
Direct2D interpolation modes/C++/DirectXBase.h [code]
Direct2D interpolation modes/C++/DirectXSample.h [code]
Direct2D interpolation modes/C++/pch.cpp [code]
Direct2D interpolation modes/C++/pch.h [code]
Direct2D interpolation modes/C++/SampleOverlay.cpp [code]
Direct2D interpolation modes/C++/SampleOverlay.h [code]
Direct2D magazine app/C++/App.xaml.cpp [code]
Direct2D magazine app/C++/App.xaml.h [code]
Direct2D magazine app/C++/ContentImageSource.cpp [code]
Direct2D magazine app/C++/ContentImageSource.h [code]
Direct2D magazine app/C++/Design.cpp [code]
Direct2D magazine app/C++/Design.h [code]
Direct2D magazine app/C++/Document.cpp [code]
Direct2D magazine app/C++/Document.h [code]
Direct2D magazine app/C++/Element.cpp [code]
Direct2D magazine app/C++/Element.h [code]
Direct2D magazine app/C++/FontFileStream.cpp [code]
Direct2D magazine app/C++/FontFileStream.h [code]
Direct2D magazine app/C++/FontLoader.cpp [code]
Direct2D magazine app/C++/FontLoader.h [code]
Direct2D magazine app/C++/Image.cpp [code]
Direct2D magazine app/C++/Image.h [code]
Direct2D magazine app/C++/ImageFile.cpp [code]
Direct2D magazine app/C++/ImageFile.h [code]
Direct2D magazine app/C++/ImageFrame.cpp [code]
Direct2D magazine app/C++/ImageFrame.h [code]
Direct2D magazine app/C++/Layer.cpp [code]
Direct2D magazine app/C++/Layer.h [code]
Direct2D magazine app/C++/List.cpp [code]
Direct2D magazine app/C++/List.h [code]
Direct2D magazine app/C++/MainPage.xaml.cpp [code]
Direct2D magazine app/C++/MainPage.xaml.h [code]
Direct2D magazine app/C++/Page.cpp [code]
Direct2D magazine app/C++/Page.h [code]
Direct2D magazine app/C++/PageModel.cpp [code]
Direct2D magazine app/C++/PageModel.h [code]
Direct2D magazine app/C++/PageRoll.cpp [code]
Direct2D magazine app/C++/PageRoll.h [code]
Direct2D magazine app/C++/pch.cpp [code]
Direct2D magazine app/C++/pch.h [code]
Direct2D magazine app/C++/Rectangle.cpp [code]
Direct2D magazine app/C++/Rectangle.h [code]
Direct2D magazine app/C++/Renderer.cpp [code]
Direct2D magazine app/C++/Renderer.h [code]
Direct2D magazine app/C++/Resource.cpp [code]
Direct2D magazine app/C++/Resource.h [code]
Direct2D magazine app/C++/Story.cpp [code]
Direct2D magazine app/C++/Story.h [code]
Direct2D magazine app/C++/Text.cpp [code]
Direct2D magazine app/C++/Text.h [code]
Direct2D magazine app/C++/TextFrame.cpp [code]
Direct2D magazine app/C++/TextFrame.h [code]
Direct2D magazine app/C++/TreeIterator.h [code]
Direct2D perspective transform/C++/D2DPerspectiveTransform.cpp [code]
Direct2D perspective transform/C++/D2DPerspectiveTransform.h [code]
Direct2D perspective transform/C++/DirectXBase.cpp [code]
Direct2D perspective transform/C++/DirectXBase.h [code]
Direct2D perspective transform/C++/DirectXSample.h [code]
Direct2D perspective transform/C++/pch.cpp [code]
Direct2D perspective transform/C++/pch.h [code]
Direct2D perspective transform/C++/SampleOverlay.cpp [code]
Direct2D perspective transform/C++/SampleOverlay.h [code]
Direct2D printing images and effects/C++/D2DPageRenderer.cpp [code]
Direct2D printing images and effects/C++/D2DPageRenderer.h [code]
Direct2D printing images and effects/C++/DirectXApp.cpp [code]
Direct2D printing images and effects/C++/DirectXApp.h [code]
Direct2D printing images and effects/C++/DirectXBase.cpp [code]
Direct2D printing images and effects/C++/DirectXBase.h [code]
Direct2D printing images and effects/C++/DirectXSample.h [code]
Direct2D printing images and effects/C++/DocSource.cpp [code]
Direct2D printing images and effects/C++/DocSource.h [code]
Direct2D printing images and effects/C++/pch.cpp [code]
Direct2D printing images and effects/C++/pch.h [code]
Direct2D printing images and effects/C++/SampleOverlay.cpp [code]
Direct2D printing images and effects/C++/SampleOverlay.h [code]
Direct2D save to image file/C++/DirectXBase.cpp [code]
Direct2D save to image file/C++/DirectXBase.h [code]
Direct2D save to image file/C++/DirectXSample.h [code]
Direct2D save to image file/C++/pch.cpp [code]
Direct2D save to image file/C++/pch.h [code]
Direct2D save to image file/C++/SampleOverlay.cpp [code]
Direct2D save to image file/C++/SampleOverlay.h [code]
Direct2D save to image file/C++/SaveAsImageFileSample.cpp [code]
Direct2D save to image file/C++/SaveAsImageFileSample.h [code]
Direct2Dapp printing/C++/D2DPageRenderer.cpp [code]
Direct2Dapp printing/C++/D2DPageRenderer.h [code]
Direct2Dapp printing/C++/D2DPageRendererContext.cpp [code]
Direct2Dapp printing/C++/D2DPageRendererContext.h [code]
Direct2Dapp printing/C++/DirectXApp.cpp [code]
Direct2Dapp printing/C++/DirectXApp.h [code]
Direct2Dapp printing/C++/DirectXBase.cpp [code]
Direct2Dapp printing/C++/DirectXBase.h [code]
Direct2Dapp printing/C++/DirectXSample.h [code]
Direct2Dapp printing/C++/DocSource.cpp [code]
Direct2Dapp printing/C++/DocSource.h [code]
Direct2Dapp printing/C++/pch.cpp [code]
Direct2Dapp printing/C++/pch.h [code]
Direct2Dapp printing/C++/SampleOverlay.cpp [code]
Direct2Dapp printing/C++/SampleOverlay.h [code]
Direct3D bump mapping/C++/BasicCamera.cpp [code]
Direct3D bump mapping/C++/BasicCamera.h [code]
Direct3D bump mapping/C++/BasicLoader.cpp [code]
Direct3D bump mapping/C++/BasicLoader.h [code]
Direct3D bump mapping/C++/BasicMath.h [code]
Direct3D bump mapping/C++/BasicReaderWriter.cpp [code]
Direct3D bump mapping/C++/BasicReaderWriter.h [code]
Direct3D bump mapping/C++/BasicShapes.cpp [code]
Direct3D bump mapping/C++/BasicShapes.h [code]
Direct3D bump mapping/C++/BasicTimer.cpp [code]
Direct3D bump mapping/C++/BasicTimer.h [code]
Direct3D bump mapping/C++/BumpMapping.cpp [code]
Direct3D bump mapping/C++/BumpMapping.h [code]
Direct3D bump mapping/C++/DDSTextureLoader.cpp [code]
Direct3D bump mapping/C++/DDSTextureLoader.h [code]
Direct3D bump mapping/C++/DirectXApp.cpp [code]
Direct3D bump mapping/C++/DirectXApp.h [code]
Direct3D bump mapping/C++/DirectXBase.cpp [code]
Direct3D bump mapping/C++/DirectXBase.h [code]
Direct3D bump mapping/C++/DirectXSample.h [code]
Direct3D bump mapping/C++/LonLatController.cpp [code]
Direct3D bump mapping/C++/LonLatController.h [code]
Direct3D bump mapping/C++/pch.cpp [code]
Direct3D bump mapping/C++/pch.h [code]
Direct3D bump mapping/C++/SampleOverlay.cpp [code]
Direct3D bump mapping/C++/SampleOverlay.h [code]
Direct3D HLSL fractal generator/C++/AutoThrottle.cpp [code]
Direct3D HLSL fractal generator/C++/AutoThrottle.h [code]
Direct3D HLSL fractal generator/C++/BasicLoader.cpp [code]
Direct3D HLSL fractal generator/C++/BasicLoader.h [code]
Direct3D HLSL fractal generator/C++/BasicMath.h [code]
Direct3D HLSL fractal generator/C++/BasicReaderWriter.cpp [code]
Direct3D HLSL fractal generator/C++/BasicReaderWriter.h [code]
Direct3D HLSL fractal generator/C++/BasicShapes.cpp [code]
Direct3D HLSL fractal generator/C++/BasicShapes.h [code]
Direct3D HLSL fractal generator/C++/BasicTimer.cpp [code]
Direct3D HLSL fractal generator/C++/BasicTimer.h [code]
Direct3D HLSL fractal generator/C++/DDSTextureLoader.cpp [code]
Direct3D HLSL fractal generator/C++/DDSTextureLoader.h [code]
Direct3D HLSL fractal generator/C++/DirectXApp.cpp [code]
Direct3D HLSL fractal generator/C++/DirectXApp.h [code]
Direct3D HLSL fractal generator/C++/DirectXBase.cpp [code]
Direct3D HLSL fractal generator/C++/DirectXBase.h [code]
Direct3D HLSL fractal generator/C++/DirectXFractal.cpp [code]
Direct3D HLSL fractal generator/C++/DirectXFractal.h [code]
Direct3D HLSL fractal generator/C++/DirectXSample.h [code]
Direct3D HLSL fractal generator/C++/DoublePrecisionMath.h [code]
Direct3D HLSL fractal generator/C++/pch.cpp [code]
Direct3D HLSL fractal generator/C++/pch.h [code]
Direct3D HLSL fractal generator/C++/SampleOverlay.cpp [code]
Direct3D HLSL fractal generator/C++/SampleOverlay.h [code]
Direct3D post-processing effects/C++/BasicCamera.cpp [code]
Direct3D post-processing effects/C++/BasicCamera.h [code]
Direct3D post-processing effects/C++/BasicLoader.cpp [code]
Direct3D post-processing effects/C++/BasicLoader.h [code]
Direct3D post-processing effects/C++/BasicMath.h [code]
Direct3D post-processing effects/C++/BasicReaderWriter.cpp [code]
Direct3D post-processing effects/C++/BasicReaderWriter.h [code]
Direct3D post-processing effects/C++/BasicShapes.cpp [code]
Direct3D post-processing effects/C++/BasicShapes.h [code]
Direct3D post-processing effects/C++/BasicTimer.cpp [code]
Direct3D post-processing effects/C++/BasicTimer.h [code]
Direct3D post-processing effects/C++/D3DPostProcessing.cpp [code]
Direct3D post-processing effects/C++/D3DPostProcessing.h [code]
Direct3D post-processing effects/C++/DDSTextureLoader.cpp [code]
Direct3D post-processing effects/C++/DDSTextureLoader.h [code]
Direct3D post-processing effects/C++/DirectXApp.cpp [code]
Direct3D post-processing effects/C++/DirectXApp.h [code]
Direct3D post-processing effects/C++/DirectXBase.cpp [code]
Direct3D post-processing effects/C++/DirectXBase.h [code]
Direct3D post-processing effects/C++/DirectXSample.h [code]
Direct3D post-processing effects/C++/pch.cpp [code]
Direct3D post-processing effects/C++/pch.h [code]
Direct3D post-processing effects/C++/SampleOverlay.cpp [code]
Direct3D post-processing effects/C++/SampleOverlay.h [code]
Direct3D resource loading/C++/BasicCamera.cpp [code]
Direct3D resource loading/C++/BasicCamera.h [code]
Direct3D resource loading/C++/BasicLoader.cpp [code]
Direct3D resource loading/C++/BasicLoader.h [code]
Direct3D resource loading/C++/BasicMath.h [code]
Direct3D resource loading/C++/BasicReaderWriter.cpp [code]
Direct3D resource loading/C++/BasicReaderWriter.h [code]
Direct3D resource loading/C++/BasicShapes.cpp [code]
Direct3D resource loading/C++/BasicShapes.h [code]
Direct3D resource loading/C++/BasicTimer.cpp [code]
Direct3D resource loading/C++/BasicTimer.h [code]
Direct3D resource loading/C++/DDSTextureLoader.cpp [code]
Direct3D resource loading/C++/DDSTextureLoader.h [code]
Direct3D resource loading/C++/DirectXApp.cpp [code]
Direct3D resource loading/C++/DirectXApp.h [code]
Direct3D resource loading/C++/DirectXBase.cpp [code]
Direct3D resource loading/C++/DirectXBase.h [code]
Direct3D resource loading/C++/DirectXSample.h [code]
Direct3D resource loading/C++/LonLatController.cpp [code]
Direct3D resource loading/C++/LonLatController.h [code]
Direct3D resource loading/C++/pch.cpp [code]
Direct3D resource loading/C++/pch.h [code]
Direct3D resource loading/C++/ResourceLoading.cpp [code]
Direct3D resource loading/C++/ResourceLoading.h [code]
Direct3D resource loading/C++/SampleOverlay.cpp [code]
Direct3D resource loading/C++/SampleOverlay.h [code]
Direct3D resource loading/C++/obj2vbo/BasicMath.h [code]
Direct3D resource loading/C++/obj2vbo/obj2vbo.cpp [code]
Direct3D resource loading/C++/texconv/BC.cpp [code]
Direct3D resource loading/C++/texconv/BC.h [code]
Direct3D resource loading/C++/texconv/BC4BC5.cpp [code]
Direct3D resource loading/C++/texconv/BC6HBC7.cpp [code]
Direct3D resource loading/C++/texconv/DDS.h [code]
Direct3D resource loading/C++/texconv/DirectXTex.h [code]
Direct3D resource loading/C++/texconv/DirectXTex.inl [code]
Direct3D resource loading/C++/texconv/DirectXTexCompress.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexConvert.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexD3D11.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexDDS.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexFlipRotate.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexImage.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexMipmaps.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexMisc.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexNormalMaps.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexP.h [code]
Direct3D resource loading/C++/texconv/DirectXTexResize.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexTGA.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexUtil.cpp [code]
Direct3D resource loading/C++/texconv/DirectXTexWIC.cpp [code]
Direct3D resource loading/C++/texconv/scoped.h [code]
Direct3D resource loading/C++/texconv/Texconv.cpp [code]
Direct3D sprite/C++/AutoThrottle.cpp [code]
Direct3D sprite/C++/AutoThrottle.h [code]
Direct3D sprite/C++/BasicLoader.cpp [code]
Direct3D sprite/C++/BasicLoader.h [code]
Direct3D sprite/C++/BasicMath.h [code]
Direct3D sprite/C++/BasicReaderWriter.cpp [code]
Direct3D sprite/C++/BasicReaderWriter.h [code]
Direct3D sprite/C++/BasicShapes.h [code]
Direct3D sprite/C++/BasicSprites.cpp [code]
Direct3D sprite/C++/BasicSprites.h [code]
Direct3D sprite/C++/BasicTimer.cpp [code]
Direct3D sprite/C++/BasicTimer.h [code]
Direct3D sprite/C++/DDSTextureLoader.cpp [code]
Direct3D sprite/C++/DDSTextureLoader.h [code]
Direct3D sprite/C++/DirectXApp.cpp [code]
Direct3D sprite/C++/DirectXApp.h [code]
Direct3D sprite/C++/DirectXBase.cpp [code]
Direct3D sprite/C++/DirectXBase.h [code]
Direct3D sprite/C++/DirectXSample.h [code]
Direct3D sprite/C++/pch.cpp [code]
Direct3D sprite/C++/pch.h [code]
Direct3D sprite/C++/SampleOverlay.cpp [code]
Direct3D sprite/C++/SampleOverlay.h [code]
Direct3D sprite/C++/SimpleSprites.cpp [code]
Direct3D sprite/C++/SimpleSprites.h [code]
Direct3D stereoscopic 3D/C++/BasicLoader.cpp [code]
Direct3D stereoscopic 3D/C++/BasicLoader.h [code]
Direct3D stereoscopic 3D/C++/BasicMath.h [code]
Direct3D stereoscopic 3D/C++/BasicReaderWriter.cpp [code]
Direct3D stereoscopic 3D/C++/BasicReaderWriter.h [code]
Direct3D stereoscopic 3D/C++/BasicShapes.cpp [code]
Direct3D stereoscopic 3D/C++/BasicShapes.h [code]
Direct3D stereoscopic 3D/C++/BasicTimer.cpp [code]
Direct3D stereoscopic 3D/C++/BasicTimer.h [code]
Direct3D stereoscopic 3D/C++/DDSTextureLoader.cpp [code]
Direct3D stereoscopic 3D/C++/DDSTextureLoader.h [code]
Direct3D stereoscopic 3D/C++/DirectXApp.cpp [code]
Direct3D stereoscopic 3D/C++/DirectXApp.h [code]
Direct3D stereoscopic 3D/C++/DirectXBase.cpp [code]
Direct3D stereoscopic 3D/C++/DirectXBase.h [code]
Direct3D stereoscopic 3D/C++/DirectXSample.h [code]
Direct3D stereoscopic 3D/C++/pch.cpp [code]
Direct3D stereoscopic 3D/C++/pch.h [code]
Direct3D stereoscopic 3D/C++/SampleOverlay.cpp [code]
Direct3D stereoscopic 3D/C++/SampleOverlay.h [code]
Direct3D stereoscopic 3D/C++/Stereo3DMatrixHelper.cpp [code]
Direct3D stereoscopic 3D/C++/Stereo3DMatrixHelper.h [code]
Direct3D stereoscopic 3D/C++/StereoSimpleD3D.cpp [code]
Direct3D stereoscopic 3D/C++/StereoSimpleD3D.h [code]
Direct3D tutorial/C++/Lesson1.Basics/DirectXSample.h [code]
Direct3D tutorial/C++/Lesson1.Basics/Main.cpp [code]
Direct3D tutorial/C++/Lesson1.Basics/pch.cpp [code]
Direct3D tutorial/C++/Lesson1.Basics/pch.h [code]
Direct3D tutorial/C++/Lesson2.Triangles/BasicMath.h [code]
Direct3D tutorial/C++/Lesson2.Triangles/BasicReaderWriter.cpp [code]
Direct3D tutorial/C++/Lesson2.Triangles/BasicReaderWriter.h [code]
Direct3D tutorial/C++/Lesson2.Triangles/DirectXSample.h [code]
Direct3D tutorial/C++/Lesson2.Triangles/Main.cpp [code]
Direct3D tutorial/C++/Lesson2.Triangles/pch.cpp [code]
Direct3D tutorial/C++/Lesson2.Triangles/pch.h [code]
Direct3D tutorial/C++/Lesson3.Cubes/BasicMath.h [code]
Direct3D tutorial/C++/Lesson3.Cubes/BasicReaderWriter.cpp [code]
Direct3D tutorial/C++/Lesson3.Cubes/BasicReaderWriter.h [code]
Direct3D tutorial/C++/Lesson3.Cubes/DirectXSample.h [code]
Direct3D tutorial/C++/Lesson3.Cubes/Main.cpp [code]
Direct3D tutorial/C++/Lesson3.Cubes/pch.cpp [code]
Direct3D tutorial/C++/Lesson3.Cubes/pch.h [code]
Direct3D tutorial/C++/Lesson4.Textures/BasicMath.h [code]
Direct3D tutorial/C++/Lesson4.Textures/BasicReaderWriter.cpp [code]
Direct3D tutorial/C++/Lesson4.Textures/BasicReaderWriter.h [code]
Direct3D tutorial/C++/Lesson4.Textures/DirectXSample.h [code]
Direct3D tutorial/C++/Lesson4.Textures/Main.cpp [code]
Direct3D tutorial/C++/Lesson4.Textures/pch.cpp [code]
Direct3D tutorial/C++/Lesson4.Textures/pch.h [code]
Direct3D tutorial/C++/Lesson5.Components/BasicCamera.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/BasicCamera.h [code]
Direct3D tutorial/C++/Lesson5.Components/BasicLoader.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/BasicLoader.h [code]
Direct3D tutorial/C++/Lesson5.Components/BasicMath.h [code]
Direct3D tutorial/C++/Lesson5.Components/BasicReaderWriter.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/BasicReaderWriter.h [code]
Direct3D tutorial/C++/Lesson5.Components/BasicShapes.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/BasicShapes.h [code]
Direct3D tutorial/C++/Lesson5.Components/BasicTimer.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/BasicTimer.h [code]
Direct3D tutorial/C++/Lesson5.Components/DDSTextureLoader.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/DDSTextureLoader.h [code]
Direct3D tutorial/C++/Lesson5.Components/Direct3DTutorial.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/Direct3DTutorial.h [code]
Direct3D tutorial/C++/Lesson5.Components/DirectXApp.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/DirectXApp.h [code]
Direct3D tutorial/C++/Lesson5.Components/DirectXBase.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/DirectXBase.h [code]
Direct3D tutorial/C++/Lesson5.Components/DirectXSample.h [code]
Direct3D tutorial/C++/Lesson5.Components/pch.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/pch.h [code]
Direct3D tutorial/C++/Lesson5.Components/SampleOverlay.cpp [code]
Direct3D tutorial/C++/Lesson5.Components/SampleOverlay.h [code]
Direct3D-Direct2D interop/C++/BasicCamera.cpp [code]
Direct3D-Direct2D interop/C++/BasicCamera.h [code]
Direct3D-Direct2D interop/C++/BasicLoader.cpp [code]
Direct3D-Direct2D interop/C++/BasicLoader.h [code]
Direct3D-Direct2D interop/C++/BasicMath.h [code]
Direct3D-Direct2D interop/C++/BasicReaderWriter.cpp [code]
Direct3D-Direct2D interop/C++/BasicReaderWriter.h [code]
Direct3D-Direct2D interop/C++/BasicShapes.cpp [code]
Direct3D-Direct2D interop/C++/BasicShapes.h [code]
Direct3D-Direct2D interop/C++/BasicTimer.cpp [code]
Direct3D-Direct2D interop/C++/BasicTimer.h [code]
Direct3D-Direct2D interop/C++/DDSTextureLoader.cpp [code]
Direct3D-Direct2D interop/C++/DDSTextureLoader.h [code]
Direct3D-Direct2D interop/C++/DirectXApp.cpp [code]
Direct3D-Direct2D interop/C++/DirectXApp.h [code]
Direct3D-Direct2D interop/C++/DirectXBase.cpp [code]
Direct3D-Direct2D interop/C++/DirectXBase.h [code]
Direct3D-Direct2D interop/C++/DirectXSample.h [code]
Direct3D-Direct2D interop/C++/pch.cpp [code]
Direct3D-Direct2D interop/C++/pch.h [code]
Direct3D-Direct2D interop/C++/SampleOverlay.cpp [code]
Direct3D-Direct2D interop/C++/SampleOverlay.h [code]
Direct3D-Direct2D interop/C++/TextInterop.cpp [code]
Direct3D-Direct2D interop/C++/TextInterop.h [code]
DirectWrite custom text renderer/C++/CustomTextRenderer.cpp [code]
DirectWrite custom text renderer/C++/CustomTextRenderer.h [code]
DirectWrite custom text renderer/C++/DirectXBase.cpp [code]
DirectWrite custom text renderer/C++/DirectXBase.h [code]
DirectWrite custom text renderer/C++/DirectXSample.h [code]
DirectWrite custom text renderer/C++/DWriteCustomTextRenderer.h [code]
DirectWrite custom text renderer/C++/pch.cpp [code]
DirectWrite custom text renderer/C++/pch.h [code]
DirectWrite custom text renderer/C++/SampleOverlay.cpp [code]
DirectWrite custom text renderer/C++/SampleOverlay.h [code]
DirectWrite font enumeration/C++,JavaScript/cpp/FontEnumerator.h [code]
DirectWrite font enumeration/C++,JavaScript/cpp/pch.cpp [code]
DirectWrite font enumeration/C++,JavaScript/cpp/pch.h [code]
DirectWrite hello world/C++/DirectXBase.cpp [code]
DirectWrite hello world/C++/DirectXBase.h [code]
DirectWrite hello world/C++/DirectXSample.h [code]
DirectWrite hello world/C++/DWriteHelloWorld.cpp [code]
DirectWrite hello world/C++/DWriteHelloWorld.h [code]
DirectWrite hello world/C++/pch.cpp [code]
DirectWrite hello world/C++/pch.h [code]
DirectWrite hello world/C++/SampleOverlay.cpp [code]
DirectWrite hello world/C++/SampleOverlay.h [code]
DirectWrite hit testing/C++/DirectXBase.cpp [code]
DirectWrite hit testing/C++/DirectXBase.h [code]
DirectWrite hit testing/C++/DirectXSample.h [code]
DirectWrite hit testing/C++/DWriteHitTesting.cpp [code]
DirectWrite hit testing/C++/DWriteHitTesting.h [code]
DirectWrite hit testing/C++/pch.cpp [code]
DirectWrite hit testing/C++/pch.h [code]
DirectWrite hit testing/C++/SampleOverlay.cpp [code]
DirectWrite hit testing/C++/SampleOverlay.h [code]
DirectWrite inline object/C++/DirectXBase.cpp [code]
DirectWrite inline object/C++/DirectXBase.h [code]
DirectWrite inline object/C++/DirectXSample.h [code]
DirectWrite inline object/C++/DWriteInlineObject.cpp [code]
DirectWrite inline object/C++/DWriteInlineObject.h [code]
DirectWrite inline object/C++/InlineImage.cpp [code]
DirectWrite inline object/C++/InlineImage.h [code]
DirectWrite inline object/C++/pch.cpp [code]
DirectWrite inline object/C++/pch.h [code]
DirectWrite inline object/C++/SampleOverlay.cpp [code]
DirectWrite inline object/C++/SampleOverlay.h [code]
DirectWrite paragraph text/C++/DirectXBase.cpp [code]
DirectWrite paragraph text/C++/DirectXBase.h [code]
DirectWrite paragraph text/C++/DirectXSample.h [code]
DirectWrite paragraph text/C++/DWriteParagraphText.cpp [code]
DirectWrite paragraph text/C++/DWriteParagraphText.h [code]
DirectWrite paragraph text/C++/pch.cpp [code]
DirectWrite paragraph text/C++/pch.h [code]
DirectWrite paragraph text/C++/SampleOverlay.cpp [code]
DirectWrite paragraph text/C++/SampleOverlay.h [code]
DirectWrite vertical text/C++/DirectXBase.cpp [code]
DirectWrite vertical text/C++/DirectXBase.h [code]
DirectWrite vertical text/C++/DirectXSample.h [code]
DirectWrite vertical text/C++/DWriteVerticalText.cpp [code]
DirectWrite vertical text/C++/DWriteVerticalText.h [code]
DirectWrite vertical text/C++/FlowLayout.cpp [code]
DirectWrite vertical text/C++/FlowLayout.h [code]
DirectWrite vertical text/C++/FlowSink.cpp [code]
DirectWrite vertical text/C++/FlowSink.h [code]
DirectWrite vertical text/C++/FlowSource.cpp [code]
DirectWrite vertical text/C++/FlowSource.h [code]
DirectWrite vertical text/C++/pch.cpp [code]
DirectWrite vertical text/C++/pch.h [code]
DirectWrite vertical text/C++/SampleOverlay.cpp [code]
DirectWrite vertical text/C++/SampleOverlay.h [code]
DirectWrite vertical text/C++/TextAnalysis.cpp [code]
DirectWrite vertical text/C++/TextAnalysis.h [code]
DirectX 3D shooting game/C++/Animate.cpp [code]
DirectX 3D shooting game/C++/Animate.h [code]
DirectX 3D shooting game/C++/Audio.cpp [code]
DirectX 3D shooting game/C++/Audio.h [code]
DirectX 3D shooting game/C++/BasicLoader.cpp [code]
DirectX 3D shooting game/C++/BasicLoader.h [code]
DirectX 3D shooting game/C++/BasicMath.h [code]
DirectX 3D shooting game/C++/BasicReaderWriter.cpp [code]
DirectX 3D shooting game/C++/BasicReaderWriter.h [code]
DirectX 3D shooting game/C++/BasicShapes.h [code]
DirectX 3D shooting game/C++/Camera.cpp [code]
DirectX 3D shooting game/C++/Camera.h [code]
DirectX 3D shooting game/C++/ConstantBuffers.h [code]
DirectX 3D shooting game/C++/Cylinder.cpp [code]
DirectX 3D shooting game/C++/Cylinder.h [code]
DirectX 3D shooting game/C++/CylinderMesh.cpp [code]
DirectX 3D shooting game/C++/CylinderMesh.h [code]
DirectX 3D shooting game/C++/DDSTextureLoader.cpp [code]
DirectX 3D shooting game/C++/DDSTextureLoader.h [code]
DirectX 3D shooting game/C++/DirectXApp.cpp [code]
DirectX 3D shooting game/C++/DirectXApp.h [code]
DirectX 3D shooting game/C++/DirectXBase.cpp [code]
DirectX 3D shooting game/C++/DirectXBase.h [code]
DirectX 3D shooting game/C++/DirectXSample.h [code]
DirectX 3D shooting game/C++/Face.cpp [code]
DirectX 3D shooting game/C++/Face.h [code]
DirectX 3D shooting game/C++/FaceMesh.cpp [code]
DirectX 3D shooting game/C++/FaceMesh.h [code]
DirectX 3D shooting game/C++/GameConstants.h [code]
DirectX 3D shooting game/C++/GameHud.cpp [code]
DirectX 3D shooting game/C++/GameHud.h [code]
DirectX 3D shooting game/C++/GameInfoOverlay.cpp [code]
DirectX 3D shooting game/C++/GameInfoOverlay.h [code]
DirectX 3D shooting game/C++/GameObject.cpp [code]
DirectX 3D shooting game/C++/GameObject.h [code]
DirectX 3D shooting game/C++/GameRenderer.cpp [code]
DirectX 3D shooting game/C++/GameRenderer.h [code]
DirectX 3D shooting game/C++/GameTimer.cpp [code]
DirectX 3D shooting game/C++/GameTimer.h [code]
DirectX 3D shooting game/C++/Level.cpp [code]
DirectX 3D shooting game/C++/Level.h [code]
DirectX 3D shooting game/C++/Level1.cpp [code]
DirectX 3D shooting game/C++/Level1.h [code]
DirectX 3D shooting game/C++/Level2.cpp [code]
DirectX 3D shooting game/C++/Level2.h [code]
DirectX 3D shooting game/C++/Level3.cpp [code]
DirectX 3D shooting game/C++/Level3.h [code]
DirectX 3D shooting game/C++/Level4.cpp [code]
DirectX 3D shooting game/C++/Level4.h [code]
DirectX 3D shooting game/C++/Level5.cpp [code]
DirectX 3D shooting game/C++/Level5.h [code]
DirectX 3D shooting game/C++/Level6.cpp [code]
DirectX 3D shooting game/C++/Level6.h [code]
DirectX 3D shooting game/C++/Material.cpp [code]
DirectX 3D shooting game/C++/Material.h [code]
DirectX 3D shooting game/C++/MediaReader.cpp [code]
DirectX 3D shooting game/C++/MediaReader.h [code]
DirectX 3D shooting game/C++/MeshObject.cpp [code]
DirectX 3D shooting game/C++/MeshObject.h [code]
DirectX 3D shooting game/C++/MoveLookController.cpp [code]
DirectX 3D shooting game/C++/MoveLookController.h [code]
DirectX 3D shooting game/C++/pch.cpp [code]
DirectX 3D shooting game/C++/pch.h [code]
DirectX 3D shooting game/C++/PersistentState.cpp [code]
DirectX 3D shooting game/C++/PersistentState.h [code]
DirectX 3D shooting game/C++/Simple3DGame.cpp [code]
DirectX 3D shooting game/C++/Simple3DGame.h [code]
DirectX 3D shooting game/C++/SoundEffect.cpp [code]
DirectX 3D shooting game/C++/SoundEffect.h [code]
DirectX 3D shooting game/C++/Sphere.cpp [code]
DirectX 3D shooting game/C++/Sphere.h [code]
DirectX 3D shooting game/C++/SphereMesh.cpp [code]
DirectX 3D shooting game/C++/SphereMesh.h [code]
DirectX 3D shooting game/C++/StereoProjection.cpp [code]
DirectX 3D shooting game/C++/StereoProjection.h [code]
DirectX 3D shooting game/C++/TargetTexture.cpp [code]
DirectX 3D shooting game/C++/TargetTexture.h [code]
DirectX 3D shooting game/C++/WorldMesh.cpp [code]
DirectX 3D shooting game/C++/WorldMesh.h [code]
DirectX marble maze game/C++/Audio.cpp [code]
DirectX marble maze game/C++/Audio.h [code]
DirectX marble maze game/C++/BasicLoader.cpp [code]
DirectX marble maze game/C++/BasicLoader.h [code]
DirectX marble maze game/C++/BasicMath.h [code]
DirectX marble maze game/C++/BasicReaderWriter.cpp [code]
DirectX marble maze game/C++/BasicReaderWriter.h [code]
DirectX marble maze game/C++/BasicShapes.cpp [code]
DirectX marble maze game/C++/BasicShapes.h [code]
DirectX marble maze game/C++/BasicTimer.cpp [code]
DirectX marble maze game/C++/BasicTimer.h [code]
DirectX marble maze game/C++/Camera.cpp [code]
DirectX marble maze game/C++/Camera.h [code]
DirectX marble maze game/C++/Collision.cpp [code]
DirectX marble maze game/C++/Collision.h [code]
DirectX marble maze game/C++/DDSTextureLoader.cpp [code]
DirectX marble maze game/C++/DDSTextureLoader.h [code]
DirectX marble maze game/C++/DirectXApp.cpp [code]
DirectX marble maze game/C++/DirectXApp.h [code]
DirectX marble maze game/C++/DirectXBase.cpp [code]
DirectX marble maze game/C++/DirectXBase.h [code]
DirectX marble maze game/C++/DirectXSample.h [code]
DirectX marble maze game/C++/LoadScreen.cpp [code]
DirectX marble maze game/C++/LoadScreen.h [code]
DirectX marble maze game/C++/MarbleMaze.cpp [code]
DirectX marble maze game/C++/MarbleMaze.h [code]
DirectX marble maze game/C++/MediaStreamer.cpp [code]
DirectX marble maze game/C++/MediaStreamer.h [code]
DirectX marble maze game/C++/pch.cpp [code]
DirectX marble maze game/C++/pch.h [code]
DirectX marble maze game/C++/PersistentState.cpp [code]
DirectX marble maze game/C++/PersistentState.h [code]
DirectX marble maze game/C++/Physics.cpp [code]
DirectX marble maze game/C++/Physics.h [code]
DirectX marble maze game/C++/Primitives.h [code]
DirectX marble maze game/C++/SampleOverlay.cpp [code]
DirectX marble maze game/C++/SampleOverlay.h [code]
DirectX marble maze game/C++/SDKMesh.cpp [code]
DirectX marble maze game/C++/SDKMesh.h [code]
DirectX marble maze game/C++/UserInterface.cpp [code]
DirectX marble maze game/C++/UserInterface.h [code]
DirectX postcard app/C++/App.xaml.cpp [code]
DirectX postcard app/C++/App.xaml.h [code]
DirectX postcard app/C++/BasicCamera.cpp [code]
DirectX postcard app/C++/BasicCamera.h [code]
DirectX postcard app/C++/BasicLoader.cpp [code]
DirectX postcard app/C++/BasicLoader.h [code]
DirectX postcard app/C++/BasicMath.h [code]
DirectX postcard app/C++/BasicReaderWriter.cpp [code]
DirectX postcard app/C++/BasicReaderWriter.h [code]
DirectX postcard app/C++/BasicShapes.cpp [code]
DirectX postcard app/C++/BasicShapes.h [code]
DirectX postcard app/C++/DDSTextureLoader.cpp [code]
DirectX postcard app/C++/DDSTextureLoader.h [code]
DirectX postcard app/C++/DirectXBase.cpp [code]
DirectX postcard app/C++/DirectXBase.h [code]
DirectX postcard app/C++/DirectXSample.h [code]
DirectX postcard app/C++/EffectsFlyout.xaml.cpp [code]
DirectX postcard app/C++/EffectsFlyout.xaml.h [code]
DirectX postcard app/C++/ExtrudedTextRenderer.cpp [code]
DirectX postcard app/C++/ExtrudedTextRenderer.h [code]
DirectX postcard app/C++/Extruder.cpp [code]
DirectX postcard app/C++/Extruder.h [code]
DirectX postcard app/C++/ImageRenderer.cpp [code]
DirectX postcard app/C++/ImageRenderer.h [code]
DirectX postcard app/C++/InkRenderer.cpp [code]
DirectX postcard app/C++/InkRenderer.h [code]
DirectX postcard app/C++/MainPage.xaml.cpp [code]
DirectX postcard app/C++/MainPage.xaml.h [code]
DirectX postcard app/C++/OutlineRenderer.cpp [code]
DirectX postcard app/C++/OutlineRenderer.h [code]
DirectX postcard app/C++/PaperFlyout.xaml.cpp [code]
DirectX postcard app/C++/PaperFlyout.xaml.h [code]
DirectX postcard app/C++/PaperFragment.cpp [code]
DirectX postcard app/C++/PaperFragment.h [code]
DirectX postcard app/C++/PaperRenderer.cpp [code]
DirectX postcard app/C++/PaperRenderer.h [code]
DirectX postcard app/C++/pch.cpp [code]
DirectX postcard app/C++/pch.h [code]
DirectX postcard app/C++/PointSnapper.cpp [code]
DirectX postcard app/C++/PointSnapper.h [code]
DirectX postcard app/C++/PostcardRenderer.cpp [code]
DirectX postcard app/C++/PostcardRenderer.h [code]
DirectX postcard app/C++/SignatureFlyout.xaml.cpp [code]
DirectX postcard app/C++/SignatureFlyout.xaml.h [code]
DirectX postcard app/C++/TextFlyout.xaml.cpp [code]
DirectX postcard app/C++/TextFlyout.xaml.h [code]
DirectX swap chain implementation/C++/CoreWindowEvents.cpp [code]
DirectX swap chain implementation/C++/CoreWindowEvents.h [code]
DirectX swap chain implementation/C++/DirectXBase.cpp [code]
DirectX swap chain implementation/C++/DirectXBase.h [code]
DirectX swap chain implementation/C++/DirectXSample.h [code]
DirectX swap chain implementation/C++/pch.cpp [code]
DirectX swap chain implementation/C++/pch.h [code]
DirectX swap chain implementation/C++/SampleOverlay.cpp [code]
DirectX swap chain implementation/C++/SampleOverlay.h [code]
DirectX touch input/C++/BasicCamera.cpp [code]
DirectX touch input/C++/BasicCamera.h [code]
DirectX touch input/C++/BasicLoader.cpp [code]
DirectX touch input/C++/BasicLoader.h [code]
DirectX touch input/C++/BasicMath.h [code]
DirectX touch input/C++/BasicReaderWriter.cpp [code]
DirectX touch input/C++/BasicReaderWriter.h [code]
DirectX touch input/C++/BasicShapes.cpp [code]
DirectX touch input/C++/BasicShapes.h [code]
DirectX touch input/C++/BasicTimer.cpp [code]
DirectX touch input/C++/BasicTimer.h [code]
DirectX touch input/C++/DDSTextureLoader.cpp [code]
DirectX touch input/C++/DDSTextureLoader.h [code]
DirectX touch input/C++/DirectXApp.cpp [code]
DirectX touch input/C++/DirectXApp.h [code]
DirectX touch input/C++/DirectXBase.cpp [code]
DirectX touch input/C++/DirectXBase.h [code]
DirectX touch input/C++/DirectXSample.h [code]
DirectX touch input/C++/MoveLookController.cpp [code]
DirectX touch input/C++/MoveLookController.h [code]
DirectX touch input/C++/pch.cpp [code]
DirectX touch input/C++/pch.h [code]
DirectX touch input/C++/SampleOverlay.cpp [code]
DirectX touch input/C++/SampleOverlay.h [code]
DirectX touch input/C++/Simple3DTouch.cpp [code]
DirectX touch input/C++/Simple3DTouch.h [code]
Display orientation/C++/App.xaml.cpp [code]
Display orientation/C++/App.xaml.h [code]
Display orientation/C++/Constants.cpp [code]
Display orientation/C++/Constants.h [code]
Display orientation/C++/MainPage.xaml.cpp [code]
Display orientation/C++/MainPage.xaml.h [code]
Display orientation/C++/pch.cpp [code]
Display orientation/C++/pch.h [code]
Display orientation/C++/Scenario1.xaml.cpp [code]
Display orientation/C++/Scenario1.xaml.h [code]
Display orientation/C++/Scenario2.xaml.cpp [code]
Display orientation/C++/Scenario2.xaml.h [code]
Display orientation/C++/Scenario3.xaml.cpp [code]
Display orientation/C++/Scenario3.xaml.h [code]
Display orientation/C++/common/LayoutAwarePage.cpp [code]
Display orientation/C++/common/LayoutAwarePage.h [code]
Display orientation/C++/common/suspensionmanager.cpp [code]
Display orientation/C++/common/suspensionmanager.h [code]
DXGI offer and reclaim resources/C++/BasicCamera.cpp [code]
DXGI offer and reclaim resources/C++/BasicCamera.h [code]
DXGI offer and reclaim resources/C++/BasicLoader.cpp [code]
DXGI offer and reclaim resources/C++/BasicLoader.h [code]
DXGI offer and reclaim resources/C++/BasicMath.h [code]
DXGI offer and reclaim resources/C++/BasicReaderWriter.cpp [code]
DXGI offer and reclaim resources/C++/BasicReaderWriter.h [code]
DXGI offer and reclaim resources/C++/BasicShapes.cpp [code]
DXGI offer and reclaim resources/C++/BasicShapes.h [code]
DXGI offer and reclaim resources/C++/BasicTimer.cpp [code]
DXGI offer and reclaim resources/C++/BasicTimer.h [code]
DXGI offer and reclaim resources/C++/DDSTextureLoader.cpp [code]
DXGI offer and reclaim resources/C++/DDSTextureLoader.h [code]
DXGI offer and reclaim resources/C++/DirectXApp.cpp [code]
DXGI offer and reclaim resources/C++/DirectXApp.h [code]
DXGI offer and reclaim resources/C++/DirectXBase.cpp [code]
DXGI offer and reclaim resources/C++/DirectXBase.h [code]
DXGI offer and reclaim resources/C++/DirectXSample.h [code]
DXGI offer and reclaim resources/C++/OfferReclaimAPI.cpp [code]
DXGI offer and reclaim resources/C++/OfferReclaimAPI.h [code]
DXGI offer and reclaim resources/C++/pch.cpp [code]
DXGI offer and reclaim resources/C++/pch.h [code]
DXGI offer and reclaim resources/C++/SampleOverlay.cpp [code]
DXGI offer and reclaim resources/C++/SampleOverlay.h [code]
DXGI swap chain rotation/C++/BasicCamera.cpp [code]
DXGI swap chain rotation/C++/BasicCamera.h [code]
DXGI swap chain rotation/C++/BasicLoader.cpp [code]
DXGI swap chain rotation/C++/BasicLoader.h [code]
DXGI swap chain rotation/C++/BasicMath.h [code]
DXGI swap chain rotation/C++/BasicReaderWriter.cpp [code]
DXGI swap chain rotation/C++/BasicReaderWriter.h [code]
DXGI swap chain rotation/C++/BasicShapes.cpp [code]
DXGI swap chain rotation/C++/BasicShapes.h [code]
DXGI swap chain rotation/C++/BasicTimer.cpp [code]
DXGI swap chain rotation/C++/BasicTimer.h [code]
DXGI swap chain rotation/C++/DDSTextureLoader.cpp [code]
DXGI swap chain rotation/C++/DDSTextureLoader.h [code]
DXGI swap chain rotation/C++/DirectXApp.cpp [code]
DXGI swap chain rotation/C++/DirectXApp.h [code]
DXGI swap chain rotation/C++/DirectXBase.cpp [code]
DXGI swap chain rotation/C++/DirectXBase.h [code]
DXGI swap chain rotation/C++/DirectXSample.h [code]
DXGI swap chain rotation/C++/DxgiRotation.cpp [code]
DXGI swap chain rotation/C++/DxgiRotation.h [code]
DXGI swap chain rotation/C++/pch.cpp [code]
DXGI swap chain rotation/C++/pch.h [code]
DXGI swap chain rotation/C++/SampleOverlay.cpp [code]
DXGI swap chain rotation/C++/SampleOverlay.h [code]
EAS policies for mail clients/C++/App.xaml.cpp [code]
EAS policies for mail clients/C++/App.xaml.h [code]
EAS policies for mail clients/C++/Constants.cpp [code]
EAS policies for mail clients/C++/Constants.h [code]
EAS policies for mail clients/C++/MainPage.xaml.cpp [code]
EAS policies for mail clients/C++/MainPage.xaml.h [code]
EAS policies for mail clients/C++/pch.cpp [code]
EAS policies for mail clients/C++/pch.h [code]
EAS policies for mail clients/C++/Scenario1.xaml.cpp [code]
EAS policies for mail clients/C++/Scenario1.xaml.h [code]
EAS policies for mail clients/C++/Scenario2.xaml.cpp [code]
EAS policies for mail clients/C++/Scenario2.xaml.h [code]
EAS policies for mail clients/C++/Scenario3.xaml.cpp [code]
EAS policies for mail clients/C++/Scenario3.xaml.h [code]
EAS policies for mail clients/C++/common/LayoutAwarePage.cpp [code]
EAS policies for mail clients/C++/common/LayoutAwarePage.h [code]
EAS policies for mail clients/C++/common/suspensionmanager.cpp [code]
EAS policies for mail clients/C++/common/suspensionmanager.h [code]
Edge gesture invocation/C++/App.xaml.cpp [code]
Edge gesture invocation/C++/App.xaml.h [code]
Edge gesture invocation/C++/CppSamplesUtils.h [code]
Edge gesture invocation/C++/MainPage.xaml.cpp [code]
Edge gesture invocation/C++/MainPage.xaml.h [code]
Edge gesture invocation/C++/pch.cpp [code]
Edge gesture invocation/C++/pch.h [code]
Edge gesture invocation/C++/ScenarioInput1.xaml.cpp [code]
Edge gesture invocation/C++/ScenarioInput1.xaml.h [code]
Edge gesture invocation/C++/ScenarioInput2.xaml.cpp [code]
Edge gesture invocation/C++/ScenarioInput2.xaml.h [code]
Edge gesture invocation/C++/ScenarioList.xaml.cpp [code]
Edge gesture invocation/C++/ScenarioList.xaml.h [code]
Edge gesture invocation/C++/ScenarioOutput1.xaml.cpp [code]
Edge gesture invocation/C++/ScenarioOutput1.xaml.h [code]
Edge gesture invocation/C++/ScenarioOutput2.xaml.cpp [code]
Edge gesture invocation/C++/ScenarioOutput2.xaml.h [code]
Extended Linguistic Services (ELS)/C++/App.xaml.cpp [code]
Extended Linguistic Services (ELS)/C++/App.xaml.h [code]
Extended Linguistic Services (ELS)/C++/Constants.cpp [code]
Extended Linguistic Services (ELS)/C++/Constants.h [code]
Extended Linguistic Services (ELS)/C++/elsutil.h [code]
Extended Linguistic Services (ELS)/C++/LanguageDetection.xaml.h [code]
Extended Linguistic Services (ELS)/C++/MainPage.xaml.cpp [code]
Extended Linguistic Services (ELS)/C++/MainPage.xaml.h [code]
Extended Linguistic Services (ELS)/C++/pch.cpp [code]
Extended Linguistic Services (ELS)/C++/pch.h [code]
Extended Linguistic Services (ELS)/C++/ScriptDetection.xaml.cpp [code]
Extended Linguistic Services (ELS)/C++/ScriptDetection.xaml.h [code]
Extended Linguistic Services (ELS)/C++/Transliteration.xaml.cpp [code]
Extended Linguistic Services (ELS)/C++/Transliteration.xaml.h [code]
Extended Linguistic Services (ELS)/C++/common/LayoutAwarePage.h [code]
File access/C++/App.xaml.cpp [code]
File access/C++/App.xaml.h [code]
File access/C++/Constants.cpp [code]
File access/C++/Constants.h [code]
File access/C++/MainPage.xaml.cpp [code]
File access/C++/MainPage.xaml.h [code]
File access/C++/pch.cpp [code]
File access/C++/pch.h [code]
File access/C++/Scenario1.xaml.cpp [code]
File access/C++/Scenario1.xaml.h [code]
File access/C++/Scenario2.xaml.cpp [code]
File access/C++/Scenario2.xaml.h [code]
File access/C++/Scenario3.xaml.cpp [code]
File access/C++/Scenario3.xaml.h [code]
File access/C++/Scenario4.xaml.cpp [code]
File access/C++/Scenario4.xaml.h [code]
File access/C++/Scenario5.xaml.cpp [code]
File access/C++/Scenario5.xaml.h [code]
File access/C++/Scenario6.xaml.cpp [code]
File access/C++/Scenario6.xaml.h [code]
File access/C++/Scenario7.xaml.cpp [code]
File access/C++/Scenario7.xaml.h [code]
File access/C++/Scenario8.xaml.cpp [code]
File access/C++/Scenario8.xaml.h [code]
File access/C++/common/LayoutAwarePage.cpp [code]
File access/C++/common/LayoutAwarePage.h [code]
File access/C++/common/suspensionmanager.cpp [code]
File access/C++/common/suspensionmanager.h [code]
File and folder thumbnail/C++/App.xaml.cpp [code]
File and folder thumbnail/C++/App.xaml.h [code]
File and folder thumbnail/C++/Constants.cpp [code]
File and folder thumbnail/C++/Constants.h [code]
File and folder thumbnail/C++/MainPage.xaml.cpp [code]
File and folder thumbnail/C++/MainPage.xaml.h [code]
File and folder thumbnail/C++/pch.cpp [code]
File and folder thumbnail/C++/pch.h [code]
File and folder thumbnail/C++/Scenario1.xaml.cpp [code]
File and folder thumbnail/C++/Scenario1.xaml.h [code]
File and folder thumbnail/C++/Scenario2.xaml.cpp [code]
File and folder thumbnail/C++/Scenario2.xaml.h [code]
File and folder thumbnail/C++/Scenario3.xaml.cpp [code]
File and folder thumbnail/C++/Scenario3.xaml.h [code]
File and folder thumbnail/C++/Scenario4.xaml.cpp [code]
File and folder thumbnail/C++/Scenario4.xaml.h [code]
File and folder thumbnail/C++/Scenario5.xaml.cpp [code]
File and folder thumbnail/C++/Scenario5.xaml.h [code]
File and folder thumbnail/C++/common/LayoutAwarePage.cpp [code]
File and folder thumbnail/C++/common/LayoutAwarePage.h [code]
File and folder thumbnail/C++/common/suspensionmanager.cpp [code]
File and folder thumbnail/C++/common/suspensionmanager.h [code]
File picker contracts/C++/App.xaml.cpp [code]
File picker contracts/C++/App.xaml.h [code]
File picker contracts/C++/CachedFileUpdater_Local.xaml.cpp [code]
File picker contracts/C++/CachedFileUpdater_Local.xaml.h [code]
File picker contracts/C++/CachedFileUpdater_Remote.xaml.cpp [code]
File picker contracts/C++/CachedFileUpdater_Remote.xaml.h [code]
File picker contracts/C++/CachedFileUpdaterPage.xaml.cpp [code]
File picker contracts/C++/CachedFileUpdaterPage.xaml.h [code]
File picker contracts/C++/Constants.cpp [code]
File picker contracts/C++/Constants.h [code]
File picker contracts/C++/FileOpenPicker_PickAppFile.xaml.cpp [code]
File picker contracts/C++/FileOpenPicker_PickAppFile.xaml.h [code]
File picker contracts/C++/FileOpenPicker_PickCachedFile.xaml.cpp [code]
File picker contracts/C++/FileOpenPicker_PickCachedFile.xaml.h [code]
File picker contracts/C++/FileOpenPicker_PickURLFile.xaml.cpp [code]
File picker contracts/C++/FileOpenPicker_PickURLFile.xaml.h [code]
File picker contracts/C++/FileOpenPickerPage.xaml.cpp [code]
File picker contracts/C++/FileOpenPickerPage.xaml.h [code]
File picker contracts/C++/FileSavePicker_FailToSave.xaml.cpp [code]
File picker contracts/C++/FileSavePicker_FailToSave.xaml.h [code]
File picker contracts/C++/FileSavePicker_SaveToAppStorage.xaml.h [code]
File picker contracts/C++/FileSavePicker_SaveToCachedFile.xaml.h [code]
File picker contracts/C++/FileSavePickerPage.xaml.cpp [code]
File picker contracts/C++/FileSavePickerPage.xaml.h [code]
File picker contracts/C++/MainPage.xaml.cpp [code]
File picker contracts/C++/MainPage.xaml.h [code]
File picker contracts/C++/MainPage_CachedFile.xaml.cpp [code]
File picker contracts/C++/MainPage_CachedFile.xaml.h [code]
File picker contracts/C++/MainPage_PickFile.xaml.cpp [code]
File picker contracts/C++/MainPage_PickFile.xaml.h [code]
File picker contracts/C++/MainPage_SaveFile.xaml.cpp [code]
File picker contracts/C++/MainPage_SaveFile.xaml.h [code]
File picker contracts/C++/pch.cpp [code]
File picker contracts/C++/pch.h [code]
File picker contracts/C++/common/LayoutAwarePage.cpp [code]
File picker contracts/C++/common/LayoutAwarePage.h [code]
File picker contracts/C++/common/suspensionmanager.cpp [code]
File picker contracts/C++/common/suspensionmanager.h [code]
File picker/C++/App.xaml.cpp [code]
File picker/C++/App.xaml.h [code]
File picker/C++/Constants.cpp [code]
File picker/C++/Constants.h [code]
File picker/C++/MainPage.xaml.cpp [code]
File picker/C++/MainPage.xaml.h [code]
File picker/C++/pch.cpp [code]
File picker/C++/pch.h [code]
File picker/C++/Scenario1.xaml.cpp [code]
File picker/C++/Scenario1.xaml.h [code]
File picker/C++/Scenario2.xaml.cpp [code]
File picker/C++/Scenario2.xaml.h [code]
File picker/C++/Scenario3.xaml.cpp [code]
File picker/C++/Scenario3.xaml.h [code]
File picker/C++/Scenario4.xaml.cpp [code]
File picker/C++/Scenario4.xaml.h [code]
File picker/C++/Scenario5.xaml.cpp [code]
File picker/C++/Scenario5.xaml.h [code]
File picker/C++/Scenario6.xaml.cpp [code]
File picker/C++/Scenario6.xaml.h [code]
File picker/C++/common/LayoutAwarePage.cpp [code]
File picker/C++/common/LayoutAwarePage.h [code]
File picker/C++/common/suspensionmanager.cpp [code]
File picker/C++/common/suspensionmanager.h [code]
Folder enumeration/C++/App.xaml.cpp [code]
Folder enumeration/C++/App.xaml.h [code]
Folder enumeration/C++/Constants.cpp [code]
Folder enumeration/C++/Constants.h [code]
Folder enumeration/C++/MainPage.xaml.cpp [code]
Folder enumeration/C++/MainPage.xaml.h [code]
Folder enumeration/C++/pch.cpp [code]
Folder enumeration/C++/pch.h [code]
Folder enumeration/C++/Scenario1.xaml.cpp [code]
Folder enumeration/C++/Scenario1.xaml.h [code]
Folder enumeration/C++/Scenario2.xaml.cpp [code]
Folder enumeration/C++/Scenario2.xaml.h [code]
Folder enumeration/C++/Scenario3.xaml.cpp [code]
Folder enumeration/C++/Scenario3.xaml.h [code]
Folder enumeration/C++/common/LayoutAwarePage.cpp [code]
Folder enumeration/C++/common/LayoutAwarePage.h [code]
Folder enumeration/C++/common/suspensionmanager.cpp [code]
Folder enumeration/C++/common/suspensionmanager.h [code]
Geolocation/C++/App.xaml.cpp [code]
Geolocation/C++/App.xaml.h [code]
Geolocation/C++/Constants.cpp [code]
Geolocation/C++/Constants.h [code]
Geolocation/C++/MainPage.xaml.cpp [code]
Geolocation/C++/MainPage.xaml.h [code]
Geolocation/C++/pch.cpp [code]
Geolocation/C++/pch.h [code]
Geolocation/C++/Scenario1_TrackPosition.xaml.cpp [code]
Geolocation/C++/Scenario1_TrackPosition.xaml.h [code]
Geolocation/C++/Scenario2_GetPosition.xaml.cpp [code]
Geolocation/C++/Scenario2_GetPosition.xaml.h [code]
Geolocation/C++/Scenario3_BackgroundTask.xaml.cpp [code]
Geolocation/C++/Scenario3_BackgroundTask.xaml.h [code]
Geolocation/C++/backgroundtask/LocationBackgroundTask.cpp [code]
Geolocation/C++/backgroundtask/LocationBackgroundTask.h [code]
Geolocation/C++/backgroundtask/pch.cpp [code]
Geolocation/C++/backgroundtask/pch.h [code]
Geolocation/C++/common/LayoutAwarePage.cpp [code]
Geolocation/C++/common/LayoutAwarePage.h [code]
Geolocation/C++/common/SuspensionManager.cpp [code]
Geolocation/C++/common/SuspensionManager.h [code]
Getting started with C++ simple blog reader/C++/App.xaml.cpp [code]
Getting started with C++ simple blog reader/C++/App.xaml.h [code]
Getting started with C++ simple blog reader/C++/DateConverter.h [code]
Getting started with C++ simple blog reader/C++/FeedData.cpp [code]
Getting started with C++ simple blog reader/C++/FeedData.h [code]
Getting started with C++ simple blog reader/C++/ItemsPage.xaml.h [code]
Getting started with C++ simple blog reader/C++/MainPage.xaml.h [code]
Getting started with C++ simple blog reader/C++/pch.cpp [code]
Getting started with C++ simple blog reader/C++/pch.h [code]
Getting started with C++ simple blog reader/C++/SplitPage.xaml.h [code]
Globalization preferences/C++/App.xaml.cpp [code]
Globalization preferences/C++/App.xaml.h [code]
Globalization preferences/C++/Constants.cpp [code]
Globalization preferences/C++/Constants.h [code]
Globalization preferences/C++/CurrentInputLanguage.xaml.cpp [code]
Globalization preferences/C++/CurrentInputLanguage.xaml.h [code]
Globalization preferences/C++/GeographicRegion.xaml.cpp [code]
Globalization preferences/C++/GeographicRegion.xaml.h [code]
Globalization preferences/C++/Language.xaml.cpp [code]
Globalization preferences/C++/Language.xaml.h [code]
Globalization preferences/C++/MainPage.xaml.cpp [code]
Globalization preferences/C++/MainPage.xaml.h [code]
Globalization preferences/C++/pch.cpp [code]
Globalization preferences/C++/pch.h [code]
Globalization preferences/C++/UserPreferences.xaml.cpp [code]
Globalization preferences/C++/UserPreferences.xaml.h [code]
Globalization preferences/C++/Utilities.cpp [code]
Globalization preferences/C++/Utilities.h [code]
Globalization preferences/C++/common/LayoutAwarePage.cpp [code]
Globalization preferences/C++/common/LayoutAwarePage.h [code]
Globalization preferences/C++/common/suspensionmanager.cpp [code]
Globalization preferences/C++/common/suspensionmanager.h [code]
Gyrometer sensor/C++/App.xaml.cpp [code]
Gyrometer sensor/C++/App.xaml.h [code]
Gyrometer sensor/C++/Constants.cpp [code]
Gyrometer sensor/C++/Constants.h [code]
Gyrometer sensor/C++/MainPage.xaml.cpp [code]
Gyrometer sensor/C++/MainPage.xaml.h [code]
Gyrometer sensor/C++/pch.cpp [code]
Gyrometer sensor/C++/pch.h [code]
Gyrometer sensor/C++/Scenario1.xaml.cpp [code]
Gyrometer sensor/C++/Scenario1.xaml.h [code]
Gyrometer sensor/C++/Scenario2.xaml.cpp [code]
Gyrometer sensor/C++/Scenario2.xaml.h [code]
Gyrometer sensor/C++/common/LayoutAwarePage.cpp [code]
Gyrometer sensor/C++/common/LayoutAwarePage.h [code]
Gyrometer sensor/C++/common/suspensionmanager.cpp [code]
Gyrometer sensor/C++/common/suspensionmanager.h [code]
Hilo C++/C++/CartoonEffect/AmpCartoon.cpp [code]
Hilo C++/C++/CartoonEffect/AmpCartoon.h [code]
Hilo C++/C++/CartoonEffect/AmpPixel.h [code]
Hilo C++/C++/CartoonEffect/FrameData.h [code]
Hilo C++/C++/CartoonEffect/FrameProcessing.cpp [code]
Hilo C++/C++/CartoonEffect/FrameProcessing.h [code]
Hilo C++/C++/CartoonEffect/pch.cpp [code]
Hilo C++/C++/CartoonEffect/pch.h [code]
Hilo C++/C++/CartoonEffect/PPLCartoon.cpp [code]
Hilo C++/C++/CartoonEffect/PPLCartoon.h [code]
Hilo C++/C++/CartoonEffect/targetver.h [code]
Hilo C++/C++/CartoonEffect/Utils.h [code]
Hilo C++/C++/Hilo/App.xaml.cpp [code]
Hilo C++/C++/Hilo/App.xaml.h [code]
Hilo C++/C++/Hilo/BooleanToBrushConverter.cpp [code]
Hilo C++/C++/Hilo/BooleanToBrushConverter.h [code]
Hilo C++/C++/Hilo/CalendarExtensions.cpp [code]
Hilo C++/C++/Hilo/CalendarExtensions.h [code]
Hilo C++/C++/Hilo/CartoonizeImageView.xaml.cpp [code]
Hilo C++/C++/Hilo/CartoonizeImageView.xaml.h [code]
Hilo C++/C++/Hilo/CartoonizeImageViewModel.cpp [code]
Hilo C++/C++/Hilo/CartoonizeImageViewModel.h [code]
Hilo C++/C++/Hilo/CropImageView.xaml.cpp [code]
Hilo C++/C++/Hilo/CropImageView.xaml.h [code]
Hilo C++/C++/Hilo/CropImageViewModel.cpp [code]
Hilo C++/C++/Hilo/CropImageViewModel.h [code]
Hilo C++/C++/Hilo/DebugLoggingExceptionPolicy.cpp [code]
Hilo C++/C++/Hilo/DebugLoggingExceptionPolicy.h [code]
Hilo C++/C++/Hilo/DelegateCommand.cpp [code]
Hilo C++/C++/Hilo/DelegateCommand.h [code]
Hilo C++/C++/Hilo/DesignTimeData.cpp [code]
Hilo C++/C++/Hilo/DesignTimeData.h [code]
Hilo C++/C++/Hilo/ExceptionPolicy.h [code]
Hilo C++/C++/Hilo/ExceptionPolicyFactory.cpp [code]
Hilo C++/C++/Hilo/ExceptionPolicyFactory.h [code]
Hilo C++/C++/Hilo/ExifExtensions.cpp [code]
Hilo C++/C++/Hilo/ExifExtensions.h [code]
Hilo C++/C++/Hilo/FileSizeConverter.cpp [code]
Hilo C++/C++/Hilo/FileSizeConverter.h [code]
Hilo C++/C++/Hilo/FileSystemRepository.cpp [code]
Hilo C++/C++/Hilo/FileSystemRepository.h [code]
Hilo C++/C++/Hilo/HiloCommonDefinitions.h [code]
Hilo C++/C++/Hilo/HiloPage.cpp [code]
Hilo C++/C++/Hilo/HiloPage.h [code]
Hilo C++/C++/Hilo/HubGroupType.h [code]
Hilo C++/C++/Hilo/HubPhotoGroup.cpp [code]
Hilo C++/C++/Hilo/HubPhotoGroup.h [code]
Hilo C++/C++/Hilo/ImageBase.cpp [code]
Hilo C++/C++/Hilo/ImageBase.h [code]
Hilo C++/C++/Hilo/ImageBrowserView.xaml.cpp [code]
Hilo C++/C++/Hilo/ImageBrowserView.xaml.h [code]
Hilo C++/C++/Hilo/ImageBrowserViewModel.cpp [code]
Hilo C++/C++/Hilo/ImageBrowserViewModel.h [code]
Hilo C++/C++/Hilo/ImageNavigationData.cpp [code]
Hilo C++/C++/Hilo/ImageNavigationData.h [code]
Hilo C++/C++/Hilo/ImageUtilities.cpp [code]
Hilo C++/C++/Hilo/ImageUtilities.h [code]
Hilo C++/C++/Hilo/ImageView.xaml.cpp [code]
Hilo C++/C++/Hilo/ImageView.xaml.h [code]
Hilo C++/C++/Hilo/ImageViewModel.cpp [code]
Hilo C++/C++/Hilo/ImageViewModel.h [code]
Hilo C++/C++/Hilo/IMonthBlock.h [code]
Hilo C++/C++/Hilo/IPhoto.h [code]
Hilo C++/C++/Hilo/IPhotoGroup.h [code]
Hilo C++/C++/Hilo/IResizable.h [code]
Hilo C++/C++/Hilo/IResourceLoader.h [code]
Hilo C++/C++/Hilo/IYearGroup.h [code]
Hilo C++/C++/Hilo/LocalResourceLoader.cpp [code]
Hilo C++/C++/Hilo/LocalResourceLoader.h [code]
Hilo C++/C++/Hilo/MainHubView.xaml.cpp [code]
Hilo C++/C++/Hilo/MainHubView.xaml.h [code]
Hilo C++/C++/Hilo/MainHubViewModel.cpp [code]
Hilo C++/C++/Hilo/MainHubViewModel.h [code]
Hilo C++/C++/Hilo/MonthBlock.cpp [code]
Hilo C++/C++/Hilo/MonthBlock.h [code]
Hilo C++/C++/Hilo/MonthGroup.cpp [code]
Hilo C++/C++/Hilo/MonthGroup.h [code]
Hilo C++/C++/Hilo/NullPhotoGroup.h [code]
Hilo C++/C++/Hilo/ObservableQuery.h [code]
Hilo C++/C++/Hilo/PageType.h [code]
Hilo C++/C++/Hilo/pch.cpp [code]
Hilo C++/C++/Hilo/pch.h [code]
Hilo C++/C++/Hilo/Photo.cpp [code]
Hilo C++/C++/Hilo/Photo.h [code]
Hilo C++/C++/Hilo/PhotoCache.cpp [code]
Hilo C++/C++/Hilo/PhotoCache.h [code]
Hilo C++/C++/Hilo/PhotoPathComparer.cpp [code]
Hilo C++/C++/Hilo/PhotoPathComparer.h [code]
Hilo C++/C++/Hilo/QueryChange.h [code]
Hilo C++/C++/Hilo/RandomPhotoSelector.cpp [code]
Hilo C++/C++/Hilo/RandomPhotoSelector.h [code]
Hilo C++/C++/Hilo/Repository.h [code]
Hilo C++/C++/Hilo/RotateImageView.xaml.cpp [code]
Hilo C++/C++/Hilo/RotateImageView.xaml.h [code]
Hilo C++/C++/Hilo/RotateImageViewModel.cpp [code]
Hilo C++/C++/Hilo/RotateImageViewModel.h [code]
Hilo C++/C++/Hilo/TaskExceptionsExtensions.h [code]
Hilo C++/C++/Hilo/TaskExtensions.cpp [code]
Hilo C++/C++/Hilo/TaskExtensions.h [code]
Hilo C++/C++/Hilo/ThumbnailGenerator.cpp [code]
Hilo C++/C++/Hilo/ThumbnailGenerator.h [code]
Hilo C++/C++/Hilo/TileUpdateScheduler.cpp [code]
Hilo C++/C++/Hilo/TileUpdateScheduler.h [code]
Hilo C++/C++/Hilo/VariableGridView.cpp [code]
Hilo C++/C++/Hilo/VariableGridView.h [code]
Hilo C++/C++/Hilo/ViewModelBase.cpp [code]
Hilo C++/C++/Hilo/ViewModelBase.h [code]
Hilo C++/C++/Hilo/ViewModelLocator.cpp [code]
Hilo C++/C++/Hilo/ViewModelLocator.h [code]
Hilo C++/C++/Hilo/WideFiveImageTile.cpp [code]
Hilo C++/C++/Hilo/WideFiveImageTile.h [code]
Hilo C++/C++/Hilo/YearGroup.cpp [code]
Hilo C++/C++/Hilo/YearGroup.h [code]
Hilo C++/C++/Hilo/Common/BindableBase.cpp [code]
Hilo C++/C++/Hilo/Common/BindableBase.h [code]
Hilo C++/C++/Hilo/Common/BooleanNegationConverter.cpp [code]
Hilo C++/C++/Hilo/Common/BooleanNegationConverter.h [code]
Hilo C++/C++/Hilo/Common/BooleanToVisibilityConverter.cpp [code]
Hilo C++/C++/Hilo/Common/BooleanToVisibilityConverter.h [code]
Hilo C++/C++/Hilo/Common/LayoutAwarePage.cpp [code]
Hilo C++/C++/Hilo/Common/LayoutAwarePage.h [code]
Hilo C++/C++/Hilo/Common/RichTextColumns.cpp [code]
Hilo C++/C++/Hilo/Common/RichTextColumns.h [code]
Hilo C++/C++/Hilo/Common/SuspensionManager.cpp [code]
Hilo C++/C++/Hilo/Common/SuspensionManager.h [code]
HomeGroup app/C++/App.xaml.cpp [code]
HomeGroup app/C++/App.xaml.h [code]
HomeGroup app/C++/Constants.cpp [code]
HomeGroup app/C++/Constants.h [code]
HomeGroup app/C++/HomeGroupAdvancedSearch.xaml.cpp [code]
HomeGroup app/C++/HomeGroupAdvancedSearch.xaml.h [code]
HomeGroup app/C++/HomeGroupPickerScenario.xaml.cpp [code]
HomeGroup app/C++/HomeGroupPickerScenario.xaml.h [code]
HomeGroup app/C++/HomeGroupVideoStream.xaml.cpp [code]
HomeGroup app/C++/HomeGroupVideoStream.xaml.h [code]
HomeGroup app/C++/MainPage.xaml.cpp [code]
HomeGroup app/C++/MainPage.xaml.h [code]
HomeGroup app/C++/pch.cpp [code]
HomeGroup app/C++/pch.h [code]
HomeGroup app/C++/SearchHomeGroup.xaml.cpp [code]
HomeGroup app/C++/SearchHomeGroup.xaml.h [code]
HomeGroup app/C++/common/LayoutAwarePage.cpp [code]
HomeGroup app/C++/common/LayoutAwarePage.h [code]
HomeGroup app/C++/common/suspensionmanager.cpp [code]
HomeGroup app/C++/common/suspensionmanager.h [code]
HttpClient/C++/App.xaml.cpp [code]
HttpClient/C++/App.xaml.h [code]
HttpClient/C++/Constants.cpp [code]
HttpClient/C++/Constants.h [code]
HttpClient/C++/HttpRequest.cpp [code]
HttpClient/C++/HttpRequest.h [code]
HttpClient/C++/MainPage.xaml.cpp [code]
HttpClient/C++/MainPage.xaml.h [code]
HttpClient/C++/pch.cpp [code]
HttpClient/C++/pch.h [code]
HttpClient/C++/Scenario1.xaml.cpp [code]
HttpClient/C++/Scenario1.xaml.h [code]
HttpClient/C++/Scenario2.xaml.cpp [code]
HttpClient/C++/Scenario2.xaml.h [code]
HttpClient/C++/Scenario3.xaml.cpp [code]
HttpClient/C++/Scenario3.xaml.h [code]
HttpClient/C++/Scenario4.xaml.cpp [code]
HttpClient/C++/Scenario4.xaml.h [code]
HttpClient/C++/Scenario5.xaml.cpp [code]
HttpClient/C++/Scenario5.xaml.h [code]
HttpClient/C++/common/LayoutAwarePage.cpp [code]
HttpClient/C++/common/LayoutAwarePage.h [code]
HttpClient/C++/common/suspensionmanager.cpp [code]
HttpClient/C++/common/suspensionmanager.h [code]
Inclinometer sensor/C++/App.xaml.cpp [code]
Inclinometer sensor/C++/App.xaml.h [code]
Inclinometer sensor/C++/Constants.cpp [code]
Inclinometer sensor/C++/Constants.h [code]
Inclinometer sensor/C++/MainPage.xaml.cpp [code]
Inclinometer sensor/C++/MainPage.xaml.h [code]
Inclinometer sensor/C++/pch.cpp [code]
Inclinometer sensor/C++/pch.h [code]
Inclinometer sensor/C++/Scenario1.xaml.cpp [code]
Inclinometer sensor/C++/Scenario1.xaml.h [code]
Inclinometer sensor/C++/Scenario2.xaml.cpp [code]
Inclinometer sensor/C++/Scenario2.xaml.h [code]
Inclinometer sensor/C++/common/LayoutAwarePage.cpp [code]
Inclinometer sensor/C++/common/LayoutAwarePage.h [code]
Inclinometer sensor/C++/common/suspensionmanager.cpp [code]
Inclinometer sensor/C++/common/suspensionmanager.h [code]
Input Device capabilities/C++/App.xaml.cpp [code]
Input Device capabilities/C++/App.xaml.h [code]
Input Device capabilities/C++/Constants.cpp [code]
Input Device capabilities/C++/Constants.h [code]
Input Device capabilities/C++/cppsamplesutils.h [code]
Input Device capabilities/C++/Keyboard.xaml.cpp [code]
Input Device capabilities/C++/Keyboard.xaml.h [code]
Input Device capabilities/C++/MainPage.xaml.cpp [code]
Input Device capabilities/C++/MainPage.xaml.h [code]
Input Device capabilities/C++/Mouse.xaml.cpp [code]
Input Device capabilities/C++/Mouse.xaml.h [code]
Input Device capabilities/C++/pch.cpp [code]
Input Device capabilities/C++/pch.h [code]
Input Device capabilities/C++/Pointer.xaml.cpp [code]
Input Device capabilities/C++/Pointer.xaml.h [code]
Input Device capabilities/C++/Touch.xaml.cpp [code]
Input Device capabilities/C++/Touch.xaml.h [code]
Input Device capabilities/C++/common/LayoutAwarePage.cpp [code]
Input Device capabilities/C++/common/LayoutAwarePage.h [code]
Input Device capabilities/C++/common/suspensionmanager.cpp [code]
Input Device capabilities/C++/common/suspensionmanager.h [code]
Input Manipulations and gestures (C++)/C++/BackgroundObject.cpp [code]
Input Manipulations and gestures (C++)/C++/BackgroundObject.h [code]
Input Manipulations and gestures (C++)/C++/DirectXBase.cpp [code]
Input Manipulations and gestures (C++)/C++/DirectXBase.h [code]
Input Manipulations and gestures (C++)/C++/DirectXSample.h [code]
Input Manipulations and gestures (C++)/C++/DrawingObject.cpp [code]
Input Manipulations and gestures (C++)/C++/DrawingObject.h [code]
Input Manipulations and gestures (C++)/C++/ManipulatableObject.h [code]
Input Manipulations and gestures (C++)/C++/pch.cpp [code]
Input Manipulations and gestures (C++)/C++/pch.h [code]
Input Simplified ink/C++/DirectXBase.cpp [code]
Input Simplified ink/C++/DirectXBase.h [code]
Input Simplified ink/C++/DirectXSample.h [code]
Input Simplified ink/C++/pch.cpp [code]
Input Simplified ink/C++/pch.h [code]
Input Simplified ink/C++/simpleInk.cpp [code]
Input Simplified ink/C++/simpleInk.h [code]
Input Touch hit testing/C++/DirectXBase.cpp [code]
Input Touch hit testing/C++/DirectXBase.h [code]
Input Touch hit testing/C++/DirectXSample.h [code]
Input Touch hit testing/C++/pch.cpp [code]
Input Touch hit testing/C++/pch.h [code]
Input Touch hit testing/C++/Program.cpp [code]
Input Touch hit testing/C++/Program.h [code]
Input Touch hit testing/C++/SampleOverlay.cpp [code]
Input Touch hit testing/C++/SampleOverlay.h [code]
Input Touch hit testing/C++/Shape.cpp [code]
Input Touch hit testing/C++/Shape.h [code]
Input Touch hit testing/C++/ShapesPuzzle.cpp [code]
Input Touch hit testing/C++/ShapesPuzzle.h [code]
Input Touch keyboard text input/C++/App.xaml.cpp [code]
Input Touch keyboard text input/C++/App.xaml.h [code]
Input Touch keyboard text input/C++/Constants.cpp [code]
Input Touch keyboard text input/C++/Constants.h [code]
Input Touch keyboard text input/C++/MainPage.xaml.cpp [code]
Input Touch keyboard text input/C++/MainPage.xaml.h [code]
Input Touch keyboard text input/C++/pch.cpp [code]
Input Touch keyboard text input/C++/pch.h [code]
Input Touch keyboard text input/C++/ScopedViews.xaml.cpp [code]
Input Touch keyboard text input/C++/ScopedViews.xaml.h [code]
Input Touch keyboard text input/C++/common/LayoutAwarePage.cpp [code]
Input Touch keyboard text input/C++/common/LayoutAwarePage.h [code]
Input Touch keyboard text input/C++/common/suspensionmanager.cpp [code]
Input Touch keyboard text input/C++/common/suspensionmanager.h [code]
Input Touch keyboard/C++/App.xaml.cpp [code]
Input Touch keyboard/C++/App.xaml.h [code]
Input Touch keyboard/C++/Constants.cpp [code]
Input Touch keyboard/C++/Constants.h [code]
Input Touch keyboard/C++/Launch.xaml.cpp [code]
Input Touch keyboard/C++/Launch.xaml.h [code]
Input Touch keyboard/C++/MainPage.xaml.cpp [code]
Input Touch keyboard/C++/MainPage.xaml.h [code]
Input Touch keyboard/C++/NonTouchableTextBlock.xaml.cpp [code]
Input Touch keyboard/C++/NonTouchableTextBlock.xaml.h [code]
Input Touch keyboard/C++/pch.cpp [code]
Input Touch keyboard/C++/pch.h [code]
Input Touch keyboard/C++/TouchableTextBlock.xaml.cpp [code]
Input Touch keyboard/C++/TouchableTextBlock.xaml.h [code]
Input Touch keyboard/C++/common/LayoutAwarePage.cpp [code]
Input Touch keyboard/C++/common/LayoutAwarePage.h [code]
Input Touch keyboard/C++/common/suspensionmanager.cpp [code]
Input Touch keyboard/C++/common/suspensionmanager.h [code]
IXmlReader and IXmlWriter XML data readwrite/C++/App.xaml.cpp [code]
IXmlReader and IXmlWriter XML data readwrite/C++/App.xaml.h [code]
IXmlReader and IXmlWriter XML data readwrite/C++/Constants.cpp [code]
IXmlReader and IXmlWriter XML data readwrite/C++/Constants.h [code]
IXmlReader and IXmlWriter XML data readwrite/C++/MainPage.xaml.h [code]
IXmlReader and IXmlWriter XML data readwrite/C++/pch.cpp [code]
IXmlReader and IXmlWriter XML data readwrite/C++/pch.h [code]
Language font mapping/C++/App.xaml.cpp [code]
Language font mapping/C++/App.xaml.h [code]
Language font mapping/C++/CppSamplesUtils.h [code]
Language font mapping/C++/LocalCache.cpp [code]
Language font mapping/C++/LocalCache.h [code]
Language font mapping/C++/MainPage.xaml.cpp [code]
Language font mapping/C++/MainPage.xaml.h [code]
Language font mapping/C++/pch.cpp [code]
Language font mapping/C++/pch.h [code]
Language font mapping/C++/ScenarioInput1.xaml.cpp [code]
Language font mapping/C++/ScenarioInput1.xaml.h [code]
Language font mapping/C++/ScenarioInput2.xaml.cpp [code]
Language font mapping/C++/ScenarioInput2.xaml.h [code]
Language font mapping/C++/ScenarioList.xaml.cpp [code]
Language font mapping/C++/ScenarioList.xaml.h [code]
Language font mapping/C++/ScenarioOutput1.xaml.cpp [code]
Language font mapping/C++/ScenarioOutput1.xaml.h [code]
Language font mapping/C++/ScenarioOutput2.xaml.cpp [code]
Language font mapping/C++/ScenarioOutput2.xaml.h [code]
LightSensor/C++/App.xaml.cpp [code]
LightSensor/C++/App.xaml.h [code]
LightSensor/C++/Constants.cpp [code]
LightSensor/C++/Constants.h [code]
LightSensor/C++/MainPage.xaml.cpp [code]
LightSensor/C++/MainPage.xaml.h [code]
LightSensor/C++/pch.cpp [code]
LightSensor/C++/pch.h [code]
LightSensor/C++/Scenario1.xaml.cpp [code]
LightSensor/C++/Scenario1.xaml.h [code]
LightSensor/C++/Scenario2.xaml.cpp [code]
LightSensor/C++/Scenario2.xaml.h [code]
LightSensor/C++/common/LayoutAwarePage.cpp [code]
LightSensor/C++/common/LayoutAwarePage.h [code]
LightSensor/C++/common/suspensionmanager.cpp [code]
LightSensor/C++/common/suspensionmanager.h [code]
Lock screen apps/C#,C++/App.xaml.cpp [code]
Lock screen apps/C#,C++/App.xaml.h [code]
Lock screen apps/C#,C++/CppSamplesUtils.h [code]
Lock screen apps/C#,C++/MainPage.xaml.cpp [code]
Lock screen apps/C#,C++/MainPage.xaml.h [code]
Lock screen apps/C#,C++/pch.cpp [code]
Lock screen apps/C#,C++/pch.h [code]
Lock screen apps/C#,C++/ScenarioInput1.xaml.cpp [code]
Lock screen apps/C#,C++/ScenarioInput1.xaml.h [code]
Lock screen apps/C#,C++/ScenarioInput2.xaml.cpp [code]
Lock screen apps/C#,C++/ScenarioInput2.xaml.h [code]
Lock screen apps/C#,C++/ScenarioInput3.xaml.cpp [code]
Lock screen apps/C#,C++/ScenarioInput3.xaml.h [code]
Lock screen apps/C#,C++/ScenarioList.xaml.cpp [code]
Lock screen apps/C#,C++/ScenarioList.xaml.h [code]
Lock screen apps/C#,C++/ScenarioOutput1.xaml.cpp [code]
Lock screen apps/C#,C++/ScenarioOutput1.xaml.h [code]
Lock screen apps/C#,C++/ScenarioOutput2.xaml.cpp [code]
Lock screen apps/C#,C++/ScenarioOutput2.xaml.h [code]
Lock screen apps/C#,C++/ScenarioOutput3.xaml.cpp [code]
Lock screen apps/C#,C++/ScenarioOutput3.xaml.h [code]
Lock screen apps/C#,C++/NotificationsExtensions/BadgeContent.cs [code]
Lock screen apps/C#,C++/NotificationsExtensions/Common.cs [code]
Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs [code]
Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs [code]
Lock screen personalization/C++/App.xaml.cpp [code]
Lock screen personalization/C++/App.xaml.h [code]
Lock screen personalization/C++/Constants.cpp [code]
Lock screen personalization/C++/Constants.h [code]
Lock screen personalization/C++/MainPage.xaml.cpp [code]
Lock screen personalization/C++/MainPage.xaml.h [code]
Lock screen personalization/C++/pch.cpp [code]
Lock screen personalization/C++/pch.h [code]
Lock screen personalization/C++/SetLockscreenImage.xaml.cpp [code]
Lock screen personalization/C++/SetLockscreenImage.xaml.h [code]
Lock screen personalization/C++/common/LayoutAwarePage.cpp [code]
Lock screen personalization/C++/common/LayoutAwarePage.h [code]
Lock screen personalization/C++/common/suspensionmanager.cpp [code]
Lock screen personalization/C++/common/suspensionmanager.h [code]
Media capture using capture device/C#,C++/App.xaml.cs [code]
Media capture using capture device/C#,C++/AudioCapture.xaml.cs [code]
Media capture using capture device/C#,C++/BasicCapture.xaml.cs [code]
Media capture using capture device/C#,C++/Constants.cs [code]
Media capture using capture device/C#,C++/MainPage.xaml.cs [code]
Media capture using capture device/C++/AdvancedCapture.xaml.cpp [code]
Media capture using capture device/C++/AdvancedCapture.xaml.h [code]
Media capture using capture device/C++/App.xaml.cpp [code]
Media capture using capture device/C++/App.xaml.h [code]
Media capture using capture device/C++/AudioCapture.xaml.cpp [code]
Media capture using capture device/C++/AudioCapture.xaml.h [code]
Media capture using capture device/C++/BasicCapture.xaml.cpp [code]
Media capture using capture device/C++/BasicCapture.xaml.h [code]
Media capture using capture device/C++/Constants.cpp [code]
Media capture using capture device/C++/Constants.h [code]
Media capture using capture device/C++/MainPage.xaml.cpp [code]
Media capture using capture device/C++/MainPage.xaml.h [code]
Media capture using capture device/C++/pch.cpp [code]
Media capture using capture device/C++/pch.h [code]
Media capture using capture device/C++/common/LayoutAwarePage.h [code]
Media engine native C++ video playback/C++/common.h [code]
Media engine native C++ video playback/C++/d3dmanagerlock.hxx [code]
Media engine native C++ video playback/C++/frameworkview.cpp [code]
Media engine native C++ video playback/C++/frameworkview.h [code]
Media engine native C++ video playback/C++/main.cpp [code]
Media engine native C++ video playback/C++/meplayer.cpp [code]
Media engine native C++ video playback/C++/meplayer.h [code]
Media engine native C++ video playback/C++/pch.cpp [code]
Media engine native C++ video playback/C++/pch.h [code]
Media engine native C++ video playback/C++/videoview.cpp [code]
Media engine native C++ video playback/C++/videoview.h [code]
Media extensions/C#,C++/App.xaml.cs [code]
Media extensions/C#,C++/MainPage.xaml.cs [code]
Media extensions/C#,C++/ScenarioInput1.xaml.cs [code]
Media extensions/C#,C++/ScenarioInput2.xaml.cs [code]
Media extensions/C#,C++/ScenarioInput3.xaml.cs [code]
Media extensions/C#,C++/ScenarioInput4.xaml.cs [code]
Media extensions/C#,C++/ScenarioList.xaml.cs [code]
Media extensions/C#,C++/ScenarioOutput1.xaml.cs [code]
Media extensions/C#,C++/ScenarioOutput2.xaml.cs [code]
Media extensions/C#,C++/ScenarioOutput3.xaml.cs [code]
Media extensions/C#,C++/ScenarioOutput4.xaml.cs [code]
Media extensions/C#,C++/MediaExtensions/Common/AsyncCB.h [code]
Media extensions/C#,C++/MediaExtensions/Common/BufferLock.h [code]
Media extensions/C#,C++/MediaExtensions/Common/CritSec.h [code]
Media extensions/C#,C++/MediaExtensions/Common/LinkList.h [code]
Media extensions/C#,C++/MediaExtensions/Common/OpQueue.h [code]
Media extensions/C#,C++/MediaExtensions/Grayscale/dllmain.cpp [code]
Media extensions/C#,C++/MediaExtensions/Grayscale/Grayscale.cpp [code]
Media extensions/C#,C++/MediaExtensions/Grayscale/Grayscale.h [code]
Media extensions/C#,C++/MediaExtensions/Invert/CopyModule.h [code]
Media extensions/C#,C++/MediaExtensions/Invert/dllmain.cpp [code]
Media extensions/C#,C++/MediaExtensions/Invert/Invert.cpp [code]
Media extensions/C#,C++/MediaExtensions/Invert/Invert.h [code]
Media extensions/C#,C++/MediaExtensions/Invert/InvertModule.cpp [code]
Media extensions/C#,C++/MediaExtensions/Invert/InvertModule.h [code]
Media extensions/C#,C++/MediaExtensions/Invert/TextureLock.h [code]
Media extensions/C#,C++/MediaExtensions/Invert/VideoBufferLock.h [code]
Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.cpp [code]
Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.h [code]
Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/dll.cpp [code]
Media extensions/C#,C++/MediaExtensions/Mpeg1Source/dllmain.cpp [code]
Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp [code]
Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.h [code]
Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.cpp [code]
Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h [code]
Media extensions/C#,C++/MediaExtensions/Polar/dllmain.cpp [code]
Media extensions/C#,C++/MediaExtensions/Polar/PolarEffect.cpp [code]
Media extensions/C#,C++/MediaExtensions/Polar/PolarEffect.h [code]
Media extensions/C#,C++/MediaExtensions/Polar/PolarTransform.idl [code]
Media extensions/C#,C++/Properties/AssemblyInfo.cs [code]
Media extensions/C#,C++/Sample-Utils/Constants.cs [code]
Media extensions/C#,C++/Sample-Utils/SuspensionManager.cs [code]
Media extensions/C++/App.xaml.cpp [code]
Media extensions/C++/App.xaml.h [code]
Media extensions/C++/CppSamplesUtils.h [code]
Media extensions/C++/MainPage.xaml.cpp [code]
Media extensions/C++/MainPage.xaml.h [code]
Media extensions/C++/pch.cpp [code]
Media extensions/C++/pch.h [code]
Media extensions/C++/ScenarioInput1.xaml.cpp [code]
Media extensions/C++/ScenarioInput1.xaml.h [code]
Media extensions/C++/ScenarioInput2.xaml.cpp [code]
Media extensions/C++/ScenarioInput2.xaml.h [code]
Media extensions/C++/ScenarioInput3.xaml.cpp [code]
Media extensions/C++/ScenarioInput3.xaml.h [code]
Media extensions/C++/ScenarioInput4.xaml.cpp [code]
Media extensions/C++/ScenarioInput4.xaml.h [code]
Media extensions/C++/ScenarioList.xaml.cpp [code]
Media extensions/C++/ScenarioList.xaml.h [code]
Media extensions/C++/ScenarioOutput1.xaml.cpp [code]
Media extensions/C++/ScenarioOutput1.xaml.h [code]
Media extensions/C++/ScenarioOutput2.xaml.cpp [code]
Media extensions/C++/ScenarioOutput2.xaml.h [code]
Media extensions/C++/ScenarioOutput3.xaml.cpp [code]
Media extensions/C++/ScenarioOutput3.xaml.h [code]
Media extensions/C++/ScenarioOutput4.xaml.cpp [code]
Media extensions/C++/ScenarioOutput4.xaml.h [code]
Media extensions/C++/MediaExtensions/Common/AsyncCB.h [code]
Media extensions/C++/MediaExtensions/Common/BufferLock.h [code]
Media extensions/C++/MediaExtensions/Common/CritSec.h [code]
Media extensions/C++/MediaExtensions/Common/LinkList.h [code]
Media extensions/C++/MediaExtensions/Common/OpQueue.h [code]
Media extensions/C++/MediaExtensions/GeometricSource/dllmain.cpp [code]
Media extensions/C++/MediaExtensions/GeometricSource/pch.cpp [code]
Media extensions/C++/MediaExtensions/GeometricSource/StdAfx.h [code]
Media extensions/C++/MediaExtensions/Grayscale/dllmain.cpp [code]
Media extensions/C++/MediaExtensions/Grayscale/Grayscale.cpp [code]
Media extensions/C++/MediaExtensions/Grayscale/Grayscale.h [code]
Media extensions/C++/MediaExtensions/Invert/CopyModule.h [code]
Media extensions/C++/MediaExtensions/Invert/dllmain.cpp [code]
Media extensions/C++/MediaExtensions/Invert/Invert.cpp [code]
Media extensions/C++/MediaExtensions/Invert/Invert.h [code]
Media extensions/C++/MediaExtensions/Invert/InvertModule.cpp [code]
Media extensions/C++/MediaExtensions/Invert/InvertModule.h [code]
Media extensions/C++/MediaExtensions/Invert/InvertTransform.idl [code]
Media extensions/C++/MediaExtensions/Invert/TextureLock.h [code]
Media extensions/C++/MediaExtensions/Invert/VideoBufferLock.h [code]
Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.cpp [code]
Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.h [code]
Media extensions/C++/MediaExtensions/Mpeg1Decoder/dll.cpp [code]
Media extensions/C++/MediaExtensions/Mpeg1Source/dllmain.cpp [code]
Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Source.idl [code]
Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp [code]
Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.h [code]
Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Stream.cpp [code]
Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Stream.h [code]
Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.cpp [code]
Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h [code]
Media extensions/C++/MediaExtensions/Polar/dllmain.cpp [code]
Media extensions/C++/MediaExtensions/Polar/PolarEffect.cpp [code]
Media extensions/C++/MediaExtensions/Polar/PolarEffect.h [code]
Media extensions/C++/MediaExtensions/Polar/PolarTransform.idl [code]
Media Play To/C++/App.xaml.cpp [code]
Media Play To/C++/App.xaml.h [code]
Media Play To/C++/Constants.cpp [code]
Media Play To/C++/Constants.h [code]
Media Play To/C++/MainPage.xaml.cpp [code]
Media Play To/C++/MainPage.xaml.h [code]
Media Play To/C++/pch.cpp [code]
Media Play To/C++/pch.h [code]
Media Play To/C++/Scenario1.xaml.cpp [code]
Media Play To/C++/Scenario1.xaml.h [code]
Media Play To/C++/Scenario2.xaml.cpp [code]
Media Play To/C++/Scenario2.xaml.h [code]
Media Play To/C++/common/LayoutAwarePage.cpp [code]
Media Play To/C++/common/LayoutAwarePage.h [code]
Media Play To/C++/common/suspensionmanager.cpp [code]
Media Play To/C++/common/suspensionmanager.h [code]
Media Server client/C++/App.xaml.cpp [code]
Media Server client/C++/App.xaml.h [code]
Media Server client/C++/Constants.cpp [code]
Media Server client/C++/Constants.h [code]
Media Server client/C++/LocateVideo.xaml.cpp [code]
Media Server client/C++/LocateVideo.xaml.h [code]
Media Server client/C++/MainPage.xaml.cpp [code]
Media Server client/C++/MainPage.xaml.h [code]
Media Server client/C++/pch.cpp [code]
Media Server client/C++/pch.h [code]
Media Server client/C++/common/LayoutAwarePage.cpp [code]
Media Server client/C++/common/LayoutAwarePage.h [code]
Media Server client/C++/common/suspensionmanager.cpp [code]
Media Server client/C++/common/suspensionmanager.h [code]
MediaStreamSource media extension/C#,C++/App.xaml.cs [code]
MediaStreamSource media extension/C#,C++/AudioSource.xaml.cs [code]
MediaStreamSource media extension/C#,C++/Constants.cs [code]
MediaStreamSource media extension/C#,C++/MainPage.xaml.cs [code]
MediaStreamSource media extension/C#,C++/PcmSource.cs [code]
Message dialog/C++/App.xaml.cpp [code]
Message dialog/C++/App.xaml.h [code]
Message dialog/C++/CancelCommand.xaml.cpp [code]
Message dialog/C++/CancelCommand.xaml.h [code]
Message dialog/C++/CompletedCallback.xaml.cpp [code]
Message dialog/C++/CompletedCallback.xaml.h [code]
Message dialog/C++/Constants.cpp [code]
Message dialog/C++/Constants.h [code]
Message dialog/C++/CustomCommand.xaml.cpp [code]
Message dialog/C++/CustomCommand.xaml.h [code]
Message dialog/C++/DefaultCloseCommand.xaml.cpp [code]
Message dialog/C++/DefaultCloseCommand.xaml.h [code]
Message dialog/C++/MainPage.xaml.cpp [code]
Message dialog/C++/MainPage.xaml.h [code]
Message dialog/C++/pch.cpp [code]
Message dialog/C++/pch.h [code]
Message dialog/C++/common/LayoutAwarePage.cpp [code]
Message dialog/C++/common/LayoutAwarePage.h [code]
Message dialog/C++/common/suspensionmanager.cpp [code]
Message dialog/C++/common/suspensionmanager.h [code]
Mobile broadband account provisioning/C++/App.xaml.cpp [code]
Mobile broadband account provisioning/C++/App.xaml.h [code]
Mobile broadband account provisioning/C++/Constants.cpp [code]
Mobile broadband account provisioning/C++/Constants.h [code]
Mobile broadband account provisioning/C++/MainPage.xaml.cpp [code]
Mobile broadband account provisioning/C++/MainPage.xaml.h [code]
Mobile broadband account provisioning/C++/pch.cpp [code]
Mobile broadband account provisioning/C++/pch.h [code]
Mobile broadband account provisioning/C++/ProvisionMno.xaml.cpp [code]
Mobile broadband account provisioning/C++/ProvisionMno.xaml.h [code]
Mobile broadband account provisioning/C++/UpdateCost.xaml.cpp [code]
Mobile broadband account provisioning/C++/UpdateCost.xaml.h [code]
Mobile broadband account provisioning/C++/UpdateUsage.xaml.cpp [code]
Mobile broadband account provisioning/C++/UpdateUsage.xaml.h [code]
Mobile broadband account provisioning/C++/Util.cpp [code]
Mobile broadband account provisioning/C++/Util.h [code]
Network information/C++/App.xaml.cpp [code]
Network information/C++/App.xaml.h [code]
Network information/C++/ConnectionProfileList.xaml.cpp [code]
Network information/C++/ConnectionProfileList.xaml.h [code]
Network information/C++/Constants.cpp [code]
Network information/C++/Constants.h [code]
Network information/C++/InternetConnectionProfile.xaml.cpp [code]
Network information/C++/InternetConnectionProfile.xaml.h [code]
Network information/C++/LanId.xaml.cpp [code]
Network information/C++/LanId.xaml.h [code]
Network information/C++/MainPage.xaml.cpp [code]
Network information/C++/MainPage.xaml.h [code]
Network information/C++/NetworkStatusChange.xaml.cpp [code]
Network information/C++/NetworkStatusChange.xaml.h [code]
Network information/C++/pch.cpp [code]
Network information/C++/pch.h [code]
Network information/C++/ProfileLocalUsageData.xaml.cpp [code]
Network information/C++/ProfileLocalUsageData.xaml.h [code]
Network information/C++/common/LayoutAwarePage.cpp [code]
Network information/C++/common/LayoutAwarePage.h [code]
Network information/C++/common/suspensionmanager.cpp [code]
Network information/C++/common/suspensionmanager.h [code]
Network status background/C++/NetworkStatusApp/App.xaml.cpp [code]
Network status background/C++/NetworkStatusApp/App.xaml.h [code]
Network status background/C++/NetworkStatusApp/Constants.cpp [code]
Network status background/C++/NetworkStatusApp/Constants.h [code]
Network status background/C++/NetworkStatusApp/MainPage.xaml.cpp [code]
Network status background/C++/NetworkStatusApp/MainPage.xaml.h [code]
Network status background/C++/NetworkStatusApp/pch.cpp [code]
Network status background/C++/NetworkStatusApp/pch.h [code]
Network status background/C++/NetworkStatusTask/BackgroundTask.h [code]
Network status background/C++/NetworkStatusTask/pch.cpp [code]
Network status background/C++/NetworkStatusTask/pch.h [code]
Number formatting and parsing/C++/App.xaml.cpp [code]
Number formatting and parsing/C++/App.xaml.h [code]
Number formatting and parsing/C++/Constants.cpp [code]
Number formatting and parsing/C++/Constants.h [code]
Number formatting and parsing/C++/CurrencyFormatting.xaml.cpp [code]
Number formatting and parsing/C++/CurrencyFormatting.xaml.h [code]
Number formatting and parsing/C++/DecimalFormatting.xaml.cpp [code]
Number formatting and parsing/C++/DecimalFormatting.xaml.h [code]
Number formatting and parsing/C++/MainPage.xaml.cpp [code]
Number formatting and parsing/C++/MainPage.xaml.h [code]
Number formatting and parsing/C++/NumberParsing.xaml.cpp [code]
Number formatting and parsing/C++/NumberParsing.xaml.h [code]
Number formatting and parsing/C++/pch.cpp [code]
Number formatting and parsing/C++/pch.h [code]
Number formatting and parsing/C++/common/LayoutAwarePage.cpp [code]
Number formatting and parsing/C++/common/LayoutAwarePage.h [code]
Number formatting and parsing/C++/common/suspensionmanager.cpp [code]
Number formatting and parsing/C++/common/suspensionmanager.h [code]
OrientationSensor/C++/App.xaml.cpp [code]
OrientationSensor/C++/App.xaml.h [code]
OrientationSensor/C++/Constants.cpp [code]
OrientationSensor/C++/Constants.h [code]
OrientationSensor/C++/MainPage.xaml.cpp [code]
OrientationSensor/C++/MainPage.xaml.h [code]
OrientationSensor/C++/pch.cpp [code]
OrientationSensor/C++/pch.h [code]
OrientationSensor/C++/Scenario1.xaml.cpp [code]
OrientationSensor/C++/Scenario1.xaml.h [code]
OrientationSensor/C++/Scenario2.xaml.cpp [code]
OrientationSensor/C++/Scenario2.xaml.h [code]
OrientationSensor/C++/common/LayoutAwarePage.cpp [code]
OrientationSensor/C++/common/LayoutAwarePage.h [code]
OrientationSensor/C++/common/suspensionmanager.cpp [code]
OrientationSensor/C++/common/suspensionmanager.h [code]
Playback Manager Companion/C++/App.xaml.cpp [code]
Playback Manager Companion/C++/App.xaml.h [code]
Playback Manager Companion/C++/Constants.cpp [code]
Playback Manager Companion/C++/Constants.h [code]
Playback Manager Companion/C++/MainPage.xaml.cpp [code]
Playback Manager Companion/C++/MainPage.xaml.h [code]
Playback Manager Companion/C++/pch.cpp [code]
Playback Manager Companion/C++/pch.h [code]
Playback Manager Companion/C++/PlaybackControl.xaml.cpp [code]
Playback Manager Companion/C++/PlaybackControl.xaml.h [code]
Playback Manager Companion/C++/StreamTypeAlert.xaml.cpp [code]
Playback Manager Companion/C++/StreamTypeAlert.xaml.h [code]
Playback Manager Companion/C++/StreamTypeCommunications.xaml.cpp [code]
Playback Manager Companion/C++/StreamTypeCommunications.xaml.h [code]
Playback Manager Companion/C++/StreamTypeMedia.xaml.cpp [code]
Playback Manager Companion/C++/StreamTypeMedia.xaml.h [code]
Playback Manager Companion/C++/StreamTypeOther.xaml.cpp [code]
Playback Manager Companion/C++/StreamTypeOther.xaml.h [code]
Playback Manager Companion/C++/common/LayoutAwarePage.cpp [code]
Playback Manager Companion/C++/common/LayoutAwarePage.h [code]
Playback Manager Companion/C++/common/suspensionmanager.cpp [code]
Playback Manager Companion/C++/common/suspensionmanager.h [code]
Playback Manager Companion/C++/sample-utils/CppSamplesUtils.h [code]
Playback Manager msAudioCategory/C++/App.xaml.cpp [code]
Playback Manager msAudioCategory/C++/App.xaml.h [code]
Playback Manager msAudioCategory/C++/Constants.cpp [code]
Playback Manager msAudioCategory/C++/Constants.h [code]
Playback Manager msAudioCategory/C++/MainPage.xaml.cpp [code]
Playback Manager msAudioCategory/C++/MainPage.xaml.h [code]
Playback Manager msAudioCategory/C++/pch.cpp [code]
Playback Manager msAudioCategory/C++/pch.h [code]
Playback Manager msAudioCategory/C++/PlaybackControl.xaml.cpp [code]
Playback Manager msAudioCategory/C++/PlaybackControl.xaml.h [code]
Playback Manager msAudioCategory/C++/StreamTypeAlert.xaml.cpp [code]
Playback Manager msAudioCategory/C++/StreamTypeAlert.xaml.h [code]
Playback Manager msAudioCategory/C++/StreamTypeMedia.xaml.cpp [code]
Playback Manager msAudioCategory/C++/StreamTypeMedia.xaml.h [code]
Playback Manager msAudioCategory/C++/StreamTypeOther.xaml.cpp [code]
Playback Manager msAudioCategory/C++/StreamTypeOther.xaml.h [code]
Playback Manager msAudioCategory/C++/common/LayoutAwarePage.cpp [code]
Playback Manager msAudioCategory/C++/common/LayoutAwarePage.h [code]
Playback Manager msAudioCategory/C++/common/suspensionmanager.h [code]
Playlist/C++/Add.xaml.cpp [code]
Playlist/C++/Add.xaml.h [code]
Playlist/C++/App.xaml.cpp [code]
Playlist/C++/App.xaml.h [code]
Playlist/C++/Clear.xaml.cpp [code]
Playlist/C++/Clear.xaml.h [code]
Playlist/C++/Constants.cpp [code]
Playlist/C++/Constants.h [code]
Playlist/C++/Create.xaml.cpp [code]
Playlist/C++/Create.xaml.h [code]
Playlist/C++/Display.xaml.cpp [code]
Playlist/C++/Display.xaml.h [code]
Playlist/C++/MainPage.xaml.cpp [code]
Playlist/C++/MainPage.xaml.h [code]
Playlist/C++/pch.cpp [code]
Playlist/C++/pch.h [code]
Playlist/C++/Remove.xaml.cpp [code]
Playlist/C++/Remove.xaml.h [code]
Playlist/C++/common/LayoutAwarePage.cpp [code]
Playlist/C++/common/LayoutAwarePage.h [code]
Playlist/C++/common/suspensionmanager.cpp [code]
Playlist/C++/common/suspensionmanager.h [code]
PlayToReceiver/C++/App.xaml.cpp [code]
PlayToReceiver/C++/App.xaml.h [code]
PlayToReceiver/C++/audiovideoptr.xaml.cpp [code]
PlayToReceiver/C++/audiovideoptr.xaml.h [code]
PlayToReceiver/C++/Constants.cpp [code]
PlayToReceiver/C++/Constants.h [code]
PlayToReceiver/C++/MainPage.xaml.cpp [code]
PlayToReceiver/C++/MainPage.xaml.h [code]
PlayToReceiver/C++/pch.cpp [code]
PlayToReceiver/C++/pch.h [code]
PlayToReceiver/C++/common/LayoutAwarePage.cpp [code]
PlayToReceiver/C++/common/LayoutAwarePage.h [code]
PlayToReceiver/C++/common/suspensionmanager.cpp [code]
PlayToReceiver/C++/common/suspensionmanager.h [code]
Portable device API/C++/App.xaml.cpp [code]
Portable device API/C++/App.xaml.h [code]
Portable device API/C++/Constants.cpp [code]
Portable device API/C++/Constants.h [code]
Portable device API/C++/EventCallback.h [code]
Portable device API/C++/MainPage.xaml.cpp [code]
Portable device API/C++/MainPage.xaml.h [code]
Portable device API/C++/pch.cpp [code]
Portable device API/C++/pch.h [code]
Portable device API/C++/S1_DeviceProperties.xaml.cpp [code]
Portable device API/C++/S1_DeviceProperties.xaml.h [code]
Portable device API/C++/S2_Enumeration.xaml.cpp [code]
Portable device API/C++/S2_Enumeration.xaml.h [code]
Portable device API/C++/S3_SendToDevice.xaml.cpp [code]
Portable device API/C++/S3_SendToDevice.xaml.h [code]
Portable device API/C++/S4_GetFromDevice.xaml.cpp [code]
Portable device API/C++/S4_GetFromDevice.xaml.h [code]
Portable device API/C++/S5_Events.xaml.cpp [code]
Portable device API/C++/S5_Events.xaml.h [code]
Portable device API/C++/S6_DeviceStatus.xaml.cpp [code]
Portable device API/C++/S6_DeviceStatus.xaml.h [code]
Portable device API/C++/common/LayoutAwarePage.cpp [code]
Portable device API/C++/common/LayoutAwarePage.h [code]
Portable device API/C++/common/SuspensionManager.cpp [code]
Portable device API/C++/common/SuspensionManager.h [code]
Print/C++/App.xaml.cpp [code]
Print/C++/App.xaml.h [code]
Print/C++/BasePrintPage.cpp [code]
Print/C++/BasePrintPage.h [code]
Print/C++/ContinuationPage.xaml.cpp [code]
Print/C++/ContinuationPage.xaml.h [code]
Print/C++/cppsamplesutils.h [code]
Print/C++/DisplayContent.h [code]
Print/C++/MainPage.xaml.cpp [code]
Print/C++/MainPage.xaml.h [code]
Print/C++/pch.cpp [code]
Print/C++/pch.h [code]
Print/C++/PreviewUnavailable.xaml.cpp [code]
Print/C++/PreviewUnavailable.xaml.h [code]
Print/C++/ScenarioInput1.xaml.cpp [code]
Print/C++/ScenarioInput1.xaml.h [code]
Print/C++/ScenarioInput2.xaml.cpp [code]
Print/C++/ScenarioInput2.xaml.h [code]
Print/C++/ScenarioInput3.xaml.cpp [code]
Print/C++/ScenarioInput3.xaml.h [code]
Print/C++/ScenarioInput4.xaml.cpp [code]
Print/C++/ScenarioInput4.xaml.h [code]
Print/C++/ScenarioInput5.xaml.cpp [code]
Print/C++/ScenarioInput5.xaml.h [code]
Print/C++/ScenarioInput6.xaml.cpp [code]
Print/C++/ScenarioInput6.xaml.h [code]
Print/C++/ScenarioList.xaml.cpp [code]
Print/C++/ScenarioList.xaml.h [code]
Print/C++/ScenarioOutput1.xaml.cpp [code]
Print/C++/ScenarioOutput1.xaml.h [code]
Print/C++/ScenarioOutput2.xaml.cpp [code]
Print/C++/ScenarioOutput2.xaml.h [code]
Print/C++/ScenarioOutput3.xaml.cpp [code]
Print/C++/ScenarioOutput3.xaml.h [code]
Print/C++/ScenarioOutput4.xaml.cpp [code]
Print/C++/ScenarioOutput4.xaml.h [code]
Print/C++/ScenarioOutput5.xaml.cpp [code]
Print/C++/ScenarioOutput5.xaml.h [code]
Print/C++/ScenarioOutput6.xaml.cpp [code]
Print/C++/ScenarioOutput6.xaml.h [code]
Programmatic file search/C++/App.xaml.cpp [code]
Programmatic file search/C++/App.xaml.h [code]
Programmatic file search/C++/Constants.cpp [code]
Programmatic file search/C++/Constants.h [code]
Programmatic file search/C++/MainPage.xaml.cpp [code]
Programmatic file search/C++/MainPage.xaml.h [code]
Programmatic file search/C++/pch.cpp [code]
Programmatic file search/C++/pch.h [code]
Programmatic file search/C++/Scenario1.xaml.cpp [code]
Programmatic file search/C++/Scenario1.xaml.h [code]
Programmatic file search/C++/common/LayoutAwarePage.cpp [code]
Programmatic file search/C++/common/LayoutAwarePage.h [code]
Programmatic file search/C++/common/suspensionmanager.cpp [code]
Programmatic file search/C++/common/suspensionmanager.h [code]
Proximity/C++/App.xaml.cpp [code]
Proximity/C++/App.xaml.h [code]
Proximity/C++/Constants.cpp [code]
Proximity/C++/Constants.h [code]
Proximity/C++/MainPage.xaml.cpp [code]
Proximity/C++/MainPage.xaml.h [code]
Proximity/C++/pch.cpp [code]
Proximity/C++/pch.h [code]
Proximity/C++/PeerFinderScenario.xaml.cpp [code]
Proximity/C++/PeerFinderScenario.xaml.h [code]
Proximity/C++/ProximityDeviceEvents.xaml.cpp [code]
Proximity/C++/ProximityDeviceEvents.xaml.h [code]
Proximity/C++/ProximityDeviceScenario.xaml.cpp [code]
Proximity/C++/ProximityDeviceScenario.xaml.h [code]
Proximity/C++/common/LayoutAwarePage.cpp [code]
Proximity/C++/common/LayoutAwarePage.h [code]
Proximity/C++/sample-utils/CppSamplesUtils.h [code]
Push and periodic notifications client-side/C++/App.xaml.cpp [code]
Push and periodic notifications client-side/C++/App.xaml.h [code]
Push and periodic notifications client-side/C++/Constants.cpp [code]
Push and periodic notifications client-side/C++/Constants.h [code]
Push and periodic notifications client-side/C++/MainPage.xaml.h [code]
Push and periodic notifications client-side/C++/pch.cpp [code]
Push and periodic notifications client-side/C++/pch.h [code]
Push and periodic notifications client-side/C++/Scenario1.xaml.h [code]
Push and periodic notifications client-side/C++/Scenario2.xaml.h [code]
Push and periodic notifications client-side/C++/Scenario3.xaml.h [code]
Push and periodic notifications client-side/C++/Scenario4.xaml.h [code]
Push and periodic notifications client-side/C++/Scenario5.xaml.h [code]
Raw notifications/C++/MainAppSample/App.xaml.cpp [code]
Raw notifications/C++/MainAppSample/App.xaml.h [code]
Raw notifications/C++/MainAppSample/CppSamplesUtils.h [code]
Raw notifications/C++/MainAppSample/MainPage.xaml.cpp [code]
Raw notifications/C++/MainAppSample/MainPage.xaml.h [code]
Raw notifications/C++/MainAppSample/pch.cpp [code]
Raw notifications/C++/MainAppSample/pch.h [code]
Raw notifications/C++/MainAppSample/ScenarioInput1.xaml.cpp [code]
Raw notifications/C++/MainAppSample/ScenarioInput1.xaml.h [code]
Raw notifications/C++/MainAppSample/ScenarioInput2.xaml.cpp [code]
Raw notifications/C++/MainAppSample/ScenarioInput2.xaml.h [code]
Raw notifications/C++/MainAppSample/ScenarioList.xaml.cpp [code]
Raw notifications/C++/MainAppSample/ScenarioList.xaml.h [code]
Raw notifications/C++/MainAppSample/ScenarioOutput1.xaml.cpp [code]
Raw notifications/C++/MainAppSample/ScenarioOutput1.xaml.h [code]
Raw notifications/C++/MainAppSample/ScenarioOutput2.xaml.cpp [code]
Raw notifications/C++/MainAppSample/ScenarioOutput2.xaml.h [code]
Raw notifications/C++/SampleBackgroundTask/BackgroundTask.cpp [code]
Raw notifications/C++/SampleBackgroundTask/BackgroundTask.h [code]
Raw notifications/C++/SampleBackgroundTask/pch.cpp [code]
Raw notifications/C++/SampleBackgroundTask/pch.h [code]
Reading and writing data/C++/App.xaml.cpp [code]
Reading and writing data/C++/App.xaml.h [code]
Reading and writing data/C++/Constants.cpp [code]
Reading and writing data/C++/Constants.h [code]
Reading and writing data/C++/MainPage.xaml.cpp [code]
Reading and writing data/C++/MainPage.xaml.h [code]
Reading and writing data/C++/pch.cpp [code]
Reading and writing data/C++/pch.h [code]
Reading and writing data/C++/ReadBytes.xaml.cpp [code]
Reading and writing data/C++/ReadBytes.xaml.h [code]
Reading and writing data/C++/WriteReadStream.xaml.cpp [code]
Reading and writing data/C++/WriteReadStream.xaml.h [code]
Reading and writing data/C++/common/LayoutAwarePage.cpp [code]
Reading and writing data/C++/common/LayoutAwarePage.h [code]
Reading and writing data/C++/common/suspensionmanager.cpp [code]
Reading and writing data/C++/common/suspensionmanager.h [code]
Real-time communication/C#,C++/App.xaml.cs [code]
Real-time communication/C#,C++/Constants.cs [code]
Real-time communication/C#,C++/LowLatency.xaml.cs [code]
Real-time communication/C#,C++/MainPage.xaml.cs [code]
Real-time communication/C#,C++/SuspensionManager.cs [code]
Real-time communication/C#,C++/VideoChat.xaml.cs [code]
Real-time communication/C#,C++/Common/CaptureDevice.cs [code]
Real-time communication/C#,C++/Common/LayoutAwarePage.cs [code]
Real-time communication/C#,C++/Properties/AssemblyInfo.cs [code]
Real-time communication/C#,C++/sample-utils/SuspensionManager.cs [code]
Real-time communication/C++/App.xaml.cpp [code]
Real-time communication/C++/App.xaml.h [code]
Real-time communication/C++/Constants.cpp [code]
Real-time communication/C++/Constants.h [code]
Real-time communication/C++/LowLatency.xaml.cpp [code]
Real-time communication/C++/LowLatency.xaml.h [code]
Real-time communication/C++/MainPage.xaml.cpp [code]
Real-time communication/C++/MainPage.xaml.h [code]
Real-time communication/C++/pch.cpp [code]
Real-time communication/C++/pch.h [code]
Real-time communication/C++/Utils.cpp [code]
Real-time communication/C++/Utils.h [code]
Real-time communication/C++/VideoChat.xaml.cpp [code]
Real-time communication/C++/VideoChat.xaml.h [code]
Real-time communication/C++/common/LayoutAwarePage.cpp [code]
Real-time communication/C++/common/LayoutAwarePage.h [code]
Real-time communication/C++/MediaExtensions/Common/AsyncCB.h [code]
Real-time communication/C++/MediaExtensions/Common/CritSec.h [code]
Real-time communication/C++/MediaExtensions/Common/LinkList.h [code]
Real-time communication/C++/MediaExtensions/Common/OpQueue.h [code]
Real-time communication/C++/sample-utils/CppSamplesUtils.h [code]
Removable storage/C++/App.xaml.cpp [code]
Removable storage/C++/App.xaml.h [code]
Removable storage/C++/Constants.cpp [code]
Removable storage/C++/Constants.h [code]
Removable storage/C++/MainPage.xaml.cpp [code]
Removable storage/C++/MainPage.xaml.h [code]
Removable storage/C++/pch.cpp [code]
Removable storage/C++/pch.h [code]
Removable storage/C++/S1_ListStorages.xaml.cpp [code]
Removable storage/C++/S1_ListStorages.xaml.h [code]
Removable storage/C++/S2_SendToStorage.xaml.cpp [code]
Removable storage/C++/S2_SendToStorage.xaml.h [code]
Removable storage/C++/S3_GetFromStorage.xaml.cpp [code]
Removable storage/C++/S3_GetFromStorage.xaml.h [code]
Removable storage/C++/S4_Autoplay.xaml.cpp [code]
Removable storage/C++/S4_Autoplay.xaml.h [code]
Removable storage/C++/common/LayoutAwarePage.cpp [code]
Removable storage/C++/common/LayoutAwarePage.h [code]
Removable storage/C++/common/SuspensionManager.cpp [code]
Removable storage/C++/common/SuspensionManager.h [code]
Scaling according to DPI/C++/App.xaml.cpp [code]
Scaling according to DPI/C++/App.xaml.h [code]
Scaling according to DPI/C++/Constants.cpp [code]
Scaling according to DPI/C++/Constants.h [code]
Scaling according to DPI/C++/MainPage.xaml.cpp [code]
Scaling according to DPI/C++/MainPage.xaml.h [code]
Scaling according to DPI/C++/pch.cpp [code]
Scaling according to DPI/C++/pch.h [code]
Scaling according to DPI/C++/Scenario1.xaml.cpp [code]
Scaling according to DPI/C++/Scenario1.xaml.h [code]
Scaling according to DPI/C++/Scenario2.xaml.cpp [code]
Scaling according to DPI/C++/Scenario2.xaml.h [code]
Scaling according to DPI/C++/common/LayoutAwarePage.cpp [code]
Scaling according to DPI/C++/common/LayoutAwarePage.h [code]
Scaling according to DPI/C++/common/suspensionmanager.cpp [code]
Scaling according to DPI/C++/common/suspensionmanager.h [code]
Scheduled notifications/C#,C++/App.xaml.cpp [code]
Scheduled notifications/C#,C++/App.xaml.h [code]
Scheduled notifications/C#,C++/CppSamplesUtils.h [code]
Scheduled notifications/C#,C++/MainPage.xaml.cpp [code]
Scheduled notifications/C#,C++/MainPage.xaml.h [code]
Scheduled notifications/C#,C++/NotificationData.cpp [code]
Scheduled notifications/C#,C++/NotificationData.h [code]
Scheduled notifications/C#,C++/pch.cpp [code]
Scheduled notifications/C#,C++/pch.h [code]
Scheduled notifications/C#,C++/ScenarioInput1.xaml.cpp [code]
Scheduled notifications/C#,C++/ScenarioInput1.xaml.h [code]
Scheduled notifications/C#,C++/ScenarioInput2.xaml.cpp [code]
Scheduled notifications/C#,C++/ScenarioInput2.xaml.h [code]
Scheduled notifications/C#,C++/ScenarioList.xaml.cpp [code]
Scheduled notifications/C#,C++/ScenarioList.xaml.h [code]
Scheduled notifications/C#,C++/ScenarioOutput1.xaml.cpp [code]
Scheduled notifications/C#,C++/ScenarioOutput1.xaml.h [code]
Scheduled notifications/C#,C++/ScenarioOutput2.xaml.cpp [code]
Scheduled notifications/C#,C++/ScenarioOutput2.xaml.h [code]
Search contract/C++/App.xaml.cpp [code]
Search contract/C++/App.xaml.h [code]
Search contract/C++/Constants.cpp [code]
Search contract/C++/Constants.h [code]
Search contract/C++/HttpRequest.cpp [code]
Search contract/C++/HttpRequest.h [code]
Search contract/C++/MainPage.xaml.cpp [code]
Search contract/C++/MainPage.xaml.h [code]
Search contract/C++/pch.cpp [code]
Search contract/C++/pch.h [code]
Search contract/C++/Scenario1.xaml.cpp [code]
Search contract/C++/Scenario1.xaml.h [code]
Search contract/C++/Scenario2.xaml.cpp [code]
Search contract/C++/Scenario2.xaml.h [code]
Search contract/C++/Scenario3.xaml.cpp [code]
Search contract/C++/Scenario3.xaml.h [code]
Search contract/C++/Scenario4.xaml.cpp [code]
Search contract/C++/Scenario4.xaml.h [code]
Search contract/C++/Scenario5.xaml.cpp [code]
Search contract/C++/Scenario5.xaml.h [code]
Search contract/C++/Scenario6.xaml.cpp [code]
Search contract/C++/Scenario6.xaml.h [code]
Search contract/C++/Scenario7.xaml.cpp [code]
Search contract/C++/Scenario7.xaml.h [code]
Search contract/C++/common/LayoutAwarePage.cpp [code]
Search contract/C++/common/LayoutAwarePage.h [code]
Search contract/C++/common/suspensionmanager.cpp [code]
Search contract/C++/common/suspensionmanager.h [code]
Secondary tiles/C#,C++/App.xaml.cpp [code]
Secondary tiles/C#,C++/App.xaml.h [code]
Secondary tiles/C#,C++/Constants.cpp [code]
Secondary tiles/C#,C++/Constants.h [code]
Secondary tiles/C#,C++/EnumerateTiles.xaml.cpp [code]
Secondary tiles/C#,C++/EnumerateTiles.xaml.h [code]
Secondary tiles/C#,C++/LaunchedFromSecondaryTile.xaml.cpp [code]
Secondary tiles/C#,C++/LaunchedFromSecondaryTile.xaml.h [code]
Secondary tiles/C#,C++/MainPage.xaml.cpp [code]
Secondary tiles/C#,C++/MainPage.xaml.h [code]
Secondary tiles/C#,C++/pch.cpp [code]
Secondary tiles/C#,C++/pch.h [code]
Secondary tiles/C#,C++/PinFromAppbar.xaml.cpp [code]
Secondary tiles/C#,C++/PinFromAppbar.xaml.h [code]
Secondary tiles/C#,C++/PinTile.xaml.cpp [code]
Secondary tiles/C#,C++/PinTile.xaml.h [code]
Secondary tiles/C#,C++/SecondaryTileNotification.xaml.cpp [code]
Secondary tiles/C#,C++/SecondaryTileNotification.xaml.h [code]
Secondary tiles/C#,C++/TilePinned.xaml.cpp [code]
Secondary tiles/C#,C++/TilePinned.xaml.h [code]
Secondary tiles/C#,C++/UnpinTile.xaml.cpp [code]
Secondary tiles/C#,C++/UnpinTile.xaml.h [code]
Secondary tiles/C#,C++/UpdateAsync.xaml.cpp [code]
Secondary tiles/C#,C++/UpdateAsync.xaml.h [code]
Secondary tiles/C#,C++/common/LayoutAwarePage.cpp [code]
Secondary tiles/C#,C++/common/LayoutAwarePage.h [code]
Secondary tiles/C#,C++/NotificationsExtensions/BadgeContent.cs [code]
Secondary tiles/C#,C++/NotificationsExtensions/Common.cs [code]
Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs [code]
Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs [code]
Secondary tiles/C#,C++/Sample-Utils/cppsamplesutils.h [code]
Sharing content source app/C++/App.xaml.cpp [code]
Sharing content source app/C++/App.xaml.h [code]
Sharing content source app/C++/Constants.cpp [code]
Sharing content source app/C++/Constants.h [code]
Sharing content source app/C++/MainPage.xaml.cpp [code]
Sharing content source app/C++/MainPage.xaml.h [code]
Sharing content source app/C++/pch.cpp [code]
Sharing content source app/C++/pch.h [code]
Sharing content source app/C++/SetErrorMessage.xaml.cpp [code]
Sharing content source app/C++/SetErrorMessage.xaml.h [code]
Sharing content source app/C++/ShareCustomData.xaml.cpp [code]
Sharing content source app/C++/ShareCustomData.xaml.h [code]
Sharing content source app/C++/ShareDelayRenderedFiles.xaml.cpp [code]
Sharing content source app/C++/ShareDelayRenderedFiles.xaml.h [code]
Sharing content source app/C++/ShareFiles.xaml.cpp [code]
Sharing content source app/C++/ShareFiles.xaml.h [code]
Sharing content source app/C++/ShareHtml.xaml.cpp [code]
Sharing content source app/C++/ShareHtml.xaml.h [code]
Sharing content source app/C++/ShareImage.xaml.cpp [code]
Sharing content source app/C++/ShareImage.xaml.h [code]
Sharing content source app/C++/ShareLink.xaml.cpp [code]
Sharing content source app/C++/ShareLink.xaml.h [code]
Sharing content source app/C++/SharePage.cpp [code]
Sharing content source app/C++/SharePage.h [code]
Sharing content source app/C++/ShareText.xaml.cpp [code]
Sharing content source app/C++/ShareText.xaml.h [code]
Sharing content source app/C++/common/LayoutAwarePage.cpp [code]
Sharing content source app/C++/common/LayoutAwarePage.h [code]
Sharing content source app/C++/common/suspensionmanager.cpp [code]
Sharing content source app/C++/common/suspensionmanager.h [code]
Sharing content target app/C++/App.xaml.cpp [code]
Sharing content target app/C++/App.xaml.h [code]
Sharing content target app/C++/DefaultPage.xaml.cpp [code]
Sharing content target app/C++/DefaultPage.xaml.h [code]
Sharing content target app/C++/MainPage.xaml.cpp [code]
Sharing content target app/C++/MainPage.xaml.h [code]
Sharing content target app/C++/pch.cpp [code]
Sharing content target app/C++/pch.h [code]
Sharing content target app/C++/common/LayoutAwarePage.cpp [code]
Sharing content target app/C++/common/LayoutAwarePage.h [code]
Sharing content target app/C++/sample-utils/CppSamplesUtils.h [code]
SimpleOrientationSensor/C++/App.xaml.cpp [code]
SimpleOrientationSensor/C++/App.xaml.h [code]
SimpleOrientationSensor/C++/Constants.cpp [code]
SimpleOrientationSensor/C++/Constants.h [code]
SimpleOrientationSensor/C++/MainPage.xaml.cpp [code]
SimpleOrientationSensor/C++/MainPage.xaml.h [code]
SimpleOrientationSensor/C++/pch.cpp [code]
SimpleOrientationSensor/C++/pch.h [code]
SimpleOrientationSensor/C++/Scenario1.xaml.cpp [code]
SimpleOrientationSensor/C++/Scenario1.xaml.h [code]
SimpleOrientationSensor/C++/Scenario2.xaml.cpp [code]
SimpleOrientationSensor/C++/Scenario2.xaml.h [code]
SimpleOrientationSensor/C++/common/LayoutAwarePage.cpp [code]
SimpleOrientationSensor/C++/common/LayoutAwarePage.h [code]
SimpleOrientationSensor/C++/common/suspensionmanager.cpp [code]
SimpleOrientationSensor/C++/common/suspensionmanager.h [code]
SMS background task/C++/SmsBackgroundTask/pch.cpp [code]
SMS background task/C++/SmsBackgroundTask/pch.h [code]
SMS background task/C++/SmsBackgroundTaskSample/App.xaml.cpp [code]
SMS background task/C++/SmsBackgroundTaskSample/App.xaml.h [code]
SMS background task/C++/SmsBackgroundTaskSample/Constants.cpp [code]
SMS background task/C++/SmsBackgroundTaskSample/Constants.h [code]
SMS background task/C++/SmsBackgroundTaskSample/MainPage.xaml.h [code]
SMS background task/C++/SmsBackgroundTaskSample/pch.cpp [code]
SMS background task/C++/SmsBackgroundTaskSample/pch.h [code]
SMS message send, receive, and SIM management/C++/App.xaml.cpp [code]
SMS message send, receive, and SIM management/C++/App.xaml.h [code]
SMS message send, receive, and SIM management/C++/Constants.cpp [code]
SMS message send, receive, and SIM management/C++/Constants.h [code]
SMS message send, receive, and SIM management/C++/pch.cpp [code]
SMS message send, receive, and SIM management/C++/pch.h [code]
Snap/C++/App.xaml.cpp [code]
Snap/C++/App.xaml.h [code]
Snap/C++/Constants.cpp [code]
Snap/C++/Constants.h [code]
Snap/C++/MainPage.xaml.cpp [code]
Snap/C++/MainPage.xaml.h [code]
Snap/C++/pch.cpp [code]
Snap/C++/pch.h [code]
Snap/C++/Scenario1.xaml.cpp [code]
Snap/C++/Scenario1.xaml.h [code]
Snap/C++/common/LayoutAwarePage.cpp [code]
Snap/C++/common/LayoutAwarePage.h [code]
Snap/C++/common/suspensionmanager.cpp [code]
Snap/C++/common/suspensionmanager.h [code]
Splash screen/C++/App.xaml.cpp [code]
Splash screen/C++/App.xaml.h [code]
Splash screen/C++/Constants.cpp [code]
Splash screen/C++/Constants.h [code]
Splash screen/C++/ExtendedSplash.xaml.cpp [code]
Splash screen/C++/ExtendedSplash.xaml.h [code]
Splash screen/C++/MainPage.xaml.cpp [code]
Splash screen/C++/MainPage.xaml.h [code]
Splash screen/C++/pch.cpp [code]
Splash screen/C++/pch.h [code]
Splash screen/C++/Scenario1.xaml.cpp [code]
Splash screen/C++/Scenario1.xaml.h [code]
Splash screen/C++/Scenario2.xaml.cpp [code]
Splash screen/C++/Scenario2.xaml.h [code]
Splash screen/C++/common/LayoutAwarePage.cpp [code]
Splash screen/C++/common/LayoutAwarePage.h [code]
Splash screen/C++/common/suspensionmanager.cpp [code]
Splash screen/C++/common/suspensionmanager.h [code]
StorageDataSource and GetVirtualizedFilesVector/C++/App.xaml.cpp [code]
StorageDataSource and GetVirtualizedFilesVector/C++/App.xaml.h [code]
StorageDataSource and GetVirtualizedFilesVector/C++/Constants.h [code]
StorageDataSource and GetVirtualizedFilesVector/C++/pch.cpp [code]
StorageDataSource and GetVirtualizedFilesVector/C++/pch.h [code]
StreamSocket/C++/App.xaml.cpp [code]
StreamSocket/C++/App.xaml.h [code]
StreamSocket/C++/Constants.cpp [code]
StreamSocket/C++/Constants.h [code]
StreamSocket/C++/MainPage.xaml.cpp [code]
StreamSocket/C++/MainPage.xaml.h [code]
StreamSocket/C++/pch.cpp [code]
StreamSocket/C++/pch.h [code]
StreamSocket/C++/Scenario1.xaml.cpp [code]
StreamSocket/C++/Scenario1.xaml.h [code]
StreamSocket/C++/Scenario2.xaml.cpp [code]
StreamSocket/C++/Scenario2.xaml.h [code]
StreamSocket/C++/Scenario3.xaml.cpp [code]
StreamSocket/C++/Scenario3.xaml.h [code]
StreamSocket/C++/Scenario4.xaml.cpp [code]
StreamSocket/C++/Scenario4.xaml.h [code]
StreamSocket/C++/Common/LayoutAwarePage.cpp [code]
StreamSocket/C++/Common/LayoutAwarePage.h [code]
StreamSocket/C++/sample-utils/CppSamplesUtils.h [code]
Syndication/C++/App.xaml.cpp [code]
Syndication/C++/App.xaml.h [code]
Syndication/C++/Constants.cpp [code]
Syndication/C++/Constants.h [code]
Syndication/C++/MainPage.xaml.cpp [code]
Syndication/C++/MainPage.xaml.h [code]
Syndication/C++/pch.cpp [code]
Syndication/C++/pch.h [code]
Syndication/C++/Scenario1.xaml.cpp [code]
Syndication/C++/Scenario1.xaml.h [code]
Syndication/C++/common/LayoutAwarePage.cpp [code]
Syndication/C++/common/LayoutAwarePage.h [code]
Syndication/C++/common/suspensionmanager.cpp [code]
Syndication/C++/common/suspensionmanager.h [code]
Thread pool/C++/App.xaml.cpp [code]
Thread pool/C++/App.xaml.h [code]
Thread pool/C++/Constants.cpp [code]
Thread pool/C++/Constants.h [code]
Thread pool/C++/DelayTimerScenario.xaml.cpp [code]
Thread pool/C++/DelayTimerScenario.xaml.h [code]
Thread pool/C++/MainPage.xaml.cpp [code]
Thread pool/C++/MainPage.xaml.h [code]
Thread pool/C++/pch.cpp [code]
Thread pool/C++/pch.h [code]
Thread pool/C++/PeriodicTimerScenario.xaml.cpp [code]
Thread pool/C++/PeriodicTimerScenario.xaml.h [code]
Thread pool/C++/WorkItemScenario.xaml.cpp [code]
Thread pool/C++/WorkItemScenario.xaml.h [code]
Thread pool/C++/common/LayoutAwarePage.cpp [code]
Thread pool/C++/common/LayoutAwarePage.h [code]
Thread pool/C++/common/suspensionmanager.cpp [code]
Thread pool/C++/common/suspensionmanager.h [code]
Toast notifications/C#,C++/App.xaml.cpp [code]
Toast notifications/C#,C++/App.xaml.h [code]
Toast notifications/C#,C++/CppSamplesUtils.h [code]
Toast notifications/C#,C++/MainPage.xaml.cpp [code]
Toast notifications/C#,C++/MainPage.xaml.h [code]
Toast notifications/C#,C++/pch.cpp [code]
Toast notifications/C#,C++/pch.h [code]
Toast notifications/C#,C++/ScenarioInput1.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioInput1.xaml.h [code]
Toast notifications/C#,C++/ScenarioInput2.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioInput2.xaml.h [code]
Toast notifications/C#,C++/ScenarioInput3.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioInput3.xaml.h [code]
Toast notifications/C#,C++/ScenarioInput4.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioInput4.xaml.h [code]
Toast notifications/C#,C++/ScenarioInput5.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioInput5.xaml.h [code]
Toast notifications/C#,C++/ScenarioInput6.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioInput6.xaml.h [code]
Toast notifications/C#,C++/ScenarioList.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioList.xaml.h [code]
Toast notifications/C#,C++/ScenarioOutput1.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioOutput1.xaml.h [code]
Toast notifications/C#,C++/ScenarioOutput2.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioOutput2.xaml.h [code]
Toast notifications/C#,C++/ScenarioOutput3.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioOutput3.xaml.h [code]
Toast notifications/C#,C++/ScenarioOutput4.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioOutput4.xaml.h [code]
Toast notifications/C#,C++/ScenarioOutput5.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioOutput5.xaml.h [code]
Toast notifications/C#,C++/ScenarioOutput6.xaml.cpp [code]
Toast notifications/C#,C++/ScenarioOutput6.xaml.h [code]
Toast notifications/C#,C++/NotificationsExtensions/Common.cs [code]
Transcoding media/C++/App.xaml.cpp [code]
Transcoding media/C++/App.xaml.h [code]
Transcoding media/C++/Constants.cpp [code]
Transcoding media/C++/Constants.h [code]
Transcoding media/C++/Custom.xaml.cpp [code]
Transcoding media/C++/Custom.xaml.h [code]
Transcoding media/C++/MainPage.xaml.cpp [code]
Transcoding media/C++/MainPage.xaml.h [code]
Transcoding media/C++/pch.cpp [code]
Transcoding media/C++/pch.h [code]
Transcoding media/C++/Presets.xaml.cpp [code]
Transcoding media/C++/Presets.xaml.h [code]
Transcoding media/C++/Trim.xaml.cpp [code]
Transcoding media/C++/Trim.xaml.h [code]
Transcoding media/C++/common/LayoutAwarePage.cpp [code]
Transcoding media/C++/common/LayoutAwarePage.h [code]
Transcoding media/C++/common/suspensionmanager.cpp [code]
Transcoding media/C++/common/suspensionmanager.h [code]
Trial app and in-app purchase/C++/App.xaml.cpp [code]
Trial app and in-app purchase/C++/App.xaml.h [code]
Trial app and in-app purchase/C++/AppListingUri.xaml.cpp [code]
Trial app and in-app purchase/C++/AppListingUri.xaml.h [code]
Trial app and in-app purchase/C++/Constants.cpp [code]
Trial app and in-app purchase/C++/Constants.h [code]
Trial app and in-app purchase/C++/ExpiringProduct.xaml.cpp [code]
Trial app and in-app purchase/C++/ExpiringProduct.xaml.h [code]
Trial app and in-app purchase/C++/InAppPurchase.xaml.cpp [code]
Trial app and in-app purchase/C++/InAppPurchase.xaml.h [code]
Trial app and in-app purchase/C++/MainPage.xaml.cpp [code]
Trial app and in-app purchase/C++/MainPage.xaml.h [code]
Trial app and in-app purchase/C++/pch.cpp [code]
Trial app and in-app purchase/C++/pch.h [code]
Trial app and in-app purchase/C++/Receipt.xaml.cpp [code]
Trial app and in-app purchase/C++/Receipt.xaml.h [code]
Trial app and in-app purchase/C++/TrialMode.xaml.cpp [code]
Trial app and in-app purchase/C++/TrialMode.xaml.h [code]
Trial app and in-app purchase/C++/common/LayoutAwarePage.cpp [code]
Trial app and in-app purchase/C++/common/LayoutAwarePage.h [code]
Trial app and in-app purchase/C++/common/suspensionmanager.cpp [code]
Trial app and in-app purchase/C++/common/suspensionmanager.h [code]
UI Automation core window provider/C++/AppWindowProvider.cpp [code]
UI Automation core window provider/C++/DirectXBase.cpp [code]
UI Automation core window provider/C++/DirectXBase.h [code]
UI Automation core window provider/C++/DirectXSample.h [code]
UI Automation core window provider/C++/InternalInterfaces.idl [code]
UI Automation core window provider/C++/pch.cpp [code]
UI Automation core window provider/C++/pch.h [code]
UI Automation core window provider/C++/TriColorValue.h [code]
UI Automation core window provider/C++/TriColorWindow.cpp [code]
UI Automation core window provider/C++/TriColorWindow.h [code]
UI contrast and settings/C++/Accessibility.xaml.cpp [code]
UI contrast and settings/C++/Accessibility.xaml.h [code]
UI contrast and settings/C++/App.xaml.cpp [code]
UI contrast and settings/C++/App.xaml.h [code]
UI contrast and settings/C++/Constants.cpp [code]
UI contrast and settings/C++/Constants.h [code]
UI contrast and settings/C++/cppsamplesutils.h [code]
UI contrast and settings/C++/MainPage.xaml.cpp [code]
UI contrast and settings/C++/MainPage.xaml.h [code]
UI contrast and settings/C++/pch.cpp [code]
UI contrast and settings/C++/pch.h [code]
UI contrast and settings/C++/UI.xaml.cpp [code]
UI contrast and settings/C++/UI.xaml.h [code]
UI contrast and settings/C++/common/LayoutAwarePage.cpp [code]
UI contrast and settings/C++/common/LayoutAwarePage.h [code]
UI contrast and settings/C++/common/suspensionmanager.cpp [code]
UI contrast and settings/C++/common/suspensionmanager.h [code]
User domain name/C++/App.xaml.cpp [code]
User domain name/C++/App.xaml.h [code]
User domain name/C++/Constants.cpp [code]
User domain name/C++/Constants.h [code]
User domain name/C++/GetDomainName.xaml.cpp [code]
User domain name/C++/GetDomainName.xaml.h [code]
User domain name/C++/GetPrincipalName.xaml.cpp [code]
User domain name/C++/GetPrincipalName.xaml.h [code]
User domain name/C++/GetSIPUri.xaml.cpp [code]
User domain name/C++/GetSIPUri.xaml.h [code]
User domain name/C++/MainPage.xaml.cpp [code]
User domain name/C++/MainPage.xaml.h [code]
User domain name/C++/pch.cpp [code]
User domain name/C++/pch.h [code]
User domain name/C++/common/LayoutAwarePage.cpp [code]
User domain name/C++/common/LayoutAwarePage.h [code]
User domain name/C++/common/suspensionmanager.cpp [code]
User domain name/C++/common/suspensionmanager.h [code]
USSD message management/C++/App.xaml.cpp [code]
USSD message management/C++/App.xaml.h [code]
USSD message management/C++/Constants.cpp [code]
USSD message management/C++/Constants.h [code]
USSD message management/C++/MainPage.xaml.cpp [code]
USSD message management/C++/MainPage.xaml.h [code]
USSD message management/C++/pch.cpp [code]
USSD message management/C++/pch.h [code]
USSD message management/C++/RequestResponse.xaml.cpp [code]
USSD message management/C++/RequestResponse.xaml.h [code]
USSD message management/C++/common/LayoutAwarePage.cpp [code]
USSD message management/C++/common/LayoutAwarePage.h [code]
USSD message management/C++/common/suspensionmanager.cpp [code]
USSD message management/C++/common/suspensionmanager.h [code]
Web authentication broker/C++/App.xaml.cpp [code]
Web authentication broker/C++/App.xaml.h [code]
Web authentication broker/C++/Constants.cpp [code]
Web authentication broker/C++/Constants.h [code]
Web authentication broker/C++/MainPage.xaml.cpp [code]
Web authentication broker/C++/MainPage.xaml.h [code]
Web authentication broker/C++/pch.cpp [code]
Web authentication broker/C++/pch.h [code]
Web authentication broker/C++/Scenario1.xaml.cpp [code]
Web authentication broker/C++/Scenario1.xaml.h [code]
Web authentication broker/C++/Scenario2.xaml.cpp [code]
Web authentication broker/C++/Scenario2.xaml.h [code]
Web authentication broker/C++/common/LayoutAwarePage.cpp [code]
Web authentication broker/C++/common/LayoutAwarePage.h [code]
Web authentication broker/C++/common/suspensionmanager.cpp [code]
Web authentication broker/C++/common/suspensionmanager.h [code]
Windows account authorization/C++/App.xaml.cpp [code]
Windows account authorization/C++/App.xaml.h [code]
Windows account authorization/C++/Constants.cpp [code]
Windows account authorization/C++/Constants.h [code]
Windows account authorization/C++/DelegationTickets.xaml.cpp [code]
Windows account authorization/C++/DelegationTickets.xaml.h [code]
Windows account authorization/C++/HttpRequest.cpp [code]
Windows account authorization/C++/HttpRequest.h [code]
Windows account authorization/C++/MainPage.xaml.cpp [code]
Windows account authorization/C++/MainPage.xaml.h [code]
Windows account authorization/C++/pch.cpp [code]
Windows account authorization/C++/pch.h [code]
Windows account authorization/C++/common/LayoutAwarePage.cpp [code]
Windows account authorization/C++/common/LayoutAwarePage.h [code]
Windows account authorization/C++/common/suspensionmanager.cpp [code]
Windows account authorization/C++/common/suspensionmanager.h [code]
Windows Audio Session (WASAPI)/C++/App.xaml.cpp [code]
Windows Audio Session (WASAPI)/C++/App.xaml.h [code]
Windows Audio Session (WASAPI)/C++/Common.h [code]
Windows Audio Session (WASAPI)/C++/Constants.cpp [code]
Windows Audio Session (WASAPI)/C++/Constants.h [code]
Windows Audio Session (WASAPI)/C++/DeviceState.h [code]
Windows Audio Session (WASAPI)/C++/MainPage.xaml.cpp [code]
Windows Audio Session (WASAPI)/C++/MainPage.xaml.h [code]
Windows Audio Session (WASAPI)/C++/MFSampleGenerator.cpp [code]
Windows Audio Session (WASAPI)/C++/MFSampleGenerator.h [code]
Windows Audio Session (WASAPI)/C++/pch.cpp [code]
Windows Audio Session (WASAPI)/C++/pch.h [code]
Windows Audio Session (WASAPI)/C++/PlotData.h [code]
Windows Audio Session (WASAPI)/C++/Scenario1.xaml.cpp [code]
Windows Audio Session (WASAPI)/C++/Scenario1.xaml.h [code]
Windows Audio Session (WASAPI)/C++/Scenario2.xaml.cpp [code]
Windows Audio Session (WASAPI)/C++/Scenario2.xaml.h [code]
Windows Audio Session (WASAPI)/C++/Scenario3.xaml.cpp [code]
Windows Audio Session (WASAPI)/C++/Scenario3.xaml.h [code]
Windows Audio Session (WASAPI)/C++/ToneSampleGenerator.cpp [code]
Windows Audio Session (WASAPI)/C++/ToneSampleGenerator.h [code]
Windows Audio Session (WASAPI)/C++/WASAPICapture.cpp [code]
Windows Audio Session (WASAPI)/C++/WASAPICapture.h [code]
Windows Audio Session (WASAPI)/C++/WASAPIRenderer.cpp [code]
Windows Audio Session (WASAPI)/C++/WASAPIRenderer.h [code]
Windows Audio Session (WASAPI)/C++/common/LayoutAwarePage.cpp [code]
Windows Audio Session (WASAPI)/C++/common/LayoutAwarePage.h [code]
Windows Audio Session (WASAPI)/C++/common/suspensionmanager.cpp [code]
Windows Audio Session (WASAPI)/C++/common/suspensionmanager.h [code]
Windows Store device app for camera/C#,C++/App.xaml.cs [code]
Windows Store device app for camera/C#,C++/Constants.cs [code]
Windows Store device app for camera/C#,C++/DeviceAppPage.xaml.cs [code]
Windows Store device app for camera/C#,C++/MainPage.xaml.cs [code]
Windows Store device app for camera/C#,C++/Wrapper/pch.cpp [code]
Windows Store device app for camera/C#,C++/Wrapper/pch.h [code]
Windows Store device app for camera/C#,C++/Wrapper/SampleMft0.h [code]
Windows Store device app for camera/C++/App.xaml.cpp [code]
Windows Store device app for camera/C++/App.xaml.h [code]
Windows Store device app for camera/C++/Constants.cpp [code]
Windows Store device app for camera/C++/Constants.h [code]
Windows Store device app for camera/C++/DeviceAppPage.xaml.cpp [code]
Windows Store device app for camera/C++/DeviceAppPage.xaml.h [code]
Windows Store device app for camera/C++/MainPage.xaml.cpp [code]
Windows Store device app for camera/C++/MainPage.xaml.h [code]
Windows Store device app for camera/C++/pch.cpp [code]
Windows Store device app for camera/C++/pch.h [code]
Windows Store device app for camera/C++/Common/LayoutAwarePage.h [code]
Windows Store device app for camera/C++/Wrapper/pch.cpp [code]
Windows Store device app for camera/C++/Wrapper/pch.h [code]
Windows Store device app for camera/C++/Wrapper/SampleMft0.h [code]
Windows Store device app for camera/C++/Wrapper/WinRTComponent.h [code]
XAML accessibility/C++/App.xaml.cpp [code]
XAML accessibility/C++/App.xaml.h [code]
XAML accessibility/C++/Constants.cpp [code]
XAML accessibility/C++/Constants.h [code]
XAML accessibility/C++/MainPage.xaml.cpp [code]
XAML accessibility/C++/MainPage.xaml.h [code]
XAML accessibility/C++/pch.cpp [code]
XAML accessibility/C++/pch.h [code]
XAML accessibility/C++/Scenario1.xaml.cpp [code]
XAML accessibility/C++/Scenario1.xaml.h [code]
XAML accessibility/C++/Scenario2.xaml.cpp [code]
XAML accessibility/C++/Scenario2.xaml.h [code]
XAML accessibility/C++/Scenario3.xaml.cpp [code]
XAML accessibility/C++/Scenario3.xaml.h [code]
XAML accessibility/C++/Scenario4.xaml.cpp [code]
XAML accessibility/C++/Scenario4.xaml.h [code]
XAML accessibility/C++/common/LayoutAwarePage.cpp [code]
XAML accessibility/C++/common/LayoutAwarePage.h [code]
XAML accessibility/C++/common/suspensionmanager.cpp [code]
XAML accessibility/C++/common/suspensionmanager.h [code]
XAML animation library/C++/App.xaml.cpp [code]
XAML animation library/C++/App.xaml.h [code]
XAML animation library/C++/Constants.cpp [code]
XAML animation library/C++/Constants.h [code]
XAML animation library/C++/MainPage.xaml.cpp [code]
XAML animation library/C++/MainPage.xaml.h [code]
XAML animation library/C++/pch.cpp [code]
XAML animation library/C++/pch.h [code]
XAML animation library/C++/Scenario1.xaml.cpp [code]
XAML animation library/C++/Scenario1.xaml.h [code]
XAML animation library/C++/Scenario2.xaml.cpp [code]
XAML animation library/C++/Scenario2.xaml.h [code]
XAML animation library/C++/Scenario3.xaml.cpp [code]
XAML animation library/C++/Scenario3.xaml.h [code]
XAML animation library/C++/common/LayoutAwarePage.cpp [code]
XAML animation library/C++/common/LayoutAwarePage.h [code]
XAML animation library/C++/common/suspensionmanager.cpp [code]
XAML animation library/C++/common/suspensionmanager.h [code]
XAML AppBar control/C++/App.xaml.cpp [code]
XAML AppBar control/C++/App.xaml.h [code]
XAML AppBar control/C++/Constants.cpp [code]
XAML AppBar control/C++/Constants.h [code]
XAML AppBar control/C++/GlobalPage.xaml.cpp [code]
XAML AppBar control/C++/GlobalPage.xaml.h [code]
XAML AppBar control/C++/MainPage.xaml.cpp [code]
XAML AppBar control/C++/MainPage.xaml.h [code]
XAML AppBar control/C++/Page1.xaml.cpp [code]
XAML AppBar control/C++/Page1.xaml.h [code]
XAML AppBar control/C++/Page2.xaml.cpp [code]
XAML AppBar control/C++/Page2.xaml.h [code]
XAML AppBar control/C++/Page3.xaml.cpp [code]
XAML AppBar control/C++/Page3.xaml.h [code]
XAML AppBar control/C++/pch.cpp [code]
XAML AppBar control/C++/pch.h [code]
XAML AppBar control/C++/Scenario1.xaml.cpp [code]
XAML AppBar control/C++/Scenario1.xaml.h [code]
XAML AppBar control/C++/Scenario2.xaml.cpp [code]
XAML AppBar control/C++/Scenario2.xaml.h [code]
XAML AppBar control/C++/Scenario3.xaml.cpp [code]
XAML AppBar control/C++/Scenario3.xaml.h [code]
XAML AppBar control/C++/Scenario4.xaml.cpp [code]
XAML AppBar control/C++/Scenario4.xaml.h [code]
XAML AppBar control/C++/common/LayoutAwarePage.cpp [code]
XAML AppBar control/C++/common/LayoutAwarePage.h [code]
XAML AppBar control/C++/Sample-Utils/CppSamplesUtils.h [code]
XAML data binding/C++/App.xaml.cpp [code]
XAML data binding/C++/App.xaml.h [code]
XAML data binding/C++/Constants.cpp [code]
XAML data binding/C++/Constants.h [code]
XAML data binding/C++/Employee.h [code]
XAML data binding/C++/GeneratorIncrementalLoadingClass.h [code]
XAML data binding/C++/IncrementalLoadingBase.h [code]
XAML data binding/C++/MainPage.xaml.cpp [code]
XAML data binding/C++/MainPage.xaml.h [code]
XAML data binding/C++/pch.cpp [code]
XAML data binding/C++/pch.h [code]
XAML data binding/C++/S2Formatter.cpp [code]
XAML data binding/C++/S2Formatter.h [code]
XAML data binding/C++/Scenario1.xaml.cpp [code]
XAML data binding/C++/Scenario1.xaml.h [code]
XAML data binding/C++/Scenario2.xaml.cpp [code]
XAML data binding/C++/Scenario2.xaml.h [code]
XAML data binding/C++/Scenario3.xaml.cpp [code]
XAML data binding/C++/Scenario3.xaml.h [code]
XAML data binding/C++/Scenario4.xaml.cpp [code]
XAML data binding/C++/Scenario4.xaml.h [code]
XAML data binding/C++/Scenario5.xaml.cpp [code]
XAML data binding/C++/Scenario5.xaml.h [code]
XAML data binding/C++/Scenario6.xaml.cpp [code]
XAML data binding/C++/Scenario6.xaml.h [code]
XAML data binding/C++/Scenario7.xaml.cpp [code]
XAML data binding/C++/Scenario7.xaml.h [code]
XAML data binding/C++/Scenario8.xaml.cpp [code]
XAML data binding/C++/Scenario8.xaml.h [code]
XAML data binding/C++/Team.cpp [code]
XAML data binding/C++/Team.h [code]
XAML data binding/C++/Common/LayoutAwarePage.cpp [code]
XAML data binding/C++/Common/LayoutAwarePage.h [code]
XAML data binding/C++/Common/suspensionmanager.cpp [code]
XAML data binding/C++/Common/suspensionmanager.h [code]
XAML Direct2D lighting effects/C++/App.xaml.cpp [code]
XAML Direct2D lighting effects/C++/App.xaml.h [code]
XAML Direct2D lighting effects/C++/D2DLightingEffectsRenderer.h [code]
XAML Direct2D lighting effects/C++/DirectXBase.cpp [code]
XAML Direct2D lighting effects/C++/DirectXBase.h [code]
XAML Direct2D lighting effects/C++/DirectXSample.h [code]
XAML Direct2D lighting effects/C++/MainPage.xaml.cpp [code]
XAML Direct2D lighting effects/C++/MainPage.xaml.h [code]
XAML Direct2D lighting effects/C++/pch.cpp [code]
XAML Direct2D lighting effects/C++/pch.h [code]
XAML DirectX 3D shooting game/C++/Animate.cpp [code]
XAML DirectX 3D shooting game/C++/Animate.h [code]
XAML DirectX 3D shooting game/C++/App.xaml.cpp [code]
XAML DirectX 3D shooting game/C++/App.xaml.h [code]
XAML DirectX 3D shooting game/C++/Audio.cpp [code]
XAML DirectX 3D shooting game/C++/Audio.h [code]
XAML DirectX 3D shooting game/C++/BasicLoader.cpp [code]
XAML DirectX 3D shooting game/C++/BasicLoader.h [code]
XAML DirectX 3D shooting game/C++/BasicMath.h [code]
XAML DirectX 3D shooting game/C++/BasicReaderWriter.cpp [code]
XAML DirectX 3D shooting game/C++/BasicReaderWriter.h [code]
XAML DirectX 3D shooting game/C++/BasicShapes.h [code]
XAML DirectX 3D shooting game/C++/Camera.cpp [code]
XAML DirectX 3D shooting game/C++/Camera.h [code]
XAML DirectX 3D shooting game/C++/ConstantBuffers.h [code]
XAML DirectX 3D shooting game/C++/Cylinder.cpp [code]
XAML DirectX 3D shooting game/C++/Cylinder.h [code]
XAML DirectX 3D shooting game/C++/CylinderMesh.cpp [code]
XAML DirectX 3D shooting game/C++/CylinderMesh.h [code]
XAML DirectX 3D shooting game/C++/DDSTextureLoader.cpp [code]
XAML DirectX 3D shooting game/C++/DDSTextureLoader.h [code]
XAML DirectX 3D shooting game/C++/DirectXBase.cpp [code]
XAML DirectX 3D shooting game/C++/DirectXBase.h [code]
XAML DirectX 3D shooting game/C++/DirectXSample.h [code]
XAML DirectX 3D shooting game/C++/Face.cpp [code]
XAML DirectX 3D shooting game/C++/Face.h [code]
XAML DirectX 3D shooting game/C++/FaceMesh.cpp [code]
XAML DirectX 3D shooting game/C++/FaceMesh.h [code]
XAML DirectX 3D shooting game/C++/GameConstants.h [code]
XAML DirectX 3D shooting game/C++/GameHud.cpp [code]
XAML DirectX 3D shooting game/C++/GameHud.h [code]
XAML DirectX 3D shooting game/C++/GameObject.cpp [code]
XAML DirectX 3D shooting game/C++/GameObject.h [code]
XAML DirectX 3D shooting game/C++/GameRenderer.cpp [code]
XAML DirectX 3D shooting game/C++/GameRenderer.h [code]
XAML DirectX 3D shooting game/C++/GameTimer.cpp [code]
XAML DirectX 3D shooting game/C++/GameTimer.h [code]
XAML DirectX 3D shooting game/C++/Level.cpp [code]
XAML DirectX 3D shooting game/C++/Level.h [code]
XAML DirectX 3D shooting game/C++/Level1.cpp [code]
XAML DirectX 3D shooting game/C++/Level1.h [code]
XAML DirectX 3D shooting game/C++/Level2.cpp [code]
XAML DirectX 3D shooting game/C++/Level2.h [code]
XAML DirectX 3D shooting game/C++/Level3.cpp [code]
XAML DirectX 3D shooting game/C++/Level3.h [code]
XAML DirectX 3D shooting game/C++/Level4.cpp [code]
XAML DirectX 3D shooting game/C++/Level4.h [code]
XAML DirectX 3D shooting game/C++/Level5.cpp [code]
XAML DirectX 3D shooting game/C++/Level5.h [code]
XAML DirectX 3D shooting game/C++/Level6.cpp [code]
XAML DirectX 3D shooting game/C++/Level6.h [code]
XAML DirectX 3D shooting game/C++/MainPage.xaml.cpp [code]
XAML DirectX 3D shooting game/C++/MainPage.xaml.h [code]
XAML DirectX 3D shooting game/C++/Material.cpp [code]
XAML DirectX 3D shooting game/C++/Material.h [code]
XAML DirectX 3D shooting game/C++/MediaReader.cpp [code]
XAML DirectX 3D shooting game/C++/MediaReader.h [code]
XAML DirectX 3D shooting game/C++/MeshObject.cpp [code]
XAML DirectX 3D shooting game/C++/MeshObject.h [code]
XAML DirectX 3D shooting game/C++/MoveLookController.cpp [code]
XAML DirectX 3D shooting game/C++/MoveLookController.h [code]
XAML DirectX 3D shooting game/C++/pch.cpp [code]
XAML DirectX 3D shooting game/C++/pch.h [code]
XAML DirectX 3D shooting game/C++/PersistentState.cpp [code]
XAML DirectX 3D shooting game/C++/PersistentState.h [code]
XAML DirectX 3D shooting game/C++/ProductItem.cpp [code]
XAML DirectX 3D shooting game/C++/ProductItem.h [code]
XAML DirectX 3D shooting game/C++/Simple3DGame.cpp [code]
XAML DirectX 3D shooting game/C++/Simple3DGame.h [code]
XAML DirectX 3D shooting game/C++/SoundEffect.cpp [code]
XAML DirectX 3D shooting game/C++/SoundEffect.h [code]
XAML DirectX 3D shooting game/C++/Sphere.cpp [code]
XAML DirectX 3D shooting game/C++/Sphere.h [code]
XAML DirectX 3D shooting game/C++/SphereMesh.cpp [code]
XAML DirectX 3D shooting game/C++/SphereMesh.h [code]
XAML DirectX 3D shooting game/C++/StereoProjection.cpp [code]
XAML DirectX 3D shooting game/C++/StereoProjection.h [code]
XAML DirectX 3D shooting game/C++/TargetTexture.cpp [code]
XAML DirectX 3D shooting game/C++/TargetTexture.h [code]
XAML DirectX 3D shooting game/C++/WorldMesh.cpp [code]
XAML DirectX 3D shooting game/C++/WorldMesh.h [code]
XAML FlipView control/C++/App.xaml.cpp [code]
XAML FlipView control/C++/App.xaml.h [code]
XAML FlipView control/C++/Constants.cpp [code]
XAML FlipView control/C++/Constants.h [code]
XAML FlipView control/C++/MainPage.xaml.cpp [code]
XAML FlipView control/C++/MainPage.xaml.h [code]
XAML FlipView control/C++/pch.cpp [code]
XAML FlipView control/C++/pch.h [code]
XAML FlipView control/C++/SampleDataSource.cpp [code]
XAML FlipView control/C++/SampleDataSource.h [code]
XAML FlipView control/C++/Scenario1.xaml.cpp [code]
XAML FlipView control/C++/Scenario1.xaml.h [code]
XAML FlipView control/C++/Scenario2.xaml.cpp [code]
XAML FlipView control/C++/Scenario2.xaml.h [code]
XAML FlipView control/C++/Scenario3.xaml.cpp [code]
XAML FlipView control/C++/Scenario3.xaml.h [code]
XAML FlipView control/C++/Scenario4.xaml.cpp [code]
XAML FlipView control/C++/Scenario4.xaml.h [code]
XAML FlipView control/C++/Scenario5.xaml.cpp [code]
XAML FlipView control/C++/Scenario5.xaml.h [code]
XAML FlipView control/C++/common/LayoutAwarePage.cpp [code]
XAML FlipView control/C++/common/LayoutAwarePage.h [code]
XAML FlipView control/C++/common/suspensionmanager.cpp [code]
XAML FlipView control/C++/common/suspensionmanager.h [code]
XAML high contrast style/C++/App.xaml.cpp [code]
XAML high contrast style/C++/App.xaml.h [code]
XAML high contrast style/C++/Constants.cpp [code]
XAML high contrast style/C++/Constants.h [code]
XAML high contrast style/C++/MainPage.xaml.cpp [code]
XAML high contrast style/C++/MainPage.xaml.h [code]
XAML high contrast style/C++/pch.cpp [code]
XAML high contrast style/C++/pch.h [code]
XAML high contrast style/C++/Scenario1.xaml.cpp [code]
XAML high contrast style/C++/Scenario1.xaml.h [code]
XAML high contrast style/C++/Scenario2.xaml.cpp [code]
XAML high contrast style/C++/Scenario2.xaml.h [code]
XAML high contrast style/C++/Scenario3.xaml.cpp [code]
XAML high contrast style/C++/Scenario3.xaml.h [code]
XAML high contrast style/C++/TargetButton.xaml.cpp [code]
XAML high contrast style/C++/TargetButton.xaml.h [code]
XAML high contrast style/C++/common/LayoutAwarePage.cpp [code]
XAML high contrast style/C++/common/LayoutAwarePage.h [code]
XAML high contrast style/C++/common/suspensionmanager.cpp [code]
XAML high contrast style/C++/common/suspensionmanager.h [code]
XAML images/C++/App.xaml.cpp [code]
XAML images/C++/App.xaml.h [code]
XAML images/C++/Constants.cpp [code]
XAML images/C++/Constants.h [code]
XAML images/C++/MainPage.xaml.cpp [code]
XAML images/C++/MainPage.xaml.h [code]
XAML images/C++/pch.cpp [code]
XAML images/C++/pch.h [code]
XAML images/C++/Scenario1.xaml.cpp [code]
XAML images/C++/Scenario1.xaml.h [code]
XAML images/C++/Scenario2.xaml.cpp [code]
XAML images/C++/Scenario2.xaml.h [code]
XAML images/C++/Scenario3.xaml.cpp [code]
XAML images/C++/Scenario3.xaml.h [code]
XAML images/C++/common/LayoutAwarePage.cpp [code]
XAML images/C++/common/LayoutAwarePage.h [code]
XAML images/C++/common/suspensionmanager.cpp [code]
XAML images/C++/common/suspensionmanager.h [code]
XAML ListView and GridView essentials/C++/App.xaml.cpp [code]
XAML ListView and GridView essentials/C++/App.xaml.h [code]
XAML ListView and GridView essentials/C++/Constants.cpp [code]
XAML ListView and GridView essentials/C++/Constants.h [code]
XAML ListView and GridView essentials/C++/MainPage.xaml.cpp [code]
XAML ListView and GridView essentials/C++/MainPage.xaml.h [code]
XAML ListView and GridView essentials/C++/pch.cpp [code]
XAML ListView and GridView essentials/C++/pch.h [code]
XAML ListView and GridView essentials/C++/SampleDataSource.cpp [code]
XAML ListView and GridView essentials/C++/SampleDataSource.h [code]
XAML ListView and GridView essentials/C++/Scenario1.xaml.cpp [code]
XAML ListView and GridView essentials/C++/Scenario1.xaml.h [code]
XAML ListView and GridView essentials/C++/Scenario2.xaml.cpp [code]
XAML ListView and GridView essentials/C++/Scenario2.xaml.h [code]
XAML ListView and GridView essentials/C++/Scenario3.xaml.cpp [code]
XAML ListView and GridView essentials/C++/Scenario3.xaml.h [code]
XAML personality animations/C++/App.xaml.cpp [code]
XAML personality animations/C++/App.xaml.h [code]
XAML personality animations/C++/Constants.cpp [code]
XAML personality animations/C++/Constants.h [code]
XAML personality animations/C++/MainPage.xaml.cpp [code]
XAML personality animations/C++/MainPage.xaml.h [code]
XAML personality animations/C++/Page1.xaml.cpp [code]
XAML personality animations/C++/Page1.xaml.h [code]
XAML personality animations/C++/Page2.xaml.cpp [code]
XAML personality animations/C++/Page2.xaml.h [code]
XAML personality animations/C++/pch.cpp [code]
XAML personality animations/C++/pch.h [code]
XAML personality animations/C++/Scenario1.xaml.cpp [code]
XAML personality animations/C++/Scenario1.xaml.h [code]
XAML personality animations/C++/Scenario2.xaml.cpp [code]
XAML personality animations/C++/Scenario2.xaml.h [code]
XAML personality animations/C++/Scenario3.xaml.cpp [code]
XAML personality animations/C++/Scenario3.xaml.h [code]
XAML personality animations/C++/common/LayoutAwarePage.cpp [code]
XAML personality animations/C++/common/LayoutAwarePage.h [code]
XAML personality animations/C++/common/suspensionmanager.cpp [code]
XAML personality animations/C++/common/suspensionmanager.h [code]
XAML personality animations/C++/SampleData/SampleDataSource.cpp [code]
XAML personality animations/C++/SampleData/SampleDataSource.h [code]
XAML Popup/C++/App.xaml.cpp [code]
XAML Popup/C++/App.xaml.h [code]
XAML Popup/C++/Constants.cpp [code]
XAML Popup/C++/Constants.h [code]
XAML Popup/C++/MainPage.xaml.cpp [code]
XAML Popup/C++/MainPage.xaml.h [code]
XAML Popup/C++/pch.cpp [code]
XAML Popup/C++/pch.h [code]
XAML Popup/C++/PopupInputContent.xaml.cpp [code]
XAML Popup/C++/PopupInputContent.xaml.h [code]
XAML Popup/C++/Scenario1.xaml.cpp [code]
XAML Popup/C++/Scenario1.xaml.h [code]
XAML Popup/C++/Scenario2.xaml.cpp [code]
XAML Popup/C++/Scenario2.xaml.h [code]
XAML Popup/C++/Scenario3.xaml.cpp [code]
XAML Popup/C++/Scenario3.xaml.h [code]
XAML Popup/C++/common/LayoutAwarePage.cpp [code]
XAML Popup/C++/common/LayoutAwarePage.h [code]
XAML Popup/C++/common/suspensionmanager.cpp [code]
XAML Popup/C++/common/suspensionmanager.h [code]
XAML scrolling, panning, and zooming/C++/App.xaml.cpp [code]
XAML scrolling, panning, and zooming/C++/App.xaml.h [code]
XAML scrolling, panning, and zooming/C++/Constants.cpp [code]
XAML scrolling, panning, and zooming/C++/Constants.h [code]
XAML scrolling, panning, and zooming/C++/MainPage.xaml.cpp [code]
XAML scrolling, panning, and zooming/C++/MainPage.xaml.h [code]
XAML scrolling, panning, and zooming/C++/pch.cpp [code]
XAML scrolling, panning, and zooming/C++/pch.h [code]
XAML scrolling, panning, and zooming/C++/Scenario1.xaml.cpp [code]
XAML scrolling, panning, and zooming/C++/Scenario1.xaml.h [code]
XAML scrolling, panning, and zooming/C++/Scenario2.xaml.cpp [code]
XAML scrolling, panning, and zooming/C++/Scenario2.xaml.h [code]
XAML scrolling, panning, and zooming/C++/Scenario3.xaml.cpp [code]
XAML scrolling, panning, and zooming/C++/Scenario3.xaml.h [code]
XAML text display/C++/App.xaml.cpp [code]
XAML text display/C++/App.xaml.h [code]
XAML text display/C++/Constants.cpp [code]
XAML text display/C++/Constants.h [code]
XAML text display/C++/MainPage.xaml.cpp [code]
XAML text display/C++/MainPage.xaml.h [code]
XAML text display/C++/pch.cpp [code]
XAML text display/C++/pch.h [code]
XAML text display/C++/Scenario1.xaml.cpp [code]
XAML text display/C++/Scenario1.xaml.h [code]
XAML text display/C++/Scenario2.xaml.cpp [code]
XAML text display/C++/Scenario2.xaml.h [code]
XAML text display/C++/Scenario3.xaml.cpp [code]
XAML text display/C++/Scenario3.xaml.h [code]
XAML text display/C++/Scenario4.xaml.cpp [code]
XAML text display/C++/Scenario4.xaml.h [code]
XAML text display/C++/Common/LayoutAwarePage.cpp [code]
XAML text display/C++/Common/LayoutAwarePage.h [code]
XAML text display/C++/Common/suspensionmanager.cpp [code]
XAML text display/C++/Common/suspensionmanager.h [code]
XAML text editing/C++/App.xaml.cpp [code]
XAML text editing/C++/App.xaml.h [code]
XAML text editing/C++/Constants.cpp [code]
XAML text editing/C++/Constants.h [code]
XAML text editing/C++/MainPage.xaml.cpp [code]
XAML text editing/C++/MainPage.xaml.h [code]
XAML text editing/C++/pch.cpp [code]
XAML text editing/C++/pch.h [code]
XAML text editing/C++/Scenario1.xaml.cpp [code]
XAML text editing/C++/Scenario1.xaml.h [code]
XAML text editing/C++/Scenario2.xaml.cpp [code]
XAML text editing/C++/Scenario2.xaml.h [code]
XAML text editing/C++/Scenario3.xaml.cpp [code]
XAML text editing/C++/Scenario3.xaml.h [code]
XAML text editing/C++/Scenario4.xaml.cpp [code]
XAML text editing/C++/Scenario4.xaml.h [code]
XAML text editing/C++/Scenario5.xaml.cpp [code]
XAML text editing/C++/Scenario5.xaml.h [code]
XAML text editing/C++/Scenario6.xaml.cpp [code]
XAML text editing/C++/Scenario6.xaml.h [code]
XAML text editing/C++/Scenario7.xaml.cpp [code]
XAML text editing/C++/Scenario7.xaml.h [code]
XAML text editing/C++/Common/LayoutAwarePage.cpp [code]
XAML text editing/C++/Common/LayoutAwarePage.h [code]
XAML text editing/C++/Common/suspensionmanager.cpp [code]
XAML text editing/C++/Common/suspensionmanager.h [code]
XAML two-dimensional transforms/C++/App.xaml.cpp [code]
XAML two-dimensional transforms/C++/App.xaml.h [code]
XAML two-dimensional transforms/C++/Constants.cpp [code]
XAML two-dimensional transforms/C++/Constants.h [code]
XAML two-dimensional transforms/C++/MainPage.xaml.cpp [code]
XAML two-dimensional transforms/C++/MainPage.xaml.h [code]
XAML two-dimensional transforms/C++/pch.cpp [code]
XAML two-dimensional transforms/C++/pch.h [code]
XAML two-dimensional transforms/C++/Scenario1.xaml.cpp [code]
XAML two-dimensional transforms/C++/Scenario1.xaml.h [code]
XAML two-dimensional transforms/C++/Scenario2.xaml.cpp [code]
XAML two-dimensional transforms/C++/Scenario2.xaml.h [code]
XAML two-dimensional transforms/C++/common/LayoutAwarePage.cpp [code]
XAML two-dimensional transforms/C++/common/LayoutAwarePage.h [code]
XAML two-dimensional transforms/C++/common/suspensionmanager.cpp [code]
XAML two-dimensional transforms/C++/common/suspensionmanager.h [code]
XAML user and custom controls/C++/App.xaml.cpp [code]
XAML user and custom controls/C++/App.xaml.h [code]
XAML user and custom controls/C++/BasicCustomControl.cpp [code]
XAML user and custom controls/C++/BasicCustomControl.h [code]
XAML user and custom controls/C++/BasicUserControl.xaml.cpp [code]
XAML user and custom controls/C++/BasicUserControl.xaml.h [code]
XAML user and custom controls/C++/Constants.cpp [code]
XAML user and custom controls/C++/Constants.h [code]
XAML user and custom controls/C++/ImageWithLabelControl.cpp [code]
XAML user and custom controls/C++/ImageWithLabelControl.h [code]
XAML user and custom controls/C++/MainPage.xaml.cpp [code]
XAML user and custom controls/C++/MainPage.xaml.h [code]
XAML user and custom controls/C++/pch.cpp [code]
XAML user and custom controls/C++/pch.h [code]
XAML user and custom controls/C++/Scenario1.xaml.cpp [code]
XAML user and custom controls/C++/Scenario1.xaml.h [code]
XAML user and custom controls/C++/Scenario2.xaml.cpp [code]
XAML user and custom controls/C++/Scenario2.xaml.h [code]
XAML user and custom controls/C++/Scenario3.xaml.cpp [code]
XAML user and custom controls/C++/Scenario3.xaml.h [code]
XAML user and custom controls/C++/Scenario4.xaml.cpp [code]
XAML user and custom controls/C++/Scenario4.xaml.h [code]
XAML user and custom controls/C++/common/LayoutAwarePage.cpp [code]
XAML user and custom controls/C++/common/LayoutAwarePage.h [code]
XAML user and custom controls/C++/common/suspensionmanager.cpp [code]
XAML user and custom controls/C++/common/suspensionmanager.h [code]
XAML vector-based drawing/C++/App.xaml.cpp [code]
XAML vector-based drawing/C++/App.xaml.h [code]
XAML vector-based drawing/C++/Constants.cpp [code]
XAML vector-based drawing/C++/Constants.h [code]
XAML vector-based drawing/C++/MainPage.xaml.cpp [code]
XAML vector-based drawing/C++/MainPage.xaml.h [code]
XAML vector-based drawing/C++/pch.cpp [code]
XAML vector-based drawing/C++/pch.h [code]
XAML vector-based drawing/C++/Scenario1.xaml.cpp [code]
XAML vector-based drawing/C++/Scenario1.xaml.h [code]
XAML vector-based drawing/C++/Scenario2.xaml.cpp [code]
XAML vector-based drawing/C++/Scenario2.xaml.h [code]
XAML vector-based drawing/C++/Scenario3.xaml.cpp [code]
XAML vector-based drawing/C++/Scenario3.xaml.h [code]
XAML vector-based drawing/C++/Scenario4.xaml.cpp [code]
XAML vector-based drawing/C++/Scenario4.xaml.h [code]
XAML vector-based drawing/C++/common/LayoutAwarePage.cpp [code]
XAML vector-based drawing/C++/common/LayoutAwarePage.h [code]
XAML vector-based drawing/C++/common/suspensionmanager.cpp [code]
XAML vector-based drawing/C++/common/suspensionmanager.h [code]
XAML WebView control/C++/App.xaml.cpp [code]
XAML WebView control/C++/App.xaml.h [code]
XAML WebView control/C++/Constants.cpp [code]
XAML WebView control/C++/Constants.h [code]
XAML WebView control/C++/MainPage.xaml.cpp [code]
XAML WebView control/C++/MainPage.xaml.h [code]
XAML WebView control/C++/PageWithAppBar.xaml.cpp [code]
XAML WebView control/C++/PageWithAppBar.xaml.h [code]
XAML WebView control/C++/pch.cpp [code]
XAML WebView control/C++/pch.h [code]
XAML WebView control/C++/Scenario1.xaml.cpp [code]
XAML WebView control/C++/Scenario1.xaml.h [code]
XAML WebView control/C++/Scenario2.xaml.cpp [code]
XAML WebView control/C++/Scenario2.xaml.h [code]
XAML WebView control/C++/Scenario3.xaml.cpp [code]
XAML WebView control/C++/Scenario3.xaml.h [code]
XAML WebView control/C++/Scenario4.xaml.cpp [code]
XAML WebView control/C++/Scenario4.xaml.h [code]
XAML WebView control/C++/Scenario5.xaml.cpp [code]
XAML WebView control/C++/Scenario5.xaml.h [code]
XAML WebView control/C++/Scenario6.xaml.cpp [code]
XAML WebView control/C++/Scenario6.xaml.h [code]
XAML WebView control/C++/Scenario7.xaml.cpp [code]
XAML WebView control/C++/Scenario7.xaml.h [code]
XAML WebView control/C++/Scenario8.xaml.cpp [code]
XAML WebView control/C++/Scenario8.xaml.h [code]
XAML WebView control/C++/common/LayoutAwarePage.cpp [code]
XAML WebView control/C++/common/LayoutAwarePage.h [code]
XAML WebView control/C++/common/suspensionmanager.cpp [code]
XAML WebView control/C++/common/suspensionmanager.h [code]
XAudio2 audio file playback/C++/BasicMath.h [code]
XAudio2 audio file playback/C++/BasicSound.cpp [code]
XAudio2 audio file playback/C++/BasicSound.h [code]
XAudio2 audio file playback/C++/BasicTimer.cpp [code]
XAudio2 audio file playback/C++/BasicTimer.h [code]
XAudio2 audio file playback/C++/DirectXApp.cpp [code]
XAudio2 audio file playback/C++/DirectXApp.h [code]
XAudio2 audio file playback/C++/DirectXBase.cpp [code]
XAudio2 audio file playback/C++/DirectXBase.h [code]
XAudio2 audio file playback/C++/DirectXSample.h [code]
XAudio2 audio file playback/C++/pch.cpp [code]
XAudio2 audio file playback/C++/pch.h [code]
XAudio2 audio file playback/C++/RandomAccessReader.cpp [code]
XAudio2 audio file playback/C++/RandomAccessReader.h [code]
XAudio2 audio file playback/C++/SampleOverlay.cpp [code]
XAudio2 audio file playback/C++/SampleOverlay.h [code]
XAudio2 audio file playback/C++/SoundFileReader.cpp [code]
XAudio2 audio file playback/C++/SoundFileReader.h [code]
XAudio2 audio file playback/C++/XAudio2SoundPlayer.cpp [code]
XAudio2 audio file playback/C++/XAudio2SoundPlayer.h [code]
XAudio2 audio stream effect/C++/BasicMath.h [code]
XAudio2 audio stream effect/C++/BasicTimer.cpp [code]
XAudio2 audio stream effect/C++/BasicTimer.h [code]
XAudio2 audio stream effect/C++/DirectXApp.cpp [code]
XAudio2 audio stream effect/C++/DirectXApp.h [code]
XAudio2 audio stream effect/C++/DirectXBase.cpp [code]
XAudio2 audio stream effect/C++/DirectXBase.h [code]
XAudio2 audio stream effect/C++/DirectXSample.h [code]
XAudio2 audio stream effect/C++/MediaStreamer.cpp [code]
XAudio2 audio stream effect/C++/MediaStreamer.h [code]
XAudio2 audio stream effect/C++/pch.cpp [code]
XAudio2 audio stream effect/C++/pch.h [code]
XAudio2 audio stream effect/C++/SampleOverlay.cpp [code]
XAudio2 audio stream effect/C++/SampleOverlay.h [code]
XAudio2 audio stream effect/C++/StreamEffect.cpp [code]
XAudio2 audio stream effect/C++/StreamEffect.h [code]
XInput audio controller playback/C++/AudioController.cpp [code]
XInput audio controller playback/C++/AudioController.h [code]
XInput audio controller playback/C++/BasicMath.h [code]
XInput audio controller playback/C++/BasicTimer.cpp [code]
XInput audio controller playback/C++/BasicTimer.h [code]
XInput audio controller playback/C++/DirectXApp.cpp [code]
XInput audio controller playback/C++/DirectXApp.h [code]
XInput audio controller playback/C++/DirectXBase.cpp [code]
XInput audio controller playback/C++/DirectXBase.h [code]
XInput audio controller playback/C++/DirectXSample.h [code]
XInput audio controller playback/C++/MediaStreamer.cpp [code]
XInput audio controller playback/C++/MediaStreamer.h [code]
XInput audio controller playback/C++/pch.cpp [code]
XInput audio controller playback/C++/pch.h [code]
XInput audio controller playback/C++/SampleOverlay.cpp [code]
XInput audio controller playback/C++/SampleOverlay.h [code]
XInput game controller/C++/BasicTimer.cpp [code]
XInput game controller/C++/BasicTimer.h [code]
XInput game controller/C++/DirectXApp.cpp [code]
XInput game controller/C++/DirectXApp.h [code]
XInput game controller/C++/DirectXBase.cpp [code]
XInput game controller/C++/DirectXBase.h [code]
XInput game controller/C++/DirectXSample.h [code]
XInput game controller/C++/pch.cpp [code]
XInput game controller/C++/pch.h [code]
XInput game controller/C++/SampleOverlay.cpp [code]
XInput game controller/C++/SampleOverlay.h [code]
XInput game controller/C++/SimpleController.cpp [code]
XInput game controller/C++/SimpleController.h [code]
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/App.xaml.cpp File Reference

  • File Members
  • Accelerometer sensor
  • C++

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/App.xaml.h File Reference

  • Accelerometer sensor
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Constants.cpp File Reference

  • Accelerometer sensor

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Constants.h File Reference

  • Accelerometer sensor
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/MainPage.xaml.cpp File Reference

  • Accelerometer sensor

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/MainPage.xaml.h File Reference

  • Accelerometer sensor
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/pch.cpp File Reference

  • Accelerometer sensor

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/pch.h File Reference

  • Accelerometer sensor

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Scenario1.xaml.cpp File Reference

  • Accelerometer sensor

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Scenario1.xaml.h File Reference

  • Accelerometer sensor
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::AccelerometerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::AccelerometerCPP
Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Scenario2.xaml.cpp File Reference

  • Accelerometer sensor

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Scenario2.xaml.h File Reference

  • Accelerometer sensor
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::AccelerometerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::AccelerometerCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Scenario3.xaml.cpp File Reference

  • Accelerometer sensor

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Scenario3.xaml.h File Reference

  • Accelerometer sensor
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::AccelerometerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::AccelerometerCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/common/LayoutAwarePage.cpp File Reference

  • Accelerometer sensor
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/common/LayoutAwarePage.h File Reference

  • Accelerometer sensor
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/common/suspensionmanager.cpp File Reference

  • Accelerometer sensor
  • common
Classes | Namespaces | Enumerations | Functions | Variables

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)

Variables

std::vector< WeakFrame^> | anonymous_namespace{suspensionmanager.cpp}::_registeredFrames
Map< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::_sessionState = ref new Map<String^, Object^>()
DependencyProperty | anonymous_namespace{suspensionmanager.cpp}::FrameSessionStateKeyProperty
DependencyProperty | anonymous_namespace{suspensionmanager.cpp}::FrameSessionStateProperty
String | anonymous_namespace{suspensionmanager.cpp}::sessionStateFilename = "_sessionState.dat"
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/common/suspensionmanager.h File Reference

  • Accelerometer sensor
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/App.xaml.cpp File Reference

  • Account picture name

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/App.xaml.h File Reference

  • Account picture name
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | AccountPictureName::App

Namespaces

namespace | AccountPictureName
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/Constants.cpp File Reference

  • Account picture name

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/Constants.h File Reference

  • Account picture name
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | AccountPictureName::MainPage
struct | AccountPictureName::Scenario

Namespaces

namespace | AccountPictureName
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/GetAccountPicture.xaml.cpp File Reference

  • Account picture name

GetAccountPicture.xaml.cpp File Reference

#include "pch.h"
#include "GetAccountPicture.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/GetAccountPicture.xaml.h File Reference

  • Account picture name
Classes | Namespaces

GetAccountPicture.xaml.h File Reference

#include "pch.h"
#include "GetAccountPicture.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AccountPictureName::sealed

Namespaces

namespace | AccountPictureName
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/GetUserDisplayName.xaml.cpp File Reference

  • Account picture name

GetUserDisplayName.xaml.cpp File Reference

#include "pch.h"
#include "GetUserDisplayName.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/GetUserDisplayName.xaml.h File Reference

  • Account picture name
Classes | Namespaces

GetUserDisplayName.xaml.h File Reference

#include "pch.h"
#include "GetUserDisplayName.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AccountPictureName::sealed

Namespaces

namespace | AccountPictureName
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/GetUserFirstAndLastName.xaml.cpp File Reference

  • Account picture name

GetUserFirstAndLastName.xaml.cpp File Reference

#include "pch.h"
#include "GetUserFirstAndLastName.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/GetUserFirstAndLastName.xaml.h File Reference

  • Account picture name
Classes | Namespaces

GetUserFirstAndLastName.xaml.h File Reference

#include "pch.h"
#include "GetUserFirstAndLastName.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AccountPictureName::sealed

Namespaces

namespace | AccountPictureName
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/MainPage.xaml.cpp File Reference

  • Account picture name

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/MainPage.xaml.h File Reference

  • Account picture name
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | AccountPictureName::sealed
class | AccountPictureName::sealed

Namespaces

namespace | AccountPictureName

Enumerations

enum | AccountPictureName::NotifyType { AccountPictureName::StatusMessage, AccountPictureName::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/pch.cpp File Reference

  • Account picture name

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/pch.h File Reference

  • Account picture name

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>
#include <wrl\implements.h>
#include <wrl\async.h>
#include <wrl\wrappers\corewrappers.h>
#include <windows.system.userprofile.h>
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/SetAccountPicture.xaml.cpp File Reference

  • Account picture name

SetAccountPicture.xaml.cpp File Reference

#include "pch.h"
#include "SetAccountPicture.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/SetAccountPicture.xaml.h File Reference

  • Account picture name
Classes | Namespaces

SetAccountPicture.xaml.h File Reference

#include "pch.h"
#include "SetAccountPicture.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AccountPictureName::sealed

Namespaces

namespace | AccountPictureName
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/common/LayoutAwarePage.cpp File Reference

  • Account picture name
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/common/LayoutAwarePage.h File Reference

  • Account picture name
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | AccountPictureName::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | AccountPictureName
namespace | AccountPictureName::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/sample-utils/CppSamplesUtils.h File Reference

  • Account picture name
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/App.xaml.cpp File Reference

  • Animation metrics

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/App.xaml.h File Reference

  • Animation metrics
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/Constants.cpp File Reference

  • Animation metrics

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/Constants.h File Reference

  • Animation metrics
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/MainPage.xaml.cpp File Reference

  • Animation metrics

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/MainPage.xaml.h File Reference

  • Animation metrics
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/pch.cpp File Reference

  • Animation metrics

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/pch.h File Reference

  • Animation metrics

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include <sstream>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/Scenario1.xaml.cpp File Reference

  • Animation metrics
Functions

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Functions

double TimeSpanToMilliseconds (Windows::Foundation::TimeSpan timeSpan)

Function Documentation

double TimeSpanToMilliseconds ( Windows::Foundation::TimeSpan timeSpan )

Definition at line 43 of file Scenario1.xaml.cpp.

{
    return timeSpan.Duration / 10000.0f;
}

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/Scenario1.xaml.h File Reference

  • Animation metrics
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::AnimationMetrics::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::AnimationMetrics
Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/common/LayoutAwarePage.cpp File Reference

  • Animation metrics
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/common/LayoutAwarePage.h File Reference

  • Animation metrics
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/common/suspensionmanager.cpp File Reference

  • Animation metrics
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/common/suspensionmanager.h File Reference

  • Animation metrics
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/App.xaml.cpp File Reference

  • App package information

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/App.xaml.h File Reference

  • App package information
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Constants.cpp File Reference

  • App package information

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Constants.h File Reference

  • App package information
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/MainPage.xaml.cpp File Reference

  • App package information

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/MainPage.xaml.h File Reference

  • App package information
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/pch.cpp File Reference

  • App package information

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/pch.h File Reference

  • App package information

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario1.xaml.cpp File Reference

  • App package information

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario1.xaml.h File Reference

  • App package information
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PackageSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PackageSample
Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario2.xaml.cpp File Reference

  • App package information

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario2.xaml.h File Reference

  • App package information
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PackageSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PackageSample
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario3.xaml.cpp File Reference

  • App package information

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario3.xaml.h File Reference

  • App package information
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PackageSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PackageSample
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/common/LayoutAwarePage.cpp File Reference

  • App package information
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/common/LayoutAwarePage.h File Reference

  • App package information
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/common/suspensionmanager.cpp File Reference

  • App package information
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/common/suspensionmanager.h File Reference

  • App package information
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/AddSettingsScenario.xaml.cpp File Reference

  • App settings

AddSettingsScenario.xaml.cpp File Reference

#include "pch.h"
#include "AddSettingsScenario.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/AddSettingsScenario.xaml.h File Reference

  • App settings
Classes | Namespaces

AddSettingsScenario.xaml.h File Reference

#include "pch.h"
#include "AddSettingsScenario.g.h"
#include "MainPage.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationSettings::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationSettings
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/App.xaml.cpp File Reference

  • App settings

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/App.xaml.h File Reference

  • App settings
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/Constants.cpp File Reference

  • App settings

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/Constants.h File Reference

  • App settings
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/DefaultScenario.xaml.cpp File Reference

  • App settings

DefaultScenario.xaml.cpp File Reference

#include "pch.h"
#include "DefaultScenario.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/DefaultScenario.xaml.h File Reference

  • App settings
Classes | Namespaces

DefaultScenario.xaml.h File Reference

#include "pch.h"
#include "DefaultScenario.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationSettings::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationSettings
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/MainPage.xaml.cpp File Reference

  • App settings

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/MainPage.xaml.h File Reference

  • App settings
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/pch.cpp File Reference

  • App settings

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/pch.h File Reference

  • App settings

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/common/LayoutAwarePage.cpp File Reference

  • App settings
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/common/LayoutAwarePage.h File Reference

  • App settings
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/common/suspensionmanager.cpp File Reference

  • App settings
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/common/suspensionmanager.h File Reference

  • App settings
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/App.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/App.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/Constants.cpp File Reference

  • App tiles and badges
  • C#,C++

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/Constants.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/EnableNotificationQueue.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

EnableNotificationQueue.xaml.cpp File Reference

#include "pch.h"
#include "EnableNotificationQueue.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/EnableNotificationQueue.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

EnableNotificationQueue.xaml.h File Reference

#include "pch.h"
#include "EnableNotificationQueue.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Tiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Tiles
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/Globalization.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

Globalization.xaml.cpp File Reference

#include "pch.h"
#include "Globalization.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/Globalization.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

Globalization.xaml.h File Reference

#include "pch.h"
#include "Globalization.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Tiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Tiles
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/ImageProtocols.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

ImageProtocols.xaml.cpp File Reference

#include "pch.h"
#include "ImageProtocols.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/ImageProtocols.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

ImageProtocols.xaml.h File Reference

#include "pch.h"
#include "ImageProtocols.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Tiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Tiles
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/MainPage.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/MainPage.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/NotificationExpiration.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

NotificationExpiration.xaml.cpp File Reference

#include "pch.h"
#include "NotificationExpiration.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/NotificationExpiration.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

NotificationExpiration.xaml.h File Reference

#include "pch.h"
#include "NotificationExpiration.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Tiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Tiles
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/pch.cpp File Reference

  • App tiles and badges
  • C#,C++

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/pch.h File Reference

  • App tiles and badges
  • C#,C++

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendBadge.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

SendBadge.xaml.cpp File Reference

#include "pch.h"
#include "SendBadge.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendBadge.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

SendBadge.xaml.h File Reference

#include "pch.h"
#include "SendBadge.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Tiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Tiles
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendLocalImageTile.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

SendLocalImageTile.xaml.cpp File Reference

#include "pch.h"
#include "SendLocalImageTile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendLocalImageTile.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

SendLocalImageTile.xaml.h File Reference

#include "pch.h"
#include "SendLocalImageTile.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Tiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Tiles
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendTextTile.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

SendTextTile.xaml.cpp File Reference

#include "pch.h"
#include "SendTextTile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendTextTile.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

SendTextTile.xaml.h File Reference

#include "pch.h"
#include "SendTextTile.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Tiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Tiles
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendWebImageTile.xaml.cpp File Reference

  • App tiles and badges
  • C#,C++

SendWebImageTile.xaml.cpp File Reference

#include "pch.h"
#include "SendWebImageTile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendWebImageTile.xaml.h File Reference

  • App tiles and badges
  • C#,C++
Classes | Namespaces

SendWebImageTile.xaml.h File Reference

#include "pch.h"
#include "SendWebImageTile.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Tiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Tiles
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/common/LayoutAwarePage.cpp File Reference

  • App tiles and badges
  • C#,C++
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/common/LayoutAwarePage.h File Reference

  • App tiles and badges
  • C#,C++
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/common/suspensionmanager.cpp File Reference

  • App tiles and badges
  • C#,C++
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/common/suspensionmanager.h File Reference

  • App tiles and badges
  • C#,C++
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/NotificationsExtensions/Common.cs File Reference

  • App tiles and badges
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

Common.cs File Reference

Go to the source code of this file.

Classes

class | NotificationsExtensions::NotificationBase
Base class for the notification content creation helper classes. More...
class | NotificationsExtensions::NotificationContentImage
class | NotificationsExtensions::NotificationContentText
class | NotificationsExtensions::NotificationContentValidationException
Exception returned when invalid notification content is provided. More...
class | NotificationsExtensions::Util

Namespaces

namespace | NotificationsExtensions
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/App.xaml.cpp File Reference

  • Application data

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/App.xaml.h File Reference

  • Application data
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/ClearScenario.xaml.cpp File Reference

  • Application data
Defines

ClearScenario.xaml.cpp File Reference

#include "pch.h"
#include "ClearScenario.xaml.h"

Go to the source code of this file.

Defines

#define | settingName "exampleCompositeSetting"
#define | settingName1 "one"
#define | settingName2 "hello"
#define | settingValue1 1
#define | settingValue2 "world"

Define Documentation

#define settingName "exampleCompositeSetting"

Definition at line 28 of file ClearScenario.xaml.cpp.

#define settingName1 "one"

Definition at line 29 of file ClearScenario.xaml.cpp.

#define settingName2 "hello"

Definition at line 31 of file ClearScenario.xaml.cpp.

#define settingValue1 1

Definition at line 30 of file ClearScenario.xaml.cpp.

#define settingValue2 "world"

Definition at line 32 of file ClearScenario.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/ClearScenario.xaml.h File Reference

  • Application data
Classes | Namespaces

ClearScenario.xaml.h File Reference

#include "pch.h"
#include "ClearScenario.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/CompositeSettings.xaml.cpp File Reference

  • Application data
Defines

CompositeSettings.xaml.cpp File Reference

#include "pch.h"
#include "CompositeSettings.xaml.h"

Go to the source code of this file.

Defines

#define | settingName "exampleCompositeSetting"
#define | settingName1 "one"
#define | settingName2 "hello"
#define | settingValue1 1
#define | settingValue2 "world"

Define Documentation

#define settingName "exampleCompositeSetting"

Definition at line 28 of file CompositeSettings.xaml.cpp.

#define settingName1 "one"

Definition at line 29 of file CompositeSettings.xaml.cpp.

#define settingName2 "hello"

Definition at line 31 of file CompositeSettings.xaml.cpp.

#define settingValue1 1

Definition at line 30 of file CompositeSettings.xaml.cpp.

#define settingValue2 "world"

Definition at line 32 of file CompositeSettings.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/CompositeSettings.xaml.h File Reference

  • Application data
Classes | Namespaces

CompositeSettings.xaml.h File Reference

#include "pch.h"
#include "CompositeSettings.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Constants.cpp File Reference

  • Application data

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Constants.h File Reference

  • Application data
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/DataChangedEvent.xaml.cpp File Reference

  • Application data
Defines

DataChangedEvent.xaml.cpp File Reference

#include "pch.h"
#include "DataChangedEvent.xaml.h"

Go to the source code of this file.

Defines

#define settingName "userName"

Define Documentation

#define settingName "userName"

Definition at line 29 of file DataChangedEvent.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/DataChangedEvent.xaml.h File Reference

  • Application data
Classes | Namespaces

DataChangedEvent.xaml.h File Reference

#include "pch.h"
#include "DataChangedEvent.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Files.xaml.cpp File Reference

  • Application data
Defines

Files.xaml.cpp File Reference

#include "pch.h"
#include "Files.xaml.h"

Go to the source code of this file.

Defines

#define filename "sampleFile.txt"

Define Documentation

#define filename "sampleFile.txt"

Definition at line 29 of file Files.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Files.xaml.h File Reference

  • Application data
Classes | Namespaces

Files.xaml.h File Reference

#include "pch.h"
#include "Files.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/HighPriority.xaml.cpp File Reference

  • Application data

HighPriority.xaml.cpp File Reference

#include "pch.h"
#include "HighPriority.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/HighPriority.xaml.h File Reference

  • Application data
Classes | Namespaces

HighPriority.xaml.h File Reference

#include "pch.h"
#include "HighPriority.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/MainPage.xaml.cpp File Reference

  • Application data

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/MainPage.xaml.h File Reference

  • Application data
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Msappdata.xaml.cpp File Reference

  • Application data

Msappdata.xaml.cpp File Reference

#include "pch.h"
#include "Msappdata.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Msappdata.xaml.h File Reference

  • Application data
Classes | Namespaces

Msappdata.xaml.h File Reference

#include "pch.h"
#include "Msappdata.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/pch.cpp File Reference

  • Application data

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/pch.h File Reference

  • Application data

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/SettingContainer.xaml.cpp File Reference

  • Application data
Defines

SettingContainer.xaml.cpp File Reference

#include "pch.h"
#include "SettingContainer.xaml.h"

Go to the source code of this file.

Defines

#define | containerName "exampleContainer"
#define | settingName "exampleSetting"
#define | settingValue "Hello World"

Define Documentation

#define containerName "exampleContainer"

Definition at line 28 of file SettingContainer.xaml.cpp.

#define settingName "exampleSetting"

Definition at line 29 of file SettingContainer.xaml.cpp.

#define settingValue "Hello World"

Definition at line 30 of file SettingContainer.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/SettingContainer.xaml.h File Reference

  • Application data
Classes | Namespaces

SettingContainer.xaml.h File Reference

#include "pch.h"
#include "SettingContainer.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Settings.xaml.cpp File Reference

  • Application data
Defines

Settings.xaml.cpp File Reference

#include "pch.h"
#include "Settings.xaml.h"

Go to the source code of this file.

Defines

#define | settingName "exampleSetting"
#define | settingValue "Hello World"

Define Documentation

#define settingName "exampleSetting"

Definition at line 28 of file Settings.xaml.cpp.

#define settingValue "Hello World"

Definition at line 29 of file Settings.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Settings.xaml.h File Reference

  • Application data
Classes | Namespaces

Settings.xaml.h File Reference

#include "pch.h"
#include "Settings.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/SetVersion.xaml.cpp File Reference

  • Application data
Defines

SetVersion.xaml.cpp File Reference

#include "pch.h"
#include "SetVersion.xaml.h"

Go to the source code of this file.

Defines

#define | settingName "SetVersionSetting"
#define | settingValue0 "Data.v0"
#define | settingValue1 "Data.v1"

Define Documentation

#define settingName "SetVersionSetting"

Definition at line 29 of file SetVersion.xaml.cpp.

#define settingValue0 "Data.v0"

Definition at line 30 of file SetVersion.xaml.cpp.

#define settingValue1 "Data.v1"

Definition at line 31 of file SetVersion.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/SetVersion.xaml.h File Reference

  • Application data
Classes | Namespaces

SetVersion.xaml.h File Reference

#include "pch.h"
#include "SetVersion.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationDataSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationDataSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/common/LayoutAwarePage.cpp File Reference

  • Application data
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/common/LayoutAwarePage.h File Reference

  • Application data
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/common/suspensionmanager.cpp File Reference

  • Application data
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/common/suspensionmanager.h File Reference

  • Application data
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/App.xaml.cpp File Reference

  • Application resources and localization

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/App.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Constants.cpp File Reference

  • Application resources and localization

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Constants.h File Reference

  • Application resources and localization
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/CppSamplesUtils.h File Reference

  • Application resources and localization
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/MainPage.xaml.cpp File Reference

  • Application resources and localization

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/MainPage.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/pch.cpp File Reference

  • Application resources and localization

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/pch.h File Reference

  • Application resources and localization

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario1.xaml.cpp File Reference

  • Application resources and localization

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario1.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario10.xaml.cpp File Reference

  • Application resources and localization

Scenario10.xaml.cpp File Reference

#include "pch.h"
#include "Scenario10.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario10.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario10.xaml.h File Reference

#include "pch.h"
#include "Scenario10.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario11.xaml.cpp File Reference

  • Application resources and localization

Scenario11.xaml.cpp File Reference

#include "pch.h"
#include "Scenario11.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario11.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario11.xaml.h File Reference

#include "pch.h"
#include "Scenario11.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario2.xaml.cpp File Reference

  • Application resources and localization

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario2.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario3.xaml.cpp File Reference

  • Application resources and localization

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario3.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario4.xaml.cpp File Reference

  • Application resources and localization

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario4.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario5.xaml.cpp File Reference

  • Application resources and localization

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario5.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario6.xaml.cpp File Reference

  • Application resources and localization

Scenario6.xaml.cpp File Reference

#include "pch.h"
#include "Scenario6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario6.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario6.xaml.h File Reference

#include "pch.h"
#include "Scenario6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario7.xaml.cpp File Reference

  • Application resources and localization

Scenario7.xaml.cpp File Reference

#include "pch.h"
#include "Scenario7.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario7.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario7.xaml.h File Reference

#include "pch.h"
#include "Scenario7.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario8.xaml.cpp File Reference

  • Application resources and localization

Scenario8.xaml.cpp File Reference

#include "pch.h"
#include "Scenario8.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario8.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario8.xaml.h File Reference

#include "pch.h"
#include "Scenario8.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario9.xaml.cpp File Reference

  • Application resources and localization

Scenario9.xaml.cpp File Reference

#include "pch.h"
#include "Scenario9.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario9.xaml.h File Reference

  • Application resources and localization
Classes | Namespaces

Scenario9.xaml.h File Reference

#include "pch.h"
#include "Scenario9.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ApplicationResources::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ApplicationResources
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/App.xaml.cpp File Reference

  • Association launching

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/App.xaml.h File Reference

  • Association launching
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/CppSamplesUtils.h File Reference

  • Association launching
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchFileInput.xaml.cpp File Reference

  • Association launching

LaunchFileInput.xaml.cpp File Reference

#include "pch.h"
#include "LaunchFileInput.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchFileInput.xaml.h File Reference

  • Association launching
Classes | Namespaces

LaunchFileInput.xaml.h File Reference

#include "pch.h"
#include "LaunchFileInput.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchFileOutput.xaml.cpp File Reference

  • Association launching

LaunchFileOutput.xaml.cpp File Reference

#include "pch.h"
#include "LaunchFileOutput.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchFileOutput.xaml.h File Reference

  • Association launching
Classes | Namespaces

LaunchFileOutput.xaml.h File Reference

#include "pch.h"
#include "LaunchFileOutput.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchUriInput.xaml.cpp File Reference

  • Association launching

LaunchUriInput.xaml.cpp File Reference

#include "pch.h"
#include "LaunchUriInput.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchUriInput.xaml.h File Reference

  • Association launching
Classes | Namespaces

LaunchUriInput.xaml.h File Reference

#include "pch.h"
#include "LaunchUriInput.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchUriOutput.xaml.cpp File Reference

  • Association launching

LaunchUriOutput.xaml.cpp File Reference

#include "pch.h"
#include "LaunchUriOutput.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchUriOutput.xaml.h File Reference

  • Association launching
Classes | Namespaces

LaunchUriOutput.xaml.h File Reference

#include "pch.h"
#include "LaunchUriOutput.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/MainPage.xaml.cpp File Reference

  • Association launching

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/MainPage.xaml.h File Reference

  • Association launching
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching

Enumerations

enum | AssociationLaunching::NotifyType { AssociationLaunching::StatusMessage, AssociationLaunching::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/pch.cpp File Reference

  • Association launching

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/pch.h File Reference

  • Association launching

pch.h File Reference

#include "CppSamplesUtils.h"
#include <ppltasks.h>
#include "CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveFileInput.xaml.cpp File Reference

  • Association launching

ReceiveFileInput.xaml.cpp File Reference

#include "pch.h"
#include "ReceiveFileInput.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveFileInput.xaml.h File Reference

  • Association launching
Classes | Namespaces

ReceiveFileInput.xaml.h File Reference

#include "pch.h"
#include "ReceiveFileInput.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveFileOutput.xaml.cpp File Reference

  • Association launching

ReceiveFileOutput.xaml.cpp File Reference

#include "pch.h"
#include "ReceiveFileOutput.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveFileOutput.xaml.h File Reference

  • Association launching
Classes | Namespaces

ReceiveFileOutput.xaml.h File Reference

#include "pch.h"
#include "ReceiveFileOutput.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveUriInput.xaml.cpp File Reference

  • Association launching

ReceiveUriInput.xaml.cpp File Reference

#include "pch.h"
#include "ReceiveUriInput.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveUriInput.xaml.h File Reference

  • Association launching
Classes | Namespaces

ReceiveUriInput.xaml.h File Reference

#include "pch.h"
#include "ReceiveUriInput.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveUriOutput.xaml.cpp File Reference

  • Association launching

ReceiveUriOutput.xaml.cpp File Reference

#include "pch.h"
#include "ReceiveUriOutput.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveUriOutput.xaml.h File Reference

  • Association launching
Classes | Namespaces

ReceiveUriOutput.xaml.h File Reference

#include "pch.h"
#include "ReceiveUriOutput.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ScenarioList.xaml.cpp File Reference

  • Association launching

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ScenarioList.xaml.h File Reference

  • Association launching
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | AssociationLaunching::sealed

Namespaces

namespace | AssociationLaunching
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/App.xaml.cpp File Reference

  • AtomPub

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/App.xaml.h File Reference

  • AtomPub
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Constants.cpp File Reference

  • AtomPub

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Constants.h File Reference

  • AtomPub
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario
class | SDKSample::sealed
class | SDKSample::sealed
class | SDKSample::StringHelper

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/MainPage.xaml.cpp File Reference

  • AtomPub

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/MainPage.xaml.h File Reference

  • AtomPub
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/pch.cpp File Reference

  • AtomPub

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/pch.h File Reference

  • AtomPub

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario1.xaml.cpp File Reference

  • AtomPub

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario1.xaml.h File Reference

  • AtomPub
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::AtomPub::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::AtomPub
Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario2.xaml.cpp File Reference

  • AtomPub

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario2.xaml.h File Reference

  • AtomPub
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::AtomPub::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::AtomPub
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario3.xaml.cpp File Reference

  • AtomPub

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario3.xaml.h File Reference

  • AtomPub
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::AtomPub::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::AtomPub
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario4.xaml.cpp File Reference

  • AtomPub

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario4.xaml.h File Reference

  • AtomPub
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::AtomPub::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::AtomPub
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/common/LayoutAwarePage.cpp File Reference

  • AtomPub
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/common/LayoutAwarePage.h File Reference

  • AtomPub
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/common/suspensionmanager.cpp File Reference

  • AtomPub
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/common/suspensionmanager.h File Reference

  • AtomPub
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/App.xaml.cpp File Reference

  • Background task
  • BackgroundTask

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/App.xaml.h File Reference

  • Background task
  • BackgroundTask
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/Constants.cpp File Reference

  • Background task
  • BackgroundTask

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/Constants.h File Reference

  • Background task
  • BackgroundTask
Classes | Namespaces | Defines

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::BackgroundTask::BackgroundTaskSample
class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
namespace | SDKSample::BackgroundTask

Defines

#define | SampleBackgroundTaskEntryPoint "Tasks.SampleBackgroundTask"
#define | SampleBackgroundTaskName "SampleBackgroundTask"
#define | SampleBackgroundTaskWithConditionName "SampleBackgroundTaskWithCondition"
#define | ServicingCompleteTaskEntryPoint "Tasks.ServicingComplete"
#define | ServicingCompleteTaskName "ServicingCompleteTask"
#define | TimeTriggeredTaskName "TimeTriggeredTask"

Define Documentation

#define SampleBackgroundTaskEntryPoint "Tasks.SampleBackgroundTask"

Definition at line 19 of file Constants.h.

#define SampleBackgroundTaskName "SampleBackgroundTask"

Definition at line 20 of file Constants.h.

#define SampleBackgroundTaskWithConditionName "SampleBackgroundTaskWithCondition"

Definition at line 21 of file Constants.h.

#define ServicingCompleteTaskEntryPoint "Tasks.ServicingComplete"

Definition at line 22 of file Constants.h.

#define ServicingCompleteTaskName "ServicingCompleteTask"

Definition at line 23 of file Constants.h.

#define TimeTriggeredTaskName "TimeTriggeredTask"

Definition at line 24 of file Constants.h.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/MainPage.xaml.cpp File Reference

  • Background task
  • BackgroundTask

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/MainPage.xaml.h File Reference

  • Background task
  • BackgroundTask
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/pch.cpp File Reference

  • Background task
  • BackgroundTask

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/pch.h File Reference

  • Background task
  • BackgroundTask

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/SampleBackgroundTask.xaml.cpp File Reference

  • Background task
  • BackgroundTask

SampleBackgroundTask.xaml.cpp File Reference

#include "pch.h"
#include "SampleBackgroundTask.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/SampleBackgroundTask.xaml.h File Reference

  • Background task
  • BackgroundTask
Classes | Namespaces

SampleBackgroundTask.xaml.h File Reference

#include "pch.h"
#include "SampleBackgroundTask.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::BackgroundTask::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::BackgroundTask
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/ServicingCompleteTask.xaml.h File Reference

  • Background task
  • BackgroundTask
Classes | Namespaces

ServicingCompleteTask.xaml.h File Reference

#include "pch.h"
#include "ServicingCompleteTask.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::BackgroundTask::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::BackgroundTask
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/TimeTriggeredTask.xaml.cpp File Reference

  • Background task
  • BackgroundTask

TimeTriggeredTask.xaml.cpp File Reference

#include "pch.h"
#include "TimeTriggeredTask.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/TimeTriggeredTask.xaml.h File Reference

  • Background task
  • BackgroundTask
Classes | Namespaces

TimeTriggeredTask.xaml.h File Reference

#include "pch.h"
#include "TimeTriggeredTask.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::BackgroundTask::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::BackgroundTask
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/common/LayoutAwarePage.cpp File Reference

  • Background task
  • BackgroundTask
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/common/LayoutAwarePage.h File Reference

  • Background task
  • BackgroundTask
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/common/suspensionmanager.cpp File Reference

  • Background task
  • BackgroundTask
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/common/suspensionmanager.h File Reference

  • Background task
  • BackgroundTask
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/pch.cpp File Reference

  • Background task
  • Tasks

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/pch.h File Reference

  • Background task
  • Tasks

pch.h File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/SampleBackgroundTask.cpp File Reference

  • Background task
  • Tasks

SampleBackgroundTask.cpp File Reference

#include "pch.h"
#include "SampleBackgroundTask.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/SampleBackgroundTask.h File Reference

  • Background task
  • Tasks
Classes | Namespaces

SampleBackgroundTask.h File Reference

#include "pch.h"
#include <agile.h>

Go to the source code of this file.

Classes

class | Tasks::sealed

Namespaces

namespace | Tasks
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/ServicingComplete.cpp File Reference

  • Background task
  • Tasks

ServicingComplete.cpp File Reference

#include "pch.h"
#include "ServicingComplete.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/ServicingComplete.h File Reference

  • Background task
  • Tasks
Classes | Namespaces

ServicingComplete.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | Tasks::sealed

Namespaces

namespace | Tasks
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/App.xaml.cpp File Reference

  • Background Transfer

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/App.xaml.h File Reference

  • Background Transfer
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Constants.cpp File Reference

  • Background Transfer

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Constants.h File Reference

  • Background Transfer
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario
class | SDKSample::StringTrimmer

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/MainPage.xaml.cpp File Reference

  • Background Transfer

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/MainPage.xaml.h File Reference

  • Background Transfer
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/pch.cpp File Reference

  • Background Transfer

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/pch.h File Reference

  • Background Transfer

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Scenario1.xaml.cpp File Reference

  • Background Transfer

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Scenario1.xaml.h File Reference

  • Background Transfer
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

struct | SDKSample::BackgroundTransfer::GuidComparer
class | SDKSample::BackgroundTransfer::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::BackgroundTransfer
Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Scenario2.xaml.cpp File Reference

  • Background Transfer

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Scenario2.xaml.h File Reference

  • Background Transfer
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"
#include "Collection.h"

Go to the source code of this file.

Classes

class | SDKSample::BackgroundTransfer::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::BackgroundTransfer
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/common/LayoutAwarePage.cpp File Reference

  • Background Transfer
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/common/LayoutAwarePage.h File Reference

  • Background Transfer
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/common/suspensionmanager.cpp File Reference

  • Background Transfer
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/common/suspensionmanager.h File Reference

  • Background Transfer
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/AntSystem.cpp File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp
Classes | Namespaces | Functions

AntSystem.cpp File Reference

#include "pch.h"
#include "AntSystem.h"
#include <assert.h>

Go to the source code of this file.

Classes

class | AntSystem::Ant

Namespaces

namespace | AntSystem

Functions

double | AntSystem::ComputeHeuristicShortestDistance (const vector< shared_ptr< Node >> &nodes, const vector< shared_ptr< Edge >> &edges)
double | AntSystem::ComputeLengthOfRoute (const vector< shared_ptr< Node >> &nodes, const vector< size_t > &indices, const vector< shared_ptr< Edge >> &edges)
template<typename IterType >
IterType::value_type | AntSystem::FindEdge (IterType firstEdge, IterType lastEdge, const shared_ptr< Node > pointA, const shared_ptr< Node > pointB)
vector< size_t > | AntSystem::OptimizeRoute (vector< shared_ptr< Node >> &nodes, vector< shared_ptr< Edge >> &edges, double alpha, double beta, double rho, unsigned int iterations, cancellation_token cancellationToken, function< void(unsigned int)> *progressCallback, bool parallel)
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/AntSystem.h File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp
Classes | Namespaces | Functions

AntSystem.h File Reference

Go to the source code of this file.

Classes

struct | AntSystem::Edge
struct | AntSystem::LatLong
struct | AntSystem::Node

Namespaces

namespace | AntSystem

Functions

std::vector< size_t > | AntSystem::OptimizeRoute (std::vector< std::shared_ptr< Node >> &nodes, std::vector< std::shared_ptr< Edge >> &edges, double alpha, double beta, double rho, unsigned int iterations, concurrency::cancellation_token cancellationToken, std::function< void(unsigned int)> *progressCallback=nullptr, bool parallel=true)
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.cpp File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp
Classes

HttpRequest.cpp File Reference

#include "pch.h"
#include "HttpRequest.h"
#include <robuffer.h>
#include <shcore.h>

Go to the source code of this file.

Classes

class HttpRequestStringCallback
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.h File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp
Classes | Namespaces | Functions

HttpRequest.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | Web::Details::HttpRequestBuffersCallback
class | Web::HttpRequest

Namespaces

namespace | Web
namespace | Web::Details

Functions

void | CheckHResult (HRESULT hResult)

Function Documentation

void CheckHResult ( HRESULT hResult ) [inline]

Definition at line 14 of file HttpRequest.h.

{
    if (hResult == E_ABORT)
    {
        concurrency::cancel_current_task();
    }
    else if (FAILED(hResult))
    {
        throw Platform::Exception::CreateException(hResult);
    }
}

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/pch.cpp File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/pch.h File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp

pch.h File Reference

#include <collection.h>
#include <concurrent_vector.h>
#include <list>
#include <msxml6.h>
#include <ppltasks.h>
#include <sstream>
#include <strsafe.h>
#include <wrl.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizer.cpp File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp

TripOptimizer.cpp File Reference

#include "pch.h"
#include "TripOptimizer.h"
#include "TripOptimizerImpl.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizer.h File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp
Classes | Namespaces

TripOptimizer.h File Reference

Go to the source code of this file.

Classes

class | TripOptimizerComponent::sealed

Namespaces

namespace | TripOptimizerComponent
namespace | TripOptimizerComponent::Details
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizerImpl.h File Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp
Classes | Namespaces

TripOptimizerImpl.h File Reference

#include "pch.h"
#include "AntSystem.h"

Go to the source code of this file.

Classes

class | TripOptimizerComponent::Details::TripOptimizerImpl
struct | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams

Namespaces

namespace | TripOptimizerComponent
namespace | TripOptimizerComponent::Details
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/App.xaml.cpp File Reference

  • Bluetooth call control

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/App.xaml.h File Reference

  • Bluetooth call control
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/Constants.cpp File Reference

  • Bluetooth call control

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/Constants.h File Reference

  • Bluetooth call control
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/MainPage.xaml.cpp File Reference

  • Bluetooth call control

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/MainPage.xaml.h File Reference

  • Bluetooth call control
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/pch.cpp File Reference

  • Bluetooth call control

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/pch.h File Reference

  • Bluetooth call control

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/PhoneCall.xaml.cpp File Reference

  • Bluetooth call control

PhoneCall.xaml.cpp File Reference

#include "pch.h"
#include "PhoneCall.xaml.h"
#include "ppltasks.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/PhoneCall.xaml.h File Reference

  • Bluetooth call control
Classes | Namespaces

PhoneCall.xaml.h File Reference

#include "pch.h"
#include "PhoneCall.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CallControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CallControl
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/common/LayoutAwarePage.cpp File Reference

  • Bluetooth call control
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/common/LayoutAwarePage.h File Reference

  • Bluetooth call control
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/common/suspensionmanager.cpp File Reference

  • Bluetooth call control
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/common/suspensionmanager.h File Reference

  • Bluetooth call control
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/App.xaml.cpp File Reference

  • Calendar details and math

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/App.xaml.h File Reference

  • Calendar details and math
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/CalendarEnumerationAndMath.xaml.h File Reference

  • Calendar details and math
Classes | Namespaces

CalendarEnumerationAndMath.xaml.h File Reference

#include "pch.h"
#include "CalendarEnumerationAndMath.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CalendarSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CalendarSample
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/Constants.cpp File Reference

  • Calendar details and math

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/Constants.h File Reference

  • Calendar details and math
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/DisplayCalendarData.xaml.cpp File Reference

  • Calendar details and math

DisplayCalendarData.xaml.cpp File Reference

#include "pch.h"
#include "DisplayCalendarData.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/DisplayCalendarData.xaml.h File Reference

  • Calendar details and math
Classes | Namespaces

DisplayCalendarData.xaml.h File Reference

#include "pch.h"
#include "DisplayCalendarData.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CalendarSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CalendarSample
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/DisplayCalendarStatistics.xaml.cpp File Reference

  • Calendar details and math

DisplayCalendarStatistics.xaml.cpp File Reference

#include "pch.h"
#include "DisplayCalendarStatistics.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/DisplayCalendarStatistics.xaml.h File Reference

  • Calendar details and math
Classes | Namespaces

DisplayCalendarStatistics.xaml.h File Reference

#include "pch.h"
#include "DisplayCalendarStatistics.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CalendarSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CalendarSample
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/MainPage.xaml.cpp File Reference

  • Calendar details and math

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/MainPage.xaml.h File Reference

  • Calendar details and math
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/pch.cpp File Reference

  • Calendar details and math

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/pch.h File Reference

  • Calendar details and math

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/common/LayoutAwarePage.cpp File Reference

  • Calendar details and math
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/common/LayoutAwarePage.h File Reference

  • Calendar details and math
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/common/suspensionmanager.cpp File Reference

  • Calendar details and math
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/common/suspensionmanager.h File Reference

  • Calendar details and math
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/App.xaml.cpp File Reference

  • CameraCaptureUI

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/App.xaml.h File Reference

  • CameraCaptureUI
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/CapturePhoto.xaml.cpp File Reference

  • CameraCaptureUI

CapturePhoto.xaml.cpp File Reference

#include "pch.h"
#include "CapturePhoto.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/CapturePhoto.xaml.h File Reference

  • CameraCaptureUI
Classes | Namespaces

CapturePhoto.xaml.h File Reference

#include "pch.h"
#include "CapturePhoto.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CameraCapture::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CameraCapture
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/CaptureVideo.xaml.cpp File Reference

  • CameraCaptureUI

CaptureVideo.xaml.cpp File Reference

#include "pch.h"
#include "CaptureVideo.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/CaptureVideo.xaml.h File Reference

  • CameraCaptureUI
Classes | Namespaces

CaptureVideo.xaml.h File Reference

#include "pch.h"
#include "CaptureVideo.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CameraCapture::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CameraCapture
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/Constants.cpp File Reference

  • CameraCaptureUI

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/Constants.h File Reference

  • CameraCaptureUI
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/MainPage.xaml.cpp File Reference

  • CameraCaptureUI

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/MainPage.xaml.h File Reference

  • CameraCaptureUI
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/pch.cpp File Reference

  • CameraCaptureUI

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/pch.h File Reference

  • CameraCaptureUI

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/common/LayoutAwarePage.cpp File Reference

  • CameraCaptureUI
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/common/LayoutAwarePage.h File Reference

  • CameraCaptureUI
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/common/suspensionmanager.cpp File Reference

  • CameraCaptureUI
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/common/suspensionmanager.h File Reference

  • CameraCaptureUI
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/App.xaml.cpp File Reference

  • CameraOptionsUI

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/App.xaml.h File Reference

  • CameraOptionsUI
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/Constants.cpp File Reference

  • CameraOptionsUI

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/Constants.h File Reference

  • CameraOptionsUI
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/MainPage.xaml.cpp File Reference

  • CameraOptionsUI

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/MainPage.xaml.h File Reference

  • CameraOptionsUI
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/pch.cpp File Reference

  • CameraOptionsUI

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/pch.h File Reference

  • CameraOptionsUI

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/ShowOptionsUI.xaml.cpp File Reference

  • CameraOptionsUI

ShowOptionsUI.xaml.cpp File Reference

#include "pch.h"
#include "ShowOptionsUI.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/ShowOptionsUI.xaml.h File Reference

  • CameraOptionsUI
Classes | Namespaces

ShowOptionsUI.xaml.h File Reference

#include "pch.h"
#include "ShowOptionsUI.g.h"
#include "MainPage.xaml.h"
#include <agile.h>

Go to the source code of this file.

Classes

class | SDKSample::CameraOptions::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CameraOptions
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/common/LayoutAwarePage.cpp File Reference

  • CameraOptionsUI
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/common/LayoutAwarePage.h File Reference

  • CameraOptionsUI
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/common/suspensionmanager.cpp File Reference

  • CameraOptionsUI
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/common/suspensionmanager.h File Reference

  • CameraOptionsUI
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/App.xaml.cpp File Reference

  • Certificate enrollment

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/App.xaml.h File Reference

  • Certificate enrollment
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/Constants.cpp File Reference

  • Certificate enrollment

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/Constants.h File Reference

  • Certificate enrollment
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/HttpRequest.cpp File Reference

  • Certificate enrollment
Classes

HttpRequest.cpp File Reference

#include "pch.h"
#include "HttpRequest.h"
#include <robuffer.h>
#include <shcore.h>

Go to the source code of this file.

Classes

class HttpRequestStringCallback
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/HttpRequest.h File Reference

  • Certificate enrollment
Classes | Namespaces | Functions

HttpRequest.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | Web::Details::HttpRequestBuffersCallback
class | Web::HttpRequest

Namespaces

namespace | Web
namespace | Web::Details

Functions

void | CheckHResult (HRESULT hResult)

Function Documentation

void CheckHResult ( HRESULT hResult ) [inline]

Definition at line 14 of file HttpRequest.h.

{
    if (hResult == E_ABORT)
    {
        concurrency::cancel_current_task();
    }
    else if (FAILED(hResult))
    {
        throw Platform::Exception::CreateException(hResult);
    }
}

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/MainPage.xaml.cpp File Reference

  • Certificate enrollment

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/MainPage.xaml.h File Reference

  • Certificate enrollment
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/pch.cpp File Reference

  • Certificate enrollment

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/pch.h File Reference

  • Certificate enrollment
Defines

pch.h File Reference

#include <Windows.h>
#include <wrl.h>
#include <wrl\implements.h>
#include <Shcore.h>
#include <MsXml6.h>
#include <collection.h>
#include <ppltasks.h>
#include <sstream>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Defines

#define CHKHR(stmt) do { hr = (stmt); if (FAILED(hr)) goto Exit; } while(0)

Define Documentation

#define CHKHR ( stmt ) do { hr = (stmt); if (FAILED(hr)) goto Exit; } while(0)

Definition at line 27 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/Scenario_Enroll.xaml.cpp File Reference

  • Certificate enrollment

Scenario_Enroll.xaml.cpp File Reference

#include "pch.h"
#include "Scenario_Enroll.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/Scenario_Enroll.xaml.h File Reference

  • Certificate enrollment
Classes | Namespaces

Scenario_Enroll.xaml.h File Reference

#include "pch.h"
#include "Scenario_Enroll.g.h"
#include "MainPage.xaml.h"
#include "HttpRequest.h"

Go to the source code of this file.

Classes

class | SDKSample::CertificateEnrollment::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CertificateEnrollment
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/Scenario_Import.xaml.cpp File Reference

  • Certificate enrollment

Scenario_Import.xaml.cpp File Reference

#include "pch.h"
#include "Scenario_Import.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/Scenario_Import.xaml.h File Reference

  • Certificate enrollment
Classes | Namespaces

Scenario_Import.xaml.h File Reference

#include "pch.h"
#include "Scenario_Import.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CertificateEnrollment::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CertificateEnrollment
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/common/LayoutAwarePage.cpp File Reference

  • Certificate enrollment
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/common/LayoutAwarePage.h File Reference

  • Certificate enrollment
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/common/suspensionmanager.cpp File Reference

  • Certificate enrollment
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/common/suspensionmanager.h File Reference

  • Certificate enrollment
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/App.xaml.cpp File Reference

  • Check if current session is remote

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/App.xaml.h File Reference

  • Check if current session is remote
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/Constants.cpp File Reference

  • Check if current session is remote

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/Constants.h File Reference

  • Check if current session is remote
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/MainPage.xaml.cpp File Reference

  • Check if current session is remote

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/MainPage.xaml.h File Reference

  • Check if current session is remote
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/pch.cpp File Reference

  • Check if current session is remote

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/pch.h File Reference

  • Check if current session is remote

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/RemoteSession.xaml.cpp File Reference

  • Check if current session is remote

RemoteSession.xaml.cpp File Reference

#include "pch.h"
#include "Wrl.h"
#include "RemoteSession.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/RemoteSession.xaml.h File Reference

  • Check if current session is remote
Classes | Namespaces

RemoteSession.xaml.h File Reference

#include "pch.h"
#include "RemoteSession.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::IsRemoteSession::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::IsRemoteSession
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/common/LayoutAwarePage.h File Reference

  • Check if current session is remote
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/App.xaml.cpp File Reference

  • Clipboard app

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/App.xaml.h File Reference

  • Clipboard app
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | Clipboard::App

Namespaces

namespace | Clipboard
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/constants.cpp File Reference

  • Clipboard app

constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/constants.h File Reference

  • Clipboard app
Classes | Namespaces

constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | Clipboard::MainPage
struct | Clipboard::Scenario

Namespaces

namespace | Clipboard
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CopyFiles.xaml.cpp File Reference

  • Clipboard app

CopyFiles.xaml.cpp File Reference

#include "pch.h"
#include "CopyFiles.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CopyFiles.xaml.h File Reference

  • Clipboard app
Classes | Namespaces

CopyFiles.xaml.h File Reference

#include "pch.h"
#include "CopyFiles.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | Clipboard::sealed

Namespaces

namespace | Clipboard
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CopyImage.xaml.cpp File Reference

  • Clipboard app

CopyImage.xaml.cpp File Reference

#include "pch.h"
#include "CopyImage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CopyImage.xaml.h File Reference

  • Clipboard app
Classes | Namespaces

CopyImage.xaml.h File Reference

#include "pch.h"
#include "CopyImage.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | Clipboard::sealed

Namespaces

namespace | Clipboard
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CopyText.xaml.cpp File Reference

  • Clipboard app

CopyText.xaml.cpp File Reference

#include "pch.h"
#include "CopyText.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CopyText.xaml.h File Reference

  • Clipboard app
Classes | Namespaces

CopyText.xaml.h File Reference

#include "pch.h"
#include "CopyText.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | Clipboard::sealed

Namespaces

namespace | Clipboard
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CppSamplesUtils.h File Reference

  • Clipboard app
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/MainPage.xaml.cpp File Reference

  • Clipboard app

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/MainPage.xaml.h File Reference

  • Clipboard app
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | Clipboard::sealed
class | Clipboard::sealed

Namespaces

namespace | Clipboard

Enumerations

enum | Clipboard::NotifyType { Clipboard::StatusMessage, Clipboard::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/Others.xaml.cpp File Reference

  • Clipboard app

Others.xaml.cpp File Reference

#include "pch.h"
#include "Others.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/Others.xaml.h File Reference

  • Clipboard app
Classes | Namespaces

Others.xaml.h File Reference

#include "pch.h"
#include "Others.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | Clipboard::sealed

Namespaces

namespace | Clipboard
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/pch.cpp File Reference

  • Clipboard app

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/pch.h File Reference

  • Clipboard app

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/common/LayoutAwarePage.cpp File Reference

  • Clipboard app
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/common/LayoutAwarePage.h File Reference

  • Clipboard app
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | Clipboard::Common::LayoutAwarePage

Namespaces

namespace | Clipboard
namespace | Clipboard::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/sample-utils/CppSamplesUtils.h File Reference

  • Clipboard app
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/App.xaml.cpp File Reference

  • Compass sensor

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/App.xaml.h File Reference

  • Compass sensor
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/Constants.cpp File Reference

  • Compass sensor

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/Constants.h File Reference

  • Compass sensor
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/MainPage.xaml.cpp File Reference

  • Compass sensor

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/MainPage.xaml.h File Reference

  • Compass sensor
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/pch.cpp File Reference

  • Compass sensor

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/pch.h File Reference

  • Compass sensor

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/Scenario1.xaml.cpp File Reference

  • Compass sensor

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/Scenario1.xaml.h File Reference

  • Compass sensor
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CompassCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CompassCPP
Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/Scenario2.xaml.cpp File Reference

  • Compass sensor

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/Scenario2.xaml.h File Reference

  • Compass sensor
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CompassCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CompassCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/common/LayoutAwarePage.cpp File Reference

  • Compass sensor
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/common/LayoutAwarePage.h File Reference

  • Compass sensor
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/common/suspensionmanager.cpp File Reference

  • Compass sensor
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/common/suspensionmanager.h File Reference

  • Compass sensor
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/App.xaml.cpp File Reference

  • Compression

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/App.xaml.h File Reference

  • Compression
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/CompressionUtils.cpp File Reference

  • Compression
Classes

CompressionUtils.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"
#include "CompressionUtils.h"

Go to the source code of this file.

Classes

struct ReadStreamTask::ReadStreamTaskImpl
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/CompressionUtils.h File Reference

  • Compression
Classes

CompressionUtils.h File Reference

Go to the source code of this file.

Classes

class | ReadStreamTask
struct | ScenarioContext
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Constants.cpp File Reference

  • Compression

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Constants.h File Reference

  • Compression
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/MainPage.xaml.cpp File Reference

  • Compression

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/MainPage.xaml.h File Reference

  • Compression
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/pch.cpp File Reference

  • Compression

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/pch.h File Reference

  • Compression

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include <compressapi.h>
#include <sstream>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario1.xaml.cpp File Reference

  • Compression

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"
#include "CompressionUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario1.xaml.h File Reference

  • Compression
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Compression::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Compression
Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario2.xaml.cpp File Reference

  • Compression

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"
#include "CompressionUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario2.xaml.h File Reference

  • Compression
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Compression::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Compression
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario3.xaml.cpp File Reference

  • Compression

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"
#include "CompressionUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario3.xaml.h File Reference

  • Compression
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Compression::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Compression
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/common/LayoutAwarePage.cpp File Reference

  • Compression
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/common/LayoutAwarePage.h File Reference

  • Compression
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/common/suspensionmanager.cpp File Reference

  • Compression
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/common/suspensionmanager.h File Reference

  • Compression
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/App.xaml.cpp File Reference

  • Configure keys for media

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/App.xaml.h File Reference

  • Configure keys for media
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/Constants.cpp File Reference

  • Configure keys for media

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/Constants.h File Reference

  • Configure keys for media
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/MainPage.xaml.cpp File Reference

  • Configure keys for media

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/MainPage.xaml.h File Reference

  • Configure keys for media
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/mediabuttons.xaml.cpp File Reference

  • Configure keys for media

mediabuttons.xaml.cpp File Reference

#include "pch.h"
#include "mediabuttons.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/mediabuttons.xaml.h File Reference

  • Configure keys for media
Classes | Namespaces

mediabuttons.xaml.h File Reference

#include "pch.h"
#include "mediabuttons.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MediaButtons::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::MediaButtons::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::MediaButtons
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/pch.cpp File Reference

  • Configure keys for media

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/pch.h File Reference

  • Configure keys for media

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/common/LayoutAwarePage.cpp File Reference

  • Configure keys for media
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/common/LayoutAwarePage.h File Reference

  • Configure keys for media
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/common/suspensionmanager.cpp File Reference

  • Configure keys for media
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/common/suspensionmanager.h File Reference

  • Configure keys for media
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/sample-utils/CppSamplesUtils.h File Reference

  • Configure keys for media
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/App.xaml.cpp File Reference

  • Connecting with WebSockets

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/App.xaml.h File Reference

  • Connecting with WebSockets
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/Constants.cpp File Reference

  • Connecting with WebSockets

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/Constants.h File Reference

  • Connecting with WebSockets
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario
class | SDKSample::StringTrimmer

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/MainPage.xaml.cpp File Reference

  • Connecting with WebSockets

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/MainPage.xaml.h File Reference

  • Connecting with WebSockets
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/pch.cpp File Reference

  • Connecting with WebSockets

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/pch.h File Reference

  • Connecting with WebSockets

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/Scenario1.xaml.cpp File Reference

  • Connecting with WebSockets

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include <strsafe.h>
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/Scenario1.xaml.h File Reference

  • Connecting with WebSockets
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebSocket::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebSocket
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/Scenario2.xaml.cpp File Reference

  • Connecting with WebSockets

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/Scenario2.xaml.h File Reference

  • Connecting with WebSockets
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebSocket::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebSocket
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/common/LayoutAwarePage.cpp File Reference

  • Connecting with WebSockets
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/common/LayoutAwarePage.h File Reference

  • Connecting with WebSockets
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/common/suspensionmanager.cpp File Reference

  • Connecting with WebSockets
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/common/suspensionmanager.h File Reference

  • Connecting with WebSockets
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/App.xaml.cpp File Reference

  • Contact Picker app

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"
#include "MainPagePicker.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/App.xaml.h File Reference

  • Contact Picker app
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ContactPicker::App

Namespaces

namespace | ContactPicker
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Constants.cpp File Reference

  • Contact Picker app

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "MainPagePicker.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Constants.h File Reference

  • Contact Picker app
Classes | Namespaces | Enumerations

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | ContactPicker::MainPage
class | ContactPicker::MainPagePicker
struct | ContactPicker::Scenario

Namespaces

namespace | ContactPicker

Enumerations

enum | ContactPicker::NotifyType { ContactPicker::StatusMessage, ContactPicker::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ContactPickerPage.xaml.cpp File Reference

  • Contact Picker app
Functions

ContactPickerPage.xaml.cpp File Reference

#include "pch.h"
#include "ContactPickerPage.xaml.h"
#include "MainPagePicker.xaml.h"

Go to the source code of this file.

Functions

void AppendValue (Contact^contact, String^value, ContactFieldType type, ContactFieldCategory category)

Function Documentation

void AppendValue | ( | Contact^ | contact,
 |  | String^ | value,
 |  | ContactFieldType | type,
 |  | ContactFieldCategory | category
 | ) |  |

Definition at line 86 of file ContactPickerPage.xaml.cpp.

{
    if (!value->IsEmpty())
    {
        contact->Fields->Append(ref new ContactField(value, type, category));
    }
}

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ContactPickerPage.xaml.h File Reference

  • Contact Picker app
Classes | Namespaces

ContactPickerPage.xaml.h File Reference

#include "pch.h"
#include "ContactPickerPage.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ContactPicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
struct | ContactPicker::sealed::SampleContact

Namespaces

namespace | ContactPicker
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/MainPage.xaml.cpp File Reference

  • Contact Picker app

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/MainPage.xaml.h File Reference

  • Contact Picker app
Classes | Namespaces

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | ContactPicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | ContactPicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ContactPicker
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/MainPagePicker.xaml.cpp File Reference

  • Contact Picker app

MainPagePicker.xaml.cpp File Reference

#include "pch.h"
#include "MainPagePicker.xaml.h"
#include "Constants.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/MainPagePicker.xaml.h File Reference

  • Contact Picker app
Classes | Namespaces

MainPagePicker.xaml.h File Reference

#include "pch.h"
#include "MainPagePicker.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | ContactPicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | ContactPicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ContactPicker
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/pch.cpp File Reference

  • Contact Picker app

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/pch.h File Reference

  • Contact Picker app

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ScenarioMultiple.xaml.cpp File Reference

  • Contact Picker app

ScenarioMultiple.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioMultiple.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ScenarioMultiple.xaml.h File Reference

  • Contact Picker app
Classes | Namespaces

ScenarioMultiple.xaml.h File Reference

#include "pch.h"
#include "ScenarioMultiple.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ContactPicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ContactPicker
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ScenarioSingle.xaml.cpp File Reference

  • Contact Picker app
Functions

ScenarioSingle.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioSingle.xaml.h"

Go to the source code of this file.

Functions

void AppendContactFieldValues (TextBlock^header, TextBlock^content, IVectorView< Contacts::ContactField^>^fields)

Function Documentation

void AppendContactFieldValues | ( | TextBlock^ | header,
 |  | TextBlock^ | content,
 |  | IVectorView< Contacts::ContactField^>^ | fields
 | ) |  |

Definition at line 81 of file ScenarioSingle.xaml.cpp.

{
    if (fields->Size > 0)
    {
        String^ output = "";
        std::for_each(begin(fields), end(fields), [&output](Contacts::ContactField^ field)
        {
            output += field->Value + "\n";
        });

        header->Visibility = Visibility::Visible;
        content->Visibility = Visibility::Visible;
        content->Text = output;
    }
    else
    {
        header->Visibility = Visibility::Collapsed;
        content->Visibility = Visibility::Collapsed;
    }
}

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ScenarioSingle.xaml.h File Reference

  • Contact Picker app
Classes | Namespaces

ScenarioSingle.xaml.h File Reference

#include "pch.h"
#include "ScenarioSingle.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ContactPicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ContactPicker
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Common/LayoutAwarePage.cpp File Reference

  • Contact Picker app
  • Common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Common/LayoutAwarePage.h File Reference

  • Contact Picker app
  • Common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | ContactPicker::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | ContactPicker
namespace | ContactPicker::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Sample-Utils/CppSamplesUtils.h File Reference

  • Contact Picker app
  • Sample-Utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/App.xaml.cpp File Reference

  • Context menu

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/App.xaml.h File Reference

  • Context menu
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/Constants.cpp File Reference

  • Context menu

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/Constants.h File Reference

  • Context menu
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/MainPage.xaml.cpp File Reference

  • Context menu

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/MainPage.xaml.h File Reference

  • Context menu
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/pch.cpp File Reference

  • Context menu

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/pch.h File Reference

  • Context menu

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/Scenario1.xaml.cpp File Reference

  • Context menu

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/Scenario1.xaml.h File Reference

  • Context menu
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ContextMenu::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ContextMenu
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/Scenario2.xaml.cpp File Reference

  • Context menu

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/Scenario2.xaml.h File Reference

  • Context menu
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ContextMenu::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ContextMenu
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/common/LayoutAwarePage.cpp File Reference

  • Context menu
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/common/LayoutAwarePage.h File Reference

  • Context menu
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/common/suspensionmanager.cpp File Reference

  • Context menu
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/common/suspensionmanager.h File Reference

  • Context menu
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/C++/Background/Background.cpp File Reference

  • ControlChannelTrigger StreamSocket
  • Background

Background.cpp File Reference

#include "pch.h"
#include "Background.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/C++/Background/Background.h File Reference

  • ControlChannelTrigger StreamSocket
  • Background
Classes | Namespaces

Background.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | Background::sealed
class | Background::sealed
class | Background::sealed

Namespaces

namespace | Background
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/C++/Background/pch.cpp File Reference

  • ControlChannelTrigger StreamSocket
  • Background

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/C++/Background/pch.h File Reference

  • ControlChannelTrigger StreamSocket
  • Background

pch.h File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamWebSocket/C++/Background/pch.cpp File Reference

  • ControlChannelTrigger StreamWebSocket
  • Background

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamWebSocket/C++/Background/pch.h File Reference

  • ControlChannelTrigger StreamWebSocket
  • Background

pch.h File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/C++/Background/Background.h File Reference

  • ControlChannelTrigger XMLHTTPRequest
  • Background
Classes | Namespaces

Background.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | Background::sealed
class | Background::sealed
class | Background::sealed

Namespaces

namespace | Background
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/C++/Background/pch.cpp File Reference

  • ControlChannelTrigger XMLHTTPRequest
  • Background

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/C++/Background/pch.h File Reference

  • ControlChannelTrigger XMLHTTPRequest
  • Background

pch.h File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/App.xaml.cpp File Reference

  • Credential locker

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/App.xaml.h File Reference

  • Credential locker
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Constants.cpp File Reference

  • Credential locker

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Constants.h File Reference

  • Credential locker
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/MainPage.xaml.cpp File Reference

  • Credential locker

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/MainPage.xaml.h File Reference

  • Credential locker
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/pch.cpp File Reference

  • Credential locker

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/pch.h File Reference

  • Credential locker

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario1.xaml.cpp File Reference

  • Credential locker
Functions

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Functions

void | DebugPrint (Page^rootPage, Platform::String^Trace)
void | Reset1 (Page^rootPage)

Function Documentation

void DebugPrint | ( | Page^ | rootPage,
 |  | Platform::String^ | Trace
 | ) |  |

Definition at line 58 of file Scenario1.xaml.cpp.

{
    Page^ outputFrame = (Page^) rootPage;
    TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
    ErrorMessage->Text += Trace + "\r\n";
}

void Reset1 ( Page^ rootPage )

Definition at line 65 of file Scenario1.xaml.cpp.

{
    try
    {
        Page^ outputFrame = (Page^) rootPage;
        Page^ inputFrame = (Page^) rootPage;
        TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
        InputUserNameValue->Text = "";
        PasswordBox^ InputPasswordValue = (PasswordBox^)outputFrame->FindName("InputPasswordValue");
        InputPasswordValue->Password= "";
        TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
        ErrorMessage->Text = "";
        TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
        CheckBox^ SaveCredCheck = (CheckBox^) outputFrame->FindName("SaveCredCheck");
        SaveCredCheck->IsChecked = false;
    }
    catch (Platform::Exception^ Error)
    {
        DebugPrint(rootPage, Error->ToString());
    }
}

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario1.xaml.h File Reference

  • Credential locker
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PasswordVaultCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PasswordVaultCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario2.xaml.cpp File Reference

  • Credential locker
Functions

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Functions

void | CleanCombobox (Page^rootPage)
void | DebugPrint2 (Page^rootPage, Platform::String^Trace)
void | Reset2 (Page^rootPage)

Function Documentation

void CleanCombobox ( Page^ rootPage )

Definition at line 53 of file Scenario2.xaml.cpp.

{
  Page^ inputFrame = (Page^) rootPage;
  ComboBox^ SelectUser = (ComboBox^) inputFrame->FindName("SelectUser");
  try
    {
    SelectUser->SelectedIndex= -1;
    SelectUser->ItemsSource = ref new Vector<String ^>();
  }
    catch (Platform::Exception^ Error)
    {
    DebugPrint2(rootPage, Error->ToString());
    }
}

void DebugPrint2 | ( | Page^ | rootPage,
 |  | Platform::String^ | Trace
 | ) |  |

Definition at line 46 of file Scenario2.xaml.cpp.

{
    Page^ outputFrame = (Page^) rootPage;
    TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
    ErrorMessage->Text += Trace + "\r\n";
 }

void Reset2 ( Page^ rootPage )

Definition at line 68 of file Scenario2.xaml.cpp.

{
  try
    {
    Page^ outputFrame = (Page^) rootPage;
        Page^ inputFrame = (Page^) rootPage;
        TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
        InputUserNameValue->Text = "";
        PasswordBox^ InputPasswordValue = (PasswordBox^)outputFrame->FindName("InputPasswordValue");
        InputPasswordValue->Password= "";
        TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
        ErrorMessage->Text = "";
        TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
        CheckBox^ SaveCredCheck = (CheckBox^) outputFrame->FindName("SaveCredCheck");
        SaveCredCheck->IsChecked = false;
    CleanCombobox(rootPage);
  }
    catch (Platform::Exception^ Error)
    {
    DebugPrint2(rootPage, Error->ToString());
  }
}

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario2.xaml.h File Reference

  • Credential locker
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PasswordVaultCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PasswordVaultCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario3.xaml.cpp File Reference

  • Credential locker

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario3.xaml.h File Reference

  • Credential locker
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PasswordVaultCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PasswordVaultCPP
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario4.xaml.cpp File Reference

  • Credential locker
Functions

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Functions

void | CleanComboboxSc4 (Page^rootPage)
void | DebugPrintSc4 (Page^rootPage, Platform::String^Trace)
void | ResetSc4 (Page^rootPage)

Function Documentation

void CleanComboboxSc4 ( Page^ rootPage )

Definition at line 54 of file Scenario4.xaml.cpp.

{
  Page^ inputFrame = (Page^) rootPage;
  ComboBox^ SelectResource = (ComboBox^) inputFrame->FindName("SelectResource");
  ComboBox^ SelectUser = (ComboBox^) inputFrame->FindName("SelectUser");
  try
    {
    SelectUser->SelectedIndex= -1;
    SelectUser->ItemsSource = ref new Vector<String ^>();

    SelectResource->SelectedIndex= -1;
    SelectResource->ItemsSource = ref new Vector<String ^>();
  }
    catch (Platform::Exception^ Error)
    {
    DebugPrintSc4(rootPage, Error->ToString());
    }
}

void DebugPrintSc4 | ( | Page^ | rootPage,
 |  | Platform::String^ | Trace
 | ) |  |

Definition at line 47 of file Scenario4.xaml.cpp.

{
  Page^ outputFrame = (Page^) rootPage;
    TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
    ErrorMessage->Text += Trace + "\r\n";
 }

void ResetSc4 ( Page^ rootPage )

Definition at line 73 of file Scenario4.xaml.cpp.

{
  try
    {
    Page^ outputFrame = (Page^) rootPage;
        Page^ inputFrame = (Page^) rootPage;

    TextBox^ InputResourceValue = (TextBox^) outputFrame->FindName("InputResourceValue");
        InputResourceValue->Text = "";

        TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
        InputUserNameValue->Text = "";
        PasswordBox^ InputPasswordValue = (PasswordBox^)outputFrame->FindName("InputPasswordValue");
        InputPasswordValue->Password= "";
        TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
        ErrorMessage->Text = "";
        TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
        CheckBox^ SaveCredCheck = (CheckBox^) outputFrame->FindName("SaveCredCheck");
        SaveCredCheck->IsChecked = false;

  }
    catch (Platform::Exception^ Error)
    {
    DebugPrintSc4(rootPage, Error->ToString());
  }
}

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario4.xaml.h File Reference

  • Credential locker
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PasswordVaultCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PasswordVaultCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/common/LayoutAwarePage.cpp File Reference

  • Credential locker
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/common/LayoutAwarePage.h File Reference

  • Credential locker
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/common/suspensionmanager.cpp File Reference

  • Credential locker
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/common/suspensionmanager.h File Reference

  • Credential locker
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/App.xaml.cpp File Reference

  • Credential picker

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/App.xaml.h File Reference

  • Credential picker
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/CppSamplesUtils.h File Reference

  • Credential picker
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/MainPage.xaml.cpp File Reference

  • Credential picker

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/MainPage.xaml.h File Reference

  • Credential picker
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP

Enumerations

enum | CredentialPickerCPP::NotifyType { CredentialPickerCPP::StatusMessage, CredentialPickerCPP::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/pch.cpp File Reference

  • Credential picker

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/pch.h File Reference

  • Credential picker
Defines

pch.h File Reference

#include "CppSamplesUtils.h"
#include <ppltasks.h>
#include "CppSamplesUtils.h"

Go to the source code of this file.

Defines

#define USE_PPLTASKS

Define Documentation

#define USE_PPLTASKS

Definition at line 14 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioInput1.xaml.cpp File Reference

  • Credential picker

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioInput1.xaml.h File Reference

  • Credential picker
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioInput2.xaml.cpp File Reference

  • Credential picker

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioInput2.xaml.h File Reference

  • Credential picker
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioInput3.xaml.cpp File Reference

  • Credential picker

ScenarioInput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioInput3.xaml.h File Reference

  • Credential picker
Classes | Namespaces

ScenarioInput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioList.xaml.cpp File Reference

  • Credential picker

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioList.xaml.h File Reference

  • Credential picker
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioOutput1.xaml.cpp File Reference

  • Credential picker

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioOutput1.xaml.h File Reference

  • Credential picker
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioOutput2.xaml.cpp File Reference

  • Credential picker

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioOutput2.xaml.h File Reference

  • Credential picker
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioOutput3.xaml.cpp File Reference

  • Credential picker

ScenarioOutput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioOutput3.xaml.h File Reference

  • Credential picker
Classes | Namespaces

ScenarioOutput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | CredentialPickerCPP::sealed

Namespaces

namespace | CredentialPickerCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/App.xaml.cpp File Reference

  • CryptoWinRT

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/App.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Constants.cpp File Reference

  • CryptoWinRT

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Constants.h File Reference

  • CryptoWinRT
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/MainPage.xaml.cpp File Reference

  • CryptoWinRT

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/MainPage.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/pch.cpp File Reference

  • CryptoWinRT

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/pch.h File Reference

  • CryptoWinRT

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario1.xaml.cpp File Reference

  • CryptoWinRT

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario1.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario10.xaml.cpp File Reference

  • CryptoWinRT

Scenario10.xaml.cpp File Reference

#include "pch.h"
#include "Scenario10.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario10.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario10.xaml.h File Reference

#include "pch.h"
#include "Scenario10.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario2.xaml.cpp File Reference

  • CryptoWinRT

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario2.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario3.xaml.cpp File Reference

  • CryptoWinRT

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario3.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario4.xaml.cpp File Reference

  • CryptoWinRT

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario4.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario5.xaml.cpp File Reference

  • CryptoWinRT

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario5.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario6.xaml.cpp File Reference

  • CryptoWinRT

Scenario6.xaml.cpp File Reference

#include "pch.h"
#include "Scenario6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario6.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario6.xaml.h File Reference

#include "pch.h"
#include "Scenario6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario7.xaml.cpp File Reference

  • CryptoWinRT

Scenario7.xaml.cpp File Reference

#include "pch.h"
#include "Scenario7.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario7.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario7.xaml.h File Reference

#include "pch.h"
#include "Scenario7.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario8.xaml.cpp File Reference

  • CryptoWinRT

Scenario8.xaml.cpp File Reference

#include "pch.h"
#include "Scenario8.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario8.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario8.xaml.h File Reference

#include "pch.h"
#include "Scenario8.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario9.xaml.cpp File Reference

  • CryptoWinRT

Scenario9.xaml.cpp File Reference

#include "pch.h"
#include "Scenario9.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario9.xaml.h File Reference

  • CryptoWinRT
Classes | Namespaces

Scenario9.xaml.h File Reference

#include "pch.h"
#include "Scenario9.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CryptoWinRT::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CryptoWinRT
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/common/LayoutAwarePage.cpp File Reference

  • CryptoWinRT
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/common/LayoutAwarePage.h File Reference

  • CryptoWinRT
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/common/suspensionmanager.cpp File Reference

  • CryptoWinRT
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/common/suspensionmanager.h File Reference

  • CryptoWinRT
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/App.xaml.cs File Reference

  • Custom driver access
  • C#,C++
  • app_cs
Classes | Namespaces

App.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::App
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/Constants.cs File Reference

  • Custom driver access
  • C#,C++
  • app_cs
Classes | Namespaces

Constants.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::Scenario

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/DeviceList.cs File Reference

  • Custom driver access
  • C#,C++
  • app_cs
Classes | Namespaces

DeviceList.cs File Reference

Go to the source code of this file.

Classes

class | CustomDeviceAccess::DeviceList
class | CustomDeviceAccess::DeviceListEntry

Namespaces

namespace | CustomDeviceAccess
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/MainPage.xaml.cs File Reference

  • Custom driver access
  • C#,C++
  • app_cs
Classes | Namespaces | Enumerations

MainPage.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::MainPageSizeChangedEventArgs

Namespaces

namespace | SDKTemplate

Enumerations

enum SDKTemplate::NotifyType {
SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage, SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage,
SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage, SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/Scenario4_DeviceAsync.xaml.cs File Reference

  • Custom driver access
  • C#,C++
  • app_cs
Classes | Namespaces

Scenario4_DeviceAsync.xaml.cs File Reference

Go to the source code of this file.

Classes

class | CustomDeviceAccess::DeviceAsync
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | CustomDeviceAccess
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/common/LayoutAwarePage.cs File Reference

  • Custom driver access
  • C#,C++
  • app_cs
  • common
Classes | Namespaces

LayoutAwarePage.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
class | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
Implementation of IObservableMap that supports reentrancy for use as a default view model. More...
class | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs

Namespaces

namespace | SDKTemplate::Common
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/Properties/AssemblyInfo.cs File Reference

  • Custom driver access
  • C#,C++
  • app_cs
  • Properties

AssemblyInfo.cs File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/fx2device.cpp File Reference

  • Custom driver access
  • C#,C++
  • DLL

fx2device.cpp File Reference

#include "fx2device.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/fx2device.h File Reference

  • Custom driver access
  • C#,C++
  • DLL
Classes | Namespaces | Functions | Variables

fx2device.h File Reference

#include <specstrings.h>
#include <deviceaccess.h>
#include <winioctl.h>
#include <strsafe.h>
#include <wrl\client.h>
#include <ppltasks.h>
#include <functional>
#include "public.h"
#include "support.h"
#include "repeater.h"
#include "public.h"
#include "support.h"
#include "repeater.h"

Go to the source code of this file.

Classes

class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...
class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...
class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...

Namespaces

namespace | Samples
namespace | Samples::Devices
namespace | Samples::Devices::Fx2

Functions

public delegate void | Samples::Devices::Fx2::SwitchStateChangedHandler (Fx2Device^Sender, SwitchStateChangedEventArgs^EventArgs)
void | THROW_HR (HRESULT hr)

Variables

const BYTE | c_NumBarsInGraph = 8
const BYTE | c_NumSwitches = 8
const BYTE | c_SegmentMask []
const unsigned int | c_SegmentMaskCe = _countof(c_SegmentMask)

Function Documentation

void THROW_HR ( HRESULT hr ) [inline]

Definition at line 40 of file fx2device.h.

{
    if (hr != 0) {
        throw Platform::Exception::ReCreateException(hr);
    }
}

Variable Documentation

const BYTE c_NumBarsInGraph = 8

Definition at line 24 of file fx2device.h.

const BYTE c_NumSwitches = 8

Definition at line 25 of file fx2device.h.

const BYTE c_SegmentMask[]
Initial value:
 {
    0xD7,
    0x06,
    0xB3,
    0xA7,
    0x66,
    0xE5,
    0xF4,
    0x07,
    0xF7,
    0x67,
}

Definition at line 26 of file fx2device.h.

const unsigned int c_SegmentMaskCe = _countof(c_SegmentMask)

Definition at line 38 of file fx2device.h.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/public.h File Reference

  • Custom driver access
  • C#,C++
  • DLL
Classes | Defines | Typedefs

public.h File Reference

#include <initguid.h>
#include "WudfOsrUsbPublic.h"
#include <pshpack1.h>
#include <poppack.h>
#include "WudfOsrUsbPublic.h"

Go to the source code of this file.

Classes

struct | _BAR_GRAPH_STATE
struct | _FILE_PLAYBACK
struct | _SWITCH_STATE

Defines

#define | FILE_DEVICE_OSRUSBFX2 0x65500
#define | IOCTL_INDEX 0x800
#define | IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY
#define | IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY
#define | IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR
#define | IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE
#define | IOCTL_OSRUSBFX2_PLAY_FILE
#define | IOCTL_OSRUSBFX2_READ_SWITCHES
#define | IOCTL_OSRUSBFX2_REENUMERATE_DEVICE
#define | IOCTL_OSRUSBFX2_RESET_DEVICE
#define | IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY
#define | IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY
#define | SS_BOTTOM 0x80
#define | SS_BOTTOM_LEFT 0x10
#define | SS_BOTTOM_RIGHT 0x04
#define | SS_CENTER 0x20
#define | SS_DOT 0x08
#define | SS_TOP 0x01
#define | SS_TOP_LEFT 0x40
#define | SS_TOP_RIGHT 0x02

Typedefs

typedef struct _BAR_GRAPH_STATE | BAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK | FILE_PLAYBACK
typedef struct _BAR_GRAPH_STATE * | PBAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK * | PFILE_PLAYBACK
typedef struct _SWITCH_STATE * | PSWITCH_STATE
typedef struct _SWITCH_STATE | SWITCH_STATE

Define Documentation

#define FILE_DEVICE_OSRUSBFX2 0x65500

Definition at line 158 of file public.h.

#define IOCTL_INDEX 0x800

Definition at line 157 of file public.h.

#define IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 7, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 193 of file public.h.

#define IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX  + 4, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 175 of file public.h.

#define IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
                                                     IOCTL_INDEX,     \
                                                     METHOD_BUFFERED,         \
                                                     FILE_READ_ACCESS)

Definition at line 160 of file public.h.

#define IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX + 9, \
                                                    METHOD_OUT_DIRECT, \
                                                    FILE_READ_ACCESS)

Definition at line 204 of file public.h.

#define IOCTL_OSRUSBFX2_PLAY_FILE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,   \
                                           IOCTL_INDEX + 10,        \
                                           METHOD_BUFFERED,         \
                                           FILE_WRITE_ACCESS)

Definition at line 209 of file public.h.

#define IOCTL_OSRUSBFX2_READ_SWITCHES
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 6, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 187 of file public.h.

#define IOCTL_OSRUSBFX2_REENUMERATE_DEVICE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX  + 3,  \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 170 of file public.h.

#define IOCTL_OSRUSBFX2_RESET_DEVICE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
                                                     IOCTL_INDEX + 1, \
                                                     METHOD_BUFFERED,         \
                                                     FILE_WRITE_ACCESS)

Definition at line 165 of file public.h.

#define IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 8, \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 199 of file public.h.

#define IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX + 5, \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 181 of file public.h.

#define SS_BOTTOM 0x80

Definition at line 131 of file public.h.

#define SS_BOTTOM_LEFT 0x10

Definition at line 129 of file public.h.

#define SS_BOTTOM_RIGHT 0x04

Definition at line 130 of file public.h.

#define SS_CENTER 0x20

Definition at line 128 of file public.h.

#define SS_DOT 0x08

Definition at line 132 of file public.h.

#define SS_TOP 0x01

Definition at line 125 of file public.h.

#define SS_TOP_LEFT 0x40

Definition at line 126 of file public.h.

#define SS_TOP_RIGHT 0x02

Definition at line 127 of file public.h.

Typedef Documentation

typedef struct _BAR_GRAPH_STATE BAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK FILE_PLAYBACK
typedef struct _BAR_GRAPH_STATE * PBAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK * PFILE_PLAYBACK
typedef struct _SWITCH_STATE * PSWITCH_STATE
typedef struct _SWITCH_STATE SWITCH_STATE
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/repeater.h File Reference

  • Custom driver access
  • C#,C++
  • DLL
Classes | Namespaces | Typedefs

repeater.h File Reference

#include <strsafe.h>
#include <assert.h>
#include <functional>
#include <mutex>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | Samples::Devices::Repeater

Namespaces

namespace | Samples
namespace | Samples::Devices
namespace | Samples::Devices::Details

Typedefs

typedef std::function< void(void)> | Samples::Devices::Details::RepeaterStoppedFunction
typedef concurrency::task< bool > | Samples::Devices::Details::RepeaterTaskType
typedef std::function
< RepeaterTaskType(concurrency::cancellation_token,
concurrency::task_continuation_context)> 		Samples::Devices::Details::StartRepeaterTaskFunction
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/support.h File Reference

  • Custom driver access
  • C#,C++
  • DLL
Classes | Namespaces | Functions

support.h File Reference

#include <strsafe.h>
#include <assert.h>

Go to the source code of this file.

Classes

struct | Samples::Devices::DeviceControlResult

Namespaces

namespace | Samples
namespace | Samples::Devices

Functions

void | DbgPrint (PCWSTR FormatString,...)
delegate void | Samples::Devices::OnIoComplete (HRESULT Result, DWORD BytesReturned)
concurrency::task
< DeviceControlResult > 		Samples::Devices::StartIoctl (_In_ IDeviceIoControl *Device, _In_ ULONG DeviceControlCode, _In_reads_bytes_opt_(InputBufferCb) PUCHAR InputBuffer, _In_ ULONG InputBufferCb, _Out_writes_bytes_opt_(OutputBufferCb) PUCHAR OutputBuffer, _In_ ULONG OutputBufferCb, _Out_opt_ ULONG_PTR *CancelToken=NULL)

Function Documentation

void DbgPrint | ( | PCWSTR | FormatString,
 |  |  | ... |
 | ) |  |  | [inline]

Printf to the debugger /summary>

Definition at line 9 of file support.h.

                                               {
  WCHAR buffer[1024];
  static ULONG line = 0;
  va_list arglist;
  va_start(arglist, FormatString);

  StringCbPrintf(buffer, sizeof(buffer), L"%03d:", line++);
  OutputDebugString(buffer);

  StringCbVPrintf(buffer, sizeof(buffer), FormatString, arglist);
  OutputDebugString(buffer);
}

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/WUDFOsrUsbPublic.h File Reference

  • Custom driver access
  • C#,C++
  • DLL
Functions

WUDFOsrUsbPublic.h File Reference

Go to the source code of this file.

Functions

DEFINE_GUID (GUID_DEVINTERFACE_OSRUSBFX2, 0x573e8c73, 0xcb4, 0x4471, 0xa1, 0xbf, 0xfa, 0xb2, 0x6c, 0x31, 0xd3, 0x84)

Function Documentation

DEFINE_GUID | ( | GUID_DEVINTERFACE_OSRUSBFX2 | ,
 |  | 0x573e8c73 | ,
 |  | 0xcb4 | ,
 |  | 0x4471 | ,
 |  | 0xa1 | ,
 |  | 0xbf | ,
 |  | 0xfa | ,
 |  | 0xb2 | ,
 |  | 0x6c | ,
 |  | 0x31 | ,
 |  | 0xd3 | ,
 |  | 0x84 |
 | ) |  |
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/fx2device.cpp File Reference

  • Custom driver access
  • C++,JavaScript
  • DLL

fx2device.cpp File Reference

#include "fx2device.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/fx2device.h File Reference

  • Custom driver access
  • C++,JavaScript
  • DLL
Classes | Namespaces | Functions | Variables

fx2device.h File Reference

#include <specstrings.h>
#include <deviceaccess.h>
#include <winioctl.h>
#include <strsafe.h>
#include <wrl\client.h>
#include <ppltasks.h>
#include <functional>
#include "public.h"
#include "support.h"
#include "repeater.h"

Go to the source code of this file.

Classes

class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...
class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...
class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...

Namespaces

namespace | Samples
namespace | Samples::Devices
namespace | Samples::Devices::Fx2

Functions

public delegate void | Samples::Devices::Fx2::SwitchStateChangedHandler (Fx2Device^Sender, SwitchStateChangedEventArgs^EventArgs)
void | THROW_HR (HRESULT hr)

Variables

const BYTE | c_NumBarsInGraph = 8
const BYTE | c_NumSwitches = 8
const BYTE | c_SegmentMask []
const unsigned int | c_SegmentMaskCe = _countof(c_SegmentMask)

Function Documentation

void THROW_HR ( HRESULT hr ) [inline]

Definition at line 40 of file fx2device.h.

{
    if (hr != 0) {
        throw Platform::Exception::ReCreateException(hr);
    }
}

Variable Documentation

const BYTE c_NumBarsInGraph = 8

Definition at line 24 of file fx2device.h.

const BYTE c_NumSwitches = 8

Definition at line 25 of file fx2device.h.

const BYTE c_SegmentMask[]
Initial value:
 {
    0xD7,
    0x06,
    0xB3,
    0xA7,
    0x66,
    0xE5,
    0xF4,
    0x07,
    0xF7,
    0x67,
}

Definition at line 26 of file fx2device.h.

const unsigned int c_SegmentMaskCe = _countof(c_SegmentMask)

Definition at line 38 of file fx2device.h.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/public.h File Reference

  • Custom driver access
  • C++,JavaScript
  • DLL
Classes | Defines | Typedefs

public.h File Reference

#include <initguid.h>
#include "WudfOsrUsbPublic.h"
#include <pshpack1.h>
#include <poppack.h>

Go to the source code of this file.

Classes

struct | _BAR_GRAPH_STATE
struct | _FILE_PLAYBACK
struct | _SWITCH_STATE

Defines

#define | FILE_DEVICE_OSRUSBFX2 0x65500
#define | IOCTL_INDEX 0x800
#define | IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY
#define | IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY
#define | IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR
#define | IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE
#define | IOCTL_OSRUSBFX2_PLAY_FILE
#define | IOCTL_OSRUSBFX2_READ_SWITCHES
#define | IOCTL_OSRUSBFX2_REENUMERATE_DEVICE
#define | IOCTL_OSRUSBFX2_RESET_DEVICE
#define | IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY
#define | IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY
#define | SS_BOTTOM 0x80
#define | SS_BOTTOM_LEFT 0x10
#define | SS_BOTTOM_RIGHT 0x04
#define | SS_CENTER 0x20
#define | SS_DOT 0x08
#define | SS_TOP 0x01
#define | SS_TOP_LEFT 0x40
#define | SS_TOP_RIGHT 0x02

Typedefs

typedef struct _BAR_GRAPH_STATE | BAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK | FILE_PLAYBACK
typedef struct _BAR_GRAPH_STATE * | PBAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK * | PFILE_PLAYBACK
typedef struct _SWITCH_STATE * | PSWITCH_STATE
typedef struct _SWITCH_STATE | SWITCH_STATE

Define Documentation

#define FILE_DEVICE_OSRUSBFX2 0x65500

Definition at line 158 of file public.h.

#define IOCTL_INDEX 0x800

Definition at line 157 of file public.h.

#define IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 7, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 193 of file public.h.

#define IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX  + 4, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 175 of file public.h.

#define IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
                                                     IOCTL_INDEX,     \
                                                     METHOD_BUFFERED,         \
                                                     FILE_READ_ACCESS)

Definition at line 160 of file public.h.

#define IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX + 9, \
                                                    METHOD_OUT_DIRECT, \
                                                    FILE_READ_ACCESS)

Definition at line 204 of file public.h.

#define IOCTL_OSRUSBFX2_PLAY_FILE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,   \
                                           IOCTL_INDEX + 10,        \
                                           METHOD_BUFFERED,         \
                                           FILE_WRITE_ACCESS)

Definition at line 209 of file public.h.

#define IOCTL_OSRUSBFX2_READ_SWITCHES
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 6, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 187 of file public.h.

#define IOCTL_OSRUSBFX2_REENUMERATE_DEVICE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX  + 3,  \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 170 of file public.h.

#define IOCTL_OSRUSBFX2_RESET_DEVICE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
                                                     IOCTL_INDEX + 1, \
                                                     METHOD_BUFFERED,         \
                                                     FILE_WRITE_ACCESS)

Definition at line 165 of file public.h.

#define IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 8, \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 199 of file public.h.

#define IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX + 5, \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 181 of file public.h.

#define SS_BOTTOM 0x80

Definition at line 131 of file public.h.

#define SS_BOTTOM_LEFT 0x10

Definition at line 129 of file public.h.

#define SS_BOTTOM_RIGHT 0x04

Definition at line 130 of file public.h.

#define SS_CENTER 0x20

Definition at line 128 of file public.h.

#define SS_DOT 0x08

Definition at line 132 of file public.h.

#define SS_TOP 0x01

Definition at line 125 of file public.h.

#define SS_TOP_LEFT 0x40

Definition at line 126 of file public.h.

#define SS_TOP_RIGHT 0x02

Definition at line 127 of file public.h.

Typedef Documentation

typedef struct _BAR_GRAPH_STATE BAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK FILE_PLAYBACK
typedef struct _BAR_GRAPH_STATE * PBAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK * PFILE_PLAYBACK
typedef struct _SWITCH_STATE * PSWITCH_STATE
typedef struct _SWITCH_STATE SWITCH_STATE
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/repeater.h File Reference

  • Custom driver access
  • C++,JavaScript
  • DLL
Classes | Namespaces

repeater.h File Reference

#include <strsafe.h>
#include <assert.h>
#include <functional>
#include <mutex>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | Samples::Devices::Repeater

Namespaces

namespace | Samples
namespace | Samples::Devices
namespace | Samples::Devices::Details
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/support.h File Reference

  • Custom driver access
  • C++,JavaScript
  • DLL
Classes | Namespaces | Functions

support.h File Reference

#include <strsafe.h>
#include <assert.h>

Go to the source code of this file.

Classes

struct | Samples::Devices::DeviceControlResult

Namespaces

namespace | Samples
namespace | Samples::Devices

Functions

void | DbgPrint (PCWSTR FormatString,...)
delegate void | Samples::Devices::OnIoComplete (HRESULT Result, DWORD BytesReturned)
concurrency::task
< DeviceControlResult > 		Samples::Devices::StartIoctl (_In_ IDeviceIoControl *Device, _In_ ULONG DeviceControlCode, _In_reads_bytes_opt_(InputBufferCb) PUCHAR InputBuffer, _In_ ULONG InputBufferCb, _Out_writes_bytes_opt_(OutputBufferCb) PUCHAR OutputBuffer, _In_ ULONG OutputBufferCb, _Out_opt_ ULONG_PTR *CancelToken=NULL)

Function Documentation

void DbgPrint | ( | PCWSTR | FormatString,
 |  |  | ... |
 | ) |  |  | [inline]

Printf to the debugger /summary>

Definition at line 9 of file support.h.

                                               {
  WCHAR buffer[1024];
  static ULONG line = 0;
  va_list arglist;
  va_start(arglist, FormatString);

  StringCbPrintf(buffer, sizeof(buffer), L"%03d:", line++);
  OutputDebugString(buffer);

  StringCbVPrintf(buffer, sizeof(buffer), FormatString, arglist);
  OutputDebugString(buffer);
}

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/WUDFOsrUsbPublic.h File Reference

  • Custom driver access
  • C++,JavaScript
  • DLL
Functions

WUDFOsrUsbPublic.h File Reference

Go to the source code of this file.

Functions

DEFINE_GUID (GUID_DEVINTERFACE_OSRUSBFX2, 0x573e8c73, 0xcb4, 0x4471, 0xa1, 0xbf, 0xfa, 0xb2, 0x6c, 0x31, 0xd3, 0x84)

Function Documentation

DEFINE_GUID | ( | GUID_DEVINTERFACE_OSRUSBFX2 | ,
 |  | 0x573e8c73 | ,
 |  | 0xcb4 | ,
 |  | 0x4471 | ,
 |  | 0xa1 | ,
 |  | 0xbf | ,
 |  | 0xfa | ,
 |  | 0xb2 | ,
 |  | 0x6c | ,
 |  | 0x31 | ,
 |  | 0xd3 | ,
 |  | 0x84 |
 | ) |  |
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/App.xaml.cpp File Reference

  • Custom driver access
  • app_cpp

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/App.xaml.h File Reference

  • Custom driver access
  • app_cpp
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Constants.cpp File Reference

  • Custom driver access
  • app_cpp

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Constants.h File Reference

  • Custom driver access
  • app_cpp
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/DeviceList.cpp File Reference

  • Custom driver access
  • app_cpp

DeviceList.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/DeviceList.h File Reference

  • Custom driver access
  • app_cpp
Classes | Namespaces | Typedefs

DeviceList.h File Reference

Go to the source code of this file.

Classes

class | SDKSample::CustomDeviceAccess::DeviceList
class | SDKSample::CustomDeviceAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CustomDeviceAccess

Typedefs

typedef
Windows::Foundation::EventHandler
< Samples::Devices::Fx2::Fx2Device^> 		SDKSample::CustomDeviceAccess::DeviceClosingHandler
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/MainPage.xaml.cpp File Reference

  • Custom driver access
  • app_cpp

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/MainPage.xaml.h File Reference

  • Custom driver access
  • app_cpp
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/pch.cpp File Reference

  • Custom driver access
  • app_cpp

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/pch.h File Reference

  • Custom driver access
  • app_cpp

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "DeviceList.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Scenario1_DeviceConnect.xaml.h File Reference

  • Custom driver access
  • app_cpp
Classes | Namespaces

Scenario1_DeviceConnect.xaml.h File Reference

#include "pch.h"
#include "Scenario1_DeviceConnect.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CustomDeviceAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CustomDeviceAccess
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Scenario3_DeviceEvents.xaml.cpp File Reference

  • Custom driver access
  • app_cpp

Scenario3_DeviceEvents.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3_DeviceEvents.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Scenario3_DeviceEvents.xaml.h File Reference

  • Custom driver access
  • app_cpp
Classes | Namespaces

Scenario3_DeviceEvents.xaml.h File Reference

#include "pch.h"
#include "Scenario3_DeviceEvents.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CustomDeviceAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CustomDeviceAccess
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Scenario4_DeviceAsync.xaml.cpp File Reference

  • Custom driver access
  • app_cpp

Scenario4_DeviceAsync.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4_DeviceAsync.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Scenario4_DeviceAsync.xaml.h File Reference

  • Custom driver access
  • app_cpp
Classes | Namespaces

Scenario4_DeviceAsync.xaml.h File Reference

#include "pch.h"
#include "Scenario4_DeviceAsync.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::CustomDeviceAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::CustomDeviceAccess
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/common/LayoutAwarePage.cpp File Reference

  • Custom driver access
  • app_cpp
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/common/LayoutAwarePage.h File Reference

  • Custom driver access
  • app_cpp
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/common/suspensionmanager.cpp File Reference

  • Custom driver access
  • app_cpp
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/common/suspensionmanager.h File Reference

  • Custom driver access
  • app_cpp
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/fx2device.cpp File Reference

  • Custom driver access
  • DLL

fx2device.cpp File Reference

#include "fx2device.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/fx2device.h File Reference

  • Custom driver access
  • DLL
Classes | Namespaces | Functions | Variables

fx2device.h File Reference

#include <specstrings.h>
#include <deviceaccess.h>
#include <winioctl.h>
#include <strsafe.h>
#include <wrl\client.h>
#include <ppltasks.h>
#include <functional>
#include "public.h"
#include "support.h"
#include "repeater.h"
#include "public.h"
#include "support.h"
#include "repeater.h"

Go to the source code of this file.

Classes

class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...
class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...
class | Samples::Devices::Fx2::sealed
The device projection for an OSR Fx2 device. More...

Namespaces

namespace | Samples
namespace | Samples::Devices
namespace | Samples::Devices::Fx2

Functions

public delegate void | Samples::Devices::Fx2::SwitchStateChangedHandler (Fx2Device^Sender, SwitchStateChangedEventArgs^EventArgs)
void | THROW_HR (HRESULT hr)

Variables

const BYTE | c_NumBarsInGraph = 8
const BYTE | c_NumSwitches = 8
const BYTE | c_SegmentMask []
const unsigned int | c_SegmentMaskCe = _countof(c_SegmentMask)

Function Documentation

void THROW_HR ( HRESULT hr ) [inline]

Definition at line 40 of file fx2device.h.

{
    if (hr != 0) {
        throw Platform::Exception::ReCreateException(hr);
    }
}

Variable Documentation

const BYTE c_NumBarsInGraph = 8

Definition at line 24 of file fx2device.h.

const BYTE c_NumSwitches = 8

Definition at line 25 of file fx2device.h.

const BYTE c_SegmentMask[]
Initial value:
 {
    0xD7,
    0x06,
    0xB3,
    0xA7,
    0x66,
    0xE5,
    0xF4,
    0x07,
    0xF7,
    0x67,
}

Definition at line 26 of file fx2device.h.

const unsigned int c_SegmentMaskCe = _countof(c_SegmentMask)

Definition at line 38 of file fx2device.h.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/public.h File Reference

  • Custom driver access
  • DLL
Classes | Defines | Typedefs

public.h File Reference

#include <initguid.h>
#include "WudfOsrUsbPublic.h"
#include <pshpack1.h>
#include <poppack.h>
#include "WudfOsrUsbPublic.h"

Go to the source code of this file.

Classes

struct | _BAR_GRAPH_STATE
struct | _FILE_PLAYBACK
struct | _SWITCH_STATE

Defines

#define | FILE_DEVICE_OSRUSBFX2 0x65500
#define | IOCTL_INDEX 0x800
#define | IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY
#define | IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY
#define | IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR
#define | IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE
#define | IOCTL_OSRUSBFX2_PLAY_FILE
#define | IOCTL_OSRUSBFX2_READ_SWITCHES
#define | IOCTL_OSRUSBFX2_REENUMERATE_DEVICE
#define | IOCTL_OSRUSBFX2_RESET_DEVICE
#define | IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY
#define | IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY
#define | SS_BOTTOM 0x80
#define | SS_BOTTOM_LEFT 0x10
#define | SS_BOTTOM_RIGHT 0x04
#define | SS_CENTER 0x20
#define | SS_DOT 0x08
#define | SS_TOP 0x01
#define | SS_TOP_LEFT 0x40
#define | SS_TOP_RIGHT 0x02

Typedefs

typedef struct _BAR_GRAPH_STATE | BAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK | FILE_PLAYBACK
typedef struct _BAR_GRAPH_STATE * | PBAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK * | PFILE_PLAYBACK
typedef struct _SWITCH_STATE * | PSWITCH_STATE
typedef struct _SWITCH_STATE | SWITCH_STATE

Define Documentation

#define FILE_DEVICE_OSRUSBFX2 0x65500

Definition at line 158 of file public.h.

#define IOCTL_INDEX 0x800

Definition at line 157 of file public.h.

#define IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 7, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 193 of file public.h.

#define IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX  + 4, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 175 of file public.h.

#define IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
                                                     IOCTL_INDEX,     \
                                                     METHOD_BUFFERED,         \
                                                     FILE_READ_ACCESS)

Definition at line 160 of file public.h.

#define IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX + 9, \
                                                    METHOD_OUT_DIRECT, \
                                                    FILE_READ_ACCESS)

Definition at line 204 of file public.h.

#define IOCTL_OSRUSBFX2_PLAY_FILE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,   \
                                           IOCTL_INDEX + 10,        \
                                           METHOD_BUFFERED,         \
                                           FILE_WRITE_ACCESS)

Definition at line 209 of file public.h.

#define IOCTL_OSRUSBFX2_READ_SWITCHES
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 6, \
                                                    METHOD_BUFFERED, \
                                                    FILE_READ_ACCESS)

Definition at line 187 of file public.h.

#define IOCTL_OSRUSBFX2_REENUMERATE_DEVICE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX  + 3,  \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 170 of file public.h.

#define IOCTL_OSRUSBFX2_RESET_DEVICE
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
                                                     IOCTL_INDEX + 1, \
                                                     METHOD_BUFFERED,         \
                                                     FILE_WRITE_ACCESS)

Definition at line 165 of file public.h.

#define IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
                                                    IOCTL_INDEX + 8, \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 199 of file public.h.

#define IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY
Value:
CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
                                                    IOCTL_INDEX + 5, \
                                                    METHOD_BUFFERED, \
                                                    FILE_WRITE_ACCESS)

Definition at line 181 of file public.h.

#define SS_BOTTOM 0x80

Definition at line 131 of file public.h.

#define SS_BOTTOM_LEFT 0x10

Definition at line 129 of file public.h.

#define SS_BOTTOM_RIGHT 0x04

Definition at line 130 of file public.h.

#define SS_CENTER 0x20

Definition at line 128 of file public.h.

#define SS_DOT 0x08

Definition at line 132 of file public.h.

#define SS_TOP 0x01

Definition at line 125 of file public.h.

#define SS_TOP_LEFT 0x40

Definition at line 126 of file public.h.

#define SS_TOP_RIGHT 0x02

Definition at line 127 of file public.h.

Typedef Documentation

typedef struct _BAR_GRAPH_STATE BAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK FILE_PLAYBACK
typedef struct _BAR_GRAPH_STATE * PBAR_GRAPH_STATE
typedef struct _FILE_PLAYBACK * PFILE_PLAYBACK
typedef struct _SWITCH_STATE * PSWITCH_STATE
typedef struct _SWITCH_STATE SWITCH_STATE
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/repeater.h File Reference

  • Custom driver access
  • DLL
Classes | Namespaces

repeater.h File Reference

#include <strsafe.h>
#include <assert.h>
#include <functional>
#include <mutex>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | Samples::Devices::Repeater

Namespaces

namespace | Samples
namespace | Samples::Devices
namespace | Samples::Devices::Details
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/support.h File Reference

  • Custom driver access
  • DLL
Classes | Namespaces | Functions

support.h File Reference

#include <strsafe.h>
#include <assert.h>

Go to the source code of this file.

Classes

struct | Samples::Devices::DeviceControlResult

Namespaces

namespace | Samples
namespace | Samples::Devices

Functions

void | DbgPrint (PCWSTR FormatString,...)
delegate void | Samples::Devices::OnIoComplete (HRESULT Result, DWORD BytesReturned)
concurrency::task
< DeviceControlResult > 		Samples::Devices::StartIoctl (_In_ IDeviceIoControl *Device, _In_ ULONG DeviceControlCode, _In_reads_bytes_opt_(InputBufferCb) PUCHAR InputBuffer, _In_ ULONG InputBufferCb, _Out_writes_bytes_opt_(OutputBufferCb) PUCHAR OutputBuffer, _In_ ULONG OutputBufferCb, _Out_opt_ ULONG_PTR *CancelToken=NULL)

Function Documentation

void DbgPrint | ( | PCWSTR | FormatString,
 |  |  | ... |
 | ) |  |  | [inline]

Printf to the debugger /summary>

Definition at line 9 of file support.h.

                                               {
  WCHAR buffer[1024];
  static ULONG line = 0;
  va_list arglist;
  va_start(arglist, FormatString);

  StringCbPrintf(buffer, sizeof(buffer), L"%03d:", line++);
  OutputDebugString(buffer);

  StringCbVPrintf(buffer, sizeof(buffer), FormatString, arglist);
  OutputDebugString(buffer);
}

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/WUDFOsrUsbPublic.h File Reference

  • Custom driver access
  • DLL
Functions

WUDFOsrUsbPublic.h File Reference

Go to the source code of this file.

Functions

DEFINE_GUID (GUID_DEVINTERFACE_OSRUSBFX2, 0x573e8c73, 0xcb4, 0x4471, 0xa1, 0xbf, 0xfa, 0xb2, 0x6c, 0x31, 0xd3, 0x84)

Function Documentation

DEFINE_GUID | ( | GUID_DEVINTERFACE_OSRUSBFX2 | ,
 |  | 0x573e8c73 | ,
 |  | 0xcb4 | ,
 |  | 0x4471 | ,
 |  | 0xa1 | ,
 |  | 0xbf | ,
 |  | 0xfa | ,
 |  | 0xb2 | ,
 |  | 0x6c | ,
 |  | 0x31 | ,
 |  | 0xd3 | ,
 |  | 0x84 |
 | ) |  |
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/App.xaml.cpp File Reference

  • DatagramSocket

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/App.xaml.h File Reference

  • DatagramSocket
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | DatagramSocketSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Constants.cpp File Reference

  • DatagramSocket

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Constants.h File Reference

  • DatagramSocket
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | DatagramSocketSample::MainPage
struct | DatagramSocketSample::Scenario

Namespaces

namespace | DatagramSocketSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/MainPage.xaml.cpp File Reference

  • DatagramSocket

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/MainPage.xaml.h File Reference

  • DatagramSocket
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | DatagramSocketSample

Enumerations

enum | DatagramSocketSample::NotifyType { DatagramSocketSample::StatusMessage, DatagramSocketSample::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/pch.cpp File Reference

  • DatagramSocket

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/pch.h File Reference

  • DatagramSocket

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario1.xaml.cpp File Reference

  • DatagramSocket

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario1.xaml.h File Reference

  • DatagramSocket
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | DatagramSocketSample
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario2.xaml.cpp File Reference

  • DatagramSocket

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario2.xaml.h File Reference

  • DatagramSocket
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | DatagramSocketSample
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario3.xaml.cpp File Reference

  • DatagramSocket

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario3.xaml.h File Reference

  • DatagramSocket
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | DatagramSocketSample
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario4.xaml.cpp File Reference

  • DatagramSocket

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario4.xaml.h File Reference

  • DatagramSocket
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | DatagramSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | DatagramSocketSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Common/LayoutAwarePage.cpp File Reference

  • DatagramSocket
  • Common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Common/LayoutAwarePage.h File Reference

  • DatagramSocket
  • Common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | DatagramSocketSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | DatagramSocketSample
namespace | DatagramSocketSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/sample-utils/CppSamplesUtils.h File Reference

  • DatagramSocket
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/App.xaml.cpp File Reference

  • Date and time formatting

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/App.xaml.h File Reference

  • Date and time formatting
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/Constants.cpp File Reference

  • Date and time formatting

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/Constants.h File Reference

  • Date and time formatting
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/LongAndShortFormats.xaml.cpp File Reference

  • Date and time formatting

LongAndShortFormats.xaml.cpp File Reference

#include "pch.h"
#include "LongAndShortFormats.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/LongAndShortFormats.xaml.h File Reference

  • Date and time formatting
Classes | Namespaces

LongAndShortFormats.xaml.h File Reference

#include "pch.h"
#include "LongAndShortFormats.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DateTimeFormatting::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DateTimeFormatting
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/MainPage.xaml.cpp File Reference

  • Date and time formatting

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/MainPage.xaml.h File Reference

  • Date and time formatting
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/OverrideSettings.xaml.cpp File Reference

  • Date and time formatting

OverrideSettings.xaml.cpp File Reference

#include "pch.h"
#include "OverrideSettings.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/OverrideSettings.xaml.h File Reference

  • Date and time formatting
Classes | Namespaces

OverrideSettings.xaml.h File Reference

#include "pch.h"
#include "OverrideSettings.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DateTimeFormatting::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DateTimeFormatting
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/ParametrizedTemplate.xaml.cpp File Reference

  • Date and time formatting

ParametrizedTemplate.xaml.cpp File Reference

#include "pch.h"
#include "ParametrizedTemplate.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/ParametrizedTemplate.xaml.h File Reference

  • Date and time formatting
Classes | Namespaces

ParametrizedTemplate.xaml.h File Reference

#include "pch.h"
#include "ParametrizedTemplate.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DateTimeFormatting::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DateTimeFormatting
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/pch.cpp File Reference

  • Date and time formatting

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/pch.h File Reference

  • Date and time formatting

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/StringTemplate.xaml.cpp File Reference

  • Date and time formatting

StringTemplate.xaml.cpp File Reference

#include "pch.h"
#include "StringTemplate.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/StringTemplate.xaml.h File Reference

  • Date and time formatting
Classes | Namespaces

StringTemplate.xaml.h File Reference

#include "pch.h"
#include "StringTemplate.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DateTimeFormatting::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DateTimeFormatting
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/common/LayoutAwarePage.cpp File Reference

  • Date and time formatting
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/common/LayoutAwarePage.h File Reference

  • Date and time formatting
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/common/suspensionmanager.cpp File Reference

  • Date and time formatting
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/common/suspensionmanager.h File Reference

  • Date and time formatting
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/BackgroundTask/pch.cpp File Reference

  • Device app for printers SDK
  • BackgroundTask

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/BackgroundTask/pch.h File Reference

  • Device app for printers SDK
  • BackgroundTask

pch.h File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/DeviceAppForPrinters/App.xaml.h File Reference

  • Device app for printers SDK
  • DeviceAppForPrinters
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | DeviceAppForPrinters::App

Namespaces

namespace | DeviceAppForPrinters
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/DeviceAppForPrinters/Constants.h File Reference

  • Device app for printers SDK
  • DeviceAppForPrinters
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | DeviceAppForPrinters::MainPage
struct | DeviceAppForPrinters::Scenario

Namespaces

namespace | DeviceAppForPrinters
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/DeviceAppForPrinters/pch.cpp File Reference

  • Device app for printers SDK
  • DeviceAppForPrinters

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/DeviceAppForPrinters/pch.h File Reference

  • Device app for printers SDK
  • DeviceAppForPrinters

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/App.xaml.cpp File Reference

  • Device auto rotation preferences

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/App.xaml.h File Reference

  • Device auto rotation preferences
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/Constants.cpp File Reference

  • Device auto rotation preferences

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/Constants.h File Reference

  • Device auto rotation preferences
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/Landscape.xaml.cpp File Reference

  • Device auto rotation preferences

Landscape.xaml.cpp File Reference

#include "pch.h"
#include "Landscape.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/Landscape.xaml.h File Reference

  • Device auto rotation preferences
Classes | Namespaces

Landscape.xaml.h File Reference

#include "pch.h"
#include "Landscape.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Rotation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Rotation
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/LandscapeFlipped.xaml.cpp File Reference

  • Device auto rotation preferences

LandscapeFlipped.xaml.cpp File Reference

#include "pch.h"
#include "LandscapeFlipped.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/LandscapeFlipped.xaml.h File Reference

  • Device auto rotation preferences
Classes | Namespaces

LandscapeFlipped.xaml.h File Reference

#include "pch.h"
#include "LandscapeFlipped.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Rotation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Rotation
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/MainPage.xaml.cpp File Reference

  • Device auto rotation preferences

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/MainPage.xaml.h File Reference

  • Device auto rotation preferences
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/None.xaml.cpp File Reference

  • Device auto rotation preferences

None.xaml.cpp File Reference

#include "pch.h"
#include "None.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/None.xaml.h File Reference

  • Device auto rotation preferences
Classes | Namespaces

None.xaml.h File Reference

#include "pch.h"
#include "None.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Rotation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Rotation
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/pch.cpp File Reference

  • Device auto rotation preferences

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/pch.h File Reference

  • Device auto rotation preferences

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/Portrait.xaml.cpp File Reference

  • Device auto rotation preferences

Portrait.xaml.cpp File Reference

#include "pch.h"
#include "Portrait.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/Portrait.xaml.h File Reference

  • Device auto rotation preferences
Classes | Namespaces

Portrait.xaml.h File Reference

#include "pch.h"
#include "Portrait.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Rotation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Rotation
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/PortraitFlipped.xaml.cpp File Reference

  • Device auto rotation preferences

PortraitFlipped.xaml.cpp File Reference

#include "pch.h"
#include "PortraitFlipped.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/PortraitFlipped.xaml.h File Reference

  • Device auto rotation preferences
Classes | Namespaces

PortraitFlipped.xaml.h File Reference

#include "pch.h"
#include "PortraitFlipped.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Rotation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Rotation
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/common/LayoutAwarePage.cpp File Reference

  • Device auto rotation preferences
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/common/LayoutAwarePage.h File Reference

  • Device auto rotation preferences
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/common/suspensionmanager.h File Reference

  • Device auto rotation preferences
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/App.xaml.cpp File Reference

  • Device enumeration

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/App.xaml.h File Reference

  • Device enumeration
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/Constants.cpp File Reference

  • Device enumeration

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/Constants.h File Reference

  • Device enumeration
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/Containers.xaml.cpp File Reference

  • Device enumeration

Containers.xaml.cpp File Reference

#include "pch.h"
#include "Containers.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/Containers.xaml.h File Reference

  • Device enumeration
Classes | Namespaces

Containers.xaml.h File Reference

#include "pch.h"
#include "Containers.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DeviceEnumeration::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::DeviceEnumeration::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DeviceEnumeration
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/Interfaces.xaml.cpp File Reference

  • Device enumeration

Interfaces.xaml.cpp File Reference

#include "pch.h"
#include "Interfaces.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/Interfaces.xaml.h File Reference

  • Device enumeration
Classes | Namespaces

Interfaces.xaml.h File Reference

#include "pch.h"
#include "Interfaces.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DeviceEnumeration::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::DeviceEnumeration::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DeviceEnumeration
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/MainPage.xaml.cpp File Reference

  • Device enumeration

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/MainPage.xaml.h File Reference

  • Device enumeration
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/pch.cpp File Reference

  • Device enumeration

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/pch.h File Reference

  • Device enumeration

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/common/LayoutAwarePage.cpp File Reference

  • Device enumeration
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/common/LayoutAwarePage.h File Reference

  • Device enumeration
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/common/suspensionmanager.cpp File Reference

  • Device enumeration
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/common/suspensionmanager.h File Reference

  • Device enumeration
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/App.xaml.cpp File Reference

  • Direct2D 3D transform effect

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/App.xaml.h File Reference

  • Direct2D 3D transform effect
Classes | Namespaces

App.xaml.h File Reference

#include "MainPage.xaml.h"
#include "App.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | D2D3DTransforms::sealed

Namespaces

namespace | D2D3DTransforms
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/D2D3DTransformsRenderer.cpp File Reference

  • Direct2D 3D transform effect

D2D3DTransformsRenderer.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/D2D3DTransformsRenderer.h File Reference

  • Direct2D 3D transform effect
Classes | Enumerations

D2D3DTransformsRenderer.h File Reference

#include "DirectXBase.h"
#include "DirectXBase.h"

Go to the source code of this file.

Classes

class | D2D3DTransformsRenderer

Enumerations

enum | TransformEffect { D2D13DTransform, D2D13DPerspectiveTransform }
enum TransformProperty {
ScaleX, ScaleY, LocalOffsetX, LocalOffsetY,
LocalOffsetZ, RotationX, RotationY, RotationZ,
GlobalOffsetX, GlobalOffsetY, GlobalOffsetZ, Perspective
}

Enumeration Type Documentation

enum TransformEffect
Enumerator:
D2D13DTransform
D2D13DPerspectiveTransform

Definition at line 14 of file D2D3DTransformsRenderer.h.

{
    D2D13DTransform,
    D2D13DPerspectiveTransform
};

enum TransformProperty
Enumerator:
ScaleX
ScaleY
LocalOffsetX
LocalOffsetY
LocalOffsetZ
RotationX
RotationY
RotationZ
GlobalOffsetX
GlobalOffsetY
GlobalOffsetZ
Perspective

Definition at line 20 of file D2D3DTransformsRenderer.h.

{
    ScaleX,
    ScaleY,
    LocalOffsetX,
    LocalOffsetY,
    LocalOffsetZ,
    RotationX,
    RotationY,
    RotationZ,
    GlobalOffsetX,
    GlobalOffsetY,
    GlobalOffsetZ,
    Perspective
};

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/DirectXBase.cpp File Reference

  • Direct2D 3D transform effect

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/DirectXBase.h File Reference

  • Direct2D 3D transform effect
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/DirectXSample.h File Reference

  • Direct2D 3D transform effect
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/MainPage.xaml.cpp File Reference

  • Direct2D 3D transform effect

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/MainPage.xaml.h File Reference

  • Direct2D 3D transform effect
Classes | Namespaces

MainPage.xaml.h File Reference

#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | D2D3DTransforms::sealed

Namespaces

namespace | D2D3DTransforms
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/pch.cpp File Reference

  • Direct2D 3D transform effect

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/pch.h File Reference

  • Direct2D 3D transform effect

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <DirectXMath.h>
#include <agile.h>
#include "PersistentState.h"
#include "D2D3DTransformsRenderer.h"
#include "DirectXSample.h"
#include "windows.ui.xaml.media.dxinterop.h"
#include "PersistentState.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/PersistentState.cpp File Reference

  • Direct2D 3D transform effect

PersistentState.cpp File Reference

#include "pch.h"
#include "PersistentState.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/PersistentState.h File Reference

  • Direct2D 3D transform effect
Classes

PersistentState.h File Reference

Go to the source code of this file.

Classes

class PersistentState
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D and DirectWrite animated text on a path/C++/pch.cpp File Reference

  • Direct2D and DirectWrite animated text on a path

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D and DirectWrite animated text on a path/C++/pch.h File Reference

  • Direct2D and DirectWrite animated text on a path

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <d2d1_1helper.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/D2DTextAnimation.cpp File Reference

  • Direct2D animated text
Functions

D2DTextAnimation.cpp File Reference

#include "pch.h"
#include "D2DTextAnimation.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 487 of file D2DTextAnimation.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/D2DTextAnimation.h File Reference

  • Direct2D animated text
Classes

D2DTextAnimation.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | D2DTextAnimation
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/DirectXBase.cpp File Reference

  • Direct2D animated text

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/DirectXBase.h File Reference

  • Direct2D animated text
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/DirectXSample.h File Reference

  • Direct2D animated text
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/pch.cpp File Reference

  • Direct2D animated text

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/pch.h File Reference

  • Direct2D animated text

pch.h File Reference

#include <d2d1_1.h>
#include <d3d11_1.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <wrl.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/SampleOverlay.cpp File Reference

  • Direct2D animated text

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/SampleOverlay.h File Reference

  • Direct2D animated text
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/animation.h File Reference

  • Direct2D animation
Classes

animation.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

class | Animation< T >
class | EaseInExponentialAnimation< T >
class | EaseInOutExponentialAnimation< T >
class | EaseOutExponentialAnimation< T >
class | LinearAnimation< T >
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/D2DBasicAnimation.cpp File Reference

  • Direct2D animation
Functions

D2DBasicAnimation.cpp File Reference

#include "pch.h"
#include "D2DBasicAnimation.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 357 of file D2DBasicAnimation.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/D2DBasicAnimation.h File Reference

  • Direct2D animation
Classes

D2DBasicAnimation.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | D2DBasicAnimation
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/DirectXBase.cpp File Reference

  • Direct2D animation

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/DirectXBase.h File Reference

  • Direct2D animation
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/DirectXSample.h File Reference

  • Direct2D animation
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/pch.cpp File Reference

  • Direct2D animation

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/pch.h File Reference

  • Direct2D animation

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <d2d1_1helper.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/SampleOverlay.cpp File Reference

  • Direct2D animation

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/SampleOverlay.h File Reference

  • Direct2D animation
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/D2DEffectsHelloWorld.cpp File Reference

  • Direct2D basic image effects
Functions

D2DEffectsHelloWorld.cpp File Reference

#include "pch.h"
#include "D2DEffectsHelloWorld.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 242 of file D2DEffectsHelloWorld.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/D2DEffectsHelloWorld.h File Reference

  • Direct2D basic image effects
Classes

D2DEffectsHelloWorld.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | D2DEffectsHelloWorld
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/DirectXBase.cpp File Reference

  • Direct2D basic image effects

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/DirectXBase.h File Reference

  • Direct2D basic image effects
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/DirectXSample.h File Reference

  • Direct2D basic image effects
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/pch.cpp File Reference

  • Direct2D basic image effects

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/pch.h File Reference

  • Direct2D basic image effects

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/SampleOverlay.cpp File Reference

  • Direct2D basic image effects

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/SampleOverlay.h File Reference

  • Direct2D basic image effects
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/BasicTimer.cpp File Reference

  • Direct2D command list

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/BasicTimer.h File Reference

  • Direct2D command list
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/CommandListSample.cpp File Reference

  • Direct2D command list
Functions

CommandListSample.cpp File Reference

#include "pch.h"
#include "CommandListSample.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 527 of file CommandListSample.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/CommandListSample.h File Reference

  • Direct2D command list
Classes

CommandListSample.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | CommandListRenderer
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/DirectXBase.cpp File Reference

  • Direct2D command list

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/DirectXBase.h File Reference

  • Direct2D command list
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/DirectXSample.h File Reference

  • Direct2D command list
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/pch.cpp File Reference

  • Direct2D command list

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/pch.h File Reference

  • Direct2D command list

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <d2d1_1helper.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/SampleOverlay.cpp File Reference

  • Direct2D command list

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/SampleOverlay.h File Reference

  • Direct2D command list
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/CompositeModes.cpp File Reference

  • Direct2D composite effect modes
Functions

CompositeModes.cpp File Reference

#include "pch.h"
#include "CompositeModes.h"
#include <math.h>

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 798 of file CompositeModes.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/CompositeModes.h File Reference

  • Direct2D composite effect modes
Classes

CompositeModes.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | CompositeModes
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/DirectXBase.cpp File Reference

  • Direct2D composite effect modes

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/DirectXBase.h File Reference

  • Direct2D composite effect modes
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/DirectXSample.h File Reference

  • Direct2D composite effect modes
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/pch.cpp File Reference

  • Direct2D composite effect modes

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/pch.h File Reference

  • Direct2D composite effect modes

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/SampleOverlay.cpp File Reference

  • Direct2D composite effect modes

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/SampleOverlay.h File Reference

  • Direct2D composite effect modes
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/ConvolutionKernels.h File Reference

  • Direct2D convolve matrix effect
Namespaces | Typedefs | Enumerations

ConvolutionKernels.h File Reference

Go to the source code of this file.

Namespaces

namespace | ConvolutionKernels

Typedefs

typedef enum KernelSelection | KernelSelection

Enumerations

enum KernelSelection {
Passthrough, BoxBlur, SimpleEdgeDetect, SimpleSharpen,
Emboss, HorizontalSmear
}

Typedef Documentation

typedef enum KernelSelection KernelSelection

Enumeration Type Documentation

enum KernelSelection
Enumerator:
Passthrough
BoxBlur
SimpleEdgeDetect
SimpleSharpen
Emboss
HorizontalSmear

Definition at line 10 of file ConvolutionKernels.h.

{
    Passthrough,
    BoxBlur,
    SimpleEdgeDetect,
    SimpleSharpen,
    Emboss,
    HorizontalSmear
} KernelSelection;

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/ConvolveMatrixEffect.cpp File Reference

  • Direct2D convolve matrix effect
Functions

ConvolveMatrixEffect.cpp File Reference

#include "pch.h"
#include "ConvolveMatrixEffect.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 643 of file ConvolveMatrixEffect.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/ConvolveMatrixEffect.h File Reference

  • Direct2D convolve matrix effect
Classes

ConvolveMatrixEffect.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "ConvolutionKernels.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | ConvolveMatrixEffect
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/DirectXBase.cpp File Reference

  • Direct2D convolve matrix effect

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/DirectXBase.h File Reference

  • Direct2D convolve matrix effect
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/DirectXSample.h File Reference

  • Direct2D convolve matrix effect
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/pch.cpp File Reference

  • Direct2D convolve matrix effect

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/pch.h File Reference

  • Direct2D convolve matrix effect

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/SampleOverlay.cpp File Reference

  • Direct2D convolve matrix effect

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/SampleOverlay.h File Reference

  • Direct2D convolve matrix effect
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/DirectXBase.cpp File Reference

  • Direct2D custom image effects
  • ComputeShader

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/DirectXBase.h File Reference

  • Direct2D custom image effects
  • ComputeShader
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/DirectXSample.h File Reference

  • Direct2D custom image effects
  • ComputeShader
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/pch.cpp File Reference

  • Direct2D custom image effects
  • ComputeShader

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/pch.h File Reference

  • Direct2D custom image effects
  • ComputeShader

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>
#include <d2d1effectauthor.h>
#include <d2d1effecthelpers.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/SampleOverlay.h File Reference

  • Direct2D custom image effects
  • ComputeShader
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/BasicTimer.cpp File Reference

  • Direct2D custom image effects
  • PixelShader

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/BasicTimer.h File Reference

  • Direct2D custom image effects
  • PixelShader
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/DirectXBase.cpp File Reference

  • Direct2D custom image effects
  • PixelShader

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/DirectXBase.h File Reference

  • Direct2D custom image effects
  • PixelShader
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/DirectXSample.h File Reference

  • Direct2D custom image effects
  • PixelShader
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/pch.cpp File Reference

  • Direct2D custom image effects
  • PixelShader

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/pch.h File Reference

  • Direct2D custom image effects
  • PixelShader

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include <math.h>
#include <d2d1effectauthor.h>
#include <d2d1effecthelpers.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/RippleEffect.cpp File Reference

  • Direct2D custom image effects
  • PixelShader
Defines | Functions

RippleEffect.cpp File Reference

#include "pch.h"
#include <initguid.h>
#include "RippleEffect.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Defines

#define XML(X) TEXT(#X)

Functions

IFACEMETHODIMP_ (UINT32) RippleEffect
IFACEMETHODIMP_ (ULONG) RippleEffect

Define Documentation

#define XML ( X ) TEXT(#X)

Definition at line 13 of file RippleEffect.cpp.

Function Documentation

IFACEMETHODIMP_ ( UINT32 )

Definition at line 305 of file RippleEffect.cpp.

{
    return 1;
}

IFACEMETHODIMP_ ( ULONG )

Definition at line 319 of file RippleEffect.cpp.

{
    m_refCount--;

    if (m_refCount == 0)
    {
        delete this;
        return 0;
    }
    else
    {
        return m_refCount;
    }
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/RippleEffect.h File Reference

  • Direct2D custom image effects
  • PixelShader
Classes | Enumerations | Functions

RippleEffect.h File Reference

Go to the source code of this file.

Classes

class RippleEffect

Enumerations

enum RIPPLE_PROP {
RIPPLE_PROP_FREQUENCY = 0, RIPPLE_PROP_PHASE = 1, RIPPLE_PROP_AMPLITUDE = 2, RIPPLE_PROP_SPREAD = 3,
RIPPLE_PROP_CENTER = 4
}

Functions

DEFINE_GUID (GUID_RipplePixelShader, 0x6716FB29, 0x06A0, 0x460F, 0xAA, 0x9C, 0x8B, 0x8F, 0xF0, 0x33, 0x5E, 0xA6)
DEFINE_GUID (CLSID_CustomRippleEffect, 0xB7B36C92, 0x3498, 0x4A94, 0x9E, 0x95, 0x9F, 0x24, 0x6F, 0x92, 0x45, 0xBF)

Enumeration Type Documentation

enum RIPPLE_PROP
Enumerator:
RIPPLE_PROP_FREQUENCY
RIPPLE_PROP_PHASE
RIPPLE_PROP_AMPLITUDE
RIPPLE_PROP_SPREAD
RIPPLE_PROP_CENTER

Definition at line 11 of file RippleEffect.h.

{
    RIPPLE_PROP_FREQUENCY = 0,
    RIPPLE_PROP_PHASE = 1,
    RIPPLE_PROP_AMPLITUDE = 2,
    RIPPLE_PROP_SPREAD = 3,
    RIPPLE_PROP_CENTER = 4
};

Function Documentation

DEFINE_GUID | ( | GUID_RipplePixelShader | ,
 |  | 0x6716FB29 | ,
 |  | 0x06A0 | ,
 |  | 0x460F | ,
 |  | 0xAA | ,
 |  | 0x9C | ,
 |  | 0x8B | ,
 |  | 0x8F | ,
 |  | 0xF0 | ,
 |  | 0x33 | ,
 |  | 0x5E | ,
 |  | 0xA6 |
 | ) |  |
DEFINE_GUID | ( | CLSID_CustomRippleEffect | ,
 |  | 0xB7B36C92 | ,
 |  | 0x3498 | ,
 |  | 0x4A94 | ,
 |  | 0x9E | ,
 |  | 0x95 | ,
 |  | 0x9F | ,
 |  | 0x24 | ,
 |  | 0x6F | ,
 |  | 0x92 | ,
 |  | 0x45 | ,
 |  | 0xBF |
 | ) |  |
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/SampleOverlay.cpp File Reference

  • Direct2D custom image effects
  • PixelShader

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/SampleOverlay.h File Reference

  • Direct2D custom image effects
  • PixelShader
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/BasicTimer.cpp File Reference

  • Direct2D custom image effects
  • VertexShader

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/BasicTimer.h File Reference

  • Direct2D custom image effects
  • VertexShader
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/DirectXBase.cpp File Reference

  • Direct2D custom image effects
  • VertexShader

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/DirectXBase.h File Reference

  • Direct2D custom image effects
  • VertexShader
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/DirectXSample.h File Reference

  • Direct2D custom image effects
  • VertexShader
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/pch.cpp File Reference

  • Direct2D custom image effects
  • VertexShader

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/pch.h File Reference

  • Direct2D custom image effects
  • VertexShader

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include <math.h>
#include <d2d1effectauthor.h>
#include <d2d1effecthelpers.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/SampleOverlay.cpp File Reference

  • Direct2D custom image effects
  • VertexShader

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/SampleOverlay.h File Reference

  • Direct2D custom image effects
  • VertexShader
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/WaveEffect.cpp File Reference

  • Direct2D custom image effects
  • VertexShader
Defines | Functions

WaveEffect.cpp File Reference

#include "pch.h"
#include <initguid.h>
#include "WaveEffect.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Defines

#define XML(X) TEXT(#X)

Functions

IFACEMETHODIMP_ (ULONG) WaveEffect

Define Documentation

#define XML ( X ) TEXT(#X)

Definition at line 13 of file WaveEffect.cpp.

Function Documentation

IFACEMETHODIMP_ ( ULONG )

Definition at line 420 of file WaveEffect.cpp.

{
    m_refCount--;

    if (m_refCount == 0)
    {
        delete this;
        return 0;
    }
    else
    {
        return m_refCount;
    }
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/WaveEffect.h File Reference

  • Direct2D custom image effects
  • VertexShader
Classes | Enumerations | Functions

WaveEffect.h File Reference

Go to the source code of this file.

Classes

class | WaveEffect
struct | WaveEffect::Vertex

Enumerations

enum | WAVE_PROP { WAVE_PROP_OFFSET = 0, WAVE_PROP_SKEW_X = 1, WAVE_PROP_SKEW_Y = 2, WAVE_PROP_FORCE_DWORD = 0xFFFFFFFF }

Functions

DEFINE_GUID (GUID_WaveTransformVertexShader, 0x65fa2492, 0x9478, 0x4c4d, 0x95, 0x67, 0xf6, 0x96, 0x72, 0x6a, 0x83, 0xa4)
DEFINE_GUID (CLSID_CustomWaveEffect, 0x7b4c948b, 0xfcf2, 0x4c6b, 0xa0, 0x93, 0xdb, 0x4e, 0x59, 0x99, 0x42, 0x43)
DEFINE_GUID (GUID_WaveTransformVertexBuffer, 0xa9149e76, 0xc708, 0x4b3a, 0xad, 0x59, 0x56, 0x72, 0x3b, 0x65, 0x33, 0x44)

Enumeration Type Documentation

enum WAVE_PROP
Enumerator:
WAVE_PROP_OFFSET
WAVE_PROP_SKEW_X
WAVE_PROP_SKEW_Y
WAVE_PROP_FORCE_DWORD

Definition at line 19 of file WaveEffect.h.

{
    WAVE_PROP_OFFSET      = 0,
    WAVE_PROP_SKEW_X     = 1,
    WAVE_PROP_SKEW_Y     = 2,
    WAVE_PROP_FORCE_DWORD = 0xFFFFFFFF
};

Function Documentation

DEFINE_GUID | ( | GUID_WaveTransformVertexShader | ,
 |  | 0x65fa2492 | ,
 |  | 0x9478 | ,
 |  | 0x4c4d | ,
 |  | 0x95 | ,
 |  | 0x67 | ,
 |  | 0xf6 | ,
 |  | 0x96 | ,
 |  | 0x72 | ,
 |  | 0x6a | ,
 |  | 0x83 | ,
 |  | 0xa4 |
 | ) |  |
DEFINE_GUID | ( | CLSID_CustomWaveEffect | ,
 |  | 0x7b4c948b | ,
 |  | 0xfcf2 | ,
 |  | 0x4c6b | ,
 |  | 0xa0 | ,
 |  | 0x93 | ,
 |  | 0xdb | ,
 |  | 0x4e | ,
 |  | 0x59 | ,
 |  | 0x99 | ,
 |  | 0x42 | ,
 |  | 0x43 |
 | ) |  |
DEFINE_GUID | ( | GUID_WaveTransformVertexBuffer | ,
 |  | 0xa9149e76 | ,
 |  | 0xc708 | ,
 |  | 0x4b3a | ,
 |  | 0xad | ,
 |  | 0x59 | ,
 |  | 0x56 | ,
 |  | 0x72 | ,
 |  | 0x3b | ,
 |  | 0x65 | ,
 |  | 0x33 | ,
 |  | 0x44 |
 | ) |  |
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.cpp File Reference

  • Direct2D effects on primitives
Functions

D2DEffectsOnPrimitives.cpp File Reference

#include "pch.h"
#include "D2DEffectsOnPrimitives.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 398 of file D2DEffectsOnPrimitives.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.h File Reference

  • Direct2D effects on primitives
Classes

D2DEffectsOnPrimitives.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | D2DEffectsOnPrimitives
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/DirectXBase.cpp File Reference

  • Direct2D effects on primitives

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/DirectXBase.h File Reference

  • Direct2D effects on primitives
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/DirectXSample.h File Reference

  • Direct2D effects on primitives
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/pch.cpp File Reference

  • Direct2D effects on primitives

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/pch.h File Reference

  • Direct2D effects on primitives

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/SampleOverlay.cpp File Reference

  • Direct2D effects on primitives

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/SampleOverlay.h File Reference

  • Direct2D effects on primitives
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/DirectXBase.cpp File Reference

  • Direct2D geometry realization

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/DirectXBase.h File Reference

  • Direct2D geometry realization
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/DirectXSample.h File Reference

  • Direct2D geometry realization
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/FPSCounter.cpp File Reference

  • Direct2D geometry realization

FPSCounter.cpp File Reference

#include "pch.h"
#include "FPSCounter.h"
#include <math.h>
#include <strsafe.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/FPSCounter.h File Reference

  • Direct2D geometry realization
Classes

FPSCounter.h File Reference

#include "DirectXSample.h"
#include <list>
#include <vector>

Go to the source code of this file.

Classes

class | FPSCounter
struct | FPSCounter::AtlasText
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/GeometryRealizationPackage.cpp File Reference

  • Direct2D geometry realization
Classes | Functions

GeometryRealizationPackage.cpp File Reference

#include "pch.h"
#include "GeometryRealizationPackage.h"

Go to the source code of this file.

Classes

class | GeometryRealization
class | GeometryRealizationFactory

Functions

HRESULT | CreateGeometryRealizationFactory (ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension, IGeometryRealizationFactory **factory)
HRESULT | CreateGeometryRealizationFactory (ID2D1DeviceContext *deviceContext, IGeometryRealizationFactory **factory)
STDMETHODIMP_ (ULONG) GeometryRealizationFactory

Function Documentation

HRESULT CreateGeometryRealizationFactory | ( | ID2D1DeviceContext * | deviceContext,
 |  | UINT | maxRealizationDimension,
 |  | IGeometryRealizationFactory ** | factory
 | ) |  |

Definition at line 226 of file GeometryRealizationPackage.cpp.

{
    return GeometryRealizationFactory::Create(
        deviceContext,
        maxRealizationDimension,
        factory
        );
}

HRESULT CreateGeometryRealizationFactory | ( | ID2D1DeviceContext * | deviceContext,
 |  | IGeometryRealizationFactory ** | factory
 | ) |  |

Definition at line 245 of file GeometryRealizationPackage.cpp.

{
    return CreateGeometryRealizationFactory(
        deviceContext,
        0xffffffff, // maxRealizationDimension
        factory
        );
}

STDMETHODIMP_ ( ULONG )

Definition at line 1279 of file GeometryRealizationPackage.cpp.

{
    ULONG ref = static_cast<ULONG>(
        InterlockedDecrement(reinterpret_cast<LONG volatile *>(&m_ref)));

    if (0 == ref)
    {
        delete this;
    }

    return ref;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/GeometryRealizationPackage.h File Reference

  • Direct2D geometry realization
Defines | Typedefs | Enumerations | Functions

GeometryRealizationPackage.h File Reference

#include <d2d1_1.h>

Go to the source code of this file.

Defines

#define | REALIZATIONS_DECLARE_INTERFACE(X) DECLSPEC_UUID(X) DECLSPEC_NOVTABLE

Typedefs

typedef enum
REALIZATION_CREATION_OPTIONS 		REALIZATION_CREATION_OPTIONS
typedef enum
REALIZATION_RENDER_MODE 		REALIZATION_RENDER_MODE

Enumerations

enum REALIZATION_CREATION_OPTIONS {
REALIZATION_CREATION_OPTIONS_ALIASED = 1, REALIZATION_CREATION_OPTIONS_ANTI_ALIASED = 2, REALIZATION_CREATION_OPTIONS_UNREALIZED = 4, REALIZATION_CREATION_OPTIONS_FILLED = 8,
REALIZATION_CREATION_OPTIONS_STROKED = 16
}
enum | REALIZATION_RENDER_MODE { REALIZATION_RENDER_MODE_FORCE_REALIZED = 0, REALIZATION_RENDER_MODE_FORCE_UNREALIZED = 1, REALIZATION_RENDER_MODE_DEFAULT = 2 }

Functions

HRESULT | CreateGeometryRealizationFactory (ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension, IGeometryRealizationFactory **factory)
HRESULT | CreateGeometryRealizationFactory (ID2D1DeviceContext *deviceContext, IGeometryRealizationFactory **factory)
interface | REALIZATIONS_DECLARE_INTERFACE ("a0b504a9-be04-44a7-ae05-71ac89c1b6a7") IGeometryRealization
interface | REALIZATIONS_DECLARE_INTERFACE ("27866d9f-8865-461d-8a10-2531156398b2") IGeometryRealizationFactory

Define Documentation

#define REALIZATIONS_DECLARE_INTERFACE ( X ) DECLSPEC_UUID(X) DECLSPEC_NOVTABLE

Definition at line 13 of file GeometryRealizationPackage.h.

Typedef Documentation

typedef enum REALIZATION_CREATION_OPTIONS REALIZATION_CREATION_OPTIONS
typedef enum REALIZATION_RENDER_MODE REALIZATION_RENDER_MODE

Enumeration Type Documentation

enum REALIZATION_CREATION_OPTIONS
Enumerator:
REALIZATION_CREATION_OPTIONS_ALIASED
REALIZATION_CREATION_OPTIONS_ANTI_ALIASED
REALIZATION_CREATION_OPTIONS_UNREALIZED
REALIZATION_CREATION_OPTIONS_FILLED
REALIZATION_CREATION_OPTIONS_STROKED

Definition at line 16 of file GeometryRealizationPackage.h.

{
    //
    // Generate mesh
    //
    REALIZATION_CREATION_OPTIONS_ALIASED = 1,

    //
    // Generate opacity mask
    //
    REALIZATION_CREATION_OPTIONS_ANTI_ALIASED = 2,

    //
    // Retain pointer to original geometry for unrealized rendering
    //
    REALIZATION_CREATION_OPTIONS_UNREALIZED = 4,

    //
    // Generate fill realization
    //
    REALIZATION_CREATION_OPTIONS_FILLED = 8,

    //
    // Generate stroke realization
    //
    REALIZATION_CREATION_OPTIONS_STROKED = 16
} REALIZATION_CREATION_OPTIONS;

enum REALIZATION_RENDER_MODE
Enumerator:
REALIZATION_RENDER_MODE_FORCE_REALIZED
REALIZATION_RENDER_MODE_FORCE_UNREALIZED
REALIZATION_RENDER_MODE_DEFAULT

Definition at line 44 of file GeometryRealizationPackage.h.

{
    //
    // Force the use of the realization
    //
    REALIZATION_RENDER_MODE_FORCE_REALIZED = 0,

    //
    // Force the use of the original geometry
    //
    REALIZATION_RENDER_MODE_FORCE_UNREALIZED = 1,

    //
    // Key off of the render-target to decide:
    //  SW: Unrealized
    //  HW: Realized
    //
    REALIZATION_RENDER_MODE_DEFAULT = 2

} REALIZATION_RENDER_MODE;

Function Documentation

HRESULT CreateGeometryRealizationFactory | ( | ID2D1DeviceContext * | deviceContext,
 |  | UINT | maxRealizationDimension,
 |  | IGeometryRealizationFactory ** | factory
 | ) |  |

Definition at line 226 of file GeometryRealizationPackage.cpp.

{
    return GeometryRealizationFactory::Create(
        deviceContext,
        maxRealizationDimension,
        factory
        );
}

HRESULT CreateGeometryRealizationFactory | ( | ID2D1DeviceContext * | deviceContext,
 |  | IGeometryRealizationFactory ** | factory
 | ) |  |

Definition at line 245 of file GeometryRealizationPackage.cpp.

{
    return CreateGeometryRealizationFactory(
        deviceContext,
        0xffffffff, // maxRealizationDimension
        factory
        );
}

interface REALIZATIONS_DECLARE_INTERFACE ( "a0b504a9-be04-44a7-ae05-71ac89c1b6a7" )

Definition at line 76 of file GeometryRealizationPackage.h.

                                                                                : public IUnknown
{
    //
    // Render the fill realization to the render target
    //
    STDMETHOD(Fill)(
        ID2D1DeviceContext *deviceContext,
        ID2D1Brush *brush,
        REALIZATION_RENDER_MODE mode
        ) PURE;

    //
    // Render the stroke realization to the render target
    //
    STDMETHOD(Draw)(
        ID2D1DeviceContext *deviceContext,
        ID2D1Brush *brush,
        REALIZATION_RENDER_MODE mode
        ) PURE;

    //
    // Discard the current realization's contents and replace with new contents.
    //
    // Note: This method will attempt to reuse the existing bitmaps (but will
    // replace the bitmaps if they aren't large enough). Since the cost of
    // destroying a texture can be surprisingly astronomical, using this method
    // can be substantially more performant than recreating a new realization
    // every time.
    //
    // Note: pWorldTransform is the transform that the realization will
    // be optimized for. If, at the time of rendering, the render target's
    // transform is the same as pWorldTransform,
    // the realization will appear identical to the unrealized version. Otherwise,
    // quality will be degraded.
    //
    STDMETHOD(Update)(
        ID2D1Geometry *geometry,
        REALIZATION_CREATION_OPTIONS options,
        CONST D2D1_MATRIX_3X2_F *worldTransform,
        float strokeWidth,
        ID2D1StrokeStyle *strokeStyle
        ) PURE;
};

interface REALIZATIONS_DECLARE_INTERFACE ( "27866d9f-8865-461d-8a10-2531156398b2" )

Definition at line 127 of file GeometryRealizationPackage.h.

                                                                                : public IUnknown
{
    //
    // Create a realization object with no content (should be populated with
    // Update() before use).
    //
    STDMETHOD(CreateGeometryRealization)(
        IGeometryRealization **realization
        ) PURE;

    //
    // Create a geometry realization.
    //
    // Note: Here, pWorldTransform is the transform that the realization will
    // be optimized for. If, at the time of rendering, the render target's
    // transform is the same as the pWorldTransform passed in here then
    // the realization will look identical to the unrealized version. Otherwise,
    // quality will be degraded.
    //
    STDMETHOD(CreateGeometryRealization)(
        ID2D1Geometry *geometry,
        REALIZATION_CREATION_OPTIONS options,
        CONST D2D1_MATRIX_3X2_F *worldTransform,
        float strokeWidth,
        ID2D1StrokeStyle *strokeStyle,
        IGeometryRealization **realization
        ) PURE;
};

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/GeometryRealizationSample.cpp File Reference

  • Direct2D geometry realization
Functions

GeometryRealizationSample.cpp File Reference

#include "pch.h"
#include "GeometryRealizationSample.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 768 of file GeometryRealizationSample.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/GeometryRealizationSample.h File Reference

  • Direct2D geometry realization
Classes

GeometryRealizationSample.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "FPSCounter.h"
#include "GeometryRealizationPackage.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | GeometryRealizationSample
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/pch.cpp File Reference

  • Direct2D geometry realization

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/pch.h File Reference

  • Direct2D geometry realization
Defines | Functions

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <d2d1_1helper.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include <math.h>
#include <strsafe.h>

Go to the source code of this file.

Defines

#define | _USE_MATH_DEFINES

Functions

template<class Interface >
void | SafeRelease (Interface **ppInterfaceToRelease)
template<class DestInterface , class SourceInterace >
void | SafeReplace (DestInterface **ppDestInterface, SourceInterace *pSourceInterface)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 18 of file pch.h.

Function Documentation

template<class Interface >
void SafeRelease ( Interface ** ppInterfaceToRelease ) [inline]

Definition at line 24 of file pch.h.

{
    if (*ppInterfaceToRelease != nullptr)
    {
        (*ppInterfaceToRelease)->Release();

        (*ppInterfaceToRelease) = nullptr;
    }
}

template<class DestInterface , class SourceInterace >
void SafeReplace | ( | DestInterface ** | ppDestInterface,
 |  | SourceInterace * | pSourceInterface |
 | ) |  |  | [inline]

Definition at line 38 of file pch.h.

{
    if (*ppDestInterface != nullptr)
    {
        (*ppDestInterface)->Release();
    }

    *ppDestInterface = pSourceInterface;

    if (pSourceInterface)
    {
        (*ppDestInterface)->AddRef();
    }
}

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/SampleOverlay.cpp File Reference

  • Direct2D geometry realization

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/SampleOverlay.h File Reference

  • Direct2D geometry realization
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/BasicTimer.cpp File Reference

  • Direct2D interpolation modes

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/BasicTimer.h File Reference

  • Direct2D interpolation modes
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/D2DInterpolationModes.cpp File Reference

  • Direct2D interpolation modes
Functions

D2DInterpolationModes.cpp File Reference

#include "pch.h"
#include "D2DInterpolationModes.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 873 of file D2DInterpolationModes.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/D2DInterpolationModes.h File Reference

  • Direct2D interpolation modes
Classes | Defines

D2DInterpolationModes.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "BasicTimer.h"
#include <deque>
#include <math.h>
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | D2DInterpolationModes
class | DirectXAppSource

Defines

#define | _USE_MATH_DEFINES

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 13 of file D2DInterpolationModes.h.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/DirectXBase.cpp File Reference

  • Direct2D interpolation modes

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/DirectXBase.h File Reference

  • Direct2D interpolation modes
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/DirectXSample.h File Reference

  • Direct2D interpolation modes
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/pch.cpp File Reference

  • Direct2D interpolation modes

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/pch.h File Reference

  • Direct2D interpolation modes

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <dxgi1_2.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/SampleOverlay.cpp File Reference

  • Direct2D interpolation modes

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/SampleOverlay.h File Reference

  • Direct2D interpolation modes
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/App.xaml.cpp File Reference

  • Direct2D magazine app

App.xaml.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/App.xaml.h File Reference

  • Direct2D magazine app
Classes | Namespaces

App.xaml.h File Reference

#include "App.g.h"

Go to the source code of this file.

Classes

class | Magazine::sealed

Namespaces

namespace | Magazine
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ContentImageSource.cpp File Reference

  • Direct2D magazine app

ContentImageSource.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ContentImageSource.h File Reference

  • Direct2D magazine app
Classes

ContentImageSource.h File Reference

Go to the source code of this file.

Classes

class | ContentImageSource
class | ContentImageSource::ImageSourceDrawHelper
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Design.cpp File Reference

  • Direct2D magazine app

Design.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Design.h File Reference

  • Direct2D magazine app
Classes

Design.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class Design
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Document.cpp File Reference

  • Direct2D magazine app

Document.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Document.h File Reference

  • Direct2D magazine app
Classes | Functions

Document.h File Reference

Go to the source code of this file.

Classes

class | Document

Functions

delegate void | DocumentLoadedCallback (_In_ Document^document)

Function Documentation

delegate void DocumentLoadedCallback ( _In_ Document^ document )
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Element.cpp File Reference

  • Direct2D magazine app

Element.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Element.h File Reference

  • Direct2D magazine app
Classes

Element.h File Reference

Go to the source code of this file.

Classes

class Element
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/FontFileStream.cpp File Reference

  • Direct2D magazine app

FontFileStream.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/FontFileStream.h File Reference

  • Direct2D magazine app
Classes

FontFileStream.h File Reference

Go to the source code of this file.

Classes

class FontFileStream
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/FontLoader.cpp File Reference

  • Direct2D magazine app

FontLoader.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/FontLoader.h File Reference

  • Direct2D magazine app
Classes

FontLoader.h File Reference

#include <vector>

Go to the source code of this file.

Classes

class FontLoader
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Image.cpp File Reference

  • Direct2D magazine app

Image.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Image.h File Reference

  • Direct2D magazine app
Classes

Image.h File Reference

#include "Resource.h"
#include "ImageFile.h"

Go to the source code of this file.

Classes

class Image
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ImageFile.cpp File Reference

  • Direct2D magazine app

ImageFile.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ImageFile.h File Reference

  • Direct2D magazine app
Classes

ImageFile.h File Reference

Go to the source code of this file.

Classes

class ImageFile
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ImageFrame.cpp File Reference

  • Direct2D magazine app

ImageFrame.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ImageFrame.h File Reference

  • Direct2D magazine app
Classes

ImageFrame.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class ImageFrame
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Layer.cpp File Reference

  • Direct2D magazine app

Layer.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Layer.h File Reference

  • Direct2D magazine app
Classes

Layer.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class Layer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/List.cpp File Reference

  • Direct2D magazine app

List.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/List.h File Reference

  • Direct2D magazine app
Classes

List.h File Reference

#include "Rectangle.h"

Go to the source code of this file.

Classes

class List< T >
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/MainPage.xaml.cpp File Reference

  • Direct2D magazine app

MainPage.xaml.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/MainPage.xaml.h File Reference

  • Direct2D magazine app
Classes | Namespaces

MainPage.xaml.h File Reference

#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | Magazine::sealed

Namespaces

namespace | Magazine
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Page.cpp File Reference

  • Direct2D magazine app

Page.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Page.h File Reference

  • Direct2D magazine app
Classes

Page.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class Page
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/PageModel.cpp File Reference

  • Direct2D magazine app

PageModel.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/PageModel.h File Reference

  • Direct2D magazine app
Classes | Namespaces

PageModel.h File Reference

Go to the source code of this file.

Classes

class | Magazine::sealed

Namespaces

namespace | Magazine
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/PageRoll.cpp File Reference

  • Direct2D magazine app

PageRoll.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/PageRoll.h File Reference

  • Direct2D magazine app
Classes

PageRoll.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class PageRoll
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/pch.cpp File Reference

  • Direct2D magazine app

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/pch.h File Reference

  • Direct2D magazine app

pch.h File Reference

#include <objidl.h>
#include <strsafe.h>
#include <wrl.h>
#include <windows.ui.xaml.media.dxinterop.h>
#include <ppltasks.h>
#include <agile.h>
#include "Renderer.h"
#include "Document.h"
#include "FontFileStream.h"
#include "FontLoader.h"
#include "TreeIterator.h"
#include "Element.h"
#include "Resource.h"
#include "ImageFile.h"
#include "Image.h"
#include "Text.h"
#include "Story.h"
#include "Design.h"
#include "PageRoll.h"
#include "Page.h"
#include "Layer.h"
#include "List.h"
#include "Rectangle.h"
#include "TextFrame.h"
#include "ImageFrame.h"
#include "ContentImageSource.h"
#include "PageModel.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Rectangle.cpp File Reference

  • Direct2D magazine app

Rectangle.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Rectangle.h File Reference

  • Direct2D magazine app
Classes

Rectangle.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class Rectangle
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Renderer.cpp File Reference

  • Direct2D magazine app

Renderer.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Renderer.h File Reference

  • Direct2D magazine app
Classes | Namespaces | Functions

Renderer.h File Reference

#include <initguid.h>
#include <wrl.h>
#include <d3d11_1.h>
#include <dxgi1_2.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>

Go to the source code of this file.

Classes

class | Renderer

Namespaces

namespace | DX

Functions

delegate void | DeviceLostEventHandler ()
void | DX::ThrowIfFailed (HRESULT hr)

Function Documentation

delegate void DeviceLostEventHandler ( )
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Resource.cpp File Reference

  • Direct2D magazine app

Resource.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Resource.h File Reference

  • Direct2D magazine app
Classes

Resource.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class Resource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Story.cpp File Reference

  • Direct2D magazine app

Story.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Story.h File Reference

  • Direct2D magazine app
Classes

Story.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class Story
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Text.cpp File Reference

  • Direct2D magazine app

Text.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Text.h File Reference

  • Direct2D magazine app
Classes

Text.h File Reference

#include "Resource.h"

Go to the source code of this file.

Classes

class Text
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/TextFrame.cpp File Reference

  • Direct2D magazine app

TextFrame.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/TextFrame.h File Reference

  • Direct2D magazine app
Classes

TextFrame.h File Reference

#include "Element.h"

Go to the source code of this file.

Classes

class TextFrame
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/TreeIterator.h File Reference

  • Direct2D magazine app
Classes

TreeIterator.h File Reference

Go to the source code of this file.

Classes

class TreeIterator< T >
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/D2DPerspectiveTransform.cpp File Reference

  • Direct2D perspective transform
Functions

D2DPerspectiveTransform.cpp File Reference

#include "pch.h"
#include "D2DPerspectiveTransform.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 322 of file D2DPerspectiveTransform.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/D2DPerspectiveTransform.h File Reference

  • Direct2D perspective transform
Classes

D2DPerspectiveTransform.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | D2DPerspectiveTransform
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/DirectXBase.cpp File Reference

  • Direct2D perspective transform

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/DirectXBase.h File Reference

  • Direct2D perspective transform
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/DirectXSample.h File Reference

  • Direct2D perspective transform
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/pch.cpp File Reference

  • Direct2D perspective transform

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/pch.h File Reference

  • Direct2D perspective transform

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/SampleOverlay.cpp File Reference

  • Direct2D perspective transform

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/SampleOverlay.h File Reference

  • Direct2D perspective transform
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/D2DPageRenderer.cpp File Reference

  • Direct2D printing images and effects

D2DPageRenderer.cpp File Reference

#include "pch.h"
#include <math.h>
#include "D2DPageRenderer.h"
#include "D2DPageRendererContext.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/D2DPageRenderer.h File Reference

  • Direct2D printing images and effects
Classes

D2DPageRenderer.h File Reference

#include <DirectXBase.h>
#include <printpreview.h>
#include "SampleOverlay.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class PageRenderer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DirectXApp.cpp File Reference

  • Direct2D printing images and effects
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 185 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DirectXApp.h File Reference

  • Direct2D printing images and effects
Classes

DirectXApp.h File Reference

#include "DocSource.h"
#include "D2DPageRenderer.h"
#include "DocSource.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DirectXBase.cpp File Reference

  • Direct2D printing images and effects

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DirectXBase.h File Reference

  • Direct2D printing images and effects
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DirectXSample.h File Reference

  • Direct2D printing images and effects
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DocSource.cpp File Reference

  • Direct2D printing images and effects

DocSource.cpp File Reference

#include "pch.h"
#include "docsource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DocSource.h File Reference

  • Direct2D printing images and effects
Classes

DocSource.h File Reference

#include <windows.graphics.printing.h>
#include <printpreview.h>
#include <documentsource.h>
#include "D2DPageRenderer.h"

Go to the source code of this file.

Classes

class CDocumentSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/pch.cpp File Reference

  • Direct2D printing images and effects

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/pch.h File Reference

  • Direct2D printing images and effects

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/SampleOverlay.cpp File Reference

  • Direct2D printing images and effects

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/SampleOverlay.h File Reference

  • Direct2D printing images and effects
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/DirectXBase.cpp File Reference

  • Direct2D save to image file

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/DirectXBase.h File Reference

  • Direct2D save to image file
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/DirectXSample.h File Reference

  • Direct2D save to image file
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/pch.cpp File Reference

  • Direct2D save to image file

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/pch.h File Reference

  • Direct2D save to image file

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <d2d1_1helper.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <shcore.h>
#include <collection.h>
#include <ppltasks.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/SampleOverlay.cpp File Reference

  • Direct2D save to image file

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/SampleOverlay.h File Reference

  • Direct2D save to image file
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/SaveAsImageFileSample.cpp File Reference

  • Direct2D save to image file
Functions

SaveAsImageFileSample.cpp File Reference

#include "pch.h"
#include "SaveAsImageFileSample.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 415 of file SaveAsImageFileSample.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/SaveAsImageFileSample.h File Reference

  • Direct2D save to image file
Classes | Enumerations

SaveAsImageFileSample.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | SaveAsImageFile

Enumerations

enum | ScreenSavingState { NotSaved, Saving, Saved }

Enumeration Type Documentation

enum ScreenSavingState
Enumerator:
NotSaved
Saving
Saved

Definition at line 13 of file SaveAsImageFileSample.h.

{
    NotSaved,
    Saving,
    Saved
};

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/D2DPageRenderer.cpp File Reference

  • Direct2Dapp printing

D2DPageRenderer.cpp File Reference

#include "pch.h"
#include <math.h>
#include "D2DPageRenderer.h"
#include "D2DPageRendererContext.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/D2DPageRenderer.h File Reference

  • Direct2Dapp printing
Classes

D2DPageRenderer.h File Reference

#include <DirectXBase.h>
#include <printpreview.h>
#include "SampleOverlay.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class PageRenderer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/D2DPageRendererContext.cpp File Reference

  • Direct2Dapp printing

D2DPageRendererContext.cpp File Reference

#include "pch.h"
#include <math.h>
#include "D2DPageRenderer.h"
#include "D2DPageRendererContext.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/D2DPageRendererContext.h File Reference

  • Direct2Dapp printing
Classes | Enumerations

D2DPageRendererContext.h File Reference

#include <DirectXBase.h>
#include <printpreview.h>
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | D2DFactoryLock
class | PageRendererContext

Enumerations

enum | DrawTypes { Rendering, Preview, Printing }

Enumeration Type Documentation

enum DrawTypes
Enumerator:
Rendering
Preview
Printing

Definition at line 13 of file D2DPageRendererContext.h.

{
    Rendering,
    Preview,
    Printing
};

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DirectXApp.cpp File Reference

  • Direct2Dapp printing
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 185 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DirectXApp.h File Reference

  • Direct2Dapp printing
Classes

DirectXApp.h File Reference

#include "DocSource.h"
#include "D2DPageRenderer.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DirectXBase.cpp File Reference

  • Direct2Dapp printing

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DirectXBase.h File Reference

  • Direct2Dapp printing
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DirectXSample.h File Reference

  • Direct2Dapp printing
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DocSource.cpp File Reference

  • Direct2Dapp printing

DocSource.cpp File Reference

#include "pch.h"
#include "docsource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DocSource.h File Reference

  • Direct2Dapp printing
Classes

DocSource.h File Reference

#include <windows.graphics.printing.h>
#include <printpreview.h>
#include <documentsource.h>
#include "D2DPageRenderer.h"

Go to the source code of this file.

Classes

class CDocumentSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/pch.cpp File Reference

  • Direct2Dapp printing

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/pch.h File Reference

  • Direct2Dapp printing

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/SampleOverlay.cpp File Reference

  • Direct2Dapp printing

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/SampleOverlay.h File Reference

  • Direct2Dapp printing
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicCamera.cpp File Reference

  • Direct3D bump mapping

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicCamera.h File Reference

  • Direct3D bump mapping
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicLoader.cpp File Reference

  • Direct3D bump mapping

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicLoader.h File Reference

  • Direct3D bump mapping
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicMath.h File Reference

  • Direct3D bump mapping
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicReaderWriter.cpp File Reference

  • Direct3D bump mapping

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicReaderWriter.h File Reference

  • Direct3D bump mapping
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicShapes.cpp File Reference

  • Direct3D bump mapping

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicShapes.h File Reference

  • Direct3D bump mapping
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicTimer.cpp File Reference

  • Direct3D bump mapping

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicTimer.h File Reference

  • Direct3D bump mapping
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BumpMapping.cpp File Reference

  • Direct3D bump mapping
Variables

BumpMapping.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "BasicLoader.h"
#include "BumpMapping.h"

Go to the source code of this file.

Variables

D3D11_INPUT_ELEMENT_DESC tangentVertexLayoutDesc []

Variable Documentation

D3D11_INPUT_ELEMENT_DESC tangentVertexLayoutDesc[]
Initial value:
{
    { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0,  0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
    { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
    { "TANGENT",  0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 20, D3D11_INPUT_PER_VERTEX_DATA, 0 },
    { "TANGENT",  1, DXGI_FORMAT_R32G32B32_FLOAT, 0, 32, D3D11_INPUT_PER_VERTEX_DATA, 0 },
}

Definition at line 18 of file BumpMapping.cpp.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BumpMapping.h File Reference

  • Direct3D bump mapping
Classes | Defines

BumpMapping.h File Reference

#include "DirectXBase.h"
#include "BasicMath.h"
#include "BasicCamera.h"
#include "LonLatController.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "LonLatController.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | BumpMapping
struct | ConstantBuffer

Defines

#define | START_POSITION (float3(0, 0.4f, -2))

Define Documentation

#define START_POSITION (float3(0, 0.4f, -2))

Definition at line 24 of file BumpMapping.h.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DDSTextureLoader.cpp File Reference

  • Direct3D bump mapping
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DDSTextureLoader.h File Reference

  • Direct3D bump mapping
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DirectXApp.cpp File Reference

  • Direct3D bump mapping
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 161 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DirectXApp.h File Reference

  • Direct3D bump mapping
Classes

DirectXApp.h File Reference

#include "BumpMapping.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DirectXBase.cpp File Reference

  • Direct3D bump mapping

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DirectXBase.h File Reference

  • Direct3D bump mapping
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DirectXSample.h File Reference

  • Direct3D bump mapping
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/LonLatController.cpp File Reference

  • Direct3D bump mapping

LonLatController.cpp File Reference

#include "pch.h"
#include "LonLatController.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/LonLatController.h File Reference

  • Direct3D bump mapping
Classes | Defines

LonLatController.h File Reference

Go to the source code of this file.

Classes

class | LonLatController

Defines

#define | LONLAT_GAIN 0.003f
#define | LONLATKEY_GAIN 0.04f

Define Documentation

#define LONLAT_GAIN 0.003f

Definition at line 11 of file LonLatController.h.

#define LONLATKEY_GAIN 0.04f

Definition at line 12 of file LonLatController.h.

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/pch.cpp File Reference

  • Direct3D bump mapping

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/pch.h File Reference

  • Direct3D bump mapping

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/SampleOverlay.cpp File Reference

  • Direct3D bump mapping

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/SampleOverlay.h File Reference

  • Direct3D bump mapping
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/AutoThrottle.cpp File Reference

  • Direct3D HLSL fractal generator

AutoThrottle.cpp File Reference

#include "pch.h"
#include "AutoThrottle.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/AutoThrottle.h File Reference

  • Direct3D HLSL fractal generator
Classes | Enumerations

AutoThrottle.h File Reference

Go to the source code of this file.

Classes

class AutoThrottle

Enumerations

enum FrameWorkload {
Increase, Decrease, Maintain, Increase,
Decrease, Maintain
}

Enumeration Type Documentation

enum FrameWorkload
Enumerator:
Increase
Decrease
Maintain
Increase
Decrease
Maintain

Definition at line 10 of file AutoThrottle.h.

{
    Increase,
    Decrease,
    Maintain
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicLoader.cpp File Reference

  • Direct3D HLSL fractal generator

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicLoader.h File Reference

  • Direct3D HLSL fractal generator
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicMath.h File Reference

  • Direct3D HLSL fractal generator
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicReaderWriter.cpp File Reference

  • Direct3D HLSL fractal generator

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicReaderWriter.h File Reference

  • Direct3D HLSL fractal generator
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicShapes.cpp File Reference

  • Direct3D HLSL fractal generator

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicShapes.h File Reference

  • Direct3D HLSL fractal generator
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicTimer.cpp File Reference

  • Direct3D HLSL fractal generator

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicTimer.h File Reference

  • Direct3D HLSL fractal generator
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DDSTextureLoader.cpp File Reference

  • Direct3D HLSL fractal generator
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DDSTextureLoader.h File Reference

  • Direct3D HLSL fractal generator
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXApp.cpp File Reference

  • Direct3D HLSL fractal generator
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 254 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXApp.h File Reference

  • Direct3D HLSL fractal generator
Classes

DirectXApp.h File Reference

#include "DirectXFractal.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXBase.cpp File Reference

  • Direct3D HLSL fractal generator

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXBase.h File Reference

  • Direct3D HLSL fractal generator
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXFractal.cpp File Reference

  • Direct3D HLSL fractal generator

DirectXFractal.cpp File Reference

#include "pch.h"
#include "DirectXFractal.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXFractal.h File Reference

  • Direct3D HLSL fractal generator
Classes | Namespaces | Enumerations

DirectXFractal.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "AutoThrottle.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | ComputeCB
struct | ComputeDoubleCB
class | DirectXFractal
struct | DrawRectCB
struct | FractalBufferElement
struct | FractalVertex
struct | ViewTransform

Namespaces

namespace | SampleSettings
namespace | SampleSettings::DirectCompute
namespace | SampleSettings::Manipulation
namespace | SampleSettings::Performance
namespace | SampleSettings::ThreePhase

Enumerations

enum | FractalTechnique { ThreePhase, SinglePass, DirectCompute }

Enumeration Type Documentation

enum FractalTechnique
Enumerator:
ThreePhase
SinglePass
DirectCompute

Definition at line 48 of file DirectXFractal.h.

{
    ThreePhase,
    SinglePass,
    DirectCompute
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXSample.h File Reference

  • Direct3D HLSL fractal generator
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DoublePrecisionMath.h File Reference

  • Direct3D HLSL fractal generator
Typedefs | Functions

DoublePrecisionMath.h File Reference

Go to the source code of this file.

Typedefs

typedef Vector2< double > | double2
typedef Matrix4x4< double > | double4x4

Functions

float4x4 | convert (double4x4 m)
double4x4 identityDouble ()
double4x4 | mulDouble (double4x4 m1, double4x4 m2)
double2 | mulDouble (double2 v, double4x4 m)
double4x4 | rotationZDouble (double degreeZ)
double4x4 | scaleDouble (double x, double y, double z)
double4x4 | translationDouble (double x, double y, double z)

Typedef Documentation

typedef Vector2<double> double2

Definition at line 10 of file DoublePrecisionMath.h.

typedef Matrix4x4<double> double4x4

Definition at line 12 of file DoublePrecisionMath.h.

Function Documentation

float4x4 convert ( double4x4 m ) [inline]

Definition at line 97 of file DoublePrecisionMath.h.

{
    float4x4 mr;
    mr._11 = static_cast<float>(m._11); mr._12 = static_cast<float>(m._12); mr._13 = static_cast<float>(m._13); mr._14 = static_cast<float>(m._14);
    mr._21 = static_cast<float>(m._21); mr._22 = static_cast<float>(m._22); mr._23 = static_cast<float>(m._23); mr._24 = static_cast<float>(m._24);
    mr._31 = static_cast<float>(m._31); mr._32 = static_cast<float>(m._32); mr._33 = static_cast<float>(m._33); mr._34 = static_cast<float>(m._34);
    mr._41 = static_cast<float>(m._41); mr._42 = static_cast<float>(m._42); mr._43 = static_cast<float>(m._43); mr._44 = static_cast<float>(m._44);
    return mr;
}

double4x4 identityDouble ( ) [inline]

Definition at line 14 of file DoublePrecisionMath.h.

{
    double4x4 mOut;

    mOut._11 = 1.0; mOut._12 = 0.0; mOut._13 = 0.0; mOut._14 = 0.0;
    mOut._21 = 0.0; mOut._22 = 1.0; mOut._23 = 0.0; mOut._24 = 0.0;
    mOut._31 = 0.0; mOut._32 = 0.0; mOut._33 = 1.0; mOut._34 = 0.0;
    mOut._41 = 0.0; mOut._42 = 0.0; mOut._43 = 0.0; mOut._44 = 1.0;

    return mOut;
}

double4x4 mulDouble | ( | double4x4 | m1,
 |  | double4x4 | m2 |
 | ) |  |  | [inline]

Definition at line 67 of file DoublePrecisionMath.h.

{
    double4x4 mr;
    mr._11 = m1._11 * m2._11 + m1._12 * m2._21 + m1._13 * m2._31 + m1._14 * m2._41;
    mr._12 = m1._11 * m2._12 + m1._12 * m2._22 + m1._13 * m2._32 + m1._14 * m2._42;
    mr._13 = m1._11 * m2._13 + m1._12 * m2._23 + m1._13 * m2._33 + m1._14 * m2._43;
    mr._14 = m1._11 * m2._14 + m1._12 * m2._24 + m1._13 * m2._34 + m1._14 * m2._44;
    mr._21 = m1._21 * m2._11 + m1._22 * m2._21 + m1._23 * m2._31 + m1._24 * m2._41;
    mr._22 = m1._21 * m2._12 + m1._22 * m2._22 + m1._23 * m2._32 + m1._24 * m2._42;
    mr._23 = m1._21 * m2._13 + m1._22 * m2._23 + m1._23 * m2._33 + m1._24 * m2._43;
    mr._24 = m1._21 * m2._14 + m1._22 * m2._24 + m1._23 * m2._34 + m1._24 * m2._44;
    mr._31 = m1._31 * m2._11 + m1._32 * m2._21 + m1._33 * m2._31 + m1._34 * m2._41;
    mr._32 = m1._31 * m2._12 + m1._32 * m2._22 + m1._33 * m2._32 + m1._34 * m2._42;
    mr._33 = m1._31 * m2._13 + m1._32 * m2._23 + m1._33 * m2._33 + m1._34 * m2._43;
    mr._34 = m1._31 * m2._14 + m1._32 * m2._24 + m1._33 * m2._34 + m1._34 * m2._44;
    mr._41 = m1._41 * m2._11 + m1._42 * m2._21 + m1._43 * m2._31 + m1._44 * m2._41;
    mr._42 = m1._41 * m2._12 + m1._42 * m2._22 + m1._43 * m2._32 + m1._44 * m2._42;
    mr._43 = m1._41 * m2._13 + m1._42 * m2._23 + m1._43 * m2._33 + m1._44 * m2._43;
    mr._44 = m1._41 * m2._14 + m1._42 * m2._24 + m1._43 * m2._34 + m1._44 * m2._44;
    return mr;
}

double2 mulDouble | ( | double2 | v,
 |  | double4x4 | m |
 | ) |  |  | [inline]

Definition at line 89 of file DoublePrecisionMath.h.

{
    return double2(
        v.x * m._11 + v.y * m._12 + m._14,
        v.x * m._21 + v.y * m._22 + m._24
    );
}

double4x4 rotationZDouble ( double degreeZ ) [inline]

Definition at line 50 of file DoublePrecisionMath.h.

{
    double angleInRadians = degreeZ * (M_PI / 180.0);

    double sinAngle = sin(angleInRadians);
    double cosAngle = cos(angleInRadians);

    double4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0; mOut._14 = 0.0;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0; mOut._24 = 0.0;
    mOut._31 = 0.0;      mOut._32 = 0.0;       mOut._33 = 1.0; mOut._34 = 0.0;
    mOut._41 = 0.0;      mOut._42 = 0.0;       mOut._43 = 0.0; mOut._44 = 1.0;

    return mOut;
}

double4x4 scaleDouble | ( | double | x,
 |  | double | y,
 |  | double | z |
 | ) |  |  | [inline]

Definition at line 38 of file DoublePrecisionMath.h.

{
    double4x4 mOut;

    mOut._11 = x;   mOut._12 = 0.0; mOut._13 = 0.0; mOut._14 = 0.0;
    mOut._21 = 0.0; mOut._22 = y;   mOut._23 = 0.0; mOut._24 = 0.0;
    mOut._31 = 0.0; mOut._32 = 0.0; mOut._33 = z;   mOut._34 = 0.0;
    mOut._41 = 0.0; mOut._42 = 0.0; mOut._43 = 0.0; mOut._44 = 1.0;

    return mOut;
}

double4x4 translationDouble | ( | double | x,
 |  | double | y,
 |  | double | z |
 | ) |  |  | [inline]

Definition at line 26 of file DoublePrecisionMath.h.

{
    double4x4 mOut;

    mOut._11 = 1.0; mOut._12 = 0.0; mOut._13 = 0.0; mOut._14 = x;
    mOut._21 = 0.0; mOut._22 = 1.0; mOut._23 = 0.0; mOut._24 = y;
    mOut._31 = 0.0; mOut._32 = 0.0; mOut._33 = 1.0; mOut._34 = z;
    mOut._41 = 0.0; mOut._42 = 0.0; mOut._43 = 0.0; mOut._44 = 1.0;

    return mOut;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/pch.cpp File Reference

  • Direct3D HLSL fractal generator

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/pch.h File Reference

  • Direct3D HLSL fractal generator

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "DoublePrecisionMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/SampleOverlay.cpp File Reference

  • Direct3D HLSL fractal generator

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/SampleOverlay.h File Reference

  • Direct3D HLSL fractal generator
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicCamera.cpp File Reference

  • Direct3D post-processing effects

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicCamera.h File Reference

  • Direct3D post-processing effects
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicLoader.cpp File Reference

  • Direct3D post-processing effects

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicLoader.h File Reference

  • Direct3D post-processing effects
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicMath.h File Reference

  • Direct3D post-processing effects
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicReaderWriter.cpp File Reference

  • Direct3D post-processing effects

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicReaderWriter.h File Reference

  • Direct3D post-processing effects
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicShapes.cpp File Reference

  • Direct3D post-processing effects

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicShapes.h File Reference

  • Direct3D post-processing effects
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicTimer.cpp File Reference

  • Direct3D post-processing effects

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicTimer.h File Reference

  • Direct3D post-processing effects
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/D3DPostProcessing.cpp File Reference

  • Direct3D post-processing effects
Functions

D3DPostProcessing.cpp File Reference

#include "pch.h"
#include "D3DPostProcessing.h"
#include "BasicShapes.h"
#include "BasicLoader.h"

Go to the source code of this file.

Functions

float | GaussianDistribution (float x, float y, float rho)
void | GetSampleOffsetsWeightsForBlur (DWORD textureWidthOrHeight, float textureCoordinateOffsets[blurKernelSpan], float4 *colorWeights, float deviation, float multiplier)

Function Documentation

float GaussianDistribution | ( | float | x,
 |  | float | y,
 |  | float | rho
 | ) |  |

Definition at line 737 of file D3DPostProcessing.cpp.

{
    float g = 1.0f / sqrtf(2.0f * PI_F * rho * rho);
    g *= expf(- (x * x + y * y) / (2 * rho * rho));

    return g;
}

void GetSampleOffsetsWeightsForBlur | ( | DWORD | textureWidthOrHeight,
 |  | float | textureCoordinateOffsets[blurKernelSpan],
 |  | float4 * | colorWeights,
 |  | float | deviation,
 |  | float | multiplier
 | ) |  |

Definition at line 750 of file D3DPostProcessing.cpp.

{
    float texelWidthOrHeight = 1.0f / static_cast<float>(textureWidthOrHeight);

    // Fill the center texel
    float weight = 1.0f * GaussianDistribution(0, 0, deviation);
    colorWeights[blurKernelMidPoint] = float4(weight, weight, weight, 1.0f);

    textureCoordinateOffsets[blurKernelMidPoint] = 0.0f;

    // Fill one side
    for (int i = 1; i <= blurKernelMidPoint; i++)
    {
        weight = multiplier * GaussianDistribution(static_cast<float>(i), 0, deviation);
        textureCoordinateOffsets[blurKernelMidPoint - i] = -i * texelWidthOrHeight;

        colorWeights[blurKernelMidPoint - i] = float4(weight, weight, weight, 1.0f);
    }

    // Copy to the other side
    for (int i = (blurKernelMidPoint + 1); i < blurKernelSpan; i++)
    {
        colorWeights[i] = colorWeights[(blurKernelSpan - 1) - i];
        textureCoordinateOffsets[i] = - textureCoordinateOffsets[(blurKernelSpan - 1) - i];
    }
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/D3DPostProcessing.h File Reference

  • Direct3D post-processing effects
Classes

D3DPostProcessing.h File Reference

#include "DirectXBase.h"
#include "BasicMath.h"
#include "BasicCamera.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
struct | ConstantBufferLayoutForDX9BrightPassPixelShader
struct | ConstantBufferLayoutForGlowPixelShader
class | D3DPostProcessing
struct | ScreenQuadVertex
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DDSTextureLoader.cpp File Reference

  • Direct3D post-processing effects
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DDSTextureLoader.h File Reference

  • Direct3D post-processing effects
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DirectXApp.cpp File Reference

  • Direct3D post-processing effects
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 133 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DirectXApp.h File Reference

  • Direct3D post-processing effects
Classes

DirectXApp.h File Reference

#include "D3DPostProcessing.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DirectXBase.cpp File Reference

  • Direct3D post-processing effects

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DirectXBase.h File Reference

  • Direct3D post-processing effects
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DirectXSample.h File Reference

  • Direct3D post-processing effects
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/pch.cpp File Reference

  • Direct3D post-processing effects

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/pch.h File Reference

  • Direct3D post-processing effects

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/SampleOverlay.cpp File Reference

  • Direct3D post-processing effects

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/SampleOverlay.h File Reference

  • Direct3D post-processing effects
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicCamera.cpp File Reference

  • Direct3D resource loading

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicCamera.h File Reference

  • Direct3D resource loading
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicLoader.cpp File Reference

  • Direct3D resource loading

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicLoader.h File Reference

  • Direct3D resource loading
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicMath.h File Reference

  • Direct3D resource loading
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicReaderWriter.cpp File Reference

  • Direct3D resource loading

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicReaderWriter.h File Reference

  • Direct3D resource loading
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicShapes.cpp File Reference

  • Direct3D resource loading

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicShapes.h File Reference

  • Direct3D resource loading
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicTimer.cpp File Reference

  • Direct3D resource loading

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicTimer.h File Reference

  • Direct3D resource loading
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DDSTextureLoader.cpp File Reference

  • Direct3D resource loading
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DDSTextureLoader.h File Reference

  • Direct3D resource loading
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DirectXApp.cpp File Reference

  • Direct3D resource loading
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 158 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DirectXApp.h File Reference

  • Direct3D resource loading
Classes

DirectXApp.h File Reference

#include "ResourceLoading.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DirectXBase.cpp File Reference

  • Direct3D resource loading

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DirectXBase.h File Reference

  • Direct3D resource loading
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DirectXSample.h File Reference

  • Direct3D resource loading
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/LonLatController.cpp File Reference

  • Direct3D resource loading

LonLatController.cpp File Reference

#include "pch.h"
#include "LonLatController.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/LonLatController.h File Reference

  • Direct3D resource loading
Classes | Defines

LonLatController.h File Reference

Go to the source code of this file.

Classes

class | LonLatController

Defines

#define | LONLAT_GAIN 0.004f
#define | LONLATKEY_GAIN 0.04f

Define Documentation

#define LONLAT_GAIN 0.004f

Definition at line 11 of file LonLatController.h.

#define LONLATKEY_GAIN 0.04f

Definition at line 12 of file LonLatController.h.

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/pch.cpp File Reference

  • Direct3D resource loading

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/pch.h File Reference

  • Direct3D resource loading

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/ResourceLoading.cpp File Reference

  • Direct3D resource loading

ResourceLoading.cpp File Reference

#include "pch.h"
#include "ResourceLoading.h"
#include "BasicShapes.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/ResourceLoading.h File Reference

  • Direct3D resource loading
Classes

ResourceLoading.h File Reference

#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "BasicMath.h"
#include "BasicCamera.h"
#include "LonLatController.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | ResourceLoading
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/SampleOverlay.cpp File Reference

  • Direct3D resource loading

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/SampleOverlay.h File Reference

  • Direct3D resource loading
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/obj2vbo/BasicMath.h File Reference

  • Direct3D resource loading
  • obj2vbo
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/obj2vbo/obj2vbo.cpp File Reference

  • Direct3D resource loading
  • obj2vbo
Classes | Functions

obj2vbo.cpp File Reference

#include <iostream>
#include <sstream>
#include <fstream>
#include <vector>
#include <map>
#include "BasicMath.h"

Go to the source code of this file.

Classes

struct | BasicVertex
struct | IndexTriplet

Functions

int | main (int argc, char *argv[])
bool | operator< (const IndexTriplet &lhs, const IndexTriplet &rhs)
void | usage ()

Function Documentation

int main | ( | int | argc,
 |  | char * | argv[]
 | ) |  |

Definition at line 46 of file obj2vbo.cpp.

{
    // Parse arguments

    if (argc < 3 || argc > 4)
    {
        usage();
        return -1;
    }

    bool normalizePositions = false;
    if (argc == 4)
    {
        if (strcmp(argv[3], "/normalize") == 0)
        {
            normalizePositions = true;
        }
        else
        {
            usage();
            return -1;
        }
    }

    ifstream objFile(argv[1], ifstream::in);
    if (!objFile.is_open())
    {
        cout << "error: could not open file \"" << argv[1] << "\" for read" << endl;
        return -1;
    }

    // Parse the object file

    vector<float3> positions;
    vector<float3> normals;
    vector<float2> texcoords;
    vector<vector<IndexTriplet>> faces;

    unsigned int lineNum = 1;

    while (objFile.good())
    {
        string line;
        getline(objFile, line);
        istringstream lineStream(line);

        // Parse the line if not a comment
        if (lineStream.peek() != '#')
        {
            string tag;
            lineStream >> tag;

            // Warn on unsupported tags
            if (
                tag.compare("mtllib") == 0 ||
                tag.compare("o") == 0 ||
                tag.compare("g") == 0 ||
                tag.compare("usemtl") == 0 ||
                tag.compare("s") == 0
                )
            {
                cout << argv[1] << "(" << lineNum << "): warning: BasicMesh VBO format does not support tag \"" << tag << "\"" << endl;
            }

            // Parse the vertex position
            else if (tag.compare("v") == 0)
            {
                float3 pos;
                lineStream >> pos.x >> pos.y >> pos.z;
                positions.push_back(pos);
            }

            // Parse the vertex normal
            else if (tag.compare("vn") == 0)
            {
                float3 norm;
                lineStream >> norm.x >> norm.y >> norm.z;
                normals.push_back(norm);
            }

            // Parse the vertex texture coordinate
            else if (tag.compare("vt") == 0)
            {
                float2 tex;
                lineStream >> tex.x >> tex.y;
                texcoords.push_back(tex);
            }

            // Parse the face
            else if (tag.compare("f") == 0)
            {
                vector<IndexTriplet> face;
                while (lineStream.good())
                {
                    string tripletString;
                    lineStream >> tripletString;
                    if (tripletString.size() > 0)
                    {
                        istringstream tripletStream(tripletString);

                        IndexTriplet triplet;
                        triplet.pos = 0;
                        triplet.norm = 0;
                        triplet.tex = 0;

                        // Parse the face triplet.  Valid formats include:
                        //  [pos] ...
                        //  [pos]/[tex] ...
                        //  [pos]/[tex]/[norm] ...
                        //  [pos]// [norm] ...

                        tripletStream >> triplet.pos;
                        if (tripletStream.get() == '/')
                        {
                            if (tripletStream.peek() != '/')
                            {
                                tripletStream >> triplet.tex;
                            }
                            if (tripletStream.get() == '/')
                            {
                                tripletStream >> triplet.norm;
                            }
                        }
                        face.push_back(triplet);
                    }
                }
                faces.push_back(face);
            }

            // Fail on unknown tag
            else if (tag.size() > 0)
            {
                cout << argv[1] << "(" << lineNum << "): error: unknown tag \"" << tag << "\"" << endl;
            }
        }
        lineNum++;
    }

    objFile.close();

    if (positions.size() == 0 || faces.size() == 0)
    {
        cout << "error: obj file \"" << argv[1] << "\" contains no geometry" << endl;
        return -1;
    }

    // Validate mesh data

    for (auto face = faces.begin(); face != faces.end(); face++)
    {
        if (face->size() < 3)
        {
            cout << "error: face size " << face->size() << " invalid" << endl;
            return -1;
        }
        for (auto triplet = face->begin(); triplet != face->end(); triplet++)
        {
            if (triplet->pos > positions.size() || triplet->pos < 1)
            {
                cout << "error: position index " << triplet->pos << " out of range" << endl;
                return -1;
            }
            if (triplet->norm > normals.size() || triplet->norm < 0)
            {
                cout << "error: normal index " << triplet->norm << " out of range" << endl;
                return -1;
            }
            if (triplet->tex > texcoords.size() || triplet->tex < 0)
            {
                cout << "error: texcoord index " << triplet->tex << " out of range" << endl;
                return -1;
            }
        }
    }

    // Get the bounding box and center of the mesh

    float3 boxMin = positions[faces[0][0].pos - 1];
    float3 boxMax = boxMin;
    for (auto face = faces.begin(); face != faces.end(); face++)
    {
        for (auto triplet = face->begin(); triplet != face->end(); triplet++)
        {
            float3 pos = positions[triplet->pos - 1];
            boxMin.x = min(boxMin.x, pos.x);
            boxMin.y = min(boxMin.y, pos.y);
            boxMin.z = min(boxMin.z, pos.z);
            boxMax.x = max(boxMax.x, pos.x);
            boxMax.y = max(boxMax.y, pos.y);
            boxMax.z = max(boxMax.z, pos.z);
        }
    }
    float3 boxCenter = (boxMax+boxMin) / 2.0f;

    // If specified in the arguments, normalize geometry to fit within a unit cube

    if (normalizePositions)
    {
        float maxAxis = max(max(boxMax.x - boxMin.x, boxMax.y - boxMin.y), boxMax.z - boxMin.z);
        for (auto pos = positions.begin(); pos != positions.end(); pos++)
        {
            *pos = (*pos - boxCenter) / maxAxis;
        }
    }

    // Generate missing normals using faceted technique

    for (auto face = faces.begin(); face != faces.end(); face++)
    {
        float3 normal(0, 0, 0);
        bool normalGenerated = false;
        for (auto triplet = face->begin(); triplet != face->end(); triplet++)
        {
            if (!normalGenerated && triplet->norm == 0)
            {
                for (auto triplet = face->begin(); triplet != face->end(); triplet++)
                {
                    float3 posThis = positions[triplet->pos - 1];
                    float3 posPrev = positions[(triplet == face->begin() ? (face->end() - 1)->pos : (triplet - 1)->pos) - 1];
                    float3 posNext = positions[(triplet == face->end() - 1 ? (face->begin())->pos : (triplet + 1)->pos) - 1];
                    normal = normal + cross(posNext - posThis, posPrev - posThis);
                    triplet->norm = normals.size() + 1;
                }
                normals.push_back(normal);
                normalGenerated = true;
            }
        }
    }

    // Fill in missing texture coordinates with (0, 0)

    bool missingTexcoordCreated = false;
    unsigned int missingTexcoordIndex = 0;
    for (auto face = faces.begin(); face != faces.end(); face++)
    {
        for (auto triplet = face->begin(); triplet != face->end(); triplet++)
        {
            if (triplet->tex == 0)
            {
                if (!missingTexcoordCreated)
                {
                    texcoords.push_back(float2(0.0f, 0.0f));
                    missingTexcoordIndex = texcoords.size();
                    missingTexcoordCreated = true;
                }
                triplet->tex = missingTexcoordIndex;
            }
        }
    }

    // Generate unique vertices and convert counter-clockwise faces to clockwise triangles

    vector<BasicVertex> vertices;
    vector<unsigned short> indices;
    map<IndexTriplet, unsigned short> tripletIndices;
    for (auto face = faces.begin(); face != faces.end(); face++)
    {
        for (auto triplet = face->begin(); triplet != face->end(); triplet++)
        {
            if (tripletIndices.find(*triplet) == tripletIndices.end())
            {
                tripletIndices[*triplet] = static_cast<unsigned short>(vertices.size());
                BasicVertex vertex;
                vertex.pos = positions[triplet->pos - 1];
                vertex.norm = normals[triplet->norm - 1];
                vertex.tex = texcoords[triplet->tex - 1];
                vertices.push_back(vertex);
            }
            if (triplet >= face->begin() + 2)
            {
                indices.push_back(tripletIndices[*face->begin()]);
                indices.push_back(tripletIndices[*triplet]);
                indices.push_back(tripletIndices[*(triplet - 1)]);
            }
        }
    }

    // Dump vertex and index data to the output VBO file

    ofstream vboFile(argv[2], ofstream::out | ofstream::binary);
    if (!vboFile.is_open())
    {
        cout << "error: could not open file \"" << argv[2] << "\" for write" << endl;
        return -1;
    }

    unsigned int numVertices = vertices.size();
    unsigned int numIndices = indices.size();
    vboFile.write(reinterpret_cast<char*>(&numVertices), sizeof(unsigned int));
    vboFile.write(reinterpret_cast<char*>(&numIndices), sizeof(unsigned int));
    vboFile.write(reinterpret_cast<char*>(&vertices[0]), sizeof(BasicVertex) * vertices.size());
    vboFile.write(reinterpret_cast<char*>(&indices[0]), sizeof(unsigned short) * indices.size());

    vboFile.close();

    return 0;
}

bool operator< | ( | const IndexTriplet & | lhs,
 |  | const IndexTriplet & | rhs
 | ) |  |

Definition at line 31 of file obj2vbo.cpp.

{
    return memcmp(&lhs, &rhs, sizeof(IndexTriplet)) < 0;
}

void usage ( )

Definition at line 36 of file obj2vbo.cpp.

{
    cout << "usage: obj2vbo.exe [input obj] [output vbo] [/normalize]" << endl;
    cout << "  input obj    specifies the input OBJ mesh file" << endl;
    cout << "  output vbo   specifies the output VBO file" << endl;
    cout << "  /normalize   transform vertex positions to fit a unit bounding box about the origin" << endl;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/BC.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

BC.cpp File Reference

#include "directxtexp.h"
#include "BC.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ void | DirectX::D3DXDecodeBC1 (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXDecodeBC2 (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXDecodeBC3 (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC1 (uint8_t *pBC, const XMVECTOR *pColor, float alphaRef, DWORD flags)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC2 (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC3 (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/BC.h File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Defines | Typedefs | Enumerations | Functions | Variables

BC.h File Reference

#include <assert.h>
#include <directxmath.h>
#include <directxpackedvector.h>
#include <float.h>
#include <stdint.h>

Go to the source code of this file.

Classes

class | DirectX::CBits< SizeInBytes >
struct | DirectX::D3DX_BC1
struct | DirectX::D3DX_BC2
struct | DirectX::D3DX_BC3
class | DirectX::D3DX_BC6H
struct | DirectX::D3DX_BC6H::EncodeParams
struct | DirectX::D3DX_BC6H::ModeDescriptor
struct | DirectX::D3DX_BC6H::ModeInfo
class | DirectX::D3DX_BC7
struct | DirectX::D3DX_BC7::EncodeParams
struct | DirectX::D3DX_BC7::ModeInfo
class | DirectX::HDRColorA
struct | DirectX::HDREndPntPair
class | DirectX::INTColor
struct | DirectX::INTEndPntPair
class | DirectX::LDRColorA
struct | DirectX::LDREndPntPair

Namespaces

namespace | DirectX

Defines

#define | BC6H_MAX_INDICES 16
#define | BC6H_MAX_REGIONS 2
#define | BC7_MAX_INDICES 16
#define | BC7_MAX_REGIONS 3
#define | NUM_PIXELS_PER_BLOCK 16
#define | SIGN_EXTEND(x, nb) ((((x)&(1<<((nb)-1)))?((~0)<<(nb)):0)|(x))

Typedefs

typedef void(* | DirectX::BC_DECODE )(XMVECTOR *pColor, const uint8_t *pBC)
typedef void(* | DirectX::BC_ENCODE )(uint8_t *pDXT, const XMVECTOR *pColor, DWORD flags)

Enumerations

enum | DirectX::BC_FLAGS { DirectX::BC_FLAGS_NONE = 0x0, DirectX::BC_FLAGS_DITHER_RGB = 0x10000, DirectX::BC_FLAGS_DITHER_A = 0x20000, DirectX::BC_FLAGS_UNIFORM = 0x40000 }

Functions

void | DirectX::D3DXDecodeBC1 (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(8) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC2 (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC3 (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC4S (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(8) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC4U (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(8) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC5S (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC5U (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC6HS (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC6HU (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | DirectX::D3DXDecodeBC7 (_Out_writes_(NUM_PIXELS_PER_BLOCK) XMVECTOR *pColor, _In_reads_(16) const uint8_t *pBC)
void | DirectX::D3DXEncodeBC1 (_Out_writes_(8) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ float alphaRef, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC2 (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC3 (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC4S (_Out_writes_(8) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC4U (_Out_writes_(8) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC5S (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC5U (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC6HS (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC6HU (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
void | DirectX::D3DXEncodeBC7 (_Out_writes_(16) uint8_t *pBC, _In_reads_(NUM_PIXELS_PER_BLOCK) const XMVECTOR *pColor, _In_ DWORD flags)
HDRColorA * | DirectX::HDRColorALerp (_Out_ HDRColorA *pOut, _In_ const HDRColorA *pC1, _In_ const HDRColorA *pC2, _In_ float s)
template<bool bRange>
void | DirectX::OptimizeAlpha (float *pX, float *pY, const float *pPoints, size_t cSteps)

Variables

const uint32_t | DirectX::BC67_WEIGHT_MAX = 64
const uint32_t | DirectX::BC67_WEIGHT_ROUND = 32
const uint32_t | DirectX::BC67_WEIGHT_SHIFT = 6
const size_t | DirectX::BC6H_MAX_SHAPES = 32
const size_t | DirectX::BC6H_NUM_CHANNELS = 3
const size_t | DirectX::BC7_MAX_SHAPES = 64
const size_t | DirectX::BC7_NUM_CHANNELS = 4
const uint16_t | DirectX::F16EM_MASK = 0x7fff
const uint16_t | DirectX::F16MAX = 0x7bff
const uint16_t | DirectX::F16S_MASK = 0x8000
const int | DirectX::g_aWeights2 [4] = {0, 21, 43, 64}
const int | DirectX::g_aWeights3 [8] = {0, 9, 18, 27, 37, 46, 55, 64}
const int | DirectX::g_aWeights4 [16] = {0, 4, 9, 13, 17, 21, 26, 30, 34, 38, 43, 47, 51, 55, 60, 64}

Define Documentation

#define BC6H_MAX_INDICES 16

Definition at line 44 of file BC.h.

#define BC6H_MAX_REGIONS 2

Definition at line 43 of file BC.h.

#define BC7_MAX_INDICES 16

Definition at line 46 of file BC.h.

#define BC7_MAX_REGIONS 3

Definition at line 45 of file BC.h.

#define NUM_PIXELS_PER_BLOCK 16

Definition at line 42 of file BC.h.

#define SIGN_EXTEND | ( | x,
 |  | nb |
 | ) |  | ((((x)&(1<<((nb)-1)))?((~0)<<(nb)):0)|(x))

Definition at line 39 of file BC.h.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/BC4BC5.cpp File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Defines | Functions

BC4BC5.cpp File Reference

#include "directxtexp.h"
#include "BC.h"

Go to the source code of this file.

Classes

struct | DirectX::BC4_SNORM
struct | DirectX::BC4_UNORM

Namespaces

namespace | DirectX

Defines

#define | BLOCK_LEN 4
#define | BLOCK_SIZE (BLOCK_LEN * BLOCK_LEN)

Functions

_Use_decl_annotations_ void | DirectX::D3DXDecodeBC4S (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXDecodeBC4U (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXDecodeBC5S (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXDecodeBC5U (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC4S (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC4U (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC5S (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC5U (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)

Define Documentation

#define BLOCK_LEN 4

Definition at line 28 of file BC4BC5.cpp.

#define BLOCK_SIZE (BLOCK_LEN * BLOCK_LEN)

Definition at line 31 of file BC4BC5.cpp.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/BC6HBC7.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

BC6HBC7.cpp File Reference

#include "directxtexp.h"
#include "BC.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ void | DirectX::D3DXDecodeBC6HS (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXDecodeBC6HU (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXDecodeBC7 (XMVECTOR *pColor, const uint8_t *pBC)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC6HS (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC6HU (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
_Use_decl_annotations_ void | DirectX::D3DXEncodeBC7 (uint8_t *pBC, const XMVECTOR *pColor, DWORD flags)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DDS.h File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Defines | Typedefs | Enumerations | Functions | Variables

DDS.h File Reference

#include <dxgiformat.h>
#include <stdint.h>

Go to the source code of this file.

Classes

struct | DirectX::DDS_HEADER
struct | DirectX::DDS_HEADER_DXT10
struct | DirectX::DDS_PIXELFORMAT

Namespaces

namespace | DirectX

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Typedefs

typedef enum
DirectX::DDS_RESOURCE_DIMENSION 		DirectX::DDS_RESOURCE_DIMENSION
typedef enum
DirectX::DDS_RESOURCE_MISC_FLAG 		DirectX::DDS_RESOURCE_MISC_FLAG

Enumerations

enum | DirectX::DDS_RESOURCE_DIMENSION { DirectX::DDS_DIMENSION_TEXTURE1D = 2, DirectX::DDS_DIMENSION_TEXTURE2D = 3, DirectX::DDS_DIMENSION_TEXTURE3D = 4 }
enum | DirectX::DDS_RESOURCE_MISC_FLAG { DirectX::DDS_RESOURCE_MISC_TEXTURECUBE = 0x4L }

Functions

DirectX::__declspec (selectany) const DDS_PIXELFORMAT DDSPF_DXT1

Variables

const uint32_t | DirectX::DDS_MAGIC = 0x20534444

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 54 of file DDS.h.

#define DDS_CUBEMAP 0x00000200

Definition at line 165 of file DDS.h.

#define DDS_CUBEMAP_ALLFACES
Value:
( DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ )

Definition at line 161 of file DDS.h.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 155 of file DDS.h.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 157 of file DDS.h.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 159 of file DDS.h.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 154 of file DDS.h.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 156 of file DDS.h.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 158 of file DDS.h.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 167 of file DDS.h.

#define DDS_FOURCC 0x00000004

Definition at line 49 of file DDS.h.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 145 of file DDS.h.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 142 of file DDS.h.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 144 of file DDS.h.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 141 of file DDS.h.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 143 of file DDS.h.

#define DDS_HEIGHT 0x00000002

Definition at line 147 of file DDS.h.

#define DDS_LUMINANCE 0x00020000

Definition at line 52 of file DDS.h.

#define DDS_LUMINANCEA 0x00020001

Definition at line 53 of file DDS.h.

#define DDS_PAL8 0x00000020

Definition at line 55 of file DDS.h.

#define DDS_RGB 0x00000040

Definition at line 50 of file DDS.h.

#define DDS_RGBA 0x00000041

Definition at line 51 of file DDS.h.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 152 of file DDS.h.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 151 of file DDS.h.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 150 of file DDS.h.

#define DDS_WIDTH 0x00000004

Definition at line 148 of file DDS.h.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32_t)(uint8_t)(ch0) | ((uint32_t)(uint8_t)(ch1) << 8) |       \
                ((uint32_t)(uint8_t)(ch2) << 16) | ((uint32_t)(uint8_t)(ch3) << 24 ))

Definition at line 58 of file DDS.h.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTex.h File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Defines | Enumerations | Functions

DirectXTex.h File Reference

#include <stdint.h>
#include <algorithm>
#include <dxgiformat.h>
#include <d3d11.h>
#include "DirectXTex.inl"

Go to the source code of this file.

Classes

class | DirectX::Blob
struct | DirectX::Image
struct | DirectX::Rect
class | DirectX::ScratchImage
struct | DirectX::TexMetadata

Namespaces

namespace | DirectX

Defines

#define | DIRECTX_TEX_VERSION 100

Enumerations

enum DirectX::CNMAP_FLAGS {
DirectX::CNMAP_DEFAULT = 0, DirectX::CNMAP_CHANNEL_RED = 0x1, DirectX::CNMAP_CHANNEL_GREEN = 0x2, DirectX::CNMAP_CHANNEL_BLUE = 0x3,
DirectX::CNMAP_CHANNEL_ALPHA = 0x4, DirectX::CNMAP_CHANNEL_LUMINANCE = 0x5, DirectX::CNMAP_MIRROR_U = 0x1000, DirectX::CNMAP_MIRROR_V = 0x2000,
DirectX::CNMAP_MIRROR = 0x3000, DirectX::CNMAP_INVERT_SIGN = 0x4000, DirectX::CNMAP_COMPUTE_OCCLUSION = 0x8000
}
enum DirectX::CP_FLAGS {
DirectX::CP_FLAGS_NONE = 0x0, DirectX::CP_FLAGS_LEGACY_DWORD = 0x1, DirectX::CP_FLAGS_24BPP = 0x10000, DirectX::CP_FLAGS_16BPP = 0x20000,
DirectX::CP_FLAGS_8BPP = 0x40000
}
enum DirectX::DDS_FLAGS {
DirectX::DDS_FLAGS_NONE = 0x0, DirectX::DDS_FLAGS_LEGACY_DWORD = 0x1, DirectX::DDS_FLAGS_NO_LEGACY_EXPANSION = 0x2, DirectX::DDS_FLAGS_NO_R10B10G10A2_FIXUP = 0x4,
DirectX::DDS_FLAGS_FORCE_RGB = 0x8, DirectX::DDS_FLAGS_NO_16BPP = 0x10, DirectX::DDS_FLAGS_FORCE_DX10_EXT = 0x10000
}
enum DirectX::TEX_COMPRESS_FLAGS {
DirectX::TEX_COMPRESS_DEFAULT = 0, DirectX::TEX_COMPRESS_RGB_DITHER = 0x10000, DirectX::TEX_COMPRESS_A_DITHER = 0x20000, DirectX::TEX_COMPRESS_DITHER = 0x30000,
DirectX::TEX_COMPRESS_UNIFORM = 0x40000, DirectX::TEX_COMPRESS_PARALLEL = 0x10000000
}
enum | DirectX::TEX_DIMENSION { DirectX::TEX_DIMENSION_TEXTURE1D = 2, DirectX::TEX_DIMENSION_TEXTURE2D = 3, DirectX::TEX_DIMENSION_TEXTURE3D = 4 }
enum DirectX::TEX_FILTER_FLAGS {
DirectX::TEX_FILTER_DEFAULT = 0, DirectX::TEX_FILTER_SEPARATE_ALPHA = 0x100, DirectX::TEX_FILTER_DITHER = 0x10000, DirectX::TEX_FILTER_DITHER_DIFFUSION = 0x20000,
DirectX::TEX_FILTER_POINT = 0x100000, DirectX::TEX_FILTER_LINEAR = 0x200000, DirectX::TEX_FILTER_CUBIC = 0x300000, DirectX::TEX_FILTER_FANT = 0x400000,
DirectX::TEX_FILTER_SRGB_IN = 0x1000000, DirectX::TEX_FILTER_SRGB_OUT = 0x2000000, DirectX::TEX_FILTER_SRGB = 0x3000000
}
enum DirectX::TEX_FR_FLAGS {
DirectX::TEX_FR_ROTATE0 = 0x0, DirectX::TEX_FR_ROTATE90 = 0x1, DirectX::TEX_FR_ROTATE180 = 0x2, DirectX::TEX_FR_ROTATE270 = 0x3,
DirectX::TEX_FR_FLIP_HORIZONTAL = 0x08, DirectX::TEX_FR_FLIP_VERTICAL = 0x10
}
enum | DirectX::TEX_MISC_FLAG { DirectX::TEX_MISC_TEXTURECUBE = 0x4L }
enum DirectX::WIC_FLAGS {
DirectX::WIC_FLAGS_NONE = 0x0, DirectX::WIC_FLAGS_FORCE_RGB = 0x1, DirectX::WIC_FLAGS_NO_X2_BIAS = 0x2, DirectX::WIC_FLAGS_NO_16BPP = 0x4,
DirectX::WIC_FLAGS_ALLOW_MONO = 0x8, DirectX::WIC_FLAGS_ALL_FRAMES = 0x10, DirectX::WIC_FLAGS_DITHER = 0x10000, DirectX::WIC_FLAGS_DITHER_DIFFUSION = 0x20000,
DirectX::WIC_FLAGS_FILTER_POINT = 0x100000, DirectX::WIC_FLAGS_FILTER_LINEAR = 0x200000, DirectX::WIC_FLAGS_FILTER_CUBIC = 0x300000, DirectX::WIC_FLAGS_FILTER_FANT = 0x400000
}
enum DirectX::WICCodecs {
DirectX::WIC_CODEC_BMP = 1, DirectX::WIC_CODEC_JPEG, DirectX::WIC_CODEC_PNG, DirectX::WIC_CODEC_TIFF,
DirectX::WIC_CODEC_GIF, DirectX::WIC_CODEC_WMP, DirectX::WIC_CODEC_ICO
}

Functions

size_t | DirectX::BitsPerPixel (_In_ DXGI_FORMAT fmt)
HRESULT | DirectX::CaptureTexture (_In_ ID3D11Device *pDevice, _In_ ID3D11DeviceContext *pContext, _In_ ID3D11Resource *pSource, _Out_ ScratchImage &result)
HRESULT | DirectX::Compress (_In_ const Image &srcImage, _In_ DXGI_FORMAT format, _In_ DWORD compress, _In_ float alphaRef, _Out_ ScratchImage &cImage)
HRESULT | DirectX::Compress (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DXGI_FORMAT format, _In_ DWORD compress, _In_ float alphaRef, _Out_ ScratchImage &cImages)
HRESULT | DirectX::ComputeMSE (_In_ const Image &image1, _In_ const Image &image2, _Out_ float &mse, _Out_writes_opt_(4) float *mseV)
HRESULT | DirectX::ComputeNormalMap (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD flags, _In_ float amplitude, _In_ DXGI_FORMAT format, _Out_ ScratchImage &normalMaps)
HRESULT | DirectX::ComputeNormalMap (_In_ const Image &srcImage, _In_ DWORD flags, _In_ float amplitude, _In_ DXGI_FORMAT format, _Out_ ScratchImage &normalMap)
void | DirectX::ComputePitch (_In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _Out_ size_t &rowPitch, _Out_ size_t &slicePitch, _In_ DWORD flags=CP_FLAGS_NONE)
size_t | DirectX::ComputeScanlines (_In_ DXGI_FORMAT fmt, _In_ size_t height)
_Use_decl_annotations_ size_t | DirectX::ComputeScanlines (DXGI_FORMAT fmt, size_t height)
HRESULT | DirectX::Convert (_In_ const Image &srcImage, _In_ DXGI_FORMAT format, _In_ DWORD filter, _In_ float threshold, _Out_ ScratchImage &image)
HRESULT | DirectX::Convert (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DXGI_FORMAT format, _In_ DWORD filter, _In_ float threshold, _Out_ ScratchImage &result)
HRESULT | DirectX::CopyRectangle (_In_ const Image &srcImage, _In_ const Rect &srcRect, _In_ const Image &dstImage, _In_ DWORD filter, _In_ size_t xOffset, _In_ size_t yOffset)
HRESULT | DirectX::CreateShaderResourceView (_In_ ID3D11Device *pDevice, _In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _Outptr_ ID3D11ShaderResourceView **ppSRV)
HRESULT | DirectX::CreateTexture (_In_ ID3D11Device *pDevice, _In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _Outptr_ ID3D11Resource **ppResource)
HRESULT | DirectX::Decompress (_In_ const Image &cImage, _In_ DXGI_FORMAT format, _Out_ ScratchImage &image)
HRESULT | DirectX::Decompress (_In_reads_(nimages) const Image *cImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DXGI_FORMAT format, _Out_ ScratchImage &images)
HRESULT | DirectX::FlipRotate (_In_ const Image &srcImage, _In_ DWORD flags, _Out_ ScratchImage &image)
HRESULT | DirectX::FlipRotate (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD flags, _Out_ ScratchImage &result)
HRESULT | DirectX::GenerateMipMaps (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD filter, _In_ size_t levels, _Inout_ ScratchImage &mipChain)
HRESULT | DirectX::GenerateMipMaps (_In_ const Image &baseImage, _In_ DWORD filter, _In_ size_t levels, _Inout_ ScratchImage &mipChain, _In_ bool allow1D=false)
HRESULT | DirectX::GenerateMipMaps3D (_In_reads_(depth) const Image *baseImages, _In_ size_t depth, _In_ DWORD filter, _In_ size_t levels, _Out_ ScratchImage &mipChain)
HRESULT | DirectX::GenerateMipMaps3D (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD filter, _In_ size_t levels, _Out_ ScratchImage &mipChain)
HRESULT | DirectX::GetMetadataFromDDSFile (_In_ LPCWSTR szFile, _In_ DWORD flags, _Out_ TexMetadata &metadata)
HRESULT | DirectX::GetMetadataFromDDSMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags, _Out_ TexMetadata &metadata)
HRESULT | DirectX::GetMetadataFromTGAFile (_In_ LPCWSTR szFile, _Out_ TexMetadata &metadata)
HRESULT | DirectX::GetMetadataFromTGAMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _Out_ TexMetadata &metadata)
HRESULT | DirectX::GetMetadataFromWICFile (_In_ LPCWSTR szFile, _In_ DWORD flags, _Out_ TexMetadata &metadata)
HRESULT | DirectX::GetMetadataFromWICMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags, _Out_ TexMetadata &metadata)
REFGUID | DirectX::GetWICCodec (_In_ WICCodecs codec)
bool | DirectX::IsCompressed (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | DirectX::IsCompressed (DXGI_FORMAT fmt)
bool | DirectX::IsPacked (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | DirectX::IsPacked (DXGI_FORMAT fmt)
bool | DirectX::IsSRGB (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | DirectX::IsSRGB (DXGI_FORMAT fmt)
bool | DirectX::IsSupportedTexture (_In_ ID3D11Device *pDevice, _In_ const TexMetadata &metadata)
bool | DirectX::IsTypeless (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | DirectX::IsTypeless (DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | DirectX::IsValid (DXGI_FORMAT fmt)
bool | DirectX::IsValid (_In_ DXGI_FORMAT fmt)
bool | DirectX::IsVideo (_In_ DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | DirectX::IsVideo (DXGI_FORMAT fmt)
HRESULT | DirectX::LoadFromDDSFile (_In_ LPCWSTR szFile, _In_ DWORD flags, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
HRESULT | DirectX::LoadFromDDSMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
HRESULT | DirectX::LoadFromTGAFile (_In_ LPCWSTR szFile, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
HRESULT | DirectX::LoadFromTGAMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
HRESULT | DirectX::LoadFromWICFile (_In_ LPCWSTR szFile, _In_ DWORD flags, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
HRESULT | DirectX::LoadFromWICMemory (_In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags, _Out_opt_ TexMetadata *metadata, _Out_ ScratchImage &image)
DXGI_FORMAT | DirectX::MakeSRGB (_In_ DXGI_FORMAT fmt)
HRESULT | DirectX::Resize (_In_ const Image &srcImage, _In_ size_t width, _In_ size_t height, _In_ DWORD filter, _Out_ ScratchImage &image)
HRESULT | DirectX::Resize (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ size_t width, _In_ size_t height, _In_ DWORD filter, _Out_ ScratchImage &result)
_Use_decl_annotations_ HRESULT | DirectX::SaveToDDSFile (const Image &image, DWORD flags, LPCWSTR szFile)
HRESULT | DirectX::SaveToDDSFile (_In_ const Image &image, _In_ DWORD flags, _In_ LPCWSTR szFile)
HRESULT | DirectX::SaveToDDSFile (_In_reads_(nimages) const Image *images, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD flags, _In_ LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | DirectX::SaveToDDSMemory (const Image &image, DWORD flags, Blob &blob)
HRESULT | DirectX::SaveToDDSMemory (_In_reads_(nimages) const Image *images, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DWORD flags, _Out_ Blob &blob)
HRESULT | DirectX::SaveToDDSMemory (_In_ const Image &image, _In_ DWORD flags, _Out_ Blob &blob)
HRESULT | DirectX::SaveToTGAFile (_In_ const Image &image, _In_ LPCWSTR szFile)
HRESULT | DirectX::SaveToTGAMemory (_In_ const Image &image, _Out_ Blob &blob)
HRESULT | DirectX::SaveToWICFile (_In_ const Image &image, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _In_ LPCWSTR szFile)
HRESULT | DirectX::SaveToWICFile (_In_reads_(nimages) const Image *images, _In_ size_t nimages, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _In_ LPCWSTR szFile)
HRESULT | DirectX::SaveToWICMemory (_In_reads_(nimages) const Image *images, _In_ size_t nimages, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _Out_ Blob &blob)
HRESULT | DirectX::SaveToWICMemory (_In_ const Image &image, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _Out_ Blob &blob)

Define Documentation

#define DIRECTX_TEX_VERSION 100

Definition at line 30 of file DirectXTex.h.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTex.inl File Reference

  • Direct3D resource loading
  • texconv
Functions

DirectXTex.inl File Reference

Go to the source code of this file.

Functions

_Use_decl_annotations_ size_t | ComputeScanlines (DXGI_FORMAT fmt, size_t height)
_Use_decl_annotations_ bool | IsCompressed (DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsPacked (DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsSRGB (DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsTypeless (DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsValid (DXGI_FORMAT fmt)
_Use_decl_annotations_ bool | IsVideo (DXGI_FORMAT fmt)
_Use_decl_annotations_ HRESULT | SaveToDDSFile (const Image &image, DWORD flags, LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | SaveToDDSMemory (const Image &image, DWORD flags, Blob &blob)

Function Documentation

_Use_decl_annotations_ size_t ComputeScanlines | ( | DXGI_FORMAT | fmt,
 |  | size_t | height |
 | ) |  |  | [inline]

Definition at line 157 of file DirectXTex.inl.

{
    switch ( fmt )
    {
    case DXGI_FORMAT_BC1_TYPELESS:
    case DXGI_FORMAT_BC1_UNORM:
    case DXGI_FORMAT_BC1_UNORM_SRGB:
    case DXGI_FORMAT_BC2_TYPELESS:
    case DXGI_FORMAT_BC2_UNORM:
    case DXGI_FORMAT_BC2_UNORM_SRGB:
    case DXGI_FORMAT_BC3_TYPELESS:
    case DXGI_FORMAT_BC3_UNORM:
    case DXGI_FORMAT_BC3_UNORM_SRGB:
    case DXGI_FORMAT_BC4_TYPELESS:
    case DXGI_FORMAT_BC4_UNORM:
    case DXGI_FORMAT_BC4_SNORM:
    case DXGI_FORMAT_BC5_TYPELESS:
    case DXGI_FORMAT_BC5_UNORM:
    case DXGI_FORMAT_BC5_SNORM:
    case DXGI_FORMAT_BC6H_TYPELESS:
    case DXGI_FORMAT_BC6H_UF16:
    case DXGI_FORMAT_BC6H_SF16:
    case DXGI_FORMAT_BC7_TYPELESS:
    case DXGI_FORMAT_BC7_UNORM:
    case DXGI_FORMAT_BC7_UNORM_SRGB:
        return std::max<size_t>( 1, (height + 3) / 4 );

    default:
        return height;
    }
}

_Use_decl_annotations_ bool IsCompressed ( DXGI_FORMAT fmt ) [inline]

Definition at line 29 of file DirectXTex.inl.

{
    switch ( fmt )
    {
    case DXGI_FORMAT_BC1_TYPELESS:
    case DXGI_FORMAT_BC1_UNORM:
    case DXGI_FORMAT_BC1_UNORM_SRGB:
    case DXGI_FORMAT_BC2_TYPELESS:
    case DXGI_FORMAT_BC2_UNORM:
    case DXGI_FORMAT_BC2_UNORM_SRGB:
    case DXGI_FORMAT_BC3_TYPELESS:
    case DXGI_FORMAT_BC3_UNORM:
    case DXGI_FORMAT_BC3_UNORM_SRGB:
    case DXGI_FORMAT_BC4_TYPELESS:
    case DXGI_FORMAT_BC4_UNORM:
    case DXGI_FORMAT_BC4_SNORM:
    case DXGI_FORMAT_BC5_TYPELESS:
    case DXGI_FORMAT_BC5_UNORM:
    case DXGI_FORMAT_BC5_SNORM:
    case DXGI_FORMAT_BC6H_TYPELESS:
    case DXGI_FORMAT_BC6H_UF16:
    case DXGI_FORMAT_BC6H_SF16:
    case DXGI_FORMAT_BC7_TYPELESS:
    case DXGI_FORMAT_BC7_UNORM:
    case DXGI_FORMAT_BC7_UNORM_SRGB:
        return true;

    default:
        return false;
    }
}

_Use_decl_annotations_ bool IsPacked ( DXGI_FORMAT fmt ) [inline]

Definition at line 62 of file DirectXTex.inl.

{
    return ( (fmt == DXGI_FORMAT_R8G8_B8G8_UNORM) || (fmt == DXGI_FORMAT_G8R8_G8B8_UNORM) );
}

_Use_decl_annotations_ bool IsSRGB ( DXGI_FORMAT fmt ) [inline]

Definition at line 100 of file DirectXTex.inl.

{
    switch( fmt )
    {
    case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
    case DXGI_FORMAT_BC1_UNORM_SRGB:
    case DXGI_FORMAT_BC2_UNORM_SRGB:
    case DXGI_FORMAT_BC3_UNORM_SRGB:
    case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
    case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
    case DXGI_FORMAT_BC7_UNORM_SRGB:
        return true;

    default:
        return false;
    }
}

_Use_decl_annotations_ bool IsTypeless ( DXGI_FORMAT fmt ) [inline]

Definition at line 119 of file DirectXTex.inl.

{
    switch( fmt )
    {
    case DXGI_FORMAT_R32G32B32A32_TYPELESS:
    case DXGI_FORMAT_R32G32B32_TYPELESS:
    case DXGI_FORMAT_R16G16B16A16_TYPELESS:
    case DXGI_FORMAT_R32G32_TYPELESS:
    case DXGI_FORMAT_R32G8X24_TYPELESS:
    case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
    case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
    case DXGI_FORMAT_R10G10B10A2_TYPELESS:
    case DXGI_FORMAT_R8G8B8A8_TYPELESS:
    case DXGI_FORMAT_R16G16_TYPELESS:
    case DXGI_FORMAT_R32_TYPELESS:
    case DXGI_FORMAT_R24G8_TYPELESS:
    case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
    case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
    case DXGI_FORMAT_R8G8_TYPELESS:
    case DXGI_FORMAT_R16_TYPELESS:
    case DXGI_FORMAT_R8_TYPELESS:
    case DXGI_FORMAT_BC1_TYPELESS:
    case DXGI_FORMAT_BC2_TYPELESS:
    case DXGI_FORMAT_BC3_TYPELESS:
    case DXGI_FORMAT_BC4_TYPELESS:
    case DXGI_FORMAT_BC5_TYPELESS:
    case DXGI_FORMAT_B8G8R8A8_TYPELESS:
    case DXGI_FORMAT_B8G8R8X8_TYPELESS:
    case DXGI_FORMAT_BC6H_TYPELESS:
    case DXGI_FORMAT_BC7_TYPELESS:
        return true;

    default:
        return false;
    }
}

_Use_decl_annotations_ bool IsValid ( DXGI_FORMAT fmt ) [inline]

Definition at line 23 of file DirectXTex.inl.

{
    return ( static_cast<size_t>(fmt) >= 1 && static_cast<size_t>(fmt) <= 115 );
}

_Use_decl_annotations_ bool IsVideo ( DXGI_FORMAT fmt ) [inline]

Definition at line 69 of file DirectXTex.inl.

{
    switch ( fmt )
    {
    case DXGI_FORMAT_AYUV:
    case DXGI_FORMAT_Y410:
    case DXGI_FORMAT_Y416:
    case DXGI_FORMAT_NV12:
    case DXGI_FORMAT_P010:
    case DXGI_FORMAT_P016:
    case DXGI_FORMAT_YUY2:
    case DXGI_FORMAT_Y210:
    case DXGI_FORMAT_Y216:
    case DXGI_FORMAT_NV11:
        // These video formats can be used with the 3D pipeline through special view mappings
        return true;

    case DXGI_FORMAT_420_OPAQUE:
    case DXGI_FORMAT_AI44:
    case DXGI_FORMAT_IA44:
    case DXGI_FORMAT_P8:
    case DXGI_FORMAT_A8P8:
        // These are limited use video formats not usable in any way by the 3D pipeline
        return true;

    default:
        return false;
    }
}

_Use_decl_annotations_ HRESULT SaveToDDSFile | ( | const Image & | image,
 |  | DWORD | flags,
 |  | LPCWSTR | szFile |
 | ) |  |  | [inline]

Definition at line 209 of file DirectXTex.inl.

{
    TexMetadata mdata;
    memset( &mdata, 0, sizeof(mdata) );
    mdata.width = image.width;
    mdata.height = image.height;
    mdata.depth = 1;
    mdata.arraySize = 1;
    mdata.mipLevels = 1;
    mdata.format = image.format;
    mdata.dimension = TEX_DIMENSION_TEXTURE2D;

    return SaveToDDSFile( &image, 1, mdata, flags, szFile );
}

_Use_decl_annotations_ HRESULT SaveToDDSMemory | ( | const Image & | image,
 |  | DWORD | flags,
 |  | Blob & | blob |
 | ) |  |  | [inline]

Definition at line 193 of file DirectXTex.inl.

{
    TexMetadata mdata;
    memset( &mdata, 0, sizeof(mdata) );
    mdata.width = image.width;
    mdata.height = image.height;
    mdata.depth = 1;
    mdata.arraySize = 1;
    mdata.mipLevels = 1;
    mdata.format = image.format;
    mdata.dimension = TEX_DIMENSION_TEXTURE2D;

    return SaveToDDSMemory( &image, 1, mdata, flags, blob );
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexCompress.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

DirectXTexCompress.cpp File Reference

#include "directxtexp.h"
#include "bc.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ HRESULT | DirectX::Compress (const Image &srcImage, DXGI_FORMAT format, DWORD compress, float alphaRef, ScratchImage &image)
_Use_decl_annotations_ HRESULT | DirectX::Compress (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DXGI_FORMAT format, DWORD compress, float alphaRef, ScratchImage &cImages)
_Use_decl_annotations_ HRESULT | DirectX::Decompress (const Image *cImages, size_t nimages, const TexMetadata &metadata, DXGI_FORMAT format, ScratchImage &images)
_Use_decl_annotations_ HRESULT | DirectX::Decompress (const Image &cImage, DXGI_FORMAT format, ScratchImage &image)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexConvert.cpp File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Defines | Functions

DirectXTexConvert.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Classes

struct | DirectX::ConvertData

Namespaces

namespace | DirectX

Defines

#define | LOAD_SCANLINE(type, func)
#define | LOAD_SCANLINE2(type, func, defvec)
#define | LOAD_SCANLINE3(type, func, defvec)
#define | STORE_SCANLINE(type, func)

Functions

_Use_decl_annotations_ HRESULT | DirectX::_ConvertFromR32G32B32A32 (const Image &srcImage, DXGI_FORMAT format, ScratchImage &image)
_Use_decl_annotations_ HRESULT | DirectX::_ConvertFromR32G32B32A32 (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DXGI_FORMAT format, ScratchImage &result)
_Use_decl_annotations_ HRESULT | DirectX::_ConvertFromR32G32B32A32 (const Image &srcImage, const Image &destImage)
_Use_decl_annotations_ void | DirectX::_ConvertScanline (XMVECTOR *pBuffer, size_t count, DXGI_FORMAT outFormat, DXGI_FORMAT inFormat, DWORD flags)
_Use_decl_annotations_ HRESULT | DirectX::_ConvertToR32G32B32A32 (const Image &srcImage, ScratchImage &image)
void | DirectX::_CopyScanline (_When_(pDestination==pSource, _Inout_updates_bytes_(outSize)) _When_(pDestination!=pSource, _Out_writes_bytes_(outSize)) LPVOID pDestination, _In_ size_t outSize, _In_reads_bytes_(inSize) LPCVOID pSource, _In_ size_t inSize, _In_ DXGI_FORMAT format, _In_ DWORD flags)
_Use_decl_annotations_ bool | DirectX::_ExpandScanline (LPVOID pDestination, size_t outSize, DXGI_FORMAT outFormat, LPCVOID pSource, size_t inSize, DXGI_FORMAT inFormat, DWORD flags)
_Use_decl_annotations_ DWORD | DirectX::_GetConvertFlags (DXGI_FORMAT format)
_Use_decl_annotations_ bool | DirectX::_LoadScanline (XMVECTOR *pDestination, size_t count, LPCVOID pSource, size_t size, DXGI_FORMAT format)
_Use_decl_annotations_ bool | DirectX::_StoreScanline (LPVOID pDestination, size_t size, DXGI_FORMAT format, const XMVECTOR *pSource, size_t count)
_Use_decl_annotations_ void | DirectX::_SwizzleScanline (LPVOID pDestination, size_t outSize, LPCVOID pSource, size_t inSize, DXGI_FORMAT format, DWORD flags)
_Use_decl_annotations_ HRESULT | DirectX::Convert (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DXGI_FORMAT format, DWORD filter, float threshold, ScratchImage &result)
_Use_decl_annotations_ HRESULT | DirectX::Convert (const Image &srcImage, DXGI_FORMAT format, DWORD filter, float threshold, ScratchImage &image)

Define Documentation

#define LOAD_SCANLINE | ( | type,
 |  | func
 | ) |
Value:
if ( size >= sizeof(type) )\
        {\
            const type * __restrict sPtr = reinterpret_cast<const type*>(pSource);\
            for( size_t icount = 0; icount < size; icount += sizeof(type) )\
            {\
                if ( dPtr >= ePtr ) break;\
                *(dPtr++) = func( sPtr++ );\
            }\
            return true;\
        }\
        return false;

Definition at line 450 of file DirectXTexConvert.cpp.

#define LOAD_SCANLINE2 | ( | type,
 |  | func,
 |  | defvec
 | ) |
Value:
if ( size >= sizeof(type) )\
        {\
            const type * __restrict sPtr = reinterpret_cast<const type*>(pSource);\
            for( size_t icount = 0; icount < size; icount += sizeof(type) )\
            {\
                XMVECTOR v = func( sPtr++ );\
                if ( dPtr >= ePtr ) break;\
                *(dPtr++) = XMVectorSelect( defvec, v, g_XMSelect1100 );\
            }\
                return true;\
        }\
        return false;

Definition at line 477 of file DirectXTexConvert.cpp.

#define LOAD_SCANLINE3 | ( | type,
 |  | func,
 |  | defvec
 | ) |
Value:
if ( size >= sizeof(type) )\
        {\
            const type * __restrict sPtr = reinterpret_cast<const type*>(pSource);\
            for( size_t icount = 0; icount < size; icount += sizeof(type) )\
            {\
                XMVECTOR v = func( sPtr++ );\
                if ( dPtr >= ePtr ) break;\
                *(dPtr++) = XMVectorSelect( defvec, v, g_XMSelect1110 );\
            }\
            return true;\
        }\
        return false;

Definition at line 463 of file DirectXTexConvert.cpp.

#define STORE_SCANLINE | ( | type,
 |  | func
 | ) |
Value:
if ( size >= sizeof(type) )\
        {\
            type * __restrict dPtr = reinterpret_cast<type*>(pDestination);\
            for( size_t icount = 0; icount < size; icount += sizeof(type) )\
            {\
                if ( sPtr >= ePtr ) break;\
                func( dPtr++, *sPtr++ );\
            }\
        }\
        return true;

Definition at line 957 of file DirectXTexConvert.cpp.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexD3D11.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

DirectXTexD3D11.cpp File Reference

#include "directxtexp.h"
#include <d3dcommon.h>
#include <d3d10.h>

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ HRESULT | DirectX::CaptureTexture (ID3D11Device *pDevice, ID3D11DeviceContext *pContext, ID3D11Resource *pSource, ScratchImage &result)
_Use_decl_annotations_ HRESULT | DirectX::CreateShaderResourceView (ID3D11Device *pDevice, const Image *srcImages, size_t nimages, const TexMetadata &metadata, ID3D11ShaderResourceView **ppSRV)
_Use_decl_annotations_ HRESULT | DirectX::CreateTexture (ID3D11Device *pDevice, const Image *srcImages, size_t nimages, const TexMetadata &metadata, ID3D11Resource **ppResource)
_Use_decl_annotations_ bool | DirectX::IsSupportedTexture (ID3D11Device *pDevice, const TexMetadata &metadata)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexDDS.cpp File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Enumerations | Functions | Variables

DirectXTexDDS.cpp File Reference

#include "directxtexp.h"
#include "dds.h"

Go to the source code of this file.

Classes

struct | DirectX::LegacyDDS

Namespaces

namespace | DirectX

Enumerations

enum DirectX::CONVERSION_FLAGS {
DirectX::CONV_FLAGS_NONE = 0x0, DirectX::CONV_FLAGS_EXPAND = 0x1, DirectX::CONV_FLAGS_NOALPHA = 0x2, DirectX::CONV_FLAGS_SWIZZLE = 0x4,
DirectX::CONV_FLAGS_PAL8 = 0x8, DirectX::CONV_FLAGS_888 = 0x10, DirectX::CONV_FLAGS_565 = 0x20, DirectX::CONV_FLAGS_5551 = 0x40,
DirectX::CONV_FLAGS_4444 = 0x80, DirectX::CONV_FLAGS_44 = 0x100, DirectX::CONV_FLAGS_332 = 0x200, DirectX::CONV_FLAGS_8332 = 0x400,
DirectX::CONV_FLAGS_A8P8 = 0x800, DirectX::CONV_FLAGS_DX10 = 0x10000
}
enum DirectX::TEXP_LEGACY_FORMAT {
DirectX::TEXP_LEGACY_UNKNOWN = 0, DirectX::TEXP_LEGACY_R8G8B8, DirectX::TEXP_LEGACY_R3G3B2, DirectX::TEXP_LEGACY_A8R3G3B2,
DirectX::TEXP_LEGACY_P8, DirectX::TEXP_LEGACY_A8P8, DirectX::TEXP_LEGACY_A4L4, DirectX::TEXP_LEGACY_B4G4R4A4
}

Functions

_Use_decl_annotations_ HRESULT | DirectX::_EncodeDDSHeader (const TexMetadata &metadata, DWORD flags, LPVOID pDestination, size_t maxsize, size_t &required)
size_t _In_ DXGI_FORMAT | DirectX::_In_reads_bytes_ (inSize) LPCVOID pSource
size_t _In_ DXGI_FORMAT size_t
_In_ TEXP_LEGACY_FORMAT 		DirectX::_In_reads_opt_ (256) const uint32_t *pal8
DirectX::_Success_ (return!=false) static bool _LegacyExpandScanline(_Out_writes_bytes_(outSize) LPVOID pDestination

Variables

const LegacyDDS | DirectX::g_LegacyDDSMap []
size_t _In_ DXGI_FORMAT size_t
_In_ TEXP_LEGACY_FORMAT 		DirectX::inFormat
size_t _In_ DXGI_FORMAT size_t | DirectX::inSize
size_t _In_ DXGI_FORMAT | DirectX::outFormat
size_t | DirectX::outSize
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexFlipRotate.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

DirectXTexFlipRotate.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ HRESULT | DirectX::FlipRotate (const Image &srcImage, DWORD flags, ScratchImage &image)
_Use_decl_annotations_ HRESULT | DirectX::FlipRotate (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DWORD flags, ScratchImage &result)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexImage.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

DirectXTexImage.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

bool | DirectX::_CalculateMipLevels (_In_ size_t width, _In_ size_t height, _Inout_ size_t &mipLevels)
bool | DirectX::_CalculateMipLevels3D (_In_ size_t width, _In_ size_t height, _In_ size_t depth, _Inout_ size_t &mipLevels)
_Use_decl_annotations_ void | DirectX::_DetermineImageArray (const TexMetadata &metadata, DWORD cpFlags, size_t &nImages, size_t &pixelSize)
_Use_decl_annotations_ bool | DirectX::_SetupImageArray (uint8_t *pMemory, size_t pixelSize, const TexMetadata &metadata, DWORD cpFlags, Image *images, size_t nImages)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexMipmaps.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

DirectXTexMipmaps.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

bool | DirectX::_CalculateMipLevels (_In_ size_t width, _In_ size_t height, _Inout_ size_t &mipLevels)
bool | DirectX::_CalculateMipLevels3D (_In_ size_t width, _In_ size_t height, _In_ size_t depth, _Inout_ size_t &mipLevels)
HRESULT | DirectX::_ResizeSeparateColorAndAlpha (_In_ IWICImagingFactory *pWIC, _In_ IWICBitmap *original, _In_ size_t newWidth, _In_ size_t newHeight, _In_ DWORD filter, _Inout_ const Image *img)
_Use_decl_annotations_ HRESULT | DirectX::GenerateMipMaps (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DWORD filter, size_t levels, ScratchImage &mipChain)
_Use_decl_annotations_ HRESULT | DirectX::GenerateMipMaps (const Image &baseImage, DWORD filter, size_t levels, ScratchImage &mipChain, bool allow1D)
_Use_decl_annotations_ HRESULT | DirectX::GenerateMipMaps3D (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DWORD filter, size_t levels, ScratchImage &mipChain)
_Use_decl_annotations_ HRESULT | DirectX::GenerateMipMaps3D (const Image *baseImages, size_t depth, DWORD filter, size_t levels, ScratchImage &mipChain)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexMisc.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

DirectXTexMisc.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ HRESULT | DirectX::ComputeMSE (const Image &image1, const Image &image2, float &mse, float *mseV)
_Use_decl_annotations_ HRESULT | DirectX::CopyRectangle (const Image &srcImage, const Rect &srcRect, const Image &dstImage, DWORD filter, size_t xOffset, size_t yOffset)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexNormalMaps.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

DirectXTexNormalMaps.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ HRESULT | DirectX::ComputeNormalMap (const Image *srcImages, size_t nimages, const TexMetadata &metadata, DWORD flags, float amplitude, DXGI_FORMAT format, ScratchImage &normalMaps)
_Use_decl_annotations_ HRESULT | DirectX::ComputeNormalMap (const Image &srcImage, DWORD flags, float amplitude, DXGI_FORMAT format, ScratchImage &normalMap)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexP.h File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Defines | Enumerations | Functions | Variables

DirectXTexP.h File Reference

#include <windows.h>
#include <directxmath.h>
#include <directxpackedvector.h>
#include <assert.h>
#include <malloc.h>
#include <memory>
#include <vector>
#include <stdlib.h>
#include <search.h>
#include <ole2.h>
#include <wincodec.h>
#include "directxtex.h"
#include "scoped.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Defines

#define | NOMINMAX
#define | TEX_FILTER_MASK 0xF00000

Enumerations

enum DirectX::CONVERT_FLAGS {
DirectX::CONVF_FLOAT = 0x1, DirectX::CONVF_UNORM = 0x2, DirectX::CONVF_UINT = 0x4, DirectX::CONVF_SNORM = 0x8,
DirectX::CONVF_SINT = 0x10, DirectX::CONVF_DEPTH = 0x20, DirectX::CONVF_STENCIL = 0x40, DirectX::CONVF_SHAREDEXP = 0x80,
DirectX::CONVF_BGR = 0x100, DirectX::CONVF_X2 = 0x200, DirectX::CONVF_PACKED = 0x400, DirectX::CONVF_BC = 0x800,
DirectX::CONVF_R = 0x10000, DirectX::CONVF_G = 0x20000, DirectX::CONVF_B = 0x40000, DirectX::CONVF_A = 0x80000,
DirectX::CONVF_RGB_MASK = 0x70000, DirectX::CONVF_RGBA_MASK = 0xF0000
}
enum | DirectX::TEXP_SCANLINE_FLAGS { DirectX::TEXP_SCANLINE_NONE = 0, DirectX::TEXP_SCANLINE_SETALPHA = 0x1, DirectX::TEXP_SCANLINE_LEGACY = 0x2 }

Functions

HRESULT | DirectX::_ConvertFromR32G32B32A32 (_In_ const Image &srcImage, _In_ const Image &destImage)
HRESULT | DirectX::_ConvertFromR32G32B32A32 (_In_ const Image &srcImage, _In_ DXGI_FORMAT format, _Inout_ ScratchImage &image)
HRESULT | DirectX::_ConvertFromR32G32B32A32 (_In_reads_(nimages) const Image *srcImages, _In_ size_t nimages, _In_ const TexMetadata &metadata, _In_ DXGI_FORMAT format, _Out_ ScratchImage &result)
void | DirectX::_ConvertScanline (_Inout_updates_all_(count) XMVECTOR *pBuffer, _In_ size_t count, _In_ DXGI_FORMAT outFormat, _In_ DXGI_FORMAT inFormat, _In_ DWORD flags)
HRESULT | DirectX::_ConvertToR32G32B32A32 (_In_ const Image &srcImage, _Inout_ ScratchImage &image)
void | DirectX::_CopyScanline (_When_(pDestination==pSource, _Inout_updates_bytes_(outSize)) _When_(pDestination!=pSource, _Out_writes_bytes_(outSize)) LPVOID pDestination, _In_ size_t outSize, _In_reads_bytes_(inSize) LPCVOID pSource, _In_ size_t inSize, _In_ DXGI_FORMAT format, _In_ DWORD flags)
void | DirectX::_DetermineImageArray (_In_ const TexMetadata &metadata, _In_ DWORD cpFlags, _Out_ size_t &nImages, _Out_ size_t &pixelSize)
bool | DirectX::_DXGIToWIC (_In_ DXGI_FORMAT format, _Out_ GUID &guid)
HRESULT | DirectX::_EncodeDDSHeader (_In_ const TexMetadata &metadata, DWORD flags, _Out_writes_bytes_to_opt_(maxsize, required) LPVOID pDestination, _In_ size_t maxsize, _Out_ size_t &required)
DWORD | DirectX::_GetConvertFlags (_In_ DXGI_FORMAT format)
IWICImagingFactory * | DirectX::_GetWIC ()
WICBitmapDitherType | DirectX::_GetWICDither (_In_ DWORD flags)
WICBitmapInterpolationMode | DirectX::_GetWICInterp (_In_ DWORD flags)
_In_ size_t _In_ DXGI_FORMAT | DirectX::_In_reads_ (count) const XMVECTOR *pSource
_In_ size_t | DirectX::_In_reads_bytes_ (size) LPCVOID pSource
size_t _In_ DXGI_FORMAT | DirectX::_In_reads_bytes_ (inSize) LPCVOID pSource
_In_ size_t _In_ const
TexMetadata _In_ DWORD 		DirectX::_Out_writes_ (nImages) Image *images
DirectX::_Success_ (return!=false) static bool _LegacyExpandScanline(_Out_writes_bytes_(outSize) LPVOID pDestination
void | DirectX::_SwizzleScanline (_When_(pDestination==pSource, _In_) _When_(pDestination!=pSource, _Out_writes_bytes_(outSize)) LPVOID pDestination, _In_ size_t outSize, _In_reads_bytes_(inSize) LPCVOID pSource, _In_ size_t inSize, _In_ DXGI_FORMAT format, _In_ DWORD flags)
size_t | DirectX::_WICBitsPerPixel (_In_ REFGUID targetGuid)
DXGI_FORMAT | DirectX::_WICToDXGI (_In_ const GUID &guid)

Variables

_In_ size_t | DirectX::count
_In_ size_t _In_ const
TexMetadata _In_ DWORD 		DirectX::cpFlags
_In_ size_t _In_ DXGI_FORMAT
_In_ size_t _In_ DXGI_FORMAT
_In_ DWORD 		DirectX::flags
_In_ size_t _In_ size_t _In_
DXGI_FORMAT 		DirectX::format
_In_ size_t _In_ const
TexMetadata & 		DirectX::metadata
_In_ size_t _In_ const
TexMetadata _In_ DWORD _In_
size_t 		DirectX::nImages
_In_ size_t | DirectX::pixelSize
_In_ size_t _In_ size_t | DirectX::size

Define Documentation

#define NOMINMAX

Definition at line 18 of file DirectXTexP.h.

#define TEX_FILTER_MASK 0xF00000

Definition at line 45 of file DirectXTexP.h.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexResize.cpp File Reference

  • Direct3D resource loading
  • texconv
Namespaces | Functions

DirectXTexResize.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Namespaces

namespace | DirectX

Functions

HRESULT | DirectX::_ResizeSeparateColorAndAlpha (_In_ IWICImagingFactory *pWIC, _In_ IWICBitmap *original, _In_ size_t newWidth, _In_ size_t newHeight, _In_ DWORD filter, _Inout_ const Image *img)
_Use_decl_annotations_ HRESULT | DirectX::Resize (const Image *srcImages, size_t nimages, const TexMetadata &metadata, size_t width, size_t height, DWORD filter, ScratchImage &result)
_Use_decl_annotations_ HRESULT | DirectX::Resize (const Image &srcImage, size_t width, size_t height, DWORD filter, ScratchImage &image)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexTGA.cpp File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Enumerations | Functions | Variables

DirectXTexTGA.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Classes

struct | TGA_EXTENSION
struct | TGA_FOOTER
struct | TGA_HEADER

Namespaces

namespace | DirectX

Enumerations

enum CONVERSION_FLAGS {
CONV_FLAGS_NONE = 0x0, CONV_FLAGS_EXPAND = 0x1, CONV_FLAGS_INVERTX = 0x2, CONV_FLAGS_INVERTY = 0x4,
CONV_FLAGS_RLE = 0x8, CONV_FLAGS_SWIZZLE = 0x10000, CONV_FLAGS_888 = 0x20000
}
enum | TGADescriptorFlags { TGA_FLAGS_INVERTX = 0x10, TGA_FLAGS_INVERTY = 0x20, TGA_FLAGS_INTERLEAVED_2WAY = 0x40, TGA_FLAGS_INTERLEAVED_4WAY = 0x80 }
enum TGAImageType {
TGA_NO_IMAGE = 0, TGA_COLOR_MAPPED = 1, TGA_TRUECOLOR = 2, TGA_BLACK_AND_WHITE = 3,
TGA_COLOR_MAPPED_RLE = 9, TGA_TRUECOLOR_RLE = 10, TGA_BLACK_AND_WHITE_RLE = 11
}

Functions

_Use_decl_annotations_ HRESULT | DirectX::GetMetadataFromTGAFile (LPCWSTR szFile, TexMetadata &metadata)
_Use_decl_annotations_ HRESULT | DirectX::GetMetadataFromTGAMemory (LPCVOID pSource, size_t size, TexMetadata &metadata)
_Use_decl_annotations_ HRESULT | DirectX::LoadFromTGAFile (LPCWSTR szFile, TexMetadata *metadata, ScratchImage &image)
_Use_decl_annotations_ HRESULT | DirectX::LoadFromTGAMemory (LPCVOID pSource, size_t size, TexMetadata *metadata, ScratchImage &image)
_Use_decl_annotations_ HRESULT | DirectX::SaveToTGAFile (const Image &image, LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | DirectX::SaveToTGAMemory (const Image &image, Blob &blob)

Variables

const char * | g_TGA20_Signature = "TRUEVISION-XFILE."

Enumeration Type Documentation

enum CONVERSION_FLAGS
Enumerator:
CONV_FLAGS_NONE
CONV_FLAGS_EXPAND
CONV_FLAGS_INVERTX
CONV_FLAGS_INVERTY
CONV_FLAGS_RLE
CONV_FLAGS_SWIZZLE
CONV_FLAGS_888

Definition at line 99 of file DirectXTexTGA.cpp.

{
    CONV_FLAGS_NONE     = 0x0,
    CONV_FLAGS_EXPAND   = 0x1,      // Conversion requires expanded pixel size
    CONV_FLAGS_INVERTX  = 0x2,      // If set, scanlines are right-to-left
    CONV_FLAGS_INVERTY  = 0x4,      // If set, scanlines are top-to-bottom
    CONV_FLAGS_RLE      = 0x8,      // Source data is RLE compressed

    CONV_FLAGS_SWIZZLE  = 0x10000,  // Swizzle BGR<->RGB data
    CONV_FLAGS_888      = 0x20000,  // 24bpp format
};

enum TGADescriptorFlags
Enumerator:
TGA_FLAGS_INVERTX
TGA_FLAGS_INVERTY
TGA_FLAGS_INTERLEAVED_2WAY
TGA_FLAGS_INTERLEAVED_4WAY

Definition at line 35 of file DirectXTexTGA.cpp.

{
    TGA_FLAGS_INVERTX           = 0x10,
    TGA_FLAGS_INVERTY           = 0x20,
    TGA_FLAGS_INTERLEAVED_2WAY  = 0x40, // Deprecated
    TGA_FLAGS_INTERLEAVED_4WAY  = 0x80, // Deprecated
};

enum TGAImageType
Enumerator:
TGA_NO_IMAGE
TGA_COLOR_MAPPED
TGA_TRUECOLOR
TGA_BLACK_AND_WHITE
TGA_COLOR_MAPPED_RLE
TGA_TRUECOLOR_RLE
TGA_BLACK_AND_WHITE_RLE

Definition at line 24 of file DirectXTexTGA.cpp.

{
    TGA_NO_IMAGE            = 0,
    TGA_COLOR_MAPPED        = 1,
    TGA_TRUECOLOR           = 2,
    TGA_BLACK_AND_WHITE     = 3,
    TGA_COLOR_MAPPED_RLE    = 9,
    TGA_TRUECOLOR_RLE       = 10,
    TGA_BLACK_AND_WHITE_RLE = 11,
};

Variable Documentation

const char* g_TGA20_Signature = "TRUEVISION-XFILE."

Definition at line 43 of file DirectXTexTGA.cpp.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexUtil.cpp File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Functions

DirectXTexUtil.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Classes

struct | WICTranslate

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ bool | DirectX::_DXGIToWIC (DXGI_FORMAT format, GUID &guid)
IWICImagingFactory * | DirectX::_GetWIC ()
_Use_decl_annotations_ size_t | DirectX::_WICBitsPerPixel (REFGUID targetGuid)
_Use_decl_annotations_ DXGI_FORMAT | DirectX::_WICToDXGI (const GUID &guid)
_Use_decl_annotations_ size_t | DirectX::BitsPerPixel (DXGI_FORMAT fmt)
_Use_decl_annotations_ void | DirectX::ComputePitch (DXGI_FORMAT fmt, size_t width, size_t height, size_t &rowPitch, size_t &slicePitch, DWORD flags)
_Use_decl_annotations_ REFGUID | DirectX::GetWICCodec (WICCodecs codec)
_Use_decl_annotations_ DXGI_FORMAT | DirectX::MakeSRGB (DXGI_FORMAT fmt)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexWIC.cpp File Reference

  • Direct3D resource loading
  • texconv
Classes | Namespaces | Functions

DirectXTexWIC.cpp File Reference

#include "directxtexp.h"

Go to the source code of this file.

Classes

struct | WICConvert

Namespaces

namespace | DirectX

Functions

_Use_decl_annotations_ HRESULT | DirectX::GetMetadataFromWICFile (LPCWSTR szFile, DWORD flags, TexMetadata &metadata)
_Use_decl_annotations_ HRESULT | DirectX::GetMetadataFromWICMemory (LPCVOID pSource, size_t size, DWORD flags, TexMetadata &metadata)
_Use_decl_annotations_ HRESULT | DirectX::LoadFromWICFile (LPCWSTR szFile, DWORD flags, TexMetadata *metadata, ScratchImage &image)
_Use_decl_annotations_ HRESULT | DirectX::LoadFromWICMemory (LPCVOID pSource, size_t size, DWORD flags, TexMetadata *metadata, ScratchImage &image)
_Use_decl_annotations_ HRESULT | DirectX::SaveToWICFile (const Image &image, DWORD flags, REFGUID guidContainerFormat, LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | DirectX::SaveToWICFile (const Image *images, size_t nimages, DWORD flags, REFGUID guidContainerFormat, LPCWSTR szFile)
_Use_decl_annotations_ HRESULT | DirectX::SaveToWICMemory (const Image *images, size_t nimages, DWORD flags, REFGUID guidContainerFormat, Blob &blob)
_Use_decl_annotations_ HRESULT | DirectX::SaveToWICMemory (const Image &image, DWORD flags, REFGUID guidContainerFormat, Blob &blob)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/scoped.h File Reference

  • Direct3D resource loading
  • texconv
Classes | Typedefs | Functions

scoped.h File Reference

#include <assert.h>
#include <memory>
#include <malloc.h>

Go to the source code of this file.

Classes

struct | aligned_deleter
struct | handle_closer
class | ScopedObject< T >

Typedefs

typedef std::unique_ptr< float,
aligned_deleter > 		ScopedAlignedArrayFloat
typedef std::unique_ptr
< DirectX::XMVECTOR,
aligned_deleter > 		ScopedAlignedArrayXMVECTOR
typedef public std::unique_ptr
< void, handle_closer > 		ScopedHandle

Functions

HANDLE | safe_handle (HANDLE h)

Typedef Documentation

typedef std::unique_ptr<float, aligned_deleter> ScopedAlignedArrayFloat

Definition at line 25 of file scoped.h.

typedef std::unique_ptr<DirectX::XMVECTOR, aligned_deleter> ScopedAlignedArrayXMVECTOR

Definition at line 26 of file scoped.h.

typedef public std::unique_ptr<void, handle_closer> ScopedHandle

Definition at line 31 of file scoped.h.

Function Documentation

HANDLE safe_handle ( HANDLE h ) [inline]

Definition at line 33 of file scoped.h.

{ return (h == INVALID_HANDLE_VALUE) ? 0 : h; }

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/Texconv.cpp File Reference

  • Direct3D resource loading
  • texconv
Classes | Defines | Enumerations | Functions | Variables

Texconv.cpp File Reference

#include <stdio.h>
#include <stdlib.h>
#include <assert.h>
#include <dxgiformat.h>
#include "directxtex.h"

Go to the source code of this file.

Classes

struct | SConversion
struct | SValue

Defines

#define | CODEC_DDS 0xFFFF0001
#define | CODEC_TGA 0xFFFF0002
#define | DEFFMT(fmt) { L#fmt , DXGI_FORMAT_ ## fmt }

Enumerations

enum OPTIONS {
OPT_WIDTH = 1, OPT_HEIGHT, OPT_MIPLEVELS, OPT_FORMAT,
OPT_FILTER, OPT_SRGBI, OPT_SRGBO, OPT_SRGB,
OPT_PREFIX, OPT_SUFFIX, OPT_OUTPUTDIR, OPT_FILETYPE,
OPT_HFLIP, OPT_VFLIP, OPT_DDS_DWORD_ALIGN, OPT_USE_DX10,
OPT_NOLOGO, OPT_SEPALPHA
}

Functions

DWORD | LookupByName (const WCHAR *pName, const SValue *pArray)
const WCHAR * | LookupByValue (DWORD pValue, const SValue *pArray)
void | PrintFormat (DXGI_FORMAT Format)
void | PrintInfo (const TexMetadata &info)
void | PrintList (size_t cch, SValue *pValue)
void | PrintLogo ()
void | PrintUsage ()
int __cdecl | wmain (_In_ int argc, _In_reads_(argc) PWSTR argv[])

Variables

SValue g_pFilters []
SValue g_pFormats []
SValue g_pOptions []
SValue g_pSaveFileTypes []

Define Documentation

#define CODEC_DDS 0xFFFF0001

Definition at line 179 of file Texconv.cpp.

#define CODEC_TGA 0xFFFF0002

Definition at line 180 of file Texconv.cpp.

#define DEFFMT ( fmt ) { L#fmt , DXGI_FORMAT_ ## fmt }

Definition at line 83 of file Texconv.cpp.

Enumeration Type Documentation

enum OPTIONS
Enumerator:
OPT_WIDTH
OPT_HEIGHT
OPT_MIPLEVELS
OPT_FORMAT
OPT_FILTER
OPT_SRGBI
OPT_SRGBO
OPT_SRGB
OPT_PREFIX
OPT_SUFFIX
OPT_OUTPUTDIR
OPT_FILETYPE
OPT_HFLIP
OPT_VFLIP
OPT_DDS_DWORD_ALIGN
OPT_USE_DX10
OPT_NOLOGO
OPT_SEPALPHA

Definition at line 20 of file Texconv.cpp.

                       : dwOptions below assumes 32 or less options.
{
    OPT_WIDTH = 1,
    OPT_HEIGHT,
    OPT_MIPLEVELS,
    OPT_FORMAT,
    OPT_FILTER,
    OPT_SRGBI,
    OPT_SRGBO,
    OPT_SRGB,
    OPT_PREFIX,
    OPT_SUFFIX,
    OPT_OUTPUTDIR,
    OPT_FILETYPE,
    OPT_HFLIP,
    OPT_VFLIP,
    OPT_DDS_DWORD_ALIGN,
    OPT_USE_DX10,
    OPT_NOLOGO,
    OPT_SEPALPHA
};

Function Documentation

DWORD LookupByName | ( | const WCHAR * | pName,
 |  | const SValue * | pArray
 | ) |  |

Definition at line 210 of file Texconv.cpp.

{
    while(pArray->pName)
    {
        if(!_wcsicmp(pName, pArray->pName))
            return pArray->dwValue;

        pArray++;
    }

    return 0;
}

const WCHAR* LookupByValue | ( | DWORD | pValue,
 |  | const SValue * | pArray
 | ) |  |

Definition at line 223 of file Texconv.cpp.

{
    while(pArray->pName)
    {
        if(pValue == pArray->dwValue)
            return pArray->pName;

        pArray++;
    }

    return L"";
}

void PrintFormat ( DXGI_FORMAT Format )

Definition at line 236 of file Texconv.cpp.

{
    for(SValue *pFormat = g_pFormats; pFormat->pName; pFormat++)
    {
        if((DXGI_FORMAT) pFormat->dwValue == Format)
        {
            wprintf( pFormat->pName );
            break;
        }
    }
}

void PrintInfo ( const TexMetadata & info )

Definition at line 248 of file Texconv.cpp.

{
    wprintf( L" (%Iux%Iu", info.width, info.height);

    if ( TEX_DIMENSION_TEXTURE3D == info.dimension )
        wprintf( L"x%Iu", info.depth);

    if ( info.mipLevels > 1 )
        wprintf( L",%Iu", info.mipLevels);

    wprintf( L" ");
    PrintFormat( info.format );

    switch ( info.dimension )
    {
    case TEX_DIMENSION_TEXTURE1D:
        wprintf( (info.arraySize > 1) ? L" 1DArray" : L" 1D" );
        break;

    case TEX_DIMENSION_TEXTURE2D:
        if ( info.miscFlags & TEX_MISC_TEXTURECUBE )
        {
            wprintf( (info.arraySize > 1) ? L" CubeArray" : L" Cube" );
        }
        else
        {
            wprintf( (info.arraySize > 1) ? L" 2DArray" : L" 2D" );
        }
        break;

    case TEX_DIMENSION_TEXTURE3D:
        wprintf( L" 3D");
        break;
    }

    wprintf( L")");
}

void PrintList | ( | size_t | cch,
 |  | SValue * | pValue
 | ) |  |

Definition at line 287 of file Texconv.cpp.

{
    while(pValue->pName)
    {
        size_t cchName = wcslen(pValue->pName);

        if(cch + cchName + 2>= 80)
        {
            wprintf( L"\n      ");
            cch = 6;
        }

        wprintf( L"%s ", pValue->pName );
        cch += cchName + 2;
        pValue++;
    }

    wprintf( L"\n");
}

void PrintLogo ( )

Definition at line 308 of file Texconv.cpp.

{
    wprintf( L"Microsoft (R) DirectX 11 Texture Converter (DirectXTex version)\n");
    wprintf( L"Copyright (C) Microsoft Corp. All rights reserved.\n");
    wprintf( L"\n");
}

void PrintUsage ( )

Definition at line 316 of file Texconv.cpp.

{
    PrintLogo();

    wprintf( L"Usage: texconv <options> <files>\n");
    wprintf( L"\n");
    wprintf( L"   -w <n>              width\n");
    wprintf( L"   -h <n>              height\n");
    wprintf( L"   -d <n>              depth\n");
    wprintf( L"   -m <n>              miplevels\n");
    wprintf( L"   -f <format>         format\n");
    wprintf( L"   -if <filter>        image filtering\n");
    wprintf( L"   -srgb{i|o}          sRGB {input, output}\n");
    wprintf( L"   -px <string>        name prefix\n");
    wprintf( L"   -sx <string>        name suffix\n");
    wprintf( L"   -o <directory>      output directory\n");
    wprintf( L"   -ft <filetype>      output file type\n");
    wprintf( L"   -hflip              horizonal flip of source image\n");
    wprintf( L"   -vflip              vertical flip of source image\n");
    wprintf( L"   -sepalpha           resize/generate mips alpha channel separately from color channels\n");
    wprintf( L"   -dword              Use DWORD instead of BYTE alignment (DDS input only)\n");
    wprintf( L"   -dx10               Force use of 'DX10' extended header (DDS output only)\n");
    wprintf( L"   -nologo             suppress copyright message\n");

    wprintf( L"\n");
    wprintf( L"   <format>: ");
    PrintList(13, g_pFormats);

    wprintf( L"\n");
    wprintf( L"   <filter>: ");
    PrintList(13, g_pFilters);

    wprintf( L"\n");
    wprintf( L"   <filetype>: ");
    PrintList(15, g_pSaveFileTypes);
}

int __cdecl wmain | ( | _In_ int | argc,
 |  | _In_reads_(argc) PWSTR | argv[]
 | ) |  |

Definition at line 359 of file Texconv.cpp.

{
    // Parameters and defaults
    HRESULT hr;
    INT nReturn;

    size_t width = 0;
    size_t height = 0;
    size_t mipLevels = 0;
    DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
    DWORD dwFilter = TEX_FILTER_DEFAULT;
    DWORD dwSRGB = 0;
    DWORD dwFilterOpts = 0;
    DWORD FileType = CODEC_DDS;

    WCHAR szPrefix   [MAX_PATH];
    WCHAR szSuffix   [MAX_PATH];
    WCHAR szOutputDir[MAX_PATH];

    szPrefix[0]    = 0;
    szSuffix[0]    = 0;
    szOutputDir[0] = 0;

    // Initialize COM (needed for WIC)
    if( FAILED( hr = CoInitializeEx(nullptr, COINIT_MULTITHREADED) ) )
    {
        wprintf( L"Failed to initialize COM (%08X)\n", hr);
        return 1;
    }

    // Process command line
    DWORD dwOptions = 0;
    SConversion *pConversion = nullptr;
    SConversion **ppConversion = &pConversion;

    for(int iArg = 1; iArg < argc; iArg++)
    {
        PWSTR pArg = argv[iArg];

        if(('-' == pArg[0]) || ('/' == pArg[0]))
        {
            pArg++;
            PWSTR pValue;

            for(pValue = pArg; *pValue && (':' != *pValue); pValue++);

            if(*pValue)
                *pValue++ = 0;

            DWORD dwOption = LookupByName(pArg, g_pOptions);

            if(!dwOption || (dwOptions & (1 << dwOption)))
            {
                PrintUsage();
                return 1;
            }

            dwOptions |= 1 << dwOption;

            if( (OPT_NOLOGO != dwOption) && (OPT_SEPALPHA != dwOption)
                && (OPT_SRGB != dwOption) && (OPT_SRGBI != dwOption) && (OPT_SRGBO != dwOption)
                && (OPT_HFLIP != dwOption) && (OPT_VFLIP != dwOption)
                && (OPT_DDS_DWORD_ALIGN != dwOption) && (OPT_USE_DX10 != dwOption) )
            {
                if(!*pValue)
                {
                    if((iArg + 1 >= argc))
                    {
                        PrintUsage();
                        return 1;
                    }

                    iArg++;
                    pValue = argv[iArg];
                }
            }

            switch(dwOption)
            {
            case OPT_WIDTH:
                if (swscanf_s(pValue, L"%Iu", &width) != 1)
                {
                    wprintf( L"Invalid value specified with -w (%s)\n", pValue);
                    wprintf( L"\n");
                    PrintUsage();
                    return 1;
                }
                break;

            case OPT_HEIGHT:
                if (swscanf_s(pValue, L"%Iu", &height) != 1)
                {
                    wprintf( L"Invalid value specified with -h (%s)\n", pValue);
                    printf("\n");
                    PrintUsage();
                    return 1;
                }
                break;

            case OPT_MIPLEVELS:
                if (swscanf_s(pValue, L"%Iu", &mipLevels) != 1)
                {
                    wprintf( L"Invalid value specified with -m (%s)\n", pValue);
                    wprintf( L"\n");
                    PrintUsage();
                    return 1;
                }
                break;

            case OPT_FORMAT:
                format = (DXGI_FORMAT) LookupByName(pValue, g_pFormats);
                if ( !format )
                {
                    wprintf( L"Invalid value specified with -f (%s)\n", pValue);
                    wprintf( L"\n");
                    PrintUsage();
                    return 1;
                }
                break;

            case OPT_FILTER:
                dwFilter = LookupByName(pValue, g_pFilters);
                if ( !dwFilter )
                {
                    wprintf( L"Invalid value specified with -if (%s)\n", pValue);
                    wprintf( L"\n");
                    PrintUsage();
                    return 1;
                }
                break;

            case OPT_SRGBI:
                dwSRGB |= TEX_FILTER_SRGB_IN;
                break;

            case OPT_SRGBO:
                dwSRGB |= TEX_FILTER_SRGB_OUT;
                break;

            case OPT_SRGB:
                dwSRGB |= TEX_FILTER_SRGB;
                break;

            case OPT_SEPALPHA:
                dwFilterOpts |= TEX_FILTER_SEPARATE_ALPHA;
                break;

            case OPT_PREFIX:
                wcscpy_s(szPrefix, MAX_PATH, pValue);
                break;

            case OPT_SUFFIX:
                wcscpy_s(szSuffix, MAX_PATH, pValue);
                break;

            case OPT_OUTPUTDIR:
                wcscpy_s(szOutputDir, MAX_PATH, pValue);
                break;

            case OPT_FILETYPE:
                FileType = LookupByName(pValue, g_pSaveFileTypes);
                if ( !FileType )
                {
                    wprintf( L"Invalid value specified with -ft (%s)\n", pValue);
                    wprintf( L"\n");
                    PrintUsage();
                    return 1;
                }
                break;
            }
        }
        else
        {
            SConversion *pConv = new SConversion;
            if ( !pConv )
                return 1;

            wcscpy_s(pConv->szSrc, MAX_PATH, pArg);

            pConv->szDest[0] = 0;
            pConv->pNext = nullptr;

            *ppConversion = pConv;
            ppConversion = &pConv->pNext;
        }
    }

    if(!pConversion)
    {
        PrintUsage();
        return 0;
    }

    if(~dwOptions & (1 << OPT_NOLOGO))
        PrintLogo();

    // Work out out filename prefix and suffix
    if(szOutputDir[0] && (L'\\' != szOutputDir[wcslen(szOutputDir) - 1]))
        wcscat_s( szOutputDir, MAX_PATH, L"\\" );

    if(szPrefix[0])
        wcscat_s(szOutputDir, MAX_PATH, szPrefix);

    wcscpy_s(szPrefix, MAX_PATH, szOutputDir);

    const WCHAR* fileTypeName = LookupByValue(FileType, g_pSaveFileTypes);

    if (fileTypeName)
    {
        wcscat_s(szSuffix, MAX_PATH, L".");
        wcscat_s(szSuffix, MAX_PATH, fileTypeName);
    }
    else
    {
        wcscat_s(szSuffix, MAX_PATH, L".unknown");
    }

    if (FileType != CODEC_DDS)
    {
        mipLevels = 1;
    }

    // Convert images
    bool nonpow2warn = false;
    SConversion *pConv;

    for(pConv = pConversion; pConv; pConv = pConv->pNext)
    {
        // Load source image
        if(pConv != pConversion)
            wprintf( L"\n");

        wprintf( L"reading %s", pConv->szSrc );
        fflush(stdout);

        WCHAR ext[_MAX_EXT];
        WCHAR fname[_MAX_FNAME];
        _wsplitpath_s( pConv->szSrc, nullptr, 0, nullptr, 0, fname, _MAX_FNAME, ext, _MAX_EXT );

        TexMetadata info;
        ScratchImage *image = new ScratchImage;

        if ( !image )
        {
            wprintf( L" ERROR: Memory allocation failed\n" );
            goto LError;
        }

        if ( _wcsicmp( ext, L".dds" ) == 0 )
        {
            hr = LoadFromDDSFile( pConv->szSrc,
                                  (dwOptions & (1 << OPT_DDS_DWORD_ALIGN)) ? DDS_FLAGS_LEGACY_DWORD : DDS_FLAGS_NONE,
                                  &info, *image );
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED (%x)\n", hr);
                delete image;
                continue;
            }
        }
        else if ( _wcsicmp( ext, L".tga" ) == 0 )
        {
            hr = LoadFromTGAFile( pConv->szSrc, &info, *image );
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED (%x)\n", hr);
                delete image;
                continue;
            }
        }
        else
        {
            // WIC shares the same filter values for mode and dither
            static_assert( WIC_FLAGS_DITHER == TEX_FILTER_DITHER, "WIC_FLAGS_* & TEX_FILTER_* should match" );
            static_assert( WIC_FLAGS_DITHER_DIFFUSION == TEX_FILTER_DITHER_DIFFUSION, "WIC_FLAGS_* & TEX_FILTER_* should match"  );
            static_assert( WIC_FLAGS_FILTER_POINT == TEX_FILTER_POINT, "WIC_FLAGS_* & TEX_FILTER_* should match"  );
            static_assert( WIC_FLAGS_FILTER_LINEAR == TEX_FILTER_LINEAR, "WIC_FLAGS_* & TEX_FILTER_* should match"  );
            static_assert( WIC_FLAGS_FILTER_CUBIC == TEX_FILTER_CUBIC, "WIC_FLAGS_* & TEX_FILTER_* should match"  );
            static_assert( WIC_FLAGS_FILTER_FANT == TEX_FILTER_FANT, "WIC_FLAGS_* & TEX_FILTER_* should match"  );

            hr = LoadFromWICFile( pConv->szSrc, dwFilter, &info, *image );
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED (%x)\n", hr);
                delete image;
                continue;
            }
        }

        PrintInfo( info );

        size_t twidth = ( !width ) ? info.width : width;
        size_t theight = ( !height ) ? info.height : height;
        size_t tMips = ( !mipLevels && info.mipLevels > 1 ) ? info.mipLevels : mipLevels;
        DXGI_FORMAT tformat = ( format == DXGI_FORMAT_UNKNOWN ) ? info.format : format;

        // Convert texture
        wprintf( L" as");
        fflush(stdout);

        // --- Decompress --------------------------------------------------------------
        if ( IsCompressed( info.format ) )
        {
            const Image* img = image->GetImage(0,0,0);
            assert( img );
            size_t nimg = image->GetImageCount();

            ScratchImage *timage = new ScratchImage;
            if ( !timage )
            {
                wprintf( L" ERROR: Memory allocation failed\n" );
                delete image;
                goto LError;
            }

            hr = Decompress( img, nimg, info, DXGI_FORMAT_UNKNOWN /* picks good default */, *timage );
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED [decompress] (%x)\n", hr);
                delete timage;
                delete image;
                continue;
            }

            const TexMetadata& tinfo = timage->GetMetadata();

            info.format = tinfo.format;

            assert( info.width == tinfo.width );
            assert( info.height == tinfo.height );
            assert( info.depth == tinfo.depth );
            assert( info.arraySize == tinfo.arraySize );
            assert( info.mipLevels == tinfo.mipLevels );
            assert( info.miscFlags == tinfo.miscFlags );
            assert( info.dimension == tinfo.dimension );

            delete image;
            image = timage;
        }

        // --- Flip/Rotate -------------------------------------------------------------
        if ( dwOptions & ( (1 << OPT_HFLIP) | (1 << OPT_VFLIP) ) )
        {
            ScratchImage *timage = new ScratchImage;
            if ( !timage )
            {
                wprintf( L" ERROR: Memory allocation failed\n" );
                delete image;
                goto LError;
            }

            DWORD dwFlags = 0;

            if ( dwOptions & (1 << OPT_HFLIP) )
                dwFlags |= TEX_FR_FLIP_HORIZONTAL;

            if ( dwOptions & (1 << OPT_VFLIP) )
                dwFlags |= TEX_FR_FLIP_VERTICAL;

            assert( dwFlags != 0 );

            hr = FlipRotate( image->GetImages(), image->GetImageCount(), image->GetMetadata(), dwFlags, *timage );
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED [fliprotate] (%x)\n", hr);
                delete timage;
                delete image;
                goto LError;
            }

            const TexMetadata& tinfo = timage->GetMetadata();

            assert( tinfo.width == twidth && tinfo.height == theight );

            info.width = tinfo.width;
            info.height = tinfo.height;

            assert( info.depth == tinfo.depth );
            assert( info.arraySize == tinfo.arraySize );
            assert( info.mipLevels == tinfo.mipLevels );
            assert( info.miscFlags == tinfo.miscFlags );
            assert( info.format == tinfo.format );
            assert( info.dimension == tinfo.dimension );

            delete image;
            image = timage;
        }

        // --- Resize ------------------------------------------------------------------
        if ( info.width != twidth || info.height != theight )
        {
            ScratchImage *timage = new ScratchImage;
            if ( !timage )
            {
                wprintf( L" ERROR: Memory allocation failed\n" );
                delete image;
                goto LError;
            }

            hr = Resize( image->GetImages(), image->GetImageCount(), image->GetMetadata(), twidth, theight, dwFilter | dwFilterOpts, *timage );
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED [resize] (%x)\n", hr);
                delete timage;
                delete image;
                goto LError;
            }

            const TexMetadata& tinfo = timage->GetMetadata();

            assert( tinfo.width == twidth && tinfo.height == theight && tinfo.mipLevels == 1 );
            info.width = tinfo.width;
            info.height = tinfo.height;
            info.mipLevels = 1;

            assert( info.depth == tinfo.depth );
            assert( info.arraySize == tinfo.arraySize );
            assert( info.miscFlags == tinfo.miscFlags );
            assert( info.format == tinfo.format );
            assert( info.dimension == tinfo.dimension );

            delete image;
            image = timage;
        }

        // --- Convert -----------------------------------------------------------------
        if ( info.format != tformat && !IsCompressed( tformat ) )
        {
            ScratchImage *timage = new ScratchImage;
            if ( !timage )
            {
                wprintf( L" ERROR: Memory allocation failed\n" );
                delete image;
                goto LError;
            }

            hr = Convert( image->GetImages(), image->GetImageCount(), image->GetMetadata(), tformat, dwFilter | dwSRGB, 05.f, *timage );
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED [convert] (%x)\n", hr);
                delete timage;
                delete image;
                goto LError;
            }

            const TexMetadata& tinfo = timage->GetMetadata();

            assert( tinfo.format == tformat );
            info.format = tinfo.format;

            assert( info.width == tinfo.width );
            assert( info.height == tinfo.height );
            assert( info.depth == tinfo.depth );
            assert( info.arraySize == tinfo.arraySize );
            assert( info.mipLevels == tinfo.mipLevels );
            assert( info.miscFlags == tinfo.miscFlags );
            assert( info.dimension == tinfo.dimension );

            delete image;
            image = timage;
        }

        // --- Generate mips -----------------------------------------------------------
        if ( !ispow2(info.width) || !ispow2(info.height) || !ispow2(info.depth) )
        {
            if ( info.dimension == TEX_DIMENSION_TEXTURE3D )
            {
                if ( !tMips )
                {
                    tMips = 1;
                }
                else
                {
                    wprintf( L" ERROR: Cannot generate mips for non-power-of-2 volume textures\n" );
                    delete image;
                    goto LError;
                }
            }
            else if ( !tMips || info.mipLevels != 1 )
            {
                nonpow2warn = true;
            }
        }

        if ( !tMips || info.mipLevels != tMips )
        {
            ScratchImage *timage = new ScratchImage;
            if ( !timage )
            {
                wprintf( L" ERROR: Memory allocation failed\n" );
                delete image;
                goto LError;
            }

            if ( info.dimension == TEX_DIMENSION_TEXTURE3D )
            {
                hr = GenerateMipMaps3D( image->GetImages(), image->GetImageCount(), image->GetMetadata(), dwFilter | dwFilterOpts, tMips, *timage );
            }
            else
            {
                hr = GenerateMipMaps( image->GetImages(), image->GetImageCount(), image->GetMetadata(), dwFilter | dwFilterOpts, tMips, *timage );
            }
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED [mipmaps] (%x)\n", hr);
                delete timage;
                delete image;
                goto LError;
            }

            const TexMetadata& tinfo = timage->GetMetadata();
            info.mipLevels = tinfo.mipLevels;

            assert( info.width == tinfo.width );
            assert( info.height == tinfo.height );
            assert( info.depth == tinfo.depth );
            assert( info.arraySize == tinfo.arraySize );
            assert( info.mipLevels == tinfo.mipLevels );
            assert( info.miscFlags == tinfo.miscFlags );
            assert( info.dimension == tinfo.dimension );

            delete image;
            image = timage;
        }

        // --- Compress ----------------------------------------------------------------
        if ( IsCompressed( tformat ) && (FileType == CODEC_DDS) )
        {
            const Image* img = image->GetImage(0,0,0);
            assert( img );
            size_t nimg = image->GetImageCount();

            ScratchImage *timage = new ScratchImage;
            if ( !timage )
            {
                wprintf( L" ERROR: Memory allocation failed\n" );
                delete image;
                goto LError;
            }

            hr = Compress( img, nimg, info, tformat, TEX_COMPRESS_DEFAULT, 0.5f, *timage );
            if ( FAILED(hr) )
            {
                wprintf( L" FAILED [compress] (%x)\n", hr);
                delete timage;
                delete image;
                continue;
            }

            const TexMetadata& tinfo = timage->GetMetadata();

            info.format = tinfo.format;
            assert( info.width == tinfo.width );
            assert( info.height == tinfo.height );
            assert( info.depth == tinfo.depth );
            assert( info.arraySize == tinfo.arraySize );
            assert( info.mipLevels == tinfo.mipLevels );
            assert( info.miscFlags == tinfo.miscFlags );
            assert( info.dimension == tinfo.dimension );

            delete image;
            image = timage;
        }

        // --- Save result -------------------------------------------------------------
        {
            const Image* img = image->GetImage(0,0,0);
            assert( img );
            size_t nimg = image->GetImageCount();

            PrintInfo( info );
            wprintf( L"\n");

            // Figure out dest filename
            WCHAR *pchSlash, *pchDot;

            wcscpy_s(pConv->szDest, MAX_PATH, szPrefix);

            pchSlash = wcsrchr(pConv->szSrc, L'\\');
            if(pchSlash != 0)
                wcscat_s(pConv->szDest, MAX_PATH, pchSlash + 1);
            else
                wcscat_s(pConv->szDest, MAX_PATH, pConv->szSrc);

            pchSlash = wcsrchr(pConv->szDest, '\\');
            pchDot = wcsrchr(pConv->szDest, '.');

            if(pchDot > pchSlash)
                *pchDot = 0;

            wcscat_s(pConv->szDest, MAX_PATH, szSuffix);

            // Write texture
            wprintf( L"writing %s", pConv->szDest);
            fflush(stdout);

            switch( FileType )
            {
            case CODEC_DDS:
                hr = SaveToDDSFile( img, nimg, info,
                                    (dwOptions & (1 << OPT_USE_DX10) ) ? DDS_FLAGS_FORCE_DX10_EXT : DDS_FLAGS_NONE,
                                    pConv->szDest );
                break;

            case CODEC_TGA:
                hr = SaveToTGAFile( img[0], pConv->szDest );
                break;

            default:
                hr = SaveToWICFile( img, nimg, WIC_FLAGS_ALL_FRAMES, GetWICCodec( static_cast<WICCodecs>(FileType) ), pConv->szDest );
                break;
            }

            if(FAILED(hr))
            {
                wprintf( L" FAILED (%x)\n", hr);
                delete image;
                continue;
            }
            wprintf( L"\n");
        }

        delete image;
    }

    if ( nonpow2warn )
        wprintf( L"\n WARNING: Not all feature levels support non-power-of-2 textures with mipmaps\n" );

    nReturn = 0;

    goto LDone;

LError:
    nReturn = 1;

LDone:

    while(pConversion)
    {
        pConv = pConversion;
        pConversion = pConversion->pNext;
        delete pConv;
    }

    return nReturn;
}

Variable Documentation

SValue g_pFilters[]
Initial value:

{
    { L"POINT",         TEX_FILTER_POINT                                },
    { L"LINEAR",        TEX_FILTER_LINEAR                               },
    { L"CUBIC",         TEX_FILTER_CUBIC                                },
    { L"FANT",          TEX_FILTER_FANT                                 },
    { L"POINT_DITHER",  TEX_FILTER_POINT | TEX_FILTER_DITHER_DIFFUSION  },
    { L"LINEAR_DITHER", TEX_FILTER_LINEAR | TEX_FILTER_DITHER_DIFFUSION },
    { L"CUBIC_DITHER",  TEX_FILTER_CUBIC | TEX_FILTER_DITHER_DIFFUSION  },
    { L"FANT_DITHER",   TEX_FILTER_FANT  | TEX_FILTER_DITHER_DIFFUSION  },
    { nullptr,          TEX_FILTER_DEFAULT                              }
}

Definition at line 166 of file Texconv.cpp.

SValue g_pFormats[]

Definition at line 85 of file Texconv.cpp.

SValue g_pOptions[]
Initial value:

{
    { L"w",             OPT_WIDTH     },
    { L"h",             OPT_HEIGHT    },
    { L"m",             OPT_MIPLEVELS },
    { L"f",             OPT_FORMAT    },
    { L"if",            OPT_FILTER    },
    { L"srgbi",         OPT_SRGBI     },
    { L"srgbo",         OPT_SRGBO     },
    { L"srgb",          OPT_SRGB      },
    { L"px",            OPT_PREFIX    },
    { L"sx",            OPT_SUFFIX    },
    { L"o",             OPT_OUTPUTDIR },
    { L"ft",            OPT_FILETYPE  },
    { L"hflip",         OPT_HFLIP     },
    { L"vflip",         OPT_VFLIP     },
    { L"dword",         OPT_DDS_DWORD_ALIGN },
    { L"dx10",          OPT_USE_DX10  },
    { L"nologo",        OPT_NOLOGO    },
    { L"sepalpha",      OPT_SEPALPHA  },
    { nullptr,          0             }
}

Definition at line 60 of file Texconv.cpp.

SValue g_pSaveFileTypes[]
Initial value:

{
    { L"BMP",           WIC_CODEC_BMP  },
    { L"JPG",           WIC_CODEC_JPEG },
    { L"JPEG",          WIC_CODEC_JPEG },
    { L"PNG",           WIC_CODEC_PNG  },
    { L"DDS",           CODEC_DDS      },
    { L"TGA",           CODEC_TGA      },
    { L"TIF",           WIC_CODEC_TIFF },
    { L"TIFF",          WIC_CODEC_TIFF },
    { L"WDP",           WIC_CODEC_WMP  },
    { L"HDP",           WIC_CODEC_WMP  },
    { nullptr,          CODEC_DDS      }
}

Definition at line 182 of file Texconv.cpp.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/AutoThrottle.cpp File Reference

  • Direct3D sprite

AutoThrottle.cpp File Reference

#include "pch.h"
#include "AutoThrottle.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/AutoThrottle.h File Reference

  • Direct3D sprite
Classes | Enumerations

AutoThrottle.h File Reference

Go to the source code of this file.

Classes

class AutoThrottle

Enumerations

enum FrameWorkload {
Increase, Decrease, Maintain, Increase,
Decrease, Maintain
}

Enumeration Type Documentation

enum FrameWorkload
Enumerator:
Increase
Decrease
Maintain
Increase
Decrease
Maintain

Definition at line 10 of file AutoThrottle.h.

{
    Increase,
    Decrease,
    Maintain
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicLoader.cpp File Reference

  • Direct3D sprite

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicLoader.h File Reference

  • Direct3D sprite
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicMath.h File Reference

  • Direct3D sprite
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicReaderWriter.cpp File Reference

  • Direct3D sprite

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicReaderWriter.h File Reference

  • Direct3D sprite
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicShapes.h File Reference

  • Direct3D sprite
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicSprites.cpp File Reference

  • Direct3D sprite

BasicSprites.cpp File Reference

#include "pch.h"
#include "BasicSprites.h"
#include "DirectXSample.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicSprites.h File Reference

  • Direct3D sprite
Classes | Namespaces | Enumerations

BasicSprites.h File Reference

#include "BasicMath.h"
#include <vector>
#include <map>
#include <memory>

Go to the source code of this file.

Classes

struct | BasicSprites::InstanceData
struct | BasicSprites::InstancingVertex
struct | BasicSprites::ReplicationVertex
class | BasicSprites::SpriteBatch
struct | BasicSprites::SpriteRunInfo
struct | BasicSprites::TextureMapElement

Namespaces

namespace | BasicSprites
namespace | BasicSprites::Parameters

Enumerations

enum | BasicSprites::BlendMode { BasicSprites::Alpha, BasicSprites::Additive }
enum BasicSprites::PositionUnits {
BasicSprites::DIPs, BasicSprites::Pixels, BasicSprites::Normalized, BasicSprites::UniformWidth,
BasicSprites::UniformHeight
}
enum | BasicSprites::RenderTechnique { BasicSprites::Replication, BasicSprites::Instancing, BasicSprites::GeometryShader }
enum | BasicSprites::SizeUnits { BasicSprites::DIPs, BasicSprites::Pixels, BasicSprites::Normalized }
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicTimer.cpp File Reference

  • Direct3D sprite

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicTimer.h File Reference

  • Direct3D sprite
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/DDSTextureLoader.cpp File Reference

  • Direct3D sprite
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/DDSTextureLoader.h File Reference

  • Direct3D sprite
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/DirectXApp.cpp File Reference

  • Direct3D sprite
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 184 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/DirectXApp.h File Reference

  • Direct3D sprite
Classes

DirectXApp.h File Reference

#include "SimpleSprites.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/DirectXBase.cpp File Reference

  • Direct3D sprite

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/DirectXBase.h File Reference

  • Direct3D sprite
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/DirectXSample.h File Reference

  • Direct3D sprite
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/pch.cpp File Reference

  • Direct3D sprite

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/pch.h File Reference

  • Direct3D sprite

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/SampleOverlay.cpp File Reference

  • Direct3D sprite

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/SampleOverlay.h File Reference

  • Direct3D sprite
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/SimpleSprites.cpp File Reference

  • Direct3D sprite

SimpleSprites.cpp File Reference

#include "pch.h"
#include "SimpleSprites.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/SimpleSprites.h File Reference

  • Direct3D sprite
Classes | Namespaces

SimpleSprites.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "AutoThrottle.h"
#include "BasicSprites.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | AsteroidData
struct | ParticleData
class | SimpleSprites

Namespaces

namespace | SampleSettings
namespace | SampleSettings::Performance
namespace | SampleSettings::Physics
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicLoader.cpp File Reference

  • Direct3D stereoscopic 3D

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicLoader.h File Reference

  • Direct3D stereoscopic 3D
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicMath.h File Reference

  • Direct3D stereoscopic 3D
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicReaderWriter.cpp File Reference

  • Direct3D stereoscopic 3D

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicReaderWriter.h File Reference

  • Direct3D stereoscopic 3D
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicShapes.cpp File Reference

  • Direct3D stereoscopic 3D

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicShapes.h File Reference

  • Direct3D stereoscopic 3D
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicTimer.cpp File Reference

  • Direct3D stereoscopic 3D

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicTimer.h File Reference

  • Direct3D stereoscopic 3D
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/DDSTextureLoader.cpp File Reference

  • Direct3D stereoscopic 3D
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/DDSTextureLoader.h File Reference

  • Direct3D stereoscopic 3D
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/DirectXApp.cpp File Reference

  • Direct3D stereoscopic 3D
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 225 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/DirectXApp.h File Reference

  • Direct3D stereoscopic 3D
Classes

DirectXApp.h File Reference

#include "StereoSimpleD3D.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/DirectXBase.cpp File Reference

  • Direct3D stereoscopic 3D

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/DirectXBase.h File Reference

  • Direct3D stereoscopic 3D
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/DirectXSample.h File Reference

  • Direct3D stereoscopic 3D
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/pch.cpp File Reference

  • Direct3D stereoscopic 3D

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/pch.h File Reference

  • Direct3D stereoscopic 3D

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <DirectXMath.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/SampleOverlay.cpp File Reference

  • Direct3D stereoscopic 3D

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/SampleOverlay.h File Reference

  • Direct3D stereoscopic 3D
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/Stereo3DMatrixHelper.cpp File Reference

  • Direct3D stereoscopic 3D
Functions

Stereo3DMatrixHelper.cpp File Reference

#include "pch.h"
#include "Stereo3DMatrixHelper.h"

Go to the source code of this file.

Functions

StereoParameters | CreateDefaultStereoParameters (float viewportWidthInches, float viewportHeightInches, float worldScaleInInches, float stereoExaggeration)
DirectX::XMMATRIX | StereoProjectionFieldOfViewRightHand (const StereoParameters &parameters, float nearZ, float farZ, bool rightChannel)

Function Documentation

StereoParameters CreateDefaultStereoParameters | ( | float | viewportWidthInches,
 |  | float | viewportHeightInches,
 |  | float | worldScaleInInches,
 |  | float | stereoExaggeration
 | ) |  |

Definition at line 13 of file Stereo3DMatrixHelper.cpp.

{
    // The default stereo parameters produced by this method are based on two assumptions:
    // 1. The viewer's eyes are 24 inches from the display, and
    // 2. The viewer's eyes are separated by 1.25 inches (interocular distance.)
    const float DEFAULT_VIEWER_DISTANCE_IN_INCHES = 24.0f;
    const float DEFAULT_INTEROCULAR_DISTANCE_IN_INCHES = 1.25f;

    StereoParameters parameters;
    parameters.viewportWidth = viewportWidthInches / worldScaleInInches;
    parameters.viewportHeight = viewportHeightInches / worldScaleInInches;
    parameters.viewerDistance = DEFAULT_VIEWER_DISTANCE_IN_INCHES / worldScaleInInches;
    parameters.interocularDistance = DEFAULT_INTEROCULAR_DISTANCE_IN_INCHES / worldScaleInInches * stereoExaggeration;

    return parameters;
}

DirectX::XMMATRIX StereoProjectionFieldOfViewRightHand | ( | const StereoParameters & | parameters,
 |  | float | nearZ,
 |  | float | farZ,
 |  | bool | rightChannel
 | ) |  |

Definition at line 35 of file Stereo3DMatrixHelper.cpp.

{
    float yScale = 2.f * parameters.viewerDistance / parameters.viewportHeight;
    float xScale = 2.f * parameters.viewerDistance / parameters.viewportWidth;

    float mFactor = - parameters.interocularDistance / parameters.viewportWidth;

    if (!rightChannel)
    {
        mFactor = -mFactor;
    }

    float m22 = farZ / (nearZ - farZ);

    // Construct a stereo perspective projection matrix based on assumptions
    // about the viewer and specified stereo parameters. Note that compared
    // to a mono perspective projection matrix, there are two differences:
    //  - a non-zero x:z component (m20)
    //  - a non-zero x:w component (m30)
    // The values of these two factors affect both the x-offset between the
    // left and right eyes, as well as the depth at which they converge. The
    // math used to arrive at these values will often need to change depending
    // on the content being presented in order to ensure a comfortable viewing
    // experience. For example, the factors for rendering massive exterior
    // landscapes will be different than those used for rendering building
    // interiors. Because of this, developers are encouraged to experiment
    // with different techniques for generating these values.
    return XMMATRIX(
        xScale, 0, 0, 0,
        0, yScale, 0, 0,
        mFactor, 0, m22, -1,
        parameters.viewerDistance * mFactor, 0, nearZ * m22, 0
        );
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/Stereo3DMatrixHelper.h File Reference

  • Direct3D stereoscopic 3D
Classes | Functions

Stereo3DMatrixHelper.h File Reference

Go to the source code of this file.

Classes

struct | StereoParameters

Functions

StereoParameters | CreateDefaultStereoParameters (float viewportWidthInches, float viewportHeightInches, float worldScaleInInches, float stereoExaggeration)
DirectX::XMMATRIX | StereoProjectionFieldOfViewRightHand (const StereoParameters &parameters, float nearZ, float farZ, bool rightChannel)

Function Documentation

StereoParameters CreateDefaultStereoParameters | ( | float | viewportWidthInches,
 |  | float | viewportHeightInches,
 |  | float | worldScaleInInches,
 |  | float | stereoExaggeration
 | ) |  |

Definition at line 13 of file Stereo3DMatrixHelper.cpp.

{
    // The default stereo parameters produced by this method are based on two assumptions:
    // 1. The viewer's eyes are 24 inches from the display, and
    // 2. The viewer's eyes are separated by 1.25 inches (interocular distance.)
    const float DEFAULT_VIEWER_DISTANCE_IN_INCHES = 24.0f;
    const float DEFAULT_INTEROCULAR_DISTANCE_IN_INCHES = 1.25f;

    StereoParameters parameters;
    parameters.viewportWidth = viewportWidthInches / worldScaleInInches;
    parameters.viewportHeight = viewportHeightInches / worldScaleInInches;
    parameters.viewerDistance = DEFAULT_VIEWER_DISTANCE_IN_INCHES / worldScaleInInches;
    parameters.interocularDistance = DEFAULT_INTEROCULAR_DISTANCE_IN_INCHES / worldScaleInInches * stereoExaggeration;

    return parameters;
}

DirectX::XMMATRIX StereoProjectionFieldOfViewRightHand | ( | const StereoParameters & | parameters,
 |  | float | nearZ,
 |  | float | farZ,
 |  | bool | rightChannel
 | ) |  |

Definition at line 35 of file Stereo3DMatrixHelper.cpp.

{
    float yScale = 2.f * parameters.viewerDistance / parameters.viewportHeight;
    float xScale = 2.f * parameters.viewerDistance / parameters.viewportWidth;

    float mFactor = - parameters.interocularDistance / parameters.viewportWidth;

    if (!rightChannel)
    {
        mFactor = -mFactor;
    }

    float m22 = farZ / (nearZ - farZ);

    // Construct a stereo perspective projection matrix based on assumptions
    // about the viewer and specified stereo parameters. Note that compared
    // to a mono perspective projection matrix, there are two differences:
    //  - a non-zero x:z component (m20)
    //  - a non-zero x:w component (m30)
    // The values of these two factors affect both the x-offset between the
    // left and right eyes, as well as the depth at which they converge. The
    // math used to arrive at these values will often need to change depending
    // on the content being presented in order to ensure a comfortable viewing
    // experience. For example, the factors for rendering massive exterior
    // landscapes will be different than those used for rendering building
    // interiors. Because of this, developers are encouraged to experiment
    // with different techniques for generating these values.
    return XMMATRIX(
        xScale, 0, 0, 0,
        0, yScale, 0, 0,
        mFactor, 0, m22, -1,
        parameters.viewerDistance * mFactor, 0, nearZ * m22, 0
        );
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/StereoSimpleD3D.cpp File Reference

  • Direct3D stereoscopic 3D

StereoSimpleD3D.cpp File Reference

#include "pch.h"
#include <math.h>
#include "StereoSimpleD3D.h"
#include "BasicShapes.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/StereoSimpleD3D.h File Reference

  • Direct3D stereoscopic 3D
Classes

StereoSimpleD3D.h File Reference

#include "DirectXBase.h"
#include "BasicMath.h"
#include "SampleOverlay.h"
#include "DirectXMath.h"
#include "Stereo3DMatrixHelper.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | StereoSimpleD3D
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson1.Basics/DirectXSample.h File Reference

  • Direct3D tutorial
  • Lesson1.Basics
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson1.Basics/Main.cpp File Reference

  • Direct3D tutorial
  • Lesson1.Basics
Classes | Functions

Main.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class | Direct3DTutorialFrameworkView
class | Direct3DTutorialFrameworkViewSource

Functions

int | main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 302 of file Main.cpp.

{
    auto frameworkViewSource = ref new Direct3DTutorialFrameworkViewSource();
    Windows::ApplicationModel::Core::CoreApplication::Run(frameworkViewSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson1.Basics/pch.cpp File Reference

  • Direct3D tutorial
  • Lesson1.Basics

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson1.Basics/pch.h File Reference

  • Direct3D tutorial
  • Lesson1.Basics

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/BasicMath.h File Reference

  • Direct3D tutorial
  • Lesson2.Triangles
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/BasicReaderWriter.cpp File Reference

  • Direct3D tutorial
  • Lesson2.Triangles

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/BasicReaderWriter.h File Reference

  • Direct3D tutorial
  • Lesson2.Triangles
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/DirectXSample.h File Reference

  • Direct3D tutorial
  • Lesson2.Triangles
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/Main.cpp File Reference

  • Direct3D tutorial
  • Lesson2.Triangles
Classes | Functions

Main.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"
#include "BasicMath.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class | Direct3DTutorialFrameworkView
class | Direct3DTutorialFrameworkViewSource

Functions

int | main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 449 of file Main.cpp.

{
    auto frameworkViewSource = ref new Direct3DTutorialFrameworkViewSource();
    Windows::ApplicationModel::Core::CoreApplication::Run(frameworkViewSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/pch.cpp File Reference

  • Direct3D tutorial
  • Lesson2.Triangles

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/pch.h File Reference

  • Direct3D tutorial
  • Lesson2.Triangles

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/BasicMath.h File Reference

  • Direct3D tutorial
  • Lesson3.Cubes
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/BasicReaderWriter.cpp File Reference

  • Direct3D tutorial
  • Lesson3.Cubes

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/BasicReaderWriter.h File Reference

  • Direct3D tutorial
  • Lesson3.Cubes
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/DirectXSample.h File Reference

  • Direct3D tutorial
  • Lesson3.Cubes
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/Main.cpp File Reference

  • Direct3D tutorial
  • Lesson3.Cubes
Classes | Functions

Main.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"
#include "BasicMath.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | Direct3DTutorialFrameworkView
class | Direct3DTutorialFrameworkViewSource
struct | SimpleCubeVertex

Functions

int | main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 616 of file Main.cpp.

{
    auto frameworkViewSource = ref new Direct3DTutorialFrameworkViewSource();
    Windows::ApplicationModel::Core::CoreApplication::Run(frameworkViewSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/pch.cpp File Reference

  • Direct3D tutorial
  • Lesson3.Cubes

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/pch.h File Reference

  • Direct3D tutorial
  • Lesson3.Cubes

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/BasicMath.h File Reference

  • Direct3D tutorial
  • Lesson4.Textures
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/BasicReaderWriter.cpp File Reference

  • Direct3D tutorial
  • Lesson4.Textures

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/BasicReaderWriter.h File Reference

  • Direct3D tutorial
  • Lesson4.Textures
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/DirectXSample.h File Reference

  • Direct3D tutorial
  • Lesson4.Textures
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/Main.cpp File Reference

  • Direct3D tutorial
  • Lesson4.Textures
Classes | Functions

Main.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"
#include "BasicMath.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

struct | BasicVertex
struct | ConstantBuffer
class | Direct3DTutorialFrameworkView
class | Direct3DTutorialFrameworkViewSource

Functions

int | main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 749 of file Main.cpp.

{
    auto frameworkViewSource = ref new Direct3DTutorialFrameworkViewSource();
    Windows::ApplicationModel::Core::CoreApplication::Run(frameworkViewSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/pch.cpp File Reference

  • Direct3D tutorial
  • Lesson4.Textures

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/pch.h File Reference

  • Direct3D tutorial
  • Lesson4.Textures

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicCamera.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicCamera.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicLoader.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicLoader.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicMath.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicReaderWriter.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicReaderWriter.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicShapes.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicShapes.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicTimer.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicTimer.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DDSTextureLoader.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DDSTextureLoader.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/Direct3DTutorial.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

Direct3DTutorial.cpp File Reference

#include "pch.h"
#include "Direct3DTutorial.h"
#include "BasicShapes.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/Direct3DTutorial.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

Direct3DTutorial.h File Reference

#include "DirectXBase.h"
#include "BasicCamera.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | Direct3DTutorial
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DirectXApp.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 133 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DirectXApp.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

DirectXApp.h File Reference

#include "Direct3DTutorial.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DirectXBase.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DirectXBase.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DirectXSample.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/pch.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/pch.h File Reference

  • Direct3D tutorial
  • Lesson5.Components

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/SampleOverlay.cpp File Reference

  • Direct3D tutorial
  • Lesson5.Components

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/SampleOverlay.h File Reference

  • Direct3D tutorial
  • Lesson5.Components
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicCamera.cpp File Reference

  • Direct3D-Direct2D interop

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicCamera.h File Reference

  • Direct3D-Direct2D interop
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicLoader.cpp File Reference

  • Direct3D-Direct2D interop

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicLoader.h File Reference

  • Direct3D-Direct2D interop
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicMath.h File Reference

  • Direct3D-Direct2D interop
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicReaderWriter.cpp File Reference

  • Direct3D-Direct2D interop

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicReaderWriter.h File Reference

  • Direct3D-Direct2D interop
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicShapes.cpp File Reference

  • Direct3D-Direct2D interop

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicShapes.h File Reference

  • Direct3D-Direct2D interop
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicTimer.cpp File Reference

  • Direct3D-Direct2D interop

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicTimer.h File Reference

  • Direct3D-Direct2D interop
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DDSTextureLoader.cpp File Reference

  • Direct3D-Direct2D interop
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DDSTextureLoader.h File Reference

  • Direct3D-Direct2D interop
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DirectXApp.cpp File Reference

  • Direct3D-Direct2D interop
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 133 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DirectXApp.h File Reference

  • Direct3D-Direct2D interop
Classes

DirectXApp.h File Reference

#include "TextInterop.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DirectXBase.cpp File Reference

  • Direct3D-Direct2D interop

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DirectXBase.h File Reference

  • Direct3D-Direct2D interop
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DirectXSample.h File Reference

  • Direct3D-Direct2D interop
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/pch.cpp File Reference

  • Direct3D-Direct2D interop

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/pch.h File Reference

  • Direct3D-Direct2D interop

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/SampleOverlay.cpp File Reference

  • Direct3D-Direct2D interop

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/SampleOverlay.h File Reference

  • Direct3D-Direct2D interop
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/TextInterop.cpp File Reference

  • Direct3D-Direct2D interop

TextInterop.cpp File Reference

#include "pch.h"
#include "TextInterop.h"
#include "BasicShapes.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/TextInterop.h File Reference

  • Direct3D-Direct2D interop
Classes

TextInterop.h File Reference

#include "DirectXBase.h"
#include "BasicMath.h"
#include "BasicCamera.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | TextInterop
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/CustomTextRenderer.cpp File Reference

  • DirectWrite custom text renderer
Functions

CustomTextRenderer.cpp File Reference

#include "pch.h"
#include "CustomTextRenderer.h"

Go to the source code of this file.

Functions

IFACEMETHODIMP_ (unsigned long) CustomTextRenderer

Function Documentation

IFACEMETHODIMP_ ( unsigned long )

Definition at line 267 of file CustomTextRenderer.cpp.

{
    unsigned long newCount = InterlockedDecrement(&refCount);
    if (newCount == 0)
    {
        delete this;
        return 0;
    }

    return newCount;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/CustomTextRenderer.h File Reference

  • DirectWrite custom text renderer
Classes

CustomTextRenderer.h File Reference

#include "DirectXBase.h"
#include "DirectXBase.h"

Go to the source code of this file.

Classes

class CustomTextRenderer
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/DirectXBase.cpp File Reference

  • DirectWrite custom text renderer

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/DirectXBase.h File Reference

  • DirectWrite custom text renderer
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/DirectXSample.h File Reference

  • DirectWrite custom text renderer
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/DWriteCustomTextRenderer.h File Reference

  • DirectWrite custom text renderer
Classes

DWriteCustomTextRenderer.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "CustomTextRenderer.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | DWriteCustomTextRenderer
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/pch.cpp File Reference

  • DirectWrite custom text renderer

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/pch.h File Reference

  • DirectWrite custom text renderer

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1_1helper.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/SampleOverlay.cpp File Reference

  • DirectWrite custom text renderer

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/SampleOverlay.h File Reference

  • DirectWrite custom text renderer
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/C++,JavaScript/cpp/FontEnumerator.h File Reference

  • DirectWrite font enumeration
  • C++,JavaScript
  • cpp
Classes | Namespaces

FontEnumerator.h File Reference

Go to the source code of this file.

Classes

class | FontEnumeration::sealed

Namespaces

namespace | FontEnumeration
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/C++,JavaScript/cpp/pch.cpp File Reference

  • DirectWrite font enumeration
  • C++,JavaScript
  • cpp

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/C++,JavaScript/cpp/pch.h File Reference

  • DirectWrite font enumeration
  • C++,JavaScript
  • cpp

pch.h File Reference

#include <wrl.h>
#include <dwrite.h>
#include <strsafe.h>
#include <assert.h>
#include <time.h>
#include <WinNls.h>
#include <datetimeapi.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/DirectXBase.cpp File Reference

  • DirectWrite hello world

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/DirectXBase.h File Reference

  • DirectWrite hello world
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/DirectXSample.h File Reference

  • DirectWrite hello world
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/DWriteHelloWorld.cpp File Reference

  • DirectWrite hello world
Functions

DWriteHelloWorld.cpp File Reference

#include "pch.h"
#include "DWriteHelloWorld.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 278 of file DWriteHelloWorld.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/DWriteHelloWorld.h File Reference

  • DirectWrite hello world
Classes

DWriteHelloWorld.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | DWriteHelloWorld
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/pch.cpp File Reference

  • DirectWrite hello world

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/pch.h File Reference

  • DirectWrite hello world

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1_1helper.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/SampleOverlay.cpp File Reference

  • DirectWrite hello world

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/SampleOverlay.h File Reference

  • DirectWrite hello world
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/DirectXBase.cpp File Reference

  • DirectWrite hit testing

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/DirectXBase.h File Reference

  • DirectWrite hit testing
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/DirectXSample.h File Reference

  • DirectWrite hit testing
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/DWriteHitTesting.cpp File Reference

  • DirectWrite hit testing
Functions

DWriteHitTesting.cpp File Reference

#include "pch.h"
#include "DWriteHitTesting.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 318 of file DWriteHitTesting.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/DWriteHitTesting.h File Reference

  • DirectWrite hit testing
Classes

DWriteHitTesting.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | DWriteHitTesting
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/pch.cpp File Reference

  • DirectWrite hit testing

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/pch.h File Reference

  • DirectWrite hit testing

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1_1helper.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/SampleOverlay.cpp File Reference

  • DirectWrite hit testing

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/SampleOverlay.h File Reference

  • DirectWrite hit testing
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/DirectXBase.cpp File Reference

  • DirectWrite inline object

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/DirectXBase.h File Reference

  • DirectWrite inline object
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/DirectXSample.h File Reference

  • DirectWrite inline object
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/DWriteInlineObject.cpp File Reference

  • DirectWrite inline object
Functions

DWriteInlineObject.cpp File Reference

#include "pch.h"
#include "DWriteInlineObject.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 246 of file DWriteInlineObject.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/DWriteInlineObject.h File Reference

  • DirectWrite inline object
Classes

DWriteInlineObject.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "InlineImage.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | DWriteInlineObject
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/InlineImage.cpp File Reference

  • DirectWrite inline object
Functions

InlineImage.cpp File Reference

#include "pch.h"
#include "DWriteInlineObject.h"

Go to the source code of this file.

Functions

STDMETHODIMP_ (unsigned long) InlineImage

Function Documentation

STDMETHODIMP_ ( unsigned long )

Definition at line 192 of file InlineImage.cpp.

{
    unsigned long newCount = InterlockedDecrement(&refCount);

    if (newCount == 0)
    {
        delete this;
        return 0;
    }

    return newCount;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/InlineImage.h File Reference

  • DirectWrite inline object
Classes

InlineImage.h File Reference

Go to the source code of this file.

Classes

class InlineImage
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/pch.cpp File Reference

  • DirectWrite inline object

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/pch.h File Reference

  • DirectWrite inline object

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1_1helper.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/SampleOverlay.cpp File Reference

  • DirectWrite inline object

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/SampleOverlay.h File Reference

  • DirectWrite inline object
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/DirectXBase.cpp File Reference

  • DirectWrite paragraph text

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/DirectXBase.h File Reference

  • DirectWrite paragraph text
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/DirectXSample.h File Reference

  • DirectWrite paragraph text
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/DWriteParagraphText.cpp File Reference

  • DirectWrite paragraph text
Functions

DWriteParagraphText.cpp File Reference

#include "pch.h"
#include "DWriteParagraphText.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 435 of file DWriteParagraphText.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/DWriteParagraphText.h File Reference

  • DirectWrite paragraph text
Classes

DWriteParagraphText.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | DWriteParagraphText
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/pch.cpp File Reference

  • DirectWrite paragraph text

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/pch.h File Reference

  • DirectWrite paragraph text

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1_1helper.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/SampleOverlay.cpp File Reference

  • DirectWrite paragraph text

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/SampleOverlay.h File Reference

  • DirectWrite paragraph text
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/DirectXBase.cpp File Reference

  • DirectWrite vertical text

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/DirectXBase.h File Reference

  • DirectWrite vertical text
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/DirectXSample.h File Reference

  • DirectWrite vertical text
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/DWriteVerticalText.cpp File Reference

  • DirectWrite vertical text
Functions

DWriteVerticalText.cpp File Reference

#include "pch.h"
#include "DWriteVerticalText.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 267 of file DWriteVerticalText.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/DWriteVerticalText.h File Reference

  • DirectWrite vertical text
Classes

DWriteVerticalText.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "FlowLayout.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | DWriteVerticalText
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/FlowLayout.cpp File Reference

  • DirectWrite vertical text
Namespaces | Functions

FlowLayout.cpp File Reference

#include "pch.h"
#include "TextAnalysis.h"
#include "FlowSource.h"
#include "FlowSink.h"
#include "FlowLayout.h"

Go to the source code of this file.

Namespaces

namespace | anonymous_namespace{FlowLayout.cpp}

Functions

UINT32 | anonymous_namespace{FlowLayout.cpp}::EstimateGlyphCount (UINT32 textLength)
HRESULT | anonymous_namespace{FlowLayout.cpp}::GetGlyphMetrics (IDWriteFontFace *fontFace, DWRITE_MEASURING_MODE measuringMode, float fontEmSize, bool isSideways, UINT32 glyphCount, _In_reads_(glyphCount) UINT16 *glyphIds, _Out_writes_(glyphCount) DWRITE_GLYPH_METRICS *glyphRunMetrics)
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/FlowLayout.h File Reference

  • DirectWrite vertical text
Functions

FlowLayout.h File Reference

#include "FlowSource.h"
#include "FlowSink.h"
#include "TextAnalysis.h"
#include "DirectXBase.h"

Go to the source code of this file.

Functions

class DECLSPEC_UUID ("E304E995-6157-48ec-8D44-ACB308A210D0") FlowLayout

Function Documentation

class DECLSPEC_UUID ( "E304E995-6157-48ec-8D44-ACB308A210D0" )

Definition at line 20 of file FlowLayout.h.

                                                                      :
    public ComBase<QiListSelf<FlowLayout, QiList<IUnknown>>>
{
    // This custom layout processes layout in two stages.
    //
    // 1. Analyze the text, given the current font and size
    //      a. Bidirectional analysis
    //      b. Script analysis
    //      c. Number substitution analysis
    //      d. Shape glyphs
    //      e. Intersect run results
    //
    // 2. Fill the text to the given shape
    //      a. Pull next rect from flow source
    //      b. Fit as much text as will go in
    //      c. Push text to flow sink

public:
    struct ClusterPosition
    {
        ClusterPosition():
            textPosition(),
            runIndex(),
            runEndPosition()
        {
        }
        UINT32 textPosition;    // Current text position
        UINT32 runIndex;        // Associated analysis run covering this position
        UINT32 runEndPosition;  // Text position where this run ends
    };

    enum JustificationMode
    {
        JustificationModeNone,
        JustificationModeInterword,
    };

public:
    FlowLayout(Microsoft::WRL::ComPtr<IDWriteFactory> dwriteFactory)
    :   m_dwriteFactory(SafeAcquire(dwriteFactory.Get())),
        m_fontFace(),
        m_numberSubstitution(),
        m_readingDirection(ReadingDirectionLeftToRightTopToBottom),
        m_glyphOrientationMode(GlyphOrientationModeDefault),
        m_justificationMode(JustificationModeInterword),
        m_fontEmSize(12),
        m_maxSpaceWidth(8),
        m_isTextAnalysisComplete(false)
    {
    }

    void SetTextFormat(Microsoft::WRL::ComPtr<IDWriteTextFormat> textFormat);
    void SetNumberSubstitution(Microsoft::WRL::ComPtr<IDWriteNumberSubstitution> numberSubstitution);
    void SetReadingDirection(ReadingDirection readingDirection);
    void SetGlyphOrientationMode(GlyphOrientationMode glyphOrientationMode);
    void SetJustificationMode(JustificationMode justificationMode);
    GlyphOrientationMode GetGlyphOrientationMode();
    ReadingDirection GetReadingDirection();

    void SetText(
        const wchar_t* text,
        UINT32 textLength
        );

    void GetText(
        _Out_ const wchar_t** text,
        _Out_ UINT32* textLength
        );

    // Perform analysis on the current text, converting text to glyphs.
    void AnalyzeText();

    // Reflow the text analysis into
    void FlowText(
        Microsoft::WRL::ComPtr<FlowLayoutSource> flowSource,
        Microsoft::WRL::ComPtr<FlowLayoutSink> flowSink
        );

protected:
    void ShapeGlyphRuns(Microsoft::WRL::ComPtr<IDWriteTextAnalyzer> textAnalyzer);

    void ShapeGlyphRun(
        Microsoft::WRL::ComPtr<IDWriteTextAnalyzer> textAnalyzer,
        UINT32 runIndex,
        _Inout_ UINT32& glyphStart
        );

    void ShapeSimpleGlyphRun(
        UINT32 runIndex,
        _Inout_ UINT32& glyphStart
        );

    bool FitText(
        const ClusterPosition& clusterStart,
        UINT32 textEnd,
        float maxWidth,
        _Out_ ClusterPosition* clusterEnd
        );

    bool ProduceGlyphRuns(
        Microsoft::WRL::ComPtr<FlowLayoutSink> flowSink,
        const FlowLayoutSource::RectF& rect,
        const ClusterPosition& clusterStart,
        const ClusterPosition& clusterEnd
        ) const;

    void ProduceJustifiedAdvances(
        float maxWidth,
        const ClusterPosition& clusterStart,
        const ClusterPosition& clusterEnd,
        _Out_ std::vector<float>& justifiedAdvances
        ) const;

    void ProduceBidiOrdering(
        UINT32 spanStart,
        UINT32 spanCount,
        _Out_writes_(spanCount) UINT32* spanIndices
        ) const;

    void SetClusterPosition(
        _Inout_ ClusterPosition& cluster,
        UINT32 textPosition
        ) const;

    void AdvanceClusterPosition(
        _Inout_ ClusterPosition& cluster
        ) const;

    UINT32 GetClusterGlyphStart(
        const ClusterPosition& cluster
        ) const;

    float GetClusterRangeWidth(
        const ClusterPosition& clusterStart,
        const ClusterPosition& clusterEnd
        ) const;

    float GetClusterRangeWidth(
        UINT32 glyphStart,
        UINT32 glyphEnd,
        const float* glyphAdvances
        ) const;

protected:
    Microsoft::WRL::ComPtr<IDWriteFactory> m_dwriteFactory;

    // Input information.
    std::wstring m_text;
    wchar_t m_localeName[LOCALE_NAME_MAX_LENGTH];
    ReadingDirection m_readingDirection;
    GlyphOrientationMode m_glyphOrientationMode;
    JustificationMode m_justificationMode;
    Microsoft::WRL::ComPtr<IDWriteFontFace> m_fontFace;
    Microsoft::WRL::ComPtr<IDWriteNumberSubstitution> m_numberSubstitution;
    float m_fontEmSize;

    // Output text analysis results
    std::vector<TextAnalysis::Run> m_runs;
    std::vector<DWRITE_LINE_BREAKPOINT> m_breakpoints;
    std::vector<DWRITE_GLYPH_OFFSET> m_glyphOffsets;
    std::vector<UINT16> m_glyphClusters;
    std::vector<UINT16> m_glyphIndices;
    std::vector<float>  m_glyphAdvances;

    float m_maxSpaceWidth;           // maximum stretch of space allowed for justification
    bool m_isTextAnalysisComplete;   // text analysis was done.
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/FlowSink.cpp File Reference

  • DirectWrite vertical text

FlowSink.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"
#include "FlowSink.h"
#include "TextAnalysis.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/FlowSink.h File Reference

  • DirectWrite vertical text
Functions

FlowSink.h File Reference

Go to the source code of this file.

Functions

class DECLSPEC_UUID ("7712E74A-C7E0-4664-B58E-854394F2ACB4") FlowLayoutSink

Function Documentation

class DECLSPEC_UUID ( "7712E74A-C7E0-4664-B58E-854394F2ACB4" )

Definition at line 13 of file FlowSink.h.

    :   public ComBase<QiListSelf<FlowLayoutSink, QiList<IUnknown>>>
{
public:
    FlowLayoutSink(Microsoft::WRL::ComPtr<IDWriteFactory> dwriteFactory):
        m_dwriteFactory(dwriteFactory),
        m_textAnalyzer()
    {
    }

    void Reset();

    void Prepare(UINT32 glyphCount);

    void SetGlyphRun(
        float x,
        float y,
        UINT32 glyphCount,
        const UINT16* glyphIndices,
        const float* glyphAdvances,
        const DWRITE_GLYPH_OFFSET* glyphOffsets,
        Microsoft::WRL::ComPtr<IDWriteFontFace> fontFace,
        float fontEmSize,
        UINT8 glyphOrientation,
        bool isReversed,
        bool isSideways
        );

    void DrawGlyphRuns(
        Microsoft::WRL::ComPtr<ID2D1DeviceContext> deviceContext,
        Microsoft::WRL::ComPtr<IDWriteRenderingParams> renderingParams,
        Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> textColor
        ) const;

protected:
    // This glyph run is based off DWRITE_GLYPH_RUN
    // and is trivially convertable to it, but stores
    // pointers as relative indices instead instead
    // of raw pointers, which makes it more useful for
    // storing in a vector. Additionally, it stores
    // the x, y coordinate.

    struct CustomGlyphRun
    {
        CustomGlyphRun()
        :   fontFace(),
            fontEmSize(),
            glyphStart(),
            glyphCount(),
            glyphOrientation(),
            isSideways(),
            isReversed(),
            x(),
            y()
        { }

        CustomGlyphRun(const CustomGlyphRun& b)
        {
            memcpy(this, &b, sizeof(*this));
            fontFace = SafeAcquire(b.fontFace);
        }

        CustomGlyphRun& operator =(const CustomGlyphRun& b)
        {
            if (this != &b)
            {
                // Define assignment operator in terms of destructor and
                // placement new constructor, paying heed to self assignment.
                this->~CustomGlyphRun();
                new(this) CustomGlyphRun(b);
            }
            return *this;
        }

        IDWriteFontFace* fontFace;
        float fontEmSize;
        float x;
        float y;
        UINT32 glyphStart;
        UINT32 glyphCount;
        UINT8 glyphOrientation;
        bool isSideways;
        bool isReversed;

        void Convert(
            const UINT16* glyphIndices,                 // [glyphCount]
            const float* glyphAdvances,                 // [glyphCount]
            const DWRITE_GLYPH_OFFSET* glyphOffsets,    // [glyphCount]
            OUT DWRITE_GLYPH_RUN* glyphRun
            ) const;
    };

    std::vector<CustomGlyphRun>         m_glyphRuns;
    std::vector<UINT16>                 m_glyphIndices;
    std::vector<float>                  m_glyphAdvances;
    std::vector<DWRITE_GLYPH_OFFSET>    m_glyphOffsets;

    Microsoft::WRL::ComPtr<IDWriteFactory> m_dwriteFactory;
    mutable Microsoft::WRL::ComPtr<IDWriteTextAnalyzer1> m_textAnalyzer;
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/FlowSource.cpp File Reference

  • DirectWrite vertical text

FlowSource.cpp File Reference

#include "pch.h"
#include "TextAnalysis.h"
#include "FlowSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/FlowSource.h File Reference

  • DirectWrite vertical text
Functions

FlowSource.h File Reference

Go to the source code of this file.

Functions

class DECLSPEC_UUID ("84600D90-8F09-480f-9275-D71125FCD0C3") FlowLayoutSource

Function Documentation

class DECLSPEC_UUID ( "84600D90-8F09-480f-9275-D71125FCD0C3" )

Definition at line 14 of file FlowSource.h.

                                                                            :
    public ComBase<QiListSelf<FlowLayoutSource, QiList<IUnknown>>>
{
public:
    struct RectF
    {
        float left;
        float top;
        float right;
        float bottom;
    };

    FlowLayoutSource():
        m_width(300),
        m_height(300),
        m_currentU(),
        m_currentV()
    {
        Reset();
    }

    void Reset();
    void SetSize(float width, float height);
    bool GetNextRect(float fontHeight, ReadingDirection readingDirection, _Out_ RectF* nextRect);

protected:
    float m_width;
    float m_height;
    float m_currentU;
    float m_currentV;
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/pch.cpp File Reference

  • DirectWrite vertical text

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/pch.h File Reference

  • DirectWrite vertical text
Classes | Enumerations | Functions

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1_1helper.h>
#include <d2d1effects.h>
#include <wincodec.h>
#include <math.h>
#include <agile.h>
#include <stdlib.h>
#include <malloc.h>
#include <memory.h>
#include <algorithm>
#include <numeric>
#include <string>
#include <vector>
#include <utility>
#include <limits>
#include <windows.h>
#include <unknwn.h>
#include <dwrite_1.h>
#include <intsafe.h>
#include <strsafe.h>

Go to the source code of this file.

Classes

class | ComBase< InterfaceChain >
class | QiList< InterfaceName, InterfaceChain >
class | QiList< InterfaceName, QiListNil >
struct | QiListNil
class | QiListSelf< InterfaceName, InterfaceChain >

Enumerations

enum | { UnicodeMax = 0x10FFFF }

Functions

bool | IsLeadingSurrogate (UINT32 ch)
bool | IsSurrogate (UINT32 ch)
bool | IsTrailingSurrogate (UINT32 ch)
UINT32 | MakeUnicodeCodepoint (UINT32 leading, UINT32 trailing)
template<typename InterfaceType >
InterfaceType * | SafeAcquire (InterfaceType *newObject)

Enumeration Type Documentation

anonymous enum
Enumerator:
UnicodeMax

Definition at line 47 of file pch.h.

     {
    UnicodeMax = 0x10FFFF
};

Function Documentation

bool IsLeadingSurrogate ( UINT32 ch ) [inline]

Definition at line 58 of file pch.h.

{
    // 0xD800 <= ch <= 0xDBFF
    return (ch & 0xFC00) == 0xD800;
}

bool IsSurrogate ( UINT32 ch ) [inline]

Definition at line 52 of file pch.h.

{
    // 0xD800 <= ch <= 0xDFFF
    return (ch & 0xF800) == 0xD800;
}

bool IsTrailingSurrogate ( UINT32 ch ) [inline]

Definition at line 64 of file pch.h.

{
    // 0xDC00 <= ch <= 0xDFFF
    return (ch & 0xFC00) == 0xDC00;
}

UINT32 MakeUnicodeCodepoint | ( | UINT32 | leading,
 |  | UINT32 | trailing |
 | ) |  |  | [inline]

Definition at line 70 of file pch.h.

{
    return ((leading & 0x03FF) << 10 | (trailing & 0x03FF)) + 0x10000;
}

template<typename InterfaceType >
InterfaceType* SafeAcquire ( InterfaceType * newObject ) [inline]

Definition at line 77 of file pch.h.

{
    if (newObject != nullptr)
    {
        newObject->AddRef();
    }
    return newObject;
}

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/SampleOverlay.cpp File Reference

  • DirectWrite vertical text

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/SampleOverlay.h File Reference

  • DirectWrite vertical text
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/TextAnalysis.cpp File Reference

  • DirectWrite vertical text

TextAnalysis.cpp File Reference

#include "pch.h"
#include "TextAnalysis.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/TextAnalysis.h File Reference

  • DirectWrite vertical text
Classes | Enumerations

TextAnalysis.h File Reference

Go to the source code of this file.

Classes

class | TextAnalysis
struct | TextAnalysis::LinkedRun
struct | TextAnalysis::Run

Enumerations

enum GlyphOrientation {
GlyphOrientationLeftToRightTopToBottom = 0, GlyphOrientationRightToLeftTopToBottom = 1, GlyphOrientationLeftToRightBottomToTop = 2, GlyphOrientationRightToLeftBottomToTop = 3,
GlyphOrientationTopToBottomLeftToRight = 4, GlyphOrientationBottomToTopLeftToRight = 5, GlyphOrientationTopToBottomRightToLeft = 6, GlyphOrientationBottomToTopRightToLeft = 7,
GlyphOrientationCW0 = GlyphOrientationLeftToRightTopToBottom, GlyphOrientationCW90 = GlyphOrientationTopToBottomRightToLeft, GlyphOrientationCW180 = GlyphOrientationRightToLeftBottomToTop, GlyphOrientationCW270 = GlyphOrientationBottomToTopLeftToRight,
GlyphOrientationES = GlyphOrientationLeftToRightTopToBottom, GlyphOrientationSW = GlyphOrientationTopToBottomRightToLeft, GlyphOrientationWN = GlyphOrientationRightToLeftBottomToTop, GlyphOrientationNE = GlyphOrientationBottomToTopLeftToRight,
GlyphOrientationFH = GlyphOrientationRightToLeftTopToBottom, GlyphOrientationFV = GlyphOrientationLeftToRightBottomToTop, GlyphOrientationFlipHorizontal = 1, GlyphOrientationFlipVertical = 2,
GlyphOrientationFlipDiagonal = 4
}
enum | GlyphOrientationMode { GlyphOrientationModeDefault, GlyphOrientationModeStacked, GlyphOrientationModeTotal }
enum ReadingDirection {
ReadingDirectionLeftToRightTopToBottom = 0, ReadingDirectionRightToLeftTopToBottom = 1, ReadingDirectionLeftToRightBottomToTop = 2, ReadingDirectionRightToLeftBottomToTop = 3,
ReadingDirectionTopToBottomLeftToRight = 4, ReadingDirectionBottomToTopLeftToRight = 5, ReadingDirectionTopToBottomRightToLeft = 6, ReadingDirectionBottomToTopRightToLeft = 7,
ReadingDirectionPrimaryProgression = 1, ReadingDirectionSecondaryProgression = 2, ReadingDirectionPrimaryAxis = 4, ReadingDirectionEs = ReadingDirectionLeftToRightTopToBottom,
ReadingDirectionSw = ReadingDirectionTopToBottomRightToLeft, ReadingDirectionWn = ReadingDirectionRightToLeftBottomToTop, ReadingDirectionNe = ReadingDirectionBottomToTopLeftToRight, ReadingDirectionE = ReadingDirectionLeftToRightTopToBottom,
ReadingDirectionS = ReadingDirectionTopToBottomLeftToRight, ReadingDirectionW = ReadingDirectionRightToLeftTopToBottom, ReadingDirectionN = ReadingDirectionBottomToTopLeftToRight
}

Enumeration Type Documentation

enum GlyphOrientation
Enumerator:
GlyphOrientationLeftToRightTopToBottom
GlyphOrientationRightToLeftTopToBottom
GlyphOrientationLeftToRightBottomToTop
GlyphOrientationRightToLeftBottomToTop
GlyphOrientationTopToBottomLeftToRight
GlyphOrientationBottomToTopLeftToRight
GlyphOrientationTopToBottomRightToLeft
GlyphOrientationBottomToTopRightToLeft
GlyphOrientationCW0
GlyphOrientationCW90
GlyphOrientationCW180
GlyphOrientationCW270
GlyphOrientationES
GlyphOrientationSW
GlyphOrientationWN
GlyphOrientationNE
GlyphOrientationFH
GlyphOrientationFV
GlyphOrientationFlipHorizontal
GlyphOrientationFlipVertical
GlyphOrientationFlipDiagonal

Definition at line 55 of file TextAnalysis.h.

{
    GlyphOrientationLeftToRightTopToBottom = 0,
    GlyphOrientationRightToLeftTopToBottom = 1,
    GlyphOrientationLeftToRightBottomToTop = 2,
    GlyphOrientationRightToLeftBottomToTop = 3,
    GlyphOrientationTopToBottomLeftToRight = 4,
    GlyphOrientationBottomToTopLeftToRight = 5,
    GlyphOrientationTopToBottomRightToLeft = 6,
    GlyphOrientationBottomToTopRightToLeft = 7,

    // Rotational aliases
    GlyphOrientationCW0                    = GlyphOrientationLeftToRightTopToBottom,
    GlyphOrientationCW90                   = GlyphOrientationTopToBottomRightToLeft,
    GlyphOrientationCW180                  = GlyphOrientationRightToLeftBottomToTop,
    GlyphOrientationCW270                  = GlyphOrientationBottomToTopLeftToRight,

    // Internal shorter aliases
    GlyphOrientationES                     = GlyphOrientationLeftToRightTopToBottom,
    GlyphOrientationSW                     = GlyphOrientationTopToBottomRightToLeft,
    GlyphOrientationWN                     = GlyphOrientationRightToLeftBottomToTop,
    GlyphOrientationNE                     = GlyphOrientationBottomToTopLeftToRight,
    GlyphOrientationFH                     = GlyphOrientationRightToLeftTopToBottom,
    GlyphOrientationFV                     = GlyphOrientationLeftToRightBottomToTop,

    // Individual bits
    GlyphOrientationFlipHorizontal         = 1,  // Glyph Mirrored Horizontally  (Left <-> Right)
    GlyphOrientationFlipVertical           = 2,  // Glyph Mirrored Vertically (Top <-> Bottom)
    GlyphOrientationFlipDiagonal           = 4,  // Glyph Transposed Around Diagonal
};

enum GlyphOrientationMode
Enumerator:
GlyphOrientationModeDefault
GlyphOrientationModeStacked
GlyphOrientationModeTotal

Definition at line 47 of file TextAnalysis.h.

{
    GlyphOrientationModeDefault,    // rotated or upright according to script default
    GlyphOrientationModeStacked,    // stacked if script allows it
    GlyphOrientationModeTotal
};

enum ReadingDirection

Direction for how reading progresses.

Enumerator:
ReadingDirectionLeftToRightTopToBottom
ReadingDirectionRightToLeftTopToBottom
ReadingDirectionLeftToRightBottomToTop
ReadingDirectionRightToLeftBottomToTop
ReadingDirectionTopToBottomLeftToRight
ReadingDirectionBottomToTopLeftToRight
ReadingDirectionTopToBottomRightToLeft
ReadingDirectionBottomToTopRightToLeft
ReadingDirectionPrimaryProgression
ReadingDirectionSecondaryProgression
ReadingDirectionPrimaryAxis
ReadingDirectionEs
ReadingDirectionSw
ReadingDirectionWn
ReadingDirectionNe
ReadingDirectionE
ReadingDirectionS
ReadingDirectionW
ReadingDirectionN

Definition at line 17 of file TextAnalysis.h.

{
    ReadingDirectionLeftToRightTopToBottom = 0,
    ReadingDirectionRightToLeftTopToBottom = 1,
    ReadingDirectionLeftToRightBottomToTop = 2,
    ReadingDirectionRightToLeftBottomToTop = 3,
    ReadingDirectionTopToBottomLeftToRight = 4,
    ReadingDirectionBottomToTopLeftToRight = 5,
    ReadingDirectionTopToBottomRightToLeft = 6,
    ReadingDirectionBottomToTopRightToLeft = 7,

    // Contributing bits
    ReadingDirectionPrimaryProgression     = 1, // False = Ltr/Ttb,    True = Rtl/Btt
    ReadingDirectionSecondaryProgression   = 2, // False = Ttb/Ltr,    True = Btt/Rtl
    ReadingDirectionPrimaryAxis            = 4, // False = Horizontal, True = Vertical

    // Shorter Aliases
    ReadingDirectionEs = ReadingDirectionLeftToRightTopToBottom,
    ReadingDirectionSw = ReadingDirectionTopToBottomRightToLeft,
    ReadingDirectionWn = ReadingDirectionRightToLeftBottomToTop,
    ReadingDirectionNe = ReadingDirectionBottomToTopLeftToRight,

    // A single direction
    ReadingDirectionE = ReadingDirectionLeftToRightTopToBottom,
    ReadingDirectionS = ReadingDirectionTopToBottomLeftToRight,
    ReadingDirectionW = ReadingDirectionRightToLeftTopToBottom,
    ReadingDirectionN = ReadingDirectionBottomToTopLeftToRight,
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Animate.cpp File Reference

  • DirectX 3D shooting game

Animate.cpp File Reference

#include "pch.h"
#include "Animate.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Animate.h File Reference

  • DirectX 3D shooting game
Classes

Animate.h File Reference

Go to the source code of this file.

Classes

class | abstract
class | AnimateCirclePosition
class | AnimateLineListPosition
class | AnimateLinePosition
struct | LineSegment
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Audio.cpp File Reference

  • DirectX 3D shooting game

Audio.cpp File Reference

#include "pch.h"
#include "Audio.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Audio.h File Reference

  • DirectX 3D shooting game
Classes

Audio.h File Reference

Go to the source code of this file.

Classes

class Audio
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicLoader.cpp File Reference

  • DirectX 3D shooting game

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicLoader.h File Reference

  • DirectX 3D shooting game
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicMath.h File Reference

  • DirectX 3D shooting game
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicReaderWriter.cpp File Reference

  • DirectX 3D shooting game

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicReaderWriter.h File Reference

  • DirectX 3D shooting game
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicShapes.h File Reference

  • DirectX 3D shooting game
Classes

BasicShapes.h File Reference

#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Camera.cpp File Reference

  • DirectX 3D shooting game

Camera.cpp File Reference

#include "pch.h"
#include "Camera.h"
#include "StereoProjection.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Camera.h File Reference

  • DirectX 3D shooting game
Classes

Camera.h File Reference

Go to the source code of this file.

Classes

class Camera
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/ConstantBuffers.h File Reference

  • DirectX 3D shooting game
Classes

ConstantBuffers.h File Reference

Go to the source code of this file.

Classes

struct | ConstantBufferChangeOnResize
struct | ConstantBufferChangesEveryFrame
struct | ConstantBufferChangesEveryPrim
struct | ConstantBufferNeverChanges
struct | PNTVertex
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Cylinder.cpp File Reference

  • DirectX 3D shooting game

Cylinder.cpp File Reference

#include "pch.h"
#include "Cylinder.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Cylinder.h File Reference

  • DirectX 3D shooting game
Classes

Cylinder.h File Reference

#include "GameObject.h"
#include "GameObject.h"

Go to the source code of this file.

Classes

class Cylinder
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/CylinderMesh.cpp File Reference

  • DirectX 3D shooting game

CylinderMesh.cpp File Reference

#include "pch.h"
#include "CylinderMesh.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/CylinderMesh.h File Reference

  • DirectX 3D shooting game
Classes

CylinderMesh.h File Reference

#include "MeshObject.h"

Go to the source code of this file.

Classes

class CylinderMesh
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DDSTextureLoader.cpp File Reference

  • DirectX 3D shooting game
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DDSTextureLoader.h File Reference

  • DirectX 3D shooting game
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DirectXApp.cpp File Reference

  • DirectX 3D shooting game
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 847 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DirectXApp.h File Reference

  • DirectX 3D shooting game
Classes | Enumerations

DirectXApp.h File Reference

#include "Simple3DGame.h"
#include "Simple3DGame.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource

Enumerations

enum GameInfoOverlayState {
Loading, GameStats, GameOverExpired, GameOverCompleted,
LevelStart, Pause
}
enum | PressResultState { LoadGame, PlayLevel, ContinueLevel }
enum UpdateEngineState {
WaitingForResources, ResourcesLoaded, WaitingForPress, Dynamics,
Snapped, Suspended, Deactivated
}

Enumeration Type Documentation

enum GameInfoOverlayState
Enumerator:
Loading
GameStats
GameOverExpired
GameOverCompleted
LevelStart
Pause

Definition at line 63 of file DirectXApp.h.

{
    Loading,
    GameStats,
    GameOverExpired,
    GameOverCompleted,
    LevelStart,
    Pause,
};

enum PressResultState
Enumerator:
LoadGame
PlayLevel
ContinueLevel

Definition at line 56 of file DirectXApp.h.

{
    LoadGame,
    PlayLevel,
    ContinueLevel,
};

enum UpdateEngineState
Enumerator:
WaitingForResources
ResourcesLoaded
WaitingForPress
Dynamics
Snapped
Suspended
Deactivated

Definition at line 45 of file DirectXApp.h.

{
    WaitingForResources,
    ResourcesLoaded,
    WaitingForPress,
    Dynamics,
    Snapped,
    Suspended,
    Deactivated,
};

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DirectXBase.cpp File Reference

  • DirectX 3D shooting game

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DirectXBase.h File Reference

  • DirectX 3D shooting game
Classes | Functions

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class | abstract

Functions

delegate void | D3DDeviceEventHandler ()

Function Documentation

delegate void D3DDeviceEventHandler ( )
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DirectXSample.h File Reference

  • DirectX 3D shooting game
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Face.cpp File Reference

  • DirectX 3D shooting game

Face.cpp File Reference

#include "pch.h"
#include "Face.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Face.h File Reference

  • DirectX 3D shooting game
Classes

Face.h File Reference

#include "GameObject.h"

Go to the source code of this file.

Classes

class Face
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/FaceMesh.cpp File Reference

  • DirectX 3D shooting game

FaceMesh.cpp File Reference

#include "pch.h"
#include "FaceMesh.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/FaceMesh.h File Reference

  • DirectX 3D shooting game
Classes

FaceMesh.h File Reference

#include "MeshObject.h"

Go to the source code of this file.

Classes

class FaceMesh
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameConstants.h File Reference

  • DirectX 3D shooting game
Namespaces

GameConstants.h File Reference

Go to the source code of this file.

Namespaces

namespace | GameConstants
namespace | GameConstants::Physics
namespace | GameConstants::Sound
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameHud.cpp File Reference

  • DirectX 3D shooting game

GameHud.cpp File Reference

#include "pch.h"
#include "GameHud.h"
#include "GameConstants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameHud.h File Reference

  • DirectX 3D shooting game
Classes

GameHud.h File Reference

#include "Simple3DGame.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class GameHud
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameInfoOverlay.cpp File Reference

  • DirectX 3D shooting game

GameInfoOverlay.cpp File Reference

#include "pch.h"
#include "GameInfoOverlay.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameInfoOverlay.h File Reference

  • DirectX 3D shooting game
Classes | Namespaces | Enumerations

GameInfoOverlay.h File Reference

Go to the source code of this file.

Classes

class | GameInfoOverlay

Namespaces

namespace | GameInfoOverlayConstant

Enumerations

enum | GameInfoOverlayCommand { None, TapToContinue, PleaseWait, PlayAgain }

Enumeration Type Documentation

enum GameInfoOverlayCommand
Enumerator:
None
TapToContinue
PleaseWait
PlayAgain

Definition at line 33 of file GameInfoOverlay.h.

{
    None,
    TapToContinue,
    PleaseWait,
    PlayAgain,
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameObject.cpp File Reference

  • DirectX 3D shooting game

GameObject.cpp File Reference

#include "pch.h"
#include "GameObject.h"
#include "ConstantBuffers.h"
#include "GameConstants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameObject.h File Reference

  • DirectX 3D shooting game
Classes

GameObject.h File Reference

#include "MeshObject.h"
#include "SoundEffect.h"
#include "Animate.h"
#include "Material.h"
#include "MeshObject.h"
#include "SoundEffect.h"
#include "Material.h"

Go to the source code of this file.

Classes

class GameObject
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameRenderer.cpp File Reference

  • DirectX 3D shooting game

GameRenderer.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"
#include "GameRenderer.h"
#include "ConstantBuffers.h"
#include "TargetTexture.h"
#include "BasicLoader.h"
#include "CylinderMesh.h"
#include "FaceMesh.h"
#include "SphereMesh.h"
#include "WorldMesh.h"
#include "Face.h"
#include "Sphere.h"
#include "Cylinder.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameRenderer.h File Reference

  • DirectX 3D shooting game
Classes

GameRenderer.h File Reference

#include "DirectXBase.h"
#include "GameInfoOverlay.h"
#include "GameHud.h"
#include "Simple3DGame.h"
#include "DirectXBase.h"
#include "GameHud.h"

Go to the source code of this file.

Classes

class GameRenderer
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameTimer.cpp File Reference

  • DirectX 3D shooting game

GameTimer.cpp File Reference

#include "pch.h"
#include "GameTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameTimer.h File Reference

  • DirectX 3D shooting game
Classes

GameTimer.h File Reference

Go to the source code of this file.

Classes

class GameTimer
THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A //// PARTICULAR PURPOSE. //// //// Copyright (c) Microsoft Corporation. All rights reserved. More...
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level.cpp File Reference

  • DirectX 3D shooting game

Level.cpp File Reference

#include "pch.h"
#include "Level.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level.h File Reference

  • DirectX 3D shooting game
Classes

Level.h File Reference

#include "GameObject.h"
#include "PersistentState.h"
#include "PersistentState.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level1.cpp File Reference

  • DirectX 3D shooting game

Level1.cpp File Reference

#include "pch.h"
#include "Level1.h"
#include "Face.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level1.h File Reference

  • DirectX 3D shooting game
Classes

Level1.h File Reference

#include "Level.h"

Go to the source code of this file.

Classes

class Level1
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level2.cpp File Reference

  • DirectX 3D shooting game

Level2.cpp File Reference

#include "pch.h"
#include "Level2.h"
#include "Face.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level2.h File Reference

  • DirectX 3D shooting game
Classes

Level2.h File Reference

#include "Level1.h"

Go to the source code of this file.

Classes

class Level2
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level3.cpp File Reference

  • DirectX 3D shooting game

Level3.cpp File Reference

#include "pch.h"
#include "Level3.h"
#include "Face.h"
#include "Animate.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level3.h File Reference

  • DirectX 3D shooting game
Classes

Level3.h File Reference

#include "Level.h"

Go to the source code of this file.

Classes

class Level3
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level4.cpp File Reference

  • DirectX 3D shooting game

Level4.cpp File Reference

#include "pch.h"
#include "Level4.h"
#include "Face.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level4.h File Reference

  • DirectX 3D shooting game
Classes

Level4.h File Reference

#include "Level3.h"

Go to the source code of this file.

Classes

class Level4
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level5.cpp File Reference

  • DirectX 3D shooting game

Level5.cpp File Reference

#include "pch.h"
#include "Level5.h"
#include "Cylinder.h"
#include "Animate.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level5.h File Reference

  • DirectX 3D shooting game
Classes

Level5.h File Reference

#include "Level3.h"

Go to the source code of this file.

Classes

class Level5
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level6.cpp File Reference

  • DirectX 3D shooting game

Level6.cpp File Reference

#include "pch.h"
#include "Level6.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level6.h File Reference

  • DirectX 3D shooting game
Classes

Level6.h File Reference

#include "Level5.h"

Go to the source code of this file.

Classes

class Level6
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Material.cpp File Reference

  • DirectX 3D shooting game

Material.cpp File Reference

#include "pch.h"
#include "Material.h"
#include "GameConstants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Material.h File Reference

  • DirectX 3D shooting game
Classes

Material.h File Reference

#include "ConstantBuffers.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Classes

class Material
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/MediaReader.cpp File Reference

  • DirectX 3D shooting game

MediaReader.cpp File Reference

#include "pch.h"
#include "MediaReader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/MediaReader.h File Reference

  • DirectX 3D shooting game
Classes

MediaReader.h File Reference

Go to the source code of this file.

Classes

class MediaReader
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/MeshObject.cpp File Reference

  • DirectX 3D shooting game

MeshObject.cpp File Reference

#include "pch.h"
#include "MeshObject.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/MeshObject.h File Reference

  • DirectX 3D shooting game
Classes

MeshObject.h File Reference

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/MoveLookController.cpp File Reference

  • DirectX 3D shooting game
Defines

MoveLookController.cpp File Reference

#include "pch.h"
#include "MoveLookController.h"
#include "DirectXSample.h"

Go to the source code of this file.

Defines

#define | MOVEMENT_GAIN 2.f
#define | ROTATION_GAIN 0.008f

Define Documentation

#define MOVEMENT_GAIN 2.f

Definition at line 22 of file MoveLookController.cpp.

#define ROTATION_GAIN 0.008f

Definition at line 21 of file MoveLookController.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/MoveLookController.h File Reference

  • DirectX 3D shooting game
Classes | Enumerations

MoveLookController.h File Reference

Go to the source code of this file.

Classes

class MoveLookController

Enumerations

enum MoveLookControllerState {
None, WaitForInput, Active, None,
WaitForInput, Active
}

Enumeration Type Documentation

enum MoveLookControllerState
Enumerator:
None
WaitForInput
Active
None
WaitForInput
Active

Definition at line 77 of file MoveLookController.h.

{
    None,
    WaitForInput,
    Active,
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/pch.cpp File Reference

  • DirectX 3D shooting game

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/pch.h File Reference

  • DirectX 3D shooting game

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <DirectXMath.h>
#include <xaudio2.h>
#include <xaudio2fx.h>
#include <mmreg.h>
#include <mfidl.h>
#include <mfapi.h>
#include <mfreadwrite.h>
#include <XInput.h>
#include <stdio.h>
#include <vector>
#include <memory>
#include <ppltasks.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/PersistentState.cpp File Reference

  • DirectX 3D shooting game

PersistentState.cpp File Reference

#include "pch.h"
#include "PersistentState.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/PersistentState.h File Reference

  • DirectX 3D shooting game
Classes

PersistentState.h File Reference

Go to the source code of this file.

Classes

class PersistentState
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Simple3DGame.cpp File Reference

  • DirectX 3D shooting game

Simple3DGame.cpp File Reference

#include "pch.h"
#include "GameRenderer.h"
#include "DirectXSample.h"
#include "Level1.h"
#include "Level2.h"
#include "Level3.h"
#include "Level4.h"
#include "Level5.h"
#include "Level6.h"
#include "Animate.h"
#include "Sphere.h"
#include "Cylinder.h"
#include "Face.h"
#include "MediaReader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Simple3DGame.h File Reference

  • DirectX 3D shooting game
Classes | Typedefs | Enumerations

Simple3DGame.h File Reference

#include "GameConstants.h"
#include "Audio.h"
#include "Camera.h"
#include "Level.h"
#include "GameObject.h"
#include "GameTimer.h"
#include "MoveLookController.h"
#include "PersistentState.h"
#include "Sphere.h"
#include "GameRenderer.h"
#include "GameConstants.h"
#include "Level.h"
#include "GameTimer.h"
#include "MoveLookController.h"
#include "Sphere.h"
#include "GameRenderer.h"

Go to the source code of this file.

Classes

struct | HighScoreEntry
class | Simple3DGame

Typedefs

typedef std::vector
< HighScoreEntry > 		HighScoreEntries

Enumerations

enum GameState {
Waiting, Active, LevelComplete, TimeExpired,
GameComplete, Initial, MainMenu, HighScoreDisplay,
PreGameCountdown, InGameActive, InGamePaused, PostGameResults,
Waiting, Active, LevelComplete, TimeExpired,
GameComplete
}

Typedef Documentation

typedef std::vector<HighScoreEntry> HighScoreEntries

Definition at line 58 of file Simple3DGame.h.

Enumeration Type Documentation

enum GameState
Enumerator:
Waiting
Active
LevelComplete
TimeExpired
GameComplete
Initial
MainMenu
HighScoreDisplay
PreGameCountdown
InGameActive
InGamePaused
PostGameResults
Waiting
Active
LevelComplete
TimeExpired
GameComplete

Definition at line 41 of file Simple3DGame.h.

{
    Waiting,
    Active,
    LevelComplete,
    TimeExpired,
    GameComplete,
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/SoundEffect.cpp File Reference

  • DirectX 3D shooting game

SoundEffect.cpp File Reference

#include "pch.h"
#include "SoundEffect.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/SoundEffect.h File Reference

  • DirectX 3D shooting game
Classes

SoundEffect.h File Reference

Go to the source code of this file.

Classes

class SoundEffect
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Sphere.cpp File Reference

  • DirectX 3D shooting game

Sphere.cpp File Reference

#include "pch.h"
#include "Sphere.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Sphere.h File Reference

  • DirectX 3D shooting game
Classes

Sphere.h File Reference

#include "GameObject.h"

Go to the source code of this file.

Classes

class Sphere
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/SphereMesh.cpp File Reference

  • DirectX 3D shooting game

SphereMesh.cpp File Reference

#include "pch.h"
#include "SphereMesh.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/SphereMesh.h File Reference

  • DirectX 3D shooting game
Classes

SphereMesh.h File Reference

#include "MeshObject.h"

Go to the source code of this file.

Classes

class SphereMesh
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/StereoProjection.cpp File Reference

  • DirectX 3D shooting game
Defines | Functions

StereoProjection.cpp File Reference

#include "pch.h"
#include "StereoProjection.h"

Go to the source code of this file.

Defines

#define | XMASSERT(Expression) ((void)0)

Functions

__forceinline bool | _XMMatrixStereoProjectionHelper (const STEREO_PARAMETERS *stereoParameters, _Out_ float *virtualProjection, _Out_ float *zNearWidth, _Out_ float *zNearHeight, float fovAngleY, float aspectHByW, float nearZ)
XMMATRIX | MatrixStereoProjectionFovLH (_In_opt_ const STEREO_PARAMETERS *stereoParameters, STEREO_CHANNEL channel, float fovAngleY, float aspectHByW, float nearZ, float farZ, STEREO_MODE stereoMode)
void | StereoCreateDefaultParameters (_Out_ STEREO_PARAMETERS *stereoParameters)

Define Documentation

#define XMASSERT ( Expression ) ((void)0)

Definition at line 12 of file StereoProjection.cpp.

Function Documentation

__forceinline bool _XMMatrixStereoProjectionHelper | ( | const STEREO_PARAMETERS * | stereoParameters,
 |  | _Out_ float * | virtualProjection,
 |  | _Out_ float * | zNearWidth,
 |  | _Out_ float * | zNearHeight,
 |  | float | fovAngleY,
 |  | float | aspectHByW,
 |  | float | nearZ
 | ) |  |

Definition at line 31 of file StereoProjection.cpp.

{
    // note that most people have difficulty fusing images into 3D
    // if the separation equals even just the human average. by
    // reducing the separation (interocular distance) by 1/2, we
    // guarantee a larger subset of people will see full 3D

    // the conservative setting should always be used. the only problem
    // with the conservative setting is that the 3D effect will be less
    // impressive on smaller screens (which makes sense, since your eye
    // cannot be tricked as easily based on the smaller fov). to simulate
    // the effect of a larger screen, use the liberal settings (debug only)

    // Conservative Settings: * max acuity angle: 0.8f degrees * interoc distance: 1.25 inches

    // Liberal Settings: * max acuity angle: 1.6f degrees * interoc distance: 2.5f inches

    // maximum visual accuity angle allowed is 3.2 degrees for
    // a physical scene, and 1.6 degrees for a virtual one.
    // thus we cannot allow an object to appear any closer to
    // the viewer than 1.6 degrees (divided by two for most
    // half-angle calculations)

    static const float maxStereoDistance = 85; // 780 inches (should be between 10 and 20m)
    static const float maxVisualAcuityAngle = 0.8f * (XM_PI / 180.0f);  // radians
    static const float interocularDistance = 1.25f; // inches

    bool comfortableResult = true;

    float displayHeight = stereoParameters->displaySizeInches / sqrtf(aspectHByW * aspectHByW + 1.0f);
    float displayWidth = displayHeight * aspectHByW;
    float halfInterocular = 0.5f * interocularDistance * stereoParameters->stereoExaggerationFactor;
    float halfPixelWidth  = displayWidth / stereoParameters->pixelResolutionWidth * 0.5f;
    float halfMaximumAcuityAngle = maxVisualAcuityAngle * 0.5f * stereoParameters->stereoExaggerationFactor;

    float maxSeparationAcuityAngle = atanf(halfInterocular / maxStereoDistance);
    float maxSeparationDistance = halfPixelWidth / tanf(maxSeparationAcuityAngle);
    float refinedMaxStereoDistance = maxStereoDistance - maxSeparationDistance;
    float fovHalfAngle = fovAngleY / 2.0f;

    if (refinedMaxStereoDistance < 0.0f || maxSeparationDistance > 0.1f * maxStereoDistance)
    {
        // Pixel resolution is too low to offer a comfortable stereo experience
        comfortableResult = false;
    }

    float refinedMaxSeparationAcuityAngle = atanf(halfInterocular / refinedMaxStereoDistance);
    float physicalZNearDistance = halfInterocular / tanf(halfMaximumAcuityAngle);

    float nearZSeparation = tanf(refinedMaxSeparationAcuityAngle) * (refinedMaxStereoDistance - physicalZNearDistance);

    *zNearHeight = cosf(fovHalfAngle) / sinf(fovHalfAngle);
    *zNearWidth = *zNearHeight / aspectHByW;
    *virtualProjection = (nearZSeparation * nearZ * (*zNearWidth * 4.0f)) / (2.0f * nearZ);

    return comfortableResult;
}

XMMATRIX MatrixStereoProjectionFovLH | ( | _In_opt_ const STEREO_PARAMETERS * | stereoParameters,
 |  | STEREO_CHANNEL | channel,
 |  | float | fovAngleY,
 |  | float | aspectHByW,
 |  | float | nearZ,
 |  | float | farZ,
 |  | STEREO_MODE | stereoMode
 | ) |  |

Definition at line 98 of file StereoProjection.cpp.

{
    float virtualProjection = 0.0f;
    float zNearWidth = 0.0f;
    float zNearHeight = 0.0f;
    float invertedAngle;
    XMMATRIX patchedProjection;
    XMMATRIX proj;
    STEREO_PARAMETERS defaultParameters;

    XMASSERT(channel == STEREO_CHANNEL::LEFT || channel == STEREO_CHANNEL::RIGHT);
    XMASSERT(stereoMode == STEREO_MODE::NORMAL || stereoMode == STEREO_MODE::INVERTED);
    XMASSERT(!XMScalarNearEqual(fovAngleY, 0.0f, 0.00001f * 2.0f));
    XMASSERT(!XMScalarNearEqual(aspectHByW, 0.0f, 0.00001f));
    XMASSERT(!XMScalarNearEqual(farZ, nearZ, 0.00001f));

    proj = XMMatrixIdentity();

    if (stereoParameters == nullptr)
    {
        StereoCreateDefaultParameters(&defaultParameters);
        stereoParameters = &defaultParameters;
    }

    XMASSERT(pStereoParameters->stereoSeparationFactor >= 0.0f && stereoParameters->stereoSeparationFactor <= 1.0f);
    XMASSERT(pStereoParameters->stereoExaggerationFactor >= 1.0f && stereoParameters->stereoExaggerationFactor <= 2.0f);

    _XMMatrixStereoProjectionHelper(stereoParameters, &virtualProjection, &zNearWidth, &zNearHeight, fovAngleY, aspectHByW, nearZ);

    virtualProjection *= stereoParameters->stereoSeparationFactor; // incorporate developer defined bias

    //
    // By applying a translation, we are forcing our cameras to be parallel
    //

    invertedAngle = atanf(virtualProjection / (2.0f * nearZ));

    proj = XMMatrixPerspectiveFovLH(fovAngleY, aspectHByW, nearZ, farZ);

    if (channel == STEREO_CHANNEL::LEFT)
    {
        if (stereoMode > STEREO_MODE::NORMAL)
        {
            XMMATRIX rots, trans;
            rots = XMMatrixRotationY(invertedAngle);
            trans = XMMatrixTranslation(-virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
        }
        else
        {
            XMMATRIX trans;
            trans = XMMatrixTranslation(-virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(trans, proj);
        }
    }
    else
    {
        if (stereoMode > STEREO_MODE::NORMAL)
        {
            XMMATRIX rots, trans;
            rots = XMMatrixRotationY(-invertedAngle);
            trans = XMMatrixTranslation(virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
        }
        else
        {
            XMMATRIX trans;
            trans = XMMatrixTranslation(virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(trans, proj);
        }
    }

    return patchedProjection;
}

void StereoCreateDefaultParameters ( _Out_ STEREO_PARAMETERS * stereoParameters )

Definition at line 17 of file StereoProjection.cpp.

{
    XMASSERT(stereoParameters != nullptr);

    // Default assumption is 1920x1200 resolution, a 22" LCD monitor, and a 2' viewing distance
    stereoParameters->viewerDistanceInches = 24.0f;
    stereoParameters->pixelResolutionWidth = 1920.0f;
    stereoParameters->pixelResolutionHeight = 1024.0f; // 480.0f; // 1200
    stereoParameters->displaySizeInches = 22.0f;

    stereoParameters->stereoSeparationFactor = 1.0f;
    stereoParameters->stereoExaggerationFactor = 1.0f;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/StereoProjection.h File Reference

  • DirectX 3D shooting game
Classes | Typedefs | Enumerations | Functions

StereoProjection.h File Reference

Go to the source code of this file.

Classes

struct | STEREO_PARAMETERS

Typedefs

typedef enum STEREO_CHANNEL | STEREO_CHANNEL
typedef enum STEREO_MODE | STEREO_MODE
typedef struct STEREO_PARAMETERS | STEREO_PARAMETERS

Enumerations

enum | STEREO_CHANNEL { LEFT = 0, RIGHT, LEFT = 0, RIGHT }
enum | STEREO_MODE { NORMAL = 0, INVERTED, NORMAL = 0, INVERTED }

Functions

DirectX::XMMATRIX | MatrixStereoProjectionFovLH (_In_opt_ const STEREO_PARAMETERS *stereoParameters, STEREO_CHANNEL channel, float fovAngleY, float aspectHByW, float nearZ, float farZ, STEREO_MODE stereoMode)
void | StereoCreateDefaultParameters (_Out_ STEREO_PARAMETERS *pStereoParameters)

Typedef Documentation

typedef enum STEREO_CHANNEL STEREO_CHANNEL
typedef enum STEREO_MODE STEREO_MODE
typedef struct STEREO_PARAMETERS STEREO_PARAMETERS

Enumeration Type Documentation

enum STEREO_CHANNEL
Enumerator:
LEFT
RIGHT
LEFT
RIGHT

Definition at line 21 of file StereoProjection.h.

{
    LEFT = 0,
    RIGHT
} STEREO_CHANNEL;

enum STEREO_MODE
Enumerator:
NORMAL
INVERTED
NORMAL
INVERTED

Definition at line 28 of file StereoProjection.h.

{
    NORMAL = 0,
    INVERTED,
} STEREO_MODE;

Function Documentation

DirectX::XMMATRIX MatrixStereoProjectionFovLH | ( | _In_opt_ const STEREO_PARAMETERS * | stereoParameters,
 |  | STEREO_CHANNEL | channel,
 |  | float | fovAngleY,
 |  | float | aspectHByW,
 |  | float | nearZ,
 |  | float | farZ,
 |  | STEREO_MODE | stereoMode
 | ) |  |

Definition at line 98 of file StereoProjection.cpp.

{
    float virtualProjection = 0.0f;
    float zNearWidth = 0.0f;
    float zNearHeight = 0.0f;
    float invertedAngle;
    XMMATRIX patchedProjection;
    XMMATRIX proj;
    STEREO_PARAMETERS defaultParameters;

    XMASSERT(channel == STEREO_CHANNEL::LEFT || channel == STEREO_CHANNEL::RIGHT);
    XMASSERT(stereoMode == STEREO_MODE::NORMAL || stereoMode == STEREO_MODE::INVERTED);
    XMASSERT(!XMScalarNearEqual(fovAngleY, 0.0f, 0.00001f * 2.0f));
    XMASSERT(!XMScalarNearEqual(aspectHByW, 0.0f, 0.00001f));
    XMASSERT(!XMScalarNearEqual(farZ, nearZ, 0.00001f));

    proj = XMMatrixIdentity();

    if (stereoParameters == nullptr)
    {
        StereoCreateDefaultParameters(&defaultParameters);
        stereoParameters = &defaultParameters;
    }

    XMASSERT(pStereoParameters->stereoSeparationFactor >= 0.0f && stereoParameters->stereoSeparationFactor <= 1.0f);
    XMASSERT(pStereoParameters->stereoExaggerationFactor >= 1.0f && stereoParameters->stereoExaggerationFactor <= 2.0f);

    _XMMatrixStereoProjectionHelper(stereoParameters, &virtualProjection, &zNearWidth, &zNearHeight, fovAngleY, aspectHByW, nearZ);

    virtualProjection *= stereoParameters->stereoSeparationFactor; // incorporate developer defined bias

    //
    // By applying a translation, we are forcing our cameras to be parallel
    //

    invertedAngle = atanf(virtualProjection / (2.0f * nearZ));

    proj = XMMatrixPerspectiveFovLH(fovAngleY, aspectHByW, nearZ, farZ);

    if (channel == STEREO_CHANNEL::LEFT)
    {
        if (stereoMode > STEREO_MODE::NORMAL)
        {
            XMMATRIX rots, trans;
            rots = XMMatrixRotationY(invertedAngle);
            trans = XMMatrixTranslation(-virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
        }
        else
        {
            XMMATRIX trans;
            trans = XMMatrixTranslation(-virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(trans, proj);
        }
    }
    else
    {
        if (stereoMode > STEREO_MODE::NORMAL)
        {
            XMMATRIX rots, trans;
            rots = XMMatrixRotationY(-invertedAngle);
            trans = XMMatrixTranslation(virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
        }
        else
        {
            XMMATRIX trans;
            trans = XMMatrixTranslation(virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(trans, proj);
        }
    }

    return patchedProjection;
}

void StereoCreateDefaultParameters ( _Out_ STEREO_PARAMETERS * pStereoParameters )

Definition at line 17 of file StereoProjection.cpp.

{
    XMASSERT(stereoParameters != nullptr);

    // Default assumption is 1920x1200 resolution, a 22" LCD monitor, and a 2' viewing distance
    stereoParameters->viewerDistanceInches = 24.0f;
    stereoParameters->pixelResolutionWidth = 1920.0f;
    stereoParameters->pixelResolutionHeight = 1024.0f; // 480.0f; // 1200
    stereoParameters->displaySizeInches = 22.0f;

    stereoParameters->stereoSeparationFactor = 1.0f;
    stereoParameters->stereoExaggerationFactor = 1.0f;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/TargetTexture.cpp File Reference

  • DirectX 3D shooting game

TargetTexture.cpp File Reference

#include "pch.h"
#include "TargetTexture.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/TargetTexture.h File Reference

  • DirectX 3D shooting game
Classes

TargetTexture.h File Reference

Go to the source code of this file.

Classes

class TargetTexture
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/WorldMesh.cpp File Reference

  • DirectX 3D shooting game

WorldMesh.cpp File Reference

#include "pch.h"
#include "WorldMesh.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/WorldMesh.h File Reference

  • DirectX 3D shooting game
Classes

WorldMesh.h File Reference

#include "MeshObject.h"

Go to the source code of this file.

Classes

class | WorldCeilingMesh
class | WorldFloorMesh
class | WorldWallsMesh
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Audio.cpp File Reference

  • DirectX marble maze game

Audio.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"
#include "Audio.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Audio.h File Reference

  • DirectX marble maze game
Classes | Enumerations

Audio.h File Reference

#include "MediaStreamer.h"
#include "BasicMath.h"
#include "MediaStreamer.h"
#include "BasicMath.h"

Go to the source code of this file.

Classes

class | Audio
class | AudioEngineCallbacks
struct | SoundEffectData
struct | StreamingVoiceContext

Enumerations

enum SoundEvent {
RollingEvent = 0, FallingEvent = 1, CollisionEvent = 2, CheckpointEvent = 3,
MenuChangeEvent = 4, MenuSelectedEvent = 5, LastSoundEvent
}

Enumeration Type Documentation

enum SoundEvent
Enumerator:
RollingEvent
FallingEvent
CollisionEvent
CheckpointEvent
MenuChangeEvent
MenuSelectedEvent
LastSoundEvent

Definition at line 16 of file Audio.h.

{
    RollingEvent        = 0,
    FallingEvent        = 1,
    CollisionEvent      = 2,
    CheckpointEvent     = 3,
    MenuChangeEvent     = 4,
    MenuSelectedEvent   = 5,
    LastSoundEvent,
};

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicLoader.cpp File Reference

  • DirectX marble maze game

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicLoader.h File Reference

  • DirectX marble maze game
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicMath.h File Reference

  • DirectX marble maze game
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicReaderWriter.cpp File Reference

  • DirectX marble maze game

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicReaderWriter.h File Reference

  • DirectX marble maze game
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicShapes.cpp File Reference

  • DirectX marble maze game

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicShapes.h File Reference

  • DirectX marble maze game
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicTimer.cpp File Reference

  • DirectX marble maze game

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicTimer.h File Reference

  • DirectX marble maze game
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Camera.cpp File Reference

  • DirectX marble maze game

Camera.cpp File Reference

#include "pch.h"
#include "Camera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Camera.h File Reference

  • DirectX marble maze game
Classes

Camera.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class Camera
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Collision.cpp File Reference

  • DirectX marble maze game

Collision.cpp File Reference

#include "pch.h"
#include "Primitives.h"
#include "Collision.h"
#include "Physics.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Collision.h File Reference

  • DirectX marble maze game
Classes | Enumerations

Collision.h File Reference

Go to the source code of this file.

Classes

class | Collision
struct | Contact

Enumerations

enum | MeshID { Wall, Ground, Floor }

Enumeration Type Documentation

enum MeshID
Enumerator:
Wall
Ground
Floor

Definition at line 11 of file Collision.h.

{
    Wall,
    Ground,
    Floor,
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/DDSTextureLoader.cpp File Reference

  • DirectX marble maze game
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/DDSTextureLoader.h File Reference

  • DirectX marble maze game
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/DirectXApp.cpp File Reference

  • DirectX marble maze game
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 286 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/DirectXApp.h File Reference

  • DirectX marble maze game
Classes

DirectXApp.h File Reference

#include "MarbleMaze.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/DirectXBase.cpp File Reference

  • DirectX marble maze game

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/DirectXBase.h File Reference

  • DirectX marble maze game
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/DirectXSample.h File Reference

  • DirectX marble maze game
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/LoadScreen.cpp File Reference

  • DirectX marble maze game

LoadScreen.cpp File Reference

#include "pch.h"
#include "LoadScreen.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/LoadScreen.h File Reference

  • DirectX marble maze game
Classes

LoadScreen.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class LoadScreen
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/MarbleMaze.cpp File Reference

  • DirectX marble maze game
Functions

MarbleMaze.cpp File Reference

#include "pch.h"
#include "MarbleMaze.h"
#include "BasicLoader.h"
#include "BasicTimer.h"
#include "DDSTextureLoader.h"

Go to the source code of this file.

Functions

D2D1_RECT_F | ConvertRect (Windows::Foundation::Rect source)
FORCEINLINE int | FindMeshIndexByName (SDKMesh &mesh, const char *meshName)
void | InflateRect (D2D1_RECT_F &rect, float x, float y)
XMFLOAT2 | PointToTouch (Windows::Foundation::Point point, Windows::Foundation::Rect bounds)

Function Documentation

D2D1_RECT_F ConvertRect ( Windows::Foundation::Rect source ) [inline]

Definition at line 115 of file MarbleMaze.cpp.

{
    // ignore the source.X and source.Y  These are the location on the screen
    // yet we don't want to use them because all coordinates are window relative.
    return D2D1::RectF(0.0f, 0.0f, source.Width, source.Height);
}

FORCEINLINE int FindMeshIndexByName | ( | SDKMesh & | mesh,
 |  | const char * | meshName
 | ) |  |

Definition at line 1358 of file MarbleMaze.cpp.

{
    UINT meshCount = mesh.GetNumMeshes();
    for (UINT i = 0; i < meshCount; ++i)
    {
        if (0 == _stricmp(mesh.GetMesh(i)->Name, meshName))
            return i;
    }

    return -1; // Not found.
}

void InflateRect | ( | D2D1_RECT_F & | rect,
 |  | float | x,
 |  | float | y |
 | ) |  |  | [inline]

Definition at line 122 of file MarbleMaze.cpp.

{
    rect.left -= x;
    rect.right += x;
    rect.top -= y;
    rect.bottom += y;
}

XMFLOAT2 PointToTouch | ( | Windows::Foundation::Point | point,
 |  | Windows::Foundation::Rect | bounds |
 | ) |  |  | [inline]

Definition at line 1244 of file MarbleMaze.cpp.

{
    float touchRadius = min(bounds.Width, bounds.Height);
    float dx = (point.X - (bounds.Width / 2.0f)) / touchRadius;
    float dy = ((bounds.Height / 2.0f) - point.Y) / touchRadius;

    return XMFLOAT2(dx, dy);
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/MarbleMaze.h File Reference

  • DirectX marble maze game
Classes | Enumerations

MarbleMaze.h File Reference

#include "DirectXBase.h"
#include "BasicMath.h"
#include "Camera.h"
#include "SampleOverlay.h"
#include "Primitives.h"
#include "Collision.h"
#include "Physics.h"
#include "SDKMesh.h"
#include "UserInterface.h"
#include "Audio.h"
#include "PersistentState.h"
#include "LoadScreen.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "PersistentState.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | MarbleMaze

Enumerations

enum | CheckpointState { None, Save, Goal }
enum GameState {
Waiting, Active, LevelComplete, TimeExpired,
GameComplete, Initial, MainMenu, HighScoreDisplay,
PreGameCountdown, InGameActive, InGamePaused, PostGameResults,
Waiting, Active, LevelComplete, TimeExpired,
GameComplete
}

Enumeration Type Documentation

enum CheckpointState
Enumerator:
None
Save
Goal

Definition at line 46 of file MarbleMaze.h.

{
    None, // No checkpoint hit.
    Save, // A save-game checkpoint was hit.
    Goal, // The end of game "goal" point was hit.
};

enum GameState
Enumerator:
Waiting
Active
LevelComplete
TimeExpired
GameComplete
Initial
MainMenu
HighScoreDisplay
PreGameCountdown
InGameActive
InGamePaused
PostGameResults
Waiting
Active
LevelComplete
TimeExpired
GameComplete

Definition at line 35 of file MarbleMaze.h.

{
    Initial,
    MainMenu,
    HighScoreDisplay,
    PreGameCountdown,
    InGameActive,
    InGamePaused,
    PostGameResults,
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/MediaStreamer.cpp File Reference

  • DirectX marble maze game

MediaStreamer.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"
#include "MediaStreamer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/MediaStreamer.h File Reference

  • DirectX marble maze game
Classes

MediaStreamer.h File Reference

Go to the source code of this file.

Classes

class MediaStreamer
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/pch.cpp File Reference

  • DirectX marble maze game

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/pch.h File Reference

  • DirectX marble maze game
Defines

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <ppltasks.h>
#include <agile.h>
#include <DirectXMath.h>
#include <xaudio2.h>
#include <xaudio2fx.h>
#include <mmreg.h>
#include <mfidl.h>
#include <mfapi.h>
#include <mfreadwrite.h>
#include <mfmediaengine.h>
#include <XInput.h>
#include <stdio.h>
#include <strsafe.h>
#include <vector>
#include <memory>
#include <map>
#include <queue>
#include <string>
#include <set>

Go to the source code of this file.

Defines

#define | XAUDIO2_HELPER_FUNCTIONS 1
#define | XM_STRICT_VECTOR4 1

Define Documentation

#define XAUDIO2_HELPER_FUNCTIONS 1

Definition at line 22 of file pch.h.

#define XM_STRICT_VECTOR4 1

Definition at line 19 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/PersistentState.cpp File Reference

  • DirectX marble maze game

PersistentState.cpp File Reference

#include "pch.h"
#include "PersistentState.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/PersistentState.h File Reference

  • DirectX marble maze game
Classes

PersistentState.h File Reference

Go to the source code of this file.

Classes

class PersistentState
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Physics.cpp File Reference

  • DirectX marble maze game

Physics.cpp File Reference

#include "pch.h"
#include "Primitives.h"
#include "Collision.h"
#include "Physics.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Physics.h File Reference

  • DirectX marble maze game
Classes | Functions | Variables

Physics.h File Reference

Go to the source code of this file.

Classes

struct | CollisionInfo
class | Physics

Functions

BOOL | IntersectRayTriangle (FXMVECTOR origin, FXMVECTOR direction, FXMVECTOR V0, CXMVECTOR V1, CXMVECTOR V2, float *dist)

Variables

const float | Damping = 1.0f
const float | Gravity = 981.0f
const float | MaxPhysicsTimestep = 1.0f / 8.0f
const float | MaxVelocity = 250.0f
const float | MinAudibleCollisionSpeed = 10.0f
const float | MinVelocity = 0.1f
const float | PhysicsTimestep = 1.0f / 60.0f
const float | WallFriction = 0.05f
const float | WallRestitutionCoefficient = 0.5f

Function Documentation

BOOL IntersectRayTriangle | ( | FXMVECTOR | origin,
 |  | FXMVECTOR | direction,
 |  | FXMVECTOR | V0,
 |  | CXMVECTOR | V1,
 |  | CXMVECTOR | V2,
 |  | float * | dist |
 | ) |  |  | [inline]

Definition at line 183 of file Physics.h.

{

    static const XMVECTOR epsilon = XMVectorSet(1e-20f, 1e-20f, 1e-20f, 1e-20f);

    XMVECTOR zero = XMVectorZero();

    XMVECTOR e1 = V1 - V0;
    XMVECTOR e2 = V2 - V0;

    // p = direction ^ e2;
    XMVECTOR p = XMVector3Cross(direction, e2);

    // det = e1 * p;
    XMVECTOR det = XMVector3Dot(e1, p);

    XMVECTOR u, v, t;

    if (XMVector3GreaterOrEqual(det, epsilon))
    {
        // Determinate is positive (front side of the triangle).
        XMVECTOR s = origin - V0;

        // u = s * p;
        u = XMVector3Dot(s, p);

        XMVECTOR noIntersection = XMVectorLess(u, zero);
        noIntersection = XMVectorOrInt(noIntersection, XMVectorGreater(u, det));

        // q = s ^ e1;
        XMVECTOR q = XMVector3Cross(s, e1);

        // v = direction * q;
        v = XMVector3Dot(direction, q);

        noIntersection = XMVectorOrInt(noIntersection, XMVectorLess(v, zero));
        noIntersection = XMVectorOrInt(noIntersection, XMVectorGreater(u + v, det));

        // t = e2 * q;
        t = XMVector3Dot(e2, q);

        noIntersection = XMVectorOrInt(noIntersection, XMVectorLess(t, zero));

        if (XMVector4EqualInt(noIntersection, XMVectorTrueInt()))
        {
            return FALSE;
        }
    }
    else if (XMVector3LessOrEqual(det, -epsilon))
    {
        // Determinate is negative (back side of the triangle).
        XMVECTOR s = origin - V0;

        // u = s * p;
        u = XMVector3Dot(s, p);

        XMVECTOR noIntersection = XMVectorGreater(u, zero);
        noIntersection = XMVectorOrInt(noIntersection, XMVectorLess(u, det));

        // q = s ^ e1;
        XMVECTOR q = XMVector3Cross(s, e1);

        // v = direction * q;
        v = XMVector3Dot(direction, q);

        noIntersection = XMVectorOrInt(noIntersection, XMVectorGreater(v, zero));
        noIntersection = XMVectorOrInt(noIntersection, XMVectorLess(u + v, det));

        // t = e2 * q;
        t = XMVector3Dot(e2, q);

        noIntersection = XMVectorOrInt(noIntersection, XMVectorGreater(t, zero));

        if (XMVector4EqualInt(noIntersection, XMVectorTrueInt()))
        {
            return FALSE;
        }
    }
    else
    {
        // Parallel ray.
        return FALSE;
    }

    XMVECTOR inv_det = XMVectorReciprocal(det);

    t *= inv_det;

    // u * inv_det and v * inv_det are the barycentric cooridinates of the intersection.

    // Store the x-component to dist
    XMStoreFloat(dist, t);

    return TRUE;
};

Variable Documentation

const float Damping = 1.0f

Definition at line 18 of file Physics.h.

const float Gravity = 981.0f

Definition at line 12 of file Physics.h.

const float MaxPhysicsTimestep = 1.0f / 8.0f

Definition at line 19 of file Physics.h.

const float MaxVelocity = 250.0f

Definition at line 14 of file Physics.h.

const float MinAudibleCollisionSpeed = 10.0f

Definition at line 16 of file Physics.h.

const float MinVelocity = 0.1f

Definition at line 15 of file Physics.h.

const float PhysicsTimestep = 1.0f / 60.0f

Definition at line 20 of file Physics.h.

const float WallFriction = 0.05f

Definition at line 13 of file Physics.h.

const float WallRestitutionCoefficient = 0.5f

Definition at line 17 of file Physics.h.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Primitives.h File Reference

  • DirectX marble maze game
Classes

Primitives.h File Reference

Go to the source code of this file.

Classes

class | Sphere
class | Triangle
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/SampleOverlay.cpp File Reference

  • DirectX marble maze game

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/SampleOverlay.h File Reference

  • DirectX marble maze game
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/SDKMesh.cpp File Reference

  • DirectX marble maze game
Defines

SDKMesh.cpp File Reference

#include "pch.h"
#include "DDSTextureLoader.h"
#include "SDKMesh.h"
#include "BasicLoader.h"

Go to the source code of this file.

Defines

#define MAX_D3D11_VERTEX_STREAMS D3D11_IA_VERTEX_INPUT_RESOURCE_SLOT_COUNT

Define Documentation

#define MAX_D3D11_VERTEX_STREAMS D3D11_IA_VERTEX_INPUT_RESOURCE_SLOT_COUNT

Definition at line 495 of file SDKMesh.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/SDKMesh.h File Reference

  • DirectX marble maze game
Classes | Defines | Typedefs | Enumerations | Functions

SDKMesh.h File Reference

Go to the source code of this file.

Classes

struct | _SDKMESHVERTEXELEMENT
struct | SDKANIMATION_DATA
struct | SDKANIMATION_FILE_HEADER
struct | SDKANIMATION_FRAME_DATA
class | SDKMesh
struct | SDKMESH_FRAME
struct | SDKMESH_HEADER
struct | SDKMESH_INDEX_BUFFER_HEADER
struct | SDKMESH_MATERIAL
struct | SDKMESH_MESH
struct | SDKMESH_SUBSET
struct | SDKMESH_VERTEX_BUFFER_HEADER

Defines

#define | ERROR_RESOURCE_VALUE 1
#define | INVALID_ANIMATION_DATA ((uint32)-1)
#define | INVALID_FRAME ((uint32)-1)
#define | INVALID_MATERIAL ((uint32)-1)
#define | INVALID_MESH ((uint32)-1)
#define | INVALID_SAMPLER_SLOT ((uint32)-1)
#define | INVALID_SUBSET ((uint32)-1)
#define | MAX_FRAME_NAME 100
#define | MAX_MATERIAL_NAME 100
#define | MAX_MATERIAL_PATH MAX_PATH
#define | MAX_MESH_NAME 100
#define | MAX_SUBSET_NAME 100
#define | MAX_TEXTURE_NAME MAX_PATH
#define | MAX_VERTEX_ELEMENTS 32
#define | MAX_VERTEX_STREAMS 16
#define | SAFE_DELETE(p) { if (p) { delete (p); (p) = nullptr; } }
#define | SAFE_DELETE_ARRAY(p) { if (p) { delete[] (p); (p) = nullptr; } }
#define | SAFE_RELEASE(p) { if (p) { (p)->Release(); (p) = nullptr; } }
#define | SDKMESH_FILE_VERSION 101

Typedefs

typedef struct
_SDKMESHVERTEXELEMENT * 		LPSDKMESHVERTEXELEMENT
typedef struct
_SDKMESHVERTEXELEMENT 		SDKMESHVERTEXELEMENT

Enumerations

enum | FrameTransformType { Relative = 0, Absolute }
enum | SDKMeshIndexType { Bits16 = 0, Bits32 }
enum SDKMeshPrimitiveType {
TriangleList = 0, TriangleStrip, LineList, LineStrip,
PointList, TriangleListAdjacent, TriangleStripAdjacent, LineListAdjacent,
LineStripAdjacent, QuadPatchList, TrianglePatchList
}

Functions

template<typename TYPE >
BOOL | IsErrorResource (TYPE data)

Define Documentation

#define ERROR_RESOURCE_VALUE 1

Definition at line 35 of file SDKMesh.h.

#define INVALID_ANIMATION_DATA ((uint32)-1)

Definition at line 33 of file SDKMesh.h.

#define INVALID_FRAME ((uint32)-1)

Definition at line 29 of file SDKMesh.h.

#define INVALID_MATERIAL ((uint32)-1)

Definition at line 31 of file SDKMesh.h.

#define INVALID_MESH ((uint32)-1)

Definition at line 30 of file SDKMesh.h.

#define INVALID_SAMPLER_SLOT ((uint32)-1)

Definition at line 34 of file SDKMesh.h.

#define INVALID_SUBSET ((uint32)-1)

Definition at line 32 of file SDKMesh.h.

#define MAX_FRAME_NAME 100

Definition at line 23 of file SDKMesh.h.

#define MAX_MATERIAL_NAME 100

Definition at line 26 of file SDKMesh.h.

#define MAX_MATERIAL_PATH MAX_PATH

Definition at line 28 of file SDKMesh.h.

#define MAX_MESH_NAME 100

Definition at line 24 of file SDKMesh.h.

#define MAX_SUBSET_NAME 100

Definition at line 25 of file SDKMesh.h.

#define MAX_TEXTURE_NAME MAX_PATH

Definition at line 27 of file SDKMesh.h.

#define MAX_VERTEX_ELEMENTS 32

Definition at line 21 of file SDKMesh.h.

#define MAX_VERTEX_STREAMS 16

Definition at line 22 of file SDKMesh.h.

#define SAFE_DELETE ( p ) { if (p) { delete (p); (p) = nullptr; } }

Definition at line 47 of file SDKMesh.h.

#define SAFE_DELETE_ARRAY ( p ) { if (p) { delete[] (p); (p) = nullptr; } }

Definition at line 50 of file SDKMesh.h.

#define SAFE_RELEASE ( p ) { if (p) { (p)->Release(); (p) = nullptr; } }

Definition at line 53 of file SDKMesh.h.

#define SDKMESH_FILE_VERSION 101

Definition at line 20 of file SDKMesh.h.

Typedef Documentation

typedef struct _SDKMESHVERTEXELEMENT * LPSDKMESHVERTEXELEMENT
typedef struct _SDKMESHVERTEXELEMENT SDKMESHVERTEXELEMENT

Enumeration Type Documentation

enum FrameTransformType
Enumerator:
Relative
Absolute

Definition at line 80 of file SDKMesh.h.

{
    Relative = 0,
    Absolute,        // This is not currently used but is here to support absolute transformations in the future
};

enum SDKMeshIndexType
Enumerator:
Bits16
Bits32

Definition at line 74 of file SDKMesh.h.

{
    Bits16 = 0,
    Bits32,
};

enum SDKMeshPrimitiveType
Enumerator:
TriangleList
TriangleStrip
LineList
LineStrip
PointList
TriangleListAdjacent
TriangleStripAdjacent
LineListAdjacent
LineStripAdjacent
QuadPatchList
TrianglePatchList

Definition at line 59 of file SDKMesh.h.

{
    TriangleList = 0,
    TriangleStrip,
    LineList,
    LineStrip,
    PointList,
    TriangleListAdjacent,
    TriangleStripAdjacent,
    LineListAdjacent,
    LineStripAdjacent,
    QuadPatchList,
    TrianglePatchList,
};

Function Documentation

template<typename TYPE >
BOOL IsErrorResource ( TYPE data )

Definition at line 37 of file SDKMesh.h.

{
    if ((TYPE)ERROR_RESOURCE_VALUE == data) {
        return TRUE;
    }

    return FALSE;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/UserInterface.cpp File Reference

  • DirectX marble maze game
Functions

UserInterface.cpp File Reference

#include "pch.h"
#include "UserInterface.h"
#include "DirectXSample.h"

Go to the source code of this file.

Functions

bool PointInRect (D2D1_POINT_2F point, D2D1_RECT_F rect)

Function Documentation

bool PointInRect | ( | D2D1_POINT_2F | point,
 |  | D2D1_RECT_F | rect |
 | ) |  |  | [inline]

Definition at line 681 of file UserInterface.cpp.

{
    if ((point.x < rect.left) ||
        (point.x > rect.right) ||
        (point.y < rect.top) ||
        (point.y > rect.bottom))
    {
        return false;
    }

    return true;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/UserInterface.h File Reference

  • DirectX marble maze game
Classes | Defines | Typedefs | Enumerations

UserInterface.h File Reference

Go to the source code of this file.

Classes

struct | Alignment
class | CountdownTimer
class | ElementBase
struct | HighScoreEntry
class | HighScoreTable
class | StopwatchTimer
class | TextButton
class | TextElement
class | TextStyle
class | UserInterface

Defines

#define | MAX_HIGH_SCORES 5

Typedefs

typedef std::set< ElementBase * > | ElementSet
typedef std::vector
< HighScoreEntry > 		HighScoreEntries

Enumerations

enum | AlignType { AlignNear, AlignCenter, AlignFar }

Define Documentation

#define MAX_HIGH_SCORES 5

Definition at line 194 of file UserInterface.h.

Typedef Documentation

typedef std::set<ElementBase*> ElementSet

Definition at line 74 of file UserInterface.h.

typedef std::vector<HighScoreEntry> HighScoreEntries

Definition at line 195 of file UserInterface.h.

Enumeration Type Documentation

enum AlignType
Enumerator:
AlignNear
AlignCenter
AlignFar

Definition at line 35 of file UserInterface.h.

{
    AlignNear,
    AlignCenter,
    AlignFar,
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/App.xaml.cpp File Reference

  • DirectX postcard app

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/App.xaml.h File Reference

  • DirectX postcard app
Classes | Namespaces

App.xaml.h File Reference

#include "MainPage.xaml.h"
#include "App.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | Postcard::sealed

Namespaces

namespace | Postcard
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicCamera.cpp File Reference

  • DirectX postcard app

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicCamera.h File Reference

  • DirectX postcard app
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicLoader.cpp File Reference

  • DirectX postcard app

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicLoader.h File Reference

  • DirectX postcard app
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicMath.h File Reference

  • DirectX postcard app
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicReaderWriter.cpp File Reference

  • DirectX postcard app

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicReaderWriter.h File Reference

  • DirectX postcard app
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicShapes.cpp File Reference

  • DirectX postcard app

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicShapes.h File Reference

  • DirectX postcard app
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/DDSTextureLoader.cpp File Reference

  • DirectX postcard app
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/DDSTextureLoader.h File Reference

  • DirectX postcard app
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/DirectXBase.cpp File Reference

  • DirectX postcard app

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/DirectXBase.h File Reference

  • DirectX postcard app
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/DirectXSample.h File Reference

  • DirectX postcard app
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/EffectsFlyout.xaml.cpp File Reference

  • DirectX postcard app

EffectsFlyout.xaml.cpp File Reference

#include "pch.h"
#include "EffectsFlyout.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/EffectsFlyout.xaml.h File Reference

  • DirectX postcard app
Classes | Namespaces | Functions

EffectsFlyout.xaml.h File Reference

#include "EffectsFlyout.g.h"

Go to the source code of this file.

Classes

class | Postcard::sealed

Namespaces

namespace | Postcard

Functions

public delegate void | Postcard::EffectIntensityChangedHandler (Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e)
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/ExtrudedTextRenderer.cpp File Reference

  • DirectX postcard app

ExtrudedTextRenderer.cpp File Reference

#include "pch.h"
#include "ExtrudedTextRenderer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/ExtrudedTextRenderer.h File Reference

  • DirectX postcard app
Classes

ExtrudedTextRenderer.h File Reference

#include "OutlineRenderer.h"
#include "Extruder.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | ExtrudedTextRenderer
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/Extruder.cpp File Reference

  • DirectX postcard app

Extruder.cpp File Reference

#include "pch.h"
#include "Extruder.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/Extruder.h File Reference

  • DirectX postcard app
Classes

Extruder.h File Reference

#include "PointSnapper.h"

Go to the source code of this file.

Classes

class | Extruder
class | Extruder::ExtrudingSink
struct | Extruder::ExtrudingSink::Vertex2D
struct | SimpleVertex
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/ImageRenderer.cpp File Reference

  • DirectX postcard app

ImageRenderer.cpp File Reference

#include "pch.h"
#include "ImageRenderer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/ImageRenderer.h File Reference

  • DirectX postcard app
Classes

ImageRenderer.h File Reference

Go to the source code of this file.

Classes

class ImageRenderer
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/InkRenderer.cpp File Reference

  • DirectX postcard app

InkRenderer.cpp File Reference

#include "pch.h"
#include "InkRenderer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/InkRenderer.h File Reference

  • DirectX postcard app
Classes | Enumerations

InkRenderer.h File Reference

Go to the source code of this file.

Classes

class | InkRenderer

Enumerations

enum | InkState { StrokeDrawing, StrokeCompleted }

Enumeration Type Documentation

enum InkState
Enumerator:
StrokeDrawing
StrokeCompleted

Definition at line 10 of file InkRenderer.h.

{
    StrokeDrawing,
    StrokeCompleted
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/MainPage.xaml.cpp File Reference

  • DirectX postcard app

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "EffectsFlyout.xaml.h"
#include "PaperFlyout.xaml.h"
#include "TextFlyout.xaml.h"
#include "SignatureFlyout.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/MainPage.xaml.h File Reference

  • DirectX postcard app
Classes | Namespaces

MainPage.xaml.h File Reference

#include "MainPage.g.h"
#include "PostcardRenderer.h"

Go to the source code of this file.

Classes

class | Postcard::sealed

Namespaces

namespace | Postcard
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/OutlineRenderer.cpp File Reference

  • DirectX postcard app

OutlineRenderer.cpp File Reference

#include "pch.h"
#include "OutlineRenderer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/OutlineRenderer.h File Reference

  • DirectX postcard app
Classes

OutlineRenderer.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class OutlineRenderer
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperFlyout.xaml.cpp File Reference

  • DirectX postcard app

PaperFlyout.xaml.cpp File Reference

#include "pch.h"
#include "PaperFlyout.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperFlyout.xaml.h File Reference

  • DirectX postcard app
Classes | Namespaces | Functions

PaperFlyout.xaml.h File Reference

#include "PaperFlyout.g.h"

Go to the source code of this file.

Classes

class | Postcard::sealed

Namespaces

namespace | Postcard

Functions

public delegate void | Postcard::ButtonClickedHandler (void)
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperFragment.cpp File Reference

  • DirectX postcard app

PaperFragment.cpp File Reference

#include "pch.h"
#include "PaperFragment.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperFragment.h File Reference

  • DirectX postcard app
Classes

PaperFragment.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class PaperFragment
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperRenderer.cpp File Reference

  • DirectX postcard app

PaperRenderer.cpp File Reference

#include "pch.h"
#include "PaperRenderer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperRenderer.h File Reference

  • DirectX postcard app
Classes | Enumerations

PaperRenderer.h File Reference

#include "PaperFragment.h"

Go to the source code of this file.

Classes

class | PaperRenderer

Enumerations

enum | PaperMode { Moving, Stamping, Deleting }

Enumeration Type Documentation

enum PaperMode
Enumerator:
Moving
Stamping
Deleting

Definition at line 12 of file PaperRenderer.h.

{
    Moving,
    Stamping,
    Deleting
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/pch.cpp File Reference

  • DirectX postcard app

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/pch.h File Reference

  • DirectX postcard app
Defines

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <math.h>
#include <DirectXMath.h>
#include <ppltasks.h>
#include <shcore.h>
#include <collection.h>
#include <assert.h>
#include <agile.h>
#include <list>
#include <vector>
#include "BasicMath.h"
#include "BasicCamera.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "BasicReaderWriter.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include "windows.ui.xaml.media.dxinterop.h"
#include "BasicMath.h"
#include "BasicCamera.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Defines

#define Assert(b)

Define Documentation

#define Assert ( b )

Definition at line 14 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PointSnapper.cpp File Reference

  • DirectX postcard app

PointSnapper.cpp File Reference

#include "pch.h"
#include "PointSnapper.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PointSnapper.h File Reference

  • DirectX postcard app
Classes

PointSnapper.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | PointSnapper
class | PointSnapper::PointSnappingSink
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PostcardRenderer.cpp File Reference

  • DirectX postcard app

PostcardRenderer.cpp File Reference

#include "pch.h"
#include "PostcardRenderer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PostcardRenderer.h File Reference

  • DirectX postcard app
Classes | Enumerations

PostcardRenderer.h File Reference

#include "pch.h"
#include "DirectXBase.h"
#include "ImageRenderer.h"
#include "PaperRenderer.h"
#include "ExtrudedTextRenderer.h"
#include "InkRenderer.h"
#include "DirectXBase.h"

Go to the source code of this file.

Classes

class PostcardRenderer

Enumerations

enum SampleMode {
Ready, AddConstructionPaper, AddImage, AddEffect,
AddText, AddSignature
}

Enumeration Type Documentation

enum SampleMode
Enumerator:
Ready
AddConstructionPaper
AddImage
AddEffect
AddText
AddSignature

Definition at line 19 of file PostcardRenderer.h.

{
    Ready,
    AddConstructionPaper,
    AddImage,
    AddEffect,
    AddText,
    AddSignature
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/SignatureFlyout.xaml.cpp File Reference

  • DirectX postcard app

SignatureFlyout.xaml.cpp File Reference

#include "pch.h"
#include "SignatureFlyout.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/SignatureFlyout.xaml.h File Reference

  • DirectX postcard app
Classes | Namespaces | Functions

SignatureFlyout.xaml.h File Reference

#include "SignatureFlyout.g.h"

Go to the source code of this file.

Classes

class | Postcard::sealed

Namespaces

namespace | Postcard

Functions

public delegate void | Postcard::SignatureButtonClickedHandler (void)
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/TextFlyout.xaml.cpp File Reference

  • DirectX postcard app

TextFlyout.xaml.cpp File Reference

#include "pch.h"
#include "TextFlyout.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/TextFlyout.xaml.h File Reference

  • DirectX postcard app
Classes | Namespaces | Functions

TextFlyout.xaml.h File Reference

#include "TextFlyout.g.h"

Go to the source code of this file.

Classes

class | Postcard::sealed

Namespaces

namespace | Postcard

Functions

public delegate void | Postcard::TextSubmittedHandler (Platform::String^)
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/CoreWindowEvents.cpp File Reference

  • DirectX swap chain implementation
Functions

CoreWindowEvents.cpp File Reference

#include "pch.h"
#include "CoreWindowEvents.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 266 of file CoreWindowEvents.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/CoreWindowEvents.h File Reference

  • DirectX swap chain implementation
Classes

CoreWindowEvents.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | CoreWindowEvents
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/DirectXBase.cpp File Reference

  • DirectX swap chain implementation

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/DirectXBase.h File Reference

  • DirectX swap chain implementation
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/DirectXSample.h File Reference

  • DirectX swap chain implementation
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/pch.cpp File Reference

  • DirectX swap chain implementation

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/pch.h File Reference

  • DirectX swap chain implementation

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/SampleOverlay.cpp File Reference

  • DirectX swap chain implementation

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/SampleOverlay.h File Reference

  • DirectX swap chain implementation
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicCamera.cpp File Reference

  • DirectX touch input

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicCamera.h File Reference

  • DirectX touch input
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicLoader.cpp File Reference

  • DirectX touch input

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicLoader.h File Reference

  • DirectX touch input
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicMath.h File Reference

  • DirectX touch input
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicReaderWriter.cpp File Reference

  • DirectX touch input

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicReaderWriter.h File Reference

  • DirectX touch input
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicShapes.cpp File Reference

  • DirectX touch input

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicShapes.h File Reference

  • DirectX touch input
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicTimer.cpp File Reference

  • DirectX touch input

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicTimer.h File Reference

  • DirectX touch input
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/DDSTextureLoader.cpp File Reference

  • DirectX touch input
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/DDSTextureLoader.h File Reference

  • DirectX touch input
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/DirectXApp.cpp File Reference

  • DirectX touch input
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 159 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/DirectXApp.h File Reference

  • DirectX touch input
Classes

DirectXApp.h File Reference

#include "Simple3DTouch.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/DirectXBase.cpp File Reference

  • DirectX touch input

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/DirectXBase.h File Reference

  • DirectX touch input
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/DirectXSample.h File Reference

  • DirectX touch input
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/MoveLookController.cpp File Reference

  • DirectX touch input
Defines

MoveLookController.cpp File Reference

#include "pch.h"
#include <DirectXMath.h>
#include "MoveLookController.h"

Go to the source code of this file.

Defines

#define | DEADSPOT (16.0f)
#define | MOVEMENT_GAIN 0.07f
#define | ROTATION_GAIN 0.004f

Define Documentation

#define DEADSPOT (16.0f)

Definition at line 23 of file MoveLookController.cpp.

#define MOVEMENT_GAIN 0.07f

Definition at line 22 of file MoveLookController.cpp.

#define ROTATION_GAIN 0.004f

Definition at line 21 of file MoveLookController.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/MoveLookController.h File Reference

  • DirectX touch input
Classes | Namespaces

MoveLookController.h File Reference

#include "BasicMath.h"
#include "math.h"

Go to the source code of this file.

Classes

class | MoveLookController

Namespaces

namespace | MoveLookControllerConstants
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/pch.cpp File Reference

  • DirectX touch input

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/pch.h File Reference

  • DirectX touch input

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/SampleOverlay.cpp File Reference

  • DirectX touch input

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/SampleOverlay.h File Reference

  • DirectX touch input
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/Simple3DTouch.cpp File Reference

  • DirectX touch input

Simple3DTouch.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "BasicLoader.h"
#include "Simple3DTouch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/Simple3DTouch.h File Reference

  • DirectX touch input
Classes | Defines

Simple3DTouch.h File Reference

#include "DirectXBase.h"
#include "BasicMath.h"
#include "BasicCamera.h"
#include "MoveLookController.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "MoveLookController.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | Simple3DTouch

Defines

#define | ROOM_BOUNDS (float3(4, 3, 6))
#define | START_POSITION (float3(0, -1.5, 0))

Define Documentation

#define ROOM_BOUNDS (float3(4, 3, 6))

Definition at line 25 of file Simple3DTouch.h.

#define START_POSITION (float3(0, -1.5, 0))

Definition at line 24 of file Simple3DTouch.h.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/App.xaml.cpp File Reference

  • Display orientation

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/App.xaml.h File Reference

  • Display orientation
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Constants.cpp File Reference

  • Display orientation

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Constants.h File Reference

  • Display orientation
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/MainPage.xaml.cpp File Reference

  • Display orientation

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/MainPage.xaml.h File Reference

  • Display orientation
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/pch.cpp File Reference

  • Display orientation

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/pch.h File Reference

  • Display orientation
Defines

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include <agile.h>
#include <math.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Defines

#define _USE_MATH_DEFINES

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 22 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario1.xaml.cpp File Reference

  • Display orientation
Variables

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Variables

const double toDegrees = 180.0 / M_PI

Variable Documentation

const double toDegrees = 180.0 / M_PI

Definition at line 30 of file Scenario1.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario1.xaml.h File Reference

  • Display orientation
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DisplayOrientation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DisplayOrientation
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario2.xaml.cpp File Reference

  • Display orientation
Variables

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Variables

const double toDegrees = 180.0 / M_PI

Variable Documentation

const double toDegrees = 180.0 / M_PI

Definition at line 31 of file Scenario2.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario2.xaml.h File Reference

  • Display orientation
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DisplayOrientation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DisplayOrientation
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario3.xaml.cpp File Reference

  • Display orientation

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario3.xaml.h File Reference

  • Display orientation
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DisplayOrientation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DisplayOrientation
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/common/LayoutAwarePage.cpp File Reference

  • Display orientation
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/common/LayoutAwarePage.h File Reference

  • Display orientation
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/common/suspensionmanager.cpp File Reference

  • Display orientation
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/common/suspensionmanager.h File Reference

  • Display orientation
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicCamera.cpp File Reference

  • DXGI offer and reclaim resources

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicCamera.h File Reference

  • DXGI offer and reclaim resources
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicLoader.cpp File Reference

  • DXGI offer and reclaim resources

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicLoader.h File Reference

  • DXGI offer and reclaim resources
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicMath.h File Reference

  • DXGI offer and reclaim resources
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicReaderWriter.cpp File Reference

  • DXGI offer and reclaim resources

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicReaderWriter.h File Reference

  • DXGI offer and reclaim resources
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicShapes.cpp File Reference

  • DXGI offer and reclaim resources

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicShapes.h File Reference

  • DXGI offer and reclaim resources
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicTimer.cpp File Reference

  • DXGI offer and reclaim resources

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicTimer.h File Reference

  • DXGI offer and reclaim resources
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DDSTextureLoader.cpp File Reference

  • DXGI offer and reclaim resources
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DDSTextureLoader.h File Reference

  • DXGI offer and reclaim resources
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DirectXApp.cpp File Reference

  • DXGI offer and reclaim resources
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 155 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DirectXApp.h File Reference

  • DXGI offer and reclaim resources
Classes

DirectXApp.h File Reference

#include "OfferReclaimAPI.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DirectXBase.cpp File Reference

  • DXGI offer and reclaim resources

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DirectXBase.h File Reference

  • DXGI offer and reclaim resources
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DirectXSample.h File Reference

  • DXGI offer and reclaim resources
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/OfferReclaimAPI.cpp File Reference

  • DXGI offer and reclaim resources

OfferReclaimAPI.cpp File Reference

#include "pch.h"
#include "OfferReclaimAPI.h"
#include "BasicShapes.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/OfferReclaimAPI.h File Reference

  • DXGI offer and reclaim resources
Classes

OfferReclaimAPI.h File Reference

#include "DirectXBase.h"
#include "BasicMath.h"
#include "BasicCamera.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | OfferReclaimAPI
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/pch.cpp File Reference

  • DXGI offer and reclaim resources

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/pch.h File Reference

  • DXGI offer and reclaim resources

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/SampleOverlay.cpp File Reference

  • DXGI offer and reclaim resources

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/SampleOverlay.h File Reference

  • DXGI offer and reclaim resources
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicCamera.cpp File Reference

  • DXGI swap chain rotation

BasicCamera.cpp File Reference

#include "pch.h"
#include "BasicCamera.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicCamera.h File Reference

  • DXGI swap chain rotation
Classes

BasicCamera.h File Reference

Go to the source code of this file.

Classes

class BasicCamera
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicLoader.cpp File Reference

  • DXGI swap chain rotation

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicLoader.h File Reference

  • DXGI swap chain rotation
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicMath.h File Reference

  • DXGI swap chain rotation
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicReaderWriter.cpp File Reference

  • DXGI swap chain rotation

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicReaderWriter.h File Reference

  • DXGI swap chain rotation
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicShapes.cpp File Reference

  • DXGI swap chain rotation

BasicShapes.cpp File Reference

#include "pch.h"
#include "BasicShapes.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicShapes.h File Reference

  • DXGI swap chain rotation
Classes

BasicShapes.h File Reference

#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicTimer.cpp File Reference

  • DXGI swap chain rotation

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicTimer.h File Reference

  • DXGI swap chain rotation
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DDSTextureLoader.cpp File Reference

  • DXGI swap chain rotation
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DDSTextureLoader.h File Reference

  • DXGI swap chain rotation
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXApp.cpp File Reference

  • DXGI swap chain rotation
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 148 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXApp.h File Reference

  • DXGI swap chain rotation
Classes

DirectXApp.h File Reference

#include "DxgiRotation.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXBase.cpp File Reference

  • DXGI swap chain rotation

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXBase.h File Reference

  • DXGI swap chain rotation
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXSample.h File Reference

  • DXGI swap chain rotation
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DxgiRotation.cpp File Reference

  • DXGI swap chain rotation

DxgiRotation.cpp File Reference

#include "pch.h"
#include "DxgiRotation.h"
#include "BasicShapes.h"
#include "BasicLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DxgiRotation.h File Reference

  • DXGI swap chain rotation
Classes

DxgiRotation.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include "BasicMath.h"
#include "BasicCamera.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

struct | ConstantBuffer
class | DxgiRotation
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/pch.cpp File Reference

  • DXGI swap chain rotation

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/pch.h File Reference

  • DXGI swap chain rotation

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/SampleOverlay.cpp File Reference

  • DXGI swap chain rotation

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/SampleOverlay.h File Reference

  • DXGI swap chain rotation
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/App.xaml.cpp File Reference

  • EAS policies for mail clients

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/App.xaml.h File Reference

  • EAS policies for mail clients
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Constants.cpp File Reference

  • EAS policies for mail clients

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Constants.h File Reference

  • EAS policies for mail clients
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/MainPage.xaml.cpp File Reference

  • EAS policies for mail clients

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/MainPage.xaml.h File Reference

  • EAS policies for mail clients
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/pch.cpp File Reference

  • EAS policies for mail clients

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/pch.h File Reference

  • EAS policies for mail clients

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario1.xaml.cpp File Reference

  • EAS policies for mail clients

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario1.xaml.h File Reference

  • EAS policies for mail clients
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::EAS::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::EAS
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario2.xaml.cpp File Reference

  • EAS policies for mail clients

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario2.xaml.h File Reference

  • EAS policies for mail clients
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::EAS::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::EAS
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario3.xaml.cpp File Reference

  • EAS policies for mail clients

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario3.xaml.h File Reference

  • EAS policies for mail clients
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::EAS::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::EAS
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/common/LayoutAwarePage.cpp File Reference

  • EAS policies for mail clients
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/common/LayoutAwarePage.h File Reference

  • EAS policies for mail clients
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/common/suspensionmanager.cpp File Reference

  • EAS policies for mail clients
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/common/suspensionmanager.h File Reference

  • EAS policies for mail clients
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/App.xaml.cpp File Reference

  • Edge gesture invocation

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/App.xaml.h File Reference

  • Edge gesture invocation
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | EdgeGestureSample::sealed

Namespaces

namespace | EdgeGestureSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/CppSamplesUtils.h File Reference

  • Edge gesture invocation
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/MainPage.xaml.cpp File Reference

  • Edge gesture invocation

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/MainPage.xaml.h File Reference

  • Edge gesture invocation
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | EdgeGestureSample::sealed

Namespaces

namespace | EdgeGestureSample

Enumerations

enum | EdgeGestureSample::NotifyType { EdgeGestureSample::StatusMessage, EdgeGestureSample::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/pch.cpp File Reference

  • Edge gesture invocation

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/pch.h File Reference

  • Edge gesture invocation

pch.h File Reference

#include "CppSamplesUtils.h"
#include "CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioInput1.xaml.cpp File Reference

  • Edge gesture invocation

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioInput1.xaml.h File Reference

  • Edge gesture invocation
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | EdgeGestureSample::sealed

Namespaces

namespace | EdgeGestureSample
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioInput2.xaml.cpp File Reference

  • Edge gesture invocation

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioInput2.xaml.h File Reference

  • Edge gesture invocation
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | EdgeGestureSample::sealed

Namespaces

namespace | EdgeGestureSample
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioList.xaml.cpp File Reference

  • Edge gesture invocation

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioList.xaml.h File Reference

  • Edge gesture invocation
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | EdgeGestureSample::sealed

Namespaces

namespace | EdgeGestureSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioOutput1.xaml.cpp File Reference

  • Edge gesture invocation

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioOutput1.xaml.h File Reference

  • Edge gesture invocation
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | EdgeGestureSample::sealed

Namespaces

namespace | EdgeGestureSample
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioOutput2.xaml.cpp File Reference

  • Edge gesture invocation

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioOutput2.xaml.h File Reference

  • Edge gesture invocation
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | EdgeGestureSample::sealed

Namespaces

namespace | EdgeGestureSample
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/App.xaml.cpp File Reference

  • Extended Linguistic Services (ELS)
  • C++

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/App.xaml.h File Reference

  • Extended Linguistic Services (ELS)
  • C++
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/Constants.cpp File Reference

  • Extended Linguistic Services (ELS)
  • C++

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/Constants.h File Reference

  • Extended Linguistic Services (ELS)
  • C++
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/elsutil.h File Reference

  • Extended Linguistic Services (ELS)
  • C++
Namespaces | Functions

elsutil.h File Reference

#include <windows.h>
#include <elscore.h>
#include <elssrvc.h>
#include <string>
#include <sstream>

Go to the source code of this file.

Namespaces

namespace | SDKSample
namespace | SDKSample::ELS
namespace | SDKSample::ELS::Private

Functions

MAPPING_SERVICE_INFO * | SDKSample::ELS::Private::GetSingleELSServiceWithNoOptions (const GUID &serviceGUID)
std::wstring | SDKSample::ELS::RecognizeTextLanguages (_In_ PCWSTR text)
std::wstring | SDKSample::ELS::RecognizeTextScripts (_In_ PCWSTR text)
std::wstring | SDKSample::ELS::TransliterateFromCyrillicToLatin (_In_ PCWSTR text)
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/LanguageDetection.xaml.h File Reference

  • Extended Linguistic Services (ELS)
  • C++
Classes | Namespaces

LanguageDetection.xaml.h File Reference

#include "pch.h"
#include "LanguageDetection.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ELS::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ELS
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/MainPage.xaml.cpp File Reference

  • Extended Linguistic Services (ELS)
  • C++

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/MainPage.xaml.h File Reference

  • Extended Linguistic Services (ELS)
  • C++
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/pch.cpp File Reference

  • Extended Linguistic Services (ELS)
  • C++

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/pch.h File Reference

  • Extended Linguistic Services (ELS)
  • C++

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/ScriptDetection.xaml.cpp File Reference

  • Extended Linguistic Services (ELS)
  • C++

ScriptDetection.xaml.cpp File Reference

#include "pch.h"
#include "ScriptDetection.xaml.h"
#include "elsutil.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/ScriptDetection.xaml.h File Reference

  • Extended Linguistic Services (ELS)
  • C++
Classes | Namespaces

ScriptDetection.xaml.h File Reference

#include "pch.h"
#include "ScriptDetection.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ELS::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ELS
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/Transliteration.xaml.cpp File Reference

  • Extended Linguistic Services (ELS)
  • C++

Transliteration.xaml.cpp File Reference

#include "pch.h"
#include "Transliteration.xaml.h"
#include "elsutil.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/Transliteration.xaml.h File Reference

  • Extended Linguistic Services (ELS)
  • C++
Classes | Namespaces

Transliteration.xaml.h File Reference

#include "pch.h"
#include "Transliteration.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ELS::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ELS
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/common/LayoutAwarePage.h File Reference

  • Extended Linguistic Services (ELS)
  • C++
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/App.xaml.cpp File Reference

  • File access

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/App.xaml.h File Reference

  • File access
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Constants.cpp File Reference

  • File access

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Constants.h File Reference

  • File access
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/MainPage.xaml.cpp File Reference

  • File access

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/MainPage.xaml.h File Reference

  • File access
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/pch.cpp File Reference

  • File access

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/pch.h File Reference

  • File access

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario1.xaml.cpp File Reference

  • File access

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario1.xaml.h File Reference

  • File access
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileAccess
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario2.xaml.cpp File Reference

  • File access

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario2.xaml.h File Reference

  • File access
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileAccess
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario3.xaml.cpp File Reference

  • File access

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario3.xaml.h File Reference

  • File access
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileAccess
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario4.xaml.cpp File Reference

  • File access

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario4.xaml.h File Reference

  • File access
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileAccess
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario5.xaml.cpp File Reference

  • File access

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario5.xaml.h File Reference

  • File access
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileAccess
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario6.xaml.cpp File Reference

  • File access

Scenario6.xaml.cpp File Reference

#include "pch.h"
#include "Scenario6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario6.xaml.h File Reference

  • File access
Classes | Namespaces

Scenario6.xaml.h File Reference

#include "pch.h"
#include "Scenario6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileAccess
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario7.xaml.cpp File Reference

  • File access

Scenario7.xaml.cpp File Reference

#include "pch.h"
#include "Scenario7.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario7.xaml.h File Reference

  • File access
Classes | Namespaces

Scenario7.xaml.h File Reference

#include "pch.h"
#include "Scenario7.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileAccess
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario8.xaml.cpp File Reference

  • File access

Scenario8.xaml.cpp File Reference

#include "pch.h"
#include "Scenario8.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario8.xaml.h File Reference

  • File access
Classes | Namespaces

Scenario8.xaml.h File Reference

#include "pch.h"
#include "Scenario8.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileAccess::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileAccess
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/common/LayoutAwarePage.cpp File Reference

  • File access
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/common/LayoutAwarePage.h File Reference

  • File access
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/common/suspensionmanager.cpp File Reference

  • File access
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/common/suspensionmanager.h File Reference

  • File access
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/App.xaml.cpp File Reference

  • File and folder thumbnail

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/App.xaml.h File Reference

  • File and folder thumbnail
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Constants.cpp File Reference

  • File and folder thumbnail

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Constants.h File Reference

  • File and folder thumbnail
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Errors
class | SDKSample::FileExtensions
class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/MainPage.xaml.cpp File Reference

  • File and folder thumbnail

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/MainPage.xaml.h File Reference

  • File and folder thumbnail
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/pch.cpp File Reference

  • File and folder thumbnail

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/pch.h File Reference

  • File and folder thumbnail

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario1.xaml.cpp File Reference

  • File and folder thumbnail

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario1.xaml.h File Reference

  • File and folder thumbnail
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileThumbnails::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::FileThumbnails
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario2.xaml.cpp File Reference

  • File and folder thumbnail

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario2.xaml.h File Reference

  • File and folder thumbnail
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileThumbnails::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::FileThumbnails
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario3.xaml.cpp File Reference

  • File and folder thumbnail

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario3.xaml.h File Reference

  • File and folder thumbnail
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileThumbnails::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::FileThumbnails
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario4.xaml.cpp File Reference

  • File and folder thumbnail

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario4.xaml.h File Reference

  • File and folder thumbnail
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileThumbnails::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::FileThumbnails
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario5.xaml.cpp File Reference

  • File and folder thumbnail

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario5.xaml.h File Reference

  • File and folder thumbnail
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileThumbnails::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::FileThumbnails
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/common/LayoutAwarePage.cpp File Reference

  • File and folder thumbnail
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/common/LayoutAwarePage.h File Reference

  • File and folder thumbnail
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/common/suspensionmanager.cpp File Reference

  • File and folder thumbnail
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/common/suspensionmanager.h File Reference

  • File and folder thumbnail
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/App.xaml.cpp File Reference

  • File picker contracts

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"
#include "FileOpenPickerPage.xaml.h"
#include "FileSavePickerPage.xaml.h"
#include "CachedFileUpdaterPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/App.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/CachedFileUpdater_Local.xaml.cpp File Reference

  • File picker contracts

CachedFileUpdater_Local.xaml.cpp File Reference

#include "pch.h"
#include "CachedFileUpdaterPage.xaml.h"
#include "CachedFileUpdater_Local.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/CachedFileUpdater_Local.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

CachedFileUpdater_Local.xaml.h File Reference

#include "pch.h"
#include "CachedFileUpdater_Local.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/CachedFileUpdater_Remote.xaml.cpp File Reference

  • File picker contracts

CachedFileUpdater_Remote.xaml.cpp File Reference

#include "pch.h"
#include "CachedFileUpdaterPage.xaml.h"
#include "CachedFileUpdater_Remote.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/CachedFileUpdater_Remote.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

CachedFileUpdater_Remote.xaml.h File Reference

#include "pch.h"
#include "CachedFileUpdater_Remote.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/CachedFileUpdaterPage.xaml.cpp File Reference

  • File picker contracts

CachedFileUpdaterPage.xaml.cpp File Reference

#include "pch.h"
#include "CachedFileUpdaterPage.xaml.h"
#include "Constants.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/CachedFileUpdaterPage.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

CachedFileUpdaterPage.xaml.h File Reference

#include "pch.h"
#include "CachedFileUpdaterPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/Constants.cpp File Reference

  • File picker contracts

Constants.cpp File Reference

#include "pch.h"
#include "Constants.h"
#include "MainPage.xaml.h"
#include "FileOpenPickerPage.xaml.h"
#include "FileSavePickerPage.xaml.h"
#include "CachedFileUpdaterPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/Constants.h File Reference

  • File picker contracts
Classes | Namespaces | Enumerations

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

struct | SDKSample::Scenario
class | SDKSample::sealed
class | SDKSample::Status

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickAppFile.xaml.cpp File Reference

  • File picker contracts

FileOpenPicker_PickAppFile.xaml.cpp File Reference

#include "pch.h"
#include "FileOpenPickerPage.xaml.h"
#include "FileOpenPicker_PickAppFile.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickAppFile.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

FileOpenPicker_PickAppFile.xaml.h File Reference

#include "pch.h"
#include "FileOpenPicker_PickAppFile.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickCachedFile.xaml.cpp File Reference

  • File picker contracts

FileOpenPicker_PickCachedFile.xaml.cpp File Reference

#include "pch.h"
#include "FileOpenPickerPage.xaml.h"
#include "FileOpenPicker_PickCachedFile.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickCachedFile.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

FileOpenPicker_PickCachedFile.xaml.h File Reference

#include "pch.h"
#include "FileOpenPicker_PickCachedFile.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickURLFile.xaml.cpp File Reference

  • File picker contracts

FileOpenPicker_PickURLFile.xaml.cpp File Reference

#include "pch.h"
#include "FileOpenPickerPage.xaml.h"
#include "FileOpenPicker_PickURLFile.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickURLFile.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

FileOpenPicker_PickURLFile.xaml.h File Reference

#include "pch.h"
#include "FileOpenPicker_PickURLFile.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPickerPage.xaml.cpp File Reference

  • File picker contracts

FileOpenPickerPage.xaml.cpp File Reference

#include "pch.h"
#include "FileOpenPickerPage.xaml.h"
#include "Constants.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPickerPage.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

FileOpenPickerPage.xaml.h File Reference

#include "pch.h"
#include "FileOpenPickerPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileSavePicker_FailToSave.xaml.cpp File Reference

  • File picker contracts

FileSavePicker_FailToSave.xaml.cpp File Reference

#include "pch.h"
#include "FileSavePickerPage.xaml.h"
#include "FileSavePicker_FailToSave.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileSavePicker_FailToSave.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

FileSavePicker_FailToSave.xaml.h File Reference

#include "pch.h"
#include "FileSavePicker_FailToSave.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileSavePicker_SaveToAppStorage.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

FileSavePicker_SaveToAppStorage.xaml.h File Reference

#include "pch.h"
#include "FileSavePicker_SaveToAppStorage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileSavePicker_SaveToCachedFile.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

FileSavePicker_SaveToCachedFile.xaml.h File Reference

#include "pch.h"
#include "FileSavePicker_SaveToCachedFile.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileSavePickerPage.xaml.cpp File Reference

  • File picker contracts

FileSavePickerPage.xaml.cpp File Reference

#include "pch.h"
#include "FileSavePickerPage.xaml.h"
#include "Constants.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileSavePickerPage.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

FileSavePickerPage.xaml.h File Reference

#include "pch.h"
#include "FileSavePickerPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage.xaml.cpp File Reference

  • File picker contracts

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_CachedFile.xaml.cpp File Reference

  • File picker contracts

MainPage_CachedFile.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "MainPage_CachedFile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_CachedFile.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

MainPage_CachedFile.xaml.h File Reference

#include "pch.h"
#include "MainPage_CachedFile.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_PickFile.xaml.cpp File Reference

  • File picker contracts

MainPage_PickFile.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "MainPage_PickFile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_PickFile.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

MainPage_PickFile.xaml.h File Reference

#include "pch.h"
#include "MainPage_PickFile.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_SaveFile.xaml.cpp File Reference

  • File picker contracts

MainPage_SaveFile.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "MainPage_SaveFile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_SaveFile.xaml.h File Reference

  • File picker contracts
Classes | Namespaces

MainPage_SaveFile.xaml.h File Reference

#include "pch.h"
#include "MainPage_SaveFile.g.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePickerContracts::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePickerContracts
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/pch.cpp File Reference

  • File picker contracts

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/pch.h File Reference

  • File picker contracts

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/common/LayoutAwarePage.cpp File Reference

  • File picker contracts
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/common/LayoutAwarePage.h File Reference

  • File picker contracts
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/common/suspensionmanager.cpp File Reference

  • File picker contracts
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/common/suspensionmanager.h File Reference

  • File picker contracts
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/App.xaml.cpp File Reference

  • File picker

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/App.xaml.h File Reference

  • File picker
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Constants.cpp File Reference

  • File picker

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Constants.h File Reference

  • File picker
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/MainPage.xaml.cpp File Reference

  • File picker

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/MainPage.xaml.h File Reference

  • File picker
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/pch.cpp File Reference

  • File picker

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/pch.h File Reference

  • File picker

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario1.xaml.cpp File Reference

  • File picker

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario1.xaml.h File Reference

  • File picker
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePicker
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario2.xaml.cpp File Reference

  • File picker

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario2.xaml.h File Reference

  • File picker
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePicker
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario3.xaml.cpp File Reference

  • File picker

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario3.xaml.h File Reference

  • File picker
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePicker
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario4.xaml.cpp File Reference

  • File picker

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario4.xaml.h File Reference

  • File picker
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePicker
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario5.xaml.cpp File Reference

  • File picker

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario5.xaml.h File Reference

  • File picker
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePicker
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario6.xaml.cpp File Reference

  • File picker

Scenario6.xaml.cpp File Reference

#include "pch.h"
#include "Scenario6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario6.xaml.h File Reference

  • File picker
Classes | Namespaces

Scenario6.xaml.h File Reference

#include "pch.h"
#include "Scenario6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FilePicker::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FilePicker
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/LayoutAwarePage.cpp File Reference

  • File picker
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/LayoutAwarePage.h File Reference

  • File picker
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/suspensionmanager.cpp File Reference

  • File picker
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/suspensionmanager.h File Reference

  • File picker
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/App.xaml.cpp File Reference

  • Folder enumeration

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/App.xaml.h File Reference

  • Folder enumeration
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Constants.cpp File Reference

  • Folder enumeration

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Constants.h File Reference

  • Folder enumeration
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/MainPage.xaml.cpp File Reference

  • Folder enumeration

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/MainPage.xaml.h File Reference

  • Folder enumeration
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/pch.cpp File Reference

  • Folder enumeration

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/pch.h File Reference

  • Folder enumeration

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Scenario1.xaml.cpp File Reference

  • Folder enumeration

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Scenario1.xaml.h File Reference

  • Folder enumeration
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FolderEnumeration::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::FolderEnumeration
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Scenario2.xaml.cpp File Reference

  • Folder enumeration

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Scenario2.xaml.h File Reference

  • Folder enumeration
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FolderEnumeration::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::FolderEnumeration
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Scenario3.xaml.cpp File Reference

  • Folder enumeration

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Scenario3.xaml.h File Reference

  • Folder enumeration
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FolderEnumeration::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::FolderEnumeration
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/common/LayoutAwarePage.cpp File Reference

  • Folder enumeration
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/common/LayoutAwarePage.h File Reference

  • Folder enumeration
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/common/suspensionmanager.cpp File Reference

  • Folder enumeration
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/common/suspensionmanager.h File Reference

  • Folder enumeration
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/App.xaml.cpp File Reference

  • Geolocation

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/App.xaml.h File Reference

  • Geolocation
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Constants.cpp File Reference

  • Geolocation

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Constants.h File Reference

  • Geolocation
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/MainPage.xaml.cpp File Reference

  • Geolocation

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/MainPage.xaml.h File Reference

  • Geolocation
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/pch.cpp File Reference

  • Geolocation

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/pch.h File Reference

  • Geolocation

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario1_TrackPosition.xaml.cpp File Reference

  • Geolocation

Scenario1_TrackPosition.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1_TrackPosition.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario1_TrackPosition.xaml.h File Reference

  • Geolocation
Classes | Namespaces

Scenario1_TrackPosition.xaml.h File Reference

#include "pch.h"
#include "Scenario1_TrackPosition.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GeolocationCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GeolocationCPP
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario2_GetPosition.xaml.cpp File Reference

  • Geolocation

Scenario2_GetPosition.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2_GetPosition.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario2_GetPosition.xaml.h File Reference

  • Geolocation
Classes | Namespaces

Scenario2_GetPosition.xaml.h File Reference

#include "pch.h"
#include "Scenario2_GetPosition.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GeolocationCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GeolocationCPP
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario3_BackgroundTask.xaml.cpp File Reference

  • Geolocation

Scenario3_BackgroundTask.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3_BackgroundTask.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario3_BackgroundTask.xaml.h File Reference

  • Geolocation
Classes | Namespaces

Scenario3_BackgroundTask.xaml.h File Reference

#include "pch.h"
#include "Scenario3_BackgroundTask.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GeolocationCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GeolocationCPP
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/backgroundtask/LocationBackgroundTask.cpp File Reference

  • Geolocation
  • backgroundtask

LocationBackgroundTask.cpp File Reference

#include "pch.h"
#include "LocationBackgroundTask.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/backgroundtask/LocationBackgroundTask.h File Reference

  • Geolocation
  • backgroundtask
Classes | Namespaces

LocationBackgroundTask.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | BackgroundTask::sealed

Namespaces

namespace | BackgroundTask
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/backgroundtask/pch.cpp File Reference

  • Geolocation
  • backgroundtask

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/backgroundtask/pch.h File Reference

  • Geolocation
  • backgroundtask

pch.h File Reference

#include <ppltasks.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/common/LayoutAwarePage.cpp File Reference

  • Geolocation
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/common/LayoutAwarePage.h File Reference

  • Geolocation
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/common/SuspensionManager.cpp File Reference

  • Geolocation
  • common
Classes | Namespaces | Enumerations | Functions | Variables

SuspensionManager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{SuspensionManager.cpp}

Enumerations

enum anonymous_namespace{SuspensionManager.cpp}::StreamTypes {
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{SuspensionManager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{SuspensionManager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{SuspensionManager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{SuspensionManager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{SuspensionManager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{SuspensionManager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{SuspensionManager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{SuspensionManager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{SuspensionManager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)

Variables

std::vector< WeakFrame^> | anonymous_namespace{SuspensionManager.cpp}::_registeredFrames
Map< String^, Object^> | anonymous_namespace{SuspensionManager.cpp}::_sessionState = ref new Map<String^, Object^>()
DependencyProperty | anonymous_namespace{SuspensionManager.cpp}::FrameSessionStateKeyProperty
DependencyProperty | anonymous_namespace{SuspensionManager.cpp}::FrameSessionStateProperty
String | anonymous_namespace{SuspensionManager.cpp}::sessionStateFilename = "_sessionState.dat"
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/common/SuspensionManager.h File Reference

  • Geolocation
  • common
Classes | Namespaces

SuspensionManager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/App.xaml.cpp File Reference

  • Getting started with C++ simple blog reader

App.xaml.cpp File Reference

#include "pch.h"
#include "app.xaml.h"
#include "MainPage.xaml.h"
#include "ItemsPage.xaml.h"
#include "common/SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/App.xaml.h File Reference

  • Getting started with C++ simple blog reader
Classes | Namespaces

App.xaml.h File Reference

#include "App.g.h"
#include "FeedData.h"

Go to the source code of this file.

Classes

class | SimpleBlogReader::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SimpleBlogReader
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/DateConverter.h File Reference

  • Getting started with C++ simple blog reader
Classes | Namespaces

DateConverter.h File Reference

Go to the source code of this file.

Classes

class | SimpleBlogReader::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SimpleBlogReader
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/FeedData.cpp File Reference

  • Getting started with C++ simple blog reader

FeedData.cpp File Reference

#include "pch.h"
#include "FeedData.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/FeedData.h File Reference

  • Getting started with C++ simple blog reader
Classes | Namespaces

FeedData.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | SimpleBlogReader::sealed
Provides application-specific behavior to supplement the default Application class. More...
class | SimpleBlogReader::sealed
Provides application-specific behavior to supplement the default Application class. More...
class | SimpleBlogReader::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SimpleBlogReader
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/ItemsPage.xaml.h File Reference

  • Getting started with C++ simple blog reader
Classes | Namespaces

ItemsPage.xaml.h File Reference

#include "Common\LayoutAwarePage.h"
#include "ItemsPage.g.h"

Go to the source code of this file.

Classes

class | SimpleBlogReader::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SimpleBlogReader
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/MainPage.xaml.h File Reference

  • Getting started with C++ simple blog reader
Classes | Namespaces

MainPage.xaml.h File Reference

#include "MainPage.g.h"
#include "FeedData.h"
#include "DateConverter.h"

Go to the source code of this file.

Classes

class | SimpleBlogReader::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SimpleBlogReader
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/pch.cpp File Reference

  • Getting started with C++ simple blog reader

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/pch.h File Reference

  • Getting started with C++ simple blog reader

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include <string>
#include <map>
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/SplitPage.xaml.h File Reference

  • Getting started with C++ simple blog reader
Classes | Namespaces

SplitPage.xaml.h File Reference

#include "Common\LayoutAwarePage.h"
#include "SplitPage.g.h"

Go to the source code of this file.

Classes

class | SimpleBlogReader::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SimpleBlogReader
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/App.xaml.cpp File Reference

  • Globalization preferences

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/App.xaml.h File Reference

  • Globalization preferences
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/Constants.cpp File Reference

  • Globalization preferences

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/Constants.h File Reference

  • Globalization preferences
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/CurrentInputLanguage.xaml.cpp File Reference

  • Globalization preferences

CurrentInputLanguage.xaml.cpp File Reference

#include "pch.h"
#include "CurrentInputLanguage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/CurrentInputLanguage.xaml.h File Reference

  • Globalization preferences
Classes | Namespaces

CurrentInputLanguage.xaml.h File Reference

#include "pch.h"
#include "CurrentInputLanguage.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GlobalizationPreferencesSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GlobalizationPreferencesSample
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/GeographicRegion.xaml.cpp File Reference

  • Globalization preferences

GeographicRegion.xaml.cpp File Reference

#include "pch.h"
#include "GeographicRegion.xaml.h"
#include "Utilities.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/GeographicRegion.xaml.h File Reference

  • Globalization preferences
Classes | Namespaces

GeographicRegion.xaml.h File Reference

#include "pch.h"
#include "GeographicRegion.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GlobalizationPreferencesSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GlobalizationPreferencesSample
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/Language.xaml.cpp File Reference

  • Globalization preferences

Language.xaml.cpp File Reference

#include "pch.h"
#include "Language.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/Language.xaml.h File Reference

  • Globalization preferences
Classes | Namespaces

Language.xaml.h File Reference

#include "pch.h"
#include "Language.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GlobalizationPreferencesSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GlobalizationPreferencesSample
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/MainPage.xaml.cpp File Reference

  • Globalization preferences

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/MainPage.xaml.h File Reference

  • Globalization preferences
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/pch.cpp File Reference

  • Globalization preferences

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/pch.h File Reference

  • Globalization preferences

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/UserPreferences.xaml.cpp File Reference

  • Globalization preferences

UserPreferences.xaml.cpp File Reference

#include "pch.h"
#include "UserPreferences.xaml.h"
#include "Utilities.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/UserPreferences.xaml.h File Reference

  • Globalization preferences
Classes | Namespaces

UserPreferences.xaml.h File Reference

#include "pch.h"
#include "UserPreferences.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GlobalizationPreferencesSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GlobalizationPreferencesSample
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/Utilities.cpp File Reference

  • Globalization preferences

Utilities.cpp File Reference

#include "pch.h"
#include "Utilities.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/Utilities.h File Reference

  • Globalization preferences
Classes | Namespaces

Utilities.h File Reference

Go to the source code of this file.

Classes

class | SDKSample::GlobalizationPreferencesSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GlobalizationPreferencesSample
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/common/LayoutAwarePage.cpp File Reference

  • Globalization preferences
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/common/LayoutAwarePage.h File Reference

  • Globalization preferences
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/common/suspensionmanager.cpp File Reference

  • Globalization preferences
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/common/suspensionmanager.h File Reference

  • Globalization preferences
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/App.xaml.cpp File Reference

  • Gyrometer sensor

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/App.xaml.h File Reference

  • Gyrometer sensor
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Constants.cpp File Reference

  • Gyrometer sensor

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Constants.h File Reference

  • Gyrometer sensor
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/MainPage.xaml.cpp File Reference

  • Gyrometer sensor

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/MainPage.xaml.h File Reference

  • Gyrometer sensor
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/pch.cpp File Reference

  • Gyrometer sensor

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/pch.h File Reference

  • Gyrometer sensor

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Scenario1.xaml.cpp File Reference

  • Gyrometer sensor

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Scenario1.xaml.h File Reference

  • Gyrometer sensor
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GyrometerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GyrometerCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Scenario2.xaml.cpp File Reference

  • Gyrometer sensor

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Scenario2.xaml.h File Reference

  • Gyrometer sensor
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::GyrometerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::GyrometerCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/common/LayoutAwarePage.cpp File Reference

  • Gyrometer sensor
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/common/LayoutAwarePage.h File Reference

  • Gyrometer sensor
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/common/suspensionmanager.cpp File Reference

  • Gyrometer sensor
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/common/suspensionmanager.h File Reference

  • Gyrometer sensor
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/AmpCartoon.cpp File Reference

  • Hilo C++
  • CartoonEffect
Functions

AmpCartoon.cpp File Reference

#include "pch.h"
#include "AmpPixel.h"
#include <amp.h>
#include <amp_math.h>

Go to the source code of this file.

Functions

void | ApplyCartoonEffectAmp (AmpPixel *sourcePixels, AmpPixel *destinationPixels, unsigned int width, unsigned int height, unsigned int neighborWindow, unsigned int phases, cancellation_token token)
void | ApplyColorSimplifier (concurrency::array< AmpPixel, 2 > frames[], const unsigned int width, const unsigned int height, const unsigned int neighborWindow, const unsigned int phases, unsigned int current, unsigned int next, cancellation_token token)
void | ApplyEdgeDetection (concurrency::array< AmpPixel, 2 > *frame, concurrency::array< AmpPixel, 2 > sourceFrame, concurrency::array< AmpPixel, 2 > destFrame, unsigned int width, unsigned int height, const unsigned int phases)
void | CalculateSobel (const array_view< const AmpPixel, 2 > &src_frame, index< 2 > idx, float &dy) restrict(amp)
void | EdgeDetection (const array< AmpPixel, 2 > &src_frame, array< AmpPixel, 2 > &dst_frame, index< 2 > idx, const array_view< const AmpPixel, 2 > &org_frame) restrict(amp)
void | PopulateInitialRGBValues (concurrency::array< AmpPixel, 2 > *frame, concurrency::array< AmpPixel, 2 > sourceFrame)
void | SimplifyIndexColumns (const array_view< const AmpPixel, 2 > &src_frame, array_view< AmpPixel, 2 > dst_frame, index< 2 > idx, int shift) restrict(amp)
void | SimplifyIndexRows (const array_view< const AmpPixel, 2 > &src_frame, array_view< AmpPixel, 2 > dst_frame, index< 2 > idx, int shift) restrict(amp)

Function Documentation

void ApplyCartoonEffectAmp | ( | AmpPixel * | sourcePixels,
 |  | AmpPixel * | destinationPixels,
 |  | unsigned int | width,
 |  | unsigned int | height,
 |  | unsigned int | neighborWindow,
 |  | unsigned int | phases,
 |  | cancellation_token | token
 | ) |  |

Definition at line 230 of file AmpCartoon.cpp.

{
    concurrency::extent<2> sourceExtent(height, width);
    concurrency::array<AmpPixel, 2> sourceFrame(sourceExtent, sourcePixels);
    concurrency::array<AmpPixel, 2> destFrame(sourceExtent);
    concurrency::array<AmpPixel, 2> frames[2] =
    {
        concurrency::array<AmpPixel, 2>(sourceFrame.extent),
        concurrency::array<AmpPixel, 2>(sourceFrame.extent)
    };
    unsigned int current = 0;
    unsigned int next = 1;

    PopulateInitialRGBValues(&frames[current], sourceFrame);
    if (token.is_canceled())
    {
        return;
    }

    ApplyColorSimplifier(frames, width, height, neighborWindow, phases, current, next, token);
    ApplyEdgeDetection(&frames[current], sourceFrame, destFrame, width, height, phases);
    if (token.is_canceled())
    {
        return;
    }

    concurrency::copy(frames[current], stdext::checked_array_iterator<AmpPixel*>(destinationPixels, width * height));
}

void ApplyColorSimplifier | ( | concurrency::array< AmpPixel, 2 > | frames[],
 |  | const unsigned int | width,
 |  | const unsigned int | height,
 |  | const unsigned int | neighborWindow,
 |  | const unsigned int | phases,
 |  | unsigned int | current,
 |  | unsigned int | next,
 |  | cancellation_token | token
 | ) |  |

Definition at line 182 of file AmpCartoon.cpp.

{
    concurrency::extent<2> computeDomain(height - neighborWindow, width - neighborWindow);
    for (unsigned int i = 0; i < phases; i++)
    {
        const concurrency::array_view<const AmpPixel, 2> source(frames[current]);
        concurrency::array_view<AmpPixel, 2> destination(frames[next]);
        const unsigned int shift = neighborWindow;

        parallel_for_each(computeDomain, [=](index<2> idx) restrict(amp)
        {
            SimplifyIndexColumns(source, destination, idx, shift);
            SimplifyIndexRows(source, destination, idx, shift);
        });

        swap(current, next);
        if (token.is_canceled())
        {
            break;
        }
    }
}

void ApplyEdgeDetection | ( | concurrency::array< AmpPixel, 2 > * | frame,
 |  | concurrency::array< AmpPixel, 2 > | sourceFrame,
 |  | concurrency::array< AmpPixel, 2 > | destFrame,
 |  | unsigned int | width,
 |  | unsigned int | height,
 |  | const unsigned int | phases
 | ) |  |

Definition at line 212 of file AmpCartoon.cpp.

{
    if (phases > 0)
    {
        const concurrency::array<AmpPixel, 2> &source((*frame));
        parallel_for_each(destFrame.section(1, 1, height - 1, width - 1).extent, [=, &source, &sourceFrame, &destFrame](index<2> idx) restrict(amp)
        {
            EdgeDetection(source, destFrame, idx, sourceFrame);
        });
        (*frame) = destFrame;
    }
}

void CalculateSobel | ( | const array_view< const AmpPixel, 2 > & | src_frame,
 |  | index< 2 > | idx,
 |  | float & | dy
 | ) |  |

Definition at line 115 of file AmpCartoon.cpp.

{
    // Apply the Sobel operator to the image.  The Sobel operation is analogous
    // to a first derivative of the grayscale part of the image. Portions of
    // the image that change rapidly (edges) have higher sobel values.
    const int gx[3][3] = { { -1, 0, 1 }, { -2, 0, 2 }, { -1, 0, 1 } };
    const int gy[3][3] = { { 1, 2, 1 }, { 0, 0, 0 }, { -1, -2, -1 } };

    const int idx_x = idx[0];
    const int idx_y = idx[1];
    float gradient_x = 0, gradient_y = 0;
    for (int y = -1; y < 2; y++)
    {
        for (int x = -1; x < 2; x++)
        {
            index<2> idx_new(idx_x + x, idx_y + y);
            float src_y = src_frame[idx_new].y;

            gradient_x += gx[x + 1][y + 1] * src_y;
            gradient_y += gy[x + 1][y + 1] * src_y;
        }
    }

    // Calculate the magnitude of the gradient from the horizontal and vertical gradients
    dy = concurrency::fast_math::sqrt((gradient_x * gradient_x) + (gradient_y * gradient_y));
}

void EdgeDetection | ( | const array< AmpPixel, 2 > & | src_frame,
 |  | array< AmpPixel, 2 > & | dst_frame,
 |  | index< 2 > | idx,
 |  | const array_view< const AmpPixel, 2 > & | org_frame
 | ) |  |

Definition at line 142 of file AmpCartoon.cpp.

{
    const float alpha = 0.3f; // Weighting of original frame for edge detection
    const float beta = 0.8f;  // Weighting of source (color simplied) frame for edge detection

    const float s0 = 0.054f;  // Minimum threshold of source frame Sobel value to detect an edge
    const float s1 = 0.064f;  // Maximum threshold of source frame Sobel value to effect the darkness of the edge
    const float a0 = 0.3f;    // Minimum threshold of original frame Sobel value to detect an edge
    const float a1 = 0.7f;    // Maximum threshold of original frame Sobel value to effect the darkness of the edge

    index<2> idxc(idx[0] + 1, idx[1] + 1);  // Corrected index for border offset

    float sy = 0.0f;
    float ay = 0.0f;

    CalculateSobel(src_frame, idxc, sy);
    CalculateSobel(org_frame, idxc, ay);

    float edge_s = (1 - alpha) * sy;
    float edge_a = (1 - alpha) * ay;
    float i = (1 - beta) * concurrency::direct3d::smoothstep(s0, s1, edge_s) + beta * concurrency::direct3d::smoothstep(a0, a1, edge_a);

    AmpPixel clr = src_frame[idxc];
    clr.UpdateRGB();

    clr.r = clr.r * (1 - i);
    clr.g = clr.g * (1 - i);
    clr.b = clr.b * (1 - i);
    dst_frame[idxc] = clr;
}

void PopulateInitialRGBValues | ( | concurrency::array< AmpPixel, 2 > * | frame,
 |  | concurrency::array< AmpPixel, 2 > | sourceFrame
 | ) |  |

Definition at line 173 of file AmpCartoon.cpp.

{
    concurrency::array_view<AmpPixel, 2> currentFrameView((*frame));
    parallel_for_each(sourceFrame.extent, [=, &sourceFrame](index<2> idx) restrict(amp)
    {
        currentFrameView[idx] = sourceFrame[idx];
    });
}

void SimplifyIndexColumns | ( | const array_view< const AmpPixel, 2 > & | src_frame,
 |  | array_view< AmpPixel, 2 > | dst_frame,
 |  | index< 2 > | idx,
 |  | int | shift
 | ) |  |

Definition at line 67 of file AmpCartoon.cpp.

{
    // Simplify a portion of the image by removing features that fall below a given color contrast.
    // We do this by calculating the difference in color between neighboring pixels and applying an
    // exponential decay function then summing the results.
    // We then set the RGB values to the nomalized sums
    float sum = 0;
    float partial_sum_r = 0, partial_sum_g = 0, partial_sum_b = 0;

    // k is the exponential decay constant and is calculated from a standard deviation of 0.025
    const float standard_deviation = 0.025f;
    const float k = -0.2f / (standard_deviation * standard_deviation);

    const int idx_y = idx[1] + shift;
    const int idx_x = idx[0];
    const int x = idx_x;
    const int y_start = idx_y - shift;
    const int y_end = idx_y + shift;

    AmpPixel org_clr = src_frame(idx_x, idx_y);

    for (int y = y_start; y <= y_end; ++y)
    {
        // Don't apply filter to the requested index, only to the neighbors
        if (y != idx_y)
        {
            AmpPixel clr = src_frame(x, y);
            float distance = concurrency::fast_math::sqrt(
                concurrency::fast_math::pow(org_clr.u - clr.u, 2) +
                concurrency::fast_math::pow(org_clr.v - clr.v, 2));
            float value = concurrency::fast_math::pow(float(M_E), k * distance * distance);

            sum += value;
            partial_sum_r += clr.r * value;
            partial_sum_g += clr.g * value;
            partial_sum_b += clr.b * value;
        }
    }

    partial_sum_r = min(max(partial_sum_r / sum, 0.0F), 1.0F);
    partial_sum_g = min(max(partial_sum_g / sum, 0.0F), 1.0F);
    partial_sum_b = min(max(partial_sum_b / sum, 0.0F), 1.0F);

    AmpPixel p;
    p.SetFromRGB(partial_sum_r, partial_sum_g, partial_sum_b);
    dst_frame(idx_x, idx_y) = p;
}

void SimplifyIndexRows | ( | const array_view< const AmpPixel, 2 > & | src_frame,
 |  | array_view< AmpPixel, 2 > | dst_frame,
 |  | index< 2 > | idx,
 |  | int | shift
 | ) |  |

Definition at line 19 of file AmpCartoon.cpp.

{
    // Simplify a portion of the image by removing features that fall below a given color contrast.
    // We do this by calculating the difference in color between neighboring pixels and applying an
    // exponential decay function then summing the results.
    // We then set the RGB values to the nomalized sums
    float sum = 0;
    float partial_sum_r = 0, partial_sum_g = 0, partial_sum_b = 0;

    // k is the exponential decay constant and is calculated from a standard deviation of 0.025
    const float standard_deviation = 0.025f;
    const float k = -0.5f / (standard_deviation * standard_deviation);

    const int idx_y = idx[1];
    const int y = idx_y;
    const int idx_x = idx[0] + shift;
    const int x_start = idx_x - shift;
    const int x_end = idx_x + shift;

    AmpPixel org_clr = src_frame(idx_x, idx_y);

    for (int x = x_start; x <= x_end; ++x)
    {
        // Don't apply filter to the requested index, only to the neighbors
        if (x != idx_x )
        {
            AmpPixel clr = src_frame(x, y);
            float distance = concurrency::fast_math::sqrt(
                concurrency::fast_math::pow(org_clr.u - clr.u, 2) +
                concurrency::fast_math::pow(org_clr.v - clr.v, 2));
            float value = concurrency::fast_math::pow(float(M_E), k * distance * distance);

            sum += value;
            partial_sum_r += clr.r * value;
            partial_sum_g += clr.g * value;
            partial_sum_b += clr.b * value;
        }
    }

    partial_sum_r = min(max(partial_sum_r / sum, 0.0F), 1.0F);
    partial_sum_g = min(max(partial_sum_g / sum, 0.0F), 1.0F);
    partial_sum_b = min(max(partial_sum_b / sum, 0.0F), 1.0F);

    AmpPixel p;
    p.SetFromRGB(partial_sum_r, partial_sum_g, partial_sum_b);
    dst_frame(idx_x, idx_y) = p;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/AmpCartoon.h File Reference

  • Hilo C++
  • CartoonEffect
Functions

AmpCartoon.h File Reference

Go to the source code of this file.

Functions

void ApplyCartoonEffectAmp (AmpPixel *sourcePixels, AmpPixel *destinationPixels, unsigned int width, unsigned int height, unsigned int neighborWindow, unsigned int phases, concurrency::cancellation_token token)

Function Documentation

void ApplyCartoonEffectAmp | ( | AmpPixel * | sourcePixels,
 |  | AmpPixel * | destinationPixels,
 |  | unsigned int | width,
 |  | unsigned int | height,
 |  | unsigned int | neighborWindow,
 |  | unsigned int | phases,
 |  | concurrency::cancellation_token | token
 | ) |  |
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/AmpPixel.h File Reference

  • Hilo C++
  • CartoonEffect
Classes | Defines

AmpPixel.h File Reference

Go to the source code of this file.

Classes

struct | AmpPixel

Defines

#define | C_UMAX 0.436F
#define | C_VMAX 0.615F
#define | C_WB 0.114F
#define | C_WG (1.0F - C_WR - C_WB)
#define | C_WR 0.229F

Define Documentation

#define C_UMAX 0.436F

Definition at line 12 of file AmpPixel.h.

#define C_VMAX 0.615F

Definition at line 13 of file AmpPixel.h.

#define C_WB 0.114F

Definition at line 10 of file AmpPixel.h.

#define C_WG (1.0F - C_WR - C_WB)

Definition at line 11 of file AmpPixel.h.

#define C_WR 0.229F

Definition at line 9 of file AmpPixel.h.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/FrameData.h File Reference

  • Hilo C++
  • CartoonEffect
Classes

FrameData.h File Reference

Go to the source code of this file.

Classes

struct FrameData
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/FrameProcessing.cpp File Reference

  • Hilo C++
  • CartoonEffect

FrameProcessing.cpp File Reference

#include "pch.h"
#include <ppltasks.h>
#include "FrameProcessing.h"
#include "FrameData.h"
#include "Utils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/FrameProcessing.h File Reference

  • Hilo C++
  • CartoonEffect
Classes

FrameProcessing.h File Reference

Go to the source code of this file.

Classes

class FrameProcessing
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/pch.cpp File Reference

  • Hilo C++
  • CartoonEffect

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/pch.h File Reference

  • Hilo C++
  • CartoonEffect
Defines

pch.h File Reference

#include "targetver.h"
#include <windows.h>
#include <math.h>

Go to the source code of this file.

Defines

#define | _USE_MATH_DEFINES
#define | WIN32_LEAN_AND_MEAN

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 14 of file pch.h.

#define WIN32_LEAN_AND_MEAN

Definition at line 11 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/PPLCartoon.cpp File Reference

  • Hilo C++
  • CartoonEffect
Functions

PPLCartoon.cpp File Reference

#include "pch.h"
#include <ppltasks.h>
#include "FrameData.h"
#include "FrameProcessing.h"

Go to the source code of this file.

Functions

void | ApplyCartoonEffectPPL (byte *sourcePixels, unsigned int width, unsigned int height, unsigned int neighborWindow, unsigned int phases, unsigned int size, cancellation_token token)
void | InitializeFrameData (FrameData &frameData, FrameProcessing &frameProcessing, byte *sourcePixels, unsigned int width, unsigned int height, unsigned int neighborWindow, unsigned int phases, unsigned int size, cancellation_token token)

Function Documentation

void ApplyCartoonEffectPPL | ( | byte * | sourcePixels,
 |  | unsigned int | width,
 |  | unsigned int | height,
 |  | unsigned int | neighborWindow,
 |  | unsigned int | phases,
 |  | unsigned int | size,
 |  | cancellation_token | token
 | ) |  |

Definition at line 49 of file PPLCartoon.cpp.

{
    FrameData frameData;
    FrameProcessing frameProcessing;
    InitializeFrameData(frameData, frameProcessing, sourcePixels, width, height, neighborWindow, phases, size, token);

    frameData.m_pFrameProcessor->ApplyFilters(frameData.m_phaseCount);
}

void InitializeFrameData | ( | FrameData & | frameData,
 |  | FrameProcessing & | frameProcessing,
 |  | byte * | sourcePixels,
 |  | unsigned int | width,
 |  | unsigned int | height,
 |  | unsigned int | neighborWindow,
 |  | unsigned int | phases,
 |  | unsigned int | size,
 |  | cancellation_token | token
 | ) |  |

Definition at line 14 of file PPLCartoon.cpp.

{
    frameData.m_BBP = 32;
    frameData.m_colorPlanes = 1;
    frameData.m_endHeight = height;
    frameData.m_endWidth = width;
    frameData.m_neighbourArea = neighborWindow;
    frameData.m_pFrame = sourcePixels;
    frameData.m_pFrameProcessor = nullptr;
    frameData.m_phaseCount = phases;
    frameData.m_pitch = 4 * width;
    frameData.m_size = size;
    frameData.m_startHeight = 0;
    frameData.m_startWidth = 0;

    frameData.m_pFrameProcessor = &frameProcessing;
    frameData.m_pFrameProcessor->SetNeighbourArea(frameData.m_neighbourArea);
    frameData.m_pFrameProcessor->SetCurrentFrame(frameData.m_pFrame,
        frameData.m_size,
        frameData.m_endWidth,
        frameData.m_endHeight,
        frameData.m_pitch,
        frameData.m_BBP,
        frameData.m_colorPlanes);
    frameData.m_pFrameProcessor->SetCancellationToken(token);
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/PPLCartoon.h File Reference

  • Hilo C++
  • CartoonEffect
Functions

PPLCartoon.h File Reference

Go to the source code of this file.

Functions

void ApplyCartoonEffectPPL (byte *sourcePixels, unsigned int width, unsigned int height, unsigned int neighborWindow, unsigned int phases, unsigned int size, concurrency::cancellation_token token)

Function Documentation

void ApplyCartoonEffectPPL | ( | byte * | sourcePixels,
 |  | unsigned int | width,
 |  | unsigned int | height,
 |  | unsigned int | neighborWindow,
 |  | unsigned int | phases,
 |  | unsigned int | size,
 |  | concurrency::cancellation_token | token
 | ) |  |
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/targetver.h File Reference

  • Hilo C++
  • CartoonEffect

targetver.h File Reference

#include <SDKDDKVer.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/Utils.h File Reference

  • Hilo C++
  • CartoonEffect
Classes

Utils.h File Reference

Go to the source code of this file.

Classes

class Utils
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/App.xaml.cpp File Reference

  • Hilo C++
  • Hilo

App.xaml.cpp File Reference

#include "pch.h"
#include "Common\SuspensionManager.h"
#include "MainHubView.g.h"
#include "TileUpdateScheduler.h"
#include "ExceptionPolicyFactory.h"
#include "HiloPage.h"
#include "LocalResourceLoader.h"
#include "FileSystemRepository.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/App.xaml.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

App.xaml.h File Reference

#include "App.g.h"
#include "HiloPage.h"
#include "ViewModelLocator.h"
#include "DesignTimeData.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/BooleanToBrushConverter.cpp File Reference

  • Hilo C++
  • Hilo

BooleanToBrushConverter.cpp File Reference

#include "pch.h"
#include "BooleanToBrushConverter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/BooleanToBrushConverter.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

BooleanToBrushConverter.h File Reference

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CalendarExtensions.cpp File Reference

  • Hilo C++
  • Hilo
Variables

CalendarExtensions.cpp File Reference

#include "pch.h"
#include "CalendarExtensions.h"

Go to the source code of this file.

Variables

const int DATE_BUFFER_SIZE = 128

Variable Documentation

const int DATE_BUFFER_SIZE = 128

Definition at line 19 of file CalendarExtensions.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CalendarExtensions.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

CalendarExtensions.h File Reference

Go to the source code of this file.

Classes

class | Hilo::CalendarExtensions

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CartoonizeImageView.xaml.cpp File Reference

  • Hilo C++
  • Hilo

CartoonizeImageView.xaml.cpp File Reference

#include "pch.h"
#include "CartoonizeImageView.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CartoonizeImageView.xaml.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

CartoonizeImageView.xaml.h File Reference

#include "CartoonizeImageView.g.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CartoonizeImageViewModel.cpp File Reference

  • Hilo C++
  • Hilo
Variables

CartoonizeImageViewModel.cpp File Reference

#include "pch.h"
#include <amp.h>
#include "CartoonizeImageViewModel.h"
#include "DelegateCommand.h"
#include "IPhoto.h"
#include "TaskExceptionsExtensions.h"
#include "ImageNavigationData.h"
#include "ImageUtilities.h"
#include "Repository.h"
#include "PPLCartoon.h"
#include "AmpPixel.h"
#include "AmpCartoon.h"

Go to the source code of this file.

Variables

const unsigned int | MaxHeight = 768
const unsigned int | MaxWidth = 1024
Platform::String const | NeighborWindowKey = "neighbourWindow"
Platform::String const | PhasesKey = "phases"

Variable Documentation

const unsigned int MaxHeight = 768

Definition at line 41 of file CartoonizeImageViewModel.cpp.

const unsigned int MaxWidth = 1024

Definition at line 40 of file CartoonizeImageViewModel.cpp.

Platform::String const NeighborWindowKey = "neighbourWindow"

Definition at line 37 of file CartoonizeImageViewModel.cpp.

Platform::String const PhasesKey = "phases"

Definition at line 38 of file CartoonizeImageViewModel.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CartoonizeImageViewModel.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

CartoonizeImageViewModel.h File Reference

#include "ImageBase.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CropImageView.xaml.cpp File Reference

  • Hilo C++
  • Hilo

CropImageView.xaml.cpp File Reference

#include "pch.h"
#include "CropImageView.xaml.h"
#include "CropImageViewModel.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CropImageView.xaml.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

CropImageView.xaml.h File Reference

#include "Common\BooleanToVisibilityConverter.h"
#include "CropImageView.g.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CropImageViewModel.cpp File Reference

  • Hilo C++
  • Hilo
Defines

CropImageViewModel.cpp File Reference

#include "pch.h"
#include "CropImageViewModel.h"
#include "DelegateCommand.h"
#include "TaskExceptionsExtensions.h"
#include "IPhoto.h"
#include "ImageNavigationData.h"
#include "NullPhotoGroup.h"
#include "Repository.h"
#include "ExifExtensions.h"
#include "ImageUtilities.h"

Go to the source code of this file.

Defines

#define | EXIFOrientationPropertyName "System.Photo.Orientation"
#define | MINIMUMBMPSIZE 10

Define Documentation

#define EXIFOrientationPropertyName "System.Photo.Orientation"

Definition at line 20 of file CropImageViewModel.cpp.

#define MINIMUMBMPSIZE 10

Definition at line 19 of file CropImageViewModel.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CropImageViewModel.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

CropImageViewModel.h File Reference

#include "ImageBase.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/DebugLoggingExceptionPolicy.cpp File Reference

  • Hilo C++
  • Hilo

DebugLoggingExceptionPolicy.cpp File Reference

#include "pch.h"
#include "DebugLoggingExceptionPolicy.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/DebugLoggingExceptionPolicy.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

DebugLoggingExceptionPolicy.h File Reference

#include "ExceptionPolicy.h"

Go to the source code of this file.

Classes

class | Hilo::DebugLoggingExceptionPolicy

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/DelegateCommand.cpp File Reference

  • Hilo C++
  • Hilo

DelegateCommand.cpp File Reference

#include "pch.h"
#include "DelegateCommand.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/DelegateCommand.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces | Functions

DelegateCommand.h File Reference

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo

Functions

public delegate bool | Hilo::CanExecuteDelegate (Platform::Object^parameter)
public delegate void | Hilo::ExecuteDelegate (Platform::Object^parameter)
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/DesignTimeData.cpp File Reference

  • Hilo C++
  • Hilo

DesignTimeData.cpp File Reference

#include "pch.h"
#include "DesignTimeData.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/DesignTimeData.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

DesignTimeData.h File Reference

#include "IResizable.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...
class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...
class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...
class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...
class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ExceptionPolicy.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ExceptionPolicy.h File Reference

Go to the source code of this file.

Classes

class | Hilo::ExceptionPolicy

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ExceptionPolicyFactory.cpp File Reference

  • Hilo C++
  • Hilo

ExceptionPolicyFactory.cpp File Reference

#include "pch.h"
#include "ExceptionPolicyFactory.h"
#include "DebugLoggingExceptionPolicy.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ExceptionPolicyFactory.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ExceptionPolicyFactory.h File Reference

Go to the source code of this file.

Classes

class | Hilo::ExceptionPolicyFactory

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ExifExtensions.cpp File Reference

  • Hilo C++
  • Hilo
Defines

ExifExtensions.cpp File Reference

#include "pch.h"
#include "ExifExtensions.h"
#include <math.h>
#include <algorithm>

Go to the source code of this file.

Defines

#define _USE_MATH_DEFINES

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file ExifExtensions.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ExifExtensions.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces | Enumerations

ExifExtensions.h File Reference

Go to the source code of this file.

Classes

class | Hilo::ExifExtensions

Namespaces

namespace | Hilo

Enumerations

enum | Hilo::ExifRotations { Hilo::NotRotated = 1, Hilo::RotatedDown = 3, Hilo::RotatedLeft = 6, Hilo::RotatedRight = 8 }
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/FileSizeConverter.cpp File Reference

  • Hilo C++
  • Hilo

FileSizeConverter.cpp File Reference

#include "pch.h"
#include "FileSizeConverter.h"
#include "LocalResourceLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/FileSizeConverter.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

FileSizeConverter.h File Reference

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/FileSystemRepository.cpp File Reference

  • Hilo C++
  • Hilo
Variables

FileSystemRepository.cpp File Reference

#include "pch.h"
#include "FileSystemRepository.h"
#include "CalendarExtensions.h"
#include "NullPhotoGroup.h"
#include "Photo.h"
#include "QueryChange.h"

Go to the source code of this file.

Variables

const std::array< String^, 6 > items = { ".jpg", ".jpeg", ".png", ".bmp", ".gif", ".tif" }

Variable Documentation

const std::array<String^, 6> items = { ".jpg", ".jpeg", ".png", ".bmp", ".gif", ".tif" }

Definition at line 30 of file FileSystemRepository.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/FileSystemRepository.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

FileSystemRepository.h File Reference

#include "Repository.h"

Go to the source code of this file.

Classes

class | Hilo::FileSystemRepository

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/HiloCommonDefinitions.h File Reference

  • Hilo C++
  • Hilo
Defines

HiloCommonDefinitions.h File Reference

Go to the source code of this file.

Defines

#define HILO_PHOTO_FILE_NOT_FOUND _HRESULT_TYPEDEF_(0x80070002)

Define Documentation

#define HILO_PHOTO_FILE_NOT_FOUND _HRESULT_TYPEDEF_(0x80070002)

Definition at line 9 of file HiloCommonDefinitions.h.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/HiloPage.cpp File Reference

  • Hilo C++
  • Hilo
Functions

HiloPage.cpp File Reference

#include "pch.h"
#include "HiloPage.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Functions

map< PageType, TypeName > create_map ()

Function Documentation

map<PageType, TypeName> create_map ( )

Definition at line 36 of file HiloPage.cpp.

{
    std::map<PageType, TypeName> pages;
    pages.insert(std::make_pair(PageType::Crop, cropImageViewType));
    pages.insert(std::make_pair(PageType::Rotate, rotateImageViewType));
    pages.insert(std::make_pair(PageType::Cartoonize, cartoonizeImageViewType));
    pages.insert(std::make_pair(PageType::Image, imageViewType));
    pages.insert(std::make_pair(PageType::Browse, imageBrowserType));
    pages.insert(std::make_pair(PageType::Hub, mainHubType));
    return pages;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/HiloPage.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

HiloPage.h File Reference

#include "Common\LayoutAwarePage.h"
#include "PageType.h"
#include "ViewModelBase.h"
#include "Common\LayoutAwarePage.h"

Go to the source code of this file.

Classes

class | Hilo::HiloPage

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/HubGroupType.h File Reference

  • Hilo C++
  • Hilo
Namespaces | Enumerations

HubGroupType.h File Reference

Go to the source code of this file.

Namespaces

namespace | Hilo

Enumerations

enum | Hilo::HubGroupType { Hilo::Pictures, Hilo::Favorites }
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/HubPhotoGroup.cpp File Reference

  • Hilo C++
  • Hilo
Variables

HubPhotoGroup.cpp File Reference

#include "pch.h"
#include "HubPhotoGroup.h"
#include "TaskExceptionsExtensions.h"
#include "IPhoto.h"
#include "IResizable.h"
#include "Repository.h"

Go to the source code of this file.

Variables

const ULONGLONG | EVENTSPACING = 30000ul
const unsigned int | MaxNumberOfPictures = 6

Variable Documentation

const ULONGLONG EVENTSPACING = 30000ul

Definition at line 51 of file HubPhotoGroup.cpp.

const unsigned int MaxNumberOfPictures = 6

Definition at line 21 of file HubPhotoGroup.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/HubPhotoGroup.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

HubPhotoGroup.h File Reference

#include "IPhotoGroup.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBase.cpp File Reference

  • Hilo C++
  • Hilo

ImageBase.cpp File Reference

#include "pch.h"
#include "ImageBase.h"
#include "IPhoto.h"
#include "HiloCommonDefinitions.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBase.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ImageBase.h File Reference

#include "ViewModelBase.h"

Go to the source code of this file.

Classes

class | Hilo::ImageBase

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBrowserView.xaml.cpp File Reference

  • Hilo C++
  • Hilo

ImageBrowserView.xaml.cpp File Reference

#include "pch.h"
#include "ImageBrowserViewModel.h"
#include "ImageNavigationData.h"
#include "ImageBrowserView.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBrowserView.xaml.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ImageBrowserView.xaml.h File Reference

#include "BooleanToBrushConverter.h"
#include "Common\BooleanNegationConverter.h"
#include "ImageBrowserView.g.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBrowserViewModel.cpp File Reference

  • Hilo C++
  • Hilo
Variables

ImageBrowserViewModel.cpp File Reference

#include "pch.h"
#include "ImageBrowserViewModel.h"
#include "IPhoto.h"
#include "IMonthBlock.h"
#include "IYearGroup.h"
#include "IPhotoGroup.h"
#include "PhotoCache.h"
#include "DelegateCommand.h"
#include "ImageNavigationData.h"
#include "TaskExceptionsExtensions.h"
#include "Repository.h"

Go to the source code of this file.

Variables

const ULONGLONG EVENTSPACING = 30000ul

Variable Documentation

const ULONGLONG EVENTSPACING = 30000ul

Definition at line 144 of file ImageBrowserViewModel.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBrowserViewModel.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ImageBrowserViewModel.h File Reference

#include "ViewModelBase.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageNavigationData.cpp File Reference

  • Hilo C++
  • Hilo

ImageNavigationData.cpp File Reference

#include "pch.h"
#include "ImageNavigationData.h"
#include "IPhoto.h"
#include "CalendarExtensions.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageNavigationData.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ImageNavigationData.h File Reference

Go to the source code of this file.

Classes

class | Hilo::ImageNavigationData

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageUtilities.cpp File Reference

  • Hilo C++
  • Hilo
Functions

ImageUtilities.cpp File Reference

#include "pch.h"
#include "ImageUtilities.h"
#include <robuffer.h>
#include <wrl.h>

Go to the source code of this file.

Functions

byte * | GetPointerToPixelData (IBuffer^buffer)
void | ThrowIfFailed (HRESULT hr)

Function Documentation

byte* GetPointerToPixelData ( IBuffer^ buffer )

Definition at line 26 of file ImageUtilities.cpp.

{
    // Cast to Object^, then to its underlying IInspectable interface.
    Object^ obj = buffer;
    ComPtr<IInspectable> insp(reinterpret_cast<IInspectable*>(obj));

    // Query the IBufferByteAccess interface.
    ComPtr<IBufferByteAccess> bufferByteAccess;
    ThrowIfFailed(insp.As(&bufferByteAccess));

    // Retrieve the buffer data.
    byte* pixels = nullptr;
    ThrowIfFailed(bufferByteAccess->Buffer(&pixels));
    return pixels;
}

void ThrowIfFailed ( HRESULT hr ) [inline]

Definition at line 17 of file ImageUtilities.cpp.

{
    if (FAILED(hr))
    {
        throw Exception::CreateException(hr);
    }
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageUtilities.h File Reference

  • Hilo C++
  • Hilo
Functions

ImageUtilities.h File Reference

Go to the source code of this file.

Functions

byte * GetPointerToPixelData (Windows::Storage::Streams::IBuffer^buffer)

Function Documentation

byte* GetPointerToPixelData ( Windows::Storage::Streams::IBuffer^ buffer )
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageView.xaml.cpp File Reference

  • Hilo C++
  • Hilo

ImageView.xaml.cpp File Reference

#include "pch.h"
#include "ImageView.xaml.h"
#include "ImageViewModel.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageView.xaml.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ImageView.xaml.h File Reference

#include "FileSizeConverter.h"
#include "ImageView.g.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageViewModel.cpp File Reference

  • Hilo C++
  • Hilo
Variables

ImageViewModel.cpp File Reference

#include "pch.h"
#include "ImageNavigationData.h"
#include "ImageViewModel.h"
#include "IPhoto.h"
#include "IPhotoGroup.h"
#include "DelegateCommand.h"
#include "TaskExceptionsExtensions.h"
#include "Repository.h"
#include "CalendarExtensions.h"

Go to the source code of this file.

Variables

String const | FileDateMapKey = "fileDate"
String const | FilePathMapKey = "filePath"
String const | QueryMapKey = "query"

Variable Documentation

String const FileDateMapKey = "fileDate"

Definition at line 30 of file ImageViewModel.cpp.

String const FilePathMapKey = "filePath"

Definition at line 29 of file ImageViewModel.cpp.

String const QueryMapKey = "query"

Definition at line 28 of file ImageViewModel.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageViewModel.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ImageViewModel.h File Reference

#include "ViewModelBase.h"
#include "PhotoPathComparer.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IMonthBlock.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

IMonthBlock.h File Reference

Go to the source code of this file.

Classes

interface | Hilo::IMonthBlock

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IPhoto.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

IPhoto.h File Reference

Go to the source code of this file.

Classes

interface | Hilo::IPhoto

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IPhotoGroup.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

IPhotoGroup.h File Reference

Go to the source code of this file.

Classes

interface | Hilo::IPhotoGroup

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IResizable.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

IResizable.h File Reference

Go to the source code of this file.

Classes

interface | Hilo::IResizable

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IResourceLoader.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

IResourceLoader.h File Reference

Go to the source code of this file.

Classes

interface | Hilo::IResourceLoader

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IYearGroup.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

IYearGroup.h File Reference

Go to the source code of this file.

Classes

interface | Hilo::IYearGroup

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/LocalResourceLoader.cpp File Reference

  • Hilo C++
  • Hilo

LocalResourceLoader.cpp File Reference

#include "pch.h"
#include "LocalResourceLoader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/LocalResourceLoader.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

LocalResourceLoader.h File Reference

#include "IResourceLoader.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MainHubView.xaml.cpp File Reference

  • Hilo C++
  • Hilo

MainHubView.xaml.cpp File Reference

#include "pch.h"
#include "MainHubView.xaml.h"
#include "ImageNavigationData.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MainHubView.xaml.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

MainHubView.xaml.h File Reference

#include "pch.h"
#include "VariableGridView.h"
#include "MainHubView.g.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MainHubViewModel.cpp File Reference

  • Hilo C++
  • Hilo

MainHubViewModel.cpp File Reference

#include "pch.h"
#include "MainHubViewModel.h"
#include "HubPhotoGroup.h"
#include "DelegateCommand.h"
#include "PageType.h"
#include "HubGroupType.h"
#include "ImageNavigationData.h"
#include "IPhoto.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MainHubViewModel.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

MainHubViewModel.h File Reference

#include "ViewModelBase.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MonthBlock.cpp File Reference

  • Hilo C++
  • Hilo

MonthBlock.cpp File Reference

#include "pch.h"
#include "MonthBlock.h"
#include "ExceptionPolicy.h"
#include "IYearGroup.h"
#include "IResourceLoader.h"
#include "TaskExceptionsExtensions.h"
#include "Repository.h"
#include "CalendarExtensions.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MonthBlock.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

MonthBlock.h File Reference

#include "IMonthBlock.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MonthGroup.cpp File Reference

  • Hilo C++
  • Hilo
Variables

MonthGroup.cpp File Reference

#include "pch.h"
#include "MonthGroup.h"
#include "TaskExceptionsExtensions.h"
#include "PhotoCache.h"
#include "Repository.h"
#include "IPhoto.h"
#include "ExceptionPolicy.h"
#include "CalendarExtensions.h"

Go to the source code of this file.

Variables

const unsigned int MaxNumberOfPictures = 8

Variable Documentation

const unsigned int MaxNumberOfPictures = 8

Definition at line 25 of file MonthGroup.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MonthGroup.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

MonthGroup.h File Reference

#include "IPhotoGroup.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/NullPhotoGroup.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

NullPhotoGroup.h File Reference

#include "IPhotoGroup.h"

Go to the source code of this file.

Classes

class | Hilo::NullPhotoGroup

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ObservableQuery.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ObservableQuery.h File Reference

#include "PageType.h"

Go to the source code of this file.

Classes

class | Hilo::ObservableQuery

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PageType.h File Reference

  • Hilo C++
  • Hilo
Namespaces | Enumerations

PageType.h File Reference

Go to the source code of this file.

Namespaces

namespace Hilo

Enumerations

enum Hilo::PageType {
Hilo::Hub, Hilo::Browse, Hilo::Image, Hilo::Crop,
Hilo::Rotate, Hilo::Cartoonize
}
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/pch.cpp File Reference

  • Hilo C++
  • Hilo

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/pch.h File Reference

  • Hilo C++
  • Hilo

pch.h File Reference

#include <assert.h>
#include <collection.h>
#include <ppltasks.h>
#include <sstream>
#include "TaskExtensions.h"
#include "TaskExceptionsExtensions.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Photo.cpp File Reference

  • Hilo C++
  • Hilo

Photo.cpp File Reference

#include "pch.h"
#include "Photo.h"
#include "ExceptionPolicy.h"
#include "TaskExceptionsExtensions.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Photo.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

Photo.h File Reference

#include "IResizable.h"
#include "IPhoto.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PhotoCache.cpp File Reference

  • Hilo C++
  • Hilo

PhotoCache.cpp File Reference

#include "pch.h"
#include "PhotoCache.h"
#include "IPhoto.h"
#include "CalendarExtensions.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PhotoCache.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

PhotoCache.h File Reference

Go to the source code of this file.

Classes

class | Hilo::PhotoCache

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PhotoPathComparer.cpp File Reference

  • Hilo C++
  • Hilo

PhotoPathComparer.cpp File Reference

#include "pch.h"
#include "PhotoPathComparer.h"
#include "IPhoto.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PhotoPathComparer.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

PhotoPathComparer.h File Reference

Go to the source code of this file.

Classes

struct | Hilo::PhotoPathComparer

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/QueryChange.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

QueryChange.h File Reference

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RandomPhotoSelector.cpp File Reference

  • Hilo C++
  • Hilo

RandomPhotoSelector.cpp File Reference

#include "pch.h"
#include "RandomPhotoSelector.h"
#include <numeric>
#include <time.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RandomPhotoSelector.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

RandomPhotoSelector.h File Reference

Go to the source code of this file.

Classes

class | Hilo::RandomPhotoSelector

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Repository.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

Repository.h File Reference

#include "ObservableQuery.h"

Go to the source code of this file.

Classes

class | Hilo::Repository

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RotateImageView.xaml.cpp File Reference

  • Hilo C++
  • Hilo

RotateImageView.xaml.cpp File Reference

#include "pch.h"
#include "RotateImageView.xaml.h"
#include "ImageBrowserViewModel.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RotateImageView.xaml.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

RotateImageView.xaml.h File Reference

#include "RotateImageView.g.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RotateImageViewModel.cpp File Reference

  • Hilo C++
  • Hilo
Defines | Variables

RotateImageViewModel.cpp File Reference

#include "pch.h"
#include "RotateImageViewModel.h"
#include "DelegateCommand.h"
#include "IPhoto.h"
#include "ImageNavigationData.h"
#include "TaskExceptionsExtensions.h"
#include "Repository.h"
#include "ExifExtensions.h"

Go to the source code of this file.

Defines

#define | EXIFOrientationPropertyName "System.Photo.Orientation"

Variables

Platform::String const | MarginBottomStateKey = "margin-bottom"
Platform::String const | MarginLeftStateKey = "margin-left"
Platform::String const | MarginRightStateKey = "margin-right"
Platform::String const | MarginTopStateKey = "margin-top"
Platform::String const | RotationStateKey = "rotation"

Define Documentation

#define EXIFOrientationPropertyName "System.Photo.Orientation"

Definition at line 16 of file RotateImageViewModel.cpp.

Variable Documentation

Platform::String const MarginBottomStateKey = "margin-bottom"

Definition at line 37 of file RotateImageViewModel.cpp.

Platform::String const MarginLeftStateKey = "margin-left"

Definition at line 34 of file RotateImageViewModel.cpp.

Platform::String const MarginRightStateKey = "margin-right"

Definition at line 36 of file RotateImageViewModel.cpp.

Platform::String const MarginTopStateKey = "margin-top"

Definition at line 35 of file RotateImageViewModel.cpp.

Platform::String const RotationStateKey = "rotation"

Definition at line 33 of file RotateImageViewModel.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RotateImageViewModel.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

RotateImageViewModel.h File Reference

#include "ImageBase.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/TaskExceptionsExtensions.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

TaskExceptionsExtensions.h File Reference

#include "ExceptionPolicy.h"

Go to the source code of this file.

Classes

struct | Hilo::ObserveException< T >

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/TaskExtensions.cpp File Reference

  • Hilo C++
  • Hilo
Namespaces | Functions | Variables

TaskExtensions.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Namespaces

namespace | Hilo

Functions

bool | IsBackgroundThread ()
bool | IsMainThread ()
void | RecordMainThread ()
void | Hilo::run_async_non_interactive (std::function< void()> &&action)

Variables

unsigned int | _mainThreadId = 0U

Function Documentation

bool IsBackgroundThread ( void )

Definition at line 40 of file TaskExtensions.cpp.

    {
        return (_mainThreadId == 0U || _mainThreadId != GetCurrentThreadId());
    }

bool IsMainThread ( void )

Definition at line 34 of file TaskExtensions.cpp.

    {
        return (_mainThreadId == 0U || _mainThreadId == GetCurrentThreadId());
    }

void RecordMainThread ( void )

Definition at line 46 of file TaskExtensions.cpp.

    {
        _mainThreadId = GetCurrentThreadId();
    }

Variable Documentation

unsigned int _mainThreadId = 0U

Definition at line 27 of file TaskExtensions.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/TaskExtensions.h File Reference

  • Hilo C++
  • Hilo
Namespaces | Functions

TaskExtensions.h File Reference

Go to the source code of this file.

Namespaces

namespace | Hilo

Functions

concurrency::task< void > | Hilo::create_empty_task ()
template<typename Result >
concurrency::task< Result > | Hilo::create_task_from_result (Result result)
bool | IsBackgroundThread (void)
bool | IsMainThread (void)
void | RecordMainThread (void)
void | Hilo::run_async_non_interactive (std::function< void()> &&action)

Function Documentation

bool IsBackgroundThread ( void )

Definition at line 40 of file TaskExtensions.cpp.

    {
        return (_mainThreadId == 0U || _mainThreadId != GetCurrentThreadId());
    }

bool IsMainThread ( void )

Definition at line 34 of file TaskExtensions.cpp.

    {
        return (_mainThreadId == 0U || _mainThreadId == GetCurrentThreadId());
    }

void RecordMainThread ( void )

Definition at line 46 of file TaskExtensions.cpp.

    {
        _mainThreadId = GetCurrentThreadId();
    }

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ThumbnailGenerator.cpp File Reference

  • Hilo C++
  • Hilo
Variables

ThumbnailGenerator.cpp File Reference

#include "pch.h"
#include "ThumbnailGenerator.h"
#include "ExceptionPolicy.h"

Go to the source code of this file.

Variables

const wstring | ThumbnailImagePrefix = "thumbImage_"
const unsigned int | ThumbnailSize = 270

Variable Documentation

const wstring ThumbnailImagePrefix = "thumbImage_"

Definition at line 26 of file ThumbnailGenerator.cpp.

const unsigned int ThumbnailSize = 270

Definition at line 25 of file ThumbnailGenerator.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ThumbnailGenerator.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ThumbnailGenerator.h File Reference

Go to the source code of this file.

Classes

class | Hilo::ThumbnailGenerator

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/TileUpdateScheduler.cpp File Reference

  • Hilo C++
  • Hilo
Variables

TileUpdateScheduler.cpp File Reference

#include "pch.h"
#include "TileUpdateScheduler.h"
#include "ThumbnailGenerator.h"
#include "Repository.h"
#include "RandomPhotoSelector.h"
#include "WideFiveImageTile.h"
#include "TaskExceptionsExtensions.h"
#include "ExceptionPolicyFactory.h"

Go to the source code of this file.

Variables

const unsigned int | BatchSize = 5
const unsigned int | SetSize = 3
String | ThumbnailsFolderName = "thumbnails"

Variable Documentation

const unsigned int BatchSize = 5

Definition at line 32 of file TileUpdateScheduler.cpp.

const unsigned int SetSize = 3

Definition at line 35 of file TileUpdateScheduler.cpp.

String ThumbnailsFolderName = "thumbnails"

Definition at line 28 of file TileUpdateScheduler.cpp.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/TileUpdateScheduler.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

TileUpdateScheduler.h File Reference

Go to the source code of this file.

Classes

class | Hilo::TileUpdateScheduler

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/VariableGridView.cpp File Reference

  • Hilo C++
  • Hilo

VariableGridView.cpp File Reference

#include "pch.h"
#include "VariableGridView.h"
#include "IResizable.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/VariableGridView.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

VariableGridView.h File Reference

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ViewModelBase.cpp File Reference

  • Hilo C++
  • Hilo

ViewModelBase.cpp File Reference

#include "pch.h"
#include "ViewModelBase.h"
#include "ExceptionPolicy.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ViewModelBase.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces | Functions

ViewModelBase.h File Reference

#include "Common\BindableBase.h"
#include "PageType.h"

Go to the source code of this file.

Classes

class | Hilo::ViewModelBase

Namespaces

namespace | Hilo

Functions

public delegate void | Hilo::NavigateEventHandler ()
public delegate void | Hilo::PageNavigateEventHandler (PageType page, Platform::Object^parameter)
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ViewModelLocator.cpp File Reference

  • Hilo C++
  • Hilo

ViewModelLocator.cpp File Reference

#include "pch.h"
#include "ViewModelLocator.h"
#include "DebugLoggingExceptionPolicy.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ViewModelLocator.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

ViewModelLocator.h File Reference

#include "MainHubViewModel.h"
#include "ImageBrowserViewModel.h"
#include "ImageViewModel.h"
#include "CropImageViewModel.h"
#include "RotateImageViewModel.h"
#include "CartoonizeImageViewModel.h"
#include "HubPhotoGroup.h"
#include "Photo.h"
#include "MonthGroup.h"
#include "YearGroup.h"
#include "MonthBlock.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/WideFiveImageTile.cpp File Reference

  • Hilo C++
  • Hilo
Variables

WideFiveImageTile.cpp File Reference

#include "pch.h"
#include "LocalResourceLoader.h"
#include "WideFiveImageTile.h"

Go to the source code of this file.

Variables

const unsigned int MaxTemplateImages = 5

Variable Documentation

const unsigned int MaxTemplateImages = 5

Definition at line 18 of file WideFiveImageTile.cpp.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/WideFiveImageTile.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

WideFiveImageTile.h File Reference

Go to the source code of this file.

Classes

class | Hilo::WideFiveImageTile

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/YearGroup.cpp File Reference

  • Hilo C++
  • Hilo

YearGroup.cpp File Reference

#include "pch.h"
#include "YearGroup.h"
#include "MonthBlock.h"
#include "ExceptionPolicy.h"
#include "LocalResourceLoader.h"
#include "Repository.h"
#include "CalendarExtensions.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/YearGroup.h File Reference

  • Hilo C++
  • Hilo
Classes | Namespaces

YearGroup.h File Reference

#include "IYearGroup.h"

Go to the source code of this file.

Classes

class | Hilo::sealed
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | Hilo
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BindableBase.cpp File Reference

  • Hilo C++
  • Hilo
  • Common

BindableBase.cpp File Reference

#include "pch.h"
#include "BindableBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BindableBase.h File Reference

  • Hilo C++
  • Hilo
  • Common
Classes | Namespaces

BindableBase.h File Reference

Go to the source code of this file.

Classes

class | Hilo::Common::BindableBase
Implementation of INotifyPropertyChanged to simplify models. More...

Namespaces

namespace | Hilo
namespace | Hilo::Common
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BooleanNegationConverter.cpp File Reference

  • Hilo C++
  • Hilo
  • Common

BooleanNegationConverter.cpp File Reference

#include "pch.h"
#include "BooleanNegationConverter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BooleanNegationConverter.h File Reference

  • Hilo C++
  • Hilo
  • Common
Classes | Namespaces

BooleanNegationConverter.h File Reference

Go to the source code of this file.

Classes

class | Hilo::Common::sealed
Value converter that translates true to false and vice versa. More...

Namespaces

namespace | Hilo
namespace | Hilo::Common
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BooleanToVisibilityConverter.cpp File Reference

  • Hilo C++
  • Hilo
  • Common

BooleanToVisibilityConverter.cpp File Reference

#include "pch.h"
#include "BooleanToVisibilityConverter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BooleanToVisibilityConverter.h File Reference

  • Hilo C++
  • Hilo
  • Common
Classes | Namespaces

BooleanToVisibilityConverter.h File Reference

Go to the source code of this file.

Classes

class | Hilo::Common::sealed
Value converter that translates true to false and vice versa. More...

Namespaces

namespace | Hilo
namespace | Hilo::Common
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/LayoutAwarePage.cpp File Reference

  • Hilo C++
  • Hilo
  • Common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/LayoutAwarePage.h File Reference

  • Hilo C++
  • Hilo
  • Common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | Hilo::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | Hilo
namespace | Hilo::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/RichTextColumns.cpp File Reference

  • Hilo C++
  • Hilo
  • Common

RichTextColumns.cpp File Reference

#include "pch.h"
#include "RichTextColumns.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/RichTextColumns.h File Reference

  • Hilo C++
  • Hilo
  • Common
Classes | Namespaces

RichTextColumns.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | Hilo::Common::sealed
Value converter that translates true to false and vice versa. More...

Namespaces

namespace | Hilo
namespace | Hilo::Common
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/SuspensionManager.cpp File Reference

  • Hilo C++
  • Hilo
  • Common
Classes | Namespaces | Enumerations | Functions

SuspensionManager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{SuspensionManager.cpp}

Enumerations

enum anonymous_namespace{SuspensionManager.cpp}::StreamTypes {
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{SuspensionManager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{SuspensionManager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{SuspensionManager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{SuspensionManager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{SuspensionManager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{SuspensionManager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{SuspensionManager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{SuspensionManager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{SuspensionManager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/SuspensionManager.h File Reference

  • Hilo C++
  • Hilo
  • Common
Classes | Namespaces

SuspensionManager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | Hilo::Common::sealed
Value converter that translates true to false and vice versa. More...

Namespaces

namespace | Hilo
namespace | Hilo::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/App.xaml.cpp File Reference

  • HomeGroup app

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/App.xaml.h File Reference

  • HomeGroup app
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/Constants.cpp File Reference

  • HomeGroup app

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/Constants.h File Reference

  • HomeGroup app
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupAdvancedSearch.xaml.cpp File Reference

  • HomeGroup app

HomeGroupAdvancedSearch.xaml.cpp File Reference

#include "pch.h"
#include "HomeGroupAdvancedSearch.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupAdvancedSearch.xaml.h File Reference

  • HomeGroup app
Classes | Namespaces

HomeGroupAdvancedSearch.xaml.h File Reference

#include "pch.h"
#include "HomeGroupAdvancedSearch.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HomeGroup::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HomeGroup
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupPickerScenario.xaml.cpp File Reference

  • HomeGroup app

HomeGroupPickerScenario.xaml.cpp File Reference

#include "pch.h"
#include "HomeGroupPickerScenario.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupPickerScenario.xaml.h File Reference

  • HomeGroup app
Classes | Namespaces

HomeGroupPickerScenario.xaml.h File Reference

#include "pch.h"
#include "HomeGroupPickerScenario.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HomeGroup::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HomeGroup
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupVideoStream.xaml.cpp File Reference

  • HomeGroup app

HomeGroupVideoStream.xaml.cpp File Reference

#include "pch.h"
#include "HomeGroupVideoStream.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupVideoStream.xaml.h File Reference

  • HomeGroup app
Classes | Namespaces

HomeGroupVideoStream.xaml.h File Reference

#include "pch.h"
#include "HomeGroupVideoStream.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HomeGroup::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HomeGroup
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/MainPage.xaml.cpp File Reference

  • HomeGroup app

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/MainPage.xaml.h File Reference

  • HomeGroup app
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/pch.cpp File Reference

  • HomeGroup app

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/pch.h File Reference

  • HomeGroup app

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/SearchHomeGroup.xaml.cpp File Reference

  • HomeGroup app

SearchHomeGroup.xaml.cpp File Reference

#include "pch.h"
#include "SearchHomeGroup.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/SearchHomeGroup.xaml.h File Reference

  • HomeGroup app
Classes | Namespaces

SearchHomeGroup.xaml.h File Reference

#include "pch.h"
#include "SearchHomeGroup.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HomeGroup::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HomeGroup
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/common/LayoutAwarePage.cpp File Reference

  • HomeGroup app
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/common/LayoutAwarePage.h File Reference

  • HomeGroup app
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/common/suspensionmanager.cpp File Reference

  • HomeGroup app
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/common/suspensionmanager.h File Reference

  • HomeGroup app
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/App.xaml.cpp File Reference

  • HttpClient

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/App.xaml.h File Reference

  • HttpClient
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Constants.cpp File Reference

  • HttpClient

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Constants.h File Reference

  • HttpClient
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Helpers
class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/HttpRequest.cpp File Reference

  • HttpClient
Classes

HttpRequest.cpp File Reference

#include "pch.h"
#include "HttpRequest.h"
#include <robuffer.h>
#include <shcore.h>

Go to the source code of this file.

Classes

class HttpRequestStringCallback
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/HttpRequest.h File Reference

  • HttpClient
Classes | Namespaces | Functions

HttpRequest.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | Web::Details::HttpRequestBuffersCallback
class | Web::HttpRequest

Namespaces

namespace | Web
namespace | Web::Details

Functions

void | CheckHResult (HRESULT hResult)

Function Documentation

void CheckHResult ( HRESULT hResult ) [inline]

Definition at line 14 of file HttpRequest.h.

{
    if (hResult == E_ABORT)
    {
        concurrency::cancel_current_task();
    }
    else if (FAILED(hResult))
    {
        throw Platform::Exception::CreateException(hResult);
    }
}

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/MainPage.xaml.cpp File Reference

  • HttpClient

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/MainPage.xaml.h File Reference

  • HttpClient
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/pch.cpp File Reference

  • HttpClient

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/pch.h File Reference

  • HttpClient

pch.h File Reference

#include <msxml6.h>
#include <collection.h>
#include <ppltasks.h>
#include <wrl.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include <sstream>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario1.xaml.cpp File Reference

  • HttpClient

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario1.xaml.h File Reference

  • HttpClient
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"
#include "HttpRequest.h"

Go to the source code of this file.

Classes

class | SDKSample::HttpClientSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HttpClientSample
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario2.xaml.cpp File Reference

  • HttpClient

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario2.xaml.h File Reference

  • HttpClient
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"
#include "HttpRequest.h"

Go to the source code of this file.

Classes

class | SDKSample::HttpClientSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HttpClientSample
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario3.xaml.cpp File Reference

  • HttpClient

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario3.xaml.h File Reference

  • HttpClient
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"
#include "HttpRequest.h"

Go to the source code of this file.

Classes

class | SDKSample::HttpClientSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HttpClientSample
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario4.xaml.cpp File Reference

  • HttpClient

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario4.xaml.h File Reference

  • HttpClient
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"
#include "HttpRequest.h"

Go to the source code of this file.

Classes

class | SDKSample::HttpClientSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HttpClientSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario5.xaml.cpp File Reference

  • HttpClient

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario5.xaml.h File Reference

  • HttpClient
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"
#include "HttpRequest.h"

Go to the source code of this file.

Classes

class | SDKSample::HttpClientSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HttpClientSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/common/LayoutAwarePage.cpp File Reference

  • HttpClient
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/common/LayoutAwarePage.h File Reference

  • HttpClient
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/common/suspensionmanager.cpp File Reference

  • HttpClient
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/common/suspensionmanager.h File Reference

  • HttpClient
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/App.xaml.cpp File Reference

  • Inclinometer sensor

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/App.xaml.h File Reference

  • Inclinometer sensor
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Constants.cpp File Reference

  • Inclinometer sensor

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Constants.h File Reference

  • Inclinometer sensor
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/MainPage.xaml.cpp File Reference

  • Inclinometer sensor

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/MainPage.xaml.h File Reference

  • Inclinometer sensor
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/pch.cpp File Reference

  • Inclinometer sensor

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/pch.h File Reference

  • Inclinometer sensor

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Scenario1.xaml.cpp File Reference

  • Inclinometer sensor

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Scenario1.xaml.h File Reference

  • Inclinometer sensor
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::InclinometerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::InclinometerCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Scenario2.xaml.cpp File Reference

  • Inclinometer sensor

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Scenario2.xaml.h File Reference

  • Inclinometer sensor
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::InclinometerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::InclinometerCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/common/LayoutAwarePage.cpp File Reference

  • Inclinometer sensor
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/common/LayoutAwarePage.h File Reference

  • Inclinometer sensor
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/common/suspensionmanager.cpp File Reference

  • Inclinometer sensor
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/common/suspensionmanager.h File Reference

  • Inclinometer sensor
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/App.xaml.cpp File Reference

  • Input Device capabilities

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/App.xaml.h File Reference

  • Input Device capabilities
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Constants.cpp File Reference

  • Input Device capabilities

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Constants.h File Reference

  • Input Device capabilities
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/cppsamplesutils.h File Reference

  • Input Device capabilities
Classes | Namespaces | Functions

cppsamplesutils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Keyboard.xaml.cpp File Reference

  • Input Device capabilities

Keyboard.xaml.cpp File Reference

#include "pch.h"
#include "Keyboard.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Keyboard.xaml.h File Reference

  • Input Device capabilities
Classes | Namespaces

Keyboard.xaml.h File Reference

#include "pch.h"
#include "Keyboard.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DeviceCaps::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DeviceCaps
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/MainPage.xaml.cpp File Reference

  • Input Device capabilities

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/MainPage.xaml.h File Reference

  • Input Device capabilities
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Mouse.xaml.cpp File Reference

  • Input Device capabilities

Mouse.xaml.cpp File Reference

#include "pch.h"
#include "Mouse.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Mouse.xaml.h File Reference

  • Input Device capabilities
Classes | Namespaces

Mouse.xaml.h File Reference

#include "pch.h"
#include "Mouse.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DeviceCaps::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DeviceCaps
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/pch.cpp File Reference

  • Input Device capabilities

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/pch.h File Reference

  • Input Device capabilities

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Pointer.xaml.cpp File Reference

  • Input Device capabilities

Pointer.xaml.cpp File Reference

#include "pch.h"
#include "Pointer.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Pointer.xaml.h File Reference

  • Input Device capabilities
Classes | Namespaces

Pointer.xaml.h File Reference

#include "pch.h"
#include "Pointer.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DeviceCaps::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DeviceCaps
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Touch.xaml.cpp File Reference

  • Input Device capabilities

Touch.xaml.cpp File Reference

#include "pch.h"
#include "Touch.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Touch.xaml.h File Reference

  • Input Device capabilities
Classes | Namespaces

Touch.xaml.h File Reference

#include "pch.h"
#include "Touch.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DeviceCaps::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DeviceCaps
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/common/LayoutAwarePage.cpp File Reference

  • Input Device capabilities
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/common/LayoutAwarePage.h File Reference

  • Input Device capabilities
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/common/suspensionmanager.cpp File Reference

  • Input Device capabilities
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/common/suspensionmanager.h File Reference

  • Input Device capabilities
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/BackgroundObject.cpp File Reference

  • Input Manipulations and gestures (C++)
  • C++

BackgroundObject.cpp File Reference

#include "pch.h"
#include "BackgroundObject.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/BackgroundObject.h File Reference

  • Input Manipulations and gestures (C++)
  • C++
Classes

BackgroundObject.h File Reference

#include "ManipulatableObject.h"

Go to the source code of this file.

Classes

class sealed
Wrap a WeakReference as a reference object for use in a collection. More...
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/DirectXBase.cpp File Reference

  • Input Manipulations and gestures (C++)
  • C++

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/DirectXBase.h File Reference

  • Input Manipulations and gestures (C++)
  • C++
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/DirectXSample.h File Reference

  • Input Manipulations and gestures (C++)
  • C++
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/DrawingObject.cpp File Reference

  • Input Manipulations and gestures (C++)
  • C++
Functions

DrawingObject.cpp File Reference

#include "pch.h"
#include "DrawingObject.h"

Go to the source code of this file.

Functions

double sgn_sqrt (double x)

Function Documentation

double sgn_sqrt ( double x ) [inline]

Definition at line 276 of file DrawingObject.cpp.

{
    return ((x >= 0) ? 1 : -1) * sqrt(fabs(x));
}

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/DrawingObject.h File Reference

  • Input Manipulations and gestures (C++)
  • C++
Classes

DrawingObject.h File Reference

#include "ManipulatableObject.h"

Go to the source code of this file.

Classes

class sealed
Wrap a WeakReference as a reference object for use in a collection. More...
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/ManipulatableObject.h File Reference

  • Input Manipulations and gestures (C++)
  • C++
Classes

ManipulatableObject.h File Reference

Go to the source code of this file.

Classes

interface | IRenderer
class | ManipulatableObject
class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/pch.cpp File Reference

  • Input Manipulations and gestures (C++)
  • C++

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/pch.h File Reference

  • Input Manipulations and gestures (C++)
  • C++
Defines

pch.h File Reference

#include <strsafe.h>
#include <math.h>
#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Defines

#define _USE_MATH_DEFINES

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 12 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/DirectXBase.cpp File Reference

  • Input Simplified ink

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/DirectXBase.h File Reference

  • Input Simplified ink
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/DirectXSample.h File Reference

  • Input Simplified ink
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/pch.cpp File Reference

  • Input Simplified ink

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/pch.h File Reference

  • Input Simplified ink

pch.h File Reference

#include <wrl.h>
#include <collection.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/simpleInk.cpp File Reference

  • Input Simplified ink
Enumerations | Functions

simpleInk.cpp File Reference

#include "pch.h"
#include <ppltasks.h>
#include "simpleInk.h"

Go to the source code of this file.

Enumerations

enum | PointerEventType { None, Ink, Select, Erase }

Functions

bool | AnySelected (_In_ Windows::Foundation::Collections::IVectorView< Windows::UI::Input::Inking::InkStroke^>^strokes)
void | CreateBrush (_In_ ID2D1DeviceContext *d2dContext, _In_ Windows::UI::Color color, _Outptr_ ID2D1SolidColorBrush **brush)
bool | EventIsErase (_In_ Windows::UI::Core::PointerEventArgs^e)
bool | EventIsInk (_In_ Windows::UI::Core::PointerEventArgs^e)
bool | EventIsSelect (_In_ Windows::UI::Core::PointerEventArgs^e)
PointerEventType | GetPointerEventType (_In_ Windows::UI::Core::PointerEventArgs^e)
int | main (Platform::Array< _In_ Platform::String^>^)
void | SelectAll (_In_ Windows::Foundation::Collections::IVectorView< Windows::UI::Input::Inking::InkStroke^>^strokes, _In_ bool val)

Enumeration Type Documentation

enum PointerEventType
Enumerator:
None
Ink
Select
Erase

Definition at line 14 of file simpleInk.cpp.

{
    None,
    Ink,
    Select,
    Erase
} PointerEventType;

Function Documentation

bool AnySelected ( _In_ Windows::Foundation::Collections::IVectorView< Windows::UI::Input::Inking::InkStroke^>^ strokes )

Definition at line 94 of file simpleInk.cpp.

{
    for (unsigned int i = 0; i < strokes->Size; i++)
    {
        if (strokes->GetAt(i)->Selected)
        {
            return true;
        }
    }
    return false;
}

void CreateBrush | ( | _In_ ID2D1DeviceContext * | d2dContext,
 |  | _In_ Windows::UI::Color | color,
 |  | _Outptr_ ID2D1SolidColorBrush ** | brush
 | ) |  |

Definition at line 79 of file simpleInk.cpp.

{
    D2D1::ColorF d2dColor(color.R/255.0f, color.G/255.0f, color.B/255.0f);
    *brush = nullptr;
    DX::ThrowIfFailed(
        d2dContext->CreateSolidColorBrush(
            d2dColor,
            brush
            )
        );
}

bool EventIsErase ( _In_ Windows::UI::Core::PointerEventArgs^ e )

Definition at line 22 of file simpleInk.cpp.

{
    auto pointerDevice = e->CurrentPoint->PointerDevice;
    auto pointerProperties = e->CurrentPoint->Properties;

    bool rval = false
        || (pointerProperties->IsEraser)
        || (pointerDevice->PointerDeviceType == Windows::Devices::Input::PointerDeviceType::Pen && !pointerProperties->IsBarrelButtonPressed && pointerProperties->IsRightButtonPressed)
        || (pointerDevice->PointerDeviceType == Windows::Devices::Input::PointerDeviceType::Mouse && pointerProperties->IsRightButtonPressed);

    return rval;
}

bool EventIsInk ( _In_ Windows::UI::Core::PointerEventArgs^ e )

Definition at line 35 of file simpleInk.cpp.

{
    auto pointerDevice = e->CurrentPoint->PointerDevice;
    auto pointerProperties = e->CurrentPoint->Properties;

    bool rval = false
        || (pointerDevice->PointerDeviceType == Windows::Devices::Input::PointerDeviceType::Pen && !pointerProperties->IsBarrelButtonPressed && !pointerProperties->IsRightButtonPressed)
        || (pointerDevice->PointerDeviceType == Windows::Devices::Input::PointerDeviceType::Mouse && pointerProperties->IsLeftButtonPressed && e->KeyModifiers == Windows::System::VirtualKeyModifiers::None);

    return rval;
}

bool EventIsSelect ( _In_ Windows::UI::Core::PointerEventArgs^ e )

Definition at line 47 of file simpleInk.cpp.

{
    auto pointerDevice = e->CurrentPoint->PointerDevice;
    auto pointerProperties = e->CurrentPoint->Properties;

    bool rval = false
        || (pointerDevice->PointerDeviceType == Windows::Devices::Input::PointerDeviceType::Pen && pointerProperties->IsBarrelButtonPressed)
        || (pointerDevice->PointerDeviceType == Windows::Devices::Input::PointerDeviceType::Mouse && pointerProperties->IsLeftButtonPressed && e->KeyModifiers == Windows::System::VirtualKeyModifiers::Control);

    return rval;
}

PointerEventType GetPointerEventType ( _In_ Windows::UI::Core::PointerEventArgs^ e )

Definition at line 59 of file simpleInk.cpp.

{
    PointerEventType type = PointerEventType::None;

    if (EventIsErase(e))
    {
        type = PointerEventType::Erase;
    }
    else if (EventIsInk(e))
    {
        type = PointerEventType::Ink;
    }
    else if (EventIsSelect(e))
    {
        type = PointerEventType::Select;
    }

    return type;
}

int main ( Platform::Array< _In_ Platform::String^>^ )

Definition at line 1038 of file simpleInk.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    Windows::ApplicationModel::Core::CoreApplication::Run(directXAppSource);
    return 0;
}

void SelectAll | ( | _In_ Windows::Foundation::Collections::IVectorView< Windows::UI::Input::Inking::InkStroke^>^ | strokes,
 |  | _In_ bool | val
 | ) |  |

Definition at line 106 of file simpleInk.cpp.

{
    for (unsigned int i = 0; i < strokes->Size; i++)
    {
        strokes->GetAt(i)->Selected = val;
    }
}

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/simpleInk.h File Reference

  • Input Simplified ink
Classes | Enumerations

simpleInk.h File Reference

#include "DirectXBase.h"

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...
class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Enumerations

enum | RenderingMode { Bezier, Live }

Enumeration Type Documentation

enum RenderingMode
Enumerator:
Bezier
Live

Definition at line 26 of file simpleInk.h.

             {
    Bezier,
    Live
} RenderingMode;

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/DirectXBase.cpp File Reference

  • Input Touch hit testing

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/DirectXBase.h File Reference

  • Input Touch hit testing
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/DirectXSample.h File Reference

  • Input Touch hit testing
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/pch.cpp File Reference

  • Input Touch hit testing

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/pch.h File Reference

  • Input Touch hit testing

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/Program.cpp File Reference

  • Input Touch hit testing
Variables

Program.cpp File Reference

#include "pch.h"
#include <stdio.h>
#include "Program.h"

Go to the source code of this file.

Variables

int const CONTROLS_AREA_SIZE = 300

Variable Documentation

int const CONTROLS_AREA_SIZE = 300

Definition at line 23 of file Program.cpp.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/Program.h File Reference

  • Input Touch hit testing
Classes

Program.h File Reference

#include <new>
#include <memory>
#include "Shape.h"

Go to the source code of this file.

Classes

class | Program
struct | ShapeRecord
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/SampleOverlay.cpp File Reference

  • Input Touch hit testing

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/SampleOverlay.h File Reference

  • Input Touch hit testing
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/Shape.cpp File Reference

  • Input Touch hit testing

Shape.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"
#include <math.h>
#include "Shape.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/Shape.h File Reference

  • Input Touch hit testing
Classes | Variables

Shape.h File Reference

Go to the source code of this file.

Classes

struct | Polygon
class | Shape

Variables

int const | CURSOR_ID_NONE = -1
int const | MAX_POLY_VERTICES = 50

Variable Documentation

int const CURSOR_ID_NONE = -1

Definition at line 14 of file Shape.h.

int const MAX_POLY_VERTICES = 50

Definition at line 13 of file Shape.h.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/ShapesPuzzle.cpp File Reference

  • Input Touch hit testing
Functions

ShapesPuzzle.cpp File Reference

#include "pch.h"
#include "ShapesPuzzle.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 206 of file ShapesPuzzle.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/ShapesPuzzle.h File Reference

  • Input Touch hit testing
Classes

ShapesPuzzle.h File Reference

#include "Program.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class | DirectXAppSource
class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/App.xaml.cpp File Reference

  • Input Touch keyboard text input

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/App.xaml.h File Reference

  • Input Touch keyboard text input
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/Constants.cpp File Reference

  • Input Touch keyboard text input

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/Constants.h File Reference

  • Input Touch keyboard text input
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/MainPage.xaml.cpp File Reference

  • Input Touch keyboard text input

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/MainPage.xaml.h File Reference

  • Input Touch keyboard text input
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/pch.cpp File Reference

  • Input Touch keyboard text input

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/pch.h File Reference

  • Input Touch keyboard text input

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/ScopedViews.xaml.cpp File Reference

  • Input Touch keyboard text input

ScopedViews.xaml.cpp File Reference

#include "pch.h"
#include "ScopedViews.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/ScopedViews.xaml.h File Reference

  • Input Touch keyboard text input
Classes | Namespaces

ScopedViews.xaml.h File Reference

#include "pch.h"
#include "ScopedViews.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TouchKeyboardTextInput::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TouchKeyboardTextInput
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/common/LayoutAwarePage.cpp File Reference

  • Input Touch keyboard text input
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/common/LayoutAwarePage.h File Reference

  • Input Touch keyboard text input
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/common/suspensionmanager.cpp File Reference

  • Input Touch keyboard text input
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/common/suspensionmanager.h File Reference

  • Input Touch keyboard text input
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/App.xaml.cpp File Reference

  • Input Touch keyboard

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/App.xaml.h File Reference

  • Input Touch keyboard
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/Constants.cpp File Reference

  • Input Touch keyboard

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/Constants.h File Reference

  • Input Touch keyboard
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/Launch.xaml.cpp File Reference

  • Input Touch keyboard

Launch.xaml.cpp File Reference

#include "pch.h"
#include "Launch.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/Launch.xaml.h File Reference

  • Input Touch keyboard
Classes | Namespaces

Launch.xaml.h File Reference

#include "pch.h"
#include "Launch.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TouchKeyboard::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::TouchKeyboard::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TouchKeyboard
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/MainPage.xaml.cpp File Reference

  • Input Touch keyboard

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/MainPage.xaml.h File Reference

  • Input Touch keyboard
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/NonTouchableTextBlock.xaml.cpp File Reference

  • Input Touch keyboard
Classes | Namespaces

NonTouchableTextBlock.xaml.cpp File Reference

#include "pch.h"
#include "NonTouchableTextBlock.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TouchKeyboard::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TouchKeyboard
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/NonTouchableTextBlock.xaml.h File Reference

  • Input Touch keyboard
Classes | Namespaces

NonTouchableTextBlock.xaml.h File Reference

#include "pch.h"
#include "NonTouchableTextBlock.g.h"

Go to the source code of this file.

Classes

class | SDKSample::TouchKeyboard::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TouchKeyboard
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/pch.cpp File Reference

  • Input Touch keyboard

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/pch.h File Reference

  • Input Touch keyboard

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/TouchableTextBlock.xaml.cpp File Reference

  • Input Touch keyboard
Classes | Namespaces

TouchableTextBlock.xaml.cpp File Reference

#include "pch.h"
#include "TouchableTextBlock.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TouchKeyboard::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TouchKeyboard
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/TouchableTextBlock.xaml.h File Reference

  • Input Touch keyboard
Classes | Namespaces

TouchableTextBlock.xaml.h File Reference

#include "pch.h"
#include "TouchableTextBlock.g.h"

Go to the source code of this file.

Classes

class | SDKSample::TouchKeyboard::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::TouchKeyboard::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TouchKeyboard
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/common/LayoutAwarePage.cpp File Reference

  • Input Touch keyboard
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/common/LayoutAwarePage.h File Reference

  • Input Touch keyboard
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/common/suspensionmanager.cpp File Reference

  • Input Touch keyboard
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/common/suspensionmanager.h File Reference

  • Input Touch keyboard
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/App.xaml.cpp File Reference

  • IXmlReader and IXmlWriter XML data readwrite

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/App.xaml.h File Reference

  • IXmlReader and IXmlWriter XML data readwrite
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/Constants.cpp File Reference

  • IXmlReader and IXmlWriter XML data readwrite

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/Constants.h File Reference

  • IXmlReader and IXmlWriter XML data readwrite
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/MainPage.xaml.h File Reference

  • IXmlReader and IXmlWriter XML data readwrite
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/pch.cpp File Reference

  • IXmlReader and IXmlWriter XML data readwrite

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/pch.h File Reference

  • IXmlReader and IXmlWriter XML data readwrite
Defines

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include <shcore.h>
#include <wrl.h>
#include <xmllite.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Defines

#define ChkHr(stmt) do { hr = stmt; if (FAILED(hr)) return hr; } while(0)

Define Documentation

#define ChkHr ( stmt ) do { hr = stmt; if (FAILED(hr)) return hr; } while(0)

Definition at line 24 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/App.xaml.cpp File Reference

  • Language font mapping

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/App.xaml.h File Reference

  • Language font mapping
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | LanguageFontCPP::sealed

Namespaces

namespace | LanguageFontCPP
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/CppSamplesUtils.h File Reference

  • Language font mapping
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/LocalCache.cpp File Reference

  • Language font mapping

LocalCache.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/LocalCache.h File Reference

  • Language font mapping
Classes | Namespaces

LocalCache.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | LanguageFontCPP::sealed

Namespaces

namespace | LanguageFontCPP
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/MainPage.xaml.cpp File Reference

  • Language font mapping

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/MainPage.xaml.h File Reference

  • Language font mapping
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LanguageFontCPP::sealed

Namespaces

namespace | LanguageFontCPP

Enumerations

enum | LanguageFontCPP::NotifyType { LanguageFontCPP::StatusMessage, LanguageFontCPP::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/pch.cpp File Reference

  • Language font mapping

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/pch.h File Reference

  • Language font mapping
Defines

pch.h File Reference

#include "CppSamplesUtils.h"
#include <ppltasks.h>
#include "LocalCache.h"
#include "CppSamplesUtils.h"

Go to the source code of this file.

Defines

#define USE_PPLTASKS

Define Documentation

#define USE_PPLTASKS

Definition at line 14 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioInput1.xaml.cpp File Reference

  • Language font mapping

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioInput1.xaml.h File Reference

  • Language font mapping
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | LanguageFontCPP::sealed

Namespaces

namespace | LanguageFontCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioInput2.xaml.cpp File Reference

  • Language font mapping

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioInput2.xaml.h File Reference

  • Language font mapping
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LanguageFontCPP::sealed

Namespaces

namespace | LanguageFontCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioList.xaml.cpp File Reference

  • Language font mapping

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioList.xaml.h File Reference

  • Language font mapping
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LanguageFontCPP::sealed

Namespaces

namespace | LanguageFontCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioOutput1.xaml.cpp File Reference

  • Language font mapping

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioOutput1.xaml.h File Reference

  • Language font mapping
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | LanguageFontCPP::sealed

Namespaces

namespace | LanguageFontCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioOutput2.xaml.cpp File Reference

  • Language font mapping

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioOutput2.xaml.h File Reference

  • Language font mapping
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LanguageFontCPP::sealed

Namespaces

namespace | LanguageFontCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/App.xaml.cpp File Reference

  • LightSensor

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/App.xaml.h File Reference

  • LightSensor
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/Constants.cpp File Reference

  • LightSensor

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/Constants.h File Reference

  • LightSensor
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/MainPage.xaml.cpp File Reference

  • LightSensor

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/MainPage.xaml.h File Reference

  • LightSensor
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/pch.cpp File Reference

  • LightSensor

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/pch.h File Reference

  • LightSensor

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/Scenario1.xaml.cpp File Reference

  • LightSensor

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/Scenario1.xaml.h File Reference

  • LightSensor
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::LightSensorCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::LightSensorCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/Scenario2.xaml.cpp File Reference

  • LightSensor

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/Scenario2.xaml.h File Reference

  • LightSensor
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::LightSensorCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::LightSensorCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/common/LayoutAwarePage.cpp File Reference

  • LightSensor
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/common/LayoutAwarePage.h File Reference

  • LightSensor
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/common/suspensionmanager.cpp File Reference

  • LightSensor
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/common/suspensionmanager.h File Reference

  • LightSensor
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/App.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/App.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/CppSamplesUtils.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/MainPage.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/MainPage.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP

Enumerations

enum | LockScreenAppsCPP::NotifyType { LockScreenAppsCPP::StatusMessage, LockScreenAppsCPP::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/pch.cpp File Reference

  • Lock screen apps
  • C#,C++

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/pch.h File Reference

  • Lock screen apps
  • C#,C++

pch.h File Reference

#include "CppSamplesUtils.h"
#include <ppltasks.h>
#include "CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioInput1.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioInput1.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioInput2.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioInput2.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioInput3.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++
Defines

ScenarioInput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Defines

#define | BADGE_TILE_ID "ST_BADGE"
#define | TEXT_TILE_ID "ST_BADGE_AND_TEXT"

Define Documentation

#define BADGE_TILE_ID "ST_BADGE"

Definition at line 32 of file ScenarioInput3.xaml.cpp.

#define TEXT_TILE_ID "ST_BADGE_AND_TEXT"

Definition at line 33 of file ScenarioInput3.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioInput3.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces

ScenarioInput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioList.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioList.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioOutput1.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioOutput1.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioOutput2.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioOutput2.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioOutput3.xaml.cpp File Reference

  • Lock screen apps
  • C#,C++

ScenarioOutput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioOutput3.xaml.h File Reference

  • Lock screen apps
  • C#,C++
Classes | Namespaces

ScenarioOutput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | LockScreenAppsCPP::sealed

Namespaces

namespace | LockScreenAppsCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/NotificationsExtensions/BadgeContent.cs File Reference

  • Lock screen apps
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

BadgeContent.cs File Reference

Go to the source code of this file.

Classes

class | NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
Notification content object to display a glyph on a tile's badge. More...
class | NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
Notification content object to display a number on a tile's badge. More...

Namespaces

namespace | NotificationsExtensions::BadgeContent
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/NotificationsExtensions/Common.cs File Reference

  • Lock screen apps
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

Common.cs File Reference

Go to the source code of this file.

Classes

class | NotificationsExtensions::NotificationBase
Base class for the notification content creation helper classes. More...
class | NotificationsExtensions::NotificationContentImage
class | NotificationsExtensions::NotificationContentText
class | NotificationsExtensions::NotificationContentValidationException
Exception returned when invalid notification content is provided. More...
class | NotificationsExtensions::Util

Namespaces

namespace | NotificationsExtensions
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/NotificationsExtensions/TileContent.cs File Reference

  • Lock screen apps
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

TileContent.cs File Reference

Go to the source code of this file.

Classes

interface | NotificationsExtensions::TileContent::ISquareTileInternal
class | NotificationsExtensions::TileContent::TileContentFactory
A factory which creates tile content objects for all of the toast template types. More...
class | NotificationsExtensions::TileContent::TileNotificationBase
class | NotificationsExtensions::TileContent::TileSquareBase
class | NotificationsExtensions::TileContent::TileSquareBlock
class | NotificationsExtensions::TileContent::TileSquareImage
class | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
class | NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
class | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
class | NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
class | NotificationsExtensions::TileContent::TileSquareText01
class | NotificationsExtensions::TileContent::TileSquareText02
class | NotificationsExtensions::TileContent::TileSquareText03
class | NotificationsExtensions::TileContent::TileSquareText04
class | NotificationsExtensions::TileContent::TileWideBase
class | NotificationsExtensions::TileContent::TileWideBlockAndText01
class | NotificationsExtensions::TileContent::TileWideBlockAndText02
class | NotificationsExtensions::TileContent::TileWideImage
class | NotificationsExtensions::TileContent::TileWideImageAndText01
class | NotificationsExtensions::TileContent::TileWideImageAndText02
class | NotificationsExtensions::TileContent::TileWideImageCollection
class | NotificationsExtensions::TileContent::TileWidePeekImage01
class | NotificationsExtensions::TileContent::TileWidePeekImage02
class | NotificationsExtensions::TileContent::TileWidePeekImage03
class | NotificationsExtensions::TileContent::TileWidePeekImage04
class | NotificationsExtensions::TileContent::TileWidePeekImage05
class | NotificationsExtensions::TileContent::TileWidePeekImage06
class | NotificationsExtensions::TileContent::TileWidePeekImageAndText01
class | NotificationsExtensions::TileContent::TileWidePeekImageAndText02
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection01
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection02
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection03
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection04
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection05
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection06
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText01
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText02
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText03
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText04
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText05
class | NotificationsExtensions::TileContent::TileWideText01
class | NotificationsExtensions::TileContent::TileWideText02
class | NotificationsExtensions::TileContent::TileWideText03
class | NotificationsExtensions::TileContent::TileWideText04
class | NotificationsExtensions::TileContent::TileWideText05
class | NotificationsExtensions::TileContent::TileWideText06
class | NotificationsExtensions::TileContent::TileWideText07
class | NotificationsExtensions::TileContent::TileWideText08
class | NotificationsExtensions::TileContent::TileWideText09
class | NotificationsExtensions::TileContent::TileWideText10
class | NotificationsExtensions::TileContent::TileWideText11

Namespaces

namespace | NotificationsExtensions::TileContent
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs File Reference

  • Lock screen apps
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

ToastContent.cs File Reference

Go to the source code of this file.

Classes

class | NotificationsExtensions::ToastContent::ToastAudio
class | NotificationsExtensions::ToastContent::ToastContentFactory
A factory which creates toast content objects for all of the toast template types.
class | NotificationsExtensions::ToastContent::ToastImageAndText01
class | NotificationsExtensions::ToastContent::ToastImageAndText02
class | NotificationsExtensions::ToastContent::ToastImageAndText03
class | NotificationsExtensions::ToastContent::ToastImageAndText04
class | NotificationsExtensions::ToastContent::ToastNotificationBase
class | NotificationsExtensions::ToastContent::ToastText01
class | NotificationsExtensions::ToastContent::ToastText02
class | NotificationsExtensions::ToastContent::ToastText03
class | NotificationsExtensions::ToastContent::ToastText04

Namespaces

namespace | NotificationsExtensions::ToastContent
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/App.xaml.cpp File Reference

  • Lock screen personalization

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/App.xaml.h File Reference

  • Lock screen personalization
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/Constants.cpp File Reference

  • Lock screen personalization

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/Constants.h File Reference

  • Lock screen personalization
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/MainPage.xaml.cpp File Reference

  • Lock screen personalization

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/MainPage.xaml.h File Reference

  • Lock screen personalization
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/pch.cpp File Reference

  • Lock screen personalization

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/pch.h File Reference

  • Lock screen personalization

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/SetLockscreenImage.xaml.cpp File Reference

  • Lock screen personalization

SetLockscreenImage.xaml.cpp File Reference

#include "pch.h"
#include "SetLockscreenImage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/SetLockscreenImage.xaml.h File Reference

  • Lock screen personalization
Classes | Namespaces

SetLockscreenImage.xaml.h File Reference

#include "pch.h"
#include "SetLockscreenImage.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Personalization::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Personalization
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/common/LayoutAwarePage.cpp File Reference

  • Lock screen personalization
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/common/LayoutAwarePage.h File Reference

  • Lock screen personalization
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/common/suspensionmanager.cpp File Reference

  • Lock screen personalization
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/common/suspensionmanager.h File Reference

  • Lock screen personalization
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C#,C++/App.xaml.cs File Reference

  • Media capture using capture device
  • C#,C++
Classes | Namespaces

App.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::App
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C#,C++/AudioCapture.xaml.cs File Reference

  • Media capture using capture device
  • C#,C++
Classes | Namespaces

AudioCapture.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaCapture::AudioCapture
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | MediaCapture
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C#,C++/BasicCapture.xaml.cs File Reference

  • Media capture using capture device
  • C#,C++
Classes | Namespaces

BasicCapture.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaCapture::BasicCapture
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | MediaCapture
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C#,C++/Constants.cs File Reference

  • Media capture using capture device
  • C#,C++
Classes | Namespaces

Constants.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::Scenario

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C#,C++/MainPage.xaml.cs File Reference

  • Media capture using capture device
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::MainPageSizeChangedEventArgs

Namespaces

namespace | SDKTemplate

Enumerations

enum SDKTemplate::NotifyType {
SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage, SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage,
SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage, SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/AdvancedCapture.xaml.cpp File Reference

  • Media capture using capture device
Classes

AdvancedCapture.xaml.cpp File Reference

#include "pch.h"
#include "AdvancedCapture.xaml.h"

Go to the source code of this file.

Classes

class sealed
Wrap a WeakReference as a reference object for use in a collection. More...
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/AdvancedCapture.xaml.h File Reference

  • Media capture using capture device
Classes | Namespaces | Defines

AdvancedCapture.xaml.h File Reference

#include "pch.h"
#include "AdvancedCapture.g.h"
#include "MainPage.xaml.h"
#include <ppl.h>
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MediaCapture::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::MediaCapture

Defines

#define | PHOTO_FILE_NAME "photo.jpg"
#define | TEMP_PHOTO_FILE_NAME "photoTmp.jpg"
#define | VIDEO_FILE_NAME "video.mp4"

Define Documentation

#define PHOTO_FILE_NAME "photo.jpg"

Definition at line 24 of file AdvancedCapture.xaml.h.

#define TEMP_PHOTO_FILE_NAME "photoTmp.jpg"

Definition at line 25 of file AdvancedCapture.xaml.h.

#define VIDEO_FILE_NAME "video.mp4"

Definition at line 23 of file AdvancedCapture.xaml.h.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/App.xaml.cpp File Reference

  • Media capture using capture device

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/App.xaml.h File Reference

  • Media capture using capture device
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/AudioCapture.xaml.cpp File Reference

  • Media capture using capture device

AudioCapture.xaml.cpp File Reference

#include "pch.h"
#include "AudioCapture.xaml.h"
#include <ppl.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/AudioCapture.xaml.h File Reference

  • Media capture using capture device
Classes | Namespaces | Defines

AudioCapture.xaml.h File Reference

#include "pch.h"
#include "AudioCapture.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MediaCapture::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::MediaCapture

Defines

#define | AUDIO_FILE_NAME "audio.mp4"

Define Documentation

#define AUDIO_FILE_NAME "audio.mp4"

Definition at line 22 of file AudioCapture.xaml.h.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/BasicCapture.xaml.cpp File Reference

  • Media capture using capture device

BasicCapture.xaml.cpp File Reference

#include "pch.h"
#include "BasicCapture.xaml.h"
#include "ppl.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/BasicCapture.xaml.h File Reference

  • Media capture using capture device
Classes | Namespaces | Defines

BasicCapture.xaml.h File Reference

#include "pch.h"
#include "BasicCapture.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MediaCapture::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::MediaCapture

Defines

#define | PHOTO_FILE_NAME "photo.jpg"
#define | VIDEO_FILE_NAME "video.mp4"

Define Documentation

#define PHOTO_FILE_NAME "photo.jpg"

Definition at line 28 of file BasicCapture.xaml.h.

#define VIDEO_FILE_NAME "video.mp4"

Definition at line 27 of file BasicCapture.xaml.h.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/Constants.cpp File Reference

  • Media capture using capture device

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/Constants.h File Reference

  • Media capture using capture device
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/MainPage.xaml.cpp File Reference

  • Media capture using capture device

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/MainPage.xaml.h File Reference

  • Media capture using capture device
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/pch.cpp File Reference

  • Media capture using capture device

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/pch.h File Reference

  • Media capture using capture device

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include <agile.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/common/LayoutAwarePage.h File Reference

  • Media capture using capture device
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/common.h File Reference

  • Media engine native C++ video playback
Functions

common.h File Reference

Go to the source code of this file.

Functions

template<class T >
void SafeRelease (T **ppT)

Function Documentation

template<class T >
void SafeRelease ( T ** ppT )

Definition at line 14 of file common.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/d3dmanagerlock.hxx File Reference

  • Media engine native C++ video playback
Classes

d3dmanagerlock.hxx File Reference

Go to the source code of this file.

Classes

class | CAutoDXDevLockBase< DevManager, DevInterface >
class | CAutoDXGILock
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/frameworkview.cpp File Reference

  • Media engine native C++ video playback

frameworkview.cpp File Reference

#include "pch.h"
#include "FrameworkView.h"
#include "VideoView.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/frameworkview.h File Reference

  • Media engine native C++ video playback
Classes | Enumerations

frameworkview.h File Reference

#include <agile.h>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...
class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Enumerations

enum | ActivationEntryPoint { Unknown, MEPlaybackNative }

Enumeration Type Documentation

enum ActivationEntryPoint
Enumerator:
Unknown
MEPlaybackNative

Definition at line 6 of file frameworkview.h.

{
    Unknown,
    MEPlaybackNative
};

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/main.cpp File Reference

  • Media engine native C++ video playback
Functions

main.cpp File Reference

#include "pch.h"
#include "FrameworkView.h"

Go to the source code of this file.

Functions

int __cdecl main (Platform::Array< Platform::String^>^)

Function Documentation

int __cdecl main ( Platform::Array< Platform::String^>^ )

Definition at line 5 of file main.cpp.

{
    auto frameworkView = ref new FrameworkViewSource();
    Windows::ApplicationModel::Core::CoreApplication::Run(frameworkView);
}

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/meplayer.cpp File Reference

  • Media engine native C++ video playback
Classes

meplayer.cpp File Reference

#include "pch.h"
#include "MEPlayer.h"
#include <d3dmanagerlock.hxx>

Go to the source code of this file.

Classes

class MediaEngineNotify
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/meplayer.h File Reference

  • Media engine native C++ video playback
Classes | Namespaces | Defines | Functions

meplayer.h File Reference

#include <wrl.h>
#include <mfmediaengine.h>
#include <d3d11_1.h>
#include <ppltasks.h>
#include <agile.h>

Go to the source code of this file.

Classes

class | abstract
class | MEPlayer

Namespaces

namespace | MEDIA

Defines

#define | ME_CAN_SEEK 0x00000002

Functions

void | MEDIA::ThrowIfFailed (HRESULT hr)

Define Documentation

#define ME_CAN_SEEK 0x00000002

Definition at line 21 of file meplayer.h.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/pch.cpp File Reference

  • Media engine native C++ video playback

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/pch.h File Reference

  • Media engine native C++ video playback

pch.h File Reference

#include <windows.h>
#include <roapi.h>
#include <wrl.h>
#include <new>
#include <mfapi.h>
#include <mferror.h>
#include <dxgitype.h>
#include <strsafe.h>
#include <vector>
#include <memory>
#include <limits>
#include <common.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/videoview.cpp File Reference

  • Media engine native C++ video playback

videoview.cpp File Reference

#include "pch.h"
#include "VideoView.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/videoview.h File Reference

  • Media engine native C++ video playback
Classes

videoview.h File Reference

#include "MEPlayer.h"

Go to the source code of this file.

Classes

class VideoView
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/App.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

App.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::App

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MainPage.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplateCS::MainPage

Namespaces

namespace | SDKTemplateCS

Enumerations

enum | SDKTemplateCS::NotifyType { SDKTemplateCS::StatusMessage, SDKTemplateCS::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioInput1.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioInput1.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioInput1

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioInput2.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioInput2.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioInput2

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioInput3.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioInput3.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioInput3

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioInput4.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioInput4.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioInput4

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioList.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioList.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioList

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioOutput1.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioOutput1.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioOutput1

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioOutput2.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioOutput2.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioOutput2

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioOutput3.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioOutput3.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioOutput3

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioOutput4.xaml.cs File Reference

  • Media extensions
  • C#,C++
Classes | Namespaces

ScenarioOutput4.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaExtensionsCS::ScenarioOutput4

Namespaces

namespace | MediaExtensionsCS
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Common/AsyncCB.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Common
Classes

AsyncCB.h File Reference

Go to the source code of this file.

Classes

class AsyncCallback< T >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Common/BufferLock.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Common
Classes

BufferLock.h File Reference

Go to the source code of this file.

Classes

class VideoBufferLock
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Common/CritSec.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Common
Classes

CritSec.h File Reference

Go to the source code of this file.

Classes

class | AutoLock
class | CritSec
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Common/LinkList.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Common
Classes

LinkList.h File Reference

Go to the source code of this file.

Classes

class | ComAutoRelease
class | ComPtrList< T, NULLABLE >
class | List< T >
struct | List< T >::Node
class | List< T >::POSITION
class | MemDelete
struct | NoOp< T >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Common/OpQueue.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Common
Classes

OpQueue.h File Reference

#include "linklist.h"
#include "AsyncCB.h"

Go to the source code of this file.

Classes

class OpQueue< T, TOperation >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Grayscale/dllmain.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Grayscale
Namespaces | Functions

dllmain.cpp File Reference

#include <initguid.h>
#include "Grayscale.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CGrayscale)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 48 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 42 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 54 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 23 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Grayscale/Grayscale.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Grayscale
Functions | Variables

Grayscale.cpp File Reference

#include "Grayscale.h"
#include "bufferlock.h"

Go to the source code of this file.

Functions

template<typename T >
T | clamp (const T &val, const T &minVal, const T &maxVal)
HRESULT | GetDefaultStride (IMFMediaType *pType, LONG *plStride)
HRESULT | GetImageSize (DWORD fcc, UINT32 width, UINT32 height, DWORD *pcbImage)
void | TransformChroma (const D2D1::Matrix3x2F &mat, BYTE *pu, BYTE *pv)
void | TransformImage_NV12 (const D2D1::Matrix3x2F &mat, const D2D_RECT_U &rcDest, _Inout_updates_(_Inexpressible_(2 *lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(2 *lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
void | TransformImage_UYVY (const D2D1::Matrix3x2F &mat, const D2D_RECT_U &rcDest, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
void | TransformImage_YUY2 (const D2D1::Matrix3x2F &mat, const D2D_RECT_U &rcDest, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
bool | ValidateRect (const RECT &rc)

Variables

const DWORD | FOURCC_NV12 = '21VN'
const DWORD | FOURCC_UYVY = 'YVYU'
const DWORD | FOURCC_YUY2 = '2YUY'
const GUID | g_MediaSubtypes []

Function Documentation

template<typename T >
T clamp | ( | const T & | val,
 |  | const T & | minVal,
 |  | const T & | maxVal |
 | ) |  |  | [inline]

Definition at line 100 of file Grayscale.cpp.

{
    return (val < minVal ? minVal : (val > maxVal ? maxVal : val));
}

HRESULT GetDefaultStride | ( | IMFMediaType * | pType,
 |  | LONG * | plStride
 | ) |  |

Definition at line 1715 of file Grayscale.cpp.

{
    LONG lStride = 0;

    // Try to get the default stride from the media type.
    HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
    if (FAILED(hr))
    {
        // Attribute not set. Try to calculate the default stride.
        GUID subtype = GUID_NULL;

        UINT32 width = 0;
        UINT32 height = 0;

        // Get the subtype and the image size.
        hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
        if (SUCCEEDED(hr))
        {
            hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
        }
        if (SUCCEEDED(hr))
        {
            if (subtype == MFVideoFormat_NV12)
            {
                lStride = width;
            }
            else if (subtype == MFVideoFormat_YUY2 || subtype == MFVideoFormat_UYVY)
            {
                lStride = ((width * 2) + 3) & ~3;
            }
            else
            {
                hr = E_INVALIDARG;
            }
        }

        // Set the attribute for later reference.
        if (SUCCEEDED(hr))
        {
            (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
        }
    }
    if (SUCCEEDED(hr))
    {
        *plStride = lStride;
    }
    return hr;
}

HRESULT GetImageSize | ( | DWORD | fcc,
 |  | UINT32 | width,
 |  | UINT32 | height,
 |  | DWORD * | pcbImage
 | ) |  |

Definition at line 1675 of file Grayscale.cpp.

{
    HRESULT hr = S_OK;

    switch (fcc)
    {
    case FOURCC_YUY2:
    case FOURCC_UYVY:
        // check overflow
        if ((width > MAXDWORD / 2) || (width * 2 > MAXDWORD / height))
        {
            hr = E_INVALIDARG;
        }
        else
        {
            // 16 bpp
            *pcbImage = width * height * 2;
        }
        break;

    case FOURCC_NV12:
        // check overflow
        if ((height/2 > MAXDWORD - height) || ((height + height/2) > MAXDWORD / width))
        {
            hr = E_INVALIDARG;
        }
        else
        {
            // 12 bpp
            *pcbImage = width * (height + (height/2));
        }
        break;

    default:
        hr = E_FAIL;    // Unsupported type.
    }
    return hr;
}

void TransformChroma | ( | const D2D1::Matrix3x2F & | mat,
 |  | BYTE * | pu,
 |  | BYTE * | pv
 | ) |  |

Definition at line 109 of file Grayscale.cpp.

{
    // Normalize the chroma values to [-112, 112] range

    D2D1_POINT_2F pt = { static_cast<float>(*pu) - 128, static_cast<float>(*pv) - 128 };

    pt = mat.TransformPoint(pt);

    // Clamp to valid range.
    clamp(pt.x, -112.0f, 112.0f);
    clamp(pt.y, -112.0f, 112.0f);

    // Map back to [16...240] range.
    *pu = static_cast<BYTE>(pt.x + 128.0f);
    *pv = static_cast<BYTE>(pt.y + 128.0f);
}

void TransformImage_NV12 | ( | const D2D1::Matrix3x2F & | mat,
 |  | const D2D_RECT_U & | rcDest,
 |  | _Inout_updates_(_Inexpressible_(2 *lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(2 *lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 284 of file Grayscale.cpp.

{
    // NV12 is planar: Y plane, followed by packed U-V plane.

    // Y plane
    for (DWORD y = 0; y < dwHeightInPixels; y++)
    {
        CopyMemory(pDest, pSrc, dwWidthInPixels);
        pDest += lDestStride;
        pSrc += lSrcStride;
    }

    // U-V plane

    // NOTE: The U-V plane has 1/2 the number of lines as the Y plane.

    // Lines above the destination rectangle.
    DWORD y = 0;
    const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);

    for ( ; y < rcDest.top/2; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }

    // Lines within the destination rectangle.
    for ( ; y < y0/2; y++)
    {
        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
            if (x >= rcDest.left && x < rcDest.right)
            {
                BYTE u = pSrc[x];
                BYTE v = pSrc[x+1];

                TransformChroma(mat, &u, &v);

                pDest[x] = u;
                pDest[x+1] = v;
            }
            else
            {
                pDest[x] = pSrc[x];
                pDest[x+1] = pSrc[x+1];
            }
        }
        pDest += lDestStride;
        pSrc += lSrcStride;
    }

    // Lines below the destination rectangle.
    for ( ; y < dwHeightInPixels/2; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }
}

void TransformImage_UYVY | ( | const D2D1::Matrix3x2F & | mat,
 |  | const D2D_RECT_U & | rcDest,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 146 of file Grayscale.cpp.

{
    DWORD y = 0;
    const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);

    // Lines above the destination rectangle.
    for ( ; y < rcDest.top; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels * 2);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }

    // Lines within the destination rectangle.
    for ( ; y < y0; y++)
    {
        WORD *pSrc_Pixel = (WORD*)pSrc;
        WORD *pDest_Pixel = (WORD*)pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
            // Byte order is U0 Y0 V0 Y1
            // Each WORD is a byte pair (U/V, Y)
            // Windows is little-endian so the order appears reversed.

            if (x >= rcDest.left && x < rcDest.right)
            {
                BYTE u = pSrc_Pixel[x] & 0x00FF;
                BYTE v = pSrc_Pixel[x+1] & 0x00FF;

                TransformChroma(mat, &u, &v);

                pDest_Pixel[x] = (pSrc_Pixel[x] & 0xFF00) | u;
                pDest_Pixel[x+1] = (pSrc_Pixel[x+1] & 0xFF00) | v;
            }
            else
            {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
                pDest_Pixel[x] = pSrc_Pixel[x];
                pDest_Pixel[x+1] = pSrc_Pixel[x+1];
#pragma warning(pop)
            }
        }

        pDest += lDestStride;
        pSrc += lSrcStride;
    }

    // Lines below the destination rectangle.
    for ( ; y < dwHeightInPixels; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels * 2);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }
}

void TransformImage_YUY2 | ( | const D2D1::Matrix3x2F & | mat,
 |  | const D2D_RECT_U & | rcDest,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 216 of file Grayscale.cpp.

{
    DWORD y = 0;
    const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);

    // Lines above the destination rectangle.
    for ( ; y < rcDest.top; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels * 2);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }

    // Lines within the destination rectangle.
    for ( ; y < y0; y++)
    {
        WORD *pSrc_Pixel = (WORD*)pSrc;
        WORD *pDest_Pixel = (WORD*)pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
            // Byte order is Y0 U0 Y1 V0
            // Each WORD is a byte pair (Y, U/V)
            // Windows is little-endian so the order appears reversed.

            if (x >= rcDest.left && x < rcDest.right)
            {
                BYTE u = pSrc_Pixel[x] >> 8;
                BYTE v = pSrc_Pixel[x+1] >> 8;

                TransformChroma(mat, &u, &v);

                pDest_Pixel[x] = (pSrc_Pixel[x] & 0x00FF) | (u<<8);
                pDest_Pixel[x+1] = (pSrc_Pixel[x+1] & 0x00FF) | (v<<8);
            }
            else
            {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
                pDest_Pixel[x] = pSrc_Pixel[x];
                pDest_Pixel[x+1] = pSrc_Pixel[x+1];
#pragma warning(pop)
            }
        }
        pDest += lDestStride;
        pSrc += lSrcStride;
    }

    // Lines below the destination rectangle.
    for ( ; y < dwHeightInPixels; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels * 2);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }
}

bool ValidateRect ( const RECT & rc )

Definition at line 1772 of file Grayscale.cpp.

{
    if (rc.left < 0 || rc.top < 0)
    {
        return false;
    }
    if (rc.left > rc.right || rc.top > rc.bottom)
    {
        return false;
    }
    return true;
}

Variable Documentation

const DWORD FOURCC_NV12 = '21VN'

Definition at line 85 of file Grayscale.cpp.

const DWORD FOURCC_UYVY = 'YVYU'

Definition at line 84 of file Grayscale.cpp.

const DWORD FOURCC_YUY2 = '2YUY'

Definition at line 83 of file Grayscale.cpp.

const GUID g_MediaSubtypes[]
Initial value:
{
    MFVideoFormat_NV12,
    MFVideoFormat_YUY2,
    MFVideoFormat_UYVY
}

Definition at line 88 of file Grayscale.cpp.

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Grayscale/Grayscale.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Grayscale
Classes | Typedefs | Functions

Grayscale.h File Reference

#include <new>
#include <mfapi.h>
#include <mftransform.h>
#include <mfidl.h>
#include <mferror.h>
#include <strsafe.h>
#include <assert.h>
#include <D2d1helper.h>
#include <wrl\implements.h>
#include <wrl\module.h>
#include <windows.media.h>
#include "GrayscaleTransform.h"

Go to the source code of this file.

Classes

class | CGrayscale

Typedefs

typedef void(* | IMAGE_TRANSFORM_FN )(const D2D1::Matrix3x2F &mat, const D2D_RECT_U &rcDest, BYTE *pDest, LONG lDestStride, const BYTE *pSrc, LONG lSrcStride, DWORD dwWidthInPixels, DWORD dwHeightInPixels)

Functions

DEFINE_GUID (CLSID_GrayscaleMFT, 0x2f3dbc05, 0xc011, 0x4a8f, 0xb2, 0x64, 0xe4, 0x2e, 0x35, 0xc6, 0x7b, 0xf4)
DEFINE_GUID (MFT_GRAYSCALE_DESTINATION_RECT, 0x7bbbb051, 0x133b, 0x41f5, 0xb6, 0xaa, 0x5a, 0xff, 0x9b, 0x33, 0xa2, 0xcb)
DEFINE_GUID (MFT_GRAYSCALE_CHROMA_ROTATION, 0xe0bade5d, 0xe4b9, 0x4689, 0x9d, 0xba, 0xe2, 0xf0, 0xd, 0x9c, 0xed, 0xe)
DEFINE_GUID (MFT_GRAYSCALE_SATURATION, 0x14782342, 0x93e8, 0x4565, 0x87, 0x2c, 0xd9, 0xa2, 0x97, 0x3d, 0x5c, 0xbf)
template<class T >
void | SafeRelease (T **ppT)

Typedef Documentation

typedef void(* IMAGE_TRANSFORM_FN)(const D2D1::Matrix3x2F &mat,const D2D_RECT_U &rcDest,BYTE *pDest,LONG lDestStride,const BYTE *pSrc,LONG lSrcStride,DWORD dwWidthInPixels,DWORD dwHeightInPixels)

Definition at line 65 of file Grayscale.h.

Function Documentation

DEFINE_GUID | ( | CLSID_GrayscaleMFT | ,
 |  | 0x2f3dbc05 | ,
 |  | 0xc011 | ,
 |  | 0x4a8f | ,
 |  | 0xb2 | ,
 |  | 0x64 | ,
 |  | 0xe4 | ,
 |  | 0x2e | ,
 |  | 0x35 | ,
 |  | 0xc6 | ,
 |  | 0x7b | ,
 |  | 0xf4 |
 | ) |  |
DEFINE_GUID | ( | MFT_GRAYSCALE_DESTINATION_RECT | ,
 |  | 0x7bbbb051 | ,
 |  | 0x133b | ,
 |  | 0x41f5 | ,
 |  | 0xb6 | ,
 |  | 0xaa | ,
 |  | 0x5a | ,
 |  | 0xff | ,
 |  | 0x9b | ,
 |  | 0x33 | ,
 |  | 0xa2 | ,
 |  | 0xcb |
 | ) |  |
DEFINE_GUID | ( | MFT_GRAYSCALE_CHROMA_ROTATION | ,
 |  | 0xe0bade5d | ,
 |  | 0xe4b9 | ,
 |  | 0x4689 | ,
 |  | 0x9d | ,
 |  | 0xba | ,
 |  | 0xe2 | ,
 |  | 0xf0 | ,
 |  | 0xd | ,
 |  | 0x9c | ,
 |  | 0xed | ,
 |  | 0xe |
 | ) |  |
DEFINE_GUID | ( | MFT_GRAYSCALE_SATURATION | ,
 |  | 0x14782342 | ,
 |  | 0x93e8 | ,
 |  | 0x4565 | ,
 |  | 0x87 | ,
 |  | 0x2c | ,
 |  | 0xd9 | ,
 |  | 0xa2 | ,
 |  | 0x97 | ,
 |  | 0x3d | ,
 |  | 0x5c | ,
 |  | 0xbf |
 | ) |  |
template<class T >
void SafeRelease ( T ** ppT )

Definition at line 55 of file Grayscale.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/CopyModule.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert
Classes

CopyModule.h File Reference

#include "DirectXVideoTransform.h"

Go to the source code of this file.

Classes

class CCopyModule
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/dllmain.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert
Namespaces | Functions

dllmain.cpp File Reference

#include <initguid.h>
#include "Invert.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CInvert)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (__in HSTRING activatibleClassId, __deref_out IActivationFactory **factory)
STDAPI | DllGetClassObject (__in REFCLSID rclsid, __in REFIID riid, __deref_out LPVOID FAR *ppv)
BOOL WINAPI | DllMain (__in_opt HINSTANCE hInstance, __in DWORD dwReason, __in_opt LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 51 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | __in HSTRING | activatibleClassId,
 |  | __deref_out IActivationFactory ** | factory
 | ) |  |

Definition at line 45 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | __in REFCLSID | rclsid,
 |  | __in REFIID | riid,
 |  | __deref_out LPVOID FAR * | ppv
 | ) |  |

Definition at line 57 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | __in_opt HINSTANCE | hInstance,
 |  | __in DWORD | dwReason,
 |  | __in_opt LPVOID | lpReserved
 | ) |  |

Definition at line 23 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        if( hInstance != NULL )
        {
            DisableThreadLibraryCalls( hInstance );
        }

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/Invert.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert
Functions

Invert.cpp File Reference

#include "Invert.h"
#include "VideoBufferLock.h"
#include "TextureLock.h"
#include "InvertModule.h"
#include "CopyModule.h"

Go to the source code of this file.

Functions

HRESULT | BufferToDXType (IMFMediaBuffer *pBuffer, _Out_ UINT *uiViewIndex, _Out_ ID3D11Texture2D **ppTexture)
HRESULT | GetDefaultStride (IMFMediaType *pType, LONG *plStride)

Function Documentation

HRESULT BufferToDXType | ( | IMFMediaBuffer * | pBuffer,
 |  | _Out_ UINT * | uiViewIndex,
 |  | _Out_ ID3D11Texture2D ** | ppTexture
 | ) |  |

Definition at line 1229 of file Invert.cpp.

{
    HRESULT hr = S_OK;
    ComPtr<IMFDXGIBuffer> spDXGIBuffer;

    hr = pBuffer->QueryInterface(__uuidof(IMFDXGIBuffer), (LPVOID *)(&spDXGIBuffer));
    if (FAILED(hr))
    {
        goto done;
    }

    hr = spDXGIBuffer->GetResource(__uuidof(ID3D11Texture2D), (LPVOID *)(ppTexture));
    if (FAILED(hr))
    {
        goto done;
    }

    hr = spDXGIBuffer->GetSubresourceIndex(uiViewIndex);
    if (FAILED(hr))
    {
        goto done;
    }

done:
    return hr;
}

HRESULT GetDefaultStride | ( | IMFMediaType * | pType,
 |  | LONG * | plStride
 | ) |  |

Definition at line 1477 of file Invert.cpp.

{
    LONG lStride = 0;

    // Try to get the default stride from the media type.
    HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
    if (FAILED(hr))
    {
        // Attribute not set. Try to calculate the default stride.
        GUID subtype = GUID_NULL;

        UINT32 width = 0;
        UINT32 height = 0;

        // Get the subtype and the image size.
        hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
        if (SUCCEEDED(hr))
        {
            hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
        }
        if (SUCCEEDED(hr))
        {
            lStride = width * 4;
        }

        // Set the attribute for later reference.
        if (SUCCEEDED(hr))
        {
            (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
        }
    }
    if (SUCCEEDED(hr))
    {
        *plStride = lStride;
    }
    return hr;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/Invert.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert
Classes | Functions

Invert.h File Reference

#include <new>
#include <mfapi.h>
#include <mftransform.h>
#include <mfidl.h>
#include <mferror.h>
#include <strsafe.h>
#include <assert.h>
#include <wrl\implements.h>
#include <wrl\module.h>
#include <wrl\client.h>
#include <windows.media.h>
#include <D3D11.h>
#include "DirectXVideoTransform.h"
#include "InvertTransform.h"

Go to the source code of this file.

Classes

class CInvert

Functions

DEFINE_GUID (CLSID_InvertMFT, 0xf1bf74f0, 0x65f4, 0x4f47, 0x92, 0x5c, 0xe8, 0xb5, 0x64, 0xa9, 0xa8, 0x7e)

Function Documentation

DEFINE_GUID | ( | CLSID_InvertMFT | ,
 |  | 0xf1bf74f0 | ,
 |  | 0x65f4 | ,
 |  | 0x4f47 | ,
 |  | 0x92 | ,
 |  | 0x5c | ,
 |  | 0xe8 | ,
 |  | 0xb5 | ,
 |  | 0x64 | ,
 |  | 0xa9 | ,
 |  | 0xa8 | ,
 |  | 0x7e |
 | ) |  |
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/InvertModule.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert
Classes | Functions

InvertModule.cpp File Reference

#include "InvertModule.h"
#include "PixelShader.hps"
#include "VertexShader.hvs"

Go to the source code of this file.

Classes

struct | ScreenVertex

Functions

HRESULT | CreateShaderInputView (ID3D11Texture2D *pTexture, UINT uiIndex, ID3D11Device *pDevice, ID3D11ShaderResourceView **ppSRV)
HRESULT | CreateShaderOutputView (ID3D11Texture2D *pTexture, UINT uiIndex, ID3D11Device *pDevice, ID3D11RenderTargetView **ppRTV)

Function Documentation

HRESULT CreateShaderInputView | ( | ID3D11Texture2D * | pTexture,
 |  | UINT | uiIndex,
 |  | ID3D11Device * | pDevice,
 |  | ID3D11ShaderResourceView ** | ppSRV
 | ) |  |

Definition at line 135 of file InvertModule.cpp.

{
    D3D11_TEXTURE2D_DESC textureDesc;
    D3D11_SHADER_RESOURCE_VIEW_DESC viewDesc;

    ZeroMemory( &viewDesc, sizeof( viewDesc ) );

    pTexture->GetDesc( &textureDesc );

    viewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;

    if ( textureDesc.ArraySize > 1 )
    {
        // Texture array, use the subresource index
        viewDesc.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2DARRAY;
        viewDesc.Texture2DArray.FirstArraySlice = uiIndex;
        viewDesc.Texture2DArray.ArraySize = 1;
        viewDesc.Texture2DArray.MipLevels = 1;
        viewDesc.Texture2DArray.MostDetailedMip = 0;
    }
    else
    {
        viewDesc.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
        viewDesc.Texture2D.MostDetailedMip = 0;
        viewDesc.Texture2D.MipLevels = 1;
    }

    return pDevice->CreateShaderResourceView(pTexture,
                                             &viewDesc,
                                             ppSRV);
}

HRESULT CreateShaderOutputView | ( | ID3D11Texture2D * | pTexture,
 |  | UINT | uiIndex,
 |  | ID3D11Device * | pDevice,
 |  | ID3D11RenderTargetView ** | ppRTV
 | ) |  |

Definition at line 167 of file InvertModule.cpp.

{
    D3D11_TEXTURE2D_DESC textureDesc;
    D3D11_RENDER_TARGET_VIEW_DESC viewDesc;

    ZeroMemory( &viewDesc, sizeof( viewDesc ) );

    pTexture->GetDesc( &textureDesc );

    viewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;

    if ( textureDesc.ArraySize > 1 )
    {
        // Texture array, use the subresource index
        viewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2DARRAY;
        viewDesc.Texture2DArray.FirstArraySlice = uiIndex;
        viewDesc.Texture2DArray.ArraySize = 1;
        viewDesc.Texture2DArray.MipSlice = 0;
    }
    else
    {
        viewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
        viewDesc.Texture2D.MipSlice = 0;
    }

    return pDevice->CreateRenderTargetView(pTexture,
                                           &viewDesc,
                                           ppRTV );

}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/InvertModule.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert
Classes

InvertModule.h File Reference

#include "DirectXVideoTransform.h"
#include <wrl\client.h>

Go to the source code of this file.

Classes

class CInvertModule
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/TextureLock.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert
Classes

TextureLock.h File Reference

#include <assert.h>
#include <D3D11.h>
#include <wrl\client.h>

Go to the source code of this file.

Classes

class TextureLock
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/VideoBufferLock.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert
Classes

VideoBufferLock.h File Reference

#include <mfapi.h>
#include <mftransform.h>
#include <mfidl.h>
#include <assert.h>
#include <wrl\client.h>

Go to the source code of this file.

Classes

class VideoBufferLock
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Decoder
Defines | Functions | Variables

decoder.cpp File Reference

#include "decoder.h"
#include "BufferLock.h"
#include <strsafe.h>

Go to the source code of this file.

Defines

#define | LODWORD(x) ((DWORD)(((DWORD_PTR)(x)) & 0xffffffff))

Functions

void | OurFillRect (PBYTE pbScanline0, DWORD dwWidth, DWORD dwHeight, LONG lStrideInBytes, COLORREF color)

Variables

const UINT32 | MAX_VIDEO_HEIGHT = 4095
const UINT32 | MAX_VIDEO_WIDTH = 4095

Define Documentation

#define LODWORD ( x ) ((DWORD)(((DWORD_PTR)(x)) & 0xffffffff))

Definition at line 22 of file decoder.cpp.

Function Documentation

void OurFillRect | ( | PBYTE | pbScanline0,
 |  | DWORD | dwWidth,
 |  | DWORD | dwHeight,
 |  | LONG | lStrideInBytes,
 |  | COLORREF | color
 | ) |  |

Definition at line 1439 of file decoder.cpp.

{
    PBYTE pbPixels = pbScanline0;

    // For just filling we don't care which way up the bitmap is -
    // we just start at pbData
    for(DWORD dwCount = 0; dwCount < dwHeight; dwCount++) {
        DWORD *pWord = (DWORD *)pbPixels;

        for(DWORD dwPixel = 0; dwPixel < dwWidth; dwPixel++) {
            pWord[dwPixel] = (DWORD)color;
        }

        //  biWidth is the stride
        pbPixels += lStrideInBytes;
    }
}

Variable Documentation

const UINT32 MAX_VIDEO_HEIGHT = 4095

Definition at line 26 of file decoder.cpp.

const UINT32 MAX_VIDEO_WIDTH = 4095

Definition at line 25 of file decoder.cpp.

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Decoder
Classes | Functions | Variables

decoder.h File Reference

#include <wrl\implements.h>
#include <windows.media.h>
#include <mftransform.h>
#include <mfapi.h>
#include <mferror.h>
#include <assert.h>
#include "MPEG1Decoder.h"

Go to the source code of this file.

Classes

class | CDecoder
class | CStreamState

Functions

template<class T >
void | SafeRelease (T **ppT)

Variables

const DWORD | MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12

Function Documentation

template<class T >
void SafeRelease ( T ** ppT )

Definition at line 27 of file decoder.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Variable Documentation

const DWORD MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12

Definition at line 24 of file decoder.h.

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/dll.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Decoder
Namespaces | Functions

dll.cpp File Reference

#include <wrl\module.h>
#include "Decoder.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CDecoder)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 48 of file dll.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 42 of file dll.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 54 of file dll.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 23 of file dll.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/dllmain.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source
Namespaces | Functions

dllmain.cpp File Reference

#include <wrl\module.h>
#include "MPEG1Src.h"
#include "MPEG1ByteStreamHandler.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CMPEG1ByteStreamHandler)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 49 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 43 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 55 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 24 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source
Functions

MPEG1Src.cpp File Reference

#include "MPEG1Src.h"

Go to the source code of this file.

Functions

HRESULT | CreateAudioMediaType (const MPEG1AudioFrameHeader &audioHeader, IMFMediaType **ppType)
HRESULT | CreateVideoMediaType (const MPEG1VideoSeqHeader &videoSeqHdr, IMFMediaType **ppType)
HRESULT | GetStreamMajorType (IMFStreamDescriptor *pSD, GUID *pguidMajorType)
BOOL | SampleRequestMatch (SourceOp *pOp1, SourceOp *pOp2)

Function Documentation

HRESULT CreateAudioMediaType | ( | const MPEG1AudioFrameHeader & | audioHeader,
 |  | IMFMediaType ** | ppType
 | ) |  |

Definition at line 2490 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;
    IMFMediaType *pType = NULL;

    MPEG1WAVEFORMAT format;
    ZeroMemory(&format, sizeof(format));

    format.wfx.wFormatTag = WAVE_FORMAT_MPEG;
    format.wfx.nChannels = audioHeader.nChannels;
    format.wfx.nSamplesPerSec = audioHeader.dwSamplesPerSec;
    if (audioHeader.dwBitRate > 0)
    {
        format.wfx.nAvgBytesPerSec = (audioHeader.dwBitRate * 1000) / 8;
    }
    format.wfx.nBlockAlign = audioHeader.nBlockAlign;
    format.wfx.wBitsPerSample = 0; // Not used.
    format.wfx.cbSize = sizeof(MPEG1WAVEFORMAT) - sizeof(WAVEFORMATEX);

    // MPEG-1 audio layer.
    switch (audioHeader.layer)
    {
    case MPEG1_Audio_Layer1:
        format.fwHeadLayer = ACM_MPEG_LAYER1;
        break;

    case MPEG1_Audio_Layer2:
        format.fwHeadLayer = ACM_MPEG_LAYER2;
        break;

    case MPEG1_Audio_Layer3:
        format.fwHeadLayer = ACM_MPEG_LAYER3;
        break;
    };

    format.dwHeadBitrate = audioHeader.dwBitRate * 1000;

    // Mode
    switch (audioHeader.mode)
    {
    case MPEG1_Audio_Stereo:
        format.fwHeadMode = ACM_MPEG_STEREO;
        break;

    case MPEG1_Audio_JointStereo:
        format.fwHeadMode = ACM_MPEG_JOINTSTEREO;
        break;

    case MPEG1_Audio_DualChannel:
        format.fwHeadMode = ACM_MPEG_DUALCHANNEL;
        break;

    case MPEG1_Audio_SingleChannel:
        format.fwHeadMode = ACM_MPEG_SINGLECHANNEL;
        break;
    };

    if (audioHeader.mode == ACM_MPEG_JOINTSTEREO)
    {
        // Convert the 'mode_extension' field to the correct MPEG1WAVEFORMAT value.
        if (audioHeader.modeExtension <= 0x03)
        {
            format.fwHeadModeExt = 0x01 << audioHeader.modeExtension;
        }
    }

    // Convert the 'emphasis' field to the correct MPEG1WAVEFORMAT value.
    if (audioHeader.emphasis <= 0x03)
    {
        format.wHeadEmphasis = audioHeader.emphasis + 1;
    }

    // The flags translate directly.
    format.fwHeadFlags = audioHeader.wFlags;
    // Add the "MPEG-1" flag, although it's somewhat redundant.
    format.fwHeadFlags |= ACM_MPEG_ID_MPEG1;

    // Use the structure to initialize the Media Foundation media type.
    hr = MFCreateMediaType(&pType);
    if (SUCCEEDED(hr))
    {
        hr = MFInitMediaTypeFromWaveFormatEx(pType, (const WAVEFORMATEX*)&format, sizeof(format));
    }

    if (SUCCEEDED(hr))
    {
        *ppType = pType;
        (*ppType)->AddRef();
    }

    SafeRelease(&pType);
    return hr;
}

HRESULT CreateVideoMediaType | ( | const MPEG1VideoSeqHeader & | videoSeqHdr,
 |  | IMFMediaType ** | ppType
 | ) |  |

Definition at line 2387 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    IMFMediaType *pType = NULL;

    hr = MFCreateMediaType(&pType);

    if (SUCCEEDED(hr))
    {
        hr = pType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
    }

    // Subtype = MPEG-1 payload
    if (SUCCEEDED(hr))
    {
        hr = pType->SetGUID(MF_MT_SUBTYPE, MFVideoFormat_MPG1);
    }

    // Format details.
    if (SUCCEEDED(hr))
    {
        // Frame size

        hr = MFSetAttributeSize(
            pType,
            MF_MT_FRAME_SIZE,
            videoSeqHdr.width,
            videoSeqHdr.height
            );
    }
    if (SUCCEEDED(hr))
    {
        // Frame rate

        hr = MFSetAttributeRatio(
            pType,
            MF_MT_FRAME_RATE,
            videoSeqHdr.frameRate.Numerator,
            videoSeqHdr.frameRate.Denominator
            );
    }
    if (SUCCEEDED(hr))
    {
        // Pixel aspect ratio

        hr = MFSetAttributeRatio(
            pType,
            MF_MT_PIXEL_ASPECT_RATIO,
            videoSeqHdr.pixelAspectRatio.Numerator,
            videoSeqHdr.pixelAspectRatio.Denominator
            );
    }
    if (SUCCEEDED(hr))
    {
        // Average bit rate

        hr = pType->SetUINT32(MF_MT_AVG_BITRATE, videoSeqHdr.bitRate);
    }
    if (SUCCEEDED(hr))
    {

        // Interlacing (progressive frames)

        hr = pType->SetUINT32(MF_MT_INTERLACE_MODE, (UINT32)MFVideoInterlace_Progressive);
    }
    if (SUCCEEDED(hr))
    {
        // Sequence header.

        hr = pType->SetBlob(
            MF_MT_MPEG_SEQUENCE_HEADER,
            videoSeqHdr.header,             // Byte array
            videoSeqHdr.cbHeader            // Size
            );
    }

    if (SUCCEEDED(hr))
    {
        *ppType = pType;
        (*ppType)->AddRef();
    }

    SafeRelease(&pType);
    return hr;
}

HRESULT GetStreamMajorType | ( | IMFStreamDescriptor * | pSD,
 |  | GUID * | pguidMajorType
 | ) |  |

Definition at line 2585 of file MPEG1Src.cpp.

{
    if (pSD == NULL) { return E_POINTER; }
    if (pguidMajorType == NULL) { return E_POINTER; }

    HRESULT hr = S_OK;
    IMFMediaTypeHandler *pHandler = NULL;

    hr = pSD->GetMediaTypeHandler(&pHandler);
    if (SUCCEEDED(hr))
    {
        hr = pHandler->GetMajorType(pguidMajorType);
    }
    SafeRelease(&pHandler);
    return hr;
}

BOOL SampleRequestMatch | ( | SourceOp * | pOp1,
 |  | SourceOp * | pOp2
 | ) |  |

Definition at line 2603 of file MPEG1Src.cpp.

{
    if ((pOp1 == NULL) && (pOp2 == NULL))
    {
        return TRUE;
    }
    else if ((pOp1 == NULL) || (pOp2 == NULL))
    {
        return FALSE;
    }
    else
    {
        return (pOp1->Data().ulVal == pOp2->Data().ulVal);
    }
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source
Classes | Defines | Typedefs | Enumerations | Functions | Variables

MPEG1Src.h File Reference

#include <new.h>
#include <windows.h>
#include <assert.h>
#include <wrl\implements.h>
#include <windows.media.h>
#include <mftransform.h>
#include <mfapi.h>
#include <mfobjects.h>
#include <mfidl.h>
#include <mferror.h>
#include "linklist.h"
#include "asynccb.h"
#include "OpQueue.h"
#include "Parse.h"
#include "MPEG1Stream.h"
#include "Parse.h"

Go to the source code of this file.

Classes

class | CMPEG1Source
class | SetRateOp
class | SourceOp
class | StartOp
class | StreamList

Defines

#define | _ASSERTE assert

Typedefs

typedef ComPtrList< IMFSample > | SampleList
typedef ComPtrList< IUnknown,
true > 		TokenList

Enumerations

enum SourceState {
STATE_INVALID, STATE_OPENING, STATE_STOPPED, STATE_PAUSED,
STATE_STARTED, STATE_SHUTDOWN, STATE_INVALID, STATE_OPENING,
STATE_STOPPED, STATE_PAUSED, STATE_STARTED, STATE_SHUTDOWN
}

Functions

void | DllAddRef ()
void | DllRelease ()
template<class T >
void | SafeRelease (T **ppT)

Variables

const DWORD | INITIAL_BUFFER_SIZE = 4 * 1024
const UINT32 | MAX_STREAMS = 32
const DWORD | READ_SIZE = 4 * 1024
const DWORD | SAMPLE_QUEUE = 2

Define Documentation

#define _ASSERTE assert

Definition at line 24 of file MPEG1Src.h.

Typedef Documentation

typedef ComPtrList<IMFSample> SampleList

Definition at line 64 of file MPEG1Src.h.

typedef ComPtrList<IUnknown, true> TokenList

Definition at line 67 of file MPEG1Src.h.

Enumeration Type Documentation

enum SourceState
Enumerator:
STATE_INVALID
STATE_OPENING
STATE_STOPPED
STATE_PAUSED
STATE_STARTED
STATE_SHUTDOWN
STATE_INVALID
STATE_OPENING
STATE_STOPPED
STATE_PAUSED
STATE_STARTED
STATE_SHUTDOWN

Definition at line 69 of file MPEG1Src.h.

{
    STATE_INVALID,      // Initial state. Have not started opening the stream.
    STATE_OPENING,      // BeginOpen is in progress.
    STATE_STOPPED,
    STATE_PAUSED,
    STATE_STARTED,
    STATE_SHUTDOWN
};

Function Documentation

void DllAddRef ( )
void DllRelease ( )
template<class T >
void SafeRelease ( T ** ppT )

Definition at line 47 of file MPEG1Src.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Variable Documentation

const DWORD INITIAL_BUFFER_SIZE = 4 * 1024

Definition at line 174 of file MPEG1Src.h.

const UINT32 MAX_STREAMS = 32

Definition at line 84 of file MPEG1Src.h.

const DWORD READ_SIZE = 4 * 1024

Definition at line 175 of file MPEG1Src.h.

const DWORD SAMPLE_QUEUE = 2

Definition at line 176 of file MPEG1Src.h.

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source
Defines | Functions

Parse.cpp File Reference

#include "MPEG1Src.h"
#include "Parse.h"

Go to the source code of this file.

Defines

#define | HAS_FLAG(b, flag) (((b) & (flag)) == (flag))
#define | htonl(x)

Functions

HRESULT | AdvanceBufferPointer (const BYTE *&pData, DWORD &cbBufferSize, DWORD cbAdvance)
HRESULT | GetAudioBitRate (MPEG1AudioLayer layer, BYTE index, DWORD *pdwBitRate)
HRESULT | GetFrameRate (BYTE frameRateCode, MFRatio *pRatio)
HRESULT | GetPixelAspectRatio (BYTE pixelAspectCode, MFRatio *pRatio)
HRESULT | GetSamplingFrequency (BYTE code, DWORD *pdwSamplesPerSec)
DWORD | MAKE_DWORD (const BYTE *pData)
DWORD | MAKE_DWORD_HOSTORDER (const BYTE *pData)
WORD | MAKE_WORD (BYTE b1, BYTE b2)
HRESULT | ParsePTS (const BYTE *pData, LONGLONG *pPTS)
HRESULT | ParseStreamData (const BYTE *pData, MPEG1StreamHeader &header)
HRESULT | ParseStreamId (BYTE id, StreamType *pType, BYTE *pStreamNum)
HRESULT | ReadAudioFrameHeader (const BYTE *pData, DWORD cbData, MPEG1AudioFrameHeader &audioHeader, DWORD *pAte)
HRESULT | ReadVideoSequenceHeader (_In_reads_bytes_(cbData) const BYTE *pData, DWORD cbData, MPEG1VideoSeqHeader &seqHeader, _Out_ DWORD *pAte)
HRESULT | ValidateBufferSize (DWORD cbBufferSize, DWORD cbMinRequiredSize)

Define Documentation

#define HAS_FLAG | ( | b,
 |  | flag |
 | ) |  | (((b) & (flag)) == (flag))

Definition at line 19 of file Parse.cpp.

#define htonl ( x )
Value:
((((x) >> 24) & 0x000000FFL) | \
    (((x) >>  8) & 0x0000FF00L) | \
    (((x) <<  8) & 0x00FF0000L) | \
    (((x) << 24) & 0xFF000000L))

Definition at line 21 of file Parse.cpp.

Function Documentation

HRESULT AdvanceBufferPointer | ( | const BYTE *& | pData,
 |  | DWORD & | cbBufferSize,
 |  | DWORD | cbAdvance |
 | ) |  |  | [inline]

Definition at line 59 of file Parse.cpp.

{
    assert(cbBufferSize >= cbAdvance);
    if (cbBufferSize < cbAdvance)
    {
        return E_FAIL;
    }
    cbBufferSize -= cbAdvance;
    pData += cbAdvance;
    return S_OK;
}

HRESULT GetAudioBitRate | ( | MPEG1AudioLayer | layer,
 |  | BYTE | index,
 |  | DWORD * | pdwBitRate
 | ) |  |

Definition at line 1255 of file Parse.cpp.

{
    const DWORD MAX_BITRATE_INDEX = 14;

    // Table of bit rates.
    const DWORD bitrate[3][ (MAX_BITRATE_INDEX+1) ] =
    {
        { 0, 32, 64, 96, 128, 160, 192, 224, 256, 288, 320, 352, 384, 416, 448 },    // Layer I
        { 0, 32, 48, 56, 64, 80, 96, 112, 128, 160, 192, 224, 256, 320, 384 },       // Layer II
        { 0, 32, 40, 48, 56, 64, 80, 96, 112, 128, 160, 192, 224, 256, 320 }         // Layer III
    };

    if (layer < MPEG1_Audio_Layer1 || layer > MPEG1_Audio_Layer3)
    {
        return E_INVALIDARG;
    }
    if (index > MAX_BITRATE_INDEX)
    {
        return E_INVALIDARG;
    }

    *pdwBitRate = bitrate[layer][index];

    return S_OK;
}

HRESULT GetFrameRate | ( | BYTE | frameRateCode,
 |  | MFRatio * | pRatio
 | ) |  |

Definition at line 1074 of file Parse.cpp.

{
    MFRatio frameRates[] =
    {
        { 0, 0 },           // invalid
        { 24000, 1001 },    // 23.976 fps
        { 24, 1 },
        { 25, 1 },
        { 30000, 1001 },    // 29.97 fps
        { 50, 1 },
        { 60000, 1001 },    // 59.94 fps
        { 60, 1 }
    };

    if (frameRateCode < 1 || frameRateCode >= ARRAYSIZE(frameRates))
    {
        return MF_E_INVALIDTYPE;
    }

    pRatio->Numerator = frameRates[frameRateCode].Numerator;
    pRatio->Denominator = frameRates[frameRateCode].Denominator;

    return S_OK;
}

HRESULT GetPixelAspectRatio | ( | BYTE | pixelAspectCode,
 |  | MFRatio * | pRatio
 | ) |  |

Definition at line 1107 of file Parse.cpp.

{
    DWORD height[] = { 0, 10000, 6735, 7031, 7615, 8055, 8437, 8935, 9157,
        9815, 10255, 10695, 10950, 11575, 12015 };

    const DWORD width = 10000;

    if (pixelAspectCode < 1 || pixelAspectCode >= ARRAYSIZE(height))
    {
        return MF_E_INVALIDTYPE;
    }

    pRatio->Numerator = height[pixelAspectCode];
    pRatio->Denominator = width;

    return S_OK;

}

HRESULT GetSamplingFrequency | ( | BYTE | code,
 |  | DWORD * | pdwSamplesPerSec |
 | ) |  |  | [inline]

Definition at line 1289 of file Parse.cpp.

{
    switch (code)
    {
    case 0:
        *pdwSamplesPerSec = 44100;
        break;
    case 1:
        *pdwSamplesPerSec = 48000;
        break;
    case 2:
        *pdwSamplesPerSec = 32000;
        break;
    default:
        return E_FAIL;
    }
    return S_OK;
}

DWORD MAKE_DWORD ( const BYTE * pData ) [inline]

Definition at line 41 of file Parse.cpp.

{
    return htonl( MAKE_DWORD_HOSTORDER(pData) );
}

DWORD MAKE_DWORD_HOSTORDER ( const BYTE * pData ) [inline]

Definition at line 34 of file Parse.cpp.

{
    return ((DWORD*)pData)[0];
}

WORD MAKE_WORD | ( | BYTE | b1,
 |  | BYTE | b2 |
 | ) |  |  | [inline]

Definition at line 27 of file Parse.cpp.

{
    return ((b1 << 8) | b2);
}

HRESULT ParsePTS | ( | const BYTE * | pData,
 |  | LONGLONG * | pPTS
 | ) |  |

Definition at line 797 of file Parse.cpp.

{
    BYTE byte1 = pData[0];
    WORD word1 = MAKE_WORD(pData[1], pData[2]);
    WORD word2 = MAKE_WORD(pData[3], pData[4]);

    // Check marker bits.
    // The first byte can be '0010xxx1' or '0x11xxxx1'
    if (((byte1 & 0xE1) != 0x21) ||
        ((word1 & 0x01) != 0x01) ||
        ((word2 & 0x01) != 0x01) )
    {
        return E_FAIL;
    }

    LARGE_INTEGER li;

    // The PTS is 33 bits, so bit 32 goes in the high-order DWORD
    li.HighPart = (byte1 & 0x08) >> 3;

    li.LowPart = (static_cast<DWORD>(byte1 & 0x06) << 29) |
        (static_cast<DWORD>(word1 & 0xFFFE) << 14) |
        (static_cast<DWORD>(word2) >> 1);

    *pPTS = li.QuadPart;
    return S_OK;
}

HRESULT ParseStreamData | ( | const BYTE * | pData,
 |  | MPEG1StreamHeader & | header
 | ) |  |

Definition at line 832 of file Parse.cpp.

{
    // Check marker bits.
    if ( (pStreamInfo[1] & 0xC0) != 0xC0 )
    {
        return E_FAIL; // Invalid bits
    }

    HRESULT hr = S_OK;
    BYTE id = 0;
    BYTE num = 0;
    DWORD bound = 0;
    StreamType type = StreamType_Unknown;

    // The id is a stream code plus (for some types) a stream number, bitwise-OR'd.

    id = pStreamInfo[0];

    hr = ParseStreamId(id, &type, &num);
    if (FAILED(hr))
    {
        return hr;
    }

    // Calculate STD bound.
    bound = pStreamInfo[2] | ((pStreamInfo[1] & 0x1F) << 8);

    if (pStreamInfo[1] & 0x20)
    {
        bound *= 1024;
    }
    else
    {
        bound *= 128;
    }

    header.stream_id = id;
    header.type = type;
    header.number = num;
    header.sizeBound = bound;

    return S_OK;
}

HRESULT ParseStreamId | ( | BYTE | id,
 |  | StreamType * | pType,
 |  | BYTE * | pStreamNum
 | ) |  |

Definition at line 889 of file Parse.cpp.

{
    StreamType type = StreamType_Unknown;
    BYTE num = 0;

    switch (id)
    {
    case MPEG1_STREAMTYPE_ALL_AUDIO:
        type = StreamType_AllAudio;
        break;

    case MPEG1_STREAMTYPE_ALL_VIDEO:
        type = StreamType_AllVideo;
        break;

    case MPEG1_STREAMTYPE_RESERVED:
        type = StreamType_Reserved;
        break;

    case MPEG1_STREAMTYPE_PRIVATE1:
        type = StreamType_Private1;
        break;

    case MPEG1_STREAMTYPE_PADDING:
        type = StreamType_Padding;
        break;

    case MPEG1_STREAMTYPE_PRIVATE2:
        type = StreamType_Private2;
        break;

    default:
        if ((id & 0xE0) == MPEG1_STREAMTYPE_AUDIO_MASK)
        {
            type = StreamType_Audio;
            num = id & 0x1F;
        }
        else if ((id & 0xF0) == MPEG1_STREAMTYPE_VIDEO_MASK)
        {
            type = StreamType_Video;
            num = id & 0x0F;
        }
        else if ((id & 0xF0) == MPEG1_STREAMTYPE_DATA_MASK)
        {
            type = StreamType_Data;
            num = id & 0x0F;
        }
        else
        {
            return E_FAIL; // Unknown stream ID code.
        }
    }

    *pType = type;
    *pStreamNum = num;
    return S_OK;
}

HRESULT ReadAudioFrameHeader | ( | const BYTE * | pData,
 |  | DWORD | cbData,
 |  | MPEG1AudioFrameHeader & | audioHeader,
 |  | DWORD * | pAte
 | ) |  |

Definition at line 1136 of file Parse.cpp.

{
    HRESULT hr = S_OK;
    MPEG1AudioFrameHeader header;
    ZeroMemory(&header, sizeof(header));

    BYTE bitRateIndex = 0;
    BYTE samplingIndex = 0;

    *pAte = 0;

    if (cbData < MPEG1_AUDIO_FRAME_HEADER_SIZE)
    {
        return S_FALSE;
    }

    if (pData[0] != 0xFF)
    {
        return E_FAIL;
    }

    if (!HAS_FLAG(pData[1], 0xF8))
    {
        return E_FAIL;
    }

    // Layer bits
    switch (pData[1] & 0x06)
    {
    case 0x00:
        return E_FAIL;

    case 0x06:
        header.layer = MPEG1_Audio_Layer1;
        break;

    case 0x04:
        header.layer = MPEG1_Audio_Layer2;
        break;

    case 0x02:
        header.layer = MPEG1_Audio_Layer3;
        break;

    default:
        return E_UNEXPECTED; // Cannot actually happen, given our bitmask above.
    }

    bitRateIndex = (pData[2] & 0xF0) >> 4;
    samplingIndex = (pData[2] & 0x0C) >> 2;

    // Bit rate.
    // Note: Accoring to ISO/IEC 11172-3, some combinations of bitrate and
    // mode are not valid. However, this is up to the decoder to validate.
    hr = GetAudioBitRate(header.layer, bitRateIndex, &header.dwBitRate);

    // Sampling frequency.
    if (SUCCEEDED(hr))
    {
        hr = GetSamplingFrequency(samplingIndex, &header.dwSamplesPerSec);
    }

    if (SUCCEEDED(hr))
    {
        header.mode = static_cast<MPEG1AudioMode>((pData[3] & 0xC0) >> 6);
        header.modeExtension = (pData[3] & 0x30) >> 4;
        header.emphasis = (pData[3] & 0x03);

        // Parse the various bit flags.
        if (HAS_FLAG(pData[1], 0x01))
        {
            header.wFlags |= MPEG1_AUDIO_PROTECTION_BIT;
        }
        if (HAS_FLAG(pData[2], 0x01))
        {
            header.wFlags |= MPEG1_AUDIO_PRIVATE_BIT;
        }
        if (HAS_FLAG(pData[3], 0x08))
        {
            header.wFlags |= MPEG1_AUDIO_COPYRIGHT_BIT;
        }
        if (HAS_FLAG(pData[3], 0x04))
        {
            header.wFlags |= MPEG1_AUDIO_ORIGINAL_BIT;
        }

        if (header.mode == MPEG1_Audio_SingleChannel)
        {
            header.nChannels = 1;
        }
        else
        {
            header.nChannels = 2;
        }

        header.nBlockAlign = 1;

        CopyMemory(&audioHeader, &header, sizeof(audioHeader));
    }

    return  hr;

};

HRESULT ReadVideoSequenceHeader | ( | _In_reads_bytes_(cbData) const BYTE * | pData,
 |  | DWORD | cbData,
 |  | MPEG1VideoSeqHeader & | seqHeader,
 |  | _Out_ DWORD * | pAte
 | ) |  |

Definition at line 957 of file Parse.cpp.

{
    DWORD cbPadding = 0;

    if (pAte == nullptr || pData == nullptr)
    {
        return E_INVALIDARG;
    }

    *pAte = 0;

    // Skip to the sequence header code.
    while ( (cbPadding + 4) <= cbData && ((DWORD*)pData)[0] == 0 )
    {
        pData += 4;
        cbPadding += 4;
    }

    cbData -= cbPadding;

    // Check for the minimum size buffer.
    if (cbData < MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE)
    {
        *pAte = cbPadding;
        return S_FALSE;
    }

    // Validate the sequence header code.
    if (MAKE_DWORD(pData) != MPEG1_SEQUENCE_HEADER_CODE)
    {
        return E_FAIL;
    }

    // Calculate the actual required size.
    DWORD cbRequired = MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE;

    // Look for quantization matrices.
    if ( HAS_FLAG(pData[11], 0x02) )
    {
        // Intra quantization matrix is TRUE.
        cbRequired += 64;
    }
    // Intra is FALSE, look for non-intra flag
    else if ( HAS_FLAG(pData[11], 0x01) )
    {
        cbRequired += 64;
    }

    if (cbData < cbRequired)
    {
        return S_FALSE;
    }

    ZeroMemory(&seqHeader, sizeof(seqHeader));

    // Check the marker bit.
    if ( !HAS_FLAG(pData[10], 0x20) )
    {
        return E_FAIL;
    }

    BYTE parCode = pData[7] >> 4;
    BYTE frameRateCode = pData[7] & 0x0F;

    if (FAILED(GetPixelAspectRatio(parCode, &seqHeader.pixelAspectRatio)))
    {
        return E_FAIL;
    }

    if (FAILED(GetFrameRate(frameRateCode, &seqHeader.frameRate)))
    {
        return E_FAIL;
    }

    seqHeader.width = (pData[4] << 4) | (pData[5] >> 4) ;
    seqHeader.height = ((pData[5] & 0x0F) << 8) | (pData[6]);
    seqHeader.bitRate = (pData[8] << 10) | (pData[9] << 2) | (pData[10] >> 6);

    if (seqHeader.bitRate == 0)
    {
        return E_FAIL;  // Not allowed.
    }
    else if (seqHeader.bitRate == 0x3FFFF)
    {
        seqHeader.bitRate = 0; // Variable bit-rate.
    }
    else
    {
        seqHeader.bitRate = seqHeader.bitRate * 400; // Units of 400 bps
    }

    seqHeader.cbVBV_Buffer = ( ((pData[10] & 0x1F) << 5) | (pData[11] >> 3) ) * 2048;
    seqHeader.bConstrained = HAS_FLAG(pData[11], 0x04);

    seqHeader.cbHeader = cbRequired;
    CopyMemory(seqHeader.header, pData, cbRequired);

    *pAte = cbRequired + cbPadding;

    return S_OK;
}

HRESULT ValidateBufferSize | ( | DWORD | cbBufferSize,
 |  | DWORD | cbMinRequiredSize |
 | ) |  |  | [inline]

Definition at line 73 of file Parse.cpp.

{
    return (cbBufferSize >= cbMinRequiredSize? S_OK : E_FAIL);
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source
Classes | Enumerations | Functions | Variables

Parse.h File Reference

Go to the source code of this file.

Classes

class | Buffer
struct | MPEG1AudioFrameHeader
struct | MPEG1PacketHeader
struct | MPEG1StreamHeader
struct | MPEG1SystemHeader
struct | MPEG1VideoSeqHeader
class | Parser

Enumerations

enum MPEG1AudioFlags {
MPEG1_AUDIO_PRIVATE_BIT = 0x01, MPEG1_AUDIO_COPYRIGHT_BIT = 0x02, MPEG1_AUDIO_ORIGINAL_BIT = 0x04, MPEG1_AUDIO_PROTECTION_BIT = 0x08,
MPEG1_AUDIO_PRIVATE_BIT = 0x01, MPEG1_AUDIO_COPYRIGHT_BIT = 0x02, MPEG1_AUDIO_ORIGINAL_BIT = 0x04, MPEG1_AUDIO_PROTECTION_BIT = 0x08
}
enum MPEG1AudioLayer {
MPEG1_Audio_Layer1 = 0, MPEG1_Audio_Layer2, MPEG1_Audio_Layer3, MPEG1_Audio_Layer1 = 0,
MPEG1_Audio_Layer2, MPEG1_Audio_Layer3
}
enum MPEG1AudioMode {
MPEG1_Audio_Stereo = 0, MPEG1_Audio_JointStereo, MPEG1_Audio_DualChannel, MPEG1_Audio_SingleChannel,
MPEG1_Audio_Stereo = 0, MPEG1_Audio_JointStereo, MPEG1_Audio_DualChannel, MPEG1_Audio_SingleChannel
}
enum StreamType {
StreamType_Unknown, StreamType_AllAudio, StreamType_AllVideo, StreamType_Reserved,
StreamType_Private1, StreamType_Padding, StreamType_Private2, StreamType_Audio,
StreamType_Video, StreamType_Data, StreamType_Unknown, StreamType_AllAudio,
StreamType_AllVideo, StreamType_Reserved, StreamType_Private1, StreamType_Padding,
StreamType_Private2, StreamType_Audio, StreamType_Video, StreamType_Data
}

Functions

HRESULT | ReadAudioFrameHeader (const BYTE *pData, DWORD cbData, MPEG1AudioFrameHeader &audioHeader, DWORD *pAte)
HRESULT | ReadVideoSequenceHeader (_In_reads_bytes_(cbData) const BYTE *pData, DWORD cbData, MPEG1VideoSeqHeader &seqHeader, _Out_ DWORD *pAte)

Variables

const DWORD | MPEG1_AUDIO_FRAME_HEADER_SIZE = 4
const DWORD | MPEG1_MAX_PACKET_SIZE = 65535 + 6
const DWORD | MPEG1_PACK_HEADER_SIZE = 12
const DWORD | MPEG1_PACK_START_CODE = 0x000001BA
const DWORD | MPEG1_PACKET_HEADER_MAX_SIZE = 34
const DWORD | MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE = 16
const DWORD | MPEG1_PACKET_HEADER_MIN_SIZE = 6
const DWORD | MPEG1_SEQUENCE_HEADER_CODE = 0x000001B3
const DWORD | MPEG1_START_CODE_PREFIX = 0x00000100
const DWORD | MPEG1_STOP_CODE = 0x000001B9
const BYTE | MPEG1_STREAMTYPE_ALL_AUDIO = 0xB8
const BYTE | MPEG1_STREAMTYPE_ALL_VIDEO = 0xB9
const BYTE | MPEG1_STREAMTYPE_AUDIO_MASK = 0xC0
const BYTE | MPEG1_STREAMTYPE_DATA_MASK = 0xF0
const BYTE | MPEG1_STREAMTYPE_PADDING = 0xBE
const BYTE | MPEG1_STREAMTYPE_PRIVATE1 = 0xBD
const BYTE | MPEG1_STREAMTYPE_PRIVATE2 = 0xBF
const BYTE | MPEG1_STREAMTYPE_RESERVED = 0xBC
const BYTE | MPEG1_STREAMTYPE_VIDEO_MASK = 0xE0
const DWORD | MPEG1_SYSTEM_HEADER_CODE = 0x000001BB
const DWORD | MPEG1_SYSTEM_HEADER_MIN_SIZE = 12
const DWORD | MPEG1_SYSTEM_HEADER_PREFIX = 6
const DWORD | MPEG1_SYSTEM_HEADER_STREAM = 3
const DWORD | MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE = 140
const DWORD | MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12

Enumeration Type Documentation

enum MPEG1AudioFlags
Enumerator:
MPEG1_AUDIO_PRIVATE_BIT
MPEG1_AUDIO_COPYRIGHT_BIT
MPEG1_AUDIO_ORIGINAL_BIT
MPEG1_AUDIO_PROTECTION_BIT
MPEG1_AUDIO_PRIVATE_BIT
MPEG1_AUDIO_COPYRIGHT_BIT
MPEG1_AUDIO_ORIGINAL_BIT
MPEG1_AUDIO_PROTECTION_BIT

Definition at line 149 of file Parse.h.

{
    MPEG1_AUDIO_PRIVATE_BIT    = 0x01,  // = ACM_MPEG_PRIVATEBIT
    MPEG1_AUDIO_COPYRIGHT_BIT  = 0x02,  // = ACM_MPEG_COPYRIGHT
    MPEG1_AUDIO_ORIGINAL_BIT   = 0x04,  // = ACM_MPEG_ORIGINALHOME
    MPEG1_AUDIO_PROTECTION_BIT = 0x08,  // = ACM_MPEG_PROTECTIONBIT
};

enum MPEG1AudioLayer
Enumerator:
MPEG1_Audio_Layer1
MPEG1_Audio_Layer2
MPEG1_Audio_Layer3
MPEG1_Audio_Layer1
MPEG1_Audio_Layer2
MPEG1_Audio_Layer3

Definition at line 131 of file Parse.h.

{
    MPEG1_Audio_Layer1 = 0,
    MPEG1_Audio_Layer2,
    MPEG1_Audio_Layer3
};

enum MPEG1AudioMode
Enumerator:
MPEG1_Audio_Stereo
MPEG1_Audio_JointStereo
MPEG1_Audio_DualChannel
MPEG1_Audio_SingleChannel
MPEG1_Audio_Stereo
MPEG1_Audio_JointStereo
MPEG1_Audio_DualChannel
MPEG1_Audio_SingleChannel

Definition at line 138 of file Parse.h.

{
    MPEG1_Audio_Stereo = 0,
    MPEG1_Audio_JointStereo,
    MPEG1_Audio_DualChannel,
    MPEG1_Audio_SingleChannel
};

enum StreamType
Enumerator:
StreamType_Unknown
StreamType_AllAudio
StreamType_AllVideo
StreamType_Reserved
StreamType_Private1
StreamType_Padding
StreamType_Private2
StreamType_Audio
StreamType_Video
StreamType_Data
StreamType_Unknown
StreamType_AllAudio
StreamType_AllVideo
StreamType_Reserved
StreamType_Private1
StreamType_Padding
StreamType_Private2
StreamType_Audio
StreamType_Video
StreamType_Data

Definition at line 64 of file Parse.h.

{
    StreamType_Unknown,
    StreamType_AllAudio,
    StreamType_AllVideo,
    StreamType_Reserved,
    StreamType_Private1,
    StreamType_Padding,
    StreamType_Private2,
    StreamType_Audio,   // ISO/IEC 11172-3
    StreamType_Video,   // ISO/IEC 11172-2
    StreamType_Data
};

Function Documentation

HRESULT ReadAudioFrameHeader | ( | const BYTE * | pData,
 |  | DWORD | cbData,
 |  | MPEG1AudioFrameHeader & | audioHeader,
 |  | DWORD * | pAte
 | ) |  |

Definition at line 1136 of file Parse.cpp.

{
    HRESULT hr = S_OK;
    MPEG1AudioFrameHeader header;
    ZeroMemory(&header, sizeof(header));

    BYTE bitRateIndex = 0;
    BYTE samplingIndex = 0;

    *pAte = 0;

    if (cbData < MPEG1_AUDIO_FRAME_HEADER_SIZE)
    {
        return S_FALSE;
    }

    if (pData[0] != 0xFF)
    {
        return E_FAIL;
    }

    if (!HAS_FLAG(pData[1], 0xF8))
    {
        return E_FAIL;
    }

    // Layer bits
    switch (pData[1] & 0x06)
    {
    case 0x00:
        return E_FAIL;

    case 0x06:
        header.layer = MPEG1_Audio_Layer1;
        break;

    case 0x04:
        header.layer = MPEG1_Audio_Layer2;
        break;

    case 0x02:
        header.layer = MPEG1_Audio_Layer3;
        break;

    default:
        return E_UNEXPECTED; // Cannot actually happen, given our bitmask above.
    }

    bitRateIndex = (pData[2] & 0xF0) >> 4;
    samplingIndex = (pData[2] & 0x0C) >> 2;

    // Bit rate.
    // Note: Accoring to ISO/IEC 11172-3, some combinations of bitrate and
    // mode are not valid. However, this is up to the decoder to validate.
    hr = GetAudioBitRate(header.layer, bitRateIndex, &header.dwBitRate);

    // Sampling frequency.
    if (SUCCEEDED(hr))
    {
        hr = GetSamplingFrequency(samplingIndex, &header.dwSamplesPerSec);
    }

    if (SUCCEEDED(hr))
    {
        header.mode = static_cast<MPEG1AudioMode>((pData[3] & 0xC0) >> 6);
        header.modeExtension = (pData[3] & 0x30) >> 4;
        header.emphasis = (pData[3] & 0x03);

        // Parse the various bit flags.
        if (HAS_FLAG(pData[1], 0x01))
        {
            header.wFlags |= MPEG1_AUDIO_PROTECTION_BIT;
        }
        if (HAS_FLAG(pData[2], 0x01))
        {
            header.wFlags |= MPEG1_AUDIO_PRIVATE_BIT;
        }
        if (HAS_FLAG(pData[3], 0x08))
        {
            header.wFlags |= MPEG1_AUDIO_COPYRIGHT_BIT;
        }
        if (HAS_FLAG(pData[3], 0x04))
        {
            header.wFlags |= MPEG1_AUDIO_ORIGINAL_BIT;
        }

        if (header.mode == MPEG1_Audio_SingleChannel)
        {
            header.nChannels = 1;
        }
        else
        {
            header.nChannels = 2;
        }

        header.nBlockAlign = 1;

        CopyMemory(&audioHeader, &header, sizeof(audioHeader));
    }

    return  hr;

};

HRESULT ReadVideoSequenceHeader | ( | _In_reads_bytes_(cbData) const BYTE * | pData,
 |  | DWORD | cbData,
 |  | MPEG1VideoSeqHeader & | seqHeader,
 |  | _Out_ DWORD * | pAte
 | ) |  |

Definition at line 957 of file Parse.cpp.

{
    DWORD cbPadding = 0;

    if (pAte == nullptr || pData == nullptr)
    {
        return E_INVALIDARG;
    }

    *pAte = 0;

    // Skip to the sequence header code.
    while ( (cbPadding + 4) <= cbData && ((DWORD*)pData)[0] == 0 )
    {
        pData += 4;
        cbPadding += 4;
    }

    cbData -= cbPadding;

    // Check for the minimum size buffer.
    if (cbData < MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE)
    {
        *pAte = cbPadding;
        return S_FALSE;
    }

    // Validate the sequence header code.
    if (MAKE_DWORD(pData) != MPEG1_SEQUENCE_HEADER_CODE)
    {
        return E_FAIL;
    }

    // Calculate the actual required size.
    DWORD cbRequired = MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE;

    // Look for quantization matrices.
    if ( HAS_FLAG(pData[11], 0x02) )
    {
        // Intra quantization matrix is TRUE.
        cbRequired += 64;
    }
    // Intra is FALSE, look for non-intra flag
    else if ( HAS_FLAG(pData[11], 0x01) )
    {
        cbRequired += 64;
    }

    if (cbData < cbRequired)
    {
        return S_FALSE;
    }

    ZeroMemory(&seqHeader, sizeof(seqHeader));

    // Check the marker bit.
    if ( !HAS_FLAG(pData[10], 0x20) )
    {
        return E_FAIL;
    }

    BYTE parCode = pData[7] >> 4;
    BYTE frameRateCode = pData[7] & 0x0F;

    if (FAILED(GetPixelAspectRatio(parCode, &seqHeader.pixelAspectRatio)))
    {
        return E_FAIL;
    }

    if (FAILED(GetFrameRate(frameRateCode, &seqHeader.frameRate)))
    {
        return E_FAIL;
    }

    seqHeader.width = (pData[4] << 4) | (pData[5] >> 4) ;
    seqHeader.height = ((pData[5] & 0x0F) << 8) | (pData[6]);
    seqHeader.bitRate = (pData[8] << 10) | (pData[9] << 2) | (pData[10] >> 6);

    if (seqHeader.bitRate == 0)
    {
        return E_FAIL;  // Not allowed.
    }
    else if (seqHeader.bitRate == 0x3FFFF)
    {
        seqHeader.bitRate = 0; // Variable bit-rate.
    }
    else
    {
        seqHeader.bitRate = seqHeader.bitRate * 400; // Units of 400 bps
    }

    seqHeader.cbVBV_Buffer = ( ((pData[10] & 0x1F) << 5) | (pData[11] >> 3) ) * 2048;
    seqHeader.bConstrained = HAS_FLAG(pData[11], 0x04);

    seqHeader.cbHeader = cbRequired;
    CopyMemory(seqHeader.header, pData, cbRequired);

    *pAte = cbRequired + cbPadding;

    return S_OK;
}

Variable Documentation

const DWORD MPEG1_AUDIO_FRAME_HEADER_SIZE = 4

Definition at line 39 of file Parse.h.

const DWORD MPEG1_MAX_PACKET_SIZE = 65535 + 6

Definition at line 25 of file Parse.h.

const DWORD MPEG1_PACK_HEADER_SIZE = 12

Definition at line 26 of file Parse.h.

const DWORD MPEG1_PACK_START_CODE = 0x000001BA

Definition at line 44 of file Parse.h.

const DWORD MPEG1_PACKET_HEADER_MAX_SIZE = 34

Definition at line 34 of file Parse.h.

const DWORD MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE = 16

Definition at line 33 of file Parse.h.

const DWORD MPEG1_PACKET_HEADER_MIN_SIZE = 6

Definition at line 32 of file Parse.h.

const DWORD MPEG1_SEQUENCE_HEADER_CODE = 0x000001B3

Definition at line 46 of file Parse.h.

const DWORD MPEG1_START_CODE_PREFIX = 0x00000100

Definition at line 43 of file Parse.h.

const DWORD MPEG1_STOP_CODE = 0x000001B9

Definition at line 47 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_ALL_AUDIO = 0xB8

Definition at line 50 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_ALL_VIDEO = 0xB9

Definition at line 51 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_AUDIO_MASK = 0xC0

Definition at line 56 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_DATA_MASK = 0xF0

Definition at line 58 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_PADDING = 0xBE

Definition at line 54 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_PRIVATE1 = 0xBD

Definition at line 53 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_PRIVATE2 = 0xBF

Definition at line 55 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_RESERVED = 0xBC

Definition at line 52 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_VIDEO_MASK = 0xE0

Definition at line 57 of file Parse.h.

const DWORD MPEG1_SYSTEM_HEADER_CODE = 0x000001BB

Definition at line 45 of file Parse.h.

const DWORD MPEG1_SYSTEM_HEADER_MIN_SIZE = 12

Definition at line 28 of file Parse.h.

const DWORD MPEG1_SYSTEM_HEADER_PREFIX = 6

Definition at line 29 of file Parse.h.

const DWORD MPEG1_SYSTEM_HEADER_STREAM = 3

Definition at line 30 of file Parse.h.

const DWORD MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE = 140

Definition at line 37 of file Parse.h.

const DWORD MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12

Definition at line 36 of file Parse.h.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Polar/dllmain.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Polar
Namespaces | Functions

dllmain.cpp File Reference

#include <initguid.h>
#include "PolarEffect.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CPolarEffect)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 46 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 40 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 52 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 21 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Polar/PolarEffect.cpp File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Polar
Functions | Variables

PolarEffect.cpp File Reference

#include "PolarEffect.h"
#include "bufferlock.h"

Go to the source code of this file.

Functions

HRESULT | GetDefaultStride (IMFMediaType *pType, LONG *plStride)
HRESULT | GetImageSize (DWORD fcc, UINT32 width, UINT32 height, DWORD *pcbImage)
void | TransformImage_NV12 (_In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 *pLookup, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
void | TransformImage_UYVY (_In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 *pLookup, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
void | TransformImage_YUY2 (_In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 *pLookup, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)

Variables

const DWORD | FOURCC_NV12 = '21VN'
const DWORD | FOURCC_UYVY = 'YVYU'
const DWORD | FOURCC_YUY2 = '2YUY'
const GUID | g_MediaSubtypes []

Function Documentation

HRESULT GetDefaultStride | ( | IMFMediaType * | pType,
 |  | LONG * | plStride
 | ) |  |

Definition at line 1756 of file PolarEffect.cpp.

{
    LONG lStride = 0;

    // Try to get the default stride from the media type.
    HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
    if (FAILED(hr))
    {
        // Attribute not set. Try to calculate the default stride.
        GUID subtype = GUID_NULL;

        UINT32 width = 0;
        UINT32 height = 0;

        // Get the subtype and the image size.
        hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
        if (SUCCEEDED(hr))
        {
            hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
        }
        if (SUCCEEDED(hr))
        {
            if (subtype == MFVideoFormat_NV12)
            {
                lStride = width;
            }
            else if (subtype == MFVideoFormat_YUY2 || subtype == MFVideoFormat_UYVY)
            {
                lStride = ((width * 2) + 3) & ~3;
            }
            else
            {
                hr = E_INVALIDARG;
            }
        }

        // Set the attribute for later reference.
        if (SUCCEEDED(hr))
        {
            (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
        }
    }
    if (SUCCEEDED(hr))
    {
        *plStride = lStride;
    }
    return hr;
}

HRESULT GetImageSize | ( | DWORD | fcc,
 |  | UINT32 | width,
 |  | UINT32 | height,
 |  | DWORD * | pcbImage
 | ) |  |

Definition at line 1716 of file PolarEffect.cpp.

{
    HRESULT hr = S_OK;

    switch (fcc)
    {
    case FOURCC_YUY2:
    case FOURCC_UYVY:
        // check overflow
        if ((width > MAXDWORD / 2) || (width * 2 > MAXDWORD / height))
        {
            hr = E_INVALIDARG;
        }
        else
        {
            // 16 bpp
            *pcbImage = width * height * 2;
        }
        break;

    case FOURCC_NV12:
        // check overflow
        if ((height/2 > MAXDWORD - height) || ((height + height/2) > MAXDWORD / width))
        {
            hr = E_INVALIDARG;
        }
        else
        {
            // 12 bpp
            *pcbImage = width * (height + (height/2));
        }
        break;

    default:
        hr = E_FAIL;    // Unsupported type.
    }
    return hr;
}

void TransformImage_NV12 | ( | _In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 * | pLookup,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 208 of file PolarEffect.cpp.

{
    // NV12 is planar: Y plane, followed by packed U-V plane.

    // Y plane

    UINT32 *pLookup_Y = (UINT32*) pLookup;
    WORD *pSrc_Y = (WORD*) pSrc;
    pSrc_Y[0] = 0x0000;    // black

    for (DWORD y = 0; y < dwHeightInPixels; y++)
    {
        WORD *pDest_Y = (WORD*) pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
            UINT32 uOffset = (pLookup_Y[x] % dwWidthInPixels) + (pLookup_Y[x] / dwWidthInPixels) * lSrcStride;
            pDest_Y[x/2] = pSrc_Y[uOffset/2];
#pragma warning(pop)
        }
        pDest += lDestStride;
        pLookup_Y += dwWidthInPixels;
    }

    // U-V plane

    // NOTE: The U-V plane has 1/2 the number of lines as the Y plane.

    UINT32 *pLookup_UV = (UINT32*) pLookup;
    WORD *pSrc_UV = (WORD*) (pSrc + lSrcStride * dwHeightInPixels);
    pSrc_UV[0] = 0x8080;    // black

    for (DWORD y = 0; y < dwHeightInPixels; y += 2)
    {
        WORD *pDest_UV = (WORD*) pDest;

        for (DWORD x = 0; x < dwWidthInPixels; x += 2)
        {
#pragma warning(push)
#pragma warning(disable: 6385)
            UINT32 uOffset = (pLookup_UV[x] % dwWidthInPixels) + ((pLookup_UV[x] / dwWidthInPixels) / 2) * lSrcStride;
#pragma warning(pop)
            pDest_UV[x/2] = pSrc_UV[uOffset/2];
        }
        pDest += lDestStride;
        pLookup_UV += dwWidthInPixels * 2;
    }
}

void TransformImage_UYVY | ( | _In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 * | pLookup,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 134 of file PolarEffect.cpp.

{
    DWORD *pSrc_UYVY = (DWORD*) pSrc;

    // Byte order is U0 Y0 V0 Y1
    // Windows is little-endian so the order appears reversed.

    pSrc_UYVY[0] = 0x00800080;  // black

    for (DWORD y = 0; y < dwHeightInPixels; y++)
    {
        DWORD *pDest_UYVY = (DWORD*) pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
            UINT32 uOffset = (pLookup[x] % dwWidthInPixels) * sizeof(WORD) + (pLookup[x] / dwWidthInPixels) * lSrcStride;
            pDest_UYVY[x/2] = pSrc_UYVY[uOffset/sizeof(DWORD)];
#pragma warning(pop)
        }
        pDest += lDestStride;
        pLookup += dwWidthInPixels;
    }
}

void TransformImage_YUY2 | ( | _In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 * | pLookup,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 171 of file PolarEffect.cpp.

{
    DWORD *pSrc_UYVY = (DWORD*) pSrc;

    // Byte order is Y0 U0 Y1 V0
    // Windows is little-endian so the order appears reversed.

    pSrc_UYVY[0] = 0x80008000;  // black

    for (DWORD y = 0; y < dwHeightInPixels; y++)
    {
        DWORD *pDest_UYVY = (DWORD*) pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
            UINT32 uOffset = (pLookup[x] % dwWidthInPixels) * sizeof(WORD) + (pLookup[x] / dwWidthInPixels) * lSrcStride;
            pDest_UYVY[x/2] = pSrc_UYVY[uOffset/sizeof(DWORD)];
#pragma warning(pop)
        }
        pDest += lDestStride;
        pLookup += dwWidthInPixels;
    }
}

Variable Documentation

const DWORD FOURCC_NV12 = '21VN'

Definition at line 101 of file PolarEffect.cpp.

const DWORD FOURCC_UYVY = 'YVYU'

Definition at line 100 of file PolarEffect.cpp.

const DWORD FOURCC_YUY2 = '2YUY'

Definition at line 99 of file PolarEffect.cpp.

const GUID g_MediaSubtypes[]
Initial value:
{
    MFVideoFormat_NV12,
    MFVideoFormat_YUY2,
    MFVideoFormat_UYVY
}

Definition at line 104 of file PolarEffect.cpp.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Polar/PolarEffect.h File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Polar
Classes | Typedefs | Functions

PolarEffect.h File Reference

#include <new>
#include <mfapi.h>
#include <mftransform.h>
#include <mfidl.h>
#include <mferror.h>
#include <strsafe.h>
#include <assert.h>
#include <math.h>
#include <D2d1helper.h>
#include <wrl\implements.h>
#include <wrl\module.h>
#include <windows.media.h>
#include <wrl\wrappers\corewrappers.h>
#include "PolarTransform.h"

Go to the source code of this file.

Classes

class | CPolarEffect

Typedefs

typedef void(* | IMAGE_TRANSFORM_FN )(const UINT32 *pLookup, BYTE *pDest, LONG lDestStride, const BYTE *pSrc, LONG lSrcStride, DWORD dwWidthInPixels, DWORD dwHeightInPixels)
typedef DOUBLE(* | PolarTransformer )(DOUBLE, DOUBLE, DOUBLE)

Functions

void | DllAddRef ()
void | DllRelease ()
template<class T >
void | SafeArrayDelete (T **ppT)
template<class T >
void | SafeRelease (T **ppT)

Typedef Documentation

typedef void(* IMAGE_TRANSFORM_FN)(const UINT32 *pLookup,BYTE *pDest,LONG lDestStride,const BYTE *pSrc,LONG lSrcStride,DWORD dwWidthInPixels,DWORD dwHeightInPixels)

Definition at line 58 of file PolarEffect.h.

typedef DOUBLE(* PolarTransformer)(DOUBLE, DOUBLE, DOUBLE)

Definition at line 68 of file PolarEffect.h.

Function Documentation

void DllAddRef ( )
void DllRelease ( )
template<class T >
void SafeArrayDelete ( T ** ppT )

Definition at line 47 of file PolarEffect.h.

{
    if (*ppT)
    {
        delete [] (*ppT);
        *ppT = NULL;
    }
}

template<class T >
void SafeRelease ( T ** ppT )

Definition at line 38 of file PolarEffect.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Polar/PolarTransform.idl File Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Polar
Namespaces

PolarTransform.idl File Reference

#include <sdkddkver.h>

Go to the source code of this file.

Namespaces

namespace PolarTransform
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/Properties/AssemblyInfo.cs File Reference

  • Media extensions
  • C#,C++
  • Properties

AssemblyInfo.cs File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/Sample-Utils/Constants.cs File Reference

  • Media extensions
  • C#,C++
  • Sample-Utils
Classes | Namespaces

Constants.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplateCS::MainPage

Namespaces

namespace | SDKTemplateCS
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/Sample-Utils/SuspensionManager.cs File Reference

  • Media extensions
  • C#,C++
  • Sample-Utils
Classes

SuspensionManager.cs File Reference

Go to the source code of this file.

Classes

class SuspensionManager
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/App.xaml.cpp File Reference

  • Media extensions

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/App.xaml.h File Reference

  • Media extensions
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::App

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/CppSamplesUtils.h File Reference

  • Media extensions
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MainPage.xaml.cpp File Reference

  • Media extensions

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MainPage.xaml.h File Reference

  • Media extensions
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP

Enumerations

enum | MediaExtensionsCPP::NotifyType { MediaExtensionsCPP::StatusMessage, MediaExtensionsCPP::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/pch.cpp File Reference

  • Media extensions

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/pch.h File Reference

  • Media extensions

pch.h File Reference

#include "CppSamplesUtils.h"
#include <ppltasks.h>
#include "CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput1.xaml.cpp File Reference

  • Media extensions
Defines

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"
#include <guiddef.h>
#include <cguid.h>
#include <mfapi.h>

Go to the source code of this file.

Defines

#define INITGUID

Define Documentation

#define INITGUID

Definition at line 16 of file ScenarioInput1.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput1.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput2.xaml.cpp File Reference

  • Media extensions

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput2.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput3.xaml.cpp File Reference

  • Media extensions

ScenarioInput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput3.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioInput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput4.xaml.cpp File Reference

  • Media extensions

ScenarioInput4.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput4.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioInput4.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioList.xaml.cpp File Reference

  • Media extensions

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioList.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput1.xaml.cpp File Reference

  • Media extensions

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput1.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput2.xaml.cpp File Reference

  • Media extensions

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput2.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput3.xaml.cpp File Reference

  • Media extensions

ScenarioOutput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput3.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioOutput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput4.xaml.cpp File Reference

  • Media extensions

ScenarioOutput4.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput4.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput4.xaml.h File Reference

  • Media extensions
Classes | Namespaces

ScenarioOutput4.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | MediaExtensionsCPP::sealed

Namespaces

namespace | MediaExtensionsCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/AsyncCB.h File Reference

  • Media extensions
  • MediaExtensions
  • Common
Classes

AsyncCB.h File Reference

Go to the source code of this file.

Classes

class AsyncCallback< T >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/BufferLock.h File Reference

  • Media extensions
  • MediaExtensions
  • Common
Classes

BufferLock.h File Reference

Go to the source code of this file.

Classes

class VideoBufferLock
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/CritSec.h File Reference

  • Media extensions
  • MediaExtensions
  • Common
Classes

CritSec.h File Reference

Go to the source code of this file.

Classes

class | AutoLock
class | CritSec
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/LinkList.h File Reference

  • Media extensions
  • MediaExtensions
  • Common
Classes

LinkList.h File Reference

Go to the source code of this file.

Classes

class | ComAutoRelease
class | ComPtrList< T, NULLABLE >
class | List< T >
struct | List< T >::Node
class | List< T >::POSITION
class | MemDelete
struct | NoOp< T >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/OpQueue.h File Reference

  • Media extensions
  • MediaExtensions
  • Common
Classes

OpQueue.h File Reference

#include "linklist.h"
#include "AsyncCB.h"

Go to the source code of this file.

Classes

class OpQueue< T, TOperation >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/GeometricSource/dllmain.cpp File Reference

  • Media extensions
  • MediaExtensions
  • GeometricSource
Namespaces | Functions

dllmain.cpp File Reference

#include "stdafx.h"
#include <wrl\module.h>
#include "GeometricSchemeHandler.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CGeometricSchemeHandler)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 48 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 42 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 54 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 23 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/GeometricSource/pch.cpp File Reference

  • Media extensions
  • MediaExtensions
  • GeometricSource

pch.cpp File Reference

#include "StdAfx.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/GeometricSource/StdAfx.h File Reference

  • Media extensions
  • MediaExtensions
  • GeometricSource

StdAfx.h File Reference

#include <windows.h>
#include <mfapi.h>
#include <mfidl.h>
#include <mferror.h>
#include <d3d11.h>
#include <assert.h>
#include <tchar.h>
#include <Strsafe.h>
#include <objidl.h>
#include <new>
#include <wrl\client.h>
#include <wrl\implements.h>
#include <wrl\ftm.h>
#include <wrl\event.h>
#include <wrl\wrappers\corewrappers.h>
#include <windows.media.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Grayscale/dllmain.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Grayscale
Namespaces | Functions

dllmain.cpp File Reference

#include <initguid.h>
#include "Grayscale.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CGrayscale)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 48 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 42 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 54 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 23 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Grayscale/Grayscale.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Grayscale
Functions | Variables

Grayscale.cpp File Reference

#include "Grayscale.h"
#include "bufferlock.h"

Go to the source code of this file.

Functions

template<typename T >
T | clamp (const T &val, const T &minVal, const T &maxVal)
HRESULT | GetDefaultStride (IMFMediaType *pType, LONG *plStride)
HRESULT | GetImageSize (DWORD fcc, UINT32 width, UINT32 height, DWORD *pcbImage)
void | TransformChroma (const D2D1::Matrix3x2F &mat, BYTE *pu, BYTE *pv)
void | TransformImage_NV12 (const D2D1::Matrix3x2F &mat, const D2D_RECT_U &rcDest, _Inout_updates_(_Inexpressible_(2 *lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(2 *lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
void | TransformImage_UYVY (const D2D1::Matrix3x2F &mat, const D2D_RECT_U &rcDest, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
void | TransformImage_YUY2 (const D2D1::Matrix3x2F &mat, const D2D_RECT_U &rcDest, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
bool | ValidateRect (const RECT &rc)

Variables

const DWORD | FOURCC_NV12 = '21VN'
const DWORD | FOURCC_UYVY = 'YVYU'
const DWORD | FOURCC_YUY2 = '2YUY'
const GUID | g_MediaSubtypes []

Function Documentation

template<typename T >
T clamp | ( | const T & | val,
 |  | const T & | minVal,
 |  | const T & | maxVal |
 | ) |  |  | [inline]

Definition at line 100 of file Grayscale.cpp.

{
    return (val < minVal ? minVal : (val > maxVal ? maxVal : val));
}

HRESULT GetDefaultStride | ( | IMFMediaType * | pType,
 |  | LONG * | plStride
 | ) |  |

Definition at line 1715 of file Grayscale.cpp.

{
    LONG lStride = 0;

    // Try to get the default stride from the media type.
    HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
    if (FAILED(hr))
    {
        // Attribute not set. Try to calculate the default stride.
        GUID subtype = GUID_NULL;

        UINT32 width = 0;
        UINT32 height = 0;

        // Get the subtype and the image size.
        hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
        if (SUCCEEDED(hr))
        {
            hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
        }
        if (SUCCEEDED(hr))
        {
            if (subtype == MFVideoFormat_NV12)
            {
                lStride = width;
            }
            else if (subtype == MFVideoFormat_YUY2 || subtype == MFVideoFormat_UYVY)
            {
                lStride = ((width * 2) + 3) & ~3;
            }
            else
            {
                hr = E_INVALIDARG;
            }
        }

        // Set the attribute for later reference.
        if (SUCCEEDED(hr))
        {
            (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
        }
    }
    if (SUCCEEDED(hr))
    {
        *plStride = lStride;
    }
    return hr;
}

HRESULT GetImageSize | ( | DWORD | fcc,
 |  | UINT32 | width,
 |  | UINT32 | height,
 |  | DWORD * | pcbImage
 | ) |  |

Definition at line 1675 of file Grayscale.cpp.

{
    HRESULT hr = S_OK;

    switch (fcc)
    {
    case FOURCC_YUY2:
    case FOURCC_UYVY:
        // check overflow
        if ((width > MAXDWORD / 2) || (width * 2 > MAXDWORD / height))
        {
            hr = E_INVALIDARG;
        }
        else
        {
            // 16 bpp
            *pcbImage = width * height * 2;
        }
        break;

    case FOURCC_NV12:
        // check overflow
        if ((height/2 > MAXDWORD - height) || ((height + height/2) > MAXDWORD / width))
        {
            hr = E_INVALIDARG;
        }
        else
        {
            // 12 bpp
            *pcbImage = width * (height + (height/2));
        }
        break;

    default:
        hr = E_FAIL;    // Unsupported type.
    }
    return hr;
}

void TransformChroma | ( | const D2D1::Matrix3x2F & | mat,
 |  | BYTE * | pu,
 |  | BYTE * | pv
 | ) |  |

Definition at line 109 of file Grayscale.cpp.

{
    // Normalize the chroma values to [-112, 112] range

    D2D1_POINT_2F pt = { static_cast<float>(*pu) - 128, static_cast<float>(*pv) - 128 };

    pt = mat.TransformPoint(pt);

    // Clamp to valid range.
    clamp(pt.x, -112.0f, 112.0f);
    clamp(pt.y, -112.0f, 112.0f);

    // Map back to [16...240] range.
    *pu = static_cast<BYTE>(pt.x + 128.0f);
    *pv = static_cast<BYTE>(pt.y + 128.0f);
}

void TransformImage_NV12 | ( | const D2D1::Matrix3x2F & | mat,
 |  | const D2D_RECT_U & | rcDest,
 |  | _Inout_updates_(_Inexpressible_(2 *lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(2 *lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 284 of file Grayscale.cpp.

{
    // NV12 is planar: Y plane, followed by packed U-V plane.

    // Y plane
    for (DWORD y = 0; y < dwHeightInPixels; y++)
    {
        CopyMemory(pDest, pSrc, dwWidthInPixels);
        pDest += lDestStride;
        pSrc += lSrcStride;
    }

    // U-V plane

    // NOTE: The U-V plane has 1/2 the number of lines as the Y plane.

    // Lines above the destination rectangle.
    DWORD y = 0;
    const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);

    for ( ; y < rcDest.top/2; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }

    // Lines within the destination rectangle.
    for ( ; y < y0/2; y++)
    {
        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
            if (x >= rcDest.left && x < rcDest.right)
            {
                BYTE u = pSrc[x];
                BYTE v = pSrc[x+1];

                TransformChroma(mat, &u, &v);

                pDest[x] = u;
                pDest[x+1] = v;
            }
            else
            {
                pDest[x] = pSrc[x];
                pDest[x+1] = pSrc[x+1];
            }
        }
        pDest += lDestStride;
        pSrc += lSrcStride;
    }

    // Lines below the destination rectangle.
    for ( ; y < dwHeightInPixels/2; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }
}

void TransformImage_UYVY | ( | const D2D1::Matrix3x2F & | mat,
 |  | const D2D_RECT_U & | rcDest,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 146 of file Grayscale.cpp.

{
    DWORD y = 0;
    const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);

    // Lines above the destination rectangle.
    for ( ; y < rcDest.top; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels * 2);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }

    // Lines within the destination rectangle.
    for ( ; y < y0; y++)
    {
        WORD *pSrc_Pixel = (WORD*)pSrc;
        WORD *pDest_Pixel = (WORD*)pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
            // Byte order is U0 Y0 V0 Y1
            // Each WORD is a byte pair (U/V, Y)
            // Windows is little-endian so the order appears reversed.

            if (x >= rcDest.left && x < rcDest.right)
            {
                BYTE u = pSrc_Pixel[x] & 0x00FF;
                BYTE v = pSrc_Pixel[x+1] & 0x00FF;

                TransformChroma(mat, &u, &v);

                pDest_Pixel[x] = (pSrc_Pixel[x] & 0xFF00) | u;
                pDest_Pixel[x+1] = (pSrc_Pixel[x+1] & 0xFF00) | v;
            }
            else
            {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
                pDest_Pixel[x] = pSrc_Pixel[x];
                pDest_Pixel[x+1] = pSrc_Pixel[x+1];
#pragma warning(pop)
            }
        }

        pDest += lDestStride;
        pSrc += lSrcStride;
    }

    // Lines below the destination rectangle.
    for ( ; y < dwHeightInPixels; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels * 2);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }
}

void TransformImage_YUY2 | ( | const D2D1::Matrix3x2F & | mat,
 |  | const D2D_RECT_U & | rcDest,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 216 of file Grayscale.cpp.

{
    DWORD y = 0;
    const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);

    // Lines above the destination rectangle.
    for ( ; y < rcDest.top; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels * 2);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }

    // Lines within the destination rectangle.
    for ( ; y < y0; y++)
    {
        WORD *pSrc_Pixel = (WORD*)pSrc;
        WORD *pDest_Pixel = (WORD*)pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
            // Byte order is Y0 U0 Y1 V0
            // Each WORD is a byte pair (Y, U/V)
            // Windows is little-endian so the order appears reversed.

            if (x >= rcDest.left && x < rcDest.right)
            {
                BYTE u = pSrc_Pixel[x] >> 8;
                BYTE v = pSrc_Pixel[x+1] >> 8;

                TransformChroma(mat, &u, &v);

                pDest_Pixel[x] = (pSrc_Pixel[x] & 0x00FF) | (u<<8);
                pDest_Pixel[x+1] = (pSrc_Pixel[x+1] & 0x00FF) | (v<<8);
            }
            else
            {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
                pDest_Pixel[x] = pSrc_Pixel[x];
                pDest_Pixel[x+1] = pSrc_Pixel[x+1];
#pragma warning(pop)
            }
        }
        pDest += lDestStride;
        pSrc += lSrcStride;
    }

    // Lines below the destination rectangle.
    for ( ; y < dwHeightInPixels; y++)
    {
        memcpy(pDest, pSrc, dwWidthInPixels * 2);
        pSrc += lSrcStride;
        pDest += lDestStride;
    }
}

bool ValidateRect ( const RECT & rc )

Definition at line 1772 of file Grayscale.cpp.

{
    if (rc.left < 0 || rc.top < 0)
    {
        return false;
    }
    if (rc.left > rc.right || rc.top > rc.bottom)
    {
        return false;
    }
    return true;
}

Variable Documentation

const DWORD FOURCC_NV12 = '21VN'

Definition at line 85 of file Grayscale.cpp.

const DWORD FOURCC_UYVY = 'YVYU'

Definition at line 84 of file Grayscale.cpp.

const DWORD FOURCC_YUY2 = '2YUY'

Definition at line 83 of file Grayscale.cpp.

const GUID g_MediaSubtypes[]
Initial value:
{
    MFVideoFormat_NV12,
    MFVideoFormat_YUY2,
    MFVideoFormat_UYVY
}

Definition at line 88 of file Grayscale.cpp.

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Grayscale/Grayscale.h File Reference

  • Media extensions
  • MediaExtensions
  • Grayscale
Classes | Typedefs | Functions

Grayscale.h File Reference

#include <new>
#include <mfapi.h>
#include <mftransform.h>
#include <mfidl.h>
#include <mferror.h>
#include <strsafe.h>
#include <assert.h>
#include <D2d1helper.h>
#include <wrl\implements.h>
#include <wrl\module.h>
#include <windows.media.h>
#include "GrayscaleTransform.h"

Go to the source code of this file.

Classes

class | CGrayscale

Typedefs

typedef void(* | IMAGE_TRANSFORM_FN )(const D2D1::Matrix3x2F &mat, const D2D_RECT_U &rcDest, BYTE *pDest, LONG lDestStride, const BYTE *pSrc, LONG lSrcStride, DWORD dwWidthInPixels, DWORD dwHeightInPixels)

Functions

DEFINE_GUID (CLSID_GrayscaleMFT, 0x2f3dbc05, 0xc011, 0x4a8f, 0xb2, 0x64, 0xe4, 0x2e, 0x35, 0xc6, 0x7b, 0xf4)
DEFINE_GUID (MFT_GRAYSCALE_DESTINATION_RECT, 0x7bbbb051, 0x133b, 0x41f5, 0xb6, 0xaa, 0x5a, 0xff, 0x9b, 0x33, 0xa2, 0xcb)
DEFINE_GUID (MFT_GRAYSCALE_CHROMA_ROTATION, 0xe0bade5d, 0xe4b9, 0x4689, 0x9d, 0xba, 0xe2, 0xf0, 0xd, 0x9c, 0xed, 0xe)
DEFINE_GUID (MFT_GRAYSCALE_SATURATION, 0x14782342, 0x93e8, 0x4565, 0x87, 0x2c, 0xd9, 0xa2, 0x97, 0x3d, 0x5c, 0xbf)
template<class T >
void | SafeRelease (T **ppT)

Typedef Documentation

typedef void(* IMAGE_TRANSFORM_FN)(const D2D1::Matrix3x2F &mat,const D2D_RECT_U &rcDest,BYTE *pDest,LONG lDestStride,const BYTE *pSrc,LONG lSrcStride,DWORD dwWidthInPixels,DWORD dwHeightInPixels)

Definition at line 65 of file Grayscale.h.

Function Documentation

DEFINE_GUID | ( | CLSID_GrayscaleMFT | ,
 |  | 0x2f3dbc05 | ,
 |  | 0xc011 | ,
 |  | 0x4a8f | ,
 |  | 0xb2 | ,
 |  | 0x64 | ,
 |  | 0xe4 | ,
 |  | 0x2e | ,
 |  | 0x35 | ,
 |  | 0xc6 | ,
 |  | 0x7b | ,
 |  | 0xf4 |
 | ) |  |
DEFINE_GUID | ( | MFT_GRAYSCALE_DESTINATION_RECT | ,
 |  | 0x7bbbb051 | ,
 |  | 0x133b | ,
 |  | 0x41f5 | ,
 |  | 0xb6 | ,
 |  | 0xaa | ,
 |  | 0x5a | ,
 |  | 0xff | ,
 |  | 0x9b | ,
 |  | 0x33 | ,
 |  | 0xa2 | ,
 |  | 0xcb |
 | ) |  |
DEFINE_GUID | ( | MFT_GRAYSCALE_CHROMA_ROTATION | ,
 |  | 0xe0bade5d | ,
 |  | 0xe4b9 | ,
 |  | 0x4689 | ,
 |  | 0x9d | ,
 |  | 0xba | ,
 |  | 0xe2 | ,
 |  | 0xf0 | ,
 |  | 0xd | ,
 |  | 0x9c | ,
 |  | 0xed | ,
 |  | 0xe |
 | ) |  |
DEFINE_GUID | ( | MFT_GRAYSCALE_SATURATION | ,
 |  | 0x14782342 | ,
 |  | 0x93e8 | ,
 |  | 0x4565 | ,
 |  | 0x87 | ,
 |  | 0x2c | ,
 |  | 0xd9 | ,
 |  | 0xa2 | ,
 |  | 0x97 | ,
 |  | 0x3d | ,
 |  | 0x5c | ,
 |  | 0xbf |
 | ) |  |
template<class T >
void SafeRelease ( T ** ppT )

Definition at line 55 of file Grayscale.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/CopyModule.h File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Classes

CopyModule.h File Reference

#include "DirectXVideoTransform.h"

Go to the source code of this file.

Classes

class CCopyModule
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/dllmain.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Namespaces | Functions

dllmain.cpp File Reference

#include <initguid.h>
#include "Invert.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CInvert)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (__in HSTRING activatibleClassId, __deref_out IActivationFactory **factory)
STDAPI | DllGetClassObject (__in REFCLSID rclsid, __in REFIID riid, __deref_out LPVOID FAR *ppv)
BOOL WINAPI | DllMain (__in_opt HINSTANCE hInstance, __in DWORD dwReason, __in_opt LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 51 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | __in HSTRING | activatibleClassId,
 |  | __deref_out IActivationFactory ** | factory
 | ) |  |

Definition at line 45 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | __in REFCLSID | rclsid,
 |  | __in REFIID | riid,
 |  | __deref_out LPVOID FAR * | ppv
 | ) |  |

Definition at line 57 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | __in_opt HINSTANCE | hInstance,
 |  | __in DWORD | dwReason,
 |  | __in_opt LPVOID | lpReserved
 | ) |  |

Definition at line 23 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        if( hInstance != NULL )
        {
            DisableThreadLibraryCalls( hInstance );
        }

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/Invert.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Functions

Invert.cpp File Reference

#include "Invert.h"
#include "VideoBufferLock.h"
#include "TextureLock.h"
#include "InvertModule.h"
#include "CopyModule.h"

Go to the source code of this file.

Functions

HRESULT | BufferToDXType (IMFMediaBuffer *pBuffer, _Out_ UINT *uiViewIndex, _Out_ ID3D11Texture2D **ppTexture)
HRESULT | GetDefaultStride (IMFMediaType *pType, LONG *plStride)

Function Documentation

HRESULT BufferToDXType | ( | IMFMediaBuffer * | pBuffer,
 |  | _Out_ UINT * | uiViewIndex,
 |  | _Out_ ID3D11Texture2D ** | ppTexture
 | ) |  |

Definition at line 1229 of file Invert.cpp.

{
    HRESULT hr = S_OK;
    ComPtr<IMFDXGIBuffer> spDXGIBuffer;

    hr = pBuffer->QueryInterface(__uuidof(IMFDXGIBuffer), (LPVOID *)(&spDXGIBuffer));
    if (FAILED(hr))
    {
        goto done;
    }

    hr = spDXGIBuffer->GetResource(__uuidof(ID3D11Texture2D), (LPVOID *)(ppTexture));
    if (FAILED(hr))
    {
        goto done;
    }

    hr = spDXGIBuffer->GetSubresourceIndex(uiViewIndex);
    if (FAILED(hr))
    {
        goto done;
    }

done:
    return hr;
}

HRESULT GetDefaultStride | ( | IMFMediaType * | pType,
 |  | LONG * | plStride
 | ) |  |

Definition at line 1477 of file Invert.cpp.

{
    LONG lStride = 0;

    // Try to get the default stride from the media type.
    HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
    if (FAILED(hr))
    {
        // Attribute not set. Try to calculate the default stride.
        GUID subtype = GUID_NULL;

        UINT32 width = 0;
        UINT32 height = 0;

        // Get the subtype and the image size.
        hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
        if (SUCCEEDED(hr))
        {
            hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
        }
        if (SUCCEEDED(hr))
        {
            lStride = width * 4;
        }

        // Set the attribute for later reference.
        if (SUCCEEDED(hr))
        {
            (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
        }
    }
    if (SUCCEEDED(hr))
    {
        *plStride = lStride;
    }
    return hr;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/Invert.h File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Classes | Functions

Invert.h File Reference

#include <new>
#include <mfapi.h>
#include <mftransform.h>
#include <mfidl.h>
#include <mferror.h>
#include <strsafe.h>
#include <assert.h>
#include <wrl\implements.h>
#include <wrl\module.h>
#include <wrl\client.h>
#include <windows.media.h>
#include <D3D11.h>
#include "DirectXVideoTransform.h"
#include "InvertTransform.h"

Go to the source code of this file.

Classes

class CInvert

Functions

DEFINE_GUID (CLSID_InvertMFT, 0xf1bf74f0, 0x65f4, 0x4f47, 0x92, 0x5c, 0xe8, 0xb5, 0x64, 0xa9, 0xa8, 0x7e)

Function Documentation

DEFINE_GUID | ( | CLSID_InvertMFT | ,
 |  | 0xf1bf74f0 | ,
 |  | 0x65f4 | ,
 |  | 0x4f47 | ,
 |  | 0x92 | ,
 |  | 0x5c | ,
 |  | 0xe8 | ,
 |  | 0xb5 | ,
 |  | 0x64 | ,
 |  | 0xa9 | ,
 |  | 0xa8 | ,
 |  | 0x7e |
 | ) |  |
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/InvertModule.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Classes | Functions

InvertModule.cpp File Reference

#include "InvertModule.h"
#include "PixelShader.hps"
#include "VertexShader.hvs"

Go to the source code of this file.

Classes

struct | ScreenVertex

Functions

HRESULT | CreateShaderInputView (ID3D11Texture2D *pTexture, UINT uiIndex, ID3D11Device *pDevice, ID3D11ShaderResourceView **ppSRV)
HRESULT | CreateShaderOutputView (ID3D11Texture2D *pTexture, UINT uiIndex, ID3D11Device *pDevice, ID3D11RenderTargetView **ppRTV)

Function Documentation

HRESULT CreateShaderInputView | ( | ID3D11Texture2D * | pTexture,
 |  | UINT | uiIndex,
 |  | ID3D11Device * | pDevice,
 |  | ID3D11ShaderResourceView ** | ppSRV
 | ) |  |

Definition at line 135 of file InvertModule.cpp.

{
    D3D11_TEXTURE2D_DESC textureDesc;
    D3D11_SHADER_RESOURCE_VIEW_DESC viewDesc;

    ZeroMemory( &viewDesc, sizeof( viewDesc ) );

    pTexture->GetDesc( &textureDesc );

    viewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;

    if ( textureDesc.ArraySize > 1 )
    {
        // Texture array, use the subresource index
        viewDesc.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2DARRAY;
        viewDesc.Texture2DArray.FirstArraySlice = uiIndex;
        viewDesc.Texture2DArray.ArraySize = 1;
        viewDesc.Texture2DArray.MipLevels = 1;
        viewDesc.Texture2DArray.MostDetailedMip = 0;
    }
    else
    {
        viewDesc.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
        viewDesc.Texture2D.MostDetailedMip = 0;
        viewDesc.Texture2D.MipLevels = 1;
    }

    return pDevice->CreateShaderResourceView(pTexture,
                                             &viewDesc,
                                             ppSRV);
}

HRESULT CreateShaderOutputView | ( | ID3D11Texture2D * | pTexture,
 |  | UINT | uiIndex,
 |  | ID3D11Device * | pDevice,
 |  | ID3D11RenderTargetView ** | ppRTV
 | ) |  |

Definition at line 167 of file InvertModule.cpp.

{
    D3D11_TEXTURE2D_DESC textureDesc;
    D3D11_RENDER_TARGET_VIEW_DESC viewDesc;

    ZeroMemory( &viewDesc, sizeof( viewDesc ) );

    pTexture->GetDesc( &textureDesc );

    viewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;

    if ( textureDesc.ArraySize > 1 )
    {
        // Texture array, use the subresource index
        viewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2DARRAY;
        viewDesc.Texture2DArray.FirstArraySlice = uiIndex;
        viewDesc.Texture2DArray.ArraySize = 1;
        viewDesc.Texture2DArray.MipSlice = 0;
    }
    else
    {
        viewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
        viewDesc.Texture2D.MipSlice = 0;
    }

    return pDevice->CreateRenderTargetView(pTexture,
                                           &viewDesc,
                                           ppRTV );

}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/InvertModule.h File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Classes

InvertModule.h File Reference

#include "DirectXVideoTransform.h"
#include <wrl\client.h>

Go to the source code of this file.

Classes

class CInvertModule
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/InvertTransform.idl File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Namespaces

InvertTransform.idl File Reference

#include <sdkddkver.h>

Go to the source code of this file.

Namespaces

namespace InvertTransform
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/TextureLock.h File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Classes

TextureLock.h File Reference

#include <assert.h>
#include <D3D11.h>
#include <wrl\client.h>

Go to the source code of this file.

Classes

class TextureLock
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/VideoBufferLock.h File Reference

  • Media extensions
  • MediaExtensions
  • Invert
Classes

VideoBufferLock.h File Reference

#include <mfapi.h>
#include <mftransform.h>
#include <mfidl.h>
#include <assert.h>
#include <wrl\client.h>

Go to the source code of this file.

Classes

class VideoBufferLock
Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Decoder
Defines | Functions | Variables

decoder.cpp File Reference

#include "decoder.h"
#include "BufferLock.h"
#include <strsafe.h>

Go to the source code of this file.

Defines

#define | LODWORD(x) ((DWORD)(((DWORD_PTR)(x)) & 0xffffffff))

Functions

void | OurFillRect (PBYTE pbScanline0, DWORD dwWidth, DWORD dwHeight, LONG lStrideInBytes, COLORREF color)

Variables

const UINT32 | MAX_VIDEO_HEIGHT = 4095
const UINT32 | MAX_VIDEO_WIDTH = 4095

Define Documentation

#define LODWORD ( x ) ((DWORD)(((DWORD_PTR)(x)) & 0xffffffff))

Definition at line 22 of file decoder.cpp.

Function Documentation

void OurFillRect | ( | PBYTE | pbScanline0,
 |  | DWORD | dwWidth,
 |  | DWORD | dwHeight,
 |  | LONG | lStrideInBytes,
 |  | COLORREF | color
 | ) |  |

Definition at line 1439 of file decoder.cpp.

{
    PBYTE pbPixels = pbScanline0;

    // For just filling we don't care which way up the bitmap is -
    // we just start at pbData
    for(DWORD dwCount = 0; dwCount < dwHeight; dwCount++) {
        DWORD *pWord = (DWORD *)pbPixels;

        for(DWORD dwPixel = 0; dwPixel < dwWidth; dwPixel++) {
            pWord[dwPixel] = (DWORD)color;
        }

        //  biWidth is the stride
        pbPixels += lStrideInBytes;
    }
}

Variable Documentation

const UINT32 MAX_VIDEO_HEIGHT = 4095

Definition at line 26 of file decoder.cpp.

const UINT32 MAX_VIDEO_WIDTH = 4095

Definition at line 25 of file decoder.cpp.

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.h File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Decoder
Classes | Functions | Variables

decoder.h File Reference

#include <wrl\implements.h>
#include <windows.media.h>
#include <mftransform.h>
#include <mfapi.h>
#include <mferror.h>
#include <assert.h>
#include "MPEG1Decoder.h"

Go to the source code of this file.

Classes

class | CDecoder
class | CStreamState

Functions

template<class T >
void | SafeRelease (T **ppT)

Variables

const DWORD | MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12

Function Documentation

template<class T >
void SafeRelease ( T ** ppT )

Definition at line 27 of file decoder.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Variable Documentation

const DWORD MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12

Definition at line 24 of file decoder.h.

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Decoder/dll.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Decoder
Namespaces | Functions

dll.cpp File Reference

#include <wrl\module.h>
#include "Decoder.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CDecoder)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 48 of file dll.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 42 of file dll.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 54 of file dll.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 23 of file dll.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/dllmain.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source
Namespaces | Functions

dllmain.cpp File Reference

#include <wrl\module.h>
#include "MPEG1Src.h"
#include "MPEG1ByteStreamHandler.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CMPEG1ByteStreamHandler)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 49 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 43 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 55 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 24 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Source.idl File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source
Namespaces

MPEG1Source.idl File Reference

#include <sdkddkver.h>

Go to the source code of this file.

Namespaces

namespace MPEG1Source
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source
Functions

MPEG1Src.cpp File Reference

#include "MPEG1Src.h"

Go to the source code of this file.

Functions

HRESULT | CreateAudioMediaType (const MPEG1AudioFrameHeader &audioHeader, IMFMediaType **ppType)
HRESULT | CreateVideoMediaType (const MPEG1VideoSeqHeader &videoSeqHdr, IMFMediaType **ppType)
HRESULT | GetStreamMajorType (IMFStreamDescriptor *pSD, GUID *pguidMajorType)
BOOL | SampleRequestMatch (SourceOp *pOp1, SourceOp *pOp2)

Function Documentation

HRESULT CreateAudioMediaType | ( | const MPEG1AudioFrameHeader & | audioHeader,
 |  | IMFMediaType ** | ppType
 | ) |  |

Definition at line 2490 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;
    IMFMediaType *pType = NULL;

    MPEG1WAVEFORMAT format;
    ZeroMemory(&format, sizeof(format));

    format.wfx.wFormatTag = WAVE_FORMAT_MPEG;
    format.wfx.nChannels = audioHeader.nChannels;
    format.wfx.nSamplesPerSec = audioHeader.dwSamplesPerSec;
    if (audioHeader.dwBitRate > 0)
    {
        format.wfx.nAvgBytesPerSec = (audioHeader.dwBitRate * 1000) / 8;
    }
    format.wfx.nBlockAlign = audioHeader.nBlockAlign;
    format.wfx.wBitsPerSample = 0; // Not used.
    format.wfx.cbSize = sizeof(MPEG1WAVEFORMAT) - sizeof(WAVEFORMATEX);

    // MPEG-1 audio layer.
    switch (audioHeader.layer)
    {
    case MPEG1_Audio_Layer1:
        format.fwHeadLayer = ACM_MPEG_LAYER1;
        break;

    case MPEG1_Audio_Layer2:
        format.fwHeadLayer = ACM_MPEG_LAYER2;
        break;

    case MPEG1_Audio_Layer3:
        format.fwHeadLayer = ACM_MPEG_LAYER3;
        break;
    };

    format.dwHeadBitrate = audioHeader.dwBitRate * 1000;

    // Mode
    switch (audioHeader.mode)
    {
    case MPEG1_Audio_Stereo:
        format.fwHeadMode = ACM_MPEG_STEREO;
        break;

    case MPEG1_Audio_JointStereo:
        format.fwHeadMode = ACM_MPEG_JOINTSTEREO;
        break;

    case MPEG1_Audio_DualChannel:
        format.fwHeadMode = ACM_MPEG_DUALCHANNEL;
        break;

    case MPEG1_Audio_SingleChannel:
        format.fwHeadMode = ACM_MPEG_SINGLECHANNEL;
        break;
    };

    if (audioHeader.mode == ACM_MPEG_JOINTSTEREO)
    {
        // Convert the 'mode_extension' field to the correct MPEG1WAVEFORMAT value.
        if (audioHeader.modeExtension <= 0x03)
        {
            format.fwHeadModeExt = 0x01 << audioHeader.modeExtension;
        }
    }

    // Convert the 'emphasis' field to the correct MPEG1WAVEFORMAT value.
    if (audioHeader.emphasis <= 0x03)
    {
        format.wHeadEmphasis = audioHeader.emphasis + 1;
    }

    // The flags translate directly.
    format.fwHeadFlags = audioHeader.wFlags;
    // Add the "MPEG-1" flag, although it's somewhat redundant.
    format.fwHeadFlags |= ACM_MPEG_ID_MPEG1;

    // Use the structure to initialize the Media Foundation media type.
    hr = MFCreateMediaType(&pType);
    if (SUCCEEDED(hr))
    {
        hr = MFInitMediaTypeFromWaveFormatEx(pType, (const WAVEFORMATEX*)&format, sizeof(format));
    }

    if (SUCCEEDED(hr))
    {
        *ppType = pType;
        (*ppType)->AddRef();
    }

    SafeRelease(&pType);
    return hr;
}

HRESULT CreateVideoMediaType | ( | const MPEG1VideoSeqHeader & | videoSeqHdr,
 |  | IMFMediaType ** | ppType
 | ) |  |

Definition at line 2387 of file MPEG1Src.cpp.

{
    HRESULT hr = S_OK;

    IMFMediaType *pType = NULL;

    hr = MFCreateMediaType(&pType);

    if (SUCCEEDED(hr))
    {
        hr = pType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
    }

    // Subtype = MPEG-1 payload
    if (SUCCEEDED(hr))
    {
        hr = pType->SetGUID(MF_MT_SUBTYPE, MFVideoFormat_MPG1);
    }

    // Format details.
    if (SUCCEEDED(hr))
    {
        // Frame size

        hr = MFSetAttributeSize(
            pType,
            MF_MT_FRAME_SIZE,
            videoSeqHdr.width,
            videoSeqHdr.height
            );
    }
    if (SUCCEEDED(hr))
    {
        // Frame rate

        hr = MFSetAttributeRatio(
            pType,
            MF_MT_FRAME_RATE,
            videoSeqHdr.frameRate.Numerator,
            videoSeqHdr.frameRate.Denominator
            );
    }
    if (SUCCEEDED(hr))
    {
        // Pixel aspect ratio

        hr = MFSetAttributeRatio(
            pType,
            MF_MT_PIXEL_ASPECT_RATIO,
            videoSeqHdr.pixelAspectRatio.Numerator,
            videoSeqHdr.pixelAspectRatio.Denominator
            );
    }
    if (SUCCEEDED(hr))
    {
        // Average bit rate

        hr = pType->SetUINT32(MF_MT_AVG_BITRATE, videoSeqHdr.bitRate);
    }
    if (SUCCEEDED(hr))
    {

        // Interlacing (progressive frames)

        hr = pType->SetUINT32(MF_MT_INTERLACE_MODE, (UINT32)MFVideoInterlace_Progressive);
    }
    if (SUCCEEDED(hr))
    {
        // Sequence header.

        hr = pType->SetBlob(
            MF_MT_MPEG_SEQUENCE_HEADER,
            videoSeqHdr.header,             // Byte array
            videoSeqHdr.cbHeader            // Size
            );
    }

    if (SUCCEEDED(hr))
    {
        *ppType = pType;
        (*ppType)->AddRef();
    }

    SafeRelease(&pType);
    return hr;
}

HRESULT GetStreamMajorType | ( | IMFStreamDescriptor * | pSD,
 |  | GUID * | pguidMajorType
 | ) |  |

Definition at line 2585 of file MPEG1Src.cpp.

{
    if (pSD == NULL) { return E_POINTER; }
    if (pguidMajorType == NULL) { return E_POINTER; }

    HRESULT hr = S_OK;
    IMFMediaTypeHandler *pHandler = NULL;

    hr = pSD->GetMediaTypeHandler(&pHandler);
    if (SUCCEEDED(hr))
    {
        hr = pHandler->GetMajorType(pguidMajorType);
    }
    SafeRelease(&pHandler);
    return hr;
}

BOOL SampleRequestMatch | ( | SourceOp * | pOp1,
 |  | SourceOp * | pOp2
 | ) |  |

Definition at line 2603 of file MPEG1Src.cpp.

{
    if ((pOp1 == NULL) && (pOp2 == NULL))
    {
        return TRUE;
    }
    else if ((pOp1 == NULL) || (pOp2 == NULL))
    {
        return FALSE;
    }
    else
    {
        return (pOp1->Data().ulVal == pOp2->Data().ulVal);
    }
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Src.h File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source
Classes | Defines | Typedefs | Enumerations | Functions | Variables

MPEG1Src.h File Reference

#include <new.h>
#include <windows.h>
#include <assert.h>
#include <wrl\implements.h>
#include <windows.media.h>
#include <mftransform.h>
#include <mfapi.h>
#include <mfobjects.h>
#include <mfidl.h>
#include <mferror.h>
#include "linklist.h"
#include "asynccb.h"
#include "OpQueue.h"
#include "Parse.h"
#include "MPEG1Stream.h"

Go to the source code of this file.

Classes

class | CMPEG1Source
class | SetRateOp
class | SourceOp
class | StartOp
class | StreamList

Defines

#define | _ASSERTE assert

Typedefs

typedef ComPtrList< IMFSample > | SampleList
typedef ComPtrList< IUnknown,
true > 		TokenList

Enumerations

enum SourceState {
STATE_INVALID, STATE_OPENING, STATE_STOPPED, STATE_PAUSED,
STATE_STARTED, STATE_SHUTDOWN, STATE_INVALID, STATE_OPENING,
STATE_STOPPED, STATE_PAUSED, STATE_STARTED, STATE_SHUTDOWN
}

Functions

void | DllAddRef ()
void | DllRelease ()
template<class T >
void | SafeRelease (T **ppT)

Variables

const DWORD | INITIAL_BUFFER_SIZE = 4 * 1024
const UINT32 | MAX_STREAMS = 32
const DWORD | READ_SIZE = 4 * 1024
const DWORD | SAMPLE_QUEUE = 2

Define Documentation

#define _ASSERTE assert

Definition at line 24 of file MPEG1Src.h.

Typedef Documentation

typedef ComPtrList<IMFSample> SampleList

Definition at line 64 of file MPEG1Src.h.

typedef ComPtrList<IUnknown, true> TokenList

Definition at line 67 of file MPEG1Src.h.

Enumeration Type Documentation

enum SourceState
Enumerator:
STATE_INVALID
STATE_OPENING
STATE_STOPPED
STATE_PAUSED
STATE_STARTED
STATE_SHUTDOWN
STATE_INVALID
STATE_OPENING
STATE_STOPPED
STATE_PAUSED
STATE_STARTED
STATE_SHUTDOWN

Definition at line 69 of file MPEG1Src.h.

{
    STATE_INVALID,      // Initial state. Have not started opening the stream.
    STATE_OPENING,      // BeginOpen is in progress.
    STATE_STOPPED,
    STATE_PAUSED,
    STATE_STARTED,
    STATE_SHUTDOWN
};

Function Documentation

void DllAddRef ( )
void DllRelease ( )
template<class T >
void SafeRelease ( T ** ppT )

Definition at line 47 of file MPEG1Src.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Variable Documentation

const DWORD INITIAL_BUFFER_SIZE = 4 * 1024

Definition at line 174 of file MPEG1Src.h.

const UINT32 MAX_STREAMS = 32

Definition at line 84 of file MPEG1Src.h.

const DWORD READ_SIZE = 4 * 1024

Definition at line 175 of file MPEG1Src.h.

const DWORD SAMPLE_QUEUE = 2

Definition at line 176 of file MPEG1Src.h.

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Stream.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source
Functions

MPEG1Stream.cpp File Reference

#include "MPEG1Src.h"

Go to the source code of this file.

Functions

_Acquires_lock_ (m_pSource) CMPEG1Stream
_Releases_lock_ (m_pSource) CMPEG1Stream

Function Documentation

_Acquires_lock_ ( m_pSource )

Definition at line 27 of file MPEG1Stream.cpp.

    : m_pSource(NULL)
{
    if (pSource)
    {
        m_pSource = pSource;
        m_pSource->AddRef();
        m_pSource->Lock();
    }
}

_Releases_lock_ ( m_pSource )

Definition at line 43 of file MPEG1Stream.cpp.

{
    if (m_pSource)
    {
        m_pSource->Unlock();
        m_pSource->Release();
    }
}

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Stream.h File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source
Classes

MPEG1Stream.h File Reference

Go to the source code of this file.

Classes

class | CMPEG1Stream
class | CMPEG1Stream::SourceLock
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source
Defines | Functions

Parse.cpp File Reference

#include "MPEG1Src.h"
#include "Parse.h"

Go to the source code of this file.

Defines

#define | HAS_FLAG(b, flag) (((b) & (flag)) == (flag))
#define | htonl(x)

Functions

HRESULT | AdvanceBufferPointer (const BYTE *&pData, DWORD &cbBufferSize, DWORD cbAdvance)
HRESULT | GetAudioBitRate (MPEG1AudioLayer layer, BYTE index, DWORD *pdwBitRate)
HRESULT | GetFrameRate (BYTE frameRateCode, MFRatio *pRatio)
HRESULT | GetPixelAspectRatio (BYTE pixelAspectCode, MFRatio *pRatio)
HRESULT | GetSamplingFrequency (BYTE code, DWORD *pdwSamplesPerSec)
DWORD | MAKE_DWORD (const BYTE *pData)
DWORD | MAKE_DWORD_HOSTORDER (const BYTE *pData)
WORD | MAKE_WORD (BYTE b1, BYTE b2)
HRESULT | ParsePTS (const BYTE *pData, LONGLONG *pPTS)
HRESULT | ParseStreamData (const BYTE *pData, MPEG1StreamHeader &header)
HRESULT | ParseStreamId (BYTE id, StreamType *pType, BYTE *pStreamNum)
HRESULT | ReadAudioFrameHeader (const BYTE *pData, DWORD cbData, MPEG1AudioFrameHeader &audioHeader, DWORD *pAte)
HRESULT | ReadVideoSequenceHeader (_In_reads_bytes_(cbData) const BYTE *pData, DWORD cbData, MPEG1VideoSeqHeader &seqHeader, _Out_ DWORD *pAte)
HRESULT | ValidateBufferSize (DWORD cbBufferSize, DWORD cbMinRequiredSize)

Define Documentation

#define HAS_FLAG | ( | b,
 |  | flag |
 | ) |  | (((b) & (flag)) == (flag))

Definition at line 19 of file Parse.cpp.

#define htonl ( x )
Value:
((((x) >> 24) & 0x000000FFL) | \
    (((x) >>  8) & 0x0000FF00L) | \
    (((x) <<  8) & 0x00FF0000L) | \
    (((x) << 24) & 0xFF000000L))

Definition at line 21 of file Parse.cpp.

Function Documentation

HRESULT AdvanceBufferPointer | ( | const BYTE *& | pData,
 |  | DWORD & | cbBufferSize,
 |  | DWORD | cbAdvance |
 | ) |  |  | [inline]

Definition at line 59 of file Parse.cpp.

{
    assert(cbBufferSize >= cbAdvance);
    if (cbBufferSize < cbAdvance)
    {
        return E_FAIL;
    }
    cbBufferSize -= cbAdvance;
    pData += cbAdvance;
    return S_OK;
}

HRESULT GetAudioBitRate | ( | MPEG1AudioLayer | layer,
 |  | BYTE | index,
 |  | DWORD * | pdwBitRate
 | ) |  |

Definition at line 1255 of file Parse.cpp.

{
    const DWORD MAX_BITRATE_INDEX = 14;

    // Table of bit rates.
    const DWORD bitrate[3][ (MAX_BITRATE_INDEX+1) ] =
    {
        { 0, 32, 64, 96, 128, 160, 192, 224, 256, 288, 320, 352, 384, 416, 448 },    // Layer I
        { 0, 32, 48, 56, 64, 80, 96, 112, 128, 160, 192, 224, 256, 320, 384 },       // Layer II
        { 0, 32, 40, 48, 56, 64, 80, 96, 112, 128, 160, 192, 224, 256, 320 }         // Layer III
    };

    if (layer < MPEG1_Audio_Layer1 || layer > MPEG1_Audio_Layer3)
    {
        return E_INVALIDARG;
    }
    if (index > MAX_BITRATE_INDEX)
    {
        return E_INVALIDARG;
    }

    *pdwBitRate = bitrate[layer][index];

    return S_OK;
}

HRESULT GetFrameRate | ( | BYTE | frameRateCode,
 |  | MFRatio * | pRatio
 | ) |  |

Definition at line 1074 of file Parse.cpp.

{
    MFRatio frameRates[] =
    {
        { 0, 0 },           // invalid
        { 24000, 1001 },    // 23.976 fps
        { 24, 1 },
        { 25, 1 },
        { 30000, 1001 },    // 29.97 fps
        { 50, 1 },
        { 60000, 1001 },    // 59.94 fps
        { 60, 1 }
    };

    if (frameRateCode < 1 || frameRateCode >= ARRAYSIZE(frameRates))
    {
        return MF_E_INVALIDTYPE;
    }

    pRatio->Numerator = frameRates[frameRateCode].Numerator;
    pRatio->Denominator = frameRates[frameRateCode].Denominator;

    return S_OK;
}

HRESULT GetPixelAspectRatio | ( | BYTE | pixelAspectCode,
 |  | MFRatio * | pRatio
 | ) |  |

Definition at line 1107 of file Parse.cpp.

{
    DWORD height[] = { 0, 10000, 6735, 7031, 7615, 8055, 8437, 8935, 9157,
        9815, 10255, 10695, 10950, 11575, 12015 };

    const DWORD width = 10000;

    if (pixelAspectCode < 1 || pixelAspectCode >= ARRAYSIZE(height))
    {
        return MF_E_INVALIDTYPE;
    }

    pRatio->Numerator = height[pixelAspectCode];
    pRatio->Denominator = width;

    return S_OK;

}

HRESULT GetSamplingFrequency | ( | BYTE | code,
 |  | DWORD * | pdwSamplesPerSec
 | ) |  |

Definition at line 1289 of file Parse.cpp.

{
    switch (code)
    {
    case 0:
        *pdwSamplesPerSec = 44100;
        break;
    case 1:
        *pdwSamplesPerSec = 48000;
        break;
    case 2:
        *pdwSamplesPerSec = 32000;
        break;
    default:
        return E_FAIL;
    }
    return S_OK;
}

DWORD MAKE_DWORD ( const BYTE * pData ) [inline]

Definition at line 41 of file Parse.cpp.

{
    return htonl( MAKE_DWORD_HOSTORDER(pData) );
}

DWORD MAKE_DWORD_HOSTORDER ( const BYTE * pData ) [inline]

Definition at line 34 of file Parse.cpp.

{
    return ((DWORD*)pData)[0];
}

WORD MAKE_WORD | ( | BYTE | b1,
 |  | BYTE | b2 |
 | ) |  |  | [inline]

Definition at line 27 of file Parse.cpp.

{
    return ((b1 << 8) | b2);
}

HRESULT ParsePTS | ( | const BYTE * | pData,
 |  | LONGLONG * | pPTS
 | ) |  |

Definition at line 797 of file Parse.cpp.

{
    BYTE byte1 = pData[0];
    WORD word1 = MAKE_WORD(pData[1], pData[2]);
    WORD word2 = MAKE_WORD(pData[3], pData[4]);

    // Check marker bits.
    // The first byte can be '0010xxx1' or '0x11xxxx1'
    if (((byte1 & 0xE1) != 0x21) ||
        ((word1 & 0x01) != 0x01) ||
        ((word2 & 0x01) != 0x01) )
    {
        return E_FAIL;
    }

    LARGE_INTEGER li;

    // The PTS is 33 bits, so bit 32 goes in the high-order DWORD
    li.HighPart = (byte1 & 0x08) >> 3;

    li.LowPart = (static_cast<DWORD>(byte1 & 0x06) << 29) |
        (static_cast<DWORD>(word1 & 0xFFFE) << 14) |
        (static_cast<DWORD>(word2) >> 1);

    *pPTS = li.QuadPart;
    return S_OK;
}

HRESULT ParseStreamData | ( | const BYTE * | pData,
 |  | MPEG1StreamHeader & | header
 | ) |  |

Definition at line 832 of file Parse.cpp.

{
    // Check marker bits.
    if ( (pStreamInfo[1] & 0xC0) != 0xC0 )
    {
        return E_FAIL; // Invalid bits
    }

    HRESULT hr = S_OK;
    BYTE id = 0;
    BYTE num = 0;
    DWORD bound = 0;
    StreamType type = StreamType_Unknown;

    // The id is a stream code plus (for some types) a stream number, bitwise-OR'd.

    id = pStreamInfo[0];

    hr = ParseStreamId(id, &type, &num);
    if (FAILED(hr))
    {
        return hr;
    }

    // Calculate STD bound.
    bound = pStreamInfo[2] | ((pStreamInfo[1] & 0x1F) << 8);

    if (pStreamInfo[1] & 0x20)
    {
        bound *= 1024;
    }
    else
    {
        bound *= 128;
    }

    header.stream_id = id;
    header.type = type;
    header.number = num;
    header.sizeBound = bound;

    return S_OK;
}

HRESULT ParseStreamId | ( | BYTE | id,
 |  | StreamType * | pType,
 |  | BYTE * | pStreamNum
 | ) |  |

Definition at line 889 of file Parse.cpp.

{
    StreamType type = StreamType_Unknown;
    BYTE num = 0;

    switch (id)
    {
    case MPEG1_STREAMTYPE_ALL_AUDIO:
        type = StreamType_AllAudio;
        break;

    case MPEG1_STREAMTYPE_ALL_VIDEO:
        type = StreamType_AllVideo;
        break;

    case MPEG1_STREAMTYPE_RESERVED:
        type = StreamType_Reserved;
        break;

    case MPEG1_STREAMTYPE_PRIVATE1:
        type = StreamType_Private1;
        break;

    case MPEG1_STREAMTYPE_PADDING:
        type = StreamType_Padding;
        break;

    case MPEG1_STREAMTYPE_PRIVATE2:
        type = StreamType_Private2;
        break;

    default:
        if ((id & 0xE0) == MPEG1_STREAMTYPE_AUDIO_MASK)
        {
            type = StreamType_Audio;
            num = id & 0x1F;
        }
        else if ((id & 0xF0) == MPEG1_STREAMTYPE_VIDEO_MASK)
        {
            type = StreamType_Video;
            num = id & 0x0F;
        }
        else if ((id & 0xF0) == MPEG1_STREAMTYPE_DATA_MASK)
        {
            type = StreamType_Data;
            num = id & 0x0F;
        }
        else
        {
            return E_FAIL; // Unknown stream ID code.
        }
    }

    *pType = type;
    *pStreamNum = num;
    return S_OK;
}

HRESULT ReadAudioFrameHeader | ( | const BYTE * | pData,
 |  | DWORD | cbData,
 |  | MPEG1AudioFrameHeader & | audioHeader,
 |  | DWORD * | pAte
 | ) |  |

Definition at line 1136 of file Parse.cpp.

{
    HRESULT hr = S_OK;
    MPEG1AudioFrameHeader header;
    ZeroMemory(&header, sizeof(header));

    BYTE bitRateIndex = 0;
    BYTE samplingIndex = 0;

    *pAte = 0;

    if (cbData < MPEG1_AUDIO_FRAME_HEADER_SIZE)
    {
        return S_FALSE;
    }

    if (pData[0] != 0xFF)
    {
        return E_FAIL;
    }

    if (!HAS_FLAG(pData[1], 0xF8))
    {
        return E_FAIL;
    }

    // Layer bits
    switch (pData[1] & 0x06)
    {
    case 0x00:
        return E_FAIL;

    case 0x06:
        header.layer = MPEG1_Audio_Layer1;
        break;

    case 0x04:
        header.layer = MPEG1_Audio_Layer2;
        break;

    case 0x02:
        header.layer = MPEG1_Audio_Layer3;
        break;

    default:
        return E_UNEXPECTED; // Cannot actually happen, given our bitmask above.
    }

    bitRateIndex = (pData[2] & 0xF0) >> 4;
    samplingIndex = (pData[2] & 0x0C) >> 2;

    // Bit rate.
    // Note: Accoring to ISO/IEC 11172-3, some combinations of bitrate and
    // mode are not valid. However, this is up to the decoder to validate.
    hr = GetAudioBitRate(header.layer, bitRateIndex, &header.dwBitRate);

    // Sampling frequency.
    if (SUCCEEDED(hr))
    {
        hr = GetSamplingFrequency(samplingIndex, &header.dwSamplesPerSec);
    }

    if (SUCCEEDED(hr))
    {
        header.mode = static_cast<MPEG1AudioMode>((pData[3] & 0xC0) >> 6);
        header.modeExtension = (pData[3] & 0x30) >> 4;
        header.emphasis = (pData[3] & 0x03);

        // Parse the various bit flags.
        if (HAS_FLAG(pData[1], 0x01))
        {
            header.wFlags |= MPEG1_AUDIO_PROTECTION_BIT;
        }
        if (HAS_FLAG(pData[2], 0x01))
        {
            header.wFlags |= MPEG1_AUDIO_PRIVATE_BIT;
        }
        if (HAS_FLAG(pData[3], 0x08))
        {
            header.wFlags |= MPEG1_AUDIO_COPYRIGHT_BIT;
        }
        if (HAS_FLAG(pData[3], 0x04))
        {
            header.wFlags |= MPEG1_AUDIO_ORIGINAL_BIT;
        }

        if (header.mode == MPEG1_Audio_SingleChannel)
        {
            header.nChannels = 1;
        }
        else
        {
            header.nChannels = 2;
        }

        header.nBlockAlign = 1;

        CopyMemory(&audioHeader, &header, sizeof(audioHeader));
    }

    return  hr;

};

HRESULT ReadVideoSequenceHeader | ( | _In_reads_bytes_(cbData) const BYTE * | pData,
 |  | DWORD | cbData,
 |  | MPEG1VideoSeqHeader & | seqHeader,
 |  | _Out_ DWORD * | pAte
 | ) |  |

Definition at line 957 of file Parse.cpp.

{
    DWORD cbPadding = 0;

    if (pAte == nullptr || pData == nullptr)
    {
        return E_INVALIDARG;
    }

    *pAte = 0;

    // Skip to the sequence header code.
    while ( (cbPadding + 4) <= cbData && ((DWORD*)pData)[0] == 0 )
    {
        pData += 4;
        cbPadding += 4;
    }

    cbData -= cbPadding;

    // Check for the minimum size buffer.
    if (cbData < MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE)
    {
        *pAte = cbPadding;
        return S_FALSE;
    }

    // Validate the sequence header code.
    if (MAKE_DWORD(pData) != MPEG1_SEQUENCE_HEADER_CODE)
    {
        return E_FAIL;
    }

    // Calculate the actual required size.
    DWORD cbRequired = MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE;

    // Look for quantization matrices.
    if ( HAS_FLAG(pData[11], 0x02) )
    {
        // Intra quantization matrix is TRUE.
        cbRequired += 64;
    }
    // Intra is FALSE, look for non-intra flag
    else if ( HAS_FLAG(pData[11], 0x01) )
    {
        cbRequired += 64;
    }

    if (cbData < cbRequired)
    {
        return S_FALSE;
    }

    ZeroMemory(&seqHeader, sizeof(seqHeader));

    // Check the marker bit.
    if ( !HAS_FLAG(pData[10], 0x20) )
    {
        return E_FAIL;
    }

    BYTE parCode = pData[7] >> 4;
    BYTE frameRateCode = pData[7] & 0x0F;

    if (FAILED(GetPixelAspectRatio(parCode, &seqHeader.pixelAspectRatio)))
    {
        return E_FAIL;
    }

    if (FAILED(GetFrameRate(frameRateCode, &seqHeader.frameRate)))
    {
        return E_FAIL;
    }

    seqHeader.width = (pData[4] << 4) | (pData[5] >> 4) ;
    seqHeader.height = ((pData[5] & 0x0F) << 8) | (pData[6]);
    seqHeader.bitRate = (pData[8] << 10) | (pData[9] << 2) | (pData[10] >> 6);

    if (seqHeader.bitRate == 0)
    {
        return E_FAIL;  // Not allowed.
    }
    else if (seqHeader.bitRate == 0x3FFFF)
    {
        seqHeader.bitRate = 0; // Variable bit-rate.
    }
    else
    {
        seqHeader.bitRate = seqHeader.bitRate * 400; // Units of 400 bps
    }

    seqHeader.cbVBV_Buffer = ( ((pData[10] & 0x1F) << 5) | (pData[11] >> 3) ) * 2048;
    seqHeader.bConstrained = HAS_FLAG(pData[11], 0x04);

    seqHeader.cbHeader = cbRequired;
    CopyMemory(seqHeader.header, pData, cbRequired);

    *pAte = cbRequired + cbPadding;

    return S_OK;
}

HRESULT ValidateBufferSize | ( | DWORD | cbBufferSize,
 |  | DWORD | cbMinRequiredSize |
 | ) |  |  | [inline]

Definition at line 73 of file Parse.cpp.

{
    return (cbBufferSize >= cbMinRequiredSize? S_OK : E_FAIL);
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.h File Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source
Classes | Enumerations | Functions | Variables

Parse.h File Reference

Go to the source code of this file.

Classes

class | Buffer
struct | MPEG1AudioFrameHeader
struct | MPEG1PacketHeader
struct | MPEG1StreamHeader
struct | MPEG1SystemHeader
struct | MPEG1VideoSeqHeader
class | Parser

Enumerations

enum MPEG1AudioFlags {
MPEG1_AUDIO_PRIVATE_BIT = 0x01, MPEG1_AUDIO_COPYRIGHT_BIT = 0x02, MPEG1_AUDIO_ORIGINAL_BIT = 0x04, MPEG1_AUDIO_PROTECTION_BIT = 0x08,
MPEG1_AUDIO_PRIVATE_BIT = 0x01, MPEG1_AUDIO_COPYRIGHT_BIT = 0x02, MPEG1_AUDIO_ORIGINAL_BIT = 0x04, MPEG1_AUDIO_PROTECTION_BIT = 0x08
}
enum MPEG1AudioLayer {
MPEG1_Audio_Layer1 = 0, MPEG1_Audio_Layer2, MPEG1_Audio_Layer3, MPEG1_Audio_Layer1 = 0,
MPEG1_Audio_Layer2, MPEG1_Audio_Layer3
}
enum MPEG1AudioMode {
MPEG1_Audio_Stereo = 0, MPEG1_Audio_JointStereo, MPEG1_Audio_DualChannel, MPEG1_Audio_SingleChannel,
MPEG1_Audio_Stereo = 0, MPEG1_Audio_JointStereo, MPEG1_Audio_DualChannel, MPEG1_Audio_SingleChannel
}
enum StreamType {
StreamType_Unknown, StreamType_AllAudio, StreamType_AllVideo, StreamType_Reserved,
StreamType_Private1, StreamType_Padding, StreamType_Private2, StreamType_Audio,
StreamType_Video, StreamType_Data, StreamType_Unknown, StreamType_AllAudio,
StreamType_AllVideo, StreamType_Reserved, StreamType_Private1, StreamType_Padding,
StreamType_Private2, StreamType_Audio, StreamType_Video, StreamType_Data
}

Functions

HRESULT | ReadAudioFrameHeader (const BYTE *pData, DWORD cbData, MPEG1AudioFrameHeader &audioHeader, DWORD *pAte)
HRESULT | ReadVideoSequenceHeader (_In_reads_bytes_(cbData) const BYTE *pData, DWORD cbData, MPEG1VideoSeqHeader &seqHeader, _Out_ DWORD *pAte)

Variables

const DWORD | MPEG1_AUDIO_FRAME_HEADER_SIZE = 4
const DWORD | MPEG1_MAX_PACKET_SIZE = 65535 + 6
const DWORD | MPEG1_PACK_HEADER_SIZE = 12
const DWORD | MPEG1_PACK_START_CODE = 0x000001BA
const DWORD | MPEG1_PACKET_HEADER_MAX_SIZE = 34
const DWORD | MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE = 16
const DWORD | MPEG1_PACKET_HEADER_MIN_SIZE = 6
const DWORD | MPEG1_SEQUENCE_HEADER_CODE = 0x000001B3
const DWORD | MPEG1_START_CODE_PREFIX = 0x00000100
const DWORD | MPEG1_STOP_CODE = 0x000001B9
const BYTE | MPEG1_STREAMTYPE_ALL_AUDIO = 0xB8
const BYTE | MPEG1_STREAMTYPE_ALL_VIDEO = 0xB9
const BYTE | MPEG1_STREAMTYPE_AUDIO_MASK = 0xC0
const BYTE | MPEG1_STREAMTYPE_DATA_MASK = 0xF0
const BYTE | MPEG1_STREAMTYPE_PADDING = 0xBE
const BYTE | MPEG1_STREAMTYPE_PRIVATE1 = 0xBD
const BYTE | MPEG1_STREAMTYPE_PRIVATE2 = 0xBF
const BYTE | MPEG1_STREAMTYPE_RESERVED = 0xBC
const BYTE | MPEG1_STREAMTYPE_VIDEO_MASK = 0xE0
const DWORD | MPEG1_SYSTEM_HEADER_CODE = 0x000001BB
const DWORD | MPEG1_SYSTEM_HEADER_MIN_SIZE = 12
const DWORD | MPEG1_SYSTEM_HEADER_PREFIX = 6
const DWORD | MPEG1_SYSTEM_HEADER_STREAM = 3
const DWORD | MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE = 140
const DWORD | MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12

Enumeration Type Documentation

enum MPEG1AudioFlags
Enumerator:
MPEG1_AUDIO_PRIVATE_BIT
MPEG1_AUDIO_COPYRIGHT_BIT
MPEG1_AUDIO_ORIGINAL_BIT
MPEG1_AUDIO_PROTECTION_BIT
MPEG1_AUDIO_PRIVATE_BIT
MPEG1_AUDIO_COPYRIGHT_BIT
MPEG1_AUDIO_ORIGINAL_BIT
MPEG1_AUDIO_PROTECTION_BIT

Definition at line 149 of file Parse.h.

{
    MPEG1_AUDIO_PRIVATE_BIT    = 0x01,  // = ACM_MPEG_PRIVATEBIT
    MPEG1_AUDIO_COPYRIGHT_BIT  = 0x02,  // = ACM_MPEG_COPYRIGHT
    MPEG1_AUDIO_ORIGINAL_BIT   = 0x04,  // = ACM_MPEG_ORIGINALHOME
    MPEG1_AUDIO_PROTECTION_BIT = 0x08,  // = ACM_MPEG_PROTECTIONBIT
};

enum MPEG1AudioLayer
Enumerator:
MPEG1_Audio_Layer1
MPEG1_Audio_Layer2
MPEG1_Audio_Layer3
MPEG1_Audio_Layer1
MPEG1_Audio_Layer2
MPEG1_Audio_Layer3

Definition at line 131 of file Parse.h.

{
    MPEG1_Audio_Layer1 = 0,
    MPEG1_Audio_Layer2,
    MPEG1_Audio_Layer3
};

enum MPEG1AudioMode
Enumerator:
MPEG1_Audio_Stereo
MPEG1_Audio_JointStereo
MPEG1_Audio_DualChannel
MPEG1_Audio_SingleChannel
MPEG1_Audio_Stereo
MPEG1_Audio_JointStereo
MPEG1_Audio_DualChannel
MPEG1_Audio_SingleChannel

Definition at line 138 of file Parse.h.

{
    MPEG1_Audio_Stereo = 0,
    MPEG1_Audio_JointStereo,
    MPEG1_Audio_DualChannel,
    MPEG1_Audio_SingleChannel
};

enum StreamType
Enumerator:
StreamType_Unknown
StreamType_AllAudio
StreamType_AllVideo
StreamType_Reserved
StreamType_Private1
StreamType_Padding
StreamType_Private2
StreamType_Audio
StreamType_Video
StreamType_Data
StreamType_Unknown
StreamType_AllAudio
StreamType_AllVideo
StreamType_Reserved
StreamType_Private1
StreamType_Padding
StreamType_Private2
StreamType_Audio
StreamType_Video
StreamType_Data

Definition at line 64 of file Parse.h.

{
    StreamType_Unknown,
    StreamType_AllAudio,
    StreamType_AllVideo,
    StreamType_Reserved,
    StreamType_Private1,
    StreamType_Padding,
    StreamType_Private2,
    StreamType_Audio,   // ISO/IEC 11172-3
    StreamType_Video,   // ISO/IEC 11172-2
    StreamType_Data
};

Function Documentation

HRESULT ReadAudioFrameHeader | ( | const BYTE * | pData,
 |  | DWORD | cbData,
 |  | MPEG1AudioFrameHeader & | audioHeader,
 |  | DWORD * | pAte
 | ) |  |

Definition at line 1136 of file Parse.cpp.

{
    HRESULT hr = S_OK;
    MPEG1AudioFrameHeader header;
    ZeroMemory(&header, sizeof(header));

    BYTE bitRateIndex = 0;
    BYTE samplingIndex = 0;

    *pAte = 0;

    if (cbData < MPEG1_AUDIO_FRAME_HEADER_SIZE)
    {
        return S_FALSE;
    }

    if (pData[0] != 0xFF)
    {
        return E_FAIL;
    }

    if (!HAS_FLAG(pData[1], 0xF8))
    {
        return E_FAIL;
    }

    // Layer bits
    switch (pData[1] & 0x06)
    {
    case 0x00:
        return E_FAIL;

    case 0x06:
        header.layer = MPEG1_Audio_Layer1;
        break;

    case 0x04:
        header.layer = MPEG1_Audio_Layer2;
        break;

    case 0x02:
        header.layer = MPEG1_Audio_Layer3;
        break;

    default:
        return E_UNEXPECTED; // Cannot actually happen, given our bitmask above.
    }

    bitRateIndex = (pData[2] & 0xF0) >> 4;
    samplingIndex = (pData[2] & 0x0C) >> 2;

    // Bit rate.
    // Note: Accoring to ISO/IEC 11172-3, some combinations of bitrate and
    // mode are not valid. However, this is up to the decoder to validate.
    hr = GetAudioBitRate(header.layer, bitRateIndex, &header.dwBitRate);

    // Sampling frequency.
    if (SUCCEEDED(hr))
    {
        hr = GetSamplingFrequency(samplingIndex, &header.dwSamplesPerSec);
    }

    if (SUCCEEDED(hr))
    {
        header.mode = static_cast<MPEG1AudioMode>((pData[3] & 0xC0) >> 6);
        header.modeExtension = (pData[3] & 0x30) >> 4;
        header.emphasis = (pData[3] & 0x03);

        // Parse the various bit flags.
        if (HAS_FLAG(pData[1], 0x01))
        {
            header.wFlags |= MPEG1_AUDIO_PROTECTION_BIT;
        }
        if (HAS_FLAG(pData[2], 0x01))
        {
            header.wFlags |= MPEG1_AUDIO_PRIVATE_BIT;
        }
        if (HAS_FLAG(pData[3], 0x08))
        {
            header.wFlags |= MPEG1_AUDIO_COPYRIGHT_BIT;
        }
        if (HAS_FLAG(pData[3], 0x04))
        {
            header.wFlags |= MPEG1_AUDIO_ORIGINAL_BIT;
        }

        if (header.mode == MPEG1_Audio_SingleChannel)
        {
            header.nChannels = 1;
        }
        else
        {
            header.nChannels = 2;
        }

        header.nBlockAlign = 1;

        CopyMemory(&audioHeader, &header, sizeof(audioHeader));
    }

    return  hr;

};

HRESULT ReadVideoSequenceHeader | ( | _In_reads_bytes_(cbData) const BYTE * | pData,
 |  | DWORD | cbData,
 |  | MPEG1VideoSeqHeader & | seqHeader,
 |  | _Out_ DWORD * | pAte
 | ) |  |

Definition at line 957 of file Parse.cpp.

{
    DWORD cbPadding = 0;

    if (pAte == nullptr || pData == nullptr)
    {
        return E_INVALIDARG;
    }

    *pAte = 0;

    // Skip to the sequence header code.
    while ( (cbPadding + 4) <= cbData && ((DWORD*)pData)[0] == 0 )
    {
        pData += 4;
        cbPadding += 4;
    }

    cbData -= cbPadding;

    // Check for the minimum size buffer.
    if (cbData < MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE)
    {
        *pAte = cbPadding;
        return S_FALSE;
    }

    // Validate the sequence header code.
    if (MAKE_DWORD(pData) != MPEG1_SEQUENCE_HEADER_CODE)
    {
        return E_FAIL;
    }

    // Calculate the actual required size.
    DWORD cbRequired = MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE;

    // Look for quantization matrices.
    if ( HAS_FLAG(pData[11], 0x02) )
    {
        // Intra quantization matrix is TRUE.
        cbRequired += 64;
    }
    // Intra is FALSE, look for non-intra flag
    else if ( HAS_FLAG(pData[11], 0x01) )
    {
        cbRequired += 64;
    }

    if (cbData < cbRequired)
    {
        return S_FALSE;
    }

    ZeroMemory(&seqHeader, sizeof(seqHeader));

    // Check the marker bit.
    if ( !HAS_FLAG(pData[10], 0x20) )
    {
        return E_FAIL;
    }

    BYTE parCode = pData[7] >> 4;
    BYTE frameRateCode = pData[7] & 0x0F;

    if (FAILED(GetPixelAspectRatio(parCode, &seqHeader.pixelAspectRatio)))
    {
        return E_FAIL;
    }

    if (FAILED(GetFrameRate(frameRateCode, &seqHeader.frameRate)))
    {
        return E_FAIL;
    }

    seqHeader.width = (pData[4] << 4) | (pData[5] >> 4) ;
    seqHeader.height = ((pData[5] & 0x0F) << 8) | (pData[6]);
    seqHeader.bitRate = (pData[8] << 10) | (pData[9] << 2) | (pData[10] >> 6);

    if (seqHeader.bitRate == 0)
    {
        return E_FAIL;  // Not allowed.
    }
    else if (seqHeader.bitRate == 0x3FFFF)
    {
        seqHeader.bitRate = 0; // Variable bit-rate.
    }
    else
    {
        seqHeader.bitRate = seqHeader.bitRate * 400; // Units of 400 bps
    }

    seqHeader.cbVBV_Buffer = ( ((pData[10] & 0x1F) << 5) | (pData[11] >> 3) ) * 2048;
    seqHeader.bConstrained = HAS_FLAG(pData[11], 0x04);

    seqHeader.cbHeader = cbRequired;
    CopyMemory(seqHeader.header, pData, cbRequired);

    *pAte = cbRequired + cbPadding;

    return S_OK;
}

Variable Documentation

const DWORD MPEG1_AUDIO_FRAME_HEADER_SIZE = 4

Definition at line 39 of file Parse.h.

const DWORD MPEG1_MAX_PACKET_SIZE = 65535 + 6

Definition at line 25 of file Parse.h.

const DWORD MPEG1_PACK_HEADER_SIZE = 12

Definition at line 26 of file Parse.h.

const DWORD MPEG1_PACK_START_CODE = 0x000001BA

Definition at line 44 of file Parse.h.

const DWORD MPEG1_PACKET_HEADER_MAX_SIZE = 34

Definition at line 34 of file Parse.h.

const DWORD MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE = 16

Definition at line 33 of file Parse.h.

const DWORD MPEG1_PACKET_HEADER_MIN_SIZE = 6

Definition at line 32 of file Parse.h.

const DWORD MPEG1_SEQUENCE_HEADER_CODE = 0x000001B3

Definition at line 46 of file Parse.h.

const DWORD MPEG1_START_CODE_PREFIX = 0x00000100

Definition at line 43 of file Parse.h.

const DWORD MPEG1_STOP_CODE = 0x000001B9

Definition at line 47 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_ALL_AUDIO = 0xB8

Definition at line 50 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_ALL_VIDEO = 0xB9

Definition at line 51 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_AUDIO_MASK = 0xC0

Definition at line 56 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_DATA_MASK = 0xF0

Definition at line 58 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_PADDING = 0xBE

Definition at line 54 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_PRIVATE1 = 0xBD

Definition at line 53 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_PRIVATE2 = 0xBF

Definition at line 55 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_RESERVED = 0xBC

Definition at line 52 of file Parse.h.

const BYTE MPEG1_STREAMTYPE_VIDEO_MASK = 0xE0

Definition at line 57 of file Parse.h.

const DWORD MPEG1_SYSTEM_HEADER_CODE = 0x000001BB

Definition at line 45 of file Parse.h.

const DWORD MPEG1_SYSTEM_HEADER_MIN_SIZE = 12

Definition at line 28 of file Parse.h.

const DWORD MPEG1_SYSTEM_HEADER_PREFIX = 6

Definition at line 29 of file Parse.h.

const DWORD MPEG1_SYSTEM_HEADER_STREAM = 3

Definition at line 30 of file Parse.h.

const DWORD MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE = 140

Definition at line 37 of file Parse.h.

const DWORD MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12

Definition at line 36 of file Parse.h.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Polar/dllmain.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Polar
Namespaces | Functions

dllmain.cpp File Reference

#include <initguid.h>
#include "PolarEffect.h"

Go to the source code of this file.

Namespaces

namespace | Microsoft
namespace | Microsoft::Samples

Functions

Microsoft::Samples::ActivatableClass (CPolarEffect)
HRESULT WINAPI | DllCanUnloadNow ()
HRESULT WINAPI | DllGetActivationFactory (_In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory **factory)
STDAPI | DllGetClassObject (_In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR *ppv)
BOOL WINAPI | DllMain (_In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved)

Function Documentation

HRESULT WINAPI DllCanUnloadNow ( )

Definition at line 46 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return (module.Terminate()) ? S_OK : S_FALSE;
}

HRESULT WINAPI DllGetActivationFactory | ( | _In_ HSTRING | activatibleClassId,
 |  | _Outptr_ IActivationFactory ** | factory
 | ) |  |

Definition at line 40 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
    return module.GetActivationFactory( activatibleClassId, factory );
}

STDAPI DllGetClassObject | ( | _In_ REFCLSID | rclsid,
 |  | _In_ REFIID | riid,
 |  | _Outptr_ LPVOID FAR * | ppv
 | ) |  |

Definition at line 52 of file dllmain.cpp.

{
    auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
    return module.GetClassObject( rclsid, riid, ppv );
}

BOOL WINAPI DllMain | ( | _In_ HINSTANCE | hInstance,
 |  | _In_ DWORD | dwReason,
 |  | _In_opt_ LPVOID | lpReserved
 | ) |  |

Definition at line 21 of file dllmain.cpp.

{
    if( DLL_PROCESS_ATTACH == dwReason )
    {
        //
        //  Don't need per-thread callbacks
        //
        DisableThreadLibraryCalls( hInstance );

        Module<InProc>::GetModule().Create();
    }
    else if( DLL_PROCESS_DETACH == dwReason )
    {
        Module<InProc>::GetModule().Terminate();
    }

    return TRUE;
}

Generated on Sat Nov 23 2024 16:09:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Polar/PolarEffect.cpp File Reference

  • Media extensions
  • MediaExtensions
  • Polar
Functions | Variables

PolarEffect.cpp File Reference

#include "PolarEffect.h"
#include "bufferlock.h"

Go to the source code of this file.

Functions

HRESULT | GetDefaultStride (IMFMediaType *pType, LONG *plStride)
HRESULT | GetImageSize (DWORD fcc, UINT32 width, UINT32 height, DWORD *pcbImage)
void | TransformImage_NV12 (_In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 *pLookup, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
void | TransformImage_UYVY (_In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 *pLookup, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)
void | TransformImage_YUY2 (_In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 *pLookup, _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE *pDest, _In_ LONG lDestStride, _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE *pSrc, _In_ LONG lSrcStride, _In_ DWORD dwWidthInPixels, _In_ DWORD dwHeightInPixels)

Variables

const DWORD | FOURCC_NV12 = '21VN'
const DWORD | FOURCC_UYVY = 'YVYU'
const DWORD | FOURCC_YUY2 = '2YUY'
const GUID | g_MediaSubtypes []

Function Documentation

HRESULT GetDefaultStride | ( | IMFMediaType * | pType,
 |  | LONG * | plStride
 | ) |  |

Definition at line 1756 of file PolarEffect.cpp.

{
    LONG lStride = 0;

    // Try to get the default stride from the media type.
    HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
    if (FAILED(hr))
    {
        // Attribute not set. Try to calculate the default stride.
        GUID subtype = GUID_NULL;

        UINT32 width = 0;
        UINT32 height = 0;

        // Get the subtype and the image size.
        hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
        if (SUCCEEDED(hr))
        {
            hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
        }
        if (SUCCEEDED(hr))
        {
            if (subtype == MFVideoFormat_NV12)
            {
                lStride = width;
            }
            else if (subtype == MFVideoFormat_YUY2 || subtype == MFVideoFormat_UYVY)
            {
                lStride = ((width * 2) + 3) & ~3;
            }
            else
            {
                hr = E_INVALIDARG;
            }
        }

        // Set the attribute for later reference.
        if (SUCCEEDED(hr))
        {
            (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
        }
    }
    if (SUCCEEDED(hr))
    {
        *plStride = lStride;
    }
    return hr;
}

HRESULT GetImageSize | ( | DWORD | fcc,
 |  | UINT32 | width,
 |  | UINT32 | height,
 |  | DWORD * | pcbImage
 | ) |  |

Definition at line 1716 of file PolarEffect.cpp.

{
    HRESULT hr = S_OK;

    switch (fcc)
    {
    case FOURCC_YUY2:
    case FOURCC_UYVY:
        // check overflow
        if ((width > MAXDWORD / 2) || (width * 2 > MAXDWORD / height))
        {
            hr = E_INVALIDARG;
        }
        else
        {
            // 16 bpp
            *pcbImage = width * height * 2;
        }
        break;

    case FOURCC_NV12:
        // check overflow
        if ((height/2 > MAXDWORD - height) || ((height + height/2) > MAXDWORD / width))
        {
            hr = E_INVALIDARG;
        }
        else
        {
            // 12 bpp
            *pcbImage = width * (height + (height/2));
        }
        break;

    default:
        hr = E_FAIL;    // Unsupported type.
    }
    return hr;
}

void TransformImage_NV12 | ( | _In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 * | pLookup,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 208 of file PolarEffect.cpp.

{
    // NV12 is planar: Y plane, followed by packed U-V plane.

    // Y plane

    UINT32 *pLookup_Y = (UINT32*) pLookup;
    WORD *pSrc_Y = (WORD*) pSrc;
    pSrc_Y[0] = 0x0000;    // black

    for (DWORD y = 0; y < dwHeightInPixels; y++)
    {
        WORD *pDest_Y = (WORD*) pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
            UINT32 uOffset = (pLookup_Y[x] % dwWidthInPixels) + (pLookup_Y[x] / dwWidthInPixels) * lSrcStride;
            pDest_Y[x/2] = pSrc_Y[uOffset/2];
#pragma warning(pop)
        }
        pDest += lDestStride;
        pLookup_Y += dwWidthInPixels;
    }

    // U-V plane

    // NOTE: The U-V plane has 1/2 the number of lines as the Y plane.

    UINT32 *pLookup_UV = (UINT32*) pLookup;
    WORD *pSrc_UV = (WORD*) (pSrc + lSrcStride * dwHeightInPixels);
    pSrc_UV[0] = 0x8080;    // black

    for (DWORD y = 0; y < dwHeightInPixels; y += 2)
    {
        WORD *pDest_UV = (WORD*) pDest;

        for (DWORD x = 0; x < dwWidthInPixels; x += 2)
        {
#pragma warning(push)
#pragma warning(disable: 6385)
            UINT32 uOffset = (pLookup_UV[x] % dwWidthInPixels) + ((pLookup_UV[x] / dwWidthInPixels) / 2) * lSrcStride;
#pragma warning(pop)
            pDest_UV[x/2] = pSrc_UV[uOffset/2];
        }
        pDest += lDestStride;
        pLookup_UV += dwWidthInPixels * 2;
    }
}

void TransformImage_UYVY | ( | _In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 * | pLookup,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 134 of file PolarEffect.cpp.

{
    DWORD *pSrc_UYVY = (DWORD*) pSrc;

    // Byte order is U0 Y0 V0 Y1
    // Windows is little-endian so the order appears reversed.

    pSrc_UYVY[0] = 0x00800080;  // black

    for (DWORD y = 0; y < dwHeightInPixels; y++)
    {
        DWORD *pDest_UYVY = (DWORD*) pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
            UINT32 uOffset = (pLookup[x] % dwWidthInPixels) * sizeof(WORD) + (pLookup[x] / dwWidthInPixels) * lSrcStride;
            pDest_UYVY[x/2] = pSrc_UYVY[uOffset/sizeof(DWORD)];
#pragma warning(pop)
        }
        pDest += lDestStride;
        pLookup += dwWidthInPixels;
    }
}

void TransformImage_YUY2 | ( | _In_reads_(_Inexpressible_(dwWidthInPixels *dwHeightInPixels)) const UINT32 * | pLookup,
 |  | _Inout_updates_(_Inexpressible_(lDestStride *dwHeightInPixels)) BYTE * | pDest,
 |  | _In_ LONG | lDestStride,
 |  | _In_reads_(_Inexpressible_(lSrcStride *dwHeightInPixels)) const BYTE * | pSrc,
 |  | _In_ LONG | lSrcStride,
 |  | _In_ DWORD | dwWidthInPixels,
 |  | _In_ DWORD | dwHeightInPixels
 | ) |  |

Definition at line 171 of file PolarEffect.cpp.

{
    DWORD *pSrc_UYVY = (DWORD*) pSrc;

    // Byte order is Y0 U0 Y1 V0
    // Windows is little-endian so the order appears reversed.

    pSrc_UYVY[0] = 0x80008000;  // black

    for (DWORD y = 0; y < dwHeightInPixels; y++)
    {
        DWORD *pDest_UYVY = (DWORD*) pDest;

        for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
        {
#pragma warning(push)
#pragma warning(disable: 6385)
#pragma warning(disable: 6386)
            UINT32 uOffset = (pLookup[x] % dwWidthInPixels) * sizeof(WORD) + (pLookup[x] / dwWidthInPixels) * lSrcStride;
            pDest_UYVY[x/2] = pSrc_UYVY[uOffset/sizeof(DWORD)];
#pragma warning(pop)
        }
        pDest += lDestStride;
        pLookup += dwWidthInPixels;
    }
}

Variable Documentation

const DWORD FOURCC_NV12 = '21VN'

Definition at line 101 of file PolarEffect.cpp.

const DWORD FOURCC_UYVY = 'YVYU'

Definition at line 100 of file PolarEffect.cpp.

const DWORD FOURCC_YUY2 = '2YUY'

Definition at line 99 of file PolarEffect.cpp.

const GUID g_MediaSubtypes[]
Initial value:
{
    MFVideoFormat_NV12,
    MFVideoFormat_YUY2,
    MFVideoFormat_UYVY
}

Definition at line 104 of file PolarEffect.cpp.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Polar/PolarEffect.h File Reference

  • Media extensions
  • MediaExtensions
  • Polar
Classes | Typedefs | Functions

PolarEffect.h File Reference

#include <new>
#include <mfapi.h>
#include <mftransform.h>
#include <mfidl.h>
#include <mferror.h>
#include <strsafe.h>
#include <assert.h>
#include <math.h>
#include <D2d1helper.h>
#include <wrl\implements.h>
#include <wrl\module.h>
#include <windows.media.h>
#include <wrl\wrappers\corewrappers.h>
#include "PolarTransform.h"

Go to the source code of this file.

Classes

class | CPolarEffect

Typedefs

typedef void(* | IMAGE_TRANSFORM_FN )(const UINT32 *pLookup, BYTE *pDest, LONG lDestStride, const BYTE *pSrc, LONG lSrcStride, DWORD dwWidthInPixels, DWORD dwHeightInPixels)
typedef DOUBLE(* | PolarTransformer )(DOUBLE, DOUBLE, DOUBLE)

Functions

void | DllAddRef ()
void | DllRelease ()
template<class T >
void | SafeArrayDelete (T **ppT)
template<class T >
void | SafeRelease (T **ppT)

Typedef Documentation

typedef void(* IMAGE_TRANSFORM_FN)(const UINT32 *pLookup,BYTE *pDest,LONG lDestStride,const BYTE *pSrc,LONG lSrcStride,DWORD dwWidthInPixels,DWORD dwHeightInPixels)

Definition at line 58 of file PolarEffect.h.

typedef DOUBLE(* PolarTransformer)(DOUBLE, DOUBLE, DOUBLE)

Definition at line 68 of file PolarEffect.h.

Function Documentation

void DllAddRef ( )
void DllRelease ( )
template<class T >
void SafeArrayDelete ( T ** ppT )

Definition at line 47 of file PolarEffect.h.

{
    if (*ppT)
    {
        delete [] (*ppT);
        *ppT = NULL;
    }
}

template<class T >
void SafeRelease ( T ** ppT )

Definition at line 38 of file PolarEffect.h.

{
    if (*ppT)
    {
        (*ppT)->Release();
        *ppT = NULL;
    }
}

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Polar/PolarTransform.idl File Reference

  • Media extensions
  • MediaExtensions
  • Polar
Namespaces

PolarTransform.idl File Reference

#include <sdkddkver.h>

Go to the source code of this file.

Namespaces

namespace PolarTransform
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/App.xaml.cpp File Reference

  • Media Play To

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/App.xaml.h File Reference

  • Media Play To
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Constants.cpp File Reference

  • Media Play To

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Constants.h File Reference

  • Media Play To
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/MainPage.xaml.cpp File Reference

  • Media Play To

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/MainPage.xaml.h File Reference

  • Media Play To
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/pch.cpp File Reference

  • Media Play To

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/pch.h File Reference

  • Media Play To

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Scenario1.xaml.cpp File Reference

  • Media Play To

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Scenario1.xaml.h File Reference

  • Media Play To
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PlayTo::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlayTo
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Scenario2.xaml.cpp File Reference

  • Media Play To

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Scenario2.xaml.h File Reference

  • Media Play To
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PlayTo::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlayTo
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/common/LayoutAwarePage.cpp File Reference

  • Media Play To
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/common/LayoutAwarePage.h File Reference

  • Media Play To
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/common/suspensionmanager.cpp File Reference

  • Media Play To
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/common/suspensionmanager.h File Reference

  • Media Play To
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/App.xaml.cpp File Reference

  • Media Server client

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/App.xaml.h File Reference

  • Media Server client
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/Constants.cpp File Reference

  • Media Server client

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/Constants.h File Reference

  • Media Server client
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/LocateVideo.xaml.cpp File Reference

  • Media Server client

LocateVideo.xaml.cpp File Reference

#include "pch.h"
#include "LocateVideo.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/LocateVideo.xaml.h File Reference

  • Media Server client
Classes | Namespaces

LocateVideo.xaml.h File Reference

#include "pch.h"
#include "LocateVideo.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MediaServerClient::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::MediaServerClient
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/MainPage.xaml.cpp File Reference

  • Media Server client

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/MainPage.xaml.h File Reference

  • Media Server client
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/pch.cpp File Reference

  • Media Server client

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/pch.h File Reference

  • Media Server client

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/common/LayoutAwarePage.cpp File Reference

  • Media Server client
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/common/LayoutAwarePage.h File Reference

  • Media Server client
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/common/suspensionmanager.cpp File Reference

  • Media Server client
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/common/suspensionmanager.h File Reference

  • Media Server client
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/App.xaml.cs File Reference

  • MediaStreamSource media extension
  • C#,C++
Classes | Namespaces

App.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::App
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/AudioSource.xaml.cs File Reference

  • MediaStreamSource media extension
  • C#,C++
Classes | Namespaces

AudioSource.xaml.cs File Reference

Go to the source code of this file.

Classes

class | MediaStreamSource::AudioSource
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | MediaStreamSource
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/Constants.cs File Reference

  • MediaStreamSource media extension
  • C#,C++
Classes | Namespaces

Constants.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::Scenario

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/MainPage.xaml.cs File Reference

  • MediaStreamSource media extension
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::MainPageSizeChangedEventArgs

Namespaces

namespace | SDKTemplate

Enumerations

enum SDKTemplate::NotifyType {
SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage, SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage,
SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage, SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/PcmSource.cs File Reference

  • MediaStreamSource media extension
  • C#,C++
Classes | Namespaces

PcmSource.cs File Reference

Go to the source code of this file.

Classes

class | MediaStreamSource::PcmSource
A simple media source generating audio wave. More...

Namespaces

namespace | MediaStreamSource
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/App.xaml.cpp File Reference

  • Message dialog

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/App.xaml.h File Reference

  • Message dialog
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CancelCommand.xaml.cpp File Reference

  • Message dialog

CancelCommand.xaml.cpp File Reference

#include "pch.h"
#include "CancelCommand.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CancelCommand.xaml.h File Reference

  • Message dialog
Classes | Namespaces

CancelCommand.xaml.h File Reference

#include "pch.h"
#include "CancelCommand.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MessageDialogSample::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::MessageDialogSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CompletedCallback.xaml.cpp File Reference

  • Message dialog

CompletedCallback.xaml.cpp File Reference

#include "pch.h"
#include "CompletedCallback.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CompletedCallback.xaml.h File Reference

  • Message dialog
Classes | Namespaces

CompletedCallback.xaml.h File Reference

#include "pch.h"
#include "CompletedCallback.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MessageDialogSample::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::MessageDialogSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/Constants.cpp File Reference

  • Message dialog

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/Constants.h File Reference

  • Message dialog
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CustomCommand.xaml.cpp File Reference

  • Message dialog

CustomCommand.xaml.cpp File Reference

#include "pch.h"
#include "CustomCommand.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CustomCommand.xaml.h File Reference

  • Message dialog
Classes | Namespaces

CustomCommand.xaml.h File Reference

#include "pch.h"
#include "CustomCommand.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MessageDialogSample::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::MessageDialogSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/DefaultCloseCommand.xaml.cpp File Reference

  • Message dialog

DefaultCloseCommand.xaml.cpp File Reference

#include "pch.h"
#include "DefaultCloseCommand.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/DefaultCloseCommand.xaml.h File Reference

  • Message dialog
Classes | Namespaces

DefaultCloseCommand.xaml.h File Reference

#include "pch.h"
#include "DefaultCloseCommand.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::MessageDialogSample::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::MessageDialogSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/MainPage.xaml.cpp File Reference

  • Message dialog

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/MainPage.xaml.h File Reference

  • Message dialog
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/pch.cpp File Reference

  • Message dialog

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/pch.h File Reference

  • Message dialog

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/common/LayoutAwarePage.cpp File Reference

  • Message dialog
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/common/LayoutAwarePage.h File Reference

  • Message dialog
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/common/suspensionmanager.cpp File Reference

  • Message dialog
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/common/suspensionmanager.h File Reference

  • Message dialog
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/App.xaml.cpp File Reference

  • Mobile broadband account provisioning

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/App.xaml.h File Reference

  • Mobile broadband account provisioning
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/Constants.cpp File Reference

  • Mobile broadband account provisioning

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/Constants.h File Reference

  • Mobile broadband account provisioning
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/MainPage.xaml.cpp File Reference

  • Mobile broadband account provisioning

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/MainPage.xaml.h File Reference

  • Mobile broadband account provisioning
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/pch.cpp File Reference

  • Mobile broadband account provisioning

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/pch.h File Reference

  • Mobile broadband account provisioning

pch.h File Reference

#include <windows.h>
#include <strsafe.h>
#include <stdio.h>
#include <string.h>
#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/ProvisionMno.xaml.cpp File Reference

  • Mobile broadband account provisioning

ProvisionMno.xaml.cpp File Reference

#include "pch.h"
#include "ProvisionMno.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/ProvisionMno.xaml.h File Reference

  • Mobile broadband account provisioning
Classes | Namespaces

ProvisionMno.xaml.h File Reference

#include "pch.h"
#include "ProvisionMno.g.h"
#include "MainPage.xaml.h"
#include "Util.h"

Go to the source code of this file.

Classes

class | SDKSample::ProvisioningAgent::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ProvisioningAgent
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/UpdateCost.xaml.cpp File Reference

  • Mobile broadband account provisioning

UpdateCost.xaml.cpp File Reference

#include "pch.h"
#include "UpdateCost.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/UpdateCost.xaml.h File Reference

  • Mobile broadband account provisioning
Classes | Namespaces

UpdateCost.xaml.h File Reference

#include "pch.h"
#include "UpdateCost.g.h"
#include "MainPage.xaml.h"
#include "Util.h"

Go to the source code of this file.

Classes

class | SDKSample::ProvisioningAgent::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ProvisioningAgent
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/UpdateUsage.xaml.cpp File Reference

  • Mobile broadband account provisioning

UpdateUsage.xaml.cpp File Reference

#include "pch.h"
#include "UpdateUsage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/UpdateUsage.xaml.h File Reference

  • Mobile broadband account provisioning
Classes | Namespaces

UpdateUsage.xaml.h File Reference

#include "pch.h"
#include "UpdateUsage.g.h"
#include "MainPage.xaml.h"
#include "Util.h"

Go to the source code of this file.

Classes

class | SDKSample::ProvisioningAgent::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ProvisioningAgent
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/Util.cpp File Reference

  • Mobile broadband account provisioning

Util.cpp File Reference

#include "pch.h"
#include "Util.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/Util.h File Reference

  • Mobile broadband account provisioning
Classes | Namespaces

Util.h File Reference

#include "pch.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ProvisioningAgent::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ProvisioningAgent
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/App.xaml.cpp File Reference

  • Network information

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/App.xaml.h File Reference

  • Network information
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/ConnectionProfileList.xaml.cpp File Reference

  • Network information

ConnectionProfileList.xaml.cpp File Reference

#include "pch.h"
#include "ConnectionProfileList.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/ConnectionProfileList.xaml.h File Reference

  • Network information
Classes | Namespaces

ConnectionProfileList.xaml.h File Reference

#include "pch.h"
#include "ConnectionProfileList.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::NetworkInformationApi::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::NetworkInformationApi
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/Constants.cpp File Reference

  • Network information

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/Constants.h File Reference

  • Network information
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/InternetConnectionProfile.xaml.cpp File Reference

  • Network information

InternetConnectionProfile.xaml.cpp File Reference

#include "pch.h"
#include "InternetConnectionProfile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/InternetConnectionProfile.xaml.h File Reference

  • Network information
Classes | Namespaces

InternetConnectionProfile.xaml.h File Reference

#include "pch.h"
#include "InternetConnectionProfile.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::NetworkInformationApi::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::NetworkInformationApi
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/LanId.xaml.cpp File Reference

  • Network information
Defines

LanId.xaml.cpp File Reference

#include "pch.h"
#include "LanId.xaml.h"

Go to the source code of this file.

Defines

#define MAX_GUID_STRING_SIZE 39

Define Documentation

#define MAX_GUID_STRING_SIZE 39

Definition at line 23 of file LanId.xaml.cpp.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/LanId.xaml.h File Reference

  • Network information
Classes | Namespaces

LanId.xaml.h File Reference

#include "pch.h"
#include "LanId.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::NetworkInformationApi::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::NetworkInformationApi
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/MainPage.xaml.cpp File Reference

  • Network information

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/MainPage.xaml.h File Reference

  • Network information
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/NetworkStatusChange.xaml.cpp File Reference

  • Network information

NetworkStatusChange.xaml.cpp File Reference

#include "pch.h"
#include "NetworkStatusChange.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/NetworkStatusChange.xaml.h File Reference

  • Network information
Classes | Namespaces

NetworkStatusChange.xaml.h File Reference

#include "pch.h"
#include "NetworkStatusChange.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::NetworkInformationApi::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::NetworkInformationApi
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/pch.cpp File Reference

  • Network information

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/pch.h File Reference

  • Network information

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/ProfileLocalUsageData.xaml.cpp File Reference

  • Network information

ProfileLocalUsageData.xaml.cpp File Reference

#include "pch.h"
#include "ProfileLocalUsageData.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/ProfileLocalUsageData.xaml.h File Reference

  • Network information
Classes | Namespaces

ProfileLocalUsageData.xaml.h File Reference

#include "pch.h"
#include "ProfileLocalUsageData.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::NetworkInformationApi::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::NetworkInformationApi
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/common/LayoutAwarePage.cpp File Reference

  • Network information
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/common/LayoutAwarePage.h File Reference

  • Network information
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/common/suspensionmanager.cpp File Reference

  • Network information
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/common/suspensionmanager.h File Reference

  • Network information
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/App.xaml.cpp File Reference

  • Network status background
  • NetworkStatusApp

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/App.xaml.h File Reference

  • Network status background
  • NetworkStatusApp
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/Constants.cpp File Reference

  • Network status background
  • NetworkStatusApp

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/Constants.h File Reference

  • Network status background
  • NetworkStatusApp
Classes | Namespaces | Defines

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::BackgroundTaskSample
class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample

Defines

#define | SampleBackgroundTaskEntryPoint "NetworkStatusTask.BackgroundTask"
#define | SampleBackgroundTaskWithConditionName "SampleBackgroundTaskWithCondition"

Define Documentation

#define SampleBackgroundTaskEntryPoint "NetworkStatusTask.BackgroundTask"

Definition at line 19 of file Constants.h.

#define SampleBackgroundTaskWithConditionName "SampleBackgroundTaskWithCondition"

Definition at line 20 of file Constants.h.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/MainPage.xaml.cpp File Reference

  • Network status background
  • NetworkStatusApp

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/MainPage.xaml.h File Reference

  • Network status background
  • NetworkStatusApp
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/pch.cpp File Reference

  • Network status background
  • NetworkStatusApp

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/pch.h File Reference

  • Network status background
  • NetworkStatusApp

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusTask/BackgroundTask.h File Reference

  • Network status background
  • NetworkStatusTask
Classes | Namespaces

BackgroundTask.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | NetworkStatusTask::sealed

Namespaces

namespace | NetworkStatusTask
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusTask/pch.cpp File Reference

  • Network status background
  • NetworkStatusTask

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusTask/pch.h File Reference

  • Network status background
  • NetworkStatusTask

pch.h File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/App.xaml.cpp File Reference

  • Number formatting and parsing

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/App.xaml.h File Reference

  • Number formatting and parsing
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/Constants.cpp File Reference

  • Number formatting and parsing

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/Constants.h File Reference

  • Number formatting and parsing
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/CurrencyFormatting.xaml.cpp File Reference

  • Number formatting and parsing

CurrencyFormatting.xaml.cpp File Reference

#include "pch.h"
#include "CurrencyFormatting.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/CurrencyFormatting.xaml.h File Reference

  • Number formatting and parsing
Classes | Namespaces

CurrencyFormatting.xaml.h File Reference

#include "pch.h"
#include "CurrencyFormatting.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::NumberFormatting::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::NumberFormatting
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/DecimalFormatting.xaml.cpp File Reference

  • Number formatting and parsing

DecimalFormatting.xaml.cpp File Reference

#include "pch.h"
#include "DecimalFormatting.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/DecimalFormatting.xaml.h File Reference

  • Number formatting and parsing
Classes | Namespaces

DecimalFormatting.xaml.h File Reference

#include "pch.h"
#include "DecimalFormatting.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::NumberFormatting::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::NumberFormatting
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/MainPage.xaml.cpp File Reference

  • Number formatting and parsing

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/MainPage.xaml.h File Reference

  • Number formatting and parsing
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/NumberParsing.xaml.cpp File Reference

  • Number formatting and parsing

NumberParsing.xaml.cpp File Reference

#include "pch.h"
#include "NumberParsing.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/NumberParsing.xaml.h File Reference

  • Number formatting and parsing
Classes | Namespaces

NumberParsing.xaml.h File Reference

#include "pch.h"
#include "NumberParsing.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::NumberFormatting::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::NumberFormatting
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/pch.cpp File Reference

  • Number formatting and parsing

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/pch.h File Reference

  • Number formatting and parsing

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/common/LayoutAwarePage.cpp File Reference

  • Number formatting and parsing
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/common/LayoutAwarePage.h File Reference

  • Number formatting and parsing
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/common/suspensionmanager.cpp File Reference

  • Number formatting and parsing
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/common/suspensionmanager.h File Reference

  • Number formatting and parsing
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/App.xaml.cpp File Reference

  • OrientationSensor

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/App.xaml.h File Reference

  • OrientationSensor
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/Constants.cpp File Reference

  • OrientationSensor

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/Constants.h File Reference

  • OrientationSensor
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/MainPage.xaml.cpp File Reference

  • OrientationSensor

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/MainPage.xaml.h File Reference

  • OrientationSensor
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/pch.cpp File Reference

  • OrientationSensor

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/pch.h File Reference

  • OrientationSensor

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/Scenario1.xaml.cpp File Reference

  • OrientationSensor

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/Scenario1.xaml.h File Reference

  • OrientationSensor
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::OrientationSensorCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::OrientationSensorCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/Scenario2.xaml.cpp File Reference

  • OrientationSensor

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/Scenario2.xaml.h File Reference

  • OrientationSensor
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::OrientationSensorCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::OrientationSensorCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/common/LayoutAwarePage.cpp File Reference

  • OrientationSensor
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/common/LayoutAwarePage.h File Reference

  • OrientationSensor
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/common/suspensionmanager.cpp File Reference

  • OrientationSensor
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/common/suspensionmanager.h File Reference

  • OrientationSensor
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/App.xaml.cpp File Reference

  • Playback Manager Companion

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/App.xaml.h File Reference

  • Playback Manager Companion
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/Constants.cpp File Reference

  • Playback Manager Companion

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/Constants.h File Reference

  • Playback Manager Companion
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/MainPage.xaml.cpp File Reference

  • Playback Manager Companion

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/MainPage.xaml.h File Reference

  • Playback Manager Companion
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/pch.cpp File Reference

  • Playback Manager Companion

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/pch.h File Reference

  • Playback Manager Companion

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/PlaybackControl.xaml.cpp File Reference

  • Playback Manager Companion

PlaybackControl.xaml.cpp File Reference

#include "pch.h"
#include "PlaybackControl.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/PlaybackControl.xaml.h File Reference

  • Playback Manager Companion
Classes | Namespaces

PlaybackControl.xaml.h File Reference

#include "pch.h"
#include "PlaybackControl.g.h"
#include "MainPage.xaml.h"
#include <agile.h>

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager2::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager2
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeAlert.xaml.cpp File Reference

  • Playback Manager Companion

StreamTypeAlert.xaml.cpp File Reference

#include "pch.h"
#include "StreamTypeAlert.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeAlert.xaml.h File Reference

  • Playback Manager Companion
Classes | Namespaces

StreamTypeAlert.xaml.h File Reference

#include "pch.h"
#include "StreamTypeAlert.g.h"
#include "MainPage.xaml.h"
#include "PlaybackControl.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager2::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager2
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeCommunications.xaml.cpp File Reference

  • Playback Manager Companion

StreamTypeCommunications.xaml.cpp File Reference

#include "pch.h"
#include "StreamTypeCommunications.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeCommunications.xaml.h File Reference

  • Playback Manager Companion
Classes | Namespaces

StreamTypeCommunications.xaml.h File Reference

#include "pch.h"
#include "StreamTypeCommunications.g.h"
#include "MainPage.xaml.h"
#include "PlaybackControl.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager2::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager2
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeMedia.xaml.cpp File Reference

  • Playback Manager Companion

StreamTypeMedia.xaml.cpp File Reference

#include "pch.h"
#include "StreamTypeMedia.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeMedia.xaml.h File Reference

  • Playback Manager Companion
Classes | Namespaces

StreamTypeMedia.xaml.h File Reference

#include "pch.h"
#include "StreamTypeMedia.g.h"
#include "MainPage.xaml.h"
#include "Playback.h"

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager2::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager2
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeOther.xaml.cpp File Reference

  • Playback Manager Companion

StreamTypeOther.xaml.cpp File Reference

#include "pch.h"
#include "StreamTypeOther.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeOther.xaml.h File Reference

  • Playback Manager Companion
Classes | Namespaces

StreamTypeOther.xaml.h File Reference

#include "pch.h"
#include "StreamTypeOther.g.h"
#include "MainPage.xaml.h"
#include "PlaybackControl.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager2::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager2
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/common/LayoutAwarePage.cpp File Reference

  • Playback Manager Companion
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/common/LayoutAwarePage.h File Reference

  • Playback Manager Companion
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/common/suspensionmanager.cpp File Reference

  • Playback Manager Companion
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/common/suspensionmanager.h File Reference

  • Playback Manager Companion
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/sample-utils/CppSamplesUtils.h File Reference

  • Playback Manager Companion
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/App.xaml.cpp File Reference

  • Playback Manager msAudioCategory

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/App.xaml.h File Reference

  • Playback Manager msAudioCategory
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/Constants.cpp File Reference

  • Playback Manager msAudioCategory

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/Constants.h File Reference

  • Playback Manager msAudioCategory
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/MainPage.xaml.cpp File Reference

  • Playback Manager msAudioCategory

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/MainPage.xaml.h File Reference

  • Playback Manager msAudioCategory
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/pch.cpp File Reference

  • Playback Manager msAudioCategory

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/pch.h File Reference

  • Playback Manager msAudioCategory

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/PlaybackControl.xaml.cpp File Reference

  • Playback Manager msAudioCategory

PlaybackControl.xaml.cpp File Reference

#include "pch.h"
#include "PlaybackControl.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/PlaybackControl.xaml.h File Reference

  • Playback Manager msAudioCategory
Classes | Namespaces

PlaybackControl.xaml.h File Reference

#include "pch.h"
#include "PlaybackControl.g.h"
#include "MainPage.xaml.h"
#include <agile.h>

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/StreamTypeAlert.xaml.cpp File Reference

  • Playback Manager msAudioCategory

StreamTypeAlert.xaml.cpp File Reference

#include "pch.h"
#include "StreamTypeAlert.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/StreamTypeAlert.xaml.h File Reference

  • Playback Manager msAudioCategory
Classes | Namespaces

StreamTypeAlert.xaml.h File Reference

#include "pch.h"
#include "StreamTypeAlert.g.h"
#include "MainPage.xaml.h"
#include "PlaybackControl.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/StreamTypeMedia.xaml.cpp File Reference

  • Playback Manager msAudioCategory

StreamTypeMedia.xaml.cpp File Reference

#include "pch.h"
#include "StreamTypeMedia.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/StreamTypeMedia.xaml.h File Reference

  • Playback Manager msAudioCategory
Classes | Namespaces

StreamTypeMedia.xaml.h File Reference

#include "pch.h"
#include "StreamTypeMedia.g.h"
#include "MainPage.xaml.h"
#include "Playback.h"

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/StreamTypeOther.xaml.cpp File Reference

  • Playback Manager msAudioCategory

StreamTypeOther.xaml.cpp File Reference

#include "pch.h"
#include "StreamTypeOther.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/StreamTypeOther.xaml.h File Reference

  • Playback Manager msAudioCategory
Classes | Namespaces

StreamTypeOther.xaml.h File Reference

#include "pch.h"
#include "StreamTypeOther.g.h"
#include "MainPage.xaml.h"
#include "PlaybackControl.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PlaybackManager::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlaybackManager
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/common/LayoutAwarePage.cpp File Reference

  • Playback Manager msAudioCategory
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/common/LayoutAwarePage.h File Reference

  • Playback Manager msAudioCategory
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/common/suspensionmanager.h File Reference

  • Playback Manager msAudioCategory
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Add.xaml.cpp File Reference

  • Playlist

Add.xaml.cpp File Reference

#include "pch.h"
#include "Add.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Add.xaml.h File Reference

  • Playlist
Classes | Namespaces

Add.xaml.h File Reference

#include "pch.h"
#include "Add.g.h"
#include "MainPage.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Playlists::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Playlists
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/App.xaml.cpp File Reference

  • Playlist

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/App.xaml.h File Reference

  • Playlist
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Clear.xaml.cpp File Reference

  • Playlist

Clear.xaml.cpp File Reference

#include "pch.h"
#include "Clear.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Clear.xaml.h File Reference

  • Playlist
Classes | Namespaces

Clear.xaml.h File Reference

#include "pch.h"
#include "Clear.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Playlists::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Playlists
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Constants.cpp File Reference

  • Playlist

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Constants.h File Reference

  • Playlist
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Create.xaml.cpp File Reference

  • Playlist

Create.xaml.cpp File Reference

#include "pch.h"
#include "Create.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Create.xaml.h File Reference

  • Playlist
Classes | Namespaces

Create.xaml.h File Reference

#include "pch.h"
#include "Create.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Playlists::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Playlists
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Display.xaml.cpp File Reference

  • Playlist

Display.xaml.cpp File Reference

#include "pch.h"
#include "Display.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Display.xaml.h File Reference

  • Playlist
Classes | Namespaces

Display.xaml.h File Reference

#include "pch.h"
#include "Display.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Playlists::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Playlists
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/MainPage.xaml.cpp File Reference

  • Playlist

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/MainPage.xaml.h File Reference

  • Playlist
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/pch.cpp File Reference

  • Playlist

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/pch.h File Reference

  • Playlist

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Remove.xaml.cpp File Reference

  • Playlist

Remove.xaml.cpp File Reference

#include "pch.h"
#include "Remove.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Remove.xaml.h File Reference

  • Playlist
Classes | Namespaces

Remove.xaml.h File Reference

#include "pch.h"
#include "Remove.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Playlists::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Playlists
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/common/LayoutAwarePage.cpp File Reference

  • Playlist
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/common/LayoutAwarePage.h File Reference

  • Playlist
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/common/suspensionmanager.cpp File Reference

  • Playlist
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/common/suspensionmanager.h File Reference

  • Playlist
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/App.xaml.cpp File Reference

  • PlayToReceiver

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/App.xaml.h File Reference

  • PlayToReceiver
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/audiovideoptr.xaml.cpp File Reference

  • PlayToReceiver
Variables

audiovideoptr.xaml.cpp File Reference

#include "pch.h"
#include <string.h>
#include "AudioVideoPTR.xaml.h"

Go to the source code of this file.

Variables

Scenario1 g_this

Variable Documentation

Scenario1 g_this

Definition at line 29 of file audiovideoptr.xaml.cpp.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/audiovideoptr.xaml.h File Reference

  • PlayToReceiver
Classes | Namespaces

audiovideoptr.xaml.h File Reference

#include <agile.h>
#include "pch.h"
#include "AudioVideoPTR.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PlayToreceiver::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PlayToreceiver
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/Constants.cpp File Reference

  • PlayToReceiver

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/Constants.h File Reference

  • PlayToReceiver
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/MainPage.xaml.cpp File Reference

  • PlayToReceiver

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/MainPage.xaml.h File Reference

  • PlayToReceiver
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/pch.cpp File Reference

  • PlayToReceiver

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/pch.h File Reference

  • PlayToReceiver

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/common/LayoutAwarePage.cpp File Reference

  • PlayToReceiver
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/common/LayoutAwarePage.h File Reference

  • PlayToReceiver
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/common/suspensionmanager.cpp File Reference

  • PlayToReceiver
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/common/suspensionmanager.h File Reference

  • PlayToReceiver
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/App.xaml.cpp File Reference

  • Portable device API

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/App.xaml.h File Reference

  • Portable device API
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/Constants.cpp File Reference

  • Portable device API

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/Constants.h File Reference

  • Portable device API
Classes | Namespaces | Defines | Typedefs | Functions

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::CoTaskMemFreeArray
struct | SDKSample::CoTaskMemFreeStruct
class | SDKSample::MainPage
struct | SDKSample::PropVariantClearStruct
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample

Defines

#define | NUM_OBJECTS_TO_REQUEST 10

Typedefs

typedef std::unique_ptr
< wchar_t, CoTaskMemFreeStruct > 		SDKSample::CoTaskMemString
typedef std::unique_ptr
< PROPVARIANT,
PropVariantClearStruct > 		SDKSample::PropVariantPtr

Functions

Microsoft::WRL::ComPtr
< IPortableDeviceValues > 		SDKSample::GetClientInfo ()
Platform::String | SDKSample::GetFirstStorageId (_In_ IPortableDevice *device)
ULONGLONG | SDKSample::StreamCopy (_In_ IStream *destStream, _In_ IStream *sourceStream, DWORD transferSizeBytes)
void | SDKSample::ThrowIfFailed (HRESULT hr)

Define Documentation

#define NUM_OBJECTS_TO_REQUEST 10

Definition at line 15 of file Constants.h.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/EventCallback.h File Reference

  • Portable device API
Classes | Namespaces | Functions

EventCallback.h File Reference

#include <wrl\implements.h>

Go to the source code of this file.

Classes

class | SDKSample::PortableDeviceCPP::EventCallback

Namespaces

namespace | SDKSample
namespace | SDKSample::PortableDeviceCPP

Functions

public delegate void | SDKSample::PortableDeviceCPP::EventReceived (Platform::String^deviceId, Platform::String^eventData)
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/MainPage.xaml.cpp File Reference

  • Portable device API

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/MainPage.xaml.h File Reference

  • Portable device API
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/pch.cpp File Reference

  • Portable device API

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/pch.h File Reference

  • Portable device API

pch.h File Reference

#include <windows.h>
#include <vector>
#include <memory>
#include <collection.h>
#include <shcore.h>
#include <wrl\client.h>
#include <PortableDevice.h>
#include <PortableDeviceApi.h>
#include <PortableDeviceTypes.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S1_DeviceProperties.xaml.cpp File Reference

  • Portable device API

S1_DeviceProperties.xaml.cpp File Reference

#include "pch.h"
#include "Constants.h"
#include "S1_DeviceProperties.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S1_DeviceProperties.xaml.h File Reference

  • Portable device API
Classes | Namespaces

S1_DeviceProperties.xaml.h File Reference

#include "pch.h"
#include "S1_DeviceProperties.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PortableDeviceCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PortableDeviceCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S2_Enumeration.xaml.cpp File Reference

  • Portable device API

S2_Enumeration.xaml.cpp File Reference

#include "pch.h"
#include "S2_Enumeration.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S2_Enumeration.xaml.h File Reference

  • Portable device API
Classes | Namespaces

S2_Enumeration.xaml.h File Reference

#include "pch.h"
#include "S2_Enumeration.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PortableDeviceCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PortableDeviceCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S3_SendToDevice.xaml.cpp File Reference

  • Portable device API
Defines

S3_SendToDevice.xaml.cpp File Reference

#include "pch.h"
#include "S3_SendToDevice.xaml.h"

Go to the source code of this file.

Defines

#define COMPILETIMESTRLEN(A) ARRAYSIZE(A) - 1

Define Documentation

#define COMPILETIMESTRLEN ( A ) ARRAYSIZE(A) - 1

Returns an IPortableDeviceValues containing properties used for creating an image object on the device.

Parameters:
file | The image file that will be transferred to the new image object.
parentId | The parent object identifier for the new image object.
size | The size of the new image object.
Returns:
IPortableDeviceValues ComPtr containing the image object property keys and values.

Definition at line 237 of file S3_SendToDevice.xaml.cpp.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S3_SendToDevice.xaml.h File Reference

  • Portable device API
Classes | Namespaces

S3_SendToDevice.xaml.h File Reference

#include "pch.h"
#include "S3_SendToDevice.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PortableDeviceCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PortableDeviceCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S4_GetFromDevice.xaml.cpp File Reference

  • Portable device API

S4_GetFromDevice.xaml.cpp File Reference

#include "pch.h"
#include "S4_GetFromDevice.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S4_GetFromDevice.xaml.h File Reference

  • Portable device API
Classes | Namespaces

S4_GetFromDevice.xaml.h File Reference

#include "pch.h"
#include "S4_GetFromDevice.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PortableDeviceCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PortableDeviceCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S5_Events.xaml.cpp File Reference

  • Portable device API

S5_Events.xaml.cpp File Reference

#include "pch.h"
#include "Constants.h"
#include "EventCallback.h"
#include "S5_Events.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S5_Events.xaml.h File Reference

  • Portable device API
Classes | Namespaces

S5_Events.xaml.h File Reference

#include "pch.h"
#include "S5_Events.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PortableDeviceCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PortableDeviceCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S6_DeviceStatus.xaml.cpp File Reference

  • Portable device API
Defines

S6_DeviceStatus.xaml.cpp File Reference

#include "pch.h"
#include <initguid.h>
#include <guiddef.h>
#include <propkeydef.h>
#include <StatusDeviceService.h>
#include "S6_DeviceStatus.xaml.h"

Go to the source code of this file.

Defines

#define | DEFINE_DEVSVCGUID DEFINE_GUID
#define | DEFINE_DEVSVCPROPKEY DEFINE_PROPERTYKEY

Define Documentation

#define DEFINE_DEVSVCGUID DEFINE_GUID

Definition at line 22 of file S6_DeviceStatus.xaml.cpp.

#define DEFINE_DEVSVCPROPKEY DEFINE_PROPERTYKEY

Definition at line 23 of file S6_DeviceStatus.xaml.cpp.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S6_DeviceStatus.xaml.h File Reference

  • Portable device API
Classes | Namespaces | Functions

S6_DeviceStatus.xaml.h File Reference

#include "pch.h"
#include "S6_DeviceStatus.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PortableDeviceCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PortableDeviceCPP

Functions

delegate void | SDKSample::PortableDeviceCPP::OnServiceOpenComplete (HRESULT result)
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/common/LayoutAwarePage.cpp File Reference

  • Portable device API
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/common/LayoutAwarePage.h File Reference

  • Portable device API
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/common/SuspensionManager.cpp File Reference

  • Portable device API
  • common
Classes | Namespaces | Enumerations | Functions

SuspensionManager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{SuspensionManager.cpp}

Enumerations

enum anonymous_namespace{SuspensionManager.cpp}::StreamTypes {
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{SuspensionManager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{SuspensionManager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{SuspensionManager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{SuspensionManager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{SuspensionManager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{SuspensionManager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{SuspensionManager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{SuspensionManager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{SuspensionManager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/common/SuspensionManager.h File Reference

  • Portable device API
  • common
Classes | Namespaces

SuspensionManager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/App.xaml.cpp File Reference

  • Print

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/App.xaml.h File Reference

  • Print
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/BasePrintPage.cpp File Reference

  • Print

BasePrintPage.cpp File Reference

#include "pch.h"
#include "BasePrintPage.h"
#include "ContinuationPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/BasePrintPage.h File Reference

  • Print
Classes | Namespaces

BasePrintPage.h File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | PrintSample::BasePrintPage

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ContinuationPage.xaml.cpp File Reference

  • Print

ContinuationPage.xaml.cpp File Reference

#include "pch.h"
#include "ContinuationPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ContinuationPage.xaml.h File Reference

  • Print
Classes | Namespaces

ContinuationPage.xaml.h File Reference

#include "ContinuationPage.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/cppsamplesutils.h File Reference

  • Print
Classes | Namespaces | Functions

cppsamplesutils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/DisplayContent.h File Reference

  • Print
Namespaces | Enumerations

DisplayContent.h File Reference

Go to the source code of this file.

Namespaces

namespace | PrintSample

Enumerations

enum | PrintSample::DisplayContent { PrintSample::Text = 1, PrintSample::Images = 2, PrintSample::TextAndImages = 3 }
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/MainPage.xaml.cpp File Reference

  • Print

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/MainPage.xaml.h File Reference

  • Print
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample

Enumerations

enum | PrintSample::NotifyType { PrintSample::StatusMessage, PrintSample::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/pch.cpp File Reference

  • Print

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/pch.h File Reference

  • Print

pch.h File Reference

#include "CppSamplesUtils.h"
#include "BasePrintPage.h"
#include "CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/PreviewUnavailable.xaml.cpp File Reference

  • Print

PreviewUnavailable.xaml.cpp File Reference

#include "pch.h"
#include "PreviewUnavailable.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/PreviewUnavailable.xaml.h File Reference

  • Print
Classes | Namespaces

PreviewUnavailable.xaml.h File Reference

#include "PreviewUnavailable.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput1.xaml.cpp File Reference

  • Print

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput1.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput2.xaml.cpp File Reference

  • Print

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput2.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput3.xaml.cpp File Reference

  • Print

ScenarioInput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput3.xaml.h"
#include "ScenarioOutput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput3.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioInput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput4.xaml.cpp File Reference

  • Print
Functions

ScenarioInput4.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput4.xaml.h"
#include "ScenarioInput4.xaml.h"

Go to the source code of this file.

Functions

DisplayContent GetDisplayContent (int option)

Function Documentation

DisplayContent GetDisplayContent ( int option )

Definition at line 35 of file ScenarioInput4.xaml.cpp.

{
    DisplayContent displayContent;
    switch (option)
    {
    case 1:
        displayContent = DisplayContent::Text;
        break;
    case 2:
        displayContent = DisplayContent::Images;
        break;
    default:
        displayContent = DisplayContent::TextAndImages;
        break;
    }

    return displayContent;
}

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput4.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioInput4.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput4.g.h"
#include "MainPage.xaml.h"
#include "DisplayContent.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput5.xaml.cpp File Reference

  • Print

ScenarioInput5.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput5.xaml.h"
#include "ScenarioOutput5.xaml.h"
#include <algorithm>
#include <regex>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput5.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioInput5.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput5.g.h"
#include "MainPage.xaml.h"
#include "DisplayContent.h"

Go to the source code of this file.

Classes

class | PrintSample::InvalidPageException
class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput6.xaml.cpp File Reference

  • Print

ScenarioInput6.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput6.xaml.h"
#include "PreviewUnavailable.xaml.h"
#include <robuffer.h>
#include <wrl\client.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput6.xaml.h File Reference

  • Print
Classes | Namespaces | Enumerations

ScenarioInput6.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | PrintSample::PageDescription
Printable page description. More...
class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample

Enumerations

enum | PrintSample::PhotoSize { PrintSample::psFullPage, PrintSample::ps4x6, PrintSample::ps5x7, PrintSample::ps8x10 }
enum | PrintSample::Scaling { PrintSample::sShrinkToFit, PrintSample::sCrop }
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioList.xaml.cpp File Reference

  • Print

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioList.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput1.xaml.cpp File Reference

  • Print

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput1.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput2.xaml.cpp File Reference

  • Print

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput2.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput3.xaml.cpp File Reference

  • Print

ScenarioOutput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput3.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioOutput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput4.xaml.cpp File Reference

  • Print

ScenarioOutput4.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput4.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioOutput4.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput4.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput5.xaml.cpp File Reference

  • Print

ScenarioOutput5.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput5.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioOutput5.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput6.xaml.cpp File Reference

  • Print

ScenarioOutput6.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput6.xaml.h File Reference

  • Print
Classes | Namespaces

ScenarioOutput6.xaml.h File Reference

#include "ScenarioOutput6.g.h"

Go to the source code of this file.

Classes

class | PrintSample::sealed
A paged used to flow text from a given text container Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page" In that case simply add new continuation pages of the given size until all the content can be displayed. More...

Namespaces

namespace | PrintSample
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/App.xaml.cpp File Reference

  • Programmatic file search

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/App.xaml.h File Reference

  • Programmatic file search
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/Constants.cpp File Reference

  • Programmatic file search

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/Constants.h File Reference

  • Programmatic file search
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/MainPage.xaml.cpp File Reference

  • Programmatic file search

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/MainPage.xaml.h File Reference

  • Programmatic file search
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/pch.cpp File Reference

  • Programmatic file search

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/pch.h File Reference

  • Programmatic file search

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/Scenario1.xaml.cpp File Reference

  • Programmatic file search

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/Scenario1.xaml.h File Reference

  • Programmatic file search
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FileSearch::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FileSearch
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/common/LayoutAwarePage.cpp File Reference

  • Programmatic file search
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/common/LayoutAwarePage.h File Reference

  • Programmatic file search
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/common/suspensionmanager.cpp File Reference

  • Programmatic file search
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/common/suspensionmanager.h File Reference

  • Programmatic file search
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/App.xaml.cpp File Reference

  • Proximity

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/App.xaml.h File Reference

  • Proximity
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ProximityCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ProximityCPP
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/Constants.cpp File Reference

  • Proximity

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/Constants.h File Reference

  • Proximity
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | ProximityCPP::MainPage
struct | ProximityCPP::Scenario

Namespaces

namespace | ProximityCPP
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/MainPage.xaml.cpp File Reference

  • Proximity

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/MainPage.xaml.h File Reference

  • Proximity
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | ProximityCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | ProximityCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ProximityCPP

Enumerations

enum | ProximityCPP::NotifyType { ProximityCPP::StatusMessage, ProximityCPP::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/pch.cpp File Reference

  • Proximity

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/pch.h File Reference

  • Proximity

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/PeerFinderScenario.xaml.cpp File Reference

  • Proximity

PeerFinderScenario.xaml.cpp File Reference

#include "pch.h"
#include "PeerFinderScenario.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/PeerFinderScenario.xaml.h File Reference

  • Proximity
Classes | Namespaces

PeerFinderScenario.xaml.h File Reference

#include "pch.h"
#include "PeerFinderScenario.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ProximityCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ProximityCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/ProximityDeviceEvents.xaml.cpp File Reference

  • Proximity

ProximityDeviceEvents.xaml.cpp File Reference

#include "pch.h"
#include "ProximityDeviceEvents.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/ProximityDeviceEvents.xaml.h File Reference

  • Proximity
Classes | Namespaces

ProximityDeviceEvents.xaml.h File Reference

#include "pch.h"
#include "ProximityDeviceEvents.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ProximityCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ProximityCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/ProximityDeviceScenario.xaml.cpp File Reference

  • Proximity

ProximityDeviceScenario.xaml.cpp File Reference

#include "pch.h"
#include "ProximityDeviceScenario.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/ProximityDeviceScenario.xaml.h File Reference

  • Proximity
Classes | Namespaces

ProximityDeviceScenario.xaml.h File Reference

#include "pch.h"
#include "ProximityDeviceScenario.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ProximityCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | ProximityCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/common/LayoutAwarePage.cpp File Reference

  • Proximity
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/common/LayoutAwarePage.h File Reference

  • Proximity
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | ProximityCPP::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | ProximityCPP
namespace | ProximityCPP::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/sample-utils/CppSamplesUtils.h File Reference

  • Proximity
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/App.xaml.cpp File Reference

  • Push and periodic notifications client-side

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/App.xaml.h File Reference

  • Push and periodic notifications client-side
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Constants.cpp File Reference

  • Push and periodic notifications client-side

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Constants.h File Reference

  • Push and periodic notifications client-side
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/MainPage.xaml.h File Reference

  • Push and periodic notifications client-side
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/pch.cpp File Reference

  • Push and periodic notifications client-side

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/pch.h File Reference

  • Push and periodic notifications client-side

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Scenario1.xaml.h File Reference

  • Push and periodic notifications client-side
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SDKTemplate::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SDKTemplate
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Scenario2.xaml.h File Reference

  • Push and periodic notifications client-side
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SDKTemplate::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SDKTemplate
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Scenario3.xaml.h File Reference

  • Push and periodic notifications client-side
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SDKTemplate::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SDKTemplate
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Scenario4.xaml.h File Reference

  • Push and periodic notifications client-side
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SDKTemplate::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SDKTemplate
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Scenario5.xaml.h File Reference

  • Push and periodic notifications client-side
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SDKTemplate::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SDKTemplate
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/App.xaml.cpp File Reference

  • Raw notifications
  • MainAppSample

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/App.xaml.h File Reference

  • Raw notifications
  • MainAppSample
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | RawNotificationsSampleCPP::sealed

Namespaces

namespace | RawNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/CppSamplesUtils.h File Reference

  • Raw notifications
  • MainAppSample
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/MainPage.xaml.cpp File Reference

  • Raw notifications
  • MainAppSample

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/MainPage.xaml.h File Reference

  • Raw notifications
  • MainAppSample
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | RawNotificationsSampleCPP::sealed

Namespaces

namespace | RawNotificationsSampleCPP

Enumerations

enum | RawNotificationsSampleCPP::NotifyType { RawNotificationsSampleCPP::StatusMessage, RawNotificationsSampleCPP::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/pch.cpp File Reference

  • Raw notifications
  • MainAppSample

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/pch.h File Reference

  • Raw notifications
  • MainAppSample

pch.h File Reference

#include <ppltasks.h>
#include "CppSamplesUtils.h"
#include "CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioInput1.xaml.cpp File Reference

  • Raw notifications
  • MainAppSample
Variables

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Variables

const wchar_t * | SAMPLE_TASK_ENTRY_POINT = "BackgroundTasks.SampleBackgroundTask"
const wchar_t * | SAMPLE_TASK_NAME = "SampleBackgroundTask"

Variable Documentation

const wchar_t* SAMPLE_TASK_ENTRY_POINT = "BackgroundTasks.SampleBackgroundTask"

Definition at line 37 of file ScenarioInput1.xaml.cpp.

const wchar_t* SAMPLE_TASK_NAME = "SampleBackgroundTask"

Definition at line 36 of file ScenarioInput1.xaml.cpp.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioInput1.xaml.h File Reference

  • Raw notifications
  • MainAppSample
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | RawNotificationsSampleCPP::sealed

Namespaces

namespace | RawNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioInput2.xaml.cpp File Reference

  • Raw notifications
  • MainAppSample

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioInput2.xaml.h File Reference

  • Raw notifications
  • MainAppSample
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | RawNotificationsSampleCPP::sealed

Namespaces

namespace | RawNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioList.xaml.cpp File Reference

  • Raw notifications
  • MainAppSample

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioList.xaml.h File Reference

  • Raw notifications
  • MainAppSample
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | RawNotificationsSampleCPP::sealed

Namespaces

namespace | RawNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioOutput1.xaml.cpp File Reference

  • Raw notifications
  • MainAppSample

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioOutput1.xaml.h File Reference

  • Raw notifications
  • MainAppSample
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | RawNotificationsSampleCPP::sealed

Namespaces

namespace | RawNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioOutput2.xaml.cpp File Reference

  • Raw notifications
  • MainAppSample

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioOutput2.xaml.h File Reference

  • Raw notifications
  • MainAppSample
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | RawNotificationsSampleCPP::sealed

Namespaces

namespace | RawNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/SampleBackgroundTask/BackgroundTask.cpp File Reference

  • Raw notifications
  • SampleBackgroundTask

BackgroundTask.cpp File Reference

#include "pch.h"
#include "BackgroundTask.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/SampleBackgroundTask/BackgroundTask.h File Reference

  • Raw notifications
  • SampleBackgroundTask
Classes | Namespaces

BackgroundTask.h File Reference

Go to the source code of this file.

Classes

class | BackgroundTasks::sealed

Namespaces

namespace | BackgroundTasks
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/SampleBackgroundTask/pch.cpp File Reference

  • Raw notifications
  • SampleBackgroundTask

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/SampleBackgroundTask/pch.h File Reference

  • Raw notifications
  • SampleBackgroundTask

pch.h File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/App.xaml.cpp File Reference

  • Reading and writing data

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/App.xaml.h File Reference

  • Reading and writing data
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/Constants.cpp File Reference

  • Reading and writing data

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/Constants.h File Reference

  • Reading and writing data
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/MainPage.xaml.cpp File Reference

  • Reading and writing data

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/MainPage.xaml.h File Reference

  • Reading and writing data
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/pch.cpp File Reference

  • Reading and writing data

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/pch.h File Reference

  • Reading and writing data

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/ReadBytes.xaml.cpp File Reference

  • Reading and writing data

ReadBytes.xaml.cpp File Reference

#include "pch.h"
#include "ReadBytes.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/ReadBytes.xaml.h File Reference

  • Reading and writing data
Classes | Namespaces

ReadBytes.xaml.h File Reference

#include <cstring>
#include "pch.h"
#include "ReadBytes.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DataReaderWriter::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataReaderWriter
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/WriteReadStream.xaml.cpp File Reference

  • Reading and writing data
Variables

WriteReadStream.xaml.cpp File Reference

#include "pch.h"
#include "WriteReadStream.xaml.h"

Go to the source code of this file.

Variables

Array< String^> _inputElements

Variable Documentation

Array<String^> _inputElements
Initial value:
 ref new Array<String^>
{
    "Hello", "World", "1 2 3 4 5", "Très bien!", "Goodbye"
}

Definition at line 27 of file WriteReadStream.xaml.cpp.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/WriteReadStream.xaml.h File Reference

  • Reading and writing data
Classes | Namespaces

WriteReadStream.xaml.h File Reference

#include "pch.h"
#include "WriteReadStream.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DataReaderWriter::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataReaderWriter
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/common/LayoutAwarePage.cpp File Reference

  • Reading and writing data
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/common/LayoutAwarePage.h File Reference

  • Reading and writing data
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/common/suspensionmanager.cpp File Reference

  • Reading and writing data
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/common/suspensionmanager.h File Reference

  • Reading and writing data
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/App.xaml.cs File Reference

  • Real-time communication
  • C#,C++
Classes | Namespaces

App.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::App
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/Constants.cs File Reference

  • Real-time communication
  • C#,C++
Classes | Namespaces

Constants.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::Scenario

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/LowLatency.xaml.cs File Reference

  • Real-time communication
  • C#,C++
Classes | Namespaces

LowLatency.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SimpleCommunication::LowLatency
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SimpleCommunication
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/MainPage.xaml.cs File Reference

  • Real-time communication
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::MainPageSizeChangedEventArgs

Namespaces

namespace | SDKTemplate

Enumerations

enum SDKTemplate::NotifyType {
SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage, SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage,
SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage, SDKTemplate::StatusMessage, SDKTemplate::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/SuspensionManager.cs File Reference

  • Real-time communication
  • C#,C++
Classes

SuspensionManager.cs File Reference

Go to the source code of this file.

Classes

class SuspensionManager
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/VideoChat.xaml.cs File Reference

  • Real-time communication
  • C#,C++
Classes | Namespaces

VideoChat.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SimpleCommunication::VideoChat
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SimpleCommunication
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/Common/CaptureDevice.cs File Reference

  • Real-time communication
  • C#,C++
  • Common
Classes | Namespaces

CaptureDevice.cs File Reference

Go to the source code of this file.

Classes

class | SimpleCommunication::Common::CaptureDevice

Namespaces

namespace | SimpleCommunication::Common
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/Common/LayoutAwarePage.cs File Reference

  • Real-time communication
  • C#,C++
  • Common
Classes | Namespaces

LayoutAwarePage.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...
class | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
Implementation of IObservableMap that supports reentrancy for use as a default view model. More...
class | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs

Namespaces

namespace | SDKTemplate::Common
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/Properties/AssemblyInfo.cs File Reference

  • Real-time communication
  • C#,C++
  • Properties

AssemblyInfo.cs File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/sample-utils/SuspensionManager.cs File Reference

  • Real-time communication
  • C#,C++
  • sample-utils
Classes

SuspensionManager.cs File Reference

Go to the source code of this file.

Classes

class SuspensionManager
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/App.xaml.cpp File Reference

  • Real-time communication

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/App.xaml.h File Reference

  • Real-time communication
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SimpleCommunication::App

Namespaces

namespace | SimpleCommunication
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/Constants.cpp File Reference

  • Real-time communication

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/Constants.h File Reference

  • Real-time communication
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SimpleCommunication::MainPage
struct | SimpleCommunication::Scenario

Namespaces

namespace | SimpleCommunication
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/LowLatency.xaml.cpp File Reference

  • Real-time communication
Enumerations

LowLatency.xaml.cpp File Reference

#include "pch.h"
#include "LowLatency.xaml.h"

Go to the source code of this file.

Enumerations

enum Action {
previewButtonClicked, localClientButtonClicked, previewSetupCompleted, recordingStarted,
latencyModeToggled
}

Enumeration Type Documentation

enum Action
Enumerator:
previewButtonClicked
localClientButtonClicked
previewSetupCompleted
recordingStarted
latencyModeToggled

Definition at line 27 of file LowLatency.xaml.cpp.

{
    previewButtonClicked,
    localClientButtonClicked,
    previewSetupCompleted,
    recordingStarted,
    latencyModeToggled,
};

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/LowLatency.xaml.h File Reference

  • Real-time communication
Classes | Namespaces

LowLatency.xaml.h File Reference

#include "pch.h"
#include "Utils.h"
#include "LowLatency.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SimpleCommunication::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
struct | SimpleCommunication::sealed::StreamFilteringCriteria

Namespaces

namespace | SimpleCommunication
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MainPage.xaml.cpp File Reference

  • Real-time communication

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MainPage.xaml.h File Reference

  • Real-time communication
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SimpleCommunication::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SimpleCommunication::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SimpleCommunication

Enumerations

enum | SimpleCommunication::NotifyType { SimpleCommunication::StatusMessage, SimpleCommunication::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/pch.cpp File Reference

  • Real-time communication

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/pch.h File Reference

  • Real-time communication

pch.h File Reference

#include <agile.h>
#include <ppltasks.h>
#include <concrt.h>
#include "Sample-Utils\CppSamplesUtils.h"
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/Utils.cpp File Reference

  • Real-time communication

Utils.cpp File Reference

#include "pch.h"
#include "Utils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/Utils.h File Reference

  • Real-time communication
Classes | Namespaces | Functions

Utils.h File Reference

Go to the source code of this file.

Classes

class | SimpleCommunication::CaptureFailedEventArgs
class | SimpleCommunication::SdkSample
class | SimpleCommunication::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SimpleCommunication

Functions

delegate void | SimpleCommunication::CaptureFailedHandler (CaptureDevice^sender, CaptureFailedEventArgs^errorEventArgs)
delegate void | SimpleCommunication::IncomingconnectioneventHandler (Microsoft::Samples::SimpleCommunication::StspMediaSink^sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^args)
delegate bool | SimpleCommunication::VideoSettingsFilter (Windows::Media::MediaProperties::IMediaEncodingProperties^, unsigned int)
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/VideoChat.xaml.cpp File Reference

  • Real-time communication

VideoChat.xaml.cpp File Reference

#include "pch.h"
#include "VideoChat.xaml.h"
#include <wrl\wrappers\corewrappers.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/VideoChat.xaml.h File Reference

  • Real-time communication
Classes | Namespaces

VideoChat.xaml.h File Reference

#include "pch.h"
#include "Utils.h"
#include "VideoChat.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SimpleCommunication::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SimpleCommunication
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/common/LayoutAwarePage.cpp File Reference

  • Real-time communication
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/common/LayoutAwarePage.h File Reference

  • Real-time communication
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | SimpleCommunication::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | SimpleCommunication
namespace | SimpleCommunication::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/Common/AsyncCB.h File Reference

  • Real-time communication
  • MediaExtensions
  • Common
Classes

AsyncCB.h File Reference

Go to the source code of this file.

Classes

class AsyncCallback< T >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/Common/CritSec.h File Reference

  • Real-time communication
  • MediaExtensions
  • Common
Classes

CritSec.h File Reference

Go to the source code of this file.

Classes

class | AutoLock
class | CritSec
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/Common/LinkList.h File Reference

  • Real-time communication
  • MediaExtensions
  • Common
Classes

LinkList.h File Reference

Go to the source code of this file.

Classes

class | ComAutoRelease
class | ComPtrList< T, NULLABLE >
class | List< T >
struct | List< T >::Node
class | List< T >::POSITION
class | MemDelete
struct | NoOp< T >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/Common/OpQueue.h File Reference

  • Real-time communication
  • MediaExtensions
  • Common
Classes

OpQueue.h File Reference

#include "linklist.h"
#include "AsyncCB.h"

Go to the source code of this file.

Classes

class OpQueue< T, TOperation >
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/sample-utils/CppSamplesUtils.h File Reference

  • Real-time communication
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/App.xaml.cpp File Reference

  • Removable storage

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/App.xaml.h File Reference

  • Removable storage
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/Constants.cpp File Reference

  • Removable storage

Constants.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/Constants.h File Reference

  • Removable storage
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::App
class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/MainPage.xaml.cpp File Reference

  • Removable storage

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/MainPage.xaml.h File Reference

  • Removable storage
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/pch.cpp File Reference

  • Removable storage

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/pch.h File Reference

  • Removable storage

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "Constants.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "Constants.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S1_ListStorages.xaml.cpp File Reference

  • Removable storage

S1_ListStorages.xaml.cpp File Reference

#include "pch.h"
#include "S1_ListStorages.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S1_ListStorages.xaml.h File Reference

  • Removable storage
Classes | Namespaces

S1_ListStorages.xaml.h File Reference

#include "pch.h"
#include "S1_ListStorages.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::RemovableStorageCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::RemovableStorageCPP
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S2_SendToStorage.xaml.cpp File Reference

  • Removable storage

S2_SendToStorage.xaml.cpp File Reference

#include "pch.h"
#include "S2_SendToStorage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S2_SendToStorage.xaml.h File Reference

  • Removable storage
Classes | Namespaces

S2_SendToStorage.xaml.h File Reference

#include "pch.h"
#include "S2_SendToStorage.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::RemovableStorageCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::RemovableStorageCPP
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S3_GetFromStorage.xaml.cpp File Reference

  • Removable storage

S3_GetFromStorage.xaml.cpp File Reference

#include "pch.h"
#include "S3_GetFromStorage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S3_GetFromStorage.xaml.h File Reference

  • Removable storage
Classes | Namespaces

S3_GetFromStorage.xaml.h File Reference

#include "pch.h"
#include "S3_GetFromStorage.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::RemovableStorageCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::RemovableStorageCPP
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S4_Autoplay.xaml.cpp File Reference

  • Removable storage

S4_Autoplay.xaml.cpp File Reference

#include "pch.h"
#include "S4_Autoplay.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S4_Autoplay.xaml.h File Reference

  • Removable storage
Classes | Namespaces

S4_Autoplay.xaml.h File Reference

#include "pch.h"
#include "S4_Autoplay.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::RemovableStorageCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::RemovableStorageCPP
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/LayoutAwarePage.cpp File Reference

  • Removable storage
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/LayoutAwarePage.h File Reference

  • Removable storage
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/SuspensionManager.cpp File Reference

  • Removable storage
  • common
Classes | Namespaces | Enumerations | Functions

SuspensionManager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{SuspensionManager.cpp}

Enumerations

enum anonymous_namespace{SuspensionManager.cpp}::StreamTypes {
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker,
anonymous_namespace{SuspensionManager.cpp}::NullPtrType = 0, anonymous_namespace{SuspensionManager.cpp}::UInt8Type, anonymous_namespace{SuspensionManager.cpp}::UInt16Type, anonymous_namespace{SuspensionManager.cpp}::UInt32Type,
anonymous_namespace{SuspensionManager.cpp}::UInt64Type, anonymous_namespace{SuspensionManager.cpp}::Int16Type, anonymous_namespace{SuspensionManager.cpp}::Int32Type, anonymous_namespace{SuspensionManager.cpp}::Int64Type,
anonymous_namespace{SuspensionManager.cpp}::SingleType, anonymous_namespace{SuspensionManager.cpp}::DoubleType, anonymous_namespace{SuspensionManager.cpp}::BooleanType, anonymous_namespace{SuspensionManager.cpp}::Char16Type,
anonymous_namespace{SuspensionManager.cpp}::GuidType, anonymous_namespace{SuspensionManager.cpp}::StringType, anonymous_namespace{SuspensionManager.cpp}::StringToObjectMapType, anonymous_namespace{SuspensionManager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{SuspensionManager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{SuspensionManager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{SuspensionManager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{SuspensionManager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{SuspensionManager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{SuspensionManager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{SuspensionManager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{SuspensionManager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{SuspensionManager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/SuspensionManager.h File Reference

  • Removable storage
  • common
Classes | Namespaces

SuspensionManager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/App.xaml.cpp File Reference

  • Scaling according to DPI

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/App.xaml.h File Reference

  • Scaling according to DPI
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Constants.cpp File Reference

  • Scaling according to DPI

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Constants.h File Reference

  • Scaling according to DPI
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/MainPage.xaml.cpp File Reference

  • Scaling according to DPI

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/MainPage.xaml.h File Reference

  • Scaling according to DPI
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/pch.cpp File Reference

  • Scaling according to DPI

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/pch.h File Reference

  • Scaling according to DPI

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Scenario1.xaml.cpp File Reference

  • Scaling according to DPI

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Scenario1.xaml.h File Reference

  • Scaling according to DPI
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Scaling::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Scaling
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Scenario2.xaml.cpp File Reference

  • Scaling according to DPI

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Scenario2.xaml.h File Reference

  • Scaling according to DPI
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Scaling::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Scaling
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/common/LayoutAwarePage.cpp File Reference

  • Scaling according to DPI
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/common/LayoutAwarePage.h File Reference

  • Scaling according to DPI
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/common/suspensionmanager.cpp File Reference

  • Scaling according to DPI
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/common/suspensionmanager.h File Reference

  • Scaling according to DPI
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/App.xaml.cpp File Reference

  • Scheduled notifications
  • C#,C++

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/App.xaml.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | ScheduledNotificationsSampleCPP::sealed

Namespaces

namespace | ScheduledNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/CppSamplesUtils.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/MainPage.xaml.cpp File Reference

  • Scheduled notifications
  • C#,C++

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/MainPage.xaml.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ScheduledNotificationsSampleCPP::sealed

Namespaces

namespace | ScheduledNotificationsSampleCPP

Enumerations

enum | ScheduledNotificationsSampleCPP::NotifyType { ScheduledNotificationsSampleCPP::StatusMessage, ScheduledNotificationsSampleCPP::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/NotificationData.cpp File Reference

  • Scheduled notifications
  • C#,C++

NotificationData.cpp File Reference

#include "pch.h"
#include "NotificationData.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/NotificationData.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces

NotificationData.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | ScheduledNotificationsSampleCPP::sealed
class | ScheduledNotificationsSampleCPP::sealed

Namespaces

namespace | ScheduledNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/pch.cpp File Reference

  • Scheduled notifications
  • C#,C++

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/pch.h File Reference

  • Scheduled notifications
  • C#,C++

pch.h File Reference

#include <strsafe.h>
#include <Windows.h>
#include "CppSamplesUtils.h"
#include <ppltasks.h>
#include "App.xaml.h"
#include "CppSamplesUtils.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioInput1.xaml.cpp File Reference

  • Scheduled notifications
  • C#,C++

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioInput1.xaml.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ScheduledNotificationsSampleCPP::sealed

Namespaces

namespace | ScheduledNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioInput2.xaml.cpp File Reference

  • Scheduled notifications
  • C#,C++

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioInput2.xaml.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.g.h"
#include "NotificationData.h"

Go to the source code of this file.

Classes

class | ScheduledNotificationsSampleCPP::sealed

Namespaces

namespace | ScheduledNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioList.xaml.cpp File Reference

  • Scheduled notifications
  • C#,C++

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioList.xaml.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ScheduledNotificationsSampleCPP::sealed

Namespaces

namespace | ScheduledNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioOutput1.xaml.cpp File Reference

  • Scheduled notifications
  • C#,C++

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioOutput1.xaml.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ScheduledNotificationsSampleCPP::sealed

Namespaces

namespace | ScheduledNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioOutput2.xaml.cpp File Reference

  • Scheduled notifications
  • C#,C++

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioOutput2.xaml.h File Reference

  • Scheduled notifications
  • C#,C++
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ScheduledNotificationsSampleCPP::sealed

Namespaces

namespace | ScheduledNotificationsSampleCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/App.xaml.cpp File Reference

  • Search contract

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/App.xaml.h File Reference

  • Search contract
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Constants.cpp File Reference

  • Search contract

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Constants.h File Reference

  • Search contract
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Finally
class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/HttpRequest.cpp File Reference

  • Search contract
Classes

HttpRequest.cpp File Reference

#include "pch.h"
#include "HttpRequest.h"
#include <robuffer.h>
#include <shcore.h>

Go to the source code of this file.

Classes

class HttpRequestStringCallback
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/HttpRequest.h File Reference

  • Search contract
Classes | Namespaces | Functions

HttpRequest.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | Web::Details::HttpRequestBuffersCallback
class | Web::HttpRequest

Namespaces

namespace | Web
namespace | Web::Details

Functions

void | CheckHResult (HRESULT hResult)

Function Documentation

void CheckHResult ( HRESULT hResult ) [inline]

Definition at line 13 of file HttpRequest.h.

{
    if (hResult == E_ABORT)
    {
        concurrency::cancel_current_task();
    }
    else if (FAILED(hResult))
    {
        throw Platform::Exception::CreateException(hResult);
    }
}

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/MainPage.xaml.cpp File Reference

  • Search contract

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/MainPage.xaml.h File Reference

  • Search contract
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/pch.cpp File Reference

  • Search contract

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/pch.h File Reference

  • Search contract

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include <sstream>
#include <msxml6.h>
#include <wrl.h>
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario1.xaml.cpp File Reference

  • Search contract

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario1.xaml.h File Reference

  • Search contract
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SearchContract::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SearchContract
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario2.xaml.cpp File Reference

  • Search contract

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario2.xaml.h File Reference

  • Search contract
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SearchContract::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SearchContract
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario3.xaml.cpp File Reference

  • Search contract

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario3.xaml.h File Reference

  • Search contract
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SearchContract::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SearchContract
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario4.xaml.cpp File Reference

  • Search contract

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario4.xaml.h File Reference

  • Search contract
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SearchContract::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SearchContract
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario5.xaml.cpp File Reference

  • Search contract

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario5.xaml.h File Reference

  • Search contract
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"
#include "HttpRequest.h"

Go to the source code of this file.

Classes

class | SDKSample::SearchContract::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SearchContract
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario6.xaml.cpp File Reference

  • Search contract

Scenario6.xaml.cpp File Reference

#include "pch.h"
#include "Scenario6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario6.xaml.h File Reference

  • Search contract
Classes | Namespaces

Scenario6.xaml.h File Reference

#include "pch.h"
#include "Scenario6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SearchContract::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SearchContract
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario7.xaml.cpp File Reference

  • Search contract

Scenario7.xaml.cpp File Reference

#include "pch.h"
#include "Scenario7.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario7.xaml.h File Reference

  • Search contract
Classes | Namespaces

Scenario7.xaml.h File Reference

#include "pch.h"
#include "Scenario7.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SearchContract::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SearchContract
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/common/LayoutAwarePage.cpp File Reference

  • Search contract
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/common/LayoutAwarePage.h File Reference

  • Search contract
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/common/suspensionmanager.cpp File Reference

  • Search contract
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/common/suspensionmanager.h File Reference

  • Search contract
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/App.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/App.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/Constants.cpp File Reference

  • Secondary tiles
  • C#,C++

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/Constants.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SecondaryTiles::MainPage
struct | SecondaryTiles::Scenario

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/EnumerateTiles.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

EnumerateTiles.xaml.cpp File Reference

#include "pch.h"
#include "EnumerateTiles.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/EnumerateTiles.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

EnumerateTiles.xaml.h File Reference

#include "pch.h"
#include "EnumerateTiles.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/LaunchedFromSecondaryTile.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

LaunchedFromSecondaryTile.xaml.cpp File Reference

#include "pch.h"
#include "LaunchedFromSecondaryTile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/LaunchedFromSecondaryTile.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

LaunchedFromSecondaryTile.xaml.h File Reference

#include "pch.h"
#include "LaunchedFromSecondaryTile.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/MainPage.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/MainPage.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles

Enumerations

enum | SecondaryTiles::NotifyType { SecondaryTiles::StatusMessage, SecondaryTiles::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/pch.cpp File Reference

  • Secondary tiles
  • C#,C++

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/pch.h File Reference

  • Secondary tiles
  • C#,C++

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/PinFromAppbar.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

PinFromAppbar.xaml.cpp File Reference

#include "pch.h"
#include "PinFromAppbar.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/PinFromAppbar.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

PinFromAppbar.xaml.h File Reference

#include "pch.h"
#include "PinFromAppbar.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/PinTile.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

PinTile.xaml.cpp File Reference

#include "pch.h"
#include "PinTile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/PinTile.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

PinTile.xaml.h File Reference

#include "pch.h"
#include "PinTile.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/SecondaryTileNotification.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

SecondaryTileNotification.xaml.cpp File Reference

#include "pch.h"
#include "SecondaryTileNotification.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/SecondaryTileNotification.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

SecondaryTileNotification.xaml.h File Reference

#include "pch.h"
#include "SecondaryTileNotification.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/TilePinned.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

TilePinned.xaml.cpp File Reference

#include "pch.h"
#include "TilePinned.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/TilePinned.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

TilePinned.xaml.h File Reference

#include "pch.h"
#include "TilePinned.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/UnpinTile.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

UnpinTile.xaml.cpp File Reference

#include "pch.h"
#include "UnpinTile.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/UnpinTile.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

UnpinTile.xaml.h File Reference

#include "pch.h"
#include "UnpinTile.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/UpdateAsync.xaml.cpp File Reference

  • Secondary tiles
  • C#,C++

UpdateAsync.xaml.cpp File Reference

#include "pch.h"
#include "UpdateAsync.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/UpdateAsync.xaml.h File Reference

  • Secondary tiles
  • C#,C++
Classes | Namespaces

UpdateAsync.xaml.h File Reference

#include "pch.h"
#include "UpdateAsync.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SecondaryTiles::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SecondaryTiles
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/common/LayoutAwarePage.cpp File Reference

  • Secondary tiles
  • C#,C++
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/common/LayoutAwarePage.h File Reference

  • Secondary tiles
  • C#,C++
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | SecondaryTiles::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | SecondaryTiles
namespace | SecondaryTiles::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/NotificationsExtensions/BadgeContent.cs File Reference

  • Secondary tiles
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

BadgeContent.cs File Reference

Go to the source code of this file.

Classes

class | NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
Notification content object to display a glyph on a tile's badge. More...
class | NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
Notification content object to display a number on a tile's badge. More...

Namespaces

namespace | NotificationsExtensions::BadgeContent
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/NotificationsExtensions/Common.cs File Reference

  • Secondary tiles
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

Common.cs File Reference

Go to the source code of this file.

Classes

class | NotificationsExtensions::NotificationBase
Base class for the notification content creation helper classes. More...
class | NotificationsExtensions::NotificationContentImage
class | NotificationsExtensions::NotificationContentText
class | NotificationsExtensions::NotificationContentValidationException
Exception returned when invalid notification content is provided. More...
class | NotificationsExtensions::Util

Namespaces

namespace | NotificationsExtensions
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/NotificationsExtensions/TileContent.cs File Reference

  • Secondary tiles
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

TileContent.cs File Reference

Go to the source code of this file.

Classes

interface | NotificationsExtensions::TileContent::ISquareTileInternal
class | NotificationsExtensions::TileContent::TileContentFactory
A factory which creates tile content objects for all of the toast template types. More...
class | NotificationsExtensions::TileContent::TileNotificationBase
class | NotificationsExtensions::TileContent::TileSquareBase
class | NotificationsExtensions::TileContent::TileSquareBlock
class | NotificationsExtensions::TileContent::TileSquareImage
class | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
class | NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
class | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
class | NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
class | NotificationsExtensions::TileContent::TileSquareText01
class | NotificationsExtensions::TileContent::TileSquareText02
class | NotificationsExtensions::TileContent::TileSquareText03
class | NotificationsExtensions::TileContent::TileSquareText04
class | NotificationsExtensions::TileContent::TileWideBase
class | NotificationsExtensions::TileContent::TileWideBlockAndText01
class | NotificationsExtensions::TileContent::TileWideBlockAndText02
class | NotificationsExtensions::TileContent::TileWideImage
class | NotificationsExtensions::TileContent::TileWideImageAndText01
class | NotificationsExtensions::TileContent::TileWideImageAndText02
class | NotificationsExtensions::TileContent::TileWideImageCollection
class | NotificationsExtensions::TileContent::TileWidePeekImage01
class | NotificationsExtensions::TileContent::TileWidePeekImage02
class | NotificationsExtensions::TileContent::TileWidePeekImage03
class | NotificationsExtensions::TileContent::TileWidePeekImage04
class | NotificationsExtensions::TileContent::TileWidePeekImage05
class | NotificationsExtensions::TileContent::TileWidePeekImage06
class | NotificationsExtensions::TileContent::TileWidePeekImageAndText01
class | NotificationsExtensions::TileContent::TileWidePeekImageAndText02
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection01
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection02
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection03
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection04
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection05
class | NotificationsExtensions::TileContent::TileWidePeekImageCollection06
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText01
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText02
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText03
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText04
class | NotificationsExtensions::TileContent::TileWideSmallImageAndText05
class | NotificationsExtensions::TileContent::TileWideText01
class | NotificationsExtensions::TileContent::TileWideText02
class | NotificationsExtensions::TileContent::TileWideText03
class | NotificationsExtensions::TileContent::TileWideText04
class | NotificationsExtensions::TileContent::TileWideText05
class | NotificationsExtensions::TileContent::TileWideText06
class | NotificationsExtensions::TileContent::TileWideText07
class | NotificationsExtensions::TileContent::TileWideText08
class | NotificationsExtensions::TileContent::TileWideText09
class | NotificationsExtensions::TileContent::TileWideText10
class | NotificationsExtensions::TileContent::TileWideText11

Namespaces

namespace | NotificationsExtensions::TileContent
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs File Reference

  • Secondary tiles
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

ToastContent.cs File Reference

Go to the source code of this file.

Classes

class | NotificationsExtensions::ToastContent::ToastAudio
class | NotificationsExtensions::ToastContent::ToastContentFactory
A factory which creates toast content objects for all of the toast template types.
class | NotificationsExtensions::ToastContent::ToastImageAndText01
class | NotificationsExtensions::ToastContent::ToastImageAndText02
class | NotificationsExtensions::ToastContent::ToastImageAndText03
class | NotificationsExtensions::ToastContent::ToastImageAndText04
class | NotificationsExtensions::ToastContent::ToastNotificationBase
class | NotificationsExtensions::ToastContent::ToastText01
class | NotificationsExtensions::ToastContent::ToastText02
class | NotificationsExtensions::ToastContent::ToastText03
class | NotificationsExtensions::ToastContent::ToastText04

Namespaces

namespace | NotificationsExtensions::ToastContent
Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/Sample-Utils/cppsamplesutils.h File Reference

  • Secondary tiles
  • C#,C++
  • Sample-Utils
Classes | Namespaces | Functions

cppsamplesutils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/App.xaml.cpp File Reference

  • Sharing content source app

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/App.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/Constants.cpp File Reference

  • Sharing content source app

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/Constants.h File Reference

  • Sharing content source app
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/MainPage.xaml.cpp File Reference

  • Sharing content source app

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/MainPage.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/pch.cpp File Reference

  • Sharing content source app

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/pch.h File Reference

  • Sharing content source app

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include <sstream>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/SetErrorMessage.xaml.cpp File Reference

  • Sharing content source app

SetErrorMessage.xaml.cpp File Reference

#include "pch.h"
#include "SharePage.h"
#include "SetErrorMessage.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/SetErrorMessage.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces

SetErrorMessage.xaml.h File Reference

#include "pch.h"
#include "SharePage.h"
#include "SetErrorMessage.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ShareSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ShareSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareCustomData.xaml.cpp File Reference

  • Sharing content source app

ShareCustomData.xaml.cpp File Reference

#include "pch.h"
#include "ShareCustomData.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareCustomData.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces | Defines

ShareCustomData.xaml.h File Reference

#include "pch.h"
#include "SharePage.h"
#include "ShareCustomData.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ShareSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ShareSource

Defines

#define | CUSTOM_DATA_CONTENT "{ \ \"type\" : \"http://schema.org/Book\", \ \"properties\" : \ { \ \"image\" : \"http://sourceurl.com/catcher-in-the-rye-book-cover.jpg\", \ \"name\" : \"The Catcher in the Rye\", \ \"bookFormat\" : \"http://schema.org/Paperback\", \ \"author\" : \"http://sourceurl.com/author/jd_salinger.html\", \ \"numberOfPages\" : 224, \ \"publisher\" : \"Little, Brown, and Company\", \ \"datePublished\" : \"1991-05-01\", \ \"inLanguage\" : \"English\", \ \"isbn\" : \"0316769487\" \ } \ }"

Define Documentation

#define CUSTOM_DATA_CONTENT "{ \ \"type\" : \"http://schema.org/Book\", \ \"properties\" : \ { \ \"image\" : \"http://sourceurl.com/catcher-in-the-rye-book-cover.jpg\", \ \"name\" : \"The Catcher in the Rye\", \ \"bookFormat\" : \"http://schema.org/Paperback\", \ \"author\" : \"http://sourceurl.com/author/jd_salinger.html\", \ \"numberOfPages\" : 224, \ \"publisher\" : \"Little, Brown, and Company\", \ \"datePublished\" : \"1991-05-01\", \ \"inLanguage\" : \"English\", \ \"isbn\" : \"0316769487\" \ } \ }"

Definition at line 23 of file ShareCustomData.xaml.h.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareDelayRenderedFiles.xaml.cpp File Reference

  • Sharing content source app

ShareDelayRenderedFiles.xaml.cpp File Reference

#include "pch.h"
#include "ShareDelayRenderedFiles.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareDelayRenderedFiles.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces

ShareDelayRenderedFiles.xaml.h File Reference

#include "pch.h"
#include "SharePage.h"
#include "ShareDelayRenderedFiles.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ShareSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ShareSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareFiles.xaml.cpp File Reference

  • Sharing content source app

ShareFiles.xaml.cpp File Reference

#include "pch.h"
#include "ShareFiles.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareFiles.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces

ShareFiles.xaml.h File Reference

#include "pch.h"
#include "SharePage.h"
#include "ShareFiles.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ShareSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ShareSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareHtml.xaml.cpp File Reference

  • Sharing content source app

ShareHtml.xaml.cpp File Reference

#include "pch.h"
#include "ShareHtml.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareHtml.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces

ShareHtml.xaml.h File Reference

#include "pch.h"
#include "SharePage.h"
#include "ShareHtml.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ShareSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ShareSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareImage.xaml.cpp File Reference

  • Sharing content source app

ShareImage.xaml.cpp File Reference

#include "pch.h"
#include "ShareImage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareImage.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces

ShareImage.xaml.h File Reference

#include "pch.h"
#include "SharePage.h"
#include "ShareImage.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ShareSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ShareSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareLink.xaml.cpp File Reference

  • Sharing content source app

ShareLink.xaml.cpp File Reference

#include "pch.h"
#include "ShareLink.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareLink.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces

ShareLink.xaml.h File Reference

#include "pch.h"
#include "SharePage.h"
#include "ShareLink.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ShareSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ShareSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/SharePage.cpp File Reference

  • Sharing content source app

SharePage.cpp File Reference

#include "pch.h"
#include "SharePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/SharePage.h File Reference

  • Sharing content source app
Classes | Namespaces

SharePage.h File Reference

#include "pch.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Common::SharePage

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareText.xaml.cpp File Reference

  • Sharing content source app

ShareText.xaml.cpp File Reference

#include "pch.h"
#include "ShareText.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareText.xaml.h File Reference

  • Sharing content source app
Classes | Namespaces

ShareText.xaml.h File Reference

#include "pch.h"
#include "SharePage.h"
#include "ShareText.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ShareSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ShareSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/common/LayoutAwarePage.cpp File Reference

  • Sharing content source app
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/common/LayoutAwarePage.h File Reference

  • Sharing content source app
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/common/suspensionmanager.cpp File Reference

  • Sharing content source app
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/common/suspensionmanager.h File Reference

  • Sharing content source app
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/App.xaml.cpp File Reference

  • Sharing content target app

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/App.xaml.h File Reference

  • Sharing content target app
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | ShareTarget::sealed

Namespaces

namespace | ShareTarget
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/DefaultPage.xaml.cpp File Reference

  • Sharing content target app

DefaultPage.xaml.cpp File Reference

#include "pch.h"
#include "DefaultPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/DefaultPage.xaml.h File Reference

  • Sharing content target app
Classes | Namespaces

DefaultPage.xaml.h File Reference

#include "pch.h"
#include "DefaultPage.g.h"

Go to the source code of this file.

Classes

class | ShareTarget::sealed

Namespaces

namespace | ShareTarget
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/MainPage.xaml.cpp File Reference

  • Sharing content target app

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/MainPage.xaml.h File Reference

  • Sharing content target app
Classes | Namespaces | Defines | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include <agile.h>
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ShareTarget::sealed

Namespaces

namespace | ShareTarget

Defines

#define | DATA_FORMAT_NAME "http://schema.org/Book"

Enumerations

enum | ShareTarget::NotifyType { ShareTarget::StatusMessage, ShareTarget::ErrorMessage }

Define Documentation

#define DATA_FORMAT_NAME "http://schema.org/Book"

Definition at line 20 of file MainPage.xaml.h.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/pch.cpp File Reference

  • Sharing content target app

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/pch.h File Reference

  • Sharing content target app

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/common/LayoutAwarePage.cpp File Reference

  • Sharing content target app
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/common/LayoutAwarePage.h File Reference

  • Sharing content target app
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | ShareTarget::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | ShareTarget
namespace | ShareTarget::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/sample-utils/CppSamplesUtils.h File Reference

  • Sharing content target app
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/App.xaml.cpp File Reference

  • SimpleOrientationSensor

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/App.xaml.h File Reference

  • SimpleOrientationSensor
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Constants.cpp File Reference

  • SimpleOrientationSensor

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Constants.h File Reference

  • SimpleOrientationSensor
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/MainPage.xaml.cpp File Reference

  • SimpleOrientationSensor

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/MainPage.xaml.h File Reference

  • SimpleOrientationSensor
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/pch.cpp File Reference

  • SimpleOrientationSensor

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/pch.h File Reference

  • SimpleOrientationSensor

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Scenario1.xaml.cpp File Reference

  • SimpleOrientationSensor

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Scenario1.xaml.h File Reference

  • SimpleOrientationSensor
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SimpleOrientationSensorCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SimpleOrientationSensorCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Scenario2.xaml.cpp File Reference

  • SimpleOrientationSensor

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Scenario2.xaml.h File Reference

  • SimpleOrientationSensor
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SimpleOrientationSensorCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SimpleOrientationSensorCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/common/LayoutAwarePage.cpp File Reference

  • SimpleOrientationSensor
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/common/LayoutAwarePage.h File Reference

  • SimpleOrientationSensor
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/common/suspensionmanager.cpp File Reference

  • SimpleOrientationSensor
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/common/suspensionmanager.h File Reference

  • SimpleOrientationSensor
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTask/pch.cpp File Reference

  • SMS background task
  • SmsBackgroundTask

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTask/pch.h File Reference

  • SMS background task
  • SmsBackgroundTask

pch.h File Reference

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/App.xaml.cpp File Reference

  • SMS background task
  • SmsBackgroundTaskSample

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/App.xaml.h File Reference

  • SMS background task
  • SmsBackgroundTaskSample
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/Constants.cpp File Reference

  • SMS background task
  • SmsBackgroundTaskSample

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/Constants.h File Reference

  • SMS background task
  • SmsBackgroundTaskSample
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/MainPage.xaml.h File Reference

  • SMS background task
  • SmsBackgroundTaskSample
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/pch.cpp File Reference

  • SMS background task
  • SmsBackgroundTaskSample

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/pch.h File Reference

  • SMS background task
  • SmsBackgroundTaskSample

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/App.xaml.cpp File Reference

  • SMS message send, receive, and SIM management

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/App.xaml.h File Reference

  • SMS message send, receive, and SIM management
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/Constants.cpp File Reference

  • SMS message send, receive, and SIM management

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/Constants.h File Reference

  • SMS message send, receive, and SIM management
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/pch.cpp File Reference

  • SMS message send, receive, and SIM management

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/pch.h File Reference

  • SMS message send, receive, and SIM management

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/App.xaml.cpp File Reference

  • Snap

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/App.xaml.h File Reference

  • Snap
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/Constants.cpp File Reference

  • Snap

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/Constants.h File Reference

  • Snap
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/MainPage.xaml.cpp File Reference

  • Snap

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/MainPage.xaml.h File Reference

  • Snap
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/pch.cpp File Reference

  • Snap

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/pch.h File Reference

  • Snap

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/Scenario1.xaml.cpp File Reference

  • Snap

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/Scenario1.xaml.h File Reference

  • Snap
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SnapSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SnapSample
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/common/LayoutAwarePage.cpp File Reference

  • Snap
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/common/LayoutAwarePage.h File Reference

  • Snap
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/common/suspensionmanager.cpp File Reference

  • Snap
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/common/suspensionmanager.h File Reference

  • Snap
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/App.xaml.cpp File Reference

  • Splash screen

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"
#include "ExtendedSplash.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/App.xaml.h File Reference

  • Splash screen
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/Constants.cpp File Reference

  • Splash screen

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/Constants.h File Reference

  • Splash screen
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/ExtendedSplash.xaml.cpp File Reference

  • Splash screen

ExtendedSplash.xaml.cpp File Reference

#include "pch.h"
#include "ExtendedSplash.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/ExtendedSplash.xaml.h File Reference

  • Splash screen
Classes | Namespaces

ExtendedSplash.xaml.h File Reference

#include "pch.h"
#include "ExtendedSplash.g.h"

Go to the source code of this file.

Classes

class | SDKSample::SplashScreen::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SplashScreen
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/MainPage.xaml.cpp File Reference

  • Splash screen

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "ExtendedSplash.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/MainPage.xaml.h File Reference

  • Splash screen
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/pch.cpp File Reference

  • Splash screen

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/pch.h File Reference

  • Splash screen

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/Scenario1.xaml.cpp File Reference

  • Splash screen

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/Scenario1.xaml.h File Reference

  • Splash screen
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SplashScreen::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SplashScreen
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/Scenario2.xaml.cpp File Reference

  • Splash screen

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/Scenario2.xaml.h File Reference

  • Splash screen
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::SplashScreen::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::SplashScreen
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/common/LayoutAwarePage.cpp File Reference

  • Splash screen
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/common/LayoutAwarePage.h File Reference

  • Splash screen
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/common/suspensionmanager.cpp File Reference

  • Splash screen
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/common/suspensionmanager.h File Reference

  • Splash screen
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/App.xaml.cpp File Reference

  • StorageDataSource and GetVirtualizedFilesVector

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/App.xaml.h File Reference

  • StorageDataSource and GetVirtualizedFilesVector
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/Constants.h File Reference

  • StorageDataSource and GetVirtualizedFilesVector
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/pch.cpp File Reference

  • StorageDataSource and GetVirtualizedFilesVector

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/pch.h File Reference

  • StorageDataSource and GetVirtualizedFilesVector

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/App.xaml.cpp File Reference

  • StreamSocket

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/App.xaml.h File Reference

  • StreamSocket
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | StreamSocketSample::App

Namespaces

namespace | StreamSocketSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Constants.cpp File Reference

  • StreamSocket

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Constants.h File Reference

  • StreamSocket
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | StreamSocketSample::MainPage
struct | StreamSocketSample::Scenario

Namespaces

namespace | StreamSocketSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/MainPage.xaml.cpp File Reference

  • StreamSocket

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/MainPage.xaml.h File Reference

  • StreamSocket
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | StreamSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | StreamSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | StreamSocketSample

Enumerations

enum | StreamSocketSample::NotifyType { StreamSocketSample::StatusMessage, StreamSocketSample::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/pch.cpp File Reference

  • StreamSocket

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/pch.h File Reference

  • StreamSocket

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>
#include "Sample-Utils\CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario1.xaml.cpp File Reference

  • StreamSocket

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario1.xaml.h File Reference

  • StreamSocket
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | StreamSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | StreamSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | StreamSocketSample
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario2.xaml.cpp File Reference

  • StreamSocket

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario2.xaml.h File Reference

  • StreamSocket
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | StreamSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | StreamSocketSample
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario3.xaml.cpp File Reference

  • StreamSocket

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario3.xaml.h File Reference

  • StreamSocket
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | StreamSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | StreamSocketSample
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario4.xaml.cpp File Reference

  • StreamSocket

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario4.xaml.h File Reference

  • StreamSocket
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | StreamSocketSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | StreamSocketSample
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Common/LayoutAwarePage.cpp File Reference

  • StreamSocket
  • Common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Common/LayoutAwarePage.h File Reference

  • StreamSocket
  • Common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | StreamSocketSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | StreamSocketSample
namespace | StreamSocketSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/sample-utils/CppSamplesUtils.h File Reference

  • StreamSocket
  • sample-utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/App.xaml.cpp File Reference

  • Syndication

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/App.xaml.h File Reference

  • Syndication
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/Constants.cpp File Reference

  • Syndication

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/Constants.h File Reference

  • Syndication
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario
class | SDKSample::sealed
class | SDKSample::StringTrimmer

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/MainPage.xaml.cpp File Reference

  • Syndication

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/MainPage.xaml.h File Reference

  • Syndication
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/pch.cpp File Reference

  • Syndication

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/pch.h File Reference

  • Syndication

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/Scenario1.xaml.cpp File Reference

  • Syndication

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/Scenario1.xaml.h File Reference

  • Syndication
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Syndication::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Syndication
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/common/LayoutAwarePage.cpp File Reference

  • Syndication
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/common/LayoutAwarePage.h File Reference

  • Syndication
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/common/suspensionmanager.cpp File Reference

  • Syndication
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/common/suspensionmanager.h File Reference

  • Syndication
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/App.xaml.cpp File Reference

  • Thread pool

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/App.xaml.h File Reference

  • Thread pool
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/Constants.cpp File Reference

  • Thread pool
Variables

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"
#include "DelayTimerScenario.xaml.h"

Go to the source code of this file.

Variables

Platform::String | DelayTimerInfo = ""
int | DelayTimerMilliseconds = 0
int | DelayTimerSelectedIndex = 0
Status | DelayTimerStatus = SDKSample::ThreadPool::Status::Unregistered
int | PeriodicTimerCount = 0
Platform::String | PeriodicTimerInfo = ""
int | PeriodicTimerMilliseconds = 0
int | PeriodicTimerSelectedIndex = 0
Status | PeriodicTimerStatus = SDKSample::ThreadPool::Status::Unregistered
Platform::String | WorkItemInfo = ""
int | WorkItemSelectedIndex = 1
Status | WorkItemStatus = SDKSample::ThreadPool::Status::Unregistered
Windows::System::Threading::WorkItemPriority | WorkPriority = Windows::System::Threading::WorkItemPriority::Normal

Variable Documentation

Platform::String DelayTimerInfo = ""

Definition at line 20 of file Constants.cpp.

int DelayTimerMilliseconds = 0

Definition at line 19 of file Constants.cpp.

int DelayTimerSelectedIndex = 0

Definition at line 22 of file Constants.cpp.

Status DelayTimerStatus = SDKSample::ThreadPool::Status::Unregistered

Definition at line 21 of file Constants.cpp.

int PeriodicTimerCount = 0

Definition at line 24 of file Constants.cpp.

Platform::String PeriodicTimerInfo = ""

Definition at line 26 of file Constants.cpp.

int PeriodicTimerMilliseconds = 0

Definition at line 25 of file Constants.cpp.

int PeriodicTimerSelectedIndex = 0

Definition at line 28 of file Constants.cpp.

Status PeriodicTimerStatus = SDKSample::ThreadPool::Status::Unregistered

Definition at line 27 of file Constants.cpp.

Platform::String WorkItemInfo = ""

Definition at line 31 of file Constants.cpp.

int WorkItemSelectedIndex = 1

Definition at line 33 of file Constants.cpp.

Status WorkItemStatus = SDKSample::ThreadPool::Status::Unregistered

Definition at line 30 of file Constants.cpp.

Windows::System::Threading::WorkItemPriority WorkPriority = Windows::System::Threading::WorkItemPriority::Normal

Definition at line 32 of file Constants.cpp.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/Constants.h File Reference

  • Thread pool
Classes | Namespaces | Enumerations

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario
struct | SDKSample::ThreadPool::ThreadPoolSample

Namespaces

namespace | SDKSample
namespace | SDKSample::ThreadPool

Enumerations

enum | SDKSample::ThreadPool::Status { SDKSample::ThreadPool::Unregistered = 0, SDKSample::ThreadPool::Started = 1, SDKSample::ThreadPool::Canceled = 2, SDKSample::ThreadPool::Completed = 3 }
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/DelayTimerScenario.xaml.cpp File Reference

  • Thread pool

DelayTimerScenario.xaml.cpp File Reference

#include "pch.h"
#include "DelayTimerScenario.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/DelayTimerScenario.xaml.h File Reference

  • Thread pool
Classes | Namespaces

DelayTimerScenario.xaml.h File Reference

#include "pch.h"
#include "Constants.h"
#include "DelayTimerScenario.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ThreadPool::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ThreadPool
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/MainPage.xaml.cpp File Reference

  • Thread pool

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/MainPage.xaml.h File Reference

  • Thread pool
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/pch.cpp File Reference

  • Thread pool

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/pch.h File Reference

  • Thread pool

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/PeriodicTimerScenario.xaml.cpp File Reference

  • Thread pool

PeriodicTimerScenario.xaml.cpp File Reference

#include "pch.h"
#include "PeriodicTimerScenario.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/PeriodicTimerScenario.xaml.h File Reference

  • Thread pool
Classes | Namespaces

PeriodicTimerScenario.xaml.h File Reference

#include "pch.h"
#include "Constants.h"
#include "PeriodicTimerScenario.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ThreadPool::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ThreadPool
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/WorkItemScenario.xaml.cpp File Reference

  • Thread pool

WorkItemScenario.xaml.cpp File Reference

#include "pch.h"
#include "WorkItemScenario.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/WorkItemScenario.xaml.h File Reference

  • Thread pool
Classes | Namespaces

WorkItemScenario.xaml.h File Reference

#include "pch.h"
#include "WorkItemScenario.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ThreadPool::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ThreadPool
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/common/LayoutAwarePage.cpp File Reference

  • Thread pool
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/common/LayoutAwarePage.h File Reference

  • Thread pool
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/common/suspensionmanager.cpp File Reference

  • Thread pool
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/common/suspensionmanager.h File Reference

  • Thread pool
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/App.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/App.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/CppSamplesUtils.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/MainPage.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/MainPage.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed
class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP

Enumerations

enum | ToastsSampleCPP::NotifyType { ToastsSampleCPP::StatusMessage, ToastsSampleCPP::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/pch.cpp File Reference

  • Toast notifications
  • C#,C++

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/pch.h File Reference

  • Toast notifications
  • C#,C++

pch.h File Reference

#include <ppltasks.h>
#include "CppSamplesUtils.h"
#include "CppSamplesUtils.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput1.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioInput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput1.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioInput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput2.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioInput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput2.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioInput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput3.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioInput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput3.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioInput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput4.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioInput4.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput4.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioInput4.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput5.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioInput5.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput5.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioInput5.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput6.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioInput6.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioInput6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput6.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioInput6.xaml.h File Reference

#include "pch.h"
#include "ScenarioInput6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioList.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioList.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioList.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioList.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioList.xaml.h File Reference

#include "pch.h"
#include "ScenarioList.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput1.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioOutput1.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput1.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput1.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioOutput1.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput2.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioOutput2.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput2.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput2.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioOutput2.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput2.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput3.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioOutput3.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput3.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput3.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioOutput3.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput3.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput4.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioOutput4.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput4.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput4.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioOutput4.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput5.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioOutput5.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput5.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput5.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioOutput5.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput6.xaml.cpp File Reference

  • Toast notifications
  • C#,C++

ScenarioOutput6.xaml.cpp File Reference

#include "pch.h"
#include "ScenarioOutput6.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput6.xaml.h File Reference

  • Toast notifications
  • C#,C++
Classes | Namespaces

ScenarioOutput6.xaml.h File Reference

#include "pch.h"
#include "ScenarioOutput6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | ToastsSampleCPP::sealed

Namespaces

namespace | ToastsSampleCPP
Generated on Sat Nov 23 2024 16:09:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/NotificationsExtensions/Common.cs File Reference

  • Toast notifications
  • C#,C++
  • NotificationsExtensions
Classes | Namespaces

Common.cs File Reference

Go to the source code of this file.

Classes

class | NotificationsExtensions::NotificationBase
Base class for the notification content creation helper classes. More...
class | NotificationsExtensions::NotificationContentImage
class | NotificationsExtensions::NotificationContentText
class | NotificationsExtensions::NotificationContentValidationException
Exception returned when invalid notification content is provided. More...
class | NotificationsExtensions::Util

Namespaces

namespace | NotificationsExtensions
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/App.xaml.cpp File Reference

  • Transcoding media

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/App.xaml.h File Reference

  • Transcoding media
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Constants.cpp File Reference

  • Transcoding media

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Constants.h File Reference

  • Transcoding media
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Custom.xaml.cpp File Reference

  • Transcoding media

Custom.xaml.cpp File Reference

#include "pch.h"
#include "Custom.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Custom.xaml.h File Reference

  • Transcoding media
Classes | Namespaces

Custom.xaml.h File Reference

#include "pch.h"
#include "Custom.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Transcode::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Transcode
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/MainPage.xaml.cpp File Reference

  • Transcoding media

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/MainPage.xaml.h File Reference

  • Transcoding media
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/pch.cpp File Reference

  • Transcoding media

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/pch.h File Reference

  • Transcoding media

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Presets.xaml.cpp File Reference

  • Transcoding media

Presets.xaml.cpp File Reference

#include "pch.h"
#include "Presets.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Presets.xaml.h File Reference

  • Transcoding media
Classes | Namespaces

Presets.xaml.h File Reference

#include "pch.h"
#include "Presets.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Transcode::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Transcode
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Trim.xaml.cpp File Reference

  • Transcoding media

Trim.xaml.cpp File Reference

#include "pch.h"
#include "Trim.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Trim.xaml.h File Reference

  • Transcoding media
Classes | Namespaces

Trim.xaml.h File Reference

#include "pch.h"
#include "Trim.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Transcode::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Transcode
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/common/LayoutAwarePage.cpp File Reference

  • Transcoding media
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/common/LayoutAwarePage.h File Reference

  • Transcoding media
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/common/suspensionmanager.cpp File Reference

  • Transcoding media
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/common/suspensionmanager.h File Reference

  • Transcoding media
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/App.xaml.cpp File Reference

  • Trial app and in-app purchase

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/App.xaml.h File Reference

  • Trial app and in-app purchase
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/AppListingUri.xaml.cpp File Reference

  • Trial app and in-app purchase

AppListingUri.xaml.cpp File Reference

#include "pch.h"
#include "AppListingUri.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/AppListingUri.xaml.h File Reference

  • Trial app and in-app purchase
Classes | Namespaces

AppListingUri.xaml.h File Reference

#include "pch.h"
#include "AppListingUri.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::StoreSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::StoreSample
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/Constants.cpp File Reference

  • Trial app and in-app purchase

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/Constants.h File Reference

  • Trial app and in-app purchase
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/ExpiringProduct.xaml.cpp File Reference

  • Trial app and in-app purchase

ExpiringProduct.xaml.cpp File Reference

#include "pch.h"
#include "ExpiringProduct.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/ExpiringProduct.xaml.h File Reference

  • Trial app and in-app purchase
Classes | Namespaces

ExpiringProduct.xaml.h File Reference

#include "pch.h"
#include "ExpiringProduct.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::StoreSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::StoreSample
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/InAppPurchase.xaml.cpp File Reference

  • Trial app and in-app purchase

InAppPurchase.xaml.cpp File Reference

#include "pch.h"
#include "InAppPurchase.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/InAppPurchase.xaml.h File Reference

  • Trial app and in-app purchase
Classes | Namespaces

InAppPurchase.xaml.h File Reference

#include "pch.h"
#include "InAppPurchase.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::StoreSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::StoreSample
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/MainPage.xaml.cpp File Reference

  • Trial app and in-app purchase

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/MainPage.xaml.h File Reference

  • Trial app and in-app purchase
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/pch.cpp File Reference

  • Trial app and in-app purchase

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/pch.h File Reference

  • Trial app and in-app purchase

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/Receipt.xaml.cpp File Reference

  • Trial app and in-app purchase

Receipt.xaml.cpp File Reference

#include "pch.h"
#include "Receipt.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/Receipt.xaml.h File Reference

  • Trial app and in-app purchase
Classes | Namespaces

Receipt.xaml.h File Reference

#include "pch.h"
#include "Receipt.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::StoreSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::StoreSample
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/TrialMode.xaml.cpp File Reference

  • Trial app and in-app purchase

TrialMode.xaml.cpp File Reference

#include "pch.h"
#include "TrialMode.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/TrialMode.xaml.h File Reference

  • Trial app and in-app purchase
Classes | Namespaces

TrialMode.xaml.h File Reference

#include "pch.h"
#include "TrialMode.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::StoreSample::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::StoreSample
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/common/LayoutAwarePage.cpp File Reference

  • Trial app and in-app purchase
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/common/LayoutAwarePage.h File Reference

  • Trial app and in-app purchase
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/common/suspensionmanager.cpp File Reference

  • Trial app and in-app purchase
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/common/suspensionmanager.h File Reference

  • Trial app and in-app purchase
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/AppWindowProvider.cpp File Reference

  • UI Automation core window provider
Classes | Functions

AppWindowProvider.cpp File Reference

#include "pch.h"
#include <windows.system.h>
#include <windows.ui.core.h>
#include <UIAutomationCore.h>
#include <UIAutomationCoreApi.h>
#include "InternalInterfaces_h.h"

Go to the source code of this file.

Classes

class | CAppWindowProvider

Functions

HRESULT | CAppWindowProvider_CreateInstance (IInspectable **retVal)

Function Documentation

HRESULT CAppWindowProvider_CreateInstance ( IInspectable ** retVal )

Definition at line 340 of file AppWindowProvider.cpp.

{
    HRESULT hr = E_OUTOFMEMORY;
    *retVal = nullptr;
    ComPtr<CAppWindowProvider> spProvider = Make<CAppWindowProvider>();
    if (spProvider != nullptr)
    {
        hr = spProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
    }
    return hr;
}

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/DirectXBase.cpp File Reference

  • UI Automation core window provider

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/DirectXBase.h File Reference

  • UI Automation core window provider
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include <agile.h>
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/DirectXSample.h File Reference

  • UI Automation core window provider
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/InternalInterfaces.idl File Reference

  • UI Automation core window provider
Classes | Namespaces | Typedefs | Enumerations | Functions

InternalInterfaces.idl File Reference

#include <sdkddkver.h>

Go to the source code of this file.

Classes

interface | UiaCoreWindowProvider::IAppWindowProvider
interface | UiaCoreWindowProvider::IDisconnectableProvider
interface | UiaCoreWindowProvider::ITriColorControlInternal
interface | UiaCoreWindowProvider::ITriColorControlProvider
interface | UiaCoreWindowProvider::ITriColorFragmentProvider

Namespaces

namespace | UiaCoreWindowProvider

Typedefs

typedef enum
UiaCoreWindowProvider::TriColorValue 		UiaCoreWindowProvider::TriColorValue

Enumerations

enum | UiaCoreWindowProvider::TriColorValue { UiaCoreWindowProvider::Red, UiaCoreWindowProvider::Yellow, UiaCoreWindowProvider::Green }

Functions

UiaCoreWindowProvider::activatable (NTDDI_WIN8)] runtimeclass TriColorControlProvider
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/pch.cpp File Reference

  • UI Automation core window provider

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/pch.h File Reference

  • UI Automation core window provider
Variables

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <strsafe.h>

Go to the source code of this file.

Variables

const long | UIA_AutomationFocusChangedEventId = 20005
const long | UIA_AutomationIdPropertyId = 30011
const long | UIA_ControlTypePropertyId = 30003
const long | UIA_CustomControlTypeId = 50025
const long | UIA_HasKeyboardFocusPropertyId = 30008
const long | UIA_HelpTextPropertyId = 30013
const long | UIA_IsContentElementPropertyId = 30017
const long | UIA_IsControlElementPropertyId = 30016
const long | UIA_IsEnabledPropertyId = 30010
const long | UIA_IsKeyboardFocusablePropertyId = 30009
const long | UIA_IsPasswordPropertyId = 30019
const long | UIA_LocalizedControlTypePropertyId = 30004
const long | UIA_NamePropertyId = 30005
const long | UIA_ProviderDescriptionPropertyId = 30107
const long | UIA_SelectionItem_ElementSelectedEventId = 20012
const long | UIA_SelectionItemPatternId = 10010
const long | UIA_SelectionPatternId = 10001
const long | UIA_ValuePatternId = 10002
const long | UIA_ValueValuePropertyId = 30045
const long | UIA_WindowControlTypeId = 50032

Variable Documentation

const long UIA_AutomationFocusChangedEventId = 20005

Definition at line 20 of file pch.h.

const long UIA_AutomationIdPropertyId = 30011

Definition at line 29 of file pch.h.

const long UIA_ControlTypePropertyId = 30003

Definition at line 23 of file pch.h.

const long UIA_CustomControlTypeId = 50025

Definition at line 37 of file pch.h.

const long UIA_HasKeyboardFocusPropertyId = 30008

Definition at line 26 of file pch.h.

const long UIA_HelpTextPropertyId = 30013

Definition at line 30 of file pch.h.

const long UIA_IsContentElementPropertyId = 30017

Definition at line 32 of file pch.h.

const long UIA_IsControlElementPropertyId = 30016

Definition at line 31 of file pch.h.

const long UIA_IsEnabledPropertyId = 30010

Definition at line 28 of file pch.h.

const long UIA_IsKeyboardFocusablePropertyId = 30009

Definition at line 27 of file pch.h.

const long UIA_IsPasswordPropertyId = 30019

Definition at line 33 of file pch.h.

const long UIA_LocalizedControlTypePropertyId = 30004

Definition at line 24 of file pch.h.

const long UIA_NamePropertyId = 30005

Definition at line 25 of file pch.h.

const long UIA_ProviderDescriptionPropertyId = 30107

Definition at line 35 of file pch.h.

const long UIA_SelectionItem_ElementSelectedEventId = 20012

Definition at line 21 of file pch.h.

const long UIA_SelectionItemPatternId = 10010

Definition at line 18 of file pch.h.

const long UIA_SelectionPatternId = 10001

Definition at line 16 of file pch.h.

const long UIA_ValuePatternId = 10002

Definition at line 17 of file pch.h.

const long UIA_ValueValuePropertyId = 30045

Definition at line 34 of file pch.h.

const long UIA_WindowControlTypeId = 50032

Definition at line 38 of file pch.h.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/TriColorValue.h File Reference

  • UI Automation core window provider
Classes

TriColorValue.h File Reference

Go to the source code of this file.

Classes

class TriColorValueHelper
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/TriColorWindow.cpp File Reference

  • UI Automation core window provider
Functions

TriColorWindow.cpp File Reference

#include "pch.h"
#include "TriColorWindow.h"
#include "TriColorValue.h"
#include <UIAutomationCore.h>
#include <UIAutomationCoreApi.h>

Go to the source code of this file.

Functions

ComPtr< IRawElementProviderSimple > | AsSimpleProvider (Platform::Object^object)
HRESULT | CAppWindowProvider_CreateInstance (IInspectable **retVal)
HRESULT | CTriColorControlProvider_CreateInstance (IInspectable **retVal)
HRESULT | CTriColorFragmentProvider_CreateInstance (IInspectable **retVal)
int | main (Platform::Array< Platform::String^>^)
D2D1_RECT_F | RectToRectF (_In_ Rect rect)

Function Documentation

ComPtr<IRawElementProviderSimple> AsSimpleProvider ( Platform::Object^ object )

Definition at line 46 of file TriColorWindow.cpp.

{
    ComPtr<IRawElementProviderSimple> spSimple;
    DX::ThrowIfFailed(
        ((IUnknown*)reinterpret_cast<__abi_IUnknown*>(object))->QueryInterface(IID_PPV_ARGS(&spSimple))
    );
    return spSimple;
}

HRESULT CAppWindowProvider_CreateInstance ( IInspectable ** retVal )

Definition at line 340 of file AppWindowProvider.cpp.

{
    HRESULT hr = E_OUTOFMEMORY;
    *retVal = nullptr;
    ComPtr<CAppWindowProvider> spProvider = Make<CAppWindowProvider>();
    if (spProvider != nullptr)
    {
        hr = spProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
    }
    return hr;
}

HRESULT CTriColorControlProvider_CreateInstance ( IInspectable ** retVal )
HRESULT CTriColorFragmentProvider_CreateInstance ( IInspectable ** retVal )
int main ( Platform::Array< Platform::String^>^ )

Definition at line 747 of file TriColorWindow.cpp.

{
    auto frameworkViewSource = ref new CTriColorWindowFactory();
    Windows::ApplicationModel::Core::CoreApplication::Run(frameworkViewSource);
    return 0;
}

D2D1_RECT_F RectToRectF ( _In_ Rect rect )

Definition at line 34 of file TriColorWindow.cpp.

{
    return D2D1::RectF(
        rect.X,
        rect.Y,
        rect.X + rect.Width,
        rect.Y + rect.Height
        );
}

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/TriColorWindow.h File Reference

  • UI Automation core window provider
Classes

TriColorWindow.h File Reference

#include "DirectXBase.h"

Go to the source code of this file.

Classes

class | CTriColorWindowFactory
class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/Accessibility.xaml.cpp File Reference

  • UI contrast and settings

Accessibility.xaml.cpp File Reference

#include "pch.h"
#include "Accessibility.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/Accessibility.xaml.h File Reference

  • UI contrast and settings
Classes | Namespaces

Accessibility.xaml.h File Reference

#include "pch.h"
#include "Accessibility.g.h"
#include "MainPage.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HighContrast::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HighContrast
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/App.xaml.cpp File Reference

  • UI contrast and settings

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/App.xaml.h File Reference

  • UI contrast and settings
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/Constants.cpp File Reference

  • UI contrast and settings

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/Constants.h File Reference

  • UI contrast and settings
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/cppsamplesutils.h File Reference

  • UI contrast and settings
Classes | Namespaces | Functions

cppsamplesutils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/MainPage.xaml.cpp File Reference

  • UI contrast and settings

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/MainPage.xaml.h File Reference

  • UI contrast and settings
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/pch.cpp File Reference

  • UI contrast and settings

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/pch.h File Reference

  • UI contrast and settings

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/UI.xaml.cpp File Reference

  • UI contrast and settings

UI.xaml.cpp File Reference

#include "pch.h"
#include "UI.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/UI.xaml.h File Reference

  • UI contrast and settings
Classes | Namespaces

UI.xaml.h File Reference

#include "pch.h"
#include "UI.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HighContrast::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HighContrast
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/common/LayoutAwarePage.cpp File Reference

  • UI contrast and settings
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/common/LayoutAwarePage.h File Reference

  • UI contrast and settings
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/common/suspensionmanager.cpp File Reference

  • UI contrast and settings
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/common/suspensionmanager.h File Reference

  • UI contrast and settings
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/App.xaml.cpp File Reference

  • User domain name

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/App.xaml.h File Reference

  • User domain name
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/Constants.cpp File Reference

  • User domain name

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/Constants.h File Reference

  • User domain name
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetDomainName.xaml.cpp File Reference

  • User domain name

GetDomainName.xaml.cpp File Reference

#include "pch.h"
#include "GetDomainName.xaml.h"
#include <ppltasks.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetDomainName.xaml.h File Reference

  • User domain name
Classes | Namespaces

GetDomainName.xaml.h File Reference

#include "pch.h"
#include "GetDomainName.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::UserDomainName::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserDomainName
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetPrincipalName.xaml.cpp File Reference

  • User domain name

GetPrincipalName.xaml.cpp File Reference

#include "pch.h"
#include "GetPrincipalName.xaml.h"
#include <ppltasks.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetPrincipalName.xaml.h File Reference

  • User domain name
Classes | Namespaces

GetPrincipalName.xaml.h File Reference

#include "pch.h"
#include "GetPrincipalName.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::UserDomainName::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserDomainName
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetSIPUri.xaml.cpp File Reference

  • User domain name

GetSIPUri.xaml.cpp File Reference

#include "pch.h"
#include "GetSIPUri.xaml.h"
#include <ppltasks.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetSIPUri.xaml.h File Reference

  • User domain name
Classes | Namespaces

GetSIPUri.xaml.h File Reference

#include "pch.h"
#include "GetSIPUri.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::UserDomainName::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserDomainName
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/MainPage.xaml.cpp File Reference

  • User domain name

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/MainPage.xaml.h File Reference

  • User domain name
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/pch.cpp File Reference

  • User domain name

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/pch.h File Reference

  • User domain name

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/common/LayoutAwarePage.cpp File Reference

  • User domain name
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/common/LayoutAwarePage.h File Reference

  • User domain name
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/common/suspensionmanager.cpp File Reference

  • User domain name
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/common/suspensionmanager.h File Reference

  • User domain name
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/App.xaml.cpp File Reference

  • USSD message management

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/App.xaml.h File Reference

  • USSD message management
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/Constants.cpp File Reference

  • USSD message management

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/Constants.h File Reference

  • USSD message management
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/MainPage.xaml.cpp File Reference

  • USSD message management

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/MainPage.xaml.h File Reference

  • USSD message management
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/pch.cpp File Reference

  • USSD message management

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/pch.h File Reference

  • USSD message management

pch.h File Reference

#include <windows.h>
#include <strsafe.h>
#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/RequestResponse.xaml.cpp File Reference

  • USSD message management

RequestResponse.xaml.cpp File Reference

#include "pch.h"
#include "RequestResponse.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/RequestResponse.xaml.h File Reference

  • USSD message management
Classes | Namespaces

RequestResponse.xaml.h File Reference

#include "pch.h"
#include "RequestResponse.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::UssdApi::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UssdApi
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/common/LayoutAwarePage.cpp File Reference

  • USSD message management
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/common/LayoutAwarePage.h File Reference

  • USSD message management
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/common/suspensionmanager.cpp File Reference

  • USSD message management
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/common/suspensionmanager.h File Reference

  • USSD message management
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/App.xaml.cpp File Reference

  • Web authentication broker

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/App.xaml.h File Reference

  • Web authentication broker
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/Constants.cpp File Reference

  • Web authentication broker

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/Constants.h File Reference

  • Web authentication broker
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/MainPage.xaml.cpp File Reference

  • Web authentication broker

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/MainPage.xaml.h File Reference

  • Web authentication broker
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/pch.cpp File Reference

  • Web authentication broker

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/pch.h File Reference

  • Web authentication broker

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/Scenario1.xaml.cpp File Reference

  • Web authentication broker

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/Scenario1.xaml.h File Reference

  • Web authentication broker
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebAuthentication::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebAuthentication
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/Scenario2.xaml.cpp File Reference

  • Web authentication broker

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/Scenario2.xaml.h File Reference

  • Web authentication broker
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebAuthentication::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebAuthentication
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/common/LayoutAwarePage.cpp File Reference

  • Web authentication broker
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/common/LayoutAwarePage.h File Reference

  • Web authentication broker
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/common/suspensionmanager.cpp File Reference

  • Web authentication broker
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/common/suspensionmanager.h File Reference

  • Web authentication broker
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/App.xaml.cpp File Reference

  • Windows account authorization

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/App.xaml.h File Reference

  • Windows account authorization
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/Constants.cpp File Reference

  • Windows account authorization

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/Constants.h File Reference

  • Windows account authorization
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/DelegationTickets.xaml.cpp File Reference

  • Windows account authorization

DelegationTickets.xaml.cpp File Reference

#include "pch.h"
#include "DelegationTickets.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/DelegationTickets.xaml.h File Reference

  • Windows account authorization
Classes | Namespaces

DelegationTickets.xaml.h File Reference

#include "pch.h"
#include "DelegationTickets.g.h"
#include "MainPage.xaml.h"
#include "HttpRequest.h"

Go to the source code of this file.

Classes

class | SDKSample::MicrosoftAccount::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::MicrosoftAccount
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/HttpRequest.cpp File Reference

  • Windows account authorization
Classes

HttpRequest.cpp File Reference

#include "pch.h"
#include "HttpRequest.h"
#include <robuffer.h>
#include <shcore.h>

Go to the source code of this file.

Classes

class HttpRequestStringCallback
Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/HttpRequest.h File Reference

  • Windows account authorization
Classes | Namespaces | Functions

HttpRequest.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | Web::Details::HttpRequestBuffersCallback
class | Web::HttpRequest

Namespaces

namespace | Web
namespace | Web::Details

Functions

void | CheckHResult (HRESULT hResult)

Function Documentation

void CheckHResult ( HRESULT hResult ) [inline]

Definition at line 14 of file HttpRequest.h.

{
    if (hResult == E_ABORT)
    {
        concurrency::cancel_current_task();
    }
    else if (FAILED(hResult))
    {
        throw Platform::Exception::CreateException(hResult);
    }
}

Generated on Sat Nov 23 2024 16:08:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/MainPage.xaml.cpp File Reference

  • Windows account authorization

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/MainPage.xaml.h File Reference

  • Windows account authorization
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/pch.cpp File Reference

  • Windows account authorization

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/pch.h File Reference

  • Windows account authorization

pch.h File Reference

#include <msxml6.h>
#include <collection.h>
#include <ppltasks.h>
#include <wrl.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include <sstream>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/common/LayoutAwarePage.cpp File Reference

  • Windows account authorization
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/common/LayoutAwarePage.h File Reference

  • Windows account authorization
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/common/suspensionmanager.cpp File Reference

  • Windows account authorization
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/common/suspensionmanager.h File Reference

  • Windows account authorization
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/App.xaml.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/App.xaml.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Common.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Defines | Enumerations | Functions

Common.h File Reference

#include <Windows.h>
#include <wrl\implements.h>
#include <mmreg.h>
#include <mfapi.h>

Go to the source code of this file.

Classes

class | CAsyncState
struct | RenderBuffer

Defines

#define | METHODASYNCCALLBACK(Parent, AsyncCallback, pfnCallback)
#define | SAFE_ARRAYDELETE(x) { delete[] x; x = nullptr; }
#define | SAFE_DELETE(x) { delete x; x = nullptr; }
#define | SAFE_RELEASE(x) { SafeRelease(&x); }

Enumerations

enum | RenderSampleType { SampleTypeUnknown, SampleTypeFloat, SampleType16BitPCM }

Functions

RenderSampleType | CalculateMixFormatType (WAVEFORMATEX *wfx)
template<class T >
void | SafeRelease (__deref_inout_opt T **ppT)
void | ThrowIfFailed (HRESULT hr)

Define Documentation

#define METHODASYNCCALLBACK | ( | Parent,
 |  | AsyncCallback,
 |  | pfnCallback
 | ) |

Definition at line 60 of file Common.h.

#define SAFE_ARRAYDELETE ( x ) { delete[] x; x = nullptr; }

Definition at line 56 of file Common.h.

#define SAFE_DELETE ( x ) { delete x; x = nullptr; }

Definition at line 52 of file Common.h.

#define SAFE_RELEASE ( x ) { SafeRelease(&x); }

Definition at line 48 of file Common.h.

Enumeration Type Documentation

enum RenderSampleType
Enumerator:
SampleTypeUnknown
SampleTypeFloat
SampleType16BitPCM

Definition at line 155 of file Common.h.

{
    SampleTypeUnknown,
    SampleTypeFloat,
    SampleType16BitPCM,
};

Function Documentation

RenderSampleType CalculateMixFormatType ( WAVEFORMATEX * wfx ) [inline]

Definition at line 167 of file Common.h.

{
    if ( (wfx->wFormatTag == WAVE_FORMAT_PCM) ||
         (  (wfx->wFormatTag == WAVE_FORMAT_EXTENSIBLE) &&
            (reinterpret_cast<WAVEFORMATEXTENSIBLE *>(wfx)->SubFormat == KSDATAFORMAT_SUBTYPE_PCM) ) )
    {
        if (wfx->wBitsPerSample == 16)
        {
            return RenderSampleType::SampleType16BitPCM;
        }
    }
    else if ( (wfx->wFormatTag == WAVE_FORMAT_IEEE_FLOAT) ||
              ( (wfx->wFormatTag == WAVE_FORMAT_EXTENSIBLE) &&
                (reinterpret_cast<WAVEFORMATEXTENSIBLE *>(wfx)->SubFormat == KSDATAFORMAT_SUBTYPE_IEEE_FLOAT) ) )
    {
        return RenderSampleType::SampleTypeFloat;
    }

    return RenderSampleType::SampleTypeUnknown;
}

template<class T >
void SafeRelease ( __deref_inout_opt T ** ppT )

Definition at line 27 of file Common.h.

{
    T *pTTemp = *ppT;    // temp copy
    *ppT = nullptr;      // zero the input
    if (pTTemp)
    {
        pTTemp->Release();
    }
}

void ThrowIfFailed ( HRESULT hr ) [inline]

Definition at line 38 of file Common.h.

{
    if (FAILED( hr ))
    {
        // Set a breakpoint on this line to catch API errors.
        throw Platform::Exception::CreateException( hr );
    }
}

Generated on Sat Nov 23 2024 16:08:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Constants.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Constants.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/DeviceState.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces | Enumerations | Functions

DeviceState.h File Reference

#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WASAPIAudio::sealed
class | SDKSample::WASAPIAudio::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio

Enumerations

enum SDKSample::WASAPIAudio::DeviceState {
SDKSample::WASAPIAudio::DeviceStateUnInitialized, SDKSample::WASAPIAudio::DeviceStateInError, SDKSample::WASAPIAudio::DeviceStateDiscontinutity, SDKSample::WASAPIAudio::DeviceStateFlushing,
SDKSample::WASAPIAudio::DeviceStateActivated, SDKSample::WASAPIAudio::DeviceStateInitialized, SDKSample::WASAPIAudio::DeviceStateStarting, SDKSample::WASAPIAudio::DeviceStatePlaying,
SDKSample::WASAPIAudio::DeviceStateCapturing, SDKSample::WASAPIAudio::DeviceStatePausing, SDKSample::WASAPIAudio::DeviceStatePaused, SDKSample::WASAPIAudio::DeviceStateStopping,
SDKSample::WASAPIAudio::DeviceStateStopped
}

Functions

public delegate void | SDKSample::WASAPIAudio::DeviceStateChangedHandler (Platform::Object^sender, DeviceStateChangedEventArgs^e)
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/MainPage.xaml.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/MainPage.xaml.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/MFSampleGenerator.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

MFSampleGenerator.cpp File Reference

#include "pch.h"
#include "MFSampleGenerator.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/MFSampleGenerator.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces | Defines

MFSampleGenerator.h File Reference

#include <windows.h>
#include <mfapi.h>
#include <mfidl.h>
#include <mfreadwrite.h>
#include <mferror.h>
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WASAPIAudio::MFSampleGenerator

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio

Defines

#define | PREROLL_DURATION_SEC 3

Define Documentation

#define PREROLL_DURATION_SEC 3

Definition at line 24 of file MFSampleGenerator.h.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/pch.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/pch.h File Reference

  • Windows Audio Session (WASAPI)
  • C++

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/PlotData.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces | Defines | Functions

PlotData.h File Reference

#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WASAPIAudio::sealed
class | SDKSample::WASAPIAudio::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio

Defines

#define | MILLISECONDS_TO_VISUALIZE 20

Functions

public delegate void | SDKSample::WASAPIAudio::PlotDataReadyHandler (Platform::Object^sender, PlotDataReadyEventArgs^e)

Define Documentation

#define MILLISECONDS_TO_VISUALIZE 20

Definition at line 19 of file PlotData.h.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Scenario1.xaml.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Scenario1.xaml.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WASAPIAudio::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Scenario2.xaml.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Scenario2.xaml.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces | Enumerations

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"
#include "WASAPIRenderer.h"

Go to the source code of this file.

Classes

class | SDKSample::WASAPIAudio::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio

Enumerations

enum | SDKSample::WASAPIAudio::ContentType { SDKSample::WASAPIAudio::ContentTypeTone, SDKSample::WASAPIAudio::ContentTypeFile }
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Scenario3.xaml.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/Scenario3.xaml.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces | Defines

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"
#include "WASAPICapture.h"

Go to the source code of this file.

Classes

class | SDKSample::WASAPIAudio::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio

Defines

#define | OSC_START_X 100
#define | OSC_START_Y 100
#define | OSC_TOTAL_HEIGHT 200
#define | OSC_X_LENGTH 700

Define Documentation

#define OSC_START_X 100

Definition at line 23 of file Scenario3.xaml.h.

#define OSC_START_Y 100

Definition at line 24 of file Scenario3.xaml.h.

#define OSC_TOTAL_HEIGHT 200

Definition at line 26 of file Scenario3.xaml.h.

#define OSC_X_LENGTH 700

Definition at line 25 of file Scenario3.xaml.h.

Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/ToneSampleGenerator.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++
Functions | Variables

ToneSampleGenerator.cpp File Reference

#include "pch.h"
#include "ToneSampleGenerator.h"

Go to the source code of this file.

Functions

template<>
float | Convert< float > (double Value)
template<>
short | Convert< short > (double Value)

Variables

const double | TONE_AMPLITUDE = 0.5
const int | TONE_DURATION_SEC = 30

Function Documentation

template<>
float Convert< float > ( double Value )
template<>
short Convert< short > ( double Value )

Definition at line 30 of file ToneSampleGenerator.cpp.

{
    return (short)(Value * _I16_MAX);
};

Variable Documentation

const double TONE_AMPLITUDE = 0.5

Definition at line 21 of file ToneSampleGenerator.cpp.

const int TONE_DURATION_SEC = 30

Definition at line 20 of file ToneSampleGenerator.cpp.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/ToneSampleGenerator.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces | Defines | Functions

ToneSampleGenerator.h File Reference

#include <math.h>
#include <limits.h>
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WASAPIAudio::ToneSampleGenerator

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio

Defines

#define | _USE_MATH_DEFINES

Functions

template<typename T >
T | Convert (double Value)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 17 of file ToneSampleGenerator.h.

Function Documentation

template<typename T >
T Convert ( double Value )
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/WASAPICapture.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

WASAPICapture.cpp File Reference

#include "pch.h"
#include "WASAPICapture.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/WASAPICapture.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces | Defines

WASAPICapture.h File Reference

#include <Windows.h>
#include <wrl\implements.h>
#include <mfapi.h>
#include <AudioClient.h>
#include <mmdeviceapi.h>
#include "MainPage.xaml.h"
#include "DeviceState.h"
#include "PlotData.h"

Go to the source code of this file.

Classes

class | SDKSample::WASAPIAudio::WASAPICapture

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio

Defines

#define | AUDIO_FILE_NAME "WASAPIAudioCapture.wav"
#define | FLUSH_INTERVAL_SEC 3

Define Documentation

#define AUDIO_FILE_NAME "WASAPIAudioCapture.wav"

Definition at line 28 of file WASAPICapture.h.

#define FLUSH_INTERVAL_SEC 3

Definition at line 29 of file WASAPICapture.h.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/WASAPIRenderer.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++

WASAPIRenderer.cpp File Reference

#include "pch.h"
#include "WASAPIRenderer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/WASAPIRenderer.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
Classes | Namespaces

WASAPIRenderer.h File Reference

#include <Windows.h>
#include <wrl\implements.h>
#include <mfapi.h>
#include <AudioClient.h>
#include <mmdeviceapi.h>
#include "MainPage.xaml.h"
#include "DeviceState.h"
#include "ToneSampleGenerator.h"
#include "MFSampleGenerator.h"

Go to the source code of this file.

Classes

struct | SDKSample::WASAPIAudio::DEVICEPROPS
class | SDKSample::WASAPIAudio::WASAPIRenderer

Namespaces

namespace | SDKSample
namespace | SDKSample::WASAPIAudio
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/common/LayoutAwarePage.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/common/LayoutAwarePage.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/common/suspensionmanager.cpp File Reference

  • Windows Audio Session (WASAPI)
  • C++
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/common/suspensionmanager.h File Reference

  • Windows Audio Session (WASAPI)
  • C++
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/App.xaml.cs File Reference

  • Windows Store device app for camera
  • C#,C++
Classes | Namespaces

App.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::App
Provides application-specific behavior to supplement the default Application class. More...

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/Constants.cs File Reference

  • Windows Store device app for camera
  • C#,C++
Classes | Namespaces

Constants.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKTemplate::Scenario

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/DeviceAppPage.xaml.cs File Reference

  • Windows Store device app for camera
  • C#,C++
Classes | Namespaces

DeviceAppPage.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::DeviceAppPage

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/MainPage.xaml.cs File Reference

  • Windows Store device app for camera
  • C#,C++
Classes | Namespaces

MainPage.xaml.cs File Reference

Go to the source code of this file.

Classes

class | SDKTemplate::MainPage
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKTemplate
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/Wrapper/pch.cpp File Reference

  • Windows Store device app for camera
  • C#,C++
  • Wrapper

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/Wrapper/pch.h File Reference

  • Windows Store device app for camera
  • C#,C++
  • Wrapper

pch.h File Reference

#include <winstring.h>
#include <wrl\client.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/Wrapper/SampleMft0.h File Reference

  • Windows Store device app for camera
  • C#,C++
  • Wrapper
Classes | Defines | Typedefs | Variables

SampleMft0.h File Reference

#include "rpc.h"
#include "rpcndr.h"
#include "windows.h"
#include "ole2.h"
#include "oaidl.h"
#include "ocidl.h"
#include "Inspectable.h"
#include "mftransform.h"

Go to the source code of this file.

Classes

struct | IMft0Vtbl

Defines

#define | __IMft0_FWD_DEFINED__
#define | __IMft0_INTERFACE_DEFINED__
#define | __Mft0_FWD_DEFINED__
#define | __REQUIRED_RPCNDR_H_VERSION__ 500
#define | __samplemft0_h__
#define | __SampleMft0Lib_LIBRARY_DEFINED__

Typedefs

typedef interface IMft0 | IMft0
typedef struct IMft0Vtbl | IMft0Vtbl
typedef struct Mft0 | Mft0

Variables

EXTERN_C const CLSID | CLSID_Mft0
EXTERN_C const IID | IID_IMft0
EXTERN_C const IID | LIBID_SampleMft0Lib

Define Documentation

#define __IMft0_FWD_DEFINED__

Definition at line 44 of file SampleMft0.h.

#define __IMft0_INTERFACE_DEFINED__

Definition at line 74 of file SampleMft0.h.

#define __Mft0_FWD_DEFINED__

Definition at line 51 of file SampleMft0.h.

#define __REQUIRED_RPCNDR_H_VERSION__ 500

Definition at line 14 of file SampleMft0.h.

#define __samplemft0_h__

Definition at line 35 of file SampleMft0.h.

#define __SampleMft0Lib_LIBRARY_DEFINED__

Definition at line 183 of file SampleMft0.h.

Typedef Documentation

typedef interface IMft0 IMft0

Definition at line 45 of file SampleMft0.h.

typedef struct IMft0Vtbl IMft0Vtbl
typedef struct Mft0 Mft0

Definition at line 56 of file SampleMft0.h.

Variable Documentation

EXTERN_C const CLSID CLSID_Mft0

Definition at line 191 of file SampleMft0.h.

EXTERN_C const IID IID_IMft0

Definition at line 80 of file SampleMft0.h.

EXTERN_C const IID LIBID_SampleMft0Lib

Definition at line 189 of file SampleMft0.h.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/App.xaml.cpp File Reference

  • Windows Store device app for camera

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"
#include "DeviceAppPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/App.xaml.h File Reference

  • Windows Store device app for camera
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"
#include "DeviceAppPage.g.h"

Go to the source code of this file.

Classes

class | DeviceAppForWebcam::sealed

Namespaces

namespace | DeviceAppForWebcam
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Constants.cpp File Reference

  • Windows Store device app for camera

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Constants.h File Reference

  • Windows Store device app for camera
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | DeviceAppForWebcam::MainPage

Namespaces

namespace | DeviceAppForWebcam
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/DeviceAppPage.xaml.cpp File Reference

  • Windows Store device app for camera

DeviceAppPage.xaml.cpp File Reference

#include "pch.h"
#include "DeviceAppPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/DeviceAppPage.xaml.h File Reference

  • Windows Store device app for camera
Classes | Namespaces

DeviceAppPage.xaml.h File Reference

#include "pch.h"
#include "DeviceAppPage.g.h"
#include <agile.h>

Go to the source code of this file.

Classes

class | DeviceAppForWebcam::sealed

Namespaces

namespace | DeviceAppForWebcam
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/MainPage.xaml.cpp File Reference

  • Windows Store device app for camera

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/MainPage.xaml.h File Reference

  • Windows Store device app for camera
Classes | Namespaces

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | DeviceAppForWebcam::sealed

Namespaces

namespace | DeviceAppForWebcam
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/pch.cpp File Reference

  • Windows Store device app for camera

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/pch.h File Reference

  • Windows Store device app for camera

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Common/LayoutAwarePage.h File Reference

  • Windows Store device app for camera
  • Common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | DeviceAppForWebcam::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | DeviceAppForWebcam
namespace | DeviceAppForWebcam::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Wrapper/pch.cpp File Reference

  • Windows Store device app for camera
  • Wrapper

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Wrapper/pch.h File Reference

  • Windows Store device app for camera
  • Wrapper

pch.h File Reference

#include <winstring.h>
#include <wrl\client.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Wrapper/SampleMft0.h File Reference

  • Windows Store device app for camera
  • Wrapper
Classes | Defines | Typedefs | Variables

SampleMft0.h File Reference

#include "rpc.h"
#include "rpcndr.h"
#include "windows.h"
#include "ole2.h"
#include "oaidl.h"
#include "ocidl.h"
#include "Inspectable.h"
#include "mftransform.h"

Go to the source code of this file.

Classes

struct | IMft0Vtbl

Defines

#define | __IMft0_FWD_DEFINED__
#define | __IMft0_INTERFACE_DEFINED__
#define | __Mft0_FWD_DEFINED__
#define | __REQUIRED_RPCNDR_H_VERSION__ 500
#define | __samplemft0_h__
#define | __SampleMft0Lib_LIBRARY_DEFINED__

Typedefs

typedef interface IMft0 | IMft0
typedef struct IMft0Vtbl | IMft0Vtbl
typedef struct Mft0 | Mft0

Variables

EXTERN_C const CLSID | CLSID_Mft0
EXTERN_C const IID | IID_IMft0
EXTERN_C const IID | LIBID_SampleMft0Lib

Define Documentation

#define __IMft0_FWD_DEFINED__

Definition at line 44 of file SampleMft0.h.

#define __IMft0_INTERFACE_DEFINED__

Definition at line 74 of file SampleMft0.h.

#define __Mft0_FWD_DEFINED__

Definition at line 51 of file SampleMft0.h.

#define __REQUIRED_RPCNDR_H_VERSION__ 500

Definition at line 14 of file SampleMft0.h.

#define __samplemft0_h__

Definition at line 35 of file SampleMft0.h.

#define __SampleMft0Lib_LIBRARY_DEFINED__

Definition at line 183 of file SampleMft0.h.

Typedef Documentation

typedef interface IMft0 IMft0

Definition at line 45 of file SampleMft0.h.

typedef struct IMft0Vtbl IMft0Vtbl
typedef struct Mft0 Mft0

Definition at line 56 of file SampleMft0.h.

Variable Documentation

EXTERN_C const CLSID CLSID_Mft0

Definition at line 191 of file SampleMft0.h.

EXTERN_C const IID IID_IMft0

Definition at line 80 of file SampleMft0.h.

EXTERN_C const IID LIBID_SampleMft0Lib

Definition at line 189 of file SampleMft0.h.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Wrapper/WinRTComponent.h File Reference

  • Windows Store device app for camera
  • Wrapper
Classes | Namespaces

WinRTComponent.h File Reference

Go to the source code of this file.

Classes

struct | Wrapper::DspSettings
class | Wrapper::sealed

Namespaces

namespace | Wrapper
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/App.xaml.cpp File Reference

  • XAML accessibility

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/App.xaml.h File Reference

  • XAML accessibility
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Constants.cpp File Reference

  • XAML accessibility

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Constants.h File Reference

  • XAML accessibility
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/MainPage.xaml.cpp File Reference

  • XAML accessibility

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/MainPage.xaml.h File Reference

  • XAML accessibility
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/pch.cpp File Reference

  • XAML accessibility

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/pch.h File Reference

  • XAML accessibility

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario1.xaml.cpp File Reference

  • XAML accessibility

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario1.xaml.h File Reference

  • XAML accessibility
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Accessibility
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario2.xaml.cpp File Reference

  • XAML accessibility

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario2.xaml.h File Reference

  • XAML accessibility
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Accessibility
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario3.xaml.cpp File Reference

  • XAML accessibility

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario3.xaml.h File Reference

  • XAML accessibility
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Accessibility
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario4.xaml.cpp File Reference

  • XAML accessibility

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario4.xaml.h File Reference

  • XAML accessibility
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::Accessibility::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Accessibility
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/common/LayoutAwarePage.cpp File Reference

  • XAML accessibility
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/common/LayoutAwarePage.h File Reference

  • XAML accessibility
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/common/suspensionmanager.cpp File Reference

  • XAML accessibility
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/common/suspensionmanager.h File Reference

  • XAML accessibility
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/App.xaml.cpp File Reference

  • XAML animation library

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/App.xaml.h File Reference

  • XAML animation library
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Constants.cpp File Reference

  • XAML animation library

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Constants.h File Reference

  • XAML animation library
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/MainPage.xaml.cpp File Reference

  • XAML animation library

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/MainPage.xaml.h File Reference

  • XAML animation library
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/pch.cpp File Reference

  • XAML animation library

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/pch.h File Reference

  • XAML animation library

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario1.xaml.cpp File Reference

  • XAML animation library

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario1.xaml.h File Reference

  • XAML animation library
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Animation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Animation
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario2.xaml.cpp File Reference

  • XAML animation library

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario2.xaml.h File Reference

  • XAML animation library
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Animation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Animation
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario3.xaml.cpp File Reference

  • XAML animation library

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario3.xaml.h File Reference

  • XAML animation library
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Animation::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Animation
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/common/LayoutAwarePage.cpp File Reference

  • XAML animation library
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/common/LayoutAwarePage.h File Reference

  • XAML animation library
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/common/suspensionmanager.cpp File Reference

  • XAML animation library
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/common/suspensionmanager.h File Reference

  • XAML animation library
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/App.xaml.cpp File Reference

  • XAML AppBar control

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/App.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | AppBarControl::App

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Constants.cpp File Reference

  • XAML AppBar control

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Constants.h File Reference

  • XAML AppBar control
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | AppBarControl::MainPage
struct | AppBarControl::Scenario

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/GlobalPage.xaml.cpp File Reference

  • XAML AppBar control

GlobalPage.xaml.cpp File Reference

#include "pch.h"
#include "Page1.xaml.h"
#include "GlobalPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/GlobalPage.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

GlobalPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "GlobalPage.g.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/MainPage.xaml.cpp File Reference

  • XAML AppBar control

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/MainPage.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl

Enumerations

enum | AppBarControl::NotifyType { AppBarControl::StatusMessage, AppBarControl::ErrorMessage }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page1.xaml.cpp File Reference

  • XAML AppBar control

Page1.xaml.cpp File Reference

#include "pch.h"
#include "Page1.xaml.h"
#include "Page2.xaml.h"
#include "GlobalPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page1.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

Page1.xaml.h File Reference

#include "pch.h"
#include "GlobalPage.xaml.h"
#include "Page1.g.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page2.xaml.cpp File Reference

  • XAML AppBar control

Page2.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "Page2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page2.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

Page2.xaml.h File Reference

#include "pch.h"
#include "GlobalPage.xaml.h"
#include "Page2.g.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page3.xaml.cpp File Reference

  • XAML AppBar control

Page3.xaml.cpp File Reference

#include "pch.h"
#include "Page3.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page3.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

Page3.xaml.h File Reference

#include "Page3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/pch.cpp File Reference

  • XAML AppBar control

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/pch.h File Reference

  • XAML AppBar control

pch.h File Reference

#include "Sample-Utils\CppSamplesUtils.h"
#include <ppltasks.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario1.xaml.cpp File Reference

  • XAML AppBar control

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario1.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario2.xaml.cpp File Reference

  • XAML AppBar control

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario2.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario3.xaml.cpp File Reference

  • XAML AppBar control

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "GlobalPage.xaml.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario3.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario4.xaml.cpp File Reference

  • XAML AppBar control

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Page3.xaml.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario4.xaml.h File Reference

  • XAML AppBar control
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | AppBarControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | AppBarControl
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/common/LayoutAwarePage.cpp File Reference

  • XAML AppBar control
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/common/LayoutAwarePage.h File Reference

  • XAML AppBar control
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include "pch.h"
#include <collection.h>

Go to the source code of this file.

Classes

class | AppBarControl::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences: application view state to visual state mapping, GoBack and GoHome event handlers, and a default view model. More...

Namespaces

namespace | AppBarControl
namespace | AppBarControl::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Sample-Utils/CppSamplesUtils.h File Reference

  • XAML AppBar control
  • Sample-Utils
Classes | Namespaces | Functions

CppSamplesUtils.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | CppSamplesUtils::SuspensionManager

Namespaces

namespace | CppSamplesUtils
namespace | CppSamplesUtils::Details

Functions

Platform::String | CppSamplesUtils::Details::ConvertPropertyValueToString (Windows::Foundation::IPropertyValue^pv)
Platform::Object | CppSamplesUtils::Details::ConvertStringToObject (Windows::Foundation::PropertyType type, Platform::String^str)
Windows::Data::Xml::Dom::XmlElement | CppSamplesUtils::Details::CreateXmlElementFromObject (Windows::Data::Xml::Dom::XmlDocument^doc, Platform::String^name, Platform::Object^value)
concurrency::task< void > | CppSamplesUtils::Details::DeserializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
T | CppSamplesUtils::Details::FromHexStringTo (Platform::String^str)
template<class T >
T | CppSamplesUtils::Details::FromStringTo (Platform::String^str)
template<>
Platform::Guid | CppSamplesUtils::Details::FromStringTo< Platform::Guid > (Platform::String^str)
Windows::Foundation::PropertyType | CppSamplesUtils::Details::PropertyTypeFromString (Platform::String^str)
concurrency::task< void > | CppSamplesUtils::Details::SerializeSessionState (Windows::Storage::IStorageFile^file)
template<class T >
Platform::String | CppSamplesUtils::Details::ToString (T value)
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/App.xaml.cpp File Reference

  • XAML data binding

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/App.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Constants.cpp File Reference

  • XAML data binding

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Constants.h File Reference

  • XAML data binding
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Employee.h File Reference

  • XAML data binding
Classes | Namespaces

Employee.h File Reference

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/GeneratorIncrementalLoadingClass.h File Reference

  • XAML data binding
Classes | Namespaces

GeneratorIncrementalLoadingClass.h File Reference

#include <ppltasks.h>
#include <collection.h>
#include "IncrementalLoadingBase.h"
#include "Employee.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::GeneratorIncrementalLoadingClass

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/IncrementalLoadingBase.h File Reference

  • XAML data binding
Classes | Namespaces

IncrementalLoadingBase.h File Reference

#include <ppltasks.h>
#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::IncrementalLoadingBase

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/MainPage.xaml.cpp File Reference

  • XAML data binding

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/MainPage.xaml.h File Reference

  • XAML data binding
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/pch.cpp File Reference

  • XAML data binding

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/pch.h File Reference

  • XAML data binding

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Constants.h"
#include "S2Formatter.h"
#include "Employee.h"
#include "Team.h"
#include "IncrementalLoadingBase.h"
#include "GeneratorIncrementalLoadingClass.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Constants.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/S2Formatter.cpp File Reference

  • XAML data binding

S2Formatter.cpp File Reference

#include "pch.h"
#include "S2Formatter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/S2Formatter.h File Reference

  • XAML data binding
Classes | Namespaces

S2Formatter.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario1.xaml.cpp File Reference

  • XAML data binding

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario1.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario2.xaml.cpp File Reference

  • XAML data binding

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"
#include "S2Formatter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario2.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"
#include "S2Formatter.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario3.xaml.cpp File Reference

  • XAML data binding

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"
#include "Employee.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario3.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"
#include "Employee.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario4.xaml.cpp File Reference

  • XAML data binding

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"
#include "Team.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario4.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario5.xaml.cpp File Reference

  • XAML data binding

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"
#include "Team.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario5.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario6.xaml.cpp File Reference

  • XAML data binding

Scenario6.xaml.cpp File Reference

#include "pch.h"
#include "Scenario6.xaml.h"
#include "Team.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario6.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

Scenario6.xaml.h File Reference

#include "pch.h"
#include "Scenario6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario7.xaml.cpp File Reference

  • XAML data binding

Scenario7.xaml.cpp File Reference

#include "pch.h"
#include "Scenario7.xaml.h"
#include "Team.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario7.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

Scenario7.xaml.h File Reference

#include "pch.h"
#include "Scenario7.g.h"
#include "MainPage.xaml.h"
#include "Team.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario8.xaml.cpp File Reference

  • XAML data binding

Scenario8.xaml.cpp File Reference

#include "pch.h"
#include "Scenario8.xaml.h"
#include "Team.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario8.xaml.h File Reference

  • XAML data binding
Classes | Namespaces

Scenario8.xaml.h File Reference

#include "pch.h"
#include "Scenario8.g.h"
#include "MainPage.xaml.h"
#include "Employee.h"

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Team.cpp File Reference

  • XAML data binding

Team.cpp File Reference

#include "pch.h"
#include "Team.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Team.h File Reference

  • XAML data binding
Classes | Namespaces

Team.h File Reference

Go to the source code of this file.

Classes

class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::DataBinding::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::DataBinding
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Common/LayoutAwarePage.cpp File Reference

  • XAML data binding
  • Common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Common/LayoutAwarePage.h File Reference

  • XAML data binding
  • Common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Common/suspensionmanager.cpp File Reference

  • XAML data binding
  • Common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Common/suspensionmanager.h File Reference

  • XAML data binding
  • Common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/App.xaml.cpp File Reference

  • XAML Direct2D lighting effects

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/App.xaml.h File Reference

  • XAML Direct2D lighting effects
Classes | Namespaces

App.xaml.h File Reference

#include "MainPage.xaml.h"
#include "App.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | D2DLightingEffects::sealed

Namespaces

namespace | D2DLightingEffects
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/D2DLightingEffectsRenderer.h File Reference

  • XAML Direct2D lighting effects
Classes | Enumerations

D2DLightingEffectsRenderer.h File Reference

#include "DirectXBase.h"
#include "DirectXBase.h"

Go to the source code of this file.

Classes

class D2DLightingEffectsRenderer

Enumerations

enum LightingEffect {
PointSpecular, SpotSpecular, DistantSpecular, PointDiffuse,
SpotDiffuse, DistantDiffuse
}
enum LightingProperty {
LightPositionZ, SpecularExponent, SpecularConstant, DiffuseConstant,
Focus, LimitingConeAngle, Elevation, Azimuth,
SurfaceScale
}

Enumeration Type Documentation

enum LightingEffect
Enumerator:
PointSpecular
SpotSpecular
DistantSpecular
PointDiffuse
SpotDiffuse
DistantDiffuse

Definition at line 12 of file D2DLightingEffectsRenderer.h.

{
    PointSpecular,
    SpotSpecular,
    DistantSpecular,
    PointDiffuse,
    SpotDiffuse,
    DistantDiffuse
};

enum LightingProperty
Enumerator:
LightPositionZ
SpecularExponent
SpecularConstant
DiffuseConstant
Focus
LimitingConeAngle
Elevation
Azimuth
SurfaceScale

Definition at line 24 of file D2DLightingEffectsRenderer.h.

{
    LightPositionZ,
    SpecularExponent,
    SpecularConstant,
    DiffuseConstant,
    Focus,
    LimitingConeAngle,
    Elevation,
    Azimuth,
    SurfaceScale
};

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/DirectXBase.cpp File Reference

  • XAML Direct2D lighting effects

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/DirectXBase.h File Reference

  • XAML Direct2D lighting effects
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/DirectXSample.h File Reference

  • XAML Direct2D lighting effects
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/MainPage.xaml.cpp File Reference

  • XAML Direct2D lighting effects

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/MainPage.xaml.h File Reference

  • XAML Direct2D lighting effects
Classes | Namespaces

MainPage.xaml.h File Reference

#include "MainPage.g.h"
#include "D2DLightingEffectsRenderer.h"

Go to the source code of this file.

Classes

class | D2DLightingEffects::sealed

Namespaces

namespace | D2DLightingEffects
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/pch.cpp File Reference

  • XAML Direct2D lighting effects

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/pch.h File Reference

  • XAML Direct2D lighting effects

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "windows.ui.xaml.media.dxinterop.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Animate.cpp File Reference

  • XAML DirectX 3D shooting game

Animate.cpp File Reference

#include "pch.h"
#include "Animate.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Animate.h File Reference

  • XAML DirectX 3D shooting game
Classes

Animate.h File Reference

Go to the source code of this file.

Classes

class | abstract
class | AnimateCirclePosition
class | AnimateLineListPosition
class | AnimateLinePosition
struct | LineSegment
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/App.xaml.cpp File Reference

  • XAML DirectX 3D shooting game

App.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/App.xaml.h File Reference

  • XAML DirectX 3D shooting game
Classes | Namespaces | Defines | Enumerations

App.xaml.h File Reference

#include "MainPage.xaml.h"
#include "Simple3DGame.h"
#include "PersistentState.h"
#include "App.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | Simple3DGameXaml::sealed

Namespaces

namespace | Simple3DGameXaml

Defines

#define | USE_STORE_SIMULATOR 1

Enumerations

enum Simple3DGameXaml::GameInfoOverlayState {
Simple3DGameXaml::Loading, Simple3DGameXaml::GameStats, Simple3DGameXaml::GameOverExpired, Simple3DGameXaml::GameOverCompleted,
Simple3DGameXaml::LevelStart, Simple3DGameXaml::Pause, Simple3DGameXaml::Snapped
}
enum | Simple3DGameXaml::PressResultState { Simple3DGameXaml::LoadGame, Simple3DGameXaml::PlayLevel, Simple3DGameXaml::ContinueLevel }
enum Simple3DGameXaml::UpdateEngineState {
Simple3DGameXaml::WaitingForResources, Simple3DGameXaml::ResourcesLoaded, Simple3DGameXaml::WaitingForPress, Simple3DGameXaml::Dynamics,
Simple3DGameXaml::Snapped, Simple3DGameXaml::Suspended, Simple3DGameXaml::Deactivated
}

Define Documentation

#define USE_STORE_SIMULATOR 1

Definition at line 50 of file App.xaml.h.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Audio.cpp File Reference

  • XAML DirectX 3D shooting game

Audio.cpp File Reference

#include "pch.h"
#include "Audio.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Audio.h File Reference

  • XAML DirectX 3D shooting game
Classes

Audio.h File Reference

Go to the source code of this file.

Classes

class Audio
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicLoader.cpp File Reference

  • XAML DirectX 3D shooting game

BasicLoader.cpp File Reference

#include "pch.h"
#include "BasicLoader.h"
#include "BasicShapes.h"
#include "DDSTextureLoader.h"
#include "DirectXSample.h"
#include <memory>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicLoader.h File Reference

  • XAML DirectX 3D shooting game
Classes

BasicLoader.h File Reference

#include "BasicReaderWriter.h"

Go to the source code of this file.

Classes

class BasicLoader
Generated on Sat Nov 23 2024 16:08:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicMath.h File Reference

  • XAML DirectX 3D shooting game
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicReaderWriter.cpp File Reference

  • XAML DirectX 3D shooting game

BasicReaderWriter.cpp File Reference

#include "pch.h"
#include "BasicReaderWriter.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicReaderWriter.h File Reference

  • XAML DirectX 3D shooting game
Classes

BasicReaderWriter.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class BasicReaderWriter
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicShapes.h File Reference

  • XAML DirectX 3D shooting game
Classes

BasicShapes.h File Reference

#include "BasicMath.h"
#include "BasicMath.h"

Go to the source code of this file.

Classes

class | BasicShapes
struct | BasicVertex
struct | TangentVertex
Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Camera.cpp File Reference

  • XAML DirectX 3D shooting game

Camera.cpp File Reference

#include "pch.h"
#include "Camera.h"
#include "StereoProjection.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Camera.h File Reference

  • XAML DirectX 3D shooting game
Classes

Camera.h File Reference

Go to the source code of this file.

Classes

class Camera
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/ConstantBuffers.h File Reference

  • XAML DirectX 3D shooting game
Classes

ConstantBuffers.h File Reference

Go to the source code of this file.

Classes

struct | ConstantBufferChangeOnResize
struct | ConstantBufferChangesEveryFrame
struct | ConstantBufferChangesEveryPrim
struct | ConstantBufferNeverChanges
struct | PNTVertex
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Cylinder.cpp File Reference

  • XAML DirectX 3D shooting game

Cylinder.cpp File Reference

#include "pch.h"
#include "Cylinder.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Cylinder.h File Reference

  • XAML DirectX 3D shooting game
Classes

Cylinder.h File Reference

#include "GameObject.h"

Go to the source code of this file.

Classes

class Cylinder
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/CylinderMesh.cpp File Reference

  • XAML DirectX 3D shooting game

CylinderMesh.cpp File Reference

#include "pch.h"
#include "CylinderMesh.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/CylinderMesh.h File Reference

  • XAML DirectX 3D shooting game
Classes

CylinderMesh.h File Reference

#include "MeshObject.h"

Go to the source code of this file.

Classes

class CylinderMesh
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/DDSTextureLoader.cpp File Reference

  • XAML DirectX 3D shooting game
Classes | Defines | Functions

DDSTextureLoader.cpp File Reference

#include "pch.h"
#include <dxgiformat.h>
#include <assert.h>
#include <memory>
#include <algorithm>
#include "DDSTextureLoader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

struct | DDS_HEADER
struct | DDS_HEADER_DXT10
struct | DDS_PIXELFORMAT

Defines

#define | DDS_ALPHA 0x00000002
#define | DDS_CUBEMAP 0x00000200
#define | DDS_CUBEMAP_ALLFACES
#define | DDS_CUBEMAP_NEGATIVEX 0x00000a00
#define | DDS_CUBEMAP_NEGATIVEY 0x00002200
#define | DDS_CUBEMAP_NEGATIVEZ 0x00008200
#define | DDS_CUBEMAP_POSITIVEX 0x00000600
#define | DDS_CUBEMAP_POSITIVEY 0x00001200
#define | DDS_CUBEMAP_POSITIVEZ 0x00004200
#define | DDS_FLAGS_VOLUME 0x00200000
#define | DDS_FOURCC 0x00000004
#define | DDS_HEADER_FLAGS_LINEARSIZE 0x00080000
#define | DDS_HEADER_FLAGS_MIPMAP 0x00020000
#define | DDS_HEADER_FLAGS_PITCH 0x00000008
#define | DDS_HEADER_FLAGS_TEXTURE 0x00001007
#define | DDS_HEADER_FLAGS_VOLUME 0x00800000
#define | DDS_HEIGHT 0x00000002
#define | DDS_LUMINANCE 0x00020000
#define | DDS_LUMINANCEA 0x00020001
#define | DDS_MAGIC 0x20534444
#define | DDS_PAL8 0x00000020
#define | DDS_RGB 0x00000040
#define | DDS_RGBA 0x00000041
#define | DDS_SURFACE_FLAGS_CUBEMAP 0x00000008
#define | DDS_SURFACE_FLAGS_MIPMAP 0x00400008
#define | DDS_SURFACE_FLAGS_TEXTURE 0x00001000
#define | DDS_WIDTH 0x00000004
#define | ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
#define | MAKEFOURCC(ch0, ch1, ch2, ch3)

Functions

void | CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize)

Define Documentation

#define DDS_ALPHA 0x00000002

Definition at line 63 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP 0x00000200

Definition at line 90 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_ALLFACES
Value:
(DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
                              DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
                              DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)

Definition at line 86 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEX 0x00000a00

Definition at line 80 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEY 0x00002200

Definition at line 82 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_NEGATIVEZ 0x00008200

Definition at line 84 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEX 0x00000600

Definition at line 79 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEY 0x00001200

Definition at line 81 of file DDSTextureLoader.cpp.

#define DDS_CUBEMAP_POSITIVEZ 0x00004200

Definition at line 83 of file DDSTextureLoader.cpp.

#define DDS_FLAGS_VOLUME 0x00200000

Definition at line 92 of file DDSTextureLoader.cpp.

#define DDS_FOURCC 0x00000004

Definition at line 58 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_LINEARSIZE 0x00080000

Definition at line 70 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_MIPMAP 0x00020000

Definition at line 67 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_PITCH 0x00000008

Definition at line 69 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_TEXTURE 0x00001007

Definition at line 66 of file DDSTextureLoader.cpp.

#define DDS_HEADER_FLAGS_VOLUME 0x00800000

Definition at line 68 of file DDSTextureLoader.cpp.

#define DDS_HEIGHT 0x00000002

Definition at line 72 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCE 0x00020000

Definition at line 61 of file DDSTextureLoader.cpp.

#define DDS_LUMINANCEA 0x00020001

Definition at line 62 of file DDSTextureLoader.cpp.

#define DDS_MAGIC 0x20534444

Definition at line 44 of file DDSTextureLoader.cpp.

#define DDS_PAL8 0x00000020

Definition at line 64 of file DDSTextureLoader.cpp.

#define DDS_RGB 0x00000040

Definition at line 59 of file DDSTextureLoader.cpp.

#define DDS_RGBA 0x00000041

Definition at line 60 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008

Definition at line 77 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_MIPMAP 0x00400008

Definition at line 76 of file DDSTextureLoader.cpp.

#define DDS_SURFACE_FLAGS_TEXTURE 0x00001000

Definition at line 75 of file DDSTextureLoader.cpp.

#define DDS_WIDTH 0x00000004

Definition at line 73 of file DDSTextureLoader.cpp.

#define ISBITMASK | ( | r,
 |  | g,
 |  | b,
 |  | a |
 | ) |  | (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)

Definition at line 354 of file DDSTextureLoader.cpp.

#define MAKEFOURCC | ( | ch0,
 |  | ch1,
 |  | ch2,
 |  | ch3
 | ) |
Value:
((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
                ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))

Definition at line 32 of file DDSTextureLoader.cpp.

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/DDSTextureLoader.h File Reference

  • XAML DirectX 3D shooting game
Functions

DDSTextureLoader.h File Reference

Go to the source code of this file.

Functions

void CreateDDSTextureFromMemory (_In_ ID3D11Device *d3dDevice, _In_reads_bytes_(ddsDataSize) const byte *ddsData, _In_ size_t ddsDataSize, _Out_opt_ ID3D11Resource **texture, _Out_opt_ ID3D11ShaderResourceView **textureView, _In_ size_t maxsize=0)

Function Documentation

void CreateDDSTextureFromMemory | ( | _In_ ID3D11Device * | d3dDevice,
 |  | _In_reads_bytes_(ddsDataSize) const byte * | ddsData,
 |  | _In_ size_t | ddsDataSize,
 |  | _Out_opt_ ID3D11Resource ** | texture,
 |  | _Out_opt_ ID3D11ShaderResourceView ** | textureView,
 |  | _In_ size_t | maxsize = 0
 | ) |  |

Definition at line 1082 of file DDSTextureLoader.cpp.

{
    if (!d3dDevice || !ddsData || (!texture && !textureView))
    {
        throw ref new Platform::InvalidArgumentException();
    }

    // Validate DDS file in memory
    if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
    {
        throw ref new Platform::FailureException();
    }

    uint32 dwMagicNumber = *(const uint32*)(ddsData);
    if (dwMagicNumber != DDS_MAGIC)
    {
        throw ref new Platform::FailureException();
    }

    const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));

    // Verify header to validate DDS file
    if (header->size != sizeof(DDS_HEADER) ||
        header->ddspf.size != sizeof(DDS_PIXELFORMAT))
    {
        throw ref new Platform::FailureException();
    }

    // Check for DX10 extension
    bool bDXT10Header = false;
    if ((header->ddspf.flags & DDS_FOURCC) &&
        (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
    {
        // Must be long enough for both headers and magic value
        if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
        {
            throw ref new Platform::FailureException();
        }

        bDXT10Header = true;
    }

    ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);

    CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
}

Generated on Sat Nov 23 2024 16:08:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/DirectXBase.cpp File Reference

  • XAML DirectX 3D shooting game

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"
#include "windows.ui.xaml.media.dxinterop.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/DirectXBase.h File Reference

  • XAML DirectX 3D shooting game
Classes | Functions

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class | abstract

Functions

delegate void | D3DDeviceEventHandler ()

Function Documentation

delegate void D3DDeviceEventHandler ( )
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/DirectXSample.h File Reference

  • XAML DirectX 3D shooting game
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Face.cpp File Reference

  • XAML DirectX 3D shooting game

Face.cpp File Reference

#include "pch.h"
#include "Face.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Face.h File Reference

  • XAML DirectX 3D shooting game
Classes

Face.h File Reference

#include "GameObject.h"

Go to the source code of this file.

Classes

class Face
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/FaceMesh.cpp File Reference

  • XAML DirectX 3D shooting game

FaceMesh.cpp File Reference

#include "pch.h"
#include "FaceMesh.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/FaceMesh.h File Reference

  • XAML DirectX 3D shooting game
Classes

FaceMesh.h File Reference

#include "MeshObject.h"

Go to the source code of this file.

Classes

class FaceMesh
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameConstants.h File Reference

  • XAML DirectX 3D shooting game
Namespaces

GameConstants.h File Reference

Go to the source code of this file.

Namespaces

namespace | GameConstants
namespace | GameConstants::Physics
namespace | GameConstants::Sound
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameHud.cpp File Reference

  • XAML DirectX 3D shooting game

GameHud.cpp File Reference

#include "pch.h"
#include "GameHud.h"
#include "GameConstants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameHud.h File Reference

  • XAML DirectX 3D shooting game
Classes

GameHud.h File Reference

#include "Simple3DGame.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class GameHud
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameObject.cpp File Reference

  • XAML DirectX 3D shooting game

GameObject.cpp File Reference

#include "pch.h"
#include "GameObject.h"
#include "ConstantBuffers.h"
#include "GameConstants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameObject.h File Reference

  • XAML DirectX 3D shooting game
Classes

GameObject.h File Reference

#include "MeshObject.h"
#include "SoundEffect.h"
#include "Animate.h"
#include "Material.h"

Go to the source code of this file.

Classes

class GameObject
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameRenderer.cpp File Reference

  • XAML DirectX 3D shooting game

GameRenderer.cpp File Reference

#include "pch.h"
#include "DirectXSample.h"
#include "GameRenderer.h"
#include "ConstantBuffers.h"
#include "TargetTexture.h"
#include "BasicLoader.h"
#include "CylinderMesh.h"
#include "FaceMesh.h"
#include "SphereMesh.h"
#include "WorldMesh.h"
#include "Face.h"
#include "Sphere.h"
#include "Cylinder.h"
#include "windows.ui.xaml.media.dxinterop.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameRenderer.h File Reference

  • XAML DirectX 3D shooting game
Classes

GameRenderer.h File Reference

#include "DirectXBase.h"
#include "GameHud.h"
#include "Simple3DGame.h"
#include "DirectXBase.h"

Go to the source code of this file.

Classes

class GameRenderer
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameTimer.cpp File Reference

  • XAML DirectX 3D shooting game

GameTimer.cpp File Reference

#include "pch.h"
#include "GameTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameTimer.h File Reference

  • XAML DirectX 3D shooting game
Classes

GameTimer.h File Reference

Go to the source code of this file.

Classes

class GameTimer
THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A //// PARTICULAR PURPOSE. //// //// Copyright (c) Microsoft Corporation. All rights reserved. More...
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level.cpp File Reference

  • XAML DirectX 3D shooting game

Level.cpp File Reference

#include "pch.h"
#include "Level.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level.h File Reference

  • XAML DirectX 3D shooting game
Classes

Level.h File Reference

#include "GameObject.h"
#include "PersistentState.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level1.cpp File Reference

  • XAML DirectX 3D shooting game

Level1.cpp File Reference

#include "pch.h"
#include "Level1.h"
#include "Face.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level1.h File Reference

  • XAML DirectX 3D shooting game
Classes

Level1.h File Reference

#include "Level.h"

Go to the source code of this file.

Classes

class Level1
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level2.cpp File Reference

  • XAML DirectX 3D shooting game

Level2.cpp File Reference

#include "pch.h"
#include "Level2.h"
#include "Face.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level2.h File Reference

  • XAML DirectX 3D shooting game
Classes

Level2.h File Reference

#include "Level1.h"

Go to the source code of this file.

Classes

class Level2
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level3.cpp File Reference

  • XAML DirectX 3D shooting game

Level3.cpp File Reference

#include "pch.h"
#include "Level3.h"
#include "Face.h"
#include "Animate.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level3.h File Reference

  • XAML DirectX 3D shooting game
Classes

Level3.h File Reference

#include "Level.h"

Go to the source code of this file.

Classes

class Level3
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level4.cpp File Reference

  • XAML DirectX 3D shooting game

Level4.cpp File Reference

#include "pch.h"
#include "Level4.h"
#include "Face.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level4.h File Reference

  • XAML DirectX 3D shooting game
Classes

Level4.h File Reference

#include "Level3.h"

Go to the source code of this file.

Classes

class Level4
Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level5.cpp File Reference

  • XAML DirectX 3D shooting game

Level5.cpp File Reference

#include "pch.h"
#include "Level5.h"
#include "Cylinder.h"
#include "Animate.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level5.h File Reference

  • XAML DirectX 3D shooting game
Classes

Level5.h File Reference

#include "Level3.h"

Go to the source code of this file.

Classes

class Level5
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level6.cpp File Reference

  • XAML DirectX 3D shooting game

Level6.cpp File Reference

#include "pch.h"
#include "Level6.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level6.h File Reference

  • XAML DirectX 3D shooting game
Classes

Level6.h File Reference

#include "Level5.h"

Go to the source code of this file.

Classes

class Level6
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MainPage.xaml.cpp File Reference

  • XAML DirectX 3D shooting game

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "App.xaml.h"
#include "MainPage.xaml.h"
#include "ProductItem.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MainPage.xaml.h File Reference

  • XAML DirectX 3D shooting game
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "MainPage.g.h"
#include "ProductItem.h"

Go to the source code of this file.

Classes

class | Simple3DGameXaml::sealed

Namespaces

namespace | Simple3DGameXaml

Enumerations

enum | Simple3DGameXaml::GameInfoOverlayCommand { Simple3DGameXaml::None, Simple3DGameXaml::TapToContinue, Simple3DGameXaml::PleaseWait, Simple3DGameXaml::PlayAgain }
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Material.cpp File Reference

  • XAML DirectX 3D shooting game

Material.cpp File Reference

#include "pch.h"
#include "Material.h"
#include "GameConstants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Material.h File Reference

  • XAML DirectX 3D shooting game
Classes

Material.h File Reference

#include "ConstantBuffers.h"

Go to the source code of this file.

Classes

class Material
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MediaReader.cpp File Reference

  • XAML DirectX 3D shooting game

MediaReader.cpp File Reference

#include "pch.h"
#include "MediaReader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MediaReader.h File Reference

  • XAML DirectX 3D shooting game
Classes

MediaReader.h File Reference

Go to the source code of this file.

Classes

class MediaReader
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MeshObject.cpp File Reference

  • XAML DirectX 3D shooting game

MeshObject.cpp File Reference

#include "pch.h"
#include "MeshObject.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MeshObject.h File Reference

  • XAML DirectX 3D shooting game
Classes

MeshObject.h File Reference

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MoveLookController.cpp File Reference

  • XAML DirectX 3D shooting game
Defines

MoveLookController.cpp File Reference

#include "pch.h"
#include "MoveLookController.h"
#include "DirectXSample.h"

Go to the source code of this file.

Defines

#define | MOVEMENT_GAIN 2.f
#define | ROTATION_GAIN 0.008f

Define Documentation

#define MOVEMENT_GAIN 2.f

Definition at line 22 of file MoveLookController.cpp.

#define ROTATION_GAIN 0.008f

Definition at line 21 of file MoveLookController.cpp.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MoveLookController.h File Reference

  • XAML DirectX 3D shooting game
Classes | Enumerations

MoveLookController.h File Reference

Go to the source code of this file.

Classes

class MoveLookController

Enumerations

enum MoveLookControllerState {
None, WaitForInput, Active, None,
WaitForInput, Active
}

Enumeration Type Documentation

enum MoveLookControllerState
Enumerator:
None
WaitForInput
Active
None
WaitForInput
Active

Definition at line 77 of file MoveLookController.h.

{
    None,
    WaitForInput,
    Active,
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/pch.cpp File Reference

  • XAML DirectX 3D shooting game

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/pch.h File Reference

  • XAML DirectX 3D shooting game

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <DirectXMath.h>
#include <xaudio2.h>
#include <xaudio2fx.h>
#include <mmreg.h>
#include <mfidl.h>
#include <mfapi.h>
#include <mfreadwrite.h>
#include <XInput.h>
#include <stdio.h>
#include <vector>
#include <memory>
#include <ppltasks.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/PersistentState.cpp File Reference

  • XAML DirectX 3D shooting game

PersistentState.cpp File Reference

#include "pch.h"
#include "PersistentState.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/PersistentState.h File Reference

  • XAML DirectX 3D shooting game
Classes

PersistentState.h File Reference

Go to the source code of this file.

Classes

class PersistentState
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/ProductItem.cpp File Reference

  • XAML DirectX 3D shooting game

ProductItem.cpp File Reference

#include "pch.h"
#include "ProductItem.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/ProductItem.h File Reference

  • XAML DirectX 3D shooting game
Classes | Namespaces

ProductItem.h File Reference

Go to the source code of this file.

Classes

class | Simple3DGameXaml::sealed

Namespaces

namespace | Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Simple3DGame.cpp File Reference

  • XAML DirectX 3D shooting game

Simple3DGame.cpp File Reference

#include "pch.h"
#include "GameRenderer.h"
#include "DirectXSample.h"
#include "Level1.h"
#include "Level2.h"
#include "Level3.h"
#include "Level4.h"
#include "Level5.h"
#include "Level6.h"
#include "Animate.h"
#include "Sphere.h"
#include "Cylinder.h"
#include "Face.h"
#include "MediaReader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Simple3DGame.h File Reference

  • XAML DirectX 3D shooting game
Classes | Typedefs | Enumerations

Simple3DGame.h File Reference

#include "GameConstants.h"
#include "Audio.h"
#include "Camera.h"
#include "Level.h"
#include "GameObject.h"
#include "GameTimer.h"
#include "MoveLookController.h"
#include "PersistentState.h"
#include "Sphere.h"
#include "GameRenderer.h"

Go to the source code of this file.

Classes

struct | GameConfig
struct | HighScoreEntry
class | Simple3DGame

Typedefs

typedef std::vector
< HighScoreEntry > 		HighScoreEntries

Enumerations

enum GameState {
Waiting, Active, LevelComplete, TimeExpired,
GameComplete, Initial, MainMenu, HighScoreDisplay,
PreGameCountdown, InGameActive, InGamePaused, PostGameResults,
Waiting, Active, LevelComplete, TimeExpired,
GameComplete
}

Typedef Documentation

typedef std::vector<HighScoreEntry> HighScoreEntries

Definition at line 58 of file Simple3DGame.h.

Enumeration Type Documentation

enum GameState
Enumerator:
Waiting
Active
LevelComplete
TimeExpired
GameComplete
Initial
MainMenu
HighScoreDisplay
PreGameCountdown
InGameActive
InGamePaused
PostGameResults
Waiting
Active
LevelComplete
TimeExpired
GameComplete

Definition at line 41 of file Simple3DGame.h.

{
    Waiting,
    Active,
    LevelComplete,
    TimeExpired,
    GameComplete,
};

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/SoundEffect.cpp File Reference

  • XAML DirectX 3D shooting game

SoundEffect.cpp File Reference

#include "pch.h"
#include "SoundEffect.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/SoundEffect.h File Reference

  • XAML DirectX 3D shooting game
Classes

SoundEffect.h File Reference

Go to the source code of this file.

Classes

class SoundEffect
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Sphere.cpp File Reference

  • XAML DirectX 3D shooting game

Sphere.cpp File Reference

#include "pch.h"
#include "Sphere.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Sphere.h File Reference

  • XAML DirectX 3D shooting game
Classes

Sphere.h File Reference

#include "GameObject.h"

Go to the source code of this file.

Classes

class Sphere
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/SphereMesh.cpp File Reference

  • XAML DirectX 3D shooting game

SphereMesh.cpp File Reference

#include "pch.h"
#include "SphereMesh.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/SphereMesh.h File Reference

  • XAML DirectX 3D shooting game
Classes

SphereMesh.h File Reference

#include "MeshObject.h"

Go to the source code of this file.

Classes

class SphereMesh
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/StereoProjection.cpp File Reference

  • XAML DirectX 3D shooting game
Defines | Functions

StereoProjection.cpp File Reference

#include "pch.h"
#include "StereoProjection.h"

Go to the source code of this file.

Defines

#define | XMASSERT(Expression) ((void)0)

Functions

__forceinline bool | _XMMatrixStereoProjectionHelper (const STEREO_PARAMETERS *stereoParameters, _Out_ float *virtualProjection, _Out_ float *zNearWidth, _Out_ float *zNearHeight, float fovAngleY, float aspectHByW, float nearZ)
XMMATRIX | MatrixStereoProjectionFovLH (_In_opt_ const STEREO_PARAMETERS *stereoParameters, STEREO_CHANNEL channel, float fovAngleY, float aspectHByW, float nearZ, float farZ, STEREO_MODE stereoMode)
void | StereoCreateDefaultParameters (_Out_ STEREO_PARAMETERS *stereoParameters)

Define Documentation

#define XMASSERT ( Expression ) ((void)0)

Definition at line 12 of file StereoProjection.cpp.

Function Documentation

__forceinline bool _XMMatrixStereoProjectionHelper | ( | const STEREO_PARAMETERS * | stereoParameters,
 |  | _Out_ float * | virtualProjection,
 |  | _Out_ float * | zNearWidth,
 |  | _Out_ float * | zNearHeight,
 |  | float | fovAngleY,
 |  | float | aspectHByW,
 |  | float | nearZ
 | ) |  |

Definition at line 31 of file StereoProjection.cpp.

{
    // note that most people have difficulty fusing images into 3D
    // if the separation equals even just the human average. by
    // reducing the separation (interocular distance) by 1/2, we
    // guarantee a larger subset of people will see full 3D

    // the conservative setting should always be used. the only problem
    // with the conservative setting is that the 3D effect will be less
    // impressive on smaller screens (which makes sense, since your eye
    // cannot be tricked as easily based on the smaller fov). to simulate
    // the effect of a larger screen, use the liberal settings (debug only)

    // Conservative Settings: * max acuity angle: 0.8f degrees * interoc distance: 1.25 inches

    // Liberal Settings: * max acuity angle: 1.6f degrees * interoc distance: 2.5f inches

    // maximum visual accuity angle allowed is 3.2 degrees for
    // a physical scene, and 1.6 degrees for a virtual one.
    // thus we cannot allow an object to appear any closer to
    // the viewer than 1.6 degrees (divided by two for most
    // half-angle calculations)

    static const float maxStereoDistance = 85; // 780 inches (should be between 10 and 20m)
    static const float maxVisualAcuityAngle = 0.8f * (XM_PI / 180.0f);  // radians
    static const float interocularDistance = 1.25f; // inches

    bool comfortableResult = true;

    float displayHeight = stereoParameters->displaySizeInches / sqrtf(aspectHByW * aspectHByW + 1.0f);
    float displayWidth = displayHeight * aspectHByW;
    float halfInterocular = 0.5f * interocularDistance * stereoParameters->stereoExaggerationFactor;
    float halfPixelWidth  = displayWidth / stereoParameters->pixelResolutionWidth * 0.5f;
    float halfMaximumAcuityAngle = maxVisualAcuityAngle * 0.5f * stereoParameters->stereoExaggerationFactor;

    float maxSeparationAcuityAngle = atanf(halfInterocular / maxStereoDistance);
    float maxSeparationDistance = halfPixelWidth / tanf(maxSeparationAcuityAngle);
    float refinedMaxStereoDistance = maxStereoDistance - maxSeparationDistance;
    float fovHalfAngle = fovAngleY / 2.0f;

    if (refinedMaxStereoDistance < 0.0f || maxSeparationDistance > 0.1f * maxStereoDistance)
    {
        // Pixel resolution is too low to offer a comfortable stereo experience
        comfortableResult = false;
    }

    float refinedMaxSeparationAcuityAngle = atanf(halfInterocular / refinedMaxStereoDistance);
    float physicalZNearDistance = halfInterocular / tanf(halfMaximumAcuityAngle);

    float nearZSeparation = tanf(refinedMaxSeparationAcuityAngle) * (refinedMaxStereoDistance - physicalZNearDistance);

    *zNearHeight = cosf(fovHalfAngle) / sinf(fovHalfAngle);
    *zNearWidth = *zNearHeight / aspectHByW;
    *virtualProjection = (nearZSeparation * nearZ * (*zNearWidth * 4.0f)) / (2.0f * nearZ);

    return comfortableResult;
}

XMMATRIX MatrixStereoProjectionFovLH | ( | _In_opt_ const STEREO_PARAMETERS * | stereoParameters,
 |  | STEREO_CHANNEL | channel,
 |  | float | fovAngleY,
 |  | float | aspectHByW,
 |  | float | nearZ,
 |  | float | farZ,
 |  | STEREO_MODE | stereoMode
 | ) |  |

Definition at line 98 of file StereoProjection.cpp.

{
    float virtualProjection = 0.0f;
    float zNearWidth = 0.0f;
    float zNearHeight = 0.0f;
    float invertedAngle;
    XMMATRIX patchedProjection;
    XMMATRIX proj;
    STEREO_PARAMETERS defaultParameters;

    XMASSERT(channel == STEREO_CHANNEL::LEFT || channel == STEREO_CHANNEL::RIGHT);
    XMASSERT(stereoMode == STEREO_MODE::NORMAL || stereoMode == STEREO_MODE::INVERTED);
    XMASSERT(!XMScalarNearEqual(fovAngleY, 0.0f, 0.00001f * 2.0f));
    XMASSERT(!XMScalarNearEqual(aspectHByW, 0.0f, 0.00001f));
    XMASSERT(!XMScalarNearEqual(farZ, nearZ, 0.00001f));

    proj = XMMatrixIdentity();

    if (stereoParameters == nullptr)
    {
        StereoCreateDefaultParameters(&defaultParameters);
        stereoParameters = &defaultParameters;
    }

    XMASSERT(pStereoParameters->stereoSeparationFactor >= 0.0f && stereoParameters->stereoSeparationFactor <= 1.0f);
    XMASSERT(pStereoParameters->stereoExaggerationFactor >= 1.0f && stereoParameters->stereoExaggerationFactor <= 2.0f);

    _XMMatrixStereoProjectionHelper(stereoParameters, &virtualProjection, &zNearWidth, &zNearHeight, fovAngleY, aspectHByW, nearZ);

    virtualProjection *= stereoParameters->stereoSeparationFactor; // incorporate developer defined bias

    //
    // By applying a translation, we are forcing our cameras to be parallel
    //

    invertedAngle = atanf(virtualProjection / (2.0f * nearZ));

    proj = XMMatrixPerspectiveFovLH(fovAngleY, aspectHByW, nearZ, farZ);

    if (channel == STEREO_CHANNEL::LEFT)
    {
        if (stereoMode > STEREO_MODE::NORMAL)
        {
            XMMATRIX rots, trans;
            rots = XMMatrixRotationY(invertedAngle);
            trans = XMMatrixTranslation(-virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
        }
        else
        {
            XMMATRIX trans;
            trans = XMMatrixTranslation(-virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(trans, proj);
        }
    }
    else
    {
        if (stereoMode > STEREO_MODE::NORMAL)
        {
            XMMATRIX rots, trans;
            rots = XMMatrixRotationY(-invertedAngle);
            trans = XMMatrixTranslation(virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
        }
        else
        {
            XMMATRIX trans;
            trans = XMMatrixTranslation(virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(trans, proj);
        }
    }

    return patchedProjection;
}

void StereoCreateDefaultParameters ( _Out_ STEREO_PARAMETERS * stereoParameters )

Definition at line 17 of file StereoProjection.cpp.

{
    XMASSERT(stereoParameters != nullptr);

    // Default assumption is 1920x1200 resolution, a 22" LCD monitor, and a 2' viewing distance
    stereoParameters->viewerDistanceInches = 24.0f;
    stereoParameters->pixelResolutionWidth = 1920.0f;
    stereoParameters->pixelResolutionHeight = 1024.0f; // 480.0f; // 1200
    stereoParameters->displaySizeInches = 22.0f;

    stereoParameters->stereoSeparationFactor = 1.0f;
    stereoParameters->stereoExaggerationFactor = 1.0f;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/StereoProjection.h File Reference

  • XAML DirectX 3D shooting game
Classes | Typedefs | Enumerations | Functions

StereoProjection.h File Reference

Go to the source code of this file.

Classes

struct | STEREO_PARAMETERS

Typedefs

typedef enum STEREO_CHANNEL | STEREO_CHANNEL
typedef enum STEREO_MODE | STEREO_MODE
typedef struct STEREO_PARAMETERS | STEREO_PARAMETERS

Enumerations

enum | STEREO_CHANNEL { LEFT = 0, RIGHT, LEFT = 0, RIGHT }
enum | STEREO_MODE { NORMAL = 0, INVERTED, NORMAL = 0, INVERTED }

Functions

DirectX::XMMATRIX | MatrixStereoProjectionFovLH (_In_opt_ const STEREO_PARAMETERS *stereoParameters, STEREO_CHANNEL channel, float fovAngleY, float aspectHByW, float nearZ, float farZ, STEREO_MODE stereoMode)
void | StereoCreateDefaultParameters (_Out_ STEREO_PARAMETERS *pStereoParameters)

Typedef Documentation

typedef enum STEREO_CHANNEL STEREO_CHANNEL
typedef enum STEREO_MODE STEREO_MODE
typedef struct STEREO_PARAMETERS STEREO_PARAMETERS

Enumeration Type Documentation

enum STEREO_CHANNEL
Enumerator:
LEFT
RIGHT
LEFT
RIGHT

Definition at line 21 of file StereoProjection.h.

{
    LEFT = 0,
    RIGHT
} STEREO_CHANNEL;

enum STEREO_MODE
Enumerator:
NORMAL
INVERTED
NORMAL
INVERTED

Definition at line 28 of file StereoProjection.h.

{
    NORMAL = 0,
    INVERTED,
} STEREO_MODE;

Function Documentation

DirectX::XMMATRIX MatrixStereoProjectionFovLH | ( | _In_opt_ const STEREO_PARAMETERS * | stereoParameters,
 |  | STEREO_CHANNEL | channel,
 |  | float | fovAngleY,
 |  | float | aspectHByW,
 |  | float | nearZ,
 |  | float | farZ,
 |  | STEREO_MODE | stereoMode
 | ) |  |

Definition at line 98 of file StereoProjection.cpp.

{
    float virtualProjection = 0.0f;
    float zNearWidth = 0.0f;
    float zNearHeight = 0.0f;
    float invertedAngle;
    XMMATRIX patchedProjection;
    XMMATRIX proj;
    STEREO_PARAMETERS defaultParameters;

    XMASSERT(channel == STEREO_CHANNEL::LEFT || channel == STEREO_CHANNEL::RIGHT);
    XMASSERT(stereoMode == STEREO_MODE::NORMAL || stereoMode == STEREO_MODE::INVERTED);
    XMASSERT(!XMScalarNearEqual(fovAngleY, 0.0f, 0.00001f * 2.0f));
    XMASSERT(!XMScalarNearEqual(aspectHByW, 0.0f, 0.00001f));
    XMASSERT(!XMScalarNearEqual(farZ, nearZ, 0.00001f));

    proj = XMMatrixIdentity();

    if (stereoParameters == nullptr)
    {
        StereoCreateDefaultParameters(&defaultParameters);
        stereoParameters = &defaultParameters;
    }

    XMASSERT(pStereoParameters->stereoSeparationFactor >= 0.0f && stereoParameters->stereoSeparationFactor <= 1.0f);
    XMASSERT(pStereoParameters->stereoExaggerationFactor >= 1.0f && stereoParameters->stereoExaggerationFactor <= 2.0f);

    _XMMatrixStereoProjectionHelper(stereoParameters, &virtualProjection, &zNearWidth, &zNearHeight, fovAngleY, aspectHByW, nearZ);

    virtualProjection *= stereoParameters->stereoSeparationFactor; // incorporate developer defined bias

    //
    // By applying a translation, we are forcing our cameras to be parallel
    //

    invertedAngle = atanf(virtualProjection / (2.0f * nearZ));

    proj = XMMatrixPerspectiveFovLH(fovAngleY, aspectHByW, nearZ, farZ);

    if (channel == STEREO_CHANNEL::LEFT)
    {
        if (stereoMode > STEREO_MODE::NORMAL)
        {
            XMMATRIX rots, trans;
            rots = XMMatrixRotationY(invertedAngle);
            trans = XMMatrixTranslation(-virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
        }
        else
        {
            XMMATRIX trans;
            trans = XMMatrixTranslation(-virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(trans, proj);
        }
    }
    else
    {
        if (stereoMode > STEREO_MODE::NORMAL)
        {
            XMMATRIX rots, trans;
            rots = XMMatrixRotationY(-invertedAngle);
            trans = XMMatrixTranslation(virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
        }
        else
        {
            XMMATRIX trans;
            trans = XMMatrixTranslation(virtualProjection, 0, 0);
            patchedProjection = XMMatrixMultiply(trans, proj);
        }
    }

    return patchedProjection;
}

void StereoCreateDefaultParameters ( _Out_ STEREO_PARAMETERS * pStereoParameters )

Definition at line 17 of file StereoProjection.cpp.

{
    XMASSERT(stereoParameters != nullptr);

    // Default assumption is 1920x1200 resolution, a 22" LCD monitor, and a 2' viewing distance
    stereoParameters->viewerDistanceInches = 24.0f;
    stereoParameters->pixelResolutionWidth = 1920.0f;
    stereoParameters->pixelResolutionHeight = 1024.0f; // 480.0f; // 1200
    stereoParameters->displaySizeInches = 22.0f;

    stereoParameters->stereoSeparationFactor = 1.0f;
    stereoParameters->stereoExaggerationFactor = 1.0f;
}

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/TargetTexture.cpp File Reference

  • XAML DirectX 3D shooting game

TargetTexture.cpp File Reference

#include "pch.h"
#include "TargetTexture.h"
#include "DirectXSample.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/TargetTexture.h File Reference

  • XAML DirectX 3D shooting game
Classes

TargetTexture.h File Reference

Go to the source code of this file.

Classes

class TargetTexture
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/WorldMesh.cpp File Reference

  • XAML DirectX 3D shooting game

WorldMesh.cpp File Reference

#include "pch.h"
#include "WorldMesh.h"
#include "DirectXSample.h"
#include "ConstantBuffers.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/WorldMesh.h File Reference

  • XAML DirectX 3D shooting game
Classes

WorldMesh.h File Reference

#include "MeshObject.h"

Go to the source code of this file.

Classes

class | WorldCeilingMesh
class | WorldFloorMesh
class | WorldWallsMesh
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/App.xaml.cpp File Reference

  • XAML FlipView control

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/App.xaml.h File Reference

  • XAML FlipView control
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Constants.cpp File Reference

  • XAML FlipView control

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Constants.h File Reference

  • XAML FlipView control
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/MainPage.xaml.cpp File Reference

  • XAML FlipView control

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/MainPage.xaml.h File Reference

  • XAML FlipView control
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/pch.cpp File Reference

  • XAML FlipView control

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/pch.h File Reference

  • XAML FlipView control

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/SampleDataSource.cpp File Reference

  • XAML FlipView control

SampleDataSource.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/SampleDataSource.h File Reference

  • XAML FlipView control
Classes | Namespaces

SampleDataSource.h File Reference

Go to the source code of this file.

Classes

class | SDKSample::FlipViewData::sealed
Creates a collection of groups and items with hard-coded content. More...
class | SDKSample::FlipViewData::sealed
Creates a collection of groups and items with hard-coded content. More...
class | SDKSample::FlipViewData::sealed
Creates a collection of groups and items with hard-coded content. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FlipViewData
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario1.xaml.cpp File Reference

  • XAML FlipView control

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario1.xaml.h File Reference

  • XAML FlipView control
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FlipViewCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FlipViewCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario2.xaml.cpp File Reference

  • XAML FlipView control

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario2.xaml.h File Reference

  • XAML FlipView control
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FlipViewCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FlipViewCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario3.xaml.cpp File Reference

  • XAML FlipView control

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario3.xaml.h File Reference

  • XAML FlipView control
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Classes

class | SDKSample::FlipViewCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::FlipViewCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FlipViewCPP
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario4.xaml.cpp File Reference

  • XAML FlipView control

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario4.xaml.h File Reference

  • XAML FlipView control
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FlipViewCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FlipViewCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario5.xaml.cpp File Reference

  • XAML FlipView control

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario5.xaml.h File Reference

  • XAML FlipView control
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::FlipViewCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::FlipViewCPP
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/common/LayoutAwarePage.cpp File Reference

  • XAML FlipView control
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/common/LayoutAwarePage.h File Reference

  • XAML FlipView control
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/common/suspensionmanager.cpp File Reference

  • XAML FlipView control
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/common/suspensionmanager.h File Reference

  • XAML FlipView control
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/App.xaml.cpp File Reference

  • XAML high contrast style

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/App.xaml.h File Reference

  • XAML high contrast style
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Constants.cpp File Reference

  • XAML high contrast style

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Constants.h File Reference

  • XAML high contrast style
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/MainPage.xaml.cpp File Reference

  • XAML high contrast style

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/MainPage.xaml.h File Reference

  • XAML high contrast style
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/pch.cpp File Reference

  • XAML high contrast style

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/pch.h File Reference

  • XAML high contrast style

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Scenario1.xaml.cpp File Reference

  • XAML high contrast style

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Scenario1.xaml.h File Reference

  • XAML high contrast style
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HighContrast::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HighContrast
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Scenario2.xaml.cpp File Reference

  • XAML high contrast style

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Scenario2.xaml.h File Reference

  • XAML high contrast style
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HighContrast::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HighContrast
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Scenario3.xaml.cpp File Reference

  • XAML high contrast style

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Scenario3.xaml.h File Reference

  • XAML high contrast style
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::HighContrast::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HighContrast
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/TargetButton.xaml.cpp File Reference

  • XAML high contrast style

TargetButton.xaml.cpp File Reference

#include "pch.h"
#include "TargetButton.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/TargetButton.xaml.h File Reference

  • XAML high contrast style
Classes | Namespaces

TargetButton.xaml.h File Reference

#include "TargetButton.g.h"

Go to the source code of this file.

Classes

class | SDKSample::HighContrast::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::HighContrast
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/LayoutAwarePage.cpp File Reference

  • XAML high contrast style
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/LayoutAwarePage.h File Reference

  • XAML high contrast style
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/suspensionmanager.cpp File Reference

  • XAML high contrast style
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/suspensionmanager.h File Reference

  • XAML high contrast style
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/App.xaml.cpp File Reference

  • XAML images

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/App.xaml.h File Reference

  • XAML images
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Constants.cpp File Reference

  • XAML images

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Constants.h File Reference

  • XAML images
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/MainPage.xaml.cpp File Reference

  • XAML images

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/MainPage.xaml.h File Reference

  • XAML images
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/pch.cpp File Reference

  • XAML images

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/pch.h File Reference

  • XAML images

pch.h File Reference

#include <string>
#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario1.xaml.cpp File Reference

  • XAML images

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario1.xaml.h File Reference

  • XAML images
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Images::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Images
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario2.xaml.cpp File Reference

  • XAML images

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"
#include <ppltasks.h>
#include <stdio.h>
#include <stdlib.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario2.xaml.h File Reference

  • XAML images
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Images::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Images
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario3.xaml.cpp File Reference

  • XAML images

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario3.xaml.h File Reference

  • XAML images
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Images::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Images
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/common/LayoutAwarePage.cpp File Reference

  • XAML images
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/common/LayoutAwarePage.h File Reference

  • XAML images
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/common/suspensionmanager.cpp File Reference

  • XAML images
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/common/suspensionmanager.h File Reference

  • XAML images
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/App.xaml.cpp File Reference

  • XAML ListView and GridView essentials

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/App.xaml.h File Reference

  • XAML ListView and GridView essentials
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Constants.cpp File Reference

  • XAML ListView and GridView essentials

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Constants.h File Reference

  • XAML ListView and GridView essentials
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/MainPage.xaml.cpp File Reference

  • XAML ListView and GridView essentials

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/MainPage.xaml.h File Reference

  • XAML ListView and GridView essentials
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/pch.cpp File Reference

  • XAML ListView and GridView essentials

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/pch.h File Reference

  • XAML ListView and GridView essentials

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/SampleDataSource.cpp File Reference

  • XAML ListView and GridView essentials

SampleDataSource.cpp File Reference

#include "pch.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/SampleDataSource.h File Reference

  • XAML ListView and GridView essentials
Classes | Namespaces

SampleDataSource.h File Reference

Go to the source code of this file.

Classes

class | SDKSample::ListViewSampleDataSource::sealed
class | SDKSample::ListViewSampleDataSource::sealed

Namespaces

namespace | SDKSample
namespace | SDKSample::ListViewSampleDataSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario1.xaml.cpp File Reference

  • XAML ListView and GridView essentials

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario1.xaml.h File Reference

  • XAML ListView and GridView essentials
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Classes

class | SDKSample::ListViewSimple::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ListViewSimple
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario2.xaml.cpp File Reference

  • XAML ListView and GridView essentials

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario2.xaml.h File Reference

  • XAML ListView and GridView essentials
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Classes

class | SDKSample::ListViewSimple::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ListViewSimple
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario3.xaml.cpp File Reference

  • XAML ListView and GridView essentials

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario3.xaml.h File Reference

  • XAML ListView and GridView essentials
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Classes

class | SDKSample::ListViewSimple::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ListViewSimple
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/App.xaml.cpp File Reference

  • XAML personality animations

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/App.xaml.h File Reference

  • XAML personality animations
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Constants.cpp File Reference

  • XAML personality animations

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Constants.h File Reference

  • XAML personality animations
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/MainPage.xaml.cpp File Reference

  • XAML personality animations

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/MainPage.xaml.h File Reference

  • XAML personality animations
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Page1.xaml.cpp File Reference

  • XAML personality animations

Page1.xaml.cpp File Reference

#include "pch.h"
#include "Page1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Page1.xaml.h File Reference

  • XAML personality animations
Classes | Namespaces

Page1.xaml.h File Reference

#include "Page1.g.h"
#include "SampleData/SampleDataSource.h"

Go to the source code of this file.

Classes

class | SDKSample::PersonalityAnimations::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PersonalityAnimations
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Page2.xaml.cpp File Reference

  • XAML personality animations

Page2.xaml.cpp File Reference

#include "pch.h"
#include "Page2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Page2.xaml.h File Reference

  • XAML personality animations
Classes | Namespaces

Page2.xaml.h File Reference

#include "Page2.g.h"
#include "SampleData/SampleDataSource.h"

Go to the source code of this file.

Classes

class | SDKSample::PersonalityAnimations::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PersonalityAnimations
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/pch.cpp File Reference

  • XAML personality animations

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/pch.h File Reference

  • XAML personality animations

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario1.xaml.cpp File Reference

  • XAML personality animations

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario1.xaml.h File Reference

  • XAML personality animations
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PersonalityAnimations::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PersonalityAnimations
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario2.xaml.cpp File Reference

  • XAML personality animations

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario2.xaml.h File Reference

  • XAML personality animations
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"
#include "SampleData/SampleDataSource.h"

Go to the source code of this file.

Classes

class | SDKSample::PersonalityAnimations::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PersonalityAnimations
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario3.xaml.cpp File Reference

  • XAML personality animations

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"
#include "Page1.xaml.h"
#include "Page2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario3.xaml.h File Reference

  • XAML personality animations
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::PersonalityAnimations::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::PersonalityAnimations
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/common/LayoutAwarePage.cpp File Reference

  • XAML personality animations
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/common/LayoutAwarePage.h File Reference

  • XAML personality animations
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/common/suspensionmanager.cpp File Reference

  • XAML personality animations
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/common/suspensionmanager.h File Reference

  • XAML personality animations
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/SampleData/SampleDataSource.cpp File Reference

  • XAML personality animations
  • SampleData

SampleDataSource.cpp File Reference

#include "pch.h"
#include "SampleDataSource.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/SampleData/SampleDataSource.h File Reference

  • XAML personality animations
  • SampleData
Classes | Namespaces

SampleDataSource.h File Reference

#include <string>
#include <sstream>
#include <algorithm>
#include <collection.h>
#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
An empty page that can be used on its own or navigated to within a Frame. More...
class | SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ExpressionBlendSampleDataSampleDataSource
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/App.xaml.cpp File Reference

  • XAML Popup

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/App.xaml.h File Reference

  • XAML Popup
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Constants.cpp File Reference

  • XAML Popup

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Constants.h File Reference

  • XAML Popup
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/MainPage.xaml.cpp File Reference

  • XAML Popup

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/MainPage.xaml.h File Reference

  • XAML Popup
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/pch.cpp File Reference

  • XAML Popup

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/pch.h File Reference

  • XAML Popup

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/PopupInputContent.xaml.cpp File Reference

  • XAML Popup

PopupInputContent.xaml.cpp File Reference

#include "pch.h"
#include "PopupInputContent.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/PopupInputContent.xaml.h File Reference

  • XAML Popup
Classes | Namespaces

PopupInputContent.xaml.h File Reference

#include "PopupInputContent.g.h"

Go to the source code of this file.

Classes

class | SDKSample::XAMLPopup::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::XAMLPopup
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Scenario1.xaml.cpp File Reference

  • XAML Popup

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Scenario1.xaml.h File Reference

  • XAML Popup
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::XAMLPopup::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::XAMLPopup
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Scenario2.xaml.cpp File Reference

  • XAML Popup

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Scenario2.xaml.h File Reference

  • XAML Popup
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"
#include "PopupInputContent.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::XAMLPopup::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::XAMLPopup
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Scenario3.xaml.cpp File Reference

  • XAML Popup

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Scenario3.xaml.h File Reference

  • XAML Popup
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::XAMLPopup::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::XAMLPopup
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/common/LayoutAwarePage.cpp File Reference

  • XAML Popup
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/common/LayoutAwarePage.h File Reference

  • XAML Popup
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/common/suspensionmanager.cpp File Reference

  • XAML Popup
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/common/suspensionmanager.h File Reference

  • XAML Popup
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/App.xaml.cpp File Reference

  • XAML scrolling, panning, and zooming

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/App.xaml.h File Reference

  • XAML scrolling, panning, and zooming
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Constants.cpp File Reference

  • XAML scrolling, panning, and zooming

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Constants.h File Reference

  • XAML scrolling, panning, and zooming
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/MainPage.xaml.cpp File Reference

  • XAML scrolling, panning, and zooming

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/MainPage.xaml.h File Reference

  • XAML scrolling, panning, and zooming
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/pch.cpp File Reference

  • XAML scrolling, panning, and zooming

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/pch.h File Reference

  • XAML scrolling, panning, and zooming

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario1.xaml.cpp File Reference

  • XAML scrolling, panning, and zooming

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario1.xaml.h File Reference

  • XAML scrolling, panning, and zooming
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ScrollViewerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ScrollViewerCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario2.xaml.cpp File Reference

  • XAML scrolling, panning, and zooming

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario2.xaml.h File Reference

  • XAML scrolling, panning, and zooming
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ScrollViewerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ScrollViewerCPP
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario3.xaml.cpp File Reference

  • XAML scrolling, panning, and zooming

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario3.xaml.h File Reference

  • XAML scrolling, panning, and zooming
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::ScrollViewerCPP::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::ScrollViewerCPP
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/App.xaml.cpp File Reference

  • XAML text display

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/App.xaml.h File Reference

  • XAML text display
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Constants.cpp File Reference

  • XAML text display

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Constants.h File Reference

  • XAML text display
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/MainPage.xaml.cpp File Reference

  • XAML text display

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/MainPage.xaml.h File Reference

  • XAML text display
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/pch.cpp File Reference

  • XAML text display

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/pch.h File Reference

  • XAML text display

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario1.xaml.cpp File Reference

  • XAML text display

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario1.xaml.h File Reference

  • XAML text display
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextDisplay::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextDisplay
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario2.xaml.cpp File Reference

  • XAML text display

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario2.xaml.h File Reference

  • XAML text display
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextDisplay::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextDisplay
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario3.xaml.cpp File Reference

  • XAML text display

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario3.xaml.h File Reference

  • XAML text display
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextDisplay::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextDisplay
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario4.xaml.cpp File Reference

  • XAML text display

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario4.xaml.h File Reference

  • XAML text display
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextDisplay::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextDisplay
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Common/LayoutAwarePage.cpp File Reference

  • XAML text display
  • Common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Common/LayoutAwarePage.h File Reference

  • XAML text display
  • Common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Common/suspensionmanager.cpp File Reference

  • XAML text display
  • Common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Common/suspensionmanager.h File Reference

  • XAML text display
  • Common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/App.xaml.cpp File Reference

  • XAML text editing

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/App.xaml.h File Reference

  • XAML text editing
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Constants.cpp File Reference

  • XAML text editing

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Constants.h File Reference

  • XAML text editing
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/MainPage.xaml.cpp File Reference

  • XAML text editing

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/MainPage.xaml.h File Reference

  • XAML text editing
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/pch.cpp File Reference

  • XAML text editing

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/pch.h File Reference

  • XAML text editing

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario1.xaml.cpp File Reference

  • XAML text editing

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario1.xaml.h File Reference

  • XAML text editing
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextEditing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextEditing
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario2.xaml.cpp File Reference

  • XAML text editing

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario2.xaml.h File Reference

  • XAML text editing
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextEditing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextEditing
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario3.xaml.cpp File Reference

  • XAML text editing

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario3.xaml.h File Reference

  • XAML text editing
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextEditing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextEditing
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario4.xaml.cpp File Reference

  • XAML text editing

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario4.xaml.h File Reference

  • XAML text editing
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextEditing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextEditing
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario5.xaml.cpp File Reference

  • XAML text editing

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario5.xaml.h File Reference

  • XAML text editing
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextEditing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextEditing
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario6.xaml.cpp File Reference

  • XAML text editing

Scenario6.xaml.cpp File Reference

#include "pch.h"
#include "Scenario6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario6.xaml.h File Reference

  • XAML text editing
Classes | Namespaces

Scenario6.xaml.h File Reference

#include "pch.h"
#include "Scenario6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextEditing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextEditing
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario7.xaml.cpp File Reference

  • XAML text editing

Scenario7.xaml.cpp File Reference

#include "pch.h"
#include "Scenario7.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario7.xaml.h File Reference

  • XAML text editing
Classes | Namespaces

Scenario7.xaml.h File Reference

#include "pch.h"
#include "Scenario7.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::TextEditing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::TextEditing
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Common/LayoutAwarePage.cpp File Reference

  • XAML text editing
  • Common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Common/LayoutAwarePage.h File Reference

  • XAML text editing
  • Common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Common/suspensionmanager.cpp File Reference

  • XAML text editing
  • Common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Common/suspensionmanager.h File Reference

  • XAML text editing
  • Common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/App.xaml.cpp File Reference

  • XAML two-dimensional transforms

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/App.xaml.h File Reference

  • XAML two-dimensional transforms
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/Constants.cpp File Reference

  • XAML two-dimensional transforms

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/Constants.h File Reference

  • XAML two-dimensional transforms
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/MainPage.xaml.cpp File Reference

  • XAML two-dimensional transforms

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/MainPage.xaml.h File Reference

  • XAML two-dimensional transforms
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/pch.cpp File Reference

  • XAML two-dimensional transforms

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/pch.h File Reference

  • XAML two-dimensional transforms

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/Scenario1.xaml.cpp File Reference

  • XAML two-dimensional transforms

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/Scenario1.xaml.h File Reference

  • XAML two-dimensional transforms
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Transforms::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Transforms
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/Scenario2.xaml.cpp File Reference

  • XAML two-dimensional transforms

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/Scenario2.xaml.h File Reference

  • XAML two-dimensional transforms
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Transforms::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Transforms
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/common/LayoutAwarePage.cpp File Reference

  • XAML two-dimensional transforms
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/common/LayoutAwarePage.h File Reference

  • XAML two-dimensional transforms
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/common/suspensionmanager.cpp File Reference

  • XAML two-dimensional transforms
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/common/suspensionmanager.h File Reference

  • XAML two-dimensional transforms
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/App.xaml.cpp File Reference

  • XAML user and custom controls

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/App.xaml.h File Reference

  • XAML user and custom controls
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/BasicCustomControl.cpp File Reference

  • XAML user and custom controls

BasicCustomControl.cpp File Reference

#include "pch.h"
#include "BasicCustomControl.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/BasicCustomControl.h File Reference

  • XAML user and custom controls
Classes | Namespaces

BasicCustomControl.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | SDKSample::UserAndCustomControls::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserAndCustomControls
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/BasicUserControl.xaml.cpp File Reference

  • XAML user and custom controls

BasicUserControl.xaml.cpp File Reference

#include "pch.h"
#include "BasicUserControl.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/BasicUserControl.xaml.h File Reference

  • XAML user and custom controls
Classes | Namespaces

BasicUserControl.xaml.h File Reference

#include "pch.h"
#include "BasicUserControl.g.h"

Go to the source code of this file.

Classes

class | SDKSample::UserAndCustomControls::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserAndCustomControls
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Constants.cpp File Reference

  • XAML user and custom controls

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Constants.h File Reference

  • XAML user and custom controls
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/ImageWithLabelControl.cpp File Reference

  • XAML user and custom controls

ImageWithLabelControl.cpp File Reference

#include "pch.h"
#include "ImageWithLabelControl.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/ImageWithLabelControl.h File Reference

  • XAML user and custom controls
Classes | Namespaces

ImageWithLabelControl.h File Reference

#include "pch.h"

Go to the source code of this file.

Classes

class | SDKSample::UserAndCustomControls::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserAndCustomControls
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/MainPage.xaml.cpp File Reference

  • XAML user and custom controls

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/MainPage.xaml.h File Reference

  • XAML user and custom controls
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/pch.cpp File Reference

  • XAML user and custom controls

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/pch.h File Reference

  • XAML user and custom controls

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "BasicCustomControl.h"
#include "ImageWithLabelControl.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario1.xaml.cpp File Reference

  • XAML user and custom controls

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario1.xaml.h File Reference

  • XAML user and custom controls
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::UserAndCustomControls::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserAndCustomControls
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario2.xaml.cpp File Reference

  • XAML user and custom controls

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario2.xaml.h File Reference

  • XAML user and custom controls
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::UserAndCustomControls::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserAndCustomControls
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario3.xaml.cpp File Reference

  • XAML user and custom controls

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario3.xaml.h File Reference

  • XAML user and custom controls
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::UserAndCustomControls::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserAndCustomControls
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario4.xaml.cpp File Reference

  • XAML user and custom controls

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario4.xaml.h File Reference

  • XAML user and custom controls
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::UserAndCustomControls::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::UserAndCustomControls
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/common/LayoutAwarePage.cpp File Reference

  • XAML user and custom controls
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/common/LayoutAwarePage.h File Reference

  • XAML user and custom controls
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/common/suspensionmanager.cpp File Reference

  • XAML user and custom controls
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/common/suspensionmanager.h File Reference

  • XAML user and custom controls
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/App.xaml.cpp File Reference

  • XAML vector-based drawing

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/App.xaml.h File Reference

  • XAML vector-based drawing
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Constants.cpp File Reference

  • XAML vector-based drawing

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Constants.h File Reference

  • XAML vector-based drawing
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/MainPage.xaml.cpp File Reference

  • XAML vector-based drawing

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/MainPage.xaml.h File Reference

  • XAML vector-based drawing
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/pch.cpp File Reference

  • XAML vector-based drawing

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/pch.h File Reference

  • XAML vector-based drawing

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario1.xaml.cpp File Reference

  • XAML vector-based drawing

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario1.xaml.h File Reference

  • XAML vector-based drawing
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Drawing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Drawing
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario2.xaml.cpp File Reference

  • XAML vector-based drawing

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario2.xaml.h File Reference

  • XAML vector-based drawing
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Drawing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Drawing
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario3.xaml.cpp File Reference

  • XAML vector-based drawing

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario3.xaml.h File Reference

  • XAML vector-based drawing
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Drawing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Drawing
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario4.xaml.cpp File Reference

  • XAML vector-based drawing

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario4.xaml.h File Reference

  • XAML vector-based drawing
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::Drawing::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Drawing
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/common/LayoutAwarePage.cpp File Reference

  • XAML vector-based drawing
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/common/LayoutAwarePage.h File Reference

  • XAML vector-based drawing
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/common/suspensionmanager.cpp File Reference

  • XAML vector-based drawing
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/common/suspensionmanager.h File Reference

  • XAML vector-based drawing
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/App.xaml.cpp File Reference

  • XAML WebView control

App.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/App.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

App.xaml.h File Reference

#include "pch.h"
#include "App.g.h"
#include "MainPage.g.h"

Go to the source code of this file.

Classes

class | SDKSample::App

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Constants.cpp File Reference

  • XAML WebView control

Constants.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "Constants.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Constants.h File Reference

  • XAML WebView control
Classes | Namespaces

Constants.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::MainPage
struct | SDKSample::Scenario

Namespaces

namespace | SDKSample
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/MainPage.xaml.cpp File Reference

  • XAML WebView control

MainPage.xaml.cpp File Reference

#include "pch.h"
#include "MainPage.xaml.h"
#include "App.xaml.h"
#include <collection.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/MainPage.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces | Enumerations

MainPage.xaml.h File Reference

#include "pch.h"
#include "MainPage.g.h"
#include "Common\LayoutAwarePage.h"
#include "Constants.h"

Go to the source code of this file.

Classes

class | SDKSample::sealed
class | SDKSample::sealed

Namespaces

namespace | SDKSample

Enumerations

enum SDKSample::NotifyType {
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage,
SDKSample::StatusMessage, SDKSample::ErrorMessage, SDKSample::StatusMessage, SDKSample::ErrorMessage
}
Generated on Sat Nov 23 2024 16:08:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/PageWithAppBar.xaml.cpp File Reference

  • XAML WebView control

PageWithAppBar.xaml.cpp File Reference

#include "pch.h"
#include "PageWithAppBar.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/PageWithAppBar.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

PageWithAppBar.xaml.h File Reference

#include "pch.h"
#include "PageWithAppBar.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/pch.cpp File Reference

  • XAML WebView control

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/pch.h File Reference

  • XAML WebView control

pch.h File Reference

#include <collection.h>
#include <ppltasks.h>
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"
#include "App.xaml.h"
#include "Common\LayoutAwarePage.h"
#include "Common\SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario1.xaml.cpp File Reference

  • XAML WebView control

Scenario1.xaml.cpp File Reference

#include "pch.h"
#include "Scenario1.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario1.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

Scenario1.xaml.h File Reference

#include "pch.h"
#include "Scenario1.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario2.xaml.cpp File Reference

  • XAML WebView control

Scenario2.xaml.cpp File Reference

#include "pch.h"
#include "Scenario2.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario2.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

Scenario2.xaml.h File Reference

#include "pch.h"
#include "Scenario2.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario3.xaml.cpp File Reference

  • XAML WebView control

Scenario3.xaml.cpp File Reference

#include "pch.h"
#include "Scenario3.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario3.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

Scenario3.xaml.h File Reference

#include "pch.h"
#include "Scenario3.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:08:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario4.xaml.cpp File Reference

  • XAML WebView control

Scenario4.xaml.cpp File Reference

#include "pch.h"
#include "Scenario4.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario4.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

Scenario4.xaml.h File Reference

#include "pch.h"
#include "Scenario4.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario5.xaml.cpp File Reference

  • XAML WebView control

Scenario5.xaml.cpp File Reference

#include "pch.h"
#include "Scenario5.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario5.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

Scenario5.xaml.h File Reference

#include "pch.h"
#include "Scenario5.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario6.xaml.cpp File Reference

  • XAML WebView control

Scenario6.xaml.cpp File Reference

#include "pch.h"
#include "Scenario6.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario6.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

Scenario6.xaml.h File Reference

#include "pch.h"
#include "Scenario6.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario7.xaml.cpp File Reference

  • XAML WebView control

Scenario7.xaml.cpp File Reference

#include "pch.h"
#include "Scenario7.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario7.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

Scenario7.xaml.h File Reference

#include "pch.h"
#include "Scenario7.g.h"
#include "MainPage.xaml.h"
#include <agile.h>

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario8.xaml.cpp File Reference

  • XAML WebView control

Scenario8.xaml.cpp File Reference

#include "pch.h"
#include "PageWithAppBar.xaml.h"
#include "Scenario8.xaml.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario8.xaml.h File Reference

  • XAML WebView control
Classes | Namespaces

Scenario8.xaml.h File Reference

#include "pch.h"
#include "Scenario8.g.h"
#include "MainPage.xaml.h"

Go to the source code of this file.

Classes

class | SDKSample::WebViewControl::sealed
An empty page that can be used on its own or navigated to within a Frame. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::WebViewControl
Generated on Sat Nov 23 2024 16:08:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/common/LayoutAwarePage.cpp File Reference

  • XAML WebView control
  • common

LayoutAwarePage.cpp File Reference

#include "pch.h"
#include "LayoutAwarePage.h"
#include "SuspensionManager.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/common/LayoutAwarePage.h File Reference

  • XAML WebView control
  • common
Classes | Namespaces

LayoutAwarePage.h File Reference

#include <collection.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::LayoutAwarePage
Typical implementation of Page that provides several important conveniences:

  • Application view state to visual state mapping
  • GoBack, GoForward, and GoHome event handlers
  • Mouse and keyboard shortcuts for navigation
  • State management for navigation and process lifetime management
  • A default view model
More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/common/suspensionmanager.cpp File Reference

  • XAML WebView control
  • common
Classes | Namespaces | Enumerations | Functions

suspensionmanager.cpp File Reference

#include "pch.h"
#include "SuspensionManager.h"
#include <collection.h>
#include <algorithm>

Go to the source code of this file.

Classes

class | sealed
Wrap a WeakReference as a reference object for use in a collection. More...

Namespaces

namespace | anonymous_namespace{suspensionmanager.cpp}

Enumerations

enum anonymous_namespace{suspensionmanager.cpp}::StreamTypes {
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker,
anonymous_namespace{suspensionmanager.cpp}::NullPtrType = 0, anonymous_namespace{suspensionmanager.cpp}::UInt8Type, anonymous_namespace{suspensionmanager.cpp}::UInt16Type, anonymous_namespace{suspensionmanager.cpp}::UInt32Type,
anonymous_namespace{suspensionmanager.cpp}::UInt64Type, anonymous_namespace{suspensionmanager.cpp}::Int16Type, anonymous_namespace{suspensionmanager.cpp}::Int32Type, anonymous_namespace{suspensionmanager.cpp}::Int64Type,
anonymous_namespace{suspensionmanager.cpp}::SingleType, anonymous_namespace{suspensionmanager.cpp}::DoubleType, anonymous_namespace{suspensionmanager.cpp}::BooleanType, anonymous_namespace{suspensionmanager.cpp}::Char16Type,
anonymous_namespace{suspensionmanager.cpp}::GuidType, anonymous_namespace{suspensionmanager.cpp}::StringType, anonymous_namespace{suspensionmanager.cpp}::StringToObjectMapType, anonymous_namespace{suspensionmanager.cpp}::MapEndMarker
}

Functions

Platform::Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (Windows::Storage::Streams::DataReader^reader)
Object | anonymous_namespace{suspensionmanager.cpp}::ReadObject (DataReader^reader)
String | anonymous_namespace{suspensionmanager.cpp}::ReadString (DataReader^reader)
IMap< String^, Object^> | anonymous_namespace{suspensionmanager.cpp}::ReadStringToObjectMap (DataReader^reader)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (Windows::Storage::Streams::DataWriter^writer, Platform::Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteObject (DataWriter^writer, Object^object)
void | anonymous_namespace{suspensionmanager.cpp}::WriteProperty (DataWriter^writer, IPropertyValue^propertyValue)
void | anonymous_namespace{suspensionmanager.cpp}::WriteString (DataWriter^writer, String^string)
void | anonymous_namespace{suspensionmanager.cpp}::WriteStringToObjectMap (DataWriter^writer, IMap< String^, Object^>^map)
Generated on Sat Nov 23 2024 16:08:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/common/suspensionmanager.h File Reference

  • XAML WebView control
  • common
Classes | Namespaces

suspensionmanager.h File Reference

#include <ppltasks.h>

Go to the source code of this file.

Classes

class | SDKSample::Common::sealed
SuspensionManager captures global session state to simplify process lifetime management for an application. More...

Namespaces

namespace | SDKSample
namespace | SDKSample::Common
Generated on Sat Nov 23 2024 16:08:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/BasicMath.h File Reference

  • XAudio2 audio file playback
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/BasicSound.cpp File Reference

  • XAudio2 audio file playback
Namespaces | Variables

BasicSound.cpp File Reference

#include "pch.h"
#include "BasicSound.h"
#include "SoundFileReader.h"
#include "DirectXSample.h"

Go to the source code of this file.

Namespaces

namespace | anonymous_namespace{BasicSound.cpp}

Variables

const char16 * | anonymous_namespace{BasicSound.cpp}::APPLICATION_TITLE = "XAudio2 sound playback sample"
const char16 | anonymous_namespace{BasicSound.cpp}::FONT_LOCALE [] = "en-US"
const char16 | anonymous_namespace{BasicSound.cpp}::FONT_NAME [] = "Segoe UI"
const float | anonymous_namespace{BasicSound.cpp}::FONT_SIZE_TEXT = 18.0f
const float | anonymous_namespace{BasicSound.cpp}::INFORMATION_START_X = 32.0f
const float | anonymous_namespace{BasicSound.cpp}::INFORMATION_START_Y = 150.0f
const char16 | anonymous_namespace{BasicSound.cpp}::MSG_NEED_AUDIO [] = "No usable audio devices were found; install an audio device and restart the sample."
const char16 * | anonymous_namespace{BasicSound.cpp}::SOUND_FILE_LIST []
const uint32 | anonymous_namespace{BasicSound.cpp}::SOUND_SAMPLE_RATE = 48000
const float | anonymous_namespace{BasicSound.cpp}::TITLE_MARGIN = 100.0f
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/BasicSound.h File Reference

  • XAudio2 audio file playback
Classes

BasicSound.h File Reference

#include "SampleOverlay.h"
#include "XAudio2SoundPlayer.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class BasicSound
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/BasicTimer.cpp File Reference

  • XAudio2 audio file playback

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/BasicTimer.h File Reference

  • XAudio2 audio file playback
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/DirectXApp.cpp File Reference

  • XAudio2 audio file playback
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 165 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/DirectXApp.h File Reference

  • XAudio2 audio file playback
Classes

DirectXApp.h File Reference

#include "BasicSound.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/DirectXBase.cpp File Reference

  • XAudio2 audio file playback

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/DirectXBase.h File Reference

  • XAudio2 audio file playback
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/DirectXSample.h File Reference

  • XAudio2 audio file playback
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/pch.cpp File Reference

  • XAudio2 audio file playback

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/pch.h File Reference

  • XAudio2 audio file playback

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include <vector>
#include "strsafe.h"
#include <memory>
#include <xaudio2.h>
#include <mmreg.h>
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/RandomAccessReader.cpp File Reference

  • XAudio2 audio file playback

RandomAccessReader.cpp File Reference

#include "pch.h"
#include "RandomAccessReader.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/RandomAccessReader.h File Reference

  • XAudio2 audio file playback
Classes

RandomAccessReader.h File Reference

Go to the source code of this file.

Classes

class RandomAccessReader
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/SampleOverlay.cpp File Reference

  • XAudio2 audio file playback

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/SampleOverlay.h File Reference

  • XAudio2 audio file playback
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/SoundFileReader.cpp File Reference

  • XAudio2 audio file playback
Classes | Namespaces | Functions | Variables

SoundFileReader.cpp File Reference

#include "pch.h"
#include "SoundFileReader.h"
#include "RandomAccessReader.h"

Go to the source code of this file.

Classes

struct | anonymous_namespace{SoundFileReader.cpp}::ChunkHeader

Namespaces

namespace | anonymous_namespace{SoundFileReader.cpp}

Functions

uint64 | anonymous_namespace{SoundFileReader.cpp}::FindChunk (RandomAccessReader^file, uint32 tag, uint64 startLoc, uint64 endLoc)
void | anonymous_namespace{SoundFileReader.cpp}::ReadHeader (RandomAccessReader^file, uint64 loc, ChunkHeader &header)

Variables

const uint32 | anonymous_namespace{SoundFileReader.cpp}::FOURCC_DATA_TAG = 'atad'
const uint32 | anonymous_namespace{SoundFileReader.cpp}::FOURCC_FORMAT_TAG = ' tmf'
const uint32 | anonymous_namespace{SoundFileReader.cpp}::FOURCC_RIFF_TAG = 'FFIR'
const uint32 | anonymous_namespace{SoundFileReader.cpp}::FOURCC_WAVE_FILE_TAG = 'EVAW'
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/SoundFileReader.h File Reference

  • XAudio2 audio file playback
Classes

SoundFileReader.h File Reference

Go to the source code of this file.

Classes

class SoundFileReader
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/XAudio2SoundPlayer.cpp File Reference

  • XAudio2 audio file playback
Classes | Namespaces

XAudio2SoundPlayer.cpp File Reference

#include "pch.h"
#include "XAudio2SoundPlayer.h"

Go to the source code of this file.

Classes

class | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
struct | XAudio2SoundPlayer::ImplData

Namespaces

namespace | anonymous_namespace{XAudio2SoundPlayer.cpp}
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/XAudio2SoundPlayer.h File Reference

  • XAudio2 audio file playback
Classes

XAudio2SoundPlayer.h File Reference

#include "DirectXBase.h"
#include "mmreg.h"
#include <vector>
#include <memory>
#include "DirectXBase.h"

Go to the source code of this file.

Classes

class XAudio2SoundPlayer
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/BasicMath.h File Reference

  • XAudio2 audio stream effect
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/BasicTimer.cpp File Reference

  • XAudio2 audio stream effect

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/BasicTimer.h File Reference

  • XAudio2 audio stream effect
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/DirectXApp.cpp File Reference

  • XAudio2 audio stream effect
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 155 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/DirectXApp.h File Reference

  • XAudio2 audio stream effect
Classes

DirectXApp.h File Reference

#include "StreamEffect.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/DirectXBase.cpp File Reference

  • XAudio2 audio stream effect

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/DirectXBase.h File Reference

  • XAudio2 audio stream effect
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/DirectXSample.h File Reference

  • XAudio2 audio stream effect
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/MediaStreamer.cpp File Reference

  • XAudio2 audio stream effect

MediaStreamer.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"
#include "directxsample.h"
#include <initguid.h>
#include "MediaStreamer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/MediaStreamer.h File Reference

  • XAudio2 audio stream effect
Classes

MediaStreamer.h File Reference

#include <roapi.h>
#include <mfidl.h>
#include <mfapi.h>
#include <mfreadwrite.h>

Go to the source code of this file.

Classes

class MediaStreamer
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/pch.cpp File Reference

  • XAudio2 audio stream effect

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/pch.h File Reference

  • XAudio2 audio stream effect

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include <vector>
#include "strsafe.h"
#include <xaudio2.h>
#include <xaudio2fx.h>
#include <memory>
#include "BasicMath.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/SampleOverlay.cpp File Reference

  • XAudio2 audio stream effect

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/SampleOverlay.h File Reference

  • XAudio2 audio stream effect
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/StreamEffect.cpp File Reference

  • XAudio2 audio stream effect
Namespaces | Variables

StreamEffect.cpp File Reference

#include "pch.h"
#include "StreamEffect.h"
#include "DirectXSample.h"

Go to the source code of this file.

Namespaces

namespace | anonymous_namespace{StreamEffect.cpp}

Variables

const char16 | anonymous_namespace{StreamEffect.cpp}::APPLICATION_TITLE [] = "XAudio2 audio stream playback sample"
const size_t | anonymous_namespace{StreamEffect.cpp}::BUFFER_COUNT = 3
const char16 | anonymous_namespace{StreamEffect.cpp}::FONT_LOCALE [] = "en-US"
const char16 | anonymous_namespace{StreamEffect.cpp}::FONT_NAME [] = "Segoe UI"
const float | anonymous_namespace{StreamEffect.cpp}::FONT_SIZE_TEXT = 18.0f
const float | anonymous_namespace{StreamEffect.cpp}::INFORMATION_START_X = 32.0f
const float | anonymous_namespace{StreamEffect.cpp}::INFORMATION_START_Y = 150.0f
const char16 | anonymous_namespace{StreamEffect.cpp}::MSG_NEED_AUDIO [] = "No usable audio devices were found; install an audio device and restart the sample."
const char16 | anonymous_namespace{StreamEffect.cpp}::MUSIC_FILE [] = "Media\\Wavs\\becky.wma"
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/StreamEffect.h File Reference

  • XAudio2 audio stream effect
Classes

StreamEffect.h File Reference

#include "SampleOverlay.h"
#include "DirectXSample.h"
#include "DirectXBase.h"
#include "MediaStreamer.h"
#include "SampleOverlay.h"
#include "DirectXBase.h"
#include "MediaStreamer.h"

Go to the source code of this file.

Classes

class StreamEffect
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/AudioController.cpp File Reference

  • XInput audio controller playback
Namespaces | Variables

AudioController.cpp File Reference

#include "pch.h"
#include "AudioController.h"
#include "DirectXSample.h"

Go to the source code of this file.

Namespaces

namespace | anonymous_namespace{AudioController.cpp}

Variables

const char16 | anonymous_namespace{AudioController.cpp}::APPLICATION_TITLE [] = "XInput audio controller playback sample"
const char16 | anonymous_namespace{AudioController.cpp}::FONT_LOCAL [] = "en-US"
const char16 | anonymous_namespace{AudioController.cpp}::FONT_NAME [] = "Segoe UI"
const float | anonymous_namespace{AudioController.cpp}::FONT_SIZE_TEXT = 18.0f
const float | anonymous_namespace{AudioController.cpp}::INFORMATION_START_X = 32.0f
const float | anonymous_namespace{AudioController.cpp}::INFORMATION_START_Y = 150.0f
const char16 | anonymous_namespace{AudioController.cpp}::MSG_INSTRUCTIONS [] = "Press the A button to play a sound."
const char16 | anonymous_namespace{AudioController.cpp}::MSG_NEED_CONTROLLER [] = "Please insert an Xbox 360 common controller device and attach a headset."
const char16 | anonymous_namespace{AudioController.cpp}::MSG_NEED_HEADSET [] = "Please attach a headset to the Xbox 360 common controller device."
const char16 | anonymous_namespace{AudioController.cpp}::SOUND_FILE [] = "media\\wavs\\pow.wav"
const uint64 | anonymous_namespace{AudioController.cpp}::XINPUT_ENUM_TIMEOUT_MS = 2000
const uint64 | anonymous_namespace{AudioController.cpp}::XINPUT_HEADSET_CHECK_TIMEOUT_MS = 2000
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/AudioController.h File Reference

  • XInput audio controller playback
Classes

AudioController.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"
#include <xaudio2.h>
#include <xaudio2fx.h>
#include "MediaStreamer.h"
#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class AudioController
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/BasicMath.h File Reference

  • XInput audio controller playback
Classes | Defines | Typedefs | Functions

BasicMath.h File Reference

#include <math.h>

Go to the source code of this file.

Classes

struct | Matrix4x4< T >
struct | Vector2< T >
struct | Vector3< T >
struct | Vector4< T >

Defines

#define | _USE_MATH_DEFINES
#define | PI_F 3.1415927f

Typedefs

typedef Vector2< float > | float2
typedef Vector3< float > | float3
typedef Vector4< float > | float4
typedef Matrix4x4< float > | float4x4
typedef unsigned int | uint

Functions

template<class T >
Vector3< T > | cross (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector3< T > a, Vector3< T > b)
template<class T >
T | dot (Vector2< T > a, Vector2< T > b)
template<class T >
T | dot (Vector4< T > a, Vector4< T > b)
float4x4 identity ()
template<class T >
T | length (Vector2< T > a)
template<class T >
T | length (Vector3< T > a)
template<class T >
T | length (Vector4< T > a)
template<class T >
Matrix4x4< T > | mul (Matrix4x4< T > m1, Matrix4x4< T > m2)
template<class T >
Vector2< T > | normalize (Vector2< T > a)
template<class T >
Vector3< T > | normalize (Vector3< T > a)
template<class T >
Vector4< T > | normalize (Vector4< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, T s)
template<class T >
Vector2< T > | operator* (T s, Vector2< T > a)
template<class T >
Vector2< T > | operator* (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator* (Vector3< T > a, T s)
template<class T >
Vector3< T > | operator* (T s, Vector3< T > a)
template<class T >
Vector3< T > | operator* (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator* (Vector4< T > a, T s)
template<class T >
Vector4< T > | operator* (T s, Vector4< T > a)
template<class T >
Vector4< T > | operator* (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator+ (Vector2< T > a, Vector2< T > b)
template<class T >
Vector3< T > | operator+ (Vector3< T > a, Vector3< T > b)
template<class T >
Vector4< T > | operator+ (Vector4< T > a, Vector4< T > b)
template<class T >
Vector4< T > | operator- (Vector4< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a)
template<class T >
Vector4< T > | operator- (Vector4< T > a, Vector4< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a, Vector2< T > b)
template<class T >
Vector2< T > | operator- (Vector2< T > a)
template<class T >
Vector3< T > | operator- (Vector3< T > a, Vector3< T > b)
template<class T >
Vector3< T > | operator/ (Vector3< T > a, T s)
template<class T >
Vector4< T > | operator/ (Vector4< T > a, T s)
template<class T >
Vector2< T > | operator/ (Vector2< T > a, T s)
float4x4 | rotationArbitrary (float3 axis, float degree)
float4x4 | rotationX (float degreeX)
float4x4 | rotationY (float degreeY)
float4x4 | rotationZ (float degreeZ)
float4x4 | scale (float x, float y, float z)
float4x4 | translation (float x, float y, float z)
template<class T >
Matrix4x4< T > | transpose (Matrix4x4< T > m)

Define Documentation

#define _USE_MATH_DEFINES

Definition at line 10 of file BasicMath.h.

#define PI_F 3.1415927f

Definition at line 18 of file BasicMath.h.

Typedef Documentation

typedef Vector2<float> float2

Definition at line 389 of file BasicMath.h.

typedef Vector3<float> float3

Definition at line 390 of file BasicMath.h.

typedef Vector4<float> float4

Definition at line 391 of file BasicMath.h.

typedef Matrix4x4<float> float4x4

Definition at line 393 of file BasicMath.h.

typedef unsigned int uint

Definition at line 387 of file BasicMath.h.

Function Documentation

template<class T >
Vector3<T> cross | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 197 of file BasicMath.h.

{
    return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
}

template<class T >
T dot | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 167 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z;
}

template<class T >
T dot | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 161 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y;
}

template<class T >
T dot | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 173 of file BasicMath.h.

{
    return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
}

float4x4 identity ( ) [inline]

Definition at line 397 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
T length ( Vector2< T > a )

Definition at line 179 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y);
}

template<class T >
T length ( Vector3< T > a )

Definition at line 185 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
}

template<class T >
T length ( Vector4< T > a )

Definition at line 191 of file BasicMath.h.

{
    return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
}

template<class T >
Matrix4x4<T> mul | ( | Matrix4x4< T > | m1,
 |  | Matrix4x4< T > | m2
 | ) |  |

Definition at line 367 of file BasicMath.h.

{
    Matrix4x4<T> mOut;

    for (int i = 0; i < 4; i++)
    {
        for (int j = 0; j < 4; j++)
        {
            for (int k = 0; k < 4; k++)
            {
                mOut[i][j] += m1[i][k] * m2[k][j];
            }
        }
    }

    return mOut;
}

template<class T >
Vector2<T> normalize ( Vector2< T > a )

Definition at line 203 of file BasicMath.h.

{
    T len = length(a);
    return Vector2<T>(a.x / len, a.y / len);
}

template<class T >
Vector3<T> normalize ( Vector3< T > a )

Definition at line 210 of file BasicMath.h.

{
    T len = length(a);
    return Vector3<T>(a.x / len, a.y / len, a.z / len);
}

template<class T >
Vector4<T> normalize ( Vector4< T > a )

Definition at line 217 of file BasicMath.h.

{
    T len = length(a);
    return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 280 of file BasicMath.h.

{
    return Vector2<T>(a.x * s, a.y * s);
}

template<class T >
Vector2<T> operator* | ( | T | s,
 |  | Vector2< T > | a
 | ) |  |

Definition at line 286 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector2<T> operator* | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 292 of file BasicMath.h.

{
    return Vector2<T>(a.x * b.x, a.y * b.y);
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 304 of file BasicMath.h.

{
    return Vector3<T>(a.x * s, a.y * s, a.z * s);
}

template<class T >
Vector3<T> operator* | ( | T | s,
 |  | Vector3< T > | a
 | ) |  |

Definition at line 310 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector3<T> operator* | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 316 of file BasicMath.h.

{
    return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 328 of file BasicMath.h.

{
    return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
}

template<class T >
Vector4<T> operator* | ( | T | s,
 |  | Vector4< T > | a
 | ) |  |

Definition at line 334 of file BasicMath.h.

{
    return a * s;
}

template<class T >
Vector4<T> operator* | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 340 of file BasicMath.h.

{
    return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
}

template<class T >
Vector2<T> operator+ | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 262 of file BasicMath.h.

{
    return Vector2<T>(a.x + b.x, a.y + b.y);
}

template<class T >
Vector3<T> operator+ | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 268 of file BasicMath.h.

{
    return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
}

template<class T >
Vector4<T> operator+ | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 274 of file BasicMath.h.

{
    return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
}

template<class T >
Vector4<T> operator- ( Vector4< T > a )

Definition at line 256 of file BasicMath.h.

{
    return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
}

template<class T >
Vector3<T> operator- ( Vector3< T > a )

Definition at line 244 of file BasicMath.h.

{
    return Vector3<T>(-a.x, -a.y, -a.z);
}

template<class T >
Vector4<T> operator- | ( | Vector4< T > | a,
 |  | Vector4< T > | b
 | ) |  |

Definition at line 250 of file BasicMath.h.

{
    return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
}

template<class T >
Vector2<T> operator- | ( | Vector2< T > | a,
 |  | Vector2< T > | b
 | ) |  |

Definition at line 226 of file BasicMath.h.

{
    return Vector2<T>(a.x - b.x, a.y - b.y);
}

template<class T >
Vector2<T> operator- ( Vector2< T > a )

Definition at line 232 of file BasicMath.h.

{
    return Vector2<T>(-a.x, -a.y);
}

template<class T >
Vector3<T> operator- | ( | Vector3< T > | a,
 |  | Vector3< T > | b
 | ) |  |

Definition at line 238 of file BasicMath.h.

{
    return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
}

template<class T >
Vector3<T> operator/ | ( | Vector3< T > | a,
 |  | T | s
 | ) |  |

Definition at line 322 of file BasicMath.h.

{
    return Vector3<T>(a.x / s, a.y / s, a.z / s);
}

template<class T >
Vector4<T> operator/ | ( | Vector4< T > | a,
 |  | T | s
 | ) |  |

Definition at line 346 of file BasicMath.h.

{
    return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
}

template<class T >
Vector2<T> operator/ | ( | Vector2< T > | a,
 |  | T | s
 | ) |  |

Definition at line 298 of file BasicMath.h.

{
    return Vector2<T>(a.x / s, a.y / s);
}

float4x4 rotationArbitrary | ( | float3 | axis,
 |  | float | degree |
 | ) |  |  | [inline]

Definition at line 485 of file BasicMath.h.

{
    axis = normalize(axis);

    float angleInRadians = degree * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);
    float oneMinusCosAngle = 1 - cosAngle;

    float4x4 mOut;

    mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
    mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
    mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
    mOut._41 = 0.0f;

    mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
    mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
    mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
    mOut._24 = 0.0f;

    mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
    mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
    mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
    mOut._34 = 0.0f;

    mOut._41 = 0.0f;
    mOut._42 = 0.0f;
    mOut._43 = 0.0f;
    mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationX ( float degreeX ) [inline]

Definition at line 433 of file BasicMath.h.

{
    float angleInRadians = degreeX * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationY ( float degreeY ) [inline]

Definition at line 450 of file BasicMath.h.

{
    float angleInRadians = degreeY * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
    mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
    mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
    mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;

    return mOut;
}

float4x4 rotationZ ( float degreeZ ) [inline]

Definition at line 467 of file BasicMath.h.

{
    float angleInRadians = degreeZ * (PI_F / 180.0f);

    float sinAngle = sinf(angleInRadians);
    float cosAngle = cosf(angleInRadians);

    float4x4 mOut;

    mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
    mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 scale | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 421 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
    mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

float4x4 translation | ( | float | x,
 |  | float | y,
 |  | float | z |
 | ) |  |  | [inline]

Definition at line 409 of file BasicMath.h.

{
    float4x4 mOut;

    mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
    mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
    mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
    mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;

    return mOut;
}

template<class T >
Matrix4x4<T> transpose ( Matrix4x4< T > m )

Definition at line 356 of file BasicMath.h.

{
    return Matrix4x4<T>(
        m._11, m._21, m._31, m._41,
        m_.12, m._22, m._32, m._42,
        m._13, m._23, m._33, m._43,
        m._14, m._24, m._34, m._44
        );
}

Generated on Sat Nov 23 2024 16:08:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/BasicTimer.cpp File Reference

  • XInput audio controller playback

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/BasicTimer.h File Reference

  • XInput audio controller playback
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/DirectXApp.cpp File Reference

  • XInput audio controller playback
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 155 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/DirectXApp.h File Reference

  • XInput audio controller playback
Classes

DirectXApp.h File Reference

#include "AudioController.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/DirectXBase.cpp File Reference

  • XInput audio controller playback

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/DirectXBase.h File Reference

  • XInput audio controller playback
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"
#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/DirectXSample.h File Reference

  • XInput audio controller playback
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/MediaStreamer.cpp File Reference

  • XInput audio controller playback

MediaStreamer.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"
#include "directxsample.h"
#include <initguid.h>
#include "MediaStreamer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/MediaStreamer.h File Reference

  • XInput audio controller playback
Classes

MediaStreamer.h File Reference

#include <roapi.h>
#include <mmreg.h>
#include <mfidl.h>
#include <mfapi.h>
#include <mfreadwrite.h>

Go to the source code of this file.

Classes

class MediaStreamer
Generated on Sat Nov 23 2024 16:08:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/pch.cpp File Reference

  • XInput audio controller playback

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/pch.h File Reference

  • XInput audio controller playback

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <agile.h>
#include "BasicMath.h"
#include <vector>
#include "strsafe.h"
#include <XInput.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/SampleOverlay.cpp File Reference

  • XInput audio controller playback

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/SampleOverlay.h File Reference

  • XInput audio controller playback
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/BasicTimer.cpp File Reference

  • XInput game controller

BasicTimer.cpp File Reference

#include "pch.h"
#include "BasicTimer.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/BasicTimer.h File Reference

  • XInput game controller
Classes

BasicTimer.h File Reference

Go to the source code of this file.

Classes

class BasicTimer
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/DirectXApp.cpp File Reference

  • XInput game controller
Functions

DirectXApp.cpp File Reference

#include "pch.h"
#include "DirectXApp.h"
#include "BasicTimer.h"

Go to the source code of this file.

Functions

int main (Platform::Array< Platform::String^>^)

Function Documentation

int main ( Platform::Array< Platform::String^>^ )

Definition at line 153 of file DirectXApp.cpp.

{
    auto directXAppSource = ref new DirectXAppSource();
    CoreApplication::Run(directXAppSource);
    return 0;
}

Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/DirectXApp.h File Reference

  • XInput game controller
Classes

DirectXApp.h File Reference

#include "SimpleController.h"

Go to the source code of this file.

Classes

class | DirectXApp
class | DirectXAppSource
Generated on Sat Nov 23 2024 16:08:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/DirectXBase.cpp File Reference

  • XInput game controller

DirectXBase.cpp File Reference

#include "pch.h"
#include "DirectXBase.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/DirectXBase.h File Reference

  • XInput game controller
Classes

DirectXBase.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class abstract
Generated on Sat Nov 23 2024 16:08:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/DirectXSample.h File Reference

  • XInput game controller
Namespaces | Functions

DirectXSample.h File Reference

Go to the source code of this file.

Namespaces

namespace | DX

Functions

void | DX::ThrowIfFailed (HRESULT hr)
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/pch.cpp File Reference

  • XInput game controller

pch.cpp File Reference

#include "pch.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/pch.h File Reference

  • XInput game controller

pch.h File Reference

#include <wrl.h>
#include <d3d11_1.h>
#include <d2d1_1.h>
#include <d2d1effects.h>
#include <dwrite_1.h>
#include <wincodec.h>
#include <XInput.h>
#include <stdio.h>
#include <agile.h>

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/SampleOverlay.cpp File Reference

  • XInput game controller

SampleOverlay.cpp File Reference

#include "pch.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/SampleOverlay.h File Reference

  • XInput game controller
Classes

SampleOverlay.h File Reference

#include "DirectXSample.h"

Go to the source code of this file.

Classes

class SampleOverlay
Generated on Sat Nov 23 2024 16:08:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/SimpleController.cpp File Reference

  • XInput game controller
Namespaces | Variables

SimpleController.cpp File Reference

#include "pch.h"
#include "SimpleController.h"
#include "DirectXSample.h"

Go to the source code of this file.

Namespaces

namespace | anonymous_namespace{SimpleController.cpp}

Variables

const char16 | anonymous_namespace{SimpleController.cpp}::APPLICATION_TITLE [] = "XInput game controller sample"
const float | anonymous_namespace{SimpleController.cpp}::CAPS_DATA_START = INFORMATION_START_X + 400.0f
const char16 | anonymous_namespace{SimpleController.cpp}::CAPS_HEADER [] = "XInput Capabilties"
const float | anonymous_namespace{SimpleController.cpp}::CAPS_LABEL_START = INFORMATION_START_X + 300.0f
const float | anonymous_namespace{SimpleController.cpp}::CLEAR_COLOR [4] = { 0.071f, 0.040f, 0.561f, 1.0f }
const char16 | anonymous_namespace{SimpleController.cpp}::FONT_LOCAL [] = "en-US"
const char16 | anonymous_namespace{SimpleController.cpp}::FONT_NAME [] = "Segoe UI"
const float | anonymous_namespace{SimpleController.cpp}::FONT_SIZE_HEADER = 18.0f
const float | anonymous_namespace{SimpleController.cpp}::FONT_SIZE_TEXT = 18.0f
const float | anonymous_namespace{SimpleController.cpp}::INFORMATION_START_X = 32.0f
const float | anonymous_namespace{SimpleController.cpp}::INFORMATION_START_Y = 150.0f
const float | anonymous_namespace{SimpleController.cpp}::INPUT_DATA_START = INFORMATION_START_X + 132.0f
const float | anonymous_namespace{SimpleController.cpp}::INPUT_LABEL_START = INFORMATION_START_X
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_CAPS_FLAGS [] = "Flags"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_CAPS_SUBTYPE [] = "Subtype"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_CAPS_TYPE [] = "Type"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_STATE_BUTTONS [] = "Buttons"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_STATE_LEFT_THUMB_X [] = "Left Thumb X"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_STATE_LEFT_THUMB_Y [] = "Left Thumb Y"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_STATE_LEFT_TRIGGER [] = "Left Trigger"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_STATE_PACKET_NUMBER [] = "Packet Number"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_STATE_RIGHT_THUMB_X [] = "Right Thumb X"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_STATE_RIGHT_THUMB_Y [] = "Right Thumb Y"
const char16 | anonymous_namespace{SimpleController.cpp}::LABEL_STATE_RIGHT_TRIGGER [] = "Right Trigger"
const float | anonymous_namespace{SimpleController.cpp}::LINE_HEIGHT = FONT_SIZE_HEADER * 1.5f
const char16 | anonymous_namespace{SimpleController.cpp}::MSG_NEED_CONTROLLER [] = "Please attach an Xbox 360 common controller device."
const char16 | anonymous_namespace{SimpleController.cpp}::STATE_HEADER [] = "XInput State"
const char16 | anonymous_namespace{SimpleController.cpp}::VALUE_CAPS_VOICE_SUPPORT [] = "Voice Support"
const char16 | anonymous_namespace{SimpleController.cpp}::VALUE_CAPS_WIRED [] = "Wired"
const char16 | anonymous_namespace{SimpleController.cpp}::VALUE_CAPS_WIRELESS [] = "Wireless"
const uint64 | anonymous_namespace{SimpleController.cpp}::XINPUT_ENUM_TIMEOUT_MS = 2000
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/SimpleController.h File Reference

  • XInput game controller
Classes

SimpleController.h File Reference

#include "DirectXBase.h"
#include "SampleOverlay.h"

Go to the source code of this file.

Classes

class SimpleController
Generated on Sat Nov 23 2024 16:09:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Directory Hierarchy

Directories

This directory hierarchy is sorted roughly, but not completely, alphabetically:
  • Accelerometer sensor
    • C++
      • common
  • Account picture name
    • C++
      • common
      • sample-utils
  • Animation metrics
    • C++
      • common
  • App package information
    • C++
      • common
  • App settings
    • C++
      • common
  • App tiles and badges
    • C#,C++
      • common
      • NotificationsExtensions
  • Application data
    • C++
      • common
  • Application resources and localization
    • C++
  • Association launching
    • C++
  • AtomPub
    • C++
      • common
  • Background task
    • C++
      • BackgroundTask
        • common
      • Tasks
  • Background Transfer
    • C++
      • common
  • Bing Maps Trip Optimizer
    • C++,JavaScript
      • cpp
  • Bluetooth call control
    • C++
      • common
  • Calendar details and math
    • C++
      • common
  • CameraCaptureUI
    • C++
      • common
  • CameraOptionsUI
    • C++
      • common
  • Certificate enrollment
    • C++
      • common
  • Check if current session is remote
    • C++
      • common
  • Clipboard app
    • C++
      • common
      • sample-utils
  • Compass sensor
    • C++
      • common
  • Compression
    • C++
      • common
  • Configure keys for media
    • C++
      • common
      • sample-utils
  • Connecting with WebSockets
    • C++
      • common
  • Contact Picker app
    • C++
      • Common
      • Sample-Utils
  • Context menu
    • C++
      • common
  • ControlChannelTrigger StreamSocket
    • C++
      • Background
  • ControlChannelTrigger StreamWebSocket
    • C++
      • Background
  • ControlChannelTrigger XMLHTTPRequest
    • C++
      • Background
  • Credential locker
    • C++
      • common
  • Credential picker
    • C++
  • CryptoWinRT
    • C++
      • common
  • Custom driver access
    • C#,C++
      • app_cs
        • common
        • Properties
      • DLL
    • C++
      • app_cpp
        • common
      • DLL
    • C++,JavaScript
      • DLL
  • DatagramSocket
    • C++
      • Common
      • sample-utils
  • Date and time formatting
    • C++
      • common
  • Device app for printers SDK
    • C++
      • BackgroundTask
      • DeviceAppForPrinters
  • Device auto rotation preferences
    • C++
      • common
  • Device enumeration
    • C++
      • common
  • Direct2D 3D transform effect
    • C++
  • Direct2D and DirectWrite animated text on a path
    • C++
  • Direct2D animated text
    • C++
  • Direct2D animation
    • C++
  • Direct2D basic image effects
    • C++
  • Direct2D command list
    • C++
  • Direct2D composite effect modes
    • C++
  • Direct2D convolve matrix effect
    • C++
  • Direct2D custom image effects
    • C++
      • ComputeShader
      • PixelShader
      • VertexShader
  • Direct2D effects on primitives
    • C++
  • Direct2D geometry realization
    • C++
  • Direct2D interpolation modes
    • C++
  • Direct2D magazine app
    • C++
  • Direct2D perspective transform
    • C++
  • Direct2D printing images and effects
    • C++
  • Direct2D save to image file
    • C++
  • Direct2Dapp printing
    • C++
  • Direct3D bump mapping
    • C++
  • Direct3D HLSL fractal generator
    • C++
  • Direct3D post-processing effects
    • C++
  • Direct3D resource loading
    • C++
      • obj2vbo
      • texconv
  • Direct3D sprite
    • C++
  • Direct3D stereoscopic 3D
    • C++
  • Direct3D tutorial
    • C++
      • Lesson1.Basics
      • Lesson2.Triangles
      • Lesson3.Cubes
      • Lesson4.Textures
      • Lesson5.Components
  • Direct3D-Direct2D interop
    • C++
  • DirectWrite custom text renderer
    • C++
  • DirectWrite font enumeration
    • C++,JavaScript
      • cpp
  • DirectWrite hello world
    • C++
  • DirectWrite hit testing
    • C++
  • DirectWrite inline object
    • C++
  • DirectWrite paragraph text
    • C++
  • DirectWrite vertical text
    • C++
  • DirectX 3D shooting game
    • C++
  • DirectX marble maze game
    • C++
  • DirectX postcard app
    • C++
  • DirectX swap chain implementation
    • C++
  • DirectX touch input
    • C++
  • Display orientation
    • C++
      • common
  • DXGI offer and reclaim resources
    • C++
  • DXGI swap chain rotation
    • C++
  • EAS policies for mail clients
    • C++
      • common
  • Edge gesture invocation
    • C++
  • Extended Linguistic Services (ELS)
    • C++
      • common
  • File access
    • C++
      • common
  • File and folder thumbnail
    • C++
      • common
  • File picker
    • C++
      • common
  • File picker contracts
    • C++
      • common
  • Folder enumeration
    • C++
      • common
  • Geolocation
    • C++
      • backgroundtask
      • common
  • Getting started with C++ simple blog reader
    • C++
  • Globalization preferences
    • C++
      • common
  • Gyrometer sensor
    • C++
      • common
  • Hilo C++
    • C++
      • CartoonEffect
      • Hilo
        • Common
  • HomeGroup app
    • C++
      • common
  • HttpClient
    • C++
      • common
  • Inclinometer sensor
    • C++
      • common
  • Input Device capabilities
    • C++
      • common
  • Input Manipulations and gestures (C++)
    • C++
  • Input Simplified ink
    • C++
  • Input Touch hit testing
    • C++
  • Input Touch keyboard
    • C++
      • common
  • Input Touch keyboard text input
    • C++
      • common
  • IXmlReader and IXmlWriter XML data readwrite
    • C++
  • Language font mapping
    • C++
  • LightSensor
    • C++
      • common
  • Lock screen apps
    • C#,C++
      • NotificationsExtensions
  • Lock screen personalization
    • C++
      • common
  • Media capture using capture device
    • C#,C++
    • C++
      • common
  • Media engine native C++ video playback
    • C++
  • Media extensions
    • C#,C++
      • MediaExtensions
        • Common
        • Grayscale
        • Invert
        • Mpeg1Decoder
        • Mpeg1Source
        • Polar
      • Properties
      • Sample-Utils
    • C++
      • MediaExtensions
        • Common
        • GeometricSource
        • Grayscale
        • Invert
        • Mpeg1Decoder
        • Mpeg1Source
        • Polar
  • Media Play To
    • C++
      • common
  • Media Server client
    • C++
      • common
  • MediaStreamSource media extension
    • C#,C++
  • Message dialog
    • C++
      • common
  • Mobile broadband account provisioning
    • C++
  • Network information
    • C++
      • common
  • Network status background
    • C++
      • NetworkStatusApp
      • NetworkStatusTask
  • Number formatting and parsing
    • C++
      • common
  • OrientationSensor
    • C++
      • common
  • Playback Manager Companion
    • C++
      • common
      • sample-utils
  • Playback Manager msAudioCategory
    • C++
      • common
  • Playlist
    • C++
      • common
  • PlayToReceiver
    • C++
      • common
  • Portable device API
    • C++
      • common
  • Print
    • C++
  • Programmatic file search
    • C++
      • common
  • Proximity
    • C++
      • common
      • sample-utils
  • Push and periodic notifications client-side
    • C++
  • Raw notifications
    • C++
      • MainAppSample
      • SampleBackgroundTask
  • Reading and writing data
    • C++
      • common
  • Real-time communication
    • C#,C++
      • Common
      • Properties
      • sample-utils
    • C++
      • common
      • MediaExtensions
        • Common
      • sample-utils
  • Removable storage
    • C++
      • common
  • Scaling according to DPI
    • C++
      • common
  • Scheduled notifications
    • C#,C++
  • Search contract
    • C++
      • common
  • Secondary tiles
    • C#,C++
      • common
      • NotificationsExtensions
      • Sample-Utils
  • Sharing content source app
    • C++
      • common
  • Sharing content target app
    • C++
      • common
      • sample-utils
  • SimpleOrientationSensor
    • C++
      • common
  • SMS background task
    • C++
      • SmsBackgroundTask
      • SmsBackgroundTaskSample
  • SMS message send, receive, and SIM management
    • C++
  • Snap
    • C++
      • common
  • Splash screen
    • C++
      • common
  • StorageDataSource and GetVirtualizedFilesVector
    • C++
  • StreamSocket
    • C++
      • Common
      • sample-utils
  • Syndication
    • C++
      • common
  • Thread pool
    • C++
      • common
  • Toast notifications
    • C#,C++
      • NotificationsExtensions
  • Transcoding media
    • C++
      • common
  • Trial app and in-app purchase
    • C++
      • common
  • UI Automation core window provider
    • C++
  • UI contrast and settings
    • C++
      • common
  • User domain name
    • C++
      • common
  • USSD message management
    • C++
      • common
  • Web authentication broker
    • C++
      • common
  • Windows account authorization
    • C++
      • common
  • Windows Audio Session (WASAPI)
    • C++
      • common
  • Windows Store device app for camera
    • C#,C++
      • Wrapper
    • C++
      • Common
      • Wrapper
  • XAML accessibility
    • C++
      • common
  • XAML animation library
    • C++
      • common
  • XAML AppBar control
    • C++
      • common
      • Sample-Utils
  • XAML data binding
    • C++
      • Common
  • XAML Direct2D lighting effects
    • C++
  • XAML DirectX 3D shooting game
    • C++
  • XAML FlipView control
    • C++
      • common
  • XAML high contrast style
    • C++
      • common
  • XAML images
    • C++
      • common
  • XAML ListView and GridView essentials
    • C++
  • XAML personality animations
    • C++
      • common
      • SampleData
  • XAML Popup
    • C++
      • common
  • XAML scrolling, panning, and zooming
    • C++
  • XAML text display
    • C++
      • Common
  • XAML text editing
    • C++
      • Common
  • XAML two-dimensional transforms
    • C++
      • common
  • XAML user and custom controls
    • C++
      • common
  • XAML vector-based drawing
    • C++
      • common
  • XAML WebView control
    • C++
      • common
  • XAudio2 audio file playback
    • C++
  • XAudio2 audio stream effect
    • C++
  • XInput audio controller playback
    • C++
  • XInput game controller
    • C++
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/ Directory Reference

  • Accelerometer sensor

Accelerometer sensor Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/ Directory Reference

  • Accelerometer sensor

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/common/ Directory Reference

  • Accelerometer sensor
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/ Directory Reference

  • Account picture name

Account picture name Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/ Directory Reference

  • Account picture name

C++ Directory Reference

Directories

directory | common
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | GetAccountPicture.xaml.cpp [code]
file | GetAccountPicture.xaml.h [code]
file | GetUserDisplayName.xaml.cpp [code]
file | GetUserDisplayName.xaml.h [code]
file | GetUserFirstAndLastName.xaml.cpp [code]
file | GetUserFirstAndLastName.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SetAccountPicture.xaml.cpp [code]
file | SetAccountPicture.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/common/ Directory Reference

  • Account picture name
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/sample-utils/ Directory Reference

  • Account picture name
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/ Directory Reference

  • Animation metrics

Animation metrics Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/ Directory Reference

  • Animation metrics

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/common/ Directory Reference

  • Animation metrics
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/ Directory Reference

  • App package information

App package information Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/ Directory Reference

  • App package information

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/common/ Directory Reference

  • App package information
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/ Directory Reference

  • App settings

App settings Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/ Directory Reference

  • App settings

C++ Directory Reference

Directories

directory | common

Files

file | AddSettingsScenario.xaml.cpp [code]
file | AddSettingsScenario.xaml.h [code]
file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | DefaultScenario.xaml.cpp [code]
file | DefaultScenario.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/common/ Directory Reference

  • App settings
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/ Directory Reference

  • App tiles and badges

App tiles and badges Directory Reference

Directories

directory C#,C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/ Directory Reference

  • App tiles and badges
  • C#,C++

C#,C++ Directory Reference

Directories

directory | common
directory | NotificationsExtensions

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | EnableNotificationQueue.xaml.cpp [code]
file | EnableNotificationQueue.xaml.h [code]
file | Globalization.xaml.cpp [code]
file | Globalization.xaml.h [code]
file | ImageProtocols.xaml.cpp [code]
file | ImageProtocols.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | NotificationExpiration.xaml.cpp [code]
file | NotificationExpiration.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SendBadge.xaml.cpp [code]
file | SendBadge.xaml.h [code]
file | SendLocalImageTile.xaml.cpp [code]
file | SendLocalImageTile.xaml.h [code]
file | SendTextTile.xaml.cpp [code]
file | SendTextTile.xaml.h [code]
file | SendWebImageTile.xaml.cpp [code]
file | SendWebImageTile.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/common/ Directory Reference

  • App tiles and badges
  • C#,C++
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/NotificationsExtensions/ Directory Reference

  • App tiles and badges
  • C#,C++
  • NotificationsExtensions

NotificationsExtensions Directory Reference

Files

file Common.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/ Directory Reference

  • Application data

Application data Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/ Directory Reference

  • Application data

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | ClearScenario.xaml.cpp [code]
file | ClearScenario.xaml.h [code]
file | CompositeSettings.xaml.cpp [code]
file | CompositeSettings.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | DataChangedEvent.xaml.cpp [code]
file | DataChangedEvent.xaml.h [code]
file | Files.xaml.cpp [code]
file | Files.xaml.h [code]
file | HighPriority.xaml.cpp [code]
file | HighPriority.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | Msappdata.xaml.cpp [code]
file | Msappdata.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SettingContainer.xaml.cpp [code]
file | SettingContainer.xaml.h [code]
file | Settings.xaml.cpp [code]
file | Settings.xaml.h [code]
file | SetVersion.xaml.cpp [code]
file | SetVersion.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/common/ Directory Reference

  • Application data
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/ Directory Reference

  • Application resources and localization

Application resources and localization Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/ Directory Reference

  • Application resources and localization

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario10.xaml.cpp [code]
file | Scenario10.xaml.h [code]
file | Scenario11.xaml.cpp [code]
file | Scenario11.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
file | Scenario6.xaml.cpp [code]
file | Scenario6.xaml.h [code]
file | Scenario7.xaml.cpp [code]
file | Scenario7.xaml.h [code]
file | Scenario8.xaml.cpp [code]
file | Scenario8.xaml.h [code]
file | Scenario9.xaml.cpp [code]
file | Scenario9.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/ Directory Reference

  • Association launching

Association launching Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ Directory Reference

  • Association launching

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | LaunchFileInput.xaml.cpp [code]
file | LaunchFileInput.xaml.h [code]
file | LaunchFileOutput.xaml.cpp [code]
file | LaunchFileOutput.xaml.h [code]
file | LaunchUriInput.xaml.cpp [code]
file | LaunchUriInput.xaml.h [code]
file | LaunchUriOutput.xaml.cpp [code]
file | LaunchUriOutput.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ReceiveFileInput.xaml.cpp [code]
file | ReceiveFileInput.xaml.h [code]
file | ReceiveFileOutput.xaml.cpp [code]
file | ReceiveFileOutput.xaml.h [code]
file | ReceiveUriInput.xaml.cpp [code]
file | ReceiveUriInput.xaml.h [code]
file | ReceiveUriOutput.xaml.cpp [code]
file | ReceiveUriOutput.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/ Directory Reference

  • AtomPub

AtomPub Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/ Directory Reference

  • AtomPub

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/common/ Directory Reference

  • AtomPub
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/ Directory Reference

  • Background task

Background task Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/ Directory Reference

  • Background task

C++ Directory Reference

Directories

directory | BackgroundTask
directory | Tasks
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/ Directory Reference

  • Background task
  • BackgroundTask

BackgroundTask Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleBackgroundTask.xaml.cpp [code]
file | SampleBackgroundTask.xaml.h [code]
file | ServicingCompleteTask.xaml.h [code]
file | TimeTriggeredTask.xaml.cpp [code]
file | TimeTriggeredTask.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/common/ Directory Reference

  • Background task
  • BackgroundTask
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/ Directory Reference

  • Background task
  • Tasks

Tasks Directory Reference

Files

file | pch.cpp [code]
file | pch.h [code]
file | SampleBackgroundTask.cpp [code]
file | SampleBackgroundTask.h [code]
file | ServicingComplete.cpp [code]
file | ServicingComplete.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/ Directory Reference

  • Background Transfer

Background Transfer Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/ Directory Reference

  • Background Transfer

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/common/ Directory Reference

  • Background Transfer
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/ Directory Reference

  • Bing Maps Trip Optimizer

Bing Maps Trip Optimizer Directory Reference

Directories

directory C++,JavaScript
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/ Directory Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript

C++,JavaScript Directory Reference

Directories

directory cpp
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/ Directory Reference

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp

cpp Directory Reference

Files

file | AntSystem.cpp [code]
file | AntSystem.h [code]
file | HttpRequest.cpp [code]
file | HttpRequest.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | TripOptimizer.cpp [code]
file | TripOptimizer.h [code]
file | TripOptimizerImpl.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/ Directory Reference

  • Bluetooth call control

Bluetooth call control Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/ Directory Reference

  • Bluetooth call control

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PhoneCall.xaml.cpp [code]
file | PhoneCall.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/common/ Directory Reference

  • Bluetooth call control
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/ Directory Reference

  • Calendar details and math

Calendar details and math Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/ Directory Reference

  • Calendar details and math

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CalendarEnumerationAndMath.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | DisplayCalendarData.xaml.cpp [code]
file | DisplayCalendarData.xaml.h [code]
file | DisplayCalendarStatistics.xaml.cpp [code]
file | DisplayCalendarStatistics.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/common/ Directory Reference

  • Calendar details and math
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/ Directory Reference

  • CameraCaptureUI

CameraCaptureUI Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/ Directory Reference

  • CameraCaptureUI

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CapturePhoto.xaml.cpp [code]
file | CapturePhoto.xaml.h [code]
file | CaptureVideo.xaml.cpp [code]
file | CaptureVideo.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/common/ Directory Reference

  • CameraCaptureUI
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/ Directory Reference

  • CameraOptionsUI

CameraOptionsUI Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/ Directory Reference

  • CameraOptionsUI

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ShowOptionsUI.xaml.cpp [code]
file | ShowOptionsUI.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/common/ Directory Reference

  • CameraOptionsUI
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/ Directory Reference

  • Certificate enrollment

Certificate enrollment Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/ Directory Reference

  • Certificate enrollment

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | HttpRequest.cpp [code]
file | HttpRequest.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario_Enroll.xaml.cpp [code]
file | Scenario_Enroll.xaml.h [code]
file | Scenario_Import.xaml.cpp [code]
file | Scenario_Import.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/common/ Directory Reference

  • Certificate enrollment
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/ Directory Reference

  • Check if current session is remote

Check if current session is remote Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/ Directory Reference

  • Check if current session is remote

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | RemoteSession.xaml.cpp [code]
file | RemoteSession.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/common/ Directory Reference

  • Check if current session is remote
  • common

common Directory Reference

Files

file LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/ Directory Reference

  • Clipboard app

Clipboard app Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/ Directory Reference

  • Clipboard app

C++ Directory Reference

Directories

directory | common
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | constants.cpp [code]
file | constants.h [code]
file | CopyFiles.xaml.cpp [code]
file | CopyFiles.xaml.h [code]
file | CopyImage.xaml.cpp [code]
file | CopyImage.xaml.h [code]
file | CopyText.xaml.cpp [code]
file | CopyText.xaml.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | Others.xaml.cpp [code]
file | Others.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/common/ Directory Reference

  • Clipboard app
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/sample-utils/ Directory Reference

  • Clipboard app
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/ Directory Reference

  • Compass sensor

Compass sensor Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/ Directory Reference

  • Compass sensor

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/common/ Directory Reference

  • Compass sensor
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/ Directory Reference

  • Compression

Compression Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/ Directory Reference

  • Compression

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CompressionUtils.cpp [code]
file | CompressionUtils.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/common/ Directory Reference

  • Compression
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/ Directory Reference

  • Configure keys for media

Configure keys for media Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/ Directory Reference

  • Configure keys for media

C++ Directory Reference

Directories

directory | common
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | mediabuttons.xaml.cpp [code]
file | mediabuttons.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/common/ Directory Reference

  • Configure keys for media
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/sample-utils/ Directory Reference

  • Configure keys for media
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/ Directory Reference

  • Connecting with WebSockets

Connecting with WebSockets Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/ Directory Reference

  • Connecting with WebSockets

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/common/ Directory Reference

  • Connecting with WebSockets
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/ Directory Reference

  • Contact Picker app

Contact Picker app Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ Directory Reference

  • Contact Picker app

C++ Directory Reference

Directories

directory | Common
directory | Sample-Utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | ContactPickerPage.xaml.cpp [code]
file | ContactPickerPage.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | MainPagePicker.xaml.cpp [code]
file | MainPagePicker.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioMultiple.xaml.cpp [code]
file | ScenarioMultiple.xaml.h [code]
file | ScenarioSingle.xaml.cpp [code]
file | ScenarioSingle.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Common/ Directory Reference

  • Contact Picker app
  • Common

Common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Sample-Utils/ Directory Reference

  • Contact Picker app
  • Sample-Utils

Sample-Utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/ Directory Reference

  • Context menu

Context menu Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/ Directory Reference

  • Context menu

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/common/ Directory Reference

  • Context menu
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/ Directory Reference

  • ControlChannelTrigger StreamSocket

ControlChannelTrigger StreamSocket Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/C++/ Directory Reference

  • ControlChannelTrigger StreamSocket

C++ Directory Reference

Directories

directory Background
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/C++/Background/ Directory Reference

  • ControlChannelTrigger StreamSocket
  • Background

Background Directory Reference

Files

file | Background.cpp [code]
file | Background.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamWebSocket/ Directory Reference

  • ControlChannelTrigger StreamWebSocket

ControlChannelTrigger StreamWebSocket Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamWebSocket/C++/ Directory Reference

  • ControlChannelTrigger StreamWebSocket

C++ Directory Reference

Directories

directory Background
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamWebSocket/C++/Background/ Directory Reference

  • ControlChannelTrigger StreamWebSocket
  • Background

Background Directory Reference

Files

file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/ Directory Reference

  • ControlChannelTrigger XMLHTTPRequest

ControlChannelTrigger XMLHTTPRequest Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/C++/ Directory Reference

  • ControlChannelTrigger XMLHTTPRequest

C++ Directory Reference

Directories

directory Background
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/C++/Background/ Directory Reference

  • ControlChannelTrigger XMLHTTPRequest
  • Background

Background Directory Reference

Files

file | Background.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/ Directory Reference

  • Credential locker

Credential locker Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/ Directory Reference

  • Credential locker

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/common/ Directory Reference

  • Credential locker
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/ Directory Reference

  • Credential picker

Credential picker Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ Directory Reference

  • Credential picker

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioInput3.xaml.cpp [code]
file | ScenarioInput3.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
file | ScenarioOutput3.xaml.cpp [code]
file | ScenarioOutput3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/ Directory Reference

  • CryptoWinRT

CryptoWinRT Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/ Directory Reference

  • CryptoWinRT

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario10.xaml.cpp [code]
file | Scenario10.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
file | Scenario6.xaml.cpp [code]
file | Scenario6.xaml.h [code]
file | Scenario7.xaml.cpp [code]
file | Scenario7.xaml.h [code]
file | Scenario8.xaml.cpp [code]
file | Scenario8.xaml.h [code]
file | Scenario9.xaml.cpp [code]
file | Scenario9.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/common/ Directory Reference

  • CryptoWinRT
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/ Directory Reference

  • Custom driver access

Custom driver access Directory Reference

Directories

directory | C#,C++
directory | C++
directory | C++,JavaScript
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/ Directory Reference

  • Custom driver access
  • C#,C++

C#,C++ Directory Reference

Directories

directory | app_cs
directory | DLL
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/ Directory Reference

  • Custom driver access
  • C#,C++
  • app_cs

app_cs Directory Reference

Directories

directory | common
directory | Properties

Files

file | App.xaml.cs [code]
file | Constants.cs [code]
file | DeviceList.cs [code]
file | MainPage.xaml.cs [code]
file | Scenario4_DeviceAsync.xaml.cs [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/common/ Directory Reference

  • Custom driver access
  • C#,C++
  • app_cs
  • common

common Directory Reference

Files

file LayoutAwarePage.cs [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/Properties/ Directory Reference

  • Custom driver access
  • C#,C++
  • app_cs
  • Properties

Properties Directory Reference

Files

file AssemblyInfo.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/ Directory Reference

  • Custom driver access
  • C#,C++
  • DLL

DLL Directory Reference

Files

file | fx2device.cpp [code]
file | fx2device.h [code]
file | public.h [code]
file | repeater.h [code]
file | support.h [code]
file | WUDFOsrUsbPublic.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/ Directory Reference

  • Custom driver access

C++ Directory Reference

Directories

directory | app_cpp
directory | DLL
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/ Directory Reference

  • Custom driver access
  • app_cpp

app_cpp Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | DeviceList.cpp [code]
file | DeviceList.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1_DeviceConnect.xaml.h [code]
file | Scenario3_DeviceEvents.xaml.cpp [code]
file | Scenario3_DeviceEvents.xaml.h [code]
file | Scenario4_DeviceAsync.xaml.cpp [code]
file | Scenario4_DeviceAsync.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/common/ Directory Reference

  • Custom driver access
  • app_cpp
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/ Directory Reference

  • Custom driver access
  • DLL

DLL Directory Reference

Files

file | fx2device.cpp [code]
file | fx2device.h [code]
file | public.h [code]
file | repeater.h [code]
file | support.h [code]
file | WUDFOsrUsbPublic.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/ Directory Reference

  • Custom driver access
  • C++,JavaScript

C++,JavaScript Directory Reference

Directories

directory DLL
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/ Directory Reference

  • Custom driver access
  • C++,JavaScript
  • DLL

DLL Directory Reference

Files

file | fx2device.cpp [code]
file | fx2device.h [code]
file | public.h [code]
file | repeater.h [code]
file | support.h [code]
file | WUDFOsrUsbPublic.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/ Directory Reference

  • DatagramSocket

DatagramSocket Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/ Directory Reference

  • DatagramSocket

C++ Directory Reference

Directories

directory | Common
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Common/ Directory Reference

  • DatagramSocket
  • Common

Common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/sample-utils/ Directory Reference

  • DatagramSocket
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/ Directory Reference

  • Date and time formatting

Date and time formatting Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/ Directory Reference

  • Date and time formatting

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | LongAndShortFormats.xaml.cpp [code]
file | LongAndShortFormats.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | OverrideSettings.xaml.cpp [code]
file | OverrideSettings.xaml.h [code]
file | ParametrizedTemplate.xaml.cpp [code]
file | ParametrizedTemplate.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | StringTemplate.xaml.cpp [code]
file | StringTemplate.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/common/ Directory Reference

  • Date and time formatting
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/ Directory Reference

  • Device app for printers SDK

Device app for printers SDK Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/ Directory Reference

  • Device app for printers SDK

C++ Directory Reference

Directories

directory | BackgroundTask
directory | DeviceAppForPrinters
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/BackgroundTask/ Directory Reference

  • Device app for printers SDK
  • BackgroundTask

BackgroundTask Directory Reference

Files

file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/DeviceAppForPrinters/ Directory Reference

  • Device app for printers SDK
  • DeviceAppForPrinters

DeviceAppForPrinters Directory Reference

Files

file | App.xaml.h [code]
file | Constants.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/ Directory Reference

  • Device auto rotation preferences

Device auto rotation preferences Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/ Directory Reference

  • Device auto rotation preferences

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | Landscape.xaml.cpp [code]
file | Landscape.xaml.h [code]
file | LandscapeFlipped.xaml.cpp [code]
file | LandscapeFlipped.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | None.xaml.cpp [code]
file | None.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Portrait.xaml.cpp [code]
file | Portrait.xaml.h [code]
file | PortraitFlipped.xaml.cpp [code]
file | PortraitFlipped.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/common/ Directory Reference

  • Device auto rotation preferences
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/ Directory Reference

  • Device enumeration

Device enumeration Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/ Directory Reference

  • Device enumeration

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | Containers.xaml.cpp [code]
file | Containers.xaml.h [code]
file | Interfaces.xaml.cpp [code]
file | Interfaces.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/common/ Directory Reference

  • Device enumeration
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/ Directory Reference

  • Direct2D 3D transform effect

Direct2D 3D transform effect Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/ Directory Reference

  • Direct2D 3D transform effect

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | D2D3DTransformsRenderer.cpp [code]
file | D2D3DTransformsRenderer.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PersistentState.cpp [code]
file | PersistentState.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D and DirectWrite animated text on a path/ Directory Reference

  • Direct2D and DirectWrite animated text on a path

Direct2D and DirectWrite animated text on a path Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D and DirectWrite animated text on a path/C++/ Directory Reference

  • Direct2D and DirectWrite animated text on a path

C++ Directory Reference

Files

file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/ Directory Reference

  • Direct2D animated text

Direct2D animated text Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/ Directory Reference

  • Direct2D animated text

C++ Directory Reference

Files

file | D2DTextAnimation.cpp [code]
file | D2DTextAnimation.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/ Directory Reference

  • Direct2D animation

Direct2D animation Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/ Directory Reference

  • Direct2D animation

C++ Directory Reference

Files

file | animation.h [code]
file | D2DBasicAnimation.cpp [code]
file | D2DBasicAnimation.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/ Directory Reference

  • Direct2D basic image effects

Direct2D basic image effects Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/ Directory Reference

  • Direct2D basic image effects

C++ Directory Reference

Files

file | D2DEffectsHelloWorld.cpp [code]
file | D2DEffectsHelloWorld.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/ Directory Reference

  • Direct2D command list

Direct2D command list Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/ Directory Reference

  • Direct2D command list

C++ Directory Reference

Files

file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | CommandListSample.cpp [code]
file | CommandListSample.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/ Directory Reference

  • Direct2D composite effect modes

Direct2D composite effect modes Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/ Directory Reference

  • Direct2D composite effect modes

C++ Directory Reference

Files

file | CompositeModes.cpp [code]
file | CompositeModes.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/ Directory Reference

  • Direct2D convolve matrix effect

Direct2D convolve matrix effect Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/ Directory Reference

  • Direct2D convolve matrix effect

C++ Directory Reference

Files

file | ConvolutionKernels.h [code]
file | ConvolveMatrixEffect.cpp [code]
file | ConvolveMatrixEffect.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/ Directory Reference

  • Direct2D custom image effects

Direct2D custom image effects Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ Directory Reference

  • Direct2D custom image effects

C++ Directory Reference

Directories

directory | ComputeShader
directory | PixelShader
directory | VertexShader
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/ Directory Reference

  • Direct2D custom image effects
  • ComputeShader

ComputeShader Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/ Directory Reference

  • Direct2D custom image effects
  • PixelShader

PixelShader Directory Reference

Files

file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | RippleEffect.cpp [code]
file | RippleEffect.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/ Directory Reference

  • Direct2D custom image effects
  • VertexShader

VertexShader Directory Reference

Files

file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | WaveEffect.cpp [code]
file | WaveEffect.h [code]
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/ Directory Reference

  • Direct2D effects on primitives

Direct2D effects on primitives Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/ Directory Reference

  • Direct2D effects on primitives

C++ Directory Reference

Files

file | D2DEffectsOnPrimitives.cpp [code]
file | D2DEffectsOnPrimitives.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/ Directory Reference

  • Direct2D geometry realization

Direct2D geometry realization Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/ Directory Reference

  • Direct2D geometry realization

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | FPSCounter.cpp [code]
file | FPSCounter.h [code]
file | GeometryRealizationPackage.cpp [code]
file | GeometryRealizationPackage.h [code]
file | GeometryRealizationSample.cpp [code]
file | GeometryRealizationSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/ Directory Reference

  • Direct2D interpolation modes

Direct2D interpolation modes Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/ Directory Reference

  • Direct2D interpolation modes

C++ Directory Reference

Files

file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | D2DInterpolationModes.cpp [code]
file | D2DInterpolationModes.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/ Directory Reference

  • Direct2D magazine app

Direct2D magazine app Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ Directory Reference

  • Direct2D magazine app

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | ContentImageSource.cpp [code]
file | ContentImageSource.h [code]
file | Design.cpp [code]
file | Design.h [code]
file | Document.cpp [code]
file | Document.h [code]
file | Element.cpp [code]
file | Element.h [code]
file | FontFileStream.cpp [code]
file | FontFileStream.h [code]
file | FontLoader.cpp [code]
file | FontLoader.h [code]
file | Image.cpp [code]
file | Image.h [code]
file | ImageFile.cpp [code]
file | ImageFile.h [code]
file | ImageFrame.cpp [code]
file | ImageFrame.h [code]
file | Layer.cpp [code]
file | Layer.h [code]
file | List.cpp [code]
file | List.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | Page.cpp [code]
file | Page.h [code]
file | PageModel.cpp [code]
file | PageModel.h [code]
file | PageRoll.cpp [code]
file | PageRoll.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Rectangle.cpp [code]
file | Rectangle.h [code]
file | Renderer.cpp [code]
file | Renderer.h [code]
file | Resource.cpp [code]
file | Resource.h [code]
file | Story.cpp [code]
file | Story.h [code]
file | Text.cpp [code]
file | Text.h [code]
file | TextFrame.cpp [code]
file | TextFrame.h [code]
file | TreeIterator.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/ Directory Reference

  • Direct2D perspective transform

Direct2D perspective transform Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/ Directory Reference

  • Direct2D perspective transform

C++ Directory Reference

Files

file | D2DPerspectiveTransform.cpp [code]
file | D2DPerspectiveTransform.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/ Directory Reference

  • Direct2D printing images and effects

Direct2D printing images and effects Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/ Directory Reference

  • Direct2D printing images and effects

C++ Directory Reference

Files

file | D2DPageRenderer.cpp [code]
file | D2DPageRenderer.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DocSource.cpp [code]
file | DocSource.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/ Directory Reference

  • Direct2D save to image file

Direct2D save to image file Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/ Directory Reference

  • Direct2D save to image file

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | SaveAsImageFileSample.cpp [code]
file | SaveAsImageFileSample.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/ Directory Reference

  • Direct2Dapp printing

Direct2Dapp printing Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/ Directory Reference

  • Direct2Dapp printing

C++ Directory Reference

Files

file | D2DPageRenderer.cpp [code]
file | D2DPageRenderer.h [code]
file | D2DPageRendererContext.cpp [code]
file | D2DPageRendererContext.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DocSource.cpp [code]
file | DocSource.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/ Directory Reference

  • Direct3D bump mapping

Direct3D bump mapping Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/ Directory Reference

  • Direct3D bump mapping

C++ Directory Reference

Files

file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | BumpMapping.cpp [code]
file | BumpMapping.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | LonLatController.cpp [code]
file | LonLatController.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/ Directory Reference

  • Direct3D HLSL fractal generator

Direct3D HLSL fractal generator Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/ Directory Reference

  • Direct3D HLSL fractal generator

C++ Directory Reference

Files

file | AutoThrottle.cpp [code]
file | AutoThrottle.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXFractal.cpp [code]
file | DirectXFractal.h [code]
file | DirectXSample.h [code]
file | DoublePrecisionMath.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/ Directory Reference

  • Direct3D post-processing effects

Direct3D post-processing effects Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/ Directory Reference

  • Direct3D post-processing effects

C++ Directory Reference

Files

file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | D3DPostProcessing.cpp [code]
file | D3DPostProcessing.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/ Directory Reference

  • Direct3D resource loading

Direct3D resource loading Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/ Directory Reference

  • Direct3D resource loading

C++ Directory Reference

Directories

directory | obj2vbo
directory | texconv

Files

file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | LonLatController.cpp [code]
file | LonLatController.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ResourceLoading.cpp [code]
file | ResourceLoading.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/obj2vbo/ Directory Reference

  • Direct3D resource loading
  • obj2vbo

obj2vbo Directory Reference

Files

file | BasicMath.h [code]
file | obj2vbo.cpp [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/ Directory Reference

  • Direct3D resource loading
  • texconv

texconv Directory Reference

Files

file | BC.cpp [code]
file | BC.h [code]
file | BC4BC5.cpp [code]
file | BC6HBC7.cpp [code]
file | DDS.h [code]
file | DirectXTex.h [code]
file | DirectXTex.inl [code]
file | DirectXTexCompress.cpp [code]
file | DirectXTexConvert.cpp [code]
file | DirectXTexD3D11.cpp [code]
file | DirectXTexDDS.cpp [code]
file | DirectXTexFlipRotate.cpp [code]
file | DirectXTexImage.cpp [code]
file | DirectXTexMipmaps.cpp [code]
file | DirectXTexMisc.cpp [code]
file | DirectXTexNormalMaps.cpp [code]
file | DirectXTexP.h [code]
file | DirectXTexResize.cpp [code]
file | DirectXTexTGA.cpp [code]
file | DirectXTexUtil.cpp [code]
file | DirectXTexWIC.cpp [code]
file | scoped.h [code]
file | Texconv.cpp [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/ Directory Reference

  • Direct3D sprite

Direct3D sprite Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/ Directory Reference

  • Direct3D sprite

C++ Directory Reference

Files

file | AutoThrottle.cpp [code]
file | AutoThrottle.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.h [code]
file | BasicSprites.cpp [code]
file | BasicSprites.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | SimpleSprites.cpp [code]
file | SimpleSprites.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/ Directory Reference

  • Direct3D stereoscopic 3D

Direct3D stereoscopic 3D Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/ Directory Reference

  • Direct3D stereoscopic 3D

C++ Directory Reference

Files

file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | Stereo3DMatrixHelper.cpp [code]
file | Stereo3DMatrixHelper.h [code]
file | StereoSimpleD3D.cpp [code]
file | StereoSimpleD3D.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/ Directory Reference

  • Direct3D tutorial

Direct3D tutorial Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/ Directory Reference

  • Direct3D tutorial

C++ Directory Reference

Directories

directory | Lesson1.Basics
directory | Lesson2.Triangles
directory | Lesson3.Cubes
directory | Lesson4.Textures
directory | Lesson5.Components
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson1.Basics/ Directory Reference

  • Direct3D tutorial
  • Lesson1.Basics

Lesson1.Basics Directory Reference

Files

file | DirectXSample.h [code]
file | Main.cpp [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/ Directory Reference

  • Direct3D tutorial
  • Lesson2.Triangles

Lesson2.Triangles Directory Reference

Files

file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | DirectXSample.h [code]
file | Main.cpp [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/ Directory Reference

  • Direct3D tutorial
  • Lesson3.Cubes

Lesson3.Cubes Directory Reference

Files

file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | DirectXSample.h [code]
file | Main.cpp [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/ Directory Reference

  • Direct3D tutorial
  • Lesson4.Textures

Lesson4.Textures Directory Reference

Files

file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | DirectXSample.h [code]
file | Main.cpp [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/ Directory Reference

  • Direct3D tutorial
  • Lesson5.Components

Lesson5.Components Directory Reference

Files

file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | Direct3DTutorial.cpp [code]
file | Direct3DTutorial.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/ Directory Reference

  • Direct3D-Direct2D interop

Direct3D-Direct2D interop Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/ Directory Reference

  • Direct3D-Direct2D interop

C++ Directory Reference

Files

file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | TextInterop.cpp [code]
file | TextInterop.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/ Directory Reference

  • DirectWrite custom text renderer

DirectWrite custom text renderer Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/ Directory Reference

  • DirectWrite custom text renderer

C++ Directory Reference

Files

file | CustomTextRenderer.cpp [code]
file | CustomTextRenderer.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DWriteCustomTextRenderer.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/ Directory Reference

  • DirectWrite font enumeration

DirectWrite font enumeration Directory Reference

Directories

directory C++,JavaScript
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/C++,JavaScript/ Directory Reference

  • DirectWrite font enumeration
  • C++,JavaScript

C++,JavaScript Directory Reference

Directories

directory cpp
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/C++,JavaScript/cpp/ Directory Reference

  • DirectWrite font enumeration
  • C++,JavaScript
  • cpp

cpp Directory Reference

Files

file | FontEnumerator.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/ Directory Reference

  • DirectWrite hello world

DirectWrite hello world Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/ Directory Reference

  • DirectWrite hello world

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DWriteHelloWorld.cpp [code]
file | DWriteHelloWorld.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/ Directory Reference

  • DirectWrite hit testing

DirectWrite hit testing Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/ Directory Reference

  • DirectWrite hit testing

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DWriteHitTesting.cpp [code]
file | DWriteHitTesting.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/ Directory Reference

  • DirectWrite inline object

DirectWrite inline object Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/ Directory Reference

  • DirectWrite inline object

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DWriteInlineObject.cpp [code]
file | DWriteInlineObject.h [code]
file | InlineImage.cpp [code]
file | InlineImage.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/ Directory Reference

  • DirectWrite paragraph text

DirectWrite paragraph text Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/ Directory Reference

  • DirectWrite paragraph text

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DWriteParagraphText.cpp [code]
file | DWriteParagraphText.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/ Directory Reference

  • DirectWrite vertical text

DirectWrite vertical text Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/ Directory Reference

  • DirectWrite vertical text

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DWriteVerticalText.cpp [code]
file | DWriteVerticalText.h [code]
file | FlowLayout.cpp [code]
file | FlowLayout.h [code]
file | FlowSink.cpp [code]
file | FlowSink.h [code]
file | FlowSource.cpp [code]
file | FlowSource.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | TextAnalysis.cpp [code]
file | TextAnalysis.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/ Directory Reference

  • DirectX 3D shooting game

DirectX 3D shooting game Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/ Directory Reference

  • DirectX 3D shooting game

C++ Directory Reference

Files

file | Animate.cpp [code]
file | Animate.h [code]
file | Audio.cpp [code]
file | Audio.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.h [code]
file | Camera.cpp [code]
file | Camera.h [code]
file | ConstantBuffers.h [code]
file | Cylinder.cpp [code]
file | Cylinder.h [code]
file | CylinderMesh.cpp [code]
file | CylinderMesh.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | Face.cpp [code]
file | Face.h [code]
file | FaceMesh.cpp [code]
file | FaceMesh.h [code]
file | GameConstants.h [code]
file | GameHud.cpp [code]
file | GameHud.h [code]
file | GameInfoOverlay.cpp [code]
file | GameInfoOverlay.h [code]
file | GameObject.cpp [code]
file | GameObject.h [code]
file | GameRenderer.cpp [code]
file | GameRenderer.h [code]
file | GameTimer.cpp [code]
file | GameTimer.h [code]
file | Level.cpp [code]
file | Level.h [code]
file | Level1.cpp [code]
file | Level1.h [code]
file | Level2.cpp [code]
file | Level2.h [code]
file | Level3.cpp [code]
file | Level3.h [code]
file | Level4.cpp [code]
file | Level4.h [code]
file | Level5.cpp [code]
file | Level5.h [code]
file | Level6.cpp [code]
file | Level6.h [code]
file | Material.cpp [code]
file | Material.h [code]
file | MediaReader.cpp [code]
file | MediaReader.h [code]
file | MeshObject.cpp [code]
file | MeshObject.h [code]
file | MoveLookController.cpp [code]
file | MoveLookController.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PersistentState.cpp [code]
file | PersistentState.h [code]
file | Simple3DGame.cpp [code]
file | Simple3DGame.h [code]
file | SoundEffect.cpp [code]
file | SoundEffect.h [code]
file | Sphere.cpp [code]
file | Sphere.h [code]
file | SphereMesh.cpp [code]
file | SphereMesh.h [code]
file | StereoProjection.cpp [code]
file | StereoProjection.h [code]
file | TargetTexture.cpp [code]
file | TargetTexture.h [code]
file | WorldMesh.cpp [code]
file | WorldMesh.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/ Directory Reference

  • DirectX marble maze game

DirectX marble maze game Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/ Directory Reference

  • DirectX marble maze game

C++ Directory Reference

Files

file | Audio.cpp [code]
file | Audio.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | Camera.cpp [code]
file | Camera.h [code]
file | Collision.cpp [code]
file | Collision.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | LoadScreen.cpp [code]
file | LoadScreen.h [code]
file | MarbleMaze.cpp [code]
file | MarbleMaze.h [code]
file | MediaStreamer.cpp [code]
file | MediaStreamer.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PersistentState.cpp [code]
file | PersistentState.h [code]
file | Physics.cpp [code]
file | Physics.h [code]
file | Primitives.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | SDKMesh.cpp [code]
file | SDKMesh.h [code]
file | UserInterface.cpp [code]
file | UserInterface.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/ Directory Reference

  • DirectX postcard app

DirectX postcard app Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/ Directory Reference

  • DirectX postcard app

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | EffectsFlyout.xaml.cpp [code]
file | EffectsFlyout.xaml.h [code]
file | ExtrudedTextRenderer.cpp [code]
file | ExtrudedTextRenderer.h [code]
file | Extruder.cpp [code]
file | Extruder.h [code]
file | ImageRenderer.cpp [code]
file | ImageRenderer.h [code]
file | InkRenderer.cpp [code]
file | InkRenderer.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | OutlineRenderer.cpp [code]
file | OutlineRenderer.h [code]
file | PaperFlyout.xaml.cpp [code]
file | PaperFlyout.xaml.h [code]
file | PaperFragment.cpp [code]
file | PaperFragment.h [code]
file | PaperRenderer.cpp [code]
file | PaperRenderer.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PointSnapper.cpp [code]
file | PointSnapper.h [code]
file | PostcardRenderer.cpp [code]
file | PostcardRenderer.h [code]
file | SignatureFlyout.xaml.cpp [code]
file | SignatureFlyout.xaml.h [code]
file | TextFlyout.xaml.cpp [code]
file | TextFlyout.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/ Directory Reference

  • DirectX swap chain implementation

DirectX swap chain implementation Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/ Directory Reference

  • DirectX swap chain implementation

C++ Directory Reference

Files

file | CoreWindowEvents.cpp [code]
file | CoreWindowEvents.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/ Directory Reference

  • DirectX touch input

DirectX touch input Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/ Directory Reference

  • DirectX touch input

C++ Directory Reference

Files

file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | MoveLookController.cpp [code]
file | MoveLookController.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | Simple3DTouch.cpp [code]
file | Simple3DTouch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/ Directory Reference

  • Display orientation

Display orientation Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/ Directory Reference

  • Display orientation

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/common/ Directory Reference

  • Display orientation
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/ Directory Reference

  • DXGI offer and reclaim resources

DXGI offer and reclaim resources Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/ Directory Reference

  • DXGI offer and reclaim resources

C++ Directory Reference

Files

file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | OfferReclaimAPI.cpp [code]
file | OfferReclaimAPI.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/ Directory Reference

  • DXGI swap chain rotation

DXGI swap chain rotation Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/ Directory Reference

  • DXGI swap chain rotation

C++ Directory Reference

Files

file | BasicCamera.cpp [code]
file | BasicCamera.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.cpp [code]
file | BasicShapes.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DxgiRotation.cpp [code]
file | DxgiRotation.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/ Directory Reference

  • EAS policies for mail clients

EAS policies for mail clients Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/ Directory Reference

  • EAS policies for mail clients

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/common/ Directory Reference

  • EAS policies for mail clients
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/ Directory Reference

  • Edge gesture invocation

Edge gesture invocation Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ Directory Reference

  • Edge gesture invocation

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/ Directory Reference

  • Extended Linguistic Services (ELS)

Extended Linguistic Services (ELS) Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/ Directory Reference

  • Extended Linguistic Services (ELS)
  • C++

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | elsutil.h [code]
file | LanguageDetection.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScriptDetection.xaml.cpp [code]
file | ScriptDetection.xaml.h [code]
file | Transliteration.xaml.cpp [code]
file | Transliteration.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/common/ Directory Reference

  • Extended Linguistic Services (ELS)
  • C++
  • common

common Directory Reference

Files

file LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/ Directory Reference

  • File access

File access Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/ Directory Reference

  • File access

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
file | Scenario6.xaml.cpp [code]
file | Scenario6.xaml.h [code]
file | Scenario7.xaml.cpp [code]
file | Scenario7.xaml.h [code]
file | Scenario8.xaml.cpp [code]
file | Scenario8.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/common/ Directory Reference

  • File access
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/ Directory Reference

  • File and folder thumbnail

File and folder thumbnail Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/ Directory Reference

  • File and folder thumbnail

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/common/ Directory Reference

  • File and folder thumbnail
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/ Directory Reference

  • File picker

File picker Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/ Directory Reference

  • File picker

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
file | Scenario6.xaml.cpp [code]
file | Scenario6.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/ Directory Reference

  • File picker
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/ Directory Reference

  • File picker contracts

File picker contracts Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/ Directory Reference

  • File picker contracts

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CachedFileUpdater_Local.xaml.cpp [code]
file | CachedFileUpdater_Local.xaml.h [code]
file | CachedFileUpdater_Remote.xaml.cpp [code]
file | CachedFileUpdater_Remote.xaml.h [code]
file | CachedFileUpdaterPage.xaml.cpp [code]
file | CachedFileUpdaterPage.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | FileOpenPicker_PickAppFile.xaml.cpp [code]
file | FileOpenPicker_PickAppFile.xaml.h [code]
file | FileOpenPicker_PickCachedFile.xaml.cpp [code]
file | FileOpenPicker_PickCachedFile.xaml.h [code]
file | FileOpenPicker_PickURLFile.xaml.cpp [code]
file | FileOpenPicker_PickURLFile.xaml.h [code]
file | FileOpenPickerPage.xaml.cpp [code]
file | FileOpenPickerPage.xaml.h [code]
file | FileSavePicker_FailToSave.xaml.cpp [code]
file | FileSavePicker_FailToSave.xaml.h [code]
file | FileSavePicker_SaveToAppStorage.xaml.h [code]
file | FileSavePicker_SaveToCachedFile.xaml.h [code]
file | FileSavePickerPage.xaml.cpp [code]
file | FileSavePickerPage.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | MainPage_CachedFile.xaml.cpp [code]
file | MainPage_CachedFile.xaml.h [code]
file | MainPage_PickFile.xaml.cpp [code]
file | MainPage_PickFile.xaml.h [code]
file | MainPage_SaveFile.xaml.cpp [code]
file | MainPage_SaveFile.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/common/ Directory Reference

  • File picker contracts
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/ Directory Reference

  • Folder enumeration

Folder enumeration Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/ Directory Reference

  • Folder enumeration

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/common/ Directory Reference

  • Folder enumeration
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/ Directory Reference

  • Geolocation

Geolocation Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/ Directory Reference

  • Geolocation

C++ Directory Reference

Directories

directory | backgroundtask
directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1_TrackPosition.xaml.cpp [code]
file | Scenario1_TrackPosition.xaml.h [code]
file | Scenario2_GetPosition.xaml.cpp [code]
file | Scenario2_GetPosition.xaml.h [code]
file | Scenario3_BackgroundTask.xaml.cpp [code]
file | Scenario3_BackgroundTask.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/backgroundtask/ Directory Reference

  • Geolocation
  • backgroundtask

backgroundtask Directory Reference

Files

file | LocationBackgroundTask.cpp [code]
file | LocationBackgroundTask.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/common/ Directory Reference

  • Geolocation
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | SuspensionManager.cpp [code]
file | SuspensionManager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/ Directory Reference

  • Getting started with C++ simple blog reader

Getting started with C++ simple blog reader Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/ Directory Reference

  • Getting started with C++ simple blog reader

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | DateConverter.h [code]
file | FeedData.cpp [code]
file | FeedData.h [code]
file | ItemsPage.xaml.h [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SplitPage.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/ Directory Reference

  • Globalization preferences

Globalization preferences Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/ Directory Reference

  • Globalization preferences

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | CurrentInputLanguage.xaml.cpp [code]
file | CurrentInputLanguage.xaml.h [code]
file | GeographicRegion.xaml.cpp [code]
file | GeographicRegion.xaml.h [code]
file | Language.xaml.cpp [code]
file | Language.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | UserPreferences.xaml.cpp [code]
file | UserPreferences.xaml.h [code]
file | Utilities.cpp [code]
file | Utilities.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/common/ Directory Reference

  • Globalization preferences
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/ Directory Reference

  • Gyrometer sensor

Gyrometer sensor Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/ Directory Reference

  • Gyrometer sensor

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/common/ Directory Reference

  • Gyrometer sensor
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/ Directory Reference

  • Hilo C++

Hilo C++ Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/ Directory Reference

  • Hilo C++

C++ Directory Reference

Directories

directory | CartoonEffect
directory | Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/ Directory Reference

  • Hilo C++
  • CartoonEffect

CartoonEffect Directory Reference

Files

file | AmpCartoon.cpp [code]
file | AmpCartoon.h [code]
file | AmpPixel.h [code]
file | FrameData.h [code]
file | FrameProcessing.cpp [code]
file | FrameProcessing.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PPLCartoon.cpp [code]
file | PPLCartoon.h [code]
file | targetver.h [code]
file | Utils.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ Directory Reference

  • Hilo C++
  • Hilo

Hilo Directory Reference

Directories

directory | Common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | BooleanToBrushConverter.cpp [code]
file | BooleanToBrushConverter.h [code]
file | CalendarExtensions.cpp [code]
file | CalendarExtensions.h [code]
file | CartoonizeImageView.xaml.cpp [code]
file | CartoonizeImageView.xaml.h [code]
file | CartoonizeImageViewModel.cpp [code]
file | CartoonizeImageViewModel.h [code]
file | CropImageView.xaml.cpp [code]
file | CropImageView.xaml.h [code]
file | CropImageViewModel.cpp [code]
file | CropImageViewModel.h [code]
file | DebugLoggingExceptionPolicy.cpp [code]
file | DebugLoggingExceptionPolicy.h [code]
file | DelegateCommand.cpp [code]
file | DelegateCommand.h [code]
file | DesignTimeData.cpp [code]
file | DesignTimeData.h [code]
file | ExceptionPolicy.h [code]
file | ExceptionPolicyFactory.cpp [code]
file | ExceptionPolicyFactory.h [code]
file | ExifExtensions.cpp [code]
file | ExifExtensions.h [code]
file | FileSizeConverter.cpp [code]
file | FileSizeConverter.h [code]
file | FileSystemRepository.cpp [code]
file | FileSystemRepository.h [code]
file | HiloCommonDefinitions.h [code]
file | HiloPage.cpp [code]
file | HiloPage.h [code]
file | HubGroupType.h [code]
file | HubPhotoGroup.cpp [code]
file | HubPhotoGroup.h [code]
file | ImageBase.cpp [code]
file | ImageBase.h [code]
file | ImageBrowserView.xaml.cpp [code]
file | ImageBrowserView.xaml.h [code]
file | ImageBrowserViewModel.cpp [code]
file | ImageBrowserViewModel.h [code]
file | ImageNavigationData.cpp [code]
file | ImageNavigationData.h [code]
file | ImageUtilities.cpp [code]
file | ImageUtilities.h [code]
file | ImageView.xaml.cpp [code]
file | ImageView.xaml.h [code]
file | ImageViewModel.cpp [code]
file | ImageViewModel.h [code]
file | IMonthBlock.h [code]
file | IPhoto.h [code]
file | IPhotoGroup.h [code]
file | IResizable.h [code]
file | IResourceLoader.h [code]
file | IYearGroup.h [code]
file | LocalResourceLoader.cpp [code]
file | LocalResourceLoader.h [code]
file | MainHubView.xaml.cpp [code]
file | MainHubView.xaml.h [code]
file | MainHubViewModel.cpp [code]
file | MainHubViewModel.h [code]
file | MonthBlock.cpp [code]
file | MonthBlock.h [code]
file | MonthGroup.cpp [code]
file | MonthGroup.h [code]
file | NullPhotoGroup.h [code]
file | ObservableQuery.h [code]
file | PageType.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Photo.cpp [code]
file | Photo.h [code]
file | PhotoCache.cpp [code]
file | PhotoCache.h [code]
file | PhotoPathComparer.cpp [code]
file | PhotoPathComparer.h [code]
file | QueryChange.h [code]
file | RandomPhotoSelector.cpp [code]
file | RandomPhotoSelector.h [code]
file | Repository.h [code]
file | RotateImageView.xaml.cpp [code]
file | RotateImageView.xaml.h [code]
file | RotateImageViewModel.cpp [code]
file | RotateImageViewModel.h [code]
file | TaskExceptionsExtensions.h [code]
file | TaskExtensions.cpp [code]
file | TaskExtensions.h [code]
file | ThumbnailGenerator.cpp [code]
file | ThumbnailGenerator.h [code]
file | TileUpdateScheduler.cpp [code]
file | TileUpdateScheduler.h [code]
file | VariableGridView.cpp [code]
file | VariableGridView.h [code]
file | ViewModelBase.cpp [code]
file | ViewModelBase.h [code]
file | ViewModelLocator.cpp [code]
file | ViewModelLocator.h [code]
file | WideFiveImageTile.cpp [code]
file | WideFiveImageTile.h [code]
file | YearGroup.cpp [code]
file | YearGroup.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/ Directory Reference

  • Hilo C++
  • Hilo
  • Common

Common Directory Reference

Files

file | BindableBase.cpp [code]
file | BindableBase.h [code]
file | BooleanNegationConverter.cpp [code]
file | BooleanNegationConverter.h [code]
file | BooleanToVisibilityConverter.cpp [code]
file | BooleanToVisibilityConverter.h [code]
file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | RichTextColumns.cpp [code]
file | RichTextColumns.h [code]
file | SuspensionManager.cpp [code]
file | SuspensionManager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/ Directory Reference

  • HomeGroup app

HomeGroup app Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/ Directory Reference

  • HomeGroup app

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | HomeGroupAdvancedSearch.xaml.cpp [code]
file | HomeGroupAdvancedSearch.xaml.h [code]
file | HomeGroupPickerScenario.xaml.cpp [code]
file | HomeGroupPickerScenario.xaml.h [code]
file | HomeGroupVideoStream.xaml.cpp [code]
file | HomeGroupVideoStream.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SearchHomeGroup.xaml.cpp [code]
file | SearchHomeGroup.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/common/ Directory Reference

  • HomeGroup app
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/ Directory Reference

  • HttpClient

HttpClient Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/ Directory Reference

  • HttpClient

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | HttpRequest.cpp [code]
file | HttpRequest.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/common/ Directory Reference

  • HttpClient
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/ Directory Reference

  • Inclinometer sensor

Inclinometer sensor Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/ Directory Reference

  • Inclinometer sensor

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/common/ Directory Reference

  • Inclinometer sensor
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/ Directory Reference

  • Input Device capabilities

Input Device capabilities Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/ Directory Reference

  • Input Device capabilities

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | cppsamplesutils.h [code]
file | Keyboard.xaml.cpp [code]
file | Keyboard.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | Mouse.xaml.cpp [code]
file | Mouse.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Pointer.xaml.cpp [code]
file | Pointer.xaml.h [code]
file | Touch.xaml.cpp [code]
file | Touch.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/common/ Directory Reference

  • Input Device capabilities
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/ Directory Reference

  • Input Manipulations and gestures (C++)

Input Manipulations and gestures (C++) Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/ Directory Reference

  • Input Manipulations and gestures (C++)
  • C++

C++ Directory Reference

Files

file | BackgroundObject.cpp [code]
file | BackgroundObject.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | DrawingObject.cpp [code]
file | DrawingObject.h [code]
file | ManipulatableObject.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/ Directory Reference

  • Input Simplified ink

Input Simplified ink Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/ Directory Reference

  • Input Simplified ink

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | simpleInk.cpp [code]
file | simpleInk.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/ Directory Reference

  • Input Touch hit testing

Input Touch hit testing Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/ Directory Reference

  • Input Touch hit testing

C++ Directory Reference

Files

file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Program.cpp [code]
file | Program.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | Shape.cpp [code]
file | Shape.h [code]
file | ShapesPuzzle.cpp [code]
file | ShapesPuzzle.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/ Directory Reference

  • Input Touch keyboard

Input Touch keyboard Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/ Directory Reference

  • Input Touch keyboard

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | Launch.xaml.cpp [code]
file | Launch.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | NonTouchableTextBlock.xaml.cpp [code]
file | NonTouchableTextBlock.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | TouchableTextBlock.xaml.cpp [code]
file | TouchableTextBlock.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/common/ Directory Reference

  • Input Touch keyboard
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/ Directory Reference

  • Input Touch keyboard text input

Input Touch keyboard text input Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/ Directory Reference

  • Input Touch keyboard text input

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScopedViews.xaml.cpp [code]
file | ScopedViews.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/common/ Directory Reference

  • Input Touch keyboard text input
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/ Directory Reference

  • IXmlReader and IXmlWriter XML data readwrite

IXmlReader and IXmlWriter XML data readwrite Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/ Directory Reference

  • IXmlReader and IXmlWriter XML data readwrite

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/ Directory Reference

  • Language font mapping

Language font mapping Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ Directory Reference

  • Language font mapping

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | LocalCache.cpp [code]
file | LocalCache.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/ Directory Reference

  • LightSensor

LightSensor Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/ Directory Reference

  • LightSensor

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/common/ Directory Reference

  • LightSensor
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/ Directory Reference

  • Lock screen apps

Lock screen apps Directory Reference

Directories

directory C#,C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ Directory Reference

  • Lock screen apps
  • C#,C++

C#,C++ Directory Reference

Directories

directory | NotificationsExtensions

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioInput3.xaml.cpp [code]
file | ScenarioInput3.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
file | ScenarioOutput3.xaml.cpp [code]
file | ScenarioOutput3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/NotificationsExtensions/ Directory Reference

  • Lock screen apps
  • C#,C++
  • NotificationsExtensions

NotificationsExtensions Directory Reference

Files

file | BadgeContent.cs [code]
file | Common.cs [code]
file | TileContent.cs [code]
file | ToastContent.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/ Directory Reference

  • Lock screen personalization

Lock screen personalization Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/ Directory Reference

  • Lock screen personalization

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SetLockscreenImage.xaml.cpp [code]
file | SetLockscreenImage.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/common/ Directory Reference

  • Lock screen personalization
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/ Directory Reference

  • Media capture using capture device

Media capture using capture device Directory Reference

Directories

directory | C#,C++
directory | C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C#,C++/ Directory Reference

  • Media capture using capture device
  • C#,C++

C#,C++ Directory Reference

Files

file | App.xaml.cs [code]
file | AudioCapture.xaml.cs [code]
file | BasicCapture.xaml.cs [code]
file | Constants.cs [code]
file | MainPage.xaml.cs [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/ Directory Reference

  • Media capture using capture device

C++ Directory Reference

Directories

directory | common

Files

file | AdvancedCapture.xaml.cpp [code]
file | AdvancedCapture.xaml.h [code]
file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | AudioCapture.xaml.cpp [code]
file | AudioCapture.xaml.h [code]
file | BasicCapture.xaml.cpp [code]
file | BasicCapture.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/common/ Directory Reference

  • Media capture using capture device
  • common

common Directory Reference

Files

file LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/ Directory Reference

  • Media engine native C++ video playback

Media engine native C++ video playback Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/ Directory Reference

  • Media engine native C++ video playback

C++ Directory Reference

Files

file | common.h [code]
file | d3dmanagerlock.hxx [code]
file | frameworkview.cpp [code]
file | frameworkview.h [code]
file | main.cpp [code]
file | meplayer.cpp [code]
file | meplayer.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | videoview.cpp [code]
file | videoview.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/ Directory Reference

  • Media extensions

Media extensions Directory Reference

Directories

directory | C#,C++
directory | C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ Directory Reference

  • Media extensions
  • C#,C++

C#,C++ Directory Reference

Directories

directory | MediaExtensions
directory | Properties
directory | Sample-Utils

Files

file | App.xaml.cs [code]
file | MainPage.xaml.cs [code]
file | ScenarioInput1.xaml.cs [code]
file | ScenarioInput2.xaml.cs [code]
file | ScenarioInput3.xaml.cs [code]
file | ScenarioInput4.xaml.cs [code]
file | ScenarioList.xaml.cs [code]
file | ScenarioOutput1.xaml.cs [code]
file | ScenarioOutput2.xaml.cs [code]
file | ScenarioOutput3.xaml.cs [code]
file | ScenarioOutput4.xaml.cs [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/ Directory Reference

  • Media extensions
  • C#,C++
  • MediaExtensions

MediaExtensions Directory Reference

Directories

directory | Common
directory | Grayscale
directory | Invert
directory | Mpeg1Decoder
directory | Mpeg1Source
directory | Polar
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Common/ Directory Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Common

Common Directory Reference

Files

file | AsyncCB.h [code]
file | BufferLock.h [code]
file | CritSec.h [code]
file | LinkList.h [code]
file | OpQueue.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Grayscale/ Directory Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Grayscale

Grayscale Directory Reference

Files

file | dllmain.cpp [code]
file | Grayscale.cpp [code]
file | Grayscale.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/ Directory Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert

Invert Directory Reference

Files

file | CopyModule.h [code]
file | dllmain.cpp [code]
file | Invert.cpp [code]
file | Invert.h [code]
file | InvertModule.cpp [code]
file | InvertModule.h [code]
file | TextureLock.h [code]
file | VideoBufferLock.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/ Directory Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Decoder

Mpeg1Decoder Directory Reference

Files

file | decoder.cpp [code]
file | decoder.h [code]
file | dll.cpp [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/ Directory Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source

Mpeg1Source Directory Reference

Files

file | dllmain.cpp [code]
file | MPEG1Src.cpp [code]
file | MPEG1Src.h [code]
file | Parse.cpp [code]
file | Parse.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Polar/ Directory Reference

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Polar

Polar Directory Reference

Files

file | dllmain.cpp [code]
file | PolarEffect.cpp [code]
file | PolarEffect.h [code]
file | PolarTransform.idl [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/Properties/ Directory Reference

  • Media extensions
  • C#,C++
  • Properties

Properties Directory Reference

Files

file AssemblyInfo.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/Sample-Utils/ Directory Reference

  • Media extensions
  • C#,C++
  • Sample-Utils

Sample-Utils Directory Reference

Files

file | Constants.cs [code]
file | SuspensionManager.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ Directory Reference

  • Media extensions

C++ Directory Reference

Directories

directory | MediaExtensions

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioInput3.xaml.cpp [code]
file | ScenarioInput3.xaml.h [code]
file | ScenarioInput4.xaml.cpp [code]
file | ScenarioInput4.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
file | ScenarioOutput3.xaml.cpp [code]
file | ScenarioOutput3.xaml.h [code]
file | ScenarioOutput4.xaml.cpp [code]
file | ScenarioOutput4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/ Directory Reference

  • Media extensions
  • MediaExtensions

MediaExtensions Directory Reference

Directories

directory | Common
directory | GeometricSource
directory | Grayscale
directory | Invert
directory | Mpeg1Decoder
directory | Mpeg1Source
directory | Polar
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/ Directory Reference

  • Media extensions
  • MediaExtensions
  • Common

Common Directory Reference

Files

file | AsyncCB.h [code]
file | BufferLock.h [code]
file | CritSec.h [code]
file | LinkList.h [code]
file | OpQueue.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/GeometricSource/ Directory Reference

  • Media extensions
  • MediaExtensions
  • GeometricSource

GeometricSource Directory Reference

Files

file | dllmain.cpp [code]
file | pch.cpp [code]
file | StdAfx.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Grayscale/ Directory Reference

  • Media extensions
  • MediaExtensions
  • Grayscale

Grayscale Directory Reference

Files

file | dllmain.cpp [code]
file | Grayscale.cpp [code]
file | Grayscale.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/ Directory Reference

  • Media extensions
  • MediaExtensions
  • Invert

Invert Directory Reference

Files

file | CopyModule.h [code]
file | dllmain.cpp [code]
file | Invert.cpp [code]
file | Invert.h [code]
file | InvertModule.cpp [code]
file | InvertModule.h [code]
file | InvertTransform.idl [code]
file | TextureLock.h [code]
file | VideoBufferLock.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Decoder/ Directory Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Decoder

Mpeg1Decoder Directory Reference

Files

file | decoder.cpp [code]
file | decoder.h [code]
file | dll.cpp [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/ Directory Reference

  • Media extensions
  • MediaExtensions
  • Mpeg1Source

Mpeg1Source Directory Reference

Files

file | dllmain.cpp [code]
file | MPEG1Source.idl [code]
file | MPEG1Src.cpp [code]
file | MPEG1Src.h [code]
file | MPEG1Stream.cpp [code]
file | MPEG1Stream.h [code]
file | Parse.cpp [code]
file | Parse.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Polar/ Directory Reference

  • Media extensions
  • MediaExtensions
  • Polar

Polar Directory Reference

Files

file | dllmain.cpp [code]
file | PolarEffect.cpp [code]
file | PolarEffect.h [code]
file | PolarTransform.idl [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/ Directory Reference

  • Media Play To

Media Play To Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/ Directory Reference

  • Media Play To

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/common/ Directory Reference

  • Media Play To
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/ Directory Reference

  • Media Server client

Media Server client Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/ Directory Reference

  • Media Server client

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | LocateVideo.xaml.cpp [code]
file | LocateVideo.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/common/ Directory Reference

  • Media Server client
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/ Directory Reference

  • MediaStreamSource media extension

MediaStreamSource media extension Directory Reference

Directories

directory C#,C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/ Directory Reference

  • MediaStreamSource media extension
  • C#,C++

C#,C++ Directory Reference

Files

file | App.xaml.cs [code]
file | AudioSource.xaml.cs [code]
file | Constants.cs [code]
file | MainPage.xaml.cs [code]
file | PcmSource.cs [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/ Directory Reference

  • Message dialog

Message dialog Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/ Directory Reference

  • Message dialog

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CancelCommand.xaml.cpp [code]
file | CancelCommand.xaml.h [code]
file | CompletedCallback.xaml.cpp [code]
file | CompletedCallback.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | CustomCommand.xaml.cpp [code]
file | CustomCommand.xaml.h [code]
file | DefaultCloseCommand.xaml.cpp [code]
file | DefaultCloseCommand.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/common/ Directory Reference

  • Message dialog
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/ Directory Reference

  • Mobile broadband account provisioning

Mobile broadband account provisioning Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/ Directory Reference

  • Mobile broadband account provisioning

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ProvisionMno.xaml.cpp [code]
file | ProvisionMno.xaml.h [code]
file | UpdateCost.xaml.cpp [code]
file | UpdateCost.xaml.h [code]
file | UpdateUsage.xaml.cpp [code]
file | UpdateUsage.xaml.h [code]
file | Util.cpp [code]
file | Util.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/ Directory Reference

  • Network information

Network information Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/ Directory Reference

  • Network information

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | ConnectionProfileList.xaml.cpp [code]
file | ConnectionProfileList.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | InternetConnectionProfile.xaml.cpp [code]
file | InternetConnectionProfile.xaml.h [code]
file | LanId.xaml.cpp [code]
file | LanId.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | NetworkStatusChange.xaml.cpp [code]
file | NetworkStatusChange.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ProfileLocalUsageData.xaml.cpp [code]
file | ProfileLocalUsageData.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/common/ Directory Reference

  • Network information
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/ Directory Reference

  • Network status background

Network status background Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/ Directory Reference

  • Network status background

C++ Directory Reference

Directories

directory | NetworkStatusApp
directory | NetworkStatusTask
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/ Directory Reference

  • Network status background
  • NetworkStatusApp

NetworkStatusApp Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusTask/ Directory Reference

  • Network status background
  • NetworkStatusTask

NetworkStatusTask Directory Reference

Files

file | BackgroundTask.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/ Directory Reference

  • Number formatting and parsing

Number formatting and parsing Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/ Directory Reference

  • Number formatting and parsing

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | CurrencyFormatting.xaml.cpp [code]
file | CurrencyFormatting.xaml.h [code]
file | DecimalFormatting.xaml.cpp [code]
file | DecimalFormatting.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | NumberParsing.xaml.cpp [code]
file | NumberParsing.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/common/ Directory Reference

  • Number formatting and parsing
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/ Directory Reference

  • OrientationSensor

OrientationSensor Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/ Directory Reference

  • OrientationSensor

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/common/ Directory Reference

  • OrientationSensor
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/ Directory Reference

  • Playback Manager Companion

Playback Manager Companion Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/ Directory Reference

  • Playback Manager Companion

C++ Directory Reference

Directories

directory | common
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PlaybackControl.xaml.cpp [code]
file | PlaybackControl.xaml.h [code]
file | StreamTypeAlert.xaml.cpp [code]
file | StreamTypeAlert.xaml.h [code]
file | StreamTypeCommunications.xaml.cpp [code]
file | StreamTypeCommunications.xaml.h [code]
file | StreamTypeMedia.xaml.cpp [code]
file | StreamTypeMedia.xaml.h [code]
file | StreamTypeOther.xaml.cpp [code]
file | StreamTypeOther.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/common/ Directory Reference

  • Playback Manager Companion
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/sample-utils/ Directory Reference

  • Playback Manager Companion
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/ Directory Reference

  • Playback Manager msAudioCategory

Playback Manager msAudioCategory Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/ Directory Reference

  • Playback Manager msAudioCategory

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PlaybackControl.xaml.cpp [code]
file | PlaybackControl.xaml.h [code]
file | StreamTypeAlert.xaml.cpp [code]
file | StreamTypeAlert.xaml.h [code]
file | StreamTypeMedia.xaml.cpp [code]
file | StreamTypeMedia.xaml.h [code]
file | StreamTypeOther.xaml.cpp [code]
file | StreamTypeOther.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/common/ Directory Reference

  • Playback Manager msAudioCategory
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/ Directory Reference

  • Playlist

Playlist Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/ Directory Reference

  • Playlist

C++ Directory Reference

Directories

directory | common

Files

file | Add.xaml.cpp [code]
file | Add.xaml.h [code]
file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Clear.xaml.cpp [code]
file | Clear.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | Create.xaml.cpp [code]
file | Create.xaml.h [code]
file | Display.xaml.cpp [code]
file | Display.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Remove.xaml.cpp [code]
file | Remove.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/common/ Directory Reference

  • Playlist
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/ Directory Reference

  • PlayToReceiver

PlayToReceiver Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/ Directory Reference

  • PlayToReceiver

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | audiovideoptr.xaml.cpp [code]
file | audiovideoptr.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/common/ Directory Reference

  • PlayToReceiver
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/ Directory Reference

  • Portable device API

Portable device API Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/ Directory Reference

  • Portable device API

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | EventCallback.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | S1_DeviceProperties.xaml.cpp [code]
file | S1_DeviceProperties.xaml.h [code]
file | S2_Enumeration.xaml.cpp [code]
file | S2_Enumeration.xaml.h [code]
file | S3_SendToDevice.xaml.cpp [code]
file | S3_SendToDevice.xaml.h [code]
file | S4_GetFromDevice.xaml.cpp [code]
file | S4_GetFromDevice.xaml.h [code]
file | S5_Events.xaml.cpp [code]
file | S5_Events.xaml.h [code]
file | S6_DeviceStatus.xaml.cpp [code]
file | S6_DeviceStatus.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/common/ Directory Reference

  • Portable device API
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | SuspensionManager.cpp [code]
file | SuspensionManager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/ Directory Reference

  • Print

Print Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ Directory Reference

  • Print

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | BasePrintPage.cpp [code]
file | BasePrintPage.h [code]
file | ContinuationPage.xaml.cpp [code]
file | ContinuationPage.xaml.h [code]
file | cppsamplesutils.h [code]
file | DisplayContent.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PreviewUnavailable.xaml.cpp [code]
file | PreviewUnavailable.xaml.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioInput3.xaml.cpp [code]
file | ScenarioInput3.xaml.h [code]
file | ScenarioInput4.xaml.cpp [code]
file | ScenarioInput4.xaml.h [code]
file | ScenarioInput5.xaml.cpp [code]
file | ScenarioInput5.xaml.h [code]
file | ScenarioInput6.xaml.cpp [code]
file | ScenarioInput6.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
file | ScenarioOutput3.xaml.cpp [code]
file | ScenarioOutput3.xaml.h [code]
file | ScenarioOutput4.xaml.cpp [code]
file | ScenarioOutput4.xaml.h [code]
file | ScenarioOutput5.xaml.cpp [code]
file | ScenarioOutput5.xaml.h [code]
file | ScenarioOutput6.xaml.cpp [code]
file | ScenarioOutput6.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/ Directory Reference

  • Programmatic file search

Programmatic file search Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/ Directory Reference

  • Programmatic file search

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/common/ Directory Reference

  • Programmatic file search
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/ Directory Reference

  • Proximity

Proximity Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/ Directory Reference

  • Proximity

C++ Directory Reference

Directories

directory | common
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PeerFinderScenario.xaml.cpp [code]
file | PeerFinderScenario.xaml.h [code]
file | ProximityDeviceEvents.xaml.cpp [code]
file | ProximityDeviceEvents.xaml.h [code]
file | ProximityDeviceScenario.xaml.cpp [code]
file | ProximityDeviceScenario.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/common/ Directory Reference

  • Proximity
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/sample-utils/ Directory Reference

  • Proximity
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/ Directory Reference

  • Push and periodic notifications client-side

Push and periodic notifications client-side Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/ Directory Reference

  • Push and periodic notifications client-side

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/ Directory Reference

  • Raw notifications

Raw notifications Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/ Directory Reference

  • Raw notifications

C++ Directory Reference

Directories

directory | MainAppSample
directory | SampleBackgroundTask
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ Directory Reference

  • Raw notifications
  • MainAppSample

MainAppSample Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/SampleBackgroundTask/ Directory Reference

  • Raw notifications
  • SampleBackgroundTask

SampleBackgroundTask Directory Reference

Files

file | BackgroundTask.cpp [code]
file | BackgroundTask.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/ Directory Reference

  • Reading and writing data

Reading and writing data Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/ Directory Reference

  • Reading and writing data

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ReadBytes.xaml.cpp [code]
file | ReadBytes.xaml.h [code]
file | WriteReadStream.xaml.cpp [code]
file | WriteReadStream.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/common/ Directory Reference

  • Reading and writing data
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/ Directory Reference

  • Real-time communication

Real-time communication Directory Reference

Directories

directory | C#,C++
directory | C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/ Directory Reference

  • Real-time communication
  • C#,C++

C#,C++ Directory Reference

Directories

directory | Common
directory | Properties
directory | sample-utils

Files

file | App.xaml.cs [code]
file | Constants.cs [code]
file | LowLatency.xaml.cs [code]
file | MainPage.xaml.cs [code]
file | SuspensionManager.cs [code]
file | VideoChat.xaml.cs [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/Common/ Directory Reference

  • Real-time communication
  • C#,C++
  • Common

Common Directory Reference

Files

file | CaptureDevice.cs [code]
file | LayoutAwarePage.cs [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/Properties/ Directory Reference

  • Real-time communication
  • C#,C++
  • Properties

Properties Directory Reference

Files

file AssemblyInfo.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/sample-utils/ Directory Reference

  • Real-time communication
  • C#,C++
  • sample-utils

sample-utils Directory Reference

Files

file SuspensionManager.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/ Directory Reference

  • Real-time communication

C++ Directory Reference

Directories

directory | common
directory | MediaExtensions
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | LowLatency.xaml.cpp [code]
file | LowLatency.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Utils.cpp [code]
file | Utils.h [code]
file | VideoChat.xaml.cpp [code]
file | VideoChat.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/common/ Directory Reference

  • Real-time communication
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/ Directory Reference

  • Real-time communication
  • MediaExtensions

MediaExtensions Directory Reference

Directories

directory Common
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/Common/ Directory Reference

  • Real-time communication
  • MediaExtensions
  • Common

Common Directory Reference

Files

file | AsyncCB.h [code]
file | CritSec.h [code]
file | LinkList.h [code]
file | OpQueue.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/sample-utils/ Directory Reference

  • Real-time communication
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/ Directory Reference

  • Removable storage

Removable storage Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/ Directory Reference

  • Removable storage

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | S1_ListStorages.xaml.cpp [code]
file | S1_ListStorages.xaml.h [code]
file | S2_SendToStorage.xaml.cpp [code]
file | S2_SendToStorage.xaml.h [code]
file | S3_GetFromStorage.xaml.cpp [code]
file | S3_GetFromStorage.xaml.h [code]
file | S4_Autoplay.xaml.cpp [code]
file | S4_Autoplay.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/ Directory Reference

  • Removable storage
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | SuspensionManager.cpp [code]
file | SuspensionManager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/ Directory Reference

  • Scaling according to DPI

Scaling according to DPI Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/ Directory Reference

  • Scaling according to DPI

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/common/ Directory Reference

  • Scaling according to DPI
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/ Directory Reference

  • Scheduled notifications

Scheduled notifications Directory Reference

Directories

directory C#,C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ Directory Reference

  • Scheduled notifications
  • C#,C++

C#,C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | NotificationData.cpp [code]
file | NotificationData.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/ Directory Reference

  • Search contract

Search contract Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/ Directory Reference

  • Search contract

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | HttpRequest.cpp [code]
file | HttpRequest.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
file | Scenario6.xaml.cpp [code]
file | Scenario6.xaml.h [code]
file | Scenario7.xaml.cpp [code]
file | Scenario7.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/common/ Directory Reference

  • Search contract
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/ Directory Reference

  • Secondary tiles

Secondary tiles Directory Reference

Directories

directory C#,C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/ Directory Reference

  • Secondary tiles
  • C#,C++

C#,C++ Directory Reference

Directories

directory | common
directory | NotificationsExtensions
directory | Sample-Utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | EnumerateTiles.xaml.cpp [code]
file | EnumerateTiles.xaml.h [code]
file | LaunchedFromSecondaryTile.xaml.cpp [code]
file | LaunchedFromSecondaryTile.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PinFromAppbar.xaml.cpp [code]
file | PinFromAppbar.xaml.h [code]
file | PinTile.xaml.cpp [code]
file | PinTile.xaml.h [code]
file | SecondaryTileNotification.xaml.cpp [code]
file | SecondaryTileNotification.xaml.h [code]
file | TilePinned.xaml.cpp [code]
file | TilePinned.xaml.h [code]
file | UnpinTile.xaml.cpp [code]
file | UnpinTile.xaml.h [code]
file | UpdateAsync.xaml.cpp [code]
file | UpdateAsync.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/common/ Directory Reference

  • Secondary tiles
  • C#,C++
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/NotificationsExtensions/ Directory Reference

  • Secondary tiles
  • C#,C++
  • NotificationsExtensions

NotificationsExtensions Directory Reference

Files

file | BadgeContent.cs [code]
file | Common.cs [code]
file | TileContent.cs [code]
file | ToastContent.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/Sample-Utils/ Directory Reference

  • Secondary tiles
  • C#,C++
  • Sample-Utils

Sample-Utils Directory Reference

Files

file cppsamplesutils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/ Directory Reference

  • Sharing content source app

Sharing content source app Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ Directory Reference

  • Sharing content source app

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SetErrorMessage.xaml.cpp [code]
file | SetErrorMessage.xaml.h [code]
file | ShareCustomData.xaml.cpp [code]
file | ShareCustomData.xaml.h [code]
file | ShareDelayRenderedFiles.xaml.cpp [code]
file | ShareDelayRenderedFiles.xaml.h [code]
file | ShareFiles.xaml.cpp [code]
file | ShareFiles.xaml.h [code]
file | ShareHtml.xaml.cpp [code]
file | ShareHtml.xaml.h [code]
file | ShareImage.xaml.cpp [code]
file | ShareImage.xaml.h [code]
file | ShareLink.xaml.cpp [code]
file | ShareLink.xaml.h [code]
file | SharePage.cpp [code]
file | SharePage.h [code]
file | ShareText.xaml.cpp [code]
file | ShareText.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/common/ Directory Reference

  • Sharing content source app
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/ Directory Reference

  • Sharing content target app

Sharing content target app Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/ Directory Reference

  • Sharing content target app

C++ Directory Reference

Directories

directory | common
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | DefaultPage.xaml.cpp [code]
file | DefaultPage.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/common/ Directory Reference

  • Sharing content target app
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/sample-utils/ Directory Reference

  • Sharing content target app
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/ Directory Reference

  • SimpleOrientationSensor

SimpleOrientationSensor Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/ Directory Reference

  • SimpleOrientationSensor

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/common/ Directory Reference

  • SimpleOrientationSensor
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/ Directory Reference

  • SMS background task

SMS background task Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/ Directory Reference

  • SMS background task

C++ Directory Reference

Directories

directory | SmsBackgroundTask
directory | SmsBackgroundTaskSample
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTask/ Directory Reference

  • SMS background task
  • SmsBackgroundTask

SmsBackgroundTask Directory Reference

Files

file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/ Directory Reference

  • SMS background task
  • SmsBackgroundTaskSample

SmsBackgroundTaskSample Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/ Directory Reference

  • SMS message send, receive, and SIM management

SMS message send, receive, and SIM management Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/ Directory Reference

  • SMS message send, receive, and SIM management

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/ Directory Reference

  • Snap

Snap Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/ Directory Reference

  • Snap

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/common/ Directory Reference

  • Snap
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/ Directory Reference

  • Splash screen

Splash screen Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/ Directory Reference

  • Splash screen

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | ExtendedSplash.xaml.cpp [code]
file | ExtendedSplash.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/common/ Directory Reference

  • Splash screen
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/ Directory Reference

  • StorageDataSource and GetVirtualizedFilesVector

StorageDataSource and GetVirtualizedFilesVector Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/ Directory Reference

  • StorageDataSource and GetVirtualizedFilesVector

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/ Directory Reference

  • StreamSocket

StreamSocket Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/ Directory Reference

  • StreamSocket

C++ Directory Reference

Directories

directory | Common
directory | sample-utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Common/ Directory Reference

  • StreamSocket
  • Common

Common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/sample-utils/ Directory Reference

  • StreamSocket
  • sample-utils

sample-utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/ Directory Reference

  • Syndication

Syndication Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/ Directory Reference

  • Syndication

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/common/ Directory Reference

  • Syndication
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/ Directory Reference

  • Thread pool

Thread pool Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/ Directory Reference

  • Thread pool

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | DelayTimerScenario.xaml.cpp [code]
file | DelayTimerScenario.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PeriodicTimerScenario.xaml.cpp [code]
file | PeriodicTimerScenario.xaml.h [code]
file | WorkItemScenario.xaml.cpp [code]
file | WorkItemScenario.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/common/ Directory Reference

  • Thread pool
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/ Directory Reference

  • Toast notifications

Toast notifications Directory Reference

Directories

directory C#,C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ Directory Reference

  • Toast notifications
  • C#,C++

C#,C++ Directory Reference

Directories

directory | NotificationsExtensions

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | CppSamplesUtils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | ScenarioInput1.xaml.cpp [code]
file | ScenarioInput1.xaml.h [code]
file | ScenarioInput2.xaml.cpp [code]
file | ScenarioInput2.xaml.h [code]
file | ScenarioInput3.xaml.cpp [code]
file | ScenarioInput3.xaml.h [code]
file | ScenarioInput4.xaml.cpp [code]
file | ScenarioInput4.xaml.h [code]
file | ScenarioInput5.xaml.cpp [code]
file | ScenarioInput5.xaml.h [code]
file | ScenarioInput6.xaml.cpp [code]
file | ScenarioInput6.xaml.h [code]
file | ScenarioList.xaml.cpp [code]
file | ScenarioList.xaml.h [code]
file | ScenarioOutput1.xaml.cpp [code]
file | ScenarioOutput1.xaml.h [code]
file | ScenarioOutput2.xaml.cpp [code]
file | ScenarioOutput2.xaml.h [code]
file | ScenarioOutput3.xaml.cpp [code]
file | ScenarioOutput3.xaml.h [code]
file | ScenarioOutput4.xaml.cpp [code]
file | ScenarioOutput4.xaml.h [code]
file | ScenarioOutput5.xaml.cpp [code]
file | ScenarioOutput5.xaml.h [code]
file | ScenarioOutput6.xaml.cpp [code]
file | ScenarioOutput6.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/NotificationsExtensions/ Directory Reference

  • Toast notifications
  • C#,C++
  • NotificationsExtensions

NotificationsExtensions Directory Reference

Files

file Common.cs [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/ Directory Reference

  • Transcoding media

Transcoding media Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/ Directory Reference

  • Transcoding media

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | Custom.xaml.cpp [code]
file | Custom.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Presets.xaml.cpp [code]
file | Presets.xaml.h [code]
file | Trim.xaml.cpp [code]
file | Trim.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/common/ Directory Reference

  • Transcoding media
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/ Directory Reference

  • Trial app and in-app purchase

Trial app and in-app purchase Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/ Directory Reference

  • Trial app and in-app purchase

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | AppListingUri.xaml.cpp [code]
file | AppListingUri.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | ExpiringProduct.xaml.cpp [code]
file | ExpiringProduct.xaml.h [code]
file | InAppPurchase.xaml.cpp [code]
file | InAppPurchase.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Receipt.xaml.cpp [code]
file | Receipt.xaml.h [code]
file | TrialMode.xaml.cpp [code]
file | TrialMode.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/common/ Directory Reference

  • Trial app and in-app purchase
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/ Directory Reference

  • UI Automation core window provider

UI Automation core window provider Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/ Directory Reference

  • UI Automation core window provider

C++ Directory Reference

Files

file | AppWindowProvider.cpp [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | InternalInterfaces.idl [code]
file | pch.cpp [code]
file | pch.h [code]
file | TriColorValue.h [code]
file | TriColorWindow.cpp [code]
file | TriColorWindow.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/ Directory Reference

  • UI contrast and settings

UI contrast and settings Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/ Directory Reference

  • UI contrast and settings

C++ Directory Reference

Directories

directory | common

Files

file | Accessibility.xaml.cpp [code]
file | Accessibility.xaml.h [code]
file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | cppsamplesutils.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | UI.xaml.cpp [code]
file | UI.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/common/ Directory Reference

  • UI contrast and settings
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/ Directory Reference

  • User domain name

User domain name Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/ Directory Reference

  • User domain name

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | GetDomainName.xaml.cpp [code]
file | GetDomainName.xaml.h [code]
file | GetPrincipalName.xaml.cpp [code]
file | GetPrincipalName.xaml.h [code]
file | GetSIPUri.xaml.cpp [code]
file | GetSIPUri.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/common/ Directory Reference

  • User domain name
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/ Directory Reference

  • USSD message management

USSD message management Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/ Directory Reference

  • USSD message management

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | RequestResponse.xaml.cpp [code]
file | RequestResponse.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/common/ Directory Reference

  • USSD message management
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/ Directory Reference

  • Web authentication broker

Web authentication broker Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/ Directory Reference

  • Web authentication broker

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/common/ Directory Reference

  • Web authentication broker
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/ Directory Reference

  • Windows account authorization

Windows account authorization Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/ Directory Reference

  • Windows account authorization

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | DelegationTickets.xaml.cpp [code]
file | DelegationTickets.xaml.h [code]
file | HttpRequest.cpp [code]
file | HttpRequest.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/common/ Directory Reference

  • Windows account authorization
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/ Directory Reference

  • Windows Audio Session (WASAPI)

Windows Audio Session (WASAPI) Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/ Directory Reference

  • Windows Audio Session (WASAPI)
  • C++

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Common.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | DeviceState.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | MFSampleGenerator.cpp [code]
file | MFSampleGenerator.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PlotData.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | ToneSampleGenerator.cpp [code]
file | ToneSampleGenerator.h [code]
file | WASAPICapture.cpp [code]
file | WASAPICapture.h [code]
file | WASAPIRenderer.cpp [code]
file | WASAPIRenderer.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/common/ Directory Reference

  • Windows Audio Session (WASAPI)
  • C++
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/ Directory Reference

  • Windows Store device app for camera

Windows Store device app for camera Directory Reference

Directories

directory | C#,C++
directory | C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/ Directory Reference

  • Windows Store device app for camera
  • C#,C++

C#,C++ Directory Reference

Directories

directory | Wrapper

Files

file | App.xaml.cs [code]
file | Constants.cs [code]
file | DeviceAppPage.xaml.cs [code]
file | MainPage.xaml.cs [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/Wrapper/ Directory Reference

  • Windows Store device app for camera
  • C#,C++
  • Wrapper

Wrapper Directory Reference

Files

file | pch.cpp [code]
file | pch.h [code]
file | SampleMft0.h [code]
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/ Directory Reference

  • Windows Store device app for camera

C++ Directory Reference

Directories

directory | Common
directory | Wrapper

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | DeviceAppPage.xaml.cpp [code]
file | DeviceAppPage.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Common/ Directory Reference

  • Windows Store device app for camera
  • Common

Common Directory Reference

Files

file LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Wrapper/ Directory Reference

  • Windows Store device app for camera
  • Wrapper

Wrapper Directory Reference

Files

file | pch.cpp [code]
file | pch.h [code]
file | SampleMft0.h [code]
file | WinRTComponent.h [code]
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/ Directory Reference

  • XAML accessibility

XAML accessibility Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/ Directory Reference

  • XAML accessibility

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/common/ Directory Reference

  • XAML accessibility
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/ Directory Reference

  • XAML animation library

XAML animation library Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/ Directory Reference

  • XAML animation library

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/common/ Directory Reference

  • XAML animation library
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/ Directory Reference

  • XAML AppBar control

XAML AppBar control Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/ Directory Reference

  • XAML AppBar control

C++ Directory Reference

Directories

directory | common
directory | Sample-Utils

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | GlobalPage.xaml.cpp [code]
file | GlobalPage.xaml.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | Page1.xaml.cpp [code]
file | Page1.xaml.h [code]
file | Page2.xaml.cpp [code]
file | Page2.xaml.h [code]
file | Page3.xaml.cpp [code]
file | Page3.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/common/ Directory Reference

  • XAML AppBar control
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Sample-Utils/ Directory Reference

  • XAML AppBar control
  • Sample-Utils

Sample-Utils Directory Reference

Files

file CppSamplesUtils.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/ Directory Reference

  • XAML data binding

XAML data binding Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/ Directory Reference

  • XAML data binding

C++ Directory Reference

Directories

directory | Common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | Employee.h [code]
file | GeneratorIncrementalLoadingClass.h [code]
file | IncrementalLoadingBase.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | S2Formatter.cpp [code]
file | S2Formatter.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
file | Scenario6.xaml.cpp [code]
file | Scenario6.xaml.h [code]
file | Scenario7.xaml.cpp [code]
file | Scenario7.xaml.h [code]
file | Scenario8.xaml.cpp [code]
file | Scenario8.xaml.h [code]
file | Team.cpp [code]
file | Team.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Common/ Directory Reference

  • XAML data binding
  • Common

Common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/ Directory Reference

  • XAML Direct2D lighting effects

XAML Direct2D lighting effects Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/ Directory Reference

  • XAML Direct2D lighting effects

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | D2DLightingEffectsRenderer.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/ Directory Reference

  • XAML DirectX 3D shooting game

XAML DirectX 3D shooting game Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/ Directory Reference

  • XAML DirectX 3D shooting game

C++ Directory Reference

Files

file | Animate.cpp [code]
file | Animate.h [code]
file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Audio.cpp [code]
file | Audio.h [code]
file | BasicLoader.cpp [code]
file | BasicLoader.h [code]
file | BasicMath.h [code]
file | BasicReaderWriter.cpp [code]
file | BasicReaderWriter.h [code]
file | BasicShapes.h [code]
file | Camera.cpp [code]
file | Camera.h [code]
file | ConstantBuffers.h [code]
file | Cylinder.cpp [code]
file | Cylinder.h [code]
file | CylinderMesh.cpp [code]
file | CylinderMesh.h [code]
file | DDSTextureLoader.cpp [code]
file | DDSTextureLoader.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | Face.cpp [code]
file | Face.h [code]
file | FaceMesh.cpp [code]
file | FaceMesh.h [code]
file | GameConstants.h [code]
file | GameHud.cpp [code]
file | GameHud.h [code]
file | GameObject.cpp [code]
file | GameObject.h [code]
file | GameRenderer.cpp [code]
file | GameRenderer.h [code]
file | GameTimer.cpp [code]
file | GameTimer.h [code]
file | Level.cpp [code]
file | Level.h [code]
file | Level1.cpp [code]
file | Level1.h [code]
file | Level2.cpp [code]
file | Level2.h [code]
file | Level3.cpp [code]
file | Level3.h [code]
file | Level4.cpp [code]
file | Level4.h [code]
file | Level5.cpp [code]
file | Level5.h [code]
file | Level6.cpp [code]
file | Level6.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | Material.cpp [code]
file | Material.h [code]
file | MediaReader.cpp [code]
file | MediaReader.h [code]
file | MeshObject.cpp [code]
file | MeshObject.h [code]
file | MoveLookController.cpp [code]
file | MoveLookController.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PersistentState.cpp [code]
file | PersistentState.h [code]
file | ProductItem.cpp [code]
file | ProductItem.h [code]
file | Simple3DGame.cpp [code]
file | Simple3DGame.h [code]
file | SoundEffect.cpp [code]
file | SoundEffect.h [code]
file | Sphere.cpp [code]
file | Sphere.h [code]
file | SphereMesh.cpp [code]
file | SphereMesh.h [code]
file | StereoProjection.cpp [code]
file | StereoProjection.h [code]
file | TargetTexture.cpp [code]
file | TargetTexture.h [code]
file | WorldMesh.cpp [code]
file | WorldMesh.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/ Directory Reference

  • XAML FlipView control

XAML FlipView control Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/ Directory Reference

  • XAML FlipView control

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleDataSource.cpp [code]
file | SampleDataSource.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/common/ Directory Reference

  • XAML FlipView control
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/ Directory Reference

  • XAML high contrast style

XAML high contrast style Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/ Directory Reference

  • XAML high contrast style

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | TargetButton.xaml.cpp [code]
file | TargetButton.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/ Directory Reference

  • XAML high contrast style
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/ Directory Reference

  • XAML images

XAML images Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/ Directory Reference

  • XAML images

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/common/ Directory Reference

  • XAML images
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/ Directory Reference

  • XAML ListView and GridView essentials

XAML ListView and GridView essentials Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/ Directory Reference

  • XAML ListView and GridView essentials

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleDataSource.cpp [code]
file | SampleDataSource.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/ Directory Reference

  • XAML personality animations

XAML personality animations Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/ Directory Reference

  • XAML personality animations

C++ Directory Reference

Directories

directory | common
directory | SampleData

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | Page1.xaml.cpp [code]
file | Page1.xaml.h [code]
file | Page2.xaml.cpp [code]
file | Page2.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/common/ Directory Reference

  • XAML personality animations
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/SampleData/ Directory Reference

  • XAML personality animations
  • SampleData

SampleData Directory Reference

Files

file | SampleDataSource.cpp [code]
file | SampleDataSource.h [code]
Generated on Sat Nov 23 2024 16:09:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/ Directory Reference

  • XAML Popup

XAML Popup Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/ Directory Reference

  • XAML Popup

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | PopupInputContent.xaml.cpp [code]
file | PopupInputContent.xaml.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/common/ Directory Reference

  • XAML Popup
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/ Directory Reference

  • XAML scrolling, panning, and zooming

XAML scrolling, panning, and zooming Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/ Directory Reference

  • XAML scrolling, panning, and zooming

C++ Directory Reference

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/ Directory Reference

  • XAML text display

XAML text display Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/ Directory Reference

  • XAML text display

C++ Directory Reference

Directories

directory | Common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Common/ Directory Reference

  • XAML text display
  • Common

Common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/ Directory Reference

  • XAML text editing

XAML text editing Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/ Directory Reference

  • XAML text editing

C++ Directory Reference

Directories

directory | Common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
file | Scenario6.xaml.cpp [code]
file | Scenario6.xaml.h [code]
file | Scenario7.xaml.cpp [code]
file | Scenario7.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Common/ Directory Reference

  • XAML text editing
  • Common

Common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/ Directory Reference

  • XAML two-dimensional transforms

XAML two-dimensional transforms Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/ Directory Reference

  • XAML two-dimensional transforms

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/common/ Directory Reference

  • XAML two-dimensional transforms
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/ Directory Reference

  • XAML user and custom controls

XAML user and custom controls Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/ Directory Reference

  • XAML user and custom controls

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | BasicCustomControl.cpp [code]
file | BasicCustomControl.h [code]
file | BasicUserControl.xaml.cpp [code]
file | BasicUserControl.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | ImageWithLabelControl.cpp [code]
file | ImageWithLabelControl.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/common/ Directory Reference

  • XAML user and custom controls
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/ Directory Reference

  • XAML vector-based drawing

XAML vector-based drawing Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/ Directory Reference

  • XAML vector-based drawing

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/common/ Directory Reference

  • XAML vector-based drawing
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/ Directory Reference

  • XAML WebView control

XAML WebView control Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/ Directory Reference

  • XAML WebView control

C++ Directory Reference

Directories

directory | common

Files

file | App.xaml.cpp [code]
file | App.xaml.h [code]
file | Constants.cpp [code]
file | Constants.h [code]
file | MainPage.xaml.cpp [code]
file | MainPage.xaml.h [code]
file | PageWithAppBar.xaml.cpp [code]
file | PageWithAppBar.xaml.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | Scenario1.xaml.cpp [code]
file | Scenario1.xaml.h [code]
file | Scenario2.xaml.cpp [code]
file | Scenario2.xaml.h [code]
file | Scenario3.xaml.cpp [code]
file | Scenario3.xaml.h [code]
file | Scenario4.xaml.cpp [code]
file | Scenario4.xaml.h [code]
file | Scenario5.xaml.cpp [code]
file | Scenario5.xaml.h [code]
file | Scenario6.xaml.cpp [code]
file | Scenario6.xaml.h [code]
file | Scenario7.xaml.cpp [code]
file | Scenario7.xaml.h [code]
file | Scenario8.xaml.cpp [code]
file | Scenario8.xaml.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/common/ Directory Reference

  • XAML WebView control
  • common

common Directory Reference

Files

file | LayoutAwarePage.cpp [code]
file | LayoutAwarePage.h [code]
file | suspensionmanager.cpp [code]
file | suspensionmanager.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/ Directory Reference

  • XAudio2 audio file playback

XAudio2 audio file playback Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/ Directory Reference

  • XAudio2 audio file playback

C++ Directory Reference

Files

file | BasicMath.h [code]
file | BasicSound.cpp [code]
file | BasicSound.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | RandomAccessReader.cpp [code]
file | RandomAccessReader.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | SoundFileReader.cpp [code]
file | SoundFileReader.h [code]
file | XAudio2SoundPlayer.cpp [code]
file | XAudio2SoundPlayer.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/ Directory Reference

  • XAudio2 audio stream effect

XAudio2 audio stream effect Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/ Directory Reference

  • XAudio2 audio stream effect

C++ Directory Reference

Files

file | BasicMath.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | MediaStreamer.cpp [code]
file | MediaStreamer.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | StreamEffect.cpp [code]
file | StreamEffect.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/ Directory Reference

  • XInput audio controller playback

XInput audio controller playback Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/ Directory Reference

  • XInput audio controller playback

C++ Directory Reference

Files

file | AudioController.cpp [code]
file | AudioController.h [code]
file | BasicMath.h [code]
file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | MediaStreamer.cpp [code]
file | MediaStreamer.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/ Directory Reference

  • XInput game controller

XInput game controller Directory Reference

Directories

directory C++
Generated on Sat Nov 23 2024 16:09:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/ Directory Reference

  • XInput game controller

C++ Directory Reference

Files

file | BasicTimer.cpp [code]
file | BasicTimer.h [code]
file | DirectXApp.cpp [code]
file | DirectXApp.h [code]
file | DirectXBase.cpp [code]
file | DirectXBase.h [code]
file | DirectXSample.h [code]
file | pch.cpp [code]
file | pch.h [code]
file | SampleOverlay.cpp [code]
file | SampleOverlay.h [code]
file | SimpleController.cpp [code]
file | SimpleController.h [code]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- _ -

  • __IMft0_FWD_DEFINED__ : SampleMft0.h
  • __IMft0_INTERFACE_DEFINED__ : SampleMft0.h
  • __Mft0_FWD_DEFINED__ : SampleMft0.h
  • __REQUIRED_RPCNDR_H_VERSION__ : SampleMft0.h
  • __samplemft0_h__ : SampleMft0.h
  • __SampleMft0Lib_LIBRARY_DEFINED__ : SampleMft0.h
  • _Acquires_lock_() : MPEG1Stream.cpp
  • _ASSERTE : MPEG1Src.h
  • _inputElements : WriteReadStream.xaml.cpp
  • _mainThreadId : TaskExtensions.cpp
  • _Releases_lock_() : MPEG1Stream.cpp
  • _USE_MATH_DEFINES : BasicMath.h , pch.h , BasicMath.h , ToneSampleGenerator.h , BasicMath.h , pch.h , D2DInterpolationModes.h , BasicMath.h , pch.h , BasicMath.h , ExifExtensions.cpp , BasicMath.h
  • _XMMatrixStereoProjectionHelper() : StereoProjection.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Alphabetical List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Class Index

A | B | C | D | E | F | G | H | I | L | M | N | O | P | Q | R | S | T | U | V | W | X | _
A
DspSettings (Wrapper) MainPage (ContactPicker) sealed SoundEffectData
abstract DWriteCustomTextRenderer MainPage (Clipboard) sealed (SDKSample::XAMLPopup) SoundFileReader
aligned_deleter DWriteHelloWorld MainPage (AppBarControl) sealed (SDKSample::WebViewControl) CMPEG1Stream::SourceLock
Alignment DWriteHitTesting MainPage (AccountPictureName) sealed (SDKSample::WebSocket) SourceOp
AmpPixel DWriteInlineObject MainPagePicker (ContactPicker) sealed (SDKSample::WebAuthentication) Sphere
AnimateCirclePosition DWriteParagraphText MainPageSizeChangedEventArgs (SDKTemplate) sealed (SDKSample::WASAPIAudio) SphereMesh
AnimateLineListPosition DWriteVerticalText ManipulatableObject sealed (SDKSample::UssdApi) SpriteBatch (BasicSprites)
AnimateLinePosition DxgiRotation MarbleMaze sealed (SDKSample::UserDomainName) SpriteRunInfo (BasicSprites)
Animation
E
Material sealed (SDKSample::UserAndCustomControls) StartOp
Ant (AntSystem) EaseInExponentialAnimation Matrix4x4 sealed (SDKSample::Transforms) Status (SDKSample)
App (StreamSocketSample) EaseInOutExponentialAnimation MediaEngineNotify sealed (SDKSample::Transcode) STEREO_PARAMETERS
App (SimpleCommunication) EaseOutExponentialAnimation MediaReader sealed (SDKSample::TouchKeyboardTextInput) StereoParameters
App (SDKTemplate) Edge (AntSystem) MediaStreamer sealed (SDKSample::TouchKeyboard) StereoSimpleD3D
App (SDKSample) Element MemDelete sealed (SDKSample::Tiles) StopwatchTimer
App (MediaExtensionsCS) ElementBase MEPlayer sealed (SDKSample::ThreadPool) Story
App (MediaExtensionsCPP) D3DX_BC7::EncodeParams (DirectX) MFSampleGenerator (SDKSample::WASAPIAudio) sealed (SDKSample::TextEditing) StreamEffect
App (DeviceAppForPrinters) D3DX_BC6H::EncodeParams (DirectX) D3DX_BC6H::ModeDescriptor (DirectX) sealed (SDKSample::TextDisplay) sealed::StreamFilteringCriteria (SimpleCommunication)
App (ContactPicker) Errors (SDKSample) D3DX_BC7::ModeInfo (DirectX) sealed (SDKSample::Syndication) StreamingVoiceContext
App (Clipboard) EventCallback (SDKSample::PortableDeviceCPP) D3DX_BC6H::ModeInfo (DirectX) sealed (SDKSample::StoreSample) StreamList
App (AppBarControl) ExceptionPolicy (Hilo) MoveLookController sealed (SDKSample::SplashScreen) StringHelper (SDKSample)
App (AccountPictureName) ExceptionPolicyFactory (Hilo) MPEG1AudioFrameHeader sealed (SDKSample::SnapSample) StringTrimmer (SDKSample)
AsteroidData ExifExtensions (Hilo) MPEG1PacketHeader sealed (SDKSample::SimpleOrientationSensorCPP) SuspensionManager
AsyncCallback ExtrudedTextRenderer MPEG1StreamHeader sealed (SDKSample::ShareSource) SuspensionManager (CppSamplesUtils)
FPSCounter::AtlasText Extruder MPEG1SystemHeader sealed (SDKSample::SearchContract) SValue
Audio Extruder::ExtrudingSink MPEG1VideoSeqHeader sealed (SDKSample)
T
AudioCapture (MediaCapture)
F
N
sealed (SDKSample::SDKTemplate) TangentVertex
AudioController Face List::Node sealed (SDKSample::ScrollViewerCPP) TargetTexture
AudioEngineCallbacks FaceMesh Node (AntSystem) sealed (SDKSample::Scaling) TexMetadata (DirectX)
AudioSource (MediaStreamSource) FileExtensions (SDKSample) NoOp sealed (SDKSample::Rotation) Text
AutoLock FileSystemRepository (Hilo) NotificationBase (NotificationsExtensions) sealed (SDKSample::RemovableStorageCPP) TextAnalysis
AutoThrottle Finally (SDKSample) NotificationContentImage (NotificationsExtensions) sealed (SDKSample::ProvisioningAgent) TextButton
B
FontFileStream NotificationContentText (NotificationsExtensions) sealed (SDKSample::PortableDeviceCPP) TextElement
BackgroundTaskSample (SDKSample) FontLoader NotificationContentValidationException (NotificationsExtensions) sealed (SDKSample::PlayToreceiver) TextFrame
BackgroundTaskSample (SDKSample::BackgroundTask) FPSCounter NullPhotoGroup (Hilo) sealed (SDKSample::PlayTo) TextInterop
BadgeGlyphNotificationContent (NotificationsExtensions::BadgeContent) FractalBufferElement
O
sealed (SDKSample::Playlists) TextStyle
BadgeNumericNotificationContent (NotificationsExtensions::BadgeContent) FractalVertex LayoutAwarePage::ObservableDictionary-g (SDKTemplate::Common) sealed (SDKSample::PlaybackManager) TextureLock
BasePrintPage (PrintSample) FrameData LayoutAwarePage::ObservableDictionary-g::ObservableDictionaryChangedEventArgs (SDKTemplate::Common) sealed (SDKSample::PlaybackManager2) TextureMapElement (BasicSprites)
BasicCamera FrameProcessing ObservableQuery (Hilo) sealed (SDKSample::Personalization) TGA_EXTENSION
BasicCapture (MediaCapture)
G
ObserveException (Hilo) sealed (SDKSample::PersonalityAnimations) TGA_FOOTER
BasicLoader GameConfig OfferReclaimAPI sealed (SDKSample::PasswordVaultCPP) TGA_HEADER
BasicReaderWriter GameHud OpQueue sealed (SDKSample::PackageSample) ThreadPoolSample (SDKSample::ThreadPool)
BasicShapes GameInfoOverlay TripOptimizerImpl::OptimizeTripParams (TripOptimizerComponent::Details) sealed (SDKSample::OrientationSensorCPP) ThumbnailGenerator (Hilo)
BasicSound GameObject OutlineRenderer sealed (SDKSample::NumberFormatting) TileContentFactory (NotificationsExtensions::TileContent)
BasicTimer GameRenderer
P
sealed (SDKSample::NetworkInformationApi) TileNotificationBase (NotificationsExtensions::TileContent)
BasicVertex GameTimer Page sealed (SDKSample::MicrosoftAccount) TileSquareBase (NotificationsExtensions::TileContent)
BC4_SNORM (DirectX) GeneratorIncrementalLoadingClass (SDKSample::DataBinding) PageDescription (PrintSample) sealed (SDKSample::MessageDialogSample) TileSquareBlock (NotificationsExtensions::TileContent)
BC4_UNORM (DirectX) GeometryRealization PageRenderer sealed (SDKSample::MediaServerClient) TileSquareImage (NotificationsExtensions::TileContent)
BindableBase (Hilo::Common) GeometryRealizationFactory PageRendererContext sealed (SDKSample::MediaCapture) TileSquarePeekImageAndText01 (NotificationsExtensions::TileContent)
Blob (DirectX) GeometryRealizationSample PageRoll sealed (SDKSample::MediaButtons) TileSquarePeekImageAndText02 (NotificationsExtensions::TileContent)
Buffer GuidComparer (SDKSample::BackgroundTransfer) PaperFragment sealed (SDKSample::ListViewSimple) TileSquarePeekImageAndText03 (NotificationsExtensions::TileContent)
BumpMapping
H
PaperRenderer sealed (SDKSample::ListViewSampleDataSource) TileSquarePeekImageAndText04 (NotificationsExtensions::TileContent)
C
handle_closer Parser sealed (SDKSample::LightSensorCPP) TileSquareText01 (NotificationsExtensions::TileContent)
CalendarExtensions (Hilo) HDRColorA (DirectX) ParticleData sealed (SDKSample::IsRemoteSession) TileSquareText02 (NotificationsExtensions::TileContent)
Camera HDREndPntPair (DirectX) PcmSource (MediaStreamSource) sealed (SDKSample::InclinometerCPP) TileSquareText03 (NotificationsExtensions::TileContent)
CAppWindowProvider Helpers (SDKSample) PersistentState sealed (SDKSample::Images) TileSquareText04 (NotificationsExtensions::TileContent)
CaptureDevice (SimpleCommunication::Common) HighScoreEntry PhotoCache (Hilo) sealed (SDKSample::HttpClientSample) TileUpdateScheduler (Hilo)
CaptureFailedEventArgs (SimpleCommunication) HighScoreTable PhotoPathComparer (Hilo) sealed (SDKSample::HomeGroup) TileWideBase (NotificationsExtensions::TileContent)
CAsyncState HiloPage (Hilo) Physics sealed (SDKSample::HighContrast) TileWideBlockAndText01 (NotificationsExtensions::TileContent)
CAutoDXDevLockBase HttpRequest (Web) PNTVertex sealed (SDKSample::GyrometerCPP) TileWideBlockAndText02 (NotificationsExtensions::TileContent)
CAutoDXGILock HttpRequestBuffersCallback (Web::Details) PointSnapper sealed (SDKSample::GlobalizationPreferencesSample) TileWideImage (NotificationsExtensions::TileContent)
CBits (DirectX) HttpRequestStringCallback PointSnapper::PointSnappingSink sealed (SDKSample::GeolocationCPP) TileWideImageAndText01 (NotificationsExtensions::TileContent)
CCopyModule
I
Polygon sealed (SDKSample::FolderEnumeration) TileWideImageAndText02 (NotificationsExtensions::TileContent)
CDecoder IAppWindowProvider (UiaCoreWindowProvider) List::POSITION sealed (SDKSample::FlipViewData) TileWideImageCollection (NotificationsExtensions::TileContent)
CDocumentSource IDisconnectableProvider (UiaCoreWindowProvider) PostcardRenderer sealed (SDKSample::FlipViewCPP) TileWidePeekImage01 (NotificationsExtensions::TileContent)
CGrayscale IDWriteTextAnalysisSource1 Program sealed (SDKSample::FileThumbnails) TileWidePeekImage02 (NotificationsExtensions::TileContent)
ChunkHeader (anonymous_namespace{SoundFileReader.cpp}) Image PropVariantClearStruct (SDKSample) sealed (SDKSample::FileSearch) TileWidePeekImage03 (NotificationsExtensions::TileContent)
CInvert Image (DirectX)
Q
sealed (SDKSample::FilePickerContracts) TileWidePeekImage04 (NotificationsExtensions::TileContent)
CInvertModule ImageBase (Hilo) QiList sealed (SDKSample::FilePicker) TileWidePeekImage05 (NotificationsExtensions::TileContent)
CMPEG1Source ImageFile QiList< InterfaceName, QiListNil > sealed (SDKSample::FileAccess) TileWidePeekImage06 (NotificationsExtensions::TileContent)
CMPEG1Stream ImageFrame QiListNil sealed (SDKSample::ExpressionBlendSampleDataSampleDataSource) TileWidePeekImageAndText01 (NotificationsExtensions::TileContent)
Collision ImageNavigationData (Hilo) QiListSelf sealed (SDKSample::ELS) TileWidePeekImageAndText02 (NotificationsExtensions::TileContent)
CollisionInfo ImageRenderer
R
sealed (SDKSample::EAS) TileWidePeekImageCollection01 (NotificationsExtensions::TileContent)
ComAutoRelease ContentImageSource::ImageSourceDrawHelper RandomAccessReader sealed (SDKSample::Drawing) TileWidePeekImageCollection02 (NotificationsExtensions::TileContent)
ComBase IMFAsyncCallback RandomPhotoSelector (Hilo) sealed (SDKSample::DisplayOrientation) TileWidePeekImageCollection03 (NotificationsExtensions::TileContent)
CommandListRenderer IMft0Vtbl ReadStreamTask sealed (SDKSample::DeviceEnumeration) TileWidePeekImageCollection04 (NotificationsExtensions::TileContent)
CompositeModes IMonthBlock (Hilo) ReadStreamTask::ReadStreamTaskImpl sealed (SDKSample::DeviceCaps) TileWidePeekImageCollection05 (NotificationsExtensions::TileContent)
ComPtrList XAudio2SoundPlayer::ImplData Rect (DirectX) sealed (SDKSample::DateTimeFormatting) TileWidePeekImageCollection06 (NotificationsExtensions::TileContent)
ComputeCB IncrementalLoadingBase (SDKSample::DataBinding) Rectangle sealed (SDKSample::DataReaderWriter) TileWideSmallImageAndText01 (NotificationsExtensions::TileContent)
ComputeDoubleCB IndexTriplet RenderBuffer sealed (SDKSample::DataBinding) TileWideSmallImageAndText02 (NotificationsExtensions::TileContent)
ConstantBuffer InkRenderer Renderer sealed (SDKSample::CustomDeviceAccess) TileWideSmallImageAndText03 (NotificationsExtensions::TileContent)
ConstantBufferChangeOnResize InlineImage Repeater (Samples::Devices) sealed (SDKSample::CryptoWinRT) TileWideSmallImageAndText04 (NotificationsExtensions::TileContent)
ConstantBufferChangesEveryFrame InstanceData (BasicSprites) ReplicationVertex (BasicSprites) sealed (SDKSample::ContextMenu) TileWideSmallImageAndText05 (NotificationsExtensions::TileContent)
ConstantBufferChangesEveryPrim InstancingVertex (BasicSprites) Repository (Hilo) sealed (SDKSample::Compression) TileWideText01 (NotificationsExtensions::TileContent)
ConstantBufferLayoutForDX9BrightPassPixelShader INTColor (DirectX) Resource sealed (SDKSample::CompassCPP) TileWideText02 (NotificationsExtensions::TileContent)
ConstantBufferLayoutForGlowPixelShader INTEndPntPair (DirectX) ResourceLoading sealed (SDKSample::Common) TileWideText03 (NotificationsExtensions::TileContent)
ConstantBufferNeverChanges InvalidPageException (PrintSample) RippleEffect sealed (SDKSample::CertificateEnrollment) TileWideText04 (NotificationsExtensions::TileContent)
Contact IPhoto (Hilo) TextAnalysis::Run sealed (SDKSample::CameraOptions) TileWideText05 (NotificationsExtensions::TileContent)
ContentImageSource IPhotoGroup (Hilo)
S
sealed (SDKSample::CameraCapture) TileWideText06 (NotificationsExtensions::TileContent)
ConvertData (DirectX) IRenderer sealed::SampleContact (ContactPicker) sealed (SDKSample::CallControl) TileWideText07 (NotificationsExtensions::TileContent)
ConvolveMatrixEffect IResizable (Hilo) SampleOverlay sealed (SDKSample::CalendarSample) TileWideText08 (NotificationsExtensions::TileContent)
CoreWindowEvents IResourceLoader (Hilo) SaveAsImageFile sealed (SDKSample::BackgroundTransfer) TileWideText09 (NotificationsExtensions::TileContent)
CoTaskMemFreeArray (SDKSample) ISquareTileInternal (NotificationsExtensions::TileContent) Scenario (StreamSocketSample) sealed (SDKSample::BackgroundTask) TileWideText10 (NotificationsExtensions::TileContent)
CoTaskMemFreeStruct (SDKSample) ITriColorControlInternal (UiaCoreWindowProvider) Scenario (SimpleCommunication) sealed (SDKSample::AtomPub) TileWideText11 (NotificationsExtensions::TileContent)
CountdownTimer ITriColorControlProvider (UiaCoreWindowProvider) Scenario (SecondaryTiles) sealed (SDKSample::ApplicationSettings) ToastAudio (NotificationsExtensions::ToastContent)
CPolarEffect ITriColorFragmentProvider (UiaCoreWindowProvider) Scenario (SDKTemplate) sealed (SDKSample::ApplicationResources) ToastImageAndText01 (NotificationsExtensions::ToastContent)
CritSec IYearGroup (Hilo) Scenario (SDKSample) sealed (SDKSample::ApplicationDataSample) ToastImageAndText02 (NotificationsExtensions::ToastContent)
CStreamState
L
Scenario (ProximityCPP) sealed (SDKSample::AnimationMetrics) ToastImageAndText03 (NotificationsExtensions::ToastContent)
CTriColorWindowFactory LatLong (AntSystem) Scenario (DeviceAppForPrinters) sealed (SDKSample::Animation) ToastImageAndText04 (NotificationsExtensions::ToastContent)
CustomTextRenderer Layer Scenario (DatagramSocketSample) sealed (SDKSample::Accessibility) ToastNotificationBase (NotificationsExtensions::ToastContent)
Cylinder LayoutAwarePage (StreamSocketSample::Common) Scenario (ContactPicker) sealed (SDKSample::AccelerometerCPP) ToastText01 (NotificationsExtensions::ToastContent)
CylinderMesh LayoutAwarePage (SimpleCommunication::Common) Scenario (Clipboard) sealed (ScheduledNotificationsSampleCPP) ToastText02 (NotificationsExtensions::ToastContent)
D
LayoutAwarePage (ShareTarget::Common) Scenario (AppBarControl) sealed (Samples::Devices::Fx2) ToastText03 (NotificationsExtensions::ToastContent)
D2D3DTransformsRenderer LayoutAwarePage (SecondaryTiles::Common) Scenario (AccountPictureName) sealed (RawNotificationsSampleCPP) ToastText04 (NotificationsExtensions::ToastContent)
D2DBasicAnimation LayoutAwarePage (SDKTemplate::Common) ScenarioContext sealed (ProximityCPP) ToneSampleGenerator (SDKSample::WASAPIAudio)
D2DEffectsHelloWorld LayoutAwarePage (SDKSample::Common) ScenarioInput1 (MediaExtensionsCS) sealed (PrintSample) TreeIterator
D2DEffectsOnPrimitives LayoutAwarePage (ProximityCPP::Common) ScenarioInput2 (MediaExtensionsCS) sealed (Postcard) Triangle
D2DFactoryLock LayoutAwarePage (Hilo::Common) ScenarioInput3 (MediaExtensionsCS) sealed (NetworkStatusTask) TriColorValueHelper
D2DInterpolationModes LayoutAwarePage (DeviceAppForWebcam::Common) ScenarioInput4 (MediaExtensionsCS) sealed (MediaExtensionsCPP) TripOptimizerImpl (TripOptimizerComponent::Details)
D2DLightingEffectsRenderer LayoutAwarePage (DatagramSocketSample::Common) ScenarioList (MediaExtensionsCS) sealed (Magazine)
U
D2DPerspectiveTransform LayoutAwarePage (ContactPicker::Common) ScenarioOutput1 (MediaExtensionsCS) sealed (LockScreenAppsCPP) UserInterface
D2DTextAnimation LayoutAwarePage (Clipboard::Common) ScenarioOutput2 (MediaExtensionsCS) sealed (LanguageFontCPP) Utils
D3DPostProcessing LayoutAwarePage (AppBarControl::Common) ScenarioOutput3 (MediaExtensionsCS) sealed (Hilo)
V
D3DX_BC1 (DirectX) LayoutAwarePage (AccountPictureName::Common) ScenarioOutput4 (MediaExtensionsCS) sealed (Hilo::Common) Vector2
D3DX_BC2 (DirectX) LDRColorA (DirectX) SConversion sealed (FontEnumeration) Vector3
D3DX_BC3 (DirectX) LDREndPntPair (DirectX) ScopedObject sealed (EdgeGestureSample) Vector4
D3DX_BC6H (DirectX) LegacyDDS (DirectX) ScratchImage (DirectX) sealed (DeviceAppForWebcam) WaveEffect::Vertex
D3DX_BC7 (DirectX) Level1 ScreenQuadVertex sealed (DatagramSocketSample) Extruder::ExtrudingSink::Vertex2D
DDS_HEADER (DirectX) Level2 ScreenVertex sealed (D2DLightingEffects) VideoBufferLock
DDS_HEADER Level3 SDKANIMATION_DATA sealed (D2D3DTransforms) VideoChat (SimpleCommunication)
DDS_HEADER_DXT10 (DirectX) Level4 SDKANIMATION_FILE_HEADER sealed (CredentialPickerCPP) VideoView
DDS_HEADER_DXT10 Level5 SDKANIMATION_FRAME_DATA sealed (ContactPicker) ViewModelBase (Hilo)
DDS_PIXELFORMAT (DirectX) Level6 SDKMesh sealed (Clipboard) ViewTransform
DDS_PIXELFORMAT LinearAnimation SDKMESH_FRAME sealed (BackgroundTasks)
W
DebugLoggingExceptionPolicy (Hilo) LineSegment SDKMESH_HEADER sealed (BackgroundTask) WASAPICapture (SDKSample::WASAPIAudio)
Design TextAnalysis::LinkedRun SDKMESH_INDEX_BUFFER_HEADER sealed (Background) WASAPIRenderer (SDKSample::WASAPIAudio)
DeviceAppPage (SDKTemplate) List SDKMESH_MATERIAL sealed (AssociationLaunching) WaveEffect
DeviceAsync (CustomDeviceAccess) LoadScreen SDKMESH_MESH sealed (AppBarControl) WICConvert
DeviceControlResult (Samples::Devices) LonLatController SDKMESH_SUBSET sealed (AccountPictureName) WICTranslate
DeviceList (SDKSample::CustomDeviceAccess) LowLatency (SimpleCommunication) SDKMESH_VERTEX_BUFFER_HEADER SetRateOp WideFiveImageTile (Hilo)
DeviceList (CustomDeviceAccess)
M
SdkSample (SimpleCommunication) Shape WorldCeilingMesh
DeviceListEntry (CustomDeviceAccess) MainPage (StreamSocketSample) sealed (Wrapper) ShapeRecord WorldFloorMesh
DEVICEPROPS (SDKSample::WASAPIAudio) MainPage (SimpleCommunication) sealed (TripOptimizerComponent) SharePage (SDKSample::Common) WorldWallsMesh
Direct3DTutorial MainPage (SecondaryTiles) sealed (ToastsSampleCPP) Simple3DGame
X
Direct3DTutorialFrameworkView MainPage (SDKTemplateCS) sealed (Tasks) Simple3DTouch XAudio2SoundPlayer
Direct3DTutorialFrameworkViewSource MainPage (SDKTemplate) sealed (StreamSocketSample) SimpleController
_
DirectXApp MainPage (SDKSample) sealed (SimpleCommunication) SimpleCubeVertex _BAR_GRAPH_STATE
DirectXAppSource MainPage (ProximityCPP) sealed (SimpleBlogReader) SimpleSprites _FILE_PLAYBACK
DirectXFractal MainPage (DeviceAppForWebcam) sealed (Simple3DGameXaml) SimpleVertex _SDKMESHVERTEXELEMENT
Document MainPage (DeviceAppForPrinters) sealed (ShareTarget) SoundCallbackHander (anonymous_namespace{XAudio2SoundPlayer.cpp}) _SWITCH_STATE
DrawRectCB MainPage (DatagramSocketSample) sealed (SecondaryTiles) SoundEffect
A | B | C | D | E | F | G | H | I | L | M | N | O | P | Q | R | S | T | U | V | W | X | _
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- j -

  • Join() : SDKSample::StringHelper
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- k -

  • key : PersistentState
  • Key : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
  • Keyboard() : SDKSample::DeviceCaps::sealed
  • KeyboardGetSettings_Click() : SDKSample::DeviceCaps::sealed
  • KeyDown() : MarbleMaze
  • Keys : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • KeyUp() : MarbleMaze
  • KnownTypes : SuspensionManager
  • knownTypes_ : SuspensionManager
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- l -

  • Landscape() : SDKSample::Rotation::sealed
  • LandscapeFlipped() : SDKSample::Rotation::sealed
  • Lang : NotificationsExtensions::NotificationBase , NotificationsExtensions::NotificationContentText
  • LanguageDetection() : SDKSample::ELS::sealed
  • LanguageScenario() : SDKSample::GlobalizationPreferencesSample::sealed
  • LanId() : SDKSample::NetworkInformationApi::sealed
  • LanId_Click() : SDKSample::NetworkInformationApi::sealed
  • lanIdInfo : SDKSample::NetworkInformationApi::sealed
  • lastName : SDKSample::Accessibility::sealed
  • LatencyMode : SimpleCommunication::LowLatency
  • LatencyModes : SimpleCommunication::sealed
  • LatencyModeToggle_Toggled() : SimpleCommunication::LowLatency
  • LatencyModeToggled() : SimpleCommunication::sealed
  • Latitude : AntSystem::LatLong
  • LatLong() : AntSystem::LatLong
  • Launch : NotificationsExtensions::ToastContent::ToastNotificationBase , SDKSample::TouchKeyboard::sealed
  • Launch_Click()
: SDKSample::PasswordVaultCPP::sealed
, CredentialPickerCPP::sealed
, SDKSample::WebAuthentication::sealed
  • Launch_Click1() : SDKSample::EAS::sealed
  • Launch_Click2() : SDKSample::EAS::sealed
  • Launch_Click3() : SDKSample::EAS::sealed
  • LaunchArgs
: SDKTemplate::MainPage
, DeviceAppForWebcam::sealed
, SDKSample::App
, SDKTemplate::App
  • LaunchedFromSecondaryTile() : SecondaryTiles::sealed
  • LaunchFileButton_Click() : AssociationLaunching::sealed
  • LaunchFileInput() : AssociationLaunching::sealed
  • LaunchFileOpenWithButton_Click() : AssociationLaunching::sealed
  • LaunchFileOutput() : AssociationLaunching::sealed
  • LaunchFileWithWarningButton_Click() : AssociationLaunching::sealed
  • LaunchUriButton_Click() : AssociationLaunching::sealed
  • LaunchUriInput() : AssociationLaunching::sealed
  • LaunchUriOpenWithButton_Click() : AssociationLaunching::sealed
  • LaunchUriOutput() : AssociationLaunching::sealed
  • LaunchUriWithWarningButton_Click() : AssociationLaunching::sealed
  • layer : MPEG1AudioFrameHeader
  • LayoutAwarePage() : SDKTemplate::Common::LayoutAwarePage
  • lcWrapper : SDKTemplate::DeviceAppPage , DeviceAppForWebcam::sealed
  • LDRColorA() : DirectX::LDRColorA
  • LearnMoreButton_Click() : SDKSample::SplashScreen::sealed
  • LeftEyeProjection() : Camera
  • length : LineSegment
  • LevelActive() : Simple3DGame
  • levelCompleted : HighScoreEntry
  • LevelCompleted() : Simple3DGame
  • license : Simple3DGameXaml::sealed
  • LicenseChanged() : Simple3DGameXaml::sealed
  • lightColor : ConstantBufferNeverChanges
  • lightPosition : ConstantBufferNeverChanges
  • lightStrength : ConstantBuffer
  • LimitManipulationScale() : ManipulatableObject
  • LinearAnimation() : LinearAnimation< T >
  • LinearInterpolate() : CommandListRenderer
  • Link : SimpleBlogReader::sealed
  • LinkedRun() : TextAnalysis::LinkedRun
  • LinkField_Click() : SDKSample::Syndication::sealed
  • List() : List< T >
  • List< T > : List< T >::POSITION
  • listener : DatagramSocketSample::sealed , StreamSocketSample::sealed
  • ListenerContext()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • ListenerCount : Samples::Devices::Fx2::sealed
  • ListStorages_Click() : SDKSample::RemovableStorageCPP::sealed
  • ListSystemFonts() : FontEnumeration::sealed
  • llTimestamp : SDKSample::WASAPIAudio::MFSampleGenerator
  • Load() : DirectXApp , D2DTextAnimation , D2DBasicAnimation , D2DEffectsHelloWorld , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , D2DEffectsOnPrimitives , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , DirectXApp , SaveAsImageFile , DirectXApp , Direct3DTutorialFrameworkView , DirectXApp , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , DWriteVerticalText , DirectXApp , CoreWindowEvents , DirectXApp , sealed , DirectXApp
  • Load_Click() : SDKSample::WebViewControl::sealed
  • LoadAnimation() : SDKMesh
  • LoadAppListingUriProxyFile() : SDKSample::StoreSample::sealed
  • LoadAsync() : Document , FontLoader , ImageFile
  • LoadBitmap() : PrintSample::sealed
  • LoadBitmapFromFile() : InlineImage
  • LoadBool() : PersistentState
  • LoadContentAsync() : SDKSample::TextEditing::sealed
  • LoadData() : ScheduledNotificationsSampleCPP::sealed
  • LoadDeferredResources() : MarbleMaze
  • LoadExpiringProductProxyFile() : SDKSample::StoreSample::sealed
  • LoadGame() : Simple3DGame
  • LoadGradient() : SDKSample::Drawing::sealed
  • LoadHighScore() : Simple3DGame
  • LoadImage() : ImageRenderer , PostcardRenderer
  • LoadInAppPurchaseProxyFile() : SDKSample::StoreSample::sealed
  • LoadInt32() : PersistentState
  • LoadInternalState() : BumpMapping , LonLatController , DirectXFractal , LonLatController , ResourceLoading , MoveLookController , Simple3DTouch
  • LoadLevelAsync() : Simple3DGame
  • LoadLevelResourcesAsync() : GameRenderer
  • LoadMaterials() : SDKMesh
  • LoadMedia() : MediaReader
  • LoadMediaFiles() : SDKSample::MediaServerClient::sealed
  • LoadMesh() : BasicLoader
  • LoadMeshAsync() : BasicLoader
  • LoadMoreItemsOverride() : SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • LoadPhoto() : SDKSample::CameraCapture::sealed
  • LoadReceiptProxyFile() : SDKSample::StoreSample::sealed
  • LoadScenario()
: SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SimpleCommunication::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
  • LoadSetAccountPictureScenario() : AccountPictureName::MainPage
  • LoadShader() : BasicLoader
  • LoadShaderAsync() : BasicLoader
  • LoadSingle() : PersistentState
  • LoadState()
: SDKSample::sealed
, abstract
, SDKSample::sealed
, MarbleMaze
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SimpleBlogReader::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, Level4
, Simple3DGame
, Level2
, SDKSample::sealed
, Magazine::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::HiloPage
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::ViewModelBase
, Level2
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::sealed
, SDKSample::Common::LayoutAwarePage
, Simple3DGame
, SDKSample::sealed
, Level4
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, abstract
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, Hilo::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
  • LoadString() : PersistentState
  • LoadTexture() : BasicLoader
  • LoadTextureAsync() : BasicLoader
  • LoadTrialModeProxyFile() : SDKSample::StoreSample::sealed
  • LoadVideo() : SDKSample::CameraCapture::sealed
  • LoadXMFLOAT3() : PersistentState
  • LocalClientButtonClicked() : SimpleCommunication::sealed
  • localFile : SDKSample::PlayTo::sealed
  • LocalhostVideo : SimpleCommunication::LowLatency
  • localScenariosInner : SDKSample::FilePickerContracts::sealed
  • localSettings : SDKSample::ApplicationDataSample::sealed
  • LocalTransform() : ManipulatableObject
  • localVideo_CurrentStateChanged() : SDKSample::MediaServerClient::sealed
  • localVideo_MediaFailed() : SDKSample::MediaServerClient::sealed
  • LocationBackgroundTask() : BackgroundTask::sealed
  • Locations : AntSystem::Node
  • lock : DatagramSocketSample::sealed
  • Lock() : VideoBufferLock
  • LockBuffer() : VideoBufferLock
  • LockDevice() : CAutoDXGILock , CAutoDXDevLockBase< DevManager, DevInterface >
  • LockRegion() : ImageFile
  • LockScenarioChange() : SimpleCommunication::sealed
  • Log()
: SDKSample::BackgroundTransfer::sealed
, SimpleCommunication::SdkSample
, SDKSample::BackgroundTransfer::sealed
, SimpleCommunication::SdkSample
  • LogException() : SDKSample::BackgroundTransfer::sealed
  • LogInfo() : ProximityCPP::sealed
  • LogStatus() : SDKSample::BackgroundTransfer::sealed
  • LongAndShortFormats() : SDKSample::DateTimeFormatting::sealed
  • Longitude : AntSystem::LatLong
  • LongRunningShareLabel_Tapped() : ShareTarget::sealed
  • LookAt() : Camera
  • LookDirection() : MoveLookController , Camera , MoveLookController
  • Lookup() : SDKSample::DataBinding::sealed
  • Loop : NotificationsExtensions::ToastContent::ToastAudio , MEPlayer
  • LoopbackClient_Click() : SimpleCommunication::LowLatency
  • LostFocusHandler() : Postcard::sealed
  • LowLatency() : SimpleCommunication::LowLatency
  • lowLatency : SimpleCommunication::sealed
  • LowLatency() : SimpleCommunication::sealed
  • lstEnumedDevices_SelectionChanged() : SDKSample::MediaCapture::sealed
  • Lzms_Click() : SDKSample::Compression::sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- m -

  • M : DirectX::D3DX_BC6H
  • m_2DAffineTransformEffectLeft : D2DInterpolationModes
  • m_2DAffineTransformEffectRight : D2DInterpolationModes
  • m_3DPerspectiveTransformEffect : D2D3DTransformsRenderer
  • m_3DTransformEffect : D2D3DTransformsRenderer
  • m_aButtonWasPressed : AudioController
  • m_acceleration : Physics
  • m_accelerometer : MarbleMaze
  • m_accSettings : sealed
  • m_accumulatedTime : Physics
  • m_actionBrush : GameInfoOverlay
  • m_activated : sealed
  • m_activationEntryPoint : sealed
  • m_active : StopwatchTimer , GameObject , GameTimer
  • m_activeBackground : Simple3DGame
  • m_actualHeight : Hilo::sealed
  • m_actualWidth : Hilo::sealed
  • m_AddImageQueryNullable : NotificationsExtensions::NotificationContentImage , NotificationsExtensions::NotificationBase
  • m_adjacencyIndexBufferArray : SDKMesh
  • m_alignment : ElementBase
  • m_allocated : Buffer
  • m_allPhotosQueryChange : Hilo::FileSystemRepository
  • m_alpha : AntSystem::Ant , CompositeModes
  • m_Alt : NotificationsExtensions::NotificationContentImage
  • m_ammo : Simple3DGame
  • m_ammoCount : Simple3DGame
  • m_ammoNext : Simple3DGame
  • m_anchor : List< T >
  • m_animatePosition : GameObject
  • m_animating : D2DTextAnimation
  • m_animationData : SDKMesh
  • m_animationFrameData : SDKMesh
  • m_animationHeader : SDKMesh
  • m_antialiasMode : GeometryRealizationSample
  • m_app : Simple3DGameXaml::sealed
  • m_appleAlphaEffect : CompositeModes
  • m_appleBitmap : CompositeModes
  • m_appleEffect : CompositeModes
  • m_applicationView : sealed , VideoView
  • m_appWindowProvider : sealed
  • m_arithmeticCompositeEffect : D2DEffectsOnPrimitives
  • m_arrivedToken : ProximityCPP::sealed
  • m_arTS : CStreamState
  • m_aspectRatio : Camera
  • m_asteroid : SimpleSprites
  • m_asteroidData : SimpleSprites
  • m_atStartScreen : Postcard::sealed
  • m_Audio : NotificationsExtensions::ToastContent::ToastNotificationBase
  • m_audio : AudioEngineCallbacks , MarbleMaze
  • m_audioAvailable : Audio , SoundEffect
  • m_audioBuffer : SoundEffectData
  • m_audioBuffers : Audio , StreamEffect
  • m_AudioCaptureClient : SDKSample::WASAPIAudio::WASAPICapture
  • m_AudioClient : SDKSample::WASAPIAudio::WASAPIRenderer , SDKSample::WASAPIAudio::WASAPICapture
  • m_audioController : Simple3DGame
  • m_audioEngine : XAudio2SoundPlayer , AudioController
  • m_AudioMT : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_AudioRenderClient : SDKSample::WASAPIAudio::WASAPIRenderer
  • m_audioType : MediaStreamer
  • m_autoFire : MoveLookController
  • m_autoThrottle : SimpleSprites
  • m_axis : Cylinder
  • m_back : LonLatController , MoveLookController
  • m_background : Magazine::sealed , SimpleSprites
  • m_backgroundBrush : GameInfoOverlay
  • m_bActive : CMPEG1Stream
  • m_bananaAlphaEffect : CompositeModes
  • m_bananaBitmap : CompositeModes
  • m_bananaEffect : CompositeModes
  • m_Bars : Samples::Devices::Fx2::sealed
  • m_baseline : TextFrame
  • m_baseTime : GameTimer
  • m_BaseUri : NotificationsExtensions::NotificationBase
  • m_basicReaderWriter : BasicLoader
  • m_BBP : FrameData
  • m_bEffectAdded : SDKSample::MediaCapture::sealed
  • m_bEffectAddedToPhoto : SDKSample::MediaCapture::sealed
  • m_bEffectAddedToRecord : SDKSample::MediaCapture::sealed
  • m_begin : Buffer
  • m_bEOS : Parser , CMPEG1Stream
  • m_beta : AntSystem::Ant
  • m_bGOPData : CStreamState
  • m_bHasPacketHeader : Parser
  • m_bindPoseFrameMatrices : SDKMesh
  • m_bitmap : Image , LoadScreen , PaperFragment
  • m_bitmapBrush : DWriteCustomTextRenderer
  • m_bitmapOffset : PaperFragment
  • m_bitmapPerspective : D2DPerspectiveTransform
  • m_bitmapPixelBounds : ImageFrame
  • m_bitmapPixelSize : CompositeModes , ConvolveMatrixEffect
  • m_bitmapSourceEffect : D2D3DTransformsRenderer , D2DEffectsHelloWorld , ConvolveMatrixEffect , D2DInterpolationModes , ImageRenderer , D2DLightingEffectsRenderer
  • m_bkgColor : MEPlayer
  • m_blackBrush : PaperRenderer , CoreWindowEvents , sealed , D2DTextAnimation , D2DBasicAnimation , GeometryRealizationSample , SaveAsImageFile , PageRendererContext , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , DWriteVerticalText , TargetTexture , InkRenderer
  • m_blendEffect : CompositeModes
  • m_blendModeNames : CompositeModes
  • m_blendModeTextLayout : CompositeModes
  • m_blendState : MarbleMaze
  • m_blendStateAdditive : BasicSprites::SpriteBatch
  • m_blendStateAlpha : BasicSprites::SpriteBatch
  • m_bLowLatencyMode : CDecoder
  • m_blueBrush : CommandListRenderer , TargetTexture
  • m_bottom : Hilo::sealed
  • m_bottomMargin : TextFrame
  • m_bPicture : CDecoder
  • m_BPP : FrameProcessing
  • m_bPreviewing : MediaCapture::BasicCapture , SDKSample::MediaCapture::sealed
  • m_Branding : NotificationsExtensions::TileContent::TileNotificationBase
  • m_breakpoints : TextAnalysis
  • m_bRecording
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • m_bReversePreviewRotation : SDKSample::MediaCapture::sealed
  • m_brightPassConstantBuffer : D3DPostProcessing
  • m_brightPassTextureRenderTargetView : D3DPostProcessing
  • m_brightPassTextureShaderResourceView : D3DPostProcessing
  • m_bRotateVideoOnOrientationChange : SDKSample::MediaCapture::sealed
  • m_browseConnectSupported : ProximityCPP::sealed
  • m_brush : Rectangle , TextFrame , StereoSimpleD3D , PaperFragment
  • m_bStreamingInitialized : CGrayscale , CInvert , CPolarEffect
  • m_bstrURL : MEPlayer
  • m_bSuspended
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • m_BufferFrames : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_bufferHeight : DirectXFractal
  • m_bufferInfoCB : DirectXFractal
  • m_bufferWidth : DirectXFractal
  • m_buttonInUse : MoveLookController
  • m_buttonLowerRight : MoveLookController
  • m_buttonPointerID : MoveLookController
  • m_buttonPressed : MoveLookController
  • m_buttonUpperLeft : MoveLookController
  • m_BytesPerPeriod : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_cachedDigits : FPSCounter
  • m_cachedStaticText : FPSCounter
  • m_callback : Hilo::sealed
  • m_camera : BumpMapping , D3DPostProcessing , ResourceLoading , Direct3DTutorial , TextInterop , Simple3DGame , MarbleMaze , ExtrudedTextRenderer , Simple3DTouch
  • m_Camera : OfferReclaimAPI , DxgiRotation
  • m_cameraPitchAngle : Camera
  • m_cameraYawAngle : Camera
  • m_cancelCommand : Hilo::sealed
  • m_cancellationTokenSource : TripOptimizerComponent::Details::TripOptimizerImpl , Hilo::sealed
  • m_Canceller : Samples::Devices::Repeater
  • m_CancelToken : Samples::Devices::Fx2::sealed
  • m_canExecute : Hilo::sealed
  • m_canExecuteDelegate : Hilo::sealed
  • m_capacity : BasicSprites::SpriteBatch
  • m_captionFormat : D2D3DTransformsRenderer
  • m_captionHeight : D2D3DTransformsRenderer
  • m_captionLayouts : CompositeModes
  • m_captionTop : D2D3DTransformsRenderer
  • m_cartoonizeCommand : Hilo::sealed
  • m_cartoonizeImageCommand : Hilo::sealed
  • m_cbBytes : CStreamState
  • m_cbData : CDecoder
  • m_cbDataSize : SDKSample::WASAPIAudio::WASAPICapture
  • m_cbFlushCounter : SDKSample::WASAPIAudio::WASAPICapture
  • m_cbHeaderSize : SDKSample::WASAPIAudio::WASAPICapture
  • m_cbImageSize : CGrayscale , CInvert , CDecoder , CPolarEffect
  • m_ceilingTexture : GameRenderer
  • m_cellSize : CompositeModes
  • m_center : AnimateCirclePosition
  • m_characters : ExtrudedTextRenderer
  • m_checkedForHardwareAcceleration : Hilo::sealed
  • m_checkpoints : MarbleMaze
  • m_checkpointText : MarbleMaze
  • m_circleGeometry1 : TargetTexture
  • m_circleGeometry2 : TargetTexture
  • m_circleGeometry3 : TargetTexture
  • m_circleGeometry4 : TargetTexture
  • m_circleGeometry5 : TargetTexture
  • m_clearBrush : TargetTexture
  • m_clockwise : AnimateCirclePosition
  • m_collision : MarbleMaze , Physics
  • m_collisions : Collision
  • m_color : Rectangle , TextFrame , PaperFragment , Shape
  • m_coloredBrush : D2DEffectsOnPrimitives
  • m_colorPlanes : FrameData , FrameProcessing
  • m_columnSpan : Hilo::sealed
  • m_commandList : CommandListRenderer
  • m_complete : DirectXFractal
  • m_completedIterations : DirectXFractal
  • m_compositeEffect : CompositeModes , TextFrame
  • m_compositeModeNames : CompositeModes
  • m_compositeModeTextLayout : CompositeModes
  • m_computeCB : DirectXFractal
  • m_connectionRequestedToken : ProximityCPP::sealed
  • m_ConnectStateArray : ProximityCPP::sealed
  • m_constantBuffer : ResourceLoading , StereoSimpleD3D , Direct3DTutorialFrameworkView , Direct3DTutorial , TextInterop , MarbleMaze , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation , BumpMapping , D3DPostProcessing
  • m_constantBufferChangeOnResize : GameRenderer
  • m_constantBufferChangesEveryFrame : GameRenderer
  • m_constantBufferChangesEveryPrim : GameRenderer
  • m_constantBufferData : BumpMapping , D3DPostProcessing , ResourceLoading , StereoSimpleD3D , Direct3DTutorialFrameworkView , Direct3DTutorial , TextInterop , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_constantBufferNeverChanges : GameRenderer
  • m_constants : RippleEffect , WaveEffect
  • m_container : ElementBase
  • m_Content : NotificationsExtensions::ToastContent::ToastAudio
  • m_content : ContentImageSource , Magazine::sealed
  • m_contentBitmap : TextFrame
  • m_contentSize : ContentImageSource
  • m_ContentStream
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::sealed
, SDKSample::WASAPIAudio::WASAPICapture
  • m_ContentType : SDKSample::WASAPIAudio::sealed
  • m_contextSize : CompositeModes
  • m_continuous : abstract
  • m_control : CAppWindowProvider
  • m_controller : BumpMapping , ResourceLoading , DirectXApp , Simple3DGame , Simple3DTouch , Simple3DGameXaml::sealed
  • m_controlProvider : sealed
  • m_controlRect : sealed
  • m_convolveMatrixEffect : ConvolveMatrixEffect
  • m_coreDispatcher : ProximityCPP::sealed
  • m_CoreDispatcher : SDKSample::WASAPIAudio::sealed
  • m_count : AnimateLineListPosition , Hilo::sealed , List< T > , StreamList , Buffer
  • m_cPendingEOS : CMPEG1Source
  • m_cPlotDataFilled : SDKSample::WASAPIAudio::WASAPICapture
  • m_cPlotDataMax : SDKSample::WASAPIAudio::WASAPICapture
  • m_cRef : MediaEngineNotify , SourceOp , CMPEG1Source , CMPEG1Stream
  • m_cRestartCounter : CMPEG1Source
  • m_criticalSection : CritSec
  • m_critSec : MEPlayer , CGrayscale , CInvert , CDecoder , CMPEG1Source , CPolarEffect
  • m_critsec : OpQueue< T, TOperation >
  • m_CritSec : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_cropImageCommand : Hilo::sealed
  • m_cropImageViewModel : Hilo::sealed
  • m_cropOverlayHeight : Hilo::sealed
  • m_cropOverlayLeft : Hilo::sealed
  • m_cropOverlayTop : Hilo::sealed
  • m_cropOverlayWidth : Hilo::sealed
  • m_cropX : Hilo::sealed
  • m_cropY : Hilo::sealed
  • m_csPrintSync : PrintSample::sealed
  • m_cts : Hilo::sealed
  • m_curPacketHeader : Parser
  • m_currentBlendState : BasicSprites::SpriteBatch
  • m_currentBuffer : Audio , StreamEffect
  • m_currentCheckpoint : MarbleMaze
  • m_currentEffect : D2D3DTransformsRenderer , D2DLightingEffectsRenderer
  • m_currentFontFile : FontLoader
  • m_currentLevel : Simple3DGame
  • m_currentMode : Hilo::sealed
  • m_currentNode : TreeIterator< T >
  • m_currentOpacity : Layer
  • m_currentPage : PrintSample::BasePrintPage
  • m_currentPageDescription : PrintSample::sealed
  • m_currentPosition : TextAnalysis
  • m_currentQueryId : Hilo::sealed
  • m_currentRoomSize : Physics
  • m_currentRunIndex : TextAnalysis
  • m_currentScenarioLoaded : SDKSample::MediaCapture::sealed
  • m_currentStroke : InkRenderer
  • m_currentTextureView : BasicSprites::SpriteBatch
  • m_currentTime : BasicTimer , GameTimer
  • m_cWindow : MediaEngineNotify
  • m_cylinderTexture : GameRenderer
  • m_d2dContext : abstract , SampleOverlay , FPSCounter , PageRendererContext , GameInfoOverlay , TargetTexture , LoadScreen , UserInterface , ImageRenderer , InkRenderer , PaperFragment , PaperRenderer , Program
  • m_d2dDevice : abstract , SampleOverlay , Renderer , LoadScreen , UserInterface
  • m_d2dDeviceContext : Renderer
  • m_d2dFactory : abstract , SampleOverlay , Renderer , TargetTexture , LoadScreen , UserInterface , ExtrudedTextRenderer , InkRenderer , PaperRenderer
  • m_d2dMultithread : D2DFactoryLock
  • m_d2dPrintControl : PageRenderer
  • m_d2dTargetBitmap : abstract
  • m_d2dTargetBitmapRight : abstract
  • m_d3dContext : abstract , BasicSprites::SpriteBatch , SDKMesh , ExtrudedTextRenderer
  • m_d3dDepthStencilView : abstract , ExtrudedTextRenderer
  • m_d3dDevice : abstract , BasicLoader , BasicShapes , BasicSprites::SpriteBatch , Direct3DTutorialFrameworkView , TargetTexture , SDKMesh , ExtrudedTextRenderer
  • m_d3dDeviceContext : Direct3DTutorialFrameworkView
  • m_d3dFormat : MEPlayer
  • m_d3dRenderTargetView : abstract , ExtrudedTextRenderer
  • m_d3dRenderTargetViewRight : abstract
  • m_data : FontFileStream , ImageFile , SourceOp
  • m_Data : CAsyncState
  • m_dataTextFormat : BasicSound , StreamEffect , AudioController , SimpleController
  • m_dataWriter : ProximityCPP::sealed
  • m_dateQuery : Hilo::ImageNavigationData
  • m_dateTimeForTitle : Hilo::sealed
  • m_defaultXAxis : GameObject
  • m_defaultYAxis : GameObject
  • m_defaultZAxis : GameObject
  • m_deferredResourcesReady : MarbleMaze
  • m_delta : BasicTimer
  • m_deltaTime : GameTimer
  • m_departedToken : ProximityCPP::sealed
  • m_depthStencilView : Direct3DTutorialFrameworkView
  • m_design : Document
  • m_Device : SDKSample::CustomDeviceAccess::sealed
  • m_deviceContext : GeometryRealization , GeometryRealizationFactory
  • m_DeviceIdString : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_DeviceIoControl : Samples::Devices::Fx2::sealed
  • m_DeviceProps : SDKSample::WASAPIAudio::WASAPIRenderer
  • m_DevicesList : SDKSample::WASAPIAudio::sealed
  • m_DeviceState : SDKSample::WASAPIAudio::sealed
  • m_DeviceStateChanged : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_deviceStateChangeToken : SDKSample::WASAPIAudio::sealed
  • m_devInfoCollection : SDKSample::MediaCapture::sealed
  • m_diffuseColor : Material
  • m_directComputeCS : DirectXFractal
  • m_direction : BasicCamera , Camera
  • m_disconnected : CAppWindowProvider
  • m_DiscontinuityCount : SDKSample::WASAPIAudio::sealed
  • m_displayMessage : PrintSample::InvalidPageException
  • m_displayPageRendererContext : PageRenderer
  • m_displaySize : TextFrame
  • m_displayText : GeometryRealizationSample
  • m_distantDiffuseEffect : D2DLightingEffectsRenderer
  • m_distantSpecularEffect : D2DLightingEffectsRenderer
  • m_document : ContentImageSource , Magazine::sealed
  • m_down : LonLatController , MoveLookController
  • m_downSampleRatio : DirectXFractal
  • m_downScaleBrightPass9PixelShader : D3DPostProcessing
  • m_downScaleBrightPassPixelShader : D3DPostProcessing
  • m_dpi : abstract , RippleEffect , FPSCounter , Renderer , BasicSprites::SpriteBatch , GameInfoOverlay , ExtrudedTextRenderer , ImageRenderer , InkRenderer , PaperRenderer
  • m_drawEnabled : CompositeModes
  • m_drawInfo : RippleEffect , WaveEffect
  • m_drawOverlay : SampleOverlay
  • m_drawRectCB : DirectXFractal
  • m_drawStroke : GeometryRealizationSample
  • m_duration : abstract
  • m_Duration : Animation< T > , NotificationsExtensions::ToastContent::ToastNotificationBase
  • m_dwNextTimeCode : CStreamState
  • m_dwQueueID : SDKSample::WASAPIAudio::WASAPICapture
  • m_dwriteFactory : abstract , SampleOverlay , FPSCounter , Document , FontLoader , GameHud , GameInfoOverlay , TargetTexture , UserInterface , ExtrudedTextRenderer
  • m_dwTimeCode : CStreamState
  • m_dxgiDevice : FPSCounter , Renderer
  • m_dxgiPreviewTarget : CDocumentSource
  • m_edges : AntSystem::Ant
  • m_effectContext : RippleEffect
  • m_eField : DirectX::D3DX_BC6H::ModeDescriptor
  • m_elapsedTime : D2DBasicAnimation , CountdownTimer , StopwatchTimer
  • m_elements : UserInterface
  • m_emptyTitle : Hilo::sealed
  • m_end : Buffer
  • m_End : Animation< T >
  • m_endHeight : FrameData
  • m_endPosition : AnimateLinePosition
  • m_endWidth : FrameData
  • m_engineExperiencedCriticalError : Audio
  • m_entries : HighScoreTable
  • m_eventName : CoreWindowEvents
  • m_eventRegistrationToken : SDKSample::MediaCapture::sealed
  • m_eventTextFormat : CoreWindowEvents
  • m_exceptionPolicy
: Hilo::sealed
, Hilo::FileSystemRepository
, Hilo::ThumbnailGenerator
, Hilo::ViewModelBase
  • m_executeDelegate : Hilo::sealed
  • m_extrudedTextRenderer : PostcardRenderer
  • m_eye : Camera
  • m_fadeOutTime : TextElement
  • m_fadeOutTimeElapsed : TextElement
  • m_fadeStartingOpacity : TextElement
  • m_farPlane : Camera
  • m_farZ : StereoSimpleD3D
  • m_fastGenerate : DirectXFractal
  • m_featureLevel : abstract , Renderer
  • m_feedCompletionEvents : SimpleBlogReader::sealed
  • m_feeds : SimpleBlogReader::sealed
  • m_fEOS : MEPlayer
  • m_fExitApp : MEPlayer
  • m_fieldOfView : Camera
  • m_figureVertices : Extruder::ExtrudingSink
  • m_file : Image , RandomAccessReader
  • m_fileDate : Hilo::ImageNavigationData , Hilo::sealed
  • m_fileInfo : Hilo::sealed
  • m_fileName : Document
  • m_fileNames : Hilo::WideFiveImageTile
  • m_filePath : Hilo::ImageNavigationData , Hilo::sealed
  • m_fillMaskDestBounds : GeometryRealization
  • m_fillMaskSourceBounds : GeometryRealization
  • m_fillMesh : GeometryRealization
  • m_fillRT : GeometryRealization
  • m_filmStripLoadedToken : Hilo::sealed
  • m_finalPassPixelShader : D3DPostProcessing
  • m_finalPS : DirectXFractal
  • m_finalRTV : DirectXFractal
  • m_finalSRV : DirectXFractal
  • m_fInitSuccess : MEPlayer
  • m_fireInUse : MoveLookController
  • m_fireLastPoint : MoveLookController
  • m_fireLowerRight : MoveLookController
  • m_firePointerID : MoveLookController
  • m_firePressed : MoveLookController
  • m_fireUpperLeft : MoveLookController
  • m_firstChild : Element
  • m_firstDigitOffset : FPSCounter
  • m_firstPage : PrintSample::BasePrintPage
  • m_firstRun : D2DTextAnimation
  • m_fLoop : MEPlayer
  • m_floorTexture : GameRenderer
  • m_floorTriList : Collision
  • m_flowLayout : DWriteVerticalText
  • m_flowLayoutSink : DWriteVerticalText
  • m_flowLayoutSource : DWriteVerticalText
  • m_flRate : SetRateOp , CMPEG1Source , CMPEG1Stream
  • m_folderQuery : Hilo::sealed
  • m_fontCollection : Document
  • m_fontFileCount : FontLoader
  • m_fontFileStreamIndex : FontLoader
  • m_fontFileStreams : FontLoader
  • m_fontLoader : Document
  • m_fontName : DWriteVerticalText , TextStyle
  • m_fontSize : TextFrame , DWriteVerticalText , TextStyle
  • m_fontStyle : TextStyle
  • m_fontWeight : TextStyle
  • m_foreground : Simple3DGameXaml::sealed
  • m_formattedPrice : Simple3DGameXaml::sealed
  • m_forward : LonLatController , MoveLookController
  • m_fPlaying : MEPlayer
  • m_frameArray : SDKMesh
  • m_frameRate : CDecoder
  • m_frequency : BasicTimer
  • m_fStopTimer : MEPlayer
  • m_fThin : SetRateOp
  • m_fUseDX : MEPlayer
  • m_fWriting : SDKSample::WASAPIAudio::WASAPICapture
  • m_Fx2Device : CustomDeviceAccess::DeviceList , SDKSample::CustomDeviceAccess::DeviceList
  • m_Fx2Devices : CustomDeviceAccess::DeviceList
  • m_Fx2Watcher : CustomDeviceAccess::DeviceList , SDKSample::CustomDeviceAccess::DeviceList
  • m_game : DirectXApp , GameRenderer , Simple3DGameXaml::sealed
  • m_gameActive : Simple3DGame
  • m_gameConfig : Simple3DGame
  • m_gameHud : GameRenderer
  • m_gameInfoOverlay : GameRenderer
  • m_gameInfoOverlayCommand : DirectXApp
  • m_gameInfoOverlayState : DirectXApp , Simple3DGameXaml::sealed
  • m_gameResourcesLoaded : GameRenderer
  • m_gameState : MarbleMaze
  • m_gaussianBlurEffect : D2DEffectsHelloWorld
  • m_geometry : GeometryRealization , GeometryRealizationSample , PaperFragment
  • m_geometryShader : BasicSprites::SpriteBatch
  • m_gestureRecognizer : D2DTextAnimation , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , DirectXApp , DWriteParagraphText
  • m_getPhotoAsyncIsRunning : Hilo::sealed
  • m_globalOffsetX : D2D3DTransformsRenderer
  • m_globalOffsetY : D2D3DTransformsRenderer
  • m_globalOffsetZ : D2D3DTransformsRenderer
  • m_glowConstantBuffer : D3DPostProcessing
  • m_glowEffect : TextFrame
  • m_glowPixelShader : D3DPostProcessing
  • m_glowTextureHeight : D3DPostProcessing
  • m_glowTextureRenderTargetViews : D3DPostProcessing
  • m_glowTextureShaderResourceViews : D3DPostProcessing
  • m_glowTextureWidth : D3DPostProcessing
  • m_Glyph : NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
  • m_glyphOrientationMode : TextAnalysis
  • m_gradient : DirectXFractal
  • m_gravity : Physics
  • m_greenBrush : TargetTexture , sealed , BasicSound
  • m_greenProvider : sealed
  • m_ground : GameObject
  • m_groundTriList : Collision
  • m_groupCommand : Hilo::sealed
  • m_handler : Hilo::ObserveException< T >
  • m_hasCount : Hilo::sealed
  • m_hasFileUpdateTask : Hilo::sealed
  • m_hasHandlers : Hilo::HiloPage
  • m_haveFocus : DirectXApp , Simple3DGameXaml::sealed
  • m_hDev : CAutoDXDevLockBase< DevManager, DevInterface >
  • m_hDeviceHandle : CInvert
  • m_headerTextFormat : SimpleController
  • m_headingTextFormat : CompositeModes
  • m_heapData : SDKMesh
  • m_height : CDocumentSource , Face , Extruder::ExtrudingSink , FrameProcessing , Program , Shape
  • m_heightInInches : StereoSimpleD3D
  • m_heightVector : Face
  • m_heuristicShortestDistance : AntSystem::Ant
  • m_hFile : SDKMesh
  • m_hFileMappingObject : SDKMesh
  • m_highlightedWords : SDKSample::TextEditing::sealed
  • m_highScoreButton : MarbleMaze
  • m_highScoreTable : MarbleMaze
  • m_hintMessage : StereoSimpleD3D
  • m_hit : GameObject
  • m_hitColor : Material
  • m_hitMaterial : GameObject
  • m_hitSound : GameObject
  • m_hitTime : GameObject
  • m_homeKeyActive : MarbleMaze
  • m_homeKeyPressed : MarbleMaze
  • m_horizontalOffset : CompositeModes
  • m_hr : ContentImageSource::ImageSourceDrawHelper , SDKSample::WASAPIAudio::sealed
  • m_Hr : Samples::Devices::Fx2::sealed
  • m_hubViewModelCallback : Hilo::FileSystemRepository
  • m_Id : Samples::Devices::Fx2::sealed
  • m_id : StreamList
  • m_idIncrement : SampleOverlay
  • m_image : Hilo::sealed
  • m_imageableRect : CDocumentSource
  • m_imageBrowserViewModelCallback : Hilo::FileSystemRepository
  • m_imageBrush : CommandListRenderer
  • m_imageFailedEventToken : Hilo::sealed
  • m_imageFileName : SaveAsImageFile
  • m_imageHeightInPixels : CGrayscale , CInvert , CDecoder , CPolarEffect
  • m_imageMargin : Hilo::sealed
  • m_imagePixelSize : ImageRenderer
  • m_imageRenderer : PostcardRenderer
  • m_imageRotate : D2DInterpolationModes
  • m_Images : NotificationsExtensions::NotificationBase
  • m_imageSize : D2D3DTransformsRenderer , CompositeModes , ConvolveMatrixEffect , D2DInterpolationModes , LoadScreen , D2DLightingEffectsRenderer
  • m_imageSizeDips : D2DInterpolationModes , ImageRenderer
  • m_imageSource : ContentImageSource
  • m_imageSourceNative : ContentImageSource::ImageSourceDrawHelper , ContentImageSource
  • m_imageText : PrintSample::sealed
  • m_imageViewModelCallback : Hilo::FileSystemRepository
  • m_imageWidthInPixels : CGrayscale , CInvert , CDecoder , CPolarEffect
  • m_imageZoomFactor : ImageRenderer
  • m_impl : TripOptimizerComponent::sealed
  • m_indexBuffer : BumpMapping , DirectXFractal , D3DPostProcessing , ResourceLoading , BasicSprites::SpriteBatch , StereoSimpleD3D , Direct3DTutorial , TextInterop , abstract , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_indexBufferArray : SDKMesh
  • m_indexCount : BumpMapping , DirectXFractal , D3DPostProcessing , ResourceLoading , StereoSimpleD3D , Direct3DTutorial , TextInterop , abstract , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_indices : SDKMesh
  • m_inGameStopwatchTimer : MarbleMaze
  • m_initializationTask : Hilo::sealed
  • m_initialized : GameRenderer
  • m_initialNodeIndex : AntSystem::Ant
  • m_initialOpacity : Layer
  • m_initialPS : DirectXFractal
  • m_inkManager : InkRenderer
  • m_inkRenderer : PostcardRenderer
  • m_inkState : InkRenderer
  • m_inlineImage : DWriteInlineObject
  • m_inProgress : Hilo::sealed
  • m_inputImage : D2DEffectsOnPrimitives
  • m_inputLayout : BumpMapping , DirectXFractal , D3DPostProcessing , ResourceLoading , BasicSprites::SpriteBatch , StereoSimpleD3D , Direct3DTutorial , TextInterop , MarbleMaze , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_inputRect : RippleEffect , WaveEffect
  • m_installedLocation : MediaReader
  • m_installedLocationPath : MediaReader
  • m_instance : UserInterface
  • m_instanceData : BasicSprites::SpriteBatch
  • m_instanceDataBuffer : BasicSprites::SpriteBatch
  • m_intermediateRenderTargetHeight : D3DPostProcessing
  • m_intermediateRenderTargetWidth : D3DPostProcessing
  • m_intermediateTextureRenderTargetView : D3DPostProcessing
  • m_intermediateTextureShaderResourceView : D3DPostProcessing
  • m_intersectsGround : Collision
  • m_inverseView : Camera
  • m_isAmpPixelArrayPopulated : Hilo::sealed
  • m_isApp : Simple3DGameXaml::sealed
  • m_isAppActive : Simple3DGameXaml::sealed
  • m_isAppBarEnabled : Hilo::ViewModelBase
  • m_isAppBarOpen : Hilo::ViewModelBase
  • m_isAppBarSticky : Hilo::ViewModelBase
  • m_isAppTrial : Simple3DGameXaml::sealed
  • m_isAudioStarted : Audio , StreamEffect
  • m_isAvailableForPurchase : Simple3DGameXaml::sealed
  • m_isControllerConnected : MoveLookController , AudioController , SimpleController
  • m_isCropOverlayVisible : Hilo::sealed
  • m_isFadingOut : TextElement
  • m_isHeadsetConnected : AudioController
  • m_isIncreasedSpacing : DWriteParagraphText
  • m_IsInitialized : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_isInvalidThumbnail : Hilo::sealed
  • m_isJustified : DWriteParagraphText
  • m_IsLaunchedByTap : ProximityCPP::sealed
  • m_IsMFLoaded : SDKSample::WASAPIAudio::sealed
  • m_isOpaque : ContentImageSource
  • m_isPlayingHolder : anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • m_isProductActive : Simple3DGameXaml::sealed
  • m_isRegisteredForPrinting : PrintSample::BasePrintPage
  • m_isSaving : Hilo::sealed
  • m_isSnapped : D2DInterpolationModes , PageRenderer , SaveAsImageFile
  • m_isSourcePixelsPopulated : Hilo::sealed
  • m_isTrial : Simple3DGameXaml::sealed
  • m_isWindowClosed : D2DInterpolationModes
  • m_isWindowVisible : D2DInterpolationModes
  • m_items : SimpleBlogReader::sealed
  • m_keyName : PersistentState
  • m_labelFormat : sealed
  • m_Lang : NotificationsExtensions::NotificationContentText , NotificationsExtensions::NotificationBase
  • m_lastDistance : LonLatController
  • m_lastEnumTime : AudioController , SimpleController
  • m_lastFileChangeTime : Hilo::sealed
  • m_lastHeadsetCheckTime : AudioController
  • m_lastPoint : Extruder::ExtrudingSink
  • m_lastTime : BasicTimer
  • m_latitude : LonLatController
  • m_Launch : NotificationsExtensions::ToastContent::ToastNotificationBase
  • m_leading : TextFrame
  • m_left : LonLatController , MoveLookController , Hilo::sealed
  • m_length : AnimateLinePosition , Cylinder
  • m_lengthOfPath : AntSystem::Ant
  • m_level : Simple3DGame
  • m_levelActive : Simple3DGame
  • m_levelBitmap : GameInfoOverlay
  • m_levelBonusTime : Simple3DGame
  • m_levelCount : Simple3DGame
  • m_levelDuration : Simple3DGame
  • m_levelResourcesLoaded : GameRenderer
  • m_levelTimeRemaining : Simple3DGame
  • m_licenseInformation : Simple3DGameXaml::sealed
  • m_licenseState : Simple3DGameXaml::sealed
  • m_lightPositionZ : D2DLightingEffectsRenderer
  • m_lightStrength : MarbleMaze
  • m_linearSampler : DirectXFractal , D3DPostProcessing , BasicSprites::SpriteBatch
  • m_List : SDKSample::CustomDeviceAccess::DeviceList
  • m_listingInformation : Simple3DGameXaml::sealed
  • m_loader : Hilo::sealed , Hilo::WideFiveImageTile
  • m_loading : SDKMesh
  • m_loadingComplete : ResourceLoading
  • m_loadingCount : DirectXApp
  • m_loadScreen : MarbleMaze
  • m_localeName : DWriteVerticalText , TextAnalysis
  • m_localOffsetX : D2D3DTransformsRenderer
  • m_localOffsetY : D2D3DTransformsRenderer
  • m_localOffsetZ : D2D3DTransformsRenderer
  • m_location : Document , FontLoader , BasicReaderWriter
  • m_locationPath : BasicReaderWriter
  • m_Lock : Samples::Devices::Repeater
  • m_locked : CAutoDXDevLockBase< DevManager, DevInterface >
  • m_logoBitmap : SampleOverlay , DWriteCustomTextRenderer , GameHud
  • m_logoSize : SampleOverlay , GameHud
  • m_longitude : LonLatController
  • m_lonLatCommand : LonLatController
  • m_lonLatInUse : LonLatController
  • m_lonLatLastDelta : LonLatController
  • m_lonLatLastPoint : LonLatController
  • m_lonLatLastPoint1 : LonLatController
  • m_lonLatLastPoint2 : LonLatController
  • m_lonLatPointerID : LonLatController
  • m_lonLatPointerID1 : LonLatController
  • m_lonLatPointerID2 : LonLatController
  • m_lookAt : Camera
  • m_lookControlLayout : Simple3DTouch
  • m_lookInUse : MoveLookController
  • m_lookLastDelta : MoveLookController
  • m_lookLastPoint : MoveLookController
  • m_lookMetrics : Simple3DTouch
  • m_lookPointerID : MoveLookController
  • m_Loop : NotificationsExtensions::ToastContent::ToastAudio
  • m_mainPage
: D2D3DTransforms::sealed
, Postcard::sealed
, D2DLightingEffects::sealed
, Simple3DGameXaml::sealed
  • m_marbleConstantBufferData : MarbleMaze
  • m_marbleMesh : MarbleMaze
  • m_margin : List< T > , PageRendererContext
  • m_masteringVoice : XAudio2SoundPlayer , AudioController
  • m_materialArray : SDKMesh
  • m_matrixHeight : D2D3DTransformsRenderer
  • m_matrixTop : D2D3DTransformsRenderer
  • m_matrixValueFormat : D2D3DTransformsRenderer
  • m_matrixWidth : D2D3DTransformsRenderer
  • m_maxBound : Simple3DGame
  • m_maxCollisionSpeed : Physics
  • m_maxRealizationDimension : GeometryRealization , GeometryRealizationFactory
  • m_maxRollingSpeed : Physics
  • m_maxStreamLengthInBytes : MediaStreamer
  • m_maxTitleSize : GameHud
  • m_mazeConstantBufferData : MarbleMaze
  • m_mazeMesh : MarbleMaze
  • m_mediaCaptureMgr
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • m_MediaControlPauseToken : SDKSample::WASAPIAudio::sealed
  • m_MediaControlPlayPauseToken : SDKSample::WASAPIAudio::sealed
  • m_MediaControlPlayToken : SDKSample::WASAPIAudio::sealed
  • m_MediaControlStopToken : SDKSample::WASAPIAudio::sealed
  • m_mesh : GameObject
  • m_meshArray : SDKMesh
  • m_meshColor : Material
  • m_meshHeader : SDKMesh
  • m_messageFormat : PageRenderer , PageRendererContext
  • m_MFSource : SDKSample::WASAPIAudio::WASAPIRenderer
  • m_MFSourceReader : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_minBound : Simple3DGame
  • m_missedFrameHistory : AutoThrottle
  • m_MixFormat
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • m_modelMatrix : GameObject
  • m_modeTextFormat : D2DInterpolationModes
  • m_modeTextLeft : D2DInterpolationModes
  • m_modeTextRight : D2DInterpolationModes
  • m_month : Hilo::sealed
  • m_monthGroups : Hilo::sealed
  • m_monthQueryChange : Hilo::FileSystemRepository
  • m_months : Hilo::sealed
  • m_mouseInUse : MoveLookController
  • m_mouseLastPoint : MoveLookController
  • m_mouseLeftInUse : MoveLookController
  • m_mouseLookInUse : MoveLookController
  • m_mouseLookPointerID : MoveLookController
  • m_mousePointerID : MoveLookController
  • m_mouseRightInUse : MoveLookController
  • m_moveCommand : MoveLookController
  • m_moveControlLayout : Simple3DTouch
  • m_moveFirstDown : MoveLookController
  • m_moveInUse : MoveLookController
  • m_moveLowerRight : MoveLookController
  • m_moveMetrics : Simple3DTouch
  • m_movePointerID : MoveLookController
  • m_movePointerPosition : MoveLookController
  • m_moveUpperLeft : MoveLookController
  • m_movingThrottle : DirectXFractal
  • m_musicEngine : Audio , StreamEffect
  • m_musicEngineCallback : Audio
  • m_musicMasteringVoice : Audio , StreamEffect
  • m_musicReverbVoiceLargeRoom : Audio
  • m_musicReverbVoiceSmallRoom : Audio
  • m_musicSourceVoice : Audio , StreamEffect
  • m_musicStreamer : Audio , StreamEffect
  • m_muxRate : Parser
  • m_name : Element , Hilo::sealed
  • m_navigateBackEventToken : Hilo::HiloPage
  • m_navigateHomeEventToken : Hilo::HiloPage
  • m_navigateToPageEventToken : Hilo::HiloPage
  • m_navigateToPicturesCommand : Hilo::sealed
  • m_nearPlane : Camera
  • m_nearZ : StereoSimpleD3D
  • m_needsResourceUpdate : D2DLightingEffectsRenderer
  • m_neighborWindow : FrameProcessing , Hilo::sealed
  • m_neighbourArea : FrameData
  • m_newHighScore : MarbleMaze
  • m_nextId : Level2 , Level4
  • m_nextSibling : Element
  • m_nodes : AntSystem::Ant
  • m_normal : Face
  • m_normalMaterial : GameObject
  • m_normals : BumpMapping
  • m_normalSampler : BumpMapping
  • m_normalSRV : BumpMapping
  • m_Number : NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
  • m_numberOfSquares : GeometryRealizationSample
  • m_numberSubstitution : TextAnalysis
  • m_numBuffers : abstract
  • m_numIterationsPerFrame : DirectXFractal
  • m_numOutstandingResources : SDKMesh
  • m_numParticlesToDraw : SimpleSprites
  • m_numPointersDown : LonLatController
  • m_numSpritesDrawn : BasicSprites::SpriteBatch
  • m_numVertices : WaveEffect
  • m_objectGeometry : D2DBasicAnimation
  • m_objective : abstract
  • m_objects : Simple3DGame
  • m_offset : Element , ImageFile , LoadScreen
  • m_OnByteStreamRead : CMPEG1Source
  • m_OnProcessQueue : OpQueue< T, TOperation >
  • m_onRenderingEventToken : Simple3DGameXaml::sealed
  • m_op : SourceOp
  • m_opacity : Rectangle , TextFrame
  • m_opacityBitmap : D2DTextAnimation
  • m_OpQueue : OpQueue< T, TOperation >
  • m_orientation : abstract
  • m_orientationChangedEventToken : SDKSample::MediaCapture::sealed
  • m_Oscilliscope : SDKSample::WASAPIAudio::sealed
  • m_OutputStream : SDKSample::WASAPIAudio::WASAPICapture
  • m_overlayWidth : SampleOverlay
  • m_p2DBuffer : VideoBufferLock
  • m_padding : SampleOverlay , TextButton
  • m_pageCollection : PrintSample::sealed
  • m_pageList : PrintSample::sealed
  • m_pageRangeEditVisible : PrintSample::sealed
  • m_pageSize : Design
  • m_paginateCalled : CDocumentSource
  • m_panPosition : ExtrudedTextRenderer
  • m_paperFragmentList : PaperRenderer
  • m_paperMode : PaperRenderer
  • m_paperRenderer : PostcardRenderer
  • m_parent : Element
  • m_pArray : Buffer
  • m_particle : SimpleSprites
  • m_particleData : SimpleSprites
  • m_path : SDKMesh
  • m_pathGeometry : D2DBasicAnimation , Shape
  • m_pathLength : D2DBasicAnimation
  • m_pAttributes : CGrayscale , CInvert , CPolarEffect
  • m_pause : MoveLookController
  • m_paused : GeometryRealizationSample
  • m_pausedText : MarbleMaze
  • m_pausedTime : GeometryRealizationSample , GameTimer
  • m_pauseKeyActive : MarbleMaze
  • m_pauseKeyPressed : MarbleMaze
  • m_pausePressed : MoveLookController
  • m_pauseRequested : Simple3DGameXaml::sealed
  • m_pbData : CDecoder
  • m_pBeginOpenResult : CMPEG1Source
  • m_pBuffer : VideoBufferLock , CDecoder
  • m_pBufferImage : FrameProcessing
  • m_pByteStream : CMPEG1Source
  • m_pCB : MediaEngineNotify
  • m_pContext : CInvert
  • m_pCriticalSection : AutoLock
  • m_pCurrentImage : FrameProcessing
  • m_pCurrentOp : CMPEG1Source
  • m_pDevice : CInvert
  • m_pDX11Manager : CInvert
  • m_peerFinderStarted : ProximityCPP::sealed
  • m_peerInformationList : ProximityCPP::sealed
  • m_persistentState : MarbleMaze
  • m_perspective : D2D3DTransformsRenderer
  • m_pEventQueue : CMPEG1Source , CMPEG1Stream
  • m_pFactory : OutlineRenderer
  • m_pFrame : FrameData
  • m_pFrameProcessor : FrameData
  • m_pGeometry : OutlineRenderer
  • m_phaseCount : FrameData
  • m_phases : Hilo::sealed
  • m_pHeader : CMPEG1Source , Parser
  • m_photo : Hilo::ImageBase , Hilo::sealed
  • m_photoCache : Hilo::sealed , Hilo::PhotoCache
  • m_photoCts : Hilo::sealed
  • m_photoPath : Hilo::sealed
  • m_photos : Hilo::sealed
  • m_photoScale : PrintSample::sealed
  • m_photosCts : Hilo::sealed
  • m_photoSize : PrintSample::sealed
  • m_photoStorageFile : MediaCapture::BasicCapture , SDKSample::MediaCapture::sealed
  • m_physics : MarbleMaze
  • m_pickFileTask : MEPlayer
  • m_pictureGroup : Hilo::sealed
  • m_pictureGroupPropertyChangedToken : Hilo::sealed
  • m_pictureHubGroupQueryChange : Hilo::FileSystemRepository
  • m_pInBufferTex : CInvert
  • m_pIndexLookup : CPolarEffect
  • m_pInputType : CGrayscale , CInvert , CDecoder , CPolarEffect
  • m_pInvokeFn : AsyncCallback< T >
  • m_pitch : MoveLookController , FrameData , FrameProcessing
  • m_pixelShader : BumpMapping , D3DPostProcessing , ResourceLoading , BasicSprites::SpriteBatch , StereoSimpleD3D , Direct3DTutorial , TextInterop , GameRenderer , Material , MarbleMaze , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_pixelShaderFlat : GameRenderer
  • m_planeNormal : AnimateCirclePosition
  • m_player : Simple3DGame , VideoView
  • m_PlotData : SDKSample::WASAPIAudio::WASAPICapture
  • m_plotDataReadyToken : SDKSample::WASAPIAudio::sealed
  • m_point : Face
  • m_PointArray : SDKSample::WASAPIAudio::sealed
  • m_pointDiffuseEffect : D2DLightingEffectsRenderer
  • m_pointer : Hilo::sealed
  • m_pointerId : InkRenderer
  • m_pointerPressed : Hilo::sealed
  • m_pointQueue : MarbleMaze
  • m_pointSampler : DirectXFractal , D3DPostProcessing
  • m_pointSpecularEffect : D2DLightingEffectsRenderer
  • m_policy : Hilo::ExceptionPolicyFactory
  • m_polygonAbsolute : Shape
  • m_polygonRelative : Shape
  • m_pOriginalPixels : Hilo::sealed
  • m_position : FPSCounter , BasicCamera , LonLatController , GameObject , Camera , Physics , PaperFragment , MoveLookController
  • m_possiblePurchaseUpgrade : Simple3DGameXaml::sealed
  • m_pOutBufferStage : CInvert
  • m_pOutBufferTex : CInvert
  • m_pOutputType : CGrayscale , CInvert , CDecoder , CPolarEffect
  • m_pParent : AsyncCallback< T >
  • m_pParser : CMPEG1Source
  • m_pPD : StartOp
  • m_pPixelShader : CInvertModule
  • m_pPresentationDescriptor : CMPEG1Source
  • m_pRadiusTransformFn : CPolarEffect
  • m_preGameCountdownTimer : MarbleMaze
  • m_pressComplete : Simple3DGameXaml::sealed
  • m_pressed : TextButton
  • m_pressResult : DirectXApp , Simple3DGameXaml::sealed
  • m_previousPosition : Physics
  • m_previousTime : GameTimer
  • m_printDocument : PrintSample::BasePrintPage
  • m_printDocumentSource : PrintSample::BasePrintPage
  • m_printManager : DirectXApp
  • m_printPreviewPages : PrintSample::BasePrintPage
  • m_printTaskRequestedEventToken : PrintSample::BasePrintPage
  • m_productId : Simple3DGameXaml::sealed
  • m_profiledWicBitmap : PageRenderer
  • m_program : sealed
  • m_projAspect : StereoSimpleD3D
  • m_projection : Camera , BasicCamera
  • m_projectionMatrix : Camera
  • m_projectionMatrixLeft : Camera
  • m_projectionMatrixRight : Camera
  • m_propertyHeight : D2D3DTransformsRenderer
  • m_propertyTop : D2D3DTransformsRenderer
  • m_propertyValueFormat : D2D3DTransformsRenderer
  • m_propertyWidth : D2D3DTransformsRenderer
  • m_proximityDevice : ProximityCPP::sealed
  • m_pSample : CGrayscale , CInvert , CPolarEffect
  • m_pSampleRequest : CMPEG1Source
  • m_pSampleStateLinear : CInvertModule
  • m_pScreenQuadVB : CInvertModule
  • m_pSinkNoRef : PointSnapper::PointSnappingSink
  • m_pSource : CMPEG1Stream::SourceLock , CMPEG1Stream
  • m_pSourcePixels : Hilo::sealed
  • m_pStreamDescriptor : CMPEG1Stream
  • m_pThetaTransformFn : CPolarEffect
  • m_ptPointerPosition : Shape
  • m_pTransform : CInvert
  • m_pTransformFn : CGrayscale , CPolarEffect
  • m_publishedMessageId : ProximityCPP::sealed
  • m_pVertexShader : CInvertModule
  • m_quadLayout : D3DPostProcessing
  • m_quadVertexBuffer : D3DPostProcessing
  • m_quadVertexShader : D3DPostProcessing
  • m_query : Hilo::sealed
  • m_queryPhotoImageAsyncIsRunning : Hilo::sealed
  • m_radius : Sphere , LonLatController , AnimateCirclePosition , Cylinder , Physics
  • m_rcDest : CGrayscale
  • m_rcTarget : MEPlayer
  • m_ReadBuffer : CMPEG1Source
  • m_reader : MediaStreamer
  • m_ReaderState : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_readingDirection : TextAnalysis , DWriteVerticalText
  • m_realization : GeometryRealizationSample
  • m_realizationTransform : GeometryRealization
  • m_realizationTransformInv : GeometryRealization
  • m_realizationTransformIsIdentity : GeometryRealization
  • m_receivedChangeWhileRunning : Hilo::sealed
  • m_recenter : CommandListRenderer
  • m_recenterStartPosition : CommandListRenderer
  • m_recenterStartTime : CommandListRenderer
  • m_recenterStartZoom : CommandListRenderer
  • m_recordStorageFile
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • m_rectangleHeight : BasicSound
  • m_rectangleWidth : BasicSound
  • m_redBrush : sealed , TargetTexture
  • m_redProvider : sealed
  • m_ref : Extruder::ExtrudingSink , GeometryRealization , GeometryRealizationFactory , OutlineRenderer , PointSnapper::PointSnappingSink
  • m_Ref : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_refCount : RippleEffect , WaveEffect , ContentImageSource , FontFileStream , FontLoader , ImageFile
  • m_referenceBitmap : DxgiRotation
  • m_referenceBitmapSource : DxgiRotation
  • m_renderBufferPS : DirectXFractal
  • m_renderDuration : D2DInterpolationModes
  • m_renderer : DirectXApp , D2D3DTransforms::sealed , Document , CDocumentSource , DirectXApp , Simple3DGame , Postcard::sealed , DirectXApp , D2DLightingEffects::sealed , Simple3DGameXaml::sealed , DirectXApp
  • m_renderingParams : DWriteVerticalText
  • m_renderNeeded : DirectXApp , Simple3DGameXaml::sealed
  • m_renderObjects : Simple3DGame
  • m_renderTargetInfoCbuffer : BasicSprites::SpriteBatch
  • m_renderTargetSize : abstract , BasicSprites::SpriteBatch , ExtrudedTextRenderer
  • m_renderTargetView : Direct3DTutorialFrameworkView
  • m_renderTexturePS : DirectXFractal
  • m_renderTimeFormat : D2DInterpolationModes
  • m_renderTimer : D2DInterpolationModes
  • m_RepeaterStoppedFunction : Samples::Devices::Repeater
  • m_repository : Hilo::sealed
  • m_repulsors : SimpleSprites
  • m_requestCount : PrintSample::sealed
  • m_requestingPeer : ProximityCPP::sealed
  • m_Requests : CMPEG1Stream
  • m_RequireSquareContent : NotificationsExtensions::TileContent::TileWideBase
  • m_resetCamera : MarbleMaze
  • m_resetMarbleRotation : MarbleMaze
  • m_resultsText : MarbleMaze
  • m_resumeCartoonizeCommand : Hilo::sealed
  • m_resumeCropCommand : Hilo::sealed
  • m_resumeRotateCommand : Hilo::sealed
  • m_retrievedPhotos : Hilo::sealed
  • m_reverbParametersLarge : Audio
  • m_reverbParametersSmall : Audio
  • m_right : MoveLookController , LonLatController , Hilo::sealed
  • m_rootElement : Document
  • m_rootPage : PrintSample::BasePrintPage , ProximityCPP::sealed
  • m_rootXml : Document
  • m_rotateCommand : Hilo::sealed
  • m_rotateImageCommand : Hilo::sealed
  • m_rotationAngle : Hilo::sealed , D2DPerspectiveTransform
  • m_rotationKeyDown : DirectXApp
  • m_rotationMatrix : AnimateCirclePosition , Face , Cylinder
  • m_rotationTransform2D : abstract
  • m_rotationTransform3D : abstract
  • m_rotationX : D2D3DTransformsRenderer
  • m_rotationY : D2D3DTransformsRenderer
  • m_rotationZ : D2D3DTransformsRenderer
  • m_route : AntSystem::Ant
  • m_rowSpan : Hilo::sealed
  • m_rt : CStreamState
  • m_rtFrame : CDecoder
  • m_rtLength : CDecoder
  • m_runningMonthQuery : Hilo::sealed
  • m_runningOperation : Hilo::sealed
  • m_runningQuery : Hilo::sealed
  • m_runningQueryPhotosAsync : Hilo::sealed
  • m_runningQuerySinglePhotoAsync : Hilo::sealed
  • m_runningYearQuery : Hilo::sealed
  • m_runOperation : Hilo::sealed
  • m_runs : TextAnalysis
  • m_sampleMode : PostcardRenderer
  • m_sampleName : SampleOverlay
  • m_sampleOverlay : D2DTextAnimation , D2DBasicAnimation , D2DEffectsHelloWorld , CommandListRenderer , CompositeModes , D2DEffectsOnPrimitives , GeometryRealizationSample , D2DInterpolationModes , PageRenderer , SaveAsImageFile , BumpMapping , D3DPostProcessing , ResourceLoading , SimpleSprites , StereoSimpleD3D , Direct3DTutorial , TextInterop , DWriteCustomTextRenderer , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , MarbleMaze , CoreWindowEvents , Simple3DTouch , DxgiRotation , sealed , BasicSound , StreamEffect , AudioController , SimpleController , DWriteVerticalText , OfferReclaimAPI , DWriteHelloWorld , D2DPerspectiveTransform , DirectXFractal , ConvolveMatrixEffect
  • m_SampleQueue : SDKSample::WASAPIAudio::MFSampleGenerator , SDKSample::WASAPIAudio::ToneSampleGenerator
  • m_SampleQueueTail : SDKSample::WASAPIAudio::MFSampleGenerator , SDKSample::WASAPIAudio::ToneSampleGenerator
  • m_sampler : BumpMapping , ResourceLoading , StereoSimpleD3D , Direct3DTutorial , MarbleMaze , Simple3DTouch , OfferReclaimAPI , DxgiRotation , D3DPostProcessing , TextInterop
  • m_SampleReadyAsyncResult : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_SampleReadyEvent : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_SampleReadyKey : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_samplerLinear : GameRenderer
  • m_Samples : CMPEG1Stream
  • m_saturationEffect : ImageRenderer
  • m_saveCommand : Hilo::sealed
  • m_savedState : Simple3DGame
  • m_scale : Shape
  • m_scaledHeight : Hilo::sealed
  • m_scaledWidth : Hilo::sealed
  • m_scaleEffect : CompositeModes
  • m_scaleX : D2D3DTransformsRenderer
  • m_scaleY : D2D3DTransformsRenderer
  • m_SCR : Parser
  • m_screenSavingState : SaveAsImageFile
  • m_secondsPerCount : GameTimer
  • m_secondsRemaining : CountdownTimer
  • m_segment : AnimateLineListPosition
  • m_selected : TextButton
  • m_selectedEffect : D2DInterpolationModes
  • m_selectedFragment : PaperRenderer
  • m_selectedKernel : ConvolveMatrixEffect
  • m_selectionMode : PrintSample::sealed
  • m_settingsValues : PersistentState
  • m_shadowColorBrush : TextElement
  • m_shapes : Program
  • m_showTitle : GameHud
  • m_singlePassPS : DirectXFractal
  • m_size : Element , ElementBase , FrameData
  • m_Size : CAsyncState , SDKSample::WASAPIAudio::sealed
  • m_size : FrameProcessing
  • m_sizeChangedAttached : Hilo::sealed
  • m_sizeX : WaveEffect
  • m_sizeY : WaveEffect
  • m_skewX : WaveEffect
  • m_skewY : WaveEffect
  • m_snappedViewFormat : D2D3DTransformsRenderer , CompositeModes , SaveAsImageFile
  • m_socket : ProximityCPP::sealed
  • m_socketClosed : ProximityCPP::sealed
  • m_solidColorBrush : GeometryRealizationSample
  • m_soundData : SoundEffect , SoundFileReader
  • m_soundEffectBuffer : AudioController
  • m_soundEffectBufferData : SoundEffectData
  • m_soundEffectBufferLength : SoundEffectData
  • m_soundEffectEngine : Audio
  • m_soundEffectEngineCallback : Audio
  • m_soundEffectMasteringVoice : Audio
  • m_soundEffectReverbVoiceLargeRoom : Audio
  • m_soundEffectReverbVoiceSmallRoom : Audio
  • m_soundEffects : Audio
  • m_soundEffectSampleRate : SoundEffectData
  • m_soundEffectSourceVoice : SoundEffectData
  • m_soundEffectStarted : SoundEffectData
  • m_soundEventType : SoundEffectData
  • m_soundFormat : SoundFileReader
  • m_soundLevelHandler : MediaCapture::BasicCapture , MediaCapture::AudioCapture
  • m_soundList : XAudio2SoundPlayer
  • m_soundPlayer : BasicSound
  • m_sourceImage : ImageFrame
  • m_sourceName : ImageFrame , TextFrame
  • m_sourceText : TextFrame
  • m_sourceVoice : AudioController , SoundEffect
  • m_spCapture : SDKSample::WASAPIAudio::sealed
  • m_spDevManager : CAutoDXDevLockBase< DevManager, DevInterface >
  • m_spDX11Device : MEPlayer
  • m_spDX11DeviceContext : MEPlayer
  • m_spDX11SwapChain : MEPlayer
  • m_spDXGIManager : MEPlayer
  • m_spDXGIOutput : MEPlayer
  • m_specularColor : Material
  • m_specularExponent : Material
  • m_spEngineEx : MEPlayer
  • m_sphereTexture : GameRenderer
  • m_spImpl : Wrapper::sealed
  • m_spMediaEngine : MEPlayer
  • m_spotDiffuseEffect : D2DLightingEffectsRenderer
  • m_spotSpecularEffect : D2DLightingEffectsRenderer
  • m_spOutputAttributes : CInvert
  • m_spOutputSampleAllocator : CInvert
  • m_spQuadLayout : CInvertModule
  • m_spRenderer : SDKSample::WASAPIAudio::sealed
  • m_spriteBatch : SimpleSprites
  • m_spriteRuns : BasicSprites::SpriteBatch
  • m_spritesInRun : BasicSprites::SpriteBatch
  • m_SquareContent : NotificationsExtensions::TileContent::TileWideBase
  • m_Src : NotificationsExtensions::NotificationContentImage
  • m_starStampGeometry : PaperRenderer
  • m_Start : Animation< T >
  • m_startGameButton : MarbleMaze
  • m_startHeight : FrameData
  • m_startPeerFinderImmediately : ProximityCPP::sealed
  • m_startPoint : Extruder::ExtrudingSink
  • m_startPosition : AnimateCirclePosition , AnimateLinePosition
  • m_StartTaskFunction : Samples::Devices::Repeater
  • m_startTime : BasicTimer , abstract
  • m_startWidth : FrameData
  • m_state : MoveLookController , CMPEG1Source
  • m_State : Samples::Devices::Fx2::sealed , Samples::Devices::Repeater
  • m_state : CMPEG1Stream
  • m_stateBlock : LoadScreen , UserInterface , SampleOverlay
  • m_StateChangedEvent : SDKSample::WASAPIAudio::sealed
  • m_staticMeshData : SDKMesh
  • m_staticText : FPSCounter
  • m_status : Simple3DGameXaml::sealed
  • m_stepPS : DirectXFractal
  • m_stereoEnabled : abstract
  • m_stereoExaggerationFactor : StereoSimpleD3D
  • m_stopTime : GameTimer
  • m_streams : StreamList , CMPEG1Source
  • m_StreamState : CDecoder
  • m_StrictValidation : NotificationsExtensions::NotificationBase
  • m_string : D2DEffectsOnPrimitives
  • m_strokeMaskDestBounds : GeometryRealization
  • m_strokeMaskSourceBounds : GeometryRealization
  • m_strokeMesh : GeometryRealization
  • m_strokeRT : GeometryRealization
  • m_strokes : InkRenderer
  • m_strokeStyle : GeometryRealization
  • m_strokeWidth : GeometryRealization
  • m_subscribedMessageId : ProximityCPP::sealed
  • m_subsetArray : SDKMesh
  • m_swapChain : abstract , Direct3DTutorialFrameworkView
  • m_swapChainPanel : abstract , PostcardRenderer
  • m_Switches : Samples::Devices::Fx2::sealed
  • m_SwitchState : Samples::Devices::Fx2::sealed
  • m_SwitchStateChangedEvent : Samples::Devices::Fx2::sealed
  • m_swRT : GeometryRealization
  • m_symbolFormat : D2D3DTransformsRenderer
  • m_target : GameObject
  • m_targetBox : PageRendererContext
  • m_targetFrameTime : AutoThrottle
  • m_targetId : GameObject
  • m_targetLightStrength : MarbleMaze
  • m_tcs : MEPlayer
  • m_technique : BasicSprites::SpriteBatch , DirectXFractal
  • m_TemplateName : NotificationsExtensions::NotificationBase
  • m_tempRTV : DirectXFractal
  • m_tempSRV : DirectXFractal
  • m_tempUAV : DirectXFractal
  • m_Text : NotificationsExtensions::NotificationContentText
  • m_text : DWriteVerticalText , TextAnalysis , TextElement , DWriteHitTesting
  • m_textAlign : TextFrame
  • m_textAlignment : TextStyle
  • m_textAtlasBitmap : FPSCounter
  • m_textBrush : DxgiRotation , StreamEffect , FPSCounter , Simple3DTouch , GameInfoOverlay , GameHud , BasicSound , AudioController , SimpleController
  • m_textBrushGrey : GameHud
  • m_textColorBrush : TextElement
  • m_textExtents : TextElement
  • m_TextFields : NotificationsExtensions::NotificationBase
  • m_textFormat : DxgiRotation , DWriteVerticalText , D2DEffectsOnPrimitives , SaveAsImageFile , DWriteCustomTextRenderer , D2DTextAnimation , D2DBasicAnimation , FPSCounter , CompositeModes , PageRendererContext , DWriteHitTesting , TargetTexture , TextStyle , Simple3DTouch , GeometryRealizationSample , PageRenderer , StereoSimpleD3D , DWriteInlineObject , DWriteParagraphText , DWriteHelloWorld
  • m_textFormatBody : GameHud , GameInfoOverlay
  • m_textFormatBodySymbol : GameHud
  • m_textFormatTitle : GameInfoOverlay
  • m_textFormatTitleBody : GameHud
  • m_textFormatTitleHeader : GameHud
  • m_textFormatTitleLicense : GameHud
  • m_textGeometry : ExtrudedTextRenderer
  • m_textLayout : DWriteVerticalText , DWriteCustomTextRenderer , D2DTextAnimation , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , TextElement , SampleOverlay , Text , ExtrudedTextRenderer , DxgiRotation
  • m_textLayout1 : DWriteParagraphText
  • m_textLength : Text , TextAnalysis , DWriteVerticalText
  • m_textMetrics : D2DTextAnimation
  • m_textPosition : Text
  • m_textRange : DWriteParagraphText
  • m_textRenderer : DWriteCustomTextRenderer
  • m_textStyle : TextElement
  • m_textTypography : DWriteInlineObject , DWriteVerticalText , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteParagraphText
  • m_texture : TextInterop , D3DPostProcessing , BumpMapping , Direct3DTutorial , Simple3DTouch , DxgiRotation , OfferReclaimAPI
  • m_textureMap : BasicSprites::SpriteBatch
  • m_textureRV : Material
  • m_textureShaderResourceView : D3DPostProcessing , StereoSimpleD3D , TextInterop
  • m_textureSRV : ResourceLoading , DxgiRotation , BumpMapping , Direct3DTutorial , Simple3DTouch , OfferReclaimAPI
  • m_textVerticalOffset : SampleOverlay
  • m_thumbnailUpdatedEventToken : Hilo::sealed
  • m_tileUpdateScheduler : Hilo::sealed
  • m_timeDelta : GeometryRealizationSample
  • m_timeLimit : abstract
  • m_timer : Simple3DGame
  • m_TimerThreadHandle : MEPlayer
  • m_times : FPSCounter
  • m_title : Simple3DGameXaml::sealed
  • m_titleBody : GameHud
  • m_titleBodyLayout : GameHud
  • m_titleBodyVerticalOffset : GameHud
  • m_titleFormat : sealed
  • m_titleHeader : GameHud
  • m_titleHeaderLayout : GameHud
  • m_titleLicenseInfo : GameHud
  • m_titleLicenseInfoLayout : GameHud
  • m_titleLicenseVerticalOffset : GameHud
  • m_token : FrameProcessing
  • m_ToneSource : SDKSample::WASAPIAudio::WASAPIRenderer
  • m_top : Hilo::sealed
  • m_topLeftX : Shape
  • m_topLeftY : Shape
  • m_topMargin : TextFrame
  • m_topScore : Simple3DGame
  • m_total : BasicTimer
  • m_totalHits : Simple3DGame
  • m_totalLength : AnimateLineListPosition
  • m_totalPages : PrintSample::sealed , CDocumentSource
  • m_totalShots : Simple3DGame
  • m_totalSize : LoadScreen
  • m_totalZoom : D2DInterpolationModes
  • m_touches : MarbleMaze
  • m_transform : CGrayscale , DirectXFractal
  • m_transformedFrameMatrices : SDKMesh
  • m_triggeredConnectSupported : ProximityCPP::sealed
  • m_triggerToken : ProximityCPP::sealed
  • m_type : PageRendererContext
  • m_uBit : DirectX::D3DX_BC6H::ModeDescriptor
  • m_uBits : DirectX::CBits< SizeInBytes >
  • m_uiHeight : CInvertModule
  • m_uiSettings : sealed
  • m_uiWidth : CInvertModule
  • m_underlineArray : DWriteHitTesting
  • m_up : Camera , LonLatController , MoveLookController
  • m_updateDisplayText : GeometryRealizationSample
  • m_updateRealization : GeometryRealizationSample
  • m_updateState : DirectXApp , Simple3DGameXaml::sealed
  • m_updateStateNext : DirectXApp , Simple3DGameXaml::sealed
  • m_useDoubles : DirectXFractal
  • m_useHardwareAcceleration : Hilo::sealed
  • m_useRealizations : GeometryRealizationSample
  • m_useUnormTextures : DirectXFractal
  • m_value : sealed
  • m_velDueToAccel : Physics
  • m_velocity : GameObject , MoveLookController , Physics
  • m_vertexBuffer : BumpMapping , BasicSprites::SpriteBatch , StereoSimpleD3D , D3DPostProcessing , DxgiRotation , Simple3DTouch , Direct3DTutorial , DirectXFractal , WaveEffect , ResourceLoading , TextInterop , abstract , ExtrudedTextRenderer , OfferReclaimAPI
  • m_vertexBufferArray : SDKMesh
  • m_vertexCount : abstract
  • m_vertexData : BasicSprites::SpriteBatch
  • m_vertexLayout : GameRenderer
  • m_vertexShader : ResourceLoading , BasicSprites::SpriteBatch , DirectXFractal , ExtrudedTextRenderer , Simple3DTouch , Material , OfferReclaimAPI , StereoSimpleD3D , GameRenderer , BumpMapping , D3DPostProcessing , Direct3DTutorial , TextInterop , MarbleMaze , DxgiRotation
  • m_vertexShaderFlat : GameRenderer
  • m_vertexStride : MarbleMaze
  • m_vertices : SDKMesh , Extruder::ExtrudingSink
  • m_view : Camera , BasicCamera
  • m_viewMatrix : Camera
  • m_viewModel : Hilo::sealed
  • m_viewPosition : D2DInterpolationModes , D2DTextAnimation , CommandListRenderer
  • m_viewState : MarbleMaze
  • m_visbilityHandler : SDKSample::MediaCapture::sealed
  • m_visibilityEventRegistrationToken : SimpleCommunication::sealed
  • m_visible : DirectXApp , Simple3DGameXaml::sealed , GameInfoOverlay , ElementBase
  • m_voiceContext : Audio
  • m_wallDistances : Physics
  • m_wallsTexture : GameRenderer
  • m_wallTriList : Collision
  • m_WatcherStarted : SDKSample::CustomDeviceAccess::DeviceList
  • m_WatcherSuspended : CustomDeviceAccess::DeviceList , SDKSample::CustomDeviceAccess::DeviceList
  • m_watchToken : Hilo::sealed
  • m_WAVDataWriter : SDKSample::WASAPIAudio::WASAPICapture
  • m_waveFormat : MediaStreamer , MediaReader
  • m_waveOffset : WaveEffect
  • m_weakPhotoCache : Hilo::sealed
  • m_weakPhotoGroup : Hilo::sealed
  • m_whiteBrush : D2DBasicAnimation , TargetTexture , D2DEffectsOnPrimitives , D2DInterpolationModes , D2D3DTransformsRenderer , SampleOverlay , CompositeModes , sealed , BasicSound
  • m_wicBitmapDecoder : DWriteCustomTextRenderer
  • m_wicBitmapFrame : DWriteCustomTextRenderer
  • m_wicColorContext : PageRenderer
  • m_wicConvertedSource : ConvolveMatrixEffect , PageRenderer
  • m_wicConverter : D2DLightingEffectsRenderer
  • m_wicDecoder : D2DEffectsHelloWorld
  • m_wicFactory : abstract , Renderer , UserInterface , GameHud , LoadScreen , SampleOverlay , BasicLoader , ImageRenderer
  • m_wicFormatConverter : DWriteCustomTextRenderer , D2DEffectsHelloWorld , D2D3DTransformsRenderer
  • m_wicFrameDecode : D2DEffectsHelloWorld
  • m_width : Shape , FrameProcessing , CDocumentSource , Face , Program
  • m_widthInInches : StereoSimpleD3D
  • m_widthVector : Face
  • m_window : sealed , Direct3DTutorialFrameworkView , Program , abstract , MEPlayer , VideoView , CAppWindowProvider
  • m_windowActive : MarbleMaze
  • m_windowBounds : Renderer , abstract
  • m_windowClosed : CommandListRenderer , D2DBasicAnimation , GeometryRealizationSample , DirectXApp
  • m_windowSizeChangeInProgress : abstract
  • m_windowState : PostcardRenderer , D2D3DTransformsRenderer , D2DLightingEffectsRenderer
  • m_windowTextBrush : sealed
  • m_windowVisible : DirectXApp , CommandListRenderer , GeometryRealizationSample , D2DBasicAnimation
  • m_worldPoseFrameMatrices : SDKMesh
  • m_worldScale : StereoSimpleD3D
  • m_xinputCaps : SimpleController , AudioController , MoveLookController
  • m_xinputStartButtonInUse : MoveLookController
  • m_xinputState : AudioController , MoveLookController , SimpleController
  • m_xinputTriggerInUse : MoveLookController
  • m_yaw : MoveLookController
  • m_year : Hilo::sealed
  • m_yearDate : Hilo::sealed
  • m_yearGroups : Hilo::sealed
  • m_yellowBrush : TargetTexture , sealed
  • m_yellowProvider : sealed
  • m_zoom : ExtrudedTextRenderer , D2DTextAnimation , CommandListRenderer
  • MainHubView() : Hilo::sealed
  • MainPage()
: SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, LanguageFontCPP::sealed
, SDKSample::sealed
, SimpleBlogReader::sealed
, SDKSample::sealed
, Clipboard::sealed
, ContactPicker::sealed
, SDKSample::sealed
, EdgeGestureSample::sealed
, SDKSample::sealed
, Magazine::sealed
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, Simple3DGameXaml::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, D2DLightingEffects::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, ToastsSampleCPP::sealed
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, PrintSample::sealed
, ShareTarget::sealed
, SDKTemplate::MainPage
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::sealed
, RawNotificationsSampleCPP::sealed
, SimpleCommunication::sealed
, SDKTemplateCS::MainPage
, SDKSample::sealed
, DeviceAppForWebcam::sealed
, SDKSample::sealed
, Postcard::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, LockScreenAppsCPP::sealed
, SDKSample::sealed
, AssociationLaunching::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, CredentialPickerCPP::sealed
, SDKSample::sealed
, D2D3DTransforms::sealed
, SDKSample::sealed
, MediaExtensionsCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
  • MainPage_CachedFile() : SDKSample::FilePickerContracts::sealed
  • MainPage_Loaded()
: SDKTemplateCS::MainPage
, SecondaryTiles::sealed
  • MainPage_PickFile() : SDKSample::FilePickerContracts::sealed
  • MainPage_SaveFile() : SDKSample::FilePickerContracts::sealed
  • MainPage_SizeChanged()
: SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, DeviceAppForWebcam::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SimpleCommunication::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, ProximityCPP::sealed
, SDKSample::sealed
, SDKTemplateCS::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
  • MainPageAndContext() : ToastsSampleCPP::sealed
  • MainPagePicker() : ContactPicker::sealed
  • MainPagePicker_SizeChanged() : ContactPicker::sealed
  • MainPagePickerResized : ContactPicker::sealed
  • MainPageResized
: ContactPicker::sealed
, StreamSocketSample::sealed
, SimpleCommunication::sealed
, SDKTemplate::MainPage
, ProximityCPP::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, AccountPictureName::sealed
, DatagramSocketSample::sealed
, Clipboard::sealed
, AppBarControl::sealed
  • MakeDocument() : CDocumentSource
  • MakePage() : CDocumentSource
  • MakeUnorm() : BasicSprites::SpriteBatch
  • ManipulatableObjectTransform() : sealed
  • ManipulationTransform() : ManipulatableObject
  • Map() : TextureLock
  • map : TextureLock
  • MapChanged : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • MapColors()
: DirectX::D3DX_BC7
, DirectX::D3DX_BC6H
  • MapColorsQuantized() : DirectX::D3DX_BC6H
  • MapInputRectsToOutputRect() : WaveEffect , RippleEffect
  • MapInvalidRect() : WaveEffect , RippleEffect
  • MapOutputRectToInputRects() : WaveEffect , RippleEffect
  • marblePosition : ConstantBuffer
  • marbleRadius : ConstantBuffer
  • Margin : PrintSample::PageDescription
  • MarkIn() : SDKSample::Transcode::sealed
  • MarkOut() : SDKSample::Transcode::sealed
  • MarshalLog() : SDKSample::BackgroundTransfer::sealed
  • MarshalText() : SDKSample::WebSocket::sealed
  • Matched : CustomDeviceAccess::DeviceListEntry
  • MaterialDataOffset : SDKMESH_HEADER
  • MaterialID : SDKMESH_SUBSET
  • MaterialInstancePath : SDKMESH_MATERIAL
  • Matrix : SDKMESH_FRAME
  • matrix : WaveEffect
  • Matrix4x4() : Matrix4x4< T >
  • maxCollisionSpeed : CollisionInfo
  • MaxCount : sealed
  • maxRollingSpeed : CollisionInfo
  • Measure() : Rectangle , PageRoll , ImageFrame , Element , TextFrame , ContentImageSource , Resource , List< T >
  • MeasureOverride() : Hilo::Common::sealed
  • mediabuttons() : SDKSample::MediaButtons::sealed
  • mediaCapture : SimpleCommunication::Common::CaptureDevice
  • mediaCapture_Failed() : SimpleCommunication::Common::CaptureDevice
  • mediaCaptureMgr : SDKSample::CameraOptions::sealed
  • MediaContainerAP() : SDKSample::Accessibility::sealed
  • MediaControl_PausePressed()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • MediaControl_PlayPauseTogglePressed()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • MediaControl_PlayPressed()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • MediaControl_SoundLevelChanged()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
, SDKSample::CameraOptions::sealed
  • MediaControl_StopPressed()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • mediaElement : SDKSample::Accessibility::sealed
  • MediaElement_CurrentStateChanged() : SDKSample::MediaButtons::sealed
  • MediaElement_MediaEnded() : SDKSample::MediaButtons::sealed
  • MediaElement_MediaOpened() : SDKSample::MediaButtons::sealed
  • MediaElementContainer() : SDKSample::Accessibility::sealed
  • MediaEngineNotify() : MediaEngineNotify
  • MediaEngineNotifyCallback() : MediaEngineNotify
  • mediaExtensionMgr : SDKTemplate::MainPage
  • mediaFile : SDKSample::MediaServerClient::sealed
  • mediaFiles : SDKSample::MediaServerClient::sealed
  • mediaSelect_SelectionChanged() : SDKSample::MediaServerClient::sealed
  • mediaServers : SDKSample::MediaServerClient::sealed
  • mediaSink : SimpleCommunication::Common::CaptureDevice
  • mediaSink_IncomingConnectionEvent() : SimpleCommunication::Common::CaptureDevice
  • mediaStream : SDKSample::MediaServerClient::sealed
  • MediaStreamer() : MediaStreamer
  • MediaType : SDKSample::PlayToreceiver::sealed
  • MediaType_SelectionChanged() : SDKSample::ProvisioningAgent::sealed
  • MenuItemSelected() : D2DInterpolationModes
  • MergeSharedEdgeCoplanarContacts() : Collision
  • Mesh() : GameObject , SDKMESH_FRAME
  • meshColor : ConstantBufferChangesEveryPrim
  • MeshDataOffset : SDKMESH_HEADER
  • meshID : Contact
  • message : SimpleCommunication::CaptureFailedEventArgs
  • messageData : SDKSample::PersonalityAnimations::sealed
  • MessageData() : SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • MessageReceived()
: ProximityCPP::sealed
, SDKSample::WebSocket::sealed
  • messageWebSocket : SDKSample::WebSocket::sealed
  • messageWriter : SDKSample::WebSocket::sealed
  • Method : _SDKMESHVERTEXELEMENT
  • METHODASYNCCALLBACK()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
, SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
, SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
, SDKSample::WASAPIAudio::WASAPICapture
  • MFSampleGenerator() : SDKSample::WASAPIAudio::MFSampleGenerator
  • MFVideoFormat_MPG1 : MediaExtensionsCS::ScenarioInput1
  • MillisecondsToTimeSpan() : SDKSample::ThreadPool::ThreadPoolSample
  • MinReadChunkSize : ReadStreamTask
  • mipLevels : DirectX::TexMetadata
  • mipMapCount : DDS_HEADER
  • miscFlag : DirectX::DDS_HEADER_DXT10 , DDS_HEADER_DXT10
  • miscFlags : DirectX::TexMetadata
  • mlt : Samples::Devices::Repeater
  • MobilePhone : ContactPicker::sealed::SampleContact
  • mode : SimpleCommunication::LowLatency , MPEG1AudioFrameHeader
  • modeExtension : MPEG1AudioFrameHeader
  • model : ConstantBuffer
  • ModelMatrix() : GameObject
  • month : Hilo::sealed
  • MonthPhoto : Hilo::PhotoCache
  • Mouse() : SDKSample::DeviceCaps::sealed
  • MouseGetSettings_Click() : SDKSample::DeviceCaps::sealed
  • Move() : SDKSample::TouchKeyboard::sealed
  • MoveButtonClicked() : Postcard::sealed
  • MoveEnd() : Buffer
  • MoveEndpointByRange() : SDKSample::TouchKeyboard::sealed
  • MoveEndpointByUnit() : SDKSample::TouchKeyboard::sealed
  • MoveNext() : SDKSample::sealed , FontLoader , AntSystem::Ant
  • MovePaper() : PaperRenderer , PostcardRenderer
  • MovePaperClicked : Postcard::sealed
  • MovePrevious() : SDKSample::sealed
  • MoveRepulsor() : SimpleSprites
  • MoveStart() : Buffer
  • MoveToFront() : Program
  • mruToken : SDKSample::MainPage
  • ms_aDesc : DirectX::D3DX_BC6H
  • ms_aInfo : DirectX::D3DX_BC7 , DirectX::D3DX_BC6H
  • ms_aModeToInfo : DirectX::D3DX_BC6H
  • Msappdata() : SDKSample::ApplicationDataSample::sealed
  • Mszip_Click() : SDKSample::Compression::sealed
  • Music : SDKSample::FileExtensions
  • MusicEngine() : Audio
  • Mute() : MEPlayer
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- n -

  • NA : DirectX::D3DX_BC6H
  • name : SDKSample::DeviceEnumeration::sealed
  • Name : SDKMESH_MESH , SDKMESH_SUBSET , ContactPicker::sealed::SampleContact , SDKMESH_FRAME , SDKMESH_MATERIAL
  • Names : AntSystem::Node
  • Nav_Click() : SDKSample::WebViewControl::sealed
  • Navigate() : CAppWindowProvider
  • NavigateBack : Hilo::ViewModelBase
  • NavigateButton_Click() : SDKSample::WebViewControl::sealed
  • NavigateDPHelp() : SDKSample::UserAndCustomControls::sealed
  • NavigateHome : Hilo::ViewModelBase , Hilo::HiloPage
  • NavigateToGroup() : Hilo::sealed
  • NavigateToLaunchedFromSecondaryTile() : SecondaryTiles::sealed
  • NavigateToLink() : SDKSample::UserAndCustomControls::sealed
  • NavigateToPage : Hilo::ViewModelBase , Hilo::HiloPage
  • NavigateToPictures() : Hilo::sealed
  • NavigatingPrevented() : SimpleCommunication::sealed
  • NavToString_Click() : SDKSample::WebViewControl::sealed
  • nBlockAlign : MPEG1AudioFrameHeader
  • nChannels : MPEG1AudioFrameHeader
  • NearClipPlane() : Camera
  • NeedsData() : CMPEG1Stream
  • NeedsResourceUpdate() : D2DLightingEffectsRenderer
  • needToPrintClipboardFormat : Clipboard::sealed
  • NetworkCostCategory_SelectionChanged() : SDKSample::ProvisioningAgent::sealed
  • networkCostType : SDKSample::ProvisioningAgent::sealed
  • networkInfo : SDKSample::NetworkInformationApi::sealed
  • networkStatusCallback : SDKSample::NetworkInformationApi::sealed
  • NetworkStatusChange() : SDKSample::NetworkInformationApi::sealed
  • NetworkStatusChange_Click() : SDKSample::NetworkInformationApi::sealed
  • next : ShapeRecord , List< T >::Node
  • Next : RenderBuffer , List< T >
  • NextByte() : CStreamState
  • nextItem_Click() : SDKSample::PlayTo::sealed
  • NextItem_Click()
: SDKSample::AtomPub::sealed
, SDKSample::Syndication::sealed
  • nextRunIndex : TextAnalysis::LinkedRun
  • nextTimestamp : MediaStreamSource::PcmSource
  • NextTrack() : SDKSample::MediaButtons::sealed
  • NextValue() : TriColorValueHelper
  • NoAlbumArt : SDKSample::Errors
  • Node()
: AntSystem::Node
, List< T >::Node
  • nodeNamespace : SDKSample::sealed
  • Nodes : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • nodeValue : SDKSample::sealed
  • NoExifThumbnail : SDKSample::Errors
  • NoIcon : SDKSample::Errors
  • NoImages : SDKSample::Errors
  • NonBufferDataSize : SDKMESH_HEADER
  • None : SDKSample::PlayToreceiver::sealed , SDKSample::Rotation::sealed
  • nonParentPopup : SDKSample::XAMLPopup::sealed
  • NonTouchableTextBlock() : SDKSample::TouchKeyboard::sealed
  • NonTouchableTextBlockAutomationPeer() : SDKSample::TouchKeyboard::sealed
  • norm : BasicVertex , IndexTriplet , Extruder::ExtrudingSink::Vertex2D
  • Norm : SimpleVertex
  • normal : PNTVertex
  • Normal() : Triangle
  • Normalize() : Extruder::ExtrudingSink
  • NormalMaterial() : GameObject
  • NormalRV : SDKMESH_MATERIAL
  • NormalTexture : SDKMESH_MATERIAL
  • NormalTextureName : SDKMESH_MATERIAL
  • NoThumbnail : SDKSample::Errors
  • NotificationBase() : NotificationsExtensions::NotificationBase
  • NotificationContentImage() : NotificationsExtensions::NotificationContentImage
  • NotificationContentText() : NotificationsExtensions::NotificationContentText
  • NotificationContentValidationException() : NotificationsExtensions::NotificationContentValidationException
  • NotificationData() : ScheduledNotificationsSampleCPP::sealed
  • NotificationDataSource() : ScheduledNotificationsSampleCPP::sealed
  • NotificationExpiration() : SDKSample::Tiles::sealed
  • notifier : SDKSample::MainPage
  • NotifyAllObservers()
: Hilo::FileSystemRepository
, Hilo::Repository
  • NotifyType : SDKSample::Helpers
  • NotifyUser()
: SDKSample::sealed
, CredentialPickerCPP::sealed
, Clipboard::sealed
, AssociationLaunching::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, SecondaryTiles::sealed
, StreamSocketSample::sealed
, ToastsSampleCPP::sealed
, SDKTemplateCS::MainPage
, SimpleCommunication::sealed
, ShareTarget::sealed
, SDKSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, LockScreenAppsCPP::sealed
, ProximityCPP::sealed
, SDKTemplate::MainPage
, SDKSample::FilePickerContracts::sealed
, SDKTemplate::MainPage
, DatagramSocketSample::sealed
, SDKTemplate::MainPage
, SDKSample::FilePickerContracts::sealed
, AppBarControl::sealed
, AccountPictureName::sealed
, ContactPicker::sealed
, EdgeGestureSample::sealed
, SDKSample::FilePickerContracts::sealed
, LanguageFontCPP::sealed
  • NotifyUserBackgroundThread()
: ShareTarget::sealed
, Clipboard::sealed
  • NotifyUserFileNotExist() : SDKSample::MainPage
  • NotifyUserFromAsyncThread()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
, CredentialPickerCPP::sealed
, DatagramSocketSample::sealed
  • NumAnimationKeys : SDKANIMATION_FILE_HEADER
  • number : MPEG1StreamHeader
  • Number : NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
  • number : MPEG1PacketHeader
  • NumberOfPhotos : PrintSample::sealed
  • NumberOrGlyph_SelectionChanged() : SDKSample::Tiles::sealed
  • NumberParsing() : SDKSample::NumberFormatting::sealed
  • NumFrameInfluences : SDKMESH_MESH
  • NumFrames : SDKMESH_HEADER , SDKANIMATION_FILE_HEADER
  • NumIndexBuffers : SDKMESH_HEADER
  • NumIndices : SDKMESH_INDEX_BUFFER_HEADER
  • NumMaterials : SDKMESH_HEADER
  • NumMeshes : SDKMESH_HEADER
  • numPoints : Polygon
  • numSprites : BasicSprites::SpriteRunInfo
  • NumSubsets : SDKMESH_MESH
  • NumTotalSubsets : SDKMESH_HEADER
  • NumVertexBuffers : SDKMESH_HEADER , SDKMESH_MESH
  • NumVertices : SDKMESH_VERTEX_BUFFER_HEADER
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- o -

  • Objective() : abstract
  • ObservableDictionaryChangedEventArgs() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
  • ObserveException() : Hilo::ObserveException< T >
  • ObserveFileChange() : Hilo::sealed
  • offset : BasicSprites::InstanceData
  • Offset : _SDKMESHVERTEXELEMENT
  • OnActivated() : CommandListRenderer , Direct3DTutorialFrameworkView , CompositeModes , Direct3DTutorialFrameworkView , ConvolveMatrixEffect , DirectXApp , D2DEffectsOnPrimitives , DWriteCustomTextRenderer , DWriteHelloWorld , AccountPictureName::App , GeometryRealizationSample , DWriteHitTesting , DWriteInlineObject , D2DInterpolationModes , DWriteParagraphText , DWriteVerticalText , ContactPicker::App , D2DPerspectiveTransform , DirectXApp , CoreWindowEvents , DirectXApp , DeviceAppForPrinters::App , SaveAsImageFile , DirectXApp , sealed , D2DTextAnimation , DirectXApp , SDKSample::App , sealed , DirectXApp , SDKTemplate::App , DeviceAppForWebcam::sealed , D2DBasicAnimation , DirectXApp , D2DEffectsHelloWorld , DirectXApp
  • OnAppBarOpened() : Simple3DGameXaml::sealed
  • OnApplyTemplate() : SDKSample::HighContrast::sealed
  • OnAudioSampleRequested()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • OnAutomationProviderRequested() : sealed
  • OnAzimuthValueChanged() : D2DLightingEffects::sealed
  • OnBrtAutoToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnBrtSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnBuyAppButtonTapped() : Simple3DGameXaml::sealed
  • OnBuySelectorClicked() : Simple3DGameXaml::sealed
  • OnByteStreamRead() : CMPEG1Source
  • OnCachedFileUpdaterActivated() : SDKSample::App
  • OnCanceled()
: Tasks::sealed
, EdgeGestureSample::sealed
, BackgroundTask::sealed
, NetworkStatusTask::sealed
  • OnCaptureFailed() : SimpleCommunication::sealed
  • OnChangeBackgroundButtonClicked() : Simple3DGameXaml::sealed
  • OnChangeDrawingAttributes() : sealed
  • OnChangeRecognizer() : sealed
  • OnCharacterReceived() : CoreWindowEvents , sealed
  • OnCheckInputType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • OnCheckMediaType() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CPolarEffect
  • OnCheckOutputType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • OnClipboardChanged() : Clipboard::sealed
  • onCommandsRequested() : SDKSample::ApplicationSettings::sealed
  • OnCompleted()
: EdgeGestureSample::sealed
, SDKSample::GeolocationCPP::sealed
  • OnConnection() : StreamSocketSample::sealed
  • OnContactRemoved() : ContactPicker::sealed
  • OnContentCreated()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • OnContextMenu() : EdgeGestureSample::sealed
  • OnCopyTextToClipboard() : sealed
  • OnCopyToClipboard() : sealed
  • OnCreateAutomationPeer()
: SDKSample::TouchKeyboard::sealed
, SDKSample::Accessibility::sealed
  • OnCriticalError() : AudioEngineCallbacks
  • OnCropRectangleTapped() : Hilo::sealed
  • OnCrtAutoToggleChanged()
: DeviceAppForWebcam::sealed
, SDKTemplate::DeviceAppPage
  • OnCrtSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnDataAvailable() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • OnDataChanged() : Hilo::sealed
  • OnDataRequested() : PostcardRenderer , SDKSample::Common::SharePage
  • OnDeferredImageRequestedHandler()
: Clipboard::sealed
, SDKSample::ShareSource::sealed
  • OnDelete() : sealed
  • OnDeviceEventReceived() : SDKSample::PortableDeviceCPP::sealed
  • OnDeviceLost() : Magazine::sealed , DirectXApp , Simple3DGameXaml::sealed
  • OnDeviceReset() : DirectXApp , Simple3DGameXaml::sealed
  • OnDeviceStateChange() : SDKSample::WASAPIAudio::sealed
  • OnDiffuseConstantValueChanged() : D2DLightingEffects::sealed
  • OnDiscontinuity() : CDecoder
  • OnDispatchSamples() : CMPEG1Stream
  • OnDisplayContentsInvalidated() : D2D3DTransforms::sealed , D2DTextAnimation , D2DEffectsHelloWorld , CompositeModes , ConvolveMatrixEffect , D2DEffectsOnPrimitives , D2DInterpolationModes , D2DPerspectiveTransform , SaveAsImageFile , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , DWriteVerticalText , DirectXApp , CoreWindowEvents , sealed , D2DLightingEffects::sealed , Simple3DGameXaml::sealed
  • OnEffectEnabledToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnEffectSelectorSelectionChanged()
: D2D3DTransforms::sealed
, D2DLightingEffects::sealed
  • OnEffectSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnElevationValueChanged() : D2DLightingEffects::sealed
  • OnEndOfStream() : CMPEG1Source , Parser , CMPEG1Source , Parser
  • OnError() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • OnEvent() : SDKSample::PortableDeviceCPP::EventCallback
  • OnExpAutoToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnExpSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnFileActivated() : SDKSample::App
  • OnFileOpenPickerActivated() : SDKSample::App
  • OnFileQueryContentsChanged() : Hilo::sealed
  • OnFileRemoved() : SDKSample::FilePickerContracts::sealed
  • OnFileSavePickerActivated() : SDKSample::App
  • OnFileUpdateRequested() : SDKSample::FilePickerContracts::sealed
  • OnFilmStripLoaded() : Hilo::sealed
  • OnFinishCapture() : SDKSample::WASAPIAudio::WASAPICapture
  • OnFlush() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CDecoder , CPolarEffect
  • OnFocusAutoToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnFocusChange() : MarbleMaze
  • OnFocusSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnFx2Added()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • OnFx2EnumerationComplete()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • OnFx2Removed()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • OnGameInfoOverlayTapped() : Simple3DGameXaml::sealed
  • OnGetPartialType() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CPolarEffect
  • OnGlobalOffsetXValueChanged() : D2D3DTransforms::sealed
  • OnGlobalOffsetYValueChanged() : D2D3DTransforms::sealed
  • OnGlobalOffsetZValueChanged() : D2D3DTransforms::sealed
  • OnGotFocus() : SDKSample::TouchKeyboard::sealed
  • OnGround() : GameObject
  • OnHeadersAvailable() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • OnHighContrastChanged() : sealed
  • OnHiloDataContextPropertyChanged() : Hilo::HiloPage
  • OnHolding() : ConvolveMatrixEffect , GeometryRealizationSample , DWriteParagraphText , sealed
  • OnImageFailedToOpen() : Hilo::sealed
  • OnImagePointerMoved() : Hilo::sealed
  • OnImagePointerPressed() : Hilo::sealed
  • OnImagePointerReleased() : Hilo::sealed
  • OnIncomingConnection() : SimpleCommunication::sealed
  • OnInitializeCompleted() : SimpleCommunication::sealed
  • OnInitializeCompletedDispatchedHandler() : SimpleCommunication::sealed
  • OnKeyDown() : LonLatController , DirectXApp , LonLatController , DirectXApp , MoveLookController , DirectXApp , CoreWindowEvents , MoveLookController , SDKSample::TouchKeyboard::sealed , sealed , MoveLookController
  • OnKeyPressed() : VideoView
  • OnKeyUp() : LonLatController , DirectXApp , LonLatController , MoveLookController , DirectXApp , CoreWindowEvents , MoveLookController
  • OnLaunched()
: SDKSample::App
, AccountPictureName::App
, SDKSample::App
, AssociationLaunching::sealed
, SDKSample::App
, Clipboard::App
, SDKSample::App
, ContactPicker::App
, SDKSample::App
, CredentialPickerCPP::sealed
, SDKSample::App
, SDKTemplate::App
, SDKSample::App
, DatagramSocketSample::sealed
, SDKSample::App
, DeviceAppForPrinters::App
, SDKSample::App
, D2D3DTransforms::sealed
, Magazine::sealed
, Postcard::sealed
, SDKSample::App
, EdgeGestureSample::sealed
, SDKSample::App
, SimpleBlogReader::sealed
, SDKSample::App
, Hilo::sealed
, SDKSample::App
, LanguageFontCPP::sealed
, SDKSample::App
, LockScreenAppsCPP::sealed
, SDKSample::App
, SDKTemplate::App
, SDKSample::App
, MediaExtensionsCS::App
, MediaExtensionsCPP::App
, SDKSample::App
, SDKTemplate::App
, SDKSample::App
, PrintSample::sealed
, SDKSample::App
, ProximityCPP::sealed
, SDKSample::App
, RawNotificationsSampleCPP::sealed
, SDKSample::App
, SDKTemplate::App
, SimpleCommunication::App
, SDKSample::App
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::App
, SecondaryTiles::sealed
, SDKSample::App
, ShareTarget::sealed
, SDKSample::App
, StreamSocketSample::App
, SDKSample::App
, ToastsSampleCPP::sealed
, SDKSample::App
, SDKTemplate::App
, DeviceAppForWebcam::sealed
, SDKSample::App
, AppBarControl::App
, SDKSample::App
, D2DLightingEffects::sealed
, Simple3DGameXaml::sealed
, SDKSample::App
  • OnLicenseChanged() : Simple3DGameXaml::sealed
  • OnLightPositionZValueChanged() : D2DLightingEffects::sealed
  • OnLimitingConeAngleValueChanged() : D2DLightingEffects::sealed
  • OnLoad() : sealed
  • OnLoaded()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • OnLoadStoreClicked() : Simple3DGameXaml::sealed
  • OnLocalOffsetXValueChanged() : D2D3DTransforms::sealed
  • OnLocalOffsetYValueChanged() : D2D3DTransforms::sealed
  • OnLocalOffsetZValueChanged() : D2D3DTransforms::sealed
  • OnLogicalDpiChanged() : D2D3DTransforms::sealed , D2DTextAnimation , D2DBasicAnimation , D2DEffectsHelloWorld , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , D2DEffectsOnPrimitives , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , DirectXApp , SaveAsImageFile , DirectXApp , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , DWriteVerticalText , DirectXApp , Postcard::sealed , CoreWindowEvents , DirectXApp , sealed , D2DLightingEffects::sealed , Simple3DGameXaml::sealed , DirectXApp
  • OnLostFocus() : SDKSample::TouchKeyboard::sealed
  • OnManipulationCompleted() : D2DTextAnimation , PaperRenderer , PostcardRenderer , Hilo::sealed , sealed
  • OnManipulationDelta() : ExtrudedTextRenderer , PaperRenderer , PostcardRenderer , Hilo::sealed
  • OnManipulationInertiaStarting() : sealed
  • OnManipulationStarted() : PaperRenderer , PostcardRenderer , sealed
  • OnManipulationUpdated() : D2DTextAnimation , CommandListRenderer , CompositeModes , D2DInterpolationModes , D2DPerspectiveTransform , DirectXApp , sealed
  • OnMediaCaptureFailed() : SimpleCommunication::sealed
  • OnMediaEngineEvent() : MEPlayer
  • OnMessage() : DatagramSocketSample::sealed
  • OnMouseMoved() : MoveLookController
  • OnNavigatedFrom()
: SDKSample::Common::LayoutAwarePage
, SDKSample::AccelerometerCPP::sealed
, AccountPictureName::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ApplicationSettings::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ApplicationResources::sealed
, AssociationLaunching::sealed
, SDKSample::Common::LayoutAwarePage
, Clipboard::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CompassCPP::sealed
, SDKSample::Common::LayoutAwarePage
, ContactPicker::sealed
, SDKSample::Common::LayoutAwarePage
, CredentialPickerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CustomDeviceAccess::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DisplayOrientation::sealed
, SDKSample::Common::LayoutAwarePage
, EdgeGestureSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GeolocationCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GyrometerCPP::sealed
, Hilo::Common::LayoutAwarePage
, Hilo::HiloPage
, Hilo::sealed
, Hilo::ViewModelBase
, SDKSample::Common::LayoutAwarePage
, SDKSample::InclinometerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, LanguageFontCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::LightSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
, SDKSample::Common::LayoutAwarePage
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCS::ScenarioOutput1
, MediaExtensionsCS::ScenarioOutput2
, MediaExtensionsCS::ScenarioOutput3
, MediaExtensionsCS::ScenarioOutput4
, MediaExtensionsCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PlayTo::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::NetworkInformationApi::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PortableDeviceCPP::sealed
, PrintSample::BasePrintPage
, PrintSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SDKTemplate::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SearchContract::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Common::SharePage
, SDKSample::Common::LayoutAwarePage
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ThreadPool::sealed
, ToastsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WASAPIAudio::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WebViewControl::sealed
  • OnNavigatedTo()
: Hilo::HiloPage
, Hilo::sealed
, Hilo::ViewModelBase
, SDKSample::Common::LayoutAwarePage
, SDKSample::HomeGroup::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::HttpClientSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::InclinometerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DeviceCaps::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::TouchKeyboard::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::TouchKeyboardTextInput::sealed
, LanguageFontCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::LightSensorCPP::sealed
, LockScreenAppsCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Personalization::sealed
, MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKTemplate::MainPage
, SDKSample::MediaCapture::sealed
, SDKSample::Common::LayoutAwarePage
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCS::ScenarioList
, MediaExtensionsCS::ScenarioOutput1
, MediaExtensionsCS::ScenarioOutput2
, MediaExtensionsCS::ScenarioOutput3
, MediaExtensionsCS::ScenarioOutput4
, MediaExtensionsCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PlayTo::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::MediaServerClient::sealed
, MediaStreamSource::AudioSource
, SDKTemplate::MainPage
, SDKSample::MessageDialogSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::MessageDialogSample::sealed
, SDKSample::ProvisioningAgent::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::NetworkInformationApi::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::NumberFormatting::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PlaybackManager2::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PlaybackManager::sealed
, SDKSample::Playlists::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Playlists::sealed
, SDKSample::PlayToreceiver::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PortableDeviceCPP::sealed
, PrintSample::BasePrintPage
, PrintSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WebViewControl::sealed
, ProximityCPP::sealed
, SDKSample::Drawing::sealed
, ProximityCPP::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SDKTemplate::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DataReaderWriter::sealed
, SDKSample::TextEditing::sealed
, SimpleCommunication::LowLatency
, SDKTemplate::MainPage
, SimpleCommunication::VideoChat
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::RemovableStorageCPP::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Scaling::sealed
, SDKSample::Common::LayoutAwarePage
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SearchContract::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SearchContract::sealed
, SecondaryTiles::sealed
, SDKSample::HighContrast::sealed
, SecondaryTiles::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Common::SharePage
, ShareTarget::sealed
, SDKSample::Common::LayoutAwarePage
, AppBarControl::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, AppBarControl::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SplashScreen::sealed
, SDKSample::Animation::sealed
, StreamSocketSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Syndication::sealed
, SDKTemplate::MainPage
, SDKSample::Common::LayoutAwarePage
, SDKSample::ThreadPool::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ThreadPool::sealed
, ToastsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, ToastsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, ToastsSampleCPP::sealed
, SDKSample::StoreSample::sealed
, ToastsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Transcode::sealed
, SDKSample::StoreSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::StoreSample::sealed
, SDKSample::HighContrast::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::UserDomainName::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::UssdApi::sealed
, SDKSample::WebAuthentication::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WASAPIAudio::sealed
, DeviceAppForWebcam::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Accessibility::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Animation::sealed
, AppBarControl::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FlipViewCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::HighContrast::sealed
, SDKSample::Images::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PersonalityAnimations::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::Transforms::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WebViewControl::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::AccelerometerCPP::sealed
, AccountPictureName::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::AnimationMetrics::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PackageSample::sealed
, SDKSample::ApplicationSettings::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ApplicationSettings::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Tiles::sealed
, SDKSample::ApplicationDataSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ApplicationDataSample::sealed
, SDKSample::ApplicationResources::sealed
, AssociationLaunching::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::AtomPub::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::BackgroundTask::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::BackgroundTransfer::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CallControl::sealed
, SDKSample::CalendarSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CalendarSample::sealed
, SDKSample::CameraCapture::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CameraOptions::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CertificateEnrollment::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::IsRemoteSession::sealed
, Clipboard::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CompassCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Compression::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::MediaButtons::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WebSocket::sealed
, ContactPicker::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PasswordVaultCPP::sealed
, CredentialPickerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CryptoWinRT::sealed
, Hilo::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::CryptoWinRT::sealed
, SDKTemplate::MainPage
, CustomDeviceAccess::DeviceAsync
, SDKSample::Common::LayoutAwarePage
, SDKSample::CustomDeviceAccess::sealed
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::sealed
, SDKSample::FilePickerContracts::sealed
, DatagramSocketSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DateTimeFormatting::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Rotation::sealed
, SDKSample::ELS::sealed
, SDKSample::Rotation::sealed
, EdgeGestureSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DeviceEnumeration::sealed
, EdgeGestureSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DisplayOrientation::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::EAS::sealed
, EdgeGestureSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ELS::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FileThumbnails::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GeolocationCPP::sealed
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GyrometerCPP::sealed
, Hilo::sealed
, Hilo::Common::LayoutAwarePage
  • OnNavigatingFrom()
: AppBarControl::sealed
, SDKSample::StoreSample::sealed
, SecondaryTiles::sealed
, SimpleCommunication::VideoChat
, ProximityCPP::sealed
, SDKSample::AtomPub::sealed
, SDKSample::ApplicationDataSample::sealed
, SDKSample::AtomPub::sealed
, ProximityCPP::sealed
, SimpleCommunication::LowLatency
, SimpleCommunication::sealed
, SecondaryTiles::sealed
, SDKSample::StoreSample::sealed
  • OnNetworkStatusChange() : SDKSample::NetworkInformationApi::sealed
  • OnOrientationChanged() : SDKSample::DisplayOrientation::sealed , DirectXApp
  • OnPasteFromClipboard() : sealed
  • OnPausePlayback() : SDKSample::WASAPIAudio::WASAPIRenderer
  • OnPerspectiveValueChanged() : D2D3DTransforms::sealed
  • OnPhotoItemClicked() : Hilo::sealed
  • OnPickFileAsync() : SDKSample::WASAPIAudio::sealed
  • OnPictureGroupPropertyChanged() : Hilo::sealed
  • OnPlayButtonClicked() : Simple3DGameXaml::sealed
  • OnPlotDataReady() : SDKSample::WASAPIAudio::sealed
  • OnPointerEvent() : Shape
  • OnPointerExited() : MoveLookController
  • OnPointerMoved() : PostcardRenderer , MoveLookController , DirectXApp , D2DTextAnimation , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , LonLatController , DirectXApp , DWriteParagraphText , DirectXApp , InkRenderer , Postcard::sealed , CoreWindowEvents , MoveLookController , sealed , Program , sealed , D2DLightingEffectsRenderer , MoveLookController
  • OnPointerPressed() : BasicSound , Program , Postcard::sealed , LonLatController , GeometryRealizationSample , D2DTextAnimation , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , D2DInterpolationModes , D2DPerspectiveTransform , SaveAsImageFile , DirectXApp , DWriteHitTesting , DWriteParagraphText , MoveLookController , DirectXApp , InkRenderer , PostcardRenderer , CoreWindowEvents , sealed , VideoView , MoveLookController , DirectXApp
  • OnPointerReleased() : sealed , InkRenderer , DirectXApp , D2DPerspectiveTransform , D2DTextAnimation , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , GeometryRealizationSample , D2DInterpolationModes , LonLatController , DirectXApp , LonLatController , DWriteParagraphText , MoveLookController , DirectXApp , Postcard::sealed , PostcardRenderer , CoreWindowEvents , MoveLookController , sealed , Program , sealed , MoveLookController
  • OnPointerWheelChanged() : D2DInterpolationModes , D2DTextAnimation , CommandListRenderer , LonLatController , DirectXApp
  • OnPopupClosed() : SDKSample::XAMLPopup::sealed
  • OnPositionChanged() : SDKSample::GeolocationCPP::sealed
  • OnProcessingPassEnd() : AudioEngineCallbacks
  • OnProcessingPassStart() : AudioEngineCallbacks
  • OnProcessOutput() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CPolarEffect
  • OnPropertyChanged()
: Hilo::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::DataBinding::sealed
, SDKSample::ListViewSampleDataSource::sealed
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, SDKSample::FlipViewData::sealed
, Hilo::sealed
  • OnPushNotificationReceived()
: SDKSample::SDKTemplate::sealed
, RawNotificationsSampleCPP::sealed
  • OnQuerySubmitted() : SDKSample::App
  • OnRecognize() : sealed
  • OnRedirect() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • OnRendering() : Simple3DGameXaml::sealed
  • OnResetButtonClicked() : Simple3DGameXaml::sealed
  • OnResetLicenseButtonClicked() : Simple3DGameXaml::sealed
  • OnResponseReceived() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback
  • OnRestoreDefaultsClick()
: D2D3DTransforms::sealed
, D2DLightingEffects::sealed
  • OnResultSuggestionChosen() : SDKSample::SearchContract::sealed
  • OnResuming() : sealed , Simple3DGame , D2DPerspectiveTransform , AudioController , BasicSound , DWriteCustomTextRenderer , sealed , DirectXApp , Magazine::sealed , D2DInterpolationModes , DirectXApp , Simple3DGame , DWriteHitTesting , D2DBasicAnimation , CommandListRenderer , CompositeModes , GeometryRealizationSample , DirectXApp , DWriteHelloWorld , DirectXApp , VideoView , DWriteInlineObject , DWriteParagraphText , DirectXApp , MarbleMaze , DirectXApp , ConvolveMatrixEffect , OfferReclaimAPI , D2DLightingEffects::sealed , DirectXApp , StreamEffect , DirectXApp , Simple3DGameXaml::sealed , DirectXApp
  • OnRightTapped() : sealed
  • OnRotationXValueChanged() : D2D3DTransforms::sealed
  • OnRotationYValueChanged() : D2D3DTransforms::sealed
  • OnRotationZValueChanged() : D2D3DTransforms::sealed
  • OnSampleReady()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • OnSave() : sealed
  • OnScaleXValueChanged() : D2D3DTransforms::sealed
  • OnScaleYValueChanged() : D2D3DTransforms::sealed
  • OnSearchActivated() : SDKSample::App
  • OnSearchPaneSuggestionsRequested() : SDKSample::SearchContract::sealed
  • OnSelectAll() : sealed
  • OnSendScopeData() : SDKSample::WASAPIAudio::WASAPICapture
  • OnSetInputType() : CPolarEffect , CDecoder , CGrayscale , CDecoder , CGrayscale , CPolarEffect
  • OnSetOutputType() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CDecoder
  • onSettingsCommand() : SDKSample::ApplicationSettings::sealed
  • OnSetVolume() : SDKSample::WASAPIAudio::sealed
  • OnShareTargetActivated() : ShareTarget::sealed
  • OnSizeChanged() : Hilo::sealed
  • OnSpecularConstantValueChanged() : D2DLightingEffects::sealed
  • OnSpecularExponentValueChanged() : D2DLightingEffects::sealed
  • OnSpotFocusValueChanged() : D2DLightingEffects::sealed
  • OnStartCapture() : SDKSample::WASAPIAudio::WASAPICapture
  • OnStarting() : EdgeGestureSample::sealed
  • OnStartPlayback() : SDKSample::WASAPIAudio::WASAPIRenderer
  • OnStatusChanged() : SDKSample::GeolocationCPP::sealed
  • OnStereoEnabledChanged() : abstract
  • OnStopCapture() : SDKSample::WASAPIAudio::WASAPICapture
  • OnStopPlayback() : SDKSample::WASAPIAudio::WASAPIRenderer
  • OnStoreReturnClicked() : Simple3DGameXaml::sealed
  • OnStreamRequestSample() : CMPEG1Source
  • OnSurfaceScaleValueChanged() : D2DLightingEffects::sealed
  • OnSuspending()
: MediaExtensionsCS::App
, SDKSample::App
, DirectXApp
, SDKSample::App
, Simple3DGameXaml::sealed
, AppBarControl::App
, D2DLightingEffects::sealed
, SDKTemplate::App
, SDKSample::App
, ToastsSampleCPP::sealed
, SDKSample::App
, SimpleCommunication::App
, SDKSample::App
, DirectXApp
, SDKSample::App
, PrintSample::sealed
, SDKSample::App
, D2DTextAnimation
, SDKSample::App
, MediaExtensionsCPP::App
, SDKSample::App
, D2DBasicAnimation
, SDKTemplate::App
, D2DPerspectiveTransform
, VideoView
, LanguageFontCPP::sealed
, DWriteHelloWorld
, sealed
, SDKSample::App
, DWriteCustomTextRenderer
, SDKSample::App
, OfferReclaimAPI
, SimpleBlogReader::sealed
, Hilo::sealed
, SDKSample::App
, EdgeGestureSample::sealed
, SDKSample::App
, DirectXApp
, Simple3DGame
, DWriteHitTesting
, DirectXApp
, SDKSample::App
, D2DInterpolationModes
, CommandListRenderer
, D2D3DTransforms::sealed
, SDKSample::App
, ContactPicker::App
, SDKSample::App
, AccountPictureName::App
, SDKSample::App
, DatagramSocketSample::sealed
, SDKSample::App
, AssociationLaunching::sealed
, SDKSample::App
, Clipboard::App
, SDKSample::App
, CredentialPickerCPP::sealed
, SDKTemplate::App
, DeviceAppForPrinters::App
, SDKSample::App
, D2D3DTransforms::sealed
, CompositeModes
, ConvolveMatrixEffect
, GeometryRealizationSample
, Magazine::sealed
, DirectXApp
, DWriteInlineObject
, DWriteParagraphText
, DirectXApp
, MarbleMaze
, DirectXApp
, SDKSample::App
, LockScreenAppsCPP::sealed
, SDKSample::App
, SDKTemplate::App
, SDKSample::App
, ProximityCPP::sealed
, RawNotificationsSampleCPP::sealed
, SDKTemplate::App
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::App
, SecondaryTiles::sealed
, SDKSample::App
, StreamSocketSample::App
, SDKSample::App
, sealed
, SDKSample::App
, DeviceAppForWebcam::sealed
, SDKSample::App
, Simple3DGame
, SDKSample::App
, D2DLightingEffects::sealed
, DirectXApp
, StreamEffect
, AudioController
, DirectXApp
, SDKSample::App
, DirectXApp
, SDKSample::App
, DirectXApp
, BasicSound
, SDKSample::App
  • OnSwapChainPointerMoved() : D2DLightingEffects::sealed
  • OnSwitchStateChangedEvent() : SDKSample::CustomDeviceAccess::sealed
  • OnTapped() : CommandListRenderer , PostcardRenderer , SDKSample::TouchKeyboard::sealed , D2DTextAnimation , sealed , SDKSample::TouchKeyboard::sealed , PaperRenderer
  • OnTargetFileRequested() : SDKSample::FilePickerContracts::sealed
  • OnTargetFormatChanged() : SDKSample::Transcode::sealed
  • OnThumbDragDelta() : Hilo::sealed
  • OnThumbnailUpdated() : Hilo::sealed
  • OnTimer() : MEPlayer
  • OnTouchHitTesting() : Program
  • OnUIRequested() : SDKSample::FilePickerContracts::sealed
  • OnUnloaded()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • OnViewChange() : MarbleMaze
  • OnViewChangeCompleted() : Hilo::sealed
  • OnVisibilityChanged() : DirectXApp , D2DInterpolationModes , DirectXApp , CommandListRenderer , DirectXApp , D2DBasicAnimation , DirectXApp , GeometryRealizationSample , DirectXApp , Clipboard::sealed , DirectXApp , Simple3DGameXaml::sealed , DirectXApp
  • OnWindowActivated() : CoreWindowEvents , sealed
  • OnWindowActivationChanged() : DirectXApp , Simple3DGameXaml::sealed , DirectXApp
  • OnWindowClosed() : DirectXApp , sealed , DirectXApp , D2DInterpolationModes , CommandListRenderer , GeometryRealizationSample , DirectXApp , D2DBasicAnimation , DirectXApp
  • OnWindowCreated() : SDKSample::App
  • OnWindowSizeChanged() : DirectXApp , Direct3DTutorialFrameworkView , D2DEffectsHelloWorld , D2D3DTransforms::sealed , CommandListRenderer , ConvolveMatrixEffect , D2DBasicAnimation , GeometryRealizationSample , Direct3DTutorialFrameworkView , DirectXApp , Magazine::sealed , DirectXApp , D2DTextAnimation , DirectXApp , D2DLightingEffects::sealed , DWriteHelloWorld , DirectXApp , DWriteCustomTextRenderer , sealed , DWriteVerticalText , DirectXApp , DWriteParagraphText , CoreWindowEvents , DWriteInlineObject , DirectXApp , DWriteHitTesting , VideoView , DirectXApp , D2DPerspectiveTransform , SaveAsImageFile , sealed , D2DEffectsOnPrimitives , Simple3DGameXaml::sealed , Direct3DTutorialFrameworkView , DirectXApp , D2DInterpolationModes , Direct3DTutorialFrameworkView , DirectXApp , CompositeModes , Postcard::sealed , Simple3DGameXaml::sealed , sealed , DirectXApp
  • OnZoomedOutGridPointerEntered() : Hilo::sealed
  • Op() : SourceOp
  • OP_END_OF_STREAM : SourceOp
  • OP_PAUSE : SourceOp
  • OP_REQUEST_DATA : SourceOp
  • OP_SETRATE : SourceOp
  • OP_START : SourceOp
  • OP_STOP : SourceOp
  • Open_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCPP::sealed
  • OpenChannel_Click() : SDKSample::SDKTemplate::sealed
  • OpenChannelAndRegisterTask() : RawNotificationsSampleCPP::sealed
  • OpenFile() : MEPlayer
  • OpenFisheye_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
  • OpenFromListButton_Click() : SDKSample::FileAccess::sealed
  • OpenFx2Device() : SDKSample::CustomDeviceAccess::sealed
  • OpenGrayscale_Click()
: MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
  • OpenInvert_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
  • OpenMediaAsync() : MediaStreamSource::PcmSource
  • OpenPinch_Click()
: MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
  • OpenReadAsync() : Hilo::IPhoto
  • OpenVideoWithPolarEffect()
: MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
  • OpenWarp_Click()
: MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
  • Operation : SourceOp
  • operator!=()
: List< T >::POSITION
, PrintSample::PageDescription
, List< T >::POSITION
  • operator&() : ScopedObject< T >
  • operator&=() : DirectX::INTColor
  • operator()() : NoOp< T > , SDKSample::PropVariantClearStruct , ComAutoRelease , MemDelete , Hilo::PhotoPathComparer , aligned_deleter , MemDelete , SDKSample::CoTaskMemFreeStruct , Hilo::ObserveException< T > , handle_closer , SDKSample::BackgroundTransfer::GuidComparer , NoOp< T > , ComAutoRelease , Hilo::ObserveException< T > , NoOp< T >
  • operator*() : DirectX::HDRColorA , ScopedObject< T >
  • operator*=() : DirectX::HDRColorA
  • operator+() : DirectX::HDRColorA
  • operator++() : TreeIterator< T >
  • operator+=()
: DirectX::HDRColorA
, DirectX::INTColor
  • operator-() : DirectX::INTColor , DirectX::HDRColorA
  • operator-=()
: DirectX::HDRColorA
, DirectX::INTColor
  • operator->() : ScopedObject< T >
  • operator/() : DirectX::HDRColorA
  • operator/=() : DirectX::HDRColorA
  • operator=()
: ScopedObject< T >
, DirectX::Blob
, ComBase< InterfaceChain >
, DirectX::ScratchImage
, DirectX::LDRColorA
, DirectX::HDRColorA
, AntSystem::Ant
, ReadStreamTask
  • operator==()
: TextAnalysis::Run
, PrintSample::PageDescription
, List< T >::POSITION
  • operator[]() : DirectX::LDRColorA , Vector2< T > , Vector3< T > , Vector4< T > , Matrix4x4< T > , Vector3< T > , Vector2< T > , Vector3< T > , Matrix4x4< T > , Vector4< T > , Matrix4x4< T > , Vector2< T > , Vector4< T > , Matrix4x4< T > , Vector3< T > , Vector4< T > , Matrix4x4< T > , Vector2< T > , Vector3< T > , Matrix4x4< T > , Vector3< T > , Matrix4x4< T > , Vector2< T > , Vector4< T > , Vector2< T > , Matrix4x4< T > , Vector4< T > , Vector3< T > , Vector2< T > , Vector3< T > , Vector2< T > , Matrix4x4< T > , Vector3< T > , StreamList , Vector4< T > , Vector3< T > , Vector2< T > , Vector4< T > , Vector2< T > , Matrix4x4< T > , Vector2< T > , Matrix4x4< T > , Vector4< T > , Vector3< T > , Matrix4x4< T > , Vector4< T > , StreamList , DirectX::LDRColorA , Vector3< T > , Vector4< T > , Vector2< T > , DirectX::INTColor , Vector2< T > , Vector3< T > , Vector4< T > , Vector2< T > , Vector4< T > , Matrix4x4< T > , Vector4< T > , Vector3< T > , Matrix4x4< T > , StreamList , Vector2< T > , Vector3< T > , Matrix4x4< T > , Vector2< T > , Vector4< T > , Vector3< T > , Matrix4x4< T > , Vector3< T > , Matrix4x4< T > , Vector3< T > , StreamList , Vector2< T > , Vector3< T > , Matrix4x4< T > , Vector3< T > , Vector2< T > , Vector4< T >
  • OpList : OpQueue< T, TOperation >
  • OpQueue() : OpQueue< T, TOperation >
  • Optimize : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • OptimizeEndPoints()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • OptimizeOne()
: DirectX::D3DX_BC7
, DirectX::D3DX_BC6H
  • OptimizeTripAsync()
: TripOptimizerComponent::Details::TripOptimizerImpl
, TripOptimizerComponent::sealed
  • OptionalTrialUpgrade() : Simple3DGameXaml::sealed
  • Orange : sealed
  • Orientation : SDKANIMATION_DATA
  • Orientation_Click() : SDKSample::FlipViewCPP::sealed
  • OrientationChanged() : SDKSample::SimpleOrientationSensorCPP::sealed
  • orientationChangedEventToken : SDKSample::DisplayOrientation::sealed
  • orientationToken : SDKSample::SimpleOrientationSensorCPP::sealed
  • origin : BasicSprites::InstanceData
  • originalData : ScenarioContext
  • originDtid00 : ComputeCB , ComputeDoubleCB
  • originOffset : FPSCounter::AtlasText
  • Other_Click()
: SDKSample::PasswordVaultCPP::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::HighContrast::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::TextDisplay::sealed
  • Others() : Clipboard::sealed
  • outlineBrush : CustomTextRenderer
  • OutlineRenderer() : OutlineRenderer
  • OutputFileAsync()
: SDKSample::FilePickerContracts::sealed
, SDKSample::FilePicker::sealed
, SDKSample::FilePickerContracts::sealed
  • OutputFileButton_Click() : SDKSample::FilePicker::sealed
  • OutputFrame : SDKTemplateCS::MainPage
  • OutputFrameLoaded
: RawNotificationsSampleCPP::sealed
, PrintSample::sealed
, AssociationLaunching::sealed
, LockScreenAppsCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, CredentialPickerCPP::sealed
, RawNotificationsSampleCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, SDKTemplateCS::MainPage
, ToastsSampleCPP::sealed
  • outputFrameNavigated()
: RawNotificationsSampleCPP::sealed
, PrintSample::sealed
, MediaExtensionsCPP::sealed
, LockScreenAppsCPP::sealed
, AssociationLaunching::sealed
, LanguageFontCPP::sealed
, ToastsSampleCPP::sealed
, EdgeGestureSample::sealed
, CredentialPickerCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
  • OutputPauseButton_Click() : SDKSample::Transcode::sealed
  • OutputPlayButton_Click() : SDKSample::Transcode::sealed
  • OutputSettings() : SDKSample::Scaling::sealed
  • OutputStopButton_Click() : SDKSample::Transcode::sealed
  • OutputStream : sealed
  • outputStream : DatagramSocketSample::sealed
  • outputText : ToastsSampleCPP::sealed , EdgeGestureSample::sealed
  • OutputText() : ToastsSampleCPP::sealed
  • OutputToTextBox() : RawNotificationsSampleCPP::sealed
  • outputVideo
: MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput2
  • outputVideoStabilized : MediaExtensionsCS::ScenarioInput3 , MediaExtensionsCPP::sealed
  • override : Resource , PageRoll , Story
  • overrideFontFamily : SDKSample::Scaling::sealed
  • OverrideSettings() : SDKSample::DateTimeFormatting::sealed
  • OverwriteButton_Click() : SDKSample::FilePickerContracts::sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- z -

  • z : Vector3< T > , Vector4< T >
  • ZipCode : ContactPicker::sealed::SampleContact
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- ~ -

  • ~App()
: AssociationLaunching::sealed
, Magazine::sealed
, Simple3DGameXaml::sealed
, PrintSample::sealed
  • ~Audio() : Audio
  • ~AudioController() : AudioController
  • ~BackgroundObject() : sealed
  • ~BackgroundTask() : NetworkStatusTask::sealed
  • ~BasicSound() : BasicSound
  • ~Blob() : DirectX::Blob
  • ~Buffer() : Buffer
  • ~CartoonizeImageViewModel() : Hilo::sealed
  • ~CAsyncState() : CAsyncState
  • ~CAutoDXDevLockBase() : CAutoDXDevLockBase< DevManager, DevInterface >
  • ~CDecoder() : CDecoder
  • ~CGrayscale() : CGrayscale
  • ~CInvert() : CInvert
  • ~CInvertModule() : CInvertModule
  • ~CMPEG1Source() : CMPEG1Source
  • ~CMPEG1Stream() : CMPEG1Stream
  • ~ComBase() : ComBase< InterfaceChain >
  • ~CompositeModes() : CompositeModes
  • ~ComPtrList() : ComPtrList< T, NULLABLE >
  • ~CoTaskMemFreeArray() : SDKSample::CoTaskMemFreeArray
  • ~CPolarEffect() : CPolarEffect
  • ~CritSec() : CritSec
  • ~CTriColorWindow() : sealed
  • ~D2DFactoryLock() : D2DFactoryLock
  • ~DeviceAppPage() : DeviceAppForWebcam::sealed
  • ~Document() : Document
  • ~DrawingObject() : sealed
  • ~EventCallback() : SDKSample::PortableDeviceCPP::EventCallback
  • ~FeedData() : SimpleBlogReader::sealed
  • ~FeedItem() : SimpleBlogReader::sealed
  • ~Finally() : SDKSample::Finally
  • ~FrameProcessing() : FrameProcessing
  • ~Fx2Device() : Samples::Devices::Fx2::sealed
  • ~GeometryRealization() : GeometryRealization
  • ~GeometryRealizationFactory() : GeometryRealizationFactory
  • ~HttpRequestBuffersCallback() : Web::Details::HttpRequestBuffersCallback
  • ~HttpRequestStringCallback() : HttpRequestStringCallback
  • ~HubPhotoGroup() : Hilo::sealed
  • ~ImageBrowserViewModel() : Hilo::sealed
  • ~ImageSourceDrawHelper() : ContentImageSource::ImageSourceDrawHelper
  • ~ImageView() : Hilo::sealed
  • ~ImageViewModel() : Hilo::sealed
  • ~ImplData() : XAudio2SoundPlayer::ImplData
  • ~InvalidPageException() : PrintSample::InvalidPageException
  • ~LaunchFileInput() : AssociationLaunching::sealed
  • ~LaunchFileOutput() : AssociationLaunching::sealed
  • ~LaunchUriInput() : AssociationLaunching::sealed
  • ~LaunchUriOutput() : AssociationLaunching::sealed
  • ~List() : List< T >
  • ~ListenerContext()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • ~LocationBackgroundTask() : BackgroundTask::sealed
  • ~MainHubViewModel() : Hilo::sealed
  • ~MainPage()
: AccountPictureName::sealed
, AssociationLaunching::sealed
, Clipboard::sealed
, ContactPicker::sealed
, CredentialPickerCPP::sealed
, DatagramSocketSample::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
, ScheduledNotificationsSampleCPP::sealed
, SecondaryTiles::sealed
, ShareTarget::sealed
, StreamSocketSample::sealed
, ToastsSampleCPP::sealed
, DeviceAppForWebcam::sealed
, AppBarControl::sealed
  • ~MainPagePicker() : ContactPicker::sealed
  • ~MediaStreamer() : MediaStreamer
  • ~MEPlayer() : MEPlayer
  • ~MFSampleGenerator() : SDKSample::WASAPIAudio::MFSampleGenerator
  • ~OpQueue() : OpQueue< T, TOperation >
  • ~Parser() : Parser
  • ~Photo() : Hilo::sealed
  • ~Program() : Program
  • ~QueryChange() : Hilo::sealed
  • ~ReceiveFileInput() : AssociationLaunching::sealed
  • ~ReceiveFileOutput() : AssociationLaunching::sealed
  • ~ReceiveUriInput() : AssociationLaunching::sealed
  • ~ReceiveUriOutput() : AssociationLaunching::sealed
  • ~ReencodeState() : sealed
  • ~RenderBuffer() : RenderBuffer
  • ~Repeater() : Samples::Devices::Repeater
  • ~S2Formatter() : SDKSample::DataBinding::sealed
  • ~SampleBackgroundTask() : Tasks::sealed
  • ~Scenario1()
: SDKSample::BackgroundTransfer::sealed
, SDKSample::WebSocket::sealed
  • ~Scenario2()
: SDKSample::WASAPIAudio::sealed
, SDKSample::WebSocket::sealed
, SDKSample::BackgroundTransfer::sealed
  • ~Scenario3() : SDKSample::WASAPIAudio::sealed
  • ~ScenarioInput1()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, ToastsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
  • ~ScenarioInput2()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, LanguageFontCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
  • ~ScenarioInput3()
: MediaExtensionsCPP::sealed
, CredentialPickerCPP::sealed
, LockScreenAppsCPP::sealed
, ToastsSampleCPP::sealed
  • ~ScenarioInput4()
: MediaExtensionsCPP::sealed
, ToastsSampleCPP::sealed
  • ~ScenarioInput5() : ToastsSampleCPP::sealed
  • ~ScenarioInput6() : ToastsSampleCPP::sealed
  • ~ScenarioList()
: EdgeGestureSample::sealed
, PrintSample::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
, AssociationLaunching::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
  • ~ScenarioOutput1()
: ScheduledNotificationsSampleCPP::sealed
, LockScreenAppsCPP::sealed
, EdgeGestureSample::sealed
, PrintSample::sealed
, LanguageFontCPP::sealed
, ToastsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, CredentialPickerCPP::sealed
  • ~ScenarioOutput2()
: CredentialPickerCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, PrintSample::sealed
, LockScreenAppsCPP::sealed
, LanguageFontCPP::sealed
, EdgeGestureSample::sealed
  • ~ScenarioOutput3()
: PrintSample::sealed
, CredentialPickerCPP::sealed
, MediaExtensionsCPP::sealed
, LockScreenAppsCPP::sealed
, ToastsSampleCPP::sealed
  • ~ScenarioOutput4()
: PrintSample::sealed
, MediaExtensionsCPP::sealed
, ToastsSampleCPP::sealed
  • ~ScenarioOutput5() : ToastsSampleCPP::sealed
  • ~ScenarioOutput6()
: ToastsSampleCPP::sealed
, PrintSample::sealed
  • ~ScopedObject() : ScopedObject< T >
  • ~ScratchImage() : DirectX::ScratchImage
  • ~SDKMesh() : SDKMesh
  • ~ServicingComplete() : Tasks::sealed
  • ~SetRateOp() : SetRateOp
  • ~Shape() : Shape
  • ~SocketContext() : DatagramSocketSample::sealed
  • ~SoundCallbackHander() : anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • ~SourceOp() : SourceOp
  • ~StartOp() : StartOp
  • ~StreamEffect() : StreamEffect
  • ~StreamingVoiceContext() : StreamingVoiceContext
  • ~StreamList() : StreamList
  • ~TextureLock() : TextureLock
  • ~ToneSampleGenerator() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • ~TripOptimizer() : TripOptimizerComponent::sealed
  • ~UserInterface() : UserInterface
  • ~VideoBufferLock() : VideoBufferLock
  • ~VideoChat() : SimpleCommunication::sealed
  • ~WASAPICapture() : SDKSample::WASAPIAudio::WASAPICapture
  • ~WASAPIRenderer() : SDKSample::WASAPIAudio::WASAPIRenderer
  • ~WinRTComponent() : Wrapper::sealed
  • ~XAudio2SoundPlayer() : XAudio2SoundPlayer
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- a -

  • a : Vector4< T > , DirectX::LDRColorA
  • A : DirectX::LDREndPntPair , DirectX::HDREndPntPair
  • a : DirectX::HDRColorA
  • A : DirectX::INTEndPntPair , Triangle
  • ABitMask : DDS_PIXELFORMAT
  • accClass : SDKSample::TouchKeyboard::sealed
  • accelerometer : SDKSample::AccelerometerCPP::sealed , SDKSample::DisplayOrientation::sealed
  • AcceptChildNode() : Page , Text , Design , Element , Layer , List< T >
  • Accessibility() : SDKSample::HighContrast::sealed
  • AccessibilityGetSettings_Click() : SDKSample::HighContrast::sealed
  • accessTicket : SDKSample::MicrosoftAccount::sealed
  • AccumulateSphereTriangleIntersections() : Collision
  • ActionTransition() : SimpleCommunication::sealed
  • actionTransitionFunctions : SimpleCommunication::sealed
  • Activate() : SDKSample::FilePickerContracts::sealed , CMPEG1Stream
  • ActivateCompleted()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • activated : SimpleCommunication::VideoChat
  • Active() : GameObject , GameTimer , MoveLookController , GameObject , GameTimer , MoveLookController
  • active : SimpleCommunication::sealed
  • activeDownloads : SDKSample::BackgroundTransfer::sealed
  • Add()
: SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
, SDKSample::Playlists::sealed
, SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
, SDKSample::FlipViewData::sealed
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • AddButtonClicked() : Postcard::sealed
  • AddCallback_Click() : SDKSample::SDKTemplate::sealed
  • AddChild() : Element
  • AddConstructionPaperClicked() : Postcard::sealed
  • AddContentValue() : ShareTarget::sealed
  • AddEffectsClicked() : Postcard::sealed
  • AddEffectToImageStream() : SDKSample::MediaCapture::sealed
  • AddFavoriteButton_Click() : AppBarControl::sealed
  • AddFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • AddGeometry() : OutlineRenderer
  • AddImage() : Postcard::sealed
  • AddImageQuery : NotificationsExtensions::NotificationContentImage , NotificationsExtensions::NotificationBase
  • AddImageQueryNullable : NotificationsExtensions::NotificationContentImage , NotificationsExtensions::NotificationBase
  • AddInputStreams() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • AddItem() : ScheduledNotificationsSampleCPP::sealed
  • AddLocalFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • AddMenuItem() : D2DInterpolationModes
  • AddObserver()
: Hilo::FileSystemRepository
, Hilo::ObservableQuery
  • AddOnePrintPreviewPage()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • AddPaper() : PaperRenderer , PostcardRenderer
  • AddPaperClicked : Postcard::sealed
  • AddPrintPages()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • AddQuickLink_Checked() : ShareTarget::sealed
  • AddQuickLink_Unchecked() : ShareTarget::sealed
  • AddRef() : ContentImageSource , FontFileStream , FontLoader , ImageFile , InlineImage
  • AddRepulsor() : SimpleSprites
  • Address : ContactPicker::sealed::SampleContact
  • Address_KeyUp() : SDKSample::WebViewControl::sealed
  • AddSampleContact() : ContactPicker::sealed
  • AddSamplesToQueue() : SDKSample::WASAPIAudio::MFSampleGenerator
  • AddScoreToTable() : HighScoreTable
  • AddSettingsScenario() : SDKSample::ApplicationSettings::sealed
  • addSettingsScenarioAdd_Click() : SDKSample::ApplicationSettings::sealed
  • AddShape() : Program
  • AddSibling() : Element
  • AddSignatureClicked() : Postcard::sealed
  • AddSound() : XAudio2SoundPlayer
  • AddStream() : StreamList
  • AddSuggestionFromNode() : SDKSample::SearchContract::sealed
  • AddTextClicked() : Postcard::sealed
  • AddTexture() : BasicSprites::SpriteBatch
  • AddToListButton_Click() : SDKSample::FileAccess::sealed
  • AddToSelection() : SDKSample::TouchKeyboard::sealed
  • AddTouch() : MarbleMaze
  • AddURIIfValid() : SDKSample::SDKTemplate::sealed
  • AddURLFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • AdvancedCapture() : SDKSample::MediaCapture::sealed
  • advanceWidth : FPSCounter::AtlasText
  • AdviseEventAdded() : CAppWindowProvider
  • AdviseEventRemoved() : CAppWindowProvider
  • aEndPts : DirectX::D3DX_BC7::EncodeParams
  • aHDRPixels : DirectX::D3DX_BC6H::EncodeParams , DirectX::D3DX_BC7::EncodeParams
  • aIPixels : DirectX::D3DX_BC6H::EncodeParams
  • aLDRPixels : DirectX::D3DX_BC7::EncodeParams
  • Allocate() : Buffer
  • AllocateStreamingResources() : CDecoder
  • Alpha : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • alpha : DirectX::D3DX_BC3
  • Alt : NotificationsExtensions::NotificationContentImage
  • Ambient : SDKMESH_MATERIAL
  • amplitude : RippleEffect
  • AmpPixel() : AmpPixel
  • AnalyzeBidi() : TextAnalysis
  • AnalyzeGlyphOrientation() : TextAnalysis
  • AnimatePosition() : GameObject
  • Animation() : Animation< T >
  • AnimationData : SDKANIMATION_FRAME_DATA
  • AnimationDataIndex : SDKMESH_FRAME
  • AnimationDataOffset : SDKANIMATION_FILE_HEADER
  • AnimationDataSize : SDKANIMATION_FILE_HEADER
  • AnimationFPS : SDKANIMATION_FILE_HEADER
  • Animations_SelectionChanged() : SDKSample::AnimationMetrics::sealed
  • Ant() : AntSystem::Ant
  • App()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, D2D3DTransforms::sealed
, Magazine::sealed
, Postcard::sealed
, SimpleBlogReader::sealed
, Hilo::sealed
, LanguageFontCPP::sealed
, SDKTemplate::App
, MediaExtensionsCS::App
, SDKTemplate::App
, PrintSample::sealed
, ProximityCPP::sealed
, RawNotificationsSampleCPP::sealed
, SDKTemplate::App
, SecondaryTiles::sealed
, ShareTarget::sealed
, ToastsSampleCPP::sealed
, DeviceAppForWebcam::sealed
, D2DLightingEffects::sealed
, Simple3DGameXaml::sealed
, SDKTemplate::App
, ScheduledNotificationsSampleCPP::sealed
, EdgeGestureSample::sealed
, LockScreenAppsCPP::sealed
, SDKTemplate::App
  • App::EnsureMainPageActivated() : SDKSample::App
  • App::OnActivated() : AssociationLaunching::sealed
  • App::OnFileActivated() : AssociationLaunching::sealed
  • App::OnResume() : Hilo::sealed
  • appBar : SecondaryTiles::sealed
  • appBarOpenedToken : SecondaryTiles::sealed
  • appData : SDKSample::ApplicationDataSample::sealed
  • AppendAudioTag() : NotificationsExtensions::ToastContent::ToastNotificationBase
  • applicationData : SDKSample::ApplicationDataSample::sealed
  • AppListingUri() : SDKSample::StoreSample::sealed
  • AppListingUriRefreshScenario() : SDKSample::StoreSample::sealed
  • ApplyColorSimplifier() : FrameProcessing
  • ApplyEdgeDetection() : FrameProcessing
  • ApplyEdgeDetectionParallel() : FrameProcessing
  • ApplyFilters() : FrameProcessing
  • ApplyFont_Click() : LanguageFontCPP::sealed
  • ApplyForces() : Physics
  • ApplyJustificationSettings() : DWriteParagraphText
  • ApplySpacingSettings() : DWriteParagraphText
  • AppMuted()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • appSettings : SDKSample::CameraCapture::sealed
  • AppUnmuted()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • ArchitectureString() : SDKSample::PackageSample::sealed
  • args : MoveLookController , LonLatController
  • ArrangeOverride() : Hilo::Common::sealed
  • arraySize : DirectX::TexMetadata , DDS_HEADER_DXT10 , DirectX::DDS_HEADER_DXT10
  • artistInner : SDKSample::MediaButtons::sealed
  • aspectRatio : SimpleCommunication::sealed::StreamFilteringCriteria
  • AssignIndices()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • AsyncCallback() : AsyncCallback< T >
  • atlasRect : FPSCounter::AtlasText
  • Attach() : sealed
  • AttachFeed() : SDKSample::sealed
  • AttachmentImage_RightTapped() : SDKSample::ContextMenu::sealed
  • AttachNavigationHandlers() : Hilo::HiloPage
  • AttachProgressAndCompletedHandlers() : SDKSample::BackgroundTask::sealed
  • Audio : NotificationsExtensions::ToastContent::ToastNotificationBase
  • AUDIO_FILE_NAME : MediaCapture::AudioCapture
  • AudioCapture()
: SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
  • AudioEngineCallbacks() : AudioEngineCallbacks
  • audioExtensionsInner : SDKSample::MainPage
  • AudioSource() : MediaStreamSource::AudioSource
  • AudioSrcIsLooping() : NotificationsExtensions::ToastContent::ToastNotificationBase
  • AudioVisual : SDKSample::PlayToreceiver::sealed
  • aUnqEndPts : DirectX::D3DX_BC6H::EncodeParams
  • authenticator : SDKSample::MicrosoftAccount::sealed
  • Author : SimpleBlogReader::sealed
  • AutoFire() : MoveLookController
  • autoFire : GameConfig
  • automationId : SDKSample::Accessibility::sealed
  • automationName : SDKSample::Accessibility::sealed
  • AutoPlay() : MEPlayer
  • autoplayFileSystemDeviceFolder : SDKSample::MainPage
  • autoplayNonFileSystemDeviceId : SDKSample::MainPage
  • autoplayScenarioIndex : SDKSample::MainPage
  • autoSizeInputSectionWhenSnapped
: StreamSocketSample::sealed
, SecondaryTiles::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
, DatagramSocketSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, Clipboard::sealed
  • AutoSizeInputSectionWhenSnapped : SDKTemplate::MainPage
  • autoSizeInputSectionWhenSnapped
: ContactPicker::sealed
, AppBarControl::sealed
, SDKSample::FilePickerContracts::sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- b -

  • b : Vector3< T > , Vector4< T > , DirectX::HDRColorA
  • B : DirectX::LDREndPntPair , DirectX::HDREndPntPair
  • b : DirectX::INTColor
  • B : DirectX::INTEndPntPair , Triangle
  • b : DirectX::LDRColorA , AmpPixel
  • Back() : List< T >
  • Back_Click() : AppBarControl::sealed
  • backgroundAvailable : GameConfig
  • BackgroundObject() : sealed
  • BackgroundTask() : NetworkStatusTask::sealed
  • BackgroundTaskCompleted() : RawNotificationsSampleCPP::sealed
  • Backtrack() : AntSystem::Ant
  • BadgeGlyphNotificationContent() : NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
  • BadgeNumericNotificationContent() : NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
  • Bar1 : _BAR_GRAPH_STATE
  • Bar2 : _BAR_GRAPH_STATE
  • Bar3 : _BAR_GRAPH_STATE
  • Bar4 : _BAR_GRAPH_STATE
  • Bar5 : _BAR_GRAPH_STATE
  • Bar6 : _BAR_GRAPH_STATE
  • Bar7 : _BAR_GRAPH_STATE
  • Bar8 : _BAR_GRAPH_STATE
  • BarGraphDisplayResult() : Samples::Devices::Fx2::sealed
  • BarsAsUChar : _BAR_GRAPH_STATE
  • baseline : InlineImage
  • BaseUri : NotificationsExtensions::NotificationBase
  • BasicCapture()
: MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • BasicCustomControl() : SDKSample::UserAndCustomControls::sealed
  • BasicReaderWriter() : BasicReaderWriter
  • BasicUserControl() : SDKSample::UserAndCustomControls::sealed
  • bAttributesType : TGA_EXTENSION
  • bAudioLock : MPEG1SystemHeader
  • BBitMask : DDS_PIXELFORMAT
  • bBitsPerPixel : TGA_HEADER
  • bc1 : DirectX::D3DX_BC2 , DirectX::D3DX_BC3
  • bColorMapSize : TGA_HEADER
  • bColorMapType : TGA_HEADER
  • bConstrained : MPEG1VideoSeqHeader
  • bCSPS : MPEG1SystemHeader
  • bDescriptor : TGA_HEADER
  • Begin() : BasicSprites::SpriteBatch
  • BeginAsyncOp() : CMPEG1Source
  • BeginGetEvent() : CMPEG1Source , CMPEG1Stream
  • BeginOpen() : CMPEG1Source
  • BeginStreaming() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CPolarEffect
  • Beta : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • BezierRender() : sealed
  • bFixed : MPEG1SystemHeader
  • bHasPTS : MPEG1PacketHeader
  • bHorizontal : SDKSample::FlipViewCPP::sealed
  • bidiLevel : TextAnalysis::Run
  • bIDLength : TGA_HEADER
  • bImageType : TGA_HEADER
  • BindableNode() : SDKSample::sealed
  • BindableVectorChanged() : SDKSample::DataBinding::sealed
  • BindResource() : TextFrame , Element , ImageFrame
  • BingMapsKey : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • bitmap
: DirectX::D3DX_BC3
, DirectX::D3DX_BC1
, DirectX::D3DX_BC2
, InlineImage
  • Bitmap() : GameInfoOverlay
  • bitRate : MPEG1VideoSeqHeader
  • BitsPerSample : MediaStreamSource::PcmSource
  • blendState : BasicSprites::SpriteRunInfo
  • Blob() : DirectX::Blob
  • Blue : sealed
  • BoldButtonClick() : SDKSample::TextEditing::sealed
  • BonusTime() : Simple3DGame
  • BottomAppBar_Closed() : SDKSample::WebViewControl::sealed
  • BottomAppBar_Opened()
: SecondaryTiles::sealed
, SDKSample::WebViewControl::sealed
  • BottonAppBar_Loaded() : AppBarControl::sealed
  • BoundingBoxCenter : SDKMESH_MESH
  • BoundingBoxExtents : SDKMESH_MESH
  • bounds : FractalVertex
  • boundsTransform : DrawRectCB
  • Branding : NotificationsExtensions::TileContent::TileNotificationBase
  • BrightPassDownFilter() : D3DPostProcessing
  • bSigned : DirectX::D3DX_BC6H::EncodeParams
  • btmapImage_ImageOpened() : SDKSample::PlayToreceiver::sealed
  • btnFilePicker_Click() : SDKSample::WASAPIAudio::sealed
  • btnPause_Click() : SDKSample::WASAPIAudio::sealed
  • btnPlay_Click() : SDKSample::WASAPIAudio::sealed
  • btnPlayPause_Click() : SDKSample::WASAPIAudio::sealed
  • BtnRemoveTeam_Click() : SDKSample::DataBinding::sealed
  • btnStartCapture_Click() : SDKSample::WASAPIAudio::sealed
  • btnStartDevice_Click()
: MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
, SDKSample::MediaCapture::sealed
  • btnStartPreview_Click()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • btnStartStopRecord_Click()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
, MediaCapture::AudioCapture
  • btnStop_Click() : SDKSample::WASAPIAudio::sealed
  • btnStopCapture_Click() : SDKSample::WASAPIAudio::sealed
  • btnTakePhoto_Click()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
  • bTransformed : DirectX::D3DX_BC6H::ModeInfo
  • Buffer : RenderBuffer , Buffer , Samples::Devices::Fx2::sealed
  • BufferDataSize : SDKMESH_HEADER
  • bufferedPlaybackRate : SDKSample::PlayToreceiver::sealed
  • buffersCallback : Web::HttpRequest
  • BufferSize : RenderBuffer
  • BuildCollisionListForSphere() : Collision
  • BuildDateQuery() : Hilo::sealed
  • Button_Click() : SecondaryTiles::sealed
  • Button_Pause_Click()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • Button_Play_Click()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • Button_Stop_Click()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • buttonClickToken : SecondaryTiles::sealed
  • ButtonHangUp_Click() : SDKSample::CallControl::sealed
  • ButtonInitialize_Click() : SDKSample::CallControl::sealed
  • ButtonRing_Click() : SDKSample::CallControl::sealed
  • BuyProduct1Button_Click() : SDKSample::StoreSample::sealed
  • BuyProduct2_Click() : SDKSample::StoreSample::sealed
  • bValid : CStreamState
  • bVersionLetter : TGA_EXTENSION
  • bVideoLock : MPEG1SystemHeader
  • BW : DirectX::D3DX_BC6H
  • BX : DirectX::D3DX_BC6H
  • BY : DirectX::D3DX_BC6H
  • BytesFilled : RenderBuffer
  • bytesPerRow : SDKSample::DataReaderWriter::sealed
  • bytesPerSegment : SDKSample::DataReaderWriter::sealed
  • bytesReceived : SDKSample::WebSocket::sealed
  • BytesTransferred : Samples::Devices::DeviceControlResult
  • BZ : DirectX::D3DX_BC6H
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- c -

  • C : Triangle
  • CachedFileUpdater_Local() : SDKSample::FilePickerContracts::sealed
  • CachedFileUpdater_Remote() : SDKSample::FilePickerContracts::sealed
  • CachedFileUpdaterPage() : SDKSample::FilePickerContracts::sealed
  • CachedFileUpdaterPage_SizeChanged() : SDKSample::FilePickerContracts::sealed
  • cachedFileUpdaterUI : SDKSample::FilePickerContracts::sealed
  • CalculateCenterPosition() : D2DTextAnimation
  • CalculateContact() : Contact
  • CalculateCurrentRoomSize() : Physics
  • CalculateDeviceRotation() : SDKSample::DisplayOrientation::sealed
  • CalculateInitialCropOverlayPosition() : Hilo::sealed
  • CalculateSize() : ElementBase , TextElement , TextButton
  • CalculateSobel() : FrameProcessing
  • CalendarEnumerationAndMath() : SDKSample::CalendarSample::sealed
  • Call_Click() : SimpleCommunication::VideoChat
  • callback : Hilo::sealed
  • callbackHander : XAudio2SoundPlayer::ImplData
  • CallButton_Click() : SimpleCommunication::sealed
  • CallControlError() : SDKSample::CallControl::sealed
  • CallControls : SDKSample::CallControl::sealed
  • CallControls_AnswerRequested() : SDKSample::CallControl::sealed
  • CallControls_AudioTransferRequested() : SDKSample::CallControl::sealed
  • CallControls_DialRequested() : SDKSample::CallControl::sealed
  • CallControls_HangUpRequested() : SDKSample::CallControl::sealed
  • CallControls_RedialRequested() : SDKSample::CallControl::sealed
  • CallControlStatus() : SDKSample::CallControl::sealed
  • CallToken : SDKSample::CallControl::sealed
  • CameraFound : SDKTemplate::MainPage
  • Cancel : SDKSample::Errors
  • Cancel_Click() : SDKSample::HttpClientSample::sealed
  • CancelAll_Click() : SDKSample::BackgroundTransfer::sealed
  • CancelCartoonize() : Hilo::sealed
  • CancelCommand() : SDKSample::MessageDialogSample::sealed
  • CancelCommandButton_Click() : SDKSample::MessageDialogSample::sealed
  • CancelContext : Samples::Devices::Fx2::sealed
  • CancelCrop() : Hilo::sealed
  • CancelDelayTimer() : SDKSample::ThreadPool::sealed
  • CancelGetGeolocation() : SDKSample::GeolocationCPP::sealed
  • cancellationToken : SDKSample::BackgroundTransfer::sealed , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • cancellationTokenSource : SDKSample::HttpClientSample::sealed , SDKSample::MicrosoftAccount::sealed
  • CancelMonthAndYearQueries() : Hilo::sealed
  • CancelPeriodicTimer() : SDKSample::ThreadPool::sealed
  • CancelRequested : Tasks::sealed
  • CancelRotate() : Hilo::sealed
  • CancelThreadPoolWorkItem() : SDKSample::ThreadPool::sealed
  • CanExecute() : Hilo::sealed
  • CanExecuteChanged : Hilo::sealed
  • CanNavigateToPictures() : Hilo::sealed
  • CanProcessImage() : Hilo::sealed
  • CAppWindowProvider() : CAppWindowProvider
  • caps : DDS_HEADER
  • caps2 : DDS_HEADER
  • caps3 : DDS_HEADER
  • caps4 : DDS_HEADER
  • CaptureDevice()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • CaptureFailed : SimpleCommunication::Common::CaptureDevice
  • CapturePhoto() : SDKSample::CameraCapture::sealed
  • CapturePhoto_Click() : SDKSample::CameraCapture::sealed
  • CaptureSource : SimpleCommunication::Common::CaptureDevice
  • CaptureVideo() : SDKSample::CameraCapture::sealed
  • CaptureVideo_Click() : SDKSample::CameraCapture::sealed
  • CartoonizeImage() : Hilo::sealed
  • CartoonizeImageAmpAsync() : Hilo::sealed
  • CartoonizeImagePPLAsync() : Hilo::sealed
  • CartoonizeImageView() : Hilo::sealed
  • CAsyncState() : CAsyncState
  • cAudioBound : MPEG1SystemHeader
  • CAutoDXDevLockBase() : CAutoDXDevLockBase< DevManager, DevInterface >
  • CAutoDXGILock() : CAutoDXGILock
  • cbHeader : MPEG1VideoSeqHeader
  • cbPacketSize : MPEG1PacketHeader
  • cbPayload : MPEG1PacketHeader
  • cbSize : MPEG1SystemHeader
  • cbVBV_Buffer : MPEG1VideoSeqHeader
  • center : RippleEffect , Sphere
  • certificateRequest : SDKSample::CertificateEnrollment::sealed
  • ChangeInProgress() : Hilo::sealed
  • ChangeUser_Click() : SDKSample::PasswordVaultCPP::sealed
  • channel : SDKSample::MainPage
  • ChannelDown() : SDKSample::MediaButtons::sealed
  • Channels : MediaStreamSource::PcmSource
  • ChannelUp() : SDKSample::MediaButtons::sealed
  • CheckBox_Checked_HorizontalRailed() : SDKSample::ScrollViewerCPP::sealed
  • CheckBox_Checked_VerticalRailed() : SDKSample::ScrollViewerCPP::sealed
  • CheckBox_Unchecked_HorizontalRailed() : SDKSample::ScrollViewerCPP::sealed
  • CheckBox_Unchecked_VerticalRailed() : SDKSample::ScrollViewerCPP::sealed
  • CheckDisconnected() : CAppWindowProvider
  • CheckDX11Device() : CInvert
  • CheckForCancellation() : Hilo::sealed
  • CheckForRecordingDeviceAsync() : SimpleCommunication::Common::CaptureDevice
  • CheckLoadDone() : SDKMesh
  • Checkpoints : MarbleMaze
  • CheckResolutionAndViewState()
: ToastsSampleCPP::sealed
, AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • CheckResult() : Samples::Devices::Fx2::sealed
  • CheckRotationAngle() : Hilo::sealed
  • CheckSharesVertsOrCoplanar() : Triangle
  • CheckShutdown() : CMPEG1Source , CMPEG1Stream
  • CheckStereoEnabledStatus() : abstract
  • ChildFrame : SDKMESH_FRAME
  • chkAddRemoveEffect_Checked() : SDKSample::MediaCapture::sealed
  • chkAddRemoveEffect_Unchecked() : SDKSample::MediaCapture::sealed
  • chunkSize : SDKSample::DataReaderWriter::sealed
  • Circle_Click()
: MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCPP::sealed
  • City : ContactPicker::sealed::SampleContact
  • Clamp() : CommandListRenderer , CompositeModes , RippleEffect , WaveEffect , D2DInterpolationModes , DirectX::HDRColorA , DirectX::INTColor
  • ClassName
: SDKSample::Scenario
, AccountPictureName::Scenario
, Clipboard::Scenario
, ContactPicker::Scenario
, DatagramSocketSample::Scenario
, DeviceAppForPrinters::Scenario
, SDKSample::Scenario
, ProximityCPP::Scenario
, SimpleCommunication::Scenario
, StreamSocketSample::Scenario
, AppBarControl::Scenario
  • className : SecondaryTiles::Scenario
  • ClassType : SDKTemplate::Scenario
  • Cleanup() : SimpleCommunication::sealed
  • CleanUp() : SimpleCommunication::sealed
  • CleanUpAsync() : SimpleCommunication::Common::CaptureDevice
  • CleanupAsync()
: SimpleCommunication::LowLatency
, SimpleCommunication::sealed
  • CleanupSink()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • Clear() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , Hilo::PhotoCache , List< T > , ComPtrList< T, NULLABLE > , StreamList , List< T > , ComPtrList< T, NULLABLE > , StreamList , SDKSample::Playlists::sealed , SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , List< T > , ComPtrList< T, NULLABLE >
  • Clear_Click() : SDKSample::ApplicationDataSample::sealed
  • ClearAllHighlightedWords() : SDKSample::TextEditing::sealed
  • ClearBadge_Click()
: SDKSample::Tiles::sealed
, LockScreenAppsCPP::sealed
  • ClearBarGraphTable()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • ClearCachedData() : Hilo::sealed
  • ClearImageData() : Hilo::sealed
  • ClearLastStatus() : SimpleCommunication::SdkSample
  • ClearLog() : ProximityCPP::sealed
  • ClearOutput() : Clipboard::sealed
  • ClearOutputButton_Click() : Clipboard::sealed
  • ClearPacket() : Parser
  • ClearPageCollection() : PrintSample::sealed
  • ClearPreference_Click() : SDKSample::Rotation::sealed
  • ClearScenario() : SDKSample::ApplicationDataSample::sealed
  • ClearSwitchStateTable() : SDKSample::CustomDeviceAccess::sealed
  • ClearTile_Click()
: SDKSample::Tiles::sealed
, LockScreenAppsCPP::sealed
  • ClickMeButtonClicked() : SDKSample::UserAndCustomControls::sealed
  • clockwise : AnimateCirclePosition
  • Clone() : ImageFile , SDKSample::TouchKeyboard::sealed
  • Close()
: Extruder::ExtrudingSink
, PointSnapper::PointSnappingSink
  • Close_Click() : SDKSample::WebSocket::sealed
  • CloseAnimatedPopupClicked() : SDKSample::XAMLPopup::sealed
  • CloseChannel_Click() : SDKSample::SDKTemplate::sealed
  • Closed() : SDKSample::WebSocket::sealed
  • CloseFilePicker() : MEPlayer
  • CloseFx2Device() : SDKSample::CustomDeviceAccess::sealed
  • CloseMedia() : MediaStreamSource::PcmSource
  • ClosePopupClicked() : SDKSample::XAMLPopup::sealed
  • ClosePrintControl() : PageRenderer
  • CloseSettingsPopupClicked() : SDKSample::XAMLPopup::sealed
  • CloseSocket() : ProximityCPP::sealed
  • CloseSockets_Click()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • closingVelocity : Contact
  • CMPEG1Source() : CMPEG1Source
  • CMPEG1Stream() : CMPEG1Stream
  • CollectionChange : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
  • Collision() : Collision
  • color : BasicSprites::ReplicationVertex , BasicSprites::InstanceData , SimpleCubeVertex , PaperFragment
  • ColorButtonClick() : SDKSample::TextEditing::sealed
  • ColorOffsetValueChanged() : SDKSample::Drawing::sealed
  • ColorSelectionChanged() : SDKSample::Drawing::sealed
  • ColorSpaceProperty : SDKSample::FolderEnumeration::sealed
  • ComBase() : ComBase< InterfaceChain >
  • CombineGlow() : D3DPostProcessing
  • ComboBox1_DropDownClosed() : SDKSample::WebViewControl::sealed
  • ComboBox1_DropDownOpened() : SDKSample::WebViewControl::sealed
  • ComboBox_SelectionChanged_1() : SDKSample::ScrollViewerCPP::sealed
  • CommandInvokedHandler() : SDKSample::MessageDialogSample::sealed
  • commandsRequestedEventRegistrationToken : SDKSample::ApplicationSettings::sealed
  • Commit() : ImageFile
  • Compare() : SDKSample::TouchKeyboard::sealed
  • CompareEndpoints() : SDKSample::TouchKeyboard::sealed
  • compass : SDKSample::CompassCPP::sealed
  • CompleteAsyncOp() : CMPEG1Source
  • CompletedCallback() : SDKSample::MessageDialogSample::sealed
  • CompletedCallbackButton_Click() : SDKSample::MessageDialogSample::sealed
  • CompleteOpen() : CMPEG1Source
  • completionEvent : HttpRequestStringCallback
  • CompositeSettings() : SDKSample::ApplicationDataSample::sealed
  • compressedData : ScenarioContext
  • compressor : ScenarioContext
  • ComputeIndex() : DirectX::TexMetadata
  • ComputeTriangleLocation() : D2DBasicAnimation
  • ComputeValue() : Animation< T > , LinearAnimation< T > , EaseInExponentialAnimation< T > , EaseOutExponentialAnimation< T > , EaseInOutExponentialAnimation< T >
  • ConfigureDeviceInternal() : SDKSample::WASAPIAudio::WASAPIRenderer
  • ConfigureSource() : SDKSample::WASAPIAudio::WASAPIRenderer
  • ConfigureStreams() : SDKSample::WASAPIAudio::MFSampleGenerator
  • connected : DatagramSocketSample::sealed
  • connectionProfileInfo : SDKSample::NetworkInformationApi::sealed
  • ConnectionProfileList() : SDKSample::NetworkInformationApi::sealed
  • ConnectionProfileList_Click() : SDKSample::NetworkInformationApi::sealed
  • ConnectionRequestedEventHandler() : ProximityCPP::sealed
  • ConnectSocket_Click()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • Contact() : Contact
  • contactIsEdge : Contact
  • ContactList_SelectionChanged() : ContactPicker::sealed
  • ContactPickerPage() : ContactPicker::sealed
  • contactPickerUI : ContactPicker::sealed
  • contactPosition : Contact
  • contactSet : ContactPicker::sealed
  • ContainerDisplayItem() : SDKSample::DeviceEnumeration::sealed
  • Containers() : SDKSample::DeviceEnumeration::sealed
  • Contains() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • ContainsKey() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • ContainsTextPosition() : TextAnalysis::Run
  • Content : SimpleBlogReader::sealed , NotificationsExtensions::ToastContent::ToastAudio
  • contentChangedToken : Clipboard::sealed
  • ContentImageSource() : ContentImageSource
  • ContentStream : SDKSample::WASAPIAudio::DEVICEPROPS
  • contentText : SDKSample::TouchKeyboard::sealed
  • ContextChanged() : SDKSample::ApplicationResources::sealed
  • ContinuationPage() : PrintSample::sealed
  • ContinueGame() : Simple3DGame
  • continuous : AnimateLinePosition , AnimateCirclePosition
  • Continuous() : abstract
  • ControlRect() : UiaCoreWindowProvider::ITriColorControlInternal
  • ControlValue() : UiaCoreWindowProvider::ITriColorControlInternal
  • Convert()
: SimpleBlogReader::sealed
, Hilo::sealed
, Hilo::Common::sealed
, Hilo::sealed
, SDKSample::DataBinding::sealed
  • ConvertBack()
: SimpleBlogReader::sealed
, Hilo::sealed
, Hilo::Common::sealed
, Hilo::sealed
, SDKSample::DataBinding::sealed
  • ConvertDegreesRotationToExifOrientation() : Hilo::ExifExtensions
  • ConvertDipsToPixels() : abstract
  • ConvertExifOrientationToDegreesRotation() : Hilo::ExifExtensions
  • ConvertIndexToColor() : SDKSample::MainPage
  • ConvertResolution()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ConvertStrokeToGeometry() : InkRenderer
  • ConvertTrial_Click() : SDKSample::StoreSample::sealed
  • ConvertViewState()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::SnapSample::sealed
, ToastsSampleCPP::sealed
  • convFlags : DirectX::LegacyDDS
  • cookie : SDKSample::NetworkInformationApi::sealed
  • CopyAmpPixelArrayToPixelData() : Hilo::sealed
  • CopyBitmap() : Clipboard::sealed
  • CopyButton_Click() : Clipboard::sealed
  • CopyFile() : SDKSample::ApplicationDataSample::sealed
  • CopyFileButton_Click() : SDKSample::FileAccess::sealed
  • CopyFiles() : Clipboard::sealed
  • CopyFileToFolderOnStorageAsync() : SDKSample::RemovableStorageCPP::sealed
  • CopyImage() : Clipboard::sealed
  • CopyPixelDataToAmpPixelArray() : Hilo::sealed
  • CopyPixelDataToPlatformArray() : Hilo::sealed
  • CopyrightProperty : SDKSample::FolderEnumeration::sealed
  • CopyText() : Clipboard::sealed
  • CopyTo() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , ImageFile , SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • CopyWithDelayedRenderingButton_Click() : Clipboard::sealed
  • CoreDispatcher_AcceleratorKeyActivated()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • CoreWindow_PointerPressed()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • CoTaskMemFreeArray() : SDKSample::CoTaskMemFreeArray
  • count : SDKSample::FlipViewData::sealed
  • Count : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • CountdownTimer() : CountdownTimer
  • counter : SDKSample::ApplicationDataSample::sealed
  • Create() : GeometryRealization , GeometryRealizationFactory , Element , SDKMesh , SDKSample::Playlists::sealed
  • CreateAndThenDeleteFolderOnDeviceAsync() : SDKSample::PortableDeviceCPP::sealed
  • CreateAudioResources() : StreamEffect
  • CreateAudioType() : SDKSample::WASAPIAudio::MFSampleGenerator
  • CreateAudioVoices() : AudioController
  • CreateBackBuffers() : MEPlayer
  • CreateBadgeAndTextTile_Click() : LockScreenAppsCPP::sealed
  • CreateBadgeTile_Click() : LockScreenAppsCPP::sealed
  • CreateBooleanTable()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • CreateBox() : BasicShapes
  • CreateBuffers() : ExtrudedTextRenderer
  • CreateContainer_Click() : SDKSample::ApplicationDataSample::sealed
  • CreateCube() : BasicShapes
  • CreateDataTask() : Web::Details::HttpRequestBuffersCallback
  • CreateDelayTimer() : SDKSample::ThreadPool::sealed
  • CreateDeviceIndependentResources() : abstract , StreamEffect , abstract , PaperRenderer , D2D3DTransformsRenderer , abstract , D2DTextAnimation , DWriteHitTesting , abstract , D2DBasicAnimation , abstract , DWriteCustomTextRenderer , D2DEffectsHelloWorld , abstract , CompositeModes , abstract , ConvolveMatrixEffect , abstract , D2DEffectsOnPrimitives , abstract , GeometryRealizationSample , abstract , Renderer , D2DPerspectiveTransform , abstract , PageRenderer , abstract , SaveAsImageFile , PageRenderer , abstract , BumpMapping , abstract , DirectXFractal , D3DPostProcessing , abstract , ResourceLoading , abstract , SimpleSprites , abstract , StereoSimpleD3D , Direct3DTutorial , abstract , TextInterop , abstract , DWriteHelloWorld , abstract , DWriteInlineObject , abstract , DWriteParagraphText , abstract , DWriteVerticalText , Audio , GameHud , GameInfoOverlay , GameRenderer , abstract , ExtrudedTextRenderer , InkRenderer , PostcardRenderer , CoreWindowEvents , abstract , Simple3DTouch , abstract , OfferReclaimAPI , abstract , sealed , abstract , sealed , D2DLightingEffectsRenderer , Audio , abstract , GameHud , GameRenderer , BasicSound , abstract
  • CreateDeviceResources() : abstract , OfferReclaimAPI , InkRenderer , D2DEffectsOnPrimitives , D2DInterpolationModes , abstract , D2D3DTransformsRenderer , D2DTextAnimation , abstract , D2DBasicAnimation , D2DEffectsHelloWorld , abstract , CommandListRenderer , abstract , CompositeModes , abstract , ConvolveMatrixEffect , abstract , GeometryRealizationSample , abstract , Renderer , D2DPerspectiveTransform , abstract , PageRenderer , abstract , PageRenderer , abstract , BumpMapping , abstract , DirectXFractal , D3DPostProcessing , abstract , ResourceLoading , abstract , SimpleSprites , abstract , StereoSimpleD3D , Direct3DTutorial , abstract , TextInterop , abstract , DWriteHelloWorld , abstract , DWriteInlineObject , abstract , DWriteParagraphText , abstract , DWriteVerticalText , abstract , GameInfoOverlay , GameRenderer , abstract , ExtrudedTextRenderer , ImageRenderer , PaperRenderer , PostcardRenderer , CoreWindowEvents , abstract , Simple3DTouch , abstract , DxgiRotation , abstract , sealed , abstract , sealed , D2DLightingEffectsRenderer , abstract , GameHud , GameRenderer , BasicSound , abstract , StreamEffect , AudioController , abstract , SimpleController , GameHud , MarbleMaze , abstract , DWriteHitTesting , DWriteCustomTextRenderer , SaveAsImageFile , abstract
  • CreateDpiDependentResources() : GameInfoOverlay
  • CreateDX11Device() : MEPlayer
  • CreateEffectGraph() : D2DEffectsHelloWorld , D2DEffectsOnPrimitives
  • CreateEnumeratorFromKey() : FontLoader
  • CreateExtrudingSink() : Extruder::ExtrudingSink
  • CreateFileButton_Click() : SDKSample::FileAccess::sealed
  • CreateFileQuery() : Hilo::FileSystemRepository
  • CreateFromFile() : SDKMesh
  • CreateFromMemory() : SDKMesh
  • CreateGameDeviceResourcesAsync() : GameRenderer
  • CreateGeometries() : GeometryRealizationSample
  • CreateGeometryRealization() : GeometryRealizationFactory
  • CreateGraph() : TripOptimizerComponent::Details::TripOptimizerImpl
  • CreateHeaderTextBlock() : SDKSample::FolderEnumeration::sealed
  • CreateHitTextureResourceView() : TargetTexture
  • CreateIndexBuffer() : BasicShapes , SDKMesh , BasicShapes
  • CreateInputLayout() : BasicLoader
  • CreateInstance() : CMPEG1Source
  • CreateLineItemTextBlock() : SDKSample::FolderEnumeration::sealed
  • CreateLocalThumbnailAsync() : Hilo::ThumbnailGenerator
  • CreateMemoryStream() : Web::HttpRequest
  • CreateMesh() : BasicLoader
  • CreateMonthRangeFromDate() : Hilo::CalendarExtensions
  • CreateMonthRangeFromYearAndMonth() : Hilo::CalendarExtensions
  • CreateNotification()
: NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::TileContent::TileNotificationBase
, NotificationsExtensions::ToastContent::ToastNotificationBase
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::ToastContent::ToastNotificationBase
  • CreateOp() : SourceOp
  • CreateOpacityMask() : D2DTextAnimation
  • CreateOutlineRenderer() : OutlineRenderer
  • CreatePeriodicTimer() : SDKSample::ThreadPool::sealed
  • CreatePlaylist() : SDKSample::MediaButtons::sealed
  • CreatePointSnappingSink() : PointSnapper::PointSnappingSink
  • CreatePresentationDescriptor() : CMPEG1Source
  • CreatePrimitives() : D2DEffectsOnPrimitives
  • CreatePrintControl() : PageRenderer
  • CreatePrintPreviewPages()
: PrintSample::sealed
, PrintSample::BasePrintPage
  • CreateRandomizedVector() : Hilo::RandomPhotoSelector
  • CreateReferenceAxis() : BasicShapes
  • CreateRequest_Click() : SDKSample::CertificateEnrollment::sealed
  • CreateResources() : Audio
  • CreateReverb() : Audio
  • CreateRippleImpl() : RippleEffect
  • CreateSample() : MediaStreamSource::PcmSource
  • CreateSetRateOp() : SourceOp
  • CreateSourceVoice() : Audio
  • CreateSphere() : BasicShapes
  • CreateSpiralPathAndTriangle() : D2DBasicAnimation
  • CreateStartOp() : SourceOp
  • CreateStream() : CMPEG1Source
  • CreateStreamFromKey() : FontLoader
  • CreateTangentSphere() : BasicShapes
  • CreateTangentVertexBuffer() : BasicShapes
  • CreateTextLayout() : TextElement
  • CreateTexture() : BasicLoader
  • CreateTextureResourceView() : TargetTexture
  • CreateThemeSpecificResources() : sealed
  • CreateThreadPoolWorkItem() : SDKSample::ThreadPool::sealed
  • CreateThumbnailFromPictureFileAsync() : Hilo::ThumbnailGenerator
  • CreateTileSquareBlock() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareImage() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquarePeekImageAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquarePeekImageAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquarePeekImageAndText03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquarePeekImageAndText04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareText03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareText04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideBlockAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideBlockAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideImage() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideImageAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideImageAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideImageCollection() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage05() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage06() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection05() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection06() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText05() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText05() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText06() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText07() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText08() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText09() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText10() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText11() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateVertexBuffer() : BasicShapes , SDKMesh , BasicShapes
  • CreateView() : DirectXAppSource , CTriColorWindowFactory , DirectXAppSource , Direct3DTutorialFrameworkViewSource , DirectXAppSource , Direct3DTutorialFrameworkViewSource , DirectXAppSource , Direct3DTutorialFrameworkViewSource , DirectXAppSource , sealed , DirectXAppSource , sealed , DirectXAppSource
  • CreateWaveImpl() : WaveEffect
  • CreateWAVFile() : SDKSample::WASAPIAudio::WASAPICapture
  • CreateWindowSizeDependentResources() : abstract , D2DInterpolationModes , DWriteCustomTextRenderer , DWriteHelloWorld , Direct3DTutorialFrameworkView , sealed , abstract , D2D3DTransformsRenderer , abstract , DWriteVerticalText , ImageRenderer , D2DEffectsHelloWorld , InkRenderer , StereoSimpleD3D , ExtrudedTextRenderer , abstract , SimpleController , ResourceLoading , abstract , D2DLightingEffectsRenderer , abstract , D3DPostProcessing , D2DEffectsOnPrimitives , abstract , Direct3DTutorialFrameworkView , PaperRenderer , abstract , DWriteInlineObject , DWriteParagraphText , abstract , TextInterop , DxgiRotation , abstract , DWriteHitTesting , Program , abstract , ConvolveMatrixEffect , Direct3DTutorial , PostcardRenderer , AudioController , abstract , sealed , abstract , Simple3DTouch , abstract , sealed , Direct3DTutorialFrameworkView , abstract , OfferReclaimAPI , CompositeModes , abstract , StreamEffect , abstract , D2DPerspectiveTransform , abstract , MarbleMaze , abstract , DirectXFractal , Direct3DTutorialFrameworkView , abstract , SimpleSprites , abstract , BasicSound , abstract , BumpMapping
  • criticalSection : SDKSample::WebSocket::sealed
  • CritSec() : CritSec
  • CropImage() : Hilo::sealed
  • CropImageAsync() : Hilo::sealed
  • CropImageView() : Hilo::sealed
  • cStreams : MPEG1SystemHeader
  • CStreamState() : CStreamState
  • CTriColorWindow() : sealed
  • cts : SDKSample::SearchContract::sealed
  • currChunk : SDKSample::DataReaderWriter::sealed
  • CurrencyFormatting() : SDKSample::NumberFormatting::sealed
  • Current : SDKTemplate::MainPage , CustomDeviceAccess::DeviceList
  • Current_DeviceClosing() : SDKSample::CustomDeviceAccess::sealed
  • currentFeed : SDKSample::Syndication::sealed
  • CurrentFeedUri : SimpleBlogReader::sealed
  • CurrentFreeSize() : Buffer
  • CurrentInputLanguage() : SDKSample::GlobalizationPreferencesSample::sealed
  • currentItemIndex : SDKSample::Syndication::sealed
  • CurrentLevel() : Simple3DGame
  • currentState : SimpleCommunication::LowLatency
  • currentType : SDKSample::PlayToreceiver::sealed
  • cursorId : ShapeRecord
  • Custom() : SDKSample::Transcode::sealed
  • CustomCommand() : SDKSample::MessageDialogSample::sealed
  • CustomCommandButton_Click() : SDKSample::MessageDialogSample::sealed
  • CustomTextBox() : SDKSample::TouchKeyboard::sealed
  • CustomTextRenderer() : CustomTextRenderer
  • cVideoBound : MPEG1SystemHeader
  • cw : SDKSample::PlaybackManager::sealed , SDKSample::PlaybackManager2::sealed
  • CycleBackground() : Simple3DGame , Simple3DGameXaml::sealed
  • Cylinder() : Cylinder
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- d -

  • D : DirectX::D3DX_BC6H
  • D2D1_FIGURE_BEGIN : Extruder::ExtrudingSink
  • d2dContext : TargetTexture , LoadScreen , PageRendererContext
  • D2DDeviceContext : CustomTextRenderer
  • d2dFactory : TargetTexture
  • D2DFactory : CustomTextRenderer
  • D2DFactoryLock() : D2DFactoryLock
  • D2DFlatten() : Extruder
  • D2DOutline() : Extruder
  • Data() : SourceOp
  • data : DirectX::BC4_UNORM , DirectX::BC4_SNORM
  • DataChangedEvent() : SDKSample::ApplicationDataSample::sealed
  • DataChangedHandler() : SDKSample::ApplicationDataSample::sealed
  • dataEvent : Web::Details::HttpRequestBuffersCallback
  • dataEventLock : Web::Details::HttpRequestBuffersCallback
  • dataHResult : Web::Details::HttpRequestBuffersCallback
  • DataOffset : SDKMESH_VERTEX_BUFFER_HEADER , SDKMESH_INDEX_BUFFER_HEADER , SDKANIMATION_FRAME_DATA
  • DataPtr() : Buffer
  • dataRequestedToken : SDKSample::Common::SharePage , SDKSample::WebViewControl::sealed
  • dataSent : SDKSample::WebSocket::sealed
  • datasize : DirectX::ConvertData
  • DataSize() : Buffer
  • dataStream : Web::Details::HttpRequestBuffersCallback
  • dataTransferManager : SDKSample::WebViewControl::sealed
  • dataTransferManager_DataRequested() : SDKSample::WebViewControl::sealed
  • dateAccessedProperty : SDKSample::FileAccess::sealed
  • dateFormat : SDKSample::FileAccess::sealed
  • ddpf : DirectX::LegacyDDS
  • ddspf : DDS_HEADER , DirectX::DDS_HEADER
  • Deactivate() : SimpleCommunication::sealed
  • DebugReset() : Physics
  • DecimalFormatting() : SDKSample::NumberFormatting::sealed
  • Decl : SDKMESH_VERTEX_BUFFER_HEADER
  • Decode()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • DecodeFromIndex()
: DirectX::BC4_UNORM
, DirectX::BC4_SNORM
  • DecodeImage() : D2DEffectsHelloWorld
  • decodePixelHeight : SDKSample::Images::sealed
  • decodePixelWidth : SDKSample::Images::sealed
  • Decoder : sealed
  • decompressedData : ScenarioContext
  • Default_Click()
: SDKSample::CryptoWinRT::sealed
, SDKSample::HomeGroup::sealed
, SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
, SDKSample::HighContrast::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::IsRemoteSession::sealed
, SDKSample::Compression::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
  • DEFAULT_LOGICALPPI : SDKSample::Scaling::sealed
  • DefaultCloseCommand() : SDKSample::MessageDialogSample::sealed
  • DefaultCloseCommandButton_Click() : SDKSample::MessageDialogSample::sealed
  • defaultFontFamily : SDKSample::Scaling::sealed
  • defaultMode : SimpleCommunication::LowLatency
  • DefaultPage() : ShareTarget::sealed
  • DefaultRadius() : CPolarEffect
  • DefaultScenario() : SDKSample::ApplicationSettings::sealed
  • DefaultTheta() : CPolarEffect
  • DefaultViewModel : SDKTemplate::Common::LayoutAwarePage
  • DefaultViewModelProperty : SDKTemplate::Common::LayoutAwarePage
  • Deferral : Tasks::sealed
  • Deinitialize() : SimpleCommunication::SdkSample
  • Delay : _FILE_PLAYBACK
  • DelayTimerScenario() : SDKSample::ThreadPool::sealed
  • DelegateCommand() : Hilo::sealed
  • DelegationTickets() : SDKSample::MicrosoftAccount::sealed
  • DeleteAllStrokes() : InkRenderer
  • DeleteCompositeSetting_Click() : SDKSample::ApplicationDataSample::sealed
  • DeleteContainer_Click() : SDKSample::ApplicationDataSample::sealed
  • DeleteFileButton_Click() : SDKSample::FileAccess::sealed
  • DeleteInputStream() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • DeleteItem_Click() : SDKSample::AtomPub::sealed
  • DeleteSetting_Click() : SDKSample::ApplicationDataSample::sealed
  • DeliverPayload() : CMPEG1Source , CMPEG1Stream , CMPEG1Source
  • deltaPerDtidX : ComputeCB , ComputeDoubleCB
  • deltaPerDtidY : ComputeCB , ComputeDoubleCB
  • DeltaTime() : GameTimer
  • depth : DDS_HEADER , DirectX::TexMetadata
  • Deserialize() : sealed , ManipulatableObject
  • DesignTimeData() : Hilo::sealed
  • DesignTimeMonthBlock() : Hilo::sealed
  • DesignTimePhotoGroup() : Hilo::sealed
  • DesignTimeYearGroup() : Hilo::sealed
  • DesignToDisplayHeight() : Document
  • DesignToDisplayWidth() : Document
  • desiredReportInterval
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
  • Destroy() : SDKMesh
  • Detach() : sealed
  • DetachNavigationHandlers() : Hilo::HiloPage
  • DetermineFractalTechnique() : DirectXFractal
  • DetermineVisualState()
: SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • device : SimpleCommunication::LowLatency , SimpleCommunication::VideoChat
  • Device : CustomDeviceAccess::DeviceListEntry
  • device_CaptureFailed()
: SimpleCommunication::LowLatency
, SimpleCommunication::VideoChat
  • device_IncomingConnectionArrived()
: SimpleCommunication::LowLatency
, SimpleCommunication::VideoChat
  • DeviceAppPage()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • DeviceArrived() : ProximityCPP::sealed
  • DeviceAsync()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • deviceAsyncGet_Click_1()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • deviceAsyncSet_Click_1()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • DeviceChecked : SDKTemplate::MainPage
  • DeviceClosing : CustomDeviceAccess::DeviceList , SDKSample::CustomDeviceAccess::DeviceList
  • deviceClosingHandler : SDKSample::CustomDeviceAccess::sealed
  • DeviceConnect() : SDKSample::CustomDeviceAccess::sealed
  • deviceConnectDevices_SelectionChanged_1() : SDKSample::CustomDeviceAccess::sealed
  • deviceConnectStart_Click_1() : SDKSample::CustomDeviceAccess::sealed
  • deviceConnectStop_Click_1() : SDKSample::CustomDeviceAccess::sealed
  • deviceContext : InlineImage
  • DeviceControlResult() : Samples::Devices::DeviceControlResult
  • DeviceDeparted() : ProximityCPP::sealed
  • DeviceEvents() : SDKSample::CustomDeviceAccess::sealed
  • deviceEventsGet_Click_1() : SDKSample::CustomDeviceAccess::sealed
  • deviceEventsRegister_Click_1() : SDKSample::CustomDeviceAccess::sealed
  • DeviceList()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • DeviceList_Tapped()
: SDKSample::PortableDeviceCPP::sealed
, SDKSample::RemovableStorageCPP::sealed
  • DeviceListEntry()
: CustomDeviceAccess::DeviceListEntry
, SDKSample::CustomDeviceAccess::sealed
  • DeviceLost : Renderer , abstract
  • DeviceReset : abstract
  • DeviceStateChangedEvent() : SDKSample::WASAPIAudio::sealed
  • Diffuse : SDKMESH_MATERIAL
  • diffuseColor : Material , ConstantBufferChangesEveryPrim
  • DiffuseRV : SDKMESH_MATERIAL
  • DiffuseTexture : SDKMESH_MATERIAL
  • DiffuseTextureName : SDKMESH_MATERIAL
  • dimension : DirectX::TexMetadata
  • DipsToPixelsRoundDown() : FPSCounter
  • DipsToPixelsRoundUp() : FPSCounter
  • Disable() : Wrapper::sealed
  • DisableButtons() : SDKSample::Transcode::sealed
  • disableHangUpButton() : SDKSample::CallControl::sealed
  • disableIncomingCallButton() : SDKSample::CallControl::sealed
  • disableInitializeButton() : SDKSample::CallControl::sealed
  • DisableNotificationQueue_Click() : SDKSample::Tiles::sealed
  • DiscardGeometries() : GeometryRealizationSample
  • DiscardThemeSpecificResources() : sealed
  • Disconnect() : CAppWindowProvider , UiaCoreWindowProvider::IDisconnectableProvider
  • DiscoverActiveDownloads() : SDKSample::BackgroundTransfer::sealed
  • DiscoverActiveUploads() : SDKSample::BackgroundTransfer::sealed
  • dismissed : SDKSample::SplashScreen::sealed
  • Dismissed : SDKSample::sealed
  • DismissedEventHandler() : SDKSample::SplashScreen::sealed
  • dispatcher
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CameraOptions::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::PlayTo::sealed
, SDKSample::OrientationSensorCPP::sealed
, ToastsSampleCPP::sealed
, SimpleCommunication::SdkSample
, SDKSample::InclinometerCPP::sealed
  • dispatcherTimer
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::GyrometerCPP::sealed
  • DispatchOperation() : OpQueue< T, TOperation > , CMPEG1Source , OpQueue< T, TOperation > , CMPEG1Source , OpQueue< T, TOperation >
  • DispatchSamples() : CMPEG1Stream
  • Display() : SDKSample::Playlists::sealed
  • Display_Click()
: SDKSample::CalendarSample::sealed
, SDKSample::DateTimeFormatting::sealed
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::NumberFormatting::sealed
, SDKSample::CalendarSample::sealed
, SDKSample::DateTimeFormatting::sealed
  • DisplayCalendarData() : SDKSample::CalendarSample::sealed
  • DisplayCalendarStatistics() : SDKSample::CalendarSample::sealed
  • DisplayCurrentItem() : SDKSample::Syndication::sealed
  • DisplayCurrentReading()
: SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::AccelerometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
  • DisplayDeviceContainer() : SDKSample::DeviceEnumeration::sealed
  • DisplayDeviceInterface() : SDKSample::DeviceEnumeration::sealed
  • DisplayDeviceProperties() : SDKSample::PortableDeviceCPP::sealed
  • DisplayDeviceStatusAsync() : SDKSample::PortableDeviceCPP::sealed
  • DisplayDeviceStatusServiceProperties() : SDKSample::PortableDeviceCPP::sealed
  • DisplayError() : SimpleCommunication::SdkSample
  • DisplayFeed() : SDKSample::Syndication::sealed
  • DisplayFormats() : Clipboard::sealed
  • DisplayImageAsync() : SDKSample::RemovableStorageCPP::sealed
  • DisplayItem() : SDKSample::AtomPub::sealed
  • DisplayLanIdentifierData() : SDKSample::NetworkInformationApi::sealed
  • DisplayLink_Click() : SDKSample::StoreSample::sealed
  • DisplayMetrics() : SDKSample::AnimationMetrics::sealed
  • DisplayOrientation() : SDKSample::SimpleOrientationSensorCPP::sealed
  • DisplayOutput() : SDKSample::ApplicationDataSample::sealed
  • DisplayProperties_LogicalDpiChanged()
: RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, LockScreenAppsCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, SDKSample::Scaling::sealed
, ToastsSampleCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, CredentialPickerCPP::sealed
, SDKSample::Scaling::sealed
  • DisplayProperties_OrientationChanged() : SDKSample::MediaCapture::sealed
  • DisplayResult() : SDKSample::MainPage
  • displaySizeInches : STEREO_PARAMETERS
  • DisplayStatus()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
, SimpleCommunication::SdkSample
, SDKSample::MediaButtons::sealed
  • DisplayTextResult() : SDKSample::HttpClientSample::sealed
  • DisplayToDesignHeight() : Document
  • DisplayToDesignWidth() : Document
  • dmrImage_ImageFailed_1() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_CurrentStateChanged() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_DownloadProgressChanged_1() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_MediaEnded() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_MediaFailed() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_MediaOpened() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_RateChanged() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_SeekCompleted() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_VolumeChanged() : SDKSample::PlayToreceiver::sealed
  • dmsRefreshButton_Click() : SDKSample::MediaServerClient::sealed
  • dmsSelect_SelectionChanged() : SDKSample::MediaServerClient::sealed
  • DoCleanup()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • DoCrop() : Hilo::sealed
  • Document : SDKSample::FileExtensions
  • DocumentLoaded() : Magazine::sealed
  • DoNavigation()
: LanguageFontCPP::sealed
, RawNotificationsSampleCPP::sealed
, SDKTemplateCS::MainPage
, PrintSample::sealed
, CredentialPickerCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, AssociationLaunching::sealed
, EdgeGestureSample::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, ToastsSampleCPP::sealed
  • DoPause() : CMPEG1Source
  • DoScenario() : SDKSample::Compression::sealed
  • DoSetRate() : CMPEG1Source
  • DoSomething_Click()
: SDKSample::UserAndCustomControls::sealed
, SDKSample::TextEditing::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::HighContrast::sealed
, SDKSample::TextDisplay::sealed
  • DoStart() : CMPEG1Source
  • DoStop() : CMPEG1Source
  • DownloadAsync() : Web::HttpRequest
  • DownloadProgress() : SDKSample::BackgroundTransfer::sealed
  • dpi : RippleEffect , FPSCounter , Renderer
  • DPI96 : PrintSample::sealed
  • Draw() : GeometryRealization , PageRendererContext , ContentImageSource , Element , BasicSprites::SpriteBatch , Rectangle , TextFrame , BasicSprites::SpriteBatch , ImageFrame , sealed , BasicSprites::SpriteBatch , List< T > , PaperFragment , InlineImage , BasicSprites::SpriteBatch , Resource
  • Draw3DPerspectiveProperty() : D2D3DTransformsRenderer
  • DrawAtlasText() : FPSCounter
  • DrawBackground() : sealed
  • DrawBackward() : Program
  • DrawBitmap() : Image
  • DrawButtonText() : SimpleController
  • DrawChildren() : Element
  • DrawExtrudedText() : ExtrudedTextRenderer
  • DrawGlyphRun() : CustomTextRenderer , OutlineRenderer
  • DrawHeader() : SimpleController
  • DrawImageAndEffects() : ImageRenderer
  • DrawingObject() : sealed
  • DrawInk() : InkRenderer
  • DrawInlineObject() : CustomTextRenderer , OutlineRenderer
  • DrawMatrix() : D2D3DTransformsRenderer
  • DrawMessage() : PageRendererContext
  • DrawOverlay() : sealed
  • DrawPaper() : PaperRenderer
  • DrawPattern() : CommandListRenderer
  • DrawPreviewSurface() : PageRenderer
  • DrawQuad() : D3DPostProcessing
  • DrawStrikethrough() : OutlineRenderer , CustomTextRenderer
  • DrawSymbol() : D2D3DTransformsRenderer
  • DrawText() : SimpleController
  • DrawTextLayout() : D2DTextAnimation
  • DrawUnderline() : OutlineRenderer , CustomTextRenderer
  • Duration : NotificationsExtensions::ToastContent::ToastNotificationBase , abstract
  • duration : AnimateLinePosition
  • Duration() : abstract
  • duration : AnimateCirclePosition
  • dwABitMask : DirectX::DDS_PIXELFORMAT
  • dwBBitMask : DirectX::DDS_PIXELFORMAT
  • dwBitRate : MPEG1AudioFrameHeader
  • dwCaps : DirectX::DDS_HEADER
  • dwCaps2 : DirectX::DDS_HEADER
  • dwCaps3 : DirectX::DDS_HEADER
  • dwCaps4 : DirectX::DDS_HEADER
  • dwColorOffset : TGA_EXTENSION
  • dwDepth : DirectX::DDS_HEADER
  • dwDeveloperOffset : TGA_FOOTER
  • dwExtensionOffset : TGA_FOOTER
  • dwFlags : DirectX::DDS_PIXELFORMAT , DirectX::DDS_HEADER
  • dwFourCC : DirectX::DDS_PIXELFORMAT
  • dwGBitMask : DirectX::DDS_PIXELFORMAT
  • dwHeight : DirectX::DDS_HEADER
  • dwKeyColor : TGA_EXTENSION
  • dwMipMapCount : DirectX::DDS_HEADER
  • dwPitchOrLinearSize : DirectX::DDS_HEADER
  • dwRBitMask : DirectX::DDS_PIXELFORMAT
  • dwReserved1 : DirectX::DDS_HEADER
  • dwReserved2 : DirectX::DDS_HEADER
  • dwRGBBitCount : DirectX::DDS_PIXELFORMAT
  • dwriteFactory : TargetTexture
  • dwSamplesPerSec : MPEG1AudioFrameHeader
  • dwScanOffset : TGA_EXTENSION
  • dwSize : DirectX::DDS_PIXELFORMAT , DirectX::DDS_HEADER
  • dwStampOffset : TGA_EXTENSION
  • dwStreamFlags : SDKSample::WASAPIAudio::MFSampleGenerator
  • dwStreamIndex : SDKSample::WASAPIAudio::MFSampleGenerator
  • dwValue : SValue
  • dwWidth : DirectX::DDS_HEADER
  • dxgiFormat : DDS_HEADER_DXT10 , DirectX::DDS_HEADER_DXT10
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- e -

  • e : Hilo::Common::sealed
  • EaseInExponentialAnimation() : EaseInExponentialAnimation< T >
  • EaseInOutExponentialAnimation() : EaseInOutExponentialAnimation< T >
  • EaseOutExponentialAnimation() : EaseOutExponentialAnimation< T >
  • EchoMessage() : DatagramSocketSample::sealed
  • Edge() : AntSystem::Edge
  • EdgeGestureCanceledEventToken : EdgeGestureSample::sealed
  • EdgeGestureCompletedEventToken : EdgeGestureSample::sealed
  • EdgeGestureStartingEventToken : EdgeGestureSample::sealed
  • Edges : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • editUri : SDKSample::sealed
  • EffectIntensityChanged : Postcard::sealed
  • EffectIntensitySliderChanged() : Postcard::sealed
  • EffectsFlyout() : Postcard::sealed
  • EField : DirectX::D3DX_BC6H
  • elapsedTime : HighScoreEntry
  • elasticCollision : CollisionInfo
  • ElementBase() : ElementBase
  • ElementProviderFromPoint() : CAppWindowProvider
  • Emissive : SDKMESH_MATERIAL
  • EmitBlock()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • emphasis : MPEG1AudioFrameHeader
  • Employee() : SDKSample::DataBinding::sealed
  • employeeChanged() : SDKSample::DataBinding::sealed
  • employees : SDKSample::DataBinding::sealed
  • EmptyClipboardButton_Click() : Clipboard::sealed
  • emptyTitle : Hilo::sealed
  • Enable() : Wrapper::sealed
  • EnableButton()
: MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
  • EnableButtons() : SDKSample::Transcode::sealed
  • enableHangUpButton() : SDKSample::CallControl::sealed
  • enableIncomingCallButton() : SDKSample::CallControl::sealed
  • enableInitializeButton() : SDKSample::CallControl::sealed
  • EnableNotificationQueue() : SDKSample::Tiles::sealed
  • EnableNotificationQueue_Click() : SDKSample::Tiles::sealed
  • EnableVideoEffect() : MEPlayer
  • Encode()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • EncodeImageAsync() : Hilo::sealed
  • EncodeParams()
: DirectX::D3DX_BC6H::EncodeParams
, DirectX::D3DX_BC7::EncodeParams
  • Encoder : sealed
  • EncodeRotateImageToStream() : Hilo::sealed
  • end : SimpleCommunication::sealed
  • End() : BasicSprites::SpriteBatch
  • EndCall() : SimpleCommunication::sealed
  • EndCall_Click() : SimpleCommunication::VideoChat
  • EndCallAsync() : SimpleCommunication::VideoChat
  • EndCallButton_Click() : SimpleCommunication::sealed
  • EndGetEvent() : CMPEG1Source , CMPEG1Stream
  • EndOfMPEGStream() : CMPEG1Source
  • EndOfStream() : CMPEG1Stream
  • EndOpen() : CMPEG1Source
  • EndPointsFit() : DirectX::D3DX_BC6H
  • EndPosition() : List< T >
  • endPosition : AnimateLinePosition
  • EndPosition() : List< T >
  • EndRotation() : Hilo::sealed
  • EndStreaming() : CGrayscale , CPolarEffect , CGrayscale
  • EnsureAppWindowProviderCreated() : sealed
  • EnsureControlProviderCreated() : sealed
  • EnsureFragmentProviderCreated() : sealed
  • EnsureMediaExtensionManager() : SDKTemplate::MainPage
  • EnsureUnsnapped() : SDKSample::MainPage
  • EnsureVisible() : Shape
  • Enumerate_Click() : SDKSample::WASAPIAudio::sealed
  • EnumerateAudioDevicesAsync() : SDKSample::WASAPIAudio::sealed
  • EnumerateDeviceContainers() : SDKSample::DeviceEnumeration::sealed
  • EnumerateDeviceInterfaces() : SDKSample::DeviceEnumeration::sealed
  • EnumerateObjects() : SDKSample::PortableDeviceCPP::sealed
  • EnumerateSecondaryTiles_Click() : SecondaryTiles::sealed
  • EnumerateTiles() : SecondaryTiles::sealed
  • EnumerateWebcamsAsync() : SDKSample::MediaCapture::sealed
  • EraseButtonClicked() : Postcard::sealed
  • EraseClicked() : Postcard::sealed
  • error : anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • ErrorMessage : SDKSample::Helpers
  • Evaluate() : AnimateCirclePosition , AnimateLineListPosition , abstract , AnimateLinePosition , abstract , AnimateLinePosition , AnimateCirclePosition
  • EvaluateCommands() : Hilo::sealed
  • EventCallback() : SDKSample::PortableDeviceCPP::EventCallback
  • EventNotify() : MediaEngineNotify
  • EventPrint() : CoreWindowEvents
  • eventRegistrationToken : SDKSample::StoreSample::sealed
  • eventToken : SDKSample::ApplicationResources::sealed
  • exceptionPolicy : Hilo::sealed
  • Execute() : Hilo::sealed
  • Exhaustive() : DirectX::D3DX_BC7
  • ExitApp() : MEPlayer
  • ExpandLongRunningShareSection_Checked() : ShareTarget::sealed
  • ExpandLongRunningShareSection_Unchecked() : ShareTarget::sealed
  • ExpandToEnclosingUnit() : SDKSample::TouchKeyboard::sealed
  • ExpiringProduct() : SDKSample::StoreSample::sealed
  • ExpiringProductRefreshScenario() : SDKSample::StoreSample::sealed
  • Explore() : AntSystem::Ant
  • ExtendedSplash() : SDKSample::SplashScreen::sealed
  • ExtendedSplash_OnResize() : SDKSample::SplashScreen::sealed
  • ExtensionManager : SDKTemplateCS::MainPage
  • ExtractTrianglesFromMesh() : MarbleMaze
  • ExtrudeGeometry() : Extruder
  • ExtrudingSink() : Extruder::ExtrudingSink
  • Eye() : Camera
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- f -

  • F16ToINT() : DirectX::INTColor
  • Face() : Face
  • FadeOut() : TextElement
  • Failed()
: SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • FailureCount : Samples::Devices::Fx2::sealed
  • falToken : SDKSample::MainPage
  • FarClipPlane() : Camera
  • FastForward() : SDKSample::MediaButtons::sealed
  • fBestErr : DirectX::D3DX_BC6H::EncodeParams
  • FEATURE_NAME : SDKTemplate::MainPage , SDKTemplateCS::MainPage
  • feed : SDKSample::sealed
  • FeedData() : SimpleBlogReader::sealed
  • feedData : SimpleBlogReader::sealed
  • FeedDataSource() : SimpleBlogReader::sealed
  • FeedItem() : SimpleBlogReader::sealed
  • feedIterator : SDKSample::AtomPub::sealed
  • feedUri : SDKSample::sealed
  • FetchControllerInput() : AudioController , SimpleController
  • FetchNextRun() : TextAnalysis
  • figureBegin : PointSnapper::PointSnappingSink
  • fileActivationFiles : SDKSample::MainPage
  • FileAdded : SDKSample::Status
  • FileAddFailed : SDKSample::Status
  • FileGroupEmpty : SDKSample::Errors
  • FileGroupLocation : SDKSample::Errors
  • fileID : SDKSample::FilePickerContracts::sealed
  • FileIsCurrentButton_Click() : SDKSample::FilePickerContracts::sealed
  • fileName : Document
  • filename : SuspensionManager
  • FileOpenPicker_PickAppFile() : SDKSample::FilePickerContracts::sealed
  • FileOpenPicker_PickCachedFile() : SDKSample::FilePickerContracts::sealed
  • FileOpenPicker_PickURLFile() : SDKSample::FilePickerContracts::sealed
  • FileOpenPickerPage() : SDKSample::FilePickerContracts::sealed
  • FileOpenPickerPage_SizeChanged() : SDKSample::FilePickerContracts::sealed
  • fileOpenPickerUI : SDKSample::FilePickerContracts::sealed
  • fileOwnerProperty : SDKSample::FileAccess::sealed
  • FileRemoved : SDKSample::Status
  • Files() : SDKSample::ApplicationDataSample::sealed
  • FileSavePicker_FailToSave() : SDKSample::FilePickerContracts::sealed
  • FileSavePicker_SaveToAppStorage() : SDKSample::FilePickerContracts::sealed
  • FileSavePicker_SaveToCachedFile() : SDKSample::FilePickerContracts::sealed
  • FileSavePickerPage() : SDKSample::FilePickerContracts::sealed
  • FileSavePickerPage_SizeChanged() : SDKSample::FilePickerContracts::sealed
  • fileSavePickerUI : SDKSample::FilePickerContracts::sealed
  • FileSizeConverter() : Hilo::sealed
  • FileSystemRepository() : Hilo::FileSystemRepository
  • fileToken : SDKSample::FilePicker::sealed
  • fileToLaunch : AssociationLaunching::sealed
  • fileUpdateRequest : SDKSample::FilePickerContracts::sealed
  • fileUpdateRequestDeferral : SDKSample::FilePickerContracts::sealed
  • Fill() : GeometryRealization
  • fillBrush : CustomTextRenderer
  • FillInPropertiesForFolder() : SDKSample::PortableDeviceCPP::sealed
  • FillInPropertiesForImage() : SDKSample::PortableDeviceCPP::sealed
  • FillSampleBuffer()
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::ToneSampleGenerator
  • FillSelection_SelectionChanged() : SDKSample::Drawing::sealed
  • FinalizeCreateGameDeviceResources() : GameRenderer
  • FinalizeLoadLevel() : Simple3DGame
  • FinalizeLoadLevelResources() : GameRenderer
  • Finally() : SDKSample::Finally
  • finallyClause : SDKSample::Finally
  • Find() : StreamList
  • FindAndHighlightText() : SDKSample::TextEditing::sealed
  • FindAndTransferFirstImageFileFromDevice() : SDKSample::PortableDeviceCPP::sealed
  • FindAttribute() : SDKSample::TouchKeyboard::sealed
  • FindBoxGotFocus() : SDKSample::TextEditing::sealed
  • FindBoxLostFocus() : SDKSample::TextEditing::sealed
  • FindBoxTextChanged() : SDKSample::TextEditing::sealed
  • FindDevice() : SDKSample::CustomDeviceAccess::DeviceList
  • FindEditUri() : SDKSample::AtomPub::sealed
  • FindFrame() : SDKMesh
  • FindInitialCollisions() : Physics
  • FindInList() : CustomDeviceAccess::DeviceList
  • FindNextStartCode() : Parser
  • FindText() : SDKSample::TouchKeyboard::sealed
  • FindWorstInterpenetration() : Collision
  • FinishCaptureAsync() : SDKSample::WASAPIAudio::WASAPICapture
  • FinishMonthAndYearQueries() : Hilo::sealed
  • FinishUnquantize() : DirectX::D3DX_BC6H
  • FireScript_Click() : SDKSample::WebViewControl::sealed
  • First() : SDKSample::DataBinding::sealed
  • firstName : SDKSample::Accessibility::sealed
  • FisheyeRadius() : CPolarEffect
  • FixWAVHeader() : SDKSample::WASAPIAudio::WASAPICapture
  • flags : DDS_PIXELFORMAT , DDS_HEADER , DirectX::ConvertData
  • Flush()
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::ToneSampleGenerator
  • folderQuery : Hilo::sealed
  • FontColorButtonClick() : SDKSample::TextEditing::sealed
  • FontColorButtonLostFocus() : SDKSample::TextEditing::sealed
  • FontFileStream() : FontFileStream
  • FontLoader() : FontLoader
  • Footer_Click()
: SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::FilePickerContracts::sealed
, ContactPicker::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, EdgeGestureSample::sealed
, SDKSample::sealed
, CredentialPickerCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, ToastsSampleCPP::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, AssociationLaunching::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, ShareTarget::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, RawNotificationsSampleCPP::sealed
, LanguageFontCPP::sealed
, ShareTarget::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, MediaExtensionsCPP::sealed
, LockScreenAppsCPP::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKTemplateCS::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SimpleCommunication::sealed
, SDKSample::sealed
, PrintSample::sealed
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, DeviceAppForWebcam::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
  • Force64_1 : SDKMESH_MATERIAL
  • Force64_2 : SDKMESH_MATERIAL
  • Force64_3 : SDKMESH_MATERIAL
  • Force64_4 : SDKMESH_MATERIAL
  • Force64_5 : SDKMESH_MATERIAL
  • Force64_6 : SDKMESH_MATERIAL
  • format
: WICTranslate
, DirectX::ConvertData
, DirectX::LegacyDDS
, DirectX::Image
, DirectX::TexMetadata
  • FormatError() : SimpleCommunication::SdkSample
  • forwardEvents : SimpleCommunication::Common::CaptureDevice
  • fourCC : DDS_PIXELFORMAT
  • FrameData() : FrameData
  • FrameDataOffset : SDKMESH_HEADER
  • FrameInfluenceOffset : SDKMESH_MESH
  • FrameInfluences : SDKMESH_MESH
  • FrameName : SDKANIMATION_FRAME_DATA
  • FrameProcessing() : FrameProcessing
  • frameRate : MPEG1VideoSeqHeader
  • FrameStep() : MEPlayer
  • FrameTransformType : SDKANIMATION_FILE_HEADER
  • FrameworkView() : sealed
  • FrameworkViewSource() : sealed
  • FreeStreamingResources() : CDecoder
  • frequency : RippleEffect
  • Frequency : MediaStreamSource::PcmSource , SDKSample::WASAPIAudio::DEVICEPROPS
  • FromId() : Samples::Devices::Fx2::sealed
  • Front() : List< T >
  • FrontPosition() : List< T >
  • FullProduct_Click() : SDKSample::StoreSample::sealed
  • Fx2Device : CustomDeviceAccess::DeviceList , Samples::Devices::Fx2::sealed
  • Fx2Devices : CustomDeviceAccess::DeviceList
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- g -

  • g : Vector2< T > , Vector3< T > , DirectX::LDRColorA , AmpPixel , DirectX::HDRColorA , Vector4< T > , DirectX::INTColor , AmpPixel
  • GameActive() : Simple3DGame
  • GameCamera() : Simple3DGame
  • GameInfoOverlayLowerRight() : GameRenderer
  • GameInfoOverlayUpperLeft() : GameRenderer
  • GBitMask : DDS_PIXELFORMAT
  • Generate() : Hilo::ThumbnailGenerator
  • GenerateMesh() : WaveEffect
  • GenerateOpacityMask() : GeometryRealization
  • GeneratePaletteQuantized()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • GeneratePaletteUnquantized() : DirectX::D3DX_BC6H
  • GeneratePaperBitmap() : PaperFragment
  • GeneratePersonNamesSource() : SDKSample::Accessibility::sealed
  • GeneratePolarLookup() : CPolarEffect
  • GenerateResults() : TextAnalysis
  • GenerateSampleBuffer() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • GenerateSampleStream() : SDKSample::HttpClientSample::sealed
  • GenerateSineSamples() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • GenerateTextOutline() : ExtrudedTextRenderer
  • Generator() : SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • GeographicRegionScenario() : SDKSample::GlobalizationPreferencesSample::sealed
  • geolocator : SDKSample::GeolocationCPP::sealed
  • geolocTask : SDKSample::GeolocationCPP::sealed
  • geometry : sealed
  • GeometryRealization() : GeometryRealization
  • GeometryRealizationFactory() : GeometryRealizationFactory
  • geopositionTaskTokenSource : BackgroundTask::sealed , SDKSample::GeolocationCPP::sealed
  • Get() : ScopedObject< T >
  • get_BoundingRectangle() : CAppWindowProvider
  • get_DisplayMessage() : PrintSample::InvalidPageException
  • get_FragmentRoot() : CAppWindowProvider
  • get_HostRawElementProvider() : CAppWindowProvider
  • get_LookPoint() : LonLatController
  • get_Position() : LonLatController
  • get_ProviderOptions() : CAppWindowProvider
  • GetAcceleration() : Physics
  • GetAccountPicture() : AccountPictureName::sealed
  • GetAddress() : SDKSample::DataReaderWriter::sealed
  • GetAdjacencyIndexBuffer() : SDKMesh
  • GetAmplitude() : RippleEffect
  • GetAnimationKeyFromTime() : SDKMesh
  • GetAnimationProperties() : SDKMesh
  • GetAppWindowProvider() : UiaCoreWindowProvider::ITriColorControlInternal , sealed
  • GetAqsFormattedDate() : Hilo::CalendarExtensions
  • GetAsync() : Web::HttpRequest
  • GetAttributes() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetAttributeValue() : SDKSample::TouchKeyboard::sealed
  • GetAutomationControlTypeCore() : SDKSample::Accessibility::sealed
  • GetBack() : List< T >
  • GetBackgroundTaskStatus() : SDKSample::BackgroundTask::BackgroundTaskSample
  • GetBarGraphDisplayAsync() : Samples::Devices::Fx2::sealed
  • GetBit() : DirectX::CBits< SizeInBytes >
  • GetBits() : DirectX::CBits< SizeInBytes >
  • GetBoundingRectangles() : SDKSample::TouchKeyboard::sealed
  • GetBounds() : ElementBase
  • GetBreakConditions() : InlineImage
  • GetBufferFramesPerPeriod() : SDKSample::WASAPIAudio::WASAPIRenderer
  • GetBufferFromString() : SDKSample::FileAccess::sealed
  • GetBufferLength() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • GetBufferPointer() : DirectX::Blob
  • GetBufferSize() : DirectX::Blob
  • GetCalendar() : Hilo::CalendarExtensions
  • GetCenter() : RippleEffect
  • GetCharacteristics() : CMPEG1Source
  • GetChildren() : SDKSample::TouchKeyboard::sealed
  • GetClassNameCore()
: SDKSample::TouchKeyboard::sealed
, SDKSample::Accessibility::sealed
  • GetClient() : SDKSample::sealed
  • GetCollectionCount() : SDKSample::FlipViewData::sealed
  • GetCollisionEngine() : Physics
  • GetCollisionInfo() : Physics
  • GetColor() : sealed
  • GetCompletionEvent() : HttpRequestStringCallback
  • GetConnectionCostInfo() : SDKSample::NetworkInformationApi::sealed
  • GetConnectionProfile() : SDKSample::NetworkInformationApi::sealed
  • GetContent()
: NotificationsExtensions::TileContent::TileWideBase
, NotificationsExtensions::ToastContent::ToastNotificationBase
, NotificationsExtensions::NotificationBase
, SDKSample::sealed
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::NotificationBase
, NotificationsExtensions::TileContent::TileSquareBase
, NotificationsExtensions::TileContent::TileWideBase
, NotificationsExtensions::ToastContent::ToastNotificationBase
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::NotificationBase
, NotificationsExtensions::TileContent::TileSquareBase
  • GetContentFromDeviceAsync() : SDKSample::PortableDeviceCPP::sealed
  • GetContentRoot() : Document
  • GetCostBasedSuggestions() : SDKSample::NetworkInformationApi::sealed
  • GetCount() : List< T > , StreamList , List< T > , StreamList , List< T >
  • GetCurrentFontFile() : FontLoader
  • GetCurrentNode() : TreeIterator< T >
  • GetCurrentPhotoRotation() : SDKSample::MediaCapture::sealed
  • GetCurrentPolicy() : Hilo::ExceptionPolicyFactory
  • GetCurrentTransform() : CustomTextRenderer , OutlineRenderer
  • GetCustomProfile() : SDKSample::Transcode::sealed
  • GetCustomProperty() : Hilo::Common::BindableBase
  • GetD2DContext() : UserInterface
  • GetD2DDeviceContext() : Renderer
  • GetData() : VideoBufferLock
  • GetDataPlanStatusInfo() : SDKSample::NetworkInformationApi::sealed
  • GetDateQuery() : Hilo::ImageNavigationData
  • GetDateTimeForYearFolderAsync() : Hilo::FileSystemRepository
  • GetDecoderInfo() : Hilo::sealed
  • GetDependencies_Click() : SDKSample::PackageSample::sealed
  • GetDesign() : Story
  • GetDeviceDescription() : sealed
  • GetDeviceSelector() : Samples::Devices::Fx2::sealed
  • GetDeviceStateEvent()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • GetDiagnosticAsync() : MediaStreamSource::PcmSource
  • GetDisplayHeight() : Renderer
  • GetDisplayNameButton_Click() : AccountPictureName::sealed
  • GetDisplaySize() : Renderer
  • GetDisplayWidth() : Renderer
  • GetDistance() : Utils
  • GetDNSDomain_Click() : SDKSample::UserDomainName::sealed
  • GetDomainName() : SDKSample::UserDomainName::sealed
  • GetDspSetting() : Wrapper::sealed
  • GetDuration() : Animation< T > , MEPlayer
  • GetDWriteFactory() : Document , UserInterface
  • GetDXGIDevice() : Renderer
  • GetEditUri() : SDKSample::sealed
  • GetElapsedTime() : StopwatchTimer
  • GetElementRect() : LockScreenAppsCPP::sealed
  • GetEmbeddedFragmentRoots() : CAppWindowProvider
  • GetEnclosingElement() : SDKSample::TouchKeyboard::sealed
  • GetEnd() : Animation< T >
  • GetEntries() : HighScoreTable
  • GetEnumerator() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • GetError() : Web::Details::HttpRequestBuffersCallback
  • GetEvent() : CMPEG1Source , CMPEG1Stream
  • GetExclusionWith() : PaperFragment
  • GetExtension() : BasicLoader
  • GetFeed_Click()
: SDKSample::AtomPub::sealed
, SDKSample::Syndication::sealed
  • GetFeedAsync() : SimpleBlogReader::sealed
  • GetFeedData() : SimpleBlogReader::sealed
  • GetFeedItem() : SimpleBlogReader::sealed
  • GetFileDate() : Hilo::ImageNavigationData
  • GetFileNameFromFileSavePickerAsync() : Hilo::ImageBase
  • GetFilePath() : Hilo::ImageNavigationData
  • GetFilesAndFolderButton_Click() : SDKSample::FolderEnumeration::sealed
  • GetFilesButton_Click() : SDKSample::FolderEnumeration::sealed
  • GetFileSize() : FontFileStream , RandomAccessReader
  • GetFirstChild() : Element
  • GetFirstImageFromStorageAsync() : SDKSample::RemovableStorageCPP::sealed
  • GetFirstNameButton_Click() : AccountPictureName::sealed
  • GetFocus() : CAppWindowProvider
  • GetFolderPhotoCountAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetFontCollection() : Document
  • GetFormattedTime() : StopwatchTimer
  • GetForYearAndMonth() : Hilo::PhotoCache
  • GetFrame() : SDKMesh
  • GetFrequency() : RippleEffect
  • GetFront() : List< T >
  • GetGeolocation() : SDKSample::GeolocationCPP::sealed
  • GetGeometry() : OutlineRenderer
  • GetGeopositionAsync() : SDKSample::GeolocationCPP::sealed
  • GetGreenRect() : sealed
  • GetImage() : DirectX::ScratchImage
  • GetImage_Click() : SDKSample::RemovableStorageCPP::sealed
  • GetImageCount() : DirectX::ScratchImage
  • GetImagePhotoAsync() : Hilo::sealed
  • GetImages() : DirectX::ScratchImage
  • GetImageSize() : ContentImageSource
  • GetImageSource() : ContentImageSource
  • GetIndex()
: DirectX::BC4_UNORM
, DirectX::BC4_SNORM
  • GetIndexBuffer() : SDKMesh
  • GetIndexBufferAt() : SDKMesh
  • GetIndexBufferFormat() : SDKMesh
  • GetIndexDescription() : SDKSample::sealed
  • GetIndexedProperty() : Hilo::Common::BindableBase
  • GetIndexType() : SDKMesh
  • GetInfluenceMatrix() : SDKMesh
  • GetInputAvailableType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInputCurrentType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInputStatus() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInputStreamAttributes() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInputStreamInfo() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInstalledLocation_Click() : SDKSample::PackageSample::sealed
  • GetInstance() : UserInterface
  • GetIntersectionWith() : PaperFragment
  • GetItem() : List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE >
  • GetItemAt() : SDKSample::FlipViewData::sealed
  • GetItemPos() : List< T >
  • GetLargeImageButton_Click() : AccountPictureName::sealed
  • GetLastNameButton_Click() : AccountPictureName::sealed
  • GetLastWriteTime() : FontFileStream
  • GetLength() : Text
  • GetLocaleName() : TextAnalysis
  • GetLocalizedAbbreviatedMonthName() : Hilo::CalendarExtensions
  • GetLocalizedControlTypeCore() : SDKSample::Accessibility::sealed
  • GetLocalizedMonthAndYear() : Hilo::CalendarExtensions
  • GetLocalizedYear() : Hilo::CalendarExtensions
  • GetLocation() : Document
  • GetLookPoint() : MoveLookController
  • GetMaterial() : SDKMesh
  • GetMaxStreamLengthInBytes() : MediaStreamer
  • GetMediaSource() : CMPEG1Stream
  • GetMergeWith() : PaperFragment
  • GetMesh() : SDKMesh
  • GetMeshBoundingBoxCenter() : SDKMesh
  • GetMeshBoundingBoxExtents() : SDKMesh
  • GetMeshInfluenceMatrix() : SDKMesh
  • GetMeshPath() : SDKMesh
  • GetMessageFormatNoRef() : PageRenderer
  • GetMetadata() : DirectX::ScratchImage
  • GetMetrics() : InlineImage
  • GetMFSample() : SDKSample::WASAPIAudio::WASAPIRenderer
  • GetMinDPI() : SDKSample::Scaling::sealed
  • GetMinResolution() : SDKSample::Scaling::sealed
  • GetMonthGroupedPhotosWithCacheAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetName() : Element
  • GetNeighbourArea() : FrameProcessing
  • GetNetworkSecuritySettingsInfo() : SDKSample::NetworkInformationApi::sealed
  • GetNextBuffer() : MediaStreamer
  • GetNextSibling() : Element
  • GetNonce() : SDKSample::CryptoWinRT::sealed
  • GetNormal() : Extruder::ExtrudingSink
  • GetNumberOfMonthsInYear() : Hilo::CalendarExtensions
  • GetNumberSubstitution() : TextAnalysis
  • GetNumericYear() : Hilo::CalendarExtensions
  • GetNumFrames() : SDKMesh
  • GetNumIndexBuffers() : SDKMesh
  • GetNumIndices() : SDKMesh
  • GetNumInfluences() : SDKMesh
  • GetNumMaterials() : SDKMesh
  • GetNumMeshes() : SDKMesh
  • GetNumSubsets() : SDKMesh
  • GetNumVertexBuffers() : SDKMesh
  • GetNumVertices() : SDKMesh
  • GetObjectDescription() : sealed
  • GetOpacity() : Element , Layer , Rectangle , TextFrame
  • GetOpenWithPosition() : AssociationLaunching::sealed
  • GetOriginalWicBitmapSourceNoRef() : PageRenderer
  • GetOutputAvailableType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputCurrentType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputStatus() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputStreamAttributes() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputStreamInfo() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputWaveFormatEx() : MediaReader , MediaStreamer , MediaReader , MediaStreamer
  • GetOutstandingBufferResources() : SDKMesh
  • GetOutstandingResources() : SDKMesh
  • GetOverhangMetrics() : InlineImage
  • GetPackage_Click() : SDKSample::PackageSample::sealed
  • GetPagesInRange() : PrintSample::sealed
  • GetPageSize() : Design , Document
  • GetParameters() : AsyncCallback< T >
  • GetParent() : Element
  • GetPatternCore()
: SDKSample::TouchKeyboard::sealed
, SDKSample::Accessibility::sealed
  • GetPatternProvider() : CAppWindowProvider
  • GetPhase() : RippleEffect
  • GetPhotoDataForMonthGroup()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetPhotoForYearAndMonth() : Hilo::sealed
  • GetPhotosForDateRangeQueryAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetPhotosForPictureHubGroupAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetPhotoStorageFilesAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetPixel() : FrameProcessing
  • GetPixels() : DirectX::ScratchImage
  • GetPixelsPerDip() : CustomTextRenderer , OutlineRenderer
  • GetPixelsSize() : DirectX::ScratchImage
  • GetPlaceHolderImage() : SDKSample::MainPage
  • GetPlaybackPosition() : MEPlayer
  • GetPolygon() : Shape
  • GetPosition() : Physics , PaperFragment , MoveLookController , RandomAccessReader
  • GetPresentationDescriptor() : StartOp
  • GetPresetProfile() : SDKSample::Transcode::sealed
  • GetPreviewPageCollection() : CDocumentSource
  • GetPreviousPosition() : Physics
  • GetPrimitiveType() : SDKMesh
  • GetPrincipalName() : SDKSample::UserDomainName::sealed
  • GetPrincipalName_Click() : SDKSample::UserDomainName::sealed
  • GetPrintPreviewPage()
: PrintSample::sealed
, PrintSample::BasePrintPage
  • GetProjectionMatrix() : BasicCamera , Camera , BasicCamera
  • GetPropertyDisplayValue() : SDKSample::FolderEnumeration::sealed
  • GetPropertyValue() : CAppWindowProvider
  • GetRadius() : Physics
  • GetRate() : SetRateOp , CMPEG1Source
  • GetRawIndicesAt() : SDKMesh
  • GetRawVerticesAt() : SDKMesh
  • GetReasonPhrase()
: Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
  • GetRedRect() : sealed
  • GetRegisteredTask() : SDKSample::SDKTemplate::sealed
  • GetRenderer() : Document
  • GetRoomDimensions() : Physics
  • GetRoomSize() : Physics
  • GetRuntimeId() : CAppWindowProvider
  • GetSampleAsync() : MediaStreamSource::PcmSource
  • GetSelected() : TextButton
  • GetService() : CMPEG1Source
  • GetShareContent()
: SDKSample::ShareSource::sealed
, SDKSample::Common::SharePage
, SDKSample::ShareSource::sealed
  • GetSinglePhotoAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetSIPUri() : SDKSample::UserDomainName::sealed
  • GetSize() : Element
  • GetSkewX() : WaveEffect
  • GetSkewY() : WaveEffect
  • GetSmallImageButton_Click() : AccountPictureName::sealed
  • GetSoundCount() : XAudio2SoundPlayer
  • GetSoundData() : SoundFileReader
  • GetSoundFormat() : SoundFileReader
  • GetSpread() : RippleEffect
  • GetStart() : Animation< T >
  • GetState()
: Samples::Devices::Repeater
, SDKSample::WASAPIAudio::sealed
  • GetStateFileDate() : Hilo::sealed
  • GetStateFilePath() : Hilo::sealed
  • GetStateQuery() : Hilo::sealed
  • GetStatusCode()
: HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
  • GetStatusString() : SDKSample::ThreadPool::ThreadPoolSample
  • GetStereoEnabledStatus() : abstract
  • GetStereoExaggeration() : StereoSimpleD3D
  • GetStreamCount() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CDecoder , CPolarEffect , CInvert
  • GetStreamDescriptor() : CMPEG1Stream
  • GetStreamIDs() : CGrayscale , CInvert , CDecoder , CPolarEffect , CInvert , CDecoder , CPolarEffect , CGrayscale
  • GetStreamLimits() : CInvert , CDecoder , CPolarEffect , CInvert , CDecoder , CPolarEffect , CGrayscale
  • GetStreamWithFailCheck() : Hilo::ImageBase
  • GetStride() : VideoBufferLock
  • GetString()
: Hilo::IResourceLoader
, Hilo::sealed
  • GetStringRepresentation() : Hilo::Common::BindableBase
  • GetSubset() : SDKMesh
  • GetSuggestions() : SDKSample::SearchContract::sealed
  • GetSurfaceNormal() : Contact
  • GetSwapChainBackgroundPanel() : Simple3DGameXaml::sealed
  • GetSyndicationItem() : SDKSample::sealed
  • GetSystemHeader() : Parser
  • GetTask() : ReadStreamTask
  • GetText() : Text , SDKSample::TouchKeyboard::sealed
  • GetTextAtPosition() : TextAnalysis
  • GetTextBeforePosition() : TextAnalysis
  • GetTextFormat() : TextStyle
  • GetTextFormatNoRef() : PageRenderer
  • GetTextLayout() : Text
  • GetTextStyle() : TextElement
  • GetThumbnailButton_Click() : SDKSample::FileThumbnails::sealed
  • GetTileNotification() : Hilo::WideFiveImageTile
  • GetTimeStampedMessage()
: SDKSample::MediaButtons::sealed
, SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • GetTitle() : SDKSample::sealed
  • GetTitleHeightInDips() : SampleOverlay
  • GetToneSample() : SDKSample::WASAPIAudio::WASAPIRenderer
  • GetTour() : AntSystem::Ant
  • GetTriColorControlProvider() : UiaCoreWindowProvider::ITriColorControlInternal , sealed
  • GetTriColorFragmentProvider() : UiaCoreWindowProvider::ITriColorControlInternal , sealed
  • GetUri_Click() : SDKSample::UserDomainName::sealed
  • GetUserDisplayName() : AccountPictureName::sealed
  • GetUserFirstAndLastName() : AccountPictureName::sealed
  • GetValue() : Animation< T >
  • GetVelocity() : Physics
  • GetVertexBuffer() : SDKMesh
  • GetVertexBufferAt() : SDKMesh
  • GetVertexStride() : SDKMesh
  • GetVerticalGlyphOrientation() : TextAnalysis
  • GetVideoButton_Click() : AccountPictureName::sealed
  • GetView() : SDKSample::DataBinding::sealed
  • GetWaveOffset() : WaveEffect
  • GetWicBitmapSourceWithEmbeddedColorContextNoRef() : PageRenderer
  • GetWicColorContextNoRef() : PageRenderer
  • GetWICImagingFactory() : Renderer
  • GetWorldMatrix() : SDKMesh
  • GetWriter() : DatagramSocketSample::sealed
  • GetXml()
: NotificationsExtensions::NotificationBase
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::NotificationBase
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::NotificationBase
  • GetYearGroupedMonthsAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetYellowRect() : sealed
  • GiveControlFocus() : SDKSample::Accessibility::sealed
  • Globalization() : SDKSample::Tiles::sealed
  • GlobalPage() : AppBarControl::sealed
  • Glyph : NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
  • glyphCount : TextAnalysis::Run
  • glyphOrientation : TextAnalysis::Run
  • glyphStart : TextAnalysis::Run
  • glyphThumbnail : SDKSample::DeviceEnumeration::sealed
  • Go_Click()
: SDKSample::WebViewControl::sealed
, SDKSample::ELS::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::ELS::sealed
, SDKSample::HighContrast::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::ScrollViewerCPP::sealed
  • GoBack()
: SDKSample::Common::LayoutAwarePage
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • GoForward()
: Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • GoHome()
: SDKTemplate::Common::LayoutAwarePage
, Hilo::ViewModelBase
  • GotFocusHandler() : Postcard::sealed
  • GoToPage() : Hilo::ViewModelBase
  • Green : sealed
  • GroupByHelper() : SDKSample::FolderEnumeration::sealed
  • GroupByMonthButton_Click() : SDKSample::FolderEnumeration::sealed
  • GroupByRatingButton_Click() : SDKSample::FolderEnumeration::sealed
  • GroupByTagButton_Click() : SDKSample::FolderEnumeration::sealed
  • GW : DirectX::D3DX_BC6H
  • GX : DirectX::D3DX_BC6H
  • GY : DirectX::D3DX_BC6H
  • gyrometer : SDKSample::GyrometerCPP::sealed
  • GZ : DirectX::D3DX_BC6H
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- h -

  • h : DirectX::Rect
  • HadLoadingError() : SDKMesh
  • HandleClipboardChanged() : Clipboard::sealed
  • HandleCollisions() : Physics
  • HandleDeviceLost() : abstract , Renderer , abstract , DWriteInlineObject , abstract , GameRenderer , abstract , MarbleMaze , abstract , DirectXFractal , abstract , D3DPostProcessing , abstract , D2DLightingEffectsRenderer , abstract , GameRenderer , abstract
  • HandleDownloadAsync() : SDKSample::BackgroundTransfer::sealed
  • HandleException()
: Hilo::DebugLoggingExceptionPolicy
, Hilo::ExceptionPolicy
, SDKSample::WebSocket::sealed
  • HandleFileNotFoundException() : SDKSample::MainPage
  • HandleManipulationUpdated() : D2DInterpolationModes
  • HandlePointerDoubleTapped() : CommandListRenderer
  • HandlePointerPressed() : D2DInterpolationModes
  • HandleUploadAsync() : SDKSample::BackgroundTransfer::sealed
  • HandleViewManipulation() : DirectXFractal
  • HasElements() : SDKSample::sealed
  • HasEngineExperiencedCriticalError() : Audio
  • HasFocus() : UiaCoreWindowProvider::ITriColorControlInternal
  • HasKey() : SDKSample::DataBinding::sealed
  • HasMoreItemsOverride() : SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • HasPacket() : Parser
  • HasPendingOutput() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CDecoder , CPolarEffect
  • HasPhotosInRangeAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • HasSystemHeader() : Parser
  • HasTextFormatChanged() : TextStyle
  • HDRColorA() : DirectX::HDRColorA
  • header : MPEG1VideoSeqHeader
  • HeaderSize : SDKMESH_HEADER
  • height : DDS_HEADER , DirectX::TexMetadata , DirectX::Image , MPEG1VideoSeqHeader
  • HexDump() : SDKSample::DataReaderWriter::sealed
  • HiddenFrame
: AccountPictureName::sealed
, StreamSocketSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, Clipboard::sealed
, ContactPicker::sealed
, SDKTemplate::MainPage
, SDKSample::FilePickerContracts::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
, DeviceAppForWebcam::sealed
, AppBarControl::sealed
  • hiddenFrame : SecondaryTiles::sealed
  • Hide() : Postcard::sealed
  • HideGameInfoOverlay() : Simple3DGameXaml::sealed , DirectXApp , GameInfoOverlay , Simple3DGameXaml::sealed
  • HideImageAndVideoControls() : AccountPictureName::sealed
  • HideSnapped() : Simple3DGameXaml::sealed , DirectXApp , Simple3DGameXaml::sealed
  • highLatency : SimpleCommunication::sealed
  • HighPriority() : SDKSample::ApplicationDataSample::sealed
  • HighScore() : Simple3DGame
  • HighScoreTable() : HighScoreTable
  • Hit() : GameObject
  • HitMaterial() : GameObject
  • HitSound() : GameObject
  • HitTest() : sealed , PaperFragment , UserInterface
  • HitTestFragmentsWithPosition() : PaperRenderer
  • HitTestWithGeometry() : PaperFragment
  • HitTime() : GameObject
  • hnsBufferDuration : SDKSample::WASAPIAudio::DEVICEPROPS
  • Home_Click() : SDKSample::WebViewControl::sealed
  • HomeEmail : ContactPicker::sealed::SampleContact
  • HomeGroupAdvancedSearch() : SDKSample::HomeGroup::sealed
  • HomeGroupPicker() : SDKSample::HomeGroup::sealed
  • HomeGroupVideoStream() : SDKSample::HomeGroup::sealed
  • HomePhone : ContactPicker::sealed::SampleContact
  • horizontal : Alignment
  • horizontalResolution : SimpleCommunication::sealed::StreamFilteringCriteria
  • hostName : DatagramSocketSample::sealed
  • hr : SDKSample::WASAPIAudio::sealed
  • HRESULT() : IMft0Vtbl
  • hsbvCombo_SelectionChanged_1() : SDKSample::ScrollViewerCPP::sealed
  • hsmCombo_SelectionChanged_1() : SDKSample::ScrollViewerCPP::sealed
  • htmlDescription : Clipboard::sealed
  • HttpRequest() : Web::HttpRequest
  • httpRequest : SDKSample::CertificateEnrollment::sealed
  • HttpRequest() : Web::HttpRequest
  • httpRequest : SDKSample::HttpClientSample::sealed , SDKSample::SearchContract::sealed
  • HttpRequest() : Web::HttpRequest
  • httpRequest : SDKSample::MicrosoftAccount::sealed
  • HttpRequest::PostAsync() : Web::HttpRequest
  • HttpRequestBuffersCallback() : Web::Details::HttpRequestBuffersCallback
  • HttpRequestStringCallback() : HttpRequestStringCallback
  • HttpTime : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • Hud() : GameRenderer
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- i -

  • Id : ContactPicker::sealed::SampleContact , CustomDeviceAccess::DeviceListEntry
  • IFACEMETHOD_() : CustomTextRenderer , ComBase< InterfaceChain > , CustomTextRenderer , ComBase< InterfaceChain >
  • IFACEMETHODIMP_() : RippleEffect , WaveEffect , TextAnalysis , RippleEffect
  • Image
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileWideSmallImageAndText04
, NotificationsExtensions::TileContent::TileWideSmallImageAndText05
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
, NotificationsExtensions::ToastContent::ToastImageAndText01
, NotificationsExtensions::ToastContent::ToastImageAndText02
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::ToastContent::ToastImageAndText03
, NotificationsExtensions::ToastContent::ToastImageAndText04
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
, SDKSample::PlayToreceiver::sealed
, NotificationsExtensions::TileContent::TileWideImage
, NotificationsExtensions::TileContent::TileWideImageAndText01
, NotificationsExtensions::TileContent::TileWideImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImage01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImage03
, NotificationsExtensions::TileContent::TileWidePeekImage04
, NotificationsExtensions::TileContent::TileWidePeekImageAndText01
, SDKSample::FileExtensions
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText01
, NotificationsExtensions::TileContent::TileSquareImage
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText03
  • image100 : SDKSample::Scaling::sealed
  • image140 : SDKSample::Scaling::sealed
  • image180 : SDKSample::Scaling::sealed
  • ImageBrowserView() : Hilo::sealed
  • imageFile : SDKSample::ShareSource::sealed
  • ImageFile() : ImageFile
  • ImageMain
: NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImage05
, NotificationsExtensions::TileContent::TileWidePeekImage06
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • ImageNavigationData() : Hilo::ImageNavigationData
  • ImageProtocols() : SDKSample::Tiles::sealed
  • imageRecd : SDKSample::PlayToreceiver::sealed
  • imageRelativePath : SDKSample::Tiles::sealed
  • Images : NotificationsExtensions::NotificationBase
  • ImageSecondary
: NotificationsExtensions::TileContent::TileWidePeekImage05
, NotificationsExtensions::TileContent::TileWidePeekImage06
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • ImageSmallColumn1Row1
: NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • ImageSmallColumn1Row2
: NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • ImageSmallColumn2Row1
: NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • ImageSmallColumn2Row2
: NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • ImageSourceDrawHelper() : ContentImageSource::ImageSourceDrawHelper
  • ImageView() : Hilo::sealed
  • ImageWithLabelControl() : SDKSample::UserAndCustomControls::sealed
  • imgSrc : Clipboard::sealed
  • imgStreamRef : Clipboard::sealed
  • ImplData::ImplData() : XAudio2SoundPlayer::ImplData
  • ImportPfx_Click() : SDKSample::CertificateEnrollment::sealed
  • InAppPurchase() : SDKSample::StoreSample::sealed
  • InAppPurchaseRefreshScenario() : SDKSample::StoreSample::sealed
  • inclinometer : SDKSample::InclinometerCPP::sealed
  • IncomingConnectionArrived : SimpleCommunication::Common::CaptureDevice
  • Incomingconnectionevent : SimpleCommunication::sealed
  • Increment_Click() : SDKSample::ApplicationDataSample::sealed
  • IncrementHighPriority_Click() : SDKSample::ApplicationDataSample::sealed
  • index : SDKSample::sealed
  • IndexBuffer : SDKMESH_INDEX_BUFFER_HEADER , SDKMESH_MESH
  • IndexCount : SDKMESH_SUBSET
  • IndexStart : SDKMESH_SUBSET
  • IndexStreamHeadersOffset : SDKMESH_HEADER
  • IndexType : SDKMESH_INDEX_BUFFER_HEADER
  • indices : DirectX::BC4_UNORM , DirectX::BC4_SNORM
  • InfoOverlay() : GameRenderer
  • Init() : SecondaryTiles::sealed
  • Initalize() : Buffer
  • InitDeviceWatcher()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • InitialisePlayToReceiver() : SDKSample::PlayToreceiver::sealed
  • Initialize() : SampleOverlay , TextButton , HighScoreTable , D2DEffectsHelloWorld , UserInterface , abstract , CoreWindowEvents , abstract , SampleOverlay , DirectXApp , CommandListRenderer , abstract , MoveLookController , abstract , SampleOverlay , DirectXApp , SampleOverlay , abstract , SampleOverlay , CompositeModes , DirectXApp , abstract , SampleOverlay , SDKSample::MainPage , SampleOverlay , Hilo::sealed , ConvolveMatrixEffect , Hilo::sealed , abstract , sealed , abstract , SampleOverlay , sealed , abstract , sealed , abstract , SampleOverlay , Program , SampleOverlay , abstract , sealed , RippleEffect , MEPlayer , VideoView , SampleOverlay , CCopyModule , CInvertModule , abstract , CCopyModule , CInvertModule , SampleOverlay , SimpleCommunication::sealed , WaveEffect , CAppWindowProvider , abstract , D2DEffectsOnPrimitives , UiaCoreWindowProvider::IAppWindowProvider , UiaCoreWindowProvider::ITriColorControlProvider , abstract , UiaCoreWindowProvider::ITriColorFragmentProvider , sealed , SampleOverlay , SDKSample::WASAPIAudio::MFSampleGenerator , SDKTemplate::DeviceAppPage , abstract , DeviceAppForWebcam::sealed , Wrapper::sealed , FPSCounter , abstract , Audio , GeometryRealization , Cylinder , abstract , GeometryRealizationFactory , GameRenderer , Level1 , GeometryRealizationSample , Level2 , Level3 , SampleOverlay , Level4 , Level5 , D2DInterpolationModes , MoveLookController , Simple3DGame , abstract , SoundEffect , DirectXApp , SampleOverlay , abstract , SampleOverlay , ContentImageSource , DirectXApp , abstract , Design , SampleOverlay , DirectXApp , Element , abstract , SampleOverlay , Image , DirectXApp , abstract , ImageFrame , SampleOverlay , List< T > , Rectangle , Text , TextFrame , D2DPerspectiveTransform , abstract , SampleOverlay , DirectXApp , abstract , SampleOverlay , abstract , SampleOverlay , SaveAsImageFile , DirectXApp , abstract , SampleOverlay , DirectXApp , abstract , SampleOverlay , DirectXApp , abstract , SampleOverlay , DirectXApp , abstract , SampleOverlay , DirectXApp , abstract , LonLatController , SampleOverlay , DirectX::ScratchImage , DirectX::Blob , BasicSprites::SpriteBatch , DirectXApp , abstract , SampleOverlay , DirectXApp , abstract , SampleOverlay , Direct3DTutorialFrameworkView , DirectXApp , abstract , SampleOverlay , DirectXApp , abstract , SampleOverlay , abstract , DWriteCustomTextRenderer , SampleOverlay , abstract , DWriteHelloWorld , SampleOverlay , abstract , DWriteHitTesting , SampleOverlay , abstract , DWriteInlineObject , SampleOverlay , abstract , DWriteParagraphText , SampleOverlay , abstract , DWriteVerticalText , SampleOverlay , Audio , Cylinder , DirectXApp , abstract , GameRenderer , Level1 , Level2 , Level3 , Level4 , Level5 , MoveLookController , Simple3DGame , abstract , SoundEffect , AudioEngineCallbacks , D2DTextAnimation , Audio , DirectXApp , abstract , MarbleMaze , SampleOverlay , MediaStreamer , SampleOverlay , D2DBasicAnimation , ElementBase , TextElement , abstract , CountdownTimer , StopwatchTimer
  • Initialize1D() : DirectX::ScratchImage
  • Initialize2D() : DirectX::ScratchImage
  • Initialize3D() : DirectX::ScratchImage
  • Initialize3DFromImages() : DirectX::ScratchImage
  • InitializeAmmo() : Simple3DGame
  • InitializeArrayFromImages() : DirectX::ScratchImage
  • InitializeAsync()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::LowLatency
, SimpleCommunication::VideoChat
, SimpleCommunication::sealed
  • InitializeAudioDeviceAsync()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • InitializeBackgroundTaskStatus() : SDKSample::BackgroundTask::BackgroundTaskSample
  • InitializeCapture() : SDKSample::WASAPIAudio::sealed
  • InitializeCube() : DirectX::ScratchImage
  • InitializeCubeFromImages() : DirectX::ScratchImage
  • InitializeDevice() : SDKSample::WASAPIAudio::sealed
  • InitializeEdgeGestureHandlers() : EdgeGestureSample::sealed
  • InitializeFromImage() : DirectX::ScratchImage
  • InitializeGameConfig() : Simple3DGame
  • InitializeGameState() : DirectXApp , Simple3DGameXaml::sealed
  • InitializeLicense() : Simple3DGameXaml::sealed
  • InitializeLicenseCore() : Simple3DGameXaml::sealed
  • InitializeMediaServers() : SDKSample::MediaServerClient::sealed
  • InitializeObject() : Shape
  • InitializeScopeData() : SDKSample::WASAPIAudio::WASAPICapture
  • InitializeUIControls() : SimpleCommunication::sealed
  • InitializeValues()
: D2D3DTransforms::sealed
, D2DLightingEffects::sealed
  • InitializeVaultAsync() : SDKSample::PasswordVaultCPP::sealed
  • initializing : SimpleCommunication::sealed
  • initializing_previewSetupCompleted() : SimpleCommunication::sealed
  • InitPresentationDescriptor() : CMPEG1Source
  • InitPrintManager() : DirectXApp
  • InlineImage() : InlineImage
  • InputFrame : SDKTemplateCS::MainPage
  • InputFrameLoaded : SDKTemplateCS::MainPage
  • inputFrameNavigated()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • InputName : AntSystem::Node
  • InputPauseButton_Click() : SDKSample::Transcode::sealed
  • InputPlayButton_Click() : SDKSample::Transcode::sealed
  • InputStopButton_Click() : SDKSample::Transcode::sealed
  • InRegion() : Shape
  • Insert() : SDKSample::DataBinding::sealed
  • InsertAfter() : List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE >
  • InsertBack() : List< T >
  • InsertFront() : List< T >
  • InsertPhoto() : Hilo::PhotoCache
  • InsertPos() : List< T >
  • InspectableClass() : CDocumentSource , CAppWindowProvider
  • InstallCertifiate_Click() : SDKSample::CertificateEnrollment::sealed
  • InstanceId : CustomDeviceAccess::DeviceListEntry
  • INT2F16() : DirectX::INTColor
  • INTColor() : DirectX::INTColor
  • IntegrateSimulation() : Physics
  • InterfaceClasses_SelectionChanged() : SDKSample::DeviceEnumeration::sealed
  • InterfaceDisplayItem() : SDKSample::DeviceEnumeration::sealed
  • Interfaces() : SDKSample::DeviceEnumeration::sealed
  • InternalOptimizeTripAsync() : TripOptimizerComponent::Details::TripOptimizerImpl
  • InternalProcessOutput() : CDecoder
  • InternalSaveToFile() : Hilo::ThumbnailGenerator
  • InternetConnectionProfile() : SDKSample::NetworkInformationApi::sealed
  • InternetConnectionProfile_Click() : SDKSample::NetworkInformationApi::sealed
  • internetProfileInfo : SDKSample::NetworkInformationApi::sealed
  • interocularDistance : StereoParameters
  • interpNorm1 : Extruder::ExtrudingSink::Vertex2D
  • interpNorm2 : Extruder::ExtrudingSink::Vertex2D
  • Interpolate() : DirectX::LDRColorA
  • InterpolateA() : DirectX::LDRColorA
  • InterpolateRGB() : DirectX::LDRColorA
  • IntersectsWithGround() : Collision
  • Invalidate() : Contact , CCopyModule , CInvertModule , CCopyModule , CInvertModule
  • InvalidateDX11Resources() : CInvert
  • InvalidateSize()
: SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, Clipboard::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, DeviceAppForWebcam::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SimpleCommunication::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
  • InvalidateViewState()
: SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, DatagramSocketSample::sealed
, SDKSample::sealed
, AppBarControl::sealed
, DeviceAppForWebcam::sealed
, SDKTemplate::MainPage
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SimpleCommunication::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
  • InvalidateVisualState()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • InvalidPageException() : PrintSample::InvalidPageException
  • Invoke() : AsyncCallback< T >
  • InvokeFn : AsyncCallback< T >
  • InvokeMapChanged() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • InvokePrintButtonClick() : PrintSample::sealed
  • InvokeSimpleToast() : Background::sealed
  • IsActive() : CMPEG1Stream , abstract
  • IsActivePlay() : Simple3DGame
  • isApp : Simple3DGameXaml::sealed
  • IsAudioSetup() : StreamEffect
  • IsBackground : SDKSample::WASAPIAudio::DEVICEPROPS
  • IsBigEndian : SDKMESH_HEADER , SDKANIMATION_FILE_HEADER
  • IsCartoonizing() : Hilo::sealed
  • IsColliding() : Contact
  • IsConnected() : DatagramSocketSample::sealed
  • IsContentCropped : PrintSample::PageDescription
  • IsCountdownComplete() : CountdownTimer
  • IsDegenerate() : Triangle
  • IsEmpty() : List< T >
  • isEnabled : Wrapper::DspSettings , SDKSample::DeviceEnumeration::sealed
  • IsEndOfStream() : Parser
  • IsEOF()
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::ToneSampleGenerator
  • isEventRegistered : SDKSample::ApplicationSettings::sealed
  • IsFinished() : abstract
  • IsFiring() : MoveLookController
  • IsFirst() : TriColorValueHelper
  • IsHWOffload : SDKSample::WASAPIAudio::DEVICEPROPS
  • IsInitialized : SDKSample::MediaButtons::sealed , CMPEG1Source
  • IsLast() : TriColorValueHelper
  • IsLaunchedByTap() : ProximityCPP::sealed
  • IsLoaded() : SDKMesh
  • IsLoading() : SDKMesh
  • IsMatching() : DatagramSocketSample::sealed
  • IsMediaJustLoaded : SDKSample::PlayToreceiver::sealed
  • IsMoving() : Physics
  • IsNull() : ScopedObject< T >
  • isNumberSubstituted : TextAnalysis::Run
  • IsOrientationLandscape() : Renderer
  • IsPauseRequested() : MoveLookController
  • IsPixelSnappingDisabled() : CustomTextRenderer , OutlineRenderer
  • isPlaying : XAudio2SoundPlayer::ImplData
  • IsPlaying : SDKSample::PlaybackManager::sealed , SDKSample::PlaybackManager2::sealed , MEPlayer
  • IsPlayReceivedPreMediaLoaded : SDKSample::PlayToreceiver::sealed
  • IsPreRollFilled() : SDKSample::WASAPIAudio::MFSampleGenerator
  • IsPressComplete() : MoveLookController
  • IsPressed() : TextButton
  • IsRateSupported() : CMPEG1Source
  • IsReadOnly : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • IsReceiverStarted : SDKSample::PlayToreceiver::sealed
  • isRect : Polygon
  • IsRegistered : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • IsRegisteredForDeviceEvents() : SDKSample::PortableDeviceCPP::sealed
  • IsResponseComplete() : Web::HttpRequest
  • IsResponseReceived() : Web::Details::HttpRequestBuffersCallback
  • isReversed : TextAnalysis::Run
  • isRollingOnFloor : CollisionInfo
  • isScenario2StoryboardRunning : SDKSample::Animation::sealed
  • IsSeeking : SDKSample::PlayToreceiver::sealed , MEPlayer
  • isSideways : TextAnalysis::Run
  • IsSoundEffectStarted() : Audio
  • IsSoundPlaying() : XAudio2SoundPlayer
  • IsSticky_Click() : AppBarControl::sealed
  • IsStreamActive() : CMPEG1Source
  • IsStreamTypeSupported() : CMPEG1Source
  • isTerminator : SimpleCommunication::VideoChat
  • IsThin() : SetRateOp
  • IsTonePlayback : SDKSample::WASAPIAudio::DEVICEPROPS
  • IsTouching() : Cylinder , Face , GameObject , Sphere , Face , Sphere , Cylinder
  • IsTrial() : Simple3DGame
  • isTrial : GameConfig
  • IsValidInputStream() : CPolarEffect , CDecoder , CPolarEffect , CGrayscale
  • IsValidOutputStream() : CPolarEffect , CGrayscale , CPolarEffect , CGrayscale , CDecoder
  • IsVisible() : ElementBase
  • ItalicButtonClick() : SDKSample::TextEditing::sealed
  • item : List< T >::Node
  • Item()
: List< T >::Node
, SDKSample::ListViewSampleDataSource::sealed
, List< T >::Node
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, List< T >::Node
  • ItemClickHandler() : SDKSample::ListViewSimple::sealed
  • ItemCollection() : SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • itemCollection : SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed , SDKSample::FlipViewData::sealed
  • ItemCollection() : SDKSample::FlipViewData::sealed
  • ItemListView_SelectionChanged() : SimpleBlogReader::sealed
  • ItemsPage() : SimpleBlogReader::sealed
  • ItemView_ItemClick() : SimpleBlogReader::sealed
  • iteration : FractalBufferElement
  • Iterations : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- p -

  • PacketHeader() : Parser
  • Page1()
: SDKSample::PersonalityAnimations::sealed
, AppBarControl::sealed
  • Page2()
: AppBarControl::sealed
, SDKSample::PersonalityAnimations::sealed
  • Page3() : AppBarControl::sealed
  • Page_Loaded()
: AssociationLaunching::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, CredentialPickerCPP::sealed
, ToastsSampleCPP::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
  • Page_SizeChanged()
: ToastsSampleCPP::sealed
, AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::SnapSample::sealed
, ToastsSampleCPP::sealed
  • PageLoadedHandler() : SimpleBlogReader::sealed
  • pageRenderer : PageRendererContext
  • PageResized : SDKSample::FilePickerContracts::sealed , SDKSample::sealed
  • PageSize : PrintSample::PageDescription
  • PageTwo_Click() : AppBarControl::sealed
  • PageWithAppBar() : SDKSample::WebViewControl::sealed
  • Paginate() : CDocumentSource
  • Paint() : Shape
  • PaperFlyout() : Postcard::sealed
  • PaperFlyoutAddPaperClicked() : Postcard::sealed
  • PaperFlyoutDeletePaperClicked() : Postcard::sealed
  • PaperFlyoutMoveClicked() : Postcard::sealed
  • PaperFlyoutStampClicked() : Postcard::sealed
  • Parallel : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • ParametrizedTemplate() : SDKSample::DateTimeFormatting::sealed
  • Parent() : ManipulatableObject
  • ParentFrame : SDKMESH_FRAME
  • ParentTransform() : ManipulatableObject
  • Parse() : Document
  • ParseBytes() : Parser
  • ParseColor() : Element
  • ParseData() : CMPEG1Source
  • ParseErrorCode() : SDKSample::ProvisioningAgent::sealed
  • ParseNameIdentifier() : Element
  • ParsePacketHeader() : Parser
  • ParsePackHeader() : Parser
  • Parser() : Parser
  • ParseResultXML() : SDKSample::ProvisioningAgent::sealed
  • ParseSystemHeader() : Parser
  • passive : SimpleCommunication::sealed
  • password : SDKSample::sealed
  • PasswordField_PasswordChanged() : SDKSample::AtomPub::sealed
  • PasteButton_Click() : Clipboard::sealed
  • Path : _FILE_PLAYBACK
  • Pause() : SDKSample::MediaButtons::sealed , MEPlayer , CMPEG1Source , CMPEG1Stream , SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • PauseAll_Click() : SDKSample::BackgroundTransfer::sealed
  • PauseAudio() : SDKSample::CallControl::sealed
  • pauseButton_Click() : SDKSample::PlayTo::sealed
  • PauseDevice() : SDKSample::WASAPIAudio::sealed
  • PauseGame() : Simple3DGame
  • PausePlaybackAsync() : SDKSample::WASAPIAudio::WASAPIRenderer
  • PausePressedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • PauseRequested() : Simple3DGameXaml::sealed
  • pauseSlideshow_Click() : SDKSample::PlayTo::sealed
  • PayloadSize() : Parser
  • PcmSource() : MediaStreamSource::PcmSource
  • PeerFinder_Accept() : ProximityCPP::sealed
  • PeerFinder_BrowsePeers() : ProximityCPP::sealed
  • PeerFinder_Connect() : ProximityCPP::sealed
  • PeerFinder_Send() : ProximityCPP::sealed
  • PeerFinder_StartFindingPeers() : ProximityCPP::sealed
  • PeerFinder_StartReader() : ProximityCPP::sealed
  • PeerFinder_StartSendReceive() : ProximityCPP::sealed
  • PeerFinderInit() : ProximityCPP::sealed
  • PeerFinderReset() : ProximityCPP::sealed
  • PeerFinderScenario() : ProximityCPP::sealed
  • penetrationDistance : Contact
  • PERCENT : SDKSample::Scaling::sealed
  • percentOfScreen : Wrapper::DspSettings
  • PeriodicTimer : Tasks::sealed
  • PeriodicTimerScenario() : SDKSample::ThreadPool::sealed
  • Person() : SDKSample::Accessibility::sealed
  • PerturbOne()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • pGeometry : PaperFragment
  • phase : RippleEffect
  • Pheromone : AntSystem::Edge
  • PhoneCall() : SDKSample::CallControl::sealed
  • PHOTO_FILE_NAME : MediaCapture::BasicCapture
  • photoGroup : Hilo::sealed
  • PhotoRotationLookup() : SDKSample::MediaCapture::sealed
  • PhotoSizeChanged() : Hilo::sealed
  • PhotoStorage : sealed
  • Physics() : Physics
  • PickAContactButton_Click() : ContactPicker::sealed
  • PickAFileButton_Click() : SDKSample::FilePicker::sealed
  • PickAndLaunchFileButton_Click() : AssociationLaunching::sealed
  • PickAndSetButton_Click() : SDKSample::Personalization::sealed
  • PickAudioButton_Click() : SDKSample::Playlists::sealed
  • PickContactsButton_Click() : ContactPicker::sealed
  • PickFile() : SDKSample::Transcode::sealed
  • PickFileButton_Click()
: SDKSample::FilePicker::sealed
, SDKSample::FilePickerContracts::sealed
  • PickFilesButton_Click() : SDKSample::FilePicker::sealed
  • PickFolderButton_Click() : SDKSample::FilePicker::sealed
  • PickImage_Click() : SDKSample::Tiles::sealed
  • PickPlaylist() : SDKSample::MainPage
  • PickPlaylistButton_Click() : SDKSample::Playlists::sealed
  • PickSingleFileAndSet()
: SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
  • PictureChanged() : AccountPictureName::sealed
  • PictureTime() : CStreamState
  • PictureViewSize : PrintSample::PageDescription
  • PinButton_Click() : SecondaryTiles::sealed
  • PinchRadius() : CPolarEffect
  • PinFromAppbar() : SecondaryTiles::sealed
  • PinLiveTile_Click() : SecondaryTiles::sealed
  • PinTile() : SecondaryTiles::sealed
  • pinToAppBar : SecondaryTiles::sealed
  • pIsEnabled : IMft0Vtbl
  • Pitch() : Camera , MoveLookController , Camera , MoveLookController
  • pitchOrLinearSize : DDS_HEADER
  • pixelAspectRatio : MPEG1VideoSeqHeader
  • pixelHeight : ConstantBufferLayoutForDX9BrightPassPixelShader
  • pixelResolutionHeight : STEREO_PARAMETERS
  • pixelResolutionWidth : STEREO_PARAMETERS
  • pixels : DirectX::Image
  • pixelShader : Material
  • PixelsToDips() : FPSCounter
  • pixelWidth : ConstantBufferLayoutForDX9BrightPassPixelShader
  • plane : Contact , Triangle
  • planeNormal : AnimateCirclePosition
  • Play() : SDKSample::MediaButtons::sealed , MEPlayer , SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • Play_Click() : SDKSample::MediaButtons::sealed
  • PlayAudio() : SDKSample::CallControl::sealed
  • PlaybackControl()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • playButton_Click() : SDKSample::PlayTo::sealed
  • playData : XAudio2SoundPlayer::ImplData
  • PlayFile() : SDKSample::Transcode::sealed
  • PlayingTime() : GameTimer
  • Playlist_SelectionChanged() : SDKSample::PlayTo::sealed
  • playlistExtensionsInner : SDKSample::MainPage
  • playlistInner : SDKSample::MainPage
  • playListPlayNext() : SDKSample::PlayTo::sealed
  • playlistTimer : SDKSample::PlayTo::sealed
  • playlistTimer_Tick() : SDKSample::PlayTo::sealed
  • PlayPause() : SDKSample::MediaButtons::sealed
  • PlayPauseToggle() : SDKSample::WASAPIAudio::sealed
  • PlayPauseTogglePressedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • PlayPressedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • playSlideshow_Click() : SDKSample::PlayTo::sealed
  • PlaySound() : GameObject , SoundEffect , GameObject , SoundEffect , XAudio2SoundPlayer
  • PlaySoundEffect() : Audio
  • playToManager : SDKSample::PlayTo::sealed
  • playToManager_SourceRequested() : SDKSample::PlayTo::sealed
  • PlotDataReadyEvent() : SDKSample::WASAPIAudio::sealed
  • PlotEasingFunctionGraph() : SDKSample::Animation::sealed
  • pName : SValue
  • pNext : SConversion
  • pNode : List< T >::POSITION
  • PointA : AntSystem::Edge
  • PointB : AntSystem::Edge
  • Pointer() : SDKSample::DeviceCaps::sealed
  • PointerGetSettings_Click() : SDKSample::DeviceCaps::sealed
  • PointerType() : SDKSample::DeviceCaps::sealed
  • PointHitTest() : Program
  • PointInRect() : sealed
  • PointQueue : MarbleMaze
  • points : Polygon , SDKSample::WASAPIAudio::sealed
  • pointsCount : Extruder::ExtrudingSink , PointSnapper::PointSnappingSink
  • PointSnappingSink() : PointSnapper::PointSnappingSink
  • PopInClick() : SDKSample::PersonalityAnimations::sealed
  • PopOutClick() : SDKSample::PersonalityAnimations::sealed
  • PopulateScenarios()
: SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SimpleCommunication::sealed
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
  • PopupInputContent() : SDKSample::XAMLPopup::sealed
  • port : DatagramSocketSample::sealed
  • Portrait() : SDKSample::Rotation::sealed
  • PortraitFlipped() : SDKSample::Rotation::sealed
  • pos : BasicVertex , TangentVertex , ScreenQuadVertex , IndexTriplet , BasicSprites::ReplicationVertex , AsteroidData , ParticleData , SimpleCubeVertex , ScreenVertex
  • Pos : SimpleVertex
  • pos : BasicSprites::InstancingVertex , FractalVertex
  • Position() : GameObject , Sphere , GameObject , Sphere
  • POSITION() : List< T >::POSITION
  • position : FPSCounter , LineSegment , PNTVertex
  • POSITION() : List< T >::POSITION
  • Position() : GameObject
  • PositionAtlasText() : FPSCounter
  • PositionImage() : SDKSample::SplashScreen::sealed
  • positionToken : SDKSample::GeolocationCPP::sealed
  • PostAsync() : Web::HttpRequest
  • Power : SDKMESH_MATERIAL
  • ppvObject : IMft0Vtbl
  • PrepareContainerForItemOverride()
: SDKSample::Accessibility::sealed
, Hilo::sealed
  • PrepareForRender() : WaveEffect , RippleEffect
  • PrepareForVideoRecording() : SDKSample::MediaCapture::sealed
  • PrepareToDraw() : Resource , Element , TextFrame
  • PrepareToDrawChildren() : Element
  • PreparetPrintContent() : PrintSample::sealed
  • Present() : abstract , sealed , abstract
  • Presets() : SDKSample::Transcode::sealed
  • PressComplete() : Simple3DGameXaml::sealed
  • prev : List< T >::Node
  • Preview_Click() : SimpleCommunication::LowLatency
  • PreviewButtonClicked() : SimpleCommunication::sealed
  • previewEncodingProperties : SimpleCommunication::LowLatency
  • previewing : SimpleCommunication::sealed
  • previewing_localClientButtonClicked() : SimpleCommunication::sealed
  • previewing_previewButtonClicked() : SimpleCommunication::sealed
  • Previewing_PreviewButtonClicked() : SimpleCommunication::LowLatency
  • previewing_recordingStarted() : SimpleCommunication::sealed
  • PreviewSetupCompleted() : SimpleCommunication::LowLatency
  • previewStarted : SDKSample::CameraOptions::sealed
  • PreviewUnavailable() : PrintSample::sealed
  • PreviousItem_Click() : SDKSample::AtomPub::sealed
  • previousItem_Click() : SDKSample::PlayTo::sealed
  • PreviousItem_Click()
: SDKSample::AtomPub::sealed
, SDKSample::Syndication::sealed
  • previousState : SimpleCommunication::LowLatency
  • previousSwitchValues : SDKSample::CustomDeviceAccess::sealed
  • PreviousValue() : TriColorValueHelper
  • PrevTrack() : SDKSample::MediaButtons::sealed
  • PrimitiveType : SDKMESH_SUBSET
  • printDetailedOptions_OptionChanged() : PrintSample::sealed
  • PrintDetailedOptionsOptionChanged() : PrintSample::sealed
  • PrintExceptionCode() : SDKSample::ProvisioningAgent::sealed
  • PrintPage() : PageRenderer
  • PrintPointerInfo() : CoreWindowEvents
  • PrintRow() : SDKSample::DataReaderWriter::sealed
  • PrintTaskRequested()
: PrintSample::sealed
, PrintSample::BasePrintPage
, PrintSample::sealed
  • Process() : CDecoder
  • ProcessEvent() : CPolarEffect , CGrayscale , CDecoder , CInvert , CGrayscale , CInvert
  • ProcessFrame() : CInvertModule , CCopyModule
  • ProcessInput() : CPolarEffect , CDecoder , CGrayscale , CInvert , CGrayscale , CPolarEffect , CDecoder , CInvert
  • ProcessLocation() : TripOptimizerComponent::Details::TripOptimizerImpl
  • ProcessMessage() : CPolarEffect , CDecoder , CGrayscale , CDecoder , CPolarEffect , CInvert , CGrayscale
  • ProcessOutput() : CPolarEffect , CGrayscale , CInvert , CPolarEffect , CGrayscale , CDecoder
  • ProcessQueue() : OpQueue< T, TOperation >
  • ProcessQueueAsync() : OpQueue< T, TOperation >
  • ProcessRoute() : TripOptimizerComponent::Details::TripOptimizerImpl
  • ProcessScopeData() : SDKSample::WASAPIAudio::WASAPICapture
  • productId : Simple3DGameXaml::sealed
  • ProfileLocalUsageData() : SDKSample::NetworkInformationApi::sealed
  • ProfileLocalUsageData_Click() : SDKSample::NetworkInformationApi::sealed
  • profileMediaType : SDKSample::ProvisioningAgent::sealed
  • Progress : Tasks::sealed
  • Projection() : Camera
  • projection : ConstantBuffer
  • Projection() : Camera
  • projection : ConstantBufferChangeOnResize , ConstantBuffer
  • properties : SDKSample::DeviceEnumeration::sealed
  • PropertyChanged
: ScheduledNotificationsSampleCPP::sealed
, Hilo::sealed
, Simple3DGameXaml::sealed
, Magazine::sealed
, Hilo::Common::BindableBase
  • Protocol_SelectionChanged() : CredentialPickerCPP::sealed
  • ProtocolList_SelectionChanged() : SDKSample::Tiles::sealed
  • ProvideUpdatedVersionButton_Click() : SDKSample::FilePickerContracts::sealed
  • ProvisionMno() : SDKSample::ProvisioningAgent::sealed
  • ProvisionMno_Click() : SDKSample::ProvisioningAgent::sealed
  • ProximityDevice_PublishMessage() : ProximityCPP::sealed
  • ProximityDevice_SubscribeForMessage() : ProximityCPP::sealed
  • ProximityDeviceEvents() : ProximityCPP::sealed
  • ProximityDeviceScenario() : ProximityCPP::sealed
  • pSample : SDKSample::WASAPIAudio::MFSampleGenerator
  • pt : Extruder::ExtrudingSink::Vertex2D
  • PtFromPx() : SDKSample::Scaling::sealed
  • Ptr() : Buffer , ComPtrList< T, NULLABLE > , Buffer , ComPtrList< T, NULLABLE >
  • PTS : MPEG1PacketHeader
  • PubDate : SimpleBlogReader::sealed
  • puiPercentOfScreen : IMft0Vtbl
  • Purple : sealed
  • pushReceivedToken : SDKSample::SDKTemplate::sealed
  • pushToken : RawNotificationsSampleCPP::sealed
  • PxFromPt() : SDKSample::Scaling::sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- q -

  • Quantize()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • QuantizeEndPts() : DirectX::D3DX_BC6H
  • QueryInterface() : GeometryRealizationFactory , Extruder::ExtrudingSink , OutlineRenderer , ContentImageSource , PointSnapper::PointSnappingSink , MediaEngineNotify , RippleEffect , FontFileStream , AsyncCallback< T > , SourceOp , FontLoader , CMPEG1Source , AsyncCallback< T > , WaveEffect , ImageFile , AsyncCallback< T > , CMPEG1Stream , SourceOp , CMPEG1Source , CustomTextRenderer , GeometryRealization , InlineImage , ComBase< InterfaceChain >
  • QueryInterfaceInternal() : QiList< InterfaceName, QiListNil > , QiListSelf< InterfaceName, InterfaceChain > , QiList< InterfaceName, InterfaceChain >
  • QueryLockScreenAccess_Click() : LockScreenAppsCPP::sealed
  • QueryPhotoCount() : Hilo::sealed
  • QueryPhotosAsync() : Hilo::sealed
  • QuerySinglePhotoAsync() : Hilo::sealed
  • QueueAsyncOperation() : CMPEG1Source
  • QueueEvent() : CMPEG1Source , CMPEG1Stream
  • QueueOperation() : OpQueue< T, TOperation >
  • QuickLinkSectionLabel_Tapped() : ShareTarget::sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- r -

  • r : Vector2< T > , Vector3< T > , DirectX::LDRColorA , AmpPixel
  • R() : DirectX::BC4_UNORM
  • r : DirectX::HDRColorA
  • R() : DirectX::BC4_SNORM
  • r : Vector4< T > , DirectX::INTColor , AmpPixel
  • radioFile_Checked() : SDKSample::WASAPIAudio::sealed
  • radioTone_Checked() : SDKSample::WASAPIAudio::sealed
  • Radius() : Sphere
  • RandFloat() : SimpleSprites
  • RandomFloat() : PaperRenderer
  • raStream : ScenarioContext
  • rateBound : MPEG1SystemHeader
  • RBitMask : DDS_PIXELFORMAT
  • rcBound : Polygon
  • Read() : ImageFile , RandomAccessReader
  • ReadAll() : MediaStreamer
  • ReadAsync() : Web::HttpRequest
  • readBuffer : SDKSample::WebSocket::sealed , SDKSample::HttpClientSample::sealed
  • ReadBytes() : SDKSample::DataReaderWriter::sealed
  • ReadBytesButton_Click() : SDKSample::FileAccess::sealed
  • ReadChunk() : ReadStreamTask::ReadStreamTaskImpl
  • ReadCounter() : SDKSample::ApplicationDataSample::sealed
  • ReadData() : Web::Details::HttpRequestBuffersCallback , BasicReaderWriter , Web::Details::HttpRequestBuffersCallback , BasicReaderWriter
  • ReadDataAsync() : BasicReaderWriter
  • ReaderState : SDKSample::WASAPIAudio::MFSampleGenerator
  • ReaderStateEOS : SDKSample::WASAPIAudio::MFSampleGenerator
  • ReaderStatePlaying : SDKSample::WASAPIAudio::MFSampleGenerator
  • ReaderStatePreRoll : SDKSample::WASAPIAudio::MFSampleGenerator
  • ReaderStateStopped : SDKSample::WASAPIAudio::MFSampleGenerator
  • ReadFileFragment() : FontFileStream
  • ReadFromStreamButton_Click() : SDKSample::FileAccess::sealed
  • ReadingChanged()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
  • readingChangedEventToken : SDKSample::DisplayOrientation::sealed
  • readingToken
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
  • ReadLoop() : SDKSample::DataReaderWriter::sealed
  • ReadOnlyTextBox_ContextMenuOpening() : SDKSample::ContextMenu::sealed
  • ReadPayload() : CMPEG1Source
  • ReadStreamTask() : ReadStreamTask
  • ReadStreamTaskImpl() : ReadStreamTask::ReadStreamTaskImpl
  • ReadTextButton_Click() : SDKSample::FileAccess::sealed
  • ReadUtf8StringFromSequentialStream() : HttpRequestStringCallback
  • Ready() : ImageFile
  • RealVSyncTimer() : MEPlayer
  • reasonPhrase : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , Web::HttpRequest
  • Receipt() : SDKSample::StoreSample::sealed
  • ReceiptRefreshScenario() : SDKSample::StoreSample::sealed
  • ReceiveFileInput() : AssociationLaunching::sealed
  • ReceiveFileOutput() : AssociationLaunching::sealed
  • receiver : SDKSample::PlayToreceiver::sealed
  • receiver_CurrentTimeChangeRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_MuteChangeRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_PauseRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_PlaybackRateChangeRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_PlayRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_SourceChangeRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_StopRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_TimeUpdateRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_VolumeChangeRequestedEvent() : SDKSample::PlayToreceiver::sealed
  • ReceiveStringLoop() : StreamSocketSample::sealed
  • ReceiveUriInput() : AssociationLaunching::sealed
  • ReceiveUriOutput() : AssociationLaunching::sealed
  • Record() : SDKSample::MediaButtons::sealed
  • recordingStarted : SimpleCommunication::Common::CaptureDevice
  • RecordLimitationExceeded()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • rect : InlineImage
  • Rect() : DirectX::Rect
  • RectFromValue() : UiaCoreWindowProvider::ITriColorControlInternal
  • Red : sealed
  • red_0 : DirectX::BC4_UNORM , DirectX::BC4_SNORM
  • red_1 : DirectX::BC4_UNORM , DirectX::BC4_SNORM
  • ReencodePhotoAsync() : SDKSample::MediaCapture::sealed
  • ReencodeState() : sealed
  • refCount : CustomTextRenderer , InlineImage
  • Refine()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • Refresh() : ScheduledNotificationsSampleCPP::sealed
  • RefreshList_Click() : ScheduledNotificationsSampleCPP::sealed
  • RefreshListView() : ScheduledNotificationsSampleCPP::sealed
  • RefreshPreview() : PrintSample::sealed
  • refValue_ : ComBase< InterfaceChain >
  • Register() : RippleEffect , WaveEffect
  • RegisterAppBarButtons() : AppBarControl::sealed
  • RegisterBackgroundTask()
: SDKSample::BackgroundTask::BackgroundTaskSample
, SDKSample::BackgroundTask::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::BackgroundTaskSample
, RawNotificationsSampleCPP::sealed
  • RegisterClipboardContentChanged_Click() : Clipboard::sealed
  • registerContentChanged : Clipboard::sealed
  • registeredNetworkStatusNotif : SDKSample::NetworkInformationApi::sealed
  • RegisterElement() : UserInterface
  • RegisterForDeviceEvents() : SDKSample::PortableDeviceCPP::sealed
  • RegisterForPrinting() : PrintSample::BasePrintPage
  • RegisterForPrintingButtonClick()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • RegisterForSwitchStateChangedEvent() : SDKSample::CustomDeviceAccess::sealed
  • RegisterServicingCompleteBackgroundTask() : SDKSample::BackgroundTask::BackgroundTaskSample
  • RegisterTaskButton_Click() : SDKSample::SDKTemplate::sealed
  • registrationToken : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • Release() : ContentImageSource , FontFileStream , FontLoader , ImageFile , DirectX::ScratchImage , DirectX::Blob , InlineImage
  • ReleaseAudioResources() : StreamEffect , AudioController
  • ReleaseBufferResources() : ExtrudedTextRenderer
  • ReleaseFileFragment() : FontFileStream
  • ReleaseParent() : Element
  • ReleaseResources() : Audio
  • remoteScenariosInner : SDKSample::FilePickerContracts::sealed
  • RemoteSession() : SDKSample::IsRemoteSession::sealed
  • RemoteVideo_MediaFailed() : SimpleCommunication::VideoChat
  • Remove() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , List< T > , SDKSample::Playlists::sealed , SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , List< T > , SDKSample::DataBinding::sealed
  • Remove_Click() : ScheduledNotificationsSampleCPP::sealed
  • RemoveBack() : List< T >
  • RemoveButtonClicked() : Postcard::sealed
  • RemoveCallback_Click() : SDKSample::SDKTemplate::sealed
  • RemoveFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • RemoveFromSelection() : SDKSample::TouchKeyboard::sealed
  • RemoveFront() : List< T >
  • RemoveItem() : List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE >
  • RemoveLocalFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • RemoveLockScreenAccess_Click() : LockScreenAppsCPP::sealed
  • RemoveObserver()
: Hilo::FileSystemRepository
, Hilo::ObservableQuery
  • RemovePageFromPrintPreviewCollection() : PrintSample::BasePrintPage
  • RemovePageRangeEdit() : PrintSample::sealed
  • RemovePaper() : PaperRenderer , PostcardRenderer
  • RemovePaperClicked : Postcard::sealed
  • RemoveRepulsor() : SimpleSprites
  • RemoveSaveButton_Click() : AppBarControl::sealed
  • RemoveTexture() : BasicSprites::SpriteBatch
  • RemoveTouch() : MarbleMaze
  • RemoveURLFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • RenameButton_Click() : SDKSample::FilePickerContracts::sealed
  • Render() : SampleOverlay , CommandListRenderer , abstract , SampleOverlay , CompositeModes , abstract , SampleOverlay , ConvolveMatrixEffect , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , D2DEffectsOnPrimitives , abstract , SampleOverlay , abstract , FPSCounter , GeometryRealizationSample , SampleOverlay , D2DInterpolationModes , abstract , SampleOverlay , D2DPerspectiveTransform , abstract , SampleOverlay , PageRenderer , abstract , SampleOverlay , abstract , SampleOverlay , SaveAsImageFile , PageRenderer , abstract , SampleOverlay , BumpMapping , abstract , SampleOverlay , abstract , DirectXFractal , SampleOverlay , D3DPostProcessing , abstract , SampleOverlay , abstract , ResourceLoading , SampleOverlay , abstract , SampleOverlay , SimpleSprites , abstract , SampleOverlay , StereoSimpleD3D , Direct3DTutorial , abstract , SampleOverlay , abstract , SampleOverlay , TextInterop , abstract , DWriteCustomTextRenderer , SampleOverlay , abstract , DWriteHelloWorld , SampleOverlay , abstract , DWriteHitTesting , SampleOverlay , abstract , DWriteInlineObject , SampleOverlay , abstract , DWriteParagraphText , SampleOverlay , abstract , DWriteVerticalText , SampleOverlay , abstract , GameHud , GameObject , GameRenderer , abstract , Audio , abstract , LoadScreen , MarbleMaze , SampleOverlay , SDKMesh , ElementBase , TextElement , CountdownTimer , StopwatchTimer , TextButton , HighScoreTable , UserInterface , abstract , PostcardRenderer , CoreWindowEvents , abstract , SampleOverlay , abstract , SampleOverlay , Simple3DTouch , abstract , OfferReclaimAPI , SampleOverlay , abstract , DxgiRotation , SampleOverlay , abstract , sealed , abstract , SampleOverlay , sealed , abstract , sealed , D2DLightingEffectsRenderer , abstract , GameHud , GameObject , GameRenderer , abstract , BasicSound , abstract , SampleOverlay , abstract , SampleOverlay , StreamEffect , AudioController , abstract , SampleOverlay , abstract , SampleOverlay , SimpleController , D2D3DTransformsRenderer , abstract , D2DTextAnimation , abstract , SampleOverlay , D2DBasicAnimation , abstract , SampleOverlay , D2DEffectsHelloWorld , abstract
  • Render3DPerspectiveTransformEffect() : D2D3DTransformsRenderer
  • Render3DTransformEffect() : D2D3DTransformsRenderer
  • RenderAdjacent() : SDKMesh
  • RenderAudio() : StreamEffect
  • RenderBuffer() : RenderBuffer
  • RenderControllerInput() : SimpleController
  • renderer : Document
  • RenderEye() : StereoSimpleD3D
  • RenderFrame() : SDKMesh
  • RenderGlow() : D3DPostProcessing
  • RenderMainContent() : GeometryRealizationSample
  • RenderMesh() : SDKMesh
  • RenderObjects() : Simple3DGame , Program , Simple3DGame
  • RenderSetup() : Material
  • RenderToTarget() : GeometryRealization
  • RenewChannelsButton_Click() : SDKSample::SDKTemplate::sealed
  • Repeater : Samples::Devices::Fx2::sealed , Samples::Devices::Repeater
  • RepeaterState : Samples::Devices::Repeater
  • ReplaceAll() : SDKSample::Helpers
  • ReplaceUrlSearchTerms() : SDKSample::MainPage
  • ReportCompleted_Click() : ShareTarget::sealed
  • ReportDataRetrieved_Click() : ShareTarget::sealed
  • ReportErrorButton_Click() : ShareTarget::sealed
  • ReportStarted_Click() : ShareTarget::sealed
  • ReportSubmittedBackgroundTask_Click() : ShareTarget::sealed
  • repository : Hilo::sealed
  • request : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • RequestData() : CMPEG1Source
  • RequestLockScreenAccess_Click() : LockScreenAppsCPP::sealed
  • RequestRedraw() : IRenderer
  • RequestResponse() : SDKSample::UssdApi::sealed
  • RequestSample() : CMPEG1Stream
  • RequestsPending : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • RequireSquareContent : NotificationsExtensions::TileContent::TileWideBase
  • Reserve() : Buffer
  • reserved : DDS_HEADER_DXT10 , DirectX::DDS_HEADER_DXT10
  • reserved1 : DDS_HEADER
  • reserved2 : DDS_HEADER
  • Reset() : BasicTimer , ScopedObject< T > , BasicTimer , GameTimer , BasicTimer , StopwatchTimer , HighScoreTable , ExtrudedTextRenderer , ImageRenderer , InkRenderer , PaperRenderer , BasicTimer , LanguageFontCPP::sealed , CStreamState , SimpleCommunication::sealed , GameTimer , BasicTimer
  • Reset_Click()
: SDKSample::CameraCapture::sealed
, SDKSample::PasswordVaultCPP::sealed
  • Reset_Click1() : SDKSample::EAS::sealed
  • Reset_Click2() : SDKSample::EAS::sealed
  • Reset_Click3() : SDKSample::EAS::sealed
  • ResetCheckpoints() : MarbleMaze
  • ResetClicked() : Postcard::sealed
  • ResetDirectXResources() : SampleOverlay , LoadScreen , SampleOverlay
  • ResetGame() : Simple3DGameXaml::sealed
  • ResetLicense() : Simple3DGameXaml::sealed
  • ResetOutput()
: SDKSample::MainPage
, SDKSample::Scaling::sealed
  • ResetPostcard() : PostcardRenderer
  • ResetScenarioOutput()
: SDKSample::MainPage
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
  • ResetSignature() : PostcardRenderer
  • ResetState() : Shape , MoveLookController
  • ResetValues()
: D2D3DTransforms::sealed
, D2DLightingEffects::sealed
  • ResizeVideo() : MEPlayer
  • Resolve() : Contact
  • ResolvedGeographicRegion() : Hilo::CalendarExtensions
  • ResolvedLanguage() : Hilo::CalendarExtensions
  • ResolvedLocation : AntSystem::Node
  • ResolvedName : AntSystem::Node
  • ResolveSampleContact() : ContactPicker::sealed
  • resourceDimension : DDS_HEADER_DXT10 , DirectX::DDS_HEADER_DXT10
  • responseComplete : Web::HttpRequest
  • responseReceived : Web::Details::HttpRequestBuffersCallback
  • Restart() : MediaStreamer
  • RestartTask() : Samples::Devices::Repeater
  • Restore() : SDKSample::sealed
  • RestoreAsync()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
, SuspensionManager
, SDKSample::Common::sealed
, SuspensionManager
, SDKSample::Common::sealed
  • RestoreFrameNavigationState()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
  • Result : Samples::Devices::DeviceControlResult
  • resultSuggestionChosenToken : SDKSample::SearchContract::sealed
  • Resume() : XAudio2SoundPlayer
  • ResumeAll_Click() : SDKSample::BackgroundTransfer::sealed
  • ResumeAudio() : Audio
  • ResumeDeviceWatcher()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • Resuming() : SDKSample::MediaCapture::sealed
  • RetrieveLocationsAsync() : TripOptimizerComponent::Details::TripOptimizerImpl
  • RetrieveRoutesAsync() : TripOptimizerComponent::Details::TripOptimizerImpl
  • Revert() : ImageFile
  • Rewind() : SDKSample::MediaButtons::sealed
  • rgb : DirectX::D3DX_BC1
  • RGBAPrec : DirectX::D3DX_BC7::ModeInfo , DirectX::D3DX_BC6H::ModeInfo
  • RGBAPrecWithP : DirectX::D3DX_BC7::ModeInfo
  • RGBBitCount : DDS_PIXELFORMAT
  • RGBToYUV() : Utils
  • Rho : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • RichTextColumns() : Hilo::Common::sealed
  • RightClickEventToken : EdgeGestureSample::sealed
  • RightClickOverride() : EdgeGestureSample::sealed
  • RightClickRegion : EdgeGestureSample::sealed
  • RightClickRegionEventToken : EdgeGestureSample::sealed
  • RightEyeProjection() : Camera
  • rightPanel : SecondaryTiles::sealed , AppBarControl::sealed
  • riid : IMft0Vtbl
  • RippleEffect() : RippleEffect
  • roamingFolder : SDKSample::ApplicationDataSample::sealed
  • roamingSettings : SDKSample::ApplicationDataSample::sealed
  • Role : SimpleCommunication::sealed
  • roleIsActive : SimpleCommunication::VideoChat
  • rootFrame
: AppBarControl::App
, DeviceAppForWebcam::sealed
, StreamSocketSample::App
, SDKSample::App
, ContactPicker::App
, DatagramSocketSample::sealed
, DeviceAppForPrinters::App
, SDKSample::SplashScreen::sealed
, Clipboard::App
, AccountPictureName::App
, SecondaryTiles::sealed
  • RootNamespace : SDKTemplateCS::MainPage
  • rootPage
: SDKSample::Animation::sealed
, SDKSample::AnimationMetrics::sealed
, SDKSample::CallControl::sealed
, SDKSample::CalendarSample::sealed
, SDKSample::CameraCapture::sealed
, AssociationLaunching::sealed
, SDKSample::PackageSample::sealed
, AccountPictureName::sealed
, SDKSample::ProvisioningAgent::sealed
, SDKSample::ApplicationSettings::sealed
, SDKSample::MicrosoftAccount::sealed
, SDKSample::AccelerometerCPP::sealed
, SDKSample::PlayTo::sealed
, SDKSample::MessageDialogSample::sealed
, SDKSample::Compression::sealed
, SDKSample::UserAndCustomControls::sealed
, PrintSample::sealed
, SDKSample::TouchKeyboard::sealed
, SDKSample::FileAccess::sealed
, SDKSample::TextEditing::sealed
, SDKSample::NumberFormatting::sealed
, SDKSample::DeviceEnumeration::sealed
, SDKSample::CryptoWinRT::sealed
, AppBarControl::sealed
, SDKSample::HomeGroup::sealed
, MediaExtensionsCPP::sealed
, SDKSample::DateTimeFormatting::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::PlaybackManager2::sealed
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::NetworkInformationApi::sealed
, SecondaryTiles::sealed
, SDKSample::TextDisplay::sealed
, LockScreenAppsCPP::sealed
, SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
, SDKSample::PlaybackManager::sealed
, SDKSample::HighContrast::sealed
, SDKSample::ThreadPool::sealed
, MediaExtensionsCS::ScenarioInput1
, SDKSample::GeolocationCPP::sealed
, SDKSample::PortableDeviceCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::UssdApi::sealed
, SDKSample::PlayToreceiver::sealed
, SDKSample::Transcode::sealed
, MediaExtensionsCS::ScenarioList
, ToastsSampleCPP::sealed
, SDKSample::Personalization::sealed
, StreamSocketSample::sealed
, SDKSample::Syndication::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::ELS::sealed
, SDKSample::Rotation::sealed
, CustomDeviceAccess::DeviceAsync
, MediaExtensionsCS::ScenarioOutput1
, SDKSample::CompassCPP::sealed
, SDKSample::CameraOptions::sealed
, SDKSample::BackgroundTransfer::sealed
, SDKSample::DataReaderWriter::sealed
, SDKSample::StoreSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::RemovableStorageCPP::sealed
, SDKSample::FilePicker::sealed
, SDKSample::WASAPIAudio::sealed
, SimpleCommunication::LowLatency
, LanguageFontCPP::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::BackgroundTask::sealed
, SDKSample::MediaServerClient::sealed
, MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCS::ScenarioOutput2
, SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::Accessibility::sealed
, MediaExtensionsCS::ScenarioInput3
, SDKSample::ContextMenu::sealed
, SDKSample::UserDomainName::sealed
, SDKSample::OrientationSensorCPP::sealed
, AppBarControl::sealed
, MediaCapture::BasicCapture
, SDKSample::HttpClientSample::sealed
, SDKSample::TouchKeyboardTextInput::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::LightSensorCPP::sealed
, MediaExtensionsCS::ScenarioOutput4
, SDKSample::ListViewSimple::sealed
, SDKSample::DeviceCaps::sealed
, SDKSample::Playlists::sealed
, SDKSample::Images::sealed
, SDKSample::ShareSource::sealed
, SDKSample::InclinometerCPP::sealed
, AppBarControl::sealed
, SDKSample::FileThumbnails::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::Transforms::sealed
, SDKSample::EAS::sealed
, EdgeGestureSample::sealed
, MediaExtensionsCS::ScenarioInput2
, SDKSample::Drawing::sealed
, DatagramSocketSample::sealed
, MediaExtensionsCS::ScenarioOutput3
, CredentialPickerCPP::sealed
, SDKSample::CustomDeviceAccess::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::MediaButtons::sealed
, SDKSample::CertificateEnrollment::sealed
, SDKSample::WebSocket::sealed
, SDKSample::ApplicationDataSample::sealed
, SDKSample::IsRemoteSession::sealed
, Clipboard::sealed
, MediaStreamSource::AudioSource
, SDKSample::Tiles::sealed
, SimpleCommunication::VideoChat
, SDKSample::WebAuthentication::sealed
  • rootPage_InputFrameLoaded()
: LanguageFontCPP::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, ToastsSampleCPP::sealed
, LanguageFontCPP::sealed
, ToastsSampleCPP::sealed
, EdgeGestureSample::sealed
, RawNotificationsSampleCPP::sealed
, CredentialPickerCPP::sealed
, ToastsSampleCPP::sealed
, CredentialPickerCPP::sealed
  • rootPage_MainPageResized() : SDKSample::Transforms::sealed
  • rootPage_OutputFrameLoaded()
: ToastsSampleCPP::sealed
, EdgeGestureSample::sealed
, CredentialPickerCPP::sealed
, MediaExtensionsCS::ScenarioInput1
, LanguageFontCPP::sealed
, MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput2
, CredentialPickerCPP::sealed
, MediaExtensionsCS::ScenarioInput4
, LanguageFontCPP::sealed
, EdgeGestureSample::sealed
, MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput3
, CredentialPickerCPP::sealed
  • rot : AsteroidData
  • Rotate90() : Hilo::sealed
  • RotateClockwise() : Hilo::ExifExtensions
  • RotateImage() : Hilo::sealed
  • RotateImageView() : Hilo::sealed
  • RotateImageViewModel::RotateImageAsync() : Hilo::sealed
  • RotateImageViewModel::SetEncodingRotation() : Hilo::sealed
  • rotation : ViewTransform , BasicSprites::InstanceData
  • rotationAngle : SDKSample::DisplayOrientation::sealed
  • rotVel : AsteroidData
  • RoughMSE()
: DirectX::D3DX_BC7
, DirectX::D3DX_BC6H
  • Round() : RippleEffect
  • RoundUpTo16() : DirectXFractal
  • rowPitch : DirectX::Image
  • rt : CStreamState
  • Run() : D2DBasicAnimation , DWriteVerticalText , Direct3DTutorialFrameworkView , BackgroundTask::sealed , DirectXApp , Background::sealed , DWriteHitTesting , DirectXApp , DWriteParagraphText , DWriteInlineObject , SaveAsImageFile , D2DInterpolationModes , DirectXApp , DWriteHelloWorld , BackgroundTasks::sealed , DirectXApp , GeometryRealizationSample , sealed , DirectXApp , sealed , DirectXApp , Direct3DTutorialFrameworkView , DirectXApp , Tasks::sealed , VideoView , DirectXApp , CoreWindowEvents , DirectXApp , sealed , Tasks::sealed , NetworkStatusTask::sealed , Background::sealed , TextAnalysis::Run , Direct3DTutorialFrameworkView , Background::sealed , D2DPerspectiveTransform , DirectXApp , D2DEffectsHelloWorld , DWriteCustomTextRenderer , DirectXApp , D2DTextAnimation , Background::sealed , sealed , DirectXApp , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , D2DEffectsOnPrimitives
  • Run_Click() : SDKSample::PortableDeviceCPP::sealed
  • RunGame() : Simple3DGame
  • Running : Samples::Devices::Repeater
  • RunSample_Click() : SDKSample::CryptoWinRT::sealed
  • RuntimeClassInitialize() : CPolarEffect , CGrayscale , CPolarEffect , CDocumentSource , CInvert , CDocumentSource , CGrayscale
  • RW : DirectX::D3DX_BC6H
  • RX : DirectX::D3DX_BC6H
  • RY : DirectX::D3DX_BC6H
  • RZ : DirectX::D3DX_BC6H
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- s -

  • S1_DeviceProperties() : SDKSample::PortableDeviceCPP::sealed
  • S1_ListStorages() : SDKSample::RemovableStorageCPP::sealed
  • S2_Enumeration() : SDKSample::PortableDeviceCPP::sealed
  • S2_SendToStorage() : SDKSample::RemovableStorageCPP::sealed
  • S2Formatter() : SDKSample::DataBinding::sealed
  • S3_GetFromStorage() : SDKSample::RemovableStorageCPP::sealed
  • S3_SendToDevice() : SDKSample::PortableDeviceCPP::sealed
  • S4_Autoplay() : SDKSample::RemovableStorageCPP::sealed
  • S4_GetFromDevice() : SDKSample::PortableDeviceCPP::sealed
  • S5_Events() : SDKSample::PortableDeviceCPP::sealed
  • S6_DeviceStatus() : SDKSample::PortableDeviceCPP::sealed
  • SafeAdd() : RippleEffect
  • SampleBackgroundTask()
: SDKSample::BackgroundTask::sealed
, Tasks::sealed
  • sampleBackgroundTaskEntryPoint : SDKSample::GeolocationCPP::sealed
  • sampleBackgroundTaskName : SDKSample::GeolocationCPP::sealed
  • SampleBackgroundTaskProgress : SDKSample::BackgroundTask::BackgroundTaskSample
  • SampleBackgroundTaskRegistered : SDKSample::BackgroundTask::BackgroundTaskSample
  • SampleBackgroundTaskWithConditionProgress : SDKSample::BackgroundTask::BackgroundTaskSample
  • SampleBackgroundTaskWithConditionRegistered : SDKSample::BackgroundTask::BackgroundTaskSample , SDKSample::BackgroundTaskSample
  • SampleDataItem() : SDKSample::FlipViewData::sealed
  • SampleDataSource() : SDKSample::FlipViewData::sealed
  • SampleDuration : MediaStreamSource::PcmSource
  • sampleFile : SDKSample::MainPage
  • sampleOffsets : ConstantBufferLayoutForGlowPixelShader
  • SampleRate : MediaStreamSource::PcmSource
  • sampleWeights : ConstantBufferLayoutForGlowPixelShader
  • Save() : SDKSample::sealed
  • SaveAsync()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
, SuspensionManager
, SDKSample::Common::sealed
, SuspensionManager
, SDKSample::Common::sealed
  • SaveBitmapToFile() : SaveAsImageFile
  • SaveBitmapToStream() : SaveAsImageFile , PostcardRenderer
  • SaveBool() : PersistentState
  • SaveClicked() : Postcard::sealed
  • SaveFileButton_Click()
: SDKSample::FilePicker::sealed
, SDKSample::FilePickerContracts::sealed
  • SaveFrameNavigationState()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
  • SaveHighScore() : Simple3DGame
  • SaveImage() : Hilo::sealed
  • SaveImageAsync() : Hilo::ImageBase
  • SaveInt32() : PersistentState
  • SaveInternalState() : BumpMapping , LonLatController , DirectXFractal , LonLatController , ResourceLoading , MoveLookController , Simple3DTouch
  • SaveInternalValue() : DirectXFractal , MoveLookController
  • SavePostcard() : PostcardRenderer
  • SaveSingle() : PersistentState
  • SaveState()
: SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Magazine::sealed
, abstract
, Level2
, Level4
, Simple3DGame
, MarbleMaze
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::sealed
, Hilo::Common::LayoutAwarePage
, Hilo::HiloPage
, Hilo::sealed
, Hilo::ViewModelBase
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, abstract
, Level2
, Level4
, Simple3DGame
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
  • SaveString() : PersistentState
  • SaveXMFLOAT3() : PersistentState
  • scale : ViewTransform , AsteroidData
  • ScaleImageDimensions() : Hilo::sealed
  • Scaling : SDKANIMATION_DATA
  • Scenario1()
: SDKSample::XAMLPopup::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::Transforms::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::AccelerometerCPP::sealed
, SDKSample::AnimationMetrics::sealed
, SDKSample::PackageSample::sealed
, SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::BackgroundTransfer::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::Compression::sealed
, SDKSample::WebSocket::sealed
, SDKSample::ContextMenu::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::DisplayOrientation::sealed
, SDKSample::EAS::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::FolderEnumeration::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::PlayTo::sealed
, SDKSample::MediaServerClient::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::PlayToreceiver::sealed
, SDKSample::FileSearch::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::Scaling::sealed
, SDKSample::SearchContract::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::SnapSample::sealed
, SDKSample::SplashScreen::sealed
, StreamSocketSample::sealed
, SDKSample::Syndication::sealed
, SDKSample::WebAuthentication::sealed
, SDKSample::WASAPIAudio::sealed
, SDKSample::Accessibility::sealed
, SDKSample::Animation::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::HighContrast::sealed
, SDKSample::Images::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::PersonalityAnimations::sealed
  • Scenario10()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
  • Scenario10_SearchMultipleResourceIds() : SDKSample::ApplicationResources::sealed
  • Scenario10_ShowCandidates() : SDKSample::ApplicationResources::sealed
  • Scenario10Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario11() : SDKSample::ApplicationResources::sealed
  • Scenario11Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario1::GetElementRect() : SDKSample::ContextMenu::sealed
  • Scenario1DisplayToast() : ToastsSampleCPP::sealed
  • Scenario1DisplayToastWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario1Open_Click() : RawNotificationsSampleCPP::sealed
  • Scenario1Reset()
: SDKSample::DataBinding::sealed
, SDKSample::ScrollViewerCPP::sealed
  • Scenario1Unregister_Click() : RawNotificationsSampleCPP::sealed
  • Scenario2()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::PackageSample::sealed
, SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::BackgroundTransfer::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::Compression::sealed
, SDKSample::WebSocket::sealed
, SDKSample::ContextMenu::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::DisplayOrientation::sealed
, SDKSample::EAS::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::FolderEnumeration::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::PlayTo::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::Scaling::sealed
, SDKSample::SearchContract::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::SplashScreen::sealed
, StreamSocketSample::sealed
, SDKSample::WebAuthentication::sealed
, SDKSample::WASAPIAudio::sealed
, SDKSample::Accessibility::sealed
, SDKSample::Animation::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::HighContrast::sealed
, SDKSample::Images::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::Transforms::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario2::GetTextboxSelectionRect() : SDKSample::ContextMenu::sealed
  • Scenario2AddListener_Click() : RawNotificationsSampleCPP::sealed
  • Scenario2Button1_Click() : SDKSample::Images::sealed
  • Scenario2Button_Click() : SDKSample::DisplayOrientation::sealed
  • Scenario2Closed() : SDKSample::WebSocket::sealed
  • Scenario2DisplayToast() : ToastsSampleCPP::sealed
  • Scenario2DisplayToastWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario2ReadData() : SDKSample::HttpClientSample::sealed
  • Scenario2ReceiveData() : SDKSample::WebSocket::sealed
  • Scenario2RemoveListener_Click() : RawNotificationsSampleCPP::sealed
  • Scenario2Reset()
: ProximityCPP::sealed
, SDKSample::DataBinding::sealed
, SDKSample::ScrollViewerCPP::sealed
  • Scenario2SendData() : SDKSample::WebSocket::sealed
  • Scenario2ToggleStoryboard_Click() : SDKSample::Animation::sealed
  • Scenario3()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::PackageSample::sealed
, SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::Compression::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::DisplayOrientation::sealed
, SDKSample::EAS::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::FolderEnumeration::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::SearchContract::sealed
, StreamSocketSample::sealed
, SDKSample::WASAPIAudio::sealed
, SDKSample::Accessibility::sealed
, SDKSample::Animation::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::HighContrast::sealed
, SDKSample::Images::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario3_ClickHandler1() : SDKSample::PersonalityAnimations::sealed
  • Scenario3_ClickHandler2() : SDKSample::PersonalityAnimations::sealed
  • Scenario3DisplayToast() : ToastsSampleCPP::sealed
  • Scenario3DisplayToastWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario3EasingFunctionChanged() : SDKSample::Animation::sealed
  • Scenario3Reset() : SDKSample::DataBinding::sealed
  • Scenario3StringLoad_Click() : SDKSample::ApplicationResources::sealed
  • Scenario4()
: SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::SearchContract::sealed
, StreamSocketSample::sealed
, SDKSample::Accessibility::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario4DisplayToastWithSound() : ToastsSampleCPP::sealed
  • Scenario4DisplayToastWithSoundWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario4Reset() : SDKSample::DataBinding::sealed
  • Scenario5()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::SearchContract::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::TextEditing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario5Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario5DisplayToastWithCallbacks_Click() : ToastsSampleCPP::sealed
  • Scenario5HideToast_Click() : ToastsSampleCPP::sealed
  • Scenario5Reset() : SDKSample::DataBinding::sealed
  • Scenario6()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FilePicker::sealed
, SDKSample::SearchContract::sealed
, SDKSample::DataBinding::sealed
, SDKSample::TextEditing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario6Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario6DisplayLongToast() : ToastsSampleCPP::sealed
  • Scenario6DisplayLongToastWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario6Reset() : SDKSample::DataBinding::sealed
  • Scenario7()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::FileAccess::sealed
, SDKSample::SearchContract::sealed
, SDKSample::DataBinding::sealed
, SDKSample::TextEditing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario7Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario7Reset() : SDKSample::DataBinding::sealed
  • Scenario8()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::FileAccess::sealed
, SDKSample::DataBinding::sealed
, SDKSample::WebViewControl::sealed
  • Scenario8Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario8Reset() : SDKSample::DataBinding::sealed
  • Scenario9()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
  • Scenario9Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario_Enroll() : SDKSample::CertificateEnrollment::sealed
  • Scenario_Import() : SDKSample::CertificateEnrollment::sealed
  • ScenarioButtonDelete_Click() : SDKSample::PasswordVaultCPP::sealed
  • ScenarioCompleted() : SDKSample::Helpers
  • ScenarioDisable()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
  • ScenarioEnable()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
  • ScenarioGet() : SDKSample::SimpleOrientationSensorCPP::sealed
  • ScenarioInit()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • ScenarioInput1()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput2()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput3()
: CredentialPickerCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput4()
: MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput5()
: PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput6()
: PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput6::GeneratePage() : PrintSample::sealed
  • ScenarioList
: SDKSample::sealed
, AccountPictureName::sealed
, Clipboard::sealed
, ContactPicker::sealed
, DatagramSocketSample::sealed
, SDKSample::FilePickerContracts::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
, StreamSocketSample::sealed
, AppBarControl::sealed
, AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioList
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • scenarioList : SecondaryTiles::sealed
  • ScenarioLoaded
: SDKSample::sealed
, AccountPictureName::sealed
, Clipboard::sealed
, ContactPicker::sealed
, SDKTemplate::MainPage
, DatagramSocketSample::sealed
, SDKSample::FilePickerContracts::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
, SecondaryTiles::sealed
, StreamSocketSample::sealed
, AppBarControl::sealed
  • ScenarioMultiple() : ContactPicker::sealed
  • ScenarioOneStates : SimpleCommunication::sealed
  • ScenarioOutput1()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioOutput1
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput2()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioOutput2
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput3()
: CredentialPickerCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioOutput3
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput4()
: MediaExtensionsCS::ScenarioOutput4
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput5()
: PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput6()
: PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioReset()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • scenarios : SDKTemplate::MainPage
  • Scenarios_SelectionChanged()
: SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, AssociationLaunching::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, CredentialPickerCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, EdgeGestureSample::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, LanguageFontCPP::sealed
, SDKSample::sealed
, LockScreenAppsCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, MediaExtensionsCS::ScenarioList
, MediaExtensionsCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, PrintSample::sealed
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SimpleCommunication::sealed
, SDKSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, ToastsSampleCPP::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
  • ScenariosFrame : SDKTemplateCS::MainPage
  • ScenarioSingle() : ContactPicker::sealed
  • scenariosInner
: AccountPictureName::MainPage
, SDKSample::MainPage
, Clipboard::MainPage
, ContactPicker::MainPage
, ContactPicker::MainPagePicker
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKSample::MainPage
, SecondaryTiles::MainPage
  • ScenarioStarted() : SDKSample::Helpers
  • Schedule_Click() : ScheduledNotificationsSampleCPP::sealed
  • scheduledNotificationsBinding : ScheduledNotificationsSampleCPP::sealed
  • ScheduleTile() : ScheduledNotificationsSampleCPP::sealed
  • ScheduleTileWithStringManipulation() : ScheduledNotificationsSampleCPP::sealed
  • ScheduleToast() : ScheduledNotificationsSampleCPP::sealed
  • ScheduleToastWithStringManipulation() : ScheduledNotificationsSampleCPP::sealed
  • ScopedObject() : ScopedObject< T >
  • ScopedViews() : SDKSample::TouchKeyboardTextInput::sealed
  • ScratchImage() : DirectX::ScratchImage
  • script : TextAnalysis::Run
  • Script_Click() : SDKSample::WebViewControl::sealed
  • ScriptDetection() : SDKSample::ELS::sealed
  • ScrollIntoView() : SDKSample::TouchKeyboard::sealed
  • SDKMesh() : SDKMesh
  • SearchButton_Click() : SDKSample::FileSearch::sealed
  • SearchHomeGroup() : SDKSample::HomeGroup::sealed
  • searchPane : SDKSample::SearchContract::sealed
  • SearchPaneMaxSuggestions : SDKSample::MainPage
  • SecondaryTileNotification() : SecondaryTiles::sealed
  • Seek() : ImageFile
  • SeekAbsolute() : RandomAccessReader
  • SeekAsync() : MediaStreamSource::PcmSource
  • SeekRelative() : RandomAccessReader
  • SeekToEnd() : RandomAccessReader
  • SeekToStart() : RandomAccessReader
  • segments : CylinderMesh , SphereMesh
  • Select() : SDKSample::TouchKeyboard::sealed
  • SelectFile()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • SelectFiles_Click() : SDKSample::MediaButtons::sealed
  • SelectFilesAsync() : Hilo::RandomPhotoSelector
  • SelectFilesButton_Click() : SDKSample::ShareSource::sealed
  • SelectImageButton_Click() : SDKSample::ShareSource::sealed
  • SelectPreferredCameraStreamSettingAsync()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • SelectResource_Click() : SDKSample::PasswordVaultCPP::sealed
  • SelectStreams() : CMPEG1Source
  • SelectTemplateCore() : SDKSample::FlipViewCPP::sealed
  • SelectUser_Click() : SDKSample::PasswordVaultCPP::sealed
  • SendAsync() : Web::HttpRequest
  • SendBadge() : SDKSample::Tiles::sealed
  • SendBadge_Click() : LockScreenAppsCPP::sealed
  • SendBadgeNotification_Click() : SecondaryTiles::sealed
  • SendBadgeNotificationWithStringManipulation_Click() : SecondaryTiles::sealed
  • SendBadgeWithStringManipulation_Click() : LockScreenAppsCPP::sealed
  • sendBuffer : SDKSample::WebSocket::sealed
  • SendButton_Click() : SDKSample::UssdApi::sealed
  • SendContentToDeviceAsync() : SDKSample::PortableDeviceCPP::sealed
  • SendHello_Click()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • SendImage_Click() : SDKSample::RemovableStorageCPP::sealed
  • SendImageFileToStorageAsync() : SDKSample::RemovableStorageCPP::sealed
  • SendLocalImageTile() : SDKSample::Tiles::sealed
  • SendMessage() : SDKSample::WebSocket::sealed
  • SendTextTile() : SDKSample::Tiles::sealed
  • SendTile_Click() : LockScreenAppsCPP::sealed
  • SendTileNotification_Click()
: SDKSample::Tiles::sealed
, SecondaryTiles::sealed
  • SendTileNotificationImage_Click() : SDKSample::Tiles::sealed
  • SendTileNotificationText_Click() : SDKSample::Tiles::sealed
  • SendTileNotificationWithQueryStrings_Click() : SDKSample::Tiles::sealed
  • SendTileNotificationWithStringManipulation_Click() : SecondaryTiles::sealed
  • SendTileWithStringManipulation_Click() : LockScreenAppsCPP::sealed
  • SendWebImageTile() : SDKSample::Tiles::sealed
  • sensor
: SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
  • Serialize() : sealed , ManipulatableObject
  • SerializeBinding()
: NotificationsExtensions::TileContent::ISquareTileInternal
, NotificationsExtensions::TileContent::TileSquareBase
, NotificationsExtensions::TileContent::ISquareTileInternal
, NotificationsExtensions::TileContent::TileSquareBase
  • SerializeProperties() : NotificationsExtensions::NotificationBase
  • SerializeToString() : Hilo::ImageNavigationData
  • serviceDocUri : SDKSample::sealed
  • ServicingComplete() : Tasks::sealed
  • ServicingCompleteTask() : SDKSample::BackgroundTask::sealed
  • ServicingCompleteTaskProgress : SDKSample::BackgroundTask::BackgroundTaskSample
  • ServicingCompleteTaskRegistered : SDKSample::BackgroundTask::BackgroundTaskSample
  • SessionState : SuspensionManager , CppSamplesUtils::SuspensionManager
  • sessionState_ : SuspensionManager
  • SessionStateForFrame()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
  • sessionStateKey : SDKSample::Common::sealed , Hilo::Common::sealed
  • Set() : DirectX::INTColor
  • set()
: SDKSample::sealed
, SDKSample::TouchKeyboard::sealed
, SDKSample::sealed
  • Set() : LanguageFontCPP::sealed
  • set_IsTile() : ScheduledNotificationsSampleCPP::sealed
  • SetAccountPicture() : AccountPictureName::sealed
  • SetAccountPictureName() : AccountPictureName::sealed
  • SetAction() : Simple3DGameXaml::sealed , DirectXApp , GameInfoOverlay , Simple3DGameXaml::sealed
  • SetAlignment() : ElementBase
  • SetAmplitude() : RippleEffect
  • SetApp() : Simple3DGameXaml::sealed
  • SetAudioCategory()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • SetAudioDeviceType()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • SetAudioSource() : SDKSample::CallControl::sealed
  • SetBackground() : Simple3DGameXaml::sealed , GameRenderer , Simple3DGame
  • SetBalance() : MEPlayer
  • SetBidiLevel() : TextAnalysis
  • SetBit() : DirectX::CBits< SizeInBytes >
  • SetBits() : DirectX::CBits< SizeInBytes >
  • SetButtons() : SDKSample::HomeGroup::sealed
  • SetBytestream() : MEPlayer
  • SetCancelButton() : SDKSample::Transcode::sealed
  • SetCancellationToken() : FrameProcessing
  • SetCenter() : RippleEffect
  • SetCollision() : Physics
  • SetConnected() : DatagramSocketSample::sealed
  • SetContactPicker() : ContactPicker::sealed
  • SetContainer() : ElementBase
  • SetCurrentFrame() : FrameProcessing
  • SetCurrentLevelToSavedState() : Simple3DGame
  • SetCurrentPlayingAsync() : SDKSample::MediaButtons::sealed
  • SetCurrentRun() : TextAnalysis
  • SetCurrentScenario() : SimpleCommunication::sealed
  • SetD2DContext() : Program
  • SetData() : SourceOp
  • SetDebugName() : BasicLoader
  • SetDevice() : sealed
  • SetDeviceAppForWebcam() : DeviceAppForWebcam::sealed
  • SetDpi() : abstract , Renderer , abstract , GameRenderer , abstract
  • SetDrawInfo() : WaveEffect , RippleEffect
  • SetDuration() : Animation< T >
  • SetEffectIntensity() : ImageRenderer , PostcardRenderer
  • SetElapsedTime() : StopwatchTimer
  • SetEnd() : Animation< T >
  • SetEngineExperiencedCriticalError() : Audio
  • SetError() : CredentialPickerCPP::sealed
  • SetErrorMessage() : SDKSample::ShareSource::sealed
  • SetExtrudedText() : PostcardRenderer , ExtrudedTextRenderer
  • SetFeatureName()
: AssociationLaunching::sealed
, Clipboard::sealed
, SDKTemplate::MainPage
, DatagramSocketSample::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, SDKTemplate::MainPage
, SDKTemplateCS::MainPage
, SDKTemplate::MainPage
, PrintSample::sealed
, ProximityCPP::sealed
, SDKTemplate::MainPage
, SimpleCommunication::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, SDKTemplate::MainPage
, AppBarControl::sealed
, MediaExtensionsCPP::sealed
, StreamSocketSample::sealed
, RawNotificationsSampleCPP::sealed
, CredentialPickerCPP::sealed
  • SetFireRect() : MoveLookController
  • SetFocus() : CAppWindowProvider
  • SetFont() : LanguageFontCPP::sealed
  • SetFontName() : TextStyle
  • SetFontSize() : TextStyle
  • SetFontStyle() : TextStyle
  • SetFontWeight() : TextStyle
  • SetFrequency() : RippleEffect
  • SetFromRGB() : AmpPixel
  • SetGameInfoOverlay() : DirectXApp , Simple3DGameXaml::sealed
  • SetGameLoading() : Simple3DGameXaml::sealed , GameInfoOverlay
  • SetGameOver() : GameInfoOverlay , Simple3DGameXaml::sealed
  • SetGameState() : MarbleMaze
  • SetGameStats() : GameInfoOverlay , Simple3DGameXaml::sealed
  • SetGlyphOrientation() : TextAnalysis
  • SetGraph() : WaveEffect , RippleEffect
  • SetGravity() : Physics
  • SetImageButton_Click() : AccountPictureName::sealed
  • SetImageFilePaths() : Hilo::WideFiveImageTile
  • SetIndex()
: DirectX::BC4_UNORM
, DirectX::BC4_SNORM
  • SetInitialPosition() : ManipulatableObject
  • SetInputType() : CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale
  • SetLandscape_Click() : SDKSample::Rotation::sealed
  • SetLandscapeFlipped_Click() : SDKSample::Rotation::sealed
  • SetLevelStart() : GameInfoOverlay , Simple3DGameXaml::sealed
  • SetLicenseInfo() : GameHud
  • SetLightingEffect() : D2DLightingEffectsRenderer , D2DLightingEffects::sealed
  • SetLightingProperty() : D2DLightingEffectsRenderer , D2DLightingEffects::sealed
  • SetLineBreakpoints() : TextAnalysis
  • SetLoading() : SDKMesh
  • SetLocalContentSuggestions() : SDKSample::SearchContract::sealed
  • SetLockscreenImage() : SDKSample::Personalization::sealed
  • SetManipulationTransform() : ManipulatableObject
  • SetManualLoadImage() : SDKSample::Scaling::sealed
  • SetMediaElementSourceAsync() : SDKSample::MediaButtons::sealed
  • SetMoveRect() : MoveLookController
  • SetNeighbourArea() : FrameProcessing
  • SetNumberSubstitution() : TextAnalysis
  • SetOrientation() : LonLatController , MoveLookController , LonLatController
  • SetOutputBounds() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect , CInvert
  • SetOutputType() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CDecoder , CPolarEffect , CInvert
  • SetOverrideRectSize() : SDKSample::Scaling::sealed
  • SetOverrideTextFont() : SDKSample::Scaling::sealed
  • SetPadding() : TextButton
  • SetPasswordExplainVisibility() : CredentialPickerCPP::sealed
  • SetPause() : GameInfoOverlay , Simple3DGameXaml::sealed
  • SetPhase() : RippleEffect
  • SetPickFileButton() : SDKSample::Transcode::sealed
  • SetPixel() : FrameProcessing
  • SetPlane() : Face
  • SetPlaybackPosition() : MEPlayer
  • SetPortrait_Click() : SDKSample::Rotation::sealed
  • SetPortraitFlipped_Click() : SDKSample::Rotation::sealed
  • SetPosition() : LonLatController , Physics , PaperFragment , MoveLookController , LonLatController
  • SetPressed() : TextButton
  • SetPrintTask() : DirectXApp
  • SetProductItems() : Simple3DGameXaml::sealed
  • SetProjectionParameters() : BasicCamera , Camera , BasicCamera
  • SetProjParams() : Camera
  • SetProperties() : CGrayscale , CInvert , CDecoder , CPolarEffect , CInvert , CDecoder , CPolarEffect , CGrayscale , SDKSample::WASAPIAudio::WASAPIRenderer
  • SetRadius() : Physics
  • SetRate() : CMPEG1Source , CMPEG1Stream
  • SetRateOp() : SetRateOp
  • SetResult() : CredentialPickerCPP::sealed
  • SetRoomSize() : Audio
  • SetSampleMode() : PostcardRenderer
  • SetScriptAnalysis() : TextAnalysis
  • SetSecondaryTiles() : SecondaryTiles::sealed
  • SetSelected() : TextButton
  • SetSize() : ImageFile , Buffer
  • SetSkewX() : WaveEffect
  • SetSkewY() : WaveEffect
  • SetSnapped() : Simple3DGameXaml::sealed , DirectXApp
  • SetSnappedMode() : PageRenderer
  • SetSoundEffectFilter() : Audio
  • SetSoundEffectPitch() : Audio
  • SetSoundEffectVolume() : Audio
  • SetSpread() : RippleEffect
  • SetStart() : Animation< T >
  • SetStatus() : Simple3DGameXaml::sealed
  • SetStereoExaggeration() : StereoSimpleD3D
  • SetText() : TextElement
  • SetTextAlignment() : TextStyle
  • SetTextColor() : TextElement
  • SetTextOpacity() : TextElement
  • SetTexture() : Material
  • SettingContainer() : SDKSample::ApplicationDataSample::sealed
  • Settings() : SDKSample::ApplicationDataSample::sealed
  • SetTransformEffect() : D2D3DTransforms::sealed , D2D3DTransformsRenderer
  • SetTransformProperty() : D2D3DTransforms::sealed , D2D3DTransformsRenderer
  • SetUnderlineOnRedraw() : DWriteHitTesting
  • SetUpBinding() : SDKSample::Transforms::sealed
  • SetupControls() : Program
  • SetupVideoDeviceControl()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
  • SetupWindowing()
: AccountPictureName::App
, SimpleCommunication::App
, DeviceAppForPrinters::App
, ProximityCPP::sealed
, Clipboard::App
, ContactPicker::App
  • SetURL() : MEPlayer
  • SetValue() : sealed
  • SetVelocity() : Physics
  • SetVersion() : SDKSample::ApplicationDataSample::sealed
  • SetVersion0_Click() : SDKSample::ApplicationDataSample::sealed
  • SetVersion1_Click() : SDKSample::ApplicationDataSample::sealed
  • SetVersionHandler0() : SDKSample::ApplicationDataSample::sealed
  • SetVersionHandler1() : SDKSample::ApplicationDataSample::sealed
  • SetVideoButton_Click() : AccountPictureName::sealed
  • SetViewParameters() : BasicCamera , Camera , BasicCamera
  • SetViewParams() : Camera
  • SetVisible() : ElementBase
  • SetVolume() : MEPlayer
  • SetVolumeOnSession() : SDKSample::WASAPIAudio::WASAPIRenderer
  • SetWaveOffset() : WaveEffect
  • SetWindow() : DirectXApp , DWriteHitTesting , CoreWindowEvents , DWriteParagraphText , DWriteCustomTextRenderer , SaveAsImageFile , DirectXApp , D2DBasicAnimation , DirectXApp , sealed , D2DPerspectiveTransform , Direct3DTutorialFrameworkView , DirectXApp , D2DTextAnimation , CompositeModes , ConvolveMatrixEffect , D2DEffectsOnPrimitives , D2DInterpolationModes , DirectXApp , Direct3DTutorialFrameworkView , DirectXApp , DWriteInlineObject , DWriteVerticalText , DirectXApp , sealed , DirectXApp , D2DEffectsHelloWorld , CommandListRenderer , GeometryRealizationSample , DirectXApp , Direct3DTutorialFrameworkView , DWriteHelloWorld , DirectXApp , sealed
  • shakeCounter : SDKSample::AccelerometerCPP::sealed
  • Shaken() : SDKSample::AccelerometerCPP::sealed
  • shakenToken : SDKSample::AccelerometerCPP::sealed
  • shape : ShapeRecord
  • Shape() : Shape
  • ShapesPuzzle() : sealed
  • Share_Click() : SDKSample::WebViewControl::sealed
  • ShareClicked() : Postcard::sealed
  • ShareCustomData() : SDKSample::ShareSource::sealed
  • sharedBitmapStreamRef : ShareTarget::sealed
  • sharedCustomData : ShareTarget::sealed
  • sharedDataDescription : ShareTarget::sealed
  • sharedDataTitle : ShareTarget::sealed
  • ShareDelayRenderedFiles() : SDKSample::ShareSource::sealed
  • sharedHtmlFormat : ShareTarget::sealed
  • sharedResourceMap : ShareTarget::sealed
  • sharedStorageItems : ShareTarget::sealed
  • sharedText : ShareTarget::sealed
  • sharedThumbnailStreamRef : ShareTarget::sealed
  • sharedUri : ShareTarget::sealed
  • ShareFiles() : SDKSample::ShareSource::sealed
  • ShareHtml() : SDKSample::ShareSource::sealed
  • ShareImage() : SDKSample::ShareSource::sealed
  • ShareLink() : SDKSample::ShareSource::sealed
  • shareOperation : ShareTarget::sealed
  • shareQuickLinkId : ShareTarget::sealed
  • ShareText() : SDKSample::ShareSource::sealed
  • ShareWebView_LoadCompleted() : SDKSample::ShareSource::sealed
  • ShowContent() : PrintSample::sealed
  • ShowDeviceSelectorAsync()
: SDKSample::PortableDeviceCPP::sealed
, SDKSample::RemovableStorageCPP::sealed
, SDKSample::PortableDeviceCPP::sealed
, SDKSample::RemovableStorageCPP::sealed
  • ShowExceptionMessage()
: MediaCapture::BasicCapture
, MediaCapture::AudioCapture
, SDKSample::MediaCapture::sealed
  • ShowFormatButton_Click() : Clipboard::sealed
  • ShowGameInfoOverlay() : Simple3DGameXaml::sealed , GameInfoOverlay , DirectXApp
  • ShowListButton_Click() : SDKSample::FileAccess::sealed
  • ShowMe_Click()
: SDKSample::WebViewControl::sealed
, AppBarControl::sealed
  • ShowMenu() : DWriteParagraphText , GeometryRealizationSample , ConvolveMatrixEffect
  • ShowOptionsUI() : SDKSample::CameraOptions::sealed
  • ShowPopupAnimationClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupLightDismissClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupOffsetClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupSettingsClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupWithoutParentClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupWithParentClicked() : SDKSample::XAMLPopup::sealed
  • ShowPropertiesButton_Click() : SDKSample::FileAccess::sealed
  • ShowReceipt_Click() : SDKSample::StoreSample::sealed
  • ShowSettings_Click() : SDKSample::CameraOptions::sealed
  • ShowStatusMessage()
: SDKSample::MediaCapture::sealed
, SDKSample::WASAPIAudio::sealed
, SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
, SDKSample::WASAPIAudio::sealed
  • ShowStoreFlyout() : Simple3DGameXaml::sealed
  • ShowUIButton_Click() : SDKSample::Common::SharePage
  • Shutdown() : CMPEG1Stream , MEPlayer , SDKSample::WASAPIAudio::MFSampleGenerator , CMPEG1Source
  • SiblingFrame : SDKMESH_FRAME
  • Signature : TGA_FOOTER
  • SignatureFlyout() : Postcard::sealed
  • SignButtonCicked() : Postcard::sealed
  • SignClicked() : Postcard::sealed
  • SignExtend() : DirectX::INTColor
  • Signin_Click() : SDKSample::PasswordVaultCPP::sealed
  • SignInButton_Click() : SDKSample::MicrosoftAccount::sealed
  • SignOutButton_Click() : SDKSample::MicrosoftAccount::sealed
  • simpleInk() : sealed
  • SimplifyIndexOptimized() : FrameProcessing
  • SimulateRoaming_Click() : SDKSample::ApplicationDataSample::sealed
  • SimulateSaveClicked() : SDKSample::XAMLPopup::sealed
  • SimulationTime : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • SingleFingerRotation() : ManipulatableObject
  • size : DDS_HEADER , anonymous_namespace{SoundFileReader.cpp}::ChunkHeader , SDKSample::WASAPIAudio::sealed , DDS_PIXELFORMAT , BasicSprites::TextureMapElement
  • sizeBound : MPEG1StreamHeader
  • SizeBytes : SDKMESH_VERTEX_BUFFER_HEADER , SDKMESH_INDEX_BUFFER_HEADER
  • sizeX : WaveEffect
  • sizeY : WaveEffect
  • skewX : WaveEffect
  • skewY : WaveEffect
  • sldBrightness_ValueChanged()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
  • sldContrast_ValueChanged()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
  • slicePitch : DirectX::Image
  • sliderFrequency_ValueChanged() : SDKSample::WASAPIAudio::sealed
  • sliderVolume_ValueChanged() : SDKSample::WASAPIAudio::sealed
  • SmoothStep() : Utils
  • SnapCoordinate() : PointSnapper
  • SnapGeometry() : PointSnapper
  • SnapPoint() : PointSnapper
  • socket : DatagramSocketSample::sealed
  • SocketContext() : DatagramSocketSample::sealed
  • SocketError() : ProximityCPP::sealed
  • Solution_Click() : SDKSample::WebViewControl::sealed
  • Song() : SDKSample::MediaButtons::sealed
  • SoundCallbackHander() : anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • SoundEffectEngine() : Audio
  • SoundFileReader() : SoundFileReader
  • SoundLevelChanged() : SDKSample::MediaCapture::sealed
  • SoundLevelChangedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • SoundLevelToString()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • source : WICConvert
  • SourceOp() : SourceOp
  • sourceRequestedToken : SDKSample::PlayTo::sealed
  • sourceVoice : XAudio2SoundPlayer::ImplData
  • Specular : SDKMESH_MATERIAL
  • specularColor : Material , ConstantBufferChangesEveryPrim
  • specularExponent : Material
  • specularPower : ConstantBufferChangesEveryPrim
  • SpecularRV : SDKMESH_MATERIAL
  • SpecularTexture : SDKMESH_MATERIAL
  • SpecularTextureName : SDKMESH_MATERIAL
  • Sphere() : Sphere
  • splash : SDKSample::SplashScreen::sealed
  • SplashImageRect : SDKSample::sealed
  • SplitCurrentRun() : TextAnalysis
  • SplitPage() : SimpleBlogReader::sealed
  • SplitString() : PrintSample::sealed
  • spread : RippleEffect
  • Square_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput2
  • SquareContent : NotificationsExtensions::TileContent::TileWideBase
  • Src : NotificationsExtensions::NotificationContentImage
  • srv : BasicSprites::TextureMapElement
  • StampButtonClicked() : Postcard::sealed
  • StampPaper() : PaperRenderer , PostcardRenderer
  • StampPaperClicked : Postcard::sealed
  • StandardOffset() : BasicSprites::SpriteBatch
  • StandardOrigin() : BasicSprites::SpriteBatch
  • starButton : AppBarControl::sealed
  • starButton_Click() : AppBarControl::sealed
  • Start() : Samples::Devices::Repeater , abstract , Samples::Devices::Repeater , abstract , GameTimer , CMPEG1Source , CMPEG1Stream , GameTimer , Audio , StopwatchTimer , CMPEG1Source , abstract
  • Start_Click()
: SDKSample::WebSocket::sealed
, SDKSample::HttpClientSample::sealed
, MediaStreamSource::AudioSource
, SDKSample::HttpClientSample::sealed
, SDKSample::WebSocket::sealed
  • StartBadgePolling_Click() : SDKSample::SDKTemplate::sealed
  • StartCaptureAsync() : SDKSample::WASAPIAudio::WASAPICapture
  • StartCountdown() : CountdownTimer
  • StartDevice() : SDKSample::WASAPIAudio::sealed
  • StartDownload_Click() : SDKSample::BackgroundTransfer::sealed
  • StartEventLoop() : Samples::Devices::Fx2::sealed
  • StartFx2Watcher()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • StartLayoutUpdates()
: SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • StartLevel() : Simple3DGame
  • StartListener_Click()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • StartMonthAndYearQueries() : Hilo::sealed
  • StartMonthQuery() : Hilo::sealed
  • StartMultipartUpload_Click() : SDKSample::BackgroundTransfer::sealed
  • StartOp() : StartOp
  • StartPlaybackAsync() : SDKSample::WASAPIAudio::WASAPIRenderer
  • startPlayToReceiver() : SDKSample::PlayToreceiver::sealed
  • startPosition : AnimateCirclePosition
  • StartPreview_Click() : SDKSample::CameraOptions::sealed
  • StartRecordingAsync()
: SimpleCommunication::sealed
, SimpleCommunication::Common::CaptureDevice
  • StartRecordingToCustomSink()
: SimpleCommunication::sealed
, SimpleCommunication::LowLatency
  • StartRecordingToCustomSinkAsync() : SimpleCommunication::sealed
  • StartRecordToCustomSink() : SimpleCommunication::VideoChat
  • StartRestoreTask() : CppSamplesUtils::SuspensionManager
  • StartSaveTask() : CppSamplesUtils::SuspensionManager
  • StartSignature() : PostcardRenderer , InkRenderer
  • StartSource() : SDKSample::WASAPIAudio::MFSampleGenerator
  • StartTask() : Samples::Devices::Repeater
  • StartTilePolling_Click() : SDKSample::SDKTemplate::sealed
  • StartTimer() : MEPlayer
  • StartTracking() : SDKSample::GeolocationCPP::sealed
  • StartUpload_Click() : SDKSample::BackgroundTransfer::sealed
  • StartYearQuery() : Hilo::sealed
  • Stat() : ImageFile
  • State : ContactPicker::sealed::SampleContact , SimpleCommunication::LowLatency
  • StateChangedEvent : SDKSample::WASAPIAudio::sealed
  • statusCode : HttpRequestStringCallback , Web::HttpRequest , Web::Details::HttpRequestBuffersCallback
  • StatusMessage : SDKSample::Helpers
  • statusToken : SDKSample::GeolocationCPP::sealed
  • STDMETHOD_()
: Extruder::ExtrudingSink
, OutlineRenderer
, Extruder::ExtrudingSink
, StreamingVoiceContext
, Extruder::ExtrudingSink
, PointSnapper::PointSnappingSink
, anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
, PointSnapper::PointSnappingSink
, anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
, PointSnapper::PointSnappingSink
, anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
, PointSnapper::PointSnappingSink
, Extruder::ExtrudingSink
, GeometryRealizationFactory
, StreamingVoiceContext
, Extruder::ExtrudingSink
, GeometryRealization
, StreamingVoiceContext
, Extruder::ExtrudingSink
, PointSnapper::PointSnappingSink
, OutlineRenderer
, StreamingVoiceContext
, GeometryRealization
, anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
, StreamingVoiceContext
, PointSnapper::PointSnappingSink
, Extruder::ExtrudingSink
, anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
, StreamingVoiceContext
  • STDMETHODIMP_() : CMPEG1Source , MediaEngineNotify , SDKSample::WASAPIAudio::MFSampleGenerator , AsyncCallback< T > , SourceOp , AsyncCallback< T > , SDKSample::WASAPIAudio::MFSampleGenerator , SourceOp , CMPEG1Stream , SDKSample::WASAPIAudio::MFSampleGenerator , MediaEngineNotify , CMPEG1Source , SourceOp , AsyncCallback< T > , SDKSample::WASAPIAudio::MFSampleGenerator , AsyncCallback< T > , CMPEG1Source , CMPEG1Stream , AsyncCallback< T > , SDKSample::WASAPIAudio::MFSampleGenerator , CMPEG1Source , SourceOp
  • stereoExaggerationFactor : STEREO_PARAMETERS
  • stereoSeparationFactor : STEREO_PARAMETERS
  • Stop() : Samples::Devices::Repeater , SDKSample::PlaybackManager::sealed , GameTimer , CMPEG1Stream , GameTimer , StopwatchTimer , Samples::Devices::Repeater , SDKSample::MediaButtons::sealed , CMPEG1Source , SDKSample::PlaybackManager2::sealed
  • Stop_Click()
: MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCS::ScenarioInput4
, SDKSample::WebSocket::sealed
, MediaStreamSource::AudioSource
, MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCPP::sealed
  • StopAudio() : SDKSample::CallControl::sealed
  • StopBadgePolling_Click() : SDKSample::SDKTemplate::sealed
  • StopCapture() : SDKSample::WASAPIAudio::sealed
  • StopCaptureAsync() : SDKSample::WASAPIAudio::WASAPICapture
  • StopDevice() : SDKSample::WASAPIAudio::sealed
  • StopEventLoop() : Samples::Devices::Fx2::sealed
  • StopFilters() : FrameProcessing
  • StopFx2Watcher()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • StopLayoutUpdates()
: SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • Stopped : Samples::Devices::Repeater
  • Stopping : Samples::Devices::Repeater
  • StopPlaybackAsync() : SDKSample::WASAPIAudio::WASAPIRenderer
  • StopPlayers() : SDKSample::Transcode::sealed
  • stopPlayToReceiver() : SDKSample::PlayToreceiver::sealed
  • StopPressedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • StopRecordingAsync()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • StopSound() : XAudio2SoundPlayer
  • StopSoundEffect() : Audio
  • StopSource() : SDKSample::WASAPIAudio::MFSampleGenerator
  • StopTilePolling_Click() : SDKSample::SDKTemplate::sealed
  • StopTimer() : MEPlayer
  • StopTracking() : SDKSample::GeolocationCPP::sealed
  • StopwatchTimer() : StopwatchTimer
  • storageItems : SDKSample::ShareSource::sealed
  • storeData : SDKSample::ListViewSimple::sealed
  • StoreData() : SDKSample::ListViewSampleDataSource::sealed
  • Stream : _SDKMESHVERTEXELEMENT
  • stream_id : MPEG1PacketHeader , MPEG1StreamHeader
  • streaming : SimpleCommunication::sealed
  • streaming_latencyModeToggled() : SimpleCommunication::sealed
  • streaming_previewButtonClicked() : SimpleCommunication::sealed
  • Streaming_PreviewButtonClicked() : SimpleCommunication::LowLatency
  • streaming_recordingStarted() : SimpleCommunication::sealed
  • StreamingError() : CMPEG1Source
  • StreamingVoiceContext() : StreamingVoiceContext
  • StreamList() : StreamList
  • streams : MPEG1SystemHeader
  • StreamsNeedData() : CMPEG1Source
  • StreamTypeAlert()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • StreamTypeCommunications() : SDKSample::PlaybackManager2::sealed
  • StreamTypeMedia()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • StreamTypeOther()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • streamWebSocket : SDKSample::WebSocket::sealed
  • Street : ContactPicker::sealed::SampleContact
  • StrictValidation : NotificationsExtensions::NotificationBase
  • StrideBytes : SDKMESH_VERTEX_BUFFER_HEADER
  • StringFromDouble() : SDKSample::Scaling::sealed
  • StringTemplate() : SDKSample::DateTimeFormatting::sealed
  • StrokeWidthSelection_ValueChanged() : SDKSample::Drawing::sealed
  • SubmitCertificateRequestAndGetResponse() : SDKSample::CertificateEnrollment::sealed
  • SubmitItem_Click() : SDKSample::AtomPub::sealed
  • SubsetDataOffset : SDKMESH_HEADER
  • SubsetOffset : SDKMESH_MESH
  • Subsets : SDKMESH_MESH
  • subType : SimpleCommunication::sealed::StreamFilteringCriteria
  • suggestionsRequestedToken : SDKSample::SearchContract::sealed
  • Suspend() : XAudio2SoundPlayer
  • SuspendAudio() : Audio
  • SuspendDeviceWatcher()
: SDKSample::CustomDeviceAccess::DeviceList
, CustomDeviceAccess::DeviceList
  • Suspending() : SDKSample::MediaCapture::sealed
  • Swap() : PrintSample::sealed
  • SwapIndices() : DirectX::D3DX_BC6H
  • Switch1 : _SWITCH_STATE
  • Switch2 : _SWITCH_STATE
  • Switch3 : _SWITCH_STATE
  • Switch4 : _SWITCH_STATE
  • Switch5 : _SWITCH_STATE
  • Switch6 : _SWITCH_STATE
  • Switch7 : _SWITCH_STATE
  • Switch8 : _SWITCH_STATE
  • switchChangedEventsHandler : SDKSample::CustomDeviceAccess::sealed
  • switchChangedEventsRegistered : SDKSample::CustomDeviceAccess::sealed
  • SwitchesAsUChar : _SWITCH_STATE
  • SwitchKernel() : ConvolveMatrixEffect
  • SwitchMediaStreamAsync() : MediaStreamSource::PcmSource
  • SwitchRecordButtonContent()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
, MediaCapture::AudioCapture
, SDKSample::MediaCapture::sealed
  • SwitchStateChangedEventArgs() : Samples::Devices::Fx2::sealed
  • SyndicationItemIterator() : SDKSample::sealed
  • szAuthorComment : TGA_EXTENSION
  • szAuthorName : TGA_EXTENSION
  • szDest : SConversion
  • szJobName : TGA_EXTENSION
  • szSoftwareId : TGA_EXTENSION
  • szSrc : SConversion
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- t -

  • tag : HighScoreEntry , anonymous_namespace{SoundFileReader.cpp}::ChunkHeader
  • Target() : GameObject
  • target : WICConvert
  • Target() : GameObject
  • TargetButton() : SDKSample::HighContrast::sealed
  • TargetId() : GameObject
  • taskCompletedToken : SDKSample::GeolocationCPP::sealed
  • TaskInstance : Tasks::sealed
  • Team() : SDKSample::DataBinding::sealed
  • TeamDataSource() : SDKSample::DataBinding::sealed
  • TeamGroup() : SDKSample::DataBinding::sealed
  • Teams() : SDKSample::DataBinding::sealed
  • TemplateName : NotificationsExtensions::NotificationBase
  • TestVectorNonce : SDKSample::CryptoWinRT::sealed
  • tex : BasicVertex , TangentVertex , FractalVertex , ScreenQuadVertex , IndexTriplet , BasicSprites::ReplicationVertex , BasicSprites::InstancingVertex , ScreenVertex
  • texScale : DrawRectCB
  • Text : NotificationsExtensions::NotificationContentText
  • text : FPSCounter
  • TextAnalysis() : TextAnalysis
  • textBlock : SDKSample::TouchKeyboard::sealed
  • TextBlock
: NotificationsExtensions::TileContent::TileSquareBlock
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWideBlockAndText02
  • TextBody : NotificationsExtensions::ToastContent::ToastImageAndText03 , NotificationsExtensions::ToastContent::ToastText03
  • TextBody1
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileSquareText01
, NotificationsExtensions::TileContent::TileSquareText03
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWideText05
, NotificationsExtensions::ToastContent::ToastImageAndText04
, NotificationsExtensions::ToastContent::ToastText04
  • TextBody2
: NotificationsExtensions::ToastContent::ToastText04
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileSquareText01
, NotificationsExtensions::TileContent::TileSquareText03
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWideText05
, NotificationsExtensions::ToastContent::ToastImageAndText04
  • TextBody3
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileSquareText01
, NotificationsExtensions::TileContent::TileSquareText03
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWideText05
  • TextBody4
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileSquareText03
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWideText05
  • TextBody5 : NotificationsExtensions::TileContent::TileWidePeekImageAndText02 , NotificationsExtensions::TileContent::TileWideText05
  • TextBodyWrap
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
, NotificationsExtensions::TileContent::TileSquareText02
, NotificationsExtensions::TileContent::TileSquareText04
, NotificationsExtensions::TileContent::TileWideBlockAndText02
, NotificationsExtensions::TileContent::TileWidePeekImage01
, NotificationsExtensions::TileContent::TileWidePeekImage04
, NotificationsExtensions::TileContent::TileWidePeekImage05
, NotificationsExtensions::TileContent::TileWidePeekImageAndText01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWideSmallImageAndText03
, NotificationsExtensions::TileContent::TileWideSmallImageAndText04
, NotificationsExtensions::TileContent::TileWideSmallImageAndText05
, NotificationsExtensions::TileContent::TileWideText04
, NotificationsExtensions::TileContent::TileWideText09
, NotificationsExtensions::ToastContent::ToastImageAndText01
, NotificationsExtensions::ToastContent::ToastImageAndText02
, NotificationsExtensions::ToastContent::ToastText01
, NotificationsExtensions::ToastContent::ToastText02
  • TextBoxKeyUp() : Postcard::sealed
  • TextButton() : TextButton
  • TextCaption1 : NotificationsExtensions::TileContent::TileWideImageAndText02
  • TextCaption2 : NotificationsExtensions::TileContent::TileWideImageAndText02
  • TextCaptionWrap : NotificationsExtensions::TileContent::TileWideImageAndText01
  • TextColumn1Row1 : NotificationsExtensions::TileContent::TileWideText02 , NotificationsExtensions::TileContent::TileWideText06
  • TextColumn1Row2 : NotificationsExtensions::TileContent::TileWideText02 , NotificationsExtensions::TileContent::TileWideText06
  • TextColumn1Row3 : NotificationsExtensions::TileContent::TileWideText02 , NotificationsExtensions::TileContent::TileWideText06
  • TextColumn1Row4 : NotificationsExtensions::TileContent::TileWideText02 , NotificationsExtensions::TileContent::TileWideText06
  • TextColumn1Row5 : NotificationsExtensions::TileContent::TileWideText06
  • TextColumn2Row1
: NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileWideText11
  • TextColumn2Row2
: NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileWideText11
  • TextColumn2Row3
: NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileWideText11
  • TextColumn2Row4
: NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileWideText11
  • TextColumn2Row5
: NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText11
  • textDescription : Clipboard::sealed
  • TextElement() : TextElement
  • TextFields : NotificationsExtensions::NotificationBase
  • TextFlyout() : Postcard::sealed
  • textFormat : FPSCounter
  • TextHeading
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
, NotificationsExtensions::TileContent::TileSquareText01
, NotificationsExtensions::TileContent::TileSquareText02
, NotificationsExtensions::TileContent::TileWidePeekImage01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImage05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText04
, NotificationsExtensions::TileContent::TileWideSmallImageAndText05
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText09
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::ToastContent::ToastImageAndText02
, NotificationsExtensions::ToastContent::ToastImageAndText04
, NotificationsExtensions::ToastContent::ToastText02
, NotificationsExtensions::ToastContent::ToastText04
  • TextHeadingWrap
: NotificationsExtensions::TileContent::TileWidePeekImage03
, NotificationsExtensions::TileContent::TileWidePeekImage06
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
, NotificationsExtensions::TileContent::TileWideSmallImageAndText01
, NotificationsExtensions::TileContent::TileWideText03
, NotificationsExtensions::ToastContent::ToastImageAndText03
, NotificationsExtensions::ToastContent::ToastText03
  • textLength : TextAnalysis::Run
  • TextPrefixColumn1Row1 : NotificationsExtensions::TileContent::TileWideText10 , NotificationsExtensions::TileContent::TileWideText11
  • TextPrefixColumn1Row2 : NotificationsExtensions::TileContent::TileWideText10 , NotificationsExtensions::TileContent::TileWideText11
  • TextPrefixColumn1Row3 : NotificationsExtensions::TileContent::TileWideText10 , NotificationsExtensions::TileContent::TileWideText11
  • TextPrefixColumn1Row4 : NotificationsExtensions::TileContent::TileWideText10 , NotificationsExtensions::TileContent::TileWideText11
  • TextPrefixColumn1Row5 : NotificationsExtensions::TileContent::TileWideText11
  • TextShortColumn1Row1 : NotificationsExtensions::TileContent::TileWideText07 , NotificationsExtensions::TileContent::TileWideText08
  • TextShortColumn1Row2 : NotificationsExtensions::TileContent::TileWideText07 , NotificationsExtensions::TileContent::TileWideText08
  • TextShortColumn1Row3 : NotificationsExtensions::TileContent::TileWideText07 , NotificationsExtensions::TileContent::TileWideText08
  • TextShortColumn1Row4 : NotificationsExtensions::TileContent::TileWideText07 , NotificationsExtensions::TileContent::TileWideText08
  • TextShortColumn1Row5 : NotificationsExtensions::TileContent::TileWideText08
  • textStart : TextAnalysis::Run
  • TextStyle() : TextStyle
  • TextSubBlock
: NotificationsExtensions::TileContent::TileSquareBlock
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWideBlockAndText02
  • TextSubmitted : Postcard::sealed
  • textureCoordinate : PNTVertex
  • TextureLock() : TextureLock
  • textureResourceView : Material
  • textureView : BasicSprites::SpriteRunInfo
  • this : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • thumbnail : SDKSample::DeviceEnumeration::sealed
  • ThumbnailGenerator() : Hilo::ThumbnailGenerator
  • TileExists_Click() : SecondaryTiles::sealed
  • TileNotificationBase() : NotificationsExtensions::TileContent::TileNotificationBase
  • TilePinned() : SecondaryTiles::sealed
  • TileSquareBase() : NotificationsExtensions::TileContent::TileSquareBase
  • TileSquareBlock() : NotificationsExtensions::TileContent::TileSquareBlock
  • TileSquareImage() : NotificationsExtensions::TileContent::TileSquareImage
  • TileSquarePeekImageAndText01() : NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
  • TileSquarePeekImageAndText02() : NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
  • TileSquarePeekImageAndText03() : NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
  • TileSquarePeekImageAndText04() : NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
  • TileSquareText01() : NotificationsExtensions::TileContent::TileSquareText01
  • TileSquareText02() : NotificationsExtensions::TileContent::TileSquareText02
  • TileSquareText03() : NotificationsExtensions::TileContent::TileSquareText03
  • TileSquareText04() : NotificationsExtensions::TileContent::TileSquareText04
  • TileUpdateScheduler() : Hilo::TileUpdateScheduler
  • TileUpdateScheduler::ScheduleUpdateAsync() : Hilo::TileUpdateScheduler
  • TileUpdateScheduler::UpdateTile() : Hilo::TileUpdateScheduler
  • TileWideBase() : NotificationsExtensions::TileContent::TileWideBase
  • TileWideBlockAndText01() : NotificationsExtensions::TileContent::TileWideBlockAndText01
  • TileWideBlockAndText02() : NotificationsExtensions::TileContent::TileWideBlockAndText02
  • TileWideImage() : NotificationsExtensions::TileContent::TileWideImage
  • TileWideImageAndText01() : NotificationsExtensions::TileContent::TileWideImageAndText01
  • TileWideImageAndText02() : NotificationsExtensions::TileContent::TileWideImageAndText02
  • TileWideImageCollection() : NotificationsExtensions::TileContent::TileWideImageCollection
  • TileWidePeekImage01() : NotificationsExtensions::TileContent::TileWidePeekImage01
  • TileWidePeekImage02() : NotificationsExtensions::TileContent::TileWidePeekImage02
  • TileWidePeekImage03() : NotificationsExtensions::TileContent::TileWidePeekImage03
  • TileWidePeekImage04() : NotificationsExtensions::TileContent::TileWidePeekImage04
  • TileWidePeekImage05() : NotificationsExtensions::TileContent::TileWidePeekImage05
  • TileWidePeekImage06() : NotificationsExtensions::TileContent::TileWidePeekImage06
  • TileWidePeekImageAndText01() : NotificationsExtensions::TileContent::TileWidePeekImageAndText01
  • TileWidePeekImageAndText02() : NotificationsExtensions::TileContent::TileWidePeekImageAndText02
  • TileWidePeekImageCollection01() : NotificationsExtensions::TileContent::TileWidePeekImageCollection01
  • TileWidePeekImageCollection02() : NotificationsExtensions::TileContent::TileWidePeekImageCollection02
  • TileWidePeekImageCollection03() : NotificationsExtensions::TileContent::TileWidePeekImageCollection03
  • TileWidePeekImageCollection04() : NotificationsExtensions::TileContent::TileWidePeekImageCollection04
  • TileWidePeekImageCollection05() : NotificationsExtensions::TileContent::TileWidePeekImageCollection05
  • TileWidePeekImageCollection06() : NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • TileWideSmallImageAndText01() : NotificationsExtensions::TileContent::TileWideSmallImageAndText01
  • TileWideSmallImageAndText02() : NotificationsExtensions::TileContent::TileWideSmallImageAndText02
  • TileWideSmallImageAndText03() : NotificationsExtensions::TileContent::TileWideSmallImageAndText03
  • TileWideSmallImageAndText04() : NotificationsExtensions::TileContent::TileWideSmallImageAndText04
  • TileWideSmallImageAndText05() : NotificationsExtensions::TileContent::TileWideSmallImageAndText05
  • TileWideText01() : NotificationsExtensions::TileContent::TileWideText01
  • TileWideText02() : NotificationsExtensions::TileContent::TileWideText02
  • TileWideText03() : NotificationsExtensions::TileContent::TileWideText03
  • TileWideText04() : NotificationsExtensions::TileContent::TileWideText04
  • TileWideText05() : NotificationsExtensions::TileContent::TileWideText05
  • TileWideText06() : NotificationsExtensions::TileContent::TileWideText06
  • TileWideText07() : NotificationsExtensions::TileContent::TileWideText07
  • TileWideText08() : NotificationsExtensions::TileContent::TileWideText08
  • TileWideText09() : NotificationsExtensions::TileContent::TileWideText09
  • TileWideText10() : NotificationsExtensions::TileContent::TileWideText10
  • TileWideText11() : NotificationsExtensions::TileContent::TileWideText11
  • timeFormat : SDKSample::FileAccess::sealed
  • TimeLimit() : abstract
  • TimeRemaining() : Simple3DGame
  • timerTickToken : SDKSample::PlayTo::sealed
  • TimeStamp() : CStreamState
  • TimeTriggeredTask() : SDKSample::BackgroundTask::sealed
  • TimeTriggeredTaskProgress : SDKSample::BackgroundTask::BackgroundTaskSample
  • TimeTriggeredTaskRegistered : SDKSample::BackgroundTask::BackgroundTaskSample
  • title : SecondaryTiles::Scenario
  • Title
: SimpleCommunication::Scenario
, ProximityCPP::Scenario
, Clipboard::Scenario
, AccountPictureName::Scenario
, DeviceAppForPrinters::Scenario
, SDKSample::Scenario
, SDKTemplate::Scenario
, DatagramSocketSample::Scenario
, SDKSample::Scenario
, AppBarControl::Scenario
, ContactPicker::Scenario
, SimpleBlogReader::sealed
, StreamSocketSample::Scenario
  • titleBody : GameHud
  • titleLicenseInfo : GameHud
  • toast_Dismissed() : ToastsSampleCPP::sealed
  • toast_Failed() : ToastsSampleCPP::sealed
  • ToastAudio() : NotificationsExtensions::ToastContent::ToastAudio
  • toastContext : ToastsSampleCPP::sealed
  • ToastImageAndText01() : NotificationsExtensions::ToastContent::ToastImageAndText01
  • ToastImageAndText02() : NotificationsExtensions::ToastContent::ToastImageAndText02
  • ToastImageAndText03() : NotificationsExtensions::ToastContent::ToastImageAndText03
  • ToastImageAndText04() : NotificationsExtensions::ToastContent::ToastImageAndText04
  • ToastNotificationBase() : NotificationsExtensions::ToastContent::ToastNotificationBase
  • ToastText01() : NotificationsExtensions::ToastContent::ToastText01
  • ToastText02() : NotificationsExtensions::ToastContent::ToastText02
  • ToastText03() : NotificationsExtensions::ToastContent::ToastText03
  • ToastText04() : NotificationsExtensions::ToastContent::ToastText04
  • TOCButton_Click() : SDKSample::FlipViewCPP::sealed
  • ToF16() : DirectX::INTColor
  • ToggleAppBarButton() : SecondaryTiles::sealed
  • ToggleButtons() : SecondaryTiles::sealed
  • ToggleScenario2() : SDKSample::Animation::sealed
  • ToHex() : SDKSample::DataReaderWriter::sealed
  • token
: SDKSample::FilePickerContracts::sealed
, SDKSample::SearchContract::sealed
, ContactPicker::sealed
, SDKSample::MainPage
  • ToLDRColorA() : DirectX::HDRColorA
  • ToneSampleGenerator() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • ToString()
: SDKTemplate::Scenario
, NotificationsExtensions::NotificationBase
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, SDKTemplate::Scenario
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::NotificationBase
, SDKTemplate::Scenario
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, SDKTemplate::Scenario
  • TotalHits() : Simple3DGame
  • totalHits : HighScoreEntry
  • TotalHits() : Simple3DGame
  • totalShots : HighScoreEntry
  • TotalShots() : Simple3DGame
  • TotalTime : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • ToTwoDecimalPlaces() : Hilo::sealed
  • Touch() : SDKSample::DeviceCaps::sealed
  • TouchableTextBlock() : SDKSample::TouchKeyboard::sealed
  • TouchableTextBlockAutomationPeer() : SDKSample::TouchKeyboard::sealed
  • TouchableTextBlockRangeProvider() : SDKSample::TouchKeyboard::sealed
  • TouchGetSettings_Click() : SDKSample::DeviceCaps::sealed
  • TouchMap : MarbleMaze
  • trackInner : SDKSample::MediaButtons::sealed
  • TranscodeCancel() : SDKSample::Transcode::sealed
  • TranscodeComplete() : SDKSample::Transcode::sealed
  • TranscodeCustom() : SDKSample::Transcode::sealed
  • TranscodeError() : SDKSample::Transcode::sealed
  • TranscodeFailure() : SDKSample::Transcode::sealed
  • TranscodePreset() : SDKSample::Transcode::sealed
  • TranscodeProgress() : SDKSample::Transcode::sealed
  • TranscodeTrim() : SDKSample::Transcode::sealed
  • TransferData() : SDKSample::DataReaderWriter::sealed
  • TransferFileFromDeviceToAppLocalFolderAsync() : SDKSample::PortableDeviceCPP::sealed
  • TransferFileToDeviceAsync() : SDKSample::PortableDeviceCPP::sealed
  • TransformBindPose() : SDKMesh
  • TransformBindPoseFrame() : SDKMesh
  • TransformBounds() : sealed
  • TransformedPageSize() : CDocumentSource
  • TransformFrame() : SDKMesh
  • TransformFrameAbsolute() : SDKMesh
  • TransformMesh() : SDKMesh
  • Translate() : Shape
  • Translation : SDKANIMATION_DATA
  • translationX : ViewTransform
  • translationY : ViewTransform
  • Transliteration() : SDKSample::ELS::sealed
  • TravelDistance : AntSystem::Edge
  • TravelMode : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • TreeIterator() : TreeIterator< T >
  • TrialMode() : SDKSample::StoreSample::sealed
  • TrialModeRefreshScenario() : SDKSample::StoreSample::sealed
  • TrialProduct_Click() : SDKSample::StoreSample::sealed
  • TrialTime_Click() : SDKSample::StoreSample::sealed
  • Triangle() : Triangle
  • triangle : Contact
  • Triangle_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput2
  • trianglesCount : Extruder::ExtrudingSink
  • Trigger_Click() : SDKSample::PortableDeviceCPP::sealed
  • TriggeredConnectionStateChangedEventHandler() : ProximityCPP::sealed
  • TriggerSoundEffect() : AudioController
  • triIndex : Contact
  • Trim()
: SDKSample::Transcode::sealed
, SDKSample::StringTrimmer
, SDKSample::Helpers
, SDKSample::StringHelper
, SDKSample::StringTrimmer
  • TripOptimizer() : TripOptimizerComponent::sealed
  • TryGetValue() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • TryProduct1_Click() : SDKSample::StoreSample::sealed
  • TryProduct2_Click() : SDKSample::StoreSample::sealed
  • TryTransform() : sealed
  • type : MPEG1StreamHeader
  • Type : _SDKMESHVERTEXELEMENT
  • type : PageRendererContext , MPEG1PacketHeader
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- u -

  • u : Vector2< T > , Vector3< T > , AmpPixel
  • UI() : SDKSample::HighContrast::sealed
  • UIGetSettings_Click() : SDKSample::HighContrast::sealed
  • uIndexModeBits : DirectX::D3DX_BC7::ModeInfo
  • uIndexPrec : DirectX::D3DX_BC6H::ModeInfo , DirectX::D3DX_BC7::ModeInfo
  • uIndexPrec2 : DirectX::D3DX_BC7::ModeInfo
  • UINT : Extruder::ExtrudingSink , PointSnapper::PointSnappingSink
  • uiPercentOfScreen : IMft0Vtbl
  • uLength : LineSegment
  • ULONG() : IMft0Vtbl
  • uMode
: DirectX::D3DX_BC6H::ModeInfo
, DirectX::D3DX_BC6H::EncodeParams
, DirectX::D3DX_BC7::EncodeParams
  • Uninitialize() : DirectXApp , SaveAsImageFile , DirectXApp , Direct3DTutorialFrameworkView , D2DTextAnimation , Direct3DTutorialFrameworkView , DirectXApp , D2DBasicAnimation , DirectXApp , DWriteCustomTextRenderer , D2DEffectsHelloWorld , DWriteHelloWorld , DWriteHitTesting , CommandListRenderer , DWriteInlineObject , DWriteParagraphText , CompositeModes , DWriteVerticalText , DirectXApp , ConvolveMatrixEffect , DirectXApp , CoreWindowEvents , D2DEffectsOnPrimitives , DirectXApp , GeometryRealizationSample , DirectXApp , sealed , D2DInterpolationModes , sealed , D2DPerspectiveTransform , sealed , DirectXApp
  • uninitialized : SimpleCommunication::sealed
  • Unlock() : VideoBufferLock
  • UnlockBuffer() : VideoBufferLock
  • UnlockRegion() : ImageFile
  • UnlockScenarioChange() : SimpleCommunication::sealed
  • UnpinSecondaryTile_Click() : SecondaryTiles::sealed
  • UnpinTile() : SecondaryTiles::sealed
  • Unquantize()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • UnregisterBackgroundTask()
: SDKSample::BackgroundTask::sealed
, SDKSample::GeolocationCPP::sealed
, RawNotificationsSampleCPP::sealed
  • UnregisterBackgroundTasks()
: SDKSample::BackgroundTask::BackgroundTaskSample
, SDKSample::BackgroundTaskSample
  • UnregisterElement() : UserInterface
  • UnregisterForDeviceEvents() : SDKSample::PortableDeviceCPP::sealed
  • UnRegisterForNetworkStatusChangeNotif() : SDKSample::NetworkInformationApi::sealed
  • UnregisterForPrinting() : PrintSample::BasePrintPage
  • UnregisterFrame()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
  • UnregisterTaskButton_Click() : SDKSample::SDKTemplate::sealed
  • UnresolvedLocations : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • UnscaledToClient() : Shape
  • Unsnap() : Hilo::sealed
  • UnsnapButton_Click() : SDKSample::SnapSample::sealed
  • Up() : Camera
  • uPartitionBits : DirectX::D3DX_BC7::ModeInfo
  • uPartitions : DirectX::D3DX_BC6H::ModeInfo , DirectX::D3DX_BC7::ModeInfo
  • uPBits : DirectX::D3DX_BC7::ModeInfo
  • Update() : BasicTimer , SimpleController , BasicTimer , CommandListRenderer , BasicTimer , GeometryRealization , BasicTimer , BumpMapping , LonLatController , AutoThrottle , BasicTimer , DirectXFractal , BasicTimer , D3DPostProcessing , BasicTimer , LonLatController , ResourceLoading , AutoThrottle , BasicTimer , SimpleSprites , BasicTimer , StereoSimpleD3D , BasicTimer , Direct3DTutorial , BasicTimer , TextInterop , DirectXApp , GameTimer , abstract , Level2 , Level4 , Level6 , AudioController , MoveLookController , Sphere , BasicTimer , Sphere , MarbleMaze , ElementBase , TextElement , Level2 , CountdownTimer , StopwatchTimer , TextButton , HighScoreTable , UserInterface , BasicTimer , MoveLookController , Simple3DTouch , BasicTimer , OfferReclaimAPI , BasicTimer , DxgiRotation , Simple3DGameXaml::sealed , GameTimer , abstract , Level4 , Level6 , MoveLookController , BasicTimer , StreamEffect
  • UpdateAlpha() : CompositeModes
  • UpdateArrowForRotation() : SDKSample::DisplayOrientation::sealed
  • UpdateAsync() : SecondaryTiles::sealed
  • UpdateBackgroundTaskStatus()
: SDKSample::BackgroundTask::BackgroundTaskSample
, SDKSample::BackgroundTaskSample
  • UpdateBadge_Click() : SDKSample::Tiles::sealed
  • UpdateBadgeWithGlyph() : SDKSample::Tiles::sealed
  • UpdateBadgeWithGlyphWithStringManipulation() : SDKSample::Tiles::sealed
  • UpdateBadgeWithNumber() : SDKSample::Tiles::sealed
  • UpdateBadgeWithNumberWithStringManipulation() : SDKSample::Tiles::sealed
  • UpdateBarGraphTable()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • UpdateBars() : Samples::Devices::Fx2::sealed
  • UpdateButtonState() : SDKSample::FilePickerContracts::sealed
  • UpdateCharacterSpacing() : DWriteParagraphText
  • UpdateCheckpoints() : MarbleMaze
  • UpdateConstants() : RippleEffect , WaveEffect
  • UpdateContent() : ContentImageSource , Simple3DGameXaml::sealed , Magazine::sealed
  • UpdateContentProps() : SDKSample::WASAPIAudio::sealed
  • UpdateContentUI() : SDKSample::WASAPIAudio::sealed
  • UpdateContentWithValues() : Hilo::WideFiveImageTile
  • UpdateCost() : SDKSample::ProvisioningAgent::sealed
  • UpdateCost_Click() : SDKSample::ProvisioningAgent::sealed
  • UpdateCropOverlayPostion() : Hilo::sealed
  • UpdateDefaultLogo_Click() : SecondaryTiles::sealed
  • UpdateDesign() : Document
  • UpdateDisplayText() : GeometryRealizationSample
  • UpdateDsp() : Wrapper::sealed
  • UpdateDX11Device() : CInvert
  • UpdateDynamics() : Simple3DGame
  • UpdateEffectMatrices() : D2DInterpolationModes
  • UpdateFormatInfo() : CGrayscale , CInvert , CPolarEffect , CInvert , CPolarEffect , CGrayscale
  • UpdateForViewState() : SDKSample::SnapSample::sealed
  • UpdateForViewStateChanged() : D2D3DTransformsRenderer , PostcardRenderer , D2DLightingEffectsRenderer
  • UpdateForWindowSizeChange() : abstract , SampleOverlay , abstract , SampleOverlay , GameRenderer , abstract , SampleOverlay , abstract , SampleOverlay , abstract , PostcardRenderer , abstract , SampleOverlay , abstract , SampleOverlay , abstract , GameHud , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , GeometryRealizationSample , abstract , SampleOverlay , abstract , SampleOverlay , abstract , GameHud , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , GameRenderer , PageRenderer , SampleOverlay , LoadScreen , abstract , SampleOverlay , MEPlayer , PageRenderer , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract
  • UpdateGameConfig() : Simple3DGame
  • UpdateGameController() : MoveLookController
  • UpdateGeometryRendering() : GeometryRealizationSample
  • UpdateImageZoom() : ImageRenderer
  • UpdateInterpenetrations() : Collision
  • UpdateItem_Click() : SDKSample::AtomPub::sealed
  • UpdateJustification() : DWriteParagraphText
  • UpdateListener()
: RawNotificationsSampleCPP::sealed
, SDKSample::SDKTemplate::sealed
  • UpdateLocalClientWindow() : SimpleCommunication::sealed
  • UpdateManipulationTransform() : ManipulatableObject
  • UpdateMatrix() : Face
  • UpdateMediaControlUI() : SDKSample::WASAPIAudio::sealed
  • UpdateModelAndCamera() : ExtrudedTextRenderer
  • UpdatePhysicsSimulation() : Physics
  • UpdatePosition() : GameObject , Cylinder , Face , Cylinder , GameObject , Face
  • UpdateRegisterButton() : SDKSample::CustomDeviceAccess::sealed
  • UpdatesNeeded() : ContentImageSource
  • UpdateStartStopButtons() : SDKSample::CustomDeviceAccess::sealed
  • UpdateStereoEnabledStatus() : abstract
  • UpdateSwitchStateTable() : SDKSample::CustomDeviceAccess::sealed
  • UpdateTargetBox() : PageRendererContext
  • UpdateText() : HighScoreTable
  • UpdateTextGeometry() : ExtrudedTextRenderer
  • UpdateTile_Click() : SDKSample::Tiles::sealed
  • UpdateTileExpiring_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithImage_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithImageWithStringManipulation_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithText_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithTextWithStringManipulation_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithWebImage_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithWebImageWithStringManipulation_Click() : SDKSample::Tiles::sealed
  • UpdateTouch() : MarbleMaze
  • UpdateUI()
: SDKSample::FilePickerContracts::sealed
, SDKSample::ThreadPool::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::BackgroundTask::sealed
, SDKSample::ThreadPool::sealed
, SDKSample::BackgroundTask::sealed
  • UpdateUsage() : SDKSample::ProvisioningAgent::sealed
  • UpdateUsage_Click() : SDKSample::ProvisioningAgent::sealed
  • UpdateViewState() : Simple3DGameXaml::sealed , DirectXApp
  • UpdateWindowSize() : Renderer
  • UpdateWorkItemProgressUI() : SDKSample::ThreadPool::sealed
  • UploadProgress() : SDKSample::BackgroundTransfer::sealed
  • Uri : SimpleBlogReader::sealed
  • uriToLaunch : AssociationLaunching::sealed
  • uRotationBits : DirectX::D3DX_BC7::ModeInfo
  • Usage : _SDKMESHVERTEXELEMENT
  • UsageIndex : _SDKMESHVERTEXELEMENT
  • user : SDKSample::sealed
  • UserInterface() : UserInterface
  • UserNameField_TextChanged() : SDKSample::AtomPub::sealed
  • UserPreferences() : SDKSample::GlobalizationPreferencesSample::sealed
  • uShape : DirectX::D3DX_BC6H::EncodeParams
  • UsingLogicalPageNavigation() : SimpleBlogReader::sealed
  • uStart : LineSegment
  • uTan : TangentVertex
  • Util() : SDKSample::ProvisioningAgent::sealed
  • util : SDKSample::ProvisioningAgent::sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- v -

  • v : Vector2< T > , Vector3< T > , AmpPixel
  • ValidateAndGetUri() : SDKSample::ShareSource::sealed
  • ValidateAudio() : NotificationsExtensions::ToastContent::ToastNotificationBase
  • ValidateBufferValue() : SDKSample::WASAPIAudio::WASAPIRenderer
  • ValidateDevice() : abstract
  • ValidateFile() : SDKSample::MainPage
  • ValidateOperation() : OpQueue< T, TOperation > , CMPEG1Source , OpQueue< T, TOperation > , CMPEG1Source , OpQueue< T, TOperation >
  • ValidatePresentationDescriptor() : CMPEG1Source
  • ValueFromPoint() : UiaCoreWindowProvider::ITriColorControlInternal , sealed
  • Values : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • ValueToString() : TriColorValueHelper
  • Vector2() : Vector2< T >
  • Vector3() : Vector3< T >
  • Vector4() : Vector4< T >
  • VectorChanged() : SDKSample::DataBinding::sealed
  • vectorChangedHandlerToken : SDKSample::DataBinding::sealed
  • VectorPosition() : GameObject
  • VectorVelocity() : GameObject
  • VectorViewToString() : SDKSample::GlobalizationPreferencesSample::sealed
  • vel : AsteroidData , ParticleData
  • Velocity() : GameObject , MoveLookController , GameObject , MoveLookController , GameObject
  • Version : SDKMESH_HEADER , SDKANIMATION_FILE_HEADER
  • VersionString() : SDKSample::PackageSample::sealed
  • VertexBuffer : SDKMESH_VERTEX_BUFFER_HEADER
  • VertexBuffers : SDKMESH_MESH
  • VertexCount : SDKMESH_SUBSET
  • vertexShader : Material
  • VertexStart : SDKMESH_SUBSET
  • VertexStreamHeadersOffset : SDKMESH_HEADER
  • vertical : Alignment
  • VIDEO_FILE_NAME : MediaCapture::BasicCapture
  • VideoBufferLock() : VideoBufferLock
  • VideoChat()
: SimpleCommunication::VideoChat
, SimpleCommunication::sealed
  • videoDevController : DeviceAppForWebcam::sealed , SDKTemplate::DeviceAppPage
  • videoFile_Click() : SDKSample::PlayTo::sealed
  • VideoOnError()
: MediaExtensionsCPP::sealed
, SDKTemplateCS::MainPage
  • VideoPlaybackErrorHandler() : SimpleCommunication::sealed
  • VideoRotationLookup() : SDKSample::MediaCapture::sealed
  • View() : Camera
  • view : ConstantBuffer , ConstantBufferChangesEveryFrame , ConstantBuffer
  • ViewablePageSize : PrintSample::PageDescription
  • ViewCurrentResources_Click() : SDKSample::Tiles::sealed
  • ViewDetail_Click() : SimpleBlogReader::sealed
  • viewerDistance : StereoParameters
  • viewerDistanceInches : STEREO_PARAMETERS
  • ViewModelLocator() : Hilo::sealed
  • viewportHeight : StereoParameters
  • viewportWidth : StereoParameters
  • ViewSize() : IRenderer
  • viewState : SDKTemplate::MainPageSizeChangedEventArgs
  • ViewState : SDKTemplate::MainPageSizeChangedEventArgs
  • VisibilityChanged()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SimpleCommunication::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::AccelerometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::AccelerometerCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
  • visibilityChangedToken : Clipboard::sealed
  • visibilityToken
: SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::AccelerometerCPP::sealed
  • Visible() : GameInfoOverlay
  • vsbvCombo_SelectionChanged() : SDKSample::ScrollViewerCPP::sealed
  • vsmCombo_SelectionChanged_1() : SDKSample::ScrollViewerCPP::sealed
  • vTan : TangentVertex
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- w -

  • w : Vector3< T > , Vector4< T > , DirectX::Rect
  • WaitForPress() : MoveLookController
  • waiting : SimpleCommunication::sealed
  • waiting_previewButtonClicked() : SimpleCommunication::sealed
  • Waiting_PreviewButtonClicked() : SimpleCommunication::LowLatency
  • WarpTheta() : CPolarEffect
  • WASAPICapture() : SDKSample::WASAPIAudio::WASAPICapture
  • WASAPIRenderer() : SDKSample::WASAPIAudio::WASAPIRenderer
  • wasJustAdded : HighScoreEntry
  • WatcherStarted : CustomDeviceAccess::DeviceList
  • WaveEffect() : WaveEffect
  • waveOffset : WaveEffect
  • Waypoints : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • Wb : Utils
  • wColorMapFirst : TGA_HEADER
  • wColorMapLength : TGA_HEADER
  • webContent_Click() : SDKSample::PlayTo::sealed
  • WebView1_LoadCompleted() : SDKSample::WebViewControl::sealed
  • WebView4_ScriptNotify() : SDKSample::WebViewControl::sealed
  • WebView5_LoadCompleted() : SDKSample::WebViewControl::sealed
  • WebView5_ScriptNotify() : SDKSample::WebViewControl::sealed
  • WebView7_LoadCompleted() : SDKSample::WebViewControl::sealed
  • WelcomeMessage_TextChanged() : SDKSample::PasswordVaultCPP::sealed
  • wFlags : MPEG1AudioFrameHeader
  • Wg : Utils
  • wGammaDenominator : TGA_EXTENSION
  • wGammaNumerator : TGA_EXTENSION
  • wHeight : TGA_HEADER
  • wic : WICTranslate
  • wicFactory : BasicLoader , LoadScreen
  • WideFiveImageTile() : Hilo::WideFiveImageTile
  • width : DDS_HEADER , DirectX::TexMetadata , DirectX::Image , MPEG1VideoSeqHeader
  • Window_VisibilityChanged() : SimpleCommunication::LowLatency
  • WindowSizeChanged()
: SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • windowVisible : Clipboard::sealed
  • WinRTComponent() : Wrapper::sealed
  • wJobHour : TGA_EXTENSION
  • wJobMinute : TGA_EXTENSION
  • wJobSecond : TGA_EXTENSION
  • WorkEmail : ContactPicker::sealed::SampleContact
  • WorkItemScenario() : SDKSample::ThreadPool::sealed
  • WorkPhone : ContactPicker::sealed::SampleContact
  • World() : Camera
  • worldMatrix : ConstantBufferChangesEveryPrim
  • wPixelDenominator : TGA_EXTENSION
  • wPixelNumerator : TGA_EXTENSION
  • Wr : Utils
  • Write() : ImageFile
  • WriteBytesButton_Click() : SDKSample::FileAccess::sealed
  • WriteCompositeSetting_Click() : SDKSample::ApplicationDataSample::sealed
  • WriteData() : BasicReaderWriter
  • WriteDataAsync() : BasicReaderWriter
  • WriteFileButton_Click() : SDKSample::FilePicker::sealed
  • WriteLocalizedYearAndMonth() : Hilo::CalendarExtensions
  • WriteOutputText() : SDKSample::ApplicationDataSample::sealed
  • writer : ScenarioContext , DatagramSocketSample::sealed
  • WriteReadStream() : SDKSample::DataReaderWriter::sealed
  • WriteSetting_Click() : SDKSample::ApplicationDataSample::sealed
  • WriteTextButton_Click() : SDKSample::FileAccess::sealed
  • WriteToStreamButton_Click() : SDKSample::FileAccess::sealed
  • wSize : TGA_EXTENSION
  • wStampDay : TGA_EXTENSION
  • wStampHour : TGA_EXTENSION
  • wStampMinute : TGA_EXTENSION
  • wStampMonth : TGA_EXTENSION
  • wStampSecond : TGA_EXTENSION
  • wStampYear : TGA_EXTENSION
  • wVersionNumber : TGA_EXTENSION
  • wWidth : TGA_HEADER
  • wXOrigin : TGA_HEADER
  • wYOrigin : TGA_HEADER
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- x -

  • x : WaveEffect::Vertex , Vector2< T > , Vector4< T > , DirectX::Rect , Vector3< T >
  • XAudio2SoundPlayer() : XAudio2SoundPlayer
  • Xpress_Click() : SDKSample::Compression::sealed
  • XpressHuff_Click() : SDKSample::Compression::sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z
  • ~
Here is a list of all class members with links to the classes they belong to:

- y -

  • y : WaveEffect::Vertex , Vector2< T > , Vector4< T > , DirectX::Rect , Vector3< T > , AmpPixel
  • Yaw() : MoveLookController , Camera , MoveLookController
  • Yellow : sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Enumerations

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • EField : DirectX::D3DX_BC6H
  • LatencyMode : SimpleCommunication::LowLatency
  • LatencyModes : SimpleCommunication::sealed
  • MediaType : SDKSample::PlayToreceiver::sealed
  • NotifyType : SDKSample::Helpers
  • Operation : SourceOp
  • ReaderState : SDKSample::WASAPIAudio::MFSampleGenerator
  • RepeaterState : Samples::Devices::Repeater
  • Role : SimpleCommunication::sealed
  • ScenarioOneStates : SimpleCommunication::sealed
  • State : SimpleCommunication::LowLatency
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Enumerator

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • a
  • b
  • d
  • e
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • u
  • w

- a -

  • active : SimpleCommunication::sealed
  • AudioVisual : SDKSample::PlayToreceiver::sealed

- b -

  • BW : DirectX::D3DX_BC6H
  • BX : DirectX::D3DX_BC6H
  • BY : DirectX::D3DX_BC6H
  • BZ : DirectX::D3DX_BC6H

- d -

  • D : DirectX::D3DX_BC6H

- e -

  • end : SimpleCommunication::sealed
  • ErrorMessage : SDKSample::Helpers

- g -

  • GW : DirectX::D3DX_BC6H
  • GX : DirectX::D3DX_BC6H
  • GY : DirectX::D3DX_BC6H
  • GZ : DirectX::D3DX_BC6H

- h -

  • highLatency : SimpleCommunication::sealed

- i -

  • Image : SDKSample::PlayToreceiver::sealed
  • initializing : SimpleCommunication::sealed

- l -

  • lowLatency : SimpleCommunication::sealed

- m -

  • M : DirectX::D3DX_BC6H

- n -

  • NA : DirectX::D3DX_BC6H
  • None : SDKSample::PlayToreceiver::sealed

- o -

  • OP_END_OF_STREAM : SourceOp
  • OP_PAUSE : SourceOp
  • OP_REQUEST_DATA : SourceOp
  • OP_SETRATE : SourceOp
  • OP_START : SourceOp
  • OP_STOP : SourceOp

- p -

  • passive : SimpleCommunication::sealed
  • previewing : SimpleCommunication::sealed

- r -

  • ReaderStateEOS : SDKSample::WASAPIAudio::MFSampleGenerator
  • ReaderStatePlaying : SDKSample::WASAPIAudio::MFSampleGenerator
  • ReaderStatePreRoll : SDKSample::WASAPIAudio::MFSampleGenerator
  • ReaderStateStopped : SDKSample::WASAPIAudio::MFSampleGenerator
  • Running : Samples::Devices::Repeater
  • RW : DirectX::D3DX_BC6H
  • RX : DirectX::D3DX_BC6H
  • RY : DirectX::D3DX_BC6H
  • RZ : DirectX::D3DX_BC6H

- s -

  • StatusMessage : SDKSample::Helpers
  • Stopped : Samples::Devices::Repeater
  • Stopping : Samples::Devices::Repeater
  • streaming : SimpleCommunication::sealed

- u -

  • uninitialized : SimpleCommunication::sealed

- w -

  • waiting : SimpleCommunication::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Events

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • CaptureFailed : SimpleCommunication::Common::CaptureDevice
  • DeviceClosing : CustomDeviceAccess::DeviceList
  • IncomingConnectionArrived : SimpleCommunication::Common::CaptureDevice
  • InputFrameLoaded : SDKTemplateCS::MainPage
  • MainPageResized : SDKTemplate::MainPage
  • MapChanged : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • OutputFrameLoaded : SDKTemplateCS::MainPage
  • ScenarioLoaded : SDKTemplate::MainPage
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- _ -

  • _Acquires_lock_() : CritSec , AutoLock , CritSec , AutoLock , CMPEG1Source , CMPEG1Stream::SourceLock
  • _message() : SimpleCommunication::CaptureFailedEventArgs
  • _Releases_lock_() : CritSec , AutoLock , CritSec , AutoLock , CMPEG1Stream::SourceLock , CMPEG1Source
  • _storageVectorChanged() : SDKSample::DataBinding::IncrementalLoadingBase
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- j -

  • Join() : SDKSample::StringHelper
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- k -

  • Keyboard() : SDKSample::DeviceCaps::sealed
  • KeyboardGetSettings_Click() : SDKSample::DeviceCaps::sealed
  • KeyDown() : MarbleMaze
  • KeyUp() : MarbleMaze
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- l -

  • Landscape() : SDKSample::Rotation::sealed
  • LandscapeFlipped() : SDKSample::Rotation::sealed
  • LanguageDetection() : SDKSample::ELS::sealed
  • LanguageScenario() : SDKSample::GlobalizationPreferencesSample::sealed
  • LanId() : SDKSample::NetworkInformationApi::sealed
  • LanId_Click() : SDKSample::NetworkInformationApi::sealed
  • LatencyModeToggle_Toggled() : SimpleCommunication::LowLatency
  • LatencyModeToggled() : SimpleCommunication::sealed
  • LatLong() : AntSystem::LatLong
  • Launch() : SDKSample::TouchKeyboard::sealed
  • Launch_Click()
: CredentialPickerCPP::sealed
, SDKSample::WebAuthentication::sealed
, SDKSample::PasswordVaultCPP::sealed
, CredentialPickerCPP::sealed
  • Launch_Click1() : SDKSample::EAS::sealed
  • Launch_Click2() : SDKSample::EAS::sealed
  • Launch_Click3() : SDKSample::EAS::sealed
  • LaunchedFromSecondaryTile() : SecondaryTiles::sealed
  • LaunchFileButton_Click() : AssociationLaunching::sealed
  • LaunchFileInput() : AssociationLaunching::sealed
  • LaunchFileOpenWithButton_Click() : AssociationLaunching::sealed
  • LaunchFileOutput() : AssociationLaunching::sealed
  • LaunchFileWithWarningButton_Click() : AssociationLaunching::sealed
  • LaunchUriButton_Click() : AssociationLaunching::sealed
  • LaunchUriInput() : AssociationLaunching::sealed
  • LaunchUriOpenWithButton_Click() : AssociationLaunching::sealed
  • LaunchUriOutput() : AssociationLaunching::sealed
  • LaunchUriWithWarningButton_Click() : AssociationLaunching::sealed
  • LayoutAwarePage() : SDKTemplate::Common::LayoutAwarePage
  • LDRColorA() : DirectX::LDRColorA
  • LearnMoreButton_Click() : SDKSample::SplashScreen::sealed
  • LeftEyeProjection() : Camera
  • LevelActive() : Simple3DGame
  • LevelCompleted() : Simple3DGame
  • LicenseChanged() : Simple3DGameXaml::sealed
  • LimitManipulationScale() : ManipulatableObject
  • LinearAnimation() : LinearAnimation< T >
  • LinearInterpolate() : CommandListRenderer
  • LinkedRun() : TextAnalysis::LinkedRun
  • LinkField_Click() : SDKSample::Syndication::sealed
  • List() : List< T >
  • ListenerContext()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • ListStorages_Click() : SDKSample::RemovableStorageCPP::sealed
  • ListSystemFonts() : FontEnumeration::sealed
  • Load() : GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , DirectXApp , SaveAsImageFile , DirectXApp , Direct3DTutorialFrameworkView , DirectXApp , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , DWriteVerticalText , DirectXApp , CoreWindowEvents , DirectXApp , sealed , DirectXApp , D2DTextAnimation , D2DBasicAnimation , D2DEffectsHelloWorld , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , D2DEffectsOnPrimitives
  • Load_Click() : SDKSample::WebViewControl::sealed
  • LoadAnimation() : SDKMesh
  • LoadAppListingUriProxyFile() : SDKSample::StoreSample::sealed
  • LoadAsync() : Document , FontLoader , ImageFile
  • LoadBitmap() : PrintSample::sealed
  • LoadBitmapFromFile() : InlineImage
  • LoadBool() : PersistentState
  • LoadContentAsync() : SDKSample::TextEditing::sealed
  • LoadData() : ScheduledNotificationsSampleCPP::sealed
  • LoadDeferredResources() : MarbleMaze
  • LoadExpiringProductProxyFile() : SDKSample::StoreSample::sealed
  • LoadGame() : Simple3DGame
  • LoadGradient() : SDKSample::Drawing::sealed
  • LoadHighScore() : Simple3DGame
  • LoadImage() : ImageRenderer , PostcardRenderer
  • LoadInAppPurchaseProxyFile() : SDKSample::StoreSample::sealed
  • LoadInt32() : PersistentState
  • LoadInternalState() : BumpMapping , LonLatController , DirectXFractal , LonLatController , ResourceLoading , MoveLookController , Simple3DTouch
  • LoadLevelAsync() : Simple3DGame
  • LoadLevelResourcesAsync() : GameRenderer
  • LoadMaterials() : SDKMesh
  • LoadMedia() : MediaReader
  • LoadMediaFiles() : SDKSample::MediaServerClient::sealed
  • LoadMesh() : BasicLoader
  • LoadMeshAsync() : BasicLoader
  • LoadMoreItemsOverride() : SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • LoadPhoto() : SDKSample::CameraCapture::sealed
  • LoadReceiptProxyFile() : SDKSample::StoreSample::sealed
  • LoadScenario()
: SimpleCommunication::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
  • LoadSetAccountPictureScenario() : AccountPictureName::MainPage
  • LoadShader() : BasicLoader
  • LoadShaderAsync() : BasicLoader
  • LoadSingle() : PersistentState
  • LoadState()
: SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, Hilo::HiloPage
, SDKSample::Common::LayoutAwarePage
, Level4
, Magazine::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, Level2
, Hilo::sealed
, SDKSample::Common::LayoutAwarePage
, Hilo::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SimpleBlogReader::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::ViewModelBase
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Level2
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, Simple3DGame
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FilePickerContracts::sealed
, Simple3DGame
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, abstract
, SDKSample::Common::LayoutAwarePage
, MarbleMaze
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, abstract
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Level4
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
  • LoadString() : PersistentState
  • LoadTexture() : BasicLoader
  • LoadTextureAsync() : BasicLoader
  • LoadTrialModeProxyFile() : SDKSample::StoreSample::sealed
  • LoadVideo() : SDKSample::CameraCapture::sealed
  • LoadXMFLOAT3() : PersistentState
  • LocalClientButtonClicked() : SimpleCommunication::sealed
  • LocalTransform() : ManipulatableObject
  • localVideo_CurrentStateChanged() : SDKSample::MediaServerClient::sealed
  • localVideo_MediaFailed() : SDKSample::MediaServerClient::sealed
  • LocationBackgroundTask() : BackgroundTask::sealed
  • Lock() : VideoBufferLock
  • LockBuffer() : VideoBufferLock
  • LockDevice() : CAutoDXGILock , CAutoDXDevLockBase< DevManager, DevInterface >
  • LockRegion() : ImageFile
  • LockScenarioChange() : SimpleCommunication::sealed
  • Log()
: SDKSample::BackgroundTransfer::sealed
, SimpleCommunication::SdkSample
, SDKSample::BackgroundTransfer::sealed
  • LogException() : SDKSample::BackgroundTransfer::sealed
  • LogInfo() : ProximityCPP::sealed
  • LogStatus() : SDKSample::BackgroundTransfer::sealed
  • LongAndShortFormats() : SDKSample::DateTimeFormatting::sealed
  • LongRunningShareLabel_Tapped() : ShareTarget::sealed
  • LookAt() : Camera
  • LookDirection() : Camera , MoveLookController , Camera , MoveLookController
  • Lookup() : SDKSample::DataBinding::sealed
  • Loop() : MEPlayer
  • LoopbackClient_Click() : SimpleCommunication::LowLatency
  • LostFocusHandler() : Postcard::sealed
  • LowLatency()
: SimpleCommunication::sealed
, SimpleCommunication::LowLatency
  • lstEnumedDevices_SelectionChanged() : SDKSample::MediaCapture::sealed
  • Lzms_Click() : SDKSample::Compression::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- m -

  • m_callback() : Hilo::sealed
  • m_hr() : SDKSample::WASAPIAudio::sealed
  • m_Size() : SDKSample::WASAPIAudio::sealed
  • MainHubView() : Hilo::sealed
  • MainPage()
: SDKSample::sealed
, LockScreenAppsCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, D2D3DTransforms::sealed
, SDKSample::sealed
, Magazine::sealed
, SDKSample::sealed
, Postcard::sealed
, SDKSample::sealed
, PrintSample::sealed
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, EdgeGestureSample::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SimpleCommunication::sealed
, Clipboard::sealed
, SDKSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, ShareTarget::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, AssociationLaunching::sealed
, SDKSample::sealed
, SimpleBlogReader::sealed
, SDKSample::sealed
, ToastsSampleCPP::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DeviceAppForWebcam::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, D2DLightingEffects::sealed
, SDKSample::sealed
, Simple3DGameXaml::sealed
, SDKSample::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
, SDKSample::sealed
  • MainPage_CachedFile() : SDKSample::FilePickerContracts::sealed
  • MainPage_Loaded()
: SDKTemplateCS::MainPage
, SecondaryTiles::sealed
  • MainPage_PickFile() : SDKSample::FilePickerContracts::sealed
  • MainPage_SaveFile() : SDKSample::FilePickerContracts::sealed
  • MainPage_SizeChanged()
: SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, SimpleCommunication::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplateCS::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, DeviceAppForWebcam::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
  • MainPageAndContext() : ToastsSampleCPP::sealed
  • MainPagePicker() : ContactPicker::sealed
  • MainPagePicker_SizeChanged() : ContactPicker::sealed
  • MakeDocument() : CDocumentSource
  • MakePage() : CDocumentSource
  • MakeUnorm() : BasicSprites::SpriteBatch
  • ManipulatableObjectTransform() : sealed
  • ManipulationTransform() : ManipulatableObject
  • Map() : TextureLock
  • MapColors()
: DirectX::D3DX_BC7
, DirectX::D3DX_BC6H
  • MapColorsQuantized() : DirectX::D3DX_BC6H
  • MapInputRectsToOutputRect() : WaveEffect , RippleEffect
  • MapInvalidRect() : RippleEffect , WaveEffect
  • MapOutputRectToInputRects() : RippleEffect , WaveEffect
  • MarkIn() : SDKSample::Transcode::sealed
  • MarkOut() : SDKSample::Transcode::sealed
  • MarshalLog() : SDKSample::BackgroundTransfer::sealed
  • MarshalText() : SDKSample::WebSocket::sealed
  • Matrix4x4() : Matrix4x4< T >
  • Measure() : ImageFrame , TextFrame , ContentImageSource , PageRoll , Rectangle , Resource , Element , List< T >
  • MeasureOverride() : Hilo::Common::sealed
  • mediabuttons() : SDKSample::MediaButtons::sealed
  • mediaCapture_Failed() : SimpleCommunication::Common::CaptureDevice
  • MediaContainerAP() : SDKSample::Accessibility::sealed
  • MediaControl_PausePressed()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • MediaControl_PlayPauseTogglePressed()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • MediaControl_PlayPressed()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • MediaControl_SoundLevelChanged()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
, MediaCapture::AudioCapture
, SDKSample::CameraOptions::sealed
, MediaCapture::BasicCapture
  • MediaControl_StopPressed()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • MediaElement_CurrentStateChanged() : SDKSample::MediaButtons::sealed
  • MediaElement_MediaEnded() : SDKSample::MediaButtons::sealed
  • MediaElement_MediaOpened() : SDKSample::MediaButtons::sealed
  • MediaElementContainer() : SDKSample::Accessibility::sealed
  • MediaEngineNotify() : MediaEngineNotify
  • MediaEngineNotifyCallback() : MediaEngineNotify
  • mediaSelect_SelectionChanged() : SDKSample::MediaServerClient::sealed
  • mediaSink_IncomingConnectionEvent() : SimpleCommunication::Common::CaptureDevice
  • MediaStreamer() : MediaStreamer
  • MediaType_SelectionChanged() : SDKSample::ProvisioningAgent::sealed
  • MenuItemSelected() : D2DInterpolationModes
  • MergeSharedEdgeCoplanarContacts() : Collision
  • Mesh() : GameObject
  • MessageData() : SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • MessageReceived()
: ProximityCPP::sealed
, SDKSample::WebSocket::sealed
  • METHODASYNCCALLBACK()
: SDKSample::WASAPIAudio::WASAPIRenderer
, SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • MFSampleGenerator() : SDKSample::WASAPIAudio::MFSampleGenerator
  • MillisecondsToTimeSpan() : SDKSample::ThreadPool::ThreadPoolSample
  • ModelMatrix() : GameObject
  • Mouse() : SDKSample::DeviceCaps::sealed
  • MouseGetSettings_Click() : SDKSample::DeviceCaps::sealed
  • Move() : SDKSample::TouchKeyboard::sealed
  • MoveButtonClicked() : Postcard::sealed
  • MoveEnd() : Buffer
  • MoveEndpointByRange() : SDKSample::TouchKeyboard::sealed
  • MoveEndpointByUnit() : SDKSample::TouchKeyboard::sealed
  • MoveNext()
: SDKSample::sealed
, AntSystem::Ant
, FontLoader
  • MovePaper() : PostcardRenderer , PaperRenderer
  • MovePrevious() : SDKSample::sealed
  • MoveRepulsor() : SimpleSprites
  • MoveStart() : Buffer
  • MoveToFront() : Program
  • Msappdata() : SDKSample::ApplicationDataSample::sealed
  • Mszip_Click() : SDKSample::Compression::sealed
  • MusicEngine() : Audio
  • Mute() : MEPlayer
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- n -

  • Nav_Click() : SDKSample::WebViewControl::sealed
  • Navigate() : CAppWindowProvider
  • NavigateButton_Click() : SDKSample::WebViewControl::sealed
  • NavigateDPHelp() : SDKSample::UserAndCustomControls::sealed
  • NavigateHome() : Hilo::HiloPage
  • NavigateToGroup() : Hilo::sealed
  • NavigateToLaunchedFromSecondaryTile() : SecondaryTiles::sealed
  • NavigateToLink() : SDKSample::UserAndCustomControls::sealed
  • NavigateToPage() : Hilo::HiloPage
  • NavigateToPictures() : Hilo::sealed
  • NavigatingPrevented() : SimpleCommunication::sealed
  • NavToString_Click() : SDKSample::WebViewControl::sealed
  • NearClipPlane() : Camera
  • NeedsData() : CMPEG1Stream
  • NeedsResourceUpdate() : D2DLightingEffectsRenderer
  • NetworkCostCategory_SelectionChanged() : SDKSample::ProvisioningAgent::sealed
  • NetworkStatusChange() : SDKSample::NetworkInformationApi::sealed
  • NetworkStatusChange_Click() : SDKSample::NetworkInformationApi::sealed
  • Next() : List< T >
  • NextByte() : CStreamState
  • nextItem_Click() : SDKSample::PlayTo::sealed
  • NextItem_Click()
: SDKSample::AtomPub::sealed
, SDKSample::Syndication::sealed
  • NextTrack() : SDKSample::MediaButtons::sealed
  • NextValue() : TriColorValueHelper
  • Node()
: AntSystem::Node
, List< T >::Node
  • None() : SDKSample::Rotation::sealed
  • NonTouchableTextBlock() : SDKSample::TouchKeyboard::sealed
  • NonTouchableTextBlockAutomationPeer() : SDKSample::TouchKeyboard::sealed
  • Normal() : Triangle
  • Normalize() : Extruder::ExtrudingSink
  • NormalMaterial() : GameObject
  • NotificationBase() : NotificationsExtensions::NotificationBase
  • NotificationContentImage() : NotificationsExtensions::NotificationContentImage
  • NotificationContentText() : NotificationsExtensions::NotificationContentText
  • NotificationContentValidationException() : NotificationsExtensions::NotificationContentValidationException
  • NotificationData() : ScheduledNotificationsSampleCPP::sealed
  • NotificationDataSource() : ScheduledNotificationsSampleCPP::sealed
  • NotificationExpiration() : SDKSample::Tiles::sealed
  • NotifyAllObservers()
: Hilo::FileSystemRepository
, Hilo::Repository
  • NotifyUser()
: SDKTemplate::MainPage
, SecondaryTiles::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKTemplateCS::MainPage
, SDKTemplate::MainPage
, AssociationLaunching::sealed
, EdgeGestureSample::sealed
, ShareTarget::sealed
, SDKSample::FilePickerContracts::sealed
, DatagramSocketSample::sealed
, ContactPicker::sealed
, CredentialPickerCPP::sealed
, LockScreenAppsCPP::sealed
, LanguageFontCPP::sealed
, ToastsSampleCPP::sealed
, StreamSocketSample::sealed
, SimpleCommunication::sealed
, ProximityCPP::sealed
, PrintSample::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, Clipboard::sealed
, RawNotificationsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, SDKSample::FilePickerContracts::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, AppBarControl::sealed
  • NotifyUserBackgroundThread()
: ShareTarget::sealed
, Clipboard::sealed
  • NotifyUserFileNotExist() : SDKSample::MainPage
  • NotifyUserFromAsyncThread()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
, CredentialPickerCPP::sealed
  • NumberOrGlyph_SelectionChanged() : SDKSample::Tiles::sealed
  • NumberParsing() : SDKSample::NumberFormatting::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- o -

  • Objective() : abstract
  • ObservableDictionaryChangedEventArgs() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
  • ObserveException() : Hilo::ObserveException< T >
  • ObserveFileChange() : Hilo::sealed
  • OnActivated() : AccountPictureName::App , ConvolveMatrixEffect , Direct3DTutorialFrameworkView , D2DEffectsOnPrimitives , DirectXApp , ContactPicker::App , GeometryRealizationSample , DWriteCustomTextRenderer , DWriteHelloWorld , D2DInterpolationModes , DWriteHitTesting , DWriteInlineObject , DeviceAppForPrinters::App , D2DPerspectiveTransform , DWriteParagraphText , DWriteVerticalText , DirectXApp , D2DTextAnimation , SaveAsImageFile , CoreWindowEvents , DirectXApp , D2DBasicAnimation , DirectXApp , sealed , DirectXApp , SDKSample::App , sealed , D2DEffectsHelloWorld , DirectXApp , SDKTemplate::App , DeviceAppForWebcam::sealed , DirectXApp , CommandListRenderer , DirectXApp , CompositeModes , Direct3DTutorialFrameworkView
  • OnAppBarOpened() : Simple3DGameXaml::sealed
  • OnApplyTemplate() : SDKSample::HighContrast::sealed
  • OnAudioSampleRequested()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • OnAutomationProviderRequested() : sealed
  • OnAzimuthValueChanged() : D2DLightingEffects::sealed
  • OnBrtAutoToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnBrtSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnBuyAppButtonTapped() : Simple3DGameXaml::sealed
  • OnBuySelectorClicked() : Simple3DGameXaml::sealed
  • OnByteStreamRead() : CMPEG1Source
  • OnCachedFileUpdaterActivated() : SDKSample::App
  • OnCanceled()
: Tasks::sealed
, EdgeGestureSample::sealed
, BackgroundTask::sealed
, NetworkStatusTask::sealed
  • OnCaptureFailed() : SimpleCommunication::sealed
  • OnChangeBackgroundButtonClicked() : Simple3DGameXaml::sealed
  • OnChangeDrawingAttributes() : sealed
  • OnChangeRecognizer() : sealed
  • OnCharacterReceived() : CoreWindowEvents , sealed
  • OnCheckInputType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • OnCheckMediaType() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CPolarEffect
  • OnCheckOutputType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • OnClipboardChanged() : Clipboard::sealed
  • onCommandsRequested() : SDKSample::ApplicationSettings::sealed
  • OnCompleted()
: EdgeGestureSample::sealed
, SDKSample::GeolocationCPP::sealed
  • OnConnection() : StreamSocketSample::sealed
  • OnContactRemoved() : ContactPicker::sealed
  • OnContentCreated()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • OnContextMenu() : EdgeGestureSample::sealed
  • OnCopyTextToClipboard() : sealed
  • OnCopyToClipboard() : sealed
  • OnCreateAutomationPeer()
: SDKSample::TouchKeyboard::sealed
, SDKSample::Accessibility::sealed
  • OnCriticalError() : AudioEngineCallbacks
  • OnCropRectangleTapped() : Hilo::sealed
  • OnCrtAutoToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnCrtSliderValueChanged()
: DeviceAppForWebcam::sealed
, SDKTemplate::DeviceAppPage
  • OnDataAvailable() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • OnDataChanged() : Hilo::sealed
  • OnDataRequested() : PostcardRenderer , SDKSample::Common::SharePage
  • OnDeferredImageRequestedHandler()
: Clipboard::sealed
, SDKSample::ShareSource::sealed
  • OnDelete() : sealed
  • OnDeviceEventReceived() : SDKSample::PortableDeviceCPP::sealed
  • OnDeviceLost() : Magazine::sealed , DirectXApp , Simple3DGameXaml::sealed
  • OnDeviceReset() : DirectXApp , Simple3DGameXaml::sealed
  • OnDeviceStateChange() : SDKSample::WASAPIAudio::sealed
  • OnDiffuseConstantValueChanged() : D2DLightingEffects::sealed
  • OnDiscontinuity() : CDecoder
  • OnDispatchSamples() : CMPEG1Stream
  • OnDisplayContentsInvalidated() : D2D3DTransforms::sealed , D2DTextAnimation , D2DEffectsHelloWorld , CompositeModes , ConvolveMatrixEffect , D2DEffectsOnPrimitives , D2DInterpolationModes , D2DPerspectiveTransform , SaveAsImageFile , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , DWriteVerticalText , DirectXApp , CoreWindowEvents , sealed , D2DLightingEffects::sealed , Simple3DGameXaml::sealed
  • OnEffectEnabledToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnEffectSelectorSelectionChanged()
: D2D3DTransforms::sealed
, D2DLightingEffects::sealed
  • OnEffectSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnElevationValueChanged() : D2DLightingEffects::sealed
  • OnEndOfStream() : CMPEG1Source , Parser , CMPEG1Source , Parser
  • OnError() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • OnEvent() : SDKSample::PortableDeviceCPP::EventCallback
  • OnExpAutoToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnExpSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnFileActivated() : SDKSample::App
  • OnFileOpenPickerActivated() : SDKSample::App
  • OnFileQueryContentsChanged() : Hilo::sealed
  • OnFileRemoved() : SDKSample::FilePickerContracts::sealed
  • OnFileSavePickerActivated() : SDKSample::App
  • OnFileUpdateRequested() : SDKSample::FilePickerContracts::sealed
  • OnFilmStripLoaded() : Hilo::sealed
  • OnFinishCapture() : SDKSample::WASAPIAudio::WASAPICapture
  • OnFlush() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CDecoder , CPolarEffect
  • OnFocusAutoToggleChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnFocusChange() : MarbleMaze
  • OnFocusSliderValueChanged()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • OnFx2Added()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • OnFx2EnumerationComplete()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • OnFx2Removed()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • OnGameInfoOverlayTapped() : Simple3DGameXaml::sealed
  • OnGetPartialType() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CPolarEffect
  • OnGlobalOffsetXValueChanged() : D2D3DTransforms::sealed
  • OnGlobalOffsetYValueChanged() : D2D3DTransforms::sealed
  • OnGlobalOffsetZValueChanged() : D2D3DTransforms::sealed
  • OnGotFocus() : SDKSample::TouchKeyboard::sealed
  • OnGround() : GameObject
  • OnHeadersAvailable() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • OnHighContrastChanged() : sealed
  • OnHiloDataContextPropertyChanged() : Hilo::HiloPage
  • OnHolding() : ConvolveMatrixEffect , GeometryRealizationSample , DWriteParagraphText , sealed
  • OnImageFailedToOpen() : Hilo::sealed
  • OnImagePointerMoved() : Hilo::sealed
  • OnImagePointerPressed() : Hilo::sealed
  • OnImagePointerReleased() : Hilo::sealed
  • OnIncomingConnection() : SimpleCommunication::sealed
  • OnInitializeCompleted() : SimpleCommunication::sealed
  • OnInitializeCompletedDispatchedHandler() : SimpleCommunication::sealed
  • OnKeyDown() : LonLatController , DirectXApp , LonLatController , DirectXApp , MoveLookController , DirectXApp , CoreWindowEvents , MoveLookController , SDKSample::TouchKeyboard::sealed , sealed , MoveLookController
  • OnKeyPressed() : VideoView
  • OnKeyUp() : LonLatController , DirectXApp , LonLatController , MoveLookController , DirectXApp , CoreWindowEvents , MoveLookController
  • OnLaunched()
: SDKSample::App
, AccountPictureName::App
, SDKSample::App
, AssociationLaunching::sealed
, SDKSample::App
, Clipboard::App
, SDKSample::App
, ContactPicker::App
, SDKSample::App
, CredentialPickerCPP::sealed
, SDKSample::App
, SDKTemplate::App
, SDKSample::App
, DatagramSocketSample::sealed
, SDKSample::App
, DeviceAppForPrinters::App
, SDKSample::App
, D2D3DTransforms::sealed
, Magazine::sealed
, Postcard::sealed
, SDKSample::App
, EdgeGestureSample::sealed
, SDKSample::App
, SimpleBlogReader::sealed
, SDKSample::App
, Hilo::sealed
, SDKSample::App
, LanguageFontCPP::sealed
, SDKSample::App
, LockScreenAppsCPP::sealed
, SDKSample::App
, SDKTemplate::App
, SDKSample::App
, MediaExtensionsCS::App
, MediaExtensionsCPP::App
, SDKSample::App
, SDKTemplate::App
, SDKSample::App
, PrintSample::sealed
, SDKSample::App
, ProximityCPP::sealed
, SDKSample::App
, RawNotificationsSampleCPP::sealed
, SDKSample::App
, SDKTemplate::App
, SimpleCommunication::App
, SDKSample::App
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::App
, SecondaryTiles::sealed
, SDKSample::App
, ShareTarget::sealed
, SDKSample::App
, StreamSocketSample::App
, SDKSample::App
, ToastsSampleCPP::sealed
, SDKSample::App
, SDKTemplate::App
, DeviceAppForWebcam::sealed
, SDKSample::App
, AppBarControl::App
, SDKSample::App
, D2DLightingEffects::sealed
, Simple3DGameXaml::sealed
, SDKSample::App
  • OnLicenseChanged() : Simple3DGameXaml::sealed
  • OnLightPositionZValueChanged() : D2DLightingEffects::sealed
  • OnLimitingConeAngleValueChanged() : D2DLightingEffects::sealed
  • OnLoad() : sealed
  • OnLoaded()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • OnLoadStoreClicked() : Simple3DGameXaml::sealed
  • OnLocalOffsetXValueChanged() : D2D3DTransforms::sealed
  • OnLocalOffsetYValueChanged() : D2D3DTransforms::sealed
  • OnLocalOffsetZValueChanged() : D2D3DTransforms::sealed
  • OnLogicalDpiChanged() : D2D3DTransforms::sealed , D2DTextAnimation , D2DBasicAnimation , D2DEffectsHelloWorld , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , D2DEffectsOnPrimitives , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , DirectXApp , SaveAsImageFile , DirectXApp , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , DWriteVerticalText , DirectXApp , Postcard::sealed , CoreWindowEvents , DirectXApp , sealed , D2DLightingEffects::sealed , Simple3DGameXaml::sealed , DirectXApp
  • OnLostFocus() : SDKSample::TouchKeyboard::sealed
  • OnManipulationCompleted() : D2DTextAnimation , PaperRenderer , PostcardRenderer , Hilo::sealed , sealed
  • OnManipulationDelta() : ExtrudedTextRenderer , PaperRenderer , PostcardRenderer , Hilo::sealed
  • OnManipulationInertiaStarting() : sealed
  • OnManipulationStarted() : PaperRenderer , PostcardRenderer , sealed
  • OnManipulationUpdated() : D2DTextAnimation , CommandListRenderer , CompositeModes , D2DInterpolationModes , D2DPerspectiveTransform , DirectXApp , sealed
  • OnMediaCaptureFailed() : SimpleCommunication::sealed
  • OnMediaEngineEvent() : MEPlayer
  • OnMessage() : DatagramSocketSample::sealed
  • OnMouseMoved() : MoveLookController
  • OnNavigatedFrom()
: SDKSample::Common::LayoutAwarePage
, SDKSample::AccelerometerCPP::sealed
, AccountPictureName::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ApplicationSettings::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ApplicationResources::sealed
, AssociationLaunching::sealed
, SDKSample::Common::LayoutAwarePage
, Clipboard::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CompassCPP::sealed
, SDKSample::Common::LayoutAwarePage
, ContactPicker::sealed
, SDKSample::Common::LayoutAwarePage
, CredentialPickerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CustomDeviceAccess::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DisplayOrientation::sealed
, SDKSample::Common::LayoutAwarePage
, EdgeGestureSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GeolocationCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GyrometerCPP::sealed
, Hilo::Common::LayoutAwarePage
, Hilo::HiloPage
, Hilo::sealed
, Hilo::ViewModelBase
, SDKSample::Common::LayoutAwarePage
, SDKSample::InclinometerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, LanguageFontCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::LightSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
, SDKSample::Common::LayoutAwarePage
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCS::ScenarioOutput1
, MediaExtensionsCS::ScenarioOutput2
, MediaExtensionsCS::ScenarioOutput3
, MediaExtensionsCS::ScenarioOutput4
, MediaExtensionsCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PlayTo::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::NetworkInformationApi::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PortableDeviceCPP::sealed
, PrintSample::BasePrintPage
, PrintSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SDKTemplate::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SearchContract::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Common::SharePage
, SDKSample::Common::LayoutAwarePage
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ThreadPool::sealed
, ToastsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WASAPIAudio::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WebViewControl::sealed
  • OnNavigatedTo()
: Hilo::sealed
, Hilo::ViewModelBase
, SDKSample::Common::LayoutAwarePage
, SDKSample::HomeGroup::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::HttpClientSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::InclinometerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DeviceCaps::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::TouchKeyboard::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::TouchKeyboardTextInput::sealed
, LanguageFontCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::LightSensorCPP::sealed
, LockScreenAppsCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Personalization::sealed
, MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKTemplate::MainPage
, SDKSample::MediaCapture::sealed
, SDKSample::Common::LayoutAwarePage
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCS::ScenarioList
, MediaExtensionsCS::ScenarioOutput1
, MediaExtensionsCS::ScenarioOutput2
, MediaExtensionsCS::ScenarioOutput3
, MediaExtensionsCS::ScenarioOutput4
, MediaExtensionsCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PlayTo::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::MediaServerClient::sealed
, MediaStreamSource::AudioSource
, SDKTemplate::MainPage
, SDKSample::MessageDialogSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::MessageDialogSample::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::MessageDialogSample::sealed
, SDKSample::ProvisioningAgent::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::ProvisioningAgent::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::NetworkInformationApi::sealed
, SDKSample::Drawing::sealed
, SDKSample::NetworkInformationApi::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::NumberFormatting::sealed
, SDKSample::Transforms::sealed
, SDKSample::NumberFormatting::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::TextEditing::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PlaybackManager2::sealed
, SDKSample::TextEditing::sealed
, SDKSample::PlaybackManager2::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PlaybackManager::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::Playlists::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::XAMLPopup::sealed
, SDKSample::Playlists::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::PlayToreceiver::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PortableDeviceCPP::sealed
, SDKSample::Images::sealed
, SDKSample::PortableDeviceCPP::sealed
, PrintSample::BasePrintPage
, SDKSample::HighContrast::sealed
, PrintSample::sealed
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::sealed
, AppBarControl::sealed
, ProximityCPP::sealed
, SDKSample::SDKTemplate::sealed
, AppBarControl::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::Animation::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DataReaderWriter::sealed
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::LowLatency
, SDKTemplate::MainPage
, SimpleCommunication::VideoChat
, SDKSample::WASAPIAudio::sealed
, SimpleCommunication::sealed
, SDKSample::WebAuthentication::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::RemovableStorageCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Scaling::sealed
, SDKSample::Common::LayoutAwarePage
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::StoreSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SearchContract::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SearchContract::sealed
, SecondaryTiles::sealed
, ToastsSampleCPP::sealed
, SecondaryTiles::sealed
, ToastsSampleCPP::sealed
, SecondaryTiles::sealed
, ToastsSampleCPP::sealed
, SecondaryTiles::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Common::SharePage
, ShareTarget::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::Syndication::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::SplashScreen::sealed
, StreamSocketSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ThreadPool::sealed
, ToastsSampleCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Transcode::sealed
, SDKSample::StoreSample::sealed
, SDKSample::HighContrast::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::HighContrast::sealed
, SDKSample::UserDomainName::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::UssdApi::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WebAuthentication::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WASAPIAudio::sealed
, SDKTemplate::MainPage
, DeviceAppForWebcam::sealed
, SDKSample::Accessibility::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Animation::sealed
, AppBarControl::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FlipViewCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::HighContrast::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Images::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PersonalityAnimations::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::XAMLPopup::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::TextDisplay::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::TextEditing::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Transforms::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Drawing::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WebViewControl::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::AccelerometerCPP::sealed
, AccountPictureName::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::AnimationMetrics::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PackageSample::sealed
, SDKSample::ApplicationSettings::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ApplicationSettings::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Tiles::sealed
, SDKSample::ApplicationDataSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ApplicationDataSample::sealed
, SDKSample::ApplicationResources::sealed
, AssociationLaunching::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::AtomPub::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::BackgroundTask::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::BackgroundTransfer::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CallControl::sealed
, SDKSample::CalendarSample::sealed
, Hilo::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CalendarSample::sealed
, Hilo::sealed
, SDKSample::CameraCapture::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CameraOptions::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CertificateEnrollment::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::IsRemoteSession::sealed
, SDKSample::GeolocationCPP::sealed
, Clipboard::sealed
, SDKSample::FilePickerContracts::sealed
, Clipboard::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FilePickerContracts::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Compression::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::MediaButtons::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::WebSocket::sealed
, SDKSample::ELS::sealed
, SDKSample::WebSocket::sealed
, ContactPicker::sealed
, EdgeGestureSample::sealed
, ContactPicker::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::DisplayOrientation::sealed
, CredentialPickerCPP::sealed
, SDKSample::DeviceEnumeration::sealed
, CredentialPickerCPP::sealed
, SDKSample::Rotation::sealed
, CredentialPickerCPP::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CryptoWinRT::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::CryptoWinRT::sealed
, SDKTemplate::MainPage
, CustomDeviceAccess::DeviceAsync
, SDKSample::Common::LayoutAwarePage
, SDKSample::CustomDeviceAccess::sealed
, DatagramSocketSample::sealed
, SDKSample::DateTimeFormatting::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::Rotation::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DeviceEnumeration::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::DisplayOrientation::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::EAS::sealed
, EdgeGestureSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::ELS::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FileThumbnails::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GeolocationCPP::sealed
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::GyrometerCPP::sealed
, Hilo::Common::LayoutAwarePage
, Hilo::sealed
, Hilo::HiloPage
  • OnNavigatingFrom()
: SimpleCommunication::sealed
, SDKSample::StoreSample::sealed
, SecondaryTiles::sealed
, ProximityCPP::sealed
, SDKSample::AtomPub::sealed
, SDKSample::ApplicationDataSample::sealed
, SDKSample::AtomPub::sealed
, ProximityCPP::sealed
, SimpleCommunication::LowLatency
, SimpleCommunication::VideoChat
, SimpleCommunication::sealed
, SecondaryTiles::sealed
, SDKSample::StoreSample::sealed
, AppBarControl::sealed
  • OnNetworkStatusChange() : SDKSample::NetworkInformationApi::sealed
  • OnOrientationChanged() : SDKSample::DisplayOrientation::sealed , DirectXApp
  • OnPasteFromClipboard() : sealed
  • OnPausePlayback() : SDKSample::WASAPIAudio::WASAPIRenderer
  • OnPerspectiveValueChanged() : D2D3DTransforms::sealed
  • OnPhotoItemClicked() : Hilo::sealed
  • OnPickFileAsync() : SDKSample::WASAPIAudio::sealed
  • OnPictureGroupPropertyChanged() : Hilo::sealed
  • OnPlayButtonClicked() : Simple3DGameXaml::sealed
  • OnPlotDataReady() : SDKSample::WASAPIAudio::sealed
  • OnPointerEvent() : Shape
  • OnPointerExited() : MoveLookController
  • OnPointerMoved() : MoveLookController , InkRenderer , DirectXApp , CompositeModes , D2DTextAnimation , CommandListRenderer , ConvolveMatrixEffect , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , LonLatController , DirectXApp , LonLatController , DWriteParagraphText , MoveLookController , DirectXApp , Postcard::sealed , PostcardRenderer , CoreWindowEvents , sealed , Program , sealed , D2DLightingEffectsRenderer , MoveLookController
  • OnPointerPressed() : D2DPerspectiveTransform , CompositeModes , D2DTextAnimation , CommandListRenderer , ConvolveMatrixEffect , GeometryRealizationSample , D2DInterpolationModes , SaveAsImageFile , LonLatController , DirectXApp , DWriteHitTesting , DWriteParagraphText , MoveLookController , DirectXApp , InkRenderer , Postcard::sealed , PostcardRenderer , sealed , Program , sealed , MoveLookController , BasicSound , DirectXApp , VideoView , CoreWindowEvents , DirectXApp
  • OnPointerReleased() : CommandListRenderer , CompositeModes , ConvolveMatrixEffect , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , LonLatController , DirectXApp , DWriteParagraphText , DirectXApp , InkRenderer , Postcard::sealed , CoreWindowEvents , MoveLookController , sealed , Program , sealed , MoveLookController , PostcardRenderer , MoveLookController , DirectXApp , D2DTextAnimation
  • OnPointerWheelChanged() : CommandListRenderer , D2DInterpolationModes , LonLatController , DirectXApp , D2DTextAnimation
  • OnPopupClosed() : SDKSample::XAMLPopup::sealed
  • OnPositionChanged() : SDKSample::GeolocationCPP::sealed
  • OnProcessingPassEnd() : AudioEngineCallbacks
  • OnProcessingPassStart() : AudioEngineCallbacks
  • OnProcessOutput() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CPolarEffect
  • OnPropertyChanged()
: Hilo::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewData::sealed
, SDKSample::ListViewSampleDataSource::sealed
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, ScheduledNotificationsSampleCPP::sealed
, Hilo::sealed
  • OnPushNotificationReceived()
: SDKSample::SDKTemplate::sealed
, RawNotificationsSampleCPP::sealed
  • OnQuerySubmitted() : SDKSample::App
  • OnRecognize() : sealed
  • OnRedirect() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback
  • OnRendering() : Simple3DGameXaml::sealed
  • OnResetButtonClicked() : Simple3DGameXaml::sealed
  • OnResetLicenseButtonClicked() : Simple3DGameXaml::sealed
  • OnResponseReceived() : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , HttpRequestStringCallback
  • OnRestoreDefaultsClick()
: D2DLightingEffects::sealed
, D2D3DTransforms::sealed
  • OnResultSuggestionChosen() : SDKSample::SearchContract::sealed
  • OnResuming() : sealed , Simple3DGameXaml::sealed , DirectXApp , MarbleMaze , BasicSound , D2DInterpolationModes , DWriteHitTesting , DirectXApp , D2DPerspectiveTransform , DirectXApp , D2DLightingEffects::sealed , DirectXApp , GeometryRealizationSample , CompositeModes , ConvolveMatrixEffect , Magazine::sealed , DirectXApp , DWriteHelloWorld , OfferReclaimAPI , DirectXApp , Simple3DGame , DirectXApp , VideoView , sealed , Simple3DGame , DirectXApp , StreamEffect , AudioController , D2DBasicAnimation , CommandListRenderer , DirectXApp , DWriteCustomTextRenderer , DWriteInlineObject , DWriteParagraphText
  • OnRightTapped() : sealed
  • OnRotationXValueChanged() : D2D3DTransforms::sealed
  • OnRotationYValueChanged() : D2D3DTransforms::sealed
  • OnRotationZValueChanged() : D2D3DTransforms::sealed
  • OnSampleReady()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • OnSave() : sealed
  • OnScaleXValueChanged() : D2D3DTransforms::sealed
  • OnScaleYValueChanged() : D2D3DTransforms::sealed
  • OnSearchActivated() : SDKSample::App
  • OnSearchPaneSuggestionsRequested() : SDKSample::SearchContract::sealed
  • OnSelectAll() : sealed
  • OnSendScopeData() : SDKSample::WASAPIAudio::WASAPICapture
  • OnSetInputType() : CPolarEffect , CDecoder , CGrayscale , CDecoder , CGrayscale , CPolarEffect
  • OnSetOutputType() : CGrayscale , CDecoder , CGrayscale , CPolarEffect , CDecoder , CPolarEffect
  • onSettingsCommand() : SDKSample::ApplicationSettings::sealed
  • OnSetVolume() : SDKSample::WASAPIAudio::sealed
  • OnShareTargetActivated() : ShareTarget::sealed
  • OnSizeChanged() : Hilo::sealed
  • OnSpecularConstantValueChanged() : D2DLightingEffects::sealed
  • OnSpecularExponentValueChanged() : D2DLightingEffects::sealed
  • OnSpotFocusValueChanged() : D2DLightingEffects::sealed
  • OnStartCapture() : SDKSample::WASAPIAudio::WASAPICapture
  • OnStarting() : EdgeGestureSample::sealed
  • OnStartPlayback() : SDKSample::WASAPIAudio::WASAPIRenderer
  • OnStatusChanged() : SDKSample::GeolocationCPP::sealed
  • OnStereoEnabledChanged() : abstract
  • OnStopCapture() : SDKSample::WASAPIAudio::WASAPICapture
  • OnStopPlayback() : SDKSample::WASAPIAudio::WASAPIRenderer
  • OnStoreReturnClicked() : Simple3DGameXaml::sealed
  • OnStreamRequestSample() : CMPEG1Source
  • OnSurfaceScaleValueChanged() : D2DLightingEffects::sealed
  • OnSuspending()
: VideoView
, SDKSample::App
, MediaExtensionsCPP::App
, SDKSample::App
, LanguageFontCPP::sealed
, SDKSample::App
, LockScreenAppsCPP::sealed
, sealed
, SDKSample::App
, MarbleMaze
, SDKSample::App
, EdgeGestureSample::sealed
, SDKSample::App
, OfferReclaimAPI
, SDKSample::App
, AccountPictureName::App
, D2DPerspectiveTransform
, DWriteHitTesting
, DWriteInlineObject
, SDKSample::App
, DirectXApp
, AssociationLaunching::sealed
, DWriteCustomTextRenderer
, ConvolveMatrixEffect
, CompositeModes
, SDKSample::App
, DirectXApp
, SDKSample::App
, CommandListRenderer
, SDKSample::App
, D2D3DTransforms::sealed
, D2DTextAnimation
, SDKSample::App
, ContactPicker::App
, SDKSample::App
, DWriteParagraphText
, SDKSample::App
, DeviceAppForPrinters::App
, SDKTemplate::App
, SDKSample::App
, Clipboard::App
, SDKSample::App
, CredentialPickerCPP::sealed
, SDKSample::App
, DatagramSocketSample::sealed
, SDKSample::App
, D2D3DTransforms::sealed
, D2DBasicAnimation
, GeometryRealizationSample
, D2DInterpolationModes
, Magazine::sealed
, DirectXApp
, DWriteHelloWorld
, DirectXApp
, Simple3DGame
, DirectXApp
, SDKSample::App
, DirectXApp
, SDKSample::App
, SimpleBlogReader::sealed
, SDKSample::App
, Hilo::sealed
, SDKSample::App
, SDKTemplate::App
, SDKSample::App
, MediaExtensionsCS::App
, SDKTemplate::App
, SDKSample::App
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, SDKTemplate::App
, SDKSample::App
, ProximityCPP::sealed
, SecondaryTiles::sealed
, SDKSample::App
, StreamSocketSample::App
, SDKSample::App
, D2DLightingEffects::sealed
, SDKSample::App
, BasicSound
, AudioController
, DirectXApp
, SDKSample::App
, SimpleCommunication::App
, DirectXApp
, ScheduledNotificationsSampleCPP::sealed
, DirectXApp
, SDKSample::App
, ToastsSampleCPP::sealed
, SDKSample::App
, Simple3DGameXaml::sealed
, sealed
, Simple3DGame
, SDKSample::App
, AppBarControl::App
, DeviceAppForWebcam::sealed
, D2DLightingEffects::sealed
, SDKTemplate::App
, SDKSample::App
, StreamEffect
, SDKSample::App
  • OnSwapChainPointerMoved() : D2DLightingEffects::sealed
  • OnSwitchStateChangedEvent() : SDKSample::CustomDeviceAccess::sealed
  • OnTapped() : D2DTextAnimation , PostcardRenderer , CommandListRenderer , PaperRenderer , SDKSample::TouchKeyboard::sealed , sealed
  • OnTargetFileRequested() : SDKSample::FilePickerContracts::sealed
  • OnTargetFormatChanged() : SDKSample::Transcode::sealed
  • OnThumbDragDelta() : Hilo::sealed
  • OnThumbnailUpdated() : Hilo::sealed
  • OnTimer() : MEPlayer
  • OnTouchHitTesting() : Program
  • OnUIRequested() : SDKSample::FilePickerContracts::sealed
  • OnUnloaded()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • OnViewChange() : MarbleMaze
  • OnViewChangeCompleted() : Hilo::sealed
  • OnVisibilityChanged() : DirectXApp , Simple3DGameXaml::sealed , GeometryRealizationSample , DirectXApp , CommandListRenderer , DirectXApp , D2DBasicAnimation , Clipboard::sealed , D2DInterpolationModes , DirectXApp
  • OnWindowActivated() : sealed , CoreWindowEvents
  • OnWindowActivationChanged() : DirectXApp , Simple3DGameXaml::sealed , DirectXApp
  • OnWindowClosed() : D2DBasicAnimation , DirectXApp , D2DInterpolationModes , DirectXApp , CommandListRenderer , DirectXApp , sealed , DirectXApp , GeometryRealizationSample
  • OnWindowCreated() : SDKSample::App
  • OnWindowSizeChanged() : CommandListRenderer , Direct3DTutorialFrameworkView , DWriteHitTesting , DWriteParagraphText , DWriteHelloWorld , Direct3DTutorialFrameworkView , DirectXApp , CompositeModes , DirectXApp , SaveAsImageFile , GeometryRealizationSample , D2D3DTransforms::sealed , DirectXApp , Simple3DGameXaml::sealed , D2DTextAnimation , DWriteVerticalText , D2DBasicAnimation , D2DInterpolationModes , D2DEffectsOnPrimitives , Magazine::sealed , ConvolveMatrixEffect , DirectXApp , sealed , DWriteCustomTextRenderer , Direct3DTutorialFrameworkView , DirectXApp , DWriteInlineObject , Direct3DTutorialFrameworkView , DirectXApp , CoreWindowEvents , DirectXApp , sealed , DirectXApp , VideoView , D2DLightingEffects::sealed , D2DPerspectiveTransform , Simple3DGameXaml::sealed , DirectXApp , Postcard::sealed , D2DEffectsHelloWorld , DirectXApp , sealed , DirectXApp
  • OnZoomedOutGridPointerEntered() : Hilo::sealed
  • Op() : SourceOp
  • Open_Click()
: MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCPP::sealed
  • OpenChannel_Click() : SDKSample::SDKTemplate::sealed
  • OpenChannelAndRegisterTask() : RawNotificationsSampleCPP::sealed
  • OpenFile() : MEPlayer
  • OpenFisheye_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
  • OpenFromListButton_Click() : SDKSample::FileAccess::sealed
  • OpenFx2Device() : SDKSample::CustomDeviceAccess::sealed
  • OpenGrayscale_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
  • OpenInvert_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
  • OpenMediaAsync() : MediaStreamSource::PcmSource
  • OpenPinch_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
  • OpenReadAsync() : Hilo::IPhoto
  • OpenVideoWithPolarEffect()
: MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
  • OpenWarp_Click()
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
  • operator!=() : List< T >::POSITION
  • operator&() : ScopedObject< T >
  • operator&=() : DirectX::INTColor
  • operator()() : aligned_deleter , Hilo::PhotoPathComparer , Hilo::ObserveException< T > , ComAutoRelease , MemDelete , NoOp< T > , MemDelete , SDKSample::PropVariantClearStruct , SDKSample::BackgroundTransfer::GuidComparer , ComAutoRelease , MemDelete , handle_closer , SDKSample::CoTaskMemFreeStruct
  • operator*() : DirectX::HDRColorA , ScopedObject< T >
  • operator*=() : DirectX::HDRColorA
  • operator+() : DirectX::HDRColorA
  • operator++() : TreeIterator< T >
  • operator+=()
: DirectX::HDRColorA
, DirectX::INTColor
  • operator-() : DirectX::INTColor , DirectX::HDRColorA
  • operator-=()
: DirectX::HDRColorA
, DirectX::INTColor
  • operator->() : ScopedObject< T >
  • operator/() : DirectX::HDRColorA
  • operator/=() : DirectX::HDRColorA
  • operator=()
: ComBase< InterfaceChain >
, DirectX::ScratchImage
, ScopedObject< T >
, DirectX::Blob
, AntSystem::Ant
, DirectX::LDRColorA
, DirectX::HDRColorA
, ReadStreamTask
  • operator==() : List< T >::POSITION , TextAnalysis::Run
  • operator[]() : Vector4< T > , Matrix4x4< T > , Vector4< T > , Matrix4x4< T > , Vector4< T > , Matrix4x4< T > , Vector4< T > , Vector2< T > , Matrix4x4< T > , Vector4< T > , Vector2< T > , Vector3< T > , Vector2< T > , Vector3< T > , Vector4< T > , Vector2< T > , Vector4< T > , Vector3< T > , Vector2< T > , Vector4< T > , DirectX::LDRColorA , Matrix4x4< T > , Vector3< T > , Matrix4x4< T > , DirectX::INTColor , Vector2< T > , Matrix4x4< T > , Vector4< T > , StreamList , Vector2< T > , Vector4< T > , Vector3< T > , StreamList , Vector4< T > , Vector2< T > , Vector3< T > , Matrix4x4< T > , Vector4< T > , Vector3< T > , Vector4< T > , Vector2< T > , Vector4< T > , Vector3< T > , Matrix4x4< T > , Vector4< T > , Matrix4x4< T > , Vector3< T > , Vector2< T > , Vector3< T > , Vector2< T > , Vector3< T > , Matrix4x4< T > , Vector4< T > , DirectX::LDRColorA , Vector2< T > , Vector3< T > , Matrix4x4< T > , Vector4< T > , Matrix4x4< T > , StreamList , Vector2< T > , Vector4< T > , Vector2< T > , Vector4< T > , StreamList , Matrix4x4< T > , Vector2< T > , Vector3< T > , Vector2< T > , Vector3< T > , Vector2< T > , Vector3< T >
  • OpQueue() : OpQueue< T, TOperation >
  • OptimizeEndPoints()
: DirectX::D3DX_BC7
, DirectX::D3DX_BC6H
  • OptimizeOne()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • OptimizeTripAsync()
: TripOptimizerComponent::sealed
, TripOptimizerComponent::Details::TripOptimizerImpl
  • OptionalTrialUpgrade() : Simple3DGameXaml::sealed
  • Orientation_Click() : SDKSample::FlipViewCPP::sealed
  • OrientationChanged() : SDKSample::SimpleOrientationSensorCPP::sealed
  • Other_Click()
: SDKSample::PasswordVaultCPP::sealed
, SDKSample::TextEditing::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::TextEditing::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::HighContrast::sealed
, SDKSample::TextEditing::sealed
  • Others() : Clipboard::sealed
  • OutlineRenderer() : OutlineRenderer
  • OutputFileAsync()
: SDKSample::FilePickerContracts::sealed
, SDKSample::FilePicker::sealed
  • OutputFileButton_Click() : SDKSample::FilePicker::sealed
  • OutputFrameLoaded() : RawNotificationsSampleCPP::sealed
  • outputFrameNavigated()
: LanguageFontCPP::sealed
, MediaExtensionsCPP::sealed
, AssociationLaunching::sealed
, ScheduledNotificationsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
, LockScreenAppsCPP::sealed
, CredentialPickerCPP::sealed
, ToastsSampleCPP::sealed
, EdgeGestureSample::sealed
, PrintSample::sealed
  • OutputPauseButton_Click() : SDKSample::Transcode::sealed
  • OutputPlayButton_Click() : SDKSample::Transcode::sealed
  • OutputSettings() : SDKSample::Scaling::sealed
  • OutputStopButton_Click() : SDKSample::Transcode::sealed
  • OutputText() : ToastsSampleCPP::sealed
  • OutputToTextBox() : RawNotificationsSampleCPP::sealed
  • OverrideSettings() : SDKSample::DateTimeFormatting::sealed
  • OverwriteButton_Click() : SDKSample::FilePickerContracts::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- ~ -

  • ~App()
: AssociationLaunching::sealed
, Magazine::sealed
, Simple3DGameXaml::sealed
, PrintSample::sealed
  • ~Audio() : Audio
  • ~AudioController() : AudioController
  • ~BackgroundObject() : sealed
  • ~BackgroundTask() : NetworkStatusTask::sealed
  • ~BasicSound() : BasicSound
  • ~Blob() : DirectX::Blob
  • ~Buffer() : Buffer
  • ~CartoonizeImageViewModel() : Hilo::sealed
  • ~CAsyncState() : CAsyncState
  • ~CAutoDXDevLockBase() : CAutoDXDevLockBase< DevManager, DevInterface >
  • ~CDecoder() : CDecoder
  • ~CGrayscale() : CGrayscale
  • ~CInvert() : CInvert
  • ~CInvertModule() : CInvertModule
  • ~CMPEG1Source() : CMPEG1Source
  • ~CMPEG1Stream() : CMPEG1Stream
  • ~ComBase() : ComBase< InterfaceChain >
  • ~CompositeModes() : CompositeModes
  • ~ComPtrList() : ComPtrList< T, NULLABLE >
  • ~CoTaskMemFreeArray() : SDKSample::CoTaskMemFreeArray
  • ~CPolarEffect() : CPolarEffect
  • ~CritSec() : CritSec
  • ~CTriColorWindow() : sealed
  • ~D2DFactoryLock() : D2DFactoryLock
  • ~DeviceAppPage() : DeviceAppForWebcam::sealed
  • ~Document() : Document
  • ~DrawingObject() : sealed
  • ~EventCallback() : SDKSample::PortableDeviceCPP::EventCallback
  • ~FeedData() : SimpleBlogReader::sealed
  • ~FeedItem() : SimpleBlogReader::sealed
  • ~Finally() : SDKSample::Finally
  • ~FrameProcessing() : FrameProcessing
  • ~Fx2Device() : Samples::Devices::Fx2::sealed
  • ~GeometryRealization() : GeometryRealization
  • ~GeometryRealizationFactory() : GeometryRealizationFactory
  • ~HttpRequestBuffersCallback() : Web::Details::HttpRequestBuffersCallback
  • ~HttpRequestStringCallback() : HttpRequestStringCallback
  • ~HubPhotoGroup() : Hilo::sealed
  • ~ImageBrowserViewModel() : Hilo::sealed
  • ~ImageSourceDrawHelper() : ContentImageSource::ImageSourceDrawHelper
  • ~ImageView() : Hilo::sealed
  • ~ImageViewModel() : Hilo::sealed
  • ~ImplData() : XAudio2SoundPlayer::ImplData
  • ~InvalidPageException() : PrintSample::InvalidPageException
  • ~LaunchFileInput() : AssociationLaunching::sealed
  • ~LaunchFileOutput() : AssociationLaunching::sealed
  • ~LaunchUriInput() : AssociationLaunching::sealed
  • ~LaunchUriOutput() : AssociationLaunching::sealed
  • ~List() : List< T >
  • ~ListenerContext()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • ~LocationBackgroundTask() : BackgroundTask::sealed
  • ~MainHubViewModel() : Hilo::sealed
  • ~MainPage()
: AccountPictureName::sealed
, AssociationLaunching::sealed
, Clipboard::sealed
, ContactPicker::sealed
, CredentialPickerCPP::sealed
, DatagramSocketSample::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
, ScheduledNotificationsSampleCPP::sealed
, SecondaryTiles::sealed
, ShareTarget::sealed
, StreamSocketSample::sealed
, ToastsSampleCPP::sealed
, DeviceAppForWebcam::sealed
, AppBarControl::sealed
  • ~MainPagePicker() : ContactPicker::sealed
  • ~MediaStreamer() : MediaStreamer
  • ~MEPlayer() : MEPlayer
  • ~MFSampleGenerator() : SDKSample::WASAPIAudio::MFSampleGenerator
  • ~OpQueue() : OpQueue< T, TOperation >
  • ~Parser() : Parser
  • ~Photo() : Hilo::sealed
  • ~Program() : Program
  • ~QueryChange() : Hilo::sealed
  • ~ReceiveFileInput() : AssociationLaunching::sealed
  • ~ReceiveFileOutput() : AssociationLaunching::sealed
  • ~ReceiveUriInput() : AssociationLaunching::sealed
  • ~ReceiveUriOutput() : AssociationLaunching::sealed
  • ~ReencodeState() : sealed
  • ~RenderBuffer() : RenderBuffer
  • ~Repeater() : Samples::Devices::Repeater
  • ~S2Formatter() : SDKSample::DataBinding::sealed
  • ~SampleBackgroundTask() : Tasks::sealed
  • ~Scenario1()
: SDKSample::BackgroundTransfer::sealed
, SDKSample::WebSocket::sealed
  • ~Scenario2()
: SDKSample::WASAPIAudio::sealed
, SDKSample::WebSocket::sealed
, SDKSample::BackgroundTransfer::sealed
  • ~Scenario3() : SDKSample::WASAPIAudio::sealed
  • ~ScenarioInput1()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, ToastsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
  • ~ScenarioInput2()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, LanguageFontCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
  • ~ScenarioInput3()
: MediaExtensionsCPP::sealed
, CredentialPickerCPP::sealed
, LockScreenAppsCPP::sealed
, ToastsSampleCPP::sealed
  • ~ScenarioInput4()
: MediaExtensionsCPP::sealed
, ToastsSampleCPP::sealed
  • ~ScenarioInput5() : ToastsSampleCPP::sealed
  • ~ScenarioInput6() : ToastsSampleCPP::sealed
  • ~ScenarioList()
: EdgeGestureSample::sealed
, PrintSample::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
, AssociationLaunching::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
  • ~ScenarioOutput1()
: ScheduledNotificationsSampleCPP::sealed
, LockScreenAppsCPP::sealed
, EdgeGestureSample::sealed
, PrintSample::sealed
, LanguageFontCPP::sealed
, ToastsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, CredentialPickerCPP::sealed
  • ~ScenarioOutput2()
: CredentialPickerCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, PrintSample::sealed
, LockScreenAppsCPP::sealed
, LanguageFontCPP::sealed
, EdgeGestureSample::sealed
  • ~ScenarioOutput3()
: PrintSample::sealed
, CredentialPickerCPP::sealed
, MediaExtensionsCPP::sealed
, LockScreenAppsCPP::sealed
, ToastsSampleCPP::sealed
  • ~ScenarioOutput4()
: PrintSample::sealed
, MediaExtensionsCPP::sealed
, ToastsSampleCPP::sealed
  • ~ScenarioOutput5() : ToastsSampleCPP::sealed
  • ~ScenarioOutput6()
: ToastsSampleCPP::sealed
, PrintSample::sealed
  • ~ScopedObject() : ScopedObject< T >
  • ~ScratchImage() : DirectX::ScratchImage
  • ~SDKMesh() : SDKMesh
  • ~ServicingComplete() : Tasks::sealed
  • ~SetRateOp() : SetRateOp
  • ~Shape() : Shape
  • ~SocketContext() : DatagramSocketSample::sealed
  • ~SoundCallbackHander() : anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • ~SourceOp() : SourceOp
  • ~StartOp() : StartOp
  • ~StreamEffect() : StreamEffect
  • ~StreamingVoiceContext() : StreamingVoiceContext
  • ~StreamList() : StreamList
  • ~TextureLock() : TextureLock
  • ~ToneSampleGenerator() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • ~TripOptimizer() : TripOptimizerComponent::sealed
  • ~UserInterface() : UserInterface
  • ~VideoBufferLock() : VideoBufferLock
  • ~VideoChat() : SimpleCommunication::sealed
  • ~WASAPICapture() : SDKSample::WASAPIAudio::WASAPICapture
  • ~WASAPIRenderer() : SDKSample::WASAPIAudio::WASAPIRenderer
  • ~WinRTComponent() : Wrapper::sealed
  • ~XAudio2SoundPlayer() : XAudio2SoundPlayer
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- a -

  • AcceptChildNode() : Design , Element , List< T > , Page , Layer , Text
  • Accessibility() : SDKSample::HighContrast::sealed
  • AccessibilityGetSettings_Click() : SDKSample::HighContrast::sealed
  • AccumulateSphereTriangleIntersections() : Collision
  • ActionTransition() : SimpleCommunication::sealed
  • Activate() : SDKSample::FilePickerContracts::sealed , CMPEG1Stream
  • ActivateCompleted()
: SDKSample::WASAPIAudio::WASAPIRenderer
, SDKSample::WASAPIAudio::WASAPICapture
  • Active() : GameObject , GameTimer , MoveLookController , GameObject , GameTimer , MoveLookController
  • Add()
: SDKSample::FlipViewData::sealed
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
, SDKSample::Playlists::sealed
, SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • AddButtonClicked() : Postcard::sealed
  • AddCallback_Click() : SDKSample::SDKTemplate::sealed
  • AddChild() : Element
  • AddConstructionPaperClicked() : Postcard::sealed
  • AddContentValue() : ShareTarget::sealed
  • AddEffectsClicked() : Postcard::sealed
  • AddEffectToImageStream() : SDKSample::MediaCapture::sealed
  • AddFavoriteButton_Click() : AppBarControl::sealed
  • AddFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • AddGeometry() : OutlineRenderer
  • AddImage() : Postcard::sealed
  • AddInputStreams() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • AddItem() : ScheduledNotificationsSampleCPP::sealed
  • AddLocalFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • AddMenuItem() : D2DInterpolationModes
  • AddObserver()
: Hilo::FileSystemRepository
, Hilo::ObservableQuery
  • AddOnePrintPreviewPage()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • AddPaper() : PaperRenderer , PostcardRenderer
  • AddPrintPages()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • AddQuickLink_Checked() : ShareTarget::sealed
  • AddQuickLink_Unchecked() : ShareTarget::sealed
  • AddRef() : ContentImageSource , FontFileStream , FontLoader , ImageFile , InlineImage
  • AddRepulsor() : SimpleSprites
  • Address_KeyUp() : SDKSample::WebViewControl::sealed
  • AddSampleContact() : ContactPicker::sealed
  • AddSamplesToQueue() : SDKSample::WASAPIAudio::MFSampleGenerator
  • AddScoreToTable() : HighScoreTable
  • AddSettingsScenario() : SDKSample::ApplicationSettings::sealed
  • addSettingsScenarioAdd_Click() : SDKSample::ApplicationSettings::sealed
  • AddShape() : Program
  • AddSibling() : Element
  • AddSignatureClicked() : Postcard::sealed
  • AddSound() : XAudio2SoundPlayer
  • AddStream() : StreamList
  • AddSuggestionFromNode() : SDKSample::SearchContract::sealed
  • AddTextClicked() : Postcard::sealed
  • AddTexture() : BasicSprites::SpriteBatch
  • AddToListButton_Click() : SDKSample::FileAccess::sealed
  • AddToSelection() : SDKSample::TouchKeyboard::sealed
  • AddTouch() : MarbleMaze
  • AddURIIfValid() : SDKSample::SDKTemplate::sealed
  • AddURLFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • AdvancedCapture() : SDKSample::MediaCapture::sealed
  • AdviseEventAdded() : CAppWindowProvider
  • AdviseEventRemoved() : CAppWindowProvider
  • Allocate() : Buffer
  • AllocateStreamingResources() : CDecoder
  • AmpPixel() : AmpPixel
  • AnalyzeBidi() : TextAnalysis
  • AnalyzeGlyphOrientation() : TextAnalysis
  • AnimatePosition() : GameObject
  • Animation() : Animation< T >
  • Animations_SelectionChanged() : SDKSample::AnimationMetrics::sealed
  • Ant() : AntSystem::Ant
  • App()
: Hilo::sealed
, SDKTemplate::App
, ScheduledNotificationsSampleCPP::sealed
, SecondaryTiles::sealed
, ToastsSampleCPP::sealed
, SDKTemplate::App
, DeviceAppForWebcam::sealed
, MediaExtensionsCS::App
, Simple3DGameXaml::sealed
, AssociationLaunching::sealed
, Magazine::sealed
, D2DLightingEffects::sealed
, ShareTarget::sealed
, CredentialPickerCPP::sealed
, ProximityCPP::sealed
, PrintSample::sealed
, SDKTemplate::App
, LockScreenAppsCPP::sealed
, SimpleBlogReader::sealed
, SDKTemplate::App
, D2D3DTransforms::sealed
, Postcard::sealed
, EdgeGestureSample::sealed
, RawNotificationsSampleCPP::sealed
, LanguageFontCPP::sealed
, SDKTemplate::App
  • App::EnsureMainPageActivated() : SDKSample::App
  • App::OnActivated() : AssociationLaunching::sealed
  • App::OnFileActivated() : AssociationLaunching::sealed
  • App::OnResume() : Hilo::sealed
  • AppendAudioTag() : NotificationsExtensions::ToastContent::ToastNotificationBase
  • AppListingUri() : SDKSample::StoreSample::sealed
  • AppListingUriRefreshScenario() : SDKSample::StoreSample::sealed
  • ApplyColorSimplifier() : FrameProcessing
  • ApplyEdgeDetection() : FrameProcessing
  • ApplyEdgeDetectionParallel() : FrameProcessing
  • ApplyFilters() : FrameProcessing
  • ApplyFont_Click() : LanguageFontCPP::sealed
  • ApplyForces() : Physics
  • ApplyJustificationSettings() : DWriteParagraphText
  • ApplySpacingSettings() : DWriteParagraphText
  • AppMuted()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • AppUnmuted()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • ArchitectureString() : SDKSample::PackageSample::sealed
  • ArrangeOverride() : Hilo::Common::sealed
  • AssignIndices()
: DirectX::D3DX_BC7
, DirectX::D3DX_BC6H
  • AsyncCallback() : AsyncCallback< T >
  • Attach() : sealed
  • AttachFeed() : SDKSample::sealed
  • AttachmentImage_RightTapped() : SDKSample::ContextMenu::sealed
  • AttachNavigationHandlers() : Hilo::HiloPage
  • AttachProgressAndCompletedHandlers() : SDKSample::BackgroundTask::sealed
  • AudioCapture()
: SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
  • AudioEngineCallbacks() : AudioEngineCallbacks
  • AudioSource() : MediaStreamSource::AudioSource
  • AudioSrcIsLooping() : NotificationsExtensions::ToastContent::ToastNotificationBase
  • AutoFire() : MoveLookController
  • AutoPlay() : MEPlayer
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- b -

  • b() : AmpPixel
  • Back() : List< T >
  • Back_Click() : AppBarControl::sealed
  • BackgroundObject() : sealed
  • BackgroundTask() : NetworkStatusTask::sealed
  • BackgroundTaskCompleted() : RawNotificationsSampleCPP::sealed
  • Backtrack() : AntSystem::Ant
  • BadgeGlyphNotificationContent() : NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
  • BadgeNumericNotificationContent() : NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
  • BarGraphDisplayResult() : Samples::Devices::Fx2::sealed
  • BasicCapture()
: MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • BasicCustomControl() : SDKSample::UserAndCustomControls::sealed
  • BasicReaderWriter() : BasicReaderWriter
  • BasicUserControl() : SDKSample::UserAndCustomControls::sealed
  • Begin() : BasicSprites::SpriteBatch
  • BeginAsyncOp() : CMPEG1Source
  • BeginGetEvent() : CMPEG1Source , CMPEG1Stream
  • BeginOpen() : CMPEG1Source
  • BeginStreaming() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CPolarEffect
  • BezierRender() : sealed
  • BindableNode() : SDKSample::sealed
  • BindableVectorChanged() : SDKSample::DataBinding::sealed
  • BindResource() : TextFrame , Element , ImageFrame
  • Bitmap() : GameInfoOverlay
  • Blob() : DirectX::Blob
  • BoldButtonClick() : SDKSample::TextEditing::sealed
  • BonusTime() : Simple3DGame
  • BottomAppBar_Closed() : SDKSample::WebViewControl::sealed
  • BottomAppBar_Opened()
: SecondaryTiles::sealed
, SDKSample::WebViewControl::sealed
  • BottonAppBar_Loaded() : AppBarControl::sealed
  • BrightPassDownFilter() : D3DPostProcessing
  • btmapImage_ImageOpened() : SDKSample::PlayToreceiver::sealed
  • btnFilePicker_Click() : SDKSample::WASAPIAudio::sealed
  • btnPause_Click() : SDKSample::WASAPIAudio::sealed
  • btnPlay_Click() : SDKSample::WASAPIAudio::sealed
  • btnPlayPause_Click() : SDKSample::WASAPIAudio::sealed
  • BtnRemoveTeam_Click() : SDKSample::DataBinding::sealed
  • btnStartCapture_Click() : SDKSample::WASAPIAudio::sealed
  • btnStartDevice_Click()
: SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
, SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
  • btnStartPreview_Click()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • btnStartStopRecord_Click()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • btnStop_Click() : SDKSample::WASAPIAudio::sealed
  • btnStopCapture_Click() : SDKSample::WASAPIAudio::sealed
  • btnTakePhoto_Click()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • Buffer() : Buffer
  • BuildCollisionListForSphere() : Collision
  • BuildDateQuery() : Hilo::sealed
  • Button_Click() : SecondaryTiles::sealed
  • Button_Pause_Click()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • Button_Play_Click()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • Button_Stop_Click()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • ButtonHangUp_Click() : SDKSample::CallControl::sealed
  • ButtonInitialize_Click() : SDKSample::CallControl::sealed
  • ButtonRing_Click() : SDKSample::CallControl::sealed
  • BuyProduct1Button_Click() : SDKSample::StoreSample::sealed
  • BuyProduct2_Click() : SDKSample::StoreSample::sealed
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- c -

  • CachedFileUpdater_Local() : SDKSample::FilePickerContracts::sealed
  • CachedFileUpdater_Remote() : SDKSample::FilePickerContracts::sealed
  • CachedFileUpdaterPage() : SDKSample::FilePickerContracts::sealed
  • CachedFileUpdaterPage_SizeChanged() : SDKSample::FilePickerContracts::sealed
  • CalculateCenterPosition() : D2DTextAnimation
  • CalculateContact() : Contact
  • CalculateCurrentRoomSize() : Physics
  • CalculateDeviceRotation() : SDKSample::DisplayOrientation::sealed
  • CalculateInitialCropOverlayPosition() : Hilo::sealed
  • CalculateSize() : ElementBase , TextElement , TextButton
  • CalculateSobel() : FrameProcessing
  • CalendarEnumerationAndMath() : SDKSample::CalendarSample::sealed
  • Call_Click() : SimpleCommunication::VideoChat
  • CallButton_Click() : SimpleCommunication::sealed
  • CallControlError() : SDKSample::CallControl::sealed
  • CallControls_AnswerRequested() : SDKSample::CallControl::sealed
  • CallControls_AudioTransferRequested() : SDKSample::CallControl::sealed
  • CallControls_DialRequested() : SDKSample::CallControl::sealed
  • CallControls_HangUpRequested() : SDKSample::CallControl::sealed
  • CallControls_RedialRequested() : SDKSample::CallControl::sealed
  • CallControlStatus() : SDKSample::CallControl::sealed
  • Cancel_Click() : SDKSample::HttpClientSample::sealed
  • CancelAll_Click() : SDKSample::BackgroundTransfer::sealed
  • CancelCartoonize() : Hilo::sealed
  • CancelCommand() : SDKSample::MessageDialogSample::sealed
  • CancelCommandButton_Click() : SDKSample::MessageDialogSample::sealed
  • CancelCrop() : Hilo::sealed
  • CancelDelayTimer() : SDKSample::ThreadPool::sealed
  • CancelGetGeolocation() : SDKSample::GeolocationCPP::sealed
  • CancelMonthAndYearQueries() : Hilo::sealed
  • CancelPeriodicTimer() : SDKSample::ThreadPool::sealed
  • CancelRotate() : Hilo::sealed
  • CancelThreadPoolWorkItem() : SDKSample::ThreadPool::sealed
  • CanExecute() : Hilo::sealed
  • CanNavigateToPictures() : Hilo::sealed
  • CanProcessImage() : Hilo::sealed
  • CAppWindowProvider() : CAppWindowProvider
  • CaptureDevice()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • CapturePhoto() : SDKSample::CameraCapture::sealed
  • CapturePhoto_Click() : SDKSample::CameraCapture::sealed
  • CaptureVideo() : SDKSample::CameraCapture::sealed
  • CaptureVideo_Click() : SDKSample::CameraCapture::sealed
  • CartoonizeImage() : Hilo::sealed
  • CartoonizeImageAmpAsync() : Hilo::sealed
  • CartoonizeImagePPLAsync() : Hilo::sealed
  • CartoonizeImageView() : Hilo::sealed
  • CAsyncState() : CAsyncState
  • CAutoDXDevLockBase() : CAutoDXDevLockBase< DevManager, DevInterface >
  • CAutoDXGILock() : CAutoDXGILock
  • ChangeInProgress() : Hilo::sealed
  • ChangeUser_Click() : SDKSample::PasswordVaultCPP::sealed
  • ChannelDown() : SDKSample::MediaButtons::sealed
  • ChannelUp() : SDKSample::MediaButtons::sealed
  • CheckBox_Checked_HorizontalRailed() : SDKSample::ScrollViewerCPP::sealed
  • CheckBox_Checked_VerticalRailed() : SDKSample::ScrollViewerCPP::sealed
  • CheckBox_Unchecked_HorizontalRailed() : SDKSample::ScrollViewerCPP::sealed
  • CheckBox_Unchecked_VerticalRailed() : SDKSample::ScrollViewerCPP::sealed
  • CheckDisconnected() : CAppWindowProvider
  • CheckDX11Device() : CInvert
  • CheckForCancellation() : Hilo::sealed
  • CheckForRecordingDeviceAsync() : SimpleCommunication::Common::CaptureDevice
  • CheckLoadDone() : SDKMesh
  • CheckResolutionAndViewState()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • CheckResult() : Samples::Devices::Fx2::sealed
  • CheckRotationAngle() : Hilo::sealed
  • CheckSharesVertsOrCoplanar() : Triangle
  • CheckShutdown() : CMPEG1Source , CMPEG1Stream
  • CheckStereoEnabledStatus() : abstract
  • chkAddRemoveEffect_Checked() : SDKSample::MediaCapture::sealed
  • chkAddRemoveEffect_Unchecked() : SDKSample::MediaCapture::sealed
  • Circle_Click()
: MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCPP::sealed
  • Clamp() : CommandListRenderer , CompositeModes , RippleEffect , WaveEffect , D2DInterpolationModes , DirectX::HDRColorA , DirectX::INTColor
  • Cleanup() : SimpleCommunication::sealed
  • CleanUp() : SimpleCommunication::sealed
  • CleanUpAsync() : SimpleCommunication::Common::CaptureDevice
  • CleanupAsync()
: SimpleCommunication::LowLatency
, SimpleCommunication::sealed
  • CleanupSink()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • Clear() : StreamList , List< T > , ComPtrList< T, NULLABLE > , StreamList , SDKSample::Playlists::sealed , SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , List< T > , ComPtrList< T, NULLABLE > , SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , Hilo::PhotoCache , List< T > , ComPtrList< T, NULLABLE >
  • Clear_Click() : SDKSample::ApplicationDataSample::sealed
  • ClearAllHighlightedWords() : SDKSample::TextEditing::sealed
  • ClearBadge_Click()
: SDKSample::Tiles::sealed
, LockScreenAppsCPP::sealed
  • ClearBarGraphTable()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • ClearCachedData() : Hilo::sealed
  • ClearImageData() : Hilo::sealed
  • ClearLastStatus() : SimpleCommunication::SdkSample
  • ClearLog() : ProximityCPP::sealed
  • ClearOutput() : Clipboard::sealed
  • ClearOutputButton_Click() : Clipboard::sealed
  • ClearPacket() : Parser
  • ClearPageCollection() : PrintSample::sealed
  • ClearPreference_Click() : SDKSample::Rotation::sealed
  • ClearScenario() : SDKSample::ApplicationDataSample::sealed
  • ClearSwitchStateTable() : SDKSample::CustomDeviceAccess::sealed
  • ClearTile_Click()
: SDKSample::Tiles::sealed
, LockScreenAppsCPP::sealed
  • ClickMeButtonClicked() : SDKSample::UserAndCustomControls::sealed
  • Clone() : ImageFile , SDKSample::TouchKeyboard::sealed
  • Close()
: Extruder::ExtrudingSink
, PointSnapper::PointSnappingSink
  • Close_Click() : SDKSample::WebSocket::sealed
  • CloseAnimatedPopupClicked() : SDKSample::XAMLPopup::sealed
  • CloseChannel_Click() : SDKSample::SDKTemplate::sealed
  • Closed() : SDKSample::WebSocket::sealed
  • CloseFilePicker() : MEPlayer
  • CloseFx2Device() : SDKSample::CustomDeviceAccess::sealed
  • CloseMedia() : MediaStreamSource::PcmSource
  • ClosePopupClicked() : SDKSample::XAMLPopup::sealed
  • ClosePrintControl() : PageRenderer
  • CloseSettingsPopupClicked() : SDKSample::XAMLPopup::sealed
  • CloseSocket() : ProximityCPP::sealed
  • CloseSockets_Click()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • CMPEG1Source() : CMPEG1Source
  • CMPEG1Stream() : CMPEG1Stream
  • Collision() : Collision
  • ColorButtonClick() : SDKSample::TextEditing::sealed
  • ColorOffsetValueChanged() : SDKSample::Drawing::sealed
  • ColorSelectionChanged() : SDKSample::Drawing::sealed
  • ComBase() : ComBase< InterfaceChain >
  • CombineGlow() : D3DPostProcessing
  • ComboBox1_DropDownClosed() : SDKSample::WebViewControl::sealed
  • ComboBox1_DropDownOpened() : SDKSample::WebViewControl::sealed
  • ComboBox_SelectionChanged_1() : SDKSample::ScrollViewerCPP::sealed
  • CommandInvokedHandler() : SDKSample::MessageDialogSample::sealed
  • Commit() : ImageFile
  • Compare() : SDKSample::TouchKeyboard::sealed
  • CompareEndpoints() : SDKSample::TouchKeyboard::sealed
  • CompleteAsyncOp() : CMPEG1Source
  • CompletedCallback() : SDKSample::MessageDialogSample::sealed
  • CompletedCallbackButton_Click() : SDKSample::MessageDialogSample::sealed
  • CompleteOpen() : CMPEG1Source
  • CompositeSettings() : SDKSample::ApplicationDataSample::sealed
  • ComputeIndex() : DirectX::TexMetadata
  • ComputeTriangleLocation() : D2DBasicAnimation
  • ComputeValue() : Animation< T > , LinearAnimation< T > , EaseInExponentialAnimation< T > , EaseOutExponentialAnimation< T > , EaseInOutExponentialAnimation< T >
  • ConfigureDeviceInternal() : SDKSample::WASAPIAudio::WASAPIRenderer
  • ConfigureSource() : SDKSample::WASAPIAudio::WASAPIRenderer
  • ConfigureStreams() : SDKSample::WASAPIAudio::MFSampleGenerator
  • ConnectionProfileList() : SDKSample::NetworkInformationApi::sealed
  • ConnectionProfileList_Click() : SDKSample::NetworkInformationApi::sealed
  • ConnectionRequestedEventHandler() : ProximityCPP::sealed
  • ConnectSocket_Click()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • Contact() : Contact
  • ContactList_SelectionChanged() : ContactPicker::sealed
  • ContactPickerPage() : ContactPicker::sealed
  • ContainerDisplayItem() : SDKSample::DeviceEnumeration::sealed
  • Containers() : SDKSample::DeviceEnumeration::sealed
  • Contains() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • ContainsKey() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • ContainsTextPosition() : TextAnalysis::Run
  • ContentImageSource() : ContentImageSource
  • ContextChanged() : SDKSample::ApplicationResources::sealed
  • ContinuationPage() : PrintSample::sealed
  • ContinueGame() : Simple3DGame
  • Continuous() : abstract
  • ControlRect() : UiaCoreWindowProvider::ITriColorControlInternal
  • ControlValue() : UiaCoreWindowProvider::ITriColorControlInternal
  • Convert()
: SimpleBlogReader::sealed
, Hilo::sealed
, Hilo::Common::sealed
, Hilo::sealed
, SDKSample::DataBinding::sealed
  • ConvertBack()
: SimpleBlogReader::sealed
, Hilo::sealed
, Hilo::Common::sealed
, Hilo::sealed
, SDKSample::DataBinding::sealed
  • ConvertDegreesRotationToExifOrientation() : Hilo::ExifExtensions
  • ConvertDipsToPixels() : abstract
  • ConvertExifOrientationToDegreesRotation() : Hilo::ExifExtensions
  • ConvertIndexToColor() : SDKSample::MainPage
  • ConvertResolution()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ConvertStrokeToGeometry() : InkRenderer
  • ConvertTrial_Click() : SDKSample::StoreSample::sealed
  • ConvertViewState()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::SnapSample::sealed
, ToastsSampleCPP::sealed
  • CopyAmpPixelArrayToPixelData() : Hilo::sealed
  • CopyBitmap() : Clipboard::sealed
  • CopyButton_Click() : Clipboard::sealed
  • CopyFile() : SDKSample::ApplicationDataSample::sealed
  • CopyFileButton_Click() : SDKSample::FileAccess::sealed
  • CopyFiles() : Clipboard::sealed
  • CopyFileToFolderOnStorageAsync() : SDKSample::RemovableStorageCPP::sealed
  • CopyImage() : Clipboard::sealed
  • CopyPixelDataToAmpPixelArray() : Hilo::sealed
  • CopyPixelDataToPlatformArray() : Hilo::sealed
  • CopyText() : Clipboard::sealed
  • CopyTo() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , ImageFile , SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • CopyWithDelayedRenderingButton_Click() : Clipboard::sealed
  • CoreDispatcher_AcceleratorKeyActivated()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • CoreWindow_PointerPressed()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • CoTaskMemFreeArray() : SDKSample::CoTaskMemFreeArray
  • CountdownTimer() : CountdownTimer
  • Create() : GeometryRealization , GeometryRealizationFactory , Element , SDKMesh , SDKSample::Playlists::sealed
  • CreateAndThenDeleteFolderOnDeviceAsync() : SDKSample::PortableDeviceCPP::sealed
  • CreateAudioResources() : StreamEffect
  • CreateAudioType() : SDKSample::WASAPIAudio::MFSampleGenerator
  • CreateAudioVoices() : AudioController
  • CreateBackBuffers() : MEPlayer
  • CreateBadgeAndTextTile_Click() : LockScreenAppsCPP::sealed
  • CreateBadgeTile_Click() : LockScreenAppsCPP::sealed
  • CreateBooleanTable()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • CreateBox() : BasicShapes
  • CreateBuffers() : ExtrudedTextRenderer
  • CreateContainer_Click() : SDKSample::ApplicationDataSample::sealed
  • CreateCube() : BasicShapes
  • CreateDataTask() : Web::Details::HttpRequestBuffersCallback
  • CreateDelayTimer() : SDKSample::ThreadPool::sealed
  • CreateDeviceIndependentResources() : D2D3DTransformsRenderer , abstract , D2DTextAnimation , abstract , D2DBasicAnimation , abstract , D2DEffectsHelloWorld , abstract , CompositeModes , abstract , ConvolveMatrixEffect , abstract , D2DEffectsOnPrimitives , abstract , GeometryRealizationSample , abstract , Renderer , D2DPerspectiveTransform , abstract , PageRenderer , abstract , SaveAsImageFile , PageRenderer , abstract , BumpMapping , abstract , DirectXFractal , D3DPostProcessing , abstract , ResourceLoading , abstract , SimpleSprites , abstract , StereoSimpleD3D , abstract , Direct3DTutorial , abstract , sealed , TextInterop , abstract , DWriteCustomTextRenderer , abstract , DWriteHelloWorld , abstract , DWriteHitTesting , abstract , DWriteInlineObject , abstract , CoreWindowEvents , DWriteParagraphText , abstract , DWriteVerticalText , Audio , abstract , GameHud , GameInfoOverlay , GameRenderer , abstract , ExtrudedTextRenderer , InkRenderer , PaperRenderer , PostcardRenderer , abstract , Simple3DTouch , abstract , OfferReclaimAPI , abstract , sealed , abstract , D2DLightingEffectsRenderer , abstract , Audio , GameHud , GameRenderer , BasicSound , abstract , StreamEffect , abstract
  • CreateDeviceResources() : PostcardRenderer , DWriteInlineObject , DWriteHelloWorld , TextInterop , ResourceLoading , DirectXFractal , abstract , Renderer , abstract , D2D3DTransformsRenderer , abstract , D2DTextAnimation , D2DBasicAnimation , abstract , D2DEffectsHelloWorld , CommandListRenderer , abstract , CompositeModes , abstract , ConvolveMatrixEffect , abstract , D2DEffectsOnPrimitives , abstract , GeometryRealizationSample , D2DInterpolationModes , abstract , D2DPerspectiveTransform , abstract , PageRenderer , abstract , SaveAsImageFile , PageRenderer , BumpMapping , abstract , D3DPostProcessing , abstract , SimpleSprites , abstract , StereoSimpleD3D , Direct3DTutorial , abstract , DWriteCustomTextRenderer , abstract , DWriteHitTesting , abstract , DWriteParagraphText , abstract , DWriteVerticalText , abstract , GameHud , GameInfoOverlay , abstract , MarbleMaze , abstract , ImageRenderer , InkRenderer , PaperRenderer , CoreWindowEvents , abstract , Simple3DTouch , abstract , OfferReclaimAPI , abstract , sealed , abstract , sealed , abstract , GameHud , GameRenderer , BasicSound , abstract , AudioController , abstract , StreamEffect , SimpleController , D2DLightingEffectsRenderer , abstract , DxgiRotation , ExtrudedTextRenderer , GameRenderer
  • CreateDpiDependentResources() : GameInfoOverlay
  • CreateDX11Device() : MEPlayer
  • CreateEffectGraph() : D2DEffectsHelloWorld , D2DEffectsOnPrimitives
  • CreateEnumeratorFromKey() : FontLoader
  • CreateExtrudingSink() : Extruder::ExtrudingSink
  • CreateFileButton_Click() : SDKSample::FileAccess::sealed
  • CreateFileQuery() : Hilo::FileSystemRepository
  • CreateFromFile() : SDKMesh
  • CreateFromMemory() : SDKMesh
  • CreateGameDeviceResourcesAsync() : GameRenderer
  • CreateGeometries() : GeometryRealizationSample
  • CreateGeometryRealization() : GeometryRealizationFactory
  • CreateGraph() : TripOptimizerComponent::Details::TripOptimizerImpl
  • CreateHeaderTextBlock() : SDKSample::FolderEnumeration::sealed
  • CreateHitTextureResourceView() : TargetTexture
  • CreateIndexBuffer() : BasicShapes , SDKMesh , BasicShapes
  • CreateInputLayout() : BasicLoader
  • CreateInstance() : CMPEG1Source
  • CreateLineItemTextBlock() : SDKSample::FolderEnumeration::sealed
  • CreateLocalThumbnailAsync() : Hilo::ThumbnailGenerator
  • CreateMemoryStream() : Web::HttpRequest
  • CreateMesh() : BasicLoader
  • CreateMonthRangeFromDate() : Hilo::CalendarExtensions
  • CreateMonthRangeFromYearAndMonth() : Hilo::CalendarExtensions
  • CreateNotification()
: NotificationsExtensions::ToastContent::ToastNotificationBase
, NotificationsExtensions::TileContent::TileNotificationBase
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::ToastContent::ToastNotificationBase
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::TileContent::TileNotificationBase
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
  • CreateOp() : SourceOp
  • CreateOpacityMask() : D2DTextAnimation
  • CreateOutlineRenderer() : OutlineRenderer
  • CreatePeriodicTimer() : SDKSample::ThreadPool::sealed
  • CreatePlaylist() : SDKSample::MediaButtons::sealed
  • CreatePointSnappingSink() : PointSnapper::PointSnappingSink
  • CreatePresentationDescriptor() : CMPEG1Source
  • CreatePrimitives() : D2DEffectsOnPrimitives
  • CreatePrintControl() : PageRenderer
  • CreatePrintPreviewPages()
: PrintSample::sealed
, PrintSample::BasePrintPage
  • CreateRandomizedVector() : Hilo::RandomPhotoSelector
  • CreateReferenceAxis() : BasicShapes
  • CreateRequest_Click() : SDKSample::CertificateEnrollment::sealed
  • CreateResources() : Audio
  • CreateReverb() : Audio
  • CreateRippleImpl() : RippleEffect
  • CreateSample() : MediaStreamSource::PcmSource
  • CreateSetRateOp() : SourceOp
  • CreateSourceVoice() : Audio
  • CreateSphere() : BasicShapes
  • CreateSpiralPathAndTriangle() : D2DBasicAnimation
  • CreateStartOp() : SourceOp
  • CreateStream() : CMPEG1Source
  • CreateStreamFromKey() : FontLoader
  • CreateTangentSphere() : BasicShapes
  • CreateTangentVertexBuffer() : BasicShapes
  • CreateTextLayout() : TextElement
  • CreateTexture() : BasicLoader
  • CreateTextureResourceView() : TargetTexture
  • CreateThemeSpecificResources() : sealed
  • CreateThreadPoolWorkItem() : SDKSample::ThreadPool::sealed
  • CreateThumbnailFromPictureFileAsync() : Hilo::ThumbnailGenerator
  • CreateTileSquareBlock() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareImage() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquarePeekImageAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquarePeekImageAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquarePeekImageAndText03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquarePeekImageAndText04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareText03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileSquareText04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideBlockAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideBlockAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideImage() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideImageAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideImageAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideImageCollection() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage05() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImage06() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection05() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWidePeekImageCollection06() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideSmallImageAndText05() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText01() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText02() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText03() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText04() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText05() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText06() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText07() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText08() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText09() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText10() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateTileWideText11() : NotificationsExtensions::TileContent::TileContentFactory
  • CreateVertexBuffer() : BasicShapes , SDKMesh , BasicShapes
  • CreateView() : DirectXAppSource , sealed , DirectXAppSource , Direct3DTutorialFrameworkViewSource , DirectXAppSource , CTriColorWindowFactory , DirectXAppSource , sealed , DirectXAppSource , Direct3DTutorialFrameworkViewSource , DirectXAppSource
  • CreateWaveImpl() : WaveEffect
  • CreateWAVFile() : SDKSample::WASAPIAudio::WASAPICapture
  • CreateWindowSizeDependentResources() : abstract , StereoSimpleD3D , AudioController , abstract , Simple3DTouch , DxgiRotation , sealed , MarbleMaze , sealed , Direct3DTutorialFrameworkView , abstract , ConvolveMatrixEffect , abstract , D2DPerspectiveTransform , D2DEffectsOnPrimitives , D3DPostProcessing , abstract , Direct3DTutorialFrameworkView , abstract , sealed , abstract , PaperRenderer , DWriteHelloWorld , DWriteInlineObject , abstract , InkRenderer , abstract , D2D3DTransformsRenderer , abstract , BasicSound , abstract , DWriteCustomTextRenderer , abstract , ImageRenderer , D2DLightingEffectsRenderer , abstract , SimpleController , PostcardRenderer , DirectXFractal , SimpleSprites , abstract , ResourceLoading , BumpMapping , TextInterop , DWriteHitTesting , OfferReclaimAPI , abstract , D2DEffectsHelloWorld , abstract , DWriteVerticalText , ExtrudedTextRenderer , abstract , Direct3DTutorial , DWriteParagraphText , abstract , CompositeModes , abstract , Direct3DTutorialFrameworkView , Program , abstract , D2DInterpolationModes , StreamEffect , abstract , Direct3DTutorialFrameworkView , abstract
  • CritSec() : CritSec
  • CropImage() : Hilo::sealed
  • CropImageAsync() : Hilo::sealed
  • CropImageView() : Hilo::sealed
  • CStreamState() : CStreamState
  • CTriColorWindow() : sealed
  • CurrencyFormatting() : SDKSample::NumberFormatting::sealed
  • Current_DeviceClosing() : SDKSample::CustomDeviceAccess::sealed
  • CurrentFreeSize() : Buffer
  • CurrentInputLanguage() : SDKSample::GlobalizationPreferencesSample::sealed
  • CurrentLevel() : Simple3DGame
  • Custom() : SDKSample::Transcode::sealed
  • CustomCommand() : SDKSample::MessageDialogSample::sealed
  • CustomCommandButton_Click() : SDKSample::MessageDialogSample::sealed
  • CustomTextBox() : SDKSample::TouchKeyboard::sealed
  • CustomTextRenderer() : CustomTextRenderer
  • CycleBackground() : Simple3DGame , Simple3DGameXaml::sealed
  • Cylinder() : Cylinder
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- d -

  • D2DFactoryLock() : D2DFactoryLock
  • D2DFlatten() : Extruder
  • D2DOutline() : Extruder
  • Data() : SourceOp
  • DataChangedEvent() : SDKSample::ApplicationDataSample::sealed
  • DataChangedHandler() : SDKSample::ApplicationDataSample::sealed
  • DataPtr() : Buffer
  • DataSize() : Buffer
  • dataTransferManager_DataRequested() : SDKSample::WebViewControl::sealed
  • Deactivate() : SimpleCommunication::sealed
  • DebugReset() : Physics
  • DecimalFormatting() : SDKSample::NumberFormatting::sealed
  • Decode()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • DecodeFromIndex()
: DirectX::BC4_UNORM
, DirectX::BC4_SNORM
  • DecodeImage() : D2DEffectsHelloWorld
  • Default_Click()
: SDKSample::CryptoWinRT::sealed
, SDKSample::HomeGroup::sealed
, SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
, SDKSample::IsRemoteSession::sealed
, SDKSample::PlaybackManager::sealed
, SDKSample::Compression::sealed
, SDKSample::HighContrast::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::Compression::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::Compression::sealed
, SDKSample::TextEditing::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::TextEditing::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::CryptoWinRT::sealed
  • DefaultCloseCommand() : SDKSample::MessageDialogSample::sealed
  • DefaultCloseCommandButton_Click() : SDKSample::MessageDialogSample::sealed
  • DefaultPage() : ShareTarget::sealed
  • DefaultRadius() : CPolarEffect
  • DefaultScenario() : SDKSample::ApplicationSettings::sealed
  • DefaultTheta() : CPolarEffect
  • Deinitialize() : SimpleCommunication::SdkSample
  • DelayTimerScenario() : SDKSample::ThreadPool::sealed
  • DelegateCommand() : Hilo::sealed
  • DelegationTickets() : SDKSample::MicrosoftAccount::sealed
  • DeleteAllStrokes() : InkRenderer
  • DeleteCompositeSetting_Click() : SDKSample::ApplicationDataSample::sealed
  • DeleteContainer_Click() : SDKSample::ApplicationDataSample::sealed
  • DeleteFileButton_Click() : SDKSample::FileAccess::sealed
  • DeleteInputStream() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • DeleteItem_Click() : SDKSample::AtomPub::sealed
  • DeleteSetting_Click() : SDKSample::ApplicationDataSample::sealed
  • DeliverPayload() : CMPEG1Source , CMPEG1Stream
  • DeltaTime() : GameTimer
  • Deserialize() : sealed , ManipulatableObject
  • DesignTimeData() : Hilo::sealed
  • DesignTimeMonthBlock() : Hilo::sealed
  • DesignTimePhotoGroup() : Hilo::sealed
  • DesignTimeYearGroup() : Hilo::sealed
  • DesignToDisplayHeight() : Document
  • DesignToDisplayWidth() : Document
  • Destroy() : SDKMesh
  • Detach() : sealed
  • DetachNavigationHandlers() : Hilo::HiloPage
  • DetermineFractalTechnique() : DirectXFractal
  • DetermineVisualState()
: SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
  • device_CaptureFailed()
: SimpleCommunication::LowLatency
, SimpleCommunication::VideoChat
  • device_IncomingConnectionArrived()
: SimpleCommunication::LowLatency
, SimpleCommunication::VideoChat
  • DeviceAppPage()
: SDKTemplate::DeviceAppPage
, DeviceAppForWebcam::sealed
  • DeviceArrived() : ProximityCPP::sealed
  • DeviceAsync()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • deviceAsyncGet_Click_1()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • deviceAsyncSet_Click_1()
: CustomDeviceAccess::DeviceAsync
, SDKSample::CustomDeviceAccess::sealed
  • DeviceConnect() : SDKSample::CustomDeviceAccess::sealed
  • deviceConnectDevices_SelectionChanged_1() : SDKSample::CustomDeviceAccess::sealed
  • deviceConnectStart_Click_1() : SDKSample::CustomDeviceAccess::sealed
  • deviceConnectStop_Click_1() : SDKSample::CustomDeviceAccess::sealed
  • DeviceControlResult() : Samples::Devices::DeviceControlResult
  • DeviceDeparted() : ProximityCPP::sealed
  • DeviceEvents() : SDKSample::CustomDeviceAccess::sealed
  • deviceEventsGet_Click_1() : SDKSample::CustomDeviceAccess::sealed
  • deviceEventsRegister_Click_1() : SDKSample::CustomDeviceAccess::sealed
  • DeviceList()
: SDKSample::CustomDeviceAccess::DeviceList
, CustomDeviceAccess::DeviceList
  • DeviceList_Tapped()
: SDKSample::RemovableStorageCPP::sealed
, SDKSample::PortableDeviceCPP::sealed
, SDKSample::RemovableStorageCPP::sealed
  • DeviceListEntry()
: CustomDeviceAccess::DeviceListEntry
, SDKSample::CustomDeviceAccess::sealed
  • DeviceStateChangedEvent() : SDKSample::WASAPIAudio::sealed
  • DipsToPixelsRoundDown() : FPSCounter
  • DipsToPixelsRoundUp() : FPSCounter
  • Disable() : Wrapper::sealed
  • DisableButtons() : SDKSample::Transcode::sealed
  • disableHangUpButton() : SDKSample::CallControl::sealed
  • disableIncomingCallButton() : SDKSample::CallControl::sealed
  • disableInitializeButton() : SDKSample::CallControl::sealed
  • DisableNotificationQueue_Click() : SDKSample::Tiles::sealed
  • DiscardGeometries() : GeometryRealizationSample
  • DiscardThemeSpecificResources() : sealed
  • Disconnect() : UiaCoreWindowProvider::IDisconnectableProvider , CAppWindowProvider
  • DiscoverActiveDownloads() : SDKSample::BackgroundTransfer::sealed
  • DiscoverActiveUploads() : SDKSample::BackgroundTransfer::sealed
  • DismissedEventHandler() : SDKSample::SplashScreen::sealed
  • DispatchOperation() : OpQueue< T, TOperation > , CMPEG1Source , OpQueue< T, TOperation > , CMPEG1Source
  • DispatchSamples() : CMPEG1Stream
  • Display() : SDKSample::Playlists::sealed
  • Display_Click()
: SDKSample::CalendarSample::sealed
, SDKSample::DateTimeFormatting::sealed
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::NumberFormatting::sealed
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::DateTimeFormatting::sealed
  • DisplayCalendarData() : SDKSample::CalendarSample::sealed
  • DisplayCalendarStatistics() : SDKSample::CalendarSample::sealed
  • DisplayCurrentItem() : SDKSample::Syndication::sealed
  • DisplayCurrentReading()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::InclinometerCPP::sealed
  • DisplayDeviceContainer() : SDKSample::DeviceEnumeration::sealed
  • DisplayDeviceInterface() : SDKSample::DeviceEnumeration::sealed
  • DisplayDeviceProperties() : SDKSample::PortableDeviceCPP::sealed
  • DisplayDeviceStatusAsync() : SDKSample::PortableDeviceCPP::sealed
  • DisplayDeviceStatusServiceProperties() : SDKSample::PortableDeviceCPP::sealed
  • DisplayError() : SimpleCommunication::SdkSample
  • DisplayFeed() : SDKSample::Syndication::sealed
  • DisplayFormats() : Clipboard::sealed
  • DisplayImageAsync() : SDKSample::RemovableStorageCPP::sealed
  • DisplayItem() : SDKSample::AtomPub::sealed
  • DisplayLanIdentifierData() : SDKSample::NetworkInformationApi::sealed
  • DisplayLink_Click() : SDKSample::StoreSample::sealed
  • DisplayMetrics() : SDKSample::AnimationMetrics::sealed
  • DisplayOrientation() : SDKSample::SimpleOrientationSensorCPP::sealed
  • DisplayOutput() : SDKSample::ApplicationDataSample::sealed
  • DisplayProperties_LogicalDpiChanged()
: AssociationLaunching::sealed
, SDKSample::Scaling::sealed
, LanguageFontCPP::sealed
, EdgeGestureSample::sealed
, SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
, CredentialPickerCPP::sealed
, LockScreenAppsCPP::sealed
, RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, PrintSample::sealed
, CredentialPickerCPP::sealed
, SDKSample::Scaling::sealed
, ScheduledNotificationsSampleCPP::sealed
  • DisplayProperties_OrientationChanged() : SDKSample::MediaCapture::sealed
  • DisplayResult() : SDKSample::MainPage
  • DisplayStatus()
: SDKSample::PlaybackManager2::sealed
, SDKSample::MediaButtons::sealed
, SDKSample::PlaybackManager::sealed
, SimpleCommunication::SdkSample
  • DisplayTextResult() : SDKSample::HttpClientSample::sealed
  • DisplayToDesignHeight() : Document
  • DisplayToDesignWidth() : Document
  • dmrImage_ImageFailed_1() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_CurrentStateChanged() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_DownloadProgressChanged_1() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_MediaEnded() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_MediaFailed() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_MediaOpened() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_RateChanged() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_SeekCompleted() : SDKSample::PlayToreceiver::sealed
  • dmrVideo_VolumeChanged() : SDKSample::PlayToreceiver::sealed
  • dmsRefreshButton_Click() : SDKSample::MediaServerClient::sealed
  • dmsSelect_SelectionChanged() : SDKSample::MediaServerClient::sealed
  • DoCleanup()
: SimpleCommunication::sealed
, SimpleCommunication::Common::CaptureDevice
  • DoCrop() : Hilo::sealed
  • DocumentLoaded() : Magazine::sealed
  • DoNavigation()
: PrintSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, EdgeGestureSample::sealed
, MediaExtensionsCPP::sealed
, SDKTemplateCS::MainPage
, AssociationLaunching::sealed
, ToastsSampleCPP::sealed
  • DoPause() : CMPEG1Source
  • DoScenario() : SDKSample::Compression::sealed
  • DoSetRate() : CMPEG1Source
  • DoSomething_Click()
: SDKSample::HighContrast::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
  • DoStart() : CMPEG1Source
  • DoStop() : CMPEG1Source
  • DownloadAsync() : Web::HttpRequest
  • DownloadProgress() : SDKSample::BackgroundTransfer::sealed
  • Draw() : BasicSprites::SpriteBatch , sealed , BasicSprites::SpriteBatch , PaperFragment , ContentImageSource , BasicSprites::SpriteBatch , List< T > , TextFrame , PageRendererContext , Element , Resource , Rectangle , InlineImage , GeometryRealization , BasicSprites::SpriteBatch , ImageFrame
  • Draw3DPerspectiveProperty() : D2D3DTransformsRenderer
  • DrawAtlasText() : FPSCounter
  • DrawBackground() : sealed
  • DrawBackward() : Program
  • DrawBitmap() : Image
  • DrawButtonText() : SimpleController
  • DrawChildren() : Element
  • DrawExtrudedText() : ExtrudedTextRenderer
  • DrawGlyphRun() : CustomTextRenderer , OutlineRenderer
  • DrawHeader() : SimpleController
  • DrawImageAndEffects() : ImageRenderer
  • DrawingObject() : sealed
  • DrawInk() : InkRenderer
  • DrawInlineObject() : CustomTextRenderer , OutlineRenderer
  • DrawMatrix() : D2D3DTransformsRenderer
  • DrawMessage() : PageRendererContext
  • DrawOverlay() : sealed
  • DrawPaper() : PaperRenderer
  • DrawPattern() : CommandListRenderer
  • DrawPreviewSurface() : PageRenderer
  • DrawQuad() : D3DPostProcessing
  • DrawStrikethrough() : OutlineRenderer , CustomTextRenderer
  • DrawSymbol() : D2D3DTransformsRenderer
  • DrawText() : SimpleController
  • DrawTextLayout() : D2DTextAnimation
  • DrawUnderline() : CustomTextRenderer , OutlineRenderer
  • Duration() : abstract
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- e -

  • EaseInExponentialAnimation() : EaseInExponentialAnimation< T >
  • EaseInOutExponentialAnimation() : EaseInOutExponentialAnimation< T >
  • EaseOutExponentialAnimation() : EaseOutExponentialAnimation< T >
  • EchoMessage() : DatagramSocketSample::sealed
  • Edge() : AntSystem::Edge
  • EffectIntensitySliderChanged() : Postcard::sealed
  • EffectsFlyout() : Postcard::sealed
  • ElementBase() : ElementBase
  • ElementProviderFromPoint() : CAppWindowProvider
  • EmitBlock()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • Employee() : SDKSample::DataBinding::sealed
  • employeeChanged() : SDKSample::DataBinding::sealed
  • EmptyClipboardButton_Click() : Clipboard::sealed
  • Enable() : Wrapper::sealed
  • EnableButton()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • EnableButtons() : SDKSample::Transcode::sealed
  • enableHangUpButton() : SDKSample::CallControl::sealed
  • enableIncomingCallButton() : SDKSample::CallControl::sealed
  • enableInitializeButton() : SDKSample::CallControl::sealed
  • EnableNotificationQueue() : SDKSample::Tiles::sealed
  • EnableNotificationQueue_Click() : SDKSample::Tiles::sealed
  • EnableVideoEffect() : MEPlayer
  • Encode()
: DirectX::D3DX_BC7
, DirectX::D3DX_BC6H
  • EncodeImageAsync() : Hilo::sealed
  • EncodeParams()
: DirectX::D3DX_BC6H::EncodeParams
, DirectX::D3DX_BC7::EncodeParams
  • EncodeRotateImageToStream() : Hilo::sealed
  • End() : BasicSprites::SpriteBatch
  • EndCall() : SimpleCommunication::sealed
  • EndCall_Click() : SimpleCommunication::VideoChat
  • EndCallAsync() : SimpleCommunication::VideoChat
  • EndCallButton_Click() : SimpleCommunication::sealed
  • EndGetEvent() : CMPEG1Source , CMPEG1Stream
  • EndOfMPEGStream() : CMPEG1Source
  • EndOfStream() : CMPEG1Stream
  • EndOpen() : CMPEG1Source
  • EndPointsFit() : DirectX::D3DX_BC6H
  • EndPosition() : List< T >
  • EndRotation() : Hilo::sealed
  • EndStreaming() : CPolarEffect , CGrayscale , CPolarEffect , CGrayscale
  • EnsureAppWindowProviderCreated() : sealed
  • EnsureControlProviderCreated() : sealed
  • EnsureFragmentProviderCreated() : sealed
  • EnsureMediaExtensionManager() : SDKTemplate::MainPage
  • EnsureUnsnapped() : SDKSample::MainPage
  • EnsureVisible() : Shape
  • Enumerate_Click() : SDKSample::WASAPIAudio::sealed
  • EnumerateAudioDevicesAsync() : SDKSample::WASAPIAudio::sealed
  • EnumerateDeviceContainers() : SDKSample::DeviceEnumeration::sealed
  • EnumerateDeviceInterfaces() : SDKSample::DeviceEnumeration::sealed
  • EnumerateObjects() : SDKSample::PortableDeviceCPP::sealed
  • EnumerateSecondaryTiles_Click() : SecondaryTiles::sealed
  • EnumerateTiles() : SecondaryTiles::sealed
  • EnumerateWebcamsAsync() : SDKSample::MediaCapture::sealed
  • EraseButtonClicked() : Postcard::sealed
  • EraseClicked() : Postcard::sealed
  • Evaluate() : abstract , AnimateLinePosition , AnimateLineListPosition , AnimateCirclePosition , AnimateLinePosition
  • EvaluateCommands() : Hilo::sealed
  • EventCallback() : SDKSample::PortableDeviceCPP::EventCallback
  • EventNotify() : MediaEngineNotify
  • EventPrint() : CoreWindowEvents
  • Execute() : Hilo::sealed
  • Exhaustive() : DirectX::D3DX_BC7
  • ExitApp() : MEPlayer
  • ExpandLongRunningShareSection_Checked() : ShareTarget::sealed
  • ExpandLongRunningShareSection_Unchecked() : ShareTarget::sealed
  • ExpandToEnclosingUnit() : SDKSample::TouchKeyboard::sealed
  • ExpiringProduct() : SDKSample::StoreSample::sealed
  • ExpiringProductRefreshScenario() : SDKSample::StoreSample::sealed
  • Explore() : AntSystem::Ant
  • ExtendedSplash() : SDKSample::SplashScreen::sealed
  • ExtendedSplash_OnResize() : SDKSample::SplashScreen::sealed
  • ExtractTrianglesFromMesh() : MarbleMaze
  • ExtrudeGeometry() : Extruder
  • ExtrudingSink() : Extruder::ExtrudingSink
  • Eye() : Camera
Generated on Sat Nov 23 2024 16:09:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- f -

  • F16ToINT() : DirectX::INTColor
  • Face() : Face
  • FadeOut() : TextElement
  • Failed()
: SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • FarClipPlane() : Camera
  • FastForward() : SDKSample::MediaButtons::sealed
  • FeedData() : SimpleBlogReader::sealed
  • FeedDataSource() : SimpleBlogReader::sealed
  • FeedItem() : SimpleBlogReader::sealed
  • FetchControllerInput() : AudioController , SimpleController
  • FetchNextRun() : TextAnalysis
  • FileIsCurrentButton_Click() : SDKSample::FilePickerContracts::sealed
  • FileOpenPicker_PickAppFile() : SDKSample::FilePickerContracts::sealed
  • FileOpenPicker_PickCachedFile() : SDKSample::FilePickerContracts::sealed
  • FileOpenPicker_PickURLFile() : SDKSample::FilePickerContracts::sealed
  • FileOpenPickerPage() : SDKSample::FilePickerContracts::sealed
  • FileOpenPickerPage_SizeChanged() : SDKSample::FilePickerContracts::sealed
  • Files() : SDKSample::ApplicationDataSample::sealed
  • FileSavePicker_FailToSave() : SDKSample::FilePickerContracts::sealed
  • FileSavePicker_SaveToAppStorage() : SDKSample::FilePickerContracts::sealed
  • FileSavePicker_SaveToCachedFile() : SDKSample::FilePickerContracts::sealed
  • FileSavePickerPage() : SDKSample::FilePickerContracts::sealed
  • FileSavePickerPage_SizeChanged() : SDKSample::FilePickerContracts::sealed
  • FileSizeConverter() : Hilo::sealed
  • FileSystemRepository() : Hilo::FileSystemRepository
  • Fill() : GeometryRealization
  • FillInPropertiesForFolder() : SDKSample::PortableDeviceCPP::sealed
  • FillInPropertiesForImage() : SDKSample::PortableDeviceCPP::sealed
  • FillSampleBuffer()
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::ToneSampleGenerator
  • FillSelection_SelectionChanged() : SDKSample::Drawing::sealed
  • FinalizeCreateGameDeviceResources() : GameRenderer
  • FinalizeLoadLevel() : Simple3DGame
  • FinalizeLoadLevelResources() : GameRenderer
  • Finally() : SDKSample::Finally
  • Find() : StreamList
  • FindAndHighlightText() : SDKSample::TextEditing::sealed
  • FindAndTransferFirstImageFileFromDevice() : SDKSample::PortableDeviceCPP::sealed
  • FindAttribute() : SDKSample::TouchKeyboard::sealed
  • FindBoxGotFocus() : SDKSample::TextEditing::sealed
  • FindBoxLostFocus() : SDKSample::TextEditing::sealed
  • FindBoxTextChanged() : SDKSample::TextEditing::sealed
  • FindDevice() : SDKSample::CustomDeviceAccess::DeviceList
  • FindEditUri() : SDKSample::AtomPub::sealed
  • FindFrame() : SDKMesh
  • FindInitialCollisions() : Physics
  • FindInList() : CustomDeviceAccess::DeviceList
  • FindNextStartCode() : Parser
  • FindText() : SDKSample::TouchKeyboard::sealed
  • FindWorstInterpenetration() : Collision
  • FinishCaptureAsync() : SDKSample::WASAPIAudio::WASAPICapture
  • FinishMonthAndYearQueries() : Hilo::sealed
  • FinishUnquantize() : DirectX::D3DX_BC6H
  • FireScript_Click() : SDKSample::WebViewControl::sealed
  • First() : SDKSample::DataBinding::sealed
  • FisheyeRadius() : CPolarEffect
  • FixWAVHeader() : SDKSample::WASAPIAudio::WASAPICapture
  • Flush()
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::ToneSampleGenerator
  • FontColorButtonClick() : SDKSample::TextEditing::sealed
  • FontColorButtonLostFocus() : SDKSample::TextEditing::sealed
  • FontFileStream() : FontFileStream
  • FontLoader() : FontLoader
  • Footer_Click()
: SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, MediaExtensionsCPP::sealed
, SDKTemplateCS::MainPage
, SDKSample::sealed
, LockScreenAppsCPP::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, LanguageFontCPP::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SimpleCommunication::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, CredentialPickerCPP::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, AssociationLaunching::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::sealed
, PrintSample::sealed
, SDKSample::sealed
, DeviceAppForWebcam::sealed
, AccountPictureName::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, ShareTarget::sealed
, SDKSample::sealed
, ToastsSampleCPP::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, ShareTarget::sealed
, SDKSample::sealed
, EdgeGestureSample::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SecondaryTiles::sealed
, SDKSample::sealed
  • FormatError() : SimpleCommunication::SdkSample
  • FrameData() : FrameData
  • FrameProcessing() : FrameProcessing
  • FrameStep() : MEPlayer
  • FrameworkView() : sealed
  • FrameworkViewSource() : sealed
  • FreeStreamingResources() : CDecoder
  • FromId() : Samples::Devices::Fx2::sealed
  • Front() : List< T >
  • FrontPosition() : List< T >
  • FullProduct_Click() : SDKSample::StoreSample::sealed
  • Fx2Device() : Samples::Devices::Fx2::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- g -

  • g() : AmpPixel
  • GameActive() : Simple3DGame
  • GameCamera() : Simple3DGame
  • GameInfoOverlayLowerRight() : GameRenderer
  • GameInfoOverlayUpperLeft() : GameRenderer
  • Generate() : Hilo::ThumbnailGenerator
  • GenerateMesh() : WaveEffect
  • GenerateOpacityMask() : GeometryRealization
  • GeneratePaletteQuantized()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • GeneratePaletteUnquantized() : DirectX::D3DX_BC6H
  • GeneratePaperBitmap() : PaperFragment
  • GeneratePersonNamesSource() : SDKSample::Accessibility::sealed
  • GeneratePolarLookup() : CPolarEffect
  • GenerateResults() : TextAnalysis
  • GenerateSampleBuffer() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • GenerateSampleStream() : SDKSample::HttpClientSample::sealed
  • GenerateSineSamples() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • GenerateTextOutline() : ExtrudedTextRenderer
  • Generator() : SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • GeographicRegionScenario() : SDKSample::GlobalizationPreferencesSample::sealed
  • GeometryRealization() : GeometryRealization
  • GeometryRealizationFactory() : GeometryRealizationFactory
  • Get() : ScopedObject< T >
  • get_BoundingRectangle() : CAppWindowProvider
  • get_DisplayMessage() : PrintSample::InvalidPageException
  • get_FragmentRoot() : CAppWindowProvider
  • get_HostRawElementProvider() : CAppWindowProvider
  • get_LookPoint() : LonLatController
  • get_Position() : LonLatController
  • get_ProviderOptions() : CAppWindowProvider
  • GetAcceleration() : Physics
  • GetAccountPicture() : AccountPictureName::sealed
  • GetAddress() : SDKSample::DataReaderWriter::sealed
  • GetAdjacencyIndexBuffer() : SDKMesh
  • GetAmplitude() : RippleEffect
  • GetAnimationKeyFromTime() : SDKMesh
  • GetAnimationProperties() : SDKMesh
  • GetAppWindowProvider() : UiaCoreWindowProvider::ITriColorControlInternal , sealed
  • GetAqsFormattedDate() : Hilo::CalendarExtensions
  • GetAsync() : Web::HttpRequest
  • GetAttributes() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetAttributeValue() : SDKSample::TouchKeyboard::sealed
  • GetAutomationControlTypeCore() : SDKSample::Accessibility::sealed
  • GetBack() : List< T >
  • GetBackgroundTaskStatus() : SDKSample::BackgroundTask::BackgroundTaskSample
  • GetBarGraphDisplayAsync() : Samples::Devices::Fx2::sealed
  • GetBit() : DirectX::CBits< SizeInBytes >
  • GetBits() : DirectX::CBits< SizeInBytes >
  • GetBoundingRectangles() : SDKSample::TouchKeyboard::sealed
  • GetBounds() : ElementBase
  • GetBreakConditions() : InlineImage
  • GetBufferFramesPerPeriod() : SDKSample::WASAPIAudio::WASAPIRenderer
  • GetBufferFromString() : SDKSample::FileAccess::sealed
  • GetBufferLength() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • GetBufferPointer() : DirectX::Blob
  • GetBufferSize() : DirectX::Blob
  • GetCalendar() : Hilo::CalendarExtensions
  • GetCenter() : RippleEffect
  • GetCharacteristics() : CMPEG1Source
  • GetChildren() : SDKSample::TouchKeyboard::sealed
  • GetClassNameCore()
: SDKSample::TouchKeyboard::sealed
, SDKSample::Accessibility::sealed
  • GetClient() : SDKSample::sealed
  • GetCollectionCount() : SDKSample::FlipViewData::sealed
  • GetCollisionEngine() : Physics
  • GetCollisionInfo() : Physics
  • GetColor() : sealed
  • GetCompletionEvent() : HttpRequestStringCallback
  • GetConnectionCostInfo() : SDKSample::NetworkInformationApi::sealed
  • GetConnectionProfile() : SDKSample::NetworkInformationApi::sealed
  • GetContent()
: NotificationsExtensions::NotificationBase
, SDKSample::sealed
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::NotificationBase
, NotificationsExtensions::TileContent::TileSquareBase
, NotificationsExtensions::TileContent::TileWideBase
, NotificationsExtensions::ToastContent::ToastNotificationBase
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::NotificationBase
, NotificationsExtensions::TileContent::TileSquareBase
, NotificationsExtensions::TileContent::TileWideBase
, NotificationsExtensions::ToastContent::ToastNotificationBase
, NotificationsExtensions::NotificationBase
  • GetContentFromDeviceAsync() : SDKSample::PortableDeviceCPP::sealed
  • GetContentRoot() : Document
  • GetCostBasedSuggestions() : SDKSample::NetworkInformationApi::sealed
  • GetCount() : List< T > , StreamList , List< T > , StreamList , List< T >
  • GetCurrentFontFile() : FontLoader
  • GetCurrentNode() : TreeIterator< T >
  • GetCurrentPhotoRotation() : SDKSample::MediaCapture::sealed
  • GetCurrentPolicy() : Hilo::ExceptionPolicyFactory
  • GetCurrentTransform() : CustomTextRenderer , OutlineRenderer
  • GetCustomProfile() : SDKSample::Transcode::sealed
  • GetCustomProperty() : Hilo::Common::BindableBase
  • GetD2DContext() : UserInterface
  • GetD2DDeviceContext() : Renderer
  • GetData() : VideoBufferLock
  • GetDataPlanStatusInfo() : SDKSample::NetworkInformationApi::sealed
  • GetDateQuery() : Hilo::ImageNavigationData
  • GetDateTimeForYearFolderAsync() : Hilo::FileSystemRepository
  • GetDecoderInfo() : Hilo::sealed
  • GetDependencies_Click() : SDKSample::PackageSample::sealed
  • GetDesign() : Story
  • GetDeviceDescription() : sealed
  • GetDeviceSelector() : Samples::Devices::Fx2::sealed
  • GetDeviceStateEvent()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • GetDiagnosticAsync() : MediaStreamSource::PcmSource
  • GetDisplayHeight() : Renderer
  • GetDisplayNameButton_Click() : AccountPictureName::sealed
  • GetDisplaySize() : Renderer
  • GetDisplayWidth() : Renderer
  • GetDistance() : Utils
  • GetDNSDomain_Click() : SDKSample::UserDomainName::sealed
  • GetDomainName() : SDKSample::UserDomainName::sealed
  • GetDspSetting() : Wrapper::sealed
  • GetDuration() : Animation< T > , MEPlayer
  • GetDWriteFactory() : Document , UserInterface
  • GetDXGIDevice() : Renderer
  • GetEditUri() : SDKSample::sealed
  • GetElapsedTime() : StopwatchTimer
  • GetElementRect() : LockScreenAppsCPP::sealed
  • GetEmbeddedFragmentRoots() : CAppWindowProvider
  • GetEnclosingElement() : SDKSample::TouchKeyboard::sealed
  • GetEnd() : Animation< T >
  • GetEntries() : HighScoreTable
  • GetEnumerator() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • GetError() : Web::Details::HttpRequestBuffersCallback
  • GetEvent() : CMPEG1Source , CMPEG1Stream
  • GetExclusionWith() : PaperFragment
  • GetExtension() : BasicLoader
  • GetFeed_Click()
: SDKSample::AtomPub::sealed
, SDKSample::Syndication::sealed
  • GetFeedAsync() : SimpleBlogReader::sealed
  • GetFeedData() : SimpleBlogReader::sealed
  • GetFeedItem() : SimpleBlogReader::sealed
  • GetFileDate() : Hilo::ImageNavigationData
  • GetFileNameFromFileSavePickerAsync() : Hilo::ImageBase
  • GetFilePath() : Hilo::ImageNavigationData
  • GetFilesAndFolderButton_Click() : SDKSample::FolderEnumeration::sealed
  • GetFilesButton_Click() : SDKSample::FolderEnumeration::sealed
  • GetFileSize() : FontFileStream , RandomAccessReader
  • GetFirstChild() : Element
  • GetFirstImageFromStorageAsync() : SDKSample::RemovableStorageCPP::sealed
  • GetFirstNameButton_Click() : AccountPictureName::sealed
  • GetFocus() : CAppWindowProvider
  • GetFolderPhotoCountAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetFontCollection() : Document
  • GetFormattedTime() : StopwatchTimer
  • GetForYearAndMonth() : Hilo::PhotoCache
  • GetFrame() : SDKMesh
  • GetFrequency() : RippleEffect
  • GetFront() : List< T >
  • GetGeolocation() : SDKSample::GeolocationCPP::sealed
  • GetGeometry() : OutlineRenderer
  • GetGeopositionAsync() : SDKSample::GeolocationCPP::sealed
  • GetGreenRect() : sealed
  • GetImage() : DirectX::ScratchImage
  • GetImage_Click() : SDKSample::RemovableStorageCPP::sealed
  • GetImageCount() : DirectX::ScratchImage
  • GetImagePhotoAsync() : Hilo::sealed
  • GetImages() : DirectX::ScratchImage
  • GetImageSize() : ContentImageSource
  • GetImageSource() : ContentImageSource
  • GetIndex()
: DirectX::BC4_UNORM
, DirectX::BC4_SNORM
  • GetIndexBuffer() : SDKMesh
  • GetIndexBufferAt() : SDKMesh
  • GetIndexBufferFormat() : SDKMesh
  • GetIndexDescription() : SDKSample::sealed
  • GetIndexedProperty() : Hilo::Common::BindableBase
  • GetIndexType() : SDKMesh
  • GetInfluenceMatrix() : SDKMesh
  • GetInputAvailableType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInputCurrentType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInputStatus() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInputStreamAttributes() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInputStreamInfo() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetInstalledLocation_Click() : SDKSample::PackageSample::sealed
  • GetInstance() : UserInterface
  • GetIntersectionWith() : PaperFragment
  • GetItem() : List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE >
  • GetItemAt() : SDKSample::FlipViewData::sealed
  • GetItemPos() : List< T >
  • GetLargeImageButton_Click() : AccountPictureName::sealed
  • GetLastNameButton_Click() : AccountPictureName::sealed
  • GetLastWriteTime() : FontFileStream
  • GetLength() : Text
  • GetLocaleName() : TextAnalysis
  • GetLocalizedAbbreviatedMonthName() : Hilo::CalendarExtensions
  • GetLocalizedControlTypeCore() : SDKSample::Accessibility::sealed
  • GetLocalizedMonthAndYear() : Hilo::CalendarExtensions
  • GetLocalizedYear() : Hilo::CalendarExtensions
  • GetLocation() : Document
  • GetLookPoint() : MoveLookController
  • GetMaterial() : SDKMesh
  • GetMaxStreamLengthInBytes() : MediaStreamer
  • GetMediaSource() : CMPEG1Stream
  • GetMergeWith() : PaperFragment
  • GetMesh() : SDKMesh
  • GetMeshBoundingBoxCenter() : SDKMesh
  • GetMeshBoundingBoxExtents() : SDKMesh
  • GetMeshInfluenceMatrix() : SDKMesh
  • GetMeshPath() : SDKMesh
  • GetMessageFormatNoRef() : PageRenderer
  • GetMetadata() : DirectX::ScratchImage
  • GetMetrics() : InlineImage
  • GetMFSample() : SDKSample::WASAPIAudio::WASAPIRenderer
  • GetMinDPI() : SDKSample::Scaling::sealed
  • GetMinResolution() : SDKSample::Scaling::sealed
  • GetMonthGroupedPhotosWithCacheAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetName() : Element
  • GetNeighbourArea() : FrameProcessing
  • GetNetworkSecuritySettingsInfo() : SDKSample::NetworkInformationApi::sealed
  • GetNextBuffer() : MediaStreamer
  • GetNextSibling() : Element
  • GetNonce() : SDKSample::CryptoWinRT::sealed
  • GetNormal() : Extruder::ExtrudingSink
  • GetNumberOfMonthsInYear() : Hilo::CalendarExtensions
  • GetNumberSubstitution() : TextAnalysis
  • GetNumericYear() : Hilo::CalendarExtensions
  • GetNumFrames() : SDKMesh
  • GetNumIndexBuffers() : SDKMesh
  • GetNumIndices() : SDKMesh
  • GetNumInfluences() : SDKMesh
  • GetNumMaterials() : SDKMesh
  • GetNumMeshes() : SDKMesh
  • GetNumSubsets() : SDKMesh
  • GetNumVertexBuffers() : SDKMesh
  • GetNumVertices() : SDKMesh
  • GetObjectDescription() : sealed
  • GetOpacity() : Element , Layer , Rectangle , TextFrame
  • GetOpenWithPosition() : AssociationLaunching::sealed
  • GetOriginalWicBitmapSourceNoRef() : PageRenderer
  • GetOutputAvailableType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputCurrentType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputStatus() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputStreamAttributes() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputStreamInfo() : CGrayscale , CInvert , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect
  • GetOutputWaveFormatEx() : MediaReader , MediaStreamer , MediaReader , MediaStreamer
  • GetOutstandingBufferResources() : SDKMesh
  • GetOutstandingResources() : SDKMesh
  • GetOverhangMetrics() : InlineImage
  • GetPackage_Click() : SDKSample::PackageSample::sealed
  • GetPagesInRange() : PrintSample::sealed
  • GetPageSize() : Design , Document
  • GetParameters() : AsyncCallback< T >
  • GetParent() : Element
  • GetPatternCore()
: SDKSample::TouchKeyboard::sealed
, SDKSample::Accessibility::sealed
  • GetPatternProvider() : CAppWindowProvider
  • GetPhase() : RippleEffect
  • GetPhotoDataForMonthGroup()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetPhotoForYearAndMonth() : Hilo::sealed
  • GetPhotosForDateRangeQueryAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetPhotosForPictureHubGroupAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetPhotoStorageFilesAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetPixel() : FrameProcessing
  • GetPixels() : DirectX::ScratchImage
  • GetPixelsPerDip() : CustomTextRenderer , OutlineRenderer
  • GetPixelsSize() : DirectX::ScratchImage
  • GetPlaceHolderImage() : SDKSample::MainPage
  • GetPlaybackPosition() : MEPlayer
  • GetPolygon() : Shape
  • GetPosition() : Physics , PaperFragment , MoveLookController , RandomAccessReader
  • GetPresentationDescriptor() : StartOp
  • GetPresetProfile() : SDKSample::Transcode::sealed
  • GetPreviewPageCollection() : CDocumentSource
  • GetPreviousPosition() : Physics
  • GetPrimitiveType() : SDKMesh
  • GetPrincipalName() : SDKSample::UserDomainName::sealed
  • GetPrincipalName_Click() : SDKSample::UserDomainName::sealed
  • GetPrintPreviewPage()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • GetProjectionMatrix() : BasicCamera , Camera , BasicCamera
  • GetPropertyDisplayValue() : SDKSample::FolderEnumeration::sealed
  • GetPropertyValue() : CAppWindowProvider
  • GetRadius() : Physics
  • GetRate() : SetRateOp , CMPEG1Source , SetRateOp , CMPEG1Source
  • GetRawIndicesAt() : SDKMesh
  • GetRawVerticesAt() : SDKMesh
  • GetReasonPhrase()
: HttpRequestStringCallback
, Web::HttpRequest
, Web::Details::HttpRequestBuffersCallback
, HttpRequestStringCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
  • GetRedRect() : sealed
  • GetRegisteredTask() : SDKSample::SDKTemplate::sealed
  • GetRenderer() : Document
  • GetRoomDimensions() : Physics
  • GetRoomSize() : Physics
  • GetRuntimeId() : CAppWindowProvider
  • GetSampleAsync() : MediaStreamSource::PcmSource
  • GetSelected() : TextButton
  • GetService() : CMPEG1Source
  • GetShareContent()
: SDKSample::ShareSource::sealed
, SDKSample::Common::SharePage
, SDKSample::ShareSource::sealed
  • GetSinglePhotoAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • GetSIPUri() : SDKSample::UserDomainName::sealed
  • GetSize() : Element
  • GetSkewX() : WaveEffect
  • GetSkewY() : WaveEffect
  • GetSmallImageButton_Click() : AccountPictureName::sealed
  • GetSoundCount() : XAudio2SoundPlayer
  • GetSoundData() : SoundFileReader
  • GetSoundFormat() : SoundFileReader
  • GetSpread() : RippleEffect
  • GetStart() : Animation< T >
  • GetState()
: Samples::Devices::Repeater
, SDKSample::WASAPIAudio::sealed
  • GetStateFileDate() : Hilo::sealed
  • GetStateFilePath() : Hilo::sealed
  • GetStateQuery() : Hilo::sealed
  • GetStatusCode()
: Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, Web::Details::HttpRequestBuffersCallback
, Web::HttpRequest
, HttpRequestStringCallback
, Web::Details::HttpRequestBuffersCallback
, HttpRequestStringCallback
  • GetStatusString() : SDKSample::ThreadPool::ThreadPoolSample
  • GetStereoEnabledStatus() : abstract
  • GetStereoExaggeration() : StereoSimpleD3D
  • GetStreamCount() : CGrayscale , CInvert , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect , CDecoder
  • GetStreamDescriptor() : CMPEG1Stream
  • GetStreamIDs() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CDecoder , CPolarEffect , CInvert
  • GetStreamLimits() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CInvert , CDecoder , CPolarEffect , CInvert
  • GetStreamWithFailCheck() : Hilo::ImageBase
  • GetStride() : VideoBufferLock
  • GetString()
: Hilo::IResourceLoader
, Hilo::sealed
  • GetStringRepresentation() : Hilo::Common::BindableBase
  • GetSubset() : SDKMesh
  • GetSuggestions() : SDKSample::SearchContract::sealed
  • GetSurfaceNormal() : Contact
  • GetSwapChainBackgroundPanel() : Simple3DGameXaml::sealed
  • GetSyndicationItem() : SDKSample::sealed
  • GetSystemHeader() : Parser
  • GetTask() : ReadStreamTask
  • GetText() : Text , SDKSample::TouchKeyboard::sealed
  • GetTextAtPosition() : TextAnalysis
  • GetTextBeforePosition() : TextAnalysis
  • GetTextFormat() : TextStyle
  • GetTextFormatNoRef() : PageRenderer
  • GetTextLayout() : Text
  • GetTextStyle() : TextElement
  • GetThumbnailButton_Click() : SDKSample::FileThumbnails::sealed
  • GetTileNotification() : Hilo::WideFiveImageTile
  • GetTimeStampedMessage()
: SDKSample::MediaButtons::sealed
, SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • GetTitle() : SDKSample::sealed
  • GetTitleHeightInDips() : SampleOverlay
  • GetToneSample() : SDKSample::WASAPIAudio::WASAPIRenderer
  • GetTour() : AntSystem::Ant
  • GetTriColorControlProvider() : UiaCoreWindowProvider::ITriColorControlInternal , sealed
  • GetTriColorFragmentProvider() : sealed , UiaCoreWindowProvider::ITriColorControlInternal
  • GetUri_Click() : SDKSample::UserDomainName::sealed
  • GetUserDisplayName() : AccountPictureName::sealed
  • GetUserFirstAndLastName() : AccountPictureName::sealed
  • GetValue() : Animation< T >
  • GetVelocity() : Physics
  • GetVertexBuffer() : SDKMesh
  • GetVertexBufferAt() : SDKMesh
  • GetVertexStride() : SDKMesh
  • GetVerticalGlyphOrientation() : TextAnalysis
  • GetVideoButton_Click() : AccountPictureName::sealed
  • GetView() : SDKSample::DataBinding::sealed
  • GetWaveOffset() : WaveEffect
  • GetWicBitmapSourceWithEmbeddedColorContextNoRef() : PageRenderer
  • GetWicColorContextNoRef() : PageRenderer
  • GetWICImagingFactory() : Renderer
  • GetWorldMatrix() : SDKMesh
  • GetWriter() : DatagramSocketSample::sealed
  • GetXml()
: NotificationsExtensions::NotificationBase
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::NotificationBase
  • GetYearGroupedMonthsAsync()
: Hilo::Repository
, Hilo::FileSystemRepository
  • GetYellowRect() : sealed
  • GiveControlFocus() : SDKSample::Accessibility::sealed
  • Globalization() : SDKSample::Tiles::sealed
  • GlobalPage() : AppBarControl::sealed
  • Go_Click()
: SDKSample::ELS::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::ELS::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::HighContrast::sealed
, SDKSample::ELS::sealed
, SDKSample::PasswordVaultCPP::sealed
  • GoBack()
: SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • GoForward()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • GoHome()
: SDKTemplate::Common::LayoutAwarePage
, Hilo::ViewModelBase
  • GotFocusHandler() : Postcard::sealed
  • GoToPage() : Hilo::ViewModelBase
  • GroupByHelper() : SDKSample::FolderEnumeration::sealed
  • GroupByMonthButton_Click() : SDKSample::FolderEnumeration::sealed
  • GroupByRatingButton_Click() : SDKSample::FolderEnumeration::sealed
  • GroupByTagButton_Click() : SDKSample::FolderEnumeration::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- h -

  • HadLoadingError() : SDKMesh
  • HandleClipboardChanged() : Clipboard::sealed
  • HandleCollisions() : Physics
  • HandleDeviceLost() : abstract , Renderer , abstract , DWriteInlineObject , abstract , GameRenderer , abstract , MarbleMaze , abstract , DirectXFractal , abstract , D3DPostProcessing , abstract , D2DLightingEffectsRenderer , abstract , GameRenderer , abstract
  • HandleDownloadAsync() : SDKSample::BackgroundTransfer::sealed
  • HandleException()
: Hilo::ExceptionPolicy
, SDKSample::WebSocket::sealed
, Hilo::DebugLoggingExceptionPolicy
  • HandleFileNotFoundException() : SDKSample::MainPage
  • HandleManipulationUpdated() : D2DInterpolationModes
  • HandlePointerDoubleTapped() : CommandListRenderer
  • HandlePointerPressed() : D2DInterpolationModes
  • HandleUploadAsync() : SDKSample::BackgroundTransfer::sealed
  • HandleViewManipulation() : DirectXFractal
  • HasElements() : SDKSample::sealed
  • HasEngineExperiencedCriticalError() : Audio
  • HasFocus() : UiaCoreWindowProvider::ITriColorControlInternal
  • HasKey() : SDKSample::DataBinding::sealed
  • HasMoreItemsOverride() : SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • HasPacket() : Parser
  • HasPendingOutput() : CGrayscale , CDecoder , CPolarEffect , CGrayscale , CDecoder , CPolarEffect
  • HasPhotosInRangeAsync()
: Hilo::FileSystemRepository
, Hilo::Repository
  • HasSystemHeader() : Parser
  • HasTextFormatChanged() : TextStyle
  • HDRColorA() : DirectX::HDRColorA
  • HexDump() : SDKSample::DataReaderWriter::sealed
  • Hide() : Postcard::sealed
  • HideGameInfoOverlay() : DirectXApp , GameInfoOverlay , Simple3DGameXaml::sealed
  • HideImageAndVideoControls() : AccountPictureName::sealed
  • HideSnapped() : Simple3DGameXaml::sealed , DirectXApp , Simple3DGameXaml::sealed
  • HighPriority() : SDKSample::ApplicationDataSample::sealed
  • HighScore() : Simple3DGame
  • HighScoreTable() : HighScoreTable
  • Hit() : GameObject
  • HitMaterial() : GameObject
  • HitSound() : GameObject
  • HitTest() : PaperFragment , sealed , UserInterface
  • HitTestFragmentsWithPosition() : PaperRenderer
  • HitTestWithGeometry() : PaperFragment
  • HitTime() : GameObject
  • Home_Click() : SDKSample::WebViewControl::sealed
  • HomeGroupAdvancedSearch() : SDKSample::HomeGroup::sealed
  • HomeGroupPicker() : SDKSample::HomeGroup::sealed
  • HomeGroupVideoStream() : SDKSample::HomeGroup::sealed
  • HRESULT() : IMft0Vtbl
  • hsbvCombo_SelectionChanged_1() : SDKSample::ScrollViewerCPP::sealed
  • hsmCombo_SelectionChanged_1() : SDKSample::ScrollViewerCPP::sealed
  • HttpRequest() : Web::HttpRequest
  • HttpRequest::PostAsync() : Web::HttpRequest
  • HttpRequestBuffersCallback() : Web::Details::HttpRequestBuffersCallback
  • HttpRequestStringCallback() : HttpRequestStringCallback
  • Hud() : GameRenderer
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- i -

  • IFACEMETHOD_() : CustomTextRenderer , ComBase< InterfaceChain >
  • IFACEMETHODIMP_() : WaveEffect , RippleEffect , WaveEffect , TextAnalysis , RippleEffect
  • ImageBrowserView() : Hilo::sealed
  • ImageFile() : ImageFile
  • ImageNavigationData() : Hilo::ImageNavigationData
  • ImageProtocols() : SDKSample::Tiles::sealed
  • ImageSourceDrawHelper() : ContentImageSource::ImageSourceDrawHelper
  • ImageView() : Hilo::sealed
  • ImageWithLabelControl() : SDKSample::UserAndCustomControls::sealed
  • ImplData::ImplData() : XAudio2SoundPlayer::ImplData
  • ImportPfx_Click() : SDKSample::CertificateEnrollment::sealed
  • InAppPurchase() : SDKSample::StoreSample::sealed
  • InAppPurchaseRefreshScenario() : SDKSample::StoreSample::sealed
  • Increment_Click() : SDKSample::ApplicationDataSample::sealed
  • IncrementHighPriority_Click() : SDKSample::ApplicationDataSample::sealed
  • InfoOverlay() : GameRenderer
  • Init() : SecondaryTiles::sealed
  • Initalize() : Buffer
  • InitDeviceWatcher()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • InitialisePlayToReceiver() : SDKSample::PlayToreceiver::sealed
  • Initialize() : FPSCounter , abstract , DWriteHelloWorld , GeometryRealization , SampleOverlay , abstract , GeometryRealizationFactory , DWriteHitTesting , SampleOverlay , GeometryRealizationSample , abstract , DWriteInlineObject , D2DTextAnimation , SampleOverlay , abstract , D2DInterpolationModes , DWriteParagraphText , SampleOverlay , abstract , DWriteVerticalText , SampleOverlay , Audio , SampleOverlay , ContentImageSource , Cylinder , DirectXApp , Design , abstract , GameRenderer , D2DBasicAnimation , Element , Level1 , Level2 , Image , Level3 , Level4 , abstract , ImageFrame , Level5 , MoveLookController , List< T > , Simple3DGame , SoundEffect , SampleOverlay , Rectangle , AudioEngineCallbacks , Audio , Text , DirectXApp , abstract , D2DEffectsHelloWorld , TextFrame , MarbleMaze , MediaStreamer , D2DPerspectiveTransform , SampleOverlay , ElementBase , abstract , TextElement , CountdownTimer , SampleOverlay , StopwatchTimer , TextButton , SampleOverlay , DirectXApp , HighScoreTable , UserInterface , abstract , CoreWindowEvents , CommandListRenderer , SampleOverlay , abstract , SampleOverlay , abstract , DirectXApp , abstract , SampleOverlay , MoveLookController , SampleOverlay , SaveAsImageFile , DirectXApp , abstract , SampleOverlay , DirectXApp , SampleOverlay , DirectXApp , abstract , SampleOverlay , CompositeModes , SampleOverlay , SDKSample::MainPage , Hilo::sealed , DirectXApp , Hilo::sealed , abstract , Hilo::sealed , sealed , SampleOverlay , abstract , sealed , SampleOverlay , DirectXApp , abstract , sealed , abstract , Program , ConvolveMatrixEffect , SampleOverlay , sealed , DirectXApp , sealed , MEPlayer , abstract , VideoView , CCopyModule , SampleOverlay , CInvertModule , CCopyModule , SampleOverlay , DirectXApp , CInvertModule , SimpleCommunication::sealed , abstract , SimpleCommunication::sealed , CAppWindowProvider , abstract , LonLatController , abstract , UiaCoreWindowProvider::IAppWindowProvider , SampleOverlay , UiaCoreWindowProvider::ITriColorControlProvider , UiaCoreWindowProvider::ITriColorFragmentProvider , SampleOverlay , DirectX::ScratchImage , sealed , SDKSample::WASAPIAudio::MFSampleGenerator , DirectX::Blob , SDKTemplate::DeviceAppPage , DeviceAppForWebcam::sealed , abstract , BasicSprites::SpriteBatch , Wrapper::sealed , abstract , DirectXApp , Audio , Cylinder , RippleEffect , abstract , GameRenderer , SampleOverlay , Level1 , Level2 , SampleOverlay , DirectXApp , Level3 , Level4 , abstract , Level5 , MoveLookController , abstract , SampleOverlay , Simple3DGame , SoundEffect , Direct3DTutorialFrameworkView , DirectXApp , abstract , SampleOverlay , Direct3DTutorialFrameworkView , SampleOverlay , DirectXApp , Direct3DTutorialFrameworkView , abstract , SampleOverlay , WaveEffect , Direct3DTutorialFrameworkView , DirectXApp , abstract , DirectXApp , SampleOverlay , DirectXApp , D2DEffectsOnPrimitives , abstract , SampleOverlay , abstract , DirectXApp , abstract , SampleOverlay , abstract , DWriteCustomTextRenderer , SampleOverlay
  • Initialize1D() : DirectX::ScratchImage
  • Initialize2D() : DirectX::ScratchImage
  • Initialize3D() : DirectX::ScratchImage
  • Initialize3DFromImages() : DirectX::ScratchImage
  • InitializeAmmo() : Simple3DGame
  • InitializeArrayFromImages() : DirectX::ScratchImage
  • InitializeAsync()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::LowLatency
, SimpleCommunication::VideoChat
, SimpleCommunication::sealed
  • InitializeAudioDeviceAsync()
: SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • InitializeBackgroundTaskStatus() : SDKSample::BackgroundTask::BackgroundTaskSample
  • InitializeCapture() : SDKSample::WASAPIAudio::sealed
  • InitializeCube() : DirectX::ScratchImage
  • InitializeCubeFromImages() : DirectX::ScratchImage
  • InitializeDevice() : SDKSample::WASAPIAudio::sealed
  • InitializeEdgeGestureHandlers() : EdgeGestureSample::sealed
  • InitializeFromImage() : DirectX::ScratchImage
  • InitializeGameConfig() : Simple3DGame
  • InitializeGameState() : DirectXApp , Simple3DGameXaml::sealed
  • InitializeLicense() : Simple3DGameXaml::sealed
  • InitializeLicenseCore() : Simple3DGameXaml::sealed
  • InitializeMediaServers() : SDKSample::MediaServerClient::sealed
  • InitializeObject() : Shape
  • InitializeScopeData() : SDKSample::WASAPIAudio::WASAPICapture
  • InitializeUIControls() : SimpleCommunication::sealed
  • InitializeValues()
: D2D3DTransforms::sealed
, D2DLightingEffects::sealed
  • InitializeVaultAsync() : SDKSample::PasswordVaultCPP::sealed
  • initializing_previewSetupCompleted() : SimpleCommunication::sealed
  • InitPresentationDescriptor() : CMPEG1Source
  • InitPrintManager() : DirectXApp
  • InlineImage() : InlineImage
  • inputFrameNavigated()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • InputPauseButton_Click() : SDKSample::Transcode::sealed
  • InputPlayButton_Click() : SDKSample::Transcode::sealed
  • InputStopButton_Click() : SDKSample::Transcode::sealed
  • InRegion() : Shape
  • Insert() : SDKSample::DataBinding::sealed
  • InsertAfter() : List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE >
  • InsertBack() : List< T >
  • InsertFront() : List< T >
  • InsertPhoto() : Hilo::PhotoCache
  • InsertPos() : List< T >
  • InspectableClass() : CDocumentSource , CAppWindowProvider
  • InstallCertifiate_Click() : SDKSample::CertificateEnrollment::sealed
  • INT2F16() : DirectX::INTColor
  • INTColor() : DirectX::INTColor
  • IntegrateSimulation() : Physics
  • InterfaceClasses_SelectionChanged() : SDKSample::DeviceEnumeration::sealed
  • InterfaceDisplayItem() : SDKSample::DeviceEnumeration::sealed
  • Interfaces() : SDKSample::DeviceEnumeration::sealed
  • InternalOptimizeTripAsync() : TripOptimizerComponent::Details::TripOptimizerImpl
  • InternalProcessOutput() : CDecoder
  • InternalSaveToFile() : Hilo::ThumbnailGenerator
  • InternetConnectionProfile() : SDKSample::NetworkInformationApi::sealed
  • InternetConnectionProfile_Click() : SDKSample::NetworkInformationApi::sealed
  • Interpolate() : DirectX::LDRColorA
  • InterpolateA() : DirectX::LDRColorA
  • InterpolateRGB() : DirectX::LDRColorA
  • IntersectsWithGround() : Collision
  • Invalidate() : Contact , CCopyModule , CInvertModule , CCopyModule , CInvertModule
  • InvalidateDX11Resources() : CInvert
  • InvalidateSize()
: SDKSample::sealed
, DeviceAppForWebcam::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SimpleCommunication::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
  • InvalidateViewState()
: SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, StreamSocketSample::sealed
, SDKSample::sealed
, DeviceAppForWebcam::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SimpleCommunication::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
  • InvalidateVisualState()
: SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • InvalidPageException() : PrintSample::InvalidPageException
  • Invoke() : AsyncCallback< T >
  • InvokeMapChanged() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • InvokePrintButtonClick() : PrintSample::sealed
  • InvokeSimpleToast() : Background::sealed
  • IsActive() : abstract , CMPEG1Stream , abstract
  • IsActivePlay() : Simple3DGame
  • IsAudioSetup() : StreamEffect
  • IsCartoonizing() : Hilo::sealed
  • IsColliding() : Contact
  • IsConnected() : DatagramSocketSample::sealed
  • IsCountdownComplete() : CountdownTimer
  • IsDegenerate() : Triangle
  • IsEmpty() : List< T >
  • IsEndOfStream() : Parser
  • IsEOF()
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::ToneSampleGenerator
  • IsFinished() : abstract
  • IsFiring() : MoveLookController
  • IsFirst() : TriColorValueHelper
  • IsInitialized() : CMPEG1Source
  • IsLast() : TriColorValueHelper
  • IsLaunchedByTap() : ProximityCPP::sealed
  • IsLoaded() : SDKMesh
  • IsLoading() : SDKMesh
  • IsMatching() : DatagramSocketSample::sealed
  • IsMoving() : Physics
  • IsNull() : ScopedObject< T >
  • IsOrientationLandscape() : Renderer
  • IsPauseRequested() : MoveLookController
  • IsPixelSnappingDisabled() : CustomTextRenderer , OutlineRenderer
  • IsPlaying() : MEPlayer
  • IsPreRollFilled() : SDKSample::WASAPIAudio::MFSampleGenerator
  • IsPressComplete() : MoveLookController
  • IsPressed() : TextButton
  • IsRateSupported() : CMPEG1Source
  • IsRegisteredForDeviceEvents() : SDKSample::PortableDeviceCPP::sealed
  • IsResponseComplete() : Web::HttpRequest
  • IsResponseReceived() : Web::Details::HttpRequestBuffersCallback
  • IsSeeking() : MEPlayer
  • IsSoundEffectStarted() : Audio
  • IsSoundPlaying() : XAudio2SoundPlayer
  • IsSticky_Click() : AppBarControl::sealed
  • IsStreamActive() : CMPEG1Source
  • IsStreamTypeSupported() : CMPEG1Source
  • IsThin() : SetRateOp
  • IsTouching() : GameObject , Face , Cylinder , Sphere , Face , Sphere , GameObject
  • IsTrial() : Simple3DGame
  • IsValidInputStream() : CPolarEffect , CDecoder , CGrayscale , CDecoder , CGrayscale , CPolarEffect
  • IsValidOutputStream() : CDecoder , CGrayscale , CDecoder , CPolarEffect
  • IsVisible() : ElementBase
  • ItalicButtonClick() : SDKSample::TextEditing::sealed
  • Item()
: List< T >::Node
, SDKSample::ListViewSampleDataSource::sealed
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, List< T >::Node
  • ItemClickHandler() : SDKSample::ListViewSimple::sealed
  • ItemCollection()
: SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, SDKSample::FlipViewData::sealed
  • ItemListView_SelectionChanged() : SimpleBlogReader::sealed
  • ItemsPage() : SimpleBlogReader::sealed
  • ItemView_ItemClick() : SimpleBlogReader::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- p -

  • PacketHeader() : Parser
  • Page1()
: SDKSample::PersonalityAnimations::sealed
, AppBarControl::sealed
  • Page2()
: AppBarControl::sealed
, SDKSample::PersonalityAnimations::sealed
  • Page3() : AppBarControl::sealed
  • Page_Loaded()
: AssociationLaunching::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, CredentialPickerCPP::sealed
, ToastsSampleCPP::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
  • Page_SizeChanged()
: ToastsSampleCPP::sealed
, AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::SnapSample::sealed
, ToastsSampleCPP::sealed
  • PageLoadedHandler() : SimpleBlogReader::sealed
  • PageTwo_Click() : AppBarControl::sealed
  • PageWithAppBar() : SDKSample::WebViewControl::sealed
  • Paginate() : CDocumentSource
  • Paint() : Shape
  • PaperFlyout() : Postcard::sealed
  • PaperFlyoutAddPaperClicked() : Postcard::sealed
  • PaperFlyoutDeletePaperClicked() : Postcard::sealed
  • PaperFlyoutMoveClicked() : Postcard::sealed
  • PaperFlyoutStampClicked() : Postcard::sealed
  • ParametrizedTemplate() : SDKSample::DateTimeFormatting::sealed
  • Parent() : ManipulatableObject
  • ParentTransform() : ManipulatableObject
  • Parse() : Document
  • ParseBytes() : Parser
  • ParseColor() : Element
  • ParseData() : CMPEG1Source
  • ParseErrorCode() : SDKSample::ProvisioningAgent::sealed
  • ParseNameIdentifier() : Element
  • ParsePacketHeader() : Parser
  • ParsePackHeader() : Parser
  • Parser() : Parser
  • ParseResultXML() : SDKSample::ProvisioningAgent::sealed
  • ParseSystemHeader() : Parser
  • PasswordField_PasswordChanged() : SDKSample::AtomPub::sealed
  • PasteButton_Click() : Clipboard::sealed
  • Pause() : SDKSample::MediaButtons::sealed , MEPlayer , CMPEG1Source , CMPEG1Stream , SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • PauseAll_Click() : SDKSample::BackgroundTransfer::sealed
  • PauseAudio() : SDKSample::CallControl::sealed
  • pauseButton_Click() : SDKSample::PlayTo::sealed
  • PauseDevice() : SDKSample::WASAPIAudio::sealed
  • PauseGame() : Simple3DGame
  • PausePlaybackAsync() : SDKSample::WASAPIAudio::WASAPIRenderer
  • PauseRequested() : Simple3DGameXaml::sealed
  • pauseSlideshow_Click() : SDKSample::PlayTo::sealed
  • PayloadSize() : Parser
  • PcmSource() : MediaStreamSource::PcmSource
  • PeerFinder_Accept() : ProximityCPP::sealed
  • PeerFinder_BrowsePeers() : ProximityCPP::sealed
  • PeerFinder_Connect() : ProximityCPP::sealed
  • PeerFinder_Send() : ProximityCPP::sealed
  • PeerFinder_StartFindingPeers() : ProximityCPP::sealed
  • PeerFinder_StartReader() : ProximityCPP::sealed
  • PeerFinder_StartSendReceive() : ProximityCPP::sealed
  • PeerFinderInit() : ProximityCPP::sealed
  • PeerFinderReset() : ProximityCPP::sealed
  • PeerFinderScenario() : ProximityCPP::sealed
  • PeriodicTimerScenario() : SDKSample::ThreadPool::sealed
  • Person() : SDKSample::Accessibility::sealed
  • PerturbOne()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • PhoneCall() : SDKSample::CallControl::sealed
  • PhotoRotationLookup() : SDKSample::MediaCapture::sealed
  • PhotoSizeChanged() : Hilo::sealed
  • Physics() : Physics
  • PickAContactButton_Click() : ContactPicker::sealed
  • PickAFileButton_Click() : SDKSample::FilePicker::sealed
  • PickAndLaunchFileButton_Click() : AssociationLaunching::sealed
  • PickAndSetButton_Click() : SDKSample::Personalization::sealed
  • PickAudioButton_Click() : SDKSample::Playlists::sealed
  • PickContactsButton_Click() : ContactPicker::sealed
  • PickFile() : SDKSample::Transcode::sealed
  • PickFileButton_Click()
: SDKSample::FilePicker::sealed
, SDKSample::FilePickerContracts::sealed
  • PickFilesButton_Click() : SDKSample::FilePicker::sealed
  • PickFolderButton_Click() : SDKSample::FilePicker::sealed
  • PickImage_Click() : SDKSample::Tiles::sealed
  • PickPlaylist() : SDKSample::MainPage
  • PickPlaylistButton_Click() : SDKSample::Playlists::sealed
  • PickSingleFileAndSet()
: SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
  • PictureChanged() : AccountPictureName::sealed
  • PictureTime() : CStreamState
  • PinButton_Click() : SecondaryTiles::sealed
  • PinchRadius() : CPolarEffect
  • PinFromAppbar() : SecondaryTiles::sealed
  • PinLiveTile_Click() : SecondaryTiles::sealed
  • PinTile() : SecondaryTiles::sealed
  • Pitch() : Camera , MoveLookController , Camera , MoveLookController
  • PixelsToDips() : FPSCounter
  • Play() : SDKSample::MediaButtons::sealed , MEPlayer , SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • Play_Click() : SDKSample::MediaButtons::sealed
  • PlayAudio() : SDKSample::CallControl::sealed
  • PlaybackControl()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • playButton_Click() : SDKSample::PlayTo::sealed
  • PlayFile() : SDKSample::Transcode::sealed
  • PlayingTime() : GameTimer
  • Playlist_SelectionChanged() : SDKSample::PlayTo::sealed
  • playListPlayNext() : SDKSample::PlayTo::sealed
  • playlistTimer_Tick() : SDKSample::PlayTo::sealed
  • PlayPause() : SDKSample::MediaButtons::sealed
  • PlayPauseToggle() : SDKSample::WASAPIAudio::sealed
  • playSlideshow_Click() : SDKSample::PlayTo::sealed
  • PlaySound() : GameObject , SoundEffect , GameObject , SoundEffect , XAudio2SoundPlayer
  • PlaySoundEffect() : Audio
  • playToManager_SourceRequested() : SDKSample::PlayTo::sealed
  • PlotDataReadyEvent() : SDKSample::WASAPIAudio::sealed
  • PlotEasingFunctionGraph() : SDKSample::Animation::sealed
  • Pointer() : SDKSample::DeviceCaps::sealed
  • PointerGetSettings_Click() : SDKSample::DeviceCaps::sealed
  • PointerType() : SDKSample::DeviceCaps::sealed
  • PointHitTest() : Program
  • PointInRect() : sealed
  • PointSnappingSink() : PointSnapper::PointSnappingSink
  • PopInClick() : SDKSample::PersonalityAnimations::sealed
  • PopOutClick() : SDKSample::PersonalityAnimations::sealed
  • PopulateScenarios()
: SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, SimpleCommunication::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
  • PopupInputContent() : SDKSample::XAMLPopup::sealed
  • Portrait() : SDKSample::Rotation::sealed
  • PortraitFlipped() : SDKSample::Rotation::sealed
  • Position() : GameObject , Sphere , GameObject , Sphere
  • POSITION() : List< T >::POSITION
  • Position() : GameObject
  • POSITION() : List< T >::POSITION
  • PositionAtlasText() : FPSCounter
  • PositionImage() : SDKSample::SplashScreen::sealed
  • PostAsync() : Web::HttpRequest
  • PrepareContainerForItemOverride()
: Hilo::sealed
, SDKSample::Accessibility::sealed
  • PrepareForRender() : WaveEffect , RippleEffect
  • PrepareForVideoRecording() : SDKSample::MediaCapture::sealed
  • PrepareToDraw() : Resource , Element , TextFrame
  • PrepareToDrawChildren() : Element
  • PreparetPrintContent() : PrintSample::sealed
  • Present() : abstract , sealed , abstract
  • Presets() : SDKSample::Transcode::sealed
  • PressComplete() : Simple3DGameXaml::sealed
  • Preview_Click() : SimpleCommunication::LowLatency
  • PreviewButtonClicked() : SimpleCommunication::sealed
  • previewing_localClientButtonClicked() : SimpleCommunication::sealed
  • previewing_previewButtonClicked() : SimpleCommunication::sealed
  • Previewing_PreviewButtonClicked() : SimpleCommunication::LowLatency
  • previewing_recordingStarted() : SimpleCommunication::sealed
  • PreviewSetupCompleted() : SimpleCommunication::LowLatency
  • PreviewUnavailable() : PrintSample::sealed
  • PreviousItem_Click() : SDKSample::AtomPub::sealed
  • previousItem_Click() : SDKSample::PlayTo::sealed
  • PreviousItem_Click()
: SDKSample::Syndication::sealed
, SDKSample::AtomPub::sealed
  • PreviousValue() : TriColorValueHelper
  • PrevTrack() : SDKSample::MediaButtons::sealed
  • printDetailedOptions_OptionChanged() : PrintSample::sealed
  • PrintDetailedOptionsOptionChanged() : PrintSample::sealed
  • PrintExceptionCode() : SDKSample::ProvisioningAgent::sealed
  • PrintPage() : PageRenderer
  • PrintPointerInfo() : CoreWindowEvents
  • PrintRow() : SDKSample::DataReaderWriter::sealed
  • PrintTaskRequested()
: PrintSample::sealed
, PrintSample::BasePrintPage
, PrintSample::sealed
  • Process() : CDecoder
  • ProcessEvent() : CDecoder , CGrayscale , CInvert , CPolarEffect , CInvert
  • ProcessFrame() : CCopyModule , CInvertModule , CCopyModule
  • ProcessInput() : CDecoder , CGrayscale , CInvert , CPolarEffect , CInvert , CPolarEffect , CGrayscale , CDecoder
  • ProcessLocation() : TripOptimizerComponent::Details::TripOptimizerImpl
  • ProcessMessage() : CGrayscale , CDecoder , CInvert , CPolarEffect , CInvert , CPolarEffect
  • ProcessOutput() : CGrayscale , CPolarEffect , CGrayscale , CDecoder , CInvert , CPolarEffect
  • ProcessQueue() : OpQueue< T, TOperation >
  • ProcessQueueAsync() : OpQueue< T, TOperation >
  • ProcessRoute() : TripOptimizerComponent::Details::TripOptimizerImpl
  • ProcessScopeData() : SDKSample::WASAPIAudio::WASAPICapture
  • ProfileLocalUsageData() : SDKSample::NetworkInformationApi::sealed
  • ProfileLocalUsageData_Click() : SDKSample::NetworkInformationApi::sealed
  • Projection() : Camera
  • Protocol_SelectionChanged() : CredentialPickerCPP::sealed
  • ProtocolList_SelectionChanged() : SDKSample::Tiles::sealed
  • ProvideUpdatedVersionButton_Click() : SDKSample::FilePickerContracts::sealed
  • ProvisionMno() : SDKSample::ProvisioningAgent::sealed
  • ProvisionMno_Click() : SDKSample::ProvisioningAgent::sealed
  • ProximityDevice_PublishMessage() : ProximityCPP::sealed
  • ProximityDevice_SubscribeForMessage() : ProximityCPP::sealed
  • ProximityDeviceEvents() : ProximityCPP::sealed
  • ProximityDeviceScenario() : ProximityCPP::sealed
  • PtFromPx() : SDKSample::Scaling::sealed
  • Ptr() : Buffer
  • PxFromPt() : SDKSample::Scaling::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- q -

  • Quantize()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • QuantizeEndPts() : DirectX::D3DX_BC6H
  • QueryInterface() : GeometryRealizationFactory , Extruder::ExtrudingSink , OutlineRenderer , ContentImageSource , PointSnapper::PointSnappingSink , MediaEngineNotify , RippleEffect , FontFileStream , AsyncCallback< T > , SourceOp , FontLoader , CMPEG1Source , AsyncCallback< T > , WaveEffect , ImageFile , AsyncCallback< T > , CMPEG1Stream , SourceOp , CMPEG1Source , CustomTextRenderer , GeometryRealization , InlineImage , ComBase< InterfaceChain >
  • QueryInterfaceInternal() : QiList< InterfaceName, QiListNil > , QiListSelf< InterfaceName, InterfaceChain > , QiList< InterfaceName, InterfaceChain >
  • QueryLockScreenAccess_Click() : LockScreenAppsCPP::sealed
  • QueryPhotoCount() : Hilo::sealed
  • QueryPhotosAsync() : Hilo::sealed
  • QuerySinglePhotoAsync() : Hilo::sealed
  • QueueAsyncOperation() : CMPEG1Source
  • QueueEvent() : CMPEG1Source , CMPEG1Stream
  • QueueOperation() : OpQueue< T, TOperation >
  • QuickLinkSectionLabel_Tapped() : ShareTarget::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- r -

  • r() : AmpPixel
  • R()
: DirectX::BC4_UNORM
, DirectX::BC4_SNORM
  • radioFile_Checked() : SDKSample::WASAPIAudio::sealed
  • radioTone_Checked() : SDKSample::WASAPIAudio::sealed
  • Radius() : Sphere
  • RandFloat() : SimpleSprites
  • RandomFloat() : PaperRenderer
  • Read() : ImageFile , RandomAccessReader
  • ReadAll() : MediaStreamer
  • ReadAsync() : Web::HttpRequest
  • ReadBytes() : SDKSample::DataReaderWriter::sealed
  • ReadBytesButton_Click() : SDKSample::FileAccess::sealed
  • ReadChunk() : ReadStreamTask::ReadStreamTaskImpl
  • ReadCounter() : SDKSample::ApplicationDataSample::sealed
  • ReadData() : BasicReaderWriter , Web::Details::HttpRequestBuffersCallback , BasicReaderWriter , Web::Details::HttpRequestBuffersCallback , BasicReaderWriter
  • ReadDataAsync() : BasicReaderWriter
  • ReadFileFragment() : FontFileStream
  • ReadFromStreamButton_Click() : SDKSample::FileAccess::sealed
  • ReadingChanged()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
  • ReadLoop() : SDKSample::DataReaderWriter::sealed
  • ReadOnlyTextBox_ContextMenuOpening() : SDKSample::ContextMenu::sealed
  • ReadPayload() : CMPEG1Source
  • ReadStreamTask() : ReadStreamTask
  • ReadStreamTaskImpl() : ReadStreamTask::ReadStreamTaskImpl
  • ReadTextButton_Click() : SDKSample::FileAccess::sealed
  • ReadUtf8StringFromSequentialStream() : HttpRequestStringCallback
  • Ready() : ImageFile
  • RealVSyncTimer() : MEPlayer
  • Receipt() : SDKSample::StoreSample::sealed
  • ReceiptRefreshScenario() : SDKSample::StoreSample::sealed
  • ReceiveFileInput() : AssociationLaunching::sealed
  • ReceiveFileOutput() : AssociationLaunching::sealed
  • receiver_CurrentTimeChangeRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_MuteChangeRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_PauseRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_PlaybackRateChangeRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_PlayRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_SourceChangeRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_StopRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_TimeUpdateRequested() : SDKSample::PlayToreceiver::sealed
  • receiver_VolumeChangeRequestedEvent() : SDKSample::PlayToreceiver::sealed
  • ReceiveStringLoop() : StreamSocketSample::sealed
  • ReceiveUriInput() : AssociationLaunching::sealed
  • ReceiveUriOutput() : AssociationLaunching::sealed
  • Record() : SDKSample::MediaButtons::sealed
  • RecordLimitationExceeded()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • Rect() : DirectX::Rect
  • RectFromValue() : UiaCoreWindowProvider::ITriColorControlInternal
  • ReencodePhotoAsync() : SDKSample::MediaCapture::sealed
  • ReencodeState() : sealed
  • Refine()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • Refresh() : ScheduledNotificationsSampleCPP::sealed
  • RefreshList_Click() : ScheduledNotificationsSampleCPP::sealed
  • RefreshListView() : ScheduledNotificationsSampleCPP::sealed
  • RefreshPreview() : PrintSample::sealed
  • Register() : RippleEffect , WaveEffect
  • RegisterAppBarButtons() : AppBarControl::sealed
  • RegisterBackgroundTask()
: SDKSample::BackgroundTask::BackgroundTaskSample
, SDKSample::BackgroundTask::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::BackgroundTaskSample
, RawNotificationsSampleCPP::sealed
  • RegisterClipboardContentChanged_Click() : Clipboard::sealed
  • RegisterElement() : UserInterface
  • RegisterForDeviceEvents() : SDKSample::PortableDeviceCPP::sealed
  • RegisterForPrinting() : PrintSample::BasePrintPage
  • RegisterForPrintingButtonClick()
: PrintSample::BasePrintPage
, PrintSample::sealed
  • RegisterForSwitchStateChangedEvent() : SDKSample::CustomDeviceAccess::sealed
  • RegisterServicingCompleteBackgroundTask() : SDKSample::BackgroundTask::BackgroundTaskSample
  • RegisterTaskButton_Click() : SDKSample::SDKTemplate::sealed
  • Release() : ContentImageSource , FontFileStream , FontLoader , ImageFile , DirectX::ScratchImage , DirectX::Blob , InlineImage
  • ReleaseAudioResources() : StreamEffect , AudioController
  • ReleaseBufferResources() : ExtrudedTextRenderer
  • ReleaseFileFragment() : FontFileStream
  • ReleaseParent() : Element
  • ReleaseResources() : Audio
  • RemoteSession() : SDKSample::IsRemoteSession::sealed
  • RemoteVideo_MediaFailed() : SimpleCommunication::VideoChat
  • Remove() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , List< T > , SDKSample::Playlists::sealed , SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > , List< T > , SDKSample::DataBinding::sealed
  • Remove_Click() : ScheduledNotificationsSampleCPP::sealed
  • RemoveBack() : List< T >
  • RemoveButtonClicked() : Postcard::sealed
  • RemoveCallback_Click() : SDKSample::SDKTemplate::sealed
  • RemoveFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • RemoveFromSelection() : SDKSample::TouchKeyboard::sealed
  • RemoveFront() : List< T >
  • RemoveItem() : List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE > , List< T > , ComPtrList< T, NULLABLE >
  • RemoveLocalFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • RemoveLockScreenAccess_Click() : LockScreenAppsCPP::sealed
  • RemoveObserver()
: Hilo::FileSystemRepository
, Hilo::ObservableQuery
  • RemovePageFromPrintPreviewCollection() : PrintSample::BasePrintPage
  • RemovePageRangeEdit() : PrintSample::sealed
  • RemovePaper() : PaperRenderer , PostcardRenderer
  • RemoveRepulsor() : SimpleSprites
  • RemoveSaveButton_Click() : AppBarControl::sealed
  • RemoveTexture() : BasicSprites::SpriteBatch
  • RemoveTouch() : MarbleMaze
  • RemoveURLFileButton_Click() : SDKSample::FilePickerContracts::sealed
  • RenameButton_Click() : SDKSample::FilePickerContracts::sealed
  • Render() : abstract , SampleOverlay , abstract , ResourceLoading , SampleOverlay , abstract , SampleOverlay , SimpleSprites , abstract , SampleOverlay , StereoSimpleD3D , Direct3DTutorial , abstract , SampleOverlay , abstract , SampleOverlay , TextInterop , abstract , DWriteCustomTextRenderer , SampleOverlay , abstract , DWriteHelloWorld , SampleOverlay , abstract , DWriteHitTesting , SampleOverlay , abstract , DWriteInlineObject , SampleOverlay , abstract , DWriteParagraphText , SampleOverlay , abstract , DWriteVerticalText , SampleOverlay , abstract , GameHud , GameObject , GameRenderer , abstract , Audio , abstract , LoadScreen , MarbleMaze , SampleOverlay , SDKMesh , ElementBase , TextElement , CountdownTimer , StopwatchTimer , TextButton , HighScoreTable , UserInterface , abstract , PostcardRenderer , CoreWindowEvents , abstract , SampleOverlay , abstract , SampleOverlay , Simple3DTouch , abstract , OfferReclaimAPI , SampleOverlay , abstract , DxgiRotation , SampleOverlay , abstract , sealed , abstract , SampleOverlay , sealed , abstract , sealed , D2DLightingEffectsRenderer , abstract , GameHud , GameObject , GameRenderer , abstract , BasicSound , abstract , SampleOverlay , abstract , SampleOverlay , StreamEffect , AudioController , abstract , SampleOverlay , abstract , SampleOverlay , SimpleController , D2D3DTransformsRenderer , abstract , D2DTextAnimation , abstract , SampleOverlay , D2DBasicAnimation , abstract , SampleOverlay , D2DEffectsHelloWorld , abstract , SampleOverlay , CommandListRenderer , abstract , SampleOverlay , CompositeModes , abstract , SampleOverlay , ConvolveMatrixEffect , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , D2DEffectsOnPrimitives , abstract , SampleOverlay , abstract , FPSCounter , GeometryRealizationSample , SampleOverlay , D2DInterpolationModes , abstract , SampleOverlay , D2DPerspectiveTransform , abstract , SampleOverlay , PageRenderer , abstract , SampleOverlay , abstract , SampleOverlay , SaveAsImageFile , PageRenderer , abstract , SampleOverlay , BumpMapping , abstract , SampleOverlay , abstract , DirectXFractal , SampleOverlay , D3DPostProcessing
  • Render3DPerspectiveTransformEffect() : D2D3DTransformsRenderer
  • Render3DTransformEffect() : D2D3DTransformsRenderer
  • RenderAdjacent() : SDKMesh
  • RenderAudio() : StreamEffect
  • RenderBuffer() : RenderBuffer
  • RenderControllerInput() : SimpleController
  • RenderEye() : StereoSimpleD3D
  • RenderFrame() : SDKMesh
  • RenderGlow() : D3DPostProcessing
  • RenderMainContent() : GeometryRealizationSample
  • RenderMesh() : SDKMesh
  • RenderObjects() : Simple3DGame , Program , Simple3DGame
  • RenderSetup() : Material
  • RenderToTarget() : GeometryRealization
  • RenewChannelsButton_Click() : SDKSample::SDKTemplate::sealed
  • Repeater() : Samples::Devices::Repeater
  • ReplaceAll() : SDKSample::Helpers
  • ReplaceUrlSearchTerms() : SDKSample::MainPage
  • ReportCompleted_Click() : ShareTarget::sealed
  • ReportDataRetrieved_Click() : ShareTarget::sealed
  • ReportErrorButton_Click() : ShareTarget::sealed
  • ReportStarted_Click() : ShareTarget::sealed
  • ReportSubmittedBackgroundTask_Click() : ShareTarget::sealed
  • RequestData() : CMPEG1Source
  • RequestLockScreenAccess_Click() : LockScreenAppsCPP::sealed
  • RequestRedraw() : IRenderer
  • RequestResponse() : SDKSample::UssdApi::sealed
  • RequestSample() : CMPEG1Stream
  • Reserve() : Buffer
  • Reset() : BasicTimer , ScopedObject< T > , BasicTimer , GameTimer , BasicTimer , StopwatchTimer , HighScoreTable , ExtrudedTextRenderer , ImageRenderer , InkRenderer , PaperRenderer , BasicTimer , LanguageFontCPP::sealed , CStreamState , SimpleCommunication::sealed , GameTimer , BasicTimer
  • Reset_Click()
: SDKSample::PasswordVaultCPP::sealed
, SDKSample::CameraCapture::sealed
, SDKSample::PasswordVaultCPP::sealed
  • Reset_Click1() : SDKSample::EAS::sealed
  • Reset_Click2() : SDKSample::EAS::sealed
  • Reset_Click3() : SDKSample::EAS::sealed
  • ResetCheckpoints() : MarbleMaze
  • ResetClicked() : Postcard::sealed
  • ResetDirectXResources() : SampleOverlay , LoadScreen , SampleOverlay
  • ResetGame() : Simple3DGameXaml::sealed
  • ResetLicense() : Simple3DGameXaml::sealed
  • ResetOutput()
: SDKSample::MainPage
, SDKSample::Scaling::sealed
  • ResetPostcard() : PostcardRenderer
  • ResetScenarioOutput()
: SDKSample::MainPage
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
  • ResetSignature() : PostcardRenderer
  • ResetState() : MoveLookController , Shape , MoveLookController
  • ResetValues()
: D2D3DTransforms::sealed
, D2DLightingEffects::sealed
  • ResizeVideo() : MEPlayer
  • Resolve() : Contact
  • ResolvedGeographicRegion() : Hilo::CalendarExtensions
  • ResolvedLanguage() : Hilo::CalendarExtensions
  • ResolveSampleContact() : ContactPicker::sealed
  • Restart() : MediaStreamer
  • RestartTask() : Samples::Devices::Repeater
  • Restore() : SDKSample::sealed
  • RestoreAsync()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
, SuspensionManager
, SDKSample::Common::sealed
, SuspensionManager
, SDKSample::Common::sealed
  • RestoreFrameNavigationState()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
  • Resume() : XAudio2SoundPlayer
  • ResumeAll_Click() : SDKSample::BackgroundTransfer::sealed
  • ResumeAudio() : Audio
  • ResumeDeviceWatcher()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • Resuming() : SDKSample::MediaCapture::sealed
  • RetrieveLocationsAsync() : TripOptimizerComponent::Details::TripOptimizerImpl
  • RetrieveRoutesAsync() : TripOptimizerComponent::Details::TripOptimizerImpl
  • Revert() : ImageFile
  • Rewind() : SDKSample::MediaButtons::sealed
  • RGBToYUV() : Utils
  • RichTextColumns() : Hilo::Common::sealed
  • RightClickOverride() : EdgeGestureSample::sealed
  • RightEyeProjection() : Camera
  • RippleEffect() : RippleEffect
  • rootPage_InputFrameLoaded()
: LanguageFontCPP::sealed
, ToastsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, CredentialPickerCPP::sealed
, ToastsSampleCPP::sealed
, EdgeGestureSample::sealed
  • rootPage_MainPageResized() : SDKSample::Transforms::sealed
  • rootPage_OutputFrameLoaded()
: MediaExtensionsCPP::sealed
, EdgeGestureSample::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
, MediaExtensionsCS::ScenarioInput3
, EdgeGestureSample::sealed
, MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
, ToastsSampleCPP::sealed
, MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCPP::sealed
, CredentialPickerCPP::sealed
  • Rotate90() : Hilo::sealed
  • RotateClockwise() : Hilo::ExifExtensions
  • RotateImage() : Hilo::sealed
  • RotateImageView() : Hilo::sealed
  • RotateImageViewModel::RotateImageAsync() : Hilo::sealed
  • RotateImageViewModel::SetEncodingRotation() : Hilo::sealed
  • RoughMSE()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • Round() : RippleEffect
  • RoundUpTo16() : DirectXFractal
  • Run() : sealed , DWriteCustomTextRenderer , DirectXApp , Background::sealed , BackgroundTask::sealed , Background::sealed , DirectXApp , D2DEffectsOnPrimitives , Background::sealed , Direct3DTutorialFrameworkView , DirectXApp , DWriteInlineObject , DirectXApp , DWriteHitTesting , DWriteParagraphText , DirectXApp , NetworkStatusTask::sealed , GeometryRealizationSample , ConvolveMatrixEffect , DirectXApp , sealed , DirectXApp , Background::sealed , CompositeModes , DirectXApp , D2DBasicAnimation , Direct3DTutorialFrameworkView , Background::sealed , VideoView , Direct3DTutorialFrameworkView , DirectXApp , Tasks::sealed , CoreWindowEvents , DirectXApp , DWriteHelloWorld , DirectXApp , sealed , Direct3DTutorialFrameworkView , DirectXApp , CommandListRenderer , D2DTextAnimation , SaveAsImageFile , DirectXApp , D2DInterpolationModes , sealed , D2DPerspectiveTransform , DWriteVerticalText , D2DEffectsHelloWorld , TextAnalysis::Run , Tasks::sealed , BackgroundTasks::sealed , Background::sealed , DirectXApp
  • Run_Click() : SDKSample::PortableDeviceCPP::sealed
  • RunGame() : Simple3DGame
  • RunSample_Click() : SDKSample::CryptoWinRT::sealed
  • RuntimeClassInitialize() : CPolarEffect , CDocumentSource , CPolarEffect , CInvert , CGrayscale , CDocumentSource , CInvert
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- s -

  • S1_DeviceProperties() : SDKSample::PortableDeviceCPP::sealed
  • S1_ListStorages() : SDKSample::RemovableStorageCPP::sealed
  • S2_Enumeration() : SDKSample::PortableDeviceCPP::sealed
  • S2_SendToStorage() : SDKSample::RemovableStorageCPP::sealed
  • S2Formatter() : SDKSample::DataBinding::sealed
  • S3_GetFromStorage() : SDKSample::RemovableStorageCPP::sealed
  • S3_SendToDevice() : SDKSample::PortableDeviceCPP::sealed
  • S4_Autoplay() : SDKSample::RemovableStorageCPP::sealed
  • S4_GetFromDevice() : SDKSample::PortableDeviceCPP::sealed
  • S5_Events() : SDKSample::PortableDeviceCPP::sealed
  • S6_DeviceStatus() : SDKSample::PortableDeviceCPP::sealed
  • SafeAdd() : RippleEffect
  • SampleBackgroundTask()
: SDKSample::BackgroundTask::sealed
, Tasks::sealed
  • SampleDataItem() : SDKSample::FlipViewData::sealed
  • SampleDataSource() : SDKSample::FlipViewData::sealed
  • Save() : SDKSample::sealed
  • SaveAsync()
: SDKSample::Common::sealed
, SuspensionManager
, SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
, SuspensionManager
, SDKSample::Common::sealed
  • SaveBitmapToFile() : SaveAsImageFile
  • SaveBitmapToStream() : SaveAsImageFile , PostcardRenderer
  • SaveBool() : PersistentState
  • SaveClicked() : Postcard::sealed
  • SaveFileButton_Click()
: SDKSample::FilePicker::sealed
, SDKSample::FilePickerContracts::sealed
  • SaveFrameNavigationState()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
  • SaveHighScore() : Simple3DGame
  • SaveImage() : Hilo::sealed
  • SaveImageAsync() : Hilo::ImageBase
  • SaveInt32() : PersistentState
  • SaveInternalState() : BumpMapping , LonLatController , DirectXFractal , LonLatController , ResourceLoading , MoveLookController , Simple3DTouch
  • SaveInternalValue() : DirectXFractal , MoveLookController
  • SavePostcard() : PostcardRenderer
  • SaveSingle() : PersistentState
  • SaveState()
: SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Magazine::sealed
, abstract
, Level2
, Level4
, Simple3DGame
, MarbleMaze
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SimpleBlogReader::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, Hilo::sealed
, Hilo::Common::LayoutAwarePage
, Hilo::HiloPage
, Hilo::sealed
, Hilo::ViewModelBase
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, abstract
, Level2
, Level4
, Simple3DGame
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
, SDKSample::sealed
, SDKSample::Common::LayoutAwarePage
  • SaveString() : PersistentState
  • SaveXMFLOAT3() : PersistentState
  • ScaleImageDimensions() : Hilo::sealed
  • Scenario1()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::AnimationMetrics::sealed
, SDKSample::PackageSample::sealed
, SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::BackgroundTransfer::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::Compression::sealed
, SDKSample::WebSocket::sealed
, SDKSample::ContextMenu::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::DisplayOrientation::sealed
, SDKSample::EAS::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::FolderEnumeration::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::PlayTo::sealed
, SDKSample::MediaServerClient::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::PlayToreceiver::sealed
, SDKSample::FileSearch::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::Scaling::sealed
, SDKSample::SearchContract::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::SnapSample::sealed
, SDKSample::SplashScreen::sealed
, StreamSocketSample::sealed
, SDKSample::Syndication::sealed
, SDKSample::WebAuthentication::sealed
, SDKSample::WASAPIAudio::sealed
, SDKSample::Accessibility::sealed
, SDKSample::Animation::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::HighContrast::sealed
, SDKSample::Images::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::Transforms::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario10()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
  • Scenario10_SearchMultipleResourceIds() : SDKSample::ApplicationResources::sealed
  • Scenario10_ShowCandidates() : SDKSample::ApplicationResources::sealed
  • Scenario10Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario11() : SDKSample::ApplicationResources::sealed
  • Scenario11Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario1::GetElementRect() : SDKSample::ContextMenu::sealed
  • Scenario1DisplayToast() : ToastsSampleCPP::sealed
  • Scenario1DisplayToastWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario1Open_Click() : RawNotificationsSampleCPP::sealed
  • Scenario1Reset()
: SDKSample::DataBinding::sealed
, SDKSample::ScrollViewerCPP::sealed
  • Scenario1Unregister_Click() : RawNotificationsSampleCPP::sealed
  • Scenario2()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::PackageSample::sealed
, SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::BackgroundTransfer::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::Compression::sealed
, SDKSample::WebSocket::sealed
, SDKSample::ContextMenu::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::DisplayOrientation::sealed
, SDKSample::EAS::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::FolderEnumeration::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::PlayTo::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::Scaling::sealed
, SDKSample::SearchContract::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::SplashScreen::sealed
, StreamSocketSample::sealed
, SDKSample::WebAuthentication::sealed
, SDKSample::WASAPIAudio::sealed
, SDKSample::Accessibility::sealed
, SDKSample::Animation::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::HighContrast::sealed
, SDKSample::Images::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::Transforms::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario2::GetTextboxSelectionRect() : SDKSample::ContextMenu::sealed
  • Scenario2AddListener_Click() : RawNotificationsSampleCPP::sealed
  • Scenario2Button1_Click() : SDKSample::Images::sealed
  • Scenario2Button_Click() : SDKSample::DisplayOrientation::sealed
  • Scenario2Closed() : SDKSample::WebSocket::sealed
  • Scenario2DisplayToast() : ToastsSampleCPP::sealed
  • Scenario2DisplayToastWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario2ReadData() : SDKSample::HttpClientSample::sealed
  • Scenario2ReceiveData() : SDKSample::WebSocket::sealed
  • Scenario2RemoveListener_Click() : RawNotificationsSampleCPP::sealed
  • Scenario2Reset()
: ProximityCPP::sealed
, SDKSample::DataBinding::sealed
, SDKSample::ScrollViewerCPP::sealed
  • Scenario2SendData() : SDKSample::WebSocket::sealed
  • Scenario2ToggleStoryboard_Click() : SDKSample::Animation::sealed
  • Scenario3()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::PackageSample::sealed
, SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::Compression::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::DisplayOrientation::sealed
, SDKSample::EAS::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::FolderEnumeration::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::SearchContract::sealed
, StreamSocketSample::sealed
, SDKSample::WASAPIAudio::sealed
, SDKSample::Accessibility::sealed
, SDKSample::Animation::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::HighContrast::sealed
, SDKSample::Images::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::PersonalityAnimations::sealed
, SDKSample::XAMLPopup::sealed
, SDKSample::ScrollViewerCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario3_ClickHandler1() : SDKSample::PersonalityAnimations::sealed
  • Scenario3_ClickHandler2() : SDKSample::PersonalityAnimations::sealed
  • Scenario3DisplayToast() : ToastsSampleCPP::sealed
  • Scenario3DisplayToastWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario3EasingFunctionChanged() : SDKSample::Animation::sealed
  • Scenario3Reset() : SDKSample::DataBinding::sealed
  • Scenario3StringLoad_Click() : SDKSample::ApplicationResources::sealed
  • Scenario4()
: SDKSample::ApplicationResources::sealed
, SDKSample::AtomPub::sealed
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::CryptoWinRT::sealed
, DatagramSocketSample::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::SearchContract::sealed
, StreamSocketSample::sealed
, SDKSample::Accessibility::sealed
, AppBarControl::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::TextEditing::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Drawing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario4DisplayToastWithSound() : ToastsSampleCPP::sealed
  • Scenario4DisplayToastWithSoundWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario4Reset() : SDKSample::DataBinding::sealed
  • Scenario5()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FilePicker::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::SearchContract::sealed
, SDKSample::DataBinding::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::TextEditing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario5Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario5DisplayToastWithCallbacks_Click() : ToastsSampleCPP::sealed
  • Scenario5HideToast_Click() : ToastsSampleCPP::sealed
  • Scenario5Reset() : SDKSample::DataBinding::sealed
  • Scenario6()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::FileAccess::sealed
, SDKSample::FilePicker::sealed
, SDKSample::SearchContract::sealed
, SDKSample::DataBinding::sealed
, SDKSample::TextEditing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario6Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario6DisplayLongToast() : ToastsSampleCPP::sealed
  • Scenario6DisplayLongToastWithStringManipulation() : ToastsSampleCPP::sealed
  • Scenario6Reset() : SDKSample::DataBinding::sealed
  • Scenario7()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::FileAccess::sealed
, SDKSample::SearchContract::sealed
, SDKSample::DataBinding::sealed
, SDKSample::TextEditing::sealed
, SDKSample::WebViewControl::sealed
  • Scenario7Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario7Reset() : SDKSample::DataBinding::sealed
  • Scenario8()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
, SDKSample::FileAccess::sealed
, SDKSample::DataBinding::sealed
, SDKSample::WebViewControl::sealed
  • Scenario8Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario8Reset() : SDKSample::DataBinding::sealed
  • Scenario9()
: SDKSample::ApplicationResources::sealed
, SDKSample::CryptoWinRT::sealed
  • Scenario9Button_Show_Click() : SDKSample::ApplicationResources::sealed
  • Scenario_Enroll() : SDKSample::CertificateEnrollment::sealed
  • Scenario_Import() : SDKSample::CertificateEnrollment::sealed
  • ScenarioButtonDelete_Click() : SDKSample::PasswordVaultCPP::sealed
  • ScenarioCompleted() : SDKSample::Helpers
  • ScenarioDisable()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
  • ScenarioEnable()
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
  • ScenarioGet() : SDKSample::SimpleOrientationSensorCPP::sealed
  • ScenarioInit()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • ScenarioInput1()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput2()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput3()
: CredentialPickerCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput4()
: MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput5()
: PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput6()
: PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioInput6::GeneratePage() : PrintSample::sealed
  • ScenarioList()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioList
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioMultiple() : ContactPicker::sealed
  • ScenarioOutput1()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioOutput1
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput2()
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioOutput2
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput3()
: CredentialPickerCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCS::ScenarioOutput3
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput4()
: MediaExtensionsCS::ScenarioOutput4
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput5()
: PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioOutput6()
: PrintSample::sealed
, ToastsSampleCPP::sealed
  • ScenarioReset()
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • Scenarios_SelectionChanged()
: SDKSample::sealed
, AccountPictureName::sealed
, SDKSample::sealed
, AssociationLaunching::sealed
, SDKSample::sealed
, Clipboard::sealed
, SDKSample::sealed
, ContactPicker::sealed
, SDKSample::sealed
, CredentialPickerCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, DatagramSocketSample::sealed
, SDKSample::sealed
, EdgeGestureSample::sealed
, SDKSample::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, LanguageFontCPP::sealed
, SDKSample::sealed
, LockScreenAppsCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, MediaExtensionsCS::ScenarioList
, MediaExtensionsCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SDKSample::sealed
, PrintSample::sealed
, SDKSample::sealed
, ProximityCPP::sealed
, SDKSample::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::sealed
, SDKTemplate::MainPage
, SimpleCommunication::sealed
, SDKSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
, SDKSample::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, ToastsSampleCPP::sealed
, SDKSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
  • ScenarioSingle() : ContactPicker::sealed
  • ScenarioStarted() : SDKSample::Helpers
  • Schedule_Click() : ScheduledNotificationsSampleCPP::sealed
  • ScheduleTile() : ScheduledNotificationsSampleCPP::sealed
  • ScheduleTileWithStringManipulation() : ScheduledNotificationsSampleCPP::sealed
  • ScheduleToast() : ScheduledNotificationsSampleCPP::sealed
  • ScheduleToastWithStringManipulation() : ScheduledNotificationsSampleCPP::sealed
  • ScopedObject() : ScopedObject< T >
  • ScopedViews() : SDKSample::TouchKeyboardTextInput::sealed
  • ScratchImage() : DirectX::ScratchImage
  • Script_Click() : SDKSample::WebViewControl::sealed
  • ScriptDetection() : SDKSample::ELS::sealed
  • ScrollIntoView() : SDKSample::TouchKeyboard::sealed
  • SDKMesh() : SDKMesh
  • SearchButton_Click() : SDKSample::FileSearch::sealed
  • SearchHomeGroup() : SDKSample::HomeGroup::sealed
  • SecondaryTileNotification() : SecondaryTiles::sealed
  • Seek() : ImageFile
  • SeekAbsolute() : RandomAccessReader
  • SeekAsync() : MediaStreamSource::PcmSource
  • SeekRelative() : RandomAccessReader
  • SeekToEnd() : RandomAccessReader
  • SeekToStart() : RandomAccessReader
  • Select() : SDKSample::TouchKeyboard::sealed
  • SelectFile()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • SelectFiles_Click() : SDKSample::MediaButtons::sealed
  • SelectFilesAsync() : Hilo::RandomPhotoSelector
  • SelectFilesButton_Click() : SDKSample::ShareSource::sealed
  • SelectImageButton_Click() : SDKSample::ShareSource::sealed
  • SelectPreferredCameraStreamSettingAsync()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • SelectResource_Click() : SDKSample::PasswordVaultCPP::sealed
  • SelectStreams() : CMPEG1Source
  • SelectTemplateCore() : SDKSample::FlipViewCPP::sealed
  • SelectUser_Click() : SDKSample::PasswordVaultCPP::sealed
  • SendAsync() : Web::HttpRequest
  • SendBadge() : SDKSample::Tiles::sealed
  • SendBadge_Click() : LockScreenAppsCPP::sealed
  • SendBadgeNotification_Click() : SecondaryTiles::sealed
  • SendBadgeNotificationWithStringManipulation_Click() : SecondaryTiles::sealed
  • SendBadgeWithStringManipulation_Click() : LockScreenAppsCPP::sealed
  • SendButton_Click() : SDKSample::UssdApi::sealed
  • SendContentToDeviceAsync() : SDKSample::PortableDeviceCPP::sealed
  • SendHello_Click()
: DatagramSocketSample::sealed
, StreamSocketSample::sealed
  • SendImage_Click() : SDKSample::RemovableStorageCPP::sealed
  • SendImageFileToStorageAsync() : SDKSample::RemovableStorageCPP::sealed
  • SendLocalImageTile() : SDKSample::Tiles::sealed
  • SendMessage() : SDKSample::WebSocket::sealed
  • SendTextTile() : SDKSample::Tiles::sealed
  • SendTile_Click() : LockScreenAppsCPP::sealed
  • SendTileNotification_Click()
: SDKSample::Tiles::sealed
, SecondaryTiles::sealed
  • SendTileNotificationImage_Click() : SDKSample::Tiles::sealed
  • SendTileNotificationText_Click() : SDKSample::Tiles::sealed
  • SendTileNotificationWithQueryStrings_Click() : SDKSample::Tiles::sealed
  • SendTileNotificationWithStringManipulation_Click() : SecondaryTiles::sealed
  • SendTileWithStringManipulation_Click() : LockScreenAppsCPP::sealed
  • SendWebImageTile() : SDKSample::Tiles::sealed
  • Serialize() : sealed , ManipulatableObject
  • SerializeBinding()
: NotificationsExtensions::TileContent::TileSquareBase
, NotificationsExtensions::TileContent::ISquareTileInternal
, NotificationsExtensions::TileContent::TileSquareBase
, NotificationsExtensions::TileContent::ISquareTileInternal
  • SerializeProperties() : NotificationsExtensions::NotificationBase
  • SerializeToString() : Hilo::ImageNavigationData
  • ServicingComplete() : Tasks::sealed
  • ServicingCompleteTask() : SDKSample::BackgroundTask::sealed
  • SessionState() : CppSamplesUtils::SuspensionManager
  • SessionStateForFrame()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
  • set()
: SDKSample::sealed
, SDKSample::TouchKeyboard::sealed
, SDKSample::sealed
  • Set()
: DirectX::INTColor
, LanguageFontCPP::sealed
  • set() : SDKSample::sealed
  • set_IsTile() : ScheduledNotificationsSampleCPP::sealed
  • SetAccountPicture() : AccountPictureName::sealed
  • SetAccountPictureName() : AccountPictureName::sealed
  • SetAction() : DirectXApp , GameInfoOverlay , Simple3DGameXaml::sealed
  • SetAlignment() : ElementBase
  • SetAmplitude() : RippleEffect
  • SetApp() : Simple3DGameXaml::sealed
  • SetAudioCategory()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • SetAudioDeviceType()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • SetAudioSource() : SDKSample::CallControl::sealed
  • SetBackground() : Simple3DGameXaml::sealed , GameRenderer , Simple3DGame
  • SetBalance() : MEPlayer
  • SetBidiLevel() : TextAnalysis
  • SetBit() : DirectX::CBits< SizeInBytes >
  • SetBits() : DirectX::CBits< SizeInBytes >
  • SetButtons() : SDKSample::HomeGroup::sealed
  • SetBytestream() : MEPlayer
  • SetCancelButton() : SDKSample::Transcode::sealed
  • SetCancellationToken() : FrameProcessing
  • SetCenter() : RippleEffect
  • SetCollision() : Physics
  • SetConnected() : DatagramSocketSample::sealed
  • SetContactPicker() : ContactPicker::sealed
  • SetContainer() : ElementBase
  • SetCurrentFrame() : FrameProcessing
  • SetCurrentLevelToSavedState() : Simple3DGame
  • SetCurrentPlayingAsync() : SDKSample::MediaButtons::sealed
  • SetCurrentRun() : TextAnalysis
  • SetCurrentScenario() : SimpleCommunication::sealed
  • SetD2DContext() : Program
  • SetData() : SourceOp
  • SetDebugName() : BasicLoader
  • SetDevice() : sealed
  • SetDeviceAppForWebcam() : DeviceAppForWebcam::sealed
  • SetDpi() : abstract , GameRenderer , abstract , Renderer , abstract
  • SetDrawInfo() : RippleEffect , WaveEffect
  • SetDuration() : Animation< T >
  • SetEffectIntensity() : PostcardRenderer , ImageRenderer
  • SetElapsedTime() : StopwatchTimer
  • SetEnd() : Animation< T >
  • SetEngineExperiencedCriticalError() : Audio
  • SetError() : CredentialPickerCPP::sealed
  • SetErrorMessage() : SDKSample::ShareSource::sealed
  • SetExtrudedText() : ExtrudedTextRenderer , PostcardRenderer
  • SetFeatureName()
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, SDKTemplate::MainPage
, DatagramSocketSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, SDKTemplate::MainPage
, SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
, SDKTemplate::MainPage
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, SDKTemplate::MainPage
, SimpleCommunication::sealed
, StreamSocketSample::sealed
, ToastsSampleCPP::sealed
, SDKTemplate::MainPage
, AppBarControl::sealed
, ProximityCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, EdgeGestureSample::sealed
, Clipboard::sealed
  • SetFireRect() : MoveLookController
  • SetFocus() : CAppWindowProvider
  • SetFont() : LanguageFontCPP::sealed
  • SetFontName() : TextStyle
  • SetFontSize() : TextStyle
  • SetFontStyle() : TextStyle
  • SetFontWeight() : TextStyle
  • SetFrequency() : RippleEffect
  • SetFromRGB() : AmpPixel
  • SetGameInfoOverlay() : DirectXApp , Simple3DGameXaml::sealed
  • SetGameLoading() : GameInfoOverlay , Simple3DGameXaml::sealed
  • SetGameOver() : GameInfoOverlay , Simple3DGameXaml::sealed
  • SetGameState() : MarbleMaze
  • SetGameStats() : GameInfoOverlay , Simple3DGameXaml::sealed
  • SetGlyphOrientation() : TextAnalysis
  • SetGraph() : RippleEffect , WaveEffect
  • SetGravity() : Physics
  • SetImageButton_Click() : AccountPictureName::sealed
  • SetImageFilePaths() : Hilo::WideFiveImageTile
  • SetIndex()
: DirectX::BC4_UNORM
, DirectX::BC4_SNORM
  • SetInitialPosition() : ManipulatableObject
  • SetInputType() : CGrayscale , CInvert , CDecoder , CGrayscale , CInvert , CDecoder , CPolarEffect
  • SetLandscape_Click() : SDKSample::Rotation::sealed
  • SetLandscapeFlipped_Click() : SDKSample::Rotation::sealed
  • SetLevelStart() : GameInfoOverlay , Simple3DGameXaml::sealed
  • SetLicenseInfo() : GameHud
  • SetLightingEffect() : D2DLightingEffectsRenderer , D2DLightingEffects::sealed
  • SetLightingProperty() : D2DLightingEffects::sealed , D2DLightingEffectsRenderer
  • SetLineBreakpoints() : TextAnalysis
  • SetLoading() : SDKMesh
  • SetLocalContentSuggestions() : SDKSample::SearchContract::sealed
  • SetLockscreenImage() : SDKSample::Personalization::sealed
  • SetManipulationTransform() : ManipulatableObject
  • SetManualLoadImage() : SDKSample::Scaling::sealed
  • SetMediaElementSourceAsync() : SDKSample::MediaButtons::sealed
  • SetMoveRect() : MoveLookController
  • SetNeighbourArea() : FrameProcessing
  • SetNumberSubstitution() : TextAnalysis
  • SetOrientation() : LonLatController , MoveLookController
  • SetOutputBounds() : CInvert , CDecoder , CPolarEffect , CInvert , CDecoder , CPolarEffect , CGrayscale
  • SetOutputType() : CGrayscale , CInvert , CDecoder , CPolarEffect , CInvert , CDecoder , CPolarEffect , CGrayscale
  • SetOverrideRectSize() : SDKSample::Scaling::sealed
  • SetOverrideTextFont() : SDKSample::Scaling::sealed
  • SetPadding() : TextButton
  • SetPasswordExplainVisibility() : CredentialPickerCPP::sealed
  • SetPause() : Simple3DGameXaml::sealed , GameInfoOverlay
  • SetPhase() : RippleEffect
  • SetPickFileButton() : SDKSample::Transcode::sealed
  • SetPixel() : FrameProcessing
  • SetPlane() : Face
  • SetPlaybackPosition() : MEPlayer
  • SetPortrait_Click() : SDKSample::Rotation::sealed
  • SetPortraitFlipped_Click() : SDKSample::Rotation::sealed
  • SetPosition() : LonLatController , Physics , PaperFragment , MoveLookController , LonLatController
  • SetPressed() : TextButton
  • SetPrintTask() : DirectXApp
  • SetProductItems() : Simple3DGameXaml::sealed
  • SetProjectionParameters() : BasicCamera , Camera
  • SetProjParams() : Camera
  • SetProperties() : CPolarEffect , CDecoder , CGrayscale , CInvert , CGrayscale , SDKSample::WASAPIAudio::WASAPIRenderer , CInvert , CPolarEffect
  • SetRadius() : Physics
  • SetRate() : CMPEG1Source , CMPEG1Stream
  • SetRateOp() : SetRateOp
  • SetResult() : CredentialPickerCPP::sealed
  • SetRoomSize() : Audio
  • SetSampleMode() : PostcardRenderer
  • SetScriptAnalysis() : TextAnalysis
  • SetSecondaryTiles() : SecondaryTiles::sealed
  • SetSelected() : TextButton
  • SetSize() : Buffer , ImageFile
  • SetSkewX() : WaveEffect
  • SetSkewY() : WaveEffect
  • SetSnapped() : Simple3DGameXaml::sealed , DirectXApp
  • SetSnappedMode() : PageRenderer
  • SetSoundEffectFilter() : Audio
  • SetSoundEffectPitch() : Audio
  • SetSoundEffectVolume() : Audio
  • SetSpread() : RippleEffect
  • SetStart() : Animation< T >
  • SetStatus() : Simple3DGameXaml::sealed
  • SetStereoExaggeration() : StereoSimpleD3D
  • SetText() : TextElement
  • SetTextAlignment() : TextStyle
  • SetTextColor() : TextElement
  • SetTextOpacity() : TextElement
  • SetTexture() : Material
  • SettingContainer() : SDKSample::ApplicationDataSample::sealed
  • Settings() : SDKSample::ApplicationDataSample::sealed
  • SetTransformEffect() : D2D3DTransformsRenderer , D2D3DTransforms::sealed
  • SetTransformProperty() : D2D3DTransformsRenderer , D2D3DTransforms::sealed
  • SetUnderlineOnRedraw() : DWriteHitTesting
  • SetUpBinding() : SDKSample::Transforms::sealed
  • SetupControls() : Program
  • SetupVideoDeviceControl()
: MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • SetupWindowing()
: DeviceAppForPrinters::App
, ProximityCPP::sealed
, Clipboard::App
, AccountPictureName::App
, ContactPicker::App
, SimpleCommunication::App
  • SetURL() : MEPlayer
  • SetValue() : sealed
  • SetVelocity() : Physics
  • SetVersion() : SDKSample::ApplicationDataSample::sealed
  • SetVersion0_Click() : SDKSample::ApplicationDataSample::sealed
  • SetVersion1_Click() : SDKSample::ApplicationDataSample::sealed
  • SetVersionHandler0() : SDKSample::ApplicationDataSample::sealed
  • SetVersionHandler1() : SDKSample::ApplicationDataSample::sealed
  • SetVideoButton_Click() : AccountPictureName::sealed
  • SetViewParameters() : Camera , BasicCamera
  • SetViewParams() : Camera
  • SetVisible() : ElementBase
  • SetVolume() : MEPlayer
  • SetVolumeOnSession() : SDKSample::WASAPIAudio::WASAPIRenderer
  • SetWaveOffset() : WaveEffect
  • SetWindow() : D2DEffectsHelloWorld , DirectXApp , sealed , DirectXApp , sealed , DirectXApp , CompositeModes , Direct3DTutorialFrameworkView , DirectXApp , DWriteHelloWorld , ConvolveMatrixEffect , DirectXApp , DWriteCustomTextRenderer , DirectXApp , D2DBasicAnimation , CommandListRenderer , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , SaveAsImageFile , DirectXApp , Direct3DTutorialFrameworkView , DirectXApp , DWriteHitTesting , DirectXApp , CoreWindowEvents , DirectXApp , sealed , DirectXApp , D2DTextAnimation , D2DEffectsOnPrimitives , DirectXApp , Direct3DTutorialFrameworkView , DirectXApp , DWriteInlineObject , DWriteParagraphText , Direct3DTutorialFrameworkView , DirectXApp , DWriteVerticalText
  • Shaken() : SDKSample::AccelerometerCPP::sealed
  • Shape() : Shape
  • ShapesPuzzle() : sealed
  • Share_Click() : SDKSample::WebViewControl::sealed
  • ShareClicked() : Postcard::sealed
  • ShareCustomData() : SDKSample::ShareSource::sealed
  • ShareDelayRenderedFiles() : SDKSample::ShareSource::sealed
  • ShareFiles() : SDKSample::ShareSource::sealed
  • ShareHtml() : SDKSample::ShareSource::sealed
  • ShareImage() : SDKSample::ShareSource::sealed
  • ShareLink() : SDKSample::ShareSource::sealed
  • ShareText() : SDKSample::ShareSource::sealed
  • ShareWebView_LoadCompleted() : SDKSample::ShareSource::sealed
  • ShowContent() : PrintSample::sealed
  • ShowDeviceSelectorAsync()
: SDKSample::PortableDeviceCPP::sealed
, SDKSample::RemovableStorageCPP::sealed
, SDKSample::PortableDeviceCPP::sealed
, SDKSample::RemovableStorageCPP::sealed
  • ShowExceptionMessage()
: MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
, SDKSample::MediaCapture::sealed
  • ShowFormatButton_Click() : Clipboard::sealed
  • ShowGameInfoOverlay() : GameInfoOverlay , Simple3DGameXaml::sealed , DirectXApp , Simple3DGameXaml::sealed
  • ShowListButton_Click() : SDKSample::FileAccess::sealed
  • ShowMe_Click()
: SDKSample::WebViewControl::sealed
, AppBarControl::sealed
  • ShowMenu() : GeometryRealizationSample , ConvolveMatrixEffect , DWriteParagraphText
  • ShowOptionsUI() : SDKSample::CameraOptions::sealed
  • ShowPopupAnimationClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupLightDismissClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupOffsetClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupSettingsClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupWithoutParentClicked() : SDKSample::XAMLPopup::sealed
  • ShowPopupWithParentClicked() : SDKSample::XAMLPopup::sealed
  • ShowPropertiesButton_Click() : SDKSample::FileAccess::sealed
  • ShowReceipt_Click() : SDKSample::StoreSample::sealed
  • ShowSettings_Click() : SDKSample::CameraOptions::sealed
  • ShowStatusMessage()
: SDKSample::WASAPIAudio::sealed
, MediaCapture::AudioCapture
, SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
, SDKSample::WASAPIAudio::sealed
  • ShowStoreFlyout() : Simple3DGameXaml::sealed
  • ShowUIButton_Click() : SDKSample::Common::SharePage
  • Shutdown() : SDKSample::WASAPIAudio::MFSampleGenerator , CMPEG1Source , MEPlayer , CMPEG1Source , CMPEG1Stream
  • SignatureFlyout() : Postcard::sealed
  • SignButtonCicked() : Postcard::sealed
  • SignClicked() : Postcard::sealed
  • SignExtend() : DirectX::INTColor
  • Signin_Click() : SDKSample::PasswordVaultCPP::sealed
  • SignInButton_Click() : SDKSample::MicrosoftAccount::sealed
  • SignOutButton_Click() : SDKSample::MicrosoftAccount::sealed
  • simpleInk() : sealed
  • SimplifyIndexOptimized() : FrameProcessing
  • SimulateRoaming_Click() : SDKSample::ApplicationDataSample::sealed
  • SimulateSaveClicked() : SDKSample::XAMLPopup::sealed
  • SingleFingerRotation() : ManipulatableObject
  • sldBrightness_ValueChanged()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
  • sldContrast_ValueChanged()
: SDKSample::MediaCapture::sealed
, MediaCapture::BasicCapture
  • sliderFrequency_ValueChanged() : SDKSample::WASAPIAudio::sealed
  • sliderVolume_ValueChanged() : SDKSample::WASAPIAudio::sealed
  • SmoothStep() : Utils
  • SnapCoordinate() : PointSnapper
  • SnapGeometry() : PointSnapper
  • SnapPoint() : PointSnapper
  • SocketContext() : DatagramSocketSample::sealed
  • SocketError() : ProximityCPP::sealed
  • Solution_Click() : SDKSample::WebViewControl::sealed
  • Song() : SDKSample::MediaButtons::sealed
  • SoundCallbackHander() : anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • SoundEffectEngine() : Audio
  • SoundFileReader() : SoundFileReader
  • SoundLevelChanged() : SDKSample::MediaCapture::sealed
  • SoundLevelToString()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • SourceOp() : SourceOp
  • Sphere() : Sphere
  • SplitCurrentRun() : TextAnalysis
  • SplitPage() : SimpleBlogReader::sealed
  • SplitString() : PrintSample::sealed
  • Square_Click()
: MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCPP::sealed
  • StampButtonClicked() : Postcard::sealed
  • StampPaper() : PostcardRenderer , PaperRenderer
  • StandardOffset() : BasicSprites::SpriteBatch
  • StandardOrigin() : BasicSprites::SpriteBatch
  • starButton_Click() : AppBarControl::sealed
  • Start() : Samples::Devices::Repeater , abstract , Audio , CMPEG1Stream , abstract , CMPEG1Source , GameTimer , CMPEG1Source , abstract , GameTimer , Samples::Devices::Repeater , StopwatchTimer , Samples::Devices::Repeater
  • Start_Click()
: SDKSample::WebSocket::sealed
, SDKSample::HttpClientSample::sealed
, SDKSample::WebSocket::sealed
, MediaStreamSource::AudioSource
, SDKSample::HttpClientSample::sealed
  • StartBadgePolling_Click() : SDKSample::SDKTemplate::sealed
  • StartCaptureAsync() : SDKSample::WASAPIAudio::WASAPICapture
  • StartCountdown() : CountdownTimer
  • StartDevice() : SDKSample::WASAPIAudio::sealed
  • StartDownload_Click() : SDKSample::BackgroundTransfer::sealed
  • StartEventLoop() : Samples::Devices::Fx2::sealed
  • StartFx2Watcher()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • StartLayoutUpdates()
: SDKSample::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • StartLevel() : Simple3DGame
  • StartListener_Click()
: StreamSocketSample::sealed
, DatagramSocketSample::sealed
  • StartMonthAndYearQueries() : Hilo::sealed
  • StartMonthQuery() : Hilo::sealed
  • StartMultipartUpload_Click() : SDKSample::BackgroundTransfer::sealed
  • StartOp() : StartOp
  • StartPlaybackAsync() : SDKSample::WASAPIAudio::WASAPIRenderer
  • startPlayToReceiver() : SDKSample::PlayToreceiver::sealed
  • StartPreview_Click() : SDKSample::CameraOptions::sealed
  • StartRecordingAsync()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • StartRecordingToCustomSink()
: SimpleCommunication::LowLatency
, SimpleCommunication::sealed
  • StartRecordingToCustomSinkAsync() : SimpleCommunication::sealed
  • StartRecordToCustomSink() : SimpleCommunication::VideoChat
  • StartRestoreTask() : CppSamplesUtils::SuspensionManager
  • StartSaveTask() : CppSamplesUtils::SuspensionManager
  • StartSignature() : PostcardRenderer , InkRenderer
  • StartSource() : SDKSample::WASAPIAudio::MFSampleGenerator
  • StartTask() : Samples::Devices::Repeater
  • StartTilePolling_Click() : SDKSample::SDKTemplate::sealed
  • StartTimer() : MEPlayer
  • StartTracking() : SDKSample::GeolocationCPP::sealed
  • StartUpload_Click() : SDKSample::BackgroundTransfer::sealed
  • StartYearQuery() : Hilo::sealed
  • Stat() : ImageFile
  • STDMETHOD_() : Extruder::ExtrudingSink , PointSnapper::PointSnappingSink , Extruder::ExtrudingSink , OutlineRenderer , Extruder::ExtrudingSink , anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander , StreamingVoiceContext , GeometryRealization , StreamingVoiceContext , GeometryRealizationFactory , StreamingVoiceContext , GeometryRealization , PointSnapper::PointSnappingSink , Extruder::ExtrudingSink , PointSnapper::PointSnappingSink , Extruder::ExtrudingSink , anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander , StreamingVoiceContext , anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander , PointSnapper::PointSnappingSink , GeometryRealizationFactory , StreamingVoiceContext , OutlineRenderer , Extruder::ExtrudingSink , anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander , PointSnapper::PointSnappingSink , StreamingVoiceContext , Extruder::ExtrudingSink
  • STDMETHODIMP_() : AsyncCallback< T > , CMPEG1Stream , SDKSample::WASAPIAudio::MFSampleGenerator , AsyncCallback< T > , CMPEG1Source , AsyncCallback< T > , CMPEG1Source , SourceOp , CMPEG1Source , SDKSample::WASAPIAudio::MFSampleGenerator , MediaEngineNotify , AsyncCallback< T > , CMPEG1Stream , AsyncCallback< T >
  • Stop() : SDKSample::PlaybackManager2::sealed , StopwatchTimer , Samples::Devices::Repeater , GameTimer , CMPEG1Source , Samples::Devices::Repeater , GameTimer , CMPEG1Stream , SDKSample::PlaybackManager::sealed , Samples::Devices::Repeater , CMPEG1Source , SDKSample::MediaButtons::sealed
  • Stop_Click()
: MediaExtensionsCPP::sealed
, MediaStreamSource::AudioSource
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCS::ScenarioInput4
, SDKSample::WebSocket::sealed
, MediaExtensionsCPP::sealed
  • StopAudio() : SDKSample::CallControl::sealed
  • StopBadgePolling_Click() : SDKSample::SDKTemplate::sealed
  • StopCapture() : SDKSample::WASAPIAudio::sealed
  • StopCaptureAsync() : SDKSample::WASAPIAudio::WASAPICapture
  • StopDevice() : SDKSample::WASAPIAudio::sealed
  • StopEventLoop() : Samples::Devices::Fx2::sealed
  • StopFilters() : FrameProcessing
  • StopFx2Watcher()
: CustomDeviceAccess::DeviceList
, SDKSample::CustomDeviceAccess::DeviceList
  • StopLayoutUpdates()
: SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • StopPlaybackAsync() : SDKSample::WASAPIAudio::WASAPIRenderer
  • StopPlayers() : SDKSample::Transcode::sealed
  • stopPlayToReceiver() : SDKSample::PlayToreceiver::sealed
  • StopRecordingAsync()
: SimpleCommunication::Common::CaptureDevice
, SimpleCommunication::sealed
  • StopSound() : XAudio2SoundPlayer
  • StopSoundEffect() : Audio
  • StopSource() : SDKSample::WASAPIAudio::MFSampleGenerator
  • StopTilePolling_Click() : SDKSample::SDKTemplate::sealed
  • StopTimer() : MEPlayer
  • StopTracking() : SDKSample::GeolocationCPP::sealed
  • StopwatchTimer() : StopwatchTimer
  • StoreData() : SDKSample::ListViewSampleDataSource::sealed
  • streaming_latencyModeToggled() : SimpleCommunication::sealed
  • streaming_previewButtonClicked() : SimpleCommunication::sealed
  • Streaming_PreviewButtonClicked() : SimpleCommunication::LowLatency
  • streaming_recordingStarted() : SimpleCommunication::sealed
  • StreamingError() : CMPEG1Source
  • StreamingVoiceContext() : StreamingVoiceContext
  • StreamList() : StreamList
  • StreamsNeedData() : CMPEG1Source
  • StreamTypeAlert()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • StreamTypeCommunications() : SDKSample::PlaybackManager2::sealed
  • StreamTypeMedia()
: SDKSample::PlaybackManager::sealed
, SDKSample::PlaybackManager2::sealed
  • StreamTypeOther()
: SDKSample::PlaybackManager2::sealed
, SDKSample::PlaybackManager::sealed
  • StringFromDouble() : SDKSample::Scaling::sealed
  • StringTemplate() : SDKSample::DateTimeFormatting::sealed
  • StrokeWidthSelection_ValueChanged() : SDKSample::Drawing::sealed
  • SubmitCertificateRequestAndGetResponse() : SDKSample::CertificateEnrollment::sealed
  • SubmitItem_Click() : SDKSample::AtomPub::sealed
  • Suspend() : XAudio2SoundPlayer
  • SuspendAudio() : Audio
  • SuspendDeviceWatcher()
: SDKSample::CustomDeviceAccess::DeviceList
, CustomDeviceAccess::DeviceList
  • Suspending() : SDKSample::MediaCapture::sealed
  • Swap() : PrintSample::sealed
  • SwapIndices() : DirectX::D3DX_BC6H
  • SwitchKernel() : ConvolveMatrixEffect
  • SwitchMediaStreamAsync() : MediaStreamSource::PcmSource
  • SwitchRecordButtonContent()
: SDKSample::MediaCapture::sealed
, MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • SwitchStateChangedEventArgs() : Samples::Devices::Fx2::sealed
  • SyndicationItemIterator() : SDKSample::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- t -

  • Target() : GameObject
  • TargetButton() : SDKSample::HighContrast::sealed
  • TargetId() : GameObject
  • Team() : SDKSample::DataBinding::sealed
  • TeamDataSource() : SDKSample::DataBinding::sealed
  • TeamGroup() : SDKSample::DataBinding::sealed
  • Teams() : SDKSample::DataBinding::sealed
  • TextAnalysis() : TextAnalysis
  • TextBoxKeyUp() : Postcard::sealed
  • TextButton() : TextButton
  • TextElement() : TextElement
  • TextFlyout() : Postcard::sealed
  • TextStyle() : TextStyle
  • TextSubmitted() : Postcard::sealed
  • TextureLock() : TextureLock
  • ThumbnailGenerator() : Hilo::ThumbnailGenerator
  • TileExists_Click() : SecondaryTiles::sealed
  • TileNotificationBase() : NotificationsExtensions::TileContent::TileNotificationBase
  • TilePinned() : SecondaryTiles::sealed
  • TileSquareBase() : NotificationsExtensions::TileContent::TileSquareBase
  • TileSquareBlock() : NotificationsExtensions::TileContent::TileSquareBlock
  • TileSquareImage() : NotificationsExtensions::TileContent::TileSquareImage
  • TileSquarePeekImageAndText01() : NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
  • TileSquarePeekImageAndText02() : NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
  • TileSquarePeekImageAndText03() : NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
  • TileSquarePeekImageAndText04() : NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
  • TileSquareText01() : NotificationsExtensions::TileContent::TileSquareText01
  • TileSquareText02() : NotificationsExtensions::TileContent::TileSquareText02
  • TileSquareText03() : NotificationsExtensions::TileContent::TileSquareText03
  • TileSquareText04() : NotificationsExtensions::TileContent::TileSquareText04
  • TileUpdateScheduler() : Hilo::TileUpdateScheduler
  • TileUpdateScheduler::ScheduleUpdateAsync() : Hilo::TileUpdateScheduler
  • TileUpdateScheduler::UpdateTile() : Hilo::TileUpdateScheduler
  • TileWideBase() : NotificationsExtensions::TileContent::TileWideBase
  • TileWideBlockAndText01() : NotificationsExtensions::TileContent::TileWideBlockAndText01
  • TileWideBlockAndText02() : NotificationsExtensions::TileContent::TileWideBlockAndText02
  • TileWideImage() : NotificationsExtensions::TileContent::TileWideImage
  • TileWideImageAndText01() : NotificationsExtensions::TileContent::TileWideImageAndText01
  • TileWideImageAndText02() : NotificationsExtensions::TileContent::TileWideImageAndText02
  • TileWideImageCollection() : NotificationsExtensions::TileContent::TileWideImageCollection
  • TileWidePeekImage01() : NotificationsExtensions::TileContent::TileWidePeekImage01
  • TileWidePeekImage02() : NotificationsExtensions::TileContent::TileWidePeekImage02
  • TileWidePeekImage03() : NotificationsExtensions::TileContent::TileWidePeekImage03
  • TileWidePeekImage04() : NotificationsExtensions::TileContent::TileWidePeekImage04
  • TileWidePeekImage05() : NotificationsExtensions::TileContent::TileWidePeekImage05
  • TileWidePeekImage06() : NotificationsExtensions::TileContent::TileWidePeekImage06
  • TileWidePeekImageAndText01() : NotificationsExtensions::TileContent::TileWidePeekImageAndText01
  • TileWidePeekImageAndText02() : NotificationsExtensions::TileContent::TileWidePeekImageAndText02
  • TileWidePeekImageCollection01() : NotificationsExtensions::TileContent::TileWidePeekImageCollection01
  • TileWidePeekImageCollection02() : NotificationsExtensions::TileContent::TileWidePeekImageCollection02
  • TileWidePeekImageCollection03() : NotificationsExtensions::TileContent::TileWidePeekImageCollection03
  • TileWidePeekImageCollection04() : NotificationsExtensions::TileContent::TileWidePeekImageCollection04
  • TileWidePeekImageCollection05() : NotificationsExtensions::TileContent::TileWidePeekImageCollection05
  • TileWidePeekImageCollection06() : NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • TileWideSmallImageAndText01() : NotificationsExtensions::TileContent::TileWideSmallImageAndText01
  • TileWideSmallImageAndText02() : NotificationsExtensions::TileContent::TileWideSmallImageAndText02
  • TileWideSmallImageAndText03() : NotificationsExtensions::TileContent::TileWideSmallImageAndText03
  • TileWideSmallImageAndText04() : NotificationsExtensions::TileContent::TileWideSmallImageAndText04
  • TileWideSmallImageAndText05() : NotificationsExtensions::TileContent::TileWideSmallImageAndText05
  • TileWideText01() : NotificationsExtensions::TileContent::TileWideText01
  • TileWideText02() : NotificationsExtensions::TileContent::TileWideText02
  • TileWideText03() : NotificationsExtensions::TileContent::TileWideText03
  • TileWideText04() : NotificationsExtensions::TileContent::TileWideText04
  • TileWideText05() : NotificationsExtensions::TileContent::TileWideText05
  • TileWideText06() : NotificationsExtensions::TileContent::TileWideText06
  • TileWideText07() : NotificationsExtensions::TileContent::TileWideText07
  • TileWideText08() : NotificationsExtensions::TileContent::TileWideText08
  • TileWideText09() : NotificationsExtensions::TileContent::TileWideText09
  • TileWideText10() : NotificationsExtensions::TileContent::TileWideText10
  • TileWideText11() : NotificationsExtensions::TileContent::TileWideText11
  • TimeLimit() : abstract
  • TimeRemaining() : Simple3DGame
  • TimeStamp() : CStreamState
  • TimeTriggeredTask() : SDKSample::BackgroundTask::sealed
  • toast_Dismissed() : ToastsSampleCPP::sealed
  • toast_Failed() : ToastsSampleCPP::sealed
  • ToastAudio() : NotificationsExtensions::ToastContent::ToastAudio
  • ToastImageAndText01() : NotificationsExtensions::ToastContent::ToastImageAndText01
  • ToastImageAndText02() : NotificationsExtensions::ToastContent::ToastImageAndText02
  • ToastImageAndText03() : NotificationsExtensions::ToastContent::ToastImageAndText03
  • ToastImageAndText04() : NotificationsExtensions::ToastContent::ToastImageAndText04
  • ToastNotificationBase() : NotificationsExtensions::ToastContent::ToastNotificationBase
  • ToastText01() : NotificationsExtensions::ToastContent::ToastText01
  • ToastText02() : NotificationsExtensions::ToastContent::ToastText02
  • ToastText03() : NotificationsExtensions::ToastContent::ToastText03
  • ToastText04() : NotificationsExtensions::ToastContent::ToastText04
  • TOCButton_Click() : SDKSample::FlipViewCPP::sealed
  • ToF16() : DirectX::INTColor
  • ToggleAppBarButton() : SecondaryTiles::sealed
  • ToggleButtons() : SecondaryTiles::sealed
  • ToggleScenario2() : SDKSample::Animation::sealed
  • ToHex() : SDKSample::DataReaderWriter::sealed
  • ToLDRColorA() : DirectX::HDRColorA
  • ToneSampleGenerator() : SDKSample::WASAPIAudio::ToneSampleGenerator
  • ToString()
: NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, SDKTemplate::Scenario
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
, NotificationsExtensions::NotificationBase
, SDKTemplate::Scenario
, NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
, SDKTemplate::Scenario
, NotificationsExtensions::NotificationBase
  • TotalHits() : Simple3DGame
  • TotalShots() : Simple3DGame
  • ToTwoDecimalPlaces() : Hilo::sealed
  • Touch() : SDKSample::DeviceCaps::sealed
  • TouchableTextBlock() : SDKSample::TouchKeyboard::sealed
  • TouchableTextBlockAutomationPeer() : SDKSample::TouchKeyboard::sealed
  • TouchableTextBlockRangeProvider() : SDKSample::TouchKeyboard::sealed
  • TouchGetSettings_Click() : SDKSample::DeviceCaps::sealed
  • TranscodeCancel() : SDKSample::Transcode::sealed
  • TranscodeComplete() : SDKSample::Transcode::sealed
  • TranscodeCustom() : SDKSample::Transcode::sealed
  • TranscodeError() : SDKSample::Transcode::sealed
  • TranscodeFailure() : SDKSample::Transcode::sealed
  • TranscodePreset() : SDKSample::Transcode::sealed
  • TranscodeProgress() : SDKSample::Transcode::sealed
  • TranscodeTrim() : SDKSample::Transcode::sealed
  • TransferData() : SDKSample::DataReaderWriter::sealed
  • TransferFileFromDeviceToAppLocalFolderAsync() : SDKSample::PortableDeviceCPP::sealed
  • TransferFileToDeviceAsync() : SDKSample::PortableDeviceCPP::sealed
  • TransformBindPose() : SDKMesh
  • TransformBindPoseFrame() : SDKMesh
  • TransformBounds() : sealed
  • TransformedPageSize() : CDocumentSource
  • TransformFrame() : SDKMesh
  • TransformFrameAbsolute() : SDKMesh
  • TransformMesh() : SDKMesh
  • Translate() : Shape
  • Transliteration() : SDKSample::ELS::sealed
  • TreeIterator() : TreeIterator< T >
  • TrialMode() : SDKSample::StoreSample::sealed
  • TrialModeRefreshScenario() : SDKSample::StoreSample::sealed
  • TrialProduct_Click() : SDKSample::StoreSample::sealed
  • TrialTime_Click() : SDKSample::StoreSample::sealed
  • Triangle() : Triangle
  • Triangle_Click()
: MediaExtensionsCS::ScenarioInput2
, MediaExtensionsCPP::sealed
  • Trigger_Click() : SDKSample::PortableDeviceCPP::sealed
  • TriggeredConnectionStateChangedEventHandler() : ProximityCPP::sealed
  • TriggerSoundEffect() : AudioController
  • Trim()
: SDKSample::StringTrimmer
, SDKSample::Helpers
, SDKSample::StringTrimmer
, SDKSample::Transcode::sealed
, SDKSample::StringHelper
  • TripOptimizer() : TripOptimizerComponent::sealed
  • TryGetValue() : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • TryProduct1_Click() : SDKSample::StoreSample::sealed
  • TryProduct2_Click() : SDKSample::StoreSample::sealed
  • TryTransform() : sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- u -

  • u() : AmpPixel
  • UI() : SDKSample::HighContrast::sealed
  • UIGetSettings_Click() : SDKSample::HighContrast::sealed
  • ULONG() : IMft0Vtbl
  • Uninitialize() : D2DTextAnimation , D2DInterpolationModes , DirectXApp , DWriteCustomTextRenderer , D2DPerspectiveTransform , DWriteHelloWorld , DWriteHitTesting , D2DBasicAnimation , DirectXApp , DWriteInlineObject , DWriteParagraphText , SaveAsImageFile , DWriteVerticalText , DirectXApp , D2DEffectsHelloWorld , DirectXApp , CoreWindowEvents , DirectXApp , CommandListRenderer , DirectXApp , sealed , DirectXApp , sealed , CompositeModes , DirectXApp , sealed , DirectXApp , ConvolveMatrixEffect , DirectXApp , Direct3DTutorialFrameworkView , D2DEffectsOnPrimitives , Direct3DTutorialFrameworkView , GeometryRealizationSample , Direct3DTutorialFrameworkView , DirectXApp
  • Unlock() : VideoBufferLock
  • UnlockBuffer() : VideoBufferLock
  • UnlockRegion() : ImageFile
  • UnlockScenarioChange() : SimpleCommunication::sealed
  • UnpinSecondaryTile_Click() : SecondaryTiles::sealed
  • UnpinTile() : SecondaryTiles::sealed
  • Unquantize()
: DirectX::D3DX_BC6H
, DirectX::D3DX_BC7
  • UnregisterBackgroundTask()
: SDKSample::BackgroundTask::sealed
, SDKSample::GeolocationCPP::sealed
, RawNotificationsSampleCPP::sealed
  • UnregisterBackgroundTasks()
: SDKSample::BackgroundTask::BackgroundTaskSample
, SDKSample::BackgroundTaskSample
  • UnregisterElement() : UserInterface
  • UnregisterForDeviceEvents() : SDKSample::PortableDeviceCPP::sealed
  • UnRegisterForNetworkStatusChangeNotif() : SDKSample::NetworkInformationApi::sealed
  • UnregisterForPrinting() : PrintSample::BasePrintPage
  • UnregisterFrame()
: SDKSample::Common::sealed
, Hilo::Common::sealed
, SDKSample::Common::sealed
  • UnregisterTaskButton_Click() : SDKSample::SDKTemplate::sealed
  • UnscaledToClient() : Shape
  • Unsnap() : Hilo::sealed
  • UnsnapButton_Click() : SDKSample::SnapSample::sealed
  • Up() : Camera
  • Update() : BasicTimer , CommandListRenderer , BasicTimer , GeometryRealization , BasicTimer , BumpMapping , LonLatController , AutoThrottle , BasicTimer , DirectXFractal , BasicTimer , D3DPostProcessing , BasicTimer , LonLatController , ResourceLoading , AutoThrottle , BasicTimer , SimpleSprites , BasicTimer , StereoSimpleD3D , BasicTimer , Direct3DTutorial , BasicTimer , TextInterop , DirectXApp , GameTimer , abstract , Level2 , Level4 , Level6 , MoveLookController , Sphere , BasicTimer , MarbleMaze , ElementBase , TextElement , CountdownTimer , StopwatchTimer , TextButton , HighScoreTable , UserInterface , BasicTimer , MoveLookController , AudioController , Simple3DTouch , BasicTimer , OfferReclaimAPI , Sphere , BasicTimer , DxgiRotation , Simple3DGameXaml::sealed , GameTimer , abstract , Level2 , Level4 , Level6 , MoveLookController , BasicTimer , StreamEffect , BasicTimer , SimpleController
  • UpdateAlpha() : CompositeModes
  • UpdateArrowForRotation() : SDKSample::DisplayOrientation::sealed
  • UpdateAsync() : SecondaryTiles::sealed
  • UpdateBackgroundTaskStatus()
: SDKSample::BackgroundTask::BackgroundTaskSample
, SDKSample::BackgroundTaskSample
  • UpdateBadge_Click() : SDKSample::Tiles::sealed
  • UpdateBadgeWithGlyph() : SDKSample::Tiles::sealed
  • UpdateBadgeWithGlyphWithStringManipulation() : SDKSample::Tiles::sealed
  • UpdateBadgeWithNumber() : SDKSample::Tiles::sealed
  • UpdateBadgeWithNumberWithStringManipulation() : SDKSample::Tiles::sealed
  • UpdateBarGraphTable()
: SDKSample::CustomDeviceAccess::sealed
, CustomDeviceAccess::DeviceAsync
  • UpdateBars() : Samples::Devices::Fx2::sealed
  • UpdateButtonState() : SDKSample::FilePickerContracts::sealed
  • UpdateCharacterSpacing() : DWriteParagraphText
  • UpdateCheckpoints() : MarbleMaze
  • UpdateConstants() : RippleEffect , WaveEffect
  • UpdateContent() : Magazine::sealed , ContentImageSource , Simple3DGameXaml::sealed
  • UpdateContentProps() : SDKSample::WASAPIAudio::sealed
  • UpdateContentUI() : SDKSample::WASAPIAudio::sealed
  • UpdateContentWithValues() : Hilo::WideFiveImageTile
  • UpdateCost() : SDKSample::ProvisioningAgent::sealed
  • UpdateCost_Click() : SDKSample::ProvisioningAgent::sealed
  • UpdateCropOverlayPostion() : Hilo::sealed
  • UpdateDefaultLogo_Click() : SecondaryTiles::sealed
  • UpdateDesign() : Document
  • UpdateDisplayText() : GeometryRealizationSample
  • UpdateDsp() : Wrapper::sealed
  • UpdateDX11Device() : CInvert
  • UpdateDynamics() : Simple3DGame
  • UpdateEffectMatrices() : D2DInterpolationModes
  • UpdateFormatInfo() : CGrayscale , CInvert , CPolarEffect , CInvert , CPolarEffect , CGrayscale
  • UpdateForViewState() : SDKSample::SnapSample::sealed
  • UpdateForViewStateChanged() : PostcardRenderer , D2DLightingEffectsRenderer , D2D3DTransformsRenderer
  • UpdateForWindowSizeChange() : abstract , SampleOverlay , abstract , SampleOverlay , abstract , GeometryRealizationSample , GameHud , abstract , SampleOverlay , PostcardRenderer , SampleOverlay , abstract , SampleOverlay , abstract , GameRenderer , abstract , SampleOverlay , abstract , SampleOverlay , LoadScreen , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , SampleOverlay , abstract , GameRenderer , SampleOverlay , MEPlayer , SampleOverlay , abstract , GameHud , PageRenderer , abstract , PageRenderer , abstract , SampleOverlay , abstract , SampleOverlay , abstract
  • UpdateGameConfig() : Simple3DGame
  • UpdateGameController() : MoveLookController
  • UpdateGeometryRendering() : GeometryRealizationSample
  • UpdateImageZoom() : ImageRenderer
  • UpdateInterpenetrations() : Collision
  • UpdateItem_Click() : SDKSample::AtomPub::sealed
  • UpdateJustification() : DWriteParagraphText
  • UpdateListener()
: SDKSample::SDKTemplate::sealed
, RawNotificationsSampleCPP::sealed
  • UpdateLocalClientWindow() : SimpleCommunication::sealed
  • UpdateManipulationTransform() : ManipulatableObject
  • UpdateMatrix() : Face
  • UpdateMediaControlUI() : SDKSample::WASAPIAudio::sealed
  • UpdateModelAndCamera() : ExtrudedTextRenderer
  • UpdatePhysicsSimulation() : Physics
  • UpdatePosition() : Face , Cylinder , GameObject , Cylinder , Face , GameObject
  • UpdateRegisterButton() : SDKSample::CustomDeviceAccess::sealed
  • UpdatesNeeded() : ContentImageSource
  • UpdateStartStopButtons() : SDKSample::CustomDeviceAccess::sealed
  • UpdateStereoEnabledStatus() : abstract
  • UpdateSwitchStateTable() : SDKSample::CustomDeviceAccess::sealed
  • UpdateTargetBox() : PageRendererContext
  • UpdateText() : HighScoreTable
  • UpdateTextGeometry() : ExtrudedTextRenderer
  • UpdateTile_Click() : SDKSample::Tiles::sealed
  • UpdateTileExpiring_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithImage_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithImageWithStringManipulation_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithText_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithTextWithStringManipulation_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithWebImage_Click() : SDKSample::Tiles::sealed
  • UpdateTileWithWebImageWithStringManipulation_Click() : SDKSample::Tiles::sealed
  • UpdateTouch() : MarbleMaze
  • UpdateUI()
: SDKSample::ThreadPool::sealed
, SDKSample::BackgroundTask::sealed
, SDKSample::ThreadPool::sealed
, SDKSample::FilePickerContracts::sealed
, SDKSample::BackgroundTask::sealed
, SDKSample::ThreadPool::sealed
  • UpdateUsage() : SDKSample::ProvisioningAgent::sealed
  • UpdateUsage_Click() : SDKSample::ProvisioningAgent::sealed
  • UpdateViewState() : Simple3DGameXaml::sealed , DirectXApp
  • UpdateWindowSize() : Renderer
  • UpdateWorkItemProgressUI() : SDKSample::ThreadPool::sealed
  • UploadProgress() : SDKSample::BackgroundTransfer::sealed
  • UserInterface() : UserInterface
  • UserNameField_TextChanged() : SDKSample::AtomPub::sealed
  • UserPreferences() : SDKSample::GlobalizationPreferencesSample::sealed
  • UsingLogicalPageNavigation() : SimpleBlogReader::sealed
  • Util() : SDKSample::ProvisioningAgent::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- v -

  • v() : AmpPixel
  • ValidateAndGetUri() : SDKSample::ShareSource::sealed
  • ValidateAudio() : NotificationsExtensions::ToastContent::ToastNotificationBase
  • ValidateBufferValue() : SDKSample::WASAPIAudio::WASAPIRenderer
  • ValidateDevice() : abstract
  • ValidateFile() : SDKSample::MainPage
  • ValidateOperation() : OpQueue< T, TOperation > , CMPEG1Source , OpQueue< T, TOperation > , CMPEG1Source , OpQueue< T, TOperation >
  • ValidatePresentationDescriptor() : CMPEG1Source
  • ValueFromPoint() : UiaCoreWindowProvider::ITriColorControlInternal , sealed
  • ValueToString() : TriColorValueHelper
  • Vector2() : Vector2< T >
  • Vector3() : Vector3< T >
  • Vector4() : Vector4< T >
  • VectorChanged() : SDKSample::DataBinding::sealed
  • VectorPosition() : GameObject
  • VectorVelocity() : GameObject
  • VectorViewToString() : SDKSample::GlobalizationPreferencesSample::sealed
  • Velocity() : MoveLookController , GameObject , MoveLookController , GameObject
  • VersionString() : SDKSample::PackageSample::sealed
  • VideoBufferLock() : VideoBufferLock
  • VideoChat()
: SimpleCommunication::VideoChat
, SimpleCommunication::sealed
  • videoFile_Click() : SDKSample::PlayTo::sealed
  • VideoOnError()
: MediaExtensionsCPP::sealed
, SDKTemplateCS::MainPage
  • VideoPlaybackErrorHandler() : SimpleCommunication::sealed
  • VideoRotationLookup() : SDKSample::MediaCapture::sealed
  • View() : Camera
  • ViewCurrentResources_Click() : SDKSample::Tiles::sealed
  • ViewDetail_Click() : SimpleBlogReader::sealed
  • ViewModelLocator() : Hilo::sealed
  • ViewSize() : IRenderer
  • VisibilityChanged()
: SDKSample::CompassCPP::sealed
, SDKSample::AccelerometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SimpleCommunication::sealed
, SDKSample::GyrometerCPP::sealed
  • Visible() : GameInfoOverlay
  • vsbvCombo_SelectionChanged() : SDKSample::ScrollViewerCPP::sealed
  • vsmCombo_SelectionChanged_1() : SDKSample::ScrollViewerCPP::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- w -

  • WaitForPress() : MoveLookController
  • waiting_previewButtonClicked() : SimpleCommunication::sealed
  • Waiting_PreviewButtonClicked() : SimpleCommunication::LowLatency
  • WarpTheta() : CPolarEffect
  • WASAPICapture() : SDKSample::WASAPIAudio::WASAPICapture
  • WASAPIRenderer() : SDKSample::WASAPIAudio::WASAPIRenderer
  • WaveEffect() : WaveEffect
  • webContent_Click() : SDKSample::PlayTo::sealed
  • WebView1_LoadCompleted() : SDKSample::WebViewControl::sealed
  • WebView4_ScriptNotify() : SDKSample::WebViewControl::sealed
  • WebView5_LoadCompleted() : SDKSample::WebViewControl::sealed
  • WebView5_ScriptNotify() : SDKSample::WebViewControl::sealed
  • WebView7_LoadCompleted() : SDKSample::WebViewControl::sealed
  • WelcomeMessage_TextChanged() : SDKSample::PasswordVaultCPP::sealed
  • WideFiveImageTile() : Hilo::WideFiveImageTile
  • Window_VisibilityChanged() : SimpleCommunication::LowLatency
  • WindowSizeChanged()
: SDKSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • WinRTComponent() : Wrapper::sealed
  • WorkItemScenario() : SDKSample::ThreadPool::sealed
  • World() : Camera
  • Write() : ImageFile
  • WriteBytesButton_Click() : SDKSample::FileAccess::sealed
  • WriteCompositeSetting_Click() : SDKSample::ApplicationDataSample::sealed
  • WriteData() : BasicReaderWriter
  • WriteDataAsync() : BasicReaderWriter
  • WriteFileButton_Click() : SDKSample::FilePicker::sealed
  • WriteLocalizedYearAndMonth() : Hilo::CalendarExtensions
  • WriteOutputText() : SDKSample::ApplicationDataSample::sealed
  • WriteReadStream() : SDKSample::DataReaderWriter::sealed
  • WriteSetting_Click() : SDKSample::ApplicationDataSample::sealed
  • WriteTextButton_Click() : SDKSample::FileAccess::sealed
  • WriteToStreamButton_Click() : SDKSample::FileAccess::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- x -

  • XAudio2SoundPlayer() : XAudio2SoundPlayer
  • Xpress_Click() : SDKSample::Compression::sealed
  • XpressHuff_Click() : SDKSample::Compression::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • j
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • ~

- y -

  • Yaw() : Camera , MoveLookController , Camera , MoveLookController
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- _ -

  • __pad1__ : Hilo::sealed
  • _channel : RawNotificationsSampleCPP::sealed
  • _displayHandlerToken : RawNotificationsSampleCPP::sealed
  • _employee : SDKSample::DataBinding::sealed
  • _inputFrame : RawNotificationsSampleCPP::sealed
  • _inputFrameLoadedToken : RawNotificationsSampleCPP::sealed
  • _layoutHandlerToken : RawNotificationsSampleCPP::sealed
  • _logicalDpiChangedToken : RawNotificationsSampleCPP::sealed
  • _message : SimpleCommunication::CaptureFailedEventArgs
  • _observableTeams : SDKSample::DataBinding::sealed
  • _organization : SDKSample::DataBinding::sealed
  • _outputFrame : RawNotificationsSampleCPP::sealed
  • _outputFrameLoadedToken : RawNotificationsSampleCPP::sealed
  • _pageLoadedHandlerToken : RawNotificationsSampleCPP::sealed
  • _scenariosFrame : RawNotificationsSampleCPP::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- k -

  • Key : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
  • Keys : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • KnownTypes : SuspensionManager
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- l -

  • Lang : NotificationsExtensions::NotificationContentText , NotificationsExtensions::NotificationBase
  • Launch : NotificationsExtensions::ToastContent::ToastNotificationBase
  • LaunchArgs : SDKTemplate::MainPage , DeviceAppForWebcam::sealed
  • Link : SimpleBlogReader::sealed
  • LocalhostVideo : SimpleCommunication::LowLatency
  • Loop : NotificationsExtensions::ToastContent::ToastAudio
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- m -

  • m_actualHeight : Hilo::sealed
  • m_actualWidth : Hilo::sealed
  • m_bottom : Hilo::sealed
  • m_cancelCommand : Hilo::sealed
  • m_cancellationTokenSource : Hilo::sealed
  • m_cartoonizeCommand : Hilo::sealed
  • m_cartoonizeImageCommand : Hilo::sealed
  • m_checkedForHardwareAcceleration : Hilo::sealed
  • m_count : Hilo::sealed
  • m_cropImageCommand : Hilo::sealed
  • m_cropOverlayHeight : Hilo::sealed
  • m_cropOverlayLeft : Hilo::sealed
  • m_cropOverlayTop : Hilo::sealed
  • m_cropOverlayWidth : Hilo::sealed
  • m_cropX : Hilo::sealed
  • m_cropY : Hilo::sealed
  • m_cts : Hilo::sealed
  • m_currentMode : Hilo::sealed
  • m_currentQueryId : Hilo::sealed
  • m_dateTimeForTitle : Hilo::sealed
  • m_emptyTitle : Hilo::sealed
  • m_exceptionPolicy : Hilo::ViewModelBase
  • m_fileDate : Hilo::sealed
  • m_filePath : Hilo::sealed
  • m_folderQuery : Hilo::sealed
  • m_getPhotoAsyncIsRunning : Hilo::sealed
  • m_groupCommand : Hilo::sealed
  • m_hasCount : Hilo::sealed
  • m_hasFileUpdateTask : Hilo::sealed
  • m_hr : SDKSample::WASAPIAudio::sealed
  • m_image : Hilo::sealed
  • m_imageMargin : Hilo::sealed
  • m_initializationTask : Hilo::sealed
  • m_inProgress : Hilo::sealed
  • m_isAmpPixelArrayPopulated : Hilo::sealed
  • m_isAppBarEnabled : Hilo::ViewModelBase
  • m_isAppBarOpen : Hilo::ViewModelBase
  • m_isAppBarSticky : Hilo::ViewModelBase
  • m_isCropOverlayVisible : Hilo::sealed
  • m_isSaving : Hilo::sealed
  • m_isSourcePixelsPopulated : Hilo::sealed
  • m_lastFileChangeTime : Hilo::sealed
  • m_left : Hilo::sealed
  • m_month : Hilo::sealed
  • m_monthGroups : Hilo::sealed
  • m_months : Hilo::sealed
  • m_name : Hilo::sealed
  • m_navigateToPicturesCommand : Hilo::sealed
  • m_neighborWindow : Hilo::sealed
  • m_phases : Hilo::sealed
  • m_photo : Hilo::sealed
  • m_photoCache : Hilo::sealed
  • m_photoCts : Hilo::sealed
  • m_photoPath : Hilo::sealed
  • m_photos : Hilo::sealed
  • m_photosCts : Hilo::sealed
  • m_pictureGroup : Hilo::sealed
  • m_pictureGroupPropertyChangedToken : Hilo::sealed
  • m_pOriginalPixels : Hilo::sealed
  • m_pSourcePixels : Hilo::sealed
  • m_query : Hilo::sealed
  • m_receivedChangeWhileRunning : Hilo::sealed
  • m_resumeCartoonizeCommand : Hilo::sealed
  • m_resumeCropCommand : Hilo::sealed
  • m_resumeRotateCommand : Hilo::sealed
  • m_retrievedPhotos : Hilo::sealed
  • m_right : Hilo::sealed
  • m_rotateCommand : Hilo::sealed
  • m_rotateImageCommand : Hilo::sealed
  • m_rotationAngle : Hilo::sealed
  • m_rowSpan : Hilo::sealed
  • m_runningMonthQuery : Hilo::sealed
  • m_runningOperation : Hilo::sealed
  • m_runningQuery : Hilo::sealed
  • m_runningQueryPhotosAsync : Hilo::sealed
  • m_runningQuerySinglePhotoAsync : Hilo::sealed
  • m_runningYearQuery : Hilo::sealed
  • m_runOperation : Hilo::sealed
  • m_saveCommand : Hilo::sealed
  • m_scaledHeight : Hilo::sealed
  • m_scaledWidth : Hilo::sealed
  • m_top : Hilo::sealed
  • m_useHardwareAcceleration : Hilo::sealed
  • m_weakPhotoCache : Hilo::sealed
  • m_year : Hilo::sealed
  • m_yearDate : Hilo::sealed
  • m_yearGroups : Hilo::sealed
  • MainPagePickerResized : ContactPicker::sealed
  • MainPageResized
: StreamSocketSample::sealed
, ContactPicker::sealed
, AccountPictureName::sealed
, SecondaryTiles::sealed
, DatagramSocketSample::sealed
, AppBarControl::sealed
, SDKSample::sealed
, ProximityCPP::sealed
, Clipboard::sealed
, SimpleCommunication::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- n -

  • name : SDKSample::DeviceEnumeration::sealed
  • nodeNamespace : SDKSample::sealed
  • nodeValue : SDKSample::sealed
  • Number : NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- o -

  • OutputFrame : SDKTemplateCS::MainPage
  • OutputFrameLoaded
: ToastsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, RawNotificationsSampleCPP::sealed
, PrintSample::sealed
, MediaExtensionsCPP::sealed
, LockScreenAppsCPP::sealed
, LanguageFontCPP::sealed
, EdgeGestureSample::sealed
, CredentialPickerCPP::sealed
, AssociationLaunching::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- a -

  • AddImageQuery : NotificationsExtensions::NotificationContentImage , NotificationsExtensions::NotificationBase
  • AddImageQueryNullable : NotificationsExtensions::NotificationBase , NotificationsExtensions::NotificationContentImage
  • Alt : NotificationsExtensions::NotificationContentImage
  • artistInner : SDKSample::MediaButtons::sealed
  • Audio : NotificationsExtensions::ToastContent::ToastNotificationBase
  • Author : SimpleBlogReader::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- b -

  • BaseUri : NotificationsExtensions::NotificationBase
  • Branding : NotificationsExtensions::TileContent::TileNotificationBase
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- c -

  • CaptureSource : SimpleCommunication::Common::CaptureDevice
  • ClassType : SDKTemplate::Scenario
  • CollectionChange : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >::ObservableDictionaryChangedEventArgs
  • Content : SimpleBlogReader::sealed , NotificationsExtensions::ToastContent::ToastAudio
  • Count : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • Current : CustomDeviceAccess::DeviceList
  • CurrentFeedUri : SimpleBlogReader::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- d -

  • DefaultViewModel : SDKTemplate::Common::LayoutAwarePage
  • DeviceClosing : SDKSample::CustomDeviceAccess::DeviceList
  • Duration : NotificationsExtensions::ToastContent::ToastNotificationBase
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- e -

  • ExtensionManager : SDKTemplateCS::MainPage
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- f -

  • Frequency : MediaStreamSource::PcmSource
  • Fx2Device : CustomDeviceAccess::DeviceList
  • Fx2Devices : CustomDeviceAccess::DeviceList
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- g -

  • Glyph : NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
  • glyphThumbnail : SDKSample::DeviceEnumeration::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- i -

  • Id : CustomDeviceAccess::DeviceListEntry
  • Image
: NotificationsExtensions::TileContent::TileSquareImage
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
, NotificationsExtensions::TileContent::TileWideImageAndText01
, NotificationsExtensions::TileContent::TileWideSmallImageAndText01
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideImageAndText02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText03
, NotificationsExtensions::TileContent::TileWideSmallImageAndText04
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileWidePeekImage01
, NotificationsExtensions::TileContent::TileWideSmallImageAndText05
, NotificationsExtensions::ToastContent::ToastImageAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::ToastContent::ToastImageAndText02
, NotificationsExtensions::ToastContent::ToastImageAndText03
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
, NotificationsExtensions::TileContent::TileWidePeekImage03
, NotificationsExtensions::ToastContent::ToastImageAndText04
, NotificationsExtensions::TileContent::TileWidePeekImage04
, NotificationsExtensions::TileContent::TileWideImage
, NotificationsExtensions::TileContent::TileWidePeekImageAndText01
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
  • ImageMain
: NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
, NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImage05
, NotificationsExtensions::TileContent::TileWidePeekImage06
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
  • Images : NotificationsExtensions::NotificationBase
  • ImageSecondary
: NotificationsExtensions::TileContent::TileWidePeekImage05
, NotificationsExtensions::TileContent::TileWidePeekImage06
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
  • ImageSmallColumn1Row1
: NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
, NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
  • ImageSmallColumn1Row2
: NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
  • ImageSmallColumn2Row1
: NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideImageCollection
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
  • ImageSmallColumn2Row2
: NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
, NotificationsExtensions::TileContent::TileWideImageCollection
  • InputFrame : SDKTemplateCS::MainPage
  • InstanceId : CustomDeviceAccess::DeviceListEntry
  • isEnabled : SDKSample::DeviceEnumeration::sealed
  • IsReadOnly : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- p -

  • properties : SDKSample::DeviceEnumeration::sealed
  • PropertyChanged : ScheduledNotificationsSampleCPP::sealed
  • PubDate : SimpleBlogReader::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- r -

  • RequireSquareContent : NotificationsExtensions::TileContent::TileWideBase
  • RootNamespace : SDKTemplateCS::MainPage
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- s -

  • ScenarioLoaded
: SDKSample::sealed
, AccountPictureName::sealed
, ContactPicker::sealed
, SecondaryTiles::sealed
, StreamSocketSample::sealed
, DatagramSocketSample::sealed
, AppBarControl::sealed
, Clipboard::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
  • ScenariosFrame : SDKTemplateCS::MainPage
  • SessionState : SuspensionManager
  • SquareContent : NotificationsExtensions::TileContent::TileWideBase
  • Src : NotificationsExtensions::NotificationContentImage
  • StrictValidation : NotificationsExtensions::NotificationBase
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- t -

  • TemplateName : NotificationsExtensions::NotificationBase
  • Text : NotificationsExtensions::NotificationContentText
  • TextBlock
: NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWideBlockAndText02
, NotificationsExtensions::TileContent::TileSquareBlock
  • TextBody : NotificationsExtensions::ToastContent::ToastImageAndText03 , NotificationsExtensions::ToastContent::ToastText03
  • TextBody1
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileWideText05
, NotificationsExtensions::ToastContent::ToastImageAndText04
, NotificationsExtensions::TileContent::TileSquareText01
, NotificationsExtensions::ToastContent::ToastText04
, NotificationsExtensions::TileContent::TileSquareText03
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
  • TextBody2
: NotificationsExtensions::ToastContent::ToastImageAndText04
, NotificationsExtensions::ToastContent::ToastText04
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileSquareText01
, NotificationsExtensions::TileContent::TileSquareText03
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWideText05
  • TextBody3
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileSquareText01
, NotificationsExtensions::TileContent::TileSquareText03
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWideText05
  • TextBody4
: NotificationsExtensions::TileContent::TileSquarePeekImageAndText03
, NotificationsExtensions::TileContent::TileSquareText03
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageAndText02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWideText05
  • TextBody5 : NotificationsExtensions::TileContent::TileWidePeekImageAndText02 , NotificationsExtensions::TileContent::TileWideText05
  • TextBodyWrap
: NotificationsExtensions::TileContent::TileWidePeekImageAndText01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
, NotificationsExtensions::TileContent::TileWideSmallImageAndText03
, NotificationsExtensions::TileContent::TileWideSmallImageAndText04
, NotificationsExtensions::TileContent::TileWideSmallImageAndText05
, NotificationsExtensions::TileContent::TileWideText04
, NotificationsExtensions::TileContent::TileWideText09
, NotificationsExtensions::ToastContent::ToastImageAndText01
, NotificationsExtensions::ToastContent::ToastImageAndText02
, NotificationsExtensions::ToastContent::ToastText01
, NotificationsExtensions::ToastContent::ToastText02
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText04
, NotificationsExtensions::TileContent::TileSquareText02
, NotificationsExtensions::TileContent::TileSquareText04
, NotificationsExtensions::TileContent::TileWideBlockAndText02
, NotificationsExtensions::TileContent::TileWidePeekImage01
, NotificationsExtensions::TileContent::TileWidePeekImage04
, NotificationsExtensions::TileContent::TileWidePeekImage05
  • TextCaption1 : NotificationsExtensions::TileContent::TileWideImageAndText02
  • TextCaption2 : NotificationsExtensions::TileContent::TileWideImageAndText02
  • TextCaptionWrap : NotificationsExtensions::TileContent::TileWideImageAndText01
  • TextColumn1Row1 : NotificationsExtensions::TileContent::TileWideText02 , NotificationsExtensions::TileContent::TileWideText06
  • TextColumn1Row2 : NotificationsExtensions::TileContent::TileWideText02 , NotificationsExtensions::TileContent::TileWideText06
  • TextColumn1Row3 : NotificationsExtensions::TileContent::TileWideText02 , NotificationsExtensions::TileContent::TileWideText06
  • TextColumn1Row4 : NotificationsExtensions::TileContent::TileWideText02 , NotificationsExtensions::TileContent::TileWideText06
  • TextColumn1Row5 : NotificationsExtensions::TileContent::TileWideText06
  • TextColumn2Row1
: NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileWideText11
  • TextColumn2Row2
: NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileWideText11
  • TextColumn2Row3
: NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileWideText11
, NotificationsExtensions::TileContent::TileWideText07
  • TextColumn2Row4
: NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText08
, NotificationsExtensions::TileContent::TileWideText11
  • TextColumn2Row5
: NotificationsExtensions::TileContent::TileWideText11
, NotificationsExtensions::TileContent::TileWideText06
, NotificationsExtensions::TileContent::TileWideText08
  • TextFields : NotificationsExtensions::NotificationBase
  • TextHeading
: NotificationsExtensions::TileContent::TileWideText07
, NotificationsExtensions::TileContent::TileWideText10
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText04
, NotificationsExtensions::TileContent::TileWideSmallImageAndText02
, NotificationsExtensions::TileContent::TileSquarePeekImageAndText01
, NotificationsExtensions::ToastContent::ToastImageAndText04
, NotificationsExtensions::ToastContent::ToastText02
, NotificationsExtensions::TileContent::TileWidePeekImage05
, NotificationsExtensions::TileContent::TileWideText09
, NotificationsExtensions::TileContent::TileWideText02
, NotificationsExtensions::ToastContent::ToastImageAndText02
, NotificationsExtensions::TileContent::TileWideSmallImageAndText05
, NotificationsExtensions::TileContent::TileWidePeekImageCollection02
, NotificationsExtensions::TileContent::TileWideText01
, NotificationsExtensions::TileContent::TileWidePeekImage01
, NotificationsExtensions::TileContent::TileSquareText01
, NotificationsExtensions::ToastContent::ToastText04
, NotificationsExtensions::TileContent::TileWidePeekImageCollection01
, NotificationsExtensions::TileContent::TileSquareText02
, NotificationsExtensions::TileContent::TileWidePeekImage02
, NotificationsExtensions::TileContent::TileWidePeekImageCollection05
  • TextHeadingWrap
: NotificationsExtensions::TileContent::TileWidePeekImage06
, NotificationsExtensions::ToastContent::ToastImageAndText03
, NotificationsExtensions::TileContent::TileWideText03
, NotificationsExtensions::ToastContent::ToastText03
, NotificationsExtensions::TileContent::TileWideSmallImageAndText01
, NotificationsExtensions::TileContent::TileWidePeekImageCollection06
, NotificationsExtensions::TileContent::TileWidePeekImageCollection03
, NotificationsExtensions::TileContent::TileWidePeekImage03
  • TextPrefixColumn1Row1 : NotificationsExtensions::TileContent::TileWideText10 , NotificationsExtensions::TileContent::TileWideText11
  • TextPrefixColumn1Row2 : NotificationsExtensions::TileContent::TileWideText11 , NotificationsExtensions::TileContent::TileWideText10
  • TextPrefixColumn1Row3 : NotificationsExtensions::TileContent::TileWideText10 , NotificationsExtensions::TileContent::TileWideText11
  • TextPrefixColumn1Row4 : NotificationsExtensions::TileContent::TileWideText11 , NotificationsExtensions::TileContent::TileWideText10
  • TextPrefixColumn1Row5 : NotificationsExtensions::TileContent::TileWideText11
  • TextShortColumn1Row1 : NotificationsExtensions::TileContent::TileWideText07 , NotificationsExtensions::TileContent::TileWideText08
  • TextShortColumn1Row2 : NotificationsExtensions::TileContent::TileWideText07 , NotificationsExtensions::TileContent::TileWideText08
  • TextShortColumn1Row3 : NotificationsExtensions::TileContent::TileWideText07 , NotificationsExtensions::TileContent::TileWideText08
  • TextShortColumn1Row4 : NotificationsExtensions::TileContent::TileWideText07 , NotificationsExtensions::TileContent::TileWideText08
  • TextShortColumn1Row5 : NotificationsExtensions::TileContent::TileWideText08
  • TextSubBlock
: NotificationsExtensions::TileContent::TileWideBlockAndText02
, NotificationsExtensions::TileContent::TileWideBlockAndText01
, NotificationsExtensions::TileContent::TileSquareBlock
  • this : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • thumbnail : SDKSample::DeviceEnumeration::sealed
  • Title : SimpleBlogReader::sealed , SDKTemplate::Scenario
  • trackInner : SDKSample::MediaButtons::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- u -

  • Uri : SimpleBlogReader::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Properties

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v

- v -

  • Values : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • ViewState : SDKTemplate::MainPageSizeChangedEventArgs
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Related Functions

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • List< T > : List< T >::POSITION
  • operator!= : PrintSample::PageDescription
  • operator== : PrintSample::PageDescription
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Typedefs

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • Checkpoints : MarbleMaze
  • InvokeFn : AsyncCallback< T >
  • mlt : Samples::Devices::Repeater
  • MonthPhoto : Hilo::PhotoCache
  • OpList : OpQueue< T, TOperation >
  • PointQueue : MarbleMaze
  • Ptr : ComPtrList< T, NULLABLE >
  • TouchMap : MarbleMaze
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- _ -

  • _11 : Matrix4x4< T >
  • _12 : Matrix4x4< T >
  • _13 : Matrix4x4< T >
  • _14 : Matrix4x4< T >
  • _21 : Matrix4x4< T >
  • _22 : Matrix4x4< T >
  • _23 : Matrix4x4< T >
  • _24 : Matrix4x4< T >
  • _31 : Matrix4x4< T >
  • _32 : Matrix4x4< T >
  • _33 : Matrix4x4< T >
  • _34 : Matrix4x4< T >
  • _41 : Matrix4x4< T >
  • _42 : Matrix4x4< T >
  • _43 : Matrix4x4< T >
  • _44 : Matrix4x4< T >
  • __pad0__ : DatagramSocketSample::Common::LayoutAwarePage , PageRenderer , Simple3DTouch , OfferReclaimAPI , DirectXApp , DxgiRotation , SDKSample::FilePickerContracts::sealed , DeviceAppForPrinters::App , SaveAsImageFile , AmpPixel , Hilo::sealed , PageRendererContext , Hilo::Common::LayoutAwarePage , Hilo::Common::sealed , SDKSample::App , D2D3DTransformsRenderer , BasicCamera , Hilo::HiloPage , Hilo::ImageBase , BasicLoader , Hilo::NullPhotoGroup , Hilo::ViewModelBase , abstract , BasicReaderWriter , ManipulatableObject , Program , BasicShapes , SDKSample::TouchKeyboard::sealed , MEPlayer , SDKSample::Common::LayoutAwarePage , PersistentState , BumpMapping , VideoView , MediaExtensionsCPP::App , LonLatController , ProximityCPP::Common::LayoutAwarePage , ProximityCPP::sealed , D2DTextAnimation , AutoThrottle , SimpleCommunication::App , SimpleCommunication::Common::LayoutAwarePage , DirectXFractal , SimpleCommunication::sealed , SimpleCommunication::CaptureFailedEventArgs , sealed , SampleOverlay , D3DPostProcessing , SimpleCommunication::SdkSample , SecondaryTiles::Common::LayoutAwarePage , ResourceLoading , SecondaryTiles::sealed , ShareTarget::Common::LayoutAwarePage , D2DBasicAnimation , BasicSprites::SpriteBatch , SDKSample::SplashScreen::sealed , StreamSocketSample::App , SimpleSprites , StreamSocketSample::Common::LayoutAwarePage , StreamSocketSample::sealed , SDKSample::Common::sealed , D2DEffectsHelloWorld , StereoSimpleD3D , SDKSample::WASAPIAudio::sealed , DeviceAppForWebcam::Common::LayoutAwarePage , Direct3DTutorial , DeviceAppForWebcam::sealed , AppBarControl::App , BasicTimer , TextInterop , AppBarControl::Common::LayoutAwarePage , AppBarControl::sealed , DWriteCustomTextRenderer , SDKSample::DataBinding::GeneratorIncrementalLoadingClass , SDKSample::DataBinding::IncrementalLoadingBase , SDKSample::sealed , CommandListRenderer , DWriteHelloWorld , D2DLightingEffectsRenderer , Simple3DGameXaml::sealed , DWriteHitTesting , SDKSample::FlipViewCPP::sealed , BasicSound , CompositeModes , DWriteInlineObject , RandomAccessReader , StreamEffect , DWriteParagraphText , AudioController , SimpleController , AccountPictureName::App , ConvolveMatrixEffect , DWriteVerticalText , AnimateLinePosition , D2DEffectsOnPrimitives , AnimateLineListPosition , AnimateCirclePosition , AccountPictureName::Common::LayoutAwarePage , FPSCounter , Audio , Camera , GeometryRealizationSample , Cylinder , CylinderMesh , AccountPictureName::sealed , D2DInterpolationModes , Face , FaceMesh , Design , GameHud , GameInfoOverlay , Clipboard::App , Document , GameObject , GameRenderer , Element , GameTimer , Level1 , Clipboard::Common::LayoutAwarePage , Image , Level2 , Level3 , ImageFrame , Level4 , Level5 , Clipboard::sealed , Layer , Level6 , Material , List< T > , MediaReader , MoveLookController , ContactPicker::App , PageRoll , Simple3DGame , SoundEffect , Rectangle , Sphere , SphereMesh , ContactPicker::Common::LayoutAwarePage , Renderer , TargetTexture , WorldCeilingMesh , Resource , WorldFloorMesh , WorldWallsMesh , ContactPicker::sealed , Story , LoadScreen , MarbleMaze , Text , ExtrudedTextRenderer , ImageRenderer , DatagramSocketSample::sealed , TextFrame , InkRenderer , PaperFragment , D2DPerspectiveTransform , PaperRenderer , PostcardRenderer
  • __pad1__ : SDKSample::sealed , Hilo::HiloPage , ManipulatableObject , SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • _acceleratorKeyEventToken : SDKSample::Common::LayoutAwarePage , Hilo::Common::LayoutAwarePage
  • _active : SimpleCommunication::sealed
  • _age : SDKSample::Accessibility::sealed
  • _backgroundBrush : sealed
  • _backgroundColor : sealed
  • _baseUri : SDKSample::FlipViewData::sealed
  • _bLocked : TextureLock
  • _bLocked2D : VideoBufferLock
  • _bLocked2D2 : VideoBufferLock
  • _bLockedBuffer : VideoBufferLock
  • _buffer : DirectX::Blob
  • _busy : SDKSample::DataBinding::IncrementalLoadingBase
  • _Category : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _city : SDKSample::DataBinding::sealed
  • _color : sealed , SDKSample::DataBinding::sealed
  • _CompletionEvent : ReadStreamTask::ReadStreamTaskImpl
  • _Content : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _count : SDKSample::CoTaskMemFreeArray , SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • _CTS : SDKSample::Transcode::sealed
  • _Current : SDKSample::CustomDeviceAccess::DeviceList
  • _currentBuffer : sealed
  • _currentScenario : SimpleCommunication::sealed
  • _currentSongIndex : SDKSample::MediaButtons::sealed
  • _currentState : SimpleCommunication::sealed
  • _defaultViewModel
: SDKSample::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
  • _descPosition : sealed
  • _Description : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _descText : sealed
  • _Destination : ReadStreamTask::ReadStreamTaskImpl
  • _device : SimpleCommunication::sealed
  • _deviceDesc : sealed
  • _deviceEventCookie : SDKSample::PortableDeviceCPP::sealed
  • _deviceEventSource : SDKSample::PortableDeviceCPP::sealed
  • _deviceInfoCollection : SDKSample::PortableDeviceCPP::sealed , SDKSample::RemovableStorageCPP::sealed
  • _dictionary : SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >
  • _dispatcher
: SDKSample::CallControl::sealed
, SDKSample::MediaButtons::sealed
, RawNotificationsSampleCPP::sealed
, SimpleCommunication::sealed
, SimpleCommunication::SdkSample
  • _displayHandlerToken
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • _drawingAttributes : sealed
  • _dueTime : ScheduledNotificationsSampleCPP::sealed
  • _eventReceived : SDKSample::PortableDeviceCPP::EventCallback
  • _eventTextFormat : sealed
  • _extensionManager : SDKTemplateCS::MainPage , MediaExtensionsCPP::sealed
  • _fileEventArgs : AssociationLaunching::sealed
  • _fontFamily : LanguageFontCPP::sealed
  • _fontStretch : LanguageFontCPP::sealed
  • _fontStyle : LanguageFontCPP::sealed
  • _fontWeight : LanguageFontCPP::sealed
  • _formatter : ScheduledNotificationsSampleCPP::sealed
  • _frameLoadedToken
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, MediaExtensionsCPP::sealed
, RawNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
  • _frameReference : sealed
  • _Image : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _image : DirectX::ScratchImage , SDKSample::FlipViewData::sealed
  • _ImagePathProperty : SDKSample::UserAndCustomControls::sealed
  • _Impl : ReadStreamTask
  • _incomingConnectionEventRegistrationToken : SimpleCommunication::sealed
  • _initColor : sealed
  • _initDX : sealed
  • _initDY : sealed
  • _initialization : SimpleCommunication::sealed
  • _initialized : SimpleCommunication::sealed
  • _initX : sealed
  • _initY : sealed
  • _inkBrush : sealed
  • _inkStyle : sealed
  • _InputFile : SDKSample::Transcode::sealed
  • _inputFrame
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
, LockScreenAppsCPP::sealed
, SDKTemplateCS::MainPage
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, EdgeGestureSample::sealed
  • _inputFrameLoadedToken
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, AssociationLaunching::sealed
, LockScreenAppsCPP::sealed
  • _inputString : ScheduledNotificationsSampleCPP::sealed
  • _isPropertyChangedObserved : SDKSample::DataBinding::sealed
  • _isTerminator : SimpleCommunication::sealed
  • _isTile : ScheduledNotificationsSampleCPP::sealed
  • _isVectorChangedObserved : SDKSample::DataBinding::IncrementalLoadingBase
  • _itemId : ScheduledNotificationsSampleCPP::sealed
  • _items
: ScheduledNotificationsSampleCPP::sealed
, SDKSample::FlipViewData::sealed
, SDKSample::ListViewSampleDataSource::sealed
, SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, SDKSample::DataBinding::sealed
  • _itemType : ScheduledNotificationsSampleCPP::sealed
  • _labeledBy : SDKSample::Accessibility::sealed
  • _LabelProperty : SDKSample::UserAndCustomControls::sealed
  • _latencyMode : SimpleCommunication::sealed
  • _layoutAwareControls
: AccountPictureName::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, SDKTemplate::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, Hilo::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
  • _layoutHandlerToken
: AssociationLaunching::sealed
, CredentialPickerCPP::sealed
, LanguageFontCPP::sealed
, MediaExtensionsCPP::sealed
, SDKSample::SnapSample::sealed
, ToastsSampleCPP::sealed
, EdgeGestureSample::sealed
  • _Link : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _localHostVideo : SimpleCommunication::sealed
  • _logicalDpiChangedToken
: CredentialPickerCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, AssociationLaunching::sealed
, LockScreenAppsCPP::sealed
  • _lPitch : VideoBufferLock
  • _m00 : Matrix4x4< T >
  • _m01 : Matrix4x4< T >
  • _m02 : Matrix4x4< T >
  • _m03 : Matrix4x4< T >
  • _m10 : Matrix4x4< T >
  • _m11 : Matrix4x4< T >
  • _m12 : Matrix4x4< T >
  • _m13 : Matrix4x4< T >
  • _m20 : Matrix4x4< T >
  • _m21 : Matrix4x4< T >
  • _m22 : Matrix4x4< T >
  • _m23 : Matrix4x4< T >
  • _m30 : Matrix4x4< T >
  • _m31 : Matrix4x4< T >
  • _m32 : Matrix4x4< T >
  • _m33 : Matrix4x4< T >
  • _manipulationMode : sealed
  • _manipulationPoints : sealed
  • _maxCount : SDKSample::DataBinding::GeneratorIncrementalLoadingClass
  • _mediaCapture : SimpleCommunication::sealed
  • _mediaCaptureFailedEventRegistrationToken : SimpleCommunication::sealed
  • _mediaElement : SDKSample::Accessibility::sealed
  • _mediaElementFailedEventRegistrationToken : SimpleCommunication::sealed
  • _mediaExtensionMgr : SimpleCommunication::sealed
  • _mediaFailedToken : MediaExtensionsCPP::sealed
  • _mediaSink : SimpleCommunication::sealed
  • _mediaSinkIncomingConnectionEventRegistrationToken : SimpleCommunication::sealed
  • _memory : DirectX::ScratchImage
  • _messageBrush : sealed
  • _metadata : DirectX::ScratchImage
  • _mxManip : ManipulatableObject
  • _name : SDKSample::DataBinding::sealed
  • _navigationDisabled : SimpleCommunication::sealed
  • _navigationShortcutsRegistered : SDKSample::Common::LayoutAwarePage , Hilo::Common::LayoutAwarePage
  • _nextTrackPressedEventToken : SDKSample::MediaButtons::sealed
  • _nimages : DirectX::ScratchImage
  • _oriHeadingUI : LanguageFontCPP::sealed
  • _oriTextUI : LanguageFontCPP::sealed
  • _OutputFile : SDKSample::Transcode::sealed
  • _OutputFileName : SDKSample::Transcode::sealed
  • _outputFrame
: AssociationLaunching::sealed
, EdgeGestureSample::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, CredentialPickerCPP::sealed
, SDKTemplateCS::MainPage
, LockScreenAppsCPP::sealed
, LanguageFontCPP::sealed
  • _outputFrameLoadedToken
: AssociationLaunching::sealed
, ToastsSampleCPP::sealed
, PrintSample::sealed
, ScheduledNotificationsSampleCPP::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, CredentialPickerCPP::sealed
, MediaExtensionsCPP::sealed
, LockScreenAppsCPP::sealed
  • _overflowColumns : Hilo::Common::sealed
  • _pageKey : SDKSample::Common::LayoutAwarePage , Hilo::Common::LayoutAwarePage
  • _pageLoadedHandlerToken
: CredentialPickerCPP::sealed
, AssociationLaunching::sealed
, LockScreenAppsCPP::sealed
, MediaExtensionsCPP::sealed
, PrintSample::sealed
, EdgeGestureSample::sealed
, LanguageFontCPP::sealed
, ToastsSampleCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
  • _parent : ManipulatableObject
  • _pContext : TextureLock
  • _pData : VideoBufferLock
  • _peer : SDKSample::TouchKeyboard::sealed
  • _picture : SDKSample::FlipViewData::sealed
  • _pInputBuffer : VideoBufferLock
  • _pInputBuffer2D : VideoBufferLock
  • _pInputBuffer2D2 : VideoBufferLock
  • _placeholder : SDKSample::MainPage
  • _playback : SDKSample::PlaybackManager::sealed , SDKSample::PlaybackManager2::sealed
  • _playlist : SDKSample::MediaButtons::sealed
  • _playlistCount : SDKSample::MediaButtons::sealed
  • _pointer : ScopedObject< T >
  • _pointerDevice : sealed
  • _pointerId : sealed
  • _pointerPressedEventToken : SDKSample::Common::LayoutAwarePage , Hilo::Common::LayoutAwarePage
  • _previousBuffer : sealed
  • _previousState : SimpleCommunication::sealed
  • _prevTrackPressedEventToken : SDKSample::MediaButtons::sealed
  • _privatePropertyChanged : SDKSample::DataBinding::sealed
  • _privateVectorChanged : SDKSample::DataBinding::IncrementalLoadingBase
  • _Profile : SDKSample::Transcode::sealed
  • _propBag : SDKSample::DataBinding::sealed
  • _PropertyChanged
: SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
, SDKSample::ListViewSampleDataSource::sealed
, SDKSample::FlipViewData::sealed
  • _protocolEventArgs : AccountPictureName::sealed , AssociationLaunching::sealed
  • _pSample : MediaStreamSource::PcmSource
  • _pTex : TextureLock
  • _ptInit : ManipulatableObject
  • _ptr : SDKSample::CoTaskMemFreeArray
  • _Reader : ReadStreamTask::ReadStreamTaskImpl
  • _recognitionText : sealed
  • _recognizer : sealed
  • _recognizerContainer : sealed
  • _recognizerId : sealed
  • _recordingStarted : SimpleCommunication::sealed
  • _renderer : sealed
  • _renderingMode : sealed
  • _resizeHandlerToken : ScheduledNotificationsSampleCPP::sealed , LockScreenAppsCPP::sealed
  • _role : SimpleCommunication::sealed
  • _rootNamespace : SDKTemplateCS::MainPage
  • _rootPage : SimpleCommunication::sealed
  • _scenariosFrame
: LanguageFontCPP::sealed
, ScheduledNotificationsSampleCPP::sealed
, ToastsSampleCPP::sealed
, PrintSample::sealed
, SDKTemplateCS::MainPage
, CredentialPickerCPP::sealed
, AssociationLaunching::sealed
, EdgeGestureSample::sealed
, MediaExtensionsCPP::sealed
, LockScreenAppsCPP::sealed
  • _sdkSample : SimpleCommunication::sealed
  • _selectionBrush : sealed
  • _selectionStyle : sealed
  • _size : DirectX::Blob , DirectX::ScratchImage
  • _sizeChangedHandlerToken : PrintSample::sealed
  • _stabilizedMediaFailedToken : MediaExtensionsCPP::sealed
  • _start : SDKSample::Transcode::sealed
  • _statusMessage : SimpleCommunication::SdkSample , sealed
  • _stop : SDKSample::Transcode::sealed
  • _StreamData : ReadStreamTask::ReadStreamTaskImpl
  • _streamFilteringCriteria : SimpleCommunication::sealed
  • _strokeBuilder : sealed
  • _strokeContainer : sealed
  • _Subtitle : SDKSample::ListViewSampleDataSource::sealed , SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed
  • _Task : ReadStreamTask::ReadStreamTaskImpl
  • _text : SDKSample::TouchKeyboard::sealed
  • _this : Hilo::Common::LayoutAwarePage , SDKSample::Common::LayoutAwarePage
  • _Title : SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed , SDKSample::ListViewSampleDataSource::sealed
  • _title : SDKSample::FlipViewData::sealed
  • _toast : ToastsSampleCPP::sealed
  • _toastContext : ToastsSampleCPP::sealed
  • _tokenHolding : sealed
  • _tokenManipulationCompleted : sealed
  • _tokenManipulationInertiaStarting : sealed
  • _tokenManipulationStarted : sealed
  • _tokenManipulationUpdated : sealed
  • _tokenRightTapped : sealed
  • _tokenTapped : sealed
  • _Transcoder : SDKSample::Transcode::sealed
  • _type : SDKSample::FlipViewData::sealed
  • _uiIndex : TextureLock
  • _useFilledStateForNarrowWindow
: ProximityCPP::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
  • _UseMp4 : SDKSample::Transcode::sealed
  • _videoSettingsFilter : SimpleCommunication::sealed
  • _wasPlaying : SDKSample::MediaButtons::sealed
  • _windowSizeEventToken
: Hilo::Common::LayoutAwarePage
, StreamSocketSample::Common::LayoutAwarePage
, Clipboard::Common::LayoutAwarePage
, DatagramSocketSample::Common::LayoutAwarePage
, SecondaryTiles::Common::LayoutAwarePage
, AccountPictureName::Common::LayoutAwarePage
, ContactPicker::Common::LayoutAwarePage
, AppBarControl::Common::LayoutAwarePage
, ShareTarget::Common::LayoutAwarePage
, SimpleCommunication::Common::LayoutAwarePage
, ProximityCPP::Common::LayoutAwarePage
, SDKSample::Common::LayoutAwarePage
, DeviceAppForWebcam::Common::LayoutAwarePage
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- k -

  • key : PersistentState
  • knownTypes_ : SuspensionManager
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- l -

  • lanIdInfo : SDKSample::NetworkInformationApi::sealed
  • lastName : SDKSample::Accessibility::sealed
  • Latitude : AntSystem::LatLong
  • LaunchArgs : SDKSample::App , SDKTemplate::App
  • layer : MPEG1AudioFrameHeader
  • lcWrapper : DeviceAppForWebcam::sealed , SDKTemplate::DeviceAppPage
  • length : LineSegment
  • levelCompleted : HighScoreEntry
  • license : Simple3DGameXaml::sealed
  • lightColor : ConstantBufferNeverChanges
  • lightPosition : ConstantBufferNeverChanges
  • lightStrength : ConstantBuffer
  • listener : DatagramSocketSample::sealed , StreamSocketSample::sealed
  • ListenerCount : Samples::Devices::Fx2::sealed
  • llTimestamp : SDKSample::WASAPIAudio::MFSampleGenerator
  • localFile : SDKSample::PlayTo::sealed
  • localScenariosInner : SDKSample::FilePickerContracts::sealed
  • localSettings : SDKSample::ApplicationDataSample::sealed
  • Locations : AntSystem::Node
  • lock : DatagramSocketSample::sealed
  • Longitude : AntSystem::LatLong
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- m -

  • m_2DAffineTransformEffectLeft : D2DInterpolationModes
  • m_2DAffineTransformEffectRight : D2DInterpolationModes
  • m_3DPerspectiveTransformEffect : D2D3DTransformsRenderer
  • m_3DTransformEffect : D2D3DTransformsRenderer
  • m_aButtonWasPressed : AudioController
  • m_acceleration : Physics
  • m_accelerometer : MarbleMaze
  • m_accSettings : sealed
  • m_accumulatedTime : Physics
  • m_actionBrush : GameInfoOverlay
  • m_activated : sealed
  • m_activationEntryPoint : sealed
  • m_active : GameObject , GameTimer , StopwatchTimer
  • m_activeBackground : Simple3DGame
  • m_AddImageQueryNullable : NotificationsExtensions::NotificationContentImage , NotificationsExtensions::NotificationBase
  • m_adjacencyIndexBufferArray : SDKMesh
  • m_alignment : ElementBase
  • m_allocated : Buffer
  • m_allPhotosQueryChange : Hilo::FileSystemRepository
  • m_alpha : AntSystem::Ant , CompositeModes
  • m_Alt : NotificationsExtensions::NotificationContentImage
  • m_ammo : Simple3DGame
  • m_ammoCount : Simple3DGame
  • m_ammoNext : Simple3DGame
  • m_anchor : List< T >
  • m_animatePosition : GameObject
  • m_animating : D2DTextAnimation
  • m_animationData : SDKMesh
  • m_animationFrameData : SDKMesh
  • m_animationHeader : SDKMesh
  • m_antialiasMode : GeometryRealizationSample
  • m_app : Simple3DGameXaml::sealed
  • m_appleAlphaEffect : CompositeModes
  • m_appleBitmap : CompositeModes
  • m_appleEffect : CompositeModes
  • m_applicationView : sealed , VideoView
  • m_appWindowProvider : sealed
  • m_arithmeticCompositeEffect : D2DEffectsOnPrimitives
  • m_arrivedToken : ProximityCPP::sealed
  • m_arTS : CStreamState
  • m_aspectRatio : Camera
  • m_asteroid : SimpleSprites
  • m_asteroidData : SimpleSprites
  • m_atStartScreen : Postcard::sealed
  • m_Audio : NotificationsExtensions::ToastContent::ToastNotificationBase
  • m_audio : AudioEngineCallbacks , MarbleMaze
  • m_audioAvailable : Audio , SoundEffect
  • m_audioBuffer : SoundEffectData
  • m_audioBuffers : Audio , StreamEffect
  • m_AudioCaptureClient : SDKSample::WASAPIAudio::WASAPICapture
  • m_AudioClient : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_audioController : Simple3DGame
  • m_audioEngine : AudioController , XAudio2SoundPlayer
  • m_AudioMT : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_AudioRenderClient : SDKSample::WASAPIAudio::WASAPIRenderer
  • m_audioType : MediaStreamer
  • m_autoFire : MoveLookController
  • m_autoThrottle : SimpleSprites
  • m_axis : Cylinder
  • m_back : LonLatController , MoveLookController
  • m_background : Magazine::sealed , SimpleSprites
  • m_backgroundBrush : GameInfoOverlay
  • m_bActive : CMPEG1Stream
  • m_bananaAlphaEffect : CompositeModes
  • m_bananaBitmap : CompositeModes
  • m_bananaEffect : CompositeModes
  • m_Bars : Samples::Devices::Fx2::sealed
  • m_baseline : TextFrame
  • m_baseTime : GameTimer
  • m_BaseUri : NotificationsExtensions::NotificationBase
  • m_basicReaderWriter : BasicLoader
  • m_BBP : FrameData
  • m_bEffectAdded : SDKSample::MediaCapture::sealed
  • m_bEffectAddedToPhoto : SDKSample::MediaCapture::sealed
  • m_bEffectAddedToRecord : SDKSample::MediaCapture::sealed
  • m_begin : Buffer
  • m_bEOS : Parser , CMPEG1Stream
  • m_beta : AntSystem::Ant
  • m_bGOPData : CStreamState
  • m_bHasPacketHeader : Parser
  • m_bindPoseFrameMatrices : SDKMesh
  • m_bitmap : Image , LoadScreen , PaperFragment
  • m_bitmapBrush : DWriteCustomTextRenderer
  • m_bitmapOffset : PaperFragment
  • m_bitmapPerspective : D2DPerspectiveTransform
  • m_bitmapPixelBounds : ImageFrame
  • m_bitmapPixelSize : CompositeModes , ConvolveMatrixEffect
  • m_bitmapSourceEffect : D2D3DTransformsRenderer , D2DEffectsHelloWorld , ConvolveMatrixEffect , D2DInterpolationModes , ImageRenderer , D2DLightingEffectsRenderer
  • m_bkgColor : MEPlayer
  • m_blackBrush : D2DTextAnimation , D2DBasicAnimation , GeometryRealizationSample , SaveAsImageFile , PageRendererContext , DWriteCustomTextRenderer , DWriteHelloWorld , DWriteHitTesting , DWriteInlineObject , DWriteParagraphText , DWriteVerticalText , TargetTexture , InkRenderer , PaperRenderer , CoreWindowEvents , sealed
  • m_blendEffect : CompositeModes
  • m_blendModeNames : CompositeModes
  • m_blendModeTextLayout : CompositeModes
  • m_blendState : MarbleMaze
  • m_blendStateAdditive : BasicSprites::SpriteBatch
  • m_blendStateAlpha : BasicSprites::SpriteBatch
  • m_bLowLatencyMode : CDecoder
  • m_blueBrush : CommandListRenderer , TargetTexture
  • m_bottomMargin : TextFrame
  • m_bPicture : CDecoder
  • m_BPP : FrameProcessing
  • m_bPreviewing : MediaCapture::BasicCapture , SDKSample::MediaCapture::sealed
  • m_Branding : NotificationsExtensions::TileContent::TileNotificationBase
  • m_breakpoints : TextAnalysis
  • m_bRecording
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • m_bReversePreviewRotation : SDKSample::MediaCapture::sealed
  • m_brightPassConstantBuffer : D3DPostProcessing
  • m_brightPassTextureRenderTargetView : D3DPostProcessing
  • m_brightPassTextureShaderResourceView : D3DPostProcessing
  • m_bRotateVideoOnOrientationChange : SDKSample::MediaCapture::sealed
  • m_browseConnectSupported : ProximityCPP::sealed
  • m_brush : Rectangle , TextFrame , StereoSimpleD3D , PaperFragment
  • m_bStreamingInitialized : CGrayscale , CInvert , CPolarEffect
  • m_bstrURL : MEPlayer
  • m_bSuspended
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • m_BufferFrames : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_bufferHeight : DirectXFractal
  • m_bufferInfoCB : DirectXFractal
  • m_bufferWidth : DirectXFractal
  • m_buttonInUse : MoveLookController
  • m_buttonLowerRight : MoveLookController
  • m_buttonPointerID : MoveLookController
  • m_buttonPressed : MoveLookController
  • m_buttonUpperLeft : MoveLookController
  • m_BytesPerPeriod : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_cachedDigits : FPSCounter
  • m_cachedStaticText : FPSCounter
  • m_callback : Hilo::sealed
  • m_camera : BumpMapping , D3DPostProcessing , ResourceLoading , Direct3DTutorial , TextInterop , Simple3DGame , MarbleMaze , ExtrudedTextRenderer , Simple3DTouch
  • m_Camera : OfferReclaimAPI , DxgiRotation
  • m_cameraPitchAngle : Camera
  • m_cameraYawAngle : Camera
  • m_cancellationTokenSource : TripOptimizerComponent::Details::TripOptimizerImpl
  • m_Canceller : Samples::Devices::Repeater
  • m_CancelToken : Samples::Devices::Fx2::sealed
  • m_canExecute : Hilo::sealed
  • m_canExecuteDelegate : Hilo::sealed
  • m_capacity : BasicSprites::SpriteBatch
  • m_captionFormat : D2D3DTransformsRenderer
  • m_captionHeight : D2D3DTransformsRenderer
  • m_captionLayouts : CompositeModes
  • m_captionTop : D2D3DTransformsRenderer
  • m_cbBytes : CStreamState
  • m_cbData : CDecoder
  • m_cbDataSize : SDKSample::WASAPIAudio::WASAPICapture
  • m_cbFlushCounter : SDKSample::WASAPIAudio::WASAPICapture
  • m_cbHeaderSize : SDKSample::WASAPIAudio::WASAPICapture
  • m_cbImageSize : CGrayscale , CInvert , CDecoder , CPolarEffect
  • m_ceilingTexture : GameRenderer
  • m_cellSize : CompositeModes
  • m_center : AnimateCirclePosition
  • m_characters : ExtrudedTextRenderer
  • m_checkpoints : MarbleMaze
  • m_checkpointText : MarbleMaze
  • m_circleGeometry1 : TargetTexture
  • m_circleGeometry2 : TargetTexture
  • m_circleGeometry3 : TargetTexture
  • m_circleGeometry4 : TargetTexture
  • m_circleGeometry5 : TargetTexture
  • m_clearBrush : TargetTexture
  • m_clockwise : AnimateCirclePosition
  • m_collision : MarbleMaze , Physics
  • m_collisions : Collision
  • m_color : Rectangle , TextFrame , PaperFragment , Shape
  • m_coloredBrush : D2DEffectsOnPrimitives
  • m_colorPlanes : FrameData , FrameProcessing
  • m_columnSpan : Hilo::sealed
  • m_commandList : CommandListRenderer
  • m_complete : DirectXFractal
  • m_completedIterations : DirectXFractal
  • m_compositeEffect : CompositeModes , TextFrame
  • m_compositeModeNames : CompositeModes
  • m_compositeModeTextLayout : CompositeModes
  • m_computeCB : DirectXFractal
  • m_connectionRequestedToken : ProximityCPP::sealed
  • m_ConnectStateArray : ProximityCPP::sealed
  • m_constantBuffer : BumpMapping , D3DPostProcessing , ResourceLoading , StereoSimpleD3D , Direct3DTutorialFrameworkView , Direct3DTutorial , TextInterop , MarbleMaze , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_constantBufferChangeOnResize : GameRenderer
  • m_constantBufferChangesEveryFrame : GameRenderer
  • m_constantBufferChangesEveryPrim : GameRenderer
  • m_constantBufferData : BumpMapping , D3DPostProcessing , ResourceLoading , StereoSimpleD3D , Direct3DTutorialFrameworkView , Direct3DTutorial , TextInterop , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_constantBufferNeverChanges : GameRenderer
  • m_constants : RippleEffect , WaveEffect
  • m_container : ElementBase
  • m_Content : NotificationsExtensions::ToastContent::ToastAudio
  • m_content : ContentImageSource , Magazine::sealed
  • m_contentBitmap : TextFrame
  • m_contentSize : ContentImageSource
  • m_ContentStream
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::sealed
, SDKSample::WASAPIAudio::WASAPICapture
  • m_ContentType : SDKSample::WASAPIAudio::sealed
  • m_contextSize : CompositeModes
  • m_continuous : abstract
  • m_control : CAppWindowProvider
  • m_controller : BumpMapping , ResourceLoading , DirectXApp , Simple3DGame , Simple3DTouch , Simple3DGameXaml::sealed
  • m_controlProvider : sealed
  • m_controlRect : sealed
  • m_convolveMatrixEffect : ConvolveMatrixEffect
  • m_coreDispatcher : ProximityCPP::sealed
  • m_CoreDispatcher : SDKSample::WASAPIAudio::sealed
  • m_count : AnimateLineListPosition , List< T > , StreamList , Buffer
  • m_cPendingEOS : CMPEG1Source
  • m_cPlotDataFilled : SDKSample::WASAPIAudio::WASAPICapture
  • m_cPlotDataMax : SDKSample::WASAPIAudio::WASAPICapture
  • m_cRef : MediaEngineNotify , SourceOp , CMPEG1Source , CMPEG1Stream
  • m_cRestartCounter : CMPEG1Source
  • m_criticalSection : CritSec
  • m_critSec : MEPlayer , CGrayscale , CInvert , CDecoder , CMPEG1Source , CPolarEffect
  • m_critsec : OpQueue< T, TOperation >
  • m_CritSec : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_cropImageViewModel : Hilo::sealed
  • m_csPrintSync : PrintSample::sealed
  • m_curPacketHeader : Parser
  • m_currentBlendState : BasicSprites::SpriteBatch
  • m_currentBuffer : Audio , StreamEffect
  • m_currentCheckpoint : MarbleMaze
  • m_currentEffect : D2D3DTransformsRenderer , D2DLightingEffectsRenderer
  • m_currentFontFile : FontLoader
  • m_currentLevel : Simple3DGame
  • m_currentNode : TreeIterator< T >
  • m_currentOpacity : Layer
  • m_currentPage : PrintSample::BasePrintPage
  • m_currentPageDescription : PrintSample::sealed
  • m_currentPosition : TextAnalysis
  • m_currentRoomSize : Physics
  • m_currentRunIndex : TextAnalysis
  • m_currentScenarioLoaded : SDKSample::MediaCapture::sealed
  • m_currentStroke : InkRenderer
  • m_currentTextureView : BasicSprites::SpriteBatch
  • m_currentTime : BasicTimer , GameTimer
  • m_cWindow : MediaEngineNotify
  • m_cylinderTexture : GameRenderer
  • m_d2dContext : abstract , SampleOverlay , FPSCounter , PageRendererContext , GameInfoOverlay , TargetTexture , LoadScreen , UserInterface , ImageRenderer , InkRenderer , PaperFragment , PaperRenderer , Program
  • m_d2dDevice : abstract , SampleOverlay , Renderer , LoadScreen , UserInterface
  • m_d2dDeviceContext : Renderer
  • m_d2dFactory : abstract , SampleOverlay , Renderer , TargetTexture , LoadScreen , UserInterface , ExtrudedTextRenderer , InkRenderer , PaperRenderer
  • m_d2dMultithread : D2DFactoryLock
  • m_d2dPrintControl : PageRenderer
  • m_d2dTargetBitmap : abstract
  • m_d2dTargetBitmapRight : abstract
  • m_d3dContext : abstract , BasicSprites::SpriteBatch , SDKMesh , ExtrudedTextRenderer
  • m_d3dDepthStencilView : abstract , ExtrudedTextRenderer
  • m_d3dDevice : abstract , BasicLoader , BasicShapes , BasicSprites::SpriteBatch , Direct3DTutorialFrameworkView , TargetTexture , SDKMesh , ExtrudedTextRenderer
  • m_d3dDeviceContext : Direct3DTutorialFrameworkView
  • m_d3dFormat : MEPlayer
  • m_d3dRenderTargetView : abstract , ExtrudedTextRenderer
  • m_d3dRenderTargetViewRight : abstract
  • m_data : FontFileStream , ImageFile , SourceOp
  • m_Data : CAsyncState
  • m_dataTextFormat : BasicSound , StreamEffect , AudioController , SimpleController
  • m_dataWriter : ProximityCPP::sealed
  • m_dateQuery : Hilo::ImageNavigationData
  • m_defaultXAxis : GameObject
  • m_defaultYAxis : GameObject
  • m_defaultZAxis : GameObject
  • m_deferredResourcesReady : MarbleMaze
  • m_delta : BasicTimer
  • m_deltaTime : GameTimer
  • m_departedToken : ProximityCPP::sealed
  • m_depthStencilView : Direct3DTutorialFrameworkView
  • m_design : Document
  • m_Device : SDKSample::CustomDeviceAccess::sealed
  • m_deviceContext : GeometryRealization , GeometryRealizationFactory
  • m_DeviceIdString : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_DeviceIoControl : Samples::Devices::Fx2::sealed
  • m_DeviceProps : SDKSample::WASAPIAudio::WASAPIRenderer
  • m_DevicesList : SDKSample::WASAPIAudio::sealed
  • m_DeviceState : SDKSample::WASAPIAudio::sealed
  • m_DeviceStateChanged : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_deviceStateChangeToken : SDKSample::WASAPIAudio::sealed
  • m_devInfoCollection : SDKSample::MediaCapture::sealed
  • m_diffuseColor : Material
  • m_directComputeCS : DirectXFractal
  • m_direction : BasicCamera , Camera
  • m_disconnected : CAppWindowProvider
  • m_DiscontinuityCount : SDKSample::WASAPIAudio::sealed
  • m_displayMessage : PrintSample::InvalidPageException
  • m_displayPageRendererContext : PageRenderer
  • m_displaySize : TextFrame
  • m_displayText : GeometryRealizationSample
  • m_distantDiffuseEffect : D2DLightingEffectsRenderer
  • m_distantSpecularEffect : D2DLightingEffectsRenderer
  • m_document : ContentImageSource , Magazine::sealed
  • m_down : LonLatController , MoveLookController
  • m_downSampleRatio : DirectXFractal
  • m_downScaleBrightPass9PixelShader : D3DPostProcessing
  • m_downScaleBrightPassPixelShader : D3DPostProcessing
  • m_dpi : abstract , RippleEffect , FPSCounter , Renderer , BasicSprites::SpriteBatch , GameInfoOverlay , ExtrudedTextRenderer , ImageRenderer , InkRenderer , PaperRenderer
  • m_drawEnabled : CompositeModes
  • m_drawInfo : RippleEffect , WaveEffect
  • m_drawOverlay : SampleOverlay
  • m_drawRectCB : DirectXFractal
  • m_drawStroke : GeometryRealizationSample
  • m_duration : abstract
  • m_Duration : Animation< T > , NotificationsExtensions::ToastContent::ToastNotificationBase
  • m_dwNextTimeCode : CStreamState
  • m_dwQueueID : SDKSample::WASAPIAudio::WASAPICapture
  • m_dwriteFactory : abstract , SampleOverlay , FPSCounter , Document , FontLoader , GameHud , GameInfoOverlay , TargetTexture , UserInterface , ExtrudedTextRenderer
  • m_dwTimeCode : CStreamState
  • m_dxgiDevice : FPSCounter , Renderer
  • m_dxgiPreviewTarget : CDocumentSource
  • m_edges : AntSystem::Ant
  • m_effectContext : RippleEffect
  • m_eField : DirectX::D3DX_BC6H::ModeDescriptor
  • m_elapsedTime : D2DBasicAnimation , CountdownTimer , StopwatchTimer
  • m_elements : UserInterface
  • m_end : Buffer
  • m_End : Animation< T >
  • m_endHeight : FrameData
  • m_endPosition : AnimateLinePosition
  • m_endWidth : FrameData
  • m_engineExperiencedCriticalError : Audio
  • m_entries : HighScoreTable
  • m_eventName : CoreWindowEvents
  • m_eventRegistrationToken : SDKSample::MediaCapture::sealed
  • m_eventTextFormat : CoreWindowEvents
  • m_exceptionPolicy
: Hilo::sealed
, Hilo::FileSystemRepository
, Hilo::ThumbnailGenerator
  • m_executeDelegate : Hilo::sealed
  • m_extrudedTextRenderer : PostcardRenderer
  • m_eye : Camera
  • m_fadeOutTime : TextElement
  • m_fadeOutTimeElapsed : TextElement
  • m_fadeStartingOpacity : TextElement
  • m_farPlane : Camera
  • m_farZ : StereoSimpleD3D
  • m_fastGenerate : DirectXFractal
  • m_featureLevel : abstract , Renderer
  • m_feedCompletionEvents : SimpleBlogReader::sealed
  • m_feeds : SimpleBlogReader::sealed
  • m_fEOS : MEPlayer
  • m_fExitApp : MEPlayer
  • m_fieldOfView : Camera
  • m_figureVertices : Extruder::ExtrudingSink
  • m_file : Image , RandomAccessReader
  • m_fileDate : Hilo::ImageNavigationData
  • m_fileInfo : Hilo::sealed
  • m_fileName : Document
  • m_fileNames : Hilo::WideFiveImageTile
  • m_filePath : Hilo::ImageNavigationData
  • m_fillMaskDestBounds : GeometryRealization
  • m_fillMaskSourceBounds : GeometryRealization
  • m_fillMesh : GeometryRealization
  • m_fillRT : GeometryRealization
  • m_filmStripLoadedToken : Hilo::sealed
  • m_finalPassPixelShader : D3DPostProcessing
  • m_finalPS : DirectXFractal
  • m_finalRTV : DirectXFractal
  • m_finalSRV : DirectXFractal
  • m_fInitSuccess : MEPlayer
  • m_fireInUse : MoveLookController
  • m_fireLastPoint : MoveLookController
  • m_fireLowerRight : MoveLookController
  • m_firePointerID : MoveLookController
  • m_firePressed : MoveLookController
  • m_fireUpperLeft : MoveLookController
  • m_firstChild : Element
  • m_firstDigitOffset : FPSCounter
  • m_firstPage : PrintSample::BasePrintPage
  • m_firstRun : D2DTextAnimation
  • m_fLoop : MEPlayer
  • m_floorTexture : GameRenderer
  • m_floorTriList : Collision
  • m_flowLayout : DWriteVerticalText
  • m_flowLayoutSink : DWriteVerticalText
  • m_flowLayoutSource : DWriteVerticalText
  • m_flRate : SetRateOp , CMPEG1Source , CMPEG1Stream
  • m_fontCollection : Document
  • m_fontFileCount : FontLoader
  • m_fontFileStreamIndex : FontLoader
  • m_fontFileStreams : FontLoader
  • m_fontLoader : Document
  • m_fontName : DWriteVerticalText , TextStyle
  • m_fontSize : TextFrame , DWriteVerticalText , TextStyle
  • m_fontStyle : TextStyle
  • m_fontWeight : TextStyle
  • m_foreground : Simple3DGameXaml::sealed
  • m_formattedPrice : Simple3DGameXaml::sealed
  • m_forward : LonLatController , MoveLookController
  • m_fPlaying : MEPlayer
  • m_frameArray : SDKMesh
  • m_frameRate : CDecoder
  • m_frequency : BasicTimer
  • m_fStopTimer : MEPlayer
  • m_fThin : SetRateOp
  • m_fUseDX : MEPlayer
  • m_fWriting : SDKSample::WASAPIAudio::WASAPICapture
  • m_Fx2Device : CustomDeviceAccess::DeviceList , SDKSample::CustomDeviceAccess::DeviceList
  • m_Fx2Devices : CustomDeviceAccess::DeviceList
  • m_Fx2Watcher : CustomDeviceAccess::DeviceList , SDKSample::CustomDeviceAccess::DeviceList
  • m_game : DirectXApp , GameRenderer , Simple3DGameXaml::sealed
  • m_gameActive : Simple3DGame
  • m_gameConfig : Simple3DGame
  • m_gameHud : GameRenderer
  • m_gameInfoOverlay : GameRenderer
  • m_gameInfoOverlayCommand : DirectXApp
  • m_gameInfoOverlayState : DirectXApp , Simple3DGameXaml::sealed
  • m_gameResourcesLoaded : GameRenderer
  • m_gameState : MarbleMaze
  • m_gaussianBlurEffect : D2DEffectsHelloWorld
  • m_geometry : GeometryRealization , GeometryRealizationSample , PaperFragment
  • m_geometryShader : BasicSprites::SpriteBatch
  • m_gestureRecognizer : D2DTextAnimation , CommandListRenderer , CompositeModes , ConvolveMatrixEffect , GeometryRealizationSample , D2DInterpolationModes , D2DPerspectiveTransform , DirectXApp , DWriteParagraphText
  • m_globalOffsetX : D2D3DTransformsRenderer
  • m_globalOffsetY : D2D3DTransformsRenderer
  • m_globalOffsetZ : D2D3DTransformsRenderer
  • m_glowConstantBuffer : D3DPostProcessing
  • m_glowEffect : TextFrame
  • m_glowPixelShader : D3DPostProcessing
  • m_glowTextureHeight : D3DPostProcessing
  • m_glowTextureRenderTargetViews : D3DPostProcessing
  • m_glowTextureShaderResourceViews : D3DPostProcessing
  • m_glowTextureWidth : D3DPostProcessing
  • m_Glyph : NotificationsExtensions::BadgeContent::BadgeGlyphNotificationContent
  • m_glyphOrientationMode : TextAnalysis
  • m_gradient : DirectXFractal
  • m_gravity : Physics
  • m_greenBrush : TargetTexture , sealed , BasicSound
  • m_greenProvider : sealed
  • m_ground : GameObject
  • m_groundTriList : Collision
  • m_handler : Hilo::ObserveException< T >
  • m_hasHandlers : Hilo::HiloPage
  • m_haveFocus : DirectXApp , Simple3DGameXaml::sealed
  • m_hDev : CAutoDXDevLockBase< DevManager, DevInterface >
  • m_hDeviceHandle : CInvert
  • m_headerTextFormat : SimpleController
  • m_headingTextFormat : CompositeModes
  • m_heapData : SDKMesh
  • m_height : CDocumentSource , Face , Extruder::ExtrudingSink , FrameProcessing , Program , Shape
  • m_heightInInches : StereoSimpleD3D
  • m_heightVector : Face
  • m_heuristicShortestDistance : AntSystem::Ant
  • m_hFile : SDKMesh
  • m_hFileMappingObject : SDKMesh
  • m_highlightedWords : SDKSample::TextEditing::sealed
  • m_highScoreButton : MarbleMaze
  • m_highScoreTable : MarbleMaze
  • m_hintMessage : StereoSimpleD3D
  • m_hit : GameObject
  • m_hitColor : Material
  • m_hitMaterial : GameObject
  • m_hitSound : GameObject
  • m_hitTime : GameObject
  • m_homeKeyActive : MarbleMaze
  • m_homeKeyPressed : MarbleMaze
  • m_horizontalOffset : CompositeModes
  • m_hr : ContentImageSource::ImageSourceDrawHelper
  • m_Hr : Samples::Devices::Fx2::sealed
  • m_hubViewModelCallback : Hilo::FileSystemRepository
  • m_Id : Samples::Devices::Fx2::sealed
  • m_id : StreamList
  • m_idIncrement : SampleOverlay
  • m_image : Hilo::sealed
  • m_imageableRect : CDocumentSource
  • m_imageBrowserViewModelCallback : Hilo::FileSystemRepository
  • m_imageBrush : CommandListRenderer
  • m_imageFailedEventToken : Hilo::sealed
  • m_imageFileName : SaveAsImageFile
  • m_imageHeightInPixels : CGrayscale , CInvert , CDecoder , CPolarEffect
  • m_imagePixelSize : ImageRenderer
  • m_imageRenderer : PostcardRenderer
  • m_imageRotate : D2DInterpolationModes
  • m_Images : NotificationsExtensions::NotificationBase
  • m_imageSize : D2D3DTransformsRenderer , CompositeModes , ConvolveMatrixEffect , D2DInterpolationModes , LoadScreen , D2DLightingEffectsRenderer
  • m_imageSizeDips : D2DInterpolationModes , ImageRenderer
  • m_imageSource : ContentImageSource
  • m_imageSourceNative : ContentImageSource::ImageSourceDrawHelper , ContentImageSource
  • m_imageText : PrintSample::sealed
  • m_imageViewModelCallback : Hilo::FileSystemRepository
  • m_imageWidthInPixels : CGrayscale , CInvert , CDecoder , CPolarEffect
  • m_imageZoomFactor : ImageRenderer
  • m_impl : TripOptimizerComponent::sealed
  • m_indexBuffer : BumpMapping , DirectXFractal , D3DPostProcessing , ResourceLoading , BasicSprites::SpriteBatch , StereoSimpleD3D , Direct3DTutorial , TextInterop , abstract , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_indexBufferArray : SDKMesh
  • m_indexCount : BumpMapping , DirectXFractal , D3DPostProcessing , ResourceLoading , StereoSimpleD3D , Direct3DTutorial , TextInterop , abstract , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_indices : SDKMesh
  • m_inGameStopwatchTimer : MarbleMaze
  • m_initialized : GameRenderer
  • m_initialNodeIndex : AntSystem::Ant
  • m_initialOpacity : Layer
  • m_initialPS : DirectXFractal
  • m_inkManager : InkRenderer
  • m_inkRenderer : PostcardRenderer
  • m_inkState : InkRenderer
  • m_inlineImage : DWriteInlineObject
  • m_inputImage : D2DEffectsOnPrimitives
  • m_inputLayout : BumpMapping , DirectXFractal , D3DPostProcessing , ResourceLoading , BasicSprites::SpriteBatch , StereoSimpleD3D , Direct3DTutorial , TextInterop , MarbleMaze , ExtrudedTextRenderer , Simple3DTouch , OfferReclaimAPI , DxgiRotation
  • m_inputRect : RippleEffect , WaveEffect
  • m_installedLocation : MediaReader
  • m_installedLocationPath : MediaReader
  • m_instance : UserInterface
  • m_instanceData : BasicSprites::SpriteBatch
  • m_instanceDataBuffer : BasicSprites::SpriteBatch
  • m_intermediateRenderTargetHeight : D3DPostProcessing
  • m_intermediateRenderTargetWidth : D3DPostProcessing
  • m_intermediateTextureRenderTargetView : D3DPostProcessing
  • m_intermediateTextureShaderResourceView : D3DPostProcessing
  • m_intersectsGround : Collision
  • m_inverseView : Camera
  • m_isApp : Simple3DGameXaml::sealed
  • m_isAppActive : Simple3DGameXaml::sealed
  • m_isAppTrial : Simple3DGameXaml::sealed
  • m_isAudioStarted : Audio , StreamEffect
  • m_isAvailableForPurchase : Simple3DGameXaml::sealed
  • m_isControllerConnected : MoveLookController , AudioController , SimpleController
  • m_isFadingOut : TextElement
  • m_isHeadsetConnected : AudioController
  • m_isIncreasedSpacing : DWriteParagraphText
  • m_IsInitialized : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_isInvalidThumbnail : Hilo::sealed
  • m_isJustified : DWriteParagraphText
  • m_IsLaunchedByTap : ProximityCPP::sealed
  • m_IsMFLoaded : SDKSample::WASAPIAudio::sealed
  • m_isOpaque : ContentImageSource
  • m_isPlayingHolder : anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • m_isProductActive : Simple3DGameXaml::sealed
  • m_isRegisteredForPrinting : PrintSample::BasePrintPage
  • m_isSnapped : D2DInterpolationModes , PageRenderer , SaveAsImageFile
  • m_isTrial : Simple3DGameXaml::sealed
  • m_isWindowClosed : D2DInterpolationModes
  • m_isWindowVisible : D2DInterpolationModes
  • m_items : SimpleBlogReader::sealed
  • m_keyName : PersistentState
  • m_labelFormat : sealed
  • m_Lang : NotificationsExtensions::NotificationContentText , NotificationsExtensions::NotificationBase
  • m_lastDistance : LonLatController
  • m_lastEnumTime : AudioController , SimpleController
  • m_lastHeadsetCheckTime : AudioController
  • m_lastPoint : Extruder::ExtrudingSink
  • m_lastTime : BasicTimer
  • m_latitude : LonLatController
  • m_Launch : NotificationsExtensions::ToastContent::ToastNotificationBase
  • m_leading : TextFrame
  • m_left : LonLatController , MoveLookController
  • m_length : AnimateLinePosition , Cylinder
  • m_lengthOfPath : AntSystem::Ant
  • m_level : Simple3DGame
  • m_levelActive : Simple3DGame
  • m_levelBitmap : GameInfoOverlay
  • m_levelBonusTime : Simple3DGame
  • m_levelCount : Simple3DGame
  • m_levelDuration : Simple3DGame
  • m_levelResourcesLoaded : GameRenderer
  • m_levelTimeRemaining : Simple3DGame
  • m_licenseInformation : Simple3DGameXaml::sealed
  • m_licenseState : Simple3DGameXaml::sealed
  • m_lightPositionZ : D2DLightingEffectsRenderer
  • m_lightStrength : MarbleMaze
  • m_linearSampler : DirectXFractal , D3DPostProcessing , BasicSprites::SpriteBatch
  • m_List : SDKSample::CustomDeviceAccess::DeviceList
  • m_listingInformation : Simple3DGameXaml::sealed
  • m_loader : Hilo::sealed , Hilo::WideFiveImageTile
  • m_loading : SDKMesh
  • m_loadingComplete : ResourceLoading
  • m_loadingCount : DirectXApp
  • m_loadScreen : MarbleMaze
  • m_localeName : DWriteVerticalText , TextAnalysis
  • m_localOffsetX : D2D3DTransformsRenderer
  • m_localOffsetY : D2D3DTransformsRenderer
  • m_localOffsetZ : D2D3DTransformsRenderer
  • m_location : Document , FontLoader , BasicReaderWriter
  • m_locationPath : BasicReaderWriter
  • m_Lock : Samples::Devices::Repeater
  • m_locked : CAutoDXDevLockBase< DevManager, DevInterface >
  • m_logoBitmap : SampleOverlay , DWriteCustomTextRenderer , GameHud
  • m_logoSize : SampleOverlay , GameHud
  • m_longitude : LonLatController
  • m_lonLatCommand : LonLatController
  • m_lonLatInUse : LonLatController
  • m_lonLatLastDelta : LonLatController
  • m_lonLatLastPoint : LonLatController
  • m_lonLatLastPoint1 : LonLatController
  • m_lonLatLastPoint2 : LonLatController
  • m_lonLatPointerID : LonLatController
  • m_lonLatPointerID1 : LonLatController
  • m_lonLatPointerID2 : LonLatController
  • m_lookAt : Camera
  • m_lookControlLayout : Simple3DTouch
  • m_lookInUse : MoveLookController
  • m_lookLastDelta : MoveLookController
  • m_lookLastPoint : MoveLookController
  • m_lookMetrics : Simple3DTouch
  • m_lookPointerID : MoveLookController
  • m_Loop : NotificationsExtensions::ToastContent::ToastAudio
  • m_mainPage
: D2D3DTransforms::sealed
, Postcard::sealed
, D2DLightingEffects::sealed
, Simple3DGameXaml::sealed
  • m_marbleConstantBufferData : MarbleMaze
  • m_marbleMesh : MarbleMaze
  • m_margin : List< T > , PageRendererContext
  • m_masteringVoice : XAudio2SoundPlayer , AudioController
  • m_materialArray : SDKMesh
  • m_matrixHeight : D2D3DTransformsRenderer
  • m_matrixTop : D2D3DTransformsRenderer
  • m_matrixValueFormat : D2D3DTransformsRenderer
  • m_matrixWidth : D2D3DTransformsRenderer
  • m_maxBound : Simple3DGame
  • m_maxCollisionSpeed : Physics
  • m_maxRealizationDimension : GeometryRealization , GeometryRealizationFactory
  • m_maxRollingSpeed : Physics
  • m_maxStreamLengthInBytes : MediaStreamer
  • m_maxTitleSize : GameHud
  • m_mazeConstantBufferData : MarbleMaze
  • m_mazeMesh : MarbleMaze
  • m_mediaCaptureMgr
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • m_MediaControlPauseToken : SDKSample::WASAPIAudio::sealed
  • m_MediaControlPlayPauseToken : SDKSample::WASAPIAudio::sealed
  • m_MediaControlPlayToken : SDKSample::WASAPIAudio::sealed
  • m_MediaControlStopToken : SDKSample::WASAPIAudio::sealed
  • m_mesh : GameObject
  • m_meshArray : SDKMesh
  • m_meshColor : Material
  • m_meshHeader : SDKMesh
  • m_messageFormat : PageRenderer , PageRendererContext
  • m_MFSource : SDKSample::WASAPIAudio::WASAPIRenderer
  • m_MFSourceReader : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_minBound : Simple3DGame
  • m_missedFrameHistory : AutoThrottle
  • m_MixFormat
: SDKSample::WASAPIAudio::MFSampleGenerator
, SDKSample::WASAPIAudio::WASAPICapture
, SDKSample::WASAPIAudio::WASAPIRenderer
  • m_modelMatrix : GameObject
  • m_modeTextFormat : D2DInterpolationModes
  • m_modeTextLeft : D2DInterpolationModes
  • m_modeTextRight : D2DInterpolationModes
  • m_monthQueryChange : Hilo::FileSystemRepository
  • m_mouseInUse : MoveLookController
  • m_mouseLastPoint : MoveLookController
  • m_mouseLeftInUse : MoveLookController
  • m_mouseLookInUse : MoveLookController
  • m_mouseLookPointerID : MoveLookController
  • m_mousePointerID : MoveLookController
  • m_mouseRightInUse : MoveLookController
  • m_moveCommand : MoveLookController
  • m_moveControlLayout : Simple3DTouch
  • m_moveFirstDown : MoveLookController
  • m_moveInUse : MoveLookController
  • m_moveLowerRight : MoveLookController
  • m_moveMetrics : Simple3DTouch
  • m_movePointerID : MoveLookController
  • m_movePointerPosition : MoveLookController
  • m_moveUpperLeft : MoveLookController
  • m_movingThrottle : DirectXFractal
  • m_musicEngine : StreamEffect , Audio
  • m_musicEngineCallback : Audio
  • m_musicMasteringVoice : Audio , StreamEffect
  • m_musicReverbVoiceLargeRoom : Audio
  • m_musicReverbVoiceSmallRoom : Audio
  • m_musicSourceVoice : Audio , StreamEffect
  • m_musicStreamer : Audio , StreamEffect
  • m_muxRate : Parser
  • m_name : Element
  • m_navigateBackEventToken : Hilo::HiloPage
  • m_navigateHomeEventToken : Hilo::HiloPage
  • m_navigateToPageEventToken : Hilo::HiloPage
  • m_nearPlane : Camera
  • m_nearZ : StereoSimpleD3D
  • m_needsResourceUpdate : D2DLightingEffectsRenderer
  • m_neighborWindow : FrameProcessing
  • m_neighbourArea : FrameData
  • m_newHighScore : MarbleMaze
  • m_nextId : Level2 , Level4
  • m_nextSibling : Element
  • m_nodes : AntSystem::Ant
  • m_normal : Face
  • m_normalMaterial : GameObject
  • m_normals : BumpMapping
  • m_normalSampler : BumpMapping
  • m_normalSRV : BumpMapping
  • m_Number : NotificationsExtensions::BadgeContent::BadgeNumericNotificationContent
  • m_numberOfSquares : GeometryRealizationSample
  • m_numberSubstitution : TextAnalysis
  • m_numBuffers : abstract
  • m_numIterationsPerFrame : DirectXFractal
  • m_numOutstandingResources : SDKMesh
  • m_numParticlesToDraw : SimpleSprites
  • m_numPointersDown : LonLatController
  • m_numSpritesDrawn : BasicSprites::SpriteBatch
  • m_numVertices : WaveEffect
  • m_objectGeometry : D2DBasicAnimation
  • m_objective : abstract
  • m_objects : Simple3DGame
  • m_offset : ImageFile , Element , LoadScreen
  • m_OnByteStreamRead : CMPEG1Source
  • m_OnProcessQueue : OpQueue< T, TOperation >
  • m_onRenderingEventToken : Simple3DGameXaml::sealed
  • m_op : SourceOp
  • m_opacity : Rectangle , TextFrame
  • m_opacityBitmap : D2DTextAnimation
  • m_OpQueue : OpQueue< T, TOperation >
  • m_orientation : abstract
  • m_orientationChangedEventToken : SDKSample::MediaCapture::sealed
  • m_Oscilliscope : SDKSample::WASAPIAudio::sealed
  • m_OutputStream : SDKSample::WASAPIAudio::WASAPICapture
  • m_overlayWidth : SampleOverlay
  • m_p2DBuffer : VideoBufferLock
  • m_padding : SampleOverlay , TextButton
  • m_pageCollection : PrintSample::sealed
  • m_pageList : PrintSample::sealed
  • m_pageRangeEditVisible : PrintSample::sealed
  • m_pageSize : Design
  • m_paginateCalled : CDocumentSource
  • m_panPosition : ExtrudedTextRenderer
  • m_paperFragmentList : PaperRenderer
  • m_paperMode : PaperRenderer
  • m_paperRenderer : PostcardRenderer
  • m_parent : Element
  • m_pArray : Buffer
  • m_particle : SimpleSprites
  • m_particleData : SimpleSprites
  • m_path : SDKMesh
  • m_pathGeometry : D2DBasicAnimation , Shape
  • m_pathLength : D2DBasicAnimation
  • m_pAttributes : CInvert , CGrayscale , CPolarEffect
  • m_pause : MoveLookController
  • m_paused : GeometryRealizationSample
  • m_pausedText : MarbleMaze
  • m_pausedTime : GeometryRealizationSample , GameTimer
  • m_pauseKeyActive : MarbleMaze
  • m_pauseKeyPressed : MarbleMaze
  • m_pausePressed : MoveLookController
  • m_pauseRequested : Simple3DGameXaml::sealed
  • m_pbData : CDecoder
  • m_pBeginOpenResult : CMPEG1Source
  • m_pBuffer : VideoBufferLock , CDecoder
  • m_pBufferImage : FrameProcessing
  • m_pByteStream : CMPEG1Source
  • m_pCB : MediaEngineNotify
  • m_pContext : CInvert
  • m_pCriticalSection : AutoLock
  • m_pCurrentImage : FrameProcessing
  • m_pCurrentOp : CMPEG1Source
  • m_pDevice : CInvert
  • m_pDX11Manager : CInvert
  • m_peerFinderStarted : ProximityCPP::sealed
  • m_peerInformationList : ProximityCPP::sealed
  • m_persistentState : MarbleMaze
  • m_perspective : D2D3DTransformsRenderer
  • m_pEventQueue : CMPEG1Stream , CMPEG1Source
  • m_pFactory : OutlineRenderer
  • m_pFrame : FrameData
  • m_pFrameProcessor : FrameData
  • m_pGeometry : OutlineRenderer
  • m_phaseCount : FrameData
  • m_pHeader : CMPEG1Source , Parser
  • m_photo : Hilo::ImageBase
  • m_photoCache : Hilo::PhotoCache
  • m_photoScale : PrintSample::sealed
  • m_photoSize : PrintSample::sealed
  • m_photoStorageFile : MediaCapture::BasicCapture , SDKSample::MediaCapture::sealed
  • m_physics : MarbleMaze
  • m_pickFileTask : MEPlayer
  • m_pictureHubGroupQueryChange : Hilo::FileSystemRepository
  • m_pInBufferTex : CInvert
  • m_pIndexLookup : CPolarEffect
  • m_pInputType : CInvert , CDecoder , CPolarEffect , CGrayscale
  • m_pInvokeFn : AsyncCallback< T >
  • m_pitch : MoveLookController , FrameData , FrameProcessing
  • m_pixelShader : OfferReclaimAPI , BumpMapping , D3DPostProcessing , ResourceLoading , BasicSprites::SpriteBatch , Direct3DTutorial , TextInterop , GameRenderer , MarbleMaze , ExtrudedTextRenderer , Simple3DTouch , DxgiRotation , Material , StereoSimpleD3D
  • m_pixelShaderFlat : GameRenderer
  • m_planeNormal : AnimateCirclePosition
  • m_player : Simple3DGame , VideoView
  • m_PlotData : SDKSample::WASAPIAudio::WASAPICapture
  • m_plotDataReadyToken : SDKSample::WASAPIAudio::sealed
  • m_point : Face
  • m_PointArray : SDKSample::WASAPIAudio::sealed
  • m_pointDiffuseEffect : D2DLightingEffectsRenderer
  • m_pointer : Hilo::sealed
  • m_pointerId : InkRenderer
  • m_pointerPressed : Hilo::sealed
  • m_pointQueue : MarbleMaze
  • m_pointSampler : DirectXFractal , D3DPostProcessing
  • m_pointSpecularEffect : D2DLightingEffectsRenderer
  • m_policy : Hilo::ExceptionPolicyFactory
  • m_polygonAbsolute : Shape
  • m_polygonRelative : Shape
  • m_position : FPSCounter , BasicCamera , LonLatController , Camera , Physics , PaperFragment , MoveLookController , GameObject
  • m_possiblePurchaseUpgrade : Simple3DGameXaml::sealed
  • m_pOutBufferStage : CInvert
  • m_pOutBufferTex : CInvert
  • m_pOutputType : CInvert , CDecoder , CPolarEffect , CGrayscale
  • m_pParent : AsyncCallback< T >
  • m_pParser : CMPEG1Source
  • m_pPD : StartOp
  • m_pPixelShader : CInvertModule
  • m_pPresentationDescriptor : CMPEG1Source
  • m_pRadiusTransformFn : CPolarEffect
  • m_preGameCountdownTimer : MarbleMaze
  • m_pressComplete : Simple3DGameXaml::sealed
  • m_pressed : TextButton
  • m_pressResult : DirectXApp , Simple3DGameXaml::sealed
  • m_previousPosition : Physics
  • m_previousTime : GameTimer
  • m_printDocument : PrintSample::BasePrintPage
  • m_printDocumentSource : PrintSample::BasePrintPage
  • m_printManager : DirectXApp
  • m_printPreviewPages : PrintSample::BasePrintPage
  • m_printTaskRequestedEventToken : PrintSample::BasePrintPage
  • m_productId : Simple3DGameXaml::sealed
  • m_profiledWicBitmap : PageRenderer
  • m_program : sealed
  • m_projAspect : StereoSimpleD3D
  • m_projection : BasicCamera , Camera
  • m_projectionMatrix : Camera
  • m_projectionMatrixLeft : Camera
  • m_projectionMatrixRight : Camera
  • m_propertyHeight : D2D3DTransformsRenderer
  • m_propertyTop : D2D3DTransformsRenderer
  • m_propertyValueFormat : D2D3DTransformsRenderer
  • m_propertyWidth : D2D3DTransformsRenderer
  • m_proximityDevice : ProximityCPP::sealed
  • m_pSample : CGrayscale , CInvert , CPolarEffect
  • m_pSampleRequest : CMPEG1Source
  • m_pSampleStateLinear : CInvertModule
  • m_pScreenQuadVB : CInvertModule
  • m_pSinkNoRef : PointSnapper::PointSnappingSink
  • m_pSource : CMPEG1Stream::SourceLock , CMPEG1Stream
  • m_pStreamDescriptor : CMPEG1Stream
  • m_pThetaTransformFn : CPolarEffect
  • m_ptPointerPosition : Shape
  • m_pTransform : CInvert
  • m_pTransformFn : CGrayscale , CPolarEffect
  • m_publishedMessageId : ProximityCPP::sealed
  • m_pVertexShader : CInvertModule
  • m_quadLayout : D3DPostProcessing
  • m_quadVertexBuffer : D3DPostProcessing
  • m_quadVertexShader : D3DPostProcessing
  • m_query : Hilo::sealed
  • m_queryPhotoImageAsyncIsRunning : Hilo::sealed
  • m_radius : LonLatController , AnimateCirclePosition , Sphere , Physics , Cylinder
  • m_rcDest : CGrayscale
  • m_rcTarget : MEPlayer
  • m_ReadBuffer : CMPEG1Source
  • m_reader : MediaStreamer
  • m_ReaderState : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_readingDirection : DWriteVerticalText , TextAnalysis
  • m_realization : GeometryRealizationSample
  • m_realizationTransform : GeometryRealization
  • m_realizationTransformInv : GeometryRealization
  • m_realizationTransformIsIdentity : GeometryRealization
  • m_recenter : CommandListRenderer
  • m_recenterStartPosition : CommandListRenderer
  • m_recenterStartTime : CommandListRenderer
  • m_recenterStartZoom : CommandListRenderer
  • m_recordStorageFile
: MediaCapture::AudioCapture
, MediaCapture::BasicCapture
, SDKSample::MediaCapture::sealed
  • m_rectangleHeight : BasicSound
  • m_rectangleWidth : BasicSound
  • m_redBrush : TargetTexture , sealed
  • m_redProvider : sealed
  • m_ref : GeometryRealization , GeometryRealizationFactory , OutlineRenderer , PointSnapper::PointSnappingSink
  • m_Ref : SDKSample::WASAPIAudio::MFSampleGenerator
  • m_ref : Extruder::ExtrudingSink
  • m_refCount : WaveEffect , ContentImageSource , FontFileStream , ImageFile , FontLoader , RippleEffect
  • m_referenceBitmap : DxgiRotation
  • m_referenceBitmapSource : DxgiRotation
  • m_renderBufferPS : DirectXFractal
  • m_renderDuration : D2DInterpolationModes
  • m_renderer : DirectXApp , D2D3DTransforms::sealed , Document , DirectXApp , CDocumentSource , DirectXApp , Simple3DGameXaml::sealed , DirectXApp , Simple3DGame , Postcard::sealed , DirectXApp , D2DLightingEffects::sealed , DirectXApp
  • m_renderingParams : DWriteVerticalText
  • m_renderNeeded : Simple3DGameXaml::sealed , DirectXApp
  • m_renderObjects : Simple3DGame
  • m_renderTargetInfoCbuffer : BasicSprites::SpriteBatch
  • m_renderTargetSize : abstract , ExtrudedTextRenderer , BasicSprites::SpriteBatch
  • m_renderTargetView : Direct3DTutorialFrameworkView
  • m_renderTexturePS : DirectXFractal
  • m_renderTimeFormat : D2DInterpolationModes
  • m_renderTimer : D2DInterpolationModes
  • m_RepeaterStoppedFunction : Samples::Devices::Repeater
  • m_repository : Hilo::sealed
  • m_repulsors : SimpleSprites
  • m_requestCount : PrintSample::sealed
  • m_requestingPeer : ProximityCPP::sealed
  • m_Requests : CMPEG1Stream
  • m_RequireSquareContent : NotificationsExtensions::TileContent::TileWideBase
  • m_resetCamera : MarbleMaze
  • m_resetMarbleRotation : MarbleMaze
  • m_resultsText : MarbleMaze
  • m_reverbParametersLarge : Audio
  • m_reverbParametersSmall : Audio
  • m_right : LonLatController , MoveLookController
  • m_rootElement : Document
  • m_rootPage : PrintSample::BasePrintPage , ProximityCPP::sealed
  • m_rootXml : Document
  • m_rotationAngle : D2DPerspectiveTransform
  • m_rotationKeyDown : DirectXApp
  • m_rotationMatrix : Face , AnimateCirclePosition , Cylinder
  • m_rotationTransform2D : abstract
  • m_rotationTransform3D : abstract
  • m_rotationX : D2D3DTransformsRenderer
  • m_rotationY : D2D3DTransformsRenderer
  • m_rotationZ : D2D3DTransformsRenderer
  • m_route : AntSystem::Ant
  • m_rt : CStreamState
  • m_rtFrame : CDecoder
  • m_rtLength : CDecoder
  • m_runs : TextAnalysis
  • m_sampleMode : PostcardRenderer
  • m_sampleName : SampleOverlay
  • m_sampleOverlay : DWriteHelloWorld , sealed , CoreWindowEvents , DWriteInlineObject , ConvolveMatrixEffect , ResourceLoading , SaveAsImageFile , GeometryRealizationSample , DWriteParagraphText , DWriteCustomTextRenderer , CompositeModes , D2DEffectsHelloWorld , CommandListRenderer , D2DEffectsOnPrimitives , PageRenderer , BumpMapping , D3DPostProcessing , Direct3DTutorial , TextInterop , DWriteHitTesting , MarbleMaze , Simple3DTouch , DxgiRotation , AudioController , SimpleController , D2DTextAnimation , D2DBasicAnimation , D2DInterpolationModes , D2DPerspectiveTransform , DirectXFractal , SimpleSprites , StereoSimpleD3D , DWriteVerticalText , OfferReclaimAPI , BasicSound , StreamEffect
  • m_SampleQueue : SDKSample::WASAPIAudio::ToneSampleGenerator , SDKSample::WASAPIAudio::MFSampleGenerator
  • m_SampleQueueTail : SDKSample::WASAPIAudio::ToneSampleGenerator , SDKSample::WASAPIAudio::MFSampleGenerator
  • m_sampler : Simple3DTouch , StereoSimpleD3D , ResourceLoading , Direct3DTutorial , MarbleMaze , DxgiRotation , BumpMapping , D3DPostProcessing , TextInterop , OfferReclaimAPI
  • m_SampleReadyAsyncResult : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_SampleReadyEvent : SDKSample::WASAPIAudio::WASAPICapture , SDKSample::WASAPIAudio::WASAPIRenderer
  • m_SampleReadyKey : SDKSample::WASAPIAudio::WASAPIRenderer , SDKSample::WASAPIAudio::WASAPICapture
  • m_samplerLinear : GameRenderer
  • m_Samples : CMPEG1Stream
  • m_saturationEffect : ImageRenderer
  • m_savedState : Simple3DGame
  • m_scale : Shape
  • m_scaleEffect : CompositeModes
  • m_scaleX : D2D3DTransformsRenderer
  • m_scaleY : D2D3DTransformsRenderer
  • m_SCR : Parser
  • m_screenSavingState : SaveAsImageFile
  • m_secondsPerCount : GameTimer
  • m_secondsRemaining : CountdownTimer
  • m_segment : AnimateLineListPosition
  • m_selected : TextButton
  • m_selectedEffect : D2DInterpolationModes
  • m_selectedFragment : PaperRenderer
  • m_selectedKernel : ConvolveMatrixEffect
  • m_selectionMode : PrintSample::sealed
  • m_settingsValues : PersistentState
  • m_shadowColorBrush : TextElement
  • m_shapes : Program
  • m_showTitle : GameHud
  • m_singlePassPS : DirectXFractal
  • m_Size : SDKSample::WASAPIAudio::sealed
  • m_size : FrameProcessing
  • m_Size : CAsyncState
  • m_size : Element , ElementBase , FrameData
  • m_sizeChangedAttached : Hilo::sealed
  • m_sizeX : WaveEffect
  • m_sizeY : WaveEffect
  • m_skewX : WaveEffect
  • m_skewY : WaveEffect
  • m_snappedViewFormat : D2D3DTransformsRenderer , SaveAsImageFile , CompositeModes
  • m_socket : ProximityCPP::sealed
  • m_socketClosed : ProximityCPP::sealed
  • m_solidColorBrush : GeometryRealizationSample
  • m_soundData : SoundEffect , SoundFileReader
  • m_soundEffectBuffer : AudioController
  • m_soundEffectBufferData : SoundEffectData
  • m_soundEffectBufferLength : SoundEffectData
  • m_soundEffectEngine : Audio
  • m_soundEffectEngineCallback : Audio
  • m_soundEffectMasteringVoice : Audio
  • m_soundEffectReverbVoiceLargeRoom : Audio
  • m_soundEffectReverbVoiceSmallRoom : Audio
  • m_soundEffects : Audio
  • m_soundEffectSampleRate : SoundEffectData
  • m_soundEffectSourceVoice : SoundEffectData
  • m_soundEffectStarted : SoundEffectData
  • m_soundEventType : SoundEffectData
  • m_soundFormat : SoundFileReader
  • m_soundLevelHandler : MediaCapture::BasicCapture , MediaCapture::AudioCapture
  • m_soundList : XAudio2SoundPlayer
  • m_soundPlayer : BasicSound
  • m_sourceImage : ImageFrame
  • m_sourceName : TextFrame , ImageFrame
  • m_sourceText : TextFrame
  • m_sourceVoice : AudioController , SoundEffect
  • m_spCapture : SDKSample::WASAPIAudio::sealed
  • m_spDevManager : CAutoDXDevLockBase< DevManager, DevInterface >
  • m_spDX11Device : MEPlayer
  • m_spDX11DeviceContext : MEPlayer
  • m_spDX11SwapChain : MEPlayer
  • m_spDXGIManager : MEPlayer
  • m_spDXGIOutput : MEPlayer
  • m_specularColor : Material
  • m_specularExponent : Material
  • m_spEngineEx : MEPlayer
  • m_sphereTexture : GameRenderer
  • m_spImpl : Wrapper::sealed
  • m_spMediaEngine : MEPlayer
  • m_spotDiffuseEffect : D2DLightingEffectsRenderer
  • m_spotSpecularEffect : D2DLightingEffectsRenderer
  • m_spOutputAttributes : CInvert
  • m_spOutputSampleAllocator : CInvert
  • m_spQuadLayout : CInvertModule
  • m_spRenderer : SDKSample::WASAPIAudio::sealed
  • m_spriteBatch : SimpleSprites
  • m_spriteRuns : BasicSprites::SpriteBatch
  • m_spritesInRun : BasicSprites::SpriteBatch
  • m_SquareContent : NotificationsExtensions::TileContent::TileWideBase
  • m_Src : NotificationsExtensions::NotificationContentImage
  • m_starStampGeometry : PaperRenderer
  • m_Start : Animation< T >
  • m_startGameButton : MarbleMaze
  • m_startHeight : FrameData
  • m_startPeerFinderImmediately : ProximityCPP::sealed
  • m_startPoint : Extruder::ExtrudingSink
  • m_startPosition : AnimateCirclePosition , AnimateLinePosition
  • m_StartTaskFunction : Samples::Devices::Repeater
  • m_startTime : BasicTimer , abstract
  • m_startWidth : FrameData
  • m_State : Samples::Devices::Fx2::sealed , Samples::Devices::Repeater
  • m_state : CMPEG1Stream , MoveLookController , CMPEG1Source
  • m_stateBlock : LoadScreen , SampleOverlay , UserInterface
  • m_StateChangedEvent : SDKSample::WASAPIAudio::sealed
  • m_staticMeshData : SDKMesh
  • m_staticText : FPSCounter
  • m_status : Simple3DGameXaml::sealed
  • m_stepPS : DirectXFractal
  • m_stereoEnabled : abstract
  • m_stereoExaggerationFactor : StereoSimpleD3D
  • m_stopTime : GameTimer
  • m_streams : StreamList , CMPEG1Source
  • m_StreamState : CDecoder
  • m_StrictValidation : NotificationsExtensions::NotificationBase
  • m_string : D2DEffectsOnPrimitives
  • m_strokeMaskDestBounds : GeometryRealization
  • m_strokeMaskSourceBounds : GeometryRealization
  • m_strokeMesh : GeometryRealization
  • m_strokeRT : GeometryRealization
  • m_strokes : InkRenderer
  • m_strokeStyle : GeometryRealization
  • m_strokeWidth : GeometryRealization
  • m_subscribedMessageId : ProximityCPP::sealed
  • m_subsetArray : SDKMesh
  • m_swapChain : abstract , Direct3DTutorialFrameworkView
  • m_swapChainPanel : PostcardRenderer , abstract
  • m_Switches : Samples::Devices::Fx2::sealed
  • m_SwitchState : Samples::Devices::Fx2::sealed
  • m_SwitchStateChangedEvent : Samples::Devices::Fx2::sealed
  • m_swRT : GeometryRealization
  • m_symbolFormat : D2D3DTransformsRenderer
  • m_target : GameObject
  • m_targetBox : PageRendererContext
  • m_targetFrameTime : AutoThrottle
  • m_targetId : GameObject
  • m_targetLightStrength : MarbleMaze
  • m_tcs : MEPlayer
  • m_technique : BasicSprites::SpriteBatch , DirectXFractal
  • m_TemplateName : NotificationsExtensions::NotificationBase
  • m_tempRTV : DirectXFractal
  • m_tempSRV : DirectXFractal
  • m_tempUAV : DirectXFractal
  • m_text : DWriteVerticalText
  • m_Text : NotificationsExtensions::NotificationContentText
  • m_text : DWriteHitTesting , TextElement , TextAnalysis
  • m_textAlign : TextFrame
  • m_textAlignment : TextStyle
  • m_textAtlasBitmap : FPSCounter
  • m_textBrush : AudioController , BasicSound , SimpleController , FPSCounter , GameHud , Simple3DTouch , DxgiRotation , GameInfoOverlay , StreamEffect
  • m_textBrushGrey : GameHud
  • m_textColorBrush : TextElement
  • m_textExtents : TextElement
  • m_TextFields : NotificationsExtensions::NotificationBase
  • m_textFormat : Simple3DTouch , StereoSimpleD3D , PageRenderer , DWriteCustomTextRenderer , GeometryRealizationSample , FPSCounter , SaveAsImageFile , D2DEffectsOnPrimitives , DWriteParagraphText , DWriteInlineObject , DWriteVerticalText , TextStyle , DWriteHelloWorld , DxgiRotation , D2DTextAnimation , TargetTexture , PageRendererContext , D2DBasicAnimation , CompositeModes , DWriteHitTesting
  • m_textFormatBody : GameInfoOverlay , GameHud
  • m_textFormatBodySymbol : GameHud
  • m_textFormatTitle : GameInfoOverlay
  • m_textFormatTitleBody : GameHud
  • m_textFormatTitleHeader : GameHud
  • m_textFormatTitleLicense : GameHud
  • m_textGeometry : ExtrudedTextRenderer
  • m_textLayout : DWriteVerticalText , TextElement , DxgiRotation , ExtrudedTextRenderer , Text , DWriteInlineObject , DWriteHitTesting , DWriteCustomTextRenderer , SampleOverlay , DWriteHelloWorld , D2DTextAnimation
  • m_textLayout1 : DWriteParagraphText
  • m_textLength : DWriteVerticalText , TextAnalysis , Text
  • m_textMetrics : D2DTextAnimation
  • m_textPosition : Text
  • m_textRange : DWriteParagraphText
  • m_textRenderer : DWriteCustomTextRenderer
  • m_textStyle : TextElement
  • m_textTypography : DWriteParagraphText , DWriteVerticalText , DWriteHitTesting , DWriteHelloWorld , DWriteCustomTextRenderer , DWriteInlineObject
  • m_texture : Simple3DTouch , Direct3DTutorial , OfferReclaimAPI , TextInterop , D3DPostProcessing , BumpMapping , DxgiRotation
  • m_textureMap : BasicSprites::SpriteBatch
  • m_textureRV : Material
  • m_textureShaderResourceView : TextInterop , D3DPostProcessing , StereoSimpleD3D
  • m_textureSRV : BumpMapping , DxgiRotation , OfferReclaimAPI , Simple3DTouch , Direct3DTutorial , ResourceLoading
  • m_textVerticalOffset : SampleOverlay
  • m_thumbnailUpdatedEventToken : Hilo::sealed
  • m_tileUpdateScheduler : Hilo::sealed
  • m_timeDelta : GeometryRealizationSample
  • m_timeLimit : abstract
  • m_timer : Simple3DGame
  • m_TimerThreadHandle : MEPlayer
  • m_times : FPSCounter
  • m_title : Simple3DGameXaml::sealed
  • m_titleBody : GameHud
  • m_titleBodyLayout : GameHud
  • m_titleBodyVerticalOffset : GameHud
  • m_titleFormat : sealed
  • m_titleHeader : GameHud
  • m_titleHeaderLayout : GameHud
  • m_titleLicenseInfo : GameHud
  • m_titleLicenseInfoLayout : GameHud
  • m_titleLicenseVerticalOffset : GameHud
  • m_token : FrameProcessing
  • m_ToneSource : SDKSample::WASAPIAudio::WASAPIRenderer
  • m_topLeftX : Shape
  • m_topLeftY : Shape
  • m_topMargin : TextFrame
  • m_topScore : Simple3DGame
  • m_total : BasicTimer
  • m_totalHits : Simple3DGame
  • m_totalLength : AnimateLineListPosition
  • m_totalPages : CDocumentSource , PrintSample::sealed
  • m_totalShots : Simple3DGame
  • m_totalSize : LoadScreen
  • m_totalZoom : D2DInterpolationModes
  • m_touches : MarbleMaze
  • m_transform : CGrayscale , DirectXFractal
  • m_transformedFrameMatrices : SDKMesh
  • m_triggeredConnectSupported : ProximityCPP::sealed
  • m_triggerToken : ProximityCPP::sealed
  • m_type : PageRendererContext
  • m_uBit : DirectX::D3DX_BC6H::ModeDescriptor
  • m_uBits : DirectX::CBits< SizeInBytes >
  • m_uiHeight : CInvertModule
  • m_uiSettings : sealed
  • m_uiWidth : CInvertModule
  • m_underlineArray : DWriteHitTesting
  • m_up : MoveLookController , LonLatController , Camera
  • m_updateDisplayText : GeometryRealizationSample
  • m_updateRealization : GeometryRealizationSample
  • m_updateState : DirectXApp , Simple3DGameXaml::sealed
  • m_updateStateNext : DirectXApp , Simple3DGameXaml::sealed
  • m_useDoubles : DirectXFractal
  • m_useRealizations : GeometryRealizationSample
  • m_useUnormTextures : DirectXFractal
  • m_value : sealed
  • m_velDueToAccel : Physics
  • m_velocity : Physics , MoveLookController , GameObject
  • m_vertexBuffer : DirectXFractal , BumpMapping , DxgiRotation , Direct3DTutorial , ResourceLoading , abstract , WaveEffect , Simple3DTouch , OfferReclaimAPI , BasicSprites::SpriteBatch , D3DPostProcessing , StereoSimpleD3D , TextInterop , ExtrudedTextRenderer
  • m_vertexBufferArray : SDKMesh
  • m_vertexCount : abstract
  • m_vertexData : BasicSprites::SpriteBatch
  • m_vertexLayout : GameRenderer
  • m_vertexShader : ExtrudedTextRenderer , OfferReclaimAPI , MarbleMaze , DxgiRotation , BasicSprites::SpriteBatch , TextInterop , DirectXFractal , Simple3DTouch , BumpMapping , GameRenderer , Material , ResourceLoading , StereoSimpleD3D , Direct3DTutorial , D3DPostProcessing
  • m_vertexShaderFlat : GameRenderer
  • m_vertexStride : MarbleMaze
  • m_vertices : SDKMesh , Extruder::ExtrudingSink
  • m_view : BasicCamera , Camera
  • m_viewMatrix : Camera
  • m_viewModel : Hilo::sealed
  • m_viewPosition : D2DInterpolationModes , D2DTextAnimation , CommandListRenderer
  • m_viewState : MarbleMaze
  • m_visbilityHandler : SDKSample::MediaCapture::sealed
  • m_visibilityEventRegistrationToken : SimpleCommunication::sealed
  • m_visible : GameInfoOverlay , ElementBase , DirectXApp , Simple3DGameXaml::sealed
  • m_voiceContext : Audio
  • m_wallDistances : Physics
  • m_wallsTexture : GameRenderer
  • m_wallTriList : Collision
  • m_WatcherStarted : SDKSample::CustomDeviceAccess::DeviceList
  • m_WatcherSuspended : CustomDeviceAccess::DeviceList , SDKSample::CustomDeviceAccess::DeviceList
  • m_watchToken : Hilo::sealed
  • m_WAVDataWriter : SDKSample::WASAPIAudio::WASAPICapture
  • m_waveFormat : MediaReader , MediaStreamer
  • m_waveOffset : WaveEffect
  • m_weakPhotoGroup : Hilo::sealed
  • m_whiteBrush : D2D3DTransformsRenderer , SampleOverlay , sealed , D2DBasicAnimation , D2DEffectsOnPrimitives , CompositeModes , BasicSound , TargetTexture , D2DInterpolationModes
  • m_wicBitmapDecoder : DWriteCustomTextRenderer
  • m_wicBitmapFrame : DWriteCustomTextRenderer
  • m_wicColorContext : PageRenderer
  • m_wicConvertedSource : PageRenderer , ConvolveMatrixEffect
  • m_wicConverter : D2DLightingEffectsRenderer
  • m_wicDecoder : D2DEffectsHelloWorld
  • m_wicFactory : BasicLoader , ImageRenderer , UserInterface , LoadScreen , GameHud , Renderer , abstract , SampleOverlay
  • m_wicFormatConverter : D2DEffectsHelloWorld , DWriteCustomTextRenderer , D2D3DTransformsRenderer
  • m_wicFrameDecode : D2DEffectsHelloWorld
  • m_width : CDocumentSource , Shape , Face , FrameProcessing , Program
  • m_widthInInches : StereoSimpleD3D
  • m_widthVector : Face
  • m_window : Direct3DTutorialFrameworkView , CAppWindowProvider , MEPlayer , sealed , Program , VideoView , abstract
  • m_windowActive : MarbleMaze
  • m_windowBounds : abstract , Renderer
  • m_windowClosed : GeometryRealizationSample , DirectXApp , D2DBasicAnimation , CommandListRenderer
  • m_windowSizeChangeInProgress : abstract
  • m_windowState : D2D3DTransformsRenderer , D2DLightingEffectsRenderer , PostcardRenderer
  • m_windowTextBrush : sealed
  • m_windowVisible : D2DBasicAnimation , CommandListRenderer , DirectXApp , GeometryRealizationSample
  • m_worldPoseFrameMatrices : SDKMesh
  • m_worldScale : StereoSimpleD3D
  • m_xinputCaps : AudioController , SimpleController , MoveLookController
  • m_xinputStartButtonInUse : MoveLookController
  • m_xinputState : SimpleController , AudioController , MoveLookController
  • m_xinputTriggerInUse : MoveLookController
  • m_yaw : MoveLookController
  • m_yellowBrush : sealed , TargetTexture
  • m_yellowProvider : sealed
  • m_zoom : ExtrudedTextRenderer , CommandListRenderer , D2DTextAnimation
  • map : TextureLock
  • marblePosition : ConstantBuffer
  • marbleRadius : ConstantBuffer
  • Margin : PrintSample::PageDescription
  • Matched : CustomDeviceAccess::DeviceListEntry
  • MaterialDataOffset : SDKMESH_HEADER
  • MaterialID : SDKMESH_SUBSET
  • MaterialInstancePath : SDKMESH_MATERIAL
  • Matrix : SDKMESH_FRAME
  • matrix : WaveEffect
  • maxCollisionSpeed : CollisionInfo
  • MaxCount : sealed
  • maxRollingSpeed : CollisionInfo
  • mediaCapture : SimpleCommunication::Common::CaptureDevice
  • mediaCaptureMgr : SDKSample::CameraOptions::sealed
  • mediaElement : SDKSample::Accessibility::sealed
  • mediaExtensionMgr : SDKTemplate::MainPage
  • mediaFile : SDKSample::MediaServerClient::sealed
  • mediaFiles : SDKSample::MediaServerClient::sealed
  • mediaServers : SDKSample::MediaServerClient::sealed
  • mediaSink : SimpleCommunication::Common::CaptureDevice
  • mediaStream : SDKSample::MediaServerClient::sealed
  • Mesh : SDKMESH_FRAME
  • meshColor : ConstantBufferChangesEveryPrim
  • MeshDataOffset : SDKMESH_HEADER
  • meshID : Contact
  • message : SimpleCommunication::CaptureFailedEventArgs
  • messageData : SDKSample::PersonalityAnimations::sealed
  • messageWebSocket : SDKSample::WebSocket::sealed
  • messageWriter : SDKSample::WebSocket::sealed
  • Method : _SDKMESHVERTEXELEMENT
  • MFVideoFormat_MPG1 : MediaExtensionsCS::ScenarioInput1
  • MinReadChunkSize : ReadStreamTask
  • mipLevels : DirectX::TexMetadata
  • mipMapCount : DDS_HEADER
  • miscFlag : DirectX::DDS_HEADER_DXT10 , DDS_HEADER_DXT10
  • miscFlags : DirectX::TexMetadata
  • MobilePhone : ContactPicker::sealed::SampleContact
  • mode : MPEG1AudioFrameHeader , SimpleCommunication::LowLatency
  • modeExtension : MPEG1AudioFrameHeader
  • model : ConstantBuffer
  • month : Hilo::sealed
  • MovePaperClicked : Postcard::sealed
  • mruToken : SDKSample::MainPage
  • ms_aDesc : DirectX::D3DX_BC6H
  • ms_aInfo : DirectX::D3DX_BC7 , DirectX::D3DX_BC6H
  • ms_aModeToInfo : DirectX::D3DX_BC6H
  • Music : SDKSample::FileExtensions
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- n -

  • Name : ContactPicker::sealed::SampleContact , SDKMESH_MESH , SDKMESH_FRAME , SDKMESH_MATERIAL , SDKMESH_SUBSET
  • Names : AntSystem::Node
  • NavigateBack : Hilo::ViewModelBase
  • NavigateHome : Hilo::ViewModelBase
  • NavigateToPage : Hilo::ViewModelBase
  • nBlockAlign : MPEG1AudioFrameHeader
  • nChannels : MPEG1AudioFrameHeader
  • needToPrintClipboardFormat : Clipboard::sealed
  • networkCostType : SDKSample::ProvisioningAgent::sealed
  • networkInfo : SDKSample::NetworkInformationApi::sealed
  • networkStatusCallback : SDKSample::NetworkInformationApi::sealed
  • next : ShapeRecord , List< T >::Node
  • Next : RenderBuffer
  • nextRunIndex : TextAnalysis::LinkedRun
  • nextTimestamp : MediaStreamSource::PcmSource
  • NoAlbumArt : SDKSample::Errors
  • Nodes : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • NoExifThumbnail : SDKSample::Errors
  • NoIcon : SDKSample::Errors
  • NoImages : SDKSample::Errors
  • NonBufferDataSize : SDKMESH_HEADER
  • nonParentPopup : SDKSample::XAMLPopup::sealed
  • Norm : SimpleVertex
  • norm : BasicVertex , IndexTriplet , Extruder::ExtrudingSink::Vertex2D
  • normal : PNTVertex
  • NormalRV : SDKMESH_MATERIAL
  • NormalTexture : SDKMESH_MATERIAL
  • NormalTextureName : SDKMESH_MATERIAL
  • NoThumbnail : SDKSample::Errors
  • notifier : SDKSample::MainPage
  • NumAnimationKeys : SDKANIMATION_FILE_HEADER
  • number : MPEG1StreamHeader , MPEG1PacketHeader
  • NumberOfPhotos : PrintSample::sealed
  • NumFrameInfluences : SDKMESH_MESH
  • NumFrames : SDKANIMATION_FILE_HEADER , SDKMESH_HEADER
  • NumIndexBuffers : SDKMESH_HEADER
  • NumIndices : SDKMESH_INDEX_BUFFER_HEADER
  • NumMaterials : SDKMESH_HEADER
  • NumMeshes : SDKMESH_HEADER
  • numPoints : Polygon
  • numSprites : BasicSprites::SpriteRunInfo
  • NumSubsets : SDKMESH_MESH
  • NumTotalSubsets : SDKMESH_HEADER
  • NumVertexBuffers : SDKMESH_MESH , SDKMESH_HEADER
  • NumVertices : SDKMESH_VERTEX_BUFFER_HEADER
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- o -

  • offset : BasicSprites::InstanceData
  • Offset : _SDKMESHVERTEXELEMENT
  • Optimize : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • Orange : sealed
  • Orientation : SDKANIMATION_DATA
  • orientationChangedEventToken : SDKSample::DisplayOrientation::sealed
  • orientationToken : SDKSample::SimpleOrientationSensorCPP::sealed
  • origin : BasicSprites::InstanceData
  • originalData : ScenarioContext
  • originDtid00 : ComputeCB , ComputeDoubleCB
  • originOffset : FPSCounter::AtlasText
  • outlineBrush : CustomTextRenderer
  • outputStream : DatagramSocketSample::sealed
  • OutputStream : sealed
  • outputText : EdgeGestureSample::sealed , ToastsSampleCPP::sealed
  • outputVideo
: MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput1
, MediaExtensionsCPP::sealed
, MediaExtensionsCS::ScenarioInput4
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCS::ScenarioInput2
  • outputVideoStabilized : MediaExtensionsCPP::sealed , MediaExtensionsCS::ScenarioInput3
  • override : Resource , Story , PageRoll
  • overrideFontFamily : SDKSample::Scaling::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- z -

  • z : Vector3< T > , Vector4< T >
  • ZipCode : ContactPicker::sealed::SampleContact
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- a -

  • a : Vector4< T > , DirectX::LDRColorA
  • A : DirectX::LDREndPntPair , DirectX::HDREndPntPair
  • a : DirectX::HDRColorA
  • A : DirectX::INTEndPntPair , Triangle
  • ABitMask : DDS_PIXELFORMAT
  • accClass : SDKSample::TouchKeyboard::sealed
  • accelerometer : SDKSample::AccelerometerCPP::sealed , SDKSample::DisplayOrientation::sealed
  • accessTicket : SDKSample::MicrosoftAccount::sealed
  • actionTransitionFunctions : SimpleCommunication::sealed
  • activated : SimpleCommunication::VideoChat
  • activeDownloads : SDKSample::BackgroundTransfer::sealed
  • AddPaperClicked : Postcard::sealed
  • Address : ContactPicker::sealed::SampleContact
  • advanceWidth : FPSCounter::AtlasText
  • aEndPts : DirectX::D3DX_BC7::EncodeParams
  • aHDRPixels : DirectX::D3DX_BC6H::EncodeParams , DirectX::D3DX_BC7::EncodeParams
  • aIPixels : DirectX::D3DX_BC6H::EncodeParams
  • aLDRPixels : DirectX::D3DX_BC7::EncodeParams
  • Alpha : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • alpha : DirectX::D3DX_BC3
  • Ambient : SDKMESH_MATERIAL
  • amplitude : RippleEffect
  • AnimationData : SDKANIMATION_FRAME_DATA
  • AnimationDataIndex : SDKMESH_FRAME
  • AnimationDataOffset : SDKANIMATION_FILE_HEADER
  • AnimationDataSize : SDKANIMATION_FILE_HEADER
  • AnimationFPS : SDKANIMATION_FILE_HEADER
  • appBar : SecondaryTiles::sealed
  • appBarOpenedToken : SecondaryTiles::sealed
  • appData : SDKSample::ApplicationDataSample::sealed
  • applicationData : SDKSample::ApplicationDataSample::sealed
  • appSettings : SDKSample::CameraCapture::sealed
  • args : LonLatController , MoveLookController
  • arraySize : DDS_HEADER_DXT10 , DirectX::DDS_HEADER_DXT10 , DirectX::TexMetadata
  • aspectRatio : SimpleCommunication::sealed::StreamFilteringCriteria
  • atlasRect : FPSCounter::AtlasText
  • AUDIO_FILE_NAME : MediaCapture::AudioCapture
  • audioExtensionsInner : SDKSample::MainPage
  • aUnqEndPts : DirectX::D3DX_BC6H::EncodeParams
  • authenticator : SDKSample::MicrosoftAccount::sealed
  • autoFire : GameConfig
  • automationId : SDKSample::Accessibility::sealed
  • automationName : SDKSample::Accessibility::sealed
  • autoplayFileSystemDeviceFolder : SDKSample::MainPage
  • autoplayNonFileSystemDeviceId : SDKSample::MainPage
  • autoplayScenarioIndex : SDKSample::MainPage
  • autoSizeInputSectionWhenSnapped
: AccountPictureName::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
, Clipboard::sealed
, AppBarControl::sealed
, StreamSocketSample::sealed
, SDKSample::sealed
, SecondaryTiles::sealed
  • AutoSizeInputSectionWhenSnapped : SDKTemplate::MainPage
  • autoSizeInputSectionWhenSnapped
: ContactPicker::sealed
, DatagramSocketSample::sealed
, SDKSample::FilePickerContracts::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- b -

  • b : Vector3< T > , Vector4< T > , DirectX::HDRColorA
  • B : DirectX::HDREndPntPair , DirectX::INTEndPntPair
  • b : DirectX::INTColor
  • B : Triangle
  • b : DirectX::LDRColorA , AmpPixel
  • B : DirectX::LDREndPntPair
  • backgroundAvailable : GameConfig
  • Bar1 : _BAR_GRAPH_STATE
  • Bar2 : _BAR_GRAPH_STATE
  • Bar3 : _BAR_GRAPH_STATE
  • Bar4 : _BAR_GRAPH_STATE
  • Bar5 : _BAR_GRAPH_STATE
  • Bar6 : _BAR_GRAPH_STATE
  • Bar7 : _BAR_GRAPH_STATE
  • Bar8 : _BAR_GRAPH_STATE
  • BarsAsUChar : _BAR_GRAPH_STATE
  • baseline : InlineImage
  • bAttributesType : TGA_EXTENSION
  • bAudioLock : MPEG1SystemHeader
  • BBitMask : DDS_PIXELFORMAT
  • bBitsPerPixel : TGA_HEADER
  • bc1 : DirectX::D3DX_BC2 , DirectX::D3DX_BC3
  • bColorMapSize : TGA_HEADER
  • bColorMapType : TGA_HEADER
  • bConstrained : MPEG1VideoSeqHeader
  • bCSPS : MPEG1SystemHeader
  • bDescriptor : TGA_HEADER
  • Beta : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • bFixed : MPEG1SystemHeader
  • bHasPTS : MPEG1PacketHeader
  • bHorizontal : SDKSample::FlipViewCPP::sealed
  • bidiLevel : TextAnalysis::Run
  • bIDLength : TGA_HEADER
  • bImageType : TGA_HEADER
  • BingMapsKey : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • bitmap : DirectX::D3DX_BC1 , DirectX::D3DX_BC2 , InlineImage , DirectX::D3DX_BC3
  • bitRate : MPEG1VideoSeqHeader
  • BitsPerSample : MediaStreamSource::PcmSource
  • blendState : BasicSprites::SpriteRunInfo
  • Blue : sealed
  • BoundingBoxCenter : SDKMESH_MESH
  • BoundingBoxExtents : SDKMESH_MESH
  • bounds : FractalVertex
  • boundsTransform : DrawRectCB
  • bSigned : DirectX::D3DX_BC6H::EncodeParams
  • bTransformed : DirectX::D3DX_BC6H::ModeInfo
  • Buffer : Samples::Devices::Fx2::sealed , RenderBuffer
  • BufferDataSize : SDKMESH_HEADER
  • bufferedPlaybackRate : SDKSample::PlayToreceiver::sealed
  • buffersCallback : Web::HttpRequest
  • BufferSize : RenderBuffer
  • buttonClickToken : SecondaryTiles::sealed
  • bValid : CStreamState
  • bVersionLetter : TGA_EXTENSION
  • bVideoLock : MPEG1SystemHeader
  • BytesFilled : RenderBuffer
  • bytesPerRow : SDKSample::DataReaderWriter::sealed
  • bytesPerSegment : SDKSample::DataReaderWriter::sealed
  • bytesReceived : SDKSample::WebSocket::sealed
  • BytesTransferred : Samples::Devices::DeviceControlResult
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- c -

  • C : Triangle
  • cachedFileUpdaterUI : SDKSample::FilePickerContracts::sealed
  • callback : Hilo::sealed
  • callbackHander : XAudio2SoundPlayer::ImplData
  • CallControls : SDKSample::CallControl::sealed
  • CallToken : SDKSample::CallControl::sealed
  • CameraFound : SDKTemplate::MainPage
  • Cancel : SDKSample::Errors
  • CancelContext : Samples::Devices::Fx2::sealed
  • cancellationToken : SDKSample::BackgroundTransfer::sealed , HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • cancellationTokenSource : SDKSample::HttpClientSample::sealed , SDKSample::MicrosoftAccount::sealed
  • CancelRequested : Tasks::sealed
  • CanExecuteChanged : Hilo::sealed
  • caps : DDS_HEADER
  • caps2 : DDS_HEADER
  • caps3 : DDS_HEADER
  • caps4 : DDS_HEADER
  • cAudioBound : MPEG1SystemHeader
  • cbHeader : MPEG1VideoSeqHeader
  • cbPacketSize : MPEG1PacketHeader
  • cbPayload : MPEG1PacketHeader
  • cbSize : MPEG1SystemHeader
  • cbVBV_Buffer : MPEG1VideoSeqHeader
  • center : RippleEffect , Sphere
  • certificateRequest : SDKSample::CertificateEnrollment::sealed
  • channel : SDKSample::MainPage
  • Channels : MediaStreamSource::PcmSource
  • ChildFrame : SDKMESH_FRAME
  • chunkSize : SDKSample::DataReaderWriter::sealed
  • City : ContactPicker::sealed::SampleContact
  • ClassName
: SDKSample::Scenario
, AccountPictureName::Scenario
, Clipboard::Scenario
, ContactPicker::Scenario
, DatagramSocketSample::Scenario
, DeviceAppForPrinters::Scenario
, SDKSample::Scenario
, ProximityCPP::Scenario
, SimpleCommunication::Scenario
, StreamSocketSample::Scenario
, AppBarControl::Scenario
  • className : SecondaryTiles::Scenario
  • clockwise : AnimateCirclePosition
  • closingVelocity : Contact
  • color : BasicSprites::ReplicationVertex , BasicSprites::InstanceData , SimpleCubeVertex , PaperFragment
  • ColorSpaceProperty : SDKSample::FolderEnumeration::sealed
  • commandsRequestedEventRegistrationToken : SDKSample::ApplicationSettings::sealed
  • compass : SDKSample::CompassCPP::sealed
  • completionEvent : HttpRequestStringCallback
  • compressedData : ScenarioContext
  • compressor : ScenarioContext
  • connected : DatagramSocketSample::sealed
  • connectionProfileInfo : SDKSample::NetworkInformationApi::sealed
  • contactIsEdge : Contact
  • contactPickerUI : ContactPicker::sealed
  • contactPosition : Contact
  • contactSet : ContactPicker::sealed
  • contentChangedToken : Clipboard::sealed
  • ContentStream : SDKSample::WASAPIAudio::DEVICEPROPS
  • contentText : SDKSample::TouchKeyboard::sealed
  • continuous : AnimateLinePosition , AnimateCirclePosition
  • convFlags : DirectX::LegacyDDS
  • cookie : SDKSample::NetworkInformationApi::sealed
  • CopyrightProperty : SDKSample::FolderEnumeration::sealed
  • count : SDKSample::FlipViewData::sealed
  • counter : SDKSample::ApplicationDataSample::sealed
  • criticalSection : SDKSample::WebSocket::sealed
  • cStreams : MPEG1SystemHeader
  • cts : SDKSample::SearchContract::sealed
  • currChunk : SDKSample::DataReaderWriter::sealed
  • Current : SDKTemplate::MainPage
  • currentFeed : SDKSample::Syndication::sealed
  • currentItemIndex : SDKSample::Syndication::sealed
  • currentState : SimpleCommunication::LowLatency
  • currentType : SDKSample::PlayToreceiver::sealed
  • cursorId : ShapeRecord
  • cVideoBound : MPEG1SystemHeader
  • cw : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- d -

  • D2D1_FIGURE_BEGIN : Extruder::ExtrudingSink
  • d2dContext : PageRendererContext , LoadScreen , TargetTexture
  • D2DDeviceContext : CustomTextRenderer
  • D2DFactory : CustomTextRenderer
  • d2dFactory : TargetTexture
  • data : DirectX::BC4_UNORM , DirectX::BC4_SNORM
  • dataEvent : Web::Details::HttpRequestBuffersCallback
  • dataEventLock : Web::Details::HttpRequestBuffersCallback
  • dataHResult : Web::Details::HttpRequestBuffersCallback
  • DataOffset : SDKMESH_VERTEX_BUFFER_HEADER , SDKMESH_INDEX_BUFFER_HEADER , SDKANIMATION_FRAME_DATA
  • dataRequestedToken : SDKSample::Common::SharePage , SDKSample::WebViewControl::sealed
  • dataSent : SDKSample::WebSocket::sealed
  • datasize : DirectX::ConvertData
  • dataStream : Web::Details::HttpRequestBuffersCallback
  • dataTransferManager : SDKSample::WebViewControl::sealed
  • dateAccessedProperty : SDKSample::FileAccess::sealed
  • dateFormat : SDKSample::FileAccess::sealed
  • ddpf : DirectX::LegacyDDS
  • ddspf : DDS_HEADER , DirectX::DDS_HEADER
  • Decl : SDKMESH_VERTEX_BUFFER_HEADER
  • decodePixelHeight : SDKSample::Images::sealed
  • decodePixelWidth : SDKSample::Images::sealed
  • Decoder : sealed
  • decompressedData : ScenarioContext
  • DEFAULT_LOGICALPPI : SDKSample::Scaling::sealed
  • defaultFontFamily : SDKSample::Scaling::sealed
  • defaultMode : SimpleCommunication::LowLatency
  • DefaultViewModelProperty : SDKTemplate::Common::LayoutAwarePage
  • Deferral : Tasks::sealed
  • Delay : _FILE_PLAYBACK
  • deltaPerDtidX : ComputeCB , ComputeDoubleCB
  • deltaPerDtidY : ComputeCB , ComputeDoubleCB
  • depth : DDS_HEADER , DirectX::TexMetadata
  • desiredReportInterval
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
  • device : SimpleCommunication::LowLatency , SimpleCommunication::VideoChat
  • Device : CustomDeviceAccess::DeviceListEntry
  • DeviceChecked : SDKTemplate::MainPage
  • deviceClosingHandler : SDKSample::CustomDeviceAccess::sealed
  • deviceContext : InlineImage
  • DeviceLost : Renderer , abstract
  • DeviceReset : abstract
  • Diffuse : SDKMESH_MATERIAL
  • diffuseColor : ConstantBufferChangesEveryPrim , Material
  • DiffuseRV : SDKMESH_MATERIAL
  • DiffuseTexture : SDKMESH_MATERIAL
  • DiffuseTextureName : SDKMESH_MATERIAL
  • dimension : DirectX::TexMetadata
  • dismissed : SDKSample::SplashScreen::sealed
  • Dismissed : SDKSample::sealed
  • dispatcher
: SDKSample::AccelerometerCPP::sealed
, SDKSample::CameraOptions::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::PlayTo::sealed
, SimpleCommunication::SdkSample
, ToastsSampleCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::GyrometerCPP::sealed
  • dispatcherTimer
: SDKSample::AccelerometerCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::CompassCPP::sealed
  • displaySizeInches : STEREO_PARAMETERS
  • Document : SDKSample::FileExtensions
  • dpi : FPSCounter , RippleEffect , Renderer
  • DPI96 : PrintSample::sealed
  • duration : AnimateCirclePosition , AnimateLinePosition
  • dwABitMask : DirectX::DDS_PIXELFORMAT
  • dwBBitMask : DirectX::DDS_PIXELFORMAT
  • dwBitRate : MPEG1AudioFrameHeader
  • dwCaps : DirectX::DDS_HEADER
  • dwCaps2 : DirectX::DDS_HEADER
  • dwCaps3 : DirectX::DDS_HEADER
  • dwCaps4 : DirectX::DDS_HEADER
  • dwColorOffset : TGA_EXTENSION
  • dwDepth : DirectX::DDS_HEADER
  • dwDeveloperOffset : TGA_FOOTER
  • dwExtensionOffset : TGA_FOOTER
  • dwFlags : DirectX::DDS_PIXELFORMAT , DirectX::DDS_HEADER
  • dwFourCC : DirectX::DDS_PIXELFORMAT
  • dwGBitMask : DirectX::DDS_PIXELFORMAT
  • dwHeight : DirectX::DDS_HEADER
  • dwKeyColor : TGA_EXTENSION
  • dwMipMapCount : DirectX::DDS_HEADER
  • dwPitchOrLinearSize : DirectX::DDS_HEADER
  • dwRBitMask : DirectX::DDS_PIXELFORMAT
  • dwReserved1 : DirectX::DDS_HEADER
  • dwReserved2 : DirectX::DDS_HEADER
  • dwRGBBitCount : DirectX::DDS_PIXELFORMAT
  • dwriteFactory : TargetTexture
  • dwSamplesPerSec : MPEG1AudioFrameHeader
  • dwScanOffset : TGA_EXTENSION
  • dwSize : DirectX::DDS_HEADER , DirectX::DDS_PIXELFORMAT
  • dwStampOffset : TGA_EXTENSION
  • dwStreamFlags : SDKSample::WASAPIAudio::MFSampleGenerator
  • dwStreamIndex : SDKSample::WASAPIAudio::MFSampleGenerator
  • dwValue : SValue
  • dwWidth : DirectX::DDS_HEADER
  • dxgiFormat : DDS_HEADER_DXT10 , DirectX::DDS_HEADER_DXT10
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- e -

  • e : Hilo::Common::sealed
  • EdgeGestureCanceledEventToken : EdgeGestureSample::sealed
  • EdgeGestureCompletedEventToken : EdgeGestureSample::sealed
  • EdgeGestureStartingEventToken : EdgeGestureSample::sealed
  • Edges : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • editUri : SDKSample::sealed
  • EffectIntensityChanged : Postcard::sealed
  • elapsedTime : HighScoreEntry
  • elasticCollision : CollisionInfo
  • Emissive : SDKMESH_MATERIAL
  • emphasis : MPEG1AudioFrameHeader
  • employees : SDKSample::DataBinding::sealed
  • emptyTitle : Hilo::sealed
  • Encoder : sealed
  • endPosition : AnimateLinePosition
  • EraseClicked : Postcard::sealed
  • error : anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander
  • eventRegistrationToken : SDKSample::StoreSample::sealed
  • eventToken : SDKSample::ApplicationResources::sealed
  • exceptionPolicy : Hilo::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- f -

  • FailureCount : Samples::Devices::Fx2::sealed
  • falToken : SDKSample::MainPage
  • fBestErr : DirectX::D3DX_BC6H::EncodeParams
  • FEATURE_NAME : SDKTemplate::MainPage , SDKTemplateCS::MainPage
  • feed : SDKSample::sealed
  • feedData : SimpleBlogReader::sealed
  • feedIterator : SDKSample::AtomPub::sealed
  • feedUri : SDKSample::sealed
  • figureBegin : PointSnapper::PointSnappingSink
  • fileActivationFiles : SDKSample::MainPage
  • FileAdded : SDKSample::Status
  • FileAddFailed : SDKSample::Status
  • FileGroupEmpty : SDKSample::Errors
  • FileGroupLocation : SDKSample::Errors
  • fileID : SDKSample::FilePickerContracts::sealed
  • fileName : Document
  • filename : SuspensionManager
  • fileOpenPickerUI : SDKSample::FilePickerContracts::sealed
  • fileOwnerProperty : SDKSample::FileAccess::sealed
  • FileRemoved : SDKSample::Status
  • fileSavePickerUI : SDKSample::FilePickerContracts::sealed
  • fileToken : SDKSample::FilePicker::sealed
  • fileToLaunch : AssociationLaunching::sealed
  • fileUpdateRequest : SDKSample::FilePickerContracts::sealed
  • fileUpdateRequestDeferral : SDKSample::FilePickerContracts::sealed
  • fillBrush : CustomTextRenderer
  • finallyClause : SDKSample::Finally
  • firstName : SDKSample::Accessibility::sealed
  • flags : DirectX::ConvertData , DDS_HEADER , DDS_PIXELFORMAT
  • folderQuery : Hilo::sealed
  • Force64_1 : SDKMESH_MATERIAL
  • Force64_2 : SDKMESH_MATERIAL
  • Force64_3 : SDKMESH_MATERIAL
  • Force64_4 : SDKMESH_MATERIAL
  • Force64_5 : SDKMESH_MATERIAL
  • Force64_6 : SDKMESH_MATERIAL
  • format
: DirectX::Image
, DirectX::TexMetadata
, DirectX::LegacyDDS
, WICTranslate
, DirectX::ConvertData
  • forwardEvents : SimpleCommunication::Common::CaptureDevice
  • fourCC : DDS_PIXELFORMAT
  • FrameDataOffset : SDKMESH_HEADER
  • FrameInfluenceOffset : SDKMESH_MESH
  • FrameInfluences : SDKMESH_MESH
  • FrameName : SDKANIMATION_FRAME_DATA
  • frameRate : MPEG1VideoSeqHeader
  • FrameTransformType : SDKANIMATION_FILE_HEADER
  • frequency : RippleEffect
  • Frequency : SDKSample::WASAPIAudio::DEVICEPROPS
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- g -

  • g : Vector2< T > , Vector3< T > , DirectX::LDRColorA , DirectX::HDRColorA , Vector4< T > , DirectX::INTColor , AmpPixel
  • GBitMask : DDS_PIXELFORMAT
  • geolocator : SDKSample::GeolocationCPP::sealed
  • geolocTask : SDKSample::GeolocationCPP::sealed
  • geometry : sealed
  • geopositionTaskTokenSource : SDKSample::GeolocationCPP::sealed , BackgroundTask::sealed
  • glyphCount : TextAnalysis::Run
  • glyphOrientation : TextAnalysis::Run
  • glyphStart : TextAnalysis::Run
  • Green : sealed
  • gyrometer : SDKSample::GyrometerCPP::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- h -

  • h : DirectX::Rect
  • header : MPEG1VideoSeqHeader
  • HeaderSize : SDKMESH_HEADER
  • height : DDS_HEADER , DirectX::TexMetadata , DirectX::Image , MPEG1VideoSeqHeader
  • HiddenFrame
: SDKSample::sealed
, SimpleCommunication::sealed
, StreamSocketSample::sealed
, AccountPictureName::sealed
, DeviceAppForWebcam::sealed
, AppBarControl::sealed
, Clipboard::sealed
  • hiddenFrame : SecondaryTiles::sealed
  • HiddenFrame
: ContactPicker::sealed
, SDKTemplate::MainPage
, DatagramSocketSample::sealed
, SDKSample::FilePickerContracts::sealed
, ProximityCPP::sealed
  • hnsBufferDuration : SDKSample::WASAPIAudio::DEVICEPROPS
  • HomeEmail : ContactPicker::sealed::SampleContact
  • HomePhone : ContactPicker::sealed::SampleContact
  • horizontal : Alignment
  • horizontalResolution : SimpleCommunication::sealed::StreamFilteringCriteria
  • hostName : DatagramSocketSample::sealed
  • hr : SDKSample::WASAPIAudio::sealed
  • htmlDescription : Clipboard::sealed
  • httpRequest
: SDKSample::CertificateEnrollment::sealed
, SDKSample::MicrosoftAccount::sealed
, SDKSample::SearchContract::sealed
, SDKSample::HttpClientSample::sealed
  • HttpTime : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- i -

  • Id : ContactPicker::sealed::SampleContact
  • Image : SDKSample::FileExtensions
  • image100 : SDKSample::Scaling::sealed
  • image140 : SDKSample::Scaling::sealed
  • image180 : SDKSample::Scaling::sealed
  • imageFile : SDKSample::ShareSource::sealed
  • imageRecd : SDKSample::PlayToreceiver::sealed
  • imageRelativePath : SDKSample::Tiles::sealed
  • imgSrc : Clipboard::sealed
  • imgStreamRef : Clipboard::sealed
  • inclinometer : SDKSample::InclinometerCPP::sealed
  • Incomingconnectionevent : SimpleCommunication::sealed
  • index : SDKSample::sealed
  • IndexBuffer : SDKMESH_INDEX_BUFFER_HEADER , SDKMESH_MESH
  • IndexCount : SDKMESH_SUBSET
  • IndexStart : SDKMESH_SUBSET
  • IndexStreamHeadersOffset : SDKMESH_HEADER
  • IndexType : SDKMESH_INDEX_BUFFER_HEADER
  • indices : DirectX::BC4_UNORM , DirectX::BC4_SNORM
  • InputName : AntSystem::Node
  • internetProfileInfo : SDKSample::NetworkInformationApi::sealed
  • interocularDistance : StereoParameters
  • interpNorm1 : Extruder::ExtrudingSink::Vertex2D
  • interpNorm2 : Extruder::ExtrudingSink::Vertex2D
  • isApp : Simple3DGameXaml::sealed
  • IsBackground : SDKSample::WASAPIAudio::DEVICEPROPS
  • IsBigEndian : SDKMESH_HEADER , SDKANIMATION_FILE_HEADER
  • IsContentCropped : PrintSample::PageDescription
  • isEnabled : Wrapper::DspSettings
  • isEventRegistered : SDKSample::ApplicationSettings::sealed
  • IsHWOffload : SDKSample::WASAPIAudio::DEVICEPROPS
  • IsInitialized : SDKSample::MediaButtons::sealed
  • IsMediaJustLoaded : SDKSample::PlayToreceiver::sealed
  • isNumberSubstituted : TextAnalysis::Run
  • IsPlaying : SDKSample::PlaybackManager2::sealed
  • isPlaying : XAudio2SoundPlayer::ImplData
  • IsPlaying : SDKSample::PlaybackManager::sealed
  • IsPlayReceivedPreMediaLoaded : SDKSample::PlayToreceiver::sealed
  • IsReceiverStarted : SDKSample::PlayToreceiver::sealed
  • isRect : Polygon
  • IsRegistered : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • isReversed : TextAnalysis::Run
  • isRollingOnFloor : CollisionInfo
  • isScenario2StoryboardRunning : SDKSample::Animation::sealed
  • IsSeeking : SDKSample::PlayToreceiver::sealed
  • isSideways : TextAnalysis::Run
  • isTerminator : SimpleCommunication::VideoChat
  • IsTonePlayback : SDKSample::WASAPIAudio::DEVICEPROPS
  • isTrial : GameConfig
  • item : List< T >::Node
  • itemCollection : SDKSample::ExpressionBlendSampleDataSampleDataSource::sealed , SDKSample::FlipViewData::sealed
  • iteration : FractalBufferElement
  • Iterations : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- p -

  • pageRenderer : PageRendererContext
  • PageResized : SDKSample::FilePickerContracts::sealed , SDKSample::sealed
  • PageSize : PrintSample::PageDescription
  • Parallel : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • ParentFrame : SDKMESH_FRAME
  • password : SDKSample::sealed
  • Path : _FILE_PLAYBACK
  • PausePressedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • penetrationDistance : Contact
  • PERCENT : SDKSample::Scaling::sealed
  • percentOfScreen : Wrapper::DspSettings
  • PeriodicTimer : Tasks::sealed
  • pGeometry : PaperFragment
  • phase : RippleEffect
  • Pheromone : AntSystem::Edge
  • PHOTO_FILE_NAME : MediaCapture::BasicCapture
  • photoGroup : Hilo::sealed
  • PhotoStorage : sealed
  • PictureViewSize : PrintSample::PageDescription
  • pinToAppBar : SecondaryTiles::sealed
  • pIsEnabled : IMft0Vtbl
  • pitchOrLinearSize : DDS_HEADER
  • pixelAspectRatio : MPEG1VideoSeqHeader
  • pixelHeight : ConstantBufferLayoutForDX9BrightPassPixelShader
  • pixelResolutionHeight : STEREO_PARAMETERS
  • pixelResolutionWidth : STEREO_PARAMETERS
  • pixels : DirectX::Image
  • pixelShader : Material
  • pixelWidth : ConstantBufferLayoutForDX9BrightPassPixelShader
  • plane : Contact , Triangle
  • planeNormal : AnimateCirclePosition
  • playData : XAudio2SoundPlayer::ImplData
  • playlistExtensionsInner : SDKSample::MainPage
  • playlistInner : SDKSample::MainPage
  • playlistTimer : SDKSample::PlayTo::sealed
  • PlayPauseTogglePressedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • PlayPressedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • playToManager : SDKSample::PlayTo::sealed
  • pName : SValue
  • pNext : SConversion
  • pNode : List< T >::POSITION
  • PointA : AntSystem::Edge
  • PointB : AntSystem::Edge
  • points : Polygon , SDKSample::WASAPIAudio::sealed
  • pointsCount : Extruder::ExtrudingSink , PointSnapper::PointSnappingSink
  • port : DatagramSocketSample::sealed
  • pos : IndexTriplet , SimpleCubeVertex , ScreenVertex
  • Pos : SimpleVertex
  • pos : ParticleData , BasicVertex , TangentVertex , FractalVertex , ScreenQuadVertex , BasicSprites::ReplicationVertex , BasicSprites::InstancingVertex , AsteroidData
  • position : LineSegment , PNTVertex , FPSCounter
  • positionToken : SDKSample::GeolocationCPP::sealed
  • Power : SDKMESH_MATERIAL
  • ppvObject : IMft0Vtbl
  • prev : List< T >::Node
  • previewEncodingProperties : SimpleCommunication::LowLatency
  • previewStarted : SDKSample::CameraOptions::sealed
  • previousState : SimpleCommunication::LowLatency
  • previousSwitchValues : SDKSample::CustomDeviceAccess::sealed
  • PrimitiveType : SDKMESH_SUBSET
  • productId : Simple3DGameXaml::sealed
  • profileMediaType : SDKSample::ProvisioningAgent::sealed
  • Progress : Tasks::sealed
  • projection : ConstantBufferChangeOnResize , ConstantBuffer
  • PropertyChanged
: Magazine::sealed
, Hilo::Common::BindableBase
, Simple3DGameXaml::sealed
, Hilo::sealed
  • pSample : SDKSample::WASAPIAudio::MFSampleGenerator
  • pt : Extruder::ExtrudingSink::Vertex2D
  • PTS : MPEG1PacketHeader
  • puiPercentOfScreen : IMft0Vtbl
  • Purple : sealed
  • pushReceivedToken : SDKSample::SDKTemplate::sealed
  • pushToken : RawNotificationsSampleCPP::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- r -

  • r : Vector2< T > , Vector3< T > , DirectX::LDRColorA , DirectX::HDRColorA , Vector4< T > , DirectX::INTColor , AmpPixel
  • raStream : ScenarioContext
  • rateBound : MPEG1SystemHeader
  • RBitMask : DDS_PIXELFORMAT
  • rcBound : Polygon
  • readBuffer : SDKSample::WebSocket::sealed , SDKSample::HttpClientSample::sealed
  • readingChangedEventToken : SDKSample::DisplayOrientation::sealed
  • readingToken
: SDKSample::CompassCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::AccelerometerCPP::sealed
  • reasonPhrase : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback , Web::HttpRequest
  • receiver : SDKSample::PlayToreceiver::sealed
  • recordingStarted : SimpleCommunication::Common::CaptureDevice
  • rect : InlineImage
  • Red : sealed
  • red_0 : DirectX::BC4_UNORM , DirectX::BC4_SNORM
  • red_1 : DirectX::BC4_UNORM , DirectX::BC4_SNORM
  • refCount : CustomTextRenderer , InlineImage
  • refValue_ : ComBase< InterfaceChain >
  • registerContentChanged : Clipboard::sealed
  • registeredNetworkStatusNotif : SDKSample::NetworkInformationApi::sealed
  • registrationToken : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • remoteScenariosInner : SDKSample::FilePickerContracts::sealed
  • RemovePaperClicked : Postcard::sealed
  • renderer : Document
  • Repeater : Samples::Devices::Fx2::sealed
  • repository : Hilo::sealed
  • request : HttpRequestStringCallback , Web::Details::HttpRequestBuffersCallback
  • RequestsPending : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • reserved : DDS_HEADER_DXT10 , DirectX::DDS_HEADER_DXT10
  • reserved1 : DDS_HEADER
  • reserved2 : DDS_HEADER
  • ResolvedLocation : AntSystem::Node
  • ResolvedName : AntSystem::Node
  • resourceDimension : DDS_HEADER_DXT10 , DirectX::DDS_HEADER_DXT10
  • responseComplete : Web::HttpRequest
  • responseReceived : Web::Details::HttpRequestBuffersCallback
  • Result : Samples::Devices::DeviceControlResult
  • resultSuggestionChosenToken : SDKSample::SearchContract::sealed
  • rgb : DirectX::D3DX_BC1
  • RGBAPrec : DirectX::D3DX_BC6H::ModeInfo , DirectX::D3DX_BC7::ModeInfo
  • RGBAPrecWithP : DirectX::D3DX_BC7::ModeInfo
  • RGBBitCount : DDS_PIXELFORMAT
  • Rho : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • RightClickEventToken : EdgeGestureSample::sealed
  • RightClickRegion : EdgeGestureSample::sealed
  • RightClickRegionEventToken : EdgeGestureSample::sealed
  • rightPanel : SecondaryTiles::sealed , AppBarControl::sealed
  • riid : IMft0Vtbl
  • roamingFolder : SDKSample::ApplicationDataSample::sealed
  • roamingSettings : SDKSample::ApplicationDataSample::sealed
  • roleIsActive : SimpleCommunication::VideoChat
  • rootFrame
: SDKSample::App
, AccountPictureName::App
, Clipboard::App
, ContactPicker::App
, DatagramSocketSample::sealed
, DeviceAppForPrinters::App
, SecondaryTiles::sealed
, SDKSample::SplashScreen::sealed
, StreamSocketSample::App
, DeviceAppForWebcam::sealed
, AppBarControl::App
  • rootPage
: SDKSample::HomeGroup::sealed
, SDKSample::GlobalizationPreferencesSample::sealed
, SDKSample::GeolocationCPP::sealed
, SDKSample::FilePicker::sealed
, SDKSample::FileThumbnails::sealed
, SDKSample::FileAccess::sealed
, SDKSample::ELS::sealed
, EdgeGestureSample::sealed
, SDKSample::EAS::sealed
, SDKSample::DeviceEnumeration::sealed
, LockScreenAppsCPP::sealed
, SDKSample::DateTimeFormatting::sealed
, DatagramSocketSample::sealed
, SDKSample::CustomDeviceAccess::sealed
, CustomDeviceAccess::DeviceAsync
, SDKSample::CryptoWinRT::sealed
, MediaExtensionsCS::ScenarioList
, SDKSample::PasswordVaultCPP::sealed
, SDKSample::ContextMenu::sealed
, SDKSample::WebSocket::sealed
, SDKSample::MediaButtons::sealed
, SDKSample::Compression::sealed
, SDKSample::CompassCPP::sealed
, Clipboard::sealed
, MediaExtensionsCPP::sealed
, SDKSample::CertificateEnrollment::sealed
, SDKSample::CameraOptions::sealed
, SDKSample::CameraCapture::sealed
, SDKSample::CalendarSample::sealed
, SDKSample::CallControl::sealed
, SDKSample::BackgroundTransfer::sealed
, SDKSample::BackgroundTask::sealed
, AppBarControl::sealed
, AssociationLaunching::sealed
, SDKSample::ApplicationResources::sealed
, SDKSample::ApplicationDataSample::sealed
, SDKSample::Tiles::sealed
, SDKSample::ApplicationSettings::sealed
, SDKSample::PackageSample::sealed
, SDKSample::AnimationMetrics::sealed
, AccountPictureName::sealed
, SDKSample::AccelerometerCPP::sealed
, StreamSocketSample::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::Drawing::sealed
, SimpleCommunication::LowLatency
, SDKSample::HighContrast::sealed
, AppBarControl::sealed
, SDKSample::PlaybackManager2::sealed
, SDKSample::MediaCapture::sealed
, SDKSample::GyrometerCPP::sealed
, ToastsSampleCPP::sealed
, SDKSample::ScrollViewerCPP::sealed
, MediaExtensionsCS::ScenarioInput4
, SDKSample::PersonalityAnimations::sealed
, SDKSample::StoreSample::sealed
, MediaExtensionsCS::ScenarioInput3
, MediaExtensionsCS::ScenarioOutput3
, MediaCapture::BasicCapture
, SDKSample::UserDomainName::sealed
, SDKSample::LightSensorCPP::sealed
, SDKSample::DataReaderWriter::sealed
, SDKSample::UserAndCustomControls::sealed
, SDKSample::Syndication::sealed
, MediaExtensionsCS::ScenarioOutput1
, SDKSample::ProvisioningAgent::sealed
, SDKSample::WASAPIAudio::sealed
, SDKSample::MicrosoftAccount::sealed
, SDKSample::TextEditing::sealed
, SDKSample::Rotation::sealed
, SDKSample::TextDisplay::sealed
, SDKSample::Accessibility::sealed
, CredentialPickerCPP::sealed
, SDKSample::PortableDeviceCPP::sealed
, AppBarControl::sealed
, SDKSample::IsRemoteSession::sealed
, SDKSample::UssdApi::sealed
, SDKSample::Transforms::sealed
, SDKSample::FlipViewCPP::sealed
, SDKSample::AtomPub::sealed
, ScheduledNotificationsSampleCPP::sealed
, SDKSample::Images::sealed
, SDKSample::DataBinding::sealed
, SDKSample::WebViewControl::sealed
, SDKSample::TouchKeyboard::sealed
, SDKSample::TouchKeyboardTextInput::sealed
, SDKSample::ListViewSimple::sealed
, SDKSample::ShareSource::sealed
, SDKSample::Transcode::sealed
, MediaExtensionsCS::ScenarioInput1
, SDKSample::XAMLPopup::sealed
, SDKSample::ThreadPool::sealed
, MediaExtensionsCS::ScenarioOutput4
, MediaExtensionsCS::ScenarioOutput2
, SDKSample::Personalization::sealed
, MediaExtensionsCS::ScenarioInput2
, SDKSample::MessageDialogSample::sealed
, SDKSample::NetworkInformationApi::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::WebAuthentication::sealed
, SDKSample::PlayToreceiver::sealed
, PrintSample::sealed
, RawNotificationsSampleCPP::sealed
, SDKSample::Animation::sealed
, SDKSample::RemovableStorageCPP::sealed
, SecondaryTiles::sealed
, SDKSample::DeviceCaps::sealed
, LanguageFontCPP::sealed
, MediaCapture::AudioCapture
, SDKSample::HttpClientSample::sealed
, SDKSample::InclinometerCPP::sealed
, SimpleCommunication::VideoChat
, MediaStreamSource::AudioSource
, SDKSample::NumberFormatting::sealed
, SDKSample::Playlists::sealed
, SDKSample::SDKTemplate::sealed
, SDKSample::PlayTo::sealed
, SDKSample::PlaybackManager::sealed
, SDKSample::MediaServerClient::sealed
  • rot : AsteroidData
  • rotation : BasicSprites::InstanceData , ViewTransform
  • rotationAngle : SDKSample::DisplayOrientation::sealed
  • rotVel : AsteroidData
  • rowPitch : DirectX::Image
  • rt : CStreamState
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- s -

  • sampleBackgroundTaskEntryPoint : SDKSample::GeolocationCPP::sealed
  • sampleBackgroundTaskName : SDKSample::GeolocationCPP::sealed
  • SampleBackgroundTaskProgress : SDKSample::BackgroundTask::BackgroundTaskSample
  • SampleBackgroundTaskRegistered : SDKSample::BackgroundTask::BackgroundTaskSample
  • SampleBackgroundTaskWithConditionProgress : SDKSample::BackgroundTask::BackgroundTaskSample
  • SampleBackgroundTaskWithConditionRegistered : SDKSample::BackgroundTask::BackgroundTaskSample , SDKSample::BackgroundTaskSample
  • SampleDuration : MediaStreamSource::PcmSource
  • sampleFile : SDKSample::MainPage
  • sampleOffsets : ConstantBufferLayoutForGlowPixelShader
  • SampleRate : MediaStreamSource::PcmSource
  • sampleWeights : ConstantBufferLayoutForGlowPixelShader
  • scale : ViewTransform , AsteroidData
  • Scaling : SDKANIMATION_DATA
  • ScenarioList
: SDKSample::sealed
, AccountPictureName::sealed
, Clipboard::sealed
, ContactPicker::sealed
, DatagramSocketSample::sealed
, SDKSample::FilePickerContracts::sealed
, ProximityCPP::sealed
, SimpleCommunication::sealed
, StreamSocketSample::sealed
, AppBarControl::sealed
  • scenarioList : SecondaryTiles::sealed
  • ScenarioLoaded : SDKSample::FilePickerContracts::sealed
  • scenarios : SDKTemplate::MainPage
  • scenariosInner
: ContactPicker::MainPage
, ContactPicker::MainPagePicker
, SDKSample::FilePickerContracts::sealed
, SDKSample::sealed
, SDKSample::MainPage
, SecondaryTiles::MainPage
, AccountPictureName::MainPage
, SDKSample::MainPage
, Clipboard::MainPage
  • scheduledNotificationsBinding : ScheduledNotificationsSampleCPP::sealed
  • script : TextAnalysis::Run
  • searchPane : SDKSample::SearchContract::sealed
  • SearchPaneMaxSuggestions : SDKSample::MainPage
  • segments : CylinderMesh , SphereMesh
  • sendBuffer : SDKSample::WebSocket::sealed
  • sensor
: SDKSample::LightSensorCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
  • serviceDocUri : SDKSample::sealed
  • ServicingCompleteTaskProgress : SDKSample::BackgroundTask::BackgroundTaskSample
  • ServicingCompleteTaskRegistered : SDKSample::BackgroundTask::BackgroundTaskSample
  • sessionState_ : SuspensionManager
  • sessionStateKey : SDKSample::Common::sealed , Hilo::Common::sealed
  • shakeCounter : SDKSample::AccelerometerCPP::sealed
  • shakenToken : SDKSample::AccelerometerCPP::sealed
  • shape : ShapeRecord
  • sharedBitmapStreamRef : ShareTarget::sealed
  • sharedCustomData : ShareTarget::sealed
  • sharedDataDescription : ShareTarget::sealed
  • sharedDataTitle : ShareTarget::sealed
  • sharedHtmlFormat : ShareTarget::sealed
  • sharedResourceMap : ShareTarget::sealed
  • sharedStorageItems : ShareTarget::sealed
  • sharedText : ShareTarget::sealed
  • sharedThumbnailStreamRef : ShareTarget::sealed
  • sharedUri : ShareTarget::sealed
  • shareOperation : ShareTarget::sealed
  • shareQuickLinkId : ShareTarget::sealed
  • SiblingFrame : SDKMESH_FRAME
  • Signature : TGA_FOOTER
  • SignClicked : Postcard::sealed
  • SimulationTime : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • size : DDS_PIXELFORMAT , DDS_HEADER , BasicSprites::TextureMapElement , SDKSample::WASAPIAudio::sealed , anonymous_namespace{SoundFileReader.cpp}::ChunkHeader
  • sizeBound : MPEG1StreamHeader
  • SizeBytes : SDKMESH_VERTEX_BUFFER_HEADER , SDKMESH_INDEX_BUFFER_HEADER
  • sizeX : WaveEffect
  • sizeY : WaveEffect
  • skewX : WaveEffect
  • skewY : WaveEffect
  • slicePitch : DirectX::Image
  • socket : DatagramSocketSample::sealed
  • SoundLevelChangedToken : SDKSample::PlaybackManager::sealed , SDKSample::PlaybackManager2::sealed
  • source : WICConvert
  • sourceRequestedToken : SDKSample::PlayTo::sealed
  • sourceVoice : XAudio2SoundPlayer::ImplData
  • Specular : SDKMESH_MATERIAL
  • specularColor : ConstantBufferChangesEveryPrim , Material
  • specularExponent : Material
  • specularPower : ConstantBufferChangesEveryPrim
  • SpecularRV : SDKMESH_MATERIAL
  • SpecularTexture : SDKMESH_MATERIAL
  • SpecularTextureName : SDKMESH_MATERIAL
  • splash : SDKSample::SplashScreen::sealed
  • SplashImageRect : SDKSample::sealed
  • spread : RippleEffect
  • srv : BasicSprites::TextureMapElement
  • StampPaperClicked : Postcard::sealed
  • starButton : AppBarControl::sealed
  • startPosition : AnimateCirclePosition
  • State : ContactPicker::sealed::SampleContact
  • StateChangedEvent : SDKSample::WASAPIAudio::sealed
  • statusCode : HttpRequestStringCallback , Web::HttpRequest , Web::Details::HttpRequestBuffersCallback
  • statusToken : SDKSample::GeolocationCPP::sealed
  • stereoExaggerationFactor : STEREO_PARAMETERS
  • stereoSeparationFactor : STEREO_PARAMETERS
  • StopPressedToken : SDKSample::PlaybackManager2::sealed , SDKSample::PlaybackManager::sealed
  • storageItems : SDKSample::ShareSource::sealed
  • storeData : SDKSample::ListViewSimple::sealed
  • Stream : _SDKMESHVERTEXELEMENT
  • stream_id : MPEG1StreamHeader , MPEG1PacketHeader
  • streams : MPEG1SystemHeader
  • streamWebSocket : SDKSample::WebSocket::sealed
  • Street : ContactPicker::sealed::SampleContact
  • StrideBytes : SDKMESH_VERTEX_BUFFER_HEADER
  • SubsetDataOffset : SDKMESH_HEADER
  • SubsetOffset : SDKMESH_MESH
  • Subsets : SDKMESH_MESH
  • subType : SimpleCommunication::sealed::StreamFilteringCriteria
  • suggestionsRequestedToken : SDKSample::SearchContract::sealed
  • Switch1 : _SWITCH_STATE
  • Switch2 : _SWITCH_STATE
  • Switch3 : _SWITCH_STATE
  • Switch4 : _SWITCH_STATE
  • Switch5 : _SWITCH_STATE
  • Switch6 : _SWITCH_STATE
  • Switch7 : _SWITCH_STATE
  • Switch8 : _SWITCH_STATE
  • switchChangedEventsHandler : SDKSample::CustomDeviceAccess::sealed
  • switchChangedEventsRegistered : SDKSample::CustomDeviceAccess::sealed
  • SwitchesAsUChar : _SWITCH_STATE
  • szAuthorComment : TGA_EXTENSION
  • szAuthorName : TGA_EXTENSION
  • szDest : SConversion
  • szJobName : TGA_EXTENSION
  • szSoftwareId : TGA_EXTENSION
  • szSrc : SConversion
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- t -

  • tag : HighScoreEntry , anonymous_namespace{SoundFileReader.cpp}::ChunkHeader
  • target : WICConvert
  • taskCompletedToken : SDKSample::GeolocationCPP::sealed
  • TaskInstance : Tasks::sealed
  • TestVectorNonce : SDKSample::CryptoWinRT::sealed
  • tex : TangentVertex , FractalVertex , ScreenQuadVertex , IndexTriplet , BasicSprites::ReplicationVertex , BasicSprites::InstancingVertex , BasicVertex , ScreenVertex
  • texScale : DrawRectCB
  • text : FPSCounter
  • textBlock : SDKSample::TouchKeyboard::sealed
  • textDescription : Clipboard::sealed
  • textFormat : FPSCounter
  • textLength : TextAnalysis::Run
  • textStart : TextAnalysis::Run
  • TextSubmitted : Postcard::sealed
  • textureCoordinate : PNTVertex
  • textureResourceView : Material
  • textureView : BasicSprites::SpriteRunInfo
  • timeFormat : SDKSample::FileAccess::sealed
  • timerTickToken : SDKSample::PlayTo::sealed
  • TimeTriggeredTaskProgress : SDKSample::BackgroundTask::BackgroundTaskSample
  • TimeTriggeredTaskRegistered : SDKSample::BackgroundTask::BackgroundTaskSample
  • Title
: Clipboard::Scenario
, ContactPicker::Scenario
, DatagramSocketSample::Scenario
, DeviceAppForPrinters::Scenario
, SDKSample::Scenario
, ProximityCPP::Scenario
, SimpleCommunication::Scenario
, AppBarControl::Scenario
  • title : SecondaryTiles::Scenario
  • Title
: StreamSocketSample::Scenario
, SDKSample::Scenario
, AccountPictureName::Scenario
  • titleBody : GameHud
  • titleLicenseInfo : GameHud
  • toastContext : ToastsSampleCPP::sealed
  • token
: SDKSample::MainPage
, ContactPicker::sealed
, SDKSample::SearchContract::sealed
, SDKSample::FilePickerContracts::sealed
  • totalHits : HighScoreEntry
  • totalShots : HighScoreEntry
  • TotalTime : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • Translation : SDKANIMATION_DATA
  • translationX : ViewTransform
  • translationY : ViewTransform
  • TravelDistance : AntSystem::Edge
  • TravelMode : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • triangle : Contact
  • trianglesCount : Extruder::ExtrudingSink
  • triIndex : Contact
  • type : MPEG1StreamHeader , MPEG1PacketHeader , PageRendererContext
  • Type : _SDKMESHVERTEXELEMENT
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- u -

  • u : Vector2< T > , Vector3< T > , AmpPixel
  • uIndexModeBits : DirectX::D3DX_BC7::ModeInfo
  • uIndexPrec : DirectX::D3DX_BC6H::ModeInfo , DirectX::D3DX_BC7::ModeInfo
  • uIndexPrec2 : DirectX::D3DX_BC7::ModeInfo
  • UINT : Extruder::ExtrudingSink , PointSnapper::PointSnappingSink
  • uiPercentOfScreen : IMft0Vtbl
  • uLength : LineSegment
  • uMode
: DirectX::D3DX_BC6H::ModeInfo
, DirectX::D3DX_BC6H::EncodeParams
, DirectX::D3DX_BC7::EncodeParams
  • UnresolvedLocations : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • uPartitionBits : DirectX::D3DX_BC7::ModeInfo
  • uPartitions : DirectX::D3DX_BC6H::ModeInfo , DirectX::D3DX_BC7::ModeInfo
  • uPBits : DirectX::D3DX_BC7::ModeInfo
  • uriToLaunch : AssociationLaunching::sealed
  • uRotationBits : DirectX::D3DX_BC7::ModeInfo
  • Usage : _SDKMESHVERTEXELEMENT
  • UsageIndex : _SDKMESHVERTEXELEMENT
  • user : SDKSample::sealed
  • uShape : DirectX::D3DX_BC6H::EncodeParams
  • uStart : LineSegment
  • uTan : TangentVertex
  • util : SDKSample::ProvisioningAgent::sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- v -

  • v : Vector2< T > , Vector3< T > , AmpPixel
  • vectorChangedHandlerToken : SDKSample::DataBinding::sealed
  • vel : AsteroidData , ParticleData
  • Version : SDKANIMATION_FILE_HEADER , SDKMESH_HEADER
  • VertexBuffer : SDKMESH_VERTEX_BUFFER_HEADER
  • VertexBuffers : SDKMESH_MESH
  • VertexCount : SDKMESH_SUBSET
  • vertexShader : Material
  • VertexStart : SDKMESH_SUBSET
  • VertexStreamHeadersOffset : SDKMESH_HEADER
  • vertical : Alignment
  • VIDEO_FILE_NAME : MediaCapture::BasicCapture
  • videoDevController : SDKTemplate::DeviceAppPage , DeviceAppForWebcam::sealed
  • view : ConstantBuffer , ConstantBufferChangesEveryFrame
  • ViewablePageSize : PrintSample::PageDescription
  • viewerDistance : StereoParameters
  • viewerDistanceInches : STEREO_PARAMETERS
  • viewportHeight : StereoParameters
  • viewportWidth : StereoParameters
  • viewState : SDKTemplate::MainPageSizeChangedEventArgs
  • visibilityChangedToken : Clipboard::sealed
  • visibilityToken
: SDKSample::LightSensorCPP::sealed
, SDKSample::InclinometerCPP::sealed
, SDKSample::CompassCPP::sealed
, SDKSample::SimpleOrientationSensorCPP::sealed
, SDKSample::GyrometerCPP::sealed
, SDKSample::OrientationSensorCPP::sealed
, SDKSample::AccelerometerCPP::sealed
  • vTan : TangentVertex
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- w -

  • w : Vector3< T > , Vector4< T > , DirectX::Rect
  • wasJustAdded : HighScoreEntry
  • WatcherStarted : CustomDeviceAccess::DeviceList
  • waveOffset : WaveEffect
  • Waypoints : TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
  • Wb : Utils
  • wColorMapFirst : TGA_HEADER
  • wColorMapLength : TGA_HEADER
  • wFlags : MPEG1AudioFrameHeader
  • Wg : Utils
  • wGammaDenominator : TGA_EXTENSION
  • wGammaNumerator : TGA_EXTENSION
  • wHeight : TGA_HEADER
  • wic : WICTranslate
  • wicFactory : BasicLoader , LoadScreen
  • width : DDS_HEADER , DirectX::TexMetadata , DirectX::Image , MPEG1VideoSeqHeader
  • windowVisible : Clipboard::sealed
  • wJobHour : TGA_EXTENSION
  • wJobMinute : TGA_EXTENSION
  • wJobSecond : TGA_EXTENSION
  • WorkEmail : ContactPicker::sealed::SampleContact
  • WorkPhone : ContactPicker::sealed::SampleContact
  • worldMatrix : ConstantBufferChangesEveryPrim
  • wPixelDenominator : TGA_EXTENSION
  • wPixelNumerator : TGA_EXTENSION
  • Wr : Utils
  • writer : ScenarioContext , DatagramSocketSample::sealed
  • wSize : TGA_EXTENSION
  • wStampDay : TGA_EXTENSION
  • wStampHour : TGA_EXTENSION
  • wStampMinute : TGA_EXTENSION
  • wStampMonth : TGA_EXTENSION
  • wStampSecond : TGA_EXTENSION
  • wStampYear : TGA_EXTENSION
  • wVersionNumber : TGA_EXTENSION
  • wWidth : TGA_HEADER
  • wXOrigin : TGA_HEADER
  • wYOrigin : TGA_HEADER
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- x -

  • x : WaveEffect::Vertex , DirectX::Rect , Vector4< T > , Vector3< T > , Vector2< T >
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members - Variables

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Properties
  • Events
  • Related Functions
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
  • z

- y -

  • y : WaveEffect::Vertex , Vector2< T > , AmpPixel , DirectX::Rect , Vector4< T > , Vector3< T >
  • Yellow : sealed
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- k -

  • KernelSelection : ConvolutionKernels.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- l -

  • LastSoundEvent : Audio.h
  • latencyModeToggled : LowLatency.xaml.cpp
  • LEFT : StereoProjection.h
  • length() : BasicMath.h
  • LevelComplete : Simple3DGame.h
  • LevelStart : DirectXApp.h
  • LIBID_SampleMft0Lib : SampleMft0.h
  • LightingEffect : D2DLightingEffectsRenderer.h
  • LightingProperty : D2DLightingEffectsRenderer.h
  • LightPositionZ : D2DLightingEffectsRenderer.h
  • LimitingConeAngle : D2DLightingEffectsRenderer.h
  • LineList : SDKMesh.h
  • LineListAdjacent : SDKMesh.h
  • LineStrip : SDKMesh.h
  • LineStripAdjacent : SDKMesh.h
  • Live : simpleInk.h
  • LOAD_SCANLINE : DirectXTexConvert.cpp
  • LOAD_SCANLINE2 : DirectXTexConvert.cpp
  • LOAD_SCANLINE3 : DirectXTexConvert.cpp
  • LoadGame : DirectXApp.h
  • Loading : DirectXApp.h
  • localClientButtonClicked : LowLatency.xaml.cpp
  • LocalOffsetX : D2D3DTransformsRenderer.h
  • LocalOffsetY : D2D3DTransformsRenderer.h
  • LocalOffsetZ : D2D3DTransformsRenderer.h
  • LODWORD : decoder.cpp
  • LONLAT_GAIN : LonLatController.h
  • LONLATKEY_GAIN : LonLatController.h
  • LookupByName() : Texconv.cpp
  • LookupByValue() : Texconv.cpp
  • LPSDKMESHVERTEXELEMENT : SDKMesh.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- m -

  • main() : D2DTextAnimation.cpp , D2DBasicAnimation.cpp , CommandListSample.cpp , GeometryRealizationSample.cpp , DirectXApp.cpp , CoreWindowEvents.cpp , DirectXApp.cpp , D2DInterpolationModes.cpp , obj2vbo.cpp , DirectXApp.cpp , simpleInk.cpp , ShapesPuzzle.cpp , CompositeModes.cpp , D2DPerspectiveTransform.cpp , DirectXApp.cpp , main.cpp , TriColorWindow.cpp , Main.cpp , DirectXApp.cpp , Main.cpp , DirectXApp.cpp , Main.cpp , D2DEffectsHelloWorld.cpp , ConvolveMatrixEffect.cpp , SaveAsImageFileSample.cpp , Main.cpp , DirectXApp.cpp , DWriteHelloWorld.cpp , D2DEffectsOnPrimitives.cpp , DirectXApp.cpp , DWriteHitTesting.cpp , DWriteInlineObject.cpp , DirectXApp.cpp , DWriteParagraphText.cpp , DWriteVerticalText.cpp
  • MainMenu : MarbleMaze.h
  • Maintain : AutoThrottle.h
  • MAKE_DWORD() : Parse.cpp
  • MAKE_DWORD_HOSTORDER() : Parse.cpp
  • MAKE_WORD() : Parse.cpp
  • MAKEFOURCC : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • MakeUnicodeCodepoint() : pch.h
  • MarginBottomStateKey : RotateImageViewModel.cpp
  • MarginLeftStateKey : RotateImageViewModel.cpp
  • MarginRightStateKey : RotateImageViewModel.cpp
  • MarginTopStateKey : RotateImageViewModel.cpp
  • MatrixStereoProjectionFovLH() : StereoProjection.cpp , StereoProjection.h , StereoProjection.cpp , StereoProjection.h
  • MAX_D3D11_VERTEX_STREAMS : SDKMesh.cpp
  • MAX_FRAME_NAME : SDKMesh.h
  • MAX_GUID_STRING_SIZE : LanId.xaml.cpp
  • MAX_HIGH_SCORES : UserInterface.h
  • MAX_MATERIAL_NAME : SDKMesh.h
  • MAX_MATERIAL_PATH : SDKMesh.h
  • MAX_MESH_NAME : SDKMesh.h
  • MAX_POLY_VERTICES : Shape.h
  • MAX_STREAMS : MPEG1Src.h
  • MAX_SUBSET_NAME : SDKMesh.h
  • MAX_TEXTURE_NAME : SDKMesh.h
  • MAX_VERTEX_ELEMENTS : SDKMesh.h
  • MAX_VERTEX_STREAMS : SDKMesh.h
  • MAX_VIDEO_HEIGHT : decoder.cpp
  • MAX_VIDEO_WIDTH : decoder.cpp
  • MaxHeight : CartoonizeImageViewModel.cpp
  • MaxNumberOfPictures : HubPhotoGroup.cpp , MonthGroup.cpp
  • MaxPhysicsTimestep : Physics.h
  • MaxTemplateImages : WideFiveImageTile.cpp
  • MaxVelocity : Physics.h
  • MaxWidth : CartoonizeImageViewModel.cpp
  • ME_CAN_SEEK : meplayer.h
  • MenuChangeEvent : Audio.h
  • MenuSelectedEvent : Audio.h
  • MEPlaybackNative : frameworkview.h
  • MeshID : Collision.h
  • METHODASYNCCALLBACK : Common.h
  • Mft0 : SampleMft0.h
  • MILLISECONDS_TO_VISUALIZE : PlotData.h
  • MinAudibleCollisionSpeed : Physics.h
  • MINIMUMBMPSIZE : CropImageViewModel.cpp
  • MinVelocity : Physics.h
  • MoveLookControllerState : MoveLookController.h
  • MOVEMENT_GAIN : MoveLookController.cpp
  • Moving : PaperRenderer.h
  • MPEG1_AUDIO_COPYRIGHT_BIT : Parse.h
  • MPEG1_Audio_DualChannel : Parse.h
  • MPEG1_AUDIO_FRAME_HEADER_SIZE : Parse.h
  • MPEG1_Audio_JointStereo : Parse.h
  • MPEG1_Audio_Layer1 : Parse.h
  • MPEG1_Audio_Layer2 : Parse.h
  • MPEG1_Audio_Layer3 : Parse.h
  • MPEG1_AUDIO_ORIGINAL_BIT : Parse.h
  • MPEG1_AUDIO_PRIVATE_BIT : Parse.h
  • MPEG1_AUDIO_PROTECTION_BIT : Parse.h
  • MPEG1_Audio_SingleChannel : Parse.h
  • MPEG1_Audio_Stereo : Parse.h
  • MPEG1_MAX_PACKET_SIZE : Parse.h
  • MPEG1_PACK_HEADER_SIZE : Parse.h
  • MPEG1_PACK_START_CODE : Parse.h
  • MPEG1_PACKET_HEADER_MAX_SIZE : Parse.h
  • MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE : Parse.h
  • MPEG1_PACKET_HEADER_MIN_SIZE : Parse.h
  • MPEG1_SEQUENCE_HEADER_CODE : Parse.h
  • MPEG1_START_CODE_PREFIX : Parse.h
  • MPEG1_STOP_CODE : Parse.h
  • MPEG1_STREAMTYPE_ALL_AUDIO : Parse.h
  • MPEG1_STREAMTYPE_ALL_VIDEO : Parse.h
  • MPEG1_STREAMTYPE_AUDIO_MASK : Parse.h
  • MPEG1_STREAMTYPE_DATA_MASK : Parse.h
  • MPEG1_STREAMTYPE_PADDING : Parse.h
  • MPEG1_STREAMTYPE_PRIVATE1 : Parse.h
  • MPEG1_STREAMTYPE_PRIVATE2 : Parse.h
  • MPEG1_STREAMTYPE_RESERVED : Parse.h
  • MPEG1_STREAMTYPE_VIDEO_MASK : Parse.h
  • MPEG1_SYSTEM_HEADER_CODE : Parse.h
  • MPEG1_SYSTEM_HEADER_MIN_SIZE : Parse.h
  • MPEG1_SYSTEM_HEADER_PREFIX : Parse.h
  • MPEG1_SYSTEM_HEADER_STREAM : Parse.h
  • MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE : Parse.h
  • MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE : decoder.h , Parse.h , decoder.h
  • MPEG1AudioFlags : Parse.h
  • MPEG1AudioLayer : Parse.h
  • MPEG1AudioMode : Parse.h
  • mul() : BasicMath.h
  • mulDouble() : DoublePrecisionMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- n -

  • NeighborWindowKey : CartoonizeImageViewModel.cpp
  • NOMINMAX : DirectXTexP.h
  • None : MoveLookController.h , MarbleMaze.h , GameInfoOverlay.h , simpleInk.cpp , MoveLookController.h
  • NORMAL : StereoProjection.h
  • normalize() : BasicMath.h
  • NotSaved : SaveAsImageFileSample.h
  • NUM_OBJECTS_TO_REQUEST : Constants.h
  • NUM_PIXELS_PER_BLOCK : BC.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- o -

  • operator*() : BasicMath.h
  • operator+() : BasicMath.h
  • operator-() : BasicMath.h
  • operator/() : BasicMath.h
  • operator<() : obj2vbo.cpp
  • OPT_DDS_DWORD_ALIGN : Texconv.cpp
  • OPT_FILETYPE : Texconv.cpp
  • OPT_FILTER : Texconv.cpp
  • OPT_FORMAT : Texconv.cpp
  • OPT_HEIGHT : Texconv.cpp
  • OPT_HFLIP : Texconv.cpp
  • OPT_MIPLEVELS : Texconv.cpp
  • OPT_NOLOGO : Texconv.cpp
  • OPT_OUTPUTDIR : Texconv.cpp
  • OPT_PREFIX : Texconv.cpp
  • OPT_SEPALPHA : Texconv.cpp
  • OPT_SRGB : Texconv.cpp
  • OPT_SRGBI : Texconv.cpp
  • OPT_SRGBO : Texconv.cpp
  • OPT_SUFFIX : Texconv.cpp
  • OPT_USE_DX10 : Texconv.cpp
  • OPT_VFLIP : Texconv.cpp
  • OPT_WIDTH : Texconv.cpp
  • OPTIONS : Texconv.cpp
  • OSC_START_X : Scenario3.xaml.h
  • OSC_START_Y : Scenario3.xaml.h
  • OSC_TOTAL_HEIGHT : Scenario3.xaml.h
  • OSC_X_LENGTH : Scenario3.xaml.h
  • OurFillRect() : decoder.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- a -

  • Absolute : SDKMesh.h
  • Action : LowLatency.xaml.cpp
  • ActivationEntryPoint : frameworkview.h
  • Active : MoveLookController.h , Simple3DGame.h , MoveLookController.h , Simple3DGame.h
  • AddConstructionPaper : PostcardRenderer.h
  • AddEffect : PostcardRenderer.h
  • AddImage : PostcardRenderer.h
  • AddSignature : PostcardRenderer.h
  • AddText : PostcardRenderer.h
  • AdvanceBufferPointer() : Parse.cpp
  • AlignCenter : UserInterface.h
  • AlignFar : UserInterface.h
  • AlignNear : UserInterface.h
  • AlignType : UserInterface.h
  • AnySelected() : simpleInk.cpp
  • AppendContactFieldValues() : ScenarioSingle.xaml.cpp
  • AppendValue() : ContactPickerPage.xaml.cpp
  • ApplyCartoonEffectAmp() : AmpCartoon.h , AmpCartoon.cpp
  • ApplyCartoonEffectPPL() : PPLCartoon.h , PPLCartoon.cpp
  • ApplyColorSimplifier() : AmpCartoon.cpp
  • ApplyEdgeDetection() : AmpCartoon.cpp
  • Assert : pch.h
  • AsSimpleProvider() : TriColorWindow.cpp
  • AUDIO_FILE_NAME : AudioCapture.xaml.h , WASAPICapture.h
  • Azimuth : D2DLightingEffectsRenderer.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- b -

  • BADGE_TILE_ID : ScenarioInput3.xaml.cpp
  • BAR_GRAPH_STATE : public.h
  • BatchSize : TileUpdateScheduler.cpp
  • BC6H_MAX_INDICES : BC.h
  • BC6H_MAX_REGIONS : BC.h
  • BC7_MAX_INDICES : BC.h
  • BC7_MAX_REGIONS : BC.h
  • Bezier : simpleInk.h
  • Bits16 : SDKMesh.h
  • Bits32 : SDKMesh.h
  • BLOCK_LEN : BC4BC5.cpp
  • BLOCK_SIZE : BC4BC5.cpp
  • BoxBlur : ConvolutionKernels.h
  • BufferToDXType() : Invert.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- c -

  • c_NumBarsInGraph : fx2device.h
  • c_NumSwitches : fx2device.h
  • c_SegmentMask : fx2device.h
  • c_SegmentMaskCe : fx2device.h
  • C_UMAX : AmpPixel.h
  • C_VMAX : AmpPixel.h
  • C_WB : AmpPixel.h
  • C_WG : AmpPixel.h
  • C_WR : AmpPixel.h
  • CalculateMixFormatType() : Common.h
  • CalculateSobel() : AmpCartoon.cpp
  • CAppWindowProvider_CreateInstance() : AppWindowProvider.cpp , TriColorWindow.cpp
  • CheckHResult() : HttpRequest.h
  • CheckpointEvent : Audio.h
  • CheckpointState : MarbleMaze.h
  • ChkHr : pch.h
  • CHKHR : pch.h
  • clamp() : Grayscale.cpp
  • CleanCombobox() : Scenario2.xaml.cpp
  • CleanComboboxSc4() : Scenario4.xaml.cpp
  • CLSID_Mft0 : SampleMft0.h
  • CODEC_DDS : Texconv.cpp
  • CODEC_TGA : Texconv.cpp
  • CollisionEvent : Audio.h
  • COMPILETIMESTRLEN : S3_SendToDevice.xaml.cpp
  • ComputeScanlines() : DirectXTex.inl
  • containerName : SettingContainer.xaml.cpp
  • ContinueLevel : DirectXApp.h
  • CONTROLS_AREA_SIZE : Program.cpp
  • CONV_FLAGS_888 : DirectXTexTGA.cpp
  • CONV_FLAGS_EXPAND : DirectXTexTGA.cpp
  • CONV_FLAGS_INVERTX : DirectXTexTGA.cpp
  • CONV_FLAGS_INVERTY : DirectXTexTGA.cpp
  • CONV_FLAGS_NONE : DirectXTexTGA.cpp
  • CONV_FLAGS_RLE : DirectXTexTGA.cpp
  • CONV_FLAGS_SWIZZLE : DirectXTexTGA.cpp
  • CONVERSION_FLAGS : DirectXTexTGA.cpp
  • convert() : DoublePrecisionMath.h
  • Convert() : ToneSampleGenerator.h
  • Convert< float >() : ToneSampleGenerator.cpp
  • Convert< short >() : ToneSampleGenerator.cpp
  • ConvertRect() : MarbleMaze.cpp
  • create_map() : HiloPage.cpp
  • CreateAudioMediaType() : MPEG1Src.cpp
  • CreateBrush() : simpleInk.cpp
  • CreateDDSTextureFromMemory() : DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h
  • CreateDefaultStereoParameters() : Stereo3DMatrixHelper.h , Stereo3DMatrixHelper.cpp
  • CreateGeometryRealizationFactory() : GeometryRealizationPackage.cpp , GeometryRealizationPackage.h , GeometryRealizationPackage.cpp , GeometryRealizationPackage.h
  • CreateShaderInputView() : InvertModule.cpp
  • CreateShaderOutputView() : InvertModule.cpp
  • CreateVideoMediaType() : MPEG1Src.cpp
  • cross() : BasicMath.h
  • CTriColorControlProvider_CreateInstance() : TriColorWindow.cpp
  • CTriColorFragmentProvider_CreateInstance() : TriColorWindow.cpp
  • CURSOR_ID_NONE : Shape.h
  • CUSTOM_DATA_CONTENT : ShareCustomData.xaml.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- d -

  • D2D13DPerspectiveTransform : D2D3DTransformsRenderer.h
  • D2D13DTransform : D2D3DTransformsRenderer.h
  • D3DDeviceEventHandler() : DirectXBase.h
  • Damping : Physics.h
  • DATA_FORMAT_NAME : MainPage.xaml.h
  • DATE_BUFFER_SIZE : CalendarExtensions.cpp
  • DbgPrint() : support.h
  • DDS_ALPHA : DDSTextureLoader.cpp , DDS.h
  • DDS_CUBEMAP : DDSTextureLoader.cpp , DDS.h
  • DDS_CUBEMAP_ALLFACES : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_NEGATIVEX : DDSTextureLoader.cpp , DDS.h
  • DDS_CUBEMAP_NEGATIVEY : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_NEGATIVEZ : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_POSITIVEX : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_POSITIVEY : DDSTextureLoader.cpp , DDS.h
  • DDS_CUBEMAP_POSITIVEZ : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_FLAGS_VOLUME : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_FOURCC : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_LINEARSIZE : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_MIPMAP : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_PITCH : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_TEXTURE : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_VOLUME : DDSTextureLoader.cpp , DDS.h
  • DDS_HEIGHT : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_LUMINANCE : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_LUMINANCEA : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_MAGIC : DDSTextureLoader.cpp
  • DDS_PAL8 : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_RGB : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_RGBA : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_SURFACE_FLAGS_CUBEMAP : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_SURFACE_FLAGS_MIPMAP : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_SURFACE_FLAGS_TEXTURE : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_WIDTH : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • Deactivated : DirectXApp.h
  • DEADSPOT : MoveLookController.cpp
  • DebugPrint() : Scenario1.xaml.cpp
  • DebugPrint2() : Scenario2.xaml.cpp
  • DebugPrintSc4() : Scenario4.xaml.cpp
  • DECLSPEC_UUID() : FlowLayout.h , FlowSink.h , FlowSource.h
  • Decrease : AutoThrottle.h
  • DEFFMT : Texconv.cpp
  • DEFINE_DEVSVCGUID : S6_DeviceStatus.xaml.cpp
  • DEFINE_DEVSVCPROPKEY : S6_DeviceStatus.xaml.cpp
  • DEFINE_GUID() : Invert.h , Grayscale.h , WUDFOsrUsbPublic.h , WaveEffect.h , RippleEffect.h , WUDFOsrUsbPublic.h , Grayscale.h , WUDFOsrUsbPublic.h , RippleEffect.h , WaveEffect.h , Grayscale.h , Invert.h , Grayscale.h
  • DelayTimerInfo : Constants.cpp
  • DelayTimerMilliseconds : Constants.cpp
  • DelayTimerSelectedIndex : Constants.cpp
  • DelayTimerStatus : Constants.cpp
  • Deleting : PaperRenderer.h
  • DeviceLostEventHandler() : Renderer.h
  • DiffuseConstant : D2DLightingEffectsRenderer.h
  • DirectCompute : DirectXFractal.h
  • DIRECTX_TEX_VERSION : DirectXTex.h
  • DistantDiffuse : D2DLightingEffectsRenderer.h
  • DistantSpecular : D2DLightingEffectsRenderer.h
  • DllAddRef() : PolarEffect.h , MPEG1Src.h , PolarEffect.h , MPEG1Src.h
  • DllCanUnloadNow() : dllmain.cpp , dll.cpp , dllmain.cpp
  • DllGetActivationFactory() : dllmain.cpp , dll.cpp , dllmain.cpp , dll.cpp , dllmain.cpp
  • DllGetClassObject() : dllmain.cpp , dll.cpp , dllmain.cpp , dll.cpp , dllmain.cpp
  • DllMain() : dllmain.cpp , dll.cpp , dllmain.cpp , dll.cpp , dllmain.cpp
  • DllRelease() : MPEG1Src.h , PolarEffect.h , MPEG1Src.h
  • DocumentLoadedCallback() : Document.h
  • dot() : BasicMath.h
  • double2 : DoublePrecisionMath.h
  • double4x4 : DoublePrecisionMath.h
  • DrawTypes : D2DPageRendererContext.h
  • Dynamics : DirectXApp.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- e -

  • EdgeDetection() : AmpCartoon.cpp
  • ElementSet : UserInterface.h
  • Elevation : D2DLightingEffectsRenderer.h
  • Emboss : ConvolutionKernels.h
  • Erase : simpleInk.cpp
  • ERROR_RESOURCE_VALUE : SDKMesh.h
  • EventIsErase() : simpleInk.cpp
  • EventIsInk() : simpleInk.cpp
  • EventIsSelect() : simpleInk.cpp
  • EVENTSPACING : ImageBrowserViewModel.cpp , HubPhotoGroup.cpp
  • EXIFOrientationPropertyName : RotateImageViewModel.cpp , CropImageViewModel.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- f -

  • FallingEvent : Audio.h
  • FILE_DEVICE_OSRUSBFX2 : public.h
  • FILE_PLAYBACK : public.h
  • FileDateMapKey : ImageViewModel.cpp
  • filename : Files.xaml.cpp
  • FilePathMapKey : ImageViewModel.cpp
  • FindMeshIndexByName() : MarbleMaze.cpp
  • float2 : BasicMath.h
  • float3 : BasicMath.h
  • float4 : BasicMath.h
  • float4x4 : BasicMath.h
  • Floor : Collision.h
  • FLUSH_INTERVAL_SEC : WASAPICapture.h
  • Focus : D2DLightingEffectsRenderer.h
  • FOURCC_NV12 : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp
  • FOURCC_UYVY : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • FOURCC_YUY2 : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp
  • FractalTechnique : DirectXFractal.h
  • FrameTransformType : SDKMesh.h
  • FrameWorkload : AutoThrottle.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- g -

  • g_MediaSubtypes : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp
  • g_pFilters : Texconv.cpp
  • g_pFormats : Texconv.cpp
  • g_pOptions : Texconv.cpp
  • g_pSaveFileTypes : Texconv.cpp
  • g_TGA20_Signature : DirectXTexTGA.cpp
  • g_this : audiovideoptr.xaml.cpp
  • GameComplete : Simple3DGame.h
  • GameInfoOverlayCommand : GameInfoOverlay.h
  • GameInfoOverlayState : DirectXApp.h
  • GameOverCompleted : DirectXApp.h
  • GameOverExpired : DirectXApp.h
  • GameState : Simple3DGame.h , MarbleMaze.h , Simple3DGame.h
  • GameStats : DirectXApp.h
  • GaussianDistribution() : D3DPostProcessing.cpp
  • GetAudioBitRate() : Parse.cpp
  • GetDefaultStride() : Grayscale.cpp , Invert.cpp , PolarEffect.cpp , Grayscale.cpp , Invert.cpp , PolarEffect.cpp
  • GetDisplayContent() : ScenarioInput4.xaml.cpp
  • GetFrameRate() : Parse.cpp
  • GetImageSize() : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • GetPixelAspectRatio() : Parse.cpp
  • GetPointerEventType() : simpleInk.cpp
  • GetPointerToPixelData() : ImageUtilities.cpp , ImageUtilities.h
  • GetSampleOffsetsWeightsForBlur() : D3DPostProcessing.cpp
  • GetSamplingFrequency() : Parse.cpp
  • GetStreamMajorType() : MPEG1Src.cpp
  • GlobalOffsetX : D2D3DTransformsRenderer.h
  • GlobalOffsetY : D2D3DTransformsRenderer.h
  • GlobalOffsetZ : D2D3DTransformsRenderer.h
  • GlyphOrientation : TextAnalysis.h
  • GlyphOrientationBottomToTopLeftToRight : TextAnalysis.h
  • GlyphOrientationBottomToTopRightToLeft : TextAnalysis.h
  • GlyphOrientationCW0 : TextAnalysis.h
  • GlyphOrientationCW180 : TextAnalysis.h
  • GlyphOrientationCW270 : TextAnalysis.h
  • GlyphOrientationCW90 : TextAnalysis.h
  • GlyphOrientationES : TextAnalysis.h
  • GlyphOrientationFH : TextAnalysis.h
  • GlyphOrientationFlipDiagonal : TextAnalysis.h
  • GlyphOrientationFlipHorizontal : TextAnalysis.h
  • GlyphOrientationFlipVertical : TextAnalysis.h
  • GlyphOrientationFV : TextAnalysis.h
  • GlyphOrientationLeftToRightBottomToTop : TextAnalysis.h
  • GlyphOrientationLeftToRightTopToBottom : TextAnalysis.h
  • GlyphOrientationMode : TextAnalysis.h
  • GlyphOrientationModeDefault : TextAnalysis.h
  • GlyphOrientationModeStacked : TextAnalysis.h
  • GlyphOrientationModeTotal : TextAnalysis.h
  • GlyphOrientationNE : TextAnalysis.h
  • GlyphOrientationRightToLeftBottomToTop : TextAnalysis.h
  • GlyphOrientationRightToLeftTopToBottom : TextAnalysis.h
  • GlyphOrientationSW : TextAnalysis.h
  • GlyphOrientationTopToBottomLeftToRight : TextAnalysis.h
  • GlyphOrientationTopToBottomRightToLeft : TextAnalysis.h
  • GlyphOrientationWN : TextAnalysis.h
  • Goal : MarbleMaze.h
  • Gravity : Physics.h
  • Ground : Collision.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- h -

  • HAS_FLAG : Parse.cpp
  • HighScoreDisplay : MarbleMaze.h
  • HighScoreEntries : Simple3DGame.h , UserInterface.h , Simple3DGame.h
  • HILO_PHOTO_FILE_NOT_FOUND : HiloCommonDefinitions.h
  • HorizontalSmear : ConvolutionKernels.h
  • htonl : Parse.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- i -

  • identity() : BasicMath.h
  • identityDouble() : DoublePrecisionMath.h
  • IFACEMETHODIMP_() : RippleEffect.cpp , WaveEffect.cpp , CustomTextRenderer.cpp
  • IID_IMft0 : SampleMft0.h
  • IMAGE_TRANSFORM_FN : Grayscale.h , PolarEffect.h , Grayscale.h , PolarEffect.h
  • IMft0 : SampleMft0.h
  • IMft0Vtbl : SampleMft0.h
  • Increase : AutoThrottle.h
  • InflateRect() : MarbleMaze.cpp
  • InGameActive : MarbleMaze.h
  • InGamePaused : MarbleMaze.h
  • INITGUID : ScenarioInput1.xaml.cpp
  • Initial : MarbleMaze.h
  • INITIAL_BUFFER_SIZE : MPEG1Src.h
  • InitializeFrameData() : PPLCartoon.cpp
  • Ink : simpleInk.cpp
  • InkState : InkRenderer.h
  • IntersectRayTriangle() : Physics.h
  • INVALID_ANIMATION_DATA : SDKMesh.h
  • INVALID_FRAME : SDKMesh.h
  • INVALID_MATERIAL : SDKMesh.h
  • INVALID_MESH : SDKMesh.h
  • INVALID_SAMPLER_SLOT : SDKMesh.h
  • INVALID_SUBSET : SDKMesh.h
  • INVERTED : StereoProjection.h
  • IOCTL_INDEX : public.h
  • IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY : public.h
  • IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY : public.h
  • IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR : public.h
  • IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE : public.h
  • IOCTL_OSRUSBFX2_PLAY_FILE : public.h
  • IOCTL_OSRUSBFX2_READ_SWITCHES : public.h
  • IOCTL_OSRUSBFX2_REENUMERATE_DEVICE : public.h
  • IOCTL_OSRUSBFX2_RESET_DEVICE : public.h
  • IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY : public.h
  • IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY : public.h
  • IsBackgroundThread() : TaskExtensions.cpp , TaskExtensions.h
  • ISBITMASK : DDSTextureLoader.cpp
  • IsCompressed() : DirectXTex.inl
  • IsErrorResource() : SDKMesh.h
  • IsLeadingSurrogate() : pch.h
  • IsMainThread() : TaskExtensions.h , TaskExtensions.cpp
  • IsPacked() : DirectXTex.inl
  • IsSRGB() : DirectXTex.inl
  • IsSurrogate() : pch.h
  • IsTrailingSurrogate() : pch.h
  • IsTypeless() : DirectXTex.inl
  • IsValid() : DirectXTex.inl
  • IsVideo() : DirectXTex.inl
  • items : FileSystemRepository.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- p -

  • PaperMode : PaperRenderer.h
  • ParsePTS() : Parse.cpp
  • ParseStreamData() : Parse.cpp
  • ParseStreamId() : Parse.cpp
  • Passthrough : ConvolutionKernels.h
  • Pause : DirectXApp.h
  • PBAR_GRAPH_STATE : public.h
  • PeriodicTimerCount : Constants.cpp
  • PeriodicTimerInfo : Constants.cpp
  • PeriodicTimerMilliseconds : Constants.cpp
  • PeriodicTimerSelectedIndex : Constants.cpp
  • PeriodicTimerStatus : Constants.cpp
  • Perspective : D2D3DTransformsRenderer.h
  • PFILE_PLAYBACK : public.h
  • PhasesKey : CartoonizeImageViewModel.cpp
  • PHOTO_FILE_NAME : AdvancedCapture.xaml.h , BasicCapture.xaml.h
  • PhysicsTimestep : Physics.h
  • PI_F : BasicMath.h
  • PlayAgain : GameInfoOverlay.h
  • PlayLevel : DirectXApp.h
  • PleaseWait : GameInfoOverlay.h
  • PointDiffuse : D2DLightingEffectsRenderer.h
  • PointerEventType : simpleInk.cpp
  • PointInRect() : UserInterface.cpp
  • PointList : SDKMesh.h
  • PointSpecular : D2DLightingEffectsRenderer.h
  • PointToTouch() : MarbleMaze.cpp
  • PolarTransformer : PolarEffect.h
  • PopulateInitialRGBValues() : AmpCartoon.cpp
  • PostGameResults : MarbleMaze.h
  • PreGameCountdown : MarbleMaze.h
  • PREROLL_DURATION_SEC : MFSampleGenerator.h
  • PressResultState : DirectXApp.h
  • Preview : D2DPageRendererContext.h
  • previewButtonClicked : LowLatency.xaml.cpp
  • previewSetupCompleted : LowLatency.xaml.cpp
  • PrintFormat() : Texconv.cpp
  • PrintInfo() : Texconv.cpp
  • Printing : D2DPageRendererContext.h
  • PrintList() : Texconv.cpp
  • PrintLogo() : Texconv.cpp
  • PrintUsage() : Texconv.cpp
  • PSWITCH_STATE : public.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- q -

  • QuadPatchList : SDKMesh.h
  • QueryMapKey : ImageViewModel.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- r -

  • READ_SIZE : MPEG1Src.h
  • ReadAudioFrameHeader() : Parse.h , Parse.cpp , Parse.h
  • ReadingDirection : TextAnalysis.h
  • ReadingDirectionBottomToTopLeftToRight : TextAnalysis.h
  • ReadingDirectionBottomToTopRightToLeft : TextAnalysis.h
  • ReadingDirectionE : TextAnalysis.h
  • ReadingDirectionEs : TextAnalysis.h
  • ReadingDirectionLeftToRightBottomToTop : TextAnalysis.h
  • ReadingDirectionLeftToRightTopToBottom : TextAnalysis.h
  • ReadingDirectionN : TextAnalysis.h
  • ReadingDirectionNe : TextAnalysis.h
  • ReadingDirectionPrimaryAxis : TextAnalysis.h
  • ReadingDirectionPrimaryProgression : TextAnalysis.h
  • ReadingDirectionRightToLeftBottomToTop : TextAnalysis.h
  • ReadingDirectionRightToLeftTopToBottom : TextAnalysis.h
  • ReadingDirectionS : TextAnalysis.h
  • ReadingDirectionSecondaryProgression : TextAnalysis.h
  • ReadingDirectionSw : TextAnalysis.h
  • ReadingDirectionTopToBottomLeftToRight : TextAnalysis.h
  • ReadingDirectionTopToBottomRightToLeft : TextAnalysis.h
  • ReadingDirectionW : TextAnalysis.h
  • ReadingDirectionWn : TextAnalysis.h
  • ReadVideoSequenceHeader() : Parse.cpp , Parse.h , Parse.cpp , Parse.h
  • Ready : PostcardRenderer.h
  • REALIZATION_CREATION_OPTIONS : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_ALIASED : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_ANTI_ALIASED : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_FILLED : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_STROKED : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_UNREALIZED : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE_DEFAULT : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE_FORCE_REALIZED : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE_FORCE_UNREALIZED : GeometryRealizationPackage.h
  • REALIZATIONS_DECLARE_INTERFACE : GeometryRealizationPackage.h
  • recordingStarted : LowLatency.xaml.cpp
  • RecordMainThread() : TaskExtensions.cpp , TaskExtensions.h
  • RectToRectF() : TriColorWindow.cpp
  • Relative : SDKMesh.h
  • Rendering : D2DPageRendererContext.h
  • RenderingMode : simpleInk.h
  • RenderSampleType : Common.h
  • Reset1() : Scenario1.xaml.cpp
  • Reset2() : Scenario2.xaml.cpp
  • ResetSc4() : Scenario4.xaml.cpp
  • ResourcesLoaded : DirectXApp.h
  • RIGHT : StereoProjection.h
  • RIPPLE_PROP : RippleEffect.h
  • RIPPLE_PROP_AMPLITUDE : RippleEffect.h
  • RIPPLE_PROP_CENTER : RippleEffect.h
  • RIPPLE_PROP_FREQUENCY : RippleEffect.h
  • RIPPLE_PROP_PHASE : RippleEffect.h
  • RIPPLE_PROP_SPREAD : RippleEffect.h
  • RollingEvent : Audio.h
  • ROOM_BOUNDS : Simple3DTouch.h
  • ROTATION_GAIN : MoveLookController.cpp
  • rotationArbitrary() : BasicMath.h
  • RotationStateKey : RotateImageViewModel.cpp
  • rotationX() : BasicMath.h
  • RotationX : D2D3DTransformsRenderer.h
  • rotationX() : BasicMath.h
  • rotationY() : BasicMath.h
  • RotationY : D2D3DTransformsRenderer.h
  • rotationY() : BasicMath.h
  • rotationZ() : BasicMath.h
  • RotationZ : D2D3DTransformsRenderer.h
  • rotationZ() : BasicMath.h
  • rotationZDouble() : DoublePrecisionMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- s -

  • SAFE_ARRAYDELETE : Common.h
  • SAFE_DELETE : SDKMesh.h , Common.h
  • SAFE_DELETE_ARRAY : SDKMesh.h
  • safe_handle() : scoped.h
  • SAFE_RELEASE : SDKMesh.h , Common.h
  • SafeAcquire() : pch.h
  • SafeArrayDelete() : PolarEffect.h
  • SafeRelease() : PolarEffect.h , Grayscale.h , decoder.h , MPEG1Src.h , PolarEffect.h , Common.h , pch.h , common.h , Grayscale.h , decoder.h , MPEG1Src.h
  • SafeReplace() : pch.h
  • SAMPLE_QUEUE : MPEG1Src.h
  • SAMPLE_TASK_ENTRY_POINT : ScenarioInput1.xaml.cpp
  • SAMPLE_TASK_NAME : ScenarioInput1.xaml.cpp
  • SampleBackgroundTaskEntryPoint : Constants.h
  • SampleBackgroundTaskName : Constants.h
  • SampleBackgroundTaskWithConditionName : Constants.h
  • SampleList : MPEG1Src.h
  • SampleMode : PostcardRenderer.h
  • SampleRequestMatch() : MPEG1Src.cpp
  • SampleType16BitPCM : Common.h
  • SampleTypeFloat : Common.h
  • SampleTypeUnknown : Common.h
  • Save : MarbleMaze.h
  • Saved : SaveAsImageFileSample.h
  • SaveToDDSFile() : DirectXTex.inl
  • SaveToDDSMemory() : DirectXTex.inl
  • Saving : SaveAsImageFileSample.h
  • scale() : BasicMath.h
  • scaleDouble() : DoublePrecisionMath.h
  • ScaleX : D2D3DTransformsRenderer.h
  • ScaleY : D2D3DTransformsRenderer.h
  • ScopedAlignedArrayFloat : scoped.h
  • ScopedAlignedArrayXMVECTOR : scoped.h
  • ScopedHandle : scoped.h
  • ScreenSavingState : SaveAsImageFileSample.h
  • SDKMESH_FILE_VERSION : SDKMesh.h
  • SDKMeshIndexType : SDKMesh.h
  • SDKMeshPrimitiveType : SDKMesh.h
  • SDKMESHVERTEXELEMENT : SDKMesh.h
  • Select : simpleInk.cpp
  • SelectAll() : simpleInk.cpp
  • ServicingCompleteTaskEntryPoint : Constants.h
  • ServicingCompleteTaskName : Constants.h
  • SetSize : TileUpdateScheduler.cpp
  • settingName : ClearScenario.xaml.cpp , CompositeSettings.xaml.cpp , DataChangedEvent.xaml.cpp , SettingContainer.xaml.cpp , Settings.xaml.cpp , SetVersion.xaml.cpp
  • settingName1 : ClearScenario.xaml.cpp , CompositeSettings.xaml.cpp
  • settingName2 : ClearScenario.xaml.cpp , CompositeSettings.xaml.cpp
  • settingValue : SettingContainer.xaml.cpp , Settings.xaml.cpp
  • settingValue0 : SetVersion.xaml.cpp
  • settingValue1 : ClearScenario.xaml.cpp , CompositeSettings.xaml.cpp , SetVersion.xaml.cpp
  • settingValue2 : ClearScenario.xaml.cpp , CompositeSettings.xaml.cpp
  • sgn_sqrt() : DrawingObject.cpp
  • SIGN_EXTEND : BC.h
  • SimpleEdgeDetect : ConvolutionKernels.h
  • SimpleSharpen : ConvolutionKernels.h
  • SimplifyIndexColumns() : AmpCartoon.cpp
  • SimplifyIndexRows() : AmpCartoon.cpp
  • SinglePass : DirectXFractal.h
  • Snapped : DirectXApp.h
  • SoundEvent : Audio.h
  • SourceState : MPEG1Src.h
  • SpecularConstant : D2DLightingEffectsRenderer.h
  • SpecularExponent : D2DLightingEffectsRenderer.h
  • SpotDiffuse : D2DLightingEffectsRenderer.h
  • SpotSpecular : D2DLightingEffectsRenderer.h
  • SS_BOTTOM : public.h
  • SS_BOTTOM_LEFT : public.h
  • SS_BOTTOM_RIGHT : public.h
  • SS_CENTER : public.h
  • SS_DOT : public.h
  • SS_TOP : public.h
  • SS_TOP_LEFT : public.h
  • SS_TOP_RIGHT : public.h
  • Stamping : PaperRenderer.h
  • START_POSITION : Simple3DTouch.h , BumpMapping.h
  • STATE_INVALID : MPEG1Src.h
  • STATE_OPENING : MPEG1Src.h
  • STATE_PAUSED : MPEG1Src.h
  • STATE_SHUTDOWN : MPEG1Src.h
  • STATE_STARTED : MPEG1Src.h
  • STATE_STOPPED : MPEG1Src.h
  • STDMETHODIMP_() : InlineImage.cpp , GeometryRealizationPackage.cpp
  • STEREO_CHANNEL : StereoProjection.h
  • STEREO_MODE : StereoProjection.h
  • STEREO_PARAMETERS : StereoProjection.h
  • StereoCreateDefaultParameters() : StereoProjection.cpp , StereoProjection.h , StereoProjection.cpp , StereoProjection.h
  • StereoProjectionFieldOfViewRightHand() : Stereo3DMatrixHelper.h , Stereo3DMatrixHelper.cpp
  • STORE_SCANLINE : DirectXTexConvert.cpp
  • StreamType : Parse.h
  • StreamType_AllAudio : Parse.h
  • StreamType_AllVideo : Parse.h
  • StreamType_Audio : Parse.h
  • StreamType_Data : Parse.h
  • StreamType_Padding : Parse.h
  • StreamType_Private1 : Parse.h
  • StreamType_Private2 : Parse.h
  • StreamType_Reserved : Parse.h
  • StreamType_Unknown : Parse.h
  • StreamType_Video : Parse.h
  • StrokeCompleted : InkRenderer.h
  • StrokeDrawing : InkRenderer.h
  • SurfaceScale : D2DLightingEffectsRenderer.h
  • Suspended : DirectXApp.h
  • SWITCH_STATE : public.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- t -

  • tangentVertexLayoutDesc : BumpMapping.cpp
  • TapToContinue : GameInfoOverlay.h
  • TEMP_PHOTO_FILE_NAME : AdvancedCapture.xaml.h
  • TEX_FILTER_MASK : DirectXTexP.h
  • TEXT_TILE_ID : ScenarioInput3.xaml.cpp
  • TGA_BLACK_AND_WHITE : DirectXTexTGA.cpp
  • TGA_BLACK_AND_WHITE_RLE : DirectXTexTGA.cpp
  • TGA_COLOR_MAPPED : DirectXTexTGA.cpp
  • TGA_COLOR_MAPPED_RLE : DirectXTexTGA.cpp
  • TGA_FLAGS_INTERLEAVED_2WAY : DirectXTexTGA.cpp
  • TGA_FLAGS_INTERLEAVED_4WAY : DirectXTexTGA.cpp
  • TGA_FLAGS_INVERTX : DirectXTexTGA.cpp
  • TGA_FLAGS_INVERTY : DirectXTexTGA.cpp
  • TGA_NO_IMAGE : DirectXTexTGA.cpp
  • TGA_TRUECOLOR : DirectXTexTGA.cpp
  • TGA_TRUECOLOR_RLE : DirectXTexTGA.cpp
  • TGADescriptorFlags : DirectXTexTGA.cpp
  • TGAImageType : DirectXTexTGA.cpp
  • ThreePhase : DirectXFractal.h
  • THROW_HR() : fx2device.h
  • ThrowIfFailed() : ImageUtilities.cpp , Common.h
  • ThumbnailImagePrefix : ThumbnailGenerator.cpp
  • ThumbnailsFolderName : TileUpdateScheduler.cpp
  • ThumbnailSize : ThumbnailGenerator.cpp
  • TimeExpired : Simple3DGame.h
  • TimeSpanToMilliseconds() : Scenario1.xaml.cpp
  • TimeTriggeredTaskName : Constants.h
  • toDegrees : Scenario1.xaml.cpp , Scenario2.xaml.cpp
  • TokenList : MPEG1Src.h
  • TONE_AMPLITUDE : ToneSampleGenerator.cpp
  • TONE_DURATION_SEC : ToneSampleGenerator.cpp
  • TransformChroma() : Grayscale.cpp
  • TransformEffect : D2D3DTransformsRenderer.h
  • TransformImage_NV12() : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • TransformImage_UYVY() : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • TransformImage_YUY2() : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • TransformProperty : D2D3DTransformsRenderer.h
  • translation() : BasicMath.h
  • translationDouble() : DoublePrecisionMath.h
  • transpose() : BasicMath.h
  • TriangleList : SDKMesh.h
  • TriangleListAdjacent : SDKMesh.h
  • TrianglePatchList : SDKMesh.h
  • TriangleStrip : SDKMesh.h
  • TriangleStripAdjacent : SDKMesh.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- u -

  • UIA_AutomationFocusChangedEventId : pch.h
  • UIA_AutomationIdPropertyId : pch.h
  • UIA_ControlTypePropertyId : pch.h
  • UIA_CustomControlTypeId : pch.h
  • UIA_HasKeyboardFocusPropertyId : pch.h
  • UIA_HelpTextPropertyId : pch.h
  • UIA_IsContentElementPropertyId : pch.h
  • UIA_IsControlElementPropertyId : pch.h
  • UIA_IsEnabledPropertyId : pch.h
  • UIA_IsKeyboardFocusablePropertyId : pch.h
  • UIA_IsPasswordPropertyId : pch.h
  • UIA_LocalizedControlTypePropertyId : pch.h
  • UIA_NamePropertyId : pch.h
  • UIA_ProviderDescriptionPropertyId : pch.h
  • UIA_SelectionItem_ElementSelectedEventId : pch.h
  • UIA_SelectionItemPatternId : pch.h
  • UIA_SelectionPatternId : pch.h
  • UIA_ValuePatternId : pch.h
  • UIA_ValueValuePropertyId : pch.h
  • UIA_WindowControlTypeId : pch.h
  • uint : BasicMath.h
  • UnicodeMax : pch.h
  • Unknown : frameworkview.h
  • UpdateEngineState : DirectXApp.h
  • usage() : obj2vbo.cpp
  • USE_PPLTASKS : pch.h
  • USE_STORE_SIMULATOR : App.xaml.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- v -

  • ValidateBufferSize() : Parse.cpp
  • ValidateRect() : Grayscale.cpp
  • VIDEO_FILE_NAME : BasicCapture.xaml.h , AdvancedCapture.xaml.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- w -

  • WaitForInput : MoveLookController.h
  • Waiting : Simple3DGame.h
  • WaitingForPress : DirectXApp.h
  • WaitingForResources : DirectXApp.h
  • Wall : Collision.h
  • WallFriction : Physics.h
  • WallRestitutionCoefficient : Physics.h
  • WAVE_PROP : WaveEffect.h
  • WAVE_PROP_FORCE_DWORD : WaveEffect.h
  • WAVE_PROP_OFFSET : WaveEffect.h
  • WAVE_PROP_SKEW_X : WaveEffect.h
  • WAVE_PROP_SKEW_Y : WaveEffect.h
  • WIN32_LEAN_AND_MEAN : pch.h
  • wmain() : Texconv.cpp
  • WorkItemInfo : Constants.cpp
  • WorkItemSelectedIndex : Constants.cpp
  • WorkItemStatus : Constants.cpp
  • WorkPriority : Constants.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • k
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • v
  • w
  • x
Here is a list of all file members with links to the files they belong to:

- x -

  • XAUDIO2_HELPER_FUNCTIONS : pch.h
  • XM_STRICT_VECTOR4 : pch.h
  • XMASSERT : StereoProjection.cpp
  • XML : WaveEffect.cpp , RippleEffect.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- _ -

  • __IMft0_FWD_DEFINED__ : SampleMft0.h
  • __IMft0_INTERFACE_DEFINED__ : SampleMft0.h
  • __Mft0_FWD_DEFINED__ : SampleMft0.h
  • __REQUIRED_RPCNDR_H_VERSION__ : SampleMft0.h
  • __samplemft0_h__ : SampleMft0.h
  • __SampleMft0Lib_LIBRARY_DEFINED__ : SampleMft0.h
  • _ASSERTE : MPEG1Src.h
  • _USE_MATH_DEFINES : BasicMath.h , D2DInterpolationModes.h , pch.h , ToneSampleGenerator.h , ExifExtensions.cpp , BasicMath.h , pch.h , BasicMath.h , pch.h , BasicMath.h , pch.h , BasicMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- l -

  • LOAD_SCANLINE : DirectXTexConvert.cpp
  • LOAD_SCANLINE2 : DirectXTexConvert.cpp
  • LOAD_SCANLINE3 : DirectXTexConvert.cpp
  • LODWORD : decoder.cpp
  • LONLAT_GAIN : LonLatController.h
  • LONLATKEY_GAIN : LonLatController.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- m -

  • MAKEFOURCC : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • MAX_D3D11_VERTEX_STREAMS : SDKMesh.cpp
  • MAX_FRAME_NAME : SDKMesh.h
  • MAX_GUID_STRING_SIZE : LanId.xaml.cpp
  • MAX_HIGH_SCORES : UserInterface.h
  • MAX_MATERIAL_NAME : SDKMesh.h
  • MAX_MATERIAL_PATH : SDKMesh.h
  • MAX_MESH_NAME : SDKMesh.h
  • MAX_SUBSET_NAME : SDKMesh.h
  • MAX_TEXTURE_NAME : SDKMesh.h
  • MAX_VERTEX_ELEMENTS : SDKMesh.h
  • MAX_VERTEX_STREAMS : SDKMesh.h
  • ME_CAN_SEEK : meplayer.h
  • METHODASYNCCALLBACK : Common.h
  • MILLISECONDS_TO_VISUALIZE : PlotData.h
  • MINIMUMBMPSIZE : CropImageViewModel.cpp
  • MOVEMENT_GAIN : MoveLookController.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- n -

  • NOMINMAX : DirectXTexP.h
  • NUM_OBJECTS_TO_REQUEST : Constants.h
  • NUM_PIXELS_PER_BLOCK : BC.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- o -

  • OSC_START_X : Scenario3.xaml.h
  • OSC_START_Y : Scenario3.xaml.h
  • OSC_TOTAL_HEIGHT : Scenario3.xaml.h
  • OSC_X_LENGTH : Scenario3.xaml.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- a -

  • Assert : pch.h
  • AUDIO_FILE_NAME : WASAPICapture.h , AudioCapture.xaml.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- b -

  • BADGE_TILE_ID : ScenarioInput3.xaml.cpp
  • BC6H_MAX_INDICES : BC.h
  • BC6H_MAX_REGIONS : BC.h
  • BC7_MAX_INDICES : BC.h
  • BC7_MAX_REGIONS : BC.h
  • BLOCK_LEN : BC4BC5.cpp
  • BLOCK_SIZE : BC4BC5.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- c -

  • C_UMAX : AmpPixel.h
  • C_VMAX : AmpPixel.h
  • C_WB : AmpPixel.h
  • C_WG : AmpPixel.h
  • C_WR : AmpPixel.h
  • ChkHr : pch.h
  • CHKHR : pch.h
  • CODEC_DDS : Texconv.cpp
  • CODEC_TGA : Texconv.cpp
  • COMPILETIMESTRLEN : S3_SendToDevice.xaml.cpp
  • containerName : SettingContainer.xaml.cpp
  • CUSTOM_DATA_CONTENT : ShareCustomData.xaml.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- d -

  • DATA_FORMAT_NAME : MainPage.xaml.h
  • DDS_ALPHA : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_ALLFACES : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_NEGATIVEX : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_NEGATIVEY : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_NEGATIVEZ : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_POSITIVEX : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_POSITIVEY : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_CUBEMAP_POSITIVEZ : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_FLAGS_VOLUME : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_FOURCC : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_LINEARSIZE : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_MIPMAP : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_PITCH : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_TEXTURE : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEADER_FLAGS_VOLUME : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_HEIGHT : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_LUMINANCE : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_LUMINANCEA : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_MAGIC : DDSTextureLoader.cpp
  • DDS_PAL8 : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_RGB : DDSTextureLoader.cpp , DDS.h
  • DDS_RGBA : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_SURFACE_FLAGS_CUBEMAP : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_SURFACE_FLAGS_MIPMAP : DDS.h , DDSTextureLoader.cpp
  • DDS_SURFACE_FLAGS_TEXTURE : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DDS_WIDTH : DDSTextureLoader.cpp , DDS.h , DDSTextureLoader.cpp
  • DEADSPOT : MoveLookController.cpp
  • DEFFMT : Texconv.cpp
  • DEFINE_DEVSVCGUID : S6_DeviceStatus.xaml.cpp
  • DEFINE_DEVSVCPROPKEY : S6_DeviceStatus.xaml.cpp
  • DIRECTX_TEX_VERSION : DirectXTex.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- e -

  • ERROR_RESOURCE_VALUE : SDKMesh.h
  • EXIFOrientationPropertyName : RotateImageViewModel.cpp , CropImageViewModel.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- f -

  • FILE_DEVICE_OSRUSBFX2 : public.h
  • filename : Files.xaml.cpp
  • FLUSH_INTERVAL_SEC : WASAPICapture.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- h -

  • HAS_FLAG : Parse.cpp
  • HILO_PHOTO_FILE_NOT_FOUND : HiloCommonDefinitions.h
  • htonl : Parse.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- i -

  • INITGUID : ScenarioInput1.xaml.cpp
  • INVALID_ANIMATION_DATA : SDKMesh.h
  • INVALID_FRAME : SDKMesh.h
  • INVALID_MATERIAL : SDKMesh.h
  • INVALID_MESH : SDKMesh.h
  • INVALID_SAMPLER_SLOT : SDKMesh.h
  • INVALID_SUBSET : SDKMesh.h
  • IOCTL_INDEX : public.h
  • IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY : public.h
  • IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY : public.h
  • IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR : public.h
  • IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE : public.h
  • IOCTL_OSRUSBFX2_PLAY_FILE : public.h
  • IOCTL_OSRUSBFX2_READ_SWITCHES : public.h
  • IOCTL_OSRUSBFX2_REENUMERATE_DEVICE : public.h
  • IOCTL_OSRUSBFX2_RESET_DEVICE : public.h
  • IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY : public.h
  • IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY : public.h
  • ISBITMASK : DDSTextureLoader.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- p -

  • PHOTO_FILE_NAME : AdvancedCapture.xaml.h , BasicCapture.xaml.h
  • PI_F : BasicMath.h
  • PREROLL_DURATION_SEC : MFSampleGenerator.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- r -

  • REALIZATIONS_DECLARE_INTERFACE : GeometryRealizationPackage.h
  • ROOM_BOUNDS : Simple3DTouch.h
  • ROTATION_GAIN : MoveLookController.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- s -

  • SAFE_ARRAYDELETE : Common.h
  • SAFE_DELETE : SDKMesh.h , Common.h
  • SAFE_DELETE_ARRAY : SDKMesh.h
  • SAFE_RELEASE : SDKMesh.h , Common.h
  • SampleBackgroundTaskEntryPoint : Constants.h
  • SampleBackgroundTaskName : Constants.h
  • SampleBackgroundTaskWithConditionName : Constants.h
  • SDKMESH_FILE_VERSION : SDKMesh.h
  • ServicingCompleteTaskEntryPoint : Constants.h
  • ServicingCompleteTaskName : Constants.h
  • settingName : CompositeSettings.xaml.cpp , DataChangedEvent.xaml.cpp , SettingContainer.xaml.cpp , Settings.xaml.cpp , SetVersion.xaml.cpp , ClearScenario.xaml.cpp
  • settingName1 : ClearScenario.xaml.cpp , CompositeSettings.xaml.cpp
  • settingName2 : ClearScenario.xaml.cpp , CompositeSettings.xaml.cpp
  • settingValue : SettingContainer.xaml.cpp , Settings.xaml.cpp
  • settingValue0 : SetVersion.xaml.cpp
  • settingValue1 : ClearScenario.xaml.cpp , CompositeSettings.xaml.cpp , SetVersion.xaml.cpp
  • settingValue2 : CompositeSettings.xaml.cpp , ClearScenario.xaml.cpp
  • SIGN_EXTEND : BC.h
  • SS_BOTTOM : public.h
  • SS_BOTTOM_LEFT : public.h
  • SS_BOTTOM_RIGHT : public.h
  • SS_CENTER : public.h
  • SS_DOT : public.h
  • SS_TOP : public.h
  • SS_TOP_LEFT : public.h
  • SS_TOP_RIGHT : public.h
  • START_POSITION : Simple3DTouch.h , BumpMapping.h
  • STORE_SCANLINE : DirectXTexConvert.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- t -

  • TEMP_PHOTO_FILE_NAME : AdvancedCapture.xaml.h
  • TEX_FILTER_MASK : DirectXTexP.h
  • TEXT_TILE_ID : ScenarioInput3.xaml.cpp
  • TimeTriggeredTaskName : Constants.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- u -

  • USE_PPLTASKS : pch.h
  • USE_STORE_SIMULATOR : App.xaml.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- v -

  • VIDEO_FILE_NAME : AdvancedCapture.xaml.h , BasicCapture.xaml.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- w -

  • WIN32_LEAN_AND_MEAN : pch.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x

- x -

  • XAUDIO2_HELPER_FUNCTIONS : pch.h
  • XM_STRICT_VECTOR4 : pch.h
  • XMASSERT : StereoProjection.cpp
  • XML : WaveEffect.cpp , RippleEffect.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • c
  • d
  • f
  • g
  • i
  • k
  • l
  • m
  • o
  • p
  • r
  • s
  • t
  • u
  • w

- a -

  • Action : LowLatency.xaml.cpp
  • ActivationEntryPoint : frameworkview.h
  • AlignType : UserInterface.h

- c -

  • CheckpointState : MarbleMaze.h
  • CONVERSION_FLAGS : DirectXTexTGA.cpp

- d -

  • DrawTypes : D2DPageRendererContext.h

- f -

  • FractalTechnique : DirectXFractal.h
  • FrameTransformType : SDKMesh.h
  • FrameWorkload : AutoThrottle.h

- g -

  • GameInfoOverlayCommand : GameInfoOverlay.h
  • GameInfoOverlayState : DirectXApp.h
  • GameState : MarbleMaze.h , Simple3DGame.h
  • GlyphOrientation : TextAnalysis.h
  • GlyphOrientationMode : TextAnalysis.h

- i -

  • InkState : InkRenderer.h

- k -

  • KernelSelection : ConvolutionKernels.h

- l -

  • LightingEffect : D2DLightingEffectsRenderer.h
  • LightingProperty : D2DLightingEffectsRenderer.h

- m -

  • MeshID : Collision.h
  • MoveLookControllerState : MoveLookController.h
  • MPEG1AudioFlags : Parse.h
  • MPEG1AudioLayer : Parse.h
  • MPEG1AudioMode : Parse.h

- o -

  • OPTIONS : Texconv.cpp

- p -

  • PaperMode : PaperRenderer.h
  • PointerEventType : simpleInk.cpp
  • PressResultState : DirectXApp.h

- r -

  • ReadingDirection : TextAnalysis.h
  • REALIZATION_CREATION_OPTIONS : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE : GeometryRealizationPackage.h
  • RenderingMode : simpleInk.h
  • RenderSampleType : Common.h
  • RIPPLE_PROP : RippleEffect.h

- s -

  • SampleMode : PostcardRenderer.h
  • ScreenSavingState : SaveAsImageFileSample.h
  • SDKMeshIndexType : SDKMesh.h
  • SDKMeshPrimitiveType : SDKMesh.h
  • SoundEvent : Audio.h
  • SourceState : MPEG1Src.h
  • STEREO_CHANNEL : StereoProjection.h
  • STEREO_MODE : StereoProjection.h
  • StreamType : Parse.h

- t -

  • TGADescriptorFlags : DirectXTexTGA.cpp
  • TGAImageType : DirectXTexTGA.cpp
  • TransformEffect : D2D3DTransformsRenderer.h
  • TransformProperty : D2D3DTransformsRenderer.h

- u -

  • UpdateEngineState : DirectXApp.h

- w -

  • WAVE_PROP : WaveEffect.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- a -

  • Absolute : SDKMesh.h
  • Active : MoveLookController.h , Simple3DGame.h
  • AddConstructionPaper : PostcardRenderer.h
  • AddEffect : PostcardRenderer.h
  • AddImage : PostcardRenderer.h
  • AddSignature : PostcardRenderer.h
  • AddText : PostcardRenderer.h
  • AlignCenter : UserInterface.h
  • AlignFar : UserInterface.h
  • AlignNear : UserInterface.h
  • Azimuth : D2DLightingEffectsRenderer.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- l -

  • LastSoundEvent : Audio.h
  • latencyModeToggled : LowLatency.xaml.cpp
  • LEFT : StereoProjection.h
  • LevelComplete : Simple3DGame.h
  • LevelStart : DirectXApp.h
  • LightPositionZ : D2DLightingEffectsRenderer.h
  • LimitingConeAngle : D2DLightingEffectsRenderer.h
  • LineList : SDKMesh.h
  • LineListAdjacent : SDKMesh.h
  • LineStrip : SDKMesh.h
  • LineStripAdjacent : SDKMesh.h
  • Live : simpleInk.h
  • LoadGame : DirectXApp.h
  • Loading : DirectXApp.h
  • localClientButtonClicked : LowLatency.xaml.cpp
  • LocalOffsetX : D2D3DTransformsRenderer.h
  • LocalOffsetY : D2D3DTransformsRenderer.h
  • LocalOffsetZ : D2D3DTransformsRenderer.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- m -

  • MainMenu : MarbleMaze.h
  • Maintain : AutoThrottle.h
  • MenuChangeEvent : Audio.h
  • MenuSelectedEvent : Audio.h
  • MEPlaybackNative : frameworkview.h
  • Moving : PaperRenderer.h
  • MPEG1_AUDIO_COPYRIGHT_BIT : Parse.h
  • MPEG1_Audio_DualChannel : Parse.h
  • MPEG1_Audio_JointStereo : Parse.h
  • MPEG1_Audio_Layer1 : Parse.h
  • MPEG1_Audio_Layer2 : Parse.h
  • MPEG1_Audio_Layer3 : Parse.h
  • MPEG1_AUDIO_ORIGINAL_BIT : Parse.h
  • MPEG1_AUDIO_PRIVATE_BIT : Parse.h
  • MPEG1_AUDIO_PROTECTION_BIT : Parse.h
  • MPEG1_Audio_SingleChannel : Parse.h
  • MPEG1_Audio_Stereo : Parse.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- n -

  • None : GameInfoOverlay.h , MoveLookController.h , simpleInk.cpp , MoveLookController.h , MarbleMaze.h
  • NORMAL : StereoProjection.h
  • NotSaved : SaveAsImageFileSample.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- o -

  • OPT_DDS_DWORD_ALIGN : Texconv.cpp
  • OPT_FILETYPE : Texconv.cpp
  • OPT_FILTER : Texconv.cpp
  • OPT_FORMAT : Texconv.cpp
  • OPT_HEIGHT : Texconv.cpp
  • OPT_HFLIP : Texconv.cpp
  • OPT_MIPLEVELS : Texconv.cpp
  • OPT_NOLOGO : Texconv.cpp
  • OPT_OUTPUTDIR : Texconv.cpp
  • OPT_PREFIX : Texconv.cpp
  • OPT_SEPALPHA : Texconv.cpp
  • OPT_SRGB : Texconv.cpp
  • OPT_SRGBI : Texconv.cpp
  • OPT_SRGBO : Texconv.cpp
  • OPT_SUFFIX : Texconv.cpp
  • OPT_USE_DX10 : Texconv.cpp
  • OPT_VFLIP : Texconv.cpp
  • OPT_WIDTH : Texconv.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- b -

  • Bezier : simpleInk.h
  • Bits16 : SDKMesh.h
  • Bits32 : SDKMesh.h
  • BoxBlur : ConvolutionKernels.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- c -

  • CheckpointEvent : Audio.h
  • CollisionEvent : Audio.h
  • ContinueLevel : DirectXApp.h
  • CONV_FLAGS_888 : DirectXTexTGA.cpp
  • CONV_FLAGS_EXPAND : DirectXTexTGA.cpp
  • CONV_FLAGS_INVERTX : DirectXTexTGA.cpp
  • CONV_FLAGS_INVERTY : DirectXTexTGA.cpp
  • CONV_FLAGS_NONE : DirectXTexTGA.cpp
  • CONV_FLAGS_RLE : DirectXTexTGA.cpp
  • CONV_FLAGS_SWIZZLE : DirectXTexTGA.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- d -

  • D2D13DPerspectiveTransform : D2D3DTransformsRenderer.h
  • D2D13DTransform : D2D3DTransformsRenderer.h
  • Deactivated : DirectXApp.h
  • Decrease : AutoThrottle.h
  • Deleting : PaperRenderer.h
  • DiffuseConstant : D2DLightingEffectsRenderer.h
  • DirectCompute : DirectXFractal.h
  • DistantDiffuse : D2DLightingEffectsRenderer.h
  • DistantSpecular : D2DLightingEffectsRenderer.h
  • Dynamics : DirectXApp.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- e -

  • Elevation : D2DLightingEffectsRenderer.h
  • Emboss : ConvolutionKernels.h
  • Erase : simpleInk.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- f -

  • FallingEvent : Audio.h
  • Floor : Collision.h
  • Focus : D2DLightingEffectsRenderer.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- g -

  • GameComplete : Simple3DGame.h
  • GameOverCompleted : DirectXApp.h
  • GameOverExpired : DirectXApp.h
  • GameStats : DirectXApp.h
  • GlobalOffsetX : D2D3DTransformsRenderer.h
  • GlobalOffsetY : D2D3DTransformsRenderer.h
  • GlobalOffsetZ : D2D3DTransformsRenderer.h
  • GlyphOrientationBottomToTopLeftToRight : TextAnalysis.h
  • GlyphOrientationBottomToTopRightToLeft : TextAnalysis.h
  • GlyphOrientationCW0 : TextAnalysis.h
  • GlyphOrientationCW180 : TextAnalysis.h
  • GlyphOrientationCW270 : TextAnalysis.h
  • GlyphOrientationCW90 : TextAnalysis.h
  • GlyphOrientationES : TextAnalysis.h
  • GlyphOrientationFH : TextAnalysis.h
  • GlyphOrientationFlipDiagonal : TextAnalysis.h
  • GlyphOrientationFlipHorizontal : TextAnalysis.h
  • GlyphOrientationFlipVertical : TextAnalysis.h
  • GlyphOrientationFV : TextAnalysis.h
  • GlyphOrientationLeftToRightBottomToTop : TextAnalysis.h
  • GlyphOrientationLeftToRightTopToBottom : TextAnalysis.h
  • GlyphOrientationModeDefault : TextAnalysis.h
  • GlyphOrientationModeStacked : TextAnalysis.h
  • GlyphOrientationModeTotal : TextAnalysis.h
  • GlyphOrientationNE : TextAnalysis.h
  • GlyphOrientationRightToLeftBottomToTop : TextAnalysis.h
  • GlyphOrientationRightToLeftTopToBottom : TextAnalysis.h
  • GlyphOrientationSW : TextAnalysis.h
  • GlyphOrientationTopToBottomLeftToRight : TextAnalysis.h
  • GlyphOrientationTopToBottomRightToLeft : TextAnalysis.h
  • GlyphOrientationWN : TextAnalysis.h
  • Goal : MarbleMaze.h
  • Ground : Collision.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- h -

  • HighScoreDisplay : MarbleMaze.h
  • HorizontalSmear : ConvolutionKernels.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- i -

  • Increase : AutoThrottle.h
  • InGameActive : MarbleMaze.h
  • InGamePaused : MarbleMaze.h
  • Initial : MarbleMaze.h
  • Ink : simpleInk.cpp
  • INVERTED : StereoProjection.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- p -

  • Passthrough : ConvolutionKernels.h
  • Pause : DirectXApp.h
  • Perspective : D2D3DTransformsRenderer.h
  • PlayAgain : GameInfoOverlay.h
  • PlayLevel : DirectXApp.h
  • PleaseWait : GameInfoOverlay.h
  • PointDiffuse : D2DLightingEffectsRenderer.h
  • PointList : SDKMesh.h
  • PointSpecular : D2DLightingEffectsRenderer.h
  • PostGameResults : MarbleMaze.h
  • PreGameCountdown : MarbleMaze.h
  • Preview : D2DPageRendererContext.h
  • previewButtonClicked : LowLatency.xaml.cpp
  • previewSetupCompleted : LowLatency.xaml.cpp
  • Printing : D2DPageRendererContext.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- q -

  • QuadPatchList : SDKMesh.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- r -

  • ReadingDirectionBottomToTopLeftToRight : TextAnalysis.h
  • ReadingDirectionBottomToTopRightToLeft : TextAnalysis.h
  • ReadingDirectionE : TextAnalysis.h
  • ReadingDirectionEs : TextAnalysis.h
  • ReadingDirectionLeftToRightBottomToTop : TextAnalysis.h
  • ReadingDirectionLeftToRightTopToBottom : TextAnalysis.h
  • ReadingDirectionN : TextAnalysis.h
  • ReadingDirectionNe : TextAnalysis.h
  • ReadingDirectionPrimaryAxis : TextAnalysis.h
  • ReadingDirectionPrimaryProgression : TextAnalysis.h
  • ReadingDirectionRightToLeftBottomToTop : TextAnalysis.h
  • ReadingDirectionRightToLeftTopToBottom : TextAnalysis.h
  • ReadingDirectionS : TextAnalysis.h
  • ReadingDirectionSecondaryProgression : TextAnalysis.h
  • ReadingDirectionSw : TextAnalysis.h
  • ReadingDirectionTopToBottomLeftToRight : TextAnalysis.h
  • ReadingDirectionTopToBottomRightToLeft : TextAnalysis.h
  • ReadingDirectionW : TextAnalysis.h
  • ReadingDirectionWn : TextAnalysis.h
  • Ready : PostcardRenderer.h
  • REALIZATION_CREATION_OPTIONS_ALIASED : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_ANTI_ALIASED : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_FILLED : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_STROKED : GeometryRealizationPackage.h
  • REALIZATION_CREATION_OPTIONS_UNREALIZED : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE_DEFAULT : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE_FORCE_REALIZED : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE_FORCE_UNREALIZED : GeometryRealizationPackage.h
  • recordingStarted : LowLatency.xaml.cpp
  • Relative : SDKMesh.h
  • Rendering : D2DPageRendererContext.h
  • ResourcesLoaded : DirectXApp.h
  • RIGHT : StereoProjection.h
  • RIPPLE_PROP_AMPLITUDE : RippleEffect.h
  • RIPPLE_PROP_CENTER : RippleEffect.h
  • RIPPLE_PROP_FREQUENCY : RippleEffect.h
  • RIPPLE_PROP_PHASE : RippleEffect.h
  • RIPPLE_PROP_SPREAD : RippleEffect.h
  • RollingEvent : Audio.h
  • RotationX : D2D3DTransformsRenderer.h
  • RotationY : D2D3DTransformsRenderer.h
  • RotationZ : D2D3DTransformsRenderer.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- s -

  • SampleType16BitPCM : Common.h
  • SampleTypeFloat : Common.h
  • SampleTypeUnknown : Common.h
  • Save : MarbleMaze.h
  • Saved : SaveAsImageFileSample.h
  • Saving : SaveAsImageFileSample.h
  • ScaleX : D2D3DTransformsRenderer.h
  • ScaleY : D2D3DTransformsRenderer.h
  • Select : simpleInk.cpp
  • SimpleEdgeDetect : ConvolutionKernels.h
  • SimpleSharpen : ConvolutionKernels.h
  • SinglePass : DirectXFractal.h
  • Snapped : DirectXApp.h
  • SpecularConstant : D2DLightingEffectsRenderer.h
  • SpecularExponent : D2DLightingEffectsRenderer.h
  • SpotDiffuse : D2DLightingEffectsRenderer.h
  • SpotSpecular : D2DLightingEffectsRenderer.h
  • Stamping : PaperRenderer.h
  • STATE_INVALID : MPEG1Src.h
  • STATE_OPENING : MPEG1Src.h
  • STATE_PAUSED : MPEG1Src.h
  • STATE_SHUTDOWN : MPEG1Src.h
  • STATE_STARTED : MPEG1Src.h
  • STATE_STOPPED : MPEG1Src.h
  • StreamType_AllAudio : Parse.h
  • StreamType_AllVideo : Parse.h
  • StreamType_Audio : Parse.h
  • StreamType_Data : Parse.h
  • StreamType_Padding : Parse.h
  • StreamType_Private1 : Parse.h
  • StreamType_Private2 : Parse.h
  • StreamType_Reserved : Parse.h
  • StreamType_Unknown : Parse.h
  • StreamType_Video : Parse.h
  • StrokeCompleted : InkRenderer.h
  • StrokeDrawing : InkRenderer.h
  • SurfaceScale : D2DLightingEffectsRenderer.h
  • Suspended : DirectXApp.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- t -

  • TapToContinue : GameInfoOverlay.h
  • TGA_BLACK_AND_WHITE : DirectXTexTGA.cpp
  • TGA_BLACK_AND_WHITE_RLE : DirectXTexTGA.cpp
  • TGA_COLOR_MAPPED : DirectXTexTGA.cpp
  • TGA_COLOR_MAPPED_RLE : DirectXTexTGA.cpp
  • TGA_FLAGS_INTERLEAVED_2WAY : DirectXTexTGA.cpp
  • TGA_FLAGS_INTERLEAVED_4WAY : DirectXTexTGA.cpp
  • TGA_FLAGS_INVERTX : DirectXTexTGA.cpp
  • TGA_FLAGS_INVERTY : DirectXTexTGA.cpp
  • TGA_NO_IMAGE : DirectXTexTGA.cpp
  • TGA_TRUECOLOR : DirectXTexTGA.cpp
  • TGA_TRUECOLOR_RLE : DirectXTexTGA.cpp
  • ThreePhase : DirectXFractal.h
  • TimeExpired : Simple3DGame.h
  • TriangleList : SDKMesh.h
  • TriangleListAdjacent : SDKMesh.h
  • TrianglePatchList : SDKMesh.h
  • TriangleStrip : SDKMesh.h
  • TriangleStripAdjacent : SDKMesh.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- u -

  • UnicodeMax : pch.h
  • Unknown : frameworkview.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- w -

  • WaitForInput : MoveLookController.h
  • Waiting : Simple3DGame.h
  • WaitingForPress : DirectXApp.h
  • WaitingForResources : DirectXApp.h
  • Wall : Collision.h
  • WAVE_PROP_FORCE_DWORD : WaveEffect.h
  • WAVE_PROP_OFFSET : WaveEffect.h
  • WAVE_PROP_SKEW_X : WaveEffect.h
  • WAVE_PROP_SKEW_Y : WaveEffect.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- _ -

  • _Acquires_lock_() : MPEG1Stream.cpp
  • _Releases_lock_() : MPEG1Stream.cpp
  • _XMMatrixStereoProjectionHelper() : StereoProjection.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- l -

  • length() : BasicMath.h
  • LookupByName() : Texconv.cpp
  • LookupByValue() : Texconv.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- m -

  • main() : D2DTextAnimation.cpp , D2DBasicAnimation.cpp , CommandListSample.cpp , GeometryRealizationSample.cpp , DirectXApp.cpp , CoreWindowEvents.cpp , DirectXApp.cpp , D2DInterpolationModes.cpp , obj2vbo.cpp , DirectXApp.cpp , simpleInk.cpp , ShapesPuzzle.cpp , CompositeModes.cpp , D2DPerspectiveTransform.cpp , DirectXApp.cpp , main.cpp , TriColorWindow.cpp , Main.cpp , DirectXApp.cpp , Main.cpp , DirectXApp.cpp , Main.cpp , D2DEffectsHelloWorld.cpp , ConvolveMatrixEffect.cpp , SaveAsImageFileSample.cpp , Main.cpp , DirectXApp.cpp , DWriteHelloWorld.cpp , D2DEffectsOnPrimitives.cpp , DirectXApp.cpp , DWriteHitTesting.cpp , DWriteInlineObject.cpp , DirectXApp.cpp , DWriteParagraphText.cpp , DWriteVerticalText.cpp
  • MAKE_DWORD() : Parse.cpp
  • MAKE_DWORD_HOSTORDER() : Parse.cpp
  • MAKE_WORD() : Parse.cpp
  • MakeUnicodeCodepoint() : pch.h
  • MatrixStereoProjectionFovLH() : StereoProjection.h , StereoProjection.cpp , StereoProjection.h
  • mul() : BasicMath.h
  • mulDouble() : DoublePrecisionMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- n -

  • normalize() : BasicMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- o -

  • operator*() : BasicMath.h
  • operator+() : BasicMath.h
  • operator-() : BasicMath.h
  • operator/() : BasicMath.h
  • operator<() : obj2vbo.cpp
  • OurFillRect() : decoder.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- a -

  • AdvanceBufferPointer() : Parse.cpp
  • AnySelected() : simpleInk.cpp
  • AppendContactFieldValues() : ScenarioSingle.xaml.cpp
  • AppendValue() : ContactPickerPage.xaml.cpp
  • ApplyCartoonEffectAmp() : AmpCartoon.cpp , AmpCartoon.h
  • ApplyCartoonEffectPPL() : PPLCartoon.h , PPLCartoon.cpp
  • ApplyColorSimplifier() : AmpCartoon.cpp
  • ApplyEdgeDetection() : AmpCartoon.cpp
  • AsSimpleProvider() : TriColorWindow.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- b -

  • BufferToDXType() : Invert.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- c -

  • CalculateMixFormatType() : Common.h
  • CalculateSobel() : AmpCartoon.cpp
  • CAppWindowProvider_CreateInstance() : TriColorWindow.cpp , AppWindowProvider.cpp
  • CheckHResult() : HttpRequest.h
  • clamp() : Grayscale.cpp
  • CleanCombobox() : Scenario2.xaml.cpp
  • CleanComboboxSc4() : Scenario4.xaml.cpp
  • ComputeScanlines() : DirectXTex.inl
  • Convert() : ToneSampleGenerator.h
  • convert() : DoublePrecisionMath.h
  • Convert< float >() : ToneSampleGenerator.cpp
  • Convert< short >() : ToneSampleGenerator.cpp
  • ConvertRect() : MarbleMaze.cpp
  • create_map() : HiloPage.cpp
  • CreateAudioMediaType() : MPEG1Src.cpp
  • CreateBrush() : simpleInk.cpp
  • CreateDDSTextureFromMemory() : DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h , DDSTextureLoader.cpp , DDSTextureLoader.h
  • CreateDefaultStereoParameters() : Stereo3DMatrixHelper.cpp , Stereo3DMatrixHelper.h
  • CreateGeometryRealizationFactory() : GeometryRealizationPackage.h , GeometryRealizationPackage.cpp , GeometryRealizationPackage.h
  • CreateShaderInputView() : InvertModule.cpp
  • CreateShaderOutputView() : InvertModule.cpp
  • CreateVideoMediaType() : MPEG1Src.cpp
  • cross() : BasicMath.h
  • CTriColorControlProvider_CreateInstance() : TriColorWindow.cpp
  • CTriColorFragmentProvider_CreateInstance() : TriColorWindow.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- d -

  • D3DDeviceEventHandler() : DirectXBase.h
  • DbgPrint() : support.h
  • DebugPrint() : Scenario1.xaml.cpp
  • DebugPrint2() : Scenario2.xaml.cpp
  • DebugPrintSc4() : Scenario4.xaml.cpp
  • DECLSPEC_UUID() : FlowLayout.h , FlowSink.h , FlowSource.h
  • DEFINE_GUID() : RippleEffect.h , WaveEffect.h , Grayscale.h , WUDFOsrUsbPublic.h , Invert.h , Grayscale.h , WUDFOsrUsbPublic.h , Grayscale.h , WUDFOsrUsbPublic.h , Grayscale.h , Invert.h , RippleEffect.h
  • DeviceLostEventHandler() : Renderer.h
  • DllAddRef() : PolarEffect.h , MPEG1Src.h , PolarEffect.h , MPEG1Src.h
  • DllCanUnloadNow() : dllmain.cpp , dll.cpp , dllmain.cpp , dll.cpp , dllmain.cpp
  • DllGetActivationFactory() : dllmain.cpp , dll.cpp , dllmain.cpp , dll.cpp , dllmain.cpp
  • DllGetClassObject() : dllmain.cpp , dll.cpp , dllmain.cpp , dll.cpp , dllmain.cpp
  • DllMain() : dllmain.cpp , dll.cpp , dllmain.cpp , dll.cpp , dllmain.cpp
  • DllRelease() : MPEG1Src.h , PolarEffect.h , MPEG1Src.h , PolarEffect.h
  • DocumentLoadedCallback() : Document.h
  • dot() : BasicMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- e -

  • EdgeDetection() : AmpCartoon.cpp
  • EventIsErase() : simpleInk.cpp
  • EventIsInk() : simpleInk.cpp
  • EventIsSelect() : simpleInk.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- f -

  • FindMeshIndexByName() : MarbleMaze.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- g -

  • GaussianDistribution() : D3DPostProcessing.cpp
  • GetAudioBitRate() : Parse.cpp
  • GetDefaultStride() : Grayscale.cpp , Invert.cpp , PolarEffect.cpp , Invert.cpp , PolarEffect.cpp , Grayscale.cpp
  • GetDisplayContent() : ScenarioInput4.xaml.cpp
  • GetFrameRate() : Parse.cpp
  • GetImageSize() : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • GetPixelAspectRatio() : Parse.cpp
  • GetPointerEventType() : simpleInk.cpp
  • GetPointerToPixelData() : ImageUtilities.h , ImageUtilities.cpp
  • GetSampleOffsetsWeightsForBlur() : D3DPostProcessing.cpp
  • GetSamplingFrequency() : Parse.cpp
  • GetStreamMajorType() : MPEG1Src.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- i -

  • identity() : BasicMath.h
  • identityDouble() : DoublePrecisionMath.h
  • IFACEMETHODIMP_() : RippleEffect.cpp , WaveEffect.cpp , CustomTextRenderer.cpp
  • InflateRect() : MarbleMaze.cpp
  • InitializeFrameData() : PPLCartoon.cpp
  • IntersectRayTriangle() : Physics.h
  • IsBackgroundThread() : TaskExtensions.h , TaskExtensions.cpp
  • IsCompressed() : DirectXTex.inl
  • IsErrorResource() : SDKMesh.h
  • IsLeadingSurrogate() : pch.h
  • IsMainThread() : TaskExtensions.cpp , TaskExtensions.h
  • IsPacked() : DirectXTex.inl
  • IsSRGB() : DirectXTex.inl
  • IsSurrogate() : pch.h
  • IsTrailingSurrogate() : pch.h
  • IsTypeless() : DirectXTex.inl
  • IsValid() : DirectXTex.inl
  • IsVideo() : DirectXTex.inl
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- p -

  • ParsePTS() : Parse.cpp
  • ParseStreamData() : Parse.cpp
  • ParseStreamId() : Parse.cpp
  • PointInRect() : UserInterface.cpp
  • PointToTouch() : MarbleMaze.cpp
  • PopulateInitialRGBValues() : AmpCartoon.cpp
  • PrintFormat() : Texconv.cpp
  • PrintInfo() : Texconv.cpp
  • PrintList() : Texconv.cpp
  • PrintLogo() : Texconv.cpp
  • PrintUsage() : Texconv.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- r -

  • ReadAudioFrameHeader() : Parse.cpp , Parse.h , Parse.cpp
  • ReadVideoSequenceHeader() : Parse.h , Parse.cpp , Parse.h , Parse.cpp
  • REALIZATIONS_DECLARE_INTERFACE() : GeometryRealizationPackage.h
  • RecordMainThread() : TaskExtensions.cpp , TaskExtensions.h
  • RectToRectF() : TriColorWindow.cpp
  • Reset1() : Scenario1.xaml.cpp
  • Reset2() : Scenario2.xaml.cpp
  • ResetSc4() : Scenario4.xaml.cpp
  • rotationArbitrary() : BasicMath.h
  • rotationX() : BasicMath.h
  • rotationY() : BasicMath.h
  • rotationZ() : BasicMath.h
  • rotationZDouble() : DoublePrecisionMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- s -

  • safe_handle() : scoped.h
  • SafeAcquire() : pch.h
  • SafeArrayDelete() : PolarEffect.h
  • SafeRelease() : decoder.h , MPEG1Src.h , pch.h , PolarEffect.h , Grayscale.h , common.h , decoder.h , MPEG1Src.h , Grayscale.h , PolarEffect.h , Common.h
  • SafeReplace() : pch.h
  • SampleRequestMatch() : MPEG1Src.cpp
  • SaveToDDSFile() : DirectXTex.inl
  • SaveToDDSMemory() : DirectXTex.inl
  • scale() : BasicMath.h
  • scaleDouble() : DoublePrecisionMath.h
  • SelectAll() : simpleInk.cpp
  • sgn_sqrt() : DrawingObject.cpp
  • SimplifyIndexColumns() : AmpCartoon.cpp
  • SimplifyIndexRows() : AmpCartoon.cpp
  • STDMETHODIMP_() : GeometryRealizationPackage.cpp , InlineImage.cpp
  • StereoCreateDefaultParameters() : StereoProjection.cpp , StereoProjection.h , StereoProjection.cpp , StereoProjection.h
  • StereoProjectionFieldOfViewRightHand() : Stereo3DMatrixHelper.h , Stereo3DMatrixHelper.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- t -

  • THROW_HR() : fx2device.h
  • ThrowIfFailed() : ImageUtilities.cpp , Common.h
  • TimeSpanToMilliseconds() : Scenario1.xaml.cpp
  • TransformChroma() : Grayscale.cpp
  • TransformImage_NV12() : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • TransformImage_UYVY() : PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp
  • TransformImage_YUY2() : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • translation() : BasicMath.h
  • translationDouble() : DoublePrecisionMath.h
  • transpose() : BasicMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- u -

  • usage() : obj2vbo.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- v -

  • ValidateBufferSize() : Parse.cpp
  • ValidateRect() : Grayscale.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w

- w -

  • wmain() : Texconv.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • b
  • d
  • e
  • f
  • h
  • i
  • k
  • l
  • m
  • p
  • r
  • s
  • t
  • u

- b -

  • BAR_GRAPH_STATE : public.h

- d -

  • double2 : DoublePrecisionMath.h
  • double4x4 : DoublePrecisionMath.h

- e -

  • ElementSet : UserInterface.h

- f -

  • FILE_PLAYBACK : public.h
  • float2 : BasicMath.h
  • float3 : BasicMath.h
  • float4 : BasicMath.h
  • float4x4 : BasicMath.h

- h -

  • HighScoreEntries : Simple3DGame.h , UserInterface.h

- i -

  • IMAGE_TRANSFORM_FN : Grayscale.h , PolarEffect.h , Grayscale.h
  • IMft0 : SampleMft0.h
  • IMft0Vtbl : SampleMft0.h

- k -

  • KernelSelection : ConvolutionKernels.h

- l -

  • LPSDKMESHVERTEXELEMENT : SDKMesh.h

- m -

  • Mft0 : SampleMft0.h

- p -

  • PBAR_GRAPH_STATE : public.h
  • PFILE_PLAYBACK : public.h
  • PolarTransformer : PolarEffect.h
  • PSWITCH_STATE : public.h

- r -

  • REALIZATION_CREATION_OPTIONS : GeometryRealizationPackage.h
  • REALIZATION_RENDER_MODE : GeometryRealizationPackage.h

- s -

  • SampleList : MPEG1Src.h
  • ScopedAlignedArrayFloat : scoped.h
  • ScopedAlignedArrayXMVECTOR : scoped.h
  • ScopedHandle : scoped.h
  • SDKMESHVERTEXELEMENT : SDKMesh.h
  • STEREO_CHANNEL : StereoProjection.h
  • STEREO_MODE : StereoProjection.h
  • STEREO_PARAMETERS : StereoProjection.h
  • SWITCH_STATE : public.h

- t -

  • TokenList : MPEG1Src.h

- u -

  • uint : BasicMath.h
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • Defines
  • _
  • b
  • c
  • d
  • e
  • f
  • g
  • i
  • l
  • m
  • n
  • p
  • q
  • r
  • s
  • t
  • u
  • w

- _ -

  • _inputElements : WriteReadStream.xaml.cpp
  • _mainThreadId : TaskExtensions.cpp

- b -

  • BatchSize : TileUpdateScheduler.cpp

- c -

  • c_NumBarsInGraph : fx2device.h
  • c_NumSwitches : fx2device.h
  • c_SegmentMask : fx2device.h
  • c_SegmentMaskCe : fx2device.h
  • CLSID_Mft0 : SampleMft0.h
  • CONTROLS_AREA_SIZE : Program.cpp
  • CURSOR_ID_NONE : Shape.h

- d -

  • Damping : Physics.h
  • DATE_BUFFER_SIZE : CalendarExtensions.cpp
  • DelayTimerInfo : Constants.cpp
  • DelayTimerMilliseconds : Constants.cpp
  • DelayTimerSelectedIndex : Constants.cpp
  • DelayTimerStatus : Constants.cpp

- e -

  • EVENTSPACING : HubPhotoGroup.cpp , ImageBrowserViewModel.cpp

- f -

  • FileDateMapKey : ImageViewModel.cpp
  • FilePathMapKey : ImageViewModel.cpp
  • FOURCC_NV12 : PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp
  • FOURCC_UYVY : PolarEffect.cpp , Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp
  • FOURCC_YUY2 : PolarEffect.cpp , Grayscale.cpp

- g -

  • g_MediaSubtypes : Grayscale.cpp , PolarEffect.cpp , Grayscale.cpp
  • g_pFilters : Texconv.cpp
  • g_pFormats : Texconv.cpp
  • g_pOptions : Texconv.cpp
  • g_pSaveFileTypes : Texconv.cpp
  • g_TGA20_Signature : DirectXTexTGA.cpp
  • g_this : audiovideoptr.xaml.cpp
  • Gravity : Physics.h

- i -

  • IID_IMft0 : SampleMft0.h
  • INITIAL_BUFFER_SIZE : MPEG1Src.h
  • items : FileSystemRepository.cpp

- l -

  • LIBID_SampleMft0Lib : SampleMft0.h

- m -

  • MarginBottomStateKey : RotateImageViewModel.cpp
  • MarginLeftStateKey : RotateImageViewModel.cpp
  • MarginRightStateKey : RotateImageViewModel.cpp
  • MarginTopStateKey : RotateImageViewModel.cpp
  • MAX_POLY_VERTICES : Shape.h
  • MAX_STREAMS : MPEG1Src.h
  • MAX_VIDEO_HEIGHT : decoder.cpp
  • MAX_VIDEO_WIDTH : decoder.cpp
  • MaxHeight : CartoonizeImageViewModel.cpp
  • MaxNumberOfPictures : HubPhotoGroup.cpp , MonthGroup.cpp
  • MaxPhysicsTimestep : Physics.h
  • MaxTemplateImages : WideFiveImageTile.cpp
  • MaxVelocity : Physics.h
  • MaxWidth : CartoonizeImageViewModel.cpp
  • MinAudibleCollisionSpeed : Physics.h
  • MinVelocity : Physics.h
  • MPEG1_AUDIO_FRAME_HEADER_SIZE : Parse.h
  • MPEG1_MAX_PACKET_SIZE : Parse.h
  • MPEG1_PACK_HEADER_SIZE : Parse.h
  • MPEG1_PACK_START_CODE : Parse.h
  • MPEG1_PACKET_HEADER_MAX_SIZE : Parse.h
  • MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE : Parse.h
  • MPEG1_PACKET_HEADER_MIN_SIZE : Parse.h
  • MPEG1_SEQUENCE_HEADER_CODE : Parse.h
  • MPEG1_START_CODE_PREFIX : Parse.h
  • MPEG1_STOP_CODE : Parse.h
  • MPEG1_STREAMTYPE_ALL_AUDIO : Parse.h
  • MPEG1_STREAMTYPE_ALL_VIDEO : Parse.h
  • MPEG1_STREAMTYPE_AUDIO_MASK : Parse.h
  • MPEG1_STREAMTYPE_DATA_MASK : Parse.h
  • MPEG1_STREAMTYPE_PADDING : Parse.h
  • MPEG1_STREAMTYPE_PRIVATE1 : Parse.h
  • MPEG1_STREAMTYPE_PRIVATE2 : Parse.h
  • MPEG1_STREAMTYPE_RESERVED : Parse.h
  • MPEG1_STREAMTYPE_VIDEO_MASK : Parse.h
  • MPEG1_SYSTEM_HEADER_CODE : Parse.h
  • MPEG1_SYSTEM_HEADER_MIN_SIZE : Parse.h
  • MPEG1_SYSTEM_HEADER_PREFIX : Parse.h
  • MPEG1_SYSTEM_HEADER_STREAM : Parse.h
  • MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE : Parse.h
  • MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE : Parse.h , decoder.h , Parse.h , decoder.h

- n -

  • NeighborWindowKey : CartoonizeImageViewModel.cpp

- p -

  • PeriodicTimerCount : Constants.cpp
  • PeriodicTimerInfo : Constants.cpp
  • PeriodicTimerMilliseconds : Constants.cpp
  • PeriodicTimerSelectedIndex : Constants.cpp
  • PeriodicTimerStatus : Constants.cpp
  • PhasesKey : CartoonizeImageViewModel.cpp
  • PhysicsTimestep : Physics.h

- q -

  • QueryMapKey : ImageViewModel.cpp

- r -

  • READ_SIZE : MPEG1Src.h
  • RotationStateKey : RotateImageViewModel.cpp

- s -

  • SAMPLE_QUEUE : MPEG1Src.h
  • SAMPLE_TASK_ENTRY_POINT : ScenarioInput1.xaml.cpp
  • SAMPLE_TASK_NAME : ScenarioInput1.xaml.cpp
  • SetSize : TileUpdateScheduler.cpp

- t -

  • tangentVertexLayoutDesc : BumpMapping.cpp
  • ThumbnailImagePrefix : ThumbnailGenerator.cpp
  • ThumbnailsFolderName : TileUpdateScheduler.cpp
  • ThumbnailSize : ThumbnailGenerator.cpp
  • toDegrees : Scenario1.xaml.cpp , Scenario2.xaml.cpp
  • TONE_AMPLITUDE : ToneSampleGenerator.cpp
  • TONE_DURATION_SEC : ToneSampleGenerator.cpp

- u -

  • UIA_AutomationFocusChangedEventId : pch.h
  • UIA_AutomationIdPropertyId : pch.h
  • UIA_ControlTypePropertyId : pch.h
  • UIA_CustomControlTypeId : pch.h
  • UIA_HasKeyboardFocusPropertyId : pch.h
  • UIA_HelpTextPropertyId : pch.h
  • UIA_IsContentElementPropertyId : pch.h
  • UIA_IsControlElementPropertyId : pch.h
  • UIA_IsEnabledPropertyId : pch.h
  • UIA_IsKeyboardFocusablePropertyId : pch.h
  • UIA_IsPasswordPropertyId : pch.h
  • UIA_LocalizedControlTypePropertyId : pch.h
  • UIA_NamePropertyId : pch.h
  • UIA_ProviderDescriptionPropertyId : pch.h
  • UIA_SelectionItem_ElementSelectedEventId : pch.h
  • UIA_SelectionItemPatternId : pch.h
  • UIA_SelectionPatternId : pch.h
  • UIA_ValuePatternId : pch.h
  • UIA_ValueValuePropertyId : pch.h
  • UIA_WindowControlTypeId : pch.h

- w -

  • WallFriction : Physics.h
  • WallRestitutionCoefficient : Physics.h
  • WorkItemInfo : Constants.cpp
  • WorkItemSelectedIndex : Constants.cpp
  • WorkItemStatus : Constants.cpp
  • WorkPriority : Constants.cpp
Generated on Sat Nov 23 2024 16:09:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Main Page

Win8-Examples Documentation

End-User License Agreement

Introduction

This End-User License Agreement ("EULA") is a legal agreement between you (either an individual or a single entity) and SIEMA ("Licensor") for the use of SIEMA-REFERENCE ("Software"). This EULA governs your use of the Software provided by the Licensor. By installing or using the Software, you agree to be bound by the terms of this EULA.

License Grant

Licensor grants you a revocable, non-exclusive, non-transferable, limited license to download, install, and use the Software solely for your personal or commercial purposes strictly in accordance with the terms of this Agreement.

Restrictions on Use

You agree not to, and you will not permit others to:

  • Modify, or create derivative works of the Software;
  • Distribute, transfer, sublicense, lease, lend, or rent the Software to any third party;
  • Reverse engineer, decompile or disassemble the Software, except to the extent expressly permitted by applicable law;
  • Remove, alter, or obscure any proprietary notices on the Software;
  • Use the Software in any manner that could damage, disable, overburden, or impair the Software;
  • Use the Software to create or distribute any malicious software or for any unlawful purpose.

Related Agreements

By agreeing to this EULA, you also agree to comply with the terms of Terms and Conditions, Privacy Policy, and any other agreements incorporated herein by reference.

Jurisdiction

This EULA and any disputes arising out of or in connection with it will be governed by and construed in accordance with the laws of Switzerland, without regard to its conflict of laws principles. Any legal actions or proceedings arising out of this EULA shall be brought exclusively in the courts of Switzerland.Intellectual Property & Copyright Infringement

The Software and all rights, title, and interest in and to the Software, including all intellectual property rights therein, are and will remain the exclusive property of the Licensor. You agree to notify the Licensor promptly if you become aware of any infringement of the Licensor’s intellectual property rights in the Software.Termination of Licensing

Licensor may terminate this EULA at any time if you fail to comply with any term(s) of this Agreement. Upon termination, you must cease all use of the Software and destroy all copies, full or partial, of the Software.

Warranty Disclaimer

THE SOFTWARE IS PROVIDED "AS IS". LICENSOR MAKES NO WARRANTIES, WHETHER EXPRESS, IMPLIED, OR STATUTORY, INCLUDING BUT NOT LIMITED TO THE IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE, TITLE, AND NON-INFRINGEMENT. YOU BEAR THE ENTIRE RISK AS TO SELECTING THE SOFTWARE FOR YOUR PURPOSES AND AS TO THE QUALITY AND PERFORMANCE OF THE SOFTWARE.

Limitations of Liability

TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, IN NO EVENT SHALL LICENSOR BE LIABLE FOR ANY INDIRECT, INCIDENTAL, SPECIAL, CONSEQUENTIAL, OR PUNITIVE DAMAGES, OR ANY LOSS OF PROFITS OR REVENUES, WHETHER INCURRED DIRECTLY OR INDIRECTLY, OR ANY LOSS OF DATA, USE, GOODWILL, OR OTHER INTANGIBLE LOSSES, RESULTING FROM:

  1. YOUR USE OR INABILITY TO USE THE SOFTWARE;
  2. ANY UNAUTHORIZED ACCESS TO OR USE OF OUR SERVERS AND/OR ANY PERSONAL INFORMATION STORED THEREIN;
  3. ANY INTERRUPTION OR CESSATION OF TRANSMISSION TO OR FROM THE SOFTWARE;
  4. ANY ERRORS OR OMISSIONS IN ANY CONTENT OR FOR ANY LOSS OR DAMAGE INCURRED AS A RESULT OF YOUR USE OF ANY CONTENT POSTED, EMAILED, TRANSMITTED, OR OTHERWISE MADE AVAILABLE THROUGH THE SOFTWARE;
  5. THE DEFAMATORY, OFFENSIVE, OR ILLEGAL CONDUCT OF ANY THIRD PARTY.

Business Contact Information

If you have any questions about this EULA, please contact us at:

Siema
siema.switzerland@gmail.com

By installing or using the Software, you acknowledge that you have read this Agreement, understand it, and agree to be bound by its terms and conditions.

Generated on Sat Nov 23 2024 16:07:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- l -

  • LABEL_CAPS_FLAGS : anonymous_namespace{SimpleController.cpp}
  • LABEL_CAPS_SUBTYPE : anonymous_namespace{SimpleController.cpp}
  • LABEL_CAPS_TYPE : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_BUTTONS : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_LEFT_THUMB_X : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_LEFT_THUMB_Y : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_LEFT_TRIGGER : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_PACKET_NUMBER : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_RIGHT_THUMB_X : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_RIGHT_THUMB_Y : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_RIGHT_TRIGGER : anonymous_namespace{SimpleController.cpp}
  • LevelStart : Simple3DGameXaml
  • LINE_HEIGHT : anonymous_namespace{SimpleController.cpp}
  • LoadFromDDSFile() : DirectX
  • LoadFromDDSMemory() : DirectX
  • LoadFromTGAFile() : DirectX
  • LoadFromTGAMemory() : DirectX
  • LoadFromWICFile() : DirectX
  • LoadFromWICMemory() : DirectX
  • LoadGame : Simple3DGameXaml
  • Loading : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- m -

  • MakeSRGB() : DirectX
  • MapEndMarker : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • metadata : DirectX
  • MSG_INSTRUCTIONS : anonymous_namespace{AudioController.cpp}
  • MSG_NEED_AUDIO : anonymous_namespace{StreamEffect.cpp} , anonymous_namespace{BasicSound.cpp}
  • MSG_NEED_CONTROLLER : anonymous_namespace{SimpleController.cpp} , anonymous_namespace{AudioController.cpp}
  • MSG_NEED_HEADSET : anonymous_namespace{AudioController.cpp}
  • MUSIC_FILE : anonymous_namespace{StreamEffect.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- n -

  • NavigateEventHandler() : Hilo
  • nImages : DirectX
  • None : Simple3DGameXaml
  • Normalized : BasicSprites
  • NotifyType : SDKSample , AppBarControl , SDKSample , ToastsSampleCPP , SDKSample , StreamSocketSample , SDKSample , ShareTarget , SDKSample , SecondaryTiles , SDKSample , ScheduledNotificationsSampleCPP , SDKSample , SimpleCommunication , SDKTemplate , SDKSample , RawNotificationsSampleCPP , SDKSample , ProximityCPP , SDKSample , PrintSample , SDKSample , SDKTemplate , SDKSample , SDKTemplate , SDKSample , LockScreenAppsCPP , SDKSample , LanguageFontCPP , SDKSample , EdgeGestureSample , SDKSample , DatagramSocketSample , SDKSample , SDKTemplateCS , MediaExtensionsCPP , CredentialPickerCPP , SDKSample , ContactPicker , SDKSample , Clipboard , SDKSample , SDKTemplate , SDKSample , AssociationLaunching , SDKSample , AccountPictureName
  • NotRotated : Hilo
  • NullPtrType : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- o -

  • OnIoComplete() : Samples::Devices
  • OnServiceOpenComplete() : SDKSample::PortableDeviceCPP
  • OptimizeAlpha() : DirectX
  • OptimizeRoute() : AntSystem
  • outFormat : DirectX
  • outSize : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- a -

  • activatable() : UiaCoreWindowProvider
  • ActivatableClass() : Microsoft::Samples
  • Additive : BasicSprites
  • Alpha : BasicSprites
  • APPLICATION_TITLE
: anonymous_namespace{AudioController.cpp}
, anonymous_namespace{StreamEffect.cpp}
, anonymous_namespace{SimpleController.cpp}
, anonymous_namespace{BasicSound.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- b -

  • BC67_WEIGHT_MAX : DirectX
  • BC67_WEIGHT_ROUND : DirectX
  • BC67_WEIGHT_SHIFT : DirectX
  • BC6H_MAX_SHAPES : DirectX
  • BC6H_NUM_CHANNELS : DirectX
  • BC7_MAX_SHAPES : DirectX
  • BC7_NUM_CHANNELS : DirectX
  • BC_DECODE : DirectX
  • BC_ENCODE : DirectX
  • BC_FLAGS : DirectX
  • BC_FLAGS_DITHER_A : DirectX
  • BC_FLAGS_DITHER_RGB : DirectX
  • BC_FLAGS_NONE : DirectX
  • BC_FLAGS_UNIFORM : DirectX
  • BitsPerPixel() : DirectX
  • BlendMode : BasicSprites
  • BooleanType : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • Browse : Hilo
  • BUFFER_COUNT : anonymous_namespace{StreamEffect.cpp}
  • ButtonClickedHandler() : Postcard
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- c -

  • Canceled : SDKSample::ThreadPool
  • CanExecuteDelegate() : Hilo
  • CAPS_DATA_START : anonymous_namespace{SimpleController.cpp}
  • CAPS_HEADER : anonymous_namespace{SimpleController.cpp}
  • CAPS_LABEL_START : anonymous_namespace{SimpleController.cpp}
  • CaptureFailedHandler() : SimpleCommunication
  • CaptureTexture() : DirectX
  • Cartoonize : Hilo
  • Char16Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • CLEAR_COLOR : anonymous_namespace{SimpleController.cpp}
  • CNMAP_CHANNEL_ALPHA : DirectX
  • CNMAP_CHANNEL_BLUE : DirectX
  • CNMAP_CHANNEL_GREEN : DirectX
  • CNMAP_CHANNEL_LUMINANCE : DirectX
  • CNMAP_CHANNEL_RED : DirectX
  • CNMAP_COMPUTE_OCCLUSION : DirectX
  • CNMAP_DEFAULT : DirectX
  • CNMAP_FLAGS : DirectX
  • CNMAP_INVERT_SIGN : DirectX
  • CNMAP_MIRROR : DirectX
  • CNMAP_MIRROR_U : DirectX
  • CNMAP_MIRROR_V : DirectX
  • Completed : SDKSample::ThreadPool
  • Compress() : DirectX
  • ComputeHeuristicShortestDistance() : AntSystem
  • ComputeLengthOfRoute() : AntSystem
  • ComputeMSE() : DirectX
  • ComputeNormalMap() : DirectX
  • ComputePitch() : DirectX
  • ComputeScanlines() : DirectX
  • ContentType : SDKSample::WASAPIAudio
  • ContentTypeFile : SDKSample::WASAPIAudio
  • ContentTypeTone : SDKSample::WASAPIAudio
  • ContinueLevel : Simple3DGameXaml
  • CONV_FLAGS_332 : DirectX
  • CONV_FLAGS_44 : DirectX
  • CONV_FLAGS_4444 : DirectX
  • CONV_FLAGS_5551 : DirectX
  • CONV_FLAGS_565 : DirectX
  • CONV_FLAGS_8332 : DirectX
  • CONV_FLAGS_888 : DirectX
  • CONV_FLAGS_A8P8 : DirectX
  • CONV_FLAGS_DX10 : DirectX
  • CONV_FLAGS_EXPAND : DirectX
  • CONV_FLAGS_NOALPHA : DirectX
  • CONV_FLAGS_NONE : DirectX
  • CONV_FLAGS_PAL8 : DirectX
  • CONV_FLAGS_SWIZZLE : DirectX
  • CONVERSION_FLAGS : DirectX
  • Convert() : DirectX
  • CONVERT_FLAGS : DirectX
  • ConvertPropertyValueToString() : CppSamplesUtils::Details
  • ConvertStringToObject() : CppSamplesUtils::Details
  • CONVF_A : DirectX
  • CONVF_B : DirectX
  • CONVF_BC : DirectX
  • CONVF_BGR : DirectX
  • CONVF_DEPTH : DirectX
  • CONVF_FLOAT : DirectX
  • CONVF_G : DirectX
  • CONVF_PACKED : DirectX
  • CONVF_R : DirectX
  • CONVF_RGB_MASK : DirectX
  • CONVF_RGBA_MASK : DirectX
  • CONVF_SHAREDEXP : DirectX
  • CONVF_SINT : DirectX
  • CONVF_SNORM : DirectX
  • CONVF_STENCIL : DirectX
  • CONVF_UINT : DirectX
  • CONVF_UNORM : DirectX
  • CONVF_X2 : DirectX
  • CopyRectangle() : DirectX
  • CoTaskMemString : SDKSample
  • count : DirectX
  • CP_FLAGS : DirectX
  • CP_FLAGS_16BPP : DirectX
  • CP_FLAGS_24BPP : DirectX
  • CP_FLAGS_8BPP : DirectX
  • CP_FLAGS_LEGACY_DWORD : DirectX
  • CP_FLAGS_NONE : DirectX
  • cpFlags : DirectX
  • create_empty_task() : Hilo
  • create_task_from_result() : Hilo
  • CreateShaderResourceView() : DirectX
  • CreateTexture() : DirectX
  • CreateXmlElementFromObject() : CppSamplesUtils::Details
  • Crop : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- d -

  • D3DXDecodeBC1() : DirectX
  • D3DXDecodeBC2() : DirectX
  • D3DXDecodeBC3() : DirectX
  • D3DXDecodeBC4S() : DirectX
  • D3DXDecodeBC4U() : DirectX
  • D3DXDecodeBC5S() : DirectX
  • D3DXDecodeBC5U() : DirectX
  • D3DXDecodeBC6HS() : DirectX
  • D3DXDecodeBC6HU() : DirectX
  • D3DXDecodeBC7() : DirectX
  • D3DXEncodeBC1() : DirectX
  • D3DXEncodeBC2() : DirectX
  • D3DXEncodeBC3() : DirectX
  • D3DXEncodeBC4S() : DirectX
  • D3DXEncodeBC4U() : DirectX
  • D3DXEncodeBC5S() : DirectX
  • D3DXEncodeBC5U() : DirectX
  • D3DXEncodeBC6HS() : DirectX
  • D3DXEncodeBC6HU() : DirectX
  • D3DXEncodeBC7() : DirectX
  • DDS_DIMENSION_TEXTURE1D : DirectX
  • DDS_DIMENSION_TEXTURE2D : DirectX
  • DDS_DIMENSION_TEXTURE3D : DirectX
  • DDS_FLAGS : DirectX
  • DDS_FLAGS_FORCE_DX10_EXT : DirectX
  • DDS_FLAGS_FORCE_RGB : DirectX
  • DDS_FLAGS_LEGACY_DWORD : DirectX
  • DDS_FLAGS_NO_16BPP : DirectX
  • DDS_FLAGS_NO_LEGACY_EXPANSION : DirectX
  • DDS_FLAGS_NO_R10B10G10A2_FIXUP : DirectX
  • DDS_FLAGS_NONE : DirectX
  • DDS_MAGIC : DirectX
  • DDS_RESOURCE_DIMENSION : DirectX
  • DDS_RESOURCE_MISC_FLAG : DirectX
  • DDS_RESOURCE_MISC_TEXTURECUBE : DirectX
  • Deactivated : Simple3DGameXaml
  • Decompress() : DirectX
  • DeserializeSessionState() : CppSamplesUtils::Details
  • DeviceClosingHandler : SDKSample::CustomDeviceAccess
  • DeviceState : SDKSample::WASAPIAudio
  • DeviceStateActivated : SDKSample::WASAPIAudio
  • DeviceStateCapturing : SDKSample::WASAPIAudio
  • DeviceStateChangedHandler() : SDKSample::WASAPIAudio
  • DeviceStateDiscontinutity : SDKSample::WASAPIAudio
  • DeviceStateFlushing : SDKSample::WASAPIAudio
  • DeviceStateInError : SDKSample::WASAPIAudio
  • DeviceStateInitialized : SDKSample::WASAPIAudio
  • DeviceStatePaused : SDKSample::WASAPIAudio
  • DeviceStatePausing : SDKSample::WASAPIAudio
  • DeviceStatePlaying : SDKSample::WASAPIAudio
  • DeviceStateStarting : SDKSample::WASAPIAudio
  • DeviceStateStopped : SDKSample::WASAPIAudio
  • DeviceStateStopping : SDKSample::WASAPIAudio
  • DeviceStateUnInitialized : SDKSample::WASAPIAudio
  • DIPs : BasicSprites
  • DisplayContent : PrintSample
  • DoubleType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • Dynamics : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- e -

  • EffectIntensityChangedHandler() : Postcard
  • ErrorMessage : SDKSample , AssociationLaunching , DatagramSocketSample , SimpleCommunication , AppBarControl , ToastsSampleCPP , StreamSocketSample , ShareTarget , ScheduledNotificationsSampleCPP , EdgeGestureSample , SecondaryTiles , RawNotificationsSampleCPP , ProximityCPP , PrintSample , MediaExtensionsCPP , LockScreenAppsCPP , Clipboard , LanguageFontCPP , AccountPictureName , CredentialPickerCPP , ContactPicker
  • EstimateGlyphCount() : anonymous_namespace{FlowLayout.cpp}
  • EventReceived() : SDKSample::PortableDeviceCPP
  • ExecuteDelegate() : Hilo
  • ExifRotations : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- f -

  • F16EM_MASK : DirectX
  • F16MAX : DirectX
  • F16S_MASK : DirectX
  • Favorites : Hilo
  • FindChunk() : anonymous_namespace{SoundFileReader.cpp}
  • FindEdge() : AntSystem
  • flags : DirectX
  • FlipRotate() : DirectX
  • FONT_LOCAL : anonymous_namespace{AudioController.cpp} , anonymous_namespace{SimpleController.cpp}
  • FONT_LOCALE : anonymous_namespace{BasicSound.cpp} , anonymous_namespace{StreamEffect.cpp}
  • FONT_NAME
: anonymous_namespace{BasicSound.cpp}
, anonymous_namespace{StreamEffect.cpp}
, anonymous_namespace{AudioController.cpp}
, anonymous_namespace{SimpleController.cpp}
  • FONT_SIZE_HEADER : anonymous_namespace{SimpleController.cpp}
  • FONT_SIZE_TEXT
: anonymous_namespace{BasicSound.cpp}
, anonymous_namespace{StreamEffect.cpp}
, anonymous_namespace{AudioController.cpp}
, anonymous_namespace{SimpleController.cpp}
  • format : DirectX
  • FOURCC_DATA_TAG : anonymous_namespace{SoundFileReader.cpp}
  • FOURCC_FORMAT_TAG : anonymous_namespace{SoundFileReader.cpp}
  • FOURCC_RIFF_TAG : anonymous_namespace{SoundFileReader.cpp}
  • FOURCC_WAVE_FILE_TAG : anonymous_namespace{SoundFileReader.cpp}
  • FrameSessionStateKeyProperty : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • FrameSessionStateProperty : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • FromHexStringTo() : CppSamplesUtils::Details
  • FromStringTo() : CppSamplesUtils::Details
  • FromStringTo< Platform::Guid >() : CppSamplesUtils::Details
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- g -

  • g_aWeights2 : DirectX
  • g_aWeights3 : DirectX
  • g_aWeights4 : DirectX
  • g_LegacyDDSMap : DirectX
  • GameInfoOverlayCommand : Simple3DGameXaml
  • GameInfoOverlayState : Simple3DGameXaml
  • GameOverCompleted : Simple3DGameXaml
  • GameOverExpired : Simple3DGameXaml
  • GameStats : Simple3DGameXaml
  • GenerateMipMaps() : DirectX
  • GenerateMipMaps3D() : DirectX
  • GeometryShader : BasicSprites
  • GetClientInfo() : SDKSample
  • GetFirstStorageId() : SDKSample
  • GetGlyphMetrics() : anonymous_namespace{FlowLayout.cpp}
  • GetMetadataFromDDSFile() : DirectX
  • GetMetadataFromDDSMemory() : DirectX
  • GetMetadataFromTGAFile() : DirectX
  • GetMetadataFromTGAMemory() : DirectX
  • GetMetadataFromWICFile() : DirectX
  • GetMetadataFromWICMemory() : DirectX
  • GetSingleELSServiceWithNoOptions() : SDKSample::ELS::Private
  • GetWICCodec() : DirectX
  • Green : UiaCoreWindowProvider
  • GuidType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- h -

  • HDRColorALerp() : DirectX
  • Hub : Hilo
  • HubGroupType : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- i -

  • Image : Hilo
  • Images : PrintSample
  • IncomingconnectioneventHandler() : SimpleCommunication
  • inFormat : DirectX
  • INFORMATION_START_X
: anonymous_namespace{SimpleController.cpp}
, anonymous_namespace{BasicSound.cpp}
, anonymous_namespace{StreamEffect.cpp}
, anonymous_namespace{AudioController.cpp}
  • INFORMATION_START_Y
: anonymous_namespace{BasicSound.cpp}
, anonymous_namespace{StreamEffect.cpp}
, anonymous_namespace{AudioController.cpp}
, anonymous_namespace{SimpleController.cpp}
  • INPUT_DATA_START : anonymous_namespace{SimpleController.cpp}
  • INPUT_LABEL_START : anonymous_namespace{SimpleController.cpp}
  • inSize : DirectX
  • Instancing : BasicSprites
  • Int16Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • Int32Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • Int64Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • IsCompressed() : DirectX
  • IsPacked() : DirectX
  • IsSRGB() : DirectX
  • IsSupportedTexture() : DirectX
  • IsTypeless() : DirectX
  • IsValid() : DirectX
  • IsVideo() : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- p -

  • PageNavigateEventHandler() : Hilo
  • PageType : Hilo
  • Pause : Simple3DGameXaml
  • PhotoSize : PrintSample
  • Pictures : Hilo
  • Pixels : BasicSprites
  • pixelSize : DirectX
  • PlayAgain : Simple3DGameXaml
  • PlayLevel : Simple3DGameXaml
  • PleaseWait : Simple3DGameXaml
  • PlotDataReadyHandler() : SDKSample::WASAPIAudio
  • PositionUnits : BasicSprites
  • PressResultState : Simple3DGameXaml
  • PropertyTypeFromString() : CppSamplesUtils::Details
  • PropVariantPtr : SDKSample
  • ps4x6 : PrintSample
  • ps5x7 : PrintSample
  • ps8x10 : PrintSample
  • psFullPage : PrintSample
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- r -

  • ReadHeader() : anonymous_namespace{SoundFileReader.cpp}
  • ReadObject()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
  • ReadString()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • ReadStringToObjectMap()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • RecognizeTextLanguages() : SDKSample::ELS
  • RecognizeTextScripts() : SDKSample::ELS
  • Red : UiaCoreWindowProvider
  • RenderTechnique : BasicSprites
  • RepeaterStoppedFunction : Samples::Devices::Details
  • RepeaterTaskType : Samples::Devices::Details
  • Replication : BasicSprites
  • Resize() : DirectX
  • ResourcesLoaded : Simple3DGameXaml
  • Rotate : Hilo
  • RotatedDown : Hilo
  • RotatedLeft : Hilo
  • RotatedRight : Hilo
  • run_async_non_interactive() : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- s -

  • SaveToDDSFile() : DirectX
  • SaveToDDSMemory() : DirectX
  • SaveToTGAFile() : DirectX
  • SaveToTGAMemory() : DirectX
  • SaveToWICFile() : DirectX
  • SaveToWICMemory() : DirectX
  • Scaling : PrintSample
  • sCrop : PrintSample
  • SerializeSessionState() : CppSamplesUtils::Details
  • sessionStateFilename : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • SignatureButtonClickedHandler() : Postcard
  • SingleType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • size : DirectX
  • SizeUnits : BasicSprites
  • Snapped : Simple3DGameXaml
  • SOUND_FILE : anonymous_namespace{AudioController.cpp}
  • SOUND_FILE_LIST : anonymous_namespace{BasicSound.cpp}
  • SOUND_SAMPLE_RATE : anonymous_namespace{BasicSound.cpp}
  • sShrinkToFit : PrintSample
  • Started : SDKSample::ThreadPool
  • StartIoctl() : Samples::Devices
  • StartRepeaterTaskFunction : Samples::Devices::Details
  • STATE_HEADER : anonymous_namespace{SimpleController.cpp}
  • Status : SDKSample::ThreadPool
  • StatusMessage : SDKSample , AccountPictureName , AssociationLaunching , Clipboard , ContactPicker , CredentialPickerCPP , DatagramSocketSample , EdgeGestureSample , LanguageFontCPP , LockScreenAppsCPP , MediaExtensionsCPP , PrintSample , ProximityCPP , RawNotificationsSampleCPP , SimpleCommunication , ScheduledNotificationsSampleCPP , SecondaryTiles , ShareTarget , StreamSocketSample , ToastsSampleCPP , AppBarControl
  • StreamCopy() : SDKSample
  • StreamTypes
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • StringToObjectMapType : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • StringType : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • Suspended : Simple3DGameXaml
  • SwitchStateChangedHandler() : Samples::Devices::Fx2
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- t -

  • TapToContinue : Simple3DGameXaml
  • TEX_COMPRESS_A_DITHER : DirectX
  • TEX_COMPRESS_DEFAULT : DirectX
  • TEX_COMPRESS_DITHER : DirectX
  • TEX_COMPRESS_FLAGS : DirectX
  • TEX_COMPRESS_PARALLEL : DirectX
  • TEX_COMPRESS_RGB_DITHER : DirectX
  • TEX_COMPRESS_UNIFORM : DirectX
  • TEX_DIMENSION : DirectX
  • TEX_DIMENSION_TEXTURE1D : DirectX
  • TEX_DIMENSION_TEXTURE2D : DirectX
  • TEX_DIMENSION_TEXTURE3D : DirectX
  • TEX_FILTER_CUBIC : DirectX
  • TEX_FILTER_DEFAULT : DirectX
  • TEX_FILTER_DITHER : DirectX
  • TEX_FILTER_DITHER_DIFFUSION : DirectX
  • TEX_FILTER_FANT : DirectX
  • TEX_FILTER_FLAGS : DirectX
  • TEX_FILTER_LINEAR : DirectX
  • TEX_FILTER_POINT : DirectX
  • TEX_FILTER_SEPARATE_ALPHA : DirectX
  • TEX_FILTER_SRGB : DirectX
  • TEX_FILTER_SRGB_IN : DirectX
  • TEX_FILTER_SRGB_OUT : DirectX
  • TEX_FR_FLAGS : DirectX
  • TEX_FR_FLIP_HORIZONTAL : DirectX
  • TEX_FR_FLIP_VERTICAL : DirectX
  • TEX_FR_ROTATE0 : DirectX
  • TEX_FR_ROTATE180 : DirectX
  • TEX_FR_ROTATE270 : DirectX
  • TEX_FR_ROTATE90 : DirectX
  • TEX_MISC_FLAG : DirectX
  • TEX_MISC_TEXTURECUBE : DirectX
  • TEXP_LEGACY_A4L4 : DirectX
  • TEXP_LEGACY_A8P8 : DirectX
  • TEXP_LEGACY_A8R3G3B2 : DirectX
  • TEXP_LEGACY_B4G4R4A4 : DirectX
  • TEXP_LEGACY_FORMAT : DirectX
  • TEXP_LEGACY_P8 : DirectX
  • TEXP_LEGACY_R3G3B2 : DirectX
  • TEXP_LEGACY_R8G8B8 : DirectX
  • TEXP_LEGACY_UNKNOWN : DirectX
  • TEXP_SCANLINE_FLAGS : DirectX
  • TEXP_SCANLINE_LEGACY : DirectX
  • TEXP_SCANLINE_NONE : DirectX
  • TEXP_SCANLINE_SETALPHA : DirectX
  • Text : PrintSample
  • TextAndImages : PrintSample
  • TextSubmittedHandler() : Postcard
  • ThrowIfFailed() : SDKSample , DX , MEDIA
  • TITLE_MARGIN : anonymous_namespace{BasicSound.cpp}
  • ToString() : CppSamplesUtils::Details
  • TransliterateFromCyrillicToLatin() : SDKSample::ELS
  • TriColorValue : UiaCoreWindowProvider
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- u -

  • UInt16Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • UInt32Type : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • UInt64Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • UInt8Type : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • UniformHeight : BasicSprites
  • UniformWidth : BasicSprites
  • Unregistered : SDKSample::ThreadPool
  • UpdateEngineState : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- v -

  • VALUE_CAPS_VOICE_SUPPORT : anonymous_namespace{SimpleController.cpp}
  • VALUE_CAPS_WIRED : anonymous_namespace{SimpleController.cpp}
  • VALUE_CAPS_WIRELESS : anonymous_namespace{SimpleController.cpp}
  • VideoSettingsFilter() : SimpleCommunication
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- w -

  • WaitingForPress : Simple3DGameXaml
  • WaitingForResources : Simple3DGameXaml
  • WIC_CODEC_BMP : DirectX
  • WIC_CODEC_GIF : DirectX
  • WIC_CODEC_ICO : DirectX
  • WIC_CODEC_JPEG : DirectX
  • WIC_CODEC_PNG : DirectX
  • WIC_CODEC_TIFF : DirectX
  • WIC_CODEC_WMP : DirectX
  • WIC_FLAGS : DirectX
  • WIC_FLAGS_ALL_FRAMES : DirectX
  • WIC_FLAGS_ALLOW_MONO : DirectX
  • WIC_FLAGS_DITHER : DirectX
  • WIC_FLAGS_DITHER_DIFFUSION : DirectX
  • WIC_FLAGS_FILTER_CUBIC : DirectX
  • WIC_FLAGS_FILTER_FANT : DirectX
  • WIC_FLAGS_FILTER_LINEAR : DirectX
  • WIC_FLAGS_FILTER_POINT : DirectX
  • WIC_FLAGS_FORCE_RGB : DirectX
  • WIC_FLAGS_NO_16BPP : DirectX
  • WIC_FLAGS_NO_X2_BIAS : DirectX
  • WIC_FLAGS_NONE : DirectX
  • WICCodecs : DirectX
  • WriteObject()
: anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
  • WriteProperty()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • WriteString()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • WriteStringToObjectMap()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- x -

  • XINPUT_ENUM_TIMEOUT_MS : anonymous_namespace{AudioController.cpp} , anonymous_namespace{SimpleController.cpp}
  • XINPUT_HEADSET_CHECK_TIMEOUT_MS : anonymous_namespace{AudioController.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • u
  • v
  • w
  • x
  • y
Here is a list of all namespace members with links to the namespace documentation for each member:

- y -

  • Yellow : UiaCoreWindowProvider
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- b -

  • BC_FLAGS : DirectX
  • BlendMode : BasicSprites
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- n -

  • NotifyType : SDKSample , AppBarControl , SDKSample , ToastsSampleCPP , SDKSample , StreamSocketSample , SDKSample , ShareTarget , SDKSample , SecondaryTiles , SDKSample , ScheduledNotificationsSampleCPP , SDKSample , SimpleCommunication , SDKTemplate , SDKSample , RawNotificationsSampleCPP , SDKSample , ProximityCPP , SDKSample , PrintSample , SDKSample , SDKTemplate , SDKSample , MediaExtensionsCPP , SDKTemplateCS , SDKSample , SDKTemplate , SDKSample , LockScreenAppsCPP , SDKSample , LanguageFontCPP , SDKSample , EdgeGestureSample , SDKSample , DatagramSocketSample , SDKSample , SDKTemplate , SDKSample , CredentialPickerCPP , SDKSample , ContactPicker , SDKSample , Clipboard , SDKSample , AssociationLaunching , SDKSample , AccountPictureName
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- c -

  • CNMAP_FLAGS : DirectX
  • ContentType : SDKSample::WASAPIAudio
  • CONVERSION_FLAGS : DirectX
  • CONVERT_FLAGS : DirectX
  • CP_FLAGS : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- d -

  • DDS_FLAGS : DirectX
  • DDS_RESOURCE_DIMENSION : DirectX
  • DDS_RESOURCE_MISC_FLAG : DirectX
  • DeviceState : SDKSample::WASAPIAudio
  • DisplayContent : PrintSample
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- e -

  • ExifRotations : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- g -

  • GameInfoOverlayCommand : Simple3DGameXaml
  • GameInfoOverlayState : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- h -

  • HubGroupType : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- p -

  • PageType : Hilo
  • PhotoSize : PrintSample
  • PositionUnits : BasicSprites
  • PressResultState : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- r -

  • RenderTechnique : BasicSprites
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- s -

  • Scaling : PrintSample
  • SizeUnits : BasicSprites
  • Status : SDKSample::ThreadPool
  • StreamTypes
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- t -

  • TEX_COMPRESS_FLAGS : DirectX
  • TEX_DIMENSION : DirectX
  • TEX_FILTER_FLAGS : DirectX
  • TEX_FR_FLAGS : DirectX
  • TEX_MISC_FLAG : DirectX
  • TEXP_LEGACY_FORMAT : DirectX
  • TEXP_SCANLINE_FLAGS : DirectX
  • TriColorValue : UiaCoreWindowProvider
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- u -

  • UpdateEngineState : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • b
  • c
  • d
  • e
  • g
  • h
  • n
  • p
  • r
  • s
  • t
  • u
  • w

- w -

  • WIC_FLAGS : DirectX
  • WICCodecs : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- a -

  • Additive : BasicSprites
  • Alpha : BasicSprites
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- l -

  • LevelStart : Simple3DGameXaml
  • LoadGame : Simple3DGameXaml
  • Loading : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- m -

  • MapEndMarker : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- n -

  • None : Simple3DGameXaml
  • Normalized : BasicSprites
  • NotRotated : Hilo
  • NullPtrType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- b -

  • BC_FLAGS_DITHER_A : DirectX
  • BC_FLAGS_DITHER_RGB : DirectX
  • BC_FLAGS_NONE : DirectX
  • BC_FLAGS_UNIFORM : DirectX
  • BooleanType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • Browse : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- c -

  • Canceled : SDKSample::ThreadPool
  • Cartoonize : Hilo
  • Char16Type : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • CNMAP_CHANNEL_ALPHA : DirectX
  • CNMAP_CHANNEL_BLUE : DirectX
  • CNMAP_CHANNEL_GREEN : DirectX
  • CNMAP_CHANNEL_LUMINANCE : DirectX
  • CNMAP_CHANNEL_RED : DirectX
  • CNMAP_COMPUTE_OCCLUSION : DirectX
  • CNMAP_DEFAULT : DirectX
  • CNMAP_INVERT_SIGN : DirectX
  • CNMAP_MIRROR : DirectX
  • CNMAP_MIRROR_U : DirectX
  • CNMAP_MIRROR_V : DirectX
  • Completed : SDKSample::ThreadPool
  • ContentTypeFile : SDKSample::WASAPIAudio
  • ContentTypeTone : SDKSample::WASAPIAudio
  • ContinueLevel : Simple3DGameXaml
  • CONV_FLAGS_332 : DirectX
  • CONV_FLAGS_44 : DirectX
  • CONV_FLAGS_4444 : DirectX
  • CONV_FLAGS_5551 : DirectX
  • CONV_FLAGS_565 : DirectX
  • CONV_FLAGS_8332 : DirectX
  • CONV_FLAGS_888 : DirectX
  • CONV_FLAGS_A8P8 : DirectX
  • CONV_FLAGS_DX10 : DirectX
  • CONV_FLAGS_EXPAND : DirectX
  • CONV_FLAGS_NOALPHA : DirectX
  • CONV_FLAGS_NONE : DirectX
  • CONV_FLAGS_PAL8 : DirectX
  • CONV_FLAGS_SWIZZLE : DirectX
  • CONVF_A : DirectX
  • CONVF_B : DirectX
  • CONVF_BC : DirectX
  • CONVF_BGR : DirectX
  • CONVF_DEPTH : DirectX
  • CONVF_FLOAT : DirectX
  • CONVF_G : DirectX
  • CONVF_PACKED : DirectX
  • CONVF_R : DirectX
  • CONVF_RGB_MASK : DirectX
  • CONVF_RGBA_MASK : DirectX
  • CONVF_SHAREDEXP : DirectX
  • CONVF_SINT : DirectX
  • CONVF_SNORM : DirectX
  • CONVF_STENCIL : DirectX
  • CONVF_UINT : DirectX
  • CONVF_UNORM : DirectX
  • CONVF_X2 : DirectX
  • CP_FLAGS_16BPP : DirectX
  • CP_FLAGS_24BPP : DirectX
  • CP_FLAGS_8BPP : DirectX
  • CP_FLAGS_LEGACY_DWORD : DirectX
  • CP_FLAGS_NONE : DirectX
  • Crop : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- d -

  • DDS_DIMENSION_TEXTURE1D : DirectX
  • DDS_DIMENSION_TEXTURE2D : DirectX
  • DDS_DIMENSION_TEXTURE3D : DirectX
  • DDS_FLAGS_FORCE_DX10_EXT : DirectX
  • DDS_FLAGS_FORCE_RGB : DirectX
  • DDS_FLAGS_LEGACY_DWORD : DirectX
  • DDS_FLAGS_NO_16BPP : DirectX
  • DDS_FLAGS_NO_LEGACY_EXPANSION : DirectX
  • DDS_FLAGS_NO_R10B10G10A2_FIXUP : DirectX
  • DDS_FLAGS_NONE : DirectX
  • DDS_RESOURCE_MISC_TEXTURECUBE : DirectX
  • Deactivated : Simple3DGameXaml
  • DeviceStateActivated : SDKSample::WASAPIAudio
  • DeviceStateCapturing : SDKSample::WASAPIAudio
  • DeviceStateDiscontinutity : SDKSample::WASAPIAudio
  • DeviceStateFlushing : SDKSample::WASAPIAudio
  • DeviceStateInError : SDKSample::WASAPIAudio
  • DeviceStateInitialized : SDKSample::WASAPIAudio
  • DeviceStatePaused : SDKSample::WASAPIAudio
  • DeviceStatePausing : SDKSample::WASAPIAudio
  • DeviceStatePlaying : SDKSample::WASAPIAudio
  • DeviceStateStarting : SDKSample::WASAPIAudio
  • DeviceStateStopped : SDKSample::WASAPIAudio
  • DeviceStateStopping : SDKSample::WASAPIAudio
  • DeviceStateUnInitialized : SDKSample::WASAPIAudio
  • DIPs : BasicSprites
  • DoubleType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • Dynamics : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- e -

  • ErrorMessage : SDKSample , AppBarControl , ToastsSampleCPP , StreamSocketSample , ShareTarget , SecondaryTiles , ScheduledNotificationsSampleCPP , SimpleCommunication , RawNotificationsSampleCPP , ProximityCPP , PrintSample , MediaExtensionsCPP , LockScreenAppsCPP , LanguageFontCPP , EdgeGestureSample , DatagramSocketSample , CredentialPickerCPP , ContactPicker , Clipboard , AssociationLaunching , AccountPictureName
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- f -

  • Favorites : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- g -

  • GameOverCompleted : Simple3DGameXaml
  • GameOverExpired : Simple3DGameXaml
  • GameStats : Simple3DGameXaml
  • GeometryShader : BasicSprites
  • Green : UiaCoreWindowProvider
  • GuidType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- h -

  • Hub : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- i -

  • Image : Hilo
  • Images : PrintSample
  • Instancing : BasicSprites
  • Int16Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • Int32Type : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • Int64Type : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- p -

  • Pause : Simple3DGameXaml
  • Pictures : Hilo
  • Pixels : BasicSprites
  • PlayAgain : Simple3DGameXaml
  • PlayLevel : Simple3DGameXaml
  • PleaseWait : Simple3DGameXaml
  • ps4x6 : PrintSample
  • ps5x7 : PrintSample
  • ps8x10 : PrintSample
  • psFullPage : PrintSample
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- r -

  • Red : UiaCoreWindowProvider
  • Replication : BasicSprites
  • ResourcesLoaded : Simple3DGameXaml
  • Rotate : Hilo
  • RotatedDown : Hilo
  • RotatedLeft : Hilo
  • RotatedRight : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- s -

  • sCrop : PrintSample
  • SingleType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • Snapped : Simple3DGameXaml
  • sShrinkToFit : PrintSample
  • Started : SDKSample::ThreadPool
  • StatusMessage : AppBarControl , ToastsSampleCPP , AccountPictureName , LockScreenAppsCPP , SecondaryTiles , ScheduledNotificationsSampleCPP , SimpleCommunication , MediaExtensionsCPP , AssociationLaunching , PrintSample , ProximityCPP , Clipboard , LanguageFontCPP , EdgeGestureSample , DatagramSocketSample , StreamSocketSample , RawNotificationsSampleCPP , ContactPicker , CredentialPickerCPP , ShareTarget , SDKSample
  • StringToObjectMapType : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • StringType : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • Suspended : Simple3DGameXaml
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- t -

  • TapToContinue : Simple3DGameXaml
  • TEX_COMPRESS_A_DITHER : DirectX
  • TEX_COMPRESS_DEFAULT : DirectX
  • TEX_COMPRESS_DITHER : DirectX
  • TEX_COMPRESS_PARALLEL : DirectX
  • TEX_COMPRESS_RGB_DITHER : DirectX
  • TEX_COMPRESS_UNIFORM : DirectX
  • TEX_DIMENSION_TEXTURE1D : DirectX
  • TEX_DIMENSION_TEXTURE2D : DirectX
  • TEX_DIMENSION_TEXTURE3D : DirectX
  • TEX_FILTER_CUBIC : DirectX
  • TEX_FILTER_DEFAULT : DirectX
  • TEX_FILTER_DITHER : DirectX
  • TEX_FILTER_DITHER_DIFFUSION : DirectX
  • TEX_FILTER_FANT : DirectX
  • TEX_FILTER_LINEAR : DirectX
  • TEX_FILTER_POINT : DirectX
  • TEX_FILTER_SEPARATE_ALPHA : DirectX
  • TEX_FILTER_SRGB : DirectX
  • TEX_FILTER_SRGB_IN : DirectX
  • TEX_FILTER_SRGB_OUT : DirectX
  • TEX_FR_FLIP_HORIZONTAL : DirectX
  • TEX_FR_FLIP_VERTICAL : DirectX
  • TEX_FR_ROTATE0 : DirectX
  • TEX_FR_ROTATE180 : DirectX
  • TEX_FR_ROTATE270 : DirectX
  • TEX_FR_ROTATE90 : DirectX
  • TEX_MISC_TEXTURECUBE : DirectX
  • TEXP_LEGACY_A4L4 : DirectX
  • TEXP_LEGACY_A8P8 : DirectX
  • TEXP_LEGACY_A8R3G3B2 : DirectX
  • TEXP_LEGACY_B4G4R4A4 : DirectX
  • TEXP_LEGACY_P8 : DirectX
  • TEXP_LEGACY_R3G3B2 : DirectX
  • TEXP_LEGACY_R8G8B8 : DirectX
  • TEXP_LEGACY_UNKNOWN : DirectX
  • TEXP_SCANLINE_LEGACY : DirectX
  • TEXP_SCANLINE_NONE : DirectX
  • TEXP_SCANLINE_SETALPHA : DirectX
  • Text : PrintSample
  • TextAndImages : PrintSample
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- u -

  • UInt16Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • UInt32Type : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • UInt64Type : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • UInt8Type : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • UniformHeight : BasicSprites
  • UniformWidth : BasicSprites
  • Unregistered : SDKSample::ThreadPool
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- w -

  • WaitingForPress : Simple3DGameXaml
  • WaitingForResources : Simple3DGameXaml
  • WIC_CODEC_BMP : DirectX
  • WIC_CODEC_GIF : DirectX
  • WIC_CODEC_ICO : DirectX
  • WIC_CODEC_JPEG : DirectX
  • WIC_CODEC_PNG : DirectX
  • WIC_CODEC_TIFF : DirectX
  • WIC_CODEC_WMP : DirectX
  • WIC_FLAGS_ALL_FRAMES : DirectX
  • WIC_FLAGS_ALLOW_MONO : DirectX
  • WIC_FLAGS_DITHER : DirectX
  • WIC_FLAGS_DITHER_DIFFUSION : DirectX
  • WIC_FLAGS_FILTER_CUBIC : DirectX
  • WIC_FLAGS_FILTER_FANT : DirectX
  • WIC_FLAGS_FILTER_LINEAR : DirectX
  • WIC_FLAGS_FILTER_POINT : DirectX
  • WIC_FLAGS_FORCE_RGB : DirectX
  • WIC_FLAGS_NO_16BPP : DirectX
  • WIC_FLAGS_NO_X2_BIAS : DirectX
  • WIC_FLAGS_NONE : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • p
  • r
  • s
  • t
  • u
  • w
  • y

- y -

  • Yellow : UiaCoreWindowProvider
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- _ -

  • __declspec() : DirectX
  • _CalculateMipLevels() : DirectX
  • _CalculateMipLevels3D() : DirectX
  • _ConvertFromR32G32B32A32() : DirectX
  • _ConvertScanline() : DirectX
  • _ConvertToR32G32B32A32() : DirectX
  • _CopyScanline() : DirectX
  • _DetermineImageArray() : DirectX
  • _DXGIToWIC() : DirectX
  • _EncodeDDSHeader() : DirectX
  • _ExpandScanline() : DirectX
  • _GetConvertFlags() : DirectX
  • _GetWIC() : DirectX
  • _GetWICDither() : DirectX
  • _GetWICInterp() : DirectX
  • _In_reads_() : DirectX
  • _In_reads_bytes_() : DirectX
  • _In_reads_opt_() : DirectX
  • _LoadScanline() : DirectX
  • _Out_writes_() : DirectX
  • _ResizeSeparateColorAndAlpha() : DirectX
  • _SetupImageArray() : DirectX
  • _StoreScanline() : DirectX
  • _Success_() : DirectX
  • _SwizzleScanline() : DirectX
  • _WICBitsPerPixel() : DirectX
  • _WICToDXGI() : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- l -

  • LoadFromDDSFile() : DirectX
  • LoadFromDDSMemory() : DirectX
  • LoadFromTGAFile() : DirectX
  • LoadFromTGAMemory() : DirectX
  • LoadFromWICFile() : DirectX
  • LoadFromWICMemory() : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- m -

  • MakeSRGB() : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- n -

  • NavigateEventHandler() : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- o -

  • OnIoComplete() : Samples::Devices
  • OnServiceOpenComplete() : SDKSample::PortableDeviceCPP
  • OptimizeAlpha() : DirectX
  • OptimizeRoute() : AntSystem
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- a -

  • activatable() : UiaCoreWindowProvider
  • ActivatableClass() : Microsoft::Samples
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- b -

  • BitsPerPixel() : DirectX
  • ButtonClickedHandler() : Postcard
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- c -

  • CanExecuteDelegate() : Hilo
  • CaptureFailedHandler() : SimpleCommunication
  • CaptureTexture() : DirectX
  • Compress() : DirectX
  • ComputeHeuristicShortestDistance() : AntSystem
  • ComputeLengthOfRoute() : AntSystem
  • ComputeMSE() : DirectX
  • ComputeNormalMap() : DirectX
  • ComputePitch() : DirectX
  • ComputeScanlines() : DirectX
  • Convert() : DirectX
  • ConvertPropertyValueToString() : CppSamplesUtils::Details
  • ConvertStringToObject() : CppSamplesUtils::Details
  • CopyRectangle() : DirectX
  • create_empty_task() : Hilo
  • create_task_from_result() : Hilo
  • CreateShaderResourceView() : DirectX
  • CreateTexture() : DirectX
  • CreateXmlElementFromObject() : CppSamplesUtils::Details
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- d -

  • D3DXDecodeBC1() : DirectX
  • D3DXDecodeBC2() : DirectX
  • D3DXDecodeBC3() : DirectX
  • D3DXDecodeBC4S() : DirectX
  • D3DXDecodeBC4U() : DirectX
  • D3DXDecodeBC5S() : DirectX
  • D3DXDecodeBC5U() : DirectX
  • D3DXDecodeBC6HS() : DirectX
  • D3DXDecodeBC6HU() : DirectX
  • D3DXDecodeBC7() : DirectX
  • D3DXEncodeBC1() : DirectX
  • D3DXEncodeBC2() : DirectX
  • D3DXEncodeBC3() : DirectX
  • D3DXEncodeBC4S() : DirectX
  • D3DXEncodeBC4U() : DirectX
  • D3DXEncodeBC5S() : DirectX
  • D3DXEncodeBC5U() : DirectX
  • D3DXEncodeBC6HS() : DirectX
  • D3DXEncodeBC6HU() : DirectX
  • D3DXEncodeBC7() : DirectX
  • Decompress() : DirectX
  • DeserializeSessionState() : CppSamplesUtils::Details
  • DeviceStateChangedHandler() : SDKSample::WASAPIAudio
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- e -

  • EffectIntensityChangedHandler() : Postcard
  • EstimateGlyphCount() : anonymous_namespace{FlowLayout.cpp}
  • EventReceived() : SDKSample::PortableDeviceCPP
  • ExecuteDelegate() : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- f -

  • FindChunk() : anonymous_namespace{SoundFileReader.cpp}
  • FindEdge() : AntSystem
  • FlipRotate() : DirectX
  • FromHexStringTo() : CppSamplesUtils::Details
  • FromStringTo() : CppSamplesUtils::Details
  • FromStringTo< Platform::Guid >() : CppSamplesUtils::Details
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- g -

  • GenerateMipMaps() : DirectX
  • GenerateMipMaps3D() : DirectX
  • GetClientInfo() : SDKSample
  • GetFirstStorageId() : SDKSample
  • GetGlyphMetrics() : anonymous_namespace{FlowLayout.cpp}
  • GetMetadataFromDDSFile() : DirectX
  • GetMetadataFromDDSMemory() : DirectX
  • GetMetadataFromTGAFile() : DirectX
  • GetMetadataFromTGAMemory() : DirectX
  • GetMetadataFromWICFile() : DirectX
  • GetMetadataFromWICMemory() : DirectX
  • GetSingleELSServiceWithNoOptions() : SDKSample::ELS::Private
  • GetWICCodec() : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- h -

  • HDRColorALerp() : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- i -

  • IncomingconnectioneventHandler() : SimpleCommunication
  • IsCompressed() : DirectX
  • IsPacked() : DirectX
  • IsSRGB() : DirectX
  • IsSupportedTexture() : DirectX
  • IsTypeless() : DirectX
  • IsValid() : DirectX
  • IsVideo() : DirectX
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- p -

  • PageNavigateEventHandler() : Hilo
  • PlotDataReadyHandler() : SDKSample::WASAPIAudio
  • PropertyTypeFromString() : CppSamplesUtils::Details
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- r -

  • ReadHeader() : anonymous_namespace{SoundFileReader.cpp}
  • ReadObject()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
  • ReadString()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • ReadStringToObjectMap()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • RecognizeTextLanguages() : SDKSample::ELS
  • RecognizeTextScripts() : SDKSample::ELS
  • Resize() : DirectX
  • run_async_non_interactive() : Hilo
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- s -

  • SaveToDDSFile() : DirectX
  • SaveToDDSMemory() : DirectX
  • SaveToTGAFile() : DirectX
  • SaveToTGAMemory() : DirectX
  • SaveToWICFile() : DirectX
  • SaveToWICMemory() : DirectX
  • SerializeSessionState() : CppSamplesUtils::Details
  • SignatureButtonClickedHandler() : Postcard
  • StartIoctl() : Samples::Devices
  • StreamCopy() : SDKSample
  • SwitchStateChangedHandler() : Samples::Devices::Fx2
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- t -

  • TextSubmittedHandler() : Postcard
  • ThrowIfFailed() : DX , SDKSample , MEDIA
  • ToString() : CppSamplesUtils::Details
  • TransliterateFromCyrillicToLatin() : SDKSample::ELS
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- v -

  • VideoSettingsFilter() : SimpleCommunication
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • e
  • f
  • g
  • h
  • i
  • l
  • m
  • n
  • o
  • p
  • r
  • s
  • t
  • v
  • w

- w -

  • WriteObject()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • WriteProperty()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • WriteString()
: anonymous_namespace{suspensionmanager.cpp}
, anonymous_namespace{SuspensionManager.cpp}
  • WriteStringToObjectMap()
: anonymous_namespace{SuspensionManager.cpp}
, anonymous_namespace{suspensionmanager.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • BC_DECODE : DirectX
  • BC_ENCODE : DirectX
  • CoTaskMemString : SDKSample
  • DDS_RESOURCE_DIMENSION : DirectX
  • DDS_RESOURCE_MISC_FLAG : DirectX
  • DeviceClosingHandler : SDKSample::CustomDeviceAccess
  • PropVariantPtr : SDKSample
  • RepeaterStoppedFunction : Samples::Devices::Details
  • RepeaterTaskType : Samples::Devices::Details
  • StartRepeaterTaskFunction : Samples::Devices::Details
  • TriColorValue : UiaCoreWindowProvider
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Class Members

  • Namespace List
  • Namespace Members
  • All
  • Functions
  • Variables
  • Typedefs
  • Enumerations
  • Enumerator
  • _
  • a
  • b
  • c
  • d
  • f
  • g
  • i
  • l
  • m
  • n
  • o
  • p
  • s
  • t
  • v
  • x

- _ -

  • _registeredFrames : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • _sessionState : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}

- a -

  • APPLICATION_TITLE
: anonymous_namespace{BasicSound.cpp}
, anonymous_namespace{SimpleController.cpp}
, anonymous_namespace{AudioController.cpp}
, anonymous_namespace{StreamEffect.cpp}

- b -

  • BC67_WEIGHT_MAX : DirectX
  • BC67_WEIGHT_ROUND : DirectX
  • BC67_WEIGHT_SHIFT : DirectX
  • BC6H_MAX_SHAPES : DirectX
  • BC6H_NUM_CHANNELS : DirectX
  • BC7_MAX_SHAPES : DirectX
  • BC7_NUM_CHANNELS : DirectX
  • BUFFER_COUNT : anonymous_namespace{StreamEffect.cpp}

- c -

  • CAPS_DATA_START : anonymous_namespace{SimpleController.cpp}
  • CAPS_HEADER : anonymous_namespace{SimpleController.cpp}
  • CAPS_LABEL_START : anonymous_namespace{SimpleController.cpp}
  • CLEAR_COLOR : anonymous_namespace{SimpleController.cpp}
  • count : DirectX
  • cpFlags : DirectX

- d -

  • DDS_MAGIC : DirectX

- f -

  • F16EM_MASK : DirectX
  • F16MAX : DirectX
  • F16S_MASK : DirectX
  • flags : DirectX
  • FONT_LOCAL : anonymous_namespace{AudioController.cpp} , anonymous_namespace{SimpleController.cpp}
  • FONT_LOCALE : anonymous_namespace{StreamEffect.cpp} , anonymous_namespace{BasicSound.cpp}
  • FONT_NAME
: anonymous_namespace{BasicSound.cpp}
, anonymous_namespace{StreamEffect.cpp}
, anonymous_namespace{AudioController.cpp}
, anonymous_namespace{SimpleController.cpp}
  • FONT_SIZE_HEADER : anonymous_namespace{SimpleController.cpp}
  • FONT_SIZE_TEXT
: anonymous_namespace{AudioController.cpp}
, anonymous_namespace{SimpleController.cpp}
, anonymous_namespace{StreamEffect.cpp}
, anonymous_namespace{BasicSound.cpp}
  • format : DirectX
  • FOURCC_DATA_TAG : anonymous_namespace{SoundFileReader.cpp}
  • FOURCC_FORMAT_TAG : anonymous_namespace{SoundFileReader.cpp}
  • FOURCC_RIFF_TAG : anonymous_namespace{SoundFileReader.cpp}
  • FOURCC_WAVE_FILE_TAG : anonymous_namespace{SoundFileReader.cpp}
  • FrameSessionStateKeyProperty : anonymous_namespace{SuspensionManager.cpp} , anonymous_namespace{suspensionmanager.cpp}
  • FrameSessionStateProperty : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}

- g -

  • g_aWeights2 : DirectX
  • g_aWeights3 : DirectX
  • g_aWeights4 : DirectX
  • g_LegacyDDSMap : DirectX

- i -

  • inFormat : DirectX
  • INFORMATION_START_X
: anonymous_namespace{BasicSound.cpp}
, anonymous_namespace{AudioController.cpp}
, anonymous_namespace{SimpleController.cpp}
, anonymous_namespace{StreamEffect.cpp}
  • INFORMATION_START_Y
: anonymous_namespace{AudioController.cpp}
, anonymous_namespace{StreamEffect.cpp}
, anonymous_namespace{SimpleController.cpp}
, anonymous_namespace{BasicSound.cpp}
  • INPUT_DATA_START : anonymous_namespace{SimpleController.cpp}
  • INPUT_LABEL_START : anonymous_namespace{SimpleController.cpp}
  • inSize : DirectX

- l -

  • LABEL_CAPS_FLAGS : anonymous_namespace{SimpleController.cpp}
  • LABEL_CAPS_SUBTYPE : anonymous_namespace{SimpleController.cpp}
  • LABEL_CAPS_TYPE : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_BUTTONS : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_LEFT_THUMB_X : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_LEFT_THUMB_Y : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_LEFT_TRIGGER : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_PACKET_NUMBER : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_RIGHT_THUMB_X : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_RIGHT_THUMB_Y : anonymous_namespace{SimpleController.cpp}
  • LABEL_STATE_RIGHT_TRIGGER : anonymous_namespace{SimpleController.cpp}
  • LINE_HEIGHT : anonymous_namespace{SimpleController.cpp}

- m -

  • metadata : DirectX
  • MSG_INSTRUCTIONS : anonymous_namespace{AudioController.cpp}
  • MSG_NEED_AUDIO : anonymous_namespace{StreamEffect.cpp} , anonymous_namespace{BasicSound.cpp}
  • MSG_NEED_CONTROLLER : anonymous_namespace{AudioController.cpp} , anonymous_namespace{SimpleController.cpp}
  • MSG_NEED_HEADSET : anonymous_namespace{AudioController.cpp}
  • MUSIC_FILE : anonymous_namespace{StreamEffect.cpp}

- n -

  • nImages : DirectX

- o -

  • outFormat : DirectX
  • outSize : DirectX

- p -

  • pixelSize : DirectX

- s -

  • sessionStateFilename : anonymous_namespace{suspensionmanager.cpp} , anonymous_namespace{SuspensionManager.cpp}
  • size : DirectX
  • SOUND_FILE : anonymous_namespace{AudioController.cpp}
  • SOUND_FILE_LIST : anonymous_namespace{BasicSound.cpp}
  • SOUND_SAMPLE_RATE : anonymous_namespace{BasicSound.cpp}
  • STATE_HEADER : anonymous_namespace{SimpleController.cpp}

- t -

  • TITLE_MARGIN : anonymous_namespace{BasicSound.cpp}

- v -

  • VALUE_CAPS_VOICE_SUPPORT : anonymous_namespace{SimpleController.cpp}
  • VALUE_CAPS_WIRED : anonymous_namespace{SimpleController.cpp}
  • VALUE_CAPS_WIRELESS : anonymous_namespace{SimpleController.cpp}

- x -

  • XINPUT_ENUM_TIMEOUT_MS : anonymous_namespace{AudioController.cpp} , anonymous_namespace{SimpleController.cpp}
  • XINPUT_HEADSET_CHECK_TIMEOUT_MS : anonymous_namespace{AudioController.cpp}
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/common/suspensionmanager.h Source File

  • Transcoding media
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario10.xaml.h Source File

  • CryptoWinRT

Scenario10.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario10.xaml.h
00013 // Declaration of the Scenario10 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario10.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace CryptoWinRT
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario10 sealed
00031         {
00032         public:
00033             Scenario10();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/common/LayoutAwarePage.h Source File

  • XAML accessibility
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicTimer.h Source File

  • Direct3D stereoscopic 3D

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Constants.h Source File

  • App package information

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Package");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Layer Member List

This is the complete list of members for Layer, including all inherited members.
__pad0__ | Layer |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Layer | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) | Element | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() override | Layer | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
m_currentOpacity | Layer | [private]
m_initialOpacity | Layer | [private]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicReaderWriter.cpp Source File

  • DirectX marble maze game

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/App.xaml.h Source File

  • CryptoWinRT

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/DirectXBase.cpp Source File

  • XInput audio controller playback

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.h Source File

  • Direct2D effects on primitives

D2DEffectsOnPrimitives.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012
00013 ref class D2DEffectsOnPrimitives : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00014 {
00015 internal:
00016     // DirectXBase methods
00017     virtual void HandleDeviceLost() override;
00018     virtual void CreateDeviceIndependentResources() override;
00019     virtual void CreateDeviceResources() override;
00020     virtual void CreateWindowSizeDependentResources() override;
00021     virtual void Render() override;
00022
00023 public:
00024     // IFrameworkView methods
00025     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00026     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00027     virtual void Load(_In_ Platform::String^ entryPoint);
00028     virtual void Run();
00029     virtual void Uninitialize();
00030
00031 private:
00032     // Event handlers
00033     void OnWindowSizeChanged(
00034         _In_ Windows::UI::Core::CoreWindow^ sender,
00035         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00036         );
00037
00038     void OnLogicalDpiChanged(
00039         _In_ Platform::Object^ sender
00040         );
00041
00042     void OnDisplayContentsInvalidated(
00043         _In_ Platform::Object^ sender
00044         );
00045
00046     void OnActivated(
00047         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00048         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00049         );
00050
00051     void CreatePrimitives();
00052     void CreateEffectGraph();
00053
00054     SampleOverlay^                                      m_sampleOverlay;
00055
00056     Platform::String^                                   m_string;
00057     Microsoft::WRL::ComPtr<IDWriteTextFormat>           m_textFormat;
00058     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>        m_whiteBrush;
00059     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>        m_coloredBrush;
00060
00061     Microsoft::WRL::ComPtr<ID2D1Bitmap1>                m_inputImage;
00062     Microsoft::WRL::ComPtr<ID2D1Effect>                 m_arithmeticCompositeEffect;
00063 };
00064
00065 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00066 {
00067 public:
00068     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00069 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/DWriteParagraphText.cpp Source File

  • DirectWrite paragraph text

DWriteParagraphText.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DWriteParagraphText.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Foundation::Collections;
00019 using namespace Windows::Graphics::Display;
00020 using namespace Windows::UI::Input;
00021 using namespace Windows::UI::Core;
00022 using namespace Windows::UI::Popups;
00023 using namespace Windows::Storage;
00024
00025 DWriteParagraphText::DWriteParagraphText()
00026 {
00027 }
00028
00029 void DWriteParagraphText::CreateDeviceIndependentResources()
00030 {
00031     DirectXBase::CreateDeviceIndependentResources();
00032
00033     // Create a DirectWrite text format object.
00034     DX::ThrowIfFailed(
00035         m_dwriteFactory->CreateTextFormat(
00036             L"Segoe UI",
00037             nullptr,
00038             DWRITE_FONT_WEIGHT_REGULAR,
00039             DWRITE_FONT_STYLE_NORMAL,
00040             DWRITE_FONT_STRETCH_NORMAL,
00041             64.0f,
00042             L"en-US", // locale
00043             &m_textFormat
00044             )
00045         );
00046
00047     // Create two booleans to store the state of the layout.
00048     m_isJustified = false;
00049     m_isIncreasedSpacing = false;
00050
00051     // Center the text horizontally.
00052     DX::ThrowIfFailed(
00053         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00054         );
00055
00056     // Center the text vertically.
00057     DX::ThrowIfFailed(
00058         m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00059         );
00060 }
00061
00062 void DWriteParagraphText::CreateDeviceResources()
00063 {
00064     DirectXBase::CreateDeviceResources();
00065
00066     m_sampleOverlay = ref new SampleOverlay();
00067
00068     m_sampleOverlay->Initialize(
00069         m_d2dDevice.Get(),
00070         m_d2dContext.Get(),
00071         m_wicFactory.Get(),
00072         m_dwriteFactory.Get(),
00073         "DirectWrite paragraph text sample"
00074         );
00075
00076     DX::ThrowIfFailed(
00077         m_d2dContext->CreateSolidColorBrush(
00078             D2D1::ColorF(D2D1::ColorF::Black),
00079             &m_blackBrush
00080             )
00081         );
00082 }
00083
00084 void DWriteParagraphText::CreateWindowSizeDependentResources()
00085 {
00086     DirectXBase::CreateWindowSizeDependentResources();
00087
00088     Platform::String^ text = "Lorem ipsum dolor sit amet, consectetur adipiscing elit. Nunc convallis, \
00089 dui vel luctus posuere, mauris metus sodales justo, sit amet tincidunt velit \
00090 ipsum placerat augue. Integer consequat pellentesque orci, id pharetra dolor \
00091 lacinia quis. Donec leo neque, tempor ac imperdiet in, adipiscing vel nibh. \
00092 Curabitur sed est nibh. Etiam tincidunt sagittis tortor sed luctus. Nam purus \
00093 turpis, mattis nec malesuada vel, molestie ut velit. Etiam semper rutrum vestibulum.\
00094 Proin eget mi nunc. Vivamus lobortis iaculis risus at dapibus. In libero ipsum, feugiat \
00095 quis convallis ut, rutrum eget quam. ";
00096
00097     D2D1_SIZE_F size = m_d2dContext->GetSize();
00098     size.height = size.height / 3;
00099     size.width = size.width / 3;
00100
00101     ComPtr<IDWriteTextLayout> textLayout;
00102
00103     // Create a DirectWrite text layout object.
00104     DX::ThrowIfFailed(
00105         m_dwriteFactory->CreateTextLayout(
00106             text->Data(),                       // Text to be displayed
00107             text->Length(),                     // Length of the text
00108             m_textFormat.Get(),                 // DirectWrite Text Format object
00109             size.width,                         // Width of the Text Layout
00110             size.height,                        // Height of the Text Layout
00111             &textLayout
00112             )
00113         );
00114
00115     // QI the IDWriteTextLayout into a IDWriteTextLayout1.
00116     textLayout.As(&m_textLayout1);
00117
00118     m_textRange.startPosition = 0;
00119     m_textRange.length = text->Length();
00120     m_textLayout1->SetFontSize(16, m_textRange);
00121     m_textLayout1->SetCharacterSpacing(0.5f, 0.5f, 0, m_textRange);
00122 }
00123
00124 void DWriteParagraphText::Render()
00125 {
00126     m_d2dContext->BeginDraw();
00127
00128     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00129     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00130
00131     D2D1_SIZE_F screenSize = m_d2dContext->GetSize();
00132
00133     D2D1_SIZE_F size = m_d2dContext->GetSize();
00134     size.height = size.height / 3;
00135     size.width = size.width / 3;
00136
00137     m_d2dContext->DrawLine(
00138         D2D1::Point2F((screenSize.width - 2 * size.width), 0.0f),
00139         D2D1::Point2F((screenSize.width - 2 * size.width), screenSize.height),
00140         m_blackBrush.Get()
00141         );
00142
00143     m_d2dContext->DrawLine(
00144         D2D1::Point2F((screenSize.width - size.width), 0.0f),
00145         D2D1::Point2F((screenSize.width - size.width), screenSize.height),
00146         m_blackBrush.Get()
00147         );
00148
00149     m_d2dContext->DrawTextLayout(
00150         D2D1::Point2F(size.width, size.height),
00151         m_textLayout1.Get(),
00152         m_blackBrush.Get()
00153         );
00154
00155     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00156     // is lost. It will be handled during the next call to Present.
00157     HRESULT hr = m_d2dContext->EndDraw();
00158     if (hr != D2DERR_RECREATE_TARGET)
00159     {
00160         DX::ThrowIfFailed(hr);
00161     }
00162
00163     m_sampleOverlay->Render();
00164 }
00165
00166 void DWriteParagraphText::Initialize(
00167     _In_ CoreApplicationView^ applicationView
00168     )
00169 {
00170     applicationView->Activated +=
00171         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DWriteParagraphText::OnActivated);
00172
00173     CoreApplication::Suspending +=
00174         ref new EventHandler<SuspendingEventArgs^>(this, &DWriteParagraphText::OnSuspending);
00175
00176     CoreApplication::Resuming +=
00177         ref new EventHandler<Platform::Object^>(this, &DWriteParagraphText::OnResuming);
00178 }
00179
00180 void DWriteParagraphText::SetWindow(
00181     _In_ CoreWindow^ window
00182     )
00183 {
00184     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00185
00186     window->SizeChanged +=
00187         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DWriteParagraphText::OnWindowSizeChanged);
00188
00189     DisplayProperties::LogicalDpiChanged +=
00190         ref new DisplayPropertiesEventHandler(this, &DWriteParagraphText::OnLogicalDpiChanged);
00191
00192     DisplayProperties::DisplayContentsInvalidated +=
00193         ref new DisplayPropertiesEventHandler(this, &DWriteParagraphText::OnDisplayContentsInvalidated);
00194
00195     window->PointerMoved +=
00196         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &DWriteParagraphText::OnPointerMoved);
00197
00198     window->PointerPressed +=
00199         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &DWriteParagraphText::OnPointerPressed);
00200
00201     window->PointerReleased +=
00202         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &DWriteParagraphText::OnPointerReleased);
00203
00204     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00205
00206     m_gestureRecognizer = ref new GestureRecognizer();
00207
00208     m_gestureRecognizer->GestureSettings = GestureSettings::Hold;
00209
00210     m_gestureRecognizer->Holding +=
00211         ref new TypedEventHandler<GestureRecognizer^, HoldingEventArgs^>(this, &DWriteParagraphText::OnHolding);
00212 }
00213
00214 void DWriteParagraphText::OnPointerMoved(
00215     _In_ CoreWindow^ window,
00216     _In_ PointerEventArgs^ args
00217     )
00218 {
00219     m_gestureRecognizer->ProcessMoveEvents(args->GetIntermediatePoints());
00220 }
00221
00222 void DWriteParagraphText::OnPointerPressed(
00223     _In_ CoreWindow^ window,
00224     _In_ PointerEventArgs^ args
00225     )
00226 {
00227     m_gestureRecognizer->ProcessDownEvent(args->CurrentPoint);
00228 }
00229
00230 void DWriteParagraphText::OnPointerReleased(
00231     _In_ CoreWindow^ window,
00232     _In_ PointerEventArgs^ args
00233     )
00234 {
00235     m_gestureRecognizer->ProcessUpEvent(args->CurrentPoint);
00236
00237     if (args->CurrentPoint->Properties->PointerUpdateKind == PointerUpdateKind::RightButtonReleased)
00238     {
00239         ShowMenu(args->CurrentPoint->Position);
00240     }
00241 }
00242
00243 void DWriteParagraphText::OnHolding(
00244     _In_ GestureRecognizer^ recognizer,
00245     _In_ HoldingEventArgs^ args
00246     )
00247 {
00248     if (args->HoldingState == HoldingState::Started)
00249     {
00250         ShowMenu(args->Position);
00251     }
00252 }
00253
00254 void DWriteParagraphText::Load(
00255     _In_ Platform::String^ entryPoint
00256     )
00257 {
00258     // Retrieve any stored variables from the LocalSettings collection.
00259     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00260
00261     if (settingsValues->HasKey("m_isJustified"))
00262     {
00263         m_isJustified = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_isJustified"))->GetBoolean();
00264         ApplyJustificationSettings();
00265     }
00266     if (settingsValues->HasKey("m_isIncreasedSpacing"))
00267     {
00268         m_isIncreasedSpacing = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_isIncreasedSpacing"))->GetBoolean();
00269         ApplySpacingSettings();
00270     }
00271 }
00272
00273 void DWriteParagraphText::Run()
00274 {
00275     Render();
00276     Present();
00277
00278     CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
00279 }
00280
00281 void DWriteParagraphText::Uninitialize()
00282 {
00283 }
00284
00285 void DWriteParagraphText::OnWindowSizeChanged(
00286     _In_ CoreWindow^ sender,
00287     _In_ WindowSizeChangedEventArgs^ args
00288     )
00289 {
00290     UpdateForWindowSizeChange();
00291     m_sampleOverlay->UpdateForWindowSizeChange();
00292     ApplyJustificationSettings();
00293     ApplySpacingSettings();
00294     Render();
00295     Present();
00296 }
00297
00298 void DWriteParagraphText::OnLogicalDpiChanged(
00299     _In_ Platform::Object^ sender
00300     )
00301 {
00302     SetDpi(DisplayProperties::LogicalDpi);
00303     Render();
00304     Present();
00305 }
00306
00307 void DWriteParagraphText::OnDisplayContentsInvalidated(
00308     _In_ Platform::Object^ sender
00309     )
00310 {
00311     // Ensure the D3D Device is available for rendering.
00312     ValidateDevice();
00313
00314     ApplyJustificationSettings();
00315     ApplySpacingSettings();
00316     Render();
00317     Present();
00318 }
00319
00320 void DWriteParagraphText::OnActivated(
00321     _In_ CoreApplicationView^ applicationView,
00322     _In_ IActivatedEventArgs^ args
00323     )
00324 {
00325     m_window->Activate();
00326 }
00327
00328 void DWriteParagraphText::OnSuspending(
00329     _In_ Platform::Object^ sender,
00330     _In_ SuspendingEventArgs^ args
00331     )
00332 {
00333     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00334
00335     if (settingsValues->HasKey("m_isJustified"))
00336     {
00337         settingsValues->Remove("m_isJustified");
00338     }
00339     settingsValues->Insert("m_isJustified", PropertyValue::CreateBoolean(m_isJustified));
00340
00341     if (settingsValues->HasKey("m_isIncreasedSpacing"))
00342     {
00343         settingsValues->Remove("m_isIncreasedSpacing");
00344     }
00345     settingsValues->Insert("m_isIncreasedSpacing", PropertyValue::CreateBoolean(m_isIncreasedSpacing));
00346 }
00347
00348 void DWriteParagraphText::OnResuming(
00349     _In_ Platform::Object^ sender,
00350     _In_ Platform::Object^ args
00351     )
00352 {
00353 }
00354
00355 void DWriteParagraphText::ShowMenu(Point position)
00356 {
00357     PopupMenu^ popupMenu = ref new PopupMenu();
00358     popupMenu->Commands->Append(
00359         ref new UICommand("Toggle Justification",
00360         ref new UICommandInvokedHandler(this, &DWriteParagraphText::UpdateJustification))
00361         );
00362
00363     popupMenu->Commands->Append(
00364         ref new UICommand("Toggle Loose Character Spacing",
00365         ref new UICommandInvokedHandler(this, &DWriteParagraphText::UpdateCharacterSpacing))
00366         );
00367
00368     popupMenu->ShowAsync(position);
00369 }
00370
00371 void DWriteParagraphText::UpdateJustification(IUICommand^ command)
00372 {
00373     if (m_textLayout1->GetTextAlignment() == DWRITE_TEXT_ALIGNMENT_JUSTIFIED)
00374     {
00375         m_isJustified = false;
00376     }
00377     else
00378     {
00379         m_isJustified = true;
00380     }
00381     ApplyJustificationSettings();
00382     Render();
00383     Present();
00384 }
00385
00386 void DWriteParagraphText::UpdateCharacterSpacing(IUICommand^ command)
00387 {
00388     FLOAT leadingSpacing;
00389     FLOAT trailingSpacing;
00390     FLOAT minimumAdvanceWidth;
00391     m_textLayout1->GetCharacterSpacing(0, &leadingSpacing, &trailingSpacing, &minimumAdvanceWidth);
00392     if (leadingSpacing == 2)
00393     {
00394         m_isIncreasedSpacing = false;
00395     }
00396     else
00397     {
00398         m_isIncreasedSpacing = true;
00399     }
00400     ApplySpacingSettings();
00401     Render();
00402     Present();
00403 }
00404
00405 void DWriteParagraphText::ApplyJustificationSettings()
00406 {
00407     if (!m_isJustified)
00408     {
00409         m_textLayout1->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER);
00410     }
00411     else
00412     {
00413         m_textLayout1->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_JUSTIFIED);
00414     }
00415 }
00416
00417 void DWriteParagraphText::ApplySpacingSettings()
00418 {
00419     if (!m_isIncreasedSpacing)
00420     {
00421         m_textLayout1->SetCharacterSpacing(0.5f, 0.5f, 0, m_textRange);
00422     }
00423     else
00424     {
00425         m_textLayout1->SetCharacterSpacing(2, 2, 0, m_textRange);
00426     }
00427 }
00428
00429 IFrameworkView^ DirectXAppSource::CreateView()
00430 {
00431     return ref new DWriteParagraphText();
00432 }
00433
00434 [Platform::MTAThread]
00435 int main(Platform::Array<Platform::String^>^)
00436 {
00437     auto directXAppSource = ref new DirectXAppSource();
00438     CoreApplication::Run(directXAppSource);
00439     return 0;
00440 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Employee.h Source File

  • XAML data binding

Employee.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Employee.h
00010 // Declaration of the Employee class
00011 //
00012
00013 #pragma once
00014
00015 namespace SDKSample
00016 {
00017     namespace DataBinding
00018     {
00019         [Windows::Foundation::Metadata::WebHostHidden]
00020         [Windows::UI::Xaml::Data::Bindable] // in c++, adding this attribute to ref classes enables data binding for more info search for 'Bindable' on the page http://go.microsoft.com/fwlink/?LinkId=254639
00021         public ref class Employee sealed : Windows::UI::Xaml::Data::INotifyPropertyChanged
00022         {
00023         public:
00024             property Platform::String^ Name
00025             {
00026                 Platform::String^ get()
00027                 {
00028                     return _name;
00029                 }
00030                 void set(Platform::String^ value)
00031                 {
00032                     _name = value;
00033                     Employee::OnPropertyChanged("Name");
00034                 }
00035             }
00036
00037             property Platform::String^ Organization
00038             {
00039                 Platform::String^ get()
00040                 {
00041                     return _organization;
00042                 }
00043                 void set(Platform::String^ value)
00044                 {
00045                     _organization = value;
00046                     Employee::OnPropertyChanged("Organization");
00047                 }
00048             }
00049
00050         private:
00051             Platform::String^ _name;
00052             Platform::String^ _organization;
00053
00054 #pragma region INotifyPropertyChanged
00055         private:
00056             bool _isPropertyChangedObserved;
00057             event Windows::UI::Xaml::Data::PropertyChangedEventHandler^ _privatePropertyChanged;
00058
00059         protected:
00060             /// <summary>
00061             /// Notifies listeners that a property value has changed.
00062             /// </summary>
00063             /// <param name="propertyName">Name of the property used to notify listeners.</param>
00064             void OnPropertyChanged(String^ propertyName)
00065             {
00066                 if (_isPropertyChangedObserved)
00067                 {
00068                     PropertyChanged(this, ref new PropertyChangedEventArgs(propertyName));
00069                 }
00070             }
00071
00072         public:
00073             Employee()
00074             {
00075                 _isPropertyChangedObserved = false;
00076             }
00077
00078             // in c++, it is not neccessary to include definitions of add, remove, and raise.
00079             //  these definitions have been made explicitly here so that we can check if the
00080             //  event has listeners before firing the event
00081             virtual event Windows::UI::Xaml::Data::PropertyChangedEventHandler^ PropertyChanged
00082             {
00083                 virtual Windows::Foundation::EventRegistrationToken add(Windows::UI::Xaml::Data::PropertyChangedEventHandler^ e)
00084                 {
00085                     _isPropertyChangedObserved = true;
00086                     return _privatePropertyChanged += e;
00087                 }
00088                 virtual void remove(Windows::Foundation::EventRegistrationToken t)
00089                 {
00090                     _privatePropertyChanged -= t;
00091                 }
00092
00093         protected:
00094                 virtual void raise(Object^ sender, Windows::UI::Xaml::Data::PropertyChangedEventArgs^ e)
00095                 {
00096                     if (_isPropertyChangedObserved)
00097                     {
00098                         _privatePropertyChanged(sender, e);
00099                     }
00100                 }
00101             }
00102 #pragma endregion
00103
00104         };
00105     }
00106 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/App.xaml.cpp Source File

  • Mobile broadband account provisioning

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/ShapesPuzzle.cpp Source File

  • Input Touch hit testing

ShapesPuzzle.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "ShapesPuzzle.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Graphics::Display;
00019
00020 ShapesPuzzle::ShapesPuzzle()
00021 {
00022 }
00023
00024 void ShapesPuzzle::CreateDeviceResources()
00025 {
00026     DirectXBase::CreateDeviceResources();
00027
00028     m_sampleOverlay = ref new SampleOverlay();
00029
00030     m_sampleOverlay->Initialize(
00031         m_d2dDevice.Get(),
00032         m_d2dContext.Get(),
00033         m_wicFactory.Get(),
00034         m_dwriteFactory.Get(),
00035         "Shapes Puzzle - Touch Hit Test Sample"
00036         );
00037
00038     m_program->SetD2DContext(m_d2dContext.Get());
00039 }
00040
00041 void ShapesPuzzle::CreateWindowSizeDependentResources()
00042 {
00043     DirectXBase::CreateWindowSizeDependentResources();
00044     m_program->CreateWindowSizeDependentResources();
00045 }
00046
00047 void ShapesPuzzle::Render()
00048 {
00049     m_d2dContext->BeginDraw();
00050
00051     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00052     m_program->RenderObjects();
00053
00054     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00055     // is lost. It will be handled during the next call to Present.
00056     HRESULT hr = m_d2dContext->EndDraw();
00057     if (hr != D2DERR_RECREATE_TARGET)
00058     {
00059         DX::ThrowIfFailed(hr);
00060     }
00061
00062     m_sampleOverlay->Render();
00063 }
00064
00065 void ShapesPuzzle::Initialize(CoreApplicationView^ applicationView)
00066 {
00067     applicationView->Activated +=
00068         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &ShapesPuzzle::OnActivated);
00069
00070     CoreApplication::Suspending +=
00071         ref new EventHandler<SuspendingEventArgs^>(this, &ShapesPuzzle::OnSuspending);
00072
00073     CoreApplication::Resuming +=
00074         ref new EventHandler<Platform::Object^>(this, &ShapesPuzzle::OnResuming);
00075 }
00076
00077 void ShapesPuzzle::SetWindow(CoreWindow^ window)
00078 {
00079     m_program = ref new Program();
00080     m_program->Initialize(window);
00081
00082     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00083
00084     window->PointerPressed +=
00085         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &ShapesPuzzle::OnPointerPressed);
00086
00087     window->PointerMoved +=
00088         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &ShapesPuzzle::OnPointerMoved);
00089
00090     window->PointerReleased +=
00091         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &ShapesPuzzle::OnPointerReleased);
00092
00093     window->SizeChanged +=
00094         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &ShapesPuzzle::OnWindowSizeChanged);
00095
00096     DisplayProperties::LogicalDpiChanged +=
00097         ref new DisplayPropertiesEventHandler(this, &ShapesPuzzle::OnLogicalDpiChanged);
00098
00099     DisplayProperties::DisplayContentsInvalidated +=
00100         ref new DisplayPropertiesEventHandler(this, &ShapesPuzzle::OnDisplayContentsInvalidated);
00101
00102     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00103 }
00104
00105 void ShapesPuzzle::Load(Platform::String^ entryPoint)
00106 {
00107 }
00108
00109 void ShapesPuzzle::Run()
00110 {
00111     m_window->Activate();
00112
00113     Render();
00114     Present();
00115
00116     m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
00117 }
00118
00119 void ShapesPuzzle::Uninitialize()
00120 {
00121 }
00122
00123 void ShapesPuzzle::OnWindowSizeChanged(
00124     _In_ CoreWindow^ sender,
00125     _In_ WindowSizeChangedEventArgs^ args
00126     )
00127 {
00128     UpdateForWindowSizeChange();
00129     Render();
00130     Present();
00131 }
00132
00133 void ShapesPuzzle::OnPointerPressed(
00134     _In_ CoreWindow^,
00135     _In_ PointerEventArgs^ args)
00136 {
00137     m_program->OnPointerPressed(args);
00138 }
00139
00140 void ShapesPuzzle::OnPointerMoved(
00141     _In_ CoreWindow^,
00142     _In_ PointerEventArgs^ args)
00143 {
00144     m_program->OnPointerMoved(args);
00145     Render();
00146     Present();
00147 }
00148
00149 void ShapesPuzzle::OnPointerReleased(
00150     _In_ CoreWindow^,
00151     _In_ PointerEventArgs^ args)
00152 {
00153     m_program->OnPointerReleased(args);
00154     Render();
00155     Present();
00156 }
00157
00158 void ShapesPuzzle::OnLogicalDpiChanged(
00159     _In_ Platform::Object^ sender
00160     )
00161 {
00162     SetDpi(DisplayProperties::LogicalDpi);
00163     Render();
00164     Present();
00165 }
00166
00167 void ShapesPuzzle::OnDisplayContentsInvalidated(
00168     _In_ Platform::Object^ sender
00169     )
00170 {
00171     // Ensure the D3D Device is available for rendering.
00172     ValidateDevice();
00173
00174     Render();
00175     Present();
00176 }
00177
00178 void ShapesPuzzle::OnActivated(
00179     _In_ CoreApplicationView^ applicationView,
00180     _In_ IActivatedEventArgs^ args
00181     )
00182 {
00183     m_window->Activate();
00184 }
00185
00186 void ShapesPuzzle::OnSuspending(
00187     _In_ Platform::Object^ sender,
00188     _In_ SuspendingEventArgs^ args
00189     )
00190 {
00191 }
00192
00193 void ShapesPuzzle::OnResuming(
00194     _In_ Platform::Object^ sender,
00195     _In_ Platform::Object^ args
00196     )
00197 {
00198 }
00199
00200 IFrameworkView^ DirectXAppSource::CreateView()
00201 {
00202     return ref new ShapesPuzzle();
00203 }
00204
00205 [Platform::MTAThread]
00206 int main(Platform::Array<Platform::String^>^)
00207 {
00208     auto directXAppSource = ref new DirectXAppSource();
00209     CoreApplication::Run(directXAppSource);
00210     return 0;
00211 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaStreamer Member List

This is the complete list of members for MediaStreamer, including all inherited members.
GetMaxStreamLengthInBytes() | MediaStreamer | [inline]
GetMaxStreamLengthInBytes() const | MediaStreamer | [inline]
GetMaxStreamLengthInBytes() const | MediaStreamer | [inline]
GetNextBuffer(uint8 *buffer, uint32 maxBufferSize, uint32 *bufferLength) | MediaStreamer |
GetNextBuffer() | MediaStreamer |
GetNextBuffer() | MediaStreamer |
GetOutputWaveFormatEx() | MediaStreamer | [inline]
GetOutputWaveFormatEx() const | MediaStreamer | [inline]
GetOutputWaveFormatEx() const | MediaStreamer | [inline]
Initialize(_In_ const WCHAR *url) | MediaStreamer |
m_audioType | MediaStreamer |
m_maxStreamLengthInBytes | MediaStreamer | [private]
m_reader | MediaStreamer |
m_waveFormat | MediaStreamer | [private]
MediaStreamer() | MediaStreamer |
MediaStreamer(_In_ Platform::String^url) | MediaStreamer |
MediaStreamer(_In_ Platform::String^url) | MediaStreamer |
ReadAll(uint8 *buffer, uint32 maxBufferSize, uint32 *bufferLength) | MediaStreamer |
ReadAll() | MediaStreamer |
ReadAll() | MediaStreamer |
Restart() | MediaStreamer |
Restart() | MediaStreamer |
Restart() | MediaStreamer |
~MediaStreamer() | MediaStreamer |
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/pch.h Source File

  • Playback Manager Companion

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

UserInterface Member List

This is the complete list of members for UserInterface, including all inherited members.
GetD2DContext() | UserInterface | [inline, static]
GetDWriteFactory() | UserInterface | [inline, static]
GetInstance() | UserInterface | [inline, static]
HitTest(D2D1_POINT_2F point) | UserInterface |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory) | UserInterface |
m_d2dContext | UserInterface | [private]
m_d2dDevice | UserInterface | [private]
m_d2dFactory | UserInterface | [private]
m_dwriteFactory | UserInterface | [private]
m_elements | UserInterface | [private]
m_instance | UserInterface | [private, static]
m_stateBlock | UserInterface | [private]
m_wicFactory | UserInterface | [private]
RegisterElement(ElementBase *element) | UserInterface |
Render() | UserInterface |
UnregisterElement(ElementBase *element) | UserInterface |
Update(float timeTotal, float timeDelta) | UserInterface |
UserInterface() | UserInterface | [inline, private]
~UserInterface() | UserInterface | [inline, private]
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PointSnapper.h Source File

  • DirectX postcard app

PointSnapper.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011
00012 class PointSnapper
00013 {
00014 public:
00015     static void SnapGeometry(ID2D1Geometry* pGeometry, ID2D1Geometry** ppGeometry);
00016     static float SnapCoordinate(float x);
00017     static D2D1_POINT_2F SnapPoint(D2D1_POINT_2F pt);
00018     static float2 SnapPoint(float2 pt);
00019
00020 private:
00021     class PointSnappingSink : public ID2D1SimplifiedGeometrySink
00022     {
00023     public:
00024         static void CreatePointSnappingSink(
00025             _In_ ID2D1SimplifiedGeometrySink* pSink,
00026             _Outptr_ PointSnappingSink** ppPointSnappingSink
00027             );
00028
00029         // ID2D1SimplifiedGeometrySink methods.
00030         STDMETHOD_(void, AddBeziers)(const D2D1_BEZIER_SEGMENT* /*beziers*/, UINT /*beziersCount*/);
00031         STDMETHOD_(void, AddLines)(const D2D1_POINT_2F* points, UINT pointsCount);
00032         STDMETHOD_(void, BeginFigure)(D2D1_POINT_2F startPoint, D2D1_FIGURE_BEGIN figureBegin);
00033         STDMETHOD_(void, EndFigure)(D2D1_FIGURE_END figureEnd);
00034         STDMETHOD_(void, SetFillMode)(D2D1_FILL_MODE fillMode);
00035         STDMETHOD_(void, SetSegmentFlags)(D2D1_PATH_SEGMENT vertexFlags);
00036         STDMETHOD(Close)();
00037
00038         // IUknown methods.
00039         STDMETHOD(QueryInterface)(REFIID riid, _Outptr_ void** object) override;
00040         STDMETHOD_(ULONG, AddRef)() override;
00041         STDMETHOD_(ULONG, Release)() override;
00042
00043     private:
00044         // Private constructor used by CreatePointSnappingSink method.
00045         PointSnappingSink(_In_ ID2D1SimplifiedGeometrySink* pSink);
00046
00047         ID2D1SimplifiedGeometrySink* m_pSinkNoRef;      // The underlying ID2D1SimplifiedGeometrySink.
00048         ULONG m_ref;                                    // Reference count for AddRef and Release.
00049     };
00050 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeMedia.xaml.cpp Source File

  • Playback Manager Companion

StreamTypeMedia.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // StreamTypeMedia.xaml.cpp
00013 // Implementation of the StreamTypeMedia class
00014 //
00015
00016 #include "pch.h"
00017 #include "StreamTypeMedia.xaml.h"
00018
00019 using namespace SDKSample::PlaybackManager2;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::Xaml::Media;
00025
00026 StreamTypeMedia::StreamTypeMedia()
00027   : _playback(nullptr)
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void StreamTypeMedia::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // Get a pointer to our main page.
00040     rootPage = MainPage::Current;
00041 }
00042
00043
00044 void PlaybackManager2::StreamTypeMedia::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00045 {
00046   if(_playback == nullptr)
00047   {
00048     _playback = ref new Playback(Output);
00049   }
00050
00051   _playback->SetAudioCategory(AudioCategory::BackgroundCapableMedia);
00052   _playback->SetSourceStream("folk_rock.mp3");
00053 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/App.xaml.h Source File

  • Display orientation

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AppBarControl::sealed Member List

This is the complete list of members for AppBarControl::sealed, including all inherited members.
__pad0__ | AppBarControl::sealed | [protected]
AddFavoriteButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
autoSizeInputSectionWhenSnapped | AppBarControl::sealed | [private]
Back_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
Back_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
BottonAppBar_Loaded(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [protected]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
GlobalPage() | AppBarControl::sealed |
HiddenFrame | AppBarControl::sealed | [private]
InvalidateSize() | AppBarControl::sealed | [private]
InvalidateViewState() | AppBarControl::sealed | [private]
IsSticky_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
LoadScenario(Platform::String^scenarioName) | AppBarControl::sealed |
MainPage() | AppBarControl::sealed |
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | AppBarControl::sealed | [protected]
MainPageResized | AppBarControl::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | AppBarControl::sealed |
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | AppBarControl::sealed | [protected, virtual]
Page1() | AppBarControl::sealed |
Page2() | AppBarControl::sealed |
Page3() | AppBarControl::sealed |
PageTwo_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
PopulateScenarios() | AppBarControl::sealed | [private]
RegisterAppBarButtons() | AppBarControl::sealed | [private]
RemoveSaveButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
rightPanel | AppBarControl::sealed | [private]
rootPage | AppBarControl::sealed | [private, static]
rootPage | AppBarControl::sealed | [private, static]
rootPage | AppBarControl::sealed | [private]
rootPage | AppBarControl::sealed | [private]
Scenario1() | AppBarControl::sealed |
Scenario2() | AppBarControl::sealed |
Scenario3() | AppBarControl::sealed |
Scenario4() | AppBarControl::sealed |
ScenarioList | AppBarControl::sealed | [private]
ScenarioLoaded | AppBarControl::sealed |
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | AppBarControl::sealed | [protected]
SetFeatureName(Platform::String^strFeature) | AppBarControl::sealed | [private]
ShowMe_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
ShowMe_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
starButton | AppBarControl::sealed | [private]
starButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AppBarControl::sealed | [private]
~MainPage() | AppBarControl::sealed | [private]
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::Common::sealed Member List

This is the complete list of members for Hilo::Common::sealed, including all inherited members.
__pad0__ | Hilo::Common::sealed | [protected]
_overflowColumns | Hilo::Common::sealed | [private]
ArrangeOverride(Windows::Foundation::Size finalSize) override | Hilo::Common::sealed | [protected, virtual]
Convert(Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language) | Hilo::Common::sealed | [virtual]
Convert(Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language) | Hilo::Common::sealed | [virtual]
ConvertBack(Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language) | Hilo::Common::sealed | [virtual]
ConvertBack(Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language) | Hilo::Common::sealed | [virtual]
e | Hilo::Common::sealed | [protected]
MeasureOverride(Windows::Foundation::Size availableSize) override | Hilo::Common::sealed | [protected, virtual]
RestoreAsync(void) | Hilo::Common::sealed | [static]
RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^frame) | Hilo::Common::sealed | [private, static]
RichTextColumns() | Hilo::Common::sealed |
SaveAsync(void) | Hilo::Common::sealed | [static]
SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^frame) | Hilo::Common::sealed | [private, static]
SessionStateForFrame(Windows::UI::Xaml::Controls::Frame^frame) | Hilo::Common::sealed | [static]
sessionStateKey | Hilo::Common::sealed |
UnregisterFrame(Windows::UI::Xaml::Controls::Frame^frame) | Hilo::Common::sealed | [static]
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/pch.h Source File

  • XAML animation library

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/App.xaml.cpp Source File

  • Contact Picker app

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "App.xaml.h"
00018 #include "MainPage.xaml.h"
00019 #include "MainPagePicker.xaml.h"
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::ApplicationModel;
00024 using namespace Windows::ApplicationModel::Activation;
00025 using namespace CppSamplesUtils;
00026 using namespace ContactPicker;
00027 using namespace Windows::UI::Xaml::Interop;
00028
00029 App::App()
00030 {
00031     InitializeComponent();
00032     this->Suspending += ref new SuspendingEventHandler(this, &ContactPicker::App::OnSuspending);
00033 }
00034
00035 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00036 {
00037     auto deferral = pArgs->SuspendingOperation->GetDeferral();
00038     SuspensionManager::StartSaveTask().then([=]()
00039     {
00040         deferral->Complete();
00041     });
00042 }
00043
00044 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00045 {
00046     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00047     {
00048         SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
00049         {
00050             try
00051             {
00052                 restoreTask.get();
00053             }
00054             catch(Platform::Exception^)
00055             {
00056                 // If restore fails, the app should proceed as though there was no restored state.
00057             }
00058
00059             SetupWindowing(pArgs);
00060         });
00061     }
00062     else
00063     {
00064         SetupWindowing(pArgs);
00065     }
00066 }
00067
00068 void App::SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00069 {
00070     if (Window::Current->Content == nullptr)
00071     {
00072         rootFrame = ref new Frame();
00073         TypeName pageType = { "ContactPicker.MainPage", TypeKind::Custom };
00074         rootFrame->Navigate(pageType);
00075         Window::Current->Content = rootFrame;
00076     }
00077     MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
00078     p->LaunchArgs = pArgs;
00079     Window::Current->Activate();
00080 }
00081
00082 void App::OnActivated(IActivatedEventArgs^ args)
00083 {
00084     if (args->Kind == ActivationKind::ContactPicker)
00085     {
00086         auto page = ref new MainPagePicker();
00087         page->Activate(safe_cast<ContactPickerActivatedEventArgs^>(args));
00088     }
00089     else
00090     {
00091         __super::OnActivated(args);
00092     }
00093 }
00094
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/InvertModule.cpp Source File

  • Media extensions
  • MediaExtensions
  • Invert

InvertModule.cpp

Go to the documentation of this file.
00001 #pragma once
00002
00003 #include "InvertModule.h"
00004
00005 struct ScreenVertex
00006 {
00007     FLOAT pos[4];
00008     FLOAT tex[2];
00009 };
00010
00011 CInvertModule::~CInvertModule()
00012 {
00013     Invalidate();
00014 }
00015
00016 void CInvertModule::Invalidate()
00017 {
00018     m_pScreenQuadVB = nullptr;
00019     m_pSampleStateLinear = nullptr;
00020     m_spQuadLayout = nullptr;
00021     m_pVertexShader = nullptr;
00022     m_pPixelShader = nullptr;
00023 }
00024
00025 HRESULT CInvertModule::Initialize(ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight)
00026 {
00027     HRESULT hr = S_OK;
00028
00029     m_uiWidth = uiWidth;
00030     m_uiHeight = uiHeight;
00031
00032     if(m_pScreenQuadVB == nullptr)
00033     {
00034         // Vertex Buffer Layout
00035         D3D11_BUFFER_DESC vbdesc;
00036
00037         // 2 vertices (Triangles), covering the whole Viewport, with the input video mapped as a texture
00038         const ScreenVertex svDefault[4] = {
00039             //   x      y     z     w         u     v
00040             { { -1.0f,  1.0f, 0.5f, 1.0f }, { 0.0f, 0.0f } }, // 0
00041             { {  1.0f,  1.0f, 0.5f, 1.0f }, { 1.0f, 0.0f } }, // 1
00042             { { -1.0f, -1.0f, 0.5f, 1.0f }, { 0.0f, 1.0f } }, // 2
00043             { {  1.0f, -1.0f, 0.5f, 1.0f }, { 1.0f, 1.0f } }  // 3
00044         };
00045
00046         ZeroMemory(&vbdesc, sizeof(vbdesc));
00047
00048         vbdesc.Usage = D3D11_USAGE_DYNAMIC;
00049         vbdesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00050         vbdesc.CPUAccessFlags = D3D11_CPU_ACCESS_WRITE;
00051         vbdesc.MiscFlags = 0;
00052         vbdesc.ByteWidth = sizeof( svDefault );
00053
00054         D3D11_SUBRESOURCE_DATA InitData;
00055         InitData.pSysMem = svDefault;
00056         InitData.SysMemPitch = 0;
00057         InitData.SysMemSlicePitch = 0;
00058         hr = pDevice->CreateBuffer( &vbdesc, &InitData, &m_pScreenQuadVB );
00059         if( FAILED(hr) )
00060         {
00061             goto done;
00062         }
00063     }
00064
00065     // Pixel Shader
00066     {
00067         static
00068 #       include "PixelShader.hps"
00069         if(m_pPixelShader == nullptr)
00070         {
00071             hr = pDevice->CreatePixelShader(g_psshader, sizeof(g_psshader), NULL, &m_pPixelShader);
00072       if(FAILED(hr))
00073       {
00074         goto done;
00075       }
00076         }
00077     }
00078
00079     // Vertex Shader
00080     {
00081         static
00082 #       include "VertexShader.hvs"
00083         if( m_pVertexShader == nullptr )
00084         {
00085             const D3D11_INPUT_ELEMENT_DESC quadlayout[] =
00086             {
00087                 { "POSITION", 0, DXGI_FORMAT_R32G32B32A32_FLOAT, 0,  0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00088                 { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,       0, 16, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00089             };
00090             hr = pDevice->CreateVertexShader(g_vsshader, sizeof(g_vsshader), NULL, &m_pVertexShader);
00091       if(FAILED(hr))
00092       {
00093         goto done;
00094       }
00095
00096             hr = pDevice->CreateInputLayout(quadlayout, 2, g_vsshader, sizeof(g_vsshader), &m_spQuadLayout);
00097       if(FAILED(hr))
00098       {
00099         goto done;
00100       }
00101         }
00102     }
00103
00104     if( m_pSampleStateLinear == NULL )
00105     {
00106         // Sampler
00107         D3D11_SAMPLER_DESC SamplerDesc;
00108         ZeroMemory(&SamplerDesc, sizeof(SamplerDesc));
00109
00110         SamplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_CLAMP;
00111         SamplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_CLAMP;
00112         SamplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_CLAMP;
00113         SamplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;
00114         SamplerDesc.MaxLOD = D3D11_FLOAT32_MAX;
00115
00116         hr = pDevice->CreateSamplerState( &SamplerDesc, &m_pSampleStateLinear);
00117         if( FAILED(hr) )
00118         {
00119             goto done;
00120         }
00121     }
00122
00123     return hr;
00124
00125 done:
00126     m_pScreenQuadVB = nullptr;
00127     m_pSampleStateLinear = nullptr;
00128     m_spQuadLayout = nullptr;
00129     m_pVertexShader = nullptr;
00130     m_pPixelShader = nullptr;
00131     return hr;
00132
00133 }
00134
00135 HRESULT CreateShaderInputView(ID3D11Texture2D *pTexture, UINT uiIndex, ID3D11Device *pDevice, ID3D11ShaderResourceView **ppSRV)
00136 {
00137     D3D11_TEXTURE2D_DESC textureDesc;
00138     D3D11_SHADER_RESOURCE_VIEW_DESC viewDesc;
00139
00140     ZeroMemory( &viewDesc, sizeof( viewDesc ) );
00141
00142     pTexture->GetDesc( &textureDesc );
00143
00144     viewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00145
00146     if ( textureDesc.ArraySize > 1 )
00147     {
00148         // Texture array, use the subresource index
00149         viewDesc.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2DARRAY;
00150         viewDesc.Texture2DArray.FirstArraySlice = uiIndex;
00151         viewDesc.Texture2DArray.ArraySize = 1;
00152         viewDesc.Texture2DArray.MipLevels = 1;
00153         viewDesc.Texture2DArray.MostDetailedMip = 0;
00154     }
00155     else
00156     {
00157         viewDesc.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
00158         viewDesc.Texture2D.MostDetailedMip = 0;
00159         viewDesc.Texture2D.MipLevels = 1;
00160     }
00161
00162     return pDevice->CreateShaderResourceView(pTexture,
00163                                              &viewDesc,
00164                                              ppSRV);
00165 }
00166
00167 HRESULT CreateShaderOutputView(ID3D11Texture2D *pTexture, UINT uiIndex, ID3D11Device *pDevice, ID3D11RenderTargetView **ppRTV)
00168 {
00169     D3D11_TEXTURE2D_DESC textureDesc;
00170     D3D11_RENDER_TARGET_VIEW_DESC viewDesc;
00171
00172     ZeroMemory( &viewDesc, sizeof( viewDesc ) );
00173
00174     pTexture->GetDesc( &textureDesc );
00175
00176     viewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00177
00178     if ( textureDesc.ArraySize > 1 )
00179     {
00180         // Texture array, use the subresource index
00181         viewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2DARRAY;
00182         viewDesc.Texture2DArray.FirstArraySlice = uiIndex;
00183         viewDesc.Texture2DArray.ArraySize = 1;
00184         viewDesc.Texture2DArray.MipSlice = 0;
00185     }
00186     else
00187     {
00188         viewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
00189         viewDesc.Texture2D.MipSlice = 0;
00190     }
00191
00192     return pDevice->CreateRenderTargetView(pTexture,
00193                                            &viewDesc,
00194                                            ppRTV );
00195
00196 }
00197
00198 HRESULT CInvertModule::ProcessFrame(ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex)
00199 {
00200
00201     HRESULT hr = S_OK;
00202     ComPtr<ID3D11DeviceContext> pd3dImmediateContext;
00203
00204     // Render targets
00205     ComPtr<ID3D11RenderTargetView> rgpOrigRTV;
00206     ComPtr<ID3D11DepthStencilView> pOrigDSV;
00207     ID3D11RenderTargetView *pRTVs[1] = { nullptr };
00208
00209     // Shader resources
00210     ComPtr<ID3D11ShaderResourceView> rgpOrigSRV;
00211     ID3D11ShaderResourceView *pSRVs[1] = { nullptr };
00212
00213     // Vertex buffers
00214     ID3D11Buffer *pBuffers[1] = { m_pScreenQuadVB.Get() };
00215     UINT vbStrides = sizeof( ScreenVertex );
00216     UINT vbOffsets = 0;
00217
00218     // Samplers
00219     ID3D11SamplerState *pSamplers[1] = { m_pSampleStateLinear.Get() };
00220
00221     // View port
00222     D3D11_VIEWPORT vpOld[D3D11_VIEWPORT_AND_SCISSORRECT_MAX_INDEX];
00223     UINT nViewPorts = 1;
00224     D3D11_VIEWPORT vp;
00225
00226     // Get the context
00227     pDevice->GetImmediateContext(&pd3dImmediateContext);
00228
00229     // Get the resource views
00230     hr = CreateShaderInputView(pInput, uiInIndex, pDevice, &(pSRVs[0]));
00231     if( FAILED(hr) )
00232     {
00233         goto done;
00234     }
00235
00236     hr = CreateShaderOutputView(pOutput, uiOutIndex, pDevice, &(pRTVs[0]));
00237     if( FAILED(hr) )
00238     {
00239         goto done;
00240     }
00241
00242     // Setup the Draw call
00243     pd3dImmediateContext->IASetInputLayout(m_spQuadLayout.Get());
00244
00245     pd3dImmediateContext->IASetVertexBuffers(0, 1, pBuffers, &vbStrides, &vbOffsets);
00246
00247     pd3dImmediateContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP);
00248
00249     pd3dImmediateContext->PSSetSamplers(0, 1, pSamplers);
00250
00251     pd3dImmediateContext->OMGetRenderTargets(1, &rgpOrigRTV, &pOrigDSV);
00252
00253     pd3dImmediateContext->OMSetRenderTargets(1, pRTVs, NULL);
00254
00255     pd3dImmediateContext->PSGetShaderResources(0, 1, &rgpOrigSRV);
00256
00257     pd3dImmediateContext->PSSetShaderResources(0, 1, pSRVs);
00258
00259     pd3dImmediateContext->RSGetViewports( &nViewPorts, vpOld );
00260
00261     // Setup the viewport to match the backbuffer
00262     vp.Width = (float)m_uiWidth;
00263     vp.Height = (float)m_uiHeight;
00264     vp.MinDepth = 0.0f;
00265     vp.MaxDepth = 1.0f;
00266     vp.TopLeftX = 0.0f;
00267     vp.TopLeftY = 0.0f;
00268
00269     pd3dImmediateContext->RSSetViewports( 1, &vp );
00270
00271     pd3dImmediateContext->VSSetShader( m_pVertexShader.Get(), NULL, 0 );
00272
00273     pd3dImmediateContext->PSSetShader( m_pPixelShader.Get(), NULL, 0 );
00274
00275     pd3dImmediateContext->Draw( 4, 0 );
00276
00277     // Restore the Old
00278     pd3dImmediateContext->RSSetViewports( nViewPorts, vpOld );
00279     pd3dImmediateContext->PSSetShaderResources(0, 1, rgpOrigSRV.GetAddressOf());
00280     pd3dImmediateContext->OMSetRenderTargets( 1, rgpOrigRTV.GetAddressOf(), pOrigDSV.Get() );
00281
00282 done:
00283     if(nullptr != pSRVs[0])
00284     {
00285         pSRVs[0]->Release();
00286     }
00287     if(nullptr != pRTVs[0])
00288     {
00289         pRTVs[0]->Release();
00290     }
00291     return hr;
00292
00293 }
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicSprites.h Source File

  • Direct3D sprite

BasicSprites.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011 #include <vector>
00012 #include <map>
00013 #include <memory>
00014
00015 namespace BasicSprites
00016 {
00017     namespace Parameters
00018     {
00019         // The index buffer format for feature-level 9.1 devices may only be 16 bits.
00020         // With 4 vertices per sprite, this allows a maximum of (1 << 16) / 4 sprites.
00021         static unsigned int MaximumCapacityCompatible = (1 << 16) / 4;
00022     }
00023
00024     enum class PositionUnits
00025     {
00026         DIPs,         // Interpret position as device-independent pixel values.
00027         Pixels,       // Interpret position as pixel values.
00028         Normalized,   // Interpret position as a fraction of the render target dimensions.
00029         UniformWidth, // Interpret position as a fraction of the render target width.
00030         UniformHeight // Interpret position as a fraction of the render target height.
00031     };
00032
00033     enum class SizeUnits
00034     {
00035         DIPs,      // Interpret size as device-independent pixel values.
00036         Pixels,    // Interpret size as pixel values.
00037         Normalized // Interpret size as a multiplier of the pixel size of the sprite.
00038     };
00039
00040     enum class BlendMode
00041     {
00042         Alpha,   // Use alpha blending (out = old * (1 - new.a) + new * new.a).
00043         Additive // Use additive blending (out = old + new * new.a).
00044     };
00045
00046     enum class RenderTechnique
00047     {
00048         Replication,
00049         Instancing,
00050         GeometryShader
00051     };
00052
00053     struct ReplicationVertex
00054     {
00055         float2 pos;
00056         float2 tex;
00057         unsigned int color;
00058     };
00059
00060     struct InstancingVertex
00061     {
00062         float2 pos;
00063         float2 tex;
00064     };
00065
00066     struct InstanceData
00067     {
00068         float2 origin;
00069         float2 offset;
00070         float rotation;
00071         unsigned int color;
00072     };
00073
00074     struct TextureMapElement
00075     {
00076         Microsoft::WRL::ComPtr<ID3D11ShaderResourceView> srv;
00077         float2 size;
00078     };
00079
00080     struct SpriteRunInfo
00081     {
00082         ID3D11ShaderResourceView* textureView;
00083         ID3D11BlendState1* blendState;
00084         unsigned int numSprites;
00085     };
00086
00087     ref class SpriteBatch
00088     {
00089     internal:
00090         SpriteBatch();
00091         void Initialize(
00092             _In_ ID3D11Device1* d3dDevice,
00093             _In_ int capacity
00094             );
00095         void AddTexture(
00096             _In_ ID3D11Texture2D* texture
00097             );
00098         void RemoveTexture(
00099             _In_ ID3D11Texture2D* texture
00100             );
00101         void Begin();
00102         void End();
00103         void Draw(
00104             _In_ ID3D11Texture2D* texture,
00105             _In_ float2 position,
00106             _In_ PositionUnits positionUnits
00107             );
00108         void Draw(
00109             _In_ ID3D11Texture2D* texture,
00110             _In_ float2 position,
00111             _In_ PositionUnits positionUnits,
00112             _In_ float2 size,
00113             _In_ SizeUnits sizeUnits
00114             );
00115         void Draw(
00116             _In_ ID3D11Texture2D* texture,
00117             _In_ float2 position,
00118             _In_ PositionUnits positionUnits,
00119             _In_ float2 size,
00120             _In_ SizeUnits sizeUnits,
00121             _In_ float4 color
00122             );
00123         void Draw(
00124             _In_ ID3D11Texture2D* texture,
00125             _In_ float2 position,
00126             _In_ PositionUnits positionUnits,
00127             _In_ float2 size,
00128             _In_ SizeUnits sizeUnits,
00129             _In_ float4 color,
00130             _In_ float rotation
00131             );
00132         void Draw(
00133             _In_ ID3D11Texture2D* texture,
00134             _In_ float2 position,
00135             _In_ PositionUnits positionUnits,
00136             _In_ float2 size,
00137             _In_ SizeUnits sizeUnits,
00138             _In_ float4 color,
00139             _In_ float rotation,
00140             _In_ BlendMode blendMode
00141             );
00142
00143     private:
00144         unsigned int MakeUnorm(float4 color);
00145         float2 StandardOrigin(float2 position, PositionUnits positionUnits, float2 renderTargetSize, float dpi);
00146         float2 StandardOffset(float2 size, SizeUnits sizeUnits, float2 spriteSize, float dpi);
00147
00148         Microsoft::WRL::ComPtr<ID3D11Device1> m_d3dDevice;
00149         Microsoft::WRL::ComPtr<ID3D11DeviceContext1> m_d3dContext;
00150         Microsoft::WRL::ComPtr<ID3D11Buffer> m_vertexBuffer;
00151         Microsoft::WRL::ComPtr<ID3D11Buffer> m_instanceDataBuffer;
00152         Microsoft::WRL::ComPtr<ID3D11Buffer> m_indexBuffer;
00153         Microsoft::WRL::ComPtr<ID3D11BlendState1> m_blendStateAlpha;
00154         Microsoft::WRL::ComPtr<ID3D11BlendState1> m_blendStateAdditive;
00155         Microsoft::WRL::ComPtr<ID3D11InputLayout> m_inputLayout;
00156         Microsoft::WRL::ComPtr<ID3D11VertexShader> m_vertexShader;
00157         Microsoft::WRL::ComPtr<ID3D11GeometryShader> m_geometryShader;
00158         Microsoft::WRL::ComPtr<ID3D11PixelShader> m_pixelShader;
00159         Microsoft::WRL::ComPtr<ID3D11SamplerState> m_linearSampler;
00160         Microsoft::WRL::ComPtr<ID3D11Buffer> m_renderTargetInfoCbuffer;
00161
00162         std::unique_ptr<ReplicationVertex[]> m_vertexData;
00163         std::unique_ptr<InstanceData[]> m_instanceData;
00164         std::map<ID3D11Texture2D*, TextureMapElement> m_textureMap;
00165         std::vector<SpriteRunInfo> m_spriteRuns;
00166
00167         RenderTechnique m_technique;
00168         ID3D11ShaderResourceView* m_currentTextureView;
00169         ID3D11BlendState1* m_currentBlendState;
00170         float2 m_renderTargetSize;
00171         int m_capacity;
00172         int m_spritesInRun;
00173         int m_numSpritesDrawn;
00174         float m_dpi;
00175     };
00176 }
Generated on Sat Nov 23 2024 16:08:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/CurrencyFormatting.xaml.h Source File

  • Number formatting and parsing

CurrencyFormatting.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CurrencyFormatting.xaml.h
00013 // Declaration of the CurrencyFormatting class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "CurrencyFormatting.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace NumberFormatting
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class CurrencyFormatting sealed
00031         {
00032         public:
00033             CurrencyFormatting();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DDSTextureLoader.cpp Source File

  • DXGI offer and reclaim resources

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Constants.h Source File

  • XAML ListView and GridView essentials

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"XAML ListView and GridView essentials sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/MainPage.xaml.cpp Source File

  • Playback Manager msAudioCategory

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario3.xaml.h Source File

  • XAML scrolling, panning, and zooming

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ScrollViewerCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario3 sealed
00031         {
00032         public:
00033             Scenario3();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/SDKMesh.cpp Source File

  • DirectX marble maze game

SDKMesh.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // The SDK Mesh format (.sdkmesh) is not a recommended file format for production games.
00010 // It was designed to meet the specific needs of the SDK samples.  Any real-world
00011 // applications should avoid this file format in favor of a destination format that
00012 // meets the specific needs of the application.
00013 //
00014
00015 #include "pch.h"
00016
00017 using namespace DirectX;
00018
00019 #include "DDSTextureLoader.h"
00020 #include "SDKMesh.h"
00021 #include "BasicLoader.h"
00022
00023 void SDKMesh::LoadMaterials(ID3D11Device* d3dDevice, _In_reads_(numMaterials) SDKMESH_MATERIAL* materials, uint32 numMaterials)
00024 {
00025     BasicLoader^ loader = ref new BasicLoader(d3dDevice);
00026
00027     wchar_t path[MAX_PATH];
00028     wchar_t texturePath[MAX_PATH];
00029     size_t convertedChars = 0;
00030
00031         // This is a simple Mesh format that doesn't reuse texture data
00032         for (uint32 m = 0; m < numMaterials; m++)
00033         {
00034             materials[m].DiffuseTexture = nullptr;
00035             materials[m].NormalTexture = nullptr;
00036             materials[m].SpecularTexture = nullptr;
00037             materials[m].DiffuseRV = nullptr;
00038             materials[m].NormalRV = nullptr;
00039             materials[m].SpecularRV = nullptr;
00040
00041             // load textures
00042             if (materials[m].DiffuseTextureName[0] != 0)
00043             {
00044                 size_t size = strlen(materials[m].DiffuseTextureName) + 1;
00045                 mbstowcs_s(&convertedChars, texturePath, size, materials[m].DiffuseTextureName, _TRUNCATE);
00046                 swprintf_s(path, MAX_PATH, L"Media\\Textures\\%s", texturePath);
00047                 loader->LoadTexture(ref new Platform::String(path), nullptr, &materials[m].DiffuseRV);
00048             }
00049         }
00050 }
00051
00052 HRESULT SDKMesh::CreateVertexBuffer(ID3D11Device* d3dDevice, SDKMESH_VERTEX_BUFFER_HEADER* header, void* vertices)
00053 {
00054     HRESULT hr = S_OK;
00055     header->DataOffset = 0;
00056
00057     // Vertex Buffer
00058     D3D11_BUFFER_DESC bufferDesc;
00059     bufferDesc.ByteWidth = static_cast<uint32>(header->SizeBytes);
00060     bufferDesc.Usage = D3D11_USAGE_DEFAULT;
00061     bufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00062     bufferDesc.CPUAccessFlags = 0;
00063     bufferDesc.MiscFlags = 0;
00064
00065     D3D11_SUBRESOURCE_DATA initData;
00066     initData.pSysMem = vertices;
00067     hr = d3dDevice->CreateBuffer(&bufferDesc, &initData, &header->VertexBuffer);
00068
00069     return hr;
00070 }
00071
00072 HRESULT SDKMesh::CreateIndexBuffer(ID3D11Device* d3dDevice, SDKMESH_INDEX_BUFFER_HEADER* header, void* indices)
00073 {
00074     HRESULT hr = S_OK;
00075     header->DataOffset = 0;
00076
00077     // Index Buffer
00078     D3D11_BUFFER_DESC bufferDesc;
00079     bufferDesc.ByteWidth = static_cast<uint32>(header->SizeBytes);
00080     bufferDesc.Usage = D3D11_USAGE_DEFAULT;
00081     bufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00082     bufferDesc.CPUAccessFlags = 0;
00083     bufferDesc.MiscFlags = 0;
00084
00085     D3D11_SUBRESOURCE_DATA initData;
00086     initData.pSysMem = indices;
00087     hr = d3dDevice->CreateBuffer(&bufferDesc, &initData, &header->IndexBuffer);
00088
00089     return hr;
00090 }
00091
00092 HRESULT SDKMesh::CreateFromFile(ID3D11Device* d3dDevice, WCHAR* filename, bool createAdjacencyIndices)
00093 {
00094     HRESULT hr = S_OK;
00095
00096     m_hFile = CreateFile2(filename, GENERIC_READ, FILE_SHARE_READ, OPEN_EXISTING, nullptr);
00097
00098     if (INVALID_HANDLE_VALUE == m_hFile)
00099     {
00100         DWORD errorCode = GetLastError();
00101         const int msgSize = 512;
00102         WCHAR message[msgSize];
00103
00104         DWORD result = FormatMessage(
00105             FORMAT_MESSAGE_FROM_SYSTEM | FORMAT_MESSAGE_IGNORE_INSERTS,
00106             nullptr,
00107             errorCode,
00108             MAKELANGID(LANG_NEUTRAL, SUBLANG_DEFAULT),
00109             message,
00110             msgSize,
00111             nullptr
00112             );
00113         if ((result > 0) && (result < msgSize))
00114         {
00115             OutputDebugString(message);
00116         }
00117
00118         return E_FAIL;
00119     }
00120
00121     // Store the directory path without the filename
00122     wcsncpy_s(m_path, MAX_PATH, filename, wcslen(filename));
00123     WCHAR* lastBSlash = wcsrchr(m_path, L'\\');
00124     if (lastBSlash)
00125     {
00126         *(lastBSlash + 1) = L'\0';
00127     }
00128     else
00129     {
00130         *m_path = L'\0';
00131     }
00132
00133     // Get the file size
00134     FILE_STANDARD_INFO fileInfo = {0};
00135     if (!GetFileInformationByHandleEx(m_hFile, FileStandardInfo, &fileInfo, sizeof(fileInfo)))
00136     {
00137         throw ref new Platform::FailureException();
00138     }
00139
00140     if (fileInfo.EndOfFile.HighPart != 0)
00141     {
00142         throw ref new Platform::OutOfMemoryException();
00143     }
00144
00145     uint32 byteCount = fileInfo.EndOfFile.LowPart;
00146
00147     // Allocate memory
00148     m_staticMeshData = new byte[byteCount];
00149     if (!m_staticMeshData)
00150     {
00151         CloseHandle(m_hFile);
00152         return E_OUTOFMEMORY;
00153     }
00154
00155     // Read in the file
00156     DWORD bytesRead;
00157     if (!ReadFile(m_hFile, m_staticMeshData, byteCount, &bytesRead, nullptr))
00158     {
00159         hr = E_FAIL;
00160     }
00161
00162     CloseHandle(m_hFile);
00163
00164     if (SUCCEEDED(hr))
00165     {
00166         hr = CreateFromMemory(d3dDevice, m_staticMeshData, byteCount, createAdjacencyIndices, false);
00167         if (FAILED(hr))
00168         {
00169             delete[] m_staticMeshData;
00170         }
00171     }
00172
00173     return hr;
00174 }
00175
00176 HRESULT SDKMesh::CreateFromMemory(ID3D11Device* d3dDevice, byte* data, uint32 byteCount, bool createAdjacencyIndices, bool copyStatic)
00177 {
00178     HRESULT hr = E_FAIL;
00179     XMFLOAT3 lower;
00180     XMFLOAT3 upper;
00181
00182     m_d3dDevice = d3dDevice;
00183
00184     m_numOutstandingResources = 0;
00185
00186     if (copyStatic)
00187     {
00188         SDKMESH_HEADER* header = (SDKMESH_HEADER*)data;
00189
00190         size_t staticSize = static_cast<size_t>(header->HeaderSize + header->NonBufferDataSize);
00191         m_heapData = new BYTE[staticSize];
00192         if (m_heapData == nullptr)
00193         {
00194             return hr;
00195         }
00196         m_staticMeshData = m_heapData;
00197         CopyMemory(m_staticMeshData, data, staticSize);
00198     }
00199     else
00200     {
00201         m_heapData = data;
00202         m_staticMeshData = data;
00203     }
00204
00205     // Pointer fixup
00206     m_meshHeader = (SDKMESH_HEADER*)m_staticMeshData;
00207     m_vertexBufferArray = (SDKMESH_VERTEX_BUFFER_HEADER*)(m_staticMeshData + m_meshHeader->VertexStreamHeadersOffset);
00208     m_indexBufferArray = (SDKMESH_INDEX_BUFFER_HEADER*)(m_staticMeshData + m_meshHeader->IndexStreamHeadersOffset);
00209     m_meshArray = (SDKMESH_MESH*)(m_staticMeshData + m_meshHeader->MeshDataOffset);
00210     m_subsetArray = (SDKMESH_SUBSET*)(m_staticMeshData + m_meshHeader->SubsetDataOffset);
00211     m_frameArray = (SDKMESH_FRAME*)(m_staticMeshData + m_meshHeader->FrameDataOffset);
00212     m_materialArray = (SDKMESH_MATERIAL*)(m_staticMeshData + m_meshHeader->MaterialDataOffset);
00213
00214     // Setup subsets
00215     for (uint32 i = 0; i < m_meshHeader->NumMeshes; i++)
00216     {
00217         m_meshArray[i].Subsets = (uint32*)(m_staticMeshData + m_meshArray[i].SubsetOffset);
00218         m_meshArray[i].FrameInfluences = (uint32*)(m_staticMeshData + m_meshArray[i].FrameInfluenceOffset);
00219     }
00220
00221     // error condition
00222     if (m_meshHeader->Version != SDKMESH_FILE_VERSION)
00223     {
00224         hr = E_NOINTERFACE;
00225         goto Error;
00226     }
00227
00228     // Setup buffer data pointer
00229     byte* bufferData = data + m_meshHeader->HeaderSize + m_meshHeader->NonBufferDataSize;
00230
00231     // Get the start of the buffer data
00232     uint64 bufferDataStart = m_meshHeader->HeaderSize + m_meshHeader->NonBufferDataSize;
00233
00234     // Create vertex buffers
00235     m_vertices = new byte*[m_meshHeader->NumVertexBuffers];
00236     for (uint32 i = 0; i < m_meshHeader->NumVertexBuffers; i++)
00237     {
00238         byte* vertices = nullptr;
00239         vertices = (byte*)(bufferData + (m_vertexBufferArray[i].DataOffset - bufferDataStart));
00240         CreateVertexBuffer(d3dDevice, &m_vertexBufferArray[i], vertices);
00241         m_vertices[i] = vertices;
00242     }
00243
00244     // Create index buffers
00245     m_indices = new byte*[m_meshHeader->NumIndexBuffers];
00246     for (uint32 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
00247     {
00248         byte* indices = nullptr;
00249         indices = (byte*)(bufferData + (m_indexBufferArray[i].DataOffset - bufferDataStart));
00250         CreateIndexBuffer(d3dDevice, &m_indexBufferArray[i], indices);
00251         m_indices[i] = indices;
00252     }
00253
00254     // Load Materials
00255     if (d3dDevice)
00256     {
00257         LoadMaterials(d3dDevice, m_materialArray, m_meshHeader->NumMaterials);
00258     }
00259
00260     // Create a place to store our bind pose frame matrices
00261     m_bindPoseFrameMatrices = new XMMATRIX[m_meshHeader->NumFrames];
00262     if (!m_bindPoseFrameMatrices)
00263     {
00264         goto Error;
00265     }
00266
00267     // Create a place to store our transformed frame matrices
00268     m_transformedFrameMatrices = new XMMATRIX[m_meshHeader->NumFrames];
00269     if (!m_transformedFrameMatrices)
00270     {
00271         goto Error;
00272     }
00273     m_worldPoseFrameMatrices = new XMMATRIX[m_meshHeader->NumFrames];
00274     if (!m_worldPoseFrameMatrices)
00275     {
00276         goto Error;
00277     }
00278
00279     SDKMESH_SUBSET* subset = nullptr;
00280     D3D11_PRIMITIVE_TOPOLOGY primitiveType;
00281
00282     // update bounding volume
00283     SDKMESH_MESH* currentMesh = &m_meshArray[0];
00284     int tris = 0;
00285     for (uint32 mesh = 0; mesh < m_meshHeader->NumMeshes; ++mesh)
00286     {
00287         lower.x = XMVectorGetX(g_XMFltMax); lower.y = XMVectorGetX(g_XMFltMax); lower.z = XMVectorGetX(g_XMFltMax);
00288         upper.x = -XMVectorGetX(g_XMFltMax); upper.y = -XMVectorGetX(g_XMFltMax); upper.z = -XMVectorGetX(g_XMFltMax);
00289         currentMesh = GetMesh(mesh);
00290
00291         int indsize;
00292         if (m_indexBufferArray[currentMesh->IndexBuffer].IndexType == static_cast<uint32>(SDKMeshIndexType::Bits16))
00293         {
00294             indsize = 2;
00295         }
00296         else
00297         {
00298             indsize = 4;
00299         }
00300
00301         for (uint32 subsetIndex = 0; subsetIndex < currentMesh->NumSubsets; subsetIndex++)
00302         {
00303             subset = GetSubset(mesh, subsetIndex); // &m_pSubsetArray[currentMesh->pSubsets[subset]];
00304
00305             primitiveType = GetPrimitiveType(static_cast<SDKMeshPrimitiveType>(subset->PrimitiveType));
00306             assert(primitiveType == D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST); // only triangle lists are handled.
00307
00308             uint32 indexCount = (uint32)subset->IndexCount;
00309             uint32 indexStart = (uint32)subset->IndexStart;
00310
00311             uint32* ind = (uint32*)m_indices[currentMesh->IndexBuffer];
00312             float* verts = (float*)m_vertices[currentMesh->VertexBuffers[0]];
00313             uint32 stride = (uint32)m_vertexBufferArray[currentMesh->VertexBuffers[0]].StrideBytes;
00314             assert (stride % 4 == 0);
00315             stride /= 4;
00316             for (uint32 vertind = indexStart; vertind < indexStart + indexCount; ++vertind)
00317             {
00318                 uint32 currentIndex = 0;
00319                 if (indsize == 2)
00320                 {
00321                     uint32 ind_div2 = vertind / 2;
00322                     currentIndex = ind[ind_div2];
00323                     if ((vertind % 2) == 0)
00324                     {
00325                         currentIndex = currentIndex << 16;
00326                         currentIndex = currentIndex >> 16;
00327                     }
00328                     else
00329                     {
00330                         currentIndex = currentIndex >> 16;
00331                     }
00332                 }
00333                 else
00334                 {
00335                     currentIndex = ind[vertind];
00336                 }
00337                 tris++;
00338                 XMFLOAT3* pt = (XMFLOAT3*)&(verts[stride * currentIndex]);
00339                 if (pt->x < lower.x)
00340                 {
00341                     lower.x = pt->x;
00342                 }
00343                 if (pt->y < lower.y)
00344                 {
00345                     lower.y = pt->y;
00346                 }
00347                 if (pt->z < lower.z)
00348                 {
00349                     lower.z = pt->z;
00350                 }
00351                 if (pt->x > upper.x)
00352                 {
00353                     upper.x = pt->x;
00354                 }
00355                 if (pt->y > upper.y)
00356                 {
00357                     upper.y = pt->y;
00358                 }
00359                 if (pt->z > upper.z)
00360                 {
00361                     upper.z = pt->z;
00362                 }
00363             }
00364         }
00365         XMVECTOR u = XMLoadFloat3(&upper);
00366         XMVECTOR l = XMLoadFloat3(&lower);
00367         XMVECTOR half = XMVectorSubtract(u, l);
00368         XMVectorScale(half, 0.5f);
00369         XMStoreFloat3(&currentMesh->BoundingBoxExtents, half);
00370         half = XMVectorAdd(l, half);
00371         XMStoreFloat3(&currentMesh->BoundingBoxCenter, half);
00372     }
00373     // Update
00374     hr = S_OK;
00375 Error:
00376     return hr;
00377 }
00378
00379 // Transform bind pose frame using a recursive traversal
00380 void SDKMesh::TransformBindPoseFrame(uint32 frame, CXMMATRIX parentWorld)
00381 {
00382     if (m_bindPoseFrameMatrices == nullptr)
00383     {
00384         return;
00385     }
00386
00387     // Transform ourselves
00388     XMMATRIX localWorld = XMMatrixMultiply(XMLoadFloat4x4(&m_frameArray[frame].Matrix), parentWorld);
00389     m_bindPoseFrameMatrices[frame] = localWorld;
00390
00391     // Transform our siblings
00392     if (m_frameArray[frame].SiblingFrame != INVALID_FRAME)
00393     {
00394         TransformBindPoseFrame(m_frameArray[frame].SiblingFrame, parentWorld);
00395     }
00396
00397     // Transform our children
00398     if (m_frameArray[frame].ChildFrame != INVALID_FRAME)
00399     {
00400         TransformBindPoseFrame(m_frameArray[frame].ChildFrame, localWorld);
00401     }
00402 }
00403
00404 // Transform frame using a recursive traversal
00405 void SDKMesh::TransformFrame(uint32 frame, CXMMATRIX parentWorld, double time)
00406 {
00407     // Get the tick data
00408     XMMATRIX localTransform;
00409     uint32 tick = GetAnimationKeyFromTime(time);
00410
00411     if (INVALID_ANIMATION_DATA != m_frameArray[frame].AnimationDataIndex)
00412     {
00413         SDKANIMATION_FRAME_DATA* frameData = &m_animationFrameData[m_frameArray[frame].AnimationDataIndex];
00414         SDKANIMATION_DATA* data = &frameData->AnimationData[tick];
00415
00416         // turn it into a matrix (ignore scaling for now)
00417         XMMATRIX translate = XMMatrixTranslation(data->Translation.x, data->Translation.y, data->Translation.z);
00418         XMVECTOR quatVector;
00419         XMMATRIX quatMatrix;
00420
00421         if (data->Orientation.w == 0 && data->Orientation.x == 0 && data->Orientation.y == 0 && data->Orientation.z == 0)
00422         {
00423             quatVector = XMQuaternionIdentity();
00424         }
00425         else
00426         {
00427             quatVector = XMLoadFloat4(&data->Orientation);
00428             quatVector = XMVectorSwizzle(quatVector, 3, 0, 1, 2);
00429         }
00430
00431         quatVector = XMQuaternionNormalize(quatVector);
00432         quatMatrix = XMMatrixRotationQuaternion(quatVector);
00433         localTransform = (quatMatrix * translate);
00434     }
00435     else
00436     {
00437         localTransform = XMLoadFloat4x4(&m_frameArray[frame].Matrix);
00438     }
00439
00440     // Transform ourselves
00441     XMMATRIX localWorld = XMMatrixMultiply(localTransform, parentWorld);
00442     m_transformedFrameMatrices[frame] = localWorld;
00443     m_worldPoseFrameMatrices[frame] = localWorld;
00444
00445     // Transform our siblings
00446     if (m_frameArray[frame].SiblingFrame != INVALID_FRAME)
00447     {
00448         TransformFrame(m_frameArray[frame].SiblingFrame, parentWorld, time);
00449     }
00450
00451     // Transform our children
00452     if (m_frameArray[frame].ChildFrame != INVALID_FRAME)
00453     {
00454         TransformFrame(m_frameArray[frame].ChildFrame, localWorld, time);
00455     }
00456 }
00457
00458 // Transform frame assuming that it is an absolute transformation
00459 void SDKMesh::TransformFrameAbsolute(uint32 frame, double time)
00460 {
00461     XMMATRIX trans1;
00462     XMMATRIX trans2;
00463     XMMATRIX rot1;
00464     XMMATRIX rot2;
00465     XMVECTOR quat1;
00466     XMVECTOR quat2;
00467     XMMATRIX to;
00468     XMMATRIX invTo;
00469     XMMATRIX from;
00470
00471     uint32 tick = GetAnimationKeyFromTime(time);
00472
00473     if (INVALID_ANIMATION_DATA != m_frameArray[frame].AnimationDataIndex)
00474     {
00475         SDKANIMATION_FRAME_DATA* frameData = &m_animationFrameData[m_frameArray[frame].AnimationDataIndex];
00476         SDKANIMATION_DATA* data = &frameData->AnimationData[tick];
00477         SDKANIMATION_DATA* dataOrig = &frameData->AnimationData[0];
00478
00479         trans1 = XMMatrixTranslation(-dataOrig->Translation.x, -dataOrig->Translation.y, -dataOrig->Translation.z);
00480         trans2 = XMMatrixTranslation(data->Translation.x, data->Translation.y, data->Translation.z);
00481         quat1 = XMLoadFloat4(&dataOrig->Orientation);
00482         quat1 = XMQuaternionInverse(quat1);
00483         rot1 = XMMatrixRotationQuaternion(quat1);
00484         invTo = trans1 * rot1;
00485
00486         quat2 = XMLoadFloat4(&data->Orientation);
00487         rot2 = XMMatrixRotationQuaternion(quat2);
00488         from = rot2 * trans2;
00489
00490         XMMATRIX output = invTo * from;
00491         m_transformedFrameMatrices[frame] = output;
00492     }
00493 }
00494
00495 #define MAX_D3D11_VERTEX_STREAMS D3D11_IA_VERTEX_INPUT_RESOURCE_SLOT_COUNT
00496 void SDKMesh::RenderMesh(uint32 meshIndex, bool adjacent, ID3D11DeviceContext* d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot)
00497 {
00498     if (0 < GetOutstandingBufferResources())
00499     {
00500         return;
00501     }
00502
00503     SDKMESH_MESH* mesh = &m_meshArray[meshIndex];
00504     uint32 strides[MAX_D3D11_VERTEX_STREAMS];
00505     uint32 offsets[MAX_D3D11_VERTEX_STREAMS];
00506     ID3D11Buffer* vertexBuffer[MAX_D3D11_VERTEX_STREAMS];
00507
00508     ZeroMemory(strides, sizeof(uint32) * MAX_D3D11_VERTEX_STREAMS);
00509     ZeroMemory(offsets, sizeof(uint32) * MAX_D3D11_VERTEX_STREAMS);
00510     ZeroMemory(vertexBuffer, sizeof(ID3D11Buffer*) * MAX_D3D11_VERTEX_STREAMS);
00511
00512     if (mesh->NumVertexBuffers > MAX_D3D11_VERTEX_STREAMS)
00513     {
00514         return;
00515     }
00516
00517     for (uint64 i = 0; i < mesh->NumVertexBuffers; i++)
00518     {
00519         vertexBuffer[i] = m_vertexBufferArray[mesh->VertexBuffers[i]].VertexBuffer;
00520         strides[i] = static_cast<uint32>(m_vertexBufferArray[mesh->VertexBuffers[i]].StrideBytes);
00521         offsets[i] = 0;
00522     }
00523
00524     SDKMESH_INDEX_BUFFER_HEADER* indexBufferArray;
00525     if (adjacent)
00526     {
00527         indexBufferArray = m_adjacencyIndexBufferArray;
00528     }
00529     else
00530     {
00531         indexBufferArray = m_indexBufferArray;
00532     }
00533
00534     ID3D11Buffer* indexBuffer = indexBufferArray[mesh->IndexBuffer].IndexBuffer;
00535     DXGI_FORMAT indexBufferFormat = DXGI_FORMAT_R16_UINT;
00536     switch (indexBufferArray[mesh->IndexBuffer].IndexType)
00537     {
00538         case SDKMeshIndexType::Bits16:
00539             indexBufferFormat = DXGI_FORMAT_R16_UINT;
00540             break;
00541         case SDKMeshIndexType::Bits32:
00542             indexBufferFormat = DXGI_FORMAT_R32_UINT;
00543             break;
00544     };
00545
00546     d3dContext->IASetVertexBuffers(0, mesh->NumVertexBuffers, vertexBuffer, strides, offsets);
00547     d3dContext->IASetIndexBuffer(indexBuffer, indexBufferFormat, 0);
00548
00549     SDKMESH_SUBSET* subset = nullptr;
00550     SDKMESH_MATERIAL* material = nullptr;
00551     D3D11_PRIMITIVE_TOPOLOGY primitiveType;
00552
00553     for (uint32 i = 0; i < mesh->NumSubsets; i++)
00554     {
00555         subset = &m_subsetArray[mesh->Subsets[i]];
00556
00557         primitiveType = GetPrimitiveType(static_cast<SDKMeshPrimitiveType>(subset->PrimitiveType));
00558         if (adjacent)
00559         {
00560             switch (primitiveType)
00561             {
00562             case D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST:
00563                 primitiveType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST_ADJ;
00564                 break;
00565             case D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP:
00566                 primitiveType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP_ADJ;
00567                 break;
00568             case D3D11_PRIMITIVE_TOPOLOGY_LINELIST:
00569                 primitiveType = D3D11_PRIMITIVE_TOPOLOGY_LINELIST_ADJ;
00570                 break;
00571             case D3D11_PRIMITIVE_TOPOLOGY_LINESTRIP:
00572                 primitiveType = D3D11_PRIMITIVE_TOPOLOGY_LINESTRIP_ADJ;
00573                 break;
00574             }
00575         }
00576
00577         d3dContext->IASetPrimitiveTopology(primitiveType);
00578
00579         material = &m_materialArray[subset->MaterialID];
00580         if (diffuseSlot != INVALID_SAMPLER_SLOT && !IsErrorResource(material->DiffuseRV))
00581         {
00582             d3dContext->PSSetShaderResources(diffuseSlot, 1, &material->DiffuseRV);
00583         }
00584         if (normalSlot != INVALID_SAMPLER_SLOT && !IsErrorResource(material->NormalRV))
00585         {
00586             d3dContext->PSSetShaderResources(normalSlot, 1, &material->NormalRV);
00587         }
00588         if (specularSlot != INVALID_SAMPLER_SLOT && !IsErrorResource(material->SpecularRV))
00589         {
00590             d3dContext->PSSetShaderResources(specularSlot, 1, &material->SpecularRV);
00591         }
00592
00593         uint32 indexCount = (uint32)subset->IndexCount;
00594         uint32 indexStart = (uint32)subset->IndexStart;
00595         uint32 vertexStart = (uint32)subset->VertexStart;
00596
00597         if (adjacent)
00598         {
00599             indexCount *= 2;
00600             indexStart *= 2;
00601         }
00602
00603         d3dContext->DrawIndexed(indexCount, indexStart, vertexStart);
00604     }
00605 }
00606
00607 void SDKMesh::RenderFrame(uint32 frame, bool adjacent, ID3D11DeviceContext* d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot)
00608 {
00609     if (!m_staticMeshData || !m_frameArray)
00610     {
00611         return;
00612     }
00613
00614     if (m_frameArray[frame].Mesh != INVALID_MESH)
00615     {
00616         RenderMesh(m_frameArray[frame].Mesh, adjacent, d3dContext, diffuseSlot, normalSlot, specularSlot);
00617     }
00618
00619     // Render our children
00620     if (m_frameArray[frame].ChildFrame != INVALID_FRAME)
00621     {
00622         RenderFrame(m_frameArray[frame].ChildFrame, adjacent, d3dContext, diffuseSlot, normalSlot, specularSlot);
00623     }
00624
00625     // Render our siblings
00626     if (m_frameArray[frame].SiblingFrame != INVALID_FRAME)
00627     {
00628         RenderFrame(m_frameArray[frame].SiblingFrame, adjacent, d3dContext, diffuseSlot, normalSlot, specularSlot);
00629     }
00630 }
00631
00632 SDKMesh::SDKMesh() : m_numOutstandingResources(0),
00633     m_loading(false),
00634     m_hFile(0),
00635     m_hFileMappingObject(0),
00636     m_meshHeader(nullptr),
00637     m_staticMeshData(nullptr),
00638     m_heapData(nullptr),
00639     m_adjacencyIndexBufferArray(nullptr),
00640     m_animationData(nullptr),
00641     m_animationHeader(nullptr),
00642     m_vertices(nullptr),
00643     m_indices(nullptr),
00644     m_bindPoseFrameMatrices(nullptr),
00645     m_transformedFrameMatrices(nullptr),
00646     m_worldPoseFrameMatrices(nullptr),
00647     m_d3dDevice(nullptr)
00648 {
00649 }
00650
00651 SDKMesh::~SDKMesh()
00652 {
00653     Destroy();
00654 }
00655
00656 HRESULT SDKMesh::Create(ID3D11Device* d3dDevice, WCHAR* filename, bool createAdjacencyIndices)
00657 {
00658     Destroy();
00659     return CreateFromFile(d3dDevice, filename, createAdjacencyIndices);
00660 }
00661
00662 HRESULT SDKMesh::Create(ID3D11Device* d3dDevice, byte* data, uint32 byteCount, bool createAdjacencyIndices, bool copyStatic)
00663 {
00664     Destroy();
00665     return CreateFromMemory(d3dDevice, data, byteCount, createAdjacencyIndices, copyStatic);
00666 }
00667
00668 HRESULT SDKMesh::LoadAnimation(WCHAR* filename)
00669 {
00670     HRESULT hr = E_FAIL;
00671     DWORD bytesRead = 0;
00672     LARGE_INTEGER move;
00673     HANDLE fileHandle = CreateFile2(filename, GENERIC_READ, FILE_SHARE_READ, OPEN_EXISTING, nullptr);
00674
00675     if (INVALID_HANDLE_VALUE == fileHandle)
00676     {
00677         return E_FAIL;
00678     }
00679
00680     SDKANIMATION_FILE_HEADER fileHeader;
00681     if (!ReadFile(fileHandle, &fileHeader, sizeof(SDKANIMATION_FILE_HEADER), &bytesRead, nullptr))
00682     {
00683         goto Error;
00684     }
00685
00686     SAFE_DELETE_ARRAY(m_animationData);
00687     m_animationData = new BYTE[static_cast<size_t>((sizeof(SDKANIMATION_FILE_HEADER) + fileHeader.AnimationDataSize))];
00688     if (m_animationData == nullptr)
00689     {
00690         hr = E_OUTOFMEMORY;
00691         goto Error;
00692     }
00693
00694     move.QuadPart = 0;
00695     if (!SetFilePointerEx(fileHandle, move, nullptr, FILE_BEGIN))
00696     {
00697         goto Error;
00698     }
00699
00700     if (!ReadFile(fileHandle, m_animationData, static_cast<DWORD>(sizeof(SDKANIMATION_FILE_HEADER) + fileHeader.AnimationDataSize),
00701             &bytesRead, nullptr))
00702     {
00703         goto Error;
00704     }
00705
00706     // pointer fixup
00707     m_animationHeader = (SDKANIMATION_FILE_HEADER*)m_animationData;
00708     m_animationFrameData = (SDKANIMATION_FRAME_DATA*)(m_animationData + m_animationHeader->AnimationDataOffset);
00709
00710     uint64 baseOffset = sizeof(SDKANIMATION_FILE_HEADER);
00711     for (uint32 i = 0; i < m_animationHeader->NumFrames; i++)
00712     {
00713         m_animationFrameData[i].AnimationData = (SDKANIMATION_DATA*)(m_animationData + m_animationFrameData[i].DataOffset + baseOffset);
00714         SDKMESH_FRAME* frame = FindFrame(m_animationFrameData[i].FrameName);
00715         if (frame)
00716         {
00717             frame->AnimationDataIndex = i;
00718         }
00719     }
00720
00721     hr = S_OK;
00722
00723 Error:
00724     CloseHandle(fileHandle);
00725     return hr;
00726 }
00727
00728 void SDKMesh::Destroy()
00729 {
00730     if (m_staticMeshData != nullptr)
00731     {
00732         if (m_materialArray != nullptr)
00733         {
00734             for (uint64 m = 0; m < m_meshHeader->NumMaterials; m++)
00735             {
00736                 ID3D11Resource* resource = nullptr;
00737                 if (m_materialArray[m].DiffuseRV && !IsErrorResource(m_materialArray[m].DiffuseRV))
00738                 {
00739                     m_materialArray[m].DiffuseRV->GetResource(&resource);
00740                     SAFE_RELEASE(resource);
00741                     SAFE_RELEASE(m_materialArray[m].DiffuseRV);
00742                 }
00743                 if (m_materialArray[m].NormalRV && !IsErrorResource(m_materialArray[m].NormalRV))
00744                 {
00745                     m_materialArray[m].NormalRV->GetResource(&resource);
00746                     SAFE_RELEASE(resource);
00747                     SAFE_RELEASE(m_materialArray[m].NormalRV);
00748                 }
00749                 if (m_materialArray[m].SpecularRV && !IsErrorResource(m_materialArray[m].SpecularRV))
00750                 {
00751                     m_materialArray[m].SpecularRV->GetResource(&resource);
00752                     SAFE_RELEASE(resource);
00753                     SAFE_RELEASE(m_materialArray[m].SpecularRV);
00754                 }
00755             }
00756         }
00757     }
00758
00759     if (m_adjacencyIndexBufferArray != nullptr)
00760     {
00761         for (uint64 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
00762         {
00763             SAFE_RELEASE(m_adjacencyIndexBufferArray[i].IndexBuffer);
00764         }
00765     }
00766
00767     if (m_indexBufferArray != nullptr)
00768     {
00769         for (uint64 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
00770         {
00771             SAFE_RELEASE(m_indexBufferArray[i].IndexBuffer);
00772         }
00773     }
00774
00775     if (m_vertexBufferArray != nullptr)
00776     {
00777         for (uint64 i = 0; i < m_meshHeader->NumVertexBuffers; i++)
00778         {
00779             SAFE_RELEASE(m_vertexBufferArray[i].VertexBuffer);
00780         }
00781     }
00782
00783     SAFE_DELETE_ARRAY(m_adjacencyIndexBufferArray);
00784     SAFE_DELETE_ARRAY(m_heapData);
00785
00786     m_staticMeshData = nullptr;
00787
00788     SAFE_DELETE_ARRAY(m_animationData);
00789     SAFE_DELETE_ARRAY(m_bindPoseFrameMatrices);
00790     SAFE_DELETE_ARRAY(m_transformedFrameMatrices);
00791     SAFE_DELETE_ARRAY(m_worldPoseFrameMatrices);
00792     SAFE_DELETE_ARRAY(m_vertices);
00793     SAFE_DELETE_ARRAY(m_indices);
00794
00795     m_meshHeader = nullptr;
00796     m_vertexBufferArray = nullptr;
00797     m_indexBufferArray = nullptr;
00798     m_meshArray = nullptr;
00799     m_subsetArray = nullptr;
00800     m_frameArray = nullptr;
00801     m_materialArray = nullptr;
00802     m_animationHeader = nullptr;
00803     m_animationFrameData = nullptr;
00804     m_d3dDevice = nullptr;
00805 }
00806
00807 // Transform the bind pose
00808 void SDKMesh::TransformBindPose(CXMMATRIX world)
00809 {
00810     TransformBindPoseFrame(0, world);
00811 }
00812
00813 // Transform the mesh frames according to the animation for the given time
00814 void SDKMesh::TransformMesh(CXMMATRIX world, double time)
00815 {
00816     if (m_animationHeader == nullptr || FrameTransformType::Relative == static_cast<FrameTransformType>(m_animationHeader->FrameTransformType))
00817     {
00818         TransformFrame(0, world, time);
00819
00820         // For each frame, move the transform to the bind pose, then
00821         // move it to the final position
00822         XMMATRIX invBindPose;
00823         XMMATRIX final;
00824         for (uint32 i = 0; i < m_meshHeader->NumFrames; i++)
00825         {
00826             XMVECTOR determinant;
00827             invBindPose = XMMatrixInverse(&determinant, m_bindPoseFrameMatrices[i]);
00828
00829             final = invBindPose * m_transformedFrameMatrices[i];
00830             m_transformedFrameMatrices[i] = final;
00831         }
00832     }
00833     else if (FrameTransformType::Absolute == static_cast<FrameTransformType>(m_animationHeader->FrameTransformType))
00834     {
00835         for (uint32 i = 0; i < m_animationHeader->NumFrames; i++)
00836             TransformFrameAbsolute(i, time);
00837     }
00838 }
00839
00840 void SDKMesh::Render(ID3D11DeviceContext* d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot)
00841 {
00842     RenderFrame(0, false, d3dContext, diffuseSlot, normalSlot, specularSlot);
00843 }
00844
00845 void SDKMesh::RenderAdjacent(ID3D11DeviceContext* d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot)
00846 {
00847     RenderFrame(0, true, d3dContext, diffuseSlot, normalSlot, specularSlot);
00848 }
00849
00850 D3D11_PRIMITIVE_TOPOLOGY SDKMesh::GetPrimitiveType(SDKMeshPrimitiveType primitiveType)
00851 {
00852     D3D11_PRIMITIVE_TOPOLOGY returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST;
00853
00854     switch (primitiveType)
00855     {
00856         case SDKMeshPrimitiveType::TriangleList:
00857             returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST;
00858             break;
00859         case SDKMeshPrimitiveType::TriangleStrip:
00860             returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP;
00861             break;
00862         case SDKMeshPrimitiveType::LineList:
00863             returnType = D3D11_PRIMITIVE_TOPOLOGY_LINELIST;
00864             break;
00865         case SDKMeshPrimitiveType::LineStrip:
00866             returnType = D3D11_PRIMITIVE_TOPOLOGY_LINESTRIP;
00867             break;
00868         case SDKMeshPrimitiveType::PointList:
00869             returnType = D3D11_PRIMITIVE_TOPOLOGY_POINTLIST;
00870             break;
00871         case SDKMeshPrimitiveType::TriangleListAdjacent:
00872             returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST_ADJ;
00873             break;
00874         case SDKMeshPrimitiveType::TriangleStripAdjacent:
00875             returnType = D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP_ADJ;
00876             break;
00877         case SDKMeshPrimitiveType::LineListAdjacent:
00878             returnType = D3D11_PRIMITIVE_TOPOLOGY_LINELIST_ADJ;
00879             break;
00880         case SDKMeshPrimitiveType::LineStripAdjacent:
00881             returnType = D3D11_PRIMITIVE_TOPOLOGY_LINESTRIP_ADJ;
00882             break;
00883     };
00884
00885     return returnType;
00886 }
00887
00888 DXGI_FORMAT SDKMesh::GetIndexBufferFormat(uint32 mesh)
00889 {
00890     switch (m_indexBufferArray[m_meshArray[mesh].IndexBuffer].IndexType)
00891     {
00892         case SDKMeshIndexType::Bits16:
00893             return DXGI_FORMAT_R16_UINT;
00894         case SDKMeshIndexType::Bits32:
00895             return DXGI_FORMAT_R32_UINT;
00896     };
00897
00898     return DXGI_FORMAT_R16_UINT;
00899 }
00900
00901 ID3D11Buffer* SDKMesh::GetVertexBuffer(uint32 mesh, uint32 vertexBuffer)
00902 {
00903     return m_vertexBufferArray[m_meshArray[mesh].VertexBuffers[vertexBuffer]].VertexBuffer;
00904 }
00905
00906 ID3D11Buffer* SDKMesh::GetIndexBuffer(uint32 mesh)
00907 {
00908     return m_indexBufferArray[m_meshArray[mesh].IndexBuffer].IndexBuffer;
00909 }
00910
00911 SDKMeshIndexType SDKMesh::GetIndexType(uint32 mesh)
00912 {
00913     return static_cast<SDKMeshIndexType>(m_indexBufferArray[m_meshArray[mesh].IndexBuffer].IndexType);
00914 }
00915
00916 ID3D11Buffer* SDKMesh::GetAdjacencyIndexBuffer(uint32 mesh)
00917 {
00918     return m_adjacencyIndexBufferArray[m_meshArray[mesh].IndexBuffer].IndexBuffer;
00919 }
00920
00921 WCHAR* SDKMesh::GetMeshPath()
00922 {
00923     return m_path;
00924 }
00925
00926 uint32 SDKMesh::GetNumMeshes()
00927 {
00928     if (!m_meshHeader)
00929     {
00930         return 0;
00931     }
00932
00933     return m_meshHeader->NumMeshes;
00934 }
00935
00936 uint32 SDKMesh::GetNumMaterials()
00937 {
00938     if (!m_meshHeader)
00939     {
00940         return 0;
00941     }
00942
00943     return m_meshHeader->NumMaterials;
00944 }
00945
00946 uint32 SDKMesh::GetNumVertexBuffers()
00947 {
00948     if (!m_meshHeader)
00949     {
00950         return 0;
00951     }
00952
00953     return m_meshHeader->NumVertexBuffers;
00954 }
00955
00956 uint32 SDKMesh::GetNumIndexBuffers()
00957 {
00958     if (!m_meshHeader)
00959     {
00960         return 0;
00961     }
00962
00963     return m_meshHeader->NumIndexBuffers;
00964 }
00965
00966 ID3D11Buffer* SDKMesh::GetVertexBufferAt(uint32 vertexBuffer)
00967 {
00968     return m_vertexBufferArray[vertexBuffer].VertexBuffer;
00969 }
00970
00971 ID3D11Buffer* SDKMesh::GetIndexBufferAt(uint32 indexBuffer)
00972 {
00973     return m_indexBufferArray[indexBuffer].IndexBuffer;
00974 }
00975
00976 byte* SDKMesh::GetRawVerticesAt(uint32 vertexBuffer)
00977 {
00978     return m_vertices[vertexBuffer];
00979 }
00980
00981 byte* SDKMesh::GetRawIndicesAt(uint32 indexBuffer)
00982 {
00983     return m_indices[indexBuffer];
00984 }
00985
00986 SDKMESH_MATERIAL* SDKMesh::GetMaterial(uint32 material)
00987 {
00988     return &m_materialArray[material];
00989 }
00990
00991 SDKMESH_MESH* SDKMesh::GetMesh(uint32 mesh)
00992 {
00993     return &m_meshArray[mesh];
00994 }
00995
00996 uint32 SDKMesh::GetNumSubsets(uint32 mesh)
00997 {
00998     return m_meshArray[mesh].NumSubsets;
00999 }
01000
01001 SDKMESH_SUBSET* SDKMesh::GetSubset(uint32 mesh, uint32 subset)
01002 {
01003     return &m_subsetArray[m_meshArray[mesh].Subsets[subset]];
01004 }
01005
01006 uint32 SDKMesh::GetVertexStride(uint32 mesh, uint32 vertexBuffer)
01007 {
01008     return static_cast<uint32>(m_vertexBufferArray[m_meshArray[mesh].VertexBuffers[vertexBuffer]].StrideBytes);
01009 }
01010
01011 uint32 SDKMesh::GetNumFrames()
01012 {
01013     return m_meshHeader->NumFrames;
01014 }
01015
01016 SDKMESH_FRAME* SDKMesh::GetFrame(uint32 frame)
01017 {
01018     assert(frame < m_meshHeader->NumFrames);
01019
01020     if (frame < m_meshHeader->NumFrames)
01021     {
01022         return &m_frameArray[frame];
01023     }
01024
01025     return nullptr;
01026 }
01027
01028 SDKMESH_FRAME* SDKMesh::FindFrame(char* name)
01029 {
01030     for (uint32 i = 0; i < m_meshHeader->NumFrames; i++)
01031     {
01032         if (_stricmp(m_frameArray[i].Name, name) == 0)
01033         {
01034             return &m_frameArray[i];
01035         }
01036     }
01037
01038     return nullptr;
01039 }
01040
01041 uint64 SDKMesh::GetNumVertices(uint32 mesh, uint32 vertexBuffer)
01042 {
01043     return m_vertexBufferArray[m_meshArray[mesh].VertexBuffers[vertexBuffer]].NumVertices;
01044 }
01045
01046 uint64 SDKMesh::GetNumIndices(uint32 mesh)
01047 {
01048     return m_indexBufferArray[m_meshArray[mesh].IndexBuffer].NumIndices;
01049 }
01050
01051 XMFLOAT3 SDKMesh::GetMeshBoundingBoxCenter(uint32 mesh)
01052 {
01053     return m_meshArray[mesh].BoundingBoxCenter;
01054 }
01055
01056 XMFLOAT3 SDKMesh::GetMeshBoundingBoxExtents(uint32 mesh)
01057 {
01058     return m_meshArray[mesh].BoundingBoxExtents;
01059 }
01060
01061 uint32 SDKMesh::GetOutstandingResources()
01062 {
01063     uint32 outstandingResources = 0;
01064     if (m_meshHeader == nullptr)
01065     {
01066         return 1;
01067     }
01068
01069     outstandingResources += GetOutstandingBufferResources();
01070
01071     if (m_d3dDevice != nullptr)
01072     {
01073         for (uint32 i = 0; i < m_meshHeader->NumMaterials; i++)
01074         {
01075             if (m_materialArray[i].DiffuseTextureName[0] != 0)
01076             {
01077                 if (!m_materialArray[i].DiffuseRV && !IsErrorResource(m_materialArray[i].DiffuseRV))
01078                 {
01079                     outstandingResources++;
01080                 }
01081             }
01082
01083             if (m_materialArray[i].NormalTextureName[0] != 0)
01084             {
01085                 if (!m_materialArray[i].NormalRV && !IsErrorResource(m_materialArray[i].NormalRV))
01086                 {
01087                     outstandingResources++;
01088                 }
01089             }
01090
01091             if (m_materialArray[i].SpecularTextureName[0] != 0)
01092             {
01093                 if (!m_materialArray[i].SpecularRV && !IsErrorResource(m_materialArray[i].SpecularRV))
01094                 {
01095                     outstandingResources++;
01096                 }
01097             }
01098         }
01099     }
01100
01101     return outstandingResources;
01102 }
01103
01104 uint32 SDKMesh::GetOutstandingBufferResources()
01105 {
01106     uint32 outstandingResources = 0;
01107     if (m_meshHeader == nullptr)
01108     {
01109         return 1;
01110     }
01111
01112     for (uint32 i = 0; i < m_meshHeader->NumVertexBuffers; i++)
01113     {
01114         if ((m_vertexBufferArray[i].VertexBuffer == nullptr) && !IsErrorResource(m_vertexBufferArray[i].VertexBuffer))
01115         {
01116             outstandingResources++;
01117         }
01118     }
01119
01120     for (uint32 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
01121     {
01122         if ((m_indexBufferArray[i].IndexBuffer == nullptr) && !IsErrorResource(m_indexBufferArray[i].IndexBuffer))
01123         {
01124             outstandingResources++;
01125         }
01126     }
01127
01128     return outstandingResources;
01129 }
01130
01131 bool SDKMesh::CheckLoadDone()
01132 {
01133     if (0 == GetOutstandingResources())
01134     {
01135         m_loading = false;
01136         return true;
01137     }
01138
01139     return false;
01140 }
01141
01142 bool SDKMesh::IsLoaded()
01143 {
01144     if (m_staticMeshData && !m_loading)
01145     {
01146         return true;
01147     }
01148
01149     return false;
01150 }
01151
01152 bool SDKMesh::IsLoading()
01153 {
01154     return m_loading;
01155 }
01156
01157 void SDKMesh::SetLoading(bool loading)
01158 {
01159     m_loading = loading;
01160 }
01161
01162 bool SDKMesh::HadLoadingError()
01163 {
01164     if (m_meshHeader != nullptr)
01165     {
01166         for (uint32 i = 0; i < m_meshHeader->NumVertexBuffers; i++)
01167         {
01168             if (IsErrorResource(m_vertexBufferArray[i].VertexBuffer))
01169             {
01170                 return true;
01171             }
01172         }
01173
01174         for (uint32 i = 0; i < m_meshHeader->NumIndexBuffers; i++)
01175         {
01176             if (IsErrorResource(m_indexBufferArray[i].IndexBuffer))
01177             {
01178                 return true;
01179             }
01180         }
01181     }
01182
01183     return false;
01184 }
01185
01186 uint32 SDKMesh::GetNumInfluences(uint32 mesh)
01187 {
01188     return m_meshArray[mesh].NumFrameInfluences;
01189 }
01190
01191 uint32 SDKMesh::GetAnimationKeyFromTime(double time)
01192 {
01193     if (m_animationHeader == nullptr)
01194     {
01195         return 0;
01196     }
01197
01198     uint32 tick = static_cast<uint32>(m_animationHeader->AnimationFPS * time);
01199
01200     tick = tick % (m_animationHeader->NumAnimationKeys - 1);
01201     tick++;
01202
01203     return tick;
01204 }
01205
01206 bool SDKMesh::GetAnimationProperties(uint32* numKeys, float* frameTime)
01207 {
01208     if (m_animationHeader == nullptr)
01209     {
01210         return false;
01211     }
01212
01213     *numKeys = m_animationHeader->NumAnimationKeys;
01214     *frameTime = 1.0f / static_cast<float>(m_animationHeader->AnimationFPS);
01215
01216     return true;
01217 }
01218
01219 const CXMMATRIX SDKMesh::GetMeshInfluenceMatrix(uint32 mesh, uint32 influence)
01220 {
01221     uint32 frame = m_meshArray[mesh].FrameInfluences[influence];
01222     return m_transformedFrameMatrices[frame];
01223 }
01224
01225 const CXMMATRIX SDKMesh::GetWorldMatrix(uint32 frameIndex)
01226 {
01227     return m_worldPoseFrameMatrices[frameIndex];
01228 }
01229
01230 const CXMMATRIX SDKMesh::GetInfluenceMatrix(uint32 frameIndex)
01231 {
01232     return m_transformedFrameMatrices[frameIndex];
01233 }
01234
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/common/LayoutAwarePage.h Source File

  • Number formatting and parsing
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/MainPage.xaml.h Source File

  • Search contract

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioInput2.xaml.cpp Source File

  • Raw notifications
  • MainAppSample

ScenarioInput2.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Input.xaml.cpp
00010 // Implementation of the Scenario1Input class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput2.xaml.h"
00015
00016 using namespace RawNotificationsSampleCPP;
00017
00018 using namespace Platform;
00019 using namespace Windows::Networking::PushNotifications;
00020 using namespace Windows::UI::Core;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 ScenarioInput2::ScenarioInput2()
00026 {
00027   InitializeComponent();
00028     _dispatcher = Window::Current->Dispatcher;
00029 }
00030
00031 ScenarioInput2::~ScenarioInput2()
00032 {
00033 }
00034
00035 void ScenarioInput2::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037   // Get a pointer to our main page.
00038   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00039 }
00040
00041 void ScenarioInput2::OnNavigatedFrom(NavigationEventArgs^ e)
00042 {
00043   UpdateListener(false);
00044 }
00045
00046 void ScenarioInput2::Scenario2AddListener_Click(Object^ sender, RoutedEventArgs^ e)
00047 {
00048   if (UpdateListener(true))
00049     {
00050         rootPage->NotifyUser("Now listening for raw notifications", NotifyType::StatusMessage);
00051     }
00052     else
00053     {
00054         rootPage->NotifyUser("Channel not open--open a channel in Scenario 1", NotifyType::ErrorMessage);
00055     }
00056 }
00057
00058 void ScenarioInput2::Scenario2RemoveListener_Click(Object^ sender, RoutedEventArgs^ e)
00059 {
00060   if (UpdateListener(false))
00061     {
00062         rootPage->NotifyUser("No longer listening for raw notifications", NotifyType::StatusMessage);
00063     }
00064     else
00065     {
00066         rootPage->NotifyUser("Channel not open--open a channel in Scenario 1", NotifyType::ErrorMessage);
00067     }
00068 }
00069
00070 bool ScenarioInput2::UpdateListener(bool add)
00071 {
00072   if (rootPage->Channel != nullptr)
00073   {
00074     if (add && pushToken.Value == 0)
00075     {
00076       pushToken = rootPage->Channel->PushNotificationReceived += ref new TypedEventHandler<PushNotificationChannel^, PushNotificationReceivedEventArgs^>(this, &ScenarioInput2::OnPushNotificationReceived);
00077     }
00078     else if (!add && pushToken.Value != 0)
00079     {
00080       rootPage->Channel->PushNotificationReceived -= pushToken;
00081       pushToken.Value = 0;
00082     }
00083     return true;
00084   }
00085   return false;
00086 }
00087
00088 void ScenarioInput2::OnPushNotificationReceived(PushNotificationChannel^ sender, PushNotificationReceivedEventArgs^ e)
00089 {
00090   if (e->NotificationType == PushNotificationType::Raw)
00091   {
00092     e->Cancel = true;
00093     auto content = e->RawNotification->Content;
00094     _dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this, content] ()
00095     {
00096       rootPage->NotifyUser("Raw notification received with content: " + content, NotifyType::StatusMessage);
00097     }, CallbackContext::Any));
00098   }
00099 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Face.cpp Source File

  • DirectX 3D shooting game

Face.cpp

Go to the documentation of this file.
00001 /// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Face.h"
00010
00011 using namespace DirectX;
00012
00013 //----------------------------------------------------------------------
00014
00015 Face::Face()
00016 {
00017     SetPlane(
00018         XMFLOAT3(0.0f, 0.0f, 0.0f),
00019         XMFLOAT3(1.0f, 0.0f, 0.0f),
00020         XMFLOAT3(0.0f, 1.0f, 0.0f)
00021         );
00022 }
00023
00024 //----------------------------------------------------------------------
00025
00026 Face::Face(
00027     XMFLOAT3 origin,
00028     XMFLOAT3 p1,
00029     XMFLOAT3 p2
00030     )
00031 {
00032     SetPlane(origin, p1, p2);
00033 }
00034
00035 //--------------------------------------------------------------------------------
00036
00037 void Face::SetPlane(
00038     XMFLOAT3 origin,
00039     XMFLOAT3 p1,
00040     XMFLOAT3 p2
00041     )
00042 {
00043     m_position = origin;
00044     XMStoreFloat3(&m_widthVector, XMLoadFloat3(&p1) - XMLoadFloat3(&origin));
00045     XMStoreFloat3(&m_heightVector, XMLoadFloat3(&p2) - XMLoadFloat3(&origin));
00046
00047     m_point[0] = m_position;
00048     m_point[1] = p1;
00049     m_point[3] = p2;
00050     XMStoreFloat3(&m_point[2], XMLoadFloat3(&p1) + XMLoadFloat3(&m_heightVector));
00051
00052     XMStoreFloat(&m_width, XMVector3Length(XMLoadFloat3(&m_widthVector)));
00053     XMStoreFloat(&m_height, XMVector3Length(XMLoadFloat3(&m_heightVector)));
00054
00055     XMStoreFloat3(
00056         &m_normal,
00057         XMVector3Normalize(
00058             XMVector3Cross(
00059                 XMLoadFloat3(&m_widthVector),
00060                 XMLoadFloat3(&m_heightVector)
00061                 )
00062             )
00063         );
00064     UpdateMatrix();
00065 }
00066
00067 //--------------------------------------------------------------------------------
00068
00069 void Face::UpdatePosition()
00070 {
00071     m_point[0] = m_position;
00072     XMStoreFloat3(&m_point[1], XMLoadFloat3(&m_position) + XMLoadFloat3(&m_widthVector));
00073     XMStoreFloat3(&m_point[3], XMLoadFloat3(&m_position) + XMLoadFloat3(&m_heightVector));
00074     XMStoreFloat3(&m_point[2], XMLoadFloat3(&m_point[1]) + XMLoadFloat3(&m_heightVector));
00075
00076     XMStoreFloat4x4(
00077         &m_modelMatrix,
00078         XMMatrixScaling(m_width, m_height, 1.0f) *
00079         XMLoadFloat4x4(&m_rotationMatrix) *
00080         XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
00081         );
00082 }
00083
00084 //--------------------------------------------------------------------------------
00085
00086 bool Face::IsTouching(
00087     XMFLOAT3 point,
00088     float radius,
00089     _Out_ XMFLOAT3 *contact,
00090     _Out_ XMFLOAT3 *normal
00091     )
00092 {
00093     float dist;
00094
00095     // Determine if a point is within radius distance of the face and
00096     // return the point of contact (projection of the point onto the face).
00097
00098     XMStoreFloat(
00099         &dist,
00100         XMVector3Dot(
00101             XMLoadFloat3(&m_normal),
00102             XMLoadFloat3(&point) - XMLoadFloat3(&m_position)
00103             )
00104         );
00105
00106     // Determine the point of contact by projecting the point along the Normal
00107     // vector the distance the point is from the plane.
00108     XMStoreFloat3(contact, XMLoadFloat3(&point) - (XMLoadFloat3(&m_normal) * dist));
00109     normal->x = m_normal.x;
00110     normal->y = m_normal.y;
00111     normal->z = m_normal.z;
00112
00113     if (dist < 0.0f)
00114     {
00115         dist *= -1.0f;
00116         normal->x = -m_normal.x;
00117         normal->y = -m_normal.y;
00118         normal->z = -m_normal.z;
00119     }
00120     else
00121     {
00122         normal->x = m_normal.x;
00123         normal->y = m_normal.y;
00124         normal->z = m_normal.z;
00125     }
00126
00127     if (dist < radius)
00128     {
00129         // point is within radius of the plane
00130         //
00131         // Determine if the point of contact is inside the parallelogram of the target.
00132         // This is true if distance from each of the parallel lines defining the half
00133         // spaces is less than the distance between the parallel lines for both sets of
00134         // parallel lines.
00135         // To catch the cases where the contact point is just outside the parallelogram
00136         // but less than the radius we extend the parallelogram to accept points that are
00137         // the distance between the parallel lines plus the radius.
00138         //
00139
00140         float dist1, dist2, dist3, dist4;
00141
00142         XMStoreFloat(
00143             &dist1,
00144             XMVector3LinePointDistance(
00145                 XMLoadFloat3(&m_point[0]),
00146                 XMLoadFloat3(&m_point[1]),
00147                 XMLoadFloat3(contact)
00148                 )
00149             );
00150         XMStoreFloat(
00151             &dist2,
00152             XMVector3LinePointDistance(
00153                 XMLoadFloat3(&m_point[3]),
00154                 XMLoadFloat3(&m_point[2]),
00155                 XMLoadFloat3(contact)
00156                 )
00157             );
00158         XMStoreFloat(
00159             &dist3,
00160             XMVector3LinePointDistance(
00161                 XMLoadFloat3(&m_point[0]),
00162                 XMLoadFloat3(&m_point[3]),
00163                 XMLoadFloat3(contact)
00164                 )
00165             );
00166         XMStoreFloat(
00167             &dist4,
00168             XMVector3LinePointDistance(
00169                 XMLoadFloat3(&m_point[1]),
00170                 XMLoadFloat3(&m_point[2]),
00171                 XMLoadFloat3(contact)
00172                 )
00173             );
00174
00175         if (dist1 < (m_height + radius) &&
00176             dist2 < (m_height + radius) &&
00177             dist3 < (m_width + radius) &&
00178             dist4 < (m_width + radius))
00179         {
00180             return true;
00181         }
00182         else
00183         {
00184             return false;
00185         }
00186     }
00187     return false;
00188 }
00189
00190 //--------------------------------------------------------------------------------
00191
00192 void Face::UpdateMatrix()
00193 {
00194     // Determine the Model transform for the cannonical face to align with the position
00195     // and orientation of the defined face.  The cannonical face geometry is
00196     // a rectangle at the origin extending 1 unit in the +X and 1 unit in the +Y direction.
00197
00198     XMVECTOR w = XMVectorSet(1.0f, 0.0f, 0.0f, 1.0f);
00199     XMVECTOR h = XMVectorSet(0.0f, 1.0f, 0.0f, 1.0f);
00200     XMVECTOR epsilon = XMVectorReplicate(0.0001f);
00201     XMVECTOR width = XMVectorScale(XMLoadFloat3(&m_widthVector), 1.0f / m_width);
00202     XMVECTOR height = XMVectorScale(XMLoadFloat3(&m_heightVector), 1.0f / m_height);
00203     XMMATRIX mat1 = XMMatrixIdentity();
00204     XMMATRIX mat2 = XMMatrixIdentity();
00205
00206     // Determine the necessary rotation to align the widthVector with the +X axis.
00207     // Then apply the rotation to the cannonical H vector (+Y).
00208     if (!XMVector3NearEqual(w, width, epsilon))
00209     {
00210         float angle1 = XMVectorGetX(
00211             XMVector3AngleBetweenVectors(w, width)
00212             );
00213
00214         if (XMVector3NearEqual(w, XMVectorNegate(width), epsilon))
00215         {
00216             // The angle between w and width is ~180 degrees, so
00217             // pick a axis of rotation perpendicular to the W vector.
00218             mat1 = XMMatrixRotationAxis(XMVector3Orthogonal(w), angle1);
00219             h = XMVector3TransformCoord(h, mat1);
00220         }
00221         else if ((angle1 * angle1) > 0.025)
00222         {
00223             // Take the cross product between the w and width vectors to
00224             // determine the axis to rotate that is perpendicular to both vectors.
00225             XMVECTOR axis1 = XMVector3Cross(w, width);
00226             mat1 = XMMatrixRotationAxis(axis1, angle1);
00227             h = XMVector3TransformCoord(h, mat1);
00228         }
00229     }
00230
00231     // Determine the necessary rotation to align the transformed heightVector
00232     // with the transformed H vector.
00233     if (!XMVector3NearEqual(h, height, epsilon))
00234     {
00235         float angle2 = XMVectorGetX(
00236             XMVector3AngleBetweenVectors(h, height)
00237             );
00238
00239         if (XMVector3NearEqual(h, XMVectorNegate(height), epsilon))
00240         {
00241             // The angle between the h' and height vectors is ~180 degrees,
00242             // so rotate around the width vector to keep it aligned in the right
00243             // place.
00244             mat2 = XMMatrixRotationAxis(width, angle2);
00245         }
00246         else if ((angle2 * angle2) > 0.025)
00247         {
00248             // Take the cross product between the h' and height vectors
00249             // to determine the axis to rotate that is perpendicular to both vectors.
00250             XMVECTOR axis2 = XMVector3Cross(h, height);
00251             mat2 = XMMatrixRotationAxis(axis2, angle2);
00252         }
00253     }
00254     XMStoreFloat4x4(&m_rotationMatrix, mat1 * mat2);
00255
00256     // Generate the composite matrix to scale, rotate and translate to cannonical
00257     // face geometry to be positioned correctly in world space.
00258     XMStoreFloat4x4(
00259         &m_modelMatrix,
00260         XMMatrixScaling(m_width, m_height, 1.0f) *
00261         mat1 *
00262         mat2 *
00263         XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
00264         );
00265 }
00266
00267 //--------------------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/MainPage.xaml.cpp Source File

  • Language font mapping

MainPage.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.cpp
00010 // Implementation of the MainPage.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "MainPage.xaml.h"
00015 #include "App.xaml.h"
00016
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::UI::Xaml::Controls;
00019 using namespace Windows::UI::Xaml::Data;
00020 using namespace Windows::System;
00021 using namespace Windows::Foundation;
00022 using namespace Platform;
00023 using namespace LanguageFontCPP;
00024 using namespace CppSamplesUtils;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::Graphics::Display;
00028 using namespace Windows::UI::ViewManagement;
00029
00030 MainPage::MainPage()
00031 {
00032     InitializeComponent();
00033
00034     SetFeatureName("Language Font Mapping");
00035
00036     _scenariosFrame = ScenarioList;
00037     _inputFrame = ScenarioInput;
00038     _outputFrame = ScenarioOutput;
00039
00040     _layoutHandlerToken = Window::Current->SizeChanged += ref new Windows::UI::Xaml::WindowSizeChangedEventHandler(this, &MainPage::Page_SizeChanged);
00041
00042     _pageLoadedHandlerToken = Loaded += ref new RoutedEventHandler(this, &MainPage::Page_Loaded);
00043     _logicalDpiChangedToken = DisplayProperties::LogicalDpiChanged += ref new DisplayPropertiesEventHandler(this, &MainPage::DisplayProperties_LogicalDpiChanged);
00044 }
00045
00046 MainPage::~MainPage()
00047 {
00048 }
00049
00050 void MainPage::Page_Loaded(Object^ sender, RoutedEventArgs^ e)
00051 {
00052     // Load the ScenarioList page into the proper frame
00053     TypeName pageType = { "LanguageFontCPP.ScenarioList", TypeKind::Custom };
00054     ScenarioList->Navigate(pageType, this);
00055
00056     // Figure out what resolution and orientation we are in and respond appropriately.
00057     CheckResolutionAndViewState();
00058 }
00059
00060 void MainPage::SetFeatureName(String^ strFeature)
00061 {
00062     FeatureName->Text = strFeature;
00063 }
00064
00065 void MainPage::Page_SizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00066 {
00067     CheckResolutionAndViewState();
00068 }
00069
00070 void MainPage::DisplayProperties_LogicalDpiChanged(Object^ sender)
00071 {
00072     CheckResolutionAndViewState();
00073 }
00074
00075 void MainPage::CheckResolutionAndViewState()
00076 {
00077     ApplicationViewState state = ApplicationView::Value;
00078     String^ stateString = ConvertViewState(state);
00079
00080     ResolutionScale scale = DisplayProperties::ResolutionScale;
00081     String^ scaleString = ConvertResolution(scale);
00082
00083     VisualStateManager::GoToState(this, stateString + scaleString, false);
00084 }
00085
00086 String^ MainPage::ConvertViewState(ApplicationViewState state)
00087 {
00088     switch (state)
00089     {
00090     case ApplicationViewState::Filled:
00091         return "Filled";
00092     case ApplicationViewState::FullScreenLandscape:
00093         return "FullScreenLandscape";
00094     case ApplicationViewState::FullScreenPortrait:
00095         return "FullScreenPortrait";
00096     case ApplicationViewState::Snapped:
00097         return "Snapped";
00098     }
00099     return "";
00100 }
00101
00102 String^ MainPage::ConvertResolution(ResolutionScale scale)
00103 {
00104     switch (scale)
00105     {
00106     case ResolutionScale::Scale100Percent:
00107         return "Scale100Percent";
00108     case ResolutionScale::Scale140Percent:
00109         return "Scale140Percent";
00110     case ResolutionScale::Scale180Percent:
00111         return "Scale180Percent";
00112     }
00113     return "";
00114 }
00115
00116 void MainPage::DoNavigation(TypeName inPageType, Windows::UI::Xaml::Controls::Frame^ inFrame, TypeName outPageType, Windows::UI::Xaml::Controls::Frame^ outFrame)
00117 {
00118     inFrame->Navigate(inPageType, this);
00119     outFrame->Navigate(outPageType, this);
00120
00121     // Raise OutputFrameLoaded so downstream pages know that the output frame content has been loaded
00122     OutputFrameLoaded(this, nullptr);
00123     // Raise InputFrameLoaded so downstream pages know that the input frame content has been loaded
00124     InputFrameLoaded(this, nullptr);
00125 }
00126
00127 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00128 {
00129     switch (type)
00130     {
00131     case NotifyType::StatusMessage:
00132         StatusBlock->Style = dynamic_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00133         break;
00134     case NotifyType::ErrorMessage:
00135         StatusBlock->Style = dynamic_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00136         break;
00137     default:
00138         break;
00139     }
00140     StatusBlock->Text = strMessage;
00141 }
00142
00143 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00144 {
00145     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00146     Windows::System::Launcher::LaunchUriAsync(uri);
00147 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/common/LayoutAwarePage.h Source File

  • Compass sensor
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicTimer.cpp Source File

  • Direct3D tutorial
  • Lesson5.Components

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Compression::sealed Member List

This is the complete list of members for SDKSample::Compression::sealed, including all inherited members.
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
DoScenario(Windows::Storage::Compression::CompressAlgorithm Algorithm) | SDKSample::Compression::sealed | [private]
DoScenario(Windows::Storage::Compression::CompressAlgorithm Algorithm) | SDKSample::Compression::sealed | [private]
DoScenario(Windows::Storage::Compression::CompressAlgorithm Algorithm) | SDKSample::Compression::sealed | [private]
Lzms_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Lzms_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Lzms_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Mszip_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Mszip_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Mszip_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Compression::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Compression::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Compression::sealed | [protected, virtual]
rootPage | SDKSample::Compression::sealed | [private]
Scenario1() | SDKSample::Compression::sealed |
Scenario2() | SDKSample::Compression::sealed |
Scenario3() | SDKSample::Compression::sealed |
Xpress_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Xpress_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Xpress_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
XpressHuff_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
XpressHuff_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
XpressHuff_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Compression::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

BasicSprites::ReplicationVertex Member List

This is the complete list of members for BasicSprites::ReplicationVertex, including all inherited members.
color | BasicSprites::ReplicationVertex
pos | BasicSprites::ReplicationVertex
tex | BasicSprites::ReplicationVertex
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/LayoutAwarePage.cpp Source File

  • Removable storage
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/BasicTimer.cpp Source File

  • Direct2D custom image effects
  • PixelShader

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Polygon Member List

This is the complete list of members for Polygon, including all inherited members.
isRect | Polygon
numPoints | Polygon
points | Polygon
rcBound | Polygon
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/common/LayoutAwarePage.cpp Source File

  • Trial app and in-app purchase
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/C++/Background/pch.h Source File

  • ControlChannelTrigger XMLHTTPRequest
  • Background

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MainPage.xaml.cs Source File

  • Media extensions
  • C#,C++

MainPage.xaml.cs

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 using System;
00009 using System.Collections.Generic;
00010 using System.Linq;
00011 using System.Threading.Tasks;
00012 using Windows.Foundation;
00013 using Windows.Graphics.Display;
00014 using Windows.Media;
00015 using Windows.Storage;
00016 using Windows.System;
00017 using Windows.UI.Core;
00018 using Windows.UI.ViewManagement;
00019 using Windows.UI.Xaml;
00020 using Windows.UI.Xaml.Controls;
00021 using Windows.UI.Xaml.Data;
00022 using Windows.UI.Xaml.Media;
00023 using Windows.UI.Xaml.Documents;
00024
00025 using MediaExtensionsCS;
00026
00027 namespace SDKTemplateCS
00028 {
00029     partial class MainPage : Page
00030     {
00031         #region Properties
00032
00033         private Frame _scenariosFrame;
00034
00035         public Frame ScenariosFrame
00036         {
00037             get { return _scenariosFrame; }
00038             set { _scenariosFrame = value; }
00039         }
00040
00041         private Frame _inputFrame;
00042
00043         public Frame InputFrame
00044         {
00045             get { return _inputFrame; }
00046             set { _inputFrame = value; }
00047         }
00048
00049         private Frame _outputFrame;
00050
00051         public Frame OutputFrame
00052         {
00053             get { return _outputFrame; }
00054             set { _outputFrame = value; }
00055         }
00056
00057         private string _rootNamespace;
00058
00059         public string RootNamespace
00060         {
00061             get { return _rootNamespace; }
00062             set { _rootNamespace = value; }
00063         }
00064
00065         private MediaExtensionManager _extensionManager = new MediaExtensionManager();
00066
00067         public MediaExtensionManager ExtensionManager
00068         {
00069             get { return _extensionManager; }
00070         }
00071         #endregion
00072
00073         #region Events
00074
00075         public event System.EventHandler InputFrameLoaded;
00076         public event System.EventHandler OutputFrameLoaded;
00077
00078         #endregion
00079
00080         public MainPage()
00081         {
00082             InitializeComponent();
00083
00084             _scenariosFrame = ScenarioList;
00085             _inputFrame = ScenarioInput;
00086             _outputFrame = ScenarioOutput;
00087
00088             SetFeatureName(FEATURE_NAME);
00089
00090             Loaded += new RoutedEventHandler(MainPage_Loaded);
00091             Window.Current.SizeChanged += new WindowSizeChangedEventHandler(MainPage_SizeChanged);
00092             DisplayProperties.LogicalDpiChanged += new DisplayPropertiesEventHandler(DisplayProperties_LogicalDpiChanged);
00093
00094             NavigationCacheMode = Windows.UI.Xaml.Navigation.NavigationCacheMode.Required;
00095         }
00096
00097         void MainPage_Loaded(object sender, RoutedEventArgs e)
00098         {
00099             // Figure out what resolution and orientation we are in and respond appropriately
00100             CheckResolutionAndViewState();
00101
00102             // Load the ScenarioList page into the proper frame
00103             ScenarioList.Navigate(Type.GetType(_rootNamespace + ".ScenarioList"), this);
00104         }
00105
00106         #region Resolution and orientation code
00107
00108         void DisplayProperties_LogicalDpiChanged(object sender)
00109         {
00110             CheckResolutionAndViewState();
00111         }
00112
00113         void CheckResolutionAndViewState()
00114         {
00115             VisualStateManager.GoToState(this, ApplicationView.Value.ToString() + DisplayProperties.ResolutionScale.ToString(), false);
00116         }
00117
00118         void MainPage_SizeChanged(Object sender, Windows.UI.Core.WindowSizeChangedEventArgs args)
00119         {
00120             CheckResolutionAndViewState();
00121         }
00122
00123         #endregion
00124
00125         private void SetFeatureName(string str)
00126         {
00127             FeatureName.Text = str;
00128         }
00129
00130         async void Footer_Click(object sender, RoutedEventArgs e)
00131         {
00132             await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
00133         }
00134
00135         public void NotifyUser(string strMessage, NotifyType type)
00136         {
00137             switch (type)
00138             {
00139                 case NotifyType.StatusMessage:
00140                     StatusBlock.Style = Resources["StatusStyle"] as Style;
00141                     break;
00142                 case NotifyType.ErrorMessage:
00143                     StatusBlock.Style = Resources["ErrorStyle"] as Style;
00144                     break;
00145             }
00146             StatusBlock.Text = strMessage;
00147         }
00148
00149         public void DoNavigation(Type pageType, Frame frame)
00150         {
00151             frame.Navigate(pageType, this);
00152             if (pageType.Name.Contains("Input"))
00153             {
00154                 // Raise InputFrameLoaded so downstream pages know that the input frame content has been loaded.
00155                 if (InputFrameLoaded != null)
00156                 {
00157                     InputFrameLoaded(this, new EventArgs());
00158                 }
00159             }
00160             else
00161             {
00162                 // Raise OutputFrameLoaded so downstream pages know that the output frame content has been loaded.
00163                 if (OutputFrameLoaded != null)
00164                 {
00165                     OutputFrameLoaded(this, new EventArgs());
00166                 }
00167             }
00168         }
00169
00170         //
00171         //  Open a single file picker [with fileTypeFilter].
00172         //  And then, call media.SetSource(picked file).
00173         //  If the file is successfully opened, VideoMediaOpened() will be called and call media.Play().
00174         //
00175         public async void PickSingleFileAndSet(string[] fileTypeFilter, params MediaElement[] mediaElements)
00176         {
00177             var currentState = Windows.UI.ViewManagement.ApplicationView.Value;
00178             if (currentState == Windows.UI.ViewManagement.ApplicationViewState.Snapped &&
00179                 !Windows.UI.ViewManagement.ApplicationView.TryUnsnap())
00180             {
00181                 // File picker cannot be used in the snapped state.
00182                 NotifyUser("File picker cannot be used when application is in the snapped state.", NotifyType.StatusMessage);
00183                 return;
00184             }
00185
00186             CoreDispatcher dispatcher = Window.Current.Dispatcher;
00187
00188             var picker = new Windows.Storage.Pickers.FileOpenPicker();
00189             picker.SuggestedStartLocation = Windows.Storage.Pickers.PickerLocationId.VideosLibrary;
00190             foreach (string filter in fileTypeFilter)
00191             {
00192                 picker.FileTypeFilter.Add(filter);
00193             }
00194             StorageFile file = await picker.PickSingleFileAsync();
00195
00196             if (file != null)
00197             {
00198                 try
00199                 {
00200                     var stream = await file.OpenAsync(FileAccessMode.Read);
00201
00202                     for (int i = 0; i < mediaElements.Length; ++i)
00203                     {
00204                         MediaElement me = mediaElements[i];
00205                         me.Stop();
00206                         if (i + 1 < mediaElements.Length)
00207                         {
00208                             me.SetSource(stream.CloneStream(), file.ContentType);
00209                         }
00210                         else
00211                         {
00212                             me.SetSource(stream, file.ContentType);
00213                         }
00214                     }
00215                 }
00216                 catch (Exception ex)
00217                 {
00218                     NotifyUser("Cannot open video file - error: " + ex.Message, NotifyType.ErrorMessage);
00219                 }
00220             }
00221         }
00222
00223         public void VideoOnError(Object obj, ExceptionRoutedEventArgs args)
00224         {
00225             NotifyUser("Cannot open video file - error: " + args.ErrorMessage, NotifyType.ErrorMessage);
00226         }
00227     }
00228
00229     public enum NotifyType
00230     {
00231         StatusMessage,
00232         ErrorMessage
00233     };
00234 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/SampleOverlay.h Source File

  • Direct2D custom image effects
  • VertexShader

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicShapes.cpp Source File

  • Direct3D post-processing effects

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Animation::sealed Member List

This is the complete list of members for SDKSample::Animation::sealed, including all inherited members.
isScenario2StoryboardRunning | SDKSample::Animation::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Animation::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Animation::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Animation::sealed | [protected, virtual]
PlotEasingFunctionGraph(Windows::UI::Xaml::Media::Animation::EasingFunctionBase^easingFunction, double samplingInterval) | SDKSample::Animation::sealed | [private]
rootPage | SDKSample::Animation::sealed | [private]
Scenario1() | SDKSample::Animation::sealed |
Scenario2() | SDKSample::Animation::sealed |
Scenario2ToggleStoryboard_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Animation::sealed | [private]
Scenario3() | SDKSample::Animation::sealed |
Scenario3EasingFunctionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::Animation::sealed | [private]
ToggleScenario2(bool startScenario) | SDKSample::Animation::sealed | [private]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/MainPage.xaml.h Source File

  • EAS policies for mail clients

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Face.cpp Source File

  • XAML DirectX 3D shooting game

Face.cpp

Go to the documentation of this file.
00001 /// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Face.h"
00010
00011 using namespace DirectX;
00012
00013 //----------------------------------------------------------------------
00014
00015 Face::Face()
00016 {
00017     SetPlane(
00018         XMFLOAT3(0.0f, 0.0f, 0.0f),
00019         XMFLOAT3(1.0f, 0.0f, 0.0f),
00020         XMFLOAT3(0.0f, 1.0f, 0.0f)
00021         );
00022 }
00023
00024 //----------------------------------------------------------------------
00025
00026 Face::Face(
00027     XMFLOAT3 origin,
00028     XMFLOAT3 p1,
00029     XMFLOAT3 p2
00030     )
00031 {
00032     SetPlane(origin, p1, p2);
00033 }
00034
00035 //--------------------------------------------------------------------------------
00036
00037 void Face::SetPlane(
00038     XMFLOAT3 origin,
00039     XMFLOAT3 p1,
00040     XMFLOAT3 p2
00041     )
00042 {
00043     m_position = origin;
00044     XMStoreFloat3(&m_widthVector, XMLoadFloat3(&p1) - XMLoadFloat3(&origin));
00045     XMStoreFloat3(&m_heightVector, XMLoadFloat3(&p2) - XMLoadFloat3(&origin));
00046
00047     m_point[0] = m_position;
00048     m_point[1] = p1;
00049     m_point[3] = p2;
00050     XMStoreFloat3(&m_point[2], XMLoadFloat3(&p1) + XMLoadFloat3(&m_heightVector));
00051
00052     XMStoreFloat(&m_width, XMVector3Length(XMLoadFloat3(&m_widthVector)));
00053     XMStoreFloat(&m_height, XMVector3Length(XMLoadFloat3(&m_heightVector)));
00054
00055     XMStoreFloat3(
00056         &m_normal,
00057         XMVector3Normalize(
00058             XMVector3Cross(
00059                 XMLoadFloat3(&m_widthVector),
00060                 XMLoadFloat3(&m_heightVector)
00061                 )
00062             )
00063         );
00064     UpdateMatrix();
00065 }
00066
00067 //--------------------------------------------------------------------------------
00068
00069 void Face::UpdatePosition()
00070 {
00071     m_point[0] = m_position;
00072     XMStoreFloat3(&m_point[1], XMLoadFloat3(&m_position) + XMLoadFloat3(&m_widthVector));
00073     XMStoreFloat3(&m_point[3], XMLoadFloat3(&m_position) + XMLoadFloat3(&m_heightVector));
00074     XMStoreFloat3(&m_point[2], XMLoadFloat3(&m_point[1]) + XMLoadFloat3(&m_heightVector));
00075
00076     XMStoreFloat4x4(
00077         &m_modelMatrix,
00078         XMMatrixScaling(m_width, m_height, 1.0f) *
00079         XMLoadFloat4x4(&m_rotationMatrix) *
00080         XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
00081         );
00082 }
00083
00084 //--------------------------------------------------------------------------------
00085
00086 bool Face::IsTouching(
00087     XMFLOAT3 point,
00088     float radius,
00089     _Out_ XMFLOAT3 *contact,
00090     _Out_ XMFLOAT3 *normal
00091     )
00092 {
00093     float dist;
00094
00095     // Determine if a point is within radius distance of the face and
00096     // return the point of contact (projection of the point onto the face).
00097
00098     XMStoreFloat(
00099         &dist,
00100         XMVector3Dot(
00101             XMLoadFloat3(&m_normal),
00102             XMLoadFloat3(&point) - XMLoadFloat3(&m_position)
00103             )
00104         );
00105
00106     // Determine the point of contact by projecting the point along the Normal
00107     // vector the distance the point is from the plane.
00108     XMStoreFloat3(contact, XMLoadFloat3(&point) - (XMLoadFloat3(&m_normal) * dist));
00109     normal->x = m_normal.x;
00110     normal->y = m_normal.y;
00111     normal->z = m_normal.z;
00112
00113     if (dist < 0.0f)
00114     {
00115         dist *= -1.0f;
00116         normal->x = -m_normal.x;
00117         normal->y = -m_normal.y;
00118         normal->z = -m_normal.z;
00119     }
00120     else
00121     {
00122         normal->x = m_normal.x;
00123         normal->y = m_normal.y;
00124         normal->z = m_normal.z;
00125     }
00126
00127     if (dist < radius)
00128     {
00129         // point is within radius of the plane
00130         //
00131         // Determine if the point of contact is inside the parallelogram of the target.
00132         // This is true if distance from each of the parallel lines defining the half
00133         // spaces is less than the distance between the parallel lines for both sets of
00134         // parallel lines.
00135         // To catch the cases where the contact point is just outside the parallelogram
00136         // but less than the radius we extend the parallelogram to accept points that are
00137         // the distance between the parallel lines plus the radius.
00138         //
00139
00140         float dist1, dist2, dist3, dist4;
00141
00142         XMStoreFloat(
00143             &dist1,
00144             XMVector3LinePointDistance(
00145                 XMLoadFloat3(&m_point[0]),
00146                 XMLoadFloat3(&m_point[1]),
00147                 XMLoadFloat3(contact)
00148                 )
00149             );
00150         XMStoreFloat(
00151             &dist2,
00152             XMVector3LinePointDistance(
00153                 XMLoadFloat3(&m_point[3]),
00154                 XMLoadFloat3(&m_point[2]),
00155                 XMLoadFloat3(contact)
00156                 )
00157             );
00158         XMStoreFloat(
00159             &dist3,
00160             XMVector3LinePointDistance(
00161                 XMLoadFloat3(&m_point[0]),
00162                 XMLoadFloat3(&m_point[3]),
00163                 XMLoadFloat3(contact)
00164                 )
00165             );
00166         XMStoreFloat(
00167             &dist4,
00168             XMVector3LinePointDistance(
00169                 XMLoadFloat3(&m_point[1]),
00170                 XMLoadFloat3(&m_point[2]),
00171                 XMLoadFloat3(contact)
00172                 )
00173             );
00174
00175         if (dist1 < (m_height + radius) &&
00176             dist2 < (m_height + radius) &&
00177             dist3 < (m_width + radius) &&
00178             dist4 < (m_width + radius))
00179         {
00180             return true;
00181         }
00182         else
00183         {
00184             return false;
00185         }
00186     }
00187     return false;
00188 }
00189
00190 //--------------------------------------------------------------------------------
00191
00192 void Face::UpdateMatrix()
00193 {
00194     // Determine the Model transform for the cannonical face to align with the position
00195     // and orientation of the defined face.  The cannonical face geometry is
00196     // a rectangle at the origin extending 1 unit in the +X and 1 unit in the +Y direction.
00197
00198     XMVECTOR w = XMVectorSet(1.0f, 0.0f, 0.0f, 1.0f);
00199     XMVECTOR h = XMVectorSet(0.0f, 1.0f, 0.0f, 1.0f);
00200     XMVECTOR epsilon = XMVectorReplicate(0.0001f);
00201     XMVECTOR width = XMVectorScale(XMLoadFloat3(&m_widthVector), 1.0f / m_width);
00202     XMVECTOR height = XMVectorScale(XMLoadFloat3(&m_heightVector), 1.0f / m_height);
00203     XMMATRIX mat1 = XMMatrixIdentity();
00204     XMMATRIX mat2 = XMMatrixIdentity();
00205
00206     // Determine the necessary rotation to align the widthVector with the +X axis.
00207     // Then apply the rotation to the cannonical H vector (+Y).
00208     if (!XMVector3NearEqual(w, width, epsilon))
00209     {
00210         float angle1 = XMVectorGetX(
00211             XMVector3AngleBetweenVectors(w, width)
00212             );
00213
00214         if (XMVector3NearEqual(w, XMVectorNegate(width), epsilon))
00215         {
00216             // The angle between w and width is ~180 degrees, so
00217             // pick a axis of rotation perpendicular to the W vector.
00218             mat1 = XMMatrixRotationAxis(XMVector3Orthogonal(w), angle1);
00219             h = XMVector3TransformCoord(h, mat1);
00220         }
00221         else if ((angle1 * angle1) > 0.025)
00222         {
00223             // Take the cross product between the w and width vectors to
00224             // determine the axis to rotate that is perpendicular to both vectors.
00225             XMVECTOR axis1 = XMVector3Cross(w, width);
00226             mat1 = XMMatrixRotationAxis(axis1, angle1);
00227             h = XMVector3TransformCoord(h, mat1);
00228         }
00229     }
00230
00231     // Determine the necessary rotation to align the transformed heightVector
00232     // with the transformed H vector.
00233     if (!XMVector3NearEqual(h, height, epsilon))
00234     {
00235         float angle2 = XMVectorGetX(
00236             XMVector3AngleBetweenVectors(h, height)
00237             );
00238
00239         if (XMVector3NearEqual(h, XMVectorNegate(height), epsilon))
00240         {
00241             // The angle between the h' and height vectors is ~180 degrees,
00242             // so rotate around the width vector to keep it aligned in the right
00243             // place.
00244             mat2 = XMMatrixRotationAxis(width, angle2);
00245         }
00246         else if ((angle2 * angle2) > 0.025)
00247         {
00248             // Take the cross product between the h' and height vectors
00249             // to determine the axis to rotate that is perpendicular to both vectors.
00250             XMVECTOR axis2 = XMVector3Cross(h, height);
00251             mat2 = XMMatrixRotationAxis(axis2, angle2);
00252         }
00253     }
00254     XMStoreFloat4x4(&m_rotationMatrix, mat1 * mat2);
00255
00256     // Generate the composite matrix to scale, rotate and translate to cannonical
00257     // face geometry to be positioned correctly in world space.
00258     XMStoreFloat4x4(
00259         &m_modelMatrix,
00260         XMMatrixScaling(m_width, m_height, 1.0f) *
00261         mat1 *
00262         mat2 *
00263         XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
00264         );
00265 }
00266
00267 //--------------------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/common/suspensionmanager.cpp Source File

  • Transcoding media
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/common/SuspensionManager.h Source File

  • Geolocation
  • common

SuspensionManager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/TextAnalysis.cpp Source File

  • DirectWrite vertical text

TextAnalysis.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // Contents:    Implementation of text analyzer source and sink.
00009 //
00010 //----------------------------------------------------------------------------
00011 #include "pch.h"
00012 #include "TextAnalysis.h"
00013
00014 TextAnalysis::TextAnalysis(
00015     const wchar_t* text,
00016     UINT32 textLength,
00017     const wchar_t* localeName,
00018     IDWriteNumberSubstitution* numberSubstitution,
00019     ReadingDirection readingDirection,
00020     GlyphOrientationMode glyphOrientationMode
00021     )
00022 :   m_text(text),
00023     m_textLength(textLength),
00024     m_localeName(localeName),
00025     m_readingDirection(readingDirection),
00026     m_numberSubstitution(numberSubstitution),
00027     m_glyphOrientationMode(glyphOrientationMode),
00028     m_currentPosition(0),
00029     m_currentRunIndex(0)
00030 {
00031 }
00032
00033 STDMETHODIMP TextAnalysis::GenerateResults(
00034     Microsoft::WRL::ComPtr<IDWriteTextAnalyzer1> textAnalyzer,
00035     _Out_ std::vector<TextAnalysis::Run>& runs,
00036     _Out_ std::vector<DWRITE_LINE_BREAKPOINT>& breakpoints
00037     )
00038 {
00039     // Analyzes the text using each of the analyzers and returns
00040     // their results as a series of runs.
00041
00042     HRESULT hr = S_OK;
00043
00044     // Initially start out with one result that covers the entire range.
00045     // This result will be subdivided by the analysis processes.
00046     m_runs.resize(1);
00047     LinkedRun& initialRun   = m_runs[0];
00048     initialRun.nextRunIndex = 0;
00049     initialRun.textStart    = 0;
00050     initialRun.textLength   = m_textLength;
00051     initialRun.bidiLevel    = (m_readingDirection & ReadingDirectionPrimaryProgression) != 0;
00052
00053     // Allocate enough room to have one breakpoint per code unit.
00054     m_breakpoints.resize(m_textLength);
00055
00056     // Call each of the analyzers in sequence, recording their results.
00057     if (SUCCEEDED(hr = textAnalyzer->AnalyzeLineBreakpoints(this, 0, m_textLength, this))
00058         &&  SUCCEEDED(hr = AnalyzeBidi(textAnalyzer.Get(), this, 0, m_textLength, this))
00059         &&  SUCCEEDED(hr = textAnalyzer->AnalyzeScript(this, 0, m_textLength, this))
00060         &&  SUCCEEDED(hr = textAnalyzer->AnalyzeNumberSubstitution(this, 0, m_textLength, this))
00061         &&  SUCCEEDED(hr = AnalyzeGlyphOrientation(textAnalyzer, this, 0, m_textLength, this))
00062         )
00063     {
00064         // Exchange our results with the caller's.
00065         breakpoints.swap(m_breakpoints);
00066
00067         // Resequence the resulting runs in order before returning to caller.
00068         size_t totalRuns = m_runs.size();
00069         runs.resize(totalRuns);
00070
00071         UINT32 nextRunIndex = 0;
00072         for (size_t i = 0; i < totalRuns; ++i)
00073         {
00074             runs[i]         = m_runs[nextRunIndex];
00075             nextRunIndex    = m_runs[nextRunIndex].nextRunIndex;
00076         }
00077     }
00078
00079     return hr;
00080 }
00081
00082 ////////////////////////////////////////////////////////////////////////////////
00083 // IDWriteTextAnalysisSource source implementation
00084
00085 IFACEMETHODIMP TextAnalysis::GetTextAtPosition(
00086     UINT32 textPosition,
00087     _Out_ WCHAR const** textString,
00088     _Out_ UINT32* textLength
00089     )
00090 {
00091     if (textPosition >= m_textLength)
00092     {
00093         // Return no text if a query comes for a position at the end of
00094         // the range. Note that is not an error and we should not return
00095         // a failing HRESULT. Although the application is not expected
00096         // to return any text that is outside of the given range, the
00097         // analyzers may probe the ends to see if text exists.
00098         *textString = nullptr;
00099         *textLength = 0;
00100     }
00101     else
00102     {
00103         *textString = &m_text[textPosition];
00104         *textLength = m_textLength - textPosition;
00105     }
00106     return S_OK;
00107 }
00108
00109 IFACEMETHODIMP TextAnalysis::GetTextBeforePosition(
00110     UINT32 textPosition,
00111     _Out_ WCHAR const** textString,
00112     _Out_ UINT32* textLength
00113     )
00114 {
00115     if (textPosition == 0 || textPosition > m_textLength)
00116     {
00117         // Return no text if a query comes for a position at the end of
00118         // the range. Note that is not an error and we should not return
00119         // a failing HRESULT. Although the application is not expected
00120         // to return any text that is outside of the given range, the
00121         // analyzers may probe the ends to see if text exists.
00122         *textString = nullptr;
00123         *textLength = 0;
00124     }
00125     else
00126     {
00127         *textString = &m_text[0];
00128         *textLength = textPosition - 0; // text length is valid from current position backward
00129     }
00130     return S_OK;
00131 }
00132
00133
00134 DWRITE_READING_DIRECTION STDMETHODCALLTYPE TextAnalysis::GetParagraphReadingDirection()
00135 {
00136     return (m_readingDirection & ReadingDirectionPrimaryProgression) != 0
00137         ? DWRITE_READING_DIRECTION_RIGHT_TO_LEFT
00138         : DWRITE_READING_DIRECTION_LEFT_TO_RIGHT;
00139 }
00140
00141 IFACEMETHODIMP TextAnalysis::GetLocaleName(
00142     UINT32 textPosition,
00143     _Out_ UINT32* textLength,
00144     _Out_ WCHAR const** localeName
00145     )
00146 {
00147     // The pointer returned should remain valid until the next call,
00148     // or until analysis ends. Since only one locale name is supported,
00149     // the text length is valid from the current position forward to
00150     // the end of the string.
00151
00152     *localeName = m_localeName;
00153     *textLength = m_textLength - textPosition;
00154
00155     return S_OK;
00156 }
00157
00158 IFACEMETHODIMP TextAnalysis::GetNumberSubstitution(
00159     UINT32 textPosition,
00160     _Out_ UINT32* textLength,
00161     _Out_ IDWriteNumberSubstitution** numberSubstitution
00162     )
00163 {
00164     if (m_numberSubstitution != nullptr)
00165     {
00166         m_numberSubstitution->AddRef();
00167     }
00168
00169     *numberSubstitution = m_numberSubstitution;
00170     *textLength = m_textLength - textPosition;
00171
00172     return S_OK;
00173 }
00174
00175 STDMETHODIMP TextAnalysis::GetVerticalGlyphOrientation(
00176     UINT32 textPosition,
00177     _Out_ UINT32* textLength,
00178     _Out_ DWRITE_VERTICAL_GLYPH_ORIENTATION* glyphOrientation,
00179     _Out_ UINT8* bidiLevel
00180     )
00181 {
00182     SetCurrentRun(textPosition);
00183     const LinkedRun& run    = m_runs[m_currentRunIndex];
00184     *bidiLevel              = run.bidiLevel;
00185     *glyphOrientation       = DWRITE_VERTICAL_GLYPH_ORIENTATION_DEFAULT;
00186
00187     // Find the next range where a bidi level changes.
00188
00189     const size_t totalRuns = m_runs.size();
00190     UINT32 lastRunPosition = textPosition;
00191     UINT32 nextRunIndex = m_currentRunIndex;
00192
00193     do
00194     {
00195         const LinkedRun& nextRun = m_runs[nextRunIndex];
00196         if (nextRun.bidiLevel != run.bidiLevel)
00197         {
00198             break;
00199         }
00200         lastRunPosition = nextRun.textStart + nextRun.textLength;
00201         nextRunIndex = nextRun.nextRunIndex;
00202     }
00203     while (nextRunIndex < totalRuns && nextRunIndex != 0);
00204
00205     *textLength = lastRunPosition - textPosition;
00206
00207     return S_OK;
00208 }
00209
00210 ////////////////////////////////////////////////////////////////////////////////
00211 // IDWriteTextAnalysisSink implementation
00212
00213 IFACEMETHODIMP TextAnalysis::SetLineBreakpoints(
00214     UINT32 textPosition,
00215     UINT32 textLength,
00216     DWRITE_LINE_BREAKPOINT const* lineBreakpoints   // [textLength]
00217     )
00218 {
00219     if (textLength > 0)
00220     {
00221         memcpy(&m_breakpoints[textPosition], lineBreakpoints, textLength * sizeof(lineBreakpoints[0]));
00222     }
00223     return S_OK;
00224 }
00225
00226 IFACEMETHODIMP TextAnalysis::SetScriptAnalysis(
00227     UINT32 textPosition,
00228     UINT32 textLength,
00229     DWRITE_SCRIPT_ANALYSIS const* scriptAnalysis
00230     )
00231 {
00232     try
00233     {
00234         SetCurrentRun(textPosition);
00235         SplitCurrentRun(textPosition);
00236         while (textLength > 0)
00237         {
00238             LinkedRun& run  = FetchNextRun(&textLength);
00239             run.script      = *scriptAnalysis;
00240         }
00241     }
00242     catch (...)
00243     {
00244         return E_FAIL; // Unknown error, probably out of memory.
00245     }
00246
00247     return S_OK;
00248 }
00249
00250 IFACEMETHODIMP TextAnalysis::SetBidiLevel(
00251     UINT32 textPosition,
00252     UINT32 textLength,
00253     UINT8 explicitLevel,
00254     UINT8 resolvedLevel
00255     )
00256 {
00257     try
00258     {
00259         SetCurrentRun(textPosition);
00260         SplitCurrentRun(textPosition);
00261         while (textLength > 0)
00262         {
00263             LinkedRun& run  = FetchNextRun(&textLength);
00264             run.bidiLevel   = resolvedLevel;
00265             run.isReversed  = !!(resolvedLevel & 1);
00266         }
00267     }
00268     catch (...)
00269     {
00270         return E_FAIL; // Unknown error, probably out of memory.
00271     }
00272
00273     return S_OK;
00274 }
00275
00276 IFACEMETHODIMP TextAnalysis::SetNumberSubstitution(
00277     UINT32 textPosition,
00278     UINT32 textLength,
00279     IDWriteNumberSubstitution* numberSubstitution
00280     )
00281 {
00282     try
00283     {
00284         SetCurrentRun(textPosition);
00285         SplitCurrentRun(textPosition);
00286         while (textLength > 0)
00287         {
00288             LinkedRun& run          = FetchNextRun(&textLength);
00289             run.isNumberSubstituted = (numberSubstitution != nullptr);
00290         }
00291     }
00292     catch (...)
00293     {
00294         return E_FAIL; // Unknown error, probably out of memory.
00295     }
00296
00297     return S_OK;
00298 }
00299
00300 IFACEMETHODIMP TextAnalysis::SetGlyphOrientation(
00301     UINT32 textPosition,
00302     UINT32 textLength,
00303     DWRITE_GLYPH_ORIENTATION_ANGLE glyphOrientationAngle,
00304     UINT8 adjustedBidiLevel,
00305     BOOL isSideways,
00306     BOOL isRightToLeft
00307     )
00308 {
00309     try
00310     {
00311         // Mapping from angle down to small orientation.
00312         const static UINT8 glyphOrientations[] = {
00313             GlyphOrientationCW0,
00314             GlyphOrientationCW90,
00315             GlyphOrientationCW180,
00316             GlyphOrientationCW270,
00317         };
00318
00319         SetCurrentRun(textPosition);
00320         SplitCurrentRun(textPosition);
00321         while (textLength > 0)
00322         {
00323             LinkedRun& run          = FetchNextRun(&textLength);
00324             run.glyphOrientation    = glyphOrientations[glyphOrientationAngle & 3];
00325             run.isSideways          = !!isSideways;
00326             run.isReversed          = !!isRightToLeft;
00327             run.bidiLevel           = adjustedBidiLevel;
00328         }
00329     }
00330     catch (...)
00331     {
00332         return E_FAIL; // Unknown error, probably out of memory.
00333     }
00334
00335     return S_OK;
00336 }
00337
00338 STDMETHODIMP TextAnalysis::AnalyzeGlyphOrientation(
00339     Microsoft::WRL::ComPtr<IDWriteTextAnalyzer1> textAnalyzer,
00340     IDWriteTextAnalysisSource1* analysisSource,
00341     UINT32 firstPosition,
00342     UINT32 textLength,
00343     IDWriteTextAnalysisSink1* analysisSink
00344     )
00345 {
00346     if (firstPosition + textLength < firstPosition)
00347     {
00348         return E_INVALIDARG;
00349     }
00350
00351     if (textLength == 0)
00352     {
00353         return S_OK;
00354     }
00355
00356     if ((m_readingDirection & ReadingDirectionPrimaryAxis) != 0) // if vertical direction
00357     {
00358         switch (m_glyphOrientationMode)
00359         {
00360         case GlyphOrientationModeDefault:
00361         case GlyphOrientationModeStacked:
00362             textAnalyzer->AnalyzeVerticalGlyphOrientation(analysisSource, firstPosition, textLength, analysisSink);
00363             break;
00364         }
00365     }
00366
00367     return S_OK;
00368 }
00369
00370 STDMETHODIMP TextAnalysis::AnalyzeBidi(
00371     Microsoft::WRL::ComPtr<IDWriteTextAnalyzer1> textAnalyzer,
00372     IDWriteTextAnalysisSource1* analysisSource,
00373     UINT32 firstPosition,
00374     UINT32 textLength,
00375     IDWriteTextAnalysisSink1* analysisSink
00376     )
00377 {
00378     if (firstPosition + textLength < firstPosition)
00379     {
00380         return E_INVALIDARG;
00381     }
00382
00383     if (textLength == 0)
00384     {
00385         return S_OK;
00386     }
00387
00388     textAnalyzer->AnalyzeBidi(analysisSource, firstPosition, textLength, analysisSink);
00389
00390     return S_OK;
00391 }
00392
00393 // Run modification.
00394 TextAnalysis::LinkedRun& TextAnalysis::FetchNextRun(
00395     _Inout_ UINT32* textLength
00396     )
00397 {
00398     // Used by the sink setters, this returns a reference to the next run.
00399     // Position and length are adjusted to now point after the current run
00400     // being returned.
00401     UINT32 runIndex      = m_currentRunIndex;
00402     UINT32 runTextLength = m_runs[m_currentRunIndex].textLength;
00403
00404     // Split the tail if needed (the length remaining is less than the
00405     // current run's size).
00406     if (*textLength < runTextLength)
00407     {
00408         runTextLength       = *textLength; // Limit to what's actually left.
00409         UINT32 runTextStart = m_runs[m_currentRunIndex].textStart;
00410
00411         SplitCurrentRun(runTextStart + runTextLength);
00412     }
00413     else
00414     {
00415         // Just advance the current run.
00416         m_currentRunIndex = m_runs[m_currentRunIndex].nextRunIndex;
00417     }
00418     *textLength -= runTextLength;
00419
00420
00421     // Return a reference to the run that was just current.
00422     return m_runs[runIndex];
00423 }
00424
00425 void TextAnalysis::SetCurrentRun(UINT32 textPosition)
00426 {
00427     // Move the current run to the given position.
00428     // Since the analyzers generally return results in a forward manner,
00429     // this will usually just return early. If not, find the
00430     // corresponding run for the text position.
00431     if (m_currentRunIndex < m_runs.size()
00432         &&  m_runs[m_currentRunIndex].ContainsTextPosition(textPosition))
00433     {
00434         return;
00435     }
00436
00437     m_currentRunIndex = static_cast<UINT32>(
00438         std::find(m_runs.begin(), m_runs.end(), textPosition)
00439         - m_runs.begin()
00440         );
00441 }
00442
00443 void TextAnalysis::SplitCurrentRun(UINT32 splitPosition)
00444 {
00445     // Splits the current run and adjusts the run values accordingly.
00446
00447     UINT32 runTextStart = m_runs[m_currentRunIndex].textStart;
00448
00449     if (splitPosition <= runTextStart)
00450     {
00451         return; // no change
00452     }
00453
00454     // Grow runs by one.
00455     size_t totalRuns = m_runs.size();
00456     try
00457     {
00458         m_runs.resize(totalRuns + 1);
00459     }
00460     catch (...)
00461     {
00462         return; // Can't increase size. Return same run.
00463     }
00464
00465     // Copy the old run to the end.
00466     LinkedRun& frontHalf = m_runs[m_currentRunIndex];
00467     LinkedRun& backHalf  = m_runs.back();
00468     backHalf             = frontHalf;
00469
00470     // Adjust runs' text positions and lengths.
00471     UINT32 splitPoint       = splitPosition - runTextStart;
00472     backHalf.textStart     += splitPoint;
00473     backHalf.textLength    -= splitPoint;
00474     frontHalf.textLength    = splitPoint;
00475     frontHalf.nextRunIndex  = static_cast<UINT32>(totalRuns);
00476     m_currentRunIndex       = static_cast<UINT32>(totalRuns);
00477 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/BackgroundObject.cpp Source File

  • Input Manipulations and gestures (C++)
  • C++

BackgroundObject.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #include "pch.h"
00009 #include "BackgroundObject.h"
00010 #include "DirectXSample.h"
00011
00012 ///////////////////////////////////////////////////////////////////////////////
00013 // Object constructor, destructor and initialization.
00014 //
00015
00016 BackgroundObject::BackgroundObject(_In_opt_ ManipulatableObject^ parent, _In_ IRenderer^ renderer)
00017 :   ManipulatableObject(parent),
00018     _renderer(renderer)
00019 {
00020     Initialize();
00021 }
00022
00023 BackgroundObject::~BackgroundObject()
00024 {
00025 }
00026
00027 void BackgroundObject::Initialize()
00028 {
00029     _pointerDevice = nullptr;
00030     _deviceDesc[0] = L'\0';
00031
00032     SetManipulationTransform(D2D1::Matrix3x2F::Identity());
00033     SetInitialPosition(D2D1::Point2F());
00034 }
00035
00036 void BackgroundObject::SetDevice(_In_opt_ Windows::Devices::Input::IPointerDevice^ pointerDevice)
00037 {
00038     _pointerDevice = pointerDevice;
00039 }
00040
00041 ///////////////////////////////////////////////////////////////////////////////
00042 // Base class ManipulatableObject overrides
00043 //
00044
00045 D2D1::Matrix3x2F BackgroundObject::Transform()
00046 {
00047     Windows::Foundation::Size size = _renderer->ViewSize();
00048     SetInitialPosition(D2D1::Point2F(size.Width/2, size.Height/2));
00049     return __super::Transform();
00050 }
00051
00052 ///////////////////////////////////////////////////////////////////////////////
00053 // Object drawing methods.
00054 //
00055
00056 void BackgroundObject::DrawBackground(
00057     _In_ ID2D1DeviceContext* deviceContext,
00058     _In_ ID2D1SolidColorBrush* brush)
00059 {
00060     Windows::Foundation::Size clientSize = _renderer->ViewSize();
00061     D2D1::Matrix3x2F mxTransform = Transform();
00062
00063     // Find out how many tiles we must render to cover visible area.
00064     int ixMin = 0, ixMax = 0;
00065     int iyMin = 0, iyMax = 0;
00066     if ((clientSize.Width != 0) && (clientSize.Height != 0))
00067     {
00068         D2D1::Matrix3x2F mxTransformInv = mxTransform;
00069         if (D2D1InvertMatrix(&mxTransformInv))
00070         {
00071             D2D1_POINT_2F clientPoint[] = {
00072                 {0, 0},
00073                 {clientSize.Width - 1, 0},
00074                 {0,  clientSize.Height - 1},
00075                 {clientSize.Width - 1, clientSize.Height - 1}};
00076             for (int i=0; i<ARRAYSIZE(clientPoint); ++i)
00077             {
00078                 D2D1_POINT_2F pt = mxTransformInv.TransformPoint(clientPoint[i]);
00079                 int ix = (int)floor(0.5 + pt.x / clientSize.Width);
00080                 int iy = (int)floor(0.5 + pt.y / clientSize.Height);
00081                 if (i == 0)
00082                 {
00083                     ixMin = ixMax = ix;
00084                     iyMin = iyMax = iy;
00085                 }
00086                 else
00087                 {
00088                     ixMin = min(ixMin, ix);
00089                     ixMax = max(ixMax, ix);
00090                     iyMin = min(iyMin, iy);
00091                     iyMax = max(iyMax, iy);
00092                 }
00093             }
00094         }
00095     }
00096
00097     // Render background tiles.
00098     deviceContext->SetTransform(&mxTransform);
00099     for (int ix = ixMin; ix <= ixMax+1; ++ix)
00100     {
00101         D2D1_POINT_2F pt0 = {(ix - 0.5f) * clientSize.Width, (iyMin - 0.5f) * clientSize.Height};
00102         D2D1_POINT_2F pt1 = {(ix - 0.5f) * clientSize.Width, (iyMax + 0.5f) * clientSize.Height};
00103         deviceContext->DrawLine(pt0, pt1, brush);
00104     }
00105     for (int iy = iyMin; iy <= iyMax+1; ++iy)
00106     {
00107         D2D1_POINT_2F pt0 = {(ixMin - 0.5f) * clientSize.Width, (iy - 0.5f) * clientSize.Height};
00108         D2D1_POINT_2F pt1 = {(ixMax + 0.5f) * clientSize.Width, (iy - 0.5f) * clientSize.Height};
00109         deviceContext->DrawLine(pt0, pt1, brush);
00110     }
00111 }
00112
00113 void BackgroundObject::DrawOverlay(
00114     _In_ ID2D1DeviceContext* deviceContext,
00115     _In_ IDWriteTextFormat* textFormat,
00116     _In_ ID2D1SolidColorBrush* brush)
00117 {
00118     Windows::Foundation::Size clientSize = _renderer->ViewSize();
00119     brush->SetOpacity(1.0f);
00120
00121     textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING);
00122     textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR);
00123     textFormat->SetWordWrapping(DWRITE_WORD_WRAPPING_WRAP);
00124
00125     size_t deviceDescLen = 0;
00126     (void)StringCchLength(_deviceDesc , ARRAYSIZE(_deviceDesc), &deviceDescLen);
00127     if (deviceDescLen != 0)
00128     {
00129         deviceContext->DrawText(_deviceDesc, (UINT)deviceDescLen, textFormat,
00130             D2D1::RectF(0, 0, clientSize.Width, clientSize.Height), brush);
00131     }
00132 }
00133
00134 ///////////////////////////////////////////////////////////////////////////////
00135 // Attach/detach GestureRecognizer to/from the object.
00136 //
00137
00138 void BackgroundObject::Attach(_In_ Windows::UI::Input::GestureRecognizer^ gestureRecognizer)
00139 {
00140     // Configure gesture recognizer
00141     gestureRecognizer->GestureSettings =
00142         Windows::UI::Input::GestureSettings::Hold                           |
00143         Windows::UI::Input::GestureSettings::HoldWithMouse                  |
00144         Windows::UI::Input::GestureSettings::RightTap                       |
00145         Windows::UI::Input::GestureSettings::ManipulationTranslateX         |
00146         Windows::UI::Input::GestureSettings::ManipulationTranslateY         |
00147         Windows::UI::Input::GestureSettings::ManipulationScale              |
00148         Windows::UI::Input::GestureSettings::ManipulationRotate             |
00149         Windows::UI::Input::GestureSettings::ManipulationTranslateInertia   |
00150         Windows::UI::Input::GestureSettings::ManipulationScaleInertia       |
00151         Windows::UI::Input::GestureSettings::ManipulationRotateInertia;
00152
00153     // Register all the delegates
00154     _tokenRightTapped = gestureRecognizer->RightTapped::add(
00155         ref new Windows::Foundation::TypedEventHandler<
00156             Windows::UI::Input::GestureRecognizer^, Windows::UI::Input::RightTappedEventArgs^>(
00157                 this, &BackgroundObject::OnRightTapped));
00158
00159     _tokenHolding = gestureRecognizer->Holding::add(
00160         ref new Windows::Foundation::TypedEventHandler<
00161             Windows::UI::Input::GestureRecognizer^, Windows::UI::Input::HoldingEventArgs^>(
00162                 this, &BackgroundObject::OnHolding));
00163
00164     _tokenManipulationStarted = gestureRecognizer->ManipulationStarted::add(
00165         ref new Windows::Foundation::TypedEventHandler<
00166             Windows::UI::Input::GestureRecognizer^, Windows::UI::Input::ManipulationStartedEventArgs^>(
00167                 this, &BackgroundObject::OnManipulationStarted));
00168
00169     _tokenManipulationUpdated = gestureRecognizer->ManipulationUpdated::add(
00170         ref new Windows::Foundation::TypedEventHandler<
00171             Windows::UI::Input::GestureRecognizer^, Windows::UI::Input::ManipulationUpdatedEventArgs^>(
00172                 this, &BackgroundObject::OnManipulationUpdated));
00173
00174     _tokenManipulationInertiaStarting = gestureRecognizer->ManipulationInertiaStarting::add(
00175         ref new Windows::Foundation::TypedEventHandler<
00176             Windows::UI::Input::GestureRecognizer^, Windows::UI::Input::ManipulationInertiaStartingEventArgs^>(
00177                 this, &BackgroundObject::OnManipulationInertiaStarting));
00178
00179     _tokenManipulationCompleted = gestureRecognizer->ManipulationCompleted::add(
00180         ref new Windows::Foundation::TypedEventHandler<
00181             Windows::UI::Input::GestureRecognizer^, Windows::UI::Input::ManipulationCompletedEventArgs^>(
00182                 this, &BackgroundObject::OnManipulationCompleted));
00183 }
00184
00185 void BackgroundObject::Detach(_In_ Windows::UI::Input::GestureRecognizer^ gestureRecognizer)
00186 {
00187     // Remove all the delegates
00188     gestureRecognizer->RightTapped::remove(_tokenRightTapped);
00189     gestureRecognizer->Holding::remove(_tokenHolding);
00190     gestureRecognizer->ManipulationStarted::remove(_tokenManipulationStarted);
00191     gestureRecognizer->ManipulationUpdated::remove(_tokenManipulationUpdated);
00192     gestureRecognizer->ManipulationInertiaStarting::remove(_tokenManipulationInertiaStarting);
00193     gestureRecognizer->ManipulationCompleted::remove(_tokenManipulationCompleted);
00194 }
00195
00196 ///////////////////////////////////////////////////////////////////////////////
00197 // GestureRecognizer event handlers.
00198 //
00199
00200 void BackgroundObject::OnRightTapped(
00201     _In_ Windows::UI::Input::GestureRecognizer^,
00202     _In_ Windows::UI::Input::RightTappedEventArgs^)
00203 {
00204     Initialize();
00205     _renderer->RequestRedraw();
00206 }
00207
00208 void BackgroundObject::OnHolding(
00209     _In_ Windows::UI::Input::GestureRecognizer^,
00210     _In_ Windows::UI::Input::HoldingEventArgs^ args)
00211 {
00212     if (args->HoldingState == Windows::UI::Input::HoldingState::Started)
00213     {
00214         GetDeviceDescription();
00215     }
00216     else
00217     {
00218         _deviceDesc[0] = L'\0';
00219     }
00220     _renderer->RequestRedraw();
00221 }
00222
00223 void BackgroundObject::OnManipulationStarted(
00224     _In_ Windows::UI::Input::GestureRecognizer^,
00225     _In_ Windows::UI::Input::ManipulationStartedEventArgs^)
00226 {
00227 }
00228
00229 void BackgroundObject::OnManipulationUpdated(
00230     _In_ Windows::UI::Input::GestureRecognizer^,
00231     _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ args)
00232 {
00233     UpdateManipulationTransform(
00234         LimitManipulationScale(args->Delta, 0.1f, 10.0f),
00235         args->Position);
00236     _renderer->RequestRedraw();
00237 }
00238
00239 void BackgroundObject::OnManipulationInertiaStarting(
00240     _In_ Windows::UI::Input::GestureRecognizer^,
00241     _In_ Windows::UI::Input::ManipulationInertiaStartingEventArgs^)
00242 {
00243 }
00244
00245 void BackgroundObject::OnManipulationCompleted(
00246     _In_ Windows::UI::Input::GestureRecognizer^,
00247     _In_ Windows::UI::Input::ManipulationCompletedEventArgs^)
00248 {
00249 }
00250
00251 void BackgroundObject::GetDeviceDescription()
00252 {
00253     try
00254     {
00255         DX::ThrowIfFailed((_pointerDevice != nullptr) ? S_OK : E_FAIL);
00256
00257         Windows::Devices::Input::PointerDeviceType type = _pointerDevice->PointerDeviceType;
00258         boolean integrated = _pointerDevice->IsIntegrated;
00259         UINT32 maxContacts = _pointerDevice->MaxContacts;
00260         Windows::Foundation::Rect rcPhysical = _pointerDevice->PhysicalDeviceRect;
00261         Windows::Foundation::Rect rcScreen = _pointerDevice->ScreenRect;
00262
00263         StringCchPrintfW(_deviceDesc, ARRAYSIZE(_deviceDesc), L"%s %s\nMaxContacts=%u\nPhysical=(%g,%g)(%gx%g)\nScreen=(%g,%g)(%gx%g)",
00264             (type == Windows::Devices::Input::PointerDeviceType::Touch) ? L"Touch" :
00265                 (type == Windows::Devices::Input::PointerDeviceType::Pen)   ? L"Pen" :
00266                 (type == Windows::Devices::Input::PointerDeviceType::Mouse) ? L"Mouse" :
00267                 L"Unknown",
00268             integrated ? L"Integrated" : L"External",
00269             maxContacts,
00270             rcPhysical.X,
00271             rcPhysical.Y,
00272             rcPhysical.Width,
00273             rcPhysical.Height,
00274             rcScreen.X,
00275             rcScreen.Y,
00276             rcScreen.Width,
00277             rcScreen.Height);
00278     }
00279     catch (Platform::COMException^)
00280     {
00281         StringCchCopyW(_deviceDesc, ARRAYSIZE(_deviceDesc), L"?");
00282     }
00283 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/Constants.h Source File

  • Reading and writing data

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME {
00027             Platform::String^ get() {  return ref new Platform::String(L"DataReader/Writer Sample"); }
00028         }
00029
00030         static property Platform::Array<Scenario>^ scenarios {
00031             Platform::Array<Scenario>^ get()
00032             {
00033                 return scenariosInner;
00034             }
00035         }
00036     private:
00037         static Platform::Array<Scenario>^ scenariosInner;
00038     };
00039
00040
00041 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/VariableGridView.h Source File

  • Hilo C++
  • Hilo

VariableGridView.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     [Windows::Foundation::Metadata::WebHostHidden]
00012     public ref class VariableGridView sealed : public Windows::UI::Xaml::Controls::GridView
00013     {
00014     protected:
00015         virtual void PrepareContainerForItemOverride(Windows::UI::Xaml::DependencyObject^ element, Platform::Object^ item) override;
00016     };
00017 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Constants.cpp Source File

  • StreamSocket

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace StreamSocketSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "Start StreamSocketListener", "StreamSocketSample.Scenario1" },
00022     { "Connect to Listener", "StreamSocketSample.Scenario2" },
00023     { "Send Data", "StreamSocketSample.Scenario3" },
00024     { "Close Socket", "StreamSocketSample.Scenario4" }
00025 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/pch.cpp Source File

  • Scaling according to DPI

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/Sample-Utils/SuspensionManager.cs Source File

  • Media extensions
  • C#,C++
  • Sample-Utils

SuspensionManager.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using System;
00012 using System.Collections.Generic;
00013 using System.Linq;
00014 using System.Text;
00015 using System.Threading.Tasks;
00016 using Windows.Storage;
00017 using Windows.Storage.Streams;
00018 using System.Runtime.Serialization;
00019 using System.IO;
00020 using Windows.ApplicationModel;
00021
00022 class SuspensionManager
00023 {
00024     static private Dictionary<string, object> sessionState_ = new Dictionary<string, object>();
00025     static private List<Type> knownTypes_ = new List<Type>();
00026     private const string filename = "_sessionState.xml";
00027
00028     // Provides access to the currect session state
00029     static public Dictionary<string, object> SessionState
00030     {
00031         get { return sessionState_; }
00032     }
00033
00034     // Allows custom types to be added to the list of types that can be serialized
00035     static public List<Type> KnownTypes
00036     {
00037         get { return knownTypes_; }
00038     }
00039
00040     // Save the current session state
00041     static async public Task SaveAsync()
00042     {
00043         // Get the output stream for the SessionState file.
00044         StorageFile file = await ApplicationData.Current.LocalFolder.CreateFileAsync(filename, CreationCollisionOption.ReplaceExisting);
00045         using (StorageStreamTransaction transaction = await file.OpenTransactedWriteAsync())
00046         {
00047             // Serialize the Session State.
00048             DataContractSerializer serializer = new DataContractSerializer(typeof(Dictionary<string, object>), knownTypes_);
00049             serializer.WriteObject(transaction.Stream.AsStreamForWrite(), sessionState_);
00050             await transaction.CommitAsync();
00051         }
00052     }
00053
00054     // Restore the saved sesison state
00055     static async public Task RestoreAsync()
00056     {
00057         // Get the input stream for the SessionState file.
00058         try
00059         {
00060             StorageFile file = await ApplicationData.Current.LocalFolder.GetFileAsync(filename);
00061             if (file == null) return;
00062             using (IInputStream inStream = await file.OpenSequentialReadAsync())
00063             {
00064                 // Deserialize the Session State.
00065                 DataContractSerializer serializer = new DataContractSerializer(typeof(Dictionary<string, object>), knownTypes_);
00066                 sessionState_ = (Dictionary<string, object>)serializer.ReadObject(inStream.AsStreamForRead());
00067             }
00068         }
00069         catch (Exception)
00070         {
00071             // Restoring state is best-effort.  If it fails, the app will just come up with a new session.
00072         }
00073     }
00074 }
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/Constants.h Source File

  • Number formatting and parsing

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Number Formatting Sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/pch.h Source File

  • CameraCaptureUI

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::SearchContract::sealed Member List

This is the complete list of members for SDKSample::SearchContract::sealed, including all inherited members.
AddSuggestionFromNode(Windows::Data::Xml::Dom::IXmlNode^node, Windows::ApplicationModel::Search::SearchSuggestionCollection^suggestions) | SDKSample::SearchContract::sealed | [protected]
cts | SDKSample::SearchContract::sealed | [private]
GetSuggestions(Windows::Data::Xml::Dom::XmlDocument^doc, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequest^request) | SDKSample::SearchContract::sealed | [protected]
httpRequest | SDKSample::SearchContract::sealed | [private]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::SearchContract::sealed | [protected, virtual]
OnResultSuggestionChosen(Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneResultSuggestionChosenEventArgs^e) | SDKSample::SearchContract::sealed | [protected]
OnSearchPaneSuggestionsRequested(Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^e) | SDKSample::SearchContract::sealed | [protected]
OnSearchPaneSuggestionsRequested(Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^e) | SDKSample::SearchContract::sealed | [protected]
OnSearchPaneSuggestionsRequested(Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^e) | SDKSample::SearchContract::sealed | [protected]
OnSearchPaneSuggestionsRequested(Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^e) | SDKSample::SearchContract::sealed | [protected]
resultSuggestionChosenToken | SDKSample::SearchContract::sealed | [private]
Scenario1() | SDKSample::SearchContract::sealed |
Scenario2() | SDKSample::SearchContract::sealed |
Scenario3() | SDKSample::SearchContract::sealed |
Scenario4() | SDKSample::SearchContract::sealed |
Scenario5() | SDKSample::SearchContract::sealed |
Scenario6() | SDKSample::SearchContract::sealed |
Scenario7() | SDKSample::SearchContract::sealed |
searchPane | SDKSample::SearchContract::sealed | [private]
SetLocalContentSuggestions(bool isLocal) | SDKSample::SearchContract::sealed | [protected]
suggestionsRequestedToken | SDKSample::SearchContract::sealed | [private]
token | SDKSample::SearchContract::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/common/LayoutAwarePage.h Source File

  • UI contrast and settings
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/common/suspensionmanager.cpp Source File

  • App tiles and badges
  • C#,C++
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/InAppPurchase.xaml.cpp Source File

  • Trial app and in-app purchase

InAppPurchase.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // InAppPurchase.xaml.cpp
00013 // Implementation of the InAppPurchase class
00014 //
00015
00016 #include "pch.h"
00017 #include "InAppPurchase.xaml.h"
00018
00019 using namespace SDKSample::StoreSample;
00020
00021 using namespace concurrency;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::ApplicationModel::Store;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Globalization;
00026 using namespace Windows::Storage;
00027 using namespace Windows::UI::Xaml;
00028 using namespace Windows::UI::Xaml::Controls;
00029 using namespace Windows::UI::Xaml::Navigation;
00030
00031 InAppPurchase::InAppPurchase()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void InAppPurchase::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046     LoadInAppPurchaseProxyFile();
00047 }
00048
00049 void InAppPurchase::OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e)
00050 {
00051     CurrentAppSimulator::LicenseInformation->LicenseChanged -= eventRegistrationToken;
00052 }
00053
00054 void InAppPurchase::LoadInAppPurchaseProxyFile()
00055 {
00056     create_task(Package::Current->InstalledLocation->GetFolderAsync("data")).then([this](StorageFolder^ proxyDataFolder)
00057     {
00058         create_task(proxyDataFolder->GetFileAsync("in-app-purchase.xml")).then([this](StorageFile^ proxyFile)
00059         {
00060             eventRegistrationToken = (CurrentAppSimulator::LicenseInformation->LicenseChanged += ref new LicenseChangedEventHandler(this, &InAppPurchase::InAppPurchaseRefreshScenario));
00061             create_task(CurrentAppSimulator::ReloadSimulatorAsync(proxyFile)).then([this]()
00062             {
00063                 create_task(CurrentAppSimulator::LoadListingInformationAsync()).then([this](ListingInformation^ listing)
00064                 {
00065                     auto product1 = listing->ProductListings->Lookup("product1");
00066                     auto product2 = listing->ProductListings->Lookup("product2");
00067                     Product1SellMessage->Text = "You can buy " + product1->Name + " for: " + product1->FormattedPrice + ".";
00068                     Product2SellMessage->Text = "You can buy " + product2->Name + " for: " + product2->FormattedPrice + ".";
00069                 });
00070             });
00071         });
00072     });
00073 }
00074
00075 void InAppPurchase::InAppPurchaseRefreshScenario()
00076 {
00077 }
00078
00079 void InAppPurchase::TryProduct1_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00080 {
00081     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00082     auto productLicense = licenseInformation->ProductLicenses->Lookup("product1");
00083     if (productLicense->IsActive)
00084     {
00085         rootPage->NotifyUser("You can use Product 1.", NotifyType::StatusMessage);
00086     }
00087     else
00088     {
00089         rootPage->NotifyUser("You don't own Product 1. You must buy Product 1 before you can use it.", NotifyType::ErrorMessage);
00090     }
00091 }
00092
00093 void InAppPurchase::BuyProduct1Button_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00094 {
00095     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00096     if (!licenseInformation->ProductLicenses->Lookup("product1")->IsActive)
00097     {
00098         rootPage->NotifyUser("Buying Product 1...", NotifyType::StatusMessage);
00099         create_task(CurrentAppSimulator::RequestProductPurchaseAsync("product1", false)).then([this](task<Platform::String^> currentTask)
00100         {
00101             try
00102             {
00103                 currentTask.get();
00104                 auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00105                 if (licenseInformation->ProductLicenses->Lookup("product1")->IsActive)
00106                 {
00107                     rootPage->NotifyUser("You bought Product 1.", NotifyType::StatusMessage);
00108                 }
00109                 else
00110                 {
00111                     rootPage->NotifyUser("", NotifyType::StatusMessage);
00112                 }
00113             }
00114             catch(Platform::Exception^ exception)
00115             {
00116                 rootPage->NotifyUser("Unable to buy Product 1.", NotifyType::ErrorMessage);
00117             }
00118         });
00119     }
00120     else
00121     {
00122         rootPage->NotifyUser("You already own Product 1.", NotifyType::ErrorMessage);
00123     }
00124 }
00125
00126 void InAppPurchase::TryProduct2_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00127 {
00128     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00129     auto productLicense = licenseInformation->ProductLicenses->Lookup("product2");
00130     if (productLicense->IsActive)
00131     {
00132         rootPage->NotifyUser("You can use Product 2.", NotifyType::StatusMessage);
00133     }
00134     else
00135     {
00136         rootPage->NotifyUser("You don't own Product 2. You must buy Product 1 before you can use it.", NotifyType::ErrorMessage);
00137     }
00138 }
00139
00140 void InAppPurchase::BuyProduct2_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00141 {
00142     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00143     if (!licenseInformation->ProductLicenses->Lookup("product2")->IsActive)
00144     {
00145         rootPage->NotifyUser("Buying Product 2...", NotifyType::StatusMessage);
00146         create_task(CurrentAppSimulator::RequestProductPurchaseAsync("product2", false)).then([this](task<Platform::String^> currentTask)
00147         {
00148             try
00149             {
00150                 currentTask.get();
00151                 auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00152                 if (licenseInformation->ProductLicenses->Lookup("product2")->IsActive)
00153                 {
00154                     rootPage->NotifyUser("You bought Product 2.", NotifyType::StatusMessage);
00155                 }
00156                 else
00157                 {
00158                     rootPage->NotifyUser("", NotifyType::StatusMessage);
00159                 }
00160             }
00161             catch(Platform::Exception^ exception)
00162             {
00163                 rootPage->NotifyUser("Unable to buy Product 2.", NotifyType::ErrorMessage);
00164             }
00165         });
00166     }
00167     else
00168     {
00169         rootPage->NotifyUser("You already own Product 2.", NotifyType::ErrorMessage);
00170     }
00171 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/common/LayoutAwarePage.cpp Source File

  • Globalization preferences
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/pch.h Source File

  • DirectX touch input

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
00017 #include "BasicMath.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

RawNotificationsSampleCPP::sealed Member List

This is the complete list of members for RawNotificationsSampleCPP::sealed, including all inherited members.
_channel | RawNotificationsSampleCPP::sealed |
_dispatcher | RawNotificationsSampleCPP::sealed | [private]
_displayHandlerToken | RawNotificationsSampleCPP::sealed |
_frameLoadedToken | RawNotificationsSampleCPP::sealed | [private]
_frameLoadedToken | RawNotificationsSampleCPP::sealed | [private]
_inputFrame | RawNotificationsSampleCPP::sealed |
_inputFrameLoadedToken | RawNotificationsSampleCPP::sealed |
_layoutHandlerToken | RawNotificationsSampleCPP::sealed |
_logicalDpiChangedToken | RawNotificationsSampleCPP::sealed |
_outputFrame | RawNotificationsSampleCPP::sealed |
_outputFrameLoadedToken | RawNotificationsSampleCPP::sealed |
_pageLoadedHandlerToken | RawNotificationsSampleCPP::sealed |
_scenariosFrame | RawNotificationsSampleCPP::sealed |
App() | RawNotificationsSampleCPP::sealed |
BackgroundTaskCompleted(Windows::ApplicationModel::Background::BackgroundTaskRegistration^sender, Windows::ApplicationModel::Background::BackgroundTaskCompletedEventArgs^args) | RawNotificationsSampleCPP::sealed | [private]
CheckResolutionAndViewState() | RawNotificationsSampleCPP::sealed |
ConvertResolution(ResolutionScale scale) | RawNotificationsSampleCPP::sealed |
ConvertViewState(ApplicationViewState state) | RawNotificationsSampleCPP::sealed |
DisplayProperties_LogicalDpiChanged(Object^sender) | RawNotificationsSampleCPP::sealed |
DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame) | RawNotificationsSampleCPP::sealed |
Footer_Click(Object^sender, RoutedEventArgs^e) | RawNotificationsSampleCPP::sealed |
inputFrameNavigated(Object^sender, NavigationEventArgs^e) | RawNotificationsSampleCPP::sealed |
MainPage() | RawNotificationsSampleCPP::sealed |
NotifyUser(String^strMessage, NotifyType type) | RawNotificationsSampleCPP::sealed |
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | RawNotificationsSampleCPP::sealed | [virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | RawNotificationsSampleCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | RawNotificationsSampleCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | RawNotificationsSampleCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | RawNotificationsSampleCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | RawNotificationsSampleCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | RawNotificationsSampleCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | RawNotificationsSampleCPP::sealed | [protected, virtual]
OnPushNotificationReceived(Windows::Networking::PushNotifications::PushNotificationChannel^sender, Windows::Networking::PushNotifications::PushNotificationReceivedEventArgs^e) | RawNotificationsSampleCPP::sealed | [private]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | RawNotificationsSampleCPP::sealed | [virtual]
OpenChannelAndRegisterTask() | RawNotificationsSampleCPP::sealed | [private]
OutputFrameLoaded | RawNotificationsSampleCPP::sealed |
OutputFrameLoaded(Object^sender, Object^e) | RawNotificationsSampleCPP::sealed | [private]
outputFrameNavigated(Object^sender, NavigationEventArgs^e) | RawNotificationsSampleCPP::sealed |
OutputToTextBox(Platform::String^text) | RawNotificationsSampleCPP::sealed | [private]
Page_Loaded(Object^sender, RoutedEventArgs^e) | RawNotificationsSampleCPP::sealed |
Page_SizeChanged(Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | RawNotificationsSampleCPP::sealed |
pushToken | RawNotificationsSampleCPP::sealed | [private]
RegisterBackgroundTask() | RawNotificationsSampleCPP::sealed | [private]
rootPage | RawNotificationsSampleCPP::sealed | [private]
rootPage_InputFrameLoaded(Object^sender, Object^e) | RawNotificationsSampleCPP::sealed | [private]
Scenario1Open_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | RawNotificationsSampleCPP::sealed | [private]
Scenario1Unregister_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | RawNotificationsSampleCPP::sealed | [private]
Scenario2AddListener_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | RawNotificationsSampleCPP::sealed | [private]
Scenario2RemoveListener_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | RawNotificationsSampleCPP::sealed | [private]
ScenarioInput1() | RawNotificationsSampleCPP::sealed |
ScenarioInput2() | RawNotificationsSampleCPP::sealed |
ScenarioList() | RawNotificationsSampleCPP::sealed |
ScenarioOutput1() | RawNotificationsSampleCPP::sealed |
ScenarioOutput2() | RawNotificationsSampleCPP::sealed |
Scenarios_SelectionChanged(Object^sender, SelectionChangedEventArgs^e) | RawNotificationsSampleCPP::sealed | [protected]
SetFeatureName(Platform::String^strFeature) | RawNotificationsSampleCPP::sealed |
UnregisterBackgroundTask() | RawNotificationsSampleCPP::sealed | [private]
UpdateListener(bool add) | RawNotificationsSampleCPP::sealed | [private]
~ScenarioInput1() | RawNotificationsSampleCPP::sealed | [private]
~ScenarioInput2() | RawNotificationsSampleCPP::sealed | [private]
~ScenarioList() | RawNotificationsSampleCPP::sealed | [private]
~ScenarioOutput1() | RawNotificationsSampleCPP::sealed | [private]
~ScenarioOutput2() | RawNotificationsSampleCPP::sealed | [private]
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveFileInput.xaml.cpp Source File

  • Association launching

ReceiveFileInput.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ReceiveFileInput.xaml.cpp
00010 // Implementation of the ReceiveFileInput class
00011 //
00012
00013 #include "pch.h"
00014 #include "ReceiveFileInput.xaml.h"
00015
00016 using namespace AssociationLaunching;
00017
00018 using namespace Platform;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::Graphics::Display;
00022 using namespace Windows::UI::ViewManagement;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Controls::Primitives;
00026 using namespace Windows::UI::Xaml::Data;
00027 using namespace Windows::UI::Xaml::Input;
00028 using namespace Windows::UI::Xaml::Media;
00029 using namespace Windows::UI::Xaml::Navigation;
00030
00031 ReceiveFileInput::ReceiveFileInput()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 ReceiveFileInput::~ReceiveFileInput()
00037 {
00038 }
00039
00040 void ReceiveFileInput::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // Get a pointer to our main page.
00043     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00044
00045     // Display the result of the file activation if we got here as a result of being activated for a file.
00046     if (rootPage->FileEvent != nullptr)
00047     {
00048         rootPage->NotifyUser("File activation received. The number of files received is " + rootPage->FileEvent->Files->Size + ". The first received file is " + rootPage->FileEvent->Files->GetAt(0)->Name + ".", NotifyType::StatusMessage);
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario3.xaml.cpp Source File

  • File and folder thumbnail

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::FileThumbnails;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::FileProperties;
00025 using namespace Windows::Storage::Pickers;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario3::Scenario3()
00031 {
00032     InitializeComponent();
00033     rootPage = MainPage::Current;
00034     GetThumbnailButton->Click += ref new RoutedEventHandler(this, &Scenario3::GetThumbnailButton_Click);
00035 }
00036
00037 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     rootPage->ResetOutput(ThumbnailImage, OutputTextBlock, nullptr);
00040 }
00041
00042 void Scenario3::GetThumbnailButton_Click(Object^ sender, RoutedEventArgs^ e)
00043 {
00044     rootPage->ResetOutput(ThumbnailImage, OutputTextBlock, nullptr);
00045
00046     if (rootPage->EnsureUnsnapped())
00047     {
00048         // Pick a document
00049         FileOpenPicker^ openPicker = ref new FileOpenPicker();
00050         Array<String^>^ extensions = FileExtensions::Document;
00051         for (unsigned int i = 0; i < extensions->Length; i++)
00052         {
00053             openPicker->FileTypeFilter->Append(extensions[i]);
00054         }
00055
00056         create_task(openPicker->PickSingleFileAsync()).then([this](StorageFile^ file)
00057         {
00058             if (file != nullptr)
00059             {
00060                 const ThumbnailMode thumbnailMode = ThumbnailMode::DocumentsView;
00061                 const size_t size = 100;
00062                 create_task(file->GetThumbnailAsync(thumbnailMode, size)).then([this, file, size](StorageItemThumbnail^ thumbnail)
00063                 {
00064                     if (thumbnail != nullptr)
00065                     {
00066                         MainPage::DisplayResult(ThumbnailImage, OutputTextBlock, "DocumentsView", size, file, thumbnail, false);
00067                     }
00068                     else
00069                     {
00070                         rootPage->NotifyUser(Errors::NoIcon, NotifyType::StatusMessage);
00071                     }
00072                 });
00073             }
00074             else
00075             {
00076                 rootPage->NotifyUser(Errors::Cancel, NotifyType::StatusMessage);
00077             }
00078         });
00079     }
00080 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/MainPage.xaml.h Source File

  • Lock screen apps
  • C#,C++

MainPage.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.h
00010 // Declaration of the MainPage.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "MainPage.g.h"
00017
00018 namespace LockScreenAppsCPP
00019 {
00020     public enum class NotifyType
00021     {
00022         StatusMessage,
00023         ErrorMessage
00024     };
00025
00026   [Windows::Foundation::Metadata::WebHostHidden]
00027     public ref class MainPage sealed
00028     {
00029     public:
00030         MainPage();
00031
00032         property Windows::UI::Xaml::Controls::Frame^ ScenariosFrame
00033         {
00034             Windows::UI::Xaml::Controls::Frame^ get() { return _scenariosFrame; }
00035         }
00036         property Windows::UI::Xaml::Controls::Frame^ InputFrame
00037         {
00038             Windows::UI::Xaml::Controls::Frame^ get() { return _inputFrame; }
00039         }
00040         property Windows::UI::Xaml::Controls::Frame^ OutputFrame
00041         {
00042             Windows::UI::Xaml::Controls::Frame^ get() { return _outputFrame; }
00043         }
00044
00045         event Windows::Foundation::EventHandler<Platform::Object^>^ InputFrameLoaded;
00046         event Windows::Foundation::EventHandler<Platform::Object^>^ OutputFrameLoaded;
00047
00048         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00049         void DoNavigation(Windows::UI::Xaml::Interop::TypeName inPageType, Windows::UI::Xaml::Controls::Frame^ inFrame, Windows::UI::Xaml::Interop::TypeName outPageType, Windows::UI::Xaml::Controls::Frame^ outFrame);
00050         Platform::String^ ConvertViewState(Windows::UI::ViewManagement::ApplicationViewState state);
00051         Platform::String^ ConvertResolution(Windows::Graphics::Display::ResolutionScale scale);
00052
00053     private:
00054         Windows::UI::Xaml::Controls::Frame^ _scenariosFrame;
00055         Windows::UI::Xaml::Controls::Frame^ _inputFrame;
00056         Windows::UI::Xaml::Controls::Frame^ _outputFrame;
00057         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00058         Windows::Foundation::EventRegistrationToken _resizeHandlerToken;
00059         Windows::Foundation::EventRegistrationToken _displayHandlerToken;
00060         Windows::Foundation::EventRegistrationToken _pageLoadedHandlerToken;
00061         Windows::Foundation::EventRegistrationToken _logicalDpiChangedToken;
00062         Windows::Foundation::EventRegistrationToken _inputFrameLoadedToken;
00063         Windows::Foundation::EventRegistrationToken _outputFrameLoadedToken;
00064         void Page_SizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00065         void DisplayProperties_LogicalDpiChanged(Object^ sender);
00066         void Page_Loaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00067         void CheckResolutionAndViewState();
00068         void SetFeatureName(Platform::String^ strFeature);
00069         void inputFrameNavigated(Object^ sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^ e);
00070         void outputFrameNavigated(Object^ sender,  Windows::UI::Xaml::Navigation::NavigationEventArgs^ e);
00071         ~MainPage();
00072     };
00073 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Common/LayoutAwarePage.cpp Source File

  • XAML data binding
  • Common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/pch.cpp Source File

  • UI Automation core window provider

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/pch.cpp Source File

  • Media engine native C++ video playback

pch.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // pch.cpp
00003 // Include the standard header and generate the precompiled header.
00004 //
00005
00006 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/fx2device.cpp Source File

  • Custom driver access
  • C++,JavaScript
  • DLL

fx2device.cpp

Go to the documentation of this file.
00001 ﻿#include "fx2device.h"
00002
00003 Fx2Device::Fx2Device(_In_ IDeviceIoControl* DeviceControl, _In_ String^ Id) : m_DeviceIoControl(DeviceControl),
00004                                                                               m_Id(Id) {
00005     OutputDebugString(L"Fx2 constructor invoked\n");
00006     return;
00007 }
00008
00009 Fx2Device::~Fx2Device ()
00010 {
00011     OutputDebugString(L"Fx2Device destructor invoked\n");
00012     return;
00013 }
00014
00015 String^
00016 Fx2Device::GetDeviceSelector()
00017 {
00018     return L"System.Devices.InterfaceClassGuid:=\"{573E8C73-0CB4-4471-A1BF-FAB26C31D384}\" AND "
00019            L"System.Devices.InterfaceEnabled:=System.StructuredQueryType.Boolean#True";
00020 }
00021
00022 Fx2Device^
00023 Fx2Device::FromId(
00024     _In_ String^ InstancePath
00025     )
00026 {
00027     ComPtr<ICreateDeviceAccessAsync> access;
00028     ComPtr<IDeviceIoControl> deviceControl;
00029     HRESULT hr;
00030
00031     hr = CreateDeviceAccessInstance(InstancePath->Data(),
00032                                     GENERIC_READ | GENERIC_WRITE,
00033                                     &access);
00034     THROW_HR(hr);
00035
00036     //
00037     // Wait on the open
00038     //
00039
00040     hr = access->Wait(INFINITE);
00041     THROW_HR(hr);
00042
00043     hr = access->GetResult(IID_PPV_ARGS(&deviceControl));
00044     THROW_HR(hr);
00045
00046     OutputDebugStringW(L"Creating device\n");
00047
00048     //
00049     // Create an instance of the class and initialize it.
00050     //
00051     return ref new Fx2Device(deviceControl.Get(), InstancePath);
00052 }
00053
00054 String^
00055 Fx2Device::Id::get(void) {
00056     return m_Id;
00057 }
00058
00059 BYTE
00060 Fx2Device::SevenSegmentDisplay::get(VOID) {
00061
00062     BYTE ssValue = 0;
00063     ULONG numBytesReturned;
00064     HRESULT hr;
00065
00066     hr = m_DeviceIoControl->DeviceIoControlSync(
00067             IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY,
00068             NULL,
00069             0,
00070             &ssValue,
00071             sizeof(ssValue),
00072             &numBytesReturned
00073             );
00074     THROW_HR(hr);
00075
00076     for(int i = 0; i < c_SegmentMaskCe; i += 1) {
00077         if (ssValue == c_SegmentMask[i]) {
00078             return (BYTE) i;
00079         }
00080     }
00081
00082     throw ref new InvalidArgumentException(L"Seven segment display value is not between 0 and 9");
00083 }
00084
00085 void
00086 Fx2Device::SevenSegmentDisplay::set(
00087     _In_ BYTE Value
00088     )
00089 {
00090     BYTE ssValue;
00091     HRESULT hr;
00092     DWORD bytesRead;
00093
00094     if (Value >= c_SegmentMaskCe) {
00095         throw ref new InvalidArgumentException(L"Value must be between 0 and 9");
00096     }
00097
00098     ssValue = c_SegmentMask[Value];
00099
00100     hr = m_DeviceIoControl->DeviceIoControlSync(
00101         IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY,
00102         &ssValue,
00103         sizeof(ssValue),
00104         NULL,
00105         0,
00106         &bytesRead
00107         );
00108     THROW_HR(hr);
00109 }
00110
00111 Array<bool>^
00112 Fx2Device::SwitchState::get(VOID) {
00113
00114     BYTE ssValue = 0;
00115     ULONG numBytesReturned;
00116     HRESULT hr;
00117
00118     hr = m_DeviceIoControl->DeviceIoControlSync(
00119             IOCTL_OSRUSBFX2_READ_SWITCHES,
00120             NULL,
00121             0,
00122             &ssValue,
00123             sizeof(ssValue),
00124             &numBytesReturned
00125             );
00126     THROW_HR(hr);
00127
00128     Array<bool>^ result = ref new Array<bool>(c_NumSwitches);
00129
00130     for(int i = 0; i < c_NumSwitches; i += 1) {
00131         result[i] = ((ssValue & (1 << i)) != 0);
00132     }
00133
00134     return result;
00135 }
00136
00137 void
00138 Fx2Device::SetBarGraphDisplay(
00139     _In_ const Array<bool>^ Values
00140     )
00141 {
00142     BAR_GRAPH_STATE state;
00143     int valuesCe = Values->Length;
00144     DWORD bytesRead;
00145
00146
00147     state.BarsAsUChar = 0;
00148     for(int i = 0; i < min(c_NumBarsInGraph, valuesCe); i += 1) {
00149         state.BarsAsUChar |= (Values[i] ? 1 : 0) << i;
00150     }
00151
00152     HRESULT hr = m_DeviceIoControl->DeviceIoControlSync(
00153         IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY,
00154         (PBYTE) &state,
00155         sizeof(state),
00156         NULL,
00157         0,
00158         &bytesRead
00159         );
00160
00161     THROW_HR(hr);
00162 }
00163
00164 EventRegistrationToken
00165 Fx2Device::SwitchStateChanged::add(
00166     __in SwitchStateChangedHandler^ h
00167     )
00168 {
00169     EventRegistrationToken t = m_SwitchStateChangedEvent::add(h);
00170
00171     if (InterlockedIncrement(&m_SwitchState.ListenerCount) == 1) {
00172         m_SwitchState.Repeater.Start(
00173             [this](cancellation_token cancelToken, task_continuation_context& context) {
00174
00175                 // register for cancellation and abort the IOCTL if it happens
00176                 auto cancelTokenRegistration = cancelToken.register_callback([=]() {
00177                     m_DeviceIoControl->CancelOperation(m_SwitchState.CancelContext);
00178                 });
00179
00180                 // Create a task chain.  Send an ioctl to get the next switch
00181                 // state change.  Chain a task to convert that into the switch
00182                 // change event.
00183                 auto op =
00184                 StartIoctl(m_DeviceIoControl.Get(),
00185                             IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE,
00186                             NULL,
00187                             0,
00188                             (PBYTE) &m_SwitchState.Buffer,
00189                             sizeof(m_SwitchState.Buffer),
00190                             &m_SwitchState.CancelContext).
00191                 then([=](DeviceControlResult dcr) {
00192
00193                     bool abort = false;
00194                     SwitchStateChangedEventArgs^ e = nullptr;
00195
00196                     // unregister for cancellation
00197                     cancelToken.deregister_callback(cancelTokenRegistration);
00198
00199                     if (dcr.Result == HRESULT_FROM_WIN32(ERROR_OPERATION_ABORTED)) {
00200                         // fall through for cancellation
00201                         abort = true;
00202                     } else if (dcr.Result != S_OK) {
00203                         // Update the error count.  If it exceeds our limit then abort
00204                         // the reader.
00205                         m_SwitchState.FailureCount += 1;
00206                         if (m_SwitchState.FailureCount > 10) {
00207                             e = ref new SwitchStateChangedEventArgs(dcr.Result);
00208                             abort = true;
00209                         }
00210                     } else {
00211                         // Success.  Reset the failure count.
00212                         e = ref new SwitchStateChangedEventArgs(m_SwitchState.Buffer);
00213                         m_SwitchState.FailureCount = 0;
00214                     }
00215
00216                     // Raise the event if appropriate.
00217                     if (e != nullptr) {
00218                         m_SwitchStateChangedEvent(this, e);
00219                     }
00220
00221                     return !abort;
00222                 }, context);    // Since this task raises an event back to javascript
00223                                 // it must run in the context of the original call to
00224                                 // start the Repeater (which was from the UI thread)
00225
00226                 // Return the task chain.  The repeater will run this each
00227                 // time it starts an I/O operation, and takes care of starting
00228                 // the next task
00229                 return op;
00230             }
00231         );
00232     }
00233     return t;
00234 }
00235
00236 void
00237 Fx2Device::SwitchStateChanged::remove(
00238     __in EventRegistrationToken cookie
00239     )
00240 {
00241     m_SwitchStateChangedEvent::remove(cookie);
00242
00243     if (InterlockedDecrement(&m_SwitchState.ListenerCount) == 0) {
00244         m_SwitchState.Repeater.Stop();
00245     }
00246 }
00247
00248 IAsyncOperation<BarGraphDisplayResult^>^ Fx2Device::GetBarGraphDisplayAsync(void) {
00249
00250     // create an async operation object and return it to the caller.  The lambda
00251     // provided is the Start function for the operation, and returns a chain of tasks
00252     // that eventually provides the BarGraphDisplayResult^ object to the caller.
00253
00254     return create_async([this](cancellation_token cancelToken) {
00255
00256         // create the final result object, which we use to store the response
00257         // from the driver.
00258         BarGraphDisplayResult^ bgr = ref new BarGraphDisplayResult();
00259
00260         // Hook up cancellation using the cancel_token.
00261         auto registrationToken = cancelToken.register_callback([this, bgr]() {
00262             ULONG_PTR t = *(bgr->GetCancelToken());
00263             if (t != 0) {
00264                 m_DeviceIoControl->CancelOperation(t);
00265             }
00266         });
00267
00268         // StartIoctl returns a task that completes when the IOCTL completes.
00269         // Attach a follow-on task to convert the IOCTL results into bar graph
00270         // results.
00271         auto taskChain =
00272             StartIoctl(this->m_DeviceIoControl.Get(),
00273                        IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY,
00274                        nullptr,
00275                        0,
00276                        (PUCHAR) &(bgr->m_State),
00277                        sizeof(bgr->m_State),
00278                        bgr->GetCancelToken()).
00279             then([bgr,cancelToken,registrationToken](DeviceControlResult result) {
00280                 cancelToken.deregister_callback(registrationToken);
00281                 if ((result.Result == S_OK) &&
00282                     (result.BytesTransferred != sizeof(BAR_GRAPH_STATE))) {
00283                     result.Result = E_FAIL;
00284                 }
00285
00286                 if (result.Result != S_OK) {
00287                     throw Platform::Exception::CreateException(result.Result, L"Error getting bar graph display");
00288                 }
00289
00290                 bgr->UpdateBars();
00291                 return bgr;
00292             });
00293
00294         return taskChain;
00295     });
00296 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CustomDeviceAccess::DeviceList Member List

This is the complete list of members for CustomDeviceAccess::DeviceList, including all inherited members.
CreateBooleanTable(InlineCollection Table, bool[] NewValues, bool[] OldValues, string IndexTitle, string ValueTitle, string TrueValue, string FalseValue) | CustomDeviceAccess::DeviceList | [inline, static]
Current | CustomDeviceAccess::DeviceList | [static]
DeviceClosing | CustomDeviceAccess::DeviceList |
DeviceList() | CustomDeviceAccess::DeviceList | [inline, private, static]
FindInList(string id) | CustomDeviceAccess::DeviceList | [inline, private]
Fx2Device | CustomDeviceAccess::DeviceList |
Fx2Devices | CustomDeviceAccess::DeviceList |
InitDeviceWatcher() | CustomDeviceAccess::DeviceList | [inline, private]
m_Fx2Device | CustomDeviceAccess::DeviceList | [private]
m_Fx2Devices | CustomDeviceAccess::DeviceList | [private]
m_Fx2Watcher | CustomDeviceAccess::DeviceList | [private]
m_WatcherSuspended | CustomDeviceAccess::DeviceList | [private]
OnFx2Added(Windows.Devices.Enumeration.DeviceWatcher sender, Windows.Devices.Enumeration.DeviceInformation devInterface) | CustomDeviceAccess::DeviceList | [inline, private]
OnFx2EnumerationComplete(Windows.Devices.Enumeration.DeviceWatcher sender, object args) | CustomDeviceAccess::DeviceList | [inline, private]
OnFx2Removed(Windows.Devices.Enumeration.DeviceWatcher sender, Windows.Devices.Enumeration.DeviceInformationUpdate devInformation) | CustomDeviceAccess::DeviceList | [inline, private]
ResumeDeviceWatcher(object sender, object e) | CustomDeviceAccess::DeviceList | [inline, private]
StartFx2Watcher() | CustomDeviceAccess::DeviceList | [inline]
StopFx2Watcher() | CustomDeviceAccess::DeviceList | [inline]
SuspendDeviceWatcher(object sender, SuspendingEventArgs e) | CustomDeviceAccess::DeviceList | [inline, private]
WatcherStarted | CustomDeviceAccess::DeviceList |
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/pch.h Source File

  • Direct2D composite effect modes

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/pch.cpp Source File

  • Extended Linguistic Services (ELS)
  • C++

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicShapes.h Source File

  • DirectX touch input

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/MainPage.xaml.h Source File

  • Splash screen

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     [Windows::Foundation::Metadata::WebHostHidden]
00052     public ref class MainPage sealed
00053     {
00054     public:
00055         MainPage();
00056
00057     protected:
00058         virtual void LoadState(Platform::Object^ navigationParameter,
00059             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00061
00062     internal:
00063         property bool AutoSizeInputSectionWhenSnapped
00064         {
00065             bool get()
00066             {
00067                 return autoSizeInputSectionWhenSnapped;
00068             }
00069
00070             void set(bool value)
00071             {
00072                 autoSizeInputSectionWhenSnapped = value;
00073             }
00074         }
00075
00076         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00077         {
00078             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00079             {
00080                 return safe_cast<App^>(App::Current)->LaunchArgs;
00081             }
00082         }
00083
00084         void SetExtendedSplashInfo(Windows::Foundation::Rect splashRect, bool dismissStat);
00085         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00086         void LoadScenario(Platform::String^ scenarioName);
00087         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00088         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00089
00090     private:
00091         void PopulateScenarios();
00092         void InvalidateSize();
00093         void InvalidateViewState();
00094
00095         Platform::Collections::Vector<Object^>^ ScenarioList;
00096         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00097         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00098         bool autoSizeInputSectionWhenSnapped;
00099
00100         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00101         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00102
00103     internal:
00104         static MainPage^ Current;
00105         Windows::Foundation::Rect SplashImageRect;
00106         bool Dismissed;
00107     };
00108 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/pch.cpp Source File

  • Direct2D printing images and effects

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level6.h Source File

  • DirectX 3D shooting game

Level6.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Level6:
00011 // This class defines the sixth and final level of the game.  It derives from the
00012 // fifth level.  In this level the targets do not disappear when they are hit.
00013 // The target will stay highlighted for two seconds.  As this is the last level
00014 // the only criteria for completion is time expiring.
00015
00016 #include "Level5.h"
00017
00018 ref class Level6: public Level5
00019 {
00020 internal:
00021     Level6();
00022     virtual bool Update(
00023         float time,
00024         float elapsedTime,
00025         float timeRemaining,
00026         std::vector<GameObject^> objects
00027         ) override;
00028 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioOutput2.xaml.h Source File

  • Credential picker

ScenarioOutput2.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Output.xaml.h
00010 // Declaration of the Scenario2Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput2.g.h"
00017 #include "MainPage.g.h"
00018
00019 namespace CredentialPickerCPP
00020 {
00021   [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class ScenarioOutput2 sealed
00023     {
00024     public:
00025         ScenarioOutput2();
00026
00027     protected:
00028         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~ScenarioOutput2();
00033
00034         MainPage^ rootPage;
00035         void rootPage_InputFrameLoaded(Object^ sender, Object^ e);
00036         Windows::Foundation::EventRegistrationToken _frameLoadedToken;
00037     };
00038 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CMPEG1Stream Member List

This is the complete list of members for CMPEG1Stream, including all inherited members.
Activate(BOOL bActive) | CMPEG1Stream |
BeginGetEvent(IMFAsyncCallback *pCallback, IUnknown *punkState) | CMPEG1Stream |
CheckShutdown() const | CMPEG1Stream | [inline, private]
CMPEG1Stream(CMPEG1Source *pSource, IMFStreamDescriptor *pSD, HRESULT &hr) | CMPEG1Stream |
DeliverPayload(IMFSample *pSample) | CMPEG1Stream |
DispatchSamples() | CMPEG1Stream | [private]
EndGetEvent(IMFAsyncResult *pResult, IMFMediaEvent **ppEvent) | CMPEG1Stream |
EndOfStream() | CMPEG1Stream |
GetEvent(DWORD dwFlags, IMFMediaEvent **ppEvent) | CMPEG1Stream |
GetMediaSource(IMFMediaSource **ppMediaSource) | CMPEG1Stream |
GetStreamDescriptor(IMFStreamDescriptor **ppStreamDescriptor) | CMPEG1Stream |
IsActive() const | CMPEG1Stream | [inline]
m_bActive | CMPEG1Stream | [private]
m_bEOS | CMPEG1Stream | [private]
m_cRef | CMPEG1Stream | [private]
m_flRate | CMPEG1Stream | [private]
m_pEventQueue | CMPEG1Stream | [private]
m_pSource | CMPEG1Stream | [private]
m_pStreamDescriptor | CMPEG1Stream | [private]
m_Requests | CMPEG1Stream | [private]
m_Samples | CMPEG1Stream | [private]
m_state | CMPEG1Stream | [private]
NeedsData() | CMPEG1Stream |
OnDispatchSamples(IMFAsyncResult *pResult) | CMPEG1Stream |
Pause() | CMPEG1Stream |
QueryInterface(REFIID iid, void **ppv) | CMPEG1Stream |
QueueEvent(MediaEventType met, REFGUID guidExtendedType, HRESULT hrStatus, const PROPVARIANT *pvValue) | CMPEG1Stream |
RequestSample(IUnknown *pToken) | CMPEG1Stream |
SetRate(float flRate) | CMPEG1Stream |
Shutdown() | CMPEG1Stream |
Start(const PROPVARIANT &varStart) | CMPEG1Stream |
STDMETHODIMP_(ULONG) AddRef() | CMPEG1Stream |
STDMETHODIMP_(ULONG) Release() | CMPEG1Stream |
Stop() | CMPEG1Stream |
~CMPEG1Stream() | CMPEG1Stream |
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_PickFile.xaml.h Source File

  • File picker contracts

MainPage_PickFile.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage_PickFile.xaml.h
00013 // Declaration of the MainPage_PickFile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage_PickFile.g.h"
00020
00021 namespace SDKSample
00022 {
00023     namespace FilePickerContracts
00024     {
00025         /// <summary>
00026         /// An empty page that can be used on its own or navigated to within a Frame.
00027         /// </summary>
00028         public ref class MainPage_PickFile sealed
00029         {
00030         public:
00031             MainPage_PickFile();
00032
00033         private:
00034             void PickFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00035         };
00036     }
00037 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::RemovableStorageCPP::sealed Member List

This is the complete list of members for SDKSample::RemovableStorageCPP::sealed, including all inherited members.
_deviceInfoCollection | SDKSample::RemovableStorageCPP::sealed | [private]
CopyFileToFolderOnStorageAsync(Windows::Storage::StorageFile^sourceFile, Windows::Storage::StorageFolder^storage) | SDKSample::RemovableStorageCPP::sealed | [private]
DeviceList_Tapped(Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e) | SDKSample::RemovableStorageCPP::sealed | [private]
DeviceList_Tapped(Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e) | SDKSample::RemovableStorageCPP::sealed | [private]
DisplayImageAsync(Windows::Storage::StorageFile^imageFile) | SDKSample::RemovableStorageCPP::sealed | [private]
DisplayImageAsync(Windows::Storage::StorageFile^imageFile) | SDKSample::RemovableStorageCPP::sealed | [private]
GetFirstImageFromStorageAsync(Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement) | SDKSample::RemovableStorageCPP::sealed | [private]
GetFirstImageFromStorageAsync(Windows::Storage::StorageFolder^storage) | SDKSample::RemovableStorageCPP::sealed | [private]
GetImage_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::RemovableStorageCPP::sealed | [private]
GetImage_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::RemovableStorageCPP::sealed | [private]
ListStorages_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::RemovableStorageCPP::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::RemovableStorageCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::RemovableStorageCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::RemovableStorageCPP::sealed | [protected, virtual]
rootPage | SDKSample::RemovableStorageCPP::sealed | [private]
S1_ListStorages() | SDKSample::RemovableStorageCPP::sealed |
S2_SendToStorage() | SDKSample::RemovableStorageCPP::sealed |
S3_GetFromStorage() | SDKSample::RemovableStorageCPP::sealed |
S4_Autoplay() | SDKSample::RemovableStorageCPP::sealed |
SendImage_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::RemovableStorageCPP::sealed | [private]
SendImageFileToStorageAsync(Windows::Devices::Enumeration::DeviceInformation^deviceInfoElement) | SDKSample::RemovableStorageCPP::sealed | [private]
ShowDeviceSelectorAsync() | SDKSample::RemovableStorageCPP::sealed | [private]
ShowDeviceSelectorAsync() | SDKSample::RemovableStorageCPP::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/MainPage.xaml.h Source File

  • File picker

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput4.xaml.cpp Source File

  • Toast notifications
  • C#,C++

ScenarioOutput4.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.cpp
00010 // Implementation of the Scenario1Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput4.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace ToastsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput4::ScenarioOutput4()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput4::~ScenarioOutput4()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput4::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044   // Get a pointer to our main page.
00045   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047   // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048   _frameLoadedToken = rootPage->InputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioOutput4::rootPage_InputFrameLoaded);
00049 }
00050
00051 void ScenarioOutput4::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00054 }
00055
00056 #pragma endregion
00057
00058 #pragma region Use this code if you need access to elements in the input frame - otherwise delete
00059 void ScenarioOutput4::rootPage_InputFrameLoaded(Object^ sender, Object^ e)
00060 {
00061     // Get a pointer to the content within the OutputFrame.
00062     Page^ inputFrame = dynamic_cast<Page^>(rootPage->InputFrame->Content);
00063
00064     // Go find the elements that we need for this scenario
00065     // ex: flipView1 = dynamic_cast<FlipView^>(inputFrame->FindName("FlipView1"));
00066 }
00067
00068 #pragma endregion
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/pch.h Source File

  • DXGI swap chain rotation

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
00017 #include "BasicMath.h"
00018
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MainHubView.xaml.cpp Source File

  • Hilo C++
  • Hilo

MainHubView.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "MainHubView.xaml.h"
00009 #include "ImageNavigationData.h"
00010
00011 using namespace Hilo;
00012 using namespace Platform;
00013 using namespace Windows::UI::Xaml::Controls;
00014
00015 // See http://go.microsoft.com/fwlink/?LinkId=267278 for info on how Hilo creates pages and navigates to pages.
00016
00017 MainHubView::MainHubView()
00018 {
00019     InitializeComponent();
00020 }
00021
00022 void MainHubView::OnPhotoItemClicked(Object^ sender, ItemClickEventArgs^ e)
00023 {
00024     auto photo = dynamic_cast<Photo^>(e->ClickedItem);
00025     if (nullptr !=  photo)
00026     {
00027         ImageNavigationData imageData(photo);
00028         HiloPage::NavigateToPage(PageType::Image, imageData.SerializeToString());
00029     }
00030 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/common/LayoutAwarePage.cpp Source File

  • Web authentication broker
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/BasicReaderWriter.h Source File

  • Direct3D tutorial
  • Lesson2.Triangles

BasicReaderWriter.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <ppltasks.h>
00011
00012 // A simple reader/writer class that provides support for reading and writing
00013 // files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicReaderWriter
00015 {
00016 private:
00017     Windows::Storage::StorageFolder^ m_location;
00018     Platform::String^ m_locationPath;
00019
00020 internal:
00021     BasicReaderWriter();
00022     BasicReaderWriter(
00023         _In_ Windows::Storage::StorageFolder^ folder
00024         );
00025
00026     Platform::Array<byte>^ ReadData(
00027         _In_ Platform::String^ filename
00028         );
00029
00030     concurrency::task<Platform::Array<byte>^> ReadDataAsync(
00031         _In_ Platform::String^ filename
00032         );
00033
00034     uint32 WriteData(
00035         _In_ Platform::String^ filename,
00036         _In_ const Platform::Array<byte>^ fileData
00037         );
00038
00039     concurrency::task<void> WriteDataAsync(
00040         _In_ Platform::String^ filename,
00041         _In_ const Platform::Array<byte>^ fileData
00042         );
00043 };
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::FilePickerContracts::sealed Member List

This is the complete list of members for SDKSample::FilePickerContracts::sealed, including all inherited members.
__pad0__ | SDKSample::FilePickerContracts::sealed | [private]
Activate(Windows::ApplicationModel::Activation::CachedFileUpdaterActivatedEventArgs^e) | SDKSample::FilePickerContracts::sealed |
Activate(Windows::ApplicationModel::Activation::FileOpenPickerActivatedEventArgs^e) | SDKSample::FilePickerContracts::sealed |
Activate(Windows::ApplicationModel::Activation::FileSavePickerActivatedEventArgs^e) | SDKSample::FilePickerContracts::sealed |
AddFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
AddLocalFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
AddURLFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
autoSizeInputSectionWhenSnapped | SDKSample::FilePickerContracts::sealed | [private]
CachedFileUpdater_Local() | SDKSample::FilePickerContracts::sealed |
CachedFileUpdater_Remote() | SDKSample::FilePickerContracts::sealed |
CachedFileUpdaterPage() | SDKSample::FilePickerContracts::sealed |
CachedFileUpdaterPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [protected]
cachedFileUpdaterUI | SDKSample::FilePickerContracts::sealed | [private]
fileID | SDKSample::FilePickerContracts::sealed | [private]
FileIsCurrentButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
FileOpenPicker_PickAppFile() | SDKSample::FilePickerContracts::sealed |
FileOpenPicker_PickCachedFile() | SDKSample::FilePickerContracts::sealed |
FileOpenPicker_PickURLFile() | SDKSample::FilePickerContracts::sealed |
FileOpenPickerPage() | SDKSample::FilePickerContracts::sealed |
FileOpenPickerPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [protected]
fileOpenPickerUI | SDKSample::FilePickerContracts::sealed | [protected]
FileSavePicker_FailToSave() | SDKSample::FilePickerContracts::sealed |
FileSavePicker_SaveToAppStorage() | SDKSample::FilePickerContracts::sealed |
FileSavePicker_SaveToCachedFile() | SDKSample::FilePickerContracts::sealed |
FileSavePickerPage() | SDKSample::FilePickerContracts::sealed |
FileSavePickerPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [protected]
fileSavePickerUI | SDKSample::FilePickerContracts::sealed | [protected]
fileUpdateRequest | SDKSample::FilePickerContracts::sealed | [private]
fileUpdateRequestDeferral | SDKSample::FilePickerContracts::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
HiddenFrame | SDKSample::FilePickerContracts::sealed | [private]
InvalidateSize() | SDKSample::FilePickerContracts::sealed | [private]
InvalidateSize() | SDKSample::FilePickerContracts::sealed | [private]
InvalidateSize() | SDKSample::FilePickerContracts::sealed | [private]
InvalidateViewState() | SDKSample::FilePickerContracts::sealed | [private]
InvalidateViewState() | SDKSample::FilePickerContracts::sealed | [private]
InvalidateViewState() | SDKSample::FilePickerContracts::sealed | [private]
LoadScenario(Platform::String^scenarioName) | SDKSample::FilePickerContracts::sealed |
LoadScenario(Platform::String^scenarioName) | SDKSample::FilePickerContracts::sealed |
LoadScenario(Platform::String^scenarioName) | SDKSample::FilePickerContracts::sealed |
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
localScenariosInner | SDKSample::FilePickerContracts::sealed | [private, static]
MainPage_CachedFile() | SDKSample::FilePickerContracts::sealed |
MainPage_PickFile() | SDKSample::FilePickerContracts::sealed |
MainPage_SaveFile() | SDKSample::FilePickerContracts::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | SDKSample::FilePickerContracts::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | SDKSample::FilePickerContracts::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | SDKSample::FilePickerContracts::sealed |
OnFileRemoved(Windows::Storage::Pickers::Provider::FileOpenPickerUI^sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
OnFileRemoved(Windows::Storage::Pickers::Provider::FileOpenPickerUI^sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
OnFileRemoved(Windows::Storage::Pickers::Provider::FileOpenPickerUI^sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
OnFileUpdateRequested(Windows::Storage::Provider::CachedFileUpdaterUI^sender, Windows::Storage::Provider::FileUpdateRequestedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
OnTargetFileRequested(Windows::Storage::Pickers::Provider::FileSavePickerUI^sender, Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
OnTargetFileRequested(Windows::Storage::Pickers::Provider::FileSavePickerUI^sender, Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
OnTargetFileRequested(Windows::Storage::Pickers::Provider::FileSavePickerUI^sender, Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
OnUIRequested(Windows::Storage::Provider::CachedFileUpdaterUI^sender, Platform::Object^e) | SDKSample::FilePickerContracts::sealed | [private]
OutputFileAsync(Windows::Storage::StorageFile^file) | SDKSample::FilePickerContracts::sealed | [private]
OutputFileAsync(Windows::Storage::StorageFile^file) | SDKSample::FilePickerContracts::sealed | [private]
OverwriteButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
PageResized | SDKSample::FilePickerContracts::sealed |
PickFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
PopulateScenarios() | SDKSample::FilePickerContracts::sealed | [private]
PopulateScenarios() | SDKSample::FilePickerContracts::sealed | [private]
PopulateScenarios() | SDKSample::FilePickerContracts::sealed | [private]
ProvideUpdatedVersionButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
remoteScenariosInner | SDKSample::FilePickerContracts::sealed | [private, static]
RemoveFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
RemoveLocalFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
RemoveURLFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
RenameButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
ResetScenarioOutput(Windows::UI::Xaml::Controls::TextBlock^textblock) | SDKSample::FilePickerContracts::sealed |
ResetScenarioOutput(Windows::UI::Xaml::Controls::TextBlock^textblock) | SDKSample::FilePickerContracts::sealed |
ResetScenarioOutput(Windows::UI::Xaml::Controls::TextBlock^textblock) | SDKSample::FilePickerContracts::sealed |
SaveFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [private]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::FilePickerContracts::sealed | [protected, virtual]
ScenarioList | SDKSample::FilePickerContracts::sealed | [private]
ScenarioLoaded | SDKSample::FilePickerContracts::sealed |
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [protected]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [protected]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::FilePickerContracts::sealed | [protected]
scenariosInner | SDKSample::FilePickerContracts::sealed | [private, static]
token | SDKSample::FilePickerContracts::sealed | [private]
UpdateButtonState(bool fileInBasket) | SDKSample::FilePickerContracts::sealed | [private]
UpdateButtonState(bool fileInBasket) | SDKSample::FilePickerContracts::sealed | [private]
UpdateButtonState(bool fileInBasket) | SDKSample::FilePickerContracts::sealed | [private]
UpdateUI(Windows::Storage::Provider::UIStatus uiStatus) | SDKSample::FilePickerContracts::sealed | [private]
UpdateUI(Windows::Storage::Provider::UIStatus uiStatus) | SDKSample::FilePickerContracts::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/common/suspensionmanager.h Source File

  • Calendar details and math
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicShapes.cpp Source File

  • Direct3D HLSL fractal generator

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/pch.cpp Source File

  • XAML Popup

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/common/suspensionmanager.cpp Source File

  • Trial app and in-app purchase
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput1.xaml.h Source File

  • Print

ScenarioOutput1.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.h
00010 // Declaration of the Scenario1Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput1.g.h"
00017 #include "MainPage.xaml.h"
00018
00019 namespace PrintSample
00020 {
00021     public ref class ScenarioOutput1 sealed
00022     {
00023     public:
00024         ScenarioOutput1();
00025     private:
00026         ~ScenarioOutput1();
00027     };
00028 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/App.xaml.h Source File

  • XAML WebView control

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::OrientationSensorCPP::sealed Member List

This is the complete list of members for SDKSample::OrientationSensorCPP::sealed, including all inherited members.
desiredReportInterval | SDKSample::OrientationSensorCPP::sealed | [private]
dispatcher | SDKSample::OrientationSensorCPP::sealed | [private]
dispatcherTimer | SDKSample::OrientationSensorCPP::sealed | [private]
DisplayCurrentReading(Platform::Object^sender, Platform::Object^e) | SDKSample::OrientationSensorCPP::sealed | [private]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::OrientationSensorCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::OrientationSensorCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::OrientationSensorCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::OrientationSensorCPP::sealed | [protected, virtual]
ReadingChanged(Windows::Devices::Sensors::OrientationSensor^sender, Windows::Devices::Sensors::OrientationSensorReadingChangedEventArgs^e) | SDKSample::OrientationSensorCPP::sealed | [private]
readingToken | SDKSample::OrientationSensorCPP::sealed | [private]
rootPage | SDKSample::OrientationSensorCPP::sealed | [private]
Scenario1() | SDKSample::OrientationSensorCPP::sealed |
Scenario2() | SDKSample::OrientationSensorCPP::sealed |
ScenarioDisable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::OrientationSensorCPP::sealed | [private]
ScenarioDisable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::OrientationSensorCPP::sealed | [private]
ScenarioEnable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::OrientationSensorCPP::sealed | [private]
ScenarioEnable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::OrientationSensorCPP::sealed | [private]
sensor | SDKSample::OrientationSensorCPP::sealed | [private]
VisibilityChanged(Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e) | SDKSample::OrientationSensorCPP::sealed | [private]
VisibilityChanged(Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e) | SDKSample::OrientationSensorCPP::sealed | [private]
visibilityToken | SDKSample::OrientationSensorCPP::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/Scenario2.xaml.cpp Source File

  • Context menu

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::ContextMenu;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::ApplicationModel::DataTransfer;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::UI::Popups;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Media;
00029 using namespace Windows::UI::Xaml::Navigation;
00030
00031 Scenario2::Scenario2()
00032 {
00033     InitializeComponent();
00034     rootPage = MainPage::Current;
00035     ReadOnlyTextBox->ContextMenuOpening += ref new ContextMenuOpeningEventHandler(this, &Scenario2::ReadOnlyTextBox_ContextMenuOpening);
00036 }
00037
00038 // returns a rect for selected text in a single line.
00039 // if no text is selected, returns caret location
00040 // textbox should not be empty
00041 Rect Scenario2::GetTextboxSelectionRect(TextBox^ textbox)
00042 {
00043     Rect rectFirst, rectLast;
00044     if (textbox->SelectionStart == textbox->Text->Length())
00045     {
00046         rectFirst = textbox->GetRectFromCharacterIndex(textbox->SelectionStart - 1, true);
00047     }
00048     else
00049     {
00050         rectFirst = textbox->GetRectFromCharacterIndex(textbox->SelectionStart, false);
00051     }
00052
00053     const int lastIndex = textbox->SelectionStart + textbox->SelectionLength;
00054     if (lastIndex == textbox->Text->Length())
00055     {
00056         rectLast = textbox->GetRectFromCharacterIndex(lastIndex - 1, true);
00057     }
00058     else
00059     {
00060         rectLast = textbox->GetRectFromCharacterIndex(lastIndex, false);
00061     }
00062
00063     GeneralTransform^ buttonTransform = textbox->TransformToVisual(nullptr);
00064     const Point pointOrig(0, 0);
00065     const Point pointTransformed = buttonTransform->TransformPoint(pointOrig);
00066
00067     // Make sure that we return a valid rect if selection is on multiple lines
00068     // and end of the selection is to the left of the start of the selection.
00069     float x, y, dx, dy;
00070     y = pointTransformed.Y + rectFirst.Top;
00071     dy = rectLast.Bottom - rectFirst.Top;
00072     if (rectLast.Right > rectFirst.Left)
00073     {
00074         x = pointTransformed.X + rectFirst.Left;
00075         dx = rectLast.Right - rectFirst.Left;
00076     }
00077     else
00078     {
00079         x = pointTransformed.X + rectLast.Right;
00080         dx = rectFirst.Left - rectLast.Right;
00081     }
00082
00083     return Rect(x, y, dx, dy);
00084 }
00085
00086 void Scenario2::ReadOnlyTextBox_ContextMenuOpening(Object^ sender, ContextMenuEventArgs^ e)
00087 {
00088     e->Handled = true;
00089     TextBox^ textbox = safe_cast<TextBox^>(sender);
00090
00091     if (textbox->SelectionLength > 0)
00092     {
00093         // Create a menu and add commands specifying an id value for each instead of a delegate.
00094         auto menu = ref new PopupMenu();
00095
00096         menu->Commands->Append(ref new UICommand("Copy",      nullptr, PropertyValue::CreateInt32(1)));
00097         menu->Commands->Append(ref new UICommandSeparator());
00098         menu->Commands->Append(ref new UICommand("Highlight", nullptr, PropertyValue::CreateInt32(2)));
00099         menu->Commands->Append(ref new UICommand("Look up",   nullptr, PropertyValue::CreateInt32(3)));
00100
00101         // We don't want to obscure content, so pass in a rectangle representing the selection area.
00102         // NOTE: this code only handles textboxes with a single line. If a textbox has multiple lines,
00103         //       then the context menu should be placed at cursor/pointer location by convention.
00104         Rect rectContent = GetTextboxSelectionRect(textbox);
00105         String^ selectedText = textbox->SelectedText;
00106         create_task(menu->ShowForSelectionAsync(rectContent)).then([this, selectedText](IUICommand^ command)
00107         {
00108             if (command != nullptr)
00109             {
00110                 int const id = safe_cast<IBox<int>^>(command->Id)->Value;
00111                 switch (id)
00112                 {
00113                 case 1:
00114                     {
00115                         auto dataPackage = ref new DataPackage();
00116                         dataPackage->SetText(selectedText);
00117                         Clipboard::SetContent(dataPackage);
00118                         OutputTextBlock->Text = "'" + command->Label + "'(" + id.ToString() + ")" + " selected; '" + selectedText + "' copied to clipboard";
00119                     }
00120                     break;
00121
00122                 case 2:
00123                     OutputTextBlock->Text = "'" + command->Label + "'(" + id.ToString() + ")" + " selected";
00124                     break;
00125
00126                 case 3:
00127                     OutputTextBlock->Text = "'" + command->Label + "'(" + id.ToString() + ")" + " selected";
00128                     break;
00129                 }
00130             }
00131             else
00132             {
00133                 OutputTextBlock->Text = "Context menu dismissed";
00134             }
00135         });
00136         OutputTextBlock->Text = "Context menu shown";
00137     }
00138     else
00139     {
00140         OutputTextBlock->Text = "Context menu not shown because there is no text selected";
00141     }
00142 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ViewModelLocator.h Source File

  • Hilo C++
  • Hilo

ViewModelLocator.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "MainHubViewModel.h" // Required by generated header
00010 #include "ImageBrowserViewModel.h" // Required by generated header
00011 #include "ImageViewModel.h" // Required by generated header
00012 #include "CropImageViewModel.h" // Required by generated header
00013 #include "RotateImageViewModel.h" // Required by generated header
00014 #include "CartoonizeImageViewModel.h" // Required by generated header
00015 #include "HubPhotoGroup.h" // Required by generated header
00016 #include "Photo.h" // Required by generated header
00017 #include "MonthGroup.h" // Required by generated header
00018 #include "YearGroup.h" // Required by generated header
00019 #include "MonthBlock.h" // Required by generated header
00020
00021 namespace Hilo
00022 {
00023     class ExceptionPolicy;
00024     class Repository;
00025
00026     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how the ViewModelLocator
00027     // connects views (pages) with their corresponding view models (presentation logic).
00028
00029     // The ViewModelLocator class gives pages access to the app's presentation logic
00030     // following the Model-View-ViewModel (MVVM) pattern.
00031     [Windows::UI::Xaml::Data::Bindable]
00032     [Windows::Foundation::Metadata::WebHostHidden]
00033     public ref class ViewModelLocator sealed
00034     {
00035     public:
00036         ViewModelLocator();
00037
00038         property ImageBrowserViewModel^ ImageBrowserVM { ImageBrowserViewModel^ get(); }
00039         property MainHubViewModel^ MainHubVM { MainHubViewModel^ get(); }
00040         property ImageViewModel^ ImageVM { ImageViewModel^ get(); }
00041         property CropImageViewModel^ CropImageVM { CropImageViewModel^ get(); }
00042         property RotateImageViewModel^ RotateImageVM { RotateImageViewModel^ get(); }
00043         property CartoonizeImageViewModel^ CartoonizeImageVM { CartoonizeImageViewModel^ get(); }
00044
00045     private:
00046         ImageBrowserViewModel^ m_imageBrowswerViewModel;
00047         std::shared_ptr<ExceptionPolicy> m_exceptionPolicy;
00048         std::shared_ptr<Repository> m_repository;
00049     };
00050 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/BasicCapture.xaml.cpp Source File

  • Media capture using capture device

BasicCapture.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // BasicCapture.xaml.cpp
00013 // Implementation of the BasicCapture class
00014 //
00015
00016 #include "pch.h"
00017 #include "BasicCapture.xaml.h"
00018 #include "ppl.h"
00019
00020 using namespace Windows::System;
00021 using namespace Windows::Foundation;
00022 using namespace Platform;
00023 using namespace Windows::UI;
00024 using namespace Windows::UI::Core;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028 using namespace Windows::UI::Xaml::Data;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::Storage;
00031 using namespace Windows::Media::MediaProperties;
00032 using namespace Windows::Storage::Streams;
00033 using namespace Windows::System;
00034 using namespace Windows::UI::Xaml::Media::Imaging;
00035
00036 using namespace SDKSample::MediaCapture;
00037 using namespace concurrency;
00038
00039
00040 BasicCapture::BasicCapture()
00041 {
00042     InitializeComponent();
00043     ScenarioInit();
00044 }
00045
00046 /// <summary>
00047 /// Invoked when this page is about to be displayed in a Frame.
00048 /// </summary>
00049 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00050 /// property is typically used to configure the page.</param>
00051 void BasicCapture::OnNavigatedTo(NavigationEventArgs^ e)
00052 {
00053     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00054     // as NotifyUser()
00055     rootPage = MainPage::Current;
00056     m_eventRegistrationToken = Windows::Media::MediaControl::SoundLevelChanged += ref new EventHandler<Object^>(this, &BasicCapture::SoundLevelChanged);
00057 }
00058
00059 void BasicCapture::OnNavigatedFrom(NavigationEventArgs^ e)
00060 {
00061     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00062     // as NotifyUser()
00063
00064     Windows::Media::MediaControl::SoundLevelChanged -= m_eventRegistrationToken;
00065     m_currentScenarioLoaded = false;
00066 }
00067
00068
00069 void  BasicCapture::ScenarioInit()
00070 {
00071     try
00072     {
00073         btnStartDevice1->IsEnabled = true;
00074         btnStartPreview1->IsEnabled = false;
00075         btnStartStopRecord1->IsEnabled = false;
00076         m_bRecording = false;
00077         m_bPreviewing = false;
00078         btnStartStopRecord1->Content = "StartRecord";
00079         btnTakePhoto1->IsEnabled = false;
00080         previewElement1->Source = nullptr;
00081         playbackElement1->Source = nullptr;
00082         imageElement1->Source= nullptr;
00083         sldBrightness->IsEnabled = false;
00084         sldContrast->IsEnabled = false;
00085         m_bSuspended = false;
00086         previewCanvas1->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00087
00088     }
00089     catch (Exception ^e)
00090     {
00091         ShowExceptionMessage(e);
00092     }
00093
00094 }
00095
00096 void BasicCapture::ScenarioReset()
00097 {
00098     previewCanvas1->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00099     ScenarioInit();
00100 }
00101
00102 void BasicCapture::SoundLevelChanged(Object^ sender, Object^ e)
00103 {
00104     create_task(Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::High, ref new Windows::UI::Core::DispatchedHandler([this]()
00105     {
00106         if(Windows::Media::MediaControl::SoundLevel != Windows::Media::SoundLevel::Muted)
00107         {
00108             ScenarioReset();
00109         }
00110         else
00111         {
00112             if (m_bRecording)
00113             {
00114                 ShowStatusMessage("Stopping Record on invisibility");
00115
00116                 create_task(m_mediaCaptureMgr->StopRecordAsync()).then([this](task<void> recordTask)
00117                 {
00118                     m_bRecording = false;
00119                 });
00120             }
00121             if (m_bPreviewing)
00122             {
00123                 ShowStatusMessage("Stopping Preview on invisibility");
00124
00125                 create_task(m_mediaCaptureMgr->StopPreviewAsync()).then([this](task<void> previewTask)
00126                 {
00127                     try
00128                     {
00129                         previewTask.get();
00130                         m_bPreviewing = false;
00131                     }
00132                     catch (Exception ^e)
00133                     {
00134                         ShowExceptionMessage(e);
00135                     }
00136                 });
00137             }
00138         }
00139     })));
00140 }
00141
00142 void BasicCapture::RecordLimitationExceeded(Windows::Media::Capture::MediaCapture ^currentCaptureObject)
00143 {
00144     try
00145     {
00146         if (m_bRecording)
00147         {
00148             create_task(Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::High, ref new Windows::UI::Core::DispatchedHandler([this](){
00149                 try
00150                 {
00151                     ShowStatusMessage("Stopping Record on exceeding max record duration");
00152                     EnableButton(false, "StartStopRecord");
00153                     create_task(m_mediaCaptureMgr->StopRecordAsync()).then([this](task<void> recordTask)
00154                     {
00155                         try
00156                         {
00157                             recordTask.get();
00158                             m_bRecording = false;
00159                             SwitchRecordButtonContent();
00160                             EnableButton(true, "StartStopRecord");
00161                             ShowStatusMessage("Stopped record on exceeding max record duration:" + m_recordStorageFile->Path);
00162                         }
00163                         catch (Exception ^e)
00164                         {
00165                             ShowExceptionMessage(e);
00166                             m_bRecording = false;
00167                             SwitchRecordButtonContent();
00168                             EnableButton(true, "StartStopRecord");
00169                         }
00170                     });
00171
00172                 }
00173                 catch (Exception ^e)
00174                 {
00175                     m_bRecording = false;
00176                     SwitchRecordButtonContent();
00177                     EnableButton(true, "StartStopRecord");
00178                     ShowExceptionMessage(e);
00179                 }
00180
00181             })));
00182         }
00183     }
00184     catch (Exception ^e)
00185     {
00186         m_bRecording = false;
00187         SwitchRecordButtonContent();
00188         EnableButton(true, "StartStopRecord");
00189         ShowExceptionMessage(e);
00190     }
00191 }
00192
00193 void BasicCapture::Failed(Windows::Media::Capture::MediaCapture ^currentCaptureObject, Windows::Media::Capture::MediaCaptureFailedEventArgs^ currentFailure)
00194 {
00195     String ^message = "Fatal error: " + currentFailure->Message;
00196     create_task(Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::High,
00197         ref new Windows::UI::Core::DispatchedHandler([this, message]()
00198     {
00199         ShowStatusMessage(message);
00200     })));
00201 }
00202
00203 void BasicCapture::btnStartDevice_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00204 {
00205     try
00206     {
00207         EnableButton(false, "StartDevice");
00208         ShowStatusMessage("Starting device");
00209         auto mediaCapture = ref new Windows::Media::Capture::MediaCapture();
00210         m_mediaCaptureMgr = mediaCapture;
00211         create_task(mediaCapture->InitializeAsync()).then([this](task<void> initTask)
00212         {
00213             try
00214             {
00215                 initTask.get();
00216
00217                 auto mediaCapture = m_mediaCaptureMgr.Get();
00218                 EnableButton(true, "StartPreview");
00219                 EnableButton(true, "StartStopRecord");
00220                 EnableButton(true, "TakePhoto");
00221                 ShowStatusMessage("Device initialized successful");
00222                 mediaCapture->RecordLimitationExceeded += ref new Windows::Media::Capture::RecordLimitationExceededEventHandler(this, &BasicCapture::RecordLimitationExceeded);
00223                 mediaCapture->Failed += ref new Windows::Media::Capture::MediaCaptureFailedEventHandler(this, &BasicCapture::Failed);
00224             }
00225             catch (Exception ^ e)
00226             {
00227                 ShowExceptionMessage(e);
00228             }
00229         }
00230         );
00231     }
00232     catch (Platform::Exception^ e)
00233     {
00234         ShowExceptionMessage(e);
00235     }
00236 }
00237
00238 void BasicCapture::btnStartPreview_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00239 {
00240     m_bPreviewing = false;
00241     try
00242     {
00243         ShowStatusMessage("Starting preview");
00244         EnableButton(false, "StartPreview");
00245         auto mediaCapture = m_mediaCaptureMgr.Get();
00246
00247         previewCanvas1->Visibility = Windows::UI::Xaml::Visibility::Visible;
00248         previewElement1->Source = mediaCapture;
00249         create_task(mediaCapture->StartPreviewAsync()).then([this](task<void> previewTask)
00250         {
00251             try
00252             {
00253                 previewTask.get();
00254                 auto mediaCapture = m_mediaCaptureMgr.Get();
00255                 m_bPreviewing = true;
00256                 ShowStatusMessage("Start preview successful");
00257                 if(mediaCapture->VideoDeviceController->Brightness)
00258                 {
00259                     SetupVideoDeviceControl(mediaCapture->VideoDeviceController->Brightness, sldBrightness);
00260                 }
00261                 if(mediaCapture->VideoDeviceController->Contrast)
00262                 {
00263                     SetupVideoDeviceControl(mediaCapture->VideoDeviceController->Contrast, sldContrast);
00264                 }
00265
00266             }catch (Exception ^e)
00267             {
00268                 ShowExceptionMessage(e);
00269             }
00270         });
00271     }
00272     catch (Platform::Exception^ e)
00273     {
00274         m_bPreviewing = false;
00275         previewElement1->Source = nullptr;
00276         EnableButton(true, "StartPreview");
00277         ShowExceptionMessage(e);
00278     }
00279 }
00280
00281 void BasicCapture::btnTakePhoto_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00282 {
00283     try
00284     {
00285         ShowStatusMessage("Taking photo");
00286         EnableButton(false, "TakePhoto");
00287
00288         task<StorageFile^>(KnownFolders::PicturesLibrary->CreateFileAsync(PHOTO_FILE_NAME, Windows::Storage::CreationCollisionOption::GenerateUniqueName)).then([this](task<StorageFile^> getFileTask)
00289         {
00290             try
00291             {
00292                 this->m_photoStorageFile = getFileTask.get();
00293                 ShowStatusMessage("Create photo file successful");
00294                 ImageEncodingProperties^ imageProperties = ImageEncodingProperties::CreateJpeg();
00295
00296                 create_task(m_mediaCaptureMgr->CapturePhotoToStorageFileAsync(imageProperties, this->m_photoStorageFile)).then([this](task<void> photoTask)
00297                 {
00298                     try
00299                     {
00300                         photoTask.get();
00301                         EnableButton(true, "TakePhoto");
00302                         ShowStatusMessage("Photo taken");
00303
00304                         task<IRandomAccessStream^>(this->m_photoStorageFile->OpenAsync(FileAccessMode::Read)).then([this](task<IRandomAccessStream^> getStreamTask)
00305                         {
00306                             try
00307                             {
00308                                 auto photoStream = getStreamTask.get();
00309                                 ShowStatusMessage("File open successful");
00310                                 auto bmpimg = ref new BitmapImage();
00311
00312                                 bmpimg->SetSource(photoStream);
00313                                 imageElement1->Source = bmpimg;
00314                             }
00315                             catch (Exception^ e)
00316                             {
00317                                 ShowExceptionMessage(e);
00318                                 EnableButton(true, "TakePhoto");
00319                             }
00320                         });
00321                     }
00322                     catch (Platform::Exception ^ e)
00323                     {
00324                         ShowExceptionMessage(e);
00325                         EnableButton(true, "TakePhoto");
00326                     }
00327                 });
00328             }
00329             catch (Exception^ e)
00330             {
00331                 ShowExceptionMessage(e);
00332                 EnableButton(true, "TakePhoto");
00333             }
00334         });
00335     }
00336     catch (Platform::Exception^ e)
00337     {
00338         ShowExceptionMessage(e);
00339         EnableButton(true, "TakePhoto");
00340     }
00341 }
00342
00343 void BasicCapture::btnStartStopRecord_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00344 {
00345     try
00346     {
00347         String ^fileName;
00348         EnableButton(false, "StartStopRecord");
00349
00350         if (!m_bRecording)
00351         {
00352             ShowStatusMessage("Starting Record");
00353
00354             fileName = VIDEO_FILE_NAME;
00355
00356             task<StorageFile^>(KnownFolders::VideosLibrary->CreateFileAsync(fileName,Windows::Storage::CreationCollisionOption::GenerateUniqueName )).then([this](task<StorageFile^> fileTask)
00357             {
00358                 try
00359                 {
00360                     this->m_recordStorageFile = fileTask.get();
00361                     ShowStatusMessage("Create record file successful");
00362
00363                     MediaEncodingProfile^ recordProfile= nullptr;
00364                     recordProfile = MediaEncodingProfile::CreateMp4(Windows::Media::MediaProperties::VideoEncodingQuality::Auto);
00365
00366                     create_task(m_mediaCaptureMgr->StartRecordToStorageFileAsync(recordProfile, this->m_recordStorageFile)).then([this](task<void> recordTask)
00367                     {
00368                         try
00369                         {
00370                             recordTask.get();
00371                             m_bRecording = true;
00372                             SwitchRecordButtonContent();
00373                             EnableButton(true, "StartStopRecord");
00374
00375                             ShowStatusMessage("Start Record successful");
00376                         }
00377                         catch (Exception ^e)
00378                         {
00379                             ShowExceptionMessage(e);
00380                         }
00381                     });
00382                 }
00383                 catch (Exception ^e)
00384                 {
00385                     m_bRecording = false;
00386                     SwitchRecordButtonContent();
00387                     EnableButton(true, "StartStopRecord");
00388                     ShowExceptionMessage(e);
00389                 }
00390             }
00391             );
00392         }
00393         else
00394         {
00395             ShowStatusMessage("Stopping Record");
00396
00397             create_task(m_mediaCaptureMgr->StopRecordAsync()).then([this](task<void> recordTask)
00398             {
00399                 try
00400                 {
00401                     recordTask.get();
00402                     m_bRecording = false;
00403                     EnableButton(true, "StartStopRecord");
00404                     SwitchRecordButtonContent();
00405
00406                     ShowStatusMessage("Stop record successful");
00407                     if (!m_bSuspended)
00408                     {
00409                         task<IRandomAccessStream^>(this->m_recordStorageFile->OpenAsync(FileAccessMode::Read)).then([this](task<IRandomAccessStream^> streamTask)
00410                         {
00411                             try
00412                             {
00413                                 auto stream = streamTask.get();
00414                                 ShowStatusMessage("Record file opened");
00415                                 ShowStatusMessage(this->m_recordStorageFile->Path);
00416                                 playbackElement1->AutoPlay = true;
00417                                 playbackElement1->SetSource(stream, this->m_recordStorageFile->FileType);
00418                                 playbackElement1->Play();
00419                             }
00420                             catch (Exception ^e)
00421                             {
00422                                 ShowExceptionMessage(e);
00423                                 m_bRecording = false;
00424                                 EnableButton(true, "StartStopRecord");
00425                                 SwitchRecordButtonContent();
00426                             }
00427                         });
00428                     }
00429                 }
00430                 catch (Exception ^e)
00431                 {
00432                     m_bRecording = false;
00433                     EnableButton(true, "StartStopRecord");
00434                     SwitchRecordButtonContent();
00435                     ShowExceptionMessage(e);
00436                 }
00437             });
00438         }
00439     }
00440     catch (Platform::Exception^ e)
00441     {
00442         EnableButton(true, "StartStopRecord");
00443         ShowExceptionMessage(e);
00444         SwitchRecordButtonContent();
00445         m_bRecording = false;
00446     }
00447 }
00448
00449 void BasicCapture::SetupVideoDeviceControl(Windows::Media::Devices::MediaDeviceControl^ videoDeviceControl, Slider^ slider)
00450 {
00451     try
00452     {
00453         if ((videoDeviceControl->Capabilities)->Supported)
00454         {
00455             slider->IsEnabled = true;
00456             slider->Maximum = videoDeviceControl->Capabilities->Max;
00457             slider->Minimum = videoDeviceControl->Capabilities->Min;
00458             slider->StepFrequency = videoDeviceControl->Capabilities->Step;
00459             double controlValue = 0;
00460             if (videoDeviceControl->TryGetValue(&controlValue))
00461             {
00462                 slider->Value = controlValue;
00463             }
00464         }
00465         else
00466         {
00467             slider->IsEnabled = false;
00468         }
00469     }
00470     catch (Platform::Exception^ e)
00471     {
00472         ShowExceptionMessage(e);
00473     }
00474 }
00475
00476 // VideoDeviceControllers
00477 void BasicCapture::sldBrightness_ValueChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e)
00478 {
00479     bool succeeded = m_mediaCaptureMgr->VideoDeviceController->Brightness->TrySetValue(sldBrightness->Value);
00480     if (!succeeded)
00481     {
00482         ShowStatusMessage("Set Brightness failed");
00483     }
00484 }
00485
00486 void BasicCapture::sldContrast_ValueChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs ^e)
00487 {
00488     bool succeeded = m_mediaCaptureMgr->VideoDeviceController->Contrast->TrySetValue(sldContrast->Value);
00489     if (!succeeded)
00490     {
00491         ShowStatusMessage("Set Contrast failed");
00492     }
00493 }
00494
00495 void BasicCapture::ShowStatusMessage(Platform::String^ text)
00496 {
00497     rootPage->NotifyUser(text, NotifyType::StatusMessage);
00498 }
00499
00500 void BasicCapture::ShowExceptionMessage(Platform::Exception^ ex)
00501 {
00502     rootPage->NotifyUser(ex->Message, NotifyType::ErrorMessage);
00503 }
00504
00505 void BasicCapture::SwitchRecordButtonContent()
00506 {
00507     if (m_bRecording)
00508     {
00509         btnStartStopRecord1->Content="StopRecord";
00510     }
00511     else
00512     {
00513         btnStartStopRecord1->Content="StartRecord";
00514     }
00515 }
00516 void BasicCapture::EnableButton(bool enabled, String^ name)
00517 {
00518     if (name->Equals("StartDevice"))
00519     {
00520         btnStartDevice1->IsEnabled = enabled;
00521     }
00522     else if (name->Equals("StartPreview"))
00523     {
00524         btnStartPreview1->IsEnabled = enabled;
00525     }
00526     else if (name->Equals("StartStopRecord"))
00527     {
00528         btnStartStopRecord1->IsEnabled = enabled;
00529     }
00530     else if (name->Equals("TakePhoto"))
00531     {
00532         btnTakePhoto1->IsEnabled = enabled;
00533     }
00534 }
00535
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/common/LayoutAwarePage.h Source File

  • XAML two-dimensional transforms
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/FlowSource.h Source File

  • DirectWrite vertical text

FlowSource.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // Contents:    Tells a flow layout where text is allowed to flow.
00009
00010 #pragma once
00011
00012 enum ReadingDirection;
00013
00014 class DECLSPEC_UUID("84600D90-8F09-480f-9275-D71125FCD0C3") FlowLayoutSource:
00015     public ComBase<QiListSelf<FlowLayoutSource, QiList<IUnknown>>>
00016 {
00017 public:
00018     struct RectF
00019     {
00020         float left;
00021         float top;
00022         float right;
00023         float bottom;
00024     };
00025
00026     FlowLayoutSource():
00027         m_width(300),
00028         m_height(300),
00029         m_currentU(),
00030         m_currentV()
00031     {
00032         Reset();
00033     }
00034
00035     void Reset();
00036     void SetSize(float width, float height);
00037     bool GetNextRect(float fontHeight, ReadingDirection readingDirection, _Out_ RectF* nextRect);
00038
00039 protected:
00040     float m_width;
00041     float m_height;
00042     float m_currentU;
00043     float m_currentV;
00044 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/QueryChange.h Source File

  • Hilo C++
  • Hilo

QueryChange.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     // The QueryChange class subscribes to the ContentsChanged method of Windows::Storage::Search. It notifies Hilo when a
00012     // change in the file system has occurred that would alter the results of the given file query.
00013     ref class QueryChange sealed
00014     {
00015     internal:
00016         QueryChange(Windows::Storage::Search::IStorageQueryResultBase^ query, std::function<void()> callback) : m_query(query), m_callback(callback)
00017         {
00018             m_watchToken = m_query->ContentsChanged::add(ref new Windows::Foundation::TypedEventHandler<Windows::Storage::Search::IStorageQueryResultBase^, Object^>(this, &QueryChange::OnFileQueryContentsChanged));
00019         }
00020
00021     public:
00022         virtual ~QueryChange()
00023         {
00024             m_query->ContentsChanged::remove(m_watchToken);
00025         }
00026
00027     private:
00028         Windows::Storage::Search::IStorageQueryResultBase^ m_query;
00029         std::function<void()> m_callback;
00030         Windows::Foundation::EventRegistrationToken m_watchToken;
00031
00032         void OnFileQueryContentsChanged(Windows::Storage::Search::IStorageQueryResultBase^ sender, Platform::Object^ e)
00033         {
00034             // Since OnFileQueryContentsChanged may be called on any thread, we must dispatch the callback to the app's main thread,
00035             // on the assumption that the callback will modify XAML structures.
00036             Windows::UI::Core::CoreWindow^ wnd = Windows::ApplicationModel::Core::CoreApplication::MainView->CoreWindow;
00037             Windows::UI::Core::CoreDispatcher^ dispatcher = wnd->Dispatcher;
00038             dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([this] ()
00039             {
00040                 m_callback();
00041             }));
00042         }
00043     };
00044 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::Common::LayoutAwarePage Member List

This is the complete list of members for Hilo::Common::LayoutAwarePage, including all inherited members.
__pad0__ | Hilo::Common::LayoutAwarePage |
_acceleratorKeyEventToken | Hilo::Common::LayoutAwarePage | [private]
_defaultViewModel | Hilo::Common::LayoutAwarePage | [private]
_layoutAwareControls | Hilo::Common::LayoutAwarePage | [private]
_navigationShortcutsRegistered | Hilo::Common::LayoutAwarePage | [private]
_pageKey | Hilo::Common::LayoutAwarePage | [private]
_pointerPressedEventToken | Hilo::Common::LayoutAwarePage | [private]
_this | Hilo::Common::LayoutAwarePage | [private]
_windowSizeEventToken | Hilo::Common::LayoutAwarePage | [private]
CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^sender, Windows::UI::Core::AcceleratorKeyEventArgs^args) | Hilo::Common::LayoutAwarePage | [private]
CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::PointerEventArgs^args) | Hilo::Common::LayoutAwarePage | [private]
DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState) | Hilo::Common::LayoutAwarePage | [virtual]
GoBack(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | Hilo::Common::LayoutAwarePage | [virtual]
GoForward(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | Hilo::Common::LayoutAwarePage | [virtual]
InvalidateVisualState() | Hilo::Common::LayoutAwarePage |
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) | Hilo::Common::LayoutAwarePage | [virtual]
OnLoaded(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | Hilo::Common::LayoutAwarePage | [private]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | Hilo::Common::LayoutAwarePage | [virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | Hilo::Common::LayoutAwarePage | [virtual]
OnUnloaded(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | Hilo::Common::LayoutAwarePage | [private]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) | Hilo::Common::LayoutAwarePage | [virtual]
StartLayoutUpdates(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | Hilo::Common::LayoutAwarePage |
StopLayoutUpdates(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | Hilo::Common::LayoutAwarePage |
WindowSizeChanged(Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | Hilo::Common::LayoutAwarePage | [private]
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Constants.h Source File

  • XAML AppBar control

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace AppBarControl
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"AppBar control sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/App.xaml.h Source File

  • Inclinometer sensor

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/common/suspensionmanager.h Source File

  • CameraOptionsUI
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/pch.h Source File

  • Globalization preferences

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickAppFile.xaml.h Source File

  • File picker contracts

FileOpenPicker_PickAppFile.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FileOpenPicker_PickAppFile.xaml.h
00013 // Declaration of the FileOpenPicker_PickAppFile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "FileOpenPicker_PickAppFile.g.h"
00020
00021 namespace SDKSample
00022 {
00023     namespace FilePickerContracts
00024     {
00025         /// <summary>
00026         /// An empty page that can be used on its own or navigated to within a Frame.
00027         /// </summary>
00028         [Windows::Foundation::Metadata::WebHostHidden]
00029         public ref class FileOpenPicker_PickAppFile sealed
00030         {
00031         public:
00032             FileOpenPicker_PickAppFile();
00033
00034         protected:
00035             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         internal:
00039             Windows::Storage::Pickers::Provider::FileOpenPickerUI^ fileOpenPickerUI;
00040
00041         private:
00042             Platform::String^ fileID;
00043             Windows::Foundation::EventRegistrationToken token;
00044
00045             void AddLocalFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046             void RemoveLocalFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void OnFileRemoved(Windows::Storage::Pickers::Provider::FileOpenPickerUI^ sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^ e);
00048             void UpdateButtonState(bool fileInBasket);
00049         };
00050     }
00051 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

IndexTriplet Member List

This is the complete list of members for IndexTriplet, including all inherited members.
norm | IndexTriplet
pos | IndexTriplet
tex | IndexTriplet
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

_BAR_GRAPH_STATE Member List

This is the complete list of members for _BAR_GRAPH_STATE, including all inherited members.
Bar1 | _BAR_GRAPH_STATE
Bar2 | _BAR_GRAPH_STATE
Bar3 | _BAR_GRAPH_STATE
Bar4 | _BAR_GRAPH_STATE
Bar5 | _BAR_GRAPH_STATE
Bar6 | _BAR_GRAPH_STATE
Bar7 | _BAR_GRAPH_STATE
Bar8 | _BAR_GRAPH_STATE
BarsAsUChar | _BAR_GRAPH_STATE
Generated on Sat Nov 23 2024 16:09:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario2.xaml.h Source File

  • File and folder thumbnail

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FileThumbnails
00025     {
00026         [Windows::Foundation::Metadata::WebHostHidden]
00027         public ref class Scenario2 sealed
00028         {
00029         public:
00030             Scenario2();
00031
00032         protected:
00033             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00034
00035         private:
00036             MainPage^ rootPage;
00037
00038             void GetThumbnailButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/App.xaml.cpp Source File

  • Globalization preferences

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideImageAndText02 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideImageAndText02, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::TileContent::TileWideImageAndText02 |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextCaption1 | NotificationsExtensions::TileContent::TileWideImageAndText02 |
TextCaption2 | NotificationsExtensions::TileContent::TileWideImageAndText02 |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideImageAndText02() | NotificationsExtensions::TileContent::TileWideImageAndText02 | [inline]
TileWideImageAndText02() | NotificationsExtensions::TileContent::TileWideImageAndText02 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/BasicTimer.cpp Source File

  • XAudio2 audio stream effect

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/SampleOverlay.h Source File

  • Direct3D post-processing effects

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperRenderer.cpp Source File

  • DirectX postcard app

PaperRenderer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "PaperRenderer.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Foundation;
00013 using namespace Windows::UI::Xaml::Input;
00014 using namespace Platform::Collections;
00015
00016 PaperRenderer::PaperRenderer(void) :
00017     m_paperMode(PaperMode::Moving)
00018 {
00019 }
00020
00021 void PaperRenderer::CreateDeviceIndependentResources(
00022     ComPtr<ID2D1Factory1> d2dFactory
00023     )
00024 {
00025     // Save shaerd resource.
00026     m_d2dFactory = d2dFactory;
00027 }
00028
00029 void PaperRenderer::CreateDeviceResources(
00030     ComPtr<ID2D1DeviceContext> d2dContext
00031     )
00032 {
00033     // Save shared resource.
00034     m_d2dContext = d2dContext;
00035
00036     DX::ThrowIfFailed(
00037         m_d2dContext->CreateSolidColorBrush(
00038             D2D1::ColorF(D2D1::ColorF::Black),
00039             &m_blackBrush
00040             )
00041         );
00042
00043     // Create a star-shaped geometry for stamping.
00044
00045     ComPtr<ID2D1PathGeometry> starStampGeometry;
00046     DX::ThrowIfFailed(
00047         m_d2dFactory->CreatePathGeometry(&starStampGeometry)
00048         );
00049
00050     {
00051         UINT points = 5;
00052         float innerRadius = 50;
00053         float outerRadius = 100;
00054
00055         ComPtr<ID2D1GeometrySink> geometrySink;
00056
00057         DX::ThrowIfFailed(
00058             starStampGeometry->Open(&geometrySink)
00059             );
00060
00061         geometrySink->BeginFigure(
00062             D2D1::Point2F(0, -outerRadius),
00063             D2D1_FIGURE_BEGIN_FILLED
00064             );
00065
00066         for (UINT i = 0; i < (2 * points) - 1; ++i)
00067         {
00068             float radius = (i % 2 == 0) ? innerRadius : outerRadius;
00069             float angle = 2 * PI_F * (i + 1) / (2 * points);
00070
00071             geometrySink->AddLine(
00072                 D2D1::Point2F(
00073                     radius * sin(angle),
00074                     -radius * cos(angle)
00075                     )
00076                 );
00077         }
00078
00079         geometrySink->EndFigure(
00080             D2D1_FIGURE_END_CLOSED
00081             );
00082
00083         DX::ThrowIfFailed(geometrySink->Close());
00084     }
00085
00086     m_starStampGeometry = starStampGeometry;
00087 }
00088
00089 void PaperRenderer::CreateWindowSizeDependentResources(float dpi)
00090 {
00091     // Save shared DPI.
00092     m_dpi = dpi;
00093 }
00094
00095 void PaperRenderer::DrawPaper()
00096 {
00097     D2D1_SIZE_F size = m_d2dContext->GetSize();
00098
00099     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00100
00101     for (PaperFragment^ fragment : m_paperFragmentList)
00102     {
00103         fragment->Draw();
00104     }
00105 }
00106
00107 void PaperRenderer::AddPaper()
00108 {
00109     m_paperMode = PaperMode::Moving;
00110
00111     D2D1_SIZE_F size = m_d2dContext->GetSize();
00112
00113     // Create a rectangular geometry for the piece of paper.
00114
00115     ComPtr<ID2D1RectangleGeometry> paperGeometry;
00116
00117     D2D1_RECT_F paperRect = D2D1::RectF(-300, -225, 300, 225);
00118
00119     DX::ThrowIfFailed(
00120         m_d2dFactory->CreateRectangleGeometry(
00121             &paperRect,
00122             &paperGeometry
00123             )
00124         );
00125
00126     // Create a rotated version of the geometry.
00127
00128     ComPtr<ID2D1TransformedGeometry> rotatedPaperGeometry;
00129
00130     D2D_MATRIX_3X2_F translation = D2D1::Matrix3x2F::Translation(
00131         (size.width / 4) + (RandomFloat() * (size.width / 2)),
00132         (size.height / 4) + (RandomFloat() * (size.height / 2))
00133         );
00134
00135     D2D_MATRIX_3X2_F rotation = D2D1::Matrix3x2F::Rotation(
00136         RandomFloat() * 30.0f - 15.0f
00137         );
00138
00139     DX::ThrowIfFailed(
00140         m_d2dFactory->CreateTransformedGeometry(
00141             paperGeometry.Get(),
00142             &(rotation * translation),
00143             &rotatedPaperGeometry
00144             )
00145         );
00146
00147     // Create a new paper fragment from the rotated geometry.
00148
00149     PaperFragment^ paperFragment =
00150         ref new PaperFragment(
00151             m_d2dContext,
00152             rotatedPaperGeometry.Get(),
00153             D2D1::ColorF(
00154                 0.5f + 0.5f*RandomFloat(),
00155                 0.5f + 0.5f*RandomFloat(),
00156                 0.5f + 0.5f*RandomFloat(),
00157                 1.0f
00158                 )
00159             );
00160
00161     paperFragment->SetPosition(D2D1::Point2F(0, 0));
00162
00163     m_paperFragmentList.push_back(paperFragment);
00164 }
00165
00166 void PaperRenderer::RemovePaper()
00167 {
00168     m_paperMode = PaperMode::Deleting;
00169 }
00170
00171 void PaperRenderer::MovePaper()
00172 {
00173     m_paperMode = PaperMode::Moving;
00174 }
00175
00176 void PaperRenderer::StampPaper()
00177 {
00178     m_paperMode = PaperMode::Stamping;
00179 }
00180
00181 void PaperRenderer::Reset()
00182 {
00183     m_paperMode = PaperMode::Moving;
00184     m_paperFragmentList.clear();
00185     m_selectedFragment = nullptr;
00186 }
00187
00188 void PaperRenderer::OnManipulationStarted(ManipulationStartedRoutedEventArgs^ args)
00189 {
00190     D2D1_POINT_2F d2dPosition = D2D1::Point2F(args->Position.X, args->Position.Y);
00191
00192     if (m_paperMode == PaperMode::Moving)
00193     {
00194         PaperFragment^ pressedFragment = HitTestFragmentsWithPosition(d2dPosition);
00195         if (pressedFragment != nullptr)
00196         {
00197             m_selectedFragment = pressedFragment;
00198         }
00199     }
00200 }
00201
00202 void PaperRenderer::OnManipulationCompleted(ManipulationCompletedRoutedEventArgs^ args)
00203 {
00204     m_selectedFragment = nullptr;
00205     OnTapped(args->Position);
00206 }
00207
00208 void PaperRenderer::OnManipulationDelta(ManipulationDeltaRoutedEventArgs^ args)
00209 {
00210     if (m_paperMode == PaperMode::Moving)
00211     {
00212         if (m_selectedFragment != nullptr)
00213         {
00214             D2D1_POINT_2F point = m_selectedFragment->GetPosition();
00215             point.x += args->Delta.Translation.X;
00216             point.y += args->Delta.Translation.Y;
00217             m_selectedFragment->SetPosition(point);
00218         }
00219     }
00220 }
00221
00222 void PaperRenderer::OnTapped(Point position)
00223 {
00224     D2D1_POINT_2F d2dPosition = D2D1::Point2F(position.X, position.Y);
00225
00226     PaperFragment^ tappedFragment = HitTestFragmentsWithPosition(d2dPosition);
00227     if (tappedFragment != nullptr)
00228     {
00229         if (m_paperMode == PaperMode::Deleting)
00230         {
00231             // Delete the tapped fragment.
00232             m_paperFragmentList.remove(tappedFragment);
00233         }
00234         else if (m_paperMode == PaperMode::Stamping)
00235         {
00236             // Delete the tapped fragment, and add the intersection and exclusion
00237             // of the fragment with the stamp geometry.
00238             PaperFragment^ intersectFrag = tappedFragment->GetIntersectionWith(
00239                 d2dPosition,
00240                 m_starStampGeometry.Get()
00241                 );
00242
00243             PaperFragment^ excludeFrag = tappedFragment->GetExclusionWith(
00244                 d2dPosition,
00245                 m_starStampGeometry.Get()
00246                 );
00247
00248             m_paperFragmentList.remove(tappedFragment);
00249             m_paperFragmentList.push_back(intersectFrag);
00250             m_paperFragmentList.push_back(excludeFrag);
00251         }
00252     }
00253 }
00254
00255 PaperFragment^ PaperRenderer::HitTestFragmentsWithPosition(D2D1_POINT_2F position)
00256 {
00257     PaperFragment^ chosenFragment = nullptr;
00258     for (PaperFragment^ fragment : m_paperFragmentList)
00259     {
00260         if (fragment->HitTest(position))
00261         {
00262             chosenFragment = fragment;
00263         }
00264     };
00265     return chosenFragment;
00266 }
00267
00268 float PaperRenderer::RandomFloat()
00269 {
00270     return static_cast<float>(rand()) / static_cast<float>(RAND_MAX);
00271 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/TextFrame.h Source File

  • Direct2D magazine app

TextFrame.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "Element.h"
00011
00012 ref class ::Text;
00013
00014 //  <text-frame> represents the drawing of a text block which may contain multiple paragraphs.
00015 //  It supports margin in order to control alignment of text content inside a container such as
00016 //  a list. It supports leading to better control spacing to the first line and between the lines.
00017 //  Text inside this element is typeset by document-specific font. Document-specific font resides
00018 //  as embedded resource within the document and is only available to that document. DirectWrite
00019 //  fully supports document-specific font through custom font collection loader callback.
00020 //
00021 //  Text frame accepts the following additional markup attributes:
00022 //      font-size = "<float>"
00023 //          Font size. If not specified, the text size follows the 'font-size' attribute of <text> element.
00024 //      color = "#<rgb>"
00025 //          Color in red-green-blue format i.e. the value of "#FF0000" is red
00026 //      opacity = "<0..1>"
00027 //          Opacity value from 0.0 to 1.0 where 0.0 is fully transparent and 1.0 is fully opaque
00028 //      top-margin = "<float>
00029 //          Amount of spacing from the top edge of the element to the top of the text in design unit
00030 //      bottom-margin = "<float>"
00031 //          Amount of spacing from the bottom edge of the element to the bottom of the text in design unit
00032 //      leading = "<float>"
00033 //          Amount of spacing between two adjacent lines
00034 //      baseline = "<float>"
00035 //          Amount of spacing from the top of the text to the top of the first line drawn in design unit
00036 //      text-align = "leading|trailing|center"
00037 //          How text is aligned within the element
00038 //      glow = "<float>"
00039 //          Standard deviation value of the glow effect of the text.
00040 //      glow-color = "#<rgb>"
00041 //          Glow color of the glow effect of the text in color format.
00042 //
00043 ref class TextFrame : public Element
00044 {
00045 internal:
00046     TextFrame();
00047
00048     virtual bool Initialize(
00049         _In_ Document^ document,
00050         _In_ Windows::Data::Xml::Dom::XmlElement^ xmlElement
00051         ) override;
00052
00053     virtual bool BindResource(_In_ Element^ rootElement) override;
00054
00055     virtual void Measure(
00056         _In_ Document^ document,
00057         D2D1_SIZE_F const& parentSize,
00058         _Out_ D2D1_RECT_F* bounds
00059         ) override;
00060
00061     virtual bool PrepareToDraw(
00062         _In_ Document^ document,
00063         D2D1::Matrix3x2F const& transform
00064         ) override;
00065
00066     virtual bool Draw(
00067         _In_ Document^ document,
00068         D2D1::Matrix3x2F const& transform
00069         ) override;
00070
00071     virtual float GetOpacity() override
00072     {
00073         return m_opacity;
00074     }
00075
00076 private:
00077     // Name string of the source text
00078     Platform::String^ m_sourceName;
00079
00080     // Source text of the text frame
00081     ::Text^ m_sourceText;
00082
00083     // Brush to fill the text
00084     Microsoft::WRL::ComPtr<ID2D1Brush> m_brush;
00085
00086     // Direct2D shadow effect for glow
00087     Microsoft::WRL::ComPtr<ID2D1Effect> m_glowEffect;
00088
00089     // Direct2D composite effect to composite text over the glow
00090     Microsoft::WRL::ComPtr<ID2D1Effect> m_compositeEffect;
00091
00092     // Intermediate surface containing the drawing of text content.
00093     // This is only needed when effect is used for the element.
00094     Microsoft::WRL::ComPtr<ID2D1Bitmap1> m_contentBitmap;
00095
00096     // The display size the content caching is for.
00097     D2D1_SIZE_F m_displaySize;
00098
00099     // Top margin of the text
00100     float m_topMargin;
00101
00102     // Bottom margin of the text
00103     float m_bottomMargin;
00104
00105     // Baseline-to-baseline leading between two lines
00106     float m_leading;
00107
00108     // Offset to the baseline of the first line when leading is in use
00109     float m_baseline;
00110
00111     // Text horizontal alignment
00112     DWRITE_TEXT_ALIGNMENT m_textAlign;
00113
00114     // Text color
00115     uint32 m_color;
00116
00117     // Text opacity
00118     float m_opacity;
00119
00120     // Font size
00121     float m_fontSize;
00122 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/MainPage.xaml.h Source File

  • Toast notifications
  • C#,C++

MainPage.xaml.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.h
00010 // Declaration of the MainPage.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "MainPage.g.h"
00017
00018 using namespace Windows::UI::Xaml;
00019 using namespace Windows::UI::Xaml::Controls;
00020 using namespace Windows::Graphics::Display;
00021 using namespace Windows::UI::ViewManagement;
00022 using namespace Windows::UI::Xaml::Navigation;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::System;
00025 using namespace Platform;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 namespace ToastsSampleCPP
00029 {
00030     public enum class NotifyType
00031     {
00032         StatusMessage,
00033         ErrorMessage
00034     };
00035
00036   [Windows::Foundation::Metadata::WebHostHidden]
00037     public ref class MainPage sealed
00038     {
00039     public:
00040         MainPage();
00041
00042         property Windows::UI::Xaml::Controls::Frame^ ScenariosFrame
00043         {
00044             Windows::UI::Xaml::Controls::Frame^ get() { return _scenariosFrame; }
00045         }
00046         property Windows::UI::Xaml::Controls::Frame^ InputFrame
00047         {
00048             Windows::UI::Xaml::Controls::Frame^ get() { return _inputFrame; }
00049         }
00050         property Windows::UI::Xaml::Controls::Frame^ OutputFrame
00051         {
00052             Windows::UI::Xaml::Controls::Frame^ get() { return _outputFrame; }
00053         }
00054
00055         event Windows::Foundation::EventHandler<Platform::Object^>^ InputFrameLoaded;
00056         event Windows::Foundation::EventHandler<Platform::Object^>^ OutputFrameLoaded;
00057
00058         void NotifyUser(String^ strMessage, NotifyType type);
00059         void DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^ frame);
00060         String^ ConvertViewState(ApplicationViewState state);
00061         String^ ConvertResolution(ResolutionScale scale);
00062
00063     protected:
00064         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065
00066     private:
00067         ~MainPage();
00068
00069     Windows::UI::Xaml::Controls::Frame^ _scenariosFrame;
00070         Windows::UI::Xaml::Controls::Frame^ _inputFrame;
00071         Windows::UI::Xaml::Controls::Frame^ _outputFrame;
00072         void Footer_Click(Object^ sender, RoutedEventArgs^ e);
00073         Windows::Foundation::EventRegistrationToken _displayHandlerToken;
00074         Windows::Foundation::EventRegistrationToken _layoutHandlerToken;
00075         Windows::Foundation::EventRegistrationToken _pageLoadedHandlerToken;
00076         Windows::Foundation::EventRegistrationToken _logicalDpiChangedToken;
00077         Windows::Foundation::EventRegistrationToken _inputFrameLoadedToken;
00078         Windows::Foundation::EventRegistrationToken _outputFrameLoadedToken;
00079         void Page_SizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00080         void DisplayProperties_LogicalDpiChanged(Object^ sender);
00081         void Page_Loaded(Object^ sender, RoutedEventArgs^ e);
00082         void CheckResolutionAndViewState();
00083         void SetFeatureName(Platform::String^ strFeature);
00084         void inputFrameNavigated(Object^ sender, NavigationEventArgs^ e);
00085         void outputFrameNavigated(Object^ sender, NavigationEventArgs^ e);
00086
00087         Platform::String^ _toastContext;
00088     };
00089
00090   [Windows::Foundation::Metadata::WebHostHidden]
00091     public ref class MainPageAndContext sealed
00092     {
00093     public:
00094         MainPageAndContext(ToastsSampleCPP::MainPage^ mainPage, Platform::String^ toastContext)
00095         {
00096             _mainPage = mainPage;
00097             _toastContext = toastContext;
00098         }
00099         property ToastsSampleCPP::MainPage^ MainPage
00100         {
00101             ToastsSampleCPP::MainPage^ get() { return _mainPage; }
00102         }
00103         property Platform::String^ ToastContext
00104         {
00105             Platform::String^ get() { return _toastContext; }
00106         }
00107     private:
00108         ToastsSampleCPP::MainPage^ _mainPage;
00109         Platform::String^ _toastContext;
00110
00111     };
00112 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/MainPage.xaml.h Source File

  • XAML Popup

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/pch.h Source File

  • SMS background task
  • SmsBackgroundTaskSample

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicReaderWriter.h Source File

  • Direct3D stereoscopic 3D

BasicReaderWriter.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <ppltasks.h>
00011
00012 // A simple reader/writer class that provides support for reading and writing
00013 // files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicReaderWriter
00015 {
00016 private:
00017     Windows::Storage::StorageFolder^ m_location;
00018     Platform::String^ m_locationPath;
00019
00020 internal:
00021     BasicReaderWriter();
00022     BasicReaderWriter(
00023         _In_ Windows::Storage::StorageFolder^ folder
00024         );
00025
00026     Platform::Array<byte>^ ReadData(
00027         _In_ Platform::String^ filename
00028         );
00029
00030     concurrency::task<Platform::Array<byte>^> ReadDataAsync(
00031         _In_ Platform::String^ filename
00032         );
00033
00034     uint32 WriteData(
00035         _In_ Platform::String^ filename,
00036         _In_ const Platform::Array<byte>^ fileData
00037         );
00038
00039     concurrency::task<void> WriteDataAsync(
00040         _In_ Platform::String^ filename,
00041         _In_ const Platform::Array<byte>^ fileData
00042         );
00043 };
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/DirectXBase.h Source File

  • DirectWrite vertical text

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/HighPriority.xaml.h Source File

  • Application data

HighPriority.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // HighPriority.xaml.h
00013 // Declaration of the HighPriority class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "HighPriority.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ApplicationDataSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class HighPriority sealed
00031         {
00032         public:
00033             HighPriority();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             Windows::Storage::ApplicationDataContainer^ roamingSettings;
00040
00041             void IncrementHighPriority_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042             void DataChangedHandler(Windows::Storage::ApplicationData^ appData, Object^);
00043             void DisplayOutput(bool remoteUpdate);
00044         };
00045     }
00046 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicCamera.h Source File

  • DirectX postcard app

BasicCamera.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple camera class.
00011 ref class BasicCamera
00012 {
00013
00014 private:
00015     float3 m_position;      // the position of the camera
00016     float3 m_direction;     // the unit vector of the viewing direction
00017     float4x4 m_view;        // view matrix
00018     float4x4 m_projection;  // projection matrix
00019
00020 internal:
00021     void GetViewMatrix(_Out_ float4x4 *viewMatrix);
00022     void GetProjectionMatrix(_Out_ float4x4 *projectionMatrix);
00023
00024     // this method updates the view matrix based on new position and focus coordinates
00025     void SetViewParameters(
00026         _In_ float3 eyePosition,    // the position of the camera
00027         _In_ float3 lookPosition,   // the point the camera should look at
00028         _In_ float3 up              // the durection vector for up
00029         );
00030
00031     // this method updates the projection matrix based on new parameters
00032     void SetProjectionParameters(
00033         _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00034         _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00035         _In_ float nearPlane,           // depth to map to 0
00036         _In_ float farPlane             // depth to map to 1
00037         );
00038 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicLoader.cpp Source File

  • XAML DirectX 3D shooting game

BasicLoader.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicLoader.h"
00010 #include "BasicShapes.h"
00011 #include "DDSTextureLoader.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 using namespace Microsoft::WRL;
00016 using namespace Windows::Storage;
00017 using namespace Windows::Storage::Streams;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::ApplicationModel;
00020 using namespace std;
00021 using namespace concurrency;
00022
00023 BasicLoader::BasicLoader(
00024     _In_ ID3D11Device* d3dDevice,
00025     _In_opt_ IWICImagingFactory2* wicFactory
00026     ) :
00027     m_d3dDevice(d3dDevice),
00028     m_wicFactory(wicFactory)
00029 {
00030     // Create a new BasicReaderWriter to do raw file I/O.
00031     m_basicReaderWriter = ref new BasicReaderWriter();
00032 }
00033
00034 template <class DeviceChildType>
00035 inline void BasicLoader::SetDebugName(
00036     _In_ DeviceChildType* object,
00037     _In_ Platform::String^ name
00038     )
00039 {
00040 #if defined(_DEBUG)
00041     // Only assign debug names in debug builds.
00042
00043     char nameString[1024];
00044     int nameStringLength = WideCharToMultiByte(
00045         CP_ACP,
00046         0,
00047         name->Data(),
00048         -1,
00049         nameString,
00050         1024,
00051         nullptr,
00052         nullptr
00053         );
00054
00055     if (nameStringLength == 0)
00056     {
00057         char defaultNameString[] = "BasicLoaderObject";
00058         DX::ThrowIfFailed(
00059             object->SetPrivateData(
00060                 WKPDID_D3DDebugObjectName,
00061                 sizeof(defaultNameString) - 1,
00062                 defaultNameString
00063                 )
00064             );
00065     }
00066     else
00067     {
00068         DX::ThrowIfFailed(
00069             object->SetPrivateData(
00070                 WKPDID_D3DDebugObjectName,
00071                 nameStringLength - 1,
00072                 nameString
00073                 )
00074             );
00075     }
00076 #endif
00077 }
00078
00079 Platform::String^ BasicLoader::GetExtension(
00080     _In_ Platform::String^ filename
00081     )
00082 {
00083     int lastDotIndex = -1;
00084     for (int i = filename->Length() - 1; i >= 0 && lastDotIndex == -1; i--)
00085     {
00086         if (*(filename->Data() + i) == '.')
00087         {
00088             lastDotIndex = i;
00089         }
00090     }
00091     if (lastDotIndex != -1)
00092     {
00093         std::unique_ptr<wchar_t[]> extension(new wchar_t[filename->Length() - lastDotIndex]);
00094         for (unsigned int i = 0; i < filename->Length() - lastDotIndex; i++)
00095         {
00096             extension[i] = tolower(*(filename->Data() + lastDotIndex + 1 + i));
00097         }
00098         return ref new Platform::String(extension.get());
00099     }
00100     return "";
00101 }
00102
00103 void BasicLoader::CreateTexture(
00104     _In_ bool decodeAsDDS,
00105     _In_reads_bytes_(dataSize) byte* data,
00106     _In_ uint32 dataSize,
00107     _Out_opt_ ID3D11Texture2D** texture,
00108     _Out_opt_ ID3D11ShaderResourceView** textureView,
00109     _In_opt_ Platform::String^ debugName
00110     )
00111 {
00112     ComPtr<ID3D11ShaderResourceView> shaderResourceView;
00113     ComPtr<ID3D11Texture2D> texture2D;
00114
00115     if (decodeAsDDS)
00116     {
00117         ComPtr<ID3D11Resource> resource;
00118
00119         if (textureView == nullptr)
00120         {
00121             CreateDDSTextureFromMemory(
00122                 m_d3dDevice.Get(),
00123                 data,
00124                 dataSize,
00125                 &resource,
00126                 nullptr
00127                 );
00128         }
00129         else
00130         {
00131             CreateDDSTextureFromMemory(
00132                 m_d3dDevice.Get(),
00133                 data,
00134                 dataSize,
00135                 &resource,
00136                 &shaderResourceView
00137                 );
00138         }
00139
00140         DX::ThrowIfFailed(
00141             resource.As(&texture2D)
00142             );
00143     }
00144     else
00145     {
00146         if (m_wicFactory.Get() == nullptr)
00147         {
00148             // A WIC factory object is required in order to load texture
00149             // assets stored in non-DDS formats.  If BasicLoader was not
00150             // initialized with one, create one as needed.
00151             DX::ThrowIfFailed(
00152                 CoCreateInstance(
00153                     CLSID_WICImagingFactory,
00154                     nullptr,
00155                     CLSCTX_INPROC_SERVER,
00156                     IID_PPV_ARGS(&m_wicFactory)
00157                     )
00158                 );
00159         }
00160
00161         ComPtr<IWICStream> stream;
00162         DX::ThrowIfFailed(
00163             m_wicFactory->CreateStream(&stream)
00164             );
00165
00166         DX::ThrowIfFailed(
00167             stream->InitializeFromMemory(
00168                 data,
00169                 dataSize
00170                 )
00171             );
00172
00173         ComPtr<IWICBitmapDecoder> bitmapDecoder;
00174         DX::ThrowIfFailed(
00175             m_wicFactory->CreateDecoderFromStream(
00176                 stream.Get(),
00177                 nullptr,
00178                 WICDecodeMetadataCacheOnDemand,
00179                 &bitmapDecoder
00180                 )
00181             );
00182
00183         ComPtr<IWICBitmapFrameDecode> bitmapFrame;
00184         DX::ThrowIfFailed(
00185             bitmapDecoder->GetFrame(0, &bitmapFrame)
00186             );
00187
00188         ComPtr<IWICFormatConverter> formatConverter;
00189         DX::ThrowIfFailed(
00190             m_wicFactory->CreateFormatConverter(&formatConverter)
00191             );
00192
00193         DX::ThrowIfFailed(
00194             formatConverter->Initialize(
00195                 bitmapFrame.Get(),
00196                 GUID_WICPixelFormat32bppPBGRA,
00197                 WICBitmapDitherTypeNone,
00198                 nullptr,
00199                 0.0,
00200                 WICBitmapPaletteTypeCustom
00201                 )
00202             );
00203
00204         uint32 width;
00205         uint32 height;
00206         DX::ThrowIfFailed(
00207             bitmapFrame->GetSize(&width, &height)
00208             );
00209
00210         std::unique_ptr<byte[]> bitmapPixels(new byte[width * height * 4]);
00211         DX::ThrowIfFailed(
00212             formatConverter->CopyPixels(
00213                 nullptr,
00214                 width * 4,
00215                 width * height * 4,
00216                 bitmapPixels.get()
00217                 )
00218             );
00219
00220         D3D11_SUBRESOURCE_DATA initialData;
00221         ZeroMemory(&initialData, sizeof(initialData));
00222         initialData.pSysMem = bitmapPixels.get();
00223         initialData.SysMemPitch = width * 4;
00224         initialData.SysMemSlicePitch = 0;
00225
00226         CD3D11_TEXTURE2D_DESC textureDesc(
00227             DXGI_FORMAT_B8G8R8A8_UNORM,
00228             width,
00229             height,
00230             1,
00231             1
00232             );
00233
00234         DX::ThrowIfFailed(
00235             m_d3dDevice->CreateTexture2D(
00236                 &textureDesc,
00237                 &initialData,
00238                 &texture2D
00239                 )
00240             );
00241
00242         if (textureView != nullptr)
00243         {
00244             CD3D11_SHADER_RESOURCE_VIEW_DESC shaderResourceViewDesc(
00245                 texture2D.Get(),
00246                 D3D11_SRV_DIMENSION_TEXTURE2D
00247                 );
00248
00249             DX::ThrowIfFailed(
00250                 m_d3dDevice->CreateShaderResourceView(
00251                     texture2D.Get(),
00252                     &shaderResourceViewDesc,
00253                     &shaderResourceView
00254                     )
00255                 );
00256         }
00257     }
00258
00259     SetDebugName(texture2D.Get(), debugName);
00260
00261     if (texture != nullptr)
00262     {
00263         *texture = texture2D.Detach();
00264     }
00265     if (textureView != nullptr)
00266     {
00267         *textureView = shaderResourceView.Detach();
00268     }
00269 }
00270
00271 void BasicLoader::CreateInputLayout(
00272     _In_reads_bytes_(bytecodeSize) byte* bytecode,
00273     _In_ uint32 bytecodeSize,
00274     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00275     _In_ uint32 layoutDescNumElements,
00276     _Out_ ID3D11InputLayout** layout
00277     )
00278 {
00279     if (layoutDesc == nullptr)
00280     {
00281         // If no input layout is specified, use the BasicVertex layout.
00282         const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
00283         {
00284             { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
00285             { "NORMAL",   0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00286             { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 24, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00287         };
00288
00289         DX::ThrowIfFailed(
00290             m_d3dDevice->CreateInputLayout(
00291                 basicVertexLayoutDesc,
00292                 ARRAYSIZE(basicVertexLayoutDesc),
00293                 bytecode,
00294                 bytecodeSize,
00295                 layout
00296                 )
00297             );
00298     }
00299     else
00300     {
00301         DX::ThrowIfFailed(
00302             m_d3dDevice->CreateInputLayout(
00303                 layoutDesc,
00304                 layoutDescNumElements,
00305                 bytecode,
00306                 bytecodeSize,
00307                 layout
00308                 )
00309             );
00310     }
00311 }
00312
00313 void BasicLoader::CreateMesh(
00314     _In_ byte* meshData,
00315     _Out_ ID3D11Buffer** vertexBuffer,
00316     _Out_ ID3D11Buffer** indexBuffer,
00317     _Out_opt_ uint32* vertexCount,
00318     _Out_opt_ uint32* indexCount,
00319     _In_opt_ Platform::String^ debugName
00320     )
00321 {
00322     // The first 4 bytes of the BasicMesh format define the number of vertices in the mesh.
00323     uint32 numVertices = *reinterpret_cast<uint32*>(meshData);
00324
00325     // The following 4 bytes define the number of indices in the mesh.
00326     uint32 numIndices = *reinterpret_cast<uint32*>(meshData + sizeof(uint32));
00327
00328     // The next segment of the BasicMesh format contains the vertices of the mesh.
00329     BasicVertex* vertices = reinterpret_cast<BasicVertex*>(meshData + sizeof(uint32) * 2);
00330
00331     // The last segment of the BasicMesh format contains the indices of the mesh.
00332     uint16* indices = reinterpret_cast<uint16*>(meshData + sizeof(uint32) * 2 + sizeof(BasicVertex) * numVertices);
00333
00334     // Create the vertex and index buffers with the mesh data.
00335
00336     D3D11_SUBRESOURCE_DATA vertexBufferData = {0};
00337     vertexBufferData.pSysMem = vertices;
00338     vertexBufferData.SysMemPitch = 0;
00339     vertexBufferData.SysMemSlicePitch = 0;
00340     CD3D11_BUFFER_DESC vertexBufferDesc(numVertices * sizeof(BasicVertex), D3D11_BIND_VERTEX_BUFFER);
00341     DX::ThrowIfFailed(
00342         m_d3dDevice->CreateBuffer(
00343             &vertexBufferDesc,
00344             &vertexBufferData,
00345             vertexBuffer
00346             )
00347         );
00348
00349     D3D11_SUBRESOURCE_DATA indexBufferData = {0};
00350     indexBufferData.pSysMem = indices;
00351     indexBufferData.SysMemPitch = 0;
00352     indexBufferData.SysMemSlicePitch = 0;
00353     CD3D11_BUFFER_DESC indexBufferDesc(numIndices * sizeof(uint16), D3D11_BIND_INDEX_BUFFER);
00354     DX::ThrowIfFailed(
00355         m_d3dDevice->CreateBuffer(
00356             &indexBufferDesc,
00357             &indexBufferData,
00358             indexBuffer
00359             )
00360         );
00361
00362     SetDebugName(*vertexBuffer, Platform::String::Concat(debugName, "_VertexBuffer"));
00363     SetDebugName(*indexBuffer, Platform::String::Concat(debugName, "_IndexBuffer"));
00364
00365     if (vertexCount != nullptr)
00366     {
00367         *vertexCount = numVertices;
00368     }
00369     if (indexCount != nullptr)
00370     {
00371         *indexCount = numIndices;
00372     }
00373 }
00374
00375 void BasicLoader::LoadTexture(
00376     _In_ Platform::String^ filename,
00377     _Out_opt_ ID3D11Texture2D** texture,
00378     _Out_opt_ ID3D11ShaderResourceView** textureView
00379     )
00380 {
00381     Platform::Array<byte>^ textureData = m_basicReaderWriter->ReadData(filename);
00382
00383     CreateTexture(
00384         GetExtension(filename) == "dds",
00385         textureData->Data,
00386         textureData->Length,
00387         texture,
00388         textureView,
00389         filename
00390         );
00391 }
00392
00393 task<void> BasicLoader::LoadTextureAsync(
00394     _In_ Platform::String^ filename,
00395     _Out_opt_ ID3D11Texture2D** texture,
00396     _Out_opt_ ID3D11ShaderResourceView** textureView
00397     )
00398 {
00399     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ textureData)
00400     {
00401         CreateTexture(
00402             GetExtension(filename) == "dds",
00403             textureData->Data,
00404             textureData->Length,
00405             texture,
00406             textureView,
00407             filename
00408             );
00409     });
00410 }
00411
00412 void BasicLoader::LoadShader(
00413     _In_ Platform::String^ filename,
00414     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00415     _In_ uint32 layoutDescNumElements,
00416     _Out_ ID3D11VertexShader** shader,
00417     _Out_opt_ ID3D11InputLayout** layout
00418     )
00419 {
00420     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00421
00422     DX::ThrowIfFailed(
00423         m_d3dDevice->CreateVertexShader(
00424             bytecode->Data,
00425             bytecode->Length,
00426             nullptr,
00427             shader
00428             )
00429         );
00430
00431     SetDebugName(*shader, filename);
00432
00433     if (layout != nullptr)
00434     {
00435         CreateInputLayout(
00436             bytecode->Data,
00437             bytecode->Length,
00438             layoutDesc,
00439             layoutDescNumElements,
00440             layout
00441             );
00442
00443         SetDebugName(*layout, filename);
00444     }
00445 }
00446
00447 task<void> BasicLoader::LoadShaderAsync(
00448     _In_ Platform::String^ filename,
00449     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00450     _In_ uint32 layoutDescNumElements,
00451     _Out_ ID3D11VertexShader** shader,
00452     _Out_opt_ ID3D11InputLayout** layout
00453     )
00454 {
00455     // This method assumes that the lifetime of input arguments may be shorter
00456     // than the duration of this task.  In order to ensure accurate results, a
00457     // copy of all arguments passed by pointer must be made.  The method then
00458     // ensures that the lifetime of the copied data exceeds that of the task.
00459
00460     // Create copies of the layoutDesc array as well as the SemanticName strings,
00461     // both of which are pointers to data whose lifetimes may be shorter than that
00462     // of this method's task.
00463     shared_ptr<vector<D3D11_INPUT_ELEMENT_DESC>> layoutDescCopy;
00464     shared_ptr<vector<string>> layoutDescSemanticNamesCopy;
00465     if (layoutDesc != nullptr)
00466     {
00467         layoutDescCopy.reset(
00468             new vector<D3D11_INPUT_ELEMENT_DESC>(
00469                 layoutDesc,
00470                 layoutDesc + layoutDescNumElements
00471                 )
00472             );
00473
00474         layoutDescSemanticNamesCopy.reset(
00475             new vector<string>(layoutDescNumElements)
00476             );
00477
00478         for (uint32 i = 0; i < layoutDescNumElements; i++)
00479         {
00480             layoutDescSemanticNamesCopy->at(i).assign(layoutDesc[i].SemanticName);
00481         }
00482     }
00483
00484     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00485     {
00486         DX::ThrowIfFailed(
00487             m_d3dDevice->CreateVertexShader(
00488                 bytecode->Data,
00489                 bytecode->Length,
00490                 nullptr,
00491                 shader
00492                 )
00493             );
00494
00495         SetDebugName(*shader, filename);
00496
00497         if (layout != nullptr)
00498         {
00499             if (layoutDesc != nullptr)
00500             {
00501                 // Reassign the SemanticName elements of the layoutDesc array copy to point
00502                 // to the corresponding copied strings. Performing the assignment inside the
00503                 // lambda body ensures that the lambda will take a reference to the shared_ptr
00504                 // that holds the data.  This will guarantee that the data is still valid when
00505                 // CreateInputLayout is called.
00506                 for (uint32 i = 0; i < layoutDescNumElements; i++)
00507                 {
00508                     layoutDescCopy->at(i).SemanticName = layoutDescSemanticNamesCopy->at(i).c_str();
00509                 }
00510             }
00511
00512             CreateInputLayout(
00513                 bytecode->Data,
00514                 bytecode->Length,
00515                 layoutDesc == nullptr ? nullptr : layoutDescCopy->data(),
00516                 layoutDescNumElements,
00517                 layout
00518                 );
00519
00520             SetDebugName(*layout, filename);
00521         }
00522     });
00523 }
00524
00525 void BasicLoader::LoadShader(
00526     _In_ Platform::String^ filename,
00527     _Out_ ID3D11PixelShader** shader
00528     )
00529 {
00530     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00531
00532     DX::ThrowIfFailed(
00533         m_d3dDevice->CreatePixelShader(
00534             bytecode->Data,
00535             bytecode->Length,
00536             nullptr,
00537             shader
00538             )
00539         );
00540
00541     SetDebugName(*shader, filename);
00542 }
00543
00544 task<void> BasicLoader::LoadShaderAsync(
00545     _In_ Platform::String^ filename,
00546     _Out_ ID3D11PixelShader** shader
00547     )
00548 {
00549     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00550     {
00551         DX::ThrowIfFailed(
00552             m_d3dDevice->CreatePixelShader(
00553                 bytecode->Data,
00554                 bytecode->Length,
00555                 nullptr,
00556                 shader
00557                 )
00558             );
00559
00560         SetDebugName(*shader, filename);
00561     });
00562 }
00563
00564 void BasicLoader::LoadShader(
00565     _In_ Platform::String^ filename,
00566     _Out_ ID3D11ComputeShader** shader
00567     )
00568 {
00569     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00570
00571     DX::ThrowIfFailed(
00572         m_d3dDevice->CreateComputeShader(
00573             bytecode->Data,
00574             bytecode->Length,
00575             nullptr,
00576             shader
00577             )
00578         );
00579
00580     SetDebugName(*shader, filename);
00581 }
00582
00583 task<void> BasicLoader::LoadShaderAsync(
00584     _In_ Platform::String^ filename,
00585     _Out_ ID3D11ComputeShader** shader
00586     )
00587 {
00588     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00589     {
00590         DX::ThrowIfFailed(
00591             m_d3dDevice->CreateComputeShader(
00592                 bytecode->Data,
00593                 bytecode->Length,
00594                 nullptr,
00595                 shader
00596                 )
00597             );
00598
00599         SetDebugName(*shader, filename);
00600     });
00601 }
00602
00603 void BasicLoader::LoadShader(
00604     _In_ Platform::String^ filename,
00605     _Out_ ID3D11GeometryShader** shader
00606     )
00607 {
00608     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00609
00610     DX::ThrowIfFailed(
00611         m_d3dDevice->CreateGeometryShader(
00612             bytecode->Data,
00613             bytecode->Length,
00614             nullptr,
00615             shader
00616             )
00617         );
00618
00619     SetDebugName(*shader, filename);
00620 }
00621
00622 task<void> BasicLoader::LoadShaderAsync(
00623     _In_ Platform::String^ filename,
00624     _Out_ ID3D11GeometryShader** shader
00625     )
00626 {
00627     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00628     {
00629         DX::ThrowIfFailed(
00630             m_d3dDevice->CreateGeometryShader(
00631                 bytecode->Data,
00632                 bytecode->Length,
00633                 nullptr,
00634                 shader
00635                 )
00636             );
00637
00638         SetDebugName(*shader, filename);
00639     });
00640 }
00641
00642 void BasicLoader::LoadShader(
00643     _In_ Platform::String^ filename,
00644     _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00645     _In_ uint32 numEntries,
00646     _In_reads_opt_(numStrides) const uint32* bufferStrides,
00647     _In_ uint32 numStrides,
00648     _In_ uint32 rasterizedStream,
00649     _Out_ ID3D11GeometryShader** shader
00650     )
00651 {
00652     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00653
00654     DX::ThrowIfFailed(
00655         m_d3dDevice->CreateGeometryShaderWithStreamOutput(
00656             bytecode->Data,
00657             bytecode->Length,
00658             streamOutDeclaration,
00659             numEntries,
00660             bufferStrides,
00661             numStrides,
00662             rasterizedStream,
00663             nullptr,
00664             shader
00665             )
00666         );
00667
00668     SetDebugName(*shader, filename);
00669 }
00670
00671 task<void> BasicLoader::LoadShaderAsync(
00672     _In_ Platform::String^ filename,
00673     _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00674     _In_ uint32 numEntries,
00675     _In_reads_opt_(numStrides) const uint32* bufferStrides,
00676     _In_ uint32 numStrides,
00677     _In_ uint32 rasterizedStream,
00678     _Out_ ID3D11GeometryShader** shader
00679     )
00680 {
00681     // This method assumes that the lifetime of input arguments may be shorter
00682     // than the duration of this task.  In order to ensure accurate results, a
00683     // copy of all arguments passed by pointer must be made.  The method then
00684     // ensures that the lifetime of the copied data exceeds that of the task.
00685
00686     // Create copies of the streamOutDeclaration array as well as the SemanticName
00687     // strings, both of which are pointers to data whose lifetimes may be shorter
00688     // than that of this method's task.
00689     shared_ptr<vector<D3D11_SO_DECLARATION_ENTRY>> streamOutDeclarationCopy;
00690     shared_ptr<vector<string>> streamOutDeclarationSemanticNamesCopy;
00691     if (streamOutDeclaration != nullptr)
00692     {
00693         streamOutDeclarationCopy.reset(
00694             new vector<D3D11_SO_DECLARATION_ENTRY>(
00695                 streamOutDeclaration,
00696                 streamOutDeclaration + numEntries
00697                 )
00698             );
00699
00700         streamOutDeclarationSemanticNamesCopy.reset(
00701             new vector<string>(numEntries)
00702             );
00703
00704         for (uint32 i = 0; i < numEntries; i++)
00705         {
00706             streamOutDeclarationSemanticNamesCopy->at(i).assign(streamOutDeclaration[i].SemanticName);
00707         }
00708     }
00709
00710     // Create a copy of the bufferStrides array, which is a pointer to data
00711     // whose lifetime may be shorter than that of this method's task.
00712     shared_ptr<vector<uint32>> bufferStridesCopy;
00713     if (bufferStrides != nullptr)
00714     {
00715         bufferStridesCopy.reset(
00716             new vector<uint32>(
00717                 bufferStrides,
00718                 bufferStrides + numStrides
00719                 )
00720             );
00721     }
00722
00723     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00724     {
00725         if (streamOutDeclaration != nullptr)
00726         {
00727             // Reassign the SemanticName elements of the streamOutDeclaration array copy to
00728             // point to the corresponding copied strings. Performing the assignment inside the
00729             // lambda body ensures that the lambda will take a reference to the shared_ptr
00730             // that holds the data.  This will guarantee that the data is still valid when
00731             // CreateGeometryShaderWithStreamOutput is called.
00732             for (uint32 i = 0; i < numEntries; i++)
00733             {
00734                 streamOutDeclarationCopy->at(i).SemanticName = streamOutDeclarationSemanticNamesCopy->at(i).c_str();
00735             }
00736         }
00737
00738         DX::ThrowIfFailed(
00739             m_d3dDevice->CreateGeometryShaderWithStreamOutput(
00740                 bytecode->Data,
00741                 bytecode->Length,
00742                 streamOutDeclaration == nullptr ? nullptr : streamOutDeclarationCopy->data(),
00743                 numEntries,
00744                 bufferStrides == nullptr ? nullptr : bufferStridesCopy->data(),
00745                 numStrides,
00746                 rasterizedStream,
00747                 nullptr,
00748                 shader
00749                 )
00750             );
00751
00752         SetDebugName(*shader, filename);
00753     });
00754 }
00755
00756 void BasicLoader::LoadShader(
00757     _In_ Platform::String^ filename,
00758     _Out_ ID3D11HullShader** shader
00759     )
00760 {
00761     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00762
00763     DX::ThrowIfFailed(
00764         m_d3dDevice->CreateHullShader(
00765             bytecode->Data,
00766             bytecode->Length,
00767             nullptr,
00768             shader
00769             )
00770         );
00771
00772     SetDebugName(*shader, filename);
00773 }
00774
00775 task<void> BasicLoader::LoadShaderAsync(
00776     _In_ Platform::String^ filename,
00777     _Out_ ID3D11HullShader** shader
00778     )
00779 {
00780     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00781     {
00782         DX::ThrowIfFailed(
00783             m_d3dDevice->CreateHullShader(
00784                 bytecode->Data,
00785                 bytecode->Length,
00786                 nullptr,
00787                 shader
00788                 )
00789             );
00790
00791         SetDebugName(*shader, filename);
00792     });
00793 }
00794
00795 void BasicLoader::LoadShader(
00796     _In_ Platform::String^ filename,
00797     _Out_ ID3D11DomainShader** shader
00798     )
00799 {
00800     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00801
00802     DX::ThrowIfFailed(
00803         m_d3dDevice->CreateDomainShader(
00804             bytecode->Data,
00805             bytecode->Length,
00806             nullptr,
00807             shader
00808             )
00809         );
00810
00811     SetDebugName(*shader, filename);
00812 }
00813
00814 task<void> BasicLoader::LoadShaderAsync(
00815     _In_ Platform::String^ filename,
00816     _Out_ ID3D11DomainShader** shader
00817     )
00818 {
00819     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00820     {
00821         DX::ThrowIfFailed(
00822             m_d3dDevice->CreateDomainShader(
00823                 bytecode->Data,
00824                 bytecode->Length,
00825                 nullptr,
00826                 shader
00827                 )
00828             );
00829
00830         SetDebugName(*shader, filename);
00831     });
00832 }
00833
00834 void BasicLoader::LoadMesh(
00835     _In_ Platform::String^ filename,
00836     _Out_ ID3D11Buffer** vertexBuffer,
00837     _Out_ ID3D11Buffer** indexBuffer,
00838     _Out_opt_ uint32* vertexCount,
00839     _Out_opt_ uint32* indexCount
00840     )
00841 {
00842     Platform::Array<byte>^ meshData = m_basicReaderWriter->ReadData(filename);
00843
00844     CreateMesh(
00845         meshData->Data,
00846         vertexBuffer,
00847         indexBuffer,
00848         vertexCount,
00849         indexCount,
00850         filename
00851         );
00852 }
00853
00854 task<void> BasicLoader::LoadMeshAsync(
00855     _In_ Platform::String^ filename,
00856     _Out_ ID3D11Buffer** vertexBuffer,
00857     _Out_ ID3D11Buffer** indexBuffer,
00858     _Out_opt_ uint32* vertexCount,
00859     _Out_opt_ uint32* indexCount
00860     )
00861 {
00862     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ meshData)
00863     {
00864         CreateMesh(
00865             meshData->Data,
00866             vertexBuffer,
00867             indexBuffer,
00868             vertexCount,
00869             indexCount,
00870             filename
00871             );
00872     });
00873 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/App.xaml.cpp Source File

  • XAML accessibility

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/App.xaml.cpp Source File

  • XAML text display

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/Constants.h Source File

  • Animation metrics

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Animation Metrics");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/App.xaml.cpp Source File

  • Snap

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicTimer.cpp Source File

  • Direct3D post-processing effects

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario2.xaml.cpp Source File

  • File and folder thumbnail

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::FileThumbnails;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::FileProperties;
00025 using namespace Windows::Storage::Pickers;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario2::Scenario2()
00031 {
00032     InitializeComponent();
00033     rootPage = MainPage::Current;
00034     GetThumbnailButton->Click += ref new RoutedEventHandler(this, &Scenario2::GetThumbnailButton_Click);
00035 }
00036
00037 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     rootPage->ResetOutput(ThumbnailImage, OutputTextBlock, nullptr);
00040 }
00041
00042 void Scenario2::GetThumbnailButton_Click(Object^ sender, RoutedEventArgs^ e)
00043 {
00044     rootPage->ResetOutput(ThumbnailImage, OutputTextBlock, nullptr);
00045
00046     if (rootPage->EnsureUnsnapped())
00047     {
00048         // Pick a music file
00049         FileOpenPicker^ openPicker = ref new FileOpenPicker();
00050         Array<String^>^ extensions = FileExtensions::Music;
00051         for (unsigned int i = 0; i < extensions->Length; i++)
00052         {
00053             openPicker->FileTypeFilter->Append(extensions[i]);
00054         }
00055
00056         create_task(openPicker->PickSingleFileAsync()).then([this](StorageFile^ file)
00057         {
00058             if (file != nullptr)
00059             {
00060                 const ThumbnailMode thumbnailMode = ThumbnailMode::MusicView;
00061                 const size_t size = 100;
00062                 create_task(file->GetThumbnailAsync(thumbnailMode, size)).then([this, file, size](StorageItemThumbnail^ thumbnail)
00063                 {
00064                     if (thumbnail != nullptr && thumbnail->Type == ThumbnailType::Image)
00065                     {
00066                         MainPage::DisplayResult(ThumbnailImage, OutputTextBlock, "MusicView", size, file, thumbnail, false);
00067                     }
00068                     else
00069                     {
00070                         rootPage->NotifyUser(Errors::NoAlbumArt, NotifyType::StatusMessage);
00071                     }
00072                 });
00073             }
00074             else
00075             {
00076                 rootPage->NotifyUser(Errors::Cancel, NotifyType::StatusMessage);
00077             }
00078         });
00079     }
00080 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/App.xaml.h Source File

  • HttpClient

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/MainPage.xaml.cs Source File

  • Custom driver access
  • C#,C++
  • app_cs

MainPage.xaml.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using System;
00012 using Windows.UI.ViewManagement;
00013 using Windows.UI.Xaml;
00014 using Windows.UI.Xaml.Controls;
00015 using Windows.UI.Xaml.Markup;
00016 using Windows.UI.Xaml.Navigation;
00017
00018
00019 namespace SDKTemplate
00020 {
00021     /// <summary>
00022     /// An empty page that can be used on its own or navigated to within a Frame.
00023     /// </summary>
00024     public sealed partial class MainPage : SDKTemplate.Common.LayoutAwarePage
00025     {
00026         public event System.EventHandler ScenarioLoaded;
00027         public event EventHandler<MainPageSizeChangedEventArgs> MainPageResized;
00028         public bool AutoSizeInputSectionWhenSnapped = true;
00029
00030         public Windows.ApplicationModel.Activation.LaunchActivatedEventArgs LaunchArgs
00031         {
00032             get
00033             {
00034                 return ((App)App.Current).LaunchArgs;
00035             }
00036         }
00037
00038         public static MainPage Current;
00039
00040         private Frame HiddenFrame = null;
00041
00042         public MainPage()
00043         {
00044             this.InitializeComponent();
00045
00046             // This is a static public property that will allow downstream pages to get
00047             // a handle to the MainPage instance in order to call methods that are in this class.
00048             Current = this;
00049
00050             // This frame is hidden, meaning it is never shown.  It is simply used to load
00051             // each scenario page and then pluck out the input and output sections and
00052             // place them into the UserControls on the main page.
00053             HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
00054             HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
00055             ContentRoot.Children.Add(HiddenFrame);
00056
00057             // Populate the sample title from the constant in the Constants.cs file.
00058             SetFeatureName(FEATURE_NAME);
00059             Scenarios.SelectionChanged += Scenarios_SelectionChanged;
00060             SizeChanged += MainPage_SizeChanged;
00061         }
00062
00063         void MainPage_SizeChanged(object sender, SizeChangedEventArgs e)
00064         {
00065             InvalidateSize();
00066             if (MainPageResized != null)
00067             {
00068                 MainPageSizeChangedEventArgs args = new MainPageSizeChangedEventArgs();
00069                 args.ViewState = ApplicationView.Value;
00070                 MainPageResized(this, args);
00071             }
00072         }
00073
00074         /// <summary>
00075         /// Invoked when this page is about to be displayed in a Frame.
00076         /// </summary>
00077         /// <param name="e">Event data that describes how this page was reached.  The Parameter
00078         /// property is typically used to configure the page.</param>
00079         protected override void OnNavigatedTo(NavigationEventArgs e)
00080         {
00081             PopulateScenarios();
00082             InvalidateViewState();
00083         }
00084
00085         private void InvalidateSize()
00086         {
00087             // Get the window width
00088             double windowWidth = this.ActualWidth;
00089             if (windowWidth != 0.0)
00090             {
00091                 // Get the width of the ListBox.
00092                 double listBoxWidth = Scenarios.ActualWidth;
00093
00094                 // Is the ListBox using any margins that we need to consider?
00095                 double listBoxMarginLeft = Scenarios.Margin.Left;
00096                 double listBoxMarginRight = Scenarios.Margin.Right;
00097
00098                 // Figure out how much room is left after considering the list box width
00099                 double availableWidth = windowWidth - listBoxWidth;
00100
00101                 // Is the top most child using margins?
00102                 double layoutRootMarginLeft = ContentRoot.Margin.Left;
00103                 double layoutRootMarginRight = ContentRoot.Margin.Right;
00104
00105                 // We have different widths to use depending on the view state
00106                 if (ApplicationView.Value != ApplicationViewState.Snapped)
00107                 {
00108                     // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00109                     // and the LayoutRoot's margins
00110                     InputSection.Width = availableWidth - (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
00111                 }
00112                 else
00113                 {
00114                     // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00115                     if (AutoSizeInputSectionWhenSnapped)
00116                     {
00117                         InputSection.Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
00118                     }
00119                 }
00120             }
00121             InvalidateViewState();
00122         }
00123
00124         private void InvalidateViewState()
00125         {
00126             if (ApplicationView.Value == ApplicationViewState.Snapped)
00127             {
00128                 Grid.SetRow(DescriptionText, 3);
00129                 Grid.SetColumn(DescriptionText, 0);
00130
00131                 Grid.SetRow(InputSection, 4);
00132                 Grid.SetColumn(InputSection, 0);
00133
00134                 Grid.SetRow(FooterPanel, 2);
00135                 Grid.SetColumn(FooterPanel, 0);
00136             }
00137             else
00138             {
00139                 Grid.SetRow(DescriptionText, 1);
00140                 Grid.SetColumn(DescriptionText, 1);
00141
00142                 Grid.SetRow(InputSection, 2);
00143                 Grid.SetColumn(InputSection, 1);
00144
00145                 Grid.SetRow(FooterPanel, 1);
00146                 Grid.SetColumn(FooterPanel, 1);
00147             }
00148
00149             // Since we don't load the scenario page in the traditional manner (we just pluck out the
00150             // input and output sections from the page) we need to ensure that any VSM code used
00151             // by the scenario's input and output sections is fired.
00152             VisualStateManager.GoToState((Control)InputSection, "Input" + ApplicationView.Value.ToString(), false);
00153             VisualStateManager.GoToState((Control)OutputSection, "Output" + ApplicationView.Value.ToString(), false);
00154         }
00155
00156         private void PopulateScenarios()
00157         {
00158             System.Collections.ObjectModel.ObservableCollection<object> ScenarioList = new System.Collections.ObjectModel.ObservableCollection<object>();
00159             int i = 0;
00160
00161             // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00162             foreach (Scenario s in scenarios)
00163             {
00164                 ListBoxItem item = new ListBoxItem();
00165                 s.Title = (++i).ToString() + ") " + s.Title;
00166                 item.Content = s;
00167                 item.Name = s.ClassType.FullName;
00168                 ScenarioList.Add(item);
00169             }
00170
00171             // Bind the ListBox to the scenario list.
00172             Scenarios.ItemsSource = ScenarioList;
00173
00174             // Starting scenario is the first or based upon a previous selection.
00175             int startingScenarioIndex = -1;
00176
00177             if (SuspensionManager.SessionState.ContainsKey("SelectedScenarioIndex"))
00178             {
00179                 int selectedScenarioIndex = Convert.ToInt32(SuspensionManager.SessionState["SelectedScenarioIndex"]);
00180                 startingScenarioIndex = selectedScenarioIndex;
00181             }
00182             Scenarios.SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00183             Scenarios.ScrollIntoView(Scenarios.SelectedItem);
00184         }
00185
00186         /// <summary>
00187         /// This method is responsible for loading the individual input and output sections for each scenario.  This
00188         /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00189         /// and output sections into the respective UserControl on the main page.
00190         /// </summary>
00191         /// <param name="scenarioName"></param>
00192         public void LoadScenario(Type scenarioClass)
00193         {
00194             AutoSizeInputSectionWhenSnapped = true;
00195
00196             // Load the ScenarioX.xaml file into the Frame.
00197             HiddenFrame.Navigate(scenarioClass, this);
00198
00199             // Get the top element, the Page, so we can look up the elements
00200             // that represent the input and output sections of the ScenarioX file.
00201             Page hiddenPage = HiddenFrame.Content as Page;
00202
00203             // Get each element.
00204             UIElement input = hiddenPage.FindName("Input") as UIElement;
00205             UIElement output = hiddenPage.FindName("Output") as UIElement;
00206
00207             if (input == null)
00208             {
00209                 // Malformed input section.
00210                 NotifyUser(String.Format(
00211                     "Cannot load scenario input section for {0}.  Make sure root of input section markup has x:Name of 'Input'",
00212                     scenarioClass.Name), NotifyType.ErrorMessage);
00213                 return;
00214             }
00215
00216             if (output == null)
00217             {
00218                 // Malformed output section.
00219                 NotifyUser(String.Format(
00220                     "Cannot load scenario output section for {0}.  Make sure root of output section markup has x:Name of 'Output'",
00221                     scenarioClass.Name), NotifyType.ErrorMessage);
00222                 return;
00223             }
00224
00225             // Find the LayoutRoot which parents the input and output sections in the main page.
00226             Panel panel = hiddenPage.FindName("LayoutRoot") as Panel;
00227
00228             if (panel != null)
00229             {
00230                 // Get rid of the content that is currently in the intput and output sections.
00231                 panel.Children.Remove(input);
00232                 panel.Children.Remove(output);
00233
00234                 // Populate the input and output sections with the newly loaded content.
00235                 InputSection.Content = input;
00236                 OutputSection.Content = output;
00237             }
00238             else
00239             {
00240                 // Malformed Scenario file.
00241                 NotifyUser(String.Format(
00242                     "Cannot load scenario: '{0}'.  Make sure root tag in the '{0}' file has an x:Name of 'LayoutRoot'",
00243                     scenarioClass.Name), NotifyType.ErrorMessage);
00244             }
00245         }
00246
00247         void Scenarios_SelectionChanged(object sender, SelectionChangedEventArgs e)
00248         {
00249             if (Scenarios.SelectedItem != null)
00250             {
00251                 NotifyUser("", NotifyType.StatusMessage);
00252
00253                 ListBoxItem selectedListBoxItem = Scenarios.SelectedItem as ListBoxItem;
00254                 SuspensionManager.SessionState["SelectedScenarioIndex"] = Scenarios.SelectedIndex;
00255
00256                 Scenario scenario = selectedListBoxItem.Content as Scenario;
00257                 LoadScenario(scenario.ClassType);
00258                 InvalidateSize();
00259
00260                 // Fire the ScenarioLoaded event since we know that everything is loaded now.
00261                 if (ScenarioLoaded != null)
00262                 {
00263                     ScenarioLoaded(this, new EventArgs());
00264                 }
00265             }
00266         }
00267
00268         public void NotifyUser(string strMessage, NotifyType type)
00269         {
00270             switch (type)
00271             {
00272                 // Use the status message style.
00273                 case NotifyType.StatusMessage:
00274                     StatusBlock.Style = Resources["StatusStyle"] as Style;
00275                     break;
00276                 // Use the error message style.
00277                 case NotifyType.ErrorMessage:
00278                     StatusBlock.Style = Resources["ErrorStyle"] as Style;
00279                     break;
00280             }
00281             StatusBlock.Text = strMessage;
00282
00283             // Collapse the StatusBlock if it has no text to conserve real estate.
00284             if (StatusBlock.Text != String.Empty)
00285             {
00286                 StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Visible;
00287             }
00288             else
00289             {
00290                 StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
00291             }
00292         }
00293
00294         async void Footer_Click(object sender, RoutedEventArgs e)
00295         {
00296             await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
00297         }
00298
00299         private void SetFeatureName(string str)
00300         {
00301             FeatureName.Text = str;
00302         }
00303     }
00304
00305     public class MainPageSizeChangedEventArgs : EventArgs
00306     {
00307         private ApplicationViewState viewState;
00308
00309         public ApplicationViewState ViewState
00310         {
00311             get { return viewState; }
00312             set { viewState = value; }
00313         }
00314     }
00315
00316     public enum NotifyType
00317     {
00318         StatusMessage,
00319         ErrorMessage
00320     };
00321 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander Member List

This is the complete list of members for anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander, including all inherited members.
error | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander |
m_isPlayingHolder | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander | [private]
SoundCallbackHander(bool *isPlayingHolder) | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander | [inline]
STDMETHOD_(void, OnVoiceProcessingPassStart)(THIS_ UINT32 bytesRequired) | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander |
STDMETHOD_(void, OnVoiceProcessingPassEnd)(THIS) | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander |
STDMETHOD_(void, OnStreamEnd)(THIS) | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander |
STDMETHOD_(void, OnBufferStart)(THIS_ void *bufferContext) | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander |
STDMETHOD_(void, OnBufferEnd)(THIS_ void *bufferContext) | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander |
STDMETHOD_(void, OnLoopEnd)(THIS_ void *bufferContext) | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander |
STDMETHOD_(void, OnVoiceError)(THIS_ void *bufferContext | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander |
~SoundCallbackHander() | anonymous_namespace{XAudio2SoundPlayer.cpp}::SoundCallbackHander | [inline]
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DocSource.h Source File

  • Direct2Dapp printing

DocSource.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009 #include <windows.graphics.printing.h>
00010 #include <printpreview.h>
00011 #include <documentsource.h>
00012 #include "D2DPageRenderer.h"
00013
00014 class CDocumentSource : public Microsoft::WRL::RuntimeClass<Microsoft::WRL::RuntimeClassFlags<Microsoft::WRL::WinRtClassicComMix>,
00015                                                             ABI::Windows::Graphics::Printing::IPrintDocumentSource,
00016                                                             IPrintDocumentPageSource,
00017                                                             IPrintPreviewPageCollection>
00018 {
00019 private:
00020     InspectableClass(L"Windows.Graphics.Printing.IPrintDocumentSource", BaseTrust);
00021
00022 public:
00023     HRESULT RuntimeClassInitialize(
00024         _In_ IUnknown* pageRenderer
00025         )
00026     {
00027         HRESULT hr = (pageRenderer != nullptr) ? S_OK : E_INVALIDARG;
00028
00029         if (SUCCEEDED(hr))
00030         {
00031             m_paginateCalled = false;
00032             m_totalPages     = 1;
00033             m_height         = 0.f;
00034             m_width          = 0.f;
00035
00036             // Cast d2dRender back to PageRenderer object.
00037             m_renderer = reinterpret_cast<PageRenderer^>(pageRenderer);
00038         }
00039
00040         return hr;
00041     }
00042
00043     //
00044     // classic COM interface IDocumentPageSource methods
00045     //
00046     IFACEMETHODIMP
00047     GetPreviewPageCollection(
00048         _In_  IPrintDocumentPackageTarget*  docPackageTarget,
00049         _Out_ IPrintPreviewPageCollection** docPageCollection
00050         );
00051
00052     IFACEMETHODIMP
00053     MakeDocument(
00054         _In_ IInspectable*                  docOptions,
00055         _In_ IPrintDocumentPackageTarget*   docPackageTarget
00056         );
00057
00058     //
00059     // classic COM interface IPrintPreviewPageCollection methods
00060     //
00061     IFACEMETHODIMP
00062     Paginate(
00063         _In_   uint32           currentJobPage,
00064         _In_   IInspectable*    docOptions
00065         );
00066
00067     IFACEMETHODIMP
00068     MakePage(
00069         _In_ uint32 desiredJobPage,
00070         _In_ float  width,
00071         _In_ float  height
00072         );
00073
00074 private:
00075
00076     float
00077     TransformedPageSize(
00078         _In_  float                         desiredWidth,
00079         _In_  float                         desiredHeight,
00080         _Out_ Windows::Foundation::Size*    previewSize
00081         );
00082
00083     uint32                                                  m_totalPages;
00084     bool                                                    m_paginateCalled;
00085     float                                                   m_height;
00086     float                                                   m_width;
00087     D2D1_RECT_F                                             m_imageableRect;
00088     PageRenderer^                                           m_renderer;
00089     Microsoft::WRL::ComPtr<IPrintPreviewDxgiPackageTarget>  m_dxgiPreviewTarget;
00090 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/TileUpdateScheduler.h Source File

  • Hilo C++
  • Hilo

TileUpdateScheduler.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     class ExceptionPolicy;
00012     class Repository;
00013
00014     // See http://go.microsoft.com/fwlink/?LinkId=267275 for info about Hilo's implementation of tiles.
00015
00016     // The TileUpdateScheduler class keeps Hilo's start tile up to date.
00017     class TileUpdateScheduler
00018     {
00019     public:
00020         TileUpdateScheduler();
00021         concurrency::task<void> TileUpdateScheduler::ScheduleUpdateAsync(std::shared_ptr<Repository> repository, std::shared_ptr<ExceptionPolicy>  exceptionPolicy);
00022
00023     private:
00024         void TileUpdateScheduler::UpdateTile(Windows::Foundation::Collections::IVector<Windows::Storage::StorageFile^>^ files);
00025     };
00026 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DDS_HEADER Member List

This is the complete list of members for DDS_HEADER, including all inherited members.
caps | DDS_HEADER
caps2 | DDS_HEADER
caps3 | DDS_HEADER
caps4 | DDS_HEADER
ddspf | DDS_HEADER
depth | DDS_HEADER
flags | DDS_HEADER
height | DDS_HEADER
mipMapCount | DDS_HEADER
pitchOrLinearSize | DDS_HEADER
reserved1 | DDS_HEADER
reserved2 | DDS_HEADER
size | DDS_HEADER
width | DDS_HEADER
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/App.xaml.h Source File

  • UI contrast and settings

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/common/LayoutAwarePage.cpp Source File

  • Inclinometer sensor
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Constants.cpp Source File

  • Inclinometer sensor

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     { "Inclinometer data events", "SDKSample.InclinometerCPP.Scenario1" },
00020     { "Poll inclinometer readings", "SDKSample.InclinometerCPP.Scenario2" }
00021 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicShapes.cpp Source File

  • DirectX marble maze game

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/common/suspensionmanager.h Source File

  • CameraCaptureUI
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/pch.h Source File

  • XAML vector-based drawing

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DirectX::D3DX_BC6H::ModeDescriptor Member List

This is the complete list of members for DirectX::D3DX_BC6H::ModeDescriptor, including all inherited members.
m_eField | DirectX::D3DX_BC6H::ModeDescriptor
m_uBit | DirectX::D3DX_BC6H::ModeDescriptor
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageUtilities.h Source File

  • Hilo C++
  • Hilo

ImageUtilities.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 byte* GetPointerToPixelData(Windows::Storage::Streams::IBuffer^ buffer);
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::DeviceEnumeration::sealed Member List

This is the complete list of members for SDKSample::DeviceEnumeration::sealed, including all inherited members.
ContainerDisplayItem(String^id, String^name, String^properties) | SDKSample::DeviceEnumeration::sealed | [inline]
Containers() | SDKSample::DeviceEnumeration::sealed |
DisplayDeviceContainer(PnpObject^container) | SDKSample::DeviceEnumeration::sealed | [private]
DisplayDeviceInterface(DeviceInformation^deviceInterface) | SDKSample::DeviceEnumeration::sealed | [private]
EnumerateDeviceContainers(Object^sender, RoutedEventArgs^eventArgs) | SDKSample::DeviceEnumeration::sealed | [private]
EnumerateDeviceInterfaces(Object^sender, RoutedEventArgs^eventArgs) | SDKSample::DeviceEnumeration::sealed | [private]
glyphThumbnail | SDKSample::DeviceEnumeration::sealed |
InterfaceClasses_SelectionChanged(Object^sender, SelectionChangedEventArgs^eventArgs) | SDKSample::DeviceEnumeration::sealed | [private]
InterfaceDisplayItem(String^id, String^name, String^isEnabled) | SDKSample::DeviceEnumeration::sealed | [inline]
Interfaces() | SDKSample::DeviceEnumeration::sealed |
isEnabled | SDKSample::DeviceEnumeration::sealed |
name | SDKSample::DeviceEnumeration::sealed |
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::DeviceEnumeration::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::DeviceEnumeration::sealed | [protected, virtual]
properties | SDKSample::DeviceEnumeration::sealed |
rootPage | SDKSample::DeviceEnumeration::sealed | [private]
thumbnail | SDKSample::DeviceEnumeration::sealed |
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/common/LayoutAwarePage.h Source File

  • Date and time formatting
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/MainPage.xaml.cpp Source File

  • XAML Popup

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level.cpp Source File

  • DirectX 3D shooting game

Level.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Level.h"
00010
00011 //----------------------------------------------------------------------
00012
00013 bool Level::Update(
00014     float /* time */,
00015     float /* elapsedTime */,
00016     float /* timeRemaining*/,
00017     std::vector<GameObject^> objects
00018     )
00019 {
00020     int left = 0;
00021
00022     for (auto object = objects.begin(); object != objects.end(); object++)
00023     {
00024         if ((*object)->Active() && (*object)->Target())
00025         {
00026             if ((*object)->Hit())
00027             {
00028                 (*object)->Active(false);
00029             }
00030             else
00031             {
00032                 left++;
00033             }
00034         }
00035     }
00036     return (left == 0);
00037 }
00038
00039 //----------------------------------------------------------------------
00040
00041 void Level::SaveState(PersistentState^ /* state */)
00042 {
00043 }
00044
00045 //----------------------------------------------------------------------
00046
00047 void Level::LoadState(PersistentState^ /* state */)
00048 {
00049 }
00050
00051 //----------------------------------------------------------------------
00052
00053 Platform::String^ Level::Objective()
00054 {
00055     return m_objective;
00056 }
00057
00058 //----------------------------------------------------------------------
00059
00060 float Level::TimeLimit()
00061 {
00062     return m_timeLimit;
00063 }
00064
00065 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ReadStreamTask::ReadStreamTaskImpl Member List

This is the complete list of members for ReadStreamTask::ReadStreamTaskImpl, including all inherited members.
_CompletionEvent | ReadStreamTask::ReadStreamTaskImpl |
_Destination | ReadStreamTask::ReadStreamTaskImpl |
_Reader | ReadStreamTask::ReadStreamTaskImpl |
_StreamData | ReadStreamTask::ReadStreamTaskImpl |
_Task | ReadStreamTask::ReadStreamTaskImpl |
ReadChunk() | ReadStreamTask::ReadStreamTaskImpl | [inline]
ReadStreamTaskImpl(IInputStream^Stream, std::vector< byte > &Destination) | ReadStreamTask::ReadStreamTaskImpl | [inline]
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/Constants.cpp Source File

  • Syndication

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "Get a Feed", "SDKSample.Syndication.Scenario1" },
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

EaseInExponentialAnimation< T > Member List

This is the complete list of members for EaseInExponentialAnimation< T >, including all inherited members.
Animation(T start, T end, T duration) | Animation< T > | [inline]
ComputeValue(T time) | EaseInExponentialAnimation< T > | [inline, protected, virtual]
EaseInExponentialAnimation(T start=0, T end=0, T duration=0) | EaseInExponentialAnimation< T > | [inline]
GetDuration() | Animation< T > | [inline]
GetEnd() | Animation< T > | [inline]
GetStart() | Animation< T > | [inline]
GetValue(T time) | Animation< T > | [inline]
m_Duration | Animation< T > | [protected]
m_End | Animation< T > | [protected]
m_Start | Animation< T > | [protected]
SetDuration(T duration) | Animation< T > | [inline]
SetEnd(T end) | Animation< T > | [inline]
SetStart(T start) | Animation< T > | [inline]
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Collision.h Source File

  • DirectX marble maze game

Collision.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // The material types for each of the collision meshes
00011 enum class MeshID
00012 {
00013     Wall,
00014     Ground,
00015     Floor,
00016 };
00017
00018 // A contact or penetration of the mesh with the ball
00019 // Using a struct so that this can be stack allocated
00020 struct Contact
00021 {
00022     XMFLOAT4 plane;
00023     XMFLOAT3 contactPosition;
00024     float closingVelocity;
00025     float penetrationDistance;
00026     BOOL contactIsEdge;
00027     Triangle triangle;
00028     MeshID meshID;
00029     size_t triIndex;
00030
00031     Contact(const Triangle& tri, size_t index, MeshID mesh) :
00032         triangle(tri),
00033         triIndex(index),
00034         meshID(mesh)
00035     {
00036         plane = tri.plane;
00037     }
00038
00039     FORCEINLINE XMVECTOR GetSurfaceNormal() const
00040     {
00041         return XMLoadFloat3((XMFLOAT3*) &plane);
00042     }
00043
00044     BOOL IsColliding() const
00045     {
00046         const float MIN_COLLISION_DISTANCE = -1.0E-5f;
00047         return penetrationDistance <= MIN_COLLISION_DISTANCE;
00048     }
00049
00050     void Invalidate()
00051     {
00052         penetrationDistance = FLT_MAX;
00053     }
00054
00055     XMVECTOR Resolve(FXMVECTOR position, FXMVECTOR radius);
00056
00057     BOOL CalculateContact(FXMVECTOR position, FXMVECTOR radiusIn, FXMVECTOR path);
00058 };
00059
00060 // The collision engine
00061 class Collision
00062 {
00063 private:
00064     BOOL m_intersectsGround;
00065
00066 public:
00067     std::vector<Triangle> m_groundTriList;
00068     std::vector<Triangle> m_wallTriList;
00069     std::vector<Triangle> m_floorTriList;
00070     std::vector<Contact> m_collisions;
00071
00072     Collision() :
00073         m_intersectsGround(FALSE)
00074     {
00075     }
00076
00077     inline BOOL IntersectsWithGround() const
00078     {
00079         return m_intersectsGround;
00080     }
00081
00082     BOOL BuildCollisionListForSphere(const Sphere& meshLocalSpace, FXMVECTOR path);
00083     Contact* FindWorstInterpenetration();
00084     void UpdateInterpenetrations(FXMVECTOR newPosition, FXMVECTOR radius, FXMVECTOR path);
00085
00086 private:
00087     void MergeSharedEdgeCoplanarContacts(FXMVECTOR sphere, FXMVECTOR radius, FXMVECTOR path);
00088     BOOL AccumulateSphereTriangleIntersections(
00089         FXMVECTOR sphere,
00090         FXMVECTOR radius,
00091         FXMVECTOR path,
00092         MeshID mesh,
00093         const std::vector<Triangle>& triList
00094         );
00095 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveFileInput.xaml.h Source File

  • Association launching

ReceiveFileInput.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // ReceiveFileInput.xaml.h
00009 // Declaration of the ReceiveFileInput class.
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "ReceiveFileInput.g.h"
00016 #include "MainPage.xaml.h"
00017
00018 using namespace Windows::UI::Xaml;
00019
00020 namespace AssociationLaunching
00021 {
00022   [Windows::Foundation::Metadata::WebHostHidden]
00023     public ref class ReceiveFileInput sealed
00024     {
00025     public:
00026         ReceiveFileInput();
00027
00028     protected:
00029         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~ReceiveFileInput();
00033         MainPage^ rootPage;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/repeater.h Source File

  • Custom driver access
  • C#,C++
  • DLL

repeater.h

Go to the documentation of this file.
00001 #include <strsafe.h>
00002 #include <assert.h>
00003
00004 #include <functional>
00005 #include <mutex>
00006
00007 #include <ppltasks.h>
00008
00009 #pragma once
00010
00011 namespace Samples {
00012     namespace Devices {
00013
00014         // Implementation details
00015         namespace Details {
00016             // The type of task the StartTaskFunction() returns.  The bool indicates whether the next
00017             // iteration should start.
00018             typedef concurrency::task<bool> RepeaterTaskType;
00019
00020             // The type of function the creator provides to run each iteration.  It returns a task
00021             // which the repeater chains onto.
00022             typedef std::function<RepeaterTaskType (concurrency::cancellation_token, concurrency::task_continuation_context)> StartRepeaterTaskFunction;
00023
00024             // The type of the function the creator calls once the repeater is stopped.
00025             typedef std::function<void(void)> RepeaterStoppedFunction;
00026         }
00027
00028         // The repeater class performs a task over and over again.  It can be used
00029         // to issue a device I/O repeatedly - for example reading events from the
00030         // device.
00031         class Repeater {
00032         public:
00033
00034             // The state of the repeater.  It is initialized in the stopped state.
00035             enum class RepeaterState {
00036                 Stopped,
00037                 Running,
00038                 Stopping
00039             };
00040
00041         private:
00042             // The function to call when starting each iteration of the repeater
00043             Details::StartRepeaterTaskFunction m_StartTaskFunction;
00044
00045             // The source of cancellation tokens passed to the start task function
00046             concurrency::cancellation_token_source m_Canceller;
00047
00048             // Whether the repeater is active, stopping or stopped.
00049             RepeaterState m_State;
00050
00051             // Lock to protect the state.  The task chains are created under this
00052             // lock, but they execute without the lock.
00053             std::mutex m_Lock;
00054
00055             // shorthand for our mutex's lock type (mlt)
00056             typedef std::unique_lock<std::mutex> mlt;
00057
00058             // An optional function to call once the repeater is stopped
00059             // TODO: should Stop return a task that the caller can .then?
00060             Details::RepeaterStoppedFunction m_RepeaterStoppedFunction;
00061
00062         public:
00063             Repeater() : m_StartTaskFunction(nullptr),
00064                          m_State(RepeaterState::Stopped),
00065                          m_RepeaterStoppedFunction(nullptr)
00066             {
00067                 return;
00068             }
00069
00070             ~Repeater()
00071             {
00072                 // TODO: Move the core of the repeater to an allocated
00073                 //       object that i can let run down on its own on destruction.  For now
00074                 //       !! don't delete a repeater that's still running !!
00075                 assert(m_State == RepeaterState::Stopped);
00076             }
00077
00078             // Starts the repeater.  Each iteration calls StartTaskFunction to kick off a chain of tasks.
00079             // The repeater then adds a task to the end of the chain that fires off the next iteration
00080             // Caller can provide a context that plumbs through to the start functions, or use current
00081             void Start(
00082                 Details::StartRepeaterTaskFunction StartTaskFunction,
00083                 concurrency::task_continuation_context Context = concurrency::task_continuation_context::use_current()
00084                 )
00085             {
00086                 // lock the mutex
00087                 mlt lock(m_Lock);
00088
00089                 assert(m_State == RepeaterState::Stopped);
00090
00091                 if (m_State == RepeaterState::Stopped) {
00092                     m_StartTaskFunction = StartTaskFunction;
00093                     m_RepeaterStoppedFunction = nullptr;
00094
00095                     // Get a new canceller before we start the tasks
00096                     auto c = concurrency::cancellation_token_source();
00097                     m_Canceller = std::move(c);
00098
00099                     // Update task state before starting the task so that it can
00100                     // restart itself properly.
00101                     m_State = RepeaterState::Running;
00102                     StartTask(Context);
00103                 }
00104             }
00105
00106             // Stop the repeater.  This will cancel the current task (caller's task
00107             // needs to have registered for cancellation).  Caller can optionally provide a
00108             // callback that the last task will invoke.
00109             bool Stop(Details::RepeaterStoppedFunction* callback = nullptr)
00110             {
00111                 mlt lock(m_Lock);
00112                 bool active;
00113
00114                 if (m_State == RepeaterState::Running) {
00115                     m_State = RepeaterState::Stopping;
00116                     m_Canceller.cancel();
00117
00118                     active = true;
00119                 } else if (m_State == RepeaterState::Stopping) {
00120                     active = true;
00121                 } else {
00122                     active = false;
00123                 }
00124
00125                 if (callback) {
00126                     if (active == true) {
00127                         m_RepeaterStoppedFunction = *callback;
00128                         lock.release();
00129                     }
00130                 }
00131
00132                 return active;
00133             }
00134
00135             // The current state of the repeater.
00136             RepeaterState GetState(void)
00137             {
00138                 return m_State;
00139             }
00140
00141         private:
00142
00143             // Creates the task chain, and appends the restart task to it
00144             void StartTask(concurrency::task_continuation_context context) {
00145                 // start the caller's task and add a restart task onto
00146                 // the end.
00147                 m_StartTaskFunction(m_Canceller.get_token(), context).
00148                     then([this, context](bool b) {
00149                         RestartTask(context, b);
00150                     }
00151                 );
00152             }
00153
00154             // The restart task mentioned above.  If the repeater is still running &
00155             // the previous iteration didn't return false, it calls StartTask() to
00156             // fire off the next iteration.  Otherwise it handles rundown.
00157             void RestartTask(concurrency::task_continuation_context context, bool Continue) {
00158                 // Check and see if the task is still running
00159                 mlt lock(m_Lock);
00160
00161                 if (Continue == false) {
00162                     m_State = RepeaterState::Stopping;
00163                 }
00164                 if (m_State == RepeaterState::Running) {
00165                     StartTask(context);
00166                 } else if (m_State == RepeaterState::Stopping) {
00167                     m_State = RepeaterState::Stopped;
00168                     if (m_RepeaterStoppedFunction != nullptr) {
00169                         Details::RepeaterStoppedFunction callback = m_RepeaterStoppedFunction;
00170                         m_RepeaterStoppedFunction = nullptr;
00171                         lock.release();
00172                         callback();
00173                     }
00174                 }
00175             }
00176         };
00177
00178
00179     }
00180 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Constants.cpp Source File

  • Scaling according to DPI

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     { "Load images for different scales",         "SDKSample.Scaling.Scenario1" },
00020     { "Override default scaling of UI elements",  "SDKSample.Scaling.Scenario2" },
00021 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/SampleOverlay.h Source File

  • Direct3D bump mapping

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MainPage.xaml.h Source File

  • XAML DirectX 3D shooting game

MainPage.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "MainPage.g.h"
00011 #include "ProductItem.h"
00012
00013 namespace Simple3DGameXaml
00014 {
00015     ref class App;
00016
00017     public enum class GameInfoOverlayCommand
00018     {
00019         None,
00020         TapToContinue,
00021         PleaseWait,
00022         PlayAgain,
00023     };
00024
00025     [Windows::Foundation::Metadata::WebHostHidden]
00026     public ref class MainPage sealed
00027     {
00028     public:
00029         MainPage();
00030
00031         void SetApp(App^ app);
00032         void SetGameLoading();
00033         void SetGameStats(int maxLevel, int hitCount, int shotCount);
00034         void SetGameOver(bool win, int maxLevel, int hitCount, int shotCount, int highScore);
00035         void SetLevelStart(int level, Platform::String^ objective, float timeLimit, float bonusTime);
00036         void SetPause(int level, int hitCount, int shotCount, float timeRemaining);
00037         void SetSnapped();
00038         void HideSnapped();
00039         void SetAction(GameInfoOverlayCommand action);
00040         void HideGameInfoOverlay();
00041         void ShowGameInfoOverlay();
00042         void LicenseChanged(
00043             Windows::ApplicationModel::Store::ListingInformation^ listing,
00044             Windows::ApplicationModel::Store::LicenseInformation^ license
00045             );
00046         void SetProductItems(
00047             Windows::ApplicationModel::Store::ListingInformation^ listing,
00048             Windows::ApplicationModel::Store::LicenseInformation^ license
00049             );
00050         void OnWindowSizeChanged();
00051
00052         Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^ GetSwapChainBackgroundPanel() { return DXSwapChainPanel; };
00053
00054     protected:
00055         void OnPlayButtonClicked(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ args);
00056         void OnResetButtonClicked(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ args);
00057         void OnBuyAppButtonTapped(Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ args);
00058         void OnBuySelectorClicked(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ args);
00059         void OnChangeBackgroundButtonClicked(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ args);
00060         void OnResetLicenseButtonClicked(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ args);
00061         void OnGameInfoOverlayTapped(Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ args);
00062         void OnAppBarOpened(Object^ sender, Object^ args);
00063         void OnStoreReturnClicked(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ args);
00064         void OnLoadStoreClicked(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ args);
00065
00066         void OptionalTrialUpgrade();
00067         void ShowStoreFlyout();
00068
00069     private:
00070         App^ m_app;
00071         Windows::ApplicationModel::Store::LicenseInformation^ m_licenseInformation;
00072         Windows::ApplicationModel::Store::ListingInformation^ m_listingInformation;
00073         bool m_possiblePurchaseUpgrade;
00074     };
00075 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario1.xaml.cpp Source File

  • XAML images

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::Images;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario1::Scenario1()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 // Invoked when this page is about to be displayed in a Frame.
00031
00032 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00033 {
00034     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00035     // as NotifyUser()
00036     rootPage = MainPage::Current;
00037 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/DirectXSample.h Source File

  • DirectWrite hello world

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicCamera.cpp Source File

  • Direct3D tutorial
  • Lesson5.Components

BasicCamera.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicCamera.h"
00010
00011 void BasicCamera::GetViewMatrix(_Out_ float4x4 *viewMatrix)
00012 {
00013     *viewMatrix = m_view;
00014 }
00015
00016 void BasicCamera::GetProjectionMatrix(_Out_ float4x4 *projectionMatrix)
00017 {
00018     *projectionMatrix = m_projection;
00019 }
00020
00021 // this method updates the view matrix based on new position and focus coordinates
00022 void BasicCamera::SetViewParameters(
00023     _In_ float3 eyePosition,    // the position of the camera
00024     _In_ float3 lookPosition,   // the point the camera should look at
00025     _In_ float3 up              // the durection vector for up
00026     )
00027 {
00028     m_position = eyePosition;
00029     m_direction = normalize(lookPosition - eyePosition);
00030     float3 zAxis = -m_direction;
00031     float3 xAxis = normalize(cross(up, zAxis));
00032     float3 yAxis = cross(zAxis, xAxis);
00033     float xOffset = -dot(xAxis, m_position);
00034     float yOffset = -dot(yAxis, m_position);
00035     float zOffset = -dot(zAxis, m_position);
00036     m_view = float4x4(
00037         xAxis.x, xAxis.y, xAxis.z, xOffset,
00038         yAxis.x, yAxis.y, yAxis.z, yOffset,
00039         zAxis.x, zAxis.y, zAxis.z, zOffset,
00040         0.0f,    0.0f,    0.0f,    1.0f
00041         );
00042 }
00043     // this method updates the projection matrix based on new parameters
00044 void BasicCamera::SetProjectionParameters(
00045     _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00046     _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00047     _In_ float nearPlane,           // depth to map to 0
00048     _In_ float farPlane             // depth to map to 1
00049     )
00050 {
00051     float minScale = 1.0f / tan(minimumFieldOfView * PI_F / 360.0f);
00052     float xScale = 1.0f;
00053     float yScale = 1.0f;
00054     if (aspectRatio < 1.0f)
00055     {
00056         xScale = minScale;
00057         yScale = minScale * aspectRatio;
00058     }
00059     else
00060     {
00061         xScale = minScale / aspectRatio;
00062         yScale = minScale;
00063     }
00064     float zScale = farPlane / (farPlane - nearPlane);
00065     m_projection = float4x4(
00066         xScale, 0.0f,   0.0f,    0.0f,
00067         0.0f,   yScale, 0.0f,    0.0f,
00068         0.0f,   0.0f,   -zScale, -nearPlane*zScale,
00069         0.0f,   0.0f,   -1.0f,   0.0f
00070         );
00071 }
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

FontFileStream Member List

This is the complete list of members for FontFileStream, including all inherited members.
AddRef() override | FontFileStream | [virtual]
FontFileStream(_In_ Platform::Array< byte >^data) | FontFileStream |
GetFileSize(_Out_ UINT64 *fileSize) override | FontFileStream | [virtual]
GetLastWriteTime(_Out_ UINT64 *lastWriteTime) override | FontFileStream | [virtual]
m_data | FontFileStream | [private]
m_refCount | FontFileStream | [private]
QueryInterface(REFIID uuid, _Outptr_ void **object) override | FontFileStream | [virtual]
ReadFileFragment(_Outptr_result_bytebuffer_(fragmentSize) void const **fragmentStart, UINT64 fileOffset, UINT64 fragmentSize, _Out_ void **fragmentContext) override | FontFileStream | [virtual]
Release() override | FontFileStream | [virtual]
ReleaseFileFragment(_In_ void *fragmentContext) override | FontFileStream | [virtual]
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/InternetConnectionProfile.xaml.cpp Source File

  • Network information

InternetConnectionProfile.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // InternetConnectionProfile.xaml.cpp
00013 // Implementation of the InternetConnectionProfile class
00014 //
00015
00016 #include "pch.h"
00017 #include "InternetConnectionProfile.xaml.h"
00018
00019 using namespace SDKSample::NetworkInformationApi;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::System;
00025 using namespace Windows::Foundation;
00026 using namespace Platform;
00027 using namespace Windows::Networking;
00028 using namespace Windows::Networking::Connectivity;
00029
00030 InternetConnectionProfile::InternetConnectionProfile()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void InternetConnectionProfile::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00043     // as NotifyUser()
00044     rootPage = MainPage::Current;
00045 }
00046
00047 // Get Connection Cost based suggestions
00048 String^ InternetConnectionProfile::GetCostBasedSuggestions(ConnectionCost^ connectionCost)
00049 {
00050     String^ strRet = "";
00051
00052     strRet = L"Cost Based Suggestions: \n";
00053     if (connectionCost->Roaming)
00054     {
00055         strRet += L"Connection is out of MNO's network, using the connection may result in additional charge. Application can implement High Cost behavior in this scenario\n";
00056     }
00057     else if (connectionCost->NetworkCostType == NetworkCostType::Variable)
00058     {
00059         strRet += L"Connection cost is variable, and the connection is charged based on usage, so application can implement the Conservative behavior\n";
00060     }
00061     else if (connectionCost->NetworkCostType == NetworkCostType::Fixed)
00062     {
00063         if (connectionCost->OverDataLimit || connectionCost->ApproachingDataLimit)
00064         {
00065             strRet += L"Connection has exceeded the usage cap limit or is approaching the datalimit, and the application can implement High Cost behavior in this scenario\n";
00066         }
00067         else
00068         {
00069             strRet += L"Application can implemement the Conservative behavior\n";
00070         }
00071     }
00072     else
00073     {
00074         strRet += L"Application can implement the Standard behavior\n";
00075     }
00076
00077     return strRet;
00078 }
00079
00080 // Get Connection Cost information
00081 String^ InternetConnectionProfile::GetConnectionCostInfo(ConnectionCost^ connectionCost)
00082 {
00083     String^ strRet = "";
00084
00085     if (connectionCost == nullptr)
00086     {
00087         return strRet;
00088     }
00089
00090     strRet = L"Connection Cost Information: \n";
00091     strRet += L"====================\n";
00092     switch(connectionCost->NetworkCostType)
00093     {
00094         case NetworkCostType::Unrestricted:
00095             strRet += L"Cost: Unrestricted\n";
00096             break;
00097         case NetworkCostType::Fixed:
00098             strRet += L"Cost: Fixed\n";
00099             break;
00100         case NetworkCostType::Variable:
00101             strRet += L"Cost: Variable\n";
00102             break;
00103         case NetworkCostType::Unknown:
00104             strRet += L"Cost: Unknown\n";
00105             break;
00106         default:
00107             strRet += L"Cost: Error\n";
00108             break;
00109     }
00110
00111     if (connectionCost->Roaming)
00112     {
00113         strRet += L"Roaming    : Yes\n";
00114     }
00115     else
00116     {
00117         strRet += L"Roaming    : No\n";
00118     }
00119
00120     if (connectionCost->OverDataLimit)
00121     {
00122         strRet += L"OverDataLimit    : Yes\n";
00123     }
00124     else
00125     {
00126         strRet += L"OverDataLimit    : No\n";
00127     }
00128
00129     if (connectionCost->ApproachingDataLimit)
00130     {
00131         strRet += L"ApproachingDataLimit    : Yes\n";
00132     }
00133     else
00134     {
00135         strRet += L"ApproachingDataLimit    : No\n";
00136     }
00137
00138     //Get cost based suggestions
00139     strRet += GetCostBasedSuggestions(connectionCost);
00140     return strRet;
00141 }
00142
00143 // Get Dataplan Status Information
00144 String^ InternetConnectionProfile::GetDataPlanStatusInfo(DataPlanStatus^ dataPlan)
00145 {
00146     String ^strRet = "";
00147
00148     if (dataPlan == nullptr)
00149     {
00150         return strRet;
00151     }
00152
00153     strRet = L"Dataplan Status Information: \n";
00154     strRet += L"====================\n";
00155
00156     if (dataPlan->DataPlanUsage != nullptr)
00157     {
00158         auto lastSyncTime = dataPlan->DataPlanUsage->LastSyncTime;
00159         ULARGE_INTEGER lst;
00160         lst.QuadPart = lastSyncTime.UniversalTime;
00161         FILETIME ftLastSyncTime;
00162         SYSTEMTIME stLastSyncTime;
00163
00164         //get FILETIME from lastSyncTime, convert FILETIME to SYSTEMTIME and display
00165         ftLastSyncTime.dwLowDateTime = lst.LowPart;
00166         ftLastSyncTime.dwHighDateTime = lst.HighPart;
00167         FileTimeToSystemTime(&ftLastSyncTime, &stLastSyncTime);
00168         strRet += L"Usage In Megabytes : " + dataPlan->DataPlanUsage->MegabytesUsed.ToString() + "\n";
00169         strRet += L"LastSyncTime: " + stLastSyncTime.wMonth.ToString() + "/" + stLastSyncTime.wDay.ToString() + "/" + stLastSyncTime.wYear.ToString() + " " + stLastSyncTime.wHour.ToString() + ":" + stLastSyncTime.wMinute.ToString() + ":"+ stLastSyncTime.wSecond.ToString() + "\n";
00170     }
00171     else
00172     {
00173         strRet += L"DataPlan Usage : Not Defined\n";
00174     }
00175
00176     if (dataPlan->InboundBitsPerSecond != nullptr)
00177     {
00178         auto inboundBandwidth = dataPlan->InboundBitsPerSecond->Value;
00179         strRet += L"InboundBitsPerSecond : " + inboundBandwidth.ToString() + "\n";
00180     }
00181     else
00182     {
00183         strRet += L"InboundBitsPerSecond : Not Defined\n";
00184     }
00185
00186     if (dataPlan->OutboundBitsPerSecond != nullptr)
00187     {
00188         auto outboundBandwidth = dataPlan->OutboundBitsPerSecond->Value;
00189         strRet += L"OutboundBitsPerSecond : " + outboundBandwidth.ToString() + "\n";
00190     }
00191     else
00192     {
00193         strRet += L"OutboundBitsPerSecond : Not Defined\n";
00194     }
00195
00196     if (dataPlan->DataLimitInMegabytes != nullptr)
00197     {
00198         auto dataLimit = dataPlan->DataLimitInMegabytes->Value;
00199         strRet += L"DataLimitInMegabytes : " + dataLimit.ToString() + "\n";
00200
00201     }
00202     else
00203     {
00204         strRet += L"DataLimitInMegabytes : Not Defined\n";
00205     }
00206
00207     if (dataPlan->NextBillingCycle != nullptr)
00208     {
00209         auto nextBillingCycle = dataPlan->NextBillingCycle->Value;
00210         ULARGE_INTEGER nbc;
00211         nbc.QuadPart = nextBillingCycle.UniversalTime;
00212         FILETIME ftNextBillingCycle;
00213         SYSTEMTIME stNextBillingCycle;
00214
00215         //get FILETIME from NextBillingCycle, convert to FILETIME to SYSTEMTIME and display
00216         ftNextBillingCycle.dwLowDateTime = nbc.LowPart;
00217         ftNextBillingCycle.dwHighDateTime = nbc.HighPart;
00218         FileTimeToSystemTime(&ftNextBillingCycle, &stNextBillingCycle);
00219         strRet += L"NextBillingCycle: " + stNextBillingCycle.wMonth.ToString() + "/" + stNextBillingCycle.wDay.ToString() + "/" + stNextBillingCycle.wYear.ToString() + " " + stNextBillingCycle.wHour.ToString() + ":" + stNextBillingCycle.wMinute.ToString() + ":" + stNextBillingCycle.wSecond.ToString() + "\n";
00220     }
00221     else
00222     {
00223         strRet += L"NextBillingCycle : Not Defined\n";
00224     }
00225
00226     if (dataPlan->MaxTransferSizeInMegabytes != nullptr)
00227     {
00228         auto transferSize = dataPlan->MaxTransferSizeInMegabytes->Value;
00229         strRet += L"MaxTransferSizeInMegabytes : " + transferSize.ToString() + "\n";
00230     }
00231     else
00232     {
00233         strRet += L"MaxTransferSizeInMegabytes : Not Defined\n";
00234     }
00235
00236     return strRet;
00237 }
00238
00239
00240
00241 // Get Network Security Settings information
00242
00243 String^ InternetConnectionProfile::GetNetworkSecuritySettingsInfo(NetworkSecuritySettings^ netSecuritySettings)
00244 {
00245     String^ networkSecurity = "";
00246     networkSecurity += L"Network Security Settings: \n";
00247     networkSecurity += L"====================\n";
00248
00249     if (netSecuritySettings == nullptr)
00250     {
00251         networkSecurity += L"Network Security Settings not available\n";
00252         return networkSecurity;
00253     }
00254
00255     //NetworkAuthenticationType
00256     switch (netSecuritySettings->NetworkAuthenticationType)
00257     {
00258         case NetworkAuthenticationType::None:
00259             networkSecurity += L"NetworkAuthenticationType: None";
00260             break;
00261         case NetworkAuthenticationType::Unknown:
00262             networkSecurity += L"NetworkAuthenticationType: Unknown";
00263             break;
00264         case NetworkAuthenticationType::Open80211:
00265             networkSecurity += L"NetworkAuthenticationType: Open80211";
00266             break;
00267         case NetworkAuthenticationType::SharedKey80211:
00268             networkSecurity += L"NetworkAuthenticationType: SharedKey80211";
00269             break;
00270         case NetworkAuthenticationType::Wpa:
00271             networkSecurity += L"NetworkAuthenticationType: Wpa";
00272             break;
00273         case NetworkAuthenticationType::WpaPsk:
00274             networkSecurity += L"NetworkAuthenticationType: WpaPsk";
00275             break;
00276         case NetworkAuthenticationType::WpaNone:
00277             networkSecurity += L"NetworkAuthenticationType: WpaNone";
00278             break;
00279         case NetworkAuthenticationType::Rsna:
00280             networkSecurity += L"NetworkAuthenticationType: Rsna";
00281             break;
00282         case NetworkAuthenticationType::RsnaPsk:
00283             networkSecurity += L"NetworkAuthenticationType: RsnaPsk";
00284             break;
00285         default:
00286             networkSecurity += L"NetworkAuthenticationType: Error";
00287             break;
00288     }
00289     networkSecurity += L"\n";
00290
00291     //NetworkEncryptionType
00292     switch (netSecuritySettings->NetworkEncryptionType)
00293     {
00294         case NetworkEncryptionType::None:
00295             networkSecurity += L"NetworkEncryptionType: None";
00296             break;
00297         case NetworkEncryptionType::Unknown:
00298             networkSecurity += L"NetworkEncryptionType: Unknown";
00299             break;
00300         case NetworkEncryptionType::Wep:
00301             networkSecurity += L"NetworkEncryptionType: Wep";
00302             break;
00303         case NetworkEncryptionType::Wep40:
00304             networkSecurity += L"NetworkEncryptionType: Wep40";
00305             break;
00306         case NetworkEncryptionType::Wep104:
00307             networkSecurity += L"NetworkEncryptionType: Wep104";
00308             break;
00309         case NetworkEncryptionType::Tkip:
00310             networkSecurity += L"NetworkEncryptionType: Tkip";
00311             break;
00312         case NetworkEncryptionType::Ccmp:
00313             networkSecurity += L"NetworkEncryptionType: Ccmp";
00314             break;
00315         case NetworkEncryptionType::WpaUseGroup:
00316             networkSecurity += L"NetworkEncryptionType: WpaUseGroup";
00317             break;
00318         case NetworkEncryptionType::RsnUseGroup:
00319             networkSecurity += L"NetworkEncryptionType: RsnUseGroup";
00320             break;
00321         default:
00322             networkSecurity += L"NetworkEncryptionType: Error";
00323             break;
00324     }
00325     networkSecurity += L"\n";
00326     return networkSecurity;
00327 }
00328
00329
00330 // Get Connection Profile Information
00331 String^ InternetConnectionProfile::GetConnectionProfile(ConnectionProfile^ connectionProfile)
00332 {
00333     String^ strProfileInfo = "";
00334
00335     switch (connectionProfile->GetNetworkConnectivityLevel())
00336     {
00337         case NetworkConnectivityLevel::None:
00338             strProfileInfo += "Connectivity Level : None\n";
00339             break;
00340         case NetworkConnectivityLevel::LocalAccess:
00341             strProfileInfo += "Connectivity Level : Local Access\n";
00342             break;
00343         case NetworkConnectivityLevel::ConstrainedInternetAccess:
00344             strProfileInfo += "Connectivity Level : Constrained Internet Access\n";
00345             break;
00346         case NetworkConnectivityLevel::InternetAccess:
00347             strProfileInfo += "Connectivity Level : Internet Access\n";
00348             break;
00349     }
00350
00351     // Get Connection Cost information
00352     ConnectionCost^ connectionCost = connectionProfile->GetConnectionCost();
00353     strProfileInfo += GetConnectionCostInfo(connectionCost);
00354
00355     // Get Dataplan Status information
00356     DataPlanStatus^ dataPlan = connectionProfile->GetDataPlanStatus();
00357     strProfileInfo += GetDataPlanStatusInfo(dataPlan);
00358
00359
00360     //Get Network Security Settings
00361     NetworkSecuritySettings^ netSecuritySettings = connectionProfile->NetworkSecuritySettings;
00362     strProfileInfo += GetNetworkSecuritySettingsInfo(netSecuritySettings);
00363
00364     return strProfileInfo;
00365 }
00366
00367 // Display Internet Connection Profile information
00368 void SDKSample::NetworkInformationApi::InternetConnectionProfile::InternetConnectionProfile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00369 {
00370     try
00371     {
00372         //Display Internet Connection Profile information to the user
00373         ConnectionProfile^ InternetConnectionProfile = NetworkInformation::GetInternetConnectionProfile();
00374         if (InternetConnectionProfile != nullptr)
00375         {
00376             String^ strConnectionProfileInfo = GetConnectionProfile(InternetConnectionProfile);
00377             rootPage->NotifyUser(L"Profile Name : " + InternetConnectionProfile->ProfileName + L"\n" + strConnectionProfileInfo, NotifyType::StatusMessage);
00378         }
00379         else
00380         {
00381             rootPage->NotifyUser(L"Internet Connection Profile Information not found", NotifyType::StatusMessage);
00382         }
00383     }
00384
00385     catch (Exception^ ex)
00386     {
00387         rootPage->NotifyUser("An unexpected exception occured: " + ex->Message, NotifyType::ErrorMessage);
00388     }
00389 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/HttpRequest.cpp Source File

  • Search contract

HttpRequest.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010 #include "pch.h"
00011 #include "HttpRequest.h"
00012 #include <robuffer.h>
00013 #include <shcore.h>
00014
00015 using namespace concurrency;
00016 using namespace Microsoft::WRL;
00017 using namespace Platform;
00018 using namespace std;
00019 using namespace Web;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Storage::Streams;
00022
00023 // Implementation of IXMLHTTPRequest2Callback used when only the complete response is needed.
00024 // When processing chunks of response data as they are received, use HttpRequestBuffersCallback instead.
00025 class HttpRequestStringCallback
00026     : public RuntimeClass<RuntimeClassFlags<ClassicCom>, IXMLHTTPRequest2Callback, FtmBase>
00027 {
00028 public:
00029     HttpRequestStringCallback(IXMLHTTPRequest2* httpRequest,
00030         cancellation_token ct = concurrency::cancellation_token::none()) :
00031         request(httpRequest), cancellationToken(ct)
00032     {
00033         // Register a callback function that aborts the HTTP operation when
00034         // the cancellation token is canceled.
00035         if (cancellationToken != cancellation_token::none())
00036         {
00037             registrationToken = cancellationToken.register_callback([this]()
00038             {
00039                 if (request != nullptr)
00040                 {
00041                     request->Abort();
00042                 }
00043             });
00044         }
00045     }
00046
00047     // Called when the HTTP request is being redirected to a new URL.
00048     IFACEMETHODIMP OnRedirect(IXMLHTTPRequest2*, PCWSTR)
00049     {
00050         return S_OK;
00051     }
00052
00053     // Called when HTTP headers have been received and processed.
00054     IFACEMETHODIMP OnHeadersAvailable(IXMLHTTPRequest2*, DWORD statusCode, PCWSTR reasonPhrase)
00055     {
00056         HRESULT hr = S_OK;
00057
00058         // We must not propagate exceptions back to IXHR2.
00059         try
00060         {
00061             this->statusCode = statusCode;
00062             this->reasonPhrase = reasonPhrase;
00063         }
00064         catch (std::bad_alloc&)
00065         {
00066             hr = E_OUTOFMEMORY;
00067         }
00068
00069         return hr;
00070     }
00071
00072     // Called when a portion of the entity body has been received.
00073     IFACEMETHODIMP OnDataAvailable(IXMLHTTPRequest2*, ISequentialStream*)
00074     {
00075         return S_OK;
00076     }
00077
00078     // Called when the entire entity response has been received.
00079     IFACEMETHODIMP OnResponseReceived(IXMLHTTPRequest2*, ISequentialStream* responseStream)
00080     {
00081         wstring wstr;
00082         HRESULT hr = ReadUtf8StringFromSequentialStream(responseStream, wstr);
00083
00084         // We must not propagate exceptions back to IXHR2.
00085         try
00086         {
00087             completionEvent.set(make_tuple<HRESULT, wstring>(move(hr), move(wstr)));
00088         }
00089         catch (std::bad_alloc&)
00090         {
00091             hr = E_OUTOFMEMORY;
00092         }
00093
00094         return hr;
00095     }
00096
00097     // Simulate the functionality of DataReader.ReadString().
00098     // This is needed because DataReader requires IRandomAccessStream and this
00099     // code has an ISequentialStream that does not have a conversion to IRandomAccessStream like IStream does.
00100     HRESULT ReadUtf8StringFromSequentialStream(ISequentialStream* readStream, wstring& str)
00101     {
00102         // Convert the response to Unicode wstring.
00103         HRESULT hr;
00104
00105         // Holds the response as a Unicode string.
00106         wstringstream ss;
00107
00108         while (true)
00109         {
00110             ULONG cb;
00111             char buffer[4096];
00112
00113             // Read the response as a UTF-8 string.  Since UTF-8 characters are 1-4 bytes long,
00114             // we need to make sure we only read an integral number of characters.  So we'll
00115             // start with 4093 bytes.
00116             hr = readStream->Read(buffer, sizeof(buffer) - 3, &cb);
00117             if (FAILED(hr) || (cb == 0))
00118             {
00119                 break; // Error or no more data to process, exit loop.
00120             }
00121
00122             if (cb == sizeof(buffer) - 3)
00123             {
00124                 ULONG subsequentBytesRead;
00125                 unsigned int i, cl;
00126
00127                 // Find the first byte of the last UTF-8 character in the buffer.
00128                 for (i = cb - 1; (i >= 0) && ((buffer[i] & 0xC0) == 0x80); i--);
00129
00130                 // Calculate the number of subsequent bytes in the UTF-8 character.
00131                 if (((unsigned char)buffer[i]) < 0x80)
00132                 {
00133                     cl = 1;
00134                 }
00135                 else if (((unsigned char)buffer[i]) < 0xE0)
00136                 {
00137                     cl = 2;
00138                 }
00139                 else if (((unsigned char)buffer[i]) < 0xF0)
00140                 {
00141                     cl = 3;
00142                 }
00143                 else
00144                 {
00145                     cl = 4;
00146                 }
00147
00148                 // Read any remaining bytes.
00149                 if (cb < i + cl)
00150                 {
00151                     hr = readStream->Read(buffer + cb, i + cl - cb, &subsequentBytesRead);
00152                     if (FAILED(hr))
00153                     {
00154                         break; // Error, exit loop.
00155                     }
00156                     cb += subsequentBytesRead;
00157                 }
00158             }
00159
00160             // First determine the size required to store the Unicode string.
00161             int const sizeRequired = MultiByteToWideChar(CP_UTF8, 0, buffer, cb, nullptr, 0);
00162             if (sizeRequired == 0)
00163             {
00164                 // Invalid UTF-8.
00165                 hr = HRESULT_FROM_WIN32(GetLastError());
00166                 break;
00167             }
00168             unique_ptr<char16[]> wstr(new(std::nothrow) char16[sizeRequired + 1]);
00169             if (wstr.get() == nullptr)
00170             {
00171                 hr = E_OUTOFMEMORY;
00172                 break;
00173             }
00174
00175             // Convert the string from UTF-8 to UTF-16LE.  This can never fail, since
00176             // the previous call above succeeded.
00177             MultiByteToWideChar(CP_UTF8, 0, buffer, cb, wstr.get(), sizeRequired);
00178             wstr[sizeRequired] = L'\0'; // Terminate the string.
00179             ss << wstr.get(); // Write the string to the stream.
00180         }
00181
00182         str = SUCCEEDED(hr) ? ss.str() : wstring();
00183         return (SUCCEEDED(hr)) ? S_OK : hr; // Don't return S_FALSE.
00184     }
00185
00186     // Called when an error occurs during the HTTP request.
00187     IFACEMETHODIMP OnError(IXMLHTTPRequest2*, HRESULT hrError)
00188     {
00189         HRESULT hr = S_OK;
00190
00191         // We must not propagate exceptions back to IXHR2.
00192         try
00193         {
00194             completionEvent.set(make_tuple<HRESULT, wstring>(move(hrError), wstring()));
00195         }
00196         catch (std::bad_alloc&)
00197         {
00198             hr = E_OUTOFMEMORY;
00199         }
00200
00201         return hr;
00202     }
00203
00204     // Retrieves the completion event for the HTTP operation.
00205     task_completion_event<tuple<HRESULT, wstring>> const& GetCompletionEvent() const
00206     {
00207         return completionEvent;
00208     }
00209
00210     int GetStatusCode() const
00211     {
00212         return statusCode;
00213     }
00214
00215     wstring GetReasonPhrase() const
00216     {
00217         return reasonPhrase;
00218     }
00219
00220 private:
00221     ~HttpRequestStringCallback()
00222     {
00223         // Unregister the callback.
00224         if (cancellationToken != cancellation_token::none())
00225         {
00226             cancellationToken.deregister_callback(registrationToken);
00227         }
00228     }
00229
00230     // Signals that the download operation was canceled.
00231     cancellation_token cancellationToken;
00232
00233     // Used to unregister the cancellation token callback.
00234     cancellation_token_registration registrationToken;
00235
00236     // The IXMLHTTPRequest2 that processes the HTTP request.
00237     ComPtr<IXMLHTTPRequest2> request;
00238
00239     // Task completion event that is set when the
00240     // download operation completes.
00241     task_completion_event<tuple<HRESULT, wstring>> completionEvent;
00242
00243     int statusCode;
00244     wstring reasonPhrase;
00245 };
00246
00247 // Copy bytes from the sequential stream into the buffer provided until
00248 // we reach the end of one or the other.
00249 unsigned int Web::Details::HttpRequestBuffersCallback::ReadData(
00250     _Out_writes_(outputBufferSize) byte* outputBuffer,
00251     unsigned int outputBufferSize)
00252 {
00253     // Lock the data event while doing the read, to ensure that any bytes we don't read will
00254     // result in the correct event getting triggered.
00255     concurrency::critical_section::scoped_lock lock(dataEventLock);
00256
00257     ULONG bytesRead;
00258     CheckHResult(dataStream.Get()->Read(outputBuffer, outputBufferSize, &bytesRead));
00259     if (bytesRead < outputBufferSize)
00260     {
00261         // We need to reset the data event, which we can only do by creating a new one.
00262         dataEvent = task_completion_event<void>();
00263     }
00264
00265     return bytesRead;
00266 }
00267
00268 // Create a task that completes when data is available, in an exception-safe way.
00269 task<void> Web::Details::HttpRequestBuffersCallback::CreateDataTask()
00270 {
00271     concurrency::critical_section::scoped_lock lock(dataEventLock);
00272     return create_task(dataEvent, cancellationToken);
00273 }
00274
00275 HttpRequest::HttpRequest() : responseComplete(true), statusCode(200)
00276 {
00277 }
00278
00279 // Start a download of the specified URI using the specified method.  The returned task produces the
00280 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00281 task<wstring> HttpRequest::DownloadAsync(PCWSTR httpMethod, PCWSTR uri, cancellation_token cancellationToken,
00282     PCWSTR contentType, IStream* postStream, uint64 postStreamSizeToSend)
00283 {
00284     // Create an IXMLHTTPRequest2 object.
00285     ComPtr<IXMLHTTPRequest2> xhr;
00286     CheckHResult(CoCreateInstance(CLSID_XmlHttpRequest, nullptr, CLSCTX_INPROC, IID_PPV_ARGS(&xhr)));
00287
00288     // Create callback.
00289     auto stringCallback = Make<HttpRequestStringCallback>(xhr.Get(), cancellationToken);
00290     CheckHResult(stringCallback ? S_OK : E_OUTOFMEMORY);
00291
00292     auto completionTask = create_task(stringCallback->GetCompletionEvent());
00293
00294     // Create a request.
00295     CheckHResult(xhr->Open(httpMethod, uri, stringCallback.Get(), nullptr, nullptr, nullptr, nullptr));
00296
00297     if (postStream != nullptr && contentType != nullptr)
00298     {
00299         CheckHResult(xhr->SetRequestHeader(L"Content-Type", contentType));
00300     }
00301
00302     // Send the request.
00303     CheckHResult(xhr->Send(postStream, postStreamSizeToSend));
00304
00305     // Return a task that completes when the HTTP operation completes.
00306     // We pass the callback to the continuation because the lifetime of the
00307     // callback must exceed the operation to ensure that cancellation
00308     // works correctly.
00309     return completionTask.then([this, stringCallback](tuple<HRESULT, wstring> resultTuple)
00310     {
00311         // If the GET operation failed, throw an Exception.
00312         CheckHResult(std::get<0>(resultTuple));
00313
00314         statusCode = stringCallback->GetStatusCode();
00315         reasonPhrase = stringCallback->GetReasonPhrase();
00316
00317         return std::get<1>(resultTuple);
00318     });
00319 }
00320
00321 // Start an HTTP GET on the specified URI.  The returned task completes once the entire response
00322 // has been received, and the task produces the HTTP response text.  The status code and reason
00323 // can be read with GetStatusCode() and GetReasonPhrase().
00324 task<wstring> HttpRequest::GetAsync(Uri^ uri, cancellation_token cancellationToken)
00325 {
00326     return DownloadAsync(L"GET",
00327                          uri->AbsoluteUri->Data(),
00328                          cancellationToken,
00329                          nullptr,
00330                          nullptr,
00331                          0);
00332 }
00333
00334 void HttpRequest::CreateMemoryStream(IStream **stream)
00335 {
00336     auto randomAccessStream = ref new Windows::Storage::Streams::InMemoryRandomAccessStream();
00337     CheckHResult(CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(stream)));
00338 }
00339
00340 // Start an HTTP POST on the specified URI, using a string body.  The returned task produces the
00341 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00342 task<wstring> HttpRequest::PostAsync(Uri^ uri, const wstring& body, cancellation_token cancellationToken)
00343 {
00344     int length = 0;
00345     ComPtr<IStream> postStream;
00346     CreateMemoryStream(&postStream);
00347
00348     if (body.length() > 0)
00349     {
00350         // Get the required buffer size.
00351         int size = WideCharToMultiByte(CP_UTF8,                         // UTF-8
00352                                        0,                               // Conversion type
00353                                        body.c_str(),                    // Unicode string to convert
00354                                        static_cast<int>(body.length()), // Size
00355                                        nullptr,                         // Output buffer
00356                                        0,                               // Output buffer size
00357                                        nullptr,
00358                                        nullptr);
00359         CheckHResult((size != 0) ? S_OK : HRESULT_FROM_WIN32(GetLastError()));
00360
00361         std::unique_ptr<char[]> tempData(new char[size]);
00362         length = WideCharToMultiByte(CP_UTF8,                         // UTF-8
00363                                      0,                               // Conversion type
00364                                      body.c_str(),                    // Unicode string to convert
00365                                      static_cast<int>(body.length()), // Size
00366                                      tempData.get(),                  // Output buffer
00367                                      size,                            // Output buffer size
00368                                      nullptr,
00369                                      nullptr);
00370         CheckHResult((length != 0) ? S_OK : HRESULT_FROM_WIN32(GetLastError()));
00371         CheckHResult(postStream->Write(tempData.get(), length, nullptr));
00372     }
00373
00374     return DownloadAsync(L"POST",
00375                          uri->AbsoluteUri->Data(),
00376                          cancellationToken,
00377                          L"text/plain;charset=utf-8",
00378                          postStream.Get(),
00379                          length);
00380 }
00381
00382 // Start an HTTP POST on the specified URI, using a stream body.  The returned task produces the
00383 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00384 task<wstring> HttpRequest::PostAsync(Uri^ uri, PCWSTR contentType, IStream* postStream,
00385     uint64 postStreamSizeToSend, cancellation_token cancellationToken)
00386 {
00387     return DownloadAsync(L"POST",
00388                          uri->AbsoluteUri->Data(),
00389                          cancellationToken,
00390                          contentType,
00391                          postStream,
00392                          postStreamSizeToSend);
00393 }
00394
00395 // Send a request but don't return the response.  Instead, let the caller read it with ReadAsync().
00396 task<void> HttpRequest::SendAsync(const wstring& httpMethod, Uri^ uri, cancellation_token cancellationToken)
00397 {
00398     // Create an IXMLHTTPRequest2 object.
00399     ComPtr<IXMLHTTPRequest2> xhr;
00400     CheckHResult(CoCreateInstance(CLSID_XmlHttpRequest, nullptr, CLSCTX_INPROC, IID_PPV_ARGS(&xhr)));
00401
00402     // Create callback.
00403     buffersCallback = Make<Web::Details::HttpRequestBuffersCallback>(xhr.Get(), cancellationToken);
00404     CheckHResult(buffersCallback ? S_OK : E_OUTOFMEMORY);
00405
00406     ComPtr<IXMLHTTPRequest2Callback> xhrCallback;
00407     CheckHResult(buffersCallback.As(&xhrCallback));
00408
00409     // Open and send the request.
00410     CheckHResult(xhr->Open(httpMethod.c_str(),
00411                            uri->AbsoluteUri->Data(),
00412                            xhrCallback.Get(),
00413                            nullptr,
00414                            nullptr,
00415                            nullptr,
00416                            nullptr));
00417
00418     responseComplete = false;
00419
00420     CheckHResult(xhr->Send(nullptr, 0));
00421
00422     // Return a task that completes when the HTTP operation completes.
00423     // Since buffersCallback holds a reference on the callback, the lifetime of the callback will exceed
00424     // the operation and ensure that cancellation works correctly.
00425     return buffersCallback->CreateDataTask().then([this]()
00426     {
00427         CheckHResult(buffersCallback->GetError());
00428
00429         statusCode = buffersCallback->GetStatusCode();
00430         reasonPhrase = buffersCallback->GetReasonPhrase();
00431     });
00432 }
00433
00434 // Read a chunk of data from the HTTP response, up to a specified length or until we reach the end
00435 // of the response, and store the value in the provided buffer.  This is useful for large content,
00436 // enabling the streaming of the result.
00437 task<void> HttpRequest::ReadAsync(Windows::Storage::Streams::IBuffer^ readBuffer, unsigned int offsetInBuffer,
00438     unsigned int requestedBytesToRead)
00439 {
00440     if (offsetInBuffer + requestedBytesToRead > readBuffer->Capacity)
00441     {
00442         throw ref new InvalidArgumentException();
00443     }
00444
00445     // Return a task that completes when a read completes.
00446     // We pass the callback to the continuation because the lifetime of the
00447     // callback must exceed the operation to ensure that cancellation
00448     // works correctly.
00449     return buffersCallback->CreateDataTask().then([this, readBuffer, offsetInBuffer, requestedBytesToRead]()
00450     {
00451         CheckHResult(buffersCallback->GetError());
00452
00453         // Get a pointer to the location to copy data into.
00454         ComPtr<IBufferByteAccess> bufferByteAccess;
00455         CheckHResult(reinterpret_cast<IUnknown*>(readBuffer)->QueryInterface(IID_PPV_ARGS(&bufferByteAccess)));
00456         byte* outputBuffer; // Returned internal pointer, do not free this value.
00457         CheckHResult(bufferByteAccess->Buffer(&outputBuffer));
00458
00459         // Copy bytes from the sequential stream into the buffer provided until
00460         // we reach the end of one or the other.
00461         readBuffer->Length = buffersCallback->ReadData(outputBuffer + offsetInBuffer, requestedBytesToRead);
00462         if (buffersCallback->IsResponseReceived() && (readBuffer->Length < requestedBytesToRead))
00463         {
00464             responseComplete = true;
00465         }
00466     });
00467 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/BasicTimer.h Source File

  • Direct2D command list

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/App.xaml.cpp Source File

  • XAML personality animations

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicTimer.h Source File

  • Direct3D-Direct2D interop

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MediaReader.h Source File

  • XAML DirectX 3D shooting game

MediaReader.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // MediaReader:
00011 // This is a helper class for the SoundEffect class.  It reads small audio files
00012 // synchronously from the package installed folder and returns sound data as a
00013 // byte array.
00014
00015 ref class MediaReader
00016 {
00017 internal:
00018     MediaReader();
00019
00020     Platform::Array<byte>^          LoadMedia(_In_ Platform::String^ filename);
00021     WAVEFORMATEX*                   GetOutputWaveFormatEx();
00022
00023 protected private:
00024     Windows::Storage::StorageFolder^ m_installedLocation;
00025     Platform::String^               m_installedLocationPath;
00026     WAVEFORMATEX                    m_waveFormat;
00027 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Constants.h Source File

  • Media Play To

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"PlayTo");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/MainPage.xaml.cpp Source File

  • XAML animation library

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/MainPage.xaml.cpp Source File

  • Association launching

MainPage.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.cpp
00010 // Implementation of the MainPage.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "MainPage.xaml.h"
00015 #include "App.xaml.h"
00016
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::UI::Xaml::Controls;
00019 using namespace Windows::UI::Xaml::Data;
00020 using namespace Windows::System;
00021 using namespace Windows::Foundation;
00022 using namespace Platform;
00023 using namespace AssociationLaunching;
00024 using namespace CppSamplesUtils;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 MainPage::MainPage()
00029 {
00030     InitializeComponent();
00031
00032     SetFeatureName("AssociationLaunching");
00033
00034     _scenariosFrame = ScenarioList;
00035     _inputFrame = ScenarioInput;
00036     _outputFrame = ScenarioOutput;
00037
00038     _layoutHandlerToken = Window::Current->SizeChanged += ref new Windows::UI::Xaml::WindowSizeChangedEventHandler(this, &MainPage::Page_SizeChanged);
00039
00040     _pageLoadedHandlerToken = Loaded += ref new RoutedEventHandler(this, &MainPage::Page_Loaded);
00041     _logicalDpiChangedToken = DisplayProperties::LogicalDpiChanged += ref new DisplayPropertiesEventHandler(this, &MainPage::DisplayProperties_LogicalDpiChanged);
00042 }
00043
00044 MainPage::~MainPage()
00045 {
00046 }
00047
00048 void MainPage::Page_Loaded(Object^ sender, RoutedEventArgs^ e)
00049 {
00050     // Load the ScenarioList page into the proper frame.
00051     TypeName pageType = { "AssociationLaunching.ScenarioList", TypeKind::Custom };
00052     ScenarioList->Navigate(pageType, this);
00053
00054     // Figure out what resolution and orientation we are in and respond appropriately.
00055     CheckResolutionAndViewState();
00056 }
00057
00058 void MainPage::SetFeatureName(String^ strFeature)
00059 {
00060     FeatureName->Text = strFeature;
00061 }
00062
00063 void MainPage::Page_SizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00064 {
00065     CheckResolutionAndViewState();
00066 }
00067
00068 void MainPage::DisplayProperties_LogicalDpiChanged(Object^ sender)
00069 {
00070     CheckResolutionAndViewState();
00071 }
00072
00073 void MainPage::CheckResolutionAndViewState()
00074 {
00075     ApplicationViewState state = ApplicationView::Value;
00076     String^ stateString = ConvertViewState(state);
00077
00078     ResolutionScale scale = DisplayProperties::ResolutionScale;
00079     String^ scaleString = ConvertResolution(scale);
00080
00081     VisualStateManager::GoToState(this, stateString + scaleString, false);
00082 }
00083
00084 String^ MainPage::ConvertViewState(ApplicationViewState state)
00085 {
00086     switch (state)
00087     {
00088     case ApplicationViewState::Filled:
00089         return "Filled";
00090     case ApplicationViewState::FullScreenLandscape:
00091         return "FullScreenLandscape";
00092     case ApplicationViewState::FullScreenPortrait:
00093         return "FullScreenPortrait";
00094     case ApplicationViewState::Snapped:
00095         return "Snapped";
00096     }
00097     return "";
00098 }
00099
00100 String^ MainPage::ConvertResolution(ResolutionScale scale)
00101 {
00102     switch (scale)
00103     {
00104     case ResolutionScale::Scale100Percent:
00105         return "Scale100Percent";
00106     case ResolutionScale::Scale140Percent:
00107         return "Scale140Percent";
00108     case ResolutionScale::Scale180Percent:
00109         return "Scale180Percent";
00110     }
00111     return "";
00112 }
00113
00114 void MainPage::DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^ frame)
00115 {
00116     frame->Navigate(pageType, this);
00117
00118     std::wstring PageName(pageType.Name->Data());
00119     std::basic_string <wchar_t>::size_type indexSubstring;
00120     indexSubstring = PageName.find(L"Output");
00121     if (indexSubstring != std::wstring::npos)
00122     {
00123         // Raise OutputFrameLoaded so downstream pages know that the output frame content has been loaded.
00124         OutputFrameLoaded(this, nullptr);
00125     }
00126     else
00127     {
00128         // Raise InputFrameLoaded so downstream pages know that the input frame content has been loaded.
00129         InputFrameLoaded(this, nullptr);
00130     }
00131 }
00132
00133 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00134 {
00135     switch (type)
00136     {
00137     case NotifyType::StatusMessage:
00138         StatusBlock->Style = dynamic_cast<Windows::UI::Xaml::Style^>(App::Current->Resources->Lookup("StatusStyle"));
00139         break;
00140     case NotifyType::ErrorMessage:
00141         StatusBlock->Style = dynamic_cast<Windows::UI::Xaml::Style^>(App::Current->Resources->Lookup("ErrorStyle"));
00142         break;
00143     default:
00144         break;
00145     }
00146     StatusBlock->Text = strMessage;
00147 }
00148
00149 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00150 {
00151     auto uri = ref new Windows::Foundation::Uri((String^)((HyperlinkButton^)sender)->Tag);
00152     Windows::System::Launcher::LaunchUriAsync(uri);
00153 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Scenario3.xaml.h Source File

  • Push and periodic notifications client-side

Scenario3.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include "pch.h"
00014 #include "Scenario3.g.h"
00015 #include "MainPage.xaml.h"
00016
00017 namespace SDKSample
00018 {
00019     namespace SDKTemplate
00020     {
00021         /// <summary>
00022         /// An empty page that can be used on its own or navigated to within a Frame.
00023         /// </summary>
00024       [Windows::Foundation::Metadata::WebHostHidden]
00025         public ref class Scenario3 sealed
00026         {
00027         public:
00028             Scenario3();
00029
00030         protected:
00031             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033         private:
00034             MainPage^ rootPage;
00035             void AddCallback_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036         void RemoveCallback_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037         bool UpdateListener(bool add);
00038         void OnPushNotificationReceived(Windows::Networking::PushNotifications::PushNotificationChannel^ sender, Windows::Networking::PushNotifications::PushNotificationReceivedEventArgs^ e);
00039
00040         Windows::Foundation::EventRegistrationToken pushReceivedToken;
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/HttpRequest.h Source File

  • Search contract

HttpRequest.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010 #pragma once
00011 #include "pch.h"
00012
00013 inline void CheckHResult(HRESULT hResult)
00014 {
00015     if (hResult == E_ABORT)
00016     {
00017         concurrency::cancel_current_task();
00018     }
00019     else if (FAILED(hResult))
00020     {
00021         throw Platform::Exception::CreateException(hResult);
00022     }
00023 }
00024
00025 namespace Web
00026 {
00027     namespace Details
00028     {
00029         // Implementation of IXMLHTTPRequest2Callback used when partial buffers are needed from the response.
00030         // When only the complete response is needed, use HttpRequestStringCallback instead.
00031         class HttpRequestBuffersCallback
00032             : public Microsoft::WRL::RuntimeClass<
00033                 Microsoft::WRL::RuntimeClassFlags<Microsoft::WRL::ClassicCom>,
00034                 IXMLHTTPRequest2Callback,
00035                 Microsoft::WRL::FtmBase>
00036         {
00037         public:
00038             HttpRequestBuffersCallback(IXMLHTTPRequest2* httpRequest,
00039                 concurrency::cancellation_token ct = concurrency::cancellation_token::none()) :
00040                 request(httpRequest), cancellationToken(ct), responseReceived(false), dataHResult(S_OK), statusCode(200)
00041             {
00042                 // Register a callback function that aborts the HTTP operation when
00043                 // the cancellation token is canceled.
00044                 if (cancellationToken != concurrency::cancellation_token::none())
00045                 {
00046                     registrationToken = cancellationToken.register_callback([this]()
00047                     {
00048                         if (request != nullptr)
00049                         {
00050                             request->Abort();
00051                         }
00052                     });
00053                 }
00054
00055                 dataEvent = concurrency::task_completion_event<void>();
00056             }
00057
00058             // Called when the HTTP request is being redirected to a new URL.
00059             IFACEMETHODIMP OnRedirect(IXMLHTTPRequest2*, PCWSTR)
00060             {
00061                 return S_OK;
00062             }
00063
00064             // Called when HTTP headers have been received and processed.
00065             IFACEMETHODIMP OnHeadersAvailable(IXMLHTTPRequest2*, DWORD statusCode, PCWSTR reasonPhrase)
00066             {
00067                 HRESULT hr = S_OK;
00068
00069                 // We must not propagate exceptions back to IXHR2.
00070                 try
00071                 {
00072                     this->statusCode = statusCode;
00073                     this->reasonPhrase = reasonPhrase;
00074
00075                     concurrency::critical_section::scoped_lock lock(dataEventLock);
00076                     dataEvent.set();
00077                 }
00078                 catch (std::bad_alloc&)
00079                 {
00080                     hr = E_OUTOFMEMORY;
00081                 }
00082                 return hr;
00083             }
00084
00085             // Called when a portion of the entity body has been received.
00086             IFACEMETHODIMP OnDataAvailable(IXMLHTTPRequest2*, ISequentialStream* stream)
00087             {
00088                 HRESULT hr = S_OK;
00089
00090                 // We must not propagate exceptions back to IXHR2.
00091                 try
00092                 {
00093                     // Store a reference on the stream so it can be accessed by the task.
00094                     dataStream = stream;
00095
00096                     // The work must be done as fast as possible, and must not block this thread,
00097                     // for example, waiting on another event object.  Here we simply set an event
00098                     // that can be processed by another thread.
00099                     concurrency::critical_section::scoped_lock lock(dataEventLock);
00100                     dataEvent.set();
00101                 }
00102                 catch (std::bad_alloc&)
00103                 {
00104                     hr = E_OUTOFMEMORY;
00105                 }
00106                 return hr;
00107             }
00108
00109             // Called when the entire entity response has been received.
00110             IFACEMETHODIMP OnResponseReceived(IXMLHTTPRequest2* xhr, ISequentialStream* responseStream)
00111             {
00112                 responseReceived = true;
00113                 return OnDataAvailable(xhr, responseStream);
00114             }
00115
00116             // Called when an error occurs during the HTTP request.
00117             IFACEMETHODIMP OnError(IXMLHTTPRequest2*, HRESULT hrError)
00118             {
00119                 HRESULT hr = S_OK;
00120
00121                 // We must not propagate exceptions back to IXHR2.
00122                 try
00123                 {
00124                     concurrency::critical_section::scoped_lock lock(dataEventLock);
00125                     dataHResult = hrError;
00126                     dataEvent.set();
00127                 }
00128                 catch (std::bad_alloc&)
00129                 {
00130                     hr = E_OUTOFMEMORY;
00131                 }
00132
00133                 return hr;
00134             }
00135
00136             // Create a task that completes when data is available, in an exception-safe way.
00137             concurrency::task<void> CreateDataTask();
00138
00139             HRESULT GetError() const
00140             {
00141                 return dataHResult;
00142             }
00143
00144             int GetStatusCode() const
00145             {
00146                 return statusCode;
00147             }
00148
00149             std::wstring const& GetReasonPhrase() const
00150             {
00151                 return reasonPhrase;
00152             }
00153
00154             bool IsResponseReceived() const
00155             {
00156                 return responseReceived;
00157             }
00158
00159             // Copy bytes from the sequential stream into the buffer provided until
00160             // we reach the end of one or the other.
00161             unsigned int ReadData(
00162                 _Out_writes_(outputBufferSize) byte* outputBuffer,
00163                 unsigned int outputBufferSize);
00164
00165         private:
00166             ~HttpRequestBuffersCallback()
00167             {
00168                 // Unregister the callback.
00169                 if (cancellationToken != concurrency::cancellation_token::none())
00170                 {
00171                     cancellationToken.deregister_callback(registrationToken);
00172                 }
00173             }
00174
00175             // Signals that the download operation was canceled.
00176             concurrency::cancellation_token cancellationToken;
00177
00178             // Used to unregister the cancellation token callback.
00179             concurrency::cancellation_token_registration registrationToken;
00180
00181             // The IXMLHTTPRequest2 that processes the HTTP request.
00182             Microsoft::WRL::ComPtr<IXMLHTTPRequest2> request;
00183
00184             // Task completion event that is set when data is available or error is triggered.
00185             concurrency::task_completion_event<void> dataEvent;
00186             concurrency::critical_section dataEventLock;
00187
00188             // We cannot store the error obtained from IXHR2 in the dataEvent since any value there is first-writer-wins,
00189             // whereas we want a subsequent error to override an initial success.
00190             HRESULT dataHResult;
00191
00192             // Referenced pointer to the data stream.
00193             Microsoft::WRL::ComPtr<ISequentialStream> dataStream;
00194
00195             // HTTP status code and reason returned by the server.
00196             int statusCode;
00197             std::wstring reasonPhrase;
00198
00199             // Whether the response has been completely received.
00200             bool responseReceived;
00201         };
00202
00203     };
00204
00205     // Utility class for performing asynchronous HTTP requests.
00206     // This class only supports one outstanding request at a time.
00207     class HttpRequest
00208     {
00209     public:
00210         HttpRequest();
00211
00212         int GetStatusCode() const
00213         {
00214             return statusCode;
00215         }
00216
00217         std::wstring const& GetReasonPhrase() const
00218         {
00219             return reasonPhrase;
00220         }
00221
00222         // Whether the response has been completely received, if using ReadAsync().
00223         bool IsResponseComplete() const
00224         {
00225             return responseComplete;
00226         }
00227
00228         // Start an HTTP GET on the specified URI.  The returned task completes once the entire response
00229         // has been received, and the task produces the HTTP response text.  The status code and reason
00230         // can be read with GetStatusCode() and GetReasonPhrase().
00231         concurrency::task<std::wstring> GetAsync(
00232             Windows::Foundation::Uri^ uri,
00233             concurrency::cancellation_token cancellationToken = concurrency::cancellation_token::none());
00234
00235         // Start an HTTP POST on the specified URI, using a string body.  The returned task produces the
00236         // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00237         concurrency::task<std::wstring> PostAsync(
00238             Windows::Foundation::Uri^ uri,
00239             PCWSTR contentType,
00240             IStream* postStream,
00241             uint64 postStreamSizeToSend,
00242             concurrency::cancellation_token cancellationToken = concurrency::cancellation_token::none());
00243
00244         // Start an HTTP POST on the specified URI, using a stream body.  The returned task produces the
00245         // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00246         concurrency::task<std::wstring> PostAsync(
00247             Windows::Foundation::Uri^ uri,
00248             const std::wstring& str,
00249             concurrency::cancellation_token cancellationToken = concurrency::cancellation_token::none());
00250
00251         // Send a request but don't return the response.  Instead, let the caller read it with ReadAsync().
00252         concurrency::task<void> SendAsync(
00253             const std::wstring& httpMethod,
00254             Windows::Foundation::Uri^ uri,
00255             concurrency::cancellation_token cancellationToken = concurrency::cancellation_token::none());
00256
00257         // Read a chunk of data from the HTTP response, up to a specified length or until we reach the end
00258         // of the response, and store the value in the provided buffer.  This is useful for large content,
00259         // enabling the streaming of the result.
00260         concurrency::task<void> ReadAsync(
00261             Windows::Storage::Streams::IBuffer^ readBuffer,
00262             unsigned int offsetInBuffer,
00263             unsigned int requestedBytesToRead);
00264
00265         static void CreateMemoryStream(IStream **stream);
00266
00267     private:
00268         // Start a download of the specified URI using the specified method.  The returned task produces the
00269         // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00270         concurrency::task<std::wstring> DownloadAsync(
00271             PCWSTR httpMethod,
00272             PCWSTR uri,
00273             concurrency::cancellation_token cancellationToken,
00274             PCWSTR contentType,
00275             IStream* postStream,
00276             uint64 postStreamBytesToSend);
00277
00278         // Referenced pointer to the callback, if using SendAsync/ReadAsync.
00279         Microsoft::WRL::ComPtr<Details::HttpRequestBuffersCallback> buffersCallback;
00280
00281         int statusCode;
00282         std::wstring reasonPhrase;
00283
00284         // Whether the response has been completely received, if using ReadAsync().
00285         bool responseComplete;
00286     };
00287 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/common/LayoutAwarePage.cpp Source File

  • XAML user and custom controls
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/App.xaml.cpp Source File

  • LightSensor

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/App.xaml.h Source File

  • StorageDataSource and GetVirtualizedFilesVector

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Accessibility::sealed Member List

This is the complete list of members for SDKSample::Accessibility::sealed, including all inherited members.
_age | SDKSample::Accessibility::sealed | [private]
_labeledBy | SDKSample::Accessibility::sealed |
_mediaElement | SDKSample::Accessibility::sealed |
automationId | SDKSample::Accessibility::sealed | [private]
automationName | SDKSample::Accessibility::sealed | [private]
firstName | SDKSample::Accessibility::sealed | [private]
GeneratePersonNamesSource() | SDKSample::Accessibility::sealed | [inline, static]
GetAutomationControlTypeCore() override | SDKSample::Accessibility::sealed | [inline, protected, virtual]
GetClassNameCore() override | SDKSample::Accessibility::sealed | [inline, protected, virtual]
GetLocalizedControlTypeCore() override | SDKSample::Accessibility::sealed | [inline, protected, virtual]
GetPatternCore(PatternInterface patternInterface) override | SDKSample::Accessibility::sealed | [inline, protected, virtual]
GiveControlFocus(Platform::Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^args) | SDKSample::Accessibility::sealed | [private]
lastName | SDKSample::Accessibility::sealed | [private]
MediaContainerAP(MediaElementContainer^owner, MediaElement^mediaElement) | SDKSample::Accessibility::sealed |
mediaElement | SDKSample::Accessibility::sealed |
MediaElementContainer(Windows::UI::Xaml::Controls::Panel^parent) | SDKSample::Accessibility::sealed | [inline]
OnCreateAutomationPeer() override | SDKSample::Accessibility::sealed | [inline, protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Accessibility::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Accessibility::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Accessibility::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Accessibility::sealed | [protected, virtual]
Person() | SDKSample::Accessibility::sealed | [inline]
Person(Platform::String^firstName, Platform::String^lastName, Platform::String^id, int age, Platform::String^name) | SDKSample::Accessibility::sealed | [inline]
PrepareContainerForItemOverride(Windows::UI::Xaml::DependencyObject^element, Platform::Object^item) override | SDKSample::Accessibility::sealed | [inline, protected, virtual]
rootPage | SDKSample::Accessibility::sealed | [private]
Scenario1() | SDKSample::Accessibility::sealed |
Scenario2() | SDKSample::Accessibility::sealed |
Scenario3() | SDKSample::Accessibility::sealed |
Scenario4() | SDKSample::Accessibility::sealed |
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/App.xaml.h Source File

  • Account picture name

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace AccountPictureName
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028
00029     public:
00030         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00031         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00032
00033     protected:
00034         virtual void OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^ args) override;
00035
00036     private:
00037         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00038         void SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs);
00039
00040     };
00041 }
00042
00043
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ConstantBuffer Member List

This is the complete list of members for ConstantBuffer, including all inherited members.
lightStrength | ConstantBuffer
marblePosition | ConstantBuffer
marbleRadius | ConstantBuffer
model | ConstantBuffer
model | ConstantBuffer
projection | ConstantBuffer
projection | ConstantBuffer
view | ConstantBuffer
view | ConstantBuffer
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/common/LayoutAwarePage.cpp Source File

  • Geolocation
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/DirectXBase.h Source File

  • DirectX swap chain implementation

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Simple3DGame.cpp Source File

  • DirectX 3D shooting game

Simple3DGame.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "GameRenderer.h"
00010
00011 #include "DirectXSample.h"
00012 #include "Level1.h"
00013 #include "Level2.h"
00014 #include "Level3.h"
00015 #include "Level4.h"
00016 #include "Level5.h"
00017 #include "Level6.h"
00018 #include "Animate.h"
00019 #include "Sphere.h"
00020 #include "Cylinder.h"
00021 #include "Face.h"
00022 #include "MediaReader.h"
00023
00024 using namespace concurrency;
00025 using namespace DirectX;
00026 using namespace Microsoft::WRL;
00027 using namespace Windows::Storage;
00028 using namespace Windows::UI::Core;
00029
00030 //----------------------------------------------------------------------
00031
00032 Simple3DGame::Simple3DGame():
00033     m_ammoCount(0),
00034     m_ammoNext(0),
00035     m_gameActive(false),
00036     m_levelActive(false),
00037     m_totalHits(0),
00038     m_totalShots(0),
00039     m_levelBonusTime(0.0),
00040     m_levelTimeRemaining(0.0),
00041     m_levelCount(0),
00042     m_currentLevel(0)
00043 {
00044     m_topScore.totalHits = 0;
00045     m_topScore.totalShots = 0;
00046     m_topScore.levelCompleted = 0;
00047 }
00048
00049 //----------------------------------------------------------------------
00050
00051 void Simple3DGame::Initialize(
00052     _In_ MoveLookController^ controller,
00053     _In_ GameRenderer^ renderer
00054     )
00055 {
00056     // This method is expected to be called as an asynchronous task.
00057     // Care should be taken to not call rendering methods on the
00058     // m_renderer as this would result in the D3D Context being
00059     // used in multiple threads, which is not allowed.
00060
00061     m_controller = controller;
00062     m_renderer = renderer;
00063
00064     m_audioController = ref new Audio;
00065     m_audioController->CreateDeviceIndependentResources();
00066
00067     m_ammo = std::vector<Sphere^>(GameConstants::MaxAmmo);
00068     m_objects = std::vector<GameObject^>();
00069     m_renderObjects = std::vector<GameObject^>();
00070     m_level = std::vector<Level^>();
00071
00072     m_savedState = ref new PersistentState();
00073     m_savedState->Initialize(ApplicationData::Current->LocalSettings->Values, "Game");
00074
00075     m_timer = ref new GameTimer();
00076
00077     // Create a sphere primitive to represent the player.
00078     // The sphere will be used to handle collisions and constrain the player in the world.
00079     // It is not rendered so it is not added to the list of render objects.
00080     // It is added to the object list so it will be included in intersection calculations.
00081     m_player = ref new Sphere(XMFLOAT3(0.0f, -1.3f, 4.0f), 0.2f);
00082     m_objects.push_back(m_player);
00083     m_player->Active(true);
00084
00085     m_camera = ref new Camera;
00086     m_camera->SetProjParams(XM_PI / 2, 1.0f, 0.01f, 100.0f);
00087     m_camera->SetViewParams(
00088         m_player->Position(),            // Eye point in world coordinates.
00089         XMFLOAT3 (0.0f, 0.7f, 0.0f),     // Look at point in world coordinates.
00090         XMFLOAT3 (0.0f, 1.0f, 0.0f)      // The Up vector for the camera.
00091         );
00092
00093     m_controller->Pitch(m_camera->Pitch());
00094     m_controller->Yaw(m_camera->Yaw());
00095
00096     // Instantiate a set of primitives to represent the containing world. These objects
00097     // maintain the geometry and material properties of the walls, floor and ceiling.
00098     // The TargetId is used to identify the world objects so that the right geometry
00099     // and textures can be associated with them later after those resources have
00100     // been created.
00101     GameObject^ world = ref new GameObject();
00102     world->TargetId(GameConstants::WorldFloorId);
00103     world->Active(true);
00104     m_renderObjects.push_back(world);
00105
00106     world = ref new GameObject();
00107     world->TargetId(GameConstants::WorldCeilingId);
00108     world->Active(true);
00109     m_renderObjects.push_back(world);
00110
00111     world = ref new GameObject();
00112     world->TargetId(GameConstants::WorldWallsId);
00113     world->Active(true);
00114     m_renderObjects.push_back(world);
00115
00116     // Min and max Bound are defining the world space of the game.
00117     // All camera motion and dynamics are confined to this space.
00118     m_minBound = XMFLOAT3(-4.0f, -3.0f, -6.0f);
00119     m_maxBound = XMFLOAT3(4.0f, 3.0f, 6.0f);
00120
00121     // Instantiate the Cylinders for use in the various game levels.
00122     // Each cylinder has a different initial position, radius and direction vector,
00123     // but share a common set of material properties.
00124     for (int a = 0; a < GameConstants::MaxCylinders; a++)
00125     {
00126         Cylinder^ cylinder;
00127         switch (a)
00128         {
00129         case 0:
00130             cylinder = ref new Cylinder(XMFLOAT3(-2.0f, -3.0f, 0.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00131             break;
00132         case 1:
00133             cylinder = ref new Cylinder(XMFLOAT3(2.0f, -3.0f, 0.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00134             break;
00135         case 2:
00136             cylinder = ref new Cylinder(XMFLOAT3(0.0f, -3.0f, -2.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00137             break;
00138         case 3:
00139             cylinder = ref new Cylinder(XMFLOAT3(-1.5f, -3.0f, -4.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00140             break;
00141         case 4:
00142             cylinder = ref new Cylinder(XMFLOAT3(1.5f, -3.0f, -4.0f), 0.50f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00143             break;
00144         }
00145         cylinder->Active(true);
00146         m_objects.push_back(cylinder);
00147         m_renderObjects.push_back(cylinder);
00148     }
00149
00150     MediaReader^ mediaReader = ref new MediaReader;
00151     auto targetHitSound = mediaReader->LoadMedia("hit.wav");
00152
00153     // Instantiate the targets for use in the game.
00154     // Each target has a different initial position, size and orientation,
00155     // but share a common set of material properties.
00156     // The target is defined by a position and two vectors that define both
00157     // the plane of the target in world space and the size of the parallelogram
00158     // based on the lengths of the vectors.
00159     // Each target is assigned a number for identification purposes.
00160     // The Target ID number is 1 based.
00161     // All targets have the same material properties.
00162     for (int a = 1; a < GameConstants::MaxTargets; a++)
00163     {
00164         Face^ target;
00165         switch (a)
00166         {
00167         case 1:
00168             target = ref new Face(XMFLOAT3(-2.5f, -1.0f, -1.5f), XMFLOAT3(-1.5f, -1.0f, -2.0f), XMFLOAT3(-2.5f, 1.0f, -1.5f));
00169             break;
00170         case 2:
00171             target = ref new Face(XMFLOAT3(-1.0f, 1.0f, -3.0f), XMFLOAT3(0.0f, 1.0f, -3.0f), XMFLOAT3(-1.0f, 2.0f, -3.0f));
00172             break;
00173         case 3:
00174             target = ref new Face(XMFLOAT3(1.5f, 0.0f, -3.0f), XMFLOAT3(2.5f, 0.0f, -2.0f), XMFLOAT3(1.5f, 2.0f, -3.0f));
00175             break;
00176         case 4:
00177             target = ref new Face(XMFLOAT3(-2.5f, -1.0f, -5.5f), XMFLOAT3(-0.5f, -1.0f, -5.5f), XMFLOAT3(-2.5f, 1.0f, -5.5f));
00178             break;
00179         case 5:
00180             target = ref new Face(XMFLOAT3(0.5f, -2.0f, -5.0f), XMFLOAT3(1.5f, -2.0f, -5.0f), XMFLOAT3(0.5f, 0.0f, -5.0f));
00181             break;
00182         case 6:
00183             target = ref new Face(XMFLOAT3(1.5f, -2.0f, -5.5f), XMFLOAT3(2.5f, -2.0f, -5.0f), XMFLOAT3(1.5f, 0.0f, -5.5f));
00184             break;
00185         case 7:
00186             target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
00187             break;
00188         case 8:
00189             target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
00190             break;
00191         case 9:
00192             target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
00193             break;
00194         }
00195
00196         target->Target(true);
00197         target->TargetId(a);
00198         target->Active(true);
00199         target->HitSound(ref new SoundEffect());
00200         target->HitSound()->Initialize(
00201             m_audioController->SoundEffectEngine(),
00202             mediaReader->GetOutputWaveFormatEx(),
00203             targetHitSound
00204             );
00205
00206         m_objects.push_back(target);
00207         m_renderObjects.push_back(target);
00208     }
00209
00210     // Instantiate a set of spheres to be used as ammunition for the game
00211     // and set the material properties of the spheres.
00212     auto ammoHitSound = mediaReader->LoadMedia("bounce.wav");
00213
00214     for (int a = 0; a < GameConstants::MaxAmmo; a++)
00215     {
00216         m_ammo[a] = ref new Sphere;
00217         m_ammo[a]->Radius(GameConstants::AmmoRadius);
00218         m_ammo[a]->HitSound(ref new SoundEffect());
00219         m_ammo[a]->HitSound()->Initialize(
00220             m_audioController->SoundEffectEngine(),
00221             mediaReader->GetOutputWaveFormatEx(),
00222             ammoHitSound
00223             );
00224         m_ammo[a]->Active(false);
00225         m_renderObjects.push_back(m_ammo[a]);
00226     }
00227
00228     // Instantiate each of the game levels. The Level class contains methods
00229     // that initialize the objects in the world for the given level and also
00230     // define any motion paths for the objects in that level.
00231
00232     m_level.push_back(ref new Level1);
00233     m_level.push_back(ref new Level2);
00234     m_level.push_back(ref new Level3);
00235     m_level.push_back(ref new Level4);
00236     m_level.push_back(ref new Level5);
00237     m_level.push_back(ref new Level6);
00238     m_levelCount = static_cast<uint32>(m_level.size());
00239
00240     // Load the top score from disk if it exists.
00241     LoadHighScore();
00242
00243     // Load the currentScore for saved state if it exists.
00244     LoadState();
00245
00246     m_controller->Active(false);
00247 }
00248
00249 //----------------------------------------------------------------------
00250
00251 void Simple3DGame::LoadGame()
00252 {
00253     m_player->Position(XMFLOAT3 (0.0f, -1.3f, 4.0f));
00254
00255     m_camera->SetViewParams(
00256         m_player->Position(),            // Eye point in world coordinates.
00257         XMFLOAT3 (0.0f, 0.7f, 0.0f),     // Look at point in world coordinates.
00258         XMFLOAT3 (0.0f, 1.0f, 0.0f)      // The Up vector for the camera.
00259         );
00260
00261     m_controller->Pitch(m_camera->Pitch());
00262     m_controller->Yaw(m_camera->Yaw());
00263     m_currentLevel = 0;
00264     m_levelTimeRemaining = 0.0f;
00265     m_levelBonusTime = m_levelTimeRemaining;
00266     m_levelDuration = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime;
00267     InitializeAmmo();
00268     m_totalHits = 0;
00269     m_totalShots = 0;
00270     m_gameActive = false;
00271     m_levelActive = false;
00272     m_timer->Reset();
00273 }
00274
00275 //----------------------------------------------------------------------
00276
00277 task<void> Simple3DGame::LoadLevelAsync()
00278 {
00279     // Initialize the level and spin up the async loading of the rendering
00280     // resources for the level.
00281     // This will run in a separate thread, so for Direct3D 11, only Device
00282     // methods are allowed.  Any DeviceContext method calls need to be
00283     // done in FinalizeLoadLevel.
00284
00285     m_level[m_currentLevel]->Initialize(m_objects);
00286     m_levelDuration = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime;
00287
00288     return m_renderer->LoadLevelResourcesAsync();
00289 }
00290
00291 //----------------------------------------------------------------------
00292
00293 void Simple3DGame::FinalizeLoadLevel()
00294 {
00295     // This method is called on the main thread, so Direct3D 11 DeviceContext
00296     // method calls are allowable here.
00297
00298     // Finalize the Level loading.
00299     m_renderer->FinalizeLoadLevelResources();
00300 }
00301
00302 //----------------------------------------------------------------------
00303
00304 void Simple3DGame::StartLevel()
00305 {
00306     m_timer->Reset();
00307     m_timer->Start();
00308     if (m_currentLevel == 0)
00309     {
00310         m_gameActive = true;
00311     }
00312     m_levelActive = true;
00313     m_controller->Active(true);
00314 }
00315
00316 //----------------------------------------------------------------------
00317
00318 void Simple3DGame::PauseGame()
00319 {
00320     m_timer->Stop();
00321     SaveState();
00322 }
00323
00324 //----------------------------------------------------------------------
00325
00326 void Simple3DGame::ContinueGame()
00327 {
00328     m_timer->Start();
00329     m_controller->Active(true);
00330 }
00331
00332 //----------------------------------------------------------------------
00333
00334 GameState Simple3DGame::RunGame()
00335 {
00336     // This method is called to execute a single time interval for active game play.
00337     // It returns the resulting state of game play after the interval has been executed.
00338
00339     m_timer->Update();
00340
00341     m_levelTimeRemaining = m_levelDuration - m_timer->PlayingTime();
00342
00343     if (m_levelTimeRemaining <= 0.0f)
00344     {
00345         // Time expired, so the game is over.
00346         m_levelTimeRemaining = 0.0f;
00347         InitializeAmmo();
00348         m_timer->Reset();
00349         m_gameActive = false;
00350         m_levelActive = false;
00351         SaveState();
00352
00353         if (m_totalHits > m_topScore.totalHits)
00354         {
00355             // There is a new high score so save it.
00356             m_topScore.totalHits = m_totalHits;
00357             m_topScore.totalShots = m_totalShots;
00358             m_topScore.levelCompleted = m_currentLevel;
00359
00360             SaveHighScore();
00361         }
00362         return GameState::TimeExpired;
00363     }
00364     else
00365     {
00366         // Time has not expired, so run one frame of game play.
00367         m_player->Velocity(m_controller->Velocity());
00368         m_camera->LookDirection(m_controller->LookDirection());
00369
00370         UpdateDynamics();
00371
00372         // Update the Camera with the player position updates from the dynamics calculations.
00373         m_camera->Eye(m_player->Position());
00374         m_camera->LookDirection(m_controller->LookDirection());
00375
00376         if (m_level[m_currentLevel]->Update(m_timer->PlayingTime(), m_timer->DeltaTime(), m_levelTimeRemaining, m_objects))
00377         {
00378             // The level has been completed.
00379             m_levelActive = false;
00380             InitializeAmmo();
00381
00382             if (m_currentLevel < m_levelCount-1)
00383             {
00384                 // More levels to go so increment the level number.
00385                 // Actual level loading will occur in the LoadLevelAsync / FinalizeLoadLevel
00386                 // methods.
00387                 m_timer->Reset();
00388                 m_currentLevel++;
00389                 m_levelBonusTime = m_levelTimeRemaining;
00390                 SaveState();
00391                 return GameState::LevelComplete;
00392             }
00393             else
00394             {
00395                 // All levels have been completed.
00396                 m_timer->Reset();
00397                 m_gameActive = false;
00398                 m_levelActive = false;
00399                 SaveState();
00400
00401                 if (m_totalHits > m_topScore.totalHits)
00402                 {
00403                     // There is a new high score so save it.
00404                     m_topScore.totalHits = m_totalHits;
00405                     m_topScore.totalShots = m_totalShots;
00406                     m_topScore.levelCompleted = m_currentLevel;
00407
00408                     SaveHighScore();
00409                 }
00410                 return GameState::GameComplete;
00411             }
00412         }
00413     }
00414     return GameState::Active;
00415 }
00416
00417 //----------------------------------------------------------------------
00418
00419 void Simple3DGame::OnSuspending()
00420 {
00421     m_audioController->SuspendAudio();
00422 }
00423
00424 //----------------------------------------------------------------------
00425
00426 void Simple3DGame::OnResuming()
00427 {
00428     m_audioController->ResumeAudio();
00429 }
00430
00431 //----------------------------------------------------------------------
00432
00433 void Simple3DGame::UpdateDynamics()
00434 {
00435     float timeTotal = m_timer->PlayingTime();
00436     float timeFrame = m_timer->DeltaTime();
00437     bool fire = m_controller->IsFiring();
00438
00439 #pragma region Shoot Ammo
00440     // Shoot ammo.
00441     if (fire)
00442     {
00443         static float lastFired;  // Timestamp of last ammo fired.
00444
00445         if (timeTotal < lastFired)
00446         {
00447             // timeTotal is not guarenteed to be monotomically increasing because it is
00448             // reset at each level.
00449             lastFired = timeTotal - GameConstants::Physics::AutoFireDelay;
00450         }
00451
00452         if (timeTotal - lastFired >= GameConstants::Physics::AutoFireDelay)
00453         {
00454             // Get inverse view matrix.
00455             XMMATRIX invView;
00456             XMVECTOR det;
00457             invView = XMMatrixInverse(&det, m_camera->View());
00458
00459             // Compute initial velocity in world space from camera space.
00460             XMFLOAT4 initialVelocity(0.0f, 0.0f, 15.0f, 0.0f);
00461             m_ammo[m_ammoNext]->Velocity(XMVector4Transform(XMLoadFloat4(&initialVelocity), invView));
00462
00463             // Set the initial position of the ammo to be fired. The position is offset from the player
00464             // to avoid an initial collision with the player object.
00465             XMFLOAT4 initialPosition(0.0f, -0.15f, m_player->Radius() + GameConstants::AmmoSize, 1.0f);
00466             m_ammo[m_ammoNext]->Position(XMVector4Transform(XMLoadFloat4(&initialPosition), invView));
00467
00468             // Initially not laying on ground.
00469             m_ammo[m_ammoNext]->OnGround(false);
00470             m_ammo[m_ammoNext]->Active(true);
00471
00472             // Set position in array of next Ammo to use.
00473             // We will re-use ammo taking the least recently used once we have hit the
00474             // MaxAmmo in use.
00475             m_ammoNext = (m_ammoNext + 1) % GameConstants::MaxAmmo;
00476             m_ammoCount = min(m_ammoCount + 1, GameConstants::MaxAmmo);
00477
00478             lastFired = timeTotal;
00479             m_totalShots++;
00480         }
00481     }
00482 #pragma endregion
00483
00484 #pragma region Animate Objects
00485     // Walk the list of objects looking for any objects that have an animation associated with it.
00486     // Update the position of the object based on evaluating the animation object with the current time.
00487     // Once the current time (timeTotal) is past the end of the animation time remove
00488     // the animation object since it is no longer needed.
00489     for (uint32 i = 0; i < m_objects.size(); i++)
00490     {
00491         if (m_objects[i]->AnimatePosition())
00492         {
00493             m_objects[i]->Position(m_objects[i]->AnimatePosition()->Evaluate(timeTotal));
00494             if (m_objects[i]->AnimatePosition()->IsFinished(timeTotal))
00495             {
00496                 m_objects[i]->AnimatePosition(nullptr);
00497             }
00498         }
00499     }
00500 #pragma endregion
00501
00502     // If the elapsed time is too long, we slice up the time and handle physics over several
00503     // smaller time steps to avoid missing collisions.
00504     float timeLeft = timeFrame;
00505     float elapsedFrameTime;
00506     while (timeLeft > 0.0f)
00507     {
00508         elapsedFrameTime = min(timeLeft, GameConstants::Physics::FrameLength);
00509         timeLeft -= elapsedFrameTime;
00510
00511         // Update the player position.
00512         m_player->Position(m_player->VectorPosition() + m_player->VectorVelocity() * elapsedFrameTime);
00513
00514         // Do m_player / object intersections.
00515         for (uint32 a = 0; a < m_objects.size(); a++)
00516         {
00517             if (m_objects[a]->Active() && m_objects[a] != m_player)
00518             {
00519                 XMFLOAT3 contact;
00520                 XMFLOAT3 normal;
00521
00522                 if (m_objects[a]->IsTouching(m_player->Position(), m_player->Radius(), &contact, &normal))
00523                 {
00524                     // Player is in contact with m_objects[a].
00525                     XMVECTOR oneToTwo;
00526                     oneToTwo = -XMLoadFloat3(&normal);
00527
00528                     float impact = XMVectorGetX(
00529                         XMVector3Dot (oneToTwo, m_player->VectorVelocity())
00530                         );
00531                     // Make sure that the player is actually headed towards the object. At grazing angles there
00532                     // could appear to be an impact when the player is actually already hit and moving away.
00533                     if (impact > 0.0f)
00534                     {
00535                         // Compute the normal and tangential components of the player's velocity.
00536                         XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, m_player->VectorVelocity()) * oneToTwo;
00537                         XMVECTOR velocityOneTangent = m_player->VectorVelocity() - velocityOneNormal;
00538
00539                         // Compute post-collision velocity.
00540                         m_player->Velocity(velocityOneTangent - velocityOneNormal);
00541
00542                         // Fix the positions so that the player is just touching the object.
00543                         float distanceToMove = m_player->Radius();
00544                         m_player->Position(XMLoadFloat3(&contact) - (oneToTwo * distanceToMove));
00545                     }
00546                 }
00547             }
00548         }
00549         {
00550             // Do collision detection of the player with the bounding world.
00551             XMFLOAT3 position = m_player->Position();
00552             XMFLOAT3 velocity = m_player->Velocity();
00553             float radius = m_player->Radius();
00554
00555             // Check for player collisions with the walls floor or ceiling and adjust the position.
00556             float limit = m_minBound.x + radius;
00557             if (position.x < limit)
00558             {
00559                 position.x = limit;
00560                 velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
00561             }
00562             limit = m_maxBound.x - radius;
00563             if (position.x > limit)
00564             {
00565                 position.x = limit;
00566                 velocity.x = -velocity.x + GameConstants::Physics::GroundRestitution;
00567             }
00568             limit = m_minBound.y + radius;
00569             if (position.y < limit)
00570             {
00571                 position.y = limit;
00572                 velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
00573             }
00574             limit = m_maxBound.y - radius;
00575             if (position.y > limit)
00576             {
00577                 position.y = limit;
00578                 velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
00579             }
00580             limit = m_minBound.z + radius;
00581             if (position.z < limit)
00582             {
00583                 position.z = limit;
00584                 velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
00585             }
00586             limit = m_maxBound.z - radius;
00587             if (position.z > limit)
00588             {
00589                 position.z = limit;
00590                 velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
00591             }
00592             m_player->Position(position);
00593             m_player->Velocity(velocity);
00594         }
00595
00596         // Animate the ammo.
00597         if (m_ammoCount > 0)
00598         {
00599             // Check for collisions between ammo.
00600 #pragma region inter-ammo collision detection
00601             if (m_ammoCount > 1)
00602             {
00603                 for (uint32 one = 0; one < m_ammoCount; one++)
00604                 {
00605                     for (uint32 two = (one + 1); two < m_ammoCount; two++)
00606                     {
00607                         // Check collision between instances One and Two.
00608                         // OneToTwo is the vector between the centers of the two ammo that are being checked.
00609                         XMVECTOR oneToTwo;
00610                         oneToTwo = m_ammo[two]->VectorPosition() - m_ammo[one]->VectorPosition();
00611                         float distanceSquared;
00612                         distanceSquared = XMVectorGetX(
00613                             XMVector3LengthSq(oneToTwo)
00614                             );
00615                         if (distanceSquared < (GameConstants::AmmoSize * GameConstants::AmmoSize))
00616                         {
00617                             // The two ammo are intersecting.
00618                             oneToTwo = XMVector3Normalize(oneToTwo);
00619
00620                             // Check if the two instances are already moving away from each other.
00621                             // If so, skip collision.  This can happen when a lot of instances are
00622                             // bunched up next to each other.
00623                             float impact;
00624                             impact = XMVectorGetX(
00625                                 XMVector3Dot(oneToTwo, m_ammo[one]->VectorVelocity()) -
00626                                 XMVector3Dot(oneToTwo, m_ammo[two]->VectorVelocity())
00627                                 );
00628                             if (impact > 0.0f)
00629                             {
00630                                 // Compute the normal and tangential components of one's velocity.
00631                                 XMVECTOR velocityOne = (1 - GameConstants::Physics::BounceLost) * m_ammo[one]->VectorVelocity();
00632                                 XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, velocityOne) * oneToTwo;
00633                                 XMVECTOR velocityOneTangent = velocityOne - velocityOneNormal;
00634                                 // Compute the normal and tangential components of two's velocity.
00635                                 XMVECTOR velocityTwo = (1 - GameConstants::Physics::BounceLost) * m_ammo[two]->VectorVelocity();
00636                                 XMVECTOR velocityTwoNormal = XMVector3Dot(oneToTwo, velocityTwo) * oneToTwo;
00637                                 XMVECTOR velocityTwoTangent = velocityTwo - velocityTwoNormal;
00638
00639                                 // Compute the post-collision velocities.
00640                                 m_ammo[one]->Velocity(velocityOneTangent - velocityOneNormal * (1 - GameConstants::Physics::BounceTransfer) +
00641                                     velocityTwoNormal * GameConstants::Physics::BounceTransfer
00642                                     );
00643                                 m_ammo[two]->Velocity(velocityTwoTangent - velocityTwoNormal * (1 - GameConstants::Physics::BounceTransfer) +
00644                                     velocityOneNormal * GameConstants::Physics::BounceTransfer
00645                                     );
00646
00647                                 // Fix the positions so that the two balls are exactly GameConstants::AmmoSize apart.
00648                                 float distanceToMove = (GameConstants::AmmoSize - sqrtf(distanceSquared)) * 0.5f;
00649                                 m_ammo[one]->Position(m_ammo[one]->VectorPosition() - (oneToTwo * distanceToMove));
00650                                 m_ammo[two]->Position(m_ammo[two]->VectorPosition() + (oneToTwo * distanceToMove));
00651
00652                                 // Flag the two instances so that they are not laying on ground.
00653                                 m_ammo[one]->OnGround(false);
00654                                 m_ammo[two]->OnGround(false);
00655
00656                                 // Start playing the sounds for the impact between the two balls.
00657                                 m_ammo[one]->PlaySound(impact, m_player->Position());
00658                                 m_ammo[two]->PlaySound(impact, m_player->Position());
00659                             }
00660                         }
00661                     }
00662                 }
00663             }
00664 #pragma endregion
00665
00666 #pragma region Ammo-Object intersections
00667             // Check for intersections between the ammo and the other objects in the scene.
00668             for (uint32 one = 0; one < m_ammoCount; one++)
00669             {
00670                 if (m_objects.size() > 0)
00671                 {
00672                     if (!m_ammo[one]->OnGround())
00673                     {
00674                         for (uint32 i = 0; i < m_objects.size(); i++)
00675                         {
00676                             if (m_objects[i]->Active())
00677                             {
00678                                 // The object is currently active in the scene. There may be objects in the list
00679                                 // that are currently inactive, so those are skipped.
00680                                 XMFLOAT3 contact;
00681                                 XMFLOAT3 normal;
00682
00683                                 if (m_objects[i]->IsTouching(m_ammo[one]->Position(), GameConstants::AmmoRadius, &contact, &normal))
00684                                 {
00685                                     // Ball is in contact with Object.
00686                                     XMVECTOR oneToTwo;
00687                                     oneToTwo = -XMLoadFloat3(&normal);
00688
00689                                     float impact;
00690                                     impact = XMVectorGetX(
00691                                         XMVector3Dot (oneToTwo, m_ammo[one]->VectorVelocity())
00692                                         );
00693                                     // Make sure that the ball is actually headed towards the object. At grazing angles there
00694                                     // could appear to be an impact when the ball is actually already hit and moving away.
00695                                     if (impact > 0.0f)
00696                                     {
00697                                         // Compute the normal and tangential components of the ammo's velocity.
00698                                         XMVECTOR velocityOne = (1 - GameConstants::Physics::BounceLost) * m_ammo[one]->VectorVelocity();
00699                                         XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, velocityOne) * oneToTwo;
00700                                         XMVECTOR velocityOneTangent = velocityOne - velocityOneNormal;
00701
00702                                         // Compute post-collision velocity of the ammo.
00703                                         m_ammo[one]->Velocity(velocityOneTangent - velocityOneNormal * (1 - GameConstants::Physics::BounceTransfer));
00704
00705                                         // Fix the position so that the ball is exactly GameConstants::AmmoRadius from target.
00706                                         float distanceToMove = GameConstants::AmmoSize;
00707                                         m_ammo[one]->Position(XMLoadFloat3(&contact) - (oneToTwo * distanceToMove));
00708
00709                                         // Flag the Ammo as not laying on ground.
00710                                         m_ammo[one]->OnGround(false);
00711
00712                                         // Play the sound associated with the Ammo hitting something.
00713                                         m_ammo[one]->PlaySound(impact, m_player->Position());
00714
00715                                         if (m_objects[i]->Target() && !m_objects[i]->Hit())
00716                                         {
00717                                             // The object is a target and isn't currently hit, so mark it as hit and
00718                                             // play the sound associated with the impact.
00719                                             m_objects[i]->Hit(true);
00720                                             m_objects[i]->HitTime(timeTotal);
00721                                             m_totalHits++;
00722
00723                                             m_objects[i]->PlaySound(impact, m_player->Position());
00724                                         }
00725                                     }
00726                                 }
00727                             }
00728                         }
00729                     }
00730                 }
00731             }
00732 #pragma endregion
00733
00734 #pragma region Apply Gravity and world intersection
00735             // Apply gravity and check for collision against enclosing volume.
00736             for (uint32 i = 0; i < m_ammoCount; i++)
00737             {
00738                 // Update the position and velocity of the ammo instance.
00739                 m_ammo[i]->Position(m_ammo[i]->VectorPosition() + m_ammo[i]->VectorVelocity() * elapsedFrameTime);
00740
00741                 XMFLOAT3 velocity = m_ammo[i]->Velocity();
00742                 XMFLOAT3 position = m_ammo[i]->Position();
00743
00744                 velocity.x -= velocity.x * 0.1f * elapsedFrameTime;
00745                 velocity.z -= velocity.z * 0.1f * elapsedFrameTime;
00746                 if (!m_ammo[i]->OnGround())
00747                 {
00748                     // Apply gravity if the ammo instance is not already resting on the ground.
00749                     velocity.y -= GameConstants::Physics::Gravity * elapsedFrameTime;
00750                 }
00751
00752                 if (!m_ammo[i]->OnGround())
00753                 {
00754                     float limit = m_minBound.y + GameConstants::AmmoRadius;
00755                     if (position.y < limit)
00756                     {
00757                         // The ammo instance hit the ground.
00758                         // Align the ammo instance to the ground, invert the Y component of the velocity and
00759                         // play the impact sound. The X and Z velocity components will be reduced
00760                         // because of friction.
00761                         position.y = limit;
00762                         m_ammo[i]->PlaySound(-velocity.y, m_player->Position());
00763
00764                         velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
00765                         velocity.x *= GameConstants::Physics::Friction;
00766                         velocity.z *= GameConstants::Physics::Friction;
00767                     }
00768                 }
00769                 else
00770                 {
00771                     // The ammo instance is resting or rolling on ground.
00772                     // X and Z velocity components are reduced because of friction.
00773                     velocity.x *= GameConstants::Physics::Friction;
00774                     velocity.z *= GameConstants::Physics::Friction;
00775                 }
00776
00777                 float limit = m_maxBound.y - GameConstants::AmmoRadius;
00778                 if (position.y > limit)
00779                 {
00780                     // The ammo instance hit the ceiling.
00781                     // Align the ammo instance to the ceiling, invert the Y component of the velocity and
00782                     // play the impact sound. The X and Z velocity components will be reduced
00783                     // because of friction.
00784                     position.y = limit;
00785                     m_ammo[i]->PlaySound(-velocity.y, m_player->Position());
00786
00787                     velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
00788                     velocity.x *= GameConstants::Physics::Friction;
00789                     velocity.z *= GameConstants::Physics::Friction;
00790                 }
00791
00792                 limit = m_minBound.y + GameConstants::AmmoRadius;
00793                 if ((GameConstants::Physics::Gravity * (position.y - limit) + 0.5f * velocity.y * velocity.y) < GameConstants::Physics::RestThreshold)
00794                 {
00795                     // The Y velocity component is below the resting threshold so flag the instance as
00796                     // laying on the ground and set the Y velocity component to zero.
00797                     position.y = limit;
00798                     velocity.y = 0.0f;
00799                     m_ammo[i]->OnGround(true);
00800                 }
00801
00802                 limit = m_minBound.z + GameConstants::AmmoRadius;
00803                 if (position.z < limit)
00804                 {
00805                     // The ammo instance hit the a wall in the min Z direction.
00806                     // Align the ammo instance to the wall, invert the Z component of the velocity and
00807                     // play the impact sound.
00808                     position.z = limit;
00809                     m_ammo[i]->PlaySound(-velocity.z, m_player->Position());
00810                     velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
00811                 }
00812
00813                 limit = m_maxBound.z - GameConstants::AmmoRadius;
00814                 if (position.z > limit)
00815                 {
00816                     // The ammo instance hit the a wall in the max Z direction.
00817                     // Align the ammo instance to the wall, invert the Z component of the velocity and
00818                     // play the impact sound.
00819                     position.z = limit;
00820                     m_ammo[i]->PlaySound(-velocity.z, m_player->Position());
00821                     velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
00822                 }
00823
00824                 limit = m_minBound.x + GameConstants::AmmoRadius;
00825                 if (position.x < limit)
00826                 {
00827                     // The ammo instance hit the a wall in the min X direction.
00828                     // Align the ammo instance to the wall, invert the X component of the velocity and
00829                     // play the impact sound.
00830                     position.x = limit;
00831                     m_ammo[i]->PlaySound(-velocity.x, m_player->Position());
00832                     velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
00833                 }
00834
00835                 limit = m_maxBound.x - GameConstants::AmmoRadius;
00836                 if (position.x > limit)
00837                 {
00838                     // The ammo instance hit the a wall in the max X direction.
00839                     // Align the ammo instance to the wall, invert the X component of the velocity and
00840                     // play the impact sound.
00841                     position.x = limit;
00842                     m_ammo[i]->PlaySound(-velocity.x, m_player->Position());
00843                     velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
00844                 }
00845
00846                 // Save the updated velocity and position for the ammo instance.
00847                 m_ammo[i]->Velocity(velocity);
00848                 m_ammo[i]->Position(position);
00849             }
00850         }
00851     }
00852 #pragma endregion
00853 }
00854
00855 //----------------------------------------------------------------------
00856
00857 void Simple3DGame::SaveState()
00858 {
00859     // Save basic state of the game.
00860     m_savedState->SaveBool(":GameActive", m_gameActive);
00861     m_savedState->SaveBool(":LevelActive", m_levelActive);
00862     m_savedState->SaveInt32(":LevelCompleted", m_currentLevel);
00863     m_savedState->SaveInt32(":TotalShots", m_totalShots);
00864     m_savedState->SaveInt32(":TotalHits", m_totalHits);
00865     m_savedState->SaveSingle(":BonusRoundTime", m_levelBonusTime);
00866     m_savedState->SaveXMFLOAT3(":PlayerPosition", m_player->Position());
00867     m_savedState->SaveXMFLOAT3(":PlayerLookDirection", m_controller->LookDirection());
00868
00869     if (m_levelActive)
00870     {
00871         // The game is currently in the middle of a level, so save the extended state of
00872         // the game.
00873         m_savedState->SaveSingle(":LevelDuration", m_levelDuration);
00874         m_savedState->SaveSingle(":LevelPlayingTime", m_timer->PlayingTime());
00875
00876         m_savedState->SaveInt32(":AmmoCount", m_ammoCount);
00877         m_savedState->SaveInt32(":AmmoNext", m_ammoNext);
00878
00879         const int bufferLength = 16;
00880         char16 str[bufferLength];
00881
00882         for (uint32 i = 0; i < m_ammoCount; i++)
00883         {
00884             int len = swprintf_s(str, bufferLength, L"%d", i);
00885             Platform::String^ string = ref new Platform::String(str, len);
00886
00887             m_savedState->SaveBool(Platform::String::Concat(":AmmoActive", string), m_ammo[i]->Active());
00888             m_savedState->SaveXMFLOAT3(Platform::String::Concat(":AmmoPosition", string), m_ammo[i]->Position());
00889             m_savedState->SaveXMFLOAT3(Platform::String::Concat(":AmmoVelocity", string), m_ammo[i]->Velocity());
00890         }
00891
00892         m_savedState->SaveInt32(":ObjectCount", static_cast<int>(m_objects.size()));
00893
00894         for (uint32 i = 0; i < m_objects.size(); i++)
00895         {
00896             int len = swprintf_s(str, bufferLength, L"%d", i);
00897             Platform::String^ string = ref new Platform::String(str, len);
00898
00899             m_savedState->SaveBool(Platform::String::Concat(":ObjectActive", string), m_objects[i]->Active());
00900             m_savedState->SaveBool(Platform::String::Concat(":ObjectTarget", string), m_objects[i]->Target());
00901             m_savedState->SaveXMFLOAT3(Platform::String::Concat(":ObjectPosition", string), m_objects[i]->Position());
00902         }
00903
00904         m_level[m_currentLevel]->SaveState(m_savedState);
00905     }
00906 }
00907
00908 //----------------------------------------------------------------------
00909
00910 void Simple3DGame::LoadState()
00911 {
00912     m_gameActive = m_savedState->LoadBool(":GameActive", m_gameActive);
00913     m_levelActive = m_savedState->LoadBool(":LevelActive", m_levelActive);
00914
00915     if (m_gameActive)
00916     {
00917         // Loading from the last known state means the game wasn't finished when it was last played,
00918         // so set the current level.
00919
00920         m_totalShots = m_savedState->LoadInt32(":TotalShots", 0);
00921         m_totalHits = m_savedState->LoadInt32(":TotalHits", 0);
00922         m_currentLevel = m_savedState->LoadInt32(":LevelCompleted", 0);
00923         m_levelBonusTime = m_savedState->LoadSingle(":BonusRoundTime", 0.0f);
00924
00925         m_levelTimeRemaining = m_levelBonusTime;
00926
00927         // Reload the current player position and set both the camera and the controller
00928         // with the current Look Direction.
00929         m_player->Position(
00930             m_savedState->LoadXMFLOAT3(":PlayerPosition", XMFLOAT3(0.0f, 0.0f, 0.0f))
00931             );
00932         m_camera->Eye(m_player->Position());
00933         m_camera->LookDirection(
00934             m_savedState->LoadXMFLOAT3(":PlayerLookDirection", XMFLOAT3(0.0f, 0.0f, 1.0f))
00935             );
00936         m_controller->Pitch(m_camera->Pitch());
00937         m_controller->Yaw(m_camera->Yaw());
00938     }
00939     else
00940     {
00941         // The game was not being played when it was last saved, so initialize to the beginning.
00942         m_currentLevel = 0;
00943         m_levelBonusTime = 0;
00944     }
00945 }
00946
00947 //----------------------------------------------------------------------
00948
00949 void Simple3DGame::SetCurrentLevelToSavedState()
00950 {
00951     if (m_gameActive)
00952     {
00953         if (m_levelActive)
00954         {
00955             // Middle of a level so restart where left off.
00956             m_levelDuration = m_savedState->LoadSingle(":LevelDuration", 0.0f);
00957
00958             m_timer->Reset();
00959             m_timer->PlayingTime(m_savedState->LoadSingle(":LevelPlayingTime", 0.0f));
00960
00961             m_ammoCount = m_savedState->LoadInt32(":AmmoCount", 0);
00962
00963             m_ammoNext = m_savedState->LoadInt32(":AmmoNext", 0);
00964
00965             const int bufferLength = 16;
00966             char16 str[bufferLength];
00967
00968             for (uint32 i = 0; i < m_ammoCount; i++)
00969             {
00970                 int len = swprintf_s(str, bufferLength, L"%d", i);
00971                 Platform::String^ string = ref new Platform::String(str, len);
00972
00973                 m_ammo[i]->Active(
00974                     m_savedState->LoadBool(
00975                         Platform::String::Concat(":AmmoActive", string),
00976                         m_ammo[i]->Active()
00977                         )
00978                     );
00979                 if (m_ammo[i]->Active())
00980                 {
00981                     m_ammo[i]->OnGround(false);
00982                 }
00983
00984                 m_ammo[i]->Position(
00985                     m_savedState->LoadXMFLOAT3(
00986                         Platform::String::Concat(":AmmoPosition", string),
00987                         m_ammo[i]->Position()
00988                         )
00989                     );
00990
00991                 m_ammo[i]->Velocity(
00992                     m_savedState->LoadXMFLOAT3(
00993                         Platform::String::Concat(":AmmoVelocity", string),
00994                         m_ammo[i]->Velocity()
00995                         )
00996                     );
00997             }
00998
00999             int storedObjectCount = 0;
01000             storedObjectCount = m_savedState->LoadInt32(":ObjectCount", 0);
01001
01002             storedObjectCount = min(storedObjectCount, static_cast<int>(m_objects.size()));
01003
01004             for (int i = 0; i < storedObjectCount; i++)
01005             {
01006                 int len = swprintf_s(str, bufferLength, L"%d", i);
01007                 Platform::String^ string = ref new Platform::String(str, len);
01008
01009                 m_objects[i]->Active(
01010                     m_savedState->LoadBool(
01011                         Platform::String::Concat(":ObjectActive", string),
01012                         m_objects[i]->Active()
01013                         )
01014                     );
01015
01016                 m_objects[i]->Target(
01017                     m_savedState->LoadBool(
01018                         Platform::String::Concat(":ObjectTarget", string),
01019                         m_objects[i]->Target()
01020                         )
01021                     );
01022
01023                 m_objects[i]->Position(
01024                     m_savedState->LoadXMFLOAT3(
01025                         Platform::String::Concat(":ObjectPosition", string),
01026                         m_objects[i]->Position()
01027                         )
01028                     );
01029             }
01030
01031             m_level[m_currentLevel]->LoadState(m_savedState);
01032             m_levelTimeRemaining = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime - m_timer->PlayingTime();
01033         }
01034     }
01035 }
01036
01037 //----------------------------------------------------------------------
01038
01039 void Simple3DGame::SaveHighScore()
01040 {
01041     m_savedState->SaveInt32(":HighScore:LevelCompleted", m_topScore.levelCompleted);
01042     m_savedState->SaveInt32(":HighScore:TotalShots", m_topScore.totalShots);
01043     m_savedState->SaveInt32(":HighScore:TotalHits", m_topScore.totalHits);
01044 }
01045
01046 //----------------------------------------------------------------------
01047
01048 void Simple3DGame::LoadHighScore()
01049 {
01050     m_topScore.levelCompleted = m_savedState->LoadInt32(":HighScore:LevelCompleted", 0);
01051     m_topScore.totalShots = m_savedState->LoadInt32(":HighScore:TotalShots", 0);
01052     m_topScore.totalHits = m_savedState->LoadInt32(":HighScore:TotalHits", 0);
01053 }
01054
01055 //----------------------------------------------------------------------
01056
01057 void Simple3DGame::InitializeAmmo()
01058 {
01059     m_ammoCount = 0;
01060     m_ammoNext = 0;
01061     for (uint32 i = 0; i < GameConstants::MaxAmmo; i++)
01062     {
01063         m_ammo[i]->Active(false);
01064     }
01065 }
01066
01067 //----------------------------------------------------------------------
01068
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/Scenario1.xaml.cpp Source File

  • Web authentication broker

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::WebAuthentication;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 using namespace Concurrency;
00026 using namespace Platform;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Security::Authentication::Web;
00030
00031 Scenario1::Scenario1()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046 }
00047
00048 void SDKSample::WebAuthentication::Scenario1::Launch_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00049 {
00050     FacebookDebugArea->Text = "";
00051     FacebookReturnedToken->Text = "";
00052
00053     String^ facebookURL = "https://www.facebook.com/dialog/oauth?client_id=";
00054
00055     auto clientID = FacebookClientID->Text;
00056     if (clientID == nullptr || clientID->IsEmpty())
00057     {
00058         FacebookDebugArea->Text = "Enter a ClientID";
00059         return;
00060     }
00061
00062     facebookURL += clientID + "&redirect_uri=https%3A%2F%2Fwww.facebook.com%2Fconnect%2Flogin_success.html&scope=read_stream&display=popup&response_type=token";
00063
00064     try
00065     {
00066         auto facebookOutput = FacebookDebugArea;
00067         auto facebookToken = FacebookReturnedToken;
00068
00069         auto startURI = ref new Uri(facebookURL);
00070         auto endURI = ref new Uri("https://www.facebook.com/connect/login_success.html");
00071         FacebookDebugArea->Text += "Navigating to: " + facebookURL + "\n";
00072
00073         create_task(WebAuthenticationBroker::AuthenticateAsync(WebAuthenticationOptions::None, startURI, endURI)).then([this](WebAuthenticationResult^ result)
00074         {
00075             String^ statusString;
00076             switch (result->ResponseStatus)
00077             {
00078             case WebAuthenticationStatus::ErrorHttp:
00079                 statusString = "ErrorHttp: " + result->ResponseErrorDetail;
00080                 break;
00081             case WebAuthenticationStatus::Success:
00082                 statusString = "Success";
00083                 FacebookReturnedToken->Text += result->ResponseData;
00084                 break;
00085             case WebAuthenticationStatus::UserCancel:
00086                 statusString = "UserCancel";
00087                 break;
00088             }
00089
00090             FacebookDebugArea->Text += "Status returned by WebAuth broker: " + statusString;
00091
00092          });
00093     }
00094     catch (Exception^ ex)
00095     {
00096         FacebookDebugArea->Text += "Error launching WebAuth " + ex->Message;
00097         return;
00098     }
00099 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBrowserView.xaml.h Source File

  • Hilo C++
  • Hilo

ImageBrowserView.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "BooleanToBrushConverter.h" // Required by generated header
00010 #include "Common\BooleanNegationConverter.h" // Required by generated header
00011 #include "ImageBrowserView.g.h"
00012
00013 namespace Hilo
00014 {
00015     // See http://go.microsoft.com/fwlink/?LinkId=267278 for info on how Hilo creates pages and navigates to pages.
00016
00017     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how view classes interact
00018     // with corresponding view model classes that encapsulate the app’s state, actions, and operations.
00019
00020     // See http://go.microsoft.com/fwlink/?LinkId=267279 for info on how Hilo pages use XAML controls.
00021
00022     // The ImageBrowserView class implements the browser page.
00023     public ref class ImageBrowserView sealed
00024     {
00025     public:
00026         ImageBrowserView();
00027
00028     private:
00029         void OnPhotoItemClicked(Platform::Object^ sender, Windows::UI::Xaml::Controls::ItemClickEventArgs^ e);
00030         void OnViewChangeCompleted(Platform::Object^ sender, Windows::UI::Xaml::Controls::SemanticZoomViewChangedEventArgs^ e);
00031         void OnZoomedOutGridPointerEntered(Platform::Object^ sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^ e);
00032     };
00033 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/pch.cpp Source File

  • Direct2D save to image file

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BooleanNegationConverter.cpp Source File

  • Hilo C++
  • Hilo
  • Common

BooleanNegationConverter.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "BooleanNegationConverter.h"
00009
00010 using namespace Hilo::Common;
00011
00012 using namespace Platform;
00013 using namespace Windows::Foundation;
00014 using namespace Windows::UI::Xaml::Interop;
00015
00016 Object^ BooleanNegationConverter::Convert(Object^ value, TypeName targetType, Object^ parameter, String^ language)
00017 {
00018   (void) targetType;  // Unused parameter
00019   (void) parameter; // Unused parameter
00020   (void) language;  // Unused parameter
00021
00022   auto boxedBool = dynamic_cast<Box<bool>^>(value);
00023   auto boolValue = (boxedBool != nullptr && boxedBool->Value);
00024   return !boolValue;
00025 }
00026
00027 Object^ BooleanNegationConverter::ConvertBack(Object^ value, TypeName targetType, Object^ parameter, String^ language)
00028 {
00029   (void) targetType;  // Unused parameter
00030   (void) parameter; // Unused parameter
00031   (void) language;  // Unused parameter
00032
00033   auto boxedBool = dynamic_cast<Box<bool>^>(value);
00034   auto boolValue = (boxedBool != nullptr && boxedBool->Value);
00035   return !boolValue;
00036 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/App.xaml.cpp Source File

  • CameraOptionsUI

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/pch.h Source File

  • Application data

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::ListViewSimple::sealed Member List

This is the complete list of members for SDKSample::ListViewSimple::sealed, including all inherited members.
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ListViewSimple::sealed | [private]
DoSomething_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ListViewSimple::sealed | [private]
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ListViewSimple::sealed | [private]
ItemClickHandler(Platform::Object^sender, Windows::UI::Xaml::Controls::ItemClickEventArgs^e) | SDKSample::ListViewSimple::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ListViewSimple::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ListViewSimple::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ListViewSimple::sealed | [protected, virtual]
Other_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ListViewSimple::sealed | [private]
rootPage | SDKSample::ListViewSimple::sealed | [private]
Scenario1() | SDKSample::ListViewSimple::sealed |
Scenario2() | SDKSample::ListViewSimple::sealed |
Scenario3() | SDKSample::ListViewSimple::sealed |
storeData | SDKSample::ListViewSimple::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/DirectXSample.h Source File

  • Direct2D save to image file

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Face.h Source File

  • DirectX 3D shooting game

Face.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Face:
00011 // This class is a specialization of GameObject that represents a parallelogram primitive.
00012 // The face is defined by three points.  It is positioned at 'origin'.  The four corners
00013 // of the face are defined at 'origin', 'p1', 'p2' and 'p1' + ('p2' - 'origin').
00014
00015 #include "GameObject.h"
00016
00017 ref class Face: public GameObject
00018 {
00019 internal:
00020     Face();
00021     Face(
00022         DirectX::XMFLOAT3 origin,
00023         DirectX::XMFLOAT3 p1,
00024         DirectX::XMFLOAT3 p2
00025         );
00026
00027     void SetPlane(
00028         DirectX::XMFLOAT3 origin,
00029         DirectX::XMFLOAT3 p1,
00030         DirectX::XMFLOAT3 p2
00031         );
00032
00033     virtual bool IsTouching(
00034         DirectX::XMFLOAT3 point,
00035         float radius,
00036         _Out_ DirectX::XMFLOAT3 *contact,
00037         _Out_ DirectX::XMFLOAT3 *normal
00038         ) override;
00039
00040 protected:
00041     virtual void UpdatePosition() override;
00042
00043 private:
00044     void UpdateMatrix();
00045
00046     DirectX::XMFLOAT3   m_widthVector;
00047     DirectX::XMFLOAT3   m_heightVector;
00048     DirectX::XMFLOAT3   m_normal;
00049     DirectX::XMFLOAT3   m_point[4];
00050     float               m_width;
00051     float               m_height;
00052     DirectX::XMFLOAT4X4 m_rotationMatrix;
00053 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/MainPage.xaml.cpp Source File

  • Context menu

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicReaderWriter.cpp Source File

  • DXGI swap chain rotation

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/DDSTextureLoader.cpp Source File

  • XAML DirectX 3D shooting game

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::SnapSample::sealed Member List

This is the complete list of members for SDKSample::SnapSample::sealed, including all inherited members.
_layoutHandlerToken | SDKSample::SnapSample::sealed | [private]
ConvertViewState(Windows::UI::ViewManagement::ApplicationViewState state) | SDKSample::SnapSample::sealed | [private]
Page_SizeChanged(Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | SDKSample::SnapSample::sealed | [private]
Scenario1() | SDKSample::SnapSample::sealed |
UnsnapButton_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::SnapSample::sealed | [private]
UpdateForViewState() | SDKSample::SnapSample::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/cppsamplesutils.h Source File

  • Input Device capabilities

cppsamplesutils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/MainPage.xaml.h Source File

  • IXmlReader and IXmlWriter XML data readwrite

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/DateConverter.h Source File

  • Getting started with C++ simple blog reader

DateConverter.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008
00009 //dateconverter.h
00010
00011 #pragma once
00012
00013 namespace SimpleBlogReader
00014 {
00015     [Windows::Foundation::Metadata::WebHostHidden]
00016     public ref class DateConverter sealed : public Windows::UI::Xaml::Data::IValueConverter
00017     {
00018     public:
00019         virtual Platform::Object^ Convert(Platform::Object^ value,
00020             Windows::UI::Xaml::Interop::TypeName targetType,
00021             Platform::Object^ parameter,
00022             Platform::String^ language)
00023         {
00024             if (value == nullptr)
00025             {
00026                 throw ref new Platform::InvalidArgumentException();
00027             }
00028             Windows::Foundation::DateTime dt = (Windows::Foundation::DateTime) value;
00029             Platform::String^ param = safe_cast<Platform::String^>(parameter);
00030             Platform::String^ result;
00031
00032             // This is called by the items page which requires simple formatting.
00033             if (param == nullptr)
00034             {
00035                 Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ dtf =
00036                         Windows::Globalization::DateTimeFormatting::DateTimeFormatter::ShortDate::get();
00037                 result = dtf->Format(dt);
00038             }
00039
00040             // These are called by the split page to format each date element separately:
00041             else if (wcscmp(param->Data(), L"month") == 0)
00042             {
00043                 Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ month =
00044                     ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("{month.abbreviated(3)}");
00045                 result = month->Format(dt);
00046             }
00047             else if (wcscmp(param->Data(), L"day") == 0)
00048             {
00049                 Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ month =
00050                     ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("{day.integer(2)}");
00051                 result = month->Format(dt);
00052             }
00053             else if (wcscmp(param->Data(), L"year") == 0)
00054             {
00055                 Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ month =
00056                     ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("{year.full}");
00057                 result = month->Format(dt);
00058             }
00059             else
00060             {
00061                 // We don't handle other format types currently.
00062                 throw ref new Platform::InvalidArgumentException();
00063             }
00064
00065             return result;
00066         }
00067
00068         virtual Platform::Object^ ConvertBack(Platform::Object^ value,
00069             Windows::UI::Xaml::Interop::TypeName targetType,
00070             Platform::Object^ parameter,
00071             Platform::String^ language)
00072         {
00073             // Not needed in SimpleBlogReader. Left as an exercise.
00074             throw ref new Platform::NotImplementedException();
00075         }
00076     };
00077 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioOutput1.xaml.cpp Source File

  • Edge gesture invocation

ScenarioOutput1.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioOutput1.xaml.cpp
00010 // Implementation of the ScenarioOutput1 class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput1.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace EdgeGestureSample;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput1::ScenarioOutput1()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput1::~ScenarioOutput1()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput1::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Get a pointer to our main page.
00045     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047     // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048     _frameLoadedToken = rootPage->InputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioOutput1::rootPage_InputFrameLoaded);
00049 }
00050
00051 void ScenarioOutput1::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     rootPage->InputFrameLoaded -= _frameLoadedToken;
00054 }
00055
00056 #pragma endregion
00057
00058 #pragma region Use this code if you need access to elements in the input frame - otherwise delete
00059 void ScenarioOutput1::rootPage_InputFrameLoaded(Object^ sender, Object^ e)
00060 {
00061     // Get a pointer to the content within the OutputFrame.
00062     Page^ inputFrame = dynamic_cast<Page^>(rootPage->InputFrame->Content);
00063 }
00064
00065 #pragma endregion
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario4.xaml.cpp Source File

  • File picker

Scenario4.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.cpp
00013 // Implementation of the Scenario4 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario4.xaml.h"
00018
00019 using namespace SDKSample::FilePicker;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::Pickers;
00025 using namespace Windows::Storage::Provider;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario4::Scenario4()
00031 {
00032     InitializeComponent();
00033     rootPage = MainPage::Current;
00034     SaveFileButton->Click += ref new RoutedEventHandler(this, &Scenario4::SaveFileButton_Click);
00035 }
00036
00037 void Scenario4::SaveFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00038 {
00039     // Clear previous returned file name, if it exists, between iterations of this scenario
00040     rootPage->ResetScenarioOutput(OutputTextBlock);
00041
00042     if (rootPage->EnsureUnsnapped())
00043     {
00044         FileSavePicker^ savePicker = ref new FileSavePicker();
00045         savePicker->SuggestedStartLocation = PickerLocationId::DocumentsLibrary;
00046
00047         auto plainTextExtensions = ref new Platform::Collections::Vector<String^>();
00048         plainTextExtensions->Append(".txt");
00049         savePicker->FileTypeChoices->Insert("Plain Text", plainTextExtensions);
00050         savePicker->SuggestedFileName = "New Document";
00051
00052         create_task(savePicker->PickSaveFileAsync()).then([this](StorageFile^ file)
00053         {
00054             if (file != nullptr)
00055             {
00056
00057                 // Prevent updates to the remote version of the file until we finish making changes and call CompleteUpdatesAsync.
00058                 CachedFileManager::DeferUpdates(file);
00059                 // write to file
00060                 create_task(FileIO::WriteTextAsync(file, file->Name)).then([this, file]()
00061                 {
00062                     // Let Windows know that we're finished changing the file so the other app can update the remote version of the file.
00063                     // Completing updates may require Windows to ask for user input.
00064                     create_task(CachedFileManager::CompleteUpdatesAsync(file)).then([this, file](FileUpdateStatus status)
00065                     {
00066                         if (status == FileUpdateStatus::Complete)
00067                         {
00068                             OutputTextBlock->Text = "File " + file->Name + " was saved.";
00069                         }
00070                         else
00071                         {
00072                             OutputTextBlock->Text = "File " + file->Name + " couldn't be saved.";
00073                         }
00074                     });
00075                 });
00076             }
00077             else
00078             {
00079                 OutputTextBlock->Text = "Operation cancelled.";
00080             }
00081         });
00082     }
00083 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/BasicReaderWriter.cpp Source File

  • Direct3D tutorial
  • Lesson3.Cubes

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/MainPage.xaml.h Source File

  • App package information

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario3.xaml.cpp Source File

  • Application resources and localization

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::ApplicationResources;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::ApplicationModel::Resources;
00025
00026 Scenario3::Scenario3()
00027 {
00028     InitializeComponent();
00029 }
00030
00031 /// <summary>
00032 /// Invoked when this page is about to be displayed in a Frame.
00033 /// </summary>
00034 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00035 /// property is typically used to configure the page.</param>
00036 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00037 {
00038     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00039     // as NotifyUser()
00040     rootPage = MainPage::Current;
00041   Scenario3TextBlock->Text = "This is placeholder text that will be replaced by a string resource";
00042 }
00043
00044
00045 void SDKSample::ApplicationResources::Scenario3::Scenario3StringLoad_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00046 {
00047     Button^ b = safe_cast<Button^>(sender);
00048     if (b != nullptr)
00049     {
00050         auto resourceLoader = ref new ResourceLoader();
00051     // Replace the TextBlock's content with a string resource, String1, for the most appropriate language
00052     // String1 can be found in a resource file strings/.../resources.resw
00053     Scenario3TextBlock->Text = resourceLoader->GetString("string1");
00054     }
00055 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/pch.h Source File

  • Contact Picker app

pch.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include "Sample-Utils\CppSamplesUtils.h"
00019 #include <ppltasks.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario2.xaml.cpp Source File

  • DatagramSocket

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace DatagramSocketSample;
00020
00021 using namespace Concurrency;
00022 using namespace Platform;
00023 using namespace Windows::ApplicationModel::Core;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Networking;
00026 using namespace Windows::Networking::Sockets;
00027 using namespace Windows::UI::Core;
00028 using namespace Windows::UI::Xaml;
00029 using namespace Windows::UI::Xaml::Controls;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 Scenario2::Scenario2()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 /// <summary>
00038 /// Invoked when this page is about to be displayed in a Frame.
00039 /// </summary>
00040 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00041 /// property is typically used to configure the page.</param>
00042 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00045     // as NotifyUser()
00046     rootPage = MainPage::Current;
00047 }
00048
00049 void Scenario2::ConnectSocket_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00050 {
00051     if (ServiceNameForConnect->Text == nullptr)
00052     {
00053         rootPage->NotifyUser("Please provide a service name.", NotifyType::ErrorMessage);
00054         return;
00055     }
00056
00057     // By default 'HostNameForConnect' is disabled and host name validation is not required. When enabling the text
00058     // box validating the host name is required since it was received from an untrusted source (user input).
00059     // Note that when enabling the text box users may provide names for hosts on the intErnet that require the
00060     // "Internet (Client)" capability.
00061     HostName^ hostName;
00062     try
00063     {
00064         hostName = ref new HostName(HostNameForConnect->Text);
00065     }
00066     catch (InvalidArgumentException^ e)
00067     {
00068         rootPage->NotifyUser("Error: Invalid host name.", NotifyType::ErrorMessage);
00069         return;
00070     }
00071
00072     if (CoreApplication::Properties->HasKey("clientSocket"))
00073     {
00074         rootPage->NotifyUser("This step has already been executed. Please move to the next one.", NotifyType::ErrorMessage);
00075         return;
00076     }
00077
00078     DatagramSocket^ socket = ref new DatagramSocket();
00079     SocketContext^ socketContext = ref new SocketContext(rootPage, socket);
00080     socket->MessageReceived += ref new TypedEventHandler<DatagramSocket^, DatagramSocketMessageReceivedEventArgs^>(socketContext, &SocketContext::OnMessage);
00081
00082     // Events cannot be hooked up directly to the ScenarioInput2 object, as the object can fall out-of-scope and be deleted. This would render
00083     // any event hooked up to the object ineffective. The SocketContext guarantees that both the socket and object that serves it's events have the same life time.
00084     CoreApplication::Properties->Insert("clientSocket", socketContext);
00085
00086     rootPage->NotifyUser("Connecting to: " + HostNameForConnect->Text, NotifyType::StatusMessage);
00087
00088     // Connect to the server (in our case the listener we created in previous step).
00089     task<void>(socket->ConnectAsync(hostName, ServiceNameForConnect->Text)).then([this, socketContext] (task<void> previousTask)
00090     {
00091         try
00092         {
00093             // Try getting an exception.
00094             previousTask.get();
00095             rootPage->NotifyUser("Connected", NotifyType::StatusMessage);
00096             socketContext->SetConnected();
00097         }
00098         catch (Exception^ exception)
00099         {
00100             rootPage->NotifyUser("Connect failed with error: " + exception->Message, NotifyType::ErrorMessage);
00101         }
00102     });
00103 }
00104
00105 SocketContext::SocketContext(MainPage^ rootPage, DatagramSocket^ socket)
00106 {
00107     this->rootPage = rootPage;
00108     this->socket = socket;
00109     this->connected = false;
00110 }
00111
00112 SocketContext::~SocketContext()
00113 {
00114     // The socket (data writer) can be closed in two ways:
00115     //  - explicit: by using delete operator (the socket or the stream used by data writer is closed even if there are outstanding references to the objects).
00116     //  - implicit: by removing last reference to it (i.e. falling out-of-scope).
00117     // In this case this is the last reference to the socket and data writer so both will yield the same result.
00118     delete socket;
00119     socket = nullptr;
00120
00121     if (writer != nullptr)
00122     {
00123         delete writer;
00124         writer = nullptr;
00125     }
00126 }
00127
00128 void SocketContext::OnMessage(DatagramSocket^ socket, DatagramSocketMessageReceivedEventArgs^ eventArguments)
00129 {
00130     try
00131     {
00132         unsigned int stringLength = eventArguments->GetDataReader()->UnconsumedBufferLength;
00133         NotifyUserFromAsyncThread("Receive data from remote peer: \"" + eventArguments->GetDataReader()->ReadString(stringLength) + "\"", NotifyType::StatusMessage);
00134     }
00135     catch (Exception^ exception)
00136     {
00137         SocketErrorStatus socketError = SocketError::GetStatus(exception->HResult);
00138         if (socketError == SocketErrorStatus::ConnectionResetByPeer)
00139         {
00140             // This error would indicate that a previous send operation resulted in an ICMP "Port Unreachable" message.
00141             NotifyUserFromAsyncThread("Peer does not listen on the specific port. Please make sure that you run step 1 first " +
00142                 "or you have a server properly working on a remote server.", NotifyType::ErrorMessage);
00143         }
00144         else if (socketError != SocketErrorStatus::Unknown)
00145         {
00146             NotifyUserFromAsyncThread("Error happened when receiving a datagram: " + socketError.ToString(), NotifyType::ErrorMessage);
00147         }
00148         else
00149         {
00150             throw;
00151         }
00152     }
00153 }
00154
00155 DataWriter^ SocketContext::GetWriter()
00156 {
00157     if (writer == nullptr)
00158     {
00159         writer = ref new DataWriter(socket->OutputStream);
00160     }
00161
00162     return writer;
00163 }
00164
00165 boolean SocketContext::IsConnected()
00166 {
00167     return connected;
00168 }
00169
00170 void SocketContext::SetConnected()
00171 {
00172     connected = true;
00173 }
00174
00175 void SocketContext::NotifyUserFromAsyncThread(String^ message, NotifyType type)
00176 {
00177     rootPage->Dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this, message, type] ()
00178     {
00179         rootPage->NotifyUser(message, type);
00180     }));
00181 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexTGA.cpp Source File

  • Direct3D resource loading
  • texconv

DirectXTexTGA.cpp

Go to the documentation of this file.
00001 //-------------------------------------------------------------------------------------
00002 // DirectXTexTGA.cpp
00003 //
00004 // DirectX Texture Library - Targa Truevision (TGA) file format reader/writer
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //-------------------------------------------------------------------------------------
00013
00014 #include "directxtexp.h"
00015
00016 //
00017 // The implementation here has the following limitations:
00018 //      * Does not support files that contain color maps (these are rare in practice)
00019 //      * Interleaved files are not supported (deprecated aspect of TGA format)
00020 //      * Only supports 8-bit greyscale; 16-, 24-, and 32-bit truecolor images
00021 //      * Always writes uncompressed files (i.e. can read RLE compression, but does not write it)
00022 //
00023
00024 enum TGAImageType
00025 {
00026     TGA_NO_IMAGE            = 0,
00027     TGA_COLOR_MAPPED        = 1,
00028     TGA_TRUECOLOR           = 2,
00029     TGA_BLACK_AND_WHITE     = 3,
00030     TGA_COLOR_MAPPED_RLE    = 9,
00031     TGA_TRUECOLOR_RLE       = 10,
00032     TGA_BLACK_AND_WHITE_RLE = 11,
00033 };
00034
00035 enum TGADescriptorFlags
00036 {
00037     TGA_FLAGS_INVERTX           = 0x10,
00038     TGA_FLAGS_INVERTY           = 0x20,
00039     TGA_FLAGS_INTERLEAVED_2WAY  = 0x40, // Deprecated
00040     TGA_FLAGS_INTERLEAVED_4WAY  = 0x80, // Deprecated
00041 };
00042
00043 const char* g_TGA20_Signature = "TRUEVISION-XFILE.";
00044
00045 #pragma pack(push,1)
00046 struct TGA_HEADER
00047 {
00048     uint8_t     bIDLength;
00049     uint8_t     bColorMapType;
00050     uint8_t     bImageType;
00051     uint16_t    wColorMapFirst;
00052     uint16_t    wColorMapLength;
00053     uint8_t     bColorMapSize;
00054     uint16_t    wXOrigin;
00055     uint16_t    wYOrigin;
00056     uint16_t    wWidth;
00057     uint16_t    wHeight;
00058     uint8_t     bBitsPerPixel;
00059     uint8_t     bDescriptor;
00060 };
00061
00062 struct TGA_FOOTER
00063 {
00064     uint16_t    dwExtensionOffset;
00065     uint16_t    dwDeveloperOffset;
00066     char        Signature[18];
00067 };
00068
00069 struct TGA_EXTENSION
00070 {
00071     uint16_t    wSize;
00072     char        szAuthorName[41];
00073     char        szAuthorComment[324];
00074     uint16_t    wStampMonth;
00075     uint16_t    wStampDay;
00076     uint16_t    wStampYear;
00077     uint16_t    wStampHour;
00078     uint16_t    wStampMinute;
00079     uint16_t    wStampSecond;
00080     char        szJobName[41];
00081     uint16_t    wJobHour;
00082     uint16_t    wJobMinute;
00083     uint16_t    wJobSecond;
00084     char        szSoftwareId[41];
00085     uint16_t    wVersionNumber;
00086     uint8_t     bVersionLetter;
00087     uint32_t    dwKeyColor;
00088     uint16_t    wPixelNumerator;
00089     uint16_t    wPixelDenominator;
00090     uint16_t    wGammaNumerator;
00091     uint16_t    wGammaDenominator;
00092     uint32_t    dwColorOffset;
00093     uint32_t    dwStampOffset;
00094     uint32_t    dwScanOffset;
00095     uint8_t     bAttributesType;
00096 };
00097 #pragma pack(pop)
00098
00099 enum CONVERSION_FLAGS
00100 {
00101     CONV_FLAGS_NONE     = 0x0,
00102     CONV_FLAGS_EXPAND   = 0x1,      // Conversion requires expanded pixel size
00103     CONV_FLAGS_INVERTX  = 0x2,      // If set, scanlines are right-to-left
00104     CONV_FLAGS_INVERTY  = 0x4,      // If set, scanlines are top-to-bottom
00105     CONV_FLAGS_RLE      = 0x8,      // Source data is RLE compressed
00106
00107     CONV_FLAGS_SWIZZLE  = 0x10000,  // Swizzle BGR<->RGB data
00108     CONV_FLAGS_888      = 0x20000,  // 24bpp format
00109 };
00110
00111 namespace DirectX
00112 {
00113
00114 //-------------------------------------------------------------------------------------
00115 // Decodes TGA header
00116 //-------------------------------------------------------------------------------------
00117 static HRESULT _DecodeTGAHeader( _In_reads_bytes_(size) LPCVOID pSource, size_t size, _Out_ TexMetadata& metadata, size_t& offset,
00118                                  _Inout_opt_ DWORD* convFlags )
00119 {
00120     if ( !pSource )
00121         return E_INVALIDARG;
00122
00123     memset( &metadata, 0, sizeof(TexMetadata) );
00124
00125     if ( size < sizeof(TGA_HEADER) )
00126     {
00127         return HRESULT_FROM_WIN32( ERROR_INVALID_DATA );
00128     }
00129
00130     const TGA_HEADER* pHeader = reinterpret_cast<const TGA_HEADER*>( pSource );
00131     assert( pHeader );
00132
00133     if ( pHeader->bColorMapType != 0
00134          || pHeader->wColorMapLength != 0 )
00135     {
00136         return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00137     }
00138
00139     if ( pHeader->bDescriptor & (TGA_FLAGS_INTERLEAVED_2WAY|TGA_FLAGS_INTERLEAVED_4WAY) )
00140     {
00141         return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00142     }
00143
00144     if ( !pHeader->wWidth || !pHeader->wHeight )
00145     {
00146         return HRESULT_FROM_WIN32( ERROR_INVALID_DATA );
00147     }
00148
00149     switch ( pHeader->bImageType )
00150     {
00151     case TGA_TRUECOLOR:
00152     case TGA_TRUECOLOR_RLE:
00153         switch( pHeader->bBitsPerPixel )
00154         {
00155         case 16:
00156             metadata.format = DXGI_FORMAT_B5G5R5A1_UNORM;
00157             break;
00158
00159         case 24:
00160             metadata.format = DXGI_FORMAT_R8G8B8A8_UNORM;
00161             if ( convFlags )
00162                 *convFlags |= CONV_FLAGS_EXPAND;
00163             // We could use DXGI_FORMAT_B8G8R8X8_UNORM, but we prefer DXGI 1.0 formats
00164             break;
00165
00166         case 32:
00167             metadata.format = DXGI_FORMAT_R8G8B8A8_UNORM;
00168             // We could use DXGI_FORMAT_B8G8R8A8_UNORM, but we prefer DXGI 1.0 formats
00169             break;
00170         }
00171
00172         if ( convFlags && (pHeader->bImageType == TGA_TRUECOLOR_RLE) )
00173         {
00174             *convFlags |= CONV_FLAGS_RLE;
00175         }
00176         break;
00177
00178     case TGA_BLACK_AND_WHITE:
00179     case TGA_BLACK_AND_WHITE_RLE:
00180         switch( pHeader->bBitsPerPixel )
00181         {
00182         case 8:
00183             metadata.format = DXGI_FORMAT_R8_UNORM;
00184             break;
00185
00186         default:
00187             return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00188         }
00189
00190         if ( convFlags && (pHeader->bImageType == TGA_BLACK_AND_WHITE_RLE) )
00191         {
00192             *convFlags |= CONV_FLAGS_RLE;
00193         }
00194         break;
00195
00196     case TGA_NO_IMAGE:
00197     case TGA_COLOR_MAPPED:
00198     case TGA_COLOR_MAPPED_RLE:
00199         return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00200
00201     default:
00202         return HRESULT_FROM_WIN32( ERROR_INVALID_DATA );
00203     }
00204
00205     metadata.width = pHeader->wWidth;
00206     metadata.height = pHeader->wHeight;
00207     metadata.depth = metadata.arraySize = metadata.mipLevels = 1;
00208     metadata.dimension = TEX_DIMENSION_TEXTURE2D;
00209
00210     if ( convFlags )
00211     {
00212         if ( pHeader->bDescriptor & TGA_FLAGS_INVERTX )
00213             *convFlags |= CONV_FLAGS_INVERTX;
00214
00215         if ( pHeader->bDescriptor & TGA_FLAGS_INVERTY )
00216             *convFlags |= CONV_FLAGS_INVERTY;
00217     }
00218
00219     offset = sizeof( TGA_HEADER );
00220
00221     if ( pHeader->bIDLength != 0 )
00222     {
00223         offset += pHeader->bIDLength;
00224     }
00225
00226     return S_OK;
00227 }
00228
00229
00230 //-------------------------------------------------------------------------------------
00231 // Set alpha for images with all 0 alpha channel
00232 //-------------------------------------------------------------------------------------
00233 static HRESULT _SetAlphaChannelToOpaque( _In_ const Image* image )
00234 {
00235     assert( image );
00236
00237     uint8_t* pPixels = reinterpret_cast<uint8_t*>( image->pixels );
00238     if ( !pPixels )
00239         return E_POINTER;
00240
00241     for( size_t y = 0; y < image->height; ++y )
00242     {
00243         _CopyScanline( pPixels, image->rowPitch, pPixels, image->rowPitch, image->format, TEXP_SCANLINE_SETALPHA );
00244         pPixels += image->rowPitch;
00245     }
00246
00247     return S_OK;
00248 }
00249
00250
00251 //-------------------------------------------------------------------------------------
00252 // Uncompress pixel data from a TGA into the target image
00253 //-------------------------------------------------------------------------------------
00254 static HRESULT _UncompressPixels( _In_reads_bytes_(size) LPCVOID pSource, size_t size, _In_ const Image* image, DWORD convFlags )
00255 {
00256     assert( pSource && size > 0 );
00257
00258     if ( !image || !image->pixels )
00259         return E_POINTER;
00260
00261     // Compute TGA image data pitch
00262     size_t rowPitch;
00263     if ( convFlags & CONV_FLAGS_EXPAND )
00264     {
00265         rowPitch = image->width * 3;
00266     }
00267     else
00268     {
00269         size_t slicePitch;
00270         ComputePitch( image->format, image->width, image->height, rowPitch, slicePitch, CP_FLAGS_NONE );
00271     }
00272
00273     const uint8_t* sPtr = reinterpret_cast<const uint8_t*>( pSource );
00274     const uint8_t* endPtr = sPtr + size;
00275
00276     switch( image->format )
00277     {
00278     //--------------------------------------------------------------------------- 8-bit
00279     case DXGI_FORMAT_R8_UNORM:
00280         for( size_t y=0; y < image->height; ++y )
00281         {
00282             size_t offset = ( (convFlags & CONV_FLAGS_INVERTX ) ? (image->width - 1) : 0 );
00283             assert( offset < rowPitch);
00284
00285             uint8_t* dPtr = reinterpret_cast<uint8_t*>( image->pixels )
00286                          + ( image->rowPitch * ( (convFlags & CONV_FLAGS_INVERTY) ? y : (image->height - y - 1) ) )
00287                          + offset;
00288
00289             for( size_t x=0; x < image->width; )
00290             {
00291                 if ( sPtr >= endPtr )
00292                     return E_FAIL;
00293
00294                 if ( *sPtr & 0x80 )
00295                 {
00296                     // Repeat
00297                     size_t j = (*sPtr & 0x7F) + 1;
00298                     if ( ++sPtr >= endPtr )
00299                         return E_FAIL;
00300
00301                     for( ; j > 0; --j, ++x )
00302                     {
00303                         if ( x >= image->width )
00304                             return E_FAIL;
00305
00306                         *dPtr = *sPtr;
00307
00308                         if ( convFlags & CONV_FLAGS_INVERTX )
00309                             --dPtr;
00310                         else
00311                             ++dPtr;
00312                     }
00313
00314                     ++sPtr;
00315                 }
00316                 else
00317                 {
00318                     // Literal
00319                     size_t j = (*sPtr & 0x7F) + 1;
00320                     ++sPtr;
00321
00322                     if ( sPtr+j > endPtr )
00323                         return E_FAIL;
00324
00325                     for( ; j > 0; --j, ++x )
00326                     {
00327                         if ( x >= image->width )
00328                             return E_FAIL;
00329
00330                         *dPtr = *(sPtr++);
00331
00332                         if ( convFlags & CONV_FLAGS_INVERTX )
00333                             --dPtr;
00334                         else
00335                             ++dPtr;
00336                     }
00337                 }
00338             }
00339         }
00340         break;
00341
00342     //-------------------------------------------------------------------------- 16-bit
00343     case DXGI_FORMAT_B5G5R5A1_UNORM:
00344         {
00345             bool nonzeroa = false;
00346             for( size_t y=0; y < image->height; ++y )
00347             {
00348                 size_t offset = ( (convFlags & CONV_FLAGS_INVERTX ) ? (image->width - 1) : 0 );
00349                 assert( offset*2 < rowPitch);
00350
00351                 uint16_t* dPtr = reinterpret_cast<uint16_t*>( reinterpret_cast<uint8_t*>( image->pixels )
00352                              + ( image->rowPitch * ( (convFlags & CONV_FLAGS_INVERTY) ? y : (image->height - y - 1) ) ) )
00353                              + offset;
00354
00355                 for( size_t x=0; x < image->width; )
00356                 {
00357                     if ( sPtr >= endPtr )
00358                         return E_FAIL;
00359
00360                     if ( *sPtr & 0x80 )
00361                     {
00362                         // Repeat
00363                         size_t j = (*sPtr & 0x7F) + 1;
00364                         ++sPtr;
00365
00366                         if ( sPtr+1 >= endPtr )
00367                             return E_FAIL;
00368
00369                         uint16_t t =  *sPtr | (*(sPtr+1) << 8);
00370                         if ( t & 0x8000 )
00371                             nonzeroa = true;
00372                         sPtr += 2;
00373
00374                         for( ; j > 0; --j, ++x )
00375                         {
00376                             if ( x >= image->width )
00377                                 return E_FAIL;
00378
00379                             *dPtr = t;
00380
00381                             if ( convFlags & CONV_FLAGS_INVERTX )
00382                                 --dPtr;
00383                             else
00384                                 ++dPtr;
00385                         }
00386                     }
00387                     else
00388                     {
00389                         // Literal
00390                         size_t j = (*sPtr & 0x7F) + 1;
00391                         ++sPtr;
00392
00393                         if ( sPtr+(j*2) > endPtr )
00394                             return E_FAIL;
00395
00396                         for( ; j > 0; --j, ++x )
00397                         {
00398                             if ( x >= image->width )
00399                                 return E_FAIL;
00400
00401                             uint16_t t =  *sPtr | (*(sPtr+1) << 8);
00402                             if ( t & 0x8000 )
00403                                 nonzeroa = true;
00404                             sPtr += 2;
00405                             *dPtr = t;
00406
00407                             if ( convFlags & CONV_FLAGS_INVERTX )
00408                                 --dPtr;
00409                             else
00410                                 ++dPtr;
00411                         }
00412                     }
00413                 }
00414             }
00415
00416             // If there are no non-zero alpha channel entries, we'll assume alpha is not used and force it to opaque
00417             if ( !nonzeroa )
00418             {
00419                 HRESULT hr = _SetAlphaChannelToOpaque( image );
00420                 if ( FAILED(hr) )
00421                     return hr;
00422             }
00423         }
00424         break;
00425
00426     //----------------------------------------------------------------------- 24/32-bit
00427     case DXGI_FORMAT_R8G8B8A8_UNORM:
00428         {
00429             bool nonzeroa = false;
00430             for( size_t y=0; y < image->height; ++y )
00431             {
00432                 size_t offset = ( (convFlags & CONV_FLAGS_INVERTX ) ? (image->width - 1) : 0 );
00433
00434                 uint32_t* dPtr = reinterpret_cast<uint32_t*>( reinterpret_cast<uint8_t*>( image->pixels )
00435                               + ( image->rowPitch * ( (convFlags & CONV_FLAGS_INVERTY) ? y : (image->height - y - 1) ) ) )
00436                               + offset;
00437
00438                 for( size_t x=0; x < image->width; )
00439                 {
00440                     if ( sPtr >= endPtr )
00441                         return E_FAIL;
00442
00443                     if ( *sPtr & 0x80 )
00444                     {
00445                         // Repeat
00446                         size_t j = (*sPtr & 0x7F) + 1;
00447                         ++sPtr;
00448
00449                         DWORD t;
00450                         if ( convFlags & CONV_FLAGS_EXPAND )
00451                         {
00452                             assert( offset*3 < rowPitch);
00453
00454                             if ( sPtr+2 >= endPtr )
00455                                 return E_FAIL;
00456
00457                             // BGR -> RGBA
00458                             t = ( *sPtr << 16 ) | ( *(sPtr+1) << 8 ) | ( *(sPtr+2) ) | 0xFF000000;
00459                             sPtr += 3;
00460
00461                             nonzeroa = true;
00462                         }
00463                         else
00464                         {
00465                             assert( offset*4 < rowPitch);
00466
00467                             if ( sPtr+3 >= endPtr )
00468                                 return E_FAIL;
00469
00470                             // BGRA -> RGBA
00471                             t = ( *sPtr << 16 ) | ( *(sPtr+1) << 8 ) | ( *(sPtr+2) ) | ( *(sPtr+3) << 24 );
00472
00473                             if ( *(sPtr+3) > 0 )
00474                                 nonzeroa = true;
00475
00476                             sPtr += 4;
00477                         }
00478
00479                         for( ; j > 0; --j, ++x )
00480                         {
00481                             if ( x >= image->width )
00482                                 return E_FAIL;
00483
00484                             *dPtr = t;
00485
00486                             if ( convFlags & CONV_FLAGS_INVERTX )
00487                                 --dPtr;
00488                             else
00489                                 ++dPtr;
00490                         }
00491                     }
00492                     else
00493                     {
00494                         // Literal
00495                         size_t j = (*sPtr & 0x7F) + 1;
00496                         ++sPtr;
00497
00498                         if ( convFlags & CONV_FLAGS_EXPAND )
00499                         {
00500                             if ( sPtr+(j*3) > endPtr )
00501                                 return E_FAIL;
00502                         }
00503                         else
00504                         {
00505                             if ( sPtr+(j*4) > endPtr )
00506                                 return E_FAIL;
00507                         }
00508
00509                         for( ; j > 0; --j, ++x )
00510                         {
00511                             if ( x >= image->width )
00512                                 return E_FAIL;
00513
00514                             if ( convFlags & CONV_FLAGS_EXPAND )
00515                             {
00516                                 assert( offset*3 < rowPitch);
00517
00518                                 if ( sPtr+2 >= endPtr )
00519                                     return E_FAIL;
00520
00521                                 // BGR -> RGBA
00522                                 *dPtr = ( *sPtr << 16 ) | ( *(sPtr+1) << 8 ) | ( *(sPtr+2) ) | 0xFF000000;
00523                                 sPtr += 3;
00524
00525                                 nonzeroa = true;
00526                             }
00527                             else
00528                             {
00529                                 assert( offset*4 < rowPitch);
00530
00531                                 if ( sPtr+3 >= endPtr )
00532                                     return E_FAIL;
00533
00534                                 // BGRA -> RGBA
00535                                 *dPtr = ( *sPtr << 16 ) | ( *(sPtr+1) << 8 ) | ( *(sPtr+2) ) | ( *(sPtr+3) << 24 );
00536
00537                                 if ( *(sPtr+3) > 0 )
00538                                     nonzeroa = true;
00539
00540                                 sPtr += 4;
00541                             }
00542
00543                             if ( convFlags & CONV_FLAGS_INVERTX )
00544                                 --dPtr;
00545                             else
00546                                 ++dPtr;
00547                         }
00548                     }
00549                 }
00550             }
00551
00552             // If there are no non-zero alpha channel entries, we'll assume alpha is not used and force it to opaque
00553             if ( !nonzeroa )
00554             {
00555                 HRESULT hr = _SetAlphaChannelToOpaque( image );
00556                 if ( FAILED(hr) )
00557                     return hr;
00558             }
00559         }
00560         break;
00561
00562     //---------------------------------------------------------------------------------
00563     default:
00564         return E_FAIL;
00565     }
00566
00567     return S_OK;
00568 }
00569
00570
00571 //-------------------------------------------------------------------------------------
00572 // Copies pixel data from a TGA into the target image
00573 //-------------------------------------------------------------------------------------
00574 static HRESULT _CopyPixels( _In_reads_bytes_(size) LPCVOID pSource, size_t size, _In_ const Image* image, DWORD convFlags )
00575 {
00576     assert( pSource && size > 0 );
00577
00578     if ( !image || !image->pixels )
00579         return E_POINTER;
00580
00581     // Compute TGA image data pitch
00582     size_t rowPitch;
00583     if ( convFlags & CONV_FLAGS_EXPAND )
00584     {
00585         rowPitch = image->width * 3;
00586     }
00587     else
00588     {
00589         size_t slicePitch;
00590         ComputePitch( image->format, image->width, image->height, rowPitch, slicePitch, CP_FLAGS_NONE );
00591     }
00592
00593     const uint8_t* sPtr = reinterpret_cast<const uint8_t*>( pSource );
00594     const uint8_t* endPtr = sPtr + size;
00595
00596     switch( image->format )
00597     {
00598     //--------------------------------------------------------------------------- 8-bit
00599     case DXGI_FORMAT_R8_UNORM:
00600         for( size_t y=0; y < image->height; ++y )
00601         {
00602             size_t offset = ( (convFlags & CONV_FLAGS_INVERTX ) ? (image->width - 1) : 0 );
00603             assert( offset < rowPitch);
00604
00605             uint8_t* dPtr = reinterpret_cast<uint8_t*>( image->pixels )
00606                          + ( image->rowPitch * ( (convFlags & CONV_FLAGS_INVERTY) ? y : (image->height - y - 1) ) )
00607                          + offset;
00608
00609             for( size_t x=0; x < image->width; ++x )
00610             {
00611                 if ( sPtr >= endPtr )
00612                     return E_FAIL;
00613
00614                 *dPtr = *(sPtr++);
00615
00616                 if ( convFlags & CONV_FLAGS_INVERTX )
00617                     --dPtr;
00618                 else
00619                     ++dPtr;
00620             }
00621         }
00622         break;
00623
00624     //-------------------------------------------------------------------------- 16-bit
00625     case DXGI_FORMAT_B5G5R5A1_UNORM:
00626         {
00627             bool nonzeroa = false;
00628             for( size_t y=0; y < image->height; ++y )
00629             {
00630                 size_t offset = ( (convFlags & CONV_FLAGS_INVERTX ) ? (image->width - 1) : 0 );
00631                 assert( offset*2 < rowPitch);
00632
00633                 uint16_t* dPtr = reinterpret_cast<uint16_t*>( reinterpret_cast<uint8_t*>( image->pixels )
00634                              + ( image->rowPitch * ( (convFlags & CONV_FLAGS_INVERTY) ? y : (image->height - y - 1) ) ) )
00635                              + offset;
00636
00637                 for( size_t x=0; x < image->width; ++x )
00638                 {
00639                     if ( sPtr+1 >= endPtr )
00640                         return E_FAIL;
00641
00642                     uint16_t t =  *sPtr | (*(sPtr+1) << 8);
00643                     sPtr += 2;
00644                     *dPtr = t;
00645
00646                     if ( t & 0x8000 )
00647                         nonzeroa = true;
00648
00649                     if ( convFlags & CONV_FLAGS_INVERTX )
00650                         --dPtr;
00651                     else
00652                         ++dPtr;
00653                 }
00654             }
00655
00656             // If there are no non-zero alpha channel entries, we'll assume alpha is not used and force it to opaque
00657             if ( !nonzeroa )
00658             {
00659                 HRESULT hr = _SetAlphaChannelToOpaque( image );
00660                 if ( FAILED(hr) )
00661                     return hr;
00662             }
00663         }
00664         break;
00665
00666     //----------------------------------------------------------------------- 24/32-bit
00667     case DXGI_FORMAT_R8G8B8A8_UNORM:
00668         {
00669             bool nonzeroa = false;
00670             for( size_t y=0; y < image->height; ++y )
00671             {
00672                 size_t offset = ( (convFlags & CONV_FLAGS_INVERTX ) ? (image->width - 1) : 0 );
00673
00674                 uint32_t* dPtr = reinterpret_cast<uint32_t*>( reinterpret_cast<uint8_t*>( image->pixels )
00675                               + ( image->rowPitch * ( (convFlags & CONV_FLAGS_INVERTY) ? y : (image->height - y - 1) ) ) )
00676                               + offset;
00677
00678                 for( size_t x=0; x < image->width; ++x )
00679                 {
00680                     if ( convFlags & CONV_FLAGS_EXPAND )
00681                     {
00682                         assert( offset*3 < rowPitch);
00683
00684                         if ( sPtr+2 >= endPtr )
00685                             return E_FAIL;
00686
00687                         // BGR -> RGBA
00688                         *dPtr = ( *sPtr << 16 ) | ( *(sPtr+1) << 8 ) | ( *(sPtr+2) ) | 0xFF000000;
00689                         sPtr += 3;
00690
00691                         nonzeroa = true;
00692                     }
00693                     else
00694                     {
00695                         assert( offset*4 < rowPitch);
00696
00697                         if ( sPtr+3 >= endPtr )
00698                             return E_FAIL;
00699
00700                         // BGRA -> RGBA
00701                         *dPtr = ( *sPtr << 16 ) | ( *(sPtr+1) << 8 ) | ( *(sPtr+2) ) | ( *(sPtr+3) << 24 );
00702
00703                         if ( *(sPtr+3) > 0 )
00704                             nonzeroa = true;
00705
00706                         sPtr += 4;
00707                     }
00708
00709                     if ( convFlags & CONV_FLAGS_INVERTX )
00710                         --dPtr;
00711                     else
00712                         ++dPtr;
00713                 }
00714             }
00715
00716             // If there are no non-zero alpha channel entries, we'll assume alpha is not used and force it to opaque
00717             if ( !nonzeroa )
00718             {
00719                 HRESULT hr = _SetAlphaChannelToOpaque( image );
00720                 if ( FAILED(hr) )
00721                     return hr;
00722             }
00723         }
00724         break;
00725
00726     //---------------------------------------------------------------------------------
00727     default:
00728         return E_FAIL;
00729     }
00730
00731     return S_OK;
00732 }
00733
00734
00735 //-------------------------------------------------------------------------------------
00736 // Encodes TGA file header
00737 //-------------------------------------------------------------------------------------
00738 static HRESULT _EncodeTGAHeader( _In_ const Image& image, _Out_ TGA_HEADER& header, DWORD& convFlags )
00739 {
00740     assert( IsValid( image.format ) && !IsVideo( image.format ) );
00741
00742     memset( &header, 0, sizeof(TGA_HEADER) );
00743
00744     if ( (image.width > 0xFFFF)
00745          || (image.height > 0xFFFF) )
00746     {
00747          return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00748     }
00749
00750     header.wWidth = static_cast<uint16_t>( image.width );
00751     header.wHeight = static_cast<uint16_t>( image.height );
00752
00753     switch( image.format )
00754     {
00755     case DXGI_FORMAT_R8G8B8A8_UNORM:
00756     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00757         header.bImageType = TGA_TRUECOLOR;
00758         header.bBitsPerPixel = 32;
00759         header.bDescriptor = TGA_FLAGS_INVERTY | 8;
00760         convFlags |= CONV_FLAGS_SWIZZLE;
00761         break;
00762
00763     case DXGI_FORMAT_B8G8R8A8_UNORM:
00764     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00765         header.bImageType = TGA_TRUECOLOR;
00766         header.bBitsPerPixel = 32;
00767         header.bDescriptor = TGA_FLAGS_INVERTY | 8;
00768         break;
00769
00770     case DXGI_FORMAT_B8G8R8X8_UNORM:
00771     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00772         header.bImageType = TGA_TRUECOLOR;
00773         header.bBitsPerPixel = 24;
00774         header.bDescriptor = TGA_FLAGS_INVERTY;
00775         convFlags |= CONV_FLAGS_888;
00776         break;
00777
00778     case DXGI_FORMAT_R8_UNORM:
00779     case DXGI_FORMAT_A8_UNORM:
00780         header.bImageType = TGA_BLACK_AND_WHITE;
00781         header.bBitsPerPixel = 8;
00782         header.bDescriptor = TGA_FLAGS_INVERTY;
00783         break;
00784
00785     case DXGI_FORMAT_B5G5R5A1_UNORM:
00786         header.bImageType = TGA_TRUECOLOR;
00787         header.bBitsPerPixel = 16;
00788         header.bDescriptor = TGA_FLAGS_INVERTY | 1;
00789         break;
00790
00791     default:
00792         return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00793     }
00794
00795     return S_OK;
00796 }
00797
00798
00799 //-------------------------------------------------------------------------------------
00800 // Copies BGRX data to form BGR 24bpp data
00801 //-------------------------------------------------------------------------------------
00802 #pragma warning(suppress: 6001 6101) // In the case where outSize is insufficient we do not write to pDestination
00803 static void _Copy24bppScanline( _Out_writes_bytes_(outSize) LPVOID pDestination, _In_ size_t outSize,
00804                                 _In_reads_bytes_(inSize) LPCVOID pSource, _In_ size_t inSize )
00805 {
00806     assert( pDestination && outSize > 0 );
00807     assert( pSource && inSize > 0 );
00808
00809     assert( pDestination != pSource );
00810
00811     const uint32_t * __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
00812     uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
00813
00814     const uint8_t* endPtr = dPtr + outSize;
00815
00816     for( size_t count = 0; count < inSize; count += 4 )
00817     {
00818         uint32_t t = *(sPtr++);
00819
00820         if ( dPtr+2 > endPtr )
00821             return;
00822
00823         *(dPtr++) = uint8_t(t & 0xFF);              // Blue
00824         *(dPtr++) = uint8_t((t & 0xFF00) >> 8);     // Green
00825         *(dPtr++) = uint8_t((t & 0xFF0000) >> 16);  // Red
00826     }
00827 }
00828
00829
00830 //=====================================================================================
00831 // Entry-points
00832 //=====================================================================================
00833
00834 //-------------------------------------------------------------------------------------
00835 // Obtain metadata from TGA file in memory/on disk
00836 //-------------------------------------------------------------------------------------
00837
00838 _Use_decl_annotations_
00839 HRESULT GetMetadataFromTGAMemory( LPCVOID pSource, size_t size, TexMetadata& metadata )
00840 {
00841     if ( !pSource || size == 0 )
00842         return E_INVALIDARG;
00843
00844     size_t offset;
00845     return _DecodeTGAHeader( pSource, size, metadata, offset, 0 );
00846 }
00847
00848 _Use_decl_annotations_
00849 HRESULT GetMetadataFromTGAFile( LPCWSTR szFile, TexMetadata& metadata )
00850 {
00851     if ( !szFile )
00852         return E_INVALIDARG;
00853
00854 #if (_WIN32_WINNT >= _WIN32_WINNT_WIN8)
00855     ScopedHandle hFile( safe_handle( CreateFile2( szFile, GENERIC_READ, FILE_SHARE_READ, OPEN_EXISTING, 0 ) ) );
00856 #else
00857     ScopedHandle hFile( safe_handle( CreateFileW( szFile, GENERIC_READ, FILE_SHARE_READ, 0, OPEN_EXISTING,
00858                                      FILE_FLAG_SEQUENTIAL_SCAN, 0 ) ) );
00859 #endif
00860     if ( !hFile )
00861     {
00862         return HRESULT_FROM_WIN32( GetLastError() );
00863     }
00864
00865     // Get the file size
00866     LARGE_INTEGER fileSize = {0};
00867
00868 #if (_WIN32_WINNT >= _WIN32_WINNT_VISTA)
00869     FILE_STANDARD_INFO fileInfo;
00870     if ( !GetFileInformationByHandleEx( hFile.get(), FileStandardInfo, &fileInfo, sizeof(fileInfo) ) )
00871     {
00872         return HRESULT_FROM_WIN32( GetLastError() );
00873     }
00874     fileSize = fileInfo.EndOfFile;
00875 #else
00876     if ( !GetFileSizeEx( hFile.get(), &fileSize ) )
00877     {
00878         return HRESULT_FROM_WIN32( GetLastError() );
00879     }
00880 #endif
00881
00882     // File is too big for 32-bit allocation, so reject read (4 GB should be plenty large enough for a valid TGA file)
00883     if ( fileSize.HighPart > 0 )
00884     {
00885         return HRESULT_FROM_WIN32( ERROR_FILE_TOO_LARGE );
00886     }
00887
00888     // Need at least enough data to fill the standard header to be a valid TGA
00889     if ( fileSize.LowPart < ( sizeof(TGA_HEADER) ) )
00890     {
00891         return E_FAIL;
00892     }
00893
00894     // Read the standard header (we don't need the file footer to parse the file)
00895     uint8_t header[sizeof(TGA_HEADER)];
00896     DWORD bytesRead = 0;
00897     if ( !ReadFile( hFile.get(), header, sizeof(TGA_HEADER), &bytesRead, 0 ) )
00898     {
00899         return HRESULT_FROM_WIN32( GetLastError() );
00900     }
00901
00902     size_t offset;
00903     return _DecodeTGAHeader( header, bytesRead, metadata, offset, 0 );
00904 }
00905 //-------------------------------------------------------------------------------------
00906 // Load a TGA file in memory
00907 //-------------------------------------------------------------------------------------
00908
00909 _Use_decl_annotations_
00910 HRESULT LoadFromTGAMemory( LPCVOID pSource, size_t size, TexMetadata* metadata, ScratchImage& image )
00911 {
00912     if ( !pSource || size == 0 )
00913         return E_INVALIDARG;
00914
00915     image.Release();
00916
00917     size_t offset;
00918     DWORD convFlags = 0;
00919     TexMetadata mdata;
00920     HRESULT hr = _DecodeTGAHeader( pSource, size, mdata, offset, &convFlags );
00921     if ( FAILED(hr) )
00922         return hr;
00923
00924     if ( offset > size )
00925         return E_FAIL;
00926
00927     LPCVOID pPixels = reinterpret_cast<LPCVOID>( reinterpret_cast<const uint8_t*>(pSource) + offset );
00928     assert( pPixels );
00929
00930     size_t remaining = size - offset;
00931     if ( remaining == 0 )
00932         return E_FAIL;
00933
00934     hr = image.Initialize2D( mdata.format, mdata.width, mdata.height, 1, 1 );
00935     if ( FAILED(hr) )
00936         return hr;
00937
00938     if ( convFlags & CONV_FLAGS_RLE )
00939     {
00940         hr = _UncompressPixels( pPixels, remaining, image.GetImage(0,0,0), convFlags );
00941     }
00942     else
00943     {
00944         hr = _CopyPixels( pPixels, remaining, image.GetImage(0,0,0), convFlags );
00945     }
00946
00947     if ( FAILED(hr) )
00948     {
00949         image.Release();
00950         return hr;
00951     }
00952
00953     if ( metadata )
00954         memcpy( metadata, &mdata, sizeof(TexMetadata) );
00955
00956     return S_OK;
00957 }
00958
00959
00960 //-------------------------------------------------------------------------------------
00961 // Load a TGA file from disk
00962 //-------------------------------------------------------------------------------------
00963 _Use_decl_annotations_
00964 HRESULT LoadFromTGAFile( LPCWSTR szFile, TexMetadata* metadata, ScratchImage& image )
00965 {
00966     if ( !szFile )
00967         return E_INVALIDARG;
00968
00969     image.Release();
00970
00971 #if (_WIN32_WINNT >= _WIN32_WINNT_WIN8)
00972     ScopedHandle hFile( safe_handle( CreateFile2( szFile, GENERIC_READ, FILE_SHARE_READ, OPEN_EXISTING, 0 ) ) );
00973 #else
00974     ScopedHandle hFile( safe_handle( CreateFileW( szFile, GENERIC_READ, FILE_SHARE_READ, 0, OPEN_EXISTING,
00975                                                   FILE_FLAG_SEQUENTIAL_SCAN, 0 ) ) );
00976 #endif
00977     if ( !hFile )
00978     {
00979         return HRESULT_FROM_WIN32( GetLastError() );
00980     }
00981
00982     // Get the file size
00983     LARGE_INTEGER fileSize = {0};
00984
00985 #if (_WIN32_WINNT >= _WIN32_WINNT_VISTA)
00986     FILE_STANDARD_INFO fileInfo;
00987     if ( !GetFileInformationByHandleEx( hFile.get(), FileStandardInfo, &fileInfo, sizeof(fileInfo) ) )
00988     {
00989         return HRESULT_FROM_WIN32( GetLastError() );
00990     }
00991     fileSize = fileInfo.EndOfFile;
00992 #else
00993     if ( !GetFileSizeEx( hFile.get(), &fileSize ) )
00994     {
00995         return HRESULT_FROM_WIN32( GetLastError() );
00996     }
00997 #endif
00998
00999     // File is too big for 32-bit allocation, so reject read (4 GB should be plenty large enough for a valid TGA file)
01000     if ( fileSize.HighPart > 0 )
01001     {
01002         return HRESULT_FROM_WIN32( ERROR_FILE_TOO_LARGE );
01003     }
01004
01005     // Need at least enough data to fill the header to be a valid TGA
01006     if ( fileSize.LowPart < sizeof(TGA_HEADER) )
01007     {
01008         return E_FAIL;
01009     }
01010
01011     // Read the header
01012     uint8_t header[sizeof(TGA_HEADER)];
01013     DWORD bytesRead = 0;
01014     if ( !ReadFile( hFile.get(), header, sizeof(TGA_HEADER), &bytesRead, 0 ) )
01015     {
01016         return HRESULT_FROM_WIN32( GetLastError() );
01017     }
01018
01019     size_t offset;
01020     DWORD convFlags = 0;
01021     TexMetadata mdata;
01022     HRESULT hr = _DecodeTGAHeader( header, bytesRead, mdata, offset, &convFlags );
01023     if ( FAILED(hr) )
01024         return hr;
01025
01026     // Read the pixels
01027     DWORD remaining = static_cast<DWORD>( fileSize.LowPart - offset );
01028     if ( remaining == 0 )
01029         return E_FAIL;
01030
01031     if ( offset > sizeof(TGA_HEADER) )
01032     {
01033         // Skip past the id string
01034         LARGE_INTEGER filePos = { static_cast<DWORD>(offset), 0 };
01035         if ( !SetFilePointerEx( hFile.get(), filePos, 0, FILE_BEGIN ) )
01036         {
01037             return HRESULT_FROM_WIN32( GetLastError() );
01038         }
01039     }
01040
01041     hr = image.Initialize2D( mdata.format, mdata.width, mdata.height, 1, 1 );
01042     if ( FAILED(hr) )
01043         return hr;
01044
01045     assert( image.GetPixels() );
01046
01047     if ( !(convFlags & (CONV_FLAGS_RLE | CONV_FLAGS_EXPAND | CONV_FLAGS_INVERTX)) && (convFlags & CONV_FLAGS_INVERTY) )
01048     {
01049         // This case we can read directly into the image buffer in place
01050         if ( !ReadFile( hFile.get(), image.GetPixels(), static_cast<DWORD>( image.GetPixelsSize() ), &bytesRead, 0 ) )
01051         {
01052             image.Release();
01053             return HRESULT_FROM_WIN32( GetLastError() );
01054         }
01055
01056         if ( bytesRead != image.GetPixelsSize() )
01057         {
01058             image.Release();
01059             return E_FAIL;
01060         }
01061
01062         switch( mdata.format  )
01063         {
01064         case DXGI_FORMAT_R8G8B8A8_UNORM:
01065             {
01066                 // TGA stores 32-bit data in BGRA form, need to swizzle to RGBA
01067                 assert( image.GetImageCount() == 1 );
01068                 const Image* img = image.GetImage(0,0,0);
01069                 if ( !img )
01070                     return E_POINTER;
01071
01072                 uint8_t *pPixels = img->pixels;
01073                 if ( !pPixels )
01074                     return E_POINTER;
01075
01076                 size_t rowPitch = img->rowPitch;
01077
01078                 // Scan for non-zero alpha channel
01079                 bool nonzeroa = false;
01080
01081                 for( size_t h = 0; h < img->height; ++h )
01082                 {
01083                     const uint32_t* sPtr = reinterpret_cast<const uint32_t*>( pPixels );
01084
01085                     for( size_t x=0; x < img->width; ++x )
01086                     {
01087                         if ( (*sPtr) & 0xff000000 )
01088                         {
01089                             nonzeroa = true;
01090                             break;
01091                         }
01092
01093                         ++sPtr;
01094                     }
01095
01096                     if ( nonzeroa )
01097                         break;
01098
01099                     pPixels += rowPitch;
01100                 }
01101
01102                 DWORD tflags = ( !nonzeroa ) ? TEXP_SCANLINE_SETALPHA : TEXP_SCANLINE_NONE;
01103
01104                 // Swizzle scanlines
01105                 pPixels = img->pixels;
01106
01107                 for( size_t h = 0; h < img->height; ++h )
01108                 {
01109                     _SwizzleScanline( pPixels, rowPitch, pPixels, rowPitch, mdata.format, tflags );
01110                     pPixels += rowPitch;
01111                 }
01112             }
01113             break;
01114
01115         // If we start using DXGI_FORMAT_B8G8R8X8_UNORM or DXGI_FORMAT_B8G8R8A8_UNORM we need to check for a fully 0 alpha channel
01116
01117         case DXGI_FORMAT_B5G5R5A1_UNORM:
01118             {
01119                 assert( image.GetImageCount() == 1 );
01120                 const Image* img = image.GetImage(0,0,0);
01121                 if ( !img )
01122                     return E_POINTER;
01123
01124                 // Scan for non-zero alpha channel
01125                 bool nonzeroa = false;
01126
01127                 const uint8_t *pPixels = img->pixels;
01128                 if ( !pPixels )
01129                     return E_POINTER;
01130
01131                 size_t rowPitch = img->rowPitch;
01132
01133                 for( size_t h = 0; h < img->height; ++h )
01134                 {
01135                     const uint16_t* sPtr = reinterpret_cast<const uint16_t*>( pPixels );
01136
01137                     for( size_t x=0; x < img->width; ++x )
01138                     {
01139                         if ( *sPtr & 0x8000 )
01140                         {
01141                             nonzeroa = true;
01142                             break;
01143                         }
01144
01145                         ++sPtr;
01146                     }
01147
01148                     if ( nonzeroa )
01149                         break;
01150
01151                     pPixels += rowPitch;
01152                 }
01153
01154                 // If there are no non-zero alpha channel entries, we'll assume alpha is not used and force it to opaque
01155                 if ( !nonzeroa )
01156                 {
01157                     hr = _SetAlphaChannelToOpaque( img );
01158                     if ( FAILED(hr) )
01159                         return hr;
01160                 }
01161             }
01162             break;
01163         }
01164     }
01165     else // RLE || EXPAND || INVERTX || !INVERTY
01166     {
01167         std::unique_ptr<uint8_t[]> temp( new uint8_t[ remaining ] );
01168         if ( !temp )
01169         {
01170             image.Release();
01171             return E_OUTOFMEMORY;
01172         }
01173
01174         if ( !ReadFile( hFile.get(), temp.get(), remaining, &bytesRead, 0 ) )
01175         {
01176             image.Release();
01177             return HRESULT_FROM_WIN32( GetLastError() );
01178         }
01179
01180         if ( bytesRead != remaining )
01181         {
01182             image.Release();
01183             return E_FAIL;
01184         }
01185
01186         if ( convFlags & CONV_FLAGS_RLE )
01187         {
01188             hr = _UncompressPixels( temp.get(), remaining, image.GetImage(0,0,0), convFlags );
01189         }
01190         else
01191         {
01192             hr = _CopyPixels( temp.get(), remaining, image.GetImage(0,0,0), convFlags );
01193         }
01194
01195         if ( FAILED(hr) )
01196         {
01197             image.Release();
01198             return hr;
01199         }
01200     }
01201
01202     if ( metadata )
01203         memcpy( metadata, &mdata, sizeof(TexMetadata) );
01204
01205     return S_OK;
01206 }
01207 //-------------------------------------------------------------------------------------
01208 // Save a TGA file to memory
01209 //-------------------------------------------------------------------------------------
01210 _Use_decl_annotations_
01211 HRESULT SaveToTGAMemory( const Image& image, Blob& blob )
01212 {
01213     if ( !image.pixels )
01214         return E_POINTER;
01215
01216     TGA_HEADER tga_header;
01217     DWORD convFlags = 0;
01218     HRESULT hr = _EncodeTGAHeader( image, tga_header, convFlags );
01219     if ( FAILED(hr) )
01220         return hr;
01221
01222     blob.Release();
01223
01224     // Determine memory required for image data
01225     size_t rowPitch, slicePitch;
01226     if ( convFlags & CONV_FLAGS_888 )
01227     {
01228         rowPitch = image.width * 3;
01229         slicePitch = image.height * rowPitch;
01230     }
01231     else
01232     {
01233         ComputePitch( image.format, image.width, image.height, rowPitch, slicePitch, CP_FLAGS_NONE );
01234     }
01235
01236     hr = blob.Initialize( sizeof(TGA_HEADER) + slicePitch );
01237     if ( FAILED(hr) )
01238         return hr;
01239
01240     // Copy header
01241     uint8_t* dPtr = reinterpret_cast<uint8_t*>( blob.GetBufferPointer() );
01242     assert( dPtr != 0 );
01243     memcpy_s( dPtr, blob.GetBufferSize(), &tga_header, sizeof(TGA_HEADER) );
01244     dPtr += sizeof(TGA_HEADER);
01245
01246     const uint8_t* pPixels = reinterpret_cast<const uint8_t*>( image.pixels );
01247     assert( pPixels );
01248
01249     for( size_t y = 0; y < image.height; ++y )
01250     {
01251         // Copy pixels
01252         if ( convFlags & CONV_FLAGS_888 )
01253         {
01254             _Copy24bppScanline( dPtr, rowPitch, pPixels, image.rowPitch );
01255         }
01256         else if ( convFlags & CONV_FLAGS_SWIZZLE )
01257         {
01258             _SwizzleScanline( dPtr, rowPitch, pPixels, image.rowPitch, image.format, TEXP_SCANLINE_NONE );
01259         }
01260         else
01261         {
01262             _CopyScanline( dPtr, rowPitch, pPixels, image.rowPitch, image.format, TEXP_SCANLINE_NONE );
01263         }
01264
01265         dPtr += rowPitch;
01266         pPixels += image.rowPitch;
01267     }
01268
01269     return S_OK;
01270 }
01271
01272
01273 //-------------------------------------------------------------------------------------
01274 // Save a TGA file to disk
01275 //-------------------------------------------------------------------------------------
01276 _Use_decl_annotations_
01277 HRESULT SaveToTGAFile( const Image& image, LPCWSTR szFile )
01278 {
01279     if ( !szFile )
01280         return E_INVALIDARG;
01281
01282     if ( !image.pixels )
01283         return E_POINTER;
01284
01285     TGA_HEADER tga_header;
01286     DWORD convFlags = 0;
01287     HRESULT hr = _EncodeTGAHeader( image, tga_header, convFlags );
01288     if ( FAILED(hr) )
01289         return hr;
01290
01291     // Create file and write header
01292 #if (_WIN32_WINNT >= _WIN32_WINNT_WIN8)
01293     ScopedHandle hFile( safe_handle( CreateFile2( szFile, GENERIC_WRITE, 0, CREATE_ALWAYS, 0 ) ) );
01294 #else
01295     ScopedHandle hFile( safe_handle( CreateFileW( szFile, GENERIC_WRITE, 0, 0, CREATE_ALWAYS, 0, 0 ) ) );
01296 #endif
01297     if ( !hFile )
01298     {
01299         return HRESULT_FROM_WIN32( GetLastError() );
01300     }
01301
01302     // Determine size for TGA pixel data
01303     size_t rowPitch, slicePitch;
01304     if ( convFlags & CONV_FLAGS_888 )
01305     {
01306         rowPitch = image.width * 3;
01307         slicePitch = image.height * rowPitch;
01308     }
01309     else
01310     {
01311         ComputePitch( image.format, image.width, image.height, rowPitch, slicePitch, CP_FLAGS_NONE );
01312     }
01313
01314     if ( slicePitch < 65535 )
01315     {
01316         // For small images, it is better to create an in-memory file and write it out
01317         Blob blob;
01318
01319         hr = SaveToTGAMemory( image, blob );
01320         if ( FAILED(hr) )
01321             return hr;
01322
01323         // Write blob
01324         const DWORD bytesToWrite = static_cast<DWORD>( blob.GetBufferSize() );
01325         DWORD bytesWritten;
01326         if ( !WriteFile( hFile.get(), blob.GetBufferPointer(), bytesToWrite,
01327                          &bytesWritten, 0 ) )
01328         {
01329             return HRESULT_FROM_WIN32( GetLastError() );
01330         }
01331
01332         if ( bytesWritten != bytesToWrite )
01333         {
01334             return E_FAIL;
01335         }
01336     }
01337     else
01338     {
01339         // Otherwise, write the image one scanline at a time...
01340         std::unique_ptr<uint8_t[]> temp( new uint8_t[ rowPitch ] );
01341         if ( !temp )
01342             return E_OUTOFMEMORY;
01343
01344         // Write header
01345         DWORD bytesWritten;
01346         if ( !WriteFile( hFile.get(), &tga_header, sizeof(TGA_HEADER), &bytesWritten, 0 ) )
01347         {
01348             return HRESULT_FROM_WIN32( GetLastError() );
01349         }
01350
01351         if ( bytesWritten != sizeof(TGA_HEADER) )
01352             return E_FAIL;
01353
01354         // Write pixels
01355         const uint8_t* pPixels = reinterpret_cast<const uint8_t*>( image.pixels );
01356
01357         for( size_t y = 0; y < image.height; ++y )
01358         {
01359             // Copy pixels
01360             if ( convFlags & CONV_FLAGS_888 )
01361             {
01362                 _Copy24bppScanline( temp.get(), rowPitch, pPixels, image.rowPitch );
01363             }
01364             else if ( convFlags & CONV_FLAGS_SWIZZLE )
01365             {
01366                 _SwizzleScanline( temp.get(), rowPitch, pPixels, image.rowPitch, image.format, TEXP_SCANLINE_NONE );
01367             }
01368             else
01369             {
01370                 _CopyScanline( temp.get(), rowPitch, pPixels, image.rowPitch, image.format, TEXP_SCANLINE_NONE );
01371             }
01372
01373             pPixels += image.rowPitch;
01374
01375             if ( !WriteFile( hFile.get(), temp.get(), static_cast<DWORD>( rowPitch ), &bytesWritten, 0 ) )
01376             {
01377                 return HRESULT_FROM_WIN32( GetLastError() );
01378             }
01379
01380             if ( bytesWritten != rowPitch )
01381                 return E_FAIL;
01382         }
01383     }
01384
01385     return S_OK;
01386 }
01387
01388 }; // namespace
Generated on Sat Nov 23 2024 16:08:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/NotificationExpiration.xaml.h Source File

  • App tiles and badges
  • C#,C++

NotificationExpiration.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // NotificationExpiration.xaml.h
00013 // Declaration of the NotificationExpiration class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "NotificationExpiration.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Tiles
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class NotificationExpiration sealed
00031         {
00032         public:
00033             NotificationExpiration();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         void UpdateTileExpiring_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaExtensionsCPP::sealed Member List

This is the complete list of members for MediaExtensionsCPP::sealed, including all inherited members.
_displayHandlerToken | MediaExtensionsCPP::sealed | [private]
_extensionManager | MediaExtensionsCPP::sealed | [private]
_frameLoadedToken | MediaExtensionsCPP::sealed | [private]
_inputFrame | MediaExtensionsCPP::sealed | [private]
_inputFrameLoadedToken | MediaExtensionsCPP::sealed | [private]
_layoutHandlerToken | MediaExtensionsCPP::sealed | [private]
_logicalDpiChangedToken | MediaExtensionsCPP::sealed | [private]
_mediaFailedToken | MediaExtensionsCPP::sealed | [private]
_outputFrame | MediaExtensionsCPP::sealed | [private]
_outputFrameLoadedToken | MediaExtensionsCPP::sealed | [private]
_pageLoadedHandlerToken | MediaExtensionsCPP::sealed | [private]
_scenariosFrame | MediaExtensionsCPP::sealed | [private]
_stabilizedMediaFailedToken | MediaExtensionsCPP::sealed | [private]
CheckResolutionAndViewState() | MediaExtensionsCPP::sealed | [private]
Circle_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
ConvertResolution(ResolutionScale scale) | MediaExtensionsCPP::sealed |
ConvertViewState(ApplicationViewState state) | MediaExtensionsCPP::sealed |
DisplayProperties_LogicalDpiChanged(Object^sender) | MediaExtensionsCPP::sealed | [private]
DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame) | MediaExtensionsCPP::sealed |
Footer_Click(Object^sender, RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
inputFrameNavigated(Object^sender, NavigationEventArgs^e) | MediaExtensionsCPP::sealed | [private]
MainPage() | MediaExtensionsCPP::sealed |
NotifyUser(String^strMessage, NotifyType type) | MediaExtensionsCPP::sealed |
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | MediaExtensionsCPP::sealed | [protected, virtual]
Open_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
Open_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
OpenFisheye_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
OpenGrayscale_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
OpenInvert_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
OpenPinch_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
OpenVideoWithPolarEffect(String^effectName) | MediaExtensionsCPP::sealed | [private]
OpenWarp_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
OutputFrameLoaded | MediaExtensionsCPP::sealed |
outputFrameNavigated(Object^sender, NavigationEventArgs^e) | MediaExtensionsCPP::sealed | [private]
outputVideo | MediaExtensionsCPP::sealed | [private]
outputVideo | MediaExtensionsCPP::sealed | [private]
outputVideoStabilized | MediaExtensionsCPP::sealed | [private]
Page_Loaded(Object^sender, RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
Page_SizeChanged(Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
PickSingleFileAndSet(Windows::Foundation::Collections::IVector< String^>^fileTypeFilters, Windows::Foundation::Collections::IVector< MediaElement^>^mediaElements) | MediaExtensionsCPP::sealed |
rootPage | MediaExtensionsCPP::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | MediaExtensionsCPP::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | MediaExtensionsCPP::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | MediaExtensionsCPP::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | MediaExtensionsCPP::sealed | [private]
ScenarioInput1() | MediaExtensionsCPP::sealed |
ScenarioInput2() | MediaExtensionsCPP::sealed |
ScenarioInput3() | MediaExtensionsCPP::sealed |
ScenarioInput4() | MediaExtensionsCPP::sealed |
ScenarioList() | MediaExtensionsCPP::sealed |
ScenarioOutput1() | MediaExtensionsCPP::sealed |
ScenarioOutput2() | MediaExtensionsCPP::sealed |
ScenarioOutput3() | MediaExtensionsCPP::sealed |
ScenarioOutput4() | MediaExtensionsCPP::sealed |
Scenarios_SelectionChanged(Object^sender, SelectionChangedEventArgs^e) | MediaExtensionsCPP::sealed | [protected]
SetFeatureName(Platform::String^strFeature) | MediaExtensionsCPP::sealed | [private]
Square_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
Stop_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
Stop_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
Stop_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
Triangle_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | MediaExtensionsCPP::sealed | [private]
VideoOnError(Object^obj, ExceptionRoutedEventArgs^args) | MediaExtensionsCPP::sealed |
~MainPage() | MediaExtensionsCPP::sealed | [private]
~ScenarioInput1() | MediaExtensionsCPP::sealed | [private]
~ScenarioInput2() | MediaExtensionsCPP::sealed | [private]
~ScenarioInput3() | MediaExtensionsCPP::sealed | [private]
~ScenarioInput4() | MediaExtensionsCPP::sealed | [private]
~ScenarioList() | MediaExtensionsCPP::sealed | [private]
~ScenarioOutput1() | MediaExtensionsCPP::sealed | [private]
~ScenarioOutput2() | MediaExtensionsCPP::sealed | [private]
~ScenarioOutput3() | MediaExtensionsCPP::sealed | [private]
~ScenarioOutput4() | MediaExtensionsCPP::sealed | [private]
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Constants.cpp Source File

  • XAML AppBar control

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace AppBarControl;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "Basics", "AppBarControl.Scenario1" },
00022     { "'Sticky' AppBars", "AppBarControl.Scenario2" },
00023     { "Global AppBars", "AppBarControl.Scenario3" },
00024     { "Animating Commands", "AppBarControl.Scenario4" }
00025 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/LayoutAwarePage.h Source File

  • XAML high contrast style
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicShapes.h Source File

  • Direct3D stereoscopic 3D

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/common/LayoutAwarePage.h Source File

  • File access
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioOutput2.xaml.cpp Source File

  • Raw notifications
  • MainAppSample

ScenarioOutput2.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.cpp
00010 // Implementation of the Scenario1Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput2.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace RawNotificationsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput2::ScenarioOutput2()
00033 {
00034   InitializeComponent();
00035 }
00036
00037 ScenarioOutput2::~ScenarioOutput2()
00038 {
00039 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/EnumerateTiles.xaml.h Source File

  • Secondary tiles
  • C#,C++

EnumerateTiles.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // EnumerateTiles.xaml.h
00013 // Declaration of the EnumerateTiles class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "EnumerateTiles.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SecondaryTiles
00023 {
00024     /// <summary>
00025     /// An empty page that can be used on its own or navigated to within a Frame.
00026     /// </summary>
00027     [Windows::Foundation::Metadata::WebHostHidden]
00028     public ref class EnumerateTiles sealed
00029     {
00030     public:
00031         EnumerateTiles();
00032
00033     protected:
00034         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00035         virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00036
00037     private:
00038         MainPage^ rootPage;
00039         Windows::UI::Xaml::Controls::AppBar^ appBar;
00040         void EnumerateSecondaryTiles_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041     };
00042 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MPEG1SystemHeader Member List

This is the complete list of members for MPEG1SystemHeader, including all inherited members.
bAudioLock | MPEG1SystemHeader
bCSPS | MPEG1SystemHeader
bFixed | MPEG1SystemHeader
bVideoLock | MPEG1SystemHeader
cAudioBound | MPEG1SystemHeader
cbSize | MPEG1SystemHeader
cStreams | MPEG1SystemHeader
cVideoBound | MPEG1SystemHeader
rateBound | MPEG1SystemHeader
streams | MPEG1SystemHeader
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/BasicTimer.cpp Source File

  • XAudio2 audio file playback

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/SampleOverlay.h Source File

  • DirectWrite hit testing

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/pch.cpp Source File

  • Application data

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/pch.cpp Source File

  • XAML animation library

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario8.xaml.h Source File

  • XAML WebView control

Scenario8.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario8.xaml.h
00013 // Declaration of the Scenario8 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario8.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace WebViewControl
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario8 sealed
00031         {
00032         public:
00033             Scenario8();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         void ShowMe_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040       };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Grayscale/Grayscale.cpp Source File

  • Media extensions
  • MediaExtensions
  • Grayscale

Grayscale.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #include "Grayscale.h"
00009 #include "bufferlock.h"
00010
00011 #pragma comment(lib, "d2d1")
00012
00013 using namespace Microsoft::WRL;
00014
00015 /*
00016
00017 This sample implements a video effect as a Media Foundation transform (MFT).
00018
00019 The video effect manipulates chroma values in a YUV image. In the default setting,
00020 the entire image is converted to grayscale. Optionally, the application may set any
00021 of the following attributes:
00022
00023 MFT_GRAYSCALE_DESTINATION_RECT (type = blob, UINT32[4] array)
00024
00025     Sets the destination rectangle for the effect. Pixels outside the destination
00026     rectangle are not altered.
00027
00028 MFT_GRAYSCALE_SATURATION (type = double)
00029
00030     Sets the saturation level. The nominal range is [0...1]. Values beyond 1.0f
00031     result in supersaturated colors. Values below 0.0f create inverted colors.
00032
00033 MFT_GRAYSCALE_CHROMA_ROTATION (type = double)
00034
00035     Rotates the chroma values of each pixel. The attribue value is the angle of
00036     rotation in degrees. The result is a shift in hue.
00037
00038 The effect is implemented by treating the chroma value of each pixel as a vector [u,v],
00039 and applying a transformation matrix to the vector. The saturation parameter is applied
00040 as a scaling transform.
00041
00042
00043 NOTES ON THE MFT IMPLEMENTATION
00044
00045 1. The MFT has fixed streams: One input stream and one output stream.
00046
00047 2. The MFT supports the following formats: UYVY, YUY2, NV12.
00048
00049 3. If the MFT is holding an input sample, SetInputType and SetOutputType both fail.
00050
00051 4. The input and output types must be identical.
00052
00053 5. If both types are set, no type can be set until the current type is cleared.
00054
00055 6. Preferred input types:
00056
00057      (a) If the output type is set, that's the preferred type.
00058      (b) Otherwise, the preferred types are partial types, constructed from the
00059          list of supported subtypes.
00060
00061 7. Preferred output types: As above.
00062
00063 8. Streaming:
00064
00065     The private BeingStreaming() method is called in response to the
00066     MFT_MESSAGE_NOTIFY_BEGIN_STREAMING message.
00067
00068     If the client does not send MFT_MESSAGE_NOTIFY_BEGIN_STREAMING, the MFT calls
00069     BeginStreaming inside the first call to ProcessInput or ProcessOutput.
00070
00071     This is a good approach for allocating resources that your MFT requires for
00072     streaming.
00073
00074 9. The configuration attributes are applied in the BeginStreaming method. If the
00075    client changes the attributes during streaming, the change is ignored until
00076    streaming is stopped (either by changing the media types or by sending the
00077    MFT_MESSAGE_NOTIFY_END_STREAMING message) and then restarted.
00078
00079 */
00080
00081
00082 // Video FOURCC codes.
00083 const DWORD FOURCC_YUY2 = '2YUY';
00084 const DWORD FOURCC_UYVY = 'YVYU';
00085 const DWORD FOURCC_NV12 = '21VN';
00086
00087 // Static array of media types (preferred and accepted).
00088 const GUID g_MediaSubtypes[] =
00089 {
00090     MFVideoFormat_NV12,
00091     MFVideoFormat_YUY2,
00092     MFVideoFormat_UYVY
00093 };
00094
00095 HRESULT GetImageSize(DWORD fcc, UINT32 width, UINT32 height, DWORD* pcbImage);
00096 HRESULT GetDefaultStride(IMFMediaType *pType, LONG *plStride);
00097 bool ValidateRect(const RECT& rc);
00098
00099 template <typename T>
00100 inline T clamp(const T& val, const T& minVal, const T& maxVal)
00101 {
00102     return (val < minVal ? minVal : (val > maxVal ? maxVal : val));
00103 }
00104
00105
00106 // TransformChroma:
00107 // Apply the transforms to calculate the output chroma values.
00108
00109 void TransformChroma(const D2D1::Matrix3x2F& mat, BYTE *pu, BYTE *pv)
00110 {
00111     // Normalize the chroma values to [-112, 112] range
00112
00113     D2D1_POINT_2F pt = { static_cast<float>(*pu) - 128, static_cast<float>(*pv) - 128 };
00114
00115     pt = mat.TransformPoint(pt);
00116
00117     // Clamp to valid range.
00118     clamp(pt.x, -112.0f, 112.0f);
00119     clamp(pt.y, -112.0f, 112.0f);
00120
00121     // Map back to [16...240] range.
00122     *pu = static_cast<BYTE>(pt.x + 128.0f);
00123     *pv = static_cast<BYTE>(pt.y + 128.0f);
00124 }
00125
00126 //-------------------------------------------------------------------
00127 // Functions to convert a YUV images to grayscale.
00128 //
00129 // In all cases, the same transformation is applied to the 8-bit
00130 // chroma values, but the pixel layout in memory differs.
00131 //
00132 // The image conversion functions take the following parameters:
00133 //
00134 // mat               Transfomation matrix for chroma values.
00135 // rcDest            Destination rectangle.
00136 // pDest             Pointer to the destination buffer.
00137 // lDestStride       Stride of the destination buffer, in bytes.
00138 // pSrc              Pointer to the source buffer.
00139 // lSrcStride        Stride of the source buffer, in bytes.
00140 // dwWidthInPixels   Frame width in pixels.
00141 // dwHeightInPixels  Frame height, in pixels.
00142 //-------------------------------------------------------------------
00143
00144 // Convert UYVY image.
00145
00146 void TransformImage_UYVY(
00147     const D2D1::Matrix3x2F& mat,
00148     const D2D_RECT_U& rcDest,
00149     _Inout_updates_(_Inexpressible_(lDestStride * dwHeightInPixels)) BYTE *pDest,
00150     _In_ LONG lDestStride,
00151     _In_reads_(_Inexpressible_(lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00152     _In_ LONG lSrcStride,
00153     _In_ DWORD dwWidthInPixels,
00154     _In_ DWORD dwHeightInPixels)
00155 {
00156     DWORD y = 0;
00157     const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);
00158
00159     // Lines above the destination rectangle.
00160     for ( ; y < rcDest.top; y++)
00161     {
00162         memcpy(pDest, pSrc, dwWidthInPixels * 2);
00163         pSrc += lSrcStride;
00164         pDest += lDestStride;
00165     }
00166
00167     // Lines within the destination rectangle.
00168     for ( ; y < y0; y++)
00169     {
00170         WORD *pSrc_Pixel = (WORD*)pSrc;
00171         WORD *pDest_Pixel = (WORD*)pDest;
00172
00173         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00174         {
00175             // Byte order is U0 Y0 V0 Y1
00176             // Each WORD is a byte pair (U/V, Y)
00177             // Windows is little-endian so the order appears reversed.
00178
00179             if (x >= rcDest.left && x < rcDest.right)
00180             {
00181                 BYTE u = pSrc_Pixel[x] & 0x00FF;
00182                 BYTE v = pSrc_Pixel[x+1] & 0x00FF;
00183
00184                 TransformChroma(mat, &u, &v);
00185
00186                 pDest_Pixel[x] = (pSrc_Pixel[x] & 0xFF00) | u;
00187                 pDest_Pixel[x+1] = (pSrc_Pixel[x+1] & 0xFF00) | v;
00188             }
00189             else
00190             {
00191 #pragma warning(push)
00192 #pragma warning(disable: 6385)
00193 #pragma warning(disable: 6386)
00194                 pDest_Pixel[x] = pSrc_Pixel[x];
00195                 pDest_Pixel[x+1] = pSrc_Pixel[x+1];
00196 #pragma warning(pop)
00197             }
00198         }
00199
00200         pDest += lDestStride;
00201         pSrc += lSrcStride;
00202     }
00203
00204     // Lines below the destination rectangle.
00205     for ( ; y < dwHeightInPixels; y++)
00206     {
00207         memcpy(pDest, pSrc, dwWidthInPixels * 2);
00208         pSrc += lSrcStride;
00209         pDest += lDestStride;
00210     }
00211 }
00212
00213
00214 // Convert YUY2 image.
00215
00216 void TransformImage_YUY2(
00217     const D2D1::Matrix3x2F& mat,
00218     const D2D_RECT_U& rcDest,
00219     _Inout_updates_(_Inexpressible_(lDestStride * dwHeightInPixels)) BYTE *pDest,
00220     _In_ LONG lDestStride,
00221     _In_reads_(_Inexpressible_(lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00222     _In_ LONG lSrcStride,
00223     _In_ DWORD dwWidthInPixels,
00224     _In_ DWORD dwHeightInPixels)
00225 {
00226     DWORD y = 0;
00227     const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);
00228
00229     // Lines above the destination rectangle.
00230     for ( ; y < rcDest.top; y++)
00231     {
00232         memcpy(pDest, pSrc, dwWidthInPixels * 2);
00233         pSrc += lSrcStride;
00234         pDest += lDestStride;
00235     }
00236
00237     // Lines within the destination rectangle.
00238     for ( ; y < y0; y++)
00239     {
00240         WORD *pSrc_Pixel = (WORD*)pSrc;
00241         WORD *pDest_Pixel = (WORD*)pDest;
00242
00243         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00244         {
00245             // Byte order is Y0 U0 Y1 V0
00246             // Each WORD is a byte pair (Y, U/V)
00247             // Windows is little-endian so the order appears reversed.
00248
00249             if (x >= rcDest.left && x < rcDest.right)
00250             {
00251                 BYTE u = pSrc_Pixel[x] >> 8;
00252                 BYTE v = pSrc_Pixel[x+1] >> 8;
00253
00254                 TransformChroma(mat, &u, &v);
00255
00256                 pDest_Pixel[x] = (pSrc_Pixel[x] & 0x00FF) | (u<<8);
00257                 pDest_Pixel[x+1] = (pSrc_Pixel[x+1] & 0x00FF) | (v<<8);
00258             }
00259             else
00260             {
00261 #pragma warning(push)
00262 #pragma warning(disable: 6385)
00263 #pragma warning(disable: 6386)
00264                 pDest_Pixel[x] = pSrc_Pixel[x];
00265                 pDest_Pixel[x+1] = pSrc_Pixel[x+1];
00266 #pragma warning(pop)
00267             }
00268         }
00269         pDest += lDestStride;
00270         pSrc += lSrcStride;
00271     }
00272
00273     // Lines below the destination rectangle.
00274     for ( ; y < dwHeightInPixels; y++)
00275     {
00276         memcpy(pDest, pSrc, dwWidthInPixels * 2);
00277         pSrc += lSrcStride;
00278         pDest += lDestStride;
00279     }
00280 }
00281
00282 // Convert NV12 image
00283
00284 void TransformImage_NV12(
00285     const D2D1::Matrix3x2F& mat,
00286     const D2D_RECT_U& rcDest,
00287     _Inout_updates_(_Inexpressible_(2 * lDestStride * dwHeightInPixels)) BYTE *pDest,
00288     _In_ LONG lDestStride,
00289     _In_reads_(_Inexpressible_(2 * lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00290     _In_ LONG lSrcStride,
00291     _In_ DWORD dwWidthInPixels,
00292     _In_ DWORD dwHeightInPixels)
00293 {
00294     // NV12 is planar: Y plane, followed by packed U-V plane.
00295
00296     // Y plane
00297     for (DWORD y = 0; y < dwHeightInPixels; y++)
00298     {
00299         CopyMemory(pDest, pSrc, dwWidthInPixels);
00300         pDest += lDestStride;
00301         pSrc += lSrcStride;
00302     }
00303
00304     // U-V plane
00305
00306     // NOTE: The U-V plane has 1/2 the number of lines as the Y plane.
00307
00308     // Lines above the destination rectangle.
00309     DWORD y = 0;
00310     const DWORD y0 = min(rcDest.bottom, dwHeightInPixels);
00311
00312     for ( ; y < rcDest.top/2; y++)
00313     {
00314         memcpy(pDest, pSrc, dwWidthInPixels);
00315         pSrc += lSrcStride;
00316         pDest += lDestStride;
00317     }
00318
00319     // Lines within the destination rectangle.
00320     for ( ; y < y0/2; y++)
00321     {
00322         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00323         {
00324             if (x >= rcDest.left && x < rcDest.right)
00325             {
00326                 BYTE u = pSrc[x];
00327                 BYTE v = pSrc[x+1];
00328
00329                 TransformChroma(mat, &u, &v);
00330
00331                 pDest[x] = u;
00332                 pDest[x+1] = v;
00333             }
00334             else
00335             {
00336                 pDest[x] = pSrc[x];
00337                 pDest[x+1] = pSrc[x+1];
00338             }
00339         }
00340         pDest += lDestStride;
00341         pSrc += lSrcStride;
00342     }
00343
00344     // Lines below the destination rectangle.
00345     for ( ; y < dwHeightInPixels/2; y++)
00346     {
00347         memcpy(pDest, pSrc, dwWidthInPixels);
00348         pSrc += lSrcStride;
00349         pDest += lDestStride;
00350     }
00351 }
00352
00353 CGrayscale::CGrayscale() :
00354     m_pSample(NULL), m_pInputType(NULL), m_pOutputType(NULL), m_pTransformFn(NULL),
00355     m_imageWidthInPixels(0), m_imageHeightInPixels(0), m_cbImageSize(0),
00356     m_transform(D2D1::Matrix3x2F::Identity()), m_rcDest(D2D1::RectU()), m_bStreamingInitialized(false),
00357     m_pAttributes(NULL)
00358 {
00359     InitializeCriticalSectionEx(&m_critSec, 3000, 0);
00360 }
00361
00362 CGrayscale::~CGrayscale()
00363 {
00364     SafeRelease(&m_pInputType);
00365     SafeRelease(&m_pOutputType);
00366     SafeRelease(&m_pSample);
00367     SafeRelease(&m_pAttributes);
00368     DeleteCriticalSection(&m_critSec);
00369 }
00370
00371 // Initialize the instance.
00372 STDMETHODIMP CGrayscale::RuntimeClassInitialize()
00373 {
00374     // Create the attribute store.
00375     return MFCreateAttributes(&m_pAttributes, 3);
00376 }
00377
00378 // IMediaExtension methods
00379
00380 //-------------------------------------------------------------------
00381 // SetProperties
00382 // Sets the configuration of the effect
00383 //-------------------------------------------------------------------
00384 HRESULT CGrayscale::SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
00385 {
00386     return S_OK;
00387 }
00388
00389 // IMFTransform methods. Refer to the Media Foundation SDK documentation for details.
00390
00391 //-------------------------------------------------------------------
00392 // GetStreamLimits
00393 // Returns the minimum and maximum number of streams.
00394 //-------------------------------------------------------------------
00395
00396 HRESULT CGrayscale::GetStreamLimits(
00397     DWORD   *pdwInputMinimum,
00398     DWORD   *pdwInputMaximum,
00399     DWORD   *pdwOutputMinimum,
00400     DWORD   *pdwOutputMaximum
00401 )
00402 {
00403     if ((pdwInputMinimum == NULL) ||
00404         (pdwInputMaximum == NULL) ||
00405         (pdwOutputMinimum == NULL) ||
00406         (pdwOutputMaximum == NULL))
00407     {
00408         return E_POINTER;
00409     }
00410
00411     // This MFT has a fixed number of streams.
00412     *pdwInputMinimum = 1;
00413     *pdwInputMaximum = 1;
00414     *pdwOutputMinimum = 1;
00415     *pdwOutputMaximum = 1;
00416     return S_OK;
00417 }
00418
00419
00420 //-------------------------------------------------------------------
00421 // GetStreamCount
00422 // Returns the actual number of streams.
00423 //-------------------------------------------------------------------
00424
00425 HRESULT CGrayscale::GetStreamCount(
00426     DWORD   *pcInputStreams,
00427     DWORD   *pcOutputStreams
00428 )
00429 {
00430     if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))
00431
00432     {
00433         return E_POINTER;
00434     }
00435
00436     // This MFT has a fixed number of streams.
00437     *pcInputStreams = 1;
00438     *pcOutputStreams = 1;
00439     return S_OK;
00440 }
00441
00442
00443
00444 //-------------------------------------------------------------------
00445 // GetStreamIDs
00446 // Returns stream IDs for the input and output streams.
00447 //-------------------------------------------------------------------
00448
00449 HRESULT CGrayscale::GetStreamIDs(
00450     DWORD   dwInputIDArraySize,
00451     DWORD   *pdwInputIDs,
00452     DWORD   dwOutputIDArraySize,
00453     DWORD   *pdwOutputIDs
00454 )
00455 {
00456     // It is not required to implement this method if the MFT has a fixed number of
00457     // streams AND the stream IDs are numbered sequentially from zero (that is, the
00458     // stream IDs match the stream indexes).
00459
00460     // In that case, it is OK to return E_NOTIMPL.
00461     return E_NOTIMPL;
00462 }
00463
00464
00465 //-------------------------------------------------------------------
00466 // GetInputStreamInfo
00467 // Returns information about an input stream.
00468 //-------------------------------------------------------------------
00469
00470 HRESULT CGrayscale::GetInputStreamInfo(
00471     DWORD                     dwInputStreamID,
00472     MFT_INPUT_STREAM_INFO *   pStreamInfo
00473 )
00474 {
00475     if (pStreamInfo == NULL)
00476     {
00477         return E_POINTER;
00478     }
00479
00480     EnterCriticalSection(&m_critSec);
00481
00482     if (!IsValidInputStream(dwInputStreamID))
00483     {
00484         LeaveCriticalSection(&m_critSec);
00485         return MF_E_INVALIDSTREAMNUMBER;
00486     }
00487
00488     // NOTE: This method should succeed even when there is no media type on the
00489     //       stream. If there is no media type, we only need to fill in the dwFlags
00490     //       member of MFT_INPUT_STREAM_INFO. The other members depend on having a
00491     //       a valid media type.
00492
00493     pStreamInfo->hnsMaxLatency = 0;
00494     pStreamInfo->dwFlags = MFT_INPUT_STREAM_WHOLE_SAMPLES | MFT_INPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER;
00495
00496     if (m_pInputType == NULL)
00497     {
00498         pStreamInfo->cbSize = 0;
00499     }
00500     else
00501     {
00502         pStreamInfo->cbSize = m_cbImageSize;
00503     }
00504
00505     pStreamInfo->cbMaxLookahead = 0;
00506     pStreamInfo->cbAlignment = 0;
00507
00508     LeaveCriticalSection(&m_critSec);
00509     return S_OK;
00510 }
00511
00512 //-------------------------------------------------------------------
00513 // GetOutputStreamInfo
00514 // Returns information about an output stream.
00515 //-------------------------------------------------------------------
00516
00517 HRESULT CGrayscale::GetOutputStreamInfo(
00518     DWORD                     dwOutputStreamID,
00519     MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00520 )
00521 {
00522     if (pStreamInfo == NULL)
00523     {
00524         return E_POINTER;
00525     }
00526
00527     EnterCriticalSection(&m_critSec);
00528
00529     if (!IsValidOutputStream(dwOutputStreamID))
00530     {
00531         LeaveCriticalSection(&m_critSec);
00532         return MF_E_INVALIDSTREAMNUMBER;
00533     }
00534
00535     // NOTE: This method should succeed even when there is no media type on the
00536     //       stream. If there is no media type, we only need to fill in the dwFlags
00537     //       member of MFT_OUTPUT_STREAM_INFO. The other members depend on having a
00538     //       a valid media type.
00539
00540     pStreamInfo->dwFlags =
00541         MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
00542         MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
00543         MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;
00544
00545     if (m_pOutputType == NULL)
00546     {
00547         pStreamInfo->cbSize = 0;
00548     }
00549     else
00550     {
00551         pStreamInfo->cbSize = m_cbImageSize;
00552     }
00553
00554     pStreamInfo->cbAlignment = 0;
00555
00556     LeaveCriticalSection(&m_critSec);
00557     return S_OK;
00558 }
00559
00560
00561 //-------------------------------------------------------------------
00562 // GetAttributes
00563 // Returns the attributes for the MFT.
00564 //-------------------------------------------------------------------
00565
00566 HRESULT CGrayscale::GetAttributes(IMFAttributes** ppAttributes)
00567 {
00568     if (ppAttributes == NULL)
00569     {
00570         return E_POINTER;
00571     }
00572
00573     EnterCriticalSection(&m_critSec);
00574
00575     *ppAttributes = m_pAttributes;
00576     (*ppAttributes)->AddRef();
00577
00578     LeaveCriticalSection(&m_critSec);
00579     return S_OK;
00580 }
00581
00582
00583 //-------------------------------------------------------------------
00584 // GetInputStreamAttributes
00585 // Returns stream-level attributes for an input stream.
00586 //-------------------------------------------------------------------
00587
00588 HRESULT CGrayscale::GetInputStreamAttributes(
00589     DWORD           dwInputStreamID,
00590     IMFAttributes   **ppAttributes
00591 )
00592 {
00593     // This MFT does not support any stream-level attributes, so the method is not implemented.
00594     return E_NOTIMPL;
00595 }
00596
00597
00598 //-------------------------------------------------------------------
00599 // GetOutputStreamAttributes
00600 // Returns stream-level attributes for an output stream.
00601 //-------------------------------------------------------------------
00602
00603 HRESULT CGrayscale::GetOutputStreamAttributes(
00604     DWORD           dwOutputStreamID,
00605     IMFAttributes   **ppAttributes
00606 )
00607 {
00608     // This MFT does not support any stream-level attributes, so the method is not implemented.
00609     return E_NOTIMPL;
00610 }
00611
00612
00613 //-------------------------------------------------------------------
00614 // DeleteInputStream
00615 //-------------------------------------------------------------------
00616
00617 HRESULT CGrayscale::DeleteInputStream(DWORD dwStreamID)
00618 {
00619     // This MFT has a fixed number of input streams, so the method is not supported.
00620     return E_NOTIMPL;
00621 }
00622
00623
00624 //-------------------------------------------------------------------
00625 // AddInputStreams
00626 //-------------------------------------------------------------------
00627
00628 HRESULT CGrayscale::AddInputStreams(
00629     DWORD   cStreams,
00630     DWORD   *adwStreamIDs
00631 )
00632 {
00633     // This MFT has a fixed number of output streams, so the method is not supported.
00634     return E_NOTIMPL;
00635 }
00636
00637
00638 //-------------------------------------------------------------------
00639 // GetInputAvailableType
00640 // Returns a preferred input type.
00641 //-------------------------------------------------------------------
00642
00643 HRESULT CGrayscale::GetInputAvailableType(
00644     DWORD           dwInputStreamID,
00645     DWORD           dwTypeIndex, // 0-based
00646     IMFMediaType    **ppType
00647 )
00648 {
00649     if (ppType == NULL)
00650     {
00651         return E_INVALIDARG;
00652     }
00653
00654     EnterCriticalSection(&m_critSec);
00655
00656     if (!IsValidInputStream(dwInputStreamID))
00657     {
00658         LeaveCriticalSection(&m_critSec);
00659         return MF_E_INVALIDSTREAMNUMBER;
00660     }
00661
00662     HRESULT hr = S_OK;
00663
00664     // If the output type is set, return that type as our preferred input type.
00665     if (m_pOutputType == NULL)
00666     {
00667         // The output type is not set. Create a partial media type.
00668         hr = OnGetPartialType(dwTypeIndex, ppType);
00669     }
00670     else if (dwTypeIndex > 0)
00671     {
00672         hr = MF_E_NO_MORE_TYPES;
00673     }
00674     else
00675     {
00676         *ppType = m_pOutputType;
00677         (*ppType)->AddRef();
00678     }
00679
00680     LeaveCriticalSection(&m_critSec);
00681     return hr;
00682 }
00683
00684
00685
00686 //-------------------------------------------------------------------
00687 // GetOutputAvailableType
00688 // Returns a preferred output type.
00689 //-------------------------------------------------------------------
00690
00691 HRESULT CGrayscale::GetOutputAvailableType(
00692     DWORD           dwOutputStreamID,
00693     DWORD           dwTypeIndex, // 0-based
00694     IMFMediaType    **ppType
00695 )
00696 {
00697     if (ppType == NULL)
00698     {
00699         return E_INVALIDARG;
00700     }
00701
00702     EnterCriticalSection(&m_critSec);
00703
00704     if (!IsValidOutputStream(dwOutputStreamID))
00705     {
00706         LeaveCriticalSection(&m_critSec);
00707         return MF_E_INVALIDSTREAMNUMBER;
00708     }
00709
00710     HRESULT hr = S_OK;
00711
00712     if (m_pInputType == NULL)
00713     {
00714         // The input type is not set. Create a partial media type.
00715         hr = OnGetPartialType(dwTypeIndex, ppType);
00716     }
00717     else if (dwTypeIndex > 0)
00718     {
00719         hr = MF_E_NO_MORE_TYPES;
00720     }
00721     else
00722     {
00723         *ppType = m_pInputType;
00724         (*ppType)->AddRef();
00725     }
00726
00727     LeaveCriticalSection(&m_critSec);
00728     return hr;
00729 }
00730
00731
00732 //-------------------------------------------------------------------
00733 // SetInputType
00734 //-------------------------------------------------------------------
00735
00736 HRESULT CGrayscale::SetInputType(
00737     DWORD           dwInputStreamID,
00738     IMFMediaType    *pType, // Can be NULL to clear the input type.
00739     DWORD           dwFlags
00740 )
00741 {
00742     // Validate flags.
00743     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00744     {
00745         return E_INVALIDARG;
00746     }
00747
00748     EnterCriticalSection(&m_critSec);
00749
00750     if (!IsValidInputStream(dwInputStreamID))
00751     {
00752         LeaveCriticalSection(&m_critSec);
00753         return MF_E_INVALIDSTREAMNUMBER;
00754     }
00755
00756     HRESULT hr = S_OK;
00757
00758     // Does the caller want us to set the type, or just test it?
00759     BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);
00760
00761     // If we have an input sample, the client cannot change the type now.
00762     if (HasPendingOutput())
00763     {
00764         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00765         goto done;
00766     }
00767
00768     // Validate the type, if non-NULL.
00769     if (pType)
00770     {
00771         hr = OnCheckInputType(pType);
00772         if (FAILED(hr))
00773         {
00774             goto done;
00775         }
00776     }
00777
00778     // The type is OK. Set the type, unless the caller was just testing.
00779     if (bReallySet)
00780     {
00781         OnSetInputType(pType);
00782
00783         // When the type changes, end streaming.
00784         hr = EndStreaming();
00785     }
00786
00787 done:
00788     LeaveCriticalSection(&m_critSec);
00789     return hr;
00790 }
00791
00792
00793
00794 //-------------------------------------------------------------------
00795 // SetOutputType
00796 //-------------------------------------------------------------------
00797
00798 HRESULT CGrayscale::SetOutputType(
00799     DWORD           dwOutputStreamID,
00800     IMFMediaType    *pType, // Can be NULL to clear the output type.
00801     DWORD           dwFlags
00802 )
00803 {
00804     // Validate flags.
00805     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00806     {
00807         return E_INVALIDARG;
00808     }
00809
00810     EnterCriticalSection(&m_critSec);
00811
00812     if (!IsValidOutputStream(dwOutputStreamID))
00813     {
00814         LeaveCriticalSection(&m_critSec);
00815         return MF_E_INVALIDSTREAMNUMBER;
00816     }
00817
00818     HRESULT hr = S_OK;
00819
00820     // Does the caller want us to set the type, or just test it?
00821     BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);
00822
00823     // If we have an input sample, the client cannot change the type now.
00824     if (HasPendingOutput())
00825     {
00826         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00827         goto done;
00828     }
00829
00830     // Validate the type, if non-NULL.
00831     if (pType)
00832     {
00833         hr = OnCheckOutputType(pType);
00834         if (FAILED(hr))
00835         {
00836             goto done;
00837         }
00838     }
00839
00840     // The type is OK. Set the type, unless the caller was just testing.
00841     if (bReallySet)
00842     {
00843         OnSetOutputType(pType);
00844
00845         // When the type changes, end streaming.
00846         hr = EndStreaming();
00847     }
00848
00849 done:
00850     LeaveCriticalSection(&m_critSec);
00851     return hr;
00852 }
00853
00854
00855 //-------------------------------------------------------------------
00856 // GetInputCurrentType
00857 // Returns the current input type.
00858 //-------------------------------------------------------------------
00859
00860 HRESULT CGrayscale::GetInputCurrentType(
00861     DWORD           dwInputStreamID,
00862     IMFMediaType    **ppType
00863 )
00864 {
00865     if (ppType == NULL)
00866     {
00867         return E_POINTER;
00868     }
00869
00870     HRESULT hr = S_OK;
00871
00872     EnterCriticalSection(&m_critSec);
00873
00874     if (!IsValidInputStream(dwInputStreamID))
00875     {
00876         hr = MF_E_INVALIDSTREAMNUMBER;
00877     }
00878     else if (!m_pInputType)
00879     {
00880         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00881     }
00882     else
00883     {
00884         *ppType = m_pInputType;
00885         (*ppType)->AddRef();
00886     }
00887     LeaveCriticalSection(&m_critSec);
00888     return hr;
00889 }
00890
00891
00892 //-------------------------------------------------------------------
00893 // GetOutputCurrentType
00894 // Returns the current output type.
00895 //-------------------------------------------------------------------
00896
00897 HRESULT CGrayscale::GetOutputCurrentType(
00898     DWORD           dwOutputStreamID,
00899     IMFMediaType    **ppType
00900 )
00901 {
00902     if (ppType == NULL)
00903     {
00904         return E_POINTER;
00905     }
00906
00907     HRESULT hr = S_OK;
00908
00909     EnterCriticalSection(&m_critSec);
00910
00911     if (!IsValidOutputStream(dwOutputStreamID))
00912     {
00913         hr = MF_E_INVALIDSTREAMNUMBER;
00914     }
00915     else if (!m_pOutputType)
00916     {
00917         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00918     }
00919     else
00920     {
00921         *ppType = m_pOutputType;
00922         (*ppType)->AddRef();
00923     }
00924
00925     LeaveCriticalSection(&m_critSec);
00926     return hr;
00927 }
00928
00929
00930 //-------------------------------------------------------------------
00931 // GetInputStatus
00932 // Query if the MFT is accepting more input.
00933 //-------------------------------------------------------------------
00934
00935 HRESULT CGrayscale::GetInputStatus(
00936     DWORD           dwInputStreamID,
00937     DWORD           *pdwFlags
00938 )
00939 {
00940     if (pdwFlags == NULL)
00941     {
00942         return E_POINTER;
00943     }
00944
00945     EnterCriticalSection(&m_critSec);
00946
00947     if (!IsValidInputStream(dwInputStreamID))
00948     {
00949         LeaveCriticalSection(&m_critSec);
00950         return MF_E_INVALIDSTREAMNUMBER;
00951     }
00952
00953     // If an input sample is already queued, do not accept another sample until the
00954     // client calls ProcessOutput or Flush.
00955
00956     // NOTE: It is possible for an MFT to accept more than one input sample. For
00957     // example, this might be required in a video decoder if the frames do not
00958     // arrive in temporal order. In the case, the decoder must hold a queue of
00959     // samples. For the video effect, each sample is transformed independently, so
00960     // there is no reason to queue multiple input samples.
00961
00962     if (m_pSample == NULL)
00963     {
00964         *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
00965     }
00966     else
00967     {
00968         *pdwFlags = 0;
00969     }
00970
00971     LeaveCriticalSection(&m_critSec);
00972     return S_OK;
00973 }
00974
00975
00976
00977 //-------------------------------------------------------------------
00978 // GetOutputStatus
00979 // Query if the MFT can produce output.
00980 //-------------------------------------------------------------------
00981
00982 HRESULT CGrayscale::GetOutputStatus(DWORD *pdwFlags)
00983 {
00984     if (pdwFlags == NULL)
00985     {
00986         return E_POINTER;
00987     }
00988
00989     EnterCriticalSection(&m_critSec);
00990
00991     // The MFT can produce an output sample if (and only if) there an input sample.
00992     if (m_pSample != NULL)
00993     {
00994         *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
00995     }
00996     else
00997     {
00998         *pdwFlags = 0;
00999     }
01000
01001     LeaveCriticalSection(&m_critSec);
01002     return S_OK;
01003 }
01004
01005
01006 //-------------------------------------------------------------------
01007 // SetOutputBounds
01008 // Sets the range of time stamps that the MFT will output.
01009 //-------------------------------------------------------------------
01010
01011 HRESULT CGrayscale::SetOutputBounds(
01012     LONGLONG        hnsLowerBound,
01013     LONGLONG        hnsUpperBound
01014 )
01015 {
01016     // Implementation of this method is optional.
01017     return E_NOTIMPL;
01018 }
01019
01020
01021 //-------------------------------------------------------------------
01022 // ProcessEvent
01023 // Sends an event to an input stream.
01024 //-------------------------------------------------------------------
01025
01026 HRESULT CGrayscale::ProcessEvent(
01027     DWORD              dwInputStreamID,
01028     IMFMediaEvent      *pEvent
01029 )
01030 {
01031     // This MFT does not handle any stream events, so the method can
01032     // return E_NOTIMPL. This tells the pipeline that it can stop
01033     // sending any more events to this MFT.
01034     return E_NOTIMPL;
01035 }
01036
01037
01038 //-------------------------------------------------------------------
01039 // ProcessMessage
01040 //-------------------------------------------------------------------
01041
01042 HRESULT CGrayscale::ProcessMessage(
01043     MFT_MESSAGE_TYPE    eMessage,
01044     ULONG_PTR           ulParam
01045 )
01046 {
01047     EnterCriticalSection(&m_critSec);
01048
01049     HRESULT hr = S_OK;
01050
01051     switch (eMessage)
01052     {
01053     case MFT_MESSAGE_COMMAND_FLUSH:
01054         // Flush the MFT.
01055         hr = OnFlush();
01056         break;
01057
01058     case MFT_MESSAGE_COMMAND_DRAIN:
01059         // Drain: Tells the MFT to reject further input until all pending samples are
01060         // processed. That is our default behavior already, so there is nothing to do.
01061         //
01062         // For a decoder that accepts a queue of samples, the MFT might need to drain
01063         // the queue in response to this command.
01064     break;
01065
01066     case MFT_MESSAGE_SET_D3D_MANAGER:
01067         // Sets a pointer to the IDirect3DDeviceManager9 interface.
01068
01069         // The pipeline should never send this message unless the MFT sets the MF_SA_D3D_AWARE
01070         // attribute set to TRUE. Because this MFT does not set MF_SA_D3D_AWARE, it is an error
01071         // to send the MFT_MESSAGE_SET_D3D_MANAGER message to the MFT. Return an error code in
01072         // this case.
01073
01074         // NOTE: If this MFT were D3D-enabled, it would cache the IDirect3DDeviceManager9
01075         // pointer for use during streaming.
01076
01077         hr = E_NOTIMPL;
01078         break;
01079
01080     case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
01081         hr = BeginStreaming();
01082         break;
01083
01084     case MFT_MESSAGE_NOTIFY_END_STREAMING:
01085         hr = EndStreaming();
01086         break;
01087
01088     // The next two messages do not require any action from this MFT.
01089
01090     case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
01091         break;
01092
01093     case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
01094         break;
01095     }
01096
01097     LeaveCriticalSection(&m_critSec);
01098     return hr;
01099 }
01100
01101
01102 //-------------------------------------------------------------------
01103 // ProcessInput
01104 // Process an input sample.
01105 //-------------------------------------------------------------------
01106
01107 HRESULT CGrayscale::ProcessInput(
01108     DWORD               dwInputStreamID,
01109     IMFSample           *pSample,
01110     DWORD               dwFlags
01111 )
01112 {
01113     // Check input parameters.
01114     if (pSample == NULL)
01115     {
01116         return E_POINTER;
01117     }
01118
01119     if (dwFlags != 0)
01120     {
01121         return E_INVALIDARG; // dwFlags is reserved and must be zero.
01122     }
01123
01124     HRESULT hr = S_OK;
01125
01126     EnterCriticalSection(&m_critSec);
01127
01128     // Validate the input stream number.
01129     if (!IsValidInputStream(dwInputStreamID))
01130     {
01131         hr = MF_E_INVALIDSTREAMNUMBER;
01132         goto done;
01133     }
01134
01135     // Check for valid media types.
01136     // The client must set input and output types before calling ProcessInput.
01137     if (!m_pInputType || !m_pOutputType)
01138     {
01139         hr = MF_E_NOTACCEPTING;
01140         goto done;
01141     }
01142
01143     // Check if an input sample is already queued.
01144     if (m_pSample != NULL)
01145     {
01146         hr = MF_E_NOTACCEPTING;   // We already have an input sample.
01147         goto done;
01148     }
01149
01150     // Initialize streaming.
01151     hr = BeginStreaming();
01152     if (FAILED(hr))
01153     {
01154         goto done;
01155     }
01156
01157     // Cache the sample. We do the actual work in ProcessOutput.
01158     m_pSample = pSample;
01159     pSample->AddRef();  // Hold a reference count on the sample.
01160
01161 done:
01162     LeaveCriticalSection(&m_critSec);
01163     return hr;
01164 }
01165
01166
01167 //-------------------------------------------------------------------
01168 // ProcessOutput
01169 // Process an output sample.
01170 //-------------------------------------------------------------------
01171
01172 HRESULT CGrayscale::ProcessOutput(
01173     DWORD                   dwFlags,
01174     DWORD                   cOutputBufferCount,
01175     MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
01176     DWORD                   *pdwStatus
01177 )
01178 {
01179     // Check input parameters...
01180
01181     // This MFT does not accept any flags for the dwFlags parameter.
01182
01183     // The only defined flag is MFT_PROCESS_OUTPUT_DISCARD_WHEN_NO_BUFFER. This flag
01184     // applies only when the MFT marks an output stream as lazy or optional. But this
01185     // MFT has no lazy or optional streams, so the flag is not valid.
01186
01187     if (dwFlags != 0)
01188     {
01189         return E_INVALIDARG;
01190     }
01191
01192     if (pOutputSamples == NULL || pdwStatus == NULL)
01193     {
01194         return E_POINTER;
01195     }
01196
01197     // There must be exactly one output buffer.
01198     if (cOutputBufferCount != 1)
01199     {
01200         return E_INVALIDARG;
01201     }
01202
01203     // It must contain a sample.
01204     if (pOutputSamples[0].pSample == NULL)
01205     {
01206         return E_INVALIDARG;
01207     }
01208
01209     HRESULT hr = S_OK;
01210
01211     IMFMediaBuffer *pInput = NULL;
01212     IMFMediaBuffer *pOutput = NULL;
01213
01214     EnterCriticalSection(&m_critSec);
01215
01216     // There must be an input sample available for processing.
01217     if (m_pSample == NULL)
01218     {
01219         hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
01220         goto done;
01221     }
01222
01223     // Initialize streaming.
01224
01225     hr = BeginStreaming();
01226     if (FAILED(hr))
01227     {
01228         goto done;
01229     }
01230
01231     // Get the input buffer.
01232     hr = m_pSample->ConvertToContiguousBuffer(&pInput);
01233     if (FAILED(hr))
01234     {
01235         goto done;
01236     }
01237
01238     // Get the output buffer.
01239     hr = pOutputSamples[0].pSample->ConvertToContiguousBuffer(&pOutput);
01240     if (FAILED(hr))
01241     {
01242         goto done;
01243     }
01244
01245     hr = OnProcessOutput(pInput, pOutput);
01246     if (FAILED(hr))
01247     {
01248         goto done;
01249     }
01250
01251     // Set status flags.
01252     pOutputSamples[0].dwStatus = 0;
01253     *pdwStatus = 0;
01254
01255
01256     // Copy the duration and time stamp from the input sample, if present.
01257
01258     LONGLONG hnsDuration = 0;
01259     LONGLONG hnsTime = 0;
01260
01261     if (SUCCEEDED(m_pSample->GetSampleDuration(&hnsDuration)))
01262     {
01263         hr = pOutputSamples[0].pSample->SetSampleDuration(hnsDuration);
01264         if (FAILED(hr))
01265         {
01266             goto done;
01267         }
01268     }
01269
01270     if (SUCCEEDED(m_pSample->GetSampleTime(&hnsTime)))
01271     {
01272         hr = pOutputSamples[0].pSample->SetSampleTime(hnsTime);
01273     }
01274
01275 done:
01276     SafeRelease(&m_pSample);   // Release our input sample.
01277     SafeRelease(&pInput);
01278     SafeRelease(&pOutput);
01279     LeaveCriticalSection(&m_critSec);
01280     return hr;
01281 }
01282
01283 // PRIVATE METHODS
01284
01285 // All methods that follow are private to this MFT and are not part of the IMFTransform interface.
01286
01287 // Create a partial media type from our list.
01288 //
01289 // dwTypeIndex: Index into the list of peferred media types.
01290 // ppmt:        Receives a pointer to the media type.
01291
01292 HRESULT CGrayscale::OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt)
01293 {
01294     if (dwTypeIndex >= ARRAYSIZE(g_MediaSubtypes))
01295     {
01296         return MF_E_NO_MORE_TYPES;
01297     }
01298
01299     IMFMediaType *pmt = NULL;
01300
01301     HRESULT hr = MFCreateMediaType(&pmt);
01302     if (FAILED(hr))
01303     {
01304         goto done;
01305     }
01306
01307     hr = pmt->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
01308     if (FAILED(hr))
01309     {
01310         goto done;
01311     }
01312
01313     hr = pmt->SetGUID(MF_MT_SUBTYPE, g_MediaSubtypes[dwTypeIndex]);
01314     if (FAILED(hr))
01315     {
01316         goto done;
01317     }
01318
01319     *ppmt = pmt;
01320     (*ppmt)->AddRef();
01321
01322 done:
01323     SafeRelease(&pmt);
01324     return hr;
01325 }
01326
01327
01328 // Validate an input media type.
01329
01330 HRESULT CGrayscale::OnCheckInputType(IMFMediaType *pmt)
01331 {
01332     assert(pmt != NULL);
01333
01334     HRESULT hr = S_OK;
01335
01336     // If the output type is set, see if they match.
01337     if (m_pOutputType != NULL)
01338     {
01339         DWORD flags = 0;
01340         hr = pmt->IsEqual(m_pOutputType, &flags);
01341
01342         // IsEqual can return S_FALSE. Treat this as failure.
01343         if (hr != S_OK)
01344         {
01345             hr = MF_E_INVALIDMEDIATYPE;
01346         }
01347     }
01348     else
01349     {
01350         // Output type is not set. Just check this type.
01351         hr = OnCheckMediaType(pmt);
01352     }
01353     return hr;
01354 }
01355
01356
01357 // Validate an output media type.
01358
01359 HRESULT CGrayscale::OnCheckOutputType(IMFMediaType *pmt)
01360 {
01361     assert(pmt != NULL);
01362
01363     HRESULT hr = S_OK;
01364
01365     // If the input type is set, see if they match.
01366     if (m_pInputType != NULL)
01367     {
01368         DWORD flags = 0;
01369         hr = pmt->IsEqual(m_pInputType, &flags);
01370
01371         // IsEqual can return S_FALSE. Treat this as failure.
01372         if (hr != S_OK)
01373         {
01374             hr = MF_E_INVALIDMEDIATYPE;
01375         }
01376
01377     }
01378     else
01379     {
01380         // Input type is not set. Just check this type.
01381         hr = OnCheckMediaType(pmt);
01382     }
01383     return hr;
01384 }
01385
01386
01387 // Validate a media type (input or output)
01388
01389 HRESULT CGrayscale::OnCheckMediaType(IMFMediaType *pmt)
01390 {
01391     BOOL bFoundMatchingSubtype = FALSE;
01392
01393     // Major type must be video.
01394     GUID major_type;
01395     HRESULT hr = pmt->GetGUID(MF_MT_MAJOR_TYPE, &major_type);
01396     if (FAILED(hr))
01397     {
01398         goto done;
01399     }
01400
01401     if (major_type != MFMediaType_Video)
01402     {
01403         hr = MF_E_INVALIDMEDIATYPE;
01404         goto done;
01405     }
01406
01407     // Subtype must be one of the subtypes in our global list.
01408
01409     // Get the subtype GUID.
01410     GUID subtype;
01411     hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
01412     if (FAILED(hr))
01413     {
01414         goto done;
01415     }
01416
01417     // Look for the subtype in our list of accepted types.
01418     for (DWORD i = 0; i < ARRAYSIZE(g_MediaSubtypes); i++)
01419     {
01420         if (subtype == g_MediaSubtypes[i])
01421         {
01422             bFoundMatchingSubtype = TRUE;
01423             break;
01424         }
01425     }
01426
01427     if (!bFoundMatchingSubtype)
01428     {
01429         hr = MF_E_INVALIDMEDIATYPE; // The MFT does not support this subtype.
01430         goto done;
01431     }
01432
01433     // Reject single-field media types.
01434     UINT32 interlace = MFGetAttributeUINT32(pmt, MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
01435     if (interlace == MFVideoInterlace_FieldSingleUpper  || interlace == MFVideoInterlace_FieldSingleLower)
01436     {
01437         hr = MF_E_INVALIDMEDIATYPE;
01438     }
01439
01440 done:
01441     return hr;
01442 }
01443
01444
01445 // Set or clear the input media type.
01446 //
01447 // Prerequisite: The input type was already validated.
01448
01449 void CGrayscale::OnSetInputType(IMFMediaType *pmt)
01450 {
01451     // if pmt is NULL, clear the type.
01452     // if pmt is non-NULL, set the type.
01453
01454     SafeRelease(&m_pInputType);
01455     m_pInputType = pmt;
01456     if (m_pInputType)
01457     {
01458         m_pInputType->AddRef();
01459     }
01460
01461     // Update the format information.
01462     UpdateFormatInfo();
01463 }
01464
01465
01466 // Set or clears the output media type.
01467 //
01468 // Prerequisite: The output type was already validated.
01469
01470 void CGrayscale::OnSetOutputType(IMFMediaType *pmt)
01471 {
01472     // If pmt is NULL, clear the type. Otherwise, set the type.
01473
01474     SafeRelease(&m_pOutputType);
01475     m_pOutputType = pmt;
01476     if (m_pOutputType)
01477     {
01478         m_pOutputType->AddRef();
01479     }
01480 }
01481
01482
01483 // Initialize streaming parameters.
01484 //
01485 // This method is called if the client sends the MFT_MESSAGE_NOTIFY_BEGIN_STREAMING
01486 // message, or when the client processes a sample, whichever happens first.
01487
01488 HRESULT CGrayscale::BeginStreaming()
01489 {
01490     HRESULT hr = S_OK;
01491
01492     if (!m_bStreamingInitialized)
01493     {
01494         // Get the configuration attributes.
01495
01496         // Get the destination rectangle.
01497
01498         RECT rcDest;
01499         hr = m_pAttributes->GetBlob(MFT_GRAYSCALE_DESTINATION_RECT, (UINT8*)&rcDest, sizeof(rcDest), NULL);
01500         if (hr == MF_E_ATTRIBUTENOTFOUND || !ValidateRect(rcDest))
01501         {
01502             // The client did not set this attribute, or the client provided an invalid rectangle.
01503             // Default to the entire image.
01504
01505             m_rcDest = D2D1::RectU(0, 0, m_imageWidthInPixels, m_imageHeightInPixels);
01506             hr = S_OK;
01507         }
01508         else if (SUCCEEDED(hr))
01509         {
01510             m_rcDest = D2D1::RectU(rcDest.left, rcDest.top, rcDest.right, rcDest.bottom);
01511         }
01512         else
01513         {
01514             goto done;
01515         }
01516
01517         // Get the chroma transformations.
01518
01519         float scale = (float)MFGetAttributeDouble(m_pAttributes, MFT_GRAYSCALE_SATURATION, 0.0f);
01520         float angle = (float)MFGetAttributeDouble(m_pAttributes, MFT_GRAYSCALE_CHROMA_ROTATION, 0.0f);
01521
01522         m_transform = D2D1::Matrix3x2F::Scale(scale, scale) * D2D1::Matrix3x2F::Rotation(angle);
01523
01524         m_bStreamingInitialized = true;
01525     }
01526
01527 done:
01528     return hr;
01529 }
01530
01531
01532 // End streaming.
01533
01534 // This method is called if the client sends an MFT_MESSAGE_NOTIFY_END_STREAMING
01535 // message, or when the media type changes. In general, it should be called whenever
01536 // the streaming parameters need to be reset.
01537
01538 HRESULT CGrayscale::EndStreaming()
01539 {
01540     m_bStreamingInitialized = false;
01541     return S_OK;
01542 }
01543
01544
01545
01546 // Generate output data.
01547
01548 HRESULT CGrayscale::OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
01549 {
01550     BYTE *pDest = NULL;         // Destination buffer.
01551     LONG lDestStride = 0;       // Destination stride.
01552
01553     BYTE *pSrc = NULL;          // Source buffer.
01554     LONG lSrcStride = 0;        // Source stride.
01555
01556     // Helper objects to lock the buffers.
01557     VideoBufferLock inputLock(pIn);
01558     VideoBufferLock outputLock(pOut);
01559
01560     // Stride if the buffer does not support IMF2DBuffer
01561     LONG lDefaultStride = 0;
01562
01563     HRESULT hr = GetDefaultStride(m_pInputType, &lDefaultStride);
01564     if (FAILED(hr))
01565     {
01566         goto done;
01567     }
01568
01569     // Lock the input buffer.
01570     hr = inputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pSrc, &lSrcStride);
01571     if (FAILED(hr))
01572     {
01573         goto done;
01574     }
01575
01576     // Lock the output buffer.
01577     hr = outputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pDest, &lDestStride);
01578     if (FAILED(hr))
01579     {
01580         goto done;
01581     }
01582
01583     // Invoke the image transform function.
01584     assert (m_pTransformFn != NULL);
01585     if (m_pTransformFn)
01586     {
01587         (*m_pTransformFn)(m_transform, m_rcDest, pDest, lDestStride, pSrc, lSrcStride,
01588             m_imageWidthInPixels, m_imageHeightInPixels);
01589     }
01590     else
01591     {
01592         hr = E_UNEXPECTED;
01593         goto done;
01594     }
01595
01596
01597     // Set the data size on the output buffer.
01598     hr = pOut->SetCurrentLength(m_cbImageSize);
01599
01600     // The VideoBufferLock class automatically unlocks the buffers.
01601 done:
01602     return hr;
01603 }
01604
01605
01606 // Flush the MFT.
01607
01608 HRESULT CGrayscale::OnFlush()
01609 {
01610     // For this MFT, flushing just means releasing the input sample.
01611     SafeRelease(&m_pSample);
01612     return S_OK;
01613 }
01614
01615
01616 // Update the format information. This method is called whenever the
01617 // input type is set.
01618
01619 HRESULT CGrayscale::UpdateFormatInfo()
01620 {
01621     HRESULT hr = S_OK;
01622
01623     GUID subtype = GUID_NULL;
01624
01625     m_imageWidthInPixels = 0;
01626     m_imageHeightInPixels = 0;
01627     m_cbImageSize = 0;
01628
01629     m_pTransformFn = NULL;
01630
01631     if (m_pInputType != NULL)
01632     {
01633         hr = m_pInputType->GetGUID(MF_MT_SUBTYPE, &subtype);
01634         if (FAILED(hr))
01635         {
01636             goto done;
01637         }
01638         if (subtype == MFVideoFormat_YUY2)
01639         {
01640             m_pTransformFn = TransformImage_YUY2;
01641         }
01642         else if (subtype == MFVideoFormat_UYVY)
01643         {
01644             m_pTransformFn = TransformImage_UYVY;
01645         }
01646         else if (subtype == MFVideoFormat_NV12)
01647         {
01648             m_pTransformFn = TransformImage_NV12;
01649         }
01650         else
01651         {
01652             hr = E_UNEXPECTED;
01653             goto done;
01654         }
01655
01656         hr = MFGetAttributeSize(m_pInputType, MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);
01657         if (FAILED(hr))
01658         {
01659             goto done;
01660         }
01661
01662         // Calculate the image size (not including padding)
01663         hr = GetImageSize(subtype.Data1, m_imageWidthInPixels, m_imageHeightInPixels, &m_cbImageSize);
01664     }
01665
01666 done:
01667     return hr;
01668 }
01669
01670
01671 // Calculate the size of the buffer needed to store the image.
01672
01673 // fcc: The FOURCC code of the video format.
01674
01675 HRESULT GetImageSize(DWORD fcc, UINT32 width, UINT32 height, DWORD* pcbImage)
01676 {
01677     HRESULT hr = S_OK;
01678
01679     switch (fcc)
01680     {
01681     case FOURCC_YUY2:
01682     case FOURCC_UYVY:
01683         // check overflow
01684         if ((width > MAXDWORD / 2) || (width * 2 > MAXDWORD / height))
01685         {
01686             hr = E_INVALIDARG;
01687         }
01688         else
01689         {
01690             // 16 bpp
01691             *pcbImage = width * height * 2;
01692         }
01693         break;
01694
01695     case FOURCC_NV12:
01696         // check overflow
01697         if ((height/2 > MAXDWORD - height) || ((height + height/2) > MAXDWORD / width))
01698         {
01699             hr = E_INVALIDARG;
01700         }
01701         else
01702         {
01703             // 12 bpp
01704             *pcbImage = width * (height + (height/2));
01705         }
01706         break;
01707
01708     default:
01709         hr = E_FAIL;    // Unsupported type.
01710     }
01711     return hr;
01712 }
01713
01714 // Get the default stride for a video format.
01715 HRESULT GetDefaultStride(IMFMediaType *pType, LONG *plStride)
01716 {
01717     LONG lStride = 0;
01718
01719     // Try to get the default stride from the media type.
01720     HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
01721     if (FAILED(hr))
01722     {
01723         // Attribute not set. Try to calculate the default stride.
01724         GUID subtype = GUID_NULL;
01725
01726         UINT32 width = 0;
01727         UINT32 height = 0;
01728
01729         // Get the subtype and the image size.
01730         hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
01731         if (SUCCEEDED(hr))
01732         {
01733             hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
01734         }
01735         if (SUCCEEDED(hr))
01736         {
01737             if (subtype == MFVideoFormat_NV12)
01738             {
01739                 lStride = width;
01740             }
01741             else if (subtype == MFVideoFormat_YUY2 || subtype == MFVideoFormat_UYVY)
01742             {
01743                 lStride = ((width * 2) + 3) & ~3;
01744             }
01745             else
01746             {
01747                 hr = E_INVALIDARG;
01748             }
01749         }
01750
01751         // Set the attribute for later reference.
01752         if (SUCCEEDED(hr))
01753         {
01754             (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
01755         }
01756     }
01757     if (SUCCEEDED(hr))
01758     {
01759         *plStride = lStride;
01760     }
01761     return hr;
01762 }
01763
01764
01765 // Validate that a rectangle meets the following criteria:
01766 //
01767 //  - All coordinates are non-negative.
01768 //  - The rectangle is not flipped (top > bottom, left > right)
01769 //
01770 // These are the requirements for the destination rectangle.
01771
01772 bool ValidateRect(const RECT& rc)
01773 {
01774     if (rc.left < 0 || rc.top < 0)
01775     {
01776         return false;
01777     }
01778     if (rc.left > rc.right || rc.top > rc.bottom)
01779     {
01780         return false;
01781     }
01782     return true;
01783 }
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/VideoChat.xaml.h Source File

  • Real-time communication

VideoChat.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // VideoChat.xaml.h
00013 // Declaration of the VideoChat class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Utils.h"
00020 #include "VideoChat.g.h"
00021 #include "MainPage.xaml.h"
00022
00023 //#include "Utils.h"
00024
00025 namespace SimpleCommunication
00026 {
00027     /// <summary>
00028     /// An empty page that can be used on its own or navigated to within a Frame.
00029     /// </summary>
00030   [Windows::Foundation::Metadata::WebHostHidden]
00031     public ref class VideoChat sealed
00032     {
00033     public:
00034         VideoChat();
00035
00036     protected:
00037         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038         virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00039         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00040
00041     private:
00042         MainPage^ _rootPage;
00043         void CallButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044         void EndCallButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045
00046         task<void> Initialize();
00047         task<void> OnInitializeCompleted(Windows::Foundation::HResult hr);
00048         void OnInitializeCompletedDispatchedHandler();
00049         task<void> Deactivate();
00050         task<void> CleanUp();
00051         task<void> StartRecordingToCustomSinkAsync();
00052         task<void> EndCall();
00053         ~VideoChat();
00054
00055         Windows::Foundation::EventRegistrationToken _incomingConnectionEventRegistrationToken;
00056         Windows::Foundation::EventRegistrationToken _mediaCaptureFailedEventRegistrationToken;
00057         Windows::Foundation::EventRegistrationToken _mediaElementFailedEventRegistrationToken;
00058         void OnIncomingConnection(Microsoft::Samples::SimpleCommunication::StspMediaSink^ sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ args);
00059         void OnMediaCaptureFailed(CaptureDevice^ sender, CaptureFailedEventArgs^ errorEventArgs);
00060         void VideoPlaybackErrorHandler(Platform::Object^ sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^ e);
00061
00062         bool _isTerminator;
00063         bool _initialization;
00064         CaptureDevice^ _device;
00065         bool _active;
00066
00067         enum class Role
00068         {
00069             uninitialized,
00070             active,
00071             passive,
00072         };
00073         Role _role;
00074
00075         SdkSample _sdkSample;
00076         Windows::UI::Core::CoreDispatcher^ _dispatcher;
00077     };
00078 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareDelayRenderedFiles.xaml.cpp Source File

  • Sharing content source app

ShareDelayRenderedFiles.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ShareDelayRenderedFiles.xaml.cpp
00013 // Implementation of the ShareDelayRenderedFiles class
00014 //
00015
00016 #include "pch.h"
00017 #include "ShareDelayRenderedFiles.xaml.h"
00018
00019 using namespace SDKSample::ShareSource;
00020 using namespace SDKSample::Common;
00021
00022 using namespace concurrency;
00023 using namespace Platform;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Graphics::Imaging;
00026 using namespace Windows::Storage;
00027 using namespace Windows::Storage::Streams;
00028 using namespace Windows::Storage::Pickers;
00029 using namespace Windows::UI::Xaml;
00030 using namespace Windows::UI::Xaml::Media::Imaging;
00031 using namespace Windows::ApplicationModel::DataTransfer;
00032
00033 ShareDelayRenderedFiles::ShareDelayRenderedFiles()
00034 {
00035     InitializeComponent();
00036
00037     // Get a pointer to our main page.
00038     rootPage = MainPage::Current;
00039 }
00040
00041 bool ShareDelayRenderedFiles::GetShareContent(DataRequest^ request)
00042 {
00043     bool succeeded = false;
00044
00045     if (imageFile != nullptr)
00046     {
00047         auto requestData = request->Data;
00048         requestData->Properties->Title = "Delay rendered image";
00049         requestData->Properties->Description = "Resized image from the Share Source sample";
00050         requestData->Properties->Thumbnail = RandomAccessStreamReference::CreateFromFile(imageFile);
00051         requestData->SetDataProvider(StandardDataFormats::Bitmap, ref new DataProviderHandler(this, &ShareDelayRenderedFiles::OnDeferredImageRequestedHandler));
00052         succeeded = true;
00053     }
00054     else
00055     {
00056         request->FailWithDisplayText("Select an image you would like to share and try again.");
00057     }
00058     return succeeded;
00059 }
00060
00061 void ShareDelayRenderedFiles::OnDeferredImageRequestedHandler(DataProviderRequest^ request)
00062 {
00063     // In this delegate we provide updated Bitmap data using delayed rendering.
00064
00065     if (imageFile != nullptr)
00066     {
00067         // If the delegate is calling any asynchronous operations it needs to acquire the deferral first. This lets the
00068         // system know that you are performing some operations that might take a little longer and that the call to
00069         // SetData could happen after the delegate returns. Once you acquired the deferral object you must call Complete
00070         // on it after your final call to SetData.
00071         auto deferral = request->GetDeferral();
00072         auto inMemoryStream = ref new InMemoryRandomAccessStream();
00073
00074         // Use a reference-counted pointer to store the requested dimensions across function calls.
00075         std::shared_ptr<Size> newSize(new Size);
00076
00077         create_task(imageFile->OpenAsync(FileAccessMode::Read)).then(
00078             [this](IRandomAccessStream^ stream) -> IAsyncOperation<BitmapDecoder^>^
00079         {
00080             return BitmapDecoder::CreateAsync(stream);
00081         }).then([this, inMemoryStream, newSize](BitmapDecoder^ imageDecoder) -> IAsyncOperation<BitmapEncoder^>^
00082         {
00083             newSize.get()->Height = imageDecoder->OrientedPixelHeight * 0.5f;
00084             newSize.get()->Width = imageDecoder->OrientedPixelWidth * 0.5f;
00085             return BitmapEncoder::CreateForTranscodingAsync(inMemoryStream, imageDecoder);
00086         }).then([this, newSize](BitmapEncoder^ imageEncoder) -> IAsyncAction^
00087         {
00088             imageEncoder->BitmapTransform->ScaledWidth = safe_cast<unsigned int>(newSize.get()->Width);
00089             imageEncoder->BitmapTransform->ScaledHeight = safe_cast<unsigned int>(newSize.get()->Height);
00090             return imageEncoder->FlushAsync();
00091         }).then([this, deferral, request, inMemoryStream](task<void> newTask)
00092         {
00093             // Forces any exceptions from previous operations to get thrown here.
00094             // That way, we can ensure that the deferral completed method always gets called.
00095             try
00096             {
00097                 newTask.get();
00098                 request->SetData(RandomAccessStreamReference::CreateFromStream(inMemoryStream));
00099             }
00100             catch (Exception^)
00101             {
00102                 deferral->Complete();
00103                 throw;
00104             }
00105
00106             // If the operation completed successfully, end the deferral.
00107             deferral->Complete();
00108         });
00109     }
00110 }
00111
00112 void ShareDelayRenderedFiles::SelectImageButton_Click(Object^ sender, RoutedEventArgs^ e)
00113 {
00114     if (rootPage->EnsureUnsnapped())
00115     {
00116         auto imagePicker = ref new FileOpenPicker();
00117         imagePicker->ViewMode = PickerViewMode::Thumbnail;
00118         imagePicker->SuggestedStartLocation = PickerLocationId::PicturesLibrary;
00119         imagePicker->FileTypeFilter->Append(".jpg");
00120         imagePicker->FileTypeFilter->Append(".png");
00121         imagePicker->FileTypeFilter->Append(".bmp");
00122         imagePicker->FileTypeFilter->Append(".gif");
00123         imagePicker->FileTypeFilter->Append(".tif");
00124
00125         create_task(imagePicker->PickSingleFileAsync()).then([this](StorageFile^ pickedFile)
00126         {
00127             if (pickedFile != nullptr)
00128             {
00129                 imageFile = pickedFile;
00130
00131                 // Display the image in the UI.
00132                 create_task(pickedFile->OpenAsync(FileAccessMode::Read)).then([this](IRandomAccessStream^ displayStream)
00133                 {
00134                     auto bitmapImage = ref new BitmapImage();
00135                     bitmapImage->SetSource(displayStream);
00136                     ImageHolder->Source = bitmapImage;
00137                 });
00138                 rootPage->NotifyUser("Selected " + imageFile->Name +".", NotifyType::StatusMessage);
00139
00140                 ShareStep->Visibility = Windows::UI::Xaml::Visibility::Visible;
00141             }
00142         });
00143     }
00144 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/common/LayoutAwarePage.h Source File

  • Input Device capabilities
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ContinuationPage.xaml.h Source File

  • Print

ContinuationPage.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ContinuationPage.xaml.h
00010 // Declaration of the ContinuationPage class
00011 //
00012
00013 #pragma once
00014
00015 #include "ContinuationPage.g.h"
00016
00017 namespace PrintSample
00018 {
00019     /// <summary>
00020     /// A paged used to flow text from a given text container
00021     /// Usage: Outputscenarios 1-5 might not fit entirely on a given "printer page"
00022     /// In that case simply add new continuation pages of the given size until all the content can be displayed
00023     /// </summary>
00024     [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class ContinuationPage sealed
00026     {
00027     public:
00028         ContinuationPage();
00029
00030         /// <summary>
00031         /// Creates a continuation page and links text-flow to a text flow container
00032         /// </summary>
00033         /// <param name="textLinkContainer">Text link container which will flow text into this page</param>
00034         ContinuationPage(Windows::UI::Xaml::Controls::RichTextBlockOverflow^ textLinkContainer);
00035
00036     protected:
00037         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038     };
00039 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario2.xaml.cpp Source File

  • XAML animation library

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::Animation;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario2::Scenario2()
00026 {
00027     InitializeComponent();
00028   isScenario2StoryboardRunning = false;
00029
00030   // Add click event handler to toggle button
00031   Scenario2ToggleStoryboard->Click += ref new RoutedEventHandler(this, &Scenario2::Scenario2ToggleStoryboard_Click);
00032
00033 }
00034
00035
00036 // Invoked when this page is about to be displayed in a Frame.
00037 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042 }
00043
00044
00045 // Handler for button that toggles the scenario
00046 void SDKSample::Animation::Scenario2::Scenario2ToggleStoryboard_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00047 {
00048   // Toggle the storyboards to stop or begin them depending on the current state
00049   if (isScenario2StoryboardRunning)
00050   {
00051       ToggleScenario2(false);
00052   }
00053   else
00054   {
00055       ToggleScenario2(true);
00056   }
00057 }
00058
00059
00060 // Toggle the scenario
00061 void SDKSample::Animation::Scenario2::ToggleScenario2(bool startScenario)
00062 {
00063   if (!startScenario)
00064   {
00065       // Stop the storyboards
00066       Scenario2ContinuousStoryboard->Stop();
00067       Scenario2KeyFrameStoryboard->Stop();
00068       Scenario2ToggleStoryboard->Content = "Begin storyboards";
00069   }
00070   else
00071   {
00072       // Start the storyboards
00073       Scenario2ContinuousStoryboard->Begin();
00074       Scenario2KeyFrameStoryboard->Begin();
00075       Scenario2ToggleStoryboard->Content = "Stop storyboards";
00076   }
00077   isScenario2StoryboardRunning = startScenario;
00078 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/FileSystemRepository.h Source File

  • Hilo C++
  • Hilo

FileSystemRepository.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "Repository.h"
00010
00011 namespace Hilo
00012 {
00013     class ExceptionPolicy;
00014     ref class QueryChange;
00015
00016     // The FileSystemRepository class queries the user's picture library for images.
00017     // See http://go.microsoft.com/fwlink/?LinkId=267277 for more info about this class.
00018     class FileSystemRepository : public Repository, public std::enable_shared_from_this<FileSystemRepository>
00019     {
00020     public:
00021         FileSystemRepository(std::shared_ptr<ExceptionPolicy> exceptionPolicy);
00022
00023         virtual void AddObserver(const std::function<void()> callback, PageType pageType);
00024         virtual void RemoveObserver(PageType pageType);
00025
00026         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhotoGroup^>^> GetMonthGroupedPhotosWithCacheAsync(std::shared_ptr<Hilo::PhotoCache> photoCache, concurrency::cancellation_token token);
00027         virtual concurrency::task<IPhoto^> GetSinglePhotoAsync(Platform::String^ photoPath);
00028         virtual concurrency::task<unsigned int> GetFolderPhotoCountAsync(Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery);
00029         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> GetPhotoDataForMonthGroup(IPhotoGroup^ photoGroup, Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery, unsigned int maxNumberOfItems);
00030         virtual concurrency::task<bool> HasPhotosInRangeAsync(Platform::String^ dateRangeQuery, Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery);
00031         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> GetPhotosForDateRangeQueryAsync(Platform::String^ dateRangeQuery);
00032         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> GetPhotosForPictureHubGroupAsync(IPhotoGroup^ photoGroup, unsigned int maxNumberOfItem);
00033         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IYearGroup^>^> GetYearGroupedMonthsAsync(concurrency::cancellation_token token);
00034         virtual inline concurrency::task<Windows::Foundation::Collections::IVectorView<Windows::Storage::StorageFile^>^> GetPhotoStorageFilesAsync(Platform::String^ query, unsigned int maxNumberOfItems = 25);
00035         virtual void NotifyAllObservers();
00036
00037     private:
00038         std::shared_ptr<ExceptionPolicy> m_exceptionPolicy;
00039         std::function<void()> m_hubViewModelCallback;
00040         std::function<void()> m_imageBrowserViewModelCallback;
00041         std::function<void()> m_imageViewModelCallback;
00042         QueryChange^ m_allPhotosQueryChange;
00043         QueryChange^ m_pictureHubGroupQueryChange;
00044         QueryChange^ m_monthQueryChange;
00045
00046         inline Windows::Storage::Search::StorageFileQueryResult^ CreateFileQuery(Windows::Storage::Search::IStorageFolderQueryOperations^ folder, Platform::String^ query, Windows::Storage::Search::IndexerOption option = Windows::Storage::Search::IndexerOption::UseIndexerWhenAvailable);
00047         concurrency::task<YearGroup^> GetDateTimeForYearFolderAsync(Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery, std::shared_ptr<ExceptionPolicy> exceptionPolicy);
00048     };
00049 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/UI.xaml.h Source File

  • UI contrast and settings

UI.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // UI.xaml.h
00013 // Declaration of the UI class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "UI.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace HighContrast
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class UI sealed
00031         {
00032         public:
00033             UI();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void UIGetSettings_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioOutput2.xaml.h Source File

  • Language font mapping

ScenarioOutput2.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Output.xaml.h
00010 // Declaration of the Scenario2Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput2.g.h"
00017 #include "MainPage.g.h"
00018
00019 namespace LanguageFontCPP
00020 {
00021     [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class ScenarioOutput2 sealed
00023     {
00024     public:
00025         ScenarioOutput2();
00026
00027     protected:
00028         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~ScenarioOutput2();
00033         MainPage^ rootPage;
00034         void rootPage_InputFrameLoaded(Object^ sender, Object^ e);
00035         Windows::Foundation::EventRegistrationToken _frameLoadedToken;
00036     };
00037 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/common/LayoutAwarePage.h Source File

  • CameraCaptureUI
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/pch.cpp Source File

  • SMS background task
  • SmsBackgroundTaskSample

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/DirectXBase.h Source File

  • Input Touch hit testing

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/App.xaml.h Source File

  • XAML data binding

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/AudioCapture.xaml.h Source File

  • Media capture using capture device

AudioCapture.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // AudioCapture.xaml.h
00013 // Declaration of the AudioCapture class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "AudioCapture.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 #define AUDIO_FILE_NAME "audio.mp4"
00023
00024 namespace SDKSample
00025 {
00026     namespace MediaCapture
00027     {
00028         /// <summary>
00029         /// An empty page that can be used on its own or navigated to within a Frame.
00030         /// </summary>
00031       [Windows::Foundation::Metadata::WebHostHidden]
00032         public ref class AudioCapture sealed
00033         {
00034         public:
00035             AudioCapture();
00036
00037         protected:
00038             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00039             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00040         private:
00041             MainPage^ rootPage;
00042
00043             void ScenarioInit();
00044             void ScenarioReset();
00045
00046             void SoundLevelChanged(Object^ sender, Object^ e);
00047             void RecordLimitationExceeded(Windows::Media::Capture::MediaCapture ^ mediaCapture);
00048             void Failed(Windows::Media::Capture::MediaCapture ^ mediaCapture, Windows::Media::Capture::MediaCaptureFailedEventArgs ^ args);
00049
00050             void btnStartDevice_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00051
00052             void btnStartPreview_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00053
00054             void btnStartStopRecord_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00055
00056             void ShowStatusMessage(Platform::String^ text);
00057             void ShowExceptionMessage(Platform::Exception^ ex);
00058
00059             void EnableButton(bool enabled, Platform::String ^name);
00060             void SwitchRecordButtonContent();
00061
00062             Platform::Agile<Windows::Media::Capture::MediaCapture> m_mediaCaptureMgr;
00063             Windows::Storage::StorageFile^ m_photoStorageFile;
00064             Windows::Storage::StorageFile^ m_recordStorageFile;
00065             bool m_bRecording;
00066             bool m_bSuspended;
00067             Windows::Foundation::EventRegistrationToken m_eventRegistrationToken;
00068         };
00069     }
00070 }
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/TaskExtensions.h Source File

  • Hilo C++
  • Hilo

TaskExtensions.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     // Creates a task that completes with the provided result.
00012     template <typename Result>
00013     inline concurrency::task<Result> create_task_from_result(Result result)
00014     {
00015         return concurrency::create_task([result]() -> Result { return result; });
00016     }
00017
00018     // Creates a task that completes with a void result.
00019     inline concurrency::task<void> create_empty_task()
00020     {
00021         return concurrency::create_task([]{});
00022     }
00023
00024     // Runs a function in the main thread with non-interactive priority.
00025     void run_async_non_interactive(std::function<void ()>&& action);
00026 }
00027
00028 #ifndef NDEBUG
00029
00030 #ifdef  __cplusplus
00031 extern "C" {
00032 #endif
00033
00034     // Called at startup to remember the main thread id for debug assertion checking
00035     void RecordMainThread(void);
00036
00037     // Called in debug mode only for thread context assertion checks
00038     bool IsMainThread(void);
00039
00040     // Called in debug mode only for thread context assertion checks
00041     bool IsBackgroundThread(void);
00042
00043 #ifdef  __cplusplus
00044 }
00045 #endif
00046
00047 #endif /* not NDEBUG */
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::ShareSource::sealed Member List

This is the complete list of members for SDKSample::ShareSource::sealed, including all inherited members.
GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^request) override | SDKSample::ShareSource::sealed | [protected, virtual]
GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^request) override | SDKSample::ShareSource::sealed | [protected, virtual]
GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^request) override | SDKSample::ShareSource::sealed | [protected, virtual]
GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^request) override | SDKSample::ShareSource::sealed | [protected, virtual]
GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^request) override | SDKSample::ShareSource::sealed | [protected, virtual]
GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^request) override | SDKSample::ShareSource::sealed | [protected, virtual]
GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^request) override | SDKSample::ShareSource::sealed | [protected, virtual]
GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^request) override | SDKSample::ShareSource::sealed | [protected, virtual]
imageFile | SDKSample::ShareSource::sealed | [private]
OnDeferredImageRequestedHandler(Windows::ApplicationModel::DataTransfer::DataProviderRequest^request) | SDKSample::ShareSource::sealed | [private]
rootPage | SDKSample::ShareSource::sealed | [private]
SelectFilesButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ShareSource::sealed | [private]
SelectImageButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ShareSource::sealed | [private]
SelectImageButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ShareSource::sealed | [private]
SetErrorMessage() | SDKSample::ShareSource::sealed |
ShareCustomData() | SDKSample::ShareSource::sealed |
ShareDelayRenderedFiles() | SDKSample::ShareSource::sealed |
ShareFiles() | SDKSample::ShareSource::sealed |
ShareHtml() | SDKSample::ShareSource::sealed |
ShareImage() | SDKSample::ShareSource::sealed |
ShareLink() | SDKSample::ShareSource::sealed |
ShareText() | SDKSample::ShareSource::sealed |
ShareWebView_LoadCompleted(Platform::Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e) | SDKSample::ShareSource::sealed | [private]
storageItems | SDKSample::ShareSource::sealed | [private]
ValidateAndGetUri(Platform::String^uriString) | SDKSample::ShareSource::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/App.xaml.h Source File

  • Search contract

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030
00031     protected:
00032         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00033         virtual void OnSearchActivated(Windows::ApplicationModel::Activation::SearchActivatedEventArgs^ pArgs) override;
00034         virtual void OnWindowCreated(Windows::UI::Xaml::WindowCreatedEventArgs^ pArgs) override;
00035
00036         void OnQuerySubmitted(Windows::ApplicationModel::Search::SearchPane^ sender, Windows::ApplicationModel::Search::SearchPaneQuerySubmittedEventArgs^ args);
00037
00038     private:
00039         void App::EnsureMainPageActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^ pArgs);
00040         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00041     };
00042 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Constants.h Source File

  • CryptoWinRT

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Cryptography WinRT APIs");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareText.xaml.h Source File

  • Sharing content source app

ShareText.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ShareText.xaml.h
00013 // Declaration of the ShareText class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SharePage.h"
00020 #include "ShareText.g.h"
00021 #include "MainPage.xaml.h"
00022
00023 namespace SDKSample
00024 {
00025     namespace ShareSource
00026     {
00027         public ref class ShareText sealed
00028         {
00029         public:
00030             ShareText();
00031
00032         protected:
00033             virtual bool GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^ request) override;
00034         };
00035     }
00036 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput6.xaml.cpp Source File

  • Toast notifications
  • C#,C++

ScenarioOutput6.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.cpp
00010 // Implementation of the Scenario1Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput6.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace ToastsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput6::ScenarioOutput6()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput6::~ScenarioOutput6()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput6::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044   // Get a pointer to our main page.
00045   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047   // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048   _frameLoadedToken = rootPage->InputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioOutput6::rootPage_InputFrameLoaded);
00049 }
00050
00051 void ScenarioOutput6::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00054 }
00055
00056 #pragma endregion
00057
00058 #pragma region Use this code if you need access to elements in the input frame - otherwise delete
00059 void ScenarioOutput6::rootPage_InputFrameLoaded(Object^ sender, Object^ e)
00060 {
00061     // Get a pointer to the content within the OutputFrame.
00062     Page^ inputFrame = dynamic_cast<Page^>(rootPage->InputFrame->Content);
00063
00064     // Go find the elements that we need for this scenario
00065     // ex: flipView1 = dynamic_cast<FlipView^>(inputFrame->FindName("FlipView1"));
00066 }
00067
00068 #pragma endregion
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/repeater.h Source File

  • Custom driver access
  • DLL

repeater.h

Go to the documentation of this file.
00001 #include <strsafe.h>
00002 #include <assert.h>
00003
00004 #include <functional>
00005 #include <mutex>
00006
00007 #include <ppltasks.h>
00008
00009 #pragma once
00010
00011 namespace Samples {
00012     namespace Devices {
00013
00014         // Implementation details
00015         namespace Details {
00016             // The type of task the StartTaskFunction() returns.  The bool indicates whether the next
00017             // iteration should start.
00018             typedef concurrency::task<bool> RepeaterTaskType;
00019
00020             // The type of function the creator provides to run each iteration.  It returns a task
00021             // which the repeater chains onto.
00022             typedef std::function<RepeaterTaskType (concurrency::cancellation_token, concurrency::task_continuation_context)> StartRepeaterTaskFunction;
00023
00024             // The type of the function the creator calls once the repeater is stopped.
00025             typedef std::function<void(void)> RepeaterStoppedFunction;
00026         }
00027
00028         // The repeater class performs a task over and over again.  It can be used
00029         // to issue a device I/O repeatedly - for example reading events from the
00030         // device.
00031         class Repeater {
00032         public:
00033
00034             // The state of the repeater.  It is initialized in the stopped state.
00035             enum class RepeaterState {
00036                 Stopped,
00037                 Running,
00038                 Stopping
00039             };
00040
00041         private:
00042             // The function to call when starting each iteration of the repeater
00043             Details::StartRepeaterTaskFunction m_StartTaskFunction;
00044
00045             // The source of cancellation tokens passed to the start task function
00046             concurrency::cancellation_token_source m_Canceller;
00047
00048             // Whether the repeater is active, stopping or stopped.
00049             RepeaterState m_State;
00050
00051             // Lock to protect the state.  The task chains are created under this
00052             // lock, but they execute without the lock.
00053             std::mutex m_Lock;
00054
00055             // shorthand for our mutex's lock type (mlt)
00056             typedef std::unique_lock<std::mutex> mlt;
00057
00058             // An optional function to call once the repeater is stopped
00059             // TODO: should Stop return a task that the caller can .then?
00060             Details::RepeaterStoppedFunction m_RepeaterStoppedFunction;
00061
00062         public:
00063             Repeater() : m_StartTaskFunction(nullptr),
00064                          m_State(RepeaterState::Stopped),
00065                          m_RepeaterStoppedFunction(nullptr)
00066             {
00067                 return;
00068             }
00069
00070             ~Repeater()
00071             {
00072                 // TODO: Move the core of the repeater to an allocated
00073                 //       object that i can let run down on its own on destruction.  For now
00074                 //       !! don't delete a repeater that's still running !!
00075                 assert(m_State == RepeaterState::Stopped);
00076             }
00077
00078             // Starts the repeater.  Each iteration calls StartTaskFunction to kick off a chain of tasks.
00079             // The repeater then adds a task to the end of the chain that fires off the next iteration
00080             // Caller can provide a context that plumbs through to the start functions, or use current
00081             void Start(
00082                 Details::StartRepeaterTaskFunction StartTaskFunction,
00083                 concurrency::task_continuation_context Context = concurrency::task_continuation_context::use_current()
00084                 )
00085             {
00086                 // lock the mutex
00087                 mlt lock(m_Lock);
00088
00089                 assert(m_State == RepeaterState::Stopped);
00090
00091                 if (m_State == RepeaterState::Stopped) {
00092                     m_StartTaskFunction = StartTaskFunction;
00093                     m_RepeaterStoppedFunction = nullptr;
00094
00095                     // Get a new canceller before we start the tasks
00096                     auto c = concurrency::cancellation_token_source();
00097                     m_Canceller = std::move(c);
00098
00099                     // Update task state before starting the task so that it can
00100                     // restart itself properly.
00101                     m_State = RepeaterState::Running;
00102                     StartTask(Context);
00103                 }
00104             }
00105
00106             // Stop the repeater.  This will cancel the current task (caller's task
00107             // needs to have registered for cancellation).  Caller can optionally provide a
00108             // callback that the last task will invoke.
00109             bool Stop(Details::RepeaterStoppedFunction* callback = nullptr)
00110             {
00111                 mlt lock(m_Lock);
00112                 bool active;
00113
00114                 if (m_State == RepeaterState::Running) {
00115                     m_State = RepeaterState::Stopping;
00116                     m_Canceller.cancel();
00117
00118                     active = true;
00119                 } else if (m_State == RepeaterState::Stopping) {
00120                     active = true;
00121                 } else {
00122                     active = false;
00123                 }
00124
00125                 if (callback) {
00126                     if (active == true) {
00127                         m_RepeaterStoppedFunction = *callback;
00128                         lock.release();
00129                     }
00130                 }
00131
00132                 return active;
00133             }
00134
00135             // The current state of the repeater.
00136             RepeaterState GetState(void)
00137             {
00138                 return m_State;
00139             }
00140
00141         private:
00142
00143             // Creates the task chain, and appends the restart task to it
00144             void StartTask(concurrency::task_continuation_context context) {
00145                 // start the caller's task and add a restart task onto
00146                 // the end.
00147                 m_StartTaskFunction(m_Canceller.get_token(), context).
00148                     then([this, context](bool b) {
00149                         RestartTask(context, b);
00150                     }
00151                 );
00152             }
00153
00154             // The restart task mentioned above.  If the repeater is still running &
00155             // the previous iteration didn't return false, it calls StartTask() to
00156             // fire off the next iteration.  Otherwise it handles rundown.
00157             void RestartTask(concurrency::task_continuation_context context, bool Continue) {
00158                 // Check and see if the task is still running
00159                 mlt lock(m_Lock);
00160
00161                 if (Continue == false) {
00162                     m_State = RepeaterState::Stopping;
00163                 }
00164                 if (m_State == RepeaterState::Running) {
00165                     StartTask(context);
00166                 } else if (m_State == RepeaterState::Stopping) {
00167                     m_State = RepeaterState::Stopped;
00168                     if (m_RepeaterStoppedFunction != nullptr) {
00169                         Details::RepeaterStoppedFunction callback = m_RepeaterStoppedFunction;
00170                         m_RepeaterStoppedFunction = nullptr;
00171                         lock.release();
00172                         callback();
00173                     }
00174                 }
00175             }
00176         };
00177
00178
00179     }
00180 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicLoader.cpp Source File

  • Direct3D sprite

BasicLoader.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicLoader.h"
00010 #include "BasicShapes.h"
00011 #include "DDSTextureLoader.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 using namespace Microsoft::WRL;
00016 using namespace Windows::Storage;
00017 using namespace Windows::Storage::Streams;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::ApplicationModel;
00020 using namespace std;
00021 using namespace concurrency;
00022
00023 BasicLoader::BasicLoader(
00024     _In_ ID3D11Device* d3dDevice,
00025     _In_opt_ IWICImagingFactory2* wicFactory
00026     ) :
00027     m_d3dDevice(d3dDevice),
00028     m_wicFactory(wicFactory)
00029 {
00030     // Create a new BasicReaderWriter to do raw file I/O.
00031     m_basicReaderWriter = ref new BasicReaderWriter();
00032 }
00033
00034 template <class DeviceChildType>
00035 inline void BasicLoader::SetDebugName(
00036     _In_ DeviceChildType* object,
00037     _In_ Platform::String^ name
00038     )
00039 {
00040 #if defined(_DEBUG)
00041     // Only assign debug names in debug builds.
00042
00043     char nameString[1024];
00044     int nameStringLength = WideCharToMultiByte(
00045         CP_ACP,
00046         0,
00047         name->Data(),
00048         -1,
00049         nameString,
00050         1024,
00051         nullptr,
00052         nullptr
00053         );
00054
00055     if (nameStringLength == 0)
00056     {
00057         char defaultNameString[] = "BasicLoaderObject";
00058         DX::ThrowIfFailed(
00059             object->SetPrivateData(
00060                 WKPDID_D3DDebugObjectName,
00061                 sizeof(defaultNameString) - 1,
00062                 defaultNameString
00063                 )
00064             );
00065     }
00066     else
00067     {
00068         DX::ThrowIfFailed(
00069             object->SetPrivateData(
00070                 WKPDID_D3DDebugObjectName,
00071                 nameStringLength - 1,
00072                 nameString
00073                 )
00074             );
00075     }
00076 #endif
00077 }
00078
00079 Platform::String^ BasicLoader::GetExtension(
00080     _In_ Platform::String^ filename
00081     )
00082 {
00083     int lastDotIndex = -1;
00084     for (int i = filename->Length() - 1; i >= 0 && lastDotIndex == -1; i--)
00085     {
00086         if (*(filename->Data() + i) == '.')
00087         {
00088             lastDotIndex = i;
00089         }
00090     }
00091     if (lastDotIndex != -1)
00092     {
00093         std::unique_ptr<wchar_t[]> extension(new wchar_t[filename->Length() - lastDotIndex]);
00094         for (unsigned int i = 0; i < filename->Length() - lastDotIndex; i++)
00095         {
00096             extension[i] = tolower(*(filename->Data() + lastDotIndex + 1 + i));
00097         }
00098         return ref new Platform::String(extension.get());
00099     }
00100     return "";
00101 }
00102
00103 void BasicLoader::CreateTexture(
00104     _In_ bool decodeAsDDS,
00105     _In_reads_bytes_(dataSize) byte* data,
00106     _In_ uint32 dataSize,
00107     _Out_opt_ ID3D11Texture2D** texture,
00108     _Out_opt_ ID3D11ShaderResourceView** textureView,
00109     _In_opt_ Platform::String^ debugName
00110     )
00111 {
00112     ComPtr<ID3D11ShaderResourceView> shaderResourceView;
00113     ComPtr<ID3D11Texture2D> texture2D;
00114
00115     if (decodeAsDDS)
00116     {
00117         ComPtr<ID3D11Resource> resource;
00118
00119         if (textureView == nullptr)
00120         {
00121             CreateDDSTextureFromMemory(
00122                 m_d3dDevice.Get(),
00123                 data,
00124                 dataSize,
00125                 &resource,
00126                 nullptr
00127                 );
00128         }
00129         else
00130         {
00131             CreateDDSTextureFromMemory(
00132                 m_d3dDevice.Get(),
00133                 data,
00134                 dataSize,
00135                 &resource,
00136                 &shaderResourceView
00137                 );
00138         }
00139
00140         DX::ThrowIfFailed(
00141             resource.As(&texture2D)
00142             );
00143     }
00144     else
00145     {
00146         if (m_wicFactory.Get() == nullptr)
00147         {
00148             // A WIC factory object is required in order to load texture
00149             // assets stored in non-DDS formats.  If BasicLoader was not
00150             // initialized with one, create one as needed.
00151             DX::ThrowIfFailed(
00152                 CoCreateInstance(
00153                     CLSID_WICImagingFactory,
00154                     nullptr,
00155                     CLSCTX_INPROC_SERVER,
00156                     IID_PPV_ARGS(&m_wicFactory)
00157                     )
00158                 );
00159         }
00160
00161         ComPtr<IWICStream> stream;
00162         DX::ThrowIfFailed(
00163             m_wicFactory->CreateStream(&stream)
00164             );
00165
00166         DX::ThrowIfFailed(
00167             stream->InitializeFromMemory(
00168                 data,
00169                 dataSize
00170                 )
00171             );
00172
00173         ComPtr<IWICBitmapDecoder> bitmapDecoder;
00174         DX::ThrowIfFailed(
00175             m_wicFactory->CreateDecoderFromStream(
00176                 stream.Get(),
00177                 nullptr,
00178                 WICDecodeMetadataCacheOnDemand,
00179                 &bitmapDecoder
00180                 )
00181             );
00182
00183         ComPtr<IWICBitmapFrameDecode> bitmapFrame;
00184         DX::ThrowIfFailed(
00185             bitmapDecoder->GetFrame(0, &bitmapFrame)
00186             );
00187
00188         ComPtr<IWICFormatConverter> formatConverter;
00189         DX::ThrowIfFailed(
00190             m_wicFactory->CreateFormatConverter(&formatConverter)
00191             );
00192
00193         DX::ThrowIfFailed(
00194             formatConverter->Initialize(
00195                 bitmapFrame.Get(),
00196                 GUID_WICPixelFormat32bppPBGRA,
00197                 WICBitmapDitherTypeNone,
00198                 nullptr,
00199                 0.0,
00200                 WICBitmapPaletteTypeCustom
00201                 )
00202             );
00203
00204         uint32 width;
00205         uint32 height;
00206         DX::ThrowIfFailed(
00207             bitmapFrame->GetSize(&width, &height)
00208             );
00209
00210         std::unique_ptr<byte[]> bitmapPixels(new byte[width * height * 4]);
00211         DX::ThrowIfFailed(
00212             formatConverter->CopyPixels(
00213                 nullptr,
00214                 width * 4,
00215                 width * height * 4,
00216                 bitmapPixels.get()
00217                 )
00218             );
00219
00220         D3D11_SUBRESOURCE_DATA initialData;
00221         ZeroMemory(&initialData, sizeof(initialData));
00222         initialData.pSysMem = bitmapPixels.get();
00223         initialData.SysMemPitch = width * 4;
00224         initialData.SysMemSlicePitch = 0;
00225
00226         CD3D11_TEXTURE2D_DESC textureDesc(
00227             DXGI_FORMAT_B8G8R8A8_UNORM,
00228             width,
00229             height,
00230             1,
00231             1
00232             );
00233
00234         DX::ThrowIfFailed(
00235             m_d3dDevice->CreateTexture2D(
00236                 &textureDesc,
00237                 &initialData,
00238                 &texture2D
00239                 )
00240             );
00241
00242         if (textureView != nullptr)
00243         {
00244             CD3D11_SHADER_RESOURCE_VIEW_DESC shaderResourceViewDesc(
00245                 texture2D.Get(),
00246                 D3D11_SRV_DIMENSION_TEXTURE2D
00247                 );
00248
00249             DX::ThrowIfFailed(
00250                 m_d3dDevice->CreateShaderResourceView(
00251                     texture2D.Get(),
00252                     &shaderResourceViewDesc,
00253                     &shaderResourceView
00254                     )
00255                 );
00256         }
00257     }
00258
00259     SetDebugName(texture2D.Get(), debugName);
00260
00261     if (texture != nullptr)
00262     {
00263         *texture = texture2D.Detach();
00264     }
00265     if (textureView != nullptr)
00266     {
00267         *textureView = shaderResourceView.Detach();
00268     }
00269 }
00270
00271 void BasicLoader::CreateInputLayout(
00272     _In_reads_bytes_(bytecodeSize) byte* bytecode,
00273     _In_ uint32 bytecodeSize,
00274     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00275     _In_ uint32 layoutDescNumElements,
00276     _Out_ ID3D11InputLayout** layout
00277     )
00278 {
00279     if (layoutDesc == nullptr)
00280     {
00281         // If no input layout is specified, use the BasicVertex layout.
00282         const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
00283         {
00284             { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
00285             { "NORMAL",   0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00286             { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 24, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00287         };
00288
00289         DX::ThrowIfFailed(
00290             m_d3dDevice->CreateInputLayout(
00291                 basicVertexLayoutDesc,
00292                 ARRAYSIZE(basicVertexLayoutDesc),
00293                 bytecode,
00294                 bytecodeSize,
00295                 layout
00296                 )
00297             );
00298     }
00299     else
00300     {
00301         DX::ThrowIfFailed(
00302             m_d3dDevice->CreateInputLayout(
00303                 layoutDesc,
00304                 layoutDescNumElements,
00305                 bytecode,
00306                 bytecodeSize,
00307                 layout
00308                 )
00309             );
00310     }
00311 }
00312
00313 void BasicLoader::CreateMesh(
00314     _In_ byte* meshData,
00315     _Out_ ID3D11Buffer** vertexBuffer,
00316     _Out_ ID3D11Buffer** indexBuffer,
00317     _Out_opt_ uint32* vertexCount,
00318     _Out_opt_ uint32* indexCount,
00319     _In_opt_ Platform::String^ debugName
00320     )
00321 {
00322     // The first 4 bytes of the BasicMesh format define the number of vertices in the mesh.
00323     uint32 numVertices = *reinterpret_cast<uint32*>(meshData);
00324
00325     // The following 4 bytes define the number of indices in the mesh.
00326     uint32 numIndices = *reinterpret_cast<uint32*>(meshData + sizeof(uint32));
00327
00328     // The next segment of the BasicMesh format contains the vertices of the mesh.
00329     BasicVertex* vertices = reinterpret_cast<BasicVertex*>(meshData + sizeof(uint32) * 2);
00330
00331     // The last segment of the BasicMesh format contains the indices of the mesh.
00332     uint16* indices = reinterpret_cast<uint16*>(meshData + sizeof(uint32) * 2 + sizeof(BasicVertex) * numVertices);
00333
00334     // Create the vertex and index buffers with the mesh data.
00335
00336     D3D11_SUBRESOURCE_DATA vertexBufferData = {0};
00337     vertexBufferData.pSysMem = vertices;
00338     vertexBufferData.SysMemPitch = 0;
00339     vertexBufferData.SysMemSlicePitch = 0;
00340     CD3D11_BUFFER_DESC vertexBufferDesc(numVertices * sizeof(BasicVertex), D3D11_BIND_VERTEX_BUFFER);
00341     DX::ThrowIfFailed(
00342         m_d3dDevice->CreateBuffer(
00343             &vertexBufferDesc,
00344             &vertexBufferData,
00345             vertexBuffer
00346             )
00347         );
00348
00349     D3D11_SUBRESOURCE_DATA indexBufferData = {0};
00350     indexBufferData.pSysMem = indices;
00351     indexBufferData.SysMemPitch = 0;
00352     indexBufferData.SysMemSlicePitch = 0;
00353     CD3D11_BUFFER_DESC indexBufferDesc(numIndices * sizeof(uint16), D3D11_BIND_INDEX_BUFFER);
00354     DX::ThrowIfFailed(
00355         m_d3dDevice->CreateBuffer(
00356             &indexBufferDesc,
00357             &indexBufferData,
00358             indexBuffer
00359             )
00360         );
00361
00362     SetDebugName(*vertexBuffer, Platform::String::Concat(debugName, "_VertexBuffer"));
00363     SetDebugName(*indexBuffer, Platform::String::Concat(debugName, "_IndexBuffer"));
00364
00365     if (vertexCount != nullptr)
00366     {
00367         *vertexCount = numVertices;
00368     }
00369     if (indexCount != nullptr)
00370     {
00371         *indexCount = numIndices;
00372     }
00373 }
00374
00375 void BasicLoader::LoadTexture(
00376     _In_ Platform::String^ filename,
00377     _Out_opt_ ID3D11Texture2D** texture,
00378     _Out_opt_ ID3D11ShaderResourceView** textureView
00379     )
00380 {
00381     Platform::Array<byte>^ textureData = m_basicReaderWriter->ReadData(filename);
00382
00383     CreateTexture(
00384         GetExtension(filename) == "dds",
00385         textureData->Data,
00386         textureData->Length,
00387         texture,
00388         textureView,
00389         filename
00390         );
00391 }
00392
00393 task<void> BasicLoader::LoadTextureAsync(
00394     _In_ Platform::String^ filename,
00395     _Out_opt_ ID3D11Texture2D** texture,
00396     _Out_opt_ ID3D11ShaderResourceView** textureView
00397     )
00398 {
00399     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ textureData)
00400     {
00401         CreateTexture(
00402             GetExtension(filename) == "dds",
00403             textureData->Data,
00404             textureData->Length,
00405             texture,
00406             textureView,
00407             filename
00408             );
00409     });
00410 }
00411
00412 void BasicLoader::LoadShader(
00413     _In_ Platform::String^ filename,
00414     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00415     _In_ uint32 layoutDescNumElements,
00416     _Out_ ID3D11VertexShader** shader,
00417     _Out_opt_ ID3D11InputLayout** layout
00418     )
00419 {
00420     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00421
00422     DX::ThrowIfFailed(
00423         m_d3dDevice->CreateVertexShader(
00424             bytecode->Data,
00425             bytecode->Length,
00426             nullptr,
00427             shader
00428             )
00429         );
00430
00431     SetDebugName(*shader, filename);
00432
00433     if (layout != nullptr)
00434     {
00435         CreateInputLayout(
00436             bytecode->Data,
00437             bytecode->Length,
00438             layoutDesc,
00439             layoutDescNumElements,
00440             layout
00441             );
00442
00443         SetDebugName(*layout, filename);
00444     }
00445 }
00446
00447 task<void> BasicLoader::LoadShaderAsync(
00448     _In_ Platform::String^ filename,
00449     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00450     _In_ uint32 layoutDescNumElements,
00451     _Out_ ID3D11VertexShader** shader,
00452     _Out_opt_ ID3D11InputLayout** layout
00453     )
00454 {
00455     // This method assumes that the lifetime of input arguments may be shorter
00456     // than the duration of this task.  In order to ensure accurate results, a
00457     // copy of all arguments passed by pointer must be made.  The method then
00458     // ensures that the lifetime of the copied data exceeds that of the task.
00459
00460     // Create copies of the layoutDesc array as well as the SemanticName strings,
00461     // both of which are pointers to data whose lifetimes may be shorter than that
00462     // of this method's task.
00463     shared_ptr<vector<D3D11_INPUT_ELEMENT_DESC>> layoutDescCopy;
00464     shared_ptr<vector<string>> layoutDescSemanticNamesCopy;
00465     if (layoutDesc != nullptr)
00466     {
00467         layoutDescCopy.reset(
00468             new vector<D3D11_INPUT_ELEMENT_DESC>(
00469                 layoutDesc,
00470                 layoutDesc + layoutDescNumElements
00471                 )
00472             );
00473
00474         layoutDescSemanticNamesCopy.reset(
00475             new vector<string>(layoutDescNumElements)
00476             );
00477
00478         for (uint32 i = 0; i < layoutDescNumElements; i++)
00479         {
00480             layoutDescSemanticNamesCopy->at(i).assign(layoutDesc[i].SemanticName);
00481         }
00482     }
00483
00484     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00485     {
00486         DX::ThrowIfFailed(
00487             m_d3dDevice->CreateVertexShader(
00488                 bytecode->Data,
00489                 bytecode->Length,
00490                 nullptr,
00491                 shader
00492                 )
00493             );
00494
00495         SetDebugName(*shader, filename);
00496
00497         if (layout != nullptr)
00498         {
00499             if (layoutDesc != nullptr)
00500             {
00501                 // Reassign the SemanticName elements of the layoutDesc array copy to point
00502                 // to the corresponding copied strings. Performing the assignment inside the
00503                 // lambda body ensures that the lambda will take a reference to the shared_ptr
00504                 // that holds the data.  This will guarantee that the data is still valid when
00505                 // CreateInputLayout is called.
00506                 for (uint32 i = 0; i < layoutDescNumElements; i++)
00507                 {
00508                     layoutDescCopy->at(i).SemanticName = layoutDescSemanticNamesCopy->at(i).c_str();
00509                 }
00510             }
00511
00512             CreateInputLayout(
00513                 bytecode->Data,
00514                 bytecode->Length,
00515                 layoutDesc == nullptr ? nullptr : layoutDescCopy->data(),
00516                 layoutDescNumElements,
00517                 layout
00518                 );
00519
00520             SetDebugName(*layout, filename);
00521         }
00522     });
00523 }
00524
00525 void BasicLoader::LoadShader(
00526     _In_ Platform::String^ filename,
00527     _Out_ ID3D11PixelShader** shader
00528     )
00529 {
00530     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00531
00532     DX::ThrowIfFailed(
00533         m_d3dDevice->CreatePixelShader(
00534             bytecode->Data,
00535             bytecode->Length,
00536             nullptr,
00537             shader
00538             )
00539         );
00540
00541     SetDebugName(*shader, filename);
00542 }
00543
00544 task<void> BasicLoader::LoadShaderAsync(
00545     _In_ Platform::String^ filename,
00546     _Out_ ID3D11PixelShader** shader
00547     )
00548 {
00549     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00550     {
00551         DX::ThrowIfFailed(
00552             m_d3dDevice->CreatePixelShader(
00553                 bytecode->Data,
00554                 bytecode->Length,
00555                 nullptr,
00556                 shader
00557                 )
00558             );
00559
00560         SetDebugName(*shader, filename);
00561     });
00562 }
00563
00564 void BasicLoader::LoadShader(
00565     _In_ Platform::String^ filename,
00566     _Out_ ID3D11ComputeShader** shader
00567     )
00568 {
00569     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00570
00571     DX::ThrowIfFailed(
00572         m_d3dDevice->CreateComputeShader(
00573             bytecode->Data,
00574             bytecode->Length,
00575             nullptr,
00576             shader
00577             )
00578         );
00579
00580     SetDebugName(*shader, filename);
00581 }
00582
00583 task<void> BasicLoader::LoadShaderAsync(
00584     _In_ Platform::String^ filename,
00585     _Out_ ID3D11ComputeShader** shader
00586     )
00587 {
00588     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00589     {
00590         DX::ThrowIfFailed(
00591             m_d3dDevice->CreateComputeShader(
00592                 bytecode->Data,
00593                 bytecode->Length,
00594                 nullptr,
00595                 shader
00596                 )
00597             );
00598
00599         SetDebugName(*shader, filename);
00600     });
00601 }
00602
00603 void BasicLoader::LoadShader(
00604     _In_ Platform::String^ filename,
00605     _Out_ ID3D11GeometryShader** shader
00606     )
00607 {
00608     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00609
00610     DX::ThrowIfFailed(
00611         m_d3dDevice->CreateGeometryShader(
00612             bytecode->Data,
00613             bytecode->Length,
00614             nullptr,
00615             shader
00616             )
00617         );
00618
00619     SetDebugName(*shader, filename);
00620 }
00621
00622 task<void> BasicLoader::LoadShaderAsync(
00623     _In_ Platform::String^ filename,
00624     _Out_ ID3D11GeometryShader** shader
00625     )
00626 {
00627     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00628     {
00629         DX::ThrowIfFailed(
00630             m_d3dDevice->CreateGeometryShader(
00631                 bytecode->Data,
00632                 bytecode->Length,
00633                 nullptr,
00634                 shader
00635                 )
00636             );
00637
00638         SetDebugName(*shader, filename);
00639     });
00640 }
00641
00642 void BasicLoader::LoadShader(
00643     _In_ Platform::String^ filename,
00644     _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00645     _In_ uint32 numEntries,
00646     _In_reads_opt_(numStrides) const uint32* bufferStrides,
00647     _In_ uint32 numStrides,
00648     _In_ uint32 rasterizedStream,
00649     _Out_ ID3D11GeometryShader** shader
00650     )
00651 {
00652     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00653
00654     DX::ThrowIfFailed(
00655         m_d3dDevice->CreateGeometryShaderWithStreamOutput(
00656             bytecode->Data,
00657             bytecode->Length,
00658             streamOutDeclaration,
00659             numEntries,
00660             bufferStrides,
00661             numStrides,
00662             rasterizedStream,
00663             nullptr,
00664             shader
00665             )
00666         );
00667
00668     SetDebugName(*shader, filename);
00669 }
00670
00671 task<void> BasicLoader::LoadShaderAsync(
00672     _In_ Platform::String^ filename,
00673     _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00674     _In_ uint32 numEntries,
00675     _In_reads_opt_(numStrides) const uint32* bufferStrides,
00676     _In_ uint32 numStrides,
00677     _In_ uint32 rasterizedStream,
00678     _Out_ ID3D11GeometryShader** shader
00679     )
00680 {
00681     // This method assumes that the lifetime of input arguments may be shorter
00682     // than the duration of this task.  In order to ensure accurate results, a
00683     // copy of all arguments passed by pointer must be made.  The method then
00684     // ensures that the lifetime of the copied data exceeds that of the task.
00685
00686     // Create copies of the streamOutDeclaration array as well as the SemanticName
00687     // strings, both of which are pointers to data whose lifetimes may be shorter
00688     // than that of this method's task.
00689     shared_ptr<vector<D3D11_SO_DECLARATION_ENTRY>> streamOutDeclarationCopy;
00690     shared_ptr<vector<string>> streamOutDeclarationSemanticNamesCopy;
00691     if (streamOutDeclaration != nullptr)
00692     {
00693         streamOutDeclarationCopy.reset(
00694             new vector<D3D11_SO_DECLARATION_ENTRY>(
00695                 streamOutDeclaration,
00696                 streamOutDeclaration + numEntries
00697                 )
00698             );
00699
00700         streamOutDeclarationSemanticNamesCopy.reset(
00701             new vector<string>(numEntries)
00702             );
00703
00704         for (uint32 i = 0; i < numEntries; i++)
00705         {
00706             streamOutDeclarationSemanticNamesCopy->at(i).assign(streamOutDeclaration[i].SemanticName);
00707         }
00708     }
00709
00710     // Create a copy of the bufferStrides array, which is a pointer to data
00711     // whose lifetime may be shorter than that of this method's task.
00712     shared_ptr<vector<uint32>> bufferStridesCopy;
00713     if (bufferStrides != nullptr)
00714     {
00715         bufferStridesCopy.reset(
00716             new vector<uint32>(
00717                 bufferStrides,
00718                 bufferStrides + numStrides
00719                 )
00720             );
00721     }
00722
00723     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00724     {
00725         if (streamOutDeclaration != nullptr)
00726         {
00727             // Reassign the SemanticName elements of the streamOutDeclaration array copy to
00728             // point to the corresponding copied strings. Performing the assignment inside the
00729             // lambda body ensures that the lambda will take a reference to the shared_ptr
00730             // that holds the data.  This will guarantee that the data is still valid when
00731             // CreateGeometryShaderWithStreamOutput is called.
00732             for (uint32 i = 0; i < numEntries; i++)
00733             {
00734                 streamOutDeclarationCopy->at(i).SemanticName = streamOutDeclarationSemanticNamesCopy->at(i).c_str();
00735             }
00736         }
00737
00738         DX::ThrowIfFailed(
00739             m_d3dDevice->CreateGeometryShaderWithStreamOutput(
00740                 bytecode->Data,
00741                 bytecode->Length,
00742                 streamOutDeclaration == nullptr ? nullptr : streamOutDeclarationCopy->data(),
00743                 numEntries,
00744                 bufferStrides == nullptr ? nullptr : bufferStridesCopy->data(),
00745                 numStrides,
00746                 rasterizedStream,
00747                 nullptr,
00748                 shader
00749                 )
00750             );
00751
00752         SetDebugName(*shader, filename);
00753     });
00754 }
00755
00756 void BasicLoader::LoadShader(
00757     _In_ Platform::String^ filename,
00758     _Out_ ID3D11HullShader** shader
00759     )
00760 {
00761     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00762
00763     DX::ThrowIfFailed(
00764         m_d3dDevice->CreateHullShader(
00765             bytecode->Data,
00766             bytecode->Length,
00767             nullptr,
00768             shader
00769             )
00770         );
00771
00772     SetDebugName(*shader, filename);
00773 }
00774
00775 task<void> BasicLoader::LoadShaderAsync(
00776     _In_ Platform::String^ filename,
00777     _Out_ ID3D11HullShader** shader
00778     )
00779 {
00780     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00781     {
00782         DX::ThrowIfFailed(
00783             m_d3dDevice->CreateHullShader(
00784                 bytecode->Data,
00785                 bytecode->Length,
00786                 nullptr,
00787                 shader
00788                 )
00789             );
00790
00791         SetDebugName(*shader, filename);
00792     });
00793 }
00794
00795 void BasicLoader::LoadShader(
00796     _In_ Platform::String^ filename,
00797     _Out_ ID3D11DomainShader** shader
00798     )
00799 {
00800     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00801
00802     DX::ThrowIfFailed(
00803         m_d3dDevice->CreateDomainShader(
00804             bytecode->Data,
00805             bytecode->Length,
00806             nullptr,
00807             shader
00808             )
00809         );
00810
00811     SetDebugName(*shader, filename);
00812 }
00813
00814 task<void> BasicLoader::LoadShaderAsync(
00815     _In_ Platform::String^ filename,
00816     _Out_ ID3D11DomainShader** shader
00817     )
00818 {
00819     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00820     {
00821         DX::ThrowIfFailed(
00822             m_d3dDevice->CreateDomainShader(
00823                 bytecode->Data,
00824                 bytecode->Length,
00825                 nullptr,
00826                 shader
00827                 )
00828             );
00829
00830         SetDebugName(*shader, filename);
00831     });
00832 }
00833
00834 void BasicLoader::LoadMesh(
00835     _In_ Platform::String^ filename,
00836     _Out_ ID3D11Buffer** vertexBuffer,
00837     _Out_ ID3D11Buffer** indexBuffer,
00838     _Out_opt_ uint32* vertexCount,
00839     _Out_opt_ uint32* indexCount
00840     )
00841 {
00842     Platform::Array<byte>^ meshData = m_basicReaderWriter->ReadData(filename);
00843
00844     CreateMesh(
00845         meshData->Data,
00846         vertexBuffer,
00847         indexBuffer,
00848         vertexCount,
00849         indexCount,
00850         filename
00851         );
00852 }
00853
00854 task<void> BasicLoader::LoadMeshAsync(
00855     _In_ Platform::String^ filename,
00856     _Out_ ID3D11Buffer** vertexBuffer,
00857     _Out_ ID3D11Buffer** indexBuffer,
00858     _Out_opt_ uint32* vertexCount,
00859     _Out_opt_ uint32* indexCount
00860     )
00861 {
00862     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ meshData)
00863     {
00864         CreateMesh(
00865             meshData->Data,
00866             vertexBuffer,
00867             indexBuffer,
00868             vertexCount,
00869             indexCount,
00870             filename
00871             );
00872     });
00873 }
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DocSource.cpp Source File

  • Direct2Dapp printing

DocSource.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "docsource.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Graphics::Printing;
00013
00014 #pragma region IDocumentPageSource Methods
00015
00016 IFACEMETHODIMP
00017 CDocumentSource::GetPreviewPageCollection(
00018     _In_  IPrintDocumentPackageTarget*  docPackageTarget,
00019     _Out_ IPrintPreviewPageCollection** docPageCollection
00020     )
00021 {
00022     HRESULT hr = (docPackageTarget != nullptr) ? S_OK : E_INVALIDARG;
00023
00024     // Get for IPrintPreviewDxgiPackageTarget interface.
00025     if (SUCCEEDED(hr))
00026     {
00027         hr = docPackageTarget->GetPackageTarget(
00028             ID_PREVIEWPACKAGETARGET_DXGI,
00029             IID_PPV_ARGS(&m_dxgiPreviewTarget)
00030             );
00031     }
00032
00033     ComPtr<IPrintPreviewPageCollection> pageCollection;
00034     if (SUCCEEDED(hr))
00035     {
00036         ComPtr<CDocumentSource> docSource(this);
00037         hr = docSource.As<IPrintPreviewPageCollection>(&pageCollection);
00038     }
00039
00040     if (SUCCEEDED(hr))
00041     {
00042         hr = pageCollection.CopyTo(docPageCollection);
00043     }
00044
00045     return hr;
00046 }
00047
00048 IFACEMETHODIMP
00049 CDocumentSource::MakeDocument(
00050     _In_ IInspectable*                docOptions,
00051     _In_ IPrintDocumentPackageTarget* docPackageTarget
00052     )
00053 {
00054     if (docOptions == nullptr || docPackageTarget == nullptr)
00055     {
00056         return E_INVALIDARG;
00057     }
00058
00059     // Get print settings from PrintTaskOptions for printing, such as page description, which contains page size, imageable area, DPI.
00060     // User can obtain other print settings in the same way, such as ColorMode, NumberOfCopies, etc., which are not shown in this sample.
00061     PrintTaskOptions^ option = reinterpret_cast<PrintTaskOptions^>(docOptions);
00062     PrintPageDescription pageDesc = option->GetPageDescription(1); // Get the description of the first page.
00063
00064     // Create a print control properties and set DPI from PrintPageDescription.
00065     D2D1_PRINT_CONTROL_PROPERTIES printControlProperties;
00066
00067     printControlProperties.rasterDPI  = (float)(min(pageDesc.DpiX, pageDesc.DpiY)); // DPI for rasterization of all unsupported D2D commands or options
00068     printControlProperties.colorSpace = D2D1_COLOR_SPACE_SRGB;                  // Color space for vector graphics in D2D print control.
00069     printControlProperties.fontSubset = D2D1_PRINT_FONT_SUBSET_MODE_DEFAULT;    // Subset for used glyphs, send and discard font resource after every five pages
00070
00071     HRESULT hr = S_OK;
00072
00073     try
00074     {
00075         // Create a new print control linked to the package target.
00076         m_renderer->CreatePrintControl(
00077             docPackageTarget,
00078             &printControlProperties
00079             );
00080
00081         // Calculate imageable area and page size from PrintPageDescription.
00082         D2D1_RECT_F imageableRect = D2D1::RectF(
00083             pageDesc.ImageableRect.X,
00084             pageDesc.ImageableRect.Y,
00085             pageDesc.ImageableRect.X + pageDesc.ImageableRect.Width,
00086             pageDesc.ImageableRect.Y + pageDesc.ImageableRect.Height
00087             );
00088
00089         D2D1_SIZE_F pageSize = D2D1::SizeF(pageDesc.PageSize.Width, pageDesc.PageSize.Height);
00090
00091         // Loop to add page command list to d2d print control.
00092         for (uint32 pageNum = 1; pageNum <= m_totalPages; ++pageNum)
00093         {
00094             m_renderer->PrintPage(
00095                 pageNum,
00096                 imageableRect,
00097                 pageSize,
00098                 nullptr // If a page-level print ticket is not specified here, the package print ticket is applied for each page.
00099                 );
00100         }
00101     }
00102     catch (Platform::Exception^ e)
00103     {
00104         hr = e->HResult;
00105
00106         if (hr == D2DERR_RECREATE_TARGET)
00107         {
00108             // In case of device lost, the whole print job will be aborted, and we should recover
00109             // so that the device is ready when used again. At the same time, we should propagate
00110             // this error to the Modern Print Dialog.
00111             m_renderer->HandleDeviceLost();
00112         }
00113     }
00114
00115     // Make sure to close d2d print control even if AddPage fails.
00116     HRESULT hrClose = m_renderer->ClosePrintControl();
00117
00118     if (SUCCEEDED(hr))
00119     {
00120         hr = hrClose;
00121     }
00122
00123     return hr;
00124 }
00125
00126 #pragma endregion IDocumentPageSource Methods
00127
00128 #pragma region IPrintPreviewPageCollection Methods
00129
00130 IFACEMETHODIMP
00131 CDocumentSource::Paginate(
00132     _In_   uint32           currentJobPage,
00133     _In_   IInspectable*    docOptions
00134     )
00135 {
00136     HRESULT hr = (docOptions != nullptr) ? S_OK : E_INVALIDARG;
00137
00138     if (SUCCEEDED(hr))
00139     {
00140         // Get print settings from PrintTaskOptions for preview, such as page description, which contains page size, imageable area, DPI.
00141         // User can obtain other print settings in the same way, such as ColorMode, NumberOfCopies, etc., which are not shown in this sample.
00142         PrintTaskOptions^ option = reinterpret_cast<PrintTaskOptions^>(docOptions);
00143         PrintPageDescription pageDesc = option->GetPageDescription(currentJobPage);
00144
00145         hr = m_dxgiPreviewTarget->InvalidatePreview();
00146
00147         // Set the total page number.
00148         if (SUCCEEDED(hr))
00149         {
00150             hr = m_dxgiPreviewTarget->SetJobPageCount(PageCountType::FinalPageCount, m_totalPages);
00151         }
00152
00153         if (SUCCEEDED(hr))
00154         {
00155             m_width = pageDesc.PageSize.Width;
00156             m_height = pageDesc.PageSize.Height;
00157
00158             m_imageableRect = D2D1::RectF(
00159                 pageDesc.ImageableRect.X,
00160                 pageDesc.ImageableRect.Y,
00161                 pageDesc.ImageableRect.X + pageDesc.ImageableRect.Width,
00162                 pageDesc.ImageableRect.Y + pageDesc.ImageableRect.Height
00163                 );
00164
00165             // Now we are ready to let MakePage to be called.
00166             m_paginateCalled = true;
00167         }
00168     }
00169
00170     return hr;
00171 }
00172
00173 // Here, desiredWidth/desiredHeight is the desired size of preview surface by print mananger in system.
00174 // The final size of the preview surface must have the same proportion as that of the desired width/height.
00175 // In this sample, we just use it as preview size and return the scale variant for surface drawing.
00176 // The size here is in DIPs.
00177 float
00178 CDocumentSource::TransformedPageSize(
00179     _In_  float                         desiredWidth,
00180     _In_  float                         desiredHeight,
00181     _Out_ Windows::Foundation::Size*    previewSize
00182     )
00183 {
00184     float scale = 1.0f;
00185
00186     if (desiredWidth > 0 && desiredHeight > 0)
00187     {
00188         previewSize->Width  = desiredWidth;
00189         previewSize->Height = desiredHeight;
00190
00191         scale = m_width / desiredWidth;
00192     }
00193     else
00194     {
00195         previewSize->Width = 0;
00196         previewSize->Height = 0;
00197     }
00198
00199     return scale;
00200 }
00201
00202 // This sample only acts upon orientation setting for an example. The orientation is read from the user selection
00203 // in the Print Experience and is then used to reflow the content in a different way.
00204 IFACEMETHODIMP
00205 CDocumentSource::MakePage(
00206     _In_ uint32 desiredJobPage,
00207     _In_ float  width,
00208     _In_ float  height
00209     )
00210 {
00211     HRESULT hr = (width > 0 && height > 0) ? S_OK : E_INVALIDARG;
00212
00213     // When desiredJobPage is JOB_PAGE_APPLICATION_DEFINED, it means a new preview begins. If the implementation here is by an async way,
00214     // for example, queue MakePage calls for preview, app needs to clean resources for previous preview before next.
00215     // In this sample, we will reset page number if Paginate() has been called.
00216     if (desiredJobPage == JOB_PAGE_APPLICATION_DEFINED && m_paginateCalled)
00217     {
00218         desiredJobPage = 1;
00219     }
00220
00221     if (SUCCEEDED(hr) && m_paginateCalled)
00222     {
00223         // Calculate the size of preview surface, according to desired width and height.
00224         Windows::Foundation::Size previewSize;
00225         float scale = TransformedPageSize(width, height, &previewSize);
00226
00227         try
00228         {
00229             m_renderer->DrawPreviewSurface(
00230                 previewSize.Width,
00231                 previewSize.Height,
00232                 scale,
00233                 m_imageableRect,
00234                 desiredJobPage,
00235                 m_dxgiPreviewTarget.Get()
00236                 );
00237         }
00238         catch (Platform::Exception^ e)
00239         {
00240             hr = e->HResult;
00241
00242             if (hr == D2DERR_RECREATE_TARGET)
00243             {
00244                 // In case of device lost, we should recover so that the device is ready to render
00245                 // the next preview page when requested. At the same time, we should propagate this
00246                 // error to the Modern Print Dialog.
00247                 m_renderer->HandleDeviceLost();
00248             }
00249         }
00250     }
00251
00252     return hr;
00253 }
00254
00255 #pragma region IPrintPreviewPageCollection Methods
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetDomainName.xaml.cpp Source File

  • User domain name

GetDomainName.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // GetDomainName.xaml.cpp
00013 // Implementation of the GetDomainName class
00014 //
00015
00016 #include "pch.h"
00017 #include "GetDomainName.xaml.h"
00018 #include <ppltasks.h>
00019
00020 using namespace Windows::System::UserProfile;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Platform;
00025 using namespace SDKSample::UserDomainName;
00026 using namespace concurrency;
00027
00028 GetDomainName::GetDomainName()
00029 {
00030     InitializeComponent();
00031 }
00032
00033 /// <summary>
00034 /// Invoked when this page is about to be displayed in a Frame.
00035 /// </summary>
00036 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00037 /// property is typically used to configure the page.</param>
00038 void GetDomainName::OnNavigatedTo(NavigationEventArgs^ e)
00039 {
00040     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00041     // as NotifyUser()
00042     rootPage = MainPage::Current;
00043 }
00044
00045
00046 void GetDomainName::GetDNSDomain_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00047 {
00048     // The user or domain administrator may disable access to personal information by apps
00049     if (UserInformation::NameAccessAllowed)
00050     {
00051         DomainResultText->Text = "Getting domain name.";
00052         create_task(UserInformation::GetDomainNameAsync()).then([this](String^ domainName)
00053         {
00054             // an empty string may be returned in any of the following circumstances:
00055             // The information cannot be retrieved from the directory
00056             // The calling user is not a member of a domain
00057             // The user or administrator has disabled the privacy setting
00058             if (domainName->IsEmpty())
00059             {
00060                 DomainResultText->Text = "No DNS domain name returned for the current user.";
00061             }
00062             else
00063             {
00064                 DomainResultText->Text = domainName;
00065             }
00066         });
00067     }
00068     else
00069     {
00070         DomainResultText->Text = "Access to user information is disabled by the user or administrator";
00071     }
00072 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ExifExtensions.cpp Source File

  • Hilo C++
  • Hilo

ExifExtensions.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "ExifExtensions.h"
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012 #include <algorithm>
00013
00014 using namespace std;
00015 using namespace Hilo;
00016 using namespace Windows::Foundation;
00017
00018 Rect ExifExtensions::RotateClockwise(Rect rect, Rect bitmapSize, float64 degrees)
00019 {
00020     auto radians = (M_PI / 180.0) * degrees;
00021
00022     auto angleSin = sin(radians);
00023     auto angleCos = cos(radians);
00024
00025     auto width = bitmapSize.Width;
00026     auto height = bitmapSize.Height;
00027
00028     // calculate rotated translation point for image
00029     auto x1 = width * angleCos;
00030     auto y1 = width * angleSin;
00031     auto x2 = width * angleCos - height*angleSin;
00032     auto y2 = width * angleSin + height*angleCos;
00033     auto x3 = -(height * angleSin);
00034     auto y3 = height * angleCos ;
00035
00036     auto minX = min(x1, min(x2, x3));
00037     auto minY = min(y1, min(y2, y3));
00038
00039     // Adjust rotate and adjust original rect bounding box
00040     auto xOrigin = (rect.X * angleCos - rect.Y * angleSin) - minX;
00041     auto yOrigin = (rect.X * angleSin + rect.Y * angleCos) - minY;
00042
00043     auto xOther = (rect.Right * angleCos - rect.Bottom * angleSin) - minX;
00044     auto yOther = (rect.Right * angleSin + rect.Bottom * angleCos) - minY;
00045
00046     Point newOrigin(static_cast<float>(min(xOrigin, xOther)),
00047         static_cast<float>(min(yOrigin, yOther)));
00048     Point newOther(static_cast<float>(max(xOrigin, xOther)),
00049         static_cast<float>(max(yOrigin, yOther)));
00050
00051     return Rect(newOrigin, newOther);
00052 }
00053
00054 unsigned int ExifExtensions::ConvertExifOrientationToDegreesRotation(ExifRotations exifOrientationFlag)
00055 {
00056     switch (exifOrientationFlag)
00057     {
00058     case ExifRotations::NotRotated:
00059         return 0;
00060     case ExifRotations::RotatedLeft:
00061         return 90;
00062     case ExifRotations::RotatedDown:
00063         return 180;
00064     case ExifRotations::RotatedRight:
00065         return 270;
00066     default:
00067         // Ignore flip/mirroring values (2, 4, 5, 7)
00068         return 0;
00069     }
00070 }
00071
00072 ExifRotations ExifExtensions::ConvertDegreesRotationToExifOrientation(unsigned int angle)
00073 {
00074     switch (angle)
00075     {
00076     case 0:
00077         return ExifRotations::NotRotated;
00078     case 90:
00079         return ExifRotations::RotatedLeft;
00080     case 180:
00081         return ExifRotations::RotatedDown;
00082     case 270:
00083         return ExifRotations::RotatedRight;
00084     default:
00085         // Ignore flip/mirroring values (2, 4, 5, 7)
00086         return ExifRotations::NotRotated;
00087     }
00088
00089 }
00090
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Level1 Member List

This is the complete list of members for Level1, including all inherited members.
__pad0__ | Level1 |
Initialize(std::vector< GameObject^> objects) override | Level1 | [virtual]
Initialize(std::vector< GameObject^> objects) override | Level1 | [virtual]
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/TextAnalysis.h Source File

  • DirectWrite vertical text

TextAnalysis.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // Contents:    Implementation of text analyzer source and sink.
00009 //
00010 //----------------------------------------------------------------------------
00011 #pragma once
00012
00013
00014 /// <summary>
00015 /// Direction for how reading progresses.
00016 /// </summary>
00017 enum ReadingDirection
00018 {
00019     ReadingDirectionLeftToRightTopToBottom = 0,
00020     ReadingDirectionRightToLeftTopToBottom = 1,
00021     ReadingDirectionLeftToRightBottomToTop = 2,
00022     ReadingDirectionRightToLeftBottomToTop = 3,
00023     ReadingDirectionTopToBottomLeftToRight = 4,
00024     ReadingDirectionBottomToTopLeftToRight = 5,
00025     ReadingDirectionTopToBottomRightToLeft = 6,
00026     ReadingDirectionBottomToTopRightToLeft = 7,
00027
00028     // Contributing bits
00029     ReadingDirectionPrimaryProgression     = 1, // False = Ltr/Ttb,    True = Rtl/Btt
00030     ReadingDirectionSecondaryProgression   = 2, // False = Ttb/Ltr,    True = Btt/Rtl
00031     ReadingDirectionPrimaryAxis            = 4, // False = Horizontal, True = Vertical
00032
00033     // Shorter Aliases
00034     ReadingDirectionEs = ReadingDirectionLeftToRightTopToBottom,
00035     ReadingDirectionSw = ReadingDirectionTopToBottomRightToLeft,
00036     ReadingDirectionWn = ReadingDirectionRightToLeftBottomToTop,
00037     ReadingDirectionNe = ReadingDirectionBottomToTopLeftToRight,
00038
00039     // A single direction
00040     ReadingDirectionE = ReadingDirectionLeftToRightTopToBottom,
00041     ReadingDirectionS = ReadingDirectionTopToBottomLeftToRight,
00042     ReadingDirectionW = ReadingDirectionRightToLeftTopToBottom,
00043     ReadingDirectionN = ReadingDirectionBottomToTopLeftToRight,
00044 };
00045
00046
00047 enum GlyphOrientationMode
00048 {
00049     GlyphOrientationModeDefault,    // rotated or upright according to script default
00050     GlyphOrientationModeStacked,    // stacked if script allows it
00051     GlyphOrientationModeTotal
00052 };
00053
00054 // Direction for how reading progresses.
00055 enum GlyphOrientation
00056 {
00057     GlyphOrientationLeftToRightTopToBottom = 0,
00058     GlyphOrientationRightToLeftTopToBottom = 1,
00059     GlyphOrientationLeftToRightBottomToTop = 2,
00060     GlyphOrientationRightToLeftBottomToTop = 3,
00061     GlyphOrientationTopToBottomLeftToRight = 4,
00062     GlyphOrientationBottomToTopLeftToRight = 5,
00063     GlyphOrientationTopToBottomRightToLeft = 6,
00064     GlyphOrientationBottomToTopRightToLeft = 7,
00065
00066     // Rotational aliases
00067     GlyphOrientationCW0                    = GlyphOrientationLeftToRightTopToBottom,
00068     GlyphOrientationCW90                   = GlyphOrientationTopToBottomRightToLeft,
00069     GlyphOrientationCW180                  = GlyphOrientationRightToLeftBottomToTop,
00070     GlyphOrientationCW270                  = GlyphOrientationBottomToTopLeftToRight,
00071
00072     // Internal shorter aliases
00073     GlyphOrientationES                     = GlyphOrientationLeftToRightTopToBottom,
00074     GlyphOrientationSW                     = GlyphOrientationTopToBottomRightToLeft,
00075     GlyphOrientationWN                     = GlyphOrientationRightToLeftBottomToTop,
00076     GlyphOrientationNE                     = GlyphOrientationBottomToTopLeftToRight,
00077     GlyphOrientationFH                     = GlyphOrientationRightToLeftTopToBottom,
00078     GlyphOrientationFV                     = GlyphOrientationLeftToRightBottomToTop,
00079
00080     // Individual bits
00081     GlyphOrientationFlipHorizontal         = 1,  // Glyph Mirrored Horizontally  (Left <-> Right)
00082     GlyphOrientationFlipVertical           = 2,  // Glyph Mirrored Vertically (Top <-> Bottom)
00083     GlyphOrientationFlipDiagonal           = 4,  // Glyph Transposed Around Diagonal
00084 };
00085
00086
00087 // Helper source/sink class for text analysis.
00088 class TextAnalysis
00089     :   public ComBase<
00090         QiList<IDWriteTextAnalysisSource1,
00091         QiList<IDWriteTextAnalysisSink1,
00092         QiList<IUnknown
00093     >>>>
00094 {
00095 public:
00096     // A single contiguous run of characters containing the same analysis results.
00097     struct Run
00098     {
00099         Run()
00100         :   textStart(),
00101             textLength(),
00102             glyphStart(),
00103             glyphCount(),
00104             bidiLevel(),
00105             script(),
00106             glyphOrientation(),
00107             isNumberSubstituted(),
00108             isSideways(),
00109             isReversed()
00110         { }
00111
00112         UINT32 textStart;   // starting text position of this run
00113         UINT32 textLength;  // number of contiguous code units covered
00114         UINT32 glyphStart;  // starting glyph in the glyphs array
00115         UINT32 glyphCount;  // number of glyphs associated with this run of text
00116         DWRITE_SCRIPT_ANALYSIS script;
00117         UINT8 bidiLevel;
00118         UINT8 glyphOrientation;
00119         bool isNumberSubstituted;
00120         bool isSideways;
00121         bool isReversed;    // reversed along primary axis (LTR->RTL, TTB->BTT)
00122
00123         inline bool ContainsTextPosition(UINT32 desiredTextPosition) const
00124         {
00125             return desiredTextPosition >= textStart
00126                 && desiredTextPosition <  textStart + textLength;
00127         }
00128
00129         inline bool operator ==(UINT32 desiredTextPosition) const
00130         {
00131             // Allows search by text position using std::find
00132             return ContainsTextPosition(desiredTextPosition);
00133         }
00134     };
00135
00136     // Single text analysis run, which points to the next run.
00137     struct LinkedRun : Run
00138     {
00139         LinkedRun()
00140         :   nextRunIndex(0)
00141         { }
00142
00143         UINT32 nextRunIndex;  // index of next run
00144     };
00145
00146 public:
00147     TextAnalysis(
00148         const wchar_t* text,
00149         UINT32 textLength,
00150         const wchar_t* localeName,
00151         IDWriteNumberSubstitution* numberSubstitution,
00152         ReadingDirection readingDirection,
00153         GlyphOrientationMode glyphOrientationMode
00154         );
00155
00156     STDMETHODIMP GenerateResults(
00157         Microsoft::WRL::ComPtr<IDWriteTextAnalyzer1> textAnalyzer,
00158         _Out_ std::vector<Run>& runs,
00159         _Out_ std::vector<DWRITE_LINE_BREAKPOINT>& breakpoints_
00160         );
00161
00162     STDMETHODIMP AnalyzeGlyphOrientation(
00163         Microsoft::WRL::ComPtr<IDWriteTextAnalyzer1> textAnalyzer,
00164         IDWriteTextAnalysisSource1* analysisSource,
00165         UINT32 textPosition,
00166         UINT32 textLength,
00167         IDWriteTextAnalysisSink1* analysisSink
00168         );
00169
00170     STDMETHODIMP AnalyzeBidi(
00171         Microsoft::WRL::ComPtr<IDWriteTextAnalyzer1> textAnalyzer,
00172         IDWriteTextAnalysisSource1* analysisSource,
00173         UINT32 firstPosition,
00174         UINT32 textLength,
00175         IDWriteTextAnalysisSink1* analysisSink
00176         );
00177
00178     // IDWriteTextAnalysisSource implementation
00179     IFACEMETHODIMP GetTextAtPosition(
00180         UINT32 textPosition,
00181         _Out_ WCHAR const** textString,
00182         _Out_ UINT32* textLength
00183         );
00184
00185     IFACEMETHODIMP GetTextBeforePosition(
00186         UINT32 textPosition,
00187         _Out_ WCHAR const** textString,
00188         _Out_ UINT32* textLength
00189         );
00190
00191     IFACEMETHODIMP_(DWRITE_READING_DIRECTION) GetParagraphReadingDirection();
00192
00193     IFACEMETHODIMP GetLocaleName(
00194         UINT32 textPosition,
00195         _Out_ UINT32* textLength,
00196         _Out_ WCHAR const** localeName
00197         );
00198
00199     IFACEMETHODIMP GetNumberSubstitution(
00200         UINT32 textPosition,
00201         _Out_ UINT32* textLength,
00202         _Out_ IDWriteNumberSubstitution** numberSubstitution
00203         );
00204
00205     IFACEMETHODIMP TextAnalysis::GetVerticalGlyphOrientation(
00206         UINT32 textPosition,
00207         _Out_ UINT32* textLength,
00208         _Out_ DWRITE_VERTICAL_GLYPH_ORIENTATION* glyphOrientation,
00209         _Out_ UINT8* bidiLevel
00210         );
00211
00212     // IDWriteTextAnalysisSink implementation
00213     IFACEMETHODIMP SetScriptAnalysis(
00214         UINT32 textPosition,
00215         UINT32 textLength,
00216         DWRITE_SCRIPT_ANALYSIS const* scriptAnalysis
00217         );
00218
00219     IFACEMETHODIMP SetLineBreakpoints(
00220         UINT32 textPosition,
00221         UINT32 textLength,
00222         const DWRITE_LINE_BREAKPOINT* lineBreakpoints
00223         );
00224
00225     IFACEMETHODIMP SetBidiLevel(
00226         UINT32 textPosition,
00227         UINT32 textLength,
00228         UINT8 explicitLevel,
00229         UINT8 resolvedLevel
00230         );
00231
00232     IFACEMETHODIMP SetNumberSubstitution(
00233         UINT32 textPosition,
00234         UINT32 textLength,
00235         IDWriteNumberSubstitution* numberSubstitution
00236         );
00237
00238     IFACEMETHODIMP SetGlyphOrientation(
00239         UINT32 textPosition,
00240         UINT32 textLength,
00241         DWRITE_GLYPH_ORIENTATION_ANGLE glyphOrientationAngle,
00242         UINT8 adjustedBidiLevel,
00243         BOOL isSideways,
00244         BOOL isRightToLeft
00245         );
00246
00247     // Helpers
00248 protected:
00249     LinkedRun& FetchNextRun(_Inout_ UINT32* textLength);
00250
00251     void SetCurrentRun(UINT32 textPosition);
00252
00253     void SplitCurrentRun(UINT32 splitPosition);
00254
00255 protected:
00256     // Input
00257     // (weak references are fine here, since this class is a transient
00258     //  stack-based helper that doesn't need to copy data)
00259     UINT32 m_textLength;
00260     const wchar_t* m_text;
00261     const wchar_t* m_localeName;
00262     IDWriteNumberSubstitution* m_numberSubstitution;
00263     ReadingDirection m_readingDirection;
00264     GlyphOrientationMode m_glyphOrientationMode;
00265
00266     // Current processing state
00267     UINT32 m_currentPosition;
00268     UINT32 m_currentRunIndex;
00269
00270     // Output
00271     std::vector<LinkedRun> m_runs;
00272     std::vector<DWRITE_LINE_BREAKPOINT> m_breakpoints;
00273 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario6.xaml.cpp Source File

  • XAML WebView control

Scenario6.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.cpp
00013 // Implementation of the Scenario6 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario6.xaml.h"
00018
00019 using namespace SDKSample::WebViewControl;
00020
00021 using namespace Windows::Foundation;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Media;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 Scenario6::Scenario6()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 // Invoked when this page is about to be displayed in a Frame.
00033 void Scenario6::OnNavigatedTo(NavigationEventArgs^ e)
00034 {
00035     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00036     // as NotifyUser()
00037     rootPage = MainPage::Current;
00038
00039   // Select on of the items in the ComboBox
00040   ComboBox1->SelectedIndex = 0;
00041
00042   // Ensure that our Rectangle used to simulate the WebView is not shown initially
00043   Rect1->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044
00045   WebView6->Navigate(ref new Uri("http://www.bing.com"));
00046 }
00047
00048
00049 // Click handler for the 'Solution' button.
00050 void SDKSample::WebViewControl::Scenario6::Solution_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00051 {
00052   Rect1->Visibility = Windows::UI::Xaml::Visibility::Visible;
00053 }
00054
00055
00056 /// <summary>
00057 /// When the ComboBox opens we have an airspace conflict and the ComboBox cannot render its content over
00058 /// the WebView.  Therefore, we create a WebViewBrush and set the WebView as its source and call the Redraw() method
00059 /// which will take a visual snapshot of the WebView.  We then use that brush to fill our Rectangle.
00060 /// </summary>
00061 /// <param name="sender"></param>
00062 /// <param name="e"></param>
00063 void SDKSample::WebViewControl::Scenario6::ComboBox1_DropDownOpened(Platform::Object^ sender, Platform::Object^ e)
00064 {
00065   if (Rect1->Visibility == Windows::UI::Xaml::Visibility::Visible)
00066             {
00067                 WebViewBrush^ b = ref new WebViewBrush();
00068                 b->SourceName = "WebView6";
00069                 b->Redraw();
00070                 Rect1->Fill = b;
00071                 WebView6->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00072             }
00073 }
00074
00075 /// <summary>
00076 /// When the ComboBox is closed we no longer need the simulated WebView so we put things back the way they were
00077 /// </summary>
00078 /// <param name="sender"></param>
00079 /// <param name="e"></param>
00080 void SDKSample::WebViewControl::Scenario6::ComboBox1_DropDownClosed(Platform::Object^ sender, Platform::Object^ e)
00081 {
00082
00083   WebView6->Visibility = Windows::UI::Xaml::Visibility::Visible;
00084     Rect1->Fill = ref new SolidColorBrush(Windows::UI::Colors::Transparent);
00085 }
00086
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/Constants.h Source File

  • Windows account authorization

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 using namespace Windows::UI::Xaml::Controls;
00016
00017 namespace SDKSample
00018 {
00019     public value struct Scenario
00020     {
00021         Platform::String^ Title;
00022         Platform::String^ ClassName;
00023     };
00024
00025     partial ref class MainPage
00026     {
00027     public:
00028         static property Platform::String^ FEATURE_NAME
00029         {
00030             Platform::String^ get()
00031             {
00032                 return ref new Platform::String(L"Microsoft Account Authentication");
00033             }
00034         }
00035
00036         static property Platform::Array<Scenario>^ scenarios
00037         {
00038             Platform::Array<Scenario>^ get()
00039             {
00040                 return scenariosInner;
00041             }
00042         }
00043
00044     private:
00045         static Platform::Array<Scenario>^ scenariosInner;
00046     };
00047
00048 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::ImageNavigationData Member List

This is the complete list of members for Hilo::ImageNavigationData, including all inherited members.
GetDateQuery() | Hilo::ImageNavigationData |
GetFileDate() const | Hilo::ImageNavigationData |
GetFilePath() const | Hilo::ImageNavigationData |
ImageNavigationData(IPhoto^photo) | Hilo::ImageNavigationData |
ImageNavigationData(Platform::String^serializationString) | Hilo::ImageNavigationData |
m_dateQuery | Hilo::ImageNavigationData | [private]
m_fileDate | Hilo::ImageNavigationData | [private]
m_filePath | Hilo::ImageNavigationData | [private]
SerializeToString() | Hilo::ImageNavigationData |
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/DirectXApp.h Source File

  • XInput audio controller playback

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "AudioController.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032     void OnVisibilityChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(
00038         _In_ Platform::Object^ sender
00039         );
00040
00041     void OnActivated(
00042         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00043         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00044         );
00045
00046     void OnSuspending(
00047         _In_ Platform::Object^ sender,
00048         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00049         );
00050
00051     void OnResuming(
00052         _In_ Platform::Object^ sender,
00053         _In_ Platform::Object^ args
00054         );
00055
00056     void OnWindowClosed(
00057         _In_ Windows::UI::Core::CoreWindow^ sender,
00058         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00059         );
00060
00061     AudioController^ m_renderer;
00062     bool m_windowClosed;
00063     bool m_windowVisible;
00064 };
00065
00066 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00067 {
00068 public:
00069     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00070 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Physics.cpp Source File

  • DirectX marble maze game

Physics.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Microsoft::WRL;
00011 using namespace DirectX;
00012
00013 #include "Primitives.h"
00014 #include "Collision.h"
00015 #include "Physics.h"
00016
00017 static const XMVECTOR wallFrictionCoeff = XMVectorReplicate(WallFriction);
00018
00019 // Updates the physics simulation for the timestep provided.
00020 void Physics::UpdatePhysicsSimulation(float deltaT)
00021 {
00022     // If the simulation is not advancing, do nothing.
00023     if (deltaT >= 0.0f && deltaT <= FLT_EPSILON)
00024     {
00025         return;
00026     }
00027
00028     // Clamp the maximum timestep in case we're debugging.
00029     deltaT = min(deltaT, MaxPhysicsTimestep);
00030
00031     // Keep the previous position
00032     m_previousPosition = m_position;
00033
00034     // Update physics with fixed timestep, multiple iterations up to MaxPhysicsTimestep total
00035     m_accumulatedTime += deltaT;
00036
00037     while (m_accumulatedTime >= PhysicsTimestep)
00038     {
00039         m_accumulatedTime -= PhysicsTimestep;
00040         ApplyForces();  // Gravity.
00041         IntegrateSimulation(PhysicsTimestep);    // Integrate for this frame.
00042         FindInitialCollisions(PhysicsTimestep);
00043         HandleCollisions(PhysicsTimestep);
00044     }
00045
00046     CalculateCurrentRoomSize();
00047 }
00048
00049 // Updates the forces acting on the sphere, including acceleration due to gravity and friction.
00050 void Physics::ApplyForces()
00051 {
00052     const XMVECTOR gravity = XMLoadFloat3(&m_gravity);
00053
00054     // We only have gravity acting on the ball - so this step is really simple.
00055     // More forces could be added here on a per-frame basis.
00056
00057     XMStoreFloat3(&m_acceleration, gravity);
00058 }
00059
00060 Physics::Physics()
00061 {
00062     ZeroMemory(&m_velDueToAccel, sizeof(XMFLOAT3));
00063     ZeroMemory(&m_position, sizeof(m_position));
00064     ZeroMemory(&m_velocity, sizeof(m_velocity));
00065     ZeroMemory(&m_velDueToAccel, sizeof(m_velDueToAccel));
00066     ZeroMemory(&m_acceleration, sizeof(m_acceleration));
00067     ZeroMemory(&m_gravity, sizeof(m_gravity));
00068     ZeroMemory(&m_maxCollisionSpeed, sizeof(m_maxCollisionSpeed));
00069     ZeroMemory(&m_maxRollingSpeed, sizeof(m_maxRollingSpeed));
00070
00071     m_radius = 0.0f;
00072     m_accumulatedTime = 0.0f;
00073
00074     // Default the room size in case room size is static.
00075     m_currentRoomSize = 300.0f;
00076 }
00077
00078 // Integrates the acceleration to give the ball's new velocity, and the velocity to give the new position.
00079 void Physics::IntegrateSimulation(float deltaT)
00080 {
00081     XMVECTOR deltaTime = XMVectorReplicate(deltaT);
00082     XMVECTOR position = XMLoadFloat3(&m_position);
00083     XMVECTOR velocity = XMLoadFloat3(&m_velocity);
00084     XMVECTOR acceleration = XMLoadFloat3(&m_acceleration);
00085
00086     // Calculate new velocity due to acceleration for the time-slice.
00087
00088     XMVECTOR velDueToAccel =  acceleration * deltaTime;
00089     XMStoreFloat3(&m_velDueToAccel, velDueToAccel);
00090     velocity = velocity + velDueToAccel;
00091
00092     // const XMVECTOR vHalf = {0.5f, 0.5f, 0.5f, 0.5f};
00093     XMVECTOR newPosition = position + velocity * deltaTime;
00094     XMStoreFloat3(&m_position, newPosition);
00095
00096     // Damping & stabilization
00097
00098 #if defined(ENABLE_VELOCITY_DAMPING)
00099
00100     // Continuously drain energy from the ball.
00101
00102     XMVECTOR speed = XMVector3Length(velocity);
00103
00104     const XMVECTOR velDampAmount = XMVectorReplicate(Damping);
00105     XMVECTOR velUnit = XMVector3Normalize(velocity);
00106
00107     XMVECTOR dampTotal = XMVectorMin(velDampAmount, speed);
00108     velocity = velocity - (dampTotal * velUnit);
00109
00110 #endif // defined(ENABLE_VELOCITY_DAMPING)
00111
00112     // Make sure velocity stays within a safe range and doesn't spiral off, by clamping it.
00113     XMVECTOR velSpeed = XMVector3Length(velocity);
00114
00115     const XMVECTOR maxVelocity = XMVectorReplicate(MaxVelocity);
00116     velSpeed = XMVectorMin(maxVelocity, velSpeed);
00117     velocity = velSpeed * XMVector3Normalize(velocity);
00118
00119 #if defined(ENABLE_VELOCITY_CLAMP_TO_ZERO)
00120
00121     // If velocity is small enough (-1 <= v <= 1), set it to 0.
00122
00123     const XMVECTOR velSq = XMVector3LengthSq(velocity);
00124
00125     const XMVECTOR minVelocitySq = XMVectorReplicate(MinVelocity * MinVelocity);
00126
00127     const XMVECTOR select = XMVectorLess(velSq, minVelocitySq);
00128     velocity = XMVectorSelect(velocity, XMVectorZero(), select);
00129
00130 #endif // defined(ENABLE_VELOCITY_CLAMP_TO_ZERO)
00131
00132     XMStoreFloat3(&m_velocity, velocity);
00133 }
00134
00135 // Finds the initial set of collisions
00136 BOOL Physics::FindInitialCollisions(float deltaT)
00137 {
00138     XMVECTOR velocity = XMLoadFloat3(&m_velocity);
00139     Sphere bounds(m_position, m_radius);
00140     return m_collision->BuildCollisionListForSphere(bounds, velocity);
00141 }
00142
00143 // Handles elastic collisions, static contacts (resting against surface) and moving interpenetrating objects
00144 // out of each other. This is all done as a single step, as it improves the mathematical stability of the
00145 // engine.
00146 void Physics::HandleCollisions(float deltaT)
00147 {
00148     XMVECTOR velDueToGrav = XMLoadFloat3(&m_velDueToAccel);
00149     XMVECTOR velocity = XMLoadFloat3(&m_velocity);
00150     XMVECTOR position = XMLoadFloat3(&m_position);
00151     XMVECTOR radius = XMVectorReplicatePtr(&m_radius);
00152     XMVECTOR maxRollingSpeed = XMVectorZero();
00153     XMVECTOR maxCollisionSpeed = XMVectorZero();
00154     XMVECTOR deltaTime = XMVectorReplicate(deltaT);
00155
00156     const size_t MAX_COLLISION_ITERATIONS = 8;
00157     for (size_t i = 0; i < MAX_COLLISION_ITERATIONS; ++i)
00158     {
00159         // Find the collision with the biggest intrusion into the mesh, that is facing in the opposite direction to the
00160         // way the ball is moving (i.e. has a positive closing velocity).
00161         Contact* contact = m_collision->FindWorstInterpenetration();
00162         if (contact == nullptr)
00163             break;
00164
00165         XMVECTOR surfaceNormal = contact->GetSurfaceNormal();
00166
00167         XMVECTOR velocityDotNormal = XMVector3Dot(surfaceNormal, velocity);
00168         XMVECTOR velGravDotNormal = XMVector3Dot(surfaceNormal, velDueToGrav);
00169
00170         // Estimate how much the ball would have fallen into the mesh due to gravity this frame, if it started out
00171         // resting against it. If it's almost the same as the actual penetration, we must have been resting to start
00172         // with, so we can immediately cancel out this contribution.
00173         XMVECTOR penetrationDistance = XMVectorReplicatePtr(&contact->penetrationDistance);
00174         XMVECTOR distDueToGrav = velGravDotNormal * deltaTime;
00175         const XMVECTOR tolerance = XMVectorSet(0.1f, 0.1f, 0.1f, 0.1f);
00176         if (XMVector3NearEqual(penetrationDistance, distDueToGrav, tolerance))
00177         {
00178             // Contact
00179
00180             // Kill velocity in surface-normal direction entirely.
00181             velocity = velocity - surfaceNormal * velocityDotNormal;
00182
00183             XMVECTOR speed = XMVector3Length(velocity);
00184             XMVECTOR velocityDir = XMVector3Normalize(velocity); // could optimize...
00185
00186             // Find acceleration into surface
00187             XMVECTOR accel = XMLoadFloat3(&m_acceleration);
00188             XMVECTOR ADotN = XMVector3Dot(accel, surfaceNormal);
00189             XMVECTOR select = XMVectorLessOrEqual(ADotN, XMVectorZero());
00190             XMVECTOR accelSurface = XMVectorSelect(XMVectorZero(), -ADotN, select);
00191
00192             // Handle friction
00193             XMVECTOR frictionResponse =  accelSurface * wallFrictionCoeff * deltaTime;
00194             velocity = velocity - velocityDir * XMVectorMin(speed, frictionResponse);
00195
00196             maxRollingSpeed = XMVectorMax(XMVector3LengthSq(velocityDir * velocity), maxRollingSpeed);
00197
00198             // Make sure we're no longer in the mesh.
00199             position = contact->Resolve(position, radius);
00200         }
00201         else
00202         {
00203             // Elastic collision - reflect our velocity in the direction of the normal.
00204             float negRestitutionScalar = - (1.0f + WallRestitutionCoefficient);
00205             XMVECTOR negRestitution = XMVectorReplicate(negRestitutionScalar);
00206
00207             // Keep track of max collision speed for the audio sim.
00208             maxCollisionSpeed = XMVectorMax(maxCollisionSpeed, velocityDotNormal * velocityDotNormal);
00209
00210             // Update the velocity.
00211             velocity = velocity + (negRestitution * velocityDotNormal * surfaceNormal);
00212
00213             // Make sure we're no longer in the mesh.
00214             position = contact->Resolve(position, radius);
00215         }
00216
00217         // Remove this contact from consideration for this iteration.
00218         contact->Invalidate();
00219
00220         // Update the penetration of the ball.
00221         m_collision->UpdateInterpenetrations(position, radius, velocity);
00222     }
00223
00224     XMStoreFloat3(&m_velocity, velocity);
00225     XMStoreFloat3(&m_position, position);
00226     XMStoreFloat3(&m_maxRollingSpeed, XMVectorSqrt(maxRollingSpeed));
00227     XMStoreFloat3(&m_maxCollisionSpeed, XMVectorSqrt(maxCollisionSpeed));
00228 }
00229
00230 // Calculates the size of the current room, used to determine reverb parameters.
00231 // This function calculates the size of the current room, using both a square and a diamond raycast,
00232 // which allows for smoother transitions when rounding corners.
00233 void Physics::CalculateCurrentRoomSize()
00234 {
00235 #if !defined(DISABLE_RAYCAST_REVERB)
00236     static BOOL squarePattern = true;
00237     float wallDistances[4] = {FLT_MAX, FLT_MAX, FLT_MAX, FLT_MAX};
00238     XMVECTOR position = XMLoadFloat3(&m_position);
00239     size_t triCount = m_collision->m_wallTriList.size();
00240     XMVECTOR rayDirections[4];
00241     if (squarePattern)
00242     {
00243         rayDirections[0] = XMVectorSet( 0.0f,  1.0f, 0.0f, 0.0f);    // North
00244         rayDirections[1] = XMVectorSet( 0.0f, -1.0f, 0.0f, 0.0f);    // South
00245         rayDirections[2] = XMVectorSet(-1.0f,  0.0f, 0.0f, 0.0f);    // East
00246         rayDirections[3] = XMVectorSet( 1.0f,  0.0f, 0.0f, 0.0f);    // West
00247     }
00248     else
00249     {
00250         rayDirections[0] = XMVectorSet( 0.5f, -0.5f, 0.0f, 0.0f);    // NE
00251         rayDirections[1] = XMVectorSet( 0.5f,  0.5f, 0.0f, 0.0f);    // NW
00252         rayDirections[2] = XMVectorSet(-0.5f, -0.5f, 0.0f, 0.0f);    // SE
00253         rayDirections[3] = XMVectorSet(-0.5f,  0.5f, 0.0f, 0.0f);    // SW
00254     }
00255     float distance = 0.0f;
00256
00257     // Loop through all triangles in the mesh, looking for intersections with a cast ray.
00258     for (size_t i = 0; i < triCount; ++i)
00259     {
00260         XMVECTOR A = XMLoadFloat3(&m_collision->m_wallTriList[i].A);
00261         XMVECTOR B = XMLoadFloat3(&m_collision->m_wallTriList[i].B);
00262         XMVECTOR C = XMLoadFloat3(&m_collision->m_wallTriList[i].C);
00263
00264         // Loop through the cardinal directions, testing this triangle to see if it's in the path of a cast ray.
00265         for (int j = 0; j < 4; j++)
00266         {
00267             if (IntersectRayTriangle(position, rayDirections[j], A, B, C, &distance))
00268             {
00269                 if (wallDistances[j] > distance)
00270                 {
00271                     wallDistances[j] = distance;
00272                 }
00273             }
00274
00275         }
00276     }
00277
00278     if (squarePattern)
00279     {
00280         memcpy(&m_wallDistances, wallDistances, 4*sizeof(float));
00281     }
00282     else
00283     {
00284         memcpy(&m_wallDistances[4], wallDistances, 4*sizeof(float));
00285     }
00286
00287     // Default the room size to 1000.0f
00288     float roomSize = 1000.0f;
00289     for (int i = 0; i < 8; i++)
00290     {
00291         if (m_wallDistances[i] == FLT_MAX) // Some walls will not exist if the marble is outside.
00292         {
00293             m_wallDistances[i] = 1000.0f;
00294         }
00295     }
00296
00297     // Calculate the size of the room, averaging the rectangular with the diagonal measurments.
00298     roomSize = sqrt(
00299         ((m_wallDistances[0] + m_wallDistances[1]) * (m_wallDistances[2]+m_wallDistances[3]) +
00300          (m_wallDistances[4] + m_wallDistances[5]) * (m_wallDistances[6]+m_wallDistances[7]))
00301         / 2.0f
00302         );
00303
00304     if (roomSize > 1000.0f)
00305     {
00306         roomSize = 1000.0f;
00307     }
00308
00309     m_currentRoomSize = roomSize;
00310     squarePattern = !squarePattern;
00311 #endif
00312 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/ParametrizedTemplate.xaml.cpp Source File

  • Date and time formatting

ParametrizedTemplate.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ParametrizedTemplate.xaml.cpp
00013 // Implementation of the ParametrizedTemplate class
00014 //
00015
00016 #include "pch.h"
00017 #include "ParametrizedTemplate.xaml.h"
00018
00019 using namespace SDKSample::DateTimeFormatting;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Platform;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Foundation::Collections;
00027 using namespace Windows::Globalization;
00028 using namespace Windows::Globalization::DateTimeFormatting;
00029
00030
00031 ParametrizedTemplate::ParametrizedTemplate()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void ParametrizedTemplate::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046 }
00047
00048 void SDKSample::DateTimeFormatting::ParametrizedTemplate::Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00049 {
00050   // This scenario uses the Windows.Globalization.DateTimeFormatting.DateTimeFormatter class
00051   // to format a date/time by specifying a template via parameters.  Note that the current application language
00052   // language and region value will determine the pattern of the date returned based on the
00053   // specified parts.
00054
00055   //Get the current application context language
00056   String^ currentLanguage = ApplicationLanguages::Languages->GetAt(0);
00057
00058     // Formatters for dates and times
00059     Array<DateTimeFormatter^> ^dateFormatters = {
00060     ref new DateTimeFormatter(
00061       YearFormat::Full,
00062       MonthFormat::Abbreviated,
00063       DayFormat::Default,
00064       DayOfWeekFormat::Abbreviated),
00065
00066     ref new DateTimeFormatter(
00067       YearFormat::Abbreviated,
00068       MonthFormat::Abbreviated,
00069       DayFormat::Default,
00070       DayOfWeekFormat::None),
00071
00072     ref new DateTimeFormatter(
00073       YearFormat::Full,
00074       MonthFormat::Full,
00075       DayFormat::None,
00076       DayOfWeekFormat::None),
00077
00078         ref new DateTimeFormatter(
00079       YearFormat::None,
00080       MonthFormat::Full,
00081       DayFormat::Default,
00082       DayOfWeekFormat::None),
00083
00084     ref new DateTimeFormatter(
00085       HourFormat::Default,
00086       MinuteFormat::Default,
00087       SecondFormat::Default),
00088
00089     ref new DateTimeFormatter(
00090       HourFormat::Default,
00091       MinuteFormat::Default,
00092       SecondFormat::None),
00093
00094     ref new DateTimeFormatter(
00095       HourFormat::Default,
00096       MinuteFormat::None,
00097       SecondFormat::None)
00098     };
00099
00100   // Obtain the date that will be formatted.
00101   Windows::Globalization::Calendar^ cal = ref new Windows::Globalization::Calendar();
00102     Windows::Foundation::DateTime dateToFormat = cal->GetDateTime();
00103
00104     // Keep the results here
00105     String^ results = "";
00106   results = results + "Current application context language: " + currentLanguage + "\n\n";
00107
00108   // Generate the results.
00109     for (unsigned int i = 0; i < dateFormatters->Length; i++)
00110     {
00111         // Perform the actual formatting.
00112         try
00113         {
00114             results = results + dateFormatters[i]->Template + ": " + dateFormatters[i]->Format(dateToFormat) + "\n";
00115         }
00116         catch(Platform::Exception^)
00117         {
00118             // Retrieve and display formatter properties.
00119             results = results + "Unable to format using formatter with template: " +
00120                 dateFormatters[i]->Template + ", language: " +
00121                 dateFormatters[i]->Languages->GetAt(0) + ", region: " +
00122                 dateFormatters[i]->GeographicRegion + ", calendar: " +
00123                 dateFormatters[i]->Calendar + ", clock:" +
00124                 dateFormatters[i]->Clock + "\n";
00125         }
00126     }
00127
00128   // Display the results.
00129     rootPage->NotifyUser(results, NotifyType::StatusMessage);
00130 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioInput4.xaml.cs Source File

  • Media extensions
  • C#,C++

ScenarioInput4.xaml.cs

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 using System;
00009 using System.Linq;
00010 using System.Collections.Generic;
00011 using Windows.Foundation;
00012 using Windows.Foundation.Collections;
00013 using Windows.Graphics.Display;
00014 using Windows.UI.ViewManagement;
00015 using Windows.UI.Xaml;
00016 using Windows.UI.Xaml.Controls;
00017 using Windows.UI.Xaml.Controls.Primitives;
00018 using Windows.UI.Xaml.Data;
00019 using Windows.UI.Xaml.Input;
00020 using Windows.UI.Xaml.Media;
00021 using Windows.UI.Xaml.Navigation;
00022 using SDKTemplateCS;
00023
00024 namespace MediaExtensionsCS
00025 {
00026     public sealed partial class ScenarioInput4 : Page
00027     {
00028         // A pointer back to the main page which is used to gain access to the input and output frames and their content.
00029         MainPage rootPage = null;
00030         MediaElement outputVideo;
00031
00032         public ScenarioInput4()
00033         {
00034             InitializeComponent();
00035         }
00036
00037         #region Template-Related Code - Do not remove
00038         protected override void OnNavigatedTo(NavigationEventArgs e)
00039         {
00040             // Get a pointer to our main page
00041             rootPage = e.Parameter as MainPage;
00042
00043             // We want to be notified with the OutputFrame is loaded so we can get to the content.
00044             rootPage.OutputFrameLoaded += new System.EventHandler(rootPage_OutputFrameLoaded);
00045         }
00046
00047         protected override void OnNavigatedFrom(NavigationEventArgs e)
00048         {
00049             rootPage.OutputFrameLoaded -= new System.EventHandler(rootPage_OutputFrameLoaded);
00050         }
00051
00052         #endregion
00053
00054         #region Event handlers
00055         void rootPage_OutputFrameLoaded(object sender, object e)
00056         {
00057             // At this point, we know that the Output Frame has been loaded and we can go ahead
00058             // and reference elements in the page contained in the Output Frame.
00059
00060             // Get a pointer to the content within the OutputFrame.
00061             Page outputFrame = (Page)rootPage.OutputFrame.Content;
00062
00063             // Go find the elements that we need for this scenario.
00064             outputVideo = outputFrame.FindName("Video") as MediaElement;
00065         }
00066
00067         /// <summary>
00068         /// This is the click handler for the 'OpenGrayscale' button.
00069         /// </summary>
00070         /// <param name="sender"></param>
00071         /// <param name="e"></param>
00072         private void OpenGrayscale_Click(object sender, RoutedEventArgs e)
00073         {
00074             outputVideo.RemoveAllEffects();
00075             outputVideo.AddVideoEffect("GrayscaleTransform.GrayscaleEffect", true, null);
00076
00077             rootPage.PickSingleFileAndSet(new string[] { ".mp4", ".wmv", ".avi" }, outputVideo);
00078         }
00079
00080         /// <summary>
00081         /// This is the click handler for the 'OpenFisheye' button.
00082         /// </summary>
00083         /// <param name="sender"></param>
00084         /// <param name="e"></param>
00085         private void OpenFisheye_Click(object sender, RoutedEventArgs e)
00086         {
00087             OpenVideoWithPolarEffect("Fisheye");
00088         }
00089
00090         /// <summary>
00091         /// This is the click handler for the 'OpenPinch' button.
00092         /// </summary>
00093         /// <param name="sender"></param>
00094         /// <param name="e"></param>
00095         private void OpenPinch_Click(object sender, RoutedEventArgs e)
00096         {
00097             OpenVideoWithPolarEffect("Pinch");
00098         }
00099
00100         /// <summary>
00101         /// This is the click handler for the 'OpenWarp' button.
00102         /// </summary>
00103         /// <param name="sender"></param>
00104         /// <param name="e"></param>
00105         private void OpenWarp_Click(object sender, RoutedEventArgs e)
00106         {
00107             OpenVideoWithPolarEffect("Warp");
00108         }
00109
00110         /// <summary>
00111         /// This is the click handler for the 'OpenInvert' button.
00112         /// </summary>
00113         /// <param name="sender"></param>
00114         /// <param name="e"></param>
00115         private void OpenInvert_Click(object sender, RoutedEventArgs e)
00116         {
00117             outputVideo.RemoveAllEffects();
00118             outputVideo.AddVideoEffect("InvertTransform.InvertEffect", true, null);
00119
00120             rootPage.PickSingleFileAndSet(new string[] { ".mp4", ".wmv", ".avi" }, outputVideo);
00121         }
00122
00123         /// <summary>
00124         /// This is the click handler for the 'Stop' button.
00125         /// </summary>
00126         /// <param name="sender"></param>
00127         /// <param name="e"></param>
00128         private void Stop_Click(object sender, RoutedEventArgs e)
00129         {
00130             outputVideo.Source = null;
00131         }
00132         #endregion
00133
00134         private void OpenVideoWithPolarEffect(string effectName)
00135         {
00136             outputVideo.RemoveAllEffects();
00137             PropertySet configuration = new PropertySet();
00138             configuration.Add("effect", effectName);
00139             outputVideo.AddVideoEffect("PolarTransform.PolarEffect", true, configuration);
00140
00141             rootPage.PickSingleFileAndSet(new string[] { ".mp4", ".wmv", ".avi" }, outputVideo);
00142         }
00143     }
00144 }
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Helpers Member List

This is the complete list of members for SDKSample::Helpers, including all inherited members.
ErrorMessage enum value | SDKSample::Helpers |
NotifyType enum name | SDKSample::Helpers |
ReplaceAll(std::wstring &value, _In_z_ const char16 *from, _In_z_ const char16 *to) | SDKSample::Helpers | [inline, static]
ScenarioCompleted(Windows::UI::Xaml::Controls::Button^startButton, Windows::UI::Xaml::Controls::Button^cancelButton) | SDKSample::Helpers | [inline, static]
ScenarioStarted(Windows::UI::Xaml::Controls::Button^startButton, Windows::UI::Xaml::Controls::Button^cancelButton) | SDKSample::Helpers | [inline, static]
StatusMessage enum value | SDKSample::Helpers |
Trim(Platform::String^s) | SDKSample::Helpers | [inline, static]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/common/LayoutAwarePage.cpp Source File

  • Accelerometer sensor
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/App.xaml.cpp Source File

  • Association launching

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.cpp
00010 // Implementation of the App.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "App.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::ApplicationModel;
00020 using namespace Windows::ApplicationModel::Activation;
00021 using namespace CppSamplesUtils;
00022 using namespace AssociationLaunching;
00023 using namespace Windows::UI::Xaml::Interop;
00024
00025 App::App()
00026 {
00027     InitializeComponent();
00028     this->Suspending += ref new SuspendingEventHandler(this, &AssociationLaunching::App::OnSuspending);
00029 }
00030
00031 App::~App()
00032 {
00033 }
00034
00035 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ args)
00036 {
00037     auto deferral = args->SuspendingOperation->GetDeferral();
00038     SuspensionManager::StartSaveTask().then([=]() {
00039         deferral->Complete();
00040     });
00041 }
00042
00043 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args)
00044 {
00045     if (args->PreviousExecutionState == ApplicationExecutionState::Terminated)
00046     {
00047         SuspensionManager::StartRestoreTask().then([=]()
00048         {
00049             auto rootFrame = ref new Frame();
00050             TypeName pageType = { "AssociationLaunching.MainPage", TypeKind::Custom };
00051             rootFrame->Navigate(pageType);
00052             Window::Current->Content = rootFrame;
00053             auto rootPage = safe_cast<MainPage^>(rootFrame->Content);
00054             rootPage->FileEvent = nullptr;
00055             rootPage->ProtocolEvent = nullptr;
00056
00057             Window::Current->Activate();
00058         });
00059     }
00060     else
00061     {
00062         auto rootFrame = ref new Frame();
00063         TypeName pageType = { "AssociationLaunching.MainPage", TypeKind::Custom };
00064         rootFrame->Navigate(pageType);
00065         Window::Current->Content = rootFrame;
00066         auto rootPage = safe_cast<MainPage^>(rootFrame->Content);
00067         rootPage->FileEvent = nullptr;
00068         rootPage->ProtocolEvent = nullptr;
00069
00070         Window::Current->Activate();
00071     }
00072 }
00073
00074 // Handle file activations.
00075 void App::OnFileActivated(Windows::ApplicationModel::Activation::FileActivatedEventArgs^ args)
00076 {
00077     auto rootFrame = ref new Frame();
00078     TypeName pageType = { "AssociationLaunching.MainPage", TypeKind::Custom };
00079     rootFrame->Navigate(pageType);
00080     Window::Current->Content = rootFrame;
00081     auto rootPage = safe_cast<MainPage^>(rootFrame->Content);
00082     rootPage->FileEvent = args;
00083     rootPage->ProtocolEvent = nullptr;
00084
00085     Window::Current->Activate();
00086 }
00087
00088 // Handle protocol activations.
00089 void App::OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^ args)
00090 {
00091     auto rootFrame = ref new Frame();
00092     TypeName pageType = { "AssociationLaunching.MainPage", TypeKind::Custom };
00093     rootFrame->Navigate(pageType);
00094     Window::Current->Content = rootFrame;
00095
00096     if (args->Kind == Windows::ApplicationModel::Activation::ActivationKind::Protocol)
00097     {
00098         auto rootPage = safe_cast<MainPage^>(rootFrame->Content);
00099         rootPage->ProtocolEvent = safe_cast<Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs^>(args);
00100         rootPage->FileEvent = nullptr;
00101     }
00102
00103     Window::Current->Activate();
00104 }
Generated on Sat Nov 23 2024 16:07:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/SharePage.h Source File

  • Sharing content source app

SharePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SharePage.h
00013 // Declaration of the SharePage class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.xaml.h"
00020
00021 namespace SDKSample
00022 {
00023     namespace Common
00024     {
00025         [Windows::Foundation::Metadata::WebHostHidden]
00026         public ref class SharePage : SDKSample::Common::LayoutAwarePage
00027         {
00028         protected:
00029             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00031             void ShowUIButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00032             virtual bool GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^ request);
00033
00034         private:
00035             Windows::Foundation::EventRegistrationToken dataRequestedToken;
00036
00037             void OnDataRequested(Windows::ApplicationModel::DataTransfer::DataTransferManager^ sender, Windows::ApplicationModel::DataTransfer::DataRequestedEventArgs^ e);
00038         };
00039     }
00040 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario4.xaml.h Source File

  • XAML FlipView control

Scenario4.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024   namespace FlipViewCPP
00025   {
00026     /// <summary>
00027     /// An empty page that can be used on its own or navigated to within a Frame.
00028     /// </summary>
00029     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00030     public ref class Scenario4 sealed
00031     {
00032     public:
00033       Scenario4();
00034
00035     protected:
00036       virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037     private:
00038       MainPage^ rootPage;
00039     };
00040   }
00041 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario5.xaml.h Source File

  • XAML text editing

Scenario5.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario5.xaml.h
00013 // Declaration of the Scenario5 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario5.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace TextEditing
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario5 sealed
00031         {
00032         public:
00033             Scenario5();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Other_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ScenarioMultiple.xaml.cpp Source File

  • Contact Picker app

ScenarioMultiple.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ScenarioMultiple.xaml.cpp
00013 // Implementation of the ScenarioMultiple class
00014 //
00015 #include "pch.h"
00016 #include "ScenarioMultiple.xaml.h"
00017
00018 using namespace ContactPicker;
00019 using namespace concurrency;
00020 using namespace Platform;
00021 using namespace Windows::ApplicationModel;
00022 using namespace Windows::Foundation::Collections;
00023 using namespace Windows::Storage::Streams;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Media::Imaging;
00027
00028 ScenarioMultiple::ScenarioMultiple()
00029 {
00030     InitializeComponent();
00031     PickContactsButton->Click += ref new RoutedEventHandler(this, &ScenarioMultiple::PickContactsButton_Click);
00032 }
00033
00034 void ScenarioMultiple::PickContactsButton_Click(Object^ sender, RoutedEventArgs^ e)
00035 {
00036     MainPage^ page = MainPage::Current;
00037
00038     if (page->EnsureUnsnapped())
00039     {
00040         auto contactPicker = ref new Contacts::ContactPicker();
00041         contactPicker->CommitButtonText = "Select";
00042
00043         create_task(contactPicker->PickMultipleContactsAsync()).then([this](IVectorView<Contacts::ContactInformation^>^ contacts)
00044         {
00045             if (contacts->Size > 0)
00046             {
00047                 String^ output = "Selected contacts:\n";
00048                 std::for_each(begin(contacts), end(contacts), [&output](Contacts::ContactInformation^ contact)
00049                 {
00050                     output += contact->Name + "\n";
00051                 });
00052                 OutputText->Text = output;
00053             }
00054             else
00055             {
00056                 OutputText->Text = "No contacts were selected";
00057             }
00058         });
00059     }
00060 }
00061
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Direct3DTutorialFrameworkViewSource Member List

This is the complete list of members for Direct3DTutorialFrameworkViewSource, including all inherited members.
CreateView() | Direct3DTutorialFrameworkViewSource | [inline, virtual]
CreateView() | Direct3DTutorialFrameworkViewSource | [inline, virtual]
CreateView() | Direct3DTutorialFrameworkViewSource | [inline, virtual]
CreateView() | Direct3DTutorialFrameworkViewSource | [inline, virtual]
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/common/LayoutAwarePage.h Source File

  • File and folder thumbnail
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/Parse.cpp Source File

  • Media extensions
  • MediaExtensions
  • Mpeg1Source

Parse.cpp

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // Parse.cpp
00004 // MPEG-1 parsing code.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015 #include "MPEG1Src.h"
00016 #include "Parse.h"
00017
00018 // HAS_FLAG: Test if 'b' contains a specified bit flag
00019 #define HAS_FLAG(b, flag) (((b) & (flag)) == (flag))
00020
00021 #define htonl(x)   ((((x) >> 24) & 0x000000FFL) | \
00022     (((x) >>  8) & 0x0000FF00L) | \
00023     (((x) <<  8) & 0x00FF0000L) | \
00024     (((x) << 24) & 0xFF000000L))
00025
00026 // MAKE_WORD: Convert two bytes into a WORD
00027 inline WORD MAKE_WORD(BYTE b1, BYTE b2)
00028 {
00029     return ((b1 << 8) | b2);
00030 }
00031
00032 // MAKE_DWORD_HOSTORDER:
00033 // Convert the first 4 bytes of an array into a DWORD in host order (ie, no byte swapping).
00034 inline DWORD MAKE_DWORD_HOSTORDER(const BYTE *pData)
00035 {
00036     return ((DWORD*)pData)[0];
00037 }
00038
00039 // MAKE_DWORD:
00040 // Convert the first 4 bytes of an array into a DWORD in MPEG-1 stream byte order.
00041 inline DWORD MAKE_DWORD(const BYTE *pData)
00042 {
00043     return htonl( MAKE_DWORD_HOSTORDER(pData) );
00044 }
00045
00046
00047 //-------------------------------------------------------------------
00048 // AdvanceBufferPointer
00049 // Advances a byte array pointer.
00050 //
00051 // pData: The array pointer.
00052 // cbBufferSize: The array size. On output, the size remaining.
00053 // cbAdvance: Number of bytes to advance the pointer.
00054 //
00055 // This function is just a helper for keeping a valid pointer as we
00056 // walk through a buffer.
00057 //-------------------------------------------------------------------
00058
00059 inline HRESULT AdvanceBufferPointer(const BYTE* &pData, DWORD &cbBufferSize, DWORD cbAdvance)
00060 {
00061     assert(cbBufferSize >= cbAdvance);
00062     if (cbBufferSize < cbAdvance)
00063     {
00064         return E_FAIL;
00065     }
00066     cbBufferSize -= cbAdvance;
00067     pData += cbAdvance;
00068     return S_OK;
00069 }
00070
00071 // ValidateBufferSize:
00072 // Fails if cbBufferSize < cbMinRequiredSize.
00073 inline HRESULT ValidateBufferSize(DWORD cbBufferSize, DWORD cbMinRequiredSize)
00074 {
00075     return (cbBufferSize >= cbMinRequiredSize? S_OK : E_FAIL);
00076 }
00077
00078 // Forward declarations.
00079 HRESULT ParseStreamData(const BYTE *pData, MPEG1StreamHeader& header);
00080 HRESULT ParseStreamId(BYTE id, StreamType *pType, BYTE *pStreamNum);
00081 HRESULT ParsePTS(const BYTE *pData, LONGLONG *pPTS);
00082
00083 HRESULT GetFrameRate(BYTE frameRateCode, MFRatio *pRatio);
00084 HRESULT GetPixelAspectRatio(BYTE pixelAspectCode, MFRatio *pRatio);
00085
00086 HRESULT GetAudioBitRate(MPEG1AudioLayer layer, BYTE index, DWORD *pdwBitRate);
00087 HRESULT GetSamplingFrequency(BYTE code, DWORD *pdwSamplesPerSec);
00088
00089
00090 //-------------------------------------------------------------------
00091 // Buffer class
00092 //-------------------------------------------------------------------
00093
00094
00095 Buffer::Buffer() : m_begin(0), m_end(0), m_count(0), m_allocated(0), m_pArray(NULL)
00096 {
00097 }
00098
00099
00100 //-------------------------------------------------------------------
00101 // Initalize
00102 // Sets the initial buffer size.
00103 //-------------------------------------------------------------------
00104
00105 HRESULT Buffer::Initalize(DWORD cbSize)
00106 {
00107     HRESULT hr = SetSize(cbSize);
00108     if (SUCCEEDED(hr))
00109     {
00110         ZeroMemory(Ptr(), cbSize);
00111     }
00112     return hr;
00113 }
00114
00115
00116 //-------------------------------------------------------------------
00117 // DataPtr
00118 // Returns a pointer to the start of the buffer.
00119 //-------------------------------------------------------------------
00120
00121 BYTE* Buffer::DataPtr()
00122 {
00123     return Ptr() + m_begin;
00124 }
00125
00126
00127 //-------------------------------------------------------------------
00128 // DataSize
00129 // Returns the size of the buffer.
00130 //
00131 // Note: The "size" is determined by the start and end pointers.
00132 // The memory allocated for the buffer can be larger.
00133 //-------------------------------------------------------------------
00134
00135 DWORD Buffer::DataSize() const
00136 {
00137     assert(m_end >= m_begin);
00138
00139     return m_end - m_begin;
00140 }
00141
00142 // Reserves memory for the array, but does not increase the count.
00143 HRESULT Buffer::Allocate(DWORD alloc)
00144 {
00145     HRESULT hr = S_OK;
00146     if (alloc > m_allocated)
00147     {
00148         BYTE *pTmp = new BYTE[alloc];
00149         if (pTmp)
00150         {
00151             ZeroMemory(pTmp, alloc);
00152
00153             assert(m_count <= m_allocated);
00154
00155             // Copy the elements to the re-allocated array.
00156             for (DWORD i = 0; i < m_count; i++)
00157             {
00158                 pTmp[i] = m_pArray[i];
00159             }
00160
00161             delete [] m_pArray;
00162
00163             m_pArray = pTmp;
00164             m_allocated = alloc;
00165         }
00166         else
00167         {
00168             hr = E_OUTOFMEMORY;
00169         }
00170     }
00171     return hr;
00172 }
00173
00174 // Changes the count, and grows the array if needed.
00175 HRESULT Buffer::SetSize(DWORD count)
00176 {
00177     assert (m_count <= m_allocated);
00178
00179     HRESULT hr = S_OK;
00180     if (count > m_allocated)
00181     {
00182         hr = Allocate(count);
00183     }
00184     if (SUCCEEDED(hr))
00185     {
00186         m_count = count;
00187     }
00188     return hr;
00189 }
00190
00191
00192 //-------------------------------------------------------------------
00193 // Reserve
00194 // Reserves additional bytes of memory for the buffer.
00195 //
00196 // This method does *not* increase the value returned by DataSize().
00197 //
00198 // After this method returns, the value of DataPtr() might change,
00199 // so do not cache the old value.
00200 //-------------------------------------------------------------------
00201
00202 HRESULT Buffer::Reserve(DWORD cb)
00203 {
00204     if (cb > MAXDWORD - DataSize())
00205     {
00206         return E_INVALIDARG; // Overflow
00207     }
00208
00209     HRESULT hr = S_OK;
00210
00211     // If this would push the end position past the end of the array,
00212     // then we need to copy up the data to start of the array. We might
00213     // also need to realloc the array.
00214
00215     if (cb > m_count - m_end)
00216     {
00217         // New end position would be past the end of the array.
00218         // Check if we need to grow the array.
00219
00220         if (cb > CurrentFreeSize())
00221         {
00222             // Array needs to grow
00223             hr = SetSize(DataSize() + cb);
00224         }
00225
00226         if (SUCCEEDED(hr))
00227         {
00228             MoveMemory(Ptr(), DataPtr(), DataSize());
00229
00230             // Reset begin and end.
00231             m_end = DataSize(); // Update m_end first before resetting m_begin!
00232             m_begin = 0;
00233         }
00234     }
00235
00236     assert(CurrentFreeSize() >= cb);
00237
00238     return hr;
00239 }
00240
00241
00242 //-------------------------------------------------------------------
00243 // MoveStart
00244 // Moves the start of the buffer by cb bytes.
00245 //
00246 // Call this method after consuming data from the buffer.
00247 //-------------------------------------------------------------------
00248
00249 HRESULT Buffer::MoveStart(DWORD cb)
00250 {
00251     // Cannot advance pass the end of the buffer.
00252     if (cb > DataSize())
00253     {
00254         return E_INVALIDARG;
00255     }
00256
00257     m_begin += cb;
00258     return S_OK;
00259 }
00260
00261
00262 //-------------------------------------------------------------------
00263 // MoveEnd
00264 // Moves end position of the buffer.
00265 //-------------------------------------------------------------------
00266
00267 HRESULT Buffer::MoveEnd(DWORD cb)
00268 {
00269     HRESULT hr = S_OK;
00270
00271     hr = Reserve(cb);
00272
00273     if (SUCCEEDED(hr))
00274     {
00275         m_end += cb;
00276     }
00277     return hr;
00278 }
00279
00280
00281 //-------------------------------------------------------------------
00282 // CurrentFreeSize (private)
00283 //
00284 // Returns the size of the array minus the size of the data.
00285 //-------------------------------------------------------------------
00286
00287 DWORD Buffer::CurrentFreeSize() const
00288 {
00289     assert(m_count >= DataSize());
00290     return m_count - DataSize();
00291 }
00292
00293
00294 //-------------------------------------------------------------------
00295 // Parser class
00296 //-------------------------------------------------------------------
00297
00298
00299 Parser::Parser() : m_SCR(0), m_muxRate(0), m_pHeader(NULL), m_bHasPacketHeader(FALSE), m_bEOS(FALSE)
00300 {
00301     ZeroMemory(&m_curPacketHeader, sizeof(m_curPacketHeader));
00302 }
00303
00304 Parser::~Parser()
00305 {
00306     CoTaskMemFree(m_pHeader);
00307 }
00308
00309 //-------------------------------------------------------------------
00310 // GetSystemHeader class
00311 //
00312 // Returns a copy of the system header.
00313 // Do not call this method unless HasSystemHeader() returns TRUE.
00314 //
00315 // The caller must free the returned structure by calling
00316 // CoTaskMemFree.
00317 //-------------------------------------------------------------------
00318
00319 HRESULT Parser::GetSystemHeader(MPEG1SystemHeader **ppHeader)
00320 {
00321     if (ppHeader == NULL)
00322     {
00323         return E_POINTER;
00324     }
00325
00326     if (!HasSystemHeader())
00327     {
00328         return E_FAIL;
00329     }
00330
00331     assert(m_pHeader->cbSize > 0);
00332
00333     MPEG1SystemHeader *pHeader = (MPEG1SystemHeader*)CoTaskMemAlloc(m_pHeader->cbSize);
00334     if (pHeader == NULL)
00335     {
00336         return E_OUTOFMEMORY;
00337     }
00338
00339     CopyMemory(pHeader, m_pHeader, m_pHeader->cbSize);
00340
00341     *ppHeader = pHeader;
00342     return S_OK;
00343 }
00344
00345
00346 //-------------------------------------------------------------------
00347 // ParseBytes
00348 // Parses as much data as possible from the pData buffer, and returns
00349 // the amount of data parsed in pAte (*pAte <= cbLen).
00350 //
00351 // Return values:
00352 //      S_OK: The method consumed some data (*pAte > 0).
00353 //      S_FALSE: The method did not consume any data (*pAte == 0).
00354 //      [or an error code]
00355 //
00356 // If the method returns S_FALSE, the caller must allocate a larger
00357 // buffer and pass in more data.
00358 //-------------------------------------------------------------------
00359
00360 HRESULT Parser::ParseBytes(const BYTE *pData, DWORD cbLen, DWORD *pAte)
00361 {
00362     *pAte = 0;
00363
00364     if (cbLen < 4)
00365     {
00366         return S_FALSE;
00367     }
00368
00369     HRESULT hr = S_OK;
00370     DWORD cbLengthToStartCode = 0;  // How much we skip to reach the next start code.
00371     DWORD cbParsed = 0;             // How much we parse after the start code.
00372
00373     m_bHasPacketHeader = FALSE;
00374
00375     hr = FindNextStartCode(pData, cbLen, &cbLengthToStartCode);
00376
00377     if (hr == S_OK)
00378     {
00379         cbLen -= cbLengthToStartCode;
00380         pData += cbLengthToStartCode;
00381
00382         switch (MAKE_DWORD(pData))
00383         {
00384         case MPEG1_PACK_START_CODE:
00385             // Start of pack.
00386             hr = ParsePackHeader(pData, cbLen, &cbParsed);
00387             break;
00388
00389         case MPEG1_SYSTEM_HEADER_CODE:
00390             // Start of system header.
00391             hr = ParseSystemHeader(pData, cbLen, &cbParsed);
00392             break;
00393
00394         case MPEG1_STOP_CODE:
00395             // Stop code, end of stream.
00396             cbParsed = sizeof(DWORD);
00397             hr = OnEndOfStream();
00398             break;
00399
00400         default:
00401             // Start of packet.
00402             hr = ParsePacketHeader(pData, cbLen, &cbParsed);
00403             break;
00404
00405         }
00406     }
00407
00408     if (hr == S_OK)
00409     {
00410         *pAte = cbLengthToStartCode + cbParsed;
00411     }
00412     return hr;
00413 };
00414
00415
00416 //-------------------------------------------------------------------
00417 // FindNextStartCode
00418 // Looks for the next start code in the buffer.
00419 //
00420 // pData: Pointer to the buffer.
00421 // cbLen: Size of the buffer.
00422 // pAte: Receives the number of bytes *before* the start code.
00423 //
00424 // If no start code is found, the method returns S_FALSE.
00425 //-------------------------------------------------------------------
00426
00427 HRESULT Parser::FindNextStartCode(const BYTE *pData, DWORD cbLen, DWORD *pAte)
00428 {
00429     HRESULT hr = S_FALSE;
00430
00431     DWORD cbLeft = cbLen;
00432
00433     while (cbLeft > 4)
00434     {
00435         if ( (MAKE_DWORD_HOSTORDER(pData) & 0x00FFFFFF) == 0x00010000 )
00436         {
00437             hr = S_OK;
00438             break;
00439         }
00440
00441         cbLeft -= 4;
00442         pData += 4;
00443     }
00444     *pAte = (cbLen - cbLeft);
00445     return hr;
00446 }
00447
00448
00449 //-------------------------------------------------------------------
00450 // ParsePackHeader
00451 // Parses the start of an MPEG-1 pack.
00452 //-------------------------------------------------------------------
00453
00454 HRESULT Parser::ParsePackHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte)
00455 {
00456     assert( MAKE_DWORD(pData) == MPEG1_PACK_START_CODE );
00457
00458     if (cbLen < MPEG1_PACK_HEADER_SIZE)
00459     {
00460         return S_FALSE; // Not enough data yet.
00461     }
00462
00463     // Check marker bits
00464     if ( ((pData[4] & 0xF1) != 0x21) ||
00465         ((pData[6] & 0x01) != 0x01) ||
00466         ((pData[8] & 0x01) != 0x01) ||
00467         ((pData[9] & 0x80) != 0x80) ||
00468         ((pData[11] & 0x01) != 0x01) )
00469     {
00470         return E_FAIL;
00471     }
00472
00473
00474     // Calculate the SCR.
00475     LONGLONG scr = ( (pData[8] & 0xFE) >> 1) |
00476         ( (pData[7]) << 7) |
00477         ( (pData[6] & 0xFE) << 14) |
00478         ( (pData[5]) << 22) |
00479         ( (pData[4] & 0x0E) << 29);
00480
00481     DWORD muxRate = ( (pData[11] & 0xFE) >> 1) |
00482         ( (pData[10]) << 7) |
00483         ( (pData[9] & 0x7F) << 15);
00484
00485
00486     m_SCR = scr;
00487     m_muxRate = muxRate;
00488
00489     *pAte = MPEG1_PACK_HEADER_SIZE;
00490
00491     return S_OK;
00492 }
00493
00494
00495 //-------------------------------------------------------------------
00496 // ParseSystemHeader.
00497 // Parses the MPEG-1 system header.
00498 //
00499 // NOTES:
00500 // The system header optionally appears after the pack header.
00501 // The first pack must contain a system header.
00502 // Subsequent packs may contain a system header.
00503 //-------------------------------------------------------------------
00504
00505 HRESULT Parser::ParseSystemHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte)
00506 {
00507     assert( MAKE_DWORD(pData) == MPEG1_SYSTEM_HEADER_CODE );
00508
00509     if (cbLen < MPEG1_SYSTEM_HEADER_MIN_SIZE)
00510     {
00511         return S_FALSE; // Not enough data yet.
00512     }
00513
00514     // Find the total header length.
00515     DWORD cbHeaderLen = MPEG1_SYSTEM_HEADER_PREFIX +  MAKE_WORD(pData[4], pData[5]);
00516
00517     if (cbHeaderLen < MPEG1_SYSTEM_HEADER_MIN_SIZE - MPEG1_SYSTEM_HEADER_PREFIX)
00518     {
00519         return E_FAIL;  // Invalid value.
00520     }
00521
00522     if (cbLen < cbHeaderLen)
00523     {
00524         return S_FALSE; // Not enough data yet.
00525     }
00526
00527     // We have enough data to parse the header.
00528
00529     HRESULT hr = S_OK;
00530
00531     // Did we already see a system header?
00532     if (!HasSystemHeader())
00533     {
00534         // This is the first time we've seen the header. Parse it.
00535
00536         // Calculate the number of stream info's in the header.
00537         DWORD cStreamInfo = (cbHeaderLen - MPEG1_SYSTEM_HEADER_MIN_SIZE) / MPEG1_SYSTEM_HEADER_STREAM;
00538
00539         // Calculate the structure size.
00540         DWORD cbSize = sizeof(MPEG1SystemHeader);
00541         if (cStreamInfo > 1)
00542         {
00543             cbSize += sizeof(MPEG1StreamHeader) * (cStreamInfo - 1);
00544         }
00545
00546         // Allocate room for the header.
00547         m_pHeader = (MPEG1SystemHeader*)CoTaskMemAlloc(cbSize);
00548         if (m_pHeader == NULL)
00549         {
00550             hr = E_OUTOFMEMORY;
00551         }
00552
00553         if (SUCCEEDED(hr))
00554         {
00555             m_pHeader->cbSize = cbSize;
00556         }
00557
00558         // Check marker bits
00559         if (SUCCEEDED(hr))
00560         {
00561             if ( ((pData[6] & 0x80) != 0x80) ||
00562                 ((pData[8] & 0x01) != 0x01) ||
00563                 ((pData[10] & 0x20) != 0x20) ||
00564                 (pData[11] != 0xFF) )
00565             {
00566                 hr = E_FAIL;  // Invalid bits.
00567             }
00568         }
00569
00570         if (SUCCEEDED(hr))
00571         {
00572             m_pHeader->rateBound = ((pData[6] & 0x7F) << 16) | (pData[7] << 8) | (pData[8] >> 1);
00573             m_pHeader->cAudioBound = pData[9] >> 2;
00574             m_pHeader->bFixed = HAS_FLAG(pData[9], 0x02);
00575             m_pHeader->bCSPS = HAS_FLAG(pData[9], 0x01);
00576             m_pHeader->bAudioLock = HAS_FLAG(pData[10], 0x80);
00577             m_pHeader->bVideoLock = HAS_FLAG(pData[10], 0x40);
00578             m_pHeader->cVideoBound = pData[10] & 0x1F;
00579             m_pHeader->cStreams = cStreamInfo;
00580
00581             // Parse the stream information.
00582             const BYTE *pStreamInfo = pData + MPEG1_SYSTEM_HEADER_MIN_SIZE;
00583
00584             for (DWORD i = 0; i < cStreamInfo; i++)
00585             {
00586                 hr = ParseStreamData(pStreamInfo, m_pHeader->streams[i]);
00587
00588                 if (FAILED(hr))
00589                 {
00590                     break;
00591                 }
00592
00593                 pStreamInfo += MPEG1_SYSTEM_HEADER_STREAM;
00594             }
00595         }
00596     }
00597
00598     if (SUCCEEDED(hr))
00599     {
00600         *pAte = cbHeaderLen;
00601     }
00602
00603     if (FAILED(hr))
00604     {
00605         CoTaskMemFree(m_pHeader);
00606         m_pHeader = NULL;
00607     }
00608
00609     return hr;
00610 }
00611
00612 //-------------------------------------------------------------------
00613 // ParsePacketHeader
00614 //
00615 // Parses the packet header.
00616 //
00617 // If the method returns S_OK, then HasPacket() returns TRUE and the
00618 // caller can start parsing the packet.
00619 //-------------------------------------------------------------------
00620
00621 HRESULT Parser::ParsePacketHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte)
00622 {
00623     if (!HasSystemHeader())
00624     {
00625         return E_FAIL; // We should not get a packet before the first system header.
00626     }
00627
00628     if (cbLen < MPEG1_PACKET_HEADER_MIN_SIZE)
00629     {
00630         return S_FALSE; // Not enough data yet.
00631     }
00632
00633     // Before we parse anything else in the packet header, look for the header length.
00634     DWORD cbPacketLen = MAKE_WORD(pData[4], pData[5]) + MPEG1_PACKET_HEADER_MIN_SIZE;
00635
00636     // We want enough data for the maximum packet header OR the total packet size, whichever is less.
00637     if (cbLen < cbPacketLen && cbLen < MPEG1_PACKET_HEADER_MAX_SIZE)
00638     {
00639         return S_FALSE; // Not enough data yet.
00640     }
00641
00642     // Make sure the start code is 0x000001xx
00643     if ((MAKE_DWORD(pData) & 0xFFFFFF00) != MPEG1_START_CODE_PREFIX)
00644     {
00645         return E_FAIL;
00646     }
00647
00648     HRESULT hr = S_OK;
00649     BYTE id = 0;
00650     StreamType type = StreamType_Unknown;
00651     BYTE num = 0;
00652     BOOL bHasPTS = FALSE;
00653
00654     ZeroMemory(&m_curPacketHeader, sizeof(m_curPacketHeader));
00655
00656     // Find the stream ID.
00657     id = pData[3];
00658     hr = ParseStreamId(id, &type, &num);
00659     if (FAILED(hr))
00660     {
00661         return hr;
00662     }
00663
00664
00665     DWORD cbLeft = cbPacketLen - MPEG1_PACKET_HEADER_MIN_SIZE;
00666     pData = pData + MPEG1_PACKET_HEADER_MIN_SIZE;
00667     DWORD cbPadding = 0;
00668     LONGLONG pts = 0;
00669
00670     // Go past the stuffing bytes.
00671     while ((cbLeft > 0) && (*pData == 0xFF))
00672     {
00673         AdvanceBufferPointer(pData, cbLeft, 1);
00674         ++cbPadding;
00675     }
00676
00677     // Check for invalid number of stuffing bytes.
00678     if (cbPadding > MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE)
00679     {
00680         hr = E_FAIL;
00681     }
00682
00683     // The next bits are:
00684     // (optional) STD buffer size (2 bytes)
00685     // union
00686     // {
00687     //      PTS (5 bytes)
00688     //      PTS + DTS (10 bytes)
00689     //      '0000 1111' (1 bytes)
00690     // }
00691
00692     if (SUCCEEDED(hr))
00693     {
00694         hr = ValidateBufferSize(cbLeft, 1);
00695     }
00696
00697     if (SUCCEEDED(hr))
00698     {
00699         if ((*pData & 0xC0) == 0x40)
00700         {
00701             // Skip STD buffer size.
00702             hr = AdvanceBufferPointer(pData, cbLeft, 2);
00703         }
00704     }
00705
00706     if (SUCCEEDED(hr))
00707     {
00708         hr = ValidateBufferSize(cbLeft, 1);
00709     }
00710
00711     if (SUCCEEDED(hr))
00712     {
00713         if ((*pData & 0xF1) == 0x21)
00714         {
00715             // PTS
00716             hr = ValidateBufferSize(cbLeft, 5);
00717
00718             if (SUCCEEDED(hr))
00719             {
00720                 ParsePTS(pData, &pts);
00721                 bHasPTS = TRUE;
00722
00723                 hr = AdvanceBufferPointer(pData, cbLeft, 5);
00724             }
00725         }
00726         else if ((*pData & 0xF1) == 0x31)
00727         {
00728             // PTS + DTS
00729             hr = ValidateBufferSize(cbLeft, 10);
00730
00731             // Parse PTS but skip DTS.
00732             if (SUCCEEDED(hr))
00733             {
00734                 ParsePTS(pData, &pts);
00735                 bHasPTS = TRUE;
00736
00737                 hr = AdvanceBufferPointer(pData, cbLeft, 10);
00738             }
00739         }
00740         else if ((*pData) == 0x0F)
00741         {
00742             hr = AdvanceBufferPointer(pData, cbLeft, 1);
00743         }
00744         else
00745         {
00746             hr = E_FAIL; // Unexpected bit field
00747         }
00748     }
00749
00750     if (SUCCEEDED(hr))
00751     {
00752         m_curPacketHeader.stream_id = id;
00753         m_curPacketHeader.type = type;
00754         m_curPacketHeader.number = num;
00755         m_curPacketHeader.cbPacketSize = cbPacketLen;
00756         m_curPacketHeader.cbPayload = cbLeft;
00757         m_curPacketHeader.bHasPTS = bHasPTS;
00758         m_curPacketHeader.PTS = pts;
00759
00760         // Client can read the packet now.
00761         m_bHasPacketHeader = TRUE;
00762
00763         *pAte = cbPacketLen - cbLeft;
00764     }
00765
00766     return hr;
00767 }
00768
00769 //-------------------------------------------------------------------
00770 // OnEndOfStream
00771 // Called when the parser reaches the MPEG-1 stop code.
00772 //
00773 // Note: Obviously the parser is not guaranteed to see a stop code
00774 // before the client reaches the end of the source data. The client
00775 // must be prepared to handle that case.
00776 //-------------------------------------------------------------------
00777
00778 HRESULT Parser::OnEndOfStream()
00779 {
00780     m_bEOS = TRUE;
00781     ClearPacket();
00782
00783     return S_OK;
00784 }
00785
00786
00787 //-------------------------------------------------------------------
00788 // Static functions
00789 //-------------------------------------------------------------------
00790
00791
00792 //-------------------------------------------------------------------
00793 // ParsePTS
00794 // Parse the 33-bit Presentation Time Stamp (PTS)
00795 //-------------------------------------------------------------------
00796
00797 HRESULT ParsePTS(const BYTE *pData, LONGLONG *pPTS)
00798 {
00799     BYTE byte1 = pData[0];
00800     WORD word1 = MAKE_WORD(pData[1], pData[2]);
00801     WORD word2 = MAKE_WORD(pData[3], pData[4]);
00802
00803     // Check marker bits.
00804     // The first byte can be '0010xxx1' or '0x11xxxx1'
00805     if (((byte1 & 0xE1) != 0x21) ||
00806         ((word1 & 0x01) != 0x01) ||
00807         ((word2 & 0x01) != 0x01) )
00808     {
00809         return E_FAIL;
00810     }
00811
00812     LARGE_INTEGER li;
00813
00814     // The PTS is 33 bits, so bit 32 goes in the high-order DWORD
00815     li.HighPart = (byte1 & 0x08) >> 3;
00816
00817     li.LowPart = (static_cast<DWORD>(byte1 & 0x06) << 29) |
00818         (static_cast<DWORD>(word1 & 0xFFFE) << 14) |
00819         (static_cast<DWORD>(word2) >> 1);
00820
00821     *pPTS = li.QuadPart;
00822     return S_OK;
00823 }
00824
00825
00826 //-------------------------------------------------------------------
00827 // ParseStreamData
00828 // Parses the stream information (for one stream) in the system
00829 // header.
00830 //-------------------------------------------------------------------
00831
00832 HRESULT ParseStreamData(const BYTE *pStreamInfo, MPEG1StreamHeader& header)
00833 {
00834     // Check marker bits.
00835     if ( (pStreamInfo[1] & 0xC0) != 0xC0 )
00836     {
00837         return E_FAIL; // Invalid bits
00838     }
00839
00840     HRESULT hr = S_OK;
00841     BYTE id = 0;
00842     BYTE num = 0;
00843     DWORD bound = 0;
00844     StreamType type = StreamType_Unknown;
00845
00846     // The id is a stream code plus (for some types) a stream number, bitwise-OR'd.
00847
00848     id = pStreamInfo[0];
00849
00850     hr = ParseStreamId(id, &type, &num);
00851     if (FAILED(hr))
00852     {
00853         return hr;
00854     }
00855
00856     // Calculate STD bound.
00857     bound = pStreamInfo[2] | ((pStreamInfo[1] & 0x1F) << 8);
00858
00859     if (pStreamInfo[1] & 0x20)
00860     {
00861         bound *= 1024;
00862     }
00863     else
00864     {
00865         bound *= 128;
00866     }
00867
00868     header.stream_id = id;
00869     header.type = type;
00870     header.number = num;
00871     header.sizeBound = bound;
00872
00873     return S_OK;
00874 }
00875
00876
00877
00878 //-------------------------------------------------------------------
00879 // ParseStreamId
00880 // Parses an MPEG-1 stream ID.
00881 //
00882 // Note:
00883 // The id is a stream code, plus (for some types) a stream number,
00884 // bitwise-OR'd. This function returns the type and the stream number.
00885 //
00886 // See ISO/EIC 11172-1, sec 2.4.4.2
00887 //-------------------------------------------------------------------
00888
00889 HRESULT ParseStreamId(BYTE id, StreamType *pType, BYTE *pStreamNum)
00890 {
00891     StreamType type = StreamType_Unknown;
00892     BYTE num = 0;
00893
00894     switch (id)
00895     {
00896     case MPEG1_STREAMTYPE_ALL_AUDIO:
00897         type = StreamType_AllAudio;
00898         break;
00899
00900     case MPEG1_STREAMTYPE_ALL_VIDEO:
00901         type = StreamType_AllVideo;
00902         break;
00903
00904     case MPEG1_STREAMTYPE_RESERVED:
00905         type = StreamType_Reserved;
00906         break;
00907
00908     case MPEG1_STREAMTYPE_PRIVATE1:
00909         type = StreamType_Private1;
00910         break;
00911
00912     case MPEG1_STREAMTYPE_PADDING:
00913         type = StreamType_Padding;
00914         break;
00915
00916     case MPEG1_STREAMTYPE_PRIVATE2:
00917         type = StreamType_Private2;
00918         break;
00919
00920     default:
00921         if ((id & 0xE0) == MPEG1_STREAMTYPE_AUDIO_MASK)
00922         {
00923             type = StreamType_Audio;
00924             num = id & 0x1F;
00925         }
00926         else if ((id & 0xF0) == MPEG1_STREAMTYPE_VIDEO_MASK)
00927         {
00928             type = StreamType_Video;
00929             num = id & 0x0F;
00930         }
00931         else if ((id & 0xF0) == MPEG1_STREAMTYPE_DATA_MASK)
00932         {
00933             type = StreamType_Data;
00934             num = id & 0x0F;
00935         }
00936         else
00937         {
00938             return E_FAIL; // Unknown stream ID code.
00939         }
00940     }
00941
00942     *pType = type;
00943     *pStreamNum = num;
00944     return S_OK;
00945 }
00946
00947
00948 //-------------------------------------------------------------------
00949 // ReadVideoSequenceHeader
00950 // Parses a video sequence header.
00951 //
00952 // Call Parser::HasPacket() to ensure that pData points to the start
00953 // of a payload, and call Parser::PacketHeader() to verify it is a
00954 // video packet.
00955 //-------------------------------------------------------------------
00956
00957 HRESULT ReadVideoSequenceHeader(
00958     _In_reads_bytes_(cbData) const BYTE *pData,
00959     DWORD cbData,
00960     MPEG1VideoSeqHeader& seqHeader,
00961     _Out_ DWORD *pAte
00962     )
00963 {
00964     DWORD cbPadding = 0;
00965
00966     if (pAte == nullptr || pData == nullptr)
00967     {
00968         return E_INVALIDARG;
00969     }
00970
00971     *pAte = 0;
00972
00973     // Skip to the sequence header code.
00974     while ( (cbPadding + 4) <= cbData && ((DWORD*)pData)[0] == 0 )
00975     {
00976         pData += 4;
00977         cbPadding += 4;
00978     }
00979
00980     cbData -= cbPadding;
00981
00982     // Check for the minimum size buffer.
00983     if (cbData < MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE)
00984     {
00985         *pAte = cbPadding;
00986         return S_FALSE;
00987     }
00988
00989     // Validate the sequence header code.
00990     if (MAKE_DWORD(pData) != MPEG1_SEQUENCE_HEADER_CODE)
00991     {
00992         return E_FAIL;
00993     }
00994
00995     // Calculate the actual required size.
00996     DWORD cbRequired = MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE;
00997
00998     // Look for quantization matrices.
00999     if ( HAS_FLAG(pData[11], 0x02) )
01000     {
01001         // Intra quantization matrix is TRUE.
01002         cbRequired += 64;
01003     }
01004     // Intra is FALSE, look for non-intra flag
01005     else if ( HAS_FLAG(pData[11], 0x01) )
01006     {
01007         cbRequired += 64;
01008     }
01009
01010     if (cbData < cbRequired)
01011     {
01012         return S_FALSE;
01013     }
01014
01015     ZeroMemory(&seqHeader, sizeof(seqHeader));
01016
01017     // Check the marker bit.
01018     if ( !HAS_FLAG(pData[10], 0x20) )
01019     {
01020         return E_FAIL;
01021     }
01022
01023     BYTE parCode = pData[7] >> 4;
01024     BYTE frameRateCode = pData[7] & 0x0F;
01025
01026     if (FAILED(GetPixelAspectRatio(parCode, &seqHeader.pixelAspectRatio)))
01027     {
01028         return E_FAIL;
01029     }
01030
01031     if (FAILED(GetFrameRate(frameRateCode, &seqHeader.frameRate)))
01032     {
01033         return E_FAIL;
01034     }
01035
01036     seqHeader.width = (pData[4] << 4) | (pData[5] >> 4) ;
01037     seqHeader.height = ((pData[5] & 0x0F) << 8) | (pData[6]);
01038     seqHeader.bitRate = (pData[8] << 10) | (pData[9] << 2) | (pData[10] >> 6);
01039
01040     if (seqHeader.bitRate == 0)
01041     {
01042         return E_FAIL;  // Not allowed.
01043     }
01044     else if (seqHeader.bitRate == 0x3FFFF)
01045     {
01046         seqHeader.bitRate = 0; // Variable bit-rate.
01047     }
01048     else
01049     {
01050         seqHeader.bitRate = seqHeader.bitRate * 400; // Units of 400 bps
01051     }
01052
01053     seqHeader.cbVBV_Buffer = ( ((pData[10] & 0x1F) << 5) | (pData[11] >> 3) ) * 2048;
01054     seqHeader.bConstrained = HAS_FLAG(pData[11], 0x04);
01055
01056     seqHeader.cbHeader = cbRequired;
01057     CopyMemory(seqHeader.header, pData, cbRequired);
01058
01059     *pAte = cbRequired + cbPadding;
01060
01061     return S_OK;
01062 }
01063
01064
01065
01066 //-------------------------------------------------------------------
01067 // GetFrameRate
01068 // Returns the frame rate from the picture_rate field of the sequence
01069 // header.
01070 //
01071 // See ISO/IEC 11172-2, 2.4.3.2 "Sequence Header"
01072 //-------------------------------------------------------------------
01073
01074 HRESULT GetFrameRate(BYTE frameRateCode, MFRatio *pRatio)
01075 {
01076     MFRatio frameRates[] =
01077     {
01078         { 0, 0 },           // invalid
01079         { 24000, 1001 },    // 23.976 fps
01080         { 24, 1 },
01081         { 25, 1 },
01082         { 30000, 1001 },    // 29.97 fps
01083         { 50, 1 },
01084         { 60000, 1001 },    // 59.94 fps
01085         { 60, 1 }
01086     };
01087
01088     if (frameRateCode < 1 || frameRateCode >= ARRAYSIZE(frameRates))
01089     {
01090         return MF_E_INVALIDTYPE;
01091     }
01092
01093     pRatio->Numerator = frameRates[frameRateCode].Numerator;
01094     pRatio->Denominator = frameRates[frameRateCode].Denominator;
01095
01096     return S_OK;
01097 }
01098
01099 //-------------------------------------------------------------------
01100 // GetPixelAspectRatio
01101 // Returns the pixel aspect ratio (PAR) from the pel_aspect_ratio
01102 // field of the sequence header.
01103 //
01104 // See ISO/IEC 11172-2, 2.4.3.2 "Sequence Header"
01105 //-------------------------------------------------------------------
01106
01107 HRESULT GetPixelAspectRatio(BYTE pixelAspectCode, MFRatio *pRatio)
01108 {
01109     DWORD height[] = { 0, 10000, 6735, 7031, 7615, 8055, 8437, 8935, 9157,
01110         9815, 10255, 10695, 10950, 11575, 12015 };
01111
01112     const DWORD width = 10000;
01113
01114     if (pixelAspectCode < 1 || pixelAspectCode >= ARRAYSIZE(height))
01115     {
01116         return MF_E_INVALIDTYPE;
01117     }
01118
01119     pRatio->Numerator = height[pixelAspectCode];
01120     pRatio->Denominator = width;
01121
01122     return S_OK;
01123
01124 }
01125
01126
01127 //-------------------------------------------------------------------
01128 // ReadAudioFrameHeader
01129 // Parses an audio frame header.
01130 //
01131 // Call Parser::HasPacket() to ensure that pData points to the start
01132 // of a payload, and call Parser::PacketHeader() to verify it is an
01133 // audio packet.
01134 //-------------------------------------------------------------------
01135
01136 HRESULT ReadAudioFrameHeader(
01137     const BYTE *pData,
01138     DWORD cbData,
01139     MPEG1AudioFrameHeader& audioHeader,
01140     DWORD *pAte
01141     )
01142 {
01143     HRESULT hr = S_OK;
01144     MPEG1AudioFrameHeader header;
01145     ZeroMemory(&header, sizeof(header));
01146
01147     BYTE bitRateIndex = 0;
01148     BYTE samplingIndex = 0;
01149
01150     *pAte = 0;
01151
01152     if (cbData < MPEG1_AUDIO_FRAME_HEADER_SIZE)
01153     {
01154         return S_FALSE;
01155     }
01156
01157
01158     if (pData[0] != 0xFF)
01159     {
01160         return E_FAIL;
01161     }
01162
01163     if (!HAS_FLAG(pData[1], 0xF8))
01164     {
01165         return E_FAIL;
01166     }
01167
01168     // Layer bits
01169     switch (pData[1] & 0x06)
01170     {
01171     case 0x00:
01172         return E_FAIL;
01173
01174     case 0x06:
01175         header.layer = MPEG1_Audio_Layer1;
01176         break;
01177
01178     case 0x04:
01179         header.layer = MPEG1_Audio_Layer2;
01180         break;
01181
01182     case 0x02:
01183         header.layer = MPEG1_Audio_Layer3;
01184         break;
01185
01186     default:
01187         return E_UNEXPECTED; // Cannot actually happen, given our bitmask above.
01188     }
01189
01190     bitRateIndex = (pData[2] & 0xF0) >> 4;
01191     samplingIndex = (pData[2] & 0x0C) >> 2;
01192
01193     // Bit rate.
01194     // Note: Accoring to ISO/IEC 11172-3, some combinations of bitrate and
01195     // mode are not valid. However, this is up to the decoder to validate.
01196     hr = GetAudioBitRate(header.layer, bitRateIndex, &header.dwBitRate);
01197
01198     // Sampling frequency.
01199     if (SUCCEEDED(hr))
01200     {
01201         hr = GetSamplingFrequency(samplingIndex, &header.dwSamplesPerSec);
01202     }
01203
01204     if (SUCCEEDED(hr))
01205     {
01206         header.mode = static_cast<MPEG1AudioMode>((pData[3] & 0xC0) >> 6);
01207         header.modeExtension = (pData[3] & 0x30) >> 4;
01208         header.emphasis = (pData[3] & 0x03);
01209
01210         // Parse the various bit flags.
01211         if (HAS_FLAG(pData[1], 0x01))
01212         {
01213             header.wFlags |= MPEG1_AUDIO_PROTECTION_BIT;
01214         }
01215         if (HAS_FLAG(pData[2], 0x01))
01216         {
01217             header.wFlags |= MPEG1_AUDIO_PRIVATE_BIT;
01218         }
01219         if (HAS_FLAG(pData[3], 0x08))
01220         {
01221             header.wFlags |= MPEG1_AUDIO_COPYRIGHT_BIT;
01222         }
01223         if (HAS_FLAG(pData[3], 0x04))
01224         {
01225             header.wFlags |= MPEG1_AUDIO_ORIGINAL_BIT;
01226         }
01227
01228         if (header.mode == MPEG1_Audio_SingleChannel)
01229         {
01230             header.nChannels = 1;
01231         }
01232         else
01233         {
01234             header.nChannels = 2;
01235         }
01236
01237         header.nBlockAlign = 1;
01238
01239         CopyMemory(&audioHeader, &header, sizeof(audioHeader));
01240     }
01241
01242     return  hr;
01243
01244 };
01245
01246
01247 //-------------------------------------------------------------------
01248 // GetAudioBitRate
01249 // Returns the audio bit rate in KBits per second, from the
01250 // bitrate_index field of the audio frame header.
01251 //
01252 // See ISO/IEC 11172-3, 2.4.2.3, "Header"
01253 //-------------------------------------------------------------------
01254
01255 HRESULT GetAudioBitRate(MPEG1AudioLayer layer, BYTE index, DWORD *pdwBitRate)
01256 {
01257     const DWORD MAX_BITRATE_INDEX = 14;
01258
01259     // Table of bit rates.
01260     const DWORD bitrate[3][ (MAX_BITRATE_INDEX+1) ] =
01261     {
01262         { 0, 32, 64, 96, 128, 160, 192, 224, 256, 288, 320, 352, 384, 416, 448 },    // Layer I
01263         { 0, 32, 48, 56, 64, 80, 96, 112, 128, 160, 192, 224, 256, 320, 384 },       // Layer II
01264         { 0, 32, 40, 48, 56, 64, 80, 96, 112, 128, 160, 192, 224, 256, 320 }         // Layer III
01265     };
01266
01267     if (layer < MPEG1_Audio_Layer1 || layer > MPEG1_Audio_Layer3)
01268     {
01269         return E_INVALIDARG;
01270     }
01271     if (index > MAX_BITRATE_INDEX)
01272     {
01273         return E_INVALIDARG;
01274     }
01275
01276     *pdwBitRate = bitrate[layer][index];
01277
01278     return S_OK;
01279 }
01280
01281 //-------------------------------------------------------------------
01282 // GetSamplingFrequency
01283 // Returns the sampling frequency in samples per second, from the
01284 // sampling_frequency field of the audio frame header.
01285 //
01286 // See ISO/IEC 11172-3, 2.4.2.3, "Header"
01287 //-------------------------------------------------------------------
01288
01289 inline HRESULT GetSamplingFrequency(BYTE code, DWORD *pdwSamplesPerSec)
01290 {
01291     switch (code)
01292     {
01293     case 0:
01294         *pdwSamplesPerSec = 44100;
01295         break;
01296     case 1:
01297         *pdwSamplesPerSec = 48000;
01298         break;
01299     case 2:
01300         *pdwSamplesPerSec = 32000;
01301         break;
01302     default:
01303         return E_FAIL;
01304     }
01305     return S_OK;
01306 }
01307
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/pch.h Source File

  • Direct2D custom image effects
  • PixelShader

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
00017 #include <math.h>
00018 #include <d2d1effectauthor.h>
00019 #include <d2d1effecthelpers.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/pch.h Source File

  • Proximity

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include "Sample-Utils\CppSamplesUtils.h"
00019 #include <ppltasks.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/SetVersion.xaml.cpp Source File

  • Application data

SetVersion.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SetVersion.xaml.cpp
00013 // Implementation of the SetVersion class
00014 //
00015
00016 #include "pch.h"
00017 #include "SetVersion.xaml.h"
00018
00019 using namespace SDKSample::ApplicationDataSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::Storage;
00027 using namespace concurrency;
00028
00029 #define settingName   "SetVersionSetting"
00030 #define settingValue0 "Data.v0"
00031 #define settingValue1 "Data.v1"
00032
00033 SetVersion::SetVersion()
00034 {
00035     InitializeComponent();
00036
00037     appData = ApplicationData::Current;
00038
00039     DisplayOutput();
00040 }
00041
00042 void SetVersion::SetVersionHandler0(SetVersionRequest^ request)
00043 {
00044     SetVersionDeferral^ deferral = request->GetDeferral();
00045
00046     unsigned int version = appData->Version;
00047
00048     switch (version)
00049     {
00050         case 0:
00051             // Version is already 0.  Nothing to do.
00052             break;
00053
00054         case 1:
00055             // Need to convert data from v1 to v0.
00056
00057             // This sample simulates that conversion by writing a version-specific value.
00058             appData->LocalSettings->Values->Insert(settingName, dynamic_cast<PropertyValue^>(PropertyValue::CreateString(settingValue0)));
00059
00060             break;
00061
00062         default:
00063             throw ref new Exception(E_FAIL, "Unexpected ApplicationData Version: " + version.ToString());
00064     }
00065
00066     deferral->Complete();
00067 }
00068
00069 void SetVersion::SetVersionHandler1(SetVersionRequest^ request)
00070 {
00071     SetVersionDeferral^ deferral = request->GetDeferral();
00072
00073     unsigned int version = appData->Version;
00074
00075     switch (version)
00076     {
00077         case 0:
00078             // Need to convert data from v0 to v1.
00079
00080             // This sample simulates that conversion by writing a version-specific value.
00081             appData->LocalSettings->Values->Insert(settingName, dynamic_cast<PropertyValue^>(PropertyValue::CreateString(settingValue1)));
00082             break;
00083
00084         case 1:
00085             // Version is already 1.  Nothing to do.
00086             break;
00087
00088         default:
00089             throw ref new Exception(E_FAIL, "Unexpected ApplicationData Version: " + version.ToString());
00090     }
00091
00092     deferral->Complete();
00093 }
00094
00095 void SetVersion::SetVersion0_Click(Object^ sender, RoutedEventArgs^ e)
00096 {
00097     task<void>(appData->SetVersionAsync(0, ref new ApplicationDataSetVersionHandler(this, &SetVersion::SetVersionHandler0))).then([=]
00098     {
00099         DisplayOutput();
00100     });
00101 }
00102
00103 void SetVersion::SetVersion1_Click(Object^ sender, RoutedEventArgs^ e)
00104 {
00105     task<void>(appData->SetVersionAsync(1, ref new ApplicationDataSetVersionHandler(this, &SetVersion::SetVersionHandler1))).then([=]
00106     {
00107         DisplayOutput();
00108     });
00109 }
00110
00111 void SetVersion::DisplayOutput()
00112 {
00113     OutputTextBlock->Text = "Version: " + appData->Version.ToString();
00114 }
00115
00116 /// <summary>
00117 /// Invoked when this page is about to be displayed in a Frame.
00118 /// </summary>
00119 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00120 /// property is typically used to configure the page.</param>
00121 void SetVersion::OnNavigatedTo(NavigationEventArgs^ e)
00122 {
00123     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00124     // as NotifyUser()
00125     rootPage = MainPage::Current;
00126 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/Simple3DTouch.h Source File

  • DirectX touch input

Simple3DTouch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "BasicMath.h"
00012 #include "BasicCamera.h"
00013 #include "MoveLookController.h"
00014 #include "SampleOverlay.h"
00015
00016 // describes the constant buffer that will be used to draw the cube
00017 struct ConstantBuffer
00018 {
00019     float4x4 model;
00020     float4x4 view;
00021     float4x4 projection;
00022 };
00023
00024 #define START_POSITION (float3(0, -1.5, 0))
00025 #define ROOM_BOUNDS (float3(4, 3, 6))
00026
00027 ref class Simple3DTouch : public DirectXBase
00028 {
00029 internal:
00030     Simple3DTouch();
00031
00032     virtual void CreateDeviceIndependentResources() override;
00033     virtual void CreateDeviceResources() override;
00034     virtual void CreateWindowSizeDependentResources() override;
00035     virtual void Render() override;
00036
00037     void Update(float TimeTotal, float TimeDelta);
00038
00039     void SaveInternalState(_In_ Windows::Foundation::Collections::IPropertySet^ state);
00040     void LoadInternalState(_In_ Windows::Foundation::Collections::IPropertySet^ state);
00041
00042 private:
00043
00044     SampleOverlay^                                      m_sampleOverlay;
00045
00046     Microsoft::WRL::ComPtr<ID3D11InputLayout>           m_inputLayout;                // cube vertex input layout
00047     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_vertexBuffer;               // cube vertex buffer
00048     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_indexBuffer;                // cube index buffer
00049     Microsoft::WRL::ComPtr<ID3D11VertexShader>          m_vertexShader;               // cube vertex shader
00050     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_pixelShader;                // cube pixel shader
00051     Microsoft::WRL::ComPtr<ID3D11Texture2D>             m_texture;                    // cube texture
00052     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_textureSRV;                 // cube texture view
00053     Microsoft::WRL::ComPtr<ID3D11SamplerState>          m_sampler;                    // cube texture sampler
00054     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_constantBuffer;             // constant buffer resource
00055
00056     unsigned int                     m_indexCount;                  // cube index count
00057     ConstantBuffer                   m_constantBufferData;          // constant buffer resource data
00058     BasicCamera^                     m_camera;                      // scene camera
00059     MoveLookController^              m_controller;                  // controller to map from input events to movement
00060
00061     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>        m_textBrush;
00062     Microsoft::WRL::ComPtr<IDWriteTextFormat>           m_textFormat;
00063
00064     Microsoft::WRL::ComPtr<IDWriteTextLayout>           m_moveControlLayout;
00065     DWRITE_TEXT_METRICS                                 m_moveMetrics;
00066     Microsoft::WRL::ComPtr<IDWriteTextLayout>           m_lookControlLayout;
00067     DWRITE_TEXT_METRICS                                 m_lookMetrics;
00068 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

StreamSocketSample::sealed Member List

This is the complete list of members for StreamSocketSample::sealed, including all inherited members.
__pad0__ | StreamSocketSample::sealed | [protected]
autoSizeInputSectionWhenSnapped | StreamSocketSample::sealed | [private]
CloseSockets_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | StreamSocketSample::sealed | [private]
ConnectSocket_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | StreamSocketSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | StreamSocketSample::sealed | [private]
HiddenFrame | StreamSocketSample::sealed | [private]
InvalidateSize() | StreamSocketSample::sealed | [private]
InvalidateViewState() | StreamSocketSample::sealed | [private]
listener | StreamSocketSample::sealed | [private]
ListenerContext(MainPage^rootPage, StreamSocketListener^listener) | StreamSocketSample::sealed |
LoadScenario(Platform::String^scenarioName) | StreamSocketSample::sealed |
MainPage() | StreamSocketSample::sealed |
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | StreamSocketSample::sealed | [protected]
MainPageResized | StreamSocketSample::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | StreamSocketSample::sealed |
NotifyUserFromAsyncThread(String^message, NotifyType type) | StreamSocketSample::sealed | [private]
OnConnection(StreamSocketListener^listener, StreamSocketListenerConnectionReceivedEventArgs^object) | StreamSocketSample::sealed |
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | StreamSocketSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | StreamSocketSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | StreamSocketSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | StreamSocketSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | StreamSocketSample::sealed | [protected, virtual]
PopulateScenarios() | StreamSocketSample::sealed | [private]
ReceiveStringLoop(DataReader^reader, StreamSocket^socket) | StreamSocketSample::sealed | [private]
rootPage | StreamSocketSample::sealed | [private]
Scenario1() | StreamSocketSample::sealed |
Scenario2() | StreamSocketSample::sealed |
Scenario3() | StreamSocketSample::sealed |
Scenario4() | StreamSocketSample::sealed |
ScenarioList | StreamSocketSample::sealed | [private]
ScenarioLoaded | StreamSocketSample::sealed |
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | StreamSocketSample::sealed | [protected]
SendHello_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | StreamSocketSample::sealed | [private]
SetFeatureName(Platform::String^strFeature) | StreamSocketSample::sealed | [private]
StartListener_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | StreamSocketSample::sealed | [private]
~ListenerContext() | StreamSocketSample::sealed | [private]
~MainPage() | StreamSocketSample::sealed | [private]
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicReaderWriter.h Source File

  • Direct3D HLSL fractal generator

BasicReaderWriter.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <ppltasks.h>
00011
00012 // A simple reader/writer class that provides support for reading and writing
00013 // files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicReaderWriter
00015 {
00016 private:
00017     Windows::Storage::StorageFolder^ m_location;
00018     Platform::String^ m_locationPath;
00019
00020 internal:
00021     BasicReaderWriter();
00022     BasicReaderWriter(
00023         _In_ Windows::Storage::StorageFolder^ folder
00024         );
00025
00026     Platform::Array<byte>^ ReadData(
00027         _In_ Platform::String^ filename
00028         );
00029
00030     concurrency::task<Platform::Array<byte>^> ReadDataAsync(
00031         _In_ Platform::String^ filename
00032         );
00033
00034     uint32 WriteData(
00035         _In_ Platform::String^ filename,
00036         _In_ const Platform::Array<byte>^ fileData
00037         );
00038
00039     concurrency::task<void> WriteDataAsync(
00040         _In_ Platform::String^ filename,
00041         _In_ const Platform::Array<byte>^ fileData
00042         );
00043 };
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/WorldMesh.h Source File

  • DirectX 3D shooting game

WorldMesh.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "MeshObject.h"
00011
00012 // WorldCeilingMesh:
00013 // This class derives from MeshObject and creates a ID3D11Buffer of
00014 // vertices and indices to represent the ceiling of the bounding cube
00015 // of the world.
00016 // The vertices are defined by a position, a normal and a single
00017 // 2D texture coordinate.
00018
00019 ref class WorldCeilingMesh: public MeshObject
00020 {
00021 internal:
00022     WorldCeilingMesh(_In_ ID3D11Device *device);
00023 };
00024
00025 // WorldFloorMesh:
00026 // This class derives from MeshObject and creates a ID3D11Buffer of
00027 // vertices and indices to represent the floor of the bounding cube
00028 // of the world.
00029
00030 ref class WorldFloorMesh: public MeshObject
00031 {
00032 internal:
00033     WorldFloorMesh(_In_ ID3D11Device *device);
00034 };
00035
00036 // WorldWallsMesh:
00037 // This class derives from MeshObject and creates a ID3D11Buffer of
00038 // vertices and indices to represent the walls of the bounding cube
00039 // of the world.
00040
00041 ref class WorldWallsMesh: public MeshObject
00042 {
00043 internal:
00044     WorldWallsMesh(_In_ ID3D11Device *device);
00045 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::DataBinding::GeneratorIncrementalLoadingClass Member List

This is the complete list of members for SDKSample::DataBinding::GeneratorIncrementalLoadingClass, including all inherited members.
__pad0__ | SDKSample::DataBinding::GeneratorIncrementalLoadingClass |
__pad1__ | SDKSample::DataBinding::GeneratorIncrementalLoadingClass |
_busy | SDKSample::DataBinding::IncrementalLoadingBase |
_count | SDKSample::DataBinding::GeneratorIncrementalLoadingClass |
_isVectorChangedObserved | SDKSample::DataBinding::IncrementalLoadingBase |
_maxCount | SDKSample::DataBinding::GeneratorIncrementalLoadingClass |
_privateVectorChanged | SDKSample::DataBinding::IncrementalLoadingBase |
_storageVectorChanged(Windows::Foundation::Collections::IObservableVector< Platform::Object^>^sender, Windows::Foundation::Collections::IVectorChangedEventArgs^e) | SDKSample::DataBinding::IncrementalLoadingBase | [inline]
Generator(int count) | SDKSample::DataBinding::GeneratorIncrementalLoadingClass | [inline, private]
HasMoreItemsOverride() override | SDKSample::DataBinding::GeneratorIncrementalLoadingClass | [inline, virtual]
LoadMoreItemsOverride(Concurrency::cancellation_token c, unsigned int count) override | SDKSample::DataBinding::GeneratorIncrementalLoadingClass | [inline, virtual]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/MainPage.xaml.h Source File

  • App settings

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Scenario2.xaml.h Source File

  • Gyrometer sensor

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace GyrometerCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Windows::UI::Core::CoreDispatcher^ dispatcher;
00042             Windows::Devices::Sensors::Gyrometer^ gyrometer;
00043             Windows::Foundation::EventRegistrationToken visibilityToken;
00044             uint32 desiredReportInterval;
00045             Windows::UI::Xaml::DispatcherTimer^ dispatcherTimer;
00046
00047             void VisibilityChanged(Platform::Object^ sender, Windows::UI::Core::VisibilityChangedEventArgs^ e);
00048             void DisplayCurrentReading(Platform::Object^ sender, Platform::Object^ e);
00049             void ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050             void ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00051         };
00052     }
00053 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario5.xaml.cpp Source File

  • HttpClient

Scenario5.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario5.xaml.cpp
00013 // Implementation of the Scenario5 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario5.xaml.h"
00018
00019 using namespace SDKSample::HttpClientSample;
00020
00021 using namespace concurrency;
00022 using namespace Microsoft::WRL;
00023 using namespace Platform;
00024 using namespace std;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario5::Scenario5()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void Scenario5::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00043     // as NotifyUser()
00044     rootPage = MainPage::Current;
00045 }
00046
00047
00048 void SDKSample::HttpClientSample::Scenario5::Start_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00049 {
00050     Helpers::ScenarioStarted(StartButton, CancelButton);
00051     rootPage->NotifyUser("In progress", NotifyType::StatusMessage);
00052     OutputField->Text = "";
00053
00054     // 'AddressField' is a disabled text box, so the value is considered trusted input. When enabling the
00055     // text box make sure to validate user input (e.g., by catching exceptions with TryGetUri as shown in scenario 1).
00056     Uri^ resourceAddress = ref new Uri(AddressField->Text);
00057
00058     ComPtr<IStream> stream;
00059     const unsigned int contentLength = 1000;
00060     stream.Attach(GenerateSampleStream(contentLength));
00061
00062     cancellationTokenSource = cancellation_token_source();
00063
00064     // Do an asynchronous POST.  We need to use use_current() with the continuations since the tasks are completed on
00065     // background threads and we need to run on the UI thread to update the UI.
00066     httpRequest.PostAsync(resourceAddress, nullptr, stream.Get(), contentLength,
00067         cancellationTokenSource.get_token()).then([this](task<std::wstring> response)
00068     {
00069         Helpers::ScenarioCompleted(StartButton, CancelButton);
00070
00071         try
00072         {
00073             DisplayTextResult(response.get(), OutputField);
00074             rootPage->NotifyUser("Completed", NotifyType::StatusMessage);
00075         }
00076         catch (const task_canceled&)
00077         {
00078             rootPage->NotifyUser("Request canceled.", NotifyType::ErrorMessage);
00079         }
00080         catch (Exception^ ex)
00081         {
00082             rootPage->NotifyUser(ex->Message, NotifyType::ErrorMessage);
00083         }
00084     }, task_continuation_context::use_current());
00085 }
00086
00087 IStream* SDKSample::HttpClientSample::Scenario5::GenerateSampleStream(unsigned int size)
00088 {
00089     ComPtr<IStream> postStream;
00090     Web::HttpRequest::CreateMemoryStream(&postStream);
00091
00092     // Generate sample data.
00093     std::unique_ptr<byte> subData(new byte[size]);
00094
00095     for (unsigned int i = 0; i < size; i++)
00096     {
00097         subData.get()[i] = '@';
00098     }
00099
00100     CheckHResult(postStream->Write(subData.get(), size, nullptr));
00101
00102     return postStream.Detach();
00103 }
00104
00105 void SDKSample::HttpClientSample::Scenario5::Cancel_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00106 {
00107     cancellationTokenSource.cancel();
00108 }
00109
00110 void SDKSample::HttpClientSample::Scenario5::DisplayTextResult(const std::wstring& response, TextBox^ output)
00111 {
00112     output->Text += httpRequest.GetStatusCode() + " " + ref new String(httpRequest.GetReasonPhrase().c_str()) + "\n";
00113
00114     // Convert all instances of <br> to newline.
00115     std::wstring ws = response;
00116     Helpers::ReplaceAll(ws, L"<br>", L"\n");
00117
00118     output->Text += ref new String(ws.c_str());
00119 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario6.xaml.cpp Source File

  • Search contract

Scenario6.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.cpp
00013 // Implementation of the Scenario6 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario6.xaml.h"
00018
00019 using namespace SDKSample::SearchContract;
00020
00021 using namespace concurrency;
00022 using namespace std;
00023 using namespace Platform;
00024 using namespace Windows::ApplicationModel::Search;
00025 using namespace Windows::Data::Xml::Dom;
00026 using namespace Windows::Foundation;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::Streams;
00029 using namespace Windows::UI::Xaml;
00030 using namespace Windows::UI::Xaml::Controls;
00031 using namespace Windows::UI::Xaml::Navigation;
00032
00033 Scenario6::Scenario6()
00034 {
00035     InitializeComponent();
00036     searchPane = SearchPane::GetForCurrentView();
00037 }
00038
00039 void Scenario6::AddSuggestionFromNode(IXmlNode^ node, SearchSuggestionCollection^ suggestions)
00040 {
00041     String^ text = "";
00042     String^ description = "";
00043     String^ url = "";
00044     String^ imageUrl = "";
00045     String^ imageAlt = "";
00046
00047     for (unsigned int i = 0; i < node->ChildNodes->Size; i++)
00048     {
00049         IXmlNode^ subNode = node->ChildNodes->GetAt(i);
00050         if (subNode->NodeType != NodeType::ElementNode)
00051         {
00052             continue;
00053         }
00054
00055         if (subNode->NodeName->Equals("Text"))
00056         {
00057             text = subNode->InnerText;
00058         }
00059         else if (subNode->NodeName->Equals("Description"))
00060         {
00061             description = subNode->InnerText;
00062         }
00063         else if (subNode->NodeName->Equals("Url"))
00064         {
00065             url = subNode->InnerText;
00066         }
00067         else if (subNode->NodeName->Equals("Image"))
00068         {
00069             if (subNode->Attributes->GetNamedItem("source"))
00070             {
00071                 imageUrl = subNode->Attributes->GetNamedItem("source")->InnerText;
00072             }
00073
00074             if (subNode->Attributes->GetNamedItem("alt"))
00075             {
00076                 imageAlt = subNode->Attributes->GetNamedItem("alt")->InnerText;
00077             }
00078         }
00079     }
00080
00081     if (text->IsEmpty())
00082     {
00083         // No proper suggestion item exists
00084     }
00085     else if (url->IsEmpty())
00086     {
00087         suggestions->AppendQuerySuggestion(text);
00088     }
00089     else
00090     {
00091         // The following image should not be used in your application for Result Suggestions.  Replace the image with one that is tailored to your content
00092         Uri^ uri = imageUrl->IsEmpty() ? ref new Uri("ms-appx:///Assets/SDK_ResultSuggestionImage.png") : ref new Uri(imageUrl);
00093         RandomAccessStreamReference^ imageSource = RandomAccessStreamReference::CreateFromUri(uri);
00094         suggestions->AppendResultSuggestion(text, description, url, imageSource, imageAlt);
00095     }
00096 }
00097
00098 void Scenario6::GetSuggestions(XmlDocument^ doc, SearchPaneSuggestionsRequest^ request)
00099 {
00100     XmlNodeList^ nodes = doc->GetElementsByTagName("Section");
00101     if (nodes->Size > 0)
00102     {
00103         IXmlNode^ section = nodes->GetAt(0);
00104         for (unsigned int i = 0; i < section->ChildNodes->Size; i++)
00105         {
00106             IXmlNode^ node = section->ChildNodes->GetAt(i);
00107             if (node->NodeType != NodeType::ElementNode)
00108             {
00109                 continue;
00110             }
00111
00112             if (node->NodeName->Equals("Separator"))
00113             {
00114                 String^ title = nullptr;
00115                 IXmlNode^ titleAttr = node->Attributes->GetNamedItem("title");
00116                 if (titleAttr != nullptr)
00117                 {
00118                     title = titleAttr->NodeValue->ToString();
00119                 }
00120                 if (title == nullptr || title->IsEmpty())
00121                 {
00122                     title = "Suggestions";
00123                 }
00124                 request->SearchSuggestionCollection->AppendSearchSeparator(title);
00125             }
00126             else
00127             {
00128                 AddSuggestionFromNode(node, request->SearchSuggestionCollection);
00129             }
00130         }
00131     }
00132 }
00133
00134 void Scenario6::OnSearchPaneSuggestionsRequested(SearchPane^ sender, SearchPaneSuggestionsRequestedEventArgs^ e)
00135 {
00136     auto queryText = e->QueryText;
00137     unsigned int queryTextLength = queryText->Length();
00138     if (queryTextLength == 0)
00139     {
00140         MainPage::Current->NotifyUser("Use the search pane to submit a query", NotifyType::StatusMessage);
00141     }
00142     else if (UrlTextBox->Text == "")
00143     {
00144         MainPage::Current->NotifyUser("Please enter the web service URL", NotifyType::StatusMessage);
00145     }
00146     else
00147     {
00148         // Cancel the previous suggestion request if it is not finished.
00149         cts.cancel();
00150         cts = cancellation_token_source();
00151
00152         // The deferral object is used to supply suggestions asynchronously for example when fetching suggestions from a web service.
00153         // Indicate that we'll do this asynchronously:
00154         auto request = e->Request;
00155         auto deferral = request->GetDeferral();
00156
00157         try
00158         {
00159             // Use the web service Url entered in the UrlTextBox that supports XML Search Suggestions in order to see suggestions come from the web service.
00160             // See http://msdn.microsoft.com/en-us/library/cc848863(v=vs.85).aspx for details on XML Search Suggestions format.
00161             // Replace "{searchTerms}" of the Url with the query string.
00162             String^ strUrl = MainPage::ReplaceUrlSearchTerms(UrlTextBox->Text, Uri::EscapeComponent(queryText));
00163             auto token = cts.get_token();
00164             create_task(XmlDocument::LoadFromUriAsync(ref new Uri(strUrl)), token).then([=](XmlDocument^ doc)
00165             {
00166                 Finally f ([&] {
00167                     deferral->Complete(); // Indicate we're done supplying suggestions.
00168                 });
00169                 if (token.is_canceled())
00170                 {
00171                     cancel_current_task();
00172                 }
00173                 GetSuggestions(doc, request);
00174                 if (request->SearchSuggestionCollection->Size > 0)
00175                 {
00176                     MainPage::Current->NotifyUser("Suggestions provided for query: " + queryText, NotifyType::StatusMessage);
00177                 }
00178                 else
00179                 {
00180                     MainPage::Current->NotifyUser("No suggestions provided for query: " + queryText, NotifyType::StatusMessage);
00181                 }
00182             });
00183         }
00184         catch (Exception^)
00185         {
00186             MainPage::Current->NotifyUser("Suggestions could not be displayed, please verify that the service provides valid OpenSearch suggestions", NotifyType::ErrorMessage);
00187         }
00188     }
00189 }
00190
00191 void Scenario6::OnResultSuggestionChosen(SearchPane^ sender, SearchPaneResultSuggestionChosenEventArgs^ e)
00192 {
00193     // Handle the selection of a result suggestion since the XML Suggestion Format can return these.
00194     MainPage::Current->NotifyUser("Result suggestion selected with tag: " + e->Tag, NotifyType::StatusMessage);
00195 }
00196
00197 void Scenario6::OnNavigatedTo(NavigationEventArgs^ e)
00198 {
00199     MainPage::Current->NotifyUser("Use the search pane to submit a query", NotifyType::StatusMessage);
00200     // These events should be registered when your app first creates its main window after receiving an activated event, like OnLaunched, OnSearchActivated.
00201     // Typically this occurs in App.xaml.cpp.
00202     suggestionsRequestedToken = searchPane->SuggestionsRequested += ref new TypedEventHandler<SearchPane^, SearchPaneSuggestionsRequestedEventArgs^>(this, &Scenario6::OnSearchPaneSuggestionsRequested);
00203     resultSuggestionChosenToken = searchPane->ResultSuggestionChosen += ref new TypedEventHandler<SearchPane^, SearchPaneResultSuggestionChosenEventArgs^>(this, &Scenario6::OnResultSuggestionChosen);
00204 }
00205
00206 void Scenario6::OnNavigatedFrom(NavigationEventArgs^ e)
00207 {
00208     searchPane->SuggestionsRequested -= suggestionsRequestedToken;
00209     searchPane->ResultSuggestionChosen -= resultSuggestionChosenToken;
00210 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Extruder Member List

This is the complete list of members for Extruder, including all inherited members.
D2DFlatten(ID2D1Geometry *pGeometry, float flatteningTolerance, ID2D1Geometry **ppGeometry) | Extruder | [private, static]
D2DOutline(ID2D1Geometry *pGeometry, ID2D1Geometry **ppGeometry) | Extruder | [private, static]
ExtrudeGeometry(ID2D1Geometry *pGeometry, float height, std::vector< SimpleVertex > *vertices) | Extruder | [static]
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SimpleBlogReader::sealed Member List

This is the complete list of members for SimpleBlogReader::sealed, including all inherited members.
App() | SimpleBlogReader::sealed |
Author | SimpleBlogReader::sealed |
Content | SimpleBlogReader::sealed |
Convert(Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language) | SimpleBlogReader::sealed | [inline, virtual]
ConvertBack(Platform::Object^value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^parameter, Platform::String^language) | SimpleBlogReader::sealed | [inline, virtual]
CurrentFeedUri | SimpleBlogReader::sealed |
DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState) override | SimpleBlogReader::sealed | [protected, virtual]
FeedData(void) | SimpleBlogReader::sealed | [inline]
feedData | SimpleBlogReader::sealed | [private]
FeedDataSource() | SimpleBlogReader::sealed |
FeedItem(void) | SimpleBlogReader::sealed | [inline]
GetFeedAsync(Platform::String^title) | SimpleBlogReader::sealed | [static]
GetFeedData(Platform::String^feedUri, Windows::Web::Syndication::SyndicationFeed^feed) | SimpleBlogReader::sealed | [private]
GetFeedData(Platform::String^feedUriString) | SimpleBlogReader::sealed | [private]
GetFeedItem(FeedData^fd, Platform::String^uniqueiD) | SimpleBlogReader::sealed | [static]
GoBack(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) override | SimpleBlogReader::sealed | [protected, virtual]
ItemListView_SelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SimpleBlogReader::sealed | [private]
ItemListView_SelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SimpleBlogReader::sealed | [private]
ItemsPage() | SimpleBlogReader::sealed |
ItemView_ItemClick(Platform::Object^sender, Windows::UI::Xaml::Controls::ItemClickEventArgs^e) | SimpleBlogReader::sealed | [protected, virtual]
Link | SimpleBlogReader::sealed |
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SimpleBlogReader::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SimpleBlogReader::sealed | [protected, virtual]
m_feedCompletionEvents | SimpleBlogReader::sealed | [private]
m_feeds | SimpleBlogReader::sealed | [private]
m_items | SimpleBlogReader::sealed | [private]
MainPage() | SimpleBlogReader::sealed |
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SimpleBlogReader::sealed | [virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SimpleBlogReader::sealed | [protected, virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^e) | SimpleBlogReader::sealed | [private]
PageLoadedHandler(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SimpleBlogReader::sealed | [private]
PubDate | SimpleBlogReader::sealed |
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SimpleBlogReader::sealed | [protected, virtual]
SplitPage() | SimpleBlogReader::sealed |
Title | SimpleBlogReader::sealed |
Uri | SimpleBlogReader::sealed |
UsingLogicalPageNavigation() | SimpleBlogReader::sealed | [private]
UsingLogicalPageNavigation(Windows::UI::ViewManagement::ApplicationViewState viewState) | SimpleBlogReader::sealed | [private]
ViewDetail_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SimpleBlogReader::sealed | [protected]
~FeedData(void) | SimpleBlogReader::sealed | [inline, private]
~FeedItem(void) | SimpleBlogReader::sealed | [inline, private]
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/App.xaml.cpp Source File

  • Display orientation

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/MainPage.xaml.h Source File

  • Thread pool

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/sample-utils/CppSamplesUtils.h Source File

  • Configure keys for media
  • sample-utils

CppSamplesUtils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::ToastContent::ToastImageAndText04 Member List

This is the complete list of members for NotificationsExtensions::ToastContent::ToastImageAndText04, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
Audio | NotificationsExtensions::ToastContent::ToastNotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
CreateNotification() | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline]
Duration | NotificationsExtensions::ToastContent::ToastNotificationBase |
GetContent() | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline, virtual]
GetContent() | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::ToastContent::ToastImageAndText04 |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
Launch | NotificationsExtensions::ToastContent::ToastNotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBody1 | NotificationsExtensions::ToastContent::ToastImageAndText04 |
TextBody2 | NotificationsExtensions::ToastContent::ToastImageAndText04 |
TextFields | NotificationsExtensions::NotificationBase |
TextHeading | NotificationsExtensions::ToastContent::ToastImageAndText04 |
ToastImageAndText04() | NotificationsExtensions::ToastContent::ToastImageAndText04 | [inline]
ToastImageAndText04() | NotificationsExtensions::ToastContent::ToastImageAndText04 | [inline]
ToastNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline]
ToastNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexNormalMaps.cpp Source File

  • Direct3D resource loading
  • texconv

DirectXTexNormalMaps.cpp

Go to the documentation of this file.
00001 //-------------------------------------------------------------------------------------
00002 // DirectXTexNormalMaps.cpp
00003 //
00004 // DirectX Texture Library - Normal map operations
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //-------------------------------------------------------------------------------------
00013
00014 #include "directxtexp.h"
00015
00016 namespace DirectX
00017 {
00018
00019 #pragma prefast(suppress : 25000, "FXMVECTOR is 16 bytes")
00020 static inline float _EvaluateColor( _In_ FXMVECTOR val, _In_ DWORD flags )
00021 {
00022     XMFLOAT4A f;
00023
00024     static XMVECTORF32 lScale = { 0.2125f, 0.7154f, 0.0721f, 1.f };
00025
00026     static_assert( CNMAP_CHANNEL_RED == 0x1, "CNMAP_CHANNEL_ flag values don't match mask" );
00027     switch( flags & 0xf )
00028     {
00029     case 0:
00030     case CNMAP_CHANNEL_RED:     return XMVectorGetX( val );
00031     case CNMAP_CHANNEL_GREEN:   return XMVectorGetY( val );
00032     case CNMAP_CHANNEL_BLUE:    return XMVectorGetZ( val );
00033     case CNMAP_CHANNEL_ALPHA:   return XMVectorGetW( val );
00034
00035     case CNMAP_CHANNEL_LUMINANCE:
00036         {
00037             XMVECTOR v = XMVectorMultiply( val, lScale );
00038             XMStoreFloat4A( &f, v );
00039             return f.x + f.y + f.z;
00040         }
00041         break;
00042
00043     default:
00044         assert(false);
00045         return 0.f;
00046     }
00047 }
00048
00049 static void _EvaluateRow( _In_reads_(width) const XMVECTOR* pSource, _Out_writes_(width+2) float* pDest,
00050                           _In_ size_t width, _In_ DWORD flags )
00051 {
00052     assert( pSource && pDest );
00053     assert( width > 0 );
00054
00055     for( size_t x = 0; x < width; ++x )
00056     {
00057         pDest[x+1] = _EvaluateColor( pSource[x], flags );
00058     }
00059
00060     if ( flags & CNMAP_MIRROR_U )
00061     {
00062         // Mirror in U
00063         pDest[0] = _EvaluateColor( pSource[0], flags );
00064         pDest[width+1] = _EvaluateColor( pSource[width-1], flags );
00065     }
00066     else
00067     {
00068         // Wrap in U
00069         pDest[0] = _EvaluateColor( pSource[width-1], flags );
00070         pDest[width+1] = _EvaluateColor( pSource[0], flags );
00071     }
00072 }
00073
00074 static HRESULT _ComputeNMap( _In_ const Image& srcImage, _In_ DWORD flags, _In_ float amplitude,
00075                              _In_ DXGI_FORMAT format, _In_ const Image& normalMap )
00076 {
00077     if ( !srcImage.pixels || !normalMap.pixels )
00078         return E_INVALIDARG;
00079
00080     assert( !IsCompressed(format) && !IsTypeless( format ) );
00081
00082     const DWORD convFlags = _GetConvertFlags( format );
00083     if ( !convFlags )
00084         return E_FAIL;
00085
00086     if ( !( convFlags & (CONVF_UNORM | CONVF_SNORM | CONVF_FLOAT) ) )
00087         HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00088
00089     const size_t width = srcImage.width;
00090     const size_t height = srcImage.height;
00091     if ( width != normalMap.width || height != normalMap.height )
00092         return E_FAIL;
00093
00094     // Allocate temporary space (4 scanlines and 3 evaluated rows)
00095     ScopedAlignedArrayXMVECTOR scanline( reinterpret_cast<XMVECTOR*>( _aligned_malloc( (sizeof(XMVECTOR)*width*4), 16 ) ) );
00096     if ( !scanline )
00097         return E_OUTOFMEMORY;
00098
00099     ScopedAlignedArrayFloat buffer( reinterpret_cast<float*>( _aligned_malloc( ( ( sizeof(float) * ( width + 2 ) ) * 3 ), 16 ) ) );
00100     if ( !buffer )
00101         return E_OUTOFMEMORY;
00102
00103     uint8_t* pDest = normalMap.pixels;
00104     if ( !pDest )
00105         return E_POINTER;
00106
00107     XMVECTOR* row0 = scanline.get();
00108     XMVECTOR* row1 = row0 + width;
00109     XMVECTOR* row2 = row1 + width;
00110     XMVECTOR* target = row2 + width;
00111
00112     float* val0 = buffer.get();
00113     float* val1 = val0 + width + 2;
00114     float* val2 = val1 + width + 2;
00115
00116     const size_t rowPitch = srcImage.rowPitch;
00117     const uint8_t* pSrc = srcImage.pixels;
00118
00119     // Read first scanline row into 'row1'
00120     if ( !_LoadScanline( row1, width, pSrc, rowPitch, srcImage.format ) )
00121         return E_FAIL;
00122
00123     // Setup 'row0'
00124     if ( flags & CNMAP_MIRROR_V )
00125     {
00126         // Mirror first row
00127         memcpy_s( row0, rowPitch, row1, rowPitch );
00128     }
00129     else
00130     {
00131         // Read last row (Wrap V)
00132         if ( !_LoadScanline( row0, width, pSrc + (rowPitch * (height-1)), rowPitch, srcImage.format ) )
00133             return E_FAIL;
00134     }
00135
00136     // Evaluate the initial rows
00137     _EvaluateRow( row0, val0, width, flags );
00138     _EvaluateRow( row1, val1, width, flags );
00139
00140     pSrc += rowPitch;
00141
00142     for( size_t y = 0; y < height; ++y )
00143     {
00144         // Load next scanline of source image
00145         if ( y < (height-1) )
00146         {
00147             if ( !_LoadScanline( row2, width, pSrc, rowPitch, srcImage.format ) )
00148                 return E_FAIL;
00149         }
00150         else
00151         {
00152             if ( flags & CNMAP_MIRROR_V )
00153             {
00154                 // Use last row of source image
00155                 if ( !_LoadScanline( row2, width, srcImage.pixels + (rowPitch * (height-1)), rowPitch, srcImage.format ) )
00156                     return E_FAIL;
00157             }
00158             else
00159             {
00160                 // Use first row of source image (Wrap V)
00161                 if ( !_LoadScanline( row2, width, srcImage.pixels, rowPitch, srcImage.format ) )
00162                     return E_FAIL;
00163             }
00164         }
00165
00166         // Evaluate row
00167         _EvaluateRow( row2, val2, width, flags );
00168
00169         // Generate target scanline
00170         XMVECTOR *dptr = target;
00171         for( size_t x = 0; x < width; ++x )
00172         {
00173             // Compute normal via central differencing
00174             float totDelta = ( val0[x] - val0[x+2] ) + ( val1[x] - val1[x+2] ) + ( val2[x] - val2[x+2] );
00175             float deltaZX = totDelta * amplitude / 6.f;
00176
00177             totDelta = ( val0[x] - val2[x] ) + ( val0[x+1] - val2[x+1] ) + ( val0[x+2] - val2[x+2] );
00178             float deltaZY = totDelta * amplitude / 6.f;
00179
00180             XMVECTOR vx = XMVectorSetZ( g_XMNegIdentityR0, deltaZX );   // (-1.0f, 0.0f, deltaZX)
00181             XMVECTOR vy = XMVectorSetZ( g_XMNegIdentityR1, deltaZY );   // (0.0f, -1.0f, deltaZY)
00182
00183             XMVECTOR normal = XMVector3Normalize( XMVector3Cross( vx, vy ) );
00184
00185             // Compute alpha (1.0 or an occlusion term)
00186             float alpha = 1.f;
00187
00188             if ( flags & CNMAP_COMPUTE_OCCLUSION )
00189             {
00190                 float delta = 0.f;
00191                 float c = val1[x+1];
00192
00193                 float t = val0[x] - c;  if ( t > 0.f ) delta += t;
00194                 t = val0[x+1]   - c;    if ( t > 0.f ) delta += t;
00195                 t = val0[x+2]   - c;    if ( t > 0.f ) delta += t;
00196                 t = val1[x]     - c;    if ( t > 0.f ) delta += t;
00197                 // Skip current pixel
00198                 t = val1[x+2]   - c;    if ( t > 0.f ) delta += t;
00199                 t = val2[x]     - c;    if ( t > 0.f ) delta += t;
00200                 t = val2[x+1]   - c;    if ( t > 0.f ) delta += t;
00201                 t = val2[x+2]   - c;    if ( t > 0.f ) delta += t;
00202
00203                 // Average delta (divide by 8, scale by amplitude factor)
00204                 delta *= 0.125f * amplitude;
00205                 if ( delta > 0.f )
00206                 {
00207                     // If < 0, then no occlusion
00208                     float r = sqrtf( 1.f + delta*delta );
00209                     alpha = (r - delta) / r;
00210                 }
00211             }
00212
00213             // Encode based on target format
00214             if ( convFlags & CONVF_UNORM )
00215             {
00216                 // 0.5f*normal + 0.5f -or- invert sign case: -0.5f*normal + 0.5f
00217                 XMVECTOR n1 = XMVectorMultiplyAdd( (flags & CNMAP_INVERT_SIGN) ? g_XMNegativeOneHalf : g_XMOneHalf, normal, g_XMOneHalf );
00218                 *dptr++ = XMVectorSetW( n1, alpha );
00219             }
00220             else if ( flags & CNMAP_INVERT_SIGN )
00221             {
00222                 *dptr++ = XMVectorSetW( XMVectorNegate( normal ), alpha );
00223             }
00224             else
00225             {
00226                 *dptr++ = XMVectorSetW( normal, alpha );
00227             }
00228         }
00229
00230         if ( !_StoreScanline( pDest, normalMap.rowPitch, format, target, width ) )
00231             return E_FAIL;
00232
00233         // Cycle buffers
00234         float* temp = val0;
00235         val0 = val1;
00236         val1 = val2;
00237         val2 = temp;
00238
00239         pSrc += rowPitch;
00240         pDest += normalMap.rowPitch;
00241     }
00242
00243     return S_OK;
00244 }
00245
00246
00247 //=====================================================================================
00248 // Entry points
00249 //=====================================================================================
00250
00251 //-------------------------------------------------------------------------------------
00252 // Generates a normal map from a height-map
00253 //-------------------------------------------------------------------------------------
00254 _Use_decl_annotations_
00255 HRESULT ComputeNormalMap( const Image& srcImage, DWORD flags, float amplitude,
00256                           DXGI_FORMAT format, ScratchImage& normalMap )
00257 {
00258     if ( !srcImage.pixels || !IsValid(format) || IsCompressed( format ) || IsTypeless( format ) )
00259         return E_INVALIDARG;
00260
00261     static_assert( CNMAP_CHANNEL_RED == 0x1, "CNMAP_CHANNEL_ flag values don't match mask" );
00262     switch( flags & 0xf )
00263     {
00264     case 0:
00265     case CNMAP_CHANNEL_RED:
00266     case CNMAP_CHANNEL_GREEN:
00267     case CNMAP_CHANNEL_BLUE:
00268     case CNMAP_CHANNEL_ALPHA:
00269     case CNMAP_CHANNEL_LUMINANCE:
00270         break;
00271
00272     default:
00273         return E_INVALIDARG;
00274     }
00275
00276     if ( IsCompressed( srcImage.format ) || IsTypeless( srcImage.format ) )
00277         return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00278
00279     // Setup target image
00280     normalMap.Release();
00281
00282     HRESULT hr = normalMap.Initialize2D( format, srcImage.width, srcImage.height, 1, 1 );
00283     if ( FAILED(hr) )
00284         return hr;
00285
00286     const Image *img = normalMap.GetImage( 0, 0, 0 );
00287     if ( !img )
00288     {
00289         normalMap.Release();
00290         return E_POINTER;
00291     }
00292
00293     hr = _ComputeNMap( srcImage, flags, amplitude, format, *img );
00294     if ( FAILED(hr) )
00295     {
00296         normalMap.Release();
00297         return hr;
00298     }
00299
00300     return S_OK;
00301 }
00302
00303 _Use_decl_annotations_
00304 HRESULT ComputeNormalMap( const Image* srcImages, size_t nimages, const TexMetadata& metadata,
00305                           DWORD flags, float amplitude, DXGI_FORMAT format, ScratchImage& normalMaps )
00306 {
00307     if ( !srcImages || !nimages )
00308         return E_INVALIDARG;
00309
00310     if ( !IsValid(format) || IsCompressed(format) || IsTypeless(format) )
00311         return E_INVALIDARG;
00312
00313     static_assert( CNMAP_CHANNEL_RED == 0x1, "CNMAP_CHANNEL_ flag values don't match mask" );
00314     switch( flags & 0xf )
00315     {
00316     case 0:
00317     case CNMAP_CHANNEL_RED:
00318     case CNMAP_CHANNEL_GREEN:
00319     case CNMAP_CHANNEL_BLUE:
00320     case CNMAP_CHANNEL_ALPHA:
00321     case CNMAP_CHANNEL_LUMINANCE:
00322         break;
00323
00324     default:
00325         return E_INVALIDARG;
00326     }
00327
00328     normalMaps.Release();
00329
00330     TexMetadata mdata2 = metadata;
00331     mdata2.format = format;
00332     HRESULT hr = normalMaps.Initialize( mdata2 );
00333     if ( FAILED(hr) )
00334         return hr;
00335
00336     if ( nimages != normalMaps.GetImageCount() )
00337     {
00338         normalMaps.Release();
00339         return E_FAIL;
00340     }
00341
00342     const Image* dest = normalMaps.GetImages();
00343     if ( !dest )
00344     {
00345         normalMaps.Release();
00346         return E_POINTER;
00347     }
00348
00349     for( size_t index=0; index < nimages; ++index )
00350     {
00351         assert( dest[ index ].format == format );
00352
00353         const Image& src = srcImages[ index ];
00354         if ( IsCompressed( src.format ) || IsTypeless( src.format ) )
00355         {
00356             normalMaps.Release();
00357             return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
00358         }
00359
00360         if ( src.width != dest[ index ].width || src.height != dest[ index ].height )
00361         {
00362             normalMaps.Release();
00363             return E_FAIL;
00364         }
00365
00366         hr = _ComputeNMap( src, flags, amplitude, format, dest[ index ] );
00367         if ( FAILED(hr) )
00368         {
00369             normalMaps.Release();
00370             return hr;
00371         }
00372     }
00373
00374     return S_OK;
00375 }
00376
00377 }; // namespace
Generated on Sat Nov 23 2024 16:08:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaExtensionsCS::ScenarioOutput2 Member List

This is the complete list of members for MediaExtensionsCS::ScenarioOutput2, including all inherited members.
__pad0__ | Element |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Page | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) | Element | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
OnNavigatedFrom(NavigationEventArgs e) | MediaExtensionsCS::ScenarioOutput2 | [inline, protected]
OnNavigatedTo(NavigationEventArgs e) | MediaExtensionsCS::ScenarioOutput2 | [inline, protected]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
rootPage | MediaExtensionsCS::ScenarioOutput2 | [private]
ScenarioOutput2() | MediaExtensionsCS::ScenarioOutput2 | [inline]
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/App.xaml.h Source File

  • XAML Direct2D lighting effects

App.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "MainPage.xaml.h"
00011 #include "App.g.h"
00012
00013 namespace D2DLightingEffects
00014 {
00015     [Windows::Foundation::Metadata::WebHostHidden]
00016     public ref class App sealed
00017     {
00018     public:
00019         App();
00020
00021         virtual void OnLaunched(
00022             _In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args
00023             ) override;
00024
00025     private:
00026         void OnResuming(
00027             _In_ Platform::Object^ sender,
00028             _In_ Platform::Object^ args
00029             );
00030
00031         void OnSuspending(
00032             _In_ Platform::Object^ sender,
00033             _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00034             );
00035
00036         MainPage^ m_mainPage;
00037     };
00038 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Scenario1.xaml.h Source File

  • XAML AppBar control

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace AppBarControl
00023 {
00024     /// <summary>
00025     /// An empty page that can be used on its own or navigated to within a Frame.
00026     /// </summary>
00027     [Windows::Foundation::Metadata::WebHostHidden]
00028     public ref class Scenario1 sealed
00029     {
00030     public:
00031         Scenario1();
00032
00033     protected:
00034         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00035     private:
00036         MainPage^ rootPage;
00037      };
00038 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario5.xaml.h Source File

  • File picker

Scenario5.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario5.xaml.h
00013 // Declaration of the Scenario5 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario5.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FilePicker
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario5 sealed
00030         {
00031         public:
00032             Scenario5();
00033
00034         private:
00035             MainPage^ rootPage;
00036             Platform::String^ fileToken;
00037
00038             void PickFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039             void OutputFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void OutputFileAsync(Windows::Storage::StorageFile^ file);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/ServicingComplete.h Source File

  • Background task
  • Tasks

ServicingComplete.h

Go to the documentation of this file.
00001 #pragma once
00002
00003 #include "pch.h"
00004
00005 using namespace Windows::ApplicationModel::Background;
00006
00007 namespace Tasks
00008 {
00009     public ref class ServicingComplete sealed : public IBackgroundTask
00010     {
00011
00012     public:
00013         ServicingComplete();
00014
00015         virtual void Run(IBackgroundTaskInstance^ taskInstance);
00016         void OnCanceled(IBackgroundTaskInstance^ taskInstance, BackgroundTaskCancellationReason reason);
00017
00018     private:
00019         ~ServicingComplete();
00020
00021         volatile bool CancelRequested;
00022     };
00023 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/common/suspensionmanager.cpp Source File

  • Search contract
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/pch.cpp Source File

  • XAML vector-based drawing

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::FileAccess::sealed Member List

This is the complete list of members for SDKSample::FileAccess::sealed, including all inherited members.
AddToListButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
CopyFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
CreateFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
dateAccessedProperty | SDKSample::FileAccess::sealed | [private, static]
dateFormat | SDKSample::FileAccess::sealed | [private, static]
DeleteFileButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
fileOwnerProperty | SDKSample::FileAccess::sealed | [private, static]
GetBufferFromString(Platform::String^str) | SDKSample::FileAccess::sealed | [private]
OpenFromListButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
ReadBytesButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
ReadFromStreamButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
ReadTextButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
rootPage | SDKSample::FileAccess::sealed | [private]
Scenario1() | SDKSample::FileAccess::sealed |
Scenario2() | SDKSample::FileAccess::sealed |
Scenario3() | SDKSample::FileAccess::sealed |
Scenario4() | SDKSample::FileAccess::sealed |
Scenario5() | SDKSample::FileAccess::sealed |
Scenario6() | SDKSample::FileAccess::sealed |
Scenario7() | SDKSample::FileAccess::sealed |
Scenario8() | SDKSample::FileAccess::sealed |
ShowListButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
ShowPropertiesButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
timeFormat | SDKSample::FileAccess::sealed | [private, static]
WriteBytesButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
WriteTextButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
WriteToStreamButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileAccess::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicMath.h Source File

  • Direct3D sprite

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ComAutoRelease Member List

This is the complete list of members for ComAutoRelease, including all inherited members.
operator()(IUnknown *p) | ComAutoRelease | [inline]
operator()(IUnknown *p) | ComAutoRelease | [inline]
operator()(IUnknown *p) | ComAutoRelease | [inline]
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::AccelerometerCPP::sealed Member List

This is the complete list of members for SDKSample::AccelerometerCPP::sealed, including all inherited members.
accelerometer | SDKSample::AccelerometerCPP::sealed | [private]
desiredReportInterval | SDKSample::AccelerometerCPP::sealed | [private]
dispatcher | SDKSample::AccelerometerCPP::sealed | [private]
dispatcherTimer | SDKSample::AccelerometerCPP::sealed | [private]
DisplayCurrentReading(Platform::Object^sender, Platform::Object^e) | SDKSample::AccelerometerCPP::sealed | [private]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::AccelerometerCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::AccelerometerCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::AccelerometerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::AccelerometerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::AccelerometerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::AccelerometerCPP::sealed | [protected, virtual]
ReadingChanged(Windows::Devices::Sensors::Accelerometer^sender, Windows::Devices::Sensors::AccelerometerReadingChangedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
readingToken | SDKSample::AccelerometerCPP::sealed | [private]
rootPage | SDKSample::AccelerometerCPP::sealed | [private]
Scenario1() | SDKSample::AccelerometerCPP::sealed |
Scenario2() | SDKSample::AccelerometerCPP::sealed |
Scenario3() | SDKSample::AccelerometerCPP::sealed |
ScenarioDisable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
ScenarioDisable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
ScenarioDisable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
ScenarioEnable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
ScenarioEnable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
ScenarioEnable(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
shakeCounter | SDKSample::AccelerometerCPP::sealed | [private]
Shaken(Windows::Devices::Sensors::Accelerometer^sender, Windows::Devices::Sensors::AccelerometerShakenEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
shakenToken | SDKSample::AccelerometerCPP::sealed | [private]
VisibilityChanged(Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
VisibilityChanged(Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
VisibilityChanged(Platform::Object^sender, Windows::UI::Core::VisibilityChangedEventArgs^e) | SDKSample::AccelerometerCPP::sealed | [private]
visibilityToken | SDKSample::AccelerometerCPP::sealed | [private]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/AutoThrottle.h Source File

  • Direct3D HLSL fractal generator

AutoThrottle.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 enum class FrameWorkload
00011 {
00012     Increase,
00013     Decrease,
00014     Maintain
00015 };
00016
00017 ref class AutoThrottle
00018 {
00019 internal:
00020     AutoThrottle(float targetFrameTime);
00021     FrameWorkload Update(float frameTime);
00022
00023 private:
00024     unsigned int m_missedFrameHistory;
00025     float m_targetFrameTime;
00026 };
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/Constants.cpp Source File

  • Playback Manager msAudioCategory

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Stream type: BackgroundCapableMedia", "SDKSample.PlaybackManager.StreamTypeBackgroundCapableMedia" },
00022     { "Stream type: Communications", "SDKSample.PlaybackManager.StreamTypeCommunications" },
00023     { "Stream type: Other", "SDKSample.PlaybackManager.StreamTypeOther" },
00024     { "Stream type: ForegroundOnlyMedia", "SDKSample.PlaybackManager.StreamTypeForegroundOnlyMedia" },
00025     { "Stream type: Alert", "SDKSample.PlaybackManager.StreamTypeAlert" }
00026 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

StreamingVoiceContext Member List

This is the complete list of members for StreamingVoiceContext, including all inherited members.
STDMETHOD_(void, OnVoiceProcessingPassStart)(UINT32) | StreamingVoiceContext | [inline]
STDMETHOD_(void, OnVoiceProcessingPassEnd)() | StreamingVoiceContext | [inline]
STDMETHOD_(void, OnStreamEnd)() | StreamingVoiceContext | [inline]
STDMETHOD_(void, OnBufferStart)(void *) | StreamingVoiceContext | [inline]
STDMETHOD_(void, OnBufferEnd)(void *pContext) | StreamingVoiceContext | [inline]
STDMETHOD_(void, OnLoopEnd)(void *) | StreamingVoiceContext | [inline]
STDMETHOD_(void, OnVoiceError)(void * | StreamingVoiceContext |
StreamingVoiceContext() | StreamingVoiceContext | [inline]
~StreamingVoiceContext() | StreamingVoiceContext | [inline, virtual]
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioOutput3.xaml.h Source File

  • Lock screen apps
  • C#,C++

ScenarioOutput3.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Output.xaml.h
00010 // Declaration of the Scenario2Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput3.g.h"
00017 #include "MainPage.g.h"
00018
00019 namespace LockScreenAppsCPP
00020 {
00021     public ref class ScenarioOutput3 sealed
00022     {
00023     public:
00024         ScenarioOutput3();
00025
00026   private:
00027         ~ScenarioOutput3();
00028     };
00029 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/FlowSink.h Source File

  • DirectWrite vertical text

FlowSink.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // Contents:    Source interface for where text is allowed to flow.
00009 //
00010 //----------------------------------------------------------------------------
00011 #pragma once
00012
00013 class DECLSPEC_UUID("7712E74A-C7E0-4664-B58E-854394F2ACB4") FlowLayoutSink
00014     :   public ComBase<QiListSelf<FlowLayoutSink, QiList<IUnknown>>>
00015 {
00016 public:
00017     FlowLayoutSink(Microsoft::WRL::ComPtr<IDWriteFactory> dwriteFactory):
00018         m_dwriteFactory(dwriteFactory),
00019         m_textAnalyzer()
00020     {
00021     }
00022
00023     void Reset();
00024
00025     void Prepare(UINT32 glyphCount);
00026
00027     void SetGlyphRun(
00028         float x,
00029         float y,
00030         UINT32 glyphCount,
00031         const UINT16* glyphIndices,
00032         const float* glyphAdvances,
00033         const DWRITE_GLYPH_OFFSET* glyphOffsets,
00034         Microsoft::WRL::ComPtr<IDWriteFontFace> fontFace,
00035         float fontEmSize,
00036         UINT8 glyphOrientation,
00037         bool isReversed,
00038         bool isSideways
00039         );
00040
00041     void DrawGlyphRuns(
00042         Microsoft::WRL::ComPtr<ID2D1DeviceContext> deviceContext,
00043         Microsoft::WRL::ComPtr<IDWriteRenderingParams> renderingParams,
00044         Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> textColor
00045         ) const;
00046
00047 protected:
00048     // This glyph run is based off DWRITE_GLYPH_RUN
00049     // and is trivially convertable to it, but stores
00050     // pointers as relative indices instead instead
00051     // of raw pointers, which makes it more useful for
00052     // storing in a vector. Additionally, it stores
00053     // the x, y coordinate.
00054
00055     struct CustomGlyphRun
00056     {
00057         CustomGlyphRun()
00058         :   fontFace(),
00059             fontEmSize(),
00060             glyphStart(),
00061             glyphCount(),
00062             glyphOrientation(),
00063             isSideways(),
00064             isReversed(),
00065             x(),
00066             y()
00067         { }
00068
00069         CustomGlyphRun(const CustomGlyphRun& b)
00070         {
00071             memcpy(this, &b, sizeof(*this));
00072             fontFace = SafeAcquire(b.fontFace);
00073         }
00074
00075         CustomGlyphRun& operator =(const CustomGlyphRun& b)
00076         {
00077             if (this != &b)
00078             {
00079                 // Define assignment operator in terms of destructor and
00080                 // placement new constructor, paying heed to self assignment.
00081                 this->~CustomGlyphRun();
00082                 new(this) CustomGlyphRun(b);
00083             }
00084             return *this;
00085         }
00086
00087         IDWriteFontFace* fontFace;
00088         float fontEmSize;
00089         float x;
00090         float y;
00091         UINT32 glyphStart;
00092         UINT32 glyphCount;
00093         UINT8 glyphOrientation;
00094         bool isSideways;
00095         bool isReversed;
00096
00097         void Convert(
00098             const UINT16* glyphIndices,                 // [glyphCount]
00099             const float* glyphAdvances,                 // [glyphCount]
00100             const DWRITE_GLYPH_OFFSET* glyphOffsets,    // [glyphCount]
00101             OUT DWRITE_GLYPH_RUN* glyphRun
00102             ) const;
00103     };
00104
00105     std::vector<CustomGlyphRun>         m_glyphRuns;
00106     std::vector<UINT16>                 m_glyphIndices;
00107     std::vector<float>                  m_glyphAdvances;
00108     std::vector<DWRITE_GLYPH_OFFSET>    m_glyphOffsets;
00109
00110     Microsoft::WRL::ComPtr<IDWriteFactory> m_dwriteFactory;
00111     mutable Microsoft::WRL::ComPtr<IDWriteTextAnalyzer1> m_textAnalyzer;
00112 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TripOptimizerComponent::Details::TripOptimizerImpl Member List

This is the complete list of members for TripOptimizerComponent::Details::TripOptimizerImpl, including all inherited members.
CreateGraph(const std::vector< std::wstring > &waypoints, std::vector< std::shared_ptr< AntSystem::Node >> &nodes, std::vector< std::shared_ptr< AntSystem::Edge >> &edges) | TripOptimizerComponent::Details::TripOptimizerImpl | [private]
InternalOptimizeTripAsync(std::shared_ptr< OptimizeTripParams > params, concurrency::cancellation_token cancellationToken, concurrency::progress_reporter< Platform::String^> reporter) | TripOptimizerComponent::Details::TripOptimizerImpl | [private]
m_cancellationTokenSource | TripOptimizerComponent::Details::TripOptimizerImpl | [private]
OptimizeTripAsync(Windows::Foundation::Collections::IVector< Platform::String^>^waypoints, Platform::String^travelMode, Platform::String^optimize, Platform::String^bingMapsKey, double alpha, double beta, double rho, unsigned int iterations, bool parallel) | TripOptimizerComponent::Details::TripOptimizerImpl |
ProcessLocation(std::shared_ptr< AntSystem::Node > node, Windows::Data::Xml::Dom::XmlDocument^data, concurrency::concurrent_vector< std::shared_ptr< AntSystem::Node >> &unresolvedLocations) | TripOptimizerComponent::Details::TripOptimizerImpl | [private]
ProcessRoute(std::shared_ptr< AntSystem::Edge > edge, Windows::Data::Xml::Dom::XmlDocument^data) | TripOptimizerComponent::Details::TripOptimizerImpl | [private]
RetrieveLocationsAsync(std::shared_ptr< OptimizeTripParams > params, concurrency::cancellation_token cancellationToken, concurrency::progress_reporter< Platform::String^> reporter) | TripOptimizerComponent::Details::TripOptimizerImpl | [private]
RetrieveRoutesAsync(std::shared_ptr< OptimizeTripParams > params, concurrency::cancellation_token cancellationToken, concurrency::progress_reporter< Platform::String^> reporter) | TripOptimizerComponent::Details::TripOptimizerImpl | [private]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/common/suspensionmanager.h Source File

  • Thread pool
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario4.xaml.h Source File

  • XAML accessibility

Scenario4.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024   namespace Accessibility
00025   {
00026     using namespace Windows::UI::Xaml::Data;
00027         using namespace Windows::UI::Xaml;
00028         using namespace Windows::UI::Xaml::Automation;
00029
00030     /// <summary>
00031     /// An empty page that can be used on its own or navigated to within a Frame.
00032     /// </summary>
00033
00034     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00035     public ref class MyList sealed : Windows::UI::Xaml::Controls::ListView
00036     {
00037       protected:
00038         virtual void PrepareContainerForItemOverride(Windows::UI::Xaml::DependencyObject^ element, Platform::Object^ item) override
00039         {
00040           Windows::UI::Xaml::Controls::ListView::PrepareContainerForItemOverride(element, item);
00041                     FrameworkElement^ source = safe_cast<FrameworkElement^>(element);
00042                     Binding^ idBinding = ref new Binding;
00043                     Binding^ nameBinding = ref new Binding;
00044                     idBinding->Path = ref new PropertyPath("AutomationId");
00045                     source->SetBinding(AutomationProperties::AutomationIdProperty, idBinding);
00046                     nameBinding->Path = ref new PropertyPath("AutomationName");
00047                     source->SetBinding(AutomationProperties::NameProperty, nameBinding);
00048         }
00049     };
00050
00051     [Windows::UI::Xaml::Data::Bindable]
00052     public ref class Person sealed
00053     {
00054       private:
00055         Platform::String^ firstName;
00056         Platform::String^ lastName;
00057         Platform::String^ automationName;
00058         Platform::String^ automationId;
00059         int _age;
00060
00061       public:
00062         Person()
00063         {
00064         }
00065         Person(Platform::String^ firstName, Platform::String^ lastName, Platform::String^ id, int age, Platform::String^ name)
00066         {
00067           FirstName = firstName;
00068           LastName = lastName;
00069           AutomationId = id;
00070           Age = age;
00071           AutomationName = name;
00072         }
00073
00074
00075         property Platform::String^ FirstName
00076         {
00077           Platform::String^ get()
00078           {
00079             return firstName;
00080           }
00081           void set(Platform::String^ value)
00082           {
00083             firstName = value;
00084           }
00085         }
00086
00087         property Platform::String^ LastName
00088         {
00089           Platform::String^ get()
00090           {
00091             return lastName;
00092           }
00093           void set(Platform::String^ value)
00094           {
00095             lastName = value;
00096           }
00097         }
00098
00099         property int Age
00100         {
00101           int get()
00102           {
00103             return _age;
00104           }
00105           void set(int value)
00106           {
00107             _age = value;
00108           }
00109         }
00110
00111         property Platform::String^ AutomationName
00112         {
00113           Platform::String^ get()
00114           {
00115             return automationName;
00116           }
00117           void set(Platform::String^ value)
00118           {
00119             automationName = value;
00120           }
00121         }
00122
00123         property Platform::String^ AutomationId
00124         {
00125           Platform::String^ get()
00126           {
00127             return automationId;
00128           }
00129           void set(Platform::String^ value)
00130           {
00131             automationId = value;
00132           }
00133         }
00134     };
00135
00136     public ref class DataHelper sealed
00137     {
00138       public:
00139         static Windows::Foundation::Collections::IVector<Person^>^ GeneratePersonNamesSource()
00140         {
00141           Platform::Collections::Vector<Person^>^ ds = ref new Platform::Collections::Vector<Person^>();
00142           ds->Append(ref new Person("George", "Washington", "ListItemId1", 25, "ListItemName1"));
00143           ds->Append(ref new Person("John", "Adams", "ListItemId2", 30, "ListItemName2"));
00144           ds->Append(ref new Person("Thomas", "Jefferson", "ListItemId3", 45, "ListItemName3"));
00145           ds->Append(ref new Person("James", "Madison", "ListItemId4", 55, "ListItemName4"));
00146           ds->Append(ref new Person("James", "Monroe", "ListItemId5", 30, "ListItemName5"));
00147           ds->Append(ref new Person("John", "Adams", "ListItemId6", 25, "ListItemName6"));
00148           ds->Append(ref new Person("Andrew", "Jackson", "ListItemId7", 55, "ListItemName7"));
00149           ds->Append(ref new Person("Martin", "Van Buren", "ListItemId8", 56, "ListItemName8"));
00150           ds->Append(ref new Person("William", "Harrison", "ListItemId9", 40, "ListItemName9"));
00151           ds->Append(ref new Person("John", "Tyler", "ListItemId10", 42, "ListItemName10"));
00152           ds->Append(ref new Person("James", "Polk", "ListItemId11", 60, "ListItemName11"));
00153           ds->Append(ref new Person("Zachary", "Taylor", "ListItemId12", 65, "ListItemName12"));
00154           ds->Append(ref new Person("Millard", "Fillmore", "ListItemId13", 25, "ListItemName13"));
00155           ds->Append(ref new Person("Franklin", "Pierce", "ListItemId14", 35, "ListItemName14"));
00156           ds->Append(ref new Person("James", "Buchanan", "ListItemId15", 43, "ListItemName15"));
00157           ds->Append(ref new Person("Abraham", "Lincoln", "ListItemId16", 23, "ListItemName16"));
00158           ds->Append(ref new Person("Andrew", "Johnson", "ListItemId17", 21, "ListItemName17"));
00159           ds->Append(ref new Person("Rutherford", "Hayes", "ListItemId18", 25, "ListItemName18"));
00160           ds->Append(ref new Person("James", "Garfield", "ListItemId19", 30, "ListItemName19"));
00161           ds->Append(ref new Person("Chester", "Arthur", "ListItemId20", 34, "ListItemName20"));
00162           ds->Append(ref new Person("Grover", "Cleveland", "ListItemId21", 55, "ListItemName21"));
00163
00164           return ds;
00165         }
00166     };
00167
00168     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00169     public ref class Scenario4 sealed
00170     {
00171     public:
00172       Scenario4();
00173
00174     protected:
00175       virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00176     private:
00177       MainPage^ rootPage;
00178     };
00179   }
00180 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/pch.cpp Source File

  • Device enumeration

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPickerPage.xaml.h Source File

  • File picker contracts

FileOpenPickerPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FileOpenPickerPage.xaml.h
00013 // Declaration of the FileOpenPickerPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "FileOpenPickerPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     namespace FilePickerContracts
00026     {
00027         [Windows::Foundation::Metadata::WebHostHidden]
00028         public ref class FileOpenPickerPage sealed
00029         {
00030         public:
00031             FileOpenPickerPage();
00032             void Activate(Windows::ApplicationModel::Activation::FileOpenPickerActivatedEventArgs^ e);
00033
00034             static property Platform::String^ FEATURE_NAME
00035             {
00036                 Platform::String^ get()
00037                 {
00038                     return ref new Platform::String(L"File Open Picker Page");
00039                 }
00040             }
00041
00042             static property Platform::Array<Scenario>^ scenarios
00043             {
00044                 Platform::Array<Scenario>^ get()
00045                 {
00046                     return scenariosInner;
00047                 }
00048             }
00049
00050         internal:
00051             property bool AutoSizeInputSectionWhenSnapped
00052             {
00053                 bool get()
00054                 {
00055                     return autoSizeInputSectionWhenSnapped;
00056                 }
00057
00058                 void set(bool value)
00059                 {
00060                     autoSizeInputSectionWhenSnapped = value;
00061                 }
00062             }
00063
00064             property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00065             {
00066                 Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00067                 {
00068                     return safe_cast<App^>(App::Current)->LaunchArgs;
00069                 }
00070             }
00071
00072             bool EnsureUnsnapped();
00073             void ResetScenarioOutput(Windows::UI::Xaml::Controls::TextBlock^ textblock);
00074             void NotifyUser(Platform::String^ strMessage, NotifyType type);
00075             void LoadScenario(Platform::String^ scenarioName);
00076             event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00077             event Windows::Foundation::EventHandler<PageSizeChangedEventArgs^>^ PageResized;
00078
00079         private:
00080             void PopulateScenarios();
00081             void InvalidateSize();
00082             void InvalidateViewState();
00083             void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00084
00085             Platform::Collections::Vector<Object^>^ ScenarioList;
00086             Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00087             bool autoSizeInputSectionWhenSnapped;
00088             static Platform::Array<Scenario>^ scenariosInner;
00089
00090         protected:
00091             void FileOpenPickerPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00092             void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00093             virtual void LoadState(Platform::Object^ navigationParameter,
00094                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00095             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00096
00097         internal:
00098             static FileOpenPickerPage^ Current;
00099             Windows::Storage::Pickers::Provider::FileOpenPickerUI^ fileOpenPickerUI;
00100         };
00101     }
00102 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::ToastContent::ToastAudio Member List

This is the complete list of members for NotificationsExtensions::ToastContent::ToastAudio, including all inherited members.
Content | NotificationsExtensions::ToastContent::ToastAudio |
Loop | NotificationsExtensions::ToastContent::ToastAudio |
m_Content | NotificationsExtensions::ToastContent::ToastAudio | [private]
m_Loop | NotificationsExtensions::ToastContent::ToastAudio | [private]
ToastAudio() | NotificationsExtensions::ToastContent::ToastAudio | [inline, private]
ToastAudio() | NotificationsExtensions::ToastContent::ToastAudio | [inline, private]
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::FileSearch::sealed Member List

This is the complete list of members for SDKSample::FileSearch::sealed, including all inherited members.
Scenario1() | SDKSample::FileSearch::sealed |
SearchButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::FileSearch::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario7.xaml.h Source File

  • File access

Scenario7.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario7.xaml.h
00013 // Declaration of the Scenario7 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario7.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FileAccess
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario7 sealed
00030         {
00031         public:
00032             Scenario7();
00033
00034         private:
00035             MainPage^ rootPage;
00036
00037             void CopyFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038         };
00039     }
00040 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/public.h Source File

  • Custom driver access
  • C#,C++
  • DLL

public.h

Go to the documentation of this file.
00001 /*++
00002
00003 Copyright (c) Microsoft Corporation.  All rights reserved.
00004
00005 Module Name:
00006
00007     public.h
00008
00009 Abstract:
00010
00011     Public definitions for the OSR_FX2 device operations.
00012
00013 Environment:
00014
00015     User & Kernel mode
00016
00017 --*/
00018
00019 #ifndef _PUBLIC_H
00020 #define _PUBLIC_H
00021
00022 #include <initguid.h>
00023
00024 #include "WudfOsrUsbPublic.h"
00025
00026
00027 //
00028 // Define the structures that will be used by the IOCTL
00029 //  interface to the driver
00030 //
00031
00032 //
00033 // BAR_GRAPH_STATE
00034 //
00035 // BAR_GRAPH_STATE is a bit field structure with each
00036 //  bit corresponding to one of the bar graph on the
00037 //  OSRFX2 Development Board
00038 //
00039 #include <pshpack1.h>
00040
00041 #pragma warning( push )
00042 #pragma warning( disable : 4201 ) // nameless struct/union
00043 #pragma warning( disable : 4214 ) // bit-field type other than int
00044
00045 typedef struct _BAR_GRAPH_STATE {
00046
00047     union {
00048
00049         struct {
00050             //
00051             // Individual bars starting from the
00052             //  top of the stack of bars
00053             //
00054             // NOTE: There are actually 10 bars,
00055             //  but the very top two do not light
00056             //  and are not counted here
00057             //
00058             UCHAR Bar1 : 1;
00059             UCHAR Bar2 : 1;
00060             UCHAR Bar3 : 1;
00061             UCHAR Bar4 : 1;
00062             UCHAR Bar5 : 1;
00063             UCHAR Bar6 : 1;
00064             UCHAR Bar7 : 1;
00065             UCHAR Bar8 : 1;
00066         };
00067
00068         //
00069         // The state of all the bar graph as a single
00070         // UCHAR
00071         //
00072         UCHAR BarsAsUChar;
00073
00074     };
00075
00076 }BAR_GRAPH_STATE, *PBAR_GRAPH_STATE;
00077
00078 //
00079 // SWITCH_STATE
00080 //
00081 // SWITCH_STATE is a bit field structure with each
00082 //  bit corresponding to one of the switches on the
00083 //  OSRFX2 Development Board
00084 //
00085 typedef struct _SWITCH_STATE {
00086
00087     union {
00088         struct {
00089             //
00090             // Individual switches starting from the
00091             //  left of the set of switches
00092             //
00093             UCHAR Switch1 : 1;
00094             UCHAR Switch2 : 1;
00095             UCHAR Switch3 : 1;
00096             UCHAR Switch4 : 1;
00097             UCHAR Switch5 : 1;
00098             UCHAR Switch6 : 1;
00099             UCHAR Switch7 : 1;
00100             UCHAR Switch8 : 1;
00101         };
00102
00103         //
00104         // The state of all the switches as a single
00105         // UCHAR
00106         //
00107         UCHAR SwitchesAsUChar;
00108
00109     };
00110
00111
00112 }SWITCH_STATE, *PSWITCH_STATE;
00113
00114 //
00115 // Seven segment display bit values.
00116 //
00117
00118 //
00119 // Undefine conflicting MFC constant
00120 //
00121 #undef SS_CENTER
00122 #undef SS_LEFT
00123 #undef SS_RIGHT
00124
00125 #define SS_TOP          0x01
00126 #define SS_TOP_LEFT     0x40
00127 #define SS_TOP_RIGHT    0x02
00128 #define SS_CENTER       0x20
00129 #define SS_BOTTOM_LEFT  0x10
00130 #define SS_BOTTOM_RIGHT 0x04
00131 #define SS_BOTTOM       0x80
00132 #define SS_DOT          0x08
00133
00134 //
00135 // FILE_PLAYBACK
00136 //
00137 // FILE_PLAYBACK structure contains the parameters for the PLAY_FILE I/O Control.
00138 //
00139
00140 typedef struct _FILE_PLAYBACK
00141 {
00142     //
00143     // The delay between changes in the display, in milliseconds.
00144     //
00145
00146     USHORT Delay;
00147
00148     //
00149     // The data file path.
00150     //
00151
00152     WCHAR Path[1];
00153 } FILE_PLAYBACK, *PFILE_PLAYBACK;
00154
00155 #include <poppack.h>
00156
00157 #define IOCTL_INDEX             0x800
00158 #define FILE_DEVICE_OSRUSBFX2   0x65500
00159
00160 #define IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
00161                                                      IOCTL_INDEX,     \
00162                                                      METHOD_BUFFERED,         \
00163                                                      FILE_READ_ACCESS)
00164
00165 #define IOCTL_OSRUSBFX2_RESET_DEVICE  CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
00166                                                      IOCTL_INDEX + 1, \
00167                                                      METHOD_BUFFERED,         \
00168                                                      FILE_WRITE_ACCESS)
00169
00170 #define IOCTL_OSRUSBFX2_REENUMERATE_DEVICE  CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00171                                                     IOCTL_INDEX  + 3,  \
00172                                                     METHOD_BUFFERED, \
00173                                                     FILE_WRITE_ACCESS)
00174
00175 #define IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00176                                                     IOCTL_INDEX  + 4, \
00177                                                     METHOD_BUFFERED, \
00178                                                     FILE_READ_ACCESS)
00179
00180
00181 #define IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00182                                                     IOCTL_INDEX + 5, \
00183                                                     METHOD_BUFFERED, \
00184                                                     FILE_WRITE_ACCESS)
00185
00186
00187 #define IOCTL_OSRUSBFX2_READ_SWITCHES   CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00188                                                     IOCTL_INDEX + 6, \
00189                                                     METHOD_BUFFERED, \
00190                                                     FILE_READ_ACCESS)
00191
00192
00193 #define IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00194                                                     IOCTL_INDEX + 7, \
00195                                                     METHOD_BUFFERED, \
00196                                                     FILE_READ_ACCESS)
00197
00198
00199 #define IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00200                                                     IOCTL_INDEX + 8, \
00201                                                     METHOD_BUFFERED, \
00202                                                     FILE_WRITE_ACCESS)
00203
00204 #define IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00205                                                     IOCTL_INDEX + 9, \
00206                                                     METHOD_OUT_DIRECT, \
00207                                                     FILE_READ_ACCESS)
00208
00209 #define IOCTL_OSRUSBFX2_PLAY_FILE CTL_CODE(FILE_DEVICE_OSRUSBFX2,   \
00210                                            IOCTL_INDEX + 10,        \
00211                                            METHOD_BUFFERED,         \
00212                                            FILE_WRITE_ACCESS)
00213
00214 #pragma warning(pop)
00215
00216 #endif
00217
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXBase.h Source File

  • DXGI swap chain rotation

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     virtual float ConvertDipsToPixels(float dips);
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     Windows::Graphics::Display::DisplayOrientations m_orientation;
00058     bool                                            m_windowSizeChangeInProgress;
00059
00060     // Transforms used for display orientation.
00061     D2D1::Matrix3x2F                                m_rotationTransform2D;
00062     float4x4                                        m_rotationTransform3D;
00063 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicCamera.h Source File

  • DirectX touch input

BasicCamera.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple camera class.
00011 ref class BasicCamera
00012 {
00013
00014 private:
00015     float3 m_position;      // the position of the camera
00016     float3 m_direction;     // the unit vector of the viewing direction
00017     float4x4 m_view;        // view matrix
00018     float4x4 m_projection;  // projection matrix
00019
00020 internal:
00021     void GetViewMatrix(_Out_ float4x4 *viewMatrix);
00022     void GetProjectionMatrix(_Out_ float4x4 *projectionMatrix);
00023
00024     // this method updates the view matrix based on new position and focus coordinates
00025     void SetViewParameters(
00026         _In_ float3 eyePosition,    // the position of the camera
00027         _In_ float3 lookPosition,   // the point the camera should look at
00028         _In_ float3 up              // the durection vector for up
00029         );
00030
00031     // this method updates the projection matrix based on new parameters
00032     void SetProjectionParameters(
00033         _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00034         _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00035         _In_ float nearPlane,           // depth to map to 0
00036         _In_ float farPlane             // depth to map to 1
00037         );
00038 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicMath.h Source File

  • Direct3D post-processing effects

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/ImageRenderer.cpp Source File

  • DirectX postcard app

ImageRenderer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "ImageRenderer.h"
00010
00011 using namespace concurrency;
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::Storage;
00014 using namespace Windows::Storage::Pickers;
00015 using namespace Windows::Storage::Streams;
00016
00017 static const float FullSaturation = 1.0f;
00018
00019 void ImageRenderer::CreateDeviceIndependentResources(
00020     ComPtr<IWICImagingFactory2> wicFactory
00021     )
00022 {
00023     // Save the shared WIC factory.
00024     m_wicFactory = wicFactory;
00025 }
00026
00027 void ImageRenderer::CreateDeviceResources(
00028     ComPtr<ID2D1DeviceContext> d2dContext
00029     )
00030 {
00031     // Save the shared device context.
00032     m_d2dContext = d2dContext;
00033
00034     // Create a bitmap source for rendering the image.
00035     DX::ThrowIfFailed(
00036         m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_bitmapSourceEffect)
00037         );
00038
00039     // The mipmap linear interpolation mode on the BitmapSource effect instructs it to construct
00040     // a software (CPU memory) mipmap. If Direct2D requests the image at a small scale factor
00041     // (<= 0.5), BitmapSource only needs to perform the scale operation from the nearest
00042     // mip level, which is a performance optimization. In addition, for very large images,
00043     // performing scaling on the CPU reduces GPU bus bandwidth consumption and GPU memory
00044     // consumption.
00045     DX::ThrowIfFailed(
00046         m_bitmapSourceEffect->SetValue(
00047             D2D1_BITMAPSOURCE_PROP_INTERPOLATION_MODE,
00048             D2D1_BITMAPSOURCE_INTERPOLATION_MODE_MIPMAP_LINEAR
00049             )
00050         );
00051
00052     // Create saturation effect.
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateEffect(CLSID_D2D1Saturation, &m_saturationEffect)
00055         );
00056
00057     // Set the initial saturation level of the effect.
00058     DX::ThrowIfFailed(
00059         m_saturationEffect->SetValue(D2D1_SATURATION_PROP_SATURATION, FullSaturation)
00060         );
00061
00062     // Connect the effects graph.
00063     m_saturationEffect->SetInputEffect(0, m_bitmapSourceEffect.Get());
00064 }
00065
00066 void ImageRenderer::CreateWindowSizeDependentResources(float dpi)
00067 {
00068     // Save the shared DPI.
00069     m_dpi = dpi;
00070
00071     UpdateImageZoom();
00072 }
00073
00074 void ImageRenderer::DrawImageAndEffects()
00075 {
00076     D2D1_SIZE_F size = m_d2dContext->GetSize();
00077
00078     // Set the context transform to center the image.
00079     m_d2dContext->SetTransform(
00080         D2D1::Matrix3x2F::Translation(
00081             (size.width - (m_imageSizeDips.width * m_imageZoomFactor)) / 2,
00082             (size.height - (m_imageSizeDips.height * m_imageZoomFactor)) / 2
00083             )
00084         );
00085
00086     m_d2dContext->DrawImage(m_saturationEffect.Get());
00087 }
00088
00089 void ImageRenderer::LoadImage(IRandomAccessStream^ randomAccessStream)
00090 {
00091     ComPtr<IStream> stream;
00092     CreateStreamOverRandomAccessStream(
00093         reinterpret_cast<IUnknown*>(randomAccessStream),
00094         IID_PPV_ARGS(&stream)
00095         );
00096
00097     // Load the image using the Windows Imaging Component decoder.
00098     ComPtr<IWICBitmapDecoder> decoder;
00099     DX::ThrowIfFailed(
00100         m_wicFactory->CreateDecoderFromStream(
00101             stream.Get(),
00102             nullptr,
00103             WICDecodeMetadataCacheOnDemand,
00104             &decoder
00105             )
00106         );
00107
00108     ComPtr<IWICBitmapFrameDecode> frame;
00109     DX::ThrowIfFailed(
00110         decoder->GetFrame(0, &frame)
00111         );
00112
00113     ComPtr<IWICFormatConverter> wicFormatConverter;
00114     DX::ThrowIfFailed(
00115         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00116         );
00117
00118     // We format convert to a pixel format that is compatible with Direct2D.
00119     // To optimize for performance when using WIC and Direct2D together, we need to
00120     // select the target pixel format based on the image's native precision:
00121     // - <= 8 bits per channel precision: use BGRA channel order
00122     //   (example: all JPEGs, including the image in this sample, are 8bpc)
00123     // -  > 8 bits per channel precision: use RGBA channel order
00124     //   (example: TIFF and JPEG-XR images support 32bpc float
00125     // Note that a fully robust system will arbitrate between various WIC pixel formats and
00126     // hardware feature level support using the IWICPixelFormatInfo2 interface.
00127     DX::ThrowIfFailed(
00128         wicFormatConverter->Initialize(
00129             frame.Get(),
00130             GUID_WICPixelFormat32bppPBGRA,
00131             WICBitmapDitherTypeNone,
00132             nullptr,
00133             0.0f,
00134             WICBitmapPaletteTypeCustom
00135             )
00136         );
00137
00138     DX::ThrowIfFailed(
00139         m_bitmapSourceEffect->SetValue(
00140             D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE,
00141             wicFormatConverter.Get()
00142             )
00143         );
00144
00145     uint32 bitmapWidth;
00146     uint32 bitmapHeight;
00147     DX::ThrowIfFailed(
00148         frame->GetSize(&bitmapWidth, &bitmapHeight)
00149         );
00150
00151     m_imagePixelSize = D2D1::SizeU(bitmapWidth, bitmapHeight);
00152
00153     UpdateImageZoom();
00154 }
00155
00156 void ImageRenderer::UpdateImageZoom()
00157 {
00158     // Compute the minimum zoom to ensure the image fits on the screen.
00159     D2D1_SIZE_F size = m_d2dContext->GetSize();
00160
00161     // m_imageSize is in DIPs and changes depending on the app DPI.
00162     // This app ignores the source bitmap's DPI and assumes it is 96, in order to
00163     // display it at full resolution.
00164     m_imageSizeDips = D2D1::SizeF(
00165         m_imagePixelSize.width * 96.0f / m_dpi,
00166         m_imagePixelSize.height * 96.0f / m_dpi
00167         );
00168
00169     m_imageZoomFactor = std::min<float>(
00170         size.width / m_imageSizeDips.width,
00171         size.height / m_imageSizeDips.height
00172         );
00173
00174     DX::ThrowIfFailed(
00175         m_bitmapSourceEffect->SetValue(
00176             D2D1_BITMAPSOURCE_PROP_SCALE,
00177             D2D1::Vector2F(m_imageZoomFactor, m_imageZoomFactor)
00178             )
00179         );
00180 }
00181
00182 void ImageRenderer::SetEffectIntensity(float value)
00183 {
00184     DX::ThrowIfFailed(
00185         m_saturationEffect->SetValue(D2D1_SATURATION_PROP_SATURATION, value)
00186         );
00187 }
00188
00189 void ImageRenderer::Reset()
00190 {
00191     DX::ThrowIfFailed(
00192         m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE, NULL)
00193         );
00194
00195     DX::ThrowIfFailed(
00196         m_saturationEffect->SetValue(D2D1_SATURATION_PROP_SATURATION, FullSaturation)
00197         );
00198 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Samples::Devices::DeviceControlResult Member List

This is the complete list of members for Samples::Devices::DeviceControlResult, including all inherited members.
BytesTransferred | Samples::Devices::DeviceControlResult |
DeviceControlResult() | Samples::Devices::DeviceControlResult | [inline]
DeviceControlResult(HRESULT Hr, DWORD Cb) | Samples::Devices::DeviceControlResult | [inline]
DeviceControlResult() | Samples::Devices::DeviceControlResult | [inline]
DeviceControlResult(HRESULT Hr, DWORD Cb) | Samples::Devices::DeviceControlResult | [inline]
DeviceControlResult() | Samples::Devices::DeviceControlResult | [inline]
DeviceControlResult(HRESULT Hr, DWORD Cb) | Samples::Devices::DeviceControlResult | [inline]
Result | Samples::Devices::DeviceControlResult |
Generated on Sat Nov 23 2024 16:09:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario3.xaml.cpp Source File

  • XAML text editing

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::TextEditing;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario3::Scenario3()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040 }
00041
00042
00043 void SDKSample::TextEditing::Scenario3::Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00044 {
00045     Button^ b = safe_cast<Button^>(sender);
00046     if (b != nullptr)
00047     {
00048         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput6.xaml.h Source File

  • Toast notifications
  • C#,C++

ScenarioOutput6.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.h
00010 // Declaration of the Scenario1Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput6.g.h"
00017 #include "MainPage.xaml.h"
00018
00019 namespace ToastsSampleCPP
00020 {
00021   [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class ScenarioOutput6 sealed
00023     {
00024     public:
00025         ScenarioOutput6();
00026
00027     protected:
00028         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~ScenarioOutput6();
00033
00034     MainPage^ rootPage;
00035         void rootPage_InputFrameLoaded(Object^ sender, Object^ e);
00036         Windows::Foundation::EventRegistrationToken _frameLoadedToken;
00037     };
00038 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario4.xaml.h Source File

  • CryptoWinRT

Scenario4.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace CryptoWinRT
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario4 sealed
00031         {
00032         public:
00033             Scenario4();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/AmpCartoon.cpp Source File

  • Hilo C++
  • CartoonEffect

AmpCartoon.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "AmpPixel.h"
00009 #include <amp.h>
00010 #include <amp_math.h>
00011
00012 using namespace std;
00013 using concurrency::cancellation_token;
00014 using concurrency::array;
00015 using concurrency::array_view;
00016 using concurrency::index;
00017 using concurrency::extent;
00018
00019 void SimplifyIndexRows(const array_view<const AmpPixel, 2>& src_frame, array_view<AmpPixel, 2> dst_frame, index<2> idx, int shift) restrict(amp)
00020 {
00021     // Simplify a portion of the image by removing features that fall below a given color contrast.
00022     // We do this by calculating the difference in color between neighboring pixels and applying an
00023     // exponential decay function then summing the results.
00024     // We then set the RGB values to the nomalized sums
00025     float sum = 0;
00026     float partial_sum_r = 0, partial_sum_g = 0, partial_sum_b = 0;
00027
00028     // k is the exponential decay constant and is calculated from a standard deviation of 0.025
00029     const float standard_deviation = 0.025f;
00030     const float k = -0.5f / (standard_deviation * standard_deviation);
00031
00032     const int idx_y = idx[1];
00033     const int y = idx_y;
00034     const int idx_x = idx[0] + shift;
00035     const int x_start = idx_x - shift;
00036     const int x_end = idx_x + shift;
00037
00038     AmpPixel org_clr = src_frame(idx_x, idx_y);
00039
00040     for (int x = x_start; x <= x_end; ++x)
00041     {
00042         // Don't apply filter to the requested index, only to the neighbors
00043         if (x != idx_x )
00044         {
00045             AmpPixel clr = src_frame(x, y);
00046             float distance = concurrency::fast_math::sqrt(
00047                 concurrency::fast_math::pow(org_clr.u - clr.u, 2) +
00048                 concurrency::fast_math::pow(org_clr.v - clr.v, 2));
00049             float value = concurrency::fast_math::pow(float(M_E), k * distance * distance);
00050
00051             sum += value;
00052             partial_sum_r += clr.r * value;
00053             partial_sum_g += clr.g * value;
00054             partial_sum_b += clr.b * value;
00055         }
00056     }
00057
00058     partial_sum_r = min(max(partial_sum_r / sum, 0.0F), 1.0F);
00059     partial_sum_g = min(max(partial_sum_g / sum, 0.0F), 1.0F);
00060     partial_sum_b = min(max(partial_sum_b / sum, 0.0F), 1.0F);
00061
00062     AmpPixel p;
00063     p.SetFromRGB(partial_sum_r, partial_sum_g, partial_sum_b);
00064     dst_frame(idx_x, idx_y) = p;
00065 }
00066
00067 void SimplifyIndexColumns(const array_view<const AmpPixel, 2>& src_frame, array_view<AmpPixel, 2> dst_frame, index<2> idx, int shift) restrict(amp)
00068 {
00069     // Simplify a portion of the image by removing features that fall below a given color contrast.
00070     // We do this by calculating the difference in color between neighboring pixels and applying an
00071     // exponential decay function then summing the results.
00072     // We then set the RGB values to the nomalized sums
00073     float sum = 0;
00074     float partial_sum_r = 0, partial_sum_g = 0, partial_sum_b = 0;
00075
00076     // k is the exponential decay constant and is calculated from a standard deviation of 0.025
00077     const float standard_deviation = 0.025f;
00078     const float k = -0.2f / (standard_deviation * standard_deviation);
00079
00080     const int idx_y = idx[1] + shift;
00081     const int idx_x = idx[0];
00082     const int x = idx_x;
00083     const int y_start = idx_y - shift;
00084     const int y_end = idx_y + shift;
00085
00086     AmpPixel org_clr = src_frame(idx_x, idx_y);
00087
00088     for (int y = y_start; y <= y_end; ++y)
00089     {
00090         // Don't apply filter to the requested index, only to the neighbors
00091         if (y != idx_y)
00092         {
00093             AmpPixel clr = src_frame(x, y);
00094             float distance = concurrency::fast_math::sqrt(
00095                 concurrency::fast_math::pow(org_clr.u - clr.u, 2) +
00096                 concurrency::fast_math::pow(org_clr.v - clr.v, 2));
00097             float value = concurrency::fast_math::pow(float(M_E), k * distance * distance);
00098
00099             sum += value;
00100             partial_sum_r += clr.r * value;
00101             partial_sum_g += clr.g * value;
00102             partial_sum_b += clr.b * value;
00103         }
00104     }
00105
00106     partial_sum_r = min(max(partial_sum_r / sum, 0.0F), 1.0F);
00107     partial_sum_g = min(max(partial_sum_g / sum, 0.0F), 1.0F);
00108     partial_sum_b = min(max(partial_sum_b / sum, 0.0F), 1.0F);
00109
00110     AmpPixel p;
00111     p.SetFromRGB(partial_sum_r, partial_sum_g, partial_sum_b);
00112     dst_frame(idx_x, idx_y) = p;
00113 }
00114
00115 void CalculateSobel(const array_view<const AmpPixel, 2> &src_frame, index<2> idx, float &dy) restrict(amp)
00116 {
00117     // Apply the Sobel operator to the image.  The Sobel operation is analogous
00118     // to a first derivative of the grayscale part of the image. Portions of
00119     // the image that change rapidly (edges) have higher sobel values.
00120     const int gx[3][3] = { { -1, 0, 1 }, { -2, 0, 2 }, { -1, 0, 1 } };
00121     const int gy[3][3] = { { 1, 2, 1 }, { 0, 0, 0 }, { -1, -2, -1 } };
00122
00123     const int idx_x = idx[0];
00124     const int idx_y = idx[1];
00125     float gradient_x = 0, gradient_y = 0;
00126     for (int y = -1; y < 2; y++)
00127     {
00128         for (int x = -1; x < 2; x++)
00129         {
00130             index<2> idx_new(idx_x + x, idx_y + y);
00131             float src_y = src_frame[idx_new].y;
00132
00133             gradient_x += gx[x + 1][y + 1] * src_y;
00134             gradient_y += gy[x + 1][y + 1] * src_y;
00135         }
00136     }
00137
00138     // Calculate the magnitude of the gradient from the horizontal and vertical gradients
00139     dy = concurrency::fast_math::sqrt((gradient_x * gradient_x) + (gradient_y * gradient_y));
00140 }
00141
00142 void EdgeDetection(const array<AmpPixel, 2> &src_frame, array<AmpPixel, 2> &dst_frame, index<2> idx, const array_view<const AmpPixel, 2> &org_frame) restrict(amp)
00143 {
00144     const float alpha = 0.3f; // Weighting of original frame for edge detection
00145     const float beta = 0.8f;  // Weighting of source (color simplied) frame for edge detection
00146
00147     const float s0 = 0.054f;  // Minimum threshold of source frame Sobel value to detect an edge
00148     const float s1 = 0.064f;  // Maximum threshold of source frame Sobel value to effect the darkness of the edge
00149     const float a0 = 0.3f;    // Minimum threshold of original frame Sobel value to detect an edge
00150     const float a1 = 0.7f;    // Maximum threshold of original frame Sobel value to effect the darkness of the edge
00151
00152     index<2> idxc(idx[0] + 1, idx[1] + 1);  // Corrected index for border offset
00153
00154     float sy = 0.0f;
00155     float ay = 0.0f;
00156
00157     CalculateSobel(src_frame, idxc, sy);
00158     CalculateSobel(org_frame, idxc, ay);
00159
00160     float edge_s = (1 - alpha) * sy;
00161     float edge_a = (1 - alpha) * ay;
00162     float i = (1 - beta) * concurrency::direct3d::smoothstep(s0, s1, edge_s) + beta * concurrency::direct3d::smoothstep(a0, a1, edge_a);
00163
00164     AmpPixel clr = src_frame[idxc];
00165     clr.UpdateRGB();
00166
00167     clr.r = clr.r * (1 - i);
00168     clr.g = clr.g * (1 - i);
00169     clr.b = clr.b * (1 - i);
00170     dst_frame[idxc] = clr;
00171 }
00172
00173 void PopulateInitialRGBValues(concurrency::array<AmpPixel, 2>* frame, concurrency::array<AmpPixel, 2> sourceFrame)
00174 {
00175     concurrency::array_view<AmpPixel, 2> currentFrameView((*frame));
00176     parallel_for_each(sourceFrame.extent, [=, &sourceFrame](index<2> idx) restrict(amp)
00177     {
00178         currentFrameView[idx] = sourceFrame[idx];
00179     });
00180 }
00181
00182 void ApplyColorSimplifier(concurrency::array<AmpPixel, 2> frames[],
00183                           const unsigned int width,
00184                           const unsigned int height,
00185                           const unsigned int neighborWindow,
00186                           const unsigned int phases,
00187                           unsigned int current,
00188                           unsigned int next,
00189                           cancellation_token token)
00190 {
00191     concurrency::extent<2> computeDomain(height - neighborWindow, width - neighborWindow);
00192     for (unsigned int i = 0; i < phases; i++)
00193     {
00194         const concurrency::array_view<const AmpPixel, 2> source(frames[current]);
00195         concurrency::array_view<AmpPixel, 2> destination(frames[next]);
00196         const unsigned int shift = neighborWindow;
00197
00198         parallel_for_each(computeDomain, [=](index<2> idx) restrict(amp)
00199         {
00200             SimplifyIndexColumns(source, destination, idx, shift);
00201             SimplifyIndexRows(source, destination, idx, shift);
00202         });
00203
00204         swap(current, next);
00205         if (token.is_canceled())
00206         {
00207             break;
00208         }
00209     }
00210 }
00211
00212 void ApplyEdgeDetection(concurrency::array<AmpPixel, 2>* frame,
00213                         concurrency::array<AmpPixel, 2> sourceFrame,
00214                         concurrency::array<AmpPixel, 2> destFrame,
00215                         unsigned int width,
00216                         unsigned int height,
00217                         const unsigned int phases)
00218 {
00219     if (phases > 0)
00220     {
00221         const concurrency::array<AmpPixel, 2> &source((*frame));
00222         parallel_for_each(destFrame.section(1, 1, height - 1, width - 1).extent, [=, &source, &sourceFrame, &destFrame](index<2> idx) restrict(amp)
00223         {
00224             EdgeDetection(source, destFrame, idx, sourceFrame);
00225         });
00226         (*frame) = destFrame;
00227     }
00228 }
00229
00230 void ApplyCartoonEffectAmp(AmpPixel* sourcePixels,
00231                            AmpPixel* destinationPixels,
00232                            unsigned int width,
00233                            unsigned int height,
00234                            unsigned int neighborWindow,
00235                            unsigned int phases,
00236                            cancellation_token token)
00237 {
00238     concurrency::extent<2> sourceExtent(height, width);
00239     concurrency::array<AmpPixel, 2> sourceFrame(sourceExtent, sourcePixels);
00240     concurrency::array<AmpPixel, 2> destFrame(sourceExtent);
00241     concurrency::array<AmpPixel, 2> frames[2] =
00242     {
00243         concurrency::array<AmpPixel, 2>(sourceFrame.extent),
00244         concurrency::array<AmpPixel, 2>(sourceFrame.extent)
00245     };
00246     unsigned int current = 0;
00247     unsigned int next = 1;
00248
00249     PopulateInitialRGBValues(&frames[current], sourceFrame);
00250     if (token.is_canceled())
00251     {
00252         return;
00253     }
00254
00255     ApplyColorSimplifier(frames, width, height, neighborWindow, phases, current, next, token);
00256     ApplyEdgeDetection(&frames[current], sourceFrame, destFrame, width, height, phases);
00257     if (token.is_canceled())
00258     {
00259         return;
00260     }
00261
00262     concurrency::copy(frames[current], stdext::checked_array_iterator<AmpPixel*>(destinationPixels, width * height));
00263 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/FPSCounter.cpp Source File

  • Direct2D geometry realization

FPSCounter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "FPSCounter.h"
00010 #include <math.h>
00011 #include <strsafe.h>
00012
00013 using namespace Microsoft::WRL;
00014
00015 FPSCounter::FPSCounter(
00016     _In_ ID2D1DeviceContext* d2dContext,
00017     _In_ float dpi,
00018     _In_ Platform::String^ staticText,
00019     _In_ IDWriteTextFormat* textFormat,
00020     _In_ D2D1_POINT_2F position
00021     ) : m_d2dContext(d2dContext),
00022         m_dpi(dpi),
00023         m_staticText(staticText),
00024         m_textFormat(textFormat),
00025         m_position(position)
00026 {
00027 }
00028
00029 void FPSCounter::Initialize()
00030 {
00031     DX::ThrowIfFailed(
00032         DWriteCreateFactory(
00033             DWRITE_FACTORY_TYPE_SHARED,
00034             __uuidof(IDWriteFactory),
00035             &m_dwriteFactory
00036             )
00037         );
00038
00039     DX::ThrowIfFailed(
00040         m_d2dContext->CreateSolidColorBrush(
00041             D2D1::ColorF(D2D1::ColorF::White),
00042             &m_textBrush
00043             )
00044         );
00045
00046     // The static text will be placed at the top left corner of the atlas
00047
00048     ComPtr<IDWriteTextLayout> staticTextLayout;
00049
00050     PositionAtlasText(
00051         m_staticText,
00052         D2D1::Point2U(0, 0), // offsetInAtlas
00053         &staticTextLayout,
00054         &m_cachedStaticText
00055         );
00056
00057     // Determine the offset for the FPS counter. We place
00058     // the FPS counter on screen just to the right
00059     // of the last character in the text layout.
00060
00061     float pointX;
00062     float pointY;
00063     DWRITE_HIT_TEST_METRICS hitTestMetrics;
00064     DX::ThrowIfFailed(
00065         staticTextLayout->HitTestTextPosition(
00066             m_staticText->Length() - 1, // textPosition
00067             TRUE, // isTrailingHit
00068             &pointX,
00069             &pointY,
00070             &hitTestMetrics
00071             )
00072         );
00073
00074     m_firstDigitOffset.x = static_cast<uint32>(pointX);
00075     m_firstDigitOffset.y = static_cast<uint32>(pointY);
00076
00077     // Position each digit in the atlas just to the right of everything else
00078     // we've already positioned. At the same time, grow the atlas size to ensure
00079     // that it is big enough.
00080     //
00081     // Note that more general atlasing approaches will position various elements
00082     // in an atlas in two dimensions. This class only grows the atlas in one
00083     // dimension.
00084
00085     uint32 bitmapWidth = m_cachedStaticText.atlasRect.right - m_cachedStaticText.atlasRect.left;
00086     uint32 bitmapHeight = m_cachedStaticText.atlasRect.bottom - m_cachedStaticText.atlasRect.top;
00087
00088     ComPtr<IDWriteTextLayout> digitLayouts[10];
00089     for (uint32 i = 0; i < 10; i++)
00090     {
00091         char16 digit = static_cast<char16>(L'0' + i);
00092
00093         PositionAtlasText(
00094             digit.ToString(),
00095             D2D1::Point2U(bitmapWidth, 0), // offsetInAtlas
00096             &digitLayouts[i],
00097             &m_cachedDigits[i]
00098             );
00099
00100         bitmapWidth += m_cachedDigits[i].atlasRect.right - m_cachedDigits[i].atlasRect.left;
00101         bitmapHeight = max(bitmapHeight, m_cachedDigits[i].atlasRect.bottom - m_cachedDigits[i].atlasRect.top);
00102     }
00103
00104     // This class does not handle the case where the text is so big that it
00105     // doesn't fit in the atlas. More generally, an atlasing approach would need
00106     // to create several atlas bitmaps when one bitmap is not large enough to
00107     // hold all the content required.
00108
00109     if (bitmapWidth > m_d2dContext->GetMaximumBitmapSize() ||
00110         bitmapHeight > m_d2dContext->GetMaximumBitmapSize()
00111         )
00112     {
00113         DX::ThrowIfFailed(E_UNEXPECTED);
00114     }
00115
00116     // Now that we know how big the atlas should be, create the atlas bitmap.
00117     // We use an A8 format since we are only storing text in this atlas and
00118     // don't need to store the color of the text to do this.
00119
00120     DX::ThrowIfFailed(
00121         m_d2dContext->CreateBitmap(
00122             D2D1::SizeU(bitmapWidth, bitmapHeight),
00123             nullptr,
00124             0,
00125             D2D1::BitmapProperties1(
00126                 D2D1_BITMAP_OPTIONS_TARGET,
00127                 D2D1::PixelFormat(DXGI_FORMAT_A8_UNORM, D2D1_ALPHA_MODE_STRAIGHT),
00128                 m_dpi,
00129                 m_dpi
00130                 ),
00131             &m_textAtlasBitmap
00132             )
00133         );
00134
00135     // Get the Dxgi device from the bitmap
00136
00137     ComPtr<IDXGISurface> dxgiSurface;
00138     DX::ThrowIfFailed(
00139         m_textAtlasBitmap->GetSurface(&dxgiSurface)
00140         );
00141
00142     DX::ThrowIfFailed(
00143         dxgiSurface->GetDevice(IID_PPV_ARGS(&m_dxgiDevice))
00144         );
00145
00146     // Draw all the text into the atlas
00147
00148     ComPtr<ID2D1Image> oldTarget;
00149     m_d2dContext->GetTarget(&oldTarget);
00150
00151     m_d2dContext->SetTarget(m_textAtlasBitmap.Get());
00152     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black, 0.0f));
00153
00154     m_d2dContext->DrawTextLayout(
00155         D2D1::Point2F(
00156             PixelsToDips(m_cachedStaticText.atlasRect.left - m_cachedStaticText.originOffset.x),
00157             PixelsToDips(m_cachedStaticText.atlasRect.top - m_cachedStaticText.originOffset.y)
00158             ),
00159         staticTextLayout.Get(),
00160         m_textBrush.Get()
00161         );
00162
00163     for (uint32 i = 0; i < 10; i++)
00164     {
00165         m_d2dContext->DrawTextLayout(
00166             D2D1::Point2F(
00167                 PixelsToDips(m_cachedDigits[i].atlasRect.left - m_cachedDigits[i].originOffset.x),
00168                 PixelsToDips(m_cachedDigits[i].atlasRect.top - m_cachedDigits[i].originOffset.y)
00169                 ),
00170             digitLayouts[i].Get(),
00171             m_textBrush.Get()
00172             );
00173     }
00174
00175     m_d2dContext->SetTarget(oldTarget.Get());
00176 }
00177
00178 // Positions text within the atlas. The resulting position will have its top-left
00179 // corner at offsetInAtlas.
00180
00181 void FPSCounter::PositionAtlasText(
00182     _In_ Platform::String^ text,
00183     _In_ D2D1_POINT_2U offsetInAtlas,
00184     _Outptr_ IDWriteTextLayout** layout,
00185     _Out_ AtlasText* atlasText
00186     )
00187 {
00188     // Create the text layout
00189
00190     DX::ThrowIfFailed(
00191         m_dwriteFactory->CreateTextLayout(
00192             text->Data(),
00193             text->Length(),
00194             m_textFormat.Get(),
00195             0.0f,
00196             0.0f,
00197             layout
00198             )
00199         );
00200
00201     DX::ThrowIfFailed(
00202         (*layout)->SetWordWrapping(DWRITE_WORD_WRAPPING_NO_WRAP)
00203         );
00204
00205     // Get the text metrics and compute the black box.
00206
00207     DWRITE_TEXT_METRICS textMetrics;
00208     DX::ThrowIfFailed(
00209         (*layout)->GetMetrics(&textMetrics)
00210         );
00211
00212     DWRITE_OVERHANG_METRICS overhangMetrics;
00213     DX::ThrowIfFailed(
00214         (*layout)->GetOverhangMetrics(&overhangMetrics)
00215         );
00216
00217     // We use the overhang metrics here to determine the black box for the text.
00218     // The extra pixel of padding is added to make sure that we have enough
00219     // space reserved for an extra pixel of antialiasing falloff.
00220     D2D1_RECT_L blackBox = {
00221         DipsToPixelsRoundDown(-overhangMetrics.left) - 1,
00222         DipsToPixelsRoundDown(-overhangMetrics.top) - 1,
00223         DipsToPixelsRoundUp(overhangMetrics.right + textMetrics.layoutWidth) + 1,
00224         DipsToPixelsRoundUp(overhangMetrics.bottom + textMetrics.layoutHeight) + 1
00225     };
00226
00227     // Fill in the atlas text position.
00228
00229     atlasText->advanceWidth = DipsToPixelsRoundUp(textMetrics.widthIncludingTrailingWhitespace);
00230
00231     atlasText->atlasRect = D2D1::RectU(
00232         offsetInAtlas.x,
00233         offsetInAtlas.y,
00234         offsetInAtlas.x + blackBox.right - blackBox.left,
00235         offsetInAtlas.y + blackBox.bottom - blackBox.top
00236         );
00237
00238     atlasText->originOffset = D2D1::Point2L(
00239         blackBox.left,
00240         blackBox.top
00241         );
00242 }
00243
00244 // Draws the cached text to the device context using FillOpacityMask.
00245
00246 void FPSCounter::DrawAtlasText(
00247     _In_ const AtlasText& atlasText,
00248     _In_ D2D1_POINT_2F offset
00249     )
00250 {
00251     D2D1_ANTIALIAS_MODE oldAAMode = m_d2dContext->GetAntialiasMode();
00252     m_d2dContext->SetAntialiasMode(D2D1_ANTIALIAS_MODE_ALIASED);
00253
00254     D2D1_RECT_F sourceRect;
00255     sourceRect.left = PixelsToDips(atlasText.atlasRect.left);
00256     sourceRect.top = PixelsToDips(atlasText.atlasRect.top);
00257     sourceRect.right = PixelsToDips(atlasText.atlasRect.right);
00258     sourceRect.bottom = PixelsToDips(atlasText.atlasRect.bottom);
00259
00260     D2D1_RECT_F destRect;
00261     destRect.left = offset.x + PixelsToDips(atlasText.originOffset.x);
00262     destRect.top = offset.y + PixelsToDips(atlasText.originOffset.y);
00263     destRect.right = destRect.left + sourceRect.right - sourceRect.left;
00264     destRect.bottom = destRect.top + sourceRect.bottom - sourceRect.top;
00265
00266     m_d2dContext->FillOpacityMask(
00267         m_textAtlasBitmap.Get(),
00268         m_textBrush.Get(),
00269         destRect,
00270         sourceRect
00271         );
00272
00273     m_d2dContext->SetAntialiasMode(oldAAMode);
00274 }
00275
00276
00277 void FPSCounter::Render()
00278 {
00279     // Calculate the FPS
00280     LARGE_INTEGER frequency;
00281     QueryPerformanceFrequency(&frequency);
00282
00283     LARGE_INTEGER time;
00284     QueryPerformanceCounter(&time);
00285
00286     if (m_times.size() == 50)
00287     {
00288         m_times.pop_front();
00289     }
00290     m_times.push_back(static_cast<int>(time.QuadPart));
00291
00292     uint32 fps = 0;
00293     if (m_times.size() >= 2)
00294     {
00295         fps = static_cast<uint32>(
00296             0.5f +
00297             (static_cast<float>(m_times.size()-1) * static_cast<float>(frequency.QuadPart)) /
00298             static_cast<float>(m_times.back() - m_times.front())
00299             );
00300     }
00301
00302     // Draw the static text
00303
00304     D2D1_POINT_2F currentPosition = m_position;
00305
00306     DrawAtlasText(m_cachedStaticText, currentPosition);
00307     currentPosition.x += m_firstDigitOffset.x;
00308     currentPosition.y += m_firstDigitOffset.y;
00309
00310     // Draw the FPS number
00311
00312     Platform::String^ fpsString = fps.ToString();
00313
00314     for (uint32 i = 0; i < fpsString->Length(); i++)
00315     {
00316         uint32 digitIndex = fpsString->Data()[i] - '0';
00317
00318         DrawAtlasText(m_cachedDigits[digitIndex], currentPosition);
00319         currentPosition.x += PixelsToDips(m_cachedDigits[digitIndex].advanceWidth);
00320     }
00321 }
00322
00323 // Convert from device independent pixels to the nearest pixel, rounding down.
00324 int FPSCounter::DipsToPixelsRoundDown(float value)
00325 {
00326     return static_cast<int>(floor(value * m_dpi / 96.0f));
00327 }
00328
00329 // Convert from device independent pixels to the nearest pixel, rounding up.
00330 int FPSCounter::DipsToPixelsRoundUp(float value)
00331 {
00332     return static_cast<int>(ceil(value * m_dpi / 96.0f));
00333 }
00334
00335 // Convert from pixels to device independent pixels.
00336 float FPSCounter::PixelsToDips(int value)
00337 {
00338     return static_cast<float>(value) * 96.0f / m_dpi;
00339 }
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/common/suspensionmanager.h Source File

  • Display orientation
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/common/suspensionmanager.cpp Source File

  • XAML images
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Constants.h Source File

  • XAML personality animations

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"XAML personality animations sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKMESH_MATERIAL Member List

This is the complete list of members for SDKMESH_MATERIAL, including all inherited members.
Ambient | SDKMESH_MATERIAL
Diffuse | SDKMESH_MATERIAL
DiffuseRV | SDKMESH_MATERIAL
DiffuseTexture | SDKMESH_MATERIAL
DiffuseTextureName | SDKMESH_MATERIAL
Emissive | SDKMESH_MATERIAL
Force64_1 | SDKMESH_MATERIAL
Force64_2 | SDKMESH_MATERIAL
Force64_3 | SDKMESH_MATERIAL
Force64_4 | SDKMESH_MATERIAL
Force64_5 | SDKMESH_MATERIAL
Force64_6 | SDKMESH_MATERIAL
MaterialInstancePath | SDKMESH_MATERIAL
Name | SDKMESH_MATERIAL
NormalRV | SDKMESH_MATERIAL
NormalTexture | SDKMESH_MATERIAL
NormalTextureName | SDKMESH_MATERIAL
Power | SDKMESH_MATERIAL
Specular | SDKMESH_MATERIAL
SpecularRV | SDKMESH_MATERIAL
SpecularTexture | SDKMESH_MATERIAL
SpecularTextureName | SDKMESH_MATERIAL
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/common/suspensionmanager.cpp Source File

  • Playlist
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicShapes.cpp Source File

  • Direct3D-Direct2D interop

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Constants.h Source File

  • Playlist

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 using namespace Concurrency;
00016 using namespace Platform;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Media::Playlists;
00019 using namespace Windows::Storage;
00020 using namespace Windows::Storage::Pickers;
00021 using namespace Windows::UI::ViewManagement;
00022
00023 namespace SDKSample
00024 {
00025     public value struct Scenario
00026     {
00027         String^ Title;
00028         String^ ClassName;
00029     };
00030
00031     partial ref class MainPage
00032     {
00033     public:
00034         static property String^ FEATURE_NAME
00035         {
00036             String^ get()
00037             {
00038                 return ref new String(L"Playlists sample");
00039             }
00040         }
00041
00042         static property Array<Scenario>^ scenarios
00043         {
00044             Array<Scenario>^ get()
00045             {
00046                 return scenariosInner;
00047             }
00048         }
00049
00050     internal:
00051         static property Array<String^>^ audioExtensions
00052         {
00053             Array<String^>^ get()
00054             {
00055                 return audioExtensionsInner;
00056             }
00057         }
00058         static property Array<String^>^ playlistExtensions
00059         {
00060             Array<String^>^ get()
00061             {
00062                 return playlistExtensionsInner;
00063             }
00064         }
00065         static property Playlist^ playlist
00066         {
00067             Playlist^  get()
00068             {
00069                 return playlistInner;
00070             }
00071             void set(Playlist^ value)
00072             {
00073                 playlistInner = value;
00074             }
00075         }
00076
00077         static FileOpenPicker^ CreateFilePicker(Array<String^>^ extensions);
00078         static task<Playlist^> PickPlaylist();
00079         static bool EnsureUnsnapped();
00080
00081     private:
00082         static Array<Scenario>^ scenariosInner;
00083         static Array<String^>^ audioExtensionsInner;
00084         static Array<String^>^ playlistExtensionsInner;
00085         static Playlist^ playlistInner;
00086     };
00087 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/pch.h Source File

  • DirectX postcard app

pch.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #ifndef Assert
00011 #if defined(DEBUG) || defined(_DEBUG)
00012 #define Assert(b) if (!(b)) { OutputDebugStringA("Assert: " #b "\n"); }
00013 #else
00014 #define Assert(b)
00015 #endif // DEBUG || _DEBUG
00016 #endif
00017
00018 #include <wrl.h>
00019 #include <d3d11_1.h>
00020 #include <d2d1_1.h>
00021 #include <d2d1effects.h>
00022 #include <dwrite_1.h>
00023 #include <wincodec.h>
00024 #include <math.h>
00025 #include <DirectXMath.h>
00026 #include <ppltasks.h>
00027 #include <shcore.h>
00028 #include <collection.h>
00029 #include <assert.h>
00030 #include <agile.h>
00031
00032 #include <list>
00033 #include <vector>
00034
00035 #include "BasicMath.h"
00036 #include "BasicCamera.h"
00037 #include "BasicLoader.h"
00038 #include "BasicShapes.h"
00039 #include "BasicReaderWriter.h"
00040 #include "DDSTextureLoader.h"
00041
00042 #include "DirectXSample.h"
00043 #include "windows.ui.xaml.media.dxinterop.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/DeviceList.cpp Source File

  • Custom driver access
  • app_cpp

DeviceList.cpp

Go to the documentation of this file.
00001 #include "pch.h"
00002 #include "MainPage.xaml.h"
00003 #include "App.xaml.h"
00004
00005 using namespace SDKSample::CustomDeviceAccess;
00006
00007 using namespace Platform;
00008 using namespace Platform::Collections;
00009 using namespace Windows::ApplicationModel;
00010 using namespace Windows::Devices::Enumeration;
00011 using namespace Windows::Foundation;
00012 using namespace Windows::Foundation::Collections;
00013 using namespace Windows::UI::Core;
00014 using namespace Windows::UI::Xaml;
00015 using namespace Windows::UI::Xaml::Documents;
00016
00017 DeviceList^ DeviceList::_Current = nullptr;
00018
00019 DeviceList^ DeviceList::Current::get()
00020 {
00021     if (DeviceList::_Current == nullptr) {
00022         DeviceList::_Current = ref new DeviceList();
00023     }
00024     return DeviceList::_Current;
00025 }
00026
00027
00028 DeviceList::DeviceList() : m_WatcherStarted(false), m_WatcherSuspended(false)
00029 {
00030     m_Fx2Watcher = nullptr;
00031     m_List = ref new Vector<DeviceListEntry^>();
00032     InitDeviceWatcher();
00033
00034     // Register for app suspend/resume handlers
00035     App::Current->Suspending += ref new SuspendingEventHandler(this, &DeviceList::SuspendDeviceWatcher);
00036     App::Current->Resuming += ref new EventHandler<Object^>(this, &DeviceList::ResumeDeviceWatcher);
00037 }
00038
00039 void DeviceList::InitDeviceWatcher()
00040 {
00041     // Define the selector to enumerate all of the fx2 device interface class instances
00042     auto selector = Samples::Devices::Fx2::Fx2Device::GetDeviceSelector();
00043
00044     // Set of properties to retrieve
00045     auto properties = ref new Vector<String^>(1, "System.Devices.DeviceInstanceId");
00046
00047     // Create a device watcher to look for instances of the fx2 device interface
00048     m_Fx2Watcher = DeviceInformation::CreateWatcher(selector, properties);
00049
00050     m_Fx2Watcher->Added += ref new TypedEventHandler<DeviceWatcher^, DeviceInformation^>(this, &DeviceList::OnFx2Added);
00051     m_Fx2Watcher->Removed += ref new TypedEventHandler<DeviceWatcher^, DeviceInformationUpdate^>(this, &DeviceList::OnFx2Removed);
00052     m_Fx2Watcher->EnumerationCompleted += ref new TypedEventHandler<DeviceWatcher^,Object^>(this, &DeviceList::OnFx2EnumerationComplete);
00053 }
00054
00055 void DeviceList::StartFx2Watcher() {
00056     MainPage::Current->NotifyUser("starting device watcher", NotifyType::StatusMessage);
00057     std::for_each(
00058         begin(m_List),
00059         end(m_List),
00060         [](DeviceListEntry^ Entry) {
00061             Entry->Matched = false;
00062         }
00063     );
00064     WatcherStarted = true;
00065     m_Fx2Watcher->Start();
00066 }
00067
00068 void DeviceList::StopFx2Watcher() {
00069     MainPage::Current->NotifyUser("stopping fx2 watcher", NotifyType::StatusMessage);
00070     m_Fx2Watcher->Stop();
00071     WatcherStarted = false;
00072 }
00073
00074 void DeviceList::CreateBooleanTable(
00075     InlineCollection^ Table,
00076     const Platform::Array<bool>^ NewValues,
00077     const Platform::Array<bool>^ OldValues,
00078     String^ /* IndexTitle */,
00079     String^ /* ValueTitle */,
00080     String^ TrueValue,
00081     String^ FalseValue
00082     )
00083 {
00084     Table->Clear();
00085
00086     for(int i = 0; i < (int) NewValues->Length; i += 1) {
00087         auto line = ref new Span();
00088         auto block = ref new Run();
00089         block->Text = (i+1).ToString();
00090         line->Inlines->Append(block);
00091
00092         block = ref new Run();
00093         block->Text = "    ";
00094         line->Inlines->Append(block);
00095
00096         block = ref new Run();
00097         block->Text = NewValues[i] ? TrueValue : FalseValue;
00098
00099         if ((OldValues != nullptr) && (OldValues[i] != NewValues[i])) {
00100             auto bold = ref new Bold();
00101             bold->Inlines->Append(block);
00102             line->Inlines->Append(bold);
00103         } else {
00104             line->Inlines->Append(block);
00105         }
00106
00107         line->Inlines->Append(ref new LineBreak());
00108
00109         Table->Append(line);
00110     }
00111 }
00112
00113 DeviceListEntry^ DeviceList::FindDevice(String^ Id)
00114 {
00115     auto i = std::find_if(begin(m_List),
00116                           end(m_List),
00117                           [Id](DeviceListEntry^ e) {return e->Id == Id;});
00118     if (i == end(m_List)) {
00119         return nullptr;
00120     } else {
00121         return *i;
00122     }
00123 }
00124
00125 void DeviceList::OnFx2Added(DeviceWatcher^ /* Sender */, DeviceInformation^ DevInterface)
00126 {
00127     MainPage::Current->Dispatcher->RunAsync(
00128         CoreDispatcherPriority::Normal,
00129         ref new DispatchedHandler(
00130             [this, DevInterface] () -> void {
00131                 MainPage::Current->NotifyUser("OnFx2Added: " + DevInterface->Id, NotifyType::StatusMessage);
00132
00133                 // search the device list for a device with a matching interface ID
00134                 auto match = FindDevice(DevInterface->Id);
00135
00136                 // If we found a match then mark it as verified and return
00137                 if (match != nullptr) {
00138                     match->Matched = true;
00139                     return;
00140                 }
00141
00142                 // Create a new elemetn for this device interface, and queue up the query of its
00143                 // device information
00144                 match = ref new DeviceListEntry(DevInterface);
00145
00146                 // Add the new element to the end of the list of devices
00147                 m_List->Append(match);
00148             }
00149         )
00150         );
00151 }
00152
00153 void DeviceList::OnFx2Removed(DeviceWatcher^ /* Sender */, DeviceInformationUpdate^ DevInterface)
00154 {
00155     auto deviceId = DevInterface->Id;
00156
00157     MainPage::Current->Dispatcher->RunAsync(
00158         CoreDispatcherPriority::Normal,
00159         ref new DispatchedHandler(
00160             [this, deviceId] () {
00161                 MainPage::Current->NotifyUser("OnFx2Removed: " + deviceId, NotifyType::StatusMessage);
00162
00163                 // Search the list of devices for one with a matching ID.  Move the matched
00164                 // item to the end of the list.
00165                 auto i = std::remove_if(begin(m_List),
00166                                       end(m_List),
00167                                       [deviceId](DeviceListEntry^ e) {return e->Id == deviceId;});
00168
00169                 // if there's no match return.
00170                 if (i == end(m_List)) {
00171                     return;
00172                 }
00173
00174                 // Remove the last item from the list.
00175                 MainPage::Current->NotifyUser("OnFx2Removed: " + deviceId + " removed", NotifyType::StatusMessage);
00176                 m_List->RemoveAtEnd();
00177             }
00178         )
00179         );
00180 }
00181
00182 void DeviceList::OnFx2EnumerationComplete(DeviceWatcher^ /* Sender */, Object^ /* o */)
00183 {
00184     MainPage::Current->Dispatcher->RunAsync(
00185         CoreDispatcherPriority::Normal,
00186         ref new DispatchedHandler(
00187             [this] () {
00188
00189                 MainPage::Current->NotifyUser("OnFx2EnumerationComplete", NotifyType::StatusMessage);
00190
00191                 DeviceList^ me = this;
00192
00193                 // Move all the unmatched elements to the end of the list
00194                 auto i = std::remove_if(begin(m_List),
00195                                         end(m_List),
00196                                         [](DeviceListEntry^ e) { return e->Matched == false;});
00197
00198                 // Determine the number of unmatched entries
00199                 auto unmatchedCount = end(m_List) - i;
00200
00201                 while (unmatchedCount > 0) {
00202                     m_List->RemoveAtEnd();
00203                     unmatchedCount -= 1;
00204                 }
00205             }
00206         )
00207         );
00208 }
00209
00210 void DeviceList::SuspendDeviceWatcher(Object^, SuspendingEventArgs^)
00211 {
00212     if (WatcherStarted) {
00213         m_WatcherSuspended = true;
00214         StopFx2Watcher();
00215     } else {
00216         m_WatcherSuspended = false;
00217     }
00218 }
00219
00220 void DeviceList::ResumeDeviceWatcher(Object^,Object^)
00221 {
00222     if (m_WatcherSuspended) {
00223         m_WatcherSuspended = false;
00224         StartFx2Watcher();
00225     }
00226 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/MainPage.xaml.cpp Source File

  • Trial app and in-app purchase

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/BasicMath.h Source File

  • XAudio2 audio file playback

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/Constants.h Source File

  • Calendar details and math

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Calendar Sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ContactPickerPage.xaml.h Source File

  • Contact Picker app

ContactPickerPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ContactPickerPage.xaml.h
00013 // Declaration of the ContactPickerPage class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "ContactPickerPage.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace ContactPicker
00023 {
00024     /// <summary>
00025     /// An empty page that can be used on its own or navigated to within a Frame.
00026     /// </summary>
00027     [Windows::Foundation::Metadata::WebHostHidden]
00028     public ref class ContactPickerPage sealed
00029     {
00030     public:
00031         ContactPickerPage();
00032
00033     protected:
00034         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00035         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036
00037     internal:
00038         Windows::ApplicationModel::Contacts::Provider::ContactPickerUI^ contactPickerUI;
00039
00040     private:
00041         value struct SampleContact
00042         {
00043             Platform::String^ Name;
00044             Platform::String^ HomeEmail;
00045             Platform::String^ WorkEmail;
00046             Platform::String^ HomePhone;
00047             Platform::String^ WorkPhone;
00048             Platform::String^ MobilePhone;
00049             Platform::String^ Address;
00050             Platform::String^ Street;
00051             Platform::String^ City;
00052             Platform::String^ State;
00053             Platform::String^ ZipCode;
00054             Platform::String^ Id;
00055         };
00056         static Platform::Array<SampleContact>^ contactSet;
00057         void AddSampleContact(SampleContact sampleContact);
00058         SampleContact ResolveSampleContact(Object^ listBoxItem);
00059
00060         void OnContactRemoved(Windows::ApplicationModel::Contacts::Provider::ContactPickerUI^ sender, Windows::ApplicationModel::Contacts::Provider::ContactRemovedEventArgs^ e);
00061         void ContactList_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00062
00063         Windows::Foundation::EventRegistrationToken token;
00064     };
00065 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level1.cpp Source File

  • DirectX 3D shooting game

Level1.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Level1.h"
00010 #include "Face.h"
00011
00012 using namespace DirectX;
00013
00014 //----------------------------------------------------------------------
00015
00016 Level1::Level1()
00017 {
00018     m_timeLimit = 20.0f;
00019     m_objective =  "Hit each of the targets before time runs out.\nTouch to aim.  Tap in right box to fire.  Drag in left box to move.";
00020 }
00021
00022 //----------------------------------------------------------------------
00023
00024 void Level1::Initialize(std::vector<GameObject^> objects)
00025 {
00026     XMFLOAT3 position[] =
00027     {
00028         XMFLOAT3(-2.5f, -1.0f, -1.5f),
00029         XMFLOAT3(-1.0f,  1.0f, -3.0f),
00030         XMFLOAT3( 1.5f,  0.0f, -3.0f),
00031         XMFLOAT3(-2.5f, -1.0f, -5.5f),
00032         XMFLOAT3( 0.5f, -2.0f, -5.0f),
00033         XMFLOAT3( 1.5f, -2.0f, -5.5f),
00034         XMFLOAT3( 2.0f,  0.0f,  0.0f),
00035         XMFLOAT3( 0.0f,  0.0f,  0.0f),
00036         XMFLOAT3(-2.0f,  0.0f,  0.0f)
00037     };
00038
00039     int targetCount = 0;
00040     for (auto object = objects.begin(); object != objects.end(); object++)
00041     {
00042         if (Face^ target = dynamic_cast<Face^>(*object))
00043         {
00044             if (targetCount < 9)
00045             {
00046                 target->Active(true);
00047                 target->Target(true);
00048                 target->Hit(false);
00049                 target->AnimatePosition(nullptr);
00050                 target->Position(position[targetCount]);
00051                 targetCount++;
00052             }
00053             else
00054             {
00055                 (*object)->Active(false);
00056             }
00057         }
00058         else
00059         {
00060             (*object)->Active(false);
00061         }
00062     }
00063 }
00064
00065 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/common/LayoutAwarePage.h Source File

  • Transcoding media
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/pch.cpp Source File

  • Context menu

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BumpMapping.cpp Source File

  • Direct3D bump mapping

BumpMapping.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicShapes.h"
00010 #include "BasicLoader.h"
00011 #include "BumpMapping.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Windows::UI::Core;
00017
00018 D3D11_INPUT_ELEMENT_DESC tangentVertexLayoutDesc[] =
00019 {
00020     { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0,  0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00021     { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00022     { "TANGENT",  0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 20, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00023     { "TANGENT",  1, DXGI_FORMAT_R32G32B32_FLOAT, 0, 32, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00024 };
00025
00026 BumpMapping::BumpMapping()
00027 {
00028 }
00029
00030 void BumpMapping::CreateDeviceIndependentResources()
00031 {
00032     DirectXBase::CreateDeviceIndependentResources();
00033
00034     // Allocate the scene camera.
00035     m_camera = ref new BasicCamera();
00036
00037     // Allocate and initialize a controller object.
00038     m_controller = ref new LonLatController();
00039     m_controller->Initialize(m_window.Get());
00040     m_controller->SetPosition(START_POSITION);
00041 }
00042
00043 void BumpMapping::CreateDeviceResources()
00044 {
00045     DirectXBase::CreateDeviceResources();
00046
00047     // Allocate and initialize the sample header
00048     m_sampleOverlay = ref new SampleOverlay();
00049
00050     m_sampleOverlay->Initialize(
00051         m_d2dDevice.Get(),
00052         m_d2dContext.Get(),
00053         m_wicFactory.Get(),
00054         m_dwriteFactory.Get(),
00055         "Direct3D bump mapping sample"
00056         );
00057
00058
00059     // Start loading assets
00060     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00061
00062     loader->LoadShader(
00063         L"BumpVertexShader.cso",
00064         tangentVertexLayoutDesc,
00065         ARRAYSIZE(tangentVertexLayoutDesc),
00066         &m_vertexShader,
00067         &m_inputLayout
00068         );
00069
00070     // create the vertex and index buffers for drawing the sphere
00071
00072     BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());
00073
00074     shapes->CreateTangentSphere(
00075         &m_vertexBuffer,
00076         &m_indexBuffer,
00077         nullptr,
00078         &m_indexCount
00079         );
00080
00081     // create the constant buffer for updating model and camera data
00082     CD3D11_BUFFER_DESC constantBufferDesc(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
00083     DX::ThrowIfFailed(
00084         m_d3dDevice->CreateBuffer(
00085         &constantBufferDesc,
00086         nullptr,             // leave the buffer uninitialized
00087         &m_constantBuffer
00088         )
00089         );
00090
00091     loader->LoadShader(
00092         L"BumpPixelShader.cso",
00093         &m_pixelShader
00094         );
00095
00096     loader->LoadTexture(
00097         L"texture.dds",
00098         &m_texture,
00099         &m_textureSRV
00100         );
00101
00102     loader->LoadTexture(
00103         L"normals.dds",
00104         &m_normals,
00105         &m_normalSRV
00106         );
00107
00108     // create the sampler
00109     D3D11_SAMPLER_DESC samplerDesc;
00110     ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
00111     samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
00112     samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
00113     samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
00114     samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
00115     samplerDesc.MipLODBias = 0.0f;
00116     samplerDesc.MaxAnisotropy = m_featureLevel >= D3D_FEATURE_LEVEL_9_2 ? 4 : 2;
00117     samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
00118     samplerDesc.BorderColor[0] = 0.0f;
00119     samplerDesc.BorderColor[1] = 0.0f;
00120     samplerDesc.BorderColor[2] = 0.0f;
00121     samplerDesc.BorderColor[3] = 0.0f;
00122     // allow use of all mip levels
00123     samplerDesc.MinLOD = 0;
00124     samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;
00125
00126     DX::ThrowIfFailed(
00127         m_d3dDevice->CreateSamplerState(
00128         &samplerDesc,
00129         &m_sampler)
00130         );
00131
00132     // create the normal map sampler
00133     ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
00134     samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
00135     samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
00136     samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
00137     samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
00138     samplerDesc.MipLODBias = 0.0f;
00139     samplerDesc.MaxAnisotropy = m_featureLevel >= D3D_FEATURE_LEVEL_9_2 ? 4 : 2;
00140     samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
00141     samplerDesc.BorderColor[0] = 0.0f;
00142     samplerDesc.BorderColor[1] = 0.0f;
00143     samplerDesc.BorderColor[2] = 0.0f;
00144     samplerDesc.BorderColor[3] = 0.0f;
00145     // allow use of all mip levels
00146     samplerDesc.MinLOD = 0;
00147     samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;
00148
00149     DX::ThrowIfFailed(
00150         m_d3dDevice->CreateSamplerState(
00151         &samplerDesc,
00152         &m_normalSampler)
00153         );
00154 }
00155
00156 void BumpMapping::CreateWindowSizeDependentResources()
00157 {
00158     DirectXBase::CreateWindowSizeDependentResources();
00159
00160     // specify the 3D projection matrix
00161     m_camera->SetProjectionParameters(
00162         70.0f,                                                  // use a 70-degree vertical field of view
00163         m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
00164         0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
00165         100.0f                                                  // specify the farthest Z-distance at which to draw vertices
00166         );
00167
00168     // save the new projection matrix to the constant buffer data struct
00169     m_camera->GetProjectionMatrix(&m_constantBufferData.projection);
00170
00171     m_sampleOverlay->UpdateForWindowSizeChange();
00172 }
00173
00174 void BumpMapping::Render()
00175 {
00176     UINT stride = sizeof(TangentVertex);
00177     UINT offset = 0;
00178
00179     // bind the render targets
00180     m_d3dContext->OMSetRenderTargets(
00181         1,
00182         m_d3dRenderTargetView.GetAddressOf(),
00183         m_d3dDepthStencilView.Get());
00184
00185     // clear both the render target and depth stencil to default values
00186     const float ClearColor[4] = { 0, 0, 0, 1 };
00187
00188     m_d3dContext->ClearRenderTargetView(
00189         m_d3dRenderTargetView.Get(),
00190         ClearColor
00191         );
00192
00193     m_d3dContext->ClearDepthStencilView(
00194         m_d3dDepthStencilView.Get(),
00195         D3D11_CLEAR_DEPTH,
00196         1.0f,
00197         0
00198         );
00199
00200     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00201
00202     // set the vertex and index buffers, and specify the way they define geometry
00203     m_d3dContext->IASetVertexBuffers(
00204         0,                              // starting at the first vertex buffer slot
00205         1,                              // set one vertex buffer binding
00206         m_vertexBuffer.GetAddressOf(),
00207         &stride,                        // specify the size in bytes of a single vertex
00208         &offset                         // specify the base vertex in the buffer
00209         );
00210
00211     // set the index buffer
00212     m_d3dContext->IASetIndexBuffer(
00213         m_indexBuffer.Get(),
00214         DXGI_FORMAT_R16_UINT,   // unsigned short index format
00215         0                       // specify the base index in the buffer
00216         );
00217
00218     // specify the way the vertex and index buffers define geometry
00219     m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00220
00221     // set the vertex shader stage state
00222     m_d3dContext->VSSetShader(
00223         m_vertexShader.Get(),
00224         nullptr,                // don't use shader linkage
00225         0                       // don't use shader linkage
00226         );
00227
00228     m_d3dContext->VSSetConstantBuffers(
00229         0,                              // starting at the first constant buffer slot
00230         1,                              // set one constant buffer binding
00231         m_constantBuffer.GetAddressOf()
00232         );
00233
00234     // set the pixel shader stage state
00235     m_d3dContext->PSSetShader(
00236         m_pixelShader.Get(),
00237         nullptr,                // don't use shader linkage
00238         0                       // don't use shader linkage
00239         );
00240
00241     // first put the two surfaces into an array
00242     ID3D11ShaderResourceView* shaderResourceViews[] = {
00243         m_textureSRV.Get(),
00244         m_normalSRV.Get()
00245     };
00246
00247     // then bind them to the device
00248     m_d3dContext->PSSetShaderResources(
00249         0,                          // starting at the first shader resource slot
00250         2,                          // bind 2 shader resources
00251         shaderResourceViews
00252         );
00253
00254     // then put the two samplers into an array
00255     ID3D11SamplerState* samplers[] = {
00256         m_sampler.Get(),
00257         m_normalSampler.Get()
00258     };
00259
00260     // and bind them to the device
00261     m_d3dContext->PSSetSamplers(
00262         0,                          // starting at the first sampler slot
00263         2,                          // bind 2 shader resources
00264         samplers
00265         );
00266
00267     // draw the mesh
00268     m_d3dContext->DrawIndexed(
00269         m_indexCount,   // draw all created vertices
00270         0,              // starting with the first vertex
00271         0               // and the first index
00272         );
00273
00274     m_sampleOverlay->Render();
00275
00276 }
00277
00278 void BumpMapping::Update(float TimeTotal, float TimeDelta)
00279 {
00280     // update the model matrix based on the time
00281     m_constantBufferData.model = rotationY(TimeTotal * 10.0f);
00282
00283     m_controller->Update(m_window.Get());
00284
00285     // update the view matrix based on the camera position
00286     m_camera->SetViewParameters(
00287         m_controller->get_Position(),       // point we are at
00288         m_controller->get_LookPoint(),      // point to look towards
00289         float3(0, 1, 0)                     // up-vector  (+Y)
00290         );
00291
00292     // get the camera transform for transmission to the GPU
00293     m_camera->GetViewMatrix(&m_constantBufferData.view);
00294
00295     // update the constant buffer with the new data
00296     m_d3dContext->UpdateSubresource(
00297         m_constantBuffer.Get(),
00298         0,
00299         nullptr,
00300         &m_constantBufferData,
00301         0,
00302         0
00303         );
00304 }
00305
00306 void BumpMapping::SaveInternalState(_In_ IPropertySet^ state)
00307 {
00308     m_controller->SaveInternalState(state);
00309 }
00310
00311 void BumpMapping::LoadInternalState(_In_ IPropertySet^ state)
00312 {
00313     m_controller->LoadInternalState(state);
00314 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/Invert.h Source File

  • Media extensions
  • MediaExtensions
  • Invert

Invert.h

Go to the documentation of this file.
00001 // Defines the transform class.
00002 //
00003 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00004 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00005 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00006 // PARTICULAR PURPOSE.
00007 //
00008 // Copyright (c) Microsoft Corporation. All rights reserved.
00009
00010 #pragma once
00011
00012 #include <new>
00013 #include <mfapi.h>
00014 #include <mftransform.h>
00015 #include <mfidl.h>
00016 #include <mferror.h>
00017 #include <strsafe.h>
00018 #include <assert.h>
00019 #include <wrl\implements.h>
00020 #include <wrl\module.h>
00021 #include <wrl\client.h>
00022 #include <windows.media.h>
00023 #include <D3D11.h>
00024
00025 #include "DirectXVideoTransform.h"
00026 #include "InvertTransform.h"
00027
00028 using namespace Microsoft::WRL;
00029
00030 // CLSID of the MFT.
00031 // {F1BF74F0-65F4-4F47-925C-E8B564A9A87E}
00032 DEFINE_GUID(CLSID_InvertMFT,
00033 0xf1bf74f0, 0x65f4, 0x4f47, 0x92, 0x5c, 0xe8, 0xb5, 0x64, 0xa9, 0xa8, 0x7e);
00034
00035 class CInvert
00036     : public RuntimeClass<
00037            RuntimeClassFlags< Microsoft::WRL::RuntimeClassType::WinRtClassicComMix >,
00038            ABI::Windows::Media::IMediaExtension,
00039            IMFTransform >
00040 {
00041     InspectableClass(RuntimeClass_InvertTransform_InvertEffect, BaseTrust)
00042
00043 public:
00044     CInvert();
00045     ~CInvert();
00046
00047     STDMETHOD(RuntimeClassInitialize)();
00048
00049     // IMediaExtension
00050     STDMETHODIMP SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration);
00051
00052     // IMFTransform
00053     STDMETHODIMP GetStreamLimits(
00054         DWORD   *pdwInputMinimum,
00055         DWORD   *pdwInputMaximum,
00056         DWORD   *pdwOutputMinimum,
00057         DWORD   *pdwOutputMaximum
00058     );
00059
00060     STDMETHODIMP GetStreamCount(
00061         DWORD   *pcInputStreams,
00062         DWORD   *pcOutputStreams
00063     );
00064
00065     STDMETHODIMP GetInputStreamInfo(
00066         DWORD                     dwInputStreamID,
00067         MFT_INPUT_STREAM_INFO *   pStreamInfo
00068     );
00069
00070     STDMETHODIMP GetOutputStreamInfo(
00071         DWORD                     dwOutputStreamID,
00072         MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00073     );
00074
00075     STDMETHODIMP GetAttributes(IMFAttributes** pAttributes);
00076
00077     STDMETHODIMP GetInputAvailableType(
00078         DWORD           dwInputStreamID,
00079         DWORD           dwTypeIndex, // 0-based
00080         IMFMediaType    **ppType
00081     );
00082
00083     STDMETHODIMP GetOutputAvailableType(
00084         DWORD           dwOutputStreamID,
00085         DWORD           dwTypeIndex, // 0-based
00086         IMFMediaType    **ppType
00087     );
00088
00089     STDMETHODIMP SetInputType(
00090         DWORD           dwInputStreamID,
00091         IMFMediaType    *pType,
00092         DWORD           dwFlags
00093     );
00094
00095     STDMETHODIMP SetOutputType(
00096         DWORD           dwOutputStreamID,
00097         IMFMediaType    *pType,
00098         DWORD           dwFlags
00099     );
00100
00101     STDMETHODIMP GetInputCurrentType(
00102         DWORD           dwInputStreamID,
00103         IMFMediaType    **ppType
00104     );
00105
00106     STDMETHODIMP GetOutputCurrentType(
00107         DWORD           dwOutputStreamID,
00108         IMFMediaType    **ppType
00109     );
00110
00111     STDMETHODIMP GetInputStatus(
00112         DWORD           dwInputStreamID,
00113         DWORD           *pdwFlags
00114     );
00115
00116     STDMETHODIMP GetOutputStatus(DWORD *pdwFlags);
00117
00118     STDMETHODIMP ProcessMessage(
00119         MFT_MESSAGE_TYPE    eMessage,
00120         ULONG_PTR           ulParam
00121     );
00122
00123     STDMETHODIMP ProcessInput(
00124         DWORD               dwInputStreamID,
00125         IMFSample           *pSample,
00126         DWORD               dwFlags
00127     );
00128
00129     STDMETHODIMP ProcessOutput(
00130         DWORD                   dwFlags,
00131         DWORD                   cOutputBufferCount,
00132         MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
00133         DWORD                   *pdwStatus
00134     );
00135
00136     STDMETHODIMP GetOutputStreamAttributes(
00137         DWORD           dwOutputStreamID,
00138         IMFAttributes   **ppAttributes
00139         );
00140
00141     // Optional Methods
00142     STDMETHODIMP GetStreamIDs(
00143         DWORD   dwInputIDArraySize,
00144         DWORD   *pdwInputIDs,
00145         DWORD   dwOutputIDArraySize,
00146         DWORD   *pdwOutputIDs
00147         ) { return E_NOTIMPL; }
00148
00149     STDMETHODIMP GetInputStreamAttributes(
00150         DWORD           dwInputStreamID,
00151         IMFAttributes   **ppAttributes
00152         ) { return E_NOTIMPL; }
00153
00154     STDMETHODIMP DeleteInputStream(DWORD dwStreamID){ return E_NOTIMPL; }
00155
00156     STDMETHODIMP AddInputStreams(
00157         DWORD   cStreams,
00158         DWORD   *adwStreamIDs
00159         ) { return E_NOTIMPL; }
00160
00161     STDMETHODIMP SetOutputBounds(
00162         LONGLONG        hnsLowerBound,
00163         LONGLONG        hnsUpperBound
00164         ) { return E_NOTIMPL; }
00165
00166     STDMETHODIMP ProcessEvent(
00167         DWORD              dwInputStreamID,
00168         IMFMediaEvent      *pEvent
00169         ) { return E_NOTIMPL; }
00170
00171 private:
00172
00173     HRESULT OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt);
00174
00175     HRESULT OnCheckInputType(IMFMediaType *pmt);
00176     HRESULT OnCheckOutputType(IMFMediaType *pmt);
00177     HRESULT OnCheckMediaType(IMFMediaType *pmt);
00178     HRESULT BeginStreaming();
00179     HRESULT OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut);
00180     HRESULT UpdateFormatInfo();
00181     HRESULT UpdateDX11Device();
00182     HRESULT CheckDX11Device();
00183     void InvalidateDX11Resources();
00184
00185     CRITICAL_SECTION            m_critSec;
00186
00187     // Streaming
00188     bool                        m_bStreamingInitialized;
00189     ComPtr<IMFSample>           m_pSample;                 // Input sample.
00190     ComPtr<IMFMediaType>        m_pInputType;              // Input media type.
00191     ComPtr<IMFMediaType>        m_pOutputType;             // Output media type.
00192
00193     // Fomat information
00194     UINT32                      m_imageWidthInPixels;
00195     UINT32                      m_imageHeightInPixels;
00196     DWORD                       m_cbImageSize;              // Image size, in bytes.
00197
00198     ComPtr<IMFAttributes>       m_pAttributes;
00199
00200     // DirectX manager
00201     ComPtr<IMFDXGIDeviceManager> m_pDX11Manager;
00202     HANDLE m_hDeviceHandle;
00203
00204     // Device resources
00205     ComPtr<ID3D11Device> m_pDevice;
00206     ComPtr<ID3D11DeviceContext> m_pContext;
00207     ComPtr<ID3D11Texture2D> m_pInBufferTex;
00208     ComPtr<ID3D11Texture2D> m_pOutBufferTex;
00209     ComPtr<ID3D11Texture2D> m_pOutBufferStage;
00210
00211     // Output
00212     ComPtr<IMFVideoSampleAllocatorEx> m_spOutputSampleAllocator;
00213     ComPtr<IMFAttributes> m_spOutputAttributes;
00214
00215     // Transform
00216     DirectXVideoTransform *m_pTransform;
00217 };
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level6.h Source File

  • XAML DirectX 3D shooting game

Level6.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Level6:
00011 // This class defines the sixth and final level of the game.  It derives from the
00012 // fifth level.  In this level the targets do not disappear when they are hit.
00013 // The target will stay highlighted for two seconds.  As this is the last level
00014 // the only criteria for completion is time expiring.
00015
00016 #include "Level5.h"
00017
00018 ref class Level6: public Level5
00019 {
00020 internal:
00021     Level6();
00022     virtual bool Update(
00023         float time,
00024         float elapsedTime,
00025         float timeRemaining,
00026         std::vector<GameObject^> objects
00027         ) override;
00028 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Scenario1.xaml.h Source File

  • SimpleOrientationSensor

Scenario1.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace SimpleOrientationSensorCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Windows::Devices::Sensors::SimpleOrientationSensor^ sensor;
00042             Windows::Foundation::EventRegistrationToken visibilityToken;
00043             Windows::Foundation::EventRegistrationToken orientationToken;
00044
00045             void VisibilityChanged(Platform::Object^ sender, Windows::UI::Core::VisibilityChangedEventArgs^ e);
00046             void DisplayOrientation(Windows::Devices::Sensors::SimpleOrientation orientation);
00047             void OrientationChanged(Windows::Devices::Sensors::SimpleOrientationSensor^ sender, Windows::Devices::Sensors::SimpleOrientationSensorOrientationChangedEventArgs^ e);
00048             void ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00049             void ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050         };
00051     }
00052 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/SampleOverlay.cpp Source File

  • DirectWrite inline object

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/D2DInterpolationModes.cpp Source File

  • Direct2D interpolation modes

D2DInterpolationModes.cpp

Go to the documentation of this file.
00001 //  Microsoft Windows
00002 //  Copyright (c) Microsoft Corporation. All rights reserved.
00003
00004 #include "pch.h"
00005 #include "D2DInterpolationModes.h"
00006
00007 using namespace D2D1;
00008 using namespace Microsoft::WRL;
00009 using namespace Windows::ApplicationModel;
00010 using namespace Windows::ApplicationModel::Core;
00011 using namespace Windows::ApplicationModel::Activation;
00012 using namespace Windows::Foundation;
00013 using namespace Windows::Foundation::Collections;
00014 using namespace Windows::Graphics::Display;
00015 using namespace Windows::Storage;
00016 using namespace Windows::System;
00017 using namespace Windows::UI::Core;
00018 using namespace Windows::UI::Input;
00019 using namespace Windows::UI::Popups;
00020 using namespace Windows::UI::ViewManagement;
00021
00022 static const float maxZoom = 20.0f;
00023 static const float minZoom = 0.05f;
00024 static const float menuTop = 70;
00025 static const float menuMargin = 10;
00026 static const float menuBottom = 120;
00027 static const float renderTimeTextOffset = 300;
00028
00029 D2DInterpolationModes::D2DInterpolationModes() :
00030     m_totalZoom(0.0f),
00031     m_imageRotate(0.0f),
00032     m_viewPosition(D2D1::Point2F(0, 0)),
00033     m_renderTimer(ref new BasicTimer()),
00034     m_isWindowClosed(false),
00035     m_isWindowVisible(true),
00036     m_isSnapped(false)
00037 {
00038 }
00039
00040 void D2DInterpolationModes::CreateDeviceResources()
00041 {
00042     DirectXBase::CreateDeviceResources();
00043
00044     m_sampleOverlay = ref new SampleOverlay();
00045
00046     m_sampleOverlay->Initialize(
00047         m_d2dDevice.Get(),
00048         m_d2dContext.Get(),
00049         m_wicFactory.Get(),
00050         m_dwriteFactory.Get(),
00051         "Direct2D effects interpolation modes sample"
00052         );
00053
00054     // Create Text Formats.
00055     DX::ThrowIfFailed(
00056         m_dwriteFactory->CreateTextFormat(
00057             L"Segoe UI",
00058             nullptr,
00059             DWRITE_FONT_WEIGHT_THIN,
00060             DWRITE_FONT_STYLE_NORMAL,
00061             DWRITE_FONT_STRETCH_NORMAL,
00062             30,
00063             L"en-US",
00064             &m_modeTextFormat
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         m_dwriteFactory->CreateTextFormat(
00070             L"Segoe UI",
00071             nullptr,
00072             DWRITE_FONT_WEIGHT_THIN,
00073             DWRITE_FONT_STYLE_NORMAL,
00074             DWRITE_FONT_STRETCH_NORMAL,
00075             20,
00076             L"en-US",
00077             &m_renderTimeFormat
00078             )
00079         );
00080
00081     // Create white brush.
00082     DX::ThrowIfFailed(
00083         m_d2dContext->CreateSolidColorBrush(
00084             D2D1::ColorF(D2D1::ColorF::White),
00085             &m_whiteBrush
00086             )
00087         );
00088
00089     ComPtr<IWICBitmapDecoder> decoder;
00090     DX::ThrowIfFailed(
00091         m_wicFactory->CreateDecoderFromFilename(
00092             L"mammoth.jpg",
00093             nullptr,
00094             GENERIC_READ,
00095             WICDecodeMetadataCacheOnDemand,
00096             &decoder
00097             )
00098         );
00099
00100     ComPtr<IWICBitmapFrameDecode> frame;
00101     DX::ThrowIfFailed(
00102         decoder->GetFrame(0, &frame)
00103         );
00104
00105     ComPtr<IWICFormatConverter> converter;
00106     DX::ThrowIfFailed(
00107         m_wicFactory->CreateFormatConverter(&converter)
00108         );
00109
00110     DX::ThrowIfFailed(
00111         converter->Initialize(
00112             frame.Get(),
00113             GUID_WICPixelFormat32bppPBGRA,
00114             WICBitmapDitherTypeNone,
00115             nullptr,
00116             0.0f,
00117             WICBitmapPaletteTypeCustom
00118             )
00119         );
00120
00121     UINT width;
00122     UINT height;
00123     frame->GetSize(&width, &height);
00124     m_imageSize = D2D1::SizeU(width, height);
00125
00126     // Create BitmapSource effect using the WIC Format Converter as an input.
00127     DX::ThrowIfFailed(
00128         m_d2dContext->CreateEffect(
00129             CLSID_D2D1BitmapSource,
00130             &m_bitmapSourceEffect
00131             )
00132         );
00133
00134     DX::ThrowIfFailed(
00135         m_bitmapSourceEffect->SetValue(
00136             D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE,
00137             converter.Get()
00138             )
00139         );
00140
00141     // Because the image produced by m_bitmapSourceEffect will never change,
00142     // enable caching for a performance gain.
00143     DX::ThrowIfFailed(
00144         m_bitmapSourceEffect->SetValue(
00145             D2D1_PROPERTY_CACHED,
00146             TRUE
00147             )
00148         );
00149
00150     // Create two 2DAffineTransform effects and set the inputs to the BitmapSource effect.
00151     // Both effects will default to the Nearest Neighbor interpolation mode.
00152
00153     // Create left effect.
00154     DX::ThrowIfFailed(
00155         m_d2dContext->CreateEffect(
00156             CLSID_D2D12DAffineTransform,
00157             &m_2DAffineTransformEffectLeft
00158             )
00159         );
00160
00161     m_2DAffineTransformEffectLeft->SetInputEffect(0, m_bitmapSourceEffect.Get(), false);
00162
00163     DX::ThrowIfFailed(
00164         m_2DAffineTransformEffectLeft->SetValue(
00165             D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE,
00166             D2D1_INTERPOLATION_MODE_LINEAR
00167             )
00168         );
00169
00170     m_modeTextLeft = "Interpolation mode: linear";
00171
00172     // Create right effect.
00173     DX::ThrowIfFailed(
00174         m_d2dContext->CreateEffect(
00175             CLSID_D2D12DAffineTransform,
00176             &m_2DAffineTransformEffectRight
00177             )
00178         );
00179
00180     m_2DAffineTransformEffectRight->SetInputEffect(0, m_bitmapSourceEffect.Get(), false);
00181
00182     DX::ThrowIfFailed(
00183         m_2DAffineTransformEffectRight->SetValue(
00184             D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE,
00185             D2D1_INTERPOLATION_MODE_LINEAR
00186             )
00187         );
00188
00189     m_modeTextRight = "Interpolation mode: linear";
00190
00191     m_selectedEffect = nullptr;
00192 }
00193
00194 void D2DInterpolationModes::CreateWindowSizeDependentResources()
00195 {
00196     DirectXBase::CreateWindowSizeDependentResources();
00197
00198     // Convert m_imageSize to DIPs in order to be DPI-independent.
00199     m_imageSizeDips =
00200         D2D1::SizeF(
00201             m_imageSize.width * 96.0f / m_dpi,
00202             m_imageSize.height * 96.0f / m_dpi
00203             );
00204
00205     // Screen size in DIPs.
00206     D2D1_SIZE_F size = m_d2dContext->GetSize();
00207
00208     m_totalZoom = min(
00209         size.width / m_imageSizeDips.width,
00210         size.height / m_imageSizeDips.height
00211         );
00212
00213     UpdateEffectMatrices();
00214 }
00215
00216 void D2DInterpolationModes::Render()
00217 {
00218     D2D1_SIZE_F size = m_d2dContext->GetSize();
00219
00220     // Start render duration timer.
00221     m_renderTimer->Update();
00222
00223     m_d2dContext->BeginDraw();
00224
00225     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::DarkMagenta));
00226
00227     // Caculate width, horizontal midpoint and height of screen, which will be used create
00228     // the rectangles that bound the left and right 2DAffineTransform effects.
00229     const float screenWidthMidpoint = size.width / 2.0f;
00230     const float screenWidth = size.width;
00231     const float screenHeight = size.height;
00232
00233     // Draw left interpolation mode effect.
00234     m_d2dContext->DrawImage(
00235         m_2DAffineTransformEffectLeft.Get(),
00236         D2D1::Point2F(0, 0),
00237         D2D1::RectF(
00238             0,
00239             0,
00240             screenWidthMidpoint,
00241             screenHeight
00242             )
00243         );
00244
00245     // Draw right interpolation mode effect.
00246     m_d2dContext->DrawImage(
00247         m_2DAffineTransformEffectRight.Get(),
00248         D2D1::Point2F(size.width / 2.0f, 0),
00249         D2D1::RectF(
00250             screenWidthMidpoint,
00251             0,
00252             screenWidth,
00253             screenHeight
00254             )
00255         );
00256
00257     // Only draw text when not in snapped mode.
00258     if (!m_isSnapped)
00259     {
00260         // Draw left interpolation mode text.
00261         m_d2dContext->DrawText(
00262             m_modeTextLeft->Data(),
00263             m_modeTextLeft->Length(),
00264             m_modeTextFormat.Get(),
00265             D2D1::RectF(
00266                 menuMargin,
00267                 menuTop,
00268                 screenWidthMidpoint,
00269                 menuBottom
00270                 ),
00271             m_whiteBrush.Get()
00272             );
00273
00274         // Draw right interpolation mode text.
00275         m_d2dContext->DrawText(
00276             m_modeTextRight->Data(),
00277             m_modeTextRight->Length(),
00278             m_modeTextFormat.Get(),
00279             D2D1::RectF(
00280                 menuMargin + screenWidthMidpoint,
00281                 menuTop,
00282                 screenWidth,
00283                 menuBottom
00284                 ),
00285             m_whiteBrush.Get()
00286             );
00287
00288         // Don't draw render time on startup.
00289         if (m_renderDuration > 0.0f)
00290         {
00291             // Draw renderTime text, truncated to 2 decimal places.
00292             Platform::String^ renderTimeString =
00293                 "Time to render frame: " + (floor(m_renderDuration * 100000.F) / 100.0f).ToString() + "ms";
00294
00295             m_d2dContext->DrawText(
00296                 renderTimeString->Data(),
00297                 renderTimeString->Length(),
00298                 m_renderTimeFormat.Get(),
00299                 D2D1::RectF(
00300                     screenWidth - renderTimeTextOffset,
00301                     0,
00302                     screenWidth,
00303                     menuBottom
00304                     ),
00305                 m_whiteBrush.Get()
00306                 );
00307         }
00308     }
00309
00310     // Create vertical line to divide the two interpolation modes.
00311     m_d2dContext->DrawLine(
00312         D2D1::Point2F(screenWidthMidpoint, 0.0f),
00313         D2D1::Point2F(screenWidthMidpoint, screenHeight),
00314         m_whiteBrush.Get(),
00315         0.5F
00316         );
00317
00318     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00319     // is lost. It will be handled during the next call to Present.
00320     HRESULT hr = m_d2dContext->EndDraw();
00321     if (hr != D2DERR_RECREATE_TARGET)
00322     {
00323         DX::ThrowIfFailed(hr);
00324     }
00325
00326     m_sampleOverlay->Render();
00327
00328     // Measure how long it took to perform image rendering operations.
00329     m_renderTimer->Update();
00330     m_renderDuration = m_renderTimer->Delta;
00331
00332     Present();
00333 }
00334
00335 void D2DInterpolationModes::AddMenuItem(PopupMenu^ popupMenu, Platform::String^ caption)
00336 {
00337     popupMenu->Commands->Append(
00338         ref new UICommand(
00339             caption,
00340             ref new UICommandInvokedHandler(this, &D2DInterpolationModes::MenuItemSelected)
00341             )
00342         );
00343 }
00344
00345 void D2DInterpolationModes::HandlePointerPressed(PointerPoint^ point)
00346 {
00347     D2D1_SIZE_F size = m_d2dContext->GetSize();
00348
00349     Point position = point->Position;
00350     if (position.Y > menuTop && position.Y < menuBottom && !m_isSnapped)
00351     {
00352         if (position.X > menuMargin &&
00353             position.X < size.width / 2)
00354         {
00355             m_selectedEffect = m_2DAffineTransformEffectLeft;
00356         }
00357
00358         if (position.X > size.width / 2 &&
00359             position.X < size.width)
00360         {
00361             m_selectedEffect = m_2DAffineTransformEffectRight;
00362         }
00363
00364         PopupMenu^ popupMenu = ref new PopupMenu();
00365
00366         // Separate function to abstract away adding items to popup menu.
00367         AddMenuItem(popupMenu, "Nearest neighbor interpolation");
00368         AddMenuItem(popupMenu, "Linear interpolation");
00369         AddMenuItem(popupMenu, "Cubic interpolation");
00370         AddMenuItem(popupMenu, "Multisample linear interpolation");
00371         AddMenuItem(popupMenu, "Anisotropic interpolation");
00372         AddMenuItem(popupMenu, "High-quality cubic interpolation");
00373
00374         popupMenu->ShowAsync(position);
00375     }
00376     else
00377     {
00378         m_gestureRecognizer->ProcessDownEvent(point);
00379     }
00380 }
00381
00382 void D2DInterpolationModes::HandleManipulationUpdated(
00383     Point position,
00384     Point positionDelta,
00385     float zoomDelta
00386     )
00387 {
00388     D2D1_SIZE_F size = m_d2dContext->GetSize();
00389
00390     // In this method, the transformation variables are updated to reflect how
00391     // the user is manipulating the image. The GestureRecognizer does the
00392     // majority of the math; only the internal vars need to be updated here.
00393
00394     // The zoom operation should be centered around the position of the pointer/gesture,
00395     // which is stored as the "position" argument, and is in the screen coordinate space.
00396
00397     // When transforming the pointer position from screen space to image space, take
00398     // any rotation into account.
00399     Matrix3x2F inverseRotation =
00400         Matrix3x2F::Rotation(
00401             m_imageRotate * -1,
00402             D2D1::Point2F(
00403                 size.width / 2,
00404                 size.height / 2
00405                 )
00406             );
00407
00408     D2D1_POINT_2F rotatedPosition =
00409         inverseRotation.TransformPoint(
00410             D2D1::Point2F(
00411                 position.X,
00412                 position.Y
00413                 )
00414             );
00415
00416     // Apply the inverse render transforms to the pointer position to obtain the
00417     // corresponding position in the image.
00418     D2D1_POINT_2F pointerPosition_ImageSpace = D2D1::Point2F(
00419         (m_viewPosition.x - rotatedPosition.x) / m_totalZoom,
00420         (m_viewPosition.y - rotatedPosition.y) / m_totalZoom
00421         );
00422
00423     // Apply the zoom operation. zoomDelta is a coefficient for the change in zoom, thus take
00424     // the product of it and the current zoom value, not the sum.
00425     m_totalZoom *= zoomDelta;
00426     m_totalZoom = Clamp(m_totalZoom, minZoom, maxZoom);
00427
00428     // Calculate the view position based on the new m_totalZoom value.
00429     m_viewPosition.x = pointerPosition_ImageSpace.x * m_totalZoom + rotatedPosition.x;
00430     m_viewPosition.y = pointerPosition_ImageSpace.y * m_totalZoom + rotatedPosition.y;
00431
00432     float offsetX = position.X - size.width / 2.0f;
00433     float offsetY = position.Y - size.height / 2.0f;
00434
00435     float circumference = static_cast<float>(sqrtf(offsetX * offsetX + offsetY * offsetY) * 2 * M_PI);
00436
00437     // Detect edge case when pointer is directly over center of image.
00438     if (offsetX != 0 || offsetY != 0)
00439     {
00440         float distance =
00441             positionDelta.Y * (offsetX / sqrtf(offsetX * offsetX + offsetY * offsetY)) -
00442             positionDelta.X * (offsetY / sqrtf(offsetX * offsetX + offsetY * offsetY));
00443
00444         m_imageRotate += distance / circumference * 360;
00445     }
00446
00447     UpdateEffectMatrices();
00448 }
00449
00450 void D2DInterpolationModes::UpdateEffectMatrices()
00451 {
00452     D2D1_SIZE_F size = m_d2dContext->GetSize();
00453
00454     // Snaps image to center of screen once zoomed out.
00455     if (m_imageSizeDips.width * m_totalZoom < size.width ||
00456         m_imageSizeDips.height * m_totalZoom < size.height)
00457     {
00458         m_viewPosition.x = size.width / 2 - m_imageSizeDips.width * m_totalZoom / 2;
00459         m_viewPosition.y = size.height / 2 - m_imageSizeDips.height * m_totalZoom / 2;
00460     }
00461
00462     Matrix3x2F scale = Matrix3x2F::Scale(m_totalZoom, m_totalZoom);
00463
00464     Matrix3x2F translate = Matrix3x2F::Translation(
00465         m_viewPosition.x,
00466         m_viewPosition.y
00467         );
00468
00469     Matrix3x2F rotate = Matrix3x2F::Rotation(
00470         m_imageRotate,
00471         D2D1::Point2F(
00472             size.width / 2,
00473             size.height / 2
00474             )
00475         );
00476
00477     Matrix3x2F transformMatrix = scale * translate * rotate;
00478
00479     DX::ThrowIfFailed(
00480         m_2DAffineTransformEffectLeft->SetValue(
00481             D2D1_2DAFFINETRANSFORM_PROP_TRANSFORM_MATRIX,
00482             transformMatrix
00483             )
00484         );
00485
00486     DX::ThrowIfFailed(
00487         m_2DAffineTransformEffectRight->SetValue(
00488             D2D1_2DAFFINETRANSFORM_PROP_TRANSFORM_MATRIX,
00489             transformMatrix
00490             )
00491         );
00492
00493     Render();
00494 }
00495
00496 void D2DInterpolationModes::MenuItemSelected(IUICommand^ command)
00497 {
00498     Platform::String^ menuText;
00499     D2D1_INTERPOLATION_MODE interpolationMode;
00500
00501     if (command->Label == "Nearest neighbor interpolation")
00502     {
00503         menuText = "Interpolation mode: nearest neighbor";
00504         interpolationMode = D2D1_INTERPOLATION_MODE_NEAREST_NEIGHBOR;
00505     }
00506     else if (command->Label == "Linear interpolation")
00507     {
00508         menuText = "Interpolation mode: linear";
00509         interpolationMode = D2D1_INTERPOLATION_MODE_LINEAR;
00510     }
00511     else if (command->Label == "Cubic interpolation")
00512     {
00513         menuText = "Interpolation mode: cubic interpolation";
00514         interpolationMode = D2D1_INTERPOLATION_MODE_CUBIC;
00515     }
00516     else if (command->Label == "Multisample linear interpolation")
00517     {
00518         menuText = "Interpolation mode: multisample linear";
00519         interpolationMode = D2D1_INTERPOLATION_MODE_MULTI_SAMPLE_LINEAR;
00520     }
00521     else if (command->Label == "Anisotropic interpolation")
00522     {
00523         menuText = "Interpolation mode: anisotropic";
00524         interpolationMode = D2D1_INTERPOLATION_MODE_ANISOTROPIC;
00525     }
00526     else if (command->Label == "High-quality cubic interpolation")
00527     {
00528         menuText = "Interpolation mode: high-quality cubic";
00529         interpolationMode = D2D1_INTERPOLATION_MODE_HIGH_QUALITY_CUBIC;
00530     }
00531     else
00532     {
00533         // If no match, throw exception.
00534         throw ref new Platform::FailureException();
00535     }
00536
00537     // Update corresponding effect with new interpolation mode.
00538     DX::ThrowIfFailed(
00539         m_selectedEffect->SetValue(
00540             D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE,
00541             interpolationMode
00542             )
00543         );
00544
00545     // Update menu text based on selected interpolation mode.
00546     if (m_selectedEffect == m_2DAffineTransformEffectLeft)
00547     {
00548         m_modeTextLeft = menuText;
00549     }
00550     else
00551     {
00552         m_modeTextRight = menuText;
00553     }
00554
00555     Render();
00556 }
00557
00558 void D2DInterpolationModes::OnWindowSizeChanged(
00559     _In_ CoreWindow^ sender,
00560     _In_ WindowSizeChangedEventArgs^ args
00561     )
00562 {
00563     m_isSnapped = (ApplicationView::Value == ApplicationViewState::Snapped);
00564     m_sampleOverlay->UpdateForWindowSizeChange();
00565     UpdateForWindowSizeChange();
00566 }
00567
00568 void D2DInterpolationModes::OnVisibilityChanged(
00569     _In_ CoreWindow^ sender,
00570     _In_ VisibilityChangedEventArgs^ args
00571     )
00572 {
00573     m_isWindowVisible = args->Visible;
00574 }
00575
00576 void D2DInterpolationModes::OnWindowClosed(
00577     _In_ CoreWindow^ window,
00578     _In_ CoreWindowEventArgs^ args
00579     )
00580 {
00581     m_isWindowClosed = true;
00582 }
00583
00584 void D2DInterpolationModes::OnLogicalDpiChanged(
00585     _In_ Object^ sender
00586     )
00587 {
00588     SetDpi(DisplayProperties::LogicalDpi);
00589     Render();
00590 }
00591
00592 void D2DInterpolationModes::OnDisplayContentsInvalidated(
00593     _In_ Object^ sender
00594     )
00595 {
00596     // Ensure the D3D Device is available for rendering.
00597     ValidateDevice();
00598
00599     Render();
00600 }
00601
00602 // Input events.
00603 void D2DInterpolationModes::OnPointerPressed(
00604     _In_ CoreWindow^ window,
00605     _In_ PointerEventArgs^ args
00606     )
00607 {
00608     HandlePointerPressed(args->CurrentPoint);
00609 }
00610
00611 void D2DInterpolationModes::OnPointerReleased(
00612     _In_ CoreWindow^ window,
00613     _In_ PointerEventArgs^ args
00614     )
00615 {
00616     m_gestureRecognizer->ProcessUpEvent(args->CurrentPoint);
00617 }
00618
00619 void D2DInterpolationModes::OnPointerMoved(
00620     _In_ CoreWindow^ window,
00621     _In_ PointerEventArgs^ args
00622     )
00623 {
00624     m_gestureRecognizer->ProcessMoveEvents(args->GetIntermediatePoints());
00625 }
00626
00627 void D2DInterpolationModes::OnPointerWheelChanged(
00628     _In_ CoreWindow^ window,
00629     _In_ PointerEventArgs^ args
00630     )
00631 {
00632     m_gestureRecognizer->ProcessMouseWheelEvent(args->CurrentPoint, FALSE, TRUE);
00633 }
00634
00635 void D2DInterpolationModes::OnManipulationUpdated(
00636     _In_ GestureRecognizer^ gestureRecognizer,
00637     _In_ ManipulationUpdatedEventArgs^ args
00638     )
00639 {
00640     HandleManipulationUpdated(
00641         args->Position,
00642         args->Delta.Translation,
00643         args->Delta.Scale
00644         );
00645 }
00646
00647 void D2DInterpolationModes::OnActivated(
00648     _In_ CoreApplicationView^ applicationView,
00649     _In_ IActivatedEventArgs^ args
00650     )
00651 {
00652     m_window->Activate();
00653 }
00654
00655 void D2DInterpolationModes::OnSuspending(
00656     _In_ Platform::Object^ sender,
00657     _In_ SuspendingEventArgs^ args
00658     )
00659 {
00660     // Store user-manipulated properties in the LocalSettings collection.
00661     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00662
00663     // Check to ensure each key is not already in the collection. If it is present, remove
00664     // it, before storing in the new value. These values will be retried in the OnResuming method.
00665
00666     if (settingsValues->HasKey("m_totalZoom"))
00667     {
00668         settingsValues->Remove("m_totalZoom");
00669     }
00670     settingsValues->Insert("m_totalZoom", PropertyValue::CreateSingle(m_totalZoom));
00671
00672     if (settingsValues->HasKey("m_viewPositionX"))
00673     {
00674         settingsValues->Remove("m_viewPositionX");
00675     }
00676     settingsValues->Insert("m_viewPositionX", PropertyValue::CreateSingle(m_viewPosition.x));
00677
00678     if (settingsValues->HasKey("m_viewPositionY"))
00679     {
00680         settingsValues->Remove("m_viewPositionY");
00681     }
00682     settingsValues->Insert("m_viewPositionY", PropertyValue::CreateSingle(m_viewPosition.y));
00683
00684     if (settingsValues->HasKey("m_imageRotate"))
00685     {
00686         settingsValues->Remove("m_imageRotate");
00687     }
00688     settingsValues->Insert("m_imageRotate", PropertyValue::CreateSingle(m_imageRotate));
00689
00690     int leftInterpolationMode;
00691     m_2DAffineTransformEffectLeft->GetValue(D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE, &leftInterpolationMode);
00692     if (settingsValues->HasKey("leftInterpolationMode"))
00693     {
00694         settingsValues->Remove("leftInterpolationMode");
00695     }
00696     settingsValues->Insert("leftInterpolationMode", PropertyValue::CreateInt32(leftInterpolationMode));
00697
00698     int rightInterpolationMode;
00699     m_2DAffineTransformEffectRight->GetValue(D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE, &rightInterpolationMode);
00700     if (settingsValues->HasKey("rightInterpolationMode"))
00701     {
00702         settingsValues->Remove("rightInterpolationMode");
00703     }
00704     settingsValues->Insert("rightInterpolationMode", PropertyValue::CreateInt32(rightInterpolationMode));
00705
00706     if (settingsValues->HasKey("m_modeTextLeft"))
00707     {
00708         settingsValues->Remove("m_modeTextLeft");
00709     }
00710     settingsValues->Insert("m_modeTextLeft", PropertyValue::CreateString(m_modeTextLeft));
00711
00712     if (settingsValues->HasKey("m_modeTextRight"))
00713     {
00714         settingsValues->Remove("m_modeTextRight");
00715     }
00716     settingsValues->Insert("m_modeTextRight", PropertyValue::CreateString(m_modeTextRight));
00717 }
00718
00719 void D2DInterpolationModes::OnResuming(
00720     _In_ Platform::Object^ sender,
00721     _In_ Platform::Object^ args
00722     )
00723 {
00724 }
00725
00726 // Following methods implement the Windows::ApplicationModel::Core::IFrameworkView Interface.
00727 void D2DInterpolationModes::Initialize(
00728     _In_ CoreApplicationView^ applicationView
00729     )
00730 {
00731     applicationView->Activated +=
00732         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &D2DInterpolationModes::OnActivated);
00733
00734     CoreApplication::Suspending +=
00735         ref new EventHandler<SuspendingEventArgs^>(this, &D2DInterpolationModes::OnSuspending);
00736
00737     CoreApplication::Resuming +=
00738         ref new EventHandler<Platform::Object^>(this, &D2DInterpolationModes::OnResuming);
00739 }
00740
00741 void D2DInterpolationModes::SetWindow(
00742     _In_ CoreWindow^ window
00743     )
00744 {
00745     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00746
00747     window->SizeChanged +=
00748         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &D2DInterpolationModes::OnWindowSizeChanged);
00749
00750     window->VisibilityChanged +=
00751         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &D2DInterpolationModes::OnVisibilityChanged);
00752
00753     window->PointerPressed +=
00754         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DInterpolationModes::OnPointerPressed);
00755
00756     window->PointerReleased +=
00757         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DInterpolationModes::OnPointerReleased);
00758
00759     window->PointerMoved +=
00760         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DInterpolationModes::OnPointerMoved);
00761
00762     window->PointerWheelChanged +=
00763         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DInterpolationModes::OnPointerWheelChanged);
00764
00765     window->Closed +=
00766         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &D2DInterpolationModes::OnWindowClosed);
00767
00768     DisplayProperties::LogicalDpiChanged +=
00769         ref new DisplayPropertiesEventHandler(this, &D2DInterpolationModes::OnLogicalDpiChanged);
00770
00771     DisplayProperties::DisplayContentsInvalidated +=
00772         ref new DisplayPropertiesEventHandler(this, &D2DInterpolationModes::OnDisplayContentsInvalidated);
00773
00774     // The gesture recognizer automatically recognizes actions such as zooms
00775     // (whether by pinching or using the scroll wheel) and cursor movement.
00776     m_gestureRecognizer = ref new GestureRecognizer();
00777
00778     m_gestureRecognizer->AutoProcessInertia = false;
00779
00780     m_gestureRecognizer->GestureSettings =
00781         GestureSettings::DoubleTap                     |
00782         GestureSettings::ManipulationTranslateX        |
00783         GestureSettings::ManipulationTranslateY        |
00784         GestureSettings::ManipulationScale             |
00785         GestureSettings::ManipulationTranslateInertia  |
00786         GestureSettings::ManipulationScaleInertia;
00787
00788     m_gestureRecognizer->ManipulationUpdated +=
00789         ref new TypedEventHandler<GestureRecognizer^, ManipulationUpdatedEventArgs^>(this, &D2DInterpolationModes::OnManipulationUpdated);
00790
00791     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00792 }
00793
00794 void D2DInterpolationModes::Uninitialize()
00795 {
00796 }
00797
00798 void D2DInterpolationModes::Load(
00799     _In_ Platform::String^ entryPoint
00800     )
00801 {
00802     // Retrieve user-manipulated variables from the LocalSettings collection if the app was previously suspended.
00803     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00804
00805     if (settingsValues->HasKey("m_totalZoom"))
00806     {
00807         m_totalZoom = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_totalZoom"))->GetSingle();
00808     }
00809
00810     if (settingsValues->HasKey("m_viewPositionX"))
00811     {
00812         m_viewPosition.x = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_viewPositionX"))->GetSingle();
00813     }
00814
00815     if (settingsValues->HasKey("m_viewPositionY"))
00816     {
00817         m_viewPosition.y = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_viewPositionY"))->GetSingle();
00818     }
00819
00820     if (settingsValues->HasKey("m_imageRotate"))
00821     {
00822         m_imageRotate = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_imageRotate"))->GetSingle();
00823     }
00824
00825     if (settingsValues->HasKey("leftInterpolationMode"))
00826     {
00827         int leftInterpolationMode = safe_cast<IPropertyValue^>(settingsValues->Lookup("leftInterpolationMode"))->GetInt32();
00828         m_2DAffineTransformEffectLeft->SetValue(D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE, leftInterpolationMode);
00829     }
00830
00831     if (settingsValues->HasKey("rightInterpolationMode"))
00832     {
00833         int rightInterpolationMode = safe_cast<IPropertyValue^>(settingsValues->Lookup("rightInterpolationMode"))->GetInt32();
00834         m_2DAffineTransformEffectRight->SetValue(D2D1_2DAFFINETRANSFORM_PROP_INTERPOLATION_MODE, rightInterpolationMode);
00835     }
00836
00837     if (settingsValues->HasKey("m_modeTextLeft"))
00838     {
00839         m_modeTextLeft = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_modeTextLeft"))->GetString();
00840     }
00841
00842     if (settingsValues->HasKey("m_modeTextRight"))
00843     {
00844         m_modeTextRight = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_modeTextRight"))->GetString();
00845     }
00846
00847     UpdateEffectMatrices();
00848 }
00849
00850 void D2DInterpolationModes::Run()
00851 {
00852     while (!m_isWindowClosed)
00853     {
00854         if (m_isWindowVisible)
00855         {
00856             m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00857             m_gestureRecognizer->ProcessInertia();
00858         }
00859         else
00860         {
00861             m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00862         }
00863     }
00864 }
00865
00866 // Following methods implement the Windows::ApplicationModel::Core::IFrameworkViewSource interface.
00867 IFrameworkView^ DirectXAppSource::CreateView()
00868 {
00869     return ref new D2DInterpolationModes();
00870 }
00871
00872 [Platform::MTAThread]
00873 int main(Platform::Array<Platform::String^>^)
00874 {
00875     auto directXAppSource = ref new DirectXAppSource();
00876     CoreApplication::Run(directXAppSource);
00877     return 0;
00878 }
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/MainPage.xaml.h Source File

  • SMS background task
  • SmsBackgroundTaskSample

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperFlyout.xaml.h Source File

  • DirectX postcard app

PaperFlyout.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "PaperFlyout.g.h"
00011
00012 namespace Postcard
00013 {
00014     public delegate void ButtonClickedHandler(void);
00015
00016     [Windows::Foundation::Metadata::WebHostHidden]
00017     public ref class PaperFlyout sealed
00018     {
00019     public:
00020         PaperFlyout();
00021
00022         event ButtonClickedHandler^ AddPaperClicked;
00023         event ButtonClickedHandler^ RemovePaperClicked;
00024         event ButtonClickedHandler^ MovePaperClicked;
00025         event ButtonClickedHandler^ StampPaperClicked;
00026
00027     private:
00028         void AddButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00029         void RemoveButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00030         void MoveButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00031         void StampButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00032
00033         void Hide();
00034     };
00035 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/DefaultCloseCommand.xaml.cpp Source File

  • Message dialog

DefaultCloseCommand.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CustomCommand.xaml.cpp
00013 // Implementation of the CustomCommand class
00014 //
00015
00016 #include "pch.h"
00017 #include "DefaultCloseCommand.xaml.h"
00018
00019 using namespace SDKSample::MessageDialogSample;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::UI::Popups;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 DefaultCloseCommand::DefaultCloseCommand()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 void DefaultCloseCommand::OnNavigatedTo(NavigationEventArgs^ e)
00035 {
00036     rootPage = MainPage::Current;
00037 }
00038
00039 /// <summary>
00040 /// Click handler for the 'DefaultCloseCommandButton' button.
00041 /// Demonstrates showing a message dialog with a default close command and content.
00042 /// A message will be displayed indicating that the dialog has been closed.
00043 /// In this scenario, the only command is the default 'Close' command that is used if no other commands are specified.
00044 /// </summary>
00045 /// <param name="sender">The Object that caused this event to be fired.</param>
00046 /// <param name="e">State information and event data associated with the routed event.</param>
00047 void SDKSample::MessageDialogSample::DefaultCloseCommand::DefaultCloseCommandButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049     // Create the message dialog and set its content; it will get a default "Close" command since there aren't any other commands being added
00050     auto messageDialog = ref new MessageDialog("You've exceeded your trial period.");
00051
00052     // Show the message dialog
00053     create_task(messageDialog->ShowAsync()).then([this](IUICommand^ command)
00054     {
00055         rootPage->NotifyUser("The dialog has now been closed", NotifyType::StatusMessage);
00056     });
00057 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario2.xaml.cpp Source File

  • XAML data binding

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018 #include "S2Formatter.h"
00019
00020 using namespace SDKSample::DataBinding;
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025
00026 Scenario2::Scenario2()
00027 {
00028     InitializeComponent();
00029 }
00030
00031 void SDKSample::DataBinding::Scenario2::Scenario2Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00032 {
00033      sliderValueConverter->Value = 70;
00034 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/HttpRequest.cpp Source File

  • Certificate enrollment

HttpRequest.cpp

Go to the documentation of this file.
00001 //-----------------------------------------------------------------------
00002 //
00003 //  Copyright (C) Microsoft Corporation.  All rights reserved.
00004 //
00005 //
00006 // THIS CODE AND INFORMATION ARE PROVIDED AS-IS WITHOUT WARRANTY OF ANY
00007 // KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00008 // IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //-----------------------------------------------------------------------
00011 #include "pch.h"
00012 #include "HttpRequest.h"
00013 #include <robuffer.h>
00014 #include <shcore.h>
00015
00016 using namespace concurrency;
00017 using namespace Microsoft::WRL;
00018 using namespace Platform;
00019 using namespace std;
00020 using namespace Web;
00021 using namespace Windows::Foundation;
00022 using namespace Windows::Storage::Streams;
00023
00024 // Implementation of IXMLHTTPRequest2Callback used when only the complete response is needed.
00025 // When processing chunks of response data as they are received, use HttpRequestBuffersCallback instead.
00026 class HttpRequestStringCallback
00027     : public RuntimeClass<RuntimeClassFlags<ClassicCom>, IXMLHTTPRequest2Callback, FtmBase>
00028 {
00029 public:
00030     HttpRequestStringCallback(IXMLHTTPRequest2* httpRequest,
00031         cancellation_token ct = concurrency::cancellation_token::none()) :
00032         request(httpRequest), cancellationToken(ct)
00033     {
00034         // Register a callback function that aborts the HTTP operation when
00035         // the cancellation token is canceled.
00036         if (cancellationToken != cancellation_token::none())
00037         {
00038             registrationToken = cancellationToken.register_callback([this]()
00039             {
00040                 if (request != nullptr)
00041                 {
00042                     request->Abort();
00043                 }
00044             });
00045         }
00046     }
00047
00048     // Called when the HTTP request is being redirected to a new URL.
00049     IFACEMETHODIMP OnRedirect(IXMLHTTPRequest2*, PCWSTR)
00050     {
00051         return S_OK;
00052     }
00053
00054     // Called when HTTP headers have been received and processed.
00055     IFACEMETHODIMP OnHeadersAvailable(IXMLHTTPRequest2*, DWORD statusCode, PCWSTR reasonPhrase)
00056     {
00057         HRESULT hr = S_OK;
00058
00059         // We must not propagate exceptions back to IXHR2.
00060         try
00061         {
00062             this->statusCode = statusCode;
00063             this->reasonPhrase = reasonPhrase;
00064         }
00065         catch (std::bad_alloc&)
00066         {
00067             hr = E_OUTOFMEMORY;
00068         }
00069
00070         return hr;
00071     }
00072
00073     // Called when a portion of the entity body has been received.
00074     IFACEMETHODIMP OnDataAvailable(IXMLHTTPRequest2*, ISequentialStream*)
00075     {
00076         return S_OK;
00077     }
00078
00079     // Called when the entire entity response has been received.
00080     IFACEMETHODIMP OnResponseReceived(IXMLHTTPRequest2*, ISequentialStream* responseStream)
00081     {
00082         wstring wstr;
00083         HRESULT hr = ReadUtf8StringFromSequentialStream(responseStream, wstr);
00084
00085         // We must not propagate exceptions back to IXHR2.
00086         try
00087         {
00088             completionEvent.set(make_tuple<HRESULT, wstring>(move(hr), move(wstr)));
00089         }
00090         catch (std::bad_alloc&)
00091         {
00092             hr = E_OUTOFMEMORY;
00093         }
00094
00095         return hr;
00096     }
00097
00098     // Simulate the functionality of DataReader.ReadString().
00099     // This is needed because DataReader requires IRandomAccessStream and this
00100     // code has an ISequentialStream that does not have a conversion to IRandomAccessStream like IStream does.
00101     HRESULT ReadUtf8StringFromSequentialStream(ISequentialStream* readStream, wstring& str)
00102     {
00103         // Convert the response to Unicode wstring.
00104         HRESULT hr;
00105
00106         // Holds the response as a Unicode string.
00107         wstringstream ss;
00108
00109         while (true)
00110         {
00111             ULONG cb;
00112             char buffer[4096];
00113
00114             // Read the response as a UTF-8 string.  Since UTF-8 characters are 1-4 bytes long,
00115             // we need to make sure we only read an integral number of characters.  So we'll
00116             // start with 4093 bytes.
00117             hr = readStream->Read(buffer, sizeof(buffer) - 3, &cb);
00118             if (FAILED(hr) || (cb == 0))
00119             {
00120                 break; // Error or no more data to process, exit loop.
00121             }
00122
00123             if (cb == sizeof(buffer) - 3)
00124             {
00125                 ULONG subsequentBytesRead;
00126                 unsigned int i, cl;
00127
00128                 // Find the first byte of the last UTF-8 character in the buffer.
00129                 for (i = cb - 1; (i >= 0) && ((buffer[i] & 0xC0) == 0x80); i--);
00130
00131                 // Calculate the number of subsequent bytes in the UTF-8 character.
00132                 if (((unsigned char)buffer[i]) < 0x80)
00133                 {
00134                     cl = 1;
00135                 }
00136                 else if (((unsigned char)buffer[i]) < 0xE0)
00137                 {
00138                     cl = 2;
00139                 }
00140                 else if (((unsigned char)buffer[i]) < 0xF0)
00141                 {
00142                     cl = 3;
00143                 }
00144                 else
00145                 {
00146                     cl = 4;
00147                 }
00148
00149                 // Read any remaining bytes.
00150                 if (cb < i + cl)
00151                 {
00152                     hr = readStream->Read(buffer + cb, i + cl - cb, &subsequentBytesRead);
00153                     if (FAILED(hr))
00154                     {
00155                         break; // Error, exit loop.
00156                     }
00157                     cb += subsequentBytesRead;
00158                 }
00159             }
00160
00161             // First determine the size required to store the Unicode string.
00162             int const sizeRequired = MultiByteToWideChar(CP_UTF8, 0, buffer, cb, nullptr, 0);
00163             if (sizeRequired == 0)
00164             {
00165                 // Invalid UTF-8.
00166                 hr = HRESULT_FROM_WIN32(GetLastError());
00167                 break;
00168             }
00169             unique_ptr<char16[]> wstr(new(std::nothrow) char16[sizeRequired + 1]);
00170             if (wstr.get() == nullptr)
00171             {
00172                 hr = E_OUTOFMEMORY;
00173                 break;
00174             }
00175
00176             // Convert the string from UTF-8 to UTF-16LE.  This can never fail, since
00177             // the previous call above succeeded.
00178             MultiByteToWideChar(CP_UTF8, 0, buffer, cb, wstr.get(), sizeRequired);
00179             wstr[sizeRequired] = L'\0'; // Terminate the string.
00180             ss << wstr.get(); // Write the string to the stream.
00181         }
00182
00183         str = SUCCEEDED(hr) ? ss.str() : wstring();
00184         return (SUCCEEDED(hr)) ? S_OK : hr; // Don't return S_FALSE.
00185     }
00186
00187     // Called when an error occurs during the HTTP request.
00188     IFACEMETHODIMP OnError(IXMLHTTPRequest2*, HRESULT hrError)
00189     {
00190         HRESULT hr = S_OK;
00191
00192         // We must not propagate exceptions back to IXHR2.
00193         try
00194         {
00195             completionEvent.set(make_tuple<HRESULT, wstring>(move(hrError), wstring()));
00196         }
00197         catch (std::bad_alloc&)
00198         {
00199             hr = E_OUTOFMEMORY;
00200         }
00201
00202         return hr;
00203     }
00204
00205     // Retrieves the completion event for the HTTP operation.
00206     task_completion_event<tuple<HRESULT, wstring>> const& GetCompletionEvent() const
00207     {
00208         return completionEvent;
00209     }
00210
00211     int GetStatusCode() const
00212     {
00213         return statusCode;
00214     }
00215
00216     wstring GetReasonPhrase() const
00217     {
00218         return reasonPhrase;
00219     }
00220
00221 private:
00222     ~HttpRequestStringCallback()
00223     {
00224         // Unregister the callback.
00225         if (cancellationToken != cancellation_token::none())
00226         {
00227             cancellationToken.deregister_callback(registrationToken);
00228         }
00229     }
00230
00231     // Signals that the download operation was canceled.
00232     cancellation_token cancellationToken;
00233
00234     // Used to unregister the cancellation token callback.
00235     cancellation_token_registration registrationToken;
00236
00237     // The IXMLHTTPRequest2 that processes the HTTP request.
00238     ComPtr<IXMLHTTPRequest2> request;
00239
00240     // Task completion event that is set when the
00241     // download operation completes.
00242     task_completion_event<tuple<HRESULT, wstring>> completionEvent;
00243
00244     int statusCode;
00245     wstring reasonPhrase;
00246 };
00247
00248 // Copy bytes from the sequential stream into the buffer provided until
00249 // we reach the end of one or the other.
00250 unsigned int Web::Details::HttpRequestBuffersCallback::ReadData(
00251     _Out_writes_(outputBufferSize) byte* outputBuffer,
00252     unsigned int outputBufferSize)
00253 {
00254     // Lock the data event while doing the read, to ensure that any bytes we don't read will
00255     // result in the correct event getting triggered.
00256     concurrency::critical_section::scoped_lock lock(dataEventLock);
00257
00258     ULONG bytesRead;
00259     CheckHResult(dataStream.Get()->Read(outputBuffer, outputBufferSize, &bytesRead));
00260     if (bytesRead < outputBufferSize)
00261     {
00262         // We need to reset the data event, which we can only do by creating a new one.
00263         dataEvent = task_completion_event<void>();
00264     }
00265
00266     return bytesRead;
00267 }
00268
00269 // Create a task that completes when data is available, in an exception-safe way.
00270 task<void> Web::Details::HttpRequestBuffersCallback::CreateDataTask()
00271 {
00272     concurrency::critical_section::scoped_lock lock(dataEventLock);
00273     return create_task(dataEvent, cancellationToken);
00274 }
00275
00276 HttpRequest::HttpRequest() : responseComplete(true), statusCode(200)
00277 {
00278 }
00279
00280 // Start a download of the specified URI using the specified method.  The returned task produces the
00281 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00282 task<wstring> HttpRequest::DownloadAsync(PCWSTR httpMethod, PCWSTR uri, cancellation_token cancellationToken,
00283     PCWSTR contentType, IStream* postStream, uint64 postStreamSizeToSend)
00284 {
00285     // Create an IXMLHTTPRequest2 object.
00286     ComPtr<IXMLHTTPRequest2> xhr;
00287     CheckHResult(CoCreateInstance(CLSID_XmlHttpRequest, nullptr, CLSCTX_INPROC, IID_PPV_ARGS(&xhr)));
00288
00289     // Create callback.
00290     auto stringCallback = Make<HttpRequestStringCallback>(xhr.Get(), cancellationToken);
00291     CheckHResult(stringCallback ? S_OK : E_OUTOFMEMORY);
00292
00293     auto completionTask = create_task(stringCallback->GetCompletionEvent());
00294
00295     // Create a request.
00296     CheckHResult(xhr->Open(httpMethod, uri, stringCallback.Get(), nullptr, nullptr, nullptr, nullptr));
00297
00298     if (postStream != nullptr && contentType != nullptr)
00299     {
00300         CheckHResult(xhr->SetRequestHeader(L"Content-Type", contentType));
00301     }
00302
00303     // Send the request.
00304     CheckHResult(xhr->Send(postStream, postStreamSizeToSend));
00305
00306     // Return a task that completes when the HTTP operation completes.
00307     // We pass the callback to the continuation because the lifetime of the
00308     // callback must exceed the operation to ensure that cancellation
00309     // works correctly.
00310     return completionTask.then([this, stringCallback](tuple<HRESULT, wstring> resultTuple)
00311     {
00312         // If the GET operation failed, throw an Exception.
00313         CheckHResult(std::get<0>(resultTuple));
00314
00315         statusCode = stringCallback->GetStatusCode();
00316         reasonPhrase = stringCallback->GetReasonPhrase();
00317
00318         return std::get<1>(resultTuple);
00319     });
00320 }
00321
00322 // Start an HTTP GET on the specified URI.  The returned task completes once the entire response
00323 // has been received, and the task produces the HTTP response text.  The status code and reason
00324 // can be read with GetStatusCode() and GetReasonPhrase().
00325 task<wstring> HttpRequest::GetAsync(Uri^ uri, cancellation_token cancellationToken)
00326 {
00327     return DownloadAsync(L"GET",
00328                          uri->AbsoluteUri->Data(),
00329                          cancellationToken,
00330                          nullptr,
00331                          nullptr,
00332                          0);
00333 }
00334
00335 void HttpRequest::CreateMemoryStream(IStream **stream)
00336 {
00337     auto randomAccessStream = ref new Windows::Storage::Streams::InMemoryRandomAccessStream();
00338     CheckHResult(CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(stream)));
00339 }
00340
00341 // Start an HTTP POST on the specified URI, using a string body.  The returned task produces the
00342 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00343 task<wstring> HttpRequest::PostAsync(Uri^ uri, const wstring& body, cancellation_token cancellationToken)
00344 {
00345     int length = 0;
00346     ComPtr<IStream> postStream;
00347     CreateMemoryStream(&postStream);
00348
00349     if (body.length() > 0)
00350     {
00351         // Get the required buffer size.
00352         int size = WideCharToMultiByte(CP_UTF8,                         // UTF-8
00353                                        0,                               // Conversion type
00354                                        body.c_str(),                    // Unicode string to convert
00355                                        static_cast<int>(body.length()), // Size
00356                                        nullptr,                         // Output buffer
00357                                        0,                               // Output buffer size
00358                                        nullptr,
00359                                        nullptr);
00360         CheckHResult((size != 0) ? S_OK : HRESULT_FROM_WIN32(GetLastError()));
00361
00362         std::unique_ptr<char[]> tempData(new char[size]);
00363         length = WideCharToMultiByte(CP_UTF8,                         // UTF-8
00364                                      0,                               // Conversion type
00365                                      body.c_str(),                    // Unicode string to convert
00366                                      static_cast<int>(body.length()), // Size
00367                                      tempData.get(),                  // Output buffer
00368                                      size,                            // Output buffer size
00369                                      nullptr,
00370                                      nullptr);
00371         CheckHResult((length != 0) ? S_OK : HRESULT_FROM_WIN32(GetLastError()));
00372         CheckHResult(postStream->Write(tempData.get(), length, nullptr));
00373     }
00374
00375     return DownloadAsync(L"POST",
00376                          uri->AbsoluteUri->Data(),
00377                          cancellationToken,
00378                          L"text/plain;charset=utf-8",
00379                          postStream.Get(),
00380                          length);
00381 }
00382
00383 // Start an HTTP POST on the specified URI, using a string body.  The returned task produces the
00384 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00385 task<wstring> HttpRequest::PostAsync(Uri^ uri, PCWSTR contentType, const wstring& body, cancellation_token cancellationToken)
00386 {
00387     int length = 0;
00388     ComPtr<IStream> postStream;
00389     CreateMemoryStream(&postStream);
00390
00391     if (body.length() > 0)
00392     {
00393         // Get the required buffer size.
00394         int size = WideCharToMultiByte(CP_UTF8,                         // UTF-8
00395                                        0,                               // Conversion type
00396                                        body.c_str(),                    // Unicode string to convert
00397                                        static_cast<int>(body.length()), // Size
00398                                        nullptr,                         // Output buffer
00399                                        0,                               // Output buffer size
00400                                        nullptr,
00401                                        nullptr);
00402         CheckHResult((size != 0) ? S_OK : HRESULT_FROM_WIN32(GetLastError()));
00403
00404         std::unique_ptr<char[]> tempData(new char[size]);
00405         length = WideCharToMultiByte(CP_UTF8,                         // UTF-8
00406                                      0,                               // Conversion type
00407                                      body.c_str(),                    // Unicode string to convert
00408                                      static_cast<int>(body.length()), // Size
00409                                      tempData.get(),                  // Output buffer
00410                                      size,                            // Output buffer size
00411                                      nullptr,
00412                                      nullptr);
00413         CheckHResult((length != 0) ? S_OK : HRESULT_FROM_WIN32(GetLastError()));
00414         CheckHResult(postStream->Write(tempData.get(), length, nullptr));
00415     }
00416
00417     return DownloadAsync(L"POST",
00418                          uri->AbsoluteUri->Data(),
00419                          cancellationToken,
00420                          contentType,
00421                          postStream.Get(),
00422                          length);
00423 }
00424
00425
00426 // Start an HTTP POST on the specified URI, using a stream body.  The returned task produces the
00427 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00428 task<wstring> HttpRequest::PostAsync(Uri^ uri, PCWSTR contentType, IStream* postStream,
00429     uint64 postStreamSizeToSend, cancellation_token cancellationToken)
00430 {
00431     return DownloadAsync(L"POST",
00432                          uri->AbsoluteUri->Data(),
00433                          cancellationToken,
00434                          contentType,
00435                          postStream,
00436                          postStreamSizeToSend);
00437 }
00438
00439 // Send a request but don't return the response.  Instead, let the caller read it with ReadAsync().
00440 task<void> HttpRequest::SendAsync(const wstring& httpMethod, Uri^ uri, cancellation_token cancellationToken)
00441 {
00442     // Create an IXMLHTTPRequest2 object.
00443     ComPtr<IXMLHTTPRequest2> xhr;
00444     CheckHResult(CoCreateInstance(CLSID_XmlHttpRequest, nullptr, CLSCTX_INPROC, IID_PPV_ARGS(&xhr)));
00445
00446     // Create callback.
00447     buffersCallback = Make<Web::Details::HttpRequestBuffersCallback>(xhr.Get(), cancellationToken);
00448     CheckHResult(buffersCallback ? S_OK : E_OUTOFMEMORY);
00449
00450     ComPtr<IXMLHTTPRequest2Callback> xhrCallback;
00451     CheckHResult(buffersCallback.As(&xhrCallback));
00452
00453     // Open and send the request.
00454     CheckHResult(xhr->Open(httpMethod.c_str(),
00455                            uri->AbsoluteUri->Data(),
00456                            xhrCallback.Get(),
00457                            nullptr,
00458                            nullptr,
00459                            nullptr,
00460                            nullptr));
00461
00462     responseComplete = false;
00463
00464     CheckHResult(xhr->Send(nullptr, 0));
00465
00466     // Return a task that completes when the HTTP operation completes.
00467     // Since buffersCallback holds a reference on the callback, the lifetime of the callback will exceed
00468     // the operation and ensure that cancellation works correctly.
00469     return buffersCallback->CreateDataTask().then([this]()
00470     {
00471         CheckHResult(buffersCallback->GetError());
00472
00473         statusCode = buffersCallback->GetStatusCode();
00474         reasonPhrase = buffersCallback->GetReasonPhrase();
00475     });
00476 }
00477
00478 // Read a chunk of data from the HTTP response, up to a specified length or until we reach the end
00479 // of the response, and store the value in the provided buffer.  This is useful for large content,
00480 // enabling the streaming of the result.
00481 task<void> HttpRequest::ReadAsync(Windows::Storage::Streams::IBuffer^ readBuffer, unsigned int offsetInBuffer,
00482     unsigned int requestedBytesToRead)
00483 {
00484     if (offsetInBuffer + requestedBytesToRead > readBuffer->Capacity)
00485     {
00486         throw ref new InvalidArgumentException();
00487     }
00488
00489     // Return a task that completes when a read completes.
00490     // We pass the callback to the continuation because the lifetime of the
00491     // callback must exceed the operation to ensure that cancellation
00492     // works correctly.
00493     return buffersCallback->CreateDataTask().then([this, readBuffer, offsetInBuffer, requestedBytesToRead]()
00494     {
00495         CheckHResult(buffersCallback->GetError());
00496
00497         // Get a pointer to the location to copy data into.
00498         ComPtr<IBufferByteAccess> bufferByteAccess;
00499         CheckHResult(reinterpret_cast<IUnknown*>(readBuffer)->QueryInterface(IID_PPV_ARGS(&bufferByteAccess)));
00500         byte* outputBuffer; // Returned internal pointer, do not free this value.
00501         CheckHResult(bufferByteAccess->Buffer(&outputBuffer));
00502
00503         // Copy bytes from the sequential stream into the buffer provided until
00504         // we reach the end of one or the other.
00505         readBuffer->Length = buffersCallback->ReadData(outputBuffer + offsetInBuffer, requestedBytesToRead);
00506         if (buffersCallback->IsResponseReceived() && (readBuffer->Length < requestedBytesToRead))
00507         {
00508             responseComplete = true;
00509         }
00510     });
00511 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/PageModel.h Source File

  • Direct2D magazine app

PageModel.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 class ContentImageSource;
00011
00012 ref class Document;
00013 ref class Element;
00014
00015 namespace Magazine
00016 {
00017     //  Page model binds one page of content to one item in the FlipView's items source.
00018     //  It implements the custom property interfaces used to resolve property name string to
00019     //  actual runtime object.
00020     //
00021     //  A page model exposes one property for background content and another for top-level
00022     //  content. It assumes that the first <layer> content element of the <page> element is
00023     //  the background, and the next <layer> element is the top-level content. It also exposes
00024     //  the size of the content it binds. It is important for VirtualSurfaceImageSource that
00025     //  the size of the content is identical to the size of the UI element hosting the content
00026     //  or the content will be stretched to fit.
00027     //
00028     [Windows::UI::Xaml::Data::Bindable]
00029     [Windows::Foundation::Metadata::WebHostHidden]
00030     public ref class PageModel sealed :
00031         public Windows::UI::Xaml::Data::INotifyPropertyChanged
00032     {
00033     public:
00034         virtual event Windows::UI::Xaml::Data::PropertyChangedEventHandler^ PropertyChanged;
00035
00036         property Windows::UI::Xaml::Media::ImageSource^ Content
00037         {
00038             Windows::UI::Xaml::Media::ImageSource^ get()
00039             {
00040                 return m_content->GetImageSource();
00041             }
00042         }
00043
00044         property Windows::UI::Xaml::Media::ImageSource^ Background
00045         {
00046             Windows::UI::Xaml::Media::ImageSource^ get()
00047             {
00048                 return m_background->GetImageSource();
00049             }
00050         }
00051
00052         property int32 ContentWidth
00053         {
00054             int32 get()
00055             {
00056                 return m_content->GetImageSize().cx;
00057             }
00058         }
00059
00060         property int32 ContentHeight
00061         {
00062             int32 get()
00063             {
00064                 return m_content->GetImageSize().cy;
00065             }
00066         }
00067
00068     internal:
00069         PageModel(
00070             _In_ Element^ content,
00071             _In_ Document^ document
00072             );
00073
00074         void UpdateContent(_In_ Element^ content);
00075
00076     private:
00077         // Image source of the content image
00078         Microsoft::WRL::ComPtr<ContentImageSource> m_content;
00079
00080         // Image source of the background image
00081         Microsoft::WRL::ComPtr<ContentImageSource> m_background;
00082     };
00083 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/InkRenderer.h Source File

  • DirectX postcard app

InkRenderer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 enum class InkState
00011 {
00012     StrokeDrawing,
00013     StrokeCompleted
00014 };
00015
00016 ref class InkRenderer
00017 {
00018 internal:
00019     InkRenderer(void);
00020
00021     void CreateDeviceIndependentResources(Microsoft::WRL::ComPtr<ID2D1Factory1> d2dFactory);
00022     void CreateDeviceResources(Microsoft::WRL::ComPtr<ID2D1DeviceContext> d2dContext);
00023     void CreateWindowSizeDependentResources(float dpi);
00024
00025     void DrawInk();
00026
00027     void StartSignature();
00028     void Reset();
00029
00030     void OnPointerPressed(_In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args);
00031     void OnPointerReleased(_In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args);
00032     void OnPointerMoved(_In_ Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args);
00033
00034 private:
00035     void DeleteAllStrokes();
00036     void ConvertStrokeToGeometry(
00037         _In_ Windows::UI::Input::Inking::IInkStroke^ stroke,
00038         _Outptr_result_maybenull_ ID2D1PathGeometry** geometry
00039         );
00040
00041     // Resources shared with PostcardRenderer.
00042     Microsoft::WRL::ComPtr<ID2D1Factory1>                       m_d2dFactory;
00043     Microsoft::WRL::ComPtr<ID2D1DeviceContext>                  m_d2dContext;
00044     float                                                       m_dpi;
00045
00046     // Resources specific to this renderer.
00047     Platform::Agile<Windows::UI::Input::Inking::InkManager>     m_inkManager;
00048     InkState                                                    m_inkState;
00049     uint32                                                      m_pointerId;
00050     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>                m_blackBrush;
00051     std::vector<D2D1_POINT_2F>                                  m_currentStroke;
00052     std::vector<Microsoft::WRL::ComPtr<ID2D1PathGeometry>>      m_strokes;
00053 };
00054
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/ProximityDeviceEvents.xaml.h Source File

  • Proximity

ProximityDeviceEvents.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ProximityDeviceEvents.xaml.h
00013 // Declaration of the ProximityDeviceEvents class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "ProximityDeviceEvents.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace ProximityCPP
00023 {
00024     /// <summary>
00025     /// An empty page that can be used on its own or navigated to within a Frame.
00026     /// </summary>
00027   [Windows::Foundation::Metadata::WebHostHidden]
00028     public ref class ProximityDeviceEvents sealed
00029     {
00030     public:
00031         ProximityDeviceEvents();
00032         void DeviceArrived(Windows::Networking::Proximity::ProximityDevice^ device);
00033         void DeviceDeparted(Windows::Networking::Proximity::ProximityDevice^ device);
00034
00035     protected:
00036         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs ^ e) override;
00038     private:
00039         MainPage^ m_rootPage;
00040         Windows::Foundation::EventRegistrationToken m_arrivedToken;
00041         Windows::Foundation::EventRegistrationToken m_departedToken;
00042         Windows::Networking::Proximity::ProximityDevice^ m_proximityDevice;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendTextTile.xaml.h Source File

  • App tiles and badges
  • C#,C++

SendTextTile.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SendTextTile.xaml.h
00013 // Declaration of the SendTextTile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SendTextTile.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Tiles
00025     {
00026       /// <summary>
00027       /// An empty page that can be used on its own or navigated to within a Frame.
00028       /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030       public ref class SendTextTile sealed
00031       {
00032       public:
00033         SendTextTile();
00034
00035       protected:
00036         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037       private:
00038         MainPage^ rootPage;
00039         void UpdateTileWithText_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040     void UpdateTileWithTextWithStringManipulation_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         void ClearTile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042       };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/Constants.cpp Source File

  • Compass sensor

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     { "Compass data events", "SDKSample.CompassCPP.Scenario1" },
00020     { "Poll compass readings", "SDKSample.CompassCPP.Scenario2" }
00021 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

WorldWallsMesh Member List

This is the complete list of members for WorldWallsMesh, including all inherited members.
__pad0__ WorldWallsMesh
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/OpQueue.h Source File

  • Media extensions
  • MediaExtensions
  • Common

OpQueue.h

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // OpQueue.h
00004 // Async operation queue.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015 #pragma once
00016
00017 #pragma warning( push )
00018 #pragma warning( disable : 4355 )  // 'this' used in base member initializer list
00019
00020 /*
00021     This header file defines an object to help queue and serialize
00022     asynchronous operations.
00023
00024     Background:
00025
00026     To perform an operation asynchronously in Media Foundation, an object
00027     does one of the following:
00028
00029         1. Calls MFPutWorkItem(Ex), using either a standard work queue
00030            identifier or a caller-allocated work queue. The work-queue
00031            thread invokes the object's callback.
00032
00033         2. Creates an async result object (IMFAsyncResult) and calls
00034            MFInvokeCallback to invoke the object's callback.
00035
00036     Ultimately, either of these cause the object's callback to be invoked
00037     from a work-queue thread. The object can then complete the operation
00038     inside the callback.
00039
00040     However, the Media Foundation platform may dispatch async callbacks in
00041     parallel on several threads. Putting an item on a work queue does NOT
00042     guarantee that one operation will complete before the next one starts,
00043     or even that work items will be dispatched in the same order they were
00044     called.
00045
00046     To serialize async operations that should not overlap, an object should
00047     use a queue. While one operation is pending, subsequent operations are
00048     put on the queue, and only dispatched after the previous operation is
00049     complete.
00050
00051     The granularity of a single "operation" depends on the requirements of
00052     that particular object. A single operation might involve several
00053     asynchronous calls before the object dispatches the next operation on
00054     the queue.
00055
00056
00057 */
00058
00059
00060
00061 //-------------------------------------------------------------------
00062 // OpQueue class template
00063 //
00064 // Base class for an async operation queue.
00065 //
00066 // TOperation: The class used to describe operations. This class must
00067 //          implement IUnknown.
00068 //
00069 // The OpQueue class is an abstract class. The derived class must
00070 // implement the following pure-virtual methods:
00071 //
00072 // - IUnknown methods (AddRef, Release, QI)
00073 //
00074 // - DispatchOperation:
00075 //
00076 //      Performs the asynchronous operation specified by pOp.
00077 //
00078 //      At the end of each operation, the derived class must call
00079 //      ProcessQueue to process the next operation in the queue.
00080 //
00081 //      NOTE: An operation is not required to complete inside the
00082 //      DispatchOperation method. A single operation might consist
00083 //      of several asynchronous method calls.
00084 //
00085 // - ValidateOperation:
00086 //
00087 //      Checks whether the object can perform the operation specified
00088 //      by pOp at this time.
00089 //
00090 //      If the object cannot perform the operation now (e.g., because
00091 //      another operation is still in progress) the method should
00092 //      return MF_E_NOTACCEPTING.
00093 //
00094 //-------------------------------------------------------------------
00095 #include "linklist.h"
00096 #include "AsyncCB.h"
00097
00098 template <class T, class TOperation>
00099 class OpQueue //: public IUnknown
00100 {
00101 public:
00102
00103     typedef ComPtrList<TOperation>   OpList;
00104
00105     HRESULT QueueOperation(TOperation *pOp);
00106
00107 protected:
00108
00109     HRESULT ProcessQueue();
00110     HRESULT ProcessQueueAsync(IMFAsyncResult *pResult);
00111
00112     virtual HRESULT DispatchOperation(TOperation *pOp) = 0;
00113     virtual HRESULT ValidateOperation(TOperation *pOp) = 0;
00114
00115     OpQueue(CRITICAL_SECTION& critsec)
00116         : m_OnProcessQueue(static_cast<T *>(this), &OpQueue::ProcessQueueAsync),
00117           m_critsec(critsec)
00118     {
00119     }
00120
00121     virtual ~OpQueue()
00122     {
00123     }
00124
00125 protected:
00126     OpList                  m_OpQueue;         // Queue of operations.
00127     CRITICAL_SECTION&       m_critsec;         // Protects the queue state.
00128     AsyncCallback<T>  m_OnProcessQueue;  // ProcessQueueAsync callback.
00129 };
00130
00131
00132
00133 //-------------------------------------------------------------------
00134 // Place an operation on the queue.
00135 // Public method.
00136 //-------------------------------------------------------------------
00137
00138 template <class T, class TOperation>
00139 HRESULT OpQueue<T, TOperation>::QueueOperation(TOperation *pOp)
00140 {
00141     HRESULT hr = S_OK;
00142
00143     EnterCriticalSection(&m_critsec);
00144
00145     hr = m_OpQueue.InsertBack(pOp);
00146     if (SUCCEEDED(hr))
00147     {
00148         hr = ProcessQueue();
00149     }
00150
00151     LeaveCriticalSection(&m_critsec);
00152     return hr;
00153 }
00154
00155
00156 //-------------------------------------------------------------------
00157 // Process the next operation on the queue.
00158 // Protected method.
00159 //
00160 // Note: This method dispatches the operation to a work queue.
00161 //-------------------------------------------------------------------
00162
00163 template <class T, class TOperation>
00164 HRESULT OpQueue<T, TOperation>::ProcessQueue()
00165 {
00166     HRESULT hr = S_OK;
00167     if (m_OpQueue.GetCount() > 0)
00168     {
00169         hr = MFPutWorkItem2(
00170             MFASYNC_CALLBACK_QUEUE_STANDARD,    // Use the standard work queue.
00171             0,                                  // Default priority
00172             &m_OnProcessQueue,                  // Callback method.
00173             nullptr                             // State object.
00174             );
00175     }
00176     return hr;
00177 }
00178
00179
00180 //-------------------------------------------------------------------
00181 // Process the next operation on the queue.
00182 // Protected method.
00183 //
00184 // Note: This method is called from a work-queue thread.
00185 //-------------------------------------------------------------------
00186
00187 template <class T, class TOperation>
00188 HRESULT OpQueue<T, TOperation>::ProcessQueueAsync(IMFAsyncResult *pResult)
00189 {
00190     HRESULT hr = S_OK;
00191     TOperation *pOp = nullptr;
00192
00193     EnterCriticalSection(&m_critsec);
00194
00195     if (m_OpQueue.GetCount() > 0)
00196     {
00197         hr = m_OpQueue.GetFront(&pOp);
00198
00199         if (SUCCEEDED(hr))
00200         {
00201             hr = ValidateOperation(pOp);
00202         }
00203         if (SUCCEEDED(hr))
00204         {
00205             hr = m_OpQueue.RemoveFront(nullptr);
00206         }
00207         if (SUCCEEDED(hr))
00208         {
00209             (void)DispatchOperation(pOp);
00210         }
00211     }
00212
00213     if (pOp != nullptr)
00214     {
00215         pOp->Release();
00216     }
00217
00218     LeaveCriticalSection(&m_critsec);
00219     return hr;
00220 }
00221
00222 #pragma warning( pop )
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/App.xaml.cpp Source File

  • Date and time formatting

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Constants.cpp Source File

  • Accelerometer sensor

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     { "Accelerometer data events", "SDKSample.AccelerometerCPP.Scenario1" },
00020     { "Accelerometer shake events", "SDKSample.AccelerometerCPP.Scenario2" },
00021     { "Poll accelerometer readings", "SDKSample.AccelerometerCPP.Scenario3" }
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S2_SendToStorage.xaml.h Source File

  • Removable storage

S2_SendToStorage.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // S2_SendToStorage.xaml.h
00013 // Declaration of the S2_SendToStorage class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "S2_SendToStorage.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace RemovableStorageCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class S2_SendToStorage sealed
00031         {
00032         public:
00033             S2_SendToStorage();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         private:
00039             void SendImage_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void ShowDeviceSelectorAsync();
00041             void DeviceList_Tapped(Platform::Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e);
00042             void SendImageFileToStorageAsync(Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement);
00043             void CopyFileToFolderOnStorageAsync(Windows::Storage::StorageFile^ sourceFile, Windows::Storage::StorageFolder^ storage);
00044
00045             MainPage^ rootPage;
00046             // Contains the device information used for populating the device selection list
00047             Windows::Devices::Enumeration::DeviceInformationCollection^ _deviceInfoCollection;
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Scenario4.xaml.h Source File

  • Push and periodic notifications client-side

Scenario4.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include "pch.h"
00014 #include "Scenario4.g.h"
00015 #include "MainPage.xaml.h"
00016
00017 namespace SDKSample
00018 {
00019     namespace SDKTemplate
00020     {
00021         /// <summary>
00022         /// An empty page that can be used on its own or navigated to within a Frame.
00023         /// </summary>
00024       [Windows::Foundation::Metadata::WebHostHidden]
00025         public ref class Scenario4 sealed
00026         {
00027         public:
00028             Scenario4();
00029
00030         protected:
00031             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032         private:
00033             MainPage^ rootPage;
00034             void StartTilePolling_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00035         void StopTilePolling_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036         bool AddURIIfValid(Windows::Foundation::Collections::IVector<Windows::Foundation::Uri^>^ vectorToReceive, Platform::String^ polledUrl);
00037         };
00038     }
00039 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioInput1.xaml.cpp Source File

  • Scheduled notifications
  • C#,C++

ScenarioInput1.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Input.xaml.cpp
00010 // Implementation of the Scenario1Input class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput1.xaml.h"
00015
00016 using namespace ScheduledNotificationsSampleCPP;
00017
00018 using namespace NotificationsExtensions::TileContent;
00019 using namespace NotificationsExtensions::ToastContent;
00020 using namespace Platform;
00021 using namespace Windows::Foundation;
00022 using namespace Windows::UI::Notifications;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 ScenarioInput1::ScenarioInput1()
00028 {
00029   InitializeComponent();
00030   ScheduleButton->Click += ref new RoutedEventHandler(this, &ScenarioInput1::Schedule_Click);
00031   ScheduleButtonString->Click += ref new RoutedEventHandler(this, &ScenarioInput1::Schedule_Click);
00032
00033 }
00034
00035 void ScenarioInput1::Schedule_Click(Object^ sender, RoutedEventArgs^ e)
00036 {
00037   try
00038   {
00039     int dueTimeInSeconds = _wtoi(FutureTimeBox->Text->Data());
00040     if (dueTimeInSeconds <= 0) throw ref new InvalidArgumentException();
00041
00042     String^ updateString = StringBox->Text;
00043
00044     // Use the DateTime type to specify the display time
00045     FILETIME fileTime;
00046     GetSystemTimeAsFileTime(&fileTime);
00047
00048     ULARGE_INTEGER universalTime;
00049     universalTime.LowPart = fileTime.dwLowDateTime;
00050     universalTime.HighPart = fileTime.dwHighDateTime;
00051     universalTime.QuadPart += dueTimeInSeconds * 10000000;
00052
00053     DateTime dueTime;
00054     dueTime.UniversalTime = universalTime.QuadPart;
00055
00056     wchar_t pszIdNumber[6];
00057     HRESULT hr = StringCchPrintf(pszIdNumber, 6, L"%d", std::rand() + RAND_MAX);
00058
00059     auto idNumberString = ref new String(pszIdNumber);
00060
00061     if (FAILED(hr)) throw ref new FailureException();
00062
00063     if (ToastRadio->IsChecked->Value)
00064     {
00065       ScheduleToast(updateString, dueTime, idNumberString);
00066     }
00067     else
00068     {
00069       ScheduleTile(updateString, dueTime, idNumberString);
00070     }
00071   }
00072   catch (...)
00073   {
00074     rootPage->NotifyUser("You must input a valid time in seconds.", NotifyType::ErrorMessage);
00075   }
00076 }
00077
00078 void ScenarioInput1::ScheduleToast(String^ updateString, DateTime dueTime, String^ idNumberString)
00079 {
00080   auto time = Windows::Globalization::DateTimeFormatting::DateTimeFormatter::LongTime;
00081
00082   // Scheduled toasts use the same toast templates as all other kinds of toasts.
00083   IToastText02^ toastContent = ToastContentFactory::CreateToastText02();
00084
00085   toastContent->TextHeading->Text = updateString;
00086   toastContent->TextBodyWrap->Text = "Received: " + time->Format(dueTime);
00087
00088   ScheduledToastNotification^ toast;
00089   if (RepeatBox->IsChecked->Value)
00090   {
00091     TimeSpan interval;
00092     interval.Duration = 60 * 10000000;
00093     toast = ref new ScheduledToastNotification(toastContent->GetXml(), dueTime, interval, 5);
00094
00095     // You can specify an ID so that you can manage toasts later.
00096     // Make sure the ID is 15 characters or less.
00097     toast->Id = "Repeat" + idNumberString;
00098   }
00099   else
00100   {
00101     toast = ref new ScheduledToastNotification(toastContent->GetXml(), dueTime);
00102     toast->Id = "Toast" + idNumberString;
00103   }
00104
00105   ToastNotificationManager::CreateToastNotifier()->AddToSchedule(toast);
00106   rootPage->NotifyUser("Scheduled a toast with ID: " + toast->Id, NotifyType::StatusMessage);
00107 }
00108
00109 void ScenarioInput1::ScheduleTile(String^ updateString, DateTime dueTime, String^ idNumberString)
00110 {
00111   auto time = Windows::Globalization::DateTimeFormatting::DateTimeFormatter::LongTime;
00112
00113   // Scheduled tiles use the same tile templates as all other kinds of tiles.
00114   ITileWideText09^ tileContent = TileContentFactory::CreateTileWideText09();
00115   tileContent->TextHeading->Text = updateString;
00116   tileContent->TextBodyWrap->Text = "Received: " + time->Format(dueTime);
00117
00118   // Set up square tile content
00119   ITileSquareText04^ squareContent = TileContentFactory::CreateTileSquareText04();
00120   squareContent->TextBodyWrap->Text = updateString;
00121
00122   tileContent->SquareContent = squareContent;
00123
00124   // Create the notification object
00125   auto futureTile = ref new ScheduledTileNotification(tileContent->GetXml(), dueTime);
00126   futureTile->Id = "Tile" + idNumberString;
00127
00128   // Add to schedule
00129   // You can update a secondary tile in the same manner using CreateTileUpdaterForSecondaryTile(tileId)
00130   // See "Tiles" sample for more details
00131   TileUpdateManager::CreateTileUpdaterForApplication()->AddToSchedule(futureTile);
00132   rootPage->NotifyUser("Scheduled a tile with ID: " + futureTile->Id, NotifyType::StatusMessage);
00133 }
00134
00135 void ScenarioInput1::ScheduleToastWithStringManipulation(String^ updateString, DateTime dueTime, String^ idNumberString)
00136 {
00137   auto time = Windows::Globalization::DateTimeFormatting::DateTimeFormatter::LongTime;
00138
00139   // Scheduled toasts use the same toast templates as all other kinds of toasts.
00140   auto toastXmlString = "<toast>"
00141     + "<visual>"
00142     + "<binding template='ToastText02'>"
00143     + "<text id='2'>" + updateString + "</text>"
00144     + "<text id='1'>" + "Received: " + time->Format(dueTime) + "</text>"
00145     + "</binding>"
00146     + "</visual>"
00147     + "</toast>";
00148
00149   auto toastDOM = ref new Windows::Data::Xml::Dom::XmlDocument();
00150   try
00151   {
00152     toastDOM->LoadXml(toastXmlString);
00153
00154     ScheduledToastNotification^ toast;
00155     if (RepeatBox->IsChecked->Value)
00156     {
00157       TimeSpan interval;
00158       interval.Duration = 60 * 10000000;
00159       toast = ref new ScheduledToastNotification(toastDOM, dueTime, interval, 5);
00160
00161       // You can specify an ID so that you can manage toasts later.
00162       // Make sure the ID is 15 characters or less.
00163       toast->Id = "Repeat" + idNumberString;
00164     }
00165     else
00166     {
00167       toast = ref new ScheduledToastNotification(toastDOM, dueTime);
00168       toast->Id = "Toast" + idNumberString;
00169     }
00170
00171     ToastNotificationManager::CreateToastNotifier()->AddToSchedule(toast);
00172     rootPage->NotifyUser("Scheduled a toast with ID: " + toast->Id, NotifyType::StatusMessage);
00173   }
00174   catch (Exception^)
00175   {
00176     rootPage->NotifyUser("Error loading the xml, check for invalid characters in the input", NotifyType::ErrorMessage);
00177   }
00178 }
00179
00180 void ScenarioInput1::ScheduleTileWithStringManipulation(String^ updateString, DateTime dueTime, String^ idNumberString)
00181 {
00182   auto time = Windows::Globalization::DateTimeFormatting::DateTimeFormatter::LongTime;
00183
00184   auto tileXmlString = "<tile>"
00185     + "<visual>"
00186     + "<binding template='TileWideText09'>"
00187     + "<text id='1'>" + updateString + "</text>"
00188     + "<text id='2'>" + "Received: " + time->Format(dueTime) + "</text>"
00189     + "</binding>"
00190     + "<binding template='TileSquareText04'>"
00191     + "<text id='1'>" + updateString + "</text>"
00192     + "</binding>"
00193     + "</visual>"
00194     + "</tile>";
00195
00196   auto tileDOM = ref new Windows::Data::Xml::Dom::XmlDocument();
00197   try
00198   {
00199     tileDOM->LoadXml(tileXmlString);
00200
00201     // Create the notification object
00202     auto futureTile = ref new ScheduledTileNotification(tileDOM, dueTime);
00203     futureTile->Id = "Tile" + idNumberString;
00204
00205     // Add to schedule
00206     // You can update a secondary tile in the same manner using CreateTileUpdaterForSecondaryTile(tileId)
00207     // See "Tiles" sample for more details
00208     TileUpdateManager::CreateTileUpdaterForApplication()->AddToSchedule(futureTile);
00209     rootPage->NotifyUser("Scheduled a tile with ID: " + futureTile->Id, NotifyType::StatusMessage);
00210   }
00211   catch (Exception^)
00212   {
00213     rootPage->NotifyUser("Error loading the xml, check for invalid characters in the input", NotifyType::ErrorMessage);
00214   }
00215 }
00216
00217 void ScenarioInput1::OnNavigatedTo(NavigationEventArgs^ e)
00218 {
00219   // Get a pointer to our main page.
00220   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00221 }
00222
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

PaperFragment Member List

This is the complete list of members for PaperFragment, including all inherited members.
__pad0__ | PaperFragment |
color | PaperFragment |
Draw() | PaperFragment |
GeneratePaperBitmap() | PaperFragment | [private]
GetExclusionWith(D2D1_POINT_2F point, ID2D1Geometry *pGeometry) | PaperFragment |
GetIntersectionWith(D2D1_POINT_2F point, ID2D1Geometry *pGeometry) | PaperFragment |
GetMergeWith(D2D1_POINT_2F point, ID2D1Geometry *pGeometry, D2D1_COMBINE_MODE mode) | PaperFragment | [private]
GetPosition() | PaperFragment |
HitTest(D2D1_POINT_2F point) | PaperFragment |
HitTestWithGeometry(D2D1_POINT_2F point, ID2D1Geometry *pGeometry) | PaperFragment |
m_bitmap | PaperFragment | [private]
m_bitmapOffset | PaperFragment | [private]
m_brush | PaperFragment | [private]
m_color | PaperFragment | [private]
m_d2dContext | PaperFragment | [private]
m_geometry | PaperFragment | [private]
m_position | PaperFragment | [private]
pGeometry | PaperFragment |
SetPosition(D2D1_POINT_2F position) | PaperFragment |
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/NotificationsExtensions/ToastContent.cs Source File

  • Lock screen apps
  • C#,C++
  • NotificationsExtensions

ToastContent.cs

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 using System;
00009 using System.Text;
00010 #if !WINRT_NOT_PRESENT
00011 using Windows.Data.Xml.Dom;
00012 using Windows.UI.Notifications;
00013 #endif
00014
00015 namespace NotificationsExtensions.ToastContent
00016 {
00017     internal sealed class ToastAudio : IToastAudio
00018     {
00019         internal ToastAudio() { }
00020
00021         public ToastAudioContent Content
00022         {
00023             get { return m_Content; }
00024             set
00025             {
00026                 if (!Enum.IsDefined(typeof(ToastAudioContent), value))
00027                 {
00028                     throw new ArgumentOutOfRangeException("value");
00029                 }
00030                 m_Content = value;
00031             }
00032         }
00033
00034         public bool Loop
00035         {
00036             get { return m_Loop; }
00037             set { m_Loop = value; }
00038         }
00039
00040         private ToastAudioContent m_Content = ToastAudioContent.Default;
00041         private bool m_Loop = false;
00042     }
00043
00044     internal class ToastNotificationBase : NotificationBase, IToastNotificationContent
00045     {
00046         public ToastNotificationBase(string templateName, int imageCount, int textCount) : base(templateName, imageCount, textCount)
00047         {
00048         }
00049
00050         private bool AudioSrcIsLooping()
00051         {
00052             return (Audio.Content == ToastAudioContent.LoopingAlarm) || (Audio.Content == ToastAudioContent.LoopingAlarm2) ||
00053                 (Audio.Content == ToastAudioContent.LoopingCall) || (Audio.Content == ToastAudioContent.LoopingCall2);
00054         }
00055
00056         private void ValidateAudio()
00057         {
00058             if (StrictValidation)
00059             {
00060                 if (Audio.Loop && Duration != ToastDuration.Long)
00061                 {
00062                     throw new NotificationContentValidationException("Looping audio is only available for long duration toasts.");
00063                 }
00064                 if (Audio.Loop && !AudioSrcIsLooping())
00065                 {
00066                     throw new NotificationContentValidationException(
00067                         "A looping audio src must be chosen if the looping audio property is set.");
00068                 }
00069                 if (!Audio.Loop && AudioSrcIsLooping())
00070                 {
00071                     throw new NotificationContentValidationException(
00072                         "The looping audio property needs to be set if a looping audio src is chosen.");
00073                 }
00074             }
00075         }
00076
00077         private void AppendAudioTag(StringBuilder builder)
00078         {
00079             if (Audio.Content != ToastAudioContent.Default)
00080             {
00081                 builder.Append("<audio");
00082                 if (Audio.Content == ToastAudioContent.Silent)
00083                 {
00084                     builder.Append(" silent='true'/>");
00085                 }
00086                 else
00087                 {
00088                     if (Audio.Loop == true)
00089                     {
00090                         builder.Append(" loop='true'");
00091                     }
00092
00093                     // The default looping sound is LoopingCall - save size by not adding it
00094                     if (Audio.Content != ToastAudioContent.LoopingCall)
00095                     {
00096                         string audioSrc = null;
00097                         switch (Audio.Content)
00098                         {
00099                             case ToastAudioContent.IM:
00100                                 audioSrc = "ms-winsoundevent:Notification.IM";
00101                                 break;
00102                             case ToastAudioContent.Mail:
00103                                 audioSrc = "ms-winsoundevent:Notification.Mail";
00104                                 break;
00105                             case ToastAudioContent.Reminder:
00106                                 audioSrc = "ms-winsoundevent:Notification.Reminder";
00107                                 break;
00108                             case ToastAudioContent.SMS:
00109                                 audioSrc = "ms-winsoundevent:Notification.SMS";
00110                                 break;
00111                             case ToastAudioContent.LoopingAlarm:
00112                                 audioSrc = "ms-winsoundevent:Notification.Looping.Alarm";
00113                                 break;
00114                             case ToastAudioContent.LoopingAlarm2:
00115                                 audioSrc = "ms-winsoundevent:Notification.Looping.Alarm2";
00116                                 break;
00117                             case ToastAudioContent.LoopingCall:
00118                                 audioSrc = "ms-winsoundevent:Notification.Looping.Call";
00119                                 break;
00120                             case ToastAudioContent.LoopingCall2:
00121                                 audioSrc = "ms-winsoundevent:Notification.Looping.Call2";
00122                                 break;
00123                         }
00124                         builder.AppendFormat(" src='{0}'", audioSrc);
00125                     }
00126                 }
00127                 builder.Append("/>");
00128             }
00129         }
00130
00131         public override string GetContent()
00132         {
00133             ValidateAudio();
00134
00135             StringBuilder builder = new StringBuilder("<toast");
00136             if (!String.IsNullOrEmpty(Launch))
00137             {
00138                 builder.AppendFormat(" launch='{0}'", Util.HttpEncode(Launch));
00139             }
00140             if (Duration != ToastDuration.Short)
00141             {
00142                 builder.AppendFormat(" duration='{0}'", Duration.ToString().ToLowerInvariant());
00143             }
00144             builder.Append(">");
00145
00146             builder.AppendFormat("<visual version='{0}'", Util.NOTIFICATION_CONTENT_VERSION);
00147             if (!String.IsNullOrWhiteSpace(Lang))
00148             {
00149                 builder.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
00150             }
00151             if (!String.IsNullOrWhiteSpace(BaseUri))
00152             {
00153                 builder.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
00154             }
00155             if (AddImageQuery)
00156             {
00157                 builder.AppendFormat(" addImageQuery='true'");
00158             }
00159             builder.Append(">");
00160
00161             builder.AppendFormat("<binding template='{0}'>{1}</binding>", TemplateName, SerializeProperties(Lang, BaseUri, AddImageQuery));
00162             builder.Append("</visual>");
00163
00164             AppendAudioTag(builder);
00165
00166             builder.Append("</toast>");
00167
00168             return builder.ToString();
00169         }
00170
00171 #if !WINRT_NOT_PRESENT
00172         public ToastNotification CreateNotification()
00173         {
00174             XmlDocument xmlDoc = new XmlDocument();
00175             xmlDoc.LoadXml(GetContent());
00176             return new ToastNotification(xmlDoc);
00177         }
00178 #endif
00179
00180         public IToastAudio Audio
00181         {
00182             get { return m_Audio; }
00183         }
00184
00185         public string Launch
00186         {
00187             get { return m_Launch; }
00188             set { m_Launch = value; }
00189         }
00190
00191         public ToastDuration Duration
00192         {
00193             get { return m_Duration; }
00194             set
00195             {
00196                 if (!Enum.IsDefined(typeof(ToastDuration), value))
00197                 {
00198                     throw new ArgumentOutOfRangeException("value");
00199                 }
00200                 m_Duration = value;
00201             }
00202         }
00203
00204         private string m_Launch;
00205         private IToastAudio m_Audio = new ToastAudio();
00206         private ToastDuration m_Duration = ToastDuration.Short;
00207     }
00208
00209     internal class ToastImageAndText01 : ToastNotificationBase, IToastImageAndText01
00210     {
00211         public ToastImageAndText01() : base(templateName: "ToastImageAndText01", imageCount: 1, textCount: 1)
00212         {
00213         }
00214
00215         public INotificationContentImage Image { get { return Images[0]; } }
00216
00217         public INotificationContentText TextBodyWrap { get { return TextFields[0]; } }
00218     }
00219
00220     internal class ToastImageAndText02 : ToastNotificationBase, IToastImageAndText02
00221     {
00222         public ToastImageAndText02() : base(templateName: "ToastImageAndText02", imageCount: 1, textCount: 2)
00223         {
00224         }
00225
00226         public INotificationContentImage Image { get { return Images[0]; } }
00227
00228         public INotificationContentText TextHeading { get { return TextFields[0]; } }
00229         public INotificationContentText TextBodyWrap { get { return TextFields[1]; } }
00230     }
00231
00232     internal class ToastImageAndText03 : ToastNotificationBase, IToastImageAndText03
00233     {
00234         public ToastImageAndText03() : base(templateName: "ToastImageAndText03", imageCount: 1, textCount: 2)
00235         {
00236         }
00237
00238         public INotificationContentImage Image { get { return Images[0]; } }
00239
00240         public INotificationContentText TextHeadingWrap { get { return TextFields[0]; } }
00241         public INotificationContentText TextBody { get { return TextFields[1]; } }
00242     }
00243
00244     internal class ToastImageAndText04 : ToastNotificationBase, IToastImageAndText04
00245     {
00246         public ToastImageAndText04() : base(templateName: "ToastImageAndText04", imageCount: 1, textCount: 3)
00247         {
00248         }
00249
00250         public INotificationContentImage Image { get { return Images[0]; } }
00251
00252         public INotificationContentText TextHeading { get { return TextFields[0]; } }
00253         public INotificationContentText TextBody1 { get { return TextFields[1]; } }
00254         public INotificationContentText TextBody2 { get { return TextFields[2]; } }
00255     }
00256
00257     internal class ToastText01 : ToastNotificationBase, IToastText01
00258     {
00259         public ToastText01() : base(templateName: "ToastText01", imageCount: 0, textCount: 1)
00260         {
00261         }
00262
00263         public INotificationContentText TextBodyWrap { get { return TextFields[0]; } }
00264     }
00265
00266     internal class ToastText02 : ToastNotificationBase, IToastText02
00267     {
00268         public ToastText02() : base(templateName: "ToastText02", imageCount: 0, textCount: 2)
00269         {
00270         }
00271
00272         public INotificationContentText TextHeading { get { return TextFields[0]; } }
00273         public INotificationContentText TextBodyWrap { get { return TextFields[1]; } }
00274     }
00275
00276     internal class ToastText03 : ToastNotificationBase, IToastText03
00277     {
00278         public ToastText03() : base(templateName: "ToastText03", imageCount: 0, textCount: 2)
00279         {
00280         }
00281
00282         public INotificationContentText TextHeadingWrap { get { return TextFields[0]; } }
00283         public INotificationContentText TextBody { get { return TextFields[1]; } }
00284     }
00285
00286     internal class ToastText04 : ToastNotificationBase, IToastText04
00287     {
00288         public ToastText04() : base(templateName: "ToastText04", imageCount: 0, textCount: 3)
00289         {
00290         }
00291
00292         public INotificationContentText TextHeading { get { return TextFields[0]; } }
00293         public INotificationContentText TextBody1 { get { return TextFields[1]; } }
00294         public INotificationContentText TextBody2 { get { return TextFields[2]; } }
00295     }
00296
00297     /// <summary>
00298     /// A factory which creates toast content objects for all of the toast template types.
00299     /// </summary>
00300     public static class ToastContentFactory
00301     {
00302         /// <summary>
00303         /// Creates a ToastImageAndText01 template content object.
00304         /// </summary>
00305         /// <returns>A ToastImageAndText01 template content object.</returns>
00306         public static IToastImageAndText01 CreateToastImageAndText01()
00307         {
00308             return new ToastImageAndText01();
00309         }
00310
00311         /// <summary>
00312         /// Creates a ToastImageAndText02 template content object.
00313         /// </summary>
00314         /// <returns>A ToastImageAndText02 template content object.</returns>
00315         public static IToastImageAndText02 CreateToastImageAndText02()
00316         {
00317             return new ToastImageAndText02();
00318         }
00319
00320         /// <summary>
00321         /// Creates a ToastImageAndText03 template content object.
00322         /// </summary>
00323         /// <returns>A ToastImageAndText03 template content object.</returns>
00324         public static IToastImageAndText03 CreateToastImageAndText03()
00325         {
00326             return new ToastImageAndText03();
00327         }
00328
00329         /// <summary>
00330         /// Creates a ToastImageAndText04 template content object.
00331         /// </summary>
00332         /// <returns>A ToastImageAndText04 template content object.</returns>
00333         public static IToastImageAndText04 CreateToastImageAndText04()
00334         {
00335             return new ToastImageAndText04();
00336         }
00337
00338         /// <summary>
00339         /// Creates a ToastText01 template content object.
00340         /// </summary>
00341         /// <returns>A ToastText01 template content object.</returns>
00342         public static IToastText01 CreateToastText01()
00343         {
00344             return new ToastText01();
00345         }
00346
00347         /// <summary>
00348         /// Creates a ToastText02 template content object.
00349         /// </summary>
00350         /// <returns>A ToastText02 template content object.</returns>
00351         public static IToastText02 CreateToastText02()
00352         {
00353             return new ToastText02();
00354         }
00355
00356         /// <summary>
00357         /// Creates a ToastText03 template content object.
00358         /// </summary>
00359         /// <returns>A ToastText03 template content object.</returns>
00360         public static IToastText03 CreateToastText03()
00361         {
00362             return new ToastText03();
00363         }
00364
00365         /// <summary>
00366         /// Creates a ToastText04 template content object.
00367         /// </summary>
00368         /// <returns>A ToastText04 template content object.</returns>
00369         public static IToastText04 CreateToastText04()
00370         {
00371             return new ToastText04();
00372         }
00373     }
00374 }
Generated on Sat Nov 23 2024 16:08:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/RequestResponse.xaml.h Source File

  • USSD message management

RequestResponse.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // RequestResponse.xaml.h
00013 // Declaration of the RequestResponse class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "RequestResponse.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace UssdApi
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class RequestResponse sealed
00031         {
00032         public:
00033             RequestResponse();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void SendButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IYearGroup.h Source File

  • Hilo C++
  • Hilo

IYearGroup.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     interface class IMonthBlock;
00012
00013     // The IYearGroup class defines the signature of data used by the image
00014     // browser's zoomed-out view of the user's picture library. XAML controls
00015     // bind to objects of this type.
00016     public interface class IYearGroup
00017     {
00018         property Platform::String^ Title
00019         {
00020             Platform::String^ get();
00021         }
00022
00023         property int Year
00024         {
00025             int get();
00026         }
00027
00028         property Windows::Foundation::Collections::IObservableVector<IMonthBlock^>^ Items
00029         {
00030             Windows::Foundation::Collections::IObservableVector<IMonthBlock^>^ get();
00031         }
00032     };
00033 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/SettingContainer.xaml.h Source File

  • Application data

SettingContainer.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SettingContainer.xaml.h
00013 // Declaration of the SettingContainer class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SettingContainer.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ApplicationDataSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class SettingContainer sealed
00031         {
00032         public:
00033             SettingContainer();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             Windows::Storage::ApplicationDataContainer^ localSettings;
00040
00041             void CreateContainer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042             void DeleteContainer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void WriteSetting_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044             void DeleteSetting_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045             void DisplayOutput();
00046         };
00047     }
00048 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/SplitPage.xaml.h Source File

  • Getting started with C++ simple blog reader

SplitPage.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 //
00009 // SplitPage.xaml.h
00010 // Declaration of the SplitPage class
00011 //
00012
00013 #pragma once
00014
00015 #include "Common\LayoutAwarePage.h" // Required by generated header
00016 #include "SplitPage.g.h"
00017
00018 namespace SimpleBlogReader
00019 {
00020     /// <summary>
00021     /// A page that displays a group title, a list of items within the group, and details for the
00022     /// currently selected item.
00023     /// </summary>
00024     [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class SplitPage sealed
00026     {
00027     public:
00028         SplitPage();
00029
00030     protected:
00031         virtual void LoadState(Platform::Object^ navigationParameter,
00032         Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00033         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00034         virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e) override;
00035         virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState) override;
00036         void ViewDetail_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037
00038     private:
00039         void ItemListView_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00040         bool UsingLogicalPageNavigation();
00041         bool UsingLogicalPageNavigation(Windows::UI::ViewManagement::ApplicationViewState viewState);
00042
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/main.cpp Source File

  • Media engine native C++ video playback

main.cpp

Go to the documentation of this file.
00001 #include "pch.h"
00002 #include "FrameworkView.h"
00003
00004 [Platform::MTAThread]
00005 int __cdecl main(Platform::Array<Platform::String^>^)
00006 {
00007     auto frameworkView = ref new FrameworkViewSource();
00008     Windows::ApplicationModel::Core::CoreApplication::Run(frameworkView);
00009 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaExtensionsCS::ScenarioOutput4 Member List

This is the complete list of members for MediaExtensionsCS::ScenarioOutput4, including all inherited members.
__pad0__ | Element |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Page | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) | Element | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
OnNavigatedFrom(NavigationEventArgs e) | MediaExtensionsCS::ScenarioOutput4 | [inline, protected]
OnNavigatedTo(NavigationEventArgs e) | MediaExtensionsCS::ScenarioOutput4 | [inline, protected]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
rootPage | MediaExtensionsCS::ScenarioOutput4 | [private]
ScenarioOutput4() | MediaExtensionsCS::ScenarioOutput4 | [inline]
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/GeometryRealizationSample.cpp Source File

  • Direct2D geometry realization

GeometryRealizationSample.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "GeometryRealizationSample.h"
00010
00011 using namespace D2D1;
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::ApplicationModel;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::ApplicationModel::Core;
00016 using namespace Windows::Foundation;
00017 using namespace Windows::Foundation::Collections;
00018 using namespace Windows::Graphics::Display;
00019 using namespace Windows::UI::Core;
00020 using namespace Windows::UI::Input;
00021 using namespace Windows::UI::Popups;
00022 using namespace Windows::Storage;
00023 using namespace Windows::System;
00024
00025 static const UINT sc_minNumSquares = 1;
00026 static const UINT sc_maxNumSquares = 1024;
00027
00028 static const D2D1_RECT_F textInfoBox = { 10, 100, 350, 300 };
00029 static const float textInfoBoxInset = 10;
00030
00031 static const uint32 defaultNumberOfSquares = 16;
00032 static const uint32 minNumberOfSquares = 1;
00033 static const uint32 maxNumberOfSquares = 1024;
00034
00035 static const float rotationSpeed = 3.0f;
00036
00037 static const float loupeInset = 20.0f;
00038
00039 static const float strokeWidth = 1.0f;
00040
00041 // This determines that maximum texture size we will
00042 // generate for our realizations.
00043 static const uint32 maxRealizationDimension = 2000;
00044
00045 GeometryRealizationSample::GeometryRealizationSample()
00046 {
00047     m_antialiasMode = D2D1_ANTIALIAS_MODE_ALIASED;
00048     m_useRealizations = false;
00049     m_updateRealization = true;
00050     m_updateDisplayText = true;
00051     m_drawStroke = true;
00052     m_paused = false;
00053     m_pausedTime = 0;
00054     m_numberOfSquares = defaultNumberOfSquares;
00055
00056     LARGE_INTEGER time;
00057     QueryPerformanceCounter(&time);
00058
00059     m_timeDelta = -time.QuadPart;
00060     m_windowClosed = false;
00061     m_windowVisible = true;
00062 }
00063
00064 void GeometryRealizationSample::CreateDeviceIndependentResources()
00065 {
00066     DirectXBase::CreateDeviceIndependentResources();
00067
00068     // Create a DirectWrite text format object.
00069     DX::ThrowIfFailed(
00070         m_dwriteFactory->CreateTextFormat(
00071         L"Segoe UI",
00072         nullptr,
00073         DWRITE_FONT_WEIGHT_LIGHT,
00074         DWRITE_FONT_STYLE_NORMAL,
00075         DWRITE_FONT_STRETCH_NORMAL,
00076         20.0f,
00077         L"en-US", // locale
00078         &m_textFormat
00079         )
00080         );
00081 }
00082
00083 void GeometryRealizationSample::CreateDeviceResources()
00084 {
00085     // DirectXBase creates a Direct2D device context that enables multithreaded optimizations.
00086     DirectXBase::CreateDeviceResources();
00087
00088     m_sampleOverlay = ref new SampleOverlay();
00089
00090     m_sampleOverlay->Initialize(
00091         m_d2dDevice.Get(),
00092         m_d2dContext.Get(),
00093         m_wicFactory.Get(),
00094         m_dwriteFactory.Get(),
00095         "Direct2D geometry realization sample"
00096         );
00097
00098     DX::ThrowIfFailed(
00099         m_d2dContext->CreateSolidColorBrush(
00100             D2D1::ColorF(D2D1::ColorF::Black),
00101             &m_blackBrush
00102             )
00103         );
00104
00105     ComPtr<IGeometryRealizationFactory> realizationFactory;
00106     DX::ThrowIfFailed(
00107         m_d2dContext->CreateSolidColorBrush(
00108             D2D1::ColorF(D2D1::ColorF::White),
00109             &m_solidColorBrush
00110             )
00111         );
00112
00113     DX::ThrowIfFailed(
00114         CreateGeometryRealizationFactory(
00115             m_d2dContext.Get(),
00116             maxRealizationDimension,
00117             &realizationFactory
00118             )
00119         );
00120
00121     DX::ThrowIfFailed(
00122         realizationFactory->CreateGeometryRealization(&m_realization)
00123         );
00124
00125     m_updateRealization = true;
00126     m_displayText = nullptr;
00127 }
00128
00129 void GeometryRealizationSample::UpdateForWindowSizeChange()
00130 {
00131     DirectXBase::UpdateForWindowSizeChange();
00132     m_displayText = nullptr;
00133     m_updateDisplayText = true;
00134     DiscardGeometries();
00135     m_sampleOverlay->UpdateForWindowSizeChange();
00136 }
00137
00138 void GeometryRealizationSample::CreateGeometries()
00139 {
00140     if (!m_geometry)
00141     {
00142         ComPtr<IGeometryRealizationFactory> realizationFactory;
00143         ComPtr<IGeometryRealization> realization;
00144
00145         ComPtr<ID2D1TransformedGeometry>   geometry;
00146         ComPtr<ID2D1PathGeometry> pathGeometry;
00147         ComPtr<ID2D1GeometrySink> sink;
00148
00149         float boardWidth = m_d2dContext->GetSize().width;
00150         float squareWidth = 0.5f * boardWidth / m_numberOfSquares;
00151
00152         // Create the path geometry.
00153         DX::ThrowIfFailed(
00154             m_d2dFactory->CreatePathGeometry(&pathGeometry)
00155             );
00156
00157         DX::ThrowIfFailed(
00158             pathGeometry->Open(&sink)
00159             );
00160
00161         sink->SetFillMode(D2D1_FILL_MODE_ALTERNATE);
00162
00163         sink->BeginFigure(
00164             D2D1::Point2F(0, 0),
00165             D2D1_FIGURE_BEGIN_FILLED
00166             );
00167
00168         sink->AddLine(D2D1::Point2F(1.0f, 0));
00169
00170         sink->AddBezier(
00171             D2D1::BezierSegment(
00172                 D2D1::Point2F(0.75f, 0.25f),
00173                 D2D1::Point2F(0.75f, 0.75f),
00174                 D2D1::Point2F(1.0f, 1.0f)
00175                 )
00176             );
00177
00178         sink->AddLine(D2D1::Point2F(0, 1.0f));
00179
00180         sink->AddBezier(
00181             D2D1::BezierSegment(
00182                 D2D1::Point2F(0.25f, 0.75f),
00183                 D2D1::Point2F(0.25f, 0.25f),
00184                 D2D1::Point2F(0, 0)
00185                 )
00186             );
00187
00188         sink->EndFigure(D2D1_FIGURE_END_CLOSED);
00189
00190         DX::ThrowIfFailed(
00191             sink->Close()
00192             );
00193
00194         D2D1_MATRIX_3X2_F scale = D2D1::Matrix3x2F::Scale(squareWidth, squareWidth);
00195         D2D1_MATRIX_3X2_F translation = D2D1::Matrix3x2F::Translation(-squareWidth / 2, -squareWidth / 2);
00196
00197         DX::ThrowIfFailed(
00198             m_d2dFactory->CreateTransformedGeometry(
00199                 pathGeometry.Get(),
00200                 scale * translation,
00201                 &geometry
00202                 )
00203             );
00204         // Transfer the reference.
00205         m_geometry = geometry;
00206     }
00207 }
00208
00209 void GeometryRealizationSample::DiscardGeometries()
00210 {
00211     m_geometry = nullptr;
00212     m_updateRealization = true;
00213 }
00214
00215 void GeometryRealizationSample::RenderMainContent(float time)
00216 {
00217     static DWORD dwTimeStart = 0;
00218     static DWORD dwTimeLast = 0;
00219
00220     D2D1_SIZE_F rtSize = m_d2dContext->GetSize();
00221
00222     float boardWidth = rtSize.width * 0.5f;
00223     float squareWidth = boardWidth / m_numberOfSquares;
00224
00225     m_d2dContext->SetAntialiasMode(m_antialiasMode);
00226
00227     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));
00228
00229     D2D1_MATRIX_3X2_F currentTransform;
00230
00231     m_d2dContext->GetTransform(&currentTransform);
00232
00233     D2D1_MATRIX_3X2_F worldTransform =
00234         D2D1::Matrix3x2F::Translation(
00235             0.5f * (rtSize.width - squareWidth * m_numberOfSquares),
00236             0.5f * (rtSize.height - squareWidth * m_numberOfSquares)
00237             ) * currentTransform;
00238
00239     for (uint32 i = 0; i < m_numberOfSquares; ++i)
00240     {
00241         for (uint32 j = 0; j < m_numberOfSquares; ++j)
00242         {
00243             float dx = i + 0.5f - 0.5f * m_numberOfSquares;
00244             float dy = j + 0.5f - 0.5f * m_numberOfSquares;
00245
00246             float length = sqrtf(2) * m_numberOfSquares;
00247
00248             // The intensity variable determines the color and speed of rotation of the
00249             // realization instance. We choose a function that is rotationally
00250             // symmetric about the center of the grid, which produces a nice effect.
00251             float intensity =
00252                 0.5f * (1 + sinf((0.2f * time + 10.0f * sqrtf(static_cast<float>(dx * dx + dy * dy)) / length)));
00253
00254             D2D1_MATRIX_3X2_F rotateTransform =
00255                 D2D1::Matrix3x2F::Rotation(
00256                     (intensity * rotationSpeed * time * 360.0f) * ((float) M_PI / 180.0f)
00257                     );
00258
00259             D2D1_MATRIX_3X2_F newWorldTransform =
00260                 rotateTransform *
00261                 D2D1::Matrix3x2F::Translation(
00262                     (i + 0.5f) * squareWidth,
00263                     (j + 0.5f) * squareWidth
00264                     ) * worldTransform;
00265
00266             if (m_updateRealization)
00267             {
00268                 DX::ThrowIfFailed(
00269                     m_realization->Update(
00270                         m_geometry.Get(),
00271                         static_cast<REALIZATION_CREATION_OPTIONS>(
00272                             REALIZATION_CREATION_OPTIONS_ANTI_ALIASED |
00273                             REALIZATION_CREATION_OPTIONS_ALIASED |
00274                             REALIZATION_CREATION_OPTIONS_FILLED |
00275                             REALIZATION_CREATION_OPTIONS_STROKED |
00276                             REALIZATION_CREATION_OPTIONS_UNREALIZED
00277                             ),
00278                         &newWorldTransform,
00279                         strokeWidth,
00280                         nullptr // pIStrokeStyle
00281                         )
00282                     );
00283
00284                 m_updateRealization = false;
00285             }
00286
00287             m_d2dContext->SetTransform(newWorldTransform);
00288             m_solidColorBrush->SetColor(
00289                 D2D1::ColorF(0.0f, intensity, 1.0f - intensity)
00290                 );
00291
00292             DX::ThrowIfFailed(
00293                 m_realization->Fill(
00294                     m_d2dContext.Get(),
00295                     m_solidColorBrush.Get(),
00296                     m_useRealizations ?
00297                         REALIZATION_RENDER_MODE_DEFAULT :
00298                         REALIZATION_RENDER_MODE_FORCE_UNREALIZED
00299                     )
00300                 );
00301
00302             if (m_drawStroke)
00303             {
00304                 m_solidColorBrush->SetColor(D2D1::ColorF(D2D1::ColorF::White));
00305
00306                 DX::ThrowIfFailed(
00307                     m_realization->Draw(
00308                         m_d2dContext.Get(),
00309                         m_solidColorBrush.Get(),
00310                         m_useRealizations ?
00311                             REALIZATION_RENDER_MODE_DEFAULT :
00312                             REALIZATION_RENDER_MODE_FORCE_UNREALIZED
00313                         )
00314                     );
00315             }
00316         }
00317     }
00318 }
00319
00320 void GeometryRealizationSample::Render()
00321 {
00322     LARGE_INTEGER time;
00323     LARGE_INTEGER frequency;
00324     QueryPerformanceCounter(&time);
00325     QueryPerformanceFrequency(&frequency);
00326
00327     float floatTime;
00328
00329     if (!m_paused)
00330     {
00331         floatTime = static_cast<float>(time.QuadPart + m_timeDelta) / static_cast<float>(frequency.QuadPart);
00332     }
00333     else
00334     {
00335         floatTime = static_cast<float>(m_pausedTime + m_timeDelta) / static_cast<float>(frequency.QuadPart);
00336     }
00337
00338     m_d2dContext->BeginDraw();
00339
00340     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00341     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00342
00343     CreateGeometries();
00344     RenderMainContent(floatTime);
00345
00346     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00347
00348     if (m_updateDisplayText)
00349     {
00350         UpdateDisplayText();
00351     }
00352     m_displayText->Render();
00353
00354     HRESULT hr = m_d2dContext->EndDraw();
00355     if (hr != D2DERR_RECREATE_TARGET)
00356     {
00357         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00358         // is lost. It will be handled during the next call to Present.
00359         DX::ThrowIfFailed(hr);
00360     }
00361
00362     m_sampleOverlay->Render();
00363 }
00364
00365 void GeometryRealizationSample::UpdateDisplayText()
00366 {
00367     WCHAR textBuffer[400];
00368     LARGE_INTEGER frequency;
00369
00370     QueryPerformanceFrequency(&frequency);
00371
00372     uint32 numPrimitives = m_numberOfSquares * m_numberOfSquares;
00373
00374     if (m_drawStroke)
00375     {
00376         numPrimitives *= 2;
00377     }
00378
00379     StringCchPrintf(
00380         textBuffer,
00381         400,
00382         L"%s\n"
00383         L"%s\n"
00384         L"# primitives: %d x %d %s = %d\n"
00385         L"Fps: ",
00386         m_antialiasMode == D2D1_ANTIALIAS_MODE_ALIASED ? L"Aliased" : L"PerPrimitive",
00387         m_useRealizations ? L"Realized"  : L"Unrealized",
00388         m_numberOfSquares,
00389         m_numberOfSquares,
00390         m_drawStroke ? L" x 2" : L"",
00391         numPrimitives
00392         );
00393
00394     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00395
00396     m_solidColorBrush->SetColor(D2D1::ColorF(D2D1::ColorF::White));
00397
00398     m_displayText = ref new FPSCounter(
00399         m_d2dContext.Get(),
00400         m_dpi,
00401         ref new Platform::String(textBuffer),
00402         m_textFormat.Get(),
00403         D2D1::Point2F(
00404             textInfoBox.left + textInfoBoxInset,
00405             textInfoBox.top + textInfoBoxInset
00406             )
00407         );
00408     m_displayText->Initialize();
00409
00410     m_updateDisplayText = false;
00411 }
00412
00413 void GeometryRealizationSample::ShowMenu(Point position)
00414 {
00415     PopupMenu^ popupMenu = ref new PopupMenu();
00416     popupMenu->Commands->Append(
00417         ref new UICommand("Toggle Antialiasing",
00418         ref new UICommandInvokedHandler(this, &GeometryRealizationSample::UpdateGeometryRendering))
00419         );
00420
00421     popupMenu->Commands->Append(
00422         ref new UICommand("Toggle Realization",
00423         ref new UICommandInvokedHandler(this, &GeometryRealizationSample::UpdateGeometryRendering))
00424         );
00425
00426     popupMenu->Commands->Append(
00427         ref new UICommand("Toggle Stroking",
00428         ref new UICommandInvokedHandler(this, &GeometryRealizationSample::UpdateGeometryRendering))
00429         );
00430
00431     popupMenu->Commands->Append(
00432         ref new UICommand("Increase Primitives",
00433         ref new UICommandInvokedHandler(this, &GeometryRealizationSample::UpdateGeometryRendering))
00434         );
00435
00436     popupMenu->Commands->Append(
00437         ref new UICommand("Decrease Primitives",
00438         ref new UICommandInvokedHandler(this, &GeometryRealizationSample::UpdateGeometryRendering))
00439         );
00440
00441     popupMenu->Commands->Append(
00442         ref new UICommand("Toggle Animation",
00443         ref new UICommandInvokedHandler(this, &GeometryRealizationSample::UpdateGeometryRendering))
00444         );
00445
00446     popupMenu->ShowAsync(position);
00447 }
00448
00449 void GeometryRealizationSample::UpdateGeometryRendering(IUICommand^ command)
00450 {
00451     if (command->Label == "Toggle Antialiasing")
00452     {
00453         m_antialiasMode =
00454             (m_antialiasMode == D2D1_ANTIALIAS_MODE_ALIASED) ?
00455                 D2D1_ANTIALIAS_MODE_PER_PRIMITIVE :
00456                 D2D1_ANTIALIAS_MODE_ALIASED;
00457         m_updateDisplayText = true;
00458     }
00459     else if (command->Label == "Toggle Realization")
00460     {
00461         m_useRealizations = !m_useRealizations;
00462         m_updateDisplayText = true;
00463     }
00464     else if (command->Label == "Toggle Stroking")
00465     {
00466         m_drawStroke = !m_drawStroke;
00467         m_updateDisplayText = true;
00468     }
00469     else if (command->Label == "Increase Primitives")
00470     {
00471         m_numberOfSquares = min(m_numberOfSquares * 2, maxNumberOfSquares);
00472         m_updateDisplayText = true;
00473         DiscardGeometries();
00474     }
00475     else if (command->Label == "Decrease Primitives")
00476     {
00477         m_numberOfSquares = max(m_numberOfSquares / 2, minNumberOfSquares);
00478         m_updateDisplayText = true;
00479         DiscardGeometries();
00480     }
00481     else if (command->Label == "Toggle Animation")
00482     {
00483         LARGE_INTEGER time;
00484         QueryPerformanceCounter(&time);
00485
00486         if (!m_paused)
00487         {
00488             m_pausedTime = time.QuadPart;
00489         }
00490         else
00491         {
00492             m_timeDelta += m_pausedTime - time.QuadPart;
00493         }
00494
00495         m_paused = !m_paused;
00496         m_updateRealization = true;
00497     }
00498 }
00499
00500 void GeometryRealizationSample::Initialize(
00501     _In_ CoreApplicationView^ applicationView
00502     )
00503 {
00504     applicationView->Activated +=
00505         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &GeometryRealizationSample::OnActivated);
00506
00507     CoreApplication::Suspending +=
00508         ref new EventHandler<SuspendingEventArgs^>(this, &GeometryRealizationSample::OnSuspending);
00509
00510     CoreApplication::Resuming +=
00511         ref new EventHandler<Platform::Object^>(this, &GeometryRealizationSample::OnResuming);
00512 }
00513
00514 void GeometryRealizationSample::SetWindow(
00515     _In_ CoreWindow^ window
00516     )
00517 {
00518     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00519
00520     window->SizeChanged +=
00521         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &GeometryRealizationSample::OnWindowSizeChanged);
00522
00523     window->VisibilityChanged +=
00524         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &GeometryRealizationSample::OnVisibilityChanged);
00525
00526     window->PointerMoved +=
00527         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &GeometryRealizationSample::OnPointerMoved);
00528
00529     window->PointerPressed +=
00530         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &GeometryRealizationSample::OnPointerPressed);
00531
00532     window->PointerReleased +=
00533         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &GeometryRealizationSample::OnPointerReleased);
00534
00535     window->Closed +=
00536         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &GeometryRealizationSample::OnWindowClosed);
00537
00538     DisplayProperties::LogicalDpiChanged +=
00539         ref new DisplayPropertiesEventHandler(this, &GeometryRealizationSample::OnLogicalDpiChanged);
00540
00541     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00542
00543     m_gestureRecognizer = ref new GestureRecognizer();
00544
00545     m_gestureRecognizer->GestureSettings = GestureSettings::Hold;
00546
00547     m_gestureRecognizer->Holding +=
00548         ref new TypedEventHandler<GestureRecognizer^, HoldingEventArgs^>(this, &GeometryRealizationSample::OnHolding);
00549 }
00550
00551 void GeometryRealizationSample::Load(
00552     _In_ Platform::String^ entryPoint
00553     )
00554 {
00555     // Retrieve any stored variables from the LocalSettings collection.
00556     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00557
00558     if (settingsValues->HasKey("m_antialiasMode"))
00559     {
00560         m_antialiasMode = static_cast<D2D1_ANTIALIAS_MODE>(
00561             safe_cast<IPropertyValue^>(settingsValues->Lookup("m_antialiasMode"))->GetInt32()
00562             );
00563     }
00564
00565     if (settingsValues->HasKey("m_useRealizations"))
00566     {
00567         m_useRealizations = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_useRealizations"))->GetBoolean();
00568     }
00569
00570     if (settingsValues->HasKey("m_drawStroke"))
00571     {
00572         m_drawStroke = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_drawStroke"))->GetBoolean();
00573     }
00574
00575     if (settingsValues->HasKey("m_numberOfSquares"))
00576     {
00577         m_numberOfSquares = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_numberOfSquares"))->GetUInt32();
00578     }
00579
00580     if (settingsValues->HasKey("m_paused"))
00581     {
00582         m_paused = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_paused"))->GetBoolean();
00583     }
00584
00585     if (settingsValues->HasKey("m_pausedTime"))
00586     {
00587         m_pausedTime = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_pausedTime"))->GetInt64();
00588     }
00589
00590     if (settingsValues->HasKey("m_timeDelta"))
00591     {
00592         m_timeDelta = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_timeDelta"))->GetInt64();
00593     }
00594 }
00595
00596 void GeometryRealizationSample::Run()
00597 {
00598     while (!m_windowClosed)
00599     {
00600         if (m_windowVisible)
00601         {
00602             m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00603             Render();
00604             Present(); // This call is synchronized to the display frame rate.
00605         }
00606         else
00607         {
00608             m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00609         }
00610     }
00611 }
00612
00613 void GeometryRealizationSample::Uninitialize()
00614 {
00615 }
00616
00617 void GeometryRealizationSample::OnWindowSizeChanged(
00618     _In_ CoreWindow^ sender,
00619     _In_ WindowSizeChangedEventArgs^ args
00620     )
00621 {
00622     UpdateForWindowSizeChange();
00623     Render();
00624     Present();
00625 }
00626
00627 void GeometryRealizationSample::OnVisibilityChanged(
00628     _In_ CoreWindow^ sender,
00629     _In_ VisibilityChangedEventArgs^ args
00630     )
00631 {
00632     m_windowVisible = args->Visible;
00633 }
00634
00635 void GeometryRealizationSample::OnLogicalDpiChanged(
00636     _In_ Platform::Object^ sender
00637     )
00638 {
00639     SetDpi(DisplayProperties::LogicalDpi);
00640     DiscardGeometries();
00641     Render();
00642     Present();
00643 }
00644
00645 void GeometryRealizationSample::OnActivated(
00646     _In_ CoreApplicationView^ applicationView,
00647     _In_ IActivatedEventArgs^ args
00648     )
00649 {
00650     m_window->Activate();
00651 }
00652
00653 void GeometryRealizationSample::OnSuspending(
00654     _In_ Platform::Object^ sender,
00655     _In_ SuspendingEventArgs^ args
00656     )
00657 {
00658     // Store variables in the LocalSettings collection.
00659     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00660
00661     // Check to ensure each key is not already in the collection. If it is present, remove
00662     // it before inserting the new value. These values will be retrieved in the Load method.
00663
00664     if (settingsValues->HasKey("m_antialiasMode"))
00665     {
00666         settingsValues->Remove("m_antialiasMode");
00667     }
00668     settingsValues->Insert("m_antialiasMode", PropertyValue::CreateInt32(m_antialiasMode));
00669
00670     if (settingsValues->HasKey("m_useRealizations"))
00671     {
00672         settingsValues->Remove("m_useRealizations");
00673     }
00674     settingsValues->Insert("m_useRealizations", PropertyValue::CreateBoolean(m_useRealizations));
00675
00676     if (settingsValues->HasKey("m_drawStroke"))
00677     {
00678         settingsValues->Remove("m_drawStroke");
00679     }
00680     settingsValues->Insert("m_drawStroke", PropertyValue::CreateBoolean(m_drawStroke));
00681
00682     if (settingsValues->HasKey("m_numberOfSquares"))
00683     {
00684         settingsValues->Remove("m_numberOfSquares");
00685     }
00686     settingsValues->Insert("m_numberOfSquares", PropertyValue::CreateUInt32(m_numberOfSquares));
00687
00688     if (settingsValues->HasKey("m_paused"))
00689     {
00690         settingsValues->Remove("m_paused");
00691     }
00692     settingsValues->Insert("m_paused", PropertyValue::CreateBoolean(m_paused));
00693
00694     if (settingsValues->HasKey("m_pausedTime"))
00695     {
00696         settingsValues->Remove("m_pausedTime");
00697     }
00698     settingsValues->Insert("m_pausedTime", PropertyValue::CreateInt64(m_pausedTime));
00699
00700     if (settingsValues->HasKey("m_timeDelta"))
00701     {
00702         settingsValues->Remove("m_timeDelta");
00703     }
00704     settingsValues->Insert("m_timeDelta", PropertyValue::CreateInt64(m_timeDelta));
00705 }
00706
00707 void GeometryRealizationSample::OnResuming(
00708     _In_ Platform::Object^ sender,
00709     _In_ Platform::Object^ args
00710     )
00711 {
00712 }
00713
00714 void GeometryRealizationSample::OnWindowClosed(
00715     _In_ CoreWindow^ sender,
00716     _In_ CoreWindowEventArgs^ args
00717     )
00718 {
00719     m_windowClosed = true;
00720 }
00721
00722 void GeometryRealizationSample::OnPointerMoved(
00723     _In_ CoreWindow^ window,
00724     _In_ PointerEventArgs^ args
00725     )
00726 {
00727     m_gestureRecognizer->ProcessMoveEvents(args->GetIntermediatePoints());
00728 }
00729
00730 void GeometryRealizationSample::OnPointerPressed(
00731     _In_ CoreWindow^ window,
00732     _In_ PointerEventArgs^ args
00733     )
00734 {
00735     m_gestureRecognizer->ProcessDownEvent(args->CurrentPoint);
00736 }
00737
00738 void GeometryRealizationSample::OnPointerReleased(
00739     _In_ CoreWindow^ window,
00740     _In_ PointerEventArgs^ args
00741     )
00742 {
00743     m_gestureRecognizer->ProcessUpEvent(args->CurrentPoint);
00744
00745     if (args->CurrentPoint->Properties->PointerUpdateKind == PointerUpdateKind::RightButtonReleased)
00746     {
00747         ShowMenu(args->CurrentPoint->Position);
00748     }
00749 }
00750
00751 void GeometryRealizationSample::OnHolding(
00752     _In_ GestureRecognizer^ recognizer,
00753     _In_ HoldingEventArgs^ args
00754     )
00755 {
00756     if (args->HoldingState == HoldingState::Started)
00757     {
00758         ShowMenu(args->Position);
00759     }
00760 }
00761
00762 IFrameworkView^ DirectXAppSource::CreateView()
00763 {
00764     return ref new GeometryRealizationSample();
00765 }
00766
00767 [Platform::MTAThread]
00768 int main(Platform::Array<Platform::String^>^)
00769 {
00770     auto directXAppSource = ref new DirectXAppSource();
00771     CoreApplication::Run(directXAppSource);
00772     return 0;
00773 }
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/Simple3DTouch.cpp Source File

  • DirectX touch input

Simple3DTouch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicShapes.h"
00010 #include "BasicLoader.h"
00011 #include "Simple3DTouch.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Windows::UI::Core;
00017
00018 Simple3DTouch::Simple3DTouch()
00019 {
00020 }
00021
00022 void Simple3DTouch::CreateDeviceIndependentResources()
00023 {
00024     DirectXBase::CreateDeviceIndependentResources();
00025
00026     // Allocate and initialize a controller object
00027     m_controller = ref new MoveLookController();
00028     m_controller->Initialize(m_window.Get());
00029     m_controller->SetPosition(START_POSITION);
00030
00031     // Create a TextFormat for use in displaying the text to delineate the move / look control areas.
00032     DX::ThrowIfFailed(
00033         m_dwriteFactory->CreateTextFormat(
00034             L"Segoe UI",
00035             nullptr,
00036             DWRITE_FONT_WEIGHT_LIGHT,
00037             DWRITE_FONT_STYLE_NORMAL,
00038             DWRITE_FONT_STRETCH_NORMAL,
00039             15.0f,
00040             L"en-us",
00041             &m_textFormat
00042             )
00043         );
00044
00045     DX::ThrowIfFailed(m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
00046     DX::ThrowIfFailed(m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
00047 }
00048
00049 void Simple3DTouch::CreateDeviceResources()
00050 {
00051     DirectXBase::CreateDeviceResources();
00052
00053     // Allocate and initialize the sample header
00054     m_sampleOverlay = ref new SampleOverlay();
00055
00056     m_sampleOverlay->Initialize(
00057         m_d2dDevice.Get(),
00058         m_d2dContext.Get(),
00059         m_wicFactory.Get(),
00060         m_dwriteFactory.Get(),
00061         "DirectX touch input sample"
00062         );
00063
00064     // Create D2D brush for drawing the overlay to show the Move control box.
00065     DX::ThrowIfFailed(
00066         m_d2dContext->CreateSolidColorBrush(
00067             D2D1::ColorF(D2D1::ColorF::White),
00068             &m_textBrush
00069             )
00070         );
00071
00072     // Start loading assets
00073     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00074
00075     loader->LoadShader(
00076         L"SimpleVertexShader.cso",
00077         nullptr,
00078         0,
00079         &m_vertexShader,
00080         &m_inputLayout
00081         );
00082
00083     // create the vertex and index buffers for drawing the cube
00084
00085     BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());
00086
00087     shapes->CreateBox(
00088         ROOM_BOUNDS,
00089         &m_vertexBuffer,
00090         &m_indexBuffer,
00091         nullptr,
00092         &m_indexCount
00093         );
00094
00095     // create the constant buffer for updating model and camera data
00096     CD3D11_BUFFER_DESC constantBufferDesc(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
00097     DX::ThrowIfFailed(
00098         m_d3dDevice->CreateBuffer(
00099         &constantBufferDesc,
00100         nullptr,             // leave the buffer uninitialized
00101         &m_constantBuffer
00102         )
00103         );
00104
00105     loader->LoadShader(
00106         L"SimplePixelShader.cso",
00107         &m_pixelShader
00108         );
00109
00110     loader->LoadTexture(
00111         L"texture.dds",
00112         &m_texture,
00113         &m_textureSRV
00114         );
00115
00116     // create the sampler
00117     D3D11_SAMPLER_DESC samplerDesc;
00118     ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
00119     samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
00120     samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
00121     samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
00122     samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
00123     samplerDesc.MipLODBias = 0.0f;
00124     samplerDesc.MaxAnisotropy = m_featureLevel >= D3D_FEATURE_LEVEL_9_2 ? 4 : 2;
00125     samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
00126     samplerDesc.BorderColor[0] = 0.0f;
00127     samplerDesc.BorderColor[1] = 0.0f;
00128     samplerDesc.BorderColor[2] = 0.0f;
00129     samplerDesc.BorderColor[3] = 0.0f;
00130     // allow use of all mip levels
00131     samplerDesc.MinLOD = 0;
00132     samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;
00133
00134     DX::ThrowIfFailed(
00135         m_d3dDevice->CreateSamplerState(
00136         &samplerDesc,
00137         &m_sampler)
00138         );
00139
00140     // create the scene camera
00141     m_camera = ref new BasicCamera();
00142
00143 }
00144
00145 void Simple3DTouch::CreateWindowSizeDependentResources()
00146 {
00147     DirectXBase::CreateWindowSizeDependentResources();
00148
00149     // Initialize
00150
00151     // allocate and initialize the scene camera
00152     m_camera = ref new BasicCamera();
00153
00154     // specify the 3D projection matrix
00155     m_camera->SetProjectionParameters(
00156         70.0f,                                                  // use a 70-degree vertical field of view
00157         m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
00158         0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
00159         100.0f                                                  // specify the farthest Z-distance at which to draw vertices
00160         );
00161
00162     // save the new projection matrix to the constant buffer data struct
00163     m_camera->GetProjectionMatrix(&m_constantBufferData.projection);
00164
00165     m_sampleOverlay->UpdateForWindowSizeChange();
00166
00167     // Create the text layouts for the strings to delineate the move / look control areas.
00168     static Platform::String^ moveString = "Move Touch Control Area";
00169     static Platform::String^ lookString = "Look Touch Control Area";
00170
00171     DX::ThrowIfFailed(
00172         m_dwriteFactory->CreateTextLayout(
00173             moveString->Data(),
00174             moveString->Length(),
00175             m_textFormat.Get(),
00176             m_windowBounds.Width,
00177             m_windowBounds.Height,
00178             &m_moveControlLayout
00179             )
00180         );
00181     DX::ThrowIfFailed(
00182         m_moveControlLayout->GetMetrics(&m_moveMetrics)
00183         );
00184
00185     DX::ThrowIfFailed(
00186         m_dwriteFactory->CreateTextLayout(
00187             lookString->Data(),
00188             lookString->Length(),
00189             m_textFormat.Get(),
00190             m_windowBounds.Width,
00191             m_windowBounds.Height,
00192             &m_lookControlLayout
00193             )
00194         );
00195     DX::ThrowIfFailed(
00196         m_lookControlLayout->GetMetrics(&m_lookMetrics)
00197         );
00198 }
00199
00200 void Simple3DTouch::Render()
00201 {
00202     UINT stride = sizeof(BasicVertex);
00203     UINT offset = 0;
00204
00205     // bind the render targets
00206     m_d3dContext->OMSetRenderTargets(
00207         1,
00208         m_d3dRenderTargetView.GetAddressOf(),
00209         m_d3dDepthStencilView.Get());
00210
00211     // clear both the render target and depth stencil to default values
00212     const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };
00213
00214     m_d3dContext->ClearRenderTargetView(
00215         m_d3dRenderTargetView.Get(),
00216         ClearColor
00217         );
00218
00219     m_d3dContext->ClearDepthStencilView(
00220         m_d3dDepthStencilView.Get(),
00221         D3D11_CLEAR_DEPTH,
00222         1.0f,
00223         0
00224         );
00225
00226     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00227
00228     // set the vertex and index buffers, and specify the way they define geometry
00229     m_d3dContext->IASetVertexBuffers(
00230         0,                              // starting at the first vertex buffer slot
00231         1,                              // set one vertex buffer binding
00232         m_vertexBuffer.GetAddressOf(),
00233         &stride,                        // specify the size in bytes of a single vertex
00234         &offset                         // specify the base vertex in the buffer
00235         );
00236
00237     // set the index buffer
00238     m_d3dContext->IASetIndexBuffer(
00239         m_indexBuffer.Get(),
00240         DXGI_FORMAT_R16_UINT,   // unsigned short index format
00241         0                       // specify the base index in the buffer
00242         );
00243
00244     // specify the way the vertex and index buffers define geometry
00245     m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00246
00247     // set the vertex shader stage state
00248     m_d3dContext->VSSetShader(
00249         m_vertexShader.Get(),
00250         nullptr,                // don't use shader linkage
00251         0                       // don't use shader linkage
00252         );
00253
00254     m_d3dContext->VSSetConstantBuffers(
00255         0,                              // starting at the first constant buffer slot
00256         1,                              // set one constant buffer binding
00257         m_constantBuffer.GetAddressOf()
00258         );
00259
00260     // set the pixel shader stage state
00261     m_d3dContext->PSSetShader(
00262         m_pixelShader.Get(),
00263         nullptr,                // don't use shader linkage
00264         0                       // don't use shader linkage
00265         );
00266
00267     m_d3dContext->PSSetShaderResources(
00268         0,                          // starting at the first shader resource slot
00269         1,                          // set one shader resource binding
00270         m_textureSRV.GetAddressOf()
00271         );
00272
00273     m_d3dContext->PSSetSamplers(
00274         0,                          // starting at the first sampler slot
00275         1,                          // set one sampler binding
00276         m_sampler.GetAddressOf()
00277         );
00278
00279     // draw the cube
00280     m_d3dContext->DrawIndexed(
00281         m_indexCount,   // draw all created vertices
00282         0,              // starting with the first vertex
00283         0               // and the first index
00284         );
00285
00286     m_d2dContext->BeginDraw();
00287     // Draw the text to delineate the move / look control areas.
00288
00289     D2D1_POINT_2F moveTextPosition;
00290     D2D1_POINT_2F lookTextPosition;
00291
00292     if (m_windowBounds.Width < MoveLookControllerConstants::MoveMaxXCoordinate)
00293     {
00294         // The move control spans across the bottom so center the text
00295         // and stack it.
00296         moveTextPosition.x = (m_windowBounds.Width - m_moveMetrics.width) / 2.0f;
00297         moveTextPosition.y = m_windowBounds.Height - (m_moveMetrics.height + 5.0f);
00298
00299         lookTextPosition.x = (m_windowBounds.Width - m_lookMetrics.width) / 2.0f;
00300         lookTextPosition.y = MoveLookControllerConstants::MoveMinYCoordinate - (m_lookMetrics.height + 5.0f);
00301     }
00302     else
00303     {
00304         // Draw the text on the bottom edge centered in each region.
00305         moveTextPosition.x = (MoveLookControllerConstants::MoveMaxXCoordinate - m_moveMetrics.width) / 2.0f;
00306         moveTextPosition.y = m_windowBounds.Height - (m_moveMetrics.height + 5.0f);
00307
00308         lookTextPosition.x = MoveLookControllerConstants::MoveMaxXCoordinate + (m_windowBounds.Width - MoveLookControllerConstants::MoveMaxXCoordinate - m_lookMetrics.width) / 2.0f;
00309         lookTextPosition.y = m_windowBounds.Height - (m_lookMetrics.height + 5.0f);
00310     }
00311
00312     m_d2dContext->DrawTextLayout(
00313         moveTextPosition,
00314         m_moveControlLayout.Get(),
00315         m_textBrush.Get()
00316         );
00317
00318     m_d2dContext->DrawTextLayout(
00319         lookTextPosition,
00320         m_lookControlLayout.Get(),
00321         m_textBrush.Get()
00322         );
00323
00324     // Draw a rectangle for the touch input for the move control.
00325     m_d2dContext->DrawRectangle(
00326         D2D1::RectF(
00327             0.0f,
00328             MoveLookControllerConstants::MoveMinYCoordinate,
00329             MoveLookControllerConstants::MoveMaxXCoordinate,
00330             m_windowBounds.Height
00331             ),
00332         m_textBrush.Get()
00333         );
00334
00335     HRESULT hr = m_d2dContext->EndDraw();
00336     if (hr != D2DERR_RECREATE_TARGET)
00337     {
00338         // The D2DERR_RECREATE_TARGET indicates there has been a problem with the underlying
00339         // D3D device.  All subsequent rendering will be ignored until the device is recreated.
00340         // This error will be propagated and the appropriate D3D error will be returned from the
00341         // swapchain->Present(...) call.   At that point the sample will recreate the device
00342         // and all associated resources.  As a result the D2DERR_RECREATE_TARGET doesn't
00343         // need to be handled here.
00344         DX::ThrowIfFailed(hr);
00345     }
00346
00347     m_sampleOverlay->Render();
00348
00349 }
00350
00351 void Simple3DTouch::Update(float TimeTotal, float TimeDelta)
00352 {
00353
00354     // update the model matrix based on the time
00355     m_constantBufferData.model = identity(); // rotationY(-TimeTotal * 60.0f);
00356
00357     m_controller->Update(m_window.Get());
00358
00359     float3 camPosition = m_controller->GetPosition();
00360
00361     // limit position to inside cell to keep from getting lost
00362     float3 halfBound = ROOM_BOUNDS;
00363     float3 radius = float3(0.1f, 0.1f, 0.1f);
00364     halfBound = halfBound - radius;
00365
00366     if (camPosition.x > halfBound.x)
00367     {
00368         camPosition.x = halfBound.x;
00369     }
00370     else if (camPosition.x < -halfBound.x)
00371     {
00372         camPosition.x = -halfBound.x;
00373     }
00374
00375     if (camPosition.y > halfBound.y)
00376     {
00377         camPosition.y = halfBound.y;
00378     }
00379     else if (camPosition.y < -halfBound.y)
00380     {
00381         camPosition.y = -halfBound.y;
00382     }
00383
00384     if (camPosition.z > halfBound.z)
00385     {
00386         camPosition.z = halfBound.z;
00387     }
00388     else if (camPosition.z < -halfBound.z)
00389     {
00390         camPosition.z = -halfBound.z;
00391     }
00392
00393     // notify controller that we clamped its result
00394     m_controller->SetPosition(camPosition);
00395
00396     // update the view matrix based on the camera position
00397     m_camera->SetViewParameters(
00398         m_controller->GetPosition(),        // point we are at
00399         m_controller->GetLookPoint(),       // point to look towards
00400         float3(0, 1, 0)                     // up-vector
00401         );
00402
00403     // get the camera transform for transmission to the GPU
00404     m_camera->GetViewMatrix(&m_constantBufferData.view);
00405
00406     // update the constant buffer with the new data
00407     m_d3dContext->UpdateSubresource(
00408         m_constantBuffer.Get(),
00409         0,
00410         nullptr,
00411         &m_constantBufferData,
00412         0,
00413         0
00414         );
00415 }
00416
00417 void Simple3DTouch::SaveInternalState(_In_ IPropertySet^ state)
00418 {
00419     m_controller->SaveInternalState(state);
00420 }
00421
00422 void Simple3DTouch::LoadInternalState(_In_ IPropertySet^ state)
00423 {
00424     m_controller->LoadInternalState(state);
00425 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/pch.h Source File

  • UI Automation core window provider

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #ifndef UIA_CLIENT_CONSTANTS
00011 #define UIA_CLIENT_CONSTANTS
00012
00013 // Defining some useful UIA constants.
00014 // These are drawn from UIAutomationClient.idl, which is part of the Desktop SDK
00015 // but not available for use here.
00016 const long UIA_SelectionPatternId          = 10001;
00017 const long UIA_ValuePatternId              = 10002;
00018 const long UIA_SelectionItemPatternId      = 10010;
00019
00020 const long UIA_AutomationFocusChangedEventId                  = 20005;
00021 const long UIA_SelectionItem_ElementSelectedEventId           = 20012;
00022
00023 const long UIA_ControlTypePropertyId                          = 30003;
00024 const long UIA_LocalizedControlTypePropertyId                 = 30004;
00025 const long UIA_NamePropertyId                                 = 30005;
00026 const long UIA_HasKeyboardFocusPropertyId                     = 30008;
00027 const long UIA_IsKeyboardFocusablePropertyId                  = 30009;
00028 const long UIA_IsEnabledPropertyId                            = 30010;
00029 const long UIA_AutomationIdPropertyId                         = 30011;
00030 const long UIA_HelpTextPropertyId                             = 30013;
00031 const long UIA_IsControlElementPropertyId                     = 30016;
00032 const long UIA_IsContentElementPropertyId                     = 30017;
00033 const long UIA_IsPasswordPropertyId                           = 30019;
00034 const long UIA_ValueValuePropertyId                           = 30045;
00035 const long UIA_ProviderDescriptionPropertyId                  = 30107;
00036
00037 const long UIA_CustomControlTypeId        = 50025;
00038 const long UIA_WindowControlTypeId        = 50032;
00039
00040 #endif
00041
00042 #include <wrl.h>
00043 #include <d3d11_1.h>
00044 #include <d2d1_1.h>
00045 #include <d2d1effects.h>
00046 #include <dwrite_1.h>
00047 #include <wincodec.h>
00048 #include <strsafe.h>
00049
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/DirectXSample.h Source File

  • XAML Direct2D lighting effects

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/MainPage.xaml.cpp Source File

  • App tiles and badges
  • C#,C++

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

aligned_deleter Member List

This is the complete list of members for aligned_deleter, including all inherited members.
operator()(void *p) aligned_deleter [inline]
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page2.xaml.h Source File

  • XAML AppBar control

Page2.xaml.h

Go to the documentation of this file.
00001 ﻿//
00002 // Page2.xaml.h
00003 // Declaration of the Page2 class
00004 //
00005
00006 #pragma once
00007
00008 #include "pch.h"
00009 #include "GlobalPage.xaml.h"
00010 #include "Page2.g.h"
00011
00012 namespace AppBarControl
00013 {
00014   /// <summary>
00015   /// An empty page that can be used on its own or navigated to within a Frame.
00016   /// </summary>
00017   [Windows::Foundation::Metadata::WebHostHidden]
00018   public ref class Page2 sealed
00019   {
00020   public:
00021     Page2();
00022
00023   protected:
00024     virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00025     virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00026
00027   private:
00028     GlobalPage^ rootPage;
00029     Windows::UI::Xaml::Controls::Button^ starButton;
00030     Windows::UI::Xaml::Controls::StackPanel^ rightPanel;
00031     void starButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00032   };
00033 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario5.xaml.cpp Source File

  • Search contract

Scenario5.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario5.xaml.cpp
00013 // Implementation of the Scenario5 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario5.xaml.h"
00018
00019 using namespace SDKSample::SearchContract;
00020
00021 using namespace concurrency;
00022 using namespace std;
00023 using namespace Platform;
00024 using namespace Windows::ApplicationModel::Search;
00025 using namespace Windows::Data::Json;
00026 using namespace Windows::Foundation;
00027 using namespace Windows::Storage;
00028 using namespace Windows::UI::Xaml;
00029 using namespace Windows::UI::Xaml::Controls;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 Scenario5::Scenario5()
00033 {
00034     InitializeComponent();
00035     searchPane = SearchPane::GetForCurrentView();
00036 }
00037
00038 void Scenario5::OnSearchPaneSuggestionsRequested(SearchPane^ sender, SearchPaneSuggestionsRequestedEventArgs^ e)
00039 {
00040     auto queryText = e->QueryText;
00041     unsigned int queryTextLength = queryText->Length();
00042     if (queryTextLength == 0)
00043     {
00044         MainPage::Current->NotifyUser("Use the search pane to submit a query", NotifyType::StatusMessage);
00045     }
00046     else if (UrlTextBox->Text == "")
00047     {
00048         MainPage::Current->NotifyUser("Please enter the web service URL", NotifyType::StatusMessage);
00049     }
00050     else
00051     {
00052         // Cancel the previous suggestion request if it is not finished.
00053         cts.cancel();
00054         cts = cancellation_token_source();
00055
00056         // The deferral object is used to supply suggestions asynchronously for example when fetching suggestions from a web service.
00057         // Indicate that we'll do this asynchronously:
00058         auto request = e->Request;
00059         auto deferral = request->GetDeferral();
00060
00061         try
00062         {
00063             // Use the web service Url entered in the UrlTextBox that supports OpenSearch Suggestions in order to see suggestions come from the web service.
00064             // See http://www.opensearch.org/Specifications/OpenSearch/Extensions/Suggestions/1.0 for details on OpenSearch Suggestions format.
00065             // Replace "{searchTerms}" of the Url with the query string.
00066             String^ strUrl = MainPage::ReplaceUrlSearchTerms(UrlTextBox->Text, Uri::EscapeComponent(queryText));
00067             auto uri = ref new Uri(strUrl);
00068             auto token = cts.get_token();
00069             httpRequest.GetAsync(uri, token).then([=](task<wstring> response)
00070             {
00071                 Finally f ([&] {
00072                     deferral->Complete(); // Indicate we're done supplying suggestions.
00073                 });
00074                 if (token.is_canceled())
00075                 {
00076                     cancel_current_task();
00077                 }
00078                 else
00079                 {
00080                     try
00081                     {
00082                         String^ jsonText = ref new String(response.get().c_str());
00083                         JsonArray^ parsedResponse = JsonArray::Parse(jsonText);
00084                         if (parsedResponse->Size > 1)
00085                         {
00086                             parsedResponse = JsonArray::Parse(parsedResponse->GetAt(1)->Stringify());
00087                             for (unsigned int i = 0; i < parsedResponse->Size; i++)
00088                             {
00089                                 request->SearchSuggestionCollection->AppendQuerySuggestion(parsedResponse->GetAt(i)->GetString());
00090                                 if (request->SearchSuggestionCollection->Size >= MainPage::SearchPaneMaxSuggestions)
00091                                 {
00092                                     break;
00093                                 }
00094                             }
00095                         }
00096                         if (request->SearchSuggestionCollection->Size > 0)
00097                         {
00098                             MainPage::Current->NotifyUser("Suggestions provided for query: " + queryText, NotifyType::StatusMessage);
00099                         }
00100                         else
00101                         {
00102                             MainPage::Current->NotifyUser("No suggestions provided for query: " + queryText, NotifyType::StatusMessage);
00103                         }
00104                     }
00105                     catch (task_canceled &)
00106                     {
00107                         // We have canceled the task
00108                     }
00109                     catch (Exception^)
00110                     {
00111                         MainPage::Current->NotifyUser("Suggestions could not be displayed, please verify that the service provides valid OpenSearch suggestions", NotifyType::ErrorMessage);
00112                     }
00113                 }
00114             }, task_continuation_context::use_current()); // Ensure that the task continuation comes back to the UI thread.
00115         }
00116         catch (Exception^)
00117         {
00118             MainPage::Current->NotifyUser("Suggestions could not be displayed, please verify that the service provides valid OpenSearch suggestions", NotifyType::ErrorMessage);
00119         }
00120     }
00121 }
00122
00123 void Scenario5::OnNavigatedTo(NavigationEventArgs^ e)
00124 {
00125     MainPage::Current->NotifyUser("Use the search pane to submit a query", NotifyType::StatusMessage);
00126     // This event should be registered when your app first creates its main window after receiving an activated event, like OnLaunched, OnSearchActivated.
00127     // Typically this occurs in App.xaml.cpp.
00128     token = searchPane->SuggestionsRequested += ref new TypedEventHandler<SearchPane^, SearchPaneSuggestionsRequestedEventArgs^>(this, &Scenario5::OnSearchPaneSuggestionsRequested);
00129 }
00130
00131 void Scenario5::OnNavigatedFrom(NavigationEventArgs^ e)
00132 {
00133     searchPane->SuggestionsRequested -= token;
00134 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

FontEnumeration::sealed Member List

This is the complete list of members for FontEnumeration::sealed, including all inherited members.
ListSystemFonts() FontEnumeration::sealed
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IPhoto.h Source File

  • Hilo C++
  • Hilo

IPhoto.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     interface class IPhotoGroup;
00012
00013     // The IPhoto class defines the signature of data used by XAML image controls.
00014     [Windows::Foundation::Metadata::WebHostHidden]
00015     public interface class IPhoto
00016     {
00017         property IPhotoGroup^ Group
00018         {
00019             IPhotoGroup^ get();
00020         }
00021
00022         property Platform::String^ Name { Platform::String^ get(); }
00023
00024         property Platform::String^ Path
00025         {
00026             Platform::String^ get();
00027         }
00028
00029         property Platform::String^ FormattedPath
00030         {
00031             Platform::String^ get();
00032         }
00033
00034         property Platform::String^ FileType
00035         {
00036             Platform::String^ get();
00037         }
00038
00039         property Windows::Foundation::DateTime DateTaken
00040         {
00041             Windows::Foundation::DateTime get();
00042         }
00043
00044         property Platform::String^ FormattedDateTaken
00045         {
00046             Platform::String^ get();
00047         }
00048
00049         property Platform::String^ FormattedTimeTaken
00050         {
00051             Platform::String^ get();
00052         }
00053
00054         property Platform::String^ Resolution
00055         {
00056             Platform::String^ get();
00057         }
00058
00059         property uint64 FileSize
00060         {
00061             uint64 get();
00062         }
00063
00064         property Platform::String^ DisplayType
00065         {
00066             Platform::String^ get();
00067         }
00068
00069         property Windows::UI::Xaml::Media::Imaging::BitmapImage^ Thumbnail
00070         {
00071             Windows::UI::Xaml::Media::Imaging::BitmapImage^ get();
00072         }
00073
00074         property Windows::UI::Xaml::Media::Imaging::BitmapImage^ Image
00075         {
00076             Windows::UI::Xaml::Media::Imaging::BitmapImage^ get();
00077         }
00078
00079         property bool IsInvalidThumbnail
00080         {
00081             bool get();
00082         }
00083
00084         void ClearImageData();
00085
00086         Windows::Foundation::IAsyncOperation<Windows::Storage::Streams::IRandomAccessStreamWithContentType^>^ OpenReadAsync();
00087     };
00088 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/pch.cpp Source File

  • Account picture name

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/CurrencyFormatting.xaml.cpp Source File

  • Number formatting and parsing

CurrencyFormatting.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CurrencyFormatting.xaml.cpp
00013 // Implementation of the CurrencyFormatting class
00014 //
00015
00016 #include "pch.h"
00017 #include "CurrencyFormatting.xaml.h"
00018
00019 using namespace SDKSample::NumberFormatting;
00020
00021 using namespace Platform;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Foundation::Collections;
00027 using namespace Windows::Globalization::NumberFormatting;
00028
00029 CurrencyFormatting::CurrencyFormatting()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 /// <summary>
00035 /// Invoked when this page is about to be displayed in a Frame.
00036 /// </summary>
00037 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00038 /// property is typically used to configure the page.</param>
00039 void CurrencyFormatting::OnNavigatedTo(NavigationEventArgs^ e)
00040 {
00041     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00042     // as NotifyUser()
00043     rootPage = MainPage::Current;
00044 }
00045
00046 void SDKSample::NumberFormatting::CurrencyFormatting::Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00047 {
00048     // This scenario uses the Windows.Globalization.NumberFormatting.CurrencyFormatter class
00049     // to format a number as a currency.
00050
00051     // Determine the current user's default currency.
00052     auto userCurrency = Windows::System::UserProfile::GlobalizationPreferences::Currencies->First()->Current;
00053
00054     // Generate numbers used for formatting.
00055     long long wholeNumber      = 12345;
00056     double fractionalNumber = 12345.67;
00057
00058     // Create formatter initialized using the current user's preference settings for number formatting.
00059     CurrencyFormatter^ userCurrencyFormat = ref new CurrencyFormatter(userCurrency);
00060     String^ currencyDefault = userCurrencyFormat->Format(fractionalNumber);
00061
00062     // Create a formatter initialized to a specific currency, in this case it's the US Dollar, but with the default number formatting for the current user.
00063     CurrencyFormatter^ currencyFormatUSD = ref new CurrencyFormatter("USD");  // Specified as an ISO 4217 code.
00064     String^ currencyUSD = currencyFormatUSD->Format(fractionalNumber);
00065
00066     // Create a formatter initialized to a specific currency, in this case it's the Euro with the default number formatting for France.
00067     auto fr = ref new Platform::Collections::Vector<String^>();
00068     fr->Append("fr-FR");
00069     CurrencyFormatter^ currencyFormatEuroFR = ref new CurrencyFormatter("EUR", fr, "FR");
00070     String^ currencyEuroFR = currencyFormatEuroFR->Format(fractionalNumber);
00071
00072     // Create a formatter initialized to a specific currency, in this case it's the Euro with the default number formatting for Ireland.
00073     auto gd = ref new Platform::Collections::Vector<String^>();
00074     gd->Append("gd-IE");
00075     CurrencyFormatter^ currencyFormatEuroIE = ref new CurrencyFormatter("EUR", gd, "IE");
00076     String^ currencyEuroIE = currencyFormatEuroIE->Format(fractionalNumber);
00077
00078     // Formatted so that fraction digits are always included.
00079     CurrencyFormatter^ currencyFormatUSD1 = ref new CurrencyFormatter("USD");
00080     currencyFormatUSD1->FractionDigits = 2;
00081     String^ currencyUSD1 = currencyFormatUSD1->Format(wholeNumber);
00082
00083     // Formatted so that integer grouping separators are included.
00084     CurrencyFormatter^ currencyFormatUSD2 = ref new CurrencyFormatter("USD");
00085     currencyFormatUSD2->IsGrouped = 1;
00086     String^ currencyUSD2 = currencyFormatUSD2->Format(fractionalNumber);
00087
00088     // Display the results.
00089     String^ results =
00090         "Fixed number ("                                   + fractionalNumber + ")\n" +
00091         "With user's default currency: "                   + currencyDefault + "\n" +
00092         "Formatted US Dollar: "                            + currencyUSD     + "\n" +
00093         "Formatted Euro (fr-FR defaults): "                + currencyEuroFR  + "\n" +
00094         "Formatted Euro (gd-IE defaults): "                + currencyEuroIE  + "\n" +
00095         "Formatted US Dollar (with fractional digits): "   + currencyUSD1    + "\n" +
00096         "Formatted US Dollar (with grouping separators): " + currencyUSD2;
00097
00098     rootPage->NotifyUser(results, NotifyType::StatusMessage);
00099 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Cylinder.h Source File

  • XAML DirectX 3D shooting game

Cylinder.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Cylinder:
00011 // This class is a specialization of GameObject that represents a cylinder primitive.
00012 // The cylinder is defined by a vector starting at 'position' and oriented along the
00013 // 'direction' vector.  The length of the cylinder is just the length of the 'direction'
00014 // vector.
00015
00016 #include "GameObject.h"
00017
00018 ref class Cylinder: public GameObject
00019 {
00020 internal:
00021     Cylinder();
00022     Cylinder(
00023         DirectX::XMFLOAT3 position,
00024         float radius,
00025         DirectX::XMFLOAT3 direction
00026         );
00027
00028     virtual bool IsTouching(
00029         DirectX::XMFLOAT3 point,
00030         float radius,
00031         _Out_ DirectX::XMFLOAT3 *contact,
00032         _Out_ DirectX::XMFLOAT3 *normal
00033         ) override;
00034
00035 protected:
00036     virtual void UpdatePosition() override;
00037
00038 private:
00039     void Initialize(
00040         DirectX::XMFLOAT3 position,
00041         float radius,
00042         DirectX::XMFLOAT3 direction
00043         );
00044
00045     DirectX::XMFLOAT3   m_axis;
00046     float               m_length;
00047     float               m_radius;
00048     DirectX::XMFLOAT4X4 m_rotationMatrix;
00049 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/Constants.cpp Source File

  • Bluetooth call control

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Call Controls", "SDKSample.CallControl.PhoneCall" },
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/MainPage.xaml.h Source File

  • App tiles and badges
  • C#,C++

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Files.xaml.h Source File

  • Application data

Files.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Files.xaml.h
00013 // Declaration of the Files class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Files.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ApplicationDataSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Files sealed
00031         {
00032         public:
00033             Files();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             Windows::Storage::StorageFolder^ roamingFolder;
00040             int counter;
00041
00042             void Increment_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void ReadCounter();
00044             void DisplayOutput();
00045         };
00046     }
00047 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DirectXBase.cpp Source File

  • DXGI offer and reclaim resources

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/DirectXBase.cpp Source File

  • DirectWrite vertical text

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ImageFrame Member List

This is the complete list of members for ImageFrame, including all inherited members.
__pad0__ | ImageFrame |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) | Element | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) override | ImageFrame | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) override | ImageFrame | [virtual]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override | ImageFrame | [virtual]
m_bitmapPixelBounds | ImageFrame | [private]
m_sourceImage | ImageFrame | [private]
m_sourceName | ImageFrame | [private]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override | ImageFrame | [virtual]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/ScriptDetection.xaml.cpp Source File

  • Extended Linguistic Services (ELS)
  • C++

ScriptDetection.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ScriptDetection.xaml.cpp
00013 // Implementation of the ScriptDetection class
00014 //
00015
00016 #include "pch.h"
00017 #include "ScriptDetection.xaml.h"
00018
00019 #include "elsutil.h"
00020
00021 using namespace SDKSample::ELS;
00022
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 ScriptDetection::ScriptDetection()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void ScriptDetection::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042 }
00043
00044
00045 void SDKSample::ELS::ScriptDetection::Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00046 {
00047     Button^ b = safe_cast<Button^>(sender);
00048     if (b != nullptr)
00049     {
00050         auto input = TextInput->Text;
00051     auto output = RecognizeTextScripts(input->Data());
00052     TextOutput->Text = ref new Platform::String(output.c_str());
00053     }
00054 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/App.xaml.cpp Source File

  • Network status background
  • NetworkStatusApp

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/common/LayoutAwarePage.cpp Source File

  • Media Play To
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/SampleOverlay.cpp Source File

  • DXGI offer and reclaim resources

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/EffectsFlyout.xaml.h Source File

  • DirectX postcard app

EffectsFlyout.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "EffectsFlyout.g.h"
00011
00012 namespace Postcard
00013 {
00014     [Windows::Foundation::Metadata::WebHostHidden]
00015     public delegate void EffectIntensityChangedHandler(
00016         Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e
00017         );
00018
00019     [Windows::Foundation::Metadata::WebHostHidden]
00020     public ref class EffectsFlyout sealed
00021     {
00022     public:
00023         EffectsFlyout();
00024
00025         event EffectIntensityChangedHandler^ EffectIntensityChanged;
00026
00027         void EffectIntensitySliderChanged(
00028             Platform::Object^ sender,
00029             Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e
00030             );
00031     };
00032 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/DeviceAppPage.xaml.cpp Source File

  • Windows Store device app for camera

DeviceAppPage.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DeviceAppPage.xaml.cpp
00013 // Implementation of the DeviceAppPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "DeviceAppPage.xaml.h"
00018
00019 using namespace DeviceAppForWebcam;
00020
00021 DeviceAppPage::DeviceAppPage()
00022 {
00023     InitializeComponent();
00024 }
00025
00026 DeviceAppPage::~DeviceAppPage()
00027 {
00028 }
00029
00030 void DeviceAppPage::Initialize(CameraSettingsActivatedEventArgs^ args)
00031 {
00032     videoDevController = Platform::Agile<Windows::Media::Devices::VideoDeviceController>();
00033     videoDevController = (Windows::Media::Devices::VideoDeviceController^)args->VideoDeviceController;
00034
00035     lcWrapper = nullptr;
00036     if (args->VideoDeviceExtension != nullptr)
00037     {
00038         lcWrapper = ref new WinRTComponent();
00039         lcWrapper->Initialize(args->VideoDeviceExtension);
00040     }
00041
00042     bool bAuto = false;
00043     double value = 0.0;
00044
00045     if (videoDevController->Brightness->Capabilities->Step != 0)
00046     {
00047         slBrt->Minimum = videoDevController->Brightness->Capabilities->Min;
00048         slBrt->Maximum = videoDevController->Brightness->Capabilities->Max;
00049         slBrt->StepFrequency = videoDevController->Brightness->Capabilities->Step;
00050         videoDevController->Brightness->TryGetValue(&value);
00051         slBrt->Value = value;
00052     }
00053     else
00054     {
00055         slBrt->IsEnabled = false;
00056     }
00057     if (videoDevController->Brightness->Capabilities->AutoModeSupported)
00058     {
00059         videoDevController->Brightness->TryGetAuto(&bAuto);
00060         tsBrtAuto->IsOn = bAuto;
00061     }
00062     else
00063     {
00064         tsBrtAuto->IsOn = false;
00065         tsBrtAuto->IsEnabled = false;
00066     }
00067
00068     if (videoDevController->Contrast->Capabilities->Step != 0)
00069     {
00070         slCrt->Minimum = videoDevController->Contrast->Capabilities->Min;
00071         slCrt->Maximum = videoDevController->Contrast->Capabilities->Max;
00072         slCrt->StepFrequency = videoDevController->Contrast->Capabilities->Step;
00073         videoDevController->Contrast->TryGetValue(&value);
00074         slCrt->Value = value;
00075     }
00076     else
00077     {
00078         slCrt->IsEnabled = false;
00079     }
00080     if (videoDevController->Contrast->Capabilities->AutoModeSupported)
00081     {
00082         videoDevController->Contrast->TryGetAuto(&bAuto);
00083         tsCrtAuto->IsOn = bAuto;
00084     }
00085     else
00086     {
00087         tsCrtAuto->IsOn = false;
00088         tsCrtAuto->IsEnabled = false;
00089     }
00090
00091     if (videoDevController->Focus->Capabilities->Step != 0)
00092     {
00093         slFocus->Minimum = videoDevController->Focus->Capabilities->Min;
00094         slFocus->Maximum = videoDevController->Focus->Capabilities->Max;
00095         slFocus->StepFrequency = videoDevController->Focus->Capabilities->Step;
00096         videoDevController->Focus->TryGetValue(&value);
00097         slFocus->Value = value;
00098     }
00099     else
00100     {
00101         slFocus->IsEnabled = false;
00102     }
00103     if (videoDevController->Focus->Capabilities->AutoModeSupported)
00104     {
00105         videoDevController->Focus->TryGetAuto(&bAuto);
00106         tsFocusAuto->IsOn = bAuto;
00107     }
00108     else
00109     {
00110         tsFocusAuto->IsOn = false;
00111         tsFocusAuto->IsEnabled = false;
00112     }
00113
00114     if (videoDevController->Exposure->Capabilities->Step != 0)
00115     {
00116         slExp->Minimum = videoDevController->Exposure->Capabilities->Min;
00117         slExp->Maximum = videoDevController->Exposure->Capabilities->Max;
00118         slExp->StepFrequency = videoDevController->Exposure->Capabilities->Step;
00119         videoDevController->Exposure->TryGetValue(&value);
00120         slExp->Value = value;
00121     }
00122     else
00123     {
00124         slExp->IsEnabled = false;
00125     }
00126     if (videoDevController->Exposure->Capabilities->AutoModeSupported)
00127     {
00128         videoDevController->Exposure->TryGetAuto(&bAuto);
00129         tsExpAuto->IsOn = bAuto;
00130     }
00131     else
00132     {
00133         tsExpAuto->IsOn = false;
00134         tsExpAuto->IsEnabled = false;
00135     }
00136
00137     if (lcWrapper != nullptr)
00138     {
00139         slEffect->Minimum = 0;
00140         slEffect->Maximum = 100;
00141         slEffect->StepFrequency = 1;
00142
00143         DspSettings dspSettings = lcWrapper->GetDspSetting();
00144         slEffect->Value = dspSettings.percentOfScreen;
00145
00146         if (dspSettings.isEnabled == 1)
00147         {
00148             tsEffectEnabled->IsOn = true;
00149         }
00150         else
00151         {
00152             tsEffectEnabled->IsOn = false;
00153             slEffect->IsEnabled = false;
00154         }
00155     }
00156     else
00157     {
00158         tsEffectEnabled->IsEnabled = false;
00159         slEffect->IsEnabled = false;
00160     }
00161 }
00162
00163 void DeviceAppPage::OnBrtAutoToggleChanged(Object^ sender, RoutedEventArgs^ e)
00164 {
00165     videoDevController->Brightness->TrySetAuto(tsBrtAuto->IsOn);
00166     slBrt->IsEnabled = !tsBrtAuto->IsOn;
00167 }
00168
00169 void DeviceAppPage::OnBrtSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00170 {
00171     videoDevController->Brightness->TrySetValue(slBrt->Value);
00172 }
00173
00174 void DeviceAppPage::OnCrtAutoToggleChanged(Object^ sender, RoutedEventArgs^ e)
00175 {
00176     videoDevController->Contrast->TrySetAuto(tsCrtAuto->IsOn);
00177     slCrt->IsEnabled = !tsCrtAuto->IsOn;
00178 }
00179
00180 void DeviceAppPage::OnCrtSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00181 {
00182     videoDevController->Contrast->TrySetValue(slCrt->Value);
00183 }
00184
00185 void DeviceAppPage::OnFocusAutoToggleChanged(Object^ sender, RoutedEventArgs^ e)
00186 {
00187     videoDevController->Focus->TrySetAuto(tsFocusAuto->IsOn);
00188     slFocus->IsEnabled = !tsFocusAuto->IsOn;
00189 }
00190
00191 void DeviceAppPage::OnFocusSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00192 {
00193     videoDevController->Focus->TrySetValue(slFocus->Value);
00194 }
00195
00196 void DeviceAppPage::OnExpAutoToggleChanged(Object^ sender, RoutedEventArgs^ e)
00197 {
00198     videoDevController->Exposure->TrySetAuto(tsExpAuto->IsOn);
00199     slExp->IsEnabled = !tsExpAuto->IsOn;
00200 }
00201
00202 void DeviceAppPage::OnExpSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00203 {
00204     videoDevController->Exposure->TrySetValue(slExp->Value);
00205 }
00206
00207 void DeviceAppPage::OnEffectEnabledToggleChanged(Object^ sender, RoutedEventArgs^ e)
00208 {
00209     if (tsEffectEnabled->IsOn)
00210     {
00211         lcWrapper->Enable();
00212     }
00213     else
00214     {
00215         lcWrapper->Disable();
00216     }
00217     slEffect->IsEnabled = tsEffectEnabled->IsOn;
00218 }
00219
00220 void DeviceAppPage::OnEffectSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00221 {
00222     lcWrapper->UpdateDsp((int)slEffect->Value);
00223 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Sphere.cpp Source File

  • DirectX 3D shooting game

Sphere.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Sphere.h"
00010
00011 using namespace DirectX;
00012
00013 //----------------------------------------------------------------------
00014
00015 Sphere::Sphere()
00016 {
00017     m_position = XMFLOAT3(0.0f, 0.0f, 0.0f);
00018     m_radius = 1.0f;
00019     Update();
00020 }
00021
00022 //----------------------------------------------------------------------
00023
00024 Sphere::Sphere(
00025     DirectX::XMFLOAT3 position,
00026     float radius
00027     )
00028 {
00029     m_position = position;
00030     m_radius = radius;
00031     Update();
00032 }
00033
00034 //----------------------------------------------------------------------
00035
00036 void Sphere::Update()
00037 {
00038     XMStoreFloat4x4(
00039         &m_modelMatrix,
00040         XMMatrixScaling(m_radius, m_radius, m_radius) *
00041         XMMatrixTranslation(m_position.x, m_position.y, m_position.z)
00042         );
00043 }
00044
00045 //----------------------------------------------------------------------
00046
00047 bool Sphere::IsTouching(
00048     XMFLOAT3 point,
00049     float radius,
00050     _Out_ XMFLOAT3 *contact,
00051     _Out_ XMFLOAT3 *normal
00052     )
00053 {
00054     // Check collision between instances One and Two.
00055     // oneToTwo is the collision normal vector.
00056     XMVECTOR oneToTwo = XMLoadFloat3(&m_position) - XMLoadFloat3(&point);
00057
00058     float distance = XMVectorGetX(XMVector3Length(oneToTwo));
00059
00060     oneToTwo = XMVector3Normalize(oneToTwo);
00061     XMStoreFloat3(normal, oneToTwo);
00062     XMStoreFloat3(contact, oneToTwo * m_radius);
00063
00064     if (distance < 0.0f)
00065     {
00066         distance *= -1.0f;
00067     }
00068
00069     if (distance < (radius + m_radius))
00070     {
00071         return true;
00072     }
00073     else
00074     {
00075         return false;
00076     }
00077 }
00078
00079 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/pch.h Source File

  • Input Simplified ink

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Windows RunTime Header Files
00011 #include <wrl.h>
00012 #include <collection.h>
00013
00014 // DirectX Header Files
00015 #include <d3d11_1.h>
00016 #include <d2d1_1.h>
00017 #include <dwrite_1.h>
00018 #include <wincodec.h>
00019 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/ExtendedSplash.xaml.cpp Source File

  • Splash screen

ExtendedSplash.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "ExtendedSplash.xaml.h"
00010 #include "MainPage.xaml.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Activation;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::UI::Xaml;
00017 using namespace Windows::UI::Xaml::Controls;
00018 using namespace Windows::UI::Xaml::Data;
00019 using namespace Windows::UI::Xaml::Interop;
00020 using namespace Windows::UI::Xaml::Navigation;
00021
00022 using namespace SDKSample;
00023 using namespace SDKSample::Common;
00024 using namespace SDKSample::SplashScreen;
00025
00026 using namespace concurrency;
00027 using namespace Platform;
00028
00029 ExtendedSplash::ExtendedSplash(Windows::ApplicationModel::Activation::SplashScreen^ splashscreen, bool loadState) : splash(splashscreen), dismissed(false)
00030 {
00031     InitializeComponent();
00032     LearnMoreButton->Click += ref new RoutedEventHandler(this, &ExtendedSplash::LearnMoreButton_Click);
00033     // Listen for window resize events to reposition the extended splash screen image accordingly.
00034     // This is important to ensure that the extended splash screen is formatted properly in response to snapping, unsnapping, rotation, etc...
00035     Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &ExtendedSplash::ExtendedSplash_OnResize);
00036
00037     if (splash != nullptr)
00038     {
00039         // Register an event handler to be executed when the splash screen has been dismissed.
00040         splash->Dismissed += ref new TypedEventHandler<Windows::ApplicationModel::Activation::SplashScreen^, Object^>(this, &ExtendedSplash::DismissedEventHandler);
00041
00042         // Retrieve the window coordinates of the splash screen image.
00043         splashImageRect = splash->ImageLocation;
00044         PositionImage();
00045     }
00046
00047     // Create a Frame to act as the navigation context
00048     rootFrame = ref new Frame();
00049     SuspensionManager::RegisterFrame(rootFrame, "appFrame");
00050
00051     // Normally you should start the time consuming task asynchronously here
00052     // and dissmiss the extended splash screen in the completion handler for that task
00053     // In this sample we dismiss the extended splash screen in the handler for
00054     // "Learn More" button for demonstration.
00055
00056     // Here Restore the saved session state if necessary
00057     if (loadState)
00058         SuspensionManager::RestoreAsync();
00059 }
00060
00061 // Position the extended splash screen image in the same location as the system splash screen image.
00062 void ExtendedSplash::PositionImage()
00063 {
00064     Canvas::SetTop(extendedSplashImage, splashImageRect.Y);
00065     Canvas::SetLeft(extendedSplashImage, splashImageRect.X);
00066     extendedSplashImage->Height = splashImageRect.Height;
00067     extendedSplashImage->Width = splashImageRect.Width;
00068 }
00069
00070 void ExtendedSplash::ExtendedSplash_OnResize(Object^ sender, WindowSizeChangedEventArgs^ e)
00071 {
00072     // Safely update the extended splash screen image coordinates. This function will be fired in response to snapping, unsnapping, rotation, etc...
00073     if (splash != nullptr)
00074     {
00075         // Update the coordinates of the splash screen image.
00076         splashImageRect = splash->ImageLocation;
00077         PositionImage();
00078     }
00079 }
00080
00081 void ExtendedSplash::LearnMoreButton_Click(Object^ sender, RoutedEventArgs^ e)
00082 {
00083     if (rootFrame->Content == nullptr)
00084     {
00085         // Navigate to mainpage
00086         if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087         {
00088             throw ref new FailureException("Failed to create main page");
00089         }
00090     }
00091     // Set extended splash parameters on the main page
00092     ((MainPage^)rootFrame->Content)->SetExtendedSplashInfo(splashImageRect, dismissed);
00093
00094     // Place the frame in the current Window
00095     Window::Current->Content = rootFrame;
00096 }
00097
00098 // Include code to be executed when the system has transitioned from the splash screen to the extended splash screen (application's first view).
00099 void ExtendedSplash::DismissedEventHandler(Windows::ApplicationModel::Activation::SplashScreen^ sender, Object^ e)
00100 {
00101     dismissed = true;
00102
00103     // Navigate away from the app's extended splash screen after completing setup operations here...
00104     // This sample navigates away from the extended splash screen when the "Learn More" button is clicked.
00105 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/TrialMode.xaml.h Source File

  • Trial app and in-app purchase

TrialMode.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // TrialMode.xaml.h
00013 // Declaration of the TrialMode class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "TrialMode.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace StoreSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class TrialMode sealed
00031         {
00032         public:
00033             TrialMode();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Windows::Foundation::EventRegistrationToken eventRegistrationToken;
00042
00043             void LoadTrialModeProxyFile();
00044             void TrialModeRefreshScenario();
00045
00046             void TrialTime_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void TrialProduct_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void FullProduct_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00049             void ConvertTrial_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050         };
00051     }
00052 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/DDSTextureLoader.h Source File

  • XAML DirectX 3D shooting game

DDSTextureLoader.h

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.h
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #pragma once
00019
00020 void CreateDDSTextureFromMemory(
00021     _In_ ID3D11Device* d3dDevice,
00022     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
00023     _In_ size_t ddsDataSize,
00024     _Out_opt_ ID3D11Resource** texture,
00025     _Out_opt_ ID3D11ShaderResourceView** textureView,
00026     _In_ size_t maxsize = 0
00027     );
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/common/LayoutAwarePage.h Source File

  • Background Transfer
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/MediaStreamer.h Source File

  • XAudio2 audio stream effect

MediaStreamer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <roapi.h>
00011 #include <mfidl.h>
00012 #include <mfapi.h>
00013 #include <mfreadwrite.h>
00014
00015 class MediaStreamer
00016 {
00017 public:
00018     MediaStreamer(_In_ Platform::String^ url);
00019
00020     void Restart();
00021     std::vector<byte> ReadAll();
00022     std::vector<byte> GetNextBuffer();
00023
00024     const WAVEFORMATEX& GetOutputWaveFormatEx() const
00025     {
00026         return m_waveFormat;
00027     }
00028
00029     uint32 GetMaxStreamLengthInBytes() const
00030     {
00031         return m_maxStreamLengthInBytes;
00032     }
00033
00034 private:
00035     Microsoft::WRL::ComPtr<IMFSourceReader> m_reader;
00036     WAVEFORMATEX                            m_waveFormat;
00037     uint32                                  m_maxStreamLengthInBytes;
00038 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ImageFrame.cpp Source File

  • Direct2D magazine app

ImageFrame.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Windows::Data::Xml::Dom;
00011
00012 ImageFrame::ImageFrame() :
00013     Element(),
00014     m_sourceName(nullptr),
00015     m_sourceImage(nullptr),
00016     m_bitmapPixelBounds()
00017 {
00018 }
00019
00020 bool ImageFrame::Initialize(
00021     _In_ Document^ document,
00022     _In_ XmlElement^ xmlElement
00023     )
00024 {
00025     if (!Element::Initialize(document, xmlElement))
00026     {
00027         return false;
00028     }
00029
00030     Platform::String^ value = xmlElement->GetAttribute("source");
00031
00032     if (value != nullptr)
00033     {
00034         m_sourceName = ParseNameIdentifier(value);
00035     }
00036
00037     value = xmlElement->GetAttribute("image-pixel-left");
00038
00039     if (value != nullptr)
00040     {
00041         m_bitmapPixelBounds.left = static_cast<float>(_wtof(value->Data()));
00042     }
00043
00044     value = xmlElement->GetAttribute("image-pixel-top");
00045
00046     if (value != nullptr)
00047     {
00048         m_bitmapPixelBounds.top = static_cast<float>(_wtof(value->Data()));
00049     }
00050
00051     m_bitmapPixelBounds.right = m_bitmapPixelBounds.left;
00052
00053     value = xmlElement->GetAttribute("image-pixel-width");
00054
00055     if (value != nullptr)
00056     {
00057         m_bitmapPixelBounds.right += static_cast<float>(_wtof(value->Data()));
00058     }
00059
00060     m_bitmapPixelBounds.bottom = m_bitmapPixelBounds.top;
00061
00062     value = xmlElement->GetAttribute("image-pixel-height");
00063
00064     if (value != nullptr)
00065     {
00066         m_bitmapPixelBounds.bottom += static_cast<float>(_wtof(value->Data()));
00067     }
00068
00069     return true;
00070 }
00071
00072 bool ImageFrame::BindResource(_In_ Element^ rootElement)
00073 {
00074     if (rootElement != nullptr)
00075     {
00076         TreeIterator<Element> it(rootElement);
00077
00078         // Traverse the tree looking for the source image
00079         do
00080         {
00081             ::Image^ image(dynamic_cast<::Image^>(it.GetCurrentNode()));
00082
00083             if (    image != nullptr
00084                 &&  image->GetName() == m_sourceName
00085                 )
00086             {
00087                 m_sourceImage = image;
00088                 return true;
00089             }
00090
00091         } while (++it);
00092     }
00093
00094     return false;
00095 }
00096
00097 void ImageFrame::Measure(
00098     _In_ Document^ document,
00099     D2D1_SIZE_F const& parentSize,
00100     _Out_ D2D1_RECT_F* bounds
00101     )
00102 {
00103     if (m_size.width <= 0 && m_size.height <= 0)
00104     {
00105         m_size = D2D1::SizeF(parentSize.width - m_offset.x, parentSize.height - m_offset.y);
00106     }
00107
00108     *bounds = D2D1::RectF(
00109         m_offset.x,
00110         m_offset.y,
00111         m_offset.x + m_size.width,
00112         m_offset.y + m_size.height
00113         );
00114 }
00115
00116 bool ImageFrame::Draw(
00117     _In_ Document^ document,
00118     D2D1::Matrix3x2F const& transform
00119     )
00120 {
00121     if (m_sourceImage != nullptr)
00122     {
00123         auto renderer = document->GetRenderer();
00124
00125         return m_sourceImage->DrawBitmap(
00126             renderer,
00127             transform,
00128             D2D1::RectF(
00129                 m_offset.x,
00130                 m_offset.y,
00131                 m_offset.x + m_size.width,
00132                 m_offset.y + m_size.height
00133                 ),
00134             m_bitmapPixelBounds
00135             );
00136     }
00137
00138     return false;
00139 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

D2DEffectsOnPrimitives Member List

This is the complete list of members for D2DEffectsOnPrimitives, including all inherited members.
__pad0__ | D2DEffectsOnPrimitives |
CreateDeviceIndependentResources() override | D2DEffectsOnPrimitives | [virtual]
CreateDeviceResources() override | D2DEffectsOnPrimitives | [virtual]
CreateEffectGraph() | D2DEffectsOnPrimitives | [private]
CreatePrimitives() | D2DEffectsOnPrimitives | [private]
CreateWindowSizeDependentResources() override | D2DEffectsOnPrimitives | [virtual]
Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView) | D2DEffectsOnPrimitives | [virtual]
Load(_In_ Platform::String^entryPoint) | D2DEffectsOnPrimitives | [virtual]
m_arithmeticCompositeEffect | D2DEffectsOnPrimitives | [private]
m_coloredBrush | D2DEffectsOnPrimitives | [private]
m_inputImage | D2DEffectsOnPrimitives | [private]
m_sampleOverlay | D2DEffectsOnPrimitives | [private]
m_string | D2DEffectsOnPrimitives | [private]
m_textFormat | D2DEffectsOnPrimitives | [private]
m_whiteBrush | D2DEffectsOnPrimitives | [private]
OnActivated(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args) | D2DEffectsOnPrimitives | [private]
OnDisplayContentsInvalidated(_In_ Platform::Object^sender) | D2DEffectsOnPrimitives | [private]
OnLogicalDpiChanged(_In_ Platform::Object^sender) | D2DEffectsOnPrimitives | [private]
OnWindowSizeChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args) | D2DEffectsOnPrimitives | [private]
Render() override | D2DEffectsOnPrimitives | [virtual]
Run() | D2DEffectsOnPrimitives | [virtual]
SetWindow(_In_ Windows::UI::Core::CoreWindow^window) | D2DEffectsOnPrimitives | [virtual]
Uninitialize() | D2DEffectsOnPrimitives | [virtual]
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/App.xaml.cpp Source File

  • Bluetooth call control

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/MainPage.xaml.cpp Source File

  • Inclinometer sensor

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario7.xaml.cpp Source File

  • XAML WebView control

Scenario7.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario7.xaml.cpp
00013 // Implementation of the Scenario7 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario7.xaml.h"
00018
00019 using namespace SDKSample::WebViewControl;
00020
00021 using namespace Windows::Foundation;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::ApplicationModel::DataTransfer;
00026
00027 Scenario7::Scenario7()
00028 {
00029     InitializeComponent();
00030   DataTransferManager^ dataTransferManager = nullptr;
00031 }
00032
00033
00034 // Invoked when this page is about to be displayed in a Frame.
00035 void Scenario7::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040
00041   WebView7->LoadCompleted += ref new LoadCompletedEventHandler(this, &Scenario7::WebView7_LoadCompleted);
00042     WebView7->Navigate(ref new Uri("http://www.wsj.com"));
00043 }
00044
00045
00046 // Load completed handler for WebView7
00047 void SDKSample::WebViewControl::Scenario7::WebView7_LoadCompleted(Platform::Object^ sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^ e)
00048 {
00049   WebView7->Visibility = Windows::UI::Xaml::Visibility::Visible;
00050   BlockingRect->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00051   ProgressRing1->IsActive = false;
00052 }
00053
00054 // Click handler for 'Share' button
00055 void SDKSample::WebViewControl::Scenario7::Share_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00056 {
00057   dataTransferManager = DataTransferManager::GetForCurrentView();
00058   dataRequestedToken = dataTransferManager->DataRequested += ref new TypedEventHandler<DataTransferManager^, DataRequestedEventArgs^>(this, &Scenario7::dataTransferManager_DataRequested);
00059   DataTransferManager::ShowShareUI();
00060 }
00061
00062 // Data requested handler
00063 void SDKSample::WebViewControl::Scenario7::dataTransferManager_DataRequested(DataTransferManager^ sender, DataRequestedEventArgs^ args)
00064 {
00065   DataRequest^ request = args->Request;
00066   DataPackage^ p = WebView7->DataTransferPackage;
00067
00068   if (p->GetView()->Contains(StandardDataFormats::Text))
00069   {
00070       p->Properties->Title = "WebView Sharing Excerpt";
00071       p->Properties->Description = "This is a snippet from the content hosted in the WebView control";
00072       request->Data = p;
00073   }
00074   else
00075   {
00076       request->FailWithDisplayText("Nothing to share");
00077   }
00078     dataTransferManager->DataRequested -= dataRequestedToken;
00079 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioInput1.xaml.h Source File

  • Raw notifications
  • MainAppSample

ScenarioInput1.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // ScenarioInput1.xaml.h
00009 // Declaration of the ScenarioInput1 class.
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "ScenarioInput1.g.h"
00016 #include "MainPage.xaml.h"
00017
00018 using namespace Windows::UI::Xaml;
00019
00020 namespace RawNotificationsSampleCPP
00021 {
00022   [Windows::Foundation::Metadata::WebHostHidden]
00023   public ref class ScenarioInput1 sealed
00024   {
00025   public:
00026     ScenarioInput1();
00027
00028   protected:
00029     virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030     virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00031
00032   private:
00033     ~ScenarioInput1();
00034     MainPage^ rootPage;
00035     void OutputFrameLoaded(Object^ sender, Object^ e);
00036     void Scenario1Open_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037     void Scenario1Unregister_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038         void OutputToTextBox(Platform::String^ text);
00039
00040         Windows::UI::Core::CoreDispatcher^ _dispatcher;
00041     EventRegistrationToken _frameLoadedToken;
00042
00043         void OpenChannelAndRegisterTask();
00044         void RegisterBackgroundTask();
00045     bool UnregisterBackgroundTask();
00046         void BackgroundTaskCompleted(Windows::ApplicationModel::Background::BackgroundTaskRegistration^ sender, Windows::ApplicationModel::Background::BackgroundTaskCompletedEventArgs^ args);
00047   };
00048 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/DirectXSample.h Source File

  • XAudio2 audio stream effect

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BumpMapping.h Source File

  • Direct3D bump mapping

BumpMapping.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "BasicMath.h"
00012 #include "BasicCamera.h"
00013 #include "LonLatController.h"
00014 #include "SampleOverlay.h"
00015
00016 // describes the constant buffer that will be used to draw the cube
00017 struct ConstantBuffer
00018 {
00019     float4x4 model;
00020     float4x4 view;
00021     float4x4 projection;
00022 };
00023
00024 #define START_POSITION (float3(0, 0.4f, -2))
00025
00026 ref class BumpMapping : public DirectXBase
00027 {
00028 internal:
00029     BumpMapping();
00030
00031     virtual void CreateDeviceIndependentResources() override;
00032     virtual void CreateDeviceResources() override;
00033     virtual void CreateWindowSizeDependentResources() override;
00034     virtual void Render() override;
00035
00036     void Update(float TimeTotal, float TimeDelta);
00037
00038     void SaveInternalState(_In_ Windows::Foundation::Collections::IPropertySet^ state);
00039     void LoadInternalState(_In_ Windows::Foundation::Collections::IPropertySet^ state);
00040
00041 private:
00042     SampleOverlay^                                      m_sampleOverlay;
00043
00044     Microsoft::WRL::ComPtr<ID3D11InputLayout>           m_inputLayout;        // mesh vertex input layout
00045     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_vertexBuffer;       // mesh vertex buffer
00046     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_indexBuffer;        // mesh index buffer
00047     Microsoft::WRL::ComPtr<ID3D11VertexShader>          m_vertexShader;       // vertex shader
00048     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_pixelShader;        // pixel shader
00049     Microsoft::WRL::ComPtr<ID3D11Texture2D>             m_texture;            // color texture
00050     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_textureSRV;         // color texture view
00051     Microsoft::WRL::ComPtr<ID3D11SamplerState>          m_sampler;            // color texture sampler
00052     Microsoft::WRL::ComPtr<ID3D11Texture2D>             m_normals;            // normal map texture
00053     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_normalSRV;          // normal map texture view
00054     Microsoft::WRL::ComPtr<ID3D11SamplerState>          m_normalSampler;      // normal map sampler
00055     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_constantBuffer;     // constant buffer resource
00056
00057     unsigned int                     m_indexCount;                  // mesh index count
00058     ConstantBuffer                   m_constantBufferData;          // constant buffer resource data
00059     BasicCamera^                     m_camera;                      // scene camera
00060     LonLatController^                m_controller;                  // controller to map from input events to movement
00061
00062 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario3.xaml.cpp Source File

  • App package information

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::PackageSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::ApplicationModel;
00027
00028 Scenario3::Scenario3()
00029 {
00030     InitializeComponent();
00031 }
00032
00033 /// <summary>
00034 /// Invoked when this page is about to be displayed in a Frame.
00035 /// </summary>
00036 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00037 /// property is typically used to configure the page.</param>
00038 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00039 {
00040     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00041     // as NotifyUser()
00042     rootPage = MainPage::Current;
00043 }
00044
00045 void Scenario3::GetDependencies_Click(Object^ sender, RoutedEventArgs^ e)
00046 {
00047     Package^ package = Package::Current;
00048     auto dependencies = package->Dependencies;
00049
00050     String^ output = "Count: " + dependencies->Size.ToString();
00051     for (unsigned i = 0; i < dependencies->Size; i++)
00052     {
00053         Package^ dependency = dependencies->GetAt(i);
00054         output += "\n[" + i.ToString() + "]: " + dependency->Id->FullName;
00055     }
00056
00057     OutputTextBlock->Text = output;
00058 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/App.xaml.h Source File

  • PlayToReceiver

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareText.xaml.cpp Source File

  • Sharing content source app

ShareText.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ShareText.xaml.cpp
00013 // Implementation of the ShareText class
00014 //
00015
00016 #include "pch.h"
00017 #include "ShareText.xaml.h"
00018
00019 using namespace SDKSample::ShareSource;
00020 using namespace SDKSample::Common;
00021
00022 using namespace Platform;
00023 using namespace Windows::ApplicationModel::DataTransfer;
00024
00025 ShareText::ShareText()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 bool ShareText::GetShareContent(DataRequest^ request)
00031 {
00032     bool succeeded = false;
00033
00034     auto dataPackageText = TextToShare->Text;
00035     if (dataPackageText != nullptr)
00036     {
00037         auto requestData = request->Data;
00038         requestData->Properties->Title = TitleInputBox->Text;
00039
00040         // The description is optional.
00041         auto dataPackageDescription = DescriptionInputBox->Text;
00042         if (dataPackageDescription != nullptr)
00043         {
00044             requestData->Properties->Description = dataPackageDescription;
00045         }
00046         requestData->SetText(dataPackageText);
00047         succeeded = true;
00048     }
00049     else
00050     {
00051         request->FailWithDisplayText("Enter the text you would like to share and try again.");
00052     }
00053     return succeeded;
00054 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/pch.h Source File

  • Trial app and in-app purchase

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TGA_EXTENSION Member List

This is the complete list of members for TGA_EXTENSION, including all inherited members.
bAttributesType | TGA_EXTENSION
bVersionLetter | TGA_EXTENSION
dwColorOffset | TGA_EXTENSION
dwKeyColor | TGA_EXTENSION
dwScanOffset | TGA_EXTENSION
dwStampOffset | TGA_EXTENSION
szAuthorComment | TGA_EXTENSION
szAuthorName | TGA_EXTENSION
szJobName | TGA_EXTENSION
szSoftwareId | TGA_EXTENSION
wGammaDenominator | TGA_EXTENSION
wGammaNumerator | TGA_EXTENSION
wJobHour | TGA_EXTENSION
wJobMinute | TGA_EXTENSION
wJobSecond | TGA_EXTENSION
wPixelDenominator | TGA_EXTENSION
wPixelNumerator | TGA_EXTENSION
wSize | TGA_EXTENSION
wStampDay | TGA_EXTENSION
wStampHour | TGA_EXTENSION
wStampMinute | TGA_EXTENSION
wStampMonth | TGA_EXTENSION
wStampSecond | TGA_EXTENSION
wStampYear | TGA_EXTENSION
wVersionNumber | TGA_EXTENSION
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/App.xaml.h Source File

  • Number formatting and parsing

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Settings.xaml.h Source File

  • Application data

Settings.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Settings.xaml.h
00013 // Declaration of the Settings class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Settings.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ApplicationDataSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Settings sealed
00031         {
00032         public:
00033             Settings();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             Windows::Storage::ApplicationDataContainer^ localSettings;
00040
00041             void WriteSetting_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042             void DeleteSetting_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void DisplayOutput();
00044         };
00045     }
00046 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

UiaCoreWindowProvider::IDisconnectableProvider Member List

This is the complete list of members for UiaCoreWindowProvider::IDisconnectableProvider, including all inherited members.
Disconnect() UiaCoreWindowProvider::IDisconnectableProvider
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/pch.h Source File

  • Direct3D stereoscopic 3D

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <DirectXMath.h>
00017 #include <agile.h>
00018 #include "BasicMath.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/sample-utils/CppSamplesUtils.h Source File

  • Proximity
  • sample-utils

CppSamplesUtils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/MainPage.xaml.cpp Source File

  • Edge gesture invocation

MainPage.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.cpp
00010 // Implementation of the MainPage.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "MainPage.xaml.h"
00015 #include "App.xaml.h"
00016
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::UI::Xaml::Controls;
00019 using namespace Windows::UI::Xaml::Data;
00020 using namespace Windows::System;
00021 using namespace Windows::Foundation;
00022 using namespace Platform;
00023 using namespace EdgeGestureSample;
00024 using namespace CppSamplesUtils;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 MainPage::MainPage()
00029 {
00030     InitializeComponent();
00031
00032     SetFeatureName("EdgeGesture C++ Sample");
00033
00034     _scenariosFrame = ScenarioList;
00035     _inputFrame = ScenarioInput;
00036     _outputFrame = ScenarioOutput;
00037
00038     _layoutHandlerToken = Window::Current->SizeChanged += ref new Windows::UI::Xaml::WindowSizeChangedEventHandler(this, &MainPage::Page_SizeChanged);
00039
00040     _pageLoadedHandlerToken = Loaded += ref new RoutedEventHandler(this, &MainPage::Page_Loaded);
00041     _logicalDpiChangedToken = DisplayProperties::LogicalDpiChanged += ref new DisplayPropertiesEventHandler(this, &MainPage::DisplayProperties_LogicalDpiChanged);
00042 }
00043
00044 MainPage::~MainPage()
00045 {
00046 }
00047
00048 void MainPage::Page_Loaded(Object^ sender, RoutedEventArgs^ e)
00049 {
00050     // Load the ScenarioList page into the proper frame.
00051     TypeName pageType = { "EdgeGestureSample.ScenarioList", TypeKind::Custom };
00052     ScenarioList->Navigate(pageType, this);
00053
00054     // Figure out what resolution and orientation we are in and respond appropriately.
00055     CheckResolutionAndViewState();
00056 }
00057
00058 void MainPage::SetFeatureName(String^ strFeature)
00059 {
00060     FeatureName->Text = strFeature;
00061 }
00062
00063 void MainPage::Page_SizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00064 {
00065     CheckResolutionAndViewState();
00066 }
00067
00068 void MainPage::DisplayProperties_LogicalDpiChanged(Object^ sender)
00069 {
00070     CheckResolutionAndViewState();
00071 }
00072
00073 void MainPage::CheckResolutionAndViewState()
00074 {
00075     ApplicationViewState state = ApplicationView::Value;
00076     String^ stateString = ConvertViewState(state);
00077
00078     ResolutionScale scale = DisplayProperties::ResolutionScale;
00079     String^ scaleString = ConvertResolution(scale);
00080
00081     VisualStateManager::GoToState(this, stateString + scaleString, false);
00082 }
00083
00084 String^ MainPage::ConvertViewState(ApplicationViewState state)
00085 {
00086     switch (state)
00087     {
00088     case ApplicationViewState::Filled:
00089         return "Filled";
00090     case ApplicationViewState::FullScreenLandscape:
00091         return "FullScreenLandscape";
00092     case ApplicationViewState::FullScreenPortrait:
00093         return "FullScreenPortrait";
00094     case ApplicationViewState::Snapped:
00095         return "Snapped";
00096     }
00097     return "";
00098 }
00099
00100 String^ MainPage::ConvertResolution(ResolutionScale scale)
00101 {
00102     switch (scale)
00103     {
00104     case ResolutionScale::Scale100Percent:
00105         return "Scale100Percent";
00106     case ResolutionScale::Scale140Percent:
00107         return "Scale140Percent";
00108     case ResolutionScale::Scale180Percent:
00109         return "Scale180Percent";
00110     }
00111     return "";
00112 }
00113
00114 void MainPage::DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^ frame)
00115 {
00116     frame->Navigate(pageType, this);
00117
00118     std::wstring PageName(pageType.Name->Data());
00119     std::basic_string <wchar_t>::size_type indexSubstring;
00120     indexSubstring = PageName.find(L"Output");
00121     if (indexSubstring != std::wstring::npos)
00122     {
00123         // Raise OutputFrameLoaded so downstream pages know that the output frame content has been loaded.
00124         OutputFrameLoaded(this, nullptr);
00125     }
00126     else
00127     {
00128         // Raise InputFrameLoaded so downstream pages know that the input frame content has been loaded.
00129         InputFrameLoaded(this, nullptr);
00130     }
00131 }
00132
00133 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00134 {
00135     switch (type)
00136     {
00137     case NotifyType::StatusMessage:
00138         StatusBlock->Style = dynamic_cast<Windows::UI::Xaml::Style^>(App::Current->Resources->Lookup("StatusStyle"));
00139         break;
00140     case NotifyType::ErrorMessage:
00141         StatusBlock->Style = dynamic_cast<Windows::UI::Xaml::Style^>(App::Current->Resources->Lookup("ErrorStyle"));
00142         break;
00143     default:
00144         break;
00145     }
00146     StatusBlock->Text = strMessage;
00147 }
00148
00149 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00150 {
00151     auto uri = ref new Windows::Foundation::Uri((String^)((HyperlinkButton^)sender)->Tag);
00152     Windows::System::Launcher::LaunchUriAsync(uri);
00153 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BooleanToVisibilityConverter.cpp Source File

  • Hilo C++
  • Hilo
  • Common

BooleanToVisibilityConverter.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "BooleanToVisibilityConverter.h"
00009
00010 using namespace Hilo::Common;
00011
00012 using namespace Platform;
00013 using namespace Windows::Foundation;
00014 using namespace Windows::UI::Xaml;
00015 using namespace Windows::UI::Xaml::Interop;
00016
00017 Object^ BooleanToVisibilityConverter::Convert(Object^ value, TypeName targetType, Object^ parameter, String^ language)
00018 {
00019   (void) targetType;  // Unused parameter
00020   (void) parameter; // Unused parameter
00021   (void) language;  // Unused parameter
00022
00023   auto boxedBool = dynamic_cast<Box<bool>^>(value);
00024   auto boolValue = (boxedBool != nullptr && boxedBool->Value);
00025   return (boolValue ? Visibility::Visible : Visibility::Collapsed);
00026 }
00027
00028 Object^ BooleanToVisibilityConverter::ConvertBack(Object^ value, TypeName targetType, Object^ parameter, String^ language)
00029 {
00030   (void) targetType;  // Unused parameter
00031   (void) parameter; // Unused parameter
00032   (void) language;  // Unused parameter
00033
00034   auto visibility = dynamic_cast<Box<Visibility>^>(value);
00035   return (visibility != nullptr && visibility->Value == Visibility::Visible);
00036 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Clipboard::App Member List

This is the complete list of members for Clipboard::App, including all inherited members.
__pad0__ | Clipboard::App |
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | Clipboard::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | Clipboard::App | [virtual]
rootFrame | Clipboard::App | [private]
SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) | Clipboard::App | [private]
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario3.xaml.h Source File

  • XAML accessibility

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::UI::Xaml::Automation;
00026 using namespace Windows::UI::Xaml::Automation::Peers;
00027 using namespace Windows::UI::Xaml::Automation::Provider;
00028 using namespace Windows::UI::Xaml::Media;
00029
00030 namespace SDKSample
00031 {
00032     namespace Accessibility
00033     {
00034         /// <summary>
00035         /// An empty page that can be used on its own or navigated to within a Frame.
00036         /// </summary>
00037         [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00038         public ref class Scenario3 sealed
00039         {
00040         public:
00041             Scenario3();
00042
00043         protected:
00044             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00045         private:
00046             MainPage^ rootPage;
00047         };
00048
00049         ref class MediaElementContainer;
00050
00051         [Windows::Foundation::Metadata::WebHostHidden]
00052         public ref class MediaContainerAP sealed :  Windows::UI::Xaml::Automation::Peers::FrameworkElementAutomationPeer
00053                                                     ,Windows::UI::Xaml::Automation::Provider::IRangeValueProvider
00054                                                     ,Windows::UI::Xaml::Automation::Provider::IToggleProvider
00055         {
00056             MediaElement ^_mediaElement;
00057             FrameworkElement ^_labeledBy;
00058
00059         public:
00060                 MediaContainerAP(MediaElementContainer^ owner, MediaElement^ mediaElement);
00061
00062         protected:
00063             virtual Object^ GetPatternCore(PatternInterface patternInterface) override
00064             {
00065                 if (patternInterface == PatternInterface::RangeValue)
00066                 {
00067                     return this;
00068                 }
00069                 else if (patternInterface == PatternInterface::Toggle)
00070                 {
00071                     return this;
00072                 }
00073                 return nullptr;
00074             }
00075
00076         protected:
00077             virtual  AutomationControlType GetAutomationControlTypeCore() override
00078             {
00079                 return  AutomationControlType::Group;
00080             }
00081
00082         protected:
00083             virtual Platform::String^ GetLocalizedControlTypeCore() override
00084             {
00085                 return "Video";
00086             }
00087
00088         protected:
00089             virtual Platform::String^ GetClassNameCore() override
00090             {
00091                 return "MediaElementContainer";
00092             }
00093
00094         public:
00095             virtual property bool IsReadOnly
00096             {
00097                 bool get()
00098                 {
00099                     return false;
00100                 }
00101             }
00102
00103         public:
00104             virtual property double LargeChange
00105             {
00106                 double get()
00107                 {
00108                     Windows::UI::Xaml::Duration md;
00109                     md = _mediaElement->NaturalDuration;
00110                     Windows::Foundation::TimeSpan t =_mediaElement->NaturalDuration.TimeSpan;
00111                     // Windows::Foundation::TimeSpan's Duration Property is in 100 ns units (= 10 ^ -7 seconds)
00112                     // This, divided by 10 (since the C# sample does total Duration in seconds / 10) makes the conversion factor 0.00000001.
00113                     // this is both for parity with the C# sample as well as to make the
00114                     // Accessibility client see a more human friendly value / range.
00115                     return (static_cast<double> (t.Duration) * 0.00000001);
00116                 }
00117             }
00118
00119         public:
00120             virtual property double Maximum
00121             {
00122                 double get()
00123                 {
00124                     Windows::Foundation::TimeSpan t =_mediaElement->NaturalDuration.TimeSpan;
00125                     return (static_cast<double> (t.Duration) * 0.0000001);
00126                 }
00127             }
00128
00129         public:
00130             virtual property double Minimum
00131             {
00132                 double get() { return 0; }
00133             }
00134
00135         public:
00136             virtual void SetValue(double value)
00137             {
00138                 if (value > Maximum || value < 0)
00139                 {
00140                     throw ref new Platform::InvalidArgumentException;
00141                 }
00142                 // Here, we divide by 10 ^ -7 to convert from seconds to 100s of ns.
00143                 // this is both for parity with the C# sample as well as to make the
00144                 // Accessibility client see a more human friendly value / range.
00145                 Windows::Foundation::TimeSpan t = { (__int64)(value / 0.0000001)};
00146                 _mediaElement->Position = t;
00147             }
00148
00149         public:
00150             virtual property double SmallChange
00151             {
00152                 double get()
00153                 {
00154                     Windows::UI::Xaml::Duration md;
00155                     md = _mediaElement->NaturalDuration;
00156                     Windows::Foundation::TimeSpan t =_mediaElement->NaturalDuration.TimeSpan;
00157                     // Windows::Foundation::TimeSpan's Duration Property is in 100 ns units (= 10 ^ -7 seconds)
00158                     // This, divided by 10 (since the C# sample does total Duration in seconds / 50) makes the conversion factor 0.000000002.
00159                     return (static_cast<double> (t.Duration) * 0.000000002);
00160                 }
00161             }
00162
00163         public:
00164             virtual property double Value
00165             {
00166                 double get()
00167                 {
00168                     return (static_cast<double>(_mediaElement->Position.Duration) * 0.0000001);
00169                 }
00170             }
00171
00172         public:
00173             virtual void Toggle()
00174             {
00175                 if (_mediaElement->CurrentState == MediaElementState::Playing)
00176                 {
00177                     if (_mediaElement->CanPause)
00178                     {
00179                         _mediaElement->Pause();
00180                     }
00181                     else
00182                     {
00183                         _mediaElement->Stop();
00184                     }
00185                 }
00186                 else if (_mediaElement->CurrentState == MediaElementState::Paused || _mediaElement->CurrentState == MediaElementState::Stopped)
00187                 {
00188                     _mediaElement->Play();
00189                 }
00190             }
00191
00192             public:
00193                 virtual property Windows::UI::Xaml::Automation::ToggleState ToggleState
00194             {
00195                 Windows::UI::Xaml::Automation::ToggleState get()
00196                 {
00197                     if (_mediaElement->CurrentState == MediaElementState::Playing)
00198                     {
00199                         return Windows::UI::Xaml::Automation::ToggleState::On;
00200                     }
00201                     else if (_mediaElement->CurrentState == MediaElementState::Stopped || _mediaElement->CurrentState == MediaElementState::Paused)
00202                     {
00203                         return Windows::UI::Xaml::Automation::ToggleState::Off;
00204                     }
00205                     else
00206                     {
00207                         return Windows::UI::Xaml::Automation::ToggleState::Indeterminate;
00208                     }
00209                 }
00210             }
00211         };
00212
00213         [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00214         public ref class MediaElementContainer sealed : Windows::UI::Xaml::Controls::ContentControl
00215         {
00216             //Platform::String^ mediaUri;
00217             Windows::UI::Xaml::Controls::MediaElement^ mediaElement;
00218
00219         public:
00220             MediaElementContainer(Windows::UI::Xaml::Controls::Panel^ parent)
00221             {
00222                 parent->Children->Append(this);
00223                 mediaElement = ref new Windows::UI::Xaml::Controls::MediaElement();
00224                 mediaElement->Width = 200;
00225                 this->Content = mediaElement;
00226                 Windows::Foundation::Uri^ uri = ref new Windows::Foundation::Uri("ms-appx:///Media/video.wmv");
00227                 mediaElement->Source = uri;
00228                 this->IsTabStop = true;
00229                 AutomationProperties::SetAutomationId(mediaElement, "MediaElement1");
00230                 AutomationProperties::SetName(mediaElement, "MediaElement");
00231             }
00232         protected:
00233             virtual AutomationPeer^ OnCreateAutomationPeer() override
00234             {
00235                 return ref new MediaContainerAP(this, mediaElement);
00236             }
00237         };
00238     }
00239 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario3.xaml.cpp Source File

  • Credential locker

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::PasswordVaultCPP;
00020
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::Security::Credentials;
00026
00027 Scenario3::Scenario3()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042 }
00043
00044
00045 void SDKSample::PasswordVaultCPP::Scenario3::ScenarioButtonDelete_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00046 {
00047   try {
00048     Windows::Security::Credentials::PasswordVault^ v = ref new Windows::Security::Credentials::PasswordVault();
00049     Windows::Foundation::Collections::IVectorView<PasswordCredential^>^ creds = v->RetrieveAll();
00050     DeleteSummary->Text = "Number of credentials deleted: " + creds->Size;
00051     for each (PasswordCredential^ cred in creds)
00052     {
00053       v->Remove(cred);
00054     }
00055
00056     // GetAll is a snapshot in time, so to reflect the updated vault, get all credentials again
00057         creds = v->RetrieveAll();
00058         //The credentials should now be empty
00059   }
00060   catch (Platform::COMException^ Error)
00061   {
00062   }
00063 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Story Member List

This is the complete list of members for Story, including all inherited members.
__pad0__ | Story |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) | Element | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) | Element | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
GetDesign(D2D1_SIZE_F displaySize) | Story |
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
override | Story |
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario2.xaml.h Source File

  • EAS policies for mail clients

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace EAS
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Launch_Click2(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Reset_Click2(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Rectangle.cpp Source File

  • Direct2D magazine app

Rectangle.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Microsoft::WRL;
00011 using namespace Windows::Data::Xml::Dom;
00012
00013 Rectangle::Rectangle() :
00014     Element(),
00015     m_color(0),
00016     m_opacity(1.0f),
00017     m_brush()
00018 {
00019 }
00020
00021 bool Rectangle::Initialize(
00022     _In_ Document^ document,
00023     _In_ XmlElement^ xmlElement
00024     )
00025 {
00026     if (!Element::Initialize(document, xmlElement))
00027     {
00028         return false;
00029     }
00030
00031     Platform::String^ value;
00032
00033     value = xmlElement->GetAttribute("color");
00034
00035     if (value != nullptr)
00036     {
00037         m_color = ParseColor(value);
00038     }
00039
00040     value = xmlElement->GetAttribute("opacity");
00041
00042     if (value != nullptr)
00043     {
00044         m_opacity = static_cast<float>(_wtof(value->Data()));
00045     }
00046
00047     return true;
00048 }
00049
00050 void Rectangle::Measure(
00051     _In_ Document^ document,
00052     D2D1_SIZE_F const& parentSize,
00053     _Out_ D2D1_RECT_F* bounds
00054     )
00055 {
00056     *bounds = D2D1::RectF(
00057         m_offset.x,
00058         m_offset.y,
00059         m_offset.x + m_size.width,
00060         m_offset.y + m_size.height
00061         );
00062 }
00063
00064 bool Rectangle::Draw(
00065     _In_ Document^ document,
00066     D2D1::Matrix3x2F const& transform
00067     )
00068 {
00069     ComPtr<ID2D1DeviceContext> d2dDeviceContext;
00070     document->GetRenderer()->GetD2DDeviceContext(&d2dDeviceContext);
00071
00072     if (m_brush == nullptr)
00073     {
00074         ComPtr<ID2D1SolidColorBrush> solidColorBrush;
00075
00076         DX::ThrowIfFailed(
00077             d2dDeviceContext->CreateSolidColorBrush(
00078                 D2D1::ColorF(m_color, m_opacity),
00079                 D2D1::BrushProperties(),
00080                 &solidColorBrush
00081                 )
00082             );
00083
00084         m_brush = solidColorBrush;
00085     }
00086
00087     d2dDeviceContext->SetTransform(transform);
00088
00089     d2dDeviceContext->FillRectangle(
00090         D2D1::RectF(
00091             m_offset.x,
00092             m_offset.y,
00093             m_offset.x + m_size.width,
00094             m_offset.y + m_size.height
00095             ),
00096         m_brush.Get()
00097         );
00098
00099     return false;
00100 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IPhotoGroup.h Source File

  • Hilo C++
  • Hilo

IPhotoGroup.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     interface class IPhoto;
00012
00013     // The IPhotoGroup class defines the interface of the app's photo containers
00014     // (the HubPhotoGroup, MonthGroup, NullPhotoGroup classes). XAML controls
00015     // bind to objects of this type.
00016     [Windows::Foundation::Metadata::WebHostHidden]
00017     public interface class IPhotoGroup
00018     {
00019         property Platform::String^ Title
00020         {
00021             Platform::String^ get();
00022         }
00023
00024         property Windows::Foundation::Collections::IObservableVector<IPhoto^>^ Items
00025         {
00026             Windows::Foundation::Collections::IObservableVector<IPhoto^>^ get();
00027         }
00028     };
00029 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Display.xaml.h Source File

  • Playlist

Display.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Display.xaml.h
00013 // Declaration of the Display class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Display.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Playlists
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Display sealed
00031         {
00032         public:
00033             Display();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void PickPlaylistButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/Utilities.h Source File

  • Globalization preferences

Utilities.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Utilities.cpp
00013 // Declaration of the Utilities class
00014 //
00015
00016 #pragma once
00017
00018 namespace SDKSample
00019 {
00020     namespace GlobalizationPreferencesSample
00021     {
00022         /// <summary>
00023         /// Contains common code used by several scenarios of the sample.
00024         /// </summary>
00025          class Utilities sealed
00026         {
00027             public:
00028                 static Platform::String^ VectorViewToString(Windows::Foundation::Collections::IVectorView<Platform::String^>^ data);
00029         };
00030     };
00031     }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetPrincipalName.xaml.h Source File

  • User domain name

GetPrincipalName.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // GetPrincipalName.xaml.h
00013 // Declaration of the GetPrincipalName class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "GetPrincipalName.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace UserDomainName
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class GetPrincipalName sealed
00031         {
00032         public:
00033             GetPrincipalName();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void GetPrincipalName_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput3.xaml.h Source File

  • Toast notifications
  • C#,C++

ScenarioInput3.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Input.xaml.h
00010 // Declaration of the Scenario3Input class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioInput3.g.h"
00017 #include "MainPage.g.h"
00018
00019 namespace ToastsSampleCPP
00020 {
00021   [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class ScenarioInput3 sealed
00023     {
00024     public:
00025         ScenarioInput3();
00026
00027     protected:
00028         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~ScenarioInput3();
00033
00034     MainPage^ rootPage;
00035         void OutputText(Platform::String^ text);
00036         void Scenario3DisplayToast(Windows::UI::Notifications::ToastTemplateType templateType);
00037         void Scenario3DisplayToastWithStringManipulation(Windows::UI::Notifications::ToastTemplateType templateType);
00038
00039         Windows::UI::Xaml::Controls::TextBlock^ outputText;
00040     };
00041 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/App.xaml.cpp Source File

  • Media capture using capture device

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/CylinderMesh.cpp Source File

  • DirectX 3D shooting game

CylinderMesh.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "CylinderMesh.h"
00010 #include "DirectXSample.h"
00011 #include "ConstantBuffers.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace DirectX;
00015
00016 CylinderMesh::CylinderMesh(_In_ ID3D11Device *device, uint32 segments)
00017 {
00018     D3D11_BUFFER_DESC bd = {0};
00019     D3D11_SUBRESOURCE_DATA initData = {0};
00020
00021     uint32 numVertices = 6 * (segments + 1) + 1;
00022     uint32 numIndices = 3 * segments * 3 * 2;
00023
00024     std::vector<PNTVertex> point(numVertices);
00025     std::vector<uint16> index(numIndices);
00026
00027     uint32 p = 0;
00028     // Top center point (multiple points for texture coordinates).
00029     for (uint32 a = 0; a <= segments; a++)
00030     {
00031         point[p].position = XMFLOAT3(0.0f, 0.0f, 1.0f);
00032         point[p].normal = XMFLOAT3(0.0f, 0.0f, 1.0f);
00033         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 0.0f);
00034         p++;
00035     }
00036     // Top edge of cylinder: Normals point up for lighting of top surface.
00037     for (uint32 a = 0; a <= segments; a++)
00038     {
00039         float angle = static_cast<float>(a) / static_cast<float>(segments) * XM_2PI;
00040         point[p].position = XMFLOAT3(cos(angle), sin(angle), 1.0f);
00041         point[p].normal = XMFLOAT3(0.0f, 0.0f, 1.0f);
00042         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 0.0f);
00043         p++;
00044     }
00045     // Top edge of cylinder: Normals point out for lighting of the side surface.
00046     for (uint32 a = 0; a <= segments; a++)
00047     {
00048         float angle = static_cast<float>(a) / static_cast<float>(segments) * XM_2PI;
00049         point[p].position = XMFLOAT3(cos(angle), sin(angle), 1.0f);
00050         point[p].normal = XMFLOAT3(cos(angle), sin(angle), 0.0f);
00051         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 0.0f);
00052         p++;
00053     }
00054     // Bottom edge of cylinder: Normals point out for lighting of the side surface.
00055     for (uint32 a = 0; a <= segments; a++)
00056     {
00057         float angle = static_cast<float>(a) / static_cast<float>(segments) * XM_2PI;
00058         point[p].position = XMFLOAT3(cos(angle), sin(angle), 0.0f);
00059         point[p].normal = XMFLOAT3(cos(angle), sin(angle), 0.0f);
00060         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 1.0f);
00061         p++;
00062     }
00063     // Bottom edge of cylinder: Normals point down for lighting of the bottom surface.
00064     for (uint32 a = 0; a <= segments; a++)
00065     {
00066         float angle = static_cast<float>(a) / static_cast<float>(segments) * XM_2PI;
00067         point[p].position = XMFLOAT3(cos(angle), sin(angle), 0.0f);
00068         point[p].normal = XMFLOAT3(0.0f, 0.0f, -1.0f);
00069         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 1.0f);
00070         p++;
00071     }
00072     // Bottom center of cylinder: Normals point down for lighting on the bottom surface.
00073     for (uint32 a = 0; a <= segments; a++)
00074     {
00075         point[p].position = XMFLOAT3(0.0f, 0.0f, 0.0f);
00076         point[p].normal = XMFLOAT3(0.0f, 0.0f, -1.0f);
00077         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 1.0f);
00078         p++;
00079     }
00080     m_vertexCount = p;
00081
00082     p = 0;
00083     for (uint16 a = 0; a < 6; a += 2)
00084     {
00085         uint16 p1 = a*(segments + 1);
00086         uint16 p2 = (a+1)*(segments + 1);
00087         for (uint16 b = 0; b < segments; b++)
00088         {
00089             if (a < 4)
00090             {
00091                 index[p] = b + p1;
00092                 index[p+1] = b + p2;
00093                 index[p+2] = b + p2 + 1;
00094                 p = p + 3;
00095             }
00096             if (a > 0)
00097             {
00098                 index[p] = b + p1;
00099                 index[p+1] = b + p2 + 1;
00100                 index[p+2] = b + p1 + 1;
00101                 p = p + 3;
00102             }
00103         }
00104     }
00105     m_indexCount = p;
00106
00107     bd.Usage = D3D11_USAGE_DEFAULT;
00108     bd.ByteWidth = sizeof(PNTVertex) * m_vertexCount;
00109     bd.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00110     bd.CPUAccessFlags = 0;
00111     initData.pSysMem = point.data();
00112     DX::ThrowIfFailed(
00113         device->CreateBuffer(&bd, &initData, &m_vertexBuffer)
00114         );
00115
00116     bd.Usage = D3D11_USAGE_DEFAULT;
00117     bd.ByteWidth = sizeof(uint16) * m_indexCount;
00118     bd.BindFlags = D3D11_BIND_INDEX_BUFFER;
00119     bd.CPUAccessFlags = 0;
00120     initData.pSysMem = index.data();
00121     DX::ThrowIfFailed(
00122         device->CreateBuffer(&bd, &initData, &m_indexBuffer)
00123         );
00124 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/MainPage.xaml.h Source File

  • Media capture using capture device

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ImageRenderer Member List

This is the complete list of members for ImageRenderer, including all inherited members.
__pad0__ | ImageRenderer |
CreateDeviceResources(Microsoft::WRL::ComPtr< ID2D1DeviceContext > d2dContext) | ImageRenderer |
CreateWindowSizeDependentResources(float dpi) | ImageRenderer |
DrawImageAndEffects() | ImageRenderer |
LoadImage(Windows::Storage::Streams::IRandomAccessStream^randomAccessStream) | ImageRenderer |
m_bitmapSourceEffect | ImageRenderer | [private]
m_d2dContext | ImageRenderer | [private]
m_dpi | ImageRenderer | [private]
m_imagePixelSize | ImageRenderer | [private]
m_imageSizeDips | ImageRenderer | [private]
m_imageZoomFactor | ImageRenderer | [private]
m_saturationEffect | ImageRenderer | [private]
m_wicFactory | ImageRenderer | [private]
Reset() | ImageRenderer |
SetEffectIntensity(float value) | ImageRenderer |
UpdateImageZoom() | ImageRenderer | [private]
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::FlipViewData::sealed Member List

This is the complete list of members for SDKSample::FlipViewData::sealed, including all inherited members.
_baseUri | SDKSample::FlipViewData::sealed | [static]
_image | SDKSample::FlipViewData::sealed |
_items | SDKSample::FlipViewData::sealed |
_picture | SDKSample::FlipViewData::sealed |
_PropertyChanged | SDKSample::FlipViewData::sealed |
_title | SDKSample::FlipViewData::sealed |
_type | SDKSample::FlipViewData::sealed |
Add(SampleDataItem^item) | SDKSample::FlipViewData::sealed | [inline]
count | SDKSample::FlipViewData::sealed | [private]
GetCollectionCount() | SDKSample::FlipViewData::sealed | [inline]
GetItemAt(UINT i) | SDKSample::FlipViewData::sealed | [inline]
itemCollection | SDKSample::FlipViewData::sealed | [private]
ItemCollection() | SDKSample::FlipViewData::sealed | [inline]
OnPropertyChanged(Platform::String^propertyName) | SDKSample::FlipViewData::sealed | [inline]
SampleDataItem(Platform::String^title, Platform::String^type, Platform::String^picture) | SDKSample::FlipViewData::sealed |
SampleDataSource() | SDKSample::FlipViewData::sealed | [inline]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Level3 Member List

This is the complete list of members for Level3, including all inherited members.
__pad0__ | Level3 |
Initialize(std::vector< GameObject^> objects) override | Level3 | [virtual]
Initialize(std::vector< GameObject^> objects) override | Level3 | [virtual]
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/MainPage.xaml.h Source File

  • XAML scrolling, panning, and zooming

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

EdgeGestureSample::sealed Member List

This is the complete list of members for EdgeGestureSample::sealed, including all inherited members.
_displayHandlerToken | EdgeGestureSample::sealed | [private]
_frameLoadedToken | EdgeGestureSample::sealed | [private]
_inputFrame | EdgeGestureSample::sealed | [private]
_inputFrameLoadedToken | EdgeGestureSample::sealed | [private]
_layoutHandlerToken | EdgeGestureSample::sealed | [private]
_logicalDpiChangedToken | EdgeGestureSample::sealed | [private]
_outputFrame | EdgeGestureSample::sealed | [private]
_outputFrameLoadedToken | EdgeGestureSample::sealed | [private]
_pageLoadedHandlerToken | EdgeGestureSample::sealed | [private]
_scenariosFrame | EdgeGestureSample::sealed | [private]
App() | EdgeGestureSample::sealed |
CheckResolutionAndViewState() | EdgeGestureSample::sealed | [private]
ConvertResolution(ResolutionScale scale) | EdgeGestureSample::sealed |
ConvertViewState(ApplicationViewState state) | EdgeGestureSample::sealed |
DisplayProperties_LogicalDpiChanged(Object^sender) | EdgeGestureSample::sealed | [private]
DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^frame) | EdgeGestureSample::sealed |
EdgeGestureCanceledEventToken | EdgeGestureSample::sealed | [private]
EdgeGestureCompletedEventToken | EdgeGestureSample::sealed | [private]
EdgeGestureStartingEventToken | EdgeGestureSample::sealed | [private]
Footer_Click(Object^sender, RoutedEventArgs^e) | EdgeGestureSample::sealed | [private]
InitializeEdgeGestureHandlers() | EdgeGestureSample::sealed | [private]
InitializeEdgeGestureHandlers() | EdgeGestureSample::sealed | [private]
inputFrameNavigated(Object^sender, NavigationEventArgs^e) | EdgeGestureSample::sealed | [private]
MainPage() | EdgeGestureSample::sealed |
NotifyUser(String^strMessage, NotifyType type) | EdgeGestureSample::sealed |
OnCanceled(EdgeGesture^sender, EdgeGestureEventArgs^e) | EdgeGestureSample::sealed | [private]
OnCanceled(EdgeGesture^sender, EdgeGestureEventArgs^e) | EdgeGestureSample::sealed | [private]
OnCompleted(EdgeGesture^sender, EdgeGestureEventArgs^e) | EdgeGestureSample::sealed | [private]
OnCompleted(EdgeGesture^sender, EdgeGestureEventArgs^e) | EdgeGestureSample::sealed | [private]
OnContextMenu(Object^sender, RightTappedRoutedEventArgs^e) | EdgeGestureSample::sealed | [private]
OnContextMenu(Object^sender, RightTappedRoutedEventArgs^e) | EdgeGestureSample::sealed | [private]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | EdgeGestureSample::sealed | [virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | EdgeGestureSample::sealed | [protected, virtual]
OnStarting(EdgeGesture^sender, EdgeGestureEventArgs^e) | EdgeGestureSample::sealed | [private]
OnStarting(EdgeGesture^sender, EdgeGestureEventArgs^e) | EdgeGestureSample::sealed | [private]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | EdgeGestureSample::sealed | [virtual]
OutputFrameLoaded | EdgeGestureSample::sealed |
outputFrameNavigated(Object^sender, NavigationEventArgs^e) | EdgeGestureSample::sealed | [private]
outputText | EdgeGestureSample::sealed | [private]
Page_Loaded(Object^sender, RoutedEventArgs^e) | EdgeGestureSample::sealed | [private]
Page_SizeChanged(Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | EdgeGestureSample::sealed | [private]
RightClickEventToken | EdgeGestureSample::sealed | [private]
RightClickOverride(Object^sender, RightTappedRoutedEventArgs^e) | EdgeGestureSample::sealed | [private]
RightClickRegion | EdgeGestureSample::sealed | [private]
RightClickRegionEventToken | EdgeGestureSample::sealed | [private]
rootPage | EdgeGestureSample::sealed | [private]
rootPage_InputFrameLoaded(Object^sender, Object^e) | EdgeGestureSample::sealed | [private]
rootPage_InputFrameLoaded(Object^sender, Object^e) | EdgeGestureSample::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | EdgeGestureSample::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | EdgeGestureSample::sealed | [private]
ScenarioInput1() | EdgeGestureSample::sealed |
ScenarioInput2() | EdgeGestureSample::sealed |
ScenarioList() | EdgeGestureSample::sealed |
ScenarioOutput1() | EdgeGestureSample::sealed |
ScenarioOutput2() | EdgeGestureSample::sealed |
Scenarios_SelectionChanged(Object^sender, SelectionChangedEventArgs^e) | EdgeGestureSample::sealed | [protected]
SetFeatureName(Platform::String^strFeature) | EdgeGestureSample::sealed | [private]
~MainPage() | EdgeGestureSample::sealed | [private]
~ScenarioInput1() | EdgeGestureSample::sealed | [private]
~ScenarioInput2() | EdgeGestureSample::sealed | [private]
~ScenarioList() | EdgeGestureSample::sealed | [private]
~ScenarioOutput1() | EdgeGestureSample::sealed | [private]
~ScenarioOutput2() | EdgeGestureSample::sealed | [private]
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::BackgroundTransfer::GuidComparer Member List

This is the complete list of members for SDKSample::BackgroundTransfer::GuidComparer, including all inherited members.
operator()(const Platform::Guid &lhs, const Platform::Guid &rhs) const SDKSample::BackgroundTransfer::GuidComparer [inline]
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/common/LayoutAwarePage.cpp Source File

  • Windows account authorization
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

WaveEffect::Vertex Member List

This is the complete list of members for WaveEffect::Vertex, including all inherited members.
x | WaveEffect::Vertex
y | WaveEffect::Vertex
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/common/suspensionmanager.cpp Source File

  • App package information
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeCommunications.xaml.h Source File

  • Playback Manager Companion

StreamTypeCommunications.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // StreamTypeCommunications.xaml.h
00013 // Declaration of the StreamTypeCommunications class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "StreamTypeCommunications.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "PlaybackControl.xaml.h"
00022
00023 namespace SDKSample
00024 {
00025     namespace PlaybackManager2
00026     {
00027         /// <summary>
00028         /// An empty page that can be used on its own or navigated to within a Frame.
00029         /// </summary>
00030       [Windows::Foundation::Metadata::WebHostHidden]
00031         public ref class StreamTypeCommunications sealed
00032         {
00033         public:
00034             StreamTypeCommunications();
00035
00036         protected:
00037             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038         private:
00039             MainPage^ rootPage;
00040             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/common/LayoutAwarePage.cpp Source File

  • Calendar details and math
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/pch.cpp Source File

  • StorageDataSource and GetVirtualizedFilesVector

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWidePeekImageCollection06 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWidePeekImageCollection06, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
ImageMain | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 |
Images | NotificationsExtensions::NotificationBase |
ImageSecondary | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 |
ImageSmallColumn1Row1 | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 |
ImageSmallColumn1Row2 | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 |
ImageSmallColumn2Row1 | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 |
ImageSmallColumn2Row2 | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextFields | NotificationsExtensions::NotificationBase |
TextHeadingWrap | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWidePeekImageCollection06() | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 | [inline]
TileWidePeekImageCollection06() | NotificationsExtensions::TileContent::TileWidePeekImageCollection06 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DirectXSample.h Source File

  • Direct3D tutorial
  • Lesson5.Components

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/MainPagePicker.xaml.cpp Source File

  • Contact Picker app

MainPagePicker.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPagePicker.xaml.cpp
00013 // Implementation of the MainPagePicker.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPagePicker.xaml.h"
00018 #include "Constants.h"
00019 #include "App.xaml.h"
00020
00021 #include <collection.h>
00022
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::Foundation;
00026 using namespace Platform;
00027 using namespace ContactPicker;
00028 using namespace CppSamplesUtils;
00029 using namespace Windows::UI::Xaml::Navigation;
00030 using namespace Windows::UI::Xaml::Interop;
00031 using namespace Windows::Graphics::Display;
00032 using namespace Windows::UI::ViewManagement;
00033
00034
00035 MainPagePicker^ MainPagePicker::Current = nullptr;
00036
00037 MainPagePicker::MainPagePicker()
00038 {
00039     InitializeComponent();
00040
00041     // This frame is hidden, meaning it is never shown.  It is simply used to load
00042     // each scenario page and then pluck out the input and output sections and
00043     // place them into the UserControls on the main page.
00044     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00045     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00046     LayoutRoot->Children->Append(HiddenFrame);
00047
00048     // Populate the sample title from the constant in the GlobalVariables.cs file.
00049     SetContactPicker(FEATURE_NAME);
00050
00051     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPagePicker::MainPagePicker_SizeChanged);
00052     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPagePicker::Scenarios_SelectionChanged);
00053
00054     MainPagePicker::Current = this;
00055     autoSizeInputSectionWhenSnapped = true;
00056 }
00057
00058 MainPagePicker::~MainPagePicker()
00059 {
00060 }
00061
00062 /// <summary>
00063 /// Invoked when this page is about to be displayed in a Frame.
00064 /// </summary>
00065 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00066 /// property is typically used to configure the page.</param>
00067 void MainPagePicker::OnNavigatedTo(NavigationEventArgs^ e)
00068 {
00069     PopulateScenarios();
00070     InvalidateViewState();
00071 }
00072
00073 /// <summary>
00074 /// We need to handle SizeChanged so that we can make the sample layout property
00075 /// in the various layouts.
00076 /// </summary>
00077 /// <param name="sender"></param>
00078 /// <param name="e"></param>
00079 void MainPagePicker::MainPagePicker_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00080 {
00081     InvalidateSize();
00082     MainPagePickerSizeChangedEventArgs^ args = ref new MainPagePickerSizeChangedEventArgs();
00083     args->ViewState = ApplicationView::Value;
00084     MainPagePickerResized(this, args);
00085
00086 }
00087
00088 void MainPagePicker::InvalidateSize()
00089 {
00090     // Get the window width
00091     double windowWidth = this->ActualWidth;
00092
00093     if (windowWidth != 0.0)
00094     {
00095
00096         // Get the width of the ListBox.
00097         double listBoxWidth = Scenarios->ActualWidth;
00098
00099         // Is the ListBox using any margins that we need to consider?
00100         double listBoxMarginLeft = Scenarios->Margin.Left;
00101         double listBoxMarginRight = Scenarios->Margin.Right;
00102
00103         // Figure out how much room is left after considering the list box width
00104         double availableWidth = windowWidth - listBoxWidth;
00105
00106         // Is the top most child using margins?
00107         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00108         double layoutRootMarginRight = ContentRoot->Margin.Right;
00109
00110         // We have different widths to use depending on the view state
00111         if (ApplicationView::Value != ApplicationViewState::Snapped)
00112         {
00113             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00114             // and the LayoutRoot's margins
00115             InputSection->Width = ((availableWidth) -
00116                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00117         }
00118         else
00119         {
00120             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00121             if (autoSizeInputSectionWhenSnapped)
00122             {
00123                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00124             }
00125         }
00126     }
00127     InvalidateViewState();
00128 }
00129
00130 void MainPagePicker::InvalidateViewState()
00131 {
00132     // Are we going to snapped mode?
00133     if (ApplicationView::Value == ApplicationViewState::Snapped)
00134     {
00135         Grid::SetRow(DescriptionText, 3);
00136         Grid::SetColumn(DescriptionText, 0);
00137
00138         Grid::SetRow(InputSection, 4);
00139         Grid::SetColumn(InputSection, 0);
00140
00141         Grid::SetRow(FooterPanel, 2);
00142         Grid::SetColumn(FooterPanel, 0);
00143     }
00144     else
00145     {
00146         Grid::SetRow(DescriptionText, 1);
00147         Grid::SetColumn(DescriptionText, 1);
00148
00149         Grid::SetRow(InputSection, 2);
00150         Grid::SetColumn(InputSection, 1);
00151
00152         Grid::SetRow(FooterPanel, 1);
00153         Grid::SetColumn(FooterPanel, 1);
00154     }
00155
00156 }
00157
00158 #pragma optimize("", off)
00159 void MainPagePicker::PopulateScenarios()
00160 {
00161     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00162
00163     // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00164     for (unsigned int i = 0; i < scenarios->Length; ++i)
00165     {
00166         Scenario s = scenarios[i];
00167         ListBoxItem^ item = ref new ListBoxItem();
00168         item->Name = s.ClassName;
00169         item->Content = (i + 1).ToString() + ") " + s.Title;
00170         ScenarioList->Append(item);
00171     }
00172
00173     // Bind the ListBox to the scenario list.
00174     Scenarios->ItemsSource = ScenarioList;
00175     Scenarios->SelectedIndex = 0;
00176 }
00177 #pragma optimize("", on)
00178
00179 /// <summary>
00180 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00181 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00182 /// and output sections into the respective UserControl on the main page.
00183 /// </summary>
00184 /// <param name="scenarioName"></param>
00185 void MainPagePicker::LoadScenario(String^ scenarioName)
00186 {
00187     autoSizeInputSectionWhenSnapped = true;
00188
00189     // Load the ScenarioX.xaml file into the Frame.
00190     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00191     HiddenFrame->Navigate(scenarioType, this);
00192
00193     // Get the top element, the Page, so we can look up the elements
00194     // that represent the input and output sections of the ScenarioX file.
00195     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00196
00197     // Get each element.
00198     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00199     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00200
00201     if (input == nullptr)
00202     {
00203         // Malformed input section.
00204         NotifyUser("Cannot load scenario input section for " + scenarioName +
00205             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00206         return;
00207     }
00208
00209     if (output == nullptr)
00210     {
00211         // Malformed output section.
00212         NotifyUser("Cannot load scenario output section for " + scenarioName +
00213             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00214         return;
00215     }
00216
00217     // Find the LayoutRoot which parents the input and output sections in the main page.
00218     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00219
00220     if (panel != nullptr)
00221     {
00222         unsigned int index = 0;
00223         UIElementCollection^ collection = panel->Children;
00224
00225         // Get rid of the content that is currently in the intput and output sections.
00226         collection->IndexOf(input, &index);
00227         collection->RemoveAt(index);
00228
00229         collection->IndexOf(output, &index);
00230         collection->RemoveAt(index);
00231
00232         // Populate the input and output sections with the newly loaded content.
00233         InputSection->Content = input;
00234         OutputSection->Content = output;
00235
00236         ScenarioLoaded(this, nullptr);
00237     }
00238     else
00239     {
00240         // Malformed Scenario file.
00241         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00242             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00243     }
00244 }
00245
00246 void MainPagePicker::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00247 {
00248     if (Scenarios->SelectedItem != nullptr)
00249     {
00250         NotifyUser("", NotifyType::StatusMessage);
00251
00252         int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00253         SuspensionManager::SessionState()->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00254
00255         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00256         InvalidateSize();
00257     }
00258 }
00259
00260 void MainPagePicker::SetContactPicker(String^ strFeature)
00261 {
00262     ContactPicker->Text = strFeature;
00263 }
00264
00265 void MainPagePicker::NotifyUser(String^ strMessage, NotifyType type)
00266 {
00267     switch (type)
00268     {
00269     case NotifyType::StatusMessage:
00270         // Use the status message style.
00271         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00272         break;
00273     case NotifyType::ErrorMessage:
00274         // Use the error message style.
00275         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00276         break;
00277     default:
00278         break;
00279     }
00280     StatusBlock->Text = strMessage;
00281
00282     // Collapsed the StatusBlock if it has no text to conserve real estate.
00283     if (StatusBlock->Text != "")
00284         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00285     else
00286         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00287 }
00288
00289 void MainPagePicker::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00290 {
00291     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00292     Windows::System::Launcher::LaunchUriAsync(uri);
00293 }
00294
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/CompositeModes.cpp Source File

  • Direct2D composite effect modes

CompositeModes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "CompositeModes.h"
00010 #include <math.h>
00011
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::ApplicationModel;
00014 using namespace Windows::ApplicationModel::Core;
00015 using namespace Windows::ApplicationModel::Activation;
00016 using namespace Windows::UI::Core;
00017 using namespace Windows::UI::Input;
00018 using namespace Windows::UI::ViewManagement;
00019 using namespace Windows::System;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::Storage;
00024
00025 static const float GutterSize = 24.0f;
00026 static const float HeadingHeight = 36.0f;
00027 static const float LabelHeight = 16.0f;
00028 static const unsigned int BlendModesLength = 26;
00029 static const unsigned int CompositeModesLength = 11;
00030
00031 // We divide the screen into a virtual grid to fit each blend/composite mode.
00032 // Note that GridColumns = GridCompositeColumns + GridBlendColumns,
00033 // but the same is not true for rows.
00034 static const unsigned int GridRows = 6;
00035 static const unsigned int GridColumns = 7;
00036
00037 // We reserve a 2x6 section of the grid to display composite modes.
00038 static const unsigned int GridCompositeRows = 6;
00039 static const unsigned int GridCompositeColumns = 2;
00040
00041 // We reserve a 5x6 section of the grid to display blend modes.
00042 static const unsigned int GridBlendRows = 6;
00043 static const unsigned int GridBlendColumns = 5;
00044
00045 CompositeModes::CompositeModes() :
00046     m_alpha(1.0f),
00047     m_drawEnabled(true),
00048     m_bitmapPixelSize(D2D1::SizeU()),
00049     m_imageSize(D2D1::SizeF()),
00050     m_contextSize(D2D1::SizeF()),
00051     m_cellSize(D2D1::SizeF())
00052 {
00053 }
00054
00055 CompositeModes::~CompositeModes()
00056 {
00057     if (m_captionLayouts != nullptr)
00058     {
00059         delete[] m_captionLayouts;
00060     }
00061 }
00062
00063 void CompositeModes::CreateDeviceIndependentResources()
00064 {
00065     DirectXBase::CreateDeviceIndependentResources();
00066
00067     DX::ThrowIfFailed(
00068         m_dwriteFactory->CreateTextFormat(
00069             L"Segoe UI",
00070             nullptr,
00071             DWRITE_FONT_WEIGHT_LIGHT,
00072             DWRITE_FONT_STYLE_NORMAL,
00073             DWRITE_FONT_STRETCH_NORMAL,
00074             HeadingHeight,
00075             L"en-US", // locale
00076             &m_headingTextFormat
00077             )
00078         );
00079
00080     DX::ThrowIfFailed(
00081         m_dwriteFactory->CreateTextFormat(
00082             L"Segoe UI",
00083             nullptr,
00084             DWRITE_FONT_WEIGHT_LIGHT,
00085             DWRITE_FONT_STYLE_NORMAL,
00086             DWRITE_FONT_STRETCH_NORMAL,
00087             LabelHeight,
00088             L"en-US", // locale
00089             &m_textFormat
00090             )
00091         );
00092
00093     DX::ThrowIfFailed(
00094         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00095         );
00096
00097     DX::ThrowIfFailed(
00098         m_dwriteFactory->CreateTextFormat(
00099             L"Segoe UI",
00100             nullptr,
00101             DWRITE_FONT_WEIGHT_LIGHT,
00102             DWRITE_FONT_STYLE_NORMAL,
00103             DWRITE_FONT_STRETCH_NORMAL,
00104             20.0f,
00105             L"en-us", // locale
00106             &m_snappedViewFormat
00107             )
00108         );
00109
00110     DX::ThrowIfFailed(
00111         m_snappedViewFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00112         );
00113
00114     DX::ThrowIfFailed(
00115         m_snappedViewFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00116         );
00117
00118     m_blendModeNames = ref new Platform::Array<Platform::String^>(BlendModesLength);
00119     m_blendModeNames[0]  = "Multiply";
00120     m_blendModeNames[1]  = "Screen";
00121     m_blendModeNames[2]  = "Darken";
00122     m_blendModeNames[3]  = "Lighten";
00123     m_blendModeNames[4]  = "Dissolve";
00124     m_blendModeNames[5]  = "Color Burn";
00125     m_blendModeNames[6]  = "Linear Burn";
00126     m_blendModeNames[7]  = "Darker Color";
00127     m_blendModeNames[8]  = "Lighter Color";
00128     m_blendModeNames[9]  = "Color Dodge";
00129     m_blendModeNames[10] = "Linear Dodge";
00130     m_blendModeNames[11] = "Overlay";
00131     m_blendModeNames[12] = "Soft Light";
00132     m_blendModeNames[13] = "Hard Light";
00133     m_blendModeNames[14] = "Vivid Light";
00134     m_blendModeNames[15] = "Linear Light";
00135     m_blendModeNames[16] = "Pin Light";
00136     m_blendModeNames[17] = "Hard Mix";
00137     m_blendModeNames[18] = "Difference";
00138     m_blendModeNames[19] = "Exclusion";
00139     m_blendModeNames[20] = "Hue";
00140     m_blendModeNames[21] = "Saturation";
00141     m_blendModeNames[22] = "Color";
00142     m_blendModeNames[23] = "Luminosity";
00143     m_blendModeNames[24] = "Subtract";
00144     m_blendModeNames[25] = "Division";
00145
00146     m_compositeModeNames = ref new Platform::Array<Platform::String^>(CompositeModesLength);
00147     m_compositeModeNames[0]  = "Source Over";
00148     m_compositeModeNames[1]  = "Destination Over";
00149     m_compositeModeNames[2]  = "Source In";
00150     m_compositeModeNames[3]  = "Destination In";
00151     m_compositeModeNames[4]  = "Source Out";
00152     m_compositeModeNames[5]  = "Destination Out";
00153     m_compositeModeNames[6]  = "Source Atop";
00154     m_compositeModeNames[7]  = "Destination Atop";
00155     m_compositeModeNames[8]  = "Xor";
00156     m_compositeModeNames[9]  = "Plus";
00157     m_compositeModeNames[10] = "Source Copy";
00158     // There are two extra modes we are not covering in this sample: bounded source copy
00159     // and mask invert. Bounded source copy looks just like source copy but limits the
00160     // copy to the bounds of the source rather than the union of the source and destination.
00161     // Mask invert is meant for caret drawing and appears much like an XOR.
00162
00163     // Create the apple bitmap source.
00164     ComPtr<IWICBitmapDecoder> decoder;
00165     DX::ThrowIfFailed(
00166         m_wicFactory->CreateDecoderFromFilename(
00167             L"apple.png",
00168             nullptr,
00169             GENERIC_READ,
00170             WICDecodeMetadataCacheOnDemand,
00171             &decoder
00172             )
00173         );
00174
00175     ComPtr<IWICBitmapFrameDecode> frame;
00176     DX::ThrowIfFailed(
00177         decoder->GetFrame(0, &frame)
00178         );
00179
00180     DX::ThrowIfFailed(
00181         m_wicFactory->CreateFormatConverter(&m_appleBitmap)
00182         );
00183
00184     DX::ThrowIfFailed(
00185         m_appleBitmap->Initialize(
00186             frame.Get(),
00187             GUID_WICPixelFormat32bppPBGRA,
00188             WICBitmapDitherTypeNone,
00189             nullptr,
00190             0.0f,
00191             WICBitmapPaletteTypeCustom  // Premultiplied BGRA has no paletting, so this is ignored.
00192             )
00193         );
00194
00195     // Create the banana bitmap source.
00196     DX::ThrowIfFailed(
00197         m_wicFactory->CreateDecoderFromFilename(
00198             L"banana.png",
00199             nullptr,
00200             GENERIC_READ,
00201             WICDecodeMetadataCacheOnDemand,
00202             &decoder
00203             )
00204         );
00205
00206     DX::ThrowIfFailed(
00207         decoder->GetFrame(0, &frame)
00208         );
00209
00210     DX::ThrowIfFailed(
00211         m_wicFactory->CreateFormatConverter(&m_bananaBitmap)
00212         );
00213
00214     DX::ThrowIfFailed(
00215         m_bananaBitmap->Initialize(
00216             frame.Get(),
00217             GUID_WICPixelFormat32bppPBGRA,
00218             WICBitmapDitherTypeNone,
00219             nullptr,
00220             0.0f,
00221             WICBitmapPaletteTypeCustom  // Premultiplied BGRA has no paletting, so this is ignored.
00222             )
00223         );
00224
00225     // Store the image size in pixels (the apple and banana images are assumed to be the same size).
00226     // This remains constant regardless of the app's DPI.
00227     UINT width;
00228     UINT height;
00229     DX::ThrowIfFailed(
00230         m_bananaBitmap->GetSize(&width, &height)
00231         );
00232
00233     m_bitmapPixelSize = D2D1::SizeU(width, height);
00234 }
00235
00236 void CompositeModes::CreateDeviceResources()
00237 {
00238     DirectXBase::CreateDeviceResources();
00239
00240     m_sampleOverlay = ref new SampleOverlay();
00241
00242     m_sampleOverlay->Initialize(
00243         m_d2dDevice.Get(),
00244         m_d2dContext.Get(),
00245         m_wicFactory.Get(),
00246         m_dwriteFactory.Get(),
00247         "Direct2D composite and blend effects sample"
00248         );
00249
00250     DX::ThrowIfFailed(
00251         m_d2dContext->CreateSolidColorBrush(
00252             D2D1::ColorF(D2D1::ColorF::White),
00253             &m_whiteBrush
00254             )
00255         );
00256
00257     DX::ThrowIfFailed(
00258         m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_appleEffect)
00259         );
00260
00261     DX::ThrowIfFailed(
00262         m_appleEffect->SetValue(
00263             D2D1_BITMAPSOURCE_PROP_INTERPOLATION_MODE,
00264             D2D1_BITMAPSOURCE_INTERPOLATION_MODE_CUBIC
00265             )
00266         );
00267
00268     // The property system expects TRUE and FALSE rather than true or false to ensure that
00269     // the size of the value is consistent regardless of architecture.
00270     DX::ThrowIfFailed(
00271         m_appleEffect->SetValue(D2D1_PROPERTY_CACHED, TRUE)
00272         );
00273
00274     DX::ThrowIfFailed(
00275         m_appleEffect->SetValue(D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE, m_appleBitmap.Get())
00276         );
00277
00278     DX::ThrowIfFailed(
00279         m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_bananaEffect)
00280         );
00281
00282     DX::ThrowIfFailed(
00283         m_bananaEffect->SetValue(
00284             D2D1_BITMAPSOURCE_PROP_INTERPOLATION_MODE,
00285             D2D1_BITMAPSOURCE_INTERPOLATION_MODE_CUBIC
00286             )
00287         );
00288
00289     DX::ThrowIfFailed(
00290         m_bananaEffect->SetValue(D2D1_PROPERTY_CACHED, TRUE)
00291         );
00292
00293     DX::ThrowIfFailed(
00294         m_bananaEffect->SetValue(D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE, m_bananaBitmap.Get())
00295         );
00296
00297     // Create and initialize the composite and blend effects.
00298     DX::ThrowIfFailed(
00299         m_d2dContext->CreateEffect(CLSID_D2D1Composite, &m_compositeEffect)
00300         );
00301
00302     DX::ThrowIfFailed(
00303         m_d2dContext->CreateEffect(CLSID_D2D1Blend, &m_blendEffect)
00304         );
00305
00306     // Create the effects that will set the alpha of each bitmap.
00307     DX::ThrowIfFailed(
00308         m_d2dContext->CreateEffect(CLSID_D2D1ColorMatrix, &m_appleAlphaEffect)
00309         );
00310
00311     DX::ThrowIfFailed(
00312         m_d2dContext->CreateEffect(CLSID_D2D1ColorMatrix, &m_bananaAlphaEffect)
00313         );
00314
00315     // Wire up the graph. Note that the color matrix effects are used as the inputs for
00316     // both the blend and composite effects, so all we have to do is draw one or the other.
00317     m_appleAlphaEffect->SetInputEffect(0, m_appleEffect.Get());
00318     m_bananaAlphaEffect->SetInputEffect(0, m_bananaEffect.Get());
00319     m_blendEffect->SetInputEffect(0, m_appleAlphaEffect.Get());
00320     m_blendEffect->SetInputEffect(1, m_bananaAlphaEffect.Get());
00321     m_compositeEffect->SetInputEffect(0, m_appleAlphaEffect.Get());
00322     m_compositeEffect->SetInputEffect(1, m_bananaAlphaEffect.Get());
00323 }
00324
00325 void CompositeModes::CreateWindowSizeDependentResources()
00326 {
00327     DirectXBase::CreateWindowSizeDependentResources();
00328
00329     m_contextSize = m_d2dContext->GetSize();
00330
00331     // m_imageSize is in DIPs and changes depending on the app DPI.
00332     // This app ignores the source bitmap's DPI and assumes it is 96.
00333     m_imageSize = D2D1::SizeF(
00334         static_cast<float>(m_bitmapPixelSize.width) * 96.0f / m_dpi,
00335         static_cast<float>(m_bitmapPixelSize.height) * 96.0f / m_dpi
00336         );
00337
00338     // The sample will render its content into a square area in both landscape and
00339     // portrait orientations. Make the square as large as the smallest dimension available.
00340     float minDimension = min(
00341         m_contextSize.width,
00342         m_contextSize.height - m_sampleOverlay->GetTitleHeightInDips()
00343         );
00344
00345     // m_horizontalOffset is used for centering the content to be rendered
00346     m_horizontalOffset = (m_contextSize.width - minDimension) / 2.0f;
00347
00348     // We want to divide the screen into cells in which each mode demonstration will sit.
00349     // m_cellSize stores the dimensions of a single cell. The width and height dimensions
00350     // are adjusted by the space taken up by the sample overlay, heading text, and gutters.
00351     m_cellSize = D2D1::SizeF(
00352         (minDimension - 4 * HeadingHeight - GutterSize) / GridColumns,
00353         (minDimension - GutterSize) / GridRows
00354         );
00355
00356     float imageScaleSize = m_cellSize.width / m_imageSize.width;
00357     if (m_cellSize.height < m_cellSize.width)
00358     {
00359         imageScaleSize = m_cellSize.height / m_imageSize.height;
00360     }
00361
00362     DX::ThrowIfFailed(
00363         m_appleEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, D2D1::Point2F(imageScaleSize, imageScaleSize))
00364         );
00365
00366     DX::ThrowIfFailed(
00367         m_bananaEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, D2D1::Point2F(imageScaleSize, imageScaleSize))
00368         );
00369
00370     if (m_captionLayouts != nullptr)
00371     {
00372         delete[] m_captionLayouts;
00373     }
00374
00375     m_captionLayouts = new IDWriteTextLayout*[CompositeModesLength + BlendModesLength];
00376     for (int i = 0; i < CompositeModesLength; i++)
00377     {
00378         DX::ThrowIfFailed(
00379             m_dwriteFactory->CreateTextLayout(
00380                 m_compositeModeNames[i]->Data(),
00381                 m_compositeModeNames[i]->Length(),
00382                 m_textFormat.Get(),
00383                 m_cellSize.width,
00384                 m_cellSize.height,
00385                 &m_captionLayouts[i]
00386                 )
00387             );
00388     }
00389
00390     for (int i = CompositeModesLength; i < CompositeModesLength + BlendModesLength; i++)
00391     {
00392         DX::ThrowIfFailed(
00393             m_dwriteFactory->CreateTextLayout(
00394                 m_blendModeNames[i - CompositeModesLength]->Data(),
00395                 m_blendModeNames[i - CompositeModesLength]->Length(),
00396                 m_textFormat.Get(),
00397                 m_cellSize.width,
00398                 m_cellSize.height,
00399                 &m_captionLayouts[i]
00400                 )
00401             );
00402     }
00403
00404     Platform::String^ compositeModes = "Composite modes";
00405     DX::ThrowIfFailed(
00406         m_dwriteFactory->CreateTextLayout(
00407             compositeModes->Data(),
00408             compositeModes->Length(),
00409             m_headingTextFormat.Get(),
00410             m_contextSize.height,
00411             m_contextSize.width,
00412             &m_compositeModeTextLayout
00413             )
00414         );
00415
00416     Platform::String^ blendModes = "Blend modes";
00417     DX::ThrowIfFailed(
00418         m_dwriteFactory->CreateTextLayout(
00419             blendModes->Data(),
00420             blendModes->Length(),
00421             m_headingTextFormat.Get(),
00422             m_contextSize.height,
00423             m_contextSize.width,
00424             &m_blendModeTextLayout
00425             )
00426         );
00427 }
00428
00429 void CompositeModes::Render()
00430 {
00431     m_d2dContext->BeginDraw();
00432
00433     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));
00434     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00435
00436     if (m_drawEnabled)
00437     {
00438         // Draw a virtual 2x6 grid of the composite mode examples. There is room for 12 examples but only
00439         // 11 composite modes are shown, so we ignore the additional cells.
00440         for (int i = 0; i < GridCompositeColumns; i++)
00441         {
00442             for (int j = 0; j < GridCompositeRows; j++)
00443             {
00444                 if (j * GridCompositeColumns + i <= CompositeModesLength - 1)
00445                 {
00446                     // The grid must be offset to account for the space taken up by the sample overlay and the
00447                     // "Composite Modes" heading text.
00448                     float left = m_cellSize.width * i + 2 * HeadingHeight + m_horizontalOffset;
00449                     float top = m_cellSize.height * j + m_sampleOverlay->GetTitleHeightInDips() + LabelHeight;
00450
00451                     // Note we're setting a value as an integer rather than using the enumeration. While
00452                     // we recommend using the actual enumeration values for properties, they are simply
00453                     // integers and automated systems can iterate through them like integers.
00454                     DX::ThrowIfFailed(
00455                         m_compositeEffect->SetValue(D2D1_COMPOSITE_PROP_MODE, j * GridCompositeColumns + i)
00456                         );
00457
00458                     // Draw the image in the top-left corner of the cell.
00459                     m_d2dContext->DrawImage(
00460                         m_compositeEffect.Get(),
00461                         D2D1::Point2F(left, top),
00462                         D2D1::RectF(0.0f, 0.0f, m_cellSize.width, m_cellSize.height)
00463                         );
00464                 }
00465             }
00466         }
00467
00468         // Now we draw a the grid of the blend mode examples.
00469         for (int i = 0; i < GridBlendColumns; i++)
00470         {
00471             for (int j = 0; j < GridBlendRows; j++)
00472             {
00473                 // Again, there is room for 30 examples but only 26 blend modes are shown, so
00474                 // we ignore the additional cells.
00475                 if (j * GridBlendColumns + i <= BlendModesLength - 1)
00476                 {
00477                     // The grid must be offset to account for the space taken up by the sample overlay and the
00478                     // composite modes grid, as well as the "Blend Modes" heading text.
00479                     float left = m_cellSize.width * (i + GridCompositeColumns) + 4 * HeadingHeight + m_horizontalOffset;
00480                     float top = m_cellSize.height * j + m_sampleOverlay->GetTitleHeightInDips() + LabelHeight;
00481                     DX::ThrowIfFailed(
00482                         m_blendEffect->SetValue(D2D1_BLEND_PROP_MODE, j * GridBlendColumns + i)
00483                         );
00484
00485                     m_d2dContext->DrawImage(
00486                         m_blendEffect.Get(),
00487                         D2D1::Point2F(left, top),
00488                         D2D1::RectF(0.0f, 0.0f, m_cellSize.width, m_cellSize.height)
00489                         );
00490                 }
00491             }
00492         }
00493
00494         // As a performance optimization, we group all of the Direct2D Effects drawing operations
00495         // together, and draw the text afterwards.
00496         for (int i = 0; i < GridCompositeColumns; i++)
00497         {
00498             for (int j = 0; j < GridCompositeRows; j++)
00499             {
00500                 if (j * GridCompositeColumns + i <= CompositeModesLength - 1)
00501                 {
00502                     float left = m_cellSize.width * i + 2 * HeadingHeight + m_horizontalOffset;
00503                     float top = m_cellSize.height * j + m_sampleOverlay->GetTitleHeightInDips();
00504
00505                     m_d2dContext->DrawTextLayout(
00506                         D2D1::Point2F(left, top),
00507                         m_captionLayouts[j * GridCompositeColumns + i],
00508                         m_whiteBrush.Get()
00509                         );
00510                 }
00511             }
00512         }
00513
00514         for (int i = 0; i < GridBlendColumns; i++)
00515         {
00516             for (int j = 0; j < GridBlendRows; j++)
00517             {
00518                 if (j * GridBlendColumns + i <= BlendModesLength - 1)
00519                 {
00520                     float left = m_cellSize.width * (i + GridCompositeColumns) + 4 * HeadingHeight + m_horizontalOffset;
00521                     float top = m_cellSize.height * j + m_sampleOverlay->GetTitleHeightInDips();
00522
00523                     m_d2dContext->DrawTextLayout(
00524                         D2D1::Point2F(left, top),
00525                         m_captionLayouts[j * GridBlendColumns + i + CompositeModesLength],
00526                         m_whiteBrush.Get()
00527                         );
00528                 }
00529             }
00530         }
00531
00532         // Draw the "Blend Modes" and "Composite Modes" labels vertically.
00533         m_d2dContext->SetTransform(
00534             D2D1::Matrix3x2F::Rotation(-90.0f) *
00535             D2D1::Matrix3x2F::Translation(0, m_cellSize.height * GridRows / 2.0f + m_sampleOverlay->GetTitleHeightInDips())
00536             );
00537
00538         m_d2dContext->DrawTextLayout(
00539             D2D1::Point2F(0.0f, 0.5f * HeadingHeight + m_horizontalOffset),
00540             m_compositeModeTextLayout.Get(),
00541             m_whiteBrush.Get()
00542             );
00543
00544         m_d2dContext->DrawTextLayout(
00545             D2D1::Point2F(0.0f, m_cellSize.width * (GridCompositeColumns) + 2.5f * HeadingHeight + m_horizontalOffset),
00546             m_blendModeTextLayout.Get(),
00547             m_whiteBrush.Get()
00548             );
00549     }
00550     else // The blend/composite mode images are not drawn in the snapped-state.
00551     {
00552         Platform::String^ message = "This sample does not support snapped view.";
00553
00554         m_d2dContext->DrawText(
00555             message->Data(),
00556             message->Length(),
00557             m_snappedViewFormat.Get(),
00558             D2D1::RectF(0, 0, m_contextSize.width, m_contextSize.height),
00559             m_whiteBrush.Get()
00560             );
00561     }
00562
00563     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00564     // is lost. It will be handled during the next call to Present.
00565     HRESULT hr = m_d2dContext->EndDraw();
00566     if (hr != D2DERR_RECREATE_TARGET)
00567     {
00568         DX::ThrowIfFailed(hr);
00569     }
00570
00571     m_sampleOverlay->Render();
00572 }
00573
00574 void CompositeModes::Initialize(
00575     _In_ CoreApplicationView^ applicationView
00576     )
00577 {
00578     applicationView->Activated +=
00579         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(
00580             this,
00581             &CompositeModes::OnActivated
00582             );
00583
00584     CoreApplication::Suspending +=
00585         ref new EventHandler<SuspendingEventArgs^>(this, &CompositeModes::OnSuspending);
00586
00587     CoreApplication::Resuming +=
00588         ref new EventHandler<Platform::Object^>(this, &CompositeModes::OnResuming);
00589
00590     // This application doesn't support the Portrait/PortraitFlipped orientations.
00591     DisplayProperties::AutoRotationPreferences =
00592         DisplayOrientations::Landscape |
00593         DisplayOrientations::LandscapeFlipped;
00594 }
00595
00596 void CompositeModes::SetWindow(
00597     _In_ CoreWindow^ window
00598     )
00599 {
00600     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00601
00602     window->SizeChanged +=
00603         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(
00604             this,
00605             &CompositeModes::OnWindowSizeChanged
00606             );
00607
00608     window->PointerPressed +=
00609         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &CompositeModes::OnPointerPressed);
00610
00611     window->PointerReleased +=
00612         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &CompositeModes::OnPointerReleased);
00613
00614     window->PointerMoved +=
00615         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &CompositeModes::OnPointerMoved);
00616
00617     DisplayProperties::LogicalDpiChanged +=
00618         ref new DisplayPropertiesEventHandler(this, &CompositeModes::OnLogicalDpiChanged);
00619
00620     DisplayProperties::DisplayContentsInvalidated +=
00621         ref new DisplayPropertiesEventHandler(this, &CompositeModes::OnDisplayContentsInvalidated);
00622
00623     // The gesture recognizer automatically recognizes actions such as zooms
00624     // (whether by pinching or using the scroll wheel) and cursor movement.
00625     m_gestureRecognizer = ref new GestureRecognizer();
00626
00627     m_gestureRecognizer->GestureSettings =
00628         GestureSettings::ManipulationTranslateY;
00629
00630     m_gestureRecognizer->ManipulationUpdated +=
00631         ref new TypedEventHandler<GestureRecognizer^, ManipulationUpdatedEventArgs^>(
00632             this,
00633             &CompositeModes::OnManipulationUpdated
00634             );
00635
00636     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00637 }
00638
00639 void CompositeModes::Load(
00640     _In_ Platform::String^ entryPoint
00641     )
00642 {
00643     IPropertySet^ appSettings = ApplicationData::Current->LocalSettings->Values;
00644
00645     if (appSettings->HasKey("alpha"))
00646     {
00647         m_alpha = safe_cast<IPropertyValue^>(appSettings->Lookup("alpha"))->GetSingle();
00648     }
00649
00650     // After the alpha value is loaded, invoke UpdateAlpha to update the properties on the effects.
00651     UpdateAlpha(0.0f);
00652 }
00653
00654 void CompositeModes::Run()
00655 {
00656     Render();
00657     Present();
00658
00659     m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
00660 }
00661
00662 void CompositeModes::Uninitialize()
00663 {
00664 }
00665
00666 void CompositeModes::OnWindowSizeChanged(
00667     _In_ CoreWindow^ sender,
00668     _In_ WindowSizeChangedEventArgs^ args
00669     )
00670 {
00671     UpdateForWindowSizeChange();
00672     m_sampleOverlay->UpdateForWindowSizeChange();
00673
00674     // We don't want to draw the content when the application is in snapped state.
00675     m_drawEnabled = !(ApplicationView::Value == ApplicationViewState::Snapped);
00676
00677     Render();
00678     Present();
00679 }
00680
00681 void CompositeModes::OnLogicalDpiChanged(
00682     _In_ Platform::Object^ sender
00683     )
00684 {
00685     SetDpi(DisplayProperties::LogicalDpi);
00686     Render();
00687     Present();
00688 }
00689
00690 void CompositeModes::OnDisplayContentsInvalidated(
00691     _In_ Platform::Object^ sender
00692     )
00693 {
00694     // Ensure the D3D Device is available for rendering.
00695     ValidateDevice();
00696
00697     Render();
00698     Present();
00699 }
00700
00701 void CompositeModes::OnActivated(
00702     _In_ CoreApplicationView^ applicationView,
00703     _In_ IActivatedEventArgs^ args
00704     )
00705 {
00706     m_window->Activate();
00707 }
00708
00709 void CompositeModes::OnSuspending(
00710     _In_ Platform::Object^ sender,
00711     _In_ SuspendingEventArgs^ args
00712     )
00713 {
00714     IPropertySet^ appSettings = ApplicationData::Current->LocalSettings->Values;
00715
00716     // Save the alpha value. This state gets restored in the Load method.
00717     if (appSettings->HasKey("alpha"))
00718     {
00719         appSettings->Remove("alpha");
00720     }
00721
00722     appSettings->Insert("alpha", PropertyValue::CreateSingle(m_alpha));
00723 }
00724
00725 void CompositeModes::OnResuming(
00726     _In_ Platform::Object^ sender,
00727     _In_ Platform::Object^ args
00728     )
00729 {
00730 }
00731
00732 void CompositeModes::OnPointerPressed(
00733     _In_ CoreWindow^ sender,
00734     _In_ PointerEventArgs^ args
00735     )
00736 {
00737     m_gestureRecognizer->ProcessDownEvent(args->CurrentPoint);
00738 }
00739
00740 void CompositeModes::OnPointerReleased(
00741     _In_ CoreWindow^ sender,
00742     _In_ PointerEventArgs^ args
00743     )
00744 {
00745     m_gestureRecognizer->ProcessUpEvent(args->CurrentPoint);
00746 }
00747
00748 void CompositeModes::OnPointerMoved(
00749     _In_ CoreWindow^ sender,
00750     _In_ PointerEventArgs^ args
00751     )
00752 {
00753     m_gestureRecognizer->ProcessMoveEvents(args->GetIntermediatePoints());
00754 }
00755
00756 void CompositeModes::OnManipulationUpdated(
00757     _In_ GestureRecognizer^ gestureRecognizer,
00758     _In_ ManipulationUpdatedEventArgs^ args
00759     )
00760 {
00761     UpdateAlpha(args->Delta.Translation.Y);
00762 }
00763
00764 void CompositeModes::UpdateAlpha(
00765     _In_ float verticalPositionDelta
00766     )
00767 {
00768     // Divide position data by screen height so that one swipe from top
00769     // to bottom of the screen changes alpha value exactly by '1'.
00770     m_alpha -= verticalPositionDelta / m_contextSize.height;
00771
00772     m_alpha = Clamp(m_alpha, 0.0f, 1.0f);
00773
00774     D2D1_MATRIX_5X4_F alphaMatrix = {0};
00775     alphaMatrix.m[0][0] = 1;
00776     alphaMatrix.m[1][1] = 1;
00777     alphaMatrix.m[2][2] = 1;
00778     alphaMatrix.m[3][3] = m_alpha;
00779
00780     DX::ThrowIfFailed(
00781         m_appleAlphaEffect->SetValue(D2D1_COLORMATRIX_PROP_COLOR_MATRIX, alphaMatrix)
00782         );
00783
00784     DX::ThrowIfFailed(
00785         m_bananaAlphaEffect->SetValue(D2D1_COLORMATRIX_PROP_COLOR_MATRIX, alphaMatrix)
00786         );
00787
00788     Render();
00789     Present();
00790 }
00791
00792 IFrameworkView^ DirectXAppSource::CreateView()
00793 {
00794     return ref new CompositeModes();
00795 }
00796
00797 [Platform::MTAThread]
00798 int main(Platform::Array<Platform::String^>^)
00799 {
00800     auto directXAppSource = ref new DirectXAppSource();
00801     CoreApplication::Run(directXAppSource);
00802     return 0;
00803 }
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/MainPage.xaml.h Source File

  • Input Device capabilities

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

PointSnapper::PointSnappingSink Member List

This is the complete list of members for PointSnapper::PointSnappingSink, including all inherited members.
Close() | PointSnapper::PointSnappingSink |
CreatePointSnappingSink(_In_ ID2D1SimplifiedGeometrySink *pSink, _Outptr_ PointSnappingSink **ppPointSnappingSink) | PointSnapper::PointSnappingSink | [static]
figureBegin | PointSnapper::PointSnappingSink |
m_pSinkNoRef | PointSnapper::PointSnappingSink | [private]
m_ref | PointSnapper::PointSnappingSink | [private]
pointsCount | PointSnapper::PointSnappingSink |
PointSnappingSink(_In_ ID2D1SimplifiedGeometrySink *pSink) | PointSnapper::PointSnappingSink | [private]
QueryInterface(REFIID riid, _Outptr_ void **object) override | PointSnapper::PointSnappingSink |
STDMETHOD_(void, AddBeziers)(const D2D1_BEZIER_SEGMENT * | PointSnapper::PointSnappingSink |
STDMETHOD_(void, AddLines)(const D2D1_POINT_2F *points | PointSnapper::PointSnappingSink |
STDMETHOD_(void, BeginFigure)(D2D1_POINT_2F startPoint | PointSnapper::PointSnappingSink |
STDMETHOD_(void, EndFigure)(D2D1_FIGURE_END figureEnd) | PointSnapper::PointSnappingSink |
STDMETHOD_(void, SetFillMode)(D2D1_FILL_MODE fillMode) | PointSnapper::PointSnappingSink |
STDMETHOD_(void, SetSegmentFlags)(D2D1_PATH_SEGMENT vertexFlags) | PointSnapper::PointSnappingSink |
STDMETHOD_(ULONG, AddRef)() override | PointSnapper::PointSnappingSink |
STDMETHOD_(ULONG, Release)() override | PointSnapper::PointSnappingSink |
UINT | PointSnapper::PointSnappingSink |
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/Scenario2.xaml.cpp Source File

  • XAML accessibility

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::Accessibility;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario2::Scenario2()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040 }
00041
00042 void SDKSample::Accessibility::Scenario2::GiveControlFocus(Platform::Object^ sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args)
00043 {
00044   //this->Focus(FocusState::Keyboard);
00045   args->Handled = true;
00046 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MonthGroup.cpp Source File

  • Hilo C++
  • Hilo

MonthGroup.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "MonthGroup.h"
00009 #include "TaskExceptionsExtensions.h"
00010 #include "PhotoCache.h"
00011 #include "Repository.h"
00012 #include "IPhoto.h"
00013 #include "ExceptionPolicy.h"
00014 #include "CalendarExtensions.h"
00015
00016 using namespace concurrency;
00017 using namespace Hilo;
00018 using namespace Platform;
00019 using namespace Platform::Collections;
00020 using namespace std;
00021 using namespace Windows::Foundation;
00022 using namespace Windows::Foundation::Collections;
00023 using namespace Windows::Storage::Search;
00024
00025 const unsigned int MaxNumberOfPictures = 8;
00026
00027 MonthGroup::MonthGroup(shared_ptr<PhotoCache> photoCache, IStorageFolderQueryOperations^ folderQuery,
00028     shared_ptr<Repository> repository, shared_ptr<ExceptionPolicy> exceptionPolicy) :
00029     m_count(0u), m_weakPhotoCache(photoCache), m_folderQuery(folderQuery), m_repository(repository), m_exceptionPolicy(exceptionPolicy),
00030     m_hasCount(false), m_runningQuery(false)
00031 {
00032     m_dateTimeForTitle.UniversalTime = 0ll;
00033 }
00034
00035 void MonthGroup::OnPropertyChanged(String^ propertyName)
00036 {
00037     assert(IsMainThread());
00038     PropertyChanged(this, ref new Windows::UI::Xaml::Data::PropertyChangedEventArgs(propertyName));
00039 }
00040
00041 IObservableVector<IPhoto^>^ MonthGroup::Items::get()
00042 {
00043     assert(IsMainThread());
00044     if (nullptr == m_photos)
00045     {
00046         m_photos = ref new Vector<IPhoto^>();
00047
00048         if (!m_runningQuery)
00049         {
00050             m_runningQuery = true;
00051             OnPropertyChanged("IsRunning");
00052             QueryPhotosAsync().then([this](task<DateTime> priorTask)
00053             {
00054                 m_runningQuery = false;
00055                 m_dateTimeForTitle = priorTask.get();
00056                 OnPropertyChanged("Items");
00057                 OnPropertyChanged("Title");
00058                 OnPropertyChanged("IsRunning");
00059             }).then([this]() {
00060                 run_async_non_interactive([this]() {
00061                     if (m_dateTimeForTitle.UniversalTime > 0ll)
00062                     {
00063                         m_repository->GetFolderPhotoCountAsync(m_folderQuery).then([this](size_t count)
00064                         {
00065                             assert(IsMainThread());
00066                             m_count = count;
00067                             OnPropertyChanged("Title");
00068                             OnPropertyChanged("HasPhotos");
00069                         }, task_continuation_context::use_current()).then(ObserveException<void>(m_exceptionPolicy));
00070                     }
00071                 });
00072             })
00073                 .then(ObserveException<void>(m_exceptionPolicy));
00074         }
00075     }
00076     return m_photos;
00077 }
00078
00079 bool MonthGroup::HasPhotos::get()
00080 {
00081     return m_count > 0;
00082 }
00083
00084 bool MonthGroup::IsRunning::get()
00085 {
00086     return m_runningQuery;
00087 }
00088
00089 task<DateTime> MonthGroup::QueryPhotosAsync()
00090 {
00091     // for unit tests only
00092     if (nullptr == m_photos)
00093     {
00094         m_photos = ref new Vector<IPhoto^>();
00095     }
00096
00097     auto photosTask = m_repository->GetPhotoDataForMonthGroup(this, m_folderQuery, MaxNumberOfPictures);
00098     return photosTask.then([this](IVectorView<IPhoto^>^ photos)
00099     {
00100         assert(IsMainThread());
00101         bool first = true;
00102         shared_ptr<PhotoCache> cache = m_weakPhotoCache.lock();
00103         DateTime dateTime = {0ll};
00104
00105         for (auto item : photos)
00106         {
00107             // Add this photo to the display graph.
00108             m_photos->Append(item);
00109             if (first)
00110             {
00111                 // Cache a handle to the first photo. We will need this later when we want to scroll the grid of month
00112                 // groups to a chosen month. (We can only scroll to a given item, not to a property of that item.)
00113                 cache->InsertPhoto(item);
00114
00115                 // Remember the date of the first picture. We need this later to correctly display the name of the month group.
00116                 dateTime = item->DateTaken;
00117             }
00118             first = false;
00119         }
00120         return dateTime;
00121     });
00122 }
00123
00124 String^ MonthGroup::Title::get()
00125 {
00126     // Set title to month name if available
00127     if (m_title == nullptr && !m_runningQuery && m_dateTimeForTitle.UniversalTime != 0ll)
00128     {
00129         m_title = CalendarExtensions::GetLocalizedMonthAndYear(m_dateTimeForTitle);
00130     }
00131
00132     // Add count to title if available (this will be after the month name becomes available)
00133     if (m_title != nullptr && m_count > 0 && !m_hasCount)
00134     {
00135         auto formatter = ref new Windows::Globalization::NumberFormatting::DecimalFormatter();
00136         formatter->FractionDigits = 0;
00137         auto count = formatter->FormatUInt(m_count);
00138         m_title = m_title + " (" + count + ")";
00139         m_hasCount = true;
00140     }
00141     return m_title;
00142 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideSmallImageAndText03 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideSmallImageAndText03, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::TileContent::TileWideSmallImageAndText03 |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBodyWrap | NotificationsExtensions::TileContent::TileWideSmallImageAndText03 |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideSmallImageAndText03() | NotificationsExtensions::TileContent::TileWideSmallImageAndText03 | [inline]
TileWideSmallImageAndText03() | NotificationsExtensions::TileContent::TileWideSmallImageAndText03 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario2.xaml.h Source File

  • XAML ListView and GridView essentials

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "SampleDataSource.h"
00022
00023 namespace SDKSample
00024 {
00025   namespace ListViewSimple
00026   {
00027     /// <summary>
00028     /// An empty page that can be used on its own or navigated to within a Frame.
00029     /// </summary>
00030     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00031     public ref class Scenario2 sealed
00032     {
00033     public:
00034       Scenario2();
00035
00036     protected:
00037       virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039     private:
00040       MainPage^ rootPage;
00041       ListViewSampleDataSource::StoreData^ storeData;
00042
00043       void DoSomething_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044
00045       void ItemClickHandler(Platform::Object^ sender, Windows::UI::Xaml::Controls::ItemClickEventArgs^ e);
00046
00047     };
00048   }
00049 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/pch.cpp Source File

  • Direct2D custom image effects
  • ComputeShader

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Pointer.xaml.h Source File

  • Input Device capabilities

Pointer.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Pointer.xaml.h
00013 // Declaration of the Pointer class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Pointer.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace DeviceCaps
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Pointer sealed
00031         {
00032         public:
00033             Pointer();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void PointerGetSettings_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         Platform::String^ PointerType(Windows::Devices::Input::PointerDevice^ pointerDevice);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CopyText.xaml.h Source File

  • Clipboard app

CopyText.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CopyText.xaml.h
00013 // Declaration of the CopyText class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "CopyText.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace Clipboard
00023 {
00024     [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class CopyText sealed
00026     {
00027     public:
00028         CopyText();
00029
00030     protected:
00031         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032
00033     private:
00034         MainPage^ rootPage;
00035
00036         // ScenarioInput1 click events
00037         void CopyButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038         void PasteButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039
00040         Platform::String^ htmlDescription;
00041         Platform::String^ textDescription;
00042         Platform::String^ imgSrc;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Display.xaml.cpp Source File

  • Playlist

Display.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Display.xaml.cpp
00013 // Implementation of the Display class
00014 //
00015
00016 #include "pch.h"
00017 #include "Display.xaml.h"
00018
00019 using namespace SDKSample::Playlists;
00020
00021 using namespace Windows::Storage::FileProperties;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025
00026 Display::Display()
00027 {
00028     InitializeComponent();
00029 }
00030
00031 /// <summary>
00032 /// Invoked when this page is about to be displayed in a Frame.
00033 /// </summary>
00034 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00035 /// property is typically used to configure the page.</param>
00036 void Display::OnNavigatedTo(NavigationEventArgs^ e)
00037 {
00038     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00039     // as NotifyUser()
00040     rootPage = MainPage::Current;
00041 }
00042
00043 void Display::PickPlaylistButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00044 {
00045     // Make sure app is unsnapped before invoking the file picker
00046     if(!MainPage::EnsureUnsnapped())
00047     {
00048         OutputStatus->Text = "Unable to unsnap the app.";
00049         return;
00050     }
00051
00052     MainPage::PickPlaylist().then([this](task<Playlist^> playlistTask)
00053     {
00054         try
00055         {
00056             MainPage::playlist = playlistTask.get();
00057
00058             OutputStatus->Text = "Playlist content:\n";
00059             if (MainPage::playlist->Files->Size == 0)
00060             {
00061                 OutputStatus->Text += "(playlist is empty)";
00062             }
00063             else
00064             {
00065                 // create a vector to store the async operations
00066                 std::vector<task<MusicProperties^>> results(MainPage::playlist->Files->Size);
00067                 for (unsigned int i = 0; i < MainPage::playlist->Files->Size; i++)
00068                 {
00069                     StorageFile^ file = (StorageFile^)(MainPage::playlist->Files->GetAt(i));
00070                     results[i] = task<MusicProperties^>(file->Properties->GetMusicPropertiesAsync());
00071                 }
00072
00073                 // wait for all of the async operations to complete and then output the results
00074                 when_all(results.begin(), results.end()).then([this](std::vector<MusicProperties^> results)
00075                 {
00076                     for (unsigned int i = 0; i < results.size(); i++)
00077                     {
00078                         MusicProperties^ properties = results[i];
00079                         OutputStatus->Text += "\n";
00080                         OutputStatus->Text += "Title: " + properties->Title + "\n";
00081                         OutputStatus->Text += "Album: " + properties->Album + "\n";
00082                         OutputStatus->Text += "Artist: " + properties->Artist + "\n";
00083                     }
00084                 });
00085             }
00086         }
00087         catch (NullReferenceException^ ex)
00088         {
00089             OutputStatus->Text = "No playlist picked.";
00090         }
00091         catch(AccessDeniedException^ ex)
00092         {
00093             OutputStatus->Text = "Access is denied, cannot load playlist.";
00094         }
00095     });
00096 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/LandscapeFlipped.xaml.h Source File

  • Device auto rotation preferences

LandscapeFlipped.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // LandscapeFlipped.xaml.h
00013 // Declaration of the LandscapeFlipped class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "LandscapeFlipped.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Rotation
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class LandscapeFlipped sealed
00031         {
00032         public:
00033             LandscapeFlipped();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void SetLandscapeFlipped_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/DWriteInlineObject.h Source File

  • DirectWrite inline object

DWriteInlineObject.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012 #include "InlineImage.h"
00013
00014 ref class DWriteInlineObject : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00015 {
00016 internal:
00017     DWriteInlineObject();
00018
00019     // DirectXBase Methods
00020     virtual void HandleDeviceLost() override;
00021     virtual void CreateDeviceIndependentResources() override;
00022     virtual void CreateDeviceResources() override;
00023     virtual void CreateWindowSizeDependentResources() override;
00024     virtual void Render() override;
00025
00026 public:
00027     // IFrameworkView Methods
00028     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00029     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00030     virtual void Load(_In_ Platform::String^ entryPoint);
00031     virtual void Run();
00032     virtual void Uninitialize();
00033
00034 private:
00035     // Event Handlers
00036     void OnWindowSizeChanged(
00037         _In_ Windows::UI::Core::CoreWindow^ sender,
00038         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00039         );
00040
00041     void OnLogicalDpiChanged(
00042         _In_ Platform::Object^ sender
00043         );
00044
00045     void OnDisplayContentsInvalidated(
00046         _In_ Platform::Object^ sender
00047         );
00048
00049     void OnActivated(
00050         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00051         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00052         );
00053
00054     void OnSuspending(
00055         _In_ Platform::Object^ sender,
00056         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00057         );
00058
00059     void OnResuming(
00060         _In_ Platform::Object^ sender,
00061         _In_ Platform::Object^ args
00062         );
00063
00064     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>                    m_blackBrush;
00065     Microsoft::WRL::ComPtr<IDWriteTextFormat>                       m_textFormat;
00066     Microsoft::WRL::ComPtr<IDWriteTypography>                       m_textTypography;
00067     Microsoft::WRL::ComPtr<IDWriteTextLayout>                       m_textLayout;
00068     Microsoft::WRL::ComPtr<IDWriteInlineObject>                     m_inlineImage;
00069     SampleOverlay^                                                  m_sampleOverlay;
00070 };
00071
00072 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00073 {
00074 public:
00075     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00076 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/pch.h Source File

  • DirectWrite hit testing

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1_1helper.h>
00014 #include <d2d1effects.h>
00015 #include <dwrite_1.h>
00016 #include <wincodec.h>
00017 #include <math.h>
00018 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/pch.h Source File

  • Direct2D command list

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <d2d1_1helper.h>
00015 #include <dwrite_1.h>
00016 #include <wincodec.h>
00017 #include <math.h>
00018 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKMESH_MESH Member List

This is the complete list of members for SDKMESH_MESH, including all inherited members.
BoundingBoxCenter | SDKMESH_MESH
BoundingBoxExtents | SDKMESH_MESH
FrameInfluenceOffset | SDKMESH_MESH
FrameInfluences | SDKMESH_MESH
IndexBuffer | SDKMESH_MESH
Name | SDKMESH_MESH
NumFrameInfluences | SDKMESH_MESH
NumSubsets | SDKMESH_MESH
NumVertexBuffers | SDKMESH_MESH
SubsetOffset | SDKMESH_MESH
Subsets | SDKMESH_MESH
VertexBuffers | SDKMESH_MESH
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CompletedCallback.xaml.h Source File

  • Message dialog

CompletedCallback.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CompletedCallback.xaml.h
00013 // Declaration of the CompletedCallback class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "CompletedCallback.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace MessageDialogSample
00025     {
00026         [Windows::Foundation::Metadata::WebHostHidden]
00027         public ref class CompletedCallback sealed
00028         {
00029         public:
00030             CompletedCallback();
00031
00032         protected:
00033             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00034         private:
00035             MainPage^ rootPage;
00036             void CompletedCallbackButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037         };
00038     }
00039 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Pointer.xaml.cpp Source File

  • Input Device capabilities

Pointer.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Pointer.xaml.cpp
00013 // Implementation of the Pointer class
00014 //
00015
00016 #include "pch.h"
00017 #include "Pointer.xaml.h"
00018
00019 using namespace SDKSample::DeviceCaps;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 using namespace Windows::Devices::Input;
00026
00027 Pointer::Pointer()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void Pointer::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042 }
00043
00044 Platform::String^ Pointer::PointerType(PointerDevice^ pointerDevice)
00045 {
00046     if (pointerDevice->PointerDeviceType == PointerDeviceType::Mouse)
00047     {
00048         return "mouse";
00049     }
00050     else if (pointerDevice->PointerDeviceType == PointerDeviceType::Pen)
00051     {
00052         return "pen";
00053     }
00054     else if (pointerDevice->PointerDeviceType == PointerDeviceType::Touch)
00055     {
00056         return "touch";
00057     }
00058
00059   return "undefined";
00060 }
00061
00062 void SDKSample::DeviceCaps::Pointer::PointerGetSettings_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00063 {
00064     Button^ b = safe_cast<Button^>(sender);
00065     if (b != nullptr)
00066     {
00067     Windows::Foundation::Collections::IVectorView<PointerDevice^>^ PointerDeviceList = PointerDevice::GetPointerDevices();
00068         Platform::String^ Buffer;
00069
00070         for (unsigned i = 0; i < PointerDeviceList->Size; i++) {
00071             Platform::String^ displayIndex = (i + 1).ToString();
00072             Buffer += "Pointer device " + displayIndex + ":\n";
00073             Buffer += "This pointer device type is " + PointerType(PointerDeviceList->GetAt(i)) + "\n";
00074             Buffer += "This pointer device is " + (PointerDeviceList->GetAt(i)->IsIntegrated ? "not " : "") + "external\n";
00075             Buffer += "This pointer device has a maximum of " + PointerDeviceList->GetAt(i)->MaxContacts.ToString() + " contacts\n";
00076             Buffer += "The physical device rect is " +
00077                 PointerDeviceList->GetAt(i)->PhysicalDeviceRect.X.ToString() + ", " +
00078                 PointerDeviceList->GetAt(i)->PhysicalDeviceRect.Y.ToString() + ", " +
00079                 PointerDeviceList->GetAt(i)->PhysicalDeviceRect.Width.ToString() + ", " +
00080                 PointerDeviceList->GetAt(i)->PhysicalDeviceRect.Height.ToString() + "\n";
00081             Buffer += "The screen rect is " +
00082                 PointerDeviceList->GetAt(i)->ScreenRect.X.ToString() + ", " +
00083                 PointerDeviceList->GetAt(i)->ScreenRect.Y.ToString() + ", " +
00084                 PointerDeviceList->GetAt(i)->ScreenRect.Width.ToString() + ", " +
00085                 PointerDeviceList->GetAt(i)->ScreenRect.Height.ToString() + "\n\n";
00086         }
00087
00088         PointerOutputTextBlock->Text = Buffer;
00089     }
00090 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Web::HttpRequest Member List

This is the complete list of members for Web::HttpRequest, including all inherited members.
buffersCallback | Web::HttpRequest | [private]
CreateMemoryStream(IStream **stream) | Web::HttpRequest | [static]
CreateMemoryStream(IStream **stream) | Web::HttpRequest | [static]
CreateMemoryStream(IStream **stream) | Web::HttpRequest | [static]
CreateMemoryStream(IStream **stream) | Web::HttpRequest | [static]
CreateMemoryStream(IStream **stream) | Web::HttpRequest | [static]
DownloadAsync(PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend) | Web::HttpRequest | [private]
DownloadAsync(PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend) | Web::HttpRequest | [private]
DownloadAsync(PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend) | Web::HttpRequest | [private]
DownloadAsync(PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend) | Web::HttpRequest | [private]
DownloadAsync(PCWSTR httpMethod, PCWSTR uri, concurrency::cancellation_token cancellationToken, PCWSTR contentType, IStream *postStream, uint64 postStreamBytesToSend) | Web::HttpRequest | [private]
GetAsync(Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
GetAsync(Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
GetAsync(Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
GetAsync(Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
GetAsync(Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
GetReasonPhrase() const | Web::HttpRequest | [inline]
GetReasonPhrase() const | Web::HttpRequest | [inline]
GetReasonPhrase() const | Web::HttpRequest | [inline]
GetReasonPhrase() const | Web::HttpRequest | [inline]
GetReasonPhrase() const | Web::HttpRequest | [inline]
GetStatusCode() const | Web::HttpRequest | [inline]
GetStatusCode() const | Web::HttpRequest | [inline]
GetStatusCode() const | Web::HttpRequest | [inline]
GetStatusCode() const | Web::HttpRequest | [inline]
GetStatusCode() const | Web::HttpRequest | [inline]
HttpRequest() | Web::HttpRequest |
HttpRequest() | Web::HttpRequest |
HttpRequest() | Web::HttpRequest |
HttpRequest() | Web::HttpRequest |
HttpRequest() | Web::HttpRequest |
HttpRequest::PostAsync(Windows::Foundation::Uri^uri, PCWSTR contentType, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
IsResponseComplete() const | Web::HttpRequest | [inline]
IsResponseComplete() const | Web::HttpRequest | [inline]
IsResponseComplete() const | Web::HttpRequest | [inline]
IsResponseComplete() const | Web::HttpRequest | [inline]
IsResponseComplete() const | Web::HttpRequest | [inline]
PostAsync(Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, PCWSTR contentType, IStream *postStream, uint64 postStreamSizeToSend, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
PostAsync(Windows::Foundation::Uri^uri, const std::wstring &str, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
ReadAsync(Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead) | Web::HttpRequest |
ReadAsync(Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead) | Web::HttpRequest |
ReadAsync(Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead) | Web::HttpRequest |
ReadAsync(Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead) | Web::HttpRequest |
ReadAsync(Windows::Storage::Streams::IBuffer^readBuffer, unsigned int offsetInBuffer, unsigned int requestedBytesToRead) | Web::HttpRequest |
reasonPhrase | Web::HttpRequest | [private]
responseComplete | Web::HttpRequest | [private]
SendAsync(const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
SendAsync(const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
SendAsync(const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
SendAsync(const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
SendAsync(const std::wstring &httpMethod, Windows::Foundation::Uri^uri, concurrency::cancellation_token cancellationToken=concurrency::cancellation_token::none()) | Web::HttpRequest |
statusCode | Web::HttpRequest | [private]
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/Constants.cpp Source File

  • Trial app and in-app purchase

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00017 {
00018     // The format here is the following:
00019     // { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00020     { "Trial-mode", "SDKSample.StoreSample.TrialMode" },
00021     { "In-app purchase", "SDKSample.StoreSample.InAppPurchase" },
00022     { "Expiring product", "SDKSample.StoreSample.ExpiringProduct" },
00023     { "App Listing URI", "SDKSample.StoreSample.AppListingUri" },
00024     { "Receipt", "SDKSample.StoreSample.Receipt" },
00025 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/MFSampleGenerator.cpp Source File

  • Windows Audio Session (WASAPI)
  • C++

MFSampleGenerator.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MFSampleGenerator.cpp
00013 //
00014
00015 #include "pch.h"
00016 #include "MFSampleGenerator.h"
00017
00018 using namespace SDKSample::WASAPIAudio;
00019
00020 //
00021 //  MFSampleGenerator()
00022 //
00023 MFSampleGenerator::MFSampleGenerator() :
00024     m_Ref( 1 ),
00025     m_IsInitialized( false ),
00026     m_BytesPerPeriod( 0 ),
00027     m_ReaderState( ReaderStateStopped ),
00028     m_MFSourceReader( nullptr ),
00029     m_AudioMT( nullptr ),
00030     m_SampleQueue( nullptr ),
00031     m_SampleQueueTail( &m_SampleQueue )
00032 {
00033 }
00034
00035 //
00036 //  ~MFSampleGenerator()
00037 //
00038 MFSampleGenerator::~MFSampleGenerator()
00039 {
00040     Shutdown();
00041 }
00042
00043 //
00044 //  Flush()
00045 //
00046 void MFSampleGenerator::Flush()
00047 {
00048     while( m_SampleQueue != nullptr )
00049     {
00050         RenderBuffer *SampleBuffer = m_SampleQueue;
00051         m_SampleQueue = SampleBuffer->Next;
00052         SAFE_DELETE( SampleBuffer );
00053     }
00054 }
00055
00056 //
00057 //  Shutdown()
00058 //
00059 void MFSampleGenerator::Shutdown()
00060 {
00061     if (m_IsInitialized)
00062     {
00063         SAFE_RELEASE( m_AudioMT );
00064         SAFE_RELEASE( m_MFSourceReader );
00065
00066         Flush();
00067
00068         m_IsInitialized = false;
00069     }
00070 }
00071
00072 //
00073 //  StartSource()
00074 //
00075 //  Start the media source to read samples
00076 //
00077 HRESULT MFSampleGenerator::StartSource()
00078 {
00079     if (!m_IsInitialized)
00080         return E_UNEXPECTED;
00081
00082     // We can be in EOS if this is a resume from pause
00083     if ( (m_ReaderState == ReaderStatePreRoll) ||
00084          (m_ReaderState == ReaderStatePlaying) ||
00085          (m_ReaderState == ReaderStateEOS) )
00086         return S_FALSE;
00087
00088     HRESULT hr = S_OK;
00089
00090     // This will start the source reader and asynchronously call OnReadSample
00091     hr = m_MFSourceReader->ReadSample( MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, nullptr, nullptr, nullptr, nullptr );
00092     if (SUCCEEDED( hr ))
00093     {
00094         m_ReaderState = ReaderStatePreRoll;
00095     }
00096
00097     return hr;
00098 }
00099
00100 //
00101 //  StopSource()
00102 //
00103 //  Stops the media source from reading samples
00104 //
00105 void MFSampleGenerator::StopSource()
00106 {
00107     // We only really need this if Source is still reading samples, otherwise
00108     // we should be in an EOS state and parsing existing samples in the queue
00109     m_ReaderState = ReaderStateStopped;
00110 }
00111
00112 //
00113 //  Initialize()
00114 //
00115 //  Configure the Source Reader
00116 //
00117 HRESULT MFSampleGenerator::Initialize( IRandomAccessStream^ stream, UINT32 FramesPerPeriod, WAVEFORMATEX *wfx )
00118 {
00119     HRESULT hr = S_OK;
00120
00121     m_ContentStream = stream;
00122     m_MixFormat = wfx;
00123     IMFByteStream *ByteStream = nullptr;
00124     IMFAttributes *Attributes = nullptr;
00125
00126     SAFE_RELEASE( m_AudioMT );
00127     SAFE_RELEASE( m_MFSourceReader );
00128
00129     hr = MFCreateAttributes( &Attributes, 3 );
00130     if (FAILED( hr ))
00131     {
00132         goto exit;
00133     }
00134
00135     // Specify Source Reader Attributes
00136     Attributes->SetUnknown( MF_SOURCE_READER_ASYNC_CALLBACK, static_cast<IMFSourceReaderCallback *>(this) );
00137     if (FAILED( hr ))
00138     {
00139         goto exit;
00140     }
00141
00142     Attributes->SetString( MF_READWRITE_MMCSS_CLASS_AUDIO, L"Audio" );
00143     if (FAILED( hr ))
00144     {
00145         goto exit;
00146     }
00147
00148     Attributes->SetUINT32( MF_READWRITE_MMCSS_PRIORITY_AUDIO, 0 );
00149     if (FAILED( hr ))
00150     {
00151         goto exit;
00152     }
00153
00154     // Create a stream from IRandomAccessStream
00155     hr = MFCreateMFByteStreamOnStreamEx( reinterpret_cast<IUnknown*>(m_ContentStream), &ByteStream );
00156     if ( FAILED( hr ) )
00157     {
00158         goto exit;
00159     }
00160
00161     // Create source reader
00162     hr = MFCreateSourceReaderFromByteStream( ByteStream, Attributes, &m_MFSourceReader );
00163     if ( FAILED( hr ) )
00164     {
00165         goto exit;
00166     }
00167
00168     // Configures media types
00169     hr = ConfigureStreams();
00170     if ( FAILED( hr ) )
00171     {
00172         goto exit;
00173     }
00174
00175     m_BytesPerPeriod = FramesPerPeriod * m_MixFormat->nBlockAlign;
00176     m_IsInitialized = true;
00177
00178 exit:
00179     if ( FAILED( hr ) )
00180     {
00181         SAFE_RELEASE( m_AudioMT );
00182         SAFE_RELEASE( m_MFSourceReader );
00183     }
00184
00185     SAFE_RELEASE( Attributes );
00186     SAFE_RELEASE( ByteStream );
00187
00188     return hr;
00189 }
00190
00191 //
00192 //  ConfigureStreams()
00193 //
00194 //  Enables the first audio stream and configures the media type
00195 //
00196 HRESULT MFSampleGenerator::ConfigureStreams()
00197 {
00198     HRESULT hr = S_OK;
00199     IMFMediaType *UncompressedMT = nullptr;
00200     IMFMediaType *PartialMT = nullptr;
00201
00202     // Disable all streams
00203     hr = m_MFSourceReader->SetStreamSelection( MF_SOURCE_READER_ALL_STREAMS, false );
00204     if ( FAILED( hr ) )
00205     {
00206         goto exit;
00207     }
00208
00209     // Enable first audio stream
00210     hr = m_MFSourceReader->SetStreamSelection( MF_SOURCE_READER_FIRST_AUDIO_STREAM, true );
00211     if ( FAILED( hr ) )
00212     {
00213         goto exit;
00214     }
00215
00216     hr = CreateAudioType( &PartialMT );
00217     if ( FAILED( hr ) )
00218     {
00219         goto exit;
00220     }
00221
00222     // Set type on source reader so necessary converters / decoders will be added
00223     hr = m_MFSourceReader->SetCurrentMediaType( MF_SOURCE_READER_FIRST_AUDIO_STREAM, nullptr, PartialMT );
00224     if ( FAILED( hr ) )
00225     {
00226         goto exit;
00227     }
00228
00229     // Verify the media type on stream
00230     hr = m_MFSourceReader->GetCurrentMediaType( MF_SOURCE_READER_FIRST_AUDIO_STREAM, &UncompressedMT );
00231     if ( FAILED( hr ) )
00232     {
00233         goto exit;
00234     }
00235
00236     WAVEFORMATEX *pwfx = NULL;
00237     UINT32 cbFormat = 0;
00238     MFCreateWaveFormatExFromMFMediaType( UncompressedMT, &pwfx, &cbFormat );
00239
00240     CoTaskMemFree( pwfx );
00241
00242     m_AudioMT = UncompressedMT;
00243     m_AudioMT->AddRef();
00244
00245 exit:
00246     SAFE_RELEASE( UncompressedMT );
00247     SAFE_RELEASE( PartialMT );
00248
00249     return hr;
00250 }
00251
00252 //
00253 //  CreateAudioType()
00254 //
00255 //  Create an audio type based on the default mix format from the renderer
00256 //
00257 HRESULT MFSampleGenerator::CreateAudioType( IMFMediaType **MediaType )
00258 {
00259     HRESULT hr = S_OK;
00260     IMFMediaType *MT = nullptr;
00261
00262     // Create a partial media type for our mix format (PCM or IEEE Float)
00263     hr = MFCreateMediaType( &MT );
00264     if (FAILED( hr ))
00265     {
00266         goto exit;
00267     }
00268
00269     // Set media type attributes
00270     hr = MT->SetGUID( MF_MT_MAJOR_TYPE, MFMediaType_Audio );
00271     if ( FAILED( hr ) )
00272     {
00273         goto exit;
00274     }
00275
00276     if (RenderSampleType::SampleType16BitPCM == CalculateMixFormatType( m_MixFormat ))
00277     {
00278         hr = MT->SetGUID( MF_MT_SUBTYPE, MFAudioFormat_PCM );
00279     }
00280     else
00281     {
00282         hr = MT->SetGUID( MF_MT_SUBTYPE, MFAudioFormat_Float );
00283     }
00284
00285     if (FAILED( hr ))
00286     {
00287         goto exit;
00288     }
00289
00290     hr = MT->SetUINT32( MF_MT_AUDIO_NUM_CHANNELS, m_MixFormat->nChannels );
00291     if (FAILED( hr ))
00292     {
00293         goto exit;
00294     }
00295
00296     hr = MT->SetUINT32( MF_MT_AUDIO_SAMPLES_PER_SECOND, m_MixFormat->nSamplesPerSec );
00297     if (FAILED( hr ))
00298     {
00299         goto exit;
00300     }
00301
00302     hr = MT->SetUINT32( MF_MT_AUDIO_BLOCK_ALIGNMENT, m_MixFormat->nBlockAlign );
00303     if (FAILED( hr ))
00304     {
00305         goto exit;
00306     }
00307
00308     hr = MT->SetUINT32( MF_MT_AUDIO_AVG_BYTES_PER_SECOND, m_MixFormat->nAvgBytesPerSec );
00309     if (FAILED( hr ))
00310     {
00311         goto exit;
00312     }
00313
00314     hr = MT->SetUINT32( MF_MT_AUDIO_BITS_PER_SAMPLE, m_MixFormat->wBitsPerSample );
00315     if (FAILED( hr ))
00316     {
00317         goto exit;
00318     }
00319
00320     hr = MT->SetUINT32( MF_MT_ALL_SAMPLES_INDEPENDENT, true );
00321     if (FAILED( hr ))
00322     {
00323         goto exit;
00324     }
00325
00326     *MediaType = MT;
00327     (*MediaType)->AddRef();
00328
00329 exit:
00330     SAFE_RELEASE( MT );
00331     return hr;
00332 }
00333
00334 //
00335 //  OnEvent()
00336 //
00337 //  Implementation of IMFSourceReaderCallback::OnEvent()
00338 //
00339 HRESULT MFSampleGenerator::OnEvent(_In_ DWORD dwStreamIndex, _In_ IMFMediaEvent *pEvent)
00340 {
00341     return S_OK;
00342 }
00343
00344 //
00345 //  OnFlush()
00346 //
00347 //  Implementation of IMFSourceReaderCallback::OnFlush()
00348 //
00349 HRESULT MFSampleGenerator::OnFlush(_In_ DWORD dwStreamIndex)
00350 {
00351     return S_OK;
00352 }
00353
00354 //
00355 //  OnReadSample()
00356 //
00357 //  Implementation of IMFSourceReaderCallback::OnReadSample().  When a sample is ready, add it to the sample queue.
00358 //
00359 HRESULT MFSampleGenerator::OnReadSample(_In_ HRESULT hrStatus, _In_ DWORD dwStreamIndex, _In_ DWORD dwStreamFlags, _In_ LONGLONG llTimestamp, _In_opt_ IMFSample *pSample)
00360 {
00361     HRESULT hr = S_OK;
00362
00363     if ( (m_ReaderState != ReaderStatePlaying) &&
00364          (m_ReaderState != ReaderStatePreRoll) )
00365         return S_OK;
00366
00367     // If we have a failure, change in stream format, or hit EOF, then we stop reading samples
00368     if ( (FAILED( hrStatus )) ||
00369          (dwStreamFlags & MF_SOURCE_READERF_ENDOFSTREAM) ||
00370          (dwStreamFlags & MF_SOURCE_READERF_CURRENTMEDIATYPECHANGED) )
00371     {
00372         m_ReaderState = ReaderStateEOS;
00373         return S_OK;
00374     }
00375
00376     // Add the data from the Media Sample to our buffer queue
00377     hr = AddSamplesToQueue( pSample );
00378     if (SUCCEEDED( hr ))
00379     {
00380         // Pre-roll PREROLL_DURATION seconds worth of data
00381         if (m_ReaderState == ReaderStatePreRoll)
00382         {
00383             if (IsPreRollFilled())
00384             {
00385                 // Once Pre-roll is filled, audio endpoint will stop rendering silence and start
00386                 // picking up data from the queue
00387                 m_ReaderState = ReaderStatePlaying;
00388             }
00389         }
00390
00391         // Call ReadSample for next asynchronous sample event
00392         hr = m_MFSourceReader->ReadSample( MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, nullptr, nullptr, nullptr, nullptr );
00393     }
00394
00395     return S_OK;
00396 }
00397
00398 //
00399 //  FillSampleBuffer()
00400 //
00401 //  Called by the audio endpoint to get data to render, and will set cbWritten to valid number of
00402 //  bytes in the buffer.  The buffers are zeroed out when initialized so the endpoint could feasibly
00403 //  treat the data as silence. If there are no more samples to render, will return S_FALSE.
00404 //
00405 HRESULT MFSampleGenerator::FillSampleBuffer( UINT32 BytesToRead, BYTE *Data, UINT32 *cbWritten )
00406 {
00407     HRESULT hr = S_OK;
00408     *cbWritten = 0;
00409
00410     if (nullptr == Data)
00411     {
00412         return E_POINTER;
00413     }
00414
00415     if (!m_IsInitialized)
00416     {
00417         return E_UNEXPECTED;
00418     }
00419
00420     // Not going to return any data here while in a pre-roll state.
00421     if (m_ReaderState == ReaderStatePreRoll)
00422         return S_OK;
00423
00424     RenderBuffer *SampleBuffer = m_SampleQueue;
00425     if (nullptr == SampleBuffer)
00426     {
00427         if (m_ReaderState == ReaderStateEOS)
00428         {
00429             // We are EOS, should be set from OnReadSample() and the client should check for EOS before
00430             // calling FillSampleBuffer()
00431             hr = S_FALSE;
00432         }
00433         else
00434         {
00435             // There shouldn't be a situation where we get here unless the reader has
00436             // somehow gotten into the wrong state
00437             hr = E_FAIL;
00438         }
00439     }
00440     else
00441     {
00442         if (SampleBuffer->BufferSize > BytesToRead)
00443         {
00444             // We don't have enough data in the client audio buffer this pass
00445             // Do nothing and wait for the next sample period
00446             hr = S_OK;
00447         }
00448         else
00449         {
00450             CopyMemory( Data, SampleBuffer->Buffer, SampleBuffer->BufferSize );
00451
00452             *cbWritten = SampleBuffer->BufferSize;
00453             m_SampleQueue = m_SampleQueue->Next;
00454             hr = S_OK;
00455         }
00456     }
00457
00458     return hr;
00459 }
00460
00461 //
00462 //  AddSamplesToBuffer()
00463 //
00464 //  Data is added to the end of the sample queue
00465 //
00466 HRESULT MFSampleGenerator::AddSamplesToQueue( IMFSample *MFSample )
00467 {
00468     if (nullptr == MFSample)
00469     {
00470         return E_INVALIDARG;
00471     }
00472
00473     HRESULT hr = S_OK;
00474     IMFMediaBuffer *MediaBuffer = nullptr;
00475     BYTE *AudioData = nullptr;
00476     DWORD cbAudioData = 0;
00477
00478     // Since we are storing the raw byte data, convert this to a single buffer
00479     hr = MFSample->ConvertToContiguousBuffer( &MediaBuffer );
00480     if (FAILED( hr ))
00481     {
00482         goto exit;
00483     }
00484
00485     // Lock the sample
00486     hr = MediaBuffer->Lock( &AudioData, NULL, &cbAudioData );
00487     if ( (FAILED( hr )) || (cbAudioData == 0) )
00488     {
00489         goto exit;
00490     }
00491
00492     DWORD cbBytesCopied = 0;
00493
00494     // First fill up any partial buffers from the previous sample
00495     if ( (*m_SampleQueueTail != nullptr) &&
00496          ((*m_SampleQueueTail)->BytesFilled < m_BytesPerPeriod) )
00497     {
00498         RenderBuffer *PartialBuffer = *m_SampleQueueTail;
00499
00500         DWORD cbBytesRemaining = m_BytesPerPeriod - PartialBuffer->BytesFilled;
00501         DWORD cbBytesToCopy = min( cbAudioData, cbBytesRemaining );
00502
00503         CopyMemory( PartialBuffer->Buffer + PartialBuffer->BytesFilled, AudioData, cbBytesToCopy );
00504
00505         PartialBuffer->BytesFilled += cbBytesToCopy;
00506         cbBytesCopied += cbBytesToCopy;
00507
00508         // Move the tail pointer only if we have filled the sample
00509         if (PartialBuffer->BytesFilled == m_BytesPerPeriod)
00510         {
00511             m_SampleQueueTail = &PartialBuffer->Next;
00512         }
00513     }
00514
00515     // Create buffers for the remainder of the samples
00516     while( cbBytesCopied < cbAudioData )
00517     {
00518         RenderBuffer *SampleBuffer = new (std::nothrow) RenderBuffer();
00519         if (nullptr == SampleBuffer)
00520         {
00521             hr = E_OUTOFMEMORY;
00522             goto exit;
00523         }
00524
00525         DWORD cbBytesRemaining = cbAudioData - cbBytesCopied;
00526         DWORD cbBufferLengthInBytes = min( m_BytesPerPeriod, cbBytesRemaining );
00527
00528         SampleBuffer->Buffer = new (std::nothrow) BYTE[ m_BytesPerPeriod ];
00529         if (nullptr == SampleBuffer->Buffer)
00530         {
00531             SAFE_DELETE( SampleBuffer );
00532             hr = E_OUTOFMEMORY;
00533             goto exit;
00534         }
00535
00536         SampleBuffer->BufferSize = m_BytesPerPeriod;
00537         SampleBuffer->BytesFilled = 0;
00538
00539         ZeroMemory( SampleBuffer->Buffer, m_BytesPerPeriod );
00540         CopyMemory( SampleBuffer->Buffer, AudioData + cbBytesCopied, cbBufferLengthInBytes );
00541
00542         SampleBuffer->BytesFilled += cbBufferLengthInBytes;
00543         cbBytesCopied += cbBufferLengthInBytes;
00544
00545         *m_SampleQueueTail = SampleBuffer;
00546
00547         // Move the tail pointer only if we have filled the sample otherwise will get filled the
00548         // next time we add sample data to the queue
00549         if (SampleBuffer->BytesFilled == m_BytesPerPeriod)
00550         {
00551             m_SampleQueueTail = &SampleBuffer->Next;
00552         }
00553     }
00554
00555 exit:
00556     // Unlock the buffer
00557     hr = MediaBuffer->Unlock();
00558     AudioData = nullptr;
00559
00560     SAFE_RELEASE( MediaBuffer );
00561     return hr;
00562 }
00563
00564 //
00565 //  IsPreRollFilled()
00566 //
00567 //  Loops through the queue quickly to see if our pre-roll buffer is filled
00568 //
00569 Platform::Boolean MFSampleGenerator::IsPreRollFilled()
00570 {
00571     DWORD TotalBufferSize = 0;
00572
00573     RenderBuffer *SampleBuffer = m_SampleQueue;
00574     while( SampleBuffer != nullptr )
00575     {
00576         TotalBufferSize += SampleBuffer->BufferSize;
00577
00578         // For uncompressed formats, nAvgBytesPerSec should equal nSamplesPerSecond * nBlockAlign
00579         if (TotalBufferSize >= (m_MixFormat->nAvgBytesPerSec * PREROLL_DURATION_SEC))
00580         {
00581             return true;
00582         }
00583
00584         SampleBuffer = SampleBuffer->Next;
00585     }
00586
00587     return false;
00588 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Constants.cpp Source File

  • HttpClient

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "GET Text", "SDKSample.HttpClientSample.Scenario1" },
00022     { "GET Stream", "SDKSample.HttpClientSample.Scenario2" },
00023     { "GET List", "SDKSample.HttpClientSample.Scenario3" },
00024     { "POST Text", "SDKSample.HttpClientSample.Scenario4" },
00025     { "POST Stream", "SDKSample.HttpClientSample.Scenario5" },
00026 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario1.xaml.cpp Source File

  • Compression

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018 #include "CompressionUtils.h"
00019
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::UI::Xaml::Navigation;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::Storage;
00025 using namespace Windows::Storage::Pickers;
00026 using namespace Windows::Storage::Streams;
00027 using namespace Windows::Storage::Compression;
00028
00029 using namespace SDKSample::Compression;
00030
00031 using namespace concurrency;
00032
00033 Scenario1::Scenario1()
00034 {
00035     InitializeComponent();
00036 }
00037
00038 /// <summary>
00039 /// Invoked when this page is about to be displayed in a Frame.
00040 /// </summary>
00041 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00042 /// property is typically used to configure the page.</param>
00043 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00044 {
00045     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00046     // as NotifyUser()
00047     rootPage = MainPage::Current;
00048 }
00049
00050 void ::SDKSample::Compression::Scenario1::DoScenario(CompressAlgorithm Algorithm)
00051 {
00052     Progress->Text = "";
00053
00054     // This scenario uses File Picker which doesn't work in snapped mode - try unsnap first
00055     // and fail gracefully if we can't
00056     if ((ApplicationView::Value == ApplicationViewState::Snapped) &&
00057         !ApplicationView::TryUnsnap())
00058     {
00059         rootPage->NotifyUser("Sample doesn't work in snapped mode", NotifyType::ErrorMessage);
00060         return;
00061     }
00062
00063     rootPage->NotifyUser("Working...", NotifyType::StatusMessage);
00064
00065     auto context = std::make_shared<ScenarioContext>();
00066     context->raStream = ref new InMemoryRandomAccessStream();
00067
00068     auto picker = ref new Pickers::FileOpenPicker();
00069     picker->FileTypeFilter->Append("*");
00070
00071     // First pick a test file and open it for reading
00072     create_task(picker->PickSingleFileAsync()).then([=](StorageFile^ OriginalFile)
00073     {
00074         if (!OriginalFile)
00075         {
00076             throw std::runtime_error("No file has been selected");
00077         }
00078
00079         Progress->Text += "File \"" + OriginalFile->Name + "\" has been picked\n";
00080
00081         return OriginalFile->OpenAsync(FileAccessMode::Read);
00082     })
00083
00084     // Then read the whole file into memory buffer
00085     .then([=](IRandomAccessStream^ OriginalStream)
00086     {
00087         return ReadStreamTask(OriginalStream, context->originalData).GetTask();
00088     })
00089
00090     // Then compress data into in-memory stream
00091     .then([=](size_t BytesRead)
00092     {
00093         Progress->Text += BytesRead + " bytes have been read from disk\n";
00094
00095         auto memoryOutputStream = context->raStream->GetOutputStreamAt(0);
00096
00097         // Use default constructor if you don't need any specific algorithm and/or block size, use
00098         // "extended" constructor otherwise. This samples shows both versions for demonstration
00099         // purposes only.
00100         if (Algorithm == CompressAlgorithm::InvalidAlgorithm)
00101         {
00102             context->compressor = ref new Compressor(memoryOutputStream);
00103         }
00104         else
00105         {
00106             context->compressor = ref new Compressor(memoryOutputStream,
00107                                                         Algorithm,
00108                                                         0           // use default block size
00109                                                         );
00110         }
00111
00112         Progress->Text += "Compressor object has been created\n";
00113
00114         auto dataWriter = ref new DataWriter(context->compressor);
00115         context->writer = dataWriter;
00116         auto data = ref new Platform::Array<byte>(context->originalData.data(), (unsigned int)context->originalData.size());
00117         dataWriter->WriteBytes(data);
00118
00119         return dataWriter->StoreAsync();
00120     })
00121
00122     // Then finalize compression stream
00123     .then([=](unsigned int BytesWritten)
00124     {
00125         Progress->Text += BytesWritten + " bytes have been compressed\n";
00126
00127         return context->compressor->FinishAsync();
00128     })
00129
00130     // Then decompress in-memory stream into vector
00131     .then([=](bool)
00132     {
00133         Progress->Text += "Compressed into " + context->raStream->Size + " bytes\n";
00134
00135         auto decompressor = ref new Decompressor(context->raStream->GetInputStreamAt(0));
00136
00137         Progress->Text += "Decompressor object has been created\n";
00138
00139         return ReadStreamTask(decompressor, context->decompressedData).GetTask();
00140     })
00141
00142     // Then verify if any data has been lost in action
00143     .then([=](size_t BytesRead)
00144     {
00145         Progress->Text += BytesRead + " bytes have been decompressed\n";
00146
00147         if (context->decompressedData.size() != BytesRead)
00148         {
00149             throw std::runtime_error("Decompressed data size doesn't match number of bytes read from in-memory stream");
00150         }
00151
00152         if (context->originalData.size() != context->decompressedData.size())
00153         {
00154             throw std::runtime_error("Decompressed data size doesn't match original one");
00155         }
00156
00157         if (!std::equal(context->originalData.begin(), context->originalData.end(), context->decompressedData.begin()))
00158         {
00159             throw std::runtime_error("Decompressed data doesn't match original one");
00160         }
00161
00162         Progress->Text += "Decompressed data matches original\n";
00163     })
00164
00165     // Final task based continuation is used to handle exceptions in the chain above
00166     .then([=](task<void> FinalContinuation)
00167     {
00168         try
00169         {
00170             // Transport all exceptions to this thread. This task is guaranteed to be completed by now.
00171             FinalContinuation.get();
00172
00173             Progress->Text += "All done\n";
00174             rootPage->NotifyUser("Finished", NotifyType::StatusMessage);
00175         }
00176         catch (Platform::Exception ^e)
00177         {
00178             rootPage->NotifyUser(e->Message, NotifyType::ErrorMessage);
00179         }
00180         catch (const std::exception &e)
00181         {
00182             std::wstringstream wss;
00183             wss << e.what();
00184             rootPage->NotifyUser(ref new Platform::String(wss.str().c_str()), NotifyType::ErrorMessage);
00185         }
00186     });
00187 }
00188
00189 void ::SDKSample::Compression::Scenario1::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00190 {
00191     Button^ b = safe_cast<Button^>(sender);
00192
00193     if (b != nullptr)
00194     {
00195         DoScenario(CompressAlgorithm::InvalidAlgorithm);
00196     }
00197 }
00198
00199 void ::SDKSample::Compression::Scenario1::Xpress_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00200 {
00201     Button^ b = safe_cast<Button^>(sender);
00202
00203     if (b != nullptr)
00204     {
00205         DoScenario(CompressAlgorithm::Xpress);
00206     }
00207 }
00208
00209 void ::SDKSample::Compression::Scenario1::XpressHuff_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00210 {
00211     Button^ b = safe_cast<Button^>(sender);
00212
00213     if (b != nullptr)
00214     {
00215         DoScenario(CompressAlgorithm::XpressHuff);
00216     }
00217 }
00218
00219 void ::SDKSample::Compression::Scenario1::Mszip_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00220 {
00221     Button^ b = safe_cast<Button^>(sender);
00222
00223     if (b != nullptr)
00224     {
00225         DoScenario(CompressAlgorithm::Mszip);
00226     }
00227 }
00228
00229 void ::SDKSample::Compression::Scenario1::Lzms_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00230 {
00231     Button^ b = safe_cast<Button^>(sender);
00232
00233     if (b != nullptr)
00234     {
00235         DoScenario(CompressAlgorithm::Lzms);
00236     }
00237 }
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput3.xaml.cpp Source File

  • Media extensions

ScenarioOutput3.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Output.xaml.cpp
00010 // Implementation of the Scenario3Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput3.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace MediaExtensionsCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput3::ScenarioOutput3()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput3::~ScenarioOutput3()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput3::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Get a pointer to our main page.
00045     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047     _mediaFailedToken = Video->MediaFailed += ref new ExceptionRoutedEventHandler(rootPage, &MediaExtensionsCPP::MainPage::VideoOnError);
00048     _stabilizedMediaFailedToken = VideoStabilized->MediaFailed += ref new ExceptionRoutedEventHandler(rootPage, &MediaExtensionsCPP::MainPage::VideoOnError);
00049 }
00050
00051 void ScenarioOutput3::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     Video->MediaFailed -= _mediaFailedToken;
00054     Video->Source = nullptr;
00055
00056     VideoStabilized->MediaFailed -= _stabilizedMediaFailedToken;
00057     VideoStabilized->Source = nullptr;
00058 }
00059 #pragma endregion
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/App.xaml.cpp Source File

  • XAML WebView control

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level1.h Source File

  • DirectX 3D shooting game

Level1.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Level1:
00011 // This class defines the first level of the game.  There are nine active targets.
00012 // Each of the targets is stationary and can be hit in any order.
00013
00014 #include "Level.h"
00015
00016 ref class Level1: public Level
00017 {
00018 internal:
00019     Level1();
00020     virtual void Initialize(std::vector<GameObject^> objects) override;
00021 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AccountPictureName::App Member List

This is the complete list of members for AccountPictureName::App, including all inherited members.
__pad0__ | AccountPictureName::App |
OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override | AccountPictureName::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | AccountPictureName::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | AccountPictureName::App | [virtual]
rootFrame | AccountPictureName::App | [private]
SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) | AccountPictureName::App | [private]
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/MainPage.xaml.h Source File

  • StreamSocket

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace StreamSocketSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     [Windows::Foundation::Metadata::WebHostHidden]
00032     public ref class MainPageSizeChangedEventArgs sealed
00033     {
00034     public:
00035         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00036         {
00037             Windows::UI::ViewManagement::ApplicationViewState get()
00038             {
00039                 return viewState;
00040             }
00041
00042             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00043             {
00044                 viewState = value;
00045             }
00046         }
00047
00048     private:
00049         Windows::UI::ViewManagement::ApplicationViewState viewState;
00050     };
00051
00052     [Windows::Foundation::Metadata::WebHostHidden]
00053     public ref class MainPage sealed
00054     {
00055     public:
00056         MainPage();
00057
00058         property bool AutoSizeInputSectionWhenSnapped
00059         {
00060             bool get()
00061             {
00062                 return autoSizeInputSectionWhenSnapped;
00063             }
00064
00065             void set(bool value)
00066             {
00067                 autoSizeInputSectionWhenSnapped = value;
00068             }
00069         }
00070
00071         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00072
00073         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00074         void LoadScenario(Platform::String^ scenarioName);
00075         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00076         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00077
00078     private:
00079         ~MainPage();
00080         void SetFeatureName(Platform::String^ strFeature);
00081         void PopulateScenarios();
00082         void InvalidateSize();
00083         void InvalidateViewState();
00084
00085         Platform::Collections::Vector<Object^>^ ScenarioList;
00086         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00087         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00088         bool autoSizeInputSectionWhenSnapped;
00089
00090     protected:
00091         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00092         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00093         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00094
00095     internal:
00096         static MainPage^ Current;
00097
00098     };
00099 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWidePeekImage02 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWidePeekImage02, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::TileContent::TileWidePeekImage02 |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBody1 | NotificationsExtensions::TileContent::TileWidePeekImage02 |
TextBody2 | NotificationsExtensions::TileContent::TileWidePeekImage02 |
TextBody3 | NotificationsExtensions::TileContent::TileWidePeekImage02 |
TextBody4 | NotificationsExtensions::TileContent::TileWidePeekImage02 |
TextFields | NotificationsExtensions::NotificationBase |
TextHeading | NotificationsExtensions::TileContent::TileWidePeekImage02 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWidePeekImage02() | NotificationsExtensions::TileContent::TileWidePeekImage02 | [inline]
TileWidePeekImage02() | NotificationsExtensions::TileContent::TileWidePeekImage02 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/LayoutAwarePage.cpp Source File

  • XAML high contrast style
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_SaveFile.xaml.h Source File

  • File picker contracts

MainPage_SaveFile.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage_SaveFile.xaml.h
00013 // Declaration of the MainPage_SaveFile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage_SaveFile.g.h"
00020
00021 namespace SDKSample
00022 {
00023     namespace FilePickerContracts
00024     {
00025         /// <summary>
00026         /// An empty page that can be used on its own or navigated to within a Frame.
00027         /// </summary>
00028         public ref class MainPage_SaveFile sealed
00029         {
00030         public:
00031             MainPage_SaveFile();
00032
00033         private:
00034             void SaveFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00035         };
00036     }
00037 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/SetLockscreenImage.xaml.h Source File

  • Lock screen personalization

SetLockscreenImage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SetLockscreenImage.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Personalization
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class SetLockscreenImage sealed
00031         {
00032         public:
00033             SetLockscreenImage();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         private:
00039             MainPage^ rootPage;
00040             void PickAndSetButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:08:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/UpdateAsync.xaml.cpp Source File

  • Secondary tiles
  • C#,C++

UpdateAsync.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // UpdateAsync.xaml.cpp
00013 // Implementation of the UpdateAsync class
00014 //
00015
00016 #include "pch.h"
00017 #include "UpdateAsync.xaml.h"
00018
00019 using namespace SecondaryTiles;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::StartScreen;
00025 using namespace Windows::Foundation;
00026 using namespace Platform;
00027 using namespace concurrency;
00028
00029 UpdateAsync::UpdateAsync()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 /// <summary>
00035 /// Invoked when this page is about to be displayed in a Frame.
00036 /// </summary>
00037 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00038 /// property is typically used to configure the page.</param>
00039 void UpdateAsync::OnNavigatedTo(NavigationEventArgs^ e)
00040 {
00041     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00042     // as NotifyUser()
00043     rootPage = MainPage::current;
00044     // Preserve the app bar
00045     appBar = rootPage->BottomAppBar;
00046     // Now null it so we don't show the appbar in this scenario
00047     rootPage->BottomAppBar = nullptr;
00048 }
00049
00050 /// <summary>
00051 /// Invoked when this page is about to be navigated out in a Frame
00052 /// </summary>
00053 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00054 /// property is typically used to configure the page.</param>
00055 void UpdateAsync::OnNavigatingFrom(NavigatingCancelEventArgs^ e)
00056 {
00057     // Restore the app bar
00058     rootPage->BottomAppBar = appBar;
00059 }
00060
00061 void SecondaryTiles::UpdateAsync::UpdateDefaultLogo_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00062 {
00063     Button^ button = safe_cast<Button^>(sender);
00064     if (button != nullptr)
00065     {
00066         if (SecondaryTile::Exists(rootPage->tileId))
00067         {
00068             auto secondaryTile = ref new SecondaryTile(rootPage->tileId);
00069             // Add the properties we want to update (logo in this example)
00070             secondaryTile->Logo = ref new Uri("ms-appx:///Assets/squareTileLogoUpdate-sdk.png");
00071             // Now make the update request
00072             create_task(secondaryTile->UpdateAsync()).then([this](bool isUpdated)
00073             {
00074                 if (isUpdated)
00075                 {
00076                     rootPage->NotifyUser("Secondary tile logo updated.", NotifyType::StatusMessage);
00077                 }
00078                 else
00079                 {
00080                     rootPage->NotifyUser("Secondary tile logo not updated.", NotifyType::ErrorMessage);
00081                 }
00082             });
00083         }
00084         else
00085         {
00086             rootPage->NotifyUser("Please pin a secondary tile using scenario 1 before updating the Logo.", NotifyType::ErrorMessage);
00087         }
00088     }
00089 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario1.xaml.h Source File

  • XAML images

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Images
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DirectXApp.h Source File

  • Direct2Dapp printing

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009 #include "DocSource.h"
00010 #include "D2DPageRenderer.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Declare Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032     void OnVisibilityChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(_In_ Platform::Object^ sender);
00038
00039     void OnActivated(
00040         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00041         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00042         );
00043
00044     void OnSuspending(
00045         _In_ Platform::Object^ sender,
00046         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00047         );
00048
00049     void OnResuming(
00050         _In_ Platform::Object^ sender,
00051         _In_ Platform::Object^ args
00052         );
00053
00054     void OnWindowClosed(
00055         _In_ Windows::UI::Core::CoreWindow^ sender,
00056         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00057         );
00058
00059     void InitPrintManager();
00060
00061     void SetPrintTask(
00062         _In_ Windows::Graphics::Printing::PrintManager^ sender,
00063         _In_ Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ args
00064         );
00065
00066     PageRenderer^                                            m_renderer;
00067     Windows::Graphics::Printing::PrintManager^               m_printManager;
00068     bool                                                     m_windowClosed;
00069     bool                                                     m_windowVisible;
00070 };
00071
00072 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00073 {
00074 public:
00075     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00076 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/FeedData.cpp Source File

  • Getting started with C++ simple blog reader

FeedData.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008
00009 #include "pch.h"
00010 #include "FeedData.h"
00011
00012
00013 using namespace std;
00014 using namespace concurrency;
00015 using namespace SimpleBlogReader;
00016 using namespace Platform;
00017 using namespace Platform::Collections;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Web::Syndication;
00020
00021
00022
00023 FeedDataSource::FeedDataSource()
00024 {
00025     m_feeds = ref new Vector<FeedData^>();
00026 }
00027
00028 // Retrieve the data for each atom or rss feed and put it
00029 // into our custom data structures.
00030 void FeedDataSource::InitDataSource()
00031 {
00032     // Left as an exercise: store the urls separately and let the user configure them.
00033     // It might be more convenient to use Platform::Strings here, but using wstring
00034     // serves to demonstrate how standard C++ types can be used here.
00035     std::vector<std::wstring> urls;
00036     urls.push_back(L"http://windowsteamblog.com/windows/b/developers/atom.aspx");
00037     urls.push_back(L"http://windowsteamblog.com/windows/b/windowsexperience/atom.aspx");
00038     urls.push_back(L"http://windowsteamblog.com/windows/b/extremewindows/atom.aspx");
00039
00040     urls.push_back(L"http://windowsteamblog.com/windows/b/business/atom.aspx");
00041     urls.push_back(L"http://windowsteamblog.com/windows/b/bloggingwindows/atom.aspx");
00042     urls.push_back(L"http://windowsteamblog.com/windows/b/windowssecurity/atom.aspx");
00043     urls.push_back(L"http://windowsteamblog.com/windows/b/springboard/atom.aspx");
00044     urls.push_back(L"http://windowsteamblog.com/windows/b/windowshomeserver/atom.aspx");
00045     // There is no Atom feed for this blog, so we use the RSS feed.
00046     urls.push_back(L"http://windowsteamblog.com/windows_live/b/windowslive/rss.aspx");
00047     urls.push_back(L"http://windowsteamblog.com/windows_live/b/developer/atom.aspx");
00048     urls.push_back(L"http://windowsteamblog.com/ie/b/ie/atom.aspx");
00049     urls.push_back(L"http://windowsteamblog.com/windows_phone/b/wpdev/atom.aspx");
00050     urls.push_back(L"http://windowsteamblog.com/windows_phone/b/wmdev/atom.aspx");
00051
00052     // If we are resuming, we need to create a map of completion events so that
00053     // we don't attempt to restore page's state before it's backing data has been loaded.
00054     // First we create all the  events in an "unset" state, mapped to the urls as keys.
00055     // we'll set the event after we asynchronously load the feed.
00056     for( wstring url : urls)
00057     {
00058         String^ uri = ref new String(url.c_str());
00059         task_completion_event<FeedData^> e;
00060         m_feedCompletionEvents.insert(make_pair(uri, e));
00061     }
00062
00063     SyndicationClient^ client = ref new SyndicationClient();
00064
00065     // Range-based for loop. Never write a regular for loop again!
00066     for(wstring url : urls)
00067     {
00068         // Create the async operation. feedOp is an
00069         // IAsyncOperationWithProgress<SyndicationFeed^, RetrievalProgress>^
00070
00071         String^ uri = ref new String(url.c_str());
00072         auto feedUri = ref new Uri(uri);
00073         auto feedOp = client->RetrieveFeedAsync(feedUri);
00074
00075         // Create the task object and pass it the async operation.
00076         // SyndicationFeed^ is the type of the return value
00077         // that the feedOp operation will eventually produce.
00078
00079         // Then, initialize a FeedData object with the feed info. Each
00080         // operation is independent and does not have to happen on the
00081         // UI thread. Therefore, we specify use_arbitrary.
00082         create_task(feedOp)
00083
00084             .then([this, uri]  (SyndicationFeed^ feed) -> FeedData^
00085         {
00086             return GetFeedData(uri, feed);
00087         }, concurrency::task_continuation_context::use_arbitrary())
00088
00089
00090             // Append the initialized FeedData object to the list
00091             // that is the data source for the items collection.
00092             // This has to happen on the UI thread. By default, a .then
00093             // continuation runs in the same apartment thread that it was called on.
00094             // Because the actions will be synchronized for us, we can append
00095             // safely to the Vector without taking an explicit lock.
00096             .then([this] (FeedData^ fd)
00097         {
00098             m_feeds->Append(fd);
00099             m_feedCompletionEvents[fd->Uri].set(fd);
00100
00101             // Write to VS output window in debug mode only. Requires <windows.h>.
00102             OutputDebugString(fd->Title->Data());
00103             OutputDebugString(L"\r\n");
00104         })
00105
00106             // The last continuation serves as an error handler. The
00107             // call to get() will surface any exceptions that were raised
00108             // at any point in the task chain.
00109             .then( [] (task<void> t)
00110         {
00111             try
00112             {
00113                 t.get();
00114             }
00115             // SyndicationClient throws Platform::InvalidArgumentException
00116             // if a URL contains illegal characters.
00117             // We catch this exception for demonstration purposes only.
00118             // In the current design of this app, an illegal
00119             // character can only be introduced by a coding error
00120             // and should not be caught. If we modify the app to allow
00121             // the user to manually add a new url, then we need to catch
00122             // the exception.
00123             catch(Platform::InvalidArgumentException^ e)
00124             {
00125                 // For example purposes we just output error to console.
00126                 // In a real world app that allowed the user to enter
00127                 // a url manually, you could prompt them to try again.
00128                 OutputDebugString(e->Message->Data());
00129             }
00130         }); //end task chain
00131     };
00132 }
00133
00134
00135 FeedData^ FeedDataSource::GetFeedData(String^ feedUri, SyndicationFeed^ feed)
00136 {
00137
00138     FeedData^ feedData = ref new FeedData();
00139
00140     // Knowing this makes it easier to map completion_events
00141     // when we resume from termination.
00142     feedData->Uri = feedUri;
00143
00144     // Get the title of the feed (not the individual posts).
00145     feedData->Title = feed->Title->Text;
00146
00147     if (feed->Subtitle->Text != nullptr)
00148     {
00149         feedData->Description = feed->Subtitle->Text;
00150     }
00151     // Use the date of the latest post as the last updated date.
00152     feedData->PubDate = feed->Items->GetAt(0)->PublishedDate;
00153
00154     // Construct a FeedItem object for each post in the feed
00155     // using a range-based for loop. Preferable to a
00156     // C-style for loop, or std::for_each.
00157     for (auto  item : feed->Items)
00158     {
00159         FeedItem^ feedItem = ref new FeedItem();
00160         feedItem->Title = item->Title->Text;
00161         feedItem->PubDate = item->PublishedDate;
00162
00163         //We only get first author in case of multiple entries.
00164         feedItem->Author = item->Authors->GetAt(0)->Name;
00165
00166         if (feed->SourceFormat == SyndicationFormat::Atom10)
00167         {
00168             feedItem->Content = item->Content->Text;
00169             String^ s(L"http://windowsteamblog.com");
00170             feedItem->Link = ref new Uri(s + item->Id);
00171         }
00172
00173         else if (feed->SourceFormat == SyndicationFormat::Rss20)
00174         {
00175             feedItem->Content = item->Summary->Text;
00176             feedItem->Link = item->Links->GetAt(0)->Uri;
00177         }
00178
00179         feedData->Items->Append(feedItem);
00180     };
00181
00182     return feedData;
00183
00184 } //end GetFeedData
00185
00186
00187 // We use this method to get the proper FeedData object when resuming
00188 // from shutdown. We need to wait for this data to be populated before
00189 // we attempt to restore page state. Note the use of task_completion_event
00190 // which doesn't block the UI thread.
00191 IAsyncOperation<FeedData^>^ FeedDataSource::GetFeedAsync(String^ uri)
00192 {
00193     return create_async([uri]()
00194     {
00195         auto feedDataSource = safe_cast<FeedDataSource^>(
00196             App::Current->Resources->Lookup("feedDataSource"));
00197
00198         // Does not block the UI thread.
00199         auto f = feedDataSource->m_feedCompletionEvents[uri];
00200
00201         // In the callers we continue from this task after the event is
00202         // set in InitDataSource and we know we have a FeedData^.
00203         task<FeedData^> t = create_task(f);
00204         return t;
00205     });
00206 }
00207
00208 // We stored the stringID when the app was suspended
00209 // because storing the FeedItem itself would have required
00210 // more custom serialization code. Here is where we retrieve
00211 // the FeedItem based on its string ID.
00212 FeedItem^ FeedDataSource::GetFeedItem(FeedData^ feed, String^ uniqueId)
00213 {
00214     auto itEnd = end(feed->Items);
00215     auto it = std::find_if(begin(feed->Items), itEnd,
00216         [uniqueId] (FeedItem^ fi)
00217     {
00218         return fi->Title == uniqueId;
00219     });
00220
00221     if (it != itEnd)
00222         return safe_cast<FeedItem^>(*it);
00223
00224     return nullptr;
00225 }
00226
00227
00228
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Vector3< T > Member List

This is the complete list of members for Vector3< T >, including all inherited members.
b | Vector3< T > |
g | Vector3< T > |
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
operator[](unsigned int index) | Vector3< T > | [inline]
r | Vector3< T > |
u | Vector3< T > |
v | Vector3< T > |
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
Vector3(T _x=0, T _y=0, T _z=0) | Vector3< T > | [inline]
w | Vector3< T > |
x | Vector3< T > |
y | Vector3< T > |
z | Vector3< T > |
Generated on Sat Nov 23 2024 16:09:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/common/LayoutAwarePage.cpp Source File

  • Background Transfer
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperFragment.h Source File

  • DirectX postcard app

PaperFragment.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 ref class PaperFragment
00013 {
00014 internal:
00015     PaperFragment(
00016         Microsoft::WRL::ComPtr<ID2D1DeviceContext> d2dContext,
00017         ID2D1Geometry* pGeometry,
00018         D2D1_COLOR_F &color
00019         );
00020
00021     void Draw();
00022
00023     D2D1_POINT_2F GetPosition();
00024
00025     void SetPosition(
00026         D2D1_POINT_2F position
00027         );
00028
00029     bool HitTest(
00030         D2D1_POINT_2F point
00031         );
00032
00033     bool HitTestWithGeometry(
00034         D2D1_POINT_2F point,
00035         ID2D1Geometry* pGeometry
00036         );
00037
00038     PaperFragment^ GetIntersectionWith(
00039         D2D1_POINT_2F point,
00040         ID2D1Geometry* pGeometry
00041         );
00042
00043     PaperFragment^ GetExclusionWith(
00044         D2D1_POINT_2F point,
00045         ID2D1Geometry* pGeometry
00046         );
00047
00048 private:
00049     void GeneratePaperBitmap();
00050
00051     PaperFragment^ GetMergeWith(
00052         D2D1_POINT_2F point,
00053         ID2D1Geometry* pGeometry,
00054         D2D1_COMBINE_MODE mode
00055         );
00056
00057     Microsoft::WRL::ComPtr<ID2D1DeviceContext>          m_d2dContext;
00058     Microsoft::WRL::ComPtr<ID2D1Geometry>               m_geometry;
00059     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>        m_brush;
00060     Microsoft::WRL::ComPtr<ID2D1Bitmap1>                m_bitmap;
00061
00062     D2D1_COLOR_F                                        m_color;
00063     D2D1_POINT_2F                                       m_position;
00064     D2D1_POINT_2F                                       m_bitmapOffset;
00065 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/Constants.h Source File

  • Snap

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Snap C++ Sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/SetErrorMessage.xaml.h Source File

  • Sharing content source app

SetErrorMessage.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FailWithError.xaml.h
00013 // Declaration of the FailWithError class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SharePage.h"
00020 #include "SetErrorMessage.g.h"
00021 #include "MainPage.xaml.h"
00022
00023 namespace SDKSample
00024 {
00025     namespace ShareSource
00026     {
00027         [Windows::Foundation::Metadata::WebHostHidden]
00028         public ref class SetErrorMessage sealed
00029         {
00030         public:
00031             SetErrorMessage();
00032
00033         protected:
00034             virtual bool GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^ request) override;
00035         };
00036     }
00037 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/ExpiringProduct.xaml.h Source File

  • Trial app and in-app purchase

ExpiringProduct.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ExpiringProduct.xaml.h
00013 // Declaration of the ExpiringProduct class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "ExpiringProduct.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace StoreSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class ExpiringProduct sealed
00031         {
00032         public:
00033             ExpiringProduct();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00038         private:
00039             MainPage^ rootPage;
00040             Windows::Foundation::EventRegistrationToken eventRegistrationToken;
00041
00042             void LoadExpiringProductProxyFile();
00043             void ExpiringProductRefreshScenario();
00044         };
00045     }
00046 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/GetUserDisplayName.xaml.h Source File

  • Account picture name

GetUserDisplayName.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // GetUserDisplayName.xaml.h
00013 // Declaration of the GetUserDisplayName class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "GetUserDisplayName.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace AccountPictureName
00023 {
00024     [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class GetUserDisplayName sealed
00026     {
00027     public:
00028         GetUserDisplayName();
00029
00030     protected:
00031         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032
00033     private:
00034         MainPage^ rootPage;
00035         void GetDisplayNameButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036     };
00037 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Invert/InvertModule.h Source File

  • Media extensions
  • MediaExtensions
  • Invert

InvertModule.h

Go to the documentation of this file.
00001 #pragma once
00002
00003 #include "DirectXVideoTransform.h"
00004 #include <wrl\client.h>
00005 using namespace Microsoft::WRL;
00006
00007 class CInvertModule : public DirectXVideoTransform
00008 {
00009 public:
00010     virtual ~CInvertModule();
00011     virtual void Invalidate();
00012     virtual HRESULT Initialize(ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight);
00013     virtual HRESULT ProcessFrame(ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex);
00014
00015 private:
00016     UINT m_uiWidth, m_uiHeight;
00017     ComPtr<ID3D11Buffer> m_pScreenQuadVB;
00018     ComPtr<ID3D11SamplerState> m_pSampleStateLinear;
00019     ComPtr<ID3D11InputLayout> m_spQuadLayout;
00020     ComPtr<ID3D11VertexShader> m_pVertexShader;
00021     ComPtr<ID3D11PixelShader> m_pPixelShader;
00022 };
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/Constants.h Source File

  • PlayToReceiver

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"PlayTo Receiver");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/common/LayoutAwarePage.cs Source File

  • Custom driver access
  • C#,C++
  • app_cs
  • common

LayoutAwarePage.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using System;
00012 using System.Collections.Generic;
00013 using System.ComponentModel;
00014 using System.Linq;
00015 using Windows.Foundation;
00016 using Windows.Foundation.Collections;
00017 using Windows.UI.ViewManagement;
00018 using Windows.UI.Xaml;
00019 using Windows.UI.Xaml.Controls;
00020
00021 namespace SDKTemplate.Common
00022 {
00023     /// <summary>
00024     /// Typical implementation of Page that provides several important conveniences:
00025     /// application view state to visual state mapping, GoBack and GoHome event handlers, and
00026     /// a default view model.
00027     /// </summary>
00028     [Windows.Foundation.Metadata.WebHostHidden]
00029     public class LayoutAwarePage : Page
00030     {
00031         /// <summary>
00032         /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00033         /// </summary>
00034         public static readonly DependencyProperty DefaultViewModelProperty =
00035             DependencyProperty.Register("DefaultViewModel", typeof(IObservableMap<String, Object>),
00036             typeof(LayoutAwarePage), null);
00037
00038         private List<Control> _layoutAwareControls;
00039
00040         /// <summary>
00041         /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00042         /// </summary>
00043         public LayoutAwarePage()
00044         {
00045             if (Windows.ApplicationModel.DesignMode.DesignModeEnabled) return;
00046
00047             // Create an empty default view model
00048             this.DefaultViewModel = new ObservableDictionary<String, Object>();
00049
00050             // Map application view state to visual state for this page when it is part of the visual tree
00051             this.Loaded += this.StartLayoutUpdates;
00052             this.Unloaded += this.StopLayoutUpdates;
00053         }
00054
00055         /// <summary>
00056         /// An implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00057         /// used as a trivial view model.
00058         /// </summary>
00059         protected IObservableMap<String, Object> DefaultViewModel
00060         {
00061             get
00062             {
00063                 return this.GetValue(DefaultViewModelProperty) as IObservableMap<String, Object>;
00064             }
00065
00066             set
00067             {
00068                 this.SetValue(DefaultViewModelProperty, value);
00069             }
00070         }
00071
00072         /// <summary>
00073         /// Invoked as an event handler to navigate backward in the page's associated
00074         /// <see cref="Frame"/> until it reaches the top of the navigation stack.
00075         /// </summary>
00076         /// <param name="sender">Instance that triggered the event.</param>
00077         /// <param name="e">Event data describing the conditions that led to the event.</param>
00078         protected virtual void GoHome(object sender, RoutedEventArgs e)
00079         {
00080             // Use the navigation frame to return to the topmost page
00081             if (this.Frame != null)
00082             {
00083                 while (this.Frame.CanGoBack) this.Frame.GoBack();
00084             }
00085         }
00086
00087         /// <summary>
00088         /// Invoked as an event handler to navigate backward in the page's associated
00089         /// <see cref="Frame"/> to go back one step on the navigation stack.
00090         /// </summary>
00091         /// <param name="sender">Instance that triggered the event.</param>
00092         /// <param name="e">Event data describing the conditions that led to the
00093         /// event.</param>
00094         protected virtual void GoBack(object sender, RoutedEventArgs e)
00095         {
00096             // Use the navigation frame to return to the previous page
00097             if (this.Frame != null && this.Frame.CanGoBack) this.Frame.GoBack();
00098         }
00099
00100         /// <summary>
00101         /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00102         /// <see cref="Control"/> within the page, to indicate that the sender should start
00103         /// receiving visual state management changes that correspond to application view state
00104         /// changes.
00105         /// </summary>
00106         /// <param name="sender">Instance of <see cref="Control"/> that supports visual state
00107         /// management corresponding to view states.</param>
00108         /// <param name="e">Event data that describes how the request was made.</param>
00109         /// <remarks>The current view state will immediately be used to set the corresponding
00110         /// visual state when layout updates are requested.  A corresponding
00111         /// <see cref="Unloaded"/> event handler connected to <see cref="StopLayoutUpdates"/>
00112         /// is strongly encouraged.  Instances of <see cref="LayoutAwarePage"/> automatically
00113         /// invoke these handlers in their Loaded and Unloaded events.</remarks>
00114         /// <seealso cref="DetermineVisualState"/>
00115         /// <seealso cref="InvalidateVisualState"/>
00116         public void StartLayoutUpdates(object sender, RoutedEventArgs e)
00117         {
00118             var control = sender as Control;
00119             if (control == null) return;
00120             if (this._layoutAwareControls == null)
00121             {
00122                 // Start listening to view state changes when there are controls interested in updates
00123                 Window.Current.SizeChanged += this.WindowSizeChanged;
00124                 this._layoutAwareControls = new List<Control>();
00125             }
00126             this._layoutAwareControls.Add(control);
00127
00128             // Set the initial visual state of the control
00129             VisualStateManager.GoToState(control, DetermineVisualState(ApplicationView.Value), false);
00130         }
00131
00132         private void WindowSizeChanged(object sender, Windows.UI.Core.WindowSizeChangedEventArgs e)
00133         {
00134             this.InvalidateVisualState();
00135         }
00136
00137         /// <summary>
00138         /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00139         /// <see cref="Control"/>, to indicate that the sender should start receiving visual
00140         /// state management changes that correspond to application view state changes.
00141         /// </summary>
00142         /// <param name="sender">Instance of <see cref="Control"/> that supports visual state
00143         /// management corresponding to view states.</param>
00144         /// <param name="e">Event data that describes how the request was made.</param>
00145         /// <remarks>The current view state will immediately be used to set the corresponding
00146         /// visual state when layout updates are requested.</remarks>
00147         /// <seealso cref="StartLayoutUpdates"/>
00148         public void StopLayoutUpdates(object sender, RoutedEventArgs e)
00149         {
00150             var control = sender as Control;
00151             if (control == null || this._layoutAwareControls == null) return;
00152             this._layoutAwareControls.Remove(control);
00153             if (this._layoutAwareControls.Count == 0)
00154             {
00155                 // Stop listening to view state changes when no controls are interested in updates
00156                 this._layoutAwareControls = null;
00157                 Window.Current.SizeChanged -= this.WindowSizeChanged;
00158             }
00159         }
00160
00161         /// <summary>
00162         /// Translates <see cref="ApplicationViewState"/> values into strings for visual state
00163         /// management within the page.  The default implementation uses the names of enum values.
00164         /// Subclasses may override this method to control the mapping scheme used.
00165         /// </summary>
00166         /// <param name="viewState">View state for which a visual state is desired.</param>
00167         /// <returns>Visual state name used to drive the
00168         /// <see cref="VisualStateManager"/></returns>
00169         /// <seealso cref="InvalidateVisualState"/>
00170         protected virtual string DetermineVisualState(ApplicationViewState viewState)
00171         {
00172             return viewState.ToString();
00173         }
00174
00175         /// <summary>
00176         /// Updates all controls that are listening for visual state changes with the correct
00177         /// visual state.
00178         /// </summary>
00179         /// <remarks>
00180         /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00181         /// signal that a different value may be returned even though the view state has not
00182         /// changed.
00183         /// </remarks>
00184         public void InvalidateVisualState()
00185         {
00186             if (this._layoutAwareControls != null)
00187             {
00188                 string visualState = DetermineVisualState(ApplicationView.Value);
00189                 foreach (var layoutAwareControl in this._layoutAwareControls)
00190                 {
00191                     VisualStateManager.GoToState(layoutAwareControl, visualState, false);
00192                 }
00193             }
00194         }
00195
00196         /// <summary>
00197         /// Implementation of IObservableMap that supports reentrancy for use as a default view
00198         /// model.
00199         /// </summary>
00200         private class ObservableDictionary<K, V> : IObservableMap<K, V>
00201         {
00202             private class ObservableDictionaryChangedEventArgs : IMapChangedEventArgs<K>
00203             {
00204                 public ObservableDictionaryChangedEventArgs(CollectionChange change, K key)
00205                 {
00206                     this.CollectionChange = change;
00207                     this.Key = key;
00208                 }
00209
00210                 public CollectionChange CollectionChange { get; private set; }
00211                 public K Key { get; private set; }
00212             }
00213
00214             private Dictionary<K, V> _dictionary = new Dictionary<K, V>();
00215             public event MapChangedEventHandler<K, V> MapChanged;
00216
00217             private void InvokeMapChanged(CollectionChange change, K key)
00218             {
00219                 var eventHandler = MapChanged;
00220                 if (eventHandler != null)
00221                 {
00222                     eventHandler(this, new ObservableDictionaryChangedEventArgs(CollectionChange.ItemInserted, key));
00223                 }
00224             }
00225
00226             public void Add(K key, V value)
00227             {
00228                 this._dictionary.Add(key, value);
00229                 this.InvokeMapChanged(CollectionChange.ItemInserted, key);
00230             }
00231
00232             public void Add(KeyValuePair<K, V> item)
00233             {
00234                 this.Add(item.Key, item.Value);
00235             }
00236
00237             public bool Remove(K key)
00238             {
00239                 if (this._dictionary.Remove(key))
00240                 {
00241                     this.InvokeMapChanged(CollectionChange.ItemRemoved, key);
00242                     return true;
00243                 }
00244                 return false;
00245             }
00246
00247             public bool Remove(KeyValuePair<K, V> item)
00248             {
00249                 V currentValue;
00250                 if (this._dictionary.TryGetValue(item.Key, out currentValue) &&
00251                     Object.Equals(item.Value, currentValue) && this._dictionary.Remove(item.Key))
00252                 {
00253                     this.InvokeMapChanged(CollectionChange.ItemRemoved, item.Key);
00254                     return true;
00255                 }
00256                 return false;
00257             }
00258
00259             public V this[K key]
00260             {
00261                 get
00262                 {
00263                     return this._dictionary[key];
00264                 }
00265                 set
00266                 {
00267                     this._dictionary[key] = value;
00268                     this.InvokeMapChanged(CollectionChange.ItemChanged, key);
00269                 }
00270             }
00271
00272             public void Clear()
00273             {
00274                 var priorKeys = this._dictionary.Keys.ToArray();
00275                 this._dictionary.Clear();
00276                 foreach (var key in priorKeys)
00277                 {
00278                     this.InvokeMapChanged(CollectionChange.ItemRemoved, key);
00279                 }
00280             }
00281
00282             public ICollection<K> Keys
00283             {
00284                 get { return this._dictionary.Keys; }
00285             }
00286
00287             public bool ContainsKey(K key)
00288             {
00289                 return this._dictionary.ContainsKey(key);
00290             }
00291
00292             public bool TryGetValue(K key, out V value)
00293             {
00294                 return this._dictionary.TryGetValue(key, out value);
00295             }
00296
00297             public ICollection<V> Values
00298             {
00299                 get { return this._dictionary.Values; }
00300             }
00301
00302             public bool Contains(KeyValuePair<K, V> item)
00303             {
00304                 return this._dictionary.Contains(item);
00305             }
00306
00307             public int Count
00308             {
00309                 get { return this._dictionary.Count; }
00310             }
00311
00312             public bool IsReadOnly
00313             {
00314                 get { return false; }
00315             }
00316
00317             public IEnumerator<KeyValuePair<K, V>> GetEnumerator()
00318             {
00319                 return this._dictionary.GetEnumerator();
00320             }
00321
00322             System.Collections.IEnumerator System.Collections.IEnumerable.GetEnumerator()
00323             {
00324                 return this._dictionary.GetEnumerator();
00325             }
00326
00327             public void CopyTo(KeyValuePair<K, V>[] array, int arrayIndex)
00328             {
00329                 int arraySize = array.Length;
00330                 foreach (var pair in this._dictionary)
00331                 {
00332                     if (arrayIndex >= arraySize) break;
00333                     array[arrayIndex++] = pair;
00334                 }
00335             }
00336         }
00337     }
00338 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/App.xaml.h Source File

  • Device auto rotation preferences

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/common/LayoutAwarePage.h Source File

  • File picker contracts
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/pch.cpp Source File

  • Folder enumeration

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/PersistentState.h Source File

  • DirectX 3D shooting game

PersistentState.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple helper class that provides support for saving and loading various
00011 // data types to an IPropertySet. Used by DirectX SDK samples to implement
00012 // process lifetime management (PLM).
00013 ref class PersistentState
00014 {
00015 internal:
00016     void Initialize(
00017         _In_ Windows::Foundation::Collections::IPropertySet^ settingsValues,
00018         _In_ Platform::String^ key
00019         );
00020
00021     void SaveBool(Platform::String^ key, bool value);
00022     void SaveInt32(Platform::String^ key, int value);
00023     void SaveSingle(Platform::String^ key, float value);
00024     void SaveXMFLOAT3(Platform::String^ key, DirectX::XMFLOAT3 value);
00025     void SaveString(Platform::String^ key, Platform::String^ string);
00026
00027     bool LoadBool(Platform::String^ key, bool defaultValue);
00028     int  LoadInt32(Platform::String^ key, int defaultValue);
00029     float LoadSingle(Platform::String^ key, float defaultValue);
00030     DirectX::XMFLOAT3 LoadXMFLOAT3(Platform::String^ key, DirectX::XMFLOAT3 defaultValue);
00031     Platform::String^ LoadString(Platform::String^ key, Platform::String^ defaultValue);
00032
00033 private:
00034     Platform::String^ m_keyName;
00035     Windows::Foundation::Collections::IPropertySet^ m_settingsValues;
00036 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/App.xaml.h Source File

  • Playback Manager Companion

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/constants.h Source File

  • Clipboard app

constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace Clipboard
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Clipboard C++");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042     internal:
00043         bool EnsureUnsnapped();
00044
00045     private:
00046         static Platform::Array<Scenario>^ scenariosInner;
00047     };
00048 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/pch.cpp Source File

  • DirectX swap chain implementation

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario6.xaml.h Source File

  • XAML data binding

Scenario6.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.h
00013 // Declaration of the Scenario6 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario6.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace DataBinding
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario6 sealed
00030         {
00031         public:
00032             Scenario6();
00033         private:
00034             MainPage^ rootPage;
00035             void Scenario6Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036
00037         };
00038     }
00039 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/App.xaml.h Source File

  • Context menu

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/pch.cpp Source File

  • CameraOptionsUI

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicShapes.h Source File

  • XAML DirectX 3D shooting game

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/EnableNotificationQueue.xaml.h Source File

  • App tiles and badges
  • C#,C++

EnableNotificationQueue.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // EnableNotificationQueue.xaml.h
00013 // Declaration of the EnableNotificationQueue class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "EnableNotificationQueue.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Tiles
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class EnableNotificationQueue sealed
00031         {
00032         public:
00033             EnableNotificationQueue();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039     void EnableNotificationQueue_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040     void DisableNotificationQueue_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041     void UpdateTile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042     void ClearTile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043         };
00044     }
00045 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput4.xaml.h Source File

  • Print

ScenarioOutput4.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioOutput4.xaml.h
00010 // Declaration of the ScenarioOutput4 class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput4.g.h"
00017
00018 namespace PrintSample
00019 {
00020     public ref class ScenarioOutput4 sealed
00021     {
00022     public:
00023         ScenarioOutput4();
00024     private:
00025         ~ScenarioOutput4();
00026     };
00027 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTexConvert.cpp Source File

  • Direct3D resource loading
  • texconv

DirectXTexConvert.cpp

Go to the documentation of this file.
00001 //-------------------------------------------------------------------------------------
00002 // DirectXTexConvert.cpp
00003 //
00004 // DirectX Texture Library - Image conversion
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //-------------------------------------------------------------------------------------
00013
00014 #include "directxtexp.h"
00015
00016 using namespace DirectX::PackedVector;
00017
00018 namespace DirectX
00019 {
00020
00021 //-------------------------------------------------------------------------------------
00022 // Copies an image row with optional clearing of alpha value to 1.0
00023 // (can be used in place as well) otherwise copies the image row unmodified.
00024 //-------------------------------------------------------------------------------------
00025 void _CopyScanline(_When_(pDestination == pSource, _Inout_updates_bytes_(outSize))
00026                    _When_(pDestination != pSource, _Out_writes_bytes_(outSize))
00027                    LPVOID pDestination, _In_ size_t outSize,
00028                    _In_reads_bytes_(inSize) LPCVOID pSource, _In_ size_t inSize,
00029                    _In_ DXGI_FORMAT format, _In_ DWORD flags)
00030 {
00031     assert( pDestination && outSize > 0 );
00032     assert( pSource && inSize > 0 );
00033     assert( IsValid(format) && !IsVideo(format) );
00034
00035     if ( flags & TEXP_SCANLINE_SETALPHA )
00036     {
00037         switch( format )
00038         {
00039         //-----------------------------------------------------------------------------
00040         case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00041         case DXGI_FORMAT_R32G32B32A32_FLOAT:
00042         case DXGI_FORMAT_R32G32B32A32_UINT:
00043         case DXGI_FORMAT_R32G32B32A32_SINT:
00044             {
00045                 uint32_t alpha;
00046                 if ( format == DXGI_FORMAT_R32G32B32A32_FLOAT )
00047                     alpha = 0x3f800000;
00048                 else if ( format == DXGI_FORMAT_R32G32B32A32_SINT )
00049                     alpha = 0x7fffffff;
00050                 else
00051                     alpha = 0xffffffff;
00052
00053                 if ( pDestination == pSource )
00054                 {
00055                     uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
00056                     for( size_t count = 0; count < outSize; count += 16 )
00057                     {
00058                         dPtr += 3;
00059                         *(dPtr++) = alpha;
00060                     }
00061                 }
00062                 else
00063                 {
00064                     const uint32_t * __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
00065                     uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
00066                     size_t size = std::min<size_t>( outSize, inSize );
00067                     for( size_t count = 0; count < size; count += 16 )
00068                     {
00069                         *(dPtr++) = *(sPtr++);
00070                         *(dPtr++) = *(sPtr++);
00071                         *(dPtr++) = *(sPtr++);
00072                         *(dPtr++) = alpha;
00073                         sPtr++;
00074                     }
00075                 }
00076             }
00077             return;
00078
00079         //-----------------------------------------------------------------------------
00080         case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00081         case DXGI_FORMAT_R16G16B16A16_FLOAT:
00082         case DXGI_FORMAT_R16G16B16A16_UNORM:
00083         case DXGI_FORMAT_R16G16B16A16_UINT:
00084         case DXGI_FORMAT_R16G16B16A16_SNORM:
00085         case DXGI_FORMAT_R16G16B16A16_SINT:
00086             {
00087                 uint16_t alpha;
00088                 if ( format == DXGI_FORMAT_R16G16B16A16_FLOAT )
00089                     alpha = 0x3c00;
00090                 else if ( format == DXGI_FORMAT_R16G16B16A16_SNORM || format == DXGI_FORMAT_R16G16B16A16_SINT )
00091                     alpha = 0x7fff;
00092                 else
00093                     alpha = 0xffff;
00094
00095                 if ( pDestination == pSource )
00096                 {
00097                     uint16_t *dPtr = reinterpret_cast<uint16_t*>(pDestination);
00098                     for( size_t count = 0; count < outSize; count += 8 )
00099                     {
00100                         dPtr += 3;
00101                         *(dPtr++) = alpha;
00102                     }
00103                 }
00104                 else
00105                 {
00106                     const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
00107                     uint16_t * __restrict dPtr = reinterpret_cast<uint16_t*>(pDestination);
00108                     size_t size = std::min<size_t>( outSize, inSize );
00109                     for( size_t count = 0; count < size; count += 8 )
00110                     {
00111                         *(dPtr++) = *(sPtr++);
00112                         *(dPtr++) = *(sPtr++);
00113                         *(dPtr++) = *(sPtr++);
00114                         *(dPtr++) = alpha;
00115                         sPtr++;
00116                     }
00117                 }
00118             }
00119             return;
00120
00121         //-----------------------------------------------------------------------------
00122         case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00123         case DXGI_FORMAT_R10G10B10A2_UNORM:
00124         case DXGI_FORMAT_R10G10B10A2_UINT:
00125         case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00126             if ( pDestination == pSource )
00127             {
00128                 uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
00129                 for( size_t count = 0; count < outSize; count += 4 )
00130                 {
00131 #pragma warning(suppress: 6001 6101) // PREFast doesn't properly understand the aliasing here.
00132                     *dPtr |= 0xC0000000;
00133                     ++dPtr;
00134                 }
00135             }
00136             else
00137             {
00138                 const uint32_t * __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
00139                 uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
00140                 size_t size = std::min<size_t>( outSize, inSize );
00141                 for( size_t count = 0; count < size; count += 4 )
00142                 {
00143                     *(dPtr++) = *(sPtr++) | 0xC0000000;
00144                 }
00145             }
00146             return;
00147
00148         //-----------------------------------------------------------------------------
00149         case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00150         case DXGI_FORMAT_R8G8B8A8_UNORM:
00151         case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00152         case DXGI_FORMAT_R8G8B8A8_UINT:
00153         case DXGI_FORMAT_R8G8B8A8_SNORM:
00154         case DXGI_FORMAT_R8G8B8A8_SINT:
00155         case DXGI_FORMAT_B8G8R8A8_UNORM:
00156         case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00157         case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00158             {
00159                 const uint32_t alpha = ( format == DXGI_FORMAT_R8G8B8A8_SNORM || format == DXGI_FORMAT_R8G8B8A8_SINT ) ? 0x7f000000 : 0xff000000;
00160
00161                 if ( pDestination == pSource )
00162                 {
00163                     uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
00164                     for( size_t count = 0; count < outSize; count += 4 )
00165                     {
00166                         uint32_t t = *dPtr & 0xFFFFFF;
00167                         t |= alpha;
00168                         *(dPtr++) = t;
00169                     }
00170                 }
00171                 else
00172                 {
00173                     const uint32_t * __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
00174                     uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
00175                     size_t size = std::min<size_t>( outSize, inSize );
00176                     for( size_t count = 0; count < size; count += 4 )
00177                     {
00178                         uint32_t t = *(sPtr++) & 0xFFFFFF;
00179                         t |= alpha;
00180                         *(dPtr++) = t;
00181                     }
00182                 }
00183             }
00184             return;
00185
00186         //-----------------------------------------------------------------------------
00187         case DXGI_FORMAT_B5G5R5A1_UNORM:
00188             if ( pDestination == pSource )
00189             {
00190                 uint16_t *dPtr = reinterpret_cast<uint16_t*>(pDestination);
00191                 for( size_t count = 0; count < outSize; count += 2 )
00192                 {
00193                     *(dPtr++) |= 0x8000;
00194                 }
00195             }
00196             else
00197             {
00198                 const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
00199                 uint16_t * __restrict dPtr = reinterpret_cast<uint16_t*>(pDestination);
00200                 size_t size = std::min<size_t>( outSize, inSize );
00201                 for( size_t count = 0; count < size; count += 2 )
00202                 {
00203                     *(dPtr++) = *(sPtr++) | 0x8000;
00204                 }
00205             }
00206             return;
00207
00208         //-----------------------------------------------------------------------------
00209         case DXGI_FORMAT_A8_UNORM:
00210             memset( pDestination, 0xff, outSize );
00211             return;
00212
00213         //-----------------------------------------------------------------------------
00214         case DXGI_FORMAT_B4G4R4A4_UNORM:
00215             if ( pDestination == pSource )
00216             {
00217                 uint16_t *dPtr = reinterpret_cast<uint16_t*>(pDestination);
00218                 for( size_t count = 0; count < outSize; count += 2 )
00219                 {
00220                     *(dPtr++) |= 0xF000;
00221                 }
00222             }
00223             else
00224             {
00225                 const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
00226                 uint16_t * __restrict dPtr = reinterpret_cast<uint16_t*>(pDestination);
00227                 size_t size = std::min<size_t>( outSize, inSize );
00228                 for( size_t count = 0; count < size; count += 2 )
00229                 {
00230                     *(dPtr++) = *(sPtr++) | 0xF000;
00231                 }
00232             }
00233             return;
00234         }
00235     }
00236
00237     // Fall-through case is to just use memcpy (assuming this is not an in-place operation)
00238     if ( pDestination == pSource )
00239         return;
00240
00241     size_t size = std::min<size_t>( outSize, inSize );
00242     memcpy_s( pDestination, outSize, pSource, size );
00243 }
00244
00245
00246 //-------------------------------------------------------------------------------------
00247 // Swizzles (RGB <-> BGR) an image row with optional clearing of alpha value to 1.0
00248 // (can be used in place as well) otherwise copies the image row unmodified.
00249 //-------------------------------------------------------------------------------------
00250 _Use_decl_annotations_
00251 void _SwizzleScanline( LPVOID pDestination, size_t outSize, LPCVOID pSource, size_t inSize, DXGI_FORMAT format, DWORD flags )
00252 {
00253     assert( pDestination && outSize > 0 );
00254     assert( pSource && inSize > 0 );
00255     assert( IsValid(format) && !IsVideo(format) );
00256
00257     switch( format )
00258     {
00259     //---------------------------------------------------------------------------------
00260     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00261     case DXGI_FORMAT_R10G10B10A2_UNORM:
00262     case DXGI_FORMAT_R10G10B10A2_UINT:
00263     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00264         if ( flags & TEXP_SCANLINE_LEGACY )
00265         {
00266             // Swap Red (R) and Blue (B) channel (used for D3DFMT_A2R10G10B10 legacy sources)
00267             if ( pDestination == pSource )
00268             {
00269                 uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
00270                 for( size_t count = 0; count < outSize; count += 4 )
00271                 {
00272 #pragma warning(suppress: 6001 6101) // PREFast doesn't properly understand the aliasing here.
00273                     uint32_t t = *dPtr;
00274
00275                     uint32_t t1 = (t & 0x3ff00000) >> 20;
00276                     uint32_t t2 = (t & 0x000003ff) << 20;
00277                     uint32_t t3 = (t & 0x000ffc00);
00278                     uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xC0000000 : (t & 0xC0000000);
00279
00280                     *(dPtr++) = t1 | t2 | t3 | ta;
00281                 }
00282             }
00283             else
00284             {
00285                 const uint32_t * __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
00286                 uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
00287                 size_t size = std::min<size_t>( outSize, inSize );
00288                 for( size_t count = 0; count < size; count += 4 )
00289                 {
00290                     uint32_t t = *(sPtr++);
00291
00292                     uint32_t t1 = (t & 0x3ff00000) >> 20;
00293                     uint32_t t2 = (t & 0x000003ff) << 20;
00294                     uint32_t t3 = (t & 0x000ffc00);
00295                     uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xC0000000 : (t & 0xC0000000);
00296
00297                     *(dPtr++) = t1 | t2 | t3 | ta;
00298                 }
00299             }
00300             return;
00301         }
00302         break;
00303
00304     //---------------------------------------------------------------------------------
00305     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00306     case DXGI_FORMAT_R8G8B8A8_UNORM:
00307     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00308     case DXGI_FORMAT_B8G8R8A8_UNORM:
00309     case DXGI_FORMAT_B8G8R8X8_UNORM:
00310     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00311     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00312     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00313     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00314         // Swap Red (R) and Blue (B) channels (used to convert from DXGI 1.1 BGR formats to DXGI 1.0 RGB)
00315         if ( pDestination == pSource )
00316         {
00317             uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
00318             for( size_t count = 0; count < outSize; count += 4 )
00319             {
00320                 uint32_t t = *dPtr;
00321
00322                 uint32_t t1 = (t & 0x00ff0000) >> 16;
00323                 uint32_t t2 = (t & 0x000000ff) << 16;
00324                 uint32_t t3 = (t & 0x0000ff00);
00325                 uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xff000000 : (t & 0xFF000000);
00326
00327                 *(dPtr++) = t1 | t2 | t3 | ta;
00328             }
00329         }
00330         else
00331         {
00332             const uint32_t * __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
00333             uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
00334             size_t size = std::min<size_t>( outSize, inSize );
00335             for( size_t count = 0; count < size; count += 4 )
00336             {
00337                 uint32_t t = *(sPtr++);
00338
00339                 uint32_t t1 = (t & 0x00ff0000) >> 16;
00340                 uint32_t t2 = (t & 0x000000ff) << 16;
00341                 uint32_t t3 = (t & 0x0000ff00);
00342                 uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xff000000 : (t & 0xFF000000);
00343
00344                 *(dPtr++) = t1 | t2 | t3 | ta;
00345             }
00346         }
00347         return;
00348     }
00349
00350     // Fall-through case is to just use memcpy (assuming this is not an in-place operation)
00351     if ( pDestination == pSource )
00352         return;
00353
00354     size_t size = std::min<size_t>( outSize, inSize );
00355     memcpy_s( pDestination, outSize, pSource, size );
00356 }
00357
00358
00359 //-------------------------------------------------------------------------------------
00360 // Converts an image row with optional clearing of alpha value to 1.0
00361 // Returns true if supported, false if expansion case not supported
00362 //-------------------------------------------------------------------------------------
00363 _Use_decl_annotations_
00364 bool _ExpandScanline( LPVOID pDestination, size_t outSize, DXGI_FORMAT outFormat,
00365                       LPCVOID pSource, size_t inSize, DXGI_FORMAT inFormat, DWORD flags )
00366 {
00367     assert( pDestination && outSize > 0 );
00368     assert( pSource && inSize > 0 );
00369     assert( IsValid(outFormat) && !IsVideo(outFormat) );
00370     assert( IsValid(inFormat) && !IsVideo(inFormat) );
00371
00372     switch( inFormat )
00373     {
00374     case DXGI_FORMAT_B5G6R5_UNORM:
00375         if ( outFormat != DXGI_FORMAT_R8G8B8A8_UNORM )
00376             return false;
00377
00378         // DXGI_FORMAT_B5G6R5_UNORM -> DXGI_FORMAT_R8G8B8A8_UNORM
00379         {
00380             const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
00381             uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
00382
00383             for( size_t ocount = 0, icount = 0; ((icount < inSize) && (ocount < outSize)); icount += 2, ocount += 4 )
00384             {
00385                 uint16_t t = *(sPtr++);
00386
00387                 uint32_t t1 = ((t & 0xf800) >> 8) | ((t & 0xe000) >> 13);
00388                 uint32_t t2 = ((t & 0x07e0) << 5) | ((t & 0x0600) >> 5);
00389                 uint32_t t3 = ((t & 0x001f) << 19) | ((t & 0x001c) << 14);
00390
00391                 *(dPtr++) = t1 | t2 | t3 | 0xff000000;
00392             }
00393         }
00394         return true;
00395
00396     case DXGI_FORMAT_B5G5R5A1_UNORM:
00397         if ( outFormat != DXGI_FORMAT_R8G8B8A8_UNORM )
00398             return false;
00399
00400         // DXGI_FORMAT_B5G5R5A1_UNORM -> DXGI_FORMAT_R8G8B8A8_UNORM
00401         {
00402             const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
00403             uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
00404
00405             for( size_t ocount = 0, icount = 0; ((icount < inSize) && (ocount < outSize)); icount += 2, ocount += 4 )
00406             {
00407                 uint16_t t = *(sPtr++);
00408
00409                 uint32_t t1 = ((t & 0x7c00) >> 7) | ((t & 0x7000) >> 12);
00410                 uint32_t t2 = ((t & 0x03e0) << 6) | ((t & 0x0380) << 1);
00411                 uint32_t t3 = ((t & 0x001f) << 19) | ((t & 0x001c) << 14);
00412                 uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xff000000 : ((t & 0x8000) ? 0xff000000 : 0);
00413
00414                 *(dPtr++) = t1 | t2 | t3 | ta;
00415             }
00416         }
00417         return true;
00418
00419     case DXGI_FORMAT_B4G4R4A4_UNORM:
00420         if ( outFormat != DXGI_FORMAT_R8G8B8A8_UNORM )
00421             return false;
00422
00423         // DXGI_FORMAT_B4G4R4A4_UNORM -> DXGI_FORMAT_R8G8B8A8_UNORM
00424         {
00425             const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
00426             uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
00427
00428             for( size_t ocount = 0, icount = 0; ((icount < inSize) && (ocount < outSize)); icount += 2, ocount += 4 )
00429             {
00430                 uint16_t t = *(sPtr++);
00431
00432                 uint32_t t1 = ((t & 0x0f00) >> 4) | ((t & 0x0f00) >> 8);
00433                 uint32_t t2 = ((t & 0x00f0) << 8) | ((t & 0x00f0) << 4);
00434                 uint32_t t3 = ((t & 0x000f) << 20) | ((t & 0x000f) << 16);
00435                 uint32_t ta = ( flags & TEXP_SCANLINE_SETALPHA ) ? 0xff000000 : (((t & 0xf000) << 16) | ((t & 0xf000) << 12));
00436
00437                 *(dPtr++) = t1 | t2 | t3 | ta;
00438             }
00439         }
00440         return true;
00441     }
00442
00443     return false;
00444 }
00445
00446
00447 //-------------------------------------------------------------------------------------
00448 // Loads an image row into standard RGBA XMVECTOR (aligned) array
00449 //-------------------------------------------------------------------------------------
00450 #define LOAD_SCANLINE( type, func )\
00451         if ( size >= sizeof(type) )\
00452         {\
00453             const type * __restrict sPtr = reinterpret_cast<const type*>(pSource);\
00454             for( size_t icount = 0; icount < size; icount += sizeof(type) )\
00455             {\
00456                 if ( dPtr >= ePtr ) break;\
00457                 *(dPtr++) = func( sPtr++ );\
00458             }\
00459             return true;\
00460         }\
00461         return false;
00462
00463 #define LOAD_SCANLINE3( type, func, defvec )\
00464         if ( size >= sizeof(type) )\
00465         {\
00466             const type * __restrict sPtr = reinterpret_cast<const type*>(pSource);\
00467             for( size_t icount = 0; icount < size; icount += sizeof(type) )\
00468             {\
00469                 XMVECTOR v = func( sPtr++ );\
00470                 if ( dPtr >= ePtr ) break;\
00471                 *(dPtr++) = XMVectorSelect( defvec, v, g_XMSelect1110 );\
00472             }\
00473             return true;\
00474         }\
00475         return false;
00476
00477 #define LOAD_SCANLINE2( type, func, defvec )\
00478         if ( size >= sizeof(type) )\
00479         {\
00480             const type * __restrict sPtr = reinterpret_cast<const type*>(pSource);\
00481             for( size_t icount = 0; icount < size; icount += sizeof(type) )\
00482             {\
00483                 XMVECTOR v = func( sPtr++ );\
00484                 if ( dPtr >= ePtr ) break;\
00485                 *(dPtr++) = XMVectorSelect( defvec, v, g_XMSelect1100 );\
00486             }\
00487                 return true;\
00488         }\
00489         return false;
00490
00491 _Use_decl_annotations_
00492 bool _LoadScanline( XMVECTOR* pDestination, size_t count,
00493                     LPCVOID pSource, size_t size, DXGI_FORMAT format )
00494 {
00495     assert( pDestination && count > 0 && (((uintptr_t)pDestination & 0xF) == 0) );
00496     assert( pSource && size > 0 );
00497     assert( IsValid(format) && !IsVideo(format) && !IsTypeless(format) && !IsCompressed(format) );
00498
00499     XMVECTOR* __restrict dPtr = pDestination;
00500     if ( !dPtr )
00501         return false;
00502
00503     const XMVECTOR* ePtr = pDestination + count;
00504
00505     switch( format )
00506     {
00507     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00508         {
00509             size_t msize = (size > (sizeof(XMVECTOR)*count)) ? (sizeof(XMVECTOR)*count) : size;
00510             memcpy_s( dPtr, sizeof(XMVECTOR)*count, pSource, msize );
00511         }
00512         return true;
00513
00514     case DXGI_FORMAT_R32G32B32A32_UINT:
00515         LOAD_SCANLINE( XMUINT4, XMLoadUInt4 )
00516
00517     case DXGI_FORMAT_R32G32B32A32_SINT:
00518         LOAD_SCANLINE( XMINT4, XMLoadSInt4 )
00519
00520     case DXGI_FORMAT_R32G32B32_FLOAT:
00521         LOAD_SCANLINE3( XMFLOAT3, XMLoadFloat3, g_XMIdentityR3 )
00522
00523     case DXGI_FORMAT_R32G32B32_UINT:
00524         LOAD_SCANLINE3( XMUINT3, XMLoadUInt3, g_XMIdentityR3 )
00525
00526     case DXGI_FORMAT_R32G32B32_SINT:
00527         LOAD_SCANLINE3( XMINT3, XMLoadSInt3, g_XMIdentityR3 )
00528
00529     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00530         LOAD_SCANLINE( XMHALF4, XMLoadHalf4 )
00531
00532     case DXGI_FORMAT_R16G16B16A16_UNORM:
00533         LOAD_SCANLINE( XMUSHORTN4, XMLoadUShortN4 )
00534
00535     case DXGI_FORMAT_R16G16B16A16_UINT:
00536         LOAD_SCANLINE( XMUSHORT4, XMLoadUShort4 )
00537
00538     case DXGI_FORMAT_R16G16B16A16_SNORM:
00539         LOAD_SCANLINE( XMSHORTN4, XMLoadShortN4 )
00540
00541     case DXGI_FORMAT_R16G16B16A16_SINT:
00542         LOAD_SCANLINE( XMSHORT4, XMLoadShort4 )
00543
00544     case DXGI_FORMAT_R32G32_FLOAT:
00545         LOAD_SCANLINE2( XMFLOAT2, XMLoadFloat2, g_XMIdentityR3 )
00546
00547     case DXGI_FORMAT_R32G32_UINT:
00548         LOAD_SCANLINE2( XMUINT2, XMLoadUInt2, g_XMIdentityR3 )
00549
00550     case DXGI_FORMAT_R32G32_SINT:
00551         LOAD_SCANLINE2( XMINT2, XMLoadSInt2, g_XMIdentityR3 )
00552
00553     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00554         if ( size >= (sizeof(float)+sizeof(uint32_t)) )
00555         {
00556             const float * sPtr = reinterpret_cast<const float*>(pSource);
00557             for( size_t icount = 0; icount < size; icount += (sizeof(float)+sizeof(uint32_t)) )
00558             {
00559                 const uint8_t* ps8 = reinterpret_cast<const uint8_t*>( &sPtr[1] );
00560                 if ( dPtr >= ePtr ) break;
00561                 *(dPtr++) = XMVectorSet( sPtr[0], static_cast<float>( *ps8 ), 0.f, 1.f );
00562                 sPtr += 2;
00563             }
00564             return true;
00565         }
00566         return false;
00567
00568     case DXGI_FORMAT_R10G10B10A2_UNORM:
00569     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00570         LOAD_SCANLINE( XMUDECN4, XMLoadUDecN4 );
00571
00572     case DXGI_FORMAT_R10G10B10A2_UINT:
00573         LOAD_SCANLINE( XMUDEC4, XMLoadUDec4 );
00574
00575     case DXGI_FORMAT_R11G11B10_FLOAT:
00576         LOAD_SCANLINE3( XMFLOAT3PK, XMLoadFloat3PK, g_XMIdentityR3 );
00577
00578     case DXGI_FORMAT_R8G8B8A8_UNORM:
00579     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00580         LOAD_SCANLINE( XMUBYTEN4, XMLoadUByteN4 )
00581
00582     case DXGI_FORMAT_R8G8B8A8_UINT:
00583         LOAD_SCANLINE( XMUBYTE4, XMLoadUByte4 )
00584
00585     case DXGI_FORMAT_R8G8B8A8_SNORM:
00586         LOAD_SCANLINE( XMBYTEN4, XMLoadByteN4 )
00587
00588     case DXGI_FORMAT_R8G8B8A8_SINT:
00589         LOAD_SCANLINE( XMBYTE4, XMLoadByte4 )
00590
00591     case DXGI_FORMAT_R16G16_FLOAT:
00592         LOAD_SCANLINE2( XMHALF2, XMLoadHalf2, g_XMIdentityR3 )
00593
00594     case DXGI_FORMAT_R16G16_UNORM:
00595         LOAD_SCANLINE2( XMUSHORTN2, XMLoadUShortN2, g_XMIdentityR3 )
00596
00597     case DXGI_FORMAT_R16G16_UINT:
00598         LOAD_SCANLINE2( XMUSHORT2, XMLoadUShort2, g_XMIdentityR3 )
00599
00600     case DXGI_FORMAT_R16G16_SNORM:
00601         LOAD_SCANLINE2( XMSHORTN2, XMLoadShortN2, g_XMIdentityR3 )
00602
00603     case DXGI_FORMAT_R16G16_SINT:
00604         LOAD_SCANLINE2( XMSHORT2, XMLoadShort2, g_XMIdentityR3 )
00605
00606     case DXGI_FORMAT_D32_FLOAT:
00607     case DXGI_FORMAT_R32_FLOAT:
00608         if ( size >= sizeof(float) )
00609         {
00610             const float* __restrict sPtr = reinterpret_cast<const float*>(pSource);
00611             for( size_t icount = 0; icount < size; icount += sizeof(float) )
00612             {
00613                 XMVECTOR v = XMLoadFloat( sPtr++ );
00614                 if ( dPtr >= ePtr ) break;
00615                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1000 );
00616             }
00617             return true;
00618         }
00619         return false;
00620
00621     case DXGI_FORMAT_R32_UINT:
00622         if ( size >= sizeof(uint32_t) )
00623         {
00624             const uint32_t* __restrict sPtr = reinterpret_cast<const uint32_t*>(pSource);
00625             for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
00626             {
00627                 XMVECTOR v = XMLoadInt( sPtr++ );
00628                 v = XMConvertVectorUIntToFloat( v, 0 );
00629                 if ( dPtr >= ePtr ) break;
00630                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1000 );
00631             }
00632             return true;
00633         }
00634         return false;
00635
00636     case DXGI_FORMAT_R32_SINT:
00637         if ( size >= sizeof(int32_t) )
00638         {
00639             const int32_t * __restrict sPtr = reinterpret_cast<const int32_t*>(pSource);
00640             for( size_t icount = 0; icount < size; icount += sizeof(int32_t) )
00641             {
00642                 XMVECTOR v = XMLoadInt( reinterpret_cast<const uint32_t*> (sPtr++) );
00643                 v = XMConvertVectorIntToFloat( v, 0 );
00644                 if ( dPtr >= ePtr ) break;
00645                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1000 );
00646             }
00647             return true;
00648         }
00649         return false;
00650
00651     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00652         if ( size >= sizeof(uint32_t) )
00653         {
00654             const uint32_t * sPtr = reinterpret_cast<const uint32_t*>(pSource);
00655             for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
00656             {
00657                 float d = static_cast<float>( *sPtr & 0xFFFFFF ) / 16777215.f;
00658                 float s = static_cast<float>( ( *sPtr & 0xFF000000 ) >> 24 );
00659                 ++sPtr;
00660                 if ( dPtr >= ePtr ) break;
00661                 *(dPtr++) = XMVectorSet( d, s, 0.f, 1.f );
00662             }
00663             return true;
00664         }
00665         return false;
00666
00667     case DXGI_FORMAT_R8G8_UNORM:
00668         LOAD_SCANLINE2( XMUBYTEN2, XMLoadUByteN2, g_XMIdentityR3 )
00669
00670     case DXGI_FORMAT_R8G8_UINT:
00671         LOAD_SCANLINE2( XMUBYTE2, XMLoadUByte2, g_XMIdentityR3 )
00672
00673     case DXGI_FORMAT_R8G8_SNORM:
00674         LOAD_SCANLINE2( XMBYTEN2, XMLoadByteN2, g_XMIdentityR3 )
00675
00676     case DXGI_FORMAT_R8G8_SINT:
00677         LOAD_SCANLINE2( XMBYTE2, XMLoadByte2, g_XMIdentityR3 )
00678
00679     case DXGI_FORMAT_R16_FLOAT:
00680         if ( size >= sizeof(HALF) )
00681         {
00682             const HALF * __restrict sPtr = reinterpret_cast<const HALF*>(pSource);
00683             for( size_t icount = 0; icount < size; icount += sizeof(HALF) )
00684             {
00685                 if ( dPtr >= ePtr ) break;
00686                 *(dPtr++) = XMVectorSet( XMConvertHalfToFloat(*sPtr++), 0.f, 0.f, 1.f );
00687             }
00688             return true;
00689         }
00690         return false;
00691
00692     case DXGI_FORMAT_D16_UNORM:
00693     case DXGI_FORMAT_R16_UNORM:
00694         if ( size >= sizeof(uint16_t) )
00695         {
00696             const uint16_t* __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
00697             for( size_t icount = 0; icount < size; icount += sizeof(uint16_t) )
00698             {
00699                 if ( dPtr >= ePtr ) break;
00700                 *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++) / 65535.f, 0.f, 0.f, 1.f );
00701             }
00702             return true;
00703         }
00704         return false;
00705
00706     case DXGI_FORMAT_R16_UINT:
00707         if ( size >= sizeof(uint16_t) )
00708         {
00709             const uint16_t * __restrict sPtr = reinterpret_cast<const uint16_t*>(pSource);
00710             for( size_t icount = 0; icount < size; icount += sizeof(uint16_t) )
00711             {
00712                 if ( dPtr >= ePtr ) break;
00713                 *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++), 0.f, 0.f, 1.f );
00714             }
00715             return true;
00716         }
00717         return false;
00718
00719     case DXGI_FORMAT_R16_SNORM:
00720         if ( size >= sizeof(int16_t) )
00721         {
00722             const int16_t * __restrict sPtr = reinterpret_cast<const int16_t*>(pSource);
00723             for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
00724             {
00725                 if ( dPtr >= ePtr ) break;
00726                 *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++) / 32767.f, 0.f, 0.f, 1.f );
00727             }
00728             return true;
00729         }
00730         return false;
00731
00732     case DXGI_FORMAT_R16_SINT:
00733         if ( size >= sizeof(int16_t) )
00734         {
00735             const int16_t * __restrict sPtr = reinterpret_cast<const int16_t*>(pSource);
00736             for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
00737             {
00738                 if ( dPtr >= ePtr ) break;
00739                 *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++), 0.f, 0.f, 1.f );
00740             }
00741             return true;
00742         }
00743         return false;
00744
00745     case DXGI_FORMAT_R8_UNORM:
00746         if ( size >= sizeof(uint8_t) )
00747         {
00748             const uint8_t * __restrict sPtr = reinterpret_cast<const uint8_t*>(pSource);
00749             for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
00750             {
00751                 if ( dPtr >= ePtr ) break;
00752                 *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++) / 255.f, 0.f, 0.f, 1.f );
00753             }
00754             return true;
00755         }
00756         return false;
00757
00758     case DXGI_FORMAT_R8_UINT:
00759         if ( size >= sizeof(uint8_t) )
00760         {
00761             const uint8_t * __restrict sPtr = reinterpret_cast<const uint8_t*>(pSource);
00762             for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
00763             {
00764                 if ( dPtr >= ePtr ) break;
00765                 *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++), 0.f, 0.f, 1.f );
00766             }
00767             return true;
00768         }
00769         return false;
00770
00771     case DXGI_FORMAT_R8_SNORM:
00772         if ( size >= sizeof(char) )
00773         {
00774             const char * __restrict sPtr = reinterpret_cast<const char*>(pSource);
00775             for( size_t icount = 0; icount < size; icount += sizeof(char) )
00776             {
00777                 if ( dPtr >= ePtr ) break;
00778                 *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++) / 127.f, 0.f, 0.f, 1.f );
00779             }
00780             return true;
00781         }
00782         return false;
00783
00784     case DXGI_FORMAT_R8_SINT:
00785         if ( size >= sizeof(char) )
00786         {
00787             const char * __restrict sPtr = reinterpret_cast<const char*>(pSource);
00788             for( size_t icount = 0; icount < size; icount += sizeof(char) )
00789             {
00790                 if ( dPtr >= ePtr ) break;
00791                 *(dPtr++) = XMVectorSet( static_cast<float>(*sPtr++), 0.f, 0.f, 1.f );
00792             }
00793             return true;
00794         }
00795         return false;
00796
00797     case DXGI_FORMAT_A8_UNORM:
00798         if ( size >= sizeof(uint8_t) )
00799         {
00800             const uint8_t * __restrict sPtr = reinterpret_cast<const uint8_t*>(pSource);
00801             for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
00802             {
00803                 if ( dPtr >= ePtr ) break;
00804                 *(dPtr++) = XMVectorSet( 0.f, 0.f, 0.f, static_cast<float>(*sPtr++) / 255.f );
00805             }
00806             return true;
00807         }
00808         return false;
00809
00810     case DXGI_FORMAT_R1_UNORM:
00811         if ( size >= sizeof(uint8_t) )
00812         {
00813             const uint8_t * __restrict sPtr = reinterpret_cast<const uint8_t*>(pSource);
00814             for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
00815             {
00816                 for( size_t bcount = 0; bcount < 8; ++bcount )
00817                 {
00818                     if ( dPtr >= ePtr ) break;
00819                     *(dPtr++) = XMVectorSet( (((*sPtr >> bcount) & 0x1) ? 1.f : 0.f), 0.f, 0.f, 1.f );
00820                 }
00821
00822                 ++sPtr;
00823             }
00824             return true;
00825         }
00826         return false;
00827
00828     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00829         LOAD_SCANLINE3( XMFLOAT3SE, XMLoadFloat3SE, g_XMIdentityR3 )
00830
00831     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00832         if ( size >= sizeof(XMUBYTEN4) )
00833         {
00834             const XMUBYTEN4 * __restrict sPtr = reinterpret_cast<const XMUBYTEN4*>(pSource);
00835             for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
00836             {
00837                 XMVECTOR v = XMLoadUByteN4( sPtr++ );
00838                 XMVECTOR v1 = XMVectorSwizzle<0, 3, 2, 1>( v );
00839                 if ( dPtr >= ePtr ) break;
00840                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1110 );
00841                 if ( dPtr >= ePtr ) break;
00842                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v1, g_XMSelect1110 );
00843             }
00844             return true;
00845         }
00846         return false;
00847
00848     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00849         if ( size >= sizeof(XMUBYTEN4) )
00850         {
00851             const XMUBYTEN4 * __restrict sPtr = reinterpret_cast<const XMUBYTEN4*>(pSource);
00852             for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
00853             {
00854                 XMVECTOR v = XMLoadUByteN4( sPtr++ );
00855                 XMVECTOR v0 = XMVectorSwizzle<1, 0, 3, 2>( v );
00856                 XMVECTOR v1 = XMVectorSwizzle<1, 2, 3, 0>( v );
00857                 if ( dPtr >= ePtr ) break;
00858                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v0, g_XMSelect1110 );
00859                 if ( dPtr >= ePtr ) break;
00860                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v1, g_XMSelect1110 );
00861             }
00862             return true;
00863         }
00864         return false;
00865
00866     case DXGI_FORMAT_B5G6R5_UNORM:
00867         if ( size >= sizeof(XMU565) )
00868         {
00869             static XMVECTORF32 s_Scale = { 1.f/31.f, 1.f/63.f, 1.f/31.f, 1.f };
00870             const XMU565 * __restrict sPtr = reinterpret_cast<const XMU565*>(pSource);
00871             for( size_t icount = 0; icount < size; icount += sizeof(XMU565) )
00872             {
00873                 XMVECTOR v = XMLoadU565( sPtr++ );
00874                 v = XMVectorMultiply( v, s_Scale );
00875                 v = XMVectorSwizzle<2, 1, 0, 3>( v );
00876                 if ( dPtr >= ePtr ) break;
00877                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1110 );
00878             }
00879             return true;
00880         }
00881         return false;
00882
00883     case DXGI_FORMAT_B5G5R5A1_UNORM:
00884         if ( size >= sizeof(XMU555) )
00885         {
00886             static XMVECTORF32 s_Scale = { 1.f/31.f, 1.f/31.f, 1.f/31.f, 1.f };
00887             const XMU555 * __restrict sPtr = reinterpret_cast<const XMU555*>(pSource);
00888             for( size_t icount = 0; icount < size; icount += sizeof(XMU555) )
00889             {
00890                 XMVECTOR v = XMLoadU555( sPtr++ );
00891                 v = XMVectorMultiply( v, s_Scale );
00892                 if ( dPtr >= ePtr ) break;
00893                 *(dPtr++) = XMVectorSwizzle<2, 1, 0, 3>( v );
00894             }
00895             return true;
00896         }
00897         return false;
00898
00899     case DXGI_FORMAT_B8G8R8A8_UNORM:
00900     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00901         if ( size >= sizeof(XMUBYTEN4) )
00902         {
00903             const XMUBYTEN4 * __restrict sPtr = reinterpret_cast<const XMUBYTEN4*>(pSource);
00904             for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
00905             {
00906                 XMVECTOR v = XMLoadUByteN4( sPtr++ );
00907                 if ( dPtr >= ePtr ) break;
00908                 *(dPtr++) = XMVectorSwizzle<2, 1, 0, 3>( v );
00909             }
00910             return true;
00911         }
00912         return false;
00913
00914     case DXGI_FORMAT_B8G8R8X8_UNORM:
00915     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00916         if ( size >= sizeof(XMUBYTEN4) )
00917         {
00918             const XMUBYTEN4 * __restrict sPtr = reinterpret_cast<const XMUBYTEN4*>(pSource);
00919             for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
00920             {
00921                 XMVECTOR v = XMLoadUByteN4( sPtr++ );
00922                 v = XMVectorSwizzle<2, 1, 0, 3>( v );
00923                 if ( dPtr >= ePtr ) break;
00924                 *(dPtr++) = XMVectorSelect( g_XMIdentityR3, v, g_XMSelect1110 );
00925             }
00926             return true;
00927         }
00928         return false;
00929
00930     case DXGI_FORMAT_B4G4R4A4_UNORM:
00931         if ( size >= sizeof(XMUNIBBLE4) )
00932         {
00933             static XMVECTORF32 s_Scale = { 1.f/15.f, 1.f/15.f, 1.f/15.f, 1.f/15.f };
00934             const XMUNIBBLE4 * __restrict sPtr = reinterpret_cast<const XMUNIBBLE4*>(pSource);
00935             for( size_t icount = 0; icount < size; icount += sizeof(XMUNIBBLE4) )
00936             {
00937                 XMVECTOR v = XMLoadUNibble4( sPtr++ );
00938                 v = XMVectorMultiply( v, s_Scale );
00939                 if ( dPtr >= ePtr ) break;
00940                 *(dPtr++) = XMVectorSwizzle<2, 1, 0, 3>( v );
00941             }
00942             return true;
00943         }
00944         return false;
00945
00946     // we don't support the video formats ( see IsVideo function )
00947
00948     default:
00949         return false;
00950     }
00951 }
00952
00953
00954 //-------------------------------------------------------------------------------------
00955 // Stores an image row from standard RGBA XMVECTOR (aligned) array
00956 //-------------------------------------------------------------------------------------
00957 #define STORE_SCANLINE( type, func )\
00958         if ( size >= sizeof(type) )\
00959         {\
00960             type * __restrict dPtr = reinterpret_cast<type*>(pDestination);\
00961             for( size_t icount = 0; icount < size; icount += sizeof(type) )\
00962             {\
00963                 if ( sPtr >= ePtr ) break;\
00964                 func( dPtr++, *sPtr++ );\
00965             }\
00966         }\
00967         return true;
00968
00969 _Use_decl_annotations_
00970 bool _StoreScanline( LPVOID pDestination, size_t size, DXGI_FORMAT format,
00971                      const XMVECTOR* pSource, size_t count )
00972 {
00973     assert( pDestination && size > 0 );
00974     assert( pSource && count > 0 && (((uintptr_t)pSource & 0xF) == 0) );
00975     assert( IsValid(format) && !IsVideo(format) && !IsTypeless(format) && !IsCompressed(format) );
00976
00977     const XMVECTOR* __restrict sPtr = pSource;
00978     if ( !sPtr )
00979         return false;
00980
00981     const XMVECTOR* ePtr = pSource + count;
00982
00983     switch( format )
00984     {
00985     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00986         STORE_SCANLINE( XMFLOAT4, XMStoreFloat4 )
00987
00988     case DXGI_FORMAT_R32G32B32A32_UINT:
00989         STORE_SCANLINE( XMUINT4, XMStoreUInt4 )
00990
00991     case DXGI_FORMAT_R32G32B32A32_SINT:
00992         STORE_SCANLINE( XMINT4, XMStoreSInt4 )
00993
00994     case DXGI_FORMAT_R32G32B32_FLOAT:
00995         STORE_SCANLINE( XMFLOAT3, XMStoreFloat3 )
00996
00997     case DXGI_FORMAT_R32G32B32_UINT:
00998         STORE_SCANLINE( XMUINT3, XMStoreUInt3 )
00999
01000     case DXGI_FORMAT_R32G32B32_SINT:
01001         STORE_SCANLINE( XMINT3, XMStoreSInt3 )
01002
01003     case DXGI_FORMAT_R16G16B16A16_FLOAT:
01004         STORE_SCANLINE( XMHALF4, XMStoreHalf4 )
01005
01006     case DXGI_FORMAT_R16G16B16A16_UNORM:
01007         STORE_SCANLINE( XMUSHORTN4, XMStoreUShortN4 )
01008
01009     case DXGI_FORMAT_R16G16B16A16_UINT:
01010         STORE_SCANLINE( XMUSHORT4, XMStoreUShort4 )
01011
01012     case DXGI_FORMAT_R16G16B16A16_SNORM:
01013         STORE_SCANLINE( XMSHORTN4, XMStoreShortN4 )
01014
01015     case DXGI_FORMAT_R16G16B16A16_SINT:
01016         STORE_SCANLINE( XMSHORT4, XMStoreShort4 )
01017
01018     case DXGI_FORMAT_R32G32_FLOAT:
01019         STORE_SCANLINE( XMFLOAT2, XMStoreFloat2 )
01020
01021     case DXGI_FORMAT_R32G32_UINT:
01022         STORE_SCANLINE( XMUINT2, XMStoreUInt2 )
01023
01024     case DXGI_FORMAT_R32G32_SINT:
01025         STORE_SCANLINE( XMINT2, XMStoreSInt2 )
01026
01027     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
01028         if ( size >= (sizeof(float)+sizeof(uint32_t)) )
01029         {
01030             float *dPtr = reinterpret_cast<float*>(pDestination);
01031             for( size_t icount = 0; icount < size; icount += (sizeof(float)+sizeof(uint32_t)) )
01032             {
01033                 if ( sPtr >= ePtr ) break;
01034                 XMFLOAT4 f;
01035                 XMStoreFloat4( &f, *sPtr++ );
01036                 dPtr[0] = f.x;
01037                 uint8_t* ps8 = reinterpret_cast<uint8_t*>( &dPtr[1] );
01038                 ps8[0] = static_cast<uint8_t>( std::min<float>( 255.f, std::max<float>( 0.f, f.y ) ) );
01039                 ps8[1] = ps8[2] = ps8[3] = 0;
01040                 dPtr += 2;
01041             }
01042         }
01043         return true;
01044
01045     case DXGI_FORMAT_R10G10B10A2_UNORM:
01046     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
01047         STORE_SCANLINE( XMUDECN4, XMStoreUDecN4 );
01048
01049     case DXGI_FORMAT_R10G10B10A2_UINT:
01050         STORE_SCANLINE( XMUDEC4, XMStoreUDec4 );
01051
01052     case DXGI_FORMAT_R11G11B10_FLOAT:
01053         STORE_SCANLINE( XMFLOAT3PK, XMStoreFloat3PK );
01054
01055     case DXGI_FORMAT_R8G8B8A8_UNORM:
01056     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
01057         STORE_SCANLINE( XMUBYTEN4, XMStoreUByteN4 )
01058
01059     case DXGI_FORMAT_R8G8B8A8_UINT:
01060         STORE_SCANLINE( XMUBYTE4, XMStoreUByte4 )
01061
01062     case DXGI_FORMAT_R8G8B8A8_SNORM:
01063         STORE_SCANLINE( XMBYTEN4, XMStoreByteN4 )
01064
01065     case DXGI_FORMAT_R8G8B8A8_SINT:
01066         STORE_SCANLINE( XMBYTE4, XMStoreByte4 )
01067
01068     case DXGI_FORMAT_R16G16_FLOAT:
01069         STORE_SCANLINE( XMHALF2, XMStoreHalf2 )
01070
01071     case DXGI_FORMAT_R16G16_UNORM:
01072         STORE_SCANLINE( XMUSHORTN2, XMStoreUShortN2 )
01073
01074     case DXGI_FORMAT_R16G16_UINT:
01075         STORE_SCANLINE( XMUSHORT2, XMStoreUShort2 )
01076
01077     case DXGI_FORMAT_R16G16_SNORM:
01078         STORE_SCANLINE( XMSHORTN2, XMStoreShortN2 )
01079
01080     case DXGI_FORMAT_R16G16_SINT:
01081         STORE_SCANLINE( XMSHORT2, XMStoreShort2 )
01082
01083     case DXGI_FORMAT_D32_FLOAT:
01084     case DXGI_FORMAT_R32_FLOAT:
01085         if ( size >= sizeof(float) )
01086         {
01087             float * __restrict dPtr = reinterpret_cast<float*>(pDestination);
01088             for( size_t icount = 0; icount < size; icount += sizeof(float) )
01089             {
01090                 if ( sPtr >= ePtr ) break;
01091                 XMStoreFloat( dPtr++, *(sPtr++) );
01092             }
01093         }
01094         return true;
01095
01096     case DXGI_FORMAT_R32_UINT:
01097         if ( size >= sizeof(uint32_t) )
01098         {
01099             uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
01100             for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
01101             {
01102                 if ( sPtr >= ePtr ) break;
01103                 XMVECTOR v = XMConvertVectorFloatToUInt( *(sPtr++), 0 );
01104                 XMStoreInt( dPtr++, v );
01105             }
01106         }
01107         return true;
01108
01109     case DXGI_FORMAT_R32_SINT:
01110         if ( size >= sizeof(uint32_t) )
01111         {
01112             uint32_t * __restrict dPtr = reinterpret_cast<uint32_t*>(pDestination);
01113             for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
01114             {
01115                 if ( sPtr >= ePtr ) break;
01116                 XMVECTOR v = XMConvertVectorFloatToInt( *(sPtr++), 0 );
01117                 XMStoreInt( dPtr++, v );
01118             }
01119         }
01120         return true;
01121
01122     case DXGI_FORMAT_D24_UNORM_S8_UINT:
01123         if ( size >= sizeof(uint32_t) )
01124         {
01125             static const XMVECTORF32 clamp = { 1.f, 255.f, 0.f, 0.f };
01126             XMVECTOR zero = XMVectorZero();
01127             uint32_t *dPtr = reinterpret_cast<uint32_t*>(pDestination);
01128             for( size_t icount = 0; icount < size; icount += sizeof(uint32_t) )
01129             {
01130                 if ( sPtr >= ePtr ) break;
01131                 XMFLOAT4 f;
01132                 XMStoreFloat4( &f, XMVectorClamp( *sPtr++, zero, clamp ) );
01133                 *dPtr++ = (static_cast<uint32_t>( f.x * 16777215.f ) & 0xFFFFFF)
01134                           | ((static_cast<uint32_t>( f.y ) & 0xFF) << 24);
01135             }
01136         }
01137         return true;
01138
01139     case DXGI_FORMAT_R8G8_UNORM:
01140         STORE_SCANLINE( XMUBYTEN2, XMStoreUByteN2 )
01141
01142     case DXGI_FORMAT_R8G8_UINT:
01143         STORE_SCANLINE( XMUBYTE2, XMStoreUByte2 )
01144
01145     case DXGI_FORMAT_R8G8_SNORM:
01146         STORE_SCANLINE( XMBYTEN2, XMStoreByteN2 )
01147
01148     case DXGI_FORMAT_R8G8_SINT:
01149         STORE_SCANLINE( XMBYTE2, XMStoreByte2 )
01150
01151     case DXGI_FORMAT_R16_FLOAT:
01152         if ( size >= sizeof(HALF) )
01153         {
01154             HALF * __restrict dPtr = reinterpret_cast<HALF*>(pDestination);
01155             for( size_t icount = 0; icount < size; icount += sizeof(HALF) )
01156             {
01157                 if ( sPtr >= ePtr ) break;
01158                 float v = XMVectorGetX( *sPtr++ );
01159                 *(dPtr++) = XMConvertFloatToHalf(v);
01160             }
01161         }
01162         return true;
01163
01164     case DXGI_FORMAT_D16_UNORM:
01165     case DXGI_FORMAT_R16_UNORM:
01166         if ( size >= sizeof(int16_t) )
01167         {
01168             int16_t * __restrict dPtr = reinterpret_cast<int16_t*>(pDestination);
01169             for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
01170             {
01171                 if ( sPtr >= ePtr ) break;
01172                 float v = XMVectorGetX( *sPtr++ );
01173                 v = std::max<float>( std::min<float>( v, 1.f ), 0.f );
01174                 *(dPtr++) = static_cast<uint16_t>( v*65535.f + 0.5f );
01175             }
01176         }
01177         return true;
01178
01179     case DXGI_FORMAT_R16_UINT:
01180         if ( size >= sizeof(uint16_t) )
01181         {
01182             uint16_t * __restrict dPtr = reinterpret_cast<uint16_t*>(pDestination);
01183             for( size_t icount = 0; icount < size; icount += sizeof(uint16_t) )
01184             {
01185                 if ( sPtr >= ePtr ) break;
01186                 float v = XMVectorGetX( *sPtr++ );
01187                 v = std::max<float>( std::min<float>( v, 65535.f ), 0.f );
01188                 *(dPtr++) = static_cast<uint16_t>(v);
01189             }
01190         }
01191         return true;
01192
01193     case DXGI_FORMAT_R16_SNORM:
01194         if ( size >= sizeof(int16_t) )
01195         {
01196             int16_t * __restrict dPtr = reinterpret_cast<int16_t*>(pDestination);
01197             for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
01198             {
01199                 if ( sPtr >= ePtr ) break;
01200                 float v = XMVectorGetX( *sPtr++ );
01201                 v = std::max<float>( std::min<float>( v, 1.f ), -1.f );
01202                 *(dPtr++) = static_cast<uint16_t>( v * 32767.f );
01203             }
01204         }
01205         return true;
01206
01207     case DXGI_FORMAT_R16_SINT:
01208         if ( size >= sizeof(int16_t) )
01209         {
01210             int16_t * __restrict dPtr = reinterpret_cast<int16_t*>(pDestination);
01211             for( size_t icount = 0; icount < size; icount += sizeof(int16_t) )
01212             {
01213                 if ( sPtr >= ePtr ) break;
01214                 float v = XMVectorGetX( *sPtr++ );
01215                 v = std::max<float>( std::min<float>( v, 32767.f ), -32767.f );
01216                 *(dPtr++) = static_cast<int16_t>(v);
01217             }
01218         }
01219         return true;
01220
01221     case DXGI_FORMAT_R8_UNORM:
01222         if ( size >= sizeof(uint8_t) )
01223         {
01224             uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
01225             for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
01226             {
01227                 if ( sPtr >= ePtr ) break;
01228                 float v = XMVectorGetX( *sPtr++ );
01229                 v = std::max<float>( std::min<float>( v, 1.f ), 0.f );
01230                 *(dPtr++) = static_cast<uint8_t>( v * 255.f);
01231             }
01232         }
01233         return true;
01234
01235     case DXGI_FORMAT_R8_UINT:
01236         if ( size >= sizeof(uint8_t) )
01237         {
01238             uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
01239             for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
01240             {
01241                 if ( sPtr >= ePtr ) break;
01242                 float v = XMVectorGetX( *sPtr++ );
01243                 v = std::max<float>( std::min<float>( v, 255.f ), 0.f );
01244                 *(dPtr++) = static_cast<uint8_t>(v);
01245             }
01246         }
01247         return true;
01248
01249     case DXGI_FORMAT_R8_SNORM:
01250         if ( size >= sizeof(char) )
01251         {
01252             char * __restrict dPtr = reinterpret_cast<char*>(pDestination);
01253             for( size_t icount = 0; icount < size; icount += sizeof(char) )
01254             {
01255                 if ( sPtr >= ePtr ) break;
01256                 float v = XMVectorGetX( *sPtr++ );
01257                 v = std::max<float>( std::min<float>( v, 1.f ), -1.f );
01258                 *(dPtr++) = static_cast<char>( v * 127.f );
01259             }
01260         }
01261         return true;
01262
01263     case DXGI_FORMAT_R8_SINT:
01264         if ( size >= sizeof(char) )
01265         {
01266             char * __restrict dPtr = reinterpret_cast<char*>(pDestination);
01267             for( size_t icount = 0; icount < size; icount += sizeof(char) )
01268             {
01269                 if ( sPtr >= ePtr ) break;
01270                 float v = XMVectorGetX( *sPtr++ );
01271                 v = std::max<float>( std::min<float>( v, 127.f ), -127.f );
01272                 *(dPtr++) = static_cast<char>( v );
01273             }
01274         }
01275         return true;
01276
01277     case DXGI_FORMAT_A8_UNORM:
01278         if ( size >= sizeof(uint8_t) )
01279         {
01280             uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
01281             for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
01282             {
01283                 if ( sPtr >= ePtr ) break;
01284                 float v = XMVectorGetW( *sPtr++ );
01285                 v = std::max<float>( std::min<float>( v, 1.f ), 0.f );
01286                 *(dPtr++) = static_cast<uint8_t>( v * 255.f);
01287             }
01288         }
01289         return true;
01290
01291     case DXGI_FORMAT_R1_UNORM:
01292         if ( size >= sizeof(uint8_t) )
01293         {
01294             uint8_t * __restrict dPtr = reinterpret_cast<uint8_t*>(pDestination);
01295             for( size_t icount = 0; icount < size; icount += sizeof(uint8_t) )
01296             {
01297                 uint8_t pixels = 0;
01298                 for( size_t bcount = 0; bcount < 8; ++bcount )
01299                 {
01300                     if ( sPtr >= ePtr ) break;
01301                     float v = XMVectorGetX( *sPtr++ );
01302                     if ( v > 0.5f )
01303                         pixels |= 1 << bcount;
01304                 }
01305                 *(dPtr++) = pixels;
01306             }
01307         }
01308         return true;
01309
01310     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
01311         STORE_SCANLINE( XMFLOAT3SE, XMStoreFloat3SE )
01312
01313     case DXGI_FORMAT_R8G8_B8G8_UNORM:
01314         if ( size >= sizeof(XMUBYTEN4) )
01315         {
01316             XMUBYTEN4 * __restrict dPtr = reinterpret_cast<XMUBYTEN4*>(pDestination);
01317             for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
01318             {
01319                 if ( sPtr >= ePtr ) break;
01320                 XMVECTOR v0 = *sPtr++;
01321                 XMVECTOR v1 = (sPtr < ePtr) ? XMVectorSplatY( *sPtr++ ) : XMVectorZero();
01322                 XMVECTOR v = XMVectorSelect( v1, v0, g_XMSelect1110 );
01323                 XMStoreUByteN4( dPtr++, v );
01324             }
01325         }
01326         return true;
01327
01328     case DXGI_FORMAT_G8R8_G8B8_UNORM:
01329         if ( size >= sizeof(XMUBYTEN4) )
01330         {
01331             static XMVECTORI32 select1101 = {XM_SELECT_1, XM_SELECT_1, XM_SELECT_0, XM_SELECT_1};
01332
01333             XMUBYTEN4 * __restrict dPtr = reinterpret_cast<XMUBYTEN4*>(pDestination);
01334             for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
01335             {
01336                 if ( sPtr >= ePtr ) break;
01337                 XMVECTOR v0 = XMVectorSwizzle<1, 0, 3, 2>( *sPtr++ );
01338                 XMVECTOR v1 = (sPtr < ePtr) ? XMVectorSplatY( *sPtr++ ) : XMVectorZero();
01339                 XMVECTOR v = XMVectorSelect( v1, v0, select1101 );
01340                 XMStoreUByteN4( dPtr++, v );
01341             }
01342         }
01343         return true;
01344
01345     case DXGI_FORMAT_B5G6R5_UNORM:
01346         if ( size >= sizeof(XMU565) )
01347         {
01348             static XMVECTORF32 s_Scale = { 31.f, 63.f, 31.f, 1.f };
01349             XMU565 * __restrict dPtr = reinterpret_cast<XMU565*>(pDestination);
01350             for( size_t icount = 0; icount < size; icount += sizeof(XMU565) )
01351             {
01352                 if ( sPtr >= ePtr ) break;
01353                 XMVECTOR v = XMVectorSwizzle<2, 1, 0, 3>( *sPtr++ );
01354                 v = XMVectorMultiply( v, s_Scale );
01355                 XMStoreU565( dPtr++, v );
01356             }
01357         }
01358         return true;
01359
01360     case DXGI_FORMAT_B5G5R5A1_UNORM:
01361         if ( size >= sizeof(XMU555) )
01362         {
01363             static XMVECTORF32 s_Scale = { 31.f, 31.f, 31.f, 1.f };
01364             XMU555 * __restrict dPtr = reinterpret_cast<XMU555*>(pDestination);
01365             for( size_t icount = 0; icount < size; icount += sizeof(XMU555) )
01366             {
01367                 if ( sPtr >= ePtr ) break;
01368                 XMVECTOR v = XMVectorSwizzle<2, 1, 0, 3>( *sPtr++ );
01369                 v = XMVectorMultiply( v, s_Scale );
01370                 XMStoreU555( dPtr++, v );
01371             }
01372         }
01373         return true;
01374
01375     case DXGI_FORMAT_B8G8R8A8_UNORM:
01376     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
01377         if ( size >= sizeof(XMUBYTEN4) )
01378         {
01379             XMUBYTEN4 * __restrict dPtr = reinterpret_cast<XMUBYTEN4*>(pDestination);
01380             for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
01381             {
01382                 if ( sPtr >= ePtr ) break;
01383                 XMVECTOR v = XMVectorSwizzle<2, 1, 0, 3>( *sPtr++ );
01384                 XMStoreUByteN4( dPtr++, v );
01385             }
01386         }
01387         return true;
01388
01389     case DXGI_FORMAT_B8G8R8X8_UNORM:
01390     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
01391         if ( size >= sizeof(XMUBYTEN4) )
01392         {
01393             XMUBYTEN4 * __restrict dPtr = reinterpret_cast<XMUBYTEN4*>(pDestination);
01394             for( size_t icount = 0; icount < size; icount += sizeof(XMUBYTEN4) )
01395             {
01396                 if ( sPtr >= ePtr ) break;
01397                 XMVECTOR v = XMVectorPermute<XM_PERMUTE_0Z, XM_PERMUTE_0Y, XM_PERMUTE_0X, XM_PERMUTE_1W>( *sPtr++, g_XMIdentityR3 );
01398                 XMStoreUByteN4( dPtr++, v );
01399             }
01400         }
01401         return true;
01402
01403     case DXGI_FORMAT_B4G4R4A4_UNORM:
01404         if ( size >= sizeof(XMUNIBBLE4) )
01405         {
01406             static XMVECTORF32 s_Scale = { 15.f, 15.f, 15.f, 15.f };
01407             XMUNIBBLE4 * __restrict dPtr = reinterpret_cast<XMUNIBBLE4*>(pDestination);
01408             for( size_t icount = 0; icount < size; icount += sizeof(XMUNIBBLE4) )
01409             {
01410                 if ( sPtr >= ePtr ) break;
01411                 XMVECTOR v = XMVectorSwizzle<2, 1, 0, 3>( *sPtr++ );
01412                 v = XMVectorMultiply( v, s_Scale );
01413                 XMStoreUNibble4( dPtr++, v );
01414             }
01415         }
01416         return true;
01417
01418     // We don't support the video formats ( see IsVideo function )
01419
01420     default:
01421         return false;
01422     }
01423 }
01424
01425
01426 //-------------------------------------------------------------------------------------
01427 // Convert DXGI image to/from GUID_WICPixelFormat128bppRGBAFloat (no range conversions)
01428 //-------------------------------------------------------------------------------------
01429 _Use_decl_annotations_
01430 HRESULT _ConvertToR32G32B32A32( const Image& srcImage, ScratchImage& image )
01431 {
01432     if ( !srcImage.pixels )
01433         return E_POINTER;
01434
01435     HRESULT hr = image.Initialize2D( DXGI_FORMAT_R32G32B32A32_FLOAT, srcImage.width, srcImage.height, 1, 1 );
01436     if ( FAILED(hr) )
01437         return hr;
01438
01439     const Image *img = image.GetImage( 0, 0, 0 );
01440     if ( !img )
01441     {
01442         image.Release();
01443         return E_POINTER;
01444     }
01445
01446     uint8_t* pDest = img->pixels;
01447     if ( !pDest )
01448     {
01449         image.Release();
01450         return E_POINTER;
01451     }
01452
01453     const uint8_t *pSrc = srcImage.pixels;
01454     for( size_t h = 0; h < srcImage.height; ++h )
01455     {
01456         if ( !_LoadScanline( reinterpret_cast<XMVECTOR*>(pDest), srcImage.width, pSrc, srcImage.rowPitch, srcImage.format ) )
01457         {
01458             image.Release();
01459             return E_FAIL;
01460         }
01461
01462         pSrc += srcImage.rowPitch;
01463         pDest += img->rowPitch;
01464     }
01465
01466     return S_OK;
01467 }
01468
01469 _Use_decl_annotations_
01470 HRESULT _ConvertFromR32G32B32A32( const Image& srcImage, const Image& destImage )
01471 {
01472     assert( srcImage.format == DXGI_FORMAT_R32G32B32A32_FLOAT );
01473
01474     if ( !srcImage.pixels || !destImage.pixels )
01475         return E_POINTER;
01476
01477     if ( srcImage.width != destImage.width || srcImage.height != destImage.height )
01478         return E_FAIL;
01479
01480     const uint8_t *pSrc = srcImage.pixels;
01481     uint8_t* pDest = destImage.pixels;
01482
01483     for( size_t h = 0; h < srcImage.height; ++h )
01484     {
01485         if ( !_StoreScanline( pDest, destImage.rowPitch, destImage.format, reinterpret_cast<const XMVECTOR*>(pSrc), srcImage.width ) )
01486             return E_FAIL;
01487
01488         pSrc += srcImage.rowPitch;
01489         pDest += destImage.rowPitch;
01490     }
01491
01492     return S_OK;
01493 }
01494
01495 _Use_decl_annotations_
01496 HRESULT _ConvertFromR32G32B32A32( const Image& srcImage, DXGI_FORMAT format, ScratchImage& image )
01497 {
01498     if ( !srcImage.pixels )
01499         return E_POINTER;
01500
01501     HRESULT hr = image.Initialize2D( format, srcImage.width, srcImage.height, 1, 1 );
01502     if ( FAILED(hr) )
01503         return hr;
01504
01505     const Image *img = image.GetImage( 0, 0, 0 );
01506     if ( !img )
01507     {
01508         image.Release();
01509         return E_POINTER;
01510     }
01511
01512     hr = _ConvertFromR32G32B32A32( srcImage, *img );
01513     if ( FAILED(hr) )
01514     {
01515         image.Release();
01516         return hr;
01517     }
01518
01519     return S_OK;
01520 }
01521
01522 _Use_decl_annotations_
01523 HRESULT _ConvertFromR32G32B32A32( const Image* srcImages, size_t nimages, const TexMetadata& metadata, DXGI_FORMAT format, ScratchImage& result )
01524 {
01525     if ( !srcImages )
01526         return E_POINTER;
01527
01528     result.Release();
01529
01530     assert( metadata.format == DXGI_FORMAT_R32G32B32A32_FLOAT );
01531
01532     TexMetadata mdata2 = metadata;
01533     mdata2.format = format;
01534     HRESULT hr = result.Initialize( mdata2 );
01535     if ( FAILED(hr) )
01536         return hr;
01537
01538     if ( nimages != result.GetImageCount() )
01539     {
01540         result.Release();
01541         return E_FAIL;
01542     }
01543
01544     const Image* dest = result.GetImages();
01545     if ( !dest )
01546     {
01547         result.Release();
01548         return E_POINTER;
01549     }
01550
01551     for( size_t index=0; index < nimages; ++index )
01552     {
01553         const Image& src = srcImages[ index ];
01554         const Image& dst = dest[ index ];
01555
01556         assert( src.format == DXGI_FORMAT_R32G32B32A32_FLOAT );
01557         assert( dst.format == format );
01558
01559         if ( src.width != dst.width || src.height != dst.height )
01560         {
01561             result.Release();
01562             return E_FAIL;
01563         }
01564
01565         const uint8_t* pSrc = src.pixels;
01566         uint8_t* pDest = dst.pixels;
01567         if ( !pSrc || !pDest )
01568         {
01569             result.Release();
01570             return E_POINTER;
01571         }
01572
01573         for( size_t h=0; h < src.height; ++h )
01574         {
01575             if ( !_StoreScanline( pDest, dst.rowPitch, format, reinterpret_cast<const XMVECTOR*>(pSrc), src.width ) )
01576             {
01577                 result.Release();
01578                 return E_FAIL;
01579             }
01580
01581             pSrc += src.rowPitch;
01582             pDest += dst.rowPitch;
01583         }
01584     }
01585
01586     return S_OK;
01587 }
01588
01589
01590 //-------------------------------------------------------------------------------------
01591 // RGB -> sRGB
01592 //-------------------------------------------------------------------------------------
01593 static const uint32_t g_fEncodeGamma22[] =
01594 {
01595     0x00000000, 0x3bd56bd3, 0x3c486344, 0x3c90da15, 0x3cbc2677, 0x3ce67704, 0x3d080183, 0x3d1c7728,
01596     0x3d30a8fb, 0x3d44a03c, 0x3d586400, 0x3d6bf9e7, 0x3d7f6679, 0x3d8956bd, 0x3d92e906, 0x3d9c6b70,
01597     0x3da5df22, 0x3daf451b, 0x3db89e3e, 0x3dc1eb50, 0x3dcb2d04, 0x3dd463f7, 0x3ddd90b9, 0x3de6b3ca,
01598     0x3defcda0, 0x3df8dea6, 0x3e00f3a0, 0x3e0573e3, 0x3e09f046, 0x3e0e68f0, 0x3e12de06, 0x3e174fa6,
01599     0x3e1bbdf2, 0x3e202906, 0x3e2490fd, 0x3e28f5f1, 0x3e2d57fb, 0x3e31b72f, 0x3e3613a4, 0x3e3a6d6e,
01600     0x3e3ec4a0, 0x3e43194d, 0x3e476b84, 0x3e4bbb57, 0x3e5008d7, 0x3e54540f, 0x3e589d0f, 0x3e5ce3e5,
01601     0x3e61289d, 0x3e656b44, 0x3e69abe5, 0x3e6dea8d, 0x3e722745, 0x3e766217, 0x3e7a9b0e, 0x3e7ed235,
01602     0x3e8183c9, 0x3e839d98, 0x3e85b68c, 0x3e87cea8, 0x3e89e5f2, 0x3e8bfc6b, 0x3e8e1219, 0x3e9026ff,
01603     0x3e923b20, 0x3e944e7f, 0x3e966120, 0x3e987307, 0x3e9a8436, 0x3e9c94af, 0x3e9ea476, 0x3ea0b38e,
01604     0x3ea2c1fb, 0x3ea4cfbb, 0x3ea6dcd5, 0x3ea8e94a, 0x3eaaf51c, 0x3ead004e, 0x3eaf0ae2, 0x3eb114d9,
01605     0x3eb31e37, 0x3eb526fe, 0x3eb72f2f, 0x3eb936cd, 0x3ebb3dd8, 0x3ebd4454, 0x3ebf4a43, 0x3ec14fa5,
01606     0x3ec3547e, 0x3ec558cd, 0x3ec75c95, 0x3ec95fd8, 0x3ecb6297, 0x3ecd64d4, 0x3ecf6690, 0x3ed167ce,
01607     0x3ed3688e, 0x3ed568d1, 0x3ed76899, 0x3ed967e9, 0x3edb66bf, 0x3edd651f, 0x3edf630a, 0x3ee16080,
01608     0x3ee35d84, 0x3ee55a16, 0x3ee75636, 0x3ee951e8, 0x3eeb4d2a, 0x3eed4800, 0x3eef4269, 0x3ef13c68,
01609     0x3ef335fc, 0x3ef52f26, 0x3ef727ea, 0x3ef92046, 0x3efb183c, 0x3efd0fcd, 0x3eff06fa, 0x3f007ee2,
01610     0x3f017a16, 0x3f027519, 0x3f036fec, 0x3f046a8f, 0x3f056502, 0x3f065f47, 0x3f07595d, 0x3f085344,
01611     0x3f094cfe, 0x3f0a468b, 0x3f0b3feb, 0x3f0c391e, 0x3f0d3224, 0x3f0e2aff, 0x3f0f23af, 0x3f101c32,
01612     0x3f11148c, 0x3f120cba, 0x3f1304bf, 0x3f13fc9a, 0x3f14f44b, 0x3f15ebd3, 0x3f16e333, 0x3f17da6b,
01613     0x3f18d17a, 0x3f19c860, 0x3f1abf1f, 0x3f1bb5b7, 0x3f1cac28, 0x3f1da272, 0x3f1e9895, 0x3f1f8e92,
01614     0x3f20846a, 0x3f217a1c, 0x3f226fa8, 0x3f23650f, 0x3f245a52, 0x3f254f70, 0x3f264469, 0x3f27393f,
01615     0x3f282df1, 0x3f29227f, 0x3f2a16ea, 0x3f2b0b31, 0x3f2bff56, 0x3f2cf358, 0x3f2de738, 0x3f2edaf6,
01616     0x3f2fce91, 0x3f30c20b, 0x3f31b564, 0x3f32a89b, 0x3f339bb1, 0x3f348ea6, 0x3f35817a, 0x3f36742f,
01617     0x3f3766c3, 0x3f385936, 0x3f394b8a, 0x3f3a3dbe, 0x3f3b2fd3, 0x3f3c21c8, 0x3f3d139e, 0x3f3e0556,
01618     0x3f3ef6ee, 0x3f3fe868, 0x3f40d9c4, 0x3f41cb01, 0x3f42bc20, 0x3f43ad22, 0x3f449e06, 0x3f458ecc,
01619     0x3f467f75, 0x3f477001, 0x3f486071, 0x3f4950c2, 0x3f4a40f8, 0x3f4b3111, 0x3f4c210d, 0x3f4d10ed,
01620     0x3f4e00b2, 0x3f4ef05a, 0x3f4fdfe7, 0x3f50cf58, 0x3f51beae, 0x3f52ade8, 0x3f539d07, 0x3f548c0c,
01621     0x3f557af5, 0x3f5669c4, 0x3f575878, 0x3f584711, 0x3f593590, 0x3f5a23f6, 0x3f5b1241, 0x3f5c0072,
01622     0x3f5cee89, 0x3f5ddc87, 0x3f5eca6b, 0x3f5fb835, 0x3f60a5e7, 0x3f619380, 0x3f6280ff, 0x3f636e65,
01623     0x3f645bb3, 0x3f6548e8, 0x3f663604, 0x3f672309, 0x3f680ff4, 0x3f68fcc8, 0x3f69e983, 0x3f6ad627,
01624     0x3f6bc2b3, 0x3f6caf27, 0x3f6d9b83, 0x3f6e87c8, 0x3f6f73f5, 0x3f70600c, 0x3f714c0b, 0x3f7237f4,
01625     0x3f7323c4, 0x3f740f7f, 0x3f74fb22, 0x3f75e6af, 0x3f76d225, 0x3f77bd85, 0x3f78a8ce, 0x3f799401,
01626     0x3f7a7f1e, 0x3f7b6a25, 0x3f7c5516, 0x3f7d3ff1, 0x3f7e2ab6, 0x3f7f1566, 0x3f800000, 0x3f800000
01627 };
01628
01629 #pragma prefast(suppress : 25000, "FXMVECTOR is 16 bytes")
01630 static inline XMVECTOR _TableEncodeGamma22( FXMVECTOR v )
01631 {
01632     float f[4];
01633     XMStoreFloat4( (XMFLOAT4*)f, v );
01634
01635     for( size_t i=0; i < 4; ++i )
01636     {
01637         float f2 = sqrtf(f[i]) * 254.0f;
01638
01639         uint32_t  i2 = static_cast<uint32_t>(f2);
01640         i2 = std::min<uint32_t>( i2, _countof( g_fEncodeGamma22 )-2 );
01641
01642         float fS = f2 - (float) i2;
01643         float fA = ((float *) g_fEncodeGamma22)[i2];
01644         float fB = ((float *) g_fEncodeGamma22)[i2 + 1];
01645
01646         f[i] = fA + fS * (fB - fA);
01647     }
01648
01649     return XMLoadFloat4( (XMFLOAT4*)f );
01650 }
01651
01652
01653 //-------------------------------------------------------------------------------------
01654 // sRGB -> RGB
01655 //-------------------------------------------------------------------------------------
01656 static const uint32_t g_fDecodeGamma22[] =
01657 {
01658     0x00000000, 0x3b144eb0, 0x3b9ef3b0, 0x3bf84b42, 0x3c2a5c46, 0x3c59c180, 0x3c850eb5, 0x3c9da52a,
01659     0x3cb6967a, 0x3ccfd852, 0x3ce9628b, 0x3d01974b, 0x3d0e9b82, 0x3d1bbba3, 0x3d28f5bc, 0x3d364822,
01660     0x3d43b159, 0x3d51301d, 0x3d5ec344, 0x3d6c69c9, 0x3d7a22c4, 0x3d83f6ad, 0x3d8ae465, 0x3d91da35,
01661     0x3d98d7c7, 0x3d9fdcd2, 0x3da6e914, 0x3dadfc47, 0x3db51635, 0x3dbc36a3, 0x3dc35d62, 0x3dca8a3a,
01662     0x3dd1bd02, 0x3dd8f591, 0x3de033bb, 0x3de7775d, 0x3deec050, 0x3df60e74, 0x3dfd61a6, 0x3e025ce5,
01663     0x3e060b61, 0x3e09bc38, 0x3e0d6f5f, 0x3e1124c8, 0x3e14dc68, 0x3e189630, 0x3e1c521a, 0x3e201016,
01664     0x3e23d01d, 0x3e279225, 0x3e2b5624, 0x3e2f1c10, 0x3e32e3e4, 0x3e36ad94, 0x3e3a7918, 0x3e3e4668,
01665     0x3e42157f, 0x3e45e654, 0x3e49b8e0, 0x3e4d8d1d, 0x3e516304, 0x3e553a8d, 0x3e5913b4, 0x3e5cee70,
01666     0x3e60cabf, 0x3e64a89b, 0x3e6887fb, 0x3e6c68db, 0x3e704b3a, 0x3e742f0e, 0x3e781454, 0x3e7bfb04,
01667     0x3e7fe321, 0x3e81e650, 0x3e83dbc0, 0x3e85d1dc, 0x3e87c8a3, 0x3e89c015, 0x3e8bb830, 0x3e8db0ee,
01668     0x3e8faa51, 0x3e91a454, 0x3e939ef9, 0x3e959a3b, 0x3e97961b, 0x3e999295, 0x3e9b8fa7, 0x3e9d8d52,
01669     0x3e9f8b93, 0x3ea18a6a, 0x3ea389d2, 0x3ea589cb, 0x3ea78a56, 0x3ea98b6e, 0x3eab8d15, 0x3ead8f47,
01670     0x3eaf9204, 0x3eb1954a, 0x3eb39917, 0x3eb59d6c, 0x3eb7a246, 0x3eb9a7a5, 0x3ebbad88, 0x3ebdb3ec,
01671     0x3ebfbad3, 0x3ec1c237, 0x3ec3ca1a, 0x3ec5d27c, 0x3ec7db58, 0x3ec9e4b4, 0x3ecbee85, 0x3ecdf8d3,
01672     0x3ed0039a, 0x3ed20ed8, 0x3ed41a8a, 0x3ed626b5, 0x3ed83351, 0x3eda4065, 0x3edc4de9, 0x3ede5be0,
01673     0x3ee06a4a, 0x3ee27923, 0x3ee4886a, 0x3ee69821, 0x3ee8a845, 0x3eeab8d8, 0x3eecc9d6, 0x3eeedb3f,
01674     0x3ef0ed13, 0x3ef2ff53, 0x3ef511fb, 0x3ef7250a, 0x3ef93883, 0x3efb4c61, 0x3efd60a7, 0x3eff7553,
01675     0x3f00c531, 0x3f01cfeb, 0x3f02dad9, 0x3f03e5f5, 0x3f04f145, 0x3f05fcc4, 0x3f070875, 0x3f081456,
01676     0x3f092067, 0x3f0a2ca8, 0x3f0b3917, 0x3f0c45b7, 0x3f0d5284, 0x3f0e5f7f, 0x3f0f6caa, 0x3f107a03,
01677     0x3f118789, 0x3f12953b, 0x3f13a31d, 0x3f14b12b, 0x3f15bf64, 0x3f16cdca, 0x3f17dc5e, 0x3f18eb1b,
01678     0x3f19fa05, 0x3f1b091b, 0x3f1c185c, 0x3f1d27c7, 0x3f1e375c, 0x3f1f471d, 0x3f205707, 0x3f21671b,
01679     0x3f227759, 0x3f2387c2, 0x3f249852, 0x3f25a90c, 0x3f26b9ef, 0x3f27cafb, 0x3f28dc30, 0x3f29ed8b,
01680     0x3f2aff11, 0x3f2c10bd, 0x3f2d2290, 0x3f2e348b, 0x3f2f46ad, 0x3f3058f7, 0x3f316b66, 0x3f327dfd,
01681     0x3f3390ba, 0x3f34a39d, 0x3f35b6a7, 0x3f36c9d6, 0x3f37dd2b, 0x3f38f0a5, 0x3f3a0443, 0x3f3b1808,
01682     0x3f3c2bf2, 0x3f3d4000, 0x3f3e5434, 0x3f3f688c, 0x3f407d07, 0x3f4191a8, 0x3f42a66c, 0x3f43bb54,
01683     0x3f44d05f, 0x3f45e58e, 0x3f46fadf, 0x3f481054, 0x3f4925ed, 0x3f4a3ba8, 0x3f4b5186, 0x3f4c6789,
01684     0x3f4d7daa, 0x3f4e93f0, 0x3f4faa57, 0x3f50c0e0, 0x3f51d78b, 0x3f52ee58, 0x3f540545, 0x3f551c55,
01685     0x3f563386, 0x3f574ad7, 0x3f58624b, 0x3f5979de, 0x3f5a9191, 0x3f5ba965, 0x3f5cc15b, 0x3f5dd971,
01686     0x3f5ef1a6, 0x3f6009fc, 0x3f612272, 0x3f623b08, 0x3f6353bc, 0x3f646c90, 0x3f658586, 0x3f669e98,
01687     0x3f67b7cb, 0x3f68d11b, 0x3f69ea8d, 0x3f6b041b, 0x3f6c1dc9, 0x3f6d3795, 0x3f6e5180, 0x3f6f6b8b,
01688     0x3f7085b2, 0x3f719ff7, 0x3f72ba5b, 0x3f73d4dc, 0x3f74ef7c, 0x3f760a38, 0x3f772512, 0x3f78400b,
01689     0x3f795b20, 0x3f7a7651, 0x3f7b91a2, 0x3f7cad0e, 0x3f7dc896, 0x3f7ee43c, 0x3f800000, 0x3f800000
01690 };
01691
01692
01693 #pragma prefast(suppress : 25000, "FXMVECTOR is 16 bytes")
01694 static inline XMVECTOR _TableDecodeGamma22( FXMVECTOR v )
01695 {
01696     float f[4];
01697     XMStoreFloat4( (XMFLOAT4*)f, v );
01698
01699     for( size_t i=0; i < 4; ++i )
01700     {
01701         float f2 = f[i] * f[i] * 254.0f;
01702         uint32_t  i2 = static_cast<uint32_t>(f2);
01703         i2 = std::min<uint32_t>( i2, _countof(g_fDecodeGamma22)-2 );
01704
01705         float fS = f2 - (float) i2;
01706         float fA = ((float *) g_fDecodeGamma22)[i2];
01707         float fB = ((float *) g_fDecodeGamma22)[i2 + 1];
01708
01709         f[i] = fA + fS * (fB - fA);
01710     }
01711
01712     return XMLoadFloat4( (XMFLOAT4*)f );
01713 }
01714
01715
01716 //-------------------------------------------------------------------------------------
01717 // Convert scanline based on source/target formats
01718 //-------------------------------------------------------------------------------------
01719 struct ConvertData
01720 {
01721     DXGI_FORMAT format;
01722     size_t datasize;
01723     DWORD flags;
01724 };
01725
01726 static const ConvertData g_ConvertTable[] = {
01727     { DXGI_FORMAT_R32G32B32A32_FLOAT,           32, CONVF_FLOAT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01728     { DXGI_FORMAT_R32G32B32A32_UINT,            32, CONVF_UINT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01729     { DXGI_FORMAT_R32G32B32A32_SINT,            32, CONVF_SINT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01730     { DXGI_FORMAT_R32G32B32_FLOAT,              32, CONVF_FLOAT | CONVF_R | CONVF_G | CONVF_B },
01731     { DXGI_FORMAT_R32G32B32_UINT,               32, CONVF_UINT | CONVF_R | CONVF_G | CONVF_B },
01732     { DXGI_FORMAT_R32G32B32_SINT,               32, CONVF_SINT | CONVF_R | CONVF_G | CONVF_B },
01733     { DXGI_FORMAT_R16G16B16A16_FLOAT,           16, CONVF_FLOAT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01734     { DXGI_FORMAT_R16G16B16A16_UNORM,           16, CONVF_UNORM | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01735     { DXGI_FORMAT_R16G16B16A16_UINT,            16, CONVF_UINT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01736     { DXGI_FORMAT_R16G16B16A16_SNORM,           16, CONVF_SNORM | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01737     { DXGI_FORMAT_R16G16B16A16_SINT,            16, CONVF_SINT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01738     { DXGI_FORMAT_R32G32_FLOAT,                 32, CONVF_FLOAT | CONVF_R | CONVF_G },
01739     { DXGI_FORMAT_R32G32_UINT,                  32, CONVF_UINT | CONVF_R | CONVF_G  },
01740     { DXGI_FORMAT_R32G32_SINT,                  32, CONVF_SINT | CONVF_R | CONVF_G  },
01741     { DXGI_FORMAT_D32_FLOAT_S8X24_UINT,         32, CONVF_FLOAT | CONVF_DEPTH | CONVF_STENCIL },
01742     { DXGI_FORMAT_R10G10B10A2_UNORM,            10, CONVF_UNORM | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01743     { DXGI_FORMAT_R10G10B10A2_UINT,             10, CONVF_UINT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01744     { DXGI_FORMAT_R11G11B10_FLOAT,              10, CONVF_FLOAT | CONVF_R | CONVF_G | CONVF_B },
01745     { DXGI_FORMAT_R8G8B8A8_UNORM,               8, CONVF_UNORM | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01746     { DXGI_FORMAT_R8G8B8A8_UNORM_SRGB,          8, CONVF_UNORM | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01747     { DXGI_FORMAT_R8G8B8A8_UINT,                8, CONVF_UINT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01748     { DXGI_FORMAT_R8G8B8A8_SNORM,               8, CONVF_SNORM | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01749     { DXGI_FORMAT_R8G8B8A8_SINT,                8, CONVF_SINT | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01750     { DXGI_FORMAT_R16G16_FLOAT,                 16, CONVF_FLOAT | CONVF_R | CONVF_G },
01751     { DXGI_FORMAT_R16G16_UNORM,                 16, CONVF_UNORM | CONVF_R | CONVF_G },
01752     { DXGI_FORMAT_R16G16_UINT,                  16, CONVF_UINT | CONVF_R | CONVF_G },
01753     { DXGI_FORMAT_R16G16_SNORM,                 16, CONVF_SNORM | CONVF_R | CONVF_G },
01754     { DXGI_FORMAT_R16G16_SINT,                  16, CONVF_SINT | CONVF_R | CONVF_G },
01755     { DXGI_FORMAT_D32_FLOAT,                    32, CONVF_FLOAT | CONVF_DEPTH },
01756     { DXGI_FORMAT_R32_FLOAT,                    32, CONVF_FLOAT | CONVF_R },
01757     { DXGI_FORMAT_R32_UINT,                     32, CONVF_UINT | CONVF_R },
01758     { DXGI_FORMAT_R32_SINT,                     32, CONVF_SINT | CONVF_R },
01759     { DXGI_FORMAT_D24_UNORM_S8_UINT,            32, CONVF_UNORM | CONVF_DEPTH | CONVF_STENCIL },
01760     { DXGI_FORMAT_R8G8_UNORM,                   8, CONVF_UNORM | CONVF_R | CONVF_G },
01761     { DXGI_FORMAT_R8G8_UINT,                    8, CONVF_UINT | CONVF_R | CONVF_G },
01762     { DXGI_FORMAT_R8G8_SNORM,                   8, CONVF_SNORM | CONVF_R | CONVF_G },
01763     { DXGI_FORMAT_R8G8_SINT,                    8, CONVF_SINT | CONVF_R | CONVF_G },
01764     { DXGI_FORMAT_R16_FLOAT,                    16, CONVF_FLOAT | CONVF_R },
01765     { DXGI_FORMAT_D16_UNORM,                    16, CONVF_UNORM | CONVF_DEPTH },
01766     { DXGI_FORMAT_R16_UNORM,                    16, CONVF_UNORM | CONVF_R },
01767     { DXGI_FORMAT_R16_UINT,                     16, CONVF_UINT | CONVF_R },
01768     { DXGI_FORMAT_R16_SNORM,                    16, CONVF_SNORM | CONVF_R },
01769     { DXGI_FORMAT_R16_SINT,                     16, CONVF_SINT | CONVF_R },
01770     { DXGI_FORMAT_R8_UNORM,                     8, CONVF_UNORM | CONVF_R },
01771     { DXGI_FORMAT_R8_UINT,                      8, CONVF_UINT | CONVF_R },
01772     { DXGI_FORMAT_R8_SNORM,                     8, CONVF_SNORM | CONVF_R },
01773     { DXGI_FORMAT_R8_SINT,                      8, CONVF_SINT | CONVF_R },
01774     { DXGI_FORMAT_A8_UNORM,                     8, CONVF_UNORM | CONVF_A },
01775     { DXGI_FORMAT_R1_UNORM,                     1, CONVF_UNORM | CONVF_R },
01776     { DXGI_FORMAT_R9G9B9E5_SHAREDEXP,           9, CONVF_SHAREDEXP | CONVF_R | CONVF_G | CONVF_B },
01777     { DXGI_FORMAT_R8G8_B8G8_UNORM,              8, CONVF_UNORM | CONVF_PACKED | CONVF_R | CONVF_G | CONVF_B },
01778     { DXGI_FORMAT_G8R8_G8B8_UNORM,              8, CONVF_UNORM | CONVF_PACKED | CONVF_R | CONVF_G | CONVF_B },
01779     { DXGI_FORMAT_BC1_UNORM,                    8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01780     { DXGI_FORMAT_BC1_UNORM_SRGB,               8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01781     { DXGI_FORMAT_BC2_UNORM,                    8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01782     { DXGI_FORMAT_BC2_UNORM_SRGB,               8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01783     { DXGI_FORMAT_BC3_UNORM,                    8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01784     { DXGI_FORMAT_BC3_UNORM_SRGB,               8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01785     { DXGI_FORMAT_BC4_UNORM,                    8, CONVF_UNORM | CONVF_BC | CONVF_R },
01786     { DXGI_FORMAT_BC4_SNORM,                    8, CONVF_SNORM | CONVF_BC | CONVF_R },
01787     { DXGI_FORMAT_BC5_UNORM,                    8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G },
01788     { DXGI_FORMAT_BC5_SNORM,                    8, CONVF_SNORM | CONVF_BC | CONVF_R | CONVF_G },
01789     { DXGI_FORMAT_B5G6R5_UNORM,                 5, CONVF_UNORM | CONVF_R | CONVF_G | CONVF_B },
01790     { DXGI_FORMAT_B5G5R5A1_UNORM,               5, CONVF_UNORM | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01791     { DXGI_FORMAT_B8G8R8A8_UNORM,               8, CONVF_UNORM | CONVF_BGR | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01792     { DXGI_FORMAT_B8G8R8X8_UNORM,               8, CONVF_UNORM | CONVF_BGR | CONVF_R | CONVF_G | CONVF_B },
01793     { DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM,   10, CONVF_UNORM | CONVF_X2 | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01794     { DXGI_FORMAT_B8G8R8A8_UNORM_SRGB,          8, CONVF_UNORM | CONVF_BGR | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01795     { DXGI_FORMAT_B8G8R8X8_UNORM_SRGB,          8, CONVF_UNORM | CONVF_BGR | CONVF_R | CONVF_G | CONVF_B },
01796     { DXGI_FORMAT_BC6H_UF16,                    16, CONVF_FLOAT | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01797     { DXGI_FORMAT_BC6H_SF16,                    16, CONVF_FLOAT | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01798     { DXGI_FORMAT_BC7_UNORM,                    8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01799     { DXGI_FORMAT_BC7_UNORM_SRGB,               8, CONVF_UNORM | CONVF_BC | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01800     { DXGI_FORMAT_B4G4R4A4_UNORM,               4, CONVF_UNORM | CONVF_BGR | CONVF_R | CONVF_G | CONVF_B | CONVF_A },
01801 };
01802
01803 #pragma prefast( suppress : 25004, "Signature must match bsearch_s" );
01804 static int __cdecl _ConvertCompare( void *context, const void* ptr1, const void *ptr2 )
01805 {
01806     UNREFERENCED_PARAMETER(context);
01807     const ConvertData *p1 = reinterpret_cast<const ConvertData*>(ptr1);
01808     const ConvertData *p2 = reinterpret_cast<const ConvertData*>(ptr2);
01809     if ( p1->format == p2->format ) return 0;
01810     else return (p1->format < p2->format ) ? -1 : 1;
01811 }
01812
01813 _Use_decl_annotations_
01814 DWORD _GetConvertFlags( DXGI_FORMAT format )
01815 {
01816 #ifdef _DEBUG
01817     // Ensure conversion table is in ascending order
01818     assert( _countof(g_ConvertTable) > 0 );
01819     DXGI_FORMAT lastvalue = g_ConvertTable[0].format;
01820     for( size_t index=1; index < _countof(g_ConvertTable); ++index )
01821     {
01822         assert( g_ConvertTable[index].format > lastvalue );
01823         lastvalue = g_ConvertTable[index].format;
01824     }
01825 #endif
01826
01827     ConvertData key = { format, 0 };
01828     const ConvertData* in = (const ConvertData*) bsearch_s( &key, g_ConvertTable, _countof(g_ConvertTable), sizeof(ConvertData),
01829                                                             _ConvertCompare, 0 );
01830     return (in) ? in->flags : 0;
01831 }
01832
01833 _Use_decl_annotations_
01834 void _ConvertScanline( XMVECTOR* pBuffer, size_t count, DXGI_FORMAT outFormat, DXGI_FORMAT inFormat, DWORD flags )
01835 {
01836     assert( pBuffer && count > 0 && (((uintptr_t)pBuffer & 0xF) == 0) );
01837     assert( IsValid(outFormat) && !IsVideo(outFormat) && !IsTypeless(outFormat) );
01838     assert( IsValid(inFormat) && !IsVideo(inFormat) && !IsTypeless(inFormat) );
01839
01840     if ( !pBuffer )
01841         return;
01842
01843 #ifdef _DEBUG
01844     // Ensure conversion table is in ascending order
01845     assert( _countof(g_ConvertTable) > 0 );
01846     DXGI_FORMAT lastvalue = g_ConvertTable[0].format;
01847     for( size_t index=1; index < _countof(g_ConvertTable); ++index )
01848     {
01849         assert( g_ConvertTable[index].format > lastvalue );
01850         lastvalue = g_ConvertTable[index].format;
01851     }
01852 #endif
01853
01854     // Determine conversion details about source and dest formats
01855     ConvertData key = { inFormat, 0 };
01856     const ConvertData* in = (const ConvertData*) bsearch_s( &key, g_ConvertTable, _countof(g_ConvertTable), sizeof(ConvertData),
01857                                                             _ConvertCompare, 0 );
01858     key.format = outFormat;
01859     const ConvertData* out = (const ConvertData*) bsearch_s( &key, g_ConvertTable, _countof(g_ConvertTable), sizeof(ConvertData),
01860                                                             _ConvertCompare, 0 );
01861     if ( !in || !out )
01862     {
01863         assert(false);
01864         return;
01865     }
01866
01867     assert( _GetConvertFlags( inFormat ) == in->flags );
01868     assert( _GetConvertFlags( outFormat ) == out->flags );
01869
01870     // Handle SRGB filtering modes
01871     if ( IsSRGB( inFormat ) )
01872         flags |= TEX_FILTER_SRGB_IN;
01873
01874     if ( IsSRGB( outFormat ) )
01875         flags |= TEX_FILTER_SRGB_OUT;
01876
01877     if ( in->flags & CONVF_SNORM )
01878         flags &= ~TEX_FILTER_SRGB_IN;
01879
01880     if ( out->flags & CONVF_SNORM )
01881         flags &= ~TEX_FILTER_SRGB_OUT;
01882
01883     if ( (flags & (TEX_FILTER_SRGB_IN|TEX_FILTER_SRGB_OUT)) == (TEX_FILTER_SRGB_IN|TEX_FILTER_SRGB_OUT) )
01884     {
01885         flags &= ~(TEX_FILTER_SRGB_IN|TEX_FILTER_SRGB_OUT);
01886     }
01887
01888     // sRGB input processing (sRGB -> RGB)
01889     if ( flags & TEX_FILTER_SRGB_IN )
01890     {
01891         if ( (in->flags & CONVF_FLOAT) || (in->flags & CONVF_UNORM) )
01892         {
01893             XMVECTOR* ptr = pBuffer;
01894             for( size_t i=0; i < count; ++i )
01895             {
01896                 // rgb = rgb^(2.2); a=a
01897                 XMVECTOR v = *ptr;
01898                 XMVECTOR v1 = _TableDecodeGamma22( v );
01899                 *ptr++ = XMVectorSelect( v, v1, g_XMSelect1110 );
01900             }
01901         }
01902     }
01903
01904     // Handle conversion special cases
01905     DWORD diffFlags = in->flags ^ out->flags;
01906     if ( diffFlags != 0)
01907     {
01908         if ( out->flags & CONVF_UNORM )
01909         {
01910             if ( in->flags & CONVF_SNORM )
01911             {
01912                 // SNORM -> UNORM
01913                 XMVECTOR* ptr = pBuffer;
01914                 for( size_t i=0; i < count; ++i )
01915                 {
01916                     XMVECTOR v = *ptr;
01917                     *ptr++ = XMVectorMultiplyAdd( v, g_XMOneHalf, g_XMOneHalf );
01918                 }
01919             }
01920             else if ( in->flags & CONVF_FLOAT )
01921             {
01922                 // FLOAT -> UNORM
01923                 XMVECTOR* ptr = pBuffer;
01924                 for( size_t i=0; i < count; ++i )
01925                 {
01926                     XMVECTOR v = *ptr;
01927                     *ptr++ = XMVectorSaturate( v );
01928                 }
01929             }
01930         }
01931         else if ( out->flags & CONVF_SNORM )
01932         {
01933             if ( in->flags & CONVF_UNORM )
01934             {
01935                 // UNORM -> SNORM
01936                 static XMVECTORF32 two = { 2.0f, 2.0f, 2.0f, 2.0f };
01937                 XMVECTOR* ptr = pBuffer;
01938                 for( size_t i=0; i < count; ++i )
01939                 {
01940                     XMVECTOR v = *ptr;
01941                     *ptr++ = XMVectorMultiplyAdd( v, two, g_XMNegativeOne );
01942                 }
01943             }
01944             else if ( in->flags & CONVF_FLOAT )
01945             {
01946                 // FLOAT -> SNORM
01947                 XMVECTOR* ptr = pBuffer;
01948                 for( size_t i=0; i < count; ++i )
01949                 {
01950                     XMVECTOR v = *ptr;
01951                     *ptr++ = XMVectorClamp( v, g_XMNegativeOne, g_XMOne );
01952                 }
01953             }
01954         }
01955
01956         // !CONVF_A -> CONVF_A is handled because LoadScanline ensures alpha defaults to 1.0 for no-alpha formats
01957
01958         // CONVF_PACKED cases are handled because LoadScanline/StoreScanline handles packing/unpacking
01959
01960         if ( ((out->flags & CONVF_RGBA_MASK) == CONVF_A) && !(in->flags & CONVF_A) )
01961         {
01962             // !CONVF_A -> A format
01963             XMVECTOR* ptr = pBuffer;
01964             for( size_t i=0; i < count; ++i )
01965             {
01966                 XMVECTOR v = *ptr;
01967                 *ptr++ = XMVectorSplatX( v );
01968             }
01969         }
01970         else if ( ((in->flags & CONVF_RGBA_MASK) == CONVF_A) && !(out->flags & CONVF_A) )
01971         {
01972             // A format -> !CONVF_A
01973             XMVECTOR* ptr = pBuffer;
01974             for( size_t i=0; i < count; ++i )
01975             {
01976                 XMVECTOR v = *ptr;
01977                 *ptr++ = XMVectorSplatW( v );
01978             }
01979         }
01980         else if ( ((in->flags & CONVF_RGB_MASK) == CONVF_R) && ((out->flags & CONVF_RGB_MASK) == (CONVF_R|CONVF_G|CONVF_B)) )
01981         {
01982             // R format -> RGB format
01983             XMVECTOR* ptr = pBuffer;
01984             for( size_t i=0; i < count; ++i )
01985             {
01986                 XMVECTOR v = *ptr;
01987                 XMVECTOR v1 = XMVectorSplatX( v );
01988                 *ptr++ = XMVectorSelect( v, v1, g_XMSelect1110 );
01989             }
01990         }
01991     }
01992
01993     // sRGB output processing (RGB -> sRGB)
01994     if ( flags & TEX_FILTER_SRGB_OUT )
01995     {
01996         if ( (out->flags & CONVF_FLOAT) || (out->flags & CONVF_UNORM) )
01997         {
01998             XMVECTOR* ptr = pBuffer;
01999             for( size_t i=0; i < count; ++i )
02000             {
02001                 // rgb = rgb^(1/2.2); a=a
02002                 XMVECTOR v = *ptr;
02003                 XMVECTOR v1 = _TableEncodeGamma22( v );
02004                 *ptr++ = XMVectorSelect( v, v1, g_XMSelect1110 );
02005             }
02006         }
02007     }
02008 }
02009
02010
02011 //-------------------------------------------------------------------------------------
02012 // Convert the source image using WIC
02013 //-------------------------------------------------------------------------------------
02014 static HRESULT _ConvertUsingWIC( _In_ const Image& srcImage, _In_ const WICPixelFormatGUID& pfGUID,
02015                                  _In_ const WICPixelFormatGUID& targetGUID,
02016                                  _In_ DWORD filter, _In_ float threshold,  _In_ const Image& destImage )
02017 {
02018     assert( srcImage.width == destImage.width );
02019     assert( srcImage.height == destImage.height );
02020
02021     IWICImagingFactory* pWIC = _GetWIC();
02022     if ( !pWIC )
02023         return E_NOINTERFACE;
02024
02025     ScopedObject<IWICFormatConverter> FC;
02026     HRESULT hr = pWIC->CreateFormatConverter( &FC );
02027     if ( FAILED(hr) )
02028         return hr;
02029
02030 // Need to add logic to use TEX_FILTER_SRGB_IN/TEX_FILTER_SRGB_OUT
02031
02032     BOOL canConvert = FALSE;
02033     hr = FC->CanConvert( pfGUID, targetGUID, &canConvert );
02034     if ( FAILED(hr) || !canConvert )
02035     {
02036         // This case is not an issue for the subset of WIC formats that map directly to DXGI
02037         return E_UNEXPECTED;
02038     }
02039
02040     ScopedObject<IWICBitmap> source;
02041     hr = pWIC->CreateBitmapFromMemory( static_cast<UINT>( srcImage.width ), static_cast<UINT>( srcImage.height ), pfGUID,
02042                                        static_cast<UINT>( srcImage.rowPitch ), static_cast<UINT>( srcImage.slicePitch ),
02043                                        srcImage.pixels, &source );
02044     if ( FAILED(hr) )
02045         return hr;
02046
02047     hr = FC->Initialize( source.Get(), targetGUID, _GetWICDither( filter ), 0, threshold, WICBitmapPaletteTypeCustom );
02048     if ( FAILED(hr) )
02049         return hr;
02050
02051     hr = FC->CopyPixels( 0, static_cast<UINT>( destImage.rowPitch ), static_cast<UINT>( destImage.slicePitch ), destImage.pixels );
02052     if ( FAILED(hr) )
02053         return hr;
02054
02055     return S_OK;
02056 }
02057
02058
02059 //-------------------------------------------------------------------------------------
02060 // Convert the source using WIC and then convert to DXGI format from there
02061 //-------------------------------------------------------------------------------------
02062 static HRESULT _ConvertFromWIC( _In_ const Image& srcImage, _In_ const WICPixelFormatGUID& pfGUID,
02063                                 _In_ DWORD filter, _In_ float threshold,  _In_ const Image& destImage )
02064 {
02065     assert( srcImage.width == destImage.width );
02066     assert( srcImage.height == destImage.height );
02067
02068     IWICImagingFactory* pWIC = _GetWIC();
02069     if ( !pWIC )
02070         return E_NOINTERFACE;
02071
02072     ScopedObject<IWICFormatConverter> FC;
02073     HRESULT hr = pWIC->CreateFormatConverter( &FC );
02074     if ( FAILED(hr) )
02075         return hr;
02076
02077     BOOL canConvert = FALSE;
02078     hr = FC->CanConvert( pfGUID, GUID_WICPixelFormat128bppRGBAFloat, &canConvert );
02079     if ( FAILED(hr) || !canConvert )
02080     {
02081         // This case is not an issue for the subset of WIC formats that map directly to DXGI
02082         return E_UNEXPECTED;
02083     }
02084
02085     ScratchImage temp;
02086     hr = temp.Initialize2D( DXGI_FORMAT_R32G32B32A32_FLOAT, srcImage.width, srcImage.height, 1, 1 );
02087     if ( FAILED(hr) )
02088         return hr;
02089
02090     const Image *timg = temp.GetImage( 0, 0, 0 );
02091     if ( !timg )
02092         return E_POINTER;
02093
02094     ScopedObject<IWICBitmap> source;
02095     hr = pWIC->CreateBitmapFromMemory( static_cast<UINT>( srcImage.width ), static_cast<UINT>( srcImage.height ), pfGUID,
02096                                        static_cast<UINT>( srcImage.rowPitch ), static_cast<UINT>( srcImage.slicePitch ),
02097                                        srcImage.pixels, &source );
02098     if ( FAILED(hr) )
02099         return hr;
02100
02101     hr = FC->Initialize( source.Get(), GUID_WICPixelFormat128bppRGBAFloat, _GetWICDither( filter ), 0, threshold, WICBitmapPaletteTypeCustom );
02102     if ( FAILED(hr) )
02103         return hr;
02104
02105     hr = FC->CopyPixels( 0, static_cast<UINT>( timg->rowPitch ), static_cast<UINT>( timg->slicePitch ), timg->pixels );
02106     if ( FAILED(hr) )
02107         return hr;
02108
02109     // Perform conversion on temp image which is now in R32G32B32A32_FLOAT format to final image
02110     uint8_t *pSrc = timg->pixels;
02111     uint8_t *pDest = destImage.pixels;
02112     if ( !pSrc || !pDest )
02113         return E_POINTER;
02114
02115     for( size_t h = 0; h < srcImage.height; ++h )
02116     {
02117         _ConvertScanline( reinterpret_cast<XMVECTOR*>(pSrc), srcImage.width, destImage.format, DXGI_FORMAT_R32G32B32A32_FLOAT, filter );
02118
02119         if ( !_StoreScanline( pDest, destImage.rowPitch, destImage.format, reinterpret_cast<const XMVECTOR*>(pSrc), srcImage.width ) )
02120             return E_FAIL;
02121
02122         pSrc += timg->rowPitch;
02123         pDest += destImage.rowPitch;
02124     }
02125
02126     return S_OK;
02127 }
02128
02129
02130 //-------------------------------------------------------------------------------------
02131 // Convert the source from DXGI format then use WIC to convert to final format
02132 //-------------------------------------------------------------------------------------
02133 static HRESULT _ConvertToWIC( _In_ const Image& srcImage,
02134                               _In_ const WICPixelFormatGUID& targetGUID, _In_ DWORD filter, _In_ float threshold,  _In_ const Image& destImage )
02135 {
02136     assert( srcImage.width == destImage.width );
02137     assert( srcImage.height == destImage.height );
02138
02139     IWICImagingFactory* pWIC = _GetWIC();
02140     if ( !pWIC )
02141         return E_NOINTERFACE;
02142
02143     ScopedObject<IWICFormatConverter> FC;
02144     HRESULT hr = pWIC->CreateFormatConverter( &FC );
02145     if ( FAILED(hr) )
02146         return hr;
02147
02148     BOOL canConvert = FALSE;
02149     hr = FC->CanConvert( GUID_WICPixelFormat128bppRGBAFloat, targetGUID, &canConvert );
02150     if ( FAILED(hr) || !canConvert )
02151     {
02152         // This case is not an issue for the subset of WIC formats that map directly to DXGI
02153         return E_UNEXPECTED;
02154     }
02155
02156     ScratchImage temp;
02157     hr = temp.Initialize2D( DXGI_FORMAT_R32G32B32A32_FLOAT, srcImage.width, srcImage.height, 1, 1 );
02158     if ( FAILED(hr) )
02159         return hr;
02160
02161     const Image *timg = temp.GetImage( 0, 0, 0 );
02162     if ( !timg )
02163         return E_POINTER;
02164
02165     const uint8_t *pSrc = srcImage.pixels;
02166     if ( !pSrc )
02167         return E_POINTER;
02168
02169     uint8_t *pDest = timg->pixels;
02170     if ( !pDest )
02171         return E_POINTER;
02172
02173     for( size_t h = 0; h < srcImage.height; ++h )
02174     {
02175         if ( !_LoadScanline( reinterpret_cast<XMVECTOR*>(pDest), srcImage.width, pSrc, srcImage.rowPitch, srcImage.format ) )
02176             return E_FAIL;
02177
02178         _ConvertScanline( reinterpret_cast<XMVECTOR*>(pDest), srcImage.width, DXGI_FORMAT_R32G32B32A32_FLOAT, srcImage.format, filter );
02179
02180         pSrc += srcImage.rowPitch;
02181         pDest += timg->rowPitch;
02182     }
02183
02184     // Perform conversion on temp image which is now in R32G32B32A32_FLOAT format
02185     ScopedObject<IWICBitmap> source;
02186     hr = pWIC->CreateBitmapFromMemory( static_cast<UINT>( timg->width ), static_cast<UINT>( timg->height ), GUID_WICPixelFormat128bppRGBAFloat,
02187                                        static_cast<UINT>( timg->rowPitch ), static_cast<UINT>( timg->slicePitch ),
02188                                        timg->pixels, &source );
02189     if ( FAILED(hr) )
02190         return hr;
02191
02192     hr = FC->Initialize( source.Get(), targetGUID, _GetWICDither( filter ), 0, threshold, WICBitmapPaletteTypeCustom );
02193     if ( FAILED(hr) )
02194         return hr;
02195
02196     hr = FC->CopyPixels( 0, static_cast<UINT>( destImage.rowPitch ), static_cast<UINT>( destImage.slicePitch ), destImage.pixels );
02197     if ( FAILED(hr) )
02198         return hr;
02199
02200     return S_OK;
02201 }
02202
02203
02204 //-------------------------------------------------------------------------------------
02205 // Convert the source image (not using WIC)
02206 //-------------------------------------------------------------------------------------
02207 static HRESULT _Convert( _In_ const Image& srcImage, _In_ DWORD filter, _In_ const Image& destImage )
02208 {
02209     assert( srcImage.width == destImage.width );
02210     assert( srcImage.height == destImage.height );
02211
02212     ScopedAlignedArrayXMVECTOR scanline( reinterpret_cast<XMVECTOR*>( _aligned_malloc( (sizeof(XMVECTOR)*srcImage.width), 16 ) ) );
02213     if ( !scanline )
02214         return E_OUTOFMEMORY;
02215
02216     const uint8_t *pSrc = srcImage.pixels;
02217     uint8_t *pDest = destImage.pixels;
02218     if ( !pSrc || !pDest )
02219         return E_POINTER;
02220
02221     for( size_t h = 0; h < srcImage.height; ++h )
02222     {
02223         if ( !_LoadScanline( scanline.get(), srcImage.width, pSrc, srcImage.rowPitch, srcImage.format ) )
02224             return E_FAIL;
02225
02226         _ConvertScanline( scanline.get(), srcImage.width, destImage.format, srcImage.format, filter );
02227
02228         if ( !_StoreScanline( pDest, destImage.rowPitch, destImage.format, scanline.get(), srcImage.width ) )
02229             return E_FAIL;
02230
02231         pSrc += srcImage.rowPitch;
02232         pDest += destImage.rowPitch;
02233     }
02234
02235     return S_OK;
02236 }
02237
02238
02239 //=====================================================================================
02240 // Entry-points
02241 //=====================================================================================
02242
02243 //-------------------------------------------------------------------------------------
02244 // Convert image
02245 //-------------------------------------------------------------------------------------
02246 _Use_decl_annotations_
02247 HRESULT Convert( const Image& srcImage, DXGI_FORMAT format, DWORD filter, float threshold, ScratchImage& image )
02248 {
02249     if ( (srcImage.format == format) || !IsValid( format ) )
02250         return E_INVALIDARG;
02251
02252     if ( !srcImage.pixels )
02253         return E_POINTER;
02254
02255     if ( IsCompressed(srcImage.format) || IsCompressed(format)
02256          || IsVideo(srcImage.format) || IsVideo(format)
02257          || IsTypeless(srcImage.format) || IsTypeless(format) )
02258         return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
02259
02260 #ifdef _AMD64_
02261     if ( (srcImage.width > 0xFFFFFFFF) || (srcImage.height > 0xFFFFFFFF) )
02262         return E_INVALIDARG;
02263 #endif
02264
02265     HRESULT hr = image.Initialize2D( format, srcImage.width, srcImage.height, 1, 1 );
02266     if ( FAILED(hr) )
02267         return hr;
02268
02269     const Image *rimage = image.GetImage( 0, 0, 0 );
02270     if ( !rimage )
02271     {
02272         image.Release();
02273         return E_POINTER;
02274     }
02275
02276     WICPixelFormatGUID pfGUID;
02277     if ( _DXGIToWIC( srcImage.format, pfGUID ) )
02278     {
02279         WICPixelFormatGUID targetGUID;
02280         if ( _DXGIToWIC( format, targetGUID ) )
02281         {
02282             // Case 1: Both source and target formats are WIC supported
02283             hr = _ConvertUsingWIC( srcImage, pfGUID, targetGUID, filter, threshold, *rimage );
02284         }
02285         else
02286         {
02287             // Case 2: Source format is supported by WIC, but not the target format
02288             hr = _ConvertFromWIC( srcImage, pfGUID, filter, threshold, *rimage );
02289         }
02290     }
02291     else
02292     {
02293         WICPixelFormatGUID targetGUID;
02294         if ( _DXGIToWIC( format, targetGUID ) )
02295         {
02296             // Case 3: Source format is not supported by WIC, but does support the target format
02297             hr = _ConvertToWIC( srcImage, targetGUID, filter, threshold, *rimage );
02298         }
02299         else
02300         {
02301             // Case 4: Both source and target format are not supported by WIC
02302             hr = _Convert( srcImage, filter, *rimage );
02303         }
02304     }
02305
02306     if ( FAILED(hr) )
02307     {
02308         image.Release();
02309         return hr;
02310     }
02311
02312     return S_OK;
02313 }
02314
02315
02316 //-------------------------------------------------------------------------------------
02317 // Convert image (complex)
02318 //-------------------------------------------------------------------------------------
02319 _Use_decl_annotations_
02320 HRESULT Convert( const Image* srcImages, size_t nimages, const TexMetadata& metadata,
02321                  DXGI_FORMAT format, DWORD filter, float threshold, ScratchImage& result )
02322 {
02323     if ( !srcImages || !nimages || (metadata.format == format) || !IsValid(format) )
02324         return E_INVALIDARG;
02325
02326     if ( IsCompressed(metadata.format) || IsCompressed(format)
02327          || IsVideo(metadata.format) || IsVideo(format)
02328          || IsTypeless(metadata.format) || IsTypeless(format) )
02329         return HRESULT_FROM_WIN32( ERROR_NOT_SUPPORTED );
02330
02331 #ifdef _AMD64_
02332     if ( (metadata.width > 0xFFFFFFFF) || (metadata.height > 0xFFFFFFFF) )
02333         return E_INVALIDARG;
02334 #endif
02335
02336     TexMetadata mdata2 = metadata;
02337     mdata2.format = format;
02338     HRESULT hr = result.Initialize( mdata2 );
02339     if ( FAILED(hr) )
02340         return hr;
02341
02342     if ( nimages != result.GetImageCount() )
02343     {
02344         result.Release();
02345         return E_FAIL;
02346     }
02347
02348     const Image* dest = result.GetImages();
02349     if ( !dest )
02350     {
02351         result.Release();
02352         return E_POINTER;
02353     }
02354
02355     WICPixelFormatGUID pfGUID, targetGUID;
02356     bool wicpf = _DXGIToWIC( metadata.format, pfGUID );
02357     bool wictargetpf = _DXGIToWIC( format, targetGUID );
02358
02359     for( size_t index=0; index < nimages; ++index )
02360     {
02361         const Image& src = srcImages[ index ];
02362         if ( src.format != metadata.format )
02363         {
02364             result.Release();
02365             return E_FAIL;
02366         }
02367
02368 #ifdef _AMD64_
02369         if ( (src.width > 0xFFFFFFFF) || (src.height > 0xFFFFFFFF) )
02370             return E_FAIL;
02371 #endif
02372
02373         const Image& dst = dest[ index ];
02374         assert( dst.format == format );
02375
02376         if ( src.width != dst.width || src.height != dst.height )
02377         {
02378             result.Release();
02379             return E_FAIL;
02380         }
02381
02382         if ( wicpf )
02383         {
02384             if ( wictargetpf )
02385             {
02386                 // Case 1: Both source and target formats are WIC supported
02387                 hr = _ConvertUsingWIC( src, pfGUID, targetGUID, filter, threshold, dst );
02388             }
02389             else
02390             {
02391                 // Case 2: Source format is supported by WIC, but not the target format
02392                 hr = _ConvertFromWIC( src, pfGUID, filter, threshold, dst );
02393             }
02394         }
02395         else
02396         {
02397             if ( wictargetpf )
02398             {
02399                 // Case 3: Source format is not supported by WIC, but does support the target format
02400                 hr = _ConvertToWIC( src, targetGUID, filter, threshold, dst );
02401             }
02402             else
02403             {
02404                 // Case 4: Both source and target format are not supported by WIC
02405                 hr = _Convert( src, filter, dst );
02406             }
02407         }
02408
02409         if ( FAILED(hr) )
02410         {
02411             result.Release();
02412             return hr;
02413         }
02414     }
02415
02416     return S_OK;
02417 }
02418
02419 }; // namespace
Generated on Sat Nov 23 2024 16:08:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareLink.xaml.cpp Source File

  • Sharing content source app

ShareLink.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ShareLink.xaml.cpp
00013 // Implementation of the ShareLink class
00014 //
00015
00016 #include "pch.h"
00017 #include "ShareLink.xaml.h"
00018
00019 using namespace SDKSample::ShareSource;
00020 using namespace SDKSample::Common;
00021
00022 using namespace Platform;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::ApplicationModel::DataTransfer;
00025
00026 ShareLink::ShareLink()
00027 {
00028     InitializeComponent();
00029
00030     // Get a pointer to our main page.
00031     rootPage = MainPage::Current;
00032 }
00033
00034 bool ShareLink::GetShareContent(DataRequest^ request)
00035 {
00036     bool succeeded = false;
00037
00038     // The URI used in this sample is provided by the user so we need to ensure it's a wellformatted absolute URI
00039     // before we try to share it.
00040     rootPage->NotifyUser("", NotifyType::StatusMessage);
00041     Uri^ dataPackageUri = ValidateAndGetUri(UriToShare->Text);
00042     if (dataPackageUri != nullptr)
00043     {
00044         auto requestData = request->Data;
00045         requestData->Properties->Title = TitleInputBox->Text;
00046
00047         // The description is optional.
00048         auto dataPackageDescription = DescriptionInputBox->Text;
00049         if (dataPackageDescription != nullptr)
00050         {
00051             requestData->Properties->Description = dataPackageDescription;
00052         }
00053         requestData->SetUri(dataPackageUri);
00054         succeeded = true;
00055     }
00056     else
00057     {
00058         request->FailWithDisplayText("Enter the link you would like to share and try again.");
00059     }
00060     return succeeded;
00061 }
00062
00063 Uri^ ShareLink::ValidateAndGetUri(String^ uriString)
00064 {
00065     Uri^ uri = nullptr;
00066     try
00067     {
00068         uri = ref new Uri(uriString);
00069     }
00070     catch (InvalidArgumentException^)
00071     {
00072         rootPage->NotifyUser("The link provided is not a valid absolute URI.", NotifyType::ErrorMessage);
00073     }
00074     catch (NullReferenceException^)
00075     {
00076         rootPage->NotifyUser("Please provide a link to share.", NotifyType::ErrorMessage);
00077     }
00078     return uri;
00079 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/pch.cpp Source File

  • Compass sensor

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickCachedFile.xaml.h Source File

  • File picker contracts

FileOpenPicker_PickCachedFile.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FileOpenPicker_PickCachedFile.xaml.h
00013 // Declaration of the FileOpenPicker_PickCachedFile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "FileOpenPicker_PickCachedFile.g.h"
00020
00021 namespace SDKSample
00022 {
00023     namespace FilePickerContracts
00024     {
00025         /// <summary>
00026         /// An empty page that can be used on its own or navigated to within a Frame.
00027         /// </summary>
00028         [Windows::Foundation::Metadata::WebHostHidden]
00029         public ref class FileOpenPicker_PickCachedFile sealed
00030         {
00031         public:
00032             FileOpenPicker_PickCachedFile();
00033
00034         protected:
00035             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         internal:
00039             Windows::Storage::Pickers::Provider::FileOpenPickerUI^ fileOpenPickerUI;
00040
00041         private:
00042             Platform::String^ fileID;
00043             Windows::Foundation::EventRegistrationToken token;
00044
00045             void AddFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046             void RemoveFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void OnFileRemoved(Windows::Storage::Pickers::Provider::FileOpenPickerUI^ sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^ e);
00048             void UpdateButtonState(bool fileInBasket);
00049         };
00050     }
00051 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/Invert.cpp Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert

Invert.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #include "Invert.h"
00009 #include "VideoBufferLock.h"
00010 #include "TextureLock.h"
00011
00012 #include "InvertModule.h"
00013 #include "CopyModule.h"
00014
00015 using namespace Microsoft::WRL;
00016
00017 HRESULT GetDefaultStride(IMFMediaType *pType, LONG *plStride);
00018 HRESULT BufferToDXType(IMFMediaBuffer *pBuffer, _Out_ UINT *uiViewIndex, _Out_ ID3D11Texture2D **ppTexture);
00019
00020 CInvert::CInvert() :
00021     m_imageWidthInPixels(0),
00022     m_imageHeightInPixels(0),
00023     m_cbImageSize(0),
00024     m_bStreamingInitialized(false)
00025 {
00026     InitializeCriticalSectionEx(&m_critSec, 3000, 0);
00027 }
00028
00029 CInvert::~CInvert()
00030 {
00031     DeleteCriticalSection(&m_critSec);
00032     if( m_pTransform )
00033     {
00034         delete m_pTransform;
00035     }
00036 }
00037
00038 // Initialize the instance.
00039 STDMETHODIMP CInvert::RuntimeClassInitialize()
00040 {
00041     HRESULT hr = S_OK;
00042
00043     // Create the attribute store.
00044     hr = MFCreateAttributes(&m_pAttributes, 3);
00045     if (FAILED(hr))
00046     {
00047         goto done;
00048     }
00049
00050     // MFT supports DX11 acceleration
00051     hr = m_pAttributes->SetUINT32(MF_SA_D3D_AWARE, 1);
00052     if (FAILED(hr))
00053     {
00054         goto done;
00055     }
00056
00057     hr = m_pAttributes->SetUINT32(MF_SA_D3D11_AWARE, 1);
00058     if (FAILED(hr))
00059     {
00060         goto done;
00061     }
00062
00063     // output attributes
00064     hr = MFCreateAttributes( &m_spOutputAttributes, 1 );
00065     if (FAILED(hr))
00066     {
00067         goto done;
00068     }
00069
00070     // Load the transform
00071     m_pTransform = new CInvertModule();
00072     if( m_pTransform == nullptr )
00073     {
00074         hr = E_OUTOFMEMORY;
00075         goto done;
00076     }
00077
00078 done:
00079     return hr;
00080 }
00081
00082 // IMediaExtension methods
00083
00084 //-------------------------------------------------------------------
00085 // SetProperties
00086 // Sets the configuration of the effect
00087 //-------------------------------------------------------------------
00088 HRESULT CInvert::SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
00089 {
00090     return S_OK;
00091 }
00092
00093 //-------------------------------------------------------------------
00094 // GetStreamLimits
00095 // Returns the minimum and maximum number of streams.
00096 //-------------------------------------------------------------------
00097
00098 HRESULT CInvert::GetStreamLimits(
00099     DWORD   *pdwInputMinimum,
00100     DWORD   *pdwInputMaximum,
00101     DWORD   *pdwOutputMinimum,
00102     DWORD   *pdwOutputMaximum
00103 )
00104 {
00105     if ((pdwInputMinimum == NULL) ||
00106         (pdwInputMaximum == NULL) ||
00107         (pdwOutputMinimum == NULL) ||
00108         (pdwOutputMaximum == NULL))
00109     {
00110         return E_POINTER;
00111     }
00112
00113     // This MFT has a fixed number of streams.
00114     *pdwInputMinimum = 1;
00115     *pdwInputMaximum = 1;
00116     *pdwOutputMinimum = 1;
00117     *pdwOutputMaximum = 1;
00118     return S_OK;
00119 }
00120
00121
00122 //-------------------------------------------------------------------
00123 // GetStreamCount
00124 // Returns the actual number of streams.
00125 //-------------------------------------------------------------------
00126
00127 HRESULT CInvert::GetStreamCount(
00128     DWORD   *pcInputStreams,
00129     DWORD   *pcOutputStreams
00130 )
00131 {
00132     if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))
00133     {
00134         return E_POINTER;
00135     }
00136
00137     // This MFT has a fixed number of streams.
00138     *pcInputStreams = 1;
00139     *pcOutputStreams = 1;
00140     return S_OK;
00141 }
00142
00143
00144 //-------------------------------------------------------------------
00145 // GetInputStreamInfo
00146 // Returns information about an input stream.
00147 //-------------------------------------------------------------------
00148
00149 HRESULT CInvert::GetInputStreamInfo(
00150     DWORD                     dwInputStreamID,
00151     MFT_INPUT_STREAM_INFO *   pStreamInfo
00152 )
00153 {
00154     if (pStreamInfo == NULL)
00155     {
00156         return E_POINTER;
00157     }
00158
00159     if (dwInputStreamID != 0)
00160     {
00161         return MF_E_INVALIDSTREAMNUMBER;
00162     }
00163
00164     EnterCriticalSection(&m_critSec);
00165
00166     pStreamInfo->hnsMaxLatency = 0;
00167     pStreamInfo->dwFlags = MFT_INPUT_STREAM_WHOLE_SAMPLES | MFT_INPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER;
00168     pStreamInfo->cbSize = m_pInputType == NULL ? 0 : m_cbImageSize;
00169     pStreamInfo->cbMaxLookahead = 0;
00170     pStreamInfo->cbAlignment = 0;
00171
00172     LeaveCriticalSection(&m_critSec);
00173     return S_OK;
00174 }
00175
00176 //-------------------------------------------------------------------
00177 // GetOutputStreamInfo
00178 // Returns information about an output stream.
00179 //-------------------------------------------------------------------
00180
00181 HRESULT CInvert::GetOutputStreamInfo(
00182     DWORD                     dwOutputStreamID,
00183     MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00184 )
00185 {
00186     if (pStreamInfo == NULL)
00187     {
00188         return E_POINTER;
00189     }
00190
00191     if (dwOutputStreamID != 0)
00192     {
00193         return MF_E_INVALIDSTREAMNUMBER;
00194     }
00195
00196     EnterCriticalSection(&m_critSec);
00197
00198     pStreamInfo->dwFlags =
00199         MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
00200         MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
00201         MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;
00202
00203     if( m_pDX11Manager != nullptr )
00204     {
00205         pStreamInfo->dwFlags |= MFT_OUTPUT_STREAM_PROVIDES_SAMPLES;
00206     }
00207
00208     pStreamInfo->cbSize = m_pInputType == NULL ? 0 : m_cbImageSize;
00209     pStreamInfo->cbAlignment = 0;
00210
00211     LeaveCriticalSection(&m_critSec);
00212     return S_OK;
00213 }
00214
00215 //-------------------------------------------------------------------
00216 // Name: GetOutputStreamAttributes
00217 // Returns stream-level attributes for an output stream.
00218 //-------------------------------------------------------------------
00219
00220 HRESULT CInvert::GetOutputStreamAttributes(
00221     DWORD           dwOutputStreamID,
00222     IMFAttributes   **ppAttributes
00223     )
00224 {
00225     HRESULT hr = S_OK;
00226
00227     if (NULL == ppAttributes)
00228     {
00229         return E_POINTER;
00230     }
00231
00232     if (dwOutputStreamID != 0)
00233     {
00234         return MF_E_INVALIDSTREAMNUMBER;
00235     }
00236
00237     m_spOutputAttributes.CopyTo(ppAttributes);
00238
00239     return( hr );
00240 }
00241
00242 //-------------------------------------------------------------------
00243 // GetAttributes
00244 // Returns the attributes for the MFT.
00245 //-------------------------------------------------------------------
00246
00247 HRESULT CInvert::GetAttributes(IMFAttributes** ppAttributes)
00248 {
00249     if (ppAttributes == NULL)
00250     {
00251         return E_POINTER;
00252     }
00253
00254     EnterCriticalSection(&m_critSec);
00255
00256     m_pAttributes.CopyTo(ppAttributes);
00257
00258     LeaveCriticalSection(&m_critSec);
00259     return S_OK;
00260 }
00261
00262
00263 //-------------------------------------------------------------------
00264 // GetInputAvailableType
00265 // Returns a preferred input type.
00266 //-------------------------------------------------------------------
00267
00268 HRESULT CInvert::GetInputAvailableType(
00269     DWORD           dwInputStreamID,
00270     DWORD           dwTypeIndex, // 0-based
00271     IMFMediaType    **ppType
00272 )
00273 {
00274     if (ppType == NULL)
00275     {
00276         return E_INVALIDARG;
00277     }
00278
00279     if (dwInputStreamID != 0)
00280     {
00281         return MF_E_INVALIDSTREAMNUMBER;
00282     }
00283
00284     EnterCriticalSection(&m_critSec);
00285     HRESULT hr = S_OK;
00286
00287     // If the output type is set, return that type as our preferred input type.
00288     if (m_pOutputType == NULL)
00289     {
00290         // The output type is not set. Create a partial media type.
00291         hr = OnGetPartialType(dwTypeIndex, ppType);
00292     }
00293     else if (dwTypeIndex > 0)
00294     {
00295         hr = MF_E_NO_MORE_TYPES;
00296     }
00297     else
00298     {
00299         *ppType = m_pOutputType.Get();
00300         (*ppType)->AddRef();
00301     }
00302
00303     LeaveCriticalSection(&m_critSec);
00304     return hr;
00305 }
00306
00307
00308
00309 //-------------------------------------------------------------------
00310 // GetOutputAvailableType
00311 // Returns a preferred output type.
00312 //-------------------------------------------------------------------
00313
00314 HRESULT CInvert::GetOutputAvailableType(
00315     DWORD           dwOutputStreamID,
00316     DWORD           dwTypeIndex, // 0-based
00317     IMFMediaType    **ppType
00318 )
00319 {
00320     if (ppType == NULL)
00321     {
00322         return E_INVALIDARG;
00323     }
00324
00325     if (dwOutputStreamID != 0)
00326     {
00327         return MF_E_INVALIDSTREAMNUMBER;
00328     }
00329
00330     EnterCriticalSection(&m_critSec);
00331     HRESULT hr = S_OK;
00332
00333     if (m_pInputType == NULL)
00334     {
00335         // The input type is not set. Create a partial media type.
00336         hr = OnGetPartialType(dwTypeIndex, ppType);
00337     }
00338     else if (dwTypeIndex > 0)
00339     {
00340         hr = MF_E_NO_MORE_TYPES;
00341     }
00342     else
00343     {
00344         *ppType = m_pInputType.Get();
00345         (*ppType)->AddRef();
00346     }
00347
00348     LeaveCriticalSection(&m_critSec);
00349     return hr;
00350 }
00351
00352
00353 //-------------------------------------------------------------------
00354 // SetInputType
00355 //-------------------------------------------------------------------
00356
00357 HRESULT CInvert::SetInputType(
00358     DWORD           dwInputStreamID,
00359     IMFMediaType    *pType, // Can be NULL to clear the input type.
00360     DWORD           dwFlags
00361 )
00362 {
00363     // Validate flags.
00364     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00365     {
00366         return E_INVALIDARG;
00367     }
00368
00369     if (dwInputStreamID != 0)
00370     {
00371         return MF_E_INVALIDSTREAMNUMBER;
00372     }
00373
00374     EnterCriticalSection(&m_critSec);
00375     HRESULT hr = S_OK;
00376
00377     // If we have an input sample, the client cannot change the type now.
00378     if (m_pSample != NULL)
00379     {
00380         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00381         goto done;
00382     }
00383
00384     // Validate the type, if non-NULL.
00385     if (pType)
00386     {
00387         hr = OnCheckInputType(pType);
00388         if (FAILED(hr))
00389         {
00390             goto done;
00391         }
00392     }
00393
00394     // The type is OK. Set the type, unless the caller was just testing.
00395     if ( (dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0 )
00396     {
00397         m_pInputType = nullptr;
00398         m_pInputType = pType;
00399
00400         // Update the format information.
00401         UpdateFormatInfo();
00402
00403         // When the type changes, end streaming.
00404         m_bStreamingInitialized = false;
00405     }
00406
00407 done:
00408     LeaveCriticalSection(&m_critSec);
00409     return hr;
00410 }
00411
00412
00413
00414 //-------------------------------------------------------------------
00415 // SetOutputType
00416 //-------------------------------------------------------------------
00417
00418 HRESULT CInvert::SetOutputType(
00419     DWORD           dwOutputStreamID,
00420     IMFMediaType    *pType, // Can be NULL to clear the output type.
00421     DWORD           dwFlags
00422 )
00423 {
00424     // Validate flags.
00425     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00426     {
00427         return E_INVALIDARG;
00428     }
00429
00430     if (dwOutputStreamID != 0)
00431     {
00432         return MF_E_INVALIDSTREAMNUMBER;
00433     }
00434
00435     EnterCriticalSection(&m_critSec);
00436     HRESULT hr = S_OK;
00437
00438     // If we have an input sample, the client cannot change the type now.
00439     if (m_pSample != NULL)
00440     {
00441         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00442         goto done;
00443     }
00444
00445     // Validate the type, if non-NULL.
00446     if (pType)
00447     {
00448         hr = OnCheckOutputType(pType);
00449         if (FAILED(hr))
00450         {
00451             goto done;
00452         }
00453     }
00454
00455     // The type is OK. Set the type, unless the caller was just testing.
00456     if ( (dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0 )
00457     {
00458         m_pOutputType = pType;
00459
00460         // When the type changes, end streaming.
00461         m_bStreamingInitialized = false;
00462     }
00463
00464 done:
00465     LeaveCriticalSection(&m_critSec);
00466     return hr;
00467 }
00468
00469
00470 //-------------------------------------------------------------------
00471 // GetInputCurrentType
00472 // Returns the current input type.
00473 //-------------------------------------------------------------------
00474
00475 HRESULT CInvert::GetInputCurrentType(
00476     DWORD           dwInputStreamID,
00477     IMFMediaType    **ppType
00478 )
00479 {
00480     if (ppType == NULL)
00481     {
00482         return E_POINTER;
00483     }
00484
00485     if (dwInputStreamID != 0)
00486     {
00487         return MF_E_INVALIDSTREAMNUMBER;
00488     }
00489
00490     HRESULT hr = S_OK;
00491     EnterCriticalSection(&m_critSec);
00492
00493     if (!m_pInputType)
00494     {
00495         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00496     }
00497     else
00498     {
00499         *ppType = m_pInputType.Get();
00500         (*ppType)->AddRef();
00501     }
00502
00503     LeaveCriticalSection(&m_critSec);
00504     return hr;
00505 }
00506
00507
00508 //-------------------------------------------------------------------
00509 // GetOutputCurrentType
00510 // Returns the current output type.
00511 //-------------------------------------------------------------------
00512
00513 HRESULT CInvert::GetOutputCurrentType(
00514     DWORD           dwOutputStreamID,
00515     IMFMediaType    **ppType
00516 )
00517 {
00518     if (ppType == NULL)
00519     {
00520         return E_POINTER;
00521     }
00522
00523     if( dwOutputStreamID != 0 )
00524     {
00525         return MF_E_INVALIDSTREAMNUMBER;
00526     }
00527
00528     HRESULT hr = S_OK;
00529     EnterCriticalSection(&m_critSec);
00530
00531     if (!m_pOutputType)
00532     {
00533         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00534     }
00535     else
00536     {
00537         m_pOutputType.CopyTo(ppType);
00538     }
00539
00540     LeaveCriticalSection(&m_critSec);
00541     return hr;
00542 }
00543
00544
00545 //-------------------------------------------------------------------
00546 // GetInputStatus
00547 // Query if the MFT is accepting more input.
00548 //-------------------------------------------------------------------
00549
00550 HRESULT CInvert::GetInputStatus(
00551     DWORD           dwInputStreamID,
00552     DWORD           *pdwFlags
00553 )
00554 {
00555     if (pdwFlags == NULL)
00556     {
00557         return E_POINTER;
00558     }
00559
00560     if (dwInputStreamID != 0)
00561     {
00562         return MF_E_INVALIDSTREAMNUMBER;
00563     }
00564
00565     EnterCriticalSection(&m_critSec);
00566
00567     if (m_pSample == NULL)
00568     {
00569         *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
00570     }
00571     else
00572     {
00573         *pdwFlags = 0;
00574     }
00575
00576     LeaveCriticalSection(&m_critSec);
00577     return S_OK;
00578 }
00579
00580
00581 //-------------------------------------------------------------------
00582 // GetOutputStatus
00583 // Query if the MFT can produce output.
00584 //-------------------------------------------------------------------
00585
00586 HRESULT CInvert::GetOutputStatus(DWORD *pdwFlags)
00587 {
00588     if (pdwFlags == NULL)
00589     {
00590         return E_POINTER;
00591     }
00592
00593     EnterCriticalSection(&m_critSec);
00594
00595     // The MFT can produce an output sample if (and only if) there an input sample.
00596     if (m_pSample != NULL)
00597     {
00598         *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
00599     }
00600     else
00601     {
00602         *pdwFlags = 0;
00603     }
00604
00605     LeaveCriticalSection(&m_critSec);
00606     return S_OK;
00607 }
00608
00609
00610 //-------------------------------------------------------------------
00611 // ProcessMessage
00612 //-------------------------------------------------------------------
00613
00614 HRESULT CInvert::ProcessMessage(
00615     MFT_MESSAGE_TYPE    eMessage,
00616     ULONG_PTR           ulParam
00617 )
00618 {
00619     EnterCriticalSection(&m_critSec);
00620
00621     HRESULT hr = S_OK;
00622     ComPtr<IUnknown> pUnk;
00623     ComPtr<IMFDXGIDeviceManager> pDXGIDeviceManager;
00624
00625     switch (eMessage)
00626     {
00627     case MFT_MESSAGE_COMMAND_FLUSH:
00628         // Flush the MFT.
00629         m_pSample = nullptr;
00630         break;
00631
00632     case MFT_MESSAGE_SET_D3D_MANAGER:
00633         if (ulParam != NULL)
00634         {
00635             pUnk = (IUnknown*)ulParam;
00636             hr = pUnk.As(&pDXGIDeviceManager);
00637
00638             if( SUCCEEDED( hr ) && (m_pDX11Manager != pDXGIDeviceManager) )
00639             {
00640                 InvalidateDX11Resources();
00641                 m_pDX11Manager = nullptr;
00642                 m_pDX11Manager = pDXGIDeviceManager;
00643
00644                 hr = UpdateDX11Device();
00645                 if (FAILED(hr))
00646                 {
00647                     goto done;
00648                 }
00649
00650                 if( m_spOutputSampleAllocator )
00651                 {
00652                     hr = m_spOutputSampleAllocator->SetDirectXManager(pUnk.Get());
00653                     if (FAILED(hr))
00654                     {
00655                         goto done;
00656                     }
00657                 }
00658             }
00659         }
00660         else
00661         {
00662             InvalidateDX11Resources();
00663             m_pDX11Manager = nullptr;
00664         }
00665         break;
00666
00667     case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
00668         hr = BeginStreaming();
00669         break;
00670
00671     case MFT_MESSAGE_NOTIFY_END_STREAMING:
00672         m_bStreamingInitialized = false;
00673         break;
00674
00675     // The remaining messages require no action
00676     case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
00677     case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
00678     case MFT_MESSAGE_COMMAND_DRAIN:
00679         break;
00680     }
00681
00682 done:
00683     LeaveCriticalSection(&m_critSec);
00684     return hr;
00685 }
00686
00687
00688 //-------------------------------------------------------------------
00689 // ProcessInput
00690 // Process an input sample.
00691 //-------------------------------------------------------------------
00692
00693 HRESULT CInvert::ProcessInput(
00694     DWORD               dwInputStreamID,
00695     IMFSample           *pSample,
00696     DWORD               dwFlags
00697 )
00698 {
00699     // Check input parameters.
00700     if (pSample == NULL)
00701     {
00702         return E_POINTER;
00703     }
00704
00705     if (dwFlags != 0)
00706     {
00707         return E_INVALIDARG; // dwFlags is reserved and must be zero.
00708     }
00709
00710     // Validate the input stream number.
00711     if (dwInputStreamID != 0)
00712     {
00713         return MF_E_INVALIDSTREAMNUMBER;
00714     }
00715
00716     HRESULT hr = S_OK;
00717
00718     EnterCriticalSection(&m_critSec);
00719
00720     // Check for valid media types.
00721     // The client must set input and output types before calling ProcessInput.
00722     if (!m_pInputType || !m_pOutputType)
00723     {
00724         hr = MF_E_NOTACCEPTING;
00725         goto done;
00726     }
00727
00728     // Check if an input sample is already queued.
00729     if (m_pSample != NULL)
00730     {
00731         hr = MF_E_NOTACCEPTING;   // We already have an input sample.
00732         goto done;
00733     }
00734
00735     // Initialize streaming.
00736     hr = BeginStreaming();
00737     if (FAILED(hr))
00738     {
00739         goto done;
00740     }
00741
00742     // Cache the sample. We do the actual work in ProcessOutput.
00743     m_pSample = pSample;
00744
00745 done:
00746     LeaveCriticalSection(&m_critSec);
00747     return hr;
00748 }
00749
00750
00751 //-------------------------------------------------------------------
00752 // ProcessOutput
00753 // Process an output sample.
00754 //-------------------------------------------------------------------
00755
00756 HRESULT CInvert::ProcessOutput(
00757     DWORD                   dwFlags,
00758     DWORD                   cOutputBufferCount,
00759     MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
00760     DWORD                   *pdwStatus
00761 )
00762 {
00763     if (dwFlags != 0)
00764     {
00765         return E_INVALIDARG;
00766     }
00767
00768     if (pOutputSamples == NULL || pdwStatus == NULL)
00769     {
00770         return E_POINTER;
00771     }
00772
00773     // There must be exactly one output buffer.
00774     if (cOutputBufferCount != 1)
00775     {
00776         return E_INVALIDARG;
00777     }
00778
00779     // It must contain a sample.
00780     if (pOutputSamples[0].pSample == NULL && m_pDX11Manager == nullptr)
00781     {
00782         return E_INVALIDARG;
00783     }
00784
00785     HRESULT hr = S_OK;
00786     ComPtr<IMFMediaBuffer> pInput;
00787     ComPtr<IMFMediaBuffer> pOutput;
00788     ComPtr<ID3D11Device> spDevice;
00789     ComPtr<IMFMediaBuffer> pMediaBuffer;
00790     bool bDeviceLocked = false;
00791
00792     EnterCriticalSection(&m_critSec);
00793
00794     // There must be an input sample available for processing.
00795     if (m_pSample == nullptr)
00796     {
00797         hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
00798         goto done;
00799     }
00800
00801     // Initialize streaming.
00802     hr = BeginStreaming();
00803     if (FAILED(hr))
00804     {
00805         goto done;
00806     }
00807
00808     // Check that our device is still good
00809     hr = CheckDX11Device();
00810     if (FAILED(hr))
00811     {
00812         goto done;
00813     }
00814
00815     // When using DX we provide the output samples...
00816     if (m_pDX11Manager != nullptr)
00817     {
00818         hr = m_spOutputSampleAllocator->AllocateSample( &(pOutputSamples[0].pSample) );
00819         if (FAILED(hr))
00820         {
00821             goto done;
00822         }
00823     }
00824
00825     if (pOutputSamples[0].pSample == nullptr)
00826     {
00827         hr = E_INVALIDARG;
00828         goto done;
00829     }
00830
00831     // Get the input buffer.
00832     hr = m_pSample->GetBufferByIndex(0, &pInput);
00833     if (FAILED(hr))
00834     {
00835         goto done;
00836     }
00837
00838     // Get the output buffer.
00839     hr = pOutputSamples[0].pSample->GetBufferByIndex(0, &pOutput);
00840     if (FAILED(hr))
00841     {
00842         goto done;
00843     }
00844
00845     // Attempt to lock the device if necessary
00846     if (m_pDX11Manager != nullptr)
00847     {
00848         hr = m_pDX11Manager->LockDevice(m_hDeviceHandle, IID_PPV_ARGS( &spDevice ), TRUE );
00849         if (FAILED(hr))
00850         {
00851             goto done;
00852         }
00853         bDeviceLocked = true;
00854     }
00855
00856     hr = OnProcessOutput(pInput.Get(), pOutput.Get());
00857     if (FAILED(hr))
00858     {
00859         goto done;
00860     }
00861
00862     // Set status flags.
00863     pOutputSamples[0].dwStatus = 0;
00864     *pdwStatus = 0;
00865
00866     // Copy the duration and time stamp from the input sample, if present.
00867     LONGLONG hnsDuration = 0;
00868     LONGLONG hnsTime = 0;
00869
00870     if (SUCCEEDED(m_pSample->GetSampleDuration(&hnsDuration)))
00871     {
00872         hr = pOutputSamples[0].pSample->SetSampleDuration(hnsDuration);
00873         if (FAILED(hr))
00874         {
00875             goto done;
00876         }
00877     }
00878
00879     if (SUCCEEDED(m_pSample->GetSampleTime(&hnsTime)))
00880     {
00881         hr = pOutputSamples[0].pSample->SetSampleTime(hnsTime);
00882     }
00883
00884     // Always set the sample size
00885     hr = pOutputSamples[0].pSample->GetBufferByIndex( 0, &pMediaBuffer );
00886     if (FAILED(hr))
00887     {
00888         goto done;
00889     }
00890
00891     hr = pMediaBuffer->SetCurrentLength(m_cbImageSize);
00892     if (FAILED(hr))
00893     {
00894         goto done;
00895     }
00896
00897 done:
00898     m_pSample = nullptr;
00899
00900     if (bDeviceLocked)
00901     {
00902         hr = m_pDX11Manager->UnlockDevice(m_hDeviceHandle, FALSE);
00903     }
00904
00905     LeaveCriticalSection(&m_critSec);
00906     return hr;
00907 }
00908
00909 // PRIVATE METHODS
00910
00911 HRESULT CInvert::CheckDX11Device()
00912 {
00913     HRESULT hr = S_OK;
00914
00915     if(m_pDX11Manager != nullptr && m_hDeviceHandle )
00916     {
00917         if(m_pDX11Manager->TestDevice(m_hDeviceHandle) != S_OK)
00918         {
00919             InvalidateDX11Resources();
00920
00921             hr = UpdateDX11Device();
00922             if (FAILED(hr))
00923             {
00924                 return hr;
00925             }
00926
00927             return m_pTransform->Initialize(m_pDevice.Get(), m_imageWidthInPixels, m_imageHeightInPixels);
00928         }
00929     }
00930
00931     return S_OK;
00932 }
00933
00934 // Delete any resources dependant on the current device we are using
00935 void CInvert::InvalidateDX11Resources()
00936 {
00937     m_pTransform->Invalidate();
00938     m_pDevice  = nullptr;
00939     m_pContext = nullptr;
00940     m_pInBufferTex = nullptr;
00941     m_pOutBufferTex = nullptr;
00942     m_pOutBufferStage = nullptr;
00943 }
00944
00945 // Update the directx device
00946 HRESULT CInvert::UpdateDX11Device()
00947 {
00948     HRESULT hr = S_OK;
00949
00950     if (m_pDX11Manager != nullptr)
00951     {
00952         hr = m_pDX11Manager->OpenDeviceHandle(&m_hDeviceHandle);
00953         if (FAILED(hr))
00954         {
00955             goto done;
00956         }
00957
00958         hr = m_pDX11Manager->GetVideoService(m_hDeviceHandle, __uuidof(m_pDevice), (void**)&m_pDevice);
00959         if (FAILED(hr))
00960         {
00961             goto done;
00962         }
00963
00964         m_pDevice->GetImmediateContext(&m_pContext);
00965     }
00966     else
00967     {
00968         D3D_FEATURE_LEVEL level;
00969         D3D_FEATURE_LEVEL levelsWanted[] =
00970         {
00971             D3D_FEATURE_LEVEL_11_1,
00972             D3D_FEATURE_LEVEL_11_0,
00973             D3D_FEATURE_LEVEL_10_1,
00974             D3D_FEATURE_LEVEL_10_0,
00975         };
00976         DWORD numLevelsWanted = sizeof( levelsWanted ) / sizeof( levelsWanted[0] );
00977
00978         hr = D3D11CreateDevice( NULL, D3D_DRIVER_TYPE_WARP, NULL, 0 , levelsWanted, numLevelsWanted,
00979                                 D3D11_SDK_VERSION, &m_pDevice, &level, &m_pContext);
00980         if (FAILED(hr))
00981         {
00982             goto done;
00983         }
00984
00985     }
00986
00987
00988     return hr;
00989
00990 done:
00991     InvalidateDX11Resources();
00992     return hr;
00993 }
00994
00995 // Create a partial media type.
00996 HRESULT CInvert::OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt)
00997 {
00998     if (dwTypeIndex > 0)
00999     {
01000         return MF_E_NO_MORE_TYPES;
01001     }
01002
01003     ComPtr<IMFMediaType> pmt;
01004
01005     HRESULT hr = MFCreateMediaType(&pmt);
01006     if (FAILED(hr))
01007     {
01008         goto done;
01009     }
01010
01011     hr = pmt->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
01012     if (FAILED(hr))
01013     {
01014         goto done;
01015     }
01016
01017     hr = pmt->SetGUID(MF_MT_SUBTYPE, MFVideoFormat_ARGB32);
01018     if (FAILED(hr))
01019     {
01020         goto done;
01021     }
01022
01023     pmt.CopyTo(ppmt);
01024
01025 done:
01026     return hr;
01027 }
01028
01029 // Validate an input media type.
01030 HRESULT CInvert::OnCheckInputType(IMFMediaType *pmt)
01031 {
01032     assert(pmt != NULL);
01033
01034     HRESULT hr = S_OK;
01035
01036     // If the output type is set, see if they match.
01037     if (m_pOutputType != NULL)
01038     {
01039         DWORD flags = 0;
01040         hr = pmt->IsEqual(m_pOutputType.Get(), &flags);
01041
01042         // IsEqual can return S_FALSE. Treat this as failure.
01043         if (hr != S_OK)
01044         {
01045             hr = MF_E_INVALIDMEDIATYPE;
01046         }
01047     }
01048     else
01049     {
01050         // Output type is not set. Just check this type.
01051         hr = OnCheckMediaType(pmt);
01052     }
01053     return hr;
01054 }
01055
01056 // Validate an output media type.
01057 HRESULT CInvert::OnCheckOutputType(IMFMediaType *pmt)
01058 {
01059     assert(pmt != NULL);
01060
01061     HRESULT hr = S_OK;
01062
01063     // If the input type is set, see if they match.
01064     if (m_pInputType != NULL)
01065     {
01066         DWORD flags = 0;
01067         hr = pmt->IsEqual(m_pInputType.Get(), &flags);
01068
01069         // IsEqual can return S_FALSE. Treat this as failure.
01070         if (hr != S_OK)
01071         {
01072             hr = MF_E_INVALIDMEDIATYPE;
01073         }
01074     }
01075     else
01076     {
01077         // Input type is not set. Just check this type.
01078         hr = OnCheckMediaType(pmt);
01079     }
01080     return hr;
01081 }
01082
01083 // Validate a media type (input or output)
01084 HRESULT CInvert::OnCheckMediaType(IMFMediaType *pmt)
01085 {
01086     // Major type must be video.
01087     GUID major_type;
01088     HRESULT hr = pmt->GetGUID(MF_MT_MAJOR_TYPE, &major_type);
01089     if (FAILED(hr))
01090     {
01091         goto done;
01092     }
01093
01094     if (major_type != MFMediaType_Video)
01095     {
01096         hr = MF_E_INVALIDMEDIATYPE;
01097         goto done;
01098     }
01099
01100     // Get the subtype GUID.
01101     GUID subtype;
01102     hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
01103     if (FAILED(hr))
01104     {
01105         goto done;
01106     }
01107
01108     if(subtype != MFVideoFormat_ARGB32)
01109     {
01110         hr = MF_E_INVALIDMEDIATYPE;
01111         goto done;
01112     }
01113
01114     // Reject single-field media types.
01115     UINT32 interlace = MFGetAttributeUINT32(pmt, MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
01116     if (interlace == MFVideoInterlace_FieldSingleUpper  || interlace == MFVideoInterlace_FieldSingleLower)
01117     {
01118         hr = MF_E_INVALIDMEDIATYPE;
01119         goto done;
01120     }
01121
01122     // Reject media types without a frame size
01123     UINT width, height;
01124     hr = MFGetAttributeSize(pmt, MF_MT_FRAME_SIZE, &width, &height);
01125     if (FAILED(hr))
01126     {
01127         goto done;
01128     }
01129
01130 done:
01131     return hr;
01132 }
01133
01134 // Initialize streaming parameters.
01135 HRESULT CInvert::BeginStreaming()
01136 {
01137     HRESULT hr = S_OK;
01138
01139     if (!m_bStreamingInitialized)
01140     {
01141         if( m_pDevice == nullptr )
01142         {
01143             hr = UpdateDX11Device();
01144             if (FAILED(hr))
01145             {
01146                 goto done;
01147             }
01148         }
01149
01150         hr = m_pTransform->Initialize(m_pDevice.Get(), m_imageWidthInPixels, m_imageHeightInPixels);
01151         if (FAILED(hr))
01152         {
01153             goto done;
01154         }
01155
01156         // if the device is dxman we need to alloc samples...
01157         if( m_pDX11Manager != nullptr )
01158         {
01159             DWORD dwBindFlags = MFGetAttributeUINT32( m_spOutputAttributes.Get(), MF_SA_D3D11_BINDFLAGS, D3D11_BIND_RENDER_TARGET );
01160             dwBindFlags |= D3D11_BIND_RENDER_TARGET;        // render target binding must always be set
01161             hr = m_spOutputAttributes->SetUINT32( MF_SA_D3D11_BINDFLAGS, dwBindFlags );
01162             if (FAILED(hr))
01163             {
01164                 goto done;
01165             }
01166             hr = m_spOutputAttributes->SetUINT32( MF_SA_BUFFERS_PER_SAMPLE, 1 );
01167             if (FAILED(hr))
01168             {
01169                 goto done;
01170             }
01171             hr = m_spOutputAttributes->SetUINT32( MF_SA_D3D11_USAGE, D3D11_USAGE_DEFAULT );
01172             if (FAILED(hr))
01173             {
01174                 goto done;
01175             }
01176
01177             if ( NULL == m_spOutputSampleAllocator )
01178             {
01179                 ComPtr<IMFVideoSampleAllocatorEx> spVideoSampleAllocator;
01180                 ComPtr<IUnknown> spDXGIManagerUnk;
01181
01182                 hr = MFCreateVideoSampleAllocatorEx( IID_PPV_ARGS( &spVideoSampleAllocator ) );
01183                 if (FAILED(hr))
01184                 {
01185                     goto done;
01186                 }
01187
01188                 hr = m_pDX11Manager.As( &spDXGIManagerUnk );
01189                 if (FAILED(hr))
01190                 {
01191                     goto done;
01192                 }
01193
01194                 hr = spVideoSampleAllocator->SetDirectXManager( spDXGIManagerUnk.Get() );
01195                 if (FAILED(hr))
01196                 {
01197                     goto done;
01198                 }
01199
01200                 m_spOutputSampleAllocator.Attach( spVideoSampleAllocator.Detach() );
01201             }
01202
01203             hr = m_spOutputSampleAllocator->InitializeSampleAllocatorEx( 1, 10, m_spOutputAttributes.Get(), m_pOutputType.Get() );
01204
01205             if ( FAILED(hr) && (dwBindFlags != D3D11_BIND_RENDER_TARGET) )
01206             {
01207                 // Try again with only the mandatory "render target" binding
01208                 hr = m_spOutputAttributes->SetUINT32( MF_SA_D3D11_BINDFLAGS, D3D11_BIND_RENDER_TARGET );
01209                 if (FAILED(hr))
01210                 {
01211                     goto done;
01212                 }
01213                 hr = m_spOutputSampleAllocator->InitializeSampleAllocatorEx( 1, 10, m_spOutputAttributes.Get(), m_pOutputType.Get() );
01214                 if (FAILED(hr))
01215                 {
01216                     goto done;
01217                 }
01218             }
01219         }
01220
01221         m_bStreamingInitialized = true;
01222     }
01223
01224 done:
01225     return hr;
01226 }
01227
01228 // Reads DX buffers from IMFMediaBuffer
01229 HRESULT BufferToDXType(IMFMediaBuffer *pBuffer, _Out_ UINT *uiViewIndex, _Out_ ID3D11Texture2D **ppTexture)
01230 {
01231     HRESULT hr = S_OK;
01232     ComPtr<IMFDXGIBuffer> spDXGIBuffer;
01233
01234     hr = pBuffer->QueryInterface(__uuidof(IMFDXGIBuffer), (LPVOID *)(&spDXGIBuffer));
01235     if (FAILED(hr))
01236     {
01237         goto done;
01238     }
01239
01240     hr = spDXGIBuffer->GetResource(__uuidof(ID3D11Texture2D), (LPVOID *)(ppTexture));
01241     if (FAILED(hr))
01242     {
01243         goto done;
01244     }
01245
01246     hr = spDXGIBuffer->GetSubresourceIndex(uiViewIndex);
01247     if (FAILED(hr))
01248     {
01249         goto done;
01250     }
01251
01252 done:
01253     return hr;
01254 }
01255
01256 // Generate output data.
01257 HRESULT CInvert::OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
01258 {
01259     HRESULT hr = S_OK;
01260     ComPtr<ID3D11Texture2D> pInTex;
01261     ComPtr<ID3D11Texture2D> pOutTex;
01262     BOOL bNativeOut = FALSE, bNativeIn = FALSE;
01263     UINT uiInIndex = 0;
01264     UINT uiOutIndex = 0;
01265
01266     // Attempt to convert directly to DX textures
01267     hr = BufferToDXType(pIn, &uiInIndex, &pInTex);
01268     bNativeIn = SUCCEEDED(hr) && pInTex != nullptr;
01269     hr = BufferToDXType(pOut, &uiOutIndex, &pOutTex);
01270     bNativeOut = SUCCEEDED(hr) && pOutTex != nullptr;
01271
01272     // If the input or output textures' device does not match our device
01273     // we have to move them to our device
01274     if (bNativeIn)
01275     {
01276         ComPtr<ID3D11Device> pDev;
01277         pInTex->GetDevice(&pDev);
01278         if( pDev != m_pDevice )
01279         {
01280             bNativeIn = FALSE;
01281         }
01282     }
01283     if (bNativeOut)
01284     {
01285         ComPtr<ID3D11Device> pDev;
01286         pOutTex->GetDevice(&pDev);
01287         if( pDev != m_pDevice )
01288         {
01289             bNativeOut = FALSE;
01290         }
01291     }
01292
01293
01294     if (!bNativeIn)
01295     {
01296         // Native DX texture in the buffer failed
01297         // create a texture we can use and copy the data in
01298         if (m_pInBufferTex == nullptr)
01299         {
01300             D3D11_TEXTURE2D_DESC desc;
01301             ZeroMemory(&desc,sizeof(desc));
01302             desc.Width = m_imageWidthInPixels;
01303             desc.Height = m_imageHeightInPixels;
01304             desc.ArraySize = 1;
01305             desc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
01306             desc.Usage = D3D11_USAGE_DYNAMIC;
01307             desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
01308             desc.CPUAccessFlags = D3D11_CPU_ACCESS_WRITE;
01309             desc.MipLevels = 1;
01310             desc.SampleDesc.Count = 1;
01311
01312             hr = m_pDevice->CreateTexture2D(&desc, NULL, &m_pInBufferTex);
01313             if (FAILED(hr))
01314             {
01315                 goto done;
01316             }
01317         }
01318
01319         // scope the texture lock
01320         {
01321             TextureLock tlock(m_pContext.Get(), m_pInBufferTex.Get());
01322             hr = tlock.Map(uiInIndex, D3D11_MAP_WRITE_DISCARD, 0);
01323             if (FAILED(hr))
01324             {
01325                 goto done;
01326             }
01327
01328             // scope the video buffer lock
01329             {
01330                 VideoBufferLock lock;
01331                 LONG lStride;
01332
01333                 hr = GetDefaultStride(m_pInputType.Get(), &lStride);
01334                 if (FAILED(hr))
01335                 {
01336                     goto done;
01337                 }
01338
01339                 hr = lock.Lock(pIn, MF2DBuffer_LockFlags_Read, lStride * m_imageHeightInPixels, lStride);
01340                 if (FAILED(hr))
01341                 {
01342                     goto done;
01343                 }
01344
01345                 hr = MFCopyImage((BYTE*)tlock.map.pData, tlock.map.RowPitch, lock.GetData(), lock.GetStride(), abs(lStride), m_imageHeightInPixels);
01346                 if (FAILED(hr))
01347                 {
01348                     goto done;
01349                 }
01350             }
01351         }
01352         pInTex = m_pInBufferTex;
01353     }
01354
01355     if (!bNativeOut)
01356     {
01357         if (m_pOutBufferTex == nullptr)
01358         {
01359             D3D11_TEXTURE2D_DESC desc;
01360             ZeroMemory(&desc,sizeof(desc));
01361             desc.Width = m_imageWidthInPixels;
01362             desc.Height = m_imageHeightInPixels;
01363             desc.ArraySize = 1;
01364             desc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
01365             desc.Usage = D3D11_USAGE_DEFAULT;
01366             desc.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
01367             desc.MipLevels = 1;
01368             desc.SampleDesc.Count = 1;
01369             hr = m_pDevice->CreateTexture2D(&desc, NULL, &m_pOutBufferTex);
01370             if (FAILED(hr))
01371             {
01372                 goto done;
01373             }
01374         }
01375         pOutTex = m_pOutBufferTex;
01376     }
01377
01378     // do some processing
01379     m_pTransform->ProcessFrame(m_pDevice.Get(),pInTex.Get(),uiInIndex,pOutTex.Get(),uiOutIndex);
01380
01381     // write back pOut if necessary
01382     if (!bNativeOut)
01383     {
01384         if (m_pOutBufferStage == nullptr)
01385         {
01386             D3D11_TEXTURE2D_DESC desc;
01387             ZeroMemory(&desc,sizeof(desc));
01388             desc.Width = m_imageWidthInPixels;
01389             desc.Height = m_imageHeightInPixels;
01390             desc.ArraySize = 1;
01391             desc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
01392             desc.Usage = D3D11_USAGE_STAGING;
01393             desc.CPUAccessFlags = D3D11_CPU_ACCESS_READ;
01394             desc.MipLevels = 1;
01395             desc.SampleDesc.Count = 1;
01396             hr = m_pDevice->CreateTexture2D(&desc, NULL, &m_pOutBufferStage);
01397             if (FAILED(hr))
01398             {
01399                 goto done;
01400             }
01401         }
01402
01403         m_pContext->CopyResource(m_pOutBufferStage.Get(), m_pOutBufferTex.Get());
01404
01405         {
01406             TextureLock tlock(m_pContext.Get(), m_pOutBufferStage.Get());
01407             hr = tlock.Map(uiOutIndex, D3D11_MAP_READ, 0);
01408             if (FAILED(hr))
01409             {
01410                 goto done;
01411             }
01412
01413             // scope the video buffer lock
01414             {
01415                 VideoBufferLock lock;
01416                 LONG lStride;
01417
01418                 hr = GetDefaultStride(m_pOutputType.Get(), &lStride);
01419                 if (FAILED(hr))
01420                 {
01421                     goto done;
01422                 }
01423
01424                 hr = lock.Lock(pOut, MF2DBuffer_LockFlags_Write, lStride * m_imageHeightInPixels, lStride);
01425                 if (FAILED(hr))
01426                 {
01427                     goto done;
01428                 }
01429
01430                 hr = MFCopyImage(lock.GetData(), lock.GetStride(), (BYTE*)tlock.map.pData, tlock.map.RowPitch, abs(lStride), m_imageHeightInPixels);
01431                 if (FAILED(hr))
01432                 {
01433                     goto done;
01434                 }
01435             }
01436         }
01437     }
01438
01439 done:
01440     return hr;
01441 }
01442
01443 // Update the format information. This method is called whenever the
01444 // input type is set.
01445 HRESULT CInvert::UpdateFormatInfo()
01446 {
01447     HRESULT hr = S_OK;
01448     LONG lStride = 0;
01449
01450     m_imageWidthInPixels = 0;
01451     m_imageHeightInPixels = 0;
01452     m_cbImageSize = 0;
01453
01454     if (m_pInputType != NULL)
01455     {
01456         hr = MFGetAttributeSize(m_pInputType.Get(), MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);
01457         if (FAILED(hr))
01458         {
01459             goto done;
01460         }
01461
01462         hr = GetDefaultStride(m_pInputType.Get(), &lStride);
01463         if (FAILED(hr))
01464         {
01465             goto done;
01466         }
01467
01468         // Calculate the image size
01469         m_cbImageSize = abs(lStride) * 4 * m_imageHeightInPixels;
01470     }
01471
01472 done:
01473     return hr;
01474 }
01475
01476 // Get the default stride for a video format.
01477 HRESULT GetDefaultStride(IMFMediaType *pType, LONG *plStride)
01478 {
01479     LONG lStride = 0;
01480
01481     // Try to get the default stride from the media type.
01482     HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
01483     if (FAILED(hr))
01484     {
01485         // Attribute not set. Try to calculate the default stride.
01486         GUID subtype = GUID_NULL;
01487
01488         UINT32 width = 0;
01489         UINT32 height = 0;
01490
01491         // Get the subtype and the image size.
01492         hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
01493         if (SUCCEEDED(hr))
01494         {
01495             hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
01496         }
01497         if (SUCCEEDED(hr))
01498         {
01499             lStride = width * 4;
01500         }
01501
01502         // Set the attribute for later reference.
01503         if (SUCCEEDED(hr))
01504         {
01505             (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
01506         }
01507     }
01508     if (SUCCEEDED(hr))
01509     {
01510         *plStride = lStride;
01511     }
01512     return hr;
01513 }
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario3.xaml.h Source File

  • XAML WebView control

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace WebViewControl
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario3 sealed
00031         {
00032         public:
00033             Scenario3();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         void Load_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         void Script_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042       };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/PageModel.cpp Source File

  • Direct2D magazine app

PageModel.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Magazine;
00011 using namespace Windows::UI::Xaml::Data;
00012 using namespace Windows::UI::Xaml::Interop;
00013
00014 PageModel::PageModel(
00015     _In_ Element^ content,
00016     _In_ Document^ document
00017     )
00018 {
00019     // Get the first <layer> element of the <page> element. At least two layers are required
00020     // to complete a page view. One for the page content and another for background.
00021
00022     Element^ child = content->GetFirstChild();
00023
00024     if (child != nullptr)
00025     {
00026         // Background image is opaque. By passing true as the last parameter, the virtual
00027         // surface image source can optimize for rendering performance accordingly.
00028         m_background = new ContentImageSource(child, document, true);
00029         child = child->GetNextSibling();
00030     }
00031
00032     if (child != nullptr)
00033     {
00034         m_content = new ContentImageSource(child, document, false);
00035     }
00036 }
00037
00038 void PageModel::UpdateContent(_In_ Element^ content)
00039 {
00040     Element^ child = content->GetFirstChild();
00041
00042     if (child != nullptr)
00043     {
00044         m_background->UpdateContent(child);
00045
00046         PropertyChanged(this, ref new PropertyChangedEventArgs("Background"));
00047
00048         child = child->GetNextSibling();
00049     }
00050
00051     if (child != nullptr)
00052     {
00053         // Top-level content is always resized to fit with the current window size.
00054         m_content->UpdateContent(child);
00055
00056         PropertyChanged(this, ref new PropertyChangedEventArgs("Content"));
00057         PropertyChanged(this, ref new PropertyChangedEventArgs("ContentWidth"));
00058         PropertyChanged(this, ref new PropertyChangedEventArgs("ContentHeight"));
00059     }
00060 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/videoview.cpp Source File

  • Media engine native C++ video playback

videoview.cpp

Go to the documentation of this file.
00001 #include "pch.h"
00002 #include "VideoView.h"
00003
00004 using namespace Windows::ApplicationModel;
00005 using namespace Windows::ApplicationModel::Activation;
00006 using namespace Windows::UI::Core;
00007 using namespace Windows::System;
00008 using namespace Windows::Foundation;
00009 using namespace Windows::Foundation::Collections;
00010 using namespace Windows::UI::Input;
00011 using namespace Windows::Storage;
00012
00013 VideoView::VideoView()
00014 {
00015 }
00016
00017 void VideoView::Initialize(
00018     _In_ Platform::Agile<CoreWindow> window,
00019     _In_ Platform::Agile<Windows::ApplicationModel::Core::CoreApplicationView> applicationView
00020     )
00021 {
00022     m_window = window;
00023     m_applicationView = applicationView;
00024
00025     // Specify the cursor type as the standard arrow cursor.
00026     m_window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00027
00028     m_window->SizeChanged +=
00029     ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &VideoView::OnWindowSizeChanged);
00030
00031     m_window->PointerPressed +=
00032     ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &VideoView::OnPointerPressed);
00033
00034     m_window->KeyDown +=
00035     ref new TypedEventHandler<CoreWindow^, KeyEventArgs^>(this, &VideoView::OnKeyPressed);
00036
00037     Windows::ApplicationModel::Core::CoreApplication::Resuming +=
00038   ref new EventHandler<Platform::Object^>(this, &VideoView::OnResuming);
00039
00040     Windows::ApplicationModel::Core::CoreApplication::Suspending +=
00041     ref new EventHandler<SuspendingEventArgs^>(this, &VideoView::OnSuspending);
00042
00043     m_player = ref new MEPlayer();
00044   m_player->Initialize(m_window.Get());
00045
00046 }
00047
00048 void VideoView::Run()
00049 {
00050     // Activate the application window, making it visible and enabling it to receive events.
00051     m_window->Activate();
00052
00053     // Open the media file using File Picker
00054     m_player->OpenFile();
00055
00056     while (!m_player->ExitApp())
00057     {
00058         //Because of the CPU overhead involved in the video renderering we will only use
00059         //ProcessOneAndAllPending for events because it will throttle back the render loop to
00060         //only execute when an event occurs.
00061         m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00062     }
00063 }
00064
00065 void VideoView::OnWindowSizeChanged(
00066     _In_ Windows::UI::Core::CoreWindow^ sender,
00067     _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00068     )
00069 {
00070     m_player->UpdateForWindowSizeChange();
00071 }
00072
00073 void VideoView::OnPointerPressed(
00074     _In_ Windows::UI::Core::CoreWindow^ sender,
00075     _In_ Windows::UI::Core::PointerEventArgs^ args
00076     )
00077 {
00078     Windows::UI::Input::PointerPoint^ pPoint = args->CurrentPoint;
00079
00080     if(pPoint)
00081     {
00082         Windows::UI::Input::PointerPointProperties^ pPointProperties = pPoint->Properties;
00083
00084         if(pPointProperties)
00085         {
00086             bool fMiddleButtonPressed = pPointProperties->IsMiddleButtonPressed;
00087             bool fRightButtonPressed = pPointProperties->IsRightButtonPressed;
00088
00089             if(fMiddleButtonPressed)
00090             {
00091                 if(m_player->IsPlaying())
00092                 {
00093                     m_player->Pause();
00094                 }
00095                 else
00096                 {
00097                     m_player->Play();
00098                 }
00099             }
00100             else if(fRightButtonPressed)
00101             {
00102                 m_player->OpenFile();
00103             }
00104         }
00105     }
00106 }
00107
00108 void VideoView::OnKeyPressed(
00109     _In_ Windows::UI::Core::CoreWindow^ sender,
00110     _In_ Windows::UI::Core::KeyEventArgs^ args
00111     )
00112 {
00113     Windows::System::VirtualKey vKey = args->VirtualKey;
00114
00115     if(VirtualKey::Space == vKey)
00116     {
00117         if(m_player->IsPlaying())
00118         {
00119             m_player->Pause();
00120         }
00121         else
00122         {
00123             m_player->Play();
00124         }
00125     }
00126     else if(VirtualKey::V == vKey)
00127     {
00128         m_player->EnableVideoEffect(TRUE);
00129     }
00130     else if(VirtualKey::O == vKey)
00131     {
00132         m_player->OpenFile();
00133     }
00134   else if(VirtualKey::L == vKey)
00135     {
00136         m_player->Loop();
00137     }
00138 }
00139
00140 void VideoView::OnResuming(
00141     _In_ Platform::Object^ sender,
00142     _In_ Platform::Object^ args
00143     )
00144 {
00145     // When this application is suspended, it stores the drawing state.
00146     // This code attempts to restore the saved state.
00147     IPropertySet^ set = ApplicationData::Current->LocalSettings->Values;
00148     // an int called StereoExaggerationFactor is used as a key
00149     if (set->HasKey("MEPlaybackState"))
00150     {
00151         BOOL bMEPlaybackState = (safe_cast<IPropertyValue^>(set->Lookup("MEPlaybackState")))->GetInt32();
00152
00153         if(bMEPlaybackState)
00154         {
00155             m_player->Play();
00156         }
00157     }
00158     else
00159     {
00160         MEDIA::ThrowIfFailed(E_UNEXPECTED);
00161     }
00162 }
00163
00164 void VideoView::OnSuspending(
00165     _In_ Platform::Object^ sender,
00166     _In_ SuspendingEventArgs^ args
00167     )
00168 {
00169     // Save application state.
00170     // If your application needs time to complete a lengthy operation, it can request a deferral.
00171     // The SuspendingOperation has a deadline time. Make sure all your operations are complete by that time!
00172     // If the app doesn't return from this handler within five seconds, it will be terminated.
00173     SuspendingOperation^ op = args->SuspendingOperation;
00174     SuspendingDeferral^ deferral = op->GetDeferral();
00175
00176     // This is also a good time to save your application's state in case the process gets terminated.
00177     // That way, when the user relaunches the application, they will return to the position they left.
00178     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00179     if (settingsValues->HasKey("MEPlaybackState"))
00180     {
00181         settingsValues->Remove("MEPlaybackState");
00182     }
00183
00184     BOOL bMEPlaybackState = m_player->IsPlaying();
00185     settingsValues->Insert("MEPlaybackState", PropertyValue::CreateInt32(bMEPlaybackState));
00186
00187     if(bMEPlaybackState)
00188     {
00189         m_player->Pause();
00190     }
00191
00192     deferral->Complete();
00193 }
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/DirectXSample.h Source File

  • Direct2D command list

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

BasicSprites::InstancingVertex Member List

This is the complete list of members for BasicSprites::InstancingVertex, including all inherited members.
pos | BasicSprites::InstancingVertex
tex | BasicSprites::InstancingVertex
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKTemplate::App Member List

This is the complete list of members for SDKTemplate::App, including all inherited members.
App() | SDKTemplate::App | [inline]
App() | SDKTemplate::App | [inline]
App() | SDKTemplate::App | [inline]
App() | SDKTemplate::App | [inline]
App() | SDKTemplate::App | [inline]
LaunchArgs | SDKTemplate::App |
OnActivated(IActivatedEventArgs args) | SDKTemplate::App | [inline, protected]
OnLaunched(LaunchActivatedEventArgs args) | SDKTemplate::App | [inline, protected]
OnLaunched(LaunchActivatedEventArgs args) | SDKTemplate::App | [inline, protected]
OnLaunched(LaunchActivatedEventArgs args) | SDKTemplate::App | [inline, protected]
OnLaunched(LaunchActivatedEventArgs args) | SDKTemplate::App | [inline, protected]
OnLaunched(LaunchActivatedEventArgs args) | SDKTemplate::App | [inline, protected]
OnSuspending(object sender, SuspendingEventArgs args) | SDKTemplate::App | [inline, private]
OnSuspending(object sender, SuspendingEventArgs args) | SDKTemplate::App | [inline, private]
OnSuspending(object sender, SuspendingEventArgs args) | SDKTemplate::App | [inline, private]
OnSuspending(object sender, SuspendingEventArgs args) | SDKTemplate::App | [inline, private]
OnSuspending(object sender, SuspendingEventArgs args) | SDKTemplate::App | [inline, private]
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaCapture::AudioCapture Member List

This is the complete list of members for MediaCapture::AudioCapture, including all inherited members.
__pad0__ | Element |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Page | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
AUDIO_FILE_NAME | MediaCapture::AudioCapture | [private]
AudioCapture() | MediaCapture::AudioCapture | [inline]
BindResource(_In_ Element^rootElement) | Element | [virtual]
btnStartDevice_Click(Object sender, Windows.UI.Xaml.RoutedEventArgs e) | MediaCapture::AudioCapture | [inline, private]
btnStartStopRecord_Click(Object sender, Windows.UI.Xaml.RoutedEventArgs e) | MediaCapture::AudioCapture | [inline, private]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
DefaultViewModel | SDKTemplate::Common::LayoutAwarePage | [protected]
DefaultViewModelProperty | SDKTemplate::Common::LayoutAwarePage | [static]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
EnableButton(bool enabled, String name) | MediaCapture::AudioCapture | [inline, private]
Failed(Windows.Media.Capture.MediaCapture currentCaptureObject, MediaCaptureFailedEventArgs currentFailure) | MediaCapture::AudioCapture | [inline]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
m_bRecording | MediaCapture::AudioCapture | [private]
m_bSuspended | MediaCapture::AudioCapture | [private]
m_mediaCaptureMgr | MediaCapture::AudioCapture | [private]
m_recordStorageFile | MediaCapture::AudioCapture | [private]
m_soundLevelHandler | MediaCapture::AudioCapture | [private]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
MediaControl_SoundLevelChanged(object sender, Object e) | MediaCapture::AudioCapture | [inline, private]
OnNavigatedFrom(NavigationEventArgs e) | MediaCapture::AudioCapture | [inline, protected]
OnNavigatedTo(NavigationEventArgs e) | MediaCapture::AudioCapture | [inline, protected]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
RecordLimitationExceeded(Windows.Media.Capture.MediaCapture currentCaptureObject) | MediaCapture::AudioCapture | [inline]
ReleaseParent() | Element | [virtual]
rootPage | MediaCapture::AudioCapture | [private]
ScenarioInit() | MediaCapture::AudioCapture | [inline, private]
ScenarioReset() | MediaCapture::AudioCapture | [inline, private]
ShowExceptionMessage(Exception ex) | MediaCapture::AudioCapture | [inline, private]
ShowStatusMessage(String text) | MediaCapture::AudioCapture | [inline, private]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
SwitchRecordButtonContent() | MediaCapture::AudioCapture | [inline, private]
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/Constants.h Source File

  • App tiles and badges
  • C#,C++

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Tiles C++");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042     internal:
00043         bool EnsureUnsnapped();
00044
00045     private:
00046         static Platform::Array<Scenario>^ scenariosInner;
00047     };
00048 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Files.xaml.cpp Source File

  • Application data

Files.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Files.xaml.cpp
00013 // Implementation of the Files class
00014 //
00015
00016 #include "pch.h"
00017 #include "Files.xaml.h"
00018
00019 using namespace SDKSample::ApplicationDataSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::Storage;
00027 using namespace concurrency;
00028
00029 #define filename "sampleFile.txt"
00030
00031 Files::Files()
00032 {
00033     InitializeComponent();
00034
00035     roamingFolder = ApplicationData::Current->RoamingFolder;
00036     counter = 0;
00037
00038     DisplayOutput();
00039 }
00040
00041 /// <summary>
00042 /// Invoked when this page is about to be displayed in a Frame.
00043 /// </summary>
00044 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00045 /// property is typically used to configure the page.</param>
00046 void Files::OnNavigatedTo(NavigationEventArgs^ e)
00047 {
00048     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00049     // as NotifyUser()
00050     rootPage = MainPage::Current;
00051 }
00052
00053 // Guidance for Local, Roaming, and Temporary files.
00054 //
00055 // Files are ideal for storing large data-sets, databases, or data that is
00056 // in a common file-format.
00057 //
00058 // Files can exist in either the Local, Roaming, or Temporary folders.
00059 //
00060 // Roaming files will be synchronized across machines on which the user has
00061 // singed in with a connected account.  Roaming of files is not instant; the
00062 // system weighs several factors when determining when to send the data.  Usage
00063 // of roaming data should be kept below the quota (available via the
00064 // RoamingStorageQuota property), or else roaming of data will be suspended.
00065 // Files cannot be roamed while an application is writing to them, so be sure
00066 // to close your application's file objects when they are no longer needed.
00067 //
00068 // Local files are not synchronized and remain on the machine on which they
00069 // were originally written.
00070 //
00071 // Temporary files are subject to deletion when not in use.  The system
00072 // considers factors such as available disk capacity and the age of a file when
00073 // determining when or whether to delete a temporary file.
00074
00075 // This sample illustrates reading and writing a file in the Roaming folder, though a
00076 // Local or Temporary file could be used just as easily.
00077
00078 void Files::Increment_Click(Object^ sender, RoutedEventArgs^ e)
00079 {
00080     counter++;
00081
00082     create_task(roamingFolder->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then(
00083         [this](StorageFile^ file)
00084     {
00085         return FileIO::WriteTextAsync(file, counter.ToString());
00086     }).then([this](task<void> previousTask)
00087     {
00088         try
00089         {
00090             previousTask.get();
00091         }
00092         catch (Platform::Exception^)
00093         {
00094         }
00095         DisplayOutput();
00096     });
00097 }
00098
00099 void Files::ReadCounter()
00100 {
00101     create_task(roamingFolder->GetFileAsync(filename)).then([this](StorageFile^ file)
00102     {
00103         return FileIO::ReadTextAsync(file);
00104     }).then([this](task<String^> previousTask)
00105     {
00106         try
00107         {
00108             String^ text = previousTask.get();
00109
00110             OutputTextBlock->Text = "Counter: " + text;
00111
00112             counter = _wtoi(text->Data());
00113         }
00114         catch (...)
00115         {
00116             OutputTextBlock->Text = "Counter: <not found>";
00117         }
00118     });
00119 }
00120
00121 void Files::DisplayOutput()
00122 {
00123     ReadCounter();
00124 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario6.xaml.h Source File

  • XAML text editing

Scenario6.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.h
00013 // Declaration of the Scenario6 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario6.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Platform;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Text ;
00025 using namespace std ;
00026
00027 namespace SDKSample
00028 {
00029     namespace TextEditing
00030     {
00031         /// <summary>
00032         /// An empty page that can be used on its own or navigated to within a Frame.
00033         /// </summary>
00034       [Windows::Foundation::Metadata::WebHostHidden]
00035         public ref class Scenario6 sealed
00036         {
00037         public:
00038             Scenario6();
00039
00040         protected:
00041             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00042
00043         private:
00044         // button click handlers
00045         void BoldButtonClick(Object^ sender, RoutedEventArgs^ e) ;
00046         void ItalicButtonClick(Object^ sender, RoutedEventArgs^ e);
00047         void FontColorButtonClick(Object^ sender, RoutedEventArgs^ e);
00048         void ColorButtonClick(Object^ sender, RoutedEventArgs^ e);
00049
00050         // focus change handlers
00051         void FontColorButtonLostFocus(Object^ sender, RoutedEventArgs^ e);
00052         void FindBoxLostFocus(Object^ sender, RoutedEventArgs^ e);
00053         void FindBoxGotFocus(Object^ sender, RoutedEventArgs^ e);
00054
00055         // text changed handlers
00056         void FindBoxTextChanged(Object^ sender, Windows::UI::Xaml::Controls::TextChangedEventArgs^ e);
00057
00058         // helper functions
00059         void ClearAllHighlightedWords() ;
00060         void FindAndHighlightText(String^ textToFind) ;
00061         void LoadContentAsync();
00062
00063             MainPage^ rootPage;
00064         vector<ITextRange^> m_highlightedWords ;
00065             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00066             void Other_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00067         };
00068     }
00069 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario4.xaml.h Source File

  • Search contract

Scenario4.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace SearchContract
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario4 sealed
00031         {
00032         public:
00033             Scenario4();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038             void SetLocalContentSuggestions(bool isLocal);
00039
00040         private:
00041             Windows::Foundation::EventRegistrationToken token;
00042         };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/PersistentState.h Source File

  • XAML DirectX 3D shooting game

PersistentState.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple helper class that provides support for saving and loading various
00011 // data types to an IPropertySet. Used by DirectX SDK samples to implement
00012 // process lifetime management (PLM).
00013 ref class PersistentState
00014 {
00015 internal:
00016     void Initialize(
00017         _In_ Windows::Foundation::Collections::IPropertySet^ settingsValues,
00018         _In_ Platform::String^ key
00019         );
00020
00021     void SaveBool(Platform::String^ key, bool value);
00022     void SaveInt32(Platform::String^ key, int value);
00023     void SaveSingle(Platform::String^ key, float value);
00024     void SaveXMFLOAT3(Platform::String^ key, DirectX::XMFLOAT3 value);
00025     void SaveString(Platform::String^ key, Platform::String^ string);
00026
00027     bool LoadBool(Platform::String^ key, bool defaultValue);
00028     int  LoadInt32(Platform::String^ key, int defaultValue);
00029     float LoadSingle(Platform::String^ key, float defaultValue);
00030     DirectX::XMFLOAT3 LoadXMFLOAT3(Platform::String^ key, DirectX::XMFLOAT3 defaultValue);
00031     Platform::String^ LoadString(Platform::String^ key, Platform::String^ defaultValue);
00032
00033 private:
00034     Platform::String^ m_keyName;
00035     Windows::Foundation::Collections::IPropertySet^ m_settingsValues;
00036 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/BasicUserControl.xaml.cpp Source File

  • XAML user and custom controls

BasicUserControl.xaml.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // BasicUserControl.xaml.cpp
00003 // Implementation of the BasicUserControl class
00004 //
00005
00006 #include "pch.h"
00007 #include "BasicUserControl.xaml.h"
00008
00009 using namespace SDKSample::UserAndCustomControls;
00010
00011 using namespace Platform;
00012 using namespace Windows::Foundation;
00013 using namespace Windows::Foundation::Collections;
00014 using namespace Windows::UI::Xaml;
00015 using namespace Windows::UI::Xaml::Controls;
00016 using namespace Windows::UI::Xaml::Controls::Primitives;
00017 using namespace Windows::UI::Xaml::Data;
00018 using namespace Windows::UI::Xaml::Input;
00019 using namespace Windows::UI::Xaml::Media;
00020 using namespace Windows::UI::Xaml::Navigation;
00021
00022 // The User Control item template is documented at http://go.microsoft.com/fwlink/?LinkId=234236
00023
00024 BasicUserControl::BasicUserControl()
00025 {
00026   InitializeComponent();
00027 }
00028
00029
00030 void SDKSample::UserAndCustomControls::BasicUserControl::ClickMeButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00031 {
00032   OutputText->Text = "Hello " + NameInput->Text;
00033 }
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/common/LayoutAwarePage.cpp Source File

  • CryptoWinRT
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Msappdata.xaml.h Source File

  • Application data

Msappdata.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Msappdata.xaml.h
00013 // Declaration of the Msappdata class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Msappdata.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ApplicationDataSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Msappdata sealed
00031         {
00032         public:
00033             Msappdata();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00038
00039         private:
00040             Concurrency::task<void> CopyFile(Windows::Foundation::Uri^ sourceUri, Windows::Storage::StorageFolder^ destFolder, Platform::String^ destFilename);
00041             MainPage^ rootPage;
00042         };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/CylinderMesh.h Source File

  • DirectX 3D shooting game

CylinderMesh.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // CylinderMesh:
00011 // This class derives from MeshObject and creates a ID3D11Buffer of
00012 // vertices and indices to represent a canonical cylinder (capped at
00013 // both ends) that is positioned at the origin with a radius of 1.0,
00014 // a height of 1.0 and with its axis in the +Z direction.
00015
00016 #include "MeshObject.h"
00017
00018 ref class CylinderMesh: public MeshObject
00019 {
00020 internal:
00021     CylinderMesh(_In_ ID3D11Device *device, uint32 segments);
00022 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/MediaStreamer.cpp Source File

  • DirectX marble maze game

MediaStreamer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXSample.h"
00010 #include "MediaStreamer.h"
00011
00012 MediaStreamer::MediaStreamer()
00013 {
00014     m_reader = nullptr;
00015     m_audioType = nullptr;
00016     ZeroMemory(&m_waveFormat, sizeof(m_waveFormat));
00017 }
00018
00019 MediaStreamer::~MediaStreamer()
00020 {
00021 }
00022
00023 void MediaStreamer::Initialize(_In_ const WCHAR* url)
00024 {
00025     Microsoft::WRL::ComPtr<IMFMediaType> outputMediaType;
00026     Microsoft::WRL::ComPtr<IMFMediaType> mediaType;
00027
00028     DX::ThrowIfFailed(
00029         MFStartup(MF_VERSION)
00030         );
00031
00032     DX::ThrowIfFailed(
00033         MFCreateSourceReaderFromURL(url, nullptr, &m_reader)
00034         );
00035
00036     // Set the decoded output format as PCM.
00037     // XAudio2 on Windows can process PCM and ADPCM-encoded buffers.
00038     // When this sample uses Media Foundation, it always decodes into PCM.
00039
00040     DX::ThrowIfFailed(
00041         MFCreateMediaType(&mediaType)
00042         );
00043
00044     DX::ThrowIfFailed(
00045         mediaType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Audio)
00046         );
00047
00048     DX::ThrowIfFailed(
00049         mediaType->SetGUID(MF_MT_SUBTYPE, MFAudioFormat_PCM)
00050         );
00051
00052     DX::ThrowIfFailed(
00053         m_reader->SetCurrentMediaType(MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, mediaType.Get())
00054         );
00055
00056     // Get the complete WAVEFORMAT from the Media Type.
00057     DX::ThrowIfFailed(
00058         m_reader->GetCurrentMediaType(MF_SOURCE_READER_FIRST_AUDIO_STREAM, &outputMediaType)
00059         );
00060
00061     uint32 formatSize = 0;
00062     WAVEFORMATEX* waveFormat;
00063     DX::ThrowIfFailed(
00064         MFCreateWaveFormatExFromMFMediaType(outputMediaType.Get(), &waveFormat, &formatSize)
00065         );
00066     CopyMemory(&m_waveFormat, waveFormat, sizeof(m_waveFormat));
00067     CoTaskMemFree(waveFormat);
00068
00069     // Get the total length of the stream, in bytes.
00070     PROPVARIANT var;
00071     DX::ThrowIfFailed(
00072         m_reader->GetPresentationAttribute(MF_SOURCE_READER_MEDIASOURCE, MF_PD_DURATION, &var)
00073         );
00074
00075     // duration is in 100ns units; convert to seconds, and round up
00076     // to the nearest whole byte.
00077     ULONGLONG duration = var.uhVal.QuadPart;
00078     m_maxStreamLengthInBytes =
00079         static_cast<unsigned int>(
00080             ((duration * static_cast<ULONGLONG>(m_waveFormat.nAvgBytesPerSec)) + 10000000) /
00081             10000000
00082             );
00083 }
00084
00085 bool MediaStreamer::GetNextBuffer(uint8* buffer, uint32 maxBufferSize, uint32* bufferLength)
00086 {
00087     Microsoft::WRL::ComPtr<IMFSample> sample;
00088     Microsoft::WRL::ComPtr<IMFMediaBuffer> mediaBuffer;
00089     BYTE *audioData = nullptr;
00090     DWORD sampleBufferLength = 0;
00091     DWORD flags = 0;
00092
00093     *bufferLength = 0;
00094
00095     if (m_reader == nullptr)
00096     {
00097         return false;
00098     }
00099
00100     DX::ThrowIfFailed(
00101         m_reader->ReadSample(MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, nullptr, &flags, nullptr, &sample)
00102         );
00103
00104     if (sample == nullptr)
00105     {
00106         if (flags & MF_SOURCE_READERF_ENDOFSTREAM)
00107         {
00108             return true;
00109         }
00110         else
00111         {
00112             return false;
00113         }
00114     }
00115
00116     DX::ThrowIfFailed(
00117         sample->ConvertToContiguousBuffer(&mediaBuffer)
00118         );
00119
00120     DX::ThrowIfFailed(
00121         mediaBuffer->Lock(&audioData, nullptr, &sampleBufferLength)
00122         );
00123
00124     // Only copy the sample if the remaining buffer is large enough.
00125     if (sampleBufferLength <= maxBufferSize)
00126     {
00127         CopyMemory(buffer, audioData, sampleBufferLength);
00128         *bufferLength = sampleBufferLength;
00129     }
00130
00131     if (flags & MF_SOURCE_READERF_ENDOFSTREAM)
00132     {
00133         return true;
00134     }
00135     else
00136     {
00137         return false;
00138     }
00139 }
00140
00141 void MediaStreamer::ReadAll(uint8* buffer, uint32 maxBufferSize, uint32* bufferLength)
00142 {
00143     uint32 valuesWritten = 0;
00144     uint32 sampleBufferLength = 0;
00145
00146     if (m_reader == nullptr)
00147     {
00148         return;
00149     }
00150
00151     *bufferLength = 0;
00152     // If buffer isn't large enough, return
00153     if (maxBufferSize < m_maxStreamLengthInBytes)
00154     {
00155         return;
00156     }
00157
00158     while (!GetNextBuffer(buffer + valuesWritten, maxBufferSize - valuesWritten, &sampleBufferLength))
00159     {
00160         valuesWritten += sampleBufferLength;
00161     }
00162
00163     *bufferLength = valuesWritten + sampleBufferLength;
00164 }
00165
00166 void MediaStreamer::Restart()
00167 {
00168     if (m_reader == nullptr)
00169     {
00170         return;
00171     }
00172
00173     PROPVARIANT var = {0};
00174     var.vt = VT_I8;
00175
00176     DX::ThrowIfFailed(
00177         m_reader->SetCurrentPosition(GUID_NULL, var)
00178         );
00179 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/common/LayoutAwarePage.h Source File

  • Real-time communication
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include "pch.h"
00014 #include <collection.h>
00015
00016 namespace SimpleCommunication
00017 {
00018     namespace Common
00019     {
00020         /// <summary>
00021         /// Typical implementation of Page that provides several important conveniences: application
00022         /// view state to visual state mapping, GoBack and GoHome event handlers, and a default view
00023         /// model.
00024         /// </summary>
00025         [Windows::Foundation::Metadata::WebHostHidden]
00026         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00027         {
00028         internal:
00029             LayoutAwarePage();
00030
00031         public:
00032             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00033             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00034             void InvalidateVisualState();
00035             property bool UseFilledStateForNarrowWindow
00036             {
00037                 bool get();
00038                 void set(bool value);
00039             }
00040             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ DefaultViewModel
00041             {
00042                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ get();
00043             }
00044
00045         protected:
00046             virtual void GoHome(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             virtual void GoBack(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00049
00050         private:
00051             bool _useFilledStateForNarrowWindow;
00052             Platform::Collections::Map<Platform::String^, Object^>^ _defaultViewModel;
00053             Windows::Foundation::EventRegistrationToken _windowSizeEventToken;
00054             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00055             void WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00056         };
00057     }
00058 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DirectXApp.cpp Source File

  • Direct3D post-processing effects

DirectXApp.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXApp.h"
00010 #include "BasicTimer.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Graphics::Display;
00019
00020 DirectXApp::DirectXApp() :
00021     m_windowClosed(false),
00022     m_windowVisible(true)
00023 {
00024 }
00025
00026 void DirectXApp::Initialize(
00027     _In_ CoreApplicationView^ applicationView
00028     )
00029 {
00030     applicationView->Activated +=
00031         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DirectXApp::OnActivated);
00032
00033     m_renderer = ref new D3DPostProcessing();
00034 }
00035
00036 void DirectXApp::SetWindow(
00037     _In_ CoreWindow^ window
00038     )
00039 {
00040     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00041
00042     window->SizeChanged +=
00043         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DirectXApp::OnWindowSizeChanged);
00044
00045     window->VisibilityChanged +=
00046         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &DirectXApp::OnVisibilityChanged);
00047
00048     window->Closed +=
00049         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &DirectXApp::OnWindowClosed);
00050
00051     DisplayProperties::LogicalDpiChanged +=
00052         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnLogicalDpiChanged);
00053
00054     m_renderer->Initialize(window, DisplayProperties::LogicalDpi);
00055 }
00056
00057 void DirectXApp::Load(
00058     _In_ Platform::String^ entryPoint
00059     )
00060 {
00061 }
00062
00063 void DirectXApp::Run()
00064 {
00065     BasicTimer^ timer = ref new BasicTimer();
00066
00067     while (!m_windowClosed)
00068     {
00069         if (m_windowVisible)
00070         {
00071             timer->Update();
00072             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00073             m_renderer->Update(timer->Total, timer->Delta);
00074             m_renderer->Render();
00075             m_renderer->Present(); // This call is synchronized to the display frame rate.
00076         }
00077         else
00078         {
00079             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00080         }
00081     }
00082 }
00083
00084 void DirectXApp::Uninitialize()
00085 {
00086 }
00087
00088 void DirectXApp::OnWindowSizeChanged(
00089     _In_ CoreWindow^ sender,
00090     _In_ WindowSizeChangedEventArgs^ args
00091     )
00092 {
00093     m_renderer->UpdateForWindowSizeChange();
00094 }
00095
00096 void DirectXApp::OnVisibilityChanged(
00097     _In_ CoreWindow^ sender,
00098     _In_ VisibilityChangedEventArgs^ args
00099     )
00100 {
00101     m_windowVisible = args->Visible;
00102 }
00103
00104 void DirectXApp::OnWindowClosed(
00105     _In_ CoreWindow^ sender,
00106     _In_ CoreWindowEventArgs^ args
00107     )
00108 {
00109     m_windowClosed = true;
00110 }
00111
00112 void DirectXApp::OnLogicalDpiChanged(
00113     _In_ Platform::Object^ sender
00114     )
00115 {
00116     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00117 }
00118
00119 void DirectXApp::OnActivated(
00120     _In_ CoreApplicationView^ applicationView,
00121     _In_ IActivatedEventArgs^ args
00122     )
00123 {
00124     CoreWindow::GetForCurrentThread()->Activate();
00125 }
00126
00127 IFrameworkView^ DirectXAppSource::CreateView()
00128 {
00129     return ref new DirectXApp();
00130 }
00131
00132 [Platform::MTAThread]
00133 int main(Platform::Array<Platform::String^>^)
00134 {
00135     auto directXAppSource = ref new DirectXAppSource();
00136     CoreApplication::Run(directXAppSource);
00137     return 0;
00138 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/targetver.h Source File

  • Hilo C++
  • CartoonEffect

targetver.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 // Including SDKDDKVer.h defines the highest available Windows platform.
00010
00011 // If you wish to build your application for a previous Windows platform, include WinSDKVer.h and
00012 // set the _WIN32_WINNT macro to the platform you wish to support before including SDKDDKVer.h.
00013
00014 #include <SDKDDKVer.h>
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario4.xaml.h Source File

  • XAML WebView control

Scenario4.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace WebViewControl
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario4 sealed
00031         {
00032         public:
00033             Scenario4();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Other_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         void WebView4_ScriptNotify(Platform::Object^ sender, Windows::UI::Xaml::Controls::NotifyEventArgs^ e);
00042         void FireScript_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043         void NavToString_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044         void Nav_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045       };
00046     }
00047 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/DirectXBase.cpp Source File

  • Direct2D geometry realization

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_ENABLE_MULTITHREADED_OPTIMIZATIONS,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Audio.cpp Source File

  • DirectX marble maze game

Audio.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXSample.h"
00010 #include "Audio.h"
00011
00012 void AudioEngineCallbacks::Initialize(Audio* audio)
00013 {
00014     m_audio = audio;
00015 }
00016
00017 // Called when a critical system error causes XAudio2
00018 // to be closed and restarted. The error code is given in Error.
00019 void  _stdcall AudioEngineCallbacks::OnCriticalError(HRESULT Error)
00020 {
00021     m_audio->SetEngineExperiencedCriticalError();
00022 }
00023
00024 Audio::~Audio()
00025 {
00026     SuspendAudio();
00027 }
00028
00029 void Audio::Initialize()
00030 {
00031     m_isAudioStarted = false;
00032     m_musicEngine = nullptr;
00033     m_soundEffectEngine = nullptr;
00034     m_musicMasteringVoice = nullptr;
00035     m_soundEffectMasteringVoice = nullptr;
00036     m_musicSourceVoice = nullptr;
00037
00038     m_reverbParametersSmall.ReflectionsDelay = XAUDIO2FX_REVERB_DEFAULT_REFLECTIONS_DELAY;
00039     m_reverbParametersSmall.ReverbDelay = XAUDIO2FX_REVERB_DEFAULT_REVERB_DELAY;
00040     m_reverbParametersSmall.RearDelay = XAUDIO2FX_REVERB_DEFAULT_REAR_DELAY;
00041     m_reverbParametersSmall.PositionLeft = XAUDIO2FX_REVERB_DEFAULT_POSITION;
00042     m_reverbParametersSmall.PositionRight = XAUDIO2FX_REVERB_DEFAULT_POSITION;
00043     m_reverbParametersSmall.PositionMatrixLeft = XAUDIO2FX_REVERB_DEFAULT_POSITION_MATRIX;
00044     m_reverbParametersSmall.PositionMatrixRight = XAUDIO2FX_REVERB_DEFAULT_POSITION_MATRIX;
00045     m_reverbParametersSmall.EarlyDiffusion = 4;
00046     m_reverbParametersSmall.LateDiffusion = 15;
00047     m_reverbParametersSmall.LowEQGain = XAUDIO2FX_REVERB_DEFAULT_LOW_EQ_GAIN;
00048     m_reverbParametersSmall.LowEQCutoff = XAUDIO2FX_REVERB_DEFAULT_LOW_EQ_CUTOFF;
00049     m_reverbParametersSmall.HighEQGain = XAUDIO2FX_REVERB_DEFAULT_HIGH_EQ_GAIN;
00050     m_reverbParametersSmall.HighEQCutoff = XAUDIO2FX_REVERB_DEFAULT_HIGH_EQ_CUTOFF;
00051     m_reverbParametersSmall.RoomFilterFreq = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_FREQ;
00052     m_reverbParametersSmall.RoomFilterMain = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_MAIN;
00053     m_reverbParametersSmall.RoomFilterHF = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_HF;
00054     m_reverbParametersSmall.ReflectionsGain = XAUDIO2FX_REVERB_DEFAULT_REFLECTIONS_GAIN;
00055     m_reverbParametersSmall.ReverbGain = XAUDIO2FX_REVERB_DEFAULT_REVERB_GAIN;
00056     m_reverbParametersSmall.DecayTime = XAUDIO2FX_REVERB_DEFAULT_DECAY_TIME;
00057     m_reverbParametersSmall.Density = XAUDIO2FX_REVERB_DEFAULT_DENSITY;
00058     m_reverbParametersSmall.RoomSize = XAUDIO2FX_REVERB_DEFAULT_ROOM_SIZE;
00059     m_reverbParametersSmall.WetDryMix = XAUDIO2FX_REVERB_DEFAULT_WET_DRY_MIX;
00060     m_reverbParametersSmall.DisableLateField = TRUE;
00061
00062     m_reverbParametersLarge.ReflectionsDelay = XAUDIO2FX_REVERB_DEFAULT_REFLECTIONS_DELAY;
00063     m_reverbParametersLarge.ReverbDelay = XAUDIO2FX_REVERB_DEFAULT_REVERB_DELAY;
00064     m_reverbParametersLarge.RearDelay = XAUDIO2FX_REVERB_DEFAULT_REAR_DELAY;
00065     m_reverbParametersLarge.PositionLeft = XAUDIO2FX_REVERB_DEFAULT_POSITION;
00066     m_reverbParametersLarge.PositionRight = XAUDIO2FX_REVERB_DEFAULT_POSITION;
00067     m_reverbParametersLarge.PositionMatrixLeft = XAUDIO2FX_REVERB_DEFAULT_POSITION_MATRIX;
00068     m_reverbParametersLarge.PositionMatrixRight = XAUDIO2FX_REVERB_DEFAULT_POSITION_MATRIX;
00069     m_reverbParametersLarge.EarlyDiffusion = 4;
00070     m_reverbParametersLarge.LateDiffusion = 4;
00071     m_reverbParametersLarge.LowEQGain = XAUDIO2FX_REVERB_DEFAULT_LOW_EQ_GAIN;
00072     m_reverbParametersLarge.LowEQCutoff = XAUDIO2FX_REVERB_DEFAULT_LOW_EQ_CUTOFF;
00073     m_reverbParametersLarge.HighEQGain = XAUDIO2FX_REVERB_DEFAULT_HIGH_EQ_GAIN;
00074     m_reverbParametersLarge.HighEQCutoff = XAUDIO2FX_REVERB_DEFAULT_HIGH_EQ_CUTOFF;
00075     m_reverbParametersLarge.RoomFilterFreq = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_FREQ;
00076     m_reverbParametersLarge.RoomFilterMain = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_MAIN;
00077     m_reverbParametersLarge.RoomFilterHF = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_HF;
00078     m_reverbParametersLarge.ReflectionsGain = XAUDIO2FX_REVERB_DEFAULT_REFLECTIONS_GAIN;
00079     m_reverbParametersLarge.ReverbGain = XAUDIO2FX_REVERB_DEFAULT_REVERB_GAIN;
00080     m_reverbParametersLarge.DecayTime = 1.0f;
00081     m_reverbParametersLarge.Density = 10;
00082     m_reverbParametersLarge.RoomSize = 100;
00083     m_reverbParametersLarge.WetDryMix = XAUDIO2FX_REVERB_DEFAULT_WET_DRY_MIX;
00084     m_reverbParametersLarge.DisableLateField = FALSE;
00085
00086     for (int i = 0; i < ARRAYSIZE(m_soundEffects); i++)
00087     {
00088         m_soundEffects[i].m_soundEffectBufferData = nullptr;
00089         m_soundEffects[i].m_soundEffectSourceVoice = nullptr;
00090         m_soundEffects[i].m_soundEffectStarted = false;
00091         ZeroMemory(&m_soundEffects[i].m_audioBuffer, sizeof(m_soundEffects[i].m_audioBuffer));
00092     }
00093     ZeroMemory(m_audioBuffers, sizeof(m_audioBuffers));
00094 }
00095
00096 void Audio::SetRoomSize(float roomSize, float* wallDistances)
00097 {
00098     // Maximum "outdoors" is a room size of 1000.0f
00099     float normalizedRoomSize = roomSize  / 1000.0f;
00100
00101     float outputMatrix[4] = {0, 0, 0, 0};
00102     float leftRatio = wallDistances[2] / (wallDistances[2] + wallDistances[3]);
00103     if ((wallDistances[2] + wallDistances[3]) == 0)
00104     {
00105         leftRatio = 0.5f;
00106     }
00107     float width = abs((wallDistances[3] + wallDistances[5] + wallDistances[7]) / 3.0f - (wallDistances[2] + wallDistances[4] + wallDistances[6]) / 3.0f);
00108     float height = abs(wallDistances[1] - wallDistances[0]);
00109     float widthNormalized = width / max(width, height);
00110     if (width == 0)
00111     {
00112         widthNormalized = 1.0f;
00113     }
00114
00115     // As widthNormalized approaches 0, the room is taller than wide.
00116     // This means that the late-field reverb should be non-localized across both speakers.
00117     leftRatio -= .5f;
00118     leftRatio *= widthNormalized;
00119     leftRatio += .5f;
00120
00121     // Near-field reverb with the speaker closest to the wall getting more reverb
00122     outputMatrix[0] = (1.0f - leftRatio)* normalizedRoomSize;
00123     outputMatrix[1] = 0;
00124     outputMatrix[2] = 0;
00125     outputMatrix[3] = leftRatio * normalizedRoomSize;
00126     DX::ThrowIfFailed(
00127         m_soundEffectReverbVoiceSmallRoom->SetOutputMatrix(m_soundEffectMasteringVoice, 2, 2, outputMatrix)
00128         );
00129
00130     outputMatrix[0] = (1.0f - leftRatio) * normalizedRoomSize;
00131     outputMatrix[1] = 0;
00132     outputMatrix[2] = 0;
00133     outputMatrix[3]= leftRatio * normalizedRoomSize;
00134     DX::ThrowIfFailed(
00135         m_musicReverbVoiceSmallRoom->SetOutputMatrix(m_musicMasteringVoice, 2, 2, outputMatrix)
00136         );
00137
00138     // Late-field reverb: The wall furthest away gets more of the late-field reverb
00139     outputMatrix[0] = leftRatio * (1.0f - normalizedRoomSize);
00140     outputMatrix[1] = 0;
00141     outputMatrix[2] = 0;
00142     outputMatrix[3]= (1.0f - leftRatio) * (1.0f - normalizedRoomSize);
00143     DX::ThrowIfFailed(
00144         m_soundEffectReverbVoiceLargeRoom->SetOutputMatrix(m_soundEffectMasteringVoice, 2, 2, outputMatrix)
00145         );
00146
00147     outputMatrix[0] = leftRatio * (1.0f - normalizedRoomSize);
00148     outputMatrix[1] = 0;
00149     outputMatrix[2] = 0;
00150     outputMatrix[3] = (1.0f - leftRatio) * (1.0f - normalizedRoomSize);
00151
00152     DX::ThrowIfFailed(
00153         m_musicReverbVoiceLargeRoom->SetOutputMatrix(m_musicMasteringVoice, 2, 2, outputMatrix)
00154         );
00155 }
00156
00157 void Audio::CreateResources()
00158 {
00159     try
00160     {
00161         // Media Foundation is a convenient way to get both file I/O and format decode for
00162         // audio assets. You can replace the streamer in this sample with your own file I/O
00163         // and decode routines.
00164         m_musicStreamer.Initialize(L"Media\\Audio\\background.wma");
00165
00166         DX::ThrowIfFailed(
00167             XAudio2Create(&m_musicEngine)
00168             );
00169
00170 #if defined(_DEBUG)
00171         XAUDIO2_DEBUG_CONFIGURATION debugConfig = {0};
00172         debugConfig.BreakMask = XAUDIO2_LOG_ERRORS;
00173         debugConfig.TraceMask = XAUDIO2_LOG_ERRORS;
00174         m_musicEngine->SetDebugConfiguration(&debugConfig);
00175 #endif
00176
00177         m_musicEngineCallback.Initialize(this);
00178         m_musicEngine->RegisterForCallbacks(&m_musicEngineCallback);
00179
00180         // This sample plays the equivalent of background music, which we tag on the
00181         // mastering voice as AudioCategory_GameMedia. In ordinary usage, if we were
00182         // playing the music track with no effects, we could route it entirely through
00183         // Media Foundation. Here we are using XAudio2 to apply a reverb effect to the
00184         // music, so we use Media Foundation to decode the data then we feed it through
00185         // the XAudio2 pipeline as a separate Mastering Voice, so that we can tag it
00186         // as Game Media. We default the mastering voice to 2 channels to simplify
00187         // the reverb logic.
00188         DX::ThrowIfFailed(
00189             m_musicEngine->CreateMasteringVoice(
00190                 &m_musicMasteringVoice,
00191                 2,
00192                 48000,
00193                 0,
00194                 nullptr,
00195                 nullptr,
00196                 AudioCategory_GameMedia
00197                 )
00198         );
00199
00200         CreateReverb(
00201             m_musicEngine,
00202             m_musicMasteringVoice,
00203             &m_reverbParametersSmall,
00204             &m_musicReverbVoiceSmallRoom,
00205             true
00206             );
00207         CreateReverb(
00208             m_musicEngine,
00209             m_musicMasteringVoice,
00210             &m_reverbParametersLarge,
00211             &m_musicReverbVoiceLargeRoom,
00212             true
00213             );
00214
00215         XAUDIO2_SEND_DESCRIPTOR descriptors[3];
00216         descriptors[0].pOutputVoice = m_musicMasteringVoice;
00217         descriptors[0].Flags = 0;
00218         descriptors[1].pOutputVoice = m_musicReverbVoiceSmallRoom;
00219         descriptors[1].Flags = 0;
00220         descriptors[2].pOutputVoice = m_musicReverbVoiceLargeRoom;
00221         descriptors[2].Flags = 0;
00222         XAUDIO2_VOICE_SENDS sends = {0};
00223         sends.SendCount = 3;
00224         sends.pSends = descriptors;
00225         WAVEFORMATEX& waveFormat = m_musicStreamer.GetOutputWaveFormatEx();
00226
00227         DX::ThrowIfFailed(
00228             m_musicEngine->CreateSourceVoice(&m_musicSourceVoice, &waveFormat, 0, 1.0f, &m_voiceContext, &sends, nullptr)
00229             );
00230
00231         DX::ThrowIfFailed(
00232             m_musicMasteringVoice->SetVolume(0.4f)
00233             );
00234
00235         // Create a separate engine and mastering voice for sound effects in the sample
00236         // Games will use many voices in a complex graph for audio, mixing all effects down to a
00237         // single mastering voice.
00238         // We are creating an entirely new engine instance and mastering voice in order to tag
00239         // our sound effects with the audio category AudioCategory_GameEffects.
00240         DX::ThrowIfFailed(
00241             XAudio2Create(&m_soundEffectEngine)
00242             );
00243
00244         m_soundEffectEngineCallback.Initialize(this);
00245         m_soundEffectEngine->RegisterForCallbacks(&m_soundEffectEngineCallback);
00246
00247         // We default the mastering voice to 2 channels to simplify the reverb logic.
00248         DX::ThrowIfFailed(
00249             m_soundEffectEngine->CreateMasteringVoice(&m_soundEffectMasteringVoice, 2, 48000, 0, nullptr, nullptr, AudioCategory_GameEffects)
00250             );
00251
00252         CreateReverb(m_soundEffectEngine, m_soundEffectMasteringVoice, &m_reverbParametersSmall, &m_soundEffectReverbVoiceSmallRoom, true);
00253         CreateReverb(m_soundEffectEngine, m_soundEffectMasteringVoice, &m_reverbParametersLarge, &m_soundEffectReverbVoiceLargeRoom, true);
00254
00255         CreateSourceVoice(RollingEvent);
00256         CreateSourceVoice(FallingEvent);
00257         CreateSourceVoice(CollisionEvent);
00258         CreateSourceVoice(MenuChangeEvent);
00259         CreateSourceVoice(MenuSelectedEvent);
00260         CreateSourceVoice(CheckpointEvent);
00261     }
00262     catch (...)
00263     {
00264         m_engineExperiencedCriticalError = true;
00265     }
00266 }
00267
00268 void Audio::CreateReverb(IXAudio2* engine, IXAudio2MasteringVoice* masteringVoice, XAUDIO2FX_REVERB_PARAMETERS* parameters, IXAudio2SubmixVoice** newSubmix, bool enableEffect)
00269 {
00270     XAUDIO2_EFFECT_DESCRIPTOR soundEffectdescriptor;
00271     XAUDIO2_EFFECT_CHAIN soundEffectChain;
00272     Microsoft::WRL::ComPtr<IUnknown> soundEffectXAPO;
00273
00274     DX::ThrowIfFailed(
00275         XAudio2CreateReverb(&soundEffectXAPO)
00276         );
00277
00278     soundEffectdescriptor.InitialState = false;
00279     soundEffectdescriptor.OutputChannels = 2;
00280     soundEffectdescriptor.pEffect = soundEffectXAPO.Get();
00281     soundEffectChain.EffectCount = 1;
00282     soundEffectChain.pEffectDescriptors = &soundEffectdescriptor;
00283
00284     DX::ThrowIfFailed(
00285         engine->CreateSubmixVoice(newSubmix, 2, 48000, 0, 0, nullptr, &soundEffectChain)
00286         );
00287
00288     DX::ThrowIfFailed(
00289         (*newSubmix)->SetEffectParameters(0, parameters, sizeof(m_reverbParametersSmall))
00290         );
00291
00292     if (enableEffect)
00293     {
00294         DX::ThrowIfFailed(
00295             (*newSubmix)->EnableEffect(0)
00296             );
00297     }
00298
00299     DX::ThrowIfFailed(
00300         (*newSubmix)->SetVolume (1.0f)
00301         );
00302
00303     float outputMatrix[4] = {0, 0, 0, 0};
00304     DX::ThrowIfFailed(
00305         (*newSubmix)->SetOutputMatrix(masteringVoice, 2, 2, outputMatrix)
00306         );
00307 }
00308
00309 void Audio::CreateSourceVoice(SoundEvent sound)
00310 {
00311     // Load all data for each sound effect into a single in-memory buffer
00312     MediaStreamer soundEffectStream;
00313     switch (sound)
00314     {
00315         case RollingEvent: soundEffectStream.Initialize(L"Media\\Audio\\MarbleRoll.wav"); break;
00316         case FallingEvent: soundEffectStream.Initialize(L"Media\\Audio\\MarbleFall.wav"); break;
00317         case CollisionEvent: soundEffectStream.Initialize(L"Media\\Audio\\MarbleHit.wav"); break;
00318         case MenuChangeEvent: soundEffectStream.Initialize(L"Media\\Audio\\MenuChange.wav"); break;
00319         case MenuSelectedEvent: soundEffectStream.Initialize(L"Media\\Audio\\MenuSelect.wav"); break;
00320         case CheckpointEvent: soundEffectStream.Initialize(L"Media\\Audio\\Checkpoint.wav"); break;
00321     }
00322     m_soundEffects[sound].m_soundEventType = sound;
00323
00324     uint32 bufferLength = soundEffectStream.GetMaxStreamLengthInBytes();
00325     m_soundEffects[sound].m_soundEffectBufferData = new byte[bufferLength];
00326     soundEffectStream.ReadAll(m_soundEffects[sound].m_soundEffectBufferData, bufferLength, &m_soundEffects[sound].m_soundEffectBufferLength);
00327
00328     XAUDIO2_SEND_DESCRIPTOR descriptors[3];
00329     descriptors[0].pOutputVoice = m_soundEffectMasteringVoice;
00330     descriptors[0].Flags = 0;
00331     descriptors[1].pOutputVoice = m_soundEffectReverbVoiceSmallRoom;
00332     descriptors[1].Flags = 0;
00333     descriptors[2].pOutputVoice = m_soundEffectReverbVoiceLargeRoom;
00334     descriptors[2].Flags = 0;
00335     XAUDIO2_VOICE_SENDS sends = {0};
00336     sends.SendCount = 3;
00337     sends.pSends = descriptors;
00338
00339     // The rolling sound can have pitch shifting and a low-pass filter.
00340     if (sound == RollingEvent)
00341     {
00342         DX::ThrowIfFailed(
00343             m_soundEffectEngine->CreateSourceVoice(
00344                 &m_soundEffects[sound].m_soundEffectSourceVoice,
00345                 &(soundEffectStream.GetOutputWaveFormatEx()),
00346                 XAUDIO2_VOICE_USEFILTER,
00347                 2.0f,
00348                 &m_voiceContext,
00349                 &sends)
00350             );
00351     }
00352     else
00353     {
00354         DX::ThrowIfFailed(
00355             m_soundEffectEngine->CreateSourceVoice(
00356                 &m_soundEffects[sound].m_soundEffectSourceVoice,
00357                 &(soundEffectStream.GetOutputWaveFormatEx()),
00358                 0,
00359                 1.0f,
00360                 &m_voiceContext,
00361                 &sends)
00362             );
00363     }
00364     m_soundEffects[sound].m_soundEffectSampleRate = soundEffectStream.GetOutputWaveFormatEx().nSamplesPerSec;
00365
00366     // Queue in-memory buffer for playback
00367     ZeroMemory(&m_soundEffects[sound].m_audioBuffer, sizeof(m_soundEffects[sound].m_audioBuffer));
00368
00369     m_soundEffects[sound].m_audioBuffer.AudioBytes = m_soundEffects[sound].m_soundEffectBufferLength;
00370     m_soundEffects[sound].m_audioBuffer.pAudioData = m_soundEffects[sound].m_soundEffectBufferData;
00371     m_soundEffects[sound].m_audioBuffer.pContext = &m_soundEffects[sound];
00372     m_soundEffects[sound].m_audioBuffer.Flags = XAUDIO2_END_OF_STREAM;
00373     if (sound == RollingEvent)
00374     {
00375         m_soundEffects[sound].m_audioBuffer.LoopCount = XAUDIO2_LOOP_INFINITE;
00376     }
00377     else
00378     {
00379         m_soundEffects[sound].m_audioBuffer.LoopCount = 0;
00380     }
00381
00382     if (sound == FallingEvent || sound == CheckpointEvent)
00383     {
00384         m_soundEffects[sound].m_soundEffectSourceVoice->SetVolume(0.4f);
00385     }
00386
00387     DX::ThrowIfFailed(
00388         m_soundEffects[sound].m_soundEffectSourceVoice->SubmitSourceBuffer(&m_soundEffects[sound].m_audioBuffer)
00389         );
00390 }
00391
00392 void Audio::ReleaseResources()
00393 {
00394     if (m_musicSourceVoice != nullptr)
00395     {
00396         m_musicSourceVoice->DestroyVoice();
00397     }
00398     if (m_soundEffectReverbVoiceSmallRoom != nullptr)
00399     {
00400         m_soundEffectReverbVoiceSmallRoom->DestroyVoice();
00401     }
00402     if (m_soundEffectReverbVoiceLargeRoom != nullptr)
00403     {
00404         m_soundEffectReverbVoiceLargeRoom->DestroyVoice();
00405     }
00406     if (m_musicReverbVoiceSmallRoom != nullptr)
00407     {
00408         m_musicReverbVoiceSmallRoom->DestroyVoice();
00409     }
00410     if (m_musicReverbVoiceLargeRoom != nullptr)
00411     {
00412         m_musicReverbVoiceLargeRoom->DestroyVoice();
00413     }
00414     for (int i = 0; i < ARRAYSIZE(m_soundEffects); i++)
00415     {
00416         if (m_soundEffects[i].m_soundEffectSourceVoice != nullptr)
00417         {
00418             m_soundEffects[i].m_soundEffectSourceVoice->DestroyVoice();
00419         }
00420         m_soundEffects[i].m_soundEffectSourceVoice = nullptr;
00421     }
00422     if (m_musicMasteringVoice != nullptr)
00423     {
00424             m_musicMasteringVoice->DestroyVoice();
00425     }
00426     if (m_soundEffectMasteringVoice != nullptr)
00427     {
00428         m_soundEffectMasteringVoice->DestroyVoice();
00429     }
00430
00431     m_musicSourceVoice = nullptr;
00432     m_musicMasteringVoice = nullptr;
00433     m_soundEffectMasteringVoice = nullptr;
00434     m_soundEffectReverbVoiceSmallRoom = nullptr;
00435     m_soundEffectReverbVoiceLargeRoom = nullptr;
00436     m_musicReverbVoiceSmallRoom = nullptr;
00437     m_musicReverbVoiceLargeRoom = nullptr;
00438     m_musicEngine = nullptr;
00439     m_soundEffectEngine = nullptr;
00440 }
00441
00442 void Audio::Start()
00443 {
00444     if (m_engineExperiencedCriticalError)
00445     {
00446         return;
00447     }
00448
00449     HRESULT hr = m_musicSourceVoice->Start(0);
00450
00451     if SUCCEEDED(hr) {
00452         m_isAudioStarted = true;
00453     }
00454     else
00455     {
00456         m_engineExperiencedCriticalError = true;
00457     }
00458 }
00459
00460 // This sample processes audio buffers during the render cycle of the application.
00461 // As long as the sample maintains a high-enough frame rate, this approach should
00462 // not glitch audio. In game code, it is best for audio buffers to be processed
00463 // on a separate thread that is not synced to the main render loop of the game.
00464 void Audio::Render()
00465 {
00466     if (m_engineExperiencedCriticalError)
00467     {
00468         m_engineExperiencedCriticalError = false;
00469         ReleaseResources();
00470         Initialize();
00471         CreateResources();
00472         Start();
00473         if (m_engineExperiencedCriticalError)
00474         {
00475             return;
00476         }
00477     }
00478
00479     try
00480     {
00481         bool streamComplete;
00482         XAUDIO2_VOICE_STATE state;
00483         uint32 bufferLength;
00484         XAUDIO2_BUFFER buf = {0};
00485
00486         // Use MediaStreamer to stream the buffers.
00487         m_musicSourceVoice->GetState(&state);
00488         while (state.BuffersQueued <= MAX_BUFFER_COUNT - 1)
00489         {
00490             streamComplete = m_musicStreamer.GetNextBuffer(
00491                 m_audioBuffers[m_currentBuffer],
00492                 STREAMING_BUFFER_SIZE,
00493                 &bufferLength
00494                 );
00495
00496             if (bufferLength > 0)
00497             {
00498                 buf.AudioBytes = bufferLength;
00499                 buf.pAudioData = m_audioBuffers[m_currentBuffer];
00500                 buf.Flags = (streamComplete) ? XAUDIO2_END_OF_STREAM : 0;
00501                 buf.pContext = 0;
00502                 DX::ThrowIfFailed(
00503                     m_musicSourceVoice->SubmitSourceBuffer(&buf)
00504                     );
00505
00506                 m_currentBuffer++;
00507                 m_currentBuffer %= MAX_BUFFER_COUNT;
00508             }
00509
00510             if (streamComplete)
00511             {
00512                 // Loop the stream.
00513                 m_musicStreamer.Restart();
00514                 break;
00515             }
00516
00517             m_musicSourceVoice->GetState(&state);
00518         }
00519     }
00520     catch (...)
00521     {
00522         m_engineExperiencedCriticalError = true;
00523     }
00524 }
00525
00526 void Audio::PlaySoundEffect(SoundEvent sound)
00527 {
00528     XAUDIO2_BUFFER buf = {0};
00529     XAUDIO2_VOICE_STATE state = {0};
00530
00531     if (m_engineExperiencedCriticalError) {
00532         // If there's an error, then we'll recreate the engine on the next
00533         // render pass.
00534         return;
00535     }
00536
00537     SoundEffectData* soundEffect = &m_soundEffects[sound];
00538     HRESULT hr = soundEffect->m_soundEffectSourceVoice->Start();
00539     if FAILED(hr)
00540     {
00541         m_engineExperiencedCriticalError = true;
00542         return;
00543     }
00544
00545     // For one-off voices, submit a new buffer if there's none queued up,
00546     // and allow up to two collisions to be queued up.
00547     if (sound != RollingEvent)
00548     {
00549         XAUDIO2_VOICE_STATE state = {0};
00550         soundEffect->m_soundEffectSourceVoice->GetState(&state, XAUDIO2_VOICE_NOSAMPLESPLAYED);
00551         if (state.BuffersQueued == 0)
00552         {
00553             soundEffect->m_soundEffectSourceVoice->SubmitSourceBuffer(&soundEffect->m_audioBuffer);
00554         }
00555         else if (state.BuffersQueued < 2 && sound == CollisionEvent)
00556         {
00557             soundEffect->m_soundEffectSourceVoice->SubmitSourceBuffer(&soundEffect->m_audioBuffer);
00558         }
00559
00560         // For the menu clicks, we want to stop the voice and replay the click right away.
00561         // Note that stopping and then flushing could cause a glitch due to the
00562         // waveform not being at a zero-crossing, but due to the nature of the sound
00563         // (fast and 'clicky'), we don't mind.
00564         if (state.BuffersQueued > 0 && sound == MenuChangeEvent)
00565         {
00566             soundEffect->m_soundEffectSourceVoice->Stop();
00567             soundEffect->m_soundEffectSourceVoice->FlushSourceBuffers();
00568             soundEffect->m_soundEffectSourceVoice->SubmitSourceBuffer(&soundEffect->m_audioBuffer);
00569             soundEffect->m_soundEffectSourceVoice->Start();
00570         }
00571     }
00572
00573     m_soundEffects[sound].m_soundEffectStarted = true;
00574 }
00575
00576 void Audio::StopSoundEffect(SoundEvent sound)
00577 {
00578     if (m_engineExperiencedCriticalError) {
00579         return;
00580     }
00581
00582     HRESULT hr = m_soundEffects[sound].m_soundEffectSourceVoice->Stop();
00583     if FAILED(hr)
00584     {
00585         // If there's an error, then we'll recreate the engine on the next render pass
00586         m_engineExperiencedCriticalError = true;
00587         return;
00588     }
00589
00590     m_soundEffects[sound].m_soundEffectStarted = false;
00591 }
00592
00593 bool Audio::IsSoundEffectStarted(SoundEvent sound)
00594 {
00595     return m_soundEffects[sound].m_soundEffectStarted;
00596 }
00597
00598 void Audio::SetSoundEffectVolume(SoundEvent sound, float volume)
00599 {
00600     if (m_soundEffects[sound].m_soundEffectSourceVoice != nullptr) {
00601         m_soundEffects[sound].m_soundEffectSourceVoice->SetVolume(volume);
00602     }
00603 }
00604
00605 void Audio::SetSoundEffectPitch(SoundEvent sound, float pitch)
00606 {
00607     if (m_soundEffects[sound].m_soundEffectSourceVoice != nullptr) {
00608         m_soundEffects[sound].m_soundEffectSourceVoice->SetFrequencyRatio(pitch);
00609     }
00610 }
00611
00612 void Audio::SetSoundEffectFilter(SoundEvent sound, float frequency, float oneOverQ)
00613 {
00614     if (m_soundEffects[sound].m_soundEffectSourceVoice != nullptr) {
00615         if (oneOverQ <= 0.1f)
00616         {
00617             oneOverQ = 0.1f;
00618         }
00619         if (oneOverQ > XAUDIO2_MAX_FILTER_ONEOVERQ)
00620         {
00621             oneOverQ = XAUDIO2_MAX_FILTER_ONEOVERQ;
00622         }
00623         XAUDIO2_FILTER_PARAMETERS params = {LowPassFilter, XAudio2CutoffFrequencyToRadians(frequency, m_soundEffects[sound].m_soundEffectSampleRate), oneOverQ};
00624
00625         m_soundEffects[sound].m_soundEffectSourceVoice->SetFilterParameters(&params);
00626     }
00627 }
00628
00629 // Uses the IXAudio2::StopEngine method to stop all audio immediately.
00630 // It leaves the audio graph untouched, which preserves all effect parameters
00631 // and effect histories (like reverb effects) voice states, pending buffers,
00632 // cursor positions and so on.
00633 // When the engines are restarted, the resulting audio will sound as if it had
00634 // never been stopped except for the period of silence.
00635 void Audio::SuspendAudio()
00636 {
00637     if (m_engineExperiencedCriticalError)
00638     {
00639         return;
00640     }
00641
00642     if (m_isAudioStarted)
00643     {
00644         m_musicEngine->StopEngine();
00645         m_soundEffectEngine->StopEngine();
00646     }
00647     m_isAudioStarted = false;
00648 }
00649
00650 // Restarts the audio streams. A call to this method must match a previous call
00651 // to SuspendAudio. This method causes audio to continue where it left off.
00652 // If there is a problem with the restart, the m_engineExperiencedCriticalError
00653 // flag is set. The next call to Render will recreate all the resources and
00654 // reset the audio pipeline.
00655 void Audio::ResumeAudio()
00656 {
00657     if (m_engineExperiencedCriticalError)
00658     {
00659         return;
00660     }
00661
00662     HRESULT hr = m_musicEngine->StartEngine();
00663     HRESULT hr2 = m_soundEffectEngine->StartEngine();
00664
00665     if (FAILED(hr) || FAILED(hr2))
00666     {
00667         m_engineExperiencedCriticalError = true;
00668     }
00669 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::DataBinding::sealed Member List

This is the complete list of members for SDKSample::DataBinding::sealed, including all inherited members.
_city | SDKSample::DataBinding::sealed | [private]
_color | SDKSample::DataBinding::sealed | [private]
_employee | SDKSample::DataBinding::sealed | [private]
_isPropertyChangedObserved | SDKSample::DataBinding::sealed | [private]
_items | SDKSample::DataBinding::sealed | [private]
_name | SDKSample::DataBinding::sealed | [private]
_observableTeams | SDKSample::DataBinding::sealed |
_organization | SDKSample::DataBinding::sealed |
_privatePropertyChanged | SDKSample::DataBinding::sealed | [private]
_propBag | SDKSample::DataBinding::sealed | [private]
BindableVectorChanged(Windows::UI::Xaml::Interop::IBindableObservableVector^sender, Object^e) | SDKSample::DataBinding::sealed | [protected]
BtnRemoveTeam_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [protected]
Convert(Object^value, TypeName targetType, Object^parameter, String^language) | SDKSample::DataBinding::sealed | [virtual]
ConvertBack(Object^value, TypeName targetType, Object^parameter, String^language) | SDKSample::DataBinding::sealed | [virtual]
Employee() | SDKSample::DataBinding::sealed | [inline]
employeeChanged(Object^sender, PropertyChangedEventArgs^e) | SDKSample::DataBinding::sealed | [private]
employees | SDKSample::DataBinding::sealed | [private]
First() | SDKSample::DataBinding::sealed | [inline, virtual]
First() | SDKSample::DataBinding::sealed | [inline, virtual]
GetView() | SDKSample::DataBinding::sealed | [inline]
GetView() | SDKSample::DataBinding::sealed | [inline]
HasKey(Platform::String^key) | SDKSample::DataBinding::sealed | [inline, virtual]
HasKey(Platform::String^key) | SDKSample::DataBinding::sealed | [inline, virtual]
Insert(Platform::String^key, Platform::Object^value) | SDKSample::DataBinding::sealed | [inline, virtual]
Insert(Platform::String^key, Platform::Object^value) | SDKSample::DataBinding::sealed | [inline, virtual]
Lookup(Platform::String^key) | SDKSample::DataBinding::sealed | [inline, virtual]
Lookup(Platform::String^key) | SDKSample::DataBinding::sealed | [inline, virtual]
OnPropertyChanged(String^propertyName) | SDKSample::DataBinding::sealed | [inline, protected]
Remove(Platform::String^key) | SDKSample::DataBinding::sealed | [inline, virtual]
Remove(Platform::String^key) | SDKSample::DataBinding::sealed | [inline, virtual]
rootPage | SDKSample::DataBinding::sealed | [private]
S2Formatter() | SDKSample::DataBinding::sealed |
Scenario1() | SDKSample::DataBinding::sealed |
Scenario1Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [private]
Scenario2() | SDKSample::DataBinding::sealed |
Scenario2Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [private]
Scenario3() | SDKSample::DataBinding::sealed |
Scenario3Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [private]
Scenario4() | SDKSample::DataBinding::sealed |
Scenario4Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [private]
Scenario5() | SDKSample::DataBinding::sealed |
Scenario5Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [private]
Scenario6() | SDKSample::DataBinding::sealed |
Scenario6Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [private]
Scenario7() | SDKSample::DataBinding::sealed |
Scenario7Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [protected]
Scenario8() | SDKSample::DataBinding::sealed |
Scenario8Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::DataBinding::sealed | [protected]
Team() | SDKSample::DataBinding::sealed |
TeamDataSource() | SDKSample::DataBinding::sealed |
TeamGroup(Platform::String^name) | SDKSample::DataBinding::sealed |
Teams() | SDKSample::DataBinding::sealed |
VectorChanged(Windows::Foundation::Collections::IObservableVector< Object^>^sender, Windows::Foundation::Collections::IVectorChangedEventArgs^e) | SDKSample::DataBinding::sealed | [protected]
vectorChangedHandlerToken | SDKSample::DataBinding::sealed | [private]
~S2Formatter() | SDKSample::DataBinding::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Playlists::sealed Member List

This is the complete list of members for SDKSample::Playlists::sealed, including all inherited members.
Add() | SDKSample::Playlists::sealed |
Clear() | SDKSample::Playlists::sealed |
Create() | SDKSample::Playlists::sealed |
Display() | SDKSample::Playlists::sealed |
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Playlists::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Playlists::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Playlists::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Playlists::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Playlists::sealed | [protected, virtual]
PickAudioButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Playlists::sealed | [private]
PickAudioButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Playlists::sealed | [private]
PickPlaylistButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Playlists::sealed | [private]
PickPlaylistButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Playlists::sealed | [private]
PickPlaylistButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Playlists::sealed | [private]
PickPlaylistButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Playlists::sealed | [private]
Remove() | SDKSample::Playlists::sealed |
rootPage | SDKSample::Playlists::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/D2DTextAnimation.cpp Source File

  • Direct2D animated text

D2DTextAnimation.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "D2DTextAnimation.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Activation;
00014 using namespace Windows::ApplicationModel::Core;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::Foundation::Collections;
00017 using namespace Windows::Graphics::Display;
00018 using namespace Windows::Storage;
00019 using namespace Windows::UI::Core;
00020 using namespace Windows::UI::Input;
00021
00022 static const float MinZoom           = 0.5f;
00023 static const float MaxZoom           = 9.0f;
00024 static const float StartZoom         = 1.0f;
00025 static const float OpacityMaskScaler = 2.0f; // Adjusts the resolution of the opacity mask texture.
00026
00027 D2DTextAnimation::D2DTextAnimation() :
00028     m_zoom(StartZoom),
00029     m_animating(false),
00030     m_firstRun(true)
00031 {
00032     m_viewPosition.X = 0.0f;
00033     m_viewPosition.Y = 0.0f;
00034 }
00035
00036 void D2DTextAnimation::CreateDeviceIndependentResources()
00037 {
00038     DirectXBase::CreateDeviceIndependentResources();
00039
00040     Platform::String^ text = L"This sample demonstrates how to efficiently render animated text with D2D and DWrite. The text in this sample can be scaled and panned using touch and mouse controls. As the text's size and position are manipulated, this sample renders the animated text using a faster rendering mode than what is used when the text is static.";
00041
00042     // Create a text format object to describe the text's style.
00043     DX::ThrowIfFailed(
00044         m_dwriteFactory->CreateTextFormat(
00045             L"Segoe UI",
00046             nullptr,
00047             DWRITE_FONT_WEIGHT_NORMAL,
00048             DWRITE_FONT_STYLE_NORMAL,
00049             DWRITE_FONT_STRETCH_NORMAL,
00050             18.0f,
00051             L"en-us",
00052             &m_textFormat
00053             )
00054         );
00055
00056     DX::ThrowIfFailed(
00057         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00058         );
00059
00060     DX::ThrowIfFailed(
00061         m_dwriteFactory->CreateTextLayout(
00062             text->Data(),
00063             text->Length(),
00064             m_textFormat.Get(),
00065             700, // maxWidth
00066             1000, // maxHeight
00067             &m_textLayout
00068             )
00069         );
00070
00071     DX::ThrowIfFailed(
00072         m_textLayout->GetMetrics(&m_textMetrics)
00073         );
00074 }
00075
00076 void D2DTextAnimation::CreateDeviceResources()
00077 {
00078     DirectXBase::CreateDeviceResources();
00079
00080     m_sampleOverlay = ref new SampleOverlay();
00081
00082     m_sampleOverlay->Initialize(
00083         m_d2dDevice.Get(),
00084         m_d2dContext.Get(),
00085         m_wicFactory.Get(),
00086         m_dwriteFactory.Get(),
00087         "Direct2D animated text sample"
00088         );
00089
00090     DX::ThrowIfFailed(
00091         m_d2dContext->CreateSolidColorBrush(
00092             D2D1::ColorF(D2D1::ColorF::Black),
00093             &m_blackBrush
00094             )
00095         );
00096
00097     CreateOpacityMask();
00098 }
00099
00100 void D2DTextAnimation::DrawTextLayout(float x, float y)
00101 {
00102     m_d2dContext->DrawTextLayout(
00103         D2D1::Point2F(x, y),
00104         m_textLayout.Get(),
00105         m_blackBrush.Get(),
00106         D2D1_DRAW_TEXT_OPTIONS_NO_SNAP
00107         );
00108 }
00109
00110 void D2DTextAnimation::CalculateCenterPosition()
00111 {
00112     D2D1_SIZE_F size = m_d2dContext->GetSize();
00113     m_viewPosition.X = size.width/2 - m_textMetrics.widthIncludingTrailingWhitespace/2;
00114     m_viewPosition.Y = size.height/2 - m_textMetrics.height/2;
00115 }
00116
00117 void D2DTextAnimation::CreateOpacityMask()
00118 {
00119     D2D1_BITMAP_PROPERTIES1 properties = D2D1::BitmapProperties1(
00120         D2D1_BITMAP_OPTIONS_TARGET,
00121         D2D1::PixelFormat(DXGI_FORMAT_A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED)
00122         );
00123
00124     D2D1_SIZE_U opacityBitmapSize = D2D1::SizeU(
00125         static_cast<UINT32>(OpacityMaskScaler * m_textMetrics.widthIncludingTrailingWhitespace),
00126         static_cast<UINT32>(OpacityMaskScaler * m_textMetrics.height)
00127         );
00128
00129     DX::ThrowIfFailed(
00130         m_d2dContext->CreateBitmap(
00131             opacityBitmapSize,
00132             nullptr,
00133             0,
00134             &properties,
00135             &m_opacityBitmap
00136             )
00137         );
00138
00139     D2D1::Matrix3x2F zoom = D2D1::Matrix3x2F::Scale(
00140         OpacityMaskScaler,
00141         OpacityMaskScaler
00142         );
00143
00144     m_d2dContext->SetTarget(m_opacityBitmap.Get());
00145     m_d2dContext->BeginDraw();
00146     m_d2dContext->SetTransform(zoom);
00147
00148     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black, 0.0f));
00149
00150     DrawTextLayout(0.0f, 0.0f);
00151
00152     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00153     // is lost. It will be handled during the next call to Present.
00154     HRESULT hr = m_d2dContext->EndDraw();
00155     if (hr != D2DERR_RECREATE_TARGET)
00156     {
00157         DX::ThrowIfFailed(hr);
00158     }
00159
00160     m_d2dContext->SetTarget(nullptr);
00161 }
00162
00163 void D2DTextAnimation::Render()
00164 {
00165     if (m_firstRun)
00166     {
00167         CalculateCenterPosition();
00168         m_firstRun = false;
00169     }
00170
00171     D2D1::Matrix3x2F translation = D2D1::Matrix3x2F::Translation(
00172         m_viewPosition.X,
00173         m_viewPosition.Y
00174         );
00175
00176     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00177     m_d2dContext->BeginDraw();
00178
00179     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00180
00181     if (!m_animating)
00182     {
00183         // Use default (high quality) text rendering when the text is not being animated.
00184         D2D1::Matrix3x2F zoom = D2D1::Matrix3x2F::Scale(m_zoom, m_zoom);
00185         m_d2dContext->SetTransform(zoom * translation);
00186         DrawTextLayout(0.0f, 0.0f);
00187     }
00188     else
00189     {
00190         // Use fast opacity mask text rendering when the text is being animated.
00191         D2D1::Matrix3x2F defaultZoom = D2D1::Matrix3x2F::Scale(
00192             m_zoom / OpacityMaskScaler,
00193             m_zoom / OpacityMaskScaler
00194             );
00195         m_d2dContext->SetTransform(defaultZoom * translation);
00196         m_d2dContext->SetAntialiasMode(D2D1_ANTIALIAS_MODE_ALIASED);
00197         m_d2dContext->FillOpacityMask(m_opacityBitmap.Get(), m_blackBrush.Get(), D2D1_OPACITY_MASK_CONTENT_GRAPHICS);
00198         m_d2dContext->SetAntialiasMode(D2D1_ANTIALIAS_MODE_PER_PRIMITIVE);
00199     }
00200
00201     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00202     // is lost. It will be handled during the next call to Present.
00203     HRESULT hr = m_d2dContext->EndDraw();
00204     if (hr != D2DERR_RECREATE_TARGET)
00205     {
00206         DX::ThrowIfFailed(hr);
00207     }
00208
00209     m_sampleOverlay->Render();
00210 }
00211
00212 void D2DTextAnimation::Initialize(
00213     _In_ CoreApplicationView^ applicationView
00214     )
00215 {
00216     applicationView->Activated +=
00217         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &D2DTextAnimation::OnActivated);
00218
00219     CoreApplication::Suspending +=
00220         ref new EventHandler<SuspendingEventArgs^>(this, &D2DTextAnimation::OnSuspending);
00221 }
00222
00223 void D2DTextAnimation::SetWindow(
00224     _In_ CoreWindow^ window
00225     )
00226 {
00227     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00228
00229     window->SizeChanged +=
00230         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &D2DTextAnimation::OnWindowSizeChanged);
00231
00232     window->PointerPressed +=
00233         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DTextAnimation::OnPointerPressed);
00234
00235     window->PointerReleased +=
00236         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DTextAnimation::OnPointerReleased);
00237
00238     window->PointerMoved +=
00239         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DTextAnimation::OnPointerMoved);
00240
00241     window->PointerWheelChanged +=
00242         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DTextAnimation::OnPointerWheelChanged);
00243
00244     DisplayProperties::LogicalDpiChanged +=
00245         ref new DisplayPropertiesEventHandler(this, &D2DTextAnimation::OnLogicalDpiChanged);
00246
00247     DisplayProperties::DisplayContentsInvalidated +=
00248         ref new DisplayPropertiesEventHandler(this, &D2DTextAnimation::OnDisplayContentsInvalidated);
00249
00250     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00251
00252     // We will use the gesture recognizer to compute the touch gestures, like pinching and dragging,
00253     // into transformations we can use in Direct2D. We simply funnel any touch events into it
00254     // and the gesture recognizer will fire events when the transformations need to be updated or
00255     // a specific gesture (e.g. double tap) occurs.
00256
00257     m_gestureRecognizer = ref new GestureRecognizer();
00258
00259     m_gestureRecognizer->AutoProcessInertia = false;
00260
00261     m_gestureRecognizer->GestureSettings =
00262         GestureSettings::DoubleTap                     |
00263         GestureSettings::ManipulationTranslateX        |
00264         GestureSettings::ManipulationTranslateY        |
00265         GestureSettings::ManipulationScale;
00266
00267     m_gestureRecognizer->Tapped +=
00268         ref new TypedEventHandler<GestureRecognizer^, TappedEventArgs^>(this, &D2DTextAnimation::OnTapped);
00269
00270     m_gestureRecognizer->ManipulationUpdated +=
00271         ref new TypedEventHandler<GestureRecognizer^, ManipulationUpdatedEventArgs^>(this, &D2DTextAnimation::OnManipulationUpdated);
00272
00273     m_gestureRecognizer->ManipulationCompleted +=
00274         ref new TypedEventHandler<GestureRecognizer^, ManipulationCompletedEventArgs^>(this, &D2DTextAnimation::OnManipulationCompleted);
00275
00276     m_gestureRecognizer->AutoProcessInertia = true;
00277 }
00278
00279 void D2DTextAnimation::Load(
00280     _In_ Platform::String^ entryPoint
00281     )
00282 {
00283     // Retrieve any stored variables from the LocalSettings collection.
00284     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00285
00286     if (settingsValues->HasKey("m_viewPosition"))
00287     {
00288         m_viewPosition = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_viewPosition"))->GetPoint();
00289     }
00290
00291     if (settingsValues->HasKey("m_zoom"))
00292     {
00293         m_zoom = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_zoom"))->GetSingle();
00294     }
00295
00296     if (settingsValues->HasKey("m_firstRun"))
00297     {
00298         m_firstRun = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_firstRun"))->GetBoolean();
00299     }
00300 }
00301
00302 void D2DTextAnimation::Run()
00303 {
00304     Render();
00305     Present();
00306
00307     m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
00308 }
00309
00310 void D2DTextAnimation::Uninitialize()
00311 {
00312 }
00313
00314 void D2DTextAnimation::OnWindowSizeChanged(
00315     _In_ CoreWindow^ sender,
00316     _In_ WindowSizeChangedEventArgs^ args
00317     )
00318 {
00319     UpdateForWindowSizeChange();
00320     m_sampleOverlay->UpdateForWindowSizeChange();
00321     Render();
00322     Present();
00323 }
00324
00325 void D2DTextAnimation::OnLogicalDpiChanged(
00326     _In_ Platform::Object^ sender
00327     )
00328 {
00329     SetDpi(DisplayProperties::LogicalDpi);
00330     Render();
00331     Present();
00332 }
00333
00334 void D2DTextAnimation::OnDisplayContentsInvalidated(
00335     _In_ Platform::Object^ sender
00336     )
00337 {
00338     // Ensure the D3D Device is available for rendering.
00339     ValidateDevice();
00340
00341     Render();
00342     Present();
00343 }
00344
00345 void D2DTextAnimation::OnActivated(
00346     _In_ CoreApplicationView^ applicationView,
00347     _In_ IActivatedEventArgs^ args
00348     )
00349 {
00350     m_window->Activate();
00351 }
00352
00353 void D2DTextAnimation::OnSuspending(
00354     _In_ Platform::Object^ sender,
00355     _In_ SuspendingEventArgs^ args
00356     )
00357 {
00358     // Store variables in the LocalSettings collection.
00359     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00360
00361     if (settingsValues->HasKey("m_viewPosition"))
00362     {
00363         settingsValues->Remove("m_viewPosition");
00364     }
00365     settingsValues->Insert("m_viewPosition", PropertyValue::CreatePoint(m_viewPosition));
00366
00367     if (settingsValues->HasKey("m_zoom"))
00368     {
00369         settingsValues->Remove("m_zoom");
00370     }
00371     settingsValues->Insert("m_zoom", PropertyValue::CreateSingle(m_zoom));
00372
00373     if (settingsValues->HasKey("m_firstRun"))
00374     {
00375         settingsValues->Remove("m_firstRun");
00376     }
00377     settingsValues->Insert("m_firstRun", PropertyValue::CreateBoolean(m_firstRun));
00378 }
00379
00380 void D2DTextAnimation::OnPointerPressed(
00381     _In_ CoreWindow^ window,
00382     _In_ PointerEventArgs^ args
00383     )
00384 {
00385     m_gestureRecognizer->ProcessDownEvent(args->CurrentPoint);
00386 }
00387
00388 void D2DTextAnimation::OnPointerReleased(
00389     _In_ CoreWindow^ window,
00390     _In_ PointerEventArgs^ args
00391     )
00392 {
00393     m_gestureRecognizer->ProcessUpEvent(args->CurrentPoint);
00394 }
00395
00396 void D2DTextAnimation::OnPointerMoved(
00397     _In_ CoreWindow^ window,
00398     _In_ PointerEventArgs^ args
00399     )
00400 {
00401     m_gestureRecognizer->ProcessMoveEvents(args->GetIntermediatePoints());
00402 }
00403
00404 void D2DTextAnimation::OnPointerWheelChanged(
00405     _In_ CoreWindow^ window,
00406     _In_ PointerEventArgs^ args
00407     )
00408 {
00409     // Always zoom when the mouse wheel is used.
00410     m_gestureRecognizer->ProcessMouseWheelEvent(args->CurrentPoint, false, true);
00411 }
00412
00413 void D2DTextAnimation::OnTapped(
00414     _In_ GestureRecognizer^ gestureRecognizer,
00415     _In_ TappedEventArgs^ args
00416     )
00417 {
00418     if (args->TapCount == 2)
00419     {
00420         // A double tap means we should recenter.
00421         CalculateCenterPosition();
00422         m_zoom = StartZoom;
00423
00424         Render();
00425         Present();
00426     }
00427 }
00428
00429 void D2DTextAnimation::OnManipulationUpdated(
00430     _In_ GestureRecognizer^ gestureRecognizer,
00431     _In_ ManipulationUpdatedEventArgs^ args
00432     )
00433 {
00434     Point position = args->Position;
00435     Point positionDelta = args->Delta.Translation;
00436     float zoomDelta = args->Delta.Scale;
00437
00438     // In this method, we simply update the transformation variables to reflect how the user is manipulating the scene.
00439     // The gesture recognizer does the majority of the math; we simply need to update our internal variables.
00440
00441     // Reposition the view to reflect translations.
00442     m_viewPosition.X += positionDelta.X;
00443     m_viewPosition.Y += positionDelta.Y;
00444
00445     // We want to have any zoom operation be "centered" around the pointer position, which
00446     // requires recalculating the view position based on the new zoom and pointer position.
00447     // Step 1: Calculate the absolute pointer position (image position).
00448     D2D1_POINT_2F pointerAbsolutePosition = D2D1::Point2F(
00449         (m_viewPosition.X - position.X) / m_zoom,
00450         (m_viewPosition.Y - position.Y) / m_zoom
00451         );
00452
00453     // Step 2: Apply the zoom operation and clamp to the min/max zoom.
00454     // zoomDelta is a coefficient for the change in zoom.
00455     m_zoom *= zoomDelta;
00456     m_zoom = Clamp(m_zoom, MinZoom, MaxZoom);
00457
00458     // Step 3: Adjust the view position based on the new m_zoom value.
00459     m_viewPosition.X = pointerAbsolutePosition.x * m_zoom + position.X;
00460     m_viewPosition.Y = pointerAbsolutePosition.y * m_zoom + position.Y;
00461
00462     // When the user is manipulating text via a gesture, text should be rendered using the opacity mask method.
00463     m_animating = true;
00464
00465     Render();
00466     Present();
00467 }
00468
00469 void D2DTextAnimation::OnManipulationCompleted(
00470     _In_ GestureRecognizer^ gestureRecognizer,
00471     _In_ ManipulationCompletedEventArgs^ args
00472     )
00473 {
00474     // Once the user has finished a gesture, text should be rendered using the default method.
00475     m_animating = false;
00476
00477     Render();
00478     Present();
00479 }
00480
00481 IFrameworkView^ DirectXAppSource::CreateView()
00482 {
00483     return ref new D2DTextAnimation();
00484 }
00485
00486 [Platform::MTAThread]
00487 int main(Platform::Array<Platform::String^>^)
00488 {
00489     auto directXAppSource = ref new DirectXAppSource();
00490     CoreApplication::Run(directXAppSource);
00491     return 0;
00492 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/App.xaml.cpp Source File

  • Transcoding media

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Level2 Member List

This is the complete list of members for Level2, including all inherited members.
__pad0__ | Level2 |
Initialize(std::vector< GameObject^> objects) override | Level2 | [virtual]
Initialize(std::vector< GameObject^> objects) override | Level2 | [virtual]
LoadState(PersistentState^state) override | Level2 | [virtual]
LoadState(PersistentState^state) override | Level2 | [virtual]
m_nextId | Level2 | [private]
SaveState(PersistentState^state) override | Level2 | [virtual]
SaveState(PersistentState^state) override | Level2 | [virtual]
Update(float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override | Level2 | [virtual]
Update(float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override | Level2 | [virtual]
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/NonTouchableTextBlock.xaml.cpp Source File

  • Input Touch keyboard

NonTouchableTextBlock.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // NonTouchableTextBlock.xaml.cpp
00010 // Implementation of the NonTouchableTextBlock class
00011 //
00012
00013 #include "pch.h"
00014 #include "NonTouchableTextBlock.xaml.h"
00015
00016 using namespace SDKSample::TouchKeyboard;
00017
00018 using namespace Platform;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Controls::Primitives;
00024 using namespace Windows::UI::Xaml::Data;
00025 using namespace Windows::UI::Xaml::Input;
00026 using namespace Windows::UI::Xaml::Media;
00027 using namespace Windows::UI::Xaml::Navigation;
00028 using namespace Windows::UI::Xaml::Automation::Peers;     // needed for FrameworkElementAutomationPeer class
00029
00030 namespace SDKSample
00031 {
00032     namespace TouchKeyboard
00033     {
00034       /// <summary>
00035       /// Automation Peer class for NonTouchableTextBlock.
00036       ///
00037       /// Note: The difference between this and TouchableTextBlockAutomationPeer is that this one does not implement
00038       /// Text Pattern (ITextProvider) and Value Pattern (IValuePattern) interfaces.  So Touch keyboard does not show
00039       /// automatically when user taps on the control with Touch or Pen.
00040       /// </summary>
00041       [Windows::Foundation::Metadata::WebHostHidden]
00042       public ref class NonTouchableTextBlockAutomationPeer sealed : FrameworkElementAutomationPeer
00043       {
00044       public:
00045
00046         NonTouchableTextBlockAutomationPeer(NonTouchableTextBlock^ owner)
00047           : FrameworkElementAutomationPeer(owner)
00048         {
00049           this->textBlock = owner;
00050           this->accClass = "NonTouchableTextBlock";
00051         }
00052       protected:
00053         /// <summary>
00054         /// Override GetClassNameCore and set the name of the class that defines the type associated with this control.
00055         /// </summary>
00056         /// <returns>The name of the control class</returns>
00057         virtual String^ GetClassNameCore() override
00058         {
00059           return this->accClass;
00060         }
00061
00062       private:
00063         NonTouchableTextBlock^ textBlock;
00064         String^ accClass;
00065
00066       };
00067
00068       // The User Control item template is documented at http://go.microsoft.com/fwlink/?LinkId=234236
00069
00070       /// <summary>
00071       /// Loads the XAML UI contents and set properties required for this custom control.
00072       /// </summary>
00073       NonTouchableTextBlock::NonTouchableTextBlock()
00074       {
00075         InitializeComponent();
00076         this->IsTabStop = true;
00077         this->IsTapEnabled = true;
00078       }
00079
00080       /// <summary>
00081       /// Create the Automation peer implementations for custom control (CustomInputBox2) to provide the accessibility support.
00082       /// </summary>
00083       /// <returns>Automation Peer implementation for this control</returns>
00084       AutomationPeer^ NonTouchableTextBlock::OnCreateAutomationPeer()
00085       {
00086         return ref new NonTouchableTextBlockAutomationPeer(this);
00087       }
00088
00089       /// <summary>
00090       /// Override the default event handler for GotFocus.
00091       /// When the control got focus, indicate it has focus by highlighting the control by changing the background color to yellow.
00092       /// </summary>
00093       /// <param name="e">State information and event data associated with GotFocus event.</param>
00094       void NonTouchableTextBlock::OnGotFocus(RoutedEventArgs^ e)
00095       {
00096         this->myBorder->Background = ref new SolidColorBrush(Windows::UI::Colors::Yellow);
00097       }
00098
00099       /// <summary>
00100       /// Override the default event handler for LostFocus.
00101       /// When the control lost focus, indicate it does not have focus by changing the background color to gray.
00102       /// And the content is cleared.
00103       /// </summary>
00104       /// <param name="e">State information and event data associated with LostFocus event.</param>
00105       void NonTouchableTextBlock::OnLostFocus(RoutedEventArgs^ e)
00106       {
00107         this->myBorder->Background = ref new SolidColorBrush(Windows::UI::Colors::Gray);
00108         this->myTextBlock->Text = "";
00109       }
00110
00111       /// <summary>
00112       /// Override the default event handler for Tapped.
00113       /// Set input focus to the control when tapped on.
00114       /// </summary>
00115       /// <param name="e">State information and event data associated with Tapped event.</param>
00116       void NonTouchableTextBlock::OnTapped(TappedRoutedEventArgs^ e)
00117       {
00118         this->Focus(Windows::UI::Xaml::FocusState::Pointer);
00119       }
00120
00121       /// <summary>
00122       /// Override the default event handler for KeyDown.
00123       /// Displays the text "A key is pressed" and the approximate time when the key is pressed.
00124       /// </summary>
00125       /// <param name="e">State information and event data associated with KeyDown event.</param>
00126       void NonTouchableTextBlock::OnKeyDown(KeyRoutedEventArgs^ e)
00127       {
00128         auto currentCalendar = ref new Windows::Globalization::Calendar();
00129         String^ timeOfDay = currentCalendar->HourAsPaddedString(2) + ":" +
00130           currentCalendar->MinuteAsPaddedString(2) + ":" +
00131           currentCalendar->SecondAsPaddedString(2);
00132         this->myTextBlock->Text = "A key was pressed @ " + timeOfDay + " ";
00133       }
00134     }
00135 }
Generated on Sat Nov 23 2024 16:08:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/pch.h Source File

  • XAML personality animations

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario4.xaml.cpp Source File

  • XAML vector-based drawing

Scenario4.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.cpp
00013 // Implementation of the Scenario4 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario4.xaml.h"
00018
00019 using namespace SDKSample::Drawing;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario4::Scenario4()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 // Invoked when this page is about to be displayed in a Frame.
00031 void Scenario4::OnNavigatedTo(NavigationEventArgs^ e)
00032 {
00033     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00034     // as NotifyUser()
00035     rootPage = MainPage::Current;
00036 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/Scenario2.xaml.h Source File

  • Connecting with WebSockets

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Platform;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::Networking::Sockets;
00025 using namespace Windows::Storage::Streams;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::Web;
00030
00031 namespace SDKSample
00032 {
00033     namespace WebSocket
00034     {
00035         /// <summary>
00036         /// An empty page that can be used on its own or navigated to within a Frame.
00037         /// </summary>
00038       [Windows::Foundation::Metadata::WebHostHidden]
00039         public ref class Scenario2 sealed
00040         {
00041         public:
00042             Scenario2();
00043
00044         protected:
00045             virtual void OnNavigatedTo(NavigationEventArgs^ e) override;
00046         private:
00047             ~Scenario2();
00048
00049         MainPage^ rootPage;
00050             StreamWebSocket^ streamWebSocket;
00051             IBuffer^ readBuffer;
00052             IBuffer^ sendBuffer;
00053             int bytesReceived;
00054             int dataSent;
00055             CRITICAL_SECTION criticalSection;
00056
00057             void Start_Click(Object^ sender, RoutedEventArgs^ e);
00058             void Stop_Click(Object^ sender, RoutedEventArgs^ e);
00059             void Scenario2ReceiveData();
00060             void Scenario2SendData();
00061             void Scenario2Closed(IWebSocket^ sender, WebSocketClosedEventArgs^ args);
00062             void HandleException(Exception^ exception);
00063             void MarshalText(TextBox^ output, String^ value);
00064             void MarshalText(TextBox^ output, String^ value, bool append);
00065         };
00066     }
00067 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/MainPage.xaml.h Source File

  • Message dialog

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/DirectXBase.cpp Source File

  • XAML Direct2D lighting effects

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace Windows::UI::Xaml::Controls;
00016 using namespace D2D1;
00017
00018 // Constructor.
00019 DirectXBase::DirectXBase() :
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(
00026     CoreWindow^ window,
00027     SwapChainBackgroundPanel^ swapChainPanel,
00028     float dpi
00029     )
00030 {
00031     m_window = window;
00032     m_swapChainPanel = swapChainPanel;
00033
00034     CreateDeviceIndependentResources();
00035     CreateDeviceResources();
00036     SetDpi(dpi);
00037 }
00038
00039 // Recreate all device resources and set them back to the current state.
00040 void DirectXBase::HandleDeviceLost()
00041 {
00042     // Reset these member variables to ensure that SetDpi recreates all resources.
00043     float dpi = m_dpi;
00044     m_dpi = -1.0f;
00045     m_windowBounds.Width = 0;
00046     m_windowBounds.Height = 0;
00047     m_swapChain = nullptr;
00048
00049     CreateDeviceResources();
00050     SetDpi(dpi);
00051 }
00052
00053 // These are the resources required independent of the device.
00054 void DirectXBase::CreateDeviceIndependentResources()
00055 {
00056     D2D1_FACTORY_OPTIONS options;
00057     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00058
00059 #if defined(_DEBUG)
00060     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00061     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00062 #endif
00063
00064     DX::ThrowIfFailed(
00065         D2D1CreateFactory(
00066             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00067             __uuidof(ID2D1Factory1),
00068             &options,
00069             &m_d2dFactory
00070             )
00071         );
00072
00073     DX::ThrowIfFailed(
00074         DWriteCreateFactory(
00075             DWRITE_FACTORY_TYPE_SHARED,
00076             __uuidof(IDWriteFactory),
00077             &m_dwriteFactory
00078             )
00079         );
00080
00081     DX::ThrowIfFailed(
00082         CoCreateInstance(
00083             CLSID_WICImagingFactory,
00084             nullptr,
00085             CLSCTX_INPROC_SERVER,
00086             IID_PPV_ARGS(&m_wicFactory)
00087             )
00088         );
00089 }
00090
00091 // These are the resources that depend on the device.
00092 void DirectXBase::CreateDeviceResources()
00093 {
00094     // This flag adds support for surfaces with a different color channel ordering
00095     // than the API default. It is required for compatibility with Direct2D.
00096     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00097     ComPtr<IDXGIDevice> dxgiDevice;
00098
00099 #if defined(_DEBUG)
00100     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00101     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00102 #endif
00103
00104     // This array defines the set of DirectX hardware feature levels this app will support.
00105     // Note the ordering should be preserved.
00106     // Don't forget to declare your application's minimum required feature level in its
00107     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00108     D3D_FEATURE_LEVEL featureLevels[] =
00109     {
00110         D3D_FEATURE_LEVEL_11_1,
00111         D3D_FEATURE_LEVEL_11_0,
00112         D3D_FEATURE_LEVEL_10_1,
00113         D3D_FEATURE_LEVEL_10_0,
00114         D3D_FEATURE_LEVEL_9_3,
00115         D3D_FEATURE_LEVEL_9_2,
00116         D3D_FEATURE_LEVEL_9_1
00117     };
00118
00119     // Create the Direct3D 11 API device object and a corresponding context.
00120     ComPtr<ID3D11Device> device;
00121     ComPtr<ID3D11DeviceContext> context;
00122     DX::ThrowIfFailed(
00123         D3D11CreateDevice(
00124             nullptr,                    // Specify nullptr to use the default adapter.
00125             D3D_DRIVER_TYPE_HARDWARE,
00126             0,
00127             creationFlags,              // Set debug and Direct2D compatibility flags.
00128             featureLevels,              // List of feature levels this app can support.
00129             ARRAYSIZE(featureLevels),
00130             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00131             &device,                    // Returns the Direct3D device created.
00132             &m_featureLevel,            // Returns feature level of device created.
00133             &context                    // Returns the device immediate context.
00134             )
00135         );
00136
00137     // Get the Direct3D 11.1 API device and context interfaces.
00138     DX::ThrowIfFailed(
00139         device.As(&m_d3dDevice)
00140         );
00141
00142     DX::ThrowIfFailed(
00143         context.As(&m_d3dContext)
00144         );
00145
00146     // Get the underlying DXGI device of the Direct3D device.
00147     DX::ThrowIfFailed(
00148         m_d3dDevice.As(&dxgiDevice)
00149         );
00150
00151     // Create the Direct2D device object and a corresponding context.
00152     DX::ThrowIfFailed(
00153         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00154         );
00155
00156     DX::ThrowIfFailed(
00157         m_d2dDevice->CreateDeviceContext(
00158             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00159             &m_d2dContext
00160             )
00161         );
00162 }
00163
00164 // Helps track the DPI in the helper class.
00165 // This is called in the dpiChanged event handler in the view class.
00166 void DirectXBase::SetDpi(float dpi)
00167 {
00168     if (dpi != m_dpi)
00169     {
00170         // Save the DPI of this display in our class.
00171         m_dpi = dpi;
00172
00173         // Update Direct2D's stored DPI.
00174         m_d2dContext->SetDpi(m_dpi, m_dpi);
00175
00176         // Often a DPI change implies a window size change. In some cases Windows will issue
00177         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00178         // will not change, and the window resize code will only be executed once.
00179         UpdateForWindowSizeChange();
00180     }
00181 }
00182
00183 // This routine is called in the event handler for the view SizeChanged event.
00184 void DirectXBase::UpdateForWindowSizeChange()
00185 {
00186     // Only handle window size changed if there is no pending DPI change.
00187     if (m_dpi != DisplayProperties::LogicalDpi)
00188     {
00189         return;
00190     }
00191
00192     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00193         m_window->Bounds.Height != m_windowBounds.Height)
00194     {
00195         m_d2dContext->SetTarget(nullptr);
00196         m_d2dTargetBitmap = nullptr;
00197         m_d3dRenderTargetView = nullptr;
00198         m_d3dDepthStencilView = nullptr;
00199         CreateWindowSizeDependentResources();
00200     }
00201 }
00202
00203 // Allocate all memory resources that change on a window SizeChanged event.
00204 void DirectXBase::CreateWindowSizeDependentResources()
00205 {
00206     // Store the window bounds so the next time we get a SizeChanged event we can
00207     // avoid rebuilding everything if the size is identical.
00208     m_windowBounds = m_window->Bounds;
00209
00210     // If the swap chain already exists, resize it.
00211     if (m_swapChain != nullptr)
00212     {
00213         HRESULT hr = m_swapChain->ResizeBuffers(
00214             2,
00215             static_cast<UINT>(m_window->Bounds.Width * m_dpi / 96.0f), // Can not use 0 to get the default on Composition SwapChain.
00216             static_cast<UINT>(m_window->Bounds.Height * m_dpi / 96.0f),
00217             DXGI_FORMAT_B8G8R8A8_UNORM,
00218             0
00219             );
00220
00221         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00222         {
00223             // If the device was removed for any reason, a new device and swapchain will need to be created.
00224             HandleDeviceLost();
00225
00226             // Everything is set up now. Do not continue execution of this method.
00227             return;
00228         }
00229         else
00230         {
00231             DX::ThrowIfFailed(hr);
00232         }
00233     }
00234     else // If it does not exist, create it.
00235     {
00236         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00237         swapChainDesc.Width = static_cast<UINT>(m_window->Bounds.Width * m_dpi / 96.0f); // Can not use 0 to get the default on Composition SwapChain.
00238         swapChainDesc.Height = static_cast<UINT>(m_window->Bounds.Height * m_dpi / 96.0f);
00239         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // Use the recommended color format.
00240         swapChainDesc.Stereo = false;
00241         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00242         swapChainDesc.SampleDesc.Quality = 0;
00243         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT; // Allow it to be used as a render target.
00244         swapChainDesc.BufferCount = 2;                               // Use double buffering to enable flip effect.
00245         swapChainDesc.Scaling = DXGI_SCALING_STRETCH;
00246         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // This is the recommended swap effect.
00247         swapChainDesc.Flags = 0;
00248
00249         // Once the desired swap chain description is configured, it must be created on the same adapter as our D3D Device.
00250
00251         // First, retrieve the underlying DXGI Device from the D3D Device.
00252         ComPtr<IDXGIDevice1> dxgiDevice;
00253         DX::ThrowIfFailed(
00254             m_d3dDevice.As(&dxgiDevice)
00255             );
00256
00257         // Next, get the associated adapter from the DXGI Device.
00258         ComPtr<IDXGIAdapter> dxgiAdapter;
00259         DX::ThrowIfFailed(
00260             dxgiDevice->GetAdapter(&dxgiAdapter)
00261             );
00262
00263         // Next, get the parent factory from the DXGI adapter.
00264         ComPtr<IDXGIFactory2> dxgiFactory;
00265         DX::ThrowIfFailed(
00266             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00267             );
00268
00269         // Create the swap chain and then associate it with the SwapChainBackgroundPanel.
00270         DX::ThrowIfFailed(
00271             dxgiFactory->CreateSwapChainForComposition(
00272                 m_d3dDevice.Get(),
00273                 &swapChainDesc,
00274                 nullptr,
00275                 &m_swapChain
00276                 )
00277             );
00278
00279         ComPtr<ISwapChainBackgroundPanelNative> dxRootPanelAsSwapChainBackgroundPanel;
00280
00281         // Set the swap chain on the SwapChainBackgroundPanel.
00282         reinterpret_cast<IUnknown*>(m_swapChainPanel)->QueryInterface(
00283             IID_PPV_ARGS(&dxRootPanelAsSwapChainBackgroundPanel)
00284             );
00285
00286         DX::ThrowIfFailed(
00287             dxRootPanelAsSwapChainBackgroundPanel->SetSwapChain(m_swapChain.Get())
00288             );
00289
00290         // Ensure that DXGI does not queue more than one frame at a time. This both reduces
00291         // latency and ensures that the application will only render after each VSync, minimizing
00292         // power consumption.
00293         DX::ThrowIfFailed(
00294             dxgiDevice->SetMaximumFrameLatency(1)
00295             );
00296     }
00297
00298     // Create a view on the swap chain back buffer.
00299     ComPtr<ID3D11Texture2D> backBuffer;
00300     DX::ThrowIfFailed(
00301         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00302         );
00303
00304     D3D11_RENDER_TARGET_VIEW_DESC renderTargetViewDesc = {};
00305     renderTargetViewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00306     renderTargetViewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2DARRAY;        // Render target view is a Texture2D array.
00307     renderTargetViewDesc.Texture2DArray.MipSlice = 0;                               // Each array element is one Texture2D.
00308     renderTargetViewDesc.Texture2DArray.ArraySize = 1;
00309     renderTargetViewDesc.Texture2DArray.FirstArraySlice = 0;
00310     DX::ThrowIfFailed(
00311         m_d3dDevice->CreateRenderTargetView(
00312             backBuffer.Get(),
00313             &renderTargetViewDesc,
00314             &m_d3dRenderTargetView
00315             )
00316         );
00317
00318     // Get the back buffer description for later use.
00319     D3D11_TEXTURE2D_DESC backBufferDesc;
00320     backBuffer->GetDesc(&backBufferDesc);
00321
00322     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00323     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00324
00325     D2D1_BITMAP_PROPERTIES1 bitmapProperties = {};
00326     bitmapProperties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
00327     bitmapProperties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
00328     bitmapProperties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
00329     bitmapProperties.colorContext = nullptr;
00330     bitmapProperties.dpiX = m_dpi;
00331     bitmapProperties.dpiY = m_dpi;
00332
00333     ComPtr<IDXGIResource1> dxgiBackBuffer;
00334     DX::ThrowIfFailed(
00335         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00336         );
00337
00338     ComPtr<IDXGISurface2> dxgiSurface;
00339     DX::ThrowIfFailed(
00340         dxgiBackBuffer->CreateSubresourceSurface(0, &dxgiSurface)
00341         );
00342
00343     DX::ThrowIfFailed(
00344         m_d2dContext->CreateBitmapFromDxgiSurface(
00345             dxgiSurface.Get(),
00346             &bitmapProperties,
00347             &m_d2dTargetBitmap
00348             )
00349         );
00350
00351     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00352 }
00353
00354 // Method to deliver the final image to the display.
00355 void DirectXBase::Present()
00356 {
00357     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00358     // in certain scenarios.  In this sample, however, we do not utilize those features.
00359     DXGI_PRESENT_PARAMETERS parameters = {0};
00360     parameters.DirtyRectsCount = 0;
00361     parameters.pDirtyRects = nullptr;
00362     parameters.pScrollRect = nullptr;
00363     parameters.pScrollOffset = nullptr;
00364
00365     // The first argument instructs DXGI to block until VSync, putting the application
00366     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00367     // frames that will never be displayed to the screen.
00368     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00369
00370     // If the device was removed either by a disconnect or a driver upgrade, we
00371     // must recreate all device resources.
00372     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00373     {
00374         HandleDeviceLost();
00375     }
00376     else
00377     {
00378         DX::ThrowIfFailed(hr);
00379     }
00380 }
00381
00382 void DirectXBase::ValidateDevice()
00383 {
00384     // The D3D Device is no longer valid if the default adapter changes or if
00385     // the device has been removed.
00386
00387     // First, get the information for the adapter related to the current device.
00388
00389     ComPtr<IDXGIDevice1> dxgiDevice;
00390     ComPtr<IDXGIAdapter> deviceAdapter;
00391     DXGI_ADAPTER_DESC deviceDesc;
00392     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00393     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00394     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00395
00396     // Next, get the information for the default adapter.
00397
00398     ComPtr<IDXGIFactory2> dxgiFactory;
00399     ComPtr<IDXGIAdapter1> currentAdapter;
00400     DXGI_ADAPTER_DESC currentDesc;
00401     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00402     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00403     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00404
00405     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00406     // a new D3D device must be created.
00407
00408     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00409         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00410         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00411     {
00412         // Release references to resources related to the old device.
00413         dxgiDevice = nullptr;
00414         deviceAdapter = nullptr;
00415
00416         // Create a new device and swap chain.
00417         HandleDeviceLost();
00418     }
00419 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S5_Events.xaml.cpp Source File

  • Portable device API

S5_Events.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // S5_Events.xaml.cpp
00013 // Implementation of the S5_Events class
00014 //
00015
00016 #include "pch.h"
00017 #include "Constants.h"
00018 #include "EventCallback.h"
00019 #include "S5_Events.xaml.h"
00020
00021 using namespace SDKSample::PortableDeviceCPP;
00022
00023 using namespace concurrency;
00024 using namespace Microsoft::WRL;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Devices::Enumeration;
00028 using namespace Windows::Foundation;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Navigation;
00033
00034 S5_Events::S5_Events() : rootPage(MainPage::Current)
00035 {
00036     InitializeComponent();
00037 }
00038
00039 /// <summary>
00040 /// Invoked when this page is about to be displayed in a Frame.
00041 /// </summary>
00042 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00043 /// property is typically used to configure the page.</param>
00044 void S5_Events::OnNavigatedTo(NavigationEventArgs^ e)
00045 {
00046     DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00047     ScenarioOutput->Text = "";
00048     if (IsRegisteredForDeviceEvents())
00049     {
00050         ScenarioInput->Content = "Unregister for Events";
00051         ScenarioEventTrigger->IsEnabled = true;
00052     }
00053     else
00054     {
00055         ScenarioInput->Content = "Register for Events";
00056         ScenarioEventTrigger->IsEnabled = false;
00057     }
00058 }
00059
00060 /// <summary>
00061 /// Invoked when this page is no longer displayed.
00062 /// </summary>
00063 /// <param name="e></param>
00064 void S5_Events::OnNavigatedFrom(NavigationEventArgs^ e)
00065 {
00066     // Clean up the existing device event registration, if any.
00067     if (IsRegisteredForDeviceEvents())
00068     {
00069         UnregisterForDeviceEvents();
00070     }
00071 }
00072
00073
00074 /// <summary>
00075 /// This is the click handler for the 'Run' button.
00076 /// </summary>
00077 /// <param name="sender"></param>
00078 /// <param name="e"></param>
00079 void S5_Events::Run_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00080 {
00081     ScenarioOutput->Text = "";
00082     if (IsRegisteredForDeviceEvents())
00083     {
00084         UnregisterForDeviceEvents();
00085     }
00086     else
00087     {
00088         ShowDeviceSelectorAsync();
00089     }
00090 }
00091
00092 /// <summary>
00093 /// This is the click handler for the 'Trigger Events' button.
00094 /// </summary>
00095 /// <param name="sender"></param>
00096 /// <param name="e"></param>
00097 void S5_Events::Trigger_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00098 {
00099     if (IsRegisteredForDeviceEvents())
00100     {
00101         CreateAndThenDeleteFolderOnDeviceAsync();
00102     }
00103 }
00104
00105 /// <summary>
00106 /// Enumerates all portable devices and populates the device selection list.
00107 /// </summary>
00108 void S5_Events::ShowDeviceSelectorAsync()
00109 {
00110     _deviceInfoCollection = nullptr;
00111
00112     // Find all portable devices
00113     String^ aqsFilter = "System.Devices.InterfaceClassGuid:=\"{6AC27878-A6FA-4155-BA85-F98F491D4F33}\" AND System.Devices.InterfaceEnabled:=System.StructuredQueryType.Boolean#True";
00114     create_task(DeviceInformation::FindAllAsync(aqsFilter)).then([this] (DeviceInformationCollection^ deviceInfoCollection)
00115     {
00116         _deviceInfoCollection = deviceInfoCollection;
00117         if (_deviceInfoCollection->Size > 0)
00118         {
00119             auto items = ref new Vector<String^>();
00120             std::for_each(begin(_deviceInfoCollection), end(_deviceInfoCollection), [items](IDeviceInformation^ deviceInfoElement)
00121             {
00122                 items->Append(ref new String(deviceInfoElement->Name->Begin()));
00123             });
00124             cvs->Source = items;
00125             DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Visible;
00126         }
00127         else
00128         {
00129             rootPage->NotifyUser("No portable devices were found. Please attach a portable device to the system (e.g. a camera, music player, or cellular phone)", NotifyType::ErrorMessage);
00130         }
00131     });
00132 }
00133
00134 /// <summary>
00135 /// This is the tapped handler for the device selection list. It runs the scenario
00136 /// for the selected portable device.
00137 /// </summary>
00138 /// <param name="sender"></param>
00139 /// <param name="e"></param>
00140 void S5_Events::DeviceList_Tapped(Platform::Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e)
00141 {
00142     DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00143     if (_deviceInfoCollection == nullptr)
00144     {
00145         return; // not yet populated
00146     }
00147
00148     auto deviceInfo = _deviceInfoCollection->GetAt(DeviceList->SelectedIndex);
00149     RegisterForDeviceEvents(deviceInfo);
00150 }
00151
00152 /// <summary>
00153 /// Registers to receive events from a portable device.
00154 /// </summary>
00155 /// <param name="deviceInfoElement">Contains information about a selected device.</param>
00156 void S5_Events::RegisterForDeviceEvents(DeviceInformation^ deviceInfoElement)
00157 {
00158     ThrowIfFailed(CoCreateInstance(CLSID_PortableDeviceFTM, nullptr, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&_deviceEventSource)));
00159
00160     auto clientInfo = GetClientInfo();
00161     HRESULT hr = _deviceEventSource->Open(deviceInfoElement->Id->Begin(), clientInfo.Get());
00162     if (hr == E_ACCESSDENIED)
00163     {
00164         rootPage->NotifyUser("Access to " + deviceInfoElement->Name + " is denied. Only a Privileged Application may access this device.", NotifyType::ErrorMessage);
00165         return;
00166     }
00167     ThrowIfFailed(hr);
00168
00169     // Assign our delegate to the event callback.  The event callback is a COM object that implements IPortableDeviceEventCallback.
00170     PWSTR cookie = nullptr;
00171     auto callback = Make<EventCallback>(ref new EventReceived(this, &S5_Events::OnDeviceEventReceived));
00172
00173     // Register the callback object with the PortableDevice COM API and receive a cookie that can be used for unregistration.
00174     hr = _deviceEventSource->Advise(0, callback.Get(), nullptr, &cookie);
00175     CoTaskMemString cookiePtr(cookie);
00176     ThrowIfFailed(hr);
00177     _deviceEventCookie = ref new String(cookie);
00178
00179     rootPage->NotifyUser("Successfully registered for events (cookie '" + _deviceEventCookie + "'). Now click 'Trigger Events' to perform operations on '"
00180         + deviceInfoElement->Name + "' that can trigger the events.", NotifyType::StatusMessage);
00181
00182     ScenarioInput->Content = "Unregister for Events";
00183     ScenarioEventTrigger->IsEnabled = true;
00184 }
00185
00186 /// <summary>
00187 /// Unregisters the existing portable device event registration.
00188 /// </summary>
00189 void S5_Events::UnregisterForDeviceEvents()
00190 {
00191     if (IsRegisteredForDeviceEvents())
00192     {
00193         ThrowIfFailed(_deviceEventSource->Unadvise(_deviceEventCookie->Begin()));
00194         rootPage->NotifyUser("Successfully unregistered for events (cookie '" + _deviceEventCookie + "')", NotifyType::StatusMessage);
00195
00196         // Cleanup
00197         _deviceEventCookie = nullptr;
00198         _deviceEventSource = nullptr;
00199
00200         ScenarioInput->Content = "Register for Events";
00201         ScenarioEventTrigger->IsEnabled = false;
00202     }
00203 }
00204
00205 /// <summary>
00206 /// Event delegate that is invoked with an event is received from the device.
00207 /// </summary>
00208 /// <param name="deviceId">Identifies the device sending the event.</param>
00209 /// <param name="eventData">Contains information about the event being received.</param>
00210 void S5_Events::OnDeviceEventReceived(String^ senderDeviceId, String^ eventData)
00211 {
00212     ScenarioOutput->Text += "[Device Event] " + eventData + ", Device Id: " + senderDeviceId + "\n";
00213 }
00214
00215 /// <summary>
00216 /// Creates a folder on the first storage of a portable device and then deletes it.
00217 /// On success, this triggers the DeviceEventReceived delegate for two events:
00218 ////- 'Object Added' for the folder creation and
00219 /// - 'Object Removed' for the subsequent delete.
00220 /// </summary>
00221 /// <see cref="DeviceEventReceived"/>
00222 void S5_Events::CreateAndThenDeleteFolderOnDeviceAsync()
00223 {
00224     ScenarioOutput->Text = "";
00225     if (_deviceEventSource != nullptr)
00226     {
00227         // The event triggerring is not required to be asynchronous, but the recommendation is to move
00228         // long running operations involving devices in tasks to avoid blocking UI.
00229         create_task([this]() -> void {
00230
00231             // For demonstration purposes, open a separate IPortableDevice connection to perform the folder operations.
00232             PWSTR deviceId = nullptr;
00233             HRESULT hr = _deviceEventSource->GetPnPDeviceID(&deviceId);
00234             CoTaskMemString deviceIdPtr(deviceId);
00235             ThrowIfFailed(hr);
00236
00237             ComPtr<IPortableDevice> device;
00238             ThrowIfFailed(CoCreateInstance(CLSID_PortableDeviceFTM, nullptr, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&device)));
00239
00240             auto clientInfo = GetClientInfo();
00241             ThrowIfFailed(device->Open(deviceId, clientInfo.Get()));
00242
00243             ComPtr<IPortableDeviceContent> content;
00244             ThrowIfFailed(device->Content(&content));
00245
00246             // Create a folder on the storage and then delete it
00247             auto storageId = GetFirstStorageId(device.Get());
00248             if (storageId != nullptr)
00249             {
00250                 ComPtr<IPortableDeviceContent> content;
00251                 ThrowIfFailed(device->Content(&content));
00252
00253                 // Create a new object with properties and data
00254                 String^ statusMessage = "Creating a folder on the device to trigger the 'Object Added' event ... \n";
00255                 rootPage->DispatcherNotifyUser(statusMessage, NotifyType::StatusMessage);
00256
00257                 auto folderProperties = FillInPropertiesForFolder(storageId);
00258                 PWSTR folderId = nullptr;
00259                 hr = content->CreateObjectWithPropertiesOnly(folderProperties.Get(), // Properties describing the folder data
00260                                                              &folderId);             // Object id of the newly created folder
00261                 CoTaskMemString folderIdPtr(folderId);
00262                 if (hr == E_ACCESSDENIED)
00263                 {
00264                     rootPage->DispatcherNotifyUser("Device does not allow folder creation in storage '" + storageId + "', no events will be triggered.", NotifyType::ErrorMessage);
00265                     return;
00266                 }
00267                 ThrowIfFailed(hr);
00268                 String^ strFolderId = ref new String(folderId);
00269                 statusMessage += "New folder '" + strFolderId + "' was created. Now deleting the folder to trigger the 'Object Removed' event ...\n";
00270                 rootPage->DispatcherNotifyUser(statusMessage, NotifyType::StatusMessage);
00271
00272                 // Delete the folder object we just created
00273                 ComPtr<IPortableDevicePropVariantCollection> objectsToDelete;
00274                 ComPtr<IPortableDevicePropVariantCollection> objectsToDeleteResults;
00275                 ThrowIfFailed(CoCreateInstance(CLSID_PortableDevicePropVariantCollection, nullptr, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&objectsToDelete)));
00276
00277                 PROPVARIANT folderIdPropVariant = {};
00278                 folderIdPropVariant.vt = VT_LPWSTR;
00279                 folderIdPropVariant.pwszVal = folderId; // Assignment, don't PropVariantClear
00280
00281                 ThrowIfFailed(objectsToDelete->Add(&folderIdPropVariant));
00282                 hr = content->Delete(PORTABLE_DEVICE_DELETE_NO_RECURSION, objectsToDelete.Get(), &objectsToDeleteResults);
00283                 if (hr == S_OK)
00284                 {
00285                     statusMessage += "New folder '" + strFolderId + "' was deleted.\n";
00286                     rootPage->DispatcherNotifyUser(statusMessage, NotifyType::StatusMessage);
00287                 }
00288                 else if (hr == S_FALSE)
00289                 {
00290                     PROPVARIANT deleteResult = {};
00291                     ThrowIfFailed(objectsToDeleteResults->GetAt(0, &deleteResult));
00292                     rootPage->DispatcherNotifyUser("New folder '" + strFolderId + "' failed to be deleted, delete result = " + deleteResult.scode.ToString(), NotifyType::ErrorMessage);
00293                 }
00294                 ThrowIfFailed(hr);
00295             }
00296             else
00297             {
00298                 rootPage->DispatcherNotifyUser("No storages were found on the device. Please attach a device with at least 1 storage.", NotifyType::ErrorMessage);
00299             }
00300
00301         }).then([this] (task<void> thisTask)
00302         {
00303             // Handle errors from the task. We're catching all exceptions here because the device may return any failure HRESULT.
00304             try
00305             {
00306                 thisTask.get();
00307             }
00308             catch (Exception^ e)
00309             {
00310                 rootPage->DispatcherNotifyUser("Creating and deleting a new folder failed with error: " + e->Message, NotifyType::ErrorMessage);
00311             }
00312         });
00313     }
00314 }
00315
00316 /// <summary>
00317 /// Returns an IPortableDeviceValues containing properties used for creating a folder object on the device.
00318 /// </summary>
00319 /// <param name="parentId">The parent object identifier for the new image object.</param>
00320 /// <returns>IPortableDeviceValues ComPtr containing the folder object property keys and values.</returns>
00321 ComPtr<IPortableDeviceValues> S5_Events::FillInPropertiesForFolder(String^ parentId)
00322 {
00323     ComPtr<IPortableDeviceValues> result;
00324     ThrowIfFailed(CoCreateInstance(CLSID_PortableDeviceValues, nullptr, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&result)));
00325
00326     ThrowIfFailed(result->SetStringValue(WPD_OBJECT_PARENT_ID, parentId->Begin()));
00327     ThrowIfFailed(result->SetStringValue(WPD_OBJECT_NAME, L"My new folder"));
00328     ThrowIfFailed(result->SetStringValue(WPD_OBJECT_ORIGINAL_FILE_NAME, L"New folder"));
00329     ThrowIfFailed(result->SetGuidValue(WPD_OBJECT_FORMAT, WPD_OBJECT_FORMAT_PROPERTIES_ONLY));
00330     ThrowIfFailed(result->SetGuidValue(WPD_OBJECT_CONTENT_TYPE, WPD_CONTENT_TYPE_FOLDER));
00331
00332     return result;
00333 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Finally Member List

This is the complete list of members for SDKSample::Finally, including all inherited members.
Finally(std::function< void()> f) | SDKSample::Finally | [inline]
finallyClause | SDKSample::Finally | [private]
~Finally() | SDKSample::Finally | [inline]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicTimer.cpp Source File

  • Direct3D HLSL fractal generator

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario3.xaml.cpp Source File

  • XAML data binding

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018 #include "Employee.h"
00019
00020 using namespace SDKSample::DataBinding;
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025
00026 Scenario3::Scenario3()
00027 {
00028
00029   InitializeComponent();
00030
00031   _employee = ref new Employee();
00032   Output->DataContext = _employee;
00033   _employee->PropertyChanged += ref new PropertyChangedEventHandler(this, &Scenario3::employeeChanged);
00034
00035   Scenario3Reset(nullptr,nullptr);
00036 }
00037
00038 void SDKSample::DataBinding::Scenario3::Scenario3Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00039 {
00040   _employee->Name = "Jane Doe";
00041   _employee->Organization = "Contoso";
00042
00043   tbBoundDataModelStatus->Text = "";
00044 }
00045
00046 void Scenario3::employeeChanged(Object^ sender, PropertyChangedEventArgs^ e)
00047 {
00048   tbBoundDataModelStatus->Text = "The property:'" + e->PropertyName + "' was changed";
00049 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioList.xaml.cpp Source File

  • Toast notifications
  • C#,C++

ScenarioList.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioList.xaml.cpp
00010 // Implementation of the ScenarioList class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioList.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace ToastsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031 using namespace Windows::UI::Xaml::Interop;
00032
00033 ScenarioList::ScenarioList()
00034 {
00035     InitializeComponent();
00036 }
00037
00038 ScenarioList::~ScenarioList()
00039 {
00040 }
00041
00042 void ScenarioList::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00043 {
00044     if(Scenarios->SelectedItem != nullptr)
00045     {
00046         rootPage->NotifyUser("", NotifyType::StatusMessage);
00047
00048         ListBoxItem^ selectedListBoxItem = dynamic_cast<ListBoxItem^>(Scenarios->SelectedItem);
00049         SuspensionManager::SessionState()->Insert("SelectedScenario", selectedListBoxItem->Name);
00050
00051         if (rootPage->InputFrame != nullptr && rootPage->OutputFrame != nullptr)
00052         {
00053              //Load the input and output pages for the current scenario into their respective frames
00054             TypeName inputPage = { "ToastsSampleCPP" + "." + "ScenarioInput" + ((Scenarios->SelectedIndex + 1).ToString()), TypeKind::Custom };
00055             TypeName outputPage = { "ToastsSampleCPP" + "." + "ScenarioOutput" + ((Scenarios->SelectedIndex + 1).ToString()), TypeKind::Custom };
00056             rootPage->DoNavigation(inputPage, rootPage->InputFrame);
00057             rootPage->DoNavigation(outputPage, rootPage->OutputFrame);
00058         }
00059     }
00060 }
00061
00062 void ScenarioList::OnNavigatedTo(NavigationEventArgs^ e)
00063 {
00064     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00065
00066     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &ScenarioList::Scenarios_SelectionChanged);
00067     ListBoxItem^ startingScenario = nullptr;
00068
00069     auto ps = SuspensionManager::SessionState();
00070     if (ps->HasKey("SelectedScenario"))
00071     {
00072         PropertyValue^ pv;
00073         String^ item = dynamic_cast<String^>(ps->Lookup("SelectedScenario"));
00074         startingScenario = dynamic_cast<ListBoxItem^>(this->FindName(item));
00075     }
00076
00077     Scenarios->SelectedItem = startingScenario != nullptr ? startingScenario : Scenario1;
00078 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CropImageViewModel.h Source File

  • Hilo C++
  • Hilo

CropImageViewModel.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "ImageBase.h"
00010
00011 namespace Hilo
00012 {
00013     interface class IPhoto;
00014     class ImageNavigationData;
00015     class Repository;
00016     class ExceptionPolicy;
00017
00018     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how view model classes interact
00019     // with view classes (pages) and model classes (the state and operations of business objects).
00020
00021     // The CropImageViewModel class contains the presentation logic for the crop image page.
00022     [Windows::UI::Xaml::Data::Bindable]
00023     [Windows::Foundation::Metadata::WebHostHidden]
00024     public ref class CropImageViewModel sealed : public ImageBase
00025     {
00026     internal:
00027         CropImageViewModel(std::shared_ptr<Repository> repository, std::shared_ptr<ExceptionPolicy> exceptionPolicy);
00028
00029         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031         void Initialize(Platform::String^ photoPath);
00032         void CalculateInitialCropOverlayPosition(Windows::UI::Xaml::Media::GeneralTransform^ transform, float width, float height);
00033         void UpdateCropOverlayPostion(Windows::UI::Xaml::Controls::Primitives::Thumb^ thumb, float64 verticalChange, float64 horizontalChange, float64 minWidth, float64 minHeight);
00034         concurrency::task<void> CropImageAsync(float64 actualWidth);
00035
00036     public:
00037         property Windows::UI::Xaml::Media::ImageSource^ Image
00038         {
00039             Windows::UI::Xaml::Media::ImageSource^ get();
00040         }
00041
00042         property Windows::UI::Xaml::Input::ICommand^ SaveCommand
00043         {
00044             Windows::UI::Xaml::Input::ICommand^ get();
00045         }
00046
00047         property Windows::UI::Xaml::Input::ICommand^ CancelCommand
00048         {
00049             Windows::UI::Xaml::Input::ICommand^ get();
00050         }
00051
00052         property Windows::UI::Xaml::Input::ICommand^ ResumeCropCommand
00053         {
00054             Windows::UI::Xaml::Input::ICommand^ get();
00055         }
00056
00057         property bool InProgress { bool get(); }
00058         property float64 CropOverlayLeft { float64 get(); }
00059         property float64 CropOverlayTop { float64 get(); }
00060         property float64 CropOverlayHeight { float64 get(); }
00061         property float64 CropOverlayWidth { float64 get();}
00062         property bool IsCropOverlayVisible { bool get(); }
00063
00064     private:
00065         std::shared_ptr<Repository> m_repository;
00066         Windows::UI::Xaml::Media::Imaging::WriteableBitmap^ m_image;
00067         Windows::UI::Xaml::Input::ICommand^ m_resumeCropCommand;
00068         Windows::UI::Xaml::Input::ICommand^ m_saveCommand;
00069         Windows::UI::Xaml::Input::ICommand^ m_cancelCommand;
00070         bool m_inProgress;
00071         bool m_isCropOverlayVisible;
00072         bool m_isSaving;
00073         Platform::String^ m_photoPath;
00074
00075         float64 m_left;
00076         float64 m_top;
00077         float64 m_right;
00078         float64 m_bottom;
00079
00080         float64 m_cropOverlayLeft;
00081         float64 m_cropOverlayTop;
00082         float64 m_cropOverlayHeight;
00083         float64 m_cropOverlayWidth;
00084         float64 m_actualHeight;
00085         float64 m_actualWidth;
00086
00087         unsigned int m_cropX;
00088         unsigned int m_cropY;
00089
00090         void ChangeInProgress(bool value);
00091         concurrency::task<IPhoto^> GetImagePhotoAsync();
00092         concurrency::task<Windows::Storage::Streams::IRandomAccessStream^> EncodeImageAsync(Windows::Storage::Streams::IRandomAccessStream^ sourceStream);
00093         void DoCrop(uint32_t xOffset, uint32_t yOffset, uint32_t newHeight, uint32_t newWidth, uint32_t oldWidth, byte* pSrcPixels, byte* pDestPixels);
00094
00095         // Member functions that implement Commands
00096         void SaveImage(Platform::Object^ parameter);
00097         void CancelCrop(Platform::Object^ parameter);
00098         void Unsnap(Platform::Object^ parameter);
00099     };
00100 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

FontLoader Member List

This is the complete list of members for FontLoader, including all inherited members.
AddRef() override | FontLoader | [virtual]
CreateEnumeratorFromKey(_In_ IDWriteFactory *factory, _In_reads_bytes_(fontCollectionKeySize) void const *fontCollectionKey, uint32 fontCollectionKeySize, _Outptr_ IDWriteFontFileEnumerator **fontFileEnumerator) override | FontLoader | [virtual]
CreateStreamFromKey(_In_reads_bytes_(fontFileReferenceKeySize) void const *fontFileReferenceKey, uint32 fontFileReferenceKeySize, _Outptr_ IDWriteFontFileStream **fontFileStream) override | FontLoader | [virtual]
FontLoader(_In_ Windows::Storage::StorageFolder^location, _In_ IDWriteFactory *dwriteFactory) | FontLoader |
GetCurrentFontFile(OUT IDWriteFontFile **currentFontFile) override | FontLoader | [virtual]
LoadAsync() | FontLoader |
m_currentFontFile | FontLoader | [private]
m_dwriteFactory | FontLoader | [private]
m_fontFileCount | FontLoader | [private]
m_fontFileStreamIndex | FontLoader | [private]
m_fontFileStreams | FontLoader | [private]
m_location | FontLoader | [private]
m_refCount | FontLoader | [private]
MoveNext(OUT BOOL *hasCurrentFile) override | FontLoader | [virtual]
QueryInterface(REFIID uuid, _Outptr_ void **object) override | FontLoader | [virtual]
Release() override | FontLoader | [virtual]
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicLoader.cpp Source File

  • Direct3D bump mapping

BasicLoader.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicLoader.h"
00010 #include "BasicShapes.h"
00011 #include "DDSTextureLoader.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 using namespace Microsoft::WRL;
00016 using namespace Windows::Storage;
00017 using namespace Windows::Storage::Streams;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::ApplicationModel;
00020 using namespace std;
00021 using namespace concurrency;
00022
00023 BasicLoader::BasicLoader(
00024     _In_ ID3D11Device* d3dDevice,
00025     _In_opt_ IWICImagingFactory2* wicFactory
00026     ) :
00027     m_d3dDevice(d3dDevice),
00028     m_wicFactory(wicFactory)
00029 {
00030     // Create a new BasicReaderWriter to do raw file I/O.
00031     m_basicReaderWriter = ref new BasicReaderWriter();
00032 }
00033
00034 template <class DeviceChildType>
00035 inline void BasicLoader::SetDebugName(
00036     _In_ DeviceChildType* object,
00037     _In_ Platform::String^ name
00038     )
00039 {
00040 #if defined(_DEBUG)
00041     // Only assign debug names in debug builds.
00042
00043     char nameString[1024];
00044     int nameStringLength = WideCharToMultiByte(
00045         CP_ACP,
00046         0,
00047         name->Data(),
00048         -1,
00049         nameString,
00050         1024,
00051         nullptr,
00052         nullptr
00053         );
00054
00055     if (nameStringLength == 0)
00056     {
00057         char defaultNameString[] = "BasicLoaderObject";
00058         DX::ThrowIfFailed(
00059             object->SetPrivateData(
00060                 WKPDID_D3DDebugObjectName,
00061                 sizeof(defaultNameString) - 1,
00062                 defaultNameString
00063                 )
00064             );
00065     }
00066     else
00067     {
00068         DX::ThrowIfFailed(
00069             object->SetPrivateData(
00070                 WKPDID_D3DDebugObjectName,
00071                 nameStringLength - 1,
00072                 nameString
00073                 )
00074             );
00075     }
00076 #endif
00077 }
00078
00079 Platform::String^ BasicLoader::GetExtension(
00080     _In_ Platform::String^ filename
00081     )
00082 {
00083     int lastDotIndex = -1;
00084     for (int i = filename->Length() - 1; i >= 0 && lastDotIndex == -1; i--)
00085     {
00086         if (*(filename->Data() + i) == '.')
00087         {
00088             lastDotIndex = i;
00089         }
00090     }
00091     if (lastDotIndex != -1)
00092     {
00093         std::unique_ptr<wchar_t[]> extension(new wchar_t[filename->Length() - lastDotIndex]);
00094         for (unsigned int i = 0; i < filename->Length() - lastDotIndex; i++)
00095         {
00096             extension[i] = tolower(*(filename->Data() + lastDotIndex + 1 + i));
00097         }
00098         return ref new Platform::String(extension.get());
00099     }
00100     return "";
00101 }
00102
00103 void BasicLoader::CreateTexture(
00104     _In_ bool decodeAsDDS,
00105     _In_reads_bytes_(dataSize) byte* data,
00106     _In_ uint32 dataSize,
00107     _Out_opt_ ID3D11Texture2D** texture,
00108     _Out_opt_ ID3D11ShaderResourceView** textureView,
00109     _In_opt_ Platform::String^ debugName
00110     )
00111 {
00112     ComPtr<ID3D11ShaderResourceView> shaderResourceView;
00113     ComPtr<ID3D11Texture2D> texture2D;
00114
00115     if (decodeAsDDS)
00116     {
00117         ComPtr<ID3D11Resource> resource;
00118
00119         if (textureView == nullptr)
00120         {
00121             CreateDDSTextureFromMemory(
00122                 m_d3dDevice.Get(),
00123                 data,
00124                 dataSize,
00125                 &resource,
00126                 nullptr
00127                 );
00128         }
00129         else
00130         {
00131             CreateDDSTextureFromMemory(
00132                 m_d3dDevice.Get(),
00133                 data,
00134                 dataSize,
00135                 &resource,
00136                 &shaderResourceView
00137                 );
00138         }
00139
00140         DX::ThrowIfFailed(
00141             resource.As(&texture2D)
00142             );
00143     }
00144     else
00145     {
00146         if (m_wicFactory.Get() == nullptr)
00147         {
00148             // A WIC factory object is required in order to load texture
00149             // assets stored in non-DDS formats.  If BasicLoader was not
00150             // initialized with one, create one as needed.
00151             DX::ThrowIfFailed(
00152                 CoCreateInstance(
00153                     CLSID_WICImagingFactory,
00154                     nullptr,
00155                     CLSCTX_INPROC_SERVER,
00156                     IID_PPV_ARGS(&m_wicFactory)
00157                     )
00158                 );
00159         }
00160
00161         ComPtr<IWICStream> stream;
00162         DX::ThrowIfFailed(
00163             m_wicFactory->CreateStream(&stream)
00164             );
00165
00166         DX::ThrowIfFailed(
00167             stream->InitializeFromMemory(
00168                 data,
00169                 dataSize
00170                 )
00171             );
00172
00173         ComPtr<IWICBitmapDecoder> bitmapDecoder;
00174         DX::ThrowIfFailed(
00175             m_wicFactory->CreateDecoderFromStream(
00176                 stream.Get(),
00177                 nullptr,
00178                 WICDecodeMetadataCacheOnDemand,
00179                 &bitmapDecoder
00180                 )
00181             );
00182
00183         ComPtr<IWICBitmapFrameDecode> bitmapFrame;
00184         DX::ThrowIfFailed(
00185             bitmapDecoder->GetFrame(0, &bitmapFrame)
00186             );
00187
00188         ComPtr<IWICFormatConverter> formatConverter;
00189         DX::ThrowIfFailed(
00190             m_wicFactory->CreateFormatConverter(&formatConverter)
00191             );
00192
00193         DX::ThrowIfFailed(
00194             formatConverter->Initialize(
00195                 bitmapFrame.Get(),
00196                 GUID_WICPixelFormat32bppPBGRA,
00197                 WICBitmapDitherTypeNone,
00198                 nullptr,
00199                 0.0,
00200                 WICBitmapPaletteTypeCustom
00201                 )
00202             );
00203
00204         uint32 width;
00205         uint32 height;
00206         DX::ThrowIfFailed(
00207             bitmapFrame->GetSize(&width, &height)
00208             );
00209
00210         std::unique_ptr<byte[]> bitmapPixels(new byte[width * height * 4]);
00211         DX::ThrowIfFailed(
00212             formatConverter->CopyPixels(
00213                 nullptr,
00214                 width * 4,
00215                 width * height * 4,
00216                 bitmapPixels.get()
00217                 )
00218             );
00219
00220         D3D11_SUBRESOURCE_DATA initialData;
00221         ZeroMemory(&initialData, sizeof(initialData));
00222         initialData.pSysMem = bitmapPixels.get();
00223         initialData.SysMemPitch = width * 4;
00224         initialData.SysMemSlicePitch = 0;
00225
00226         CD3D11_TEXTURE2D_DESC textureDesc(
00227             DXGI_FORMAT_B8G8R8A8_UNORM,
00228             width,
00229             height,
00230             1,
00231             1
00232             );
00233
00234         DX::ThrowIfFailed(
00235             m_d3dDevice->CreateTexture2D(
00236                 &textureDesc,
00237                 &initialData,
00238                 &texture2D
00239                 )
00240             );
00241
00242         if (textureView != nullptr)
00243         {
00244             CD3D11_SHADER_RESOURCE_VIEW_DESC shaderResourceViewDesc(
00245                 texture2D.Get(),
00246                 D3D11_SRV_DIMENSION_TEXTURE2D
00247                 );
00248
00249             DX::ThrowIfFailed(
00250                 m_d3dDevice->CreateShaderResourceView(
00251                     texture2D.Get(),
00252                     &shaderResourceViewDesc,
00253                     &shaderResourceView
00254                     )
00255                 );
00256         }
00257     }
00258
00259     SetDebugName(texture2D.Get(), debugName);
00260
00261     if (texture != nullptr)
00262     {
00263         *texture = texture2D.Detach();
00264     }
00265     if (textureView != nullptr)
00266     {
00267         *textureView = shaderResourceView.Detach();
00268     }
00269 }
00270
00271 void BasicLoader::CreateInputLayout(
00272     _In_reads_bytes_(bytecodeSize) byte* bytecode,
00273     _In_ uint32 bytecodeSize,
00274     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00275     _In_ uint32 layoutDescNumElements,
00276     _Out_ ID3D11InputLayout** layout
00277     )
00278 {
00279     if (layoutDesc == nullptr)
00280     {
00281         // If no input layout is specified, use the BasicVertex layout.
00282         const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
00283         {
00284             { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
00285             { "NORMAL",   0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00286             { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 24, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00287         };
00288
00289         DX::ThrowIfFailed(
00290             m_d3dDevice->CreateInputLayout(
00291                 basicVertexLayoutDesc,
00292                 ARRAYSIZE(basicVertexLayoutDesc),
00293                 bytecode,
00294                 bytecodeSize,
00295                 layout
00296                 )
00297             );
00298     }
00299     else
00300     {
00301         DX::ThrowIfFailed(
00302             m_d3dDevice->CreateInputLayout(
00303                 layoutDesc,
00304                 layoutDescNumElements,
00305                 bytecode,
00306                 bytecodeSize,
00307                 layout
00308                 )
00309             );
00310     }
00311 }
00312
00313 void BasicLoader::CreateMesh(
00314     _In_ byte* meshData,
00315     _Out_ ID3D11Buffer** vertexBuffer,
00316     _Out_ ID3D11Buffer** indexBuffer,
00317     _Out_opt_ uint32* vertexCount,
00318     _Out_opt_ uint32* indexCount,
00319     _In_opt_ Platform::String^ debugName
00320     )
00321 {
00322     // The first 4 bytes of the BasicMesh format define the number of vertices in the mesh.
00323     uint32 numVertices = *reinterpret_cast<uint32*>(meshData);
00324
00325     // The following 4 bytes define the number of indices in the mesh.
00326     uint32 numIndices = *reinterpret_cast<uint32*>(meshData + sizeof(uint32));
00327
00328     // The next segment of the BasicMesh format contains the vertices of the mesh.
00329     BasicVertex* vertices = reinterpret_cast<BasicVertex*>(meshData + sizeof(uint32) * 2);
00330
00331     // The last segment of the BasicMesh format contains the indices of the mesh.
00332     uint16* indices = reinterpret_cast<uint16*>(meshData + sizeof(uint32) * 2 + sizeof(BasicVertex) * numVertices);
00333
00334     // Create the vertex and index buffers with the mesh data.
00335
00336     D3D11_SUBRESOURCE_DATA vertexBufferData = {0};
00337     vertexBufferData.pSysMem = vertices;
00338     vertexBufferData.SysMemPitch = 0;
00339     vertexBufferData.SysMemSlicePitch = 0;
00340     CD3D11_BUFFER_DESC vertexBufferDesc(numVertices * sizeof(BasicVertex), D3D11_BIND_VERTEX_BUFFER);
00341     DX::ThrowIfFailed(
00342         m_d3dDevice->CreateBuffer(
00343             &vertexBufferDesc,
00344             &vertexBufferData,
00345             vertexBuffer
00346             )
00347         );
00348
00349     D3D11_SUBRESOURCE_DATA indexBufferData = {0};
00350     indexBufferData.pSysMem = indices;
00351     indexBufferData.SysMemPitch = 0;
00352     indexBufferData.SysMemSlicePitch = 0;
00353     CD3D11_BUFFER_DESC indexBufferDesc(numIndices * sizeof(uint16), D3D11_BIND_INDEX_BUFFER);
00354     DX::ThrowIfFailed(
00355         m_d3dDevice->CreateBuffer(
00356             &indexBufferDesc,
00357             &indexBufferData,
00358             indexBuffer
00359             )
00360         );
00361
00362     SetDebugName(*vertexBuffer, Platform::String::Concat(debugName, "_VertexBuffer"));
00363     SetDebugName(*indexBuffer, Platform::String::Concat(debugName, "_IndexBuffer"));
00364
00365     if (vertexCount != nullptr)
00366     {
00367         *vertexCount = numVertices;
00368     }
00369     if (indexCount != nullptr)
00370     {
00371         *indexCount = numIndices;
00372     }
00373 }
00374
00375 void BasicLoader::LoadTexture(
00376     _In_ Platform::String^ filename,
00377     _Out_opt_ ID3D11Texture2D** texture,
00378     _Out_opt_ ID3D11ShaderResourceView** textureView
00379     )
00380 {
00381     Platform::Array<byte>^ textureData = m_basicReaderWriter->ReadData(filename);
00382
00383     CreateTexture(
00384         GetExtension(filename) == "dds",
00385         textureData->Data,
00386         textureData->Length,
00387         texture,
00388         textureView,
00389         filename
00390         );
00391 }
00392
00393 task<void> BasicLoader::LoadTextureAsync(
00394     _In_ Platform::String^ filename,
00395     _Out_opt_ ID3D11Texture2D** texture,
00396     _Out_opt_ ID3D11ShaderResourceView** textureView
00397     )
00398 {
00399     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ textureData)
00400     {
00401         CreateTexture(
00402             GetExtension(filename) == "dds",
00403             textureData->Data,
00404             textureData->Length,
00405             texture,
00406             textureView,
00407             filename
00408             );
00409     });
00410 }
00411
00412 void BasicLoader::LoadShader(
00413     _In_ Platform::String^ filename,
00414     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00415     _In_ uint32 layoutDescNumElements,
00416     _Out_ ID3D11VertexShader** shader,
00417     _Out_opt_ ID3D11InputLayout** layout
00418     )
00419 {
00420     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00421
00422     DX::ThrowIfFailed(
00423         m_d3dDevice->CreateVertexShader(
00424             bytecode->Data,
00425             bytecode->Length,
00426             nullptr,
00427             shader
00428             )
00429         );
00430
00431     SetDebugName(*shader, filename);
00432
00433     if (layout != nullptr)
00434     {
00435         CreateInputLayout(
00436             bytecode->Data,
00437             bytecode->Length,
00438             layoutDesc,
00439             layoutDescNumElements,
00440             layout
00441             );
00442
00443         SetDebugName(*layout, filename);
00444     }
00445 }
00446
00447 task<void> BasicLoader::LoadShaderAsync(
00448     _In_ Platform::String^ filename,
00449     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00450     _In_ uint32 layoutDescNumElements,
00451     _Out_ ID3D11VertexShader** shader,
00452     _Out_opt_ ID3D11InputLayout** layout
00453     )
00454 {
00455     // This method assumes that the lifetime of input arguments may be shorter
00456     // than the duration of this task.  In order to ensure accurate results, a
00457     // copy of all arguments passed by pointer must be made.  The method then
00458     // ensures that the lifetime of the copied data exceeds that of the task.
00459
00460     // Create copies of the layoutDesc array as well as the SemanticName strings,
00461     // both of which are pointers to data whose lifetimes may be shorter than that
00462     // of this method's task.
00463     shared_ptr<vector<D3D11_INPUT_ELEMENT_DESC>> layoutDescCopy;
00464     shared_ptr<vector<string>> layoutDescSemanticNamesCopy;
00465     if (layoutDesc != nullptr)
00466     {
00467         layoutDescCopy.reset(
00468             new vector<D3D11_INPUT_ELEMENT_DESC>(
00469                 layoutDesc,
00470                 layoutDesc + layoutDescNumElements
00471                 )
00472             );
00473
00474         layoutDescSemanticNamesCopy.reset(
00475             new vector<string>(layoutDescNumElements)
00476             );
00477
00478         for (uint32 i = 0; i < layoutDescNumElements; i++)
00479         {
00480             layoutDescSemanticNamesCopy->at(i).assign(layoutDesc[i].SemanticName);
00481         }
00482     }
00483
00484     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00485     {
00486         DX::ThrowIfFailed(
00487             m_d3dDevice->CreateVertexShader(
00488                 bytecode->Data,
00489                 bytecode->Length,
00490                 nullptr,
00491                 shader
00492                 )
00493             );
00494
00495         SetDebugName(*shader, filename);
00496
00497         if (layout != nullptr)
00498         {
00499             if (layoutDesc != nullptr)
00500             {
00501                 // Reassign the SemanticName elements of the layoutDesc array copy to point
00502                 // to the corresponding copied strings. Performing the assignment inside the
00503                 // lambda body ensures that the lambda will take a reference to the shared_ptr
00504                 // that holds the data.  This will guarantee that the data is still valid when
00505                 // CreateInputLayout is called.
00506                 for (uint32 i = 0; i < layoutDescNumElements; i++)
00507                 {
00508                     layoutDescCopy->at(i).SemanticName = layoutDescSemanticNamesCopy->at(i).c_str();
00509                 }
00510             }
00511
00512             CreateInputLayout(
00513                 bytecode->Data,
00514                 bytecode->Length,
00515                 layoutDesc == nullptr ? nullptr : layoutDescCopy->data(),
00516                 layoutDescNumElements,
00517                 layout
00518                 );
00519
00520             SetDebugName(*layout, filename);
00521         }
00522     });
00523 }
00524
00525 void BasicLoader::LoadShader(
00526     _In_ Platform::String^ filename,
00527     _Out_ ID3D11PixelShader** shader
00528     )
00529 {
00530     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00531
00532     DX::ThrowIfFailed(
00533         m_d3dDevice->CreatePixelShader(
00534             bytecode->Data,
00535             bytecode->Length,
00536             nullptr,
00537             shader
00538             )
00539         );
00540
00541     SetDebugName(*shader, filename);
00542 }
00543
00544 task<void> BasicLoader::LoadShaderAsync(
00545     _In_ Platform::String^ filename,
00546     _Out_ ID3D11PixelShader** shader
00547     )
00548 {
00549     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00550     {
00551         DX::ThrowIfFailed(
00552             m_d3dDevice->CreatePixelShader(
00553                 bytecode->Data,
00554                 bytecode->Length,
00555                 nullptr,
00556                 shader
00557                 )
00558             );
00559
00560         SetDebugName(*shader, filename);
00561     });
00562 }
00563
00564 void BasicLoader::LoadShader(
00565     _In_ Platform::String^ filename,
00566     _Out_ ID3D11ComputeShader** shader
00567     )
00568 {
00569     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00570
00571     DX::ThrowIfFailed(
00572         m_d3dDevice->CreateComputeShader(
00573             bytecode->Data,
00574             bytecode->Length,
00575             nullptr,
00576             shader
00577             )
00578         );
00579
00580     SetDebugName(*shader, filename);
00581 }
00582
00583 task<void> BasicLoader::LoadShaderAsync(
00584     _In_ Platform::String^ filename,
00585     _Out_ ID3D11ComputeShader** shader
00586     )
00587 {
00588     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00589     {
00590         DX::ThrowIfFailed(
00591             m_d3dDevice->CreateComputeShader(
00592                 bytecode->Data,
00593                 bytecode->Length,
00594                 nullptr,
00595                 shader
00596                 )
00597             );
00598
00599         SetDebugName(*shader, filename);
00600     });
00601 }
00602
00603 void BasicLoader::LoadShader(
00604     _In_ Platform::String^ filename,
00605     _Out_ ID3D11GeometryShader** shader
00606     )
00607 {
00608     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00609
00610     DX::ThrowIfFailed(
00611         m_d3dDevice->CreateGeometryShader(
00612             bytecode->Data,
00613             bytecode->Length,
00614             nullptr,
00615             shader
00616             )
00617         );
00618
00619     SetDebugName(*shader, filename);
00620 }
00621
00622 task<void> BasicLoader::LoadShaderAsync(
00623     _In_ Platform::String^ filename,
00624     _Out_ ID3D11GeometryShader** shader
00625     )
00626 {
00627     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00628     {
00629         DX::ThrowIfFailed(
00630             m_d3dDevice->CreateGeometryShader(
00631                 bytecode->Data,
00632                 bytecode->Length,
00633                 nullptr,
00634                 shader
00635                 )
00636             );
00637
00638         SetDebugName(*shader, filename);
00639     });
00640 }
00641
00642 void BasicLoader::LoadShader(
00643     _In_ Platform::String^ filename,
00644     _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00645     _In_ uint32 numEntries,
00646     _In_reads_opt_(numStrides) const uint32* bufferStrides,
00647     _In_ uint32 numStrides,
00648     _In_ uint32 rasterizedStream,
00649     _Out_ ID3D11GeometryShader** shader
00650     )
00651 {
00652     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00653
00654     DX::ThrowIfFailed(
00655         m_d3dDevice->CreateGeometryShaderWithStreamOutput(
00656             bytecode->Data,
00657             bytecode->Length,
00658             streamOutDeclaration,
00659             numEntries,
00660             bufferStrides,
00661             numStrides,
00662             rasterizedStream,
00663             nullptr,
00664             shader
00665             )
00666         );
00667
00668     SetDebugName(*shader, filename);
00669 }
00670
00671 task<void> BasicLoader::LoadShaderAsync(
00672     _In_ Platform::String^ filename,
00673     _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00674     _In_ uint32 numEntries,
00675     _In_reads_opt_(numStrides) const uint32* bufferStrides,
00676     _In_ uint32 numStrides,
00677     _In_ uint32 rasterizedStream,
00678     _Out_ ID3D11GeometryShader** shader
00679     )
00680 {
00681     // This method assumes that the lifetime of input arguments may be shorter
00682     // than the duration of this task.  In order to ensure accurate results, a
00683     // copy of all arguments passed by pointer must be made.  The method then
00684     // ensures that the lifetime of the copied data exceeds that of the task.
00685
00686     // Create copies of the streamOutDeclaration array as well as the SemanticName
00687     // strings, both of which are pointers to data whose lifetimes may be shorter
00688     // than that of this method's task.
00689     shared_ptr<vector<D3D11_SO_DECLARATION_ENTRY>> streamOutDeclarationCopy;
00690     shared_ptr<vector<string>> streamOutDeclarationSemanticNamesCopy;
00691     if (streamOutDeclaration != nullptr)
00692     {
00693         streamOutDeclarationCopy.reset(
00694             new vector<D3D11_SO_DECLARATION_ENTRY>(
00695                 streamOutDeclaration,
00696                 streamOutDeclaration + numEntries
00697                 )
00698             );
00699
00700         streamOutDeclarationSemanticNamesCopy.reset(
00701             new vector<string>(numEntries)
00702             );
00703
00704         for (uint32 i = 0; i < numEntries; i++)
00705         {
00706             streamOutDeclarationSemanticNamesCopy->at(i).assign(streamOutDeclaration[i].SemanticName);
00707         }
00708     }
00709
00710     // Create a copy of the bufferStrides array, which is a pointer to data
00711     // whose lifetime may be shorter than that of this method's task.
00712     shared_ptr<vector<uint32>> bufferStridesCopy;
00713     if (bufferStrides != nullptr)
00714     {
00715         bufferStridesCopy.reset(
00716             new vector<uint32>(
00717                 bufferStrides,
00718                 bufferStrides + numStrides
00719                 )
00720             );
00721     }
00722
00723     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00724     {
00725         if (streamOutDeclaration != nullptr)
00726         {
00727             // Reassign the SemanticName elements of the streamOutDeclaration array copy to
00728             // point to the corresponding copied strings. Performing the assignment inside the
00729             // lambda body ensures that the lambda will take a reference to the shared_ptr
00730             // that holds the data.  This will guarantee that the data is still valid when
00731             // CreateGeometryShaderWithStreamOutput is called.
00732             for (uint32 i = 0; i < numEntries; i++)
00733             {
00734                 streamOutDeclarationCopy->at(i).SemanticName = streamOutDeclarationSemanticNamesCopy->at(i).c_str();
00735             }
00736         }
00737
00738         DX::ThrowIfFailed(
00739             m_d3dDevice->CreateGeometryShaderWithStreamOutput(
00740                 bytecode->Data,
00741                 bytecode->Length,
00742                 streamOutDeclaration == nullptr ? nullptr : streamOutDeclarationCopy->data(),
00743                 numEntries,
00744                 bufferStrides == nullptr ? nullptr : bufferStridesCopy->data(),
00745                 numStrides,
00746                 rasterizedStream,
00747                 nullptr,
00748                 shader
00749                 )
00750             );
00751
00752         SetDebugName(*shader, filename);
00753     });
00754 }
00755
00756 void BasicLoader::LoadShader(
00757     _In_ Platform::String^ filename,
00758     _Out_ ID3D11HullShader** shader
00759     )
00760 {
00761     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00762
00763     DX::ThrowIfFailed(
00764         m_d3dDevice->CreateHullShader(
00765             bytecode->Data,
00766             bytecode->Length,
00767             nullptr,
00768             shader
00769             )
00770         );
00771
00772     SetDebugName(*shader, filename);
00773 }
00774
00775 task<void> BasicLoader::LoadShaderAsync(
00776     _In_ Platform::String^ filename,
00777     _Out_ ID3D11HullShader** shader
00778     )
00779 {
00780     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00781     {
00782         DX::ThrowIfFailed(
00783             m_d3dDevice->CreateHullShader(
00784                 bytecode->Data,
00785                 bytecode->Length,
00786                 nullptr,
00787                 shader
00788                 )
00789             );
00790
00791         SetDebugName(*shader, filename);
00792     });
00793 }
00794
00795 void BasicLoader::LoadShader(
00796     _In_ Platform::String^ filename,
00797     _Out_ ID3D11DomainShader** shader
00798     )
00799 {
00800     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00801
00802     DX::ThrowIfFailed(
00803         m_d3dDevice->CreateDomainShader(
00804             bytecode->Data,
00805             bytecode->Length,
00806             nullptr,
00807             shader
00808             )
00809         );
00810
00811     SetDebugName(*shader, filename);
00812 }
00813
00814 task<void> BasicLoader::LoadShaderAsync(
00815     _In_ Platform::String^ filename,
00816     _Out_ ID3D11DomainShader** shader
00817     )
00818 {
00819     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00820     {
00821         DX::ThrowIfFailed(
00822             m_d3dDevice->CreateDomainShader(
00823                 bytecode->Data,
00824                 bytecode->Length,
00825                 nullptr,
00826                 shader
00827                 )
00828             );
00829
00830         SetDebugName(*shader, filename);
00831     });
00832 }
00833
00834 void BasicLoader::LoadMesh(
00835     _In_ Platform::String^ filename,
00836     _Out_ ID3D11Buffer** vertexBuffer,
00837     _Out_ ID3D11Buffer** indexBuffer,
00838     _Out_opt_ uint32* vertexCount,
00839     _Out_opt_ uint32* indexCount
00840     )
00841 {
00842     Platform::Array<byte>^ meshData = m_basicReaderWriter->ReadData(filename);
00843
00844     CreateMesh(
00845         meshData->Data,
00846         vertexBuffer,
00847         indexBuffer,
00848         vertexCount,
00849         indexCount,
00850         filename
00851         );
00852 }
00853
00854 task<void> BasicLoader::LoadMeshAsync(
00855     _In_ Platform::String^ filename,
00856     _Out_ ID3D11Buffer** vertexBuffer,
00857     _Out_ ID3D11Buffer** indexBuffer,
00858     _Out_opt_ uint32* vertexCount,
00859     _Out_opt_ uint32* indexCount
00860     )
00861 {
00862     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ meshData)
00863     {
00864         CreateMesh(
00865             meshData->Data,
00866             vertexBuffer,
00867             indexBuffer,
00868             vertexCount,
00869             indexCount,
00870             filename
00871             );
00872     });
00873 }
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/OfferReclaimAPI.h Source File

  • DXGI offer and reclaim resources

OfferReclaimAPI.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "BasicMath.h"
00012 #include "BasicCamera.h"
00013 #include "SampleOverlay.h"
00014
00015 // describes the constant buffer that will be used to draw the cube
00016 struct ConstantBuffer
00017 {
00018     float4x4 model;
00019     float4x4 view;
00020     float4x4 projection;
00021 };
00022
00023 ref class OfferReclaimAPI : public DirectXBase
00024 {
00025 internal:
00026     OfferReclaimAPI();
00027
00028     virtual void CreateDeviceIndependentResources() override;
00029     virtual void CreateDeviceResources() override;
00030     virtual void CreateWindowSizeDependentResources() override;
00031     virtual void Render() override;
00032
00033     void Update(float TimeTotal, float TimeDelta);
00034
00035     void OnSuspending();
00036     void OnResuming();
00037 private:
00038     SampleOverlay^                                      m_sampleOverlay;
00039
00040     Microsoft::WRL::ComPtr<ID3D11InputLayout>           m_inputLayout;                // cube vertex input layout
00041     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_vertexBuffer;               // cube vertex buffer
00042     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_indexBuffer;                // cube index buffer
00043     Microsoft::WRL::ComPtr<ID3D11VertexShader>          m_vertexShader;               // cube vertex shader
00044     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_pixelShader;                // cube pixel shader
00045     Microsoft::WRL::ComPtr<ID3D11Texture2D>             m_texture;                    // cube texture
00046     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_textureSRV;                 // cube texture view
00047     Microsoft::WRL::ComPtr<ID3D11SamplerState>          m_sampler;                    // cube texture sampler
00048     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_constantBuffer;             // constant buffer resource
00049
00050     unsigned int             m_indexCount;                  // cube index count
00051     ConstantBuffer           m_constantBufferData;          // constant buffer resource data
00052     BasicCamera^             m_Camera;                      // scene camera
00053 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario3_BackgroundTask.xaml.cpp Source File

  • Geolocation

Scenario3_BackgroundTask.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3_BackgroundTask.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3_BackgroundTask.xaml.h"
00018
00019 using namespace SDKSample::GeolocationCPP;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::ApplicationModel::Background;
00024 using namespace Windows::Devices::Geolocation;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Storage;
00027 using namespace Windows::UI::Core;
00028 using namespace Windows::UI::Xaml;
00029 using namespace Windows::UI::Xaml::Controls;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 Scenario3::Scenario3() : rootPage(MainPage::Current), sampleBackgroundTaskName("SampleLocationBackgroundTask"), sampleBackgroundTaskEntryPoint("BackgroundTask.LocationBackgroundTask")
00033 {
00034     InitializeComponent();
00035 }
00036
00037 /// <summary>
00038 /// Invoked when this page is about to be displayed in a Frame.
00039 /// </summary>
00040 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00041 /// property is typically used to configure the page.</param>
00042 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Look for an already registered background task
00045     geolocTask = nullptr;
00046
00047     auto iter = BackgroundTaskRegistration::AllTasks->First();
00048     while (iter->HasCurrent)
00049     {
00050         auto task = iter->Current;
00051         if (task->Value->Name == sampleBackgroundTaskName)
00052         {
00053             geolocTask = safe_cast<BackgroundTaskRegistration^>(task->Value);
00054             break;
00055         }
00056         iter->MoveNext();
00057     }
00058
00059     if (geolocTask != nullptr)
00060     {
00061         // Register for background task completion notifications
00062         taskCompletedToken = geolocTask->Completed::add(ref new BackgroundTaskCompletedEventHandler(this, &Scenario3::OnCompleted));
00063
00064         // Check the background access status of the application and display the appropriate status message
00065         switch (BackgroundExecutionManager::GetAccessStatus())
00066         {
00067         case BackgroundAccessStatus::Unspecified:
00068         case BackgroundAccessStatus::Denied:
00069             rootPage->NotifyUser("This application must be added to the lock screen before the background task will run.", NotifyType::ErrorMessage);
00070             break;
00071
00072         default:
00073             rootPage->NotifyUser("Background task is already registered. Waiting for next update...", NotifyType::StatusMessage);
00074             break;
00075         }
00076
00077         RegisterBackgroundTaskButton->IsEnabled = false;
00078         UnregisterBackgroundTaskButton->IsEnabled = true;
00079     }
00080     else
00081     {
00082         RegisterBackgroundTaskButton->IsEnabled = true;
00083         UnregisterBackgroundTaskButton->IsEnabled = false;
00084     }
00085 }
00086
00087 /// <summary>
00088 /// Invoked when this page is no longer displayed.
00089 /// </summary>
00090 /// <param name="e"></param>
00091 void Scenario3::OnNavigatedFrom(NavigationEventArgs^ e)
00092 {
00093     // Just in case the original GetGeopositionAsync call is still active
00094     geopositionTaskTokenSource.cancel();
00095
00096     if (geolocTask != nullptr)
00097     {
00098         geolocTask->Completed::remove(taskCompletedToken);
00099     }
00100 }
00101
00102 void Scenario3::RegisterBackgroundTask(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00103 {
00104     // Get permission for a background task from the user. If the user has already answered once,
00105     // this does nothing and the user must manually update their preference via PC Settings.
00106     task<BackgroundAccessStatus> requestAccessTask(BackgroundExecutionManager::RequestAccessAsync());
00107     requestAccessTask.then([this](BackgroundAccessStatus backgroundAccessStatus)
00108     {
00109         // Create a new background task builder
00110         BackgroundTaskBuilder^ geolocTaskBuilder = ref new BackgroundTaskBuilder();
00111
00112         geolocTaskBuilder->Name = sampleBackgroundTaskName;
00113         geolocTaskBuilder->TaskEntryPoint = sampleBackgroundTaskEntryPoint;
00114
00115         // Create a new timer triggering at a 15 minute interval
00116         auto trigger = ref new TimeTrigger(15, false);
00117
00118         // Associate the timer trigger with the background task builder
00119         geolocTaskBuilder->SetTrigger(trigger);
00120
00121         // Register the background task
00122         geolocTask = geolocTaskBuilder->Register();
00123
00124         // Register for background task completion notifications
00125         taskCompletedToken = geolocTask->Completed::add(ref new BackgroundTaskCompletedEventHandler(this, &Scenario3::OnCompleted));
00126
00127         RegisterBackgroundTaskButton->IsEnabled = false;
00128         UnregisterBackgroundTaskButton->IsEnabled = true;
00129
00130         // Check the background access status of the application and display the appropriate status message
00131         switch (backgroundAccessStatus)
00132         {
00133         case BackgroundAccessStatus::Unspecified:
00134         case BackgroundAccessStatus::Denied:
00135             rootPage->NotifyUser("This application must be added to the lock screen before the background task will run.", NotifyType::ErrorMessage);
00136             break;
00137
00138         default:
00139             GetGeopositionAsync();
00140             break;
00141         }
00142     });
00143 }
00144
00145 void Scenario3::UnregisterBackgroundTask(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00146 {
00147     // Remove the application from the lock screen
00148     BackgroundExecutionManager::RemoveAccess();
00149
00150     // Unregister the background task
00151     geolocTask->Unregister(true);
00152     geolocTask = nullptr;
00153
00154     rootPage->NotifyUser("Background task unregistered", NotifyType::StatusMessage);
00155
00156     ScenarioOutput_Latitude->Text = "No data";
00157     ScenarioOutput_Longitude->Text = "No data";
00158     ScenarioOutput_Accuracy->Text = "No data";
00159
00160     RegisterBackgroundTaskButton->IsEnabled = true;
00161     UnregisterBackgroundTaskButton->IsEnabled = false;
00162 }
00163
00164 void Scenario3::GetGeopositionAsync()
00165 {
00166     Geolocator^ geolocator = ref new Geolocator();
00167
00168     rootPage->NotifyUser("Getting initial position...", NotifyType::StatusMessage);
00169
00170     task<Geoposition^> geopositionTask(geolocator->GetGeopositionAsync(), geopositionTaskTokenSource.get_token());
00171     geopositionTask.then([this, geolocator](task<Geoposition^> getPosTask)
00172     {
00173         try
00174         {
00175             // Get will throw an exception if the task was canceled or failed with an error
00176             Geoposition^ pos = getPosTask.get();
00177
00178             rootPage->NotifyUser("Initial position. Waiting for update...", NotifyType::StatusMessage);
00179
00180             ScenarioOutput_Latitude->Text = pos->Coordinate->Latitude.ToString();
00181             ScenarioOutput_Longitude->Text = pos->Coordinate->Longitude.ToString();
00182             ScenarioOutput_Accuracy->Text = pos->Coordinate->Accuracy.ToString();
00183         }
00184         catch (Platform::AccessDeniedException^)
00185         {
00186             rootPage->NotifyUser("Disabled by user. Enable access through the settings charm to enable the background task.", NotifyType::ErrorMessage);
00187
00188             // Clear cached location data if any
00189             ScenarioOutput_Latitude->Text = "No data";
00190             ScenarioOutput_Longitude->Text = "No data";
00191             ScenarioOutput_Accuracy->Text = "No data";
00192         }
00193         catch (task_canceled&)
00194         {
00195             rootPage->NotifyUser("Operation canceled", NotifyType::StatusMessage);
00196         }
00197     });
00198 }
00199
00200 void Scenario3::OnCompleted(BackgroundTaskRegistration^ task, Windows::ApplicationModel::Background::BackgroundTaskCompletedEventArgs^ args)
00201 {
00202     // Update the UI with progress reported by the background task
00203     // We need to dispatch to the UI thread to display the output
00204     Dispatcher->RunAsync(
00205         CoreDispatcherPriority::Normal,
00206         ref new DispatchedHandler(
00207             [this, args]()
00208             {
00209                 try
00210                 {
00211                     // Throw an exception if the background task had an unrecoverable error
00212                     args->CheckResult();
00213
00214                     // Update the UI with the completion status of the background task
00215                     auto settings = ApplicationData::Current->LocalSettings->Values;
00216                     if (settings->HasKey("Status"))
00217                     {
00218                         rootPage->NotifyUser(safe_cast<String^>(settings->Lookup("Status")), NotifyType::StatusMessage);
00219                     }
00220
00221                     // Extract and display Latitude
00222                     if (settings->HasKey("Latitude"))
00223                     {
00224                         ScenarioOutput_Latitude->Text = safe_cast<String^>(settings->Lookup("Latitude"));
00225                     }
00226                     else
00227                     {
00228                         ScenarioOutput_Latitude->Text = "No data";
00229                     }
00230
00231                     // Extract and display Longitude
00232                     if (settings->HasKey("Longitude"))
00233                     {
00234                         ScenarioOutput_Longitude->Text = safe_cast<String^>(settings->Lookup("Longitude"));
00235                     }
00236                     else
00237                     {
00238                         ScenarioOutput_Longitude->Text = "No data";
00239                     }
00240
00241                     // Extract and display Accuracy
00242                     if (settings->HasKey("Accuracy"))
00243                     {
00244                         ScenarioOutput_Accuracy->Text = safe_cast<String^>(settings->Lookup("Accuracy"));
00245                     }
00246                     else
00247                     {
00248                         ScenarioOutput_Accuracy->Text = "No data";
00249                     }
00250                 }
00251                 catch (Exception^ ex)
00252                 {
00253                     // The background task had an error
00254                     rootPage->NotifyUser(ex->Message, NotifyType::ErrorMessage);
00255                 }
00256             },
00257             CallbackContext::Any
00258             )
00259         );
00260 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::sealed Member List

This is the complete list of members for SDKSample::sealed, including all inherited members.
__pad0__ | SDKSample::sealed | [protected]
__pad1__ | SDKSample::sealed | [private]
AttachFeed(SyndicationFeed^feed) | SDKSample::sealed | [inline]
autoSizeInputSectionWhenSnapped | SDKSample::sealed | [private]
BindableNode(String^nodeName, String^nodeNamespace, String^nodeValue) | SDKSample::sealed | [inline]
Dismissed | SDKSample::sealed | [private]
editUri | SDKSample::sealed | [static]
feed | SDKSample::sealed | [private]
feedUri | SDKSample::sealed | [static]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::sealed | [private]
GetClient() | SDKSample::sealed | [inline, static]
GetContent() | SDKSample::sealed | [inline]
GetEditUri() | SDKSample::sealed | [inline]
GetIndexDescription() | SDKSample::sealed | [inline]
GetSyndicationItem() | SDKSample::sealed | [inline]
GetTitle() | SDKSample::sealed | [inline]
HasElements() | SDKSample::sealed | [inline]
HiddenFrame | SDKSample::sealed | [private]
index | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateSize() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
InvalidateViewState() | SDKSample::sealed | [private]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed |
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadScenario(Platform::String^scenarioName) | SDKSample::sealed | [protected]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
LoadState(Platform::Object^navigationParameter, Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage() | SDKSample::sealed |
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [protected]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SDKSample::sealed | [private]
MainPageResized | SDKSample::sealed | [protected]
MoveNext() | SDKSample::sealed | [inline]
MovePrevious() | SDKSample::sealed | [inline]
nodeNamespace | SDKSample::sealed |
nodeValue | SDKSample::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | SDKSample::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | SDKSample::sealed | [protected]
PageResized | SDKSample::sealed |
password | SDKSample::sealed | [static]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
PopulateScenarios() | SDKSample::sealed | [private]
ResetScenarioOutput(Windows::UI::Xaml::Controls::TextBlock^textblock) | SDKSample::sealed |
Restore(Page^inputFrame) | SDKSample::sealed | [inline, static]
Save(Platform::String^baseUri, Platform::String^user, Platform::String^password) | SDKSample::sealed | [inline, static]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^pageState) override | SDKSample::sealed | [protected, virtual]
ScenarioList | SDKSample::sealed | [private]
ScenarioLoaded | SDKSample::sealed | [protected]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [protected]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::sealed | [private]
scenariosInner | SDKSample::sealed | [private, static]
serviceDocUri | SDKSample::sealed | [static]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
set(bool value) | SDKSample::sealed | [inline, protected]
SplashImageRect | SDKSample::sealed | [private]
SyndicationItemIterator() | SDKSample::sealed | [inline]
user | SDKSample::sealed | [static]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicTimer.cpp Source File

  • DirectX marble maze game

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/SuspensionManager.h Source File

  • Removable storage
  • common

SuspensionManager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileSquarePeekImageAndText03, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
NotificationsExtensions::GetContent() | NotificationsExtensions::TileContent::TileSquareBase | [inline]
NotificationsExtensions::GetContent() | NotificationsExtensions::TileContent::TileSquareBase | [inline]
NotificationsExtensions::TileContent::TileNotificationBase::GetContent() | NotificationsExtensions::NotificationBase | [pure virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeBinding(string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
SerializeBinding(string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBody1 | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 |
TextBody2 | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 |
TextBody3 | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 |
TextBody4 | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileSquareBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
TileSquareBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
TileSquarePeekImageAndText03() | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 | [inline]
TileSquarePeekImageAndText03() | NotificationsExtensions::TileContent::TileSquarePeekImageAndText03 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/Constants.cpp Source File

  • Media Server client

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Consume media from Digital Media Server", "SDKSample.MediaServerClient.Scenario1" },
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/common/LayoutAwarePage.h Source File

  • Reading and writing data
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/pch.cpp Source File

  • CameraCaptureUI

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/App.xaml.h Source File

  • Sharing content target app

App.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.h
00010 // Declaration of the App.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "App.g.h"
00017
00018 namespace ShareTarget
00019 {
00020     ref class App sealed
00021     {
00022     public:
00023         App();
00024         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00025         virtual void OnShareTargetActivated(Windows::ApplicationModel::Activation::ShareTargetActivatedEventArgs^ args) override;
00026     };
00027 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/Constants.h Source File

  • Proximity

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace ProximityCPP
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Proximity C++ Sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicShapes.cpp Source File

  • Direct3D bump mapping

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/common/suspensionmanager.cpp Source File

  • Inclinometer sensor
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/common/suspensionmanager.cpp Source File

  • Syndication
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/pch.cpp Source File

  • XAML user and custom controls

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/FPSCounter.h Source File

  • Direct2D geometry realization

FPSCounter.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011 #include <list>
00012 #include <vector>
00013
00014 // This class displays how fast an application is rendering in frames per second,
00015 // or FPS. So as not to take too much time rendering the text and interfere with
00016 // the performance of the application, this class caches all the digits 0-9 in
00017 // an atlas bitmap when it is first initialized, and then it renders the cached
00018 // digits from that atlas each frame.
00019 ref class FPSCounter
00020 {
00021 internal:
00022     FPSCounter(
00023         _In_ ID2D1DeviceContext* d2dContext,
00024         _In_ float dpi,
00025         _In_ Platform::String^ text,
00026         _In_ IDWriteTextFormat* textFormat,
00027         _In_ D2D1_POINT_2F position
00028         );
00029
00030     void Initialize();
00031
00032     void Render();
00033
00034 private:
00035
00036     // This struct represents the position of a piece of text within the atlas.
00037     // All units are in pixels.
00038     struct AtlasText
00039     {
00040         D2D1_RECT_U atlasRect;      // The black box of text in the atlas
00041         D2D1_POINT_2L originOffset; // The offset to draw the text (relative to the origin)
00042         uint32 advanceWidth;        // The distance to the next character
00043     };
00044
00045     void PositionAtlasText(
00046         _In_ Platform::String^ text,
00047         _In_ D2D1_POINT_2U offsetInAtlas,
00048         _Outptr_ IDWriteTextLayout** layout,
00049         _Out_ AtlasText* atlasText
00050         );
00051
00052     void DrawAtlasText(
00053         _In_ const AtlasText& atlasText,
00054         _In_ D2D1_POINT_2F offset
00055         );
00056
00057     int DipsToPixelsRoundDown(float value);
00058     int DipsToPixelsRoundUp(float value);
00059     float PixelsToDips(int value);
00060
00061     Microsoft::WRL::ComPtr<ID2D1DeviceContext> m_d2dContext;
00062     float m_dpi;
00063     Microsoft::WRL::ComPtr<IDXGIDevice2> m_dxgiDevice;
00064     Microsoft::WRL::ComPtr<IDWriteFactory> m_dwriteFactory;
00065     Platform::String^ m_staticText;
00066     Microsoft::WRL::ComPtr<IDWriteTextFormat> m_textFormat;
00067     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> m_textBrush;
00068     Microsoft::WRL::ComPtr<ID2D1Bitmap1> m_textAtlasBitmap;
00069
00070     D2D1_POINT_2F m_position;
00071     AtlasText m_cachedStaticText;
00072     D2D1_POINT_2U m_firstDigitOffset;
00073     AtlasText m_cachedDigits[10];
00074     std::list<int> m_times;
00075 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/ImageWithLabelControl.cpp Source File

  • XAML user and custom controls

ImageWithLabelControl.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // ImageWithLabelControl.cpp
00003 // Implementation of the ImageWithLabelControl class.
00004 //
00005
00006 #include "pch.h"
00007 #include "ImageWithLabelControl.h"
00008
00009 using namespace SDKSample::UserAndCustomControls;
00010
00011 using namespace Platform;
00012 using namespace Windows::Foundation;
00013 using namespace Windows::Foundation::Collections;
00014 using namespace Windows::UI::Xaml;
00015 using namespace Windows::UI::Xaml::Controls;
00016 using namespace Windows::UI::Xaml::Data;
00017 using namespace Windows::UI::Xaml::Documents;
00018 using namespace Windows::UI::Xaml::Input;
00019 using namespace Windows::UI::Xaml::Interop;
00020 using namespace Windows::UI::Xaml::Media;
00021
00022 // The Templated Control item template is documented at http://go.microsoft.com/fwlink/?LinkId=234235
00023
00024 ImageWithLabelControl::ImageWithLabelControl()
00025 {
00026   DefaultStyleKey = "SDKSample.UserAndCustomControls.ImageWithLabelControl";
00027 }
00028
00029 DependencyProperty^ ImageWithLabelControl::_LabelProperty = DependencyProperty::Register("Label", Platform::String::typeid, ImageWithLabelControl::typeid, nullptr);
00030 DependencyProperty^ ImageWithLabelControl::_ImagePathProperty = DependencyProperty::Register("ImagePath", ImageSource::typeid, ImageWithLabelControl::typeid, nullptr);
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/Constants.cpp Source File

  • Reading and writing data

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Read and write simple structured data.", "SDKSample.DataReaderWriter.WriteReadStream" },
00022     { "Dump file contents using ReadBytes().", "SDKSample.DataReaderWriter.ReadBytes" }
00023 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DDSTextureLoader.h Source File

  • DXGI offer and reclaim resources

DDSTextureLoader.h

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.h
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #pragma once
00019
00020 void CreateDDSTextureFromMemory(
00021     _In_ ID3D11Device* d3dDevice,
00022     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
00023     _In_ size_t ddsDataSize,
00024     _Out_opt_ ID3D11Resource** texture,
00025     _Out_opt_ ID3D11ShaderResourceView** textureView,
00026     _In_ size_t maxsize = 0
00027     );
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/FileSizeConverter.h Source File

  • Hilo C++
  • Hilo

FileSizeConverter.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     interface class IResourceLoader;
00012
00013     // See http://go.microsoft.com/fwlink/?LinkId=267279 for info about the FileSizeConverter class
00014     // and other data converters.
00015
00016     [Windows::Foundation::Metadata::WebHostHidden]
00017     public ref class FileSizeConverter sealed : public Windows::UI::Xaml::Data::IValueConverter
00018     {
00019     public:
00020         FileSizeConverter();
00021         FileSizeConverter(IResourceLoader^ loader);
00022
00023         virtual Object^ Convert(Object^ value, Windows::UI::Xaml::Interop::TypeName targetType, Object^ parameter, Platform::String^ language);
00024         virtual Object^ ConvertBack(Object^ value, Windows::UI::Xaml::Interop::TypeName targetType, Object^ parameter, Platform::String^ language);
00025
00026     private:
00027         float64 ToTwoDecimalPlaces(float64 value);
00028         IResourceLoader^ m_loader;
00029     };
00030 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/TilePinned.xaml.h Source File

  • Secondary tiles
  • C#,C++

TilePinned.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // TilePinned.xaml.h
00013 // Declaration of the TilePinned class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "TilePinned.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SecondaryTiles
00023 {
00024     /// <summary>
00025     /// An empty page that can be used on its own or navigated to within a Frame.
00026     /// </summary>
00027     [Windows::Foundation::Metadata::WebHostHidden]
00028     public ref class TilePinned sealed
00029     {
00030     public:
00031         TilePinned();
00032
00033     protected:
00034         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00035         virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00036     private:
00037         MainPage^ rootPage;
00038         Windows::UI::Xaml::Controls::AppBar^ appBar;
00039         void TileExists_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040     };
00041 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SimpleCommunication::LowLatency Member List

This is the complete list of members for SimpleCommunication::LowLatency, including all inherited members.
__pad0__ | Element |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Page | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) | Element | [virtual]
CleanupAsync() | SimpleCommunication::LowLatency | [inline, private]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
currentState | SimpleCommunication::LowLatency | [private]
defaultMode | SimpleCommunication::LowLatency | [private]
DefaultViewModel | SDKTemplate::Common::LayoutAwarePage | [protected]
DefaultViewModelProperty | SDKTemplate::Common::LayoutAwarePage | [static]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
device | SimpleCommunication::LowLatency | [private]
device_CaptureFailed(object sender, MediaCaptureFailedEventArgs e) | SimpleCommunication::LowLatency | [inline, private]
device_IncomingConnectionArrived(object sender, IncomingConnectionEventArgs e) | SimpleCommunication::LowLatency | [inline, private]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
InitializeAsync(CancellationToken cancel=default(CancellationToken)) | SimpleCommunication::LowLatency | [inline, private]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
LatencyMode enum name | SimpleCommunication::LowLatency | [private]
LatencyModeToggle_Toggled(object sender, RoutedEventArgs e) | SimpleCommunication::LowLatency | [inline, private]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
LocalhostVideo | SimpleCommunication::LowLatency | [private]
LoopbackClient_Click(object sender, RoutedEventArgs e) | SimpleCommunication::LowLatency | [inline, private]
LowLatency() | SimpleCommunication::LowLatency | [inline]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
mode | SimpleCommunication::LowLatency | [private]
OnNavigatedTo(NavigationEventArgs e) | SimpleCommunication::LowLatency | [inline, protected]
OnNavigatingFrom(NavigatingCancelEventArgs e) | SimpleCommunication::LowLatency | [inline, protected]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
Preview_Click(object sender, RoutedEventArgs e) | SimpleCommunication::LowLatency | [inline, private]
previewEncodingProperties | SimpleCommunication::LowLatency | [private]
Previewing_PreviewButtonClicked() | SimpleCommunication::LowLatency | [inline, private]
PreviewSetupCompleted() | SimpleCommunication::LowLatency | [inline, private]
previousState | SimpleCommunication::LowLatency | [private]
ReleaseParent() | Element | [virtual]
rootPage | SimpleCommunication::LowLatency | [private]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StartRecordingToCustomSink() | SimpleCommunication::LowLatency | [inline, private]
State enum name | SimpleCommunication::LowLatency | [private]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
Streaming_PreviewButtonClicked() | SimpleCommunication::LowLatency | [inline, private]
Waiting_PreviewButtonClicked() | SimpleCommunication::LowLatency | [inline, private]
Window_VisibilityChanged(object sender, Windows.UI.Core.VisibilityChangedEventArgs e) | SimpleCommunication::LowLatency | [inline, private]
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson1.Basics/pch.cpp Source File

  • Direct3D tutorial
  • Lesson1.Basics

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicShapes.h Source File

  • Direct3D sprite

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/Constants.h Source File

  • HomeGroup app

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"HomeGroup C++");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042     internal:
00043         bool EnsureUnsnapped();
00044
00045     private:
00046         static Platform::Array<Scenario>^ scenariosInner;
00047     };
00048 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/MainPage.xaml.cpp Source File

  • Media capture using capture device

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::App Member List

This is the complete list of members for SDKSample::App, including all inherited members.
__pad0__ | SDKSample::App |
App::EnsureMainPageActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^pArgs) | SDKSample::App | [private]
App::EnsureMainPageActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^pArgs) | SDKSample::App | [private]
LaunchArgs | SDKSample::App |
OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override | SDKSample::App | [virtual]
OnCachedFileUpdaterActivated(Windows::ApplicationModel::Activation::CachedFileUpdaterActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnFileActivated(Windows::ApplicationModel::Activation::FileActivatedEventArgs^args) override | SDKSample::App | [virtual]
OnFileOpenPickerActivated(Windows::ApplicationModel::Activation::FileOpenPickerActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnFileSavePickerActivated(Windows::ApplicationModel::Activation::FileSavePickerActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnQuerySubmitted(Windows::ApplicationModel::Search::SearchPane^sender, Windows::ApplicationModel::Search::SearchPaneQuerySubmittedEventArgs^args) | SDKSample::App | [protected]
OnSearchActivated(Windows::ApplicationModel::Activation::SearchActivatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SDKSample::App | [virtual]
OnWindowCreated(Windows::UI::Xaml::WindowCreatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
OnWindowCreated(Windows::UI::Xaml::WindowCreatedEventArgs^pArgs) override | SDKSample::App | [protected, virtual]
rootFrame | SDKSample::App | [private]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/DeviceAppForPrinters/pch.cpp Source File

  • Device app for printers SDK
  • DeviceAppForPrinters

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/pch.h Source File

  • Media Server client

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/FrameData.h Source File

  • Hilo C++
  • CartoonEffect

FrameData.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 class FrameProcessing;
00010
00011 struct FrameData
00012 {
00013     int m_size;
00014     unsigned int m_startWidth;
00015     unsigned int m_startHeight;
00016     unsigned int m_endWidth;
00017     unsigned int m_endHeight;
00018     int m_pitch;
00019     int m_BBP;
00020     int m_colorPlanes;
00021     byte* m_pFrame;
00022     int m_phaseCount;
00023     int m_neighbourArea;
00024     FrameProcessing* m_pFrameProcessor;
00025
00026     FrameData()
00027     {
00028         m_neighbourArea = 3;
00029         m_phaseCount = 0;
00030         m_size = 0;
00031         m_startWidth = 0;
00032         m_endWidth = 0;
00033         m_startHeight = 0;
00034         m_endHeight = 0;
00035         m_pitch = 0;
00036         m_BBP = 0;
00037         m_pFrame = nullptr;
00038         m_pFrameProcessor = nullptr;
00039         m_colorPlanes = 0;
00040     }
00041 };
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/MainPage.xaml.h Source File

  • Date and time formatting

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/DirectXBase.h Source File

  • XAudio2 audio file playback

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/DefaultScenario.xaml.cpp Source File

  • App settings

DefaultScenario.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DefaultScenario.xaml.cpp
00013 // Implementation of the DefaultScenario class
00014 //
00015
00016 #include "pch.h"
00017 #include "DefaultScenario.xaml.h"
00018
00019 using namespace SDKSample::ApplicationSettings;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::ApplicationSettings;
00025 using namespace Windows::UI::Popups;
00026
00027 DefaultScenario::DefaultScenario()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void DefaultScenario::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042
00043     rootPage->NotifyUser("To show the settings charm window, invoke the charm bar by swiping your finger on the right edge of the screen or bringing your mouse to the lower right corner of the screen, then select Settings. Or you can just press Windows logo + i. To dismiss the settings charm, tap in the application, swipe a screen edge, right click, invoke another charm or application.", NotifyType::StatusMessage);
00044 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/NotificationsExtensions/Common.cs Source File

  • Secondary tiles
  • C#,C++
  • NotificationsExtensions

Common.cs

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 using System;
00009 using System.Collections.ObjectModel;
00010 using System.Runtime.InteropServices;
00011 using System.Text;
00012 #if !WINRT_NOT_PRESENT
00013 using Windows.Data.Xml.Dom;
00014 #endif
00015
00016 namespace NotificationsExtensions
00017 {
00018     internal sealed class NotificationContentText : INotificationContentText
00019     {
00020         internal NotificationContentText() { }
00021
00022         public string Text
00023         {
00024             get { return m_Text; }
00025             set { m_Text = value; }
00026         }
00027
00028         public string Lang
00029         {
00030             get { return m_Lang; }
00031             set { m_Lang = value; }
00032         }
00033
00034         private string m_Text;
00035         private string m_Lang;
00036     }
00037
00038     internal sealed class NotificationContentImage : INotificationContentImage
00039     {
00040         internal NotificationContentImage() { }
00041
00042         public string Src
00043         {
00044             get { return m_Src; }
00045             set { m_Src = value; }
00046         }
00047
00048         public string Alt
00049         {
00050             get { return m_Alt; }
00051             set { m_Alt = value; }
00052         }
00053
00054         public bool AddImageQuery
00055         {
00056             get
00057             {
00058                 if (m_AddImageQueryNullable == null || m_AddImageQueryNullable.Value == false)
00059                 {
00060                     return false;
00061                 }
00062                 else
00063                 {
00064                     return true;
00065                 }
00066             }
00067             set { m_AddImageQueryNullable = value; }
00068         }
00069
00070         public bool? AddImageQueryNullable
00071         {
00072             get { return m_AddImageQueryNullable; }
00073             set { m_AddImageQueryNullable = value; }
00074         }
00075
00076         private string m_Src;
00077         private string m_Alt;
00078         private bool? m_AddImageQueryNullable;
00079     }
00080
00081     internal static class Util
00082     {
00083         public const int NOTIFICATION_CONTENT_VERSION = 1;
00084
00085         public static string HttpEncode(string value)
00086         {
00087             return value.Replace("&", "&amp;").Replace("<", "&lt;").Replace(">", "&gt;").Replace("\"", "&quot;").Replace("'", "&apos;");
00088         }
00089     }
00090
00091     /// <summary>
00092     /// Base class for the notification content creation helper classes.
00093     /// </summary>
00094 #if !WINRT_NOT_PRESENT
00095     internal abstract class NotificationBase
00096 #else
00097     abstract partial class NotificationBase
00098 #endif
00099     {
00100         protected NotificationBase(string templateName, int imageCount, int textCount)
00101         {
00102             m_TemplateName = templateName;
00103
00104             m_Images = new NotificationContentImage[imageCount];
00105             for (int i = 0; i < m_Images.Length; i++)
00106             {
00107                 m_Images[i] = new NotificationContentImage();
00108             }
00109
00110             m_TextFields = new INotificationContentText[textCount];
00111             for (int i = 0; i < m_TextFields.Length; i++)
00112             {
00113                 m_TextFields[i] = new NotificationContentText();
00114             }
00115         }
00116
00117         public bool StrictValidation
00118         {
00119             get { return m_StrictValidation; }
00120             set { m_StrictValidation = value; }
00121         }
00122         public abstract string GetContent();
00123
00124         public override string ToString()
00125         {
00126             return GetContent();
00127         }
00128
00129 #if !WINRT_NOT_PRESENT
00130         public XmlDocument GetXml()
00131         {
00132             XmlDocument xml = new XmlDocument();
00133             xml.LoadXml(GetContent());
00134             return xml;
00135         }
00136 #endif
00137
00138         /// <summary>
00139         /// Retrieves the list of images that can be manipulated on the notification content.
00140         /// </summary>
00141         public INotificationContentImage[] Images
00142         {
00143             get { return m_Images; }
00144         }
00145
00146         /// <summary>
00147         /// Retrieves the list of text fields that can be manipulated on the notification content.
00148         /// </summary>
00149         public INotificationContentText[] TextFields
00150         {
00151             get { return m_TextFields; }
00152         }
00153
00154         /// <summary>
00155         /// The base Uri path that should be used for all image references in the notification.
00156         /// </summary>
00157         public string BaseUri
00158         {
00159             get { return m_BaseUri; }
00160             set
00161             {
00162                 if (this.StrictValidation && !String.IsNullOrEmpty(value))
00163                 {
00164                     Uri uri;
00165                     try
00166                     {
00167                         uri = new Uri(value);
00168                     }
00169                     catch (Exception e)
00170                     {
00171                         throw new ArgumentException("Invalid URI. Use a valid URI or turn off StrictValidation", e);
00172                     }
00173                     if (!(uri.Scheme.Equals("http", StringComparison.OrdinalIgnoreCase)
00174                         || uri.Scheme.Equals("https", StringComparison.OrdinalIgnoreCase)
00175                         || uri.Scheme.Equals("ms-appx", StringComparison.OrdinalIgnoreCase)
00176                         || (uri.Scheme.Equals("ms-appdata", StringComparison.OrdinalIgnoreCase)
00177                             && (String.IsNullOrEmpty(uri.Authority)) // check to make sure the Uri isn't ms-appdata://foo/local
00178                             && (uri.AbsolutePath.StartsWith("/local/") || uri.AbsolutePath.StartsWith("local/"))))) // both ms-appdata:local/ and ms-appdata:/local/ are valid
00179                     {
00180                         throw new ArgumentException("The BaseUri must begin with http://, https://, ms-appx:///, or ms-appdata:///local/.", "value");
00181                     }
00182                 }
00183                 m_BaseUri = value;
00184             }
00185         }
00186
00187         public string Lang
00188         {
00189             get { return m_Lang; }
00190             set { m_Lang = value; }
00191         }
00192
00193         public bool AddImageQuery
00194         {
00195             get
00196             {
00197                 if (m_AddImageQueryNullable == null || m_AddImageQueryNullable.Value == false)
00198                 {
00199                     return false;
00200                 }
00201                 else
00202                 {
00203                     return true;
00204                 }
00205             }
00206             set { m_AddImageQueryNullable = value; }
00207         }
00208
00209         public bool? AddImageQueryNullable
00210         {
00211             get { return m_AddImageQueryNullable; }
00212             set { m_AddImageQueryNullable = value; }
00213         }
00214
00215         protected string SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery)
00216         {
00217             globalLang = (globalLang != null) ? globalLang : String.Empty;
00218             globalBaseUri = String.IsNullOrWhiteSpace(globalBaseUri) ? null : globalBaseUri;
00219
00220             StringBuilder builder = new StringBuilder(String.Empty);
00221             for (int i = 0; i < m_Images.Length; i++)
00222             {
00223                 if (!String.IsNullOrEmpty(m_Images[i].Src))
00224                 {
00225                     string escapedSrc = Util.HttpEncode(m_Images[i].Src);
00226                     if (!String.IsNullOrWhiteSpace(m_Images[i].Alt))
00227                     {
00228                         string escapedAlt = Util.HttpEncode(m_Images[i].Alt);
00229                         if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
00230                         {
00231                             builder.AppendFormat("<image id='{0}' src='{1}' alt='{2}'/>", i + 1, escapedSrc, escapedAlt);
00232                         }
00233                         else
00234                         {
00235                             builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}' alt='{3}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc, escapedAlt);
00236                         }
00237                     }
00238                     else
00239                     {
00240                         if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
00241                         {
00242                             builder.AppendFormat("<image id='{0}' src='{1}'/>", i + 1, escapedSrc);
00243                         }
00244                         else
00245                         {
00246                             builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc);
00247                         }
00248                     }
00249                 }
00250             }
00251
00252             for (int i = 0; i < m_TextFields.Length; i++)
00253             {
00254                 if (!String.IsNullOrWhiteSpace(m_TextFields[i].Text))
00255                 {
00256                     string escapedValue = Util.HttpEncode(m_TextFields[i].Text);
00257                     if (!String.IsNullOrWhiteSpace(m_TextFields[i].Lang) && !m_TextFields[i].Lang.Equals(globalLang))
00258                     {
00259                         string escapedLang = Util.HttpEncode(m_TextFields[i].Lang);
00260                         builder.AppendFormat("<text id='{0}' lang='{1}'>{2}</text>", i + 1, escapedLang, escapedValue);
00261                     }
00262                     else
00263                     {
00264                         builder.AppendFormat("<text id='{0}'>{1}</text>", i + 1, escapedValue);
00265                     }
00266                 }
00267             }
00268
00269             return builder.ToString();
00270         }
00271
00272         public string TemplateName { get { return m_TemplateName; } }
00273
00274         private bool m_StrictValidation = true;
00275         private NotificationContentImage[] m_Images;
00276         private INotificationContentText[] m_TextFields;
00277
00278         private string m_Lang;
00279         private string m_BaseUri;
00280         private string m_TemplateName;
00281         private bool? m_AddImageQueryNullable;
00282     }
00283
00284     /// <summary>
00285     /// Exception returned when invalid notification content is provided.
00286     /// </summary>
00287     internal sealed class NotificationContentValidationException : COMException
00288     {
00289         public NotificationContentValidationException(string message)
00290             : base(message, unchecked((int)0x80070057))
00291         {
00292         }
00293     }
00294 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/Constants.h Source File

  • SMS message send, receive, and SIM management

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"SMS Send/Receive");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/pch.cpp Source File

  • EAS policies for mail clients

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/PinTile.xaml.cpp Source File

  • Secondary tiles
  • C#,C++

PinTile.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PinTile.xaml.cpp
00013 // Implementation of the PinTile class
00014 //
00015
00016 #include "pch.h"
00017 #include "PinTile.xaml.h"
00018
00019 using namespace SecondaryTiles;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::StartScreen;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Globalization;
00027 using namespace Windows::Globalization::DateTimeFormatting;
00028 using namespace Platform;
00029 using namespace concurrency;
00030
00031 PinTile::PinTile()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void PinTile::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::current;
00046     // Preserve the app bar
00047     appBar = rootPage->BottomAppBar;
00048     // Now null it so we don't show the appbar in this scenario
00049     rootPage->BottomAppBar = nullptr;
00050 }
00051
00052 /// <summary>
00053 /// Invoked when this page is about to be navigated out in a Frame
00054 /// </summary>
00055 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00056 /// property is typically used to configure the page.</param>
00057 void PinTile::OnNavigatingFrom(NavigatingCancelEventArgs^ e)
00058 {
00059     // Restore the app bar
00060     rootPage->BottomAppBar = appBar;
00061 }
00062
00063 void SecondaryTiles::PinTile::PinButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00064 {
00065     Button^ button = safe_cast<Button^>(sender);
00066     if (button != nullptr)
00067     {
00068         // Prepare package images for use as the Tile Logo and small logo in the tile to be pinned.
00069         // The path provided is a relative path to the package
00070         auto logo = ref new Uri("ms-appx:///Assets/squareTile-sdk.png");
00071         auto smallLogo = ref new Uri("ms-appx:///Assets/smallTile-sdk.png");
00072         Calendar^ cal = ref new Calendar();
00073         auto longtime = ref new DateTimeFormatter("longtime");
00074         DateTime time = cal->GetDateTime();
00075
00076         // During creation of secondary tile, an application may set additional arguments on the tile that will be passed in during activation.
00077         // These arguments should be meaningful to the application. In this sample, we will just pass a text as an argument.
00078         String^ tileActivationArguments = rootPage->tileId + " WasPinnedAt=" + longtime->Format(time);
00079
00080         auto secondaryTile = ref new SecondaryTile(rootPage->tileId,
00081             "Title text shown on the tile",
00082             "Name of the tile the user sees when searching for the tile",
00083             tileActivationArguments,
00084             Windows::UI::StartScreen::TileOptions::ShowNameOnLogo,
00085             logo);
00086
00087         // The tile background color is inherited from the parent unless a separate value is specified.
00088         // This operation will over-ride the default.
00089         secondaryTile->ForegroundText = ForegroundText::Dark;
00090
00091         // Like the background color, the small tile logo is inherited from the parent application tile by default.
00092         // This operation will over-ride the default.
00093         secondaryTile->SmallLogo = smallLogo;
00094
00095         // OK, the tile is created and we can now attempt to pin the tile.
00096         // Note that the status message is updated when the async operation to pin the tile completes.
00097         auto const rect = rootPage->GetElementRect(safe_cast<FrameworkElement^>(sender));
00098         create_task(secondaryTile->RequestCreateForSelectionAsync(rect, Windows::UI::Popups::Placement::Below)).then([this](bool isCreated)
00099         {
00100             if (isCreated)
00101             {
00102                 rootPage->NotifyUser("Secondary tile successfully pinned.", NotifyType::StatusMessage);
00103             }
00104             else
00105             {
00106                 rootPage->NotifyUser("Secondary tile not pinned.", NotifyType::ErrorMessage);
00107             }
00108         });
00109     }
00110 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TextFrame Member List

This is the complete list of members for TextFrame, including all inherited members.
__pad0__ | TextFrame |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) | Element | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) override | TextFrame | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) override | TextFrame | [virtual]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() override | TextFrame | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override | TextFrame | [virtual]
m_baseline | TextFrame | [private]
m_bottomMargin | TextFrame | [private]
m_brush | TextFrame | [private]
m_color | TextFrame | [private]
m_compositeEffect | TextFrame | [private]
m_contentBitmap | TextFrame | [private]
m_displaySize | TextFrame | [private]
m_fontSize | TextFrame | [private]
m_glowEffect | TextFrame | [private]
m_leading | TextFrame | [private]
m_opacity | TextFrame | [private]
m_sourceName | TextFrame | [private]
m_sourceText | TextFrame | [private]
m_textAlign | TextFrame | [private]
m_topMargin | TextFrame | [private]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override | TextFrame | [virtual]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) override | TextFrame | [virtual]
ReleaseParent() | Element | [virtual]
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/pch.h Source File

  • Bluetooth call control

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario2.xaml.h Source File

  • XAML WebView control

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace WebViewControl
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void DoSomething_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         void Load_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041       };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/pch.cpp Source File

  • DirectWrite vertical text

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/Constants.cpp Source File

  • IXmlReader and IXmlWriter XML data readwrite

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "XmlLite Reader", "SDKSample.XmlLiteSample.Scenario1" },
00022     { "XmlLite Writer", "SDKSample.XmlLiteSample.Scenario2" }
00023 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario2.xaml.cpp Source File

  • XAML scrolling, panning, and zooming

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::ScrollViewerCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario2::Scenario2()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 // Invoked when this page is about to be displayed in a Frame.
00031 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00032 {
00033     rootPage = MainPage::Current;
00034 }
00035
00036 // Handler for combobox
00037 void SDKSample::ScrollViewerCPP::Scenario2::ComboBox_SelectionChanged_1(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00038 {
00039   if (scrollViewer == nullptr)
00040   {
00041       return;
00042   }
00043
00044   auto cb = (ComboBox^) sender;
00045
00046   if (cb != nullptr)
00047   {
00048       switch (cb->SelectedIndex)
00049       {
00050           case 0: // None
00051               scrollViewer->HorizontalSnapPointsType = SnapPointsType::None;
00052               break;
00053           case 1: //Optional
00054               scrollViewer->HorizontalSnapPointsType = SnapPointsType::Optional;
00055               break;
00056           case 2: // Optional Single
00057               scrollViewer->HorizontalSnapPointsType = SnapPointsType::OptionalSingle;
00058               break;
00059           case 3: // Mandatory
00060               scrollViewer->HorizontalSnapPointsType = SnapPointsType::Mandatory;
00061               break;
00062           case 4: // Mandatory Single
00063               scrollViewer->HorizontalSnapPointsType = SnapPointsType::MandatorySingle;
00064               break;
00065           default:
00066               scrollViewer->HorizontalSnapPointsType = SnapPointsType::None;
00067               break;
00068       }
00069   }
00070 }
00071
00072 // Call Scenario2Reset()
00073 void SDKSample::ScrollViewerCPP::Scenario2::Scenario2Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00074 {
00075   Scenario2Reset();
00076 }
00077
00078 // Reset the scenario
00079 void SDKSample::ScrollViewerCPP::Scenario2::Scenario2Reset()
00080 {
00081   //Restore to defaults
00082   scrollViewer->HorizontalSnapPointsType = SnapPointsType::None;
00083   snapPointsCombo->SelectedIndex = 0;
00084 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/PreviewUnavailable.xaml.cpp Source File

  • Print

PreviewUnavailable.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // PreviewUnavailable.xaml.cpp
00010 // Implementation of the PreviewUnavailable class
00011 //
00012
00013 #include "pch.h"
00014 #include "PreviewUnavailable.xaml.h"
00015
00016 using namespace PrintSample;
00017
00018 using namespace Platform;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Controls::Primitives;
00024 using namespace Windows::UI::Xaml::Data;
00025 using namespace Windows::UI::Xaml::Input;
00026 using namespace Windows::UI::Xaml::Media;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 PreviewUnavailable::PreviewUnavailable()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 /// <summary>
00035 /// Preview unavailable page constructor
00036 /// </summary>
00037 /// <param name="paperSize">The printing page paper size</param>
00038 /// <param name="printableSize">The usable/"printable" area on the page</param>
00039 PreviewUnavailable::PreviewUnavailable(Size paperSize, Size printableSize)
00040 {
00041     InitializeComponent();
00042
00043     page->Width = paperSize.Width;
00044     page->Height  = paperSize.Height;
00045
00046     printablePage->Width = printableSize.Width;
00047     printablePage->Height = printableSize.Height;
00048 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/common/LayoutAwarePage.h Source File

  • App tiles and badges
  • C#,C++
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Constants.h Source File

  • SimpleOrientationSensor

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"SimpleOrientation Sensor Raw Data");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/C++/Background/pch.cpp Source File

  • ControlChannelTrigger StreamSocket
  • Background

pch.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // pch.cpp
00003 // Include the standard header and generate the precompiled header.
00004 //
00005
00006 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/MainPage.xaml.h Source File

  • Custom driver access
  • app_cpp

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/pch.cpp Source File

  • Direct2D geometry realization

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/DirectXBase.cpp Source File

  • XInput game controller

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/CoreWindowEvents.h Source File

  • DirectX swap chain implementation

CoreWindowEvents.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012
00013 ref class CoreWindowEvents : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00014 {
00015 public:
00016
00017     // DirectXBase Methods
00018     virtual void CreateDeviceIndependentResources() override;
00019     virtual void CreateDeviceResources() override;
00020     virtual void Render() override;
00021
00022     // IFrameworkView Methods
00023     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00024     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00025     virtual void Load(_In_ Platform::String^ entryPoint);
00026     virtual void Run();
00027     virtual void Uninitialize();
00028
00029     // Event Handlers
00030     void OnWindowSizeChanged(
00031         _In_ Windows::UI::Core::CoreWindow^ sender,
00032         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00033         );
00034
00035     void OnCharacterReceived(
00036         _In_ Windows::UI::Core::CoreWindow^ sender,
00037         _In_ Windows::UI::Core::CharacterReceivedEventArgs^ args
00038         );
00039
00040     void CoreWindowEvents::OnKeyDown(
00041         _In_ Windows::UI::Core::CoreWindow^ sender,
00042         _In_ Windows::UI::Core::KeyEventArgs^ args
00043         );
00044
00045     void CoreWindowEvents::OnKeyUp(
00046         _In_ Windows::UI::Core::CoreWindow^ sender,
00047         _In_ Windows::UI::Core::KeyEventArgs^ args
00048         );
00049
00050     void CoreWindowEvents::OnPointerPressed(
00051         _In_ Windows::UI::Core::CoreWindow^ sender,
00052         _In_ Windows::UI::Core::PointerEventArgs^ args
00053         );
00054
00055     void CoreWindowEvents::OnPointerReleased(
00056         _In_ Windows::UI::Core::CoreWindow^ sender,
00057         _In_ Windows::UI::Core::PointerEventArgs^ args
00058         );
00059
00060     void CoreWindowEvents::OnPointerMoved(
00061         _In_ Windows::UI::Core::CoreWindow^ sender,
00062         _In_ Windows::UI::Core::PointerEventArgs^ args
00063         );
00064
00065     void CoreWindowEvents::OnWindowActivated(
00066         _In_ Windows::UI::Core::CoreWindow^ sender,
00067         _In_ Windows::UI::Core::WindowActivatedEventArgs^ args
00068         );
00069
00070     void OnLogicalDpiChanged(
00071         _In_ Platform::Object^ sender
00072         );
00073
00074     void OnDisplayContentsInvalidated(
00075         _In_ Platform::Object^ sender
00076         );
00077
00078     void OnActivated(
00079         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00080         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00081         );
00082
00083 private:
00084     void EventPrint(
00085         _In_ Platform::String^ eventText
00086         );
00087
00088     void CoreWindowEvents::PrintPointerInfo(
00089         _In_ Platform::String^ eventText,
00090         _In_ Windows::UI::Core::PointerEventArgs^ args
00091         );
00092
00093     SampleOverlay^                                  m_sampleOverlay;
00094     Microsoft::WRL::ComPtr<IDWriteTextFormat>       m_eventTextFormat;
00095     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_blackBrush;
00096     Platform::String^                               m_eventName;
00097 };
00098
00099 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00100 {
00101 public:
00102     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00103 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/Constants.h Source File

  • Message dialog

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"MessageDialog C++ sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/LayoutAwarePage.h Source File

  • File picker
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/MainPage.xaml.cpp Source File

  • Direct2D 3D transform effect

MainPage.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "MainPage.xaml.h"
00010
00011 using namespace D2D3DTransforms;
00012
00013 using namespace Platform;
00014 using namespace Windows::ApplicationModel;
00015 using namespace Windows::ApplicationModel::Core;
00016 using namespace Windows::ApplicationModel::Activation;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Foundation::Collections;
00019 using namespace Windows::Graphics::Display;
00020 using namespace Windows::Storage;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Media::Media3D;
00031 using namespace Windows::UI::Xaml::Navigation;
00032 using namespace Microsoft::WRL;
00033
00034 MainPage::MainPage()
00035 {
00036     m_renderer = ref new D2D3DTransformsRenderer();
00037     m_renderer->Initialize(Window::Current->CoreWindow, this, DisplayProperties::LogicalDpi);
00038
00039     InitializeComponent();
00040
00041     DisplayProperties::LogicalDpiChanged +=
00042         ref new DisplayPropertiesEventHandler(this, &MainPage::OnLogicalDpiChanged);
00043
00044     DisplayProperties::DisplayContentsInvalidated +=
00045         ref new DisplayPropertiesEventHandler(this, &MainPage::OnDisplayContentsInvalidated);
00046
00047     Window::Current->CoreWindow->SizeChanged +=
00048         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &MainPage::OnWindowSizeChanged);
00049
00050     InitializeValues();
00051     m_renderer->Render();
00052 }
00053
00054 void MainPage::OnEffectSelectorSelectionChanged(
00055     Object^ sender,
00056     SelectionChangedEventArgs^ args
00057     )
00058 {
00059     switch (EffectSelector->SelectedIndex)
00060     {
00061     case TransformEffect::D2D13DTransform:
00062         ScaleX->IsEnabled = true; // 3DTransform supports scaling via
00063         ScaleY->IsEnabled = true; // the Matrix4x4::Scale helper.
00064         break;
00065     case TransformEffect::D2D13DPerspectiveTransform:
00066         ScaleX->IsEnabled = false; // 3DPerspectiveTransform does not have a 'Scale' property. A similar effect
00067         ScaleY->IsEnabled = false; // can be achieved by changing the Z value on the Local/GlobalOffset property.
00068         break;
00069     }
00070
00071     SetTransformEffect(static_cast<TransformEffect>(EffectSelector->SelectedIndex));
00072 }
00073
00074 void MainPage::OnScaleXValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00075 {
00076     SetTransformProperty(
00077         TransformProperty::ScaleX,
00078         static_cast<float>(args->NewValue)
00079         );
00080 }
00081
00082 void MainPage::OnScaleYValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00083 {
00084     SetTransformProperty(
00085         TransformProperty::ScaleY,
00086         static_cast<float>(args->NewValue)
00087         );
00088 }
00089
00090 void MainPage::OnLocalOffsetXValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00091 {
00092     SetTransformProperty(
00093         TransformProperty::LocalOffsetX,
00094         static_cast<float>(args->NewValue)
00095         );
00096 }
00097
00098 void MainPage::OnLocalOffsetYValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00099 {
00100     SetTransformProperty(
00101         TransformProperty::LocalOffsetY,
00102         static_cast<float>(args->NewValue)
00103         );
00104 }
00105
00106 void MainPage::OnLocalOffsetZValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00107 {
00108     SetTransformProperty(
00109         TransformProperty::LocalOffsetZ,
00110         static_cast<float>(args->NewValue)
00111         );
00112 }
00113
00114 void MainPage::OnRotationXValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00115 {
00116     SetTransformProperty(
00117         TransformProperty::RotationX,
00118         static_cast<float>(args->NewValue)
00119         );
00120 }
00121
00122 void MainPage::OnRotationYValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00123 {
00124     SetTransformProperty(
00125         TransformProperty::RotationY,
00126         static_cast<float>(args->NewValue)
00127         );
00128 }
00129
00130 void MainPage::OnRotationZValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00131 {
00132     SetTransformProperty(
00133         TransformProperty::RotationZ,
00134         static_cast<float>(args->NewValue)
00135         );
00136 }
00137
00138 void MainPage::OnGlobalOffsetXValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00139 {
00140     SetTransformProperty(
00141         TransformProperty::GlobalOffsetX,
00142         static_cast<float>(args->NewValue)
00143         );
00144 }
00145
00146 void MainPage::OnGlobalOffsetYValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00147 {
00148     SetTransformProperty(
00149         TransformProperty::GlobalOffsetY,
00150         static_cast<float>(args->NewValue)
00151         );
00152 }
00153
00154 void MainPage::OnGlobalOffsetZValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00155 {
00156     SetTransformProperty(
00157         TransformProperty::GlobalOffsetZ,
00158         static_cast<float>(args->NewValue)
00159         );
00160 }
00161
00162 void MainPage::OnPerspectiveValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ args)
00163 {
00164     SetTransformProperty(
00165         TransformProperty::Perspective,
00166         static_cast<float>(args->NewValue)
00167         );
00168 }
00169
00170 void MainPage::OnRestoreDefaultsClick(Object^ sender, RoutedEventArgs^ args)
00171 {
00172     ResetValues();
00173     m_renderer->Render();
00174 }
00175
00176 void MainPage::InitializeValues()
00177 {
00178     // Retrieve user-manipulated variables from the LocalSettings collection if the app was previously terminated
00179     // after being suspended. If the app is resumed from a suspended state, the properties will be preserved regardless.
00180     PersistentState^ stateHelper = ref new PersistentState();
00181     stateHelper->Initialize(ApplicationData::Current->LocalSettings->Values, "appSettings");
00182
00183     EffectSelector->SelectedIndex = stateHelper->LoadInt32("CurrentEffect", 0);
00184     ScaleX->Value = stateHelper->LoadSingle("ScaleX", 1);
00185     ScaleY->Value = stateHelper->LoadSingle("ScaleY", 1);
00186     LocalOffsetX->Value = stateHelper->LoadSingle("LocalOffsetX", 0);
00187     LocalOffsetY->Value = stateHelper->LoadSingle("LocalOffsetY", 0);
00188     LocalOffsetZ->Value = stateHelper->LoadSingle("LocalOffsetZ", 0);
00189     RotationX->Value = stateHelper->LoadSingle("RotationX", 0);
00190     RotationY->Value = stateHelper->LoadSingle("RotationY", 0);
00191     RotationZ->Value = stateHelper->LoadSingle("RotationZ", 0);
00192     GlobalOffsetX->Value = stateHelper->LoadSingle("GlobalOffsetX", 0);
00193     GlobalOffsetY->Value = stateHelper->LoadSingle("GlobalOffsetY", 0);
00194     GlobalOffsetZ->Value = stateHelper->LoadSingle("GlobalOffsetZ", 0);
00195     Perspective->Value = stateHelper->LoadSingle("Perspective", 1500);
00196 }
00197
00198 void MainPage::ResetValues()
00199 {
00200     EffectSelector->SelectedIndex = 0;
00201     ScaleX->Value = 1;
00202     ScaleY->Value = 1;
00203     LocalOffsetX->Value = 0;
00204     LocalOffsetY->Value = 0;
00205     LocalOffsetZ->Value = 0;
00206     RotationX->Value = 0;
00207     RotationY->Value = 0;
00208     RotationZ->Value = 0;
00209     GlobalOffsetX->Value = 0;
00210     GlobalOffsetY->Value = 0;
00211     GlobalOffsetZ->Value = 0;
00212     Perspective->Value = 1500;
00213 }
00214
00215 void MainPage::SetTransformEffect(TransformEffect transformEffect)
00216 {
00217     m_renderer->SetTransformEffect(transformEffect);
00218 }
00219
00220 void MainPage::SetTransformProperty(TransformProperty transformProperty, float value)
00221 {
00222     m_renderer->SetTransformProperty(transformProperty, value);
00223 }
00224
00225 void MainPage::OnSuspending(
00226     Object^ sender,
00227     SuspendingEventArgs^ args
00228     )
00229 {
00230     // Store user-manipulated properties in the LocalSettings collection.
00231     PersistentState^ stateHelper = ref new PersistentState();
00232     stateHelper->Initialize(ApplicationData::Current->LocalSettings->Values, "appSettings");
00233
00234     stateHelper->SaveInt32("CurrentEffect", EffectSelector->SelectedIndex);
00235     stateHelper->SaveSingle("ScaleX", static_cast<float>(ScaleX->Value));
00236     stateHelper->SaveSingle("ScaleY", static_cast<float>(ScaleY->Value));
00237     stateHelper->SaveSingle("LocalOffsetX", static_cast<float>(LocalOffsetX->Value));
00238     stateHelper->SaveSingle("LocalOffsetY", static_cast<float>(LocalOffsetY->Value));
00239     stateHelper->SaveSingle("LocalOffsetZ", static_cast<float>(LocalOffsetZ->Value));
00240     stateHelper->SaveSingle("RotationX", static_cast<float>(RotationX->Value));
00241     stateHelper->SaveSingle("RotationY", static_cast<float>(RotationY->Value));
00242     stateHelper->SaveSingle("RotationZ", static_cast<float>(RotationZ->Value));
00243     stateHelper->SaveSingle("GlobalOffsetX", static_cast<float>(GlobalOffsetX->Value));
00244     stateHelper->SaveSingle("GlobalOffsetY", static_cast<float>(GlobalOffsetY->Value));
00245     stateHelper->SaveSingle("GlobalOffsetZ", static_cast<float>(GlobalOffsetZ->Value));
00246     stateHelper->SaveSingle("Perspective", static_cast<float>(Perspective->Value));
00247 }
00248
00249 void MainPage::OnLogicalDpiChanged(
00250     Object^ sender
00251     )
00252 {
00253     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00254 }
00255
00256 void MainPage::OnDisplayContentsInvalidated(
00257     Object^ sender
00258     )
00259 {
00260     // Ensure the D3D Device is available for rendering.
00261     m_renderer->ValidateDevice();
00262
00263     m_renderer->Render();
00264 }
00265
00266 void MainPage::OnWindowSizeChanged(
00267     CoreWindow^ sender,
00268     WindowSizeChangedEventArgs^ args
00269     )
00270 {
00271     if (ApplicationView::Value == ApplicationViewState::Snapped)
00272     {
00273         VisualStateManager::GoToState(this->LayoutControl, "SnappedState", true);
00274     }
00275     else
00276     {
00277         VisualStateManager::GoToState(this->LayoutControl, "UnsnappedState", true);
00278     }
00279
00280     m_renderer->UpdateForViewStateChanged(ApplicationView::Value);
00281     m_renderer->UpdateForWindowSizeChange();
00282 }
Generated on Sat Nov 23 2024 16:07:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/App.xaml.cpp Source File

  • Reading and writing data

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::MediaServerClient::sealed Member List

This is the complete list of members for SDKSample::MediaServerClient::sealed, including all inherited members.
dmsRefreshButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MediaServerClient::sealed | [private]
dmsSelect_SelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::MediaServerClient::sealed | [private]
InitializeMediaServers() | SDKSample::MediaServerClient::sealed | [private]
LoadMediaFiles() | SDKSample::MediaServerClient::sealed | [private]
localVideo_CurrentStateChanged(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MediaServerClient::sealed | [private]
localVideo_MediaFailed(Platform::Object^sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^e) | SDKSample::MediaServerClient::sealed | [private]
mediaFile | SDKSample::MediaServerClient::sealed | [private]
mediaFiles | SDKSample::MediaServerClient::sealed | [private]
mediaSelect_SelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::MediaServerClient::sealed | [private]
mediaServers | SDKSample::MediaServerClient::sealed | [private]
mediaStream | SDKSample::MediaServerClient::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::MediaServerClient::sealed | [protected, virtual]
rootPage | SDKSample::MediaServerClient::sealed | [private]
Scenario1() | SDKSample::MediaServerClient::sealed |
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/common/LayoutAwarePage.cpp Source File

  • Message dialog
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/common/suspensionmanager.h Source File

  • XAML WebView control
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/Constants.cs Source File

  • Real-time communication
  • C#,C++

Constants.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using System.Collections.Generic;
00012 using System;
00013
00014 namespace SDKTemplate
00015 {
00016     public partial class MainPage : SDKTemplate.Common.LayoutAwarePage
00017     {
00018         // Change the string below to reflect the name of your sample.
00019         // This is used on the main page as the title of the sample.
00020         public const string FEATURE_NAME = "Simple Communication";
00021
00022         public bool DeviceChecked = false;
00023         public bool CameraFound = false;
00024
00025         Windows.Media.MediaExtensionManager mediaExtensionMgr;
00026
00027         // Change the array below to reflect the name of your scenarios.
00028         // This will be used to populate the list of scenarios on the main page with
00029         // which the user will choose the specific scenario that they are interested in.
00030         // These should be in the form: "Navigating to a web page".
00031         // The code in MainPage will take care of turning this into: "1) Navigating to a web page"
00032         List<Scenario> scenarios = new List<Scenario>
00033         {
00034             new Scenario() { Title = "Low Latency", ClassType = typeof(SimpleCommunication.LowLatency) },
00035             new Scenario() { Title = "Video Chat", ClassType = typeof(SimpleCommunication.VideoChat) }
00036         };
00037
00038         public void EnsureMediaExtensionManager()
00039         {
00040             if (mediaExtensionMgr == null)
00041             {
00042                 mediaExtensionMgr = new Windows.Media.MediaExtensionManager();
00043                 mediaExtensionMgr.RegisterSchemeHandler("Microsoft.Samples.SimpleCommunication.StspSchemeHandler", "stsp:");
00044             }
00045         }
00046     }
00047
00048     public class Scenario
00049     {
00050         public string Title { get; set; }
00051
00052         public Type ClassType { get; set; }
00053
00054         public override string ToString()
00055         {
00056             return Title;
00057         }
00058     }
00059 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/DirectXBase.cpp Source File

  • Direct2D custom image effects
  • ComputeShader

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // This app requires at least D3D Feature Level 10 in order to run its compute shaders.
00101     D3D_FEATURE_LEVEL featureLevels[] =
00102     {
00103         D3D_FEATURE_LEVEL_11_1,
00104         D3D_FEATURE_LEVEL_11_0,
00105         D3D_FEATURE_LEVEL_10_1,
00106         D3D_FEATURE_LEVEL_10_0
00107     };
00108
00109     // Create the Direct3D 11 API device object and a corresponding context.
00110     ComPtr<ID3D11Device> device;
00111     ComPtr<ID3D11DeviceContext> context;
00112
00113     HRESULT hr = D3D11CreateDevice(
00114         nullptr,                    // Specify null to use the default adapter.
00115         D3D_DRIVER_TYPE_HARDWARE,
00116         0,
00117         creationFlags,              // Set debug and Direct2D compatibility flags.
00118         featureLevels,              // List of feature levels this app can support.
00119         ARRAYSIZE(featureLevels),
00120         D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00121         &device,                    // Returns the Direct3D device created.
00122         &m_featureLevel,            // Returns feature level of device created.
00123         &context                    // Returns the device immediate context.
00124         );
00125
00126     D3D11_FEATURE_DATA_D3D10_X_HARDWARE_OPTIONS hardwareOptions = {0};
00127
00128     // Only check device for compute shader support if it was created in first place. Feature Level 9_* will fail creation.
00129     if (SUCCEEDED(hr))
00130     {
00131         // Check device to ensure it supports compute shaders. Some DX10 devices do, while some do not.
00132         DX::ThrowIfFailed(
00133             device->CheckFeatureSupport(
00134                 D3D11_FEATURE_D3D10_X_HARDWARE_OPTIONS,
00135                 &hardwareOptions,
00136                 sizeof(hardwareOptions)
00137                 )
00138             );
00139     }
00140
00141     // If hardware does not support DirectX feature levels 10/11 or does not support compute shaders, fall back to WARP.
00142     if (hr == DXGI_ERROR_UNSUPPORTED || !hardwareOptions.ComputeShaders_Plus_RawAndStructuredBuffers_Via_Shader_4_x)
00143     {
00144         DX::ThrowIfFailed(
00145             D3D11CreateDevice(
00146                 nullptr,                    // Specify null to use the default adapter.
00147                 D3D_DRIVER_TYPE_WARP,       // Use WARP instead of HARDWARE.
00148                 0,
00149                 creationFlags,              // Set debug and Direct2D compatibility flags.
00150                 featureLevels,              // List of feature levels this app can support.
00151                 ARRAYSIZE(featureLevels),
00152                 D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION.
00153                 &device,                    // Returns the Direct3D device created.
00154                 &m_featureLevel,            // Returns feature level of device created.
00155                 &context                    // Returns the device immediate context.
00156                 )
00157             );
00158     }
00159
00160     // Get the Direct3D 11.1 API device and context interfaces.
00161     DX::ThrowIfFailed(
00162         device.As(&m_d3dDevice)
00163         );
00164
00165     DX::ThrowIfFailed(
00166         context.As(&m_d3dContext)
00167         );
00168
00169     // Get the underlying DXGI device of the Direct3D device.
00170     DX::ThrowIfFailed(
00171         m_d3dDevice.As(&dxgiDevice)
00172         );
00173
00174     // Create the Direct2D device object and a corresponding context.
00175     DX::ThrowIfFailed(
00176         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00177         );
00178
00179     DX::ThrowIfFailed(
00180         m_d2dDevice->CreateDeviceContext(
00181             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00182             &m_d2dContext
00183             )
00184         );
00185 }
00186
00187 // Helps track the DPI in the helper class.
00188 // This is called in the dpiChanged event handler in the view class.
00189 void DirectXBase::SetDpi(float dpi)
00190 {
00191     if (dpi != m_dpi)
00192     {
00193         // Save the DPI of this display in our class.
00194         m_dpi = dpi;
00195
00196         // Update Direct2D's stored DPI.
00197         m_d2dContext->SetDpi(m_dpi, m_dpi);
00198
00199         // Often a DPI change implies a window size change. In some cases Windows will issue
00200         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00201         // will not change, and the window resize code will only be executed once.
00202         UpdateForWindowSizeChange();
00203     }
00204 }
00205
00206 // This routine is called in the event handler for the view SizeChanged event.
00207 void DirectXBase::UpdateForWindowSizeChange()
00208 {
00209     // Only handle window size changed if there is no pending DPI change.
00210     if (m_dpi != DisplayProperties::LogicalDpi)
00211     {
00212         return;
00213     }
00214
00215     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00216         m_window->Bounds.Height != m_windowBounds.Height)
00217     {
00218         m_d2dContext->SetTarget(nullptr);
00219         m_d2dTargetBitmap = nullptr;
00220         m_d3dRenderTargetView = nullptr;
00221         m_d3dDepthStencilView = nullptr;
00222         m_windowSizeChangeInProgress = true;
00223         CreateWindowSizeDependentResources();
00224     }
00225 }
00226
00227 // Allocate all memory resources that change on a window SizeChanged event.
00228 void DirectXBase::CreateWindowSizeDependentResources()
00229 {
00230     // Store the window bounds so the next time we get a SizeChanged event we can
00231     // avoid rebuilding everything if the size is identical.
00232     m_windowBounds = m_window->Bounds;
00233
00234     if (m_swapChain != nullptr)
00235     {
00236         // If the swap chain already exists, resize it.
00237         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00238
00239         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00240         {
00241             // If the device was removed for any reason, a new device and swapchain will need to be created.
00242             HandleDeviceLost();
00243
00244             // Everything is set up now. Do not continue execution of this method.
00245             return;
00246         }
00247         else
00248         {
00249             DX::ThrowIfFailed(hr);
00250         }
00251     }
00252     else
00253     {
00254         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00255         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00256         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00257         swapChainDesc.Height = 0;
00258         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swapchain format.
00259         swapChainDesc.Stereo = false;
00260         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00261         swapChainDesc.SampleDesc.Quality = 0;
00262         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00263         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00264         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00265         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00266         swapChainDesc.Flags = 0;
00267
00268         ComPtr<IDXGIDevice1>  dxgiDevice;
00269         DX::ThrowIfFailed(
00270             m_d3dDevice.As(&dxgiDevice)
00271             );
00272
00273         ComPtr<IDXGIAdapter> dxgiAdapter;
00274         DX::ThrowIfFailed(
00275             dxgiDevice->GetAdapter(&dxgiAdapter)
00276             );
00277
00278         ComPtr<IDXGIFactory2> dxgiFactory;
00279         DX::ThrowIfFailed(
00280             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00281             );
00282
00283         CoreWindow^ window = m_window.Get();
00284         DX::ThrowIfFailed(
00285             dxgiFactory->CreateSwapChainForCoreWindow(
00286                 m_d3dDevice.Get(),
00287                 reinterpret_cast<IUnknown*>(window),
00288                 &swapChainDesc,
00289                 nullptr,
00290                 &m_swapChain
00291                 )
00292             );
00293
00294         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00295         // ensures that the application will only render after each VSync, minimizing power consumption.
00296         DX::ThrowIfFailed(
00297             dxgiDevice->SetMaximumFrameLatency(1)
00298             );
00299     }
00300
00301     // Create a Direct3D render target view of the swap chain back buffer.
00302     ComPtr<ID3D11Texture2D> backBuffer;
00303     DX::ThrowIfFailed(
00304         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00305         );
00306
00307     DX::ThrowIfFailed(
00308         m_d3dDevice->CreateRenderTargetView(
00309             backBuffer.Get(),
00310             nullptr,
00311             &m_d3dRenderTargetView
00312             )
00313         );
00314
00315     // Cache the rendertarget dimensions in our helper class for convenient use.
00316     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00317     backBuffer->GetDesc(&backBufferDesc);
00318     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00319     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00320
00321     // Create a depth stencil view for use with 3D rendering if needed.
00322     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00323         DXGI_FORMAT_D24_UNORM_S8_UINT,
00324         backBufferDesc.Width,
00325         backBufferDesc.Height,
00326         1,
00327         1,
00328         D3D11_BIND_DEPTH_STENCIL
00329         );
00330
00331     ComPtr<ID3D11Texture2D> depthStencil;
00332     DX::ThrowIfFailed(
00333         m_d3dDevice->CreateTexture2D(
00334             &depthStencilDesc,
00335             nullptr,
00336             &depthStencil
00337             )
00338         );
00339
00340     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00341     DX::ThrowIfFailed(
00342         m_d3dDevice->CreateDepthStencilView(
00343             depthStencil.Get(),
00344             &viewDesc,
00345             &m_d3dDepthStencilView
00346             )
00347         );
00348
00349     // Set the 3D rendering viewport to target the entire window.
00350     CD3D11_VIEWPORT viewport(
00351         0.0f,
00352         0.0f,
00353         static_cast<float>(backBufferDesc.Width),
00354         static_cast<float>(backBufferDesc.Height)
00355         );
00356
00357     m_d3dContext->RSSetViewports(1, &viewport);
00358
00359     // Create a Direct2D target bitmap associated with the
00360     // swap chain back buffer and set it as the current target.
00361     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00362         BitmapProperties1(
00363             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00364             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00365             m_dpi,
00366             m_dpi
00367             );
00368
00369     ComPtr<IDXGISurface> dxgiBackBuffer;
00370     DX::ThrowIfFailed(
00371         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00372         );
00373
00374     DX::ThrowIfFailed(
00375         m_d2dContext->CreateBitmapFromDxgiSurface(
00376             dxgiBackBuffer.Get(),
00377             &bitmapProperties,
00378             &m_d2dTargetBitmap
00379             )
00380         );
00381
00382     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00383
00384     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00385     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00386 }
00387
00388 // Method to deliver the final image to the display.
00389 void DirectXBase::Present()
00390 {
00391     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00392     // in certain scenarios.  In this sample, however, we do not utilize those features.
00393     DXGI_PRESENT_PARAMETERS parameters = {0};
00394     parameters.DirtyRectsCount = 0;
00395     parameters.pDirtyRects = nullptr;
00396     parameters.pScrollRect = nullptr;
00397     parameters.pScrollOffset = nullptr;
00398
00399     // The first argument instructs DXGI to block until VSync, putting the application
00400     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00401     // frames that will never be displayed to the screen.
00402     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00403
00404     // Discard the contents of the render target.
00405     // This is a valid operation only when the existing contents will be entirely
00406     // overwritten. If dirty or scroll rects are used, this call should be removed.
00407     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00408
00409     // Discard the contents of the depth stencil.
00410     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00411
00412     // If the device was removed either by a disconnect or a driver upgrade, we
00413     // must recreate all device resources.
00414     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00415     {
00416         HandleDeviceLost();
00417     }
00418     else
00419     {
00420         DX::ThrowIfFailed(hr);
00421     }
00422
00423     if (m_windowSizeChangeInProgress)
00424     {
00425         // A window size change has been initiated and the app has just completed presenting
00426         // the first frame with the new size. Notify the resize manager so we can short
00427         // circuit any resize animation and prevent unnecessary delays.
00428         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00429         m_windowSizeChangeInProgress = false;
00430     }
00431 }
00432
00433 void DirectXBase::ValidateDevice()
00434 {
00435     // The D3D Device is no longer valid if the default adapter changes or if
00436     // the device has been removed.
00437
00438     // First, get the information for the adapter related to the current device.
00439
00440     ComPtr<IDXGIDevice1> dxgiDevice;
00441     ComPtr<IDXGIAdapter> deviceAdapter;
00442     DXGI_ADAPTER_DESC deviceDesc;
00443     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00444     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00445     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00446
00447     // Next, get the information for the default adapter.
00448
00449     ComPtr<IDXGIFactory2> dxgiFactory;
00450     ComPtr<IDXGIAdapter1> currentAdapter;
00451     DXGI_ADAPTER_DESC currentDesc;
00452     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00453     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00454     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00455
00456     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00457     // a new D3D device must be created.
00458
00459     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00460         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00461         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00462     {
00463         // Release references to resources related to the old device.
00464         dxgiDevice = nullptr;
00465         deviceAdapter = nullptr;
00466
00467         // Create a new device and swap chain.
00468         HandleDeviceLost();
00469     }
00470 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/common/LayoutAwarePage.h Source File

  • Input Touch keyboard text input
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/Constants.cpp Source File

  • Device enumeration

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     { "Device interfaces", "SDKSample.DeviceEnumeration.Interfaces" },
00020     { "Device containers", "SDKSample.DeviceEnumeration.Containers" }
00021 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/DeviceAppPage.xaml.h Source File

  • Windows Store device app for camera

DeviceAppPage.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DeviceAppPage.xaml.h
00013 // Declaration of the DeviceAppPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "DeviceAppPage.g.h"
00020 #include <agile.h>
00021 using namespace Windows::ApplicationModel::Activation;
00022 using namespace Windows::Media::Devices;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Controls::Primitives;
00026 using namespace Windows::UI::Xaml::Data;
00027 using namespace Wrapper;
00028
00029 namespace DeviceAppForWebcam
00030 {
00031     [Windows::Foundation::Metadata::WebHostHidden]
00032     public ref class DeviceAppPage sealed
00033     {
00034         ~DeviceAppPage();
00035         Platform::Agile<Windows::Media::Devices::VideoDeviceController> videoDevController;
00036         Wrapper::WinRTComponent^ lcWrapper;
00037
00038     public:
00039         DeviceAppPage();
00040         void Initialize(CameraSettingsActivatedEventArgs^ args);
00041         void OnBrtAutoToggleChanged(Object^ sender, RoutedEventArgs^ e);
00042         void OnBrtSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e);
00043         void OnCrtAutoToggleChanged(Object^ sender, RoutedEventArgs^ e);
00044         void OnCrtSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e);
00045         void OnFocusAutoToggleChanged(Object^ sender, RoutedEventArgs^ e);
00046         void OnFocusSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e);
00047         void OnExpAutoToggleChanged(Object^ sender, RoutedEventArgs^ e);
00048         void OnExpSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e);
00049         void OnEffectEnabledToggleChanged(Object^ sender, RoutedEventArgs^ e);
00050         void OnEffectSliderValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e);
00051     };
00052 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/pch.h Source File

  • Lock screen apps
  • C#,C++

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
00007 #include "CppSamplesUtils.h"
00008 #include <ppltasks.h>
00009
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTex.inl Source File

  • Direct3D resource loading
  • texconv

DirectXTex.inl

Go to the documentation of this file.
00001 //-------------------------------------------------------------------------------------
00002 // DirectXTex.inl
00003 //
00004 // DirectX Texture Library
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //-------------------------------------------------------------------------------------
00013
00014 #if defined(_MSC_VER) && (_MSC_VER > 1000)
00015 #pragma once
00016 #endif
00017
00018 //=====================================================================================
00019 // DXGI Format Utilities
00020 //=====================================================================================
00021
00022 _Use_decl_annotations_
00023 inline bool IsValid( DXGI_FORMAT fmt )
00024 {
00025     return ( static_cast<size_t>(fmt) >= 1 && static_cast<size_t>(fmt) <= 115 );
00026 }
00027
00028 _Use_decl_annotations_
00029 inline bool IsCompressed( DXGI_FORMAT fmt )
00030 {
00031     switch ( fmt )
00032     {
00033     case DXGI_FORMAT_BC1_TYPELESS:
00034     case DXGI_FORMAT_BC1_UNORM:
00035     case DXGI_FORMAT_BC1_UNORM_SRGB:
00036     case DXGI_FORMAT_BC2_TYPELESS:
00037     case DXGI_FORMAT_BC2_UNORM:
00038     case DXGI_FORMAT_BC2_UNORM_SRGB:
00039     case DXGI_FORMAT_BC3_TYPELESS:
00040     case DXGI_FORMAT_BC3_UNORM:
00041     case DXGI_FORMAT_BC3_UNORM_SRGB:
00042     case DXGI_FORMAT_BC4_TYPELESS:
00043     case DXGI_FORMAT_BC4_UNORM:
00044     case DXGI_FORMAT_BC4_SNORM:
00045     case DXGI_FORMAT_BC5_TYPELESS:
00046     case DXGI_FORMAT_BC5_UNORM:
00047     case DXGI_FORMAT_BC5_SNORM:
00048     case DXGI_FORMAT_BC6H_TYPELESS:
00049     case DXGI_FORMAT_BC6H_UF16:
00050     case DXGI_FORMAT_BC6H_SF16:
00051     case DXGI_FORMAT_BC7_TYPELESS:
00052     case DXGI_FORMAT_BC7_UNORM:
00053     case DXGI_FORMAT_BC7_UNORM_SRGB:
00054         return true;
00055
00056     default:
00057         return false;
00058     }
00059 }
00060
00061 _Use_decl_annotations_
00062 inline bool IsPacked( DXGI_FORMAT fmt )
00063 {
00064     return ( (fmt == DXGI_FORMAT_R8G8_B8G8_UNORM) || (fmt == DXGI_FORMAT_G8R8_G8B8_UNORM) );
00065 }
00066
00067
00068 _Use_decl_annotations_
00069 inline bool IsVideo( DXGI_FORMAT fmt )
00070 {
00071     switch ( fmt )
00072     {
00073     case DXGI_FORMAT_AYUV:
00074     case DXGI_FORMAT_Y410:
00075     case DXGI_FORMAT_Y416:
00076     case DXGI_FORMAT_NV12:
00077     case DXGI_FORMAT_P010:
00078     case DXGI_FORMAT_P016:
00079     case DXGI_FORMAT_YUY2:
00080     case DXGI_FORMAT_Y210:
00081     case DXGI_FORMAT_Y216:
00082     case DXGI_FORMAT_NV11:
00083         // These video formats can be used with the 3D pipeline through special view mappings
00084         return true;
00085
00086     case DXGI_FORMAT_420_OPAQUE:
00087     case DXGI_FORMAT_AI44:
00088     case DXGI_FORMAT_IA44:
00089     case DXGI_FORMAT_P8:
00090     case DXGI_FORMAT_A8P8:
00091         // These are limited use video formats not usable in any way by the 3D pipeline
00092         return true;
00093
00094     default:
00095         return false;
00096     }
00097 }
00098
00099 _Use_decl_annotations_
00100 inline bool IsSRGB( DXGI_FORMAT fmt )
00101 {
00102     switch( fmt )
00103     {
00104     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00105     case DXGI_FORMAT_BC1_UNORM_SRGB:
00106     case DXGI_FORMAT_BC2_UNORM_SRGB:
00107     case DXGI_FORMAT_BC3_UNORM_SRGB:
00108     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00109     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00110     case DXGI_FORMAT_BC7_UNORM_SRGB:
00111         return true;
00112
00113     default:
00114         return false;
00115     }
00116 }
00117
00118 _Use_decl_annotations_
00119 inline bool IsTypeless( DXGI_FORMAT fmt )
00120 {
00121     switch( fmt )
00122     {
00123     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00124     case DXGI_FORMAT_R32G32B32_TYPELESS:
00125     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00126     case DXGI_FORMAT_R32G32_TYPELESS:
00127     case DXGI_FORMAT_R32G8X24_TYPELESS:
00128     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00129     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00130     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00131     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00132     case DXGI_FORMAT_R16G16_TYPELESS:
00133     case DXGI_FORMAT_R32_TYPELESS:
00134     case DXGI_FORMAT_R24G8_TYPELESS:
00135     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00136     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00137     case DXGI_FORMAT_R8G8_TYPELESS:
00138     case DXGI_FORMAT_R16_TYPELESS:
00139     case DXGI_FORMAT_R8_TYPELESS:
00140     case DXGI_FORMAT_BC1_TYPELESS:
00141     case DXGI_FORMAT_BC2_TYPELESS:
00142     case DXGI_FORMAT_BC3_TYPELESS:
00143     case DXGI_FORMAT_BC4_TYPELESS:
00144     case DXGI_FORMAT_BC5_TYPELESS:
00145     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00146     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00147     case DXGI_FORMAT_BC6H_TYPELESS:
00148     case DXGI_FORMAT_BC7_TYPELESS:
00149         return true;
00150
00151     default:
00152         return false;
00153     }
00154 }
00155
00156 _Use_decl_annotations_
00157 inline size_t ComputeScanlines( DXGI_FORMAT fmt, size_t height )
00158 {
00159     switch ( fmt )
00160     {
00161     case DXGI_FORMAT_BC1_TYPELESS:
00162     case DXGI_FORMAT_BC1_UNORM:
00163     case DXGI_FORMAT_BC1_UNORM_SRGB:
00164     case DXGI_FORMAT_BC2_TYPELESS:
00165     case DXGI_FORMAT_BC2_UNORM:
00166     case DXGI_FORMAT_BC2_UNORM_SRGB:
00167     case DXGI_FORMAT_BC3_TYPELESS:
00168     case DXGI_FORMAT_BC3_UNORM:
00169     case DXGI_FORMAT_BC3_UNORM_SRGB:
00170     case DXGI_FORMAT_BC4_TYPELESS:
00171     case DXGI_FORMAT_BC4_UNORM:
00172     case DXGI_FORMAT_BC4_SNORM:
00173     case DXGI_FORMAT_BC5_TYPELESS:
00174     case DXGI_FORMAT_BC5_UNORM:
00175     case DXGI_FORMAT_BC5_SNORM:
00176     case DXGI_FORMAT_BC6H_TYPELESS:
00177     case DXGI_FORMAT_BC6H_UF16:
00178     case DXGI_FORMAT_BC6H_SF16:
00179     case DXGI_FORMAT_BC7_TYPELESS:
00180     case DXGI_FORMAT_BC7_UNORM:
00181     case DXGI_FORMAT_BC7_UNORM_SRGB:
00182         return std::max<size_t>( 1, (height + 3) / 4 );
00183
00184     default:
00185         return height;
00186     }
00187 }
00188
00189 //=====================================================================================
00190 // Image I/O
00191 //=====================================================================================
00192 _Use_decl_annotations_
00193 inline HRESULT SaveToDDSMemory( const Image& image, DWORD flags, Blob& blob )
00194 {
00195     TexMetadata mdata;
00196     memset( &mdata, 0, sizeof(mdata) );
00197     mdata.width = image.width;
00198     mdata.height = image.height;
00199     mdata.depth = 1;
00200     mdata.arraySize = 1;
00201     mdata.mipLevels = 1;
00202     mdata.format = image.format;
00203     mdata.dimension = TEX_DIMENSION_TEXTURE2D;
00204
00205     return SaveToDDSMemory( &image, 1, mdata, flags, blob );
00206 }
00207
00208 _Use_decl_annotations_
00209 inline HRESULT SaveToDDSFile( const Image& image, DWORD flags, LPCWSTR szFile )
00210 {
00211     TexMetadata mdata;
00212     memset( &mdata, 0, sizeof(mdata) );
00213     mdata.width = image.width;
00214     mdata.height = image.height;
00215     mdata.depth = 1;
00216     mdata.arraySize = 1;
00217     mdata.mipLevels = 1;
00218     mdata.format = image.format;
00219     mdata.dimension = TEX_DIMENSION_TEXTURE2D;
00220
00221     return SaveToDDSFile( &image, 1, mdata, flags, szFile );
00222 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/pch.cpp Source File

  • Scheduled notifications
  • C#,C++

pch.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // pch.cpp
00003 // Include the standard header and generate the precompiled header.
00004 //
00005
00006 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/common/LayoutAwarePage.h Source File

  • Account picture name
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include "pch.h"
00014 #include <collection.h>
00015
00016 namespace AccountPictureName
00017 {
00018     namespace Common
00019     {
00020         /// <summary>
00021         /// Typical implementation of Page that provides several important conveniences: application
00022         /// view state to visual state mapping, GoBack and GoHome event handlers, and a default view
00023         /// model.
00024         /// </summary>
00025         [Windows::Foundation::Metadata::WebHostHidden]
00026         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00027         {
00028         internal:
00029             LayoutAwarePage();
00030
00031         public:
00032             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00033             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00034             void InvalidateVisualState();
00035             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00036             {
00037                 Windows::UI::Xaml::DependencyProperty^ get();
00038             };
00039             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ DefaultViewModel
00040             {
00041                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ get();
00042                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ value);
00043             }
00044
00045         protected:
00046             virtual void GoHome(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             virtual void GoBack(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00049
00050         private:
00051             Platform::Collections::Map<Platform::String^, Object^>^ _defaultViewModel;
00052             Windows::Foundation::EventRegistrationToken _windowSizeEventToken;
00053             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00054             void WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00055         };
00056     }
00057 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/App.xaml.cpp Source File

  • XAML FlipView control

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioList.xaml.h Source File

  • Lock screen apps
  • C#,C++

ScenarioList.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioList.xaml.h
00010 // Declaration of the ScenarioList class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioList.g.h"
00017 #include "MainPage.g.h"
00018
00019 using namespace Windows::UI::Xaml::Controls;
00020 using namespace CppSamplesUtils;
00021
00022 namespace LockScreenAppsCPP
00023 {
00024   [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class ScenarioList sealed
00026     {
00027     public:
00028         ScenarioList();
00029
00030     protected:
00031         void Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e);
00032         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033
00034     private:
00035         ~ScenarioList();
00036
00037         MainPage^ rootPage;
00038     };
00039 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/StreamTypeAlert.xaml.h Source File

  • Playback Manager Companion

StreamTypeAlert.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // StreamTypeAlert.xaml.h
00013 // Declaration of the StreamTypeAlert class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "StreamTypeAlert.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "PlaybackControl.xaml.h"
00022
00023 namespace SDKSample
00024 {
00025     namespace PlaybackManager2
00026     {
00027         /// <summary>
00028         /// An empty page that can be used on its own or navigated to within a Frame.
00029         /// </summary>
00030       [Windows::Foundation::Metadata::WebHostHidden]
00031         public ref class StreamTypeAlert sealed
00032         {
00033         public:
00034             StreamTypeAlert();
00035
00036         protected:
00037             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038         private:
00039             MainPage^ rootPage;
00040             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/pch.cpp Source File

  • Direct3D tutorial
  • Lesson3.Cubes

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicMath.h Source File

  • Direct3D stereoscopic 3D

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

FractalVertex Member List

This is the complete list of members for FractalVertex, including all inherited members.
bounds | FractalVertex
pos | FractalVertex
tex | FractalVertex
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/App.xaml.h Source File

  • Input Touch keyboard

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/App.xaml.h Source File

  • XAML accessibility

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario3.xaml.h Source File

  • Compression

Scenario3.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Compression
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario3 sealed
00031         {
00032         public:
00033             Scenario3();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039
00040             void DoScenario(Windows::Storage::Compression::CompressAlgorithm Algorithm);
00041
00042             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void Xpress_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044             void XpressHuff_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045             void Mszip_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046             void Lzms_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);        };
00047     }
00048 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ContactPicker::MainPage Member List

This is the complete list of members for ContactPicker::MainPage, including all inherited members.
scenariosInner ContactPicker::MainPage [private, static]
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/BasicMath.h Source File

  • XAML DirectX 3D shooting game

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/AutoThrottle.cpp Source File

  • Direct3D HLSL fractal generator

AutoThrottle.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 // This class provides a lightweight throttle feedback mechanism for
00009 // variable frame workloads.  The class is initialized with a target
00010 // frame time and a "history" represented as bits in an unsigned int.
00011 // A 1 bit represents a frame that missed its target frame time.
00012 // If the past N frames, corresponding to the maskDecrease/maskIncrease
00013 // values, have all been missed or made, then the update method will
00014 // return a control recommendation to Decrease or Increase the frame
00015 // workload, respectively.  The initial value for the frame history
00016 // is chosen such that the returned control recommendation is to maintain
00017 // frame workload until the history is primed with accurate values.
00018
00019 #include "pch.h"
00020 #include "AutoThrottle.h"
00021
00022 AutoThrottle::AutoThrottle(float targetFrameTime) :
00023     m_missedFrameHistory(0xCCCCCCCC),
00024     m_targetFrameTime(targetFrameTime)
00025 {
00026 }
00027
00028 FrameWorkload AutoThrottle::Update(float frameTime)
00029 {
00030     static const float epsilon = 0.005f; // Compensation for noise in the frameTime value.
00031     static const unsigned int maskIncrease = 0x0000001F; // Require 5 made frames to increase workload.
00032     static const unsigned int maskDecrease = 0x00000003; // Require 2 missed frames to decrease workload.
00033
00034     // Shift history back by one frame.  The LSB represents the most recent frame.
00035     m_missedFrameHistory <<= 1;
00036
00037     if (frameTime > m_targetFrameTime - epsilon)
00038     {
00039         m_missedFrameHistory |= 1;
00040     }
00041
00042     if ((m_missedFrameHistory & maskIncrease) == 0)
00043     {
00044         return FrameWorkload::Increase;
00045     }
00046     if ((m_missedFrameHistory & maskDecrease) == maskDecrease)
00047     {
00048         return FrameWorkload::Decrease;
00049     }
00050
00051     return FrameWorkload::Maintain;
00052 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/common/suspensionmanager.h Source File

  • XAML animation library
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/VideoChat.xaml.cpp Source File

  • Real-time communication

VideoChat.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Videochat.xaml.cpp
00013 // Implementation of the Videochat class
00014 //
00015
00016 #include "pch.h"
00017 #include "VideoChat.xaml.h"
00018 #include <wrl\wrappers\corewrappers.h>
00019
00020 using namespace SimpleCommunication;
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025
00026 VideoChat::VideoChat()
00027     : _device(nullptr)
00028     , _active(false)
00029     , _initialization(false)
00030     , _isTerminator(false)
00031     , _role(Role::uninitialized)
00032     , _dispatcher(nullptr)
00033 {
00034     InitializeComponent();
00035
00036     _sdkSample.Initialize(StatusMessage, Window::Current->Dispatcher);
00037     _dispatcher = Window::Current->Dispatcher;
00038 }
00039
00040 VideoChat::~VideoChat()
00041 {
00042 }
00043
00044 /// <summary>
00045 /// Invoked when this page is about to be displayed in a Frame.
00046 /// </summary>
00047 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00048 /// property is typically used to configure the page.</param>
00049 void VideoChat::OnNavigatedTo(NavigationEventArgs^ e)
00050 {
00051     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00052     // as NotifyUser()
00053     _rootPage = MainPage::Current;
00054
00055     _rootPage->LockScenarioChange(); // Lock
00056
00057     Initialize().then([this](task<void> asyncInfo)
00058     {
00059         Windows::Foundation::HResult hr;
00060         try
00061         {
00062             asyncInfo.get();
00063             hr.Value = S_OK;
00064         }
00065         catch (Platform::Exception^ e)
00066         {
00067             hr.Value = e->HResult;
00068         }
00069
00070         return OnInitializeCompleted(hr).then([this]()
00071         {
00072             _rootPage->UnlockScenarioChange(); // Unlock
00073         });
00074     });
00075 }
00076
00077 void
00078     VideoChat::OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e)
00079 {
00080     if (_rootPage->NavigatingPrevented())
00081     {
00082         e->Cancel = true;
00083     }
00084     else
00085     {
00086         RemoteVideo->MediaFailed::remove(_mediaElementFailedEventRegistrationToken);
00087         _mediaElementFailedEventRegistrationToken.Value = 0;
00088         Deactivate();
00089     }
00090 }
00091
00092 void
00093     VideoChat::OnNavigatedFrom(NavigationEventArgs^ e)
00094 {
00095     _sdkSample.Deinitialize();
00096 }
00097
00098 void
00099     VideoChat::CallButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00100 {
00101     auto address = IpAddressTextbox->Text;
00102     if (address)
00103     {
00104         _role = Role::active;
00105         RemoteVideo->Source = ref new Windows::Foundation::Uri("stsp://" + address);
00106         RemoteVideo->Play();
00107         RemoteVideoBorder->Visibility = Windows::UI::Xaml::Visibility::Visible;
00108         RemoteVideoPosterBorder->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00109         IpAddressTextbox->IsEnabled = false;
00110         CallButton->IsEnabled = false;
00111         _sdkSample.DisplayStatus("Initiating connection... Please wait!");
00112     }
00113 }
00114
00115 void
00116     VideoChat::EndCallButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00117 {
00118     bool callEndCall = false;
00119
00120     if (!_isTerminator && _active)
00121     {
00122         _isTerminator = true;
00123         callEndCall = true;
00124         _rootPage->LockScenarioChange(); // Lock
00125     }
00126
00127     if (callEndCall)
00128     {
00129         EndCall().then([this](task<void>)
00130         {
00131             _isTerminator = false;
00132         });
00133     }
00134 }
00135
00136 task<void>
00137     VideoChat::Initialize()
00138 {
00139     if (_initialization || _device)
00140     {
00141         return create_task([](){});
00142     }
00143     _initialization = true;
00144     _active = true;
00145
00146     return task<DeviceInformationCollection^>(DeviceInformation::FindAllAsync(DeviceClass::VideoCapture)).then([this](DeviceInformationCollection^ devices)
00147     {
00148         auto videoCaptures = devices->Size;
00149         return task<DeviceInformationCollection^>(DeviceInformation::FindAllAsync(DeviceClass::AudioCapture)).then([this,videoCaptures](DeviceInformationCollection^ devices)
00150         {
00151             auto audioCaptures = devices->Size;
00152             return ((videoCaptures > 0) && (audioCaptures) > 0);
00153         });
00154     }).then([this](task<bool> asyncInfo)
00155     {
00156         bool succeed;
00157         try
00158         {
00159             succeed = asyncInfo.get();
00160         }
00161         catch (Platform::Exception^ e)
00162         {
00163             Windows::Foundation::HResult hr;
00164             hr.Value = e->HResult;
00165             _sdkSample.FormatError(hr, "SimpleCommunication.NoCamera", "A machine with a camera and a microphone is required to run this sample.");
00166             throw;
00167         }
00168
00169         if (succeed)
00170         {
00171             CaptureDevice ^device = ref new CaptureDevice();
00172
00173             return device->InitializeAsync().then([this, device]()
00174             {
00175                 _device = device;
00176                 _mediaCaptureFailedEventRegistrationToken = _device->Failed::add(ref new CaptureFailedHandler(this, &VideoChat::OnMediaCaptureFailed));
00177                 _incomingConnectionEventRegistrationToken = _device->Incomingconnectionevent::add(ref new IncomingconnectioneventHandler(this, &VideoChat::OnIncomingConnection));
00178                 return StartRecordingToCustomSinkAsync();
00179             });
00180         }
00181         else
00182         {
00183             _sdkSample.DisplayError("A machine with a camera and a microphone is required to run this sample.");
00184             _rootPage->UnlockScenarioChange();
00185             cancel_current_task();
00186         }
00187     });
00188 }
00189
00190 task<void>
00191     VideoChat::OnInitializeCompleted(Windows::Foundation::HResult hr)
00192 {
00193     return create_task([this, hr]()
00194     {
00195         if (FAILED(hr.Value))
00196         {
00197             _rootPage->UnlockScenarioChange();
00198             _initialization = false;
00199
00200             Deactivate();
00201
00202             _sdkSample.FormatError(hr, "", ref new Platform::String(L"Initialization") + " error: ");
00203             throw ref new Platform::Exception(hr.Value);
00204         }
00205
00206         return task<void>(_dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([this]()
00207         {
00208             CallButton->IsEnabled = true;
00209             IpAddressTextbox->IsEnabled = true;
00210             EndCallButton->IsEnabled = false;
00211
00212             CallButton->IsEnabled = true;
00213             EndCallButton->IsEnabled = true;
00214             if (_mediaElementFailedEventRegistrationToken.Value == 0)
00215             {
00216                 _mediaElementFailedEventRegistrationToken = RemoteVideo->MediaFailed::add(ref new Windows::UI::Xaml::ExceptionRoutedEventHandler(this, &VideoChat::VideoPlaybackErrorHandler));
00217             }
00218
00219             // Both side start out as passive
00220             _role = Role::passive;
00221             _isTerminator = false;
00222             _initialization = false;
00223
00224             _sdkSample.DisplayStatus("Tap 'Call' button to start call");
00225             _rootPage->SetCurrentScenario("SimpleCommunication::VideoChat");
00226         }
00227         )));
00228     });
00229 }
00230
00231 task<void>
00232     VideoChat::EndCall()
00233 {
00234     return CleanUp().then([this]()
00235     {
00236
00237         if (_active)
00238         {
00239             return Initialize().then([this](task<void> asyncInfo)
00240             {
00241                 Windows::Foundation::HResult hr;
00242                 try
00243                 {
00244                     asyncInfo.get();
00245                     hr.Value = S_OK;
00246                 }
00247                 catch (Platform::Exception^ e)
00248                 {
00249                     hr.Value = e->HResult;
00250                 }
00251
00252                 return OnInitializeCompleted(hr).then([this](task<void> asyncInfo){});
00253             });
00254         }
00255         return create_task([](){});
00256     });
00257 }
00258
00259 task<void>
00260     VideoChat::Deactivate()
00261 {
00262     _active = false;
00263
00264     return CleanUp();
00265 }
00266
00267 task<void>
00268     VideoChat::CleanUp()
00269 {
00270     if (_device != nullptr)
00271     {
00272         _device->Failed::remove(_mediaCaptureFailedEventRegistrationToken);
00273         _device->Incomingconnectionevent::remove(_incomingConnectionEventRegistrationToken);
00274     }
00275     _mediaCaptureFailedEventRegistrationToken.Value = 0;
00276     _incomingConnectionEventRegistrationToken.Value = 0;
00277
00278     return task<void>(_dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([this]()
00279     {
00280         CallButton->IsEnabled = false;
00281         EndCallButton->IsEnabled = false;
00282     }
00283     ))).then([this]()
00284     {
00285         if (_device != nullptr)
00286         {
00287             auto device = _device;
00288             _device = nullptr;
00289
00290             return device->CleanupAsync();
00291         }
00292
00293         return create_task([](){});
00294     }).then([this](task<void>)
00295     {
00296         if (!_active)
00297         {
00298             return;
00299         }
00300         _dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([this]()
00301         {
00302             RemoteVideo->Source = nullptr;
00303             RemoteVideoBorder->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00304             RemoteVideoPosterBorder->Visibility = Windows::UI::Xaml::Visibility::Visible;
00305         }));
00306     });
00307 }
00308
00309 task<void>
00310     VideoChat::StartRecordingToCustomSinkAsync()
00311 {
00312     auto mediaEncodingProfile = Windows::Media::MediaProperties::MediaEncodingProfile::CreateMp4(Windows::Media::MediaProperties::VideoEncodingQuality::Qvga);
00313
00314     mediaEncodingProfile->Video->FrameRate->Numerator = 15;
00315     mediaEncodingProfile->Video->FrameRate->Denominator = 1;
00316     mediaEncodingProfile->Container = nullptr;
00317
00318     return _device->StartRecordingAsync(mediaEncodingProfile);
00319 }
00320
00321 void
00322     VideoChat::OnIncomingConnection(Microsoft::Samples::SimpleCommunication::StspMediaSink^ sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ args)
00323 {
00324     args->Accept();
00325
00326     _dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([this, args]()
00327     {
00328         EndCallButton->IsEnabled = true;
00329         _isTerminator = false;
00330
00331         Microsoft::WRL::Wrappers::HString url_, header_;
00332         header_.Set(L"stsp://");
00333         WindowsTrimStringStart(reinterpret_cast<HSTRING>(args->RemoteUrl), header_.Get(), url_.GetAddressOf());
00334         auto url = reinterpret_cast<Platform::String^>(url_.Get());
00335
00336         switch (_role)
00337         {
00338         case Role::active:
00339             _sdkSample.DisplayStatus("Connected. Remote machine address: " + url);
00340             break;
00341         case Role::passive:
00342             {
00343                 auto address = args->RemoteUrl;
00344                 RemoteVideo->Source = ref new Windows::Foundation::Uri(address);
00345                 RemoteVideo->Play();
00346                 RemoteVideoBorder->Visibility = Windows::UI::Xaml::Visibility::Visible;
00347                 RemoteVideoPosterBorder->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00348                 _sdkSample.DisplayStatus("Connected. Remote machine address: " + url);
00349             }
00350             IpAddressTextbox->IsEnabled = false;
00351             CallButton->IsEnabled = false;
00352             break;
00353         default:
00354             break;
00355         }
00356     }
00357     ));
00358 }
00359
00360 void
00361     VideoChat::OnMediaCaptureFailed(CaptureDevice^ sender, CaptureFailedEventArgs^ errorEventArgs)
00362 {
00363     _sdkSample.FormatError(errorEventArgs, "Capture error code: ");
00364
00365     _dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([this]()
00366     {
00367         if (!_isTerminator && _active)
00368         {
00369             _isTerminator = true;
00370
00371             EndCall().then([this](task<void> previousTask)
00372             {
00373                 _isTerminator = false;
00374             });
00375         }
00376     }));
00377 }
00378
00379 void
00380     VideoChat::VideoPlaybackErrorHandler(Platform::Object^ sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^ e)
00381 {
00382     // See MF_MEDIA_ENGINE_ERR
00383     if (e->ErrorMessage != "MF_MEDIA_ENGINE_ERR_NOERROR")
00384     {
00385         _sdkSample.DisplayError(e->ErrorMessage);
00386
00387         _dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([this]()
00388         {
00389             if (!_isTerminator && _active)
00390             {
00391                 _isTerminator = true;
00392
00393                 EndCall().then([this](task<void> previousTask)
00394                 {
00395                     _isTerminator = false;
00396                 });
00397             }
00398         }));
00399     }
00400 }
00401
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

LoadScreen Member List

This is the complete list of members for LoadScreen, including all inherited members.
__pad0__ | LoadScreen |
d2dContext | LoadScreen |
m_bitmap | LoadScreen | [private]
m_d2dContext | LoadScreen | [private]
m_d2dDevice | LoadScreen | [private]
m_d2dFactory | LoadScreen | [private]
m_imageSize | LoadScreen | [private]
m_offset | LoadScreen | [private]
m_stateBlock | LoadScreen | [private]
m_totalSize | LoadScreen | [private]
m_wicFactory | LoadScreen | [private]
Render() | LoadScreen |
ResetDirectXResources() | LoadScreen |
UpdateForWindowSizeChange() | LoadScreen |
wicFactory | LoadScreen |
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKMESH_HEADER Member List

This is the complete list of members for SDKMESH_HEADER, including all inherited members.
BufferDataSize | SDKMESH_HEADER
FrameDataOffset | SDKMESH_HEADER
HeaderSize | SDKMESH_HEADER
IndexStreamHeadersOffset | SDKMESH_HEADER
IsBigEndian | SDKMESH_HEADER
MaterialDataOffset | SDKMESH_HEADER
MeshDataOffset | SDKMESH_HEADER
NonBufferDataSize | SDKMESH_HEADER
NumFrames | SDKMESH_HEADER
NumIndexBuffers | SDKMESH_HEADER
NumMaterials | SDKMESH_HEADER
NumMeshes | SDKMESH_HEADER
NumTotalSubsets | SDKMESH_HEADER
NumVertexBuffers | SDKMESH_HEADER
SubsetDataOffset | SDKMESH_HEADER
Version | SDKMESH_HEADER
VertexStreamHeadersOffset | SDKMESH_HEADER
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ViewModelLocator.cpp Source File

  • Hilo C++
  • Hilo

ViewModelLocator.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "ViewModelLocator.h"
00009 #include "DebugLoggingExceptionPolicy.h"
00010
00011 using namespace Hilo;
00012 using namespace Platform::Collections;
00013 using namespace std;
00014 using namespace Windows::ApplicationModel::Resources;
00015
00016 ViewModelLocator::ViewModelLocator()
00017 {
00018     m_exceptionPolicy = make_shared<DebugLoggingExceptionPolicy>();
00019     m_repository = safe_cast<Hilo::App^>(Windows::UI::Xaml::Application::Current)->GetRepository();
00020 }
00021
00022 MainHubViewModel^ ViewModelLocator::MainHubVM::get()
00023 {
00024     auto vector = ref new Vector<HubPhotoGroup^>();
00025     // Pictures Group
00026     auto loader = ref new ResourceLoader();
00027     auto title = loader->GetString("PicturesTitle");
00028     auto emptyTitle = loader->GetString("EmptyPicturesTitle");
00029     auto picturesGroup = ref new HubPhotoGroup(title, emptyTitle, m_repository, m_exceptionPolicy);
00030     vector->Append(picturesGroup);
00031     return ref new MainHubViewModel(vector, m_exceptionPolicy);
00032 }
00033
00034 ImageBrowserViewModel^ ViewModelLocator::ImageBrowserVM::get()
00035 {
00036     if (nullptr == m_imageBrowswerViewModel)
00037     {
00038         m_imageBrowswerViewModel = ref new ImageBrowserViewModel(m_repository, m_exceptionPolicy);
00039     }
00040
00041     return m_imageBrowswerViewModel;
00042 }
00043
00044 ImageViewModel^ ViewModelLocator::ImageVM::get()
00045 {
00046     return ref new ImageViewModel(m_repository, m_exceptionPolicy);
00047 }
00048
00049 CropImageViewModel^ ViewModelLocator::CropImageVM::get()
00050 {
00051     return ref new CropImageViewModel(m_repository, m_exceptionPolicy);
00052 }
00053
00054 RotateImageViewModel^ ViewModelLocator::RotateImageVM::get()
00055 {
00056     return ref new RotateImageViewModel(m_repository, m_exceptionPolicy);
00057 }
00058
00059 CartoonizeImageViewModel^ ViewModelLocator::CartoonizeImageVM::get()
00060 {
00061     return ref new CartoonizeImageViewModel(m_repository, m_exceptionPolicy);
00062 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DDS_HEADER_DXT10 Member List

This is the complete list of members for DDS_HEADER_DXT10, including all inherited members.
arraySize | DDS_HEADER_DXT10
dxgiFormat | DDS_HEADER_DXT10
miscFlag | DDS_HEADER_DXT10
reserved | DDS_HEADER_DXT10
resourceDimension | DDS_HEADER_DXT10
Generated on Sat Nov 23 2024 16:09:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/common/LayoutAwarePage.cpp Source File

  • File and folder thumbnail
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameConstants.h Source File

  • XAML DirectX 3D shooting game

GameConstants.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 namespace GameConstants
00011 {
00012     static const int MaxAmmo                    = 10;
00013     static const int MaxCylinders               = 5;
00014     static const int MaxTargets                 = 10;
00015     static const float AmmoSize                 = 0.2f;
00016     static const float AmmoRadius               = AmmoSize * 0.5f;
00017     static const float TouchRectangleSize       = 300.0f;
00018     static const int MaxBackgroundTextures      = 3;
00019
00020     static const float CrossHairHalfSize        = 20.0f;
00021     static const float HudSafeWidth             = 300.0f;
00022     static const float HudRightOffset           = 250.0f;
00023     static const float HudTopOffset             = 50.0f;
00024     static const float Margin                   = 5.0f;
00025     static const float HudBodyPointSize         = 24.0f;
00026     static const float HudTitleHeaderPointSize  = 16.0f;
00027     static const float HudTitleBodyPointSize    = 36.0f;
00028     static const float HudLicensePointSize      = 20.0f;
00029
00030     static const int InitialLoadingDelay        = 2000;     // Number of ms to wait before completion of initial load.
00031     static const int LevelLoadingDelay          = 500;      // Number of ms to wait before completion of level load.
00032
00033     static const int WorldFloorId               = 80001;
00034     static const int WorldCeilingId             = 80002;
00035     static const int WorldWallsId               = 80003;
00036
00037     namespace Physics
00038     {
00039         static const float GroundRestitution    = 0.8f;     // Percentage of the velocity transmitted by ground and walls when an ammo hit.
00040         static const float Friction             = 0.9f;     // The amount of velocity retained after friction is applied.
00041         static const float AutoFireDelay        = 0.2f;     // The period between two successive ammo firing.
00042         static const float Gravity              = 5.0f;     // The magnitude of the downward force applied to ammos.
00043         static const float BounceTransfer       = 0.8f;     // The proportion of velocity transferred during a collision between 2 ammos.
00044         static const float BounceLost           = 0.1f;     // The proportion of velocity lost during a collision between 2 ammos.
00045         static const float RestThreshold        = 0.02f;    // The energy below which the ball is flagged as laying on ground.
00046                                                             // It is defined as Gravity * Height_above_ground + 0.5 * Velocity * Velocity.
00047         static const float FrameLength          = 0.003f;   // The duration of a frame for physics handling when the graphics frame length is too long.
00048     }
00049
00050     namespace Sound
00051     {
00052         static const float MaxVelocity          = 10.0f;    // The velocity at which the bouncing sound is played at maximum volume.
00053         static const float MinVelocity          = 0.05f;    // The minimum contact velocity required to make a sound.
00054         static const float MinAdjustment        = 0.2f;     // The minimum volume adjustment based on contact velocity.
00055     }
00056 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/pch.cpp Source File

  • XAML scrolling, panning, and zooming

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::ThumbnailGenerator Member List

This is the complete list of members for Hilo::ThumbnailGenerator, including all inherited members.
CreateLocalThumbnailAsync(Windows::Storage::StorageFolder^folder, Windows::Storage::StorageFile^imageFile, Platform::String^localFileName, unsigned int thumbSize, std::shared_ptr< ExceptionPolicy > policy) | Hilo::ThumbnailGenerator | [private, static]
CreateThumbnailFromPictureFileAsync(Windows::Storage::StorageFile^sourceFile, unsigned int thumbSize) | Hilo::ThumbnailGenerator | [private, static]
Generate(Windows::Foundation::Collections::IVector< Windows::Storage::StorageFile^>^files, Windows::Storage::StorageFolder^thumbnailsFolder) | Hilo::ThumbnailGenerator |
InternalSaveToFile(Windows::Storage::StorageFolder^folder, Windows::Storage::Streams::InMemoryRandomAccessStream^stream, Platform::String^filename) | Hilo::ThumbnailGenerator | [private, static]
m_exceptionPolicy | Hilo::ThumbnailGenerator | [private]
ThumbnailGenerator(std::shared_ptr< ExceptionPolicy > policy) | Hilo::ThumbnailGenerator |
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/MainPage.xaml.h Source File

  • Reading and writing data

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/ImageProtocols.xaml.h Source File

  • App tiles and badges
  • C#,C++

ImageProtocols.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ImageProtocols.xaml.h
00013 // Declaration of the ImageProtocols class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "ImageProtocols.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Tiles
00025     {
00026       /// <summary>
00027       /// An empty page that can be used on its own or navigated to within a Frame.
00028       /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030       public ref class ImageProtocols sealed
00031       {
00032       public:
00033         ImageProtocols();
00034
00035       protected:
00036         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037       private:
00038         MainPage^ rootPage;
00039         Platform::String^ imageRelativePath;
00040         void ProtocolList_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00041         void SendTileNotification_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042         void PickImage_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043       };
00044     }
00045 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/common/LayoutAwarePage.h Source File

  • Credential locker
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/MainPage.xaml.h Source File

  • DirectX postcard app

MainPage.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "MainPage.g.h"
00011 #include "PostcardRenderer.h"
00012
00013 namespace Postcard
00014 {
00015     public ref class MainPage sealed
00016     {
00017     public:
00018         MainPage();
00019
00020     private:
00021         void OnLogicalDpiChanged(
00022             Platform::Object^ sender
00023             );
00024         void OnWindowSizeChanged(
00025             Windows::UI::Core::CoreWindow^ sender,
00026             Windows::UI::Core::WindowSizeChangedEventArgs^ args
00027             );
00028         void OnPointerPressed(
00029             Platform::Object^ sender,
00030             Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args
00031             );
00032         void OnPointerReleased(
00033             Platform::Object^ sender,
00034             Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args
00035             );
00036         void OnPointerMoved(
00037             Platform::Object^ sender,
00038             Windows::UI::Xaml::Input::PointerRoutedEventArgs^ args
00039             );
00040
00041         void AddImage();
00042         void AddEffectsClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043         void EffectIntensitySliderChanged(Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e);
00044         void AddConstructionPaperClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045         void PaperFlyoutAddPaperClicked();
00046         void PaperFlyoutDeletePaperClicked();
00047         void PaperFlyoutMoveClicked();
00048         void PaperFlyoutStampClicked();
00049         void AddTextClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050         void TextSubmitted(Platform::String^ text);
00051         void AddSignatureClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00052         void SignClicked();
00053         void EraseClicked();
00054         void SaveClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00055         void ShareClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00056         void ResetClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00057
00058         PostcardRenderer^ m_renderer;
00059         bool m_atStartScreen;
00060     };
00061 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::MicrosoftAccount::sealed Member List

This is the complete list of members for SDKSample::MicrosoftAccount::sealed, including all inherited members.
accessTicket | SDKSample::MicrosoftAccount::sealed | [private]
authenticator | SDKSample::MicrosoftAccount::sealed | [private]
cancellationTokenSource | SDKSample::MicrosoftAccount::sealed | [private]
DelegationTickets() | SDKSample::MicrosoftAccount::sealed |
httpRequest | SDKSample::MicrosoftAccount::sealed | [private]
rootPage | SDKSample::MicrosoftAccount::sealed | [private]
SignInButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MicrosoftAccount::sealed | [private]
SignOutButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MicrosoftAccount::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/Receipt.xaml.cpp Source File

  • Trial app and in-app purchase

Receipt.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Receipt.xaml.cpp
00013 // Implementation of the ExpiringProduct class
00014 //
00015
00016 #include "pch.h"
00017 #include "Receipt.xaml.h"
00018
00019 using namespace SDKSample::StoreSample;
00020
00021 using namespace concurrency;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::ApplicationModel::Store;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Globalization;
00026 using namespace Windows::Storage;
00027 using namespace Windows::UI::Xaml;
00028 using namespace Windows::UI::Xaml::Controls;
00029 using namespace Windows::UI::Xaml::Navigation;
00030
00031 Receipt::Receipt()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void Receipt::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046     LoadReceiptProxyFile();
00047 }
00048 void Receipt::OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e)
00049 {
00050     CurrentAppSimulator::LicenseInformation->LicenseChanged -= eventRegistrationToken;
00051 }
00052
00053 void Receipt::LoadReceiptProxyFile()
00054 {
00055     create_task(Package::Current->InstalledLocation->GetFolderAsync("data")).then([this](StorageFolder^ proxyDataFolder)
00056     {
00057         create_task(proxyDataFolder->GetFileAsync("receipt.xml")).then([this](StorageFile^ proxyFile)
00058         {
00059             eventRegistrationToken = (CurrentAppSimulator::LicenseInformation->LicenseChanged += ref new LicenseChangedEventHandler(this, &Receipt::ReceiptRefreshScenario));
00060             create_task(CurrentAppSimulator::ReloadSimulatorAsync(proxyFile)).then([this]()
00061             {
00062             });
00063         });
00064     });
00065 }
00066
00067 void Receipt::ReceiptRefreshScenario()
00068 {
00069 }
00070
00071 void Receipt::ShowReceipt_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00072 {
00073     create_task(CurrentAppSimulator::GetAppReceiptAsync()).then([this](task<Platform::String^> currentTask)
00074     {
00075         try
00076         {
00077             Platform::String^ receipt = currentTask.get();
00078             rootPage->NotifyUser(receipt, NotifyType::StatusMessage);
00079         }
00080         catch(Platform::Exception^ exception)
00081         {
00082             rootPage->NotifyUser("Get Receipt failed.", NotifyType::ErrorMessage);
00083         }
00084     });
00085 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/App.xaml.cpp Source File

  • Compression

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicCamera.cpp Source File

  • DXGI offer and reclaim resources

BasicCamera.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicCamera.h"
00010
00011 void BasicCamera::GetViewMatrix(_Out_ float4x4 *viewMatrix)
00012 {
00013     *viewMatrix = m_view;
00014 }
00015
00016 void BasicCamera::GetProjectionMatrix(_Out_ float4x4 *projectionMatrix)
00017 {
00018     *projectionMatrix = m_projection;
00019 }
00020
00021 // this method updates the view matrix based on new position and focus coordinates
00022 void BasicCamera::SetViewParameters(
00023     _In_ float3 eyePosition,    // the position of the camera
00024     _In_ float3 lookPosition,   // the point the camera should look at
00025     _In_ float3 up              // the durection vector for up
00026     )
00027 {
00028     m_position = eyePosition;
00029     m_direction = normalize(lookPosition - eyePosition);
00030     float3 zAxis = -m_direction;
00031     float3 xAxis = normalize(cross(up, zAxis));
00032     float3 yAxis = cross(zAxis, xAxis);
00033     float xOffset = -dot(xAxis, m_position);
00034     float yOffset = -dot(yAxis, m_position);
00035     float zOffset = -dot(zAxis, m_position);
00036     m_view = float4x4(
00037         xAxis.x, xAxis.y, xAxis.z, xOffset,
00038         yAxis.x, yAxis.y, yAxis.z, yOffset,
00039         zAxis.x, zAxis.y, zAxis.z, zOffset,
00040         0.0f,    0.0f,    0.0f,    1.0f
00041         );
00042 }
00043     // this method updates the projection matrix based on new parameters
00044 void BasicCamera::SetProjectionParameters(
00045     _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00046     _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00047     _In_ float nearPlane,           // depth to map to 0
00048     _In_ float farPlane             // depth to map to 1
00049     )
00050 {
00051     float minScale = 1.0f / tan(minimumFieldOfView * PI_F / 360.0f);
00052     float xScale = 1.0f;
00053     float yScale = 1.0f;
00054     if (aspectRatio < 1.0f)
00055     {
00056         xScale = minScale;
00057         yScale = minScale * aspectRatio;
00058     }
00059     else
00060     {
00061         xScale = minScale / aspectRatio;
00062         yScale = minScale;
00063     }
00064     float zScale = farPlane / (farPlane - nearPlane);
00065     m_projection = float4x4(
00066         xScale, 0.0f,   0.0f,    0.0f,
00067         0.0f,   yScale, 0.0f,    0.0f,
00068         0.0f,   0.0f,   -zScale, -nearPlane*zScale,
00069         0.0f,   0.0f,   -1.0f,   0.0f
00070         );
00071 }
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

D2DLightingEffects::sealed Member List

This is the complete list of members for D2DLightingEffects::sealed, including all inherited members.
App() | D2DLightingEffects::sealed |
InitializeValues() | D2DLightingEffects::sealed |
m_mainPage | D2DLightingEffects::sealed | [private]
m_renderer | D2DLightingEffects::sealed | [private]
MainPage() | D2DLightingEffects::sealed |
OnAzimuthValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnDiffuseConstantValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnDisplayContentsInvalidated(Object^sender) | D2DLightingEffects::sealed | [private]
OnEffectSelectorSelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnElevationValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnLaunched(_In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override | D2DLightingEffects::sealed | [virtual]
OnLightPositionZValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnLimitingConeAngleValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnLogicalDpiChanged(Object^sender) | D2DLightingEffects::sealed | [private]
OnRestoreDefaultsClick(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnResuming(_In_ Platform::Object^sender, _In_ Platform::Object^args) | D2DLightingEffects::sealed | [private]
OnSpecularConstantValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnSpecularExponentValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnSpotFocusValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnSurfaceScaleValueChanged(Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | D2DLightingEffects::sealed | [private]
OnSuspending(_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args) | D2DLightingEffects::sealed | [private]
OnSuspending(Object^sender, Windows::ApplicationModel::SuspendingEventArgs^args) | D2DLightingEffects::sealed |
OnSwapChainPointerMoved(Object^sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^args) | D2DLightingEffects::sealed | [private]
OnWindowSizeChanged(Windows::UI::Core::CoreWindow^sender, Windows::UI::Core::WindowSizeChangedEventArgs^args) | D2DLightingEffects::sealed | [private]
ResetValues() | D2DLightingEffects::sealed |
SetLightingEffect(LightingEffect lightingEffect) | D2DLightingEffects::sealed | [private]
SetLightingProperty(LightingProperty lightingProperty, float value) | D2DLightingEffects::sealed | [private]
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DirectXSample.h Source File

  • DirectX 3D shooting game

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicCamera.h Source File

  • Direct3D post-processing effects

BasicCamera.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple camera class.
00011 ref class BasicCamera
00012 {
00013
00014 private:
00015     float3 m_position;      // the position of the camera
00016     float3 m_direction;     // the unit vector of the viewing direction
00017     float4x4 m_view;        // view matrix
00018     float4x4 m_projection;  // projection matrix
00019
00020 internal:
00021     void GetViewMatrix(_Out_ float4x4 *viewMatrix);
00022     void GetProjectionMatrix(_Out_ float4x4 *projectionMatrix);
00023
00024     // this method updates the view matrix based on new position and focus coordinates
00025     void SetViewParameters(
00026         _In_ float3 eyePosition,    // the position of the camera
00027         _In_ float3 lookPosition,   // the point the camera should look at
00028         _In_ float3 up              // the durection vector for up
00029         );
00030
00031     // this method updates the projection matrix based on new parameters
00032     void SetProjectionParameters(
00033         _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00034         _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00035         _In_ float nearPlane,           // depth to map to 0
00036         _In_ float farPlane             // depth to map to 1
00037         );
00038 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/pch.cpp Source File

  • Direct2D custom image effects
  • VertexShader

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

RippleEffect Member List

This is the complete list of members for RippleEffect, including all inherited members.
amplitude | RippleEffect |
center | RippleEffect |
Clamp(float v, float low, float high) | RippleEffect | [inline, private, static]
CreateRippleImpl(_Outptr_ IUnknown **ppEffectImpl) | RippleEffect | [static]
dpi | RippleEffect |
frequency | RippleEffect |
GetAmplitude() const | RippleEffect |
GetCenter() const | RippleEffect |
GetFrequency() const | RippleEffect |
GetPhase() const | RippleEffect |
GetSpread() const | RippleEffect |
IFACEMETHODIMP_(UINT32) GetInputCount() const | RippleEffect |
IFACEMETHODIMP_(ULONG) AddRef() | RippleEffect |
IFACEMETHODIMP_(ULONG) Release() | RippleEffect |
Initialize(_In_ ID2D1EffectContext *pContextInternal, _In_ ID2D1TransformGraph *pTransformGraph) | RippleEffect |
m_constants | RippleEffect | [private]
m_dpi | RippleEffect | [private]
m_drawInfo | RippleEffect | [private]
m_effectContext | RippleEffect | [private]
m_inputRect | RippleEffect | [private]
m_refCount | RippleEffect | [private]
MapInputRectsToOutputRect(_In_reads_(inputRectCount) CONST D2D1_RECT_L *pInputRects, _In_reads_(inputRectCount) CONST D2D1_RECT_L *pInputOpaqueSubRects, UINT32 inputRectCount, _Out_ D2D1_RECT_L *pOutputRect, _Out_ D2D1_RECT_L *pOutputOpaqueSubRect) | RippleEffect |
MapInvalidRect(UINT32 inputIndex, D2D1_RECT_L invalidInputRect, _Out_ D2D1_RECT_L *pInvalidOutputRect) const | RippleEffect |
MapOutputRectToInputRects(_In_ const D2D1_RECT_L *pOutputRect, _Out_writes_(inputRectCount) D2D1_RECT_L *pInputRects, UINT32 inputRectCount) const | RippleEffect |
phase | RippleEffect |
PrepareForRender(D2D1_CHANGE_TYPE changeType) | RippleEffect |
QueryInterface(_In_ REFIID riid, _Outptr_ void **ppOutput) | RippleEffect |
Register(_In_ ID2D1Factory1 *pFactory) | RippleEffect | [static]
RippleEffect() | RippleEffect | [private]
Round(float v) | RippleEffect | [inline, private, static]
SafeAdd(long base, long valueToAdd) | RippleEffect | [inline, private, static]
SetAmplitude(float amplitude) | RippleEffect |
SetCenter(D2D1_POINT_2F center) | RippleEffect |
SetDrawInfo(_In_ ID2D1DrawInfo *pRenderInfo) | RippleEffect |
SetFrequency(float frequency) | RippleEffect |
SetGraph(_In_ ID2D1TransformGraph *pGraph) | RippleEffect |
SetPhase(float phase) | RippleEffect |
SetSpread(float spread) | RippleEffect |
spread | RippleEffect |
UpdateConstants() | RippleEffect | [private]
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/DDSTextureLoader.cpp Source File

  • DirectX postcard app

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/App.xaml.h Source File

  • SMS message send, receive, and SIM management

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/SampleOverlay.h Source File

  • DirectWrite paragraph text

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/common/suspensionmanager.cpp Source File

  • Configure keys for media
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/MainPage.xaml.h Source File

  • Contact Picker app

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace ContactPicker
00024 {
00025     public ref class MainPageSizeChangedEventArgs sealed
00026     {
00027     public:
00028         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00029         {
00030             Windows::UI::ViewManagement::ApplicationViewState get()
00031             {
00032                 return viewState;
00033             }
00034
00035             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00036             {
00037                 viewState = value;
00038             }
00039         }
00040
00041     private:
00042         Windows::UI::ViewManagement::ApplicationViewState viewState;
00043     };
00044
00045     [Windows::Foundation::Metadata::WebHostHidden]
00046     public ref class MainPage sealed
00047     {
00048     public:
00049         MainPage();
00050
00051         property bool AutoSizeInputSectionWhenSnapped
00052         {
00053             bool get()
00054             {
00055                 return autoSizeInputSectionWhenSnapped;
00056             }
00057
00058             void set(bool value)
00059             {
00060                 autoSizeInputSectionWhenSnapped = value;
00061             }
00062         }
00063
00064         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00065
00066         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00067         void LoadScenario(Platform::String^ scenarioName);
00068         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00069         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00070
00071
00072     private:
00073         void SetContactPicker(Platform::String^ strFeature);
00074         void PopulateScenarios();
00075         void InvalidateSize();
00076         void InvalidateViewState();
00077         ~MainPage();
00078
00079         Platform::Collections::Vector<Object^>^ ScenarioList;
00080         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00081         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00082         bool autoSizeInputSectionWhenSnapped;
00083
00084
00085     protected:
00086         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00087         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00088         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00089
00090     internal:
00091         static MainPage^ Current;
00092
00093     };
00094
00095 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/MainPage.xaml.h Source File

  • XAML accessibility

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioList.xaml.h Source File

  • Scheduled notifications
  • C#,C++

ScenarioList.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioList.xaml.h
00010 // Declaration of the ScenarioList class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioList.g.h"
00017 #include "MainPage.g.h"
00018
00019 using namespace Windows::UI::Xaml::Controls;
00020 using namespace CppSamplesUtils;
00021
00022 namespace ScheduledNotificationsSampleCPP
00023 {
00024   [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class ScenarioList sealed
00026     {
00027     public:
00028         ScenarioList();
00029
00030     protected:
00031         void Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e);
00032         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033
00034     private:
00035         ~ScenarioList();
00036         MainPage^ rootPage;
00037     };
00038 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicMath.h Source File

  • DXGI swap chain rotation

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicReaderWriter.cpp Source File

  • DirectX postcard app

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioList.xaml.cpp Source File

  • Raw notifications
  • MainAppSample

ScenarioList.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioList.xaml.cpp
00010 // Implementation of the ScenarioList class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioList.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017
00018
00019 using namespace RawNotificationsSampleCPP;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::Foundation::Collections;
00024 using namespace Windows::Graphics::Display;
00025 using namespace Windows::UI::ViewManagement;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Controls::Primitives;
00029 using namespace Windows::UI::Xaml::Data;
00030 using namespace Windows::UI::Xaml::Input;
00031 using namespace Windows::UI::Xaml::Media;
00032 using namespace Windows::UI::Xaml::Navigation;
00033 using namespace Windows::UI::Xaml::Interop;
00034
00035 ScenarioList::ScenarioList()
00036 {
00037   InitializeComponent();
00038 }
00039
00040 ScenarioList::~ScenarioList()
00041 {
00042 }
00043
00044 void ScenarioList::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00045 {
00046   if (Scenarios->SelectedItem != nullptr)
00047   {
00048     rootPage->NotifyUser("", NotifyType::StatusMessage);
00049
00050     ListBoxItem^ selectedListBoxItem = dynamic_cast<ListBoxItem^>(Scenarios->SelectedItem);
00051     SuspensionManager::SessionState()->Insert("SelectedScenario", selectedListBoxItem->Name);
00052
00053     if (rootPage->InputFrame != nullptr && rootPage->OutputFrame != nullptr)
00054     {
00055       //Load the input and output pages for the current scenario into their respective frames.
00056       TypeName inputPage = { "RawNotificationsSampleCPP" + "." + "ScenarioInput" + ((Scenarios->SelectedIndex + 1).ToString()), TypeKind::Custom };
00057       TypeName outputPage = { "RawNotificationsSampleCPP" + "." + "ScenarioOutput" + ((Scenarios->SelectedIndex + 1).ToString()), TypeKind::Custom };
00058       rootPage->DoNavigation(inputPage, rootPage->InputFrame);
00059       rootPage->DoNavigation(outputPage, rootPage->OutputFrame);
00060     }
00061   }
00062 }
00063
00064 void ScenarioList::OnNavigatedTo(NavigationEventArgs^ e)
00065 {
00066   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00067
00068   Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &ScenarioList::Scenarios_SelectionChanged);
00069   ListBoxItem^ startingScenario = nullptr;
00070
00071   auto ps = SuspensionManager::SessionState();
00072   if (ps->HasKey("SelectedScenario"))
00073   {
00074     PropertyValue^ pv;
00075     String^ item = dynamic_cast<String^>(ps->Lookup("SelectedScenario"));
00076     startingScenario = dynamic_cast<ListBoxItem^>(this->FindName(item));
00077   }
00078
00079   Scenarios->SelectedItem = startingScenario != nullptr ? startingScenario : Scenario1;
00080 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/Landscape.xaml.cpp Source File

  • Device auto rotation preferences

Landscape.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Landscape.xaml.cpp
00013 // Implementation of the Landscape class
00014 //
00015
00016 #include "pch.h"
00017 #include "Landscape.xaml.h"
00018
00019 using namespace SDKSample::Rotation;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Landscape::Landscape()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void Landscape::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040 }
00041
00042 void SDKSample::Rotation::Landscape::SetLandscape_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00043 {
00044     Button^ b = safe_cast<Button^>(sender);
00045     if (b != nullptr)
00046     {
00047         Windows::Graphics::Display::DisplayProperties::AutoRotationPreferences = Windows::Graphics::Display::DisplayOrientations::Landscape;
00048
00049         if (Windows::Graphics::Display::DisplayProperties::AutoRotationPreferences == Windows::Graphics::Display::DisplayOrientations::Landscape)
00050         {
00051             rootPage->NotifyUser("Succeeded: Preference set to Landscape.", NotifyType::StatusMessage);
00052         }
00053         else
00054         {
00055             rootPage->NotifyUser("Error: Failed to set the preference.", NotifyType::StatusMessage);
00056         }
00057     }
00058 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/Landscape.xaml.h Source File

  • Device auto rotation preferences

Landscape.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Landscape.xaml.h
00013 // Declaration of the Landscape class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Landscape.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Rotation
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Landscape sealed
00031         {
00032         public:
00033             Landscape();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void SetLandscape_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario2.xaml.cpp Source File

  • CryptoWinRT

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::CryptoWinRT;
00020
00021 using namespace Platform;
00022 using namespace Windows::Security::Cryptography;
00023 using namespace Windows::Security::Cryptography::Core;
00024 using namespace Windows::Storage::Streams;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 Scenario2::Scenario2()
00030 {
00031     InitializeComponent();
00032     AlgorithmNames->SelectedIndex = 0;
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00043     // as NotifyUser()
00044     rootPage = MainPage::Current;
00045 }
00046
00047
00048 void SDKSample::CryptoWinRT::Scenario2::RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00049 {
00050     Scenario2Text->Text = "";
00051     String^ algName;
00052
00053     algName = AlgorithmNames->SelectionBoxItem->ToString();
00054
00055     // Create a HashAlgorithmProvider object.
00056     HashAlgorithmProvider^ Algorithm = HashAlgorithmProvider::OpenAlgorithm(algName);
00057     IBuffer^ vector = CryptographicBuffer::DecodeFromBase64String("uiwyeroiugfyqcajkds897945234==");
00058
00059     Scenario2Text->Text += "*** Sample Hash Algorithm: " + Algorithm->AlgorithmName + "\n";
00060     Scenario2Text->Text += "\tInitial vector:  " + CryptographicBuffer::EncodeToBase64String(vector) + "\n";
00061
00062     // Compute the hash in one call.
00063     IBuffer^ digest = Algorithm->HashData(vector);
00064
00065     if (digest->Length != Algorithm->HashLength)
00066     {
00067         Scenario2Text->Text += "HashAlgorithmProvider failed to generate a hash of proper length!\n";
00068         return;
00069     }
00070
00071     Scenario2Text->Text += "\tHash:  " + CryptographicBuffer::EncodeToHexString(digest) + "\n";
00072
00073     // Use a reusable hash object to hash the data by using multiple calls.
00074     CryptographicHash^ reusableHash = Algorithm->CreateHash();
00075
00076     reusableHash->Append(vector);
00077
00078     // Note that calling GetValueAndReset resets the data that has been appended to the
00079     // CryptographicHash object.
00080     IBuffer^ digest2 = reusableHash->GetValueAndReset();
00081
00082     if (!CryptographicBuffer::Compare(digest, digest2))
00083     {
00084         Scenario2Text->Text += "CryptographicHash failed to generate the same hash data!\n";
00085         return;
00086     }
00087
00088     reusableHash->Append(vector);
00089     digest2 = reusableHash->GetValueAndReset();
00090
00091     if (!CryptographicBuffer::Compare(digest, digest2))
00092     {
00093         Scenario2Text->Text += "Reusable CryptographicHash failed to generate the same hash data!\n";
00094         return;
00095     }
00096 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::StringTrimmer Member List

This is the complete list of members for SDKSample::StringTrimmer, including all inherited members.
Trim(Platform::String^s) | SDKSample::StringTrimmer | [inline, static]
Trim(Platform::String^s) | SDKSample::StringTrimmer | [inline, static]
Trim(Platform::String^s) | SDKSample::StringTrimmer | [inline, static]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Constants.cpp Source File

  • XAML FlipView control

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "Basic population", "SDKSample.FlipViewCPP.Scenario1" },
00022     { "Orientation", "SDKSample.FlipViewCPP.Scenario2" },
00023     { "Using interactive content", "SDKSample.FlipViewCPP.Scenario3" },
00024   { "Creating a context control", "SDKSample.FlipViewCPP.Scenario4" },
00025   { "Styling navigation buttons", "SDKSample.FlipViewCPP.Scenario5" }
00026 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioInput2.xaml.h Source File

  • Lock screen apps
  • C#,C++

ScenarioInput2.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Input.xaml.h
00010 // Declaration of the Scenario2Input class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioInput2.g.h"
00017 #include "MainPage.g.h"
00018
00019 namespace LockScreenAppsCPP
00020 {
00021   [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class ScenarioInput2 sealed
00023     {
00024     public:
00025         ScenarioInput2();
00026
00027     protected:
00028         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029
00030     private:
00031         void SendBadge_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00032         void SendBadgeWithStringManipulation_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00033         void ClearBadge_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00034         void SendTileWithStringManipulation_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00035         void SendTile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036         void ClearTile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037         ~ScenarioInput2();
00038
00039         MainPage^ rootPage;
00040     };
00041 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/App.xaml.cpp Source File

  • Animation metrics

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/pch.cpp Source File

  • Connecting with WebSockets

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/App.xaml.cpp Source File

  • Real-time communication

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "App.xaml.h"
00018 #include "MainPage.xaml.h"
00019
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::ApplicationModel::Activation;
00024 using namespace CppSamplesUtils;
00025 using namespace SimpleCommunication;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 App::App()
00029 {
00030     InitializeComponent();
00031     this->Suspending += ref new SuspendingEventHandler(this, &SimpleCommunication::App::OnSuspending);
00032 }
00033
00034
00035 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00036 {
00037     auto deferral = pArgs->SuspendingOperation->GetDeferral();
00038     SuspensionManager::StartSaveTask().then([=]()
00039     {
00040         deferral->Complete();
00041     });
00042 }
00043
00044 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00045 {
00046     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00047     {
00048         SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
00049         {
00050             try
00051             {
00052                 restoreTask.get();
00053             }
00054             catch(Platform::Exception^)
00055             {
00056                 // If restore fails, the app should proceed as though there was no restored state.
00057             }
00058
00059             SetupWindowing(pArgs);
00060         });
00061     }
00062     else
00063     {
00064         SetupWindowing(pArgs);
00065     }
00066 }
00067
00068 void App::SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00069 {
00070     if (Window::Current->Content == nullptr)
00071     {
00072         auto rootFrame = ref new Frame();
00073         TypeName pageType = { "SimpleCommunication.MainPage", TypeKind::Custom };
00074         rootFrame->Navigate(pageType);
00075         Window::Current->Content = rootFrame;
00076     }
00077     Window::Current->Activate();
00078 }
00079
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/UserPreferences.xaml.h Source File

  • Globalization preferences

UserPreferences.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // UserPreferences.xaml.h
00013 // Declaration of the UserPreferences class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "UserPreferences.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace GlobalizationPreferencesSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class UserPreferences sealed
00031         {
00032         public:
00033             UserPreferences();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CDecoder Member List

This is the complete list of members for CDecoder, including all inherited members.
AddInputStreams(DWORD cStreams, DWORD *adwStreamIDs) | CDecoder | [private]
AddInputStreams(DWORD cStreams, DWORD *adwStreamIDs) | CDecoder | [private]
AllocateStreamingResources() | CDecoder | [protected]
AllocateStreamingResources() | CDecoder | [protected]
DeleteInputStream(DWORD dwStreamID) | CDecoder | [private]
DeleteInputStream(DWORD dwStreamID) | CDecoder | [private]
FreeStreamingResources() | CDecoder | [protected]
FreeStreamingResources() | CDecoder | [protected]
GetAttributes(IMFAttributes **pAttributes) | CDecoder | [private]
GetAttributes(IMFAttributes **pAttributes) | CDecoder | [private]
GetInputAvailableType(DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CDecoder | [private]
GetInputAvailableType(DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CDecoder | [private]
GetInputCurrentType(DWORD dwInputStreamID, IMFMediaType **ppType) | CDecoder | [private]
GetInputCurrentType(DWORD dwInputStreamID, IMFMediaType **ppType) | CDecoder | [private]
GetInputStatus(DWORD dwInputStreamID, DWORD *pdwFlags) | CDecoder | [private]
GetInputStatus(DWORD dwInputStreamID, DWORD *pdwFlags) | CDecoder | [private]
GetInputStreamAttributes(DWORD dwInputStreamID, IMFAttributes **ppAttributes) | CDecoder | [private]
GetInputStreamAttributes(DWORD dwInputStreamID, IMFAttributes **ppAttributes) | CDecoder | [private]
GetInputStreamInfo(DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo) | CDecoder | [private]
GetInputStreamInfo(DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo) | CDecoder | [private]
GetOutputAvailableType(DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CDecoder | [private]
GetOutputAvailableType(DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CDecoder | [private]
GetOutputCurrentType(DWORD dwOutputStreamID, IMFMediaType **ppType) | CDecoder | [private]
GetOutputCurrentType(DWORD dwOutputStreamID, IMFMediaType **ppType) | CDecoder | [private]
GetOutputStatus(DWORD *pdwFlags) | CDecoder | [private]
GetOutputStatus(DWORD *pdwFlags) | CDecoder | [private]
GetOutputStreamAttributes(DWORD dwOutputStreamID, IMFAttributes **ppAttributes) | CDecoder | [private]
GetOutputStreamAttributes(DWORD dwOutputStreamID, IMFAttributes **ppAttributes) | CDecoder | [private]
GetOutputStreamInfo(DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo) | CDecoder | [private]
GetOutputStreamInfo(DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo) | CDecoder | [private]
GetStreamCount(DWORD *pcInputStreams, DWORD *pcOutputStreams) | CDecoder | [private]
GetStreamCount(DWORD *pcInputStreams, DWORD *pcOutputStreams) | CDecoder | [private]
GetStreamIDs(DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs) | CDecoder | [private]
GetStreamIDs(DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs) | CDecoder | [private]
GetStreamLimits(DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum) | CDecoder | [private]
GetStreamLimits(DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum) | CDecoder | [private]
HasPendingOutput() const | CDecoder | [inline, protected]
HasPendingOutput() const | CDecoder | [inline, protected]
InternalProcessOutput(IMFSample *pSample, IMFMediaBuffer *pOutputBuffer) | CDecoder | [protected]
InternalProcessOutput(IMFSample *pSample, IMFMediaBuffer *pOutputBuffer) | CDecoder | [protected]
IsValidInputStream(DWORD dwInputStreamID) const | CDecoder | [inline, protected]
IsValidInputStream(DWORD dwInputStreamID) const | CDecoder | [inline, protected]
IsValidOutputStream(DWORD dwOutputStreamID) const | CDecoder | [inline, protected]
IsValidOutputStream(DWORD dwOutputStreamID) const | CDecoder | [inline, protected]
m_bLowLatencyMode | CDecoder | [protected]
m_bPicture | CDecoder | [protected]
m_cbData | CDecoder | [protected]
m_cbImageSize | CDecoder | [protected]
m_critSec | CDecoder | [protected]
m_frameRate | CDecoder | [protected]
m_imageHeightInPixels | CDecoder | [protected]
m_imageWidthInPixels | CDecoder | [protected]
m_pbData | CDecoder | [protected]
m_pBuffer | CDecoder | [protected]
m_pInputType | CDecoder | [protected]
m_pOutputType | CDecoder | [protected]
m_rtFrame | CDecoder | [protected]
m_rtLength | CDecoder | [protected]
m_StreamState | CDecoder | [protected]
OnCheckInputType(IMFMediaType *pmt) | CDecoder | [protected]
OnCheckInputType(IMFMediaType *pmt) | CDecoder | [protected]
OnCheckOutputType(IMFMediaType *pmt) | CDecoder | [protected]
OnCheckOutputType(IMFMediaType *pmt) | CDecoder | [protected]
OnDiscontinuity() | CDecoder | [protected]
OnDiscontinuity() | CDecoder | [protected]
OnFlush() | CDecoder | [protected]
OnFlush() | CDecoder | [protected]
OnSetInputType(IMFMediaType *pmt) | CDecoder | [protected]
OnSetInputType(IMFMediaType *pmt) | CDecoder | [protected]
OnSetOutputType(IMFMediaType *pmt) | CDecoder | [protected]
OnSetOutputType(IMFMediaType *pmt) | CDecoder | [protected]
Process() | CDecoder | [protected]
Process() | CDecoder | [protected]
ProcessEvent(DWORD dwInputStreamID, IMFMediaEvent *pEvent) | CDecoder | [private]
ProcessEvent(DWORD dwInputStreamID, IMFMediaEvent *pEvent) | CDecoder | [private]
ProcessInput(DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags) | CDecoder | [private]
ProcessInput(DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags) | CDecoder | [private]
ProcessMessage(MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam) | CDecoder | [private]
ProcessMessage(MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam) | CDecoder | [private]
ProcessOutput(DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus) | CDecoder | [private]
ProcessOutput(DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus) | CDecoder | [private]
SetInputType(DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags) | CDecoder | [private]
SetInputType(DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags) | CDecoder | [private]
SetOutputBounds(LONGLONG hnsLowerBound, LONGLONG hnsUpperBound) | CDecoder | [private]
SetOutputBounds(LONGLONG hnsLowerBound, LONGLONG hnsUpperBound) | CDecoder | [private]
SetOutputType(DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags) | CDecoder | [private]
SetOutputType(DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags) | CDecoder | [private]
SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration) | CDecoder | [private]
SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration) | CDecoder | [private]
~CDecoder() | CDecoder | [private]
~CDecoder() | CDecoder | [private]
Generated on Sat Nov 23 2024 16:09:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Decoder/decoder.h Source File

  • Media extensions
  • MediaExtensions
  • Mpeg1Decoder

decoder.h

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // decoder.h
00004 // Implements the MPEG-1 decoder.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015 #pragma once
00016 #include <wrl\implements.h>
00017 #include <windows.media.h>
00018
00019 #include <mftransform.h>
00020 #include <mfapi.h>
00021 #include <mferror.h>
00022 #include <assert.h>
00023
00024 const DWORD MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12;       // Minimum length of the video sequence header.
00025 static const REFERENCE_TIME INVALID_TIME = _I64_MAX;    //  Not really invalid but unlikely enough for sample code.
00026
00027 template <class T> void SafeRelease(T **ppT)
00028 {
00029     if (*ppT)
00030     {
00031         (*ppT)->Release();
00032         *ppT = NULL;
00033     }
00034 }
00035
00036
00037 //-------------------------------------------------------------------
00038 // CStreamState class.
00039 // Provides state machine for picture start codes and timestamps.
00040 //
00041 //  We need to know:
00042 //
00043 //    - The time stamp to associate with a picture start code
00044 //    - The next time stamp
00045 //
00046 //-------------------------------------------------------------------
00047
00048 class CStreamState
00049 {
00050 private:
00051
00052     DWORD m_cbBytes;    // Number of valid bytes of start code so far
00053
00054     struct
00055     {
00056         bool           bValid;
00057         REFERENCE_TIME rt;
00058     } m_arTS[4];        // Array of all the timestamps.
00059                         // m_cbBytes+1 entries are valid.
00060
00061     REFERENCE_TIME m_rt;
00062
00063     BYTE m_bGOPData[4];
00064
00065     DWORD m_dwTimeCode;
00066     DWORD m_dwNextTimeCode;
00067
00068 public:
00069     CStreamState()
00070     {
00071         Reset();
00072     }
00073
00074     //  Returns true if a start code was identifed
00075     bool NextByte(BYTE bData);
00076     void TimeStamp(REFERENCE_TIME rt);
00077     void Reset();
00078
00079     REFERENCE_TIME PictureTime(DWORD *pdwTimeCode) const
00080     {
00081         *pdwTimeCode = m_dwTimeCode;
00082         return m_rt;
00083     }
00084 };
00085
00086
00087
00088 //-------------------------------------------------------------------
00089 // CDecoder
00090 //
00091 // Implements the MPEG-1 "decoder" MFT.
00092 //
00093 // The decoder outputs RGB-32 only.
00094 //
00095 // Note: This MFT is derived from a sample that used to ship in the
00096 // DirectX SDK.
00097 //-------------------------------------------------------------------
00098 #include "MPEG1Decoder.h"
00099
00100 class CDecoder
00101     : public Microsoft::WRL::RuntimeClass<
00102            Microsoft::WRL::RuntimeClassFlags< Microsoft::WRL::RuntimeClassType::WinRtClassicComMix >,
00103            ABI::Windows::Media::IMediaExtension,
00104            IMFTransform>
00105 {
00106     InspectableClass(RuntimeClass_MPEG1Decoder_MPEG1Decoder, BaseTrust)
00107
00108 public:
00109     CDecoder();
00110     ~CDecoder();
00111
00112     // IMediaExtension
00113     IFACEMETHOD (SetProperties) (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration);
00114
00115     // IMFTransform methods
00116     STDMETHODIMP GetStreamLimits(
00117         DWORD   *pdwInputMinimum,
00118         DWORD   *pdwInputMaximum,
00119         DWORD   *pdwOutputMinimum,
00120         DWORD   *pdwOutputMaximum
00121     );
00122
00123     STDMETHODIMP GetStreamCount(
00124         DWORD   *pcInputStreams,
00125         DWORD   *pcOutputStreams
00126     );
00127
00128     STDMETHODIMP GetStreamIDs(
00129         DWORD   dwInputIDArraySize,
00130         DWORD   *pdwInputIDs,
00131         DWORD   dwOutputIDArraySize,
00132         DWORD   *pdwOutputIDs
00133     );
00134
00135     STDMETHODIMP GetInputStreamInfo(
00136         DWORD                     dwInputStreamID,
00137         MFT_INPUT_STREAM_INFO *   pStreamInfo
00138     );
00139
00140     STDMETHODIMP GetOutputStreamInfo(
00141         DWORD                     dwOutputStreamID,
00142         MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00143     );
00144
00145     STDMETHODIMP GetAttributes(IMFAttributes** pAttributes);
00146
00147     STDMETHODIMP GetInputStreamAttributes(
00148         DWORD           dwInputStreamID,
00149         IMFAttributes   **ppAttributes
00150     );
00151
00152     STDMETHODIMP GetOutputStreamAttributes(
00153         DWORD           dwOutputStreamID,
00154         IMFAttributes   **ppAttributes
00155     );
00156
00157     STDMETHODIMP DeleteInputStream(DWORD dwStreamID);
00158
00159     STDMETHODIMP AddInputStreams(
00160         DWORD   cStreams,
00161         DWORD   *adwStreamIDs
00162     );
00163
00164     STDMETHODIMP GetInputAvailableType(
00165         DWORD           dwInputStreamID,
00166         DWORD           dwTypeIndex, // 0-based
00167         IMFMediaType    **ppType
00168     );
00169
00170     STDMETHODIMP GetOutputAvailableType(
00171         DWORD           dwOutputStreamID,
00172         DWORD           dwTypeIndex, // 0-based
00173         IMFMediaType    **ppType
00174     );
00175
00176     STDMETHODIMP SetInputType(
00177         DWORD           dwInputStreamID,
00178         IMFMediaType    *pType,
00179         DWORD           dwFlags
00180     );
00181
00182     STDMETHODIMP SetOutputType(
00183         DWORD           dwOutputStreamID,
00184         IMFMediaType    *pType,
00185         DWORD           dwFlags
00186     );
00187
00188     STDMETHODIMP GetInputCurrentType(
00189         DWORD           dwInputStreamID,
00190         IMFMediaType    **ppType
00191     );
00192
00193     STDMETHODIMP GetOutputCurrentType(
00194         DWORD           dwOutputStreamID,
00195         IMFMediaType    **ppType
00196     );
00197
00198     STDMETHODIMP GetInputStatus(
00199         DWORD           dwInputStreamID,
00200         DWORD           *pdwFlags
00201     );
00202
00203     STDMETHODIMP GetOutputStatus(DWORD *pdwFlags);
00204
00205     STDMETHODIMP SetOutputBounds(
00206         LONGLONG        hnsLowerBound,
00207         LONGLONG        hnsUpperBound
00208     );
00209
00210     STDMETHODIMP ProcessEvent(
00211         DWORD              dwInputStreamID,
00212         IMFMediaEvent      *pEvent
00213     );
00214
00215     STDMETHODIMP ProcessMessage(
00216         MFT_MESSAGE_TYPE    eMessage,
00217         ULONG_PTR           ulParam
00218     );
00219
00220     STDMETHODIMP ProcessInput(
00221         DWORD               dwInputStreamID,
00222         IMFSample           *pSample,
00223         DWORD               dwFlags
00224     );
00225
00226     STDMETHODIMP ProcessOutput(
00227         DWORD                   dwFlags,
00228         DWORD                   cOutputBufferCount,
00229         MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
00230         DWORD                   *pdwStatus
00231     );
00232
00233 protected:
00234
00235     // HasPendingOutput: Returns TRUE if the MFT is holding an input sample.
00236     BOOL HasPendingOutput() const { return m_pBuffer != NULL; }
00237
00238     // IsValidInputStream: Returns TRUE if dwInputStreamID is a valid input stream identifier.
00239     BOOL IsValidInputStream(DWORD dwInputStreamID) const
00240     {
00241         return dwInputStreamID == 0;
00242     }
00243
00244     // IsValidOutputStream: Returns TRUE if dwOutputStreamID is a valid output stream identifier.
00245     BOOL IsValidOutputStream(DWORD dwOutputStreamID) const
00246     {
00247         return dwOutputStreamID == 0;
00248     }
00249
00250     //  Internal processing routine
00251     HRESULT InternalProcessOutput(IMFSample *pSample, IMFMediaBuffer *pOutputBuffer);
00252     HRESULT Process();
00253     HRESULT OnCheckInputType(IMFMediaType *pmt);
00254     HRESULT OnCheckOutputType(IMFMediaType *pmt);
00255     HRESULT OnSetInputType(IMFMediaType *pmt);
00256     HRESULT OnSetOutputType(IMFMediaType *pmt);
00257     HRESULT OnDiscontinuity();
00258     HRESULT AllocateStreamingResources();
00259     HRESULT FreeStreamingResources();
00260     HRESULT OnFlush();
00261
00262
00263 protected:
00264
00265     CRITICAL_SECTION        m_critSec;
00266
00267     //  Streaming locals
00268     IMFMediaType            *m_pInputType;              // Input media type.
00269     IMFMediaType            *m_pOutputType;             // Output media type.
00270
00271     IMFMediaBuffer          *m_pBuffer;
00272     BYTE *                  m_pbData;
00273     DWORD                   m_cbData;
00274
00275     // Fomat information
00276     UINT32                      m_imageWidthInPixels;
00277     UINT32                      m_imageHeightInPixels;
00278     MFRatio                     m_frameRate;
00279     DWORD                       m_cbImageSize;              // Image size, in bytes.
00280
00281     //  Fabricate timestamps based on the average time per from if there isn't one in the stream
00282     REFERENCE_TIME          m_rtFrame;
00283     UINT64                  m_rtLength;
00284
00285     //  Current state info
00286     CStreamState            m_StreamState;
00287     bool                    m_bPicture;
00288     bool                    m_bLowLatencyMode;
00289 };
00290
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/pch.h Source File

  • Check if current session is remote

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/pch.h Source File

  • Geolocation

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/SampleBackgroundTask/BackgroundTask.cpp Source File

  • Raw notifications
  • SampleBackgroundTask

BackgroundTask.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BackgroundTask.h"
00010
00011 using namespace BackgroundTasks;
00012 using namespace Windows::ApplicationModel::Background;
00013 using namespace Windows::Networking::PushNotifications;
00014 using namespace Windows::Storage;
00015
00016 void SampleBackgroundTask::Run(IBackgroundTaskInstance^ taskInstance)
00017 {
00018     // Get the background task details
00019     auto settings = ApplicationData::Current->LocalSettings;
00020     auto taskName = taskInstance->Task->Name;
00021
00022     // Store the content received from the notification so it can be retrieved from the UI
00023     auto notificationDetails = dynamic_cast<IRawNotification^>(taskInstance->TriggerDetails);
00024     settings->Values->Insert(taskName, notificationDetails->Content);
00025 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/SampleOverlay.h Source File

  • Direct2D command list

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Constants.cpp Source File

  • Application resources and localization

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021
00022     { "String Resources In XAML", "SDKSample.ApplicationResources.Scenario1" },
00023     { "File Resources In XAML", "SDKSample.ApplicationResources.Scenario2" },
00024     { "String Resources In Code", "SDKSample.ApplicationResources.Scenario3" },
00025   { "Resources in the AppX manifest", "SDKSample.ApplicationResources.Scenario4" },
00026   { "Additional Resource Files", "SDKSample.ApplicationResources.Scenario5" },
00027   { "Class Library Resources", "SDKSample.ApplicationResources.Scenario6" },
00028   { "Runtime Changes/Events", "SDKSample.ApplicationResources.Scenario7" },
00029   { "Application Languages", "SDKSample.ApplicationResources.Scenario8" },
00030   { "Override Languages", "SDKSample.ApplicationResources.Scenario9" },
00031   { "Multi-dimensional fallback", "SDKSample.ApplicationResources.Scenario10" },
00032   { "Working with webservices", "SDKSample.ApplicationResources.Scenario11" }
00033 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::ExifExtensions Member List

This is the complete list of members for Hilo::ExifExtensions, including all inherited members.
ConvertDegreesRotationToExifOrientation(unsigned int angle) | Hilo::ExifExtensions | [static]
ConvertExifOrientationToDegreesRotation(ExifRotations exifOrientationFlag) | Hilo::ExifExtensions | [static]
RotateClockwise(Windows::Foundation::Rect rect, Windows::Foundation::Rect bitmapSize, float64 degrees) | Hilo::ExifExtensions | [static]
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

BumpMapping Member List

This is the complete list of members for BumpMapping, including all inherited members.
__pad0__ | BumpMapping |
CreateDeviceIndependentResources() override | BumpMapping | [virtual]
CreateDeviceResources() override | BumpMapping | [virtual]
CreateWindowSizeDependentResources() override | BumpMapping | [virtual]
LoadInternalState(_In_ Windows::Foundation::Collections::IPropertySet^state) | BumpMapping |
m_camera | BumpMapping | [private]
m_constantBuffer | BumpMapping | [private]
m_constantBufferData | BumpMapping | [private]
m_controller | BumpMapping | [private]
m_indexBuffer | BumpMapping | [private]
m_indexCount | BumpMapping | [private]
m_inputLayout | BumpMapping | [private]
m_normals | BumpMapping | [private]
m_normalSampler | BumpMapping | [private]
m_normalSRV | BumpMapping | [private]
m_pixelShader | BumpMapping | [private]
m_sampleOverlay | BumpMapping | [private]
m_sampler | BumpMapping | [private]
m_texture | BumpMapping | [private]
m_textureSRV | BumpMapping | [private]
m_vertexBuffer | BumpMapping | [private]
m_vertexShader | BumpMapping | [private]
Render() override | BumpMapping | [virtual]
SaveInternalState(_In_ Windows::Foundation::Collections::IPropertySet^state) | BumpMapping |
Update(float TimeTotal, float TimeDelta) | BumpMapping |
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioInput2.xaml.h Source File

  • Scheduled notifications
  • C#,C++

ScenarioInput2.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Input.xaml.h
00010 // Declaration of the Scenario2Input class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioInput2.g.h"
00017 #include "MainPage.g.h"
00018 #include "NotificationData.h"
00019
00020 namespace ScheduledNotificationsSampleCPP
00021 {
00022   [Windows::Foundation::Metadata::WebHostHidden]
00023     public ref class ScenarioInput2 sealed
00024     {
00025     public:
00026         ScenarioInput2();
00027
00028     protected:
00029         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~ScenarioInput2();
00033         MainPage^ rootPage;
00034         NotificationDataSource^ scheduledNotificationsBinding;
00035         void Remove_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036         void RefreshList_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037         void RefreshListView();
00038     };
00039 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/App.xaml.cpp Source File

  • Extended Linguistic Services (ELS)
  • C++

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicTimer.h Source File

  • DXGI swap chain rotation

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Constants.h Source File

  • Display orientation

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Windows Store app display orientation sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput4.xaml.h Source File

  • Toast notifications
  • C#,C++

ScenarioInput4.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // ScenarioInput4.xaml.h
00009 // Declaration of the ScenarioInput4 class.
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "ScenarioInput4.g.h"
00016 #include "MainPage.xaml.h"
00017
00018 using namespace Windows::UI::Xaml;
00019
00020 namespace ToastsSampleCPP
00021 {
00022   [Windows::Foundation::Metadata::WebHostHidden]
00023     public ref class ScenarioInput4 sealed
00024     {
00025     public:
00026         ScenarioInput4();
00027
00028     protected:
00029         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00031
00032     private:
00033         ~ScenarioInput4();
00034
00035     MainPage^ rootPage;
00036         void OutputText(Platform::String^ text);
00037         void Scenario4DisplayToastWithSound(NotificationsExtensions::ToastContent::ToastAudioContent audioContent, Platform::String^ audioSrc);
00038         void Scenario4DisplayToastWithSoundWithStringManipulation(NotificationsExtensions::ToastContent::ToastAudioContent audioContent, Platform::String^ audioSrc);
00039
00040         Windows::UI::Xaml::Controls::TextBlock^ outputText;
00041     };
00042 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetSIPUri.xaml.h Source File

  • User domain name

GetSIPUri.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // GetSIPUri.xaml.h
00013 // Declaration of the GetSIPUri class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "GetSIPUri.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace UserDomainName
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class GetSIPUri sealed
00031         {
00032         public:
00033             GetSIPUri();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void GetUri_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::CustomDeviceAccess::DeviceList Member List

This is the complete list of members for SDKSample::CustomDeviceAccess::DeviceList, including all inherited members.
_Current | SDKSample::CustomDeviceAccess::DeviceList | [private, static]
CreateBooleanTable(Windows::UI::Xaml::Documents::InlineCollection^Table, const Platform::Array< bool >^NewValues, const Platform::Array< bool >^OldValues, Platform::String^IndexTitle, Platform::String^ValueTitle, Platform::String^TrueValue, Platform::String^FalseValue) | SDKSample::CustomDeviceAccess::DeviceList | [static]
DeviceClosing | SDKSample::CustomDeviceAccess::DeviceList |
DeviceList() | SDKSample::CustomDeviceAccess::DeviceList | [private]
FindDevice(Platform::String^Id) | SDKSample::CustomDeviceAccess::DeviceList | [private]
InitDeviceWatcher() | SDKSample::CustomDeviceAccess::DeviceList | [private]
m_Fx2Device | SDKSample::CustomDeviceAccess::DeviceList | [private]
m_Fx2Watcher | SDKSample::CustomDeviceAccess::DeviceList | [private]
m_List | SDKSample::CustomDeviceAccess::DeviceList | [private]
m_WatcherStarted | SDKSample::CustomDeviceAccess::DeviceList | [private]
m_WatcherSuspended | SDKSample::CustomDeviceAccess::DeviceList | [private]
OnFx2Added(Windows::Devices::Enumeration::DeviceWatcher^Sender, Windows::Devices::Enumeration::DeviceInformation^DevInformation) | SDKSample::CustomDeviceAccess::DeviceList | [private]
OnFx2EnumerationComplete(Windows::Devices::Enumeration::DeviceWatcher^Sender, Object^Args) | SDKSample::CustomDeviceAccess::DeviceList | [private]
OnFx2Removed(Windows::Devices::Enumeration::DeviceWatcher^Sender, Windows::Devices::Enumeration::DeviceInformationUpdate^DevInformation) | SDKSample::CustomDeviceAccess::DeviceList | [private]
ResumeDeviceWatcher(Object^Sender, Object^Args) | SDKSample::CustomDeviceAccess::DeviceList | [private]
StartFx2Watcher() | SDKSample::CustomDeviceAccess::DeviceList |
StopFx2Watcher() | SDKSample::CustomDeviceAccess::DeviceList |
SuspendDeviceWatcher(Object^Sender, Windows::ApplicationModel::SuspendingEventArgs^Args) | SDKSample::CustomDeviceAccess::DeviceList | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario1.xaml.h Source File

  • EAS policies for mail clients

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace EAS
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Launch_Click1(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Reset_Click1(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/Constants.h Source File

  • Check if current session is remote

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Remote Desktop");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicShapes.cpp Source File

  • DirectX postcard app

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/DDSTextureLoader.cpp Source File

  • DirectX 3D shooting game

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/DirectXBase.h Source File

  • Direct2D effects on primitives

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/PlaybackControl.xaml.cpp Source File

  • Playback Manager msAudioCategory

PlaybackControl.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PlaybackControl.xaml.cpp
00013 // Implementation of the PlaybackControl class
00014 //
00015
00016 #include "pch.h"
00017 #include "PlaybackControl.xaml.h"
00018
00019 using namespace SDKSample::PlaybackManager;
00020
00021 using namespace Windows::Foundation;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Media;
00026 using namespace Windows::Media;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::Pickers;
00029 using namespace Windows::Storage::Streams;
00030 using namespace Platform;
00031 using namespace Concurrency;
00032
00033 bool PlaybackControl::IsRegistered = false;
00034 EventRegistrationToken PlaybackControl::SoundLevelChangedToken;
00035 EventRegistrationToken PlaybackControl::PlayPauseTogglePressedToken;
00036 EventRegistrationToken PlaybackControl::PlayPressedToken;
00037 EventRegistrationToken PlaybackControl::PausePressedToken;
00038 EventRegistrationToken PlaybackControl::StopPressedToken;
00039
00040 PlaybackControl::PlaybackControl()
00041 {
00042     InitializeComponent();
00043
00044     cw = Window::Current->CoreWindow;
00045     IsPlaying = false;
00046     if(IsRegistered)
00047     {
00048         // remove handlers
00049         MediaControl::SoundLevelChanged      -= SoundLevelChangedToken;
00050         MediaControl::PlayPauseTogglePressed -= PlayPauseTogglePressedToken;
00051         MediaControl::PlayPressed            -= PlayPressedToken;
00052         MediaControl::PausePressed           -= PausePressedToken;
00053         MediaControl::StopPressed            -= StopPressedToken;
00054     }
00055     // add handlers and save token
00056     SoundLevelChangedToken      = MediaControl::SoundLevelChanged      += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_SoundLevelChanged);
00057     PlayPauseTogglePressedToken = MediaControl::PlayPauseTogglePressed += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_PlayPauseTogglePressed);
00058     PlayPressedToken            = MediaControl::PlayPressed            += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_PlayPressed);
00059     PausePressedToken           = MediaControl::PausePressed           += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_PausePressed);
00060     StopPressedToken            = MediaControl::StopPressed            += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_StopPressed);
00061
00062     IsRegistered = true;
00063
00064     MediaControl::IsPlaying = false;
00065 }
00066
00067
00068 void PlaybackControl::Play()
00069 {
00070     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00071     {
00072         OutputMedia->Play();
00073         MediaControl::IsPlaying = true;
00074     }
00075     , CallbackContext::Any));
00076 }
00077
00078
00079 void PlaybackControl::Pause()
00080 {
00081     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00082     {
00083         OutputMedia->Pause();
00084         MediaControl::IsPlaying = false;
00085     }
00086     , CallbackContext::Any));
00087 }
00088
00089
00090 void PlaybackControl::Stop()
00091 {
00092     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00093     {
00094         OutputMedia->Stop();
00095         MediaControl::IsPlaying = false;
00096     }
00097     , CallbackContext::Any));
00098 }
00099
00100
00101 void PlaybackControl::SetAudioCategory(AudioCategory category)
00102 {
00103     OutputMedia->AudioCategory = category;
00104 }
00105
00106
00107 void PlaybackControl::SetAudioDeviceType(AudioDeviceType devicetype)
00108 {
00109     OutputMedia->AudioDeviceType = devicetype;
00110 }
00111
00112
00113 void PlaybackControl::SelectFile()
00114 {
00115     try
00116     {
00117         FileOpenPicker^ picker = ref new FileOpenPicker();
00118         picker->ViewMode = PickerViewMode::List;
00119         picker->SuggestedStartLocation = PickerLocationId::MusicLibrary;
00120         picker->FileTypeFilter->Append(".mp3");
00121         picker->FileTypeFilter->Append(".mp4");
00122         picker->FileTypeFilter->Append(".m4a");
00123         picker->FileTypeFilter->Append(".wma");
00124         picker->FileTypeFilter->Append(".wav");
00125
00126     create_task(picker->PickSingleFileAsync()).then([this](StorageFile^ file)
00127     {
00128       if (file)
00129             {
00130                 create_task(file->OpenAsync(FileAccessMode::Read)).then([this, file](Streams::IRandomAccessStream^ stream)
00131                 {
00132                     if (stream)
00133           {
00134             cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00135             {
00136               OutputMedia->SetSource(stream, file->ContentType);
00137             }
00138             , CallbackContext::Any));
00139           }
00140                 });
00141             }
00142
00143         });
00144
00145     }
00146     catch(Exception^ ex)
00147     {
00148         DisplayStatus(ex->ToString());
00149     }
00150 }
00151
00152
00153 void PlaybackControl::DisplayStatus(Platform::String^ text)
00154 {
00155     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00156     {
00157         Status->Text += text + "\n";
00158     }
00159     , CallbackContext::Any));
00160 }
00161
00162
00163 String^ PlaybackControl::GetTimeStampedMessage(String^ EventCalled)
00164 {
00165     Platform::String^ message;
00166     Windows::Foundation::DateTime timestamp = Windows::Foundation::DateTime();
00167
00168     Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ formatter = ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("longtime");
00169     Windows::Globalization::Calendar^ calendar = ref new Windows::Globalization::Calendar();
00170     calendar->SetToNow();
00171
00172     message = EventCalled + "   " + formatter->Format(calendar->GetDateTime());
00173
00174     return message;
00175 }
00176
00177   //If your app is playing media you feel that a user should not miss if a VOIP call comes in, you may
00178   //want to consider pausing playback when your app receives a SoundLevel(Low) notification.
00179   //A SoundLevel(Low) means your app volume has been attenuated by the system (likely for a VOIP call).
00180
00181 String^ PlaybackControl::SoundLevelToString(SoundLevel level)
00182 {
00183     String^ LevelString;
00184
00185     switch (level)
00186     {
00187     case Windows::Media::SoundLevel::Muted:
00188         LevelString = "Muted";
00189         break;
00190     case Windows::Media::SoundLevel::Low:
00191         LevelString = "Low";
00192         break;
00193     case Windows::Media::SoundLevel::Full:
00194         LevelString = "Full";
00195         break;
00196     default:
00197         LevelString = "Unknown";
00198         break;
00199     }
00200
00201     return LevelString;
00202 }
00203
00204
00205 void PlaybackControl::AppMuted()
00206 {
00207     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00208     {
00209         if (OutputMedia->CurrentState != MediaElementState::Paused)
00210         {
00211             IsPlaying = true;
00212             Pause();
00213         }
00214         else
00215         {
00216             IsPlaying = false;
00217         }
00218     }
00219     , CallbackContext::Any));
00220     DisplayStatus(GetTimeStampedMessage("Muted"));
00221 }
00222
00223
00224 void PlaybackControl::AppUnmuted()
00225 {
00226     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00227     {
00228         if (IsPlaying)
00229         {
00230             Play();
00231         }
00232     }
00233     , CallbackContext::Any));
00234     DisplayStatus(GetTimeStampedMessage("Unmuted"));
00235 }
00236
00237
00238 void PlaybackControl::MediaControl_SoundLevelChanged(Object^ sender, Object^ e)
00239 {
00240     auto soundLevelState = MediaControl::SoundLevel;
00241
00242     DisplayStatus(GetTimeStampedMessage("App sound level is ["+SoundLevelToString(soundLevelState)+"]"));
00243     if(soundLevelState == SoundLevel::Muted)
00244     {
00245         AppMuted();
00246     }
00247     else
00248     {
00249         AppUnmuted();
00250     }
00251 }
00252
00253
00254 void PlaybackControl::MediaControl_PlayPauseTogglePressed(Object^ sender, Object^ e)
00255 {
00256     if(MediaControl::IsPlaying)
00257     {
00258         Pause();
00259         DisplayStatus(GetTimeStampedMessage("Play/Pause Pressed - Pause"));
00260     }
00261     else
00262     {
00263         Play();
00264         DisplayStatus(GetTimeStampedMessage("Play/Pause Pressed - Play"));
00265     }
00266 }
00267
00268
00269 void PlaybackControl::MediaControl_PlayPressed(Object^ sender, Object^ e)
00270 {
00271     Play();
00272     DisplayStatus(GetTimeStampedMessage("Play Pressed"));
00273 }
00274
00275
00276 void PlaybackControl::MediaControl_PausePressed(Object^ sender, Object^ e)
00277 {
00278     Pause();
00279     DisplayStatus(GetTimeStampedMessage("Pause Pressed"));
00280 }
00281
00282
00283 void PlaybackControl::MediaControl_StopPressed(Object^ sender, Object^ e)
00284 {
00285     Stop();
00286     DisplayStatus(GetTimeStampedMessage("Stop Pressed"));
00287 }
00288
00289
00290 void PlaybackControl::Button_Play_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00291 {
00292     Play();
00293 }
00294
00295
00296 void PlaybackControl::Button_Pause_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00297 {
00298     Pause();
00299 }
00300
00301
00302 void PlaybackControl::Button_Stop_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00303 {
00304     Stop();
00305 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/BasicCapture.xaml.h Source File

  • Media capture using capture device

BasicCapture.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // BasicCapture.xaml.h
00013 // Declaration of the BasicCapture class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "BasicCapture.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Graphics::Display;
00025 using namespace Windows::UI::ViewManagement;
00026 using namespace Windows::Devices::Enumeration;
00027 #define VIDEO_FILE_NAME "video.mp4"
00028 #define PHOTO_FILE_NAME "photo.jpg"
00029 namespace SDKSample
00030 {
00031     namespace MediaCapture
00032     {
00033         /// <summary>
00034         /// An empty page that can be used on its own or navigated to within a Frame.
00035         /// </summary>
00036       [Windows::Foundation::Metadata::WebHostHidden]
00037         public ref class BasicCapture sealed
00038         {
00039         public:
00040             BasicCapture();
00041
00042         protected:
00043             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00044             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00045
00046         private:
00047             MainPage^ rootPage;
00048             void ScenarioInit();
00049             void ScenarioReset();
00050
00051             void Suspending(Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ e);
00052             void Resuming(Object^ sender, Object^ e);
00053
00054             void btnStartDevice_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00055             void SoundLevelChanged(Object^ sender, Object^ e);
00056             void RecordLimitationExceeded(Windows::Media::Capture::MediaCapture ^ mediaCapture);
00057             void Failed(Windows::Media::Capture::MediaCapture ^ mediaCapture, Windows::Media::Capture::MediaCaptureFailedEventArgs ^ args);
00058
00059
00060             void btnStartPreview_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061
00062             void btnStartStopRecord_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063
00064             void btnTakePhoto_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00065
00066             void SetupVideoDeviceControl(Windows::Media::Devices::MediaDeviceControl^ videoDeviceControl, Slider^ slider);
00067             void sldBrightness_ValueChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e);
00068             void sldContrast_ValueChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e);
00069
00070             void ShowStatusMessage(Platform::String^ text);
00071             void ShowExceptionMessage(Platform::Exception^ ex);
00072
00073             void EnableButton(bool enabled, Platform::String ^name);
00074             void SwitchRecordButtonContent();
00075
00076             Platform::Agile<Windows::Media::Capture::MediaCapture> m_mediaCaptureMgr;
00077             Windows::Storage::StorageFile^ m_photoStorageFile;
00078             Windows::Storage::StorageFile^ m_recordStorageFile;
00079             bool m_bRecording;
00080             bool m_bEffectAdded;
00081             bool m_bSuspended;
00082             bool m_bPreviewing;
00083             Windows::UI::Xaml::WindowVisibilityChangedEventHandler ^m_visbilityHandler;
00084             Windows::Foundation::EventRegistrationToken m_eventRegistrationToken;
00085             bool m_currentScenarioLoaded;
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/pch.h Source File

  • XAML Popup

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::CoTaskMemFreeStruct Member List

This is the complete list of members for SDKSample::CoTaskMemFreeStruct, including all inherited members.
operator()(void *ptr) const SDKSample::CoTaskMemFreeStruct [inline]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/App.xaml.h Source File

  • Playlist

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

StreamSocketSample::Common::LayoutAwarePage Member List

This is the complete list of members for StreamSocketSample::Common::LayoutAwarePage, including all inherited members.
__pad0__ | StreamSocketSample::Common::LayoutAwarePage |
_defaultViewModel | StreamSocketSample::Common::LayoutAwarePage | [private]
_layoutAwareControls | StreamSocketSample::Common::LayoutAwarePage | [private]
_windowSizeEventToken | StreamSocketSample::Common::LayoutAwarePage | [private]
DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState) | StreamSocketSample::Common::LayoutAwarePage | [virtual]
GoBack(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | StreamSocketSample::Common::LayoutAwarePage | [virtual]
InvalidateVisualState() | StreamSocketSample::Common::LayoutAwarePage |
StartLayoutUpdates(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | StreamSocketSample::Common::LayoutAwarePage |
StopLayoutUpdates(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | StreamSocketSample::Common::LayoutAwarePage |
WindowSizeChanged(Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | StreamSocketSample::Common::LayoutAwarePage | [private]
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/NotificationsExtensions/ToastContent.cs Source File

  • Secondary tiles
  • C#,C++
  • NotificationsExtensions

ToastContent.cs

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 using System;
00009 using System.Text;
00010 #if !WINRT_NOT_PRESENT
00011 using Windows.Data.Xml.Dom;
00012 using Windows.UI.Notifications;
00013 #endif
00014
00015 namespace NotificationsExtensions.ToastContent
00016 {
00017     internal sealed class ToastAudio : IToastAudio
00018     {
00019         internal ToastAudio() { }
00020
00021         public ToastAudioContent Content
00022         {
00023             get { return m_Content; }
00024             set
00025             {
00026                 if (!Enum.IsDefined(typeof(ToastAudioContent), value))
00027                 {
00028                     throw new ArgumentOutOfRangeException("value");
00029                 }
00030                 m_Content = value;
00031             }
00032         }
00033
00034         public bool Loop
00035         {
00036             get { return m_Loop; }
00037             set { m_Loop = value; }
00038         }
00039
00040         private ToastAudioContent m_Content = ToastAudioContent.Default;
00041         private bool m_Loop = false;
00042     }
00043
00044     internal class ToastNotificationBase : NotificationBase, IToastNotificationContent
00045     {
00046         public ToastNotificationBase(string templateName, int imageCount, int textCount) : base(templateName, imageCount, textCount)
00047         {
00048         }
00049
00050         private bool AudioSrcIsLooping()
00051         {
00052             return (Audio.Content == ToastAudioContent.LoopingAlarm) || (Audio.Content == ToastAudioContent.LoopingAlarm2) ||
00053                 (Audio.Content == ToastAudioContent.LoopingCall) || (Audio.Content == ToastAudioContent.LoopingCall2);
00054         }
00055
00056         private void ValidateAudio()
00057         {
00058             if (StrictValidation)
00059             {
00060                 if (Audio.Loop && Duration != ToastDuration.Long)
00061                 {
00062                     throw new NotificationContentValidationException("Looping audio is only available for long duration toasts.");
00063                 }
00064                 if (Audio.Loop && !AudioSrcIsLooping())
00065                 {
00066                     throw new NotificationContentValidationException(
00067                         "A looping audio src must be chosen if the looping audio property is set.");
00068                 }
00069                 if (!Audio.Loop && AudioSrcIsLooping())
00070                 {
00071                     throw new NotificationContentValidationException(
00072                         "The looping audio property needs to be set if a looping audio src is chosen.");
00073                 }
00074             }
00075         }
00076
00077         private void AppendAudioTag(StringBuilder builder)
00078         {
00079             if (Audio.Content != ToastAudioContent.Default)
00080             {
00081                 builder.Append("<audio");
00082                 if (Audio.Content == ToastAudioContent.Silent)
00083                 {
00084                     builder.Append(" silent='true'/>");
00085                 }
00086                 else
00087                 {
00088                     if (Audio.Loop == true)
00089                     {
00090                         builder.Append(" loop='true'");
00091                     }
00092
00093                     // The default looping sound is LoopingCall - save size by not adding it
00094                     if (Audio.Content != ToastAudioContent.LoopingCall)
00095                     {
00096                         string audioSrc = null;
00097                         switch (Audio.Content)
00098                         {
00099                             case ToastAudioContent.IM:
00100                                 audioSrc = "ms-winsoundevent:Notification.IM";
00101                                 break;
00102                             case ToastAudioContent.Mail:
00103                                 audioSrc = "ms-winsoundevent:Notification.Mail";
00104                                 break;
00105                             case ToastAudioContent.Reminder:
00106                                 audioSrc = "ms-winsoundevent:Notification.Reminder";
00107                                 break;
00108                             case ToastAudioContent.SMS:
00109                                 audioSrc = "ms-winsoundevent:Notification.SMS";
00110                                 break;
00111                             case ToastAudioContent.LoopingAlarm:
00112                                 audioSrc = "ms-winsoundevent:Notification.Looping.Alarm";
00113                                 break;
00114                             case ToastAudioContent.LoopingAlarm2:
00115                                 audioSrc = "ms-winsoundevent:Notification.Looping.Alarm2";
00116                                 break;
00117                             case ToastAudioContent.LoopingCall:
00118                                 audioSrc = "ms-winsoundevent:Notification.Looping.Call";
00119                                 break;
00120                             case ToastAudioContent.LoopingCall2:
00121                                 audioSrc = "ms-winsoundevent:Notification.Looping.Call2";
00122                                 break;
00123                         }
00124                         builder.AppendFormat(" src='{0}'", audioSrc);
00125                     }
00126                 }
00127                 builder.Append("/>");
00128             }
00129         }
00130
00131         public override string GetContent()
00132         {
00133             ValidateAudio();
00134
00135             StringBuilder builder = new StringBuilder("<toast");
00136             if (!String.IsNullOrEmpty(Launch))
00137             {
00138                 builder.AppendFormat(" launch='{0}'", Util.HttpEncode(Launch));
00139             }
00140             if (Duration != ToastDuration.Short)
00141             {
00142                 builder.AppendFormat(" duration='{0}'", Duration.ToString().ToLowerInvariant());
00143             }
00144             builder.Append(">");
00145
00146             builder.AppendFormat("<visual version='{0}'", Util.NOTIFICATION_CONTENT_VERSION);
00147             if (!String.IsNullOrWhiteSpace(Lang))
00148             {
00149                 builder.AppendFormat(" lang='{0}'", Util.HttpEncode(Lang));
00150             }
00151             if (!String.IsNullOrWhiteSpace(BaseUri))
00152             {
00153                 builder.AppendFormat(" baseUri='{0}'", Util.HttpEncode(BaseUri));
00154             }
00155             if (AddImageQuery)
00156             {
00157                 builder.AppendFormat(" addImageQuery='true'");
00158             }
00159             builder.Append(">");
00160
00161             builder.AppendFormat("<binding template='{0}'>{1}</binding>", TemplateName, SerializeProperties(Lang, BaseUri, AddImageQuery));
00162             builder.Append("</visual>");
00163
00164             AppendAudioTag(builder);
00165
00166             builder.Append("</toast>");
00167
00168             return builder.ToString();
00169         }
00170
00171 #if !WINRT_NOT_PRESENT
00172         public ToastNotification CreateNotification()
00173         {
00174             XmlDocument xmlDoc = new XmlDocument();
00175             xmlDoc.LoadXml(GetContent());
00176             return new ToastNotification(xmlDoc);
00177         }
00178 #endif
00179
00180         public IToastAudio Audio
00181         {
00182             get { return m_Audio; }
00183         }
00184
00185         public string Launch
00186         {
00187             get { return m_Launch; }
00188             set { m_Launch = value; }
00189         }
00190
00191         public ToastDuration Duration
00192         {
00193             get { return m_Duration; }
00194             set
00195             {
00196                 if (!Enum.IsDefined(typeof(ToastDuration), value))
00197                 {
00198                     throw new ArgumentOutOfRangeException("value");
00199                 }
00200                 m_Duration = value;
00201             }
00202         }
00203
00204         private string m_Launch;
00205         private IToastAudio m_Audio = new ToastAudio();
00206         private ToastDuration m_Duration = ToastDuration.Short;
00207     }
00208
00209     internal class ToastImageAndText01 : ToastNotificationBase, IToastImageAndText01
00210     {
00211         public ToastImageAndText01() : base(templateName: "ToastImageAndText01", imageCount: 1, textCount: 1)
00212         {
00213         }
00214
00215         public INotificationContentImage Image { get { return Images[0]; } }
00216
00217         public INotificationContentText TextBodyWrap { get { return TextFields[0]; } }
00218     }
00219
00220     internal class ToastImageAndText02 : ToastNotificationBase, IToastImageAndText02
00221     {
00222         public ToastImageAndText02() : base(templateName: "ToastImageAndText02", imageCount: 1, textCount: 2)
00223         {
00224         }
00225
00226         public INotificationContentImage Image { get { return Images[0]; } }
00227
00228         public INotificationContentText TextHeading { get { return TextFields[0]; } }
00229         public INotificationContentText TextBodyWrap { get { return TextFields[1]; } }
00230     }
00231
00232     internal class ToastImageAndText03 : ToastNotificationBase, IToastImageAndText03
00233     {
00234         public ToastImageAndText03() : base(templateName: "ToastImageAndText03", imageCount: 1, textCount: 2)
00235         {
00236         }
00237
00238         public INotificationContentImage Image { get { return Images[0]; } }
00239
00240         public INotificationContentText TextHeadingWrap { get { return TextFields[0]; } }
00241         public INotificationContentText TextBody { get { return TextFields[1]; } }
00242     }
00243
00244     internal class ToastImageAndText04 : ToastNotificationBase, IToastImageAndText04
00245     {
00246         public ToastImageAndText04() : base(templateName: "ToastImageAndText04", imageCount: 1, textCount: 3)
00247         {
00248         }
00249
00250         public INotificationContentImage Image { get { return Images[0]; } }
00251
00252         public INotificationContentText TextHeading { get { return TextFields[0]; } }
00253         public INotificationContentText TextBody1 { get { return TextFields[1]; } }
00254         public INotificationContentText TextBody2 { get { return TextFields[2]; } }
00255     }
00256
00257     internal class ToastText01 : ToastNotificationBase, IToastText01
00258     {
00259         public ToastText01() : base(templateName: "ToastText01", imageCount: 0, textCount: 1)
00260         {
00261         }
00262
00263         public INotificationContentText TextBodyWrap { get { return TextFields[0]; } }
00264     }
00265
00266     internal class ToastText02 : ToastNotificationBase, IToastText02
00267     {
00268         public ToastText02() : base(templateName: "ToastText02", imageCount: 0, textCount: 2)
00269         {
00270         }
00271
00272         public INotificationContentText TextHeading { get { return TextFields[0]; } }
00273         public INotificationContentText TextBodyWrap { get { return TextFields[1]; } }
00274     }
00275
00276     internal class ToastText03 : ToastNotificationBase, IToastText03
00277     {
00278         public ToastText03() : base(templateName: "ToastText03", imageCount: 0, textCount: 2)
00279         {
00280         }
00281
00282         public INotificationContentText TextHeadingWrap { get { return TextFields[0]; } }
00283         public INotificationContentText TextBody { get { return TextFields[1]; } }
00284     }
00285
00286     internal class ToastText04 : ToastNotificationBase, IToastText04
00287     {
00288         public ToastText04() : base(templateName: "ToastText04", imageCount: 0, textCount: 3)
00289         {
00290         }
00291
00292         public INotificationContentText TextHeading { get { return TextFields[0]; } }
00293         public INotificationContentText TextBody1 { get { return TextFields[1]; } }
00294         public INotificationContentText TextBody2 { get { return TextFields[2]; } }
00295     }
00296
00297     /// <summary>
00298     /// A factory which creates toast content objects for all of the toast template types.
00299     /// </summary>
00300     public static class ToastContentFactory
00301     {
00302         /// <summary>
00303         /// Creates a ToastImageAndText01 template content object.
00304         /// </summary>
00305         /// <returns>A ToastImageAndText01 template content object.</returns>
00306         public static IToastImageAndText01 CreateToastImageAndText01()
00307         {
00308             return new ToastImageAndText01();
00309         }
00310
00311         /// <summary>
00312         /// Creates a ToastImageAndText02 template content object.
00313         /// </summary>
00314         /// <returns>A ToastImageAndText02 template content object.</returns>
00315         public static IToastImageAndText02 CreateToastImageAndText02()
00316         {
00317             return new ToastImageAndText02();
00318         }
00319
00320         /// <summary>
00321         /// Creates a ToastImageAndText03 template content object.
00322         /// </summary>
00323         /// <returns>A ToastImageAndText03 template content object.</returns>
00324         public static IToastImageAndText03 CreateToastImageAndText03()
00325         {
00326             return new ToastImageAndText03();
00327         }
00328
00329         /// <summary>
00330         /// Creates a ToastImageAndText04 template content object.
00331         /// </summary>
00332         /// <returns>A ToastImageAndText04 template content object.</returns>
00333         public static IToastImageAndText04 CreateToastImageAndText04()
00334         {
00335             return new ToastImageAndText04();
00336         }
00337
00338         /// <summary>
00339         /// Creates a ToastText01 template content object.
00340         /// </summary>
00341         /// <returns>A ToastText01 template content object.</returns>
00342         public static IToastText01 CreateToastText01()
00343         {
00344             return new ToastText01();
00345         }
00346
00347         /// <summary>
00348         /// Creates a ToastText02 template content object.
00349         /// </summary>
00350         /// <returns>A ToastText02 template content object.</returns>
00351         public static IToastText02 CreateToastText02()
00352         {
00353             return new ToastText02();
00354         }
00355
00356         /// <summary>
00357         /// Creates a ToastText03 template content object.
00358         /// </summary>
00359         /// <returns>A ToastText03 template content object.</returns>
00360         public static IToastText03 CreateToastText03()
00361         {
00362             return new ToastText03();
00363         }
00364
00365         /// <summary>
00366         /// Creates a ToastText04 template content object.
00367         /// </summary>
00368         /// <returns>A ToastText04 template content object.</returns>
00369         public static IToastText04 CreateToastText04()
00370         {
00371             return new ToastText04();
00372         }
00373     }
00374 }
Generated on Sat Nov 23 2024 16:08:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/suspensionmanager.cpp Source File

  • XAML high contrast style
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Scenario2.xaml.h Source File

  • Scaling according to DPI

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Scaling
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         private:
00039             // Helpers to convert between points and pixels.
00040             double PtFromPx(double pixel);
00041             double PxFromPt(double pt);
00042
00043             Platform::String^ StringFromDouble(double);
00044             void SetOverrideRectSize(double sizeInPhysicalPx, double scaleFactor);
00045             void SetOverrideTextFont(double size, Windows::UI::Xaml::Media::FontFamily^ fontFamily);
00046             void OutputSettings(double scaleFactor, Windows::UI::Xaml::FrameworkElement^ rectangle, Windows::UI::Xaml::Controls::TextBlock^ relativePxText,
00047                                 Windows::UI::Xaml::Controls::TextBlock^ physicalPxText, Windows::UI::Xaml::Controls::TextBlock^ fontTextBlock);
00048             void ResetOutput();
00049             void DisplayProperties_LogicalDpiChanged(Platform::Object^ sender);
00050
00051             Windows::UI::Xaml::Media::FontFamily^ defaultFontFamily;
00052             Windows::UI::Xaml::Media::FontFamily^ overrideFontFamily;
00053         };
00054     }
00055 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/SampleOverlay.h Source File

  • DirectX marble maze game

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/StreamTypeMedia.xaml.cpp Source File

  • Playback Manager msAudioCategory

StreamTypeMedia.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // StreamTypeMedia.xaml.cpp
00013 // Implementation of the StreamTypeMedia class
00014 //
00015
00016 #include "pch.h"
00017 #include "StreamTypeMedia.xaml.h"
00018
00019 using namespace SDKSample::PlaybackManager;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::Xaml::Media;
00025
00026 StreamTypeMedia::StreamTypeMedia()
00027   : _playback(nullptr)
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void StreamTypeMedia::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // Get a pointer to our main page.
00040     rootPage = MainPage::Current;
00041 }
00042
00043
00044 void PlaybackManager::StreamTypeMedia::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00045 {
00046   if(_playback == nullptr)
00047   {
00048     _playback = ref new Playback(Output);
00049   }
00050
00051   _playback->SetAudioCategory(AudioCategory::BackgroundCapableMedia);
00052   _playback->SetSourceStream("folk_rock.mp3");
00053 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/GeneratorIncrementalLoadingClass.h Source File

  • XAML data binding

GeneratorIncrementalLoadingClass.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // GeneratorIncrementalLoadingClass.h
00010 // Declaration of the GeneratorIncrementalLoadingClass class
00011 //
00012
00013 #pragma once
00014
00015 #include <ppltasks.h>
00016 #include <collection.h>
00017 #include "IncrementalLoadingBase.h"
00018 #include "Employee.h"
00019
00020 namespace SDKSample
00021 {
00022     namespace DataBinding
00023     {
00024         // This class implements IncrementalLoadingBase.
00025         // To create your own Infinite List, you can create a class like this one that doesn't have 'generator' or 'maxcount',
00026         //  and instead downloads items from a live data source in LoadMoreItemsOverrideAsync.
00027         ref class GeneratorIncrementalLoadingClass : public DataBinding::IncrementalLoadingBase
00028         {
00029 #pragma region State
00030         internal:
00031             unsigned int _count;
00032             unsigned int _maxCount;
00033 #pragma endregion
00034
00035         internal:
00036             GeneratorIncrementalLoadingClass(unsigned int maxCount)
00037             {
00038                 _maxCount = maxCount;
00039                 _count = 0;
00040             }
00041
00042             virtual Concurrency::task<Windows::Foundation::Collections::IVector<Platform::Object^>^> LoadMoreItemsOverride(Concurrency::cancellation_token c, unsigned int count) override
00043             {
00044                 return Concurrency::task<Windows::Foundation::Collections::IVector<Platform::Object^>^>(
00045                     [=]() -> Windows::Foundation::Collections::IVector<Platform::Object^>^ {
00046                         unsigned int toGenerate = _maxCount - _count;
00047
00048                         ///
00049                         ///  Replace this section with your code to load more items
00050                         ///
00051                         Concurrency::wait(10);
00052
00053                         if (count < toGenerate)
00054                         {
00055                             toGenerate = count;
00056                         }
00057
00058                         /// Note that Platform::Collections::Vector<Platform::Object^> can be returned as Windows::Foundation::Collections::IVector<Platform::Object^>
00059                         auto items = ref new Platform::Collections::Vector<Platform::Object^>();
00060                         for(unsigned int i=0; i < toGenerate; i++)
00061                         {
00062                             auto item = this->Generator(this->_count++);
00063                             items->Append(item);
00064                         }
00065
00066                         return items;
00067
00068                         ///
00069                         /// end Replace this section with your code to load more items
00070                         ///
00071                     }
00072                 );
00073             }
00074
00075             virtual bool HasMoreItemsOverride() override
00076             {
00077                 return _count < _maxCount;
00078             }
00079
00080         private:
00081             Platform::Object^ Generator(int count)
00082             {
00083                 auto employee = ref new Employee();
00084                 employee->Name = "Name" + count;
00085                 employee->Organization = "Organization" + count;
00086                 return employee;
00087             }
00088         };
00089     }
00090 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Matrix4x4< T > Member List

This is the complete list of members for Matrix4x4< T >, including all inherited members.
_11 | Matrix4x4< T > |
_12 | Matrix4x4< T > |
_13 | Matrix4x4< T > |
_14 | Matrix4x4< T > |
_21 | Matrix4x4< T > |
_22 | Matrix4x4< T > |
_23 | Matrix4x4< T > |
_24 | Matrix4x4< T > |
_31 | Matrix4x4< T > |
_32 | Matrix4x4< T > |
_33 | Matrix4x4< T > |
_34 | Matrix4x4< T > |
_41 | Matrix4x4< T > |
_42 | Matrix4x4< T > |
_43 | Matrix4x4< T > |
_44 | Matrix4x4< T > |
_m00 | Matrix4x4< T > |
_m01 | Matrix4x4< T > |
_m02 | Matrix4x4< T > |
_m03 | Matrix4x4< T > |
_m10 | Matrix4x4< T > |
_m11 | Matrix4x4< T > |
_m12 | Matrix4x4< T > |
_m13 | Matrix4x4< T > |
_m20 | Matrix4x4< T > |
_m21 | Matrix4x4< T > |
_m22 | Matrix4x4< T > |
_m23 | Matrix4x4< T > |
_m30 | Matrix4x4< T > |
_m31 | Matrix4x4< T > |
_m32 | Matrix4x4< T > |
_m33 | Matrix4x4< T > |
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
Matrix4x4(T value=0) | Matrix4x4< T > | [inline]
Matrix4x4(T i11, T i12, T i13, T i14, T i21, T i22, T i23, T i24, T i31, T i32, T i33, T i34, T i41, T i42, T i43, T i44) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
operator[](unsigned int index) | Matrix4x4< T > | [inline]
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::DebugLoggingExceptionPolicy Member List

This is the complete list of members for Hilo::DebugLoggingExceptionPolicy, including all inherited members.
HandleException(Platform::Exception^exception) Hilo::DebugLoggingExceptionPolicy [virtual]
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/Constants.h Source File

  • Removable storage

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Removable Storage");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042         property Windows::Foundation::Collections::IVectorView<Windows::Storage::IStorageItem^>^ FileActivationFiles
00043         {
00044             Windows::Foundation::Collections::IVectorView<Windows::Storage::IStorageItem^>^ get()
00045             {
00046                 return fileActivationFiles;
00047             }
00048
00049             void set(Windows::Foundation::Collections::IVectorView<Windows::Storage::IStorageItem^>^ value)
00050             {
00051                 fileActivationFiles = value;
00052             }
00053         }
00054
00055         property Windows::Storage::StorageFolder^ AutoplayFileSystemDeviceFolder
00056         {
00057             Windows::Storage::StorageFolder^ get()
00058             {
00059                 return autoplayFileSystemDeviceFolder;
00060             }
00061
00062             void set(Windows::Storage::StorageFolder^ value)
00063             {
00064                 autoplayFileSystemDeviceFolder = value;
00065             }
00066         }
00067
00068         property Platform::String^ AutoplayNonFileSystemDeviceId
00069         {
00070             Platform::String^ get()
00071             {
00072                 return autoplayNonFileSystemDeviceId;
00073             }
00074
00075             void set(Platform::String^ value)
00076             {
00077                 autoplayNonFileSystemDeviceId = value;
00078             }
00079         }
00080
00081         // Selects and loads the Autoplay scenario
00082         void LoadAutoplayScenario()
00083         {
00084             LoadScenario((safe_cast<Windows::UI::Xaml::Controls::ListBoxItem^>(Scenarios->SelectedItem))->Name);
00085             Scenarios->SelectedIndex = MainPage::autoplayScenarioIndex;
00086         }
00087
00088     private:
00089         static Platform::Array<Scenario>^ scenariosInner;
00090         static int autoplayScenarioIndex;
00091
00092         // Contains the list of Windows.Storage.StorageItem's provided when this application is activated to handle
00093         // the supported file types specified in the manifest (here, these will be image files).
00094         Windows::Foundation::Collections::IVectorView<Windows::Storage::IStorageItem^>^ fileActivationFiles;
00095
00096         // Contains the storage folder (representing a file-system removable storage) when this application is
00097         // activated by Content Autoplay.
00098         Windows::Storage::StorageFolder^ autoplayFileSystemDeviceFolder;
00099
00100         // Contains the device identifier (representing a non-file system removable storage) provided when this application
00101         // is activated by Device Autoplay.
00102         Platform::String^ autoplayNonFileSystemDeviceId;
00103     };
00104
00105     partial ref class App
00106     {
00107     public:
00108         virtual void OnFileActivated(Windows::ApplicationModel::Activation::FileActivatedEventArgs^ args) override;
00109         virtual void OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^ args) override;
00110     };
00111 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario3.xaml.cpp Source File

  • Compression

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018 #include "CompressionUtils.h"
00019
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::UI::Xaml::Navigation;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::Storage;
00025 using namespace Windows::Storage::Pickers;
00026 using namespace Windows::Storage::Streams;
00027 using namespace Windows::Storage::Compression;
00028
00029 using namespace SDKSample::Compression;
00030
00031 using namespace concurrency;
00032
00033 Scenario3::Scenario3()
00034 {
00035     InitializeComponent();
00036 }
00037
00038 /// <summary>
00039 /// Invoked when this page is about to be displayed in a Frame.
00040 /// </summary>
00041 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00042 /// property is typically used to configure the page.</param>
00043 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00044 {
00045     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00046     // as NotifyUser()
00047     rootPage = MainPage::Current;
00048 }
00049
00050 void ::SDKSample::Compression::Scenario3::DoScenario(Windows::Storage::Compression::CompressAlgorithm Algorithm)
00051 {
00052     Progress->Text = "";
00053
00054     // This scenario uses File Picker which doesn't work in snapped mode - try unsnap first
00055     // and fail gracefully if we can't
00056     if ((ApplicationView::Value == ApplicationViewState::Snapped) &&
00057         !ApplicationView::TryUnsnap())
00058     {
00059         rootPage->NotifyUser("Sample doesn't work in snapped mode", NotifyType::ErrorMessage);
00060         return;
00061     }
00062
00063     rootPage->NotifyUser("Working...", NotifyType::StatusMessage);
00064
00065     auto context = std::make_shared<ScenarioContext>();
00066     context->raStream = ref new InMemoryRandomAccessStream();
00067
00068     auto picker = ref new Pickers::FileOpenPicker();
00069     picker->FileTypeFilter->Append("*");
00070
00071     // First pick a test file and open it for reading
00072     create_task(picker->PickSingleFileAsync()).then([=](StorageFile^ OriginalFile)
00073     {
00074         if (!OriginalFile)
00075         {
00076             throw std::runtime_error("No file has been selected");
00077         }
00078
00079         Progress->Text += "File \"" + OriginalFile->Name + "\" has been picked\n";
00080
00081         return OriginalFile->OpenAsync(FileAccessMode::Read);
00082     })
00083
00084     // Then read the whole file into memory buffer
00085     .then([=](IRandomAccessStream^ OriginalStream)
00086     {
00087         return ReadStreamTask(OriginalStream, context->originalData).GetTask();
00088     })
00089
00090     // Then compress data using "classic" Compression API
00091     .then([=](size_t BytesRead)
00092     {
00093         Progress->Text += BytesRead + " bytes have been read from disk\n";
00094
00095         // IMPORTANT:
00096         // Tasks, that are created over IAsyncOperation (and the likes) or descended from them
00097         // have their continuations scheduled to the same ASTA apartment effectively blocking
00098         // the GUI for the length of processing continuation. Create an independent task here
00099         // instead of adding continuation on the upper level task (which descends from
00100         // "apartment-aware" task) so we will not block the GUI (ASTA) thread while compressing.
00101         return task<size_t>([=]
00102         {
00103             // We are by convention the only thread to touch context->compressedData and
00104             // context->decompressedData at this point - no synchronization necessary
00105
00106             COMPRESSOR_HANDLE compressorHandle = nullptr;
00107
00108             try
00109             {
00110                 // Enumaration values of Windows::Storage::Compression::CompressAlgorithm are
00111                 // guaranteed to match values from compressapi.h
00112                 ULONG compressAlgorithm = static_cast<ULONG>(Algorithm);
00113                 SIZE_T compressedDataSize = 0;
00114                 std::vector<byte> compressedData;
00115
00116                 // Compress algorithm should always be explicit for "classic" Compression API
00117                 if (compressAlgorithm == COMPRESS_ALGORITHM_INVALID)
00118                 {
00119                     compressAlgorithm = COMPRESS_ALGORITHM_XPRESS;
00120                 }
00121
00122                 if (!CreateCompressor(compressAlgorithm, nullptr, &compressorHandle))
00123                 {
00124                     throw std::runtime_error("Cannot create compressor");
00125                 }
00126
00127                 if (!Compress(compressorHandle, context->originalData.data(), context->originalData.size(), nullptr, 0, &compressedDataSize) &&
00128                     (GetLastError() != ERROR_INSUFFICIENT_BUFFER))
00129                 {
00130                     throw std::runtime_error("Cannot get decompressed data size");
00131                 }
00132
00133                 compressedData.resize(compressedDataSize);
00134
00135                 if (!Compress(compressorHandle,
00136                                 context->originalData.data(),
00137                                 context->originalData.size(),
00138                                 compressedData.data(),
00139                                 compressedData.size(),
00140                                 &compressedDataSize))
00141                 {
00142                     throw std::runtime_error("Cannot decompress data");
00143                 }
00144                 compressedData.resize(compressedDataSize);
00145
00146                 CloseCompressor(compressorHandle);
00147
00148                 context->compressedData = std::move(compressedData);
00149                 return context->compressedData.size();
00150             }
00151             catch (...)
00152             {
00153                 if (compressorHandle != nullptr)
00154                 {
00155                     CloseDecompressor(compressorHandle);
00156                 }
00157
00158                 throw;
00159             }
00160         });
00161     })
00162
00163     // Then write compressed data into in-memory stream
00164     .then([=](size_t CompressedSize)
00165     {
00166         Progress->Text += "Compressed into " + CompressedSize + " bytes\n";
00167
00168         auto dataWriter = ref new DataWriter(context->raStream);
00169         context->writer = dataWriter;
00170         auto data = ref new Platform::Array<byte>(context->compressedData.data(), (unsigned int)context->compressedData.size());
00171         dataWriter->WriteBytes(data);
00172
00173         return dataWriter->StoreAsync();
00174     })
00175
00176     // Then decompress in-memory stream into vector
00177     .then([=](size_t CompressedSize)
00178     {
00179         auto decompressor = ref new Decompressor(context->raStream->GetInputStreamAt(0));
00180
00181         Progress->Text += "Decompressor object has been created\n";
00182
00183         return ReadStreamTask(decompressor, context->decompressedData).GetTask();
00184     })
00185
00186     // Then verify if any data has been lost in action
00187     .then([=](size_t BytesRead)
00188     {
00189         Progress->Text += BytesRead + " bytes have been decompressed\n";
00190
00191         if (context->decompressedData.size() != BytesRead)
00192         {
00193             throw std::runtime_error("Decompressed data size doesn't match number of bytes read from in-memory stream");
00194         }
00195
00196         if (context->originalData.size() != context->decompressedData.size())
00197         {
00198             throw std::runtime_error("Decompressed data size doesn't match original one");
00199         }
00200
00201         if (!std::equal(context->originalData.begin(), context->originalData.end(), context->decompressedData.begin()))
00202         {
00203             throw std::runtime_error("Decompressed data doesn't match original one");
00204         }
00205
00206         Progress->Text += "Decompressed data matches original\n";
00207     })
00208
00209     // Final task based continuation is used to handle exceptions in the chain above
00210     .then([=](task<void> FinalContinuation)
00211     {
00212         try
00213         {
00214             // Transport all exceptions to this thread. This task is guaranteed to be completed by now.
00215             FinalContinuation.get();
00216
00217             Progress->Text += "All done\n";
00218             rootPage->NotifyUser("Finished", NotifyType::StatusMessage);
00219         }
00220         catch (Platform::Exception ^e)
00221         {
00222             rootPage->NotifyUser(e->Message, NotifyType::ErrorMessage);
00223         }
00224         catch (const std::exception &e)
00225         {
00226             std::wstringstream wss;
00227             wss << e.what();
00228             rootPage->NotifyUser(ref new Platform::String(wss.str().c_str()), NotifyType::ErrorMessage);
00229         }
00230     });
00231 }
00232
00233 void ::SDKSample::Compression::Scenario3::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00234 {
00235     Button^ b = safe_cast<Button^>(sender);
00236
00237     if (b != nullptr)
00238     {
00239         DoScenario(CompressAlgorithm::InvalidAlgorithm);
00240     }
00241 }
00242
00243 void ::SDKSample::Compression::Scenario3::Xpress_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00244 {
00245     Button^ b = safe_cast<Button^>(sender);
00246
00247     if (b != nullptr)
00248     {
00249         DoScenario(CompressAlgorithm::Xpress);
00250     }
00251 }
00252
00253 void ::SDKSample::Compression::Scenario3::XpressHuff_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00254 {
00255     Button^ b = safe_cast<Button^>(sender);
00256
00257     if (b != nullptr)
00258     {
00259         DoScenario(CompressAlgorithm::XpressHuff);
00260     }
00261 }
00262
00263 void ::SDKSample::Compression::Scenario3::Mszip_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00264 {
00265     Button^ b = safe_cast<Button^>(sender);
00266
00267     if (b != nullptr)
00268     {
00269         DoScenario(CompressAlgorithm::Mszip);
00270     }
00271 }
00272
00273 void ::SDKSample::Compression::Scenario3::Lzms_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00274 {
00275     Button^ b = safe_cast<Button^>(sender);
00276
00277     if (b != nullptr)
00278     {
00279         DoScenario(CompressAlgorithm::Lzms);
00280     }
00281 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/DirectXSample.h Source File

  • Direct2D geometry realization

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/App.xaml.h Source File

  • Raw notifications
  • MainAppSample

App.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.h
00010 // Declaration of the App.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "App.g.h"
00017
00018 namespace RawNotificationsSampleCPP
00019 {
00020     ref class App sealed
00021     {
00022     public:
00023         App();
00024         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00025         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00026     };
00027 }
00028
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario4.xaml.cpp Source File

  • Credential locker

Scenario4.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.cpp
00013 // Implementation of the Scenario4 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario4.xaml.h"
00018
00019 using namespace SDKSample::PasswordVaultCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Security::Credentials;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027
00028
00029
00030 Scenario4::Scenario4()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void Scenario4::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00043     // as NotifyUser()
00044     rootPage = MainPage::Current;
00045 }
00046
00047 void DebugPrintSc4(Page^ rootPage, Platform::String^ Trace)
00048 {
00049   Page^ outputFrame = (Page^) rootPage;
00050     TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
00051     ErrorMessage->Text += Trace + "\r\n";
00052  }
00053
00054 void CleanComboboxSc4(Page^ rootPage)
00055 {
00056   Page^ inputFrame = (Page^) rootPage;
00057   ComboBox^ SelectResource = (ComboBox^) inputFrame->FindName("SelectResource");
00058   ComboBox^ SelectUser = (ComboBox^) inputFrame->FindName("SelectUser");
00059   try
00060     {
00061     SelectUser->SelectedIndex= -1;
00062     SelectUser->ItemsSource = ref new Vector<String ^>();
00063
00064     SelectResource->SelectedIndex= -1;
00065     SelectResource->ItemsSource = ref new Vector<String ^>();
00066   }
00067     catch (Platform::Exception^ Error)
00068     {
00069     DebugPrintSc4(rootPage, Error->ToString());
00070     }
00071 }
00072
00073 void ResetSc4(Page^ rootPage)
00074 {
00075   try
00076     {
00077     Page^ outputFrame = (Page^) rootPage;
00078         Page^ inputFrame = (Page^) rootPage;
00079
00080     TextBox^ InputResourceValue = (TextBox^) outputFrame->FindName("InputResourceValue");
00081         InputResourceValue->Text = "";
00082
00083         TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
00084         InputUserNameValue->Text = "";
00085         PasswordBox^ InputPasswordValue = (PasswordBox^)outputFrame->FindName("InputPasswordValue");
00086         InputPasswordValue->Password= "";
00087         TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
00088         ErrorMessage->Text = "";
00089         TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
00090         CheckBox^ SaveCredCheck = (CheckBox^) outputFrame->FindName("SaveCredCheck");
00091         SaveCredCheck->IsChecked = false;
00092
00093   }
00094     catch (Platform::Exception^ Error)
00095     {
00096     DebugPrintSc4(rootPage, Error->ToString());
00097   }
00098 }
00099
00100
00101 void SDKSample::PasswordVaultCPP::Scenario4::Launch_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00102 {
00103   try
00104   {
00105     Page^ outputFrame = (Page^) rootPage;
00106         Page^ inputFrame = (Page^) rootPage;
00107
00108     Vector<String^>^ itemSource1 = ref new Vector<String^>();
00109     Vector<String^>^ itemSource2 = ref new Vector<String^>();
00110     Vector <Object^>^ l = ref new Vector<Object^>();
00111     Vector <Object^>^ m = ref new Vector<Object^>();
00112
00113     ResetSc4(rootPage);
00114     CleanComboboxSc4(rootPage);
00115
00116     CheckBox^ AuthenticationFailCheck = (CheckBox ^) outputFrame->FindName("AuthenticationFailCheck");
00117     TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
00118     ComboBox^ SelectUser = (ComboBox^) inputFrame->FindName("SelectUser");
00119     ComboBox^ SelectResource = (ComboBox^) inputFrame->FindName("SelectResource");
00120
00121     if (AuthenticationFailCheck->IsChecked->Value == true)
00122     {
00123       WelcomeMessage->Text = "Blocked";
00124     }
00125     else
00126     {
00127       try
00128       {
00129         PasswordCredential^ cred = ref new PasswordCredential();
00130         Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00131         Windows::Foundation::Collections::IVectorView<PasswordCredential^>^ creds = vault->RetrieveAll();
00132         for each (PasswordCredential^ cred in creds)
00133         {
00134           itemSource1->InsertAt(0, cred->UserName);
00135           itemSource2->InsertAt(0, cred->Resource);
00136         }
00137
00138       }
00139       catch (Platform::COMException^ Error) // If there are no stored credentials, no list to populate
00140       {
00141         DebugPrintSc4(this->rootPage, Error->ToString());
00142       }
00143       itemSource1->InsertAt(0, "Add new user");
00144       itemSource1->InsertAt(0, "");
00145       SelectUser->ItemsSource = itemSource1;
00146       SelectUser->SelectedIndex = 0;
00147
00148
00149       itemSource2->InsertAt(0, "Add new resource");
00150       itemSource2->InsertAt(0, "");
00151       SelectResource->ItemsSource = itemSource2;
00152       SelectResource->SelectedIndex = 0;
00153
00154       WelcomeMessage->Text = "Scenario is ready, please sign in";
00155
00156     }
00157
00158   }
00159   catch (Platform::COMException^ Error)
00160   {
00161     DebugPrintSc4(rootPage, Error->ToString());
00162   }
00163
00164 }
00165
00166
00167 void SDKSample::PasswordVaultCPP::Scenario4::Signin_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00168 {
00169   Page^ outputFrame = (Page^) rootPage;
00170   Page^ inputFrame = (Page^) rootPage;
00171
00172   TextBox^ InputResourceNameValue = (TextBox^) outputFrame->FindName("InputResourceValue");
00173   TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
00174   PasswordBox^ InputPasswordValue = (PasswordBox^) outputFrame->FindName("InputPasswordValue");
00175   TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
00176   CheckBox^ SaveCredCheck = (CheckBox^) outputFrame->FindName("SaveCredCheck");
00177
00178   try
00179   {
00180
00181     if (InputUserNameValue->Text == "" || InputPasswordValue->Password == "")
00182     {
00183       TextBox^ ErrorMessage = (TextBox ^) outputFrame->FindName("ErrorMessage");
00184       ErrorMessage->Text = "User name and password are not allowed to be empty, Please input user name and password";
00185     }
00186     else
00187     {
00188       try
00189       {
00190         Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00191         PasswordCredential^ c = ref new PasswordCredential(InputResourceNameValue->Text, InputUserNameValue->Text, InputPasswordValue->Password);
00192         if (SaveCredCheck->IsChecked->Value)
00193         {
00194           vault->Add(c);
00195         }
00196
00197         WelcomeMessage->Text = "Welcome to " + c->Resource + ", " + c->UserName;
00198       }
00199       catch (Platform::COMException^ Error) // No stored credentials, so none to delete
00200       {
00201         DebugPrintSc4(rootPage, Error->ToString());
00202       }
00203     }
00204   }
00205   catch (Exception^ Error) // No stored credentials, so none to delete
00206   {
00207     DebugPrintSc4(rootPage, Error->ToString());
00208   }
00209
00210     ResetSc4(rootPage);
00211
00212     CheckBox^ AuthenticationFailCheck = (CheckBox ^) outputFrame->FindName("AuthenticationFailCheck");
00213     AuthenticationFailCheck->IsChecked = false;
00214 }
00215
00216
00217 void SDKSample::PasswordVaultCPP::Scenario4::ChangeUser_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00218 {
00219   Page^ outputFrame = (Page^) rootPage;
00220   Page^ inputFrame = (Page^) rootPage;
00221
00222   try
00223     {
00224     Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00225     Windows::Foundation::Collections::IVectorView<PasswordCredential^>^ creds = vault->RetrieveAll();
00226
00227     for each (PasswordCredential^ c in creds)
00228         {
00229       try
00230             {
00231         vault->Remove(c);
00232             }
00233       catch (Platform::COMException^ Error) // No stored credentials, so none to delete
00234       {
00235         DebugPrintSc4(rootPage, Error->ToString());
00236       }
00237     }
00238
00239   }
00240   catch (Exception^ Error) // No stored credentials, so none to delete
00241   {
00242       DebugPrintSc4(rootPage, Error->ToString());
00243     }
00244
00245   ResetSc4(rootPage);
00246   CleanComboboxSc4(rootPage);
00247     CheckBox^ AuthenticationFailCheck = (CheckBox ^) outputFrame->FindName("AuthenticationFailCheck");
00248   AuthenticationFailCheck->IsChecked = false;
00249     TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
00250     WelcomeMessage->Text = "User has been changed, please resign in with new credentials, choose save and launch scenario again";
00251
00252 }
00253
00254
00255 void SDKSample::PasswordVaultCPP::Scenario4::Reset_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00256 {
00257   ResetSc4(rootPage);
00258   CleanComboboxSc4(this->rootPage);
00259 }
00260
00261
00262 void SDKSample::PasswordVaultCPP::Scenario4::SelectResource_Click(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00263 {
00264   Page^ outputFrame = (Page^) rootPage;
00265   Page^ inputFrame = (Page^) rootPage;
00266
00267   TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
00268   TextBox^ InputResourceValue = (TextBox^) outputFrame->FindName("InputResourceValue");
00269   PasswordBox^ InputPasswordValue = (PasswordBox^) outputFrame->FindName("InputPasswordValue");
00270   ComboBox^ SelectUser = (ComboBox^) inputFrame->FindName("SelectUser");
00271   ComboBox^ SelectResource = (ComboBox^) inputFrame->FindName("SelectResource");
00272   InputPasswordValue->Password = "";
00273   try
00274     {
00275     if ((SelectUser->SelectedIndex > 1) && SelectResource->SelectedIndex > 1)
00276     {
00277       InputUserNameValue->Text = SelectUser->SelectedItem->ToString();
00278       InputResourceValue->Text = SelectResource->SelectedItem->ToString();
00279
00280       Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00281       PasswordCredential^ cred = vault->Retrieve((String^)SelectResource->SelectedItem, (String^)SelectUser->SelectedItem);
00282       if(cred->Password != "")
00283       {
00284         InputPasswordValue->Password = cred->Password;
00285       }
00286     }
00287   }
00288   catch (Platform::COMException^ Error) // No stored credentials, so none to delete
00289   {
00290     DebugPrintSc4(rootPage, Error->ToString());
00291     }
00292
00293 }
00294
00295 void SDKSample::PasswordVaultCPP::Scenario4::SelectUser_Click(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00296 {
00297   Page^ outputFrame = (Page^) rootPage;
00298   Page^ inputFrame = (Page^) rootPage;
00299
00300   TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
00301   PasswordBox^ InputPasswordValue = (PasswordBox^) outputFrame->FindName("InputPasswordValue");
00302   ComboBox^ SelectUser = (ComboBox^) inputFrame->FindName("SelectUser");
00303   ComboBox^ SelectResource = (ComboBox^) inputFrame->FindName("SelectResource");
00304
00305   InputPasswordValue->Password = "";
00306
00307   try
00308     {
00309     if ((SelectUser->SelectedIndex > 1) && SelectResource->SelectedIndex > 1)
00310     {
00311       InputUserNameValue->Text = SelectUser->SelectedItem->ToString();
00312       InputResourceValue->Text = SelectResource->SelectedItem->ToString();
00313       Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00314       PasswordCredential^ cred = vault->Retrieve((String^) SelectResource->SelectedItem, (String^)SelectUser->SelectedItem);
00315       if(cred->Password != "")
00316       {
00317         InputPasswordValue->Password = cred->Password;
00318       }
00319     }
00320   }
00321   catch (Platform::COMException^ Error) // No stored credentials, so none to delete
00322   {
00323     DebugPrintSc4(rootPage, Error->ToString());
00324     }
00325 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/App.xaml.h Source File

  • OrientationSensor

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/Constants.h Source File

  • Scaling according to DPI

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Scaling C++ sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042     private:
00043         static Platform::Array<Scenario>^ scenariosInner;
00044     };
00045 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DirectXApp.cpp Source File

  • Direct3D resource loading

DirectXApp.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXApp.h"
00010 #include "BasicTimer.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Storage;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Foundation::Collections;
00020 using namespace Windows::Graphics::Display;
00021
00022 DirectXApp::DirectXApp() :
00023     m_windowClosed(false),
00024     m_windowVisible(true)
00025 {
00026 }
00027
00028 void DirectXApp::Initialize(
00029     _In_ CoreApplicationView^ applicationView
00030     )
00031 {
00032     applicationView->Activated +=
00033         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DirectXApp::OnActivated);
00034
00035     CoreApplication::Suspending +=
00036         ref new EventHandler<SuspendingEventArgs^>(this, &DirectXApp::OnSuspending);
00037
00038     CoreApplication::Resuming +=
00039         ref new EventHandler<Platform::Object^>(this, &DirectXApp::OnResuming);
00040
00041     m_renderer = ref new ResourceLoading();
00042 }
00043
00044 void DirectXApp::SetWindow(
00045     _In_ CoreWindow^ window
00046     )
00047 {
00048     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00049
00050     window->SizeChanged +=
00051         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DirectXApp::OnWindowSizeChanged);
00052
00053     window->VisibilityChanged +=
00054         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &DirectXApp::OnVisibilityChanged);
00055
00056     window->Closed +=
00057         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &DirectXApp::OnWindowClosed);
00058
00059     DisplayProperties::LogicalDpiChanged +=
00060         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnLogicalDpiChanged);
00061
00062     m_renderer->Initialize(window, DisplayProperties::LogicalDpi);
00063 }
00064
00065 void DirectXApp::Load(
00066     _In_ Platform::String^ entryPoint
00067     )
00068 {
00069     m_renderer->LoadInternalState(ApplicationData::Current->LocalSettings->Values);
00070 }
00071
00072 void DirectXApp::Run()
00073 {
00074     BasicTimer^ timer = ref new BasicTimer();
00075
00076     while (!m_windowClosed)
00077     {
00078         if (m_windowVisible)
00079         {
00080             timer->Update();
00081             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00082             m_renderer->Update(timer->Total, timer->Delta);
00083             m_renderer->Render();
00084             m_renderer->Present(); // This call is synchronized to the display frame rate.
00085         }
00086         else
00087         {
00088             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00089         }
00090     }
00091 }
00092
00093 void DirectXApp::Uninitialize()
00094 {
00095 }
00096
00097 void DirectXApp::OnWindowSizeChanged(
00098     _In_ CoreWindow^ sender,
00099     _In_ WindowSizeChangedEventArgs^ args
00100     )
00101 {
00102     m_renderer->UpdateForWindowSizeChange();
00103 }
00104
00105 void DirectXApp::OnVisibilityChanged(
00106     _In_ CoreWindow^ sender,
00107     _In_ VisibilityChangedEventArgs^ args
00108     )
00109 {
00110     m_windowVisible = args->Visible;
00111 }
00112
00113 void DirectXApp::OnWindowClosed(
00114     _In_ CoreWindow^ sender,
00115     _In_ CoreWindowEventArgs^ args
00116     )
00117 {
00118     m_windowClosed = true;
00119 }
00120
00121 void DirectXApp::OnLogicalDpiChanged(
00122     _In_ Platform::Object^ sender
00123     )
00124 {
00125     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00126 }
00127
00128 void DirectXApp::OnActivated(
00129     _In_ CoreApplicationView^ applicationView,
00130     _In_ IActivatedEventArgs^ args
00131     )
00132 {
00133     CoreWindow::GetForCurrentThread()->Activate();
00134 }
00135
00136 void DirectXApp::OnSuspending(
00137     _In_ Platform::Object^ sender,
00138     _In_ SuspendingEventArgs^ args
00139     )
00140 {
00141     IPropertySet^ appState = ApplicationData::Current->LocalSettings->Values;
00142     m_renderer->SaveInternalState(appState);
00143 }
00144
00145 void DirectXApp::OnResuming(
00146     _In_ Platform::Object^ sender,
00147     _In_ Platform::Object^ args
00148     )
00149 {
00150 }
00151
00152 IFrameworkView^ DirectXAppSource::CreateView()
00153 {
00154     return ref new DirectXApp();
00155 }
00156
00157 [Platform::MTAThread]
00158 int main(Platform::Array<Platform::String^>^)
00159 {
00160     auto directXAppSource = ref new DirectXAppSource();
00161     CoreApplication::Run(directXAppSource);
00162     return 0;
00163 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level2.h Source File

  • DirectX 3D shooting game

Level2.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Level2:
00011 // This class defines the second level of the game.  It derives from the
00012 // first level.  In this level the targets must be hit in numeric order.
00013
00014 #include "Level1.h"
00015
00016 ref class Level2: public Level1
00017 {
00018 internal:
00019     Level2();
00020     virtual void Initialize(std::vector<GameObject^> objects) override;
00021
00022     virtual bool Update(
00023         float time,
00024         float elapsedTime,
00025         float timeRemaining,
00026         std::vector<GameObject^> objects
00027         ) override;
00028
00029     virtual void SaveState(PersistentState^ state) override;
00030     virtual void LoadState(PersistentState^ state) override;
00031
00032 private:
00033     int m_nextId;
00034 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageUtilities.cpp Source File

  • Hilo C++
  • Hilo

ImageUtilities.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "ImageUtilities.h"
00009
00010 #include <robuffer.h>
00011 #include <wrl.h>
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Platform;
00015 using namespace Windows::Storage::Streams;
00016
00017 inline void ThrowIfFailed(HRESULT hr)
00018 {
00019     if (FAILED(hr))
00020     {
00021         throw Exception::CreateException(hr);
00022     }
00023 }
00024
00025 // Retrieves the raw pixel data from the provided IBuffer object.
00026 byte* GetPointerToPixelData(IBuffer^ buffer)
00027 {
00028     // Cast to Object^, then to its underlying IInspectable interface.
00029     Object^ obj = buffer;
00030     ComPtr<IInspectable> insp(reinterpret_cast<IInspectable*>(obj));
00031
00032     // Query the IBufferByteAccess interface.
00033     ComPtr<IBufferByteAccess> bufferByteAccess;
00034     ThrowIfFailed(insp.As(&bufferByteAccess));
00035
00036     // Retrieve the buffer data.
00037     byte* pixels = nullptr;
00038     ThrowIfFailed(bufferByteAccess->Buffer(&pixels));
00039     return pixels;
00040 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/Receipt.xaml.h Source File

  • Trial app and in-app purchase

Receipt.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Receipt.xaml.h
00013 // Declaration of the Receipt class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Receipt.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace StoreSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Receipt sealed
00030         {
00031         public:
00032             Receipt();
00033
00034         protected:
00035             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036             virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             Windows::Foundation::EventRegistrationToken eventRegistrationToken;
00040
00041             void LoadReceiptProxyFile();
00042             void ReceiptRefreshScenario();
00043
00044             void ShowReceipt_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045         };
00046     }
00047 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/App.xaml.cpp Source File

  • Input Device capabilities

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/Constants.h Source File

  • Bluetooth call control

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME {
00027             Platform::String^ get() {  return ref new Platform::String(L"Call Control"); }
00028         }
00029
00030         static property Platform::Array<Scenario>^ scenarios {
00031             Platform::Array<Scenario>^ get()
00032             {
00033                 return scenariosInner;
00034             }
00035         }
00036     private:
00037         static Platform::Array<Scenario>^ scenariosInner;
00038     };
00039
00040
00041 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/SphereMesh.h Source File

  • XAML DirectX 3D shooting game

SphereMesh.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // SphereMesh:
00011 // This class derives from MeshObject and creates a ID3D11Buffer of
00012 // vertices and indices to represent a canonical sphere that is
00013 // positioned at the origin with a radius of 1.0.
00014
00015 #include "MeshObject.h"
00016
00017 ref class SphereMesh: public MeshObject
00018 {
00019 internal:
00020     SphereMesh(_In_ ID3D11Device *device, uint32 segments);
00021 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/common/suspensionmanager.cpp Source File

  • Sharing content source app
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperRenderer.h Source File

  • DirectX postcard app

PaperRenderer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "PaperFragment.h"
00011
00012 enum class PaperMode
00013 {
00014     Moving,
00015     Stamping,
00016     Deleting
00017 };
00018
00019 ref class PaperRenderer
00020 {
00021 internal:
00022     PaperRenderer();
00023
00024     void CreateDeviceIndependentResources(Microsoft::WRL::ComPtr<ID2D1Factory1> d2dFactory);
00025     void CreateDeviceResources(Microsoft::WRL::ComPtr<ID2D1DeviceContext> d2dContext);
00026     void CreateWindowSizeDependentResources(float dpi);
00027
00028     void DrawPaper();
00029
00030     void AddPaper();
00031     void RemovePaper();
00032     void MovePaper();
00033     void StampPaper();
00034     void Reset();
00035
00036     void OnManipulationStarted(Windows::UI::Xaml::Input::ManipulationStartedRoutedEventArgs^ args);
00037     void OnManipulationCompleted(Windows::UI::Xaml::Input::ManipulationCompletedRoutedEventArgs^ args);
00038     void OnManipulationDelta(Windows::UI::Xaml::Input::ManipulationDeltaRoutedEventArgs^ args);
00039     void OnTapped(Windows::Foundation::Point position);
00040
00041 private:
00042     PaperFragment^ HitTestFragmentsWithPosition(D2D1_POINT_2F position);
00043     float RandomFloat();
00044
00045     // Resources shared with PostcardRenderer.
00046     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00047     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00048     float                                           m_dpi;
00049
00050     // Resources specific to this renderer.
00051     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_blackBrush;
00052     Microsoft::WRL::ComPtr<ID2D1Geometry>           m_starStampGeometry;
00053     std::list<PaperFragment^>                       m_paperFragmentList;
00054     PaperFragment^                                  m_selectedFragment;
00055     PaperMode                                       m_paperMode;
00056 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Animation< T > Member List

This is the complete list of members for Animation< T >, including all inherited members.
Animation(T start, T end, T duration) | Animation< T > | [inline]
ComputeValue(T time)=0 | Animation< T > | [protected, pure virtual]
GetDuration() | Animation< T > | [inline]
GetEnd() | Animation< T > | [inline]
GetStart() | Animation< T > | [inline]
GetValue(T time) | Animation< T > | [inline]
m_Duration | Animation< T > | [protected]
m_End | Animation< T > | [protected]
m_Start | Animation< T > | [protected]
SetDuration(T duration) | Animation< T > | [inline]
SetEnd(T end) | Animation< T > | [inline]
SetStart(T start) | Animation< T > | [inline]
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/App.xaml.h Source File

  • Media capture using capture device

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/common/LayoutAwarePage.h Source File

  • Custom driver access
  • app_cpp
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/pch.cpp Source File

  • Snap

pch.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // pch.cpp
00010 // Include the standard header and generate the precompiled header.
00011 //
00012
00013 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicMath.h Source File

  • Direct3D bump mapping

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/CaptureVideo.xaml.h Source File

  • CameraCaptureUI

CaptureVideo.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CaptureVideo.xaml.h
00013 // Declaration of the CaptureVideo class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "CaptureVideo.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace CameraCapture
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class CaptureVideo sealed
00031         {
00032         public:
00033             CaptureVideo();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void CaptureVideo_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Reset_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041             void LoadVideo(Platform::String^ filePath);
00042
00043             Windows::Foundation::Collections::IPropertySet^ appSettings;
00044         };
00045     }
00046 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/DecimalFormatting.xaml.h Source File

  • Number formatting and parsing

DecimalFormatting.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DecimalFormatting.xaml.h
00013 // Declaration of the DecimalFormatting class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "DecimalFormatting.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace NumberFormatting
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class DecimalFormatting sealed
00031         {
00032         public:
00033             DecimalFormatting();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S4_Autoplay.xaml.cpp Source File

  • Removable storage

S4_Autoplay.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // S4_Autoplay.xaml.cpp
00013 // Implementation of the S4_Autoplay class
00014 //
00015
00016 #include "pch.h"
00017 #include "S4_Autoplay.xaml.h"
00018
00019 using namespace SDKSample::RemovableStorageCPP;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Platform::Collections;
00024 using namespace Windows::Devices::Portable;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Windows::Globalization::DateTimeFormatting;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::FileProperties;
00029 using namespace Windows::Storage::Search;
00030 using namespace Windows::Storage::Streams;
00031 using namespace Windows::UI::Core;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Media::Imaging;
00035 using namespace Windows::UI::Xaml::Navigation;
00036
00037 S4_Autoplay::S4_Autoplay() : rootPage(MainPage::Current)
00038 {
00039     InitializeComponent();
00040 }
00041
00042 /// <summary>
00043 /// Invoked when this page is about to be displayed in a Frame.
00044 /// </summary>
00045 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00046 /// property is typically used to configure the page.</param>
00047 void S4_Autoplay::OnNavigatedTo(NavigationEventArgs^ e)
00048 {
00049     // Enable the button only when launched from Autoplay or File Activation
00050     ScenarioInput->IsEnabled = (rootPage->AutoplayFileSystemDeviceFolder != nullptr ||
00051                                 rootPage->AutoplayNonFileSystemDeviceId  != nullptr ||
00052                                 rootPage->FileActivationFiles            != nullptr);
00053
00054 }
00055
00056 /// <summary>
00057 /// This is the click handler for the 'Get Image' button.
00058 /// If launched by Autoplay, this will find and display the first image file on the storage.
00059 /// If launched by file activation, this will display the first image file from the activation file list.
00060 /// </summary>
00061 /// <param name="sender"></param>
00062 /// <param name="e"></param>
00063 void S4_Autoplay::GetImage_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00064 {
00065     if (rootPage->FileActivationFiles != nullptr)
00066     {
00067         if (rootPage->FileActivationFiles->Size > 0)
00068         {
00069             // Because this sample only supports image file types in its manifest,
00070             // we can know that all files in the array of files will be image files.
00071             rootPage->NotifyUser("[File Activation] Displaying first image file ...", NotifyType::StatusMessage);
00072             auto imageFile = safe_cast<StorageFile^>(rootPage->FileActivationFiles->GetAt(0));
00073             DisplayImageAsync(imageFile);
00074         }
00075         else
00076         {
00077             rootPage->NotifyUser("[File Activation] File activation occurred but 0 files were received", NotifyType::ErrorMessage);
00078         }
00079     }
00080     else
00081     {
00082         if (rootPage->AutoplayFileSystemDeviceFolder != nullptr)
00083         {
00084             GetFirstImageFromStorageAsync(rootPage->AutoplayFileSystemDeviceFolder);
00085         }
00086         else
00087         {
00088             auto storage = StorageDevice::FromId(rootPage->AutoplayNonFileSystemDeviceId);
00089             GetFirstImageFromStorageAsync(storage);
00090         }
00091     }
00092 }
00093
00094 /// <summary>
00095 /// Finds and displays the first image file on the storage.
00096 /// </summary>
00097 /// <param name="storage"></param>
00098 void S4_Autoplay::GetFirstImageFromStorageAsync(StorageFolder^ storage)
00099 {
00100     auto storageName = storage->Name;
00101
00102     // Construct the query for image files
00103     auto filter = ref new Vector<String^>();
00104     filter->Append(".jpg");
00105     filter->Append(".png");
00106     filter->Append(".gif");
00107     auto queryOptions = ref new QueryOptions(CommonFileQuery::OrderByName, filter);
00108     auto imageFileQuery = storage->CreateFileQueryWithOptions(queryOptions);
00109
00110     // Run the query for image files
00111     rootPage->NotifyUser("[Launched by Autoplay] Looking for images on " + storageName + " ...", NotifyType::StatusMessage);
00112     create_task(imageFileQuery->GetFilesAsync()).then([this, storageName] (IVectorView<StorageFile^>^ imageFiles)
00113     {
00114         if (imageFiles->Size > 0)
00115         {
00116             auto imageFile = imageFiles->GetAt(0);
00117             rootPage->NotifyUser("[Launched by Autoplay] Found " + imageFile->Name + " on " + storageName, NotifyType::StatusMessage);
00118             DisplayImageAsync(imageFile);
00119         }
00120         else
00121         {
00122             rootPage->NotifyUser("[Launched by Autoplay] No images were found on " + storageName + ". You can use scenario 2 to transfer an image to it", NotifyType::StatusMessage);
00123         }
00124     });
00125 }
00126
00127 /// <summary>
00128 /// Displays an image file in the 'ScenarioOutputImage' element.
00129 /// </summary>
00130 /// <param name="imageFile">The image file to display.</param>
00131 void S4_Autoplay::DisplayImageAsync(Windows::Storage::StorageFile^ imageFile)
00132 {
00133     create_task(imageFile->GetBasicPropertiesAsync()).then([this, imageFile] (BasicProperties^ imageProperties)
00134     {
00135         if (imageProperties->Size > 0)
00136         {
00137             auto dateFormatter = ref new DateTimeFormatter("longdate");
00138             auto timeFormatter = ref new DateTimeFormatter("longtime");
00139             rootPage->NotifyUser("Displaying: " + imageFile->Name + ", date modified: " +
00140                 dateFormatter->Format(imageProperties->DateModified) + " " +
00141                 timeFormatter->Format(imageProperties->DateModified) + ", size: " +
00142                 imageProperties->Size + " bytes", NotifyType::StatusMessage);
00143
00144             // Note: The following task is nested instead of chained from the previous task because it runs only when the image size is > 0.
00145             create_task(imageFile->OpenAsync(FileAccessMode::Read)).then([this] (IRandomAccessStream^ stream)
00146             {
00147                 // BitmapImage.SetSource needs to be called in the UI thread
00148                 Dispatcher->RunAsync(
00149                     CoreDispatcherPriority::Normal,
00150                     ref new DispatchedHandler(
00151                         [this, stream]()
00152                         {
00153                             auto bitmap = ref new BitmapImage();
00154                             bitmap->SetSource(stream);
00155                             ScenarioOutputImage->SetValue(Image::SourceProperty, bitmap);
00156                         },
00157                         CallbackContext::Any
00158                     )
00159                 );
00160             });
00161         }
00162         else
00163         {
00164             rootPage->NotifyUser("Cannot display " + imageFile->Name + " because its size is 0", NotifyType::ErrorMessage);
00165         }
00166     });
00167 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaStreamSource::PcmSource Member List

This is the complete list of members for MediaStreamSource::PcmSource, including all inherited members.
_pSample | MediaStreamSource::PcmSource | [private]
BitsPerSample | MediaStreamSource::PcmSource | [private]
Channels | MediaStreamSource::PcmSource | [private]
CloseMedia() | MediaStreamSource::PcmSource | [inline]
CreateSample() | MediaStreamSource::PcmSource | [inline, private]
Frequency | MediaStreamSource::PcmSource |
GetDiagnosticAsync(MediaStreamSourceDiagnosticKind diagnosticKind) | MediaStreamSource::PcmSource | [inline]
GetSampleAsync(MediaStreamType mediaStreamType) | MediaStreamSource::PcmSource | [inline]
nextTimestamp | MediaStreamSource::PcmSource | [private]
OpenMediaAsync() | MediaStreamSource::PcmSource | [inline]
PcmSource() | MediaStreamSource::PcmSource | [inline]
SampleDuration | MediaStreamSource::PcmSource | [private]
SampleRate | MediaStreamSource::PcmSource | [private]
SeekAsync(long seekToTime) | MediaStreamSource::PcmSource | [inline]
SwitchMediaStreamAsync(MediaStreamDescription mediaStreamDescription) | MediaStreamSource::PcmSource | [inline]
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/pch.cpp Source File

  • Direct3D-Direct2D interop

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/pch.h Source File

  • Push and periodic notifications client-side

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/MainPage.xaml.cpp Source File

  • Direct2D magazine app

MainPage.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Magazine;
00011 using namespace concurrency;
00012 using namespace Windows::Foundation;
00013 using namespace Windows::Foundation::Collections;
00014 using namespace Windows::ApplicationModel;
00015 using namespace Windows::UI::Xaml;
00016 using namespace Windows::UI::Xaml::Controls;
00017 using namespace Windows::UI::Xaml::Controls::Primitives;
00018 using namespace Windows::UI::Xaml::Data;
00019 using namespace Windows::UI::Xaml::Input;
00020 using namespace Windows::UI::Xaml::Media;
00021 using namespace Windows::UI::Xaml::Navigation;
00022 using namespace Windows::UI::Xaml::Interop;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::Search;
00025 using namespace Windows::Graphics::Display;
00026
00027 MainPage::MainPage() :
00028     m_document(nullptr)
00029 {
00030     InitializeComponent();
00031
00032     // Initialize DirectX renderer
00033     auto renderer = ref new Renderer(
00034         Window::Current->Bounds,
00035         DisplayProperties::LogicalDpi
00036         );
00037
00038     // Start loading the document content
00039     auto document = ref new Document(Package::Current->InstalledLocation, "sample.story", renderer);
00040     task<void>(document->LoadAsync()).then([=]()
00041     {
00042         DocumentLoaded(document);
00043
00044     }, task_continuation_context::use_current());
00045
00046     renderer->DeviceLost += ref new DeviceLostEventHandler(this, &MainPage::OnDeviceLost);
00047
00048     Window::Current->SizeChanged +=
00049         ref new WindowSizeChangedEventHandler(this, &MainPage::OnWindowSizeChanged);
00050 }
00051
00052 void MainPage::LoadState(_In_ IPropertySet^ localSettings)
00053 {
00054     if (localSettings->HasKey("Document.Page"))
00055     {
00056         int page = safe_cast<IPropertyValue^>(localSettings->Lookup("Document.Page"))->GetInt32();
00057
00058         FlipView->SelectedIndex = page;
00059     }
00060 }
00061
00062 void MainPage::SaveState(_In_ IPropertySet^ localSettings)
00063 {
00064     if (localSettings->HasKey("Document.Page"))
00065     {
00066         localSettings->Remove("Document.Page");
00067     }
00068
00069     localSettings->Insert(
00070         "Document.Page",
00071         PropertyValue::CreateInt32(FlipView->SelectedIndex)
00072         );
00073 }
00074
00075 void MainPage::DocumentLoaded(_In_ Document^ document)
00076 {
00077     // Parse the document into an element tree.
00078     document->Parse();
00079
00080     auto contentRoot = document->GetContentRoot();
00081
00082     if (contentRoot != nullptr)
00083     {
00084         // Create a collection of content element to bind to the view
00085         auto items = ref new Platform::Collections::Vector<Platform::Object^>();
00086
00087         auto pageContent = contentRoot->GetFirstChild();
00088
00089         while (pageContent != nullptr)
00090         {
00091             items->Append(ref new PageModel(pageContent, document));
00092
00093             pageContent = pageContent->GetNextSibling();
00094         }
00095
00096         FlipView->ItemsSource = items;
00097
00098         // Load the saved document state if any
00099         LoadState(ApplicationData::Current->LocalSettings->Values);
00100
00101         m_document = document;
00102     }
00103 }
00104
00105 void MainPage::OnDeviceLost()
00106 {
00107     // Save the application state and reload the document so that all elements will
00108     // be recreated with the new device.
00109
00110     SaveState(ApplicationData::Current->LocalSettings->Values);
00111
00112     DocumentLoaded(m_document);
00113 }
00114
00115 void MainPage::OnWindowSizeChanged(
00116     _In_ Platform::Object^ sender,
00117     _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00118     )
00119 {
00120     if (m_document != nullptr)
00121     {
00122         // Update renderer with the new window size
00123         auto renderer = m_document->GetRenderer();
00124         renderer->UpdateWindowSize();
00125
00126         // Window size change could mean changing display orientation. When this happens the display
00127         // content may change to suit the new display layout. We need to update the page model with
00128         // all the new content.
00129         auto contentRoot = m_document->GetContentRoot();
00130         auto pageContent = contentRoot->GetFirstChild();
00131
00132         auto currentItems = dynamic_cast<Platform::Collections::Vector<Platform::Object^>^>(FlipView->ItemsSource);
00133
00134         for (uint32 i = 0; i != currentItems->Size && pageContent != nullptr; ++i)
00135         {
00136             // Refresh the current item with the new page content
00137             PageModel^ pageModel = dynamic_cast<PageModel^>(currentItems->GetAt(i));
00138             pageModel->UpdateContent(pageContent);
00139
00140             pageContent = pageContent->GetNextSibling();
00141         }
00142     }
00143 }
Generated on Sat Nov 23 2024 16:07:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.cpp Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source

MPEG1Src.cpp

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // CMPEG1Source.h
00004 // Implements the MPEG-1 media source object.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015
00016 #include "MPEG1Src.h"
00017
00018 //-------------------------------------------------------------------
00019 //
00020 // Notes:
00021 // This sample contains an MPEG-1 source.
00022 //
00023 // - The source parses MPEG-1 systems-layer streams and generates
00024 //   samples that contain MPEG-1 payloads.
00025 // - The source does not support files that contain a raw MPEG-1
00026 //   video or audio stream.
00027 // - The source does not support seeking.
00028 //
00029 //-------------------------------------------------------------------
00030
00031 #pragma warning( push )
00032 #pragma warning( disable : 4355 )  // 'this' used in base member initializer list
00033
00034 HRESULT CreateVideoMediaType(const MPEG1VideoSeqHeader& videoSeqHdr, IMFMediaType **ppType);
00035 HRESULT CreateAudioMediaType(const MPEG1AudioFrameHeader& audioHeader, IMFMediaType **ppType);
00036 HRESULT GetStreamMajorType(IMFStreamDescriptor *pSD, GUID *pguidMajorType);
00037 BOOL    SampleRequestMatch(SourceOp *pOp1, SourceOp *pOp2);
00038
00039
00040 /* Public class methods */
00041
00042 //-------------------------------------------------------------------
00043 // Name: CreateInstance
00044 // Static method to create an instance of the source.
00045 //
00046 // ppSource:    Receives a ref-counted pointer to the source.
00047 //-------------------------------------------------------------------
00048
00049 HRESULT CMPEG1Source::CreateInstance(CMPEG1Source **ppSource)
00050 {
00051     if (ppSource == NULL)
00052     {
00053         return E_POINTER;
00054     }
00055
00056     HRESULT hr = S_OK;
00057     CMPEG1Source *pSource = new (std::nothrow) CMPEG1Source(hr);
00058     if (pSource == NULL)
00059     {
00060         return E_OUTOFMEMORY;
00061     }
00062
00063     if (SUCCEEDED(hr))
00064     {
00065         *ppSource = pSource;
00066         (*ppSource)->AddRef();
00067     }
00068
00069     SafeRelease(&pSource);
00070     return hr;
00071 }
00072
00073
00074 //-------------------------------------------------------------------
00075 // IUnknown methods
00076 //-------------------------------------------------------------------
00077
00078 HRESULT CMPEG1Source::QueryInterface(REFIID riid, void** ppv)
00079 {
00080     if (ppv == nullptr)
00081     {
00082         return E_POINTER;
00083     }
00084
00085     HRESULT hr = E_NOINTERFACE;
00086     if (riid == IID_IUnknown ||
00087         riid == IID_IMFMediaEventGenerator ||
00088         riid == IID_IMFMediaSource)
00089     {
00090         (*ppv) = static_cast<IMFMediaSource *>(this);
00091         AddRef();
00092         hr = S_OK;
00093     }
00094     else if (riid == IID_IMFGetService)
00095     {
00096         (*ppv) = static_cast<IMFGetService*>(this);
00097         AddRef();
00098         hr = S_OK;
00099     }
00100     else if (riid == IID_IMFRateControl)
00101     {
00102         (*ppv) = static_cast<IMFRateControl*>(this);
00103         AddRef();
00104         hr = S_OK;
00105     }
00106
00107     return hr;
00108 }
00109
00110 ULONG CMPEG1Source::AddRef()
00111 {
00112     return _InterlockedIncrement(&m_cRef);
00113 }
00114
00115 ULONG CMPEG1Source::Release()
00116 {
00117     LONG cRef = _InterlockedDecrement(&m_cRef);
00118     if (cRef == 0)
00119     {
00120         delete this;
00121     }
00122     return cRef;
00123 }
00124
00125 //-------------------------------------------------------------------
00126 // IMFMediaEventGenerator methods
00127 //
00128 // All of the IMFMediaEventGenerator methods do the following:
00129 // 1. Check for shutdown status.
00130 // 2. Call the event queue helper object.
00131 //-------------------------------------------------------------------
00132
00133 HRESULT CMPEG1Source::BeginGetEvent(IMFAsyncCallback* pCallback,IUnknown* punkState)
00134 {
00135     HRESULT hr = S_OK;
00136
00137     EnterCriticalSection(&m_critSec);
00138
00139     hr = CheckShutdown();
00140
00141     if (SUCCEEDED(hr))
00142     {
00143         hr = m_pEventQueue->BeginGetEvent(pCallback, punkState);
00144     }
00145
00146     LeaveCriticalSection(&m_critSec);
00147     return hr;
00148 }
00149
00150 HRESULT CMPEG1Source::EndGetEvent(IMFAsyncResult* pResult, IMFMediaEvent** ppEvent)
00151 {
00152     HRESULT hr = S_OK;
00153
00154     EnterCriticalSection(&m_critSec);
00155
00156     hr = CheckShutdown();
00157
00158     if (SUCCEEDED(hr))
00159     {
00160         hr = m_pEventQueue->EndGetEvent(pResult, ppEvent);
00161     }
00162
00163     LeaveCriticalSection(&m_critSec);
00164     return hr;
00165 }
00166
00167 HRESULT CMPEG1Source::GetEvent(DWORD dwFlags, IMFMediaEvent** ppEvent)
00168 {
00169     // NOTE:
00170     // GetEvent can block indefinitely, so we don't hold the critical
00171     // section. Therefore we need to use a local copy of the event queue
00172     // pointer, to make sure the pointer remains valid.
00173
00174     HRESULT hr = S_OK;
00175
00176     IMFMediaEventQueue *pQueue = NULL;
00177
00178     EnterCriticalSection(&m_critSec);
00179
00180     // Check shutdown
00181     hr = CheckShutdown();
00182
00183     // Cache a local pointer to the queue.
00184     if (SUCCEEDED(hr))
00185     {
00186         pQueue = m_pEventQueue;
00187         pQueue->AddRef();
00188     }
00189
00190     LeaveCriticalSection(&m_critSec);
00191
00192     // Use the local pointer to call GetEvent.
00193     if (SUCCEEDED(hr))
00194     {
00195         hr = pQueue->GetEvent(dwFlags, ppEvent);
00196     }
00197
00198     SafeRelease(&pQueue);
00199     return hr;
00200 }
00201
00202 HRESULT CMPEG1Source::QueueEvent(MediaEventType met, REFGUID guidExtendedType, HRESULT hrStatus, const PROPVARIANT* pvValue)
00203 {
00204     HRESULT hr = S_OK;
00205
00206     EnterCriticalSection(&m_critSec);
00207
00208     hr = CheckShutdown();
00209
00210     if (SUCCEEDED(hr))
00211     {
00212         hr = m_pEventQueue->QueueEventParamVar(met, guidExtendedType, hrStatus, pvValue);
00213     }
00214
00215     LeaveCriticalSection(&m_critSec);
00216
00217     return hr;
00218 }
00219
00220 //-------------------------------------------------------------------
00221 // IMFMediaSource methods
00222 //-------------------------------------------------------------------
00223
00224
00225 //-------------------------------------------------------------------
00226 // CreatePresentationDescriptor
00227 // Returns a shallow copy of the source's presentation descriptor.
00228 //-------------------------------------------------------------------
00229
00230 HRESULT CMPEG1Source::CreatePresentationDescriptor(
00231     IMFPresentationDescriptor** ppPresentationDescriptor
00232     )
00233 {
00234     if (ppPresentationDescriptor == NULL)
00235     {
00236         return E_POINTER;
00237     }
00238
00239     HRESULT hr = S_OK;
00240
00241     EnterCriticalSection(&m_critSec);
00242
00243     // Fail if the source is shut down.
00244     hr = CheckShutdown();
00245
00246     // Fail if the source was not initialized yet.
00247     if (SUCCEEDED(hr))
00248     {
00249         hr = IsInitialized();
00250     }
00251
00252     // Do we have a valid presentation descriptor?
00253     if (SUCCEEDED(hr))
00254     {
00255         if (m_pPresentationDescriptor == NULL)
00256         {
00257             hr = MF_E_NOT_INITIALIZED;
00258         }
00259     }
00260
00261     // Clone our presentation descriptor.
00262     if (SUCCEEDED(hr))
00263     {
00264         hr = m_pPresentationDescriptor->Clone(ppPresentationDescriptor);
00265     }
00266
00267     LeaveCriticalSection(&m_critSec);
00268     return hr;
00269 }
00270
00271
00272 //-------------------------------------------------------------------
00273 // GetCharacteristics
00274 // Returns capabilities flags.
00275 //-------------------------------------------------------------------
00276
00277 HRESULT CMPEG1Source::GetCharacteristics(DWORD* pdwCharacteristics)
00278 {
00279     if (pdwCharacteristics == NULL)
00280     {
00281         return E_POINTER;
00282     }
00283
00284     HRESULT hr = S_OK;
00285
00286     EnterCriticalSection(&m_critSec);
00287
00288     hr = CheckShutdown();
00289
00290     if (SUCCEEDED(hr))
00291     {
00292         *pdwCharacteristics =  MFMEDIASOURCE_CAN_PAUSE;
00293     }
00294
00295     // NOTE: This sample does not implement seeking, so we do not
00296     // include the MFMEDIASOURCE_CAN_SEEK flag.
00297
00298     LeaveCriticalSection(&m_critSec);
00299     return hr;
00300 }
00301
00302
00303 //-------------------------------------------------------------------
00304 // Pause
00305 // Pauses the source.
00306 //-------------------------------------------------------------------
00307
00308 HRESULT CMPEG1Source::Pause()
00309 {
00310     EnterCriticalSection(&m_critSec);
00311
00312     HRESULT hr = S_OK;
00313
00314     // Fail if the source is shut down.
00315     hr = CheckShutdown();
00316
00317     // Queue the operation.
00318     if (SUCCEEDED(hr))
00319     {
00320         hr = QueueAsyncOperation(SourceOp::OP_PAUSE);
00321     }
00322
00323     LeaveCriticalSection(&m_critSec);
00324     return hr;
00325 }
00326
00327 //-------------------------------------------------------------------
00328 // Shutdown
00329 // Shuts down the source and releases all resources.
00330 //-------------------------------------------------------------------
00331
00332 HRESULT CMPEG1Source::Shutdown()
00333 {
00334     EnterCriticalSection(&m_critSec);
00335
00336     HRESULT hr = S_OK;
00337
00338     CMPEG1Stream *pStream = NULL;
00339
00340     hr = CheckShutdown();
00341
00342     if (SUCCEEDED(hr))
00343     {
00344         // Shut down the stream objects.
00345
00346         for (DWORD i = 0; i < m_streams.GetCount(); i++)
00347         {
00348             (void)m_streams[i]->Shutdown();
00349         }
00350
00351         // Shut down the event queue.
00352         if (m_pEventQueue)
00353         {
00354             (void)m_pEventQueue->Shutdown();
00355         }
00356
00357         // Release objects.
00358
00359         SafeRelease(&m_pEventQueue);
00360         SafeRelease(&m_pPresentationDescriptor);
00361         SafeRelease(&m_pBeginOpenResult);
00362         SafeRelease(&m_pByteStream);
00363         SafeRelease(&m_pCurrentOp);
00364
00365         CoTaskMemFree(m_pHeader);
00366         m_pHeader = NULL;
00367
00368         delete m_pParser;
00369         m_pParser = NULL;
00370
00371         // Set the state.
00372         m_state = STATE_SHUTDOWN;
00373     }
00374
00375     LeaveCriticalSection(&m_critSec);
00376     return hr;
00377 }
00378
00379
00380 //-------------------------------------------------------------------
00381 // Start
00382 // Starts or seeks the media source.
00383 //-------------------------------------------------------------------
00384
00385 HRESULT CMPEG1Source::Start(
00386         IMFPresentationDescriptor* pPresentationDescriptor,
00387         const GUID* pguidTimeFormat,
00388         const PROPVARIANT* pvarStartPos
00389     )
00390 {
00391
00392     HRESULT hr = S_OK;
00393     SourceOp *pAsyncOp = NULL;
00394
00395     // Check parameters.
00396
00397     // Start position and presentation descriptor cannot be NULL.
00398     if (pvarStartPos == NULL || pPresentationDescriptor == NULL)
00399     {
00400         return E_INVALIDARG;
00401     }
00402
00403     // Check the time format.
00404     if ((pguidTimeFormat != NULL) && (*pguidTimeFormat != GUID_NULL))
00405     {
00406         // Unrecognized time format GUID.
00407         return MF_E_UNSUPPORTED_TIME_FORMAT;
00408     }
00409
00410     // Check the data type of the start position.
00411     if ((pvarStartPos->vt != VT_I8) && (pvarStartPos->vt != VT_EMPTY))
00412     {
00413         return MF_E_UNSUPPORTED_TIME_FORMAT;
00414     }
00415
00416     EnterCriticalSection(&m_critSec);
00417
00418     // Check if this is a seek request. This sample does not support seeking.
00419
00420     if (pvarStartPos->vt == VT_I8)
00421     {
00422         // If the current state is STOPPED, then position 0 is valid.
00423         // Otherwise, the start position must be VT_EMPTY (current position).
00424
00425         if ((m_state != STATE_STOPPED) || (pvarStartPos->hVal.QuadPart != 0))
00426         {
00427             hr = MF_E_INVALIDREQUEST;
00428             goto done;
00429         }
00430     }
00431
00432     // Fail if the source is shut down.
00433     hr = CheckShutdown();
00434     if (FAILED(hr))
00435     {
00436         goto done;
00437     }
00438
00439     // Fail if the source was not initialized yet.
00440     hr = IsInitialized();
00441     if (FAILED(hr))
00442     {
00443         goto done;
00444     }
00445
00446     // Perform a sanity check on the caller's presentation descriptor.
00447     hr = ValidatePresentationDescriptor(pPresentationDescriptor);
00448     if (FAILED(hr))
00449     {
00450         goto done;
00451     }
00452
00453     // The operation looks OK. Complete the operation asynchronously.
00454
00455     hr = SourceOp::CreateStartOp(pPresentationDescriptor, &pAsyncOp);
00456     if (FAILED(hr))
00457     {
00458         goto done;
00459     }
00460
00461     hr = pAsyncOp->SetData(*pvarStartPos);
00462     if (FAILED(hr))
00463     {
00464         goto done;
00465     }
00466
00467     hr = QueueOperation(pAsyncOp);
00468
00469 done:
00470     SafeRelease(&pAsyncOp);
00471     LeaveCriticalSection(&m_critSec);
00472     return hr;
00473 }
00474
00475
00476 //-------------------------------------------------------------------
00477 // Stop
00478 // Stops the media source.
00479 //-------------------------------------------------------------------
00480
00481 HRESULT CMPEG1Source::Stop()
00482 {
00483     EnterCriticalSection(&m_critSec);
00484
00485     HRESULT hr = S_OK;
00486
00487     // Fail if the source is shut down.
00488     hr = CheckShutdown();
00489
00490     // Fail if the source was not initialized yet.
00491     if (SUCCEEDED(hr))
00492     {
00493         hr = IsInitialized();
00494     }
00495
00496     // Queue the operation.
00497     if (SUCCEEDED(hr))
00498     {
00499         hr = QueueAsyncOperation(SourceOp::OP_STOP);
00500     }
00501
00502     LeaveCriticalSection(&m_critSec);
00503     return hr;
00504 }
00505
00506 //-------------------------------------------------------------------
00507 // IMFMediaSource methods
00508 //-------------------------------------------------------------------
00509
00510 //-------------------------------------------------------------------
00511 // GetService
00512 // Returns a service
00513 //-------------------------------------------------------------------
00514
00515 HRESULT CMPEG1Source::GetService( _In_ REFGUID guidService, _In_ REFIID riid, _Out_opt_ LPVOID *ppvObject)
00516 {
00517     HRESULT hr = MF_E_UNSUPPORTED_SERVICE;
00518
00519     if (ppvObject == nullptr)
00520     {
00521         return E_POINTER;
00522     }
00523
00524     if (guidService == MF_RATE_CONTROL_SERVICE)
00525     {
00526         hr = QueryInterface(riid, ppvObject);
00527     }
00528
00529     return hr;
00530 }
00531
00532 //-------------------------------------------------------------------
00533 // IMFRateControl methods
00534 //-------------------------------------------------------------------
00535
00536 //-------------------------------------------------------------------
00537 // SetRate
00538 // Sets a rate on the source. Only supported rates are 0 and 1.
00539 //-------------------------------------------------------------------
00540
00541 HRESULT CMPEG1Source::SetRate(BOOL fThin, float flRate)
00542 {
00543     if (fThin)
00544     {
00545         return MF_E_THINNING_UNSUPPORTED;
00546     }
00547     if (!IsRateSupported(flRate, &flRate))
00548     {
00549         return MF_E_UNSUPPORTED_RATE;
00550     }
00551
00552     EnterCriticalSection(&m_critSec);
00553     HRESULT hr = S_OK;
00554     SourceOp *pAsyncOp = nullptr;
00555
00556     if (flRate == m_flRate)
00557     {
00558         goto done;
00559     }
00560
00561     hr = SourceOp::CreateSetRateOp(fThin, flRate, &pAsyncOp);
00562
00563     if (SUCCEEDED(hr))
00564     {
00565         // Queue asynchronous stop
00566         hr = QueueOperation(pAsyncOp);
00567     }
00568
00569 done:
00570     SafeRelease(&pAsyncOp);
00571     LeaveCriticalSection(&m_critSec);
00572     return hr;
00573 }
00574
00575 //-------------------------------------------------------------------
00576 // GetRate
00577 // Returns a current rate.
00578 //-------------------------------------------------------------------
00579
00580 HRESULT CMPEG1Source::GetRate(_Inout_opt_ BOOL *pfThin, _Inout_opt_ float *pflRate)
00581 {
00582     if (pfThin == nullptr || pflRate == nullptr)
00583     {
00584         return E_INVALIDARG;
00585     }
00586
00587     EnterCriticalSection(&m_critSec);
00588     *pfThin = FALSE;
00589     *pflRate = m_flRate;
00590     LeaveCriticalSection(&m_critSec);
00591
00592     return S_OK;
00593 }
00594
00595
00596 //-------------------------------------------------------------------
00597 // Public non-interface methods
00598 //-------------------------------------------------------------------
00599
00600 //-------------------------------------------------------------------
00601 // BeginOpen
00602 // Begins reading the byte stream to initialize the source.
00603 // Called by the byte-stream handler when it creates the source.
00604 //
00605 // This method is asynchronous. When the operation completes,
00606 // the callback is invoked and the byte-stream handler calls
00607 // EndOpen.
00608 //
00609 // pStream: Pointer to the byte stream for the MPEG-1 stream.
00610 // pCB: Pointer to the byte-stream handler's callback.
00611 // pState: State object for the async callback. (Can be NULL.)
00612 //
00613 // Note: The source reads enough data to find one packet header
00614 // for each audio or video stream. This enables the source to
00615 // create a presentation descriptor that describes the format of
00616 // each stream. The source queues the packets that it reads during
00617 // BeginOpen.
00618 //-------------------------------------------------------------------
00619
00620 HRESULT CMPEG1Source::BeginOpen(IMFByteStream *pStream, IMFAsyncCallback *pCB, IUnknown *pState)
00621 {
00622     if (pStream == NULL || pCB == NULL)
00623     {
00624         return E_POINTER;
00625     }
00626
00627     if (m_state != STATE_INVALID)
00628     {
00629         return MF_E_INVALIDREQUEST;
00630     }
00631
00632     HRESULT hr = S_OK;
00633     DWORD dwCaps = 0;
00634
00635     EnterCriticalSection(&m_critSec);
00636
00637     // Cache the byte-stream pointer.
00638     m_pByteStream = pStream;
00639     m_pByteStream->AddRef();
00640
00641     // Validate the capabilities of the byte stream.
00642     // The byte stream must be readable and seekable.
00643     hr = pStream->GetCapabilities(&dwCaps);
00644
00645     if (SUCCEEDED(hr))
00646     {
00647         if ((dwCaps & MFBYTESTREAM_IS_SEEKABLE) == 0)
00648         {
00649             hr = MF_E_BYTESTREAM_NOT_SEEKABLE;
00650         }
00651         else if ((dwCaps & MFBYTESTREAM_IS_READABLE) == 0)
00652         {
00653             hr = E_FAIL;
00654         }
00655     }
00656
00657     // Reserve space in the read buffer.
00658     if (SUCCEEDED(hr))
00659     {
00660         hr = m_ReadBuffer.Initalize(INITIAL_BUFFER_SIZE);
00661     }
00662
00663     // Create the MPEG-1 parser.
00664     if (SUCCEEDED(hr))
00665     {
00666         m_pParser = new (std::nothrow) Parser();
00667         if (m_pParser == NULL)
00668         {
00669             hr = E_OUTOFMEMORY;
00670         }
00671     }
00672
00673     // Create an async result object. We'll use it later to invoke the callback.
00674     if (SUCCEEDED(hr))
00675     {
00676         hr = MFCreateAsyncResult(NULL, pCB, pState, &m_pBeginOpenResult);
00677     }
00678
00679     // Start reading data from the stream.
00680     if (SUCCEEDED(hr))
00681     {
00682         hr = RequestData(READ_SIZE);
00683     }
00684
00685     // At this point, we now guarantee to invoke the callback.
00686     if (SUCCEEDED(hr))
00687     {
00688         m_state = STATE_OPENING;
00689     }
00690
00691     LeaveCriticalSection(&m_critSec);
00692     return hr;
00693 }
00694
00695
00696 //-------------------------------------------------------------------
00697 // EndOpen
00698 // Completes the BeginOpen operation.
00699 // Called by the byte-stream handler when it creates the source.
00700 //-------------------------------------------------------------------
00701
00702 HRESULT CMPEG1Source::EndOpen(IMFAsyncResult *pResult)
00703 {
00704     EnterCriticalSection(&m_critSec);
00705
00706     HRESULT hr = S_OK;
00707
00708     hr = pResult->GetStatus();
00709
00710     if (FAILED(hr))
00711     {
00712         // The source is not designed to recover after failing to open.
00713         // Switch to shut-down state.
00714         Shutdown();
00715     }
00716     LeaveCriticalSection(&m_critSec);
00717     return hr;
00718 }
00719
00720
00721
00722 //-------------------------------------------------------------------
00723 // OnByteStreamRead
00724 // Called when an asynchronous read completes.
00725 //
00726 // Read requests are issued in the RequestData() method.
00727 //-------------------------------------------------------------------
00728
00729 HRESULT CMPEG1Source::OnByteStreamRead(IMFAsyncResult *pResult)
00730 {
00731     EnterCriticalSection(&m_critSec);
00732
00733     HRESULT hr = S_OK;
00734     DWORD cbRead = 0;
00735
00736     IUnknown *pState = NULL;
00737
00738     if (m_state == STATE_SHUTDOWN)
00739     {
00740         // If we are shut down, then we've already released the
00741         // byte stream. Nothing to do.
00742         LeaveCriticalSection(&m_critSec);
00743         return S_OK;
00744     }
00745
00746     // Get the state object. This is either NULL or the most
00747     // recent OP_REQUEST_DATA operation.
00748     (void)pResult->GetState(&pState);
00749
00750     // Complete the read opertation.
00751     hr = m_pByteStream->EndRead(pResult, &cbRead);
00752
00753     // If the source stops and restarts in rapid succession, there is
00754     // a chance this is a "stale" read request, initiated before the
00755     // stop/restart.
00756
00757     // To ensure that we don't deliver stale data, we store the
00758     // OP_REQUEST_DATA operation as a state object in pResult, and compare
00759     // this against the current value of m_cRestartCounter.
00760
00761     // If they don't match, we discard the data.
00762
00763     // NOTE: During BeginOpen, pState is NULL
00764
00765     if (SUCCEEDED(hr))
00766     {
00767         if ((pState == NULL) || ( ((SourceOp*)pState)->Data().ulVal == m_cRestartCounter) )
00768         {
00769             // This data is OK to parse.
00770
00771             if (cbRead == 0)
00772             {
00773                 // There is no more data in the stream. Signal end-of-stream.
00774                 hr = EndOfMPEGStream();
00775             }
00776             else
00777             {
00778                 // Update the end-position of the read buffer.
00779                 hr = m_ReadBuffer.MoveEnd(cbRead);
00780
00781                 // Parse the new data.
00782                 if (SUCCEEDED(hr))
00783                 {
00784                     hr = ParseData();
00785                 }
00786             }
00787         }
00788     }
00789
00790     if (FAILED(hr))
00791     {
00792         StreamingError(hr);
00793     }
00794     SafeRelease(&pState);
00795     LeaveCriticalSection(&m_critSec);
00796     return hr;
00797 }
00798
00799
00800
00801 /* Private methods */
00802
00803 CMPEG1Source::CMPEG1Source(HRESULT& hr) :
00804     OpQueue(m_critSec),
00805     m_cRef(1),
00806     m_pEventQueue(NULL),
00807     m_pPresentationDescriptor(NULL),
00808     m_pBeginOpenResult(NULL),
00809     m_pParser(NULL),
00810     m_pByteStream(NULL),
00811     m_pHeader(NULL),
00812     m_state(STATE_INVALID),
00813     m_pCurrentOp(NULL),
00814     m_pSampleRequest(NULL),
00815     m_cRestartCounter(0),
00816     m_OnByteStreamRead(this, &CMPEG1Source::OnByteStreamRead),
00817     m_flRate(1.0f)
00818 {
00819     auto module = ::Microsoft::WRL::GetModuleBase();
00820     if (module != nullptr)
00821     {
00822         module->IncrementObjectCount();
00823     }
00824
00825   InitializeCriticalSectionEx(&m_critSec, 3000, 0);
00826
00827     // Create the media event queue.
00828     hr = MFCreateEventQueue(&m_pEventQueue);
00829 }
00830
00831 CMPEG1Source::~CMPEG1Source()
00832 {
00833     if (m_state != STATE_SHUTDOWN)
00834     {
00835         Shutdown();
00836     }
00837
00838     DeleteCriticalSection(&m_critSec);
00839
00840   auto module = ::Microsoft::WRL::GetModuleBase();
00841     if (module != nullptr)
00842     {
00843         module->DecrementObjectCount();
00844     }
00845 }
00846
00847
00848 //-------------------------------------------------------------------
00849 // CompleteOpen
00850 //
00851 // Completes the asynchronous BeginOpen operation.
00852 //
00853 // hrStatus: Status of the BeginOpen operation.
00854 //-------------------------------------------------------------------
00855
00856 HRESULT CMPEG1Source::CompleteOpen(HRESULT hrStatus)
00857 {
00858     HRESULT hr = S_OK;
00859
00860     if (m_pBeginOpenResult)
00861     {
00862         hr = m_pBeginOpenResult->SetStatus(hrStatus);
00863         if (SUCCEEDED(hr))
00864         {
00865             hr = MFInvokeCallback(m_pBeginOpenResult);
00866         }
00867     }
00868
00869     SafeRelease(&m_pBeginOpenResult);
00870     return hr;
00871 }
00872
00873
00874 //-------------------------------------------------------------------
00875 // IsInitialized:
00876 // Returns S_OK if the source is correctly initialized with an
00877 // MPEG-1 byte stream. Otherwise, returns MF_E_NOT_INITIALIZED.
00878 //-------------------------------------------------------------------
00879
00880 HRESULT CMPEG1Source::IsInitialized() const
00881 {
00882     if (m_state == STATE_OPENING || m_state == STATE_INVALID)
00883     {
00884         return MF_E_NOT_INITIALIZED;
00885     }
00886     else
00887     {
00888         return S_OK;
00889     }
00890 }
00891
00892
00893 //-------------------------------------------------------------------
00894 // IsStreamTypeSupported:
00895 // Returns TRUE if the source supports the specified MPEG-1 stream
00896 // type.
00897 //-------------------------------------------------------------------
00898
00899 BOOL CMPEG1Source::IsStreamTypeSupported(StreamType type) const
00900 {
00901     // We support audio and video streams.
00902     return (type == StreamType_Video || type == StreamType_Audio);
00903 }
00904
00905 //-------------------------------------------------------------------
00906 // IsStreamActive:
00907 // Returns TRUE if the source should deliver a payload, whose type
00908 // is indicated by the specified packet header.
00909 //
00910 // Note: This method does not test the started/paused/stopped state
00911 //       of the source.
00912 //-------------------------------------------------------------------
00913
00914 BOOL CMPEG1Source::IsStreamActive(const MPEG1PacketHeader& packetHdr)
00915 {
00916     if (m_state == STATE_OPENING)
00917     {
00918         // The source is still opening.
00919         // Deliver payloads for every supported stream type.
00920         return IsStreamTypeSupported(packetHdr.type);
00921     }
00922     else
00923     {
00924         // The source is already opened. Check if the stream is active.
00925         CMPEG1Stream *pStream = m_streams.Find(packetHdr.stream_id);
00926
00927         if (pStream == NULL)
00928         {
00929             return FALSE;
00930         }
00931         else
00932         {
00933             return pStream->IsActive();
00934         }
00935     }
00936 }
00937
00938
00939 //-------------------------------------------------------------------
00940 // InitPresentationDescriptor
00941 //
00942 // Creates the source's presentation descriptor, if possible.
00943 //
00944 // During the BeginOpen operation, the source reads packets looking
00945 // for headers for each stream. This enables the source to create the
00946 // presentation descriptor, which describes the stream formats.
00947 //
00948 // This method tests whether the source has seen enough packets
00949 // to create the PD. If so, it invokes the callback to complete
00950 // the BeginOpen operation.
00951 //-------------------------------------------------------------------
00952
00953 HRESULT CMPEG1Source::InitPresentationDescriptor()
00954 {
00955     HRESULT hr = S_OK;
00956     DWORD cStreams = 0;
00957
00958     assert(m_pPresentationDescriptor == NULL);
00959     assert(m_state == STATE_OPENING);
00960
00961     if (m_pHeader == NULL)
00962     {
00963         return E_FAIL;
00964     }
00965
00966     // Get the number of streams, as declared in the MPEG-1 header, skipping
00967     // any streams with an unsupported format.
00968     for (DWORD i = 0; i < m_pHeader->cStreams; i++)
00969     {
00970         if (IsStreamTypeSupported(m_pHeader->streams[i].type))
00971         {
00972             cStreams++;
00973         }
00974     }
00975
00976     // How many streams do we actually have?
00977     if (cStreams > m_streams.GetCount())
00978     {
00979         // Keep reading data until we have seen a packet for each stream.
00980         return S_OK;
00981     }
00982
00983     // We should never create a stream we don't support.
00984     assert(cStreams == m_streams.GetCount());
00985
00986     // Ready to create the presentation descriptor.
00987
00988     // Create an array of IMFStreamDescriptor pointers.
00989     IMFStreamDescriptor **ppSD =
00990             new (std::nothrow) IMFStreamDescriptor*[cStreams];
00991
00992     if (ppSD == NULL)
00993     {
00994         hr = E_OUTOFMEMORY;
00995         goto done;
00996     }
00997
00998     ZeroMemory(ppSD, cStreams * sizeof(IMFStreamDescriptor*));
00999
01000     // Fill the array by getting the stream descriptors from the streams.
01001     for (DWORD i = 0; i < cStreams; i++)
01002     {
01003         hr = m_streams[i]->GetStreamDescriptor(&ppSD[i]);
01004         if (FAILED(hr))
01005         {
01006             goto done;
01007         }
01008     }
01009
01010     // Create the presentation descriptor.
01011     hr = MFCreatePresentationDescriptor(cStreams, ppSD,
01012         &m_pPresentationDescriptor);
01013
01014     if (FAILED(hr))
01015     {
01016         goto done;
01017     }
01018
01019     // Select the first video stream (if any).
01020     for (DWORD i = 0; i < cStreams; i++)
01021     {
01022         GUID majorType = GUID_NULL;
01023
01024         hr = GetStreamMajorType(ppSD[i], &majorType);
01025         if (FAILED(hr))
01026         {
01027             goto done;
01028         }
01029
01030         hr = m_pPresentationDescriptor->SelectStream(i);
01031         if (FAILED(hr))
01032         {
01033             goto done;
01034         }
01035     }
01036
01037     // Switch state from "opening" to stopped.
01038     m_state = STATE_STOPPED;
01039
01040     // Invoke the async callback to complete the BeginOpen operation.
01041     hr = CompleteOpen(S_OK);
01042
01043 done:
01044     // clean up:
01045     if (ppSD)
01046     {
01047         for (DWORD i = 0; i < cStreams; i++)
01048         {
01049             SafeRelease(&ppSD[i]);
01050         }
01051         delete [] ppSD;
01052     }
01053     return hr;
01054 }
01055
01056
01057 //-------------------------------------------------------------------
01058 // QueueAsyncOperation
01059 // Queue an asynchronous operation.
01060 //
01061 // OpType: Type of operation to queue.
01062 //
01063 // Note: If the SourceOp object requires additional information, call
01064 // OpQueue<SourceOp>::QueueOperation, which takes a SourceOp pointer.
01065 //-------------------------------------------------------------------
01066
01067 HRESULT CMPEG1Source::QueueAsyncOperation(SourceOp::Operation OpType)
01068 {
01069     HRESULT hr = S_OK;
01070     SourceOp *pOp = NULL;
01071
01072     hr = SourceOp::CreateOp(OpType, &pOp);
01073
01074     if (SUCCEEDED(hr))
01075     {
01076         hr = QueueOperation(pOp);
01077     }
01078
01079     SafeRelease(&pOp);
01080     return hr;
01081 }
01082
01083 //-------------------------------------------------------------------
01084 // BeginAsyncOp
01085 //
01086 // Starts an asynchronous operation. Called by the source at the
01087 // begining of any asynchronous operation.
01088 //-------------------------------------------------------------------
01089
01090 HRESULT CMPEG1Source::BeginAsyncOp(SourceOp *pOp)
01091 {
01092     // At this point, the current operation should be NULL (the
01093     // previous operation is NULL) and the new operation (pOp)
01094     // must not be NULL.
01095
01096     if (pOp == NULL || m_pCurrentOp != NULL)
01097     {
01098         assert(FALSE);
01099         return E_FAIL;
01100     }
01101
01102     // Store the new operation as the current operation.
01103
01104     m_pCurrentOp = pOp;
01105     m_pCurrentOp->AddRef();
01106
01107     return S_OK;
01108 }
01109
01110 //-------------------------------------------------------------------
01111 // CompleteAsyncOp
01112 //
01113 // Completes an asynchronous operation. Called by the source at the
01114 // end of any asynchronous operation.
01115 //-------------------------------------------------------------------
01116
01117 HRESULT CMPEG1Source::CompleteAsyncOp(SourceOp *pOp)
01118 {
01119     HRESULT hr = S_OK;
01120
01121     // At this point, the current operation (m_pCurrentOp)
01122     // must match the operation that is ending (pOp).
01123
01124     if (pOp == NULL || m_pCurrentOp == NULL)
01125     {
01126         assert(FALSE);
01127         return E_FAIL;
01128     }
01129
01130     if (m_pCurrentOp != pOp)
01131     {
01132         assert(FALSE);
01133         return E_FAIL;
01134     }
01135
01136     // Release the current operation.
01137     SafeRelease(&m_pCurrentOp);
01138
01139     // Process the next operation on the queue.
01140     hr = ProcessQueue();
01141
01142     return hr;
01143 }
01144
01145 //-------------------------------------------------------------------
01146 // DispatchOperation
01147 //
01148 // Performs the asynchronous operation indicated by pOp.
01149 //
01150 // NOTE:
01151 // This method implements the pure-virtual OpQueue::DispatchOperation
01152 // method. It is always called from a work-queue thread.
01153 //-------------------------------------------------------------------
01154
01155 HRESULT CMPEG1Source::DispatchOperation(SourceOp *pOp)
01156 {
01157     EnterCriticalSection(&m_critSec);
01158
01159     HRESULT hr = S_OK;
01160
01161     if (m_state == STATE_SHUTDOWN)
01162     {
01163         LeaveCriticalSection(&m_critSec);
01164
01165         return S_OK; // Already shut down, ignore the request.
01166     }
01167
01168     switch (pOp->Op())
01169     {
01170
01171     // IMFMediaSource methods:
01172
01173     case SourceOp::OP_START:
01174         hr = DoStart((StartOp*)pOp);
01175         break;
01176
01177     case SourceOp::OP_STOP:
01178         hr = DoStop(pOp);
01179         break;
01180
01181     case SourceOp::OP_PAUSE:
01182         hr = DoPause(pOp);
01183         break;
01184
01185     case SourceOp::OP_SETRATE:
01186         hr = DoSetRate(pOp);
01187         break;
01188
01189     // Operations requested by the streams:
01190
01191     case SourceOp::OP_REQUEST_DATA:
01192         hr = OnStreamRequestSample(pOp);
01193         break;
01194
01195     case SourceOp::OP_END_OF_STREAM:
01196         hr = OnEndOfStream(pOp);
01197         break;
01198
01199     default:
01200         hr = E_UNEXPECTED;
01201     }
01202
01203     if (FAILED(hr))
01204     {
01205         StreamingError(hr);
01206     }
01207
01208     LeaveCriticalSection(&m_critSec);
01209     return hr;
01210 }
01211
01212
01213 //-------------------------------------------------------------------
01214 // ValidateOperation
01215 //
01216 // Checks whether the source can perform the operation indicated
01217 // by pOp at this time.
01218 //
01219 // If the source cannot perform the operation now, the method
01220 // returns MF_E_NOTACCEPTING.
01221 //
01222 // NOTE:
01223 // Implements the pure-virtual OpQueue::ValidateOperation method.
01224 //-------------------------------------------------------------------
01225
01226 HRESULT CMPEG1Source::ValidateOperation(SourceOp *pOp)
01227 {
01228     if (m_pCurrentOp != NULL)
01229     {
01230         return MF_E_NOTACCEPTING;
01231     }
01232     return S_OK;
01233 }
01234
01235
01236
01237 //-------------------------------------------------------------------
01238 // DoStart
01239 // Perform an async start operation (IMFMediaSource::Start)
01240 //
01241 // pOp: Contains the start parameters.
01242 //
01243 // Note: This sample currently does not implement seeking, and the
01244 // Start() method fails if the caller requests a seek.
01245 //-------------------------------------------------------------------
01246
01247 HRESULT CMPEG1Source::DoStart(StartOp *pOp)
01248 {
01249     assert(pOp->Op() == SourceOp::OP_START);
01250
01251     IMFPresentationDescriptor *pPD = NULL;
01252     IMFMediaEvent  *pEvent = NULL;
01253
01254     HRESULT     hr = S_OK;
01255     LONGLONG    llStartOffset = 0;
01256     BOOL        bRestartFromCurrentPosition = FALSE;
01257     BOOL        bSentEvents = FALSE;
01258
01259     hr = BeginAsyncOp(pOp);
01260
01261     // Get the presentation descriptor from the SourceOp object.
01262     // This is the PD that the caller passed into the Start() method.
01263     // The PD has already been validated.
01264     if (SUCCEEDED(hr))
01265     {
01266         hr = pOp->GetPresentationDescriptor(&pPD);
01267     }
01268     // Because this sample does not support seeking, the start
01269     // position must be 0 (from stopped) or "current position."
01270
01271     // If the sample supported seeking, we would need to get the
01272     // start position from the PROPVARIANT data contained in pOp.
01273
01274     if (SUCCEEDED(hr))
01275     {
01276         // Select/deselect streams, based on what the caller set in the PD.
01277         // This method also sends the MENewStream/MEUpdatedStream events.
01278         hr = SelectStreams(pPD, pOp->Data());
01279     }
01280
01281     if (SUCCEEDED(hr))
01282     {
01283         m_state = STATE_STARTED;
01284
01285         // Queue the "started" event. The event data is the start position.
01286         hr = m_pEventQueue->QueueEventParamVar(
01287             MESourceStarted,
01288             GUID_NULL,
01289             S_OK,
01290             &pOp->Data()
01291             );
01292     }
01293
01294     if (FAILED(hr))
01295     {
01296         // Failure. Send the error code to the application.
01297
01298         // Note: It's possible that QueueEvent itself failed, in which case it
01299         // is likely to fail again. But there is no good way to recover in
01300         // that case.
01301
01302         (void)m_pEventQueue->QueueEventParamVar(
01303             MESourceStarted, GUID_NULL, hr, NULL);
01304     }
01305
01306     CompleteAsyncOp(pOp);
01307
01308     SafeRelease(&pEvent);
01309     SafeRelease(&pPD);
01310     return hr;
01311 }
01312
01313
01314 //-------------------------------------------------------------------
01315 // DoStop
01316 // Perform an async stop operation (IMFMediaSource::Stop)
01317 //-------------------------------------------------------------------
01318
01319 HRESULT CMPEG1Source::DoStop(SourceOp *pOp)
01320 {
01321     HRESULT hr = S_OK;
01322     QWORD qwCurrentPosition = 0;
01323
01324     hr = BeginAsyncOp(pOp);
01325
01326     // Stop the active streams.
01327     if (SUCCEEDED(hr))
01328     {
01329         for (DWORD i = 0; i < m_streams.GetCount(); i++)
01330         {
01331             if (m_streams[i]->IsActive())
01332             {
01333                 hr = m_streams[i]->Stop();
01334             }
01335             if (FAILED(hr))
01336             {
01337                 break;
01338             }
01339         }
01340     }
01341
01342     // Seek to the start of the file. If we restart after stopping,
01343     // we will start from the beginning of the file again.
01344     if (SUCCEEDED(hr))
01345     {
01346         hr = m_pByteStream->Seek(
01347             msoBegin,
01348             0,
01349             MFBYTESTREAM_SEEK_FLAG_CANCEL_PENDING_IO,
01350             &qwCurrentPosition
01351             );
01352     }
01353
01354     // Increment the counter that tracks "stale" read requests.
01355     if (SUCCEEDED(hr))
01356     {
01357         ++m_cRestartCounter; // This counter is allowed to overflow.
01358     }
01359
01360     SafeRelease(&m_pSampleRequest);
01361
01362     m_state = STATE_STOPPED;
01363
01364     // Send the "stopped" event. This might include a failure code.
01365     (void)m_pEventQueue->QueueEventParamVar(MESourceStopped, GUID_NULL, hr, NULL);
01366
01367     CompleteAsyncOp(pOp);
01368
01369     return hr;
01370 }
01371
01372
01373 //-------------------------------------------------------------------
01374 // DoPause
01375 // Perform an async pause operation (IMFMediaSource::Pause)
01376 //-------------------------------------------------------------------
01377
01378 HRESULT CMPEG1Source::DoPause(SourceOp *pOp)
01379 {
01380     HRESULT hr = S_OK;
01381
01382     hr = BeginAsyncOp(pOp);
01383
01384     // Pause is only allowed while running.
01385     if (SUCCEEDED(hr))
01386     {
01387         if (m_state != STATE_STARTED)
01388         {
01389             hr = MF_E_INVALID_STATE_TRANSITION;
01390         }
01391     }
01392
01393     // Pause the active streams.
01394     if (SUCCEEDED(hr))
01395     {
01396         for (DWORD i = 0; i < m_streams.GetCount(); i++)
01397         {
01398             if (m_streams[i]->IsActive())
01399             {
01400                 hr = m_streams[i]->Pause();
01401             }
01402             if (FAILED(hr))
01403             {
01404                 break;
01405             }
01406         }
01407     }
01408
01409     m_state = STATE_PAUSED;
01410
01411
01412     // Send the "paused" event. This might include a failure code.
01413     (void)m_pEventQueue->QueueEventParamVar(MESourcePaused, GUID_NULL, hr, NULL);
01414
01415     CompleteAsyncOp(pOp);
01416
01417     return hr;
01418 }
01419
01420 //-------------------------------------------------------------------
01421 // DoSetRate
01422 // Perform an async set rate operation (IMFRateControl::SetRate)
01423 //-------------------------------------------------------------------
01424
01425 HRESULT CMPEG1Source::DoSetRate(SourceOp *pOp)
01426 {
01427     HRESULT hr = S_OK;
01428     SetRateOp *pSetRateOp = static_cast<SetRateOp*>(pOp);
01429
01430     hr = BeginAsyncOp(pOp);
01431
01432     // Set rate on active streams.
01433     if (SUCCEEDED(hr))
01434     {
01435         for (DWORD i = 0; i < m_streams.GetCount(); i++)
01436         {
01437             if (m_streams[i]->IsActive())
01438             {
01439                 hr = m_streams[i]->SetRate(pSetRateOp->GetRate());
01440             }
01441             if (FAILED(hr))
01442             {
01443                 break;
01444             }
01445         }
01446     }
01447
01448     if (SUCCEEDED(hr))
01449     {
01450         m_flRate = pSetRateOp->GetRate();
01451     }
01452
01453     // Send the "rate changted" event. This might include a failure code.
01454     (void)m_pEventQueue->QueueEventParamVar(MESourceRateChanged, GUID_NULL, hr, NULL);
01455
01456     CompleteAsyncOp(pOp);
01457
01458     return hr;
01459 }
01460
01461 //-------------------------------------------------------------------
01462 // StreamRequestSample
01463 // Called by streams when they need more data.
01464 //
01465 // Note: This is an async operation. The stream requests more data
01466 // by queueing an OP_REQUEST_DATA operation.
01467 //-------------------------------------------------------------------
01468
01469 HRESULT CMPEG1Source::OnStreamRequestSample(SourceOp *pOp)
01470 {
01471     HRESULT hr = S_OK;
01472
01473     hr = BeginAsyncOp(pOp);
01474
01475     // Ignore this request if we are already handling an earlier request.
01476     // (In that case m_pSampleRequest will be non-NULL.)
01477
01478     if (SUCCEEDED(hr))
01479     {
01480         if (m_pSampleRequest == NULL)
01481         {
01482             // Add the request counter as data to the operation.
01483             // This counter tracks whether a read request becomes "stale."
01484
01485             PROPVARIANT var;
01486             var.vt = VT_UI4;
01487             var.ulVal = m_cRestartCounter;
01488
01489             hr = pOp->SetData(var);
01490
01491             if (SUCCEEDED(hr))
01492             {
01493                 // Store this while the request is pending.
01494                 m_pSampleRequest = pOp;
01495                 m_pSampleRequest->AddRef();
01496
01497                 // Try to parse data - this will invoke a read request if needed.
01498                 ParseData();
01499             }
01500         }
01501
01502         CompleteAsyncOp(pOp);
01503     }
01504
01505     return hr;
01506 }
01507
01508
01509 //-------------------------------------------------------------------
01510 // OnEndOfStream
01511 // Called by each stream when it sends the last sample in the stream.
01512 //
01513 // Note: When the media source reaches the end of the MPEG-1 stream,
01514 // it calls EndOfStream on each stream object. The streams might have
01515 // data still in their queues. As each stream empties its queue, it
01516 // notifies the source through an async OP_END_OF_STREAM operation.
01517 //
01518 // When every stream notifies the source, the source can send the
01519 // "end-of-presentation" event.
01520 //-------------------------------------------------------------------
01521
01522 HRESULT CMPEG1Source::OnEndOfStream(SourceOp *pOp)
01523 {
01524     HRESULT hr = S_OK;
01525
01526     hr = BeginAsyncOp(pOp);
01527
01528     // Decrement the count of end-of-stream notifications.
01529     if (SUCCEEDED(hr))
01530     {
01531         --m_cPendingEOS;
01532         if (m_cPendingEOS == 0)
01533         {
01534             // No more streams. Send the end-of-presentation event.
01535             hr = m_pEventQueue->QueueEventParamVar(MEEndOfPresentation, GUID_NULL, S_OK, NULL);
01536         }
01537
01538     }
01539
01540     if (SUCCEEDED(hr))
01541     {
01542         hr = CompleteAsyncOp(pOp);
01543     }
01544
01545     return hr;
01546 }
01547
01548
01549
01550 //-------------------------------------------------------------------
01551 // SelectStreams
01552 // Called during START operations to select and deselect streams.
01553 //-------------------------------------------------------------------
01554
01555 HRESULT CMPEG1Source::SelectStreams(
01556     IMFPresentationDescriptor *pPD,   // Presentation descriptor.
01557     const PROPVARIANT varStart        // New start position.
01558     )
01559 {
01560     HRESULT hr = S_OK;
01561     BOOL    fSelected = FALSE;
01562     BOOL    fWasSelected = FALSE;
01563     DWORD   stream_id = 0;
01564
01565     IMFStreamDescriptor *pSD = NULL;
01566
01567     CMPEG1Stream *pStream = NULL; // Not add-ref'd
01568
01569     // Reset the pending EOS count.
01570     m_cPendingEOS = 0;
01571
01572     // Loop throught the stream descriptors to find which streams are active.
01573     for (DWORD i = 0; i < m_streams.GetCount(); i++)
01574     {
01575         hr = pPD->GetStreamDescriptorByIndex(i, &fSelected, &pSD);
01576         if (FAILED(hr))
01577         {
01578             goto done;
01579         }
01580
01581         hr = pSD->GetStreamIdentifier(&stream_id);
01582         if (FAILED(hr))
01583         {
01584             goto done;
01585         }
01586
01587         pStream = m_streams.Find((BYTE)stream_id);
01588         if (pStream == NULL)
01589         {
01590             hr = E_INVALIDARG;
01591             goto done;
01592         }
01593
01594         // Was the stream active already?
01595         fWasSelected = pStream->IsActive();
01596
01597         // Activate or deactivate the stream.
01598         hr = pStream->Activate(fSelected);
01599         if (FAILED(hr))
01600         {
01601             goto done;
01602         }
01603
01604         if (fSelected)
01605         {
01606             m_cPendingEOS++;
01607
01608             // If the stream was previously selected, send an "updated stream"
01609             // event. Otherwise, send a "new stream" event.
01610             MediaEventType met = fWasSelected ? MEUpdatedStream : MENewStream;
01611
01612             hr = m_pEventQueue->QueueEventParamUnk(met, GUID_NULL, hr, pStream);
01613             if (FAILED(hr))
01614             {
01615                 goto done;
01616             }
01617
01618             // Start the stream. The stream will send the appropriate event.
01619             hr = pStream->Start(varStart);
01620             if (FAILED(hr))
01621             {
01622                 goto done;
01623             }
01624         }
01625         SafeRelease(&pSD);
01626     }
01627
01628 done:
01629     SafeRelease(&pSD);
01630     return hr;
01631 }
01632
01633
01634 //-------------------------------------------------------------------
01635 // RequestData
01636 // Request the next batch of data.
01637 //
01638 // cbRequest: Amount of data to read, in bytes.
01639 //-------------------------------------------------------------------
01640
01641 HRESULT CMPEG1Source::RequestData(DWORD cbRequest)
01642 {
01643     HRESULT hr = S_OK;
01644
01645     // Reserve a sufficient read buffer.
01646     hr = m_ReadBuffer.Reserve(cbRequest);
01647
01648     // Submit the async read request.
01649     // When it completes, our OnByteStreamRead method will be invoked.
01650
01651     if (SUCCEEDED(hr))
01652     {
01653         hr = m_pByteStream->BeginRead(
01654             m_ReadBuffer.DataPtr() + m_ReadBuffer.DataSize(),
01655             cbRequest,
01656             &m_OnByteStreamRead,
01657             m_pSampleRequest
01658             );
01659     }
01660
01661     return hr;
01662 }
01663
01664
01665 //-------------------------------------------------------------------
01666 // ParseData
01667 // Parses the next batch of data.
01668 //-------------------------------------------------------------------
01669
01670 HRESULT CMPEG1Source::ParseData()
01671 {
01672     HRESULT hr = S_OK;
01673
01674     DWORD cbNextRequest = 0;
01675     BOOL  bNeedMoreData = FALSE;
01676
01677     // Keep processing data until
01678     // (a) All streams have enough samples, or
01679     // (b) The parser needs more data in the buffer.
01680
01681     while ( StreamsNeedData() )
01682     {
01683         DWORD cbAte = 0;    // How much data we consumed from the read buffer.
01684
01685         // Check if we got the first system header.
01686         if (m_pHeader == NULL && m_pParser->HasSystemHeader())
01687         {
01688             hr = m_pParser->GetSystemHeader(&m_pHeader);
01689
01690             if (FAILED(hr)) { break; }
01691         }
01692
01693         if (m_pParser->IsEndOfStream())
01694         {
01695             // The parser reached the end of the MPEG-1 stream. Notify the streams.
01696             hr = EndOfMPEGStream();
01697         }
01698         else if (m_pParser->HasPacket())
01699         {
01700             // The parser reached the start of a new packet.
01701             hr = ReadPayload(&cbAte, &cbNextRequest);
01702         }
01703         else
01704         {
01705             // Parse more data.
01706             hr = m_pParser->ParseBytes(m_ReadBuffer.DataPtr(), m_ReadBuffer.DataSize(), &cbAte);
01707         }
01708
01709         // Parser::ParseBytes() or ReadPayload can return S_FALSE, meaning "Need more data"
01710         if (hr == S_FALSE)
01711         {
01712             bNeedMoreData = TRUE;
01713         }
01714
01715         if (FAILED(hr)) { break; }
01716
01717         // Advance the start of the read buffer by the amount consumed.
01718         hr = m_ReadBuffer.MoveStart(cbAte);
01719
01720         if (FAILED(hr)) { break; }
01721
01722         // If we need more data, start an async read operation.
01723         if (bNeedMoreData)
01724         {
01725             hr = RequestData( max(READ_SIZE, cbNextRequest) );
01726
01727             // Break from the loop because we need to wait for the async read to complete.
01728             break;
01729         }
01730     }
01731
01732     // Flag our state. If a stream requests more data while we are waiting for an async
01733     // read to complete, we can ignore the stream's request, because the request will be
01734     // dispatched as soon as we get more data.
01735
01736     if (SUCCEEDED(hr))
01737     {
01738         if (!bNeedMoreData)
01739         {
01740             SafeRelease(&m_pSampleRequest);
01741         }
01742     }
01743
01744     return hr;
01745 }
01746
01747 //-------------------------------------------------------------------
01748 // ReadPayload
01749 // Read the next MPEG-1 payload.
01750 //
01751 // When this method is called:
01752 // - The read position has reached the beginning of a payload.
01753 // - We have the packet header, but not necessarily the entire payload.
01754 //-------------------------------------------------------------------
01755
01756 HRESULT CMPEG1Source::ReadPayload(DWORD *pcbAte, DWORD *pcbNextRequest)
01757 {
01758     assert(m_pParser != NULL);
01759     assert(m_pParser->HasPacket());
01760
01761     HRESULT hr = S_OK;
01762
01763     DWORD cbPayloadRead = 0;
01764     DWORD cbPayloadUnread = 0;
01765
01766     // At this point, the read buffer might be larger or smaller than the payload.
01767     // Calculate which portion of the payload has been read.
01768     if (m_pParser->PayloadSize() > m_ReadBuffer.DataSize())
01769     {
01770         cbPayloadUnread = m_pParser->PayloadSize() - m_ReadBuffer.DataSize();
01771     }
01772
01773     cbPayloadRead = m_pParser->PayloadSize() - cbPayloadUnread;
01774
01775     // Do we need to deliver this payload?
01776     if ( !IsStreamActive(m_pParser->PacketHeader()) )
01777     {
01778         QWORD qwCurrentPosition = 0;
01779
01780         // Skip this payload. Seek past the unread portion of the payload.
01781         hr = m_pByteStream->Seek(
01782             msoCurrent,
01783             cbPayloadUnread,
01784             MFBYTESTREAM_SEEK_FLAG_CANCEL_PENDING_IO,
01785             &qwCurrentPosition
01786             );
01787
01788         // Advance the data buffer to the end of payload, or the portion
01789         // that has been read.
01790
01791         if (SUCCEEDED(hr))
01792         {
01793             *pcbAte = cbPayloadRead;
01794
01795             // Tell the parser that we are done with this packet.
01796             m_pParser->ClearPacket();
01797         }
01798
01799     }
01800     else if (cbPayloadUnread > 0)
01801     {
01802         // Some portion of this payload has not been read. Schedule a read.
01803         *pcbNextRequest = cbPayloadUnread;
01804
01805         *pcbAte = 0;
01806
01807         hr = S_FALSE; // Need more data.
01808     }
01809     else
01810     {
01811         // The entire payload is in the data buffer. Deliver the packet.
01812         hr = DeliverPayload();
01813
01814         if (SUCCEEDED(hr))
01815         {
01816             *pcbAte = cbPayloadRead;
01817
01818             // Tell the parser that we are done with this packet.
01819             m_pParser->ClearPacket();
01820         }
01821     }
01822
01823     return hr;
01824 }
01825
01826 //-------------------------------------------------------------------
01827 // EndOfMPEGStream:
01828 // Called when the parser reaches the end of the MPEG1 stream.
01829 //-------------------------------------------------------------------
01830
01831 HRESULT CMPEG1Source::EndOfMPEGStream()
01832 {
01833     // Notify the streams. The streams might have pending samples.
01834     // When each stream delivers the last sample, it will send the
01835     // end-of-stream event to the pipeline and then notify the
01836     // source.
01837
01838     // When every stream is done, the source sends the end-of-
01839     // presentation event.
01840
01841     HRESULT hr = S_OK;
01842
01843     for (DWORD i = 0; i < m_streams.GetCount(); i++)
01844     {
01845         if (m_streams[i]->IsActive())
01846         {
01847             hr = m_streams[i]->EndOfStream();
01848         }
01849         if (FAILED(hr))
01850         {
01851             break;
01852         }
01853     }
01854
01855     return hr;
01856 }
01857
01858
01859
01860 //-------------------------------------------------------------------
01861 // StreamsNeedData:
01862 // Returns TRUE if any streams need more data.
01863 //-------------------------------------------------------------------
01864
01865 BOOL CMPEG1Source::StreamsNeedData() const
01866 {
01867     BOOL bNeedData = FALSE;
01868
01869     switch (m_state)
01870     {
01871     case STATE_OPENING:
01872         // While opening, we always need data (until we get enough
01873         // to complete the open operation).
01874         return TRUE;
01875
01876     case STATE_SHUTDOWN:
01877         // While shut down, we never need data.
01878         return FALSE;
01879
01880     default:
01881         // If none of the above, ask the streams.
01882         for (DWORD i = 0; i < m_streams.GetCount(); i++)
01883         {
01884             if (m_streams[i]->NeedsData())
01885             {
01886                 bNeedData = TRUE;
01887                 break;
01888             }
01889         }
01890         return bNeedData;
01891     }
01892 }
01893
01894
01895 //-------------------------------------------------------------------
01896 // DeliverPayload:
01897 // Delivers an MPEG-1 payload.
01898 //-------------------------------------------------------------------
01899
01900 HRESULT CMPEG1Source::DeliverPayload()
01901 {
01902     // When this method is called, the read buffer contains a complete
01903     // payload, and the payload belongs to a stream whose type we support.
01904
01905     assert(m_pParser->HasPacket());
01906
01907     HRESULT             hr = S_OK;
01908     MPEG1PacketHeader   packetHdr;
01909     CMPEG1Stream        *pStream = NULL;    // not AddRef'd
01910
01911     IMFMediaBuffer      *pBuffer = NULL;
01912     IMFSample           *pSample = NULL;
01913     BYTE                *pData = NULL;      // Pointer to the IMFMediaBuffer data.
01914
01915     packetHdr = m_pParser->PacketHeader();
01916
01917     if (packetHdr.cbPayload > m_ReadBuffer.DataSize())
01918     {
01919         assert(FALSE);
01920         hr = E_UNEXPECTED;
01921     }
01922
01923     // If we are still opening the file, then we might need to create this stream.
01924     if (SUCCEEDED(hr))
01925     {
01926         if (m_state == STATE_OPENING)
01927         {
01928             hr = CreateStream(packetHdr);
01929         }
01930     }
01931
01932     if (SUCCEEDED(hr))
01933     {
01934         pStream = m_streams.Find(packetHdr.stream_id);
01935         assert(pStream != NULL);
01936     }
01937
01938     // Create a media buffer for the payload.
01939     if (SUCCEEDED(hr))
01940     {
01941         hr = MFCreateMemoryBuffer(packetHdr.cbPayload, &pBuffer);
01942     }
01943
01944     if (SUCCEEDED(hr))
01945     {
01946         hr = pBuffer->Lock(&pData, NULL, NULL);
01947     }
01948
01949     if (SUCCEEDED(hr))
01950     {
01951         CopyMemory(pData, m_ReadBuffer.DataPtr(), packetHdr.cbPayload);
01952     }
01953
01954     if (SUCCEEDED(hr))
01955     {
01956         hr = pBuffer->Unlock();
01957     }
01958
01959     if (SUCCEEDED(hr))
01960     {
01961         hr = pBuffer->SetCurrentLength(packetHdr.cbPayload);
01962     }
01963
01964     // Create a sample to hold the buffer.
01965     if (SUCCEEDED(hr))
01966     {
01967         hr = MFCreateSample(&pSample);
01968     }
01969     if (SUCCEEDED(hr))
01970     {
01971         hr = pSample->AddBuffer(pBuffer);
01972     }
01973
01974     // Time stamp the sample.
01975     if (SUCCEEDED(hr))
01976     {
01977         if (packetHdr.bHasPTS)
01978         {
01979             LONGLONG hnsStart = packetHdr.PTS * 10000 / 90;
01980
01981             hr = pSample->SetSampleTime(hnsStart);
01982         }
01983     }
01984
01985     // Deliver the payload to the stream.
01986     if (SUCCEEDED(hr))
01987     {
01988         hr = pStream->DeliverPayload(pSample);
01989     }
01990
01991     // If the open operation is still pending, check if we're done.
01992     if (SUCCEEDED(hr))
01993     {
01994         if (m_state == STATE_OPENING)
01995         {
01996             hr = InitPresentationDescriptor();
01997         }
01998     }
01999
02000     SafeRelease(&pBuffer);
02001     SafeRelease(&pSample);
02002     return hr;
02003 }
02004
02005
02006
02007 //-------------------------------------------------------------------
02008 // CreateStream:
02009 // Creates a media stream, based on a packet header.
02010 //-------------------------------------------------------------------
02011
02012 HRESULT CMPEG1Source::CreateStream(const MPEG1PacketHeader& packetHdr)
02013 {
02014     // We validate the stream type before calling this method.
02015     assert(IsStreamTypeSupported(packetHdr.type));
02016
02017
02018     // First see if the stream already exists.
02019     if ( m_streams.Find(packetHdr.stream_id) != NULL )
02020     {
02021         // The stream already exists. Nothing to do.
02022         return S_OK;
02023     }
02024
02025     HRESULT hr = S_OK;
02026     DWORD cbAte = 0;
02027     BYTE *pPayload = NULL;
02028
02029     IMFMediaType *pType = NULL;
02030     IMFStreamDescriptor *pSD = NULL;
02031     CMPEG1Stream *pStream = NULL;
02032     IMFMediaTypeHandler *pHandler = NULL;
02033
02034     MPEG1VideoSeqHeader videoSeqHdr;
02035     MPEG1AudioFrameHeader audioFrameHeader;
02036
02037     // Get a pointer to the start of the payload.
02038     pPayload = m_ReadBuffer.DataPtr();
02039
02040     // Create a media type, based on the packet type (audio/video)
02041     switch (packetHdr.type)
02042     {
02043     case StreamType_Video:
02044         // Video: Read the sequence header and use it to create a media type.
02045         hr = ReadVideoSequenceHeader(pPayload, packetHdr.cbPayload, videoSeqHdr, &cbAte);
02046         if (SUCCEEDED(hr))
02047         {
02048             hr = CreateVideoMediaType(videoSeqHdr, &pType);
02049         }
02050         break;
02051
02052     case StreamType_Audio:
02053         // Audio: Read the frame header and use it to create a media type.
02054         hr = ReadAudioFrameHeader(pPayload, packetHdr.cbPayload, audioFrameHeader, &cbAte);
02055         if (SUCCEEDED(hr))
02056         {
02057             hr = CreateAudioMediaType(audioFrameHeader, &pType);
02058         }
02059         break;
02060
02061     default:
02062         assert(false); // If this case occurs, then IsStreamTypeSupported() is wrong.
02063         hr = E_UNEXPECTED;
02064     }
02065
02066     if (SUCCEEDED(hr))
02067     {
02068         // Create the stream descriptor from the media type.
02069         hr = MFCreateStreamDescriptor(packetHdr.stream_id, 1, &pType, &pSD);
02070     }
02071
02072     // Set the default media type on the stream handler.
02073     if (SUCCEEDED(hr))
02074     {
02075         hr = pSD->GetMediaTypeHandler(&pHandler);
02076     }
02077     if (SUCCEEDED(hr))
02078     {
02079         hr = pHandler->SetCurrentMediaType(pType);
02080     }
02081
02082     // Create the new stream.
02083     if (SUCCEEDED(hr))
02084     {
02085         pStream = new (std::nothrow) CMPEG1Stream(this, pSD, hr);
02086         if (pStream == NULL)
02087         {
02088             hr = E_OUTOFMEMORY;
02089         }
02090     }
02091
02092     // Add the stream to the array.
02093     if (SUCCEEDED(hr))
02094     {
02095         hr = m_streams.AddStream(packetHdr.stream_id, pStream);
02096     }
02097
02098     SafeRelease(&pSD);
02099     SafeRelease(&pStream);
02100     return hr;
02101 }
02102
02103
02104 //-------------------------------------------------------------------
02105 // ValidatePresentationDescriptor:
02106 // Validates the presentation descriptor that the caller specifies
02107 // in IMFMediaSource::Start().
02108 //
02109 // Note: This method performs a basic sanity check on the PD. It is
02110 // not intended to be a thorough validation.
02111 //-------------------------------------------------------------------
02112
02113 HRESULT CMPEG1Source::ValidatePresentationDescriptor(IMFPresentationDescriptor *pPD)
02114 {
02115     HRESULT hr = S_OK;
02116     BOOL fSelected = FALSE;
02117     DWORD cStreams = 0;
02118
02119     IMFStreamDescriptor *pSD = NULL;
02120
02121     if (m_pHeader == NULL)
02122     {
02123         return E_UNEXPECTED;
02124     }
02125
02126     // The caller's PD must have the same number of streams as ours.
02127     hr = pPD->GetStreamDescriptorCount(&cStreams);
02128
02129     if (SUCCEEDED(hr))
02130     {
02131         if (cStreams != m_pHeader->cStreams)
02132         {
02133             hr = E_INVALIDARG;
02134         }
02135     }
02136
02137     // The caller must select at least one stream.
02138     if (SUCCEEDED(hr))
02139     {
02140         for (DWORD i = 0; i < cStreams; i++)
02141         {
02142             hr = pPD->GetStreamDescriptorByIndex(i, &fSelected, &pSD);
02143             if (FAILED(hr))
02144             {
02145                 break;
02146             }
02147             if (fSelected)
02148             {
02149                 break;
02150             }
02151             SafeRelease(&pSD);
02152         }
02153     }
02154
02155     if (SUCCEEDED(hr))
02156     {
02157         if (!fSelected)
02158         {
02159             hr = E_INVALIDARG;
02160         }
02161     }
02162
02163     SafeRelease(&pSD);
02164     return hr;
02165 }
02166
02167
02168 //-------------------------------------------------------------------
02169 // StreamingError:
02170 // Handles an error that occurs duing an asynchronous operation.
02171 //
02172 // hr: Error code of the operation that failed.
02173 //-------------------------------------------------------------------
02174
02175 void CMPEG1Source::StreamingError(HRESULT hr)
02176 {
02177     if (m_state == STATE_OPENING)
02178     {
02179         // An error happened during BeginOpen.
02180         // Invoke the callback with the status code.
02181
02182         CompleteOpen(hr);
02183     }
02184     else if (m_state != STATE_SHUTDOWN)
02185     {
02186         // An error occurred during streaming. Send the MEError event
02187         // to notify the pipeline.
02188
02189         QueueEvent(MEError, GUID_NULL, hr, NULL);
02190     }
02191 }
02192
02193 BOOL CMPEG1Source::IsRateSupported(float flRate, float *pflAdjustedRate)
02194 {
02195     if (flRate < 0.00001f && flRate > -0.00001f)
02196     {
02197         *pflAdjustedRate = 0.0f;
02198         return TRUE;
02199     }
02200     else if(flRate < 1.0001f && flRate > 0.9999f)
02201     {
02202         *pflAdjustedRate = 1.0f;
02203         return TRUE;
02204     }
02205     return FALSE;
02206 }
02207
02208
02209 /* SourceOp class */
02210
02211
02212 //-------------------------------------------------------------------
02213 // CreateOp
02214 // Static method to create a SourceOp instance.
02215 //
02216 // op: Specifies the async operation.
02217 // ppOp: Receives a pointer to the SourceOp object.
02218 //-------------------------------------------------------------------
02219
02220 HRESULT SourceOp::CreateOp(SourceOp::Operation op, SourceOp **ppOp)
02221 {
02222     if (ppOp == NULL)
02223     {
02224         return E_POINTER;
02225     }
02226
02227     SourceOp *pOp = new (std::nothrow) SourceOp(op);
02228     if (pOp  == NULL)
02229     {
02230         return E_OUTOFMEMORY;
02231     }
02232     *ppOp = pOp;
02233
02234     return S_OK;
02235 }
02236
02237 //-------------------------------------------------------------------
02238 // CreateStartOp:
02239 // Static method to create a SourceOp instance for the Start()
02240 // operation.
02241 //
02242 // pPD: Presentation descriptor from the caller.
02243 // ppOp: Receives a pointer to the SourceOp object.
02244 //-------------------------------------------------------------------
02245
02246 HRESULT SourceOp::CreateStartOp(IMFPresentationDescriptor *pPD, SourceOp **ppOp)
02247 {
02248     if (ppOp == NULL)
02249     {
02250         return E_POINTER;
02251     }
02252
02253     SourceOp *pOp = new (std::nothrow) StartOp(pPD);
02254     if (pOp == NULL)
02255     {
02256         return E_OUTOFMEMORY;
02257     }
02258
02259     *ppOp = pOp;
02260     return S_OK;
02261 }
02262
02263 //-------------------------------------------------------------------
02264 // CreateSetRateOp:
02265 // Static method to create a SourceOp instance for the SetRate()
02266 // operation.
02267 //
02268 // fThin: TRUE - thinning is on, FALSE otherwise
02269 // flRate: New rate
02270 // ppOp: Receives a pointer to the SourceOp object.
02271 //-------------------------------------------------------------------
02272
02273 HRESULT SourceOp::CreateSetRateOp(BOOL fThin, float flRate, SourceOp **ppOp)
02274 {
02275     if (ppOp == NULL)
02276     {
02277         return E_POINTER;
02278     }
02279
02280     SourceOp *pOp = new (std::nothrow) SetRateOp(fThin, flRate);
02281     if (pOp == NULL)
02282     {
02283         return E_OUTOFMEMORY;
02284     }
02285
02286     *ppOp = pOp;
02287     return S_OK;
02288 }
02289
02290 ULONG SourceOp::AddRef()
02291 {
02292     return _InterlockedIncrement(&m_cRef);
02293 }
02294
02295 ULONG SourceOp::Release()
02296 {
02297     LONG cRef = _InterlockedDecrement(&m_cRef);
02298     if (cRef == 0)
02299     {
02300         delete this;
02301     }
02302     return cRef;
02303 }
02304
02305 HRESULT SourceOp::QueryInterface(REFIID riid, void** ppv)
02306 {
02307     if (ppv == nullptr)
02308     {
02309         return E_POINTER;
02310     }
02311
02312     HRESULT hr = E_NOINTERFACE;
02313     if (riid == IID_IUnknown)
02314     {
02315         (*ppv) = static_cast<IUnknown *>(this);
02316         AddRef();
02317         hr = S_OK;
02318     }
02319
02320     return hr;
02321 }
02322
02323 SourceOp::SourceOp(Operation op) : m_cRef(1), m_op(op)
02324 {
02325     ZeroMemory(&m_data, sizeof(m_data));
02326 }
02327
02328 SourceOp::~SourceOp()
02329 {
02330     PropVariantClear(&m_data);
02331 }
02332
02333 HRESULT SourceOp::SetData(const PROPVARIANT& var)
02334 {
02335     return PropVariantCopy(&m_data, &var);
02336 }
02337
02338
02339 StartOp::StartOp(IMFPresentationDescriptor *pPD) : SourceOp(SourceOp::OP_START), m_pPD(pPD)
02340 {
02341     if (m_pPD)
02342     {
02343         m_pPD->AddRef();
02344     }
02345 }
02346
02347 StartOp::~StartOp()
02348 {
02349     SafeRelease(&m_pPD);
02350 }
02351
02352
02353 HRESULT StartOp::GetPresentationDescriptor(IMFPresentationDescriptor **ppPD)
02354 {
02355     if (ppPD == NULL)
02356     {
02357         return E_POINTER;
02358     }
02359     if (m_pPD == NULL)
02360     {
02361         return MF_E_INVALIDREQUEST;
02362     }
02363     *ppPD = m_pPD;
02364     (*ppPD)->AddRef();
02365     return S_OK;
02366 }
02367
02368 SetRateOp::SetRateOp(BOOL fThin, float flRate)
02369 : SourceOp(SourceOp::OP_SETRATE)
02370 , m_fThin(fThin)
02371 , m_flRate(flRate)
02372 {
02373 }
02374
02375 SetRateOp::~SetRateOp()
02376 {
02377 }
02378
02379 /*  Static functions */
02380
02381
02382 //-------------------------------------------------------------------
02383 // CreateVideoMediaType:
02384 // Create a media type from an MPEG-1 video sequence header.
02385 //-------------------------------------------------------------------
02386
02387 HRESULT CreateVideoMediaType(const MPEG1VideoSeqHeader& videoSeqHdr, IMFMediaType **ppType)
02388 {
02389     HRESULT hr = S_OK;
02390
02391     IMFMediaType *pType = NULL;
02392
02393     hr = MFCreateMediaType(&pType);
02394
02395     if (SUCCEEDED(hr))
02396     {
02397         hr = pType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
02398     }
02399
02400     // Subtype = MPEG-1 payload
02401     if (SUCCEEDED(hr))
02402     {
02403         hr = pType->SetGUID(MF_MT_SUBTYPE, MFVideoFormat_MPG1);
02404     }
02405
02406     // Format details.
02407     if (SUCCEEDED(hr))
02408     {
02409         // Frame size
02410
02411         hr = MFSetAttributeSize(
02412             pType,
02413             MF_MT_FRAME_SIZE,
02414             videoSeqHdr.width,
02415             videoSeqHdr.height
02416             );
02417     }
02418     if (SUCCEEDED(hr))
02419     {
02420         // Frame rate
02421
02422         hr = MFSetAttributeRatio(
02423             pType,
02424             MF_MT_FRAME_RATE,
02425             videoSeqHdr.frameRate.Numerator,
02426             videoSeqHdr.frameRate.Denominator
02427             );
02428     }
02429     if (SUCCEEDED(hr))
02430     {
02431         // Pixel aspect ratio
02432
02433         hr = MFSetAttributeRatio(
02434             pType,
02435             MF_MT_PIXEL_ASPECT_RATIO,
02436             videoSeqHdr.pixelAspectRatio.Numerator,
02437             videoSeqHdr.pixelAspectRatio.Denominator
02438             );
02439     }
02440     if (SUCCEEDED(hr))
02441     {
02442         // Average bit rate
02443
02444         hr = pType->SetUINT32(MF_MT_AVG_BITRATE, videoSeqHdr.bitRate);
02445     }
02446     if (SUCCEEDED(hr))
02447     {
02448
02449         // Interlacing (progressive frames)
02450
02451         hr = pType->SetUINT32(MF_MT_INTERLACE_MODE, (UINT32)MFVideoInterlace_Progressive);
02452     }
02453     if (SUCCEEDED(hr))
02454     {
02455         // Sequence header.
02456
02457         hr = pType->SetBlob(
02458             MF_MT_MPEG_SEQUENCE_HEADER,
02459             videoSeqHdr.header,             // Byte array
02460             videoSeqHdr.cbHeader            // Size
02461             );
02462     }
02463
02464     if (SUCCEEDED(hr))
02465     {
02466         *ppType = pType;
02467         (*ppType)->AddRef();
02468     }
02469
02470     SafeRelease(&pType);
02471     return hr;
02472 }
02473
02474
02475 //-------------------------------------------------------------------
02476 // CreateAudioMediaType:
02477 // Create a media type from an MPEG-1 audio frame header.
02478 //
02479 // Note: This function fills in an MPEG1WAVEFORMAT structure and then
02480 // converts the structure to a Media Foundation media type
02481 // (IMFMediaType). This is somewhat roundabout but it guarantees
02482 // that the type can be converted back to an MPEG1WAVEFORMAT by the
02483 // decoder if need be.
02484 //
02485 // The WAVEFORMATEX portion of the MPEG1WAVEFORMAT structure is
02486 // converted into attributes on the IMFMediaType object. The rest of
02487 // the struct is stored in the MF_MT_USER_DATA attribute.
02488 //-------------------------------------------------------------------
02489
02490 HRESULT CreateAudioMediaType(const MPEG1AudioFrameHeader& audioHeader, IMFMediaType **ppType)
02491 {
02492     HRESULT hr = S_OK;
02493     IMFMediaType *pType = NULL;
02494
02495     MPEG1WAVEFORMAT format;
02496     ZeroMemory(&format, sizeof(format));
02497
02498     format.wfx.wFormatTag = WAVE_FORMAT_MPEG;
02499     format.wfx.nChannels = audioHeader.nChannels;
02500     format.wfx.nSamplesPerSec = audioHeader.dwSamplesPerSec;
02501     if (audioHeader.dwBitRate > 0)
02502     {
02503         format.wfx.nAvgBytesPerSec = (audioHeader.dwBitRate * 1000) / 8;
02504     }
02505     format.wfx.nBlockAlign = audioHeader.nBlockAlign;
02506     format.wfx.wBitsPerSample = 0; // Not used.
02507     format.wfx.cbSize = sizeof(MPEG1WAVEFORMAT) - sizeof(WAVEFORMATEX);
02508
02509     // MPEG-1 audio layer.
02510     switch (audioHeader.layer)
02511     {
02512     case MPEG1_Audio_Layer1:
02513         format.fwHeadLayer = ACM_MPEG_LAYER1;
02514         break;
02515
02516     case MPEG1_Audio_Layer2:
02517         format.fwHeadLayer = ACM_MPEG_LAYER2;
02518         break;
02519
02520     case MPEG1_Audio_Layer3:
02521         format.fwHeadLayer = ACM_MPEG_LAYER3;
02522         break;
02523     };
02524
02525     format.dwHeadBitrate = audioHeader.dwBitRate * 1000;
02526
02527     // Mode
02528     switch (audioHeader.mode)
02529     {
02530     case MPEG1_Audio_Stereo:
02531         format.fwHeadMode = ACM_MPEG_STEREO;
02532         break;
02533
02534     case MPEG1_Audio_JointStereo:
02535         format.fwHeadMode = ACM_MPEG_JOINTSTEREO;
02536         break;
02537
02538     case MPEG1_Audio_DualChannel:
02539         format.fwHeadMode = ACM_MPEG_DUALCHANNEL;
02540         break;
02541
02542     case MPEG1_Audio_SingleChannel:
02543         format.fwHeadMode = ACM_MPEG_SINGLECHANNEL;
02544         break;
02545     };
02546
02547     if (audioHeader.mode == ACM_MPEG_JOINTSTEREO)
02548     {
02549         // Convert the 'mode_extension' field to the correct MPEG1WAVEFORMAT value.
02550         if (audioHeader.modeExtension <= 0x03)
02551         {
02552             format.fwHeadModeExt = 0x01 << audioHeader.modeExtension;
02553         }
02554     }
02555
02556     // Convert the 'emphasis' field to the correct MPEG1WAVEFORMAT value.
02557     if (audioHeader.emphasis <= 0x03)
02558     {
02559         format.wHeadEmphasis = audioHeader.emphasis + 1;
02560     }
02561
02562     // The flags translate directly.
02563     format.fwHeadFlags = audioHeader.wFlags;
02564     // Add the "MPEG-1" flag, although it's somewhat redundant.
02565     format.fwHeadFlags |= ACM_MPEG_ID_MPEG1;
02566
02567     // Use the structure to initialize the Media Foundation media type.
02568     hr = MFCreateMediaType(&pType);
02569     if (SUCCEEDED(hr))
02570     {
02571         hr = MFInitMediaTypeFromWaveFormatEx(pType, (const WAVEFORMATEX*)&format, sizeof(format));
02572     }
02573
02574     if (SUCCEEDED(hr))
02575     {
02576         *ppType = pType;
02577         (*ppType)->AddRef();
02578     }
02579
02580     SafeRelease(&pType);
02581     return hr;
02582 }
02583
02584 // Get the major media type from a stream descriptor.
02585 HRESULT GetStreamMajorType(IMFStreamDescriptor *pSD, GUID *pguidMajorType)
02586 {
02587     if (pSD == NULL) { return E_POINTER; }
02588     if (pguidMajorType == NULL) { return E_POINTER; }
02589
02590     HRESULT hr = S_OK;
02591     IMFMediaTypeHandler *pHandler = NULL;
02592
02593     hr = pSD->GetMediaTypeHandler(&pHandler);
02594     if (SUCCEEDED(hr))
02595     {
02596         hr = pHandler->GetMajorType(pguidMajorType);
02597     }
02598     SafeRelease(&pHandler);
02599     return hr;
02600 }
02601
02602
02603 BOOL SampleRequestMatch(SourceOp *pOp1, SourceOp *pOp2)
02604 {
02605     if ((pOp1 == NULL) && (pOp2 == NULL))
02606     {
02607         return TRUE;
02608     }
02609     else if ((pOp1 == NULL) || (pOp2 == NULL))
02610     {
02611         return FALSE;
02612     }
02613     else
02614     {
02615         return (pOp1->Data().ulVal == pOp2->Data().ulVal);
02616     }
02617 }
02618
02619 #pragma warning( pop )
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaEngineNotify Member List

This is the complete list of members for MediaEngineNotify, including all inherited members.
EventNotify(DWORD meEvent, DWORD_PTR param1, DWORD param2) | MediaEngineNotify | [inline]
m_cRef | MediaEngineNotify | [private]
m_cWindow | MediaEngineNotify | [private]
m_pCB | MediaEngineNotify | [private]
MediaEngineNotify(Platform::Agile< Windows::UI::Core::CoreWindow > cWindow) | MediaEngineNotify | [inline]
MediaEngineNotifyCallback(MediaEngineNotifyCallback^pCB) | MediaEngineNotify | [inline]
QueryInterface(REFIID riid, void **ppv) | MediaEngineNotify | [inline]
STDMETHODIMP_(ULONG) AddRef() | MediaEngineNotify | [inline]
STDMETHODIMP_(ULONG) Release() | MediaEngineNotify | [inline]
Generated on Sat Nov 23 2024 16:09:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/Constants.h Source File

  • Programmatic file search

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"File search C++ sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042     private:
00043         static Platform::Array<Scenario>^ scenariosInner;
00044     };
00045 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/App.xaml.h Source File

  • Device enumeration

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/PageWithAppBar.xaml.cpp Source File

  • XAML WebView control

PageWithAppBar.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PageWithAppBar.xaml.cpp
00013 // Implementation of the PageWithAppBar class
00014 //
00015
00016 #include "pch.h"
00017 #include "PageWithAppBar.xaml.h"
00018
00019 using namespace SDKSample::WebViewControl;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 PageWithAppBar::PageWithAppBar()
00028 {
00029     InitializeComponent();
00030
00031      // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00032     // as NotifyUser()
00033     rootPage = MainPage::Current;
00034
00035     // Hook the opned and closed events on the AppBar so we know when
00036     // to adjust the WebView.
00037     BottomAppBar->Opened += ref new EventHandler<Object^>(this, &PageWithAppBar::BottomAppBar_Opened);
00038     BottomAppBar->Closed += ref new EventHandler<Object^>(this, &PageWithAppBar::BottomAppBar_Closed);
00039 }
00040
00041
00042 // Invoked when this page is about to be displayed in a Frame.
00043 void PageWithAppBar::OnNavigatedTo(NavigationEventArgs^ e)
00044 {
00045     // Navigate to some web site
00046     WebView8->Navigate(ref new Uri("http://www.microsoft.com"));
00047 }
00048
00049 void PageWithAppBar::OnNavigatedFrom(NavigationEventArgs^ e)
00050 {
00051 }
00052
00053 void SDKSample::WebViewControl::PageWithAppBar::BottomAppBar_Opened(Object^ sender, Object^ obj)
00054 {
00055     // AppBar has Opened so we need to put the WebView back to its
00056     // original size/location.
00057     AppBar^ bottomAppBar = (AppBar^) sender;
00058     if (bottomAppBar != nullptr)
00059     {
00060         // Force layout so that we can guarantee that our AppBar's
00061         // actual height has height
00062         this->UpdateLayout();
00063         // Get the height of the AppBar
00064         double appBarHeight = bottomAppBar->ActualHeight;
00065         // Reduce the height of the WebView to allow for the AppBar
00066         WebView8->Height = WebView8->ActualHeight - appBarHeight;
00067         // Translate the WebView in the Y direction to reclaim the space occupied by the AppBar.
00068         TranslateYOpen->To = -appBarHeight / 2.0;
00069         // Run our translate animation to match the AppBar
00070         OpenAppBar->Begin();
00071     }
00072 }
00073
00074 void SDKSample::WebViewControl::PageWithAppBar::BottomAppBar_Closed(Object^ sender, Object^ obj)
00075 {
00076     // AppBar has closed so we need to put the WebView back to its
00077     // original size/location.
00078     AppBar^ bottomAppBar = (AppBar^) sender;
00079     if (bottomAppBar != nullptr)
00080     {
00081         // Force layout so that we can guarantee that our AppBar's
00082         // actual height has height
00083         this->UpdateLayout();
00084         // Get the height of the AppBar
00085         double appBarHeight = bottomAppBar->ActualHeight;
00086         // Increase the height of the WebView to allow for the space
00087         // that was occupied by the AppBar
00088         WebView8->Height = WebView8->ActualHeight + appBarHeight;
00089         // Translate the WebView in the Y direction to allow for
00090         TranslateYOpen->To = appBarHeight / 2.0;
00091         // Run our translate animation to match the AppBar
00092         CloseAppBar->Begin();
00093     }
00094 }
00095
00096
00097 // Click handler for home button
00098 void SDKSample::WebViewControl::PageWithAppBar::Home_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00099 {
00100     if (rootPage->Frame->CanGoBack)
00101     {
00102         rootPage->Frame->GoBack();
00103     }
00104 }
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaCapture::BasicCapture Member List

This is the complete list of members for MediaCapture::BasicCapture, including all inherited members.
__pad0__ | Element |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Page | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BasicCapture() | MediaCapture::BasicCapture | [inline]
BindResource(_In_ Element^rootElement) | Element | [virtual]
btnStartDevice_Click(Object sender, Windows.UI.Xaml.RoutedEventArgs e) | MediaCapture::BasicCapture | [inline, private]
btnStartPreview_Click(Object sender, Windows.UI.Xaml.RoutedEventArgs e) | MediaCapture::BasicCapture | [inline, private]
btnStartStopRecord_Click(Object sender, Windows.UI.Xaml.RoutedEventArgs e) | MediaCapture::BasicCapture | [inline, private]
btnTakePhoto_Click(Object sender, Windows.UI.Xaml.RoutedEventArgs e) | MediaCapture::BasicCapture | [inline, private]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
DefaultViewModel | SDKTemplate::Common::LayoutAwarePage | [protected]
DefaultViewModelProperty | SDKTemplate::Common::LayoutAwarePage | [static]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
EnableButton(bool enabled, String name) | MediaCapture::BasicCapture | [inline, private]
Failed(Windows.Media.Capture.MediaCapture currentCaptureObject, MediaCaptureFailedEventArgs currentFailure) | MediaCapture::BasicCapture | [inline]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
m_bPreviewing | MediaCapture::BasicCapture | [private]
m_bRecording | MediaCapture::BasicCapture | [private]
m_bSuspended | MediaCapture::BasicCapture | [private]
m_mediaCaptureMgr | MediaCapture::BasicCapture | [private]
m_photoStorageFile | MediaCapture::BasicCapture | [private]
m_recordStorageFile | MediaCapture::BasicCapture | [private]
m_soundLevelHandler | MediaCapture::BasicCapture | [private]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
MediaControl_SoundLevelChanged(object sender, Object e) | MediaCapture::BasicCapture | [inline, private]
OnNavigatedFrom(NavigationEventArgs e) | MediaCapture::BasicCapture | [inline, protected]
OnNavigatedTo(NavigationEventArgs e) | MediaCapture::BasicCapture | [inline, protected]
PHOTO_FILE_NAME | MediaCapture::BasicCapture | [private]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
RecordLimitationExceeded(Windows.Media.Capture.MediaCapture currentCaptureObject) | MediaCapture::BasicCapture | [inline]
ReleaseParent() | Element | [virtual]
rootPage | MediaCapture::BasicCapture | [private]
ScenarioInit() | MediaCapture::BasicCapture | [inline, private]
ScenarioReset() | MediaCapture::BasicCapture | [inline, private]
SetupVideoDeviceControl(Windows.Media.Devices.MediaDeviceControl videoDeviceControl, Slider slider) | MediaCapture::BasicCapture | [inline, private]
ShowExceptionMessage(Exception ex) | MediaCapture::BasicCapture | [inline, private]
ShowStatusMessage(String text) | MediaCapture::BasicCapture | [inline, private]
sldBrightness_ValueChanged(Object sender, Windows.UI.Xaml.Controls.Primitives.RangeBaseValueChangedEventArgs e) | MediaCapture::BasicCapture | [inline, private]
sldContrast_ValueChanged(Object sender, Windows.UI.Xaml.Controls.Primitives.RangeBaseValueChangedEventArgs e) | MediaCapture::BasicCapture | [inline, private]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
SwitchRecordButtonContent() | MediaCapture::BasicCapture | [inline, private]
VIDEO_FILE_NAME | MediaCapture::BasicCapture | [private]
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/MainPage.xaml.h Source File

  • Direct2D magazine app

MainPage.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "MainPage.g.h"
00011
00012 ref class Document;
00013 ref class Element;
00014
00015 namespace Magazine
00016 {
00017     public ref class MainPage sealed
00018     {
00019     public:
00020         MainPage();
00021
00022         void LoadState(_In_ Windows::Foundation::Collections::IPropertySet^ localSettings);
00023
00024         void SaveState(_In_ Windows::Foundation::Collections::IPropertySet^ localSettings);
00025
00026     private:
00027
00028         void DocumentLoaded(_In_ Document^ document);
00029
00030         void OnDeviceLost();
00031
00032         void OnWindowSizeChanged(
00033             _In_ Platform::Object^ sender,
00034             _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00035             );
00036
00037         // Current document loaded
00038         Document^ m_document;
00039     };
00040 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario7.xaml.h Source File

  • XAML text editing

Scenario7.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario7.xaml.h
00013 // Declaration of the Scenario7 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario7.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace TextEditing
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario7 sealed
00031         {
00032         public:
00033             Scenario7();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Other_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/MainPage.xaml.cpp Source File

  • UI contrast and settings

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicReaderWriter.h Source File

  • DXGI offer and reclaim resources

BasicReaderWriter.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <ppltasks.h>
00011
00012 // A simple reader/writer class that provides support for reading and writing
00013 // files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicReaderWriter
00015 {
00016 private:
00017     Windows::Storage::StorageFolder^ m_location;
00018     Platform::String^ m_locationPath;
00019
00020 internal:
00021     BasicReaderWriter();
00022     BasicReaderWriter(
00023         _In_ Windows::Storage::StorageFolder^ folder
00024         );
00025
00026     Platform::Array<byte>^ ReadData(
00027         _In_ Platform::String^ filename
00028         );
00029
00030     concurrency::task<Platform::Array<byte>^> ReadDataAsync(
00031         _In_ Platform::String^ filename
00032         );
00033
00034     uint32 WriteData(
00035         _In_ Platform::String^ filename,
00036         _In_ const Platform::Array<byte>^ fileData
00037         );
00038
00039     concurrency::task<void> WriteDataAsync(
00040         _In_ Platform::String^ filename,
00041         _In_ const Platform::Array<byte>^ fileData
00042         );
00043 };
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Polar/PolarEffect.cpp Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Polar

PolarEffect.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #include "PolarEffect.h"
00009 #include "bufferlock.h"
00010
00011 #pragma comment(lib, "d2d1")
00012
00013 /*
00014
00015 This sample implements video effects as a Media Foundation transform (MFT).
00016
00017 Windows Store apps using JavaScript can select one of the following effects
00018 by using PropertySet argument of msInsertVideoEffect.
00019
00020 Fisheye
00021
00022     var effect = new Windows.Foundation.Collections.PropertySet();
00023     effect["effect"] = "Fisheye";
00024
00025 Pinch
00026
00027     var effect = new Windows.Foundation.Collections.PropertySet();
00028     effect["effect"] = "Pinch";
00029
00030 Warp
00031
00032     var effect = new Windows.Foundation.Collections.PropertySet();
00033     effect["effect"] = "Warp";
00034
00035
00036 These effects are based on polar transformation.
00037
00038 Each pixel in a YUV image is represented as radius (r) and angle (theta) from
00039 the center of the image. If R is the maximum distance from the center of the
00040 image, the new pixel location is calculated by the following rules:
00041
00042 Fisheye
00043
00044     r := r*(r/R)
00045
00046 Pinch
00047
00048     r := sqrt(r/R)
00049
00050 Warp
00051
00052     theta := theta + r/R
00053
00054
00055 Before the first video frame is processed, a lookup table is created to store
00056 the result of the polar transformation. Then, the same lookup table is used
00057 until the end of the streaming session.
00058
00059
00060 NOTES ON THE MFT IMPLEMENTATION
00061
00062 1. The MFT has fixed streams: One input stream and one output stream.
00063
00064 2. The MFT supports the following formats: UYVY, YUY2, NV12.
00065
00066 3. If the MFT is holding an input sample, SetInputType and SetOutputType both fail.
00067
00068 4. The input and output types must be identical.
00069
00070 5. If both types are set, no type can be set until the current type is cleared.
00071
00072 6. Preferred input types:
00073
00074      (a) If the output type is set, that's the preferred type.
00075      (b) Otherwise, the preferred types are partial types, constructed from the
00076          list of supported subtypes.
00077
00078 7. Preferred output types: As above.
00079
00080 8. Streaming:
00081
00082     The private BeingStreaming() method is called in response to the
00083     MFT_MESSAGE_NOTIFY_BEGIN_STREAMING message.
00084
00085     If the client does not send MFT_MESSAGE_NOTIFY_BEGIN_STREAMING, the MFT calls
00086     BeginStreaming inside the first call to ProcessInput or ProcessOutput.
00087
00088     This is a good approach for allocating resources that your MFT requires for
00089     streaming.
00090
00091 9. The configuration attributes are applied in the BeginStreaming method. If the
00092    client changes the attributes during streaming, the change is ignored until
00093    streaming is stopped (either by changing the media types or by sending the
00094    MFT_MESSAGE_NOTIFY_END_STREAMING message) and then restarted.
00095
00096 */
00097
00098 // Video FOURCC codes.
00099 const DWORD FOURCC_YUY2 = '2YUY';
00100 const DWORD FOURCC_UYVY = 'YVYU';
00101 const DWORD FOURCC_NV12 = '21VN';
00102
00103 // Static array of media types (preferred and accepted).
00104 const GUID g_MediaSubtypes[] =
00105 {
00106     MFVideoFormat_NV12,
00107     MFVideoFormat_YUY2,
00108     MFVideoFormat_UYVY
00109 };
00110
00111 HRESULT GetImageSize(DWORD fcc, UINT32 width, UINT32 height, DWORD* pcbImage);
00112 HRESULT GetDefaultStride(IMFMediaType *pType, LONG *plStride);
00113
00114 //-------------------------------------------------------------------
00115 // Functions to apply the lookup table to YUV images.
00116 //
00117 // In all cases, the same transformation is applied to the YUV
00118 // image, but the pixel layout in memory differs. The transformation
00119 // is applied to the pair of pixels which share the UV component.
00120 //
00121 // The image conversion functions take the following parameters:
00122 //
00123 // pLookup          Pointer to the lookup table.
00124 // pDest             Pointer to the destination buffer.
00125 // lDestStride       Stride of the destination buffer, in bytes.
00126 // pSrc              Pointer to the source buffer.
00127 // lSrcStride        Stride of the source buffer, in bytes.
00128 // dwWidthInPixels   Frame width in pixels.
00129 // dwHeightInPixels  Frame height, in pixels.
00130 //-------------------------------------------------------------------
00131
00132 // Convert UYVY image.
00133
00134 void TransformImage_UYVY(
00135     _In_reads_(_Inexpressible_(dwWidthInPixels * dwHeightInPixels)) const UINT32* pLookup,
00136     _Inout_updates_(_Inexpressible_(lDestStride * dwHeightInPixels)) BYTE *pDest,
00137     _In_ LONG lDestStride,
00138     _In_reads_(_Inexpressible_(lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00139     _In_ LONG lSrcStride,
00140     _In_ DWORD dwWidthInPixels,
00141     _In_ DWORD dwHeightInPixels)
00142 {
00143     DWORD *pSrc_UYVY = (DWORD*) pSrc;
00144
00145     // Byte order is U0 Y0 V0 Y1
00146     // Windows is little-endian so the order appears reversed.
00147
00148     pSrc_UYVY[0] = 0x00800080;  // black
00149
00150     for (DWORD y = 0; y < dwHeightInPixels; y++)
00151     {
00152         DWORD *pDest_UYVY = (DWORD*) pDest;
00153
00154         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00155         {
00156 #pragma warning(push)
00157 #pragma warning(disable: 6385)
00158 #pragma warning(disable: 6386)
00159             UINT32 uOffset = (pLookup[x] % dwWidthInPixels) * sizeof(WORD) + (pLookup[x] / dwWidthInPixels) * lSrcStride;
00160             pDest_UYVY[x/2] = pSrc_UYVY[uOffset/sizeof(DWORD)];
00161 #pragma warning(pop)
00162         }
00163         pDest += lDestStride;
00164         pLookup += dwWidthInPixels;
00165     }
00166 }
00167
00168
00169 // Convert YUY2 image.
00170
00171 void TransformImage_YUY2(
00172     _In_reads_(_Inexpressible_(dwWidthInPixels * dwHeightInPixels)) const UINT32* pLookup,
00173     _Inout_updates_(_Inexpressible_(lDestStride * dwHeightInPixels)) BYTE *pDest,
00174     _In_ LONG lDestStride,
00175     _In_reads_(_Inexpressible_(lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00176     _In_ LONG lSrcStride,
00177     _In_ DWORD dwWidthInPixels,
00178     _In_ DWORD dwHeightInPixels)
00179 {
00180     DWORD *pSrc_UYVY = (DWORD*) pSrc;
00181
00182     // Byte order is Y0 U0 Y1 V0
00183     // Windows is little-endian so the order appears reversed.
00184
00185     pSrc_UYVY[0] = 0x80008000;  // black
00186
00187     for (DWORD y = 0; y < dwHeightInPixels; y++)
00188     {
00189         DWORD *pDest_UYVY = (DWORD*) pDest;
00190
00191         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00192         {
00193 #pragma warning(push)
00194 #pragma warning(disable: 6385)
00195 #pragma warning(disable: 6386)
00196             UINT32 uOffset = (pLookup[x] % dwWidthInPixels) * sizeof(WORD) + (pLookup[x] / dwWidthInPixels) * lSrcStride;
00197             pDest_UYVY[x/2] = pSrc_UYVY[uOffset/sizeof(DWORD)];
00198 #pragma warning(pop)
00199         }
00200         pDest += lDestStride;
00201         pLookup += dwWidthInPixels;
00202     }
00203 }
00204
00205
00206 // Convert NV12 image
00207
00208 void TransformImage_NV12(
00209     _In_reads_(_Inexpressible_(dwWidthInPixels * dwHeightInPixels)) const UINT32* pLookup,
00210     _Inout_updates_(_Inexpressible_(lDestStride * dwHeightInPixels)) BYTE *pDest,
00211     _In_ LONG lDestStride,
00212     _In_reads_(_Inexpressible_(lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00213     _In_ LONG lSrcStride,
00214     _In_ DWORD dwWidthInPixels,
00215     _In_ DWORD dwHeightInPixels)
00216 {
00217     // NV12 is planar: Y plane, followed by packed U-V plane.
00218
00219     // Y plane
00220
00221     UINT32 *pLookup_Y = (UINT32*) pLookup;
00222     WORD *pSrc_Y = (WORD*) pSrc;
00223     pSrc_Y[0] = 0x0000;    // black
00224
00225     for (DWORD y = 0; y < dwHeightInPixels; y++)
00226     {
00227         WORD *pDest_Y = (WORD*) pDest;
00228
00229         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00230         {
00231 #pragma warning(push)
00232 #pragma warning(disable: 6385)
00233 #pragma warning(disable: 6386)
00234             UINT32 uOffset = (pLookup_Y[x] % dwWidthInPixels) + (pLookup_Y[x] / dwWidthInPixels) * lSrcStride;
00235             pDest_Y[x/2] = pSrc_Y[uOffset/2];
00236 #pragma warning(pop)
00237         }
00238         pDest += lDestStride;
00239         pLookup_Y += dwWidthInPixels;
00240     }
00241
00242     // U-V plane
00243
00244     // NOTE: The U-V plane has 1/2 the number of lines as the Y plane.
00245
00246     UINT32 *pLookup_UV = (UINT32*) pLookup;
00247     WORD *pSrc_UV = (WORD*) (pSrc + lSrcStride * dwHeightInPixels);
00248     pSrc_UV[0] = 0x8080;    // black
00249
00250     for (DWORD y = 0; y < dwHeightInPixels; y += 2)
00251     {
00252         WORD *pDest_UV = (WORD*) pDest;
00253
00254         for (DWORD x = 0; x < dwWidthInPixels; x += 2)
00255         {
00256 #pragma warning(push)
00257 #pragma warning(disable: 6385)
00258             UINT32 uOffset = (pLookup_UV[x] % dwWidthInPixels) + ((pLookup_UV[x] / dwWidthInPixels) / 2) * lSrcStride;
00259 #pragma warning(pop)
00260             pDest_UV[x/2] = pSrc_UV[uOffset/2];
00261         }
00262         pDest += lDestStride;
00263         pLookup_UV += dwWidthInPixels * 2;
00264     }
00265 }
00266
00267
00268
00269 CPolarEffect::CPolarEffect() :
00270     m_pSample(NULL), m_pInputType(NULL), m_pOutputType(NULL), m_pTransformFn(NULL),
00271     m_imageWidthInPixels(0), m_imageHeightInPixels(0), m_cbImageSize(0),
00272     m_pIndexLookup(NULL), m_bStreamingInitialized(false), m_pAttributes(NULL),
00273     m_pRadiusTransformFn(CPolarEffect::DefaultRadius),
00274     m_pThetaTransformFn(CPolarEffect::DefaultTheta)
00275 {
00276     InitializeCriticalSectionEx(&m_critSec, 3000, 0);
00277 }
00278
00279 CPolarEffect::~CPolarEffect()
00280 {
00281     SafeArrayDelete(&m_pIndexLookup);
00282     SafeRelease(&m_pInputType);
00283     SafeRelease(&m_pOutputType);
00284     SafeRelease(&m_pSample);
00285     SafeRelease(&m_pAttributes);
00286     DeleteCriticalSection(&m_critSec);
00287 }
00288
00289 // Initialize the instance.
00290 STDMETHODIMP CPolarEffect::RuntimeClassInitialize()
00291 {
00292     // Create the attribute store.
00293     return MFCreateAttributes(&m_pAttributes, 3);
00294 }
00295
00296 // IMediaExtension methods
00297
00298 //-------------------------------------------------------------------
00299 // SetProperties
00300 // Sets the configuration of the effect
00301 //-------------------------------------------------------------------
00302 HRESULT CPolarEffect::SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
00303 {
00304     HRESULT hr = S_OK;
00305
00306     if(pConfiguration)
00307     {
00308         Microsoft::WRL::ComPtr<IInspectable> spInsp;
00309         Microsoft::WRL::ComPtr<ABI::Windows::Foundation::Collections::IMap<HSTRING, IInspectable *>> spSetting;
00310         Microsoft::WRL::ComPtr<ABI::Windows::Foundation::IPropertyValue> spPropVal;
00311
00312         hr = pConfiguration->QueryInterface(IID_PPV_ARGS(&spSetting));
00313         if (FAILED(hr))
00314         {
00315             hr = E_FAIL;
00316             goto done;
00317         }
00318
00319         HStringReference strKey(L"effect");
00320         hr = spSetting->Lookup(strKey.Get(), spInsp.ReleaseAndGetAddressOf());
00321         if(FAILED(hr))
00322         {
00323             hr = E_INVALIDARG;
00324             goto done;
00325         }
00326
00327         hr = spInsp.As(&spPropVal);
00328         if(FAILED(hr))
00329         {
00330             hr = E_INVALIDARG;
00331             goto done;
00332         }
00333
00334         HString strEffectName;
00335         hr = spPropVal->GetString(strEffectName.GetAddressOf());
00336         if(FAILED(hr))
00337         {
00338             hr = E_INVALIDARG;
00339             goto done;
00340         }
00341
00342         LPCWSTR pszEffectName = WindowsGetStringRawBuffer(strEffectName.Get(), nullptr);
00343         if (pszEffectName == nullptr)
00344         {
00345             hr = E_INVALIDARG;
00346             goto done;
00347         }
00348
00349         if (wcscmp(pszEffectName, L"Fisheye") == 0)
00350         {
00351             m_pRadiusTransformFn = CPolarEffect::FisheyeRadius;
00352             m_pThetaTransformFn = CPolarEffect::DefaultTheta;
00353         }
00354         else if (wcscmp(pszEffectName, L"Pinch") == 0)
00355         {
00356             m_pRadiusTransformFn = CPolarEffect::PinchRadius;
00357             m_pThetaTransformFn = CPolarEffect::DefaultTheta;
00358         }
00359         else if (wcscmp(pszEffectName, L"Warp") == 0)
00360         {
00361             m_pRadiusTransformFn = CPolarEffect::DefaultRadius;
00362             m_pThetaTransformFn = CPolarEffect::WarpTheta;
00363         }
00364         else
00365         {
00366             hr = E_INVALIDARG;
00367             goto done;
00368         }
00369     }
00370
00371 done:
00372     return hr;
00373 }
00374
00375 // IMFTransform methods. Refer to the Media Foundation SDK documentation for details.
00376
00377 //-------------------------------------------------------------------
00378 // GetStreamLimits
00379 // Returns the minimum and maximum number of streams.
00380 //-------------------------------------------------------------------
00381
00382 HRESULT CPolarEffect::GetStreamLimits(
00383     DWORD   *pdwInputMinimum,
00384     DWORD   *pdwInputMaximum,
00385     DWORD   *pdwOutputMinimum,
00386     DWORD   *pdwOutputMaximum
00387 )
00388 {
00389     if ((pdwInputMinimum == NULL) ||
00390         (pdwInputMaximum == NULL) ||
00391         (pdwOutputMinimum == NULL) ||
00392         (pdwOutputMaximum == NULL))
00393     {
00394         return E_POINTER;
00395     }
00396
00397     // This MFT has a fixed number of streams.
00398     *pdwInputMinimum = 1;
00399     *pdwInputMaximum = 1;
00400     *pdwOutputMinimum = 1;
00401     *pdwOutputMaximum = 1;
00402     return S_OK;
00403 }
00404
00405
00406 //-------------------------------------------------------------------
00407 // GetStreamCount
00408 // Returns the actual number of streams.
00409 //-------------------------------------------------------------------
00410
00411 HRESULT CPolarEffect::GetStreamCount(
00412     DWORD   *pcInputStreams,
00413     DWORD   *pcOutputStreams
00414 )
00415 {
00416     if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))
00417
00418     {
00419         return E_POINTER;
00420     }
00421
00422     // This MFT has a fixed number of streams.
00423     *pcInputStreams = 1;
00424     *pcOutputStreams = 1;
00425     return S_OK;
00426 }
00427
00428
00429
00430 //-------------------------------------------------------------------
00431 // GetStreamIDs
00432 // Returns stream IDs for the input and output streams.
00433 //-------------------------------------------------------------------
00434
00435 HRESULT CPolarEffect::GetStreamIDs(
00436     DWORD   dwInputIDArraySize,
00437     DWORD   *pdwInputIDs,
00438     DWORD   dwOutputIDArraySize,
00439     DWORD   *pdwOutputIDs
00440 )
00441 {
00442     // It is not required to implement this method if the MFT has a fixed number of
00443     // streams AND the stream IDs are numbered sequentially from zero (that is, the
00444     // stream IDs match the stream indexes).
00445
00446     // In that case, it is OK to return E_NOTIMPL.
00447     return E_NOTIMPL;
00448 }
00449
00450
00451 //-------------------------------------------------------------------
00452 // GetInputStreamInfo
00453 // Returns information about an input stream.
00454 //-------------------------------------------------------------------
00455
00456 HRESULT CPolarEffect::GetInputStreamInfo(
00457     DWORD                     dwInputStreamID,
00458     MFT_INPUT_STREAM_INFO *   pStreamInfo
00459 )
00460 {
00461     if (pStreamInfo == NULL)
00462     {
00463         return E_POINTER;
00464     }
00465
00466     EnterCriticalSection(&m_critSec);
00467
00468     if (!IsValidInputStream(dwInputStreamID))
00469     {
00470         LeaveCriticalSection(&m_critSec);
00471         return MF_E_INVALIDSTREAMNUMBER;
00472     }
00473
00474     // NOTE: This method should succeed even when there is no media type on the
00475     //       stream. If there is no media type, we only need to fill in the dwFlags
00476     //       member of MFT_INPUT_STREAM_INFO. The other members depend on having a
00477     //       a valid media type.
00478
00479     pStreamInfo->hnsMaxLatency = 0;
00480     pStreamInfo->dwFlags = MFT_INPUT_STREAM_WHOLE_SAMPLES | MFT_INPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER;
00481
00482     if (m_pInputType == NULL)
00483     {
00484         pStreamInfo->cbSize = 0;
00485     }
00486     else
00487     {
00488         pStreamInfo->cbSize = m_cbImageSize;
00489     }
00490
00491     pStreamInfo->cbMaxLookahead = 0;
00492     pStreamInfo->cbAlignment = 0;
00493
00494     LeaveCriticalSection(&m_critSec);
00495     return S_OK;
00496 }
00497
00498 //-------------------------------------------------------------------
00499 // GetOutputStreamInfo
00500 // Returns information about an output stream.
00501 //-------------------------------------------------------------------
00502
00503 HRESULT CPolarEffect::GetOutputStreamInfo(
00504     DWORD                     dwOutputStreamID,
00505     MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00506 )
00507 {
00508     if (pStreamInfo == NULL)
00509     {
00510         return E_POINTER;
00511     }
00512
00513     EnterCriticalSection(&m_critSec);
00514
00515     if (!IsValidOutputStream(dwOutputStreamID))
00516     {
00517         LeaveCriticalSection(&m_critSec);
00518         return MF_E_INVALIDSTREAMNUMBER;
00519     }
00520
00521     // NOTE: This method should succeed even when there is no media type on the
00522     //       stream. If there is no media type, we only need to fill in the dwFlags
00523     //       member of MFT_OUTPUT_STREAM_INFO. The other members depend on having a
00524     //       a valid media type.
00525
00526     pStreamInfo->dwFlags =
00527         MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
00528         MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
00529         MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;
00530
00531     if (m_pOutputType == NULL)
00532     {
00533         pStreamInfo->cbSize = 0;
00534     }
00535     else
00536     {
00537         pStreamInfo->cbSize = m_cbImageSize;
00538     }
00539
00540     pStreamInfo->cbAlignment = 0;
00541
00542     LeaveCriticalSection(&m_critSec);
00543     return S_OK;
00544 }
00545
00546
00547 //-------------------------------------------------------------------
00548 // GetAttributes
00549 // Returns the attributes for the MFT.
00550 //-------------------------------------------------------------------
00551
00552 HRESULT CPolarEffect::GetAttributes(IMFAttributes** ppAttributes)
00553 {
00554     if (ppAttributes == NULL)
00555     {
00556         return E_POINTER;
00557     }
00558
00559     EnterCriticalSection(&m_critSec);
00560
00561     *ppAttributes = m_pAttributes;
00562     (*ppAttributes)->AddRef();
00563
00564     LeaveCriticalSection(&m_critSec);
00565     return S_OK;
00566 }
00567
00568
00569 //-------------------------------------------------------------------
00570 // GetInputStreamAttributes
00571 // Returns stream-level attributes for an input stream.
00572 //-------------------------------------------------------------------
00573
00574 HRESULT CPolarEffect::GetInputStreamAttributes(
00575     DWORD           dwInputStreamID,
00576     IMFAttributes   **ppAttributes
00577 )
00578 {
00579     // This MFT does not support any stream-level attributes, so the method is not implemented.
00580     return E_NOTIMPL;
00581 }
00582
00583
00584 //-------------------------------------------------------------------
00585 // GetOutputStreamAttributes
00586 // Returns stream-level attributes for an output stream.
00587 //-------------------------------------------------------------------
00588
00589 HRESULT CPolarEffect::GetOutputStreamAttributes(
00590     DWORD           dwOutputStreamID,
00591     IMFAttributes   **ppAttributes
00592 )
00593 {
00594     // This MFT does not support any stream-level attributes, so the method is not implemented.
00595     return E_NOTIMPL;
00596 }
00597
00598
00599 //-------------------------------------------------------------------
00600 // DeleteInputStream
00601 //-------------------------------------------------------------------
00602
00603 HRESULT CPolarEffect::DeleteInputStream(DWORD dwStreamID)
00604 {
00605     // This MFT has a fixed number of input streams, so the method is not supported.
00606     return E_NOTIMPL;
00607 }
00608
00609
00610 //-------------------------------------------------------------------
00611 // AddInputStreams
00612 //-------------------------------------------------------------------
00613
00614 HRESULT CPolarEffect::AddInputStreams(
00615     DWORD   cStreams,
00616     DWORD   *adwStreamIDs
00617 )
00618 {
00619     // This MFT has a fixed number of output streams, so the method is not supported.
00620     return E_NOTIMPL;
00621 }
00622
00623
00624 //-------------------------------------------------------------------
00625 // GetInputAvailableType
00626 // Returns a preferred input type.
00627 //-------------------------------------------------------------------
00628
00629 HRESULT CPolarEffect::GetInputAvailableType(
00630     DWORD           dwInputStreamID,
00631     DWORD           dwTypeIndex, // 0-based
00632     IMFMediaType    **ppType
00633 )
00634 {
00635     if (ppType == NULL)
00636     {
00637         return E_INVALIDARG;
00638     }
00639
00640     EnterCriticalSection(&m_critSec);
00641
00642     if (!IsValidInputStream(dwInputStreamID))
00643     {
00644         LeaveCriticalSection(&m_critSec);
00645         return MF_E_INVALIDSTREAMNUMBER;
00646     }
00647
00648     HRESULT hr = S_OK;
00649
00650     // If the output type is set, return that type as our preferred input type.
00651     if (m_pOutputType == NULL)
00652     {
00653         // The output type is not set. Create a partial media type.
00654         hr = OnGetPartialType(dwTypeIndex, ppType);
00655     }
00656     else if (dwTypeIndex > 0)
00657     {
00658         hr = MF_E_NO_MORE_TYPES;
00659     }
00660     else
00661     {
00662         *ppType = m_pOutputType;
00663         (*ppType)->AddRef();
00664     }
00665
00666     LeaveCriticalSection(&m_critSec);
00667     return hr;
00668 }
00669
00670
00671
00672 //-------------------------------------------------------------------
00673 // GetOutputAvailableType
00674 // Returns a preferred output type.
00675 //-------------------------------------------------------------------
00676
00677 HRESULT CPolarEffect::GetOutputAvailableType(
00678     DWORD           dwOutputStreamID,
00679     DWORD           dwTypeIndex, // 0-based
00680     IMFMediaType    **ppType
00681 )
00682 {
00683     if (ppType == NULL)
00684     {
00685         return E_INVALIDARG;
00686     }
00687
00688     EnterCriticalSection(&m_critSec);
00689
00690     if (!IsValidOutputStream(dwOutputStreamID))
00691     {
00692         LeaveCriticalSection(&m_critSec);
00693         return MF_E_INVALIDSTREAMNUMBER;
00694     }
00695
00696     HRESULT hr = S_OK;
00697
00698     if (m_pInputType == NULL)
00699     {
00700         // The input type is not set. Create a partial media type.
00701         hr = OnGetPartialType(dwTypeIndex, ppType);
00702     }
00703     else if (dwTypeIndex > 0)
00704     {
00705         hr = MF_E_NO_MORE_TYPES;
00706     }
00707     else
00708     {
00709         *ppType = m_pInputType;
00710         (*ppType)->AddRef();
00711     }
00712
00713     LeaveCriticalSection(&m_critSec);
00714     return hr;
00715 }
00716
00717
00718 //-------------------------------------------------------------------
00719 // SetInputType
00720 //-------------------------------------------------------------------
00721
00722 HRESULT CPolarEffect::SetInputType(
00723     DWORD           dwInputStreamID,
00724     IMFMediaType    *pType, // Can be NULL to clear the input type.
00725     DWORD           dwFlags
00726 )
00727 {
00728     // Validate flags.
00729     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00730     {
00731         return E_INVALIDARG;
00732     }
00733
00734     EnterCriticalSection(&m_critSec);
00735
00736     if (!IsValidInputStream(dwInputStreamID))
00737     {
00738         LeaveCriticalSection(&m_critSec);
00739         return MF_E_INVALIDSTREAMNUMBER;
00740     }
00741
00742     HRESULT hr = S_OK;
00743
00744     // Does the caller want us to set the type, or just test it?
00745     BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);
00746
00747     // If we have an input sample, the client cannot change the type now.
00748     if (HasPendingOutput())
00749     {
00750         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00751         goto done;
00752     }
00753
00754     // Validate the type, if non-NULL.
00755     if (pType)
00756     {
00757         hr = OnCheckInputType(pType);
00758         if (FAILED(hr))
00759         {
00760             goto done;
00761         }
00762     }
00763
00764     // The type is OK. Set the type, unless the caller was just testing.
00765     if (bReallySet)
00766     {
00767         OnSetInputType(pType);
00768
00769         // When the type changes, end streaming.
00770         hr = EndStreaming();
00771     }
00772
00773 done:
00774     LeaveCriticalSection(&m_critSec);
00775     return hr;
00776 }
00777
00778
00779
00780 //-------------------------------------------------------------------
00781 // SetOutputType
00782 //-------------------------------------------------------------------
00783
00784 HRESULT CPolarEffect::SetOutputType(
00785     DWORD           dwOutputStreamID,
00786     IMFMediaType    *pType, // Can be NULL to clear the output type.
00787     DWORD           dwFlags
00788 )
00789 {
00790     // Validate flags.
00791     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00792     {
00793         return E_INVALIDARG;
00794     }
00795
00796     EnterCriticalSection(&m_critSec);
00797
00798     if (!IsValidOutputStream(dwOutputStreamID))
00799     {
00800         LeaveCriticalSection(&m_critSec);
00801         return MF_E_INVALIDSTREAMNUMBER;
00802     }
00803
00804     HRESULT hr = S_OK;
00805
00806     // Does the caller want us to set the type, or just test it?
00807     BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);
00808
00809     // If we have an input sample, the client cannot change the type now.
00810     if (HasPendingOutput())
00811     {
00812         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00813         goto done;
00814     }
00815
00816     // Validate the type, if non-NULL.
00817     if (pType)
00818     {
00819         hr = OnCheckOutputType(pType);
00820         if (FAILED(hr))
00821         {
00822             goto done;
00823         }
00824     }
00825
00826     // The type is OK. Set the type, unless the caller was just testing.
00827     if (bReallySet)
00828     {
00829         OnSetOutputType(pType);
00830
00831         // When the type changes, end streaming.
00832         hr = EndStreaming();
00833     }
00834
00835 done:
00836     LeaveCriticalSection(&m_critSec);
00837     return hr;
00838 }
00839
00840
00841 //-------------------------------------------------------------------
00842 // GetInputCurrentType
00843 // Returns the current input type.
00844 //-------------------------------------------------------------------
00845
00846 HRESULT CPolarEffect::GetInputCurrentType(
00847     DWORD           dwInputStreamID,
00848     IMFMediaType    **ppType
00849 )
00850 {
00851     if (ppType == NULL)
00852     {
00853         return E_POINTER;
00854     }
00855
00856     HRESULT hr = S_OK;
00857
00858     EnterCriticalSection(&m_critSec);
00859
00860     if (!IsValidInputStream(dwInputStreamID))
00861     {
00862         hr = MF_E_INVALIDSTREAMNUMBER;
00863     }
00864     else if (!m_pInputType)
00865     {
00866         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00867     }
00868     else
00869     {
00870         *ppType = m_pInputType;
00871         (*ppType)->AddRef();
00872     }
00873     LeaveCriticalSection(&m_critSec);
00874     return hr;
00875 }
00876
00877
00878 //-------------------------------------------------------------------
00879 // GetOutputCurrentType
00880 // Returns the current output type.
00881 //-------------------------------------------------------------------
00882
00883 HRESULT CPolarEffect::GetOutputCurrentType(
00884     DWORD           dwOutputStreamID,
00885     IMFMediaType    **ppType
00886 )
00887 {
00888     if (ppType == NULL)
00889     {
00890         return E_POINTER;
00891     }
00892
00893     HRESULT hr = S_OK;
00894
00895     EnterCriticalSection(&m_critSec);
00896
00897     if (!IsValidOutputStream(dwOutputStreamID))
00898     {
00899         hr = MF_E_INVALIDSTREAMNUMBER;
00900     }
00901     else if (!m_pOutputType)
00902     {
00903         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00904     }
00905     else
00906     {
00907         *ppType = m_pOutputType;
00908         (*ppType)->AddRef();
00909     }
00910
00911     LeaveCriticalSection(&m_critSec);
00912     return hr;
00913 }
00914
00915
00916 //-------------------------------------------------------------------
00917 // GetInputStatus
00918 // Query if the MFT is accepting more input.
00919 //-------------------------------------------------------------------
00920
00921 HRESULT CPolarEffect::GetInputStatus(
00922     DWORD           dwInputStreamID,
00923     DWORD           *pdwFlags
00924 )
00925 {
00926     if (pdwFlags == NULL)
00927     {
00928         return E_POINTER;
00929     }
00930
00931     EnterCriticalSection(&m_critSec);
00932
00933     if (!IsValidInputStream(dwInputStreamID))
00934     {
00935         LeaveCriticalSection(&m_critSec);
00936         return MF_E_INVALIDSTREAMNUMBER;
00937     }
00938
00939     // If an input sample is already queued, do not accept another sample until the
00940     // client calls ProcessOutput or Flush.
00941
00942     // NOTE: It is possible for an MFT to accept more than one input sample. For
00943     // example, this might be required in a video decoder if the frames do not
00944     // arrive in temporal order. In the case, the decoder must hold a queue of
00945     // samples. For the video effect, each sample is transformed independently, so
00946     // there is no reason to queue multiple input samples.
00947
00948     if (m_pSample == NULL)
00949     {
00950         *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
00951     }
00952     else
00953     {
00954         *pdwFlags = 0;
00955     }
00956
00957     LeaveCriticalSection(&m_critSec);
00958     return S_OK;
00959 }
00960
00961
00962
00963 //-------------------------------------------------------------------
00964 // GetOutputStatus
00965 // Query if the MFT can produce output.
00966 //-------------------------------------------------------------------
00967
00968 HRESULT CPolarEffect::GetOutputStatus(DWORD *pdwFlags)
00969 {
00970     if (pdwFlags == NULL)
00971     {
00972         return E_POINTER;
00973     }
00974
00975     EnterCriticalSection(&m_critSec);
00976
00977     // The MFT can produce an output sample if (and only if) there an input sample.
00978     if (m_pSample != NULL)
00979     {
00980         *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
00981     }
00982     else
00983     {
00984         *pdwFlags = 0;
00985     }
00986
00987     LeaveCriticalSection(&m_critSec);
00988     return S_OK;
00989 }
00990
00991
00992 //-------------------------------------------------------------------
00993 // SetOutputBounds
00994 // Sets the range of time stamps that the MFT will output.
00995 //-------------------------------------------------------------------
00996
00997 HRESULT CPolarEffect::SetOutputBounds(
00998     LONGLONG        hnsLowerBound,
00999     LONGLONG        hnsUpperBound
01000 )
01001 {
01002     // Implementation of this method is optional.
01003     return E_NOTIMPL;
01004 }
01005
01006
01007 //-------------------------------------------------------------------
01008 // ProcessEvent
01009 // Sends an event to an input stream.
01010 //-------------------------------------------------------------------
01011
01012 HRESULT CPolarEffect::ProcessEvent(
01013     DWORD              dwInputStreamID,
01014     IMFMediaEvent      *pEvent
01015 )
01016 {
01017     // This MFT does not handle any stream events, so the method can
01018     // return E_NOTIMPL. This tells the pipeline that it can stop
01019     // sending any more events to this MFT.
01020     return E_NOTIMPL;
01021 }
01022
01023
01024 //-------------------------------------------------------------------
01025 // ProcessMessage
01026 //-------------------------------------------------------------------
01027
01028 HRESULT CPolarEffect::ProcessMessage(
01029     MFT_MESSAGE_TYPE    eMessage,
01030     ULONG_PTR           ulParam
01031 )
01032 {
01033     EnterCriticalSection(&m_critSec);
01034
01035     HRESULT hr = S_OK;
01036
01037     switch (eMessage)
01038     {
01039     case MFT_MESSAGE_COMMAND_FLUSH:
01040         // Flush the MFT.
01041         hr = OnFlush();
01042         break;
01043
01044     case MFT_MESSAGE_COMMAND_DRAIN:
01045         // Drain: Tells the MFT to reject further input until all pending samples are
01046         // processed. That is our default behavior already, so there is nothing to do.
01047         //
01048         // For a decoder that accepts a queue of samples, the MFT might need to drain
01049         // the queue in response to this command.
01050     break;
01051
01052     case MFT_MESSAGE_SET_D3D_MANAGER:
01053         // Sets a pointer to the IDirect3DDeviceManager9 interface.
01054
01055         // The pipeline should never send this message unless the MFT sets the MF_SA_D3D_AWARE
01056         // attribute set to TRUE. Because this MFT does not set MF_SA_D3D_AWARE, it is an error
01057         // to send the MFT_MESSAGE_SET_D3D_MANAGER message to the MFT. Return an error code in
01058         // this case.
01059
01060         // NOTE: If this MFT were D3D-enabled, it would cache the IDirect3DDeviceManager9
01061         // pointer for use during streaming.
01062
01063         hr = E_NOTIMPL;
01064         break;
01065
01066     case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
01067         hr = BeginStreaming();
01068         break;
01069
01070     case MFT_MESSAGE_NOTIFY_END_STREAMING:
01071         hr = EndStreaming();
01072         break;
01073
01074     // The next two messages do not require any action from this MFT.
01075
01076     case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
01077         break;
01078
01079     case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
01080         break;
01081     }
01082
01083     LeaveCriticalSection(&m_critSec);
01084     return hr;
01085 }
01086
01087
01088 //-------------------------------------------------------------------
01089 // ProcessInput
01090 // Process an input sample.
01091 //-------------------------------------------------------------------
01092
01093 HRESULT CPolarEffect::ProcessInput(
01094     DWORD               dwInputStreamID,
01095     IMFSample           *pSample,
01096     DWORD               dwFlags
01097 )
01098 {
01099     // Check input parameters.
01100     if (pSample == NULL)
01101     {
01102         return E_POINTER;
01103     }
01104
01105     if (dwFlags != 0)
01106     {
01107         return E_INVALIDARG; // dwFlags is reserved and must be zero.
01108     }
01109
01110     HRESULT hr = S_OK;
01111
01112     EnterCriticalSection(&m_critSec);
01113
01114     // Validate the input stream number.
01115     if (!IsValidInputStream(dwInputStreamID))
01116     {
01117         hr = MF_E_INVALIDSTREAMNUMBER;
01118         goto done;
01119     }
01120
01121     // Check for valid media types.
01122     // The client must set input and output types before calling ProcessInput.
01123     if (!m_pInputType || !m_pOutputType)
01124     {
01125         hr = MF_E_NOTACCEPTING;
01126         goto done;
01127     }
01128
01129     // Check if an input sample is already queued.
01130     if (m_pSample != NULL)
01131     {
01132         hr = MF_E_NOTACCEPTING;   // We already have an input sample.
01133         goto done;
01134     }
01135
01136     // Initialize streaming.
01137     hr = BeginStreaming();
01138     if (FAILED(hr))
01139     {
01140         goto done;
01141     }
01142
01143     // Cache the sample. We do the actual work in ProcessOutput.
01144     m_pSample = pSample;
01145     pSample->AddRef();  // Hold a reference count on the sample.
01146
01147 done:
01148     LeaveCriticalSection(&m_critSec);
01149     return hr;
01150 }
01151
01152
01153 //-------------------------------------------------------------------
01154 // ProcessOutput
01155 // Process an output sample.
01156 //-------------------------------------------------------------------
01157
01158 HRESULT CPolarEffect::ProcessOutput(
01159     DWORD                   dwFlags,
01160     DWORD                   cOutputBufferCount,
01161     MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
01162     DWORD                   *pdwStatus
01163 )
01164 {
01165     // Check input parameters...
01166
01167     // This MFT does not accept any flags for the dwFlags parameter.
01168
01169     // The only defined flag is MFT_PROCESS_OUTPUT_DISCARD_WHEN_NO_BUFFER. This flag
01170     // applies only when the MFT marks an output stream as lazy or optional. But this
01171     // MFT has no lazy or optional streams, so the flag is not valid.
01172
01173     if (dwFlags != 0)
01174     {
01175         return E_INVALIDARG;
01176     }
01177
01178     if (pOutputSamples == NULL || pdwStatus == NULL)
01179     {
01180         return E_POINTER;
01181     }
01182
01183     // There must be exactly one output buffer.
01184     if (cOutputBufferCount != 1)
01185     {
01186         return E_INVALIDARG;
01187     }
01188
01189     // It must contain a sample.
01190     if (pOutputSamples[0].pSample == NULL)
01191     {
01192         return E_INVALIDARG;
01193     }
01194
01195     HRESULT hr = S_OK;
01196
01197     IMFMediaBuffer *pInput = NULL;
01198     IMFMediaBuffer *pOutput = NULL;
01199
01200     EnterCriticalSection(&m_critSec);
01201
01202     // There must be an input sample available for processing.
01203     if (m_pSample == NULL)
01204     {
01205         hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
01206         goto done;
01207     }
01208
01209     // Initialize streaming.
01210
01211     hr = BeginStreaming();
01212     if (FAILED(hr))
01213     {
01214         goto done;
01215     }
01216
01217     // Get the input buffer.
01218     hr = m_pSample->ConvertToContiguousBuffer(&pInput);
01219     if (FAILED(hr))
01220     {
01221         goto done;
01222     }
01223
01224     // Get the output buffer.
01225     hr = pOutputSamples[0].pSample->ConvertToContiguousBuffer(&pOutput);
01226     if (FAILED(hr))
01227     {
01228         goto done;
01229     }
01230
01231     hr = OnProcessOutput(pInput, pOutput);
01232     if (FAILED(hr))
01233     {
01234         goto done;
01235     }
01236
01237     // Set status flags.
01238     pOutputSamples[0].dwStatus = 0;
01239     *pdwStatus = 0;
01240
01241
01242     // Copy the duration and time stamp from the input sample, if present.
01243
01244     LONGLONG hnsDuration = 0;
01245     LONGLONG hnsTime = 0;
01246
01247     if (SUCCEEDED(m_pSample->GetSampleDuration(&hnsDuration)))
01248     {
01249         hr = pOutputSamples[0].pSample->SetSampleDuration(hnsDuration);
01250         if (FAILED(hr))
01251         {
01252             goto done;
01253         }
01254     }
01255
01256     if (SUCCEEDED(m_pSample->GetSampleTime(&hnsTime)))
01257     {
01258         hr = pOutputSamples[0].pSample->SetSampleTime(hnsTime);
01259     }
01260
01261 done:
01262     SafeRelease(&m_pSample);   // Release our input sample.
01263     SafeRelease(&pInput);
01264     SafeRelease(&pOutput);
01265     LeaveCriticalSection(&m_critSec);
01266     return hr;
01267 }
01268
01269 // PRIVATE METHODS
01270
01271 // All methods that follow are private to this MFT and are not part of the IMFTransform interface.
01272
01273 // Create a partial media type from our list.
01274 //
01275 // dwTypeIndex: Index into the list of peferred media types.
01276 // ppmt:        Receives a pointer to the media type.
01277
01278 HRESULT CPolarEffect::OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt)
01279 {
01280     if (dwTypeIndex >= ARRAYSIZE(g_MediaSubtypes))
01281     {
01282         return MF_E_NO_MORE_TYPES;
01283     }
01284
01285     IMFMediaType *pmt = NULL;
01286
01287     HRESULT hr = MFCreateMediaType(&pmt);
01288     if (FAILED(hr))
01289     {
01290         goto done;
01291     }
01292
01293     hr = pmt->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
01294     if (FAILED(hr))
01295     {
01296         goto done;
01297     }
01298
01299     hr = pmt->SetGUID(MF_MT_SUBTYPE, g_MediaSubtypes[dwTypeIndex]);
01300     if (FAILED(hr))
01301     {
01302         goto done;
01303     }
01304
01305     *ppmt = pmt;
01306     (*ppmt)->AddRef();
01307
01308 done:
01309     SafeRelease(&pmt);
01310     return hr;
01311 }
01312
01313
01314 // Validate an input media type.
01315
01316 HRESULT CPolarEffect::OnCheckInputType(IMFMediaType *pmt)
01317 {
01318     assert(pmt != NULL);
01319
01320     HRESULT hr = S_OK;
01321
01322     // If the output type is set, see if they match.
01323     if (m_pOutputType != NULL)
01324     {
01325         DWORD flags = 0;
01326         hr = pmt->IsEqual(m_pOutputType, &flags);
01327
01328         // IsEqual can return S_FALSE. Treat this as failure.
01329         if (hr != S_OK)
01330         {
01331             hr = MF_E_INVALIDMEDIATYPE;
01332         }
01333     }
01334     else
01335     {
01336         // Output type is not set. Just check this type.
01337         hr = OnCheckMediaType(pmt);
01338     }
01339     return hr;
01340 }
01341
01342
01343 // Validate an output media type.
01344
01345 HRESULT CPolarEffect::OnCheckOutputType(IMFMediaType *pmt)
01346 {
01347     assert(pmt != NULL);
01348
01349     HRESULT hr = S_OK;
01350
01351     // If the input type is set, see if they match.
01352     if (m_pInputType != NULL)
01353     {
01354         DWORD flags = 0;
01355         hr = pmt->IsEqual(m_pInputType, &flags);
01356
01357         // IsEqual can return S_FALSE. Treat this as failure.
01358         if (hr != S_OK)
01359         {
01360             hr = MF_E_INVALIDMEDIATYPE;
01361         }
01362
01363     }
01364     else
01365     {
01366         // Input type is not set. Just check this type.
01367         hr = OnCheckMediaType(pmt);
01368     }
01369     return hr;
01370 }
01371
01372
01373 // Validate a media type (input or output)
01374
01375 HRESULT CPolarEffect::OnCheckMediaType(IMFMediaType *pmt)
01376 {
01377     BOOL bFoundMatchingSubtype = FALSE;
01378
01379     // Major type must be video.
01380     GUID major_type;
01381     HRESULT hr = pmt->GetGUID(MF_MT_MAJOR_TYPE, &major_type);
01382     if (FAILED(hr))
01383     {
01384         goto done;
01385     }
01386
01387     if (major_type != MFMediaType_Video)
01388     {
01389         hr = MF_E_INVALIDMEDIATYPE;
01390         goto done;
01391     }
01392
01393     // Subtype must be one of the subtypes in our global list.
01394
01395     // Get the subtype GUID.
01396     GUID subtype;
01397     hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
01398     if (FAILED(hr))
01399     {
01400         goto done;
01401     }
01402
01403     // Look for the subtype in our list of accepted types.
01404     for (DWORD i = 0; i < ARRAYSIZE(g_MediaSubtypes); i++)
01405     {
01406         if (subtype == g_MediaSubtypes[i])
01407         {
01408             bFoundMatchingSubtype = TRUE;
01409             break;
01410         }
01411     }
01412
01413     if (!bFoundMatchingSubtype)
01414     {
01415         hr = MF_E_INVALIDMEDIATYPE; // The MFT does not support this subtype.
01416         goto done;
01417     }
01418
01419     // Reject single-field media types.
01420     UINT32 interlace = MFGetAttributeUINT32(pmt, MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
01421     if (interlace == MFVideoInterlace_FieldSingleUpper  || interlace == MFVideoInterlace_FieldSingleLower)
01422     {
01423         hr = MF_E_INVALIDMEDIATYPE;
01424     }
01425
01426 done:
01427     return hr;
01428 }
01429
01430
01431 // Set or clear the input media type.
01432 //
01433 // Prerequisite: The input type was already validated.
01434
01435 void CPolarEffect::OnSetInputType(IMFMediaType *pmt)
01436 {
01437     // if pmt is NULL, clear the type.
01438     // if pmt is non-NULL, set the type.
01439
01440     SafeRelease(&m_pInputType);
01441     m_pInputType = pmt;
01442     if (m_pInputType)
01443     {
01444         m_pInputType->AddRef();
01445     }
01446
01447     // Update the format information.
01448     UpdateFormatInfo();
01449 }
01450
01451
01452 // Set or clears the output media type.
01453 //
01454 // Prerequisite: The output type was already validated.
01455
01456 void CPolarEffect::OnSetOutputType(IMFMediaType *pmt)
01457 {
01458     // If pmt is NULL, clear the type. Otherwise, set the type.
01459
01460     SafeRelease(&m_pOutputType);
01461     m_pOutputType = pmt;
01462     if (m_pOutputType)
01463     {
01464         m_pOutputType->AddRef();
01465     }
01466 }
01467
01468
01469 // Initialize streaming parameters.
01470 //
01471 // This method is called if the client sends the MFT_MESSAGE_NOTIFY_BEGIN_STREAMING
01472 // message, or when the client processes a sample, whichever happens first.
01473
01474 HRESULT CPolarEffect::BeginStreaming()
01475 {
01476     HRESULT hr = S_OK;
01477
01478     if (m_pIndexLookup == NULL)
01479     {
01480         UINT32 unVideoArea = m_imageWidthInPixels * m_imageHeightInPixels;
01481
01482         m_pIndexLookup = new UINT32[unVideoArea];
01483
01484         if (m_pIndexLookup != NULL)
01485         {
01486             ZeroMemory( m_pIndexLookup, unVideoArea * sizeof(UINT32) );
01487
01488             GeneratePolarLookup( m_imageWidthInPixels,
01489                                  m_imageHeightInPixels,
01490                                  m_pIndexLookup );
01491         }
01492         else
01493         {
01494             hr = E_OUTOFMEMORY;
01495         }
01496     }
01497
01498     if (SUCCEEDED(hr))
01499     {
01500         m_bStreamingInitialized = true;
01501     }
01502
01503     return hr;
01504 }
01505
01506
01507 // End streaming.
01508
01509 // This method is called if the client sends an MFT_MESSAGE_NOTIFY_END_STREAMING
01510 // message, or when the media type changes. In general, it should be called whenever
01511 // the streaming parameters need to be reset.
01512
01513 HRESULT CPolarEffect::EndStreaming()
01514 {
01515     SafeArrayDelete(&m_pIndexLookup);
01516     m_bStreamingInitialized = false;
01517     return S_OK;
01518 }
01519
01520
01521
01522 // Generate output data.
01523
01524 HRESULT CPolarEffect::OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
01525 {
01526     BYTE *pDest = NULL;         // Destination buffer.
01527     LONG lDestStride = 0;       // Destination stride.
01528
01529     BYTE *pSrc = NULL;          // Source buffer.
01530     LONG lSrcStride = 0;        // Source stride.
01531
01532     // Helper objects to lock the buffers.
01533     VideoBufferLock inputLock(pIn);
01534     VideoBufferLock outputLock(pOut);
01535
01536     // Stride if the buffer does not support IMF2DBuffer
01537     LONG lDefaultStride = 0;
01538
01539     HRESULT hr = GetDefaultStride(m_pInputType, &lDefaultStride);
01540     if (FAILED(hr))
01541     {
01542         goto done;
01543     }
01544
01545     // Lock the input buffer.
01546     hr = inputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pSrc, &lSrcStride);
01547     if (FAILED(hr))
01548     {
01549         goto done;
01550     }
01551
01552     // Lock the output buffer.
01553     hr = outputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pDest, &lDestStride);
01554     if (FAILED(hr))
01555     {
01556         goto done;
01557     }
01558
01559     // Invoke the image transform function.
01560     assert (m_pTransformFn != NULL);
01561     if (m_pTransformFn)
01562     {
01563         (*m_pTransformFn)(m_pIndexLookup, pDest, lDestStride, pSrc, lSrcStride, m_imageWidthInPixels, m_imageHeightInPixels);
01564     }
01565     else
01566     {
01567         hr = E_UNEXPECTED;
01568         goto done;
01569     }
01570
01571
01572     // Set the data size on the output buffer.
01573     hr = pOut->SetCurrentLength(m_cbImageSize);
01574
01575     // The VideoBufferLock class automatically unlocks the buffers.
01576 done:
01577     return hr;
01578 }
01579
01580
01581 // Flush the MFT.
01582
01583 HRESULT CPolarEffect::OnFlush()
01584 {
01585     // For this MFT, flushing just means releasing the input sample.
01586     SafeRelease(&m_pSample);
01587     return S_OK;
01588 }
01589
01590
01591 // Update the format information. This method is called whenever the
01592 // input type is set.
01593
01594 HRESULT CPolarEffect::UpdateFormatInfo()
01595 {
01596     HRESULT hr = S_OK;
01597
01598     GUID subtype = GUID_NULL;
01599
01600     m_imageWidthInPixels = 0;
01601     m_imageHeightInPixels = 0;
01602     m_cbImageSize = 0;
01603
01604     m_pTransformFn = NULL;
01605
01606     if (m_pInputType != NULL)
01607     {
01608         hr = m_pInputType->GetGUID(MF_MT_SUBTYPE, &subtype);
01609         if (FAILED(hr))
01610         {
01611             goto done;
01612         }
01613         if (subtype == MFVideoFormat_YUY2)
01614         {
01615             m_pTransformFn = TransformImage_YUY2;
01616         }
01617         else if (subtype == MFVideoFormat_UYVY)
01618         {
01619             m_pTransformFn = TransformImage_UYVY;
01620         }
01621         else if (subtype == MFVideoFormat_NV12)
01622         {
01623             m_pTransformFn = TransformImage_NV12;
01624         }
01625         else
01626         {
01627             hr = E_UNEXPECTED;
01628             goto done;
01629         }
01630
01631         hr = MFGetAttributeSize(m_pInputType, MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);
01632         if (FAILED(hr))
01633         {
01634             goto done;
01635         }
01636
01637         // Calculate the image size (not including padding)
01638         hr = GetImageSize(subtype.Data1, m_imageWidthInPixels, m_imageHeightInPixels, &m_cbImageSize);
01639     }
01640
01641 done:
01642     return hr;
01643 }
01644
01645
01646 // Create a lookup table which stores the result of polar transformation
01647
01648 // By controlling the radius (m_pRadiusTransformFn) and angle
01649 // (m_pThetaTransformFn) functions, different effects can be created
01650
01651 void CPolarEffect::GeneratePolarLookup(UINT32 unWidth,
01652                                             UINT32 unHeight,
01653                                             UINT32 *pIndexLookup )
01654 {
01655     LONG x, y;
01656     UINT32 *pIndex;
01657     LONG lMaxX, lMaxY;
01658     LONG lHalfWidth, lHalfHeight;
01659     LONG lTransDx, lTransDy;
01660     DOUBLE dRadius, dMaxRadius, dNewRadius;
01661     DOUBLE dTheta, dNewTheta;
01662
01663     assert(m_pRadiusTransformFn != NULL);
01664     assert(m_pThetaTransformFn != NULL);
01665
01666     lMaxX = (LONG)unWidth;
01667     lMaxY = (LONG)unHeight;
01668     lHalfWidth = unWidth / 2;
01669     lHalfHeight = unHeight / 2;
01670     dMaxRadius = floor( sqrtf( static_cast<float>(lHalfWidth*lHalfWidth+lHalfHeight*lHalfHeight) ) );
01671
01672     pIndex = pIndexLookup;
01673
01674     for(y = 0; y < lMaxY; y++)
01675     {
01676         for(x = 0; x < lMaxX; x++)
01677         {
01678             lTransDx = lHalfWidth - x;
01679             lTransDy = lHalfHeight - y;
01680
01681             dRadius = ceil( sqrtf( static_cast<float>(lTransDx*lTransDx + lTransDy*lTransDy) ) );
01682
01683             if( dRadius < dMaxRadius )
01684             {
01685                 dTheta = atan2f( static_cast<float> (lTransDy), static_cast<float> (lTransDx) );
01686
01687                 dNewRadius = m_pRadiusTransformFn(dRadius, dMaxRadius, dTheta);
01688                 dNewTheta = m_pThetaTransformFn(dRadius, dMaxRadius, dTheta);
01689
01690                 lTransDx = lHalfWidth - (LONG)(dNewRadius * cos(dNewTheta));
01691                 lTransDy = lHalfHeight - (LONG)(dNewRadius * sin(dNewTheta));
01692
01693                 if( 0 <= lTransDx && lTransDx < lMaxX &&
01694                     0 <= lTransDy && lTransDy < lMaxY )
01695                 {
01696                     *pIndex++ = lTransDy * lMaxX + lTransDx;
01697                 }
01698                 else
01699                 {
01700                     *pIndex++ = 0;
01701                 }
01702             }
01703             else
01704             {
01705                 *pIndex++ = 0;
01706             }
01707         }
01708     }
01709 }
01710
01711
01712 // Calculate the size of the buffer needed to store the image.
01713
01714 // fcc: The FOURCC code of the video format.
01715
01716 HRESULT GetImageSize(DWORD fcc, UINT32 width, UINT32 height, DWORD* pcbImage)
01717 {
01718     HRESULT hr = S_OK;
01719
01720     switch (fcc)
01721     {
01722     case FOURCC_YUY2:
01723     case FOURCC_UYVY:
01724         // check overflow
01725         if ((width > MAXDWORD / 2) || (width * 2 > MAXDWORD / height))
01726         {
01727             hr = E_INVALIDARG;
01728         }
01729         else
01730         {
01731             // 16 bpp
01732             *pcbImage = width * height * 2;
01733         }
01734         break;
01735
01736     case FOURCC_NV12:
01737         // check overflow
01738         if ((height/2 > MAXDWORD - height) || ((height + height/2) > MAXDWORD / width))
01739         {
01740             hr = E_INVALIDARG;
01741         }
01742         else
01743         {
01744             // 12 bpp
01745             *pcbImage = width * (height + (height/2));
01746         }
01747         break;
01748
01749     default:
01750         hr = E_FAIL;    // Unsupported type.
01751     }
01752     return hr;
01753 }
01754
01755 // Get the default stride for a video format.
01756 HRESULT GetDefaultStride(IMFMediaType *pType, LONG *plStride)
01757 {
01758     LONG lStride = 0;
01759
01760     // Try to get the default stride from the media type.
01761     HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
01762     if (FAILED(hr))
01763     {
01764         // Attribute not set. Try to calculate the default stride.
01765         GUID subtype = GUID_NULL;
01766
01767         UINT32 width = 0;
01768         UINT32 height = 0;
01769
01770         // Get the subtype and the image size.
01771         hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
01772         if (SUCCEEDED(hr))
01773         {
01774             hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
01775         }
01776         if (SUCCEEDED(hr))
01777         {
01778             if (subtype == MFVideoFormat_NV12)
01779             {
01780                 lStride = width;
01781             }
01782             else if (subtype == MFVideoFormat_YUY2 || subtype == MFVideoFormat_UYVY)
01783             {
01784                 lStride = ((width * 2) + 3) & ~3;
01785             }
01786             else
01787             {
01788                 hr = E_INVALIDARG;
01789             }
01790         }
01791
01792         // Set the attribute for later reference.
01793         if (SUCCEEDED(hr))
01794         {
01795             (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
01796         }
01797     }
01798     if (SUCCEEDED(hr))
01799     {
01800         *plStride = lStride;
01801     }
01802     return hr;
01803 }
01804
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWidePeekImageAndText02 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWidePeekImageAndText02, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::TileContent::TileWidePeekImageAndText02 |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBody1 | NotificationsExtensions::TileContent::TileWidePeekImageAndText02 |
TextBody2 | NotificationsExtensions::TileContent::TileWidePeekImageAndText02 |
TextBody3 | NotificationsExtensions::TileContent::TileWidePeekImageAndText02 |
TextBody4 | NotificationsExtensions::TileContent::TileWidePeekImageAndText02 |
TextBody5 | NotificationsExtensions::TileContent::TileWidePeekImageAndText02 |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWidePeekImageAndText02() | NotificationsExtensions::TileContent::TileWidePeekImageAndText02 | [inline]
TileWidePeekImageAndText02() | NotificationsExtensions::TileContent::TileWidePeekImageAndText02 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level.cpp Source File

  • XAML DirectX 3D shooting game

Level.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Level.h"
00010
00011 //----------------------------------------------------------------------
00012
00013 bool Level::Update(
00014     float /* time */,
00015     float /* elapsedTime */,
00016     float /* timeRemaining*/,
00017     std::vector<GameObject^> objects
00018     )
00019 {
00020     int left = 0;
00021
00022     for (auto object = objects.begin(); object != objects.end(); object++)
00023     {
00024         if ((*object)->Active() && (*object)->Target())
00025         {
00026             if ((*object)->Hit())
00027             {
00028                 (*object)->Active(false);
00029             }
00030             else
00031             {
00032                 left++;
00033             }
00034         }
00035     }
00036     return (left == 0);
00037 }
00038
00039 //----------------------------------------------------------------------
00040
00041 void Level::SaveState(PersistentState^ /* state */)
00042 {
00043 }
00044
00045 //----------------------------------------------------------------------
00046
00047 void Level::LoadState(PersistentState^ /* state */)
00048 {
00049 }
00050
00051 //----------------------------------------------------------------------
00052
00053 Platform::String^ Level::Objective()
00054 {
00055     return m_objective;
00056 }
00057
00058 //----------------------------------------------------------------------
00059
00060 float Level::TimeLimit()
00061 {
00062     return m_timeLimit;
00063 }
00064
00065 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/SaveAsImageFileSample.h Source File

  • Direct2D save to image file

SaveAsImageFileSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012
00013 enum class ScreenSavingState
00014 {
00015     NotSaved,
00016     Saving,
00017     Saved
00018 };
00019
00020 ref class SaveAsImageFile : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00021 {
00022 internal:
00023     SaveAsImageFile();
00024
00025     // DirectXBase Methods
00026     virtual void CreateDeviceIndependentResources() override;
00027     virtual void CreateDeviceResources() override;
00028     virtual void Render() override;
00029
00030 public:
00031     // IFrameworkView Methods
00032     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00033     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00034     virtual void Load(_In_ Platform::String^ entryPoint);
00035     virtual void Run();
00036     virtual void Uninitialize();
00037
00038 private:
00039     // Event Handlers
00040     void OnWindowSizeChanged(
00041         _In_ Windows::UI::Core::CoreWindow^ sender,
00042         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00043         );
00044
00045     void OnLogicalDpiChanged(
00046         _In_ Platform::Object^ sender
00047         );
00048
00049     void OnDisplayContentsInvalidated(
00050         _In_ Platform::Object^ sender
00051         );
00052
00053     void OnActivated(
00054         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00055         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00056         );
00057
00058     void OnPointerPressed(
00059         _In_ Windows::UI::Core::CoreWindow^ sender,
00060         _In_ Windows::UI::Core::PointerEventArgs^ args
00061         );
00062
00063     // Sample Methods
00064     void SaveBitmapToFile();
00065     static void SaveBitmapToStream(
00066         _In_ Microsoft::WRL::ComPtr<ID2D1Bitmap1> d2dBitmap,
00067         _In_ Microsoft::WRL::ComPtr<IWICImagingFactory2> wicFactory2,
00068         _In_ Microsoft::WRL::ComPtr<ID2D1DeviceContext> d2dContext,
00069         _In_ REFGUID wicFormat,
00070         _In_ IStream* stream
00071         );
00072
00073     SampleOverlay^                                                  m_sampleOverlay;
00074     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>                    m_blackBrush;
00075     Microsoft::WRL::ComPtr<IDWriteTextFormat>                       m_textFormat;
00076     Microsoft::WRL::ComPtr<IDWriteTextFormat>                       m_snappedViewFormat;
00077     ScreenSavingState                                               m_screenSavingState;
00078     Platform::String^                                               m_imageFileName;
00079     bool                                                            m_isSnapped;
00080 };
00081
00082 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00083 {
00084 public:
00085     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00086 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/common/suspensionmanager.cpp Source File

  • Folder enumeration
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario2.xaml.cpp Source File

  • EAS policies for mail clients

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::EAS;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Security::ExchangeActiveSyncProvisioning;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Foundation::Collections;
00027
00028 Scenario2::Scenario2()
00029 {
00030     InitializeComponent();
00031 }
00032
00033 /// <summary>
00034 /// Invoked when this page is about to be displayed in a Frame.
00035 /// </summary>
00036 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00037 /// property is typically used to configure the page.</param>
00038 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00039 {
00040     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00041     // as NotifyUser()
00042     rootPage = MainPage::Current;
00043 }
00044
00045
00046
00047 void SDKSample::EAS::Scenario2::Launch_Click2(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049   try
00050   {
00051
00052     EasClientSecurityPolicy^ RequestedPolicy = ref new EasClientSecurityPolicy;
00053
00054
00055     if (RequireEncryptionValue1 == nullptr)
00056     {
00057       RequestedPolicy->RequireEncryption=false;
00058     }
00059     else
00060     {
00061       if (RequireEncryptionValue1->IsChecked)
00062         RequestedPolicy->RequireEncryption=true;
00063       else
00064       {
00065         RequestedPolicy->RequireEncryption=false;
00066       }
00067
00068     }
00069
00070     if (MinPasswordLengthValue1==nullptr||MinPasswordLengthValue1->Text=="")
00071       RequestedPolicy->MinPasswordLength = 0;
00072     else
00073     {
00074       RequestedPolicy->MinPasswordLength = _wtoi(MinPasswordLengthValue1->Text->Data());
00075     }
00076
00077     if (DisallowConvenienceLogonValue1 == nullptr)
00078     {
00079       RequestedPolicy->DisallowConvenienceLogon=false;
00080     }
00081     else
00082     {
00083       if (DisallowConvenienceLogonValue1->IsChecked)
00084         RequestedPolicy->DisallowConvenienceLogon=true;
00085       else
00086       {
00087         RequestedPolicy->DisallowConvenienceLogon=false;
00088       }
00089
00090     }
00091
00092     if (MinPasswordComplexCharactersValue1==nullptr||MinPasswordComplexCharactersValue1->Text=="")
00093       RequestedPolicy->MinPasswordComplexCharacters = 0;
00094     else
00095     {
00096       RequestedPolicy->MinPasswordComplexCharacters = _wtoi(MinPasswordComplexCharactersValue1->Text->Data());
00097     }
00098
00099     TimeSpan ExpirationDays;
00100     if (PasswordExpirationValue1==nullptr||PasswordExpirationValue1->Text=="")
00101     {
00102       ExpirationDays.Duration = 0;
00103       RequestedPolicy->PasswordExpiration = ExpirationDays;
00104     }
00105     else
00106     {
00107       ExpirationDays.Duration = _wtoi(PasswordExpirationValue1->Text->Data())*86400000;
00108       RequestedPolicy->PasswordExpiration = ExpirationDays;
00109     }
00110
00111     if (PasswordHistoryValue1==nullptr||PasswordHistoryValue1->Text=="")
00112       RequestedPolicy->PasswordHistory = 0;
00113     else
00114     {
00115       RequestedPolicy->PasswordHistory = _wtoi(PasswordHistoryValue1->Text->Data());
00116     }
00117
00118     if (MaxPasswordFailedAttemptsValue1==nullptr||MaxPasswordFailedAttemptsValue1->Text=="")
00119       RequestedPolicy->MaxPasswordFailedAttempts = 0;
00120     else
00121     {
00122       RequestedPolicy->MaxPasswordFailedAttempts = _wtoi(MaxPasswordFailedAttemptsValue1->Text->Data());
00123     }
00124
00125     TimeSpan Inactiveseconds;
00126     if (MaxInactivityTimeLockValue1==nullptr||MaxInactivityTimeLockValue1->Text=="")
00127     {
00128       Inactiveseconds.Duration=0;
00129       RequestedPolicy->MaxInactivityTimeLock = Inactiveseconds;
00130     }
00131     else
00132     {
00133       Inactiveseconds.Duration=_wtoi(MaxInactivityTimeLockValue1->Text->Data())*1000;
00134       RequestedPolicy->MaxInactivityTimeLock = Inactiveseconds;
00135     }
00136
00137     EasComplianceResults^ CheckResult = RequestedPolicy->CheckCompliance();
00138
00139     RequireEncryptionResult1->Text = CheckResult->RequireEncryptionResult.ToString();
00140     MinPasswordLengthResult1->Text = CheckResult->MinPasswordLengthResult.ToString();
00141     DisallowConvenienceLogonResult1->Text = CheckResult->DisallowConvenienceLogonResult.ToString();
00142     MinPasswordComplexCharactersResult1->Text = CheckResult->MinPasswordComplexCharactersResult.ToString();
00143     PasswordExpirationResult1->Text = CheckResult->PasswordExpirationResult.ToString();
00144     PasswordHistoryResult1->Text = CheckResult->PasswordHistoryResult.ToString();
00145     MaxPasswordFailedAttemptsResult1->Text = CheckResult->MaxPasswordFailedAttemptsResult.ToString();
00146     MaxInactivityTimeLockResult1->Text = CheckResult->MaxInactivityTimeLockResult.ToString();
00147
00148
00149   }
00150
00151   catch (Platform::Exception^ ex)
00152   {
00153     DebugArea->Text += "Error: " +ex->Message;
00154   }
00155
00156 }
00157
00158 void SDKSample::EAS::Scenario2::Reset_Click2(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00159 {
00160   try
00161   {
00162     RequireEncryptionValue1->IsChecked=false;
00163     MinPasswordLengthValue1->Text="";
00164     DisallowConvenienceLogonValue1->IsChecked=false;
00165     MinPasswordComplexCharactersValue1->Text="";
00166     PasswordExpirationValue1->Text="";
00167     PasswordHistoryValue1->Text="";
00168     MaxPasswordFailedAttemptsValue1->Text="";
00169     MaxInactivityTimeLockValue1->Text="";
00170
00171     RequireEncryptionResult1->Text = "";
00172     MinPasswordLengthResult1->Text = "";
00173     DisallowConvenienceLogonResult1->Text = "";
00174     MinPasswordComplexCharactersResult1->Text = "";
00175     PasswordExpirationResult1->Text = "";
00176     PasswordHistoryResult1->Text = "";
00177     MaxPasswordFailedAttemptsResult1->Text = "";
00178     MaxInactivityTimeLockResult1->Text = "";
00179   }
00180   catch(Platform::Exception^ ex)
00181   {
00182     DebugArea->Text += "Error: " +ex->Message;
00183   }
00184 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/common/LayoutAwarePage.cpp Source File

  • Sharing content target app
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013
00014 using namespace ShareTarget::Common;
00015
00016 using namespace Platform;
00017 using namespace Platform::Collections;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Foundation::Collections;
00020 using namespace Windows::UI::ViewManagement;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023
00024 /// <summary>
00025 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00026 /// </summary>
00027 LayoutAwarePage::LayoutAwarePage()
00028 {
00029     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled) return;
00030
00031     // Map application view state to visual state for this page when it is part of the visual tree
00032     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::StartLayoutUpdates);
00033     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::StopLayoutUpdates);
00034
00035     // Establish the default view model as the initial DataContext
00036     DataContext = _defaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00037 }
00038
00039 /// <summary>
00040 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> set as the page's
00041 /// default <see cref="DataContext"/>.  This instance can be bound and surfaces property change
00042 /// notifications making it suitable for use as a trivial view model.
00043 /// </summary>
00044 IObservableMap<Platform::String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00045 {
00046     return _defaultViewModel;
00047 }
00048
00049 /// <summary>
00050 /// Gets a value indicating whether visual states can be a loose interpretation of the actual
00051 /// application view state.  This is often convenient when a page layout is space constrained.
00052 /// </summary>
00053 /// <remarks>
00054 /// The default value of false indicates that the visual state is identical to the view state,
00055 /// meaning that Filled is only used when another application is snapped.  When set to true
00056 /// FullScreenLandscape is used to indicate that at least 1366 virtual pixels of horizontal real
00057 /// estate are available - even if another application is snapped - and Filled indicates a lesser
00058 /// width, even if no other application is snapped.  On a smaller display such as a 1024x768
00059 /// panel this will result in the visual state Filled whenever the device is in landscape
00060 /// orientation.
00061 /// </remarks>
00062 bool LayoutAwarePage::UseFilledStateForNarrowWindow::get()
00063 {
00064     return _useFilledStateForNarrowWindow;
00065 }
00066
00067 /// <summary>
00068 /// Sets a value indicating whether visual states can be a loose interpretation of the actual
00069 /// application view state.  This is often convenient when a page layout is space constrained.
00070 /// </summary>
00071 /// <remarks>
00072 /// The default value of false indicates that the visual state is identical to the view state,
00073 /// meaning that Filled is only used when another application is snapped.  When set to true
00074 /// FullScreenLandscape is used to indicate that at least 1366 virtual pixels of horizontal real
00075 /// estate are available - even if another application is snapped - and Filled indicates a lesser
00076 /// width, even if no other application is snapped.  On a smaller display such as a 1024x768
00077 /// panel this will result in the visual state Filled whenever the device is in landscape
00078 /// orientation.
00079 /// </remarks>
00080 void LayoutAwarePage::UseFilledStateForNarrowWindow::set(bool value)
00081 {
00082     _useFilledStateForNarrowWindow = value;
00083     this->InvalidateVisualState();
00084 }
00085
00086 /// <summary>
00087 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00088 /// until it reaches the top of the navigation stack.
00089 /// </summary>
00090 /// <param name="sender">Instance that triggered the event.</param>
00091 /// <param name="e">Event data describing the conditions that led to the event.</param>
00092 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00093 {
00094     // Use the navigation frame to return to the topmost page
00095     if (Frame != nullptr)
00096     {
00097         while (Frame->CanGoBack) Frame->GoBack();
00098     }
00099 }
00100
00101 /// <summary>
00102 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00103 /// to go back one step on the navigation stack.
00104 /// </summary>
00105 /// <param name="sender">Instance that triggered the event.</param>
00106 /// <param name="e">Event data describing the conditions that led to the event.</param>
00107 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00108 {
00109     // Use the navigation frame to return to the previous page
00110     if (Frame != nullptr && Frame->CanGoBack) Frame->GoBack();
00111 }
00112
00113 /// <summary>
00114 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00115 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00116 /// visual state management changes that correspond to application view state changes.
00117 /// </summary>
00118 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00119 /// corresponding to view states.</param>
00120 /// <param name="e">Event data that describes how the request was made.</param>
00121 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00122 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00123 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00124 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00125 /// events.</remarks>
00126 /// <seealso cref="DetermineVisualState"/>
00127 /// <seealso cref="InvalidateVisualState"/>
00128 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00129 {
00130     auto control = safe_cast<Control^>(sender);
00131     if (_layoutAwareControls == nullptr)
00132     {
00133         // Start listening to view state changes when there are controls interested in updates
00134         _layoutAwareControls = ref new Vector<Control^>();
00135         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00136     }
00137     _layoutAwareControls->Append(control);
00138
00139     // Set the initial visual state of the control
00140     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00141 }
00142
00143 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00144 {
00145     InvalidateVisualState();
00146 }
00147
00148 /// <summary>
00149 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00150 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00151 /// management changes that correspond to application view state changes.
00152 /// </summary>
00153 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00154 /// corresponding to view states.</param>
00155 /// <param name="e">Event data that describes how the request was made.</param>
00156 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00157 /// when layout updates are requested.</remarks>
00158 /// <seealso cref="StartLayoutUpdates"/>
00159 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00160 {
00161     auto control = safe_cast<Control^>(sender);
00162     unsigned int index;
00163     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00164     {
00165         _layoutAwareControls->RemoveAt(index);
00166         if (_layoutAwareControls->Size == 0)
00167         {
00168             // Stop listening to view state changes when no controls are interested in updates
00169             Window::Current->SizeChanged -= _windowSizeEventToken;
00170             _layoutAwareControls = nullptr;
00171         }
00172     }
00173 }
00174
00175 /// <summary>
00176 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00177 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00178 /// override this method to control the mapping scheme used.
00179 /// </summary>
00180 /// <param name="viewState">View state for which a visual state is desired.</param>
00181 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00182 /// <seealso cref="InvalidateVisualState"/>
00183 Platform::String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00184 {
00185     auto actualViewState = viewState;
00186     if (_useFilledStateForNarrowWindow &&
00187         (viewState == ApplicationViewState::Filled ||
00188          viewState == ApplicationViewState::FullScreenLandscape))
00189     {
00190         // Allow pages to request that the Filled state be used only for landscape layouts narrower
00191         // than 1366 virtual pixels
00192         auto windowWidth = Window::Current->Bounds.Width;
00193         actualViewState = windowWidth >= 1366 ? ApplicationViewState::FullScreenLandscape : ApplicationViewState::Filled;
00194     }
00195     switch (actualViewState)
00196     {
00197     case ApplicationViewState::Filled: return "Filled";
00198     case ApplicationViewState::Snapped: return "Snapped";
00199     case ApplicationViewState::FullScreenPortrait: return "FullScreenPortrait";
00200     default: case ApplicationViewState::FullScreenLandscape: return "FullScreenLandscape";
00201     }
00202 }
00203
00204 /// <summary>
00205 /// Updates all controls that are listening for visual state changes with the correct visual
00206 /// state.
00207 /// </summary>
00208 /// <remarks>
00209 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00210 /// signal that a different value may be returned even though the view state has not changed.
00211 /// </remarks>
00212 void LayoutAwarePage::InvalidateVisualState()
00213 {
00214     if (_layoutAwareControls != nullptr)
00215     {
00216         String^ visualState = DetermineVisualState(ApplicationView::Value);
00217         auto controlIterator = _layoutAwareControls->First();
00218         while (controlIterator->HasCurrent)
00219         {
00220             auto control = controlIterator->Current;
00221             VisualStateManager::GoToState(control, visualState, false);
00222             controlIterator->MoveNext();
00223         }
00224     }
00225 }
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ConstantBufferChangesEveryPrim Member List

This is the complete list of members for ConstantBufferChangesEveryPrim, including all inherited members.
diffuseColor | ConstantBufferChangesEveryPrim
meshColor | ConstantBufferChangesEveryPrim
specularColor | ConstantBufferChangesEveryPrim
specularPower | ConstantBufferChangesEveryPrim
worldMatrix | ConstantBufferChangesEveryPrim
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/BasicShapes.h Source File

  • DirectX postcard app

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/common/LayoutAwarePage.h Source File

  • Syndication
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/pch.cpp Source File

  • Playback Manager Companion

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/pch.h Source File

  • DirectX 3D shooting game

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <DirectXMath.h>
00017
00018 #include <xaudio2.h>
00019 #include <xaudio2fx.h>
00020
00021 #include <mmreg.h>
00022 #include <mfidl.h>
00023 #include <mfapi.h>
00024 #include <mfreadwrite.h>
00025
00026 #include <XInput.h>
00027
00028 #include <stdio.h>
00029 #include <vector>
00030 #include <memory>
00031
00032 #include <ppltasks.h>
00033 #include <agile.h>
00034
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Scenario2.xaml.h Source File

  • Accelerometer sensor

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace AccelerometerCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Windows::UI::Core::CoreDispatcher^ dispatcher;
00042             Windows::Devices::Sensors::Accelerometer^ accelerometer;
00043             Windows::Foundation::EventRegistrationToken visibilityToken;
00044             Windows::Foundation::EventRegistrationToken shakenToken;
00045             uint16 shakeCounter;
00046
00047             void VisibilityChanged(Platform::Object^ sender, Windows::UI::Core::VisibilityChangedEventArgs^ e);
00048             void Shaken(Windows::Devices::Sensors::Accelerometer^ sender, Windows::Devices::Sensors::AccelerometerShakenEventArgs^ e);
00049             void ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050             void ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00051         };
00052     }
00053 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/MainPage.xaml.cs Source File

  • Windows Store device app for camera
  • C#,C++

MainPage.xaml.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using System;
00012 using Windows.UI.ViewManagement;
00013 using Windows.UI.Xaml;
00014 using Windows.UI.Xaml.Controls;
00015 using Windows.UI.Xaml.Markup;
00016 using Windows.UI.Xaml.Navigation;
00017
00018
00019 namespace SDKTemplate
00020 {
00021     /// <summary>
00022     /// An empty page that can be used on its own or navigated to within a Frame.
00023     /// </summary>
00024     public sealed partial class MainPage : SDKTemplate.Common.LayoutAwarePage
00025     {
00026         public Windows.ApplicationModel.Activation.LaunchActivatedEventArgs LaunchArgs;
00027
00028         public static MainPage Current;
00029
00030         private Frame HiddenFrame = null;
00031
00032         public MainPage()
00033         {
00034             this.InitializeComponent();
00035
00036             // This is a static public property that will allow downstream pages to get
00037             // a handle to the MainPage instance in order to call methods that are in this class.
00038             Current = this;
00039
00040             // This frame is hidden, meaning it is never shown.  It is simply used to load
00041             // each scenario page and then pluck out the input and output sections and
00042             // place them into the UserControls on the main page.
00043             HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
00044             HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
00045             LayoutRoot.Children.Add(HiddenFrame);
00046
00047             // Populate the sample title from the constant in the GlobalVariables.cs file.
00048             SetFeatureName(FEATURE_NAME);
00049
00050             SizeChanged += MainPage_SizeChanged;
00051
00052         }
00053
00054         void MainPage_SizeChanged(object sender, SizeChangedEventArgs e)
00055         {
00056             InvalidateSize();
00057         }
00058
00059         /// <summary>
00060         /// Invoked when this page is about to be displayed in a Frame.
00061         /// </summary>
00062         /// <param name="e">Event data that describes how this page was reached.  The Parameter
00063         /// property is typically used to configure the page.</param>
00064         protected override void OnNavigatedTo(NavigationEventArgs e)
00065         {
00066             InvalidateViewState();
00067         }
00068
00069         private void InvalidateSize()
00070         {
00071             // Get the window width
00072             double windowWidth = this.ActualWidth;
00073
00074             if (windowWidth != 0.0)
00075             {
00076                 // Get the width of the ContentPanel.
00077                 double contentPanelWidth = ContentPanel.ActualWidth;
00078
00079                 // Is the ContentPanel using any margins that we need to consider?
00080                 double contentPanelMarginLeft = ContentPanel.Margin.Left;
00081                 double contentPanelMarginRight = ContentPanel.Margin.Right;
00082
00083                 // Figure out how much room is left
00084                 double availableWidth = windowWidth;
00085
00086                 // Is the top most child using margins?
00087                 double layoutRootMarginLeft = ContentRoot.Margin.Left;
00088                 double layoutRootMarginRight = ContentRoot.Margin.Right;
00089
00090                 // We have different widths to use depending on the view state
00091                 if (ApplicationView.Value != ApplicationViewState.Snapped)
00092                 {
00093                     // Make us as big as the the left over space
00094                     ContentPanel.Width = ((availableWidth) - (layoutRootMarginLeft + layoutRootMarginRight + contentPanelMarginLeft + contentPanelMarginRight));
00095                 }
00096                 else
00097                 {
00098                     // Make us as big as the left over space
00099                     ContentPanel.Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00100                 }
00101             }
00102             InvalidateViewState();
00103         }
00104
00105         private void InvalidateViewState()
00106         {
00107
00108             if (ApplicationView.Value == ApplicationViewState.Snapped)
00109             {
00110                 Grid.SetRow(FooterPanel, 2);
00111                 Grid.SetColumn(FooterPanel, 0);
00112             }
00113             else
00114             {
00115                 Grid.SetRow(FooterPanel, 1);
00116                 Grid.SetColumn(FooterPanel, 1);
00117             }
00118         }
00119
00120         async void Footer_Click(object sender, RoutedEventArgs e)
00121         {
00122             await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
00123         }
00124
00125         private void SetFeatureName(string str)
00126         {
00127             FeatureName.Text = str;
00128         }
00129     }
00130 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AutoLock Member List

This is the complete list of members for AutoLock, including all inherited members.
_Acquires_lock_(m_pCriticalSection) AutoLock(CritSec &crit) | AutoLock | [inline]
_Acquires_lock_(m_pCriticalSection) AutoLock(CritSec &crit) | AutoLock | [inline]
_Acquires_lock_(m_pCriticalSection) AutoLock(CritSec &crit) | AutoLock | [inline]
_Releases_lock_(m_pCriticalSection)~AutoLock() | AutoLock | [inline]
_Releases_lock_(m_pCriticalSection)~AutoLock() | AutoLock | [inline]
_Releases_lock_(m_pCriticalSection)~AutoLock() | AutoLock | [inline]
m_pCriticalSection | AutoLock | [private]
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKMesh Member List

This is the complete list of members for SDKMesh, including all inherited members.
CheckLoadDone() | SDKMesh |
Create(ID3D11Device *d3dDevice, WCHAR *filename, bool createAdjacencyIndices=false) | SDKMesh | [virtual]
Create(ID3D11Device *d3dDevice, byte *data, uint32 byteCount, bool createAdjacencyIndices=false, bool copyStatic=false) | SDKMesh | [virtual]
CreateFromFile(ID3D11Device *d3dDevice, WCHAR *filename, bool createAdjacencyIndices) | SDKMesh | [protected, virtual]
CreateFromMemory(ID3D11Device *d3dDevice, byte *data, uint32 byteCount, bool createAdjacencyIndices, bool copyStatic) | SDKMesh | [protected, virtual]
CreateIndexBuffer(ID3D11Device *d3dDevice, SDKMESH_INDEX_BUFFER_HEADER *header, void *indices) | SDKMesh | [protected]
CreateVertexBuffer(ID3D11Device *d3dDevice, SDKMESH_VERTEX_BUFFER_HEADER *header, void *vertices) | SDKMesh | [protected]
Destroy() | SDKMesh | [virtual]
FindFrame(char *name) | SDKMesh |
GetAdjacencyIndexBuffer(uint32 mesh) | SDKMesh |
GetAnimationKeyFromTime(double time) | SDKMesh |
GetAnimationProperties(uint32 *numKeys, float *frameTime) | SDKMesh |
GetFrame(uint32 frame) | SDKMesh |
GetIndexBuffer(uint32 mesh) | SDKMesh |
GetIndexBufferAt(uint32 indexBuffer) | SDKMesh |
GetIndexBufferFormat(uint32 mesh) | SDKMesh |
GetIndexType(uint32 mesh) | SDKMesh |
GetInfluenceMatrix(uint32 frameIndex) | SDKMesh |
GetMaterial(uint32 material) | SDKMesh |
GetMesh(uint32 mesh) | SDKMesh |
GetMeshBoundingBoxCenter(uint32 mesh) | SDKMesh |
GetMeshBoundingBoxExtents(uint32 mesh) | SDKMesh |
GetMeshInfluenceMatrix(uint32 mesh, uint32 influence) | SDKMesh |
GetMeshPath() | SDKMesh |
GetNumFrames() | SDKMesh |
GetNumIndexBuffers() | SDKMesh |
GetNumIndices(uint32 mesh) | SDKMesh |
GetNumInfluences(uint32 mesh) | SDKMesh |
GetNumMaterials() | SDKMesh |
GetNumMeshes() | SDKMesh |
GetNumSubsets(uint32 mesh) | SDKMesh |
GetNumVertexBuffers() | SDKMesh |
GetNumVertices(uint32 mesh, uint32 vertexBuffer) | SDKMesh |
GetOutstandingBufferResources() | SDKMesh |
GetOutstandingResources() | SDKMesh |
GetPrimitiveType(SDKMeshPrimitiveType primitiveType) | SDKMesh | [static]
GetRawIndicesAt(uint32 indexBuffer) | SDKMesh |
GetRawVerticesAt(uint32 vertexBuffer) | SDKMesh |
GetSubset(uint32 mesh, uint32 subset) | SDKMesh |
GetVertexBuffer(uint32 mesh, uint32 vertexBuffer) | SDKMesh |
GetVertexBufferAt(uint32 vertexBuffer) | SDKMesh |
GetVertexStride(uint32 mesh, uint32 vertexBuffer) | SDKMesh |
GetWorldMatrix(uint32 frameIndex) | SDKMesh |
HadLoadingError() | SDKMesh |
IsLoaded() | SDKMesh |
IsLoading() | SDKMesh |
LoadAnimation(WCHAR *filename) | SDKMesh | [virtual]
LoadMaterials(ID3D11Device *d3dDevice, _In_reads_(numMaterials) SDKMESH_MATERIAL *materials, uint32 numMaterials) | SDKMesh | [protected]
m_adjacencyIndexBufferArray | SDKMesh | [protected]
m_animationData | SDKMesh | [protected]
m_animationFrameData | SDKMesh | [protected]
m_animationHeader | SDKMesh | [protected]
m_bindPoseFrameMatrices | SDKMesh | [protected]
m_d3dContext | SDKMesh | [private]
m_d3dDevice | SDKMesh | [private]
m_frameArray | SDKMesh | [protected]
m_heapData | SDKMesh | [protected]
m_hFile | SDKMesh | [private]
m_hFileMappingObject | SDKMesh | [private]
m_indexBufferArray | SDKMesh | [protected]
m_indices | SDKMesh | [protected]
m_loading | SDKMesh | [private]
m_materialArray | SDKMesh | [protected]
m_meshArray | SDKMesh | [protected]
m_meshHeader | SDKMesh | [protected]
m_numOutstandingResources | SDKMesh | [private]
m_path | SDKMesh | [protected]
m_staticMeshData | SDKMesh | [protected]
m_subsetArray | SDKMesh | [protected]
m_transformedFrameMatrices | SDKMesh | [protected]
m_vertexBufferArray | SDKMesh | [protected]
m_vertices | SDKMesh | [protected]
m_worldPoseFrameMatrices | SDKMesh | [protected]
Render(ID3D11DeviceContext *d3dContext, UINT diffuseSlot=INVALID_SAMPLER_SLOT, UINT normalSlot=INVALID_SAMPLER_SLOT, UINT specularSlot=INVALID_SAMPLER_SLOT) | SDKMesh | [virtual]
RenderAdjacent(ID3D11DeviceContext *d3dContext, uint32 diffuseSlot=INVALID_SAMPLER_SLOT, uint32 normalSlot=INVALID_SAMPLER_SLOT, uint32 specularSlot=INVALID_SAMPLER_SLOT) | SDKMesh | [virtual]
RenderFrame(uint32 frame, bool adjacent, ID3D11DeviceContext *d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot) | SDKMesh | [protected]
RenderMesh(uint32 meshIndex, bool adjacent, ID3D11DeviceContext *d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot) | SDKMesh | [protected]
SDKMesh() | SDKMesh |
SetLoading(bool loading) | SDKMesh |
TransformBindPose(CXMMATRIX world) | SDKMesh |
TransformBindPoseFrame(uint32 frame, CXMMATRIX parentWorld) | SDKMesh | [protected]
TransformFrame(uint32 frame, CXMMATRIX parentWorld, double time) | SDKMesh | [protected]
TransformFrameAbsolute(uint32 frame, double time) | SDKMesh | [protected]
TransformMesh(CXMMATRIX world, double time) | SDKMesh |
~SDKMesh() | SDKMesh | [virtual]
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CompositeModes Member List

This is the complete list of members for CompositeModes, including all inherited members.
__pad0__ | CompositeModes |
Clamp(float v, float low, float high) | CompositeModes | [inline, private, static]
CreateDeviceIndependentResources() override | CompositeModes | [virtual]
CreateDeviceResources() override | CompositeModes | [virtual]
CreateWindowSizeDependentResources() override | CompositeModes | [virtual]
Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView) | CompositeModes | [virtual]
Load(_In_ Platform::String^entryPoint) | CompositeModes | [virtual]
m_alpha | CompositeModes | [private]
m_appleAlphaEffect | CompositeModes | [private]
m_appleBitmap | CompositeModes | [private]
m_appleEffect | CompositeModes | [private]
m_bananaAlphaEffect | CompositeModes | [private]
m_bananaBitmap | CompositeModes | [private]
m_bananaEffect | CompositeModes | [private]
m_bitmapPixelSize | CompositeModes | [private]
m_blendEffect | CompositeModes | [private]
m_blendModeNames | CompositeModes | [private]
m_blendModeTextLayout | CompositeModes | [private]
m_captionLayouts | CompositeModes | [private]
m_cellSize | CompositeModes | [private]
m_compositeEffect | CompositeModes | [private]
m_compositeModeNames | CompositeModes | [private]
m_compositeModeTextLayout | CompositeModes | [private]
m_contextSize | CompositeModes | [private]
m_drawEnabled | CompositeModes | [private]
m_gestureRecognizer | CompositeModes | [private]
m_headingTextFormat | CompositeModes | [private]
m_horizontalOffset | CompositeModes | [private]
m_imageSize | CompositeModes | [private]
m_sampleOverlay | CompositeModes | [private]
m_scaleEffect | CompositeModes | [private]
m_snappedViewFormat | CompositeModes | [private]
m_textFormat | CompositeModes | [private]
m_whiteBrush | CompositeModes | [private]
OnActivated(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args) | CompositeModes | [private]
OnDisplayContentsInvalidated(_In_ Platform::Object^sender) | CompositeModes | [private]
OnLogicalDpiChanged(_In_ Platform::Object^sender) | CompositeModes | [private]
OnManipulationUpdated(_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^args) | CompositeModes | [private]
OnPointerMoved(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | CompositeModes | [private]
OnPointerPressed(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | CompositeModes | [private]
OnPointerReleased(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | CompositeModes | [private]
OnResuming(_In_ Platform::Object^sender, _In_ Platform::Object^args) | CompositeModes | [private]
OnSuspending(_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args) | CompositeModes | [private]
OnWindowSizeChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args) | CompositeModes | [private]
Render() override | CompositeModes | [virtual]
Run() | CompositeModes | [virtual]
SetWindow(_In_ Windows::UI::Core::CoreWindow^window) | CompositeModes | [virtual]
Uninitialize() | CompositeModes | [virtual]
UpdateAlpha(_In_ float verticalPositionDelta) | CompositeModes | [private]
~CompositeModes() | CompositeModes | [private]
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/App.xaml.cpp Source File

  • Proximity

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "App.xaml.h"
00018 #include "MainPage.xaml.h"
00019
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::ApplicationModel::Activation;
00024 using namespace CppSamplesUtils;
00025 using namespace ProximityCPP;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 App::App()
00029 {
00030     InitializeComponent();
00031     this->Suspending += ref new SuspendingEventHandler(this, &ProximityCPP::App::OnSuspending);
00032 }
00033
00034 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00035 {
00036     auto deferral = pArgs->SuspendingOperation->GetDeferral();
00037     SuspensionManager::StartSaveTask().then([=]()
00038     {
00039         deferral->Complete();
00040     });
00041 }
00042
00043 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00044 {
00045     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00046     {
00047         SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
00048         {
00049             try
00050             {
00051                 restoreTask.get();
00052             }
00053             catch(Platform::Exception^)
00054             {
00055                 // If restore fails, the app should proceed as though there was no restored state.
00056             }
00057
00058             SetupWindowing(pArgs);
00059         });
00060     }
00061     else
00062     {
00063         SetupWindowing(pArgs);
00064     }
00065 }
00066
00067 void App::SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00068 {
00069     TypeName pageType = { "ProximityCPP.MainPage", TypeKind::Custom };
00070     if (Window::Current->Content == nullptr)
00071     {
00072         auto rootFrame = ref new Frame();
00073
00074         rootFrame->Navigate(pageType, pArgs);
00075         Window::Current->Content = rootFrame;
00076     }
00077     else
00078     {
00079         // The app might be executing another scenario
00080         Frame^ rootFrame = safe_cast<Frame^>(Window::Current->Content);
00081         rootFrame->Navigate(pageType, pArgs);
00082     }
00083     Window::Current->Activate();
00084 }
00085
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/common/LayoutAwarePage.cpp Source File

  • Input Touch keyboard
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/pch.h Source File

  • Media extensions

pch.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // pch.h
00010 // Header for standard system include files.
00011 //
00012
00013 #pragma once
00014 #include "CppSamplesUtils.h"
00015 #include <ppltasks.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario5.xaml.h Source File

  • Search contract

Scenario5.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario5.xaml.h
00013 // Declaration of the Scenario5 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario5.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "HttpRequest.h"
00022
00023 #pragma warning(push)
00024 #pragma warning(disable:4451) // Warns about possible invalid marshaling of objects across threads. In this case, the warning doesn't apply because the SearchPane object is only accessed from the UI thread.
00025 namespace SDKSample
00026 {
00027     namespace SearchContract
00028     {
00029         /// <summary>
00030         /// An empty page that can be used on its own or navigated to within a Frame.
00031         /// </summary>
00032         [Windows::Foundation::Metadata::WebHostHidden]
00033         public ref class Scenario5 sealed
00034         {
00035         public:
00036             Scenario5();
00037
00038         protected:
00039             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00040             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00041             void OnSearchPaneSuggestionsRequested(Windows::ApplicationModel::Search::SearchPane^ sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^ e);
00042
00043         private:
00044             Windows::ApplicationModel::Search::SearchPane^ searchPane;
00045             Windows::Foundation::EventRegistrationToken token;
00046             concurrency::cancellation_token_source cts;
00047             Web::HttpRequest httpRequest;
00048         };
00049     }
00050 }
00051 #pragma warning(pop) // Reenable warning 4451
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Constants.h Source File

  • XAML FlipView control

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"XAML FlipView control sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Repository.h Source File

  • Hilo C++
  • Hilo

Repository.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "ObservableQuery.h"
00010
00011 namespace Hilo
00012 {
00013     interface class IPhoto;
00014     interface class IPhotoGroup;
00015     interface class IYearGroup;
00016     class PhotoCache;
00017
00018     // The Repository class provides the app's interface to file system queries.
00019     // See http://go.microsoft.com/fwlink/?LinkId=267277 for more info about this class.
00020     class Repository : public ObservableQuery
00021     {
00022     public:
00023         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhotoGroup^>^> GetMonthGroupedPhotosWithCacheAsync(std::shared_ptr<PhotoCache> photoCache, concurrency::cancellation_token token) = 0;
00024         virtual concurrency::task<IPhoto^> GetSinglePhotoAsync(Platform::String^ photoPath) = 0;
00025         virtual concurrency::task<unsigned int> GetFolderPhotoCountAsync(Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery) = 0;
00026         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> GetPhotoDataForMonthGroup(IPhotoGroup^ photoGroup, Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery, unsigned int maxNumberOfItems) = 0;
00027         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> GetPhotosForDateRangeQueryAsync(Platform::String^ dateRangeQuery) = 0;
00028                 virtual concurrency::task<bool> HasPhotosInRangeAsync(Platform::String^ dateRangeQuery, Windows::Storage::Search::IStorageFolderQueryOperations^ folderQuery) = 0;
00029         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IPhoto^>^> GetPhotosForPictureHubGroupAsync(IPhotoGroup^ photoGroup, unsigned int maxNumberOfItems) = 0;
00030         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<IYearGroup^>^> GetYearGroupedMonthsAsync(concurrency::cancellation_token token) = 0;
00031         virtual concurrency::task<Windows::Foundation::Collections::IVectorView<Windows::Storage::StorageFile^>^> GetPhotoStorageFilesAsync(Platform::String^ query, unsigned int maxNumberOfItems) = 0;
00032         virtual void NotifyAllObservers() = 0;
00033     };
00034 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveUriOutput.xaml.h Source File

  • Association launching

ReceiveUriOutput.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ReceiveUriOutput.xaml.h
00010 // Declaration of the ReceiveUriOutput class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ReceiveUriOutput.g.h"
00017 #include "MainPage.xaml.h"
00018
00019 namespace AssociationLaunching
00020 {
00021   [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class ReceiveUriOutput sealed
00023     {
00024     public:
00025         ReceiveUriOutput();
00026
00027     protected:
00028         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~ReceiveUriOutput();
00033         MainPage^ rootPage;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/D2DTextAnimation.h Source File

  • Direct2D animated text

D2DTextAnimation.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012
00013 inline static float Clamp(float v, float low, float high)
00014 {
00015     return (v < low) ? low : (v > high) ? high : v;
00016 }
00017
00018 ref class D2DTextAnimation : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00019 {
00020 internal:
00021     D2DTextAnimation();
00022
00023     // DirectXBase Methods
00024     virtual void CreateDeviceIndependentResources() override;
00025     virtual void CreateDeviceResources() override;
00026     virtual void Render() override;
00027     void CreateOpacityMask();
00028
00029 public:
00030     // IFrameworkView Methods
00031     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00032     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00033     virtual void Load(_In_ Platform::String^ entryPoint);
00034     virtual void Run();
00035     virtual void Uninitialize();
00036
00037 private:
00038     // Event Handlers
00039     void OnWindowSizeChanged(
00040         _In_ Windows::UI::Core::CoreWindow^ sender,
00041         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00042         );
00043
00044     void OnLogicalDpiChanged(
00045         _In_ Platform::Object^ sender
00046         );
00047
00048     void OnDisplayContentsInvalidated(
00049         _In_ Platform::Object^ sender
00050         );
00051
00052     void OnActivated(
00053         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00054         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00055         );
00056
00057     void OnSuspending(
00058         _In_ Platform::Object^ sender,
00059         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00060         );
00061
00062     void OnPointerPressed(
00063         _In_ Windows::UI::Core::CoreWindow^ window,
00064         _In_ Windows::UI::Core::PointerEventArgs^ args
00065         );
00066
00067     void OnPointerReleased(
00068         _In_ Windows::UI::Core::CoreWindow^ window,
00069         _In_ Windows::UI::Core::PointerEventArgs^ args
00070         );
00071
00072     void OnPointerMoved(
00073         _In_ Windows::UI::Core::CoreWindow^ window,
00074         _In_ Windows::UI::Core::PointerEventArgs^ args
00075         );
00076
00077     void OnPointerWheelChanged(
00078         _In_ Windows::UI::Core::CoreWindow^ window,
00079         _In_ Windows::UI::Core::PointerEventArgs^ args
00080         );
00081
00082     void OnManipulationUpdated(
00083         _In_ Windows::UI::Input::GestureRecognizer^ recognizer,
00084         _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ args
00085         );
00086
00087     void OnManipulationCompleted(
00088         _In_ Windows::UI::Input::GestureRecognizer^ recognizer,
00089         _In_ Windows::UI::Input::ManipulationCompletedEventArgs^ args
00090         );
00091
00092     void OnTapped(
00093         _In_ Windows::UI::Input::GestureRecognizer^ recognizer,
00094         _In_ Windows::UI::Input::TappedEventArgs^ args
00095         );
00096
00097     void DrawTextLayout(
00098         float x,
00099         float y
00100         );
00101
00102     void CalculateCenterPosition();
00103
00104     SampleOverlay^                                          m_sampleOverlay;
00105     Platform::Agile<Windows::UI::Input::GestureRecognizer>  m_gestureRecognizer;
00106     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>            m_blackBrush;
00107     Microsoft::WRL::ComPtr<IDWriteTextFormat>               m_textFormat;
00108     Microsoft::WRL::ComPtr<ID2D1Bitmap1>                    m_opacityBitmap;
00109     Microsoft::WRL::ComPtr<IDWriteTextLayout>               m_textLayout;
00110     DWRITE_TEXT_METRICS                                     m_textMetrics;
00111     Windows::Foundation::Point                              m_viewPosition;
00112     float                                                   m_zoom;
00113     bool                                                    m_animating;
00114     bool                                                    m_firstRun;
00115 };
00116
00117 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00118 {
00119 public:
00120     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00121 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/pch.h Source File

  • File access

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicReaderWriter.cpp Source File

  • Direct3D bump mapping

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/SampleOverlay.h Source File

  • DirectX touch input

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D geometry realization/C++/SampleOverlay.cpp Source File

  • Direct2D geometry realization

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/Common/OpQueue.h Source File

  • Real-time communication
  • MediaExtensions
  • Common

OpQueue.h

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // OpQueue.h
00004 // Async operation queue.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015 #pragma once
00016
00017 #pragma warning( push )
00018 #pragma warning( disable : 4355 )  // 'this' used in base member initializer list
00019
00020 /*
00021     This header file defines an object to help queue and serialize
00022     asynchronous operations.
00023
00024     Background:
00025
00026     To perform an operation asynchronously in Media Foundation, an object
00027     does one of the following:
00028
00029         1. Calls MFPutWorkItem(Ex), using either a standard work queue
00030            identifier or a caller-allocated work queue. The work-queue
00031            thread invokes the object's callback.
00032
00033         2. Creates an async result object (IMFAsyncResult) and calls
00034            MFInvokeCallback to invoke the object's callback.
00035
00036     Ultimately, either of these cause the object's callback to be invoked
00037     from a work-queue thread. The object can then complete the operation
00038     inside the callback.
00039
00040     However, the Media Foundation platform may dispatch async callbacks in
00041     parallel on several threads. Putting an item on a work queue does NOT
00042     guarantee that one operation will complete before the next one starts,
00043     or even that work items will be dispatched in the same order they were
00044     called.
00045
00046     To serialize async operations that should not overlap, an object should
00047     use a queue. While one operation is pending, subsequent operations are
00048     put on the queue, and only dispatched after the previous operation is
00049     complete.
00050
00051     The granularity of a single "operation" depends on the requirements of
00052     that particular object. A single operation might involve several
00053     asynchronous calls before the object dispatches the next operation on
00054     the queue.
00055
00056
00057 */
00058
00059
00060
00061 //-------------------------------------------------------------------
00062 // OpQueue class template
00063 //
00064 // Base class for an async operation queue.
00065 //
00066 // TOperation: The class used to describe operations. This class must
00067 //          implement IUnknown.
00068 //
00069 // The OpQueue class is an abstract class. The derived class must
00070 // implement the following pure-virtual methods:
00071 //
00072 // - IUnknown methods (AddRef, Release, QI)
00073 //
00074 // - DispatchOperation:
00075 //
00076 //      Performs the asynchronous operation specified by pOp.
00077 //
00078 //      At the end of each operation, the derived class must call
00079 //      ProcessQueue to process the next operation in the queue.
00080 //
00081 //      NOTE: An operation is not required to complete inside the
00082 //      DispatchOperation method. A single operation might consist
00083 //      of several asynchronous method calls.
00084 //
00085 // - ValidateOperation:
00086 //
00087 //      Checks whether the object can perform the operation specified
00088 //      by pOp at this time.
00089 //
00090 //      If the object cannot perform the operation now (e.g., because
00091 //      another operation is still in progress) the method should
00092 //      return MF_E_NOTACCEPTING.
00093 //
00094 //-------------------------------------------------------------------
00095 #include "linklist.h"
00096 #include "AsyncCB.h"
00097
00098 template <class T, class TOperation>
00099 class OpQueue //: public IUnknown
00100 {
00101 public:
00102
00103     typedef ComPtrList<TOperation>   OpList;
00104
00105     HRESULT QueueOperation(TOperation *pOp);
00106
00107 protected:
00108
00109     HRESULT ProcessQueue();
00110     HRESULT ProcessQueueAsync(IMFAsyncResult *pResult);
00111
00112     virtual HRESULT DispatchOperation(TOperation *pOp) = 0;
00113     virtual HRESULT ValidateOperation(TOperation *pOp) = 0;
00114
00115     OpQueue(CRITICAL_SECTION& critsec)
00116         : m_OnProcessQueue(static_cast<T *>(this), &OpQueue::ProcessQueueAsync),
00117           m_critsec(critsec)
00118     {
00119     }
00120
00121     virtual ~OpQueue()
00122     {
00123     }
00124
00125 protected:
00126     OpList                  m_OpQueue;         // Queue of operations.
00127     CRITICAL_SECTION&       m_critsec;         // Protects the queue state.
00128     AsyncCallback<T>  m_OnProcessQueue;  // ProcessQueueAsync callback.
00129 };
00130
00131
00132
00133 //-------------------------------------------------------------------
00134 // Place an operation on the queue.
00135 // Public method.
00136 //-------------------------------------------------------------------
00137
00138 template <class T, class TOperation>
00139 HRESULT OpQueue<T, TOperation>::QueueOperation(TOperation *pOp)
00140 {
00141     HRESULT hr = S_OK;
00142
00143     EnterCriticalSection(&m_critsec);
00144
00145     hr = m_OpQueue.InsertBack(pOp);
00146     if (SUCCEEDED(hr))
00147     {
00148         hr = ProcessQueue();
00149     }
00150
00151     LeaveCriticalSection(&m_critsec);
00152     return hr;
00153 }
00154
00155
00156 //-------------------------------------------------------------------
00157 // Process the next operation on the queue.
00158 // Protected method.
00159 //
00160 // Note: This method dispatches the operation to a work queue.
00161 //-------------------------------------------------------------------
00162
00163 template <class T, class TOperation>
00164 HRESULT OpQueue<T, TOperation>::ProcessQueue()
00165 {
00166     HRESULT hr = S_OK;
00167     if (m_OpQueue.GetCount() > 0)
00168     {
00169         hr = MFPutWorkItem2(
00170             MFASYNC_CALLBACK_QUEUE_STANDARD,    // Use the standard work queue.
00171             0,                                  // Default priority
00172             &m_OnProcessQueue,                  // Callback method.
00173             nullptr                             // State object.
00174             );
00175     }
00176     return hr;
00177 }
00178
00179
00180 //-------------------------------------------------------------------
00181 // Process the next operation on the queue.
00182 // Protected method.
00183 //
00184 // Note: This method is called from a work-queue thread.
00185 //-------------------------------------------------------------------
00186
00187 template <class T, class TOperation>
00188 HRESULT OpQueue<T, TOperation>::ProcessQueueAsync(IMFAsyncResult *pResult)
00189 {
00190     HRESULT hr = S_OK;
00191     TOperation *pOp = nullptr;
00192
00193     EnterCriticalSection(&m_critsec);
00194
00195     if (m_OpQueue.GetCount() > 0)
00196     {
00197         hr = m_OpQueue.GetFront(&pOp);
00198
00199         if (SUCCEEDED(hr))
00200         {
00201             hr = ValidateOperation(pOp);
00202         }
00203         if (SUCCEEDED(hr))
00204         {
00205             hr = m_OpQueue.RemoveFront(nullptr);
00206         }
00207         if (SUCCEEDED(hr))
00208         {
00209             (void)DispatchOperation(pOp);
00210         }
00211     }
00212
00213     if (pOp != nullptr)
00214     {
00215         pOp->Release();
00216     }
00217
00218     LeaveCriticalSection(&m_critsec);
00219     return hr;
00220 }
00221
00222 #pragma warning( pop )
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/common/LayoutAwarePage.h Source File

  • Message dialog
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/SearchHomeGroup.xaml.h Source File

  • HomeGroup app

SearchHomeGroup.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SearchHomeGroup.xaml.h
00013 // Declaration of the SearchHomeGroup class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SearchHomeGroup.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace HomeGroup
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class SearchHomeGroup sealed
00031         {
00032         public:
00033             SearchHomeGroup();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Server client/C++/LocateVideo.xaml.h Source File

  • Media Server client

LocateVideo.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "LocateVideo.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::Foundation::Collections;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::Streams;
00025
00026 namespace SDKSample
00027 {
00028     namespace MediaServerClient
00029     {
00030         /// <summary>
00031         /// An empty page that can be used on its own or navigated to within a Frame.
00032         /// </summary>
00033       [Windows::Foundation::Metadata::WebHostHidden]
00034         public ref class Scenario1 sealed
00035         {
00036         public:
00037             Scenario1();
00038
00039         protected:
00040             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00041         private:
00042             MainPage^ rootPage;
00043             void dmsRefreshButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044         void dmsSelect_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00045         void mediaSelect_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00046
00047         IVectorView<StorageFolder^>^ mediaServers;
00048         IVectorView<StorageFile^>^ mediaFiles;
00049         StorageFile^ mediaFile;
00050         IRandomAccessStream^ mediaStream;
00051
00052         void InitializeMediaServers();
00053         void LoadMediaFiles();
00054         void localVideo_MediaFailed(Platform::Object^ sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^ e);
00055         void localVideo_CurrentStateChanged(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00056       };
00057     }
00058 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

FractalBufferElement Member List

This is the complete list of members for FractalBufferElement, including all inherited members.
iteration FractalBufferElement
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/DirectXSample.h Source File

  • DirectX marble maze game

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/Constants.cpp Source File

  • USSD message management

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Request/response", "SDKSample.UssdApi.RequestResponse" }
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendBadge.xaml.cpp Source File

  • App tiles and badges
  • C#,C++

SendBadge.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SendBadge.xaml.cpp
00013 // Implementation of the SendBadge class
00014 //
00015
00016 #include "pch.h"
00017 #include "SendBadge.xaml.h"
00018
00019 using namespace SDKSample::Tiles;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::Notifications;
00025 using namespace NotificationsExtensions::BadgeContent;
00026
00027 SendBadge::SendBadge()
00028 {
00029   InitializeComponent();
00030 }
00031
00032 void SendBadge::OnNavigatedTo(NavigationEventArgs^ e)
00033 {
00034   rootPage = MainPage::Current;
00035   NumberOrGlyph->SelectedIndex = 0;
00036   GlyphList->SelectedIndex = 0;
00037 }
00038
00039 void SendBadge::NumberOrGlyph_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00040 {
00041   if (NumberOrGlyph->SelectedIndex == 0)
00042   {
00043     NumberPanel->Visibility = Windows::UI::Xaml::Visibility::Visible;
00044     GlyphPanel->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00045   }
00046   else
00047   {
00048     NumberPanel->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00049     GlyphPanel->Visibility = Windows::UI::Xaml::Visibility::Visible;
00050   }
00051 }
00052
00053 void SendBadge::UpdateBadge_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00054 {
00055   bool useStrings = false;
00056   if (sender == UpdateBadgeWithStringManipulation)
00057   {
00058     useStrings = true;
00059   }
00060
00061   if (NumberOrGlyph->SelectedIndex == 0)
00062   {
00063     int number = _wtoi(NumberInput->Text->Data());
00064     if (useStrings)
00065     {
00066       UpdateBadgeWithNumberWithStringManipulation(number);
00067     }
00068     else
00069     {
00070       UpdateBadgeWithNumber(number);
00071     }
00072   }
00073   else
00074   {
00075     if (useStrings)
00076     {
00077       UpdateBadgeWithGlyphWithStringManipulation();
00078     }
00079     else
00080     {
00081       UpdateBadgeWithGlyph(GlyphList->SelectedIndex);
00082     }
00083   }
00084 }
00085
00086
00087 void SendBadge::ClearBadge_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00088 {
00089   BadgeUpdateManager::CreateBadgeUpdaterForApplication()->Clear();
00090   OutputTextBlock->Text = "Badge cleared";
00091 }
00092
00093 void SendBadge::UpdateBadgeWithNumber(int number)
00094 {
00095   // Note: usually this would be created with new BadgeGlyphNotificationContent(GlyphValue.Alert) or any of the values of GlyphValue
00096   auto badgeContent = ref new BadgeNumericNotificationContent(number);
00097
00098   // send the notification to the app's application tile
00099   BadgeUpdateManager::CreateBadgeUpdaterForApplication()->Update(badgeContent->CreateNotification());
00100
00101   OutputTextBlock->Text = badgeContent->GetContent();
00102 }
00103
00104 void SendBadge::UpdateBadgeWithGlyph(int glyphIndex)
00105 {
00106   auto badgeContent = ref new BadgeGlyphNotificationContent((GlyphValue)glyphIndex);
00107
00108   // send the notification to the app's application tile
00109   BadgeUpdateManager::CreateBadgeUpdaterForApplication()->Update(badgeContent->CreateNotification());
00110
00111   OutputTextBlock->Text = badgeContent->GetContent();
00112 }
00113
00114 void SendBadge::UpdateBadgeWithNumberWithStringManipulation(int number)
00115 {
00116   // create a string with the badge template xml
00117   auto badgeXmlString = "<badge value='" + number + "'/>";
00118   try
00119   {
00120     // create a DOM
00121     auto badgeDOM = ref new Windows::Data::Xml::Dom::XmlDocument();
00122
00123     // load the xml string into the DOM, catching any invalid xml characters
00124     badgeDOM->LoadXml(badgeXmlString);
00125
00126     // create a badge notification
00127     auto badge = ref new BadgeNotification(badgeDOM);
00128
00129     // Send the notification to the app's application tile
00130     BadgeUpdateManager::CreateBadgeUpdaterForApplication()->Update(badge);
00131
00132     OutputTextBlock->Text = badgeDOM->GetXml();
00133   }
00134   catch (Platform::Exception^)
00135   {
00136     OutputTextBlock->Text = "Error loading the xml, check for invalid characters in the input";
00137   }
00138 }
00139
00140 void SendBadge::UpdateBadgeWithGlyphWithStringManipulation()
00141 {
00142   // create a string with the badge template xml
00143   auto badgeXmlString = "<badge value='" + safe_cast<ComboBoxItem^>(GlyphList->SelectedItem)->Content->ToString() + "'/>";
00144   try
00145   {
00146     // create a DOM
00147     auto badgeDOM = ref new Windows::Data::Xml::Dom::XmlDocument();
00148
00149     // load the xml string into the DOM, catching any invalid xml characters
00150     badgeDOM->LoadXml(badgeXmlString);
00151
00152     // create a badge notification
00153     auto badge = ref new BadgeNotification(badgeDOM);
00154
00155     // Send the notification to the app's application tile
00156     BadgeUpdateManager::CreateBadgeUpdaterForApplication()->Update(badge);
00157
00158     OutputTextBlock->Text = badgeDOM->GetXml();
00159   }
00160   catch (Platform::Exception^)
00161   {
00162     OutputTextBlock->Text = "Error loading the xml, check for invalid characters in the input";
00163   }
00164 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/D2DPageRendererContext.h Source File

  • Direct2Dapp printing

D2DPageRendererContext.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009 #include <DirectXBase.h>
00010 #include <printpreview.h>
00011 #include "SampleOverlay.h"
00012
00013 enum class DrawTypes
00014 {
00015     Rendering,
00016     Preview,
00017     Printing
00018 };
00019
00020 // RAII (Resource Acquisition Is Initialization) class for manually
00021 // acquiring/releasing the D2D lock.
00022 class D2DFactoryLock
00023 {
00024 public:
00025     D2DFactoryLock(_In_ ID2D1Factory* d2dFactory)
00026     {
00027         DX::ThrowIfFailed(
00028             d2dFactory->QueryInterface(IID_PPV_ARGS(&m_d2dMultithread))
00029             );
00030
00031         m_d2dMultithread->Enter();
00032     }
00033
00034     ~D2DFactoryLock()
00035     {
00036         m_d2dMultithread->Leave();
00037     }
00038
00039 private:
00040     Microsoft::WRL::ComPtr<ID2D1Multithread> m_d2dMultithread;
00041 };
00042
00043 // This class is in charge of rendering the contents of the page to an
00044 // arbitrary device context (which may be backed by a D2D bitmap in the case of
00045 // display or print-preview, or a D2D command list in the case of print).
00046 //
00047 // Note: unlike the PageRender class, this class is thread-specific, and hence
00048 // can hold on to both mutable and immutable resources.
00049 //
00050 // To conserve memory, it is preferable to store heavy-weight resources in the
00051 // PageRenderer, and take only a reference to those resources inside
00052 // PageRendererContext.
00053 ref class PageRendererContext
00054 {
00055 internal:
00056     PageRendererContext(
00057         _In_ D2D1_RECT_F targetBox,
00058         _In_ ID2D1DeviceContext* d2dContext,
00059         _In_ DrawTypes type,
00060         _In_ PageRenderer^ pageRenderer
00061         );
00062
00063     void UpdateTargetBox(_In_ D2D1_RECT_F& targetBox);
00064
00065     void Draw(_In_ float scale);
00066
00067     void DrawMessage(_In_ Platform::String^ string);
00068
00069 private:
00070     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00071     Microsoft::WRL::ComPtr<IDWriteTextFormat>       m_textFormat;
00072     Microsoft::WRL::ComPtr<IDWriteTextFormat>       m_messageFormat;
00073     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_blackBrush;
00074
00075     float                                           m_margin;        // The margin size is in DIPs.
00076
00077     D2D1_RECT_F                                     m_targetBox;     // The region that the page contents should be formatted for.
00078
00079     DrawTypes                                       m_type;
00080 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Polar/PolarTransform.idl Source File

  • Media extensions
  • MediaExtensions
  • Polar

PolarTransform.idl

Go to the documentation of this file.
00001 import "Windows.Media.idl";
00002
00003 #include <sdkddkver.h>
00004
00005 namespace PolarTransform
00006 {
00007   [version(NTDDI_WIN8)]
00008   runtimeclass PolarEffect
00009     {
00010     [default] interface Windows.Media.IMediaExtension;
00011   }
00012 }
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/SoundFileReader.h Source File

  • XAudio2 audio file playback

SoundFileReader.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 class SoundFileReader
00011 {
00012     public:
00013         SoundFileReader(_In_ Platform::String^ soundFileName);
00014
00015         Platform::Array<byte>^ GetSoundData() const;
00016         WAVEFORMATEX* GetSoundFormat() const;
00017
00018     private:
00019         Platform::Array<byte>^    m_soundData;
00020         Platform::Array<byte>^    m_soundFormat;
00021 };
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/Constants.cpp Source File

  • Proximity

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace ProximityCPP;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Use PeerFinder to connect to peers", "ProximityCPP.PeerFinderScenario" },
00022     { "Use ProximityDevice to publish and subscribe for messages", "ProximityCPP.ProximityDeviceScenario" },
00023     { "Display ProximityDevice events", "ProximityCPP.ProximityDeviceEvents" }
00024 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/SDKMesh.h Source File

  • DirectX marble maze game

SDKMesh.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // The SDK Mesh format (.sdkmesh) is not a recommended file format for production games.
00010 // It was designed to meet the specific needs of the SDK samples.  Any real-world
00011 // applications should avoid this file format in favor of a destination format that
00012 // meets the specific needs of the application.
00013 //
00014
00015 #pragma once
00016
00017 //--------------------------------------------------------------------------------------
00018 // Hard Defines for the various structures
00019 //--------------------------------------------------------------------------------------
00020 #define SDKMESH_FILE_VERSION 101
00021 #define MAX_VERTEX_ELEMENTS 32
00022 #define MAX_VERTEX_STREAMS 16
00023 #define MAX_FRAME_NAME 100
00024 #define MAX_MESH_NAME 100
00025 #define MAX_SUBSET_NAME 100
00026 #define MAX_MATERIAL_NAME 100
00027 #define MAX_TEXTURE_NAME MAX_PATH
00028 #define MAX_MATERIAL_PATH MAX_PATH
00029 #define INVALID_FRAME ((uint32)-1)
00030 #define INVALID_MESH ((uint32)-1)
00031 #define INVALID_MATERIAL ((uint32)-1)
00032 #define INVALID_SUBSET ((uint32)-1)
00033 #define INVALID_ANIMATION_DATA ((uint32)-1)
00034 #define INVALID_SAMPLER_SLOT ((uint32)-1)
00035 #define ERROR_RESOURCE_VALUE 1
00036
00037 template <typename TYPE> BOOL IsErrorResource(TYPE data)
00038 {
00039     if ((TYPE)ERROR_RESOURCE_VALUE == data) {
00040         return TRUE;
00041     }
00042
00043     return FALSE;
00044 }
00045
00046 #ifndef SAFE_DELETE
00047 #define SAFE_DELETE(p)       { if (p) { delete (p); (p) = nullptr; } }
00048 #endif
00049 #ifndef SAFE_DELETE_ARRAY
00050 #define SAFE_DELETE_ARRAY(p) { if (p) { delete[] (p); (p) = nullptr; } }
00051 #endif
00052 #ifndef SAFE_RELEASE
00053 #define SAFE_RELEASE(p)      { if (p) { (p)->Release(); (p) = nullptr; } }
00054 #endif
00055
00056 //--------------------------------------------------------------------------------------
00057 // Enumerated Types.
00058 //--------------------------------------------------------------------------------------
00059 enum class SDKMeshPrimitiveType
00060 {
00061     TriangleList = 0,
00062     TriangleStrip,
00063     LineList,
00064     LineStrip,
00065     PointList,
00066     TriangleListAdjacent,
00067     TriangleStripAdjacent,
00068     LineListAdjacent,
00069     LineStripAdjacent,
00070     QuadPatchList,
00071     TrianglePatchList,
00072 };
00073
00074 enum class SDKMeshIndexType
00075 {
00076     Bits16 = 0,
00077     Bits32,
00078 };
00079
00080 enum class FrameTransformType
00081 {
00082     Relative = 0,
00083     Absolute,        // This is not currently used but is here to support absolute transformations in the future
00084 };
00085
00086 //--------------------------------------------------------------------------------------
00087 // Structures.  Unions with pointers are forced to 64bit.
00088 //--------------------------------------------------------------------------------------
00089 struct SDKMESH_HEADER
00090 {
00091     // Basic Info and sizes
00092     UINT Version;
00093     BYTE IsBigEndian;
00094     UINT64 HeaderSize;
00095     UINT64 NonBufferDataSize;
00096     UINT64 BufferDataSize;
00097
00098     // Stats
00099     UINT NumVertexBuffers;
00100     UINT NumIndexBuffers;
00101     UINT NumMeshes;
00102     UINT NumTotalSubsets;
00103     UINT NumFrames;
00104     UINT NumMaterials;
00105
00106     // Offsets to Data
00107     UINT64 VertexStreamHeadersOffset;
00108     UINT64 IndexStreamHeadersOffset;
00109     UINT64 MeshDataOffset;
00110     UINT64 SubsetDataOffset;
00111     UINT64 FrameDataOffset;
00112     UINT64 MaterialDataOffset;
00113 };
00114
00115 typedef struct _SDKMESHVERTEXELEMENT
00116 {
00117     WORD    Stream;     // Stream index
00118     WORD    Offset;     // Offset in the stream in bytes
00119     BYTE    Type;       // Data type
00120     BYTE    Method;     // Processing method
00121     BYTE    Usage;      // Semantics
00122     BYTE    UsageIndex; // Semantic index
00123 } SDKMESHVERTEXELEMENT, *LPSDKMESHVERTEXELEMENT;
00124
00125 struct SDKMESH_VERTEX_BUFFER_HEADER
00126 {
00127     UINT64 NumVertices;
00128     UINT64 SizeBytes;
00129     UINT64 StrideBytes;
00130     SDKMESHVERTEXELEMENT Decl[MAX_VERTEX_ELEMENTS];
00131     union
00132     {
00133         UINT64 DataOffset;                // (This also forces the union to 64bits)
00134         ID3D11Buffer* VertexBuffer;
00135     };
00136 };
00137
00138 struct SDKMESH_INDEX_BUFFER_HEADER
00139 {
00140     UINT64 NumIndices;
00141     UINT64 SizeBytes;
00142     UINT32 IndexType;
00143     union
00144     {
00145         UINT64 DataOffset;                // (This also forces the union to 64bits)
00146         ID3D11Buffer* IndexBuffer;
00147     };
00148 };
00149
00150 struct SDKMESH_MESH
00151 {
00152     char Name[MAX_MESH_NAME];
00153     BYTE NumVertexBuffers;
00154     UINT VertexBuffers[MAX_VERTEX_STREAMS];
00155     UINT IndexBuffer;
00156     UINT NumSubsets;
00157     UINT NumFrameInfluences;             // aka bones
00158
00159     XMFLOAT3 BoundingBoxCenter;
00160     XMFLOAT3 BoundingBoxExtents;
00161
00162     union
00163     {
00164         UINT64 SubsetOffset;            // Offset to list of subsets (This also forces the union to 64bits)
00165         UINT* Subsets;                  // Pointer to list of subsets
00166     };
00167     union
00168     {
00169         UINT64 FrameInfluenceOffset;    // Offset to list of frame influences (This also forces the union to 64bits)
00170         UINT* FrameInfluences;          // Pointer to list of frame influences
00171     };
00172 };
00173
00174 struct SDKMESH_SUBSET
00175 {
00176     char Name[MAX_SUBSET_NAME];
00177     UINT MaterialID;
00178     UINT PrimitiveType;
00179     UINT64 IndexStart;
00180     UINT64 IndexCount;
00181     UINT64 VertexStart;
00182     UINT64 VertexCount;
00183 };
00184
00185 struct SDKMESH_FRAME
00186 {
00187     char Name[MAX_FRAME_NAME];
00188     UINT Mesh;
00189     UINT ParentFrame;
00190     UINT ChildFrame;
00191     UINT SiblingFrame;
00192     XMFLOAT4X4 Matrix;
00193     UINT AnimationDataIndex;        // Used to index which set of keyframes transforms this frame
00194 };
00195
00196 struct SDKMESH_MATERIAL
00197 {
00198     char Name[MAX_MATERIAL_NAME];
00199
00200     // Use MaterialInstancePath
00201     char MaterialInstancePath[MAX_MATERIAL_PATH];
00202
00203     // Or fall back to d3d8-type materials
00204     char DiffuseTextureName[MAX_TEXTURE_NAME];
00205     char NormalTextureName[MAX_TEXTURE_NAME];
00206     char SpecularTextureName[MAX_TEXTURE_NAME];
00207
00208     XMFLOAT4 Diffuse;
00209     XMFLOAT4 Ambient;
00210     XMFLOAT4 Specular;
00211     XMFLOAT4 Emissive;
00212     FLOAT Power;
00213
00214     union
00215     {
00216         UINT64 Force64_1;            // Force the union to 64bits
00217         ID3D11Texture2D* DiffuseTexture;
00218     };
00219     union
00220     {
00221         UINT64 Force64_2;            // Force the union to 64bits
00222         ID3D11Texture2D* NormalTexture;
00223     };
00224     union
00225     {
00226         UINT64 Force64_3;            // Force the union to 64bits
00227         ID3D11Texture2D* SpecularTexture;
00228     };
00229
00230     union
00231     {
00232         UINT64 Force64_4;            // Force the union to 64bits
00233         ID3D11ShaderResourceView* DiffuseRV;
00234     };
00235     union
00236     {
00237         UINT64 Force64_5;            // Force the union to 64bits
00238         ID3D11ShaderResourceView* NormalRV;
00239     };
00240     union
00241     {
00242         UINT64 Force64_6;            // Force the union to 64bits
00243         ID3D11ShaderResourceView* SpecularRV;
00244     };
00245 };
00246
00247 struct SDKANIMATION_FILE_HEADER
00248 {
00249     UINT Version;
00250     BYTE IsBigEndian;
00251     UINT FrameTransformType;
00252     UINT NumFrames;
00253     UINT NumAnimationKeys;
00254     UINT AnimationFPS;
00255     UINT64 AnimationDataSize;
00256     UINT64 AnimationDataOffset;
00257 };
00258
00259 struct SDKANIMATION_DATA
00260 {
00261     XMFLOAT3 Translation;
00262     XMFLOAT4 Orientation;
00263     XMFLOAT3 Scaling;
00264 };
00265
00266 struct SDKANIMATION_FRAME_DATA
00267 {
00268     char FrameName[MAX_FRAME_NAME];
00269     union
00270     {
00271         UINT64 DataOffset;
00272         SDKANIMATION_DATA* AnimationData;
00273     };
00274 };
00275
00276 #ifndef _CONVERTER_APP_
00277
00278 //--------------------------------------------------------------------------------------
00279 // SDKMesh class.  This class reads the sdkmesh file format for use by the samples
00280 //--------------------------------------------------------------------------------------
00281 class SDKMesh
00282 {
00283 private:
00284     UINT m_numOutstandingResources;
00285     bool m_loading;
00286     HANDLE m_hFile;
00287     HANDLE m_hFileMappingObject;
00288     ID3D11Device* m_d3dDevice;
00289     ID3D11DeviceContext* m_d3dContext;
00290
00291 protected:
00292     // These are the pointers to the two chunks of data loaded in from the mesh file
00293     BYTE* m_staticMeshData;
00294     BYTE* m_heapData;
00295     BYTE* m_animationData;
00296     BYTE** m_vertices;
00297     BYTE** m_indices;
00298
00299     // Keep track of the path
00300     WCHAR m_path[MAX_PATH];
00301
00302     // General mesh info
00303     SDKMESH_HEADER* m_meshHeader;
00304     SDKMESH_VERTEX_BUFFER_HEADER* m_vertexBufferArray;
00305     SDKMESH_INDEX_BUFFER_HEADER* m_indexBufferArray;
00306     SDKMESH_MESH* m_meshArray;
00307     SDKMESH_SUBSET* m_subsetArray;
00308     SDKMESH_FRAME* m_frameArray;
00309     SDKMESH_MATERIAL* m_materialArray;
00310
00311     // Adjacency information (not part of the m_pStaticMeshData, so it must be created and destroyed separately)
00312     SDKMESH_INDEX_BUFFER_HEADER* m_adjacencyIndexBufferArray;
00313
00314     // Animation
00315     SDKANIMATION_FILE_HEADER* m_animationHeader;
00316     SDKANIMATION_FRAME_DATA* m_animationFrameData;
00317     XMMATRIX* m_bindPoseFrameMatrices;
00318     XMMATRIX* m_transformedFrameMatrices;
00319     XMMATRIX* m_worldPoseFrameMatrices;
00320
00321 protected:
00322     void LoadMaterials(ID3D11Device* d3dDevice, _In_reads_(numMaterials) SDKMESH_MATERIAL* materials, uint32 numMaterials);
00323     HRESULT CreateVertexBuffer(ID3D11Device* d3dDevice, SDKMESH_VERTEX_BUFFER_HEADER* header, void* vertices);
00324     HRESULT CreateIndexBuffer(ID3D11Device* d3dDevice, SDKMESH_INDEX_BUFFER_HEADER* header, void* indices);
00325     virtual HRESULT CreateFromFile(ID3D11Device* d3dDevice, WCHAR* filename, bool createAdjacencyIndices);
00326     virtual HRESULT CreateFromMemory(ID3D11Device* d3dDevice, byte* data, uint32 byteCount, bool createAdjacencyIndices, bool copyStatic);
00327
00328     // frame manipulation
00329     void TransformBindPoseFrame(uint32 frame, CXMMATRIX parentWorld);
00330     void TransformFrame(uint32 frame, CXMMATRIX parentWorld, double time);
00331     void TransformFrameAbsolute(uint32 frame, double time);
00332
00333     // Direct3D rendering helpers
00334     void RenderMesh(uint32 meshIndex, bool adjacent, ID3D11DeviceContext* d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot);
00335     void RenderFrame(uint32 frame, bool adjacent, ID3D11DeviceContext* d3dContext, uint32 diffuseSlot, uint32 normalSlot, uint32 specularSlot);
00336
00337 public:
00338     SDKMesh();
00339     virtual ~SDKMesh();
00340
00341     virtual HRESULT Create(ID3D11Device* d3dDevice, WCHAR* filename, bool createAdjacencyIndices = false);
00342     virtual HRESULT Create(ID3D11Device* d3dDevice, byte* data, uint32 byteCount, bool createAdjacencyIndices = false, bool copyStatic = false);
00343     virtual HRESULT LoadAnimation(WCHAR* filename);
00344     virtual void Destroy();
00345
00346     // Frame manipulation
00347     void TransformBindPose(CXMMATRIX world);
00348     void TransformMesh(CXMMATRIX world, double time);
00349
00350     // Rendering
00351     virtual void Render(
00352         ID3D11DeviceContext* d3dContext,
00353         UINT diffuseSlot = INVALID_SAMPLER_SLOT,
00354         UINT normalSlot = INVALID_SAMPLER_SLOT,
00355         UINT specularSlot = INVALID_SAMPLER_SLOT
00356         );
00357
00358     virtual void RenderAdjacent(
00359         ID3D11DeviceContext* d3dContext,
00360         uint32 diffuseSlot = INVALID_SAMPLER_SLOT,
00361         uint32 normalSlot = INVALID_SAMPLER_SLOT,
00362         uint32 specularSlot = INVALID_SAMPLER_SLOT
00363         );
00364
00365     // Helpers
00366     static D3D11_PRIMITIVE_TOPOLOGY GetPrimitiveType(SDKMeshPrimitiveType primitiveType);
00367     DXGI_FORMAT GetIndexBufferFormat(uint32 mesh);
00368     ID3D11Buffer* GetVertexBuffer(uint32 mesh, uint32 vertexBuffer);
00369     ID3D11Buffer* GetIndexBuffer(uint32 mesh);
00370     SDKMeshIndexType GetIndexType(uint32 mesh);
00371     ID3D11Buffer* GetAdjacencyIndexBuffer(uint32 mesh);
00372     WCHAR* GetMeshPath();
00373     uint32 GetNumMeshes();
00374     uint32 GetNumMaterials();
00375     uint32 GetNumVertexBuffers();
00376     uint32 GetNumIndexBuffers();
00377
00378     ID3D11Buffer* GetVertexBufferAt(uint32 vertexBuffer);
00379     ID3D11Buffer* GetIndexBufferAt(uint32 indexBuffer);
00380
00381     byte* GetRawVerticesAt(uint32 vertexBuffer);
00382     byte* GetRawIndicesAt(uint32 indexBuffer);
00383     SDKMESH_MATERIAL* GetMaterial(uint32 material);
00384     SDKMESH_MESH* GetMesh(uint32 mesh);
00385     uint32 GetNumSubsets(uint32 mesh);
00386     SDKMESH_SUBSET* GetSubset(uint32 mesh, uint32 subset);
00387     uint32 GetVertexStride(uint32 mesh, uint32 vertexBuffer);
00388     uint32 GetNumFrames();
00389     SDKMESH_FRAME* GetFrame(uint32 frame);
00390     SDKMESH_FRAME* FindFrame(char* name);
00391     uint64 GetNumVertices(uint32 mesh, uint32 vertexBuffer);
00392     uint64 GetNumIndices(uint32 mesh);
00393     XMFLOAT3 GetMeshBoundingBoxCenter(uint32 mesh);
00394     XMFLOAT3 GetMeshBoundingBoxExtents(uint32 mesh);
00395     uint32 GetOutstandingResources();
00396     uint32 GetOutstandingBufferResources();
00397     bool CheckLoadDone();
00398     bool IsLoaded();
00399     bool IsLoading();
00400     void SetLoading(bool loading);
00401     bool HadLoadingError();
00402
00403     // Animation
00404     uint32 GetNumInfluences(uint32 mesh);
00405     uint32 GetAnimationKeyFromTime(double time);
00406     bool GetAnimationProperties(uint32* numKeys, float* frameTime);
00407     const CXMMATRIX GetMeshInfluenceMatrix(uint32 mesh, uint32 influence);
00408     const CXMMATRIX GetWorldMatrix(uint32 frameIndex);
00409     const CXMMATRIX GetInfluenceMatrix(uint32 frameIndex);
00410 };
00411
00412 #endif
00413
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/App.xaml.cpp Source File

  • Windows Store device app for camera

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "App.xaml.h"
00018 #include "MainPage.xaml.h"
00019 #include "DeviceAppPage.xaml.h"
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::ApplicationModel;
00024 using namespace Windows::ApplicationModel::Activation;
00025 using namespace CppSamplesUtils;
00026 using namespace DeviceAppForWebcam;
00027 using namespace Windows::UI::Xaml::Interop;
00028
00029 App::App()
00030 {
00031     InitializeComponent();
00032     this->Suspending += ref new SuspendingEventHandler(this, &DeviceAppForWebcam::App::OnSuspending);
00033 }
00034
00035 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00036 {
00037     auto deferral = pArgs->SuspendingOperation->GetDeferral();
00038     SuspensionManager::StartSaveTask().then([=]()
00039     {
00040         deferral->Complete();
00041     });
00042 }
00043
00044 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00045 {
00046     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00047     {
00048         SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
00049         {
00050             try
00051             {
00052                 restoreTask.get();
00053             }
00054             catch(Platform::Exception^)
00055             {
00056                 // If restore fails, the app should proceed as though there was no restored state.
00057             }
00058         });
00059     }
00060     if (Window::Current->Content == nullptr)
00061     {
00062         rootFrame = ref new Frame();
00063         TypeName pageType = { "DeviceAppForWebcam.MainPage", TypeKind::Custom };
00064         rootFrame->Navigate(pageType);
00065         Window::Current->Content = rootFrame;
00066     }
00067     MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
00068     p->LaunchArgs = pArgs;
00069     Window::Current->Activate();
00070 }
00071
00072 void App::OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^ args)
00073 {
00074     if (args->Kind == ActivationKind::CameraSettings)
00075     {
00076         DeviceAppPage^ page = ref new DeviceAppPage();
00077         Window::Current->Content = page;
00078         page->Initialize((CameraSettingsActivatedEventArgs ^)args);
00079
00080         Window::Current->Activate();
00081     }
00082 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Scenario2.xaml.h Source File

  • Application resources and localization

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ApplicationResources
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::ImageBase Member List

This is the complete list of members for Hilo::ImageBase, including all inherited members.
__pad0__ | Hilo::ImageBase | [protected]
GetCustomProperty(Platform::String^name) | Hilo::Common::BindableBase | [virtual]
GetFileNameFromFileSavePickerAsync(Platform::String^fileType) | Hilo::ImageBase | [protected]
GetIndexedProperty(Platform::String^name, Windows::UI::Xaml::Interop::TypeName type) | Hilo::Common::BindableBase | [virtual]
GetStreamWithFailCheck() | Hilo::ImageBase | [protected]
GetStringRepresentation() | Hilo::Common::BindableBase | [virtual]
GoHome() | Hilo::ViewModelBase | [virtual]
GoToPage(PageType page, Platform::Object^parameter) | Hilo::ViewModelBase | [virtual]
LoadState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) | Hilo::ViewModelBase | [virtual]
m_exceptionPolicy | Hilo::ViewModelBase |
m_isAppBarEnabled | Hilo::ViewModelBase |
m_isAppBarOpen | Hilo::ViewModelBase |
m_isAppBarSticky | Hilo::ViewModelBase |
m_photo | Hilo::ImageBase | [protected]
NavigateBack | Hilo::ViewModelBase |
NavigateHome | Hilo::ViewModelBase |
NavigateToPage | Hilo::ViewModelBase |
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) | Hilo::ViewModelBase | [virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) | Hilo::ViewModelBase | [virtual]
PropertyChanged | Hilo::Common::BindableBase |
SaveImageAsync(Windows::Storage::StorageFile^file, Windows::Storage::Streams::IRandomAccessStream^ras) | Hilo::ImageBase | [protected]
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) | Hilo::ViewModelBase | [virtual]
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/RichTextColumns.h Source File

  • Hilo C++
  • Hilo
  • Common

RichTextColumns.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include <collection.h>
00010
00011 namespace Hilo
00012 {
00013   namespace Common
00014   {
00015     /// <summary>
00016     /// Wrapper for <see cref="RichTextBlock"/> that creates as many additional overflow
00017     /// columns as needed to fit the available content.
00018     /// </summary>
00019     /// <example>
00020     /// The following creates a collection of 400-pixel wide columns spaced 50 pixels apart
00021     /// to contain arbitrary data-bound content:
00022     /// <code>
00023     /// <RichTextColumns>
00024     ///     <RichTextColumns.ColumnTemplate>
00025     ///         <DataTemplate>
00026     ///             <RichTextBlockOverflow Width="400" Margin="50,0,0,0"/>
00027     ///         </DataTemplate>
00028     ///     </RichTextColumns.ColumnTemplate>
00029     ///
00030     ///     <RichTextBlock Width="400">
00031     ///         <Paragraph>
00032     ///             <Run Text="{Binding Content}"/>
00033     ///         </Paragraph>
00034     ///     </RichTextBlock>
00035     /// </RichTextColumns>
00036     /// </code>
00037     /// </example>
00038     /// <remarks>Typically used in a horizontally scrolling region where an unbounded amount of
00039     /// space allows for all needed columns to be created.  When used in a vertically scrolling
00040     /// space there will never be any additional columns.</remarks>
00041     [Windows::UI::Xaml::Markup::ContentProperty(Name = "RichTextContent")]
00042     [Windows::Foundation::Metadata::WebHostHidden]
00043     public ref class RichTextColumns sealed : Windows::UI::Xaml::Controls::Panel
00044     {
00045     public:
00046       RichTextColumns();
00047       static property Windows::UI::Xaml::DependencyProperty^ RichTextContentProperty
00048       {
00049         Windows::UI::Xaml::DependencyProperty^ get();
00050       };
00051       static property Windows::UI::Xaml::DependencyProperty^ ColumnTemplateProperty
00052       {
00053         Windows::UI::Xaml::DependencyProperty^ get();
00054       }
00055       property Windows::UI::Xaml::DataTemplate^ ColumnTemplate
00056       {
00057         Windows::UI::Xaml::DataTemplate^ get() { return safe_cast<Windows::UI::Xaml::DataTemplate^>(GetValue(ColumnTemplateProperty)); }
00058         void set(Windows::UI::Xaml::DataTemplate^ value) { SetValue(ColumnTemplateProperty, value); }
00059       };
00060       property Windows::UI::Xaml::Controls::RichTextBlock^ RichTextContent
00061       {
00062         Windows::UI::Xaml::Controls::RichTextBlock^ get() { return safe_cast<Windows::UI::Xaml::Controls::RichTextBlock^>(GetValue(RichTextContentProperty)); }
00063         void set(Windows::UI::Xaml::Controls::RichTextBlock^ value) { SetValue(RichTextContentProperty, value); }
00064       };
00065
00066     protected:
00067       virtual Windows::Foundation::Size MeasureOverride(Windows::Foundation::Size availableSize) override;
00068       virtual Windows::Foundation::Size ArrangeOverride(Windows::Foundation::Size finalSize) override;
00069
00070     internal:
00071       static void ResetOverflowLayout(Windows::UI::Xaml::DependencyObject^ d, Windows::UI::Xaml::DependencyPropertyChangedEventArgs^ e);
00072
00073     private:
00074       Platform::Collections::Vector<Windows::UI::Xaml::Controls::RichTextBlockOverflow^>^ _overflowColumns;
00075     };
00076   }
00077 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DirectX::DDS_PIXELFORMAT Member List

This is the complete list of members for DirectX::DDS_PIXELFORMAT, including all inherited members.
dwABitMask | DirectX::DDS_PIXELFORMAT
dwBBitMask | DirectX::DDS_PIXELFORMAT
dwFlags | DirectX::DDS_PIXELFORMAT
dwFourCC | DirectX::DDS_PIXELFORMAT
dwGBitMask | DirectX::DDS_PIXELFORMAT
dwRBitMask | DirectX::DDS_PIXELFORMAT
dwRGBBitCount | DirectX::DDS_PIXELFORMAT
dwSize | DirectX::DDS_PIXELFORMAT
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CountdownTimer Member List

This is the complete list of members for CountdownTimer, including all inherited members.
CalculateSize() | TextElement | [protected, virtual]
CountdownTimer() | CountdownTimer |
CreateTextLayout() | TextElement | [protected]
ElementBase() | ElementBase | [protected]
FadeOut(float fadeOutTime) | TextElement |
GetBounds() | ElementBase |
GetTextStyle() | TextElement | [inline]
Initialize() | CountdownTimer | [virtual]
IsCountdownComplete() const | CountdownTimer |
IsVisible() const | ElementBase | [inline]
m_alignment | ElementBase | [protected]
m_container | ElementBase | [protected]
m_elapsedTime | CountdownTimer | [protected]
m_fadeOutTime | TextElement | [protected]
m_fadeOutTimeElapsed | TextElement | [protected]
m_fadeStartingOpacity | TextElement | [protected]
m_isFadingOut | TextElement | [protected]
m_secondsRemaining | CountdownTimer | [protected]
m_shadowColorBrush | TextElement | [protected]
m_size | ElementBase | [protected]
m_text | TextElement | [protected]
m_textColorBrush | TextElement | [protected]
m_textExtents | TextElement | [protected]
m_textLayout | TextElement | [protected]
m_textStyle | TextElement | [protected]
m_visible | ElementBase | [protected]
Render() | CountdownTimer | [virtual]
SetAlignment(AlignType horizontal, AlignType vertical) | ElementBase |
SetContainer(const D2D1_RECT_F &container) | ElementBase | [virtual]
SetText(__nullterminated WCHAR *text) | TextElement |
SetText(Platform::String^text) | TextElement |
SetTextColor(const D2D1_COLOR_F &textColor) | TextElement |
SetTextOpacity(float textOpacity) | TextElement |
SetVisible(bool visible) | ElementBase |
StartCountdown(int seconds) | CountdownTimer |
TextElement() | TextElement |
Update(float timeTotal, float timeDelta) | CountdownTimer | [virtual]
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DirectX::Rect Member List

This is the complete list of members for DirectX::Rect, including all inherited members.
h | DirectX::Rect |
Rect() | DirectX::Rect | [inline]
Rect(size_t _x, size_t _y, size_t _w, size_t _h) | DirectX::Rect | [inline]
w | DirectX::Rect |
x | DirectX::Rect |
y | DirectX::Rect |
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/common/suspensionmanager.h Source File

  • Custom driver access
  • app_cpp
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/common/suspensionmanager.h Source File

  • XAML Popup
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/common/LayoutAwarePage.cpp Source File

  • XAML animation library
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Scenario2.xaml.h Source File

  • Inclinometer sensor

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace InclinometerCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Windows::UI::Core::CoreDispatcher^ dispatcher;
00042             Windows::Devices::Sensors::Inclinometer^ inclinometer;
00043             Windows::Foundation::EventRegistrationToken visibilityToken;
00044             uint32 desiredReportInterval;
00045             Windows::UI::Xaml::DispatcherTimer^ dispatcherTimer;
00046
00047             void VisibilityChanged(Platform::Object^ sender, Windows::UI::Core::VisibilityChangedEventArgs^ e);
00048             void DisplayCurrentReading(Platform::Object^ sender, Platform::Object^ e);
00049             void ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050             void ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00051         };
00052     }
00053 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario4.xaml.h Source File

  • File access

Scenario4.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FileAccess
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario4 sealed
00030         {
00031         public:
00032             Scenario4();
00033
00034         private:
00035             MainPage^ rootPage;
00036
00037             void WriteToStreamButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038             void ReadFromStreamButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/common/suspensionmanager.h Source File

  • Globalization preferences
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/BasicReaderWriter.h Source File

  • Direct3D tutorial
  • Lesson3.Cubes

BasicReaderWriter.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <ppltasks.h>
00011
00012 // A simple reader/writer class that provides support for reading and writing
00013 // files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicReaderWriter
00015 {
00016 private:
00017     Windows::Storage::StorageFolder^ m_location;
00018     Platform::String^ m_locationPath;
00019
00020 internal:
00021     BasicReaderWriter();
00022     BasicReaderWriter(
00023         _In_ Windows::Storage::StorageFolder^ folder
00024         );
00025
00026     Platform::Array<byte>^ ReadData(
00027         _In_ Platform::String^ filename
00028         );
00029
00030     concurrency::task<Platform::Array<byte>^> ReadDataAsync(
00031         _In_ Platform::String^ filename
00032         );
00033
00034     uint32 WriteData(
00035         _In_ Platform::String^ filename,
00036         _In_ const Platform::Array<byte>^ fileData
00037         );
00038
00039     concurrency::task<void> WriteDataAsync(
00040         _In_ Platform::String^ filename,
00041         _In_ const Platform::Array<byte>^ fileData
00042         );
00043 };
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SecondaryTiles::sealed Member List

This is the complete list of members for SecondaryTiles::sealed, including all inherited members.
__pad0__ | SecondaryTiles::sealed | [protected]
App() | SecondaryTiles::sealed |
appBar | SecondaryTiles::sealed | [private]
appBarOpenedToken | SecondaryTiles::sealed | [private]
autoSizeInputSectionWhenSnapped | SecondaryTiles::sealed | [private]
BottomAppBar_Opened(Platform::Object^sender, Platform::Object^e) | SecondaryTiles::sealed | [private]
Button_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
buttonClickToken | SecondaryTiles::sealed | [private]
EnumerateSecondaryTiles_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
EnumerateTiles() | SecondaryTiles::sealed |
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
hiddenFrame | SecondaryTiles::sealed | [private]
Init() | SecondaryTiles::sealed | [private]
InvalidateSize() | SecondaryTiles::sealed | [private]
InvalidateViewState() | SecondaryTiles::sealed | [private]
LaunchedFromSecondaryTile() | SecondaryTiles::sealed |
LoadScenario(Platform::String^scenarioName) | SecondaryTiles::sealed |
MainPage() | SecondaryTiles::sealed |
MainPage_Loaded(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [protected]
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | SecondaryTiles::sealed | [protected]
MainPageResized | SecondaryTiles::sealed |
NavigateToLaunchedFromSecondaryTile() | SecondaryTiles::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | SecondaryTiles::sealed |
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | SecondaryTiles::sealed | [virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^e) override | SecondaryTiles::sealed | [protected, virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | SecondaryTiles::sealed | [virtual]
PinButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
PinFromAppbar() | SecondaryTiles::sealed |
PinLiveTile_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
PinTile() | SecondaryTiles::sealed |
pinToAppBar | SecondaryTiles::sealed | [private]
PopulateScenarios() | SecondaryTiles::sealed | [private]
rightPanel | SecondaryTiles::sealed | [private]
rootFrame | SecondaryTiles::sealed | [private]
rootPage | SecondaryTiles::sealed | [private]
scenarioList | SecondaryTiles::sealed | [private]
ScenarioLoaded | SecondaryTiles::sealed |
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SecondaryTiles::sealed | [protected]
SecondaryTileNotification() | SecondaryTiles::sealed |
SendBadgeNotification_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
SendBadgeNotificationWithStringManipulation_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
SendTileNotification_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
SendTileNotificationWithStringManipulation_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
SetSecondaryTiles(Platform::String^strFeature) | SecondaryTiles::sealed | [private]
TileExists_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
TilePinned() | SecondaryTiles::sealed |
ToggleAppBarButton(bool showPinButton) | SecondaryTiles::sealed | [private]
ToggleButtons(bool isEnabled) | SecondaryTiles::sealed | [private]
UnpinSecondaryTile_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
UnpinTile() | SecondaryTiles::sealed |
UpdateAsync() | SecondaryTiles::sealed |
UpdateDefaultLogo_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SecondaryTiles::sealed | [private]
~MainPage() | SecondaryTiles::sealed | [private]
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Wrapper/SampleMft0.h Source File

  • Windows Store device app for camera
  • Wrapper

SampleMft0.h

Go to the documentation of this file.
00001
00002
00003 /* this ALWAYS GENERATED file contains the definitions for the interfaces */
00004
00005
00006  /* File created by MIDL compiler version 8.00.0591 */
00007 /* @@MIDL_FILE_HEADING(  ) */
00008
00009 #pragma warning( disable: 4049 )  /* more than 64k source lines */
00010
00011
00012 /* verify that the <rpcndr.h> version is high enough to compile this file*/
00013 #ifndef __REQUIRED_RPCNDR_H_VERSION__
00014 #define __REQUIRED_RPCNDR_H_VERSION__ 500
00015 #endif
00016
00017 /* verify that the <rpcsal.h> version is high enough to compile this file*/
00018 #ifndef __REQUIRED_RPCSAL_H_VERSION__
00019 #define __REQUIRED_RPCSAL_H_VERSION__ 100
00020 #endif
00021
00022 #include "rpc.h"
00023 #include "rpcndr.h"
00024
00025 #ifndef __RPCNDR_H_VERSION__
00026 #error this stub requires an updated version of <rpcndr.h>
00027 #endif // __RPCNDR_H_VERSION__
00028
00029 #ifndef COM_NO_WINDOWS_H
00030 #include "windows.h"
00031 #include "ole2.h"
00032 #endif /*COM_NO_WINDOWS_H*/
00033
00034 #ifndef __samplemft0_h__
00035 #define __samplemft0_h__
00036
00037 #if defined(_MSC_VER) && (_MSC_VER >= 1020)
00038 #pragma once
00039 #endif
00040
00041 /* Forward Declarations */
00042
00043 #ifndef __IMft0_FWD_DEFINED__
00044 #define __IMft0_FWD_DEFINED__
00045 typedef interface IMft0 IMft0;
00046
00047 #endif  /* __IMft0_FWD_DEFINED__ */
00048
00049
00050 #ifndef __Mft0_FWD_DEFINED__
00051 #define __Mft0_FWD_DEFINED__
00052
00053 #ifdef __cplusplus
00054 typedef class Mft0 Mft0;
00055 #else
00056 typedef struct Mft0 Mft0;
00057 #endif /* __cplusplus */
00058
00059 #endif  /* __Mft0_FWD_DEFINED__ */
00060
00061
00062 /* header files for imported files */
00063 #include "oaidl.h"
00064 #include "ocidl.h"
00065 #include "Inspectable.h"
00066 #include "mftransform.h"
00067
00068 #ifdef __cplusplus
00069 extern "C"{
00070 #endif
00071
00072
00073 #ifndef __IMft0_INTERFACE_DEFINED__
00074 #define __IMft0_INTERFACE_DEFINED__
00075
00076 /* interface IMft0 */
00077 /* [unique][nonextensible][oleautomation][uuid][object] */
00078
00079
00080 EXTERN_C const IID IID_IMft0;
00081
00082 #if defined(__cplusplus) && !defined(CINTERFACE)
00083
00084     MIDL_INTERFACE("F5208B72-A37A-457E-A309-AE3060780E21")
00085     IMft0 : public IUnknown
00086     {
00087     public:
00088         virtual /* [id] */ HRESULT STDMETHODCALLTYPE UpdateDsp(
00089             /* [in] */ UINT32 uiPercentOfScreen) = 0;
00090
00091         virtual /* [id] */ HRESULT STDMETHODCALLTYPE Enable( void) = 0;
00092
00093         virtual /* [id] */ HRESULT STDMETHODCALLTYPE Disable( void) = 0;
00094
00095         virtual /* [id] */ HRESULT STDMETHODCALLTYPE GetDspSetting(
00096             /* [out] */ __RPC__out UINT *puiPercentOfScreen,
00097             /* [out] */ __RPC__out BOOL *pIsEnabled) = 0;
00098
00099     };
00100
00101
00102 #else   /* C style interface */
00103
00104     typedef struct IMft0Vtbl
00105     {
00106         BEGIN_INTERFACE
00107
00108         HRESULT ( STDMETHODCALLTYPE *QueryInterface )(
00109             __RPC__in IMft0 * This,
00110             /* [in] */ __RPC__in REFIID riid,
00111             /* [annotation][iid_is][out] */
00112             __RPC__deref_out _Result_nullonfailure_  void **ppvObject);
00113
00114         ULONG ( STDMETHODCALLTYPE *AddRef )(
00115             __RPC__in IMft0 * This);
00116
00117         ULONG ( STDMETHODCALLTYPE *Release )(
00118             __RPC__in IMft0 * This);
00119
00120         /* [id] */ HRESULT ( STDMETHODCALLTYPE *UpdateDsp )(
00121             __RPC__in IMft0 * This,
00122             /* [in] */ UINT32 uiPercentOfScreen);
00123
00124         /* [id] */ HRESULT ( STDMETHODCALLTYPE *Enable )(
00125             __RPC__in IMft0 * This);
00126
00127         /* [id] */ HRESULT ( STDMETHODCALLTYPE *Disable )(
00128             __RPC__in IMft0 * This);
00129
00130         /* [id] */ HRESULT ( STDMETHODCALLTYPE *GetDspSetting )(
00131             __RPC__in IMft0 * This,
00132             /* [out] */ __RPC__out UINT *puiPercentOfScreen,
00133             /* [out] */ __RPC__out BOOL *pIsEnabled);
00134
00135         END_INTERFACE
00136     } IMft0Vtbl;
00137
00138     interface IMft0
00139     {
00140         CONST_VTBL struct IMft0Vtbl *lpVtbl;
00141     };
00142
00143
00144
00145 #ifdef COBJMACROS
00146
00147
00148 #define IMft0_QueryInterface(This,riid,ppvObject) \
00149     ( (This)->lpVtbl -> QueryInterface(This,riid,ppvObject) )
00150
00151 #define IMft0_AddRef(This)  \
00152     ( (This)->lpVtbl -> AddRef(This) )
00153
00154 #define IMft0_Release(This) \
00155     ( (This)->lpVtbl -> Release(This) )
00156
00157
00158 #define IMft0_UpdateDsp(This,uiPercentOfScreen) \
00159     ( (This)->lpVtbl -> UpdateDsp(This,uiPercentOfScreen) )
00160
00161 #define IMft0_Enable(This)  \
00162     ( (This)->lpVtbl -> Enable(This) )
00163
00164 #define IMft0_Disable(This) \
00165     ( (This)->lpVtbl -> Disable(This) )
00166
00167 #define IMft0_GetDspSetting(This,puiPercentOfScreen,pIsEnabled) \
00168     ( (This)->lpVtbl -> GetDspSetting(This,puiPercentOfScreen,pIsEnabled) )
00169
00170 #endif /* COBJMACROS */
00171
00172
00173 #endif  /* C style interface */
00174
00175
00176
00177
00178 #endif  /* __IMft0_INTERFACE_DEFINED__ */
00179
00180
00181
00182 #ifndef __SampleMft0Lib_LIBRARY_DEFINED__
00183 #define __SampleMft0Lib_LIBRARY_DEFINED__
00184
00185 /* library SampleMft0Lib */
00186 /* [version][uuid] */
00187
00188
00189 EXTERN_C const IID LIBID_SampleMft0Lib;
00190
00191 EXTERN_C const CLSID CLSID_Mft0;
00192
00193 #ifdef __cplusplus
00194
00195 class DECLSPEC_UUID("7BB640D9-33A4-4759-B290-F41A31DCF848")
00196 Mft0;
00197 #endif
00198 #endif /* __SampleMft0Lib_LIBRARY_DEFINED__ */
00199
00200 /* Additional Prototypes for ALL interfaces */
00201
00202 /* end of Additional Prototypes */
00203
00204 #ifdef __cplusplus
00205 }
00206 #endif
00207
00208 #endif
00209
00210
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario1.xaml.cpp Source File

  • XAML ListView and GridView essentials

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::ListViewSimple;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Foundation::Collections;
00027 using namespace Windows::Graphics::Display;
00028 using namespace Windows::UI::ViewManagement;
00029 using namespace Windows::UI::Xaml::Controls::Primitives;
00030 using namespace Windows::UI::Xaml::Data;
00031 using namespace Windows::UI::Xaml::Input;
00032 using namespace Windows::UI::Xaml::Media;
00033
00034 using namespace SDKSample::ListViewSampleDataSource;
00035
00036 Scenario1::Scenario1()
00037 {
00038     InitializeComponent();
00039
00040   storeData = ref new StoreData();
00041   GridView1->ItemsSource = storeData->Items;
00042 }
00043
00044 /// <summary>
00045 /// Invoked when this page is about to be displayed in a Frame.
00046 /// </summary>
00047 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00048 /// property is typically used to configure the page.</param>
00049 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00050 {
00051     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00052     // as NotifyUser()
00053     rootPage = MainPage::Current;
00054 }
00055
00056 void SDKSample::ListViewSimple::Scenario1::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00057 {
00058     Button^ b = safe_cast<Button^>(sender);
00059     if (b != nullptr)
00060     {
00061         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00062     }
00063 }
00064
00065 void SDKSample::ListViewSimple::Scenario1::Other_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00066 {
00067     Button^ b = safe_cast<Button^>(sender);
00068     if (b != nullptr)
00069     {
00070         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00071     }
00072 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/SuspensionManager.cpp Source File

  • Removable storage
  • common

SuspensionManager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario1.xaml.h Source File

  • Display orientation

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace DisplayOrientation
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             void CalculateDeviceRotation(
00041                 Windows::Devices::Sensors::Accelerometer^ sender,
00042                 Windows::Devices::Sensors::AccelerometerReadingChangedEventArgs^ args
00043                 );
00044
00045             void UpdateArrowForRotation();
00046
00047             double rotationAngle;
00048             Windows::Devices::Sensors::Accelerometer^ accelerometer;
00049             Windows::Foundation::EventRegistrationToken readingChangedEventToken;
00050         };
00051     }
00052 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PhotoPathComparer.cpp Source File

  • Hilo C++
  • Hilo

PhotoPathComparer.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "PhotoPathComparer.h"
00009 #include "IPhoto.h"
00010
00011 using namespace Hilo;
00012
00013 bool PhotoPathComparer::operator()(IPhoto^ left, IPhoto^ right) const
00014 {
00015     if (nullptr == left && nullptr == right)
00016     {
00017         return true;
00018     }
00019     if (nullptr == left || nullptr == right)
00020     {
00021         return false;
00022     }
00023     bool equal = left->Path == right->Path;
00024     return equal;
00025 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameTimer.cpp Source File

  • XAML DirectX 3D shooting game

GameTimer.cpp

Go to the documentation of this file.
00001 /// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "GameTimer.h"
00010
00011 GameTimer::GameTimer():
00012     m_active(false)
00013 {
00014     LARGE_INTEGER frequency;
00015     if (!QueryPerformanceFrequency(&frequency))
00016     {
00017         throw ref new Platform::FailureException();
00018     }
00019     m_secondsPerCount = 1.0f / static_cast<float>(frequency.QuadPart);
00020
00021     Reset();
00022 }
00023
00024 // Returns the total time elapsed since Reset() was called, NOT counting any
00025 // time when the clock is stopped.
00026 float GameTimer::PlayingTime()
00027 {
00028     if (m_active)
00029     {
00030         // The distance m_currentTime - m_baseTime includes paused time,
00031         // which we do not want to count.  To correct this, we can subtract
00032         // the paused time from m_currentTime:
00033         return static_cast<float>(((m_currentTime.QuadPart - m_pausedTime.QuadPart) - m_baseTime.QuadPart)*m_secondsPerCount);
00034     }
00035     else
00036     {
00037         // The clock is currently not running so don't count the time since
00038         // the clock was stopped
00039         return static_cast<float>(((m_stopTime.QuadPart - m_pausedTime.QuadPart) - m_baseTime.QuadPart)*m_secondsPerCount);
00040     }
00041 }
00042
00043
00044 void GameTimer::PlayingTime(float time)
00045 {
00046     // Reset the internal state to reflect a PlayingTime of 'time'
00047     // Offset the baseTime by this 'time'.
00048     m_active = false;
00049     m_stopTime = m_currentTime;
00050     m_pausedTime.QuadPart = 0;
00051
00052     m_baseTime.QuadPart = m_stopTime.QuadPart - static_cast<__int64>(time / m_secondsPerCount);
00053 }
00054
00055
00056 float GameTimer::DeltaTime()
00057 {
00058     return m_deltaTime;
00059 }
00060
00061 void GameTimer::Reset()
00062 {
00063     LARGE_INTEGER currentTime;
00064     if (!QueryPerformanceCounter(&currentTime))
00065     {
00066         throw ref new Platform::FailureException();
00067     }
00068     m_baseTime = currentTime;
00069     m_previousTime = currentTime;
00070     m_stopTime = currentTime;
00071     m_currentTime = currentTime;
00072     m_pausedTime.QuadPart = 0;
00073     m_active = false;
00074 }
00075
00076 void GameTimer::Start()
00077 {
00078     LARGE_INTEGER startTime;
00079     if (!QueryPerformanceCounter(&startTime))
00080     {
00081         throw ref new Platform::FailureException();
00082     }
00083     if (!m_active)
00084     {
00085         // Accumulate the time elapsed between stop and start pairs.
00086         m_pausedTime.QuadPart += (startTime.QuadPart - m_stopTime.QuadPart);
00087
00088         m_previousTime = startTime;
00089         m_stopTime.QuadPart = 0;
00090         m_active = true;
00091     }
00092 }
00093
00094 void GameTimer::Stop()
00095 {
00096     if (m_active)
00097     {
00098         // Set the stop time to the time of the last update.
00099         m_stopTime = m_currentTime;
00100         m_active = false;
00101     }
00102 }
00103
00104 void GameTimer::Update()
00105 {
00106     if (!m_active)
00107     {
00108         m_deltaTime = 0.0;
00109         return;
00110     }
00111
00112     LARGE_INTEGER currentTime;
00113     if (!QueryPerformanceCounter(&currentTime))
00114     {
00115         throw ref new Platform::FailureException();
00116     }
00117     m_currentTime = currentTime;
00118
00119     m_deltaTime = (m_currentTime.QuadPart - m_previousTime.QuadPart)*m_secondsPerCount;
00120     m_previousTime = m_currentTime;
00121
00122     if (m_deltaTime < 0.0)
00123     {
00124         m_deltaTime = 0.0;
00125     }
00126 }
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario2.xaml.h Source File

  • XAML personality animations

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "SampleData/SampleDataSource.h"
00022
00023 using namespace SDKSample::ExpressionBlendSampleDataSampleDataSource;
00024
00025 namespace SDKSample
00026 {
00027   namespace PersonalityAnimations
00028   {
00029     /// <summary>
00030     /// An empty page that can be used on its own or navigated to within a Frame.
00031     /// </summary>
00032     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00033     public ref class Scenario2 sealed
00034     {
00035     public:
00036       Scenario2();
00037
00038     protected:
00039     private:
00040       MessageData^ messageData;
00041     };
00042   }
00043 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/DeviceAppForPrinters/App.xaml.h Source File

  • Device app for printers SDK
  • DeviceAppForPrinters

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace DeviceAppForPrinters
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028
00029     public:
00030         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00031         virtual void OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^ pArgs) override;
00032         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00033
00034     private:
00035         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00036         void SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs);
00037
00038     };
00039 }
00040
00041
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CustomCommand.xaml.h Source File

  • Message dialog

CustomCommand.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CustomCommand.xaml.h
00013 // Declaration of the CustomCommand class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "CustomCommand.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace MessageDialogSample
00025     {
00026         [Windows::Foundation::Metadata::WebHostHidden]
00027         public ref class CustomCommand sealed
00028         {
00029         public:
00030             CustomCommand();
00031
00032         protected:
00033             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00034         private:
00035             MainPage^ rootPage;
00036             void CustomCommandButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037         };
00038     }
00039 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

RenderBuffer Member List

This is the complete list of members for RenderBuffer, including all inherited members.
Buffer | RenderBuffer |
BufferSize | RenderBuffer |
BytesFilled | RenderBuffer |
Next | RenderBuffer |
RenderBuffer() | RenderBuffer | [inline]
~RenderBuffer() | RenderBuffer | [inline]
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/pch.cpp Source File

  • DirectWrite hello world

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/SetAccountPicture.xaml.cpp Source File

  • Account picture name

SetAccountPicture.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SetAccountPicture.xaml.cpp
00013 // Implementation of the SetAccountPicture class
00014 //
00015
00016 #include "pch.h"
00017 #include "SetAccountPicture.xaml.h"
00018
00019 using namespace AccountPictureName;
00020 using namespace concurrency;
00021 using namespace Platform;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::UI::Xaml::Media::Imaging;
00027 using namespace Windows::System::UserProfile;
00028 using namespace Windows::Foundation;
00029 using namespace Windows::ApplicationModel;
00030 using namespace Windows::Storage;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::Storage::Pickers;
00033 using namespace Microsoft::WRL;
00034 using namespace Microsoft::WRL::Wrappers;
00035
00036 Windows::Foundation::EventRegistrationToken SetAccountPicture::accountPictureChangedToken;
00037
00038 SetAccountPicture::SetAccountPicture()
00039 {
00040     InitializeComponent();
00041 }
00042
00043 /// <summary>
00044 /// Invoked when this page is about to be displayed in a Frame.
00045 /// </summary>
00046 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00047 /// property is typically used to configure the page.</param>
00048 void SetAccountPicture::OnNavigatedTo(NavigationEventArgs^ e)
00049 {
00050     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00051     // as NotifyUser()
00052     rootPage = MainPage::Current;
00053     accountPictureChangedToken = UserInformation::AccountPictureChanged += ref new EventHandler<Object^>(this, &SetAccountPicture::PictureChanged);
00054 }
00055
00056 void SetAccountPicture::OnNavigatedFrom(NavigationEventArgs^ e)
00057 {
00058     UserInformation::AccountPictureChanged -= accountPictureChangedToken;
00059 }
00060
00061 void SetAccountPicture::SetImageButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00062 {
00063     if (rootPage->EnsureUnsnapped())
00064     {
00065         FileOpenPicker^ imagePicker = ref new FileOpenPicker();
00066         imagePicker->ViewMode = PickerViewMode::Thumbnail;
00067         imagePicker->SuggestedStartLocation = PickerLocationId::PicturesLibrary;
00068         imagePicker->FileTypeFilter->Append(".jpg");
00069         imagePicker->FileTypeFilter->Append(".jpeg");
00070         imagePicker->FileTypeFilter->Append(".png");
00071         imagePicker->FileTypeFilter->Append(".bmp");
00072
00073         create_task(imagePicker->PickSingleFileAsync()).then(
00074             [this](StorageFile^ imageFile)
00075         {
00076             if (imageFile != nullptr)
00077             {
00078                 rootPage->NotifyUser("Setting " + imageFile->Name + " as account picture ...",
00079                     NotifyType::StatusMessage);
00080                 create_task(UserInformation::SetAccountPictureAsync(imageFile)).then(
00081                     [this](SetAccountPictureResult setPictureResult)
00082                 {
00083                     if (setPictureResult == SetAccountPictureResult::Success)
00084                     {
00085                         rootPage->NotifyUser("Successfully updated account picture.", NotifyType::StatusMessage);
00086                     }
00087                     else
00088                     {
00089                         rootPage->NotifyUser("Setting account picture failed.", NotifyType::ErrorMessage);
00090                     }
00091                 });
00092             }
00093             else
00094             {
00095                 rootPage->NotifyUser("No image was selected", NotifyType::StatusMessage);
00096             }
00097         });
00098     }
00099 }
00100
00101 void SetAccountPicture::SetVideoButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00102 {
00103     if (rootPage->EnsureUnsnapped())
00104     {
00105         FileOpenPicker^ videoPicker = ref new FileOpenPicker();
00106         videoPicker->ViewMode = PickerViewMode::Thumbnail;
00107         videoPicker->SuggestedStartLocation = PickerLocationId::PicturesLibrary;
00108         videoPicker->FileTypeFilter->Append(".mp4");
00109         videoPicker->FileTypeFilter->Append(".wmv");
00110         videoPicker->FileTypeFilter->Append(".mpeg");
00111         videoPicker->FileTypeFilter->Append(".mov");
00112
00113         create_task(videoPicker->PickSingleFileAsync()).then(
00114             [this](StorageFile^ videoFile)
00115         {
00116             if (videoFile != nullptr)
00117             {
00118                 rootPage->NotifyUser("Setting " + videoFile->Name + " as account picture ...",
00119                     NotifyType::StatusMessage);
00120                 create_task(UserInformation::SetAccountPictureAsync(videoFile)).then(
00121                     [this](SetAccountPictureResult setPictureResult)
00122                 {
00123                     if (setPictureResult == SetAccountPictureResult::Success)
00124                     {
00125                         rootPage->NotifyUser("Successfully updated account picture", NotifyType::StatusMessage);
00126                     }
00127                     else
00128                     {
00129                         rootPage->NotifyUser("Setting account picture failed.", NotifyType::ErrorMessage);
00130                     }
00131                 });
00132             }
00133             else
00134             {
00135                 rootPage->NotifyUser("No image was selected", NotifyType::StatusMessage);
00136             }
00137         });
00138     }
00139 }
00140
00141 void SetAccountPicture::PictureChanged(Platform::Object^ sender, Platform::Object^ e)
00142 {
00143     Dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00144     {
00145         if (!UserInformation::NameAccessAllowed)
00146         {
00147             rootPage->NotifyUser("Access to account picture disabled by Privacy Setting or Group Policy", NotifyType::ErrorMessage);
00148         }
00149         else
00150         {
00151             auto largeImageFile = UserInformation::GetAccountPicture(AccountPictureKind::LargeImage);
00152             if (largeImageFile != nullptr)
00153             {
00154                 create_task(largeImageFile->OpenReadAsync()).then(
00155                     [this](task<IRandomAccessStreamWithContentType^> imageStreamTask)
00156                 {
00157                     try
00158                     {
00159                         auto imageStream = imageStreamTask.get();
00160                         auto bitmapImage = ref new BitmapImage();
00161                         bitmapImage->SetSource(imageStream);
00162                         AccountPictureImage->Source = bitmapImage;
00163                     }
00164                     catch (Exception^ ex)
00165                     {
00166                         rootPage->NotifyUser("Failed to read from stream. " + ex->Message, NotifyType::ErrorMessage);
00167                     }
00168                 });
00169             }
00170             else
00171             {
00172                 rootPage->NotifyUser("No large account picture image returned for current user.", NotifyType::ErrorMessage);
00173             }
00174         }
00175     }));
00176 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/DirectXBase.cpp Source File

  • Direct2D custom image effects
  • PixelShader

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

GeometryRealizationFactory Member List

This is the complete list of members for GeometryRealizationFactory, including all inherited members.
Create(ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension, IGeometryRealizationFactory **factory) | GeometryRealizationFactory | [static]
CreateGeometryRealization(IGeometryRealization **realization) | GeometryRealizationFactory |
CreateGeometryRealization(ID2D1Geometry *geometry, REALIZATION_CREATION_OPTIONS options, CONST D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle, IGeometryRealization **realization) | GeometryRealizationFactory |
GeometryRealizationFactory() | GeometryRealizationFactory | [protected]
Initialize(ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension) | GeometryRealizationFactory | [protected]
m_deviceContext | GeometryRealizationFactory | [protected]
m_maxRealizationDimension | GeometryRealizationFactory | [protected]
m_ref | GeometryRealizationFactory | [protected]
QueryInterface(REFIID iid, void **object) | GeometryRealizationFactory |
STDMETHOD_(ULONG, AddRef)() | GeometryRealizationFactory |
STDMETHOD_(ULONG, Release)() | GeometryRealizationFactory |
~GeometryRealizationFactory() | GeometryRealizationFactory | [protected]
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/MainPage.xaml.cpp Source File

  • Configure keys for media

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/pch.cpp Source File

  • Portable device API

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Story.cpp Source File

  • Direct2D magazine app

Story.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Windows::Data::Xml::Dom;
00011
00012 bool Story::AcceptChildNode(
00013     _In_ Document^ document,
00014     _In_ IXmlNode^ childXmlNode
00015     )
00016 {
00017     if (childXmlNode->NodeType == NodeType::ElementNode)
00018     {
00019         XmlElement^ xmlElement = dynamic_cast<XmlElement^>(childXmlNode);
00020
00021         Element^ child = nullptr;
00022         Platform::String^ elementName = xmlElement->TagName;
00023
00024         if (elementName != nullptr)
00025         {
00026             if (elementName == "design")
00027             {
00028                 child = Element::Create<Design>(document, childXmlNode);
00029             }
00030             else if (elementName == "resource")
00031             {
00032                 child = Element::Create<Resource>(document, childXmlNode);
00033             }
00034         }
00035
00036         if (child == nullptr)
00037         {
00038             return false;
00039         }
00040
00041         AddChild(child);
00042     }
00043
00044     return true;
00045 }
00046
00047 // Choose the design with the least aspect ratio deviation from the specified display size.
00048 Design^ Story::GetDesign(D2D1_SIZE_F displaySize)
00049 {
00050     float displayAspectRatio = displaySize.width / displaySize.height;
00051     float leastDeviation = FLT_MAX;
00052
00053     Design^ chosenDesign = nullptr;
00054
00055     Element^ child = GetFirstChild();
00056
00057     while (child != nullptr)
00058     {
00059         Design^ design = dynamic_cast<Design^>(child);
00060
00061         if (design != nullptr)
00062         {
00063             D2D1_SIZE_F pageSize = design->GetPageSize();
00064
00065             float deviation = abs(pageSize.width / pageSize.height - displayAspectRatio);
00066
00067             if (deviation < leastDeviation)
00068             {
00069                 leastDeviation = deviation;
00070                 chosenDesign = design;
00071             }
00072         }
00073
00074         child = child->GetNextSibling();
00075     }
00076
00077     return chosenDesign;
00078 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Cylinder.h Source File

  • DirectX 3D shooting game

Cylinder.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Cylinder:
00011 // This class is a specialization of GameObject that represents a cylinder primitive.
00012 // The cylinder is defined by a vector starting at 'position' and oriented along the
00013 // 'direction' vector.  The length of the cylinder is just the length of the 'direction'
00014 // vector.
00015
00016 #include "GameObject.h"
00017
00018 ref class Cylinder: public GameObject
00019 {
00020 internal:
00021     Cylinder();
00022     Cylinder(
00023         DirectX::XMFLOAT3 position,
00024         float radius,
00025         DirectX::XMFLOAT3 direction
00026         );
00027
00028     virtual bool IsTouching(
00029         DirectX::XMFLOAT3 point,
00030         float radius,
00031         _Out_ DirectX::XMFLOAT3 *contact,
00032         _Out_ DirectX::XMFLOAT3 *normal
00033         ) override;
00034
00035 protected:
00036     virtual void UpdatePosition() override;
00037
00038 private:
00039     void Initialize(
00040         DirectX::XMFLOAT3 position,
00041         float radius,
00042         DirectX::XMFLOAT3 direction
00043         );
00044
00045     DirectX::XMFLOAT3   m_axis;
00046     float               m_length;
00047     float               m_radius;
00048     DirectX::XMFLOAT4X4 m_rotationMatrix;
00049 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/pch.h Source File

  • Number formatting and parsing

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DWriteHelloWorld Member List

This is the complete list of members for DWriteHelloWorld, including all inherited members.
__pad0__ | DWriteHelloWorld |
CreateDeviceIndependentResources() override | DWriteHelloWorld | [virtual]
CreateDeviceResources() override | DWriteHelloWorld | [virtual]
CreateWindowSizeDependentResources() override | DWriteHelloWorld | [virtual]
Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView) | DWriteHelloWorld | [virtual]
Load(_In_ Platform::String^entryPoint) | DWriteHelloWorld | [virtual]
m_blackBrush | DWriteHelloWorld | [private]
m_sampleOverlay | DWriteHelloWorld | [private]
m_textFormat | DWriteHelloWorld | [private]
m_textLayout | DWriteHelloWorld | [private]
m_textTypography | DWriteHelloWorld | [private]
OnActivated(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args) | DWriteHelloWorld | [private]
OnDisplayContentsInvalidated(_In_ Platform::Object^sender) | DWriteHelloWorld | [private]
OnLogicalDpiChanged(_In_ Platform::Object^sender) | DWriteHelloWorld | [private]
OnResuming(_In_ Platform::Object^sender, _In_ Platform::Object^args) | DWriteHelloWorld | [private]
OnSuspending(_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args) | DWriteHelloWorld | [private]
OnWindowSizeChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args) | DWriteHelloWorld | [private]
Render() override | DWriteHelloWorld | [virtual]
Run() | DWriteHelloWorld | [virtual]
SetWindow(_In_ Windows::UI::Core::CoreWindow^window) | DWriteHelloWorld | [virtual]
Uninitialize() | DWriteHelloWorld | [virtual]
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideText10 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideText10, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextColumn2Row1 | NotificationsExtensions::TileContent::TileWideText10 |
TextColumn2Row2 | NotificationsExtensions::TileContent::TileWideText10 |
TextColumn2Row3 | NotificationsExtensions::TileContent::TileWideText10 |
TextColumn2Row4 | NotificationsExtensions::TileContent::TileWideText10 |
TextFields | NotificationsExtensions::NotificationBase |
TextHeading | NotificationsExtensions::TileContent::TileWideText10 |
TextPrefixColumn1Row1 | NotificationsExtensions::TileContent::TileWideText10 |
TextPrefixColumn1Row2 | NotificationsExtensions::TileContent::TileWideText10 |
TextPrefixColumn1Row3 | NotificationsExtensions::TileContent::TileWideText10 |
TextPrefixColumn1Row4 | NotificationsExtensions::TileContent::TileWideText10 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideText10() | NotificationsExtensions::TileContent::TileWideText10 | [inline]
TileWideText10() | NotificationsExtensions::TileContent::TileWideText10 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/MainPage.xaml.h Source File

  • Association launching

MainPage.xaml.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.h
00010 // Declaration of the MainPage.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "MainPage.g.h"
00017
00018 using namespace Windows::UI::Xaml;
00019 using namespace Windows::UI::Xaml::Controls;
00020 using namespace Windows::Graphics::Display;
00021 using namespace Windows::UI::ViewManagement;
00022 using namespace Windows::UI::Xaml::Navigation;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::System;
00025 using namespace Platform;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 namespace AssociationLaunching
00029 {
00030     public enum class NotifyType
00031     {
00032         StatusMessage,
00033         ErrorMessage
00034     };
00035
00036   [Windows::Foundation::Metadata::WebHostHidden]
00037     public ref class MainPage sealed
00038     {
00039     public:
00040         MainPage();
00041
00042         property Windows::UI::Xaml::Controls::Frame^ ScenariosFrame
00043         {
00044             Windows::UI::Xaml::Controls::Frame^ get() { return _scenariosFrame; }
00045         }
00046         property Windows::UI::Xaml::Controls::Frame^ InputFrame
00047         {
00048             Windows::UI::Xaml::Controls::Frame^ get() { return _inputFrame; }
00049         }
00050         property Windows::UI::Xaml::Controls::Frame^ OutputFrame
00051         {
00052             Windows::UI::Xaml::Controls::Frame^ get() { return _outputFrame; }
00053         }
00054
00055         property Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs^ ProtocolEvent
00056         {
00057             Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs^ get() { return _protocolEventArgs; }
00058             void set(Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs^ value) { _protocolEventArgs = value; }
00059         }
00060
00061         property Windows::ApplicationModel::Activation::FileActivatedEventArgs^ FileEvent
00062         {
00063             Windows::ApplicationModel::Activation::FileActivatedEventArgs^ get() { return _fileEventArgs; }
00064             void set(Windows::ApplicationModel::Activation::FileActivatedEventArgs^ value) { _fileEventArgs = value; }
00065         }
00066
00067         event Windows::Foundation::EventHandler<Platform::Object^>^ InputFrameLoaded;
00068         event Windows::Foundation::EventHandler<Platform::Object^>^ OutputFrameLoaded;
00069
00070         void NotifyUser(String^ strMessage, NotifyType type);
00071         void DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^ frame);
00072         String^ ConvertViewState(ApplicationViewState state);
00073         String^ ConvertResolution(ResolutionScale scale);
00074
00075     private:
00076         Windows::UI::Xaml::Controls::Frame^ _scenariosFrame;
00077         Windows::UI::Xaml::Controls::Frame^ _inputFrame;
00078         Windows::UI::Xaml::Controls::Frame^ _outputFrame;
00079         void Footer_Click(Object^ sender, RoutedEventArgs^ e);
00080         Windows::Foundation::EventRegistrationToken _displayHandlerToken;
00081         Windows::Foundation::EventRegistrationToken _layoutHandlerToken;
00082         Windows::Foundation::EventRegistrationToken _pageLoadedHandlerToken;
00083         Windows::Foundation::EventRegistrationToken _logicalDpiChangedToken;
00084         Windows::Foundation::EventRegistrationToken _inputFrameLoadedToken;
00085         Windows::Foundation::EventRegistrationToken _outputFrameLoadedToken;
00086         void Page_SizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00087         void DisplayProperties_LogicalDpiChanged(Object^ sender);
00088         void Page_Loaded(Object^ sender, RoutedEventArgs^ e);
00089         void CheckResolutionAndViewState();
00090         void SetFeatureName(Platform::String^ strFeature);
00091         void inputFrameNavigated(Object^ sender, NavigationEventArgs^ e);
00092         void outputFrameNavigated(Object^ sender, NavigationEventArgs^ e);
00093         ~MainPage();
00094
00095         Windows::ApplicationModel::Activation::ProtocolActivatedEventArgs^ _protocolEventArgs;
00096         Windows::ApplicationModel::Activation::FileActivatedEventArgs^ _fileEventArgs;
00097     };
00098 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/MainPage.xaml.cpp Source File

  • Folder enumeration

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/pch.h Source File

  • Splash screen

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioList.xaml.cpp Source File

  • Scheduled notifications
  • C#,C++

ScenarioList.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioList.xaml.cpp
00010 // Implementation of the ScenarioList class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioList.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace ScheduledNotificationsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace CppSamplesUtils;
00021 using namespace Windows::Foundation;
00022 using namespace Windows::Foundation::Collections;
00023 using namespace Windows::Graphics::Display;
00024 using namespace Windows::UI::ViewManagement;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Controls::Primitives;
00028 using namespace Windows::UI::Xaml::Data;
00029 using namespace Windows::UI::Xaml::Input;
00030 using namespace Windows::UI::Xaml::Media;
00031 using namespace Windows::UI::Xaml::Navigation;
00032 using namespace Windows::UI::Xaml::Interop;
00033
00034 ScenarioList::ScenarioList()
00035 {
00036     InitializeComponent();
00037 }
00038
00039 ScenarioList::~ScenarioList()
00040 {
00041 }
00042
00043 void ScenarioList::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00044 {
00045     if(Scenarios->SelectedItem != nullptr)
00046     {
00047         rootPage->NotifyUser("", NotifyType::StatusMessage);
00048
00049         ListBoxItem^ selectedListBoxItem = dynamic_cast<ListBoxItem^>(Scenarios->SelectedItem);
00050         SuspensionManager::SessionState()->Insert("SelectedScenario", selectedListBoxItem->Name);
00051
00052         if (rootPage->InputFrame != nullptr && rootPage->OutputFrame != nullptr)
00053         {
00054              //Load the input and output pages for the current scenario into their respective frames
00055             TypeName inputPage = { "ScheduledNotificationsSampleCPP" + "." + "ScenarioInput" + ((Scenarios->SelectedIndex + 1).ToString()), TypeKind::Custom };
00056             TypeName outputPage = { "ScheduledNotificationsSampleCPP" + "." + "ScenarioOutput" + ((Scenarios->SelectedIndex + 1).ToString()), TypeKind::Custom };
00057             rootPage->DoNavigation(inputPage, rootPage->InputFrame, outputPage, rootPage->OutputFrame);
00058         }
00059     }
00060 }
00061
00062 void ScenarioList::OnNavigatedTo(NavigationEventArgs^ e)
00063 {
00064     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00065
00066     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &ScenarioList::Scenarios_SelectionChanged);
00067     ListBoxItem^ startingScenario = nullptr;
00068
00069     auto ps = SuspensionManager::SessionState();
00070     if (ps->HasKey("SelectedScenario"))
00071     {
00072         PropertyValue^ pv;
00073         String^ item = dynamic_cast<String^>(ps->Lookup("SelectedScenario"));
00074         startingScenario = dynamic_cast<ListBoxItem^>(this->FindName(item));
00075     }
00076
00077     Scenarios->SelectedItem = startingScenario != nullptr ? startingScenario : Scenario1;
00078 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/Transliteration.xaml.h Source File

  • Extended Linguistic Services (ELS)
  • C++

Transliteration.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Transliteration.xaml.h
00013 // Declaration of the Transliteration class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Transliteration.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ELS
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Transliteration sealed
00031         {
00032         public:
00033             Transliteration();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         private:
00039             MainPage^ rootPage;
00040             void Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

List< T > Member List

This is the complete list of members for List< T >, including all inherited members.
__pad0__ | List< T > |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | List< T > | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
Back() const | List< T > | [inline, protected]
Back() const | List< T > | [inline, protected]
Back() const | List< T > | [inline, protected]
BindResource(_In_ Element^rootElement) | Element | [virtual]
Clear(FN &clear_fn) | List< T > | [inline]
Clear() | List< T > | [inline, virtual]
Clear(FN &clear_fn) | List< T > | [inline]
Clear() | List< T > | [inline, virtual]
Clear(FN &clear_fn) | List< T > | [inline]
Clear() | List< T > | [inline, virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) override | List< T > | [virtual]
EndPosition() const | List< T > | [inline]
EndPosition() const | List< T > | [inline]
EndPosition() const | List< T > | [inline]
Front() const | List< T > | [inline, protected]
Front() const | List< T > | [inline, protected]
Front() const | List< T > | [inline, protected]
FrontPosition() | List< T > | [inline]
FrontPosition() | List< T > | [inline]
FrontPosition() | List< T > | [inline]
GetBack(T *ppItem) | List< T > | [inline]
GetBack(T *ppItem) | List< T > | [inline]
GetBack(T *ppItem) | List< T > | [inline]
GetCount() const | List< T > | [inline]
GetCount() const | List< T > | [inline]
GetCount() const | List< T > | [inline]
GetFirstChild() | Element | [inline]
GetFront(T *ppItem) | List< T > | [inline]
GetFront(T *ppItem) | List< T > | [inline]
GetFront(T *ppItem) | List< T > | [inline]
GetItem(const Node *pNode, T *ppItem) | List< T > | [inline, protected, virtual]
GetItem(const Node *pNode, T *ppItem) | List< T > | [inline, protected, virtual]
GetItem(const Node *pNode, T *ppItem) | List< T > | [inline, protected, virtual]
GetItemPos(POSITION pos, T *ppItem) | List< T > | [inline]
GetItemPos(POSITION pos, T *ppItem) | List< T > | [inline]
GetItemPos(POSITION pos, T *ppItem) | List< T > | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() override | Rectangle | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override | List< T > | [virtual]
InsertAfter(T item, Node *pBefore) | List< T > | [inline, protected, virtual]
InsertAfter(T item, Node *pBefore) | List< T > | [inline, protected, virtual]
InsertAfter(T item, Node *pBefore) | List< T > | [inline, protected, virtual]
InsertBack(T item) | List< T > | [inline]
InsertBack(T item) | List< T > | [inline]
InsertBack(T item) | List< T > | [inline]
InsertFront(T item) | List< T > | [inline]
InsertFront(T item) | List< T > | [inline]
InsertFront(T item) | List< T > | [inline]
InsertPos(POSITION pos, T item) | List< T > | [inline]
InsertPos(POSITION pos, T item) | List< T > | [inline]
InsertPos(POSITION pos, T item) | List< T > | [inline]
IsEmpty() const | List< T > | [inline]
IsEmpty() const | List< T > | [inline]
IsEmpty() const | List< T > | [inline]
List() | List< T > | [inline]
List() | List< T > | [inline]
List() | List< T > | [inline]
m_anchor | List< T > | [protected]
m_count | List< T > | [protected]
m_margin | List< T > | [private]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override | List< T > | [virtual]
Next(const POSITION pos) | List< T > | [inline]
Next(const POSITION pos) | List< T > | [inline]
Next(const POSITION pos) | List< T > | [inline]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
Remove(POSITION &pos, T *ppItem) | List< T > | [inline]
Remove(POSITION &pos, T *ppItem) | List< T > | [inline]
Remove(POSITION &pos, T *ppItem) | List< T > | [inline]
RemoveBack(T *ppItem) | List< T > | [inline]
RemoveBack(T *ppItem) | List< T > | [inline]
RemoveBack(T *ppItem) | List< T > | [inline]
RemoveFront(T *ppItem) | List< T > | [inline]
RemoveFront(T *ppItem) | List< T > | [inline]
RemoveFront(T *ppItem) | List< T > | [inline]
RemoveItem(Node *pNode, T *ppItem) | List< T > | [inline, protected, virtual]
RemoveItem(Node *pNode, T *ppItem) | List< T > | [inline, protected, virtual]
RemoveItem(Node *pNode, T *ppItem) | List< T > | [inline, protected, virtual]
~List() | List< T > | [inline, virtual]
~List() | List< T > | [inline, virtual]
~List() | List< T > | [inline, virtual]
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/PhoneCall.xaml.h Source File

  • Bluetooth call control

PhoneCall.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PhoneCall.xaml.h
00013 // Declaration of the PhoneCall class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "PhoneCall.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::Media;
00024 using namespace Platform;
00025
00026 namespace  SDKSample
00027 {
00028 namespace CallControl
00029 {
00030     /// <summary>
00031     /// An empty page that can be used on its own or navigated to within a Frame.
00032     /// </summary>
00033   [Windows::Foundation::Metadata::WebHostHidden]
00034     public ref class PhoneCall sealed
00035     {
00036     public:
00037         PhoneCall();
00038
00039     protected:
00040         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00041     private:
00042         MainPage^ rootPage;
00043         void ButtonInitialize_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044         void ButtonRing_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045         void ButtonHangUp_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046
00047         void CallControlError(String^ ErrorText);
00048         void CallControlStatus(String^ StatusText);
00049
00050         void CallControls_AnswerRequested(Devices::CallControl^ sender);
00051         void CallControls_HangUpRequested(Devices::CallControl^ sender);
00052         void CallControls_AudioTransferRequested(Devices::CallControl^ sender);
00053         void CallControls_RedialRequested(Devices::CallControl^ sender, Devices::RedialRequestedEventArgs^ e);
00054         void CallControls_DialRequested(Devices::CallControl^ sender, Devices::DialRequestedEventArgs^ e);
00055
00056         void enableIncomingCallButton();
00057         void disableIncomingCallButton();
00058         void enableInitializeButton();
00059         void disableInitializeButton();
00060         void enableHangUpButton();
00061         void disableHangUpButton();
00062
00063         void SetAudioSource();
00064         void PlayAudio();
00065         void StopAudio();
00066         void PauseAudio();
00067
00068     private:
00069         Devices::CallControl^ CallControls;
00070         Windows::UI::Core::CoreDispatcher^ _dispatcher;
00071         unsigned long long CallToken;
00072
00073   };
00074 }
00075 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/cppsamplesutils.h Source File

  • Print

cppsamplesutils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Personalization::sealed Member List

This is the complete list of members for SDKSample::Personalization::sealed, including all inherited members.
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Personalization::sealed | [protected, virtual]
PickAndSetButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Personalization::sealed | [private]
rootPage | SDKSample::Personalization::sealed | [private]
SetLockscreenImage() | SDKSample::Personalization::sealed |
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/pch.h Source File

  • XAML ListView and GridView essentials

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/common/LayoutAwarePage.cpp Source File

  • CameraOptionsUI
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::CallControl::sealed Member List

This is the complete list of members for SDKSample::CallControl::sealed, including all inherited members.
_dispatcher | SDKSample::CallControl::sealed | [private]
ButtonHangUp_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CallControl::sealed | [private]
ButtonInitialize_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CallControl::sealed | [private]
ButtonRing_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CallControl::sealed | [private]
CallControlError(String^ErrorText) | SDKSample::CallControl::sealed | [private]
CallControls | SDKSample::CallControl::sealed | [private]
CallControls_AnswerRequested(Devices::CallControl^sender) | SDKSample::CallControl::sealed | [private]
CallControls_AudioTransferRequested(Devices::CallControl^sender) | SDKSample::CallControl::sealed | [private]
CallControls_DialRequested(Devices::CallControl^sender, Devices::DialRequestedEventArgs^e) | SDKSample::CallControl::sealed | [private]
CallControls_HangUpRequested(Devices::CallControl^sender) | SDKSample::CallControl::sealed | [private]
CallControls_RedialRequested(Devices::CallControl^sender, Devices::RedialRequestedEventArgs^e) | SDKSample::CallControl::sealed | [private]
CallControlStatus(String^StatusText) | SDKSample::CallControl::sealed | [private]
CallToken | SDKSample::CallControl::sealed | [private]
disableHangUpButton() | SDKSample::CallControl::sealed | [private]
disableIncomingCallButton() | SDKSample::CallControl::sealed | [private]
disableInitializeButton() | SDKSample::CallControl::sealed | [private]
enableHangUpButton() | SDKSample::CallControl::sealed | [private]
enableIncomingCallButton() | SDKSample::CallControl::sealed | [private]
enableInitializeButton() | SDKSample::CallControl::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::CallControl::sealed | [protected, virtual]
PauseAudio() | SDKSample::CallControl::sealed | [private]
PhoneCall() | SDKSample::CallControl::sealed |
PlayAudio() | SDKSample::CallControl::sealed | [private]
rootPage | SDKSample::CallControl::sealed | [private]
SetAudioSource() | SDKSample::CallControl::sealed | [private]
StopAudio() | SDKSample::CallControl::sealed | [private]
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/App.xaml.cpp Source File

  • Secondary tiles
  • C#,C++

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "App.xaml.h"
00018 #include "MainPage.xaml.h"
00019
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::ApplicationModel::Activation;
00024 using namespace CppSamplesUtils;
00025 using namespace SecondaryTiles;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 App::App()
00029 {
00030     InitializeComponent();
00031     this->Suspending += ref new SuspendingEventHandler(this, &SecondaryTiles::App::OnSuspending);
00032 }
00033
00034 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00035 {
00036     auto deferral = pArgs->SuspendingOperation->GetDeferral();
00037     SuspensionManager::StartSaveTask().then([=]()
00038     {
00039         deferral->Complete();
00040     });
00041 }
00042
00043 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00044 {
00045     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00046     {
00047         SuspensionManager::StartRestoreTask().then([=](concurrency::task<void> restoreTask)
00048         {
00049             try
00050             {
00051                 restoreTask.get();
00052             }
00053             catch(Platform::Exception^)
00054             {
00055                 // If restore fails, the app should proceed as though there was no restored state.
00056             }
00057         });
00058     }
00059     if (Window::Current->Content == nullptr)
00060     {
00061         rootFrame = ref new Frame();
00062         TypeName pageType = { "SecondaryTiles.MainPage", TypeKind::Custom };
00063         rootFrame->Navigate(pageType);
00064         Window::Current->Content = rootFrame;
00065     }
00066     MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
00067     p->LaunchArgs = pArgs;
00068     if ((p->LaunchArgs != nullptr) && (p->LaunchArgs->Arguments != nullptr))
00069     {
00070         p->NavigateToLaunchedFromSecondaryTile();
00071     }
00072     Window::Current->Activate();
00073 }
00074
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MainPage.xaml.cpp Source File

  • Real-time communication

MainPage.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Platform;
00026 using namespace SimpleCommunication;
00027 using namespace CppSamplesUtils;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036     : _navigationDisabled(-1)
00037     , _dispatcher(Window::Current->Dispatcher)
00038 {
00039     InitializeComponent();
00040
00041     // This frame is hidden, meaning it is never shown.  It is simply used to load
00042     // each scenario page and then pluck out the input and output sections and
00043     // place them into the UserControls on the main page.
00044     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00045     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00046     LayoutRoot->Children->Append(HiddenFrame);
00047
00048     // Populate the sample title from the constant in the GlobalVariables.cs file.
00049     SetFeatureName(FEATURE_NAME);
00050
00051     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00052     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00053
00054     // Register network source
00055     _mediaExtensionMgr = ref new Windows::Media::MediaExtensionManager();
00056     _mediaExtensionMgr->RegisterSchemeHandler("Microsoft.Samples.SimpleCommunication.StspSchemeHandler", "stsp:");
00057
00058     MainPage::Current = this;
00059     autoSizeInputSectionWhenSnapped = true;
00060 }
00061
00062 MainPage::~MainPage()
00063 {
00064 }
00065
00066 /// <summary>
00067 /// Invoked when this page is about to be displayed in a Frame.
00068 /// </summary>
00069 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00070 /// property is typically used to configure the page.</param>
00071 void MainPage::OnNavigatedTo(NavigationEventArgs^ e)
00072 {
00073     PopulateScenarios();
00074     InvalidateViewState();
00075 }
00076
00077 /// <summary>
00078 /// We need to handle SizeChanged so that we can make the sample layout property
00079 /// in the various layouts.
00080 /// </summary>
00081 /// <param name="sender"></param>
00082 /// <param name="e"></param>
00083 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00084 {
00085     InvalidateSize();
00086     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00087     args->ViewState = ApplicationView::Value;
00088     MainPageResized(this, args);
00089
00090 }
00091
00092 void MainPage::InvalidateSize()
00093 {
00094
00095     // Get the window width
00096     double windowWidth = this->ActualWidth;
00097
00098     if (windowWidth != 0.0)
00099     {
00100
00101         // Get the width of the ListBox.
00102         double listBoxWidth = Scenarios->ActualWidth;
00103
00104         // Is the ListBox using any margins that we need to consider?
00105         double listBoxMarginLeft = Scenarios->Margin.Left;
00106         double listBoxMarginRight = Scenarios->Margin.Right;
00107
00108         // Figure out how much room is left after considering the list box width
00109         double availableWidth = windowWidth - listBoxWidth;
00110
00111         // Is the top most child using margins?
00112         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00113         double layoutRootMarginRight = ContentRoot->Margin.Right;
00114
00115         // We have different widths to use depending on the view state
00116         if (ApplicationView::Value != ApplicationViewState::Snapped)
00117         {
00118             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00119             // and the LayoutRoot's margins
00120             InputSection->Width = ((availableWidth) -
00121                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00122         }
00123         else
00124         {
00125             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00126             if (autoSizeInputSectionWhenSnapped)
00127             {
00128                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00129             }
00130         }
00131     }
00132     InvalidateViewState();
00133 }
00134
00135 void MainPage::InvalidateViewState()
00136 {
00137     // Are we going to snapped mode?
00138     if (ApplicationView::Value == ApplicationViewState::Snapped)
00139     {
00140         Grid::SetRow(DescriptionText, 3);
00141         Grid::SetColumn(DescriptionText, 0);
00142
00143         Grid::SetRow(InputSection, 4);
00144         Grid::SetColumn(InputSection, 0);
00145
00146         Grid::SetRow(FooterPanel, 2);
00147         Grid::SetColumn(FooterPanel, 0);
00148     }
00149     else
00150     {
00151         Grid::SetRow(DescriptionText, 1);
00152         Grid::SetColumn(DescriptionText, 1);
00153
00154         Grid::SetRow(InputSection, 2);
00155         Grid::SetColumn(InputSection, 1);
00156
00157         Grid::SetRow(FooterPanel, 1);
00158         Grid::SetColumn(FooterPanel, 1);
00159     }
00160
00161 }
00162
00163 #pragma optimize("", off)
00164 void MainPage::PopulateScenarios()
00165 {
00166     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00167
00168     // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00169     for(unsigned int i = 0; i < scenarios->Length; ++i)
00170     {
00171         Scenario s = scenarios[i];
00172         ListBoxItem^ item = ref new ListBoxItem();
00173         item->Name = s.ClassName;
00174         item->Content = (i + 1).ToString() + ") " + s.Title;
00175         ScenarioList->Append(item);
00176     }
00177
00178     // Bind the ListBox to the scenario list.
00179     Scenarios->ItemsSource = ScenarioList;
00180
00181     // Starting scenario is the first or based upon a previous selection.
00182     ListBoxItem^ startingScenario = nullptr;
00183
00184     // Starting scenario is the first or based upon a previous selection.
00185     int startingScenarioIndex = -1;
00186
00187     auto ps = SuspensionManager::SessionState();
00188     if (ps->HasKey("SelectedScenarioIndex"))
00189     {
00190         int selectedScenarioIndex = safe_cast<int>(ps->Lookup("SelectedScenarioIndex"));
00191         startingScenarioIndex = selectedScenarioIndex;
00192     }
00193
00194     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00195 }
00196 #pragma optimize("", on)
00197
00198 /// <summary>
00199 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00200 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00201 /// and output sections into the respective UserControl on the main page.
00202 /// </summary>
00203 /// <param name="scenarioName"></param>
00204 void MainPage::LoadScenario(String^ scenarioName)
00205 {
00206     autoSizeInputSectionWhenSnapped = true;
00207
00208     // Load the ScenarioX.xaml file into the Frame.
00209     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00210     HiddenFrame->Navigate(scenarioType, this);
00211
00212     // Get the top element, the Page, so we can look up the elements
00213     // that represent the input and output sections of the ScenarioX file.
00214     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00215
00216     // Get each element.
00217     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00218     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00219
00220     if (input == nullptr)
00221     {
00222         // Malformed input section.
00223         NotifyUser("Cannot load scenario input section for " + scenarioName +
00224             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00225         return;
00226     }
00227
00228     if (output == nullptr)
00229     {
00230         // Malformed output section.
00231         NotifyUser("Cannot load scenario output section for " + scenarioName +
00232             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00233         return;
00234     }
00235
00236     // Find the LayoutRoot which parents the input and output sections in the main page.
00237     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00238
00239     if (panel != nullptr)
00240     {
00241         unsigned int index = 0;
00242         UIElementCollection^ collection = panel->Children;
00243
00244         // Get rid of the content that is currently in the intput and output sections.
00245         collection->IndexOf(input, &index);
00246         collection->RemoveAt(index);
00247
00248         collection->IndexOf(output, &index);
00249         collection->RemoveAt(index);
00250
00251         // Populate the input and output sections with the newly loaded content.
00252         InputSection->Content = input;
00253         OutputSection->Content = output;
00254
00255         ScenarioLoaded(this, nullptr);
00256     }
00257     else
00258     {
00259         // Malformed Scenario file.
00260         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00261             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00262     }
00263 }
00264
00265 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00266 {
00267     if (Scenarios->SelectedItem != nullptr)
00268     {
00269         NotifyUser("", NotifyType::StatusMessage);
00270
00271         long scenarioLocked = _InterlockedExchangeAdd(&_navigationDisabled, 0);
00272         if (-1 != scenarioLocked)
00273         {
00274             // Scenario locked
00275             Scenarios->SelectedIndex = scenarioLocked;
00276         }
00277         else
00278         {
00279             int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00280             SuspensionManager::SessionState()->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00281
00282             LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00283             InvalidateSize();
00284         }
00285     }
00286 }
00287
00288 void MainPage::SetFeatureName(String^ strFeature)
00289 {
00290     FeatureName->Text = strFeature;
00291 }
00292
00293
00294 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00295 {
00296     switch (type)
00297     {
00298     case NotifyType::StatusMessage:
00299         // Use the status message style.
00300         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00301         break;
00302     case NotifyType::ErrorMessage:
00303         // Use the error message style.
00304         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00305         break;
00306     default:
00307         break;
00308     }
00309     StatusBlock->Text = strMessage;
00310
00311     // Collapsed the StatusBlock if it has no text to conserve real estate.
00312     if (StatusBlock->Text != "")
00313         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00314     else
00315         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00316 }
00317
00318 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00319 {
00320     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00321     Windows::System::Launcher::LaunchUriAsync(uri);
00322 }
00323
00324 void MainPage::LockScenarioChange()
00325 {
00326     long prev = _InterlockedCompareExchange(&_navigationDisabled, (long)Scenarios->SelectedIndex, -1);
00327     if (prev != -1)
00328     {
00329         // Someone has locked.
00330         return;
00331     }
00332 }
00333
00334 void MainPage::UnlockScenarioChange()
00335 {
00336     _InterlockedExchange(&_navigationDisabled, -1);
00337 }
00338
00339 void MainPage::SetCurrentScenario(Platform::String^ scenario)
00340 {
00341     _currentScenario = scenario;
00342 }
00343
00344 bool MainPage::NavigatingPrevented()
00345 {
00346     return _currentScenario && -1 != _InterlockedExchangeAdd(&_navigationDisabled, 0);
00347 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/MainPage.xaml.cpp Source File

  • USSD message management

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TargetTexture Member List

This is the complete list of members for TargetTexture, including all inherited members.
__pad0__ | TargetTexture |
CreateHitTextureResourceView(_In_ Platform::String^name, _Out_ ID3D11ShaderResourceView **textureResourceView) | TargetTexture |
CreateHitTextureResourceView(_In_ Platform::String^name, _Out_ ID3D11ShaderResourceView **textureResourceView) | TargetTexture |
CreateTextureResourceView(_In_ Platform::String^name, _Out_ ID3D11ShaderResourceView **textureResourceView) | TargetTexture |
CreateTextureResourceView(_In_ Platform::String^name, _Out_ ID3D11ShaderResourceView **textureResourceView) | TargetTexture |
d2dContext | TargetTexture |
d2dFactory | TargetTexture |
dwriteFactory | TargetTexture |
m_blackBrush | TargetTexture | [private]
m_blueBrush | TargetTexture | [private]
m_circleGeometry1 | TargetTexture | [private]
m_circleGeometry2 | TargetTexture | [private]
m_circleGeometry3 | TargetTexture | [private]
m_circleGeometry4 | TargetTexture | [private]
m_circleGeometry5 | TargetTexture | [private]
m_clearBrush | TargetTexture | [private]
m_d2dContext | TargetTexture | [private]
m_d2dFactory | TargetTexture | [private]
m_d3dDevice | TargetTexture | [private]
m_dwriteFactory | TargetTexture | [private]
m_greenBrush | TargetTexture | [private]
m_redBrush | TargetTexture | [private]
m_textFormat | TargetTexture | [private]
m_whiteBrush | TargetTexture | [private]
m_yellowBrush | TargetTexture | [private]
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/Utils.h Source File

  • Real-time communication

Utils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 using namespace Windows::Devices::Enumeration;
00014 using namespace Windows::Foundation;
00015
00016 using namespace Concurrency;
00017
00018 namespace SimpleCommunication
00019 {
00020     ref class CaptureFailedEventArgs
00021     {
00022     internal:
00023         CaptureFailedEventArgs(HRESULT code, Platform::String^ message)
00024             : _code(code)
00025             , _message(message)
00026         {
00027         }
00028
00029         property HRESULT Code
00030         {
00031             HRESULT get() { return _code; }
00032         }
00033
00034         property Platform::String^ Message
00035         {
00036             Platform::String^ get() { return _message; }
00037         }
00038
00039     private:
00040         HRESULT _code;
00041         Platform::String^ _message;
00042     };
00043
00044     ref class SdkSample
00045     {
00046     internal:
00047         void Initialize(Windows::UI::Xaml::Controls::TextBlock^ statusMessage, Windows::UI::Core::CoreDispatcher^ dispatcher);
00048         void Deinitialize();
00049
00050         void DisplayStatus(Platform::String^ msg);
00051         void DisplayError(Platform::String^ msg);
00052         void FormatError(HResult err, Platform::String^ msg, Platform::String^ prefix);
00053         void FormatError(CaptureFailedEventArgs^ e, Platform::String^ prefix);
00054         void ClearLastStatus();
00055
00056     private:
00057         void Log(Platform::String^ message);
00058         void Log(Platform::String^ message, Platform::String^ tag, Platform::String^ type);
00059
00060         Windows::UI::Xaml::Controls::TextBlock^ _statusMessage;
00061         Windows::UI::Core::CoreDispatcher^ _dispatcher;
00062     };
00063
00064     ref class CaptureDevice;
00065
00066     delegate void CaptureFailedHandler(CaptureDevice^ sender, CaptureFailedEventArgs^ errorEventArgs);
00067     delegate void IncomingconnectioneventHandler(Microsoft::Samples::SimpleCommunication::StspMediaSink^ sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ args);
00068     delegate bool VideoSettingsFilter (Windows::Media::MediaProperties::IMediaEncodingProperties^, unsigned int);
00069
00070     // Capture device represents a device used in one capture session between
00071     // calling CaptureManager.lockAsync and CaptureManager.unlockAsync.
00072     ref class CaptureDevice sealed
00073     {
00074     private:
00075         // Media capture object
00076         Platform::Agile<Windows::Media::Capture::MediaCapture> _mediaCapture;
00077         // Custom media sink
00078         Microsoft::Samples::SimpleCommunication::StspMediaSink^ _mediaSink;
00079         // EventRegistrationToken for StspMediaSink::IncomingConnection
00080         Windows::Foundation::EventRegistrationToken _mediaSinkIncomingConnectionEventRegistrationToken;
00081         // EventRegistrationToken for MediaCapture::Failed
00082         Windows::Foundation::EventRegistrationToken _mediaCaptureFailedEventRegistrationToken;
00083
00084         // Flag indicating if recording to custom sink has started
00085         bool _recordingStarted;
00086
00087     internal:
00088         event CaptureFailedHandler^ Failed;
00089         event IncomingconnectioneventHandler^ Incomingconnectionevent;
00090
00091         CaptureDevice();
00092
00093         /// <summary>
00094         /// Initialization of the device.
00095         /// </summary>
00096         task<void> InitializeAsync();
00097
00098         /// <summary>
00099         /// Cleaning up the sink.
00100         /// </summary>
00101         void CleanupSink();
00102
00103         /// <summary>
00104         /// Cleans up the resources.
00105         /// </summary>
00106         void DoCleanup();
00107
00108         /// <summary>
00109         /// Asynchronous method cleaning up resources and stopping recording if necessary.
00110         /// </summary>
00111         task<void> CleanupAsync();
00112
00113         /// <summary>
00114         /// Function allows to select camera settings.
00115         /// </summary>
00116         /// <param name="mediaStreamType" type="Windows.Media.Capture.MediaStreamType">
00117         /// Type of a the media stream.
00118         /// </param>
00119         /// <param name="mediaStreamType">
00120         /// Function which will be called to filter the correct settings.
00121         /// </param>
00122         task<void> SelectPreferredCameraStreamSettingAsync(Windows::Media::Capture::MediaStreamType mediaStreamType, VideoSettingsFilter^ settingsFilterFunc);
00123
00124         /// <summary>
00125         /// Begins recording
00126         /// </summary>
00127         /// <param name="mediaEncodingProfile">
00128         /// Encoding profile which should be used for the recording session.
00129         /// </param>
00130         task<void> StartRecordingAsync(Windows::Media::MediaProperties::MediaEncodingProfile^ mediaEncodingProfile);
00131
00132         /// <summary>
00133         /// Stops recording.
00134         /// </summary>
00135         task<void> StopRecordingAsync();
00136
00137         /// <summary>
00138         /// Capture has failed.
00139         /// </summary>
00140         void OnCaptureFailed(Windows::Media::Capture::MediaCapture^ sender, Windows::Media::Capture::MediaCaptureFailedEventArgs^ errorEventArgs)
00141         {
00142             // Forward the error to listeners.
00143             Failed(this, ref new CaptureFailedEventArgs(errorEventArgs->Code, errorEventArgs->Message));
00144         }
00145
00146         /// <summary>
00147         /// There is an incoming connection.
00148         /// </summary>
00149         void OnIncomingConnection(Microsoft::Samples::SimpleCommunication::StspMediaSink^ sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ args)
00150         {
00151             // Forward the event to listeners.
00152             Incomingconnectionevent(sender, args);
00153         }
00154
00155         property Platform::Agile<Windows::Media::Capture::MediaCapture> MediaCapture
00156         {
00157             Platform::Agile<Windows::Media::Capture::MediaCapture> get();
00158         }
00159     };
00160 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/DebugLoggingExceptionPolicy.cpp Source File

  • Hilo C++
  • Hilo

DebugLoggingExceptionPolicy.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "DebugLoggingExceptionPolicy.h"
00009
00010 using namespace Hilo;
00011 using namespace Platform;
00012 using namespace std;
00013
00014 void DebugLoggingExceptionPolicy::HandleException(Exception^ exception)
00015 {
00016     assert(exception != nullptr);
00017     wstringstream ss;
00018     ss << "[HR: " << exception->HResult << "] " << exception->Message->Data();
00019     OutputDebugString(ss.str().c_str());
00020 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/SampleData/SampleDataSource.h Source File

  • XAML personality animations
  • SampleData

SampleDataSource.h

Go to the documentation of this file.
00001 #pragma once
00002 #include <string>
00003 #include <sstream>
00004 #include <algorithm>
00005 #include <collection.h>
00006 #include <ppltasks.h>
00007
00008 namespace SDKSample
00009 {
00010   namespace ExpressionBlendSampleDataSampleDataSource
00011   {
00012     using namespace Platform;
00013     using namespace Windows::UI::Xaml::Data;
00014     using namespace Windows::UI::Xaml::Media;
00015     using namespace Windows::UI::Xaml::Media::Imaging;
00016     using namespace Windows::Foundation::Collections;
00017
00018     [Windows::UI::Xaml::Data::Bindable]
00019     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00020     /// <summary>
00021     /// An empty page that can be used on its own or navigated to within a Frame.
00022     /// </summary>
00023     public ref class Item sealed
00024     {
00025     public:
00026       Item();
00027
00028     private:
00029       Platform::String^  _Title;
00030       Platform::String^  _Subtitle;
00031       Platform::String^  _Link;
00032       Platform::String^  _Category;
00033       Platform::String^ _Description;
00034       Platform::String^ _Content;
00035       ImageSource^ _Image;
00036       event PropertyChangedEventHandler^ _PropertyChanged;
00037
00038     public:
00039       //void OnApplyTemplate();
00040       void OnPropertyChanged(Platform::String^ propertyName)
00041       {
00042         PropertyChangedEventArgs^ pcea = ref new  PropertyChangedEventArgs(propertyName);
00043         _PropertyChanged(this,pcea);
00044       }
00045
00046       //Title
00047       property Platform::String^ Title
00048       {
00049         Platform::String^ get()
00050         {
00051           return _Title;
00052         }
00053         void set(Platform::String^ value)
00054         {
00055           _Title = value;
00056           OnPropertyChanged("Title");
00057         }
00058       }
00059
00060       //Subtitle
00061       property Platform::String^ Subtitle
00062       {
00063         Platform::String^ get()
00064         {
00065           return _Subtitle;
00066         }
00067         void set(Platform::String^ value)
00068         {
00069           _Subtitle = value;
00070           OnPropertyChanged("Subtitle");
00071         }
00072       }
00073
00074       //Link
00075       property Platform::String^ Link
00076       {
00077         Platform::String^ get()
00078         {
00079           return _Link;
00080         }
00081         void set(Platform::String^ value)
00082         {
00083           _Link = value;
00084           OnPropertyChanged("Link");
00085         }
00086       }
00087
00088
00089       //Category
00090       property Platform::String^ Category
00091       {
00092         Platform::String^ get()
00093         {
00094           return _Category;
00095         }
00096         void set(Platform::String^ value)
00097         {
00098           _Category = value;
00099           OnPropertyChanged("Category");
00100         }
00101       }
00102
00103       //Description
00104       property Platform::String^ Description
00105       {
00106         Platform::String^ get()
00107         {
00108           return _Description;
00109         }
00110         void set(Platform::String^ value)
00111         {
00112           _Description = value;
00113           OnPropertyChanged("Description");
00114         }
00115       }
00116
00117       //Content
00118       property Platform::String^ Content
00119       {
00120         Platform::String^ get()
00121         {
00122           return _Content;
00123         }
00124         void set(Platform::String^ value)
00125         {
00126           _Content = value;
00127           OnPropertyChanged("Content");
00128         }
00129       }
00130
00131       //Image
00132       property ImageSource^ Image
00133       {
00134         ImageSource^ get()
00135         {
00136           return _Image;
00137         }
00138         void set(ImageSource^ value)
00139         {
00140           _Image = value;
00141           OnPropertyChanged("Image");
00142         }
00143       }
00144
00145       void SetImage(Windows::Foundation::Uri^ baseUri, Platform::String^ path) //SetImage() in C# code
00146       {
00147         Windows::Foundation::Uri^ uri = ref new Windows::Foundation::Uri("ms-appx:///" + path);
00148         Image = ref new BitmapImage(uri);
00149       }
00150
00151     };
00152
00153
00154     // Workaround: data binding works best with an enumeration of objects that does not implement IList
00155     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00156     public ref class ItemCollection sealed
00157     {
00158     private:
00159       Platform::Collections::Vector<Item^>^ itemCollection;
00160
00161     public:
00162       ItemCollection()
00163       {
00164           itemCollection = ref new Platform::Collections::Vector<Item^>();
00165       };
00166
00167       void Add(Item^ item)
00168       {
00169         itemCollection->Append(item);
00170       }
00171     };
00172
00173     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00174     public ref class MessageData sealed
00175     {
00176       //ItemCollection^ _Collection;
00177       Windows::UI::Xaml::Interop::IBindableObservableVector^  _items;
00178
00179     public:
00180       MessageData()
00181       {
00182         _items = ref new Platform::Collections::Vector<Item^>();
00183         Windows::Foundation::Uri^ _baseUri = ref new Windows::Foundation::Uri("ms-appx:///");
00184
00185         Item^ item;
00186         item = ref new Item();
00187         item->Title="New Flavors out this week!";
00188         item->Subtitle="Adam Barr";
00189         item->SetImage(_baseUri, "SampleData/Images/image1.jpg");
00190         item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum";
00191         _items->Append(item);
00192
00193         item = ref new Item();
00194         item->Title="Check out this topping!";
00195         item->Subtitle="David Alexander";
00196         item->SetImage(_baseUri, "SampleData/Images/image2.jpg");
00197         item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue";
00198         _items->Append(item);
00199
00200         item = ref new Item();
00201         item->Title="Come to the Ice Cream Party";
00202         item->Subtitle="Josh Bailey";
00203         item->SetImage(_baseUri, "SampleData/Images/image3.jpg");
00204         item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse";
00205         _items->Append(item);
00206
00207         item = ref new Item();
00208         item->Title="How about gluten free?";
00209         item->Subtitle="Chris Berry";
00210         item->SetImage(_baseUri, "SampleData/Images/image4.jpg");
00211         item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
00212         _items->Append(item);
00213
00214         item = ref new Item();
00215         item->Title= "Summer promotion - BYGO";
00216         item->Subtitle="Sean Bentley";
00217         item->SetImage(_baseUri, "SampleData/Images/image5.jpg");
00218         item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat";
00219         _items->Append(item);
00220
00221         item = ref new Item();
00222         item->Title="Awesome flavor combination";
00223         item->Subtitle="Adrian Lannin";
00224         item->SetImage(_baseUri, "SampleData/Images/image6.jpg");
00225         item->Content="Curabitur class aliquam vestibulum nam curae maecenas sed integer";
00226         _items->Append(item);
00227       }
00228
00229       property Windows::UI::Xaml::Interop::IBindableObservableVector^ Items
00230       {
00231         Windows::UI::Xaml::Interop::IBindableObservableVector^ get()
00232         {
00233           return _items;
00234         }
00235
00236       }
00237     };
00238   }
00239 }
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/common/suspensionmanager.cpp Source File

  • Lock screen personalization
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/ServicingComplete.cpp Source File

  • Background task
  • Tasks

ServicingComplete.cpp

Go to the documentation of this file.
00001 // ServicingComplete.cpp
00002 #include "pch.h"
00003 #include "ServicingComplete.h"
00004
00005 using namespace Tasks;
00006 using namespace Windows::Storage;
00007
00008 ServicingComplete::ServicingComplete() :
00009     CancelRequested(false)
00010 {
00011 }
00012
00013 ServicingComplete::~ServicingComplete()
00014 {
00015 }
00016
00017 void ServicingComplete::Run(IBackgroundTaskInstance^ taskInstance)
00018 {
00019     //
00020     // Do the background task activity.
00021     //
00022     unsigned int progress;
00023     for (progress = 0; progress <= 100; progress += 10)
00024     {
00025         //
00026         // If the cancellation handler indicated that the task was canceled, stop doing the task.
00027         //
00028         if (CancelRequested)
00029         {
00030             break;
00031         }
00032
00033         //
00034         // Indicate progress to the foreground application.
00035         //
00036         taskInstance->Progress = progress;
00037     }
00038
00039     //
00040     // Write to LocalSettings to indicate that this background task ran.
00041     //
00042     auto settings = ApplicationData::Current->LocalSettings;
00043   auto key = taskInstance->Task->Name;
00044     settings->Values->Insert(key, (progress < 100) ? "Canceled" : "Completed");
00045 }
00046
00047 void ServicingComplete::OnCanceled(IBackgroundTaskInstance^ taskInstance, BackgroundTaskCancellationReason reason)
00048 {
00049     //
00050     // Indicate that the background task is canceled.
00051     //
00052     CancelRequested = true;
00053 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/MainPage.xaml.cpp Source File

  • XAML accessibility

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/pch.cpp Source File

  • Syndication

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicLoader.cpp Source File

  • Direct3D HLSL fractal generator

BasicLoader.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicLoader.h"
00010 #include "BasicShapes.h"
00011 #include "DDSTextureLoader.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 using namespace Microsoft::WRL;
00016 using namespace Windows::Storage;
00017 using namespace Windows::Storage::Streams;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::ApplicationModel;
00020 using namespace std;
00021 using namespace concurrency;
00022
00023 BasicLoader::BasicLoader(
00024     _In_ ID3D11Device* d3dDevice,
00025     _In_opt_ IWICImagingFactory2* wicFactory
00026     ) :
00027     m_d3dDevice(d3dDevice),
00028     m_wicFactory(wicFactory)
00029 {
00030     // Create a new BasicReaderWriter to do raw file I/O.
00031     m_basicReaderWriter = ref new BasicReaderWriter();
00032 }
00033
00034 template <class DeviceChildType>
00035 inline void BasicLoader::SetDebugName(
00036     _In_ DeviceChildType* object,
00037     _In_ Platform::String^ name
00038     )
00039 {
00040 #if defined(_DEBUG)
00041     // Only assign debug names in debug builds.
00042
00043     char nameString[1024];
00044     int nameStringLength = WideCharToMultiByte(
00045         CP_ACP,
00046         0,
00047         name->Data(),
00048         -1,
00049         nameString,
00050         1024,
00051         nullptr,
00052         nullptr
00053         );
00054
00055     if (nameStringLength == 0)
00056     {
00057         char defaultNameString[] = "BasicLoaderObject";
00058         DX::ThrowIfFailed(
00059             object->SetPrivateData(
00060                 WKPDID_D3DDebugObjectName,
00061                 sizeof(defaultNameString) - 1,
00062                 defaultNameString
00063                 )
00064             );
00065     }
00066     else
00067     {
00068         DX::ThrowIfFailed(
00069             object->SetPrivateData(
00070                 WKPDID_D3DDebugObjectName,
00071                 nameStringLength - 1,
00072                 nameString
00073                 )
00074             );
00075     }
00076 #endif
00077 }
00078
00079 Platform::String^ BasicLoader::GetExtension(
00080     _In_ Platform::String^ filename
00081     )
00082 {
00083     int lastDotIndex = -1;
00084     for (int i = filename->Length() - 1; i >= 0 && lastDotIndex == -1; i--)
00085     {
00086         if (*(filename->Data() + i) == '.')
00087         {
00088             lastDotIndex = i;
00089         }
00090     }
00091     if (lastDotIndex != -1)
00092     {
00093         std::unique_ptr<wchar_t[]> extension(new wchar_t[filename->Length() - lastDotIndex]);
00094         for (unsigned int i = 0; i < filename->Length() - lastDotIndex; i++)
00095         {
00096             extension[i] = tolower(*(filename->Data() + lastDotIndex + 1 + i));
00097         }
00098         return ref new Platform::String(extension.get());
00099     }
00100     return "";
00101 }
00102
00103 void BasicLoader::CreateTexture(
00104     _In_ bool decodeAsDDS,
00105     _In_reads_bytes_(dataSize) byte* data,
00106     _In_ uint32 dataSize,
00107     _Out_opt_ ID3D11Texture2D** texture,
00108     _Out_opt_ ID3D11ShaderResourceView** textureView,
00109     _In_opt_ Platform::String^ debugName
00110     )
00111 {
00112     ComPtr<ID3D11ShaderResourceView> shaderResourceView;
00113     ComPtr<ID3D11Texture2D> texture2D;
00114
00115     if (decodeAsDDS)
00116     {
00117         ComPtr<ID3D11Resource> resource;
00118
00119         if (textureView == nullptr)
00120         {
00121             CreateDDSTextureFromMemory(
00122                 m_d3dDevice.Get(),
00123                 data,
00124                 dataSize,
00125                 &resource,
00126                 nullptr
00127                 );
00128         }
00129         else
00130         {
00131             CreateDDSTextureFromMemory(
00132                 m_d3dDevice.Get(),
00133                 data,
00134                 dataSize,
00135                 &resource,
00136                 &shaderResourceView
00137                 );
00138         }
00139
00140         DX::ThrowIfFailed(
00141             resource.As(&texture2D)
00142             );
00143     }
00144     else
00145     {
00146         if (m_wicFactory.Get() == nullptr)
00147         {
00148             // A WIC factory object is required in order to load texture
00149             // assets stored in non-DDS formats.  If BasicLoader was not
00150             // initialized with one, create one as needed.
00151             DX::ThrowIfFailed(
00152                 CoCreateInstance(
00153                     CLSID_WICImagingFactory,
00154                     nullptr,
00155                     CLSCTX_INPROC_SERVER,
00156                     IID_PPV_ARGS(&m_wicFactory)
00157                     )
00158                 );
00159         }
00160
00161         ComPtr<IWICStream> stream;
00162         DX::ThrowIfFailed(
00163             m_wicFactory->CreateStream(&stream)
00164             );
00165
00166         DX::ThrowIfFailed(
00167             stream->InitializeFromMemory(
00168                 data,
00169                 dataSize
00170                 )
00171             );
00172
00173         ComPtr<IWICBitmapDecoder> bitmapDecoder;
00174         DX::ThrowIfFailed(
00175             m_wicFactory->CreateDecoderFromStream(
00176                 stream.Get(),
00177                 nullptr,
00178                 WICDecodeMetadataCacheOnDemand,
00179                 &bitmapDecoder
00180                 )
00181             );
00182
00183         ComPtr<IWICBitmapFrameDecode> bitmapFrame;
00184         DX::ThrowIfFailed(
00185             bitmapDecoder->GetFrame(0, &bitmapFrame)
00186             );
00187
00188         ComPtr<IWICFormatConverter> formatConverter;
00189         DX::ThrowIfFailed(
00190             m_wicFactory->CreateFormatConverter(&formatConverter)
00191             );
00192
00193         DX::ThrowIfFailed(
00194             formatConverter->Initialize(
00195                 bitmapFrame.Get(),
00196                 GUID_WICPixelFormat32bppPBGRA,
00197                 WICBitmapDitherTypeNone,
00198                 nullptr,
00199                 0.0,
00200                 WICBitmapPaletteTypeCustom
00201                 )
00202             );
00203
00204         uint32 width;
00205         uint32 height;
00206         DX::ThrowIfFailed(
00207             bitmapFrame->GetSize(&width, &height)
00208             );
00209
00210         std::unique_ptr<byte[]> bitmapPixels(new byte[width * height * 4]);
00211         DX::ThrowIfFailed(
00212             formatConverter->CopyPixels(
00213                 nullptr,
00214                 width * 4,
00215                 width * height * 4,
00216                 bitmapPixels.get()
00217                 )
00218             );
00219
00220         D3D11_SUBRESOURCE_DATA initialData;
00221         ZeroMemory(&initialData, sizeof(initialData));
00222         initialData.pSysMem = bitmapPixels.get();
00223         initialData.SysMemPitch = width * 4;
00224         initialData.SysMemSlicePitch = 0;
00225
00226         CD3D11_TEXTURE2D_DESC textureDesc(
00227             DXGI_FORMAT_B8G8R8A8_UNORM,
00228             width,
00229             height,
00230             1,
00231             1
00232             );
00233
00234         DX::ThrowIfFailed(
00235             m_d3dDevice->CreateTexture2D(
00236                 &textureDesc,
00237                 &initialData,
00238                 &texture2D
00239                 )
00240             );
00241
00242         if (textureView != nullptr)
00243         {
00244             CD3D11_SHADER_RESOURCE_VIEW_DESC shaderResourceViewDesc(
00245                 texture2D.Get(),
00246                 D3D11_SRV_DIMENSION_TEXTURE2D
00247                 );
00248
00249             DX::ThrowIfFailed(
00250                 m_d3dDevice->CreateShaderResourceView(
00251                     texture2D.Get(),
00252                     &shaderResourceViewDesc,
00253                     &shaderResourceView
00254                     )
00255                 );
00256         }
00257     }
00258
00259     SetDebugName(texture2D.Get(), debugName);
00260
00261     if (texture != nullptr)
00262     {
00263         *texture = texture2D.Detach();
00264     }
00265     if (textureView != nullptr)
00266     {
00267         *textureView = shaderResourceView.Detach();
00268     }
00269 }
00270
00271 void BasicLoader::CreateInputLayout(
00272     _In_reads_bytes_(bytecodeSize) byte* bytecode,
00273     _In_ uint32 bytecodeSize,
00274     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00275     _In_ uint32 layoutDescNumElements,
00276     _Out_ ID3D11InputLayout** layout
00277     )
00278 {
00279     if (layoutDesc == nullptr)
00280     {
00281         // If no input layout is specified, use the BasicVertex layout.
00282         const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
00283         {
00284             { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
00285             { "NORMAL",   0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00286             { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 24, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00287         };
00288
00289         DX::ThrowIfFailed(
00290             m_d3dDevice->CreateInputLayout(
00291                 basicVertexLayoutDesc,
00292                 ARRAYSIZE(basicVertexLayoutDesc),
00293                 bytecode,
00294                 bytecodeSize,
00295                 layout
00296                 )
00297             );
00298     }
00299     else
00300     {
00301         DX::ThrowIfFailed(
00302             m_d3dDevice->CreateInputLayout(
00303                 layoutDesc,
00304                 layoutDescNumElements,
00305                 bytecode,
00306                 bytecodeSize,
00307                 layout
00308                 )
00309             );
00310     }
00311 }
00312
00313 void BasicLoader::CreateMesh(
00314     _In_ byte* meshData,
00315     _Out_ ID3D11Buffer** vertexBuffer,
00316     _Out_ ID3D11Buffer** indexBuffer,
00317     _Out_opt_ uint32* vertexCount,
00318     _Out_opt_ uint32* indexCount,
00319     _In_opt_ Platform::String^ debugName
00320     )
00321 {
00322     // The first 4 bytes of the BasicMesh format define the number of vertices in the mesh.
00323     uint32 numVertices = *reinterpret_cast<uint32*>(meshData);
00324
00325     // The following 4 bytes define the number of indices in the mesh.
00326     uint32 numIndices = *reinterpret_cast<uint32*>(meshData + sizeof(uint32));
00327
00328     // The next segment of the BasicMesh format contains the vertices of the mesh.
00329     BasicVertex* vertices = reinterpret_cast<BasicVertex*>(meshData + sizeof(uint32) * 2);
00330
00331     // The last segment of the BasicMesh format contains the indices of the mesh.
00332     uint16* indices = reinterpret_cast<uint16*>(meshData + sizeof(uint32) * 2 + sizeof(BasicVertex) * numVertices);
00333
00334     // Create the vertex and index buffers with the mesh data.
00335
00336     D3D11_SUBRESOURCE_DATA vertexBufferData = {0};
00337     vertexBufferData.pSysMem = vertices;
00338     vertexBufferData.SysMemPitch = 0;
00339     vertexBufferData.SysMemSlicePitch = 0;
00340     CD3D11_BUFFER_DESC vertexBufferDesc(numVertices * sizeof(BasicVertex), D3D11_BIND_VERTEX_BUFFER);
00341     DX::ThrowIfFailed(
00342         m_d3dDevice->CreateBuffer(
00343             &vertexBufferDesc,
00344             &vertexBufferData,
00345             vertexBuffer
00346             )
00347         );
00348
00349     D3D11_SUBRESOURCE_DATA indexBufferData = {0};
00350     indexBufferData.pSysMem = indices;
00351     indexBufferData.SysMemPitch = 0;
00352     indexBufferData.SysMemSlicePitch = 0;
00353     CD3D11_BUFFER_DESC indexBufferDesc(numIndices * sizeof(uint16), D3D11_BIND_INDEX_BUFFER);
00354     DX::ThrowIfFailed(
00355         m_d3dDevice->CreateBuffer(
00356             &indexBufferDesc,
00357             &indexBufferData,
00358             indexBuffer
00359             )
00360         );
00361
00362     SetDebugName(*vertexBuffer, Platform::String::Concat(debugName, "_VertexBuffer"));
00363     SetDebugName(*indexBuffer, Platform::String::Concat(debugName, "_IndexBuffer"));
00364
00365     if (vertexCount != nullptr)
00366     {
00367         *vertexCount = numVertices;
00368     }
00369     if (indexCount != nullptr)
00370     {
00371         *indexCount = numIndices;
00372     }
00373 }
00374
00375 void BasicLoader::LoadTexture(
00376     _In_ Platform::String^ filename,
00377     _Out_opt_ ID3D11Texture2D** texture,
00378     _Out_opt_ ID3D11ShaderResourceView** textureView
00379     )
00380 {
00381     Platform::Array<byte>^ textureData = m_basicReaderWriter->ReadData(filename);
00382
00383     CreateTexture(
00384         GetExtension(filename) == "dds",
00385         textureData->Data,
00386         textureData->Length,
00387         texture,
00388         textureView,
00389         filename
00390         );
00391 }
00392
00393 task<void> BasicLoader::LoadTextureAsync(
00394     _In_ Platform::String^ filename,
00395     _Out_opt_ ID3D11Texture2D** texture,
00396     _Out_opt_ ID3D11ShaderResourceView** textureView
00397     )
00398 {
00399     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ textureData)
00400     {
00401         CreateTexture(
00402             GetExtension(filename) == "dds",
00403             textureData->Data,
00404             textureData->Length,
00405             texture,
00406             textureView,
00407             filename
00408             );
00409     });
00410 }
00411
00412 void BasicLoader::LoadShader(
00413     _In_ Platform::String^ filename,
00414     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00415     _In_ uint32 layoutDescNumElements,
00416     _Out_ ID3D11VertexShader** shader,
00417     _Out_opt_ ID3D11InputLayout** layout
00418     )
00419 {
00420     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00421
00422     DX::ThrowIfFailed(
00423         m_d3dDevice->CreateVertexShader(
00424             bytecode->Data,
00425             bytecode->Length,
00426             nullptr,
00427             shader
00428             )
00429         );
00430
00431     SetDebugName(*shader, filename);
00432
00433     if (layout != nullptr)
00434     {
00435         CreateInputLayout(
00436             bytecode->Data,
00437             bytecode->Length,
00438             layoutDesc,
00439             layoutDescNumElements,
00440             layout
00441             );
00442
00443         SetDebugName(*layout, filename);
00444     }
00445 }
00446
00447 task<void> BasicLoader::LoadShaderAsync(
00448     _In_ Platform::String^ filename,
00449     _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00450     _In_ uint32 layoutDescNumElements,
00451     _Out_ ID3D11VertexShader** shader,
00452     _Out_opt_ ID3D11InputLayout** layout
00453     )
00454 {
00455     // This method assumes that the lifetime of input arguments may be shorter
00456     // than the duration of this task.  In order to ensure accurate results, a
00457     // copy of all arguments passed by pointer must be made.  The method then
00458     // ensures that the lifetime of the copied data exceeds that of the task.
00459
00460     // Create copies of the layoutDesc array as well as the SemanticName strings,
00461     // both of which are pointers to data whose lifetimes may be shorter than that
00462     // of this method's task.
00463     shared_ptr<vector<D3D11_INPUT_ELEMENT_DESC>> layoutDescCopy;
00464     shared_ptr<vector<string>> layoutDescSemanticNamesCopy;
00465     if (layoutDesc != nullptr)
00466     {
00467         layoutDescCopy.reset(
00468             new vector<D3D11_INPUT_ELEMENT_DESC>(
00469                 layoutDesc,
00470                 layoutDesc + layoutDescNumElements
00471                 )
00472             );
00473
00474         layoutDescSemanticNamesCopy.reset(
00475             new vector<string>(layoutDescNumElements)
00476             );
00477
00478         for (uint32 i = 0; i < layoutDescNumElements; i++)
00479         {
00480             layoutDescSemanticNamesCopy->at(i).assign(layoutDesc[i].SemanticName);
00481         }
00482     }
00483
00484     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00485     {
00486         DX::ThrowIfFailed(
00487             m_d3dDevice->CreateVertexShader(
00488                 bytecode->Data,
00489                 bytecode->Length,
00490                 nullptr,
00491                 shader
00492                 )
00493             );
00494
00495         SetDebugName(*shader, filename);
00496
00497         if (layout != nullptr)
00498         {
00499             if (layoutDesc != nullptr)
00500             {
00501                 // Reassign the SemanticName elements of the layoutDesc array copy to point
00502                 // to the corresponding copied strings. Performing the assignment inside the
00503                 // lambda body ensures that the lambda will take a reference to the shared_ptr
00504                 // that holds the data.  This will guarantee that the data is still valid when
00505                 // CreateInputLayout is called.
00506                 for (uint32 i = 0; i < layoutDescNumElements; i++)
00507                 {
00508                     layoutDescCopy->at(i).SemanticName = layoutDescSemanticNamesCopy->at(i).c_str();
00509                 }
00510             }
00511
00512             CreateInputLayout(
00513                 bytecode->Data,
00514                 bytecode->Length,
00515                 layoutDesc == nullptr ? nullptr : layoutDescCopy->data(),
00516                 layoutDescNumElements,
00517                 layout
00518                 );
00519
00520             SetDebugName(*layout, filename);
00521         }
00522     });
00523 }
00524
00525 void BasicLoader::LoadShader(
00526     _In_ Platform::String^ filename,
00527     _Out_ ID3D11PixelShader** shader
00528     )
00529 {
00530     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00531
00532     DX::ThrowIfFailed(
00533         m_d3dDevice->CreatePixelShader(
00534             bytecode->Data,
00535             bytecode->Length,
00536             nullptr,
00537             shader
00538             )
00539         );
00540
00541     SetDebugName(*shader, filename);
00542 }
00543
00544 task<void> BasicLoader::LoadShaderAsync(
00545     _In_ Platform::String^ filename,
00546     _Out_ ID3D11PixelShader** shader
00547     )
00548 {
00549     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00550     {
00551         DX::ThrowIfFailed(
00552             m_d3dDevice->CreatePixelShader(
00553                 bytecode->Data,
00554                 bytecode->Length,
00555                 nullptr,
00556                 shader
00557                 )
00558             );
00559
00560         SetDebugName(*shader, filename);
00561     });
00562 }
00563
00564 void BasicLoader::LoadShader(
00565     _In_ Platform::String^ filename,
00566     _Out_ ID3D11ComputeShader** shader
00567     )
00568 {
00569     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00570
00571     DX::ThrowIfFailed(
00572         m_d3dDevice->CreateComputeShader(
00573             bytecode->Data,
00574             bytecode->Length,
00575             nullptr,
00576             shader
00577             )
00578         );
00579
00580     SetDebugName(*shader, filename);
00581 }
00582
00583 task<void> BasicLoader::LoadShaderAsync(
00584     _In_ Platform::String^ filename,
00585     _Out_ ID3D11ComputeShader** shader
00586     )
00587 {
00588     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00589     {
00590         DX::ThrowIfFailed(
00591             m_d3dDevice->CreateComputeShader(
00592                 bytecode->Data,
00593                 bytecode->Length,
00594                 nullptr,
00595                 shader
00596                 )
00597             );
00598
00599         SetDebugName(*shader, filename);
00600     });
00601 }
00602
00603 void BasicLoader::LoadShader(
00604     _In_ Platform::String^ filename,
00605     _Out_ ID3D11GeometryShader** shader
00606     )
00607 {
00608     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00609
00610     DX::ThrowIfFailed(
00611         m_d3dDevice->CreateGeometryShader(
00612             bytecode->Data,
00613             bytecode->Length,
00614             nullptr,
00615             shader
00616             )
00617         );
00618
00619     SetDebugName(*shader, filename);
00620 }
00621
00622 task<void> BasicLoader::LoadShaderAsync(
00623     _In_ Platform::String^ filename,
00624     _Out_ ID3D11GeometryShader** shader
00625     )
00626 {
00627     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00628     {
00629         DX::ThrowIfFailed(
00630             m_d3dDevice->CreateGeometryShader(
00631                 bytecode->Data,
00632                 bytecode->Length,
00633                 nullptr,
00634                 shader
00635                 )
00636             );
00637
00638         SetDebugName(*shader, filename);
00639     });
00640 }
00641
00642 void BasicLoader::LoadShader(
00643     _In_ Platform::String^ filename,
00644     _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00645     _In_ uint32 numEntries,
00646     _In_reads_opt_(numStrides) const uint32* bufferStrides,
00647     _In_ uint32 numStrides,
00648     _In_ uint32 rasterizedStream,
00649     _Out_ ID3D11GeometryShader** shader
00650     )
00651 {
00652     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00653
00654     DX::ThrowIfFailed(
00655         m_d3dDevice->CreateGeometryShaderWithStreamOutput(
00656             bytecode->Data,
00657             bytecode->Length,
00658             streamOutDeclaration,
00659             numEntries,
00660             bufferStrides,
00661             numStrides,
00662             rasterizedStream,
00663             nullptr,
00664             shader
00665             )
00666         );
00667
00668     SetDebugName(*shader, filename);
00669 }
00670
00671 task<void> BasicLoader::LoadShaderAsync(
00672     _In_ Platform::String^ filename,
00673     _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00674     _In_ uint32 numEntries,
00675     _In_reads_opt_(numStrides) const uint32* bufferStrides,
00676     _In_ uint32 numStrides,
00677     _In_ uint32 rasterizedStream,
00678     _Out_ ID3D11GeometryShader** shader
00679     )
00680 {
00681     // This method assumes that the lifetime of input arguments may be shorter
00682     // than the duration of this task.  In order to ensure accurate results, a
00683     // copy of all arguments passed by pointer must be made.  The method then
00684     // ensures that the lifetime of the copied data exceeds that of the task.
00685
00686     // Create copies of the streamOutDeclaration array as well as the SemanticName
00687     // strings, both of which are pointers to data whose lifetimes may be shorter
00688     // than that of this method's task.
00689     shared_ptr<vector<D3D11_SO_DECLARATION_ENTRY>> streamOutDeclarationCopy;
00690     shared_ptr<vector<string>> streamOutDeclarationSemanticNamesCopy;
00691     if (streamOutDeclaration != nullptr)
00692     {
00693         streamOutDeclarationCopy.reset(
00694             new vector<D3D11_SO_DECLARATION_ENTRY>(
00695                 streamOutDeclaration,
00696                 streamOutDeclaration + numEntries
00697                 )
00698             );
00699
00700         streamOutDeclarationSemanticNamesCopy.reset(
00701             new vector<string>(numEntries)
00702             );
00703
00704         for (uint32 i = 0; i < numEntries; i++)
00705         {
00706             streamOutDeclarationSemanticNamesCopy->at(i).assign(streamOutDeclaration[i].SemanticName);
00707         }
00708     }
00709
00710     // Create a copy of the bufferStrides array, which is a pointer to data
00711     // whose lifetime may be shorter than that of this method's task.
00712     shared_ptr<vector<uint32>> bufferStridesCopy;
00713     if (bufferStrides != nullptr)
00714     {
00715         bufferStridesCopy.reset(
00716             new vector<uint32>(
00717                 bufferStrides,
00718                 bufferStrides + numStrides
00719                 )
00720             );
00721     }
00722
00723     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00724     {
00725         if (streamOutDeclaration != nullptr)
00726         {
00727             // Reassign the SemanticName elements of the streamOutDeclaration array copy to
00728             // point to the corresponding copied strings. Performing the assignment inside the
00729             // lambda body ensures that the lambda will take a reference to the shared_ptr
00730             // that holds the data.  This will guarantee that the data is still valid when
00731             // CreateGeometryShaderWithStreamOutput is called.
00732             for (uint32 i = 0; i < numEntries; i++)
00733             {
00734                 streamOutDeclarationCopy->at(i).SemanticName = streamOutDeclarationSemanticNamesCopy->at(i).c_str();
00735             }
00736         }
00737
00738         DX::ThrowIfFailed(
00739             m_d3dDevice->CreateGeometryShaderWithStreamOutput(
00740                 bytecode->Data,
00741                 bytecode->Length,
00742                 streamOutDeclaration == nullptr ? nullptr : streamOutDeclarationCopy->data(),
00743                 numEntries,
00744                 bufferStrides == nullptr ? nullptr : bufferStridesCopy->data(),
00745                 numStrides,
00746                 rasterizedStream,
00747                 nullptr,
00748                 shader
00749                 )
00750             );
00751
00752         SetDebugName(*shader, filename);
00753     });
00754 }
00755
00756 void BasicLoader::LoadShader(
00757     _In_ Platform::String^ filename,
00758     _Out_ ID3D11HullShader** shader
00759     )
00760 {
00761     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00762
00763     DX::ThrowIfFailed(
00764         m_d3dDevice->CreateHullShader(
00765             bytecode->Data,
00766             bytecode->Length,
00767             nullptr,
00768             shader
00769             )
00770         );
00771
00772     SetDebugName(*shader, filename);
00773 }
00774
00775 task<void> BasicLoader::LoadShaderAsync(
00776     _In_ Platform::String^ filename,
00777     _Out_ ID3D11HullShader** shader
00778     )
00779 {
00780     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00781     {
00782         DX::ThrowIfFailed(
00783             m_d3dDevice->CreateHullShader(
00784                 bytecode->Data,
00785                 bytecode->Length,
00786                 nullptr,
00787                 shader
00788                 )
00789             );
00790
00791         SetDebugName(*shader, filename);
00792     });
00793 }
00794
00795 void BasicLoader::LoadShader(
00796     _In_ Platform::String^ filename,
00797     _Out_ ID3D11DomainShader** shader
00798     )
00799 {
00800     Platform::Array<byte>^ bytecode = m_basicReaderWriter->ReadData(filename);
00801
00802     DX::ThrowIfFailed(
00803         m_d3dDevice->CreateDomainShader(
00804             bytecode->Data,
00805             bytecode->Length,
00806             nullptr,
00807             shader
00808             )
00809         );
00810
00811     SetDebugName(*shader, filename);
00812 }
00813
00814 task<void> BasicLoader::LoadShaderAsync(
00815     _In_ Platform::String^ filename,
00816     _Out_ ID3D11DomainShader** shader
00817     )
00818 {
00819     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ bytecode)
00820     {
00821         DX::ThrowIfFailed(
00822             m_d3dDevice->CreateDomainShader(
00823                 bytecode->Data,
00824                 bytecode->Length,
00825                 nullptr,
00826                 shader
00827                 )
00828             );
00829
00830         SetDebugName(*shader, filename);
00831     });
00832 }
00833
00834 void BasicLoader::LoadMesh(
00835     _In_ Platform::String^ filename,
00836     _Out_ ID3D11Buffer** vertexBuffer,
00837     _Out_ ID3D11Buffer** indexBuffer,
00838     _Out_opt_ uint32* vertexCount,
00839     _Out_opt_ uint32* indexCount
00840     )
00841 {
00842     Platform::Array<byte>^ meshData = m_basicReaderWriter->ReadData(filename);
00843
00844     CreateMesh(
00845         meshData->Data,
00846         vertexBuffer,
00847         indexBuffer,
00848         vertexCount,
00849         indexCount,
00850         filename
00851         );
00852 }
00853
00854 task<void> BasicLoader::LoadMeshAsync(
00855     _In_ Platform::String^ filename,
00856     _Out_ ID3D11Buffer** vertexBuffer,
00857     _Out_ ID3D11Buffer** indexBuffer,
00858     _Out_opt_ uint32* vertexCount,
00859     _Out_opt_ uint32* indexCount
00860     )
00861 {
00862     return m_basicReaderWriter->ReadDataAsync(filename).then([=](const Platform::Array<byte>^ meshData)
00863     {
00864         CreateMesh(
00865             meshData->Data,
00866             vertexBuffer,
00867             indexBuffer,
00868             vertexCount,
00869             indexCount,
00870             filename
00871             );
00872     });
00873 }
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario2.xaml.h Source File

  • XAML user and custom controls

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace UserAndCustomControls
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void DoSomething_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/DeviceAppForPrinters/pch.h Source File

  • Device app for printers SDK
  • DeviceAppForPrinters

pch.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include "Sample-Utils\CppSamplesUtils.h"
00019 #include <ppltasks.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario1.xaml.h Source File

  • XAML scrolling, panning, and zooming

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ScrollViewerCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         void hsmCombo_SelectionChanged_1(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00040         void hsbvCombo_SelectionChanged_1(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00041         void vsmCombo_SelectionChanged_1(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00042         void vsbvCombo_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00043         void CheckBox_Checked_HorizontalRailed(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044         void CheckBox_Unchecked_HorizontalRailed(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045         void CheckBox_Checked_VerticalRailed(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046         void CheckBox_Unchecked_VerticalRailed(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047         void Scenario1Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048         void Scenario1Reset();
00049       };
00050     }
00051 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/App.xaml.cpp Source File

  • Edge gesture invocation

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.cpp
00010 // Implementation of the App.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "App.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::ApplicationModel;
00020 using namespace Windows::ApplicationModel::Activation;
00021 using namespace CppSamplesUtils;
00022 using namespace EdgeGestureSample;
00023 using namespace Windows::UI::Xaml::Interop;
00024
00025 App::App()
00026 {
00027     InitializeComponent();
00028     this->Suspending += ref new SuspendingEventHandler(this, &EdgeGestureSample::App::OnSuspending);
00029 }
00030
00031 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00032 {
00033     auto deferral = pArgs->SuspendingOperation->GetDeferral();
00034     SuspensionManager::StartSaveTask().then([=]()
00035     {
00036         deferral->Complete();
00037     });
00038
00039 }
00040
00041 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00042 {
00043
00044     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00045     {
00046         SuspensionManager::StartRestoreTask().then([=]()
00047         {
00048             auto rootFrame = ref new Frame();
00049             TypeName pageType = { "EdgeGestureSample.MainPage", TypeKind::Custom };
00050             rootFrame->Navigate(pageType);
00051             Window::Current->Content = rootFrame;
00052             Window::Current->Activate();
00053         });
00054     }
00055     else
00056     {
00057         auto rootFrame = ref new Frame();
00058         TypeName pageType = { "EdgeGestureSample.MainPage", TypeKind::Custom };
00059         rootFrame->Navigate(pageType);
00060         Window::Current->Content = rootFrame;
00061         Window::Current->Activate();
00062     }
00063 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/pch.cpp Source File

  • Raw notifications
  • MainAppSample

pch.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // pch.cpp
00010 // Include the standard header and generate the precompiled header.
00011 //
00012
00013 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DirectXBase.cpp Source File

  • Direct3D resource loading

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickURLFile.xaml.cpp Source File

  • File picker contracts

FileOpenPicker_PickURLFile.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FileOpenPicker_PickURLFile.xaml.cpp
00013 // Implementation of the FileOpenPicker_PickURLFile class
00014 //
00015
00016 #include "pch.h"
00017 #include "FileOpenPickerPage.xaml.h"
00018 #include "FileOpenPicker_PickURLFile.xaml.h"
00019 #include "Constants.h"
00020
00021 using namespace SDKSample::FilePickerContracts;
00022
00023 using namespace concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::Foundation;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::Streams;
00029 using namespace Windows::Storage::Pickers::Provider;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Navigation;
00033
00034 FileOpenPicker_PickURLFile::FileOpenPicker_PickURLFile()
00035 {
00036     InitializeComponent();
00037
00038     fileID = ref new String(L"MyURLFile");
00039     fileOpenPickerUI = FileOpenPickerPage::Current->fileOpenPickerUI;
00040     AddURLFileButton->Click += ref new RoutedEventHandler(this, &FileOpenPicker_PickURLFile::AddURLFileButton_Click);
00041     RemoveURLFileButton->Click += ref new RoutedEventHandler(this, &FileOpenPicker_PickURLFile::RemoveURLFileButton_Click);
00042 }
00043
00044 void FileOpenPicker_PickURLFile::UpdateButtonState(bool fileInBasket)
00045 {
00046     AddURLFileButton->IsEnabled = !fileInBasket;
00047     RemoveURLFileButton->IsEnabled = fileInBasket;
00048 }
00049
00050 void FileOpenPicker_PickURLFile::OnNavigatedTo(NavigationEventArgs^ e)
00051 {
00052     UpdateButtonState(fileOpenPickerUI->ContainsFile(fileID));
00053     token = fileOpenPickerUI->FileRemoved += ref new TypedEventHandler<FileOpenPickerUI^, FileRemovedEventArgs^>(this, &FileOpenPicker_PickURLFile::OnFileRemoved, CallbackContext::Same);
00054 }
00055
00056 void FileOpenPicker_PickURLFile::OnNavigatedFrom(NavigationEventArgs^ e)
00057 {
00058     fileOpenPickerUI->FileRemoved -= token;
00059 }
00060
00061 void FileOpenPicker_PickURLFile::OnFileRemoved(FileOpenPickerUI^ fileOpenPickerUI, FileRemovedEventArgs^ e)
00062 {
00063     // make sure that the item got removed matches the one we added.
00064     if (e->Id == fileID)
00065     {
00066         OutputTextBlock->Text = Status::FileRemoved;
00067         UpdateButtonState(false);
00068     }
00069 }
00070
00071 void FileOpenPicker_PickURLFile::AddURLFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00072 {
00073     String^ const filename = ref new String(L"URI.png"); // This will be used as the filename of the StorageFile that references the specified URI
00074
00075     FileOpenPickerPage::Current->NotifyUser("", NotifyType::StatusMessage);
00076
00077     Uri^ uri = nullptr;
00078     try
00079     {
00080         uri = ref new Uri(URLInput->Text);
00081     }
00082     catch (Exception^)
00083     {
00084         FileOpenPickerPage::Current->NotifyUser("Please enter a valid URL.", NotifyType::ErrorMessage);
00085     }
00086
00087     if (uri != nullptr)
00088     {
00089         create_task(StorageFile::CreateStreamedFileFromUriAsync(filename, uri, RandomAccessStreamReference::CreateFromUri(uri))).then([this](StorageFile^ file)
00090         {
00091             bool inBasket;
00092             switch (fileOpenPickerUI->AddFile(fileID, file))
00093             {
00094             case AddFileResult::Added:
00095             case AddFileResult::AlreadyAdded:
00096                 inBasket = true;
00097                 OutputTextBlock->Text = Status::FileAdded;
00098                 break;
00099
00100             default:
00101                 inBasket = false;
00102                 OutputTextBlock->Text = Status::FileAddFailed;
00103                 break;
00104             }
00105             UpdateButtonState(inBasket);
00106         });
00107     }
00108 }
00109
00110 void FileOpenPicker_PickURLFile::RemoveURLFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00111 {
00112     if (fileOpenPickerUI->ContainsFile(fileID))
00113     {
00114         fileOpenPickerUI->RemoveFile(fileID);
00115         OutputTextBlock->Text = Status::FileRemoved;
00116     }
00117     UpdateButtonState(false);
00118 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/MainPage.xaml.cpp Source File

  • XAML text editing

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario4.xaml.cpp Source File

  • XAML text editing

Scenario4.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.cpp
00013 // Implementation of the Scenario4 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario4.xaml.h"
00018
00019 using namespace SDKSample::TextEditing;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario4::Scenario4()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void Scenario4::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040 }
00041
00042 void SDKSample::TextEditing::Scenario4::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00043 {
00044     Button^ b = safe_cast<Button^>(sender);
00045     if (b != nullptr)
00046     {
00047         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00048     }
00049 }
00050
00051 void SDKSample::TextEditing::Scenario4::Other_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00052 {
00053     Button^ b = safe_cast<Button^>(sender);
00054     if (b != nullptr)
00055     {
00056         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00057     }
00058 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/common/LayoutAwarePage.h Source File

  • Configure keys for media
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/common/suspensionmanager.h Source File

  • Programmatic file search
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/SampleOverlay.h Source File

  • DXGI offer and reclaim resources

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/S2Formatter.cpp Source File

  • XAML data binding

S2Formatter.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // S2Formatter.cpp
00010 // Implementation of the S2Formatter class
00011 //
00012
00013 #include "pch.h"
00014 #include "S2Formatter.h"
00015
00016 using namespace SDKSample::DataBinding;
00017
00018 using namespace Platform;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::Globalization::NumberFormatting;
00022
00023 S2Formatter::S2Formatter()
00024 {
00025 }
00026
00027 S2Formatter::~S2Formatter()
00028 {
00029 }
00030
00031 Object^ S2Formatter::Convert(Object^ value, TypeName targetType, Object^ parameter, String^ language)
00032 {
00033   String^ _grade = "";
00034   String^ _valueString = "";
00035   //try parsing the value to int
00036   int _value = ((Windows::Foundation::IPropertyValue^)value)->GetInt32();
00037   if (_value < 50)
00038     _grade = "F";
00039   else if (_value < 60)
00040     _grade = "D";
00041   else if (_value < 70)
00042     _grade = "C";
00043   else if (_value < 80)
00044     _grade = "B";
00045   else if (_value < 90)
00046     _grade = "A";
00047   else if (_value < 100)
00048     _grade = "A+";
00049   else if (_value == 100)
00050     _grade = "SUPER STAR!";
00051   return _grade;
00052 }
00053
00054 Object^ S2Formatter::ConvertBack(Object^ value, TypeName targetType, Object^ parameter, String^ language)
00055 {
00056   return nullptr; //doing one-way binding so this is not required.
00057 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::CalendarSample::sealed Member List

This is the complete list of members for SDKSample::CalendarSample::sealed, including all inherited members.
CalendarEnumerationAndMath() | SDKSample::CalendarSample::sealed |
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CalendarSample::sealed | [private]
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CalendarSample::sealed | [private]
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CalendarSample::sealed | [private]
DisplayCalendarData() | SDKSample::CalendarSample::sealed |
DisplayCalendarStatistics() | SDKSample::CalendarSample::sealed |
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::CalendarSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::CalendarSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::CalendarSample::sealed | [protected, virtual]
rootPage | SDKSample::CalendarSample::sealed | [private]
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/XAudio2SoundPlayer.cpp Source File

  • XAudio2 audio file playback

XAudio2SoundPlayer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "XAudio2SoundPlayer.h"
00010
00011 namespace
00012 {
00013     //
00014     // Handler for XAudio source voice callbacks to maintain playing state
00015     //
00016     class SoundCallbackHander : public IXAudio2VoiceCallback
00017     {
00018         public:
00019             SoundCallbackHander(bool* isPlayingHolder) :
00020                 m_isPlayingHolder(isPlayingHolder)
00021             {
00022             }
00023
00024             ~SoundCallbackHander()
00025             {
00026                 m_isPlayingHolder = nullptr;
00027             }
00028
00029             //
00030             // Voice callbacks from IXAudio2VoiceCallback
00031             //
00032             STDMETHOD_(void, OnVoiceProcessingPassStart) (THIS_ UINT32 bytesRequired);
00033             STDMETHOD_(void, OnVoiceProcessingPassEnd) (THIS);
00034             STDMETHOD_(void, OnStreamEnd) (THIS);
00035             STDMETHOD_(void, OnBufferStart) (THIS_ void* bufferContext);
00036             STDMETHOD_(void, OnBufferEnd) (THIS_ void* bufferContext);
00037             STDMETHOD_(void, OnLoopEnd) (THIS_ void* bufferContext);
00038             STDMETHOD_(void, OnVoiceError) (THIS_ void* bufferContext, HRESULT error);
00039
00040         private:
00041             bool* m_isPlayingHolder;
00042     };
00043
00044     //
00045     // Callback handlers, only implement the buffer events for maintaining play state
00046     //
00047     void SoundCallbackHander::OnVoiceProcessingPassStart(UINT32 /*bytesRequired*/)
00048     {
00049     }
00050     void SoundCallbackHander::OnVoiceProcessingPassEnd()
00051     {
00052     }
00053     void SoundCallbackHander::OnStreamEnd()
00054     {
00055     }
00056     void SoundCallbackHander::OnBufferStart(void* /*bufferContext*/)
00057     {
00058         *m_isPlayingHolder = true;
00059     }
00060     void SoundCallbackHander::OnBufferEnd(void* /*bufferContext*/)
00061     {
00062         *m_isPlayingHolder = false;
00063     }
00064     void SoundCallbackHander::OnLoopEnd(void* /*bufferContext*/)
00065     {
00066     }
00067     void SoundCallbackHander::OnVoiceError(void* /*bufferContext*/, HRESULT /*error*/)
00068     {
00069     }
00070 }
00071
00072 //
00073 // Per sound data required to play a sound
00074 //
00075 struct XAudio2SoundPlayer::ImplData
00076 {
00077     ImplData::ImplData(Platform::Array<byte>^ data) :
00078         sourceVoice(nullptr),
00079         playData(data),
00080         isPlaying(false),
00081         callbackHander(&isPlaying)
00082     {
00083     }
00084
00085     ~ImplData()
00086     {
00087         if (sourceVoice)
00088         {
00089             sourceVoice->DestroyVoice();
00090             sourceVoice = nullptr;
00091         }
00092     }
00093
00094     IXAudio2SourceVoice*    sourceVoice;
00095     Platform::Array<byte>^  playData;
00096     bool                    isPlaying;
00097     SoundCallbackHander     callbackHander;
00098 };
00099
00100
00101 //--------------------------------------------------------------------------------------
00102 // Name: XAudio2SoundPlayer constructor
00103 // Desc: Setup common XAudio2 objects:
00104 //          XAudio2Engine
00105 //          Mastering Voice
00106 //--------------------------------------------------------------------------------------
00107 XAudio2SoundPlayer::XAudio2SoundPlayer(uint32 sampleRate) :
00108     m_soundList()
00109 {
00110     // Create the XAudio2 Engine
00111     UINT32 flags = 0;
00112     DX::ThrowIfFailed(
00113         XAudio2Create(&m_audioEngine, flags)
00114         );
00115
00116     // Create the mastering voice
00117     DX::ThrowIfFailed(
00118         m_audioEngine->CreateMasteringVoice(
00119             &m_masteringVoice,
00120             XAUDIO2_DEFAULT_CHANNELS,
00121             sampleRate
00122             )
00123         );
00124 }
00125
00126 //--------------------------------------------------------------------------------------
00127 // Name: XAudio2SoundPlayer destructor
00128 // Desc: Stop all playing sounds, cleanup per sound data, and destroy XAudio object.
00129 //          XAudio2Engine
00130 //          Mastering Voice
00131 //--------------------------------------------------------------------------------------
00132 XAudio2SoundPlayer::~XAudio2SoundPlayer()
00133 {
00134     if (m_masteringVoice != nullptr)
00135     {
00136         m_masteringVoice->DestroyVoice();
00137         m_masteringVoice = nullptr;
00138     }
00139
00140     if (m_audioEngine != nullptr)
00141     {
00142         m_audioEngine->Release();
00143         m_audioEngine = nullptr;
00144     }
00145 }
00146
00147 //--------------------------------------------------------------------------------------
00148 // Name: XAudio2SoundPlayer::AddSound
00149 // Desc: Create data, create voice, store data
00150 //--------------------------------------------------------------------------------------
00151 size_t XAudio2SoundPlayer::AddSound(
00152     _In_ WAVEFORMATEX*  format,
00153     _In_ Platform::Array<byte>^   data
00154     )
00155 {
00156     //
00157     // Allocate the implementation data
00158     //
00159     std::shared_ptr<ImplData> implData(new ImplData(data));
00160
00161     //
00162     // Create the source voice
00163     //
00164     DX::ThrowIfFailed(
00165         m_audioEngine->CreateSourceVoice(
00166             &implData->sourceVoice,
00167             format,
00168             0,
00169             XAUDIO2_DEFAULT_FREQ_RATIO,
00170             reinterpret_cast<IXAudio2VoiceCallback*>(&implData->callbackHander),
00171             nullptr,
00172             nullptr
00173             )
00174         );
00175
00176     //
00177     // Add to the list and return its index
00178     //
00179     m_soundList.push_back(implData);
00180     return (m_soundList.size() - 1);
00181 }
00182
00183 //--------------------------------------------------------------------------------------
00184 // Name: XAudio2SoundPlayer::PlaySound
00185 // Desc: Stop if already playing, setup XAudio2 Sound buffer and play
00186 //--------------------------------------------------------------------------------------
00187 bool XAudio2SoundPlayer::PlaySound(size_t index)
00188 {
00189     //
00190     // Setup buffer
00191     //
00192     XAUDIO2_BUFFER playBuffer = { 0 };
00193     std::shared_ptr<ImplData> soundData = m_soundList[index];
00194     playBuffer.AudioBytes = soundData->playData->Length;
00195     playBuffer.pAudioData = soundData->playData->Data;
00196     playBuffer.Flags = XAUDIO2_END_OF_STREAM;
00197
00198     //
00199     // In case it is playing, stop it and flush the buffers.
00200     //
00201     HRESULT hr = soundData->sourceVoice->Stop();
00202     if (SUCCEEDED(hr))
00203     {
00204         hr = soundData->sourceVoice->FlushSourceBuffers();
00205     }
00206
00207     //
00208     // Submit the sound buffer and (re)start (ignore any 'stop' failures)
00209     //
00210     hr = soundData->sourceVoice->SubmitSourceBuffer(&playBuffer);
00211     if (SUCCEEDED(hr))
00212     {
00213         hr = soundData->sourceVoice->Start(0, XAUDIO2_COMMIT_NOW);
00214     }
00215
00216     return SUCCEEDED(hr);
00217 }
00218
00219 //--------------------------------------------------------------------------------------
00220 // Name: XAudio2SoundPlayer::StopSound
00221 // Desc: Stop if playing
00222 //--------------------------------------------------------------------------------------
00223 bool XAudio2SoundPlayer::StopSound(size_t index)
00224 {
00225     std::shared_ptr<ImplData> soundData = m_soundList[index];
00226
00227     HRESULT hr = soundData->sourceVoice->Stop();
00228     if (SUCCEEDED(hr))
00229     {
00230         hr = soundData->sourceVoice->FlushSourceBuffers();
00231     }
00232
00233     return SUCCEEDED(hr);
00234 }
00235
00236
00237 //--------------------------------------------------------------------------------------
00238 // Name: XAudio2SoundPlayer::IsSoundPlaying
00239 // Desc: Returns the playing state of the sound at sent index
00240 //--------------------------------------------------------------------------------------
00241 bool XAudio2SoundPlayer::IsSoundPlaying(size_t index) const
00242 {
00243     return m_soundList[index]->isPlaying;
00244 }
00245
00246 //--------------------------------------------------------------------------------------
00247 // Name: XAudio2SoundPlayer::GetSoundCount
00248 // Desc: Returns the number of sounds in the sound list
00249 //--------------------------------------------------------------------------------------
00250 size_t XAudio2SoundPlayer::GetSoundCount() const
00251 {
00252     return m_soundList.size();
00253 }
00254
00255 //--------------------------------------------------------------------------------------
00256 // Name: XAudio2SoundPlayer::Suspend
00257 // Desc: Stops the XAudio2 Engine
00258 //--------------------------------------------------------------------------------------
00259 void XAudio2SoundPlayer::Suspend()
00260 {
00261     m_audioEngine->StopEngine();
00262 }
00263
00264 //--------------------------------------------------------------------------------------
00265 // Name: XAudio2SoundPlayer::Resume
00266 // Desc: Start the XAudio2 engine
00267 //--------------------------------------------------------------------------------------
00268 void XAudio2SoundPlayer::Resume()
00269 {
00270     DX::ThrowIfFailed(
00271         m_audioEngine->StartEngine()
00272         );
00273 }
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/pch.h Source File

  • HomeGroup app

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AsteroidData Member List

This is the complete list of members for AsteroidData, including all inherited members.
pos | AsteroidData
rot | AsteroidData
rotVel | AsteroidData
scale | AsteroidData
vel | AsteroidData
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Shape Member List

This is the complete list of members for Shape, including all inherited members.
EnsureVisible() | Shape | [private]
GetPolygon() | Shape |
InitializeObject(_In_reads_(numPoints) Windows::Foundation::Point const *points, _In_ int numPoints, _In_ D2D1::ColorF color) | Shape |
InRegion(Windows::Foundation::Point pt) | Shape |
m_color | Shape | [private]
m_height | Shape | [private]
m_pathGeometry | Shape | [private]
m_polygonAbsolute | Shape | [private]
m_polygonRelative | Shape | [private]
m_ptPointerPosition | Shape | [private]
m_scale | Shape | [private]
m_topLeftX | Shape | [private]
m_topLeftY | Shape | [private]
m_width | Shape | [private]
OnPointerEvent(_In_ Windows::Foundation::Point pt, bool shouldMove) | Shape |
Paint(_In_ ID2D1DeviceContext *d2dDeviceContext) | Shape |
ResetState(_In_ float startX, _In_ float startY, _In_ float width, _In_ float height, _In_ float scale) | Shape |
Shape() | Shape |
Translate(_In_ float fdx, _In_ float fdy) | Shape | [private]
UnscaledToClient(_In_ Windows::Foundation::Point ptUnscaled, _Inout_ Windows::Foundation::Point *pptClient) | Shape | [private]
UnscaledToClient(_In_ Windows::Foundation::Rect rcUnscaled, _Inout_ Windows::Foundation::Rect *prcClient) | Shape | [private]
UnscaledToClient(_In_ Windows::Foundation::Point ptUnscaled) | Shape | [private]
UnscaledToClient(_In_ Windows::Foundation::Rect rcUnscaled) | Shape | [private]
~Shape() | Shape |
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/OutlineRenderer.h Source File

  • DirectX postcard app

OutlineRenderer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011
00012 class OutlineRenderer : public IDWriteTextRenderer
00013 {
00014 public:
00015     static void CreateOutlineRenderer(
00016         _In_ ID2D1Factory* pFactory,
00017         _Outptr_ OutlineRenderer** ppOutlineRenderer
00018         );
00019
00020     STDMETHOD(DrawGlyphRun)(
00021         void* /*clientDrawingContext*/,
00022         FLOAT baselineOriginX,
00023         FLOAT baselineOriginY,
00024         DWRITE_MEASURING_MODE /*measuringMode*/,
00025         DWRITE_GLYPH_RUN const* glyphRun,
00026         DWRITE_GLYPH_RUN_DESCRIPTION const* /*glyphRunDescription*/,
00027         IUnknown* /*clientDrawingEffect*/
00028         );
00029
00030     STDMETHOD(DrawUnderline)(
00031         void* /*clientDrawingContext*/,
00032         FLOAT /*baselineOriginX*/,
00033         FLOAT /*baselineOriginY*/,
00034         DWRITE_UNDERLINE const* /*underline*/,
00035         IUnknown* /*clientDrawingEffect*/
00036         );
00037
00038     STDMETHOD(DrawStrikethrough)(
00039         void* /*clientDrawingContext*/,
00040         FLOAT /*baselineOriginX*/,
00041         FLOAT /*baselineOriginY*/,
00042         DWRITE_STRIKETHROUGH const* /*strikethrough*/,
00043         IUnknown* /*clientDrawingEffect*/
00044         );
00045
00046     STDMETHOD(DrawInlineObject)(
00047         void* /*clientDrawingContext*/,
00048         FLOAT /*originX*/,
00049         FLOAT /*originY*/,
00050         IDWriteInlineObject* /*inlineObject*/,
00051         BOOL /*isSideways*/,
00052         BOOL /*isRightToLeft*/,
00053         IUnknown* /*clientDrawingEffect*/
00054         );
00055
00056     STDMETHOD(IsPixelSnappingDisabled)(
00057         void* /*clientDrawingContext*/,
00058         BOOL* isDisabled
00059         );
00060
00061     STDMETHOD(GetCurrentTransform)(
00062         void* /*clientDrawingContext*/,
00063         DWRITE_MATRIX* transform
00064         );
00065
00066     STDMETHOD(GetPixelsPerDip)(
00067         void* /*clientDrawingContext*/,
00068         FLOAT* pixelsPerDip
00069         );
00070
00071     // IUknown methods.
00072     STDMETHOD(QueryInterface)(REFIID riid, _Outptr_ void** object) override;
00073     STDMETHOD_(ULONG, AddRef)() override;
00074     STDMETHOD_(ULONG, Release)() override;
00075
00076     void GetGeometry(ID2D1Geometry** ppGeometry);
00077
00078 private:
00079     // Private constructor used by CreateOutlineRenderer method.
00080     OutlineRenderer(_In_ ID2D1Factory* pFactory);
00081
00082     void AddGeometry(ID2D1Geometry* pGeometry);
00083
00084     Microsoft::WRL::ComPtr<ID2D1Factory> m_pFactory;
00085     Microsoft::WRL::ComPtr<ID2D1Geometry> m_pGeometry;
00086
00087     ULONG m_ref;    // Reference count for AddRef and Release.
00088 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_PickFile.xaml.cpp Source File

  • File picker contracts

MainPage_PickFile.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage_PickFile.xaml.cpp
00013 // Implementation of the MainPage_PickFile class
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "MainPage_PickFile.xaml.h"
00019
00020 using namespace SDKSample::FilePickerContracts;
00021
00022 using namespace concurrency;
00023 using namespace Platform;
00024 using namespace Windows::Foundation::Collections;
00025 using namespace Windows::Storage;
00026 using namespace Windows::Storage::Pickers;
00027 using namespace Windows::UI::Xaml;
00028 using namespace Windows::UI::Xaml::Controls;
00029 using namespace Windows::UI::Xaml::Navigation;
00030
00031 MainPage_PickFile::MainPage_PickFile()
00032 {
00033     InitializeComponent();
00034     PickFileButton->Click += ref new RoutedEventHandler(this, &MainPage_PickFile::PickFileButton_Click);
00035 }
00036
00037 void MainPage_PickFile::PickFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00038 {
00039     MainPage^ page = MainPage::Current;
00040
00041     page->ResetScenarioOutput(OutputTextBlock);
00042     if (page->EnsureUnsnapped())
00043     {
00044         // Set up and launch the Open Picker
00045         auto fileOpenPicker = ref new FileOpenPicker();
00046         fileOpenPicker->ViewMode = PickerViewMode::Thumbnail;
00047         fileOpenPicker->FileTypeFilter->Append(".png");
00048
00049         create_task(fileOpenPicker->PickMultipleFilesAsync()).then([this](IVectorView<StorageFile^>^ files)
00050         {
00051             String^ fileNames = "";
00052             std::for_each(begin(files), end(files), [this, &fileNames](StorageFile^ file)
00053             {
00054                 // At this point, the app can begin reading from the provided file
00055                 fileNames += file->Name + "\n";
00056             });
00057
00058             OutputTextBlock->Text = fileNames->ToString();
00059         });
00060     }
00061 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/AsyncCB.h Source File

  • Media extensions
  • MediaExtensions
  • Common

AsyncCB.h

Go to the documentation of this file.
00001 #pragma once
00002
00003 //////////////////////////////////////////////////////////////////////////
00004 //  AsyncCallback [template]
00005 //
00006 //  Description:
00007 //  Helper class that routes IMFAsyncCallback::Invoke calls to a class
00008 //  method on the parent class.
00009 //
00010 //  Usage:
00011 //  Add this class as a member variable. In the parent class constructor,
00012 //  initialize the AsyncCallback class like this:
00013 //    m_cb(this, &CYourClass::OnInvoke)
00014 //  where
00015 //      m_cb       = AsyncCallback object
00016 //      CYourClass = parent class
00017 //      OnInvoke   = Method in the parent class to receive Invoke calls.
00018 //
00019 //  The parent's OnInvoke method (you can name it anything you like) must
00020 //  have a signature that matches the InvokeFn typedef below.
00021 //////////////////////////////////////////////////////////////////////////
00022
00023 // T: Type of the parent object
00024 template<class T>
00025 class AsyncCallback : public IMFAsyncCallback
00026 {
00027 public:
00028     typedef HRESULT (T::*InvokeFn)(IMFAsyncResult *pAsyncResult);
00029
00030     AsyncCallback(T *pParent, InvokeFn fn) : m_pParent(pParent), m_pInvokeFn(fn)
00031     {
00032     }
00033
00034     // IUnknown
00035     STDMETHODIMP_(ULONG) AddRef() {
00036         // Delegate to parent class.
00037         return m_pParent->AddRef();
00038     }
00039     STDMETHODIMP_(ULONG) Release() {
00040         // Delegate to parent class.
00041         return m_pParent->Release();
00042     }
00043     STDMETHODIMP QueryInterface(REFIID iid, void** ppv)
00044     {
00045         if (!ppv)
00046         {
00047             return E_POINTER;
00048         }
00049         if (iid == __uuidof(IUnknown))
00050         {
00051             *ppv = static_cast<IUnknown*>(static_cast<IMFAsyncCallback*>(this));
00052         }
00053         else if (iid == __uuidof(IMFAsyncCallback))
00054         {
00055             *ppv = static_cast<IMFAsyncCallback*>(this);
00056         }
00057         else
00058         {
00059             *ppv = NULL;
00060             return E_NOINTERFACE;
00061         }
00062         AddRef();
00063         return S_OK;
00064     }
00065
00066
00067     // IMFAsyncCallback methods
00068     STDMETHODIMP GetParameters(DWORD*, DWORD*)
00069     {
00070         // Implementation of this method is optional.
00071         return E_NOTIMPL;
00072     }
00073
00074     STDMETHODIMP Invoke(IMFAsyncResult* pAsyncResult)
00075     {
00076         return (m_pParent->*m_pInvokeFn)(pAsyncResult);
00077     }
00078
00079     T *m_pParent;
00080     InvokeFn m_pInvokeFn;
00081 };
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/MPEG1Src.h Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source

MPEG1Src.h

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // MPEG1Source.h
00004 // Implements the MPEG-1 media source object.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015
00016 #pragma once
00017
00018 #include <new.h>
00019 #include <windows.h>
00020 #include <assert.h>
00021 #include <wrl\implements.h>
00022
00023 #ifndef _ASSERTE
00024 #define _ASSERTE assert
00025 #endif
00026
00027 #include <windows.media.h>
00028
00029 #include <mftransform.h>
00030
00031 #include <mfapi.h>
00032 #include <mfobjects.h>
00033 #include <mfidl.h>
00034 #include <mferror.h>
00035
00036 //#include <amvideo.h>    // VIDEOINFOHEADER definition
00037 //#include <dvdmedia.h>   // VIDEOINFOHEADER2
00038 //#include <mmreg.h>      // MPEG1WAVEFORMAT
00039
00040 // Common sample files.
00041 #include "linklist.h"
00042
00043 #include "asynccb.h"
00044 #include "OpQueue.h"
00045
00046
00047 template <class T> void SafeRelease(T **ppT)
00048 {
00049     if (*ppT)
00050     {
00051         (*ppT)->Release();
00052         *ppT = NULL;
00053     }
00054 }
00055
00056 void DllAddRef();
00057 void DllRelease();
00058
00059
00060 // Forward declares
00061 class CMPEG1ByteStreamHandler;
00062 class CMPEG1Source;
00063 class CMPEG1Stream;
00064 class SourceOp;
00065
00066 typedef ComPtrList<IMFSample>       SampleList;
00067 typedef ComPtrList<IUnknown, true>  TokenList;    // List of tokens for IMFMediaStream::RequestSample
00068
00069 enum SourceState
00070 {
00071     STATE_INVALID,      // Initial state. Have not started opening the stream.
00072     STATE_OPENING,      // BeginOpen is in progress.
00073     STATE_STOPPED,
00074     STATE_PAUSED,
00075     STATE_STARTED,
00076     STATE_SHUTDOWN
00077 };
00078
00079 #include "Parse.h"          // MPEG-1 parser
00080 #include "MPEG1Stream.h"    // MPEG-1 stream
00081
00082
00083
00084 const UINT32 MAX_STREAMS = 32;
00085
00086 class StreamList
00087 {
00088     CMPEG1Stream*   m_streams[MAX_STREAMS];
00089     BYTE            m_id[MAX_STREAMS];
00090     UINT32          m_count;
00091
00092 public:
00093     StreamList() : m_count(0)
00094     {
00095         ZeroMemory(m_streams, sizeof(m_streams));
00096     }
00097     ~StreamList()
00098     {
00099         Clear();
00100     }
00101
00102     UINT32 GetCount() const { return m_count; }
00103
00104     void Clear()
00105     {
00106         for (UINT32 i = 0; i < MAX_STREAMS; i++)
00107         {
00108             SafeRelease(&m_streams[i]);
00109         }
00110         m_count = 0;
00111     }
00112
00113     HRESULT AddStream(BYTE id, CMPEG1Stream *pStream)
00114     {
00115         if (GetCount() >= MAX_STREAMS)
00116         {
00117             return E_FAIL;
00118         }
00119
00120         m_streams[m_count] = pStream;
00121         pStream->AddRef();
00122
00123         m_id[m_count] = id;
00124
00125         m_count++;
00126
00127         return S_OK;
00128     }
00129
00130     CMPEG1Stream* Find(BYTE id)
00131     {
00132
00133         // This method can return NULL if the source did not create a
00134         // stream for this ID. In particular, this can happen if:
00135         //
00136         // 1) The stream type is not supported. See IsStreamTypeSupported().
00137         // 2) The source is still opening.
00138         //
00139         // Note: This method does not AddRef the stream object. The source
00140         // uses this method to access the streams. If the source hands out
00141         // a stream pointer (e.g. in the MENewStream event), the source
00142         // must AddRef the stream object.
00143
00144         CMPEG1Stream* pStream = NULL;
00145         for (UINT32 i = 0; i < m_count; i++)
00146         {
00147             if (m_id[i] == id)
00148             {
00149                 pStream = m_streams[i];
00150                 break;
00151             }
00152         }
00153         return pStream;
00154     }
00155
00156     // Accessor.
00157     CMPEG1Stream* operator[](DWORD index)
00158     {
00159         assert(index < m_count);
00160         return m_streams[index];
00161     }
00162
00163     // Const accessor.
00164     CMPEG1Stream* const operator[](DWORD index) const
00165     {
00166         assert(index < m_count);
00167         return m_streams[index];
00168     }
00169 };
00170
00171
00172 // Constants
00173
00174 const DWORD INITIAL_BUFFER_SIZE = 4 * 1024; // Initial size of the read buffer. (The buffer expands dynamically.)
00175 const DWORD READ_SIZE = 4 * 1024;           // Size of each read request.
00176 const DWORD SAMPLE_QUEUE = 2;               // How many samples does each stream try to hold in its queue?
00177
00178 // Represents a request for an asynchronous operation.
00179
00180 class SourceOp : public IUnknown
00181 {
00182 public:
00183
00184     enum Operation
00185     {
00186         OP_START,
00187         OP_PAUSE,
00188         OP_STOP,
00189         OP_SETRATE,
00190         OP_REQUEST_DATA,
00191         OP_END_OF_STREAM
00192     };
00193
00194     static HRESULT CreateOp(Operation op, SourceOp **ppOp);
00195     static HRESULT CreateStartOp(IMFPresentationDescriptor *pPD, SourceOp **ppOp);
00196     static HRESULT CreateSetRateOp(BOOL fThin, float flRate, SourceOp **ppOp);
00197
00198     // IUnknown
00199     STDMETHODIMP QueryInterface(REFIID iid, void** ppv);
00200     STDMETHODIMP_(ULONG) AddRef();
00201     STDMETHODIMP_(ULONG) Release();
00202
00203     SourceOp(Operation op);
00204     virtual ~SourceOp();
00205
00206     HRESULT SetData(const PROPVARIANT& var);
00207
00208     Operation Op() const { return m_op; }
00209     const PROPVARIANT& Data() { return m_data;}
00210
00211 protected:
00212     long        m_cRef;     // Reference count.
00213     Operation   m_op;
00214     PROPVARIANT m_data;     // Data for the operation.
00215 };
00216
00217 class StartOp : public SourceOp
00218 {
00219 public:
00220     StartOp(IMFPresentationDescriptor *pPD);
00221     ~StartOp();
00222
00223     HRESULT GetPresentationDescriptor(IMFPresentationDescriptor **ppPD);
00224
00225 protected:
00226     IMFPresentationDescriptor   *m_pPD; // Presentation descriptor for Start operations.
00227
00228 };
00229
00230 class SetRateOp : public SourceOp
00231 {
00232 public:
00233     SetRateOp(BOOL fThin, float flRate);
00234     ~SetRateOp();
00235
00236     BOOL IsThin() const {return m_fThin;}
00237     float GetRate() const {return m_flRate;}
00238
00239 private:
00240     BOOL m_fThin;
00241     float m_flRate;
00242 };
00243
00244 // CMPEG1Source: The media source object.
00245 class CMPEG1Source :
00246     public OpQueue<CMPEG1Source, SourceOp>,
00247     public IMFMediaSource,
00248   public IMFGetService,
00249     public IMFRateControl
00250 {
00251 public:
00252     static HRESULT CreateInstance(CMPEG1Source **ppSource);
00253
00254     // IUnknown
00255     STDMETHODIMP QueryInterface(REFIID iid, void** ppv);
00256     STDMETHODIMP_(ULONG) AddRef();
00257     STDMETHODIMP_(ULONG) Release();
00258
00259     // IMFMediaEventGenerator
00260     STDMETHODIMP BeginGetEvent(IMFAsyncCallback* pCallback,IUnknown* punkState);
00261     STDMETHODIMP EndGetEvent(IMFAsyncResult* pResult, IMFMediaEvent** ppEvent);
00262     STDMETHODIMP GetEvent(DWORD dwFlags, IMFMediaEvent** ppEvent);
00263     STDMETHODIMP QueueEvent(MediaEventType met, REFGUID guidExtendedType, HRESULT hrStatus, const PROPVARIANT* pvValue);
00264
00265     // IMFMediaSource
00266     STDMETHODIMP CreatePresentationDescriptor(IMFPresentationDescriptor** ppPresentationDescriptor);
00267     STDMETHODIMP GetCharacteristics(DWORD* pdwCharacteristics);
00268     STDMETHODIMP Pause();
00269     STDMETHODIMP Shutdown();
00270     STDMETHODIMP Start(
00271         IMFPresentationDescriptor* pPresentationDescriptor,
00272         const GUID* pguidTimeFormat,
00273         const PROPVARIANT* pvarStartPosition
00274     );
00275     STDMETHODIMP Stop();
00276
00277   // IMFGetService
00278     IFACEMETHOD (GetService) ( _In_ REFGUID guidService, _In_ REFIID riid, _Out_opt_ LPVOID *ppvObject);
00279
00280     // IMFRateControl
00281     IFACEMETHOD (SetRate) (BOOL fThin, float flRate);
00282     IFACEMETHOD (GetRate) (_Inout_opt_ BOOL *pfThin, _Inout_opt_ float *pflRate);
00283
00284     // Called by the byte stream handler.
00285     HRESULT BeginOpen(IMFByteStream *pStream, IMFAsyncCallback *pCB, IUnknown *pUnkState);
00286     HRESULT EndOpen(IMFAsyncResult *pResult);
00287
00288     // Queues an asynchronous operation, specify by op-type.
00289     // (This method is public because the streams call it.)
00290     HRESULT QueueAsyncOperation(SourceOp::Operation OpType);
00291
00292     // Lock/Unlock:
00293     // Holds and releases the source's critical section. Called by the streams.
00294   _Acquires_lock_(m_critSec)
00295     void    Lock() { EnterCriticalSection(&m_critSec); }
00296
00297   _Releases_lock_(m_critSec)
00298   void    Unlock() { LeaveCriticalSection(&m_critSec); }
00299
00300     // Callbacks
00301     HRESULT OnByteStreamRead(IMFAsyncResult *pResult);  // Async callback for RequestData
00302
00303 private:
00304
00305     CMPEG1Source(HRESULT& hr);
00306     ~CMPEG1Source();
00307
00308     // CheckShutdown: Returns MF_E_SHUTDOWN if the source was shut down.
00309     HRESULT CheckShutdown() const
00310     {
00311         return ( m_state == STATE_SHUTDOWN ? MF_E_SHUTDOWN : S_OK );
00312     }
00313
00314     HRESULT     CompleteOpen(HRESULT hrStatus);
00315
00316     HRESULT     IsInitialized() const;
00317     BOOL        IsStreamTypeSupported(StreamType type) const;
00318     BOOL        IsStreamActive(const MPEG1PacketHeader& packetHdr);
00319     BOOL        StreamsNeedData() const;
00320
00321     HRESULT     DoStart(StartOp *pOp);
00322     HRESULT     DoStop(SourceOp *pOp);
00323     HRESULT     DoPause(SourceOp *pOp);
00324     HRESULT     DoSetRate(SourceOp *pOp);
00325     HRESULT     OnStreamRequestSample(SourceOp *pOp);
00326     HRESULT     OnEndOfStream(SourceOp *pOp);
00327
00328     HRESULT     InitPresentationDescriptor();
00329     HRESULT     SelectStreams(IMFPresentationDescriptor *pPD, const PROPVARIANT varStart);
00330
00331     HRESULT     RequestData(DWORD cbRequest);
00332     HRESULT     ParseData();
00333     HRESULT     ReadPayload(DWORD *pcbAte, DWORD *pcbNextRequest);
00334     HRESULT     DeliverPayload();
00335     HRESULT     EndOfMPEGStream();
00336
00337     HRESULT     CreateStream(const MPEG1PacketHeader& packetHdr);
00338
00339     HRESULT     ValidatePresentationDescriptor(IMFPresentationDescriptor *pPD);
00340
00341     // Handler for async errors.
00342     void        StreamingError(HRESULT hr);
00343
00344     HRESULT     BeginAsyncOp(SourceOp *pOp);
00345     HRESULT     CompleteAsyncOp(SourceOp *pOp);
00346     HRESULT     DispatchOperation(SourceOp *pOp);
00347     HRESULT     ValidateOperation(SourceOp *pOp);
00348
00349     BOOL        IsRateSupported(float flRate, float *pflAdjustedRate);
00350
00351 private:
00352     long                        m_cRef;                     // reference count
00353
00354     CRITICAL_SECTION            m_critSec;                  // critical section for thread safety
00355     SourceState                 m_state;                    // Current state (running, stopped, paused)
00356
00357     Buffer                      m_ReadBuffer;
00358     Parser                      *m_pParser;
00359
00360     IMFMediaEventQueue          *m_pEventQueue;             // Event generator helper
00361     IMFPresentationDescriptor   *m_pPresentationDescriptor; // Presentation descriptor.
00362     IMFAsyncResult              *m_pBeginOpenResult;        // Result object for async BeginOpen operation.
00363     IMFByteStream               *m_pByteStream;
00364
00365     MPEG1SystemHeader           *m_pHeader;                 // Release with CoTaskMemFree
00366
00367     StreamList                  m_streams;                  // Array of streams.
00368
00369     DWORD                       m_cPendingEOS;              // Pending EOS notifications.
00370     ULONG                       m_cRestartCounter;          // Counter for sample requests.
00371
00372     SourceOp                    *m_pCurrentOp;
00373     SourceOp                    *m_pSampleRequest;
00374
00375     // Async callback helper.
00376     AsyncCallback<CMPEG1Source>  m_OnByteStreamRead;
00377
00378     float                       m_flRate;
00379 };
00380
00381
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/MainPage.xaml.cpp Source File

  • Bluetooth call control

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/MainPage.xaml.h Source File

  • Print

MainPage.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.h
00010 // Declaration of the MainPage.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "MainPage.g.h"
00017
00018 using namespace Windows::UI::Xaml;
00019 using namespace Windows::UI::Xaml::Controls;
00020 using namespace Windows::Graphics::Display;
00021 using namespace Windows::UI::ViewManagement;
00022 using namespace Windows::UI::Xaml::Navigation;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::System;
00025 using namespace Platform;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 namespace PrintSample
00029 {
00030     public enum class NotifyType
00031     {
00032         StatusMessage,
00033         ErrorMessage
00034     };
00035
00036     [Windows::Foundation::Metadata::WebHostHidden]
00037     public ref class MainPage sealed
00038     {
00039     public:
00040         MainPage();
00041
00042         property Windows::UI::Xaml::Controls::Frame^ ScenariosFrame
00043         {
00044             Windows::UI::Xaml::Controls::Frame^ get() { return _scenariosFrame; }
00045         }
00046         property Windows::UI::Xaml::Controls::Frame^ InputFrame
00047         {
00048             Windows::UI::Xaml::Controls::Frame^ get() { return _inputFrame; }
00049         }
00050         property Windows::UI::Xaml::Controls::Frame^ OutputFrame
00051         {
00052             Windows::UI::Xaml::Controls::Frame^ get() { return _outputFrame; }
00053         }
00054
00055         event Windows::Foundation::EventHandler<Platform::Object^>^ InputFrameLoaded;
00056         event Windows::Foundation::EventHandler<Platform::Object^>^ OutputFrameLoaded;
00057
00058         void NotifyUser(String^ strMessage, NotifyType type);
00059         void DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^ frame);
00060         String^ ConvertViewState(ApplicationViewState state);
00061         String^ ConvertResolution(ResolutionScale scale);
00062
00063     private:
00064         ~MainPage();
00065         Windows::UI::Xaml::Controls::Frame^ _scenariosFrame;
00066         Windows::UI::Xaml::Controls::Frame^ _inputFrame;
00067         Windows::UI::Xaml::Controls::Frame^ _outputFrame;
00068         void Footer_Click(Object^ sender, RoutedEventArgs^ e);
00069         Windows::Foundation::EventRegistrationToken _displayHandlerToken;
00070         Windows::Foundation::EventRegistrationToken _sizeChangedHandlerToken;
00071         Windows::Foundation::EventRegistrationToken _pageLoadedHandlerToken;
00072         Windows::Foundation::EventRegistrationToken _logicalDpiChangedToken;
00073         Windows::Foundation::EventRegistrationToken _inputFrameLoadedToken;
00074         Windows::Foundation::EventRegistrationToken _outputFrameLoadedToken;
00075         void Page_SizeChanged(Windows::UI::Core::CoreWindow^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ args);
00076         void DisplayProperties_LogicalDpiChanged(Object^ sender);
00077         void Page_Loaded(Object^ sender, RoutedEventArgs^ e);
00078         void CheckResolutionAndViewState();
00079         void SetFeatureName(Platform::String^ strFeature);
00080         void inputFrameNavigated(Object^ sender, NavigationEventArgs^ e);
00081         void outputFrameNavigated(Object^ sender, NavigationEventArgs^ e);
00082     };
00083 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/InlineImage.cpp Source File

  • DirectWrite inline object

InlineImage.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DWriteInlineObject.h"
00010
00011 InlineImage::InlineImage(
00012     Microsoft::WRL::ComPtr<ID2D1DeviceContext> deviceContext,
00013     Microsoft::WRL::ComPtr<IWICImagingFactory> IWICFactory,
00014     PCWSTR uri
00015     ) :
00016     refCount(0)
00017 {
00018     // Save the render target for later.
00019     this->deviceContext = deviceContext;
00020
00021     // Load the bitmap from a file.
00022     LoadBitmapFromFile(
00023         deviceContext,
00024         IWICFactory,
00025         uri,
00026         &bitmap
00027         );
00028 }
00029
00030 HRESULT STDMETHODCALLTYPE InlineImage::Draw(
00031     _In_opt_ void* clientDrawingContext,
00032     IDWriteTextRenderer* renderer,
00033     FLOAT originX,
00034     FLOAT originY,
00035     BOOL isSideways,
00036     BOOL isRightToLeft,
00037     IUnknown* clientDrawingEffect
00038     )
00039 {
00040     float height    = rect.bottom - rect.top;
00041     float width     = rect.right  - rect.left;
00042     D2D1_RECT_F destRect  = {originX, originY, originX + width, originY + height};
00043
00044     deviceContext.Get()->DrawBitmap(bitmap.Get(), destRect);
00045
00046     return S_OK;
00047 }
00048
00049 HRESULT STDMETHODCALLTYPE InlineImage::GetMetrics(
00050     _Out_ DWRITE_INLINE_OBJECT_METRICS* metrics
00051     )
00052 {
00053     DWRITE_INLINE_OBJECT_METRICS inlineMetrics = {};
00054     inlineMetrics.width     = rect.right  - rect.left;
00055     inlineMetrics.height    = rect.bottom - rect.top;
00056     inlineMetrics.baseline  = baseline;
00057     *metrics = inlineMetrics;
00058     return S_OK;
00059 }
00060
00061 HRESULT STDMETHODCALLTYPE InlineImage::GetOverhangMetrics(
00062     _Out_ DWRITE_OVERHANG_METRICS* overhangs
00063     )
00064 {
00065     overhangs->left      = 0;
00066     overhangs->top       = 0;
00067     overhangs->right     = 0;
00068     overhangs->bottom    = 0;
00069     return S_OK;
00070 }
00071
00072 HRESULT STDMETHODCALLTYPE InlineImage::GetBreakConditions(
00073     _Out_ DWRITE_BREAK_CONDITION* breakConditionBefore,
00074     _Out_ DWRITE_BREAK_CONDITION* breakConditionAfter
00075     )
00076 {
00077     *breakConditionBefore = DWRITE_BREAK_CONDITION_NEUTRAL;
00078     *breakConditionAfter  = DWRITE_BREAK_CONDITION_NEUTRAL;
00079     return S_OK;
00080 }
00081
00082 ////  InlineImage::LoadBitmapFromFile
00083 ////
00084 ////  Loads a bitmap from a file
00085
00086 HRESULT InlineImage::LoadBitmapFromFile(
00087     Microsoft::WRL::ComPtr<ID2D1DeviceContext> deviceContext,
00088     Microsoft::WRL::ComPtr<IWICImagingFactory> IWICFactory,
00089     PCWSTR uri,
00090     _Outptr_ ID2D1Bitmap **ppBitmap
00091     )
00092 {
00093     HRESULT hr = S_OK;
00094
00095     Microsoft::WRL::ComPtr<IWICBitmapDecoder> decoder;
00096     Microsoft::WRL::ComPtr<IWICBitmapFrameDecode> source;
00097     Microsoft::WRL::ComPtr<IWICFormatConverter> converter;
00098
00099     hr = IWICFactory->CreateDecoderFromFilename(
00100         uri, nullptr, GENERIC_READ, WICDecodeMetadataCacheOnLoad, &decoder
00101         );
00102
00103     // Create the initial frame.
00104     if (SUCCEEDED(hr))
00105     {
00106         hr = decoder->GetFrame(0, &source);
00107     }
00108
00109     // Store the image size for later use.
00110     UINT imageWidth = 0, imageHeight = 0;
00111
00112     source->GetSize(&imageWidth, &imageHeight);
00113
00114     rect.left      = 0;
00115     rect.top       = 0;
00116     rect.right     = static_cast<FLOAT>(imageWidth);
00117     rect.bottom    = static_cast<FLOAT>(imageHeight);
00118
00119     baseline       = static_cast<FLOAT>(imageHeight);
00120
00121     // Convert the image format to 32bppPBGRA -- which Direct2D expects.
00122     if (SUCCEEDED(hr))
00123     {
00124         hr = IWICFactory->CreateFormatConverter(&converter);
00125     }
00126
00127     if (SUCCEEDED(hr))
00128     {
00129         hr = converter->Initialize(
00130             source.Get(),
00131             GUID_WICPixelFormat32bppPBGRA,
00132             WICBitmapDitherTypeNone,
00133             nullptr,
00134             0.f,
00135             WICBitmapPaletteTypeMedianCut
00136             );
00137     }
00138
00139     // Create a Direct2D bitmap from the WIC bitmap.
00140     if (SUCCEEDED(hr))
00141     {
00142         hr = deviceContext.Get()->CreateBitmapFromWicBitmap(
00143             converter.Get(),
00144             nullptr,
00145             ppBitmap
00146             );
00147     }
00148
00149     return hr;
00150 }
00151
00152 //// InlineImage::QueryInterface
00153 ////
00154 //// Query interface implementation
00155
00156 STDMETHODIMP InlineImage::QueryInterface(
00157     IID const& riid,
00158     void** ppvObject
00159     )
00160 {
00161     if (__uuidof(IDWriteInlineObject) == riid)
00162     {
00163         *ppvObject = dynamic_cast<IDWriteInlineObject*>(this);
00164     }
00165     else if (__uuidof(IUnknown) == riid)
00166     {
00167         *ppvObject = dynamic_cast<IUnknown*>(this);
00168     }
00169     else
00170     {
00171         *ppvObject = nullptr;
00172         return E_FAIL;
00173     }
00174
00175     return S_OK;
00176 }
00177
00178 ////  InlineImage::AddRef
00179 ////
00180 ////  Increments the ref count
00181
00182 STDMETHODIMP_(unsigned long) InlineImage::AddRef()
00183 {
00184     return InterlockedIncrement(&refCount);
00185 }
00186
00187 ////  InlineImage::Release
00188 ////
00189 ////  Decrements the ref count and deletes the instance if the ref
00190 ////  count becomes 0
00191
00192 STDMETHODIMP_(unsigned long) InlineImage::Release()
00193 {
00194     unsigned long newCount = InterlockedDecrement(&refCount);
00195
00196     if (newCount == 0)
00197     {
00198         delete this;
00199         return 0;
00200     }
00201
00202     return newCount;
00203 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/pch.h Source File

  • Background task
  • BackgroundTask

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/pch.h Source File

  • Configure keys for media

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > Member List

This is the complete list of members for SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V >, including all inherited members.
_dictionary | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [private]
Add(K key, V value) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Add(KeyValuePair< K, V > item) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Add(K key, V value) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Add(KeyValuePair< K, V > item) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Clear() | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Clear() | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Contains(KeyValuePair< K, V > item) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Contains(KeyValuePair< K, V > item) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
ContainsKey(K key) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
ContainsKey(K key) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
CopyTo(KeyValuePair< K, V >[] array, int arrayIndex) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
CopyTo(KeyValuePair< K, V >[] array, int arrayIndex) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Count | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > |
GetEnumerator() | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
GetEnumerator() | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline, private]
GetEnumerator() | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
GetEnumerator() | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline, private]
InvokeMapChanged(CollectionChange change, K key) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline, private]
InvokeMapChanged(CollectionChange change, K key) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline, private]
IsReadOnly | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > |
Keys | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > |
MapChanged | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > |
Remove(K key) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Remove(KeyValuePair< K, V > item) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Remove(K key) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Remove(KeyValuePair< K, V > item) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
this | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > |
TryGetValue(K key, out V value) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
TryGetValue(K key, out V value) | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > | [inline]
Values | SDKTemplate::Common::LayoutAwarePage::ObservableDictionary< K, V > |
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/App.xaml.cpp Source File

  • Scaling according to DPI

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/App.xaml.h Source File

  • Print

App.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.h
00010 // Declaration of the App.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "App.g.h"
00017
00018 namespace PrintSample
00019 {
00020   ref class App sealed
00021   {
00022   public:
00023     App() ;
00024
00025     virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00026     virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00027   private:
00028     ~App() ;
00029   };
00030 }
00031
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Simple3DGame.cpp Source File

  • XAML DirectX 3D shooting game

Simple3DGame.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "GameRenderer.h"
00010
00011 #include "DirectXSample.h"
00012 #include "Level1.h"
00013 #include "Level2.h"
00014 #include "Level3.h"
00015 #include "Level4.h"
00016 #include "Level5.h"
00017 #include "Level6.h"
00018 #include "Animate.h"
00019 #include "Sphere.h"
00020 #include "Cylinder.h"
00021 #include "Face.h"
00022 #include "MediaReader.h"
00023
00024 using namespace concurrency;
00025 using namespace DirectX;
00026 using namespace Microsoft::WRL;
00027 using namespace Windows::ApplicationModel::Store;
00028 using namespace Windows::Storage;
00029 using namespace Windows::UI::Core;
00030
00031 //----------------------------------------------------------------------
00032
00033 Simple3DGame::Simple3DGame():
00034     m_ammoCount(0),
00035     m_ammoNext(0),
00036     m_gameActive(false),
00037     m_levelActive(false),
00038     m_totalHits(0),
00039     m_totalShots(0),
00040     m_levelBonusTime(0.0),
00041     m_levelTimeRemaining(0.0),
00042     m_levelCount(0),
00043     m_currentLevel(0),
00044     m_activeBackground(0)
00045 {
00046     m_topScore.totalHits = 0;
00047     m_topScore.totalShots = 0;
00048     m_topScore.levelCompleted = 0;
00049 }
00050
00051 //----------------------------------------------------------------------
00052
00053 void Simple3DGame::Initialize(
00054     _In_ MoveLookController^ controller,
00055     _In_ GameRenderer^ renderer
00056     )
00057 {
00058     // This method is expected to be called as an asynchronous task.
00059     // Care should be taken to not call rendering methods on the
00060     // m_renderer as this would result in the D3D Context being
00061     // used in multiple threads, which is not allowed.
00062
00063     m_controller = controller;
00064     m_renderer = renderer;
00065
00066     m_audioController = ref new Audio;
00067     m_audioController->CreateDeviceIndependentResources();
00068
00069     InitializeGameConfig();
00070
00071     m_ammo = std::vector<Sphere^>(GameConstants::MaxAmmo);
00072     m_objects = std::vector<GameObject^>();
00073     m_renderObjects = std::vector<GameObject^>();
00074     m_level = std::vector<Level^>();
00075
00076     m_savedState = ref new PersistentState();
00077     m_savedState->Initialize(ApplicationData::Current->LocalSettings->Values, "Game");
00078
00079     m_timer = ref new GameTimer();
00080
00081     // Create a sphere primitive to represent the player.
00082     // The sphere will be used to handle collisions and constrain the player in the world.
00083     // It is not rendered so it is not added to the list of render objects.
00084     // It is added to the object list so it will be included in intersection calculations.
00085     m_player = ref new Sphere(XMFLOAT3(0.0f, -1.3f, 4.0f), 0.2f);
00086     m_objects.push_back(m_player);
00087     m_player->Active(true);
00088
00089     m_camera = ref new Camera;
00090     m_camera->SetProjParams(XM_PI / 2, 1.0f, 0.01f, 100.0f);
00091     m_camera->SetViewParams(
00092         m_player->Position(),            // Eye point in world coordinates.
00093         XMFLOAT3 (0.0f, 0.7f, 0.0f),     // Look at point in world coordinates.
00094         XMFLOAT3 (0.0f, 1.0f, 0.0f)      // The Up vector for the camera.
00095         );
00096
00097     m_controller->Pitch(m_camera->Pitch());
00098     m_controller->Yaw(m_camera->Yaw());
00099
00100     // Instantiate a set of primitives to represent the containing world. These objects
00101     // maintain the geometry and material properties of the walls, floor and ceiling.
00102     // The TargetId is used to identify the world objects so that the right geometry
00103     // and textures can be associated with them later after those resources have
00104     // been created.
00105     GameObject^ world = ref new GameObject();
00106     world->TargetId(GameConstants::WorldFloorId);
00107     world->Active(true);
00108     m_renderObjects.push_back(world);
00109
00110     world = ref new GameObject();
00111     world->TargetId(GameConstants::WorldCeilingId);
00112     world->Active(true);
00113     m_renderObjects.push_back(world);
00114
00115     world = ref new GameObject();
00116     world->TargetId(GameConstants::WorldWallsId);
00117     world->Active(true);
00118     m_renderObjects.push_back(world);
00119
00120     // Min and max Bound are defining the world space of the game.
00121     // All camera motion and dynamics are confined to this space.
00122     m_minBound = XMFLOAT3(-4.0f, -3.0f, -6.0f);
00123     m_maxBound = XMFLOAT3(4.0f, 3.0f, 6.0f);
00124
00125     // Instantiate the Cylinders for use in the various game levels.
00126     // Each cylinder has a different initial position, radius and direction vector,
00127     // but share a common set of material properties.
00128     for (int a = 0; a < GameConstants::MaxCylinders; a++)
00129     {
00130         Cylinder^ cylinder;
00131         switch (a)
00132         {
00133         case 0:
00134             cylinder = ref new Cylinder(XMFLOAT3(-2.0f, -3.0f, 0.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00135             break;
00136         case 1:
00137             cylinder = ref new Cylinder(XMFLOAT3(2.0f, -3.0f, 0.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00138             break;
00139         case 2:
00140             cylinder = ref new Cylinder(XMFLOAT3(0.0f, -3.0f, -2.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00141             break;
00142         case 3:
00143             cylinder = ref new Cylinder(XMFLOAT3(-1.5f, -3.0f, -4.0f), 0.25f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00144             break;
00145         case 4:
00146             cylinder = ref new Cylinder(XMFLOAT3(1.5f, -3.0f, -4.0f), 0.50f, XMFLOAT3(0.0f, 6.0f, 0.0f));
00147             break;
00148         }
00149         cylinder->Active(true);
00150         m_objects.push_back(cylinder);
00151         m_renderObjects.push_back(cylinder);
00152     }
00153
00154     MediaReader^ mediaReader = ref new MediaReader;
00155     auto targetHitSound = mediaReader->LoadMedia("hit.wav");
00156
00157     // Instantiate the targets for use in the game.
00158     // Each target has a different initial position, size and orientation,
00159     // but share a common set of material properties.
00160     // The target is defined by a position and two vectors that define both
00161     // the plane of the target in world space and the size of the parallelogram
00162     // based on the lengths of the vectors.
00163     // Each target is assigned a number for identification purposes.
00164     // The Target ID number is 1 based.
00165     // All targets have the same material properties.
00166     for (int a = 1; a < GameConstants::MaxTargets; a++)
00167     {
00168         Face^ target;
00169         switch (a)
00170         {
00171         case 1:
00172             target = ref new Face(XMFLOAT3(-2.5f, -1.0f, -1.5f), XMFLOAT3(-1.5f, -1.0f, -2.0f), XMFLOAT3(-2.5f, 1.0f, -1.5f));
00173             break;
00174         case 2:
00175             target = ref new Face(XMFLOAT3(-1.0f, 1.0f, -3.0f), XMFLOAT3(0.0f, 1.0f, -3.0f), XMFLOAT3(-1.0f, 2.0f, -3.0f));
00176             break;
00177         case 3:
00178             target = ref new Face(XMFLOAT3(1.5f, 0.0f, -3.0f), XMFLOAT3(2.5f, 0.0f, -2.0f), XMFLOAT3(1.5f, 2.0f, -3.0f));
00179             break;
00180         case 4:
00181             target = ref new Face(XMFLOAT3(-2.5f, -1.0f, -5.5f), XMFLOAT3(-0.5f, -1.0f, -5.5f), XMFLOAT3(-2.5f, 1.0f, -5.5f));
00182             break;
00183         case 5:
00184             target = ref new Face(XMFLOAT3(0.5f, -2.0f, -5.0f), XMFLOAT3(1.5f, -2.0f, -5.0f), XMFLOAT3(0.5f, 0.0f, -5.0f));
00185             break;
00186         case 6:
00187             target = ref new Face(XMFLOAT3(1.5f, -2.0f, -5.5f), XMFLOAT3(2.5f, -2.0f, -5.0f), XMFLOAT3(1.5f, 0.0f, -5.5f));
00188             break;
00189         case 7:
00190             target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
00191             break;
00192         case 8:
00193             target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
00194             break;
00195         case 9:
00196             target = ref new Face(XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.5f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.5f, 0.0f));
00197             break;
00198         }
00199
00200         target->Target(true);
00201         target->TargetId(a);
00202         target->Active(true);
00203         target->HitSound(ref new SoundEffect());
00204         target->HitSound()->Initialize(
00205             m_audioController->SoundEffectEngine(),
00206             mediaReader->GetOutputWaveFormatEx(),
00207             targetHitSound
00208             );
00209
00210         m_objects.push_back(target);
00211         m_renderObjects.push_back(target);
00212     }
00213
00214     // Instantiate a set of spheres to be used as ammunition for the game
00215     // and set the material properties of the spheres.
00216     auto ammoHitSound = mediaReader->LoadMedia("bounce.wav");
00217
00218     for (int a = 0; a < GameConstants::MaxAmmo; a++)
00219     {
00220         m_ammo[a] = ref new Sphere;
00221         m_ammo[a]->Radius(GameConstants::AmmoRadius);
00222         m_ammo[a]->HitSound(ref new SoundEffect());
00223         m_ammo[a]->HitSound()->Initialize(
00224             m_audioController->SoundEffectEngine(),
00225             mediaReader->GetOutputWaveFormatEx(),
00226             ammoHitSound
00227             );
00228         m_ammo[a]->Active(false);
00229         m_renderObjects.push_back(m_ammo[a]);
00230     }
00231
00232     // Instantiate each of the game levels. The Level class contains methods
00233     // that initialize the objects in the world for the given level and also
00234     // define any motion paths for the objects in that level.
00235
00236     m_level.push_back(ref new Level1);
00237     m_level.push_back(ref new Level2);
00238     if (!m_gameConfig.isTrial)
00239     {
00240         m_level.push_back(ref new Level3);
00241         m_level.push_back(ref new Level4);
00242         m_level.push_back(ref new Level5);
00243         m_level.push_back(ref new Level6);
00244     }
00245     m_levelCount = static_cast<uint32>(m_level.size());
00246
00247     // Load the top score from disk if it exists.
00248     LoadHighScore();
00249
00250     // Load the currentScore for saved state if it exists.
00251     LoadState();
00252
00253     m_controller->Active(false);
00254 }
00255
00256 //----------------------------------------------------------------------
00257
00258 void Simple3DGame::LoadGame()
00259 {
00260     m_player->Position(XMFLOAT3 (0.0f, -1.3f, 4.0f));
00261
00262     m_camera->SetViewParams(
00263         m_player->Position(),            // Eye point in world coordinates.
00264         XMFLOAT3 (0.0f, 0.7f, 0.0f),     // Look at point in world coordinates.
00265         XMFLOAT3 (0.0f, 1.0f, 0.0f)      // The Up vector for the camera.
00266         );
00267
00268     m_controller->Pitch(m_camera->Pitch());
00269     m_controller->Yaw(m_camera->Yaw());
00270     m_currentLevel = 0;
00271     m_levelTimeRemaining = 0.0f;
00272     m_levelBonusTime = m_levelTimeRemaining;
00273     m_levelDuration = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime;
00274     InitializeAmmo();
00275     m_totalHits = 0;
00276     m_totalShots = 0;
00277     m_gameActive = false;
00278     m_levelActive = false;
00279     m_timer->Reset();
00280 }
00281
00282 //----------------------------------------------------------------------
00283
00284 task<void> Simple3DGame::LoadLevelAsync()
00285 {
00286     // Initialize the level and spin up the async loading of the rendering
00287     // resources for the level.
00288     // This will run in a separate thread, so for Direct3D 11, only Device
00289     // methods are allowed.  Any DeviceContext method calls need to be
00290     // done in FinalizeLoadLevel.
00291
00292     m_level[m_currentLevel]->Initialize(m_objects);
00293     m_levelDuration = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime;
00294
00295     return m_renderer->LoadLevelResourcesAsync();
00296 }
00297
00298 //----------------------------------------------------------------------
00299
00300 void Simple3DGame::FinalizeLoadLevel()
00301 {
00302     // This method is called on the main thread, so Direct3D 11 DeviceContext
00303     // method calls are allowable here.
00304
00305     // Finalize the Level loading.
00306     m_renderer->FinalizeLoadLevelResources();
00307 }
00308
00309 //----------------------------------------------------------------------
00310
00311 void Simple3DGame::StartLevel()
00312 {
00313     m_timer->Reset();
00314     m_timer->Start();
00315     if (m_currentLevel == 0)
00316     {
00317         m_gameActive = true;
00318     }
00319     m_levelActive = true;
00320     m_controller->Active(true);
00321 }
00322
00323 //----------------------------------------------------------------------
00324
00325 void Simple3DGame::PauseGame()
00326 {
00327     m_timer->Stop();
00328     SaveState();
00329 }
00330
00331 //----------------------------------------------------------------------
00332
00333 void Simple3DGame::ContinueGame()
00334 {
00335     m_timer->Start();
00336     m_controller->Active(true);
00337 }
00338
00339 //----------------------------------------------------------------------
00340
00341 GameState Simple3DGame::RunGame()
00342 {
00343     // This method is called to execute a single time interval for active game play.
00344     // It returns the resulting state of game play after the interval has been executed.
00345
00346     m_timer->Update();
00347
00348     m_levelTimeRemaining = m_levelDuration - m_timer->PlayingTime();
00349
00350     if (m_levelTimeRemaining <= 0.0f)
00351     {
00352         // Time expired, so the game is over.
00353         m_levelTimeRemaining = 0.0f;
00354         InitializeAmmo();
00355         m_timer->Reset();
00356         m_gameActive = false;
00357         m_levelActive = false;
00358         SaveState();
00359
00360         if (m_totalHits > m_topScore.totalHits)
00361         {
00362             // There is a new high score so save it.
00363             m_topScore.totalHits = m_totalHits;
00364             m_topScore.totalShots = m_totalShots;
00365             m_topScore.levelCompleted = m_currentLevel;
00366
00367             SaveHighScore();
00368         }
00369         return GameState::TimeExpired;
00370     }
00371     else
00372     {
00373         // Time has not expired, so run one frame of game play.
00374         m_player->Velocity(m_controller->Velocity());
00375         m_camera->LookDirection(m_controller->LookDirection());
00376
00377         UpdateDynamics();
00378
00379         // Update the Camera with the player position updates from the dynamics calculations.
00380         m_camera->Eye(m_player->Position());
00381         m_camera->LookDirection(m_controller->LookDirection());
00382
00383         if (m_level[m_currentLevel]->Update(m_timer->PlayingTime(), m_timer->DeltaTime(), m_levelTimeRemaining, m_objects))
00384         {
00385             // The level has been completed.
00386             m_levelActive = false;
00387             InitializeAmmo();
00388
00389             if (m_currentLevel < m_levelCount-1)
00390             {
00391                 // More levels to go so increment the level number.
00392                 // Actual level loading will occur in the LoadLevelAsync / FinalizeLoadLevel
00393                 // methods.
00394                 m_timer->Reset();
00395                 m_currentLevel++;
00396                 m_levelBonusTime = m_levelTimeRemaining;
00397                 SaveState();
00398                 return GameState::LevelComplete;
00399             }
00400             else
00401             {
00402                 // All levels have been completed.
00403                 m_timer->Reset();
00404                 m_gameActive = false;
00405                 m_levelActive = false;
00406                 SaveState();
00407
00408                 if (m_totalHits > m_topScore.totalHits)
00409                 {
00410                     // There is a new high score so save it.
00411                     m_topScore.totalHits = m_totalHits;
00412                     m_topScore.totalShots = m_totalShots;
00413                     m_topScore.levelCompleted = m_currentLevel;
00414
00415                     SaveHighScore();
00416                 }
00417                 return GameState::GameComplete;
00418             }
00419         }
00420     }
00421     return GameState::Active;
00422 }
00423
00424 //----------------------------------------------------------------------
00425
00426 void Simple3DGame::OnSuspending()
00427 {
00428     m_audioController->SuspendAudio();
00429 }
00430
00431 //----------------------------------------------------------------------
00432
00433 void Simple3DGame::OnResuming()
00434 {
00435     m_audioController->ResumeAudio();
00436 }
00437
00438 //----------------------------------------------------------------------
00439
00440 void Simple3DGame::UpdateDynamics()
00441 {
00442     float timeTotal = m_timer->PlayingTime();
00443     float timeFrame = m_timer->DeltaTime();
00444     bool fire = m_controller->IsFiring();
00445
00446 #pragma region Shoot Ammo
00447     // Shoot ammo.
00448     if (fire)
00449     {
00450         static float lastFired;  // Timestamp of last ammo fired.
00451
00452         if (timeTotal < lastFired)
00453         {
00454             // timeTotal is not guarenteed to be monotomically increasing because it is
00455             // reset at each level.
00456             lastFired = timeTotal - GameConstants::Physics::AutoFireDelay;
00457         }
00458
00459         if (timeTotal - lastFired >= GameConstants::Physics::AutoFireDelay)
00460         {
00461             // Get inverse view matrix.
00462             XMMATRIX invView;
00463             XMVECTOR det;
00464             invView = XMMatrixInverse(&det, m_camera->View());
00465
00466             // Compute initial velocity in world space from camera space.
00467             XMFLOAT4 initialVelocity(0.0f, 0.0f, 15.0f, 0.0f);
00468             m_ammo[m_ammoNext]->Velocity(XMVector4Transform(XMLoadFloat4(&initialVelocity), invView));
00469
00470             // Set the initial position of the ammo to be fired. The position is offset from the player
00471             // to avoid an initial collision with the player object.
00472             XMFLOAT4 initialPosition(0.0f, -0.15f, m_player->Radius() + GameConstants::AmmoSize, 1.0f);
00473             m_ammo[m_ammoNext]->Position(XMVector4Transform(XMLoadFloat4(&initialPosition), invView));
00474
00475             // Initially not laying on ground.
00476             m_ammo[m_ammoNext]->OnGround(false);
00477             m_ammo[m_ammoNext]->Active(true);
00478
00479             // Set position in array of next Ammo to use.
00480             // We will re-use ammo taking the least recently used once we have hit the
00481             // MaxAmmo in use.
00482             m_ammoNext = (m_ammoNext + 1) % GameConstants::MaxAmmo;
00483             m_ammoCount = min(m_ammoCount + 1, GameConstants::MaxAmmo);
00484
00485             lastFired = timeTotal;
00486             m_totalShots++;
00487         }
00488     }
00489 #pragma endregion
00490
00491 #pragma region Animate Objects
00492     // Walk the list of objects looking for any objects that have an animation associated with it.
00493     // Update the position of the object based on evaluating the animation object with the current time.
00494     // Once the current time (timeTotal) is past the end of the animation time remove
00495     // the animation object since it is no longer needed.
00496     for (uint32 i = 0; i < m_objects.size(); i++)
00497     {
00498         if (m_objects[i]->AnimatePosition())
00499         {
00500             m_objects[i]->Position(m_objects[i]->AnimatePosition()->Evaluate(timeTotal));
00501             if (m_objects[i]->AnimatePosition()->IsFinished(timeTotal))
00502             {
00503                 m_objects[i]->AnimatePosition(nullptr);
00504             }
00505         }
00506     }
00507 #pragma endregion
00508
00509     // If the elapsed time is too long, we slice up the time and handle physics over several
00510     // smaller time steps to avoid missing collisions.
00511     float timeLeft = timeFrame;
00512     float elapsedFrameTime;
00513     while (timeLeft > 0.0f)
00514     {
00515         elapsedFrameTime = min(timeLeft, GameConstants::Physics::FrameLength);
00516         timeLeft -= elapsedFrameTime;
00517
00518         // Update the player position.
00519         m_player->Position(m_player->VectorPosition() + m_player->VectorVelocity() * elapsedFrameTime);
00520
00521         // Do m_player / object intersections.
00522         for (uint32 a = 0; a < m_objects.size(); a++)
00523         {
00524             if (m_objects[a]->Active() && m_objects[a] != m_player)
00525             {
00526                 XMFLOAT3 contact;
00527                 XMFLOAT3 normal;
00528
00529                 if (m_objects[a]->IsTouching(m_player->Position(), m_player->Radius(), &contact, &normal))
00530                 {
00531                     // Player is in contact with m_objects[a].
00532                     XMVECTOR oneToTwo;
00533                     oneToTwo = -XMLoadFloat3(&normal);
00534
00535                     float impact = XMVectorGetX(
00536                         XMVector3Dot (oneToTwo, m_player->VectorVelocity())
00537                         );
00538                     // Make sure that the player is actually headed towards the object. At grazing angles there
00539                     // could appear to be an impact when the player is actually already hit and moving away.
00540                     if (impact > 0.0f)
00541                     {
00542                         // Compute the normal and tangential components of the player's velocity.
00543                         XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, m_player->VectorVelocity()) * oneToTwo;
00544                         XMVECTOR velocityOneTangent = m_player->VectorVelocity() - velocityOneNormal;
00545
00546                         // Compute post-collision velocity.
00547                         m_player->Velocity(velocityOneTangent - velocityOneNormal);
00548
00549                         // Fix the positions so that the player is just touching the object.
00550                         float distanceToMove = m_player->Radius();
00551                         m_player->Position(XMLoadFloat3(&contact) - (oneToTwo * distanceToMove));
00552                     }
00553                 }
00554             }
00555         }
00556         {
00557             // Do collision detection of the player with the bounding world.
00558             XMFLOAT3 position = m_player->Position();
00559             XMFLOAT3 velocity = m_player->Velocity();
00560             float radius = m_player->Radius();
00561
00562             // Check for player collisions with the walls floor or ceiling and adjust the position.
00563             float limit = m_minBound.x + radius;
00564             if (position.x < limit)
00565             {
00566                 position.x = limit;
00567                 velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
00568             }
00569             limit = m_maxBound.x - radius;
00570             if (position.x > limit)
00571             {
00572                 position.x = limit;
00573                 velocity.x = -velocity.x + GameConstants::Physics::GroundRestitution;
00574             }
00575             limit = m_minBound.y + radius;
00576             if (position.y < limit)
00577             {
00578                 position.y = limit;
00579                 velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
00580             }
00581             limit = m_maxBound.y - radius;
00582             if (position.y > limit)
00583             {
00584                 position.y = limit;
00585                 velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
00586             }
00587             limit = m_minBound.z + radius;
00588             if (position.z < limit)
00589             {
00590                 position.z = limit;
00591                 velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
00592             }
00593             limit = m_maxBound.z - radius;
00594             if (position.z > limit)
00595             {
00596                 position.z = limit;
00597                 velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
00598             }
00599             m_player->Position(position);
00600             m_player->Velocity(velocity);
00601         }
00602
00603         // Animate the ammo.
00604         if (m_ammoCount > 0)
00605         {
00606             // Check for collisions between ammo.
00607 #pragma region inter-ammo collision detection
00608             if (m_ammoCount > 1)
00609             {
00610                 for (uint32 one = 0; one < m_ammoCount; one++)
00611                 {
00612                     for (uint32 two = (one + 1); two < m_ammoCount; two++)
00613                     {
00614                         // Check collision between instances One and Two.
00615                         // OneToTwo is the vector between the centers of the two ammo that are being checked.
00616                         XMVECTOR oneToTwo;
00617                         oneToTwo = m_ammo[two]->VectorPosition() - m_ammo[one]->VectorPosition();
00618                         float distanceSquared;
00619                         distanceSquared = XMVectorGetX(
00620                             XMVector3LengthSq(oneToTwo)
00621                             );
00622                         if (distanceSquared < (GameConstants::AmmoSize * GameConstants::AmmoSize))
00623                         {
00624                             // The two ammo are intersecting.
00625                             oneToTwo = XMVector3Normalize(oneToTwo);
00626
00627                             // Check if the two instances are already moving away from each other.
00628                             // If so, skip collision.  This can happen when a lot of instances are
00629                             // bunched up next to each other.
00630                             float impact;
00631                             impact = XMVectorGetX(
00632                                 XMVector3Dot(oneToTwo, m_ammo[one]->VectorVelocity()) -
00633                                 XMVector3Dot(oneToTwo, m_ammo[two]->VectorVelocity())
00634                                 );
00635                             if (impact > 0.0f)
00636                             {
00637                                 // Compute the normal and tangential components of one's velocity.
00638                                 XMVECTOR velocityOne = (1 - GameConstants::Physics::BounceLost) * m_ammo[one]->VectorVelocity();
00639                                 XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, velocityOne) * oneToTwo;
00640                                 XMVECTOR velocityOneTangent = velocityOne - velocityOneNormal;
00641                                 // Compute the normal and tangential components of two's velocity.
00642                                 XMVECTOR velocityTwo = (1 - GameConstants::Physics::BounceLost) * m_ammo[two]->VectorVelocity();
00643                                 XMVECTOR velocityTwoNormal = XMVector3Dot(oneToTwo, velocityTwo) * oneToTwo;
00644                                 XMVECTOR velocityTwoTangent = velocityTwo - velocityTwoNormal;
00645
00646                                 // Compute the post-collision velocities.
00647                                 m_ammo[one]->Velocity(velocityOneTangent - velocityOneNormal * (1 - GameConstants::Physics::BounceTransfer) +
00648                                     velocityTwoNormal * GameConstants::Physics::BounceTransfer
00649                                     );
00650                                 m_ammo[two]->Velocity(velocityTwoTangent - velocityTwoNormal * (1 - GameConstants::Physics::BounceTransfer) +
00651                                     velocityOneNormal * GameConstants::Physics::BounceTransfer
00652                                     );
00653
00654                                 // Fix the positions so that the two balls are exactly GameConstants::AmmoSize apart.
00655                                 float distanceToMove = (GameConstants::AmmoSize - sqrtf(distanceSquared)) * 0.5f;
00656                                 m_ammo[one]->Position(m_ammo[one]->VectorPosition() - (oneToTwo * distanceToMove));
00657                                 m_ammo[two]->Position(m_ammo[two]->VectorPosition() + (oneToTwo * distanceToMove));
00658
00659                                 // Flag the two instances so that they are not laying on ground.
00660                                 m_ammo[one]->OnGround(false);
00661                                 m_ammo[two]->OnGround(false);
00662
00663                                 // Start playing the sounds for the impact between the two balls.
00664                                 m_ammo[one]->PlaySound(impact, m_player->Position());
00665                                 m_ammo[two]->PlaySound(impact, m_player->Position());
00666                             }
00667                         }
00668                     }
00669                 }
00670             }
00671 #pragma endregion
00672
00673 #pragma region Ammo-Object intersections
00674             // Check for intersections between the ammo and the other objects in the scene.
00675             for (uint32 one = 0; one < m_ammoCount; one++)
00676             {
00677                 if (m_objects.size() > 0)
00678                 {
00679                     if (!m_ammo[one]->OnGround())
00680                     {
00681                         for (uint32 i = 0; i < m_objects.size(); i++)
00682                         {
00683                             if (m_objects[i]->Active())
00684                             {
00685                                 // The object is currently active in the scene. There may be objects in the list
00686                                 // that are currently inactive, so those are skipped.
00687                                 XMFLOAT3 contact;
00688                                 XMFLOAT3 normal;
00689
00690                                 if (m_objects[i]->IsTouching(m_ammo[one]->Position(), GameConstants::AmmoRadius, &contact, &normal))
00691                                 {
00692                                     // Ball is in contact with Object.
00693                                     XMVECTOR oneToTwo;
00694                                     oneToTwo = -XMLoadFloat3(&normal);
00695
00696                                     float impact;
00697                                     impact = XMVectorGetX(
00698                                         XMVector3Dot (oneToTwo, m_ammo[one]->VectorVelocity())
00699                                         );
00700                                     // Make sure that the ball is actually headed towards the object. At grazing angles there
00701                                     // could appear to be an impact when the ball is actually already hit and moving away.
00702                                     if (impact > 0.0f)
00703                                     {
00704                                         // Compute the normal and tangential components of the ammo's velocity.
00705                                         XMVECTOR velocityOne = (1 - GameConstants::Physics::BounceLost) * m_ammo[one]->VectorVelocity();
00706                                         XMVECTOR velocityOneNormal = XMVector3Dot(oneToTwo, velocityOne) * oneToTwo;
00707                                         XMVECTOR velocityOneTangent = velocityOne - velocityOneNormal;
00708
00709                                         // Compute post-collision velocity of the ammo.
00710                                         m_ammo[one]->Velocity(velocityOneTangent - velocityOneNormal * (1 - GameConstants::Physics::BounceTransfer));
00711
00712                                         // Fix the position so that the ball is exactly GameConstants::AmmoRadius from target.
00713                                         float distanceToMove = GameConstants::AmmoSize;
00714                                         m_ammo[one]->Position(XMLoadFloat3(&contact) - (oneToTwo * distanceToMove));
00715
00716                                         // Flag the Ammo as not laying on ground.
00717                                         m_ammo[one]->OnGround(false);
00718
00719                                         // Play the sound associated with the Ammo hitting something.
00720                                         m_ammo[one]->PlaySound(impact, m_player->Position());
00721
00722                                         if (m_objects[i]->Target() && !m_objects[i]->Hit())
00723                                         {
00724                                             // The object is a target and isn't currently hit, so mark it as hit and
00725                                             // play the sound associated with the impact.
00726                                             m_objects[i]->Hit(true);
00727                                             m_objects[i]->HitTime(timeTotal);
00728                                             m_totalHits++;
00729
00730                                             m_objects[i]->PlaySound(impact, m_player->Position());
00731                                         }
00732                                     }
00733                                 }
00734                             }
00735                         }
00736                     }
00737                 }
00738             }
00739 #pragma endregion
00740
00741 #pragma region Apply Gravity and world intersection
00742             // Apply gravity and check for collision against enclosing volume.
00743             for (uint32 i = 0; i < m_ammoCount; i++)
00744             {
00745                 // Update the position and velocity of the ammo instance.
00746                 m_ammo[i]->Position(m_ammo[i]->VectorPosition() + m_ammo[i]->VectorVelocity() * elapsedFrameTime);
00747
00748                 XMFLOAT3 velocity = m_ammo[i]->Velocity();
00749                 XMFLOAT3 position = m_ammo[i]->Position();
00750
00751                 velocity.x -= velocity.x * 0.1f * elapsedFrameTime;
00752                 velocity.z -= velocity.z * 0.1f * elapsedFrameTime;
00753                 if (!m_ammo[i]->OnGround())
00754                 {
00755                     // Apply gravity if the ammo instance is not already resting on the ground.
00756                     velocity.y -= GameConstants::Physics::Gravity * elapsedFrameTime;
00757                 }
00758
00759                 if (!m_ammo[i]->OnGround())
00760                 {
00761                     float limit = m_minBound.y + GameConstants::AmmoRadius;
00762                     if (position.y < limit)
00763                     {
00764                         // The ammo instance hit the ground.
00765                         // Align the ammo instance to the ground, invert the Y component of the velocity and
00766                         // play the impact sound. The X and Z velocity components will be reduced
00767                         // because of friction.
00768                         position.y = limit;
00769                         m_ammo[i]->PlaySound(-velocity.y, m_player->Position());
00770
00771                         velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
00772                         velocity.x *= GameConstants::Physics::Friction;
00773                         velocity.z *= GameConstants::Physics::Friction;
00774                     }
00775                 }
00776                 else
00777                 {
00778                     // The ammo instance is resting or rolling on ground.
00779                     // X and Z velocity components are reduced because of friction.
00780                     velocity.x *= GameConstants::Physics::Friction;
00781                     velocity.z *= GameConstants::Physics::Friction;
00782                 }
00783
00784                 float limit = m_maxBound.y - GameConstants::AmmoRadius;
00785                 if (position.y > limit)
00786                 {
00787                     // The ammo instance hit the ceiling.
00788                     // Align the ammo instance to the ceiling, invert the Y component of the velocity and
00789                     // play the impact sound. The X and Z velocity components will be reduced
00790                     // because of friction.
00791                     position.y = limit;
00792                     m_ammo[i]->PlaySound(-velocity.y, m_player->Position());
00793
00794                     velocity.y = -velocity.y * GameConstants::Physics::GroundRestitution;
00795                     velocity.x *= GameConstants::Physics::Friction;
00796                     velocity.z *= GameConstants::Physics::Friction;
00797                 }
00798
00799                 limit = m_minBound.y + GameConstants::AmmoRadius;
00800                 if ((GameConstants::Physics::Gravity * (position.y - limit) + 0.5f * velocity.y * velocity.y) < GameConstants::Physics::RestThreshold)
00801                 {
00802                     // The Y velocity component is below the resting threshold so flag the instance as
00803                     // laying on the ground and set the Y velocity component to zero.
00804                     position.y = limit;
00805                     velocity.y = 0.0f;
00806                     m_ammo[i]->OnGround(true);
00807                 }
00808
00809                 limit = m_minBound.z + GameConstants::AmmoRadius;
00810                 if (position.z < limit)
00811                 {
00812                     // The ammo instance hit the a wall in the min Z direction.
00813                     // Align the ammo instance to the wall, invert the Z component of the velocity and
00814                     // play the impact sound.
00815                     position.z = limit;
00816                     m_ammo[i]->PlaySound(-velocity.z, m_player->Position());
00817                     velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
00818                 }
00819
00820                 limit = m_maxBound.z - GameConstants::AmmoRadius;
00821                 if (position.z > limit)
00822                 {
00823                     // The ammo instance hit the a wall in the max Z direction.
00824                     // Align the ammo instance to the wall, invert the Z component of the velocity and
00825                     // play the impact sound.
00826                     position.z = limit;
00827                     m_ammo[i]->PlaySound(-velocity.z, m_player->Position());
00828                     velocity.z = -velocity.z * GameConstants::Physics::GroundRestitution;
00829                 }
00830
00831                 limit = m_minBound.x + GameConstants::AmmoRadius;
00832                 if (position.x < limit)
00833                 {
00834                     // The ammo instance hit the a wall in the min X direction.
00835                     // Align the ammo instance to the wall, invert the X component of the velocity and
00836                     // play the impact sound.
00837                     position.x = limit;
00838                     m_ammo[i]->PlaySound(-velocity.x, m_player->Position());
00839                     velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
00840                 }
00841
00842                 limit = m_maxBound.x - GameConstants::AmmoRadius;
00843                 if (position.x > limit)
00844                 {
00845                     // The ammo instance hit the a wall in the max X direction.
00846                     // Align the ammo instance to the wall, invert the X component of the velocity and
00847                     // play the impact sound.
00848                     position.x = limit;
00849                     m_ammo[i]->PlaySound(-velocity.x, m_player->Position());
00850                     velocity.x = -velocity.x * GameConstants::Physics::GroundRestitution;
00851                 }
00852
00853                 // Save the updated velocity and position for the ammo instance.
00854                 m_ammo[i]->Velocity(velocity);
00855                 m_ammo[i]->Position(position);
00856             }
00857         }
00858     }
00859 #pragma endregion
00860 }
00861
00862 //----------------------------------------------------------------------
00863
00864 void Simple3DGame::SaveState()
00865 {
00866     // Save basic state of the game.
00867     m_savedState->SaveBool(":GameActive", m_gameActive);
00868     m_savedState->SaveBool(":LevelActive", m_levelActive);
00869     m_savedState->SaveInt32(":LevelCompleted", m_currentLevel);
00870     m_savedState->SaveInt32(":TotalShots", m_totalShots);
00871     m_savedState->SaveInt32(":TotalHits", m_totalHits);
00872     m_savedState->SaveSingle(":BonusRoundTime", m_levelBonusTime);
00873     m_savedState->SaveXMFLOAT3(":PlayerPosition", m_player->Position());
00874     m_savedState->SaveXMFLOAT3(":PlayerLookDirection", m_controller->LookDirection());
00875
00876     if (m_levelActive)
00877     {
00878         // The game is currently in the middle of a level, so save the extended state of
00879         // the game.
00880         m_savedState->SaveSingle(":LevelDuration", m_levelDuration);
00881         m_savedState->SaveSingle(":LevelPlayingTime", m_timer->PlayingTime());
00882
00883         m_savedState->SaveInt32(":AmmoCount", m_ammoCount);
00884         m_savedState->SaveInt32(":AmmoNext", m_ammoNext);
00885
00886         const int bufferLength = 16;
00887         char16 str[bufferLength];
00888
00889         for (uint32 i = 0; i < m_ammoCount; i++)
00890         {
00891             int len = swprintf_s(str, bufferLength, L"%d", i);
00892             Platform::String^ string = ref new Platform::String(str, len);
00893
00894             m_savedState->SaveBool(Platform::String::Concat(":AmmoActive", string), m_ammo[i]->Active());
00895             m_savedState->SaveXMFLOAT3(Platform::String::Concat(":AmmoPosition", string), m_ammo[i]->Position());
00896             m_savedState->SaveXMFLOAT3(Platform::String::Concat(":AmmoVelocity", string), m_ammo[i]->Velocity());
00897         }
00898
00899         m_savedState->SaveInt32(":ObjectCount", static_cast<int>(m_objects.size()));
00900
00901         for (uint32 i = 0; i < m_objects.size(); i++)
00902         {
00903             int len = swprintf_s(str, bufferLength, L"%d", i);
00904             Platform::String^ string = ref new Platform::String(str, len);
00905
00906             m_savedState->SaveBool(Platform::String::Concat(":ObjectActive", string), m_objects[i]->Active());
00907             m_savedState->SaveBool(Platform::String::Concat(":ObjectTarget", string), m_objects[i]->Target());
00908             m_savedState->SaveXMFLOAT3(Platform::String::Concat(":ObjectPosition", string), m_objects[i]->Position());
00909         }
00910
00911         m_level[m_currentLevel]->SaveState(m_savedState);
00912     }
00913 }
00914
00915 //----------------------------------------------------------------------
00916
00917 void Simple3DGame::LoadState()
00918 {
00919     m_gameActive = m_savedState->LoadBool(":GameActive", m_gameActive);
00920     m_levelActive = m_savedState->LoadBool(":LevelActive", m_levelActive);
00921
00922     if (m_gameActive)
00923     {
00924         // Loading from the last known state means the game wasn't finished when it was last played,
00925         // so set the current level.
00926
00927         m_totalShots = m_savedState->LoadInt32(":TotalShots", 0);
00928         m_totalHits = m_savedState->LoadInt32(":TotalHits", 0);
00929         m_currentLevel = m_savedState->LoadInt32(":LevelCompleted", 0);
00930         m_levelBonusTime = m_savedState->LoadSingle(":BonusRoundTime", 0.0f);
00931
00932         m_levelTimeRemaining = m_levelBonusTime;
00933
00934         // Reload the current player position and set both the camera and the controller
00935         // with the current Look Direction.
00936         m_player->Position(
00937             m_savedState->LoadXMFLOAT3(":PlayerPosition", XMFLOAT3(0.0f, 0.0f, 0.0f))
00938             );
00939         m_camera->Eye(m_player->Position());
00940         m_camera->LookDirection(
00941             m_savedState->LoadXMFLOAT3(":PlayerLookDirection", XMFLOAT3(0.0f, 0.0f, 1.0f))
00942             );
00943         m_controller->Pitch(m_camera->Pitch());
00944         m_controller->Yaw(m_camera->Yaw());
00945     }
00946     else
00947     {
00948         // The game was not being played when it was last saved, so initialize to the beginning.
00949         m_currentLevel = 0;
00950         m_levelBonusTime = 0;
00951     }
00952
00953     if (m_currentLevel >= m_levelCount)
00954     {
00955         // The current level is not valid so, reset to a known state and abandon the current game.
00956         m_currentLevel = 0;
00957         m_levelBonusTime = 0;
00958         m_gameActive = false;
00959         m_levelActive = false;
00960     }
00961 }
00962
00963 //----------------------------------------------------------------------
00964
00965 void Simple3DGame::SetCurrentLevelToSavedState()
00966 {
00967     if (m_gameActive)
00968     {
00969         if (m_levelActive)
00970         {
00971             // Middle of a level so restart where left off.
00972             m_levelDuration = m_savedState->LoadSingle(":LevelDuration", 0.0f);
00973
00974             m_timer->Reset();
00975             m_timer->PlayingTime(m_savedState->LoadSingle(":LevelPlayingTime", 0.0f));
00976
00977             m_ammoCount = m_savedState->LoadInt32(":AmmoCount", 0);
00978
00979             m_ammoNext = m_savedState->LoadInt32(":AmmoNext", 0);
00980
00981             const int bufferLength = 16;
00982             char16 str[bufferLength];
00983
00984             for (uint32 i = 0; i < m_ammoCount; i++)
00985             {
00986                 int len = swprintf_s(str, bufferLength, L"%d", i);
00987                 Platform::String^ string = ref new Platform::String(str, len);
00988
00989                 m_ammo[i]->Active(
00990                     m_savedState->LoadBool(
00991                         Platform::String::Concat(":AmmoActive", string),
00992                         m_ammo[i]->Active()
00993                         )
00994                     );
00995                 if (m_ammo[i]->Active())
00996                 {
00997                     m_ammo[i]->OnGround(false);
00998                 }
00999
01000                 m_ammo[i]->Position(
01001                     m_savedState->LoadXMFLOAT3(
01002                         Platform::String::Concat(":AmmoPosition", string),
01003                         m_ammo[i]->Position()
01004                         )
01005                     );
01006
01007                 m_ammo[i]->Velocity(
01008                     m_savedState->LoadXMFLOAT3(
01009                         Platform::String::Concat(":AmmoVelocity", string),
01010                         m_ammo[i]->Velocity()
01011                         )
01012                     );
01013             }
01014
01015             int storedObjectCount = 0;
01016             storedObjectCount = m_savedState->LoadInt32(":ObjectCount", 0);
01017
01018             storedObjectCount = min(storedObjectCount, static_cast<int>(m_objects.size()));
01019
01020             for (int i = 0; i < storedObjectCount; i++)
01021             {
01022                 int len = swprintf_s(str, bufferLength, L"%d", i);
01023                 Platform::String^ string = ref new Platform::String(str, len);
01024
01025                 m_objects[i]->Active(
01026                     m_savedState->LoadBool(
01027                         Platform::String::Concat(":ObjectActive", string),
01028                         m_objects[i]->Active()
01029                         )
01030                     );
01031
01032                 m_objects[i]->Target(
01033                     m_savedState->LoadBool(
01034                         Platform::String::Concat(":ObjectTarget", string),
01035                         m_objects[i]->Target()
01036                         )
01037                     );
01038
01039                 m_objects[i]->Position(
01040                     m_savedState->LoadXMFLOAT3(
01041                         Platform::String::Concat(":ObjectPosition", string),
01042                         m_objects[i]->Position()
01043                         )
01044                     );
01045             }
01046
01047             m_level[m_currentLevel]->LoadState(m_savedState);
01048             m_levelTimeRemaining = m_level[m_currentLevel]->TimeLimit() + m_levelBonusTime - m_timer->PlayingTime();
01049         }
01050     }
01051 }
01052
01053 //----------------------------------------------------------------------
01054
01055 void Simple3DGame::SaveHighScore()
01056 {
01057     m_savedState->SaveInt32(":HighScore:LevelCompleted", m_topScore.levelCompleted);
01058     m_savedState->SaveInt32(":HighScore:TotalShots", m_topScore.totalShots);
01059     m_savedState->SaveInt32(":HighScore:TotalHits", m_topScore.totalHits);
01060 }
01061
01062 //----------------------------------------------------------------------
01063
01064 void Simple3DGame::LoadHighScore()
01065 {
01066     m_topScore.levelCompleted = m_savedState->LoadInt32(":HighScore:LevelCompleted", 0);
01067     m_topScore.totalShots = m_savedState->LoadInt32(":HighScore:TotalShots", 0);
01068     m_topScore.totalHits = m_savedState->LoadInt32(":HighScore:TotalHits", 0);
01069 }
01070
01071 //----------------------------------------------------------------------
01072
01073 void Simple3DGame::InitializeAmmo()
01074 {
01075     m_ammoCount = 0;
01076     m_ammoNext = 0;
01077     for (uint32 i = 0; i < GameConstants::MaxAmmo; i++)
01078     {
01079         m_ammo[i]->Active(false);
01080     }
01081 }
01082
01083 //----------------------------------------------------------------------
01084
01085 void Simple3DGame::InitializeGameConfig()
01086 {
01087     m_gameConfig.isTrial = true;
01088     m_gameConfig.autoFire = false;
01089     m_controller->AutoFire(false);
01090     m_activeBackground = 0;
01091     m_gameConfig.backgroundAvailable[0] = true;
01092     for (int i = 1; i < GameConstants::MaxBackgroundTextures; i++)
01093     {
01094         m_gameConfig.backgroundAvailable[i] = false;
01095     }
01096 }
01097
01098 //--------------------------------------------------------------------------------------
01099
01100 void Simple3DGame::UpdateGameConfig(LicenseInformation^ licenseInformation)
01101 {
01102     if (licenseInformation->IsActive)
01103     {
01104         m_gameConfig.isTrial = licenseInformation->IsTrial;
01105         if (!m_gameConfig.isTrial && licenseInformation->ProductLicenses->Lookup("AutoFire")->IsActive)
01106         {
01107             m_gameConfig.autoFire = true;
01108             m_controller->AutoFire(true);
01109         }
01110         else
01111         {
01112             m_gameConfig.autoFire = false;
01113             m_controller->AutoFire(false);
01114         }
01115         if (!m_gameConfig.isTrial && licenseInformation->ProductLicenses->Lookup("NightBackground")->IsActive)
01116         {
01117             m_gameConfig.backgroundAvailable[1] = true;
01118         }
01119         else
01120         {
01121             m_gameConfig.backgroundAvailable[1] = false;
01122         }
01123         if (!m_gameConfig.isTrial && licenseInformation->ProductLicenses->Lookup("DayBackground")->IsActive)
01124         {
01125             m_gameConfig.backgroundAvailable[2] = true;
01126         }
01127         else
01128         {
01129             m_gameConfig.backgroundAvailable[2] = false;
01130         }
01131     }
01132     else
01133     {
01134         // If no active license then default back to trial version.
01135         InitializeGameConfig();
01136     }
01137
01138     if (m_gameConfig.isTrial)
01139     {
01140         if (m_level.size() > 2)
01141         {
01142             m_level.erase(m_level.begin() + 2, m_level.end());
01143         }
01144     }
01145     else
01146     {
01147         if (m_level.size() == 2)
01148         {
01149             m_level.push_back(ref new Level3);
01150             m_level.push_back(ref new Level4);
01151             m_level.push_back(ref new Level5);
01152             m_level.push_back(ref new Level6);
01153         }
01154     }
01155     m_levelCount = static_cast<uint32>(m_level.size());
01156 }
01157
01158 //--------------------------------------------------------------------------------------
01159
01160 void Simple3DGame::SetBackground(uint32 background)
01161 {
01162     if (background < GameConstants::MaxBackgroundTextures)
01163     {
01164         if (m_gameConfig.backgroundAvailable[background])
01165         {
01166             m_activeBackground = background;
01167             m_renderer->SetBackground(background);
01168         }
01169     }
01170 }
01171
01172 //--------------------------------------------------------------------------------------
01173
01174 void Simple3DGame::CycleBackground()
01175 {
01176     // There may be gaps in the background textures list that are available for use because the
01177     // user has not purchased all them in order or at all.
01178     // Cycle through the list looking for the next one that is valid.  This may require wrapping
01179     // back to the beginning.
01180
01181     unsigned int newBackground = m_activeBackground;
01182
01183     while (newBackground < GameConstants::MaxBackgroundTextures)
01184     {
01185         newBackground++;
01186         if (newBackground >= GameConstants::MaxBackgroundTextures)
01187         {
01188             newBackground = 0;
01189             break;
01190         }
01191         else if (m_gameConfig.backgroundAvailable[newBackground])
01192         {
01193             break;
01194         }
01195     }
01196
01197     if (newBackground != m_activeBackground)
01198     {
01199         m_activeBackground = newBackground;
01200         m_renderer->SetBackground(newBackground);
01201     }
01202 }
01203 //--------------------------------------------------------------------------------------
01204
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/common/suspensionmanager.h Source File

  • Media Play To
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Audio.cpp Source File

  • DirectX 3D shooting game

Audio.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Audio.h"
00010 #include "DirectXSample.h"
00011
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::Foundation;
00014 using namespace Windows::UI::Core;
00015 using namespace Windows::Graphics::Display;
00016
00017 Audio::Audio():
00018     m_audioAvailable(false)
00019 {
00020 }
00021
00022 void Audio::Initialize()
00023 {
00024 }
00025
00026 void Audio::CreateDeviceIndependentResources()
00027 {
00028     UINT32 flags = 0;
00029
00030     DX::ThrowIfFailed(
00031         XAudio2Create(&m_musicEngine, flags)
00032         );
00033
00034 #if defined(_DEBUG)
00035     XAUDIO2_DEBUG_CONFIGURATION debugConfiguration = {0};
00036     debugConfiguration.BreakMask = XAUDIO2_LOG_ERRORS;
00037     debugConfiguration.TraceMask = XAUDIO2_LOG_ERRORS;
00038     m_musicEngine->SetDebugConfiguration(&debugConfiguration);
00039 #endif
00040
00041
00042     HRESULT hr = m_musicEngine->CreateMasteringVoice(&m_musicMasteringVoice);
00043     if (FAILED(hr))
00044     {
00045         // Unable to create an audio device
00046         m_audioAvailable = false;
00047         return;
00048     }
00049
00050     DX::ThrowIfFailed(
00051         XAudio2Create(&m_soundEffectEngine, flags)
00052         );
00053
00054 #if defined(_DEBUG)
00055     m_soundEffectEngine->SetDebugConfiguration(&debugConfiguration);
00056 #endif
00057
00058     DX::ThrowIfFailed(
00059         m_soundEffectEngine->CreateMasteringVoice(&m_soundEffectMasteringVoice)
00060         );
00061
00062     m_audioAvailable = true;
00063 }
00064
00065 IXAudio2* Audio::MusicEngine()
00066 {
00067     return m_musicEngine.Get();
00068 }
00069
00070 IXAudio2* Audio::SoundEffectEngine()
00071 {
00072     return m_soundEffectEngine.Get();
00073 }
00074
00075 void Audio::SuspendAudio()
00076 {
00077     if (m_audioAvailable)
00078     {
00079         m_musicEngine->StopEngine();
00080         m_soundEffectEngine->StopEngine();
00081     }
00082 }
00083
00084 void Audio::ResumeAudio()
00085 {
00086     if (m_audioAvailable)
00087     {
00088         DX::ThrowIfFailed(m_musicEngine->StartEngine());
00089         DX::ThrowIfFailed(m_soundEffectEngine->StartEngine());
00090     }
00091 }
00092
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/common/suspensionmanager.h Source File

  • LightSensor
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario3.xaml.cpp Source File

  • XAML personality animations

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018 #include "Page1.xaml.h"
00019 #include "Page2.xaml.h"
00020
00021 using namespace SDKSample::PersonalityAnimations;
00022
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 Scenario3::Scenario3()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042 }
00043
00044
00045 void SDKSample::PersonalityAnimations::Scenario3::Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00046 {
00047     Button^ b = safe_cast<Button^>(sender);
00048     if (b != nullptr)
00049     {
00050         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00051     }
00052 }
00053
00054
00055 void Scenario3::Scenario3_ClickHandler1(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00056 {
00057   Page1^ p1 = ref new Page1();
00058     mainFrame->Navigate(p1->GetType());
00059 }
00060
00061 void Scenario3::Scenario3_ClickHandler2(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00062 {
00063     Page2^ p2 = ref new Page2();
00064     mainFrame->Navigate(p2->GetType());
00065 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::NotificationContentValidationException Member List

This is the complete list of members for NotificationsExtensions::NotificationContentValidationException, including all inherited members.
NotificationContentValidationException(string message) | NotificationsExtensions::NotificationContentValidationException | [inline]
NotificationContentValidationException(string message) | NotificationsExtensions::NotificationContentValidationException | [inline]
NotificationContentValidationException(string message) | NotificationsExtensions::NotificationContentValidationException | [inline]
NotificationContentValidationException(string message) | NotificationsExtensions::NotificationContentValidationException | [inline]
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/UpdateUsage.xaml.h Source File

  • Mobile broadband account provisioning

UpdateUsage.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // UpdateUsage.xaml.h
00013 // Declaration of the UpdateUsage class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "UpdateUsage.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "Util.h"
00022
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::Graphics::Display;
00026 using namespace Windows::UI::ViewManagement;
00027 using namespace Platform;
00028
00029 namespace SDKSample
00030 {
00031     namespace ProvisioningAgent
00032     {
00033         /// <summary>
00034         /// An empty page that can be used on its own or navigated to within a Frame.
00035         /// </summary>
00036         [Windows::Foundation::Metadata::WebHostHidden]
00037         public ref class UpdateUsage sealed
00038         {
00039         public:
00040             UpdateUsage();
00041
00042         protected:
00043             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00044         private:
00045             MainPage^ rootPage;
00046             Util^ util;
00047             Windows::Networking::NetworkOperators::ProfileMediaType profileMediaType;
00048
00049             void MediaType_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e);
00050             void UpdateUsage_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00051         };
00052     }
00053 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioInput3.xaml.cpp Source File

  • Credential picker

ScenarioInput3.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Input.xaml.cpp
00010 // Implementation of the Scenario3Input class.
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput3.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace CredentialPickerCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031 using namespace Windows::Security::Credentials::UI;
00032 using namespace concurrency;
00033 using namespace Windows::UI::Core;
00034
00035 ScenarioInput3::ScenarioInput3()
00036 {
00037     InitializeComponent();
00038 }
00039
00040 ScenarioInput3::~ScenarioInput3()
00041 {
00042 }
00043
00044 #pragma region Template-Related Code - Do not remove
00045 void ScenarioInput3::OnNavigatedTo(NavigationEventArgs^ e)
00046 {
00047     // Get a pointer to our main page
00048     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00049
00050     // We want to be notified with the OutputFrame is loaded so we can get to the content.
00051     _frameLoadedToken = rootPage->OutputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioInput3::rootPage_OutputFrameLoaded);
00052 }
00053
00054 void ScenarioInput3::OnNavigatedFrom(NavigationEventArgs^ e)
00055 {
00056     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00057 }
00058
00059 #pragma endregion
00060
00061 void ScenarioInput3::SetError(Platform::String^ errorText)
00062 {
00063     this->rootPage->NotifyUser(errorText,NotifyType::ErrorMessage);
00064 }
00065
00066 void ScenarioInput3::SetResult(CredentialPickerResults^ result)
00067 {
00068     auto domainName = result->CredentialDomainName;
00069   auto userName = result->CredentialUserName;
00070   auto password = result->CredentialPassword;
00071   auto savedByApi = result->CredentialSaved;
00072   auto saveOption = result->CredentialSaveOption;
00073   Page^ outputFrame = (Page^)this->rootPage->OutputFrame->Content;
00074   TextBox^ status = (TextBox^)outputFrame->FindName("Status");
00075   status->Text = "OK";
00076   TextBox^ domain = (TextBox^)outputFrame->FindName("Domain");
00077   domain->Text = domainName;
00078   TextBox^ username = (TextBox^)outputFrame->FindName("Username");
00079   username->Text = userName;
00080   TextBox^ passwordBox = (TextBox^)outputFrame->FindName("Password");
00081   passwordBox->Text = password;
00082   TextBox^ credsaved = (TextBox^)outputFrame->FindName("CredentialSaved");
00083   credsaved->Text = (savedByApi ? "true" : "false");
00084   TextBox^ checkboxState = (TextBox^)outputFrame->FindName("CheckboxState");
00085   switch (result->CredentialSaveOption)
00086   {
00087     case Windows::Security::Credentials::UI::CredentialSaveOption::Hidden:
00088       checkboxState->Text = "Hidden";
00089       break;
00090     case Windows::Security::Credentials::UI::CredentialSaveOption::Selected:
00091       checkboxState->Text = "Selected";
00092       break;
00093     case Windows::Security::Credentials::UI::CredentialSaveOption::Unselected:
00094       checkboxState->Text = "Unselected";
00095       break;
00096   }
00097
00098 }
00099
00100 void ScenarioInput3::SetPasswordExplainVisibility(bool isShown)
00101 {
00102     Page^ outputFrame = (Page^)this->rootPage->OutputFrame->Content;
00103     TextBlock^ text1 = (TextBlock^)outputFrame->FindName("PasswordExplain1");
00104     TextBlock^ text2 = (TextBlock^)outputFrame->FindName("PasswordExplain2");
00105     if (isShown)
00106     {
00107         text1->Visibility = Windows::UI::Xaml::Visibility::Visible;
00108         text2->Visibility = Windows::UI::Xaml::Visibility::Visible;
00109     }
00110     else
00111     {
00112         text1->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00113         text2->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00114     }
00115 }
00116
00117
00118
00119 #pragma region Use this code if you need access to elements in the output frame - otherwise delete
00120 void ScenarioInput3::rootPage_OutputFrameLoaded(Object^ sender, Object^ e)
00121 {
00122     // Get a pointer to the content within the OutputFrame.
00123     Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00124
00125     // Go find the elements that we need for this scenario
00126     // ex: flipView1 = dynamic_cast<FlipView^>(outputFrame->FindName("FlipView1"));
00127 }
00128
00129 #pragma endregion
00130
00131 #pragma region Sample click handlers - modify if you need them, otherwise delete
00132 void ScenarioInput3::Launch_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00133 {
00134     if ((Message->Text == nullptr) || (Caption->Text == nullptr) || (Target->Text == nullptr))
00135     {
00136         return;
00137     }
00138
00139     CredentialPickerOptions^ credPickerOptions = ref new CredentialPickerOptions();
00140     credPickerOptions->AlwaysDisplayDialog = AlwaysShowDialog->IsChecked->Value;
00141     credPickerOptions->Message = Message->Text;
00142     credPickerOptions->Caption = Caption->Text;
00143     credPickerOptions->TargetName = Target->Text;
00144     if (Protocol->SelectedItem == nullptr)
00145     {
00146         credPickerOptions->AuthenticationProtocol = Windows::Security::Credentials::UI::AuthenticationProtocol::Negotiate;
00147     }
00148     else
00149     {
00150         String^ protocolName = ((ComboBoxItem^)Protocol->SelectedItem)->Content->ToString();
00151         if (protocolName->Equals("Negotiate"))
00152         {
00153             credPickerOptions->AuthenticationProtocol = Windows::Security::Credentials::UI::AuthenticationProtocol::Negotiate;
00154         }
00155         else if (protocolName->Equals("NTLM"))
00156         {
00157             credPickerOptions->AuthenticationProtocol = Windows::Security::Credentials::UI::AuthenticationProtocol::Ntlm;
00158         }
00159         else if (protocolName->Equals("Kerberos"))
00160         {
00161             credPickerOptions->AuthenticationProtocol = Windows::Security::Credentials::UI::AuthenticationProtocol::Kerberos;
00162         }
00163         else if (protocolName->Equals("CredSsp"))
00164         {
00165             credPickerOptions->AuthenticationProtocol = Windows::Security::Credentials::UI::AuthenticationProtocol::CredSsp;
00166         }
00167         else if (protocolName->Equals("Basic"))
00168         {
00169             credPickerOptions->AuthenticationProtocol = Windows::Security::Credentials::UI::AuthenticationProtocol::Basic;
00170         }
00171         else if (protocolName->Equals("Digest"))
00172         {
00173             credPickerOptions->AuthenticationProtocol = Windows::Security::Credentials::UI::AuthenticationProtocol::Digest;
00174         }
00175         else if (protocolName->Equals("Custom"))
00176         {
00177             credPickerOptions->AuthenticationProtocol = Windows::Security::Credentials::UI::AuthenticationProtocol::Custom;
00178             credPickerOptions->CustomAuthenticationProtocol = CustomProtocol->Text;
00179         }
00180         else
00181         {
00182             rootPage->NotifyUser("Unknown Protocol",NotifyType::ErrorMessage);
00183         }
00184     }
00185     if (CheckboxState->SelectedItem != nullptr)
00186     {
00187         String^ checkboxState = ((ComboBoxItem^)CheckboxState->SelectedItem)->Content->ToString();
00188         if (checkboxState->Equals("Hidden"))
00189         {
00190             credPickerOptions->CredentialSaveOption = Windows::Security::Credentials::UI::CredentialSaveOption::Hidden;
00191         }
00192         else if (checkboxState->Equals("Selected"))
00193         {
00194             credPickerOptions->CredentialSaveOption = Windows::Security::Credentials::UI::CredentialSaveOption::Selected;
00195         }
00196         else if (checkboxState->Equals("Unselected"))
00197         {
00198             credPickerOptions->CredentialSaveOption = Windows::Security::Credentials::UI::CredentialSaveOption::Unselected;
00199         }
00200         else
00201         {
00202             rootPage->NotifyUser("Unknown Checkbox state",NotifyType::ErrorMessage);
00203         }
00204     }
00205     create_task(CredentialPicker::PickAsync(credPickerOptions))
00206         .then([this](CredentialPickerResults^ credPickerResult)
00207     {
00208         SetResult(credPickerResult);
00209     });
00210
00211
00212 }
00213
00214 void ScenarioInput3::Protocol_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00215 {
00216     ComboBox^ box = (ComboBox^)sender;
00217     if (Protocol == nullptr || Protocol->SelectedItem == nullptr)
00218     {
00219         //return if this was triggered before all components are initialized
00220         return;
00221     }
00222
00223     String^ selectedProtocol = ((ComboBoxItem^)Protocol->SelectedItem)->Content->ToString();
00224
00225     if (selectedProtocol->Equals("Custom"))
00226     {
00227         CustomProtcolStackPanel->Visibility = Windows::UI::Xaml::Visibility::Visible;
00228     }
00229     else
00230     {
00231         CustomProtcolStackPanel->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00232         //Basic and Digest return plaintext passwords
00233         if (selectedProtocol->Equals("Basic"))
00234         {
00235             SetPasswordExplainVisibility(false);
00236         }
00237         else if (selectedProtocol->Equals("Digest"))
00238         {
00239             SetPasswordExplainVisibility(false);
00240         }
00241         else
00242         {
00243             SetPasswordExplainVisibility(true);
00244         }
00245     }
00246 }
00247
00248 #pragma endregion
00249
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/DirectXApp.cpp Source File

  • XAudio2 audio stream effect

DirectXApp.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXApp.h"
00010 #include "BasicTimer.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Graphics::Display;
00019
00020 DirectXApp::DirectXApp() :
00021     m_windowClosed(false),
00022     m_windowVisible(true)
00023 {
00024 }
00025
00026 void DirectXApp::Initialize(
00027     _In_ CoreApplicationView^ applicationView
00028     )
00029 {
00030     applicationView->Activated +=
00031         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DirectXApp::OnActivated);
00032
00033     CoreApplication::Suspending +=
00034         ref new EventHandler<SuspendingEventArgs^>(this, &DirectXApp::OnSuspending);
00035
00036     CoreApplication::Resuming +=
00037         ref new EventHandler<Platform::Object^>(this, &DirectXApp::OnResuming);
00038
00039     m_renderer = ref new StreamEffect();
00040 }
00041
00042 void DirectXApp::SetWindow(
00043     _In_ CoreWindow^ window
00044     )
00045 {
00046     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00047
00048     window->SizeChanged +=
00049         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DirectXApp::OnWindowSizeChanged);
00050
00051     window->VisibilityChanged +=
00052         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &DirectXApp::OnVisibilityChanged);
00053
00054     window->Closed +=
00055         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &DirectXApp::OnWindowClosed);
00056
00057     DisplayProperties::LogicalDpiChanged +=
00058         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnLogicalDpiChanged);
00059
00060     m_renderer->Initialize(window, DisplayProperties::LogicalDpi);
00061 }
00062
00063 void DirectXApp::Load(
00064     _In_ Platform::String^ entryPoint
00065     )
00066 {
00067 }
00068
00069 void DirectXApp::Run()
00070 {
00071     BasicTimer^ timer = ref new BasicTimer();
00072
00073     while (!m_windowClosed)
00074     {
00075         if (m_windowVisible)
00076         {
00077             timer->Update();
00078             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00079             m_renderer->Update(timer->Total, timer->Delta);
00080             m_renderer->Render();
00081             m_renderer->Present(); // This call is synchronized to the display frame rate.
00082         }
00083         else
00084         {
00085             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00086         }
00087     }
00088 }
00089
00090 void DirectXApp::Uninitialize()
00091 {
00092 }
00093
00094 void DirectXApp::OnWindowSizeChanged(
00095     _In_ CoreWindow^ sender,
00096     _In_ WindowSizeChangedEventArgs^ args
00097     )
00098 {
00099     m_renderer->UpdateForWindowSizeChange();
00100 }
00101
00102 void DirectXApp::OnVisibilityChanged(
00103     _In_ CoreWindow^ sender,
00104     _In_ VisibilityChangedEventArgs^ args
00105     )
00106 {
00107     m_windowVisible = args->Visible;
00108 }
00109
00110 void DirectXApp::OnWindowClosed(
00111     _In_ CoreWindow^ sender,
00112     _In_ CoreWindowEventArgs^ args
00113     )
00114 {
00115     m_windowClosed = true;
00116 }
00117
00118 void DirectXApp::OnLogicalDpiChanged(
00119     _In_ Platform::Object^ sender
00120     )
00121 {
00122     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00123 }
00124
00125 void DirectXApp::OnActivated(
00126     _In_ CoreApplicationView^ applicationView,
00127     _In_ IActivatedEventArgs^ args
00128     )
00129 {
00130     CoreWindow::GetForCurrentThread()->Activate();
00131 }
00132
00133 void DirectXApp::OnSuspending(
00134     _In_ Platform::Object^,
00135     _In_ SuspendingEventArgs^
00136     )
00137 {
00138     m_renderer->OnSuspending();
00139 }
00140
00141 void DirectXApp::OnResuming(
00142     _In_ Platform::Object^,
00143     _In_ Platform::Object^
00144     )
00145 {
00146     m_renderer->OnResuming();
00147 }
00148
00149 IFrameworkView^ DirectXAppSource::CreateView()
00150 {
00151     return ref new DirectXApp();
00152 }
00153
00154 [Platform::MTAThread]
00155 int main(Platform::Array<Platform::String^>^)
00156 {
00157     auto directXAppSource = ref new DirectXAppSource();
00158     CoreApplication::Run(directXAppSource);
00159     return 0;
00160 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/BasicMath.h Source File

  • Direct3D tutorial
  • Lesson2.Triangles

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/MainPage.xaml.cs Source File

  • MediaStreamSource media extension
  • C#,C++

MainPage.xaml.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using System;
00012 using Windows.UI.ViewManagement;
00013 using Windows.UI.Xaml;
00014 using Windows.UI.Xaml.Controls;
00015 using Windows.UI.Xaml.Markup;
00016 using Windows.UI.Xaml.Navigation;
00017
00018
00019 namespace SDKTemplate
00020 {
00021     /// <summary>
00022     /// An empty page that can be used on its own or navigated to within a Frame.
00023     /// </summary>
00024     public sealed partial class MainPage : SDKTemplate.Common.LayoutAwarePage
00025     {
00026         public event System.EventHandler ScenarioLoaded;
00027         public event EventHandler<MainPageSizeChangedEventArgs> MainPageResized;
00028         public bool AutoSizeInputSectionWhenSnapped = true;
00029
00030         public Windows.ApplicationModel.Activation.LaunchActivatedEventArgs LaunchArgs
00031         {
00032             get
00033             {
00034                 return ((App)App.Current).LaunchArgs;
00035             }
00036         }
00037
00038         public static MainPage Current;
00039
00040         private Frame HiddenFrame = null;
00041
00042         public MainPage()
00043         {
00044             this.InitializeComponent();
00045
00046             // This is a static public property that will allow downstream pages to get
00047             // a handle to the MainPage instance in order to call methods that are in this class.
00048             Current = this;
00049
00050             // This frame is hidden, meaning it is never shown.  It is simply used to load
00051             // each scenario page and then pluck out the input and output sections and
00052             // place them into the UserControls on the main page.
00053             HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
00054             HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
00055             ContentRoot.Children.Add(HiddenFrame);
00056
00057             // Populate the sample title from the constant in the Constants.cs file.
00058             SetFeatureName(FEATURE_NAME);
00059             Scenarios.SelectionChanged += Scenarios_SelectionChanged;
00060             SizeChanged += MainPage_SizeChanged;
00061         }
00062
00063         void MainPage_SizeChanged(object sender, SizeChangedEventArgs e)
00064         {
00065             InvalidateSize();
00066             if (MainPageResized != null)
00067             {
00068                 MainPageSizeChangedEventArgs args = new MainPageSizeChangedEventArgs();
00069                 args.ViewState = ApplicationView.Value;
00070                 MainPageResized(this, args);
00071             }
00072         }
00073
00074         /// <summary>
00075         /// Invoked when this page is about to be displayed in a Frame.
00076         /// </summary>
00077         /// <param name="e">Event data that describes how this page was reached.  The Parameter
00078         /// property is typically used to configure the page.</param>
00079         protected override void OnNavigatedTo(NavigationEventArgs e)
00080         {
00081             PopulateScenarios();
00082             InvalidateViewState();
00083         }
00084
00085         private void InvalidateSize()
00086         {
00087             // Get the window width
00088             double windowWidth = this.ActualWidth;
00089             if (windowWidth != 0.0)
00090             {
00091                 // Get the width of the ListBox.
00092                 double listBoxWidth = Scenarios.ActualWidth;
00093
00094                 // Is the ListBox using any margins that we need to consider?
00095                 double listBoxMarginLeft = Scenarios.Margin.Left;
00096                 double listBoxMarginRight = Scenarios.Margin.Right;
00097
00098                 // Figure out how much room is left after considering the list box width
00099                 double availableWidth = windowWidth - listBoxWidth;
00100
00101                 // Is the top most child using margins?
00102                 double layoutRootMarginLeft = ContentRoot.Margin.Left;
00103                 double layoutRootMarginRight = ContentRoot.Margin.Right;
00104
00105                 // We have different widths to use depending on the view state
00106                 if (ApplicationView.Value != ApplicationViewState.Snapped)
00107                 {
00108                     // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00109                     // and the LayoutRoot's margins
00110                     InputSection.Width = availableWidth - (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
00111                 }
00112                 else
00113                 {
00114                     // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00115                     if (AutoSizeInputSectionWhenSnapped)
00116                     {
00117                         InputSection.Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
00118                     }
00119                 }
00120             }
00121             InvalidateViewState();
00122         }
00123
00124         private void InvalidateViewState()
00125         {
00126             if (ApplicationView.Value == ApplicationViewState.Snapped)
00127             {
00128                 Grid.SetRow(DescriptionText, 3);
00129                 Grid.SetColumn(DescriptionText, 0);
00130
00131                 Grid.SetRow(InputSection, 4);
00132                 Grid.SetColumn(InputSection, 0);
00133
00134                 Grid.SetRow(FooterPanel, 2);
00135                 Grid.SetColumn(FooterPanel, 0);
00136             }
00137             else
00138             {
00139                 Grid.SetRow(DescriptionText, 1);
00140                 Grid.SetColumn(DescriptionText, 1);
00141
00142                 Grid.SetRow(InputSection, 2);
00143                 Grid.SetColumn(InputSection, 1);
00144
00145                 Grid.SetRow(FooterPanel, 1);
00146                 Grid.SetColumn(FooterPanel, 1);
00147             }
00148
00149             // Since we don't load the scenario page in the traditional manner (we just pluck out the
00150             // input and output sections from the page) we need to ensure that any VSM code used
00151             // by the scenario's input and output sections is fired.
00152             VisualStateManager.GoToState((Control)InputSection, "Input" + ApplicationView.Value.ToString(), false);
00153             VisualStateManager.GoToState((Control)OutputSection, "Output" + ApplicationView.Value.ToString(), false);
00154         }
00155
00156         private void PopulateScenarios()
00157         {
00158             System.Collections.ObjectModel.ObservableCollection<object> ScenarioList = new System.Collections.ObjectModel.ObservableCollection<object>();
00159             int i = 0;
00160
00161             // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00162             foreach (Scenario s in scenarios)
00163             {
00164                 ListBoxItem item = new ListBoxItem();
00165                 s.Title = (++i).ToString() + ") " + s.Title;
00166                 item.Content = s;
00167                 item.Name = s.ClassType.FullName;
00168                 ScenarioList.Add(item);
00169             }
00170
00171             // Bind the ListBox to the scenario list.
00172             Scenarios.ItemsSource = ScenarioList;
00173
00174             // Starting scenario is the first or based upon a previous selection.
00175             int startingScenarioIndex = -1;
00176
00177             if (SuspensionManager.SessionState.ContainsKey("SelectedScenarioIndex"))
00178             {
00179                 int selectedScenarioIndex = Convert.ToInt32(SuspensionManager.SessionState["SelectedScenarioIndex"]);
00180                 startingScenarioIndex = selectedScenarioIndex;
00181             }
00182             Scenarios.SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00183             Scenarios.ScrollIntoView(Scenarios.SelectedItem);
00184         }
00185
00186         /// <summary>
00187         /// This method is responsible for loading the individual input and output sections for each scenario.  This
00188         /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00189         /// and output sections into the respective UserControl on the main page.
00190         /// </summary>
00191         /// <param name="scenarioName"></param>
00192         public void LoadScenario(Type scenarioClass)
00193         {
00194             AutoSizeInputSectionWhenSnapped = true;
00195
00196             // Load the ScenarioX.xaml file into the Frame.
00197             HiddenFrame.Navigate(scenarioClass, this);
00198
00199             // Get the top element, the Page, so we can look up the elements
00200             // that represent the input and output sections of the ScenarioX file.
00201             Page hiddenPage = HiddenFrame.Content as Page;
00202
00203             // Get each element.
00204             UIElement input = hiddenPage.FindName("Input") as UIElement;
00205             UIElement output = hiddenPage.FindName("Output") as UIElement;
00206
00207             if (input == null)
00208             {
00209                 // Malformed input section.
00210                 NotifyUser(String.Format(
00211                     "Cannot load scenario input section for {0}.  Make sure root of input section markup has x:Name of 'Input'",
00212                     scenarioClass.Name), NotifyType.ErrorMessage);
00213                 return;
00214             }
00215
00216             if (output == null)
00217             {
00218                 // Malformed output section.
00219                 NotifyUser(String.Format(
00220                     "Cannot load scenario output section for {0}.  Make sure root of output section markup has x:Name of 'Output'",
00221                     scenarioClass.Name), NotifyType.ErrorMessage);
00222                 return;
00223             }
00224
00225             // Find the LayoutRoot which parents the input and output sections in the main page.
00226             Panel panel = hiddenPage.FindName("LayoutRoot") as Panel;
00227
00228             if (panel != null)
00229             {
00230                 // Get rid of the content that is currently in the intput and output sections.
00231                 panel.Children.Remove(input);
00232                 panel.Children.Remove(output);
00233
00234                 // Populate the input and output sections with the newly loaded content.
00235                 InputSection.Content = input;
00236                 OutputSection.Content = output;
00237             }
00238             else
00239             {
00240                 // Malformed Scenario file.
00241                 NotifyUser(String.Format(
00242                     "Cannot load scenario: '{0}'.  Make sure root tag in the '{0}' file has an x:Name of 'LayoutRoot'",
00243                     scenarioClass.Name), NotifyType.ErrorMessage);
00244             }
00245         }
00246
00247         void Scenarios_SelectionChanged(object sender, SelectionChangedEventArgs e)
00248         {
00249             if (Scenarios.SelectedItem != null)
00250             {
00251                 NotifyUser("", NotifyType.StatusMessage);
00252
00253                 ListBoxItem selectedListBoxItem = Scenarios.SelectedItem as ListBoxItem;
00254                 SuspensionManager.SessionState["SelectedScenarioIndex"] = Scenarios.SelectedIndex;
00255
00256                 Scenario scenario = selectedListBoxItem.Content as Scenario;
00257                 LoadScenario(scenario.ClassType);
00258                 InvalidateSize();
00259
00260                 // Fire the ScenarioLoaded event since we know that everything is loaded now.
00261                 if (ScenarioLoaded != null)
00262                 {
00263                     ScenarioLoaded(this, new EventArgs());
00264                 }
00265             }
00266         }
00267
00268         public void NotifyUser(string strMessage, NotifyType type)
00269         {
00270             switch (type)
00271             {
00272                 // Use the status message style.
00273                 case NotifyType.StatusMessage:
00274                     StatusBlock.Style = Resources["StatusStyle"] as Style;
00275                     break;
00276                 // Use the error message style.
00277                 case NotifyType.ErrorMessage:
00278                     StatusBlock.Style = Resources["ErrorStyle"] as Style;
00279                     break;
00280             }
00281             StatusBlock.Text = strMessage;
00282
00283             // Collapse the StatusBlock if it has no text to conserve real estate.
00284             if (StatusBlock.Text != String.Empty)
00285             {
00286                 StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Visible;
00287             }
00288             else
00289             {
00290                 StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
00291             }
00292         }
00293
00294         async void Footer_Click(object sender, RoutedEventArgs e)
00295         {
00296             await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
00297         }
00298
00299         private void SetFeatureName(string str)
00300         {
00301             FeatureName.Text = str;
00302         }
00303     }
00304
00305     public class MainPageSizeChangedEventArgs : EventArgs
00306     {
00307         private ApplicationViewState viewState;
00308
00309         public ApplicationViewState ViewState
00310         {
00311             get { return viewState; }
00312             set { viewState = value; }
00313         }
00314     }
00315
00316     public enum NotifyType
00317     {
00318         StatusMessage,
00319         ErrorMessage
00320     };
00321 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Scenario2.xaml.cpp Source File

  • XAML high contrast style

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::HighContrast;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario2::Scenario2()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040 }
00041
00042
00043 void SDKSample::HighContrast::Scenario2::DoSomething_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00044 {
00045     Button^ b = safe_cast<Button^>(sender);
00046     if (b != nullptr)
00047     {
00048         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/pch.h Source File

  • App tiles and badges
  • C#,C++

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/pch.h Source File

  • Direct2D animated text

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <d2d1_1.h>
00011 #include <d3d11_1.h>
00012 #include <dwrite_1.h>
00013 #include <wincodec.h>
00014 #include <wrl.h>
00015 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/SampleBackgroundTask.xaml.h Source File

  • Background task
  • BackgroundTask

SampleBackgroundTask.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SampleBackgroundTask.xaml.h
00013 // Declaration of the SampleBackgroundTask class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SampleBackgroundTask.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace BackgroundTask
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class SampleBackgroundTask sealed
00031         {
00032         public:
00033             SampleBackgroundTask();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039
00040             void AttachProgressAndCompletedHandlers(Windows::ApplicationModel::Background::IBackgroundTaskRegistration^ task);
00041             void RegisterBackgroundTask(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042             void UnregisterBackgroundTask(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void UpdateUI();
00044         };
00045     }
00046 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/DirectXBase.cpp Source File

  • Direct2D effects on primitives

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicLoader.h Source File

  • DirectX marble maze game

BasicLoader.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicReaderWriter.h"
00011
00012 // A simple loader class that provides support for loading shaders, textures,
00013 // and meshes from files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicLoader
00015 {
00016 internal:
00017     BasicLoader(
00018         _In_ ID3D11Device* d3dDevice,
00019         _In_opt_ IWICImagingFactory2* wicFactory = nullptr
00020         );
00021
00022     void LoadTexture(
00023         _In_ Platform::String^ filename,
00024         _Out_opt_ ID3D11Texture2D** texture,
00025         _Out_opt_ ID3D11ShaderResourceView** textureView
00026         );
00027
00028     concurrency::task<void> LoadTextureAsync(
00029         _In_ Platform::String^ filename,
00030         _Out_opt_ ID3D11Texture2D** texture,
00031         _Out_opt_ ID3D11ShaderResourceView** textureView
00032         );
00033
00034     void LoadShader(
00035         _In_ Platform::String^ filename,
00036         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00037         _In_ uint32 layoutDescNumElements,
00038         _Out_ ID3D11VertexShader** shader,
00039         _Out_opt_ ID3D11InputLayout** layout
00040         );
00041
00042     concurrency::task<void> LoadShaderAsync(
00043         _In_ Platform::String^ filename,
00044         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00045         _In_ uint32 layoutDescNumElements,
00046         _Out_ ID3D11VertexShader** shader,
00047         _Out_opt_ ID3D11InputLayout** layout
00048         );
00049
00050     void LoadShader(
00051         _In_ Platform::String^ filename,
00052         _Out_ ID3D11PixelShader** shader
00053         );
00054
00055     concurrency::task<void> LoadShaderAsync(
00056         _In_ Platform::String^ filename,
00057         _Out_ ID3D11PixelShader** shader
00058         );
00059
00060     void LoadShader(
00061         _In_ Platform::String^ filename,
00062         _Out_ ID3D11ComputeShader** shader
00063         );
00064
00065     concurrency::task<void> LoadShaderAsync(
00066         _In_ Platform::String^ filename,
00067         _Out_ ID3D11ComputeShader** shader
00068         );
00069
00070     void LoadShader(
00071         _In_ Platform::String^ filename,
00072         _Out_ ID3D11GeometryShader** shader
00073         );
00074
00075     concurrency::task<void> LoadShaderAsync(
00076         _In_ Platform::String^ filename,
00077         _Out_ ID3D11GeometryShader** shader
00078         );
00079
00080     void LoadShader(
00081         _In_ Platform::String^ filename,
00082         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00083         _In_ uint32 numEntries,
00084         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00085         _In_ uint32 numStrides,
00086         _In_ uint32 rasterizedStream,
00087         _Out_ ID3D11GeometryShader** shader
00088         );
00089
00090     concurrency::task<void> LoadShaderAsync(
00091         _In_ Platform::String^ filename,
00092         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00093         _In_ uint32 numEntries,
00094         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00095         _In_ uint32 numStrides,
00096         _In_ uint32 rasterizedStream,
00097         _Out_ ID3D11GeometryShader** shader
00098         );
00099
00100     void LoadShader(
00101         _In_ Platform::String^ filename,
00102         _Out_ ID3D11HullShader** shader
00103         );
00104
00105     concurrency::task<void> LoadShaderAsync(
00106         _In_ Platform::String^ filename,
00107         _Out_ ID3D11HullShader** shader
00108         );
00109
00110     void LoadShader(
00111         _In_ Platform::String^ filename,
00112         _Out_ ID3D11DomainShader** shader
00113         );
00114
00115     concurrency::task<void> LoadShaderAsync(
00116         _In_ Platform::String^ filename,
00117         _Out_ ID3D11DomainShader** shader
00118         );
00119
00120     void LoadMesh(
00121         _In_ Platform::String^ filename,
00122         _Out_ ID3D11Buffer** vertexBuffer,
00123         _Out_ ID3D11Buffer** indexBuffer,
00124         _Out_opt_ uint32* vertexCount,
00125         _Out_opt_ uint32* indexCount
00126         );
00127
00128     concurrency::task<void> LoadMeshAsync(
00129         _In_ Platform::String^ filename,
00130         _Out_ ID3D11Buffer** vertexBuffer,
00131         _Out_ ID3D11Buffer** indexBuffer,
00132         _Out_opt_ uint32* vertexCount,
00133         _Out_opt_ uint32* indexCount
00134         );
00135
00136 private:
00137     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00138     Microsoft::WRL::ComPtr<IWICImagingFactory2> m_wicFactory;
00139     BasicReaderWriter^ m_basicReaderWriter;
00140
00141     template <class DeviceChildType>
00142     inline void SetDebugName(
00143         _In_ DeviceChildType* object,
00144         _In_ Platform::String^ name
00145         );
00146
00147     Platform::String^ GetExtension(
00148         _In_ Platform::String^ filename
00149         );
00150
00151     void CreateTexture(
00152         _In_ bool decodeAsDDS,
00153         _In_reads_bytes_(dataSize) byte* data,
00154         _In_ uint32 dataSize,
00155         _Out_opt_ ID3D11Texture2D** texture,
00156         _Out_opt_ ID3D11ShaderResourceView** textureView,
00157         _In_opt_ Platform::String^ debugName
00158         );
00159
00160     void CreateInputLayout(
00161         _In_reads_bytes_(bytecodeSize) byte* bytecode,
00162         _In_ uint32 bytecodeSize,
00163         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00164         _In_ uint32 layoutDescNumElements,
00165         _Out_ ID3D11InputLayout** layout
00166         );
00167
00168     void CreateMesh(
00169         _In_ byte* meshData,
00170         _Out_ ID3D11Buffer** vertexBuffer,
00171         _Out_ ID3D11Buffer** indexBuffer,
00172         _Out_opt_ uint32* vertexCount,
00173         _Out_opt_ uint32* indexCount,
00174         _In_opt_ Platform::String^ debugName
00175         );
00176 };
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/MainPage.xaml.h Source File

  • Programmatic file search

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/App.xaml.h Source File

  • Calendar details and math

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Scenario1.xaml.cpp Source File

  • Folder enumeration

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::FolderEnumeration;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Foundation::Collections;
00024 using namespace Windows::Storage;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 Scenario1::Scenario1()
00030 {
00031     InitializeComponent();
00032     GetFilesAndFolderButton->Click += ref new RoutedEventHandler(this, &Scenario1::GetFilesAndFolderButton_Click);
00033 }
00034
00035 void Scenario1::GetFilesAndFolderButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00036 {
00037     OutputTextBlock->Text = "";
00038
00039     create_task(KnownFolders::PicturesLibrary->GetFoldersAsync()).then([this](IVectorView<StorageFolder^>^ folders)
00040     {
00041         create_task(KnownFolders::PicturesLibrary->GetFilesAsync()).then([this, folders](IVectorView<StorageFile^>^ files)
00042         {
00043             auto count = folders->Size + files->Size;
00044             String^ outputText = ref new String();
00045             outputText = KnownFolders::PicturesLibrary->Name + " (" + count.ToString() + ")\n\n";
00046             std::for_each(begin(folders), end(folders), [this, &outputText](StorageFolder^ folder)
00047             {
00048                 outputText += "    " + folder->DisplayName + "\\\n";
00049             });
00050             std::for_each(begin(files), end(files), [this, &outputText](StorageFile^ file)
00051             {
00052                 outputText += "    " + file->Name + "\n";
00053             });
00054             OutputTextBlock->Text = outputText;
00055         });
00056     });
00057 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario3.xaml.cpp Source File

  • XAML vector-based drawing

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::Drawing;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Media;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 Scenario3::Scenario3()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 // Invoked when this page is about to be displayed in a Frame.
00035 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040
00041   // Set color selections
00042   Color1Selection->SelectedIndex = 0;
00043   Color2Selection->SelectedIndex = 1;
00044   Color3Selection->SelectedIndex = 2;
00045
00046   Color1OffsetSelection->Value = Color1OffsetSelection->Minimum;
00047   Color2OffsetSelection->Value = (Color2OffsetSelection->Maximum - Color2OffsetSelection->Minimum) / 2;
00048   Color3OffsetSelection->Value = Color3OffsetSelection->Maximum;
00049 }
00050
00051 // Any time a slider or combobox is changed in the description of scenario 3
00052 // an associated event handler calls the LoadGradient function.
00053
00054 // Handler for color selection changed
00055 void SDKSample::Drawing::Scenario3::ColorSelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs e)
00056 {
00057   LoadGradient();
00058 }
00059
00060 // Hanlder for color offset slider
00061 void SDKSample::Drawing::Scenario3::ColorOffsetValueChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs e)
00062 {
00063   LoadGradient();
00064 }
00065
00066 // Load the gradient
00067 void SDKSample::Drawing::Scenario3::LoadGradient()
00068 {
00069   auto Gradient = ref new LinearGradientBrush();
00070   Point p;
00071   // Set start point
00072   p.X = 0;
00073   p.Y = 0;
00074   Gradient->StartPoint = p;
00075
00076   // Set end point
00077   p.X = 1;
00078   p.Y = 1;
00079   Gradient->EndPoint = p;
00080
00081   // Set up Color1
00082   auto Color1 = ref new GradientStop();
00083   Color1->Color = rootPage->ConvertIndexToColor(Color1Selection->SelectedIndex);
00084   Color1->Offset = Color1OffsetSelection->Value / 100.0;
00085
00086   // Set up Color2
00087   auto Color2 = ref new GradientStop();
00088   Color2->Color = rootPage->ConvertIndexToColor(Color2Selection->SelectedIndex);
00089   Color2->Offset = Color2OffsetSelection->Value / 100.0;
00090
00091   // Set up Color3
00092   auto Color3 = ref new GradientStop();
00093   Color3->Color = rootPage->ConvertIndexToColor(Color3Selection->SelectedIndex);
00094   Color3->Offset = Color3OffsetSelection->Value / 100.0;
00095
00096   // Apply gradient
00097   Gradient->GradientStops->Append(Color1);
00098   Gradient->GradientStops->Append(Color2);
00099   Gradient->GradientStops->Append(Color3);
00100   Scenario3Rectangle->Fill = Gradient;
00101 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/SoundEffect.h Source File

  • DirectX 3D shooting game

SoundEffect.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // SoundEffect:
00011 // This class plays a sound using XAudio2.  It uses a mastering voice provided
00012 // from the Audio class.  The sound data can be read from disk using the MediaReader
00013 // class.
00014
00015 ref class SoundEffect
00016 {
00017 internal:
00018     SoundEffect();
00019
00020     void Initialize(
00021         _In_ IXAudio2*              masteringEngine,
00022         _In_ WAVEFORMATEX*          sourceFormat,
00023         _In_ Platform::Array<byte>^ soundData
00024         );
00025
00026     void PlaySound(_In_ float volume);
00027
00028 protected private:
00029     bool                    m_audioAvailable;
00030     IXAudio2SourceVoice*    m_sourceVoice;
00031     Platform::Array<byte>^  m_soundData;
00032 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/PeerFinderScenario.xaml.cpp Source File

  • Proximity

PeerFinderScenario.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PeerFinderScenario.xaml.cpp
00013 // Implementation of the PeerFinderScenario class
00014 //
00015
00016
00017
00018 #include "pch.h"
00019 #include "PeerFinderScenario.xaml.h"
00020
00021 using namespace ProximityCPP;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Data;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::UI::Core;
00027 using namespace Windows::UI::ViewManagement;
00028 using namespace Windows::System;
00029 using namespace Windows::Foundation;
00030 using namespace Windows::Foundation::Collections;
00031 using namespace Windows::Networking::Proximity;
00032 using namespace Windows::Networking::Sockets;
00033 using namespace Windows::Storage::Streams;
00034 using namespace Platform;
00035
00036
00037 PeerFinderScenario::PeerFinderScenario()
00038 {
00039     InitializeComponent();
00040     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00041     // as NotifyUser()
00042     m_rootPage = MainPage::Current;
00043
00044     m_triggeredConnectSupported = (PeerFinder::SupportedDiscoveryTypes & PeerDiscoveryTypes::Triggered) ==
00045         PeerDiscoveryTypes::Triggered;
00046     m_browseConnectSupported = (PeerFinder::SupportedDiscoveryTypes & PeerDiscoveryTypes::Browse) ==
00047         PeerDiscoveryTypes::Browse;
00048
00049     //connection states
00050     m_ConnectStateArray = ref new Platform::Collections::Vector<String^>();
00051     m_ConnectStateArray->InsertAt((int)TriggeredConnectState::PeerFound, "PeerFound");
00052     m_ConnectStateArray->InsertAt((int)TriggeredConnectState::Listening, "Listening");
00053     m_ConnectStateArray->InsertAt((int)TriggeredConnectState::Connecting, "Connecting");
00054     m_ConnectStateArray->InsertAt((int)TriggeredConnectState::Completed, "Completed");
00055     m_ConnectStateArray->InsertAt((int)TriggeredConnectState::Canceled, "Canceled");
00056     m_ConnectStateArray->InsertAt((int)TriggeredConnectState::Failed, "Failed");
00057
00058     if (m_triggeredConnectSupported || m_browseConnectSupported)
00059     {
00060         PeerFinder_StartFindingPeersButton->Click += ref new RoutedEventHandler(this, &PeerFinderScenario::PeerFinder_StartFindingPeers);
00061         PeerFinder_BrowsePeersButton->Click += ref new RoutedEventHandler(this, &PeerFinderScenario::PeerFinder_BrowsePeers);
00062         PeerFinder_ConnectButton->Click += ref new RoutedEventHandler(this, &PeerFinderScenario::PeerFinder_Connect);
00063         PeerFinder_AcceptButton->Click += ref new RoutedEventHandler(this, &PeerFinderScenario::PeerFinder_Accept);
00064         PeerFinder_SendButton->Click += ref new RoutedEventHandler(this, &PeerFinderScenario::PeerFinder_Send);
00065         PeerFinder_StartFindingPeersButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00066     }
00067 }
00068
00069 /// <summary>
00070 /// Invoked when this page is about to be displayed in a Frame.
00071 /// </summary>
00072 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00073 /// property is typically used to configure the page.</param>
00074 void PeerFinderScenario::OnNavigatedTo(NavigationEventArgs^ e)
00075 {
00076     if (m_triggeredConnectSupported || m_browseConnectSupported)
00077     {
00078         PeerFinder_StartFindingPeersButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00079         PeerFinder_BrowsePeersButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00080         PeerFinder_ConnectButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00081         PeerFinder_FoundPeersList->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00082         PeerFinder_SendButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00083         PeerFinder_AcceptButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00084         PeerFinder_MessageBox->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00085         PeerFinder_MessageBox->Text = "Hello World";
00086         m_rootPage->ClearLog(PeerFinderOutputText);
00087         if (m_rootPage->IsLaunchedByTap())
00088         {
00089             m_rootPage->NotifyUser("Launched by tap", NotifyType::StatusMessage);
00090             PeerFinder_StartFindingPeers(nullptr, nullptr);
00091         }
00092         else
00093         {
00094             if (!m_triggeredConnectSupported)
00095             {
00096                 m_rootPage->NotifyUser("Tap based discovery of peers not supported", NotifyType::ErrorMessage);
00097             }
00098             else if (!m_browseConnectSupported)
00099             {
00100                 m_rootPage->NotifyUser("Browsing for peers not supported", NotifyType::ErrorMessage);
00101             }
00102         }
00103     }
00104     else
00105     {
00106         m_rootPage->NotifyUser("Tap based discovery of peers not supported \nBrowsing for peers not supported", NotifyType::ErrorMessage);
00107     }
00108 }
00109
00110 void PeerFinderScenario::OnNavigatingFrom(NavigatingCancelEventArgs^ e)
00111 {
00112     m_startPeerFinderImmediately = false;
00113     if (m_peerFinderStarted)
00114     {
00115         // unregister the events when the window goes out of scope
00116         PeerFinder::TriggeredConnectionStateChanged -= m_triggerToken;
00117         PeerFinder::ConnectionRequested -= m_connectionRequestedToken;
00118         m_peerFinderStarted = false;
00119         CloseSocket();
00120         PeerFinder::Stop();
00121     }
00122 }
00123
00124 void PeerFinderScenario::ConnectionRequestedEventHandler(Object^ sender, ConnectionRequestedEventArgs^ connectionEventArgs)
00125 {
00126     m_rootPage->NotifyUser("Connection requested from peer " + connectionEventArgs->PeerInformation->DisplayName, NotifyType::StatusMessage);
00127     m_requestingPeer = connectionEventArgs->PeerInformation;
00128     PeerFinder_AcceptButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00129     PeerFinder_SendButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00130     PeerFinder_MessageBox->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00131 }
00132
00133 void PeerFinderScenario::TriggeredConnectionStateChangedEventHandler(Object^ sender, TriggeredConnectionStateChangedEventArgs^ args)
00134 {
00135     m_rootPage->LogInfo("TriggeredConnectionStateChangedEventHandler - " +
00136         m_ConnectStateArray->GetAt((int)args->State), PeerFinderOutputText);
00137
00138     if (args->State == TriggeredConnectState::PeerFound)
00139     {
00140         // Use this state to indicate to users that the tap is complete and
00141         // they can pull there devices away.
00142         m_rootPage->NotifyUser("Tap complete, socket connection starting!", NotifyType::StatusMessage);
00143     }
00144
00145     if (args->State == TriggeredConnectState::Completed)
00146     {
00147         m_rootPage->NotifyUser("Socket connect success!", NotifyType::StatusMessage);
00148         // Start using the socket that just connected.
00149         PeerFinder_StartSendReceive(args->Socket);
00150     }
00151
00152     if (args->State == TriggeredConnectState::Failed)
00153     {
00154         m_rootPage->NotifyUser("Socket connect failed!", NotifyType::ErrorMessage);
00155     }
00156 }
00157
00158 void PeerFinderScenario::PeerFinder_StartFindingPeers(Object^ sender, RoutedEventArgs^ e)
00159 {
00160     // Then start listening for proximate peers
00161     m_rootPage->NotifyUser("", NotifyType::ErrorMessage);
00162     if (m_peerFinderStarted == false)
00163     {
00164         PeerFinder::Start();
00165         m_peerFinderStarted = true;
00166         // First attach the callback handler
00167         m_triggerToken = PeerFinder::TriggeredConnectionStateChanged += ref new TypedEventHandler<Object^, TriggeredConnectionStateChangedEventArgs^>(this,
00168             &PeerFinderScenario::TriggeredConnectionStateChangedEventHandler, CallbackContext::Same);
00169         m_connectionRequestedToken = PeerFinder::ConnectionRequested += ref new TypedEventHandler<Object^, Windows::Networking::Proximity::ConnectionRequestedEventArgs^>(this,
00170             &PeerFinderScenario::ConnectionRequestedEventHandler, CallbackContext::Same);
00171         if (m_browseConnectSupported && m_triggeredConnectSupported)
00172         {
00173             PeerFinder_BrowsePeersButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00174             m_rootPage->NotifyUser("Tap another device to connect to a peer or click Browse for Peers button.", NotifyType::StatusMessage);
00175         }
00176         else if (m_triggeredConnectSupported)
00177         {
00178             m_rootPage->NotifyUser("Tap another device to connect to a peer.", NotifyType::StatusMessage);
00179         }
00180         else
00181         {
00182             PeerFinder_BrowsePeersButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00183             m_rootPage->NotifyUser("Click Browse for Peers button.", NotifyType::StatusMessage);
00184         }
00185     }
00186 }
00187
00188 void PeerFinderScenario::PeerFinder_BrowsePeers(Object^ sender, RoutedEventArgs^ e)
00189 {
00190     m_rootPage->NotifyUser("Finding Peers...", NotifyType::StatusMessage);
00191     auto op = PeerFinder::FindAllPeersAsync();
00192     concurrency::task<IVectorView<PeerInformation^>^> findAllPeersTask(op);
00193
00194     findAllPeersTask.then([this](concurrency::task<IVectorView<PeerInformation^>^> resultTask)
00195     {
00196         try
00197         {
00198             m_peerInformationList = resultTask.get();
00199             if (m_peerInformationList->Size > 0)
00200             {
00201                 PeerFinder_FoundPeersList->Items->Clear();
00202                 for (unsigned int i = 0; i < m_peerInformationList->Size; i++)
00203                 {
00204                     ListBoxItem^ item = ref new ListBoxItem();
00205                     item->Content = m_peerInformationList->GetAt(i)->DisplayName;
00206                     PeerFinder_FoundPeersList->Items->Append(item);
00207                 }
00208                 PeerFinder_ConnectButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00209                 PeerFinder_FoundPeersList->Visibility = Windows::UI::Xaml::Visibility::Visible;
00210                 m_rootPage->NotifyUser("Finding Peers Done", NotifyType::StatusMessage);
00211             }
00212             else
00213             {
00214                 m_rootPage->NotifyUser("No peers found", NotifyType::StatusMessage);
00215                 PeerFinder_ConnectButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00216                 PeerFinder_FoundPeersList->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00217             }
00218         }
00219         catch (Exception^ e)
00220         {
00221             m_rootPage->NotifyUser("Exception occurred while finding peer: " + e->Message, NotifyType::ErrorMessage);
00222         }
00223     });
00224 }
00225
00226 void PeerFinderScenario::PeerFinder_Accept(Object^ sender, RoutedEventArgs^ e)
00227 {
00228     m_rootPage->NotifyUser("Connecting to " + m_requestingPeer->DisplayName + "....", NotifyType::StatusMessage);
00229     PeerFinder_AcceptButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00230
00231     auto op = PeerFinder::ConnectAsync(m_requestingPeer);
00232     concurrency::task<StreamSocket^> connectTask(op);
00233     connectTask.then([this](concurrency::task<StreamSocket^> resultTask)
00234     {
00235         try
00236         {
00237             m_rootPage->NotifyUser("Connection succeeded", NotifyType::StatusMessage);
00238             PeerFinder_StartSendReceive(resultTask.get());
00239         }
00240         catch(Exception^ e)
00241         {
00242             m_rootPage->NotifyUser("Connection to " + m_requestingPeer->DisplayName + " failed: " + e->Message, NotifyType::ErrorMessage);
00243         }
00244     });
00245 }
00246
00247 void PeerFinderScenario::PeerFinder_Connect(Object^ sender, RoutedEventArgs^ e)
00248 {
00249     m_rootPage->NotifyUser("", NotifyType::ErrorMessage);
00250     PeerInformation^ peerToConnect = nullptr;
00251
00252     // If nothing is selected, select the first peer
00253     if (PeerFinder_FoundPeersList->SelectedIndex == -1)
00254     {
00255         peerToConnect = m_peerInformationList->GetAt(0);
00256     }
00257     else
00258     {
00259         peerToConnect = m_peerInformationList->GetAt(PeerFinder_FoundPeersList->SelectedIndex);
00260     }
00261
00262     m_rootPage->NotifyUser("Connecting to " + peerToConnect->DisplayName + "....", NotifyType::StatusMessage);
00263     auto op = PeerFinder::ConnectAsync(peerToConnect);
00264
00265     concurrency::task<StreamSocket^> connectTask(op);
00266     connectTask.then([this, peerToConnect](concurrency::task<StreamSocket^> resultTask)
00267     {
00268         try
00269         {
00270             m_rootPage->NotifyUser("Connection succeeded", NotifyType::StatusMessage);
00271             PeerFinder_StartSendReceive(resultTask.get());
00272         }
00273         catch(Exception ^e)
00274         {
00275             m_rootPage->NotifyUser("Connection to " + peerToConnect->DisplayName + " failed: " + e->Message, NotifyType::ErrorMessage);
00276         }
00277     });
00278 }
00279
00280 void PeerFinderScenario::SocketError(String^ errMessage)
00281 {
00282     m_rootPage->NotifyUser(errMessage, NotifyType::ErrorMessage);
00283     PeerFinder_StartFindingPeersButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00284     if (m_browseConnectSupported)
00285     {
00286         PeerFinder_BrowsePeersButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00287     }
00288     PeerFinder_SendButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00289     PeerFinder_MessageBox->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00290     CloseSocket();
00291 }
00292
00293 void PeerFinderScenario::CloseSocket()
00294 {
00295     if (m_socket != nullptr)
00296     {
00297         m_socketClosed = true;
00298         delete m_socket;
00299         m_socket = nullptr;
00300     }
00301
00302     if (m_dataWriter != nullptr)
00303     {
00304         delete m_dataWriter;
00305         m_dataWriter = nullptr;
00306     }
00307 }
00308
00309 void PeerFinderScenario::PeerFinder_Send(Object^ sender, RoutedEventArgs^ e)
00310 {
00311     m_rootPage->NotifyUser("", NotifyType::ErrorMessage);
00312     String^ message = PeerFinder_MessageBox->Text;
00313     PeerFinder_MessageBox->Text = ""; // clear the input now that the message is being sent.
00314     if (!m_socketClosed)
00315     {
00316         if (message->Length() > 0)
00317         {
00318             m_dataWriter->WriteUInt32(m_dataWriter->MeasureString(message));
00319             m_dataWriter->WriteString(message);
00320             concurrency::task<unsigned int> storeTask(m_dataWriter->StoreAsync());
00321             storeTask.then([this, message](concurrency::task<unsigned int> resultTask)
00322             {
00323                 try
00324                 {
00325                     unsigned int numBytesWritten = resultTask.get();
00326                     if (numBytesWritten > 0)
00327                     {
00328                         m_rootPage->NotifyUser("Sent message: " + message + ", number of bytes written: " + numBytesWritten.ToString(), NotifyType::StatusMessage);
00329                     }
00330                     else
00331                     {
00332                         SocketError("The remote side closed the socket");
00333                     }
00334                 }
00335                 catch (Exception^ e)
00336                 {
00337                     if (!m_socketClosed)
00338                     {
00339                         SocketError("Failed to send message with error: " + e->Message);
00340                     }
00341                 }
00342             });
00343         }
00344         else
00345         {
00346             m_rootPage->NotifyUser("Please type a message", NotifyType::ErrorMessage);
00347         }
00348     }
00349     else
00350     {
00351         SocketError("The remote side closed the socket");
00352     }
00353 }
00354
00355 // Start the send receive operations
00356 void PeerFinderScenario::PeerFinder_StartSendReceive(StreamSocket^ socket)
00357 {
00358     m_socket = socket;
00359     // If the scenario was switched just as the socket connection completed, just close the socket.
00360     if (!m_peerFinderStarted)
00361     {
00362         CloseSocket();
00363         return;
00364     }
00365
00366     PeerFinder_SendButton->Visibility = Windows::UI::Xaml::Visibility::Visible;
00367     PeerFinder_MessageBox->Visibility = Windows::UI::Xaml::Visibility::Visible;
00368
00369     // Hide the controls related to setting up a connection
00370     PeerFinder_ConnectButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00371     PeerFinder_AcceptButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00372     PeerFinder_FoundPeersList->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00373     PeerFinder_BrowsePeersButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00374     PeerFinder_StartFindingPeersButton->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00375     m_dataWriter = ref new DataWriter(m_socket->OutputStream);
00376     m_socketClosed = false;
00377     PeerFinder_StartReader(ref new DataReader(m_socket->InputStream));
00378 }
00379
00380 void PeerFinderScenario::PeerFinder_StartReader(DataReader^ socketReader)
00381 {
00382     concurrency::task<unsigned int> loadTask(socketReader->LoadAsync(sizeof(unsigned int)));
00383     loadTask.then([this, socketReader](concurrency::task<unsigned int> stringBytesTask)
00384     {
00385         try
00386         {
00387             unsigned int bytesRead = stringBytesTask.get();
00388             if (bytesRead > 0)
00389             {
00390                 unsigned int strLength = (unsigned int)socketReader->ReadUInt32();
00391                 concurrency::task<unsigned int> loadStringTask(socketReader->LoadAsync(strLength));
00392                 loadStringTask.then([this, strLength, socketReader](concurrency::task<unsigned int> resultTask)
00393                 {
00394                     try
00395                     {
00396                         unsigned int bytesRead = resultTask.get();
00397                         if (bytesRead > 0)
00398                         {
00399                             String^ message = socketReader->ReadString(strLength);
00400                             m_rootPage->NotifyUser("Got message: " + message, NotifyType::StatusMessage);
00401                             PeerFinder_StartReader(socketReader);
00402                         }
00403                         else
00404                         {
00405                             SocketError("The remote side closed the socket");
00406                             delete socketReader;
00407                         }
00408                     }
00409                     catch (Exception^ e)
00410                     {
00411                         if (!m_socketClosed)
00412                         {
00413                             SocketError("Failed to read from socket: " + e->Message);
00414                         }
00415                         delete socketReader;
00416                     }
00417                 });
00418             }
00419             else
00420             {
00421                 SocketError("The remote side closed the socket");
00422                 delete socketReader;
00423             }
00424         }
00425         catch (Exception^ e)
00426         {
00427             if (!m_socketClosed)
00428             {
00429                 SocketError("Failed to read from socket: " + e->Message);
00430             }
00431             delete socketReader;
00432         }
00433     });
00434 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Simple3DGame Member List

This is the complete list of members for Simple3DGame, including all inherited members.
__pad0__ | Simple3DGame |
BonusTime() | Simple3DGame | [inline]
BonusTime() | Simple3DGame | [inline]
ContinueGame() | Simple3DGame |
ContinueGame() | Simple3DGame |
CurrentLevel() | Simple3DGame | [inline]
CurrentLevel() | Simple3DGame | [inline]
CycleBackground() | Simple3DGame |
FinalizeLoadLevel() | Simple3DGame |
FinalizeLoadLevel() | Simple3DGame |
GameActive() | Simple3DGame | [inline]
GameActive() | Simple3DGame | [inline]
GameCamera() | Simple3DGame | [inline]
GameCamera() | Simple3DGame | [inline]
HighScore() | Simple3DGame | [inline]
HighScore() | Simple3DGame | [inline]
Initialize(_In_ MoveLookController^controller, _In_ GameRenderer^renderer) | Simple3DGame |
Initialize(_In_ MoveLookController^controller, _In_ GameRenderer^renderer) | Simple3DGame |
InitializeAmmo() | Simple3DGame | [private]
InitializeAmmo() | Simple3DGame | [private]
InitializeGameConfig() | Simple3DGame | [private]
IsActivePlay() | Simple3DGame | [inline]
IsActivePlay() | Simple3DGame | [inline]
IsTrial() | Simple3DGame | [inline]
LevelActive() | Simple3DGame | [inline]
LevelActive() | Simple3DGame | [inline]
LevelCompleted() | Simple3DGame | [inline]
LevelCompleted() | Simple3DGame | [inline]
LoadGame() | Simple3DGame |
LoadGame() | Simple3DGame |
LoadHighScore() | Simple3DGame | [private]
LoadHighScore() | Simple3DGame | [private]
LoadLevelAsync() | Simple3DGame |
LoadLevelAsync() | Simple3DGame |
LoadState() | Simple3DGame | [private]
LoadState() | Simple3DGame | [private]
m_activeBackground | Simple3DGame | [private]
m_ammo | Simple3DGame | [private]
m_ammoCount | Simple3DGame | [private]
m_ammoNext | Simple3DGame | [private]
m_audioController | Simple3DGame | [private]
m_camera | Simple3DGame | [private]
m_controller | Simple3DGame | [private]
m_currentLevel | Simple3DGame | [private]
m_gameActive | Simple3DGame | [private]
m_gameConfig | Simple3DGame | [private]
m_level | Simple3DGame | [private]
m_levelActive | Simple3DGame | [private]
m_levelBonusTime | Simple3DGame | [private]
m_levelCount | Simple3DGame | [private]
m_levelDuration | Simple3DGame | [private]
m_levelTimeRemaining | Simple3DGame | [private]
m_maxBound | Simple3DGame | [private]
m_minBound | Simple3DGame | [private]
m_objects | Simple3DGame | [private]
m_player | Simple3DGame | [private]
m_renderer | Simple3DGame | [private]
m_renderObjects | Simple3DGame | [private]
m_savedState | Simple3DGame | [private]
m_timer | Simple3DGame | [private]
m_topScore | Simple3DGame | [private]
m_totalHits | Simple3DGame | [private]
m_totalShots | Simple3DGame | [private]
OnResuming() | Simple3DGame |
OnResuming() | Simple3DGame |
OnSuspending() | Simple3DGame |
OnSuspending() | Simple3DGame |
PauseGame() | Simple3DGame |
PauseGame() | Simple3DGame |
RenderObjects() | Simple3DGame | [inline]
RenderObjects() | Simple3DGame | [inline]
RunGame() | Simple3DGame |
RunGame() | Simple3DGame |
SaveHighScore() | Simple3DGame | [private]
SaveHighScore() | Simple3DGame | [private]
SaveState() | Simple3DGame | [private]
SaveState() | Simple3DGame | [private]
SetBackground(uint32 background) | Simple3DGame |
SetCurrentLevelToSavedState() | Simple3DGame |
SetCurrentLevelToSavedState() | Simple3DGame |
StartLevel() | Simple3DGame |
StartLevel() | Simple3DGame |
TimeRemaining() | Simple3DGame | [inline]
TimeRemaining() | Simple3DGame | [inline]
TotalHits() | Simple3DGame | [inline]
TotalHits() | Simple3DGame | [inline]
TotalShots() | Simple3DGame | [inline]
TotalShots() | Simple3DGame | [inline]
UpdateDynamics() | Simple3DGame | [private]
UpdateDynamics() | Simple3DGame | [private]
UpdateGameConfig(Windows::ApplicationModel::Store::LicenseInformation^licenseInformation) | Simple3DGame |
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DDSTextureLoader.cpp Source File

  • Direct3D post-processing effects

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/D3DPostProcessing.cpp Source File

  • Direct3D post-processing effects

D3DPostProcessing.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "D3DPostProcessing.h"
00010 #include "BasicShapes.h"
00011 #include "BasicLoader.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::UI::Core;
00016
00017 D3DPostProcessing::D3DPostProcessing()
00018 {
00019 }
00020
00021 void D3DPostProcessing::HandleDeviceLost()
00022 {
00023     // Release window size-dependent resources prior to creating a new device and swap chain.
00024     m_intermediateTextureRenderTargetView = nullptr;
00025     m_intermediateTextureShaderResourceView = nullptr;
00026     m_brightPassTextureRenderTargetView = nullptr;
00027     m_brightPassTextureShaderResourceView = nullptr;
00028
00029     for (int n = 0; n < numberOfGlowTextures; n++)
00030     {
00031         m_glowTextureRenderTargetViews[n] = nullptr;
00032         m_glowTextureShaderResourceViews[n] = nullptr;
00033     }
00034
00035     DirectXBase::HandleDeviceLost();
00036 }
00037
00038 void D3DPostProcessing::CreateDeviceIndependentResources()
00039 {
00040     DirectXBase::CreateDeviceIndependentResources();
00041 }
00042
00043 void D3DPostProcessing::CreateDeviceResources()
00044 {
00045     DirectXBase::CreateDeviceResources();
00046
00047     m_sampleOverlay = ref new SampleOverlay();
00048
00049     m_sampleOverlay->Initialize(
00050         m_d2dDevice.Get(),
00051         m_d2dContext.Get(),
00052         m_wicFactory.Get(),
00053         m_dwriteFactory.Get(),
00054         "Direct3D post-processing effects sample"
00055         );
00056
00057     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00058
00059     loader->LoadShader(
00060         "SimpleVertexShader.cso",
00061         nullptr,
00062         0,
00063         &m_vertexShader,
00064         &m_inputLayout
00065         );
00066
00067     // create the vertex and index buffers for drawing the cube
00068
00069     BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());
00070
00071     shapes->CreateCube(
00072         &m_vertexBuffer,
00073         &m_indexBuffer,
00074         nullptr,
00075         &m_indexCount
00076         );
00077
00078     // Create the constant buffer for updating model and camera data
00079     CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
00080     DX::ThrowIfFailed(
00081         m_d3dDevice->CreateBuffer(
00082             &constantBufferDescription,
00083             nullptr,             // Leave the buffer uninitialized
00084             &m_constantBuffer
00085             )
00086         );
00087
00088     loader->LoadShader(
00089         "SimplePixelShader.cso",
00090         &m_pixelShader
00091         );
00092
00093     loader->LoadTexture(
00094         "texture.dds",
00095         &m_texture,
00096         &m_textureShaderResourceView
00097         );
00098
00099     // create the sampler
00100     D3D11_SAMPLER_DESC samplerDescription;
00101     samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
00102     samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
00103     samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
00104     samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
00105     samplerDescription.MipLODBias = 0.0f;
00106     samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
00107     samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
00108     samplerDescription.BorderColor[0] = 0.0f;
00109     samplerDescription.BorderColor[1] = 0.0f;
00110     samplerDescription.BorderColor[2] = 0.0f;
00111     samplerDescription.BorderColor[3] = 0.0f;
00112     samplerDescription.MinLOD = 0;      // This allows the use of all mip levels
00113     samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;
00114
00115     DX::ThrowIfFailed(
00116         m_d3dDevice->CreateSamplerState(
00117             &samplerDescription,
00118             &m_sampler)
00119         );
00120
00121     m_camera = ref new BasicCamera();
00122
00123     // Create resources for the Post Processing sample
00124     // Load the compiled Post Processing pixel shaders
00125
00126     if (m_featureLevel <= D3D_FEATURE_LEVEL_9_3)
00127     {
00128         // load pixel shader for feature level 9
00129         loader->LoadShader(
00130             "DownScaleBrightPass9.cso",
00131             &m_downScaleBrightPass9PixelShader
00132             );
00133     }
00134     else
00135     {
00136         // load pixel shader for DX10 and higher feature-level hardware
00137         loader->LoadShader(
00138             "DownScale3x3BrightPass.cso",
00139             &m_downScaleBrightPassPixelShader
00140             );
00141     }
00142
00143     loader->LoadShader(
00144         "Glow.cso",
00145         &m_glowPixelShader
00146         );
00147
00148     loader->LoadShader(
00149         "FinalPass.cso",
00150         &m_finalPassPixelShader
00151         );
00152
00153     // create the full window quad input layout
00154     D3D11_INPUT_ELEMENT_DESC quadLayout[] =
00155     {
00156         { "POSITION", 0, DXGI_FORMAT_R32G32B32A32_FLOAT, 0, 0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00157         { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT, 0, D3D11_APPEND_ALIGNED_ELEMENT, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00158     };
00159
00160     // load the compiled Quad Vertex Shader
00161
00162     loader->LoadShader(
00163         "QuadVertexShader.cso",
00164         quadLayout,
00165         2,
00166         &m_quadVertexShader,
00167         &m_quadLayout
00168         );
00169
00170     // Setup constant buffer for DX9 version of the brightness threshold pixel shader
00171     D3D11_BUFFER_DESC brightPassConstantBufferDescription;
00172     brightPassConstantBufferDescription.Usage = D3D11_USAGE_DYNAMIC;
00173     brightPassConstantBufferDescription.BindFlags = D3D11_BIND_CONSTANT_BUFFER;
00174     brightPassConstantBufferDescription.CPUAccessFlags = D3D11_CPU_ACCESS_WRITE;
00175     brightPassConstantBufferDescription.MiscFlags = 0;
00176     brightPassConstantBufferDescription.ByteWidth =
00177         (sizeof(ConstantBufferLayoutForDX9BrightPassPixelShader) + 15) & ~0xF; // round size up to multiple of 16 bytes
00178
00179     DX::ThrowIfFailed(
00180         m_d3dDevice->CreateBuffer(
00181             &brightPassConstantBufferDescription,
00182             nullptr,             // leave the buffer uninitialized
00183             &m_brightPassConstantBuffer
00184             )
00185         );
00186
00187     // Setup constant buffer for Glow Pixel Shader
00188     D3D11_BUFFER_DESC glowConstantBufferDescription;
00189     glowConstantBufferDescription.Usage = D3D11_USAGE_DYNAMIC;
00190     glowConstantBufferDescription.BindFlags = D3D11_BIND_CONSTANT_BUFFER;
00191     glowConstantBufferDescription.CPUAccessFlags = D3D11_CPU_ACCESS_WRITE;
00192     glowConstantBufferDescription.MiscFlags = 0;
00193     glowConstantBufferDescription.ByteWidth = sizeof(ConstantBufferLayoutForGlowPixelShader);
00194
00195     DX::ThrowIfFailed(
00196         m_d3dDevice->CreateBuffer(
00197             &glowConstantBufferDescription,
00198             nullptr,             // leave the buffer uninitialized
00199             &m_glowConstantBuffer
00200             )
00201         );
00202
00203     // Samplers for Post Processing
00204     samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_CLAMP;
00205     samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_CLAMP;
00206     samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_CLAMP;
00207     samplerDescription.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;
00208
00209     DX::ThrowIfFailed(
00210         m_d3dDevice->CreateSamplerState(
00211             &samplerDescription,
00212             &m_linearSampler
00213             )
00214         );
00215
00216     samplerDescription.Filter = D3D11_FILTER_MIN_MAG_MIP_POINT;
00217     DX::ThrowIfFailed(
00218         m_d3dDevice->CreateSamplerState(
00219             &samplerDescription,
00220             &m_pointSampler
00221             )
00222         );
00223
00224     // Create a quad vertex buffer for render-to-texture operations
00225     ScreenQuadVertex screenVertexQuad[4];
00226     screenVertexQuad[0].pos = float4(-1.0f, 1.0f, 0.5f, 1.0f);
00227     screenVertexQuad[0].tex = float2(0.0f, 0.0f);
00228     screenVertexQuad[1].pos = float4(1.0f, 1.0f, 0.5f, 1.0f);
00229     screenVertexQuad[1].tex = float2(1.0f, 0.0f);
00230     screenVertexQuad[2].pos = float4(-1.0f, -1.0f, 0.5f, 1.0f);
00231     screenVertexQuad[2].tex = float2(0.0f, 1.0f);
00232     screenVertexQuad[3].pos = float4(1.0f, -1.0f, 0.5f, 1.0f);
00233     screenVertexQuad[3].tex = float2(1.0f, 1.0f);
00234
00235     D3D11_BUFFER_DESC vertexBufferDescription =
00236     {
00237         4 * sizeof(ScreenQuadVertex),
00238         D3D11_USAGE_DEFAULT,
00239         D3D11_BIND_VERTEX_BUFFER,
00240         0,
00241         0
00242     };
00243
00244     D3D11_SUBRESOURCE_DATA initData;
00245     initData.pSysMem = screenVertexQuad;
00246     initData.SysMemPitch = 0;
00247     initData.SysMemSlicePitch = 0;
00248
00249     DX::ThrowIfFailed(
00250         m_d3dDevice->CreateBuffer(
00251             &vertexBufferDescription,
00252             &initData,
00253             &m_quadVertexBuffer
00254             )
00255         );
00256 }
00257
00258 void D3DPostProcessing::CreateWindowSizeDependentResources()
00259 {
00260     DirectXBase::CreateWindowSizeDependentResources();
00261
00262     // update the 3D projection matrix
00263     m_camera->SetProjectionParameters(
00264         70.0f,                                                  // use a 70-degree vertical field of view
00265         m_renderTargetSize.Width / m_renderTargetSize.Height,   // specify the aspect ratio of the window
00266         0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
00267         100.0f                                                  // specify the farthest Z-distance at which to draw vertices
00268         );
00269
00270     // save the new projection matrix to the constant buffer data struct
00271     m_camera->GetProjectionMatrix(&m_constantBufferData.projection);
00272
00273     // setup Post Processing sample-specific window size-dependent resources
00274
00275     m_intermediateRenderTargetWidth  = static_cast<unsigned int>(m_renderTargetSize.Width  * 0.6f);
00276     m_intermediateRenderTargetHeight = static_cast<unsigned int>(m_renderTargetSize.Height * 0.6f);
00277
00278     m_glowTextureWidth  = static_cast<unsigned int>(m_intermediateRenderTargetWidth  / 4.0f);
00279     m_glowTextureHeight = static_cast<unsigned int>(m_intermediateRenderTargetHeight / 4.0f);
00280
00281     // set pixel size in DX9 level brightness threshold pass constant buffer
00282
00283     D3D11_MAPPED_SUBRESOURCE mappedResource;
00284     DX::ThrowIfFailed (
00285         m_d3dContext->Map(
00286             m_brightPassConstantBuffer.Get(),
00287             0,
00288             D3D11_MAP_WRITE_DISCARD,
00289             0,
00290             &mappedResource
00291             )
00292         );
00293
00294     ConstantBufferLayoutForDX9BrightPassPixelShader* brightPassConstantBuffer =
00295         static_cast<ConstantBufferLayoutForDX9BrightPassPixelShader*>(mappedResource.pData);
00296
00297     brightPassConstantBuffer->pixelWidth  = 1.0f / m_intermediateRenderTargetWidth;
00298     brightPassConstantBuffer->pixelHeight = 1.0f / m_intermediateRenderTargetHeight;
00299
00300     m_d3dContext->Unmap(
00301         m_brightPassConstantBuffer.Get(),
00302         0
00303         );
00304
00305     // create intermediate render target for 3D cube scene
00306
00307     Microsoft::WRL::ComPtr<ID3D11Texture2D> intermediateTexture; // will recieve 3D cube scene
00308
00309     D3D11_TEXTURE2D_DESC intermediateRenderTargetDescription;
00310     ZeroMemory(&intermediateRenderTargetDescription, sizeof(D3D11_TEXTURE2D_DESC));
00311     intermediateRenderTargetDescription.ArraySize = 1;
00312     intermediateRenderTargetDescription.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
00313     intermediateRenderTargetDescription.Usage = D3D11_USAGE_DEFAULT;
00314     intermediateRenderTargetDescription.Format = DXGI_FORMAT_R8G8B8A8_UNORM;
00315     intermediateRenderTargetDescription.Width  = m_intermediateRenderTargetWidth;
00316     intermediateRenderTargetDescription.Height = m_intermediateRenderTargetHeight;
00317     intermediateRenderTargetDescription.MipLevels = 1;
00318     intermediateRenderTargetDescription.SampleDesc.Count = 1;
00319
00320     DX::ThrowIfFailed(
00321         m_d3dDevice->CreateTexture2D(
00322             &intermediateRenderTargetDescription,
00323             nullptr,
00324             &intermediateTexture
00325             )
00326         );
00327
00328     // create the render target view
00329     D3D11_RENDER_TARGET_VIEW_DESC intermediateRenderTargetViewDescription;
00330     intermediateRenderTargetViewDescription.Format = intermediateRenderTargetDescription.Format;
00331     intermediateRenderTargetViewDescription.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
00332     intermediateRenderTargetViewDescription.Texture2D.MipSlice = 0;
00333
00334     DX::ThrowIfFailed(
00335         m_d3dDevice->CreateRenderTargetView(
00336             intermediateTexture.Get(),
00337             &intermediateRenderTargetViewDescription,
00338             &m_intermediateTextureRenderTargetView
00339             )
00340         );
00341
00342     // Create the shader resource view
00343     D3D11_SHADER_RESOURCE_VIEW_DESC intermediateShaderResourceViewDescription;
00344     intermediateShaderResourceViewDescription.Format = intermediateRenderTargetDescription.Format;
00345     intermediateShaderResourceViewDescription.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
00346     intermediateShaderResourceViewDescription.Texture2D.MipLevels = 1;
00347     intermediateShaderResourceViewDescription.Texture2D.MostDetailedMip = 0;
00348
00349     DX::ThrowIfFailed(
00350         m_d3dDevice->CreateShaderResourceView(
00351             intermediateTexture.Get(),
00352             &intermediateShaderResourceViewDescription,
00353             &m_intermediateTextureShaderResourceView
00354             )
00355         );
00356
00357     // Create a descriptor for the depth/stencil buffer.
00358     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00359         DXGI_FORMAT_D24_UNORM_S8_UINT,
00360         m_intermediateRenderTargetWidth,
00361         m_intermediateRenderTargetHeight,
00362         1,
00363         1,
00364         D3D11_BIND_DEPTH_STENCIL
00365         );
00366
00367     // Allocate a 2-D surface as the depth/stencil buffer.
00368     ComPtr<ID3D11Texture2D> depthStencil;
00369     DX::ThrowIfFailed(
00370         m_d3dDevice->CreateTexture2D(
00371             &depthStencilDesc,
00372             nullptr,
00373             &depthStencil
00374             )
00375         );
00376
00377     // Create a DepthStencil view on this surface to use on bind.
00378     CD3D11_DEPTH_STENCIL_VIEW_DESC depthStencilViewDesc(D3D11_DSV_DIMENSION_TEXTURE2D);
00379     DX::ThrowIfFailed(
00380         m_d3dDevice->CreateDepthStencilView(
00381             depthStencil.Get(),
00382             &depthStencilViewDesc,
00383             &m_d3dDepthStencilView
00384             )
00385         );
00386
00387     // Create the intermediate glow effect blur textures and views
00388
00389     Microsoft::WRL::ComPtr<ID3D11Texture2D> glowTextures[numberOfGlowTextures];      // render targets for horizontal and vertical glow blur
00390
00391     // Render target description for glow effect textures
00392     D3D11_TEXTURE2D_DESC glowTextureDescription;
00393     ZeroMemory(&glowTextureDescription, sizeof(D3D11_TEXTURE2D_DESC));
00394     glowTextureDescription.ArraySize = 1;
00395     glowTextureDescription.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
00396     glowTextureDescription.Usage = D3D11_USAGE_DEFAULT;
00397     glowTextureDescription.Format = DXGI_FORMAT_R8G8B8A8_UNORM;
00398     glowTextureDescription.Width = m_glowTextureWidth;
00399     glowTextureDescription.Height = m_glowTextureHeight;
00400     glowTextureDescription.MipLevels = 1;
00401     glowTextureDescription.SampleDesc.Count = 1;
00402
00403     // Render target view description
00404     ZeroMemory(&intermediateRenderTargetViewDescription, sizeof(D3D11_RENDER_TARGET_VIEW_DESC));
00405     intermediateRenderTargetViewDescription.Format = glowTextureDescription.Format;
00406     intermediateRenderTargetViewDescription.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
00407     intermediateRenderTargetViewDescription.Texture2D.MipSlice = 0;
00408
00409     // Shader resource view description
00410     ZeroMemory(&intermediateShaderResourceViewDescription, sizeof(D3D11_SHADER_RESOURCE_VIEW_DESC));
00411     intermediateShaderResourceViewDescription.Format = glowTextureDescription.Format;
00412     intermediateShaderResourceViewDescription.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
00413     intermediateShaderResourceViewDescription.Texture2D.MipLevels = 1;
00414     intermediateShaderResourceViewDescription.Texture2D.MostDetailedMip = 0;
00415
00416     for (int i = 0; i < numberOfGlowTextures; i++)
00417     {
00418         DX::ThrowIfFailed(
00419             m_d3dDevice->CreateTexture2D(
00420                 &glowTextureDescription,
00421                 nullptr,
00422                 &(glowTextures[i])
00423                 )
00424             );
00425
00426         DX::ThrowIfFailed(
00427             m_d3dDevice->CreateRenderTargetView(
00428                 glowTextures[i].Get(),
00429                 &intermediateRenderTargetViewDescription,
00430                 &(m_glowTextureRenderTargetViews[i])
00431                 )
00432             );
00433
00434         DX::ThrowIfFailed(
00435             m_d3dDevice->CreateShaderResourceView(
00436                 glowTextures[i].Get(),
00437                 &intermediateShaderResourceViewDescription,
00438                 &(m_glowTextureShaderResourceViews[i])
00439                 )
00440             );
00441     }
00442
00443     // Create the brightness threshold pass texture and views
00444
00445     Microsoft::WRL::ComPtr<ID3D11Texture2D> brightPassTexture;    // render target for scaled down brightness threshold image
00446
00447     DX::ThrowIfFailed(
00448         m_d3dDevice->CreateTexture2D(
00449             &glowTextureDescription,
00450             nullptr,
00451             &brightPassTexture
00452             )
00453         );
00454
00455     intermediateRenderTargetViewDescription.Format = glowTextureDescription.Format;
00456     intermediateRenderTargetViewDescription.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2D;
00457     intermediateRenderTargetViewDescription.Texture2D.MipSlice = 0;
00458
00459     DX::ThrowIfFailed(
00460         m_d3dDevice->CreateRenderTargetView(
00461             brightPassTexture.Get(),
00462             &intermediateRenderTargetViewDescription,
00463             &m_brightPassTextureRenderTargetView
00464             )
00465         );
00466
00467     intermediateShaderResourceViewDescription.Format = glowTextureDescription.Format;
00468     intermediateShaderResourceViewDescription.ViewDimension = D3D11_SRV_DIMENSION_TEXTURE2D;
00469     intermediateShaderResourceViewDescription.Texture2D.MipLevels = 1;
00470     intermediateShaderResourceViewDescription.Texture2D.MostDetailedMip = 0;
00471
00472     DX::ThrowIfFailed(
00473         m_d3dDevice->CreateShaderResourceView(
00474             brightPassTexture.Get(),
00475             &intermediateShaderResourceViewDescription,
00476             &m_brightPassTextureShaderResourceView
00477             )
00478         );
00479
00480     m_sampleOverlay->UpdateForWindowSizeChange();
00481 }
00482
00483 void D3DPostProcessing::Render()
00484 {
00485     // for Post Processing sample bind intermediate render target instead of backbuffer
00486     m_d3dContext->OMSetRenderTargets(
00487         1,
00488         m_intermediateTextureRenderTargetView.GetAddressOf(),
00489         m_d3dDepthStencilView.Get()
00490         );
00491
00492     // clear both the render target and depth stencil to default values
00493     const float clearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };
00494
00495     m_d3dContext->ClearRenderTargetView(
00496         m_intermediateTextureRenderTargetView.Get(),
00497         clearColor
00498         );
00499
00500     m_d3dContext->ClearDepthStencilView(
00501         m_d3dDepthStencilView.Get(),
00502         D3D11_CLEAR_DEPTH,
00503         1.0f,
00504         0
00505         );
00506
00507     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00508
00509     // set the vertex and index buffers, and specify the way they define geometry
00510     unsigned int stride = sizeof(BasicVertex);
00511     unsigned int offset = 0;
00512
00513     m_d3dContext->IASetVertexBuffers(
00514         0,                              // starting at the first vertex buffer slot
00515         1,                              // set one vertex buffer binding
00516         m_vertexBuffer.GetAddressOf(),
00517         &stride,                        // specify the size in bytes of a single vertex
00518         &offset                         // specify the base vertex in the buffer
00519         );
00520
00521     // set the index buffer
00522     m_d3dContext->IASetIndexBuffer(
00523         m_indexBuffer.Get(),
00524         DXGI_FORMAT_R16_UINT,   // unsigned short index format
00525         0                       // specify the base index in the buffer
00526         );
00527
00528     // specify the way the vertex and index buffers define geometry
00529     m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00530
00531     // set the vertex shader stage state
00532     m_d3dContext->VSSetShader(
00533         m_vertexShader.Get(),
00534         nullptr,                // don't use shader linkage
00535         0                       // don't use shader linkage
00536         );
00537
00538     m_d3dContext->VSSetConstantBuffers(
00539         0,                              // starting at the first constant buffer slot
00540         1,                              // set one constant buffer binding
00541         m_constantBuffer.GetAddressOf()
00542         );
00543
00544     // set the pixel shader stage state
00545     m_d3dContext->PSSetShader(
00546         m_pixelShader.Get(),
00547         nullptr,                // don't use shader linkage
00548         0                       // don't use shader linkage
00549         );
00550
00551     m_d3dContext->PSSetShaderResources(
00552         0,                          // starting at the first shader resource slot
00553         1,                          // set one shader resource binding
00554         m_textureShaderResourceView.GetAddressOf()
00555         );
00556
00557     m_d3dContext->PSSetSamplers(
00558         0,                          // starting at the first sampler slot
00559         1,                          // set one sampler binding
00560         m_sampler.GetAddressOf()
00561         );
00562
00563     // Save the backbuffer viewport
00564     D3D11_VIEWPORT oldViewPort[1];
00565     unsigned int numberOfViewPorts = 1;
00566     m_d3dContext->RSGetViewports(&numberOfViewPorts, oldViewPort);
00567
00568     // Setup the viewport to match the Intermediate Render Target
00569     D3D11_VIEWPORT viewPort = {0};
00570     viewPort.Width  = static_cast<float>(m_intermediateRenderTargetWidth);
00571     viewPort.Height = static_cast<float>(m_intermediateRenderTargetHeight);
00572     viewPort.MinDepth = 0.0f;
00573     viewPort.MaxDepth = 1.0f;
00574     viewPort.TopLeftX = 0;
00575     viewPort.TopLeftY = 0;
00576     m_d3dContext->RSSetViewports(1, &viewPort);
00577
00578     // draw the cube
00579     m_d3dContext->DrawIndexed(
00580         m_indexCount,   // draw all created vertices
00581         0,              // starting with the first vertex
00582         0               // and the first index
00583         );
00584
00585     // Restore the backbuffer viewport
00586     m_d3dContext->RSSetViewports(numberOfViewPorts, oldViewPort);
00587
00588     // post processing: rendered 3D cube frame is now in the intermediate texture buffer
00589
00590     BrightPassDownFilter(); // render brightness thresholded down-sample version
00591
00592     RenderGlow();  // apply separable blur to brightness image -> glow
00593
00594     CombineGlow(); // combine 3D cube frame and glow into backbuffer
00595
00596     m_sampleOverlay->Render();
00597 }
00598
00599 void D3DPostProcessing::Update(float timeTotal, float timeDelta)
00600 {
00601     // update the model matrix based on the time
00602     m_constantBufferData.model = rotationY(-timeTotal * 60.0f);
00603
00604     // update the view matrix based on the camera position
00605     // note that for this sample, the camera position is fixed
00606     m_camera->SetViewParameters(
00607         float3(0, 1.0f, 2.0f),
00608         float3(0, 0, 0),
00609         float3(0, 1, 0));
00610
00611     m_camera->GetViewMatrix(&m_constantBufferData.view);
00612
00613     // update the constant buffer with the new data
00614     m_d3dContext->UpdateSubresource(
00615         m_constantBuffer.Get(),
00616         0,
00617         nullptr,
00618         &m_constantBufferData,
00619         0,
00620         0
00621         );
00622 }
00623
00624 void D3DPostProcessing::DrawQuad(
00625     ID3D11PixelShader* pixelShader,
00626     uint width,
00627     uint height
00628     )
00629 {
00630     // Save the old viewport
00631     D3D11_VIEWPORT oldViewPort[1];
00632     unsigned int numberOfViewPorts = 1;
00633     m_d3dContext->RSGetViewports(&numberOfViewPorts, oldViewPort);
00634
00635     // Setup the viewport to match the Render Target
00636     D3D11_VIEWPORT viewPort = {0};
00637     viewPort.Width = static_cast<float>(width);
00638     viewPort.Height = static_cast<float>(height);
00639     viewPort.MinDepth = 0.0f;
00640     viewPort.MaxDepth = 1.0f;
00641     viewPort.TopLeftX = 0;
00642     viewPort.TopLeftY = 0;
00643     m_d3dContext->RSSetViewports(1, &viewPort);
00644
00645     unsigned int strides = sizeof(ScreenQuadVertex);
00646     unsigned int offsets = 0;
00647
00648     m_d3dContext->IASetInputLayout(m_quadLayout.Get());
00649
00650     m_d3dContext->IASetVertexBuffers(
00651         0,
00652         1,
00653         m_quadVertexBuffer.GetAddressOf(),
00654         &strides,
00655         &offsets
00656         );
00657
00658     m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLESTRIP);
00659
00660     m_d3dContext->VSSetShader(
00661         m_quadVertexShader.Get(),
00662         nullptr,
00663         0
00664         );
00665
00666     m_d3dContext->PSSetShader(
00667         pixelShader,
00668         nullptr,
00669         0
00670         );
00671
00672     m_d3dContext->Draw(4, 0);  // draw all 4 vertices of the quad, starting with vertex 0
00673
00674     // Restore the Old viewport
00675     m_d3dContext->RSSetViewports(numberOfViewPorts, oldViewPort);
00676 }
00677
00678 void D3DPostProcessing::BrightPassDownFilter()
00679 {
00680     m_d3dContext->OMSetRenderTargets(
00681         1,
00682         m_brightPassTextureRenderTargetView.GetAddressOf(),
00683         nullptr
00684         );
00685
00686     m_d3dContext->PSSetShaderResources(
00687         0,
00688         1,
00689         m_intermediateTextureShaderResourceView.GetAddressOf()
00690         );
00691
00692     m_d3dContext->PSSetSamplers(
00693         0,
00694         1,
00695         m_linearSampler.GetAddressOf()
00696         );
00697
00698     if (m_featureLevel <= D3D_FEATURE_LEVEL_9_3)
00699     {
00700         // Bind constant buffer for pixel size
00701         m_d3dContext->PSSetConstantBuffers(
00702             0,
00703             1,
00704             m_brightPassConstantBuffer.GetAddressOf()
00705             );
00706
00707         // Use DX9 pixel shader on a device of DX9 feature level
00708         DrawQuad(
00709             m_downScaleBrightPass9PixelShader.Get(),
00710             m_glowTextureWidth,
00711             m_glowTextureHeight
00712             );
00713
00714         // unbind constant buffer
00715         ID3D11Buffer* nullConstantBuffers[] = {0};
00716         m_d3dContext->PSSetConstantBuffers(
00717             0,
00718             1,
00719             nullConstantBuffers
00720             );
00721
00722     }
00723     else
00724     {
00725         // use the DX10 or later pixel shader
00726         DrawQuad(
00727             m_downScaleBrightPassPixelShader.Get(),
00728             m_glowTextureWidth,
00729             m_glowTextureHeight
00730             );
00731     }
00732
00733     ID3D11ShaderResourceView* nullShaderResourceViews[] = { 0, 0 };
00734     m_d3dContext->PSSetShaderResources(0, 2, nullShaderResourceViews);
00735 }
00736
00737 float GaussianDistribution(float x, float y, float rho)
00738 {
00739     float g = 1.0f / sqrtf(2.0f * PI_F * rho * rho);
00740     g *= expf(- (x * x + y * y) / (2 * rho * rho));
00741
00742     return g;
00743 }
00744
00745 // The separable blur function uses a gaussian weighting function applied to 15 (blurKernelSpan) texels centered on the texture
00746 // coordinate currently being processed. These are applied along a row (horizontal) or column (vertical). Element blurKernelMidPoint aligns with the current texel.
00747 // Because the offsets and weights are symmetrical about the center texel, the offsets can be computed for one "side" and mirrored with
00748 // a sign change for the other "side". Similarly the weights can be computed for one "side" and copied symmetrically to the other "side".
00749
00750 void GetSampleOffsetsWeightsForBlur(
00751     DWORD textureWidthOrHeight,
00752     float textureCoordinateOffsets[blurKernelSpan],
00753     float4* colorWeights,
00754     float deviation,
00755     float multiplier
00756     )
00757 {
00758     float texelWidthOrHeight = 1.0f / static_cast<float>(textureWidthOrHeight);
00759
00760     // Fill the center texel
00761     float weight = 1.0f * GaussianDistribution(0, 0, deviation);
00762     colorWeights[blurKernelMidPoint] = float4(weight, weight, weight, 1.0f);
00763
00764     textureCoordinateOffsets[blurKernelMidPoint] = 0.0f;
00765
00766     // Fill one side
00767     for (int i = 1; i <= blurKernelMidPoint; i++)
00768     {
00769         weight = multiplier * GaussianDistribution(static_cast<float>(i), 0, deviation);
00770         textureCoordinateOffsets[blurKernelMidPoint - i] = -i * texelWidthOrHeight;
00771
00772         colorWeights[blurKernelMidPoint - i] = float4(weight, weight, weight, 1.0f);
00773     }
00774
00775     // Copy to the other side
00776     for (int i = (blurKernelMidPoint + 1); i < blurKernelSpan; i++)
00777     {
00778         colorWeights[i] = colorWeights[(blurKernelSpan - 1) - i];
00779         textureCoordinateOffsets[i] = - textureCoordinateOffsets[(blurKernelSpan - 1) - i];
00780     }
00781 }
00782
00783 // Blur using a separable convolution kernel
00784 void D3DPostProcessing::RenderGlow()
00785 {
00786     // Horizontal Blur
00787     D3D11_MAPPED_SUBRESOURCE mappedResource;
00788     DX::ThrowIfFailed (
00789         m_d3dContext->Map(
00790             m_glowConstantBuffer.Get(),
00791             0,
00792             D3D11_MAP_WRITE_DISCARD,
00793             0,
00794             &mappedResource
00795             )
00796         );
00797
00798     ConstantBufferLayoutForGlowPixelShader* glowConstantBuffer =
00799         reinterpret_cast<ConstantBufferLayoutForGlowPixelShader*>(mappedResource.pData);
00800
00801     float4* sampleOffsets = glowConstantBuffer->sampleOffsets;
00802     float4* sampleWeights = glowConstantBuffer->sampleWeights;
00803
00804     float textureCoordinateOffsets[blurKernelSpan];
00805
00806     GetSampleOffsetsWeightsForBlur(
00807         m_glowTextureWidth,
00808         textureCoordinateOffsets,
00809         sampleWeights,
00810         5.0f,
00811         1.35f
00812         );
00813
00814     for (int i = 0; i < 15; i++)
00815     {
00816         sampleOffsets[i] = float4(textureCoordinateOffsets[i], 0.0f, 0.0f, 0.0f);
00817     }
00818
00819     m_d3dContext->Unmap(
00820         m_glowConstantBuffer.Get(),
00821         0
00822         );
00823
00824     m_d3dContext->PSSetConstantBuffers(
00825         0,
00826         1,
00827         m_glowConstantBuffer.GetAddressOf()
00828         );
00829
00830     m_d3dContext->OMSetRenderTargets(
00831         1,
00832         m_glowTextureRenderTargetViews[1].GetAddressOf(),
00833         nullptr
00834         );
00835
00836     m_d3dContext->PSSetShaderResources(
00837         0,
00838         1,
00839         m_brightPassTextureShaderResourceView.GetAddressOf()
00840         );
00841
00842     m_d3dContext->PSSetSamplers(
00843         0,
00844         1,
00845         m_pointSampler.GetAddressOf()
00846         );
00847
00848     // render horizontally blurred brightness threshold image
00849     // from m_brightPassTexture to m_glowTexture[1]
00850     DrawQuad(
00851         m_glowPixelShader.Get(),
00852         m_glowTextureWidth,
00853         m_glowTextureHeight
00854         );
00855
00856     // unbind shader resource views
00857     ID3D11ShaderResourceView* nullShaderResourceViews[] = { 0, 0, 0, 0 };
00858     m_d3dContext->PSSetShaderResources(
00859         0,
00860         4,
00861         nullShaderResourceViews
00862         );
00863
00864
00865     // Vertical Blur
00866     DX::ThrowIfFailed (
00867         m_d3dContext->Map(
00868             m_glowConstantBuffer.Get(),
00869             0,
00870             D3D11_MAP_WRITE_DISCARD,
00871             0,
00872             &mappedResource
00873             )
00874         );
00875
00876     glowConstantBuffer = reinterpret_cast<ConstantBufferLayoutForGlowPixelShader*>(mappedResource.pData);
00877     sampleOffsets = glowConstantBuffer->sampleOffsets;
00878     sampleWeights = glowConstantBuffer->sampleWeights;
00879
00880     GetSampleOffsetsWeightsForBlur(
00881         m_glowTextureHeight,
00882         textureCoordinateOffsets,
00883         sampleWeights,
00884         5.0f,
00885         1.35f
00886         );
00887
00888     for (int i = 0; i < 15; i++)
00889     {
00890         sampleOffsets[i] = float4(0.0f, textureCoordinateOffsets[i], 0.0f, 0.0f);
00891     }
00892
00893     m_d3dContext->Unmap(
00894         m_glowConstantBuffer.Get(),
00895         0
00896         );
00897
00898     m_d3dContext->PSSetConstantBuffers(
00899         0,
00900         1,
00901         m_glowConstantBuffer.GetAddressOf()
00902         );
00903
00904
00905     m_d3dContext->OMSetRenderTargets(
00906         1,
00907         m_glowTextureRenderTargetViews[0].GetAddressOf(),
00908         nullptr
00909         );
00910
00911     m_d3dContext->PSSetShaderResources(
00912         0,
00913         1,
00914         m_glowTextureShaderResourceViews[1].GetAddressOf()
00915         );
00916
00917     // render vertically blurred horizontally blurred brightness threshold image
00918     // from m_glowTexture[1] to m_glowTexture[0]
00919     DrawQuad(
00920         m_glowPixelShader.Get(),
00921         m_glowTextureWidth,
00922         m_glowTextureHeight
00923         );
00924
00925     // unbind shader resource views
00926     m_d3dContext->PSSetShaderResources(
00927         0,
00928         4,
00929         nullShaderResourceViews
00930         );
00931
00932     // unbind constant buffer
00933     ID3D11Buffer* nullConstantBuffers[] = {0};
00934     m_d3dContext->PSSetConstantBuffers(
00935         0,
00936         1,
00937         nullConstantBuffers
00938         );
00939 }
00940
00941 void D3DPostProcessing::CombineGlow()
00942 {
00943     // bind the final backbuffer render target
00944     m_d3dContext->OMSetRenderTargets(
00945         1,
00946         m_d3dRenderTargetView.GetAddressOf(),                 // backbuffer Render Target View
00947         nullptr                                            // no depth stencil
00948         );
00949
00950     ID3D11ShaderResourceView* shaderResourceViews[] =
00951     {
00952         m_intermediateTextureShaderResourceView.Get(),
00953         m_glowTextureShaderResourceViews[0].Get()
00954     };
00955
00956     m_d3dContext->PSSetShaderResources(
00957         0,
00958         2,
00959         shaderResourceViews
00960         );
00961
00962     ID3D11SamplerState* samplers[] =
00963     {
00964         m_pointSampler.Get(),
00965         m_linearSampler.Get()
00966     };
00967
00968     m_d3dContext->PSSetSamplers(
00969         0,
00970         2,
00971         samplers
00972         );
00973
00974     DrawQuad(
00975         m_finalPassPixelShader.Get(),
00976         static_cast<uint>(m_renderTargetSize.Width),
00977         static_cast<uint>(m_renderTargetSize.Height)
00978         );
00979
00980     // unbind shader resource views
00981     ID3D11ShaderResourceView* nullShaderResourceViews[] = { 0, 0, 0, 0 };
00982     m_d3dContext->PSSetShaderResources(
00983         0,
00984         4,
00985         nullShaderResourceViews
00986         );
00987 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/Common/CritSec.h Source File

  • Real-time communication
  • MediaExtensions
  • Common

CritSec.h

Go to the documentation of this file.
00001 #pragma once
00002
00003 //////////////////////////////////////////////////////////////////////////
00004 //  CritSec
00005 //  Description: Wraps a critical section.
00006 //////////////////////////////////////////////////////////////////////////
00007
00008 class CritSec
00009 {
00010 public:
00011     CRITICAL_SECTION m_criticalSection;
00012 public:
00013     CritSec()
00014     {
00015         InitializeCriticalSectionEx(&m_criticalSection, 100, 0);
00016     }
00017
00018     ~CritSec()
00019     {
00020         DeleteCriticalSection(&m_criticalSection);
00021     }
00022
00023   _Acquires_lock_(m_criticalSection)
00024     void Lock()
00025     {
00026         EnterCriticalSection(&m_criticalSection);
00027     }
00028
00029   _Releases_lock_(m_criticalSection)
00030     void Unlock()
00031     {
00032         LeaveCriticalSection(&m_criticalSection);
00033     }
00034 };
00035
00036
00037 //////////////////////////////////////////////////////////////////////////
00038 //  AutoLock
00039 //  Description: Provides automatic locking and unlocking of a
00040 //               of a critical section.
00041 //
00042 //  Note: The AutoLock object must go out of scope before the CritSec.
00043 //////////////////////////////////////////////////////////////////////////
00044
00045 class AutoLock
00046 {
00047 private:
00048     CritSec *m_pCriticalSection;
00049 public:
00050   _Acquires_lock_(m_pCriticalSection)
00051     AutoLock(CritSec& crit)
00052     {
00053         m_pCriticalSection = &crit;
00054         m_pCriticalSection->Lock();
00055     }
00056
00057   _Releases_lock_(m_pCriticalSection)
00058     ~AutoLock()
00059     {
00060       m_pCriticalSection->Unlock();
00061     }
00062 };
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/pch.cpp Source File

  • XAML text display

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/BasicMath.h Source File

  • XAudio2 audio stream effect

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::ContextMenu::sealed Member List

This is the complete list of members for SDKSample::ContextMenu::sealed, including all inherited members.
AttachmentImage_RightTapped(Platform::Object^sender, Windows::UI::Xaml::Input::RightTappedRoutedEventArgs^e) | SDKSample::ContextMenu::sealed | [private]
ReadOnlyTextBox_ContextMenuOpening(Platform::Object^sender, Windows::UI::Xaml::Controls::ContextMenuEventArgs^e) | SDKSample::ContextMenu::sealed | [private]
rootPage | SDKSample::ContextMenu::sealed | [private]
Scenario1() | SDKSample::ContextMenu::sealed |
Scenario1::GetElementRect(Windows::UI::Xaml::FrameworkElement^element) | SDKSample::ContextMenu::sealed | [private]
Scenario2() | SDKSample::ContextMenu::sealed |
Scenario2::GetTextboxSelectionRect(Windows::UI::Xaml::Controls::TextBox^textbox) | SDKSample::ContextMenu::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/App.xaml.h Source File

  • Edge gesture invocation

App.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.h
00010 // Declaration of the App.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "App.g.h"
00017
00018 namespace EdgeGestureSample
00019 {
00020     ref class App sealed
00021     {
00022     public:
00023         App();
00024         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00025         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00026     };
00027 }
00028
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/sample-utils/CppSamplesUtils.h Source File

  • DatagramSocket
  • sample-utils

CppSamplesUtils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/backgroundtask/LocationBackgroundTask.cpp Source File

  • Geolocation
  • backgroundtask

LocationBackgroundTask.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 // LocationBackgroundTask.cpp
00012 #include "pch.h"
00013 #include "LocationBackgroundTask.h"
00014
00015 using namespace Concurrency;
00016 using namespace BackgroundTask;
00017 using namespace Windows::ApplicationModel::Background;
00018 using namespace Windows::Devices::Geolocation;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Globalization::DateTimeFormatting;
00021 using namespace Windows::Storage;
00022
00023 LocationBackgroundTask::LocationBackgroundTask()
00024 {
00025 }
00026
00027 LocationBackgroundTask::~LocationBackgroundTask()
00028 {
00029 }
00030
00031 void LocationBackgroundTask::Run(IBackgroundTaskInstance^ taskInstance)
00032 {
00033     // Get the deferral object from the task instance
00034     Platform::Agile<BackgroundTaskDeferral> deferral(taskInstance->GetDeferral());
00035
00036     // Associate a cancellation handler with the background task
00037     taskInstance->Canceled += ref new BackgroundTaskCanceledEventHandler(this, &LocationBackgroundTask::OnCanceled);
00038
00039     Geolocator^ geolocator = ref new Geolocator();
00040
00041     task<Geoposition^> geopositionTask(geolocator->GetGeopositionAsync(), geopositionTaskTokenSource.get_token());
00042     geopositionTask.then([this, deferral, geolocator](task<Geoposition^> getPosTask)
00043     {
00044         DateTimeFormatter^ dateFormatter = ref new DateTimeFormatter("longtime");
00045         auto settings = ApplicationData::Current->LocalSettings;
00046
00047         try
00048         {
00049             // Get will throw an exception if the task was canceled or failed with an error
00050             Geoposition^ pos = getPosTask.get();
00051
00052             // Write to LocalSettings to indicate that this background task ran
00053             settings->Values->Insert("Status", "Time: " + dateFormatter->Format(pos->Coordinate->Timestamp));
00054             settings->Values->Insert("Latitude", pos->Coordinate->Latitude.ToString());
00055             settings->Values->Insert("Longitude", pos->Coordinate->Longitude.ToString());
00056             settings->Values->Insert("Accuracy", pos->Coordinate->Accuracy.ToString());
00057         }
00058         catch (Platform::AccessDeniedException^)
00059         {
00060             // Write to LocalSettings to indicate that this background task ran
00061             settings->Values->Insert("Status", "Disabled");
00062             settings->Values->Insert("Latitude", "No data");
00063             settings->Values->Insert("Longitude", "No data");
00064             settings->Values->Insert("Accuracy", "No data");
00065         }
00066         catch (task_canceled&)
00067         {
00068         }
00069
00070         // Indicate that the background task has completed
00071         deferral->Complete();
00072     });
00073 }
00074
00075 // Handles background task cancellation
00076 void LocationBackgroundTask::OnCanceled(IBackgroundTaskInstance^ taskInstance, BackgroundTaskCancellationReason reason)
00077 {
00078     // Cancel the async operation
00079     geopositionTaskTokenSource.cancel();
00080 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Accelerometer sensor/C++/Scenario2.xaml.cpp Source File

  • Accelerometer sensor

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::AccelerometerCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Devices::Sensors;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::UI::Core;
00027 using namespace Platform;
00028
00029 Scenario2::Scenario2() : rootPage(MainPage::Current), shakeCounter(0)
00030 {
00031     InitializeComponent();
00032
00033     accelerometer = Accelerometer::GetDefault();
00034     if (accelerometer == nullptr)
00035     {
00036         rootPage->NotifyUser("No accelerometer found", NotifyType::ErrorMessage);
00037     }
00038 }
00039
00040 /// <summary>
00041 /// Invoked when this page is about to be displayed in a Frame.
00042 /// </summary>
00043 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00044 /// property is typically used to configure the page.</param>
00045 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00046 {
00047     ScenarioEnableButton->IsEnabled = true;
00048     ScenarioDisableButton->IsEnabled = false;
00049 }
00050
00051 /// <summary>
00052 /// Invoked when this page is no longer displayed.
00053 /// </summary>
00054 /// <param name="e"></param>
00055 void Scenario2::OnNavigatedFrom(NavigationEventArgs^ e)
00056 {
00057     if (ScenarioDisableButton->IsEnabled)
00058     {
00059         Window::Current->VisibilityChanged::remove(visibilityToken);
00060         accelerometer->Shaken::remove(shakenToken);
00061     }
00062 }
00063
00064 /// <summary>
00065 /// This is the event handler for VisibilityChanged events. You would register for these notifications
00066 /// if handling sensor data when the app is not visible could cause unintended actions in the app.
00067 /// </summary>
00068 /// <param name="sender"></param>
00069 /// <param name="e">
00070 /// Event data that can be examined for the current visibility state.
00071 /// </param>
00072 void Scenario2::VisibilityChanged(Object^ sender, VisibilityChangedEventArgs^ e)
00073 {
00074     // The app should watch for VisibilityChanged events to disable and re-enable sensor input as appropriate
00075     if (ScenarioDisableButton->IsEnabled)
00076     {
00077         if (e->Visible)
00078         {
00079             // Re-enable sensor input
00080             shakenToken = accelerometer->Shaken::add(ref new TypedEventHandler<Accelerometer^, AccelerometerShakenEventArgs^>(this, &Scenario2::Shaken));
00081         }
00082         else
00083         {
00084             // Disable sensor input
00085             accelerometer->Shaken::remove(shakenToken);
00086         }
00087     }
00088 }
00089
00090 void Scenario2::Shaken(Accelerometer^ sender, AccelerometerShakenEventArgs^ e)
00091 {
00092     shakeCounter++;
00093
00094     // We need to dispatch to the UI thread to display the output
00095     Dispatcher->RunAsync(
00096         CoreDispatcherPriority::Normal,
00097         ref new DispatchedHandler(
00098             [this]()
00099             {
00100                 ScenarioOutputText->Text = shakeCounter.ToString();
00101             },
00102             CallbackContext::Any
00103             )
00104         );
00105 }
00106
00107 void Scenario2::ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00108 {
00109     if (accelerometer != nullptr)
00110     {
00111         visibilityToken = Window::Current->VisibilityChanged::add(ref new WindowVisibilityChangedEventHandler(this, &Scenario2::VisibilityChanged));
00112         shakenToken = accelerometer->Shaken::add(ref new TypedEventHandler<Accelerometer^, AccelerometerShakenEventArgs^>(this, &Scenario2::Shaken));
00113
00114         ScenarioEnableButton->IsEnabled = false;
00115         ScenarioDisableButton->IsEnabled = true;
00116     }
00117     else
00118     {
00119         rootPage->NotifyUser("No accelerometer found", NotifyType::ErrorMessage);
00120     }
00121 }
00122
00123 void Scenario2::ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00124 {
00125     Window::Current->VisibilityChanged::remove(visibilityToken);
00126     accelerometer->Shaken::remove(shakenToken);
00127
00128     ScenarioEnableButton->IsEnabled = true;
00129     ScenarioDisableButton->IsEnabled = false;
00130 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/GameHud.h Source File

  • XAML DirectX 3D shooting game

GameHud.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // GameHud:
00011 // This class maintains the resources necessary to draw the Heads Up Display, which is a
00012 // 2D overlay on top of the main 3D graphics generated for the game.
00013 // The GameHud Render method expects to be called within the context of a D2D BeginDraw
00014 // and makes D2D drawing calls to draw the text elements on the window.
00015
00016 #include "Simple3DGame.h"
00017 #include "DirectXSample.h"
00018
00019 ref class Simple3DGame;
00020
00021 ref class GameHud
00022 {
00023 internal:
00024     GameHud(
00025         _In_ Platform::String^ titleHeader,
00026         _In_ Platform::String^ titleBody,
00027         _In_ Platform::String^ titleLicenseInfo
00028         );
00029
00030     void CreateDeviceIndependentResources(
00031         _In_ IDWriteFactory* dwriteFactory,
00032         _In_ IWICImagingFactory* wicFactory
00033         );
00034
00035     void CreateDeviceResources(_In_ ID2D1DeviceContext* d2dContext);
00036     void UpdateForWindowSizeChange(_In_ Windows::Foundation::Rect windowBounds);
00037     void Render(
00038         _In_ Simple3DGame^ game,
00039         _In_ ID2D1DeviceContext* d2dContext,
00040         _In_ Windows::Foundation::Rect windowBounds
00041         );
00042
00043     void SetLicenseInfo(_In_ Platform::String^ licenseInfo);
00044
00045 private:
00046     Microsoft::WRL::ComPtr<IDWriteFactory>              m_dwriteFactory;
00047     Microsoft::WRL::ComPtr<IWICImagingFactory>          m_wicFactory;
00048
00049     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>        m_textBrush;
00050     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>        m_textBrushGrey;
00051     Microsoft::WRL::ComPtr<IDWriteTextFormat>           m_textFormatBody;
00052     Microsoft::WRL::ComPtr<IDWriteTextFormat>           m_textFormatBodySymbol;
00053
00054     Microsoft::WRL::ComPtr<IDWriteTextFormat>           m_textFormatTitleHeader;
00055     Microsoft::WRL::ComPtr<IDWriteTextFormat>           m_textFormatTitleBody;
00056     Microsoft::WRL::ComPtr<IDWriteTextFormat>           m_textFormatTitleLicense;
00057     Microsoft::WRL::ComPtr<ID2D1Bitmap>                 m_logoBitmap;
00058     Microsoft::WRL::ComPtr<IDWriteTextLayout>           m_titleHeaderLayout;
00059     Microsoft::WRL::ComPtr<IDWriteTextLayout>           m_titleBodyLayout;
00060     Microsoft::WRL::ComPtr<IDWriteTextLayout>           m_titleLicenseInfoLayout;
00061
00062     bool                                                m_showTitle;
00063     Platform::String^                                   m_titleHeader;
00064     Platform::String^                                   m_titleBody;
00065     Platform::String^                                   m_titleLicenseInfo;
00066
00067     float                                               m_titleBodyVerticalOffset;
00068     float                                               m_titleLicenseVerticalOffset;
00069     D2D1_SIZE_F                                         m_logoSize;
00070     D2D1_SIZE_F                                         m_maxTitleSize;
00071 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/WorkItemScenario.xaml.cpp Source File

  • Thread pool

WorkItemScenario.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // WorkItemScenario.xaml.cpp
00013 // Implementation of the WorkItemScenario class
00014 //
00015
00016 #include "pch.h"
00017 #include "WorkItemScenario.xaml.h"
00018
00019 using namespace SDKSample::ThreadPool;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 WorkItemScenario::WorkItemScenario()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void  SDKSample::ThreadPool::WorkItemScenario::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // Get a pointer to our main page.
00040     rootPage = MainPage::Current;
00041     SDKSample::ThreadPool::WorkScenario = this;
00042   Priority->SelectedIndex = SDKSample::ThreadPool::WorkItemSelectedIndex;
00043     UpdateUI(SDKSample::ThreadPool::WorkItemStatus);
00044 }
00045
00046 void  SDKSample::ThreadPool::WorkItemScenario::OnNavigatedFrom(NavigationEventArgs^ e)
00047 {
00048   SDKSample::ThreadPool::WorkItemSelectedIndex = Priority->SelectedIndex;
00049 }
00050
00051 void  SDKSample::ThreadPool::WorkItemScenario::CreateThreadPoolWorkItem(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00052 {
00053     auto workItemDelegate = [this](IAsyncAction^ workItem)
00054     {
00055         int count = 0;
00056         int maxcount = 10000000;
00057         int oldProgress = 0;
00058
00059         while (count < maxcount)
00060         {
00061             auto status = workItem->Status;
00062             if (status == AsyncStatus::Canceled)
00063             {
00064                 break;
00065             }
00066
00067             //
00068             // Simulate doing work.
00069             //
00070
00071             count++;
00072
00073             int currentProgress = (int)(((double)count / (double)maxcount) * 100);
00074             if (currentProgress > oldProgress)
00075             {
00076                 auto uiDelegate = [this, currentProgress]()
00077                 {
00078                     SDKSample::ThreadPool::WorkScenario->UpdateWorkItemProgressUI(currentProgress);
00079                 };
00080                 auto handler = ref new Windows::UI::Core::DispatchedHandler(uiDelegate);
00081                 Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, handler);
00082             }
00083
00084             oldProgress = currentProgress;
00085         }
00086     };
00087
00088     auto completionDelegate = [this](IAsyncAction^ action, AsyncStatus status)
00089     {
00090         switch (action->Status)
00091         {
00092         case AsyncStatus::Started:
00093             SDKSample::ThreadPool::WorkScenario->UpdateUI(SDKSample::ThreadPool::Status::Started);
00094             break;
00095         case AsyncStatus::Completed:
00096             SDKSample::ThreadPool::WorkScenario->UpdateUI(SDKSample::ThreadPool::Status::Completed);
00097             break;
00098         case AsyncStatus::Canceled:
00099             SDKSample::ThreadPool::WorkScenario->UpdateUI(SDKSample::ThreadPool::Status::Canceled);
00100             break;
00101         case AsyncStatus::Error:
00102             //UpdateUI->Text = "Error";
00103             break;
00104         }
00105     };
00106
00107     auto workItemHandler = ref new Windows::System::Threading::WorkItemHandler(workItemDelegate);
00108     auto completionHandler = ref new Windows::Foundation::AsyncActionCompletedHandler(completionDelegate, Platform::CallbackContext::Same);
00109     auto priority = safe_cast<String^>(Priority->SelectionBoxItem);
00110
00111     if (priority == "Low")
00112     {
00113         SDKSample::ThreadPool::WorkItemInfo = "Work item priority = Low";
00114         SDKSample::ThreadPool::WorkPriority = Windows::System::Threading::WorkItemPriority::Low;
00115     }
00116     else if (priority == "Normal")
00117     {
00118         SDKSample::ThreadPool::WorkItemInfo = "Work item priority = Normal";
00119         SDKSample::ThreadPool::WorkPriority = Windows::System::Threading::WorkItemPriority::Normal;
00120     }
00121     else if (priority == "High")
00122     {
00123         SDKSample::ThreadPool::WorkItemInfo = "Work item priority = High";
00124         SDKSample::ThreadPool::WorkPriority = Windows::System::Threading::WorkItemPriority::High;
00125     }
00126
00127     SDKSample::ThreadPool::WorkItem = Windows::System::Threading::ThreadPool::RunAsync(workItemHandler, SDKSample::ThreadPool::WorkPriority);
00128     SDKSample::ThreadPool::WorkItem->Completed = completionHandler;
00129     UpdateUI(SDKSample::ThreadPool::Status::Started);
00130 }
00131
00132 void  SDKSample::ThreadPool::WorkItemScenario::CancelThreadPoolWorkItem(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00133 {
00134     if (SDKSample::ThreadPool::WorkItem != nullptr)
00135     {
00136         SDKSample::ThreadPool::WorkItem->Cancel();
00137     }
00138 }
00139
00140 void  SDKSample::ThreadPool::WorkItemScenario::UpdateUI(Status status)
00141 {
00142     SDKSample::ThreadPool::WorkItemStatus = status;
00143     WorkItemStatus->Text = ThreadPoolSample::GetStatusString(status);
00144     WorkItemInfo->Text = SDKSample::ThreadPool::WorkItemInfo;
00145
00146     auto createButtonEnabled = (status == SDKSample::ThreadPool::Status::Started);
00147     CreateThreadPoolWorkItemButton->IsEnabled = !createButtonEnabled;
00148     CancelThreadPoolWorkItemButton->IsEnabled = createButtonEnabled;
00149 }
00150
00151 void  SDKSample::ThreadPool::WorkItemScenario::UpdateWorkItemProgressUI(int percentComplete)
00152 {
00153     WorkItemStatus->Text = "Progress: " + percentComplete + "%";
00154 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Common/CritSec.h Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Common

CritSec.h

Go to the documentation of this file.
00001 #pragma once
00002
00003 //////////////////////////////////////////////////////////////////////////
00004 //  CritSec
00005 //  Description: Wraps a critical section.
00006 //////////////////////////////////////////////////////////////////////////
00007
00008 class CritSec
00009 {
00010 public:
00011     CRITICAL_SECTION m_criticalSection;
00012 public:
00013     CritSec()
00014     {
00015         InitializeCriticalSectionEx(&m_criticalSection, 100, 0);
00016     }
00017
00018     ~CritSec()
00019     {
00020         DeleteCriticalSection(&m_criticalSection);
00021     }
00022
00023   _Acquires_lock_(m_criticalSection)
00024     void Lock()
00025     {
00026         EnterCriticalSection(&m_criticalSection);
00027     }
00028
00029   _Releases_lock_(m_criticalSection)
00030     void Unlock()
00031     {
00032         LeaveCriticalSection(&m_criticalSection);
00033     }
00034 };
00035
00036
00037 //////////////////////////////////////////////////////////////////////////
00038 //  AutoLock
00039 //  Description: Provides automatic locking and unlocking of a
00040 //               of a critical section.
00041 //
00042 //  Note: The AutoLock object must go out of scope before the CritSec.
00043 //////////////////////////////////////////////////////////////////////////
00044
00045 class AutoLock
00046 {
00047 private:
00048     CritSec *m_pCriticalSection;
00049 public:
00050   _Acquires_lock_(m_pCriticalSection)
00051     AutoLock(CritSec& crit)
00052     {
00053         m_pCriticalSection = &crit;
00054         m_pCriticalSection->Lock();
00055     }
00056
00057   _Releases_lock_(m_pCriticalSection)
00058     ~AutoLock()
00059     {
00060       m_pCriticalSection->Unlock();
00061     }
00062 };
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWidePeekImageAndText01 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWidePeekImageAndText01, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::TileContent::TileWidePeekImageAndText01 |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBodyWrap | NotificationsExtensions::TileContent::TileWidePeekImageAndText01 |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWidePeekImageAndText01() | NotificationsExtensions::TileContent::TileWidePeekImageAndText01 | [inline]
TileWidePeekImageAndText01() | NotificationsExtensions::TileContent::TileWidePeekImageAndText01 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::NumberFormatting::sealed Member List

This is the complete list of members for SDKSample::NumberFormatting::sealed, including all inherited members.
CurrencyFormatting() | SDKSample::NumberFormatting::sealed |
DecimalFormatting() | SDKSample::NumberFormatting::sealed |
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::NumberFormatting::sealed | [private]
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::NumberFormatting::sealed | [private]
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::NumberFormatting::sealed | [private]
NumberParsing() | SDKSample::NumberFormatting::sealed |
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::NumberFormatting::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::NumberFormatting::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::NumberFormatting::sealed | [protected, virtual]
rootPage | SDKSample::NumberFormatting::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::ViewModelBase Member List

This is the complete list of members for Hilo::ViewModelBase, including all inherited members.
__pad0__ | Hilo::ViewModelBase |
GetCustomProperty(Platform::String^name) | Hilo::Common::BindableBase | [virtual]
GetIndexedProperty(Platform::String^name, Windows::UI::Xaml::Interop::TypeName type) | Hilo::Common::BindableBase | [virtual]
GetStringRepresentation() | Hilo::Common::BindableBase | [virtual]
GoHome() | Hilo::ViewModelBase | [virtual]
GoToPage(PageType page, Platform::Object^parameter) | Hilo::ViewModelBase | [virtual]
LoadState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) | Hilo::ViewModelBase | [virtual]
m_exceptionPolicy | Hilo::ViewModelBase |
m_isAppBarEnabled | Hilo::ViewModelBase |
m_isAppBarOpen | Hilo::ViewModelBase |
m_isAppBarSticky | Hilo::ViewModelBase |
NavigateBack | Hilo::ViewModelBase |
NavigateHome | Hilo::ViewModelBase |
NavigateToPage | Hilo::ViewModelBase |
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) | Hilo::ViewModelBase | [virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) | Hilo::ViewModelBase | [virtual]
PropertyChanged | Hilo::Common::BindableBase |
SaveState(Windows::Foundation::Collections::IMap< Platform::String^, Platform::Object^>^stateMap) | Hilo::ViewModelBase | [virtual]
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicShapes.h Source File

  • Direct3D-Direct2D interop

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Getting started with C++ simple blog reader/C++/pch.cpp Source File

  • Getting started with C++ simple blog reader

pch.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 //
00009 // pch.cpp
00010 // Include the standard header and generate the precompiled header.
00011 //
00012
00013 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/MainPage.xaml.cpp Source File

  • Secondary tiles
  • C#,C++

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Platform;
00026 using namespace SecondaryTiles;
00027 using namespace CppSamplesUtils;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden.  It is simply used to load
00040     // each scenario page and extract the the input and output sections and
00041     // place them into the UserControls on the main page.
00042     hiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     hiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     LayoutRoot->Children->Append(hiddenFrame);
00045
00046     // Populate the sample title constants.h
00047     SetSecondaryTiles(FEATURE_NAME);
00048
00049     this->Loaded += ref new RoutedEventHandler(this, &MainPage::MainPage_Loaded);
00050     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00051     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00052
00053     MainPage::current = this;
00054     autoSizeInputSectionWhenSnapped = true;
00055 }
00056
00057 MainPage::~MainPage()
00058 {
00059 }
00060
00061 /// <summary>
00062 /// Invoked when this page is about to be displayed in a Frame.
00063 /// </summary>
00064 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00065 /// property is typically used to configure the page.</param>
00066 void MainPage::OnNavigatedTo(NavigationEventArgs^ e)
00067 {
00068     PopulateScenarios();
00069     InvalidateViewState();
00070 }
00071
00072 void MainPage::MainPage_Loaded(Object^ sender, RoutedEventArgs^ e)
00073 {
00074     // Fire the ScenarioLoaded event so downstream pages know that the respective
00075     // scenario files have been loaded.
00076     ScenarioLoaded(this, nullptr);
00077 }
00078
00079 /// <summary>
00080 /// We need to handle SizeChanged so that we can make the sample layout property
00081 /// in the various layouts.
00082 /// </summary>
00083 /// <param name="sender"></param>
00084 /// <param name="e"></param>
00085 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00086 {
00087     InvalidateSize();
00088     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00089     args->ViewState = ApplicationView::Value;
00090     MainPageResized(this, args);
00091 }
00092
00093 void MainPage::InvalidateSize()
00094 {
00095     // Get the window width
00096     double windowWidth = this->ActualWidth;
00097     if (windowWidth != 0.0)
00098     {
00099         // Get the width of the ListBox.
00100         double listBoxWidth = Scenarios->ActualWidth;
00101
00102         // Is the ListBox using any margins that we need to consider?
00103         double listBoxMarginLeft = Scenarios->Margin.Left;
00104         double listBoxMarginRight = Scenarios->Margin.Right;
00105
00106         // Figure out how much room is left after considering the list box width
00107         double availableWidth = windowWidth - listBoxWidth;
00108
00109         // Is the top most child using margins?
00110         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00111         double layoutRootMarginRight = ContentRoot->Margin.Right;
00112
00113         // We have different widths to use depending on the view state
00114         if (ApplicationView::Value != ApplicationViewState::Snapped)
00115         {
00116             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00117             // and the LayoutRoot's margins
00118             InputSection->Width = ((availableWidth) -
00119                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00120         }
00121         else
00122         {
00123             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00124             if (autoSizeInputSectionWhenSnapped)
00125             {
00126                 InputSection->Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
00127             }
00128         }
00129     }
00130     InvalidateViewState();
00131 }
00132
00133 void MainPage::InvalidateViewState()
00134 {
00135     // Are we going to snapped mode?
00136     if (ApplicationView::Value == ApplicationViewState::Snapped)
00137     {
00138         Grid::SetRow(DescriptionText, 3);
00139         Grid::SetColumn(DescriptionText, 0);
00140
00141         Grid::SetRow(InputSection, 4);
00142         Grid::SetColumn(InputSection, 0);
00143
00144         Grid::SetRow(FooterPanel, 2);
00145         Grid::SetColumn(FooterPanel, 0);
00146     }
00147     else
00148     {
00149         Grid::SetRow(DescriptionText, 1);
00150         Grid::SetColumn(DescriptionText, 1);
00151
00152         Grid::SetRow(InputSection, 2);
00153         Grid::SetColumn(InputSection, 1);
00154
00155         Grid::SetRow(FooterPanel, 1);
00156         Grid::SetColumn(FooterPanel, 1);
00157     }
00158
00159     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00160     // input and output sections from the page) we need to ensure that any VSM code used
00161     // by the scenario's input and output sections is fired.
00162     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00163     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00164 }
00165
00166 void MainPage::PopulateScenarios()
00167 {
00168     scenarioList = ref new Platform::Collections::Vector<Object^>();
00169
00170     // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00171     for (unsigned int i = 0; i < scenarios->Length; ++i)
00172     {
00173         Scenario s = scenarios[i];
00174         ListBoxItem^ item = ref new ListBoxItem();
00175         item->Name = s.className;
00176         item->Content = (i + 1).ToString() + ") " + s.title;
00177         scenarioList->Append(item);
00178     }
00179
00180     // Bind the ListBox to the scenario list.
00181     Scenarios->ItemsSource = scenarioList;
00182
00183     // Starting scenario is the first or based upon a previous selection.
00184     int startingScenarioIndex = -1;
00185
00186     auto ps = SuspensionManager::SessionState();
00187     if (ps->HasKey("SelectedScenarioIndex"))
00188     {
00189         int selectedScenarioIndex = safe_cast<int>(ps->Lookup("SelectedScenarioIndex"));
00190         startingScenarioIndex = selectedScenarioIndex;
00191     }
00192
00193     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00194 }
00195 #pragma optimize("", on)
00196
00197 /// <summary>
00198 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00199 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00200 /// and output sections into the respective UserControl on the main page.
00201 /// </summary>
00202 /// <param name="scenarioName"></param>
00203 void MainPage::LoadScenario(String^ scenarioName)
00204 {
00205     // Load the ScenarioX.xaml file into the Frame.
00206     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00207     hiddenFrame->Navigate(scenarioType, this);
00208
00209     // Get the top element, the Page, so we can look up the elements
00210     // that represent the input and output sections of the ScenarioX file.
00211     Page^ hiddenPage = safe_cast<Page^>(hiddenFrame->Content);
00212
00213     // Get each element.
00214     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00215     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00216
00217     if (input == nullptr)
00218     {
00219         // Malformed input section.
00220         NotifyUser("Cannot load scenario input section for " + scenarioName +
00221             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00222         return;
00223     }
00224
00225     if (output == nullptr)
00226     {
00227         // Malformed output section.
00228         NotifyUser("Cannot load scenario output section for " + scenarioName +
00229             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00230         return;
00231     }
00232
00233     // Find the LayoutRoot which parents the input and output sections in the main page.
00234     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00235
00236     if (panel != nullptr)
00237     {
00238         unsigned int index = 0;
00239         UIElementCollection^ collection = panel->Children;
00240
00241         // Get rid of the content that is currently in the intput and output sections.
00242         collection->IndexOf(input, &index);
00243         collection->RemoveAt(index);
00244
00245         collection->IndexOf(output, &index);
00246         collection->RemoveAt(index);
00247
00248         // Populate the input and output sections with the newly loaded content.
00249         InputSection->Content = input;
00250         OutputSection->Content = output;
00251
00252         ScenarioLoaded(this, nullptr);
00253     }
00254     else
00255     {
00256         // Malformed Scenario file.
00257         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00258             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00259     }
00260 }
00261
00262 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00263 {
00264     if (Scenarios->SelectedItem != nullptr)
00265     {
00266         NotifyUser("", NotifyType::StatusMessage);
00267
00268         int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00269         SuspensionManager::SessionState()->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00270
00271         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00272         InvalidateSize();
00273     }
00274 }
00275
00276 void MainPage::NavigateToLaunchedFromSecondaryTile()
00277 {
00278     unsigned int selectedListBoxItemIndex = 0;
00279
00280     for (selectedListBoxItemIndex = 0; selectedListBoxItemIndex < scenarios->Length; selectedListBoxItemIndex++)
00281     {
00282         Scenarios->SelectedIndex = selectedListBoxItemIndex;
00283         Platform::String^ str = (safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name;
00284         if (str->Equals("SecondaryTiles.LaunchedFromSecondaryTile"))
00285         {
00286             break;
00287         }
00288     }
00289     SuspensionManager::SessionState()->Insert("SelectedScenarioIndex", --selectedListBoxItemIndex);
00290     InvalidateSize();
00291 }
00292
00293 void MainPage::SetSecondaryTiles(String^ strFeature)
00294 {
00295     SecondaryTiles->Text = strFeature;
00296 }
00297
00298 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00299 {
00300     switch (type)
00301     {
00302     case NotifyType::StatusMessage:
00303         // Use the status message style.
00304         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00305         break;
00306     case NotifyType::ErrorMessage:
00307         // Use the error message style.
00308         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00309         break;
00310     default:
00311         break;
00312     }
00313     StatusBlock->Text = strMessage;
00314
00315     // Collapsed the StatusBlock if it has no text to conserve real estate.
00316     if (StatusBlock->Text != "")
00317     {
00318         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00319     }
00320     else
00321     {
00322         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00323     }
00324 }
00325
00326 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00327 {
00328     auto uri = ref new Uri(safe_cast<String^>(safe_cast<HyperlinkButton^>(sender)->Tag));
00329     Windows::System::Launcher::LaunchUriAsync(uri);
00330 }
00331
00332
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media capture using capture device/C++/pch.h Source File

  • Media capture using capture device

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include <agile.h>
00021 #include "Common\LayoutAwarePage.h"
00022 #include "Common\SuspensionManager.h"
00023 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/common/LayoutAwarePage.cpp Source File

  • Number formatting and parsing
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/suspensionmanager.h Source File

  • File picker
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::PasswordVaultCPP::sealed Member List

This is the complete list of members for SDKSample::PasswordVaultCPP::sealed, including all inherited members.
ChangeUser_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
ChangeUser_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
ChangeUser_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
DoSomething_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
InitializeVaultAsync() | SDKSample::PasswordVaultCPP::sealed | [private]
Launch_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Launch_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Launch_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PasswordVaultCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PasswordVaultCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PasswordVaultCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PasswordVaultCPP::sealed | [protected, virtual]
Other_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Other_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Reset_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Reset_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Reset_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
rootPage | SDKSample::PasswordVaultCPP::sealed | [private]
Scenario1() | SDKSample::PasswordVaultCPP::sealed |
Scenario2() | SDKSample::PasswordVaultCPP::sealed |
Scenario3() | SDKSample::PasswordVaultCPP::sealed |
Scenario4() | SDKSample::PasswordVaultCPP::sealed |
ScenarioButtonDelete_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
SelectResource_Click(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
SelectUser_Click(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
SelectUser_Click(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Signin_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Signin_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Signin_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
WelcomeMessage_TextChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::TextChangedEventArgs^e) | SDKSample::PasswordVaultCPP::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

GeometryRealization Member List

This is the complete list of members for GeometryRealization, including all inherited members.
Create(ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension, ID2D1Geometry *geometry, REALIZATION_CREATION_OPTIONS options, CONST D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle, IGeometryRealization **realization) | GeometryRealization | [static]
Draw(ID2D1DeviceContext *deviceContext, ID2D1Brush *brush, REALIZATION_RENDER_MODE mode) | GeometryRealization |
Fill(ID2D1DeviceContext *deviceContext, ID2D1Brush *brush, REALIZATION_RENDER_MODE mode) | GeometryRealization |
GenerateOpacityMask(bool fill, ID2D1DeviceContext *baseRT, UINT maxRealizationDimension, ID2D1BitmapRenderTarget **bitmapRT, ID2D1Geometry *geometry, const D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle, D2D1_RECT_F *maskDestBounds, D2D1_RECT_F *maskSourceBounds) | GeometryRealization | [protected, static]
GeometryRealization() | GeometryRealization | [protected]
Initialize(ID2D1DeviceContext *deviceContext, UINT maxRealizationDimension, ID2D1Geometry *geometry, REALIZATION_CREATION_OPTIONS options, CONST D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle) | GeometryRealization | [protected]
m_deviceContext | GeometryRealization | [protected]
m_fillMaskDestBounds | GeometryRealization | [protected]
m_fillMaskSourceBounds | GeometryRealization | [protected]
m_fillMesh | GeometryRealization | [protected]
m_fillRT | GeometryRealization | [protected]
m_geometry | GeometryRealization | [protected]
m_maxRealizationDimension | GeometryRealization | [protected]
m_realizationTransform | GeometryRealization | [protected]
m_realizationTransformInv | GeometryRealization | [protected]
m_realizationTransformIsIdentity | GeometryRealization | [protected]
m_ref | GeometryRealization | [protected]
m_strokeMaskDestBounds | GeometryRealization | [protected]
m_strokeMaskSourceBounds | GeometryRealization | [protected]
m_strokeMesh | GeometryRealization | [protected]
m_strokeRT | GeometryRealization | [protected]
m_strokeStyle | GeometryRealization | [protected]
m_strokeWidth | GeometryRealization | [protected]
m_swRT | GeometryRealization | [protected]
QueryInterface(REFIID iid, void **ppvObject) | GeometryRealization |
RenderToTarget(bool fill, ID2D1DeviceContext *deviceContext, ID2D1Brush *brush, REALIZATION_RENDER_MODE mode) | GeometryRealization | [protected]
STDMETHOD_(ULONG, AddRef)() | GeometryRealization |
STDMETHOD_(ULONG, Release)() | GeometryRealization |
Update(ID2D1Geometry *geometry, REALIZATION_CREATION_OPTIONS options, CONST D2D1_MATRIX_3X2_F *worldTransform, float strokeWidth, ID2D1StrokeStyle *strokeStyle) | GeometryRealization |
~GeometryRealization() | GeometryRealization | [protected]
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/pch.cpp Source File

  • File picker contracts

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput3.xaml.h Source File

  • Print

ScenarioInput3.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Input.xaml.h
00010 // Declaration of the Scenario3Input class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioInput3.g.h"
00017 #include "MainPage.xaml.h"
00018
00019 using namespace Windows::UI::Xaml;
00020 using namespace Windows::UI::Xaml::Printing;
00021
00022 namespace PrintSample
00023 {
00024     /// <summary>
00025     /// Scenario that demos how to add customizations in the displayed options list.
00026     /// </summary>
00027     [Windows::Foundation::Metadata::WebHostHidden]
00028     public ref class ScenarioInput3 sealed
00029     {
00030     public:
00031         ScenarioInput3();
00032
00033     protected:
00034         virtual void PreparetPrintContent() override;
00035
00036         /// <summary>
00037         /// This is the event handler for PrintManager.PrintTaskRequested.
00038         /// In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified by PrintTaskRequestedEventArgs->Request->Deadline.
00039         /// Therefore, we use this handler to only create the print task.
00040         /// The print settings customization can be done when the print document source is requested.
00041         /// </summary>
00042         /// <param name="sender">PrintManager</param>
00043         /// <param name="e">PrintTaskRequestedEventArgs</param>
00044         virtual void PrintTaskRequested(Windows::Graphics::Printing::PrintManager^ sender, Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ e) override;
00045
00046     public:
00047         virtual void OnNavigatedTo(NavigationEventArgs^ e) override;
00048         virtual void OnNavigatedFrom(NavigationEventArgs^ e) override;
00049     };
00050 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/GetSIPUri.xaml.cpp Source File

  • User domain name

GetSIPUri.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // GetSIPUri.xaml.cpp
00013 // Implementation of the GetSIPUri class
00014 //
00015
00016 #include "pch.h"
00017 #include "GetSIPUri.xaml.h"
00018 #include <ppltasks.h>
00019
00020 using namespace Windows::System::UserProfile;
00021 using namespace Windows::Foundation;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Platform;
00026 using namespace SDKSample::UserDomainName;
00027 using namespace concurrency;
00028
00029 GetSIPUri::GetSIPUri()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 /// <summary>
00035 /// Invoked when this page is about to be displayed in a Frame.
00036 /// </summary>
00037 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00038 /// property is typically used to configure the page.</param>
00039 void GetSIPUri::OnNavigatedTo(NavigationEventArgs^ e)
00040 {
00041     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00042     // as NotifyUser()
00043     rootPage = MainPage::Current;
00044 }
00045
00046
00047 void SDKSample::UserDomainName::GetSIPUri::GetUri_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049     // The user or domain administrator may disable access to personal information by apps
00050     if (UserInformation::NameAccessAllowed)
00051     {
00052         UriResultText->Text = "Getting sip uri.";
00053         create_task(UserInformation::GetSessionInitiationProtocolUriAsync()).then([this](Uri^ sipUri)
00054         {
00055             // a null uri may be returned in any of the following circumstances:
00056             // The information cannot be retrieved from the directory
00057             // The calling user is not a member of a domain
00058             // The user or administrator has disabled the privacy setting
00059             UriResultText->Text = sipUri ? sipUri->RawUri : "No SIP Uri returned for the current user.";
00060         });
00061     }
00062     else
00063     {
00064         UriResultText->Text = "Access to user information is disabled by the user or administrator";
00065     }
00066 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/DWriteVerticalText.h Source File

  • DirectWrite vertical text

DWriteVerticalText.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012 #include "FlowLayout.h"
00013
00014 ref class DWriteVerticalText : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00015 {
00016 internal:
00017     DWriteVerticalText();
00018
00019     // DirectXBase Methods
00020     virtual void CreateDeviceIndependentResources() override;
00021     virtual void CreateDeviceResources() override;
00022     virtual void CreateWindowSizeDependentResources() override;
00023     virtual void Render() override;
00024
00025 public:
00026     // IFrameworkView Methods
00027     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00028     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00029     virtual void Load(_In_ Platform::String^ entryPoint);
00030     virtual void Run();
00031     virtual void Uninitialize();
00032
00033 private:
00034     // Event Handlers
00035     void OnWindowSizeChanged(
00036         _In_ Windows::UI::Core::CoreWindow^ sender,
00037         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00038         );
00039
00040     void OnLogicalDpiChanged(
00041         _In_ Platform::Object^ sender
00042         );
00043
00044     void OnDisplayContentsInvalidated(
00045         _In_ Platform::Object^ sender
00046         );
00047
00048     void OnActivated(
00049         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00050         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00051         );
00052
00053     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>                    m_blackBrush;
00054     Microsoft::WRL::ComPtr<IDWriteTextFormat>                       m_textFormat;
00055     Microsoft::WRL::ComPtr<IDWriteTypography>                       m_textTypography;
00056     Microsoft::WRL::ComPtr<IDWriteTextLayout>                       m_textLayout;
00057     Microsoft::WRL::ComPtr<IDWriteRenderingParams>                  m_renderingParams;
00058     Microsoft::WRL::ComPtr<FlowLayoutSource>                        m_flowLayoutSource;
00059     Microsoft::WRL::ComPtr<FlowLayoutSink>                          m_flowLayoutSink;
00060     Microsoft::WRL::ComPtr<FlowLayout>                              m_flowLayout;
00061     SampleOverlay^                                                  m_sampleOverlay;
00062     const wchar_t*                                                  m_fontName;
00063     const wchar_t*                                                  m_localeName;
00064     UINT32                                                          m_textLength;
00065     float                                                           m_fontSize;
00066     const wchar_t*                                                  m_text;
00067     ReadingDirection                                                m_readingDirection;
00068 };
00069
00070 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00071 {
00072 public:
00073     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00074 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileSquareBase Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileSquareBase, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileSquareBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileSquareBase | [inline]
NotificationsExtensions::TileContent::TileNotificationBase::GetContent() | NotificationsExtensions::NotificationBase | [pure virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeBinding(string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
SerializeBinding(string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileSquareBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
TileSquareBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario5.xaml.cpp Source File

  • File picker

Scenario5.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario5.xaml.cpp
00013 // Implementation of the Scenario5 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario5.xaml.h"
00018
00019 using namespace SDKSample::FilePicker;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::Pickers;
00025 using namespace Windows::Storage::Provider;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::Globalization::DateTimeFormatting;
00030
00031 Scenario5::Scenario5()
00032 {
00033     InitializeComponent();
00034     rootPage = MainPage::Current;
00035     PickFileButton->Click += ref new RoutedEventHandler(this, &Scenario5::PickFileButton_Click);
00036     OutputFileButton->Click += ref new RoutedEventHandler(this, &Scenario5::OutputFileButton_Click);
00037 }
00038
00039 void Scenario5::PickFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00040 {
00041     // Clear previous returned file name, if it exists, between iterations of this scenario
00042     rootPage->ResetScenarioOutput(OutputFileName);
00043     rootPage->ResetScenarioOutput(OutputFileContent);
00044     rootPage->NotifyUser("", NotifyType::StatusMessage);
00045
00046     if (rootPage->EnsureUnsnapped())
00047     {
00048         FileOpenPicker^ openPicker = ref new FileOpenPicker();
00049         openPicker->FileTypeFilter->Append(".txt");
00050
00051         create_task(openPicker->PickSingleFileAsync()).then([this](StorageFile^ file)
00052         {
00053             if (file)
00054             {
00055                 fileToken = AccessCache::StorageApplicationPermissions::FutureAccessList->Add(file);
00056                 OutputFileButton->IsEnabled = true;
00057                 OutputFileAsync(file);
00058             }
00059             else
00060             {
00061                 rootPage->NotifyUser("Operation cancelled.", NotifyType::StatusMessage);
00062             }
00063         });
00064     }
00065 }
00066
00067 void Scenario5::OutputFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00068 {
00069     if (fileToken != nullptr)
00070     {
00071         rootPage->NotifyUser("", NotifyType::StatusMessage);
00072
00073         // Windows will call the server app to update the local version of the file
00074         create_task(AccessCache::StorageApplicationPermissions::FutureAccessList->GetFileAsync(fileToken)).then([this](task<StorageFile^> taskResult)
00075         {
00076             try
00077             {
00078                 StorageFile^ file = taskResult.get();
00079                 OutputFileAsync(file);
00080             }
00081             catch(AccessDeniedException^)
00082             {
00083                 rootPage->NotifyUser("Access is denied.", NotifyType::ErrorMessage);
00084             }
00085         });
00086     }
00087 }
00088
00089 void Scenario5::OutputFileAsync(StorageFile^ file)
00090 {
00091     create_task(FileIO::ReadTextAsync(file)).then([this, file](String^ fileContent)
00092     {
00093         OutputFileName->Text = L"Received file: " + file->Name;
00094         OutputFileContent->Text = L"File content:\n" + fileContent;
00095     });
00096 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Scenario2.xaml.cpp Source File

  • Gyrometer sensor

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::GyrometerCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Devices::Sensors;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::UI::Core;
00027 using namespace Platform;
00028
00029 Scenario2::Scenario2() : rootPage(MainPage::Current), desiredReportInterval(0)
00030 {
00031     InitializeComponent();
00032
00033     gyrometer = Gyrometer::GetDefault();
00034     if (gyrometer != nullptr)
00035     {
00036         // Select a report interval that is both suitable for the purposes of the app and supported by the sensor.
00037         // This value will be used later to activate the sensor.
00038         uint32 minReportInterval = gyrometer->MinimumReportInterval;
00039         desiredReportInterval = minReportInterval > 16 ? minReportInterval : 16;
00040
00041         // Set up a DispatchTimer
00042         TimeSpan span;
00043         span.Duration = static_cast<int32>(desiredReportInterval) * 10000;   // convert to 100ns ticks
00044         dispatcherTimer = ref new DispatcherTimer();
00045         dispatcherTimer->Interval = span;
00046         dispatcherTimer->Tick += ref new Windows::Foundation::EventHandler<Object^>(this, &Scenario2::DisplayCurrentReading);
00047     }
00048     else
00049     {
00050         rootPage->NotifyUser("No gyrometer found", NotifyType::ErrorMessage);
00051     }
00052 }
00053
00054 /// <summary>
00055 /// Invoked when this page is about to be displayed in a Frame.
00056 /// </summary>
00057 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00058 /// property is typically used to configure the page.</param>
00059 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00060 {
00061     ScenarioEnableButton->IsEnabled = true;
00062     ScenarioDisableButton->IsEnabled = false;
00063 }
00064
00065 /// <summary>
00066 /// Invoked when this page is no longer displayed.
00067 /// </summary>
00068 /// <param name="e"></param>
00069 void Scenario2::OnNavigatedFrom(NavigationEventArgs^ e)
00070 {
00071     if (ScenarioDisableButton->IsEnabled)
00072     {
00073         Window::Current->VisibilityChanged::remove(visibilityToken);
00074         dispatcherTimer->Stop();
00075
00076         // Restore the default report interval to release resources while the sensor is not in use
00077         gyrometer->ReportInterval = 0;
00078     }
00079 }
00080
00081 /// <summary>
00082 /// This is the event handler for VisibilityChanged events. You would register for these notifications
00083 /// if handling sensor data when the app is not visible could cause unintended actions in the app.
00084 /// </summary>
00085 /// <param name="sender"></param>
00086 /// <param name="e">
00087 /// Event data that can be examined for the current visibility state.
00088 /// </param>
00089 void Scenario2::VisibilityChanged(Object^ sender, VisibilityChangedEventArgs^ e)
00090 {
00091     // The app should watch for VisibilityChanged events to disable and re-enable sensor input as appropriate
00092     if (ScenarioDisableButton->IsEnabled)
00093     {
00094         if (e->Visible)
00095         {
00096             // Re-enable sensor input (no need to restore the desired reportInterval... it is restored for us upon app resume)
00097             dispatcherTimer->Start();
00098         }
00099         else
00100         {
00101             // Disable sensor input (no need to restore the default reportInterval... resources will be released upon app suspension)
00102             dispatcherTimer->Stop();
00103         }
00104     }
00105 }
00106
00107 void Scenario2::DisplayCurrentReading(Object^ sender, Object^ e)
00108 {
00109     GyrometerReading^ reading = gyrometer->GetCurrentReading();
00110     if (reading != nullptr)
00111     {
00112         ScenarioOutput_X->Text = reading->AngularVelocityX.ToString();
00113         ScenarioOutput_Y->Text = reading->AngularVelocityY.ToString();
00114         ScenarioOutput_Z->Text = reading->AngularVelocityZ.ToString();
00115     }
00116 }
00117
00118 void Scenario2::ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00119 {
00120     if (gyrometer != nullptr)
00121     {
00122         visibilityToken = Window::Current->VisibilityChanged::add(ref new WindowVisibilityChangedEventHandler(this, &Scenario2::VisibilityChanged));
00123
00124         // Set the report interval to enable the sensor for polling
00125         gyrometer->ReportInterval = desiredReportInterval;
00126
00127         dispatcherTimer->Start();
00128
00129         ScenarioEnableButton->IsEnabled = false;
00130         ScenarioDisableButton->IsEnabled = true;
00131     }
00132     else
00133     {
00134         rootPage->NotifyUser("No gyrometer found", NotifyType::ErrorMessage);
00135     }
00136 }
00137
00138 void Scenario2::ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00139 {
00140     Window::Current->VisibilityChanged::remove(visibilityToken);
00141
00142     dispatcherTimer->Stop();
00143
00144     // Restore the default report interval to release resources while the sensor is not in use
00145     gyrometer->ReportInterval = 0;
00146
00147     ScenarioEnableButton->IsEnabled = true;
00148     ScenarioDisableButton->IsEnabled = false;
00149 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/App.xaml.cpp Source File

  • File access

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PhotoCache.cpp Source File

  • Hilo C++
  • Hilo

PhotoCache.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "PhotoCache.h"
00009 #include "IPhoto.h"
00010 #include "CalendarExtensions.h"
00011
00012 using namespace Hilo;
00013 using namespace Platform;
00014 using namespace Windows::Globalization;
00015
00016 void PhotoCache::Clear()
00017 {
00018     m_photoCache.clear();
00019 }
00020
00021 void PhotoCache::InsertPhoto(IPhoto^ photo)
00022 {
00023     int year, month;
00024     auto monthDate = photo->DateTaken;
00025
00026     CalendarExtensions::WriteLocalizedYearAndMonth(monthDate, year, month);
00027     auto &yearPair = m_photoCache[year];
00028     yearPair[month] = WeakReference(photo);
00029 }
00030
00031 IPhoto^ PhotoCache::GetForYearAndMonth(int year, int month)
00032 {
00033     auto &yearMap = m_photoCache[year];
00034     auto &weakRef = yearMap[month];
00035
00036     if (nullptr != weakRef)
00037     {
00038         return weakRef.Resolve<IPhoto>();
00039     }
00040     return nullptr;
00041 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Create.xaml.h Source File

  • Playlist

Create.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Create.xaml.h
00013 // Declaration of the Create class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Create.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::Media::Playlists;
00023
00024 namespace SDKSample
00025 {
00026     namespace Playlists
00027     {
00028         /// <summary>
00029         /// An empty page that can be used on its own or navigated to within a Frame.
00030         /// </summary>
00031         [Windows::Foundation::Metadata::WebHostHidden]
00032         public ref class Create sealed
00033         {
00034         public:
00035             Create();
00036
00037         protected:
00038             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00039         private:
00040             MainPage^ rootPage;
00041             void PickAudioButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042         };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput3.xaml.h Source File

  • Media extensions

ScenarioOutput3.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Output.xaml.h
00010 // Declaration of the Scenario3Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput3.g.h"
00017 #include "MainPage.g.h"
00018
00019 using namespace Windows::UI::Xaml;
00020 using namespace Windows::UI::ViewManagement;
00021
00022 namespace MediaExtensionsCPP
00023 {
00024     [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class ScenarioOutput3 sealed
00026     {
00027     public:
00028         ScenarioOutput3();
00029
00030     protected:
00031         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033
00034     private:
00035         ~ScenarioOutput3();
00036         MainPage^ rootPage;
00037         Windows::Foundation::EventRegistrationToken _mediaFailedToken;
00038         Windows::Foundation::EventRegistrationToken _stabilizedMediaFailedToken;
00039     };
00040 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileSavePicker_FailToSave.xaml.cpp Source File

  • File picker contracts

FileSavePicker_FailToSave.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FileSavePicker_FailToSave.xaml.cpp
00013 // Implementation of the FileSavePicker_FailToSave class
00014 //
00015
00016 #include "pch.h"
00017 #include "FileSavePickerPage.xaml.h"
00018 #include "FileSavePicker_FailToSave.xaml.h"
00019 #include "Constants.h"
00020
00021 using namespace SDKSample::FilePickerContracts;
00022
00023 using namespace concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::Foundation;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::Pickers::Provider;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Popups;
00031 using namespace Windows::UI::Xaml;
00032 using namespace Windows::UI::Xaml::Controls;
00033 using namespace Windows::UI::Xaml::Navigation;
00034
00035 FileSavePicker_FailToSave::FileSavePicker_FailToSave()
00036 {
00037     InitializeComponent();
00038     fileSavePickerUI = FileSavePickerPage::Current->fileSavePickerUI;
00039 }
00040
00041 void FileSavePicker_FailToSave::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     token = fileSavePickerUI->TargetFileRequested += ref new TypedEventHandler<FileSavePickerUI^, TargetFileRequestedEventArgs^>(this, &FileSavePicker_FailToSave::OnTargetFileRequested, CallbackContext::Same);
00044 }
00045
00046 void FileSavePicker_FailToSave::OnNavigatedFrom(NavigationEventArgs^ e)
00047 {
00048     fileSavePickerUI->TargetFileRequested -= token;
00049 }
00050
00051 void FileSavePicker_FailToSave::OnTargetFileRequested(FileSavePickerUI^ fileSavePickerUI, TargetFileRequestedEventArgs^ e)
00052 {
00053     // Requesting a deferral allows the app to call another asynchronous method and complete the request at a later time
00054     auto request = e->Request;
00055     auto deferral = request->GetDeferral();
00056
00057     // Display a dialog indicating to the user that a corrective action needs to occur
00058     auto errorDialog = ref new MessageDialog("If the app needs the user to correct a problem before the app can save the file, the app can use a message like this to tell the user about the problem and how to correct it.");
00059     create_task(errorDialog->ShowAsync()).then([request, deferral](IUICommand^ command)
00060     {
00061         // Set the targetFile property to null and complete the deferral to indicate failure once the user has closed the
00062         // dialog.  This will allow the user to take any neccessary corrective action and click the Save button once again.
00063         request->TargetFile = nullptr;
00064         deferral->Complete();
00065     });
00066 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicSprites.cpp Source File

  • Direct3D sprite

BasicSprites.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 // Warning: SpriteBatch performance is significantly decreased in
00009 // the Debug configuration.  Release configuration is recommended
00010 // for accurate performance assessment.
00011
00012 #include "pch.h"
00013 #include "BasicSprites.h"
00014 #include "DirectXSample.h"
00015 #include "BasicLoader.h"
00016
00017 using namespace Microsoft::WRL;
00018 using namespace BasicSprites;
00019
00020 SpriteBatch::SpriteBatch() :
00021     m_capacity(0)
00022 {
00023 }
00024
00025 void SpriteBatch::Initialize(
00026     _In_ ID3D11Device1* d3dDevice,
00027     _In_ int capacity = 1024
00028     )
00029 {
00030     m_d3dDevice = d3dDevice;
00031     m_d3dDevice->GetImmediateContext1(&m_d3dContext);
00032     m_capacity = capacity;
00033
00034     // Determine the technique that will be used to render the sprites.
00035     auto featureLevel = m_d3dDevice->GetFeatureLevel();
00036
00037     if (featureLevel >= D3D_FEATURE_LEVEL_10_0)
00038     {
00039         // On DirectX 10+ devices, the Geometry Shader allows the sprite vertices to be
00040         // generated on the GPU, significantly reducing memory bandwidth requirements.
00041         m_technique = RenderTechnique::GeometryShader;
00042     }
00043     else if (featureLevel >= D3D_FEATURE_LEVEL_9_3)
00044     {
00045         // On DirectX 9.3+ devices, instancing allows shared sprite geometry with unique
00046         // per-sprite instance parameters, eliminating redundant data transfer.
00047         m_technique = RenderTechnique::Instancing;
00048     }
00049     else
00050     {
00051         // On devices that do not support Instancing, sprite vertex data must be replicated
00052         // in order to achieve the desired effect.
00053         m_technique = RenderTechnique::Replication;
00054
00055         if (capacity > static_cast<int>(Parameters::MaximumCapacityCompatible))
00056         {
00057             // The index buffer format for feature-level 9.1 devices may only be 16 bits.
00058             // With 4 vertices per sprite, this allows a maximum of (1 << 16) / 4 sprites.
00059             throw ref new Platform::InvalidArgumentException();
00060         }
00061     }
00062
00063     // Create the texture sampler.
00064
00065     D3D11_SAMPLER_DESC samplerDesc;
00066     ZeroMemory(&samplerDesc, sizeof(samplerDesc));
00067     samplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;
00068     samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_CLAMP;
00069     samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_CLAMP;
00070     samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_CLAMP;
00071     samplerDesc.MipLODBias = 0.0f;
00072     samplerDesc.MaxAnisotropy = 0;
00073     samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
00074     samplerDesc.BorderColor[0] = 0.0f;
00075     samplerDesc.BorderColor[1] = 0.0f;
00076     samplerDesc.BorderColor[2] = 0.0f;
00077     samplerDesc.BorderColor[3] = 0.0f;
00078     samplerDesc.MinLOD = 0.0f;
00079     samplerDesc.MaxLOD = FLT_MAX;
00080
00081     DX::ThrowIfFailed(
00082         m_d3dDevice->CreateSamplerState(
00083             &samplerDesc,
00084             &m_linearSampler
00085             )
00086         );
00087
00088     // Create the blend states.
00089
00090     D3D11_BLEND_DESC1 blendDesc;
00091     ZeroMemory(&blendDesc, sizeof(blendDesc));
00092     blendDesc.AlphaToCoverageEnable = false;
00093     blendDesc.IndependentBlendEnable = false;
00094     blendDesc.RenderTarget[0].BlendEnable = true;
00095     blendDesc.RenderTarget[0].LogicOpEnable = false;
00096     blendDesc.RenderTarget[0].SrcBlend = D3D11_BLEND_SRC_ALPHA;
00097     blendDesc.RenderTarget[0].DestBlend = D3D11_BLEND_INV_SRC_ALPHA;
00098     blendDesc.RenderTarget[0].BlendOp = D3D11_BLEND_OP_ADD;
00099     blendDesc.RenderTarget[0].SrcBlendAlpha = D3D11_BLEND_ONE;
00100     blendDesc.RenderTarget[0].DestBlendAlpha = D3D11_BLEND_ONE;
00101     blendDesc.RenderTarget[0].BlendOpAlpha = D3D11_BLEND_OP_ADD;
00102     blendDesc.RenderTarget[0].RenderTargetWriteMask = D3D11_COLOR_WRITE_ENABLE_ALL;
00103
00104     DX::ThrowIfFailed(
00105         m_d3dDevice->CreateBlendState1(
00106             &blendDesc,
00107             &m_blendStateAlpha
00108             )
00109         );
00110
00111     blendDesc.RenderTarget[0].DestBlend = D3D11_BLEND_ONE;
00112
00113     DX::ThrowIfFailed(
00114         m_d3dDevice->CreateBlendState1(
00115             &blendDesc,
00116             &m_blendStateAdditive
00117             )
00118         );
00119
00120     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00121
00122     if (m_technique == RenderTechnique::GeometryShader)
00123     {
00124         D3D11_INPUT_ELEMENT_DESC layoutDesc[] =
00125         {
00126             { "TRANSFORM", 0, DXGI_FORMAT_R32G32_FLOAT,   0, 0,  D3D11_INPUT_PER_INSTANCE_DATA, 1 },
00127             { "TRANSFORM", 1, DXGI_FORMAT_R32G32_FLOAT,   0, 8,  D3D11_INPUT_PER_INSTANCE_DATA, 1 },
00128             { "TRANSFORM", 2, DXGI_FORMAT_R32_FLOAT,      0, 16, D3D11_INPUT_PER_INSTANCE_DATA, 1 },
00129             { "COLOR",     0, DXGI_FORMAT_R8G8B8A8_UNORM, 0, 20, D3D11_INPUT_PER_INSTANCE_DATA, 1 }
00130         };
00131         loader->LoadShader(
00132             "BasicSprites.GeometryShader.vs.cso",
00133             layoutDesc,
00134             ARRAYSIZE(layoutDesc),
00135             &m_vertexShader,
00136             &m_inputLayout
00137             );
00138         loader->LoadShader(
00139             "BasicSprites.GeometryShader.gs.cso",
00140             &m_geometryShader
00141             );
00142     }
00143     else if (m_technique == RenderTechnique::Instancing)
00144     {
00145         D3D11_INPUT_ELEMENT_DESC layoutDesc[] =
00146         {
00147             { "POSITION",  0, DXGI_FORMAT_R32G32_FLOAT,   0, 0,  D3D11_INPUT_PER_VERTEX_DATA,   0 },
00148             { "TEXCOORD",  0, DXGI_FORMAT_R32G32_FLOAT,   0, 8,  D3D11_INPUT_PER_VERTEX_DATA,   0 },
00149             { "TRANSFORM", 0, DXGI_FORMAT_R32G32_FLOAT,   1, 0,  D3D11_INPUT_PER_INSTANCE_DATA, 1 },
00150             { "TRANSFORM", 1, DXGI_FORMAT_R32G32_FLOAT,   1, 8,  D3D11_INPUT_PER_INSTANCE_DATA, 1 },
00151             { "TRANSFORM", 2, DXGI_FORMAT_R32_FLOAT,      1, 16, D3D11_INPUT_PER_INSTANCE_DATA, 1 },
00152             { "COLOR",     0, DXGI_FORMAT_R8G8B8A8_UNORM, 1, 20, D3D11_INPUT_PER_INSTANCE_DATA, 1 }
00153         };
00154         loader->LoadShader(
00155             "BasicSprites.Instancing.vs.cso",
00156             layoutDesc,
00157             ARRAYSIZE(layoutDesc),
00158             &m_vertexShader,
00159             &m_inputLayout
00160             );
00161     }
00162     else if (m_technique == RenderTechnique::Replication)
00163     {
00164         D3D11_INPUT_ELEMENT_DESC layoutDesc[] =
00165         {
00166             { "POSITIONT", 0, DXGI_FORMAT_R32G32_FLOAT,   0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
00167             { "TEXCOORD",  0, DXGI_FORMAT_R32G32_FLOAT,   0, 8,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
00168             { "COLOR",     0, DXGI_FORMAT_R8G8B8A8_UNORM, 0, 16, D3D11_INPUT_PER_VERTEX_DATA, 0 }
00169         };
00170         loader->LoadShader(
00171             "BasicSprites.Replication.vs.cso",
00172             layoutDesc,
00173             ARRAYSIZE(layoutDesc),
00174             &m_vertexShader,
00175             &m_inputLayout
00176             );
00177     }
00178
00179     loader->LoadShader(
00180         "BasicSprites.ps.cso",
00181         &m_pixelShader
00182         );
00183
00184     // Create buffers.
00185
00186     if (m_technique == RenderTechnique::GeometryShader)
00187     {
00188         // Create the instance data buffer.
00189
00190         CD3D11_BUFFER_DESC instanceDataBufferDesc(
00191             m_capacity * sizeof(InstanceData),
00192             D3D11_BIND_VERTEX_BUFFER,
00193             D3D11_USAGE_DEFAULT,
00194             0
00195             );
00196
00197         DX::ThrowIfFailed(
00198             m_d3dDevice->CreateBuffer(
00199                 &instanceDataBufferDesc,
00200                 nullptr,
00201                 &m_instanceDataBuffer
00202                 )
00203             );
00204
00205         m_instanceData.reset(new InstanceData[m_capacity]);
00206     }
00207     else if (m_technique == RenderTechnique::Instancing)
00208     {
00209         // Create the vertex buffer.
00210
00211         InstancingVertex vertexBufferData[] =
00212         {
00213             { float2(-1.0f,  1.0f), float2(0.0f, 0.0f) },
00214             { float2( 1.0f,  1.0f), float2(1.0f, 0.0f) },
00215             { float2(-1.0f, -1.0f), float2(0.0f, 1.0f) },
00216             { float2( 1.0f, -1.0f), float2(1.0f, 1.0f) }
00217         };
00218
00219         D3D11_SUBRESOURCE_DATA vertexInitialData;
00220         vertexInitialData.pSysMem = vertexBufferData;
00221         vertexInitialData.SysMemPitch = 0;
00222         vertexInitialData.SysMemSlicePitch = 0;
00223
00224         CD3D11_BUFFER_DESC vertexBufferDesc(
00225             sizeof(vertexBufferData),
00226             D3D11_BIND_VERTEX_BUFFER,
00227             D3D11_USAGE_DEFAULT,
00228             0
00229             );
00230
00231         DX::ThrowIfFailed(
00232             m_d3dDevice->CreateBuffer(
00233                 &vertexBufferDesc,
00234                 &vertexInitialData,
00235                 &m_vertexBuffer
00236                 )
00237             );
00238
00239         // Create the instance data buffer.
00240
00241         CD3D11_BUFFER_DESC instanceDataBufferDesc(
00242             m_capacity * sizeof(InstanceData),
00243             D3D11_BIND_VERTEX_BUFFER,
00244             D3D11_USAGE_DEFAULT,
00245             0
00246             );
00247
00248         DX::ThrowIfFailed(
00249             m_d3dDevice->CreateBuffer(
00250                 &instanceDataBufferDesc,
00251                 nullptr,
00252                 &m_instanceDataBuffer
00253                 )
00254             );
00255
00256         m_instanceData.reset(new InstanceData[m_capacity]);
00257
00258         // Create the index buffer.
00259
00260         unsigned int indexBufferData[] =
00261         {
00262             0, 1, 2,
00263             1, 3, 2
00264         };
00265
00266         D3D11_SUBRESOURCE_DATA indexInitialData;
00267         indexInitialData.pSysMem = indexBufferData;
00268         indexInitialData.SysMemPitch = 0;
00269         indexInitialData.SysMemSlicePitch = 0;
00270
00271         CD3D11_BUFFER_DESC indexBufferDesc(
00272             sizeof(indexBufferData),
00273             D3D11_BIND_INDEX_BUFFER,
00274             D3D11_USAGE_DEFAULT,
00275             0
00276             );
00277
00278         DX::ThrowIfFailed(
00279             m_d3dDevice->CreateBuffer(
00280                 &indexBufferDesc,
00281                 &indexInitialData,
00282                 &m_indexBuffer
00283                 )
00284             );
00285     }
00286     else if (m_technique == RenderTechnique::Replication)
00287     {
00288         // Create the vertex buffer.
00289
00290         CD3D11_BUFFER_DESC vertexBufferDesc(
00291             m_capacity * 4 * sizeof(ReplicationVertex),
00292             D3D11_BIND_VERTEX_BUFFER,
00293             D3D11_USAGE_DEFAULT,
00294             0
00295             );
00296
00297         DX::ThrowIfFailed(
00298             m_d3dDevice->CreateBuffer(
00299                 &vertexBufferDesc,
00300                 nullptr,
00301                 &m_vertexBuffer
00302                 )
00303             );
00304
00305         m_vertexData.reset(new ReplicationVertex[m_capacity * 4]);
00306
00307         // Create the index buffer.
00308
00309         std::unique_ptr<unsigned short[]> indexBufferData(new unsigned short[m_capacity * 6]);
00310
00311         for (int i = 0; i < m_capacity; i++)
00312         {
00313             indexBufferData[i * 6 + 0] = i * 4 + 0;
00314             indexBufferData[i * 6 + 1] = i * 4 + 1;
00315             indexBufferData[i * 6 + 2] = i * 4 + 2;
00316             indexBufferData[i * 6 + 3] = i * 4 + 1;
00317             indexBufferData[i * 6 + 4] = i * 4 + 3;
00318             indexBufferData[i * 6 + 5] = i * 4 + 2;
00319         }
00320
00321         D3D11_SUBRESOURCE_DATA initialData;
00322         initialData.pSysMem = indexBufferData.get();
00323         initialData.SysMemPitch = 0;
00324         initialData.SysMemSlicePitch = 0;
00325
00326         CD3D11_BUFFER_DESC indexBufferDesc(
00327             m_capacity * 6 * sizeof(unsigned short),
00328             D3D11_BIND_INDEX_BUFFER,
00329             D3D11_USAGE_DEFAULT,
00330             0
00331             );
00332
00333         DX::ThrowIfFailed(
00334             m_d3dDevice->CreateBuffer(
00335                 &indexBufferDesc,
00336                 &initialData,
00337                 &m_indexBuffer
00338                 )
00339             );
00340     }
00341
00342     if (m_technique == RenderTechnique::GeometryShader || m_technique == RenderTechnique::Instancing)
00343     {
00344         // Both the Geometry Shader and Instancing techniques scale geometry in shader code.
00345         // As a result, they require information about the render target size.
00346
00347         CD3D11_BUFFER_DESC renderTargetInfoCbufferDesc(
00348             16, // Constant buffer sizes must be a multiple of 16 bytes.  16 is sufficient for the required float2 data.
00349             D3D11_BIND_CONSTANT_BUFFER,
00350             D3D11_USAGE_DYNAMIC,
00351             D3D11_CPU_ACCESS_WRITE
00352             );
00353
00354         DX::ThrowIfFailed(
00355             m_d3dDevice->CreateBuffer(
00356                 &renderTargetInfoCbufferDesc,
00357                 nullptr,
00358                 &m_renderTargetInfoCbuffer
00359                 )
00360             );
00361     }
00362 }
00363
00364 void SpriteBatch::AddTexture(
00365     _In_ ID3D11Texture2D* texture
00366     )
00367 {
00368     TextureMapElement mapElement;
00369     CD3D11_SHADER_RESOURCE_VIEW_DESC mapElementSrvDesc(
00370         texture,
00371         D3D11_SRV_DIMENSION_TEXTURE2D
00372         );
00373     DX::ThrowIfFailed(
00374         m_d3dDevice->CreateShaderResourceView(
00375             texture,
00376             &mapElementSrvDesc,
00377             &mapElement.srv
00378             )
00379         );
00380
00381     D3D11_TEXTURE2D_DESC textureDesc;
00382     texture->GetDesc(&textureDesc);
00383     mapElement.size = float2(
00384         static_cast<float>(textureDesc.Width),
00385         static_cast<float>(textureDesc.Height)
00386         );
00387
00388     m_textureMap[texture] = mapElement;
00389 }
00390
00391 void SpriteBatch::RemoveTexture(
00392     _In_ ID3D11Texture2D* texture
00393     )
00394 {
00395     m_textureMap.erase(texture);
00396 }
00397
00398 void SpriteBatch::Begin()
00399 {
00400     // Reset internal sprite data.
00401
00402     m_numSpritesDrawn = 0;
00403     m_spritesInRun = 0;
00404     m_spriteRuns.clear();
00405
00406     // Get the current render target dimensions and logical DPI.
00407
00408     ComPtr<ID3D11RenderTargetView> renderTargetView;
00409     m_d3dContext->OMGetRenderTargets(
00410         1,
00411         &renderTargetView,
00412         nullptr
00413         );
00414
00415     ComPtr<ID3D11Resource> renderTarget;
00416     renderTargetView->GetResource(&renderTarget);
00417
00418     ComPtr<ID3D11Texture2D> renderTargetTexture;
00419     renderTarget.As(&renderTargetTexture);
00420
00421     D3D11_TEXTURE2D_DESC renderTargetTextureDesc;
00422     renderTargetTexture->GetDesc(&renderTargetTextureDesc);
00423
00424     m_renderTargetSize = float2(
00425         static_cast<float>(renderTargetTextureDesc.Width),
00426         static_cast<float>(renderTargetTextureDesc.Height)
00427         );
00428
00429     m_dpi = Windows::Graphics::Display::DisplayProperties::LogicalDpi;
00430 }
00431
00432 void SpriteBatch::End()
00433 {
00434     // If no sprites were drawn, do nothing.
00435     if (m_numSpritesDrawn == 0)
00436     {
00437         return;
00438     }
00439
00440     // Save the final sprite run info.
00441
00442     SpriteRunInfo runInfo;
00443     runInfo.textureView = m_currentTextureView;
00444     runInfo.blendState = m_currentBlendState;
00445     runInfo.numSprites = m_spritesInRun;
00446     m_spriteRuns.push_back(runInfo);
00447
00448     // Update the buffer data.
00449
00450     if (m_technique == RenderTechnique::GeometryShader || m_technique == RenderTechnique::Instancing)
00451     {
00452         CD3D11_BOX instanceDataBox(
00453             0,
00454             0,
00455             0,
00456             sizeof(InstanceData) * m_numSpritesDrawn,
00457             1,
00458             1
00459             );
00460
00461         m_d3dContext->UpdateSubresource(
00462             m_instanceDataBuffer.Get(),
00463             0,
00464             &instanceDataBox,
00465             m_instanceData.get(),
00466             0,
00467             0
00468             );
00469     }
00470     else if (m_technique == RenderTechnique::Replication)
00471     {
00472         CD3D11_BOX vertexDataBox(
00473             0,
00474             0,
00475             0,
00476             sizeof(ReplicationVertex) * m_numSpritesDrawn * 4,
00477             1,
00478             1
00479             );
00480
00481         m_d3dContext->UpdateSubresource(
00482             m_vertexBuffer.Get(),
00483             0,
00484             &vertexDataBox,
00485             m_vertexData.get(),
00486             0,
00487             0
00488             );
00489     }
00490
00491     if (m_technique == RenderTechnique::GeometryShader || m_technique == RenderTechnique::Instancing)
00492     {
00493         D3D11_MAPPED_SUBRESOURCE mappedSubresource;
00494         m_d3dContext->Map(
00495             m_renderTargetInfoCbuffer.Get(),
00496             0,
00497             D3D11_MAP_WRITE_DISCARD,
00498             0,
00499             &mappedSubresource
00500             );
00501         *static_cast<float2*>(mappedSubresource.pData) = m_renderTargetSize;
00502         m_d3dContext->Unmap(
00503             m_renderTargetInfoCbuffer.Get(),
00504             0
00505             );
00506     }
00507
00508     // Set the pipeline state
00509
00510     if (m_technique == RenderTechnique::Instancing)
00511     {
00512         m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00513         m_d3dContext->IASetIndexBuffer(
00514             m_indexBuffer.Get(),
00515             DXGI_FORMAT_R32_UINT,
00516             0
00517             );
00518     }
00519     else if (m_technique == RenderTechnique::Replication)
00520     {
00521         m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00522         m_d3dContext->IASetIndexBuffer(
00523             m_indexBuffer.Get(),
00524             DXGI_FORMAT_R16_UINT,
00525             0
00526             );
00527     }
00528     else if (m_technique == RenderTechnique::GeometryShader)
00529     {
00530         m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_POINTLIST);
00531         m_d3dContext->GSSetShader(
00532             m_geometryShader.Get(),
00533             nullptr,
00534             0
00535             );
00536     }
00537
00538     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00539
00540     m_d3dContext->VSSetShader(
00541         m_vertexShader.Get(),
00542         nullptr,
00543         0
00544         );
00545
00546     if (m_technique == RenderTechnique::GeometryShader)
00547     {
00548         m_d3dContext->GSSetConstantBuffers(
00549             0,
00550             1,
00551             m_renderTargetInfoCbuffer.GetAddressOf()
00552             );
00553     }
00554     else if (m_technique == RenderTechnique::Instancing)
00555     {
00556         m_d3dContext->VSSetConstantBuffers(
00557             0,
00558             1,
00559             m_renderTargetInfoCbuffer.GetAddressOf()
00560             );
00561     }
00562
00563     m_d3dContext->PSSetShader(
00564         m_pixelShader.Get(),
00565         nullptr,
00566         0
00567         );
00568
00569     m_d3dContext->PSSetSamplers(
00570         0,
00571         1,
00572         m_linearSampler.GetAddressOf()
00573         );
00574
00575     if (m_technique == RenderTechnique::GeometryShader)
00576     {
00577         unsigned int stride = sizeof(InstanceData);
00578         unsigned int offset = 0;
00579         m_d3dContext->IASetVertexBuffers(
00580             0,
00581             1,
00582             m_instanceDataBuffer.GetAddressOf(),
00583             &stride,
00584             &offset
00585             );
00586     }
00587     else if (m_technique == RenderTechnique::Instancing)
00588     {
00589         unsigned int stride = sizeof(InstancingVertex);
00590         unsigned int offset = 0;
00591         m_d3dContext->IASetVertexBuffers(
00592             0,
00593             1,
00594             m_vertexBuffer.GetAddressOf(),
00595             &stride,
00596             &offset
00597             );
00598     }
00599     else if (m_technique == RenderTechnique::Replication)
00600     {
00601         unsigned int stride = sizeof(ReplicationVertex);
00602         unsigned int offset = 0;
00603         m_d3dContext->IASetVertexBuffers(
00604             0,
00605             1,
00606             m_vertexBuffer.GetAddressOf(),
00607             &stride,
00608             &offset
00609             );
00610     }
00611
00612     // Draw each sprite run
00613
00614     unsigned int indexBase = 0;
00615     for (auto runIterator = m_spriteRuns.begin(); runIterator != m_spriteRuns.end(); runIterator++)
00616     {
00617         m_d3dContext->PSSetShaderResources(
00618             0,
00619             1,
00620             &runIterator->textureView
00621             );
00622
00623         const FLOAT blendFactor[] = {0.0f, 0.0f, 0.0f, 0.0f};
00624
00625         m_d3dContext->OMSetBlendState(
00626             runIterator->blendState,
00627             nullptr,
00628             0xFFFFFFFF
00629             );
00630
00631         if (m_technique == RenderTechnique::GeometryShader)
00632         {
00633             unsigned int instancesToDraw = runIterator->numSprites;
00634             m_d3dContext->DrawInstanced(
00635                 1,
00636                 instancesToDraw,
00637                 0,
00638                 indexBase
00639                 );
00640             indexBase += instancesToDraw;
00641         }
00642         else if (m_technique == RenderTechnique::Instancing)
00643         {
00644             unsigned int instancesToDraw = runIterator->numSprites;
00645             unsigned int stride = sizeof(InstanceData);
00646             unsigned int offset = indexBase * stride;
00647             // Instance data offset must be zero for the draw call on feature level 9.3 and below.
00648             // Instead, set the offset in the input assembler.
00649             m_d3dContext->IASetVertexBuffers(
00650                 1,
00651                 1,
00652                 m_instanceDataBuffer.GetAddressOf(),
00653                 &stride,
00654                 &offset
00655                 );
00656             m_d3dContext->DrawIndexedInstanced(
00657                 6,
00658                 instancesToDraw,
00659                 0,
00660                 0,
00661                 0
00662                 );
00663             indexBase += instancesToDraw;
00664         }
00665         else if (m_technique == RenderTechnique::Replication)
00666         {
00667             unsigned int indicesToDraw = runIterator->numSprites * 6;
00668             m_d3dContext->DrawIndexed(indicesToDraw, indexBase, 0);
00669             indexBase += indicesToDraw;
00670         }
00671     }
00672 }
00673
00674 unsigned int SpriteBatch::MakeUnorm(float4 color)
00675 {
00676     unsigned int r = max(0, min(255, static_cast<unsigned int>(color.r * 255.0f)));
00677     unsigned int g = max(0, min(255, static_cast<unsigned int>(color.g * 255.0f)));
00678     unsigned int b = max(0, min(255, static_cast<unsigned int>(color.b * 255.0f)));
00679     unsigned int a = max(0, min(255, static_cast<unsigned int>(color.a * 255.0f)));
00680     return
00681         (a << 24) |
00682         (b << 16) |
00683         (g << 8) |
00684         r;
00685 }
00686
00687 float2 SpriteBatch::StandardOrigin(float2 position, PositionUnits positionUnits, float2 renderTargetSize, float dpi)
00688 {
00689     float2 origin;
00690     if (positionUnits == PositionUnits::Pixels)
00691     {
00692         origin.x = (position.x / renderTargetSize.x) * 2.0f - 1.0f;
00693         origin.y = 1.0f - (position.y / renderTargetSize.y) * 2.0f;
00694     }
00695     else if (positionUnits == PositionUnits::DIPs)
00696     {
00697         origin.x = ((position.x * dpi / 96.0f) / renderTargetSize.x) * 2.0f - 1.0f;
00698         origin.y = 1.0f - ((position.y * dpi / 96.0f) / renderTargetSize.y) * 2.0f;
00699     }
00700     else if (positionUnits == PositionUnits::Normalized)
00701     {
00702         origin.x = position.x * 2.0f - 1.0f;
00703         origin.y = 1.0f - position.y * 2.0f;
00704     }
00705     else if (positionUnits == PositionUnits::UniformWidth)
00706     {
00707         origin.x = position.x * 2.0f - 1.0f;
00708         origin.y = 1.0f - position.y * (renderTargetSize.x / renderTargetSize.y) * 2.0f;
00709     }
00710     else if (positionUnits == PositionUnits::UniformHeight)
00711     {
00712         origin.x = position.x * (renderTargetSize.y / renderTargetSize.x) * 2.0f - 1.0f;
00713         origin.y = 1.0f - position.y * 2.0f;
00714     }
00715     return origin;
00716 }
00717
00718 float2 SpriteBatch::StandardOffset(float2 size, SizeUnits sizeUnits, float2 spriteSize, float dpi)
00719 {
00720     float2 offset;
00721     if (sizeUnits == SizeUnits::Pixels)
00722     {
00723         offset = size;
00724     }
00725     else if (sizeUnits == SizeUnits::DIPs)
00726     {
00727         offset = size * dpi / 96.0f;
00728     }
00729     else if (sizeUnits == SizeUnits::Normalized)
00730     {
00731         offset = spriteSize * size;
00732     }
00733     return offset;
00734 }
00735
00736 void SpriteBatch::Draw(
00737     _In_ ID3D11Texture2D* texture,
00738     _In_ float2 position,
00739     _In_ PositionUnits positionUnits = PositionUnits::DIPs
00740     )
00741 {
00742     Draw(
00743         texture,
00744         position,
00745         positionUnits,
00746         float2(1.0f, 1.0f),
00747         SizeUnits::Normalized
00748         );
00749 }
00750
00751 void SpriteBatch::Draw(
00752     _In_ ID3D11Texture2D* texture,
00753     _In_ float2 position,
00754     _In_ PositionUnits positionUnits,
00755     _In_ float2 size,
00756     _In_ SizeUnits sizeUnits
00757     )
00758 {
00759     Draw(
00760         texture,
00761         position,
00762         positionUnits,
00763         size,
00764         sizeUnits,
00765         float4(1.0f, 1.0f, 1.0f, 1.0f)
00766         );
00767 }
00768
00769 void SpriteBatch::Draw(
00770     _In_ ID3D11Texture2D* texture,
00771     _In_ float2 position,
00772     _In_ PositionUnits positionUnits,
00773     _In_ float2 size,
00774     _In_ SizeUnits sizeUnits,
00775     _In_ float4 color
00776     )
00777 {
00778     Draw(
00779         texture,
00780         position,
00781         positionUnits,
00782         size,
00783         sizeUnits,
00784         color,
00785         0.0f
00786         );
00787 }
00788
00789 void SpriteBatch::Draw(
00790     _In_ ID3D11Texture2D* texture,
00791     _In_ float2 position,
00792     _In_ PositionUnits positionUnits,
00793     _In_ float2 size,
00794     _In_ SizeUnits sizeUnits,
00795     _In_ float4 color,
00796     _In_ float rotation
00797     )
00798 {
00799     Draw(
00800         texture,
00801         position,
00802         positionUnits,
00803         size,
00804         sizeUnits,
00805         color,
00806         rotation,
00807         BlendMode::Alpha
00808         );
00809 }
00810
00811 void SpriteBatch::Draw(
00812     _In_ ID3D11Texture2D* texture,
00813     _In_ float2 position,
00814     _In_ PositionUnits positionUnits,
00815     _In_ float2 size,
00816     _In_ SizeUnits sizeUnits,
00817     _In_ float4 color,
00818     _In_ float rotation,
00819     _In_ BlendMode blendMode
00820     )
00821 {
00822     // Fail if drawing this sprite would exceed the capacity of the sprite batch.
00823     if (m_numSpritesDrawn >= m_capacity)
00824     {
00825         throw ref new Platform::OutOfBoundsException();
00826     }
00827
00828     // Retrieve information about the sprite.
00829     TextureMapElement element = m_textureMap[texture];
00830     ID3D11ShaderResourceView* textureView = element.srv.Get();
00831     float2 textureSize = element.size;
00832     ID3D11BlendState1* blendState = blendMode == BlendMode::Additive ? m_blendStateAdditive.Get() : m_blendStateAlpha.Get();
00833
00834     // Fail if the texture has not previously been added to the sprite batch.
00835     if (textureView == nullptr)
00836     {
00837         throw ref new Platform::NullReferenceException();
00838     }
00839
00840     // Unless this is the first sprite run, save out the previous run info if a new run is required.
00841     if (
00842         m_numSpritesDrawn > 0 && (
00843             textureView != m_currentTextureView ||
00844             blendState != m_currentBlendState
00845             )
00846         )
00847     {
00848         SpriteRunInfo runInfo;
00849         runInfo.textureView = m_currentTextureView;
00850         runInfo.blendState = m_currentBlendState;
00851         runInfo.numSprites = m_spritesInRun;
00852         m_spriteRuns.push_back(runInfo);
00853         m_spritesInRun = 0; // Reset for the next sprite run.
00854     }
00855     m_currentTextureView = textureView;
00856     m_currentBlendState = blendState;
00857
00858     // Add the sprite to the buffer.
00859
00860     float2 origin = StandardOrigin(position, positionUnits, m_renderTargetSize, m_dpi);
00861     float2 offset = StandardOffset(size, sizeUnits, textureSize, m_dpi);
00862
00863     if (m_technique == RenderTechnique::GeometryShader || m_technique == RenderTechnique::Instancing)
00864     {
00865         m_instanceData[m_numSpritesDrawn].origin = origin;
00866         m_instanceData[m_numSpritesDrawn].offset = offset;
00867         m_instanceData[m_numSpritesDrawn].rotation = rotation;
00868         m_instanceData[m_numSpritesDrawn].color = MakeUnorm(color);
00869     }
00870     else if (m_technique == RenderTechnique::Replication)
00871     {
00872         float2 offsets[4] =
00873         {
00874             float2(-offset.x,  offset.y),
00875             float2( offset.x,  offset.y),
00876             float2(-offset.x, -offset.y),
00877             float2( offset.x, -offset.y)
00878         };
00879
00880         float sinRotation = sinf(rotation);
00881         float cosRotation = cosf(rotation);
00882
00883         for (int i = 0; i < 4; i++)
00884         {
00885             offsets[i] = float2(
00886                 offsets[i].x * cosRotation - offsets[i].y * sinRotation,
00887                 offsets[i].x * sinRotation + offsets[i].y * cosRotation
00888                 );
00889             offsets[i].x /= m_renderTargetSize.x;
00890             offsets[i].y /= m_renderTargetSize.y;
00891         }
00892
00893         // Write vertex buffer data.
00894
00895         ReplicationVertex* singleSpriteVertices = &m_vertexData[m_numSpritesDrawn * 4];
00896         unsigned int colorUnorm = MakeUnorm(color);
00897         singleSpriteVertices[0].pos = origin + offsets[0];
00898         singleSpriteVertices[1].pos = origin + offsets[1];
00899         singleSpriteVertices[2].pos = origin + offsets[2];
00900         singleSpriteVertices[3].pos = origin + offsets[3];
00901         singleSpriteVertices[0].color = colorUnorm;
00902         singleSpriteVertices[1].color = colorUnorm;
00903         singleSpriteVertices[2].color = colorUnorm;
00904         singleSpriteVertices[3].color = colorUnorm;
00905         singleSpriteVertices[0].tex = float2(0.0f, 0.0f);
00906         singleSpriteVertices[1].tex = float2(1.0f, 0.0f);
00907         singleSpriteVertices[2].tex = float2(0.0f, 1.0f);
00908         singleSpriteVertices[3].tex = float2(1.0f, 1.0f);
00909     }
00910
00911     m_spritesInRun++;
00912     m_numSpritesDrawn++;
00913 }
Generated on Sat Nov 23 2024 16:08:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/App.xaml.h Source File

  • Snap

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/DirectXSample.h Source File

  • Direct2D effects on primitives

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/SimpleController.h Source File

  • XInput game controller

SimpleController.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012
00013 ref class SimpleController : public DirectXBase
00014 {
00015 internal:
00016     SimpleController();
00017
00018     // Overrides from DirectXBase
00019     virtual void CreateDeviceResources() override;
00020     virtual void CreateWindowSizeDependentResources() override;
00021     virtual void Render() override;
00022
00023     void Update(float timeTotal, float timeDelta);
00024
00025 private:
00026     // Input functionality
00027     void FetchControllerInput();
00028     void RenderControllerInput();
00029
00030     // Functions for drawing information on screen
00031     void DrawHeader(const wchar_t* pText, const D2D1_RECT_F& loc);
00032     void DrawText(const wchar_t* pText, const D2D1_RECT_F& loc);
00033     void DrawText(uint32 value, const D2D1_RECT_F& loc);
00034     void DrawText(int16 value, const D2D1_RECT_F& loc);
00035     void DrawText(uint8 value, const D2D1_RECT_F& loc);
00036     void DrawButtonText(uint16 buttons, const D2D1_RECT_F& loc);
00037
00038     // Overlay for default sample graphics
00039     SampleOverlay^          m_sampleOverlay;
00040
00041     // Input related members
00042     bool                    m_isControllerConnected;  // Do we have a controller connected
00043     XINPUT_CAPABILITIES     m_xinputCaps;             // Capabilites of the controller
00044     XINPUT_STATE            m_xinputState;            // The current state of the controller
00045     uint64                  m_lastEnumTime;           // Last time a new controller connection was checked
00046
00047     // Members for drawing
00048     Microsoft::WRL::ComPtr<IDWriteTextFormat>       m_headerTextFormat;
00049     Microsoft::WRL::ComPtr<IDWriteTextFormat>       m_dataTextFormat;
00050     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_textBrush;
00051 };
Generated on Sat Nov 23 2024 16:08:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario1.xaml.cpp Source File

  • File picker

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::FilePicker;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::Pickers;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 Scenario1::Scenario1()
00030 {
00031     InitializeComponent();
00032     rootPage = MainPage::Current;
00033     PickAFileButton->Click += ref new RoutedEventHandler(this, &Scenario1::PickAFileButton_Click);
00034 }
00035
00036 void Scenario1::PickAFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00037 {
00038     // Clear previous returned file name, if it exists, between iterations of this scenario
00039     rootPage->ResetScenarioOutput(OutputTextBlock);
00040
00041     if (rootPage->EnsureUnsnapped())
00042     {
00043         FileOpenPicker^ openPicker = ref new FileOpenPicker();
00044         openPicker->ViewMode = PickerViewMode::Thumbnail;
00045         openPicker->SuggestedStartLocation = PickerLocationId::PicturesLibrary;
00046         openPicker->FileTypeFilter->Append(".jpg");
00047         openPicker->FileTypeFilter->Append(".jpeg");
00048         openPicker->FileTypeFilter->Append(".png");
00049
00050         create_task(openPicker->PickSingleFileAsync()).then([this](StorageFile^ file)
00051         {
00052             if (file)
00053             {
00054                 OutputTextBlock->Text = "Picked photo: " + file->Name;
00055             }
00056             else
00057             {
00058                 OutputTextBlock->Text = "Operation cancelled.";
00059             }
00060         });
00061     }
00062 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/DirectXBase.h Source File

  • Direct2D convolve matrix effect

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Common/LinkList.h Source File

  • Media extensions
  • MediaExtensions
  • Common

LinkList.h

Go to the documentation of this file.
00001 //-----------------------------------------------------------------------------
00002 // File: Linklist.h
00003 // Desc: Linked list class.
00004 //
00005 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00006 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00007 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00008 // PARTICULAR PURPOSE.
00009 //
00010 //  Copyright (C) Microsoft Corporation. All rights reserved.
00011 //-----------------------------------------------------------------------------
00012
00013 #pragma once
00014
00015 // Notes:
00016 //
00017 // The List class template implements a simple double-linked list.
00018 // It uses STL's copy semantics.
00019
00020 // There are two versions of the Clear() method:
00021 //  Clear(void) clears the list w/out cleaning up the object.
00022 //  Clear(FN fn) takes a functor object that releases the objects, if they need cleanup.
00023
00024 // The List class supports enumeration. Example of usage:
00025 //
00026 // List<T>::POSIITON pos = list.GetFrontPosition();
00027 // while (pos != list.GetEndPosition())
00028 // {
00029 //     T item;
00030 //     hr = list.GetItemPos(&item);
00031 //     pos = list.Next(pos);
00032 // }
00033
00034 // The ComPtrList class template derives from List<> and implements a list of COM pointers.
00035
00036 template <class T>
00037 struct NoOp
00038 {
00039     void operator()(T& t)
00040     {
00041     }
00042 };
00043
00044 template <class T>
00045 class List
00046 {
00047 protected:
00048
00049     // Nodes in the linked list
00050     struct Node
00051     {
00052         Node *prev;
00053         Node *next;
00054         T    item;
00055
00056         Node() : prev(nullptr), next(nullptr)
00057         {
00058         }
00059
00060         Node(T item) : prev(nullptr), next(nullptr)
00061         {
00062             this->item = item;
00063         }
00064
00065         T Item() const { return item; }
00066     };
00067
00068 public:
00069
00070     // Object for enumerating the list.
00071     class POSITION
00072     {
00073         friend class List<T>;
00074
00075     public:
00076         POSITION() : pNode(nullptr)
00077         {
00078         }
00079
00080         bool operator==(const POSITION &p) const
00081         {
00082             return pNode == p.pNode;
00083         }
00084
00085         bool operator!=(const POSITION &p) const
00086         {
00087             return pNode != p.pNode;
00088         }
00089
00090     private:
00091         const Node *pNode;
00092
00093         POSITION(Node *p) : pNode(p)
00094         {
00095         }
00096     };
00097
00098 protected:
00099     Node    m_anchor;  // Anchor node for the linked list.
00100     DWORD   m_count;   // Number of items in the list.
00101
00102     Node* Front() const
00103     {
00104         return m_anchor.next;
00105     }
00106
00107     Node* Back() const
00108     {
00109         return m_anchor.prev;
00110     }
00111
00112     virtual HRESULT InsertAfter(T item, Node *pBefore)
00113     {
00114         if (pBefore == nullptr)
00115         {
00116             return E_POINTER;
00117         }
00118
00119         Node *pNode = new Node(item);
00120         if (pNode == nullptr)
00121         {
00122             return E_OUTOFMEMORY;
00123         }
00124
00125         Node *pAfter = pBefore->next;
00126
00127         pBefore->next = pNode;
00128         pAfter->prev = pNode;
00129
00130         pNode->prev = pBefore;
00131         pNode->next = pAfter;
00132
00133         m_count++;
00134
00135         return S_OK;
00136     }
00137
00138     virtual HRESULT GetItem(const Node *pNode, T* ppItem)
00139     {
00140         if (pNode == nullptr || ppItem == nullptr)
00141         {
00142             return E_POINTER;
00143         }
00144
00145         *ppItem = pNode->item;
00146         return S_OK;
00147     }
00148
00149     // RemoveItem:
00150     // Removes a node and optionally returns the item.
00151     // ppItem can be nullptr.
00152     virtual HRESULT RemoveItem(Node *pNode, T *ppItem)
00153     {
00154         if (pNode == nullptr)
00155         {
00156             return E_POINTER;
00157         }
00158
00159         assert(pNode != &m_anchor); // We should never try to remove the anchor node.
00160         if (pNode == &m_anchor)
00161         {
00162             return E_INVALIDARG;
00163         }
00164
00165
00166         T item;
00167
00168         // The next node's previous is this node's previous.
00169         pNode->next->prev = pNode->prev;
00170
00171         // The previous node's next is this node's next.
00172         pNode->prev->next = pNode->next;
00173
00174         item = pNode->item;
00175         delete pNode;
00176
00177         m_count--;
00178
00179         if (ppItem)
00180         {
00181             *ppItem = item;
00182         }
00183
00184         return S_OK;
00185     }
00186
00187 public:
00188
00189     List()
00190     {
00191         m_anchor.next = &m_anchor;
00192         m_anchor.prev = &m_anchor;
00193
00194         m_count = 0;
00195     }
00196
00197     virtual ~List()
00198     {
00199         Clear();
00200     }
00201
00202     // Insertion functions
00203     HRESULT InsertBack(T item)
00204     {
00205         return InsertAfter(item, m_anchor.prev);
00206     }
00207
00208
00209     HRESULT InsertFront(T item)
00210     {
00211         return InsertAfter(item, &m_anchor);
00212     }
00213
00214     HRESULT InsertPos(POSITION pos, T item)
00215     {
00216         if (pos.pNode == nullptr)
00217         {
00218             return InsertBack(item);
00219         }
00220
00221         return InsertAfter(item, pos.pNode->prev);
00222     }
00223
00224     // RemoveBack: Removes the tail of the list and returns the value.
00225     // ppItem can be nullptr if you don't want the item back. (But the method does not release the item.)
00226     HRESULT RemoveBack(T *ppItem)
00227     {
00228         if (IsEmpty())
00229         {
00230             return E_FAIL;
00231         }
00232         else
00233         {
00234             return RemoveItem(Back(), ppItem);
00235         }
00236     }
00237
00238     // RemoveFront: Removes the head of the list and returns the value.
00239     // ppItem can be nullptr if you don't want the item back. (But the method does not release the item.)
00240     HRESULT RemoveFront(T *ppItem)
00241     {
00242         if (IsEmpty())
00243         {
00244             return E_FAIL;
00245         }
00246         else
00247         {
00248             return RemoveItem(Front(), ppItem);
00249         }
00250     }
00251
00252     // GetBack: Gets the tail item.
00253     HRESULT GetBack(T *ppItem)
00254     {
00255         if (IsEmpty())
00256         {
00257             return E_FAIL;
00258         }
00259         else
00260         {
00261             return GetItem(Back(), ppItem);
00262         }
00263     }
00264
00265     // GetFront: Gets the front item.
00266     HRESULT GetFront(T *ppItem)
00267     {
00268         if (IsEmpty())
00269         {
00270             return E_FAIL;
00271         }
00272         else
00273         {
00274             return GetItem(Front(), ppItem);
00275         }
00276     }
00277
00278
00279     // GetCount: Returns the number of items in the list.
00280     DWORD GetCount() const { return m_count; }
00281
00282     bool IsEmpty() const
00283     {
00284         return (GetCount() == 0);
00285     }
00286
00287     // Clear: Takes a functor object whose operator()
00288     // frees the object on the list.
00289     template <class FN>
00290     void Clear(FN& clear_fn)
00291     {
00292         Node *n = m_anchor.next;
00293
00294         // Delete the nodes
00295         while (n != &m_anchor)
00296         {
00297             clear_fn(n->item);
00298
00299             Node *tmp = n->next;
00300             delete n;
00301             n = tmp;
00302         }
00303
00304         // Reset the anchor to point at itself
00305         m_anchor.next = &m_anchor;
00306         m_anchor.prev = &m_anchor;
00307
00308         m_count = 0;
00309     }
00310
00311     // Clear: Clears the list. (Does not delete or release the list items.)
00312     virtual void Clear()
00313     {
00314         NoOp<T> clearOp;
00315         Clear<>(clearOp);
00316     }
00317
00318
00319     // Enumerator functions
00320
00321     POSITION FrontPosition()
00322     {
00323         if (IsEmpty())
00324         {
00325             return POSITION(nullptr);
00326         }
00327         else
00328         {
00329             return POSITION(Front());
00330         }
00331     }
00332
00333     POSITION EndPosition() const
00334     {
00335         return POSITION();
00336     }
00337
00338     HRESULT GetItemPos(POSITION pos, T *ppItem)
00339     {
00340         if (pos.pNode)
00341         {
00342             return GetItem(pos.pNode, ppItem);
00343         }
00344         else
00345         {
00346             return E_FAIL;
00347         }
00348     }
00349
00350     POSITION Next(const POSITION pos)
00351     {
00352         if (pos.pNode && (pos.pNode->next != &m_anchor))
00353         {
00354             return POSITION(pos.pNode->next);
00355         }
00356         else
00357         {
00358             return POSITION(nullptr);
00359         }
00360     }
00361
00362     // Remove an item at a position.
00363     // The item is returns in ppItem, unless ppItem is nullptr.
00364     // NOTE: This method invalidates the POSITION object.
00365     HRESULT Remove(POSITION& pos, T *ppItem)
00366     {
00367         if (pos.pNode)
00368         {
00369             // Remove const-ness temporarily...
00370             Node *pNode = const_cast<Node*>(pos.pNode);
00371
00372             pos = POSITION();
00373
00374             return RemoveItem(pNode, ppItem);
00375         }
00376         else
00377         {
00378             return E_INVALIDARG;
00379         }
00380     }
00381
00382 };
00383
00384
00385
00386 // Typical functors for Clear method.
00387
00388 // ComAutoRelease: Releases COM pointers.
00389 // MemDelete: Deletes pointers to new'd memory.
00390
00391 class ComAutoRelease
00392 {
00393 public:
00394     void operator()(IUnknown *p)
00395     {
00396         if (p)
00397         {
00398             p->Release();
00399         }
00400     }
00401 };
00402
00403 class MemDelete
00404 {
00405 public:
00406     void operator()(void *p)
00407     {
00408         if (p)
00409         {
00410             delete p;
00411         }
00412     }
00413 };
00414
00415
00416 // ComPtrList class
00417 // Derived class that makes it safer to store COM pointers in the List<> class.
00418 // It automatically AddRef's the pointers that are inserted onto the list
00419 // (unless the insertion method fails).
00420 //
00421 // T must be a COM interface type.
00422 // example: ComPtrList<IUnknown>
00423 //
00424 // NULLABLE: If true, client can insert nullptr pointers. This means GetItem can
00425 // succeed but return a nullptr pointer. By default, the list does not allow nullptr
00426 // pointers.
00427
00428 template <class T, bool NULLABLE = FALSE>
00429 class ComPtrList : public List<T*>
00430 {
00431 public:
00432
00433     typedef T* Ptr;
00434
00435     void Clear()
00436     {
00437         ComAutoRelease car;
00438         List<Ptr>::Clear(car);
00439     }
00440
00441     ~ComPtrList()
00442     {
00443         Clear();
00444     }
00445
00446 protected:
00447     HRESULT InsertAfter(Ptr item, Node *pBefore)
00448     {
00449         // Do not allow nullptr item pointers unless NULLABLE is true.
00450         if (item == nullptr && !NULLABLE)
00451         {
00452             return E_POINTER;
00453         }
00454
00455         if (item)
00456         {
00457             item->AddRef();
00458         }
00459
00460         HRESULT hr = List<Ptr>::InsertAfter(item, pBefore);
00461         if (FAILED(hr) && item != nullptr)
00462         {
00463             item->Release();
00464         }
00465         return hr;
00466     }
00467
00468     HRESULT GetItem(const Node *pNode, Ptr* ppItem)
00469     {
00470         Ptr pItem = nullptr;
00471
00472         // The base class gives us the pointer without AddRef'ing it.
00473         // If we return the pointer to the caller, we must AddRef().
00474         HRESULT hr = List<Ptr>::GetItem(pNode, &pItem);
00475         if (SUCCEEDED(hr))
00476         {
00477             assert(pItem || NULLABLE);
00478             if (pItem)
00479             {
00480                 *ppItem = pItem;
00481                 (*ppItem)->AddRef();
00482             }
00483         }
00484         return hr;
00485     }
00486
00487     HRESULT RemoveItem(Node *pNode, Ptr *ppItem)
00488     {
00489         // ppItem can be nullptr, but we need to get the
00490         // item so that we can release it.
00491
00492         // If ppItem is not nullptr, we will AddRef it on the way out.
00493
00494         Ptr pItem = nullptr;
00495
00496         HRESULT hr = List<Ptr>::RemoveItem(pNode, &pItem);
00497
00498         if (SUCCEEDED(hr))
00499         {
00500             assert(pItem || NULLABLE);
00501             if (ppItem && pItem)
00502             {
00503                 *ppItem = pItem;
00504                 (*ppItem)->AddRef();
00505             }
00506
00507             if (pItem)
00508             {
00509                 pItem->Release();
00510                 pItem = nullptr;
00511             }
00512         }
00513
00514         return hr;
00515     }
00516 };
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Presets.xaml.h Source File

  • Transcoding media

Presets.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Presets.xaml.h
00013 // Declaration of the Presets class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Presets.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Transcode
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Presets sealed
00031         {
00032         public:
00033             Presets();
00034         protected:
00035             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036
00037         private:
00038             void GetPresetProfile(Windows::UI::Xaml::Controls::ComboBox^ comboBox);
00039             void PickFile(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void OnTargetFormatChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00041             void SetPickFileButton(bool isEnabled);
00042             void StopPlayers();
00043             void PlayFile(Windows::Storage::StorageFile^ MediaFile);
00044
00045             void TranscodePreset(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046             void TranscodeCancel(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void TranscodeProgress(Windows::Foundation::IAsyncActionWithProgress<double>^ asyncInfo, double percent);
00048             void TranscodeError(Platform::String^ error);
00049             void TranscodeFailure(Windows::Media::Transcoding::TranscodeFailureReason reason);
00050             void SetCancelButton(bool isEnabled);
00051             void EnableButtons();
00052             void DisableButtons();
00053
00054             // Media Controls
00055             void InputPlayButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00056             void InputPauseButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00057             void InputStopButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00058             void OutputPlayButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00059             void OutputPauseButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00060             void OutputStopButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061
00062             Platform::String^ _OutputFileName;
00063             Windows::Media::MediaProperties::MediaEncodingProfile^ _Profile;
00064             Windows::Storage::StorageFile^ _InputFile;
00065             Windows::Storage::StorageFile^ _OutputFile;
00066             Windows::Media::Transcoding::MediaTranscoder^ _Transcoder;
00067             Concurrency::cancellation_token_source _CTS;
00068
00069             bool _UseMp4;
00070
00071             MainPage^ rootPage;
00072         };
00073     }
00074 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario1.xaml.cpp Source File

  • File and folder thumbnail

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::FileThumbnails;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::FileProperties;
00025 using namespace Windows::Storage::Pickers;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario1::Scenario1()
00031 {
00032     InitializeComponent();
00033     rootPage = MainPage::Current;
00034     GetThumbnailButton->Click += ref new RoutedEventHandler(this, &Scenario1::GetThumbnailButton_Click);
00035 }
00036
00037 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     rootPage->ResetOutput(ThumbnailImage, OutputTextBlock, nullptr);
00040 }
00041
00042 void Scenario1::GetThumbnailButton_Click(Object^ sender, RoutedEventArgs^ e)
00043 {
00044     rootPage->ResetOutput(ThumbnailImage, OutputTextBlock, nullptr);
00045
00046     if (rootPage->EnsureUnsnapped())
00047     {
00048         // Pick a photo
00049         FileOpenPicker^ openPicker = ref new FileOpenPicker();
00050         Array<String^>^ extensions = FileExtensions::Image;
00051         for (unsigned int i = 0; i < extensions->Length; i++)
00052         {
00053             openPicker->FileTypeFilter->Append(extensions[i]);
00054         }
00055
00056         String^ thumbnailModeName = ((ComboBoxItem^)ModeComboBox->SelectedItem)->Name;
00057         ThumbnailMode thumbnailMode = ThumbnailMode::ListView;
00058         if (thumbnailModeName == "ListView")
00059         {
00060             thumbnailMode = ThumbnailMode::ListView;
00061         }
00062         if (thumbnailModeName == "PicturesView")
00063         {
00064             thumbnailMode = ThumbnailMode::PicturesView;
00065         }
00066         else if (thumbnailModeName == "SingleItem")
00067         {
00068             thumbnailMode = ThumbnailMode::SingleItem;
00069         }
00070
00071         bool fastThumbnail = FastThumbnailCheckBox->IsChecked->Value;
00072         ThumbnailOptions thumbnailOptions = ThumbnailOptions::UseCurrentScale;
00073         if (fastThumbnail)
00074         {
00075             thumbnailOptions = thumbnailOptions | ThumbnailOptions::ReturnOnlyIfCached;
00076         }
00077
00078         create_task(openPicker->PickSingleFileAsync()).then([this, thumbnailMode, thumbnailModeName, thumbnailOptions, fastThumbnail](StorageFile^ file)
00079         {
00080             if (file != nullptr)
00081             {
00082                 const size_t size = 200;
00083                 create_task(file->GetThumbnailAsync(thumbnailMode, size, thumbnailOptions)).then([this, file, thumbnailMode, thumbnailModeName, thumbnailOptions, fastThumbnail, size](StorageItemThumbnail^ thumbnail)
00084                 {
00085                     if (thumbnail != nullptr)
00086                     {
00087                         MainPage::DisplayResult(ThumbnailImage, OutputTextBlock, thumbnailModeName, size, file, thumbnail, false);
00088                     }
00089                     else if (fastThumbnail)
00090                     {
00091                         rootPage->NotifyUser(Errors::NoExifThumbnail, NotifyType::StatusMessage);
00092                     }
00093                     else
00094                     {
00095                         rootPage->NotifyUser(Errors::NoThumbnail, NotifyType::StatusMessage);
00096                     }
00097                 });
00098             }
00099             else
00100             {
00101                 rootPage->NotifyUser(Errors::Cancel, NotifyType::StatusMessage);
00102             }
00103         });
00104     }
00105 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/Constants.cpp Source File

  • UI contrast and settings

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "UI Settings", "SDKSample.HighContrast.UI" },
00022   { "Accessibility Settings", "SDKSample.HighContrast.Accessibility" }
00023 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/pch.cpp Source File

  • Compression

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageView.xaml.cpp Source File

  • Hilo C++
  • Hilo

ImageView.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "ImageView.xaml.h"
00009 #include "ImageViewModel.h"
00010
00011 using namespace Hilo;
00012 using namespace Platform;
00013 using namespace Windows::UI::Input;
00014 using namespace Windows::UI::Xaml;
00015 using namespace Windows::UI::Xaml::Input;
00016
00017 ImageView::ImageView() : m_pointerPressed(false)
00018 {
00019     InitializeComponent();
00020
00021     m_filmStripLoadedToken = PhotosFilmStripGridView->Loaded::add(ref new RoutedEventHandler(this, &ImageView::OnFilmStripLoaded));
00022 }
00023
00024 ImageView::~ImageView()
00025 {
00026     if (nullptr != PhotosFilmStripGridView)
00027     {
00028         // Remove the event handler on the UI thread because GridView methods
00029         // must be called on the UI thread.
00030         auto photosFilmStripGridView = PhotosFilmStripGridView;
00031         auto filmStripLoadedToken = m_filmStripLoadedToken;
00032         run_async_non_interactive([photosFilmStripGridView, filmStripLoadedToken]()
00033         {
00034             photosFilmStripGridView->Loaded::remove(filmStripLoadedToken);
00035         });
00036     }
00037 }
00038
00039 // Scrolls the selected item into view after the collection is likely to have loaded.
00040 void ImageView::OnFilmStripLoaded(Object^ sender, RoutedEventArgs^ e)
00041 {
00042     auto vm = dynamic_cast<ImageViewModel^>(DataContext);
00043     if (vm != nullptr)
00044     {
00045         PhotosFilmStripGridView->ScrollIntoView(vm->SelectedItem);
00046     }
00047
00048     PhotosFilmStripGridView->Loaded::remove(m_filmStripLoadedToken);
00049 }
00050
00051 void Hilo::ImageView::OnImagePointerPressed(Object^ sender, PointerRoutedEventArgs^ e)
00052 {
00053     m_pointerPressed = true;
00054     PointerPoint^ point = e->GetCurrentPoint(PhotoGrid);
00055     m_pointer = point->Position;
00056     if (point->Properties->IsLeftButtonPressed)
00057     {
00058         ImageViewFileInformationPopup->HorizontalOffset = point->Position.X - 200;
00059         ImageViewFileInformationPopup->VerticalOffset = point->Position.Y - 200;
00060         ImageViewFileInformationPopup->IsOpen = true;
00061     }
00062 }
00063
00064 void Hilo::ImageView::OnImagePointerReleased(Object^ sender, PointerRoutedEventArgs^ e)
00065 {
00066     if (m_pointerPressed)
00067     {
00068         ImageViewFileInformationPopup->IsOpen = false;
00069         m_pointerPressed = false;
00070     }
00071 }
00072
00073 void Hilo::ImageView::OnImagePointerMoved(Object^ sender, PointerRoutedEventArgs^ e)
00074 {
00075     if (m_pointerPressed)
00076     {
00077         PointerPoint^ point = e->GetCurrentPoint(PhotoGrid);
00078         if (point->Position != m_pointer)
00079         {
00080             OnImagePointerReleased(sender, e);
00081         }
00082     }
00083 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PostcardRenderer.cpp Source File

  • DirectX postcard app

PostcardRenderer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "PostcardRenderer.h"
00010
00011 using namespace concurrency;
00012 using namespace Microsoft::WRL;
00013 using namespace Platform;
00014 using namespace Windows::ApplicationModel;
00015 using namespace Windows::ApplicationModel::Activation;
00016 using namespace Windows::ApplicationModel::Core;
00017 using namespace Windows::ApplicationModel::DataTransfer;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Graphics::Display;
00020 using namespace Windows::Storage;
00021 using namespace Windows::Storage::Pickers;
00022 using namespace Windows::Storage::Streams;
00023 using namespace Windows::UI::ApplicationSettings;
00024 using namespace Windows::UI::Core;
00025 using namespace Windows::UI::Input;
00026 using namespace Windows::UI::Input::Inking;
00027 using namespace Windows::UI::ViewManagement;
00028 using namespace Windows::UI::Xaml::Controls;
00029 using namespace Windows::UI::Xaml::Input;
00030
00031 PostcardRenderer::PostcardRenderer() :
00032     m_sampleMode(SampleMode::Ready)
00033 {
00034     m_imageRenderer = ref new ImageRenderer();
00035     m_paperRenderer = ref new PaperRenderer();
00036     m_extrudedTextRenderer = ref new ExtrudedTextRenderer();
00037     m_inkRenderer = ref new InkRenderer();
00038 }
00039
00040 void PostcardRenderer::CreateDeviceIndependentResources()
00041 {
00042     DirectXBase::CreateDeviceIndependentResources();
00043
00044     m_imageRenderer->CreateDeviceIndependentResources(m_wicFactory);
00045     m_paperRenderer->CreateDeviceIndependentResources(m_d2dFactory);
00046     m_extrudedTextRenderer->CreateDeviceIndependentResources(m_d2dFactory, m_dwriteFactory);
00047     m_inkRenderer->CreateDeviceIndependentResources(m_d2dFactory);
00048 }
00049
00050 void PostcardRenderer::CreateDeviceResources()
00051 {
00052     DirectXBase::CreateDeviceResources();
00053
00054     m_imageRenderer->CreateDeviceResources(m_d2dContext);
00055     m_paperRenderer->CreateDeviceResources(m_d2dContext);
00056     m_extrudedTextRenderer->CreateDeviceResources(m_d3dDevice, m_d3dContext);
00057     m_inkRenderer->CreateDeviceResources(m_d2dContext);
00058 }
00059
00060 void PostcardRenderer::CreateWindowSizeDependentResources()
00061 {
00062     DirectXBase::CreateWindowSizeDependentResources();
00063
00064     // Create a descriptor for the depth/stencil buffer.
00065     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00066         DXGI_FORMAT_D24_UNORM_S8_UINT,
00067         static_cast<uint32>(m_renderTargetSize.Width),
00068         static_cast<uint32>(m_renderTargetSize.Height),
00069         1,
00070         1,
00071         D3D11_BIND_DEPTH_STENCIL
00072         );
00073
00074     // Allocate a 2-D surface as the depth/stencil buffer.
00075     ComPtr<ID3D11Texture2D> depthStencil;
00076     DX::ThrowIfFailed(
00077         m_d3dDevice->CreateTexture2D(
00078             &depthStencilDesc,
00079             nullptr,
00080             &depthStencil
00081             )
00082         );
00083
00084     // Create a DepthStencil view on this surface to use on bind.
00085     DX::ThrowIfFailed(
00086         m_d3dDevice->CreateDepthStencilView(
00087             depthStencil.Get(),
00088             &CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D),
00089             &m_d3dDepthStencilView
00090             )
00091         );
00092
00093     m_imageRenderer->CreateWindowSizeDependentResources(m_dpi);
00094
00095     m_paperRenderer->CreateWindowSizeDependentResources(m_dpi);
00096
00097     m_extrudedTextRenderer->CreateWindowSizeDependentResources(
00098         m_dpi,
00099         m_d3dRenderTargetView,
00100         m_d3dDepthStencilView,
00101         m_renderTargetSize
00102         );
00103
00104     m_inkRenderer->CreateWindowSizeDependentResources(m_dpi);
00105 }
00106
00107 void PostcardRenderer::UpdateForWindowSizeChange()
00108 {
00109     // Release extra references to Direct3D resources before attempting
00110     // to resize the swap chain.
00111     m_extrudedTextRenderer->ReleaseBufferResources();
00112
00113     DirectXBase::UpdateForWindowSizeChange();
00114 }
00115
00116 void PostcardRenderer::Render()
00117 {
00118     m_d2dContext->BeginDraw();
00119     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));
00120
00121     if (m_windowState != ApplicationViewState::Snapped)
00122     {
00123         // Render each part of the postcard in order.
00124         m_imageRenderer->DrawImageAndEffects();
00125         m_paperRenderer->DrawPaper();
00126         m_d2dContext->EndDraw(); // Ignore any HRESULT. It will be dealt with after the next EndDraw().
00127
00128         // The extruded text renderer does not draw between a BeginDraw and
00129         // EndDraw because it uses Direct3D. It is inappropriate to perform
00130         // Direct3D operations while Direct2D is active.
00131         m_extrudedTextRenderer->DrawExtrudedText();
00132
00133         m_d2dContext->BeginDraw();
00134         m_inkRenderer->DrawInk();
00135     }
00136
00137     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00138     // is lost. It will be handled during the next call to Present.
00139     HRESULT hr = m_d2dContext->EndDraw();
00140     if (hr != D2DERR_RECREATE_TARGET)
00141     {
00142         DX::ThrowIfFailed(hr);
00143     }
00144 }
00145
00146 void PostcardRenderer::UpdateForViewStateChanged(ApplicationViewState state)
00147 {
00148     m_windowState = state;
00149 }
00150
00151 void PostcardRenderer::SavePostcard(IRandomAccessStream^ randomAccessStream, GUID wicFormat)
00152 {
00153     // Convert the RandomAccessStream to an IStream.
00154     ComPtr<IStream> stream;
00155     DX::ThrowIfFailed(
00156         CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(&stream))
00157         );
00158
00159     Render();
00160
00161     // Save the rendered postcard to the IStream.
00162     SaveBitmapToStream(
00163         m_d2dTargetBitmap.Get(),
00164         m_wicFactory.Get(),
00165         m_d2dContext.Get(),
00166         wicFormat,
00167         stream.Get()
00168         );
00169 }
00170
00171 void PostcardRenderer::OnDataRequested(_In_ DataTransferManager^ sender, _In_ DataRequestedEventArgs^ args)
00172 {
00173     DataPackage^ package = args->Request->Data;
00174
00175     // Set the title, description, and text to be shared.
00176     package->Properties->ApplicationName = "DirectX Postcard app sample";
00177     package->Properties->Title = "A postcard for you!";
00178     package->Properties->Description = "This is a postcard made with the DirectX Postcard app C++ sample.";
00179
00180     // Create an in-memory stream to contain the shared data.
00181     IRandomAccessStream^ randomAccessStream = ref new InMemoryRandomAccessStream();
00182
00183     // Create an IStream over that random access stream.
00184     ComPtr<IStream> stream;
00185     DX::ThrowIfFailed(
00186         CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(&stream))
00187         );
00188
00189     Render();
00190
00191     // Save the bitmap to the stream.
00192     SaveBitmapToStream(
00193         m_d2dTargetBitmap.Get(),
00194         m_wicFactory.Get(),
00195         m_d2dContext.Get(),
00196         GUID_ContainerFormatPng,
00197         stream.Get()
00198         );
00199
00200     // Create a stream reference for the random access stream and give it to the data package.
00201     RandomAccessStreamReference^ streamReference = RandomAccessStreamReference::CreateFromStream(randomAccessStream);
00202     package->SetBitmap(streamReference);
00203 }
00204
00205 // Save render target bitmap to a stream using WIC.
00206 void PostcardRenderer::SaveBitmapToStream(
00207     _In_ ID2D1Bitmap1* d2dBitmap,
00208     _In_ IWICImagingFactory2* wicFactory2,
00209     _In_ ID2D1DeviceContext* d2dContext,
00210     _In_ REFGUID wicFormat,
00211     _In_ IStream* stream
00212     )
00213 {
00214     // Create and initialize WIC bitmap encoder.
00215     ComPtr<IWICBitmapEncoder> wicBitmapEncoder;
00216     DX::ThrowIfFailed(
00217         wicFactory2->CreateEncoder(
00218             wicFormat,
00219             nullptr,
00220             &wicBitmapEncoder
00221             )
00222         );
00223
00224     DX::ThrowIfFailed(
00225         wicBitmapEncoder->Initialize(
00226             stream,
00227             WICBitmapEncoderNoCache
00228             )
00229         );
00230
00231     // Create and initialize WIC frame encoder.
00232     ComPtr<IWICBitmapFrameEncode> wicFrameEncode;
00233     DX::ThrowIfFailed(
00234         wicBitmapEncoder->CreateNewFrame(
00235             &wicFrameEncode,
00236             nullptr     // No encoder options.
00237             )
00238         );
00239
00240     DX::ThrowIfFailed(
00241         wicFrameEncode->Initialize(nullptr)
00242         );
00243
00244     // Retrieve Direct2D device.
00245     ComPtr<ID2D1Device> d2dDevice;
00246     d2dContext->GetDevice(&d2dDevice);
00247
00248     // Create WIC image encoder.
00249     ComPtr<IWICImageEncoder> imageEncoder;
00250     DX::ThrowIfFailed(
00251         wicFactory2->CreateImageEncoder(
00252             d2dDevice.Get(),
00253             &imageEncoder
00254             )
00255         );
00256
00257     DX::ThrowIfFailed(
00258         imageEncoder->WriteFrame(
00259             d2dBitmap,
00260             wicFrameEncode.Get(),
00261             nullptr     // Use default options.
00262             )
00263         );
00264
00265     DX::ThrowIfFailed(
00266         wicFrameEncode->Commit()
00267         );
00268
00269     DX::ThrowIfFailed(
00270         wicBitmapEncoder->Commit()
00271         );
00272
00273     // Flush all memory buffers to the next-level storage object.
00274     DX::ThrowIfFailed(
00275         stream->Commit(STGC_DEFAULT)
00276         );
00277 }
00278
00279 void PostcardRenderer::AddPaper()
00280 {
00281     m_paperRenderer->AddPaper();
00282     Render();
00283     Present();
00284 }
00285
00286 void PostcardRenderer::RemovePaper()
00287 {
00288     m_paperRenderer->RemovePaper();
00289 }
00290
00291 void PostcardRenderer::MovePaper()
00292 {
00293     m_paperRenderer->MovePaper();
00294 }
00295
00296 void PostcardRenderer::StampPaper()
00297 {
00298     m_paperRenderer->StampPaper();
00299 }
00300
00301 void PostcardRenderer::LoadImage(IRandomAccessStream^ randomAccessStream)
00302 {
00303     m_imageRenderer->LoadImage(randomAccessStream);
00304     Render();
00305     Present();
00306 }
00307
00308 void PostcardRenderer::SetEffectIntensity(float value)
00309 {
00310     m_imageRenderer->SetEffectIntensity(value);
00311     Render();
00312     Present();
00313 }
00314
00315 void PostcardRenderer::SetExtrudedText(String^ text)
00316 {
00317     m_extrudedTextRenderer->SetExtrudedText(text);
00318     Render();
00319     Present();
00320 }
00321
00322 void PostcardRenderer::StartSignature()
00323 {
00324     m_inkRenderer->StartSignature();
00325 }
00326
00327 void PostcardRenderer::ResetSignature()
00328 {
00329     m_inkRenderer->Reset();
00330     Render();
00331     Present();
00332 }
00333
00334 void PostcardRenderer::ResetPostcard()
00335 {
00336     m_imageRenderer->Reset();
00337     m_paperRenderer->Reset();
00338     m_extrudedTextRenderer->Reset();
00339     m_inkRenderer->Reset();
00340
00341     Render();
00342     Present();
00343 }
00344
00345 void PostcardRenderer::OnPointerPressed(
00346     _In_ Object^ /* sender */,
00347     _In_ PointerRoutedEventArgs^ args
00348     )
00349 {
00350     if (m_sampleMode == SampleMode::AddSignature)
00351     {
00352         m_inkRenderer->OnPointerPressed(args);
00353         Render();
00354         Present();
00355     }
00356 }
00357
00358 void PostcardRenderer::OnPointerReleased(
00359     _In_ Object^ /* sender */,
00360     _In_ PointerRoutedEventArgs^ args
00361     )
00362 {
00363     if (m_sampleMode == SampleMode::AddSignature)
00364     {
00365         m_inkRenderer->OnPointerReleased(args);
00366         Render();
00367         Present();
00368     }
00369 }
00370
00371 void PostcardRenderer::OnPointerMoved(
00372     _In_ Object^ /* sender */,
00373     _In_ PointerRoutedEventArgs^ args
00374     )
00375 {
00376     if (m_sampleMode == SampleMode::AddSignature)
00377     {
00378         m_inkRenderer->OnPointerMoved(args);
00379         Render();
00380         Present();
00381     }
00382 }
00383
00384 void PostcardRenderer::OnManipulationStarted(
00385     _In_ Object^ /* sender */,
00386     _In_ ManipulationStartedRoutedEventArgs^ args
00387     )
00388 {
00389     if (m_sampleMode == SampleMode::AddConstructionPaper)
00390     {
00391         m_paperRenderer->OnManipulationStarted(args);
00392         Render();
00393         Present();
00394     }
00395 }
00396
00397 void PostcardRenderer::OnManipulationCompleted(
00398     _In_ Object^ /* sender */,
00399     _In_ ManipulationCompletedRoutedEventArgs^ args
00400     )
00401 {
00402     if (m_sampleMode == SampleMode::AddConstructionPaper)
00403     {
00404         m_paperRenderer->OnManipulationCompleted(args);
00405         Render();
00406         Present();
00407     }
00408 }
00409
00410 void PostcardRenderer::OnManipulationDelta(
00411     _In_ Object^ /* sender */,
00412     _In_ ManipulationDeltaRoutedEventArgs^ args
00413     )
00414 {
00415     if (m_sampleMode == SampleMode::AddConstructionPaper)
00416     {
00417         m_paperRenderer->OnManipulationDelta(args);
00418         Render();
00419         Present();
00420     }
00421     else if (m_sampleMode == SampleMode::AddText)
00422     {
00423         m_extrudedTextRenderer->OnManipulationDelta(
00424             args->Position,
00425             args->Delta.Translation,
00426             args->Delta.Scale,
00427             args->Delta.Rotation
00428             );
00429         Render();
00430         Present();
00431     }
00432 }
00433
00434 void PostcardRenderer::OnTapped(
00435     _In_ Object^ /* sender */,
00436     _In_ TappedRoutedEventArgs^ args
00437     )
00438 {
00439     if (m_sampleMode == SampleMode::AddConstructionPaper)
00440     {
00441         m_paperRenderer->OnTapped(args->GetPosition(nullptr));
00442         Render();
00443         Present();
00444     }
00445 }
00446
00447 void PostcardRenderer::SetSampleMode(SampleMode mode)
00448 {
00449     m_sampleMode = mode;
00450 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/App.xaml.cpp Source File

  • Raw notifications
  • MainAppSample

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.cpp
00010 // Implementation of the App.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "App.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::ApplicationModel;
00020 using namespace Windows::ApplicationModel::Activation;
00021 using namespace CppSamplesUtils;
00022 using namespace RawNotificationsSampleCPP;
00023 using namespace Windows::UI::Xaml::Interop;
00024
00025 App::App()
00026 {
00027   InitializeComponent();
00028   this->Suspending += ref new SuspendingEventHandler(this, &RawNotificationsSampleCPP::App::OnSuspending);
00029 }
00030
00031 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00032 {
00033   auto deferral = pArgs->SuspendingOperation->GetDeferral();
00034     SuspensionManager::StartSaveTask().then([deferral] () {
00035         deferral->Complete();
00036     });
00037 }
00038
00039 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00040 {
00041
00042   if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00043   {
00044     SuspensionManager::StartRestoreTask().then([this]()
00045     {
00046       auto rootFrame = ref new Frame();
00047       TypeName pageType = { "RawNotificationsSampleCPP.MainPage", TypeKind::Custom };
00048       rootFrame->Navigate(pageType);
00049       Window::Current->Content = rootFrame;
00050       Window::Current->Activate();
00051     });
00052   }
00053   else
00054   {
00055     auto rootFrame = ref new Frame();
00056     TypeName pageType = { "RawNotificationsSampleCPP.MainPage", TypeKind::Custom };
00057     rootFrame->Navigate(pageType);
00058     Window::Current->Content = rootFrame;
00059     Window::Current->Activate();
00060   }
00061 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/App.xaml.cpp Source File

  • UI contrast and settings

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/Constants.h Source File

  • Compass sensor

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Compass Sensor Raw Data");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level4.h Source File

  • DirectX 3D shooting game

Level4.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Level4:
00011 // This class defines the fourth level of the game.  It derives from the
00012 // third level.  The targets must be hit in numeric order.
00013
00014 #include "Level3.h"
00015
00016 ref class Level4: public Level3
00017 {
00018 internal:
00019     Level4();
00020     virtual void Initialize(std::vector<GameObject^> objects) override;
00021
00022     virtual bool Update(
00023         float time,
00024         float elapsedTime,
00025         float timeRemaining,
00026         std::vector<GameObject^> objects
00027         ) override;
00028
00029     virtual void SaveState(PersistentState^ state) override;
00030     virtual void LoadState(PersistentState^ state) override;
00031
00032 private:
00033     int m_nextId;
00034 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::PhotoCache Member List

This is the complete list of members for Hilo::PhotoCache, including all inherited members.
Clear() | Hilo::PhotoCache |
GetForYearAndMonth(int year, int month) | Hilo::PhotoCache |
InsertPhoto(IPhoto^photo) | Hilo::PhotoCache |
m_photoCache | Hilo::PhotoCache | [private]
MonthPhoto typedef | Hilo::PhotoCache | [private]
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/DirectXBase.h Source File

  • Direct2D command list

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Scaling::sealed Member List

This is the complete list of members for SDKSample::Scaling::sealed, including all inherited members.
DEFAULT_LOGICALPPI | SDKSample::Scaling::sealed | [private, static]
defaultFontFamily | SDKSample::Scaling::sealed | [private]
DisplayProperties_LogicalDpiChanged(Platform::Object^sender) | SDKSample::Scaling::sealed | [private]
DisplayProperties_LogicalDpiChanged(Platform::Object^sender) | SDKSample::Scaling::sealed | [private]
GetMinDPI() | SDKSample::Scaling::sealed | [private]
GetMinResolution() | SDKSample::Scaling::sealed | [private]
image100 | SDKSample::Scaling::sealed | [private]
image140 | SDKSample::Scaling::sealed | [private]
image180 | SDKSample::Scaling::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Scaling::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Scaling::sealed | [protected, virtual]
OutputSettings(double scaleFactor, Windows::UI::Xaml::FrameworkElement^rectangle, Windows::UI::Xaml::Controls::TextBlock^relativePxText, Windows::UI::Xaml::Controls::TextBlock^physicalPxText, Windows::UI::Xaml::Controls::TextBlock^fontTextBlock) | SDKSample::Scaling::sealed | [private]
overrideFontFamily | SDKSample::Scaling::sealed | [private]
PERCENT | SDKSample::Scaling::sealed | [private, static]
PtFromPx(double pixel) | SDKSample::Scaling::sealed | [private]
PxFromPt(double pt) | SDKSample::Scaling::sealed | [private]
ResetOutput() | SDKSample::Scaling::sealed | [private]
ResetOutput() | SDKSample::Scaling::sealed | [private]
Scenario1() | SDKSample::Scaling::sealed |
Scenario2() | SDKSample::Scaling::sealed |
SetManualLoadImage() | SDKSample::Scaling::sealed | [private]
SetOverrideRectSize(double sizeInPhysicalPx, double scaleFactor) | SDKSample::Scaling::sealed | [private]
SetOverrideTextFont(double size, Windows::UI::Xaml::Media::FontFamily^fontFamily) | SDKSample::Scaling::sealed | [private]
StringFromDouble(double) | SDKSample::Scaling::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/PlaybackControl.xaml.cpp Source File

  • Playback Manager Companion

PlaybackControl.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PlaybackControl.xaml.cpp
00013 // Implementation of the PlaybackControl class
00014 //
00015
00016 #include "pch.h"
00017 #include "PlaybackControl.xaml.h"
00018
00019 using namespace SDKSample::PlaybackManager2;
00020
00021 using namespace Windows::Foundation;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Media;
00026 using namespace Windows::Media;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::Pickers;
00029 using namespace Windows::Storage::Streams;
00030 using namespace Platform;
00031 using namespace Concurrency;
00032
00033 bool PlaybackControl::IsRegistered = false;
00034 EventRegistrationToken PlaybackControl::SoundLevelChangedToken;
00035 EventRegistrationToken PlaybackControl::PlayPauseTogglePressedToken;
00036 EventRegistrationToken PlaybackControl::PlayPressedToken;
00037 EventRegistrationToken PlaybackControl::PausePressedToken;
00038 EventRegistrationToken PlaybackControl::StopPressedToken;
00039
00040 PlaybackControl::PlaybackControl()
00041 {
00042     InitializeComponent();
00043
00044     cw = Window::Current->CoreWindow;
00045     IsPlaying = false;
00046     if(IsRegistered)
00047     {
00048         // remove handlers
00049         MediaControl::SoundLevelChanged      -= SoundLevelChangedToken;
00050         MediaControl::PlayPauseTogglePressed -= PlayPauseTogglePressedToken;
00051         MediaControl::PlayPressed            -= PlayPressedToken;
00052         MediaControl::PausePressed           -= PausePressedToken;
00053         MediaControl::StopPressed            -= StopPressedToken;
00054     }
00055     // add handlers and save token
00056     SoundLevelChangedToken      = MediaControl::SoundLevelChanged      += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_SoundLevelChanged);
00057     PlayPauseTogglePressedToken = MediaControl::PlayPauseTogglePressed += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_PlayPauseTogglePressed);
00058     PlayPressedToken            = MediaControl::PlayPressed            += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_PlayPressed);
00059     PausePressedToken           = MediaControl::PausePressed           += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_PausePressed);
00060     StopPressedToken            = MediaControl::StopPressed            += ref new EventHandler<Object^>(this, &PlaybackControl::MediaControl_StopPressed);
00061
00062     IsRegistered = true;
00063
00064     MediaControl::IsPlaying = false;
00065 }
00066
00067
00068 void PlaybackControl::Play()
00069 {
00070     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00071     {
00072         OutputMedia->Play();
00073         MediaControl::IsPlaying = true;
00074     }
00075     , CallbackContext::Any));
00076 }
00077
00078
00079 void PlaybackControl::Pause()
00080 {
00081     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00082     {
00083         OutputMedia->Pause();
00084         MediaControl::IsPlaying = false;
00085     }
00086     , CallbackContext::Any));
00087 }
00088
00089
00090 void PlaybackControl::Stop()
00091 {
00092     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00093     {
00094         OutputMedia->Stop();
00095         MediaControl::IsPlaying = false;
00096     }
00097     , CallbackContext::Any));
00098 }
00099
00100
00101 void PlaybackControl::SetAudioCategory(AudioCategory category)
00102 {
00103     OutputMedia->AudioCategory = category;
00104 }
00105
00106
00107 void PlaybackControl::SetAudioDeviceType(AudioDeviceType devicetype)
00108 {
00109     OutputMedia->AudioDeviceType = devicetype;
00110 }
00111
00112
00113 void PlaybackControl::SelectFile()
00114 {
00115     try
00116     {
00117         FileOpenPicker^ picker = ref new FileOpenPicker();
00118         picker->ViewMode = PickerViewMode::List;
00119         picker->SuggestedStartLocation = PickerLocationId::MusicLibrary;
00120         picker->FileTypeFilter->Append(".mp3");
00121         picker->FileTypeFilter->Append(".mp4");
00122         picker->FileTypeFilter->Append(".m4a");
00123         picker->FileTypeFilter->Append(".wma");
00124         picker->FileTypeFilter->Append(".wav");
00125
00126     create_task(picker->PickSingleFileAsync()).then([this](StorageFile^ file)
00127     {
00128       if (file)
00129             {
00130                 create_task(file->OpenAsync(FileAccessMode::Read)).then([this, file](Streams::IRandomAccessStream^ stream)
00131                 {
00132                     if (stream)
00133           {
00134             cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00135             {
00136               OutputMedia->SetSource(stream, file->ContentType);
00137             }
00138             , CallbackContext::Any));
00139           }
00140                 });
00141             }
00142         });
00143
00144     }
00145     catch(Exception^ ex)
00146     {
00147         DisplayStatus(ex->ToString());
00148     }
00149 }
00150
00151
00152 void PlaybackControl::DisplayStatus(Platform::String^ text)
00153 {
00154     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00155     {
00156         Status->Text += text + "\n";
00157     }
00158     , CallbackContext::Any));
00159 }
00160
00161
00162 String^ PlaybackControl::GetTimeStampedMessage(String^ EventCalled)
00163 {
00164     Platform::String^ message;
00165     Windows::Foundation::DateTime timestamp = Windows::Foundation::DateTime();
00166
00167     Windows::Globalization::DateTimeFormatting::DateTimeFormatter^ formatter = ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("longtime");
00168     Windows::Globalization::Calendar^ calendar = ref new Windows::Globalization::Calendar();
00169     calendar->SetToNow();
00170
00171     message = EventCalled + "   " + formatter->Format(calendar->GetDateTime());
00172
00173     return message;
00174 }
00175
00176   //If your app is playing media you feel that a user should not miss if a VOIP call comes in, you may
00177   //want to consider pausing playback when your app receives a SoundLevel(Low) notification.
00178   //A SoundLevel(Low) means your app volume has been attenuated by the system (likely for a VOIP call).
00179
00180
00181 String^ PlaybackControl::SoundLevelToString(SoundLevel level)
00182 {
00183     String^ LevelString;
00184
00185     switch (level)
00186     {
00187     case Windows::Media::SoundLevel::Muted:
00188         LevelString = "Muted";
00189         break;
00190     case Windows::Media::SoundLevel::Low:
00191         LevelString = "Low";
00192         break;
00193     case Windows::Media::SoundLevel::Full:
00194         LevelString = "Full";
00195         break;
00196     default:
00197         LevelString = "Unknown";
00198         break;
00199     }
00200
00201     return LevelString;
00202 }
00203
00204
00205 void PlaybackControl::AppMuted()
00206 {
00207     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00208     {
00209         if (OutputMedia->CurrentState != MediaElementState::Paused)
00210         {
00211             IsPlaying = true;
00212             Pause();
00213         }
00214         else
00215         {
00216             IsPlaying = false;
00217         }
00218     }
00219     , CallbackContext::Any));
00220     DisplayStatus(GetTimeStampedMessage("Muted"));
00221 }
00222
00223
00224 void PlaybackControl::AppUnmuted()
00225 {
00226     cw->Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, ref new Windows::UI::Core::DispatchedHandler([=]()
00227     {
00228         if (IsPlaying)
00229         {
00230             Play();
00231         }
00232     }
00233     , CallbackContext::Any));
00234     DisplayStatus(GetTimeStampedMessage("Unmuted"));
00235 }
00236
00237
00238 void PlaybackControl::MediaControl_SoundLevelChanged(Object^ sender, Object^ e)
00239 {
00240     auto soundLevelState = MediaControl::SoundLevel;
00241
00242     DisplayStatus(GetTimeStampedMessage("App sound level is ["+SoundLevelToString(soundLevelState)+"]"));
00243     if(soundLevelState == SoundLevel::Muted)
00244     {
00245         AppMuted();
00246     }
00247     else
00248     {
00249         AppUnmuted();
00250     }
00251 }
00252
00253
00254 void PlaybackControl::MediaControl_PlayPauseTogglePressed(Object^ sender, Object^ e)
00255 {
00256     if(MediaControl::IsPlaying)
00257     {
00258         Pause();
00259         DisplayStatus(GetTimeStampedMessage("Play/Pause Pressed - Pause"));
00260     }
00261     else
00262     {
00263         Play();
00264         DisplayStatus(GetTimeStampedMessage("Play/Pause Pressed - Play"));
00265     }
00266 }
00267
00268
00269 void PlaybackControl::MediaControl_PlayPressed(Object^ sender, Object^ e)
00270 {
00271     Play();
00272     DisplayStatus(GetTimeStampedMessage("Play Pressed"));
00273 }
00274
00275
00276 void PlaybackControl::MediaControl_PausePressed(Object^ sender, Object^ e)
00277 {
00278     Pause();
00279     DisplayStatus(GetTimeStampedMessage("Pause Pressed"));
00280 }
00281
00282
00283 void PlaybackControl::MediaControl_StopPressed(Object^ sender, Object^ e)
00284 {
00285     Stop();
00286     DisplayStatus(GetTimeStampedMessage("Stop Pressed"));
00287 }
00288
00289
00290 void PlaybackControl::Button_Play_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00291 {
00292     Play();
00293 }
00294
00295
00296 void PlaybackControl::Button_Pause_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00297 {
00298     Pause();
00299 }
00300
00301
00302 void PlaybackControl::Button_Stop_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00303 {
00304     Stop();
00305 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKTemplate::MainPageSizeChangedEventArgs Member List

This is the complete list of members for SDKTemplate::MainPageSizeChangedEventArgs, including all inherited members.
viewState | SDKTemplate::MainPageSizeChangedEventArgs | [private]
ViewState | SDKTemplate::MainPageSizeChangedEventArgs |
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Scenario2.xaml.h Source File

  • Media Play To

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace PlayTo
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038         private:
00039             MainPage^ rootPage;
00040         Windows::UI::Core::CoreDispatcher^ dispatcher;
00041         Windows::UI::Xaml::DispatcherTimer^ playlistTimer;
00042         Windows::Media::PlayTo::PlayToManager^ playToManager;
00043         Windows::Foundation::EventRegistrationToken sourceRequestedToken;
00044         Windows::Foundation::EventRegistrationToken timerTickToken;
00045
00046         void playlistTimer_Tick(Platform::Object^ sender, Platform::Object^ e);
00047         void playToManager_SourceRequested(Windows::Media::PlayTo::PlayToManager^ sender, Windows::Media::PlayTo::PlayToSourceRequestedEventArgs^ e);
00048             void playSlideshow_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00049         void pauseSlideshow_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050         void previousItem_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00051         void nextItem_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00052         void playListPlayNext();
00053         void Playlist_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00054       };
00055     }
00056 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXApp.h Source File

  • DXGI swap chain rotation

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DxgiRotation.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032     void OnVisibilityChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(
00038         _In_ Platform::Object^ sender
00039         );
00040
00041     void OnOrientationChanged(
00042         _In_ Platform::Object^ sender
00043         );
00044
00045     void OnActivated(
00046         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00047         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00048         );
00049
00050     void OnWindowClosed(
00051         _In_ Windows::UI::Core::CoreWindow^ sender,
00052         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00053         );
00054
00055     DxgiRotation^ m_renderer;
00056     bool m_windowClosed;
00057     bool m_windowVisible;
00058 };
00059
00060 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00061 {
00062 public:
00063     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00064 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/MainPage.xaml.cpp Source File

  • Sharing content target app

MainPage.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.cpp
00010 // Implementation of the MainPage.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "MainPage.xaml.h"
00015 #include "App.xaml.h"
00016
00017 using namespace ShareTarget;
00018
00019 using namespace concurrency;
00020 using namespace Platform;
00021 using namespace Windows::ApplicationModel;
00022 using namespace Windows::ApplicationModel::Activation;
00023 using namespace Windows::ApplicationModel::DataTransfer;
00024 using namespace Windows::ApplicationModel::DataTransfer::ShareTarget;
00025 using namespace Windows::Data::Json;
00026 using namespace Windows::Foundation;
00027 using namespace Windows::Foundation::Collections;
00028 using namespace Windows::Storage;
00029 using namespace Windows::Storage::Streams;
00030 using namespace Windows::UI;
00031 using namespace Windows::UI::Core;
00032 using namespace Windows::UI::Text;
00033 using namespace Windows::UI::Xaml;
00034 using namespace Windows::UI::Xaml::Controls;
00035 using namespace Windows::UI::Xaml::Media::Imaging;
00036 using namespace Windows::UI::Xaml::Navigation;
00037 using namespace Windows::UI::Xaml::Documents;
00038 using namespace Windows::UI::Xaml::Input;
00039
00040 MainPage::MainPage()
00041 {
00042     InitializeComponent();
00043 }
00044
00045 MainPage::~MainPage()
00046 {
00047 }
00048
00049 void MainPage::OnNavigatedTo(NavigationEventArgs^ e)
00050 {
00051     // It is recommended to only retrieve the ShareOperation object in the activation handler, return as
00052     // quickly as possible, and retrieve all data from the share target asynchronously.
00053
00054     shareOperation = dynamic_cast<ShareOperation^>(e->Parameter);
00055
00056     create_task([this]()
00057     {
00058         // Retrieve the data package properties.
00059         sharedDataTitle = shareOperation->Data->Properties->Title;
00060         sharedDataDescription = shareOperation->Data->Properties->Description;
00061         sharedThumbnailStreamRef = shareOperation->Data->Properties->Thumbnail;
00062         shareQuickLinkId = shareOperation->QuickLinkId;
00063
00064         // Retrieve the data package content.
00065         std::vector<task<void>> dataPackageTasks;
00066         if (shareOperation->Data->Contains(StandardDataFormats::Uri))
00067         {
00068             // The GetUriAsync(), GetTextAsync(), GetStorageItemsAsync(), etc. APIs will throw if there was an error retrieving the data from the source app.
00069             // In this sample, we just display the error. It is recommended that a share target app handles these in a way appropriate for that particular app.
00070             dataPackageTasks.push_back(create_task(shareOperation->Data->GetUriAsync()).then([this](task<Uri^> uriTask)
00071             {
00072                 try
00073                 {
00074                     sharedUri = uriTask.get();
00075                 }
00076                 catch (Exception^ ex)
00077                 {
00078                     NotifyUserBackgroundThread("Failed GetUriAsync - " + ex->Message, NotifyType::ErrorMessage);
00079                 }
00080             }));
00081         }
00082         if (shareOperation->Data->Contains(StandardDataFormats::Text))
00083         {
00084             dataPackageTasks.push_back(create_task(shareOperation->Data->GetTextAsync()).then([this](task<String^> textTask)
00085             {
00086                 try
00087                 {
00088                     sharedText = textTask.get();
00089                 }
00090                 catch (Exception^ ex)
00091                 {
00092                     NotifyUserBackgroundThread("Failed GetTextAsync - " + ex->Message, NotifyType::ErrorMessage);
00093                 }
00094             }));
00095         }
00096         if (shareOperation->Data->Contains(StandardDataFormats::StorageItems))
00097         {
00098             dataPackageTasks.push_back(create_task(shareOperation->Data->GetStorageItemsAsync()).then(
00099                 [this](task<IVectorView<IStorageItem^>^> itemsTask)
00100             {
00101                 try
00102                 {
00103                     sharedStorageItems = itemsTask.get();
00104                 }
00105                 catch (Exception^ ex)
00106                 {
00107                     NotifyUserBackgroundThread("Failed GetStorageItemsAsync - " + ex->Message, NotifyType::ErrorMessage);
00108                 }
00109             }));
00110         }
00111         if (shareOperation->Data->Contains(DATA_FORMAT_NAME))
00112         {
00113             dataPackageTasks.push_back(create_task(shareOperation->Data->GetTextAsync(DATA_FORMAT_NAME)).then(
00114                 [this](task<String^> customTextTask)
00115             {
00116                 try
00117                 {
00118                     sharedCustomData = customTextTask.get();
00119                 }
00120                 catch (Exception^ ex)
00121                 {
00122                     NotifyUserBackgroundThread("Failed GetTextAsync(" + DATA_FORMAT_NAME + ") - "  + ex->Message, NotifyType::ErrorMessage);
00123                 }
00124             }));
00125         }
00126         if (shareOperation->Data->Contains(StandardDataFormats::Html))
00127         {
00128             dataPackageTasks.push_back(create_task(shareOperation->Data->GetHtmlFormatAsync()).then([this](task<String^> htmlTask)
00129             {
00130                 try
00131                 {
00132                     sharedHtmlFormat = htmlTask.get();
00133                 }
00134                 catch (Exception^ ex)
00135                 {
00136                     NotifyUserBackgroundThread("Failed GetHtmlFormatAsync - " + ex->Message, NotifyType::ErrorMessage);
00137                 }
00138             }));
00139
00140             dataPackageTasks.push_back(create_task(shareOperation->Data->GetResourceMapAsync()).then(
00141                 [this](task<IMapView<String^, RandomAccessStreamReference^>^> resourceMapTask)
00142             {
00143                 try
00144                 {
00145                     sharedResourceMap = resourceMapTask.get();
00146                 }
00147                 catch (Exception^ ex)
00148                 {
00149                     NotifyUserBackgroundThread("Failed GetResourceMapAsync - " + ex->Message, NotifyType::ErrorMessage);
00150                 }
00151             }));
00152         }
00153         if (shareOperation->Data->Contains(StandardDataFormats::Bitmap))
00154         {
00155             dataPackageTasks.push_back(create_task(shareOperation->Data->GetBitmapAsync()).then(
00156                 [this](task<RandomAccessStreamReference^> bitmapTask)
00157             {
00158                 try
00159                 {
00160                     sharedBitmapStreamRef = bitmapTask.get();
00161                 }
00162                 catch (Exception^ ex)
00163                 {
00164                     NotifyUserBackgroundThread("Failed GetBitmapAsync - " + ex->Message, NotifyType::ErrorMessage);
00165                 }
00166             }));
00167         }
00168
00169         return when_all(dataPackageTasks.begin(), dataPackageTasks.end());
00170     }).then([this] ()
00171     {
00172         // In this sample, we just display the shared data content.
00173
00174         DataPackageTitle->Text = sharedDataTitle;
00175         DataPackageDescription->Text = sharedDataDescription;
00176
00177         if (sharedThumbnailStreamRef != nullptr)
00178         {
00179             create_task(sharedThumbnailStreamRef->OpenReadAsync()).then(
00180                 [this](IRandomAccessStreamWithContentType^ thumbnailStream)
00181             {
00182                 auto bitmapImage = ref new BitmapImage();
00183                 bitmapImage->SetSource(thumbnailStream);
00184                 ThumbnailHolder->Source = bitmapImage;
00185                 ThumbnailArea->Visibility = Xaml::Visibility::Visible;
00186             });
00187         }
00188
00189         if (shareQuickLinkId != nullptr)
00190         {
00191             SelectedQuickLinkId->Text = shareQuickLinkId;
00192         }
00193
00194         if (sharedUri != nullptr)
00195         {
00196             AddContentValue("Uri: ", sharedUri->AbsoluteUri);
00197         }
00198         if (sharedText != nullptr)
00199         {
00200             AddContentValue("Text: ", sharedText);
00201         }
00202         if (sharedStorageItems != nullptr)
00203         {
00204             // Display the name of the files being shared.
00205             std::wstringstream fileNames;
00206             for (unsigned int i = 0; i < sharedStorageItems->Size; i++)
00207             {
00208                 fileNames << sharedStorageItems->GetAt(i)->Name->Data();
00209                 if (i < sharedStorageItems->Size - 1)
00210                 {
00211                     fileNames << L", ";
00212                 }
00213             }
00214             fileNames << L".";
00215
00216             AddContentValue("StorageItems: ", ref new String(fileNames.str().c_str()));
00217         }
00218         if (sharedCustomData != nullptr)
00219         {
00220             // This is an area to be especially careful parsing data from the source app to avoid buffer overruns.
00221             // This sample doesn't perform data validation but will catch any exceptions thrown.
00222             try
00223             {
00224                 auto customObject = JsonObject::Parse(sharedCustomData);
00225                 if (customObject->HasKey("type"))
00226                 {
00227                     auto typeString = customObject->GetNamedString("type");
00228                     if (typeString == "http://schema.org/Book")
00229                     {
00230                         // This sample expects the custom format to be of type http://schema.org/Book.
00231                         String^ receivedStrings = "Type: " + typeString + "\n";
00232                         auto properties = customObject->GetNamedObject("properties");
00233                         double numberOfPages = properties->GetNamedNumber("numberOfPages");
00234                         wchar_t pagesBuffer[11];
00235                         swprintf_s(pagesBuffer, ARRAYSIZE(pagesBuffer), L"%d", (int) min(numberOfPages, INT_MAX));
00236
00237                         receivedStrings += "Image: " + properties->GetNamedString("image")
00238                             + "\nName: " + properties->GetNamedString("name")
00239                             + "\nBook Format: " + properties->GetNamedString("bookFormat")
00240                             + "\nAuthor: " + properties->GetNamedString("author")
00241                             + "\nNumber of Pages: " + ref new String(pagesBuffer)
00242                             + "\nPublisher: " + properties->GetNamedString("publisher")
00243                             + "\nDate Published: " + properties->GetNamedString("datePublished")
00244                             + "\nIn Language: " + properties->GetNamedString("inLanguage")
00245                             + "\nISBN: " + properties->GetNamedString("isbn");
00246
00247                         AddContentValue("Custom format data:\n", receivedStrings);
00248                     }
00249                     else
00250                     {
00251                         NotifyUser("The custom format from the source app is not of type http://schema.org/Book", NotifyType::ErrorMessage);
00252                     }
00253                 }
00254                 else
00255                 {
00256                     NotifyUser("The custom format from the source app doesn't contain a type", NotifyType::ErrorMessage);
00257                 }
00258             }
00259             catch (Exception^ ex)
00260             {
00261                 NotifyUser("Failed to parse the custom data - " + ex->Message, NotifyType::ErrorMessage);
00262             }
00263         }
00264         if (sharedHtmlFormat != nullptr)
00265         {
00266             String^ htmlFragment = HtmlFormatHelper::GetStaticFragment(sharedHtmlFormat);
00267             if (htmlFragment != nullptr)
00268             {
00269                 AddContentValue("HTML: ");
00270                 ShareWebView->Visibility = Xaml::Visibility::Visible;
00271                 ShareWebView->NavigateToString("<html><body>" + htmlFragment + "</body></html>");
00272             }
00273             else
00274             {
00275                 NotifyUser("GetStaticFragment failed to parse the HTML from the source app", NotifyType::ErrorMessage);
00276             }
00277
00278             // Check if there are any local images in the resource map.
00279             if (sharedResourceMap->Size > 0)
00280             {
00281                 ResourceMapValue->Text = "";
00282                 std::for_each(begin(sharedResourceMap), end(sharedResourceMap), [this](IKeyValuePair<String^, RandomAccessStreamReference^>^ item)
00283                 {
00284                     ResourceMapValue->Text += "\nKey: " + item->Key;
00285                 });
00286                 ResourceMapArea->Visibility = Xaml::Visibility::Visible;
00287             }
00288         }
00289         if (sharedBitmapStreamRef != nullptr)
00290         {
00291             create_task(sharedBitmapStreamRef->OpenReadAsync()).then(
00292                 [this](IRandomAccessStreamWithContentType^ sharedStream)
00293             {
00294                 auto bitmapImage = ref new BitmapImage();
00295                 bitmapImage->SetSource(sharedStream);
00296                 ImageHolder->Source = bitmapImage;
00297                 ImageArea->Visibility = Xaml::Visibility::Visible;
00298             });
00299         }
00300     }, task_continuation_context::use_current()); // Run the continuation on the UI thread as it updates the UI.
00301 }
00302
00303 void MainPage::QuickLinkSectionLabel_Tapped(Object^ sender, TappedRoutedEventArgs^ e)
00304 {
00305     // Trigger the appropriate Checked/Unchecked event if the user taps on the text instead of the checkbox.
00306     AddQuickLink->IsChecked = !AddQuickLink->IsChecked->Value;
00307 }
00308
00309 void MainPage::AddQuickLink_Checked(Object^ sender, RoutedEventArgs^ e)
00310 {
00311     QuickLinkCustomization->Visibility = Xaml::Visibility::Visible;
00312 }
00313
00314 void MainPage::AddQuickLink_Unchecked(Object^ sender, RoutedEventArgs^ e)
00315 {
00316     QuickLinkCustomization->Visibility = Xaml::Visibility::Collapsed;
00317 }
00318
00319 void MainPage::ReportCompleted_Click(Object^ sender, RoutedEventArgs^ e)
00320 {
00321     if (AddQuickLink->IsChecked->Value)
00322     {
00323         Agile<QuickLink> quickLinkInfo(ref new QuickLink());
00324         quickLinkInfo->Id = QuickLinkId->Text;
00325         quickLinkInfo->Title = QuickLinkTitle->Text;
00326
00327         // For QuickLinks, the supported FileTypes and DataFormats are set independently from the manifest.
00328         quickLinkInfo->SupportedFileTypes->Append("*");
00329         quickLinkInfo->SupportedDataFormats->Append(StandardDataFormats::Text);
00330         quickLinkInfo->SupportedDataFormats->Append(StandardDataFormats::Uri);
00331         quickLinkInfo->SupportedDataFormats->Append(StandardDataFormats::Bitmap);
00332         quickLinkInfo->SupportedDataFormats->Append(StandardDataFormats::Html);
00333         quickLinkInfo->SupportedDataFormats->Append(DATA_FORMAT_NAME);
00334
00335         create_task(Package::Current->InstalledLocation->CreateFileAsync("assets\\user.png", CreationCollisionOption::OpenIfExists))
00336             .then([this, quickLinkInfo](task<StorageFile^> completedTask)
00337         {
00338             try
00339             {
00340                 auto iconFile = completedTask.get();
00341                 quickLinkInfo->Thumbnail = RandomAccessStreamReference::CreateFromFile(iconFile);
00342                 shareOperation->ReportCompleted(quickLinkInfo.Get());
00343             }
00344             catch (Exception^)
00345             {
00346                 // Even if the QuickLink cannot be created it is important to call ReportCompleted. Otherwise, if this is a long-running share,
00347                 // the app will stick around in the long-running share progress list.
00348                 shareOperation->ReportCompleted();
00349                 throw;
00350             }
00351         });
00352     }
00353     else
00354     {
00355         shareOperation->ReportCompleted();
00356     }
00357 }
00358
00359 void MainPage::LongRunningShareLabel_Tapped(Object^ sender, TappedRoutedEventArgs^ e)
00360 {
00361     // Trigger the appropriate Checked/Unchecked event if the user taps on the text instead of the checkbox.
00362     ExpandLongRunningShareSection->IsChecked = !ExpandLongRunningShareSection->IsChecked->Value;
00363 }
00364
00365 void MainPage::ExpandLongRunningShareSection_Checked(Object^ sender, RoutedEventArgs^ e)
00366 {
00367     ExtendedSharingArea->Visibility = Xaml::Visibility::Visible;
00368 }
00369
00370 void MainPage::ExpandLongRunningShareSection_Unchecked(Object^ sender, RoutedEventArgs^ e)
00371 {
00372     ExtendedSharingArea->Visibility = Xaml::Visibility::Collapsed;
00373 }
00374
00375 void MainPage::ReportStarted_Click(Object^ sender, RoutedEventArgs^ e)
00376 {
00377     shareOperation->ReportStarted();
00378     NotifyUser("Started...", NotifyType::StatusMessage);
00379 }
00380
00381 void MainPage::ReportDataRetrieved_Click(Object^ sender, RoutedEventArgs^ e)
00382 {
00383     shareOperation->ReportDataRetrieved();
00384     NotifyUser("Data retrieved...", NotifyType::StatusMessage);
00385 }
00386
00387 void MainPage::ReportSubmittedBackgroundTask_Click(Object^ sender, RoutedEventArgs^ e)
00388 {
00389     shareOperation->ReportSubmittedBackgroundTask();
00390     NotifyUser("Submitted background task...", NotifyType::StatusMessage);
00391 }
00392
00393 void MainPage::ReportErrorButton_Click(Object^ sender, RoutedEventArgs^ e)
00394 {
00395     shareOperation->ReportError(ReportError->Text);
00396 }
00397
00398 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00399 {
00400     auto uri = ref new Uri(safe_cast<String^>(safe_cast<HyperlinkButton^>(sender)->Tag));
00401     Windows::System::Launcher::LaunchUriAsync(uri);
00402 }
00403
00404 void MainPage::NotifyUser(String^ message, NotifyType type)
00405 {
00406     switch (type)
00407     {
00408     case NotifyType::StatusMessage:
00409         // Use the status message style.
00410         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00411         break;
00412     case NotifyType::ErrorMessage:
00413         // Use the error message style.
00414         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00415         break;
00416     default:
00417         break;
00418     }
00419     StatusBlock->Text = message;
00420 }
00421
00422 void MainPage::NotifyUserBackgroundThread(String^ message, NotifyType type)
00423 {
00424     Dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this, message, type]()
00425     {
00426         NotifyUser(message, type);
00427     }));
00428 }
00429
00430 void MainPage::AddContentValue(String^ title)
00431 {
00432     AddContentValue(title, nullptr);
00433 }
00434
00435 void MainPage::AddContentValue(String^ title, String^ description)
00436 {
00437     Run^ contentType = ref new Run();
00438     contentType->FontWeight = FontWeights::Bold;
00439     contentType->Text = title;
00440     ContentValue->Inlines->Append(contentType);
00441
00442     if (description != nullptr)
00443     {
00444         Run^ contentValue = ref new Run();
00445         contentValue->Text = description + "\n";
00446         ContentValue->Inlines->Append(contentValue);
00447     }
00448 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Constants.h Source File

  • EAS policies for mail clients

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Your Feature Name Here");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Constants.cpp Source File

  • File and folder thumbnail

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 using namespace Platform;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Storage;
00020 using namespace Windows::Storage::FileProperties;
00021 using namespace Windows::UI::ViewManagement;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Media::Imaging;
00024
00025 Array<Scenario>^ MainPage::scenariosInner = ref new Array<Scenario>
00026 {
00027     { "Display a thumbnail for a picture",    "SDKSample.FileThumbnails.Scenario1" },
00028     { "Display album art for a song",         "SDKSample.FileThumbnails.Scenario2" },
00029     { "Display an icon for a document",       "SDKSample.FileThumbnails.Scenario3" },
00030     { "Display a thumbnail for a folder",     "SDKSample.FileThumbnails.Scenario4" },
00031     { "Display a thumbnail for a file group", "SDKSample.FileThumbnails.Scenario5" },
00032 };
00033
00034 String^ Errors::NoExifThumbnail   = "No result (no EXIF thumbnail or cached thumbnail available for fast retrieval)";
00035 String^ Errors::NoThumbnail       = "No result (no thumbnail could be obtained from the selected file)";
00036 String^ Errors::NoAlbumArt        = "No result (no album art available for this song)";
00037 String^ Errors::NoIcon            = "No result (no icon available for this document type)";
00038 String^ Errors::NoImages          = "No result (no thumbnail could be obtained from the selected folder - make sure that the folder contains images)";
00039 String^ Errors::FileGroupEmpty    = "No result (unexpected error: retrieved file group was null)";
00040 String^ Errors::FileGroupLocation = "File groups are only available for library locations, please select a folder from one of your libraries";
00041 String^ Errors::Cancel            = "No result (operation cancelled, no item selected)";
00042
00043 Array<String^>^ FileExtensions::Document = ref new Array<String^>
00044 {
00045     ".doc",
00046     ".docx",
00047     ".xls",
00048     ".xlsx",
00049     ".ppt",
00050     ".pptx",
00051     ".pdf",
00052     ".txt",
00053     ".rtf",
00054 };
00055
00056 Array<String^>^ FileExtensions::Image = ref new Array<String^>
00057 {
00058     ".jpg",
00059     ".png",
00060     ".bmp",
00061     ".gif",
00062     ".tif",
00063 };
00064
00065 Array<String^>^ FileExtensions::Music = ref new Array<String^>
00066 {
00067     ".mp3",
00068     ".wma",
00069     ".m4a",
00070     ".aac",
00071 };
00072
00073 BitmapImage^ MainPage::GetPlaceHolderImage()
00074 {
00075     if (_placeholder == nullptr)
00076     {
00077         _placeholder = ref new BitmapImage(ref new Uri(BaseUri->AbsoluteUri, "Assets/placeholder-sdk.png"));
00078     }
00079
00080     return _placeholder;
00081 }
00082
00083 bool MainPage::EnsureUnsnapped()
00084 {
00085     // FilePicker APIs will not work if the application is in a snapped state.
00086     // If an app wants to show a FilePicker while snapped, it must attempt to unsnap first
00087     bool unsnapped = ((ApplicationView::Value != ApplicationViewState::Snapped) || ApplicationView::TryUnsnap());
00088     if (!unsnapped)
00089     {
00090         NotifyUser("Cannot unsnap the sample application", NotifyType::StatusMessage);
00091     }
00092
00093     return unsnapped;
00094 }
00095
00096 void MainPage::ResetOutput(Image^ image, TextBlock^ output, TextBlock^ outputDetails)
00097 {
00098     image->Source = GetPlaceHolderImage();
00099     NotifyUser("", NotifyType::ErrorMessage);
00100     NotifyUser("", NotifyType::StatusMessage);
00101     output->Text = "";
00102     if (outputDetails != nullptr)
00103     {
00104         outputDetails->Text = "";
00105     }
00106 }
00107
00108 void MainPage::DisplayResult(Image^ image, TextBlock^ textBlock, String^ thumbnailModeName, size_t size, IStorageItem^ item, StorageItemThumbnail^ thumbnail, bool isGroup)
00109 {
00110     BitmapImage^ bitmapImage = ref new BitmapImage();
00111
00112     bitmapImage->SetSource(thumbnail);
00113     image->Source = bitmapImage;
00114
00115     String^ itemType = isGroup ? "Group" : item->IsOfType(StorageItemTypes::File) ? "File" : "Folder";
00116     textBlock->Text = "ThumbnailMode." + thumbnailModeName + "\n"
00117         + itemType + " used: " + item->Name + "\n"
00118         + "Requested size: " + size.ToString() + "\n"
00119         + "Returned size: " + thumbnail->OriginalWidth.ToString() + "x" + thumbnail->OriginalHeight.ToString();
00120 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameInfoOverlay.cpp Source File

  • DirectX 3D shooting game

GameInfoOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "GameInfoOverlay.h"
00010 #include "DirectXSample.h"
00011
00012 using namespace Windows::UI::Core;
00013 using namespace Windows::Foundation;
00014 using namespace Microsoft::WRL;
00015 using namespace Windows::UI::ViewManagement;
00016 using namespace Windows::Graphics::Display;
00017 using namespace D2D1;
00018
00019 static const D2D1_RECT_F titleRectangle = D2D1::RectF(50.0f, 50.0f, GameInfoOverlayConstant::Width - 50.0f, 100.0f);
00020 static const D2D1_RECT_F bodyRectangle = D2D1::RectF(50.0f, 110.0f, GameInfoOverlayConstant::Width - 50.0f, GameInfoOverlayConstant::Height - 50.0f);
00021 static const D2D1_RECT_F actionRectangle = D2D1::RectF(50.0f, GameInfoOverlayConstant::Height - 45.0f, GameInfoOverlayConstant::Width - 50.0f, GameInfoOverlayConstant::Height - 5.0f);
00022 static const int bufferLength = 1000;
00023 static char16 wsbuffer[bufferLength];
00024
00025 GameInfoOverlay::GameInfoOverlay():
00026     m_visible(false),
00027     m_dpi(-1.0f)
00028 {
00029 }
00030
00031 //----------------------------------------------------------------------
00032
00033 void GameInfoOverlay::CreateDeviceIndependentResources(_In_ IDWriteFactory* dwriteFactory)
00034 {
00035     m_dwriteFactory = dwriteFactory;
00036
00037     // Create D2D Resources
00038     DX::ThrowIfFailed(
00039         m_dwriteFactory->CreateTextFormat(
00040             L"Segoe UI",
00041             nullptr,
00042             DWRITE_FONT_WEIGHT_MEDIUM,
00043             DWRITE_FONT_STYLE_NORMAL,
00044             DWRITE_FONT_STRETCH_NORMAL,
00045             32,         // font size
00046             L"en-us",   // locale
00047             &m_textFormatTitle
00048             )
00049         );
00050
00051     DX::ThrowIfFailed(
00052         m_dwriteFactory->CreateTextFormat(
00053             L"Segoe UI",
00054             nullptr,
00055             DWRITE_FONT_WEIGHT_LIGHT,
00056             DWRITE_FONT_STYLE_NORMAL,
00057             DWRITE_FONT_STRETCH_NORMAL,
00058             24,         // font size
00059             L"en-us",   // locale
00060             &m_textFormatBody
00061             )
00062         );
00063
00064     DX::ThrowIfFailed(
00065         m_textFormatTitle->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00066         );
00067     DX::ThrowIfFailed(
00068         m_textFormatTitle->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00069         );
00070     DX::ThrowIfFailed(
00071         m_textFormatBody->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00072         );
00073     DX::ThrowIfFailed(
00074         m_textFormatBody->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00075         );
00076 }
00077
00078 //----------------------------------------------------------------------
00079
00080 void GameInfoOverlay::CreateDeviceResources(_In_ ID2D1DeviceContext*  d2dContext)
00081 {
00082     m_d2dContext = d2dContext;
00083     m_dpi = -1.0f;
00084
00085     DX::ThrowIfFailed(
00086         m_d2dContext->CreateSolidColorBrush(
00087             D2D1::ColorF(D2D1::ColorF::White),
00088             &m_textBrush
00089             )
00090         );
00091     DX::ThrowIfFailed(
00092         m_d2dContext->CreateSolidColorBrush(
00093             D2D1::ColorF(D2D1::ColorF::Black),
00094             &m_backgroundBrush
00095             )
00096         );
00097     DX::ThrowIfFailed(
00098         m_d2dContext->CreateSolidColorBrush(
00099             D2D1::ColorF(0xdb7100, 1.0f),
00100             &m_actionBrush
00101             )
00102         );
00103 }
00104
00105 //----------------------------------------------------------------------
00106
00107 void GameInfoOverlay::CreateDpiDependentResources(float dpi)
00108 {
00109     if (m_dpi == dpi)
00110     {
00111         return;
00112     }
00113     m_dpi = dpi;
00114
00115     m_levelBitmap = nullptr;
00116
00117     // Create a D2D Bitmap to be used for Game Info Overlay when waiting to
00118     // start a level or when display game statistics.
00119     D2D1_BITMAP_PROPERTIES1 properties;
00120     properties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
00121     properties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
00122     properties.dpiX = m_dpi;
00123     properties.dpiY = m_dpi;
00124     properties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET;
00125     properties.colorContext = nullptr;
00126     DX::ThrowIfFailed(
00127         m_d2dContext->CreateBitmap(
00128             D2D1::SizeU(
00129                 static_cast<UINT32>(GameInfoOverlayConstant::Width * m_dpi / 96.0f),
00130                 static_cast<UINT32>(GameInfoOverlayConstant::Height * m_dpi / 96.0f)
00131                 ),
00132             nullptr,
00133             0,
00134             &properties,
00135             &m_levelBitmap
00136             )
00137         );
00138     m_d2dContext->SetTarget(m_levelBitmap.Get());
00139     m_d2dContext->BeginDraw();
00140     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00141     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));
00142
00143     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00144     // is lost. It will be handled during the next call to Present.
00145     HRESULT hr = m_d2dContext->EndDraw();
00146     if (hr != D2DERR_RECREATE_TARGET)
00147     {
00148         DX::ThrowIfFailed(hr);
00149     }
00150 }
00151
00152 //----------------------------------------------------------------------
00153
00154 void GameInfoOverlay::SetGameLoading(uint32 dots)
00155 {
00156     int length;
00157     Platform::String^ string = "Loading Resources";
00158
00159     m_d2dContext->SetTarget(m_levelBitmap.Get());
00160     m_d2dContext->BeginDraw();
00161     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00162     m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
00163     m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
00164     m_d2dContext->FillRectangle(&actionRectangle, m_backgroundBrush.Get());
00165
00166     m_d2dContext->DrawText(
00167         string->Data(),
00168         string->Length(),
00169         m_textFormatTitle.Get(),
00170         titleRectangle,
00171         m_textBrush.Get()
00172         );
00173
00174     dots = dots % 10;
00175     for (length = 0; length < 25; length++)
00176     {
00177         wsbuffer[length] = L' ';
00178     }
00179     for (uint32 i = 0; i < dots; i++)
00180     {
00181         wsbuffer[length++] = 0x25CF;   // This is a Dot character in the font.
00182         wsbuffer[length++] = L' ';
00183         wsbuffer[length++] = L' ';
00184         wsbuffer[length++] = L' ';
00185     }
00186
00187     m_d2dContext->DrawText(
00188         wsbuffer,
00189         length,
00190         m_textFormatBody.Get(),
00191         bodyRectangle,
00192         m_actionBrush.Get()
00193         );
00194
00195     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00196     // is lost. It will be handled during the next call to Present.
00197     HRESULT hr = m_d2dContext->EndDraw();
00198     if (hr != D2DERR_RECREATE_TARGET)
00199     {
00200         DX::ThrowIfFailed(hr);
00201     }
00202 }
00203
00204 //----------------------------------------------------------------------
00205
00206 void GameInfoOverlay::SetGameStats(int maxLevel, int hitCount, int shotCount)
00207 {
00208     int length;
00209     Platform::String^ string;
00210
00211     m_d2dContext->SetTarget(m_levelBitmap.Get());
00212     m_d2dContext->BeginDraw();
00213     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00214     m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
00215     m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
00216     string = "High Score";
00217
00218     m_d2dContext->DrawText(
00219         string->Data(),
00220         string->Length(),
00221         m_textFormatTitle.Get(),
00222         titleRectangle,
00223         m_textBrush.Get()
00224         );
00225     length = swprintf_s(
00226         wsbuffer,
00227         bufferLength,
00228         L"Levels Completed %d\nTotal Points %d\nTotal Shots %d",
00229         maxLevel,
00230         hitCount,
00231         shotCount
00232         );
00233     string = ref new Platform::String(wsbuffer, length);
00234     m_d2dContext->DrawText(
00235         string->Data(),
00236         string->Length(),
00237         m_textFormatBody.Get(),
00238         bodyRectangle,
00239         m_textBrush.Get()
00240         );
00241
00242     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00243     // is lost. It will be handled during the next call to Present.
00244     HRESULT hr = m_d2dContext->EndDraw();
00245     if (hr != D2DERR_RECREATE_TARGET)
00246     {
00247         DX::ThrowIfFailed(hr);
00248     }
00249 }
00250
00251 //----------------------------------------------------------------------
00252
00253 void GameInfoOverlay::SetGameOver(bool win, int maxLevel, int hitCount, int shotCount, int highScore)
00254 {
00255     int length;
00256     Platform::String^ string;
00257
00258
00259     m_d2dContext->SetTarget(m_levelBitmap.Get());
00260     m_d2dContext->BeginDraw();
00261     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00262     m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
00263     m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
00264     if (win)
00265     {
00266         string = "You WON!";
00267     }
00268     else
00269     {
00270         string = "Game Over";
00271     }
00272     m_d2dContext->DrawText(
00273         string->Data(),
00274         string->Length(),
00275         m_textFormatTitle.Get(),
00276         titleRectangle,
00277         m_textBrush.Get()
00278         );
00279     length = swprintf_s(
00280         wsbuffer,
00281         bufferLength,
00282         L"Levels Completed %d\nTotal Points %d\nTotal Shots %d\n\nHigh Score %d\n",
00283         maxLevel,
00284         hitCount,
00285         shotCount,
00286         highScore
00287         );
00288     m_d2dContext->DrawText(
00289         wsbuffer,
00290         length,
00291         m_textFormatBody.Get(),
00292         bodyRectangle,
00293         m_textBrush.Get()
00294         );
00295
00296     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00297     // is lost. It will be handled during the next call to Present.
00298     HRESULT hr = m_d2dContext->EndDraw();
00299     if (hr != D2DERR_RECREATE_TARGET)
00300     {
00301         DX::ThrowIfFailed(hr);
00302     }
00303 }
00304
00305 //----------------------------------------------------------------------
00306
00307 void GameInfoOverlay::SetLevelStart(int level, Platform::String^ objective, float timeLimit, float bonusTime)
00308 {
00309     int length;
00310     Platform::String^ string;
00311
00312     m_d2dContext->SetTarget(m_levelBitmap.Get());
00313     m_d2dContext->BeginDraw();
00314     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00315     m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
00316     m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
00317     length = swprintf_s(wsbuffer, bufferLength, L"Level %d", level);
00318     m_d2dContext->DrawText(
00319         wsbuffer,
00320         length,
00321         m_textFormatTitle.Get(),
00322         titleRectangle,
00323         m_textBrush.Get()
00324         );
00325
00326     if (bonusTime > 0.0f)
00327     {
00328         length = swprintf_s(
00329             wsbuffer,
00330             bufferLength,
00331             L"Objective: %s\nTime  Limit: %6.1f sec\nBonus Time: %6.1f sec\n",
00332             objective->Data(),
00333             timeLimit,
00334             bonusTime
00335             );
00336     }
00337     else
00338     {
00339         length = swprintf_s(
00340             wsbuffer,
00341             bufferLength,
00342             L"Objective: %s\nTime  Limit: %6.1f sec\n",
00343             objective->Data(),
00344             timeLimit
00345             );
00346     }
00347     string = ref new Platform::String(wsbuffer, length);
00348     m_d2dContext->DrawText(
00349         string->Data(),
00350         string->Length(),
00351         m_textFormatBody.Get(),
00352         bodyRectangle,
00353         m_textBrush.Get()
00354         );
00355
00356     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00357     // is lost. It will be handled during the next call to Present.
00358     HRESULT hr = m_d2dContext->EndDraw();
00359     if (hr != D2DERR_RECREATE_TARGET)
00360     {
00361         DX::ThrowIfFailed(hr);
00362     }
00363 }
00364
00365 //----------------------------------------------------------------------
00366
00367 void GameInfoOverlay::SetPause()
00368 {
00369     Platform::String^ string;
00370
00371     m_d2dContext->SetTarget(m_levelBitmap.Get());
00372     m_d2dContext->BeginDraw();
00373     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00374     m_d2dContext->FillRectangle(&titleRectangle, m_backgroundBrush.Get());
00375     m_d2dContext->FillRectangle(&bodyRectangle, m_backgroundBrush.Get());
00376     string = "Game Paused";
00377
00378     m_d2dContext->DrawText(
00379         string->Data(),
00380         string->Length(),
00381         m_textFormatTitle.Get(),
00382         bodyRectangle,
00383         m_textBrush.Get()
00384         );
00385
00386     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00387     // is lost. It will be handled during the next call to Present.
00388     HRESULT hr = m_d2dContext->EndDraw();
00389     if (hr != D2DERR_RECREATE_TARGET)
00390     {
00391         DX::ThrowIfFailed(hr);
00392     }
00393 }
00394
00395 //----------------------------------------------------------------------
00396
00397 void GameInfoOverlay::SetAction(GameInfoOverlayCommand action)
00398 {
00399     Platform::String^ string;
00400
00401     m_d2dContext->SetTarget(m_levelBitmap.Get());
00402     m_d2dContext->BeginDraw();
00403     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00404     m_d2dContext->FillRectangle(&actionRectangle, m_backgroundBrush.Get());
00405
00406     switch (action)
00407     {
00408     case GameInfoOverlayCommand::PlayAgain:
00409         string = "Tap to play again ...";
00410         break;
00411     case GameInfoOverlayCommand::PleaseWait:
00412         string = "Level loading, please wait ...";
00413         break;
00414     case GameInfoOverlayCommand::TapToContinue:
00415         string = "Tap to continue ...";
00416         break;
00417     default:
00418         string = "";
00419         break;
00420     }
00421     if (action != GameInfoOverlayCommand::None)
00422     {
00423         m_d2dContext->DrawText(
00424             string->Data(),
00425             string->Length(),
00426             m_textFormatBody.Get(),
00427             actionRectangle,
00428             m_actionBrush.Get()
00429             );
00430     }
00431
00432     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00433     // is lost. It will be handled during the next call to Present.
00434     HRESULT hr = m_d2dContext->EndDraw();
00435     if (hr != D2DERR_RECREATE_TARGET)
00436     {
00437         DX::ThrowIfFailed(hr);
00438     }
00439 }
00440
00441 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/LayoutAwarePage.cpp Source File

  • Hilo C++
  • Hilo
  • Common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "LayoutAwarePage.h"
00009 #include "SuspensionManager.h"
00010
00011 using namespace Hilo::Common;
00012
00013 using namespace Platform;
00014 using namespace Platform::Collections;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::Foundation::Collections;
00017 using namespace Windows::System;
00018 using namespace Windows::UI::Core;
00019 using namespace Windows::UI::ViewManagement;
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::UI::Xaml::Interop;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 /// <summary>
00026 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00027 /// </summary>
00028 LayoutAwarePage::LayoutAwarePage()
00029 {
00030   if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00031   {
00032     return;
00033   }
00034
00035   // Create an empty default view model
00036   DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00037
00038   // When this page is part of the visual tree make two changes:
00039   // 1) Map application view state to visual state for the page
00040   // 2) Handle keyboard and mouse navigation requests
00041   Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00042
00043   // Undo the same changes when the page is no longer visible
00044   Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00045 }
00046
00047 static DependencyProperty^ _defaultViewModelProperty =
00048   DependencyProperty::Register("DefaultViewModel",
00049   TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00050
00051 /// <summary>
00052 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00053 /// </summary>
00054 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00055 {
00056   return _defaultViewModelProperty;
00057 }
00058
00059 /// <summary>
00060 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00061 /// used as a trivial view model.
00062 /// </summary>
00063 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00064 {
00065   return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00066 }
00067
00068 /// <summary>
00069 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00070 /// used as a trivial view model.
00071 /// </summary>
00072 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00073 {
00074   SetValue(DefaultViewModelProperty, value);
00075 }
00076
00077 /// <summary>
00078 /// Invoked when the page is part of the visual tree
00079 /// </summary>
00080 /// <param name="sender">Instance that triggered the event.</param>
00081 /// <param name="e">Event data describing the conditions that led to the event.</param>
00082 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00083 {
00084   this->StartLayoutUpdates(sender, e);
00085
00086   // Keyboard and mouse navigation only apply when occupying the entire window
00087   if (this->ActualHeight == Window::Current->Bounds.Height &&
00088     this->ActualWidth == Window::Current->Bounds.Width)
00089   {
00090     // Listen to the window directly so focus isn't required
00091     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00092       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00093       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00094     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00095       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00096       &LayoutAwarePage::CoreWindow_PointerPressed);
00097     _navigationShortcutsRegistered = true;
00098   }
00099 }
00100
00101 /// <summary>
00102 /// Invoked when the page is removed from visual tree
00103 /// </summary>
00104 /// <param name="sender">Instance that triggered the event.</param>
00105 /// <param name="e">Event data describing the conditions that led to the event.</param>
00106 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00107 {
00108   if (_navigationShortcutsRegistered)
00109   {
00110     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00111     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00112     _navigationShortcutsRegistered = false;
00113   }
00114   StopLayoutUpdates(sender, e);
00115 }
00116
00117 #pragma region Navigation support
00118
00119 /// <summary>
00120 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00121 /// until it reaches the top of the navigation stack.
00122 /// </summary>
00123 /// <param name="sender">Instance that triggered the event.</param>
00124 /// <param name="e">Event data describing the conditions that led to the event.</param>
00125 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00126 {
00127   (void) sender;  // Unused parameter
00128   (void) e; // Unused parameter
00129
00130   // Use the navigation frame to return to the topmost page
00131   if (Frame != nullptr)
00132   {
00133     while (Frame->CanGoBack)
00134     {
00135       Frame->GoBack();
00136     }
00137   }
00138 }
00139
00140 /// <summary>
00141 /// Invoked as an event handler to navigate backward in the navigation stack
00142 /// associated with this page's <see cref="Frame"/>.
00143 /// </summary>
00144 /// <param name="sender">Instance that triggered the event.</param>
00145 /// <param name="e">Event data describing the conditions that led to the event.</param>
00146 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00147 {
00148   (void) sender;  // Unused parameter
00149   (void) e; // Unused parameter
00150
00151   // Use the navigation frame to return to the previous page
00152   if (Frame != nullptr && Frame->CanGoBack)
00153   {
00154     Frame->GoBack();
00155   }
00156 }
00157
00158 /// <summary>
00159 /// Invoked as an event handler to navigate forward in the navigation stack
00160 /// associated with this page's <see cref="Frame"/>.
00161 /// </summary>
00162 /// <param name="sender">Instance that triggered the event.</param>
00163 /// <param name="e">Event data describing the conditions that led to the event.</param>
00164 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00165 {
00166   (void) sender;  // Unused parameter
00167   (void) e; // Unused parameter
00168
00169   // Use the navigation frame to advance to the next page
00170   if (Frame != nullptr && Frame->CanGoForward)
00171   {
00172     Frame->GoForward();
00173   }
00174 }
00175
00176 /// <summary>
00177 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00178 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00179 /// between pages even when the page itself doesn't have focus.
00180 /// </summary>
00181 /// <param name="sender">Instance that triggered the event.</param>
00182 /// <param name="args">Event data describing the conditions that led to the event.</param>
00183 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender,
00184                                AcceleratorKeyEventArgs^ args)
00185 {
00186   auto virtualKey = args->VirtualKey;
00187
00188   // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00189   // are pressed
00190   if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00191     args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00192     (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00193     (int)virtualKey == 166 || (int)virtualKey == 167))
00194   {
00195     auto coreWindow = Window::Current->CoreWindow;
00196     auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00197     bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00198     bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00199     bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00200     bool noModifiers = !menuKey && !controlKey && !shiftKey;
00201     bool onlyAlt = menuKey && !controlKey && !shiftKey;
00202
00203     if (((int)virtualKey == 166 && noModifiers) ||
00204       (virtualKey == VirtualKey::Left && onlyAlt))
00205     {
00206       // When the previous key or Alt+Left are pressed navigate back
00207       args->Handled = true;
00208       GoBack(this, ref new RoutedEventArgs());
00209     }
00210     else if (((int)virtualKey == 167 && noModifiers) ||
00211       (virtualKey == VirtualKey::Right && onlyAlt))
00212     {
00213       // When the next key or Alt+Right are pressed navigate forward
00214       args->Handled = true;
00215       GoForward(this, ref new RoutedEventArgs());
00216     }
00217   }
00218 }
00219
00220 /// <summary>
00221 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00222 /// page is active and occupies the entire window.  Used to detect browser-style next and
00223 /// previous mouse button clicks to navigate between pages.
00224 /// </summary>
00225 /// <param name="sender">Instance that triggered the event.</param>
00226 /// <param name="args">Event data describing the conditions that led to the event.</param>
00227 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00228 {
00229   auto properties = args->CurrentPoint->Properties;
00230
00231   // Ignore button chords with the left, right, and middle buttons
00232   if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00233     properties->IsMiddleButtonPressed) return;
00234
00235   // If back or foward are pressed (but not both) navigate appropriately
00236   bool backPressed = properties->IsXButton1Pressed;
00237   bool forwardPressed = properties->IsXButton2Pressed;
00238   if (backPressed ^ forwardPressed)
00239   {
00240     args->Handled = true;
00241     if (backPressed) GoBack(this, ref new RoutedEventArgs());
00242     if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00243   }
00244 }
00245
00246 #pragma endregion
00247
00248 #pragma region Visual state switching
00249
00250 /// <summary>
00251 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00252 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00253 /// visual state management changes that correspond to application view state changes.
00254 /// </summary>
00255 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00256 /// corresponding to view states.</param>
00257 /// <param name="e">Event data that describes how the request was made.</param>
00258 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00259 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00260 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00261 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00262 /// events.</remarks>
00263 /// <seealso cref="DetermineVisualState"/>
00264 /// <seealso cref="InvalidateVisualState"/>
00265 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00266 {
00267   (void) e; // Unused parameter
00268
00269   auto control = safe_cast<Control^>(sender);
00270   if (_layoutAwareControls == nullptr)
00271   {
00272     // Start listening to view state changes when there are controls interested in updates
00273     _layoutAwareControls = ref new Vector<Control^>();
00274     _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00275
00276     // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00277     _this = this;
00278   }
00279   _layoutAwareControls->Append(control);
00280
00281   // Set the initial visual state of the control
00282   VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00283 }
00284
00285 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00286 {
00287   (void) sender;  // Unused parameter
00288   (void) e; // Unused parameter
00289
00290   InvalidateVisualState();
00291 }
00292
00293 /// <summary>
00294 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00295 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00296 /// management changes that correspond to application view state changes.
00297 /// </summary>
00298 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00299 /// corresponding to view states.</param>
00300 /// <param name="e">Event data that describes how the request was made.</param>
00301 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00302 /// when layout updates are requested.</remarks>
00303 /// <seealso cref="StartLayoutUpdates"/>
00304 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00305 {
00306   (void) e; // Unused parameter
00307
00308   auto control = safe_cast<Control^>(sender);
00309   unsigned int index;
00310   if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00311   {
00312     _layoutAwareControls->RemoveAt(index);
00313     if (_layoutAwareControls->Size == 0)
00314     {
00315       // Stop listening to view state changes when no controls are interested in updates
00316       Window::Current->SizeChanged -= _windowSizeEventToken;
00317       _layoutAwareControls = nullptr;
00318       // Last control has received the Unload notification.
00319       _this = nullptr;
00320     }
00321   }
00322 }
00323
00324 /// <summary>
00325 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00326 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00327 /// override this method to control the mapping scheme used.
00328 /// </summary>
00329 /// <param name="viewState">View state for which a visual state is desired.</param>
00330 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00331 /// <seealso cref="InvalidateVisualState"/>
00332 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00333 {
00334   switch (viewState)
00335   {
00336   case ApplicationViewState::Filled:
00337     return "Filled";
00338   case ApplicationViewState::Snapped:
00339     return "Snapped";
00340   case ApplicationViewState::FullScreenPortrait:
00341     return "FullScreenPortrait";
00342   case ApplicationViewState::FullScreenLandscape:
00343   default:
00344     return "FullScreenLandscape";
00345   }
00346 }
00347
00348 /// <summary>
00349 /// Updates all controls that are listening for visual state changes with the correct visual
00350 /// state.
00351 /// </summary>
00352 /// <remarks>
00353 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00354 /// signal that a different value may be returned even though the view state has not changed.
00355 /// </remarks>
00356 void LayoutAwarePage::InvalidateVisualState()
00357 {
00358   if (_layoutAwareControls != nullptr)
00359   {
00360     String^ visualState = DetermineVisualState(ApplicationView::Value);
00361     auto controlIterator = _layoutAwareControls->First();
00362     while (controlIterator->HasCurrent)
00363     {
00364       auto control = controlIterator->Current;
00365       VisualStateManager::GoToState(control, visualState, false);
00366       controlIterator->MoveNext();
00367     }
00368   }
00369 }
00370
00371 #pragma endregion
00372
00373 #pragma region Process lifetime management
00374
00375 /// <summary>
00376 /// Invoked when this page is about to be displayed in a Frame.
00377 /// </summary>
00378 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00379 /// property provides the group to be displayed.</param>
00380 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00381 {
00382   // Returning to a cached page through navigation shouldn't trigger state loading
00383   if (_pageKey != nullptr) return;
00384
00385   auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00386   _pageKey = "Page-" + Frame->BackStackDepth;
00387
00388   if (e->NavigationMode == NavigationMode::New)
00389   {
00390     // Clear existing state for forward navigation when adding a new page to the
00391     // navigation stack
00392     auto nextPageKey = _pageKey;
00393     int nextPageIndex = Frame->BackStackDepth;
00394     while (frameState->HasKey(nextPageKey))
00395     {
00396       frameState->Remove(nextPageKey);
00397       nextPageIndex++;
00398       nextPageKey = "Page-" + nextPageIndex;
00399     }
00400
00401     // Pass the navigation parameter to the new page
00402     LoadState(e->Parameter, nullptr);
00403   }
00404   else
00405   {
00406     // Pass the navigation parameter and preserved page state to the page, using
00407     // the same strategy for loading suspended state and recreating pages discarded
00408     // from cache
00409     LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00410   }
00411 }
00412
00413 /// <summary>
00414 /// Invoked when this page will no longer be displayed in a Frame.
00415 /// </summary>
00416 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00417 /// property provides the group to be displayed.</param>
00418 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00419 {
00420   auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00421   auto pageState = ref new Map<String^, Object^>();
00422   SaveState(pageState);
00423   frameState->Insert(_pageKey, pageState);
00424 }
00425
00426 /// <summary>
00427 /// Populates the page with content passed during navigation.  Any saved state is also
00428 /// provided when recreating a page from a prior session.
00429 /// </summary>
00430 /// <param name="navigationParameter">The parameter value passed to
00431 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00432 /// </param>
00433 /// <param name="pageState">A map of state preserved by this page during an earlier
00434 /// session.  This will be null the first time a page is visited.</param>
00435 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00436 {
00437 }
00438
00439 /// <summary>
00440 /// Preserves state associated with this page in case the application is suspended or the
00441 /// page is discarded from the navigation cache.  Values must conform to the serialization
00442 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00443 /// </summary>
00444 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00445 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00446 {
00447 }
00448
00449 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/MainPage.xaml.cpp Source File

  • Playlist

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput3.xaml.h Source File

  • Toast notifications
  • C#,C++

ScenarioOutput3.xaml.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Output.xaml.h
00010 // Declaration of the Scenario3Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput3.g.h"
00017 #include "MainPage.g.h"
00018
00019 using namespace Windows::UI::Xaml;
00020 using namespace Windows::UI::ViewManagement;
00021
00022 namespace ToastsSampleCPP
00023 {
00024   [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class ScenarioOutput3 sealed
00026     {
00027     public:
00028         ScenarioOutput3();
00029
00030     protected:
00031         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033     private:
00034         ~ScenarioOutput3();
00035
00036     MainPage^ rootPage;
00037         void Page_Loaded(Object^ sender, RoutedEventArgs^ e);
00038         void rootPage_InputFrameLoaded(Object^ sender, Object^ e);
00039         void Page_SizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00040         void DisplayProperties_LogicalDpiChanged(Object^ sender);
00041         Windows::Foundation::EventRegistrationToken _frameLoadedToken;
00042         void CheckResolutionAndViewState();
00043     };
00044 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/DDSTextureLoader.cpp Source File

  • Direct3D tutorial
  • Lesson5.Components

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/pch.h Source File

  • USSD message management

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <windows.h>
00019 #include <strsafe.h>
00020 #include <collection.h>
00021 #include <ppltasks.h>
00022 #include "Common\LayoutAwarePage.h"
00023 #include "Common\SuspensionManager.h"
00024 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/common/LayoutAwarePage.cpp Source File

  • Real-time communication
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013
00014 using namespace SimpleCommunication::Common;
00015
00016 using namespace Platform;
00017 using namespace Platform::Collections;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Foundation::Collections;
00020 using namespace Windows::UI::ViewManagement;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023
00024 /// <summary>
00025 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00026 /// </summary>
00027 LayoutAwarePage::LayoutAwarePage()
00028 {
00029   if (Windows::ApplicationModel::DesignMode::DesignModeEnabled) return;
00030
00031   // Map application view state to visual state for this page when it is part of the visual tree
00032   Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::StartLayoutUpdates);
00033   Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::StopLayoutUpdates);
00034
00035   // Establish the default view model as the initial DataContext
00036   DataContext = _defaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00037 }
00038
00039 /// <summary>
00040 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> set as the page's
00041 /// default <see cref="DataContext"/>.  This instance can be bound and surfaces property change
00042 /// notifications making it suitable for use as a trivial view model.
00043 /// </summary>
00044 IObservableMap<Platform::String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00045 {
00046   return _defaultViewModel;
00047 }
00048
00049 /// <summary>
00050 /// Gets a value indicating whether visual states can be a loose interpretation of the actual
00051 /// application view state.  This is often convenient when a page layout is space constrained.
00052 /// </summary>
00053 /// <remarks>
00054 /// The default value of false indicates that the visual state is identical to the view state,
00055 /// meaning that Filled is only used when another application is snapped.  When set to true
00056 /// FullScreenLandscape is used to indicate that at least 1366 virtual pixels of horizontal real
00057 /// estate are available - even if another application is snapped - and Filled indicates a lesser
00058 /// width, even if no other application is snapped.  On a smaller display such as a 1024x768
00059 /// panel this will result in the visual state Filled whenever the device is in landscape
00060 /// orientation.
00061 /// </remarks>
00062 bool LayoutAwarePage::UseFilledStateForNarrowWindow::get()
00063 {
00064   return _useFilledStateForNarrowWindow;
00065 }
00066
00067 /// <summary>
00068 /// Sets a value indicating whether visual states can be a loose interpretation of the actual
00069 /// application view state.  This is often convenient when a page layout is space constrained.
00070 /// </summary>
00071 /// <remarks>
00072 /// The default value of false indicates that the visual state is identical to the view state,
00073 /// meaning that Filled is only used when another application is snapped.  When set to true
00074 /// FullScreenLandscape is used to indicate that at least 1366 virtual pixels of horizontal real
00075 /// estate are available - even if another application is snapped - and Filled indicates a lesser
00076 /// width, even if no other application is snapped.  On a smaller display such as a 1024x768
00077 /// panel this will result in the visual state Filled whenever the device is in landscape
00078 /// orientation.
00079 /// </remarks>
00080 void LayoutAwarePage::UseFilledStateForNarrowWindow::set(bool value)
00081 {
00082   _useFilledStateForNarrowWindow = value;
00083   this->InvalidateVisualState();
00084 }
00085
00086 /// <summary>
00087 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00088 /// until it reaches the top of the navigation stack.
00089 /// </summary>
00090 /// <param name="sender">Instance that triggered the event.</param>
00091 /// <param name="e">Event data describing the conditions that led to the event.</param>
00092 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00093 {
00094   // Use the navigation frame to return to the topmost page
00095   if (Frame != nullptr)
00096   {
00097     while (Frame->CanGoBack) Frame->GoBack();
00098   }
00099 }
00100
00101 /// <summary>
00102 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00103 /// to go back one step on the navigation stack.
00104 /// </summary>
00105 /// <param name="sender">Instance that triggered the event.</param>
00106 /// <param name="e">Event data describing the conditions that led to the event.</param>
00107 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00108 {
00109   // Use the navigation frame to return to the previous page
00110   if (Frame != nullptr && Frame->CanGoBack) Frame->GoBack();
00111 }
00112
00113 /// <summary>
00114 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00115 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00116 /// visual state management changes that correspond to application view state changes.
00117 /// </summary>
00118 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00119 /// corresponding to view states.</param>
00120 /// <param name="e">Event data that describes how the request was made.</param>
00121 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00122 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00123 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00124 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00125 /// events.</remarks>
00126 /// <seealso cref="DetermineVisualState"/>
00127 /// <seealso cref="InvalidateVisualState"/>
00128 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00129 {
00130   auto control = safe_cast<Control^>(sender);
00131   if (_layoutAwareControls == nullptr) {
00132     // Start listening to view state changes when there are controls interested in updates
00133     _layoutAwareControls = ref new Vector<Control^>();
00134     _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00135   }
00136   _layoutAwareControls->Append(control);
00137
00138   // Set the initial visual state of the control
00139   VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00140 }
00141
00142 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00143 {
00144   InvalidateVisualState();
00145 }
00146
00147 /// <summary>
00148 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00149 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00150 /// management changes that correspond to application view state changes.
00151 /// </summary>
00152 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00153 /// corresponding to view states.</param>
00154 /// <param name="e">Event data that describes how the request was made.</param>
00155 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00156 /// when layout updates are requested.</remarks>
00157 /// <seealso cref="StartLayoutUpdates"/>
00158 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00159 {
00160   auto control = safe_cast<Control^>(sender);
00161   unsigned int index;
00162   if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00163   {
00164     _layoutAwareControls->RemoveAt(index);
00165     if (_layoutAwareControls->Size == 0)
00166     {
00167       // Stop listening to view state changes when no controls are interested in updates
00168       Window::Current->SizeChanged -= _windowSizeEventToken;
00169       _layoutAwareControls = nullptr;
00170     }
00171   }
00172 }
00173
00174 /// <summary>
00175 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00176 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00177 /// override this method to control the mapping scheme used.
00178 /// </summary>
00179 /// <param name="viewState">View state for which a visual state is desired.</param>
00180 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00181 /// <seealso cref="InvalidateVisualState"/>
00182 Platform::String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00183 {
00184   auto actualViewState = viewState;
00185   if (_useFilledStateForNarrowWindow &&
00186     (viewState == ApplicationViewState::Filled ||
00187     viewState == ApplicationViewState::FullScreenLandscape))
00188   {
00189     // Allow pages to request that the Filled state be used only for landscape layouts narrower
00190     // than 1366 virtual pixels
00191     auto windowWidth = Window::Current->Bounds.Width;
00192     actualViewState = windowWidth >= 1366 ? ApplicationViewState::FullScreenLandscape : ApplicationViewState::Filled;
00193   }
00194   switch (actualViewState)
00195   {
00196   case ApplicationViewState::Filled: return "Filled";
00197   case ApplicationViewState::Snapped: return "Snapped";
00198   case ApplicationViewState::FullScreenPortrait: return "FullScreenPortrait";
00199   default: case ApplicationViewState::FullScreenLandscape: return "FullScreenLandscape";
00200   }
00201 }
00202
00203 /// <summary>
00204 /// Updates all controls that are listening for visual state changes with the correct visual
00205 /// state.
00206 /// </summary>
00207 /// <remarks>
00208 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00209 /// signal that a different value may be returned even though the view state has not changed.
00210 /// </remarks>
00211 void LayoutAwarePage::InvalidateVisualState()
00212 {
00213   if (_layoutAwareControls != nullptr)
00214   {
00215     String^ visualState = DetermineVisualState(ApplicationView::Value);
00216     auto controlIterator = _layoutAwareControls->First();
00217     while (controlIterator->HasCurrent)
00218     {
00219       auto control = controlIterator->Current;
00220       VisualStateManager::GoToState(control, visualState, false);
00221       controlIterator->MoveNext();
00222     }
00223   }
00224 }
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/MainPage.xaml.cpp Source File

  • HttpClient

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/DirectXSample.h Source File

  • Direct2D custom image effects
  • PixelShader

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/pch.cpp Source File

  • App package information

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput2.xaml.cpp Source File

  • Toast notifications
  • C#,C++

ScenarioOutput2.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Output.xaml.cpp
00010 // Implementation of the Scenario2Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput2.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace ToastsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput2::ScenarioOutput2()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput2::~ScenarioOutput2()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput2::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044   // Get a pointer to our main page.
00045   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047   // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048   _frameLoadedToken = rootPage->InputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioOutput2::rootPage_InputFrameLoaded);
00049 }
00050
00051 void ScenarioOutput2::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00054 }
00055
00056 #pragma endregion
00057
00058 #pragma region Use this code if you need access to elements in the input frame - otherwise deletea
00059 void ScenarioOutput2::rootPage_InputFrameLoaded(Object^ sender, Object^ e)
00060 {
00061     // Get a pointer to the content within the OutputFrame.
00062     Page^ inputFrame = dynamic_cast<Page^>(rootPage->InputFrame->Content);
00063
00064     // Go find the elements that we need for this scenario
00065     // ex: flipView1 = dynamic_cast<FlipView^>(inputFrame->FindName("FlipView1"));
00066 }
00067
00068 #pragma endregion
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ContactPicker::MainPagePicker Member List

This is the complete list of members for ContactPicker::MainPagePicker, including all inherited members.
scenariosInner ContactPicker::MainPagePicker [private, static]
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/App.xaml.cpp Source File

  • XAML Direct2D lighting effects

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "App.xaml.h"
00010
00011 using namespace D2DLightingEffects;
00012
00013 using namespace Platform;
00014 using namespace Windows::ApplicationModel;
00015 using namespace Windows::ApplicationModel::Core;
00016 using namespace Windows::ApplicationModel::Activation;
00017 using namespace Windows::UI::Core;
00018 using namespace Windows::UI::ViewManagement;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Controls::Primitives;
00024 using namespace Windows::UI::Xaml::Data;
00025 using namespace Windows::UI::Xaml::Input;
00026 using namespace Windows::UI::Xaml::Media;
00027 using namespace Windows::UI::Xaml::Navigation;
00028 using namespace Windows::UI::Xaml::Media::Animation;
00029 using namespace Windows::Graphics::Display;
00030
00031 App::App()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 void App::OnLaunched(
00037     _In_ LaunchActivatedEventArgs^ args
00038     )
00039 {
00040     m_mainPage = ref new MainPage();
00041
00042     Window::Current->Content = m_mainPage;
00043     Window::Current->Activate();
00044
00045     Suspending += ref new SuspendingEventHandler(this, &App::OnSuspending);
00046     Resuming += ref new EventHandler<Object^>(this, &App::OnResuming);
00047 }
00048
00049 void App::OnResuming(
00050     _In_ Object^ sender,
00051     _In_ Object^ args
00052     )
00053 {
00054     // Intentionally left blank. The settings are already preserved if an app is resuming
00055     // from a suspended state. Otherwise, the previous settings are loaded when MainPage is
00056     // constructed.
00057 }
00058
00059 void App::OnSuspending(
00060     _In_ Object^ sender,
00061     _In_ SuspendingEventArgs^ args
00062     )
00063 {
00064     m_mainPage->OnSuspending(sender, args);
00065 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/App.xaml.h Source File

  • Media Play To

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/LowLatency.xaml.h Source File

  • Real-time communication

LowLatency.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // LowLatency.xaml.h
00013 // Declaration of the LowLatency class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Utils.h"
00020 #include "LowLatency.g.h"
00021 #include "MainPage.xaml.h"
00022
00023 namespace SimpleCommunication
00024 {
00025     /// <summary>
00026     /// An empty page that can be used on its own or navigated to within a Frame.
00027     /// </summary>
00028   [Windows::Foundation::Metadata::WebHostHidden]
00029     public ref class LowLatency sealed
00030     {
00031     public:
00032         LowLatency();
00033
00034     protected:
00035         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036         virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00037         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         void VisibilityChanged(Object^ sender, Windows::UI::Core::VisibilityChangedEventArgs^ e);
00040
00041     private:
00042         task<void> Initialize();
00043         void InitializeUIControls();
00044         void Reset();
00045         void UpdateLocalClientWindow();
00046         task<void> Cleanup();
00047         task<void> StartRecordingToCustomSink();
00048
00049         VideoSettingsFilter^ _videoSettingsFilter;
00050
00051         Windows::Foundation::EventRegistrationToken _incomingConnectionEventRegistrationToken;
00052         Windows::Foundation::EventRegistrationToken _mediaCaptureFailedEventRegistrationToken;
00053         void OnMediaCaptureFailed(CaptureDevice^ sender, CaptureFailedEventArgs^ errorEventArgs);
00054         void OnIncomingConnection(Microsoft::Samples::SimpleCommunication::StspMediaSink^ sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ args);
00055
00056         enum class ScenarioOneStates
00057         {
00058             uninitialized,
00059             initializing,
00060             waiting,
00061             previewing,
00062             streaming,
00063             end,
00064         };
00065         ScenarioOneStates _currentState;
00066         ScenarioOneStates _previousState;
00067
00068         /// This is the FSM encapsulating the state table (states and actions) of the scenario.
00069         delegate IAsyncAction^ ActionTransition();
00070         std::map<ScenarioOneStates, std::array<ActionTransition^, 5>> actionTransitionFunctions;
00071         IAsyncAction^ initializing_previewSetupCompleted();
00072         IAsyncAction^ waiting_previewButtonClicked();
00073         IAsyncAction^ previewing_previewButtonClicked();
00074         IAsyncAction^ previewing_localClientButtonClicked();
00075         IAsyncAction^ previewing_recordingStarted();
00076         IAsyncAction^ streaming_previewButtonClicked();
00077         IAsyncAction^ streaming_latencyModeToggled();
00078         IAsyncAction^ streaming_recordingStarted();
00079
00080         enum class LatencyModes
00081         {
00082             uninitialized,
00083             highLatency,
00084             lowLatency,
00085         };
00086         LatencyModes _latencyMode;
00087         std::map<LatencyModes, Windows::UI::Xaml::Controls::MediaElement^> _localHostVideo;
00088
00089         value struct StreamFilteringCriteria
00090         {
00091             Platform::String^   aspectRatio;
00092             int                 horizontalResolution;
00093             Platform::String^   subType;
00094         };
00095         StreamFilteringCriteria _streamFilteringCriteria;
00096
00097         bool _initialized;
00098         CaptureDevice^ _device;
00099
00100         MainPage^ _rootPage;
00101         void PreviewButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00102         void LocalClientButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00103         void LatencyModeToggled(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00104
00105         SdkSample _sdkSample;
00106         Windows::UI::Core::CoreDispatcher^ _dispatcher;
00107         Windows::Foundation::EventRegistrationToken m_visibilityEventRegistrationToken;
00108
00109     };
00110 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/Common/CaptureDevice.cs Source File

  • Real-time communication
  • C#,C++
  • Common

CaptureDevice.cs

Go to the documentation of this file.
00001 ﻿using System;
00002 using System.Collections.Generic;
00003 using System.Linq;
00004 using System.Text;
00005 using System.Threading.Tasks;
00006 using Windows.Media.Capture;
00007 using Windows.Media.MediaProperties;
00008 using Windows.Devices.Enumeration;
00009 using Microsoft.Samples.SimpleCommunication;
00010 using System.Threading;
00011
00012 namespace SimpleCommunication.Common
00013 {
00014     internal class CaptureDevice
00015     {
00016         // Media capture object
00017         private MediaCapture mediaCapture;
00018         // Custom media sink
00019         private StspMediaSink mediaSink;
00020         // Flag indicating if recording to custom sink has started
00021         private bool recordingStarted = false;
00022         private bool forwardEvents = false;
00023
00024         // Wraps the capture failed and media sink incoming connection events
00025         public event EventHandler<IncomingConnectionEventArgs> IncomingConnectionArrived;
00026         public event EventHandler<MediaCaptureFailedEventArgs> CaptureFailed;
00027
00028         public CaptureDevice() { }
00029
00030         /// <summary>
00031         ///  Handler for the wrapped MediaCapture object's Failed event. It just wraps and forward's MediaCapture's
00032         ///  Failed event as own CaptureFailed event
00033         /// </summary>
00034         private void mediaCapture_Failed(MediaCapture sender, MediaCaptureFailedEventArgs errorEventArgs)
00035         {
00036             if (CaptureFailed != null && forwardEvents) CaptureFailed(this, errorEventArgs);
00037         }
00038
00039         /// <summary>
00040         /// Handler for the wrapped media sink object's IncomingConnectionEvent. Expose the wrapped event to
00041         /// listeners as own IncomingConnectionArrived event.
00042         /// </summary>
00043         private void mediaSink_IncomingConnectionEvent(StspMediaSink sender, IncomingConnectionEventArgs args)
00044         {
00045             if (IncomingConnectionArrived != null && forwardEvents) IncomingConnectionArrived(sender, args);
00046         }
00047
00048         /// <summary>
00049         /// Cleans up the resources.
00050         /// </summary>
00051         private void CleanupSink()
00052         {
00053             if (mediaSink != null)
00054             {
00055                 mediaSink.IncomingConnectionEvent -= mediaSink_IncomingConnectionEvent;
00056                 mediaSink.Close();
00057                 mediaSink = null;
00058                 recordingStarted = false;
00059             }
00060         }
00061
00062         private void DoCleanup()
00063         {
00064             if (mediaCapture != null)
00065             {
00066                 mediaCapture.Failed -= mediaCapture_Failed;
00067                 mediaCapture = null;
00068             }
00069
00070             CleanupSink();
00071         }
00072
00073         public async Task InitializeAsync()
00074         {
00075             try
00076             {
00077                 forwardEvents = true;
00078
00079                 if (mediaCapture != null)
00080                 {
00081                     throw new InvalidOperationException("Camera is already initialized");
00082                 }
00083
00084                 mediaCapture = new MediaCapture();
00085                 mediaCapture.Failed += mediaCapture_Failed;
00086
00087                 await mediaCapture.InitializeAsync();
00088             }
00089             catch (Exception e)
00090             {
00091                 DoCleanup();
00092                 throw e;
00093             }
00094         }
00095
00096         /// <summary>
00097         /// Asynchronous method cleaning up resources and stopping recording if necessary.
00098         /// </summary>
00099         public async Task CleanUpAsync()
00100         {
00101             try
00102             {
00103                 forwardEvents = true;
00104
00105                 if (mediaCapture == null && mediaSink == null) return;
00106
00107                 if (recordingStarted)
00108                 {
00109                     await mediaCapture.StopRecordAsync();
00110                 }
00111
00112                 DoCleanup();
00113             }
00114             catch (Exception)
00115             {
00116                 DoCleanup();
00117             }
00118         }
00119
00120         /// <summary>
00121         /// Creates url object from MediaCapture
00122         /// </summary>
00123         public MediaCapture CaptureSource
00124         {
00125             get { return mediaCapture; }
00126         }
00127
00128         /// <summary>
00129         /// Allow selection of camera settings.
00130         /// </summary>
00131         /// <param name="mediaStreamType" type="Windows.Media.Capture.MediaStreamType">
00132         /// Type of a the media stream.
00133         /// </param>
00134         /// <param name="filterSettings" type="Func<Windows.Media.MediaProperties.IMediaEncodingProperties, bool>">
00135         /// A predicate function, which will be called to filter the correct settings.
00136         /// </param>
00137         public async Task<IMediaEncodingProperties> SelectPreferredCameraStreamSettingAsync(MediaStreamType mediaStreamType, Func<IMediaEncodingProperties, bool> filterSettings)
00138         {
00139             IMediaEncodingProperties previewEncodingProperties = null;
00140
00141             if (mediaStreamType == MediaStreamType.Audio || mediaStreamType == MediaStreamType.Photo)
00142             {
00143                 throw new ArgumentException("mediaStreamType value of MediaStreamType.Audio or MediaStreamType.Photo is not supported", "mediaStreamType");
00144             }
00145             if (filterSettings == null)
00146             {
00147                 throw new ArgumentNullException("filterSettings");
00148             }
00149
00150             var properties = mediaCapture.VideoDeviceController.GetAvailableMediaStreamProperties(mediaStreamType);
00151             var filterredProperties = properties.Where(filterSettings);
00152             var preferredSettings = filterredProperties.ToArray();
00153
00154             Array.Sort<IMediaEncodingProperties>(preferredSettings, (x, y) =>
00155             {
00156                 return (int)(((x as VideoEncodingProperties).Width) -
00157                     (y as VideoEncodingProperties).Width);
00158             });
00159
00160             if (preferredSettings.Length > 0)
00161             {
00162                 previewEncodingProperties = preferredSettings[0];
00163                 await mediaCapture.VideoDeviceController.SetMediaStreamPropertiesAsync(mediaStreamType, preferredSettings[0]);
00164             }
00165
00166             return previewEncodingProperties;
00167         }
00168
00169         /// <summary>
00170         /// Starts media recording asynchronously
00171         /// </summary>
00172         /// <param name="encodingProfile">
00173         /// Encoding profile used for the recording session
00174         /// </param>
00175         public async Task StartRecordingAsync(MediaEncodingProfile encodingProfile)
00176         {
00177             try
00178             {
00179                 // We cannot start recording twice.
00180                 if (mediaSink != null && recordingStarted)
00181                 {
00182                     throw new InvalidOperationException("Recording already started.");
00183                 }
00184
00185                 // Release sink if there is one already.
00186                 CleanupSink();
00187
00188                 // Create new sink
00189                 mediaSink = new StspMediaSink();
00190                 mediaSink.IncomingConnectionEvent += mediaSink_IncomingConnectionEvent;
00191
00192                 await mediaSink.InitializeAsync(encodingProfile.Audio, encodingProfile.Video);
00193                 await mediaCapture.StartRecordToCustomSinkAsync(encodingProfile, mediaSink);
00194
00195                 recordingStarted = true;
00196             }
00197             catch (Exception e)
00198             {
00199                 CleanupSink();
00200                 throw e;
00201             }
00202         }
00203
00204         /// <summary>
00205         /// Stops recording asynchronously
00206         /// </summary>
00207         public async Task StopRecordingAsync()
00208         {
00209             if (recordingStarted)
00210             {
00211                 try
00212                 {
00213                     await mediaCapture.StopRecordAsync();
00214                     CleanupSink();
00215                 }
00216                 catch (Exception e)
00217                 {
00218                     CleanupSink();
00219                     throw e;
00220                 }
00221             }
00222         }
00223
00224         public static async Task<bool> CheckForRecordingDeviceAsync()
00225         {
00226             var cameraFound = false;
00227
00228             var devices = await DeviceInformation.FindAllAsync(DeviceClass.VideoCapture);
00229             if (devices.Count > 0)
00230             {
00231                 cameraFound = true;
00232             }
00233
00234             return cameraFound;
00235         }
00236     }
00237 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/App.xaml.cpp Source File

  • Application resources and localization

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/App.xaml.h Source File

  • Clipboard app

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace Clipboard
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028
00029     public:
00030         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00031         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00032
00033     private:
00034         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00035         void SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs);
00036
00037     };
00038 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/GeometricSource/dllmain.cpp Source File

  • Media extensions
  • MediaExtensions
  • GeometricSource

dllmain.cpp

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // dllmain.cpp
00004 //
00005 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00006 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00007 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00008 // PARTICULAR PURPOSE.
00009 //
00010 // Copyright (c) Microsoft Corporation. All rights reserved.
00011 //
00012 //////////////////////////////////////////////////////////////////////////
00013
00014 #include "stdafx.h"
00015 #include <wrl\module.h>
00016 #include "GeometricSchemeHandler.h"
00017
00018 namespace Microsoft { namespace Samples {
00019     ActivatableClass(CGeometricSchemeHandler);
00020 }}
00021
00022
00023 BOOL WINAPI DllMain( _In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved )
00024 {
00025     if( DLL_PROCESS_ATTACH == dwReason )
00026     {
00027         //
00028         //  Don't need per-thread callbacks
00029         //
00030         DisableThreadLibraryCalls( hInstance );
00031
00032         Module<InProc>::GetModule().Create();
00033     }
00034     else if( DLL_PROCESS_DETACH == dwReason )
00035     {
00036         Module<InProc>::GetModule().Terminate();
00037     }
00038
00039     return TRUE;
00040 }
00041
00042 HRESULT WINAPI DllGetActivationFactory( _In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory** factory )
00043 {
00044     auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
00045     return module.GetActivationFactory( activatibleClassId, factory );
00046 }
00047
00048 HRESULT WINAPI DllCanUnloadNow()
00049 {
00050     auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
00051     return (module.Terminate()) ? S_OK : S_FALSE;
00052 }
00053
00054 STDAPI DllGetClassObject( _In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR* ppv )
00055 {
00056     auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
00057     return module.GetClassObject( rclsid, riid, ppv );
00058 }
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device app for printers SDK/C++/BackgroundTask/pch.h Source File

  • Device app for printers SDK
  • BackgroundTask

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/Constants.h Source File

  • Extended Linguistic Services (ELS)
  • C++

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"ELS Linguistic Services");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/common/LayoutAwarePage.h Source File

  • Search contract
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/SampleOverlay.cpp Source File

  • DirectWrite paragraph text

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameObject.h Source File

  • DirectX 3D shooting game

GameObject.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // GameObject:
00011 // This is the class representing a generic object in the 3D world of the game.  There are
00012 // specific sub-classes that have specific geometric shapes.  This class contains all the
00013 // properties of objects that are common.
00014 //
00015 // During the game physics calculations the IsTouching method will be called to determine
00016 // the object's proximity to a point.  It is expected the sub-classes will replace this method.
00017 // The Render method will be called during rendering to include the object in the generation of
00018 // the scene.
00019
00020 #include "MeshObject.h"
00021 #include "SoundEffect.h"
00022 #include "Animate.h"
00023 #include "Material.h"
00024
00025 ref class GameObject
00026 {
00027 internal:
00028     GameObject();
00029
00030     // Expect the IsTouching method to be overloaded by subclasses.
00031     virtual bool IsTouching(
00032         DirectX::XMFLOAT3 /* point */,
00033         float /* radius */,
00034         _Out_ DirectX::XMFLOAT3 *contact,
00035         _Out_ DirectX::XMFLOAT3 *normal
00036         )
00037     {
00038         *contact = DirectX::XMFLOAT3(0.0f, 0.0f, 0.0f);
00039         *normal = DirectX::XMFLOAT3(0.0f, 0.0f, 1.0f);
00040         return false;
00041     };
00042
00043     void Render(
00044         _In_ ID3D11DeviceContext *context,
00045         _In_ ID3D11Buffer *primitiveConstantBuffer
00046         );
00047
00048     void Active(bool active);
00049     bool Active();
00050     void Target(bool target);
00051     bool Target();
00052     void Hit(bool hit);
00053     bool Hit();
00054     void OnGround(bool ground);
00055     bool OnGround();
00056     void TargetId(int targetId);
00057     int  TargetId();
00058     void HitTime(float t);
00059     float HitTime();
00060
00061     void     AnimatePosition(_In_opt_ Animate^ animate);
00062     Animate^ AnimatePosition();
00063
00064     void         HitSound(_In_ SoundEffect^ hitSound);
00065     SoundEffect^ HitSound();
00066
00067     void PlaySound(float impactSpeed, DirectX::XMFLOAT3 eyePoint);
00068
00069     void Mesh(_In_ MeshObject^ mesh);
00070
00071     void NormalMaterial(_In_ Material^ material);
00072     Material^ NormalMaterial();
00073     void HitMaterial(_In_ Material^ material);
00074     Material^ HitMaterial();
00075
00076     void Position(DirectX::XMFLOAT3 position);
00077     void Position(DirectX::XMVECTOR position);
00078     void Velocity(DirectX::XMFLOAT3 velocity);
00079     void Velocity(DirectX::XMVECTOR velocity);
00080     DirectX::XMMATRIX ModelMatrix();
00081     DirectX::XMFLOAT3 Position();
00082     DirectX::XMVECTOR VectorPosition();
00083     DirectX::XMVECTOR VectorVelocity();
00084     DirectX::XMFLOAT3 Velocity();
00085
00086 protected private:
00087     virtual void UpdatePosition() {};
00088     // Object Data
00089     bool                m_active;
00090     bool                m_target;
00091     int                 m_targetId;
00092     bool                m_hit;
00093     bool                m_ground;
00094
00095     DirectX::XMFLOAT3   m_position;
00096     DirectX::XMFLOAT3   m_velocity;
00097     DirectX::XMFLOAT4X4 m_modelMatrix;
00098
00099     Material^           m_normalMaterial;
00100     Material^           m_hitMaterial;
00101
00102     DirectX::XMFLOAT3   m_defaultXAxis;
00103     DirectX::XMFLOAT3   m_defaultYAxis;
00104     DirectX::XMFLOAT3   m_defaultZAxis;
00105
00106     float               m_hitTime;
00107
00108     Animate^            m_animatePosition;
00109     MeshObject^         m_mesh;
00110
00111     SoundEffect^        m_hitSound;
00112 };
00113
00114
00115 __forceinline void GameObject::Active(bool active)
00116 {
00117     m_active = active;
00118 }
00119
00120 __forceinline bool GameObject::Active()
00121 {
00122     return m_active;
00123 }
00124
00125 __forceinline void GameObject::Target(bool target)
00126 {
00127     m_target = target;
00128 }
00129
00130 __forceinline bool GameObject::Target()
00131 {
00132     return m_target;
00133 }
00134
00135 __forceinline void GameObject::Hit(bool hit)
00136 {
00137     m_hit = hit;
00138 }
00139
00140 __forceinline bool GameObject::Hit()
00141 {
00142     return m_hit;
00143 }
00144
00145 __forceinline void GameObject::OnGround(bool ground)
00146 {
00147     m_ground = ground;
00148 }
00149
00150 __forceinline bool GameObject::OnGround()
00151 {
00152     return m_ground;
00153 }
00154
00155 __forceinline void GameObject::TargetId(int targetId)
00156 {
00157     m_targetId = targetId;
00158 }
00159
00160 __forceinline int GameObject::TargetId()
00161 {
00162     return m_targetId;
00163 }
00164
00165 __forceinline void GameObject::HitTime(float t)
00166 {
00167     m_hitTime = t;
00168 }
00169
00170 __forceinline float GameObject::HitTime()
00171 {
00172     return m_hitTime;
00173 }
00174
00175 __forceinline void GameObject::Position(DirectX::XMFLOAT3 position)
00176 {
00177     m_position = position;
00178     // Update any internal states that are dependent on the position.
00179     // UpdatePosition is a virtual function that is specific to the derived class.
00180     UpdatePosition();
00181 }
00182
00183 __forceinline void GameObject::Position(DirectX::XMVECTOR position)
00184 {
00185     XMStoreFloat3(&m_position, position);
00186     // Update any internal states that are dependent on the position.
00187     // UpdatePosition is a virtual function that is specific to the derived class.
00188     UpdatePosition();
00189 }
00190
00191 __forceinline DirectX::XMFLOAT3 GameObject::Position()
00192 {
00193     return m_position;
00194 }
00195
00196 __forceinline DirectX::XMVECTOR GameObject::VectorPosition()
00197 {
00198     return DirectX::XMLoadFloat3(&m_position);
00199 }
00200
00201 __forceinline void GameObject::Velocity(DirectX::XMFLOAT3 velocity)
00202 {
00203     m_velocity = velocity;
00204 }
00205
00206 __forceinline void GameObject::Velocity(DirectX::XMVECTOR velocity)
00207 {
00208     XMStoreFloat3(&m_velocity, velocity);
00209 }
00210
00211 __forceinline DirectX::XMFLOAT3 GameObject::Velocity()
00212 {
00213     return m_velocity;
00214 }
00215
00216 __forceinline DirectX::XMVECTOR GameObject::VectorVelocity()
00217 {
00218     return DirectX::XMLoadFloat3(&m_velocity);
00219 }
00220
00221 __forceinline void GameObject::AnimatePosition(_In_opt_ Animate^ animate)
00222 {
00223     m_animatePosition = animate;
00224 }
00225
00226 __forceinline Animate^ GameObject::AnimatePosition()
00227 {
00228     return m_animatePosition;
00229 }
00230
00231 __forceinline void GameObject::NormalMaterial(_In_ Material^ material)
00232 {
00233     m_normalMaterial = material;
00234 }
00235
00236 __forceinline Material^ GameObject::NormalMaterial()
00237 {
00238     return m_normalMaterial;
00239 }
00240
00241 __forceinline void GameObject::HitMaterial(_In_ Material^ material)
00242 {
00243     m_hitMaterial = material;
00244 }
00245
00246 __forceinline Material^ GameObject::HitMaterial()
00247 {
00248     return m_hitMaterial;
00249 }
00250
00251 __forceinline void GameObject::Mesh(_In_ MeshObject^ mesh)
00252 {
00253     m_mesh = mesh;
00254 }
00255
00256 __forceinline void GameObject::HitSound(_In_ SoundEffect^ hitSound)
00257 {
00258     m_hitSound = hitSound;
00259 }
00260
00261 __forceinline SoundEffect^ GameObject::HitSound()
00262 {
00263     return m_hitSound;
00264 }
00265
00266 __forceinline DirectX::XMMATRIX GameObject::ModelMatrix()
00267 {
00268     return DirectX::XMLoadFloat4x4(&m_modelMatrix);
00269 }
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/MainPage.xaml.h Source File

  • Windows account authorization

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileSavePicker_FailToSave.xaml.h Source File

  • File picker contracts

FileSavePicker_FailToSave.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FileSavePicker_FailToSave.xaml.h
00013 // Declaration of the FileSavePicker_FailToSave class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "FileSavePicker_FailToSave.g.h"
00020
00021 namespace SDKSample
00022 {
00023     namespace FilePickerContracts
00024     {
00025         /// <summary>
00026         /// An empty page that can be used on its own or navigated to within a Frame.
00027         /// </summary>
00028         [Windows::Foundation::Metadata::WebHostHidden]
00029         public ref class FileSavePicker_FailToSave sealed
00030         {
00031         public:
00032             FileSavePicker_FailToSave();
00033
00034         protected:
00035             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         internal:
00039             Windows::Storage::Pickers::Provider::FileSavePickerUI^ fileSavePickerUI;
00040
00041         private:
00042             Platform::String^ fileID;
00043             Windows::Foundation::EventRegistrationToken token;
00044
00045             void OnTargetFileRequested(Windows::Storage::Pickers::Provider::FileSavePickerUI^ sender,  Windows::Storage::Pickers::Provider::TargetFileRequestedEventArgs^ e);
00046         };
00047     }
00048 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Status Member List

This is the complete list of members for SDKSample::Status, including all inherited members.
FileAdded | SDKSample::Status | [static]
FileAddFailed | SDKSample::Status | [static]
FileRemoved | SDKSample::Status | [static]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::PersonalityAnimations::sealed Member List

This is the complete list of members for SDKSample::PersonalityAnimations::sealed, including all inherited members.
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PersonalityAnimations::sealed | [private]
messageData | SDKSample::PersonalityAnimations::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PersonalityAnimations::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PersonalityAnimations::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PersonalityAnimations::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PersonalityAnimations::sealed | [protected, virtual]
Page1() | SDKSample::PersonalityAnimations::sealed |
Page2() | SDKSample::PersonalityAnimations::sealed |
PopInClick(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PersonalityAnimations::sealed | [protected]
PopOutClick(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PersonalityAnimations::sealed | [protected]
rootPage | SDKSample::PersonalityAnimations::sealed | [private]
Scenario1() | SDKSample::PersonalityAnimations::sealed |
Scenario2() | SDKSample::PersonalityAnimations::sealed |
Scenario3() | SDKSample::PersonalityAnimations::sealed |
Scenario3_ClickHandler1(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PersonalityAnimations::sealed | [protected]
Scenario3_ClickHandler2(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PersonalityAnimations::sealed | [protected]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/BasicShapes.cpp Source File

  • Direct3D stereoscopic 3D

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page1.xaml.cpp Source File

  • XAML AppBar control

Page1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // Page1.xaml.cpp
00003 // Implementation of the Page1 class
00004 //
00005
00006 #include "pch.h"
00007 #include "Page1.xaml.h"
00008 #include "Page2.xaml.h"
00009 #include "GlobalPage.xaml.h"
00010
00011 using namespace AppBarControl;
00012
00013 using namespace Platform;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Windows::UI::Xaml;
00017 using namespace Windows::UI::Xaml::Interop;
00018 using namespace Windows::UI::Xaml::Controls;
00019 using namespace Windows::UI::Xaml::Controls::Primitives;
00020 using namespace Windows::UI::Xaml::Data;
00021 using namespace Windows::UI::Xaml::Input;
00022 using namespace Windows::UI::Xaml::Media;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 // The Blank Page item template is documented at http://go.microsoft.com/fwlink/?LinkId=234238
00026
00027 GlobalPage^ Page1::rootPage = nullptr;
00028
00029 Page1::Page1()
00030 {
00031   InitializeComponent();
00032 }
00033
00034
00035 // Invoked when this page is about to be displayed in a Frame.
00036 void Page1::OnNavigatedTo(NavigationEventArgs^ e)
00037 {
00038   rootPage = (GlobalPage^) e->Parameter;
00039 }
00040
00041
00042 void AppBarControl::Page1::PageTwo_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00043 {
00044   TypeName page2 = {Page2::typeid->FullName, TypeKind::Custom};
00045   Frame->Navigate(page2, rootPage);
00046 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/common/LayoutAwarePage.h Source File

  • Playback Manager Companion
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/pch.h Source File

  • Compression

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include <compressapi.h>
00021 #include <sstream>
00022 #include "Common\LayoutAwarePage.h"
00023 #include "Common\SuspensionManager.h"
00024 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

OfferReclaimAPI Member List

This is the complete list of members for OfferReclaimAPI, including all inherited members.
__pad0__ | OfferReclaimAPI |
CreateDeviceIndependentResources() override | OfferReclaimAPI | [virtual]
CreateDeviceResources() override | OfferReclaimAPI | [virtual]
CreateWindowSizeDependentResources() override | OfferReclaimAPI | [virtual]
m_Camera | OfferReclaimAPI | [private]
m_constantBuffer | OfferReclaimAPI | [private]
m_constantBufferData | OfferReclaimAPI | [private]
m_indexBuffer | OfferReclaimAPI | [private]
m_indexCount | OfferReclaimAPI | [private]
m_inputLayout | OfferReclaimAPI | [private]
m_pixelShader | OfferReclaimAPI | [private]
m_sampleOverlay | OfferReclaimAPI | [private]
m_sampler | OfferReclaimAPI | [private]
m_texture | OfferReclaimAPI | [private]
m_textureSRV | OfferReclaimAPI | [private]
m_vertexBuffer | OfferReclaimAPI | [private]
m_vertexShader | OfferReclaimAPI | [private]
OnResuming() | OfferReclaimAPI |
OnSuspending() | OfferReclaimAPI |
Render() override | OfferReclaimAPI | [virtual]
Update(float TimeTotal, float TimeDelta) | OfferReclaimAPI |
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Scenario2.xaml.cpp Source File

  • XAML Popup

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::XAMLPopup;
00020
00021 using namespace Windows::Foundation;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Controls::Primitives;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 Scenario2::Scenario2()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042 }
00043
00044 // Handles the Click event of the Button demonstrating a parented Popup with input content
00045 void SDKSample::XAMLPopup::Scenario2::ShowPopupWithParentClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00046 {
00047   if (!ParentedPopup->IsOpen) { ParentedPopup->IsOpen = true; }
00048 }
00049
00050 // Handles the Click event of the Button demonstrating a non-parented Popup with input content
00051 void SDKSample::XAMLPopup::Scenario2::ShowPopupWithoutParentClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00052 {
00053   // if we already have one showing, don't create another one
00054     if (nonParentPopup == nullptr)
00055     {
00056         // create the Popup in code
00057         nonParentPopup = ref new Popup();
00058
00059         // we are creating this in code and need to handle multiple instances
00060         // so we are attaching to the Popup.Closed event to remove our reference
00061     nonParentPopup->Closed += ref new EventHandler<Platform::Object^>(this, &Scenario2::OnPopupClosed);
00062         nonParentPopup->HorizontalOffset = 200;
00063     auto windowBounds = Window::Current->Bounds;
00064     nonParentPopup->VerticalOffset = windowBounds.Height - 200;
00065
00066         // set the content to our UserControl
00067         nonParentPopup->Child = ref new PopupInputContent();
00068
00069         // open the Popup
00070         nonParentPopup->IsOpen = true;
00071     }
00072 }
00073
00074 // Handles the closing of the popup created in code
00075 void SDKSample::XAMLPopup::Scenario2::OnPopupClosed(Platform::Object^ sender, Platform::Object^ args)
00076 {
00077   nonParentPopup = nullptr;
00078 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/common/suspensionmanager.cpp Source File

  • HttpClient
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Common/LayoutAwarePage.cpp Source File

  • Contact Picker app
  • Common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013
00014 using namespace ContactPicker::Common;
00015
00016 using namespace Platform;
00017 using namespace Platform::Collections;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Foundation::Collections;
00020 using namespace Windows::UI::ViewManagement;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Interop;
00024
00025 /// <summary>
00026 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00027 /// </summary>
00028 LayoutAwarePage::LayoutAwarePage()
00029 {
00030     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled) return;
00031
00032     // Create an empty default view model
00033     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00034
00035     // Map application view state to visual state for this page when it is part of the visual tree
00036     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::StartLayoutUpdates);
00037     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::StopLayoutUpdates);
00038 }
00039
00040 static TypeName _thisType = { LayoutAwarePage::typeid->FullName, TypeKind::Custom };
00041 static TypeName _observableMapType = { IObservableMap<Platform::String^, Object^>::typeid->FullName, TypeKind::Metadata };
00042 static Windows::UI::Xaml::DependencyProperty^ _defaultViewModelProperty =
00043     DependencyProperty::Register("DefaultViewModel", _observableMapType, _thisType, nullptr);
00044
00045 /// <summary>
00046 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00047 /// </summary>
00048 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00049 {
00050     return _defaultViewModelProperty;
00051 }
00052
00053 /// <summary>
00054 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00055 /// used as a trivial view model.
00056 /// </summary>
00057 IObservableMap<Platform::String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00058 {
00059     return safe_cast<Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^>(GetValue(DefaultViewModelProperty));
00060 }
00061
00062 /// <summary>
00063 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00064 /// used as a trivial view model.
00065 /// </summary>
00066 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<Platform::String^, Object^>^ value)
00067 {
00068     SetValue(DefaultViewModelProperty, value);
00069 }
00070
00071 /// <summary>
00072 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00073 /// until it reaches the top of the navigation stack.
00074 /// </summary>
00075 /// <param name="sender">Instance that triggered the event.</param>
00076 /// <param name="e">Event data describing the conditions that led to the event.</param>
00077 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00078 {
00079     // Use the navigation frame to return to the topmost page
00080     if (Frame != nullptr)
00081     {
00082         while (Frame->CanGoBack) Frame->GoBack();
00083     }
00084 }
00085
00086 /// <summary>
00087 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00088 /// to go back one step on the navigation stack.
00089 /// </summary>
00090 /// <param name="sender">Instance that triggered the event.</param>
00091 /// <param name="e">Event data describing the conditions that led to the event.</param>
00092 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00093 {
00094     // Use the navigation frame to return to the previous page
00095     if (Frame != nullptr && Frame->CanGoBack) Frame->GoBack();
00096 }
00097
00098 /// <summary>
00099 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00100 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00101 /// visual state management changes that correspond to application view state changes.
00102 /// </summary>
00103 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00104 /// corresponding to view states.</param>
00105 /// <param name="e">Event data that describes how the request was made.</param>
00106 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00107 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00108 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00109 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00110 /// events.</remarks>
00111 /// <seealso cref="DetermineVisualState"/>
00112 /// <seealso cref="InvalidateVisualState"/>
00113 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00114 {
00115     auto control = safe_cast<Control^>(sender);
00116     if (_layoutAwareControls == nullptr) {
00117         // Start listening to view state changes when there are controls interested in updates
00118         _layoutAwareControls = ref new Vector<Control^>();
00119         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00120     }
00121     _layoutAwareControls->Append(control);
00122
00123     // Set the initial visual state of the control
00124     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00125 }
00126
00127 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00128 {
00129     InvalidateVisualState();
00130 }
00131
00132 /// <summary>
00133 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00134 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00135 /// management changes that correspond to application view state changes.
00136 /// </summary>
00137 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00138 /// corresponding to view states.</param>
00139 /// <param name="e">Event data that describes how the request was made.</param>
00140 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00141 /// when layout updates are requested.</remarks>
00142 /// <seealso cref="StartLayoutUpdates"/>
00143 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00144 {
00145     auto control = safe_cast<Control^>(sender);
00146     unsigned int index;
00147     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00148     {
00149         _layoutAwareControls->RemoveAt(index);
00150         if (_layoutAwareControls->Size == 0)
00151         {
00152             // Stop listening to view state changes when no controls are interested in updates
00153             Window::Current->SizeChanged -= _windowSizeEventToken;
00154             _layoutAwareControls = nullptr;
00155         }
00156     }
00157 }
00158
00159 /// <summary>
00160 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00161 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00162 /// override this method to control the mapping scheme used.
00163 /// </summary>
00164 /// <param name="viewState">View state for which a visual state is desired.</param>
00165 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00166 /// <seealso cref="InvalidateVisualState"/>
00167 Platform::String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00168 {
00169     switch (viewState)
00170     {
00171     case ApplicationViewState::Filled: return "Filled";
00172     case ApplicationViewState::Snapped: return "Snapped";
00173     case ApplicationViewState::FullScreenPortrait: return "FullScreenPortrait";
00174     default: case ApplicationViewState::FullScreenLandscape: return "FullScreenLandscape";
00175     }
00176 }
00177
00178 /// <summary>
00179 /// Updates all controls that are listening for visual state changes with the correct visual
00180 /// state.
00181 /// </summary>
00182 /// <remarks>
00183 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00184 /// signal that a different value may be returned even though the view state has not changed.
00185 /// </remarks>
00186 void LayoutAwarePage::InvalidateVisualState()
00187 {
00188     if (_layoutAwareControls != nullptr)
00189     {
00190         String^ visualState = DetermineVisualState(ApplicationView::Value);
00191         auto controlIterator = _layoutAwareControls->First();
00192         while (controlIterator->HasCurrent)
00193         {
00194             auto control = controlIterator->Current;
00195             VisualStateManager::GoToState(control, visualState, false);
00196             controlIterator->MoveNext();
00197         }
00198     }
00199 }
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/BasicTimer.h Source File

  • XInput game controller

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario1.xaml.cpp Source File

  • XAML vector-based drawing

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::Drawing;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario1::Scenario1()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 // Invoked when this page is about to be displayed in a Frame.
00031 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00032 {
00033     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00034     // as NotifyUser()
00035     rootPage = MainPage::Current;
00036 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamWebSocket/C++/Background/pch.h Source File

  • ControlChannelTrigger StreamWebSocket
  • Background

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/common/LayoutAwarePage.cpp Source File

  • File access
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/pch.cpp Source File

  • DXGI swap chain rotation

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/pch.cpp Source File

  • XAML WebView control

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario7.xaml.h Source File

  • CryptoWinRT

Scenario7.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario7.xaml.h
00013 // Declaration of the Scenario7 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario7.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace CryptoWinRT
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario7 sealed
00031         {
00032         public:
00033             Scenario7();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level5.h Source File

  • XAML DirectX 3D shooting game

Level5.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Level5:
00011 // This class defines the fifth level of the game.  It derives from the
00012 // third level.  This level introduces obstacles that move into place
00013 // during game play.  The targets may be hit in any order.
00014
00015 #include "Level3.h"
00016
00017 ref class Level5: public Level3
00018 {
00019 internal:
00020     Level5();
00021     virtual void Initialize(std::vector<GameObject^> objects) override;
00022 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D command list/C++/CommandListSample.h Source File

  • Direct2D command list

CommandListSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012
00013 ref class CommandListRenderer : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00014 {
00015 internal:
00016     CommandListRenderer();
00017
00018     // DirectXBase Methods
00019     virtual void CreateDeviceResources() override;
00020     virtual void Render() override;
00021
00022 public:
00023     // IFrameworkView Methods
00024     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00025     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00026     virtual void Load(_In_ Platform::String^ entryPoint);
00027     virtual void Run();
00028     virtual void Uninitialize();
00029
00030 private:
00031     // Event Handlers
00032     void OnWindowSizeChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00035         );
00036
00037     void OnVisibilityChanged(
00038         _In_ Windows::UI::Core::CoreWindow^ sender,
00039         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00040         );
00041
00042     void OnLogicalDpiChanged(
00043         _In_ Platform::Object^ sender
00044         );
00045
00046     void OnActivated(
00047         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00048         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00049         );
00050
00051     void OnSuspending(
00052         _In_ Platform::Object^ sender,
00053         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00054         );
00055
00056     void OnResuming(
00057         _In_ Platform::Object^ sender,
00058         _In_ Platform::Object^ args
00059         );
00060
00061     void DrawPattern();
00062     void Update(float timeTotal);
00063
00064     // Declare event handlers for responding to touch gestures
00065     void HandlePointerDoubleTapped(Windows::Foundation::Point position);
00066
00067     void OnPointerPressed(
00068         _In_ Windows::UI::Core::CoreWindow^ window,
00069         _In_ Windows::UI::Core::PointerEventArgs^ args
00070         );
00071
00072     void OnPointerReleased(
00073         _In_ Windows::UI::Core::CoreWindow^ window,
00074         _In_ Windows::UI::Core::PointerEventArgs^ args
00075         );
00076
00077     void OnPointerMoved(
00078         _In_ Windows::UI::Core::CoreWindow^ window,
00079         _In_ Windows::UI::Core::PointerEventArgs^ args
00080         );
00081
00082     void OnPointerWheelChanged(
00083         _In_ Windows::UI::Core::CoreWindow^ window,
00084         _In_ Windows::UI::Core::PointerEventArgs^ args
00085         );
00086
00087     // Declare GestureRecognizer Event Handlers
00088     void OnManipulationUpdated(
00089         _In_ Windows::UI::Input::GestureRecognizer^ recognizer,
00090         _In_ Windows::UI::Input::ManipulationUpdatedEventArgs^ args
00091         );
00092
00093     void OnTapped(
00094         _In_ Windows::UI::Input::GestureRecognizer^ recognizer,
00095         _In_ Windows::UI::Input::TappedEventArgs^ args
00096         );
00097
00098     void OnWindowClosed(
00099         _In_ Windows::UI::Core::CoreWindow^ sender,
00100         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00101         );
00102
00103     inline static float Clamp(float value, float low, float high)
00104     {
00105         return (value < low) ? low : (value > high) ? high : value;
00106     }
00107
00108     inline static float LinearInterpolate(float start, float end, float weight)
00109     {
00110         return start * (1.0f - weight) + end * weight;
00111     }
00112
00113     SampleOverlay^                                                  m_sampleOverlay;
00114     Microsoft::WRL::ComPtr<ID2D1ImageBrush>                         m_imageBrush;
00115     Microsoft::WRL::ComPtr<ID2D1CommandList>                        m_commandList;
00116     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>                    m_blueBrush;
00117
00118     Windows::Foundation::Point                                      m_viewPosition;
00119     FLOAT                                                           m_zoom;
00120     BOOL                                                            m_recenter;
00121     D2D1_POINT_2F                                                   m_recenterStartPosition;
00122     FLOAT                                                           m_recenterStartZoom;
00123     FLOAT                                                           m_recenterStartTime;
00124     Platform::Agile<Windows::UI::Input::GestureRecognizer>          m_gestureRecognizer;
00125     bool                                                            m_windowClosed;
00126     bool                                                            m_windowVisible;
00127 };
00128
00129 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00130 {
00131 public:
00132     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00133 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/TimeTriggeredTask.xaml.h Source File

  • Background task
  • BackgroundTask

TimeTriggeredTask.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // TimeTriggeredTask.xaml.h
00013 // Declaration of the TimeTriggeredTask class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "TimeTriggeredTask.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace BackgroundTask
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class TimeTriggeredTask sealed
00031         {
00032         public:
00033             TimeTriggeredTask();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039
00040             void AttachProgressAndCompletedHandlers(Windows::ApplicationModel::Background::IBackgroundTaskRegistration^ task);
00041             void RegisterBackgroundTask(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042             void UnregisterBackgroundTask(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void UpdateUI();
00044         };
00045     }
00046 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/App.xaml.h Source File

  • Windows Store device app for camera

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021 #include "DeviceAppPage.g.h"
00022
00023 namespace DeviceAppForWebcam
00024 {
00025     ref class App sealed
00026     {
00027     public:
00028         App();
00029         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args) override;
00030         virtual void OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^ args) override;
00031         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00032
00033     private:
00034         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00035     };
00036 }
00037
00038
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/App.xaml.cpp Source File

  • Certificate enrollment

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CredentialPickerCPP::sealed Member List

This is the complete list of members for CredentialPickerCPP::sealed, including all inherited members.
_displayHandlerToken | CredentialPickerCPP::sealed | [private]
_frameLoadedToken | CredentialPickerCPP::sealed | [private]
_inputFrame | CredentialPickerCPP::sealed | [private]
_inputFrameLoadedToken | CredentialPickerCPP::sealed | [private]
_layoutHandlerToken | CredentialPickerCPP::sealed | [private]
_logicalDpiChangedToken | CredentialPickerCPP::sealed | [private]
_outputFrame | CredentialPickerCPP::sealed | [private]
_outputFrameLoadedToken | CredentialPickerCPP::sealed | [private]
_pageLoadedHandlerToken | CredentialPickerCPP::sealed | [private]
_scenariosFrame | CredentialPickerCPP::sealed | [private]
App() | CredentialPickerCPP::sealed |
CheckResolutionAndViewState() | CredentialPickerCPP::sealed | [private]
CheckResolutionAndViewState() | CredentialPickerCPP::sealed | [private]
ConvertResolution(Windows::Graphics::Display::ResolutionScale scale) | CredentialPickerCPP::sealed |
ConvertViewState(Windows::UI::ViewManagement::ApplicationViewState state) | CredentialPickerCPP::sealed |
DisplayProperties_LogicalDpiChanged(Object^sender) | CredentialPickerCPP::sealed | [private]
DisplayProperties_LogicalDpiChanged(Object^sender) | CredentialPickerCPP::sealed | [private]
DoNavigation(Windows::UI::Xaml::Interop::TypeName inPageType, Windows::UI::Xaml::Controls::Frame^inFrame, Windows::UI::Xaml::Interop::TypeName outPageType, Windows::UI::Xaml::Controls::Frame^outFrame) | CredentialPickerCPP::sealed |
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | CredentialPickerCPP::sealed | [private]
inputFrameNavigated(Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e) | CredentialPickerCPP::sealed | [private]
Launch_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | CredentialPickerCPP::sealed | [private]
Launch_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | CredentialPickerCPP::sealed | [private]
Launch_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | CredentialPickerCPP::sealed | [private]
MainPage() | CredentialPickerCPP::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | CredentialPickerCPP::sealed |
NotifyUserFromAsyncThread(Platform::String^strMessage, NotifyType type) | CredentialPickerCPP::sealed |
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | CredentialPickerCPP::sealed | [virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | CredentialPickerCPP::sealed | [protected, virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | CredentialPickerCPP::sealed | [virtual]
OutputFrameLoaded | CredentialPickerCPP::sealed |
outputFrameNavigated(Object^sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^e) | CredentialPickerCPP::sealed | [private]
Page_Loaded(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | CredentialPickerCPP::sealed | [private]
Page_Loaded(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | CredentialPickerCPP::sealed | [private]
Page_SizeChanged(Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | CredentialPickerCPP::sealed | [private]
Page_SizeChanged(Platform::Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | CredentialPickerCPP::sealed | [private]
Protocol_SelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | CredentialPickerCPP::sealed | [private]
rootPage | CredentialPickerCPP::sealed | [private]
rootPage_InputFrameLoaded(Object^sender, Object^e) | CredentialPickerCPP::sealed | [private]
rootPage_InputFrameLoaded(Object^sender, Object^e) | CredentialPickerCPP::sealed | [private]
rootPage_InputFrameLoaded(Object^sender, Object^e) | CredentialPickerCPP::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | CredentialPickerCPP::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | CredentialPickerCPP::sealed | [private]
rootPage_OutputFrameLoaded(Object^sender, Object^e) | CredentialPickerCPP::sealed | [private]
ScenarioInput1() | CredentialPickerCPP::sealed |
ScenarioInput2() | CredentialPickerCPP::sealed |
ScenarioInput3() | CredentialPickerCPP::sealed |
ScenarioList() | CredentialPickerCPP::sealed |
ScenarioOutput1() | CredentialPickerCPP::sealed |
ScenarioOutput2() | CredentialPickerCPP::sealed |
ScenarioOutput3() | CredentialPickerCPP::sealed |
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | CredentialPickerCPP::sealed | [protected]
SetError(Platform::String^errorText) | CredentialPickerCPP::sealed | [private]
SetError(Platform::String^errorText) | CredentialPickerCPP::sealed | [private]
SetError(Platform::String^errorText) | CredentialPickerCPP::sealed | [private]
SetFeatureName(Platform::String^strFeature) | CredentialPickerCPP::sealed | [private]
SetPasswordExplainVisibility(bool isShown) | CredentialPickerCPP::sealed | [private]
SetResult(Windows::Security::Credentials::UI::CredentialPickerResults^res) | CredentialPickerCPP::sealed | [private]
SetResult(Windows::Security::Credentials::UI::CredentialPickerResults^res) | CredentialPickerCPP::sealed | [private]
SetResult(Windows::Security::Credentials::UI::CredentialPickerResults^res) | CredentialPickerCPP::sealed | [private]
~MainPage() | CredentialPickerCPP::sealed | [private]
~ScenarioInput1() | CredentialPickerCPP::sealed | [private]
~ScenarioInput2() | CredentialPickerCPP::sealed | [private]
~ScenarioInput3() | CredentialPickerCPP::sealed | [private]
~ScenarioList() | CredentialPickerCPP::sealed | [private]
~ScenarioOutput1() | CredentialPickerCPP::sealed | [private]
~ScenarioOutput2() | CredentialPickerCPP::sealed | [private]
~ScenarioOutput3() | CredentialPickerCPP::sealed | [private]
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/common/suspensionmanager.cpp Source File

  • PlayToReceiver
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/BasicTimer.cpp Source File

  • XInput game controller

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideText03 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideText03, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextFields | NotificationsExtensions::NotificationBase |
TextHeadingWrap | NotificationsExtensions::TileContent::TileWideText03 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideText03() | NotificationsExtensions::TileContent::TileWideText03 | [inline]
TileWideText03() | NotificationsExtensions::TileContent::TileWideText03 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/StreamTypeOther.xaml.h Source File

  • Playback Manager msAudioCategory

StreamTypeOther.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // StreamTypeOther.xaml.h
00013 // Declaration of the StreamTypeOther class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "StreamTypeOther.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "PlaybackControl.xaml.h"
00022
00023 namespace SDKSample
00024 {
00025     namespace  PlaybackManager
00026     {
00027         /// <summary>
00028         /// An empty page that can be used on its own or navigated to within a Frame.
00029         /// </summary>
00030       [Windows::Foundation::Metadata::WebHostHidden]
00031         public ref class StreamTypeOther sealed
00032         {
00033         public:
00034             StreamTypeOther();
00035
00036         protected:
00037             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038         private:
00039             MainPage^ rootPage;
00040             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::BackgroundTransfer::sealed Member List

This is the complete list of members for SDKSample::BackgroundTransfer::sealed, including all inherited members.
activeDownloads | SDKSample::BackgroundTransfer::sealed | [private]
CancelAll_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::BackgroundTransfer::sealed | [private]
CancelAll_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::BackgroundTransfer::sealed | [private]
cancellationToken | SDKSample::BackgroundTransfer::sealed | [private]
DiscoverActiveDownloads() | SDKSample::BackgroundTransfer::sealed | [private]
DiscoverActiveUploads() | SDKSample::BackgroundTransfer::sealed | [private]
DownloadProgress(Windows::Foundation::IAsyncOperationWithProgress< Windows::Networking::BackgroundTransfer::DownloadOperation^, Windows::Networking::BackgroundTransfer::DownloadOperation^>^operation, Windows::Networking::BackgroundTransfer::DownloadOperation^) | SDKSample::BackgroundTransfer::sealed | [private]
HandleDownloadAsync(Windows::Networking::BackgroundTransfer::DownloadOperation^download, boolean start) | SDKSample::BackgroundTransfer::sealed | [private]
HandleUploadAsync(Windows::Networking::BackgroundTransfer::UploadOperation^upload, bool start) | SDKSample::BackgroundTransfer::sealed | [private]
Log(Platform::String^message) | SDKSample::BackgroundTransfer::sealed | [private]
Log(Platform::String^message) | SDKSample::BackgroundTransfer::sealed | [private]
LogException(Platform::String^title, Platform::Exception^ex) | SDKSample::BackgroundTransfer::sealed | [private]
LogException(Platform::String^title, Platform::Exception^ex) | SDKSample::BackgroundTransfer::sealed | [private]
LogStatus(Platform::String^message, NotifyType type) | SDKSample::BackgroundTransfer::sealed | [private]
LogStatus(Platform::String^message, NotifyType type) | SDKSample::BackgroundTransfer::sealed | [private]
MarshalLog(Platform::String^value) | SDKSample::BackgroundTransfer::sealed | [private]
MarshalLog(Platform::String^value) | SDKSample::BackgroundTransfer::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::BackgroundTransfer::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::BackgroundTransfer::sealed | [protected, virtual]
PauseAll_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::BackgroundTransfer::sealed | [private]
ResumeAll_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::BackgroundTransfer::sealed | [private]
rootPage | SDKSample::BackgroundTransfer::sealed | [private]
Scenario1() | SDKSample::BackgroundTransfer::sealed |
Scenario2() | SDKSample::BackgroundTransfer::sealed |
StartDownload_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::BackgroundTransfer::sealed | [private]
StartMultipartUpload_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::BackgroundTransfer::sealed | [private]
StartUpload_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::BackgroundTransfer::sealed | [private]
UploadProgress(Windows::Foundation::IAsyncOperationWithProgress< Windows::Networking::BackgroundTransfer::UploadOperation^, Windows::Networking::BackgroundTransfer::UploadOperation^>^operation, Windows::Networking::BackgroundTransfer::UploadOperation^) | SDKSample::BackgroundTransfer::sealed | [private]
~Scenario1() | SDKSample::BackgroundTransfer::sealed | [private]
~Scenario2() | SDKSample::BackgroundTransfer::sealed | [private]
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger StreamSocket/C++/Background/pch.h Source File

  • ControlChannelTrigger StreamSocket
  • Background

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/App.xaml.cpp Source File

  • DirectX postcard app

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "App.xaml.h"
00010
00011 using namespace Postcard;
00012
00013 using namespace Platform;
00014 using namespace Windows::ApplicationModel;
00015 using namespace Windows::ApplicationModel::Core;
00016 using namespace Windows::ApplicationModel::Activation;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Foundation::Collections;
00019 using namespace Windows::Graphics::Display;
00020 using namespace Windows::UI::Core;
00021 using namespace Windows::UI::ViewManagement;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Controls::Primitives;
00025 using namespace Windows::UI::Xaml::Data;
00026 using namespace Windows::UI::Xaml::Input;
00027 using namespace Windows::UI::Xaml::Media;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Media::Animation;
00030
00031 App::App()
00032 {
00033     // Used by compiler-generated code.
00034     InitializeComponent();
00035 }
00036
00037 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args)
00038 {
00039     m_mainPage = ref new MainPage();
00040
00041     Window::Current->Content = m_mainPage;
00042     Window::Current->Activate();
00043 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/Scenario1.xaml.h Source File

  • XAML two-dimensional transforms

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Transforms
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         void rootPage_MainPageResized(Platform::Object^ sender, MainPageSizeChangedEventArgs^ e);
00040         void SetUpBinding(Windows::UI::Xaml::Controls::Slider^ slider, Windows::UI::Xaml::DependencyProperty^ dp);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

UiaCoreWindowProvider::ITriColorControlProvider Member List

This is the complete list of members for UiaCoreWindowProvider::ITriColorControlProvider, including all inherited members.
Initialize([in] ITriColorControlInternal *pControl) UiaCoreWindowProvider::ITriColorControlProvider
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/common/suspensionmanager.cpp Source File

  • Background Transfer
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Syndication::sealed Member List

This is the complete list of members for SDKSample::Syndication::sealed, including all inherited members.
currentFeed | SDKSample::Syndication::sealed | [private]
currentItemIndex | SDKSample::Syndication::sealed | [private]
DisplayCurrentItem() | SDKSample::Syndication::sealed | [private]
DisplayFeed() | SDKSample::Syndication::sealed | [private]
GetFeed_Click(Object^sender, RoutedEventArgs^e) | SDKSample::Syndication::sealed | [private]
LinkField_Click(Object^sender, RoutedEventArgs^e) | SDKSample::Syndication::sealed | [private]
NextItem_Click(Object^sender, RoutedEventArgs^e) | SDKSample::Syndication::sealed | [private]
OnNavigatedTo(NavigationEventArgs^e) override | SDKSample::Syndication::sealed | [protected, virtual]
PreviousItem_Click(Object^sender, RoutedEventArgs^e) | SDKSample::Syndication::sealed | [private]
rootPage | SDKSample::Syndication::sealed | [private]
Scenario1() | SDKSample::Syndication::sealed |
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S2_Enumeration.xaml.cpp Source File

  • Portable device API

S2_Enumeration.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // S2_Enumeration.xaml.cpp
00013 // Implementation of the S2_Enumeration class
00014 //
00015
00016 #include "pch.h"
00017 #include "S2_Enumeration.xaml.h"
00018
00019 using namespace SDKSample::PortableDeviceCPP;
00020
00021 using namespace concurrency;
00022 using namespace Microsoft::WRL;
00023 using namespace Platform;
00024 using namespace Platform::Collections;
00025 using namespace Windows::Devices::Enumeration;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 S2_Enumeration::S2_Enumeration() : rootPage(MainPage::Current)
00031 {
00032     InitializeComponent();
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void S2_Enumeration::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     ScenarioOutput->Text = "";
00043     DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044 }
00045
00046 /// <summary>
00047 /// This is the click handler for the 'Run' button.
00048 /// </summary>
00049 /// <param name="sender"></param>
00050 /// <param name="e"></param>
00051 void S2_Enumeration::Run_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00052 {
00053     ShowDeviceSelectorAsync();
00054 }
00055
00056 /// <summary>
00057 /// Enumerates all portable devices and populates the device selection list.
00058 /// </summary>
00059 void S2_Enumeration::ShowDeviceSelectorAsync()
00060 {
00061     ScenarioOutput->Text = "";
00062     _deviceInfoCollection = nullptr;
00063
00064     // Find all portable devices
00065     String^ aqsFilter = "System.Devices.InterfaceClassGuid:=\"{6AC27878-A6FA-4155-BA85-F98F491D4F33}\" AND System.Devices.InterfaceEnabled:=System.StructuredQueryType.Boolean#True";
00066     create_task(DeviceInformation::FindAllAsync(aqsFilter)).then([this] (DeviceInformationCollection^ deviceInfoCollection)
00067     {
00068         _deviceInfoCollection = deviceInfoCollection;
00069         if (_deviceInfoCollection->Size > 0)
00070         {
00071             auto items = ref new Vector<String^>();
00072             std::for_each(begin(_deviceInfoCollection), end(_deviceInfoCollection), [items](IDeviceInformation^ deviceInfoElement)
00073             {
00074                 items->Append(ref new String(deviceInfoElement->Name->Begin()));
00075             });
00076             cvs->Source = items;
00077             DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Visible;
00078         }
00079         else
00080         {
00081             rootPage->NotifyUser("No portable devices were found. Please attach a portable device to the system (e.g. a camera, music player, or cellular phone)", NotifyType::ErrorMessage);
00082         }
00083     });
00084 }
00085
00086 /// <summary>
00087 /// This is the tapped handler for the device selection list. It runs the scenario
00088 /// for the selected portable device.
00089 /// </summary>
00090 /// <param name="sender"></param>
00091 /// <param name="e"></param>
00092 void S2_Enumeration::DeviceList_Tapped(Platform::Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e)
00093 {
00094     DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00095     if (_deviceInfoCollection == nullptr)
00096     {
00097         return; // not yet populated
00098     }
00099
00100     auto deviceInfo = _deviceInfoCollection->GetAt(DeviceList->SelectedIndex);
00101     EnumerateObjects(deviceInfo);
00102 }
00103
00104 /// <summary>
00105 /// Enumerates objects using the Portable Device COM APIs for the selected portable device
00106 /// and displays them.
00107 /// </summary>
00108 /// <param name="deviceInfoElement">Contains information about a selected device.</param>
00109 void S2_Enumeration::EnumerateObjects(DeviceInformation^ deviceInfoElement)
00110 {
00111     ComPtr<IPortableDevice> device;
00112     ThrowIfFailed(CoCreateInstance(CLSID_PortableDeviceFTM, nullptr, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&device)));
00113
00114     auto clientInfo = GetClientInfo();
00115     HRESULT hr = device->Open(deviceInfoElement->Id->Begin(), clientInfo.Get());
00116     if (hr == E_ACCESSDENIED)
00117     {
00118         rootPage->NotifyUser("Access to " + deviceInfoElement->Name + " is denied. Only a Privileged Application may access this device.", NotifyType::ErrorMessage);
00119         return;
00120     }
00121     ThrowIfFailed(hr);
00122
00123     ComPtr<IPortableDeviceContent> content;
00124     ThrowIfFailed(device->Content(&content));
00125
00126     // Get the children of the device object
00127     ComPtr<IEnumPortableDeviceObjectIDs> enumObjectIDs;
00128     ThrowIfFailed(content->EnumObjects(0, WPD_DEVICE_OBJECT_ID, nullptr, &enumObjectIDs));
00129
00130     rootPage->NotifyUser("Top level objects for " + deviceInfoElement->Name, NotifyType::StatusMessage);
00131     ScenarioOutput->Text = "";
00132     while(hr == S_OK)
00133     {
00134         DWORD numFetched = 0;
00135         PWSTR objectIDArray[NUM_OBJECTS_TO_REQUEST] = {};
00136         CoTaskMemFreeArray arrayPtr(reinterpret_cast<void **>(objectIDArray), ARRAYSIZE(objectIDArray));
00137
00138         hr = enumObjectIDs->Next(NUM_OBJECTS_TO_REQUEST,    // Number of objects to request on each NEXT call
00139                                  objectIDArray,             // Array of PWSTR array which will be populated on each NEXT call
00140                                  &numFetched);              // Number of objects written to the PWSTR array
00141
00142         for (DWORD index = 0; index < numFetched; index++)
00143         {
00144             // print the object identifiers
00145             ScenarioOutput->Text += ref new String(objectIDArray[index]) + "\n";
00146         }
00147     }
00148 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/common/LayoutAwarePage.h Source File

  • Trial app and in-app purchase
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/DirectXBase.h Source File

  • Direct3D sprite

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/App.xaml.cpp Source File

  • Search contract

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "App.xaml.h"
00018 #include "MainPage.xaml.h"
00019 #include "Common\SuspensionManager.h"
00020
00021 using namespace SDKSample;
00022 using namespace SDKSample::Common;
00023
00024 using namespace concurrency;
00025 using namespace Platform;
00026 using namespace Windows::ApplicationModel;
00027 using namespace Windows::ApplicationModel::Activation;
00028 using namespace Windows::ApplicationModel::Search;
00029 using namespace Windows::Foundation;
00030 using namespace Windows::Foundation::Collections;
00031 using namespace Windows::UI::Core;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 /// <summary>
00037 /// Initializes the singleton application object.  This is the first line of authored code
00038 /// executed, and as such is the logical equivalent of main() or WinMain().
00039 /// </summary>
00040 App::App()
00041 {
00042     InitializeComponent();
00043     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00044 }
00045
00046 void App::EnsureMainPageActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^ pArgs)
00047 {
00048     // Do not repeat app initialization when already running, just ensure that
00049     // the window is active
00050     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00051     {
00052         Window::Current->Activate();
00053         return;
00054     }
00055
00056     // Create a Frame to act as the navigation context and associate it with
00057     // a SuspensionManager key
00058     auto rootFrame = ref new Frame();
00059     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00060
00061     auto prerequisite = task<void>([](){});
00062     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00063     {
00064         // Restore the saved session state only when appropriate, scheduling the
00065         // final launch steps after the restore is complete
00066         prerequisite = SuspensionManager::RestoreAsync();
00067     }
00068     prerequisite.then([=]()
00069     {
00070         // When the navigation stack isn't restored navigate to the first page,
00071         // configuring the new page by passing required information as a navigation
00072         // parameter
00073         if (rootFrame->Content == nullptr)
00074         {
00075             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00076             {
00077                 throw ref new FailureException("Failed to create initial page");
00078             }
00079         }
00080
00081         // Place the frame in the current Window and ensure that it is active
00082         Window::Current->Content = rootFrame;
00083         Window::Current->Activate();
00084     }, task_continuation_context::use_current());
00085 }
00086
00087 /// <summary>
00088 /// Invoked when application execution is being suspended.  Application state is saved
00089 /// without knowing whether the application will be terminated or resumed with the contents
00090 /// of memory still intact.
00091 /// </summary>
00092 /// <param name="sender">The source of the suspend request.</param>
00093 /// <param name="e">Details about the suspend request.</param>
00094 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00095 {
00096     (void) sender;    // Unused parameter
00097
00098     auto deferral = e->SuspendingOperation->GetDeferral();
00099     SuspensionManager::SaveAsync().then([=]()
00100     {
00101         deferral->Complete();
00102     });
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the application is launched normally by the end user.  Other entry points will
00107 /// be used when the application is launched to open a specific file, to display search results,
00108 /// and so forth.
00109 /// </summary>
00110 /// <param name="pArgs">Details about the launch request and process.</param>
00111 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00112 {
00113     EnsureMainPageActivated(pArgs);
00114 }
00115
00116 // ----------------------------------------
00117 // OnSearchActivated
00118 //
00119 // Summary: This is the handler for Search activation.
00120 // ----------------------------------------
00121 void App::OnSearchActivated(Windows::ApplicationModel::Activation::SearchActivatedEventArgs^ pArgs)
00122 {
00123     EnsureMainPageActivated(pArgs);
00124     if (pArgs->QueryText == "")
00125     {
00126         // navigate to landing page.
00127     }
00128     else
00129     {
00130         // display search results.
00131         MainPage::Current->ProcessQueryText(pArgs->QueryText);
00132     }
00133 }
00134
00135 void App::OnQuerySubmitted(SearchPane^ sender, SearchPaneQuerySubmittedEventArgs^ pArgs)
00136 {
00137     if (MainPage::Current)
00138     {
00139         MainPage::Current->ProcessQueryText(pArgs->QueryText);
00140     }
00141 }
00142
00143 void App::OnWindowCreated(WindowCreatedEventArgs^ pArgs)
00144 {
00145     // Register QuerySubmitted handler for the window at window creation time and only registered once
00146     // so that the app can receive user queries at any time.
00147     SearchPane^ searchPane = SearchPane::GetForCurrentView();
00148     searchPane->QuerySubmitted += ref new TypedEventHandler<SearchPane^, SearchPaneQuerySubmittedEventArgs^>(this, &App::OnQuerySubmitted);
00149 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendBadge.xaml.h Source File

  • App tiles and badges
  • C#,C++

SendBadge.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SendBadge.xaml.h
00013 // Declaration of the SendBadge class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SendBadge.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Tiles
00025     {
00026       /// <summary>
00027       /// An empty page that can be used on its own or navigated to within a Frame.
00028       /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030       public ref class SendBadge sealed
00031       {
00032       public:
00033         SendBadge();
00034
00035       protected:
00036         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037       private:
00038     MainPage^ rootPage;
00039     void UpdateBadgeWithNumber(int number);
00040     void UpdateBadgeWithGlyph(int glyphIndex);
00041     void UpdateBadgeWithNumberWithStringManipulation(int number);
00042     void UpdateBadgeWithGlyphWithStringManipulation();
00043     void UpdateBadge_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044     void ClearBadge_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045     void NumberOrGlyph_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00046       };
00047     }
00048 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/common/LayoutAwarePage.cpp Source File

  • Credential locker
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/Constants.cpp Source File

  • Real-time communication

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SimpleCommunication;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Low Latency", "SimpleCommunication.LowLatency" },
00022     { "Video Chat", "SimpleCommunication.VideoChat" },
00023 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/pch.h Source File

  • DirectWrite hello world

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1_1helper.h>
00014 #include <d2d1effects.h>
00015 #include <dwrite_1.h>
00016 #include <wincodec.h>
00017 #include <math.h>
00018 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::ExceptionPolicy Member List

This is the complete list of members for Hilo::ExceptionPolicy, including all inherited members.
HandleException(Platform::Exception^exception)=0 Hilo::ExceptionPolicy [pure virtual]
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/Constants.cpp Source File

  • Snap

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Snap Sample", "SDKSample.SnapSample.Scenario1" },
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/MainPage.xaml.cpp Source File

  • Thread pool

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::Common::BindableBase Member List

This is the complete list of members for Hilo::Common::BindableBase, including all inherited members.
GetCustomProperty(Platform::String^name) | Hilo::Common::BindableBase | [virtual]
GetIndexedProperty(Platform::String^name, Windows::UI::Xaml::Interop::TypeName type) | Hilo::Common::BindableBase | [virtual]
GetStringRepresentation() | Hilo::Common::BindableBase | [virtual]
PropertyChanged | Hilo::Common::BindableBase |
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/common/LayoutAwarePage.cpp Source File

  • XAML accessibility
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/App.xaml.cpp Source File

  • Syndication

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Scenario3_DeviceEvents.xaml.cpp Source File

  • Custom driver access
  • app_cpp

Scenario3_DeviceEvents.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DeviceEvents.xaml.cpp
00013 // Implementation of the DeviceEvents class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3_DeviceEvents.xaml.h"
00018
00019 using namespace SDKSample::CustomDeviceAccess;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 DeviceEvents::DeviceEvents() : switchChangedEventsRegistered(false)
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void DeviceEvents::OnNavigatedTo(NavigationEventArgs^ /* e */)
00036 {
00037     // Get a pointer to our main page.
00038     rootPage = MainPage::Current;
00039     ClearSwitchStateTable();
00040     UpdateRegisterButton();
00041     deviceClosingHandler = DeviceList::Current->DeviceClosing::add(ref new DeviceClosingHandler(this, &DeviceEvents::Current_DeviceClosing));
00042 }
00043
00044 void DeviceEvents::OnNavigatedFrom(NavigationEventArgs^ /* e */)
00045 {
00046     if (switchChangedEventsRegistered == true)
00047     {
00048         RegisterForSwitchStateChangedEvent(false);
00049     }
00050     DeviceList::Current->DeviceClosing::remove(deviceClosingHandler);
00051 }
00052
00053 void DeviceEvents::deviceEventsGet_Click_1(Platform::Object^ /* sender */, Windows::UI::Xaml::RoutedEventArgs^ /* e */)
00054 {
00055     if (DeviceList::Current->Fx2Device == nullptr) {
00056         rootPage->NotifyUser("Fx2 device not connected or accessible", NotifyType::ErrorMessage);
00057         return;
00058     }
00059
00060     Platform::Array<bool>^ switchStateArray;
00061
00062     try
00063     {
00064         switchStateArray = DeviceList::Current->Fx2Device->SwitchState;
00065     }
00066     catch (Platform::Exception^ exception)
00067     {
00068         rootPage->NotifyUser(exception->ToString(), NotifyType::ErrorMessage);
00069         return;
00070     }
00071
00072     UpdateSwitchStateTable(switchStateArray);
00073 }
00074
00075
00076 void DeviceEvents::deviceEventsRegister_Click_1(Platform::Object^ /* sender */, Windows::UI::Xaml::RoutedEventArgs^ /* e */)
00077 {
00078     if (DeviceList::Current->Fx2Device == nullptr) {
00079         rootPage->NotifyUser("Fx2 device not connected or accessible", NotifyType::ErrorMessage);
00080         return;
00081     }
00082
00083     RegisterForSwitchStateChangedEvent(switchChangedEventsRegistered == false);
00084 }
00085
00086 void DeviceEvents::Current_DeviceClosing(Platform::Object^ /* sender */, Samples::Devices::Fx2::Fx2Device^ /* device */)
00087 {
00088     if (switchChangedEventsRegistered) {
00089         RegisterForSwitchStateChangedEvent(false);
00090     }
00091 }
00092
00093 void DeviceEvents::RegisterForSwitchStateChangedEvent(bool r)
00094 {
00095     if (r)
00096     {
00097         switchChangedEventsHandler =
00098             DeviceList::Current->Fx2Device->SwitchStateChanged::add(
00099                 ref new Samples::Devices::Fx2::SwitchStateChangedHandler(
00100                     this,
00101                     &DeviceEvents::OnSwitchStateChangedEvent
00102                     )
00103                 );
00104
00105     } else {
00106         DeviceList::Current->Fx2Device->SwitchStateChanged::remove(switchChangedEventsHandler);
00107     }
00108     switchChangedEventsRegistered = r;
00109     UpdateRegisterButton();
00110     ClearSwitchStateTable();
00111 }
00112
00113 void DeviceEvents::UpdateRegisterButton(void)
00114 {
00115     if (switchChangedEventsRegistered)
00116     {
00117         deviceEventsRegister->Content = "Unregister from Switch State Change Event";
00118     }
00119     else
00120     {
00121         deviceEventsRegister->Content = "Register for Switch State Change Event";
00122     }
00123 }
00124
00125 void DeviceEvents::OnSwitchStateChangedEvent(Samples::Devices::Fx2::Fx2Device^ /* sender */, Samples::Devices::Fx2::SwitchStateChangedEventArgs^ e)
00126 {
00127     Platform::Array<bool>^ switchState;
00128
00129     try
00130     {
00131         switchState = e->SwitchState;
00132     }
00133     catch (Platform::Exception^ x)
00134     {
00135         rootPage->NotifyUser(
00136             ref new Platform::String(L"Error accessing Fx2 device:\n") + x->Message,
00137             NotifyType::ErrorMessage
00138             );
00139         ClearSwitchStateTable();
00140         return;
00141     }
00142
00143     UpdateSwitchStateTable(e->SwitchState);
00144 }
00145
00146 void DeviceEvents::ClearSwitchStateTable()
00147 {
00148     deviceEventsSwitches->Inlines->Clear();
00149     previousSwitchValues = nullptr;
00150 }
00151
00152 void DeviceEvents::UpdateSwitchStateTable(Platform::Array<bool>^ switchStateArray)
00153 {
00154     auto output = deviceEventsSwitches;
00155
00156     DeviceList::CreateBooleanTable(
00157         output->Inlines,
00158         switchStateArray,
00159         previousSwitchValues,
00160         "Switch Number",
00161         "Switch State",
00162         "off",
00163         "on"
00164         );
00165     previousSwitchValues = switchStateArray;
00166 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/pch.h Source File

  • CameraOptionsUI

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/CylinderMesh.h Source File

  • XAML DirectX 3D shooting game

CylinderMesh.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // CylinderMesh:
00011 // This class derives from MeshObject and creates a ID3D11Buffer of
00012 // vertices and indices to represent a canonical cylinder (capped at
00013 // both ends) that is positioned at the origin with a radius of 1.0,
00014 // a height of 1.0 and with its axis in the +Z direction.
00015
00016 #include "MeshObject.h"
00017
00018 ref class CylinderMesh: public MeshObject
00019 {
00020 internal:
00021     CylinderMesh(_In_ ID3D11Device *device, uint32 segments);
00022 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Material.cpp Source File

  • XAML DirectX 3D shooting game

Material.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Material.h"
00010 #include "GameConstants.h"
00011
00012 using namespace DirectX;
00013
00014 //--------------------------------------------------------------------------------
00015
00016 Material::Material(
00017     XMFLOAT4 meshColor,
00018     XMFLOAT4 diffuseColor,
00019     XMFLOAT4 specularColor,
00020     float specularExponent,
00021     _In_ ID3D11ShaderResourceView* textureResourceView,
00022     _In_ ID3D11VertexShader* vertexShader,
00023     _In_ ID3D11PixelShader* pixelShader
00024     )
00025 {
00026     m_meshColor = meshColor;
00027     m_diffuseColor = diffuseColor;
00028     m_specularColor = specularColor;
00029     m_specularExponent = specularExponent;
00030
00031     m_vertexShader = vertexShader;
00032     m_pixelShader = pixelShader;
00033     m_textureRV = textureResourceView;
00034 }
00035
00036 //--------------------------------------------------------------------------------
00037
00038 void Material::RenderSetup(
00039     _In_ ID3D11DeviceContext* context,
00040     _Inout_ ConstantBufferChangesEveryPrim* constantBuffer
00041     )
00042 {
00043     constantBuffer->meshColor = m_meshColor;
00044     constantBuffer->specularColor = m_specularColor;
00045     constantBuffer->specularPower = m_specularExponent;
00046     constantBuffer->diffuseColor = m_diffuseColor;
00047
00048     context->PSSetShaderResources(0, 1, m_textureRV.GetAddressOf());
00049     context->VSSetShader(m_vertexShader.Get(), nullptr, 0);
00050     context->PSSetShader(m_pixelShader.Get(), nullptr, 0);
00051 }
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Settings.xaml.cpp Source File

  • Application data

Settings.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Settings.xaml.cpp
00013 // Implementation of the Settings class
00014 //
00015
00016 #include "pch.h"
00017 #include "Settings.xaml.h"
00018
00019 using namespace SDKSample::ApplicationDataSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::Storage;
00027
00028 #define settingName "exampleSetting"
00029 #define settingValue "Hello World"
00030
00031 Settings::Settings()
00032 {
00033     InitializeComponent();
00034
00035     localSettings = ApplicationData::Current->LocalSettings;
00036
00037     DisplayOutput();
00038 }
00039
00040 /// <summary>
00041 /// Invoked when this page is about to be displayed in a Frame.
00042 /// </summary>
00043 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00044 /// property is typically used to configure the page.</param>
00045 void Settings::OnNavigatedTo(NavigationEventArgs^ e)
00046 {
00047     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00048     // as NotifyUser()
00049     rootPage = MainPage::Current;
00050 }
00051
00052 // Guidance for Settings.
00053 //
00054 // Settings are a convenient way of storing small pieces of configuration data
00055 // for your application.
00056 //
00057 // Settings can be either Local or Roaming.
00058 //
00059 // Roaming settings will be synchronized across machines on which the user has
00060 // signed in with a Microsoft Account.  Roaming of settings is not instant; the
00061 // system weighs several factors when determining when to send the data.  Usage
00062 // of roaming data should be kept below the quota (available via the
00063 // RoamingStorageQuota property), or else roaming of data will be suspended.
00064 //
00065 // User preferences for your application are a great match for roaming settings.
00066 // User preferences are usually fixed in number and small in size.  Users will
00067 // appreciated that your application is customized the way they prefer across
00068 // all of their machines.
00069 //
00070 // Local settings are not synchronized and remain on the machine on which they
00071 // were originally written.
00072 //
00073 // Care should be taken to guard against an excessive volume of data being
00074 // stored in settings.  Settings are not intended to be used as a database.
00075 // Large data sets will take longer to load from disk during your application's
00076 // launch.
00077
00078 // This sample illustrates reading and writing from a local setting, though a
00079 // roaming setting could be used just as easily.
00080
00081 void Settings::WriteSetting_Click(Object^ sender, RoutedEventArgs^ e)
00082 {
00083     localSettings->Values->Insert(settingName, dynamic_cast<PropertyValue^>(PropertyValue::CreateString(settingValue)));
00084
00085     DisplayOutput();
00086 }
00087
00088 void Settings::DeleteSetting_Click(Object^ sender, RoutedEventArgs^ e)
00089 {
00090     localSettings->Values->Remove(settingName);
00091
00092     DisplayOutput();
00093 }
00094
00095 void Settings::DisplayOutput()
00096 {
00097     String^ value = safe_cast<String^>(localSettings->Values->Lookup(settingName));
00098
00099     OutputTextBlock->Text = "Setting: " + (value == nullptr ? "<empty>" : ("\"" + value + "\""));
00100 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/Constants.cs Source File

  • MediaStreamSource media extension
  • C#,C++

Constants.cs

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using System.Collections.Generic;
00012 using System;
00013 using MediaStreamSource;
00014
00015 namespace SDKTemplate
00016 {
00017     public partial class MainPage : SDKTemplate.Common.LayoutAwarePage
00018     {
00019         // Change the string below to reflect the name of your sample.
00020         // This is used on the main page as the title of the sample.
00021         public const string FEATURE_NAME = "Media Stream Source";
00022
00023         // Change the array below to reflect the name of your scenarios.
00024         // This will be used to populate the list of scenarios on the main page with
00025         // which the user will choose the specific scenario that they are interested in.
00026         // These should be in the form: "Navigating to a web page".
00027         // The code in MainPage will take care of turning this into: "1) Navigating to a web page"
00028         List<Scenario> scenarios = new List<Scenario>
00029         {
00030             new Scenario() { Title = "Audio Source", ClassType = typeof(AudioSource) },
00031         };
00032     }
00033
00034     public class Scenario
00035     {
00036         public string Title { get; set; }
00037
00038         public Type ClassType { get; set; }
00039
00040         public override string ToString()
00041         {
00042             return Title;
00043         }
00044     }
00045 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Page2.xaml.cpp Source File

  • XAML personality animations

Page2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // Page2.xaml.cpp
00003 // Implementation of the Page2 class
00004 //
00005
00006 #include "pch.h"
00007 #include "Page2.xaml.h"
00008
00009 using namespace SDKSample::PersonalityAnimations;
00010
00011 using namespace Platform;
00012 using namespace Windows::Foundation;
00013 using namespace Windows::Foundation::Collections;
00014 using namespace Windows::UI::Xaml;
00015 using namespace Windows::UI::Xaml::Controls;
00016 using namespace Windows::UI::Xaml::Controls::Primitives;
00017 using namespace Windows::UI::Xaml::Data;
00018 using namespace Windows::UI::Xaml::Input;
00019 using namespace Windows::UI::Xaml::Media;
00020 using namespace Windows::UI::Xaml::Navigation;
00021
00022 // The Blank Page item template is documented at http://go.microsoft.com/fwlink/?LinkId=234238
00023
00024 Page2::Page2()
00025 {
00026   InitializeComponent();
00027
00028   messageData = ref new MessageData;
00029   GridView1->ItemsSource = messageData->Items;
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void Page2::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039   VisualStateManager::GoToState(this, "NavigatedTo", true);
00040   //(void) e; // Unused parameter
00041 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C#,C++/Wrapper/pch.cpp Source File

  • Windows Store device app for camera
  • C#,C++
  • Wrapper

pch.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008
00009 // pch.cpp : source file that includes just the standard includes
00010 //   pch.pch will be the pre-compiled header
00011 //   pch.obj will contain the pre-compiled type information
00012
00013 #include "pch.h"
00014
00015 // TODO: reference any additional headers you need in PCH.H and not in this file
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/pch.h Source File

  • DXGI offer and reclaim resources

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
00017 #include "BasicMath.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/OutlineRenderer.cpp Source File

  • DirectX postcard app

OutlineRenderer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "OutlineRenderer.h"
00010
00011 using namespace Microsoft::WRL;
00012
00013 // This class represents a custom "text renderer" that extracts the
00014 // glyph runs of a text layout object and turns them into a geometry.
00015 void OutlineRenderer::CreateOutlineRenderer(
00016     _In_ ID2D1Factory* pFactory,
00017     _Outptr_ OutlineRenderer** ppOutlineRenderer
00018     )
00019 {
00020     *ppOutlineRenderer = new OutlineRenderer(pFactory);
00021     (*ppOutlineRenderer)->AddRef();
00022 }
00023
00024 OutlineRenderer::OutlineRenderer(_In_ ID2D1Factory* pFactory) :
00025     m_pFactory(pFactory),
00026     m_ref(0)
00027 {
00028 }
00029
00030 HRESULT OutlineRenderer::DrawGlyphRun(
00031     void* /*clientDrawingContext*/,
00032     FLOAT baselineOriginX,
00033     FLOAT baselineOriginY,
00034     DWRITE_MEASURING_MODE /*measuringMode*/,
00035     DWRITE_GLYPH_RUN const* glyphRun,
00036     DWRITE_GLYPH_RUN_DESCRIPTION const* /*glyphRunDescription*/,
00037     IUnknown* /*clientDrawingEffect*/
00038     )
00039 {
00040     HRESULT hr;
00041
00042     ComPtr<ID2D1PathGeometry> pPathGeometry;
00043
00044     hr = m_pFactory->CreatePathGeometry(&pPathGeometry);
00045
00046     if (SUCCEEDED(hr))
00047     {
00048         ComPtr<ID2D1GeometrySink> pSink;
00049
00050         hr = pPathGeometry->Open(&pSink);
00051
00052         if (SUCCEEDED(hr))
00053         {
00054             hr = glyphRun->fontFace->GetGlyphRunOutline(
00055                 glyphRun->fontEmSize,
00056                 glyphRun->glyphIndices,
00057                 glyphRun->glyphAdvances,
00058                 glyphRun->glyphOffsets,
00059                 glyphRun->glyphCount,
00060                 glyphRun->isSideways,
00061                 (glyphRun->bidiLevel % 2) == 1,
00062                 pSink.Get()
00063                 );
00064
00065             if (SUCCEEDED(hr))
00066             {
00067                 hr = pSink->Close();
00068
00069                 if (SUCCEEDED(hr))
00070                 {
00071                     ComPtr<ID2D1TransformedGeometry> pTransformedGeometry;
00072
00073                     hr = m_pFactory->CreateTransformedGeometry(
00074                         pPathGeometry.Get(),
00075                         D2D1::Matrix3x2F::Translation(baselineOriginX, baselineOriginY),
00076                         &pTransformedGeometry
00077                         );
00078
00079                     if (SUCCEEDED(hr))
00080                     {
00081                         AddGeometry(pTransformedGeometry.Get());
00082                     }
00083                 }
00084             }
00085         }
00086     }
00087
00088     return hr;
00089 }
00090
00091 HRESULT OutlineRenderer::DrawUnderline(
00092     void* /*clientDrawingContext*/,
00093     FLOAT /*baselineOriginX*/,
00094     FLOAT /*baselineOriginY*/,
00095     DWRITE_UNDERLINE const* /*underline*/,
00096     IUnknown* /*clientDrawingEffect*/
00097     )
00098 {
00099     // Implement this to add support for underlines.
00100     return E_NOTIMPL;
00101 }
00102
00103 HRESULT OutlineRenderer::DrawStrikethrough(
00104     void* /*clientDrawingContext*/,
00105     FLOAT /*baselineOriginX*/,
00106     FLOAT /*baselineOriginY*/,
00107     DWRITE_STRIKETHROUGH const* /*strikethrough*/,
00108     IUnknown* /*clientDrawingEffect*/
00109     )
00110 {
00111     // Implement this to add support for strikethroughs.
00112     return E_NOTIMPL;
00113 }
00114
00115 HRESULT OutlineRenderer::DrawInlineObject(
00116     void* /*clientDrawingContext*/,
00117     FLOAT /*originX*/,
00118     FLOAT /*originY*/,
00119     IDWriteInlineObject* /*inlineObject*/,
00120     BOOL /*isSideways*/,
00121     BOOL /*isRightToLeft*/,
00122     IUnknown* /*clientDrawingEffect*/
00123     )
00124 {
00125     // Implement this to add support for inline objects.
00126     return E_NOTIMPL;
00127 }
00128
00129 HRESULT OutlineRenderer::IsPixelSnappingDisabled(
00130     void* /*clientDrawingContext*/,
00131     BOOL* isDisabled
00132     )
00133 {
00134     *isDisabled = TRUE;
00135     return S_OK;
00136 }
00137
00138 HRESULT OutlineRenderer::GetCurrentTransform(
00139     void* /*clientDrawingContext*/,
00140     DWRITE_MATRIX* transform
00141     )
00142 {
00143     DWRITE_MATRIX matrix = {1, 0, 0, 1, 0, 0};
00144     *transform = matrix;
00145     return S_OK;
00146 }
00147
00148 HRESULT OutlineRenderer::GetPixelsPerDip(
00149     void* /*clientDrawingContext*/,
00150     FLOAT* pixelsPerDip
00151     )
00152 {
00153     *pixelsPerDip = 1.0f;
00154     return S_OK;
00155 }
00156
00157 void OutlineRenderer::GetGeometry(ID2D1Geometry** ppGeometry)
00158 {
00159     if (m_pGeometry)
00160     {
00161         *ppGeometry = m_pGeometry.Get();
00162         (*ppGeometry)->AddRef();
00163     }
00164     else
00165     {
00166         ComPtr<ID2D1PathGeometry> pGeometry;
00167         DX::ThrowIfFailed(
00168             m_pFactory->CreatePathGeometry(&pGeometry)
00169             );
00170
00171         ComPtr<ID2D1GeometrySink> pSink;
00172         DX::ThrowIfFailed(
00173             pGeometry->Open(&pSink)
00174             );
00175
00176         DX::ThrowIfFailed(
00177             pSink->Close()
00178             );
00179
00180         *ppGeometry = pGeometry.Get();
00181         (*ppGeometry)->AddRef();
00182     }
00183 }
00184
00185 void OutlineRenderer::AddGeometry(ID2D1Geometry* pGeometry)
00186 {
00187     if (m_pGeometry == nullptr)
00188     {
00189         // Just save the geometry.
00190         m_pGeometry = ComPtr<ID2D1Geometry>(pGeometry);
00191     }
00192     else
00193     {
00194         // Combine the provided geometry with the saved geometry.
00195
00196         ComPtr<ID2D1Factory> pFactory;
00197         m_pGeometry->GetFactory(&pFactory);
00198
00199         ComPtr<ID2D1PathGeometry> pPathGeometry;
00200         DX::ThrowIfFailed(
00201             pFactory->CreatePathGeometry(&pPathGeometry)
00202             );
00203
00204         ComPtr<ID2D1GeometrySink> pSink;
00205         DX::ThrowIfFailed(
00206             pPathGeometry->Open(&pSink)
00207             );
00208
00209         DX::ThrowIfFailed(
00210             m_pGeometry->CombineWithGeometry(
00211                 pGeometry,
00212                 D2D1_COMBINE_MODE_UNION,
00213                 nullptr, // world transform
00214                 pSink.Get()
00215                 )
00216             );
00217
00218         DX::ThrowIfFailed(
00219             pSink->Close()
00220             );
00221
00222         m_pGeometry = pPathGeometry;
00223     }
00224 }
00225
00226 //
00227 // IUnknown methods.
00228 //
00229 // These use a basic, non-thread-safe implementation of the
00230 // standard reference-counting logic.
00231 //
00232 HRESULT OutlineRenderer::QueryInterface(REFIID riid, _Outptr_ void** object)
00233 {
00234     *object = nullptr;
00235     return E_NOTIMPL;
00236 }
00237
00238 ULONG OutlineRenderer::AddRef()
00239 {
00240     m_ref++;
00241     return m_ref;
00242 }
00243
00244 ULONG OutlineRenderer::Release()
00245 {
00246     m_ref--;
00247
00248     if (m_ref == 0)
00249     {
00250         delete this;
00251         return 0;
00252     }
00253
00254     return m_ref;
00255 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/C++/Background/pch.cpp Source File

  • ControlChannelTrigger XMLHTTPRequest
  • Background

pch.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // pch.cpp
00003 // Include the standard header and generate the precompiled header.
00004 //
00005
00006 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicReaderWriter.cpp Source File

  • Direct3D HLSL fractal generator

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario5.xaml.cpp Source File

  • XAML WebView control

Scenario5.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario5.xaml.cpp
00013 // Implementation of the Scenario5 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario5.xaml.h"
00018
00019 using namespace SDKSample::WebViewControl;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::Foundation::Collections;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Navigation;
00027
00028 Scenario5::Scenario5()
00029 {
00030     InitializeComponent();
00031 }
00032
00033 // Invoked when this page is about to be displayed in a Frame.
00034 void Scenario5::OnNavigatedTo(NavigationEventArgs^ e)
00035 {
00036     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00037     // as NotifyUser()
00038     rootPage = MainPage::Current;
00039
00040   // Hook the LoadCompleted event for the WebView to know when the URL is fully loaded
00041   WebView5->LoadCompleted += ref new LoadCompletedEventHandler(this, &Scenario5::WebView5_LoadCompleted);
00042
00043   WebView5->Navigate(ref new Uri("http://kexp.org/Playlist"));
00044 }
00045
00046 // Load completed handler for WebView5
00047 void SDKSample::WebViewControl::Scenario5::WebView5_LoadCompleted(Platform::Object^ sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^ e)
00048 {
00049   IVector<Uri^>^ allowedUris = ref new Platform::Collections::Vector<Uri^>();
00050   allowedUris->Append(ref new Uri("http://kexp.org"));
00051   WebView5->AllowedScriptNotifyUris = allowedUris;
00052   WebView5->ScriptNotify += ref new NotifyEventHandler(this, &Scenario5::WebView5_ScriptNotify);
00053
00054
00055   Array<String^,1>^ args = ref new Array<String^>(1);
00056   args[0] = "document.title;";
00057   String^ foo = WebView5->InvokeScript("eval", args);
00058   String^ str = "Title is: {0}" + foo;
00059   rootPage->NotifyUser(str, NotifyType::StatusMessage);
00060 }
00061
00062 // Script notify for WebView5
00063 void SDKSample::WebViewControl::Scenario5::WebView5_ScriptNotify(Platform::Object^ sender, Windows::UI::Xaml::Controls::NotifyEventArgs^ e)
00064 {
00065   rootPage->NotifyUser(e->Value, NotifyType::StatusMessage);
00066 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/DirectXBase.h Source File

  • Input Manipulations and gestures (C++)
  • C++

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DDSTextureLoader.cpp Source File

  • Direct3D HLSL fractal generator

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicLoader.h Source File

  • Direct3D sprite

BasicLoader.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicReaderWriter.h"
00011
00012 // A simple loader class that provides support for loading shaders, textures,
00013 // and meshes from files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicLoader
00015 {
00016 internal:
00017     BasicLoader(
00018         _In_ ID3D11Device* d3dDevice,
00019         _In_opt_ IWICImagingFactory2* wicFactory = nullptr
00020         );
00021
00022     void LoadTexture(
00023         _In_ Platform::String^ filename,
00024         _Out_opt_ ID3D11Texture2D** texture,
00025         _Out_opt_ ID3D11ShaderResourceView** textureView
00026         );
00027
00028     concurrency::task<void> LoadTextureAsync(
00029         _In_ Platform::String^ filename,
00030         _Out_opt_ ID3D11Texture2D** texture,
00031         _Out_opt_ ID3D11ShaderResourceView** textureView
00032         );
00033
00034     void LoadShader(
00035         _In_ Platform::String^ filename,
00036         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00037         _In_ uint32 layoutDescNumElements,
00038         _Out_ ID3D11VertexShader** shader,
00039         _Out_opt_ ID3D11InputLayout** layout
00040         );
00041
00042     concurrency::task<void> LoadShaderAsync(
00043         _In_ Platform::String^ filename,
00044         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00045         _In_ uint32 layoutDescNumElements,
00046         _Out_ ID3D11VertexShader** shader,
00047         _Out_opt_ ID3D11InputLayout** layout
00048         );
00049
00050     void LoadShader(
00051         _In_ Platform::String^ filename,
00052         _Out_ ID3D11PixelShader** shader
00053         );
00054
00055     concurrency::task<void> LoadShaderAsync(
00056         _In_ Platform::String^ filename,
00057         _Out_ ID3D11PixelShader** shader
00058         );
00059
00060     void LoadShader(
00061         _In_ Platform::String^ filename,
00062         _Out_ ID3D11ComputeShader** shader
00063         );
00064
00065     concurrency::task<void> LoadShaderAsync(
00066         _In_ Platform::String^ filename,
00067         _Out_ ID3D11ComputeShader** shader
00068         );
00069
00070     void LoadShader(
00071         _In_ Platform::String^ filename,
00072         _Out_ ID3D11GeometryShader** shader
00073         );
00074
00075     concurrency::task<void> LoadShaderAsync(
00076         _In_ Platform::String^ filename,
00077         _Out_ ID3D11GeometryShader** shader
00078         );
00079
00080     void LoadShader(
00081         _In_ Platform::String^ filename,
00082         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00083         _In_ uint32 numEntries,
00084         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00085         _In_ uint32 numStrides,
00086         _In_ uint32 rasterizedStream,
00087         _Out_ ID3D11GeometryShader** shader
00088         );
00089
00090     concurrency::task<void> LoadShaderAsync(
00091         _In_ Platform::String^ filename,
00092         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00093         _In_ uint32 numEntries,
00094         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00095         _In_ uint32 numStrides,
00096         _In_ uint32 rasterizedStream,
00097         _Out_ ID3D11GeometryShader** shader
00098         );
00099
00100     void LoadShader(
00101         _In_ Platform::String^ filename,
00102         _Out_ ID3D11HullShader** shader
00103         );
00104
00105     concurrency::task<void> LoadShaderAsync(
00106         _In_ Platform::String^ filename,
00107         _Out_ ID3D11HullShader** shader
00108         );
00109
00110     void LoadShader(
00111         _In_ Platform::String^ filename,
00112         _Out_ ID3D11DomainShader** shader
00113         );
00114
00115     concurrency::task<void> LoadShaderAsync(
00116         _In_ Platform::String^ filename,
00117         _Out_ ID3D11DomainShader** shader
00118         );
00119
00120     void LoadMesh(
00121         _In_ Platform::String^ filename,
00122         _Out_ ID3D11Buffer** vertexBuffer,
00123         _Out_ ID3D11Buffer** indexBuffer,
00124         _Out_opt_ uint32* vertexCount,
00125         _Out_opt_ uint32* indexCount
00126         );
00127
00128     concurrency::task<void> LoadMeshAsync(
00129         _In_ Platform::String^ filename,
00130         _Out_ ID3D11Buffer** vertexBuffer,
00131         _Out_ ID3D11Buffer** indexBuffer,
00132         _Out_opt_ uint32* vertexCount,
00133         _Out_opt_ uint32* indexCount
00134         );
00135
00136 private:
00137     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00138     Microsoft::WRL::ComPtr<IWICImagingFactory2> m_wicFactory;
00139     BasicReaderWriter^ m_basicReaderWriter;
00140
00141     template <class DeviceChildType>
00142     inline void SetDebugName(
00143         _In_ DeviceChildType* object,
00144         _In_ Platform::String^ name
00145         );
00146
00147     Platform::String^ GetExtension(
00148         _In_ Platform::String^ filename
00149         );
00150
00151     void CreateTexture(
00152         _In_ bool decodeAsDDS,
00153         _In_reads_bytes_(dataSize) byte* data,
00154         _In_ uint32 dataSize,
00155         _Out_opt_ ID3D11Texture2D** texture,
00156         _Out_opt_ ID3D11ShaderResourceView** textureView,
00157         _In_opt_ Platform::String^ debugName
00158         );
00159
00160     void CreateInputLayout(
00161         _In_reads_bytes_(bytecodeSize) byte* bytecode,
00162         _In_ uint32 bytecodeSize,
00163         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00164         _In_ uint32 layoutDescNumElements,
00165         _Out_ ID3D11InputLayout** layout
00166         );
00167
00168     void CreateMesh(
00169         _In_ byte* meshData,
00170         _Out_ ID3D11Buffer** vertexBuffer,
00171         _Out_ ID3D11Buffer** indexBuffer,
00172         _Out_opt_ uint32* vertexCount,
00173         _Out_opt_ uint32* indexCount,
00174         _In_opt_ Platform::String^ debugName
00175         );
00176 };
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/ProfileLocalUsageData.xaml.h Source File

  • Network information

ProfileLocalUsageData.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ProfileLocalUsageData.xaml.h
00013 // Declaration of the ProfileLocalUsageData class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "ProfileLocalUsageData.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace NetworkInformationApi
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class ProfileLocalUsageData sealed
00030         {
00031         public:
00032             ProfileLocalUsageData();
00033
00034         protected:
00035             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036         private:
00037             MainPage^ rootPage;
00038             void ProfileLocalUsageData_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CMPEG1Stream::SourceLock Member List

This is the complete list of members for CMPEG1Stream::SourceLock, including all inherited members.
_Acquires_lock_(m_pSource) SourceLock(CMPEG1Source *pSource) | CMPEG1Stream::SourceLock |
_Releases_lock_(m_pSource)~SourceLock() | CMPEG1Stream::SourceLock |
m_pSource | CMPEG1Stream::SourceLock | [private]
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Constants.cpp Source File

  • DatagramSocket

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace DatagramSocketSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "Start Datagram Listener", "DatagramSocketSample.Scenario1" },
00022     { "Connect to Listener", "DatagramSocketSample.Scenario2" },
00023     { "Send Data", "DatagramSocketSample.Scenario3" },
00024     { "Close Socket", "DatagramSocketSample.Scenario4" }
00025 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/D2D3DTransformsRenderer.cpp Source File

  • Direct2D 3D transform effect

D2D3DTransformsRenderer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Microsoft::WRL;
00011 using namespace Platform;
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::Graphics::Display;
00017 using namespace Windows::UI::ApplicationSettings;
00018 using namespace Windows::UI::Core;
00019 using namespace Windows::UI::ViewManagement;
00020
00021 // Constants that control UI layout.
00022 static const float PropertyOffsetLeft = -555.0f;
00023 static const float PropertyOffsetTop = -150.0f;
00024 static const float PropertyWidth = 160.0f;
00025 static const float PropertyHeight = 100.0f;
00026 static const float PropertyMargin = 10.0f;
00027 static const float CaptionOffsetTop = -175.0f;
00028 static const float MatrixOffsetLeft = -550.0f;
00029 static const float MatrixOffsetTop = -150.0f;
00030 static const float MatrixMargin = 25.0f;
00031 static const float MatrixWidth = 150.0f;
00032 static const float MatrixHeight = 100.0f;
00033
00034 D2D3DTransformsRenderer::D2D3DTransformsRenderer()
00035 {
00036 }
00037
00038 void D2D3DTransformsRenderer::CreateDeviceIndependentResources()
00039 {
00040     DirectXBase::CreateDeviceIndependentResources();
00041
00042     // Text formats used for displaying the effect properties are created in
00043     // this method, since they are independent of the Direct2D device itself.
00044     // In the event the device needs to be reinstantiated (due to a resolution
00045     // change for example), these font resources will not need to be recreated.
00046
00047     String^ fontName = "Segoe UI";
00048     String^ locale = "en-US";
00049
00050     DX::ThrowIfFailed(
00051         m_dwriteFactory->CreateTextFormat(
00052             fontName->Data(),
00053             nullptr,
00054             DWRITE_FONT_WEIGHT_NORMAL,
00055             DWRITE_FONT_STYLE_NORMAL,
00056             DWRITE_FONT_STRETCH_NORMAL,
00057             11,
00058             locale->Data(),
00059             &m_captionFormat
00060             )
00061         );
00062
00063     // Center the text horizontally.
00064     DX::ThrowIfFailed(
00065         m_captionFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00066         );
00067
00068     // Center the text vertically.
00069     DX::ThrowIfFailed(
00070         m_captionFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00071         );
00072
00073     DX::ThrowIfFailed(
00074         m_dwriteFactory->CreateTextFormat(
00075             fontName->Data(),
00076             nullptr,
00077             DWRITE_FONT_WEIGHT_LIGHT,
00078             DWRITE_FONT_STYLE_NORMAL,
00079             DWRITE_FONT_STRETCH_NORMAL,
00080             12,
00081             locale->Data(),
00082             &m_matrixValueFormat
00083             )
00084         );
00085
00086     // Center the text horizontally.
00087     DX::ThrowIfFailed(
00088         m_matrixValueFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00089         );
00090
00091     // Center the text vertically.
00092     DX::ThrowIfFailed(
00093         m_matrixValueFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00094         );
00095
00096     DX::ThrowIfFailed(
00097         m_dwriteFactory->CreateTextFormat(
00098             fontName->Data(),
00099             nullptr,
00100             DWRITE_FONT_WEIGHT_NORMAL,
00101             DWRITE_FONT_STYLE_NORMAL,
00102             DWRITE_FONT_STRETCH_NORMAL,
00103             18,
00104             locale->Data(),
00105             &m_propertyValueFormat
00106             )
00107         );
00108
00109     // Center the text horizontally.
00110     DX::ThrowIfFailed(
00111         m_propertyValueFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00112         );
00113
00114     DX::ThrowIfFailed(
00115         m_dwriteFactory->CreateTextFormat(
00116             fontName->Data(),
00117             nullptr,
00118             DWRITE_FONT_WEIGHT_LIGHT,
00119             DWRITE_FONT_STYLE_NORMAL,
00120             DWRITE_FONT_STRETCH_NORMAL,
00121             18,
00122             locale->Data(),
00123             &m_symbolFormat
00124             )
00125         );
00126
00127     // Center the text horizontally.
00128     DX::ThrowIfFailed(
00129         m_symbolFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00130         );
00131
00132     // Center the text vertically.
00133     DX::ThrowIfFailed(
00134         m_symbolFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         m_dwriteFactory->CreateTextFormat(
00139             fontName->Data(),
00140             nullptr,
00141             DWRITE_FONT_WEIGHT_LIGHT,
00142             DWRITE_FONT_STYLE_NORMAL,
00143             DWRITE_FONT_STRETCH_NORMAL,
00144             20,
00145             locale->Data(),
00146             &m_snappedViewFormat
00147             )
00148         );
00149
00150     // Center the text horizontally.
00151     DX::ThrowIfFailed(
00152         m_snappedViewFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00153         );
00154
00155     // Center the text vertically.
00156     DX::ThrowIfFailed(
00157         m_snappedViewFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00158         );
00159
00160     // Load an image from a Windows Imaging Component
00161     // decoder, which will be passed to the BitmapSource effect
00162     // in CreateDeviceResources.
00163     ComPtr<IWICBitmapDecoder> decoder;
00164     DX::ThrowIfFailed(
00165         m_wicFactory->CreateDecoderFromFilename(
00166             L"mammoth_small.jpg",
00167             nullptr,
00168             GENERIC_READ,
00169             WICDecodeMetadataCacheOnDemand,
00170             &decoder
00171             )
00172         );
00173
00174     ComPtr<IWICBitmapFrameDecode> frame;
00175     DX::ThrowIfFailed(
00176         decoder->GetFrame(0, &frame)
00177         );
00178
00179     DX::ThrowIfFailed(
00180         m_wicFactory->CreateFormatConverter(&m_wicFormatConverter)
00181         );
00182
00183     DX::ThrowIfFailed(
00184         m_wicFormatConverter->Initialize(
00185             frame.Get(),
00186             GUID_WICPixelFormat32bppPBGRA,
00187             WICBitmapDitherTypeNone,
00188             nullptr,
00189             0.0f,
00190             WICBitmapPaletteTypeCustom
00191             )
00192         );
00193
00194     // Get the size of the image.
00195     unsigned int width, height;
00196     DX::ThrowIfFailed(m_wicFormatConverter->GetSize(&width, &height));
00197     m_imageSize = D2D1::SizeU(width, height);
00198 }
00199
00200 void D2D3DTransformsRenderer::CreateDeviceResources()
00201 {
00202     DirectXBase::CreateDeviceResources();
00203
00204     DX::ThrowIfFailed(
00205         m_d2dContext->CreateSolidColorBrush(
00206             D2D1::ColorF(D2D1::ColorF::White),
00207             &m_whiteBrush
00208             )
00209         );
00210
00211     // Create a bitmap source effect and bind the WIC format converter to it.
00212     m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_bitmapSourceEffect);
00213     DX::ThrowIfFailed(
00214         m_bitmapSourceEffect->SetValue(
00215             D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE,
00216             m_wicFormatConverter.Get()
00217             )
00218         );
00219
00220     // Because the image will not be changing, the BitmapSource effect should be cached for better performance.
00221
00222     // The property system expects TRUE and FALSE rather than true or false to ensure that
00223     // the size of the value is consistent regardless of architecture.
00224     DX::ThrowIfFailed(
00225         m_bitmapSourceEffect->SetValue(
00226             D2D1_PROPERTY_CACHED,
00227             TRUE
00228             )
00229         );
00230
00231     // Create the matrix-based transform effect.
00232     DX::ThrowIfFailed(
00233         m_d2dContext->CreateEffect(CLSID_D2D13DTransform, &m_3DTransformEffect)
00234         );
00235
00236     m_3DTransformEffect->SetInputEffect(0, m_bitmapSourceEffect.Get());
00237
00238     // Create the property-based transform effect.
00239     DX::ThrowIfFailed(
00240         m_d2dContext->CreateEffect(CLSID_D2D13DPerspectiveTransform, &m_3DPerspectiveTransformEffect)
00241         );
00242
00243     m_3DPerspectiveTransformEffect->SetInputEffect(0, m_bitmapSourceEffect.Get());
00244 }
00245
00246 void D2D3DTransformsRenderer::CreateWindowSizeDependentResources()
00247 {
00248     DirectXBase::CreateWindowSizeDependentResources();
00249
00250     D2D1_SIZE_F size = m_d2dContext->GetSize();
00251
00252     // Render effect properties centered at the bottom of the screen.
00253     m_captionTop = size.height + CaptionOffsetTop;
00254     m_matrixTop = size.height + MatrixOffsetTop;
00255     m_propertyTop = size.height + PropertyOffsetTop;
00256
00257     // Scale image based on DPI.
00258     D2D1_POINT_2F scale = D2D1::Point2F(m_dpi / 96.0f, m_dpi / 96.0f);
00259     m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, scale);
00260
00261     Render();
00262 }
00263
00264 void D2D3DTransformsRenderer::Render()
00265 {
00266     m_d2dContext->BeginDraw();
00267
00268     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00269
00270     if (m_windowState != ApplicationViewState::Snapped)
00271     {
00272         // Only render the effect that is currently being manipuated by the XAML code.
00273         if (m_currentEffect == TransformEffect::D2D13DTransform)
00274         {
00275             Render3DTransformEffect();
00276         }
00277         else if (m_currentEffect == TransformEffect::D2D13DPerspectiveTransform)
00278         {
00279             Render3DPerspectiveTransformEffect();
00280         }
00281         else
00282         {
00283             throw ref new Platform::FailureException();
00284         }
00285     }
00286     else
00287     {
00288         // Display message that app is not designed to be run in snapped mode.
00289
00290         Platform::String^ snapMessage = "This sample does not support snapped view.";
00291
00292         D2D1_SIZE_F size = m_d2dContext->GetSize();
00293
00294         m_d2dContext->DrawText(
00295             snapMessage->Data(),
00296             snapMessage->Length(),
00297             m_snappedViewFormat.Get(),
00298             D2D1::RectF(0.0f, 0.0f, size.width, size.height),
00299             m_whiteBrush.Get()
00300             );
00301     }
00302
00303     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00304     // is lost. It will be handled during the next call to Present.
00305     HRESULT hr = m_d2dContext->EndDraw();
00306     if (hr != D2DERR_RECREATE_TARGET)
00307     {
00308         DX::ThrowIfFailed(hr);
00309     }
00310
00311     Present();
00312 }
00313
00314 void D2D3DTransformsRenderer::SetTransformEffect(TransformEffect transformEffect)
00315 {
00316     m_currentEffect = transformEffect;
00317
00318     if (m_swapChainPanel != nullptr)
00319     {
00320         Render();
00321     }
00322 }
00323
00324 void D2D3DTransformsRenderer::SetTransformProperty(TransformProperty transformProperty, float value)
00325 {
00326     switch (transformProperty)
00327     {
00328     case TransformProperty::ScaleX:
00329         m_scaleX = value;
00330         break;
00331     case TransformProperty::ScaleY:
00332         m_scaleY = value;
00333         break;
00334     case TransformProperty::LocalOffsetX:
00335         m_localOffsetX = value;
00336         break;
00337     case TransformProperty::LocalOffsetY:
00338         m_localOffsetY = value;
00339         break;
00340     case TransformProperty::LocalOffsetZ:
00341         m_localOffsetZ = value;
00342         break;
00343     case TransformProperty::RotationX:
00344         m_rotationX = value;
00345         break;
00346     case TransformProperty::RotationY:
00347         m_rotationY = value;
00348         break;
00349     case TransformProperty::RotationZ:
00350         m_rotationZ = value;
00351         break;
00352     case TransformProperty::GlobalOffsetX:
00353         m_globalOffsetX = value;
00354         break;
00355     case TransformProperty::GlobalOffsetY:
00356         m_globalOffsetY = value;
00357         break;
00358     case TransformProperty::GlobalOffsetZ:
00359         m_globalOffsetZ = value;
00360         break;
00361     case TransformProperty::Perspective:
00362         m_perspective = value;
00363         break;
00364     default:
00365         throw ref new Platform::FailureException();
00366         break;
00367     }
00368
00369     if (m_swapChainPanel != nullptr)
00370     {
00371         Render();
00372     }
00373 }
00374
00375 void D2D3DTransformsRenderer::Render3DTransformEffect()
00376 {
00377     // Generate Transform matrix for 3DTransform effect.
00378     D2D1::Matrix4x4F transformMatrix =                   // Parentheses below denote equivalent property in 3DPerspectiveTransform.
00379         D2D1::Matrix4x4F::Scale(m_scaleX, m_scaleY, 1) * // Scales the image. (No equivalent in 3DPerspectiveTransform)
00380         D2D1::Matrix4x4F::Translation(                   // Translate the image before rotation. (LOCAL_OFFSET property)
00381             m_localOffsetX,
00382             m_localOffsetY,
00383             m_localOffsetZ
00384             ) *
00385         D2D1::Matrix4x4F::RotationX(m_rotationX) *       // Rotate the image on the X, Y and Z axes. (ROTATION property)
00386         D2D1::Matrix4x4F::RotationY(m_rotationY) *
00387         D2D1::Matrix4x4F::RotationZ(m_rotationZ) *
00388         D2D1::Matrix4x4F::Translation(                   // Translate the image after rotation. (GLOBAL_OFFSET property)
00389             m_globalOffsetX,
00390             m_globalOffsetY,
00391             m_globalOffsetZ
00392             ) *
00393         D2D1::Matrix4x4F::PerspectiveProjection(         // Apply perspective to the image. (DEPTH property)
00394             m_perspective
00395             );
00396
00397     DX::ThrowIfFailed(m_3DTransformEffect->SetValue(D2D1_3DTRANSFORM_PROP_TRANSFORM_MATRIX, transformMatrix));
00398
00399     D2D1_SIZE_F size = m_d2dContext->GetSize();
00400
00401     // Base matrix position off of the screen center.
00402     D2D1_POINT_2F screenCenter = D2D1::Point2F(
00403         size.width / 2.0f,
00404         size.height / 2.0f
00405         );
00406
00407     // Draw Scale matrix.
00408     DrawMatrix(
00409         "Matrix4x4F::Scale(" + m_scaleX.ToString() + ", " + m_scaleY.ToString() + ", 1)",
00410         D2D1::Matrix4x4F::Scale(m_scaleX, m_scaleY, 1),
00411         screenCenter.x + MatrixOffsetLeft
00412         );
00413
00414     // Draw 'x' between matrices.
00415     DrawSymbol("x", screenCenter.x + MatrixOffsetLeft + MatrixWidth);
00416
00417     // Draw the Local Offset matrix.
00418     DrawMatrix(
00419         "Matrix4x4F::Translation(" +
00420             m_localOffsetX.ToString() + ", " +
00421             m_localOffsetY.ToString() + ", " +
00422             m_localOffsetZ.ToString() + ")",
00423         D2D1::Matrix4x4F::Translation(m_localOffsetX, m_localOffsetY, m_localOffsetZ),
00424         screenCenter.x + MatrixOffsetLeft + MatrixWidth + MatrixMargin
00425         );
00426
00427     // Draw 'x' between matrices.
00428     DrawSymbol("x", screenCenter.x + MatrixOffsetLeft + MatrixWidth * 2 + MatrixMargin);
00429
00430     // Draw Rotation matrix. Two separate helper matrices are multipled together to create one rotation matrix.
00431     DrawMatrix(
00432         "Matrix4x4F::RotationX(" +m_rotationX.ToString() +
00433             ") * Matrix4x4F::RotationY(" + m_rotationY.ToString() +
00434             ") * Matrix4x4F::RotationZ(" + m_rotationZ.ToString() + ")",
00435         D2D1::Matrix4x4F::RotationX(m_rotationX) *
00436         D2D1::Matrix4x4F::RotationY(m_rotationY) *
00437         D2D1::Matrix4x4F::RotationZ(m_rotationZ),
00438         screenCenter.x + MatrixOffsetLeft + MatrixWidth * 2 + MatrixMargin * 2
00439         );
00440
00441     // Draw 'x' between matrices.
00442     DrawSymbol("x", screenCenter.x + MatrixOffsetLeft + MatrixWidth * 3 + MatrixMargin * 2);
00443
00444     // Draw the Global Offset matrix.
00445     DrawMatrix(
00446         "Matrix4x4F::Translation(" + m_globalOffsetX.ToString() + ", " + m_globalOffsetY.ToString() + ", " + m_globalOffsetZ.ToString() + ")",
00447         D2D1::Matrix4x4F::Translation(m_globalOffsetX, m_globalOffsetY, m_globalOffsetZ),
00448         screenCenter.x + MatrixOffsetLeft + MatrixWidth * 3 + MatrixMargin * 3
00449         );
00450
00451     // Draw 'x' between matrices.
00452     DrawSymbol("x", screenCenter.x + MatrixOffsetLeft + MatrixWidth * 4 + MatrixMargin * 3);
00453
00454     // Draw the Perspective matrix.
00455     DrawMatrix(
00456         "Matrix4x4F::PerspectiveProjection(\n" + m_perspective.ToString() + ")",
00457         D2D1::Matrix4x4F::PerspectiveProjection(m_perspective),
00458         screenCenter.x + MatrixOffsetLeft + MatrixWidth * 4 + MatrixMargin * 4
00459         );
00460
00461     // Draw '=' between matrices.
00462     DrawSymbol("=", screenCenter.x + MatrixOffsetLeft + MatrixWidth * 5 + MatrixMargin * 4);
00463
00464     // Result resultant transform matrix that is applied to m_3DTransformEffect.
00465     DrawMatrix(
00466         "",
00467         transformMatrix,
00468         screenCenter.x + MatrixOffsetLeft + MatrixWidth * 5 + MatrixMargin * 5
00469         );
00470
00471     // Render 3DTransform effect.
00472     m_d2dContext->DrawImage(
00473         m_3DTransformEffect.Get(),
00474         D2D1::Point2F(
00475             screenCenter.x - (m_imageSize.width / 2.0f),
00476             screenCenter.y - (m_imageSize.height / 2.0f)
00477             )
00478         );
00479 }
00480
00481 void D2D3DTransformsRenderer::Render3DPerspectiveTransformEffect()
00482 {
00483     D2D1_SIZE_F size = m_d2dContext->GetSize();
00484
00485     // Base property position off of the screen center.
00486     D2D1_POINT_2F screenCenter = D2D1::Point2F(
00487         size.width / 2.0f,
00488         size.height / 2.0f
00489         );
00490
00491     // Assign properties to 3DPerspectiveProperties effect.
00492     D2D1_VECTOR_3F localOffset = D2D1::Vector3F(m_localOffsetX, m_localOffsetY, m_localOffsetZ);
00493
00494     DX::ThrowIfFailed(
00495         m_3DPerspectiveTransformEffect->SetValue(
00496             D2D1_3DPERSPECTIVETRANSFORM_PROP_LOCAL_OFFSET,
00497             localOffset
00498             )
00499         );
00500
00501     D2D1_VECTOR_3F rotation = D2D1::Vector3F(m_rotationX, m_rotationY, m_rotationZ);
00502
00503     DX::ThrowIfFailed(
00504         m_3DPerspectiveTransformEffect->SetValue(
00505             D2D1_3DPERSPECTIVETRANSFORM_PROP_ROTATION,
00506             rotation
00507             )
00508         );
00509
00510     DX::ThrowIfFailed(
00511         m_3DPerspectiveTransformEffect->SetValue(
00512             D2D1_3DPERSPECTIVETRANSFORM_PROP_DEPTH,
00513             m_perspective
00514             )
00515         );
00516
00517     D2D1_VECTOR_3F globalOffset = D2D1::Vector3F(m_globalOffsetX, m_globalOffsetY, m_globalOffsetZ);
00518
00519     DX::ThrowIfFailed(
00520         m_3DPerspectiveTransformEffect->SetValue(
00521             D2D1_3DPERSPECTIVETRANSFORM_PROP_GLOBAL_OFFSET,
00522             globalOffset
00523             )
00524         );
00525
00526     Draw3DPerspectiveProperty("Scale Property", "Not available in 3DPerspective Transform", screenCenter.x + PropertyOffsetLeft);
00527
00528     String^ localOffsetValue = "(" + m_localOffsetX.ToString() + ", " + m_localOffsetY.ToString() + ", " + m_localOffsetZ.ToString() + ")";
00529     Draw3DPerspectiveProperty("LocalOffset Property", localOffsetValue, screenCenter.x + PropertyOffsetLeft + (PropertyWidth + PropertyMargin));
00530
00531     String^ rotationValue = "(" + m_rotationX.ToString() + ", " + m_rotationY.ToString() + ", " + m_rotationZ.ToString() + ")";
00532     Draw3DPerspectiveProperty("Rotation Property", rotationValue, screenCenter.x + PropertyOffsetLeft + (PropertyWidth + PropertyMargin) * 2.0f);
00533
00534     String^ globalOffsetValue = "(" + m_globalOffsetX.ToString() + ", " + m_globalOffsetY.ToString() + ", " + m_globalOffsetZ.ToString() + ")";
00535     Draw3DPerspectiveProperty("GlobalOffset Property", globalOffsetValue, screenCenter.x + PropertyOffsetLeft + (PropertyWidth + PropertyMargin) * 3.0f);
00536
00537     String^ depthValue = m_perspective.ToString();
00538     Draw3DPerspectiveProperty("Depth Property", depthValue, screenCenter.x + PropertyOffsetLeft + (PropertyWidth + PropertyMargin) * 4.0f);
00539
00540     // Render 3DPerspectiveTransform effect.
00541     m_d2dContext->DrawImage(
00542         m_3DPerspectiveTransformEffect.Get(),
00543         D2D1::Point2F(
00544             screenCenter.x - (m_imageSize.width / 2.0f),
00545             screenCenter.y - (m_imageSize.height / 2.0f)
00546             )
00547         );
00548 }
00549
00550 void D2D3DTransformsRenderer::Draw3DPerspectiveProperty(String^ caption, String^ value, float horizontalOffset)
00551 {
00552     // Helper method that draws the names and values of 3DPerspectiveTransform properties.
00553     m_d2dContext->DrawText(
00554         caption->Data(),
00555         caption->Length(),
00556         m_captionFormat.Get(),
00557         D2D1::RectF(
00558             horizontalOffset,
00559             m_captionTop,
00560             horizontalOffset + PropertyWidth,
00561             m_captionTop + m_captionHeight
00562             ),
00563         m_whiteBrush.Get()
00564         );
00565
00566     m_d2dContext->DrawText(
00567         value->Data(),
00568         value->Length(),
00569         m_propertyValueFormat.Get(),
00570         D2D1::RectF(
00571             horizontalOffset,
00572             m_propertyTop,
00573             horizontalOffset + PropertyWidth,
00574             m_propertyTop + PropertyHeight
00575             ),
00576         m_whiteBrush.Get()
00577         );
00578 }
00579
00580 void D2D3DTransformsRenderer::DrawMatrix(String^ caption, D2D1_MATRIX_4X4_F matrix, float horizontalOffset)
00581 {
00582     // Render Matrix Caption.
00583     m_d2dContext->DrawText(
00584         caption->Data(),
00585         caption->Length(),
00586         m_captionFormat.Get(),
00587         D2D1::RectF(
00588             horizontalOffset - MatrixMargin,
00589             m_captionTop,
00590             horizontalOffset + MatrixWidth + MatrixMargin,
00591             m_captionTop + m_captionHeight
00592             ),
00593         m_whiteBrush.Get()
00594         );
00595
00596     // Draw left bracket.
00597     m_d2dContext->DrawLine(
00598         D2D1::Point2F(horizontalOffset, m_matrixTop),
00599         D2D1::Point2F(horizontalOffset, m_matrixTop + MatrixHeight),
00600         m_whiteBrush.Get()
00601         );
00602
00603     m_d2dContext->DrawLine(
00604         D2D1::Point2F(horizontalOffset, m_matrixTop),
00605         D2D1::Point2F(horizontalOffset + MatrixWidth * 0.1f, m_matrixTop),
00606         m_whiteBrush.Get()
00607         );
00608
00609     m_d2dContext->DrawLine(
00610         D2D1::Point2F(horizontalOffset, m_matrixTop + MatrixHeight),
00611         D2D1::Point2F(horizontalOffset + MatrixWidth * 0.1f, m_matrixTop + MatrixHeight),
00612         m_whiteBrush.Get()
00613         );
00614
00615     // Draw right bracket.
00616     m_d2dContext->DrawLine(
00617         D2D1::Point2F(horizontalOffset + MatrixWidth, m_matrixTop),
00618         D2D1::Point2F(horizontalOffset + MatrixWidth, m_matrixTop + MatrixHeight),
00619         m_whiteBrush.Get()
00620         );
00621
00622     m_d2dContext->DrawLine(
00623         D2D1::Point2F(horizontalOffset + MatrixWidth * 0.9f, m_matrixTop),
00624         D2D1::Point2F(horizontalOffset + MatrixWidth, m_matrixTop),
00625         m_whiteBrush.Get()
00626         );
00627
00628     m_d2dContext->DrawLine(
00629         D2D1::Point2F(horizontalOffset + MatrixWidth * 0.9f, m_matrixTop + MatrixHeight),
00630         D2D1::Point2F(horizontalOffset + MatrixWidth, m_matrixTop + MatrixHeight),
00631         m_whiteBrush.Get()
00632         );
00633
00634     // Render contents of the passed-in matrix.
00635     for (int x = 0; x < 4; x++)
00636     {
00637         for (int y = 0; y < 4; y++)
00638         {
00639             // Use the floorf function to truncate the number to two decimal places.
00640             String^ matrixValue = (floorf(matrix.m[x][y] * 100.0f) / 100.0f).ToString();
00641
00642             m_d2dContext->DrawText(
00643                 matrixValue->Data(),
00644                 matrixValue->Length(),
00645                 m_matrixValueFormat.Get(),
00646                 D2D1::RectF(
00647                     horizontalOffset + MatrixWidth * (0.25f * x),
00648                     m_matrixTop + MatrixHeight * (0.25f * y),
00649                     horizontalOffset + MatrixWidth * (0.25f * (x + 1)),
00650                     m_matrixTop + MatrixHeight * (0.25f * (y + 1))
00651                     ),
00652                 m_whiteBrush.Get()
00653                 );
00654         }
00655     }
00656 }
00657
00658 void D2D3DTransformsRenderer::DrawSymbol(Platform::String^ symbol, float horizontalOffset)
00659 {
00660     m_d2dContext->DrawText(
00661         symbol->Data(),
00662         symbol->Length(),
00663         m_symbolFormat.Get(),
00664         D2D1::RectF(
00665             horizontalOffset,
00666             m_matrixTop,
00667             horizontalOffset + MatrixMargin,
00668             m_matrixTop + MatrixHeight
00669             ),
00670         m_whiteBrush.Get()
00671         );
00672 }
00673
00674 void D2D3DTransformsRenderer::UpdateForViewStateChanged(ApplicationViewState state)
00675 {
00676     m_windowState = state;
00677 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideText01 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideText01, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBody1 | NotificationsExtensions::TileContent::TileWideText01 |
TextBody2 | NotificationsExtensions::TileContent::TileWideText01 |
TextBody3 | NotificationsExtensions::TileContent::TileWideText01 |
TextBody4 | NotificationsExtensions::TileContent::TileWideText01 |
TextFields | NotificationsExtensions::NotificationBase |
TextHeading | NotificationsExtensions::TileContent::TileWideText01 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideText01() | NotificationsExtensions::TileContent::TileWideText01 | [inline]
TileWideText01() | NotificationsExtensions::TileContent::TileWideText01 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/pch.cpp Source File

  • Reading and writing data

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CartoonizeImageViewModel.h Source File

  • Hilo C++
  • Hilo

CartoonizeImageViewModel.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "ImageBase.h"
00010
00011 struct AmpPixel;
00012
00013 namespace Hilo
00014 {
00015     interface class IPhoto;
00016     class Repository;
00017     class ExceptionPolicy;
00018
00019     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how view model classes interact
00020     // with view classes (pages) and model classes (the state and operations of business objects).
00021
00022     // The CartoonizeImageViewModel class contains the presentation logic of the cartoon effect page (CartoonizeImageView.xaml).
00023     [Windows::UI::Xaml::Data::Bindable]
00024     [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class CartoonizeImageViewModel sealed : public ImageBase
00026     {
00027     internal:
00028         CartoonizeImageViewModel(std::shared_ptr<Repository> repository, std::shared_ptr<ExceptionPolicy> exceptionPolicy);
00029
00030         virtual void LoadState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ stateMap) override;
00031         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ stateMap) override;
00032         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033
00034         void Initialize(Platform::String^ photoPath);
00035
00036     public:
00037         virtual ~CartoonizeImageViewModel();
00038
00039         property Windows::UI::Xaml::Media::ImageSource^ Image
00040         {
00041             Windows::UI::Xaml::Media::ImageSource^ get();
00042         }
00043
00044         property Windows::UI::Xaml::Input::ICommand^ CartoonizeCommand
00045         {
00046             Windows::UI::Xaml::Input::ICommand^ get();
00047         }
00048
00049         property Windows::UI::Xaml::Input::ICommand^ ResumeCartoonizeCommand
00050         {
00051             Windows::UI::Xaml::Input::ICommand^ get();
00052         }
00053
00054         property Windows::UI::Xaml::Input::ICommand^ SaveCommand
00055         {
00056             Windows::UI::Xaml::Input::ICommand^ get();
00057         }
00058
00059         property Windows::UI::Xaml::Input::ICommand^ CancelCommand
00060         {
00061             Windows::UI::Xaml::Input::ICommand^ get();
00062         }
00063
00064         property bool InProgress { bool get(); }
00065         property float64 NeighborWindow { float64 get(); void set(float64 value); }
00066         property float64 Phases { float64 get(); void set(float64 value); }
00067
00068     private:
00069         Windows::UI::Xaml::Media::Imaging::WriteableBitmap^ m_image;
00070         concurrency::task<void> m_initializationTask;
00071         std::shared_ptr<Repository> m_repository;
00072         Platform::String^ m_photoPath;
00073         bool m_inProgress;
00074         bool m_isSaving;
00075         bool m_isAmpPixelArrayPopulated;
00076         bool m_isSourcePixelsPopulated;
00077         bool m_checkedForHardwareAcceleration;
00078         bool m_useHardwareAcceleration;
00079         concurrency::cancellation_token_source m_cts;
00080         float64 m_neighborWindow;
00081         float64 m_phases;
00082         AmpPixel* m_pOriginalPixels;
00083         byte* m_pSourcePixels;
00084         unsigned int m_scaledWidth;
00085         unsigned int m_scaledHeight;
00086
00087         Windows::UI::Xaml::Input::ICommand^ m_cartoonizeCommand;
00088         Windows::UI::Xaml::Input::ICommand^ m_resumeCartoonizeCommand;
00089         Windows::UI::Xaml::Input::ICommand^ m_saveCommand;
00090         Windows::UI::Xaml::Input::ICommand^ m_cancelCommand;
00091
00092         void ChangeInProgress(bool value);
00093         void CheckForCancellation();
00094         void EvaluateCommands();
00095         void CopyPixelDataToPlatformArray(Windows::Storage::Streams::IBuffer^ buffer, Platform::Array<unsigned char, 1>^ pixels, unsigned int width, unsigned int height);
00096         concurrency::task<IPhoto^> GetImagePhotoAsync();
00097         concurrency::task<Windows::Storage::Streams::IRandomAccessStream^> EncodeImageAsync(Windows::Storage::Streams::IRandomAccessStream^ sourceStream);
00098         bool ScaleImageDimensions(unsigned int origWidth, unsigned int origHeight);
00099
00100         AmpPixel* CopyPixelDataToAmpPixelArray(byte* sourcePixels, unsigned int width, unsigned int height, const unsigned int size);
00101         void CopyAmpPixelArrayToPixelData(byte* destPixels, AmpPixel* newPixels, unsigned int width, unsigned int height);
00102         concurrency::task<void> CartoonizeImageAmpAsync(concurrency::cancellation_token token);
00103         concurrency::task<void> CartoonizeImagePPLAsync(concurrency::cancellation_token token);
00104
00105         void CartoonizeImage(Platform::Object^ parameter);
00106         void Unsnap(Platform::Object^ parameter);
00107         void SaveImage(Platform::Object^ parameter);
00108         void CancelCartoonize(Platform::Object^ parameter);
00109         bool IsCartoonizing(Platform::Object^ parameter);
00110     };
00111 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/InAppPurchase.xaml.h Source File

  • Trial app and in-app purchase

InAppPurchase.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // InAppPurchase.xaml.h
00013 // Declaration of the InAppPurchase class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "InAppPurchase.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace StoreSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class InAppPurchase sealed
00031         {
00032         public:
00033             InAppPurchase();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00038         private:
00039             MainPage^ rootPage;
00040             Windows::Foundation::EventRegistrationToken eventRegistrationToken;
00041
00042             void LoadInAppPurchaseProxyFile();
00043             void InAppPurchaseRefreshScenario();
00044
00045             void TryProduct1_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046             void BuyProduct1Button_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void TryProduct2_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void BuyProduct2_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00049         };
00050     }
00051 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/NotificationExpiration.xaml.cpp Source File

  • App tiles and badges
  • C#,C++

NotificationExpiration.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // NotificationExpiration.xaml.cpp
00013 // Implementation of the NotificationExpiration class
00014 //
00015
00016 #include "pch.h"
00017 #include "NotificationExpiration.xaml.h"
00018
00019 using namespace SDKSample::Tiles;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Windows::UI::Notifications;
00027 using namespace NotificationsExtensions::TileContent;
00028
00029 NotificationExpiration::NotificationExpiration()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 void NotificationExpiration::OnNavigatedTo(NavigationEventArgs^ e)
00035 {
00036     rootPage = MainPage::Current;
00037 }
00038
00039 void NotificationExpiration::UpdateTileExpiring_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00040 {
00041   int seconds = _wtoi(Time->Text->Data());
00042   if (seconds == 0)
00043   {
00044     seconds = 10;
00045   }
00046
00047   Windows::Globalization::Calendar^ cal = ref new Windows::Globalization::Calendar();
00048   cal->SetToNow();
00049   cal->AddSeconds(seconds);
00050
00051   auto longTime = ref new Windows::Globalization::DateTimeFormatting::DateTimeFormatter("longtime");
00052   DateTime time = cal->GetDateTime();
00053   Platform::String^ result = longTime->Format(time);
00054
00055   auto tileContent = TileContentFactory::CreateTileWideText04();
00056   tileContent->TextBodyWrap->Text = "This notification will expire at "+ result;
00057   auto squareContent = TileContentFactory::CreateTileSquareText04();
00058   squareContent->TextBodyWrap->Text = "This notification will expire at " + result;
00059   tileContent->SquareContent = squareContent;
00060
00061   auto tile = tileContent->CreateNotification();
00062
00063   // set the expirationTime
00064   tile->ExpirationTime = dynamic_cast<Platform::IBox<DateTime>^>(PropertyValue::CreateDateTime(time));
00065
00066   TileUpdateManager::CreateTileUpdaterForApplication()->Update(tile);
00067   OutputTextBlock->Text = "Tile notification sent. It will expire at " + result;
00068 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/LowLatency.xaml.cpp Source File

  • Real-time communication

LowLatency.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // LowLatency.xaml.cpp
00013 // Implementation of the LowLatency class
00014 //
00015
00016 #include "pch.h"
00017 #include "LowLatency.xaml.h"
00018
00019 using namespace SimpleCommunication;
00020 using namespace Windows::UI::Core;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 using namespace concurrency;
00026
00027 enum Action
00028 {
00029     previewButtonClicked,
00030     localClientButtonClicked,
00031     previewSetupCompleted,
00032     recordingStarted,
00033     latencyModeToggled,
00034 };
00035
00036 LowLatency::LowLatency()
00037     : _device(nullptr)
00038     , _currentState(ScenarioOneStates::uninitialized)
00039     , _previousState(ScenarioOneStates::uninitialized)
00040     , _latencyMode(LatencyModes::uninitialized)
00041     , _initialized(false)
00042     , _videoSettingsFilter(nullptr)
00043 {
00044     InitializeComponent();
00045
00046     _sdkSample.Initialize(StatusMessage, Window::Current->Dispatcher);
00047     _dispatcher = Window::Current->Dispatcher;
00048
00049     _localHostVideo[LatencyModes::highLatency] = PlaybackVideo;
00050     _localHostVideo[LatencyModes::lowLatency] = RealTimePlaybackVideo;
00051
00052     _streamFilteringCriteria.aspectRatio = "1.333333333333333";
00053     _streamFilteringCriteria.horizontalResolution = 640;
00054     _streamFilteringCriteria.subType = "YUY2";
00055
00056     actionTransitionFunctions[ScenarioOneStates::initializing][Action::previewSetupCompleted] = ref new ActionTransition(this, &LowLatency::initializing_previewSetupCompleted);
00057     actionTransitionFunctions[ScenarioOneStates::waiting][Action::previewButtonClicked] = ref new ActionTransition(this, &LowLatency::waiting_previewButtonClicked);
00058     actionTransitionFunctions[ScenarioOneStates::previewing][Action::previewButtonClicked] = ref new ActionTransition(this, &LowLatency::previewing_previewButtonClicked);
00059     actionTransitionFunctions[ScenarioOneStates::previewing][Action::localClientButtonClicked] = ref new ActionTransition(this, &LowLatency::previewing_localClientButtonClicked);
00060     actionTransitionFunctions[ScenarioOneStates::previewing][Action::recordingStarted] = ref new ActionTransition(this, &LowLatency::previewing_recordingStarted);
00061     actionTransitionFunctions[ScenarioOneStates::streaming][Action::previewButtonClicked] = ref new ActionTransition(this, &LowLatency::streaming_previewButtonClicked);
00062     actionTransitionFunctions[ScenarioOneStates::streaming][Action::latencyModeToggled] = ref new ActionTransition(this, &LowLatency::streaming_latencyModeToggled);
00063     actionTransitionFunctions[ScenarioOneStates::streaming][Action::recordingStarted] = ref new ActionTransition(this, &LowLatency::streaming_recordingStarted);
00064 }
00065
00066 /// <summary>
00067 /// Invoked when this page is about to be displayed in a Frame.
00068 /// </summary>
00069 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00070 /// property is typically used to configure the page.</param>
00071 void
00072     LowLatency::OnNavigatedTo(NavigationEventArgs^ e)
00073 {
00074     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00075     // as NotifyUser()
00076     _rootPage = MainPage::Current;
00077
00078     if (_initialized)
00079     {
00080         InitializeUIControls();
00081         _rootPage->SetCurrentScenario("SimpleCommunication::LowLatency");
00082         return;
00083     }
00084     else
00085         if (_currentState == ScenarioOneStates::initializing || _device)
00086         {
00087             // We are already in intializing state.
00088             return;
00089         }
00090
00091         _rootPage->LockScenarioChange();
00092
00093         _sdkSample.DisplayStatus("Loading...Please wait.");
00094
00095         // Check for camera and init scenario if one is found
00096         task<DeviceInformationCollection^>(DeviceInformation::FindAllAsync(DeviceClass::VideoCapture)).then([this](DeviceInformationCollection^ devices)
00097         {
00098             return devices->Size > 0;
00099         }).then([this](bool success)
00100         {
00101             if (success)
00102             {
00103                 if (_currentState == ScenarioOneStates::initializing || _device)
00104                 {
00105                     // We are already in intializing state.
00106                     cancel_current_task();
00107                 }
00108                 else
00109                 {
00110                     return Initialize().then([this](task<void> result)
00111                     {
00112                         try
00113                         {
00114                             result.get();
00115                             return task<void>(_dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00116                             {
00117                                 InitializeUIControls();
00118                                 _rootPage->UnlockScenarioChange();
00119                                 _initialized = true;
00120                                 _rootPage->SetCurrentScenario("SimpleCommunication::LowLatency");
00121
00122                                 m_visibilityEventRegistrationToken = Window::Current->VisibilityChanged += ref new Windows::UI::Xaml::WindowVisibilityChangedEventHandler(this, &LowLatency::VisibilityChanged);
00123                             })));
00124                         }
00125                         catch (Platform::Exception^ e)
00126                         {
00127                             Windows::Foundation::HResult hr;
00128                             hr.Value = e->HResult;
00129                             _sdkSample.FormatError(hr, "Initialization error: ", "");
00130                             _rootPage->UnlockScenarioChange();
00131                             throw e;
00132                         }
00133                     });
00134                 }
00135             }
00136             else
00137             {
00138                 _sdkSample.DisplayError("A machine with a camera is required to run this sample.");
00139                 _rootPage->UnlockScenarioChange();
00140                 cancel_current_task();
00141             }
00142         });
00143 }
00144
00145 void
00146     LowLatency::InitializeUIControls()
00147 {
00148     PreviewVideo->FlowDirection = Windows::UI::Xaml::FlowDirection::RightToLeft;
00149
00150     PlaybackVideo->AutoPlay = true;
00151     PlaybackVideo->FlowDirection = Windows::UI::Xaml::FlowDirection::RightToLeft;
00152
00153     RealTimePlaybackVideo->AutoPlay = true;
00154     RealTimePlaybackVideo->FlowDirection = Windows::UI::Xaml::FlowDirection::RightToLeft;
00155
00156     _latencyMode = LatencyModes::highLatency;
00157     LatencyModeToggleSwitch->IsOn = (_latencyMode == LatencyModes::lowLatency);
00158 };
00159
00160 void
00161     LowLatency::OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e)
00162 {
00163     if (_rootPage->NavigatingPrevented())
00164     {
00165         e->Cancel = true;
00166     }
00167
00168     Window::Current->VisibilityChanged -= m_visibilityEventRegistrationToken;
00169 }
00170
00171 void
00172     LowLatency::OnNavigatedFrom(NavigationEventArgs^ e)
00173 {
00174     _sdkSample.Deinitialize();
00175     this->Cleanup();
00176     for (auto iter = _localHostVideo.begin(); iter != _localHostVideo.end(); iter ++)
00177     {
00178         auto video = iter->second;
00179         if (video)
00180         {
00181             video->Source = nullptr;
00182         }
00183     }
00184     Reset();
00185 }
00186
00187 /// <summary>Handler for the camera 'failed' event</summary>
00188 void
00189     LowLatency::OnMediaCaptureFailed(CaptureDevice^ sender, CaptureFailedEventArgs^ errorEventArgs)
00190 {
00191     _sdkSample.FormatError(errorEventArgs, "Capture engine error code: ");
00192 }
00193
00194 void
00195     LowLatency::OnIncomingConnection(Microsoft::Samples::SimpleCommunication::StspMediaSink^ sender, Microsoft::Samples::SimpleCommunication::IncomingConnectionEventArgs^ args)
00196 {
00197     args->Accept();
00198 }
00199
00200 void LowLatency::VisibilityChanged(Object^ sender, Windows::UI::Core::VisibilityChangedEventArgs^ e)
00201 {
00202     if (e->Visible == true)
00203     {
00204         Initialize();
00205     }
00206     else
00207     {
00208         Cleanup();
00209     }
00210 }
00211
00212
00213 /// <summary>Initializes the scenario</summary>
00214 task<void>
00215     LowLatency::Initialize()
00216 {
00217     _ASSERT(_currentState != ScenarioOneStates::initializing);
00218
00219     _currentState = ScenarioOneStates::initializing;
00220     CaptureDevice ^device = ref new CaptureDevice();
00221
00222
00223     return device->InitializeAsync().then([this, device](task<void> asyncInfo)
00224     {
00225         try
00226         {
00227             asyncInfo.get();
00228         }
00229         catch (Platform::Exception^ e)
00230         {
00231             _rootPage->UnlockScenarioChange();
00232             Windows::Foundation::HResult hr;
00233             hr.Value = e->HResult;
00234             _sdkSample.FormatError(hr, "Initialization error: ", "CaptureManager::InitializeAsync");
00235             _currentState = ScenarioOneStates::end;
00236             if (_device)
00237             {
00238                 _device->CleanupAsync().then([this](){});
00239                 _device = nullptr;
00240             }
00241             throw e;
00242         }
00243
00244         _device = device;
00245         if (!_videoSettingsFilter)
00246         {
00247             _videoSettingsFilter = ref new VideoSettingsFilter([this](Windows::Media::MediaProperties::IMediaEncodingProperties^ encodingProp, unsigned int index)
00248             {
00249                 if (encodingProp->Type != L"Video")
00250                 {
00251                     return false;
00252                 }
00253
00254                 auto videoProp = static_cast<Windows::Media::MediaProperties::IVideoEncodingProperties^>(encodingProp);
00255                 if (videoProp->Height != 0 && videoProp->Width != 0)
00256                 {
00257                     return (videoProp->Width == _streamFilteringCriteria.horizontalResolution &&
00258                         videoProp->Subtype == _streamFilteringCriteria.subType);
00259                 }
00260                 return false;
00261             });
00262         }
00263
00264         return device->SelectPreferredCameraStreamSettingAsync(Windows::Media::Capture::MediaStreamType::VideoPreview, _videoSettingsFilter).then([this](task<void> asyncInfo)
00265         {
00266             try
00267             {
00268                 asyncInfo.get();
00269             }
00270             catch (Platform::Exception^ e)
00271             {
00272                 Windows::Foundation::HResult hr;
00273                 hr.Value = e->HResult;
00274                 _sdkSample.FormatError(hr, "Initialization error: ", "CaptureDevice.SelectPreferredCameraStreamSettingAsync(): ");
00275                 _currentState = ScenarioOneStates::end;
00276                 if (_device)
00277                 {
00278                     _device->CleanupAsync().then([this](){});
00279                     _device = nullptr;
00280                 }
00281                 throw e;
00282             }
00283
00284             return task<void>(actionTransitionFunctions[ScenarioOneStates::initializing][Action::previewSetupCompleted]());
00285         });
00286     });
00287 }
00288
00289 task<void>
00290     LowLatency::StartRecordingToCustomSink()
00291 {
00292     //// Use the MP4 preset to an obtain H.264 video encoding profile
00293     auto mediaEncodingProfile = Windows::Media::MediaProperties::MediaEncodingProfile::CreateMp4(Windows::Media::MediaProperties::VideoEncodingQuality::Vga);
00294     mediaEncodingProfile->Audio = nullptr;
00295     mediaEncodingProfile->Container = nullptr;
00296
00297     return _device->StartRecordingAsync(mediaEncodingProfile).then([this](task<void> asyncInfo)
00298     {
00299         try
00300         {
00301             asyncInfo.get();
00302         }
00303         catch (Platform::Exception^ e)
00304         {
00305             auto prefix = _currentState.ToString();
00306             Windows::Foundation::HResult hr;
00307             hr.Value = e->HResult;
00308             _sdkSample.FormatError(hr, ": Local streaming initialization error: ", prefix);
00309             _currentState = ScenarioOneStates::end;
00310             throw e;
00311         }
00312
00313         return task<void>(actionTransitionFunctions[_currentState][Action::recordingStarted]());
00314     });
00315 }
00316
00317 /// <summary>Cleans up.</summary>
00318 task<void>
00319     LowLatency::Cleanup()
00320 {
00321     _previousState = _currentState;
00322
00323     if (!_device)
00324     {
00325         return create_task([]()
00326         {
00327         });
00328     }
00329
00330     Reset();
00331     PreviewVideo->Source = nullptr;
00332
00333     _device->Failed::remove(_mediaCaptureFailedEventRegistrationToken);
00334     _device->Incomingconnectionevent::remove(_incomingConnectionEventRegistrationToken);
00335     return _device->CleanupAsync().then([this]()
00336     {
00337         _device = nullptr;
00338         _currentState = ScenarioOneStates::end;
00339     });
00340 }
00341
00342 void
00343     LowLatency::PreviewButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00344 {
00345     _rootPage->LockScenarioChange(); // Lock
00346
00347     _sdkSample.DisplayStatus("");
00348     task<void>(actionTransitionFunctions[_currentState][Action::previewButtonClicked]()).then([this]()
00349     {
00350         _rootPage->UnlockScenarioChange(); // Unlock
00351     });
00352 }
00353
00354 void
00355     LowLatency::LocalClientButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00356 {
00357     _rootPage->LockScenarioChange(); // Lock
00358
00359     _sdkSample.DisplayStatus("");
00360     PreviewButton->IsEnabled = false;
00361
00362     task<void>(actionTransitionFunctions[ScenarioOneStates::previewing][Action::localClientButtonClicked]()).then([this]()
00363     {
00364         _dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00365         {
00366             UpdateLocalClientWindow();
00367             _rootPage->UnlockScenarioChange(); // Unlock
00368         }
00369         ));
00370     });
00371 }
00372
00373 void
00374     LowLatency::LatencyModeToggled(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00375 {
00376     if (!LatencyModeToggleSwitch->IsEnabled)
00377     {
00378         // This is not a user operation.
00379         return;
00380     }
00381
00382     _rootPage->LockScenarioChange(); // Lock
00383
00384     _sdkSample.DisplayStatus("");
00385     PreviewButton->IsEnabled = false;
00386     LatencyModeToggleSwitch->IsEnabled = false;
00387
00388     task<void>(actionTransitionFunctions[ScenarioOneStates::streaming][Action::latencyModeToggled]()).then([this]()
00389     {
00390         _dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00391         {
00392             UpdateLocalClientWindow();
00393             _rootPage->UnlockScenarioChange(); // Unlock
00394         }));
00395     });
00396 }
00397
00398 void
00399     LowLatency::UpdateLocalClientWindow()
00400 {
00401     PreviewButton->IsEnabled = true;
00402     ClientButton->IsEnabled = false;
00403     LatencyModeToggleSwitch->IsEnabled = true;
00404
00405     WebcamPlaybackPoster->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00406
00407     if (_latencyMode == LatencyModes::highLatency)
00408     {
00409         RealTimePlaybackVideo->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00410         PlaybackVideo->Visibility = Windows::UI::Xaml::Visibility::Visible;
00411     }
00412     else
00413     {
00414         PlaybackVideo->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00415         RealTimePlaybackVideo->Visibility = Windows::UI::Xaml::Visibility::Visible;
00416     }
00417 }
00418
00419 void
00420     SimpleCommunication::LowLatency::Reset()
00421 {
00422     _sdkSample.ClearLastStatus();
00423     PreviewVideo->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00424     RealTimePlaybackVideo->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00425     WebcamPreviewPoster->Visibility = Windows::UI::Xaml::Visibility::Visible;
00426     WebcamPlaybackPoster->Visibility = Windows::UI::Xaml::Visibility::Visible;
00427
00428     PreviewButton->Content = "Start Preview";
00429     ClientButton->IsEnabled = false;
00430     _latencyMode = LatencyModes::highLatency;
00431     LatencyModeToggleSwitch->IsEnabled = false;
00432     LatencyModeToggleSwitch->IsOn = (_latencyMode == LatencyModes::lowLatency);
00433
00434     if (_currentState == ScenarioOneStates::end)
00435     {
00436         PreviewButton->IsEnabled = false;
00437     }
00438 }
00439
00440 //initializing
00441 IAsyncAction^
00442     LowLatency::initializing_previewSetupCompleted()
00443 {
00444     return create_async([this]() -> task<void>
00445     {
00446         _mediaCaptureFailedEventRegistrationToken = _device->Failed::add(ref new CaptureFailedHandler(this, &LowLatency::OnMediaCaptureFailed));
00447         _incomingConnectionEventRegistrationToken = _device->Incomingconnectionevent::add(ref new IncomingconnectioneventHandler(this, &LowLatency::OnIncomingConnection));
00448         _previousState = _currentState;
00449         _currentState = ScenarioOneStates::waiting;
00450
00451         return task<void>(_dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00452         {
00453             PreviewButton->IsEnabled = true;
00454             _sdkSample.DisplayStatus("Done. Tap or click 'Start Preview' button to start webcam preview");
00455         })));
00456     });
00457 }
00458
00459 //waiting
00460 /// <summary>
00461 /// Logic when preview button is clicked and the scenario is in "waiting" state.
00462 /// </summary>
00463 IAsyncAction^
00464     LowLatency::waiting_previewButtonClicked()
00465 {
00466     return create_async([this]() -> task<void>
00467     {
00468         return task<void>(_dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00469         {
00470             if (_previousState == ScenarioOneStates::initializing)
00471             {
00472                 PreviewVideo->Source = _device->MediaCapture.Get();
00473             }
00474         }
00475         ))).then([this]()
00476         {
00477             return task<void>(_device->MediaCapture.Get()->StartPreviewAsync()).then([this]()
00478             {
00479                 _previousState = _currentState;
00480                 _currentState = ScenarioOneStates::previewing;
00481                 return _dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00482                 {
00483                     WebcamPreviewPoster->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00484                     PreviewVideo->Visibility = Windows::UI::Xaml::Visibility::Visible;
00485                     PreviewButton->Content = "Stop Preview";
00486                     ClientButton->IsEnabled = true;
00487                 }));
00488             });
00489         });
00490     });
00491 }
00492
00493 //previewing
00494 /// <summary>
00495 /// The logic when the "stop" preview button is clicked while the scenario is in "previewing" state.
00496 /// </summary>
00497 IAsyncAction^
00498     LowLatency::previewing_previewButtonClicked()
00499 {
00500     return create_async([this]() -> task<void>
00501     {
00502         return task<void>(_device->MediaCapture->StopPreviewAsync()).then([this]()
00503         {
00504             if (ScenarioOneStates::previewing == _currentState)
00505             {
00506                 _previousState = _currentState;
00507                 _currentState = ScenarioOneStates::waiting;
00508             }
00509             return _dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00510             {
00511                 Reset();
00512             }));
00513         });
00514     });
00515 }
00516
00517 IAsyncAction^
00518     LowLatency::previewing_localClientButtonClicked()
00519 {
00520     return create_async([this]() -> task<void>
00521     {
00522         return StartRecordingToCustomSink();
00523     });
00524 }
00525
00526 IAsyncAction^
00527     LowLatency::previewing_recordingStarted()
00528 {
00529     return create_async([this]() -> task<void>
00530     {
00531         return task<void>(_dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00532         {
00533             _localHostVideo[_latencyMode]->Source = ref new Uri("stsp://localhost");
00534             _previousState = _currentState;
00535             _currentState = ScenarioOneStates::streaming;
00536         })));
00537     });
00538 }
00539
00540 //streaming
00541 /// <summary>
00542 /// The logic when the "stop" preview button is clicked while the scenario is in "streaming" state.
00543 /// </summary>
00544 IAsyncAction^
00545     LowLatency::streaming_previewButtonClicked()
00546 {
00547     return create_async([this]() -> task<void>
00548     {
00549         return task<void>(_dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00550         {
00551             //// stop localhost client video
00552             auto currLocalHostVideo = _localHostVideo[_latencyMode];
00553             currLocalHostVideo->Pause();
00554         }
00555         ))).then([this]()
00556         {
00557             LatencyModes latencyMode = _latencyMode;
00558
00559             //// stop streaming to network and close network sink
00560             return _device->StopRecordingAsync().then([this, latencyMode](task<void> asyncInfo)
00561             {
00562                 try
00563                 {
00564                     asyncInfo.get();
00565                 }
00566                 catch (Platform::Exception^ e)
00567                 {
00568                     Windows::Foundation::HResult hr;
00569                     hr.Value = e->HResult;
00570                     _sdkSample.FormatError(hr, "StopRecordAsync error: ", "");
00571                     _currentState = ScenarioOneStates::end;
00572                     throw e;
00573                 }
00574
00575                 return task<void>(_dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this, asyncInfo, latencyMode]()
00576                 {
00577                     _localHostVideo[latencyMode]->Source = nullptr;
00578                     _latencyMode = LatencyModes::highLatency;
00579                 }
00580                 ))).then([this]()
00581                 {
00582                     return task<void>(actionTransitionFunctions[ScenarioOneStates::previewing][Action::previewButtonClicked]()).then([this]()
00583                     {
00584                         _previousState = _currentState;
00585                         _currentState = ScenarioOneStates::waiting;
00586                     });
00587                 });
00588             });
00589         });
00590     });
00591 }
00592
00593 IAsyncAction^
00594     LowLatency::streaming_latencyModeToggled()
00595 {
00596     return create_async([this]() -> task<void>
00597     {
00598         if (!_device)
00599         {
00600             throw ref new Platform::Exception(E_NOINTERFACE);
00601         }
00602
00603         return _device->StopRecordingAsync().then([this](task<void> asyncInfo)
00604         {
00605             try
00606             {
00607                 asyncInfo.get();
00608             }
00609             catch (Platform::Exception^ e)
00610             {
00611                 Windows::Foundation::HResult hr;
00612                 hr.Value = e->HResult;
00613                 _sdkSample.FormatError(hr, "Latency toggle error: ", "StopRecordingAsync: ");
00614                 _currentState = ScenarioOneStates::end;
00615                 throw e;
00616             }
00617
00618             return task<void>(_dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00619             {
00620                 _localHostVideo[_latencyMode]->Source = nullptr;
00621             }
00622             )));
00623         }
00624         ).then([this]()
00625         {
00626             _latencyMode = (_latencyMode == LatencyModes::highLatency) ?
00627                 LatencyModes::lowLatency : LatencyModes::highLatency;
00628
00629             return StartRecordingToCustomSink();
00630         });
00631     });
00632 }
00633
00634 /// <summary>
00635 /// Logic when the scenario is in "streaming" state and "recordingStarted"
00636 /// event is triggered after toggling latency mode.
00637 /// </summary>
00638 IAsyncAction^
00639     LowLatency::streaming_recordingStarted()
00640 {
00641     return create_async([this]() -> task<void>
00642     {
00643         return task<void>(_dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this]()
00644         {
00645             _localHostVideo[_latencyMode]->Source = ref new Uri("stsp://localhost");
00646             _localHostVideo[_latencyMode]->Play();
00647         })));
00648     });
00649 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/pch.cpp Source File

  • Playlist

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/common/suspensionmanager.h Source File

  • Playlist
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/common/suspensionmanager.cpp Source File

  • Thread pool
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/common/suspensionmanager.h Source File

  • Scaling according to DPI
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/pch.h Source File

  • Certificate enrollment

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <Windows.h>
00019 #include <wrl.h>
00020 #include <wrl\implements.h>
00021 #include <Shcore.h>
00022 #include <MsXml6.h>
00023 #include <collection.h>
00024 #include <ppltasks.h>
00025 #include <sstream>
00026
00027 #define CHKHR(stmt)  do { hr = (stmt); if (FAILED(hr)) goto Exit; } while(0)
00028
00029 #include "Common\LayoutAwarePage.h"
00030 #include "Common\SuspensionManager.h"
00031 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/App.xaml.h Source File

  • USSD message management

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/pch.cpp Source File

  • File access

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content target app/C++/App.xaml.cpp Source File

  • Sharing content target app

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.cpp
00010 // Implementation of the App.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "App.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::UI::Xaml::Controls;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::ApplicationModel;
00021 using namespace Windows::ApplicationModel::Activation;
00022 using namespace CppSamplesUtils;
00023 using namespace ShareTarget;
00024 using namespace Windows::UI::Xaml::Interop;
00025
00026 App::App()
00027 {
00028     InitializeComponent();
00029 }
00030
00031 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00032 {
00033     auto rootFrame = ref new Frame();
00034     TypeName pageType = { "ShareTarget.DefaultPage", TypeKind::Custom };
00035     rootFrame->Navigate(pageType);
00036     Window::Current->Content = rootFrame;
00037     Window::Current->Activate();
00038 }
00039
00040 void App::OnShareTargetActivated(ShareTargetActivatedEventArgs^ args)
00041 {
00042     auto rootFrame = ref new Frame();
00043     TypeName pageType = { "ShareTarget.MainPage", TypeKind::Custom };
00044     rootFrame->Navigate(pageType, args->ShareOperation);
00045     Window::Current->Content = rootFrame;
00046     Window::Current->Activate();
00047 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/suspensionmanager.cpp Source File

  • File picker
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/SampleOverlay.cpp Source File

  • Direct2D composite effect modes

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaStreamSource::AudioSource Member List

This is the complete list of members for MediaStreamSource::AudioSource, including all inherited members.
__pad0__ | Element |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Page | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
AudioSource() | MediaStreamSource::AudioSource | [inline]
BindResource(_In_ Element^rootElement) | Element | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
DefaultViewModel | SDKTemplate::Common::LayoutAwarePage | [protected]
DefaultViewModelProperty | SDKTemplate::Common::LayoutAwarePage | [static]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
OnNavigatedTo(NavigationEventArgs e) | MediaStreamSource::AudioSource | [inline, protected]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
rootPage | MediaStreamSource::AudioSource | [private]
Start_Click(object sender, RoutedEventArgs e) | MediaStreamSource::AudioSource | [inline, private]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
Stop_Click(object sender, RoutedEventArgs e) | MediaStreamSource::AudioSource | [inline, private]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario2.xaml.cpp Source File

  • XAML WebView control

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::WebViewControl;
00020
00021 using namespace Platform;
00022 using namespace Windows::Data::Html;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 Scenario2::Scenario2()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 // Invoked when this page is about to be displayed in a Frame.
00033 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00034 {
00035     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00036     // as NotifyUser()
00037     rootPage = MainPage::Current;
00038
00039   // Let's create a very simple HTML fragment
00040   String^ htmlFragment = "<!DOCTYPE html PUBLIC '-//W3C//DTD XHTML 1.0 Transitional//EN' 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd'>"
00041     + "\n\t<html>"
00042     + "\n\t  <head>"
00043     + "\n\t    <title>Map with valid credentials</title>"
00044     + "\n\t    <meta http-equiv='Content-Type' content='text/html; charset=utf-8'/>"
00045     + "\n\t    <script type='text/javascript' src='http://ecn.dev.virtualearth.net/mapcontrol/mapcontrol.ashx?v=7.0'></script>"
00046         + "\n\t    <script type='text/javascript'>"
00047     + "\n\t    var map = null;"
00048     + "\n\t    function getMap()"
00049     + "\n\t    {"
00050     + "\n\t     map = new Microsoft.Maps.Map(document.getElementById('myMap'), {credentials: 'Your Bing Maps Key'});"
00051     + "\n\t    }"
00052     + "\n\t   </script>"
00053     + "\n\t  </head>"
00054     + "\n\t  <body onload='getMap();'>"
00055         + "\n\t    <div id='myMap' style='position:relative; width:400px; height:400px;'></div>"
00056         + "\n\t  </body>"
00057     + "\n\t<html>;";
00058
00059   // Load HTML fragment into the HTML text box so it will be visible
00060   HTML2->Text = htmlFragment;
00061
00062 }
00063
00064
00065 // Click handler for the 'Load' button.
00066 void SDKSample::WebViewControl::Scenario2::Load_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00067 {
00068   WebView2->NavigateToString(HTML2->Text);
00069 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RandomPhotoSelector.cpp Source File

  • Hilo C++
  • Hilo

RandomPhotoSelector.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "RandomPhotoSelector.h"
00009 #include <numeric>
00010 #include <time.h>
00011
00012 using namespace concurrency;
00013 using namespace std;
00014 using namespace Windows::Storage;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Hilo;
00017
00018 // See http://go.microsoft.com/fwlink/?LinkId=267275 for info about Hilo's implementation of tiles.
00019
00020 task<IVector<StorageFile^>^> RandomPhotoSelector::SelectFilesAsync(IVectorView<StorageFile^>^ photos, unsigned int count )
00021 {
00022     return create_task(
00023         [photos, count]() -> IVector<StorageFile^>^
00024     {
00025         auto selectedImages = RandomPhotoSelector::CreateRandomizedVector(photos->Size, count);
00026
00027         auto selectedFiles = ref new Platform::Collections::Vector<Windows::Storage::StorageFile^>();
00028
00029         for (unsigned int imageCounter = 0; imageCounter < selectedImages.size(); imageCounter++)
00030         {
00031             auto imageFile = photos->GetAt(selectedImages[imageCounter]);
00032             selectedFiles->Append(imageFile);
00033         }
00034
00035         return selectedFiles;
00036     });
00037 }
00038
00039 vector<unsigned int> RandomPhotoSelector::CreateRandomizedVector(unsigned int vectorSize, unsigned int sampleSize)
00040 {
00041     // Seed the rand() function, which is used by random_shuffle.
00042     srand(static_cast<unsigned int>(time(nullptr)));
00043
00044     // The resulting set of random numbers.
00045     vector<unsigned int> result(vectorSize);
00046
00047     // Fill with [0..vectorSize).
00048     iota(begin(result), end(result), 0);
00049
00050     // Shuffle the elements.
00051     random_shuffle(begin(result), end(result));
00052
00053     // Trim the list to the first sampleSize elements if the collection size is greater than the sample size.
00054     if (vectorSize > sampleSize)
00055     {
00056         result.resize(sampleSize);
00057     }
00058
00059     return result;
00060 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/pch.h Source File

  • Reading and writing data

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/Constants.cpp Source File

  • XAML high contrast style

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "High contrast via XAML", "SDKSample.HighContrast.Scenario1" },
00022     { "High contrast using system colors via XAML", "SDKSample.HighContrast.Scenario2" },
00023     { "High contrast using system colors via code", "SDKSample.HighContrast.Scenario3" }
00024 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/VertexShader/BasicTimer.h Source File

  • Direct2D custom image effects
  • VertexShader

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/DirectXApp.h Source File

  • Direct3D resource loading

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "ResourceLoading.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032     void OnVisibilityChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(
00038         _In_ Platform::Object^ sender
00039         );
00040
00041     void OnActivated(
00042         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00043         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00044         );
00045
00046     void OnSuspending(
00047         _In_ Platform::Object^ sender,
00048         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00049         );
00050
00051     void OnResuming(
00052         _In_ Platform::Object^ sender,
00053         _In_ Platform::Object^ args
00054         );
00055
00056     void OnWindowClosed(
00057         _In_ Windows::UI::Core::CoreWindow^ sender,
00058         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00059         );
00060
00061     ResourceLoading^ m_renderer;
00062     bool m_windowClosed;
00063     bool m_windowVisible;
00064 };
00065
00066 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00067 {
00068 public:
00069     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00070 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/SaveAsImageFileSample.cpp Source File

  • Direct2D save to image file

SaveAsImageFileSample.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SaveAsImageFileSample.h"
00010
00011 using namespace concurrency;
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::ApplicationModel;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::ApplicationModel::Core;
00016 using namespace Windows::Foundation;
00017 using namespace Windows::Graphics::Display;
00018 using namespace Windows::Storage;
00019 using namespace Windows::System;
00020 using namespace Windows::UI::Core;
00021 using namespace Windows::UI::ViewManagement;
00022
00023 SaveAsImageFile::SaveAsImageFile() :
00024     m_screenSavingState(ScreenSavingState::NotSaved),
00025     m_isSnapped(false)
00026 {
00027 }
00028
00029 void SaveAsImageFile::CreateDeviceIndependentResources()
00030 {
00031     DirectXBase::CreateDeviceIndependentResources();
00032
00033     // Create a DirectWrite text format object.
00034     DX::ThrowIfFailed(
00035         m_dwriteFactory->CreateTextFormat(
00036             L"Segoe UI",                // font family name
00037             nullptr,                    // system font collection
00038             DWRITE_FONT_WEIGHT_LIGHT,
00039             DWRITE_FONT_STYLE_NORMAL,
00040             DWRITE_FONT_STRETCH_NORMAL,
00041             64,                         // font size
00042             L"en-US",                   // locale
00043             &m_textFormat
00044             )
00045         );
00046
00047     // Center the text horizontally.
00048     DX::ThrowIfFailed(
00049         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00050         );
00051
00052     // Center the text vertically.
00053     DX::ThrowIfFailed(
00054         m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00055         );
00056
00057     // Create a DirectWrite text format object for the snapped view message.
00058     DX::ThrowIfFailed(
00059         m_dwriteFactory->CreateTextFormat(
00060             L"Segoe UI",                // font family name
00061             nullptr,                    // system font collection
00062             DWRITE_FONT_WEIGHT_LIGHT,
00063             DWRITE_FONT_STYLE_NORMAL,
00064             DWRITE_FONT_STRETCH_NORMAL,
00065             20,                         // font size
00066             L"en-US",                   // locale
00067             &m_snappedViewFormat
00068             )
00069         );
00070
00071     // Center the text horizontally.
00072     DX::ThrowIfFailed(
00073         m_snappedViewFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00074         );
00075
00076     // Center the text vertically.
00077     DX::ThrowIfFailed(
00078         m_snappedViewFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00079         );
00080 }
00081
00082 void SaveAsImageFile::CreateDeviceResources()
00083 {
00084     DirectXBase::CreateDeviceResources();
00085
00086     m_sampleOverlay = ref new SampleOverlay();
00087
00088     m_sampleOverlay->Initialize(
00089         m_d2dDevice.Get(),
00090         m_d2dContext.Get(),
00091         m_wicFactory.Get(),
00092         m_dwriteFactory.Get(),
00093         "Direct2D save to image file sample"
00094         );
00095
00096     DX::ThrowIfFailed(
00097         m_d2dContext->CreateSolidColorBrush(
00098             D2D1::ColorF(D2D1::ColorF::Black),
00099             &m_blackBrush
00100             )
00101         );
00102 }
00103
00104 void SaveAsImageFile::Render()
00105 {
00106     m_d2dContext->BeginDraw();
00107
00108     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00109     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00110
00111     Platform::String^ string;
00112     IDWriteTextFormat *format;
00113
00114     if (m_isSnapped)
00115     {
00116         string = "This sample does not support snapped view.";
00117         format = m_snappedViewFormat.Get();
00118     }
00119     else if (m_screenSavingState == ScreenSavingState::NotSaved || m_screenSavingState == ScreenSavingState::Saving)
00120     {
00121         string = "Tap to save screen.";
00122         format = m_textFormat.Get();
00123     }
00124     else
00125     {
00126         string = Platform::String::Concat("Screen saved to ", m_imageFileName);
00127         format = m_textFormat.Get();
00128     }
00129
00130     D2D1_SIZE_F size = m_d2dContext->GetSize();
00131
00132     m_d2dContext->DrawText(
00133         string->Data(),
00134         string->Length(),
00135         format,
00136         D2D1::RectF(0, 0, size.width, size.height),
00137         m_blackBrush.Get()
00138         );
00139
00140     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00141     // is lost. It will be handled during the next call to Present.
00142     HRESULT hr = m_d2dContext->EndDraw();
00143     if (hr != D2DERR_RECREATE_TARGET)
00144     {
00145         DX::ThrowIfFailed(hr);
00146     }
00147
00148     m_sampleOverlay->Render();
00149 }
00150
00151 // Save render target bitmap to an image file, using file picker for users to input the image file name.
00152 void SaveAsImageFile::SaveBitmapToFile()
00153 {
00154     if (m_isSnapped || m_screenSavingState != ScreenSavingState::NotSaved || m_d2dTargetBitmap == nullptr)
00155     {
00156         return;
00157     }
00158
00159     // Set state to Saving to block another copy of this function being called before saving completes.
00160     m_screenSavingState = ScreenSavingState::Saving;
00161     Render();
00162     Present();
00163
00164     // Prepare a file picker for customers to input image file name.
00165     Pickers::FileSavePicker^ savePicker = ref new Pickers::FileSavePicker();
00166     auto pngExtensions = ref new Platform::Collections::Vector<Platform::String^>();
00167     pngExtensions->Append(".png");
00168     savePicker->FileTypeChoices->Insert("PNG file", pngExtensions);
00169     auto jpgExtensions = ref new Platform::Collections::Vector<Platform::String^>();
00170     jpgExtensions->Append(".jpg");
00171     savePicker->FileTypeChoices->Insert("JPEG file", jpgExtensions);
00172     auto bmpExtensions = ref new Platform::Collections::Vector<Platform::String^>();
00173     bmpExtensions->Append(".bmp");
00174     savePicker->FileTypeChoices->Insert("BMP file", bmpExtensions);
00175     savePicker->DefaultFileExtension = ".png";
00176     savePicker->SuggestedFileName = "SaveScreen";
00177     savePicker->SuggestedStartLocation = Pickers::PickerLocationId::PicturesLibrary;
00178
00179     std::shared_ptr<GUID> wicFormat = std::make_shared<GUID>(GUID_ContainerFormatPng);
00180
00181     create_task(savePicker->PickSaveFileAsync()).then([=](StorageFile^ file)
00182     {
00183         if (file == nullptr)
00184         {
00185             // If user clicks "Cancel", reset the saving state, then cancel the current task.
00186             m_screenSavingState = ScreenSavingState::NotSaved;
00187             cancel_current_task();
00188         }
00189
00190         m_imageFileName = file->Name;
00191         if (file->FileType == ".bmp")
00192         {
00193             *wicFormat = GUID_ContainerFormatBmp;
00194         }
00195         else if (file->FileType == ".jpg")
00196         {
00197             *wicFormat = GUID_ContainerFormatJpeg;
00198         }
00199         return file->OpenAsync(FileAccessMode::ReadWrite);
00200
00201     }).then([=](Streams::IRandomAccessStream^ randomAccessStream)
00202     {
00203         // Convert the RandomAccessStream to an IStream.
00204         ComPtr<IStream> stream;
00205         DX::ThrowIfFailed(
00206             CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(&stream))
00207             );
00208
00209         // Render the screen contents to an off-screen bitmap and then save that bitmap to a file.
00210         ComPtr<ID2D1Bitmap1> targetBitmap;
00211         D2D1_SIZE_U pixelSize = m_d2dContext->GetPixelSize();
00212
00213         DX::ThrowIfFailed(
00214             m_d2dContext->CreateBitmap(
00215                 pixelSize,
00216                 nullptr,
00217                 pixelSize.width * 4,    // pitch = width * size of pixel (4 bytes for B8G8R8A8)
00218                 D2D1::BitmapProperties1(
00219                     D2D1_BITMAP_OPTIONS_TARGET,
00220                     D2D1::PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED)
00221                     ),
00222                 &targetBitmap
00223                 )
00224             );
00225
00226         m_d2dContext->SetTarget(targetBitmap.Get());
00227         Render();
00228         m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00229
00230         SaveBitmapToStream(targetBitmap, m_wicFactory, m_d2dContext, *wicFormat, stream.Get());
00231
00232         m_screenSavingState = ScreenSavingState::Saved;
00233         Render();
00234         Present();
00235     });
00236 }
00237
00238 // Save render target bitmap to a stream using WIC.
00239 void SaveAsImageFile::SaveBitmapToStream(
00240     _In_ ComPtr<ID2D1Bitmap1> d2dBitmap,
00241     _In_ ComPtr<IWICImagingFactory2> wicFactory2,
00242     _In_ ComPtr<ID2D1DeviceContext> d2dContext,
00243     _In_ REFGUID wicFormat,
00244     _In_ IStream* stream
00245     )
00246 {
00247     // Create and initialize WIC Bitmap Encoder.
00248     ComPtr<IWICBitmapEncoder> wicBitmapEncoder;
00249     DX::ThrowIfFailed(
00250         wicFactory2->CreateEncoder(
00251             wicFormat,
00252             nullptr,    // No preferred codec vendor.
00253             &wicBitmapEncoder
00254             )
00255         );
00256
00257     DX::ThrowIfFailed(
00258         wicBitmapEncoder->Initialize(
00259             stream,
00260             WICBitmapEncoderNoCache
00261             )
00262         );
00263
00264     // Create and initialize WIC Frame Encoder.
00265     ComPtr<IWICBitmapFrameEncode> wicFrameEncode;
00266     DX::ThrowIfFailed(
00267         wicBitmapEncoder->CreateNewFrame(
00268             &wicFrameEncode,
00269             nullptr     // No encoder options.
00270             )
00271         );
00272
00273     DX::ThrowIfFailed(
00274         wicFrameEncode->Initialize(nullptr)
00275         );
00276
00277     // Retrieve D2D Device.
00278     ComPtr<ID2D1Device> d2dDevice;
00279     d2dContext->GetDevice(&d2dDevice);
00280
00281     // Create IWICImageEncoder.
00282     ComPtr<IWICImageEncoder> imageEncoder;
00283     DX::ThrowIfFailed(
00284         wicFactory2->CreateImageEncoder(
00285             d2dDevice.Get(),
00286             &imageEncoder
00287             )
00288         );
00289
00290     DX::ThrowIfFailed(
00291         imageEncoder->WriteFrame(
00292             d2dBitmap.Get(),
00293             wicFrameEncode.Get(),
00294             nullptr     // Use default WICImageParameter options.
00295             )
00296         );
00297
00298     DX::ThrowIfFailed(
00299         wicFrameEncode->Commit()
00300         );
00301
00302     DX::ThrowIfFailed(
00303         wicBitmapEncoder->Commit()
00304         );
00305
00306     // Flush all memory buffers to the next-level storage object.
00307     DX::ThrowIfFailed(
00308         stream->Commit(STGC_DEFAULT)
00309         );
00310 }
00311
00312 void SaveAsImageFile::Initialize(
00313     _In_ CoreApplicationView^ applicationView
00314     )
00315 {
00316     applicationView->Activated +=
00317         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &SaveAsImageFile::OnActivated);
00318 }
00319
00320 void SaveAsImageFile::SetWindow(
00321     _In_ CoreWindow^ window
00322     )
00323 {
00324     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00325
00326     window->PointerPressed +=
00327         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &SaveAsImageFile::OnPointerPressed);
00328
00329     window->SizeChanged +=
00330         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &SaveAsImageFile::OnWindowSizeChanged);
00331
00332     DisplayProperties::LogicalDpiChanged +=
00333         ref new DisplayPropertiesEventHandler(this, &SaveAsImageFile::OnLogicalDpiChanged);
00334
00335     DisplayProperties::DisplayContentsInvalidated +=
00336         ref new DisplayPropertiesEventHandler(this, &SaveAsImageFile::OnDisplayContentsInvalidated);
00337
00338     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00339 }
00340
00341 void SaveAsImageFile::Load(
00342     _In_ Platform::String^ entryPoint
00343     )
00344 {
00345 }
00346
00347 void SaveAsImageFile::Run()
00348 {
00349     Render();
00350     Present();
00351
00352     m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
00353 }
00354
00355 void SaveAsImageFile::Uninitialize()
00356 {
00357 }
00358
00359 void SaveAsImageFile::OnWindowSizeChanged(
00360     _In_ CoreWindow^ sender,
00361     _In_ WindowSizeChangedEventArgs^ args
00362     )
00363 {
00364     // If the view state is snapped to one side of the screen, diasble saving.
00365     m_isSnapped = (ApplicationView::Value == ApplicationViewState::Snapped);
00366
00367     UpdateForWindowSizeChange();
00368     m_sampleOverlay->UpdateForWindowSizeChange();
00369     Render();
00370     Present();
00371 }
00372
00373 void SaveAsImageFile::OnLogicalDpiChanged(
00374     _In_ Platform::Object^ sender
00375     )
00376 {
00377     SetDpi(DisplayProperties::LogicalDpi);
00378     Render();
00379     Present();
00380 }
00381
00382 void SaveAsImageFile::OnDisplayContentsInvalidated(
00383     _In_ Platform::Object^ sender
00384     )
00385 {
00386     // Ensure the D3D Device is available for rendering.
00387     ValidateDevice();
00388
00389     Render();
00390     Present();
00391 }
00392
00393 void SaveAsImageFile::OnActivated(
00394     _In_ CoreApplicationView^ applicationView,
00395     _In_ IActivatedEventArgs^ args
00396     )
00397 {
00398     m_window->Activate();
00399 }
00400
00401 void SaveAsImageFile::OnPointerPressed(
00402     _In_ CoreWindow^ sender,
00403     _In_ PointerEventArgs^ args
00404     )
00405 {
00406     SaveBitmapToFile();
00407 }
00408
00409 IFrameworkView^ DirectXAppSource::CreateView()
00410 {
00411     return ref new SaveAsImageFile();
00412 }
00413
00414 [Platform::MTAThread]
00415 int main(Platform::Array<Platform::String^>^)
00416 {
00417     auto directXAppSource = ref new DirectXAppSource();
00418     CoreApplication::Run(directXAppSource);
00419     return 0;
00420 }
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/App.xaml.h Source File

  • Syndication

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DirectXApp.h Source File

  • DXGI offer and reclaim resources

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "OfferReclaimAPI.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032     void OnVisibilityChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(
00038         _In_ Platform::Object^ sender
00039         );
00040
00041     void OnActivated(
00042         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00043         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00044         );
00045
00046     void OnSuspending(
00047         _In_ Platform::Object^ sender,
00048         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00049         );
00050
00051     void OnResuming(
00052         _In_ Platform::Object^ sender,
00053         _In_ Platform::Object^ args
00054         );
00055
00056     void OnWindowClosed(
00057         _In_ Windows::UI::Core::CoreWindow^ sender,
00058         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00059         );
00060
00061     OfferReclaimAPI^ m_renderer;
00062     bool m_windowClosed;
00063     bool m_windowVisible;
00064 };
00065
00066 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00067 {
00068 public:
00069     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00070 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/DelayTimerScenario.xaml.cpp Source File

  • Thread pool

DelayTimerScenario.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DelayTimerScenario.xaml.cpp
00013 // Implementation of the DelayTimerScenario class
00014 //
00015
00016 #include "pch.h"
00017 #include "DelayTimerScenario.xaml.h"
00018
00019 using namespace SDKSample::ThreadPool;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 DelayTimerScenario::DelayTimerScenario()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void DelayTimerScenario::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040     SDKSample::ThreadPool::DelayScenario = this;
00041   DelayMs->SelectedIndex = SDKSample::ThreadPool::DelayTimerSelectedIndex;
00042     UpdateUI(SDKSample::ThreadPool::DelayTimerStatus);
00043 }
00044
00045 void DelayTimerScenario::OnNavigatedFrom(NavigationEventArgs^ e)
00046 {
00047   SDKSample::ThreadPool::DelayTimerSelectedIndex = DelayMs->SelectedIndex;
00048 }
00049
00050 void SDKSample::ThreadPool::DelayTimerScenario::CreateDelayTimer(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00051 {
00052     auto timerDelegate = [this](Windows::System::Threading::ThreadPoolTimer^ timer)
00053     {
00054         auto uiDelegate = [this]()
00055         {
00056             SDKSample::ThreadPool::DelayScenario->UpdateUI(SDKSample::ThreadPool::Status::Completed);
00057         };
00058
00059         Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal,
00060                              ref new Windows::UI::Core::DispatchedHandler(uiDelegate));
00061     };
00062
00063     auto time = safe_cast<Platform::String^>(DelayMs->SelectionBoxItem);
00064     DelayTimerMilliseconds = _wtol(time->Data());
00065
00066     Windows::Foundation::TimeSpan delay = SDKSample::ThreadPool::ThreadPoolSample::MillisecondsToTimeSpan(DelayTimerMilliseconds);
00067     UpdateUI(SDKSample::ThreadPool::Status::Started);
00068
00069     SDKSample::ThreadPool::DelayTimer = Windows::System::Threading::ThreadPoolTimer::CreateTimer(ref new Windows::System::Threading::TimerElapsedHandler(timerDelegate), delay);
00070 }
00071
00072 void SDKSample::ThreadPool::DelayTimerScenario::CancelDelayTimer(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00073 {
00074     if (SDKSample::ThreadPool::DelayTimer != nullptr)
00075     {
00076         SDKSample::ThreadPool::DelayTimer->Cancel();
00077         SDKSample::ThreadPool::DelayTimerScenario::UpdateUI(SDKSample::ThreadPool::Status::Canceled);
00078     }
00079 }
00080
00081 void SDKSample::ThreadPool::DelayTimerScenario::UpdateUI(SDKSample::ThreadPool::Status status)
00082 {
00083     SDKSample::ThreadPool::DelayTimerStatus = status;
00084     DelayTimerInfo->Text = "Timer delay = " + SDKSample::ThreadPool::DelayTimerMilliseconds.ToString() + " ms.";
00085     DelayTimerStatus->Text = ThreadPoolSample::GetStatusString(status);
00086
00087     auto createButtonEnabled = (status == SDKSample::ThreadPool::Status::Started);
00088     CreateDelayTimerButton->IsEnabled = !createButtonEnabled;
00089     CancelDelayTimerButton->IsEnabled = createButtonEnabled;
00090 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Page1.xaml.cpp Source File

  • XAML personality animations

Page1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // Page1.xaml.cpp
00003 // Implementation of the Page1 class
00004 //
00005
00006 #include "pch.h"
00007 #include "Page1.xaml.h"
00008
00009 using namespace SDKSample::PersonalityAnimations;
00010
00011 using namespace Platform;
00012 using namespace Windows::Foundation;
00013 using namespace Windows::Foundation::Collections;
00014 using namespace Windows::UI::Xaml;
00015 using namespace Windows::UI::Xaml::Controls;
00016 using namespace Windows::UI::Xaml::Controls::Primitives;
00017 using namespace Windows::UI::Xaml::Data;
00018 using namespace Windows::UI::Xaml::Input;
00019 using namespace Windows::UI::Xaml::Media;
00020 using namespace Windows::UI::Xaml::Navigation;
00021
00022 // The Blank Page item template is documented at http://go.microsoft.com/fwlink/?LinkId=234238
00023
00024 Page1::Page1(): messageData(nullptr)
00025 {
00026   InitializeComponent();
00027
00028   messageData = ref new MessageData;
00029   GridView1->ItemsSource = messageData->Items;
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void Page1::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039   VisualStateManager::GoToState(this, "NavigatedTo", true);
00040   //(void) e; // Unused parameter
00041 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

D2DEffectsHelloWorld Member List

This is the complete list of members for D2DEffectsHelloWorld, including all inherited members.
__pad0__ | D2DEffectsHelloWorld |
CreateDeviceIndependentResources() override | D2DEffectsHelloWorld | [virtual]
CreateDeviceResources() override | D2DEffectsHelloWorld | [virtual]
CreateEffectGraph() | D2DEffectsHelloWorld | [private]
CreateWindowSizeDependentResources() override | D2DEffectsHelloWorld | [virtual]
DecodeImage() | D2DEffectsHelloWorld | [private]
Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView) | D2DEffectsHelloWorld | [virtual]
Load(_In_ Platform::String^entryPoint) | D2DEffectsHelloWorld | [virtual]
m_bitmapSourceEffect | D2DEffectsHelloWorld | [private]
m_gaussianBlurEffect | D2DEffectsHelloWorld | [private]
m_sampleOverlay | D2DEffectsHelloWorld | [private]
m_wicDecoder | D2DEffectsHelloWorld | [private]
m_wicFormatConverter | D2DEffectsHelloWorld | [private]
m_wicFrameDecode | D2DEffectsHelloWorld | [private]
OnActivated(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args) | D2DEffectsHelloWorld | [private]
OnDisplayContentsInvalidated(_In_ Platform::Object^sender) | D2DEffectsHelloWorld | [private]
OnLogicalDpiChanged(_In_ Platform::Object^sender) | D2DEffectsHelloWorld | [private]
OnWindowSizeChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args) | D2DEffectsHelloWorld | [private]
Render() override | D2DEffectsHelloWorld | [virtual]
Run() | D2DEffectsHelloWorld | [virtual]
SetWindow(_In_ Windows::UI::Core::CoreWindow^window) | D2DEffectsHelloWorld | [virtual]
Uninitialize() | D2DEffectsHelloWorld | [virtual]
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/Constants.h Source File

  • App settings

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Application Settings");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::ScrollViewerCPP::sealed Member List

This is the complete list of members for SDKSample::ScrollViewerCPP::sealed, including all inherited members.
CheckBox_Checked_HorizontalRailed(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
CheckBox_Checked_VerticalRailed(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
CheckBox_Unchecked_HorizontalRailed(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
CheckBox_Unchecked_VerticalRailed(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
ComboBox_SelectionChanged_1(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
hsbvCombo_SelectionChanged_1(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
hsmCombo_SelectionChanged_1(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ScrollViewerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ScrollViewerCPP::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ScrollViewerCPP::sealed | [protected, virtual]
rootPage | SDKSample::ScrollViewerCPP::sealed | [private]
Scenario1() | SDKSample::ScrollViewerCPP::sealed |
Scenario1Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
Scenario1Reset() | SDKSample::ScrollViewerCPP::sealed | [private]
Scenario2() | SDKSample::ScrollViewerCPP::sealed |
Scenario2Reset(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
Scenario2Reset() | SDKSample::ScrollViewerCPP::sealed | [private]
Scenario3() | SDKSample::ScrollViewerCPP::sealed |
vsbvCombo_SelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
vsmCombo_SelectionChanged_1(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::ScrollViewerCPP::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams Member List

This is the complete list of members for TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams, including all inherited members.
Alpha | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Beta | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
BingMapsKey | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Edges | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
HttpTime | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Iterations | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Nodes | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Optimize | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Parallel | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
RequestsPending | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Rho | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
SimulationTime | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
TotalTime | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
TravelMode | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
UnresolvedLocations | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Waypoints | TripOptimizerComponent::Details::TripOptimizerImpl::OptimizeTripParams
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/common/LayoutAwarePage.cpp Source File

  • OrientationSensor
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario2.xaml.h Source File

  • XAML animation library

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Animation
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         bool isScenario2StoryboardRunning;
00040         void Scenario2ToggleStoryboard_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         void ToggleScenario2(bool startScenario);
00042
00043         };
00044     }
00045 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/common/suspensionmanager.h Source File

  • File picker contracts
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/pch.cpp Source File

  • Web authentication broker

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/MainPage.xaml.h Source File

  • Inclinometer sensor

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/ScenarioInput2.xaml.cs Source File

  • Media extensions
  • C#,C++

ScenarioInput2.xaml.cs

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 using System;
00009 using System.Linq;
00010 using System.Collections.Generic;
00011 using Windows.Foundation;
00012 using Windows.Foundation.Collections;
00013 using Windows.Graphics.Display;
00014 using Windows.UI.ViewManagement;
00015 using Windows.UI.Xaml;
00016 using Windows.UI.Xaml.Controls;
00017 using Windows.UI.Xaml.Controls.Primitives;
00018 using Windows.UI.Xaml.Data;
00019 using Windows.UI.Xaml.Input;
00020 using Windows.UI.Xaml.Media;
00021 using Windows.UI.Xaml.Navigation;
00022 using SDKTemplateCS;
00023
00024 namespace MediaExtensionsCS
00025 {
00026     public sealed partial class ScenarioInput2 : Page
00027     {
00028         // A pointer back to the main page which is used to gain access to the input and output frames and their content.
00029         MainPage rootPage = null;
00030         MediaElement outputVideo;
00031
00032         public ScenarioInput2()
00033         {
00034             InitializeComponent();
00035         }
00036
00037         #region Template-Related Code - Do not remove
00038         protected override void OnNavigatedTo(NavigationEventArgs e)
00039         {
00040             // Get a pointer to our main page
00041             rootPage = e.Parameter as MainPage;
00042
00043             // We want to be notified with the OutputFrame is loaded so we can get to the content.
00044             rootPage.OutputFrameLoaded += new System.EventHandler(rootPage_OutputFrameLoaded);
00045
00046             rootPage.ExtensionManager.RegisterSchemeHandler("GeometricSource.GeometricSchemeHandler", "myscheme:");
00047         }
00048
00049         protected override void OnNavigatedFrom(NavigationEventArgs e)
00050         {
00051             rootPage.OutputFrameLoaded -= new System.EventHandler(rootPage_OutputFrameLoaded);
00052         }
00053
00054         #endregion
00055
00056         #region Event handlers
00057         void rootPage_OutputFrameLoaded(object sender, object e)
00058         {
00059             // At this point, we know that the Output Frame has been loaded and we can go ahead
00060             // and reference elements in the page contained in the Output Frame.
00061
00062             // Get a pointer to the content within the OutputFrame.
00063             Page outputFrame = (Page)rootPage.OutputFrame.Content;
00064
00065             // Go find the elements that we need for this scenario.
00066             outputVideo = outputFrame.FindName("Video") as MediaElement;
00067         }
00068
00069         /// <summary>
00070         /// This is the click handler for the 'Circle' button.
00071         /// </summary>
00072         /// <param name="sender"></param>
00073         /// <param name="e"></param>
00074         private void Circle_Click(object sender, RoutedEventArgs e)
00075         {
00076             outputVideo.Source = new Uri("myscheme://circle");
00077         }
00078
00079
00080         /// <summary>
00081         /// This is the click handler for the 'Square' button.
00082         /// </summary>
00083         /// <param name="sender"></param>
00084         /// <param name="e"></param>
00085         private void Square_Click(object sender, RoutedEventArgs e)
00086         {
00087             outputVideo.Source = new Uri("myscheme://square");
00088         }
00089
00090         /// <summary>
00091         /// This is the click handler for the 'Triangle' button.
00092         /// </summary>
00093         /// <param name="sender"></param>
00094         /// <param name="e"></param>
00095         private void Triangle_Click(object sender, RoutedEventArgs e)
00096         {
00097             outputVideo.Source = new Uri("myscheme://triangle");
00098         }
00099         #endregion
00100     }
00101 }
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DirectX::D3DX_BC6H::ModeInfo Member List

This is the complete list of members for DirectX::D3DX_BC6H::ModeInfo, including all inherited members.
bTransformed | DirectX::D3DX_BC6H::ModeInfo
RGBAPrec | DirectX::D3DX_BC6H::ModeInfo
uIndexPrec | DirectX::D3DX_BC6H::ModeInfo
uMode | DirectX::D3DX_BC6H::ModeInfo
uPartitions | DirectX::D3DX_BC6H::ModeInfo
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/pch.cpp Source File

  • Direct2D animation

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchFileInput.xaml.h Source File

  • Association launching

LaunchFileInput.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // LaunchFileInput.xaml.h
00009 // Declaration of the LaunchFileInput class.
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "LaunchFileInput.g.h"
00016 #include "MainPage.xaml.h"
00017
00018 using namespace Windows::UI::Xaml;
00019
00020 namespace AssociationLaunching
00021 {
00022   [Windows::Foundation::Metadata::WebHostHidden]
00023     public ref class LaunchFileInput sealed
00024     {
00025     public:
00026         LaunchFileInput();
00027
00028     protected:
00029         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00031
00032     private:
00033         MainPage^ rootPage;
00034
00035         void LaunchFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036         void LaunchFileWithWarningButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037         void LaunchFileOpenWithButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038         void PickAndLaunchFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         ~LaunchFileInput();
00040
00041         static Windows::Foundation::Point GetOpenWithPosition(Windows::UI::Xaml::FrameworkElement^ element);
00042         static Platform::String^ fileToLaunch;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/TrialMode.xaml.cpp Source File

  • Trial app and in-app purchase

TrialMode.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // TrialMode.xaml.cpp
00013 // Implementation of the TrialMode class
00014 //
00015
00016 #include "pch.h"
00017 #include "TrialMode.xaml.h"
00018
00019 using namespace SDKSample::StoreSample;
00020
00021 using namespace concurrency;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::ApplicationModel::Store;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Globalization;
00026 using namespace Windows::Storage;
00027 using namespace Windows::UI::Xaml;
00028 using namespace Windows::UI::Xaml::Controls;
00029 using namespace Windows::UI::Xaml::Navigation;
00030
00031 TrialMode::TrialMode()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void TrialMode::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046     LoadTrialModeProxyFile();
00047 }
00048
00049 void TrialMode::OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e)
00050 {
00051     CurrentAppSimulator::LicenseInformation->LicenseChanged -= eventRegistrationToken;
00052 }
00053
00054 void TrialMode::LoadTrialModeProxyFile()
00055 {
00056     create_task(Package::Current->InstalledLocation->GetFolderAsync("data")).then([this](StorageFolder^ proxyDataFolder)
00057     {
00058         create_task(proxyDataFolder->GetFileAsync("trial-mode.xml")).then([this](StorageFile^ proxyFile)
00059         {
00060             eventRegistrationToken = (CurrentAppSimulator::LicenseInformation->LicenseChanged += ref new LicenseChangedEventHandler(this, &TrialMode::TrialModeRefreshScenario));
00061             create_task(CurrentAppSimulator::ReloadSimulatorAsync(proxyFile)).then([this]()
00062             {
00063                 create_task(CurrentAppSimulator::LoadListingInformationAsync()).then([this](ListingInformation^ listing)
00064                 {
00065                     PurchasePrice->Text = "You can buy the full app for: " + listing->FormattedPrice + ".";
00066                 });
00067             });
00068         });
00069     });
00070 }
00071
00072 void TrialMode::TrialModeRefreshScenario()
00073 {
00074     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00075     if (licenseInformation->IsActive)
00076     {
00077         if (licenseInformation->IsTrial)
00078         {
00079             LicenseMode->Text = "Current license mode: Trial license";
00080         }
00081         else
00082         {
00083             LicenseMode->Text = "Current license mode: Full license";
00084         }
00085     }
00086     else
00087     {
00088         LicenseMode->Text = "Current license mode: Inactive license";
00089     }
00090 }
00091
00092 void TrialMode::TrialTime_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00093 {
00094     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00095     if (licenseInformation->IsActive)
00096     {
00097         if (licenseInformation->IsTrial)
00098         {
00099             auto calendarObj = ref new Calendar();
00100             calendarObj->SetToNow();
00101             auto currentDateTime = calendarObj->GetDateTime();
00102             auto numberOfRemainingDays = (licenseInformation->ExpirationDate.UniversalTime - currentDateTime.UniversalTime) / 864000000000;
00103             rootPage->NotifyUser("You can use this app for " + numberOfRemainingDays + " more days before the trial period ends.", NotifyType::StatusMessage);
00104         }
00105         else
00106         {
00107             rootPage->NotifyUser("You have a full license. The trial time is not meaningful.", NotifyType::ErrorMessage);
00108         }
00109     }
00110     else
00111     {
00112         rootPage->NotifyUser("You don't have a license. The trial time can't be determined.", NotifyType::ErrorMessage);
00113     }
00114 }
00115
00116 void TrialMode::TrialProduct_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00117 {
00118     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00119     if (licenseInformation->IsActive)
00120     {
00121         if (licenseInformation->IsTrial)
00122         {
00123             rootPage->NotifyUser("You are using a trial version of this app.", NotifyType::StatusMessage);
00124         }
00125         else
00126         {
00127             rootPage->NotifyUser("You no longer have a trial version of this app.", NotifyType::ErrorMessage);
00128         }
00129     }
00130     else
00131     {
00132         rootPage->NotifyUser("You don't have a license for this app.", NotifyType::ErrorMessage);
00133     }
00134 }
00135
00136 void TrialMode::FullProduct_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00137 {
00138     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00139     if (licenseInformation->IsActive)
00140     {
00141         if (licenseInformation->IsTrial)
00142         {
00143             rootPage->NotifyUser("You are using a trial version of this app.", NotifyType::ErrorMessage);
00144         }
00145         else
00146         {
00147             rootPage->NotifyUser("You are using a fully-licensed version of this app.", NotifyType::StatusMessage);
00148         }
00149     }
00150     else
00151     {
00152         rootPage->NotifyUser("You don't have a license for this app.", NotifyType::ErrorMessage);
00153     }
00154 }
00155
00156 void TrialMode::ConvertTrial_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00157 {
00158     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00159     rootPage->NotifyUser("Buying the full license...", NotifyType::StatusMessage);
00160     if (licenseInformation->IsTrial)
00161     {
00162         create_task(CurrentAppSimulator::RequestAppPurchaseAsync(false)).then([this](task<Platform::String^> currentTask)
00163         {
00164             try
00165             {
00166                 currentTask.get();
00167                 auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00168                 if (licenseInformation->IsActive && !licenseInformation->IsTrial)
00169                 {
00170                     rootPage->NotifyUser("You successfully upgraded your app to the fully-licensed version.", NotifyType::StatusMessage);
00171                 }
00172                 else
00173                 {
00174                     rootPage->NotifyUser("You still have a trial license for this app.", NotifyType::ErrorMessage);
00175                 }
00176             }
00177             catch(Platform::Exception^ exception)
00178             {
00179                 rootPage->NotifyUser("The upgrade transaction failed. You still have a trial license for this app.", NotifyType::ErrorMessage);
00180             }
00181         });
00182     }
00183     else
00184     {
00185         rootPage->NotifyUser("You already bought this app and have a fully-licensed version.", NotifyType::ErrorMessage);
00186     }
00187 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/DirectXBase.h Source File

  • UI Automation core window provider

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011 #include <agile.h>
00012
00013 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00014 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00015 ref class DirectXBase abstract
00016 {
00017 internal:
00018     DirectXBase();
00019
00020     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00021     virtual void HandleDeviceLost();
00022     virtual void CreateDeviceIndependentResources();
00023     virtual void CreateDeviceResources();
00024     virtual void SetDpi(float dpi);
00025     virtual void UpdateForWindowSizeChange();
00026     virtual void CreateWindowSizeDependentResources();
00027     virtual void Render() = 0;
00028     virtual void Present();
00029     void ValidateDevice();
00030
00031 protected private:
00032     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00033
00034     // DirectWrite & Windows Imaging Component Objects.
00035     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00036     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00037
00038     // DirectX Core Objects. Required for 2D and 3D.
00039     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00040     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00041     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00042     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00043
00044     // Direct2D Rendering Objects. Required for 2D.
00045     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00046     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00047     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00048     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00049
00050     // Direct3D Rendering Objects. Required for 3D.
00051     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00052
00053     // Cached renderer properties.
00054     D3D_FEATURE_LEVEL                               m_featureLevel;
00055     Windows::Foundation::Size                       m_renderTargetSize;
00056     Windows::Foundation::Rect                       m_windowBounds;
00057     float                                           m_dpi;
00058     bool                                            m_windowSizeChangeInProgress;
00059 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/LoadScreen.h Source File

  • DirectX marble maze game

LoadScreen.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 ref class LoadScreen
00013 {
00014 internal:
00015     void Initialize(
00016         _In_ ID2D1Device*         d2dDevice,
00017         _In_ ID2D1DeviceContext*  d2dContext,
00018         _In_ IWICImagingFactory*  wicFactory
00019         );
00020
00021     void ResetDirectXResources();
00022
00023     void UpdateForWindowSizeChange();
00024
00025     void Render();
00026
00027 private:
00028     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00029     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00030     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00031     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00032
00033     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00034     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_bitmap;
00035
00036     D2D1_SIZE_F                                     m_imageSize;
00037     D2D1_SIZE_F                                     m_offset;
00038     D2D1_SIZE_F                                     m_totalSize;
00039 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Constants.cpp Source File

  • Compression

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     { "WinRT to WinRT compression/decompression", "SDKSample.Compression.Scenario1" },
00020     { "WinRT to Classic compression/decompression", "SDKSample.Compression.Scenario2" },
00021     { "Classic to WinRT compression/decompression", "SDKSample.Compression.Scenario3" }
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/MainPage.xaml.cpp Source File

  • Gyrometer sensor

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario3.xaml.h Source File

  • File and folder thumbnail

Scenario3.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FileThumbnails
00025     {
00026         [Windows::Foundation::Metadata::WebHostHidden]
00027         public ref class Scenario3 sealed
00028         {
00029         public:
00030             Scenario3();
00031
00032         protected:
00033             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00034
00035         private:
00036             MainPage^ rootPage;
00037
00038             void GetThumbnailButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickURLFile.xaml.h Source File

  • File picker contracts

FileOpenPicker_PickURLFile.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FileOpenPicker_PickURLFile.xaml.h
00013 // Declaration of the FileOpenPicker_PickURLFile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "FileOpenPicker_PickURLFile.g.h"
00020
00021 namespace SDKSample
00022 {
00023     namespace FilePickerContracts
00024     {
00025         /// <summary>
00026         /// An empty page that can be used on its own or navigated to within a Frame.
00027         /// </summary>
00028         [Windows::Foundation::Metadata::WebHostHidden]
00029         public ref class FileOpenPicker_PickURLFile sealed
00030         {
00031         public:
00032             FileOpenPicker_PickURLFile();
00033
00034         protected:
00035             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00036             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         internal:
00039             Windows::Storage::Pickers::Provider::FileOpenPickerUI^ fileOpenPickerUI;
00040
00041         private:
00042             Platform::String^ fileID;
00043             Windows::Foundation::EventRegistrationToken token;
00044
00045             void AddURLFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046             void RemoveURLFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void OnFileRemoved(Windows::Storage::Pickers::Provider::FileOpenPickerUI^ sender, Windows::Storage::Pickers::Provider::FileRemovedEventArgs^ e);
00048             void UpdateButtonState(bool fileInBasket);
00049         };
00050     }
00051 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/pch.h Source File

  • Display orientation

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include <agile.h>
00021
00022 #define _USE_MATH_DEFINES
00023 #include <math.h>
00024
00025 #include "Common\LayoutAwarePage.h"
00026 #include "Common\SuspensionManager.h"
00027 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Invert/CopyModule.h Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Invert

CopyModule.h

Go to the documentation of this file.
00001 #pragma once
00002
00003 #include "DirectXVideoTransform.h"
00004
00005 class CCopyModule : public DirectXVideoTransform
00006 {
00007     virtual void Invalidate(){}
00008
00009     virtual HRESULT Initialize(ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight){ return S_OK; }
00010
00011     virtual HRESULT ProcessFrame(ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex)
00012     {
00013         ComPtr<ID3D11DeviceContext> pContext;
00014         pDevice->GetImmediateContext(&pContext);
00015
00016         pContext->CopySubresourceRegion(pOutput, uiOutIndex, 0, 0, 0, pInput, uiInIndex, NULL);
00017
00018         return S_OK;
00019     }
00020 };
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/Scenario2.xaml.h Source File

  • LightSensor

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace LightSensorCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Windows::UI::Core::CoreDispatcher^ dispatcher;
00042             Windows::Devices::Sensors::LightSensor^ sensor;
00043             Windows::Foundation::EventRegistrationToken visibilityToken;
00044             uint32 desiredReportInterval;
00045             Windows::UI::Xaml::DispatcherTimer^ dispatcherTimer;
00046
00047             void VisibilityChanged(Platform::Object^ sender, Windows::UI::Core::VisibilityChangedEventArgs^ e);
00048             void DisplayCurrentReading(Platform::Object^ sender, Platform::Object^ e);
00049             void ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050             void ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00051         };
00052     }
00053 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/DirectXBase.h Source File

  • Direct2D perspective transform

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/LonLatController.h Source File

  • Direct3D bump mapping

LonLatController.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007 ////----------------------------------------------------------------------
00008
00009 #pragma once
00010
00011 #define LONLAT_GAIN    0.003f // sensitivity adjustment for mouse/touch
00012 #define LONLATKEY_GAIN 0.04f // sensitivity adjustment for keys
00013
00014 // A basic Longitude/Latitude Controller class for navigation on a sphere
00015 // Uses touch, WASD keyboard, or mouse pointer movement
00016
00017 ref class LonLatController
00018 {
00019 private:
00020     // properties of the controller object
00021     float3 m_position;   // Position of the camera
00022     float m_radius;      // Distance from center of sphere
00023     float m_longitude;   // Left-right coordinate on the sphere
00024     float m_latitude;    // Pole-to-pole coordinate on the sphere
00025
00026     // properties of the LonLat control
00027     BOOL m_lonLatInUse; // the look control is in use
00028     uint32 m_lonLatPointerID1; // id of the first pointer down
00029     uint32 m_lonLatPointerID2; // id of the second pointer down
00030     float2 m_lonLatLastPoint1; // last point (from last frame)
00031     float2 m_lonLatLastPoint2; // last point (from last frame)
00032
00033     float3 m_lonLatCommand; // the net command from the move control
00034     uint32 m_numPointersDown;
00035     float  m_lastDistance;
00036
00037     // Methods to get input from the UI pointers
00038     void OnPointerPressed(
00039         _In_ Windows::UI::Core::CoreWindow^ sender,
00040         _In_ Windows::UI::Core::PointerEventArgs^ args
00041         );
00042
00043     void OnPointerMoved(
00044         _In_ Windows::UI::Core::CoreWindow^ sender,
00045         _In_ Windows::UI::Core::PointerEventArgs^ args
00046         );
00047
00048     void OnPointerReleased(
00049         _In_ Windows::UI::Core::CoreWindow^ sender,
00050         _In_ Windows::UI::Core::PointerEventArgs^ args
00051         );
00052
00053     void OnPointerWheelChanged(
00054         _In_ Windows::UI::Core::CoreWindow^ sender,
00055         _In_ Windows::UI::Core::PointerEventArgs^ args
00056         );
00057
00058     void OnKeyDown(
00059         _In_ Windows::UI::Core::CoreWindow^ sender,
00060         _In_ Windows::UI::Core::KeyEventArgs^ args
00061         );
00062
00063     void OnKeyUp(
00064         _In_ Windows::UI::Core::CoreWindow^ sender,
00065         _In_ Windows::UI::Core::KeyEventArgs^ args
00066         );
00067
00068 internal:
00069     // set up the Controls supported by this controller
00070     void Initialize(_In_ Windows::UI::Core::CoreWindow^ window);
00071
00072     // accessor to set position of controller
00073     void SetPosition(_In_ float3 pos);
00074
00075     // accessor to set position of controller
00076     void SetOrientation(_In_ float latitude, _In_ float longitude);
00077
00078     // returns the position of the controller object
00079     float3 get_Position();
00080
00081     // returns the point at which the camera controller is facing
00082     float3 get_LookPoint();
00083
00084     void Update(_In_ Windows::UI::Core::CoreWindow^ window);
00085
00086     // methods to save and restore state
00087     void SaveInternalState(_In_ Windows::Foundation::Collections::IPropertySet^ state);
00088     void LoadInternalState(_In_ Windows::Foundation::Collections::IPropertySet^ state);
00089 };
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::PortableDeviceCPP::EventCallback Member List

This is the complete list of members for SDKSample::PortableDeviceCPP::EventCallback, including all inherited members.
_eventReceived | SDKSample::PortableDeviceCPP::EventCallback | [private]
EventCallback(EventReceived^eventReceived) | SDKSample::PortableDeviceCPP::EventCallback | [inline]
OnEvent(_In_ IPortableDeviceValues *eventParameters) | SDKSample::PortableDeviceCPP::EventCallback | [inline]
~EventCallback() | SDKSample::PortableDeviceCPP::EventCallback | [inline]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/common/suspensionmanager.h Source File

  • XAML high contrast style
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SimpleVertex Member List

This is the complete list of members for SimpleVertex, including all inherited members.
Norm | SimpleVertex
Pos | SimpleVertex
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/MediaReader.cpp Source File

  • DirectX 3D shooting game

MediaReader.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "MediaReader.h"
00010 #include "DirectXSample.h"
00011
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::Storage;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017
00018 MediaReader::MediaReader()
00019 {
00020     ZeroMemory(&m_waveFormat, sizeof(m_waveFormat));
00021     m_installedLocation = Package::Current->InstalledLocation;
00022     m_installedLocationPath = Platform::String::Concat(m_installedLocation->Path, "\\");
00023 }
00024
00025 WAVEFORMATEX *MediaReader::GetOutputWaveFormatEx()
00026 {
00027     return &m_waveFormat;
00028 }
00029
00030 Platform::Array<byte>^ MediaReader::LoadMedia(_In_ Platform::String^ filename)
00031 {
00032     DX::ThrowIfFailed(
00033         MFStartup(MF_VERSION)
00034         );
00035
00036     ComPtr<IMFSourceReader> reader;
00037     DX::ThrowIfFailed(
00038         MFCreateSourceReaderFromURL(
00039             Platform::String::Concat(m_installedLocationPath, filename)->Data(),
00040             nullptr,
00041             &reader
00042             )
00043         );
00044
00045     // Set the decoded output format as PCM.
00046     // XAudio2 on Windows can process PCM and ADPCM-encoded buffers.
00047     // When using MediaFoundation, this sample always decodes into PCM.
00048     Microsoft::WRL::ComPtr<IMFMediaType> mediaType;
00049     DX::ThrowIfFailed(
00050         MFCreateMediaType(&mediaType)
00051         );
00052
00053     DX::ThrowIfFailed(
00054         mediaType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Audio)
00055         );
00056
00057     DX::ThrowIfFailed(
00058         mediaType->SetGUID(MF_MT_SUBTYPE, MFAudioFormat_PCM)
00059         );
00060
00061     DX::ThrowIfFailed(
00062         reader->SetCurrentMediaType(static_cast<uint32>(MF_SOURCE_READER_FIRST_AUDIO_STREAM), 0, mediaType.Get())
00063         );
00064
00065     // Get the complete WAVEFORMAT from the Media Type.
00066     Microsoft::WRL::ComPtr<IMFMediaType> outputMediaType;
00067     DX::ThrowIfFailed(
00068         reader->GetCurrentMediaType(static_cast<uint32>(MF_SOURCE_READER_FIRST_AUDIO_STREAM), &outputMediaType)
00069         );
00070
00071     UINT32 size = 0;
00072     WAVEFORMATEX* waveFormat;
00073     DX::ThrowIfFailed(
00074         MFCreateWaveFormatExFromMFMediaType(outputMediaType.Get(), &waveFormat, &size)
00075         );
00076
00077     CopyMemory(&m_waveFormat, waveFormat, sizeof(m_waveFormat));
00078     CoTaskMemFree(waveFormat);
00079
00080     PROPVARIANT propVariant;
00081     DX::ThrowIfFailed(
00082         reader->GetPresentationAttribute(static_cast<uint32>(MF_SOURCE_READER_MEDIASOURCE), MF_PD_DURATION, &propVariant)
00083         );
00084     // 'duration' is in 100ns units; convert to seconds, and round up
00085     // to the nearest whole byte.
00086     LONGLONG duration = propVariant.uhVal.QuadPart;
00087     unsigned int maxStreamLengthInBytes =
00088         static_cast<unsigned int>(
00089             ((duration * static_cast<ULONGLONG>(m_waveFormat.nAvgBytesPerSec)) + 10000000) /
00090             10000000
00091             );
00092
00093     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(maxStreamLengthInBytes);
00094
00095     ComPtr<IMFSample> sample;
00096     ComPtr<IMFMediaBuffer> mediaBuffer;
00097     DWORD flags = 0;
00098
00099     int positionInData = 0;
00100     bool done = false;
00101     while (!done)
00102     {
00103         DX::ThrowIfFailed(
00104             reader->ReadSample(static_cast<uint32>(MF_SOURCE_READER_FIRST_AUDIO_STREAM), 0, nullptr, &flags, nullptr, &sample)
00105             );
00106
00107         if (sample != nullptr)
00108         {
00109             DX::ThrowIfFailed(
00110                 sample->ConvertToContiguousBuffer(&mediaBuffer)
00111                 );
00112
00113             BYTE *audioData = nullptr;
00114             DWORD sampleBufferLength = 0;
00115             DX::ThrowIfFailed(
00116                 mediaBuffer->Lock(&audioData, nullptr, &sampleBufferLength)
00117                 );
00118
00119             for (DWORD i = 0; i < sampleBufferLength; i++)
00120             {
00121                 fileData[positionInData++] = audioData[i];
00122             }
00123         }
00124         if (flags & MF_SOURCE_READERF_ENDOFSTREAM)
00125         {
00126             done = true;
00127         }
00128     }
00129
00130     return fileData;
00131 }
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Constants.h Source File

  • Push and periodic notifications client-side

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME {
00027             Platform::String^ get() {  return ref new Platform::String(L"Push and Periodic Notifications"); }
00028         }
00029
00030         static property Platform::Array<Scenario>^ scenarios {
00031             Platform::Array<Scenario>^ get()
00032             {
00033                 return scenariosInner;
00034             }
00035         }
00036
00037     property Windows::Networking::PushNotifications::PushNotificationChannel^ Channel {
00038       Windows::Networking::PushNotifications::PushNotificationChannel^ get()
00039       {
00040         return channel;
00041       }
00042
00043       void set(Windows::Networking::PushNotifications::PushNotificationChannel^ newChannel)
00044       {
00045         channel = newChannel;
00046       }
00047     }
00048
00049
00050     property PushNotificationsHelper::Notifier^ Notifier {
00051       PushNotificationsHelper::Notifier^ get()
00052       {
00053         return notifier;
00054       }
00055
00056       void set(PushNotificationsHelper::Notifier^ newNotifier)
00057       {
00058         notifier = newNotifier;
00059       }
00060     }
00061     private:
00062         static Platform::Array<Scenario>^ scenariosInner;
00063     Windows::Networking::PushNotifications::PushNotificationChannel^ channel;
00064     PushNotificationsHelper::Notifier^ notifier;
00065     };
00066
00067
00068 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hit testing/C++/DirectXBase.h Source File

  • DirectWrite hit testing

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/Util.h Source File

  • Mobile broadband account provisioning

Util.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Declaration of the Util class
00013 //
00014
00015 #pragma once
00016
00017 #include "pch.h"
00018 #include "MainPage.xaml.h"
00019
00020 using namespace Platform;
00021
00022 namespace SDKSample
00023 {
00024     namespace ProvisioningAgent
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Util sealed
00030         {
00031         public:
00032             Util();
00033
00034             String^ ParseErrorCode(String^ errorCode);
00035             String^ ParseResultXML(String^ resultsXml);
00036             String^ PrintExceptionCode(Exception^ error);
00037         };
00038     }
00039 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput6.xaml.h Source File

  • Print

ScenarioOutput6.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioOutput6.xaml.h
00010 // Declaration of the ScenarioOutput6 class
00011 //
00012
00013 #pragma once
00014
00015 #include "ScenarioOutput6.g.h"
00016
00017 namespace PrintSample
00018 {
00019     [Windows::Foundation::Metadata::WebHostHidden]
00020     public ref class ScenarioOutput6 sealed
00021     {
00022     public:
00023         ScenarioOutput6();
00024     private:
00025         ~ScenarioOutput6();
00026     };
00027 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/Constants.h Source File

  • Account picture name

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace AccountPictureName
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         void LoadSetAccountPictureScenario();
00027
00028         static property Platform::String^ FEATURE_NAME
00029         {
00030             Platform::String^ get()
00031             {
00032                 return ref new Platform::String(L"AccountPictureName C++");
00033             }
00034         }
00035
00036         static property Platform::Array<Scenario>^ scenarios
00037         {
00038             Platform::Array<Scenario>^ get()
00039             {
00040                 return scenariosInner;
00041             }
00042         }
00043
00044     internal:
00045         bool EnsureUnsnapped();
00046
00047     private:
00048         static Platform::Array<Scenario>^ scenariosInner;
00049     };
00050 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/MainPage.xaml.h Source File

  • Connecting with WebSockets

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/MainPage.xaml.cpp Source File

  • Portable device API

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/common/suspensionmanager.h Source File

  • Network information
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/MainPage.xaml.h Source File

  • Bluetooth call control

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario3.xaml.h Source File

  • AtomPub

Scenario3.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 namespace SDKSample
00026 {
00027     namespace AtomPub
00028     {
00029         /// <summary>
00030         /// An empty page that can be used on its own or navigated to within a Frame.
00031         /// </summary>
00032       [Windows::Foundation::Metadata::WebHostHidden]
00033         public ref class Scenario3 sealed
00034         {
00035         public:
00036             Scenario3();
00037
00038         protected:
00039             virtual void OnNavigatedTo(NavigationEventArgs^ e) override;
00040             virtual void OnNavigatingFrom(NavigatingCancelEventArgs^ e) override;
00041
00042         private:
00043             MainPage^ rootPage;
00044             SyndicationItemIterator^ feedIterator;
00045
00046             void GetFeed_Click(Object^ sender, RoutedEventArgs^ e);
00047             void DeleteItem_Click(Object^ sender, RoutedEventArgs^ e);
00048             void PreviousItem_Click(Object^ sender, RoutedEventArgs^ e);
00049             void NextItem_Click(Object^ sender, RoutedEventArgs^ e);
00050             void UserNameField_TextChanged(Object^ sender, TextChangedEventArgs^ e);
00051             void PasswordField_PasswordChanged(Object^ sender, RoutedEventArgs^ e);
00052             void DisplayItem();
00053         };
00054     }
00055 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario2.xaml.h Source File

  • File picker

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FilePicker
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario2 sealed
00030         {
00031         public:
00032             Scenario2();
00033
00034         private:
00035             MainPage^ rootPage;
00036
00037             void PickFilesButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038         };
00039     }
00040 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicTimer.cpp Source File

  • Direct3D-Direct2D interop

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/SignatureFlyout.xaml.cpp Source File

  • DirectX postcard app

SignatureFlyout.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SignatureFlyout.xaml.h"
00010
00011 using namespace Postcard;
00012
00013 using namespace Platform;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Windows::UI::Xaml;
00017 using namespace Windows::UI::Xaml::Controls;
00018 using namespace Windows::UI::Xaml::Controls::Primitives;
00019 using namespace Windows::UI::Xaml::Data;
00020 using namespace Windows::UI::Xaml::Input;
00021 using namespace Windows::UI::Xaml::Media;
00022 using namespace Windows::UI::Xaml::Navigation;
00023
00024 SignatureFlyout::SignatureFlyout()
00025 {
00026     InitializeComponent();
00027 }
00028
00029
00030 void SignatureFlyout::SignButtonCicked(Object^ sender, RoutedEventArgs^ e)
00031 {
00032     SignClicked();
00033     Hide();
00034 }
00035
00036
00037 void SignatureFlyout::EraseButtonClicked(Object^ sender, RoutedEventArgs^ e)
00038 {
00039     EraseClicked();
00040     Hide();
00041 }
00042
00043 void SignatureFlyout::Hide()
00044 {
00045     Popup^ parent = dynamic_cast<Popup^>(this->Parent);
00046     if (parent != nullptr)
00047     {
00048         parent->IsOpen = false;
00049     }
00050 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/SampleOverlay.cpp Source File

  • Direct3D post-processing effects

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/App.xaml.cpp Source File

  • XAML DirectX 3D shooting game

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "App.xaml.h"
00010
00011 using namespace Simple3DGameXaml;
00012
00013 using namespace concurrency;
00014 using namespace DirectX;
00015 using namespace Windows::ApplicationModel;
00016 using namespace Windows::ApplicationModel::Activation;
00017 using namespace Windows::ApplicationModel::Core;
00018 using namespace Windows::ApplicationModel::Store;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Graphics::Display;
00021 using namespace Windows::Storage;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::Input;
00024 using namespace Windows::UI::ViewManagement;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Media;
00027
00028
00029 //----------------------------------------------------------------------
00030
00031 App::App():
00032     m_pauseRequested(false),
00033     m_pressComplete(false),
00034     m_renderNeeded(false),
00035     m_visible(true),
00036     m_haveFocus(true),
00037     m_updateState(UpdateEngineState::WaitingForResources)
00038 {
00039     InitializeComponent();
00040
00041 #if defined(_DEBUG)
00042     UnhandledException += ref new UnhandledExceptionEventHandler([](Object^ /* sender */, UnhandledExceptionEventArgs^ args)
00043     {
00044         Platform::String^ error = "Simple3DGameXaml::App::UnhandledException: " + args->Message + "\n";
00045         OutputDebugStringW(error->Data());
00046     });
00047 #endif
00048 }
00049
00050 //----------------------------------------------------------------------
00051
00052 App::~App()
00053 {
00054     CompositionTarget::Rendering::remove(m_onRenderingEventToken);
00055 }
00056
00057 //----------------------------------------------------------------------
00058
00059 void App::OnLaunched(_In_ LaunchActivatedEventArgs^ /* args */)
00060 {
00061     Suspending += ref new SuspendingEventHandler(this, &App::OnSuspending);
00062     Resuming += ref new EventHandler<Object^>(this, &App::OnResuming);
00063
00064     m_mainPage = ref new MainPage();
00065     m_mainPage->SetApp(this);
00066
00067     Window::Current->Content = m_mainPage;
00068     Window::Current->Activated += ref new WindowActivatedEventHandler(this, &App::OnWindowActivationChanged);
00069     Window::Current->Activate();
00070
00071     m_controller = ref new MoveLookController();
00072     m_renderer = ref new GameRenderer();
00073     m_game = ref new Simple3DGame();
00074
00075     auto window = Window::Current->CoreWindow;
00076
00077     PointerVisualizationSettings^ visualizationSettings = PointerVisualizationSettings::GetForCurrentView();
00078     visualizationSettings->IsContactFeedbackEnabled = false;
00079     visualizationSettings->IsBarrelButtonFeedbackEnabled = false;
00080
00081     window->SizeChanged +=
00082         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &App::OnWindowSizeChanged);
00083
00084     window->VisibilityChanged +=
00085         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &App::OnVisibilityChanged);
00086
00087     DisplayProperties::LogicalDpiChanged +=
00088         ref new DisplayPropertiesEventHandler(this, &App::OnLogicalDpiChanged);
00089
00090     DisplayProperties::DisplayContentsInvalidated +=
00091         ref new DisplayPropertiesEventHandler(this, &App::OnDisplayContentsInvalidated);
00092
00093     m_controller->Initialize(window);
00094     m_controller->AutoFire(false);
00095
00096     m_controller->SetMoveRect(
00097         XMFLOAT2(0.0f, window->Bounds.Height - GameConstants::TouchRectangleSize),
00098         XMFLOAT2(GameConstants::TouchRectangleSize, window->Bounds.Height)
00099         );
00100     m_controller->SetFireRect(
00101         XMFLOAT2(window->Bounds.Width - GameConstants::TouchRectangleSize, window->Bounds.Height - GameConstants::TouchRectangleSize),
00102         XMFLOAT2(window->Bounds.Width, window->Bounds.Height)
00103         );
00104
00105     m_renderer->Initialize(window, m_mainPage->GetSwapChainBackgroundPanel(), DisplayProperties::LogicalDpi);
00106     m_renderer->DeviceLost += ref new D3DDeviceEventHandler(this, &App::OnDeviceLost);
00107     m_renderer->DeviceReset += ref new D3DDeviceEventHandler(this, &App::OnDeviceReset);
00108
00109     SetGameInfoOverlay(GameInfoOverlayState::Loading);
00110     SetAction(GameInfoOverlayCommand::None);
00111     ShowGameInfoOverlay();
00112
00113     m_onRenderingEventToken = CompositionTarget::Rendering::add(ref new EventHandler<Object^>(this, &App::OnRendering));
00114     m_renderNeeded = true;
00115
00116     create_task([this]()
00117     {
00118         // Asynchronously initialize the game class and load the renderer device resources.
00119         // By doing all this asynchronously, the game gets to its main loop more quickly
00120         // and in parallel all the necessary resources are loaded on other threads.
00121         m_game->Initialize(m_controller, m_renderer);
00122
00123         return m_renderer->CreateGameDeviceResourcesAsync(m_game);
00124
00125     }).then([this]()
00126     {
00127         // The finalize code needs to run in the same thread context
00128         // as the m_renderer object was created because the D3D device context
00129         // can ONLY be accessed on a single thread.
00130         m_renderer->FinalizeCreateGameDeviceResources();
00131
00132         InitializeLicense();
00133         InitializeGameState();
00134
00135         if (m_updateState == UpdateEngineState::WaitingForResources)
00136         {
00137             // In the middle of a game so spin up the async task to load the level.
00138             create_task([this]()
00139             {
00140                 return m_game->LoadLevelAsync();
00141
00142             }).then([this]()
00143             {
00144                 // The m_game object may need to deal with D3D device context work so
00145                 // again the finalize code needs to run in the same thread
00146                 // context as the m_renderer object was created because the D3D
00147                 // device context can ONLY be accessed on a single thread.
00148                 m_game->FinalizeLoadLevel();
00149                 m_game->SetCurrentLevelToSavedState();
00150                 m_updateState = UpdateEngineState::ResourcesLoaded;
00151
00152             }, task_continuation_context::use_current());
00153         }
00154     }, task_continuation_context::use_current());
00155 }
00156
00157 //----------------------------------------------------------------------
00158
00159 void App::OnRendering(
00160     _In_ Object^ /* sender */,
00161     _In_ Object^ /* args */
00162     )
00163 {
00164     Update();
00165     if (m_updateState == UpdateEngineState::Dynamics || m_renderNeeded)
00166     {
00167         m_renderer->Render();
00168         m_renderNeeded = false;
00169     }
00170
00171     if (!m_visible || !m_haveFocus || (m_updateState == UpdateEngineState::Snapped))
00172     {
00173         // App is in an inactive state so disable the OnRendering callback
00174         // This optimizes for power and allows the framework to become more queiecent
00175         if (m_onRenderingEventToken.Value != 0)
00176         {
00177             CompositionTarget::Rendering::remove(m_onRenderingEventToken);
00178             m_onRenderingEventToken.Value = 0;
00179         }
00180     }
00181 }
00182
00183 //--------------------------------------------------------------------------------------
00184
00185 void App::OnWindowSizeChanged(
00186     _In_ CoreWindow^ window,
00187     _In_ WindowSizeChangedEventArgs^ /* args */
00188     )
00189 {
00190     UpdateViewState();
00191     m_mainPage->OnWindowSizeChanged();
00192     m_renderer->UpdateForWindowSizeChange();
00193
00194     // The location of the Control regions may have changed with the size change so update the controller.
00195     m_controller->SetMoveRect(
00196         XMFLOAT2(0.0f, window->Bounds.Height - GameConstants::TouchRectangleSize),
00197         XMFLOAT2(GameConstants::TouchRectangleSize, window->Bounds.Height)
00198         );
00199     m_controller->SetFireRect(
00200         XMFLOAT2(window->Bounds.Width - GameConstants::TouchRectangleSize, window->Bounds.Height - GameConstants::TouchRectangleSize),
00201         XMFLOAT2(window->Bounds.Width, window->Bounds.Height)
00202         );
00203
00204     m_renderNeeded = true;
00205
00206     if (m_onRenderingEventToken.Value == 0)
00207     {
00208         // Add the OnRendering Callback to make sure that an update happens.
00209         m_onRenderingEventToken = CompositionTarget::Rendering::add(ref new EventHandler<Object^>(this, &App::OnRendering));
00210     }
00211 }
00212
00213 //--------------------------------------------------------------------------------------
00214
00215 void App::OnLogicalDpiChanged(
00216     _In_ Object^ /* sender */
00217     )
00218 {
00219     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00220 }
00221
00222 //--------------------------------------------------------------------------------------
00223
00224 void App::OnDisplayContentsInvalidated(
00225     _In_ Object^ /* sender */
00226     )
00227 {
00228     m_renderNeeded = true;
00229
00230     if (m_onRenderingEventToken.Value == 0)
00231     {
00232         // Add the OnRendering Callback to make sure that an update happens.
00233         m_onRenderingEventToken = CompositionTarget::Rendering::add(ref new EventHandler<Object^>(this, &App::OnRendering));
00234     }
00235 }
00236
00237 //--------------------------------------------------------------------------------------
00238
00239 void App::OnVisibilityChanged(
00240     _In_ CoreWindow^ sender,
00241     _In_ VisibilityChangedEventArgs^ args
00242     )
00243 {
00244     m_visible = args->Visible;
00245
00246     if (m_visible && (m_onRenderingEventToken.Value == 0))
00247     {
00248         // App is now visible so set up the event handler to do game processing and rendering
00249         m_onRenderingEventToken = CompositionTarget::Rendering::add(ref new EventHandler<Object^>(this, &App::OnRendering));
00250     }
00251 }
00252
00253 //--------------------------------------------------------------------------------------
00254
00255 void App::InitializeGameState()
00256 {
00257     // Set up the initial state machine for handling Game playing state
00258     if (m_game->GameActive() && m_game->LevelActive())
00259     {
00260         // The last time the game terminated it was in the middle
00261         // of a level.
00262         // We are waiting for the user to continue the game.
00263         m_updateState = UpdateEngineState::WaitingForResources;
00264         m_pressResult = PressResultState::ContinueLevel;
00265         SetGameInfoOverlay(GameInfoOverlayState::Pause);
00266         SetAction(GameInfoOverlayCommand::PleaseWait);
00267     }
00268     else if (!m_game->GameActive() && (m_game->HighScore().totalHits > 0))
00269     {
00270         // The last time the game terminated the game had been completed.
00271         // Show the high score.
00272         // We are waiting for the user to acknowledge the high score and start a new game.
00273         // The level resources for the first level will be loaded later.
00274         m_updateState = UpdateEngineState::WaitingForPress;
00275         m_pressResult = PressResultState::LoadGame;
00276         SetGameInfoOverlay(GameInfoOverlayState::GameStats);
00277         m_controller->WaitForPress();
00278         SetAction(GameInfoOverlayCommand::TapToContinue);
00279     }
00280     else
00281     {
00282         // This is either the first time the game has run or
00283         // the last time the game terminated the level was completed.
00284         // We are waiting for the user to begin the next level.
00285         m_updateState = UpdateEngineState::WaitingForResources;
00286         m_pressResult = PressResultState::PlayLevel;
00287         SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
00288         SetAction(GameInfoOverlayCommand::PleaseWait);
00289     }
00290     ShowGameInfoOverlay();
00291 }
00292
00293 //--------------------------------------------------------------------------------------
00294
00295 void App::Update()
00296 {
00297     m_controller->Update();
00298
00299     switch (m_updateState)
00300     {
00301     case UpdateEngineState::ResourcesLoaded:
00302         switch (m_pressResult)
00303         {
00304         case PressResultState::LoadGame:
00305             SetGameInfoOverlay(GameInfoOverlayState::GameStats);
00306             break;
00307
00308         case PressResultState::PlayLevel:
00309             SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
00310             break;
00311
00312         case PressResultState::ContinueLevel:
00313             SetGameInfoOverlay(GameInfoOverlayState::Pause);
00314             break;
00315         }
00316         m_updateState = UpdateEngineState::WaitingForPress;
00317         SetAction(GameInfoOverlayCommand::TapToContinue);
00318         m_controller->WaitForPress();
00319         ShowGameInfoOverlay();
00320         m_renderNeeded = true;
00321         break;
00322
00323     case UpdateEngineState::WaitingForPress:
00324         if (m_controller->IsPressComplete() || m_pressComplete)
00325         {
00326             m_pressComplete = false;
00327
00328             switch (m_pressResult)
00329             {
00330             case PressResultState::LoadGame:
00331                 m_updateState = UpdateEngineState::WaitingForResources;
00332                 m_pressResult = PressResultState::PlayLevel;
00333                 m_controller->Active(false);
00334                 m_game->LoadGame();
00335                 SetAction(GameInfoOverlayCommand::PleaseWait);
00336                 SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
00337                 ShowGameInfoOverlay();
00338                 m_renderNeeded = true;
00339
00340                 m_game->LoadLevelAsync().then([this]()
00341                 {
00342                     m_game->FinalizeLoadLevel();
00343                     m_updateState = UpdateEngineState::ResourcesLoaded;
00344                     m_renderNeeded = true;
00345                 }, task_continuation_context::use_current());
00346                 break;
00347
00348             case PressResultState::PlayLevel:
00349                 m_updateState = UpdateEngineState::Dynamics;
00350                 HideGameInfoOverlay();
00351                 m_controller->Active(true);
00352                 m_game->StartLevel();
00353                 break;
00354
00355             case PressResultState::ContinueLevel:
00356                 m_updateState = UpdateEngineState::Dynamics;
00357                 HideGameInfoOverlay();
00358                 m_controller->Active(true);
00359                 m_game->ContinueGame();
00360                 break;
00361             }
00362         }
00363         break;
00364
00365     case UpdateEngineState::Dynamics:
00366         if (m_controller->IsPauseRequested() || m_pauseRequested)
00367         {
00368             m_pauseRequested = false;
00369
00370             m_game->PauseGame();
00371             SetGameInfoOverlay(GameInfoOverlayState::Pause);
00372             SetAction(GameInfoOverlayCommand::TapToContinue);
00373             m_updateState = UpdateEngineState::WaitingForPress;
00374             m_pressResult = PressResultState::ContinueLevel;
00375             ShowGameInfoOverlay();
00376             m_renderNeeded = true;
00377         }
00378         else
00379         {
00380             GameState runState = m_game->RunGame();
00381             switch (runState)
00382             {
00383             case GameState::TimeExpired:
00384                 SetAction(GameInfoOverlayCommand::TapToContinue);
00385                 SetGameInfoOverlay(GameInfoOverlayState::GameOverExpired);
00386                 ShowGameInfoOverlay();
00387                 m_updateState = UpdateEngineState::WaitingForPress;
00388                 m_pressResult = PressResultState::LoadGame;
00389                 m_renderNeeded = true;
00390                 break;
00391
00392             case GameState::LevelComplete:
00393                 SetAction(GameInfoOverlayCommand::PleaseWait);
00394                 SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
00395                 ShowGameInfoOverlay();
00396                 m_updateState = UpdateEngineState::WaitingForResources;
00397                 m_pressResult = PressResultState::PlayLevel;
00398                 m_renderNeeded = true;
00399
00400                 m_game->LoadLevelAsync().then([this]()
00401                 {
00402                     m_game->FinalizeLoadLevel();
00403                     m_updateState = UpdateEngineState::ResourcesLoaded;
00404                     m_renderNeeded = true;
00405
00406                 }, task_continuation_context::use_current());
00407                 break;
00408
00409             case GameState::GameComplete:
00410                 SetAction(GameInfoOverlayCommand::TapToContinue);
00411                 SetGameInfoOverlay(GameInfoOverlayState::GameOverCompleted);
00412                 ShowGameInfoOverlay();
00413                 m_updateState  = UpdateEngineState::WaitingForPress;
00414                 m_pressResult = PressResultState::LoadGame;
00415                 m_renderNeeded = true;
00416                 break;
00417             }
00418         }
00419
00420         if (m_updateState == UpdateEngineState::WaitingForPress)
00421         {
00422             // Transitioning state, so enable waiting for the press event
00423             m_controller->WaitForPress();
00424         }
00425         if (m_updateState == UpdateEngineState::WaitingForResources)
00426         {
00427             // Transitioning state, so shut down the input controller until resources are loaded
00428             m_controller->Active(false);
00429         }
00430         break;
00431     }
00432 }
00433
00434 //--------------------------------------------------------------------------------------
00435
00436 void App::OnWindowActivationChanged(
00437     _In_ Platform::Object^ /* sender */,
00438     _In_ Windows::UI::Core::WindowActivatedEventArgs^ args
00439     )
00440 {
00441     if (args->WindowActivationState == CoreWindowActivationState::Deactivated)
00442     {
00443         m_haveFocus = false;
00444
00445         switch (m_updateState)
00446         {
00447         case UpdateEngineState::Dynamics:
00448             // From Dynamic mode, when coming out of Deactivated rather than going directly back into game play
00449             // go to the paused state waiting for user input to continue
00450             m_updateStateNext = UpdateEngineState::WaitingForPress;
00451             m_pressResult = PressResultState::ContinueLevel;
00452             SetGameInfoOverlay(GameInfoOverlayState::Pause);
00453             ShowGameInfoOverlay();
00454             m_game->PauseGame();
00455             m_updateState = UpdateEngineState::Deactivated;
00456             SetAction(GameInfoOverlayCommand::None);
00457             m_renderNeeded = true;
00458             break;
00459
00460         case UpdateEngineState::WaitingForResources:
00461         case UpdateEngineState::WaitingForPress:
00462             m_updateStateNext = m_updateState;
00463             m_updateState = UpdateEngineState::Deactivated;
00464             SetAction(GameInfoOverlayCommand::None);
00465             ShowGameInfoOverlay();
00466             m_renderNeeded = true;
00467             break;
00468         }
00469         // Don't have focus so shutdown input processing
00470         m_controller->Active(false);
00471     }
00472     else if (args->WindowActivationState == CoreWindowActivationState::CodeActivated
00473         || args->WindowActivationState == CoreWindowActivationState::PointerActivated)
00474     {
00475         m_haveFocus = true;
00476
00477         if (m_updateState == UpdateEngineState::Deactivated)
00478         {
00479             m_updateState = m_updateStateNext;
00480
00481             if (m_updateState == UpdateEngineState::WaitingForPress)
00482             {
00483                 SetAction(GameInfoOverlayCommand::TapToContinue);
00484                 m_controller->WaitForPress();
00485             }
00486             else if (m_updateStateNext == UpdateEngineState::WaitingForResources)
00487             {
00488                 SetAction(GameInfoOverlayCommand::PleaseWait);
00489             }
00490
00491             // App is now "active" so set up the event handler to do game processing and rendering
00492             if (m_onRenderingEventToken.Value == 0)
00493             {
00494                 m_onRenderingEventToken = CompositionTarget::Rendering::add(ref new EventHandler<Object^>(this, &App::OnRendering));
00495             }
00496         }
00497     }
00498 }
00499
00500 //--------------------------------------------------------------------------------------
00501
00502 void App::OnSuspending(
00503     _In_ Platform::Object^ /* sender */,
00504     _In_ SuspendingEventArgs^ args
00505     )
00506 {
00507     // Save application state.
00508     switch (m_updateState)
00509     {
00510     case UpdateEngineState::Dynamics:
00511         // Game is in the active game play state, Stop Game Timer and Pause play and save state
00512         SetAction(GameInfoOverlayCommand::None);
00513         SetGameInfoOverlay(GameInfoOverlayState::Pause);
00514         m_updateStateNext = UpdateEngineState::WaitingForPress;
00515         m_pressResult = PressResultState::ContinueLevel;
00516         m_game->PauseGame();
00517         break;
00518
00519     case UpdateEngineState::WaitingForResources:
00520     case UpdateEngineState::WaitingForPress:
00521         m_updateStateNext = m_updateState;
00522         break;
00523
00524     default:
00525         // any other state don't save as next state as they are trancient states and have already set m_updateStateNext
00526         break;
00527     }
00528     m_updateState = UpdateEngineState::Suspended;
00529
00530     m_controller->Active(false);
00531     m_game->OnSuspending();
00532 }
00533
00534 //--------------------------------------------------------------------------------------
00535
00536 void App::OnResuming(
00537     _In_ Platform::Object^ /* sender */,
00538     _In_ Platform::Object^ /* args */
00539     )
00540 {
00541     if (m_haveFocus)
00542     {
00543         m_updateState = m_updateStateNext;
00544     }
00545     else
00546     {
00547         m_updateState = UpdateEngineState::Deactivated;
00548     }
00549
00550     if (m_updateState == UpdateEngineState::WaitingForPress)
00551     {
00552         SetAction(GameInfoOverlayCommand::TapToContinue);
00553         m_controller->WaitForPress();
00554     }
00555     m_game->OnResuming();
00556     ShowGameInfoOverlay();
00557     m_renderNeeded = true;
00558 }
00559
00560 //--------------------------------------------------------------------------------------
00561
00562 void App::OnDeviceLost()
00563 {
00564     if (m_updateState == UpdateEngineState::Dynamics)
00565     {
00566         // Game is in the active game play state, Stop Game Timer and Pause play and save state
00567         m_game->PauseGame();
00568     }
00569     m_renderNeeded = false;
00570 }
00571
00572 //--------------------------------------------------------------------------------------
00573
00574 void App::OnDeviceReset()
00575 {
00576
00577     SetAction(GameInfoOverlayCommand::PleaseWait);
00578     SetGameInfoOverlay(GameInfoOverlayState::Loading);
00579     m_updateState = UpdateEngineState::WaitingForResources;
00580     m_renderNeeded = true;
00581
00582     if (m_onRenderingEventToken.Value == 0)
00583     {
00584         // Add the OnRendering Callback to make sure that an update happens.
00585         m_onRenderingEventToken = CompositionTarget::Rendering::add(ref new EventHandler<Object^>(this, &App::OnRendering));
00586     }
00587
00588     create_task([this]()
00589     {
00590         return m_renderer->CreateGameDeviceResourcesAsync(m_game);
00591
00592     }).then([this]()
00593     {
00594         // The finalize code needs to run in the same thread context
00595         // as the m_renderer object was created because the D3D device context
00596         // can ONLY be accessed on a single thread.
00597         m_renderer->FinalizeCreateGameDeviceResources();
00598
00599         // Reset the main state machine based on the current game state now
00600         // that the device resources have been restored.
00601         InitializeGameState();
00602
00603         if (m_updateState == UpdateEngineState::WaitingForResources)
00604         {
00605             // In the middle of a game so spin up the async task to load the level.
00606             return m_game->LoadLevelAsync().then([this]()
00607             {
00608                 // The m_game object may need to deal with D3D device context work so
00609                 // again the finalize code needs to run in the same thread
00610                 // context as the m_renderer object was created because the D3D
00611                 // device context can ONLY be accessed on a single thread.
00612                 m_game->FinalizeLoadLevel();
00613                 m_game->SetCurrentLevelToSavedState();
00614                 m_updateState = UpdateEngineState::ResourcesLoaded;
00615
00616             }, task_continuation_context::use_current());
00617         }
00618         else
00619         {
00620             // The game is not in the middle of a level so there aren't any level
00621             // resources to load.  Creating a no-op task so that in both cases
00622             // the same continuation logic is used.
00623             return create_task([]()
00624             {
00625             });
00626         }
00627
00628     }, task_continuation_context::use_current()).then([this]()
00629     {
00630         // Since Device lost is an unexpected event, the app visual state
00631         // may be snapped or not have focus.  Put the state machine
00632         // into the correct state to reflect these cases.
00633         if (ApplicationView::Value == ApplicationViewState::Snapped)
00634         {
00635             m_updateStateNext = m_updateState;
00636             m_updateState = UpdateEngineState::Snapped;
00637             m_controller->Active(false);
00638             HideGameInfoOverlay();
00639             SetSnapped();
00640             m_renderNeeded = true;
00641         }
00642         else if (!m_haveFocus)
00643         {
00644             m_updateStateNext = m_updateState;
00645             m_updateState = UpdateEngineState::Deactivated;
00646             m_controller->Active(false);
00647             SetAction(GameInfoOverlayCommand::None);
00648             m_renderNeeded = true;
00649         }
00650
00651         if (m_onRenderingEventToken.Value == 0)
00652         {
00653             // Add the OnRendering Callback to make sure that an update happens.
00654             m_onRenderingEventToken = CompositionTarget::Rendering::add(ref new EventHandler<Object^>(this, &App::OnRendering));
00655         }
00656
00657     }, task_continuation_context::use_current());
00658 }
00659
00660 //--------------------------------------------------------------------------------------
00661
00662 void App::UpdateViewState()
00663 {
00664     if (ApplicationView::Value == ApplicationViewState::Snapped)
00665     {
00666         switch (m_updateState)
00667         {
00668         case UpdateEngineState::Dynamics:
00669             // From Dynamic mode, when coming out of SNAPPED layout rather than going directly back into game play
00670             // go to the paused state waiting for user input to continue
00671             m_updateStateNext = UpdateEngineState::WaitingForPress;
00672             m_pressResult = PressResultState::ContinueLevel;
00673             SetGameInfoOverlay(GameInfoOverlayState::Pause);
00674             SetAction(GameInfoOverlayCommand::TapToContinue);
00675             m_game->PauseGame();
00676             break;
00677
00678         case UpdateEngineState::WaitingForResources:
00679         case UpdateEngineState::WaitingForPress:
00680             // Avoid corrupting the m_updateStateNext on a transition from Snapped -> Snapped.
00681             // Otherwise just cache the current state and return to it when leaving SNAPPED layout
00682
00683             m_updateStateNext = m_updateState;
00684             break;
00685
00686         default:
00687             break;
00688         }
00689
00690         m_updateState = UpdateEngineState::Snapped;
00691         m_controller->Active(false);
00692         HideGameInfoOverlay();
00693         SetSnapped();
00694         m_renderNeeded = true;
00695     }
00696     else if (ApplicationView::Value == ApplicationViewState::Filled ||
00697         ApplicationView::Value == ApplicationViewState::FullScreenLandscape ||
00698         ApplicationView::Value == ApplicationViewState::FullScreenPortrait)
00699     {
00700         if (m_updateState == UpdateEngineState::Snapped)
00701         {
00702             HideSnapped();
00703             ShowGameInfoOverlay();
00704             m_renderNeeded = true;
00705
00706             if (m_haveFocus)
00707             {
00708                 if (m_updateStateNext == UpdateEngineState::WaitingForPress)
00709                 {
00710                     SetAction(GameInfoOverlayCommand::TapToContinue);
00711                     m_controller->WaitForPress();
00712                 }
00713                 else if (m_updateStateNext == UpdateEngineState::WaitingForResources)
00714                 {
00715                     SetAction(GameInfoOverlayCommand::PleaseWait);
00716                 }
00717
00718                 m_updateState = m_updateStateNext;
00719             }
00720             else
00721             {
00722                 m_updateState = UpdateEngineState::Deactivated;
00723                 SetAction(GameInfoOverlayCommand::None);
00724             }
00725         }
00726         else if (m_updateState == UpdateEngineState::Dynamics)
00727         {
00728             // In Dynamic mode, when a resize event happens, go to the paused state waiting for user input to continue.
00729             m_pressResult = PressResultState::ContinueLevel;
00730             SetGameInfoOverlay(GameInfoOverlayState::Pause);
00731             m_game->PauseGame();
00732             if (m_haveFocus)
00733             {
00734                 m_updateState = UpdateEngineState::WaitingForPress;
00735                 SetAction(GameInfoOverlayCommand::TapToContinue);
00736                 m_controller->WaitForPress();
00737             }
00738             else
00739             {
00740                 m_updateState = UpdateEngineState::Deactivated;
00741                 SetAction(GameInfoOverlayCommand::None);
00742             }
00743             ShowGameInfoOverlay();
00744             m_renderNeeded = true;
00745         }
00746
00747         if (m_haveFocus && m_onRenderingEventToken.Value == 0)
00748         {
00749             // App is now "active" so set up the event handler to do game processing and rendering
00750             m_onRenderingEventToken = CompositionTarget::Rendering::add(ref new EventHandler<Object^>(this, &App::OnRendering));
00751         }
00752     }
00753 }
00754
00755 //--------------------------------------------------------------------------------------
00756
00757 void App::SetGameInfoOverlay(GameInfoOverlayState state)
00758 {
00759     m_gameInfoOverlayState = state;
00760     switch (state)
00761     {
00762     case GameInfoOverlayState::Loading:
00763         m_mainPage->SetGameLoading();
00764         break;
00765
00766     case GameInfoOverlayState::GameStats:
00767         m_mainPage->SetGameStats(
00768             m_game->HighScore().levelCompleted + 1,
00769             m_game->HighScore().totalHits,
00770             m_game->HighScore().totalShots
00771             );
00772         break;
00773
00774     case GameInfoOverlayState::LevelStart:
00775         m_mainPage->SetLevelStart(
00776             m_game->LevelCompleted() + 1,
00777             m_game->CurrentLevel()->Objective(),
00778             m_game->CurrentLevel()->TimeLimit(),
00779             m_game->BonusTime()
00780             );
00781         break;
00782
00783     case GameInfoOverlayState::GameOverCompleted:
00784         m_mainPage->SetGameOver(
00785             true,
00786             m_game->LevelCompleted() + 1,
00787             m_game->TotalHits(),
00788             m_game->TotalShots(),
00789             m_game->HighScore().totalHits
00790             );
00791         break;
00792
00793     case GameInfoOverlayState::GameOverExpired:
00794         m_mainPage->SetGameOver(
00795             false,
00796             m_game->LevelCompleted(),
00797             m_game->TotalHits(),
00798             m_game->TotalShots(),
00799             m_game->HighScore().totalHits
00800             );
00801         break;
00802
00803     case GameInfoOverlayState::Pause:
00804         m_mainPage->SetPause(
00805             m_game->LevelCompleted() + 1,
00806             m_game->TotalHits(),
00807             m_game->TotalShots(),
00808             m_game->TimeRemaining()
00809             );
00810         break;
00811     }
00812 }
00813
00814 //--------------------------------------------------------------------------------------
00815
00816 void App::SetAction(GameInfoOverlayCommand command)
00817 {
00818     m_mainPage->SetAction(command);
00819 }
00820
00821 //--------------------------------------------------------------------------------------
00822
00823 void App::ShowGameInfoOverlay()
00824 {
00825     m_mainPage->ShowGameInfoOverlay();
00826 }
00827
00828 //--------------------------------------------------------------------------------------
00829
00830 void App::HideGameInfoOverlay()
00831 {
00832     m_mainPage->HideGameInfoOverlay();
00833 }
00834
00835 //--------------------------------------------------------------------------------------
00836
00837 void App::SetSnapped()
00838 {
00839     m_mainPage->SetSnapped();
00840 }
00841
00842 //--------------------------------------------------------------------------------------
00843
00844 void App::HideSnapped()
00845 {
00846     m_mainPage->HideSnapped();
00847 }
00848
00849 //--------------------------------------------------------------------------------------
00850
00851 void App::ResetGame()
00852 {
00853     m_updateState = UpdateEngineState::WaitingForResources;
00854     m_pressResult = PressResultState::PlayLevel;
00855     m_controller->Active(false);
00856     m_game->LoadGame();
00857     SetAction(GameInfoOverlayCommand::PleaseWait);
00858     SetGameInfoOverlay(GameInfoOverlayState::LevelStart);
00859     ShowGameInfoOverlay();
00860     m_renderNeeded = true;
00861
00862     m_game->LoadLevelAsync().then([this]()
00863     {
00864         m_game->FinalizeLoadLevel();
00865         m_updateState = UpdateEngineState::ResourcesLoaded;
00866         m_renderNeeded = true;
00867
00868     }, task_continuation_context::use_current());
00869 }
00870
00871 //--------------------------------------------------------------------------------------
00872
00873 void App::InitializeLicense()
00874 {
00875 #ifdef USE_STORE_SIMULATOR
00876     m_licenseState = ref new PersistentState();
00877     m_licenseState->Initialize(ApplicationData::Current->LocalSettings->Values, "CurrentAppSimulator");
00878     m_isTrial = m_licenseState->LoadBool(":isTrial", true);
00879
00880     Platform::String^ license;
00881     if (this->m_isTrial)
00882     {
00883         license = "TrialLicense.xml";
00884     }
00885     else
00886     {
00887         license = "FullLicense.xml";
00888     }
00889     task<StorageFile^> fileTask(Package::Current->InstalledLocation->GetFileAsync(license));
00890     fileTask.then([=](StorageFile^ sourceFile)
00891     {
00892         return create_task(CurrentAppSimulator::ReloadSimulatorAsync(sourceFile));
00893     }).then([this]()
00894     {
00895             this->InitializeLicenseCore();
00896     });
00897 #else
00898     this->InitializeLicenseCore();
00899 #endif
00900 }
00901
00902 //--------------------------------------------------------------------------------------
00903
00904 void App::InitializeLicenseCore()
00905 {
00906 #ifdef USE_STORE_SIMULATOR
00907     this->m_licenseInformation = CurrentAppSimulator::LicenseInformation;
00908     task<ListingInformation^> listingTask(CurrentAppSimulator::LoadListingInformationAsync());
00909 #else
00910     m_licenseInformation = CurrentApp::LicenseInformation;
00911     task<ListingInformation^> listingTask(CurrentApp::LoadListingInformationAsync());
00912 #endif
00913
00914     this->m_licenseInformation->LicenseChanged += ref new LicenseChangedEventHandler(this, &App::OnLicenseChanged);
00915     this->m_mainPage->SetProductItems(nullptr, m_licenseInformation);
00916     this->OnLicenseChanged();
00917
00918     listingTask.then([=](ListingInformation^ listing)
00919     {
00920         this->m_listingInformation = listing;
00921         this->OnLicenseChanged();
00922     });
00923 }
00924
00925 //--------------------------------------------------------------------------------------
00926
00927 #ifdef USE_STORE_SIMULATOR
00928 void App::ResetLicense()
00929 {
00930     task<StorageFile^> fileTask(Package::Current->InstalledLocation->GetFileAsync("TrialLicense.xml"));
00931     fileTask.then([=](StorageFile^ sourceFile)
00932     {
00933         CurrentAppSimulator::ReloadSimulatorAsync(sourceFile);
00934     });
00935 }
00936 #endif
00937
00938 //--------------------------------------------------------------------------------------
00939
00940 void App::OnLicenseChanged()
00941 {
00942 #ifdef USE_STORE_SIMULATOR
00943     m_isTrial = (m_licenseInformation->IsActive && m_licenseInformation->IsTrial);
00944     m_licenseState->SaveBool(":isTrial", m_isTrial);
00945 #endif
00946     m_mainPage->LicenseChanged(m_listingInformation, m_licenseInformation);
00947     m_game->UpdateGameConfig(m_licenseInformation);
00948
00949     if (m_licenseInformation->IsActive)
00950     {
00951         if (m_licenseInformation->IsTrial)
00952         {
00953             m_renderer->Hud()->SetLicenseInfo("Trial Version");
00954         }
00955         else
00956         {
00957             m_renderer->Hud()->SetLicenseInfo("Full Version");
00958         }
00959     }
00960     else
00961     {
00962         m_renderer->Hud()->SetLicenseInfo("License Inactive - defaulting to Trial Version");
00963     }
00964
00965     m_renderNeeded = true;
00966 }
00967
00968 //--------------------------------------------------------------------------------------
00969
00970 void App::SetBackground(unsigned int background)
00971 {
00972     m_game->SetBackground(background);
00973     m_renderNeeded = true;
00974 }
00975
00976 //--------------------------------------------------------------------------------------
00977
00978 void App::CycleBackground()
00979 {
00980     m_game->CycleBackground();
00981     m_renderNeeded = true;
00982 }
00983
00984 //--------------------------------------------------------------------------------------
00985
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/common/LayoutAwarePage.cpp Source File

  • User domain name
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page3.xaml.h Source File

  • XAML AppBar control

Page3.xaml.h

Go to the documentation of this file.
00001 ﻿//
00002 // Page3.xaml.h
00003 // Declaration of the Page3 class
00004 //
00005
00006 #pragma once
00007
00008 #include "Page3.g.h"
00009 #include "MainPage.xaml.h"
00010
00011 namespace AppBarControl
00012 {
00013   /// <summary>
00014   /// An empty page that can be used on its own or navigated to within a Frame.
00015   /// </summary>
00016   [Windows::Foundation::Metadata::WebHostHidden]
00017   public ref class Page3 sealed
00018   {
00019   public:
00020     Page3();
00021
00022   protected:
00023     virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00024
00025   private:
00026     void Back_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00027     void RemoveSaveButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00028     void AddFavoriteButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00029     static MainPage^ rootPage;
00030   };
00031 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/DirectXApp.h Source File

  • XInput game controller

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "SimpleController.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032     void OnVisibilityChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(
00038         _In_ Platform::Object^ sender
00039         );
00040
00041     void OnActivated(
00042         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00043         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00044         );
00045
00046     void OnSuspending(
00047         _In_ Platform::Object^ sender,
00048         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00049         );
00050
00051     void OnResuming(
00052         _In_ Platform::Object^ sender,
00053         _In_ Platform::Object^ args
00054         );
00055
00056     void OnWindowClosed(
00057         _In_ Windows::UI::Core::CoreWindow^ sender,
00058         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00059         );
00060
00061     SimpleController^ m_renderer;
00062     bool m_windowClosed;
00063     bool m_windowVisible;
00064 };
00065
00066 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00067 {
00068 public:
00069     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00070 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/XAudio2SoundPlayer.h Source File

  • XAudio2 audio file playback

XAudio2SoundPlayer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010
00011 #include "DirectXBase.h"
00012
00013 #include "mmreg.h"
00014 #include <vector>
00015 #include <memory>
00016
00017 class XAudio2SoundPlayer
00018 {
00019     struct ImplData;
00020
00021     public:
00022         XAudio2SoundPlayer(uint32 sampleRate);
00023         ~XAudio2SoundPlayer();
00024
00025         size_t AddSound(_In_ WAVEFORMATEX* format, _In_ Platform::Array<byte>^ data);
00026         bool   PlaySound(size_t index);
00027         bool   StopSound(size_t index);
00028         bool   IsSoundPlaying(size_t index) const;
00029         size_t GetSoundCount() const;
00030
00031         void Suspend();
00032         void Resume();
00033
00034     private:
00035         interface IXAudio2*                     m_audioEngine;
00036         interface IXAudio2MasteringVoice*       m_masteringVoice;
00037         std::vector<std::shared_ptr<ImplData>>  m_soundList;
00038 };
00039
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/SampleOverlay.cpp Source File

  • Direct2D basic image effects

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput6.xaml.cpp Source File

  • Print

ScenarioInput6.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioInput6.xaml.cpp
00010 // Implementation of the ScenarioInput6 class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput6.xaml.h"
00015 #include "PreviewUnavailable.xaml.h"
00016 #include <robuffer.h>
00017 #include <wrl\client.h>
00018
00019 using namespace PrintSample;
00020
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::Graphics::Display;
00024 using namespace Windows::Graphics::Imaging;
00025 using namespace Windows::Graphics::Printing;
00026 using namespace Windows::Graphics::Printing::OptionDetails;
00027 using namespace Windows::UI;
00028 using namespace Windows::UI::Text;
00029 using namespace Windows::UI::Xaml::Controls;
00030 using namespace Windows::UI::Xaml::Documents;
00031 using namespace Windows::UI::Xaml::Media;
00032 using namespace Windows::UI::Xaml::Media::Imaging;
00033 using namespace Windows::UI::Xaml::Navigation;
00034 using namespace Windows::Storage;
00035 using namespace Windows::Storage::Streams;
00036
00037
00038 // Photo printing scenario
00039
00040 ScenarioInput6::ScenarioInput6()
00041 {
00042     InitializeComponent();
00043 }
00044
00045
00046 /// <summary>
00047 /// This is the event handler for PrintManager.PrintTaskRequested.
00048 /// In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified
00049 /// by PrintTaskRequestedEventArgs->Request->Deadline.
00050 /// Therefore, we use this handler to only create the print task.
00051 /// The print settings customization can be done when the print document source is requested.
00052 /// </summary>
00053 /// <param name="sender">The print manager for which a print task request was made.</param>
00054 /// <param name="e">The print taks request associated arguments.</param>
00055 void ScenarioInput6::PrintTaskRequested(PrintManager^ sender, PrintTaskRequestedEventArgs^ e)
00056 {
00057     auto printTaskRef = std::make_shared<PrintTask^>(nullptr);
00058     *printTaskRef = e->Request->CreatePrintTask("C++ Printing SDK Sample",
00059                                                 ref new PrintTaskSourceRequestedHandler([this, printTaskRef](PrintTaskSourceRequestedArgs^ args)
00060                                                 {
00061                                                     PrintTask^ printTask = *printTaskRef;
00062
00063                                                     PrintTaskOptionDetails^ printDetailedOptions = PrintTaskOptionDetails::GetFromPrintTaskOptions(printTask->Options);
00064
00065                                                     // Choose the printer options to be shown.
00066                                                     // The order in which the options are appended determines the order in which they appear in the UI
00067                                                     printDetailedOptions->DisplayedOptions->Clear();
00068                                                     printDetailedOptions->DisplayedOptions->Append(Windows::Graphics::Printing::StandardPrintTaskOptions::MediaSize);
00069                                                     printDetailedOptions->DisplayedOptions->Append(Windows::Graphics::Printing::StandardPrintTaskOptions::Copies);
00070
00071                                                     // Create a new list option.
00072                                                     PrintCustomItemListOptionDetails^ photoSize = printDetailedOptions->CreateItemListOption("photoSize", "Photo Size");
00073                                                     photoSize->AddItem("psFullPage", "Full Page");
00074                                                     photoSize->AddItem("ps4x6", "4 x 6 in");
00075                                                     photoSize->AddItem("ps5x7", "5 x 7 in");
00076                                                     photoSize->AddItem("ps8x10", "8 x 10 in");
00077
00078                                                     // Add the custom option to the option list.
00079                                                     printDetailedOptions->DisplayedOptions->Append("photoSize");
00080
00081                                                     PrintCustomItemListOptionDetails^ scaling = printDetailedOptions->CreateItemListOption("scaling", "Scaling");
00082                                                     scaling->AddItem("sShrinkToFit", "Shrink To Fit");
00083                                                     scaling->AddItem("sCrop", "Crop");
00084
00085                                                     // Add the custom option to the option list.
00086                                                     printDetailedOptions->DisplayedOptions->Append("scaling");
00087
00088                                                     // Set default orientation to landscape.
00089                                                     printTask->Options->Orientation = PrintOrientation::Landscape;
00090
00091                                                     // Register for print task option changed notifications.
00092                                                     printDetailedOptions->OptionChanged += ref new TypedEventHandler<PrintTaskOptionDetails^, PrintTaskOptionChangedEventArgs^>(this, &ScenarioInput6::PrintDetailedOptionsOptionChanged);
00093
00094                                                     // Print Task event handler is invoked when the print job is completed.
00095                                                     printTask->Completed += ref new TypedEventHandler<PrintTask^, PrintTaskCompletedEventArgs^>(
00096                                                     [=](PrintTask^ sender, PrintTaskCompletedEventArgs^ e)
00097                                                     {
00098                                                         auto callback = ref new Windows::UI::Core::DispatchedHandler(
00099                                                         [=]()
00100                                                         {
00101                                                             ClearPageCollection();
00102
00103                                                             // Reset image options to default values.
00104                                                             m_photoScale = Scaling::sShrinkToFit;
00105                                                             m_photoSize = PhotoSize::psFullPage;
00106
00107                                                             // Reset the current page description ( modify any size)
00108                                                             m_currentPageDescription = PageDescription();
00109
00110                                                             // Notify the user when the print operation fails.
00111                                                             if (e->Completion == Windows::Graphics::Printing::PrintTaskCompletion::Failed)
00112                                                             {
00113                                                                 RootPage->NotifyUser(ref new String(L"Failed to print."), NotifyType::ErrorMessage);
00114                                                             }
00115                                                         });
00116
00117                                                         Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, callback);
00118                                                     });
00119
00120                                                     // Set the document source.
00121                                                     args->SetSource(PrintDocumentSource);
00122                                                 }));
00123 }
00124
00125 /// <summary>
00126 /// Option change event handler
00127 /// </summary>
00128 /// <param name="sender">The print task option details for which an option changed.</param>
00129 /// <param name="args">The event arguments containing the id of the changed option.</param>
00130 void ScenarioInput6::PrintDetailedOptionsOptionChanged(PrintTaskOptionDetails^ sender, PrintTaskOptionChangedEventArgs^ args)
00131 {
00132     bool invalidatePreview = false;
00133
00134     // For this scenario we are interested only when the 2 custom options change (photoSize & scaling) in order to trigger a preview refresh.
00135     // Default options that change page aspect will trigger preview invalidation (refresh) automatically.
00136     // It is safe to ignore verifying other options and(or) combinations here because during Paginate event(CreatePrintPreviewPages) we check if the PageDescription changed.
00137     if (args->OptionId == nullptr)
00138         return;
00139
00140     String^ optionId = safe_cast<String^>(args->OptionId);
00141
00142     if (optionId == "photoSize")
00143     {
00144         IPrintOptionDetails^ photoSizeOption = sender->Options->Lookup(optionId);
00145         String^ photoSizeValue = safe_cast<String^>(photoSizeOption->Value);
00146
00147         if (photoSizeValue == "psFullPage")
00148         {
00149             m_photoSize = PhotoSize::psFullPage;
00150         }
00151         else if (photoSizeValue == "ps4x6")
00152         {
00153             m_photoSize = PhotoSize::ps4x6;
00154         }
00155         else if (photoSizeValue == "ps5x7")
00156         {
00157             m_photoSize = PhotoSize::ps5x7;
00158         }
00159         else if(photoSizeValue == "ps8x10")
00160         {
00161             m_photoSize = PhotoSize::ps8x10;
00162         }
00163         invalidatePreview = true;
00164     }
00165
00166     if (optionId == "scaling")
00167     {
00168         IPrintOptionDetails^ scalingOption = sender->Options->Lookup(optionId);
00169         String^ scalingValue = safe_cast<String^>(scalingOption->Value);
00170
00171         if (scalingValue == "sCrop")
00172         {
00173             m_photoScale = Scaling::sCrop;
00174         }
00175         if (scalingValue == "sShrinkToFit")
00176         {
00177             m_photoScale = Scaling::sShrinkToFit;
00178         }
00179         invalidatePreview = true;
00180     }
00181
00182     // Invalidate the preview if one of the 2 options (photoSize, scaling) changed.
00183     if (invalidatePreview)
00184     {
00185         RefreshPreview();
00186     }
00187 }
00188
00189 /// <summary>
00190 /// This is the event handler for Pagination.
00191 /// </summary>
00192 /// <param name="sender">The document for which pagination occurs.</param>
00193 /// <param name="e">The pagination event arguments containing the print options.</param>
00194 void ScenarioInput6::CreatePrintPreviewPages(Object^ sender, PaginateEventArgs^ e)
00195 {
00196     // A new "session" starts with each paginate event.
00197     InterlockedIncrement64(&m_requestCount);
00198
00199     PageDescription pageDescription;
00200
00201     // Get printer's page description.
00202     PrintTaskOptionDetails^ printDetailedOptions = PrintTaskOptionDetails::GetFromPrintTaskOptions(e->PrintTaskOptions);
00203     PrintPageDescription printPageDescription = e->PrintTaskOptions->GetPageDescription(0);
00204
00205     // Reset the error state
00206     printDetailedOptions->Options->Lookup("photoSize")->ErrorText = "";
00207
00208     // Compute the printing page description (page size & center printable area)
00209     pageDescription.PageSize = printPageDescription.PageSize;
00210
00211     pageDescription.Margin.Width = (std::max)(printPageDescription.ImageableRect.Left,
00212                                               printPageDescription.ImageableRect.Right - printPageDescription.PageSize.Width);
00213
00214     pageDescription.Margin.Height = (std::max)(printPageDescription.ImageableRect.Top,
00215                                                printPageDescription.ImageableRect.Bottom - printPageDescription.PageSize.Height);
00216
00217     pageDescription.ViewablePageSize.Width = printPageDescription.PageSize.Width - pageDescription.Margin.Width * 2;
00218     pageDescription.ViewablePageSize.Height = printPageDescription.PageSize.Height - pageDescription.Margin.Height * 2;
00219
00220     // Compute print photo area.
00221     switch (m_photoSize)
00222     {
00223         case PhotoSize::ps4x6:
00224                 pageDescription.PictureViewSize.Width = 4.0f * DPI96;
00225                 pageDescription.PictureViewSize.Height = 6.0f * DPI96;
00226                 break;
00227         case PhotoSize::ps5x7:
00228                 pageDescription.PictureViewSize.Width = 5.0f * DPI96;
00229                 pageDescription.PictureViewSize.Height = 7.0f * DPI96;
00230                 break;
00231         case PhotoSize::ps8x10:
00232                 pageDescription.PictureViewSize.Width = 8.0f * DPI96;
00233                 pageDescription.PictureViewSize.Height = 10.0f * DPI96;
00234                 break;
00235         case PhotoSize::psFullPage:
00236                 pageDescription.PictureViewSize.Width = pageDescription.ViewablePageSize.Width;
00237                 pageDescription.PictureViewSize.Height = pageDescription.ViewablePageSize.Height;
00238                 break;
00239     }
00240
00241     // Try to maximize the photo's size based on its aspect-ratio.
00242     if ((pageDescription.ViewablePageSize.Width > pageDescription.ViewablePageSize.Height) && (m_photoSize != PhotoSize::psFullPage))
00243     {
00244         auto swap = pageDescription.PictureViewSize.Width;
00245         pageDescription.PictureViewSize.Width = pageDescription.PictureViewSize.Height;
00246         pageDescription.PictureViewSize.Height = swap;
00247     }
00248
00249     pageDescription.IsContentCropped = m_photoScale == Scaling::sCrop;
00250
00251     // Recreate content only when :
00252     // - there is no current page description
00253     // - the current page description doesn't match the new one
00254     if (m_currentPageDescription != pageDescription)
00255     {
00256         ClearPageCollection();
00257
00258         PrintDocument^ printDocument = safe_cast<PrintDocument^>(sender);
00259
00260         if (pageDescription.PictureViewSize.Width > pageDescription.ViewablePageSize.Width ||
00261             pageDescription.PictureViewSize.Height > pageDescription.ViewablePageSize.Height)
00262         {
00263             printDetailedOptions->Options->Lookup("photoSize")->ErrorText = "Photo doesn’t fit on the selected paper";
00264
00265             // Inform preview that it has only 1 page to show.
00266             printDocument->SetPreviewPageCount(1, PreviewPageCountType::Intermediate);
00267
00268             // Add a custom "preview" unavailable page
00269             m_csPrintSync.lock();
00270             m_pageCollection[0] = ref new PreviewUnavailable(pageDescription.PageSize, pageDescription.ViewablePageSize);
00271             m_csPrintSync.unlock();
00272         }
00273         else
00274         {
00275             // Inform preview that is has #NumberOfPhotos pages to show.
00276             printDocument->SetPreviewPageCount(NumberOfPhotos, PreviewPageCountType::Intermediate);
00277         }
00278
00279         m_currentPageDescription = pageDescription;
00280     }
00281 }
00282
00283 /// <summary>
00284 /// This is the event handler for PrintDocument.GetPrintPreviewPage. It provides a specific print page preview,
00285 /// in the form of an UIElement, to an instance of PrintDocument.
00286 /// PrintDocument subsequently converts the UIElement into a page that the Windows print system can deal with.
00287 /// </summary>
00288 /// <param name="sender">The print documet.</param>
00289 /// <param name="e">Arguments containing the requested page preview.</param>
00290 void ScenarioInput6::GetPrintPreviewPage(Object^ sender, GetPreviewPageEventArgs^ e)
00291 {
00292     PrintDocument^ printDocument = safe_cast<PrintDocument^>(sender);
00293
00294     // Store a local copy of the request count to use later to determine if the computed page is out of date.
00295     // If the page preview is unavailable an async operation will generate the content.
00296     // When the operation completes there is a chance that a pagination request was already made therefore making this page outdated.
00297     // If the page is outdated throw away the result (don't call SetPreviewPage) since a new GetPrintPreviewPage will server that request.
00298     LONGLONG requestNumber = 0;
00299     InterlockedExchange64(&requestNumber, m_requestCount);
00300     int pageNumber = e->PageNumber;
00301
00302     UIElement^ page;
00303
00304     // Try to get the page if it was previously generated.
00305     m_csPrintSync.lock();
00306     auto result = m_pageCollection.find(pageNumber -1);
00307     if (result != m_pageCollection.end())
00308     {
00309         page = result->second;
00310     }
00311     m_csPrintSync.unlock();
00312
00313
00314     // Detect if the page is available.
00315     if (page != nullptr)
00316     {
00317         // Send the page to preview.
00318         printDocument->SetPreviewPage(pageNumber, page);
00319     }
00320     else
00321     {
00322         // The page is not available yet.
00323         GeneratePage(pageNumber, m_currentPageDescription).then(
00324         [=](UIElement^ page)
00325         {
00326             // If the ticket changed discard the result since the content is outdated.
00327             LONGLONG localRequestNumber = requestNumber;
00328             if(InterlockedCompareExchange64(&localRequestNumber, requestNumber, m_requestCount) == m_requestCount)
00329             {
00330                 // Store the page in the collection in case a pagination request is made but the content doesn't need to be regenerated.
00331                 m_csPrintSync.lock();
00332                 m_pageCollection[pageNumber - 1] = page;
00333
00334                 // Add the newly created page to the printing root which is part of the visual tree and force it to go
00335                 // through layout so that the linked containers correctly distribute the content inside them.
00336                 printingRoot->Children->Append(page);
00337                 printingRoot->InvalidateMeasure();
00338                 printingRoot->UpdateLayout();
00339                 m_csPrintSync.unlock();
00340
00341                 // Send the page to preview.
00342                 printDocument->SetPreviewPage(pageNumber, page);
00343             }
00344         });
00345     }
00346 }
00347
00348 /// <summary>
00349 /// This is the event handler for PrintDocument.AddPages. It provides all pages to be printed, in the form of
00350 /// UIElements, to an instance of PrintDocument. PrintDocument subsequently converts the UIElements
00351 /// into a pages that the Windows print system can deal with.
00352 /// </summary>
00353 /// <param name="sender">The print document.</param>
00354 /// <param name="e">Arguments containing the print task options.</param>
00355 void ScenarioInput6::AddPrintPages(Object^ sender, AddPagesEventArgs^ e)
00356 {
00357     PrintDocument^ printDocument = safe_cast<PrintDocument^>(sender);
00358
00359     // A list of tasks that will generate content for pages that are not ready at this point.
00360     std::vector<concurrency::task<void>> createPageTasks;
00361
00362     for(int i = 0; i < NumberOfPhotos; ++i)
00363     {
00364         UIElement^ page = nullptr;
00365
00366         m_csPrintSync.lock();
00367
00368         auto value = m_pageCollection.find(i);
00369         if (value != m_pageCollection.end())
00370         {
00371             page= value->second;
00372         }
00373
00374         m_csPrintSync.unlock();
00375
00376         if ( page != nullptr)
00377         {
00378             m_pageCollection[i] = page;
00379         }
00380
00381         // If the page is not ready create a task that will generate its content.
00382         createPageTasks.push_back(GeneratePage(i + 1, m_currentPageDescription).
00383                                   then([=](UIElement^ generatedPage)
00384                                   {
00385                                     m_pageCollection[i] = generatedPage;
00386                                   }));
00387     }
00388
00389     // Add the pages to the print document when content has been generated for all of them.
00390     concurrency::when_all(createPageTasks.begin(), createPageTasks.end()).
00391                  then([=]
00392                  {
00393                     std::for_each(m_pageCollection.begin(), m_pageCollection.end(), [=](std::pair<int, UIElement^> keyValue)
00394                     {
00395                         printDocument->AddPage(keyValue.second);
00396                     });
00397
00398                     // Indicate that all of the print pages have been provided.
00399                     printDocument->AddPagesComplete();
00400                  });
00401
00402     // Reset the current page description as soon as possible since the PrintTask.Completed event might fire later (long running job)
00403     m_currentPageDescription = PageDescription();
00404 }
00405
00406 /// <summary>
00407 /// Helper function used to triger a preview refresh
00408 /// </summary>
00409 void ScenarioInput6::RefreshPreview()
00410 {
00411     // Invalidate the preview in order to refresh cotent and trigger a pagination request.
00412     auto callback = ref new Windows::UI::Core::DispatchedHandler([this]()
00413                                                                  {
00414                                                                      CurrentPrintDocument->InvalidatePreview();
00415                                                                  });
00416
00417     Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, callback);
00418 }
00419
00420 /// <summary>
00421 /// Helper function that clears the page collection and also the pages attached to the "visual root".
00422 /// </summary>
00423 void ScenarioInput6::ClearPageCollection()
00424 {
00425     m_csPrintSync.lock();
00426
00427     m_pageCollection.clear();
00428     printingRoot->Children->Clear();
00429
00430     m_csPrintSync.unlock();
00431 }
00432
00433 /// <summary>
00434 /// Generic swap of 2 values
00435 /// </summary>
00436 /// <typeparam name="T">typename</typeparam>
00437 /// <param name="v1">Value 1</param>
00438 /// <param name="v2">Value 2</param>
00439 template<class T> static void ScenarioInput6::Swap(T& v1, T& v2)
00440 {
00441     T swap = v1;
00442     v1 = v2;
00443     v2 = swap;
00444 }
00445
00446 /// <summary>
00447 /// Generates a page containing a photo.
00448 /// The image will be rotated if detected that there is a gain from that regarding size (try to maximize photo size).
00449 /// </summary>
00450 /// <param name="photoNumber">The photo number.</param>
00451 /// <param name="pageDescription">The description of the printer page.</param>
00452 /// <returns>A task that will return the page.</returns>
00453 concurrency::task<UIElement^> ScenarioInput6::GeneratePage(int photoNumber, PageDescription pageDescription)
00454 {
00455     Canvas^ page = ref new Canvas();
00456     page->Width = pageDescription.PageSize.Width;
00457     page->Height = pageDescription.PageSize.Height;
00458
00459     Canvas^ viewablePage = ref new Canvas();
00460     viewablePage->Width = pageDescription.ViewablePageSize.Width;
00461     viewablePage->Height = pageDescription.ViewablePageSize.Height;
00462
00463     viewablePage->SetValue(Canvas::LeftProperty, pageDescription.Margin.Width);
00464     viewablePage->SetValue(Canvas::TopProperty, pageDescription.Margin.Height);
00465
00466     // The image "frame" which also acts as a viewport
00467     Grid^ photoView = ref new Grid();
00468     photoView->Width = pageDescription.PictureViewSize.Width;
00469     photoView->Height = pageDescription.PictureViewSize.Height;
00470
00471     // Center the frame.
00472     photoView->SetValue(Canvas::LeftProperty, (viewablePage->Width - photoView->Width) / 2);
00473     photoView->SetValue(Canvas::TopProperty, (viewablePage->Height - photoView->Height) / 2);
00474
00475     std::wostringstream imageUriStream;
00476     imageUriStream << "ms-appx:///Images/photo" << photoNumber << ".jpg";
00477
00478     String^ imageUri = ref new String(imageUriStream.str().data());
00479
00480     // Return an async task that will complete when the image is fully loaded.
00481     return LoadBitmap(ref new Uri(imageUri), pageDescription.PageSize.Width > pageDescription.PageSize.Height).then(
00482            [=](WriteableBitmap^ bitmap) -> UIElement^
00483            {
00484                if (bitmap != nullptr)
00485                {
00486                    Image^ image = ref new Image();
00487                    image->Source = bitmap;
00488                    image->HorizontalAlignment = Windows::UI::Xaml::HorizontalAlignment::Center;
00489                    image->VerticalAlignment = Windows::UI::Xaml::VerticalAlignment::Center;
00490
00491                    // Use the real image size when croping or if the image is smaller then the target area (prevent a scale-up).
00492                    if (m_photoScale == Scaling::sCrop || (bitmap->PixelWidth <= pageDescription.PictureViewSize.Width &&
00493                                                           bitmap->PixelHeight <= pageDescription.PictureViewSize.Height))
00494                    {
00495                        image->Stretch = Stretch::None;
00496                        image->Width = bitmap->PixelWidth;
00497                        image->Height = bitmap->PixelHeight;
00498                    }
00499
00500                    // Add the newly created image to the visual root.
00501                    photoView->Children->Append(image);
00502                    viewablePage->Children->Append(photoView);
00503                    page->Children->Append(viewablePage);
00504                }
00505
00506                 // Return the page with the image centered.
00507                 return page;
00508             });
00509 }
00510
00511 /// <summary>
00512 /// Loads an image from an uri source and performs a rotation based on the print target aspect.
00513 /// </summary>
00514 /// <param name="source">The location of the image.</param>
00515 /// <param name="landscape">A flag that indicates if the target (printer page) is in landscape mode.</param>
00516 /// <returns>A task that will return the loaded bitmap.</returns>
00517 concurrency::task<WriteableBitmap^> ScenarioInput6::LoadBitmap(Uri^ source, bool landscape)
00518 {
00519     return concurrency::create_task(StorageFile::GetFileFromApplicationUriAsync(source)).
00520             then([](StorageFile^ file)
00521             {
00522                 return file->OpenAsync(FileAccessMode::Read);
00523             }).then([](IRandomAccessStream^ stream)
00524             {
00525                 return BitmapDecoder::CreateAsync(stream);
00526             }).then([landscape](BitmapDecoder^ bitmapDecoder)
00527             {
00528                 BitmapTransform^ transform = ref new BitmapTransform();
00529                 transform->Rotation = BitmapRotation::None;
00530
00531                 unsigned int width = bitmapDecoder->PixelWidth;
00532                 unsigned int height = bitmapDecoder->PixelHeight;
00533
00534                 // Rotate the image to match the printing target orientation.
00535                 if (landscape && width < height)
00536                 {
00537                     transform->Rotation = BitmapRotation::Clockwise270Degrees;
00538                     Swap(width, height);
00539                 }
00540                 else if (!landscape && width > height)
00541                 {
00542                     transform->Rotation = BitmapRotation::Clockwise90Degrees;
00543                     Swap(width, height);
00544                 }
00545
00546                 return concurrency::create_task(bitmapDecoder->GetPixelDataAsync(BitmapPixelFormat::Bgra8,    // WriteableBitmap uses BGRA format.
00547                                                                                  BitmapAlphaMode::Straight,
00548                                                                                  transform,
00549                                                                                  ExifOrientationMode::IgnoreExifOrientation,    // This sample ignores Exif orientation.
00550                                                                                  ColorManagementMode::DoNotColorManage)).then(
00551                                     [width, height](PixelDataProvider^ pixelData) -> WriteableBitmap^
00552                                     {
00553                                         WriteableBitmap^ bitmap = ref new WriteableBitmap(static_cast<int>(width), static_cast<int>(height));
00554
00555                                         IBuffer^ bitmapBuffer = bitmap->PixelBuffer;
00556                                         Microsoft::WRL::ComPtr<IUnknown> spUnknown = reinterpret_cast<IUnknown*>(bitmapBuffer);
00557                                         Microsoft::WRL::ComPtr<IBufferByteAccess> spBufferAcces;
00558
00559                                         if (SUCCEEDED(spUnknown.As(&spBufferAcces)))
00560                                         {
00561                                             byte *buffer;
00562                                             if (SUCCEEDED(spBufferAcces->Buffer(&buffer)))
00563                                             {
00564                                                 // Copy the pixels in the WriteableBitmap.
00565                                                 auto pixelDataBuffer = pixelData->DetachPixelData();
00566                                                 memcpy_s(buffer, bitmapBuffer->Length, pixelDataBuffer->begin(), pixelDataBuffer->Length);
00567                                             }
00568                                         }
00569
00570                                         return bitmap;
00571                                     });
00572             });
00573 }
00574
00575 /// <summary>
00576 /// Invoked when this page is about to be displayed in a Frame.
00577 /// </summary>
00578 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00579 /// property is typically used to configure the page.</param>
00580 void ScenarioInput6::OnNavigatedTo(NavigationEventArgs^ e)
00581 {
00582     // Get a pointer to our main page.
00583     BasePrintPage::OnNavigatedTo(e);
00584
00585     // Enable modern printing.
00586     RegisterForPrinting();
00587 }
00588
00589 void ScenarioInput6::OnNavigatedFrom(NavigationEventArgs^ e)
00590 {
00591     UnregisterForPrinting() ;
00592 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ResourceLoading Member List

This is the complete list of members for ResourceLoading, including all inherited members.
__pad0__ | ResourceLoading |
CreateDeviceIndependentResources() override | ResourceLoading | [virtual]
CreateDeviceResources() override | ResourceLoading | [virtual]
CreateWindowSizeDependentResources() override | ResourceLoading | [virtual]
LoadInternalState(_In_ Windows::Foundation::Collections::IPropertySet^state) | ResourceLoading |
m_camera | ResourceLoading | [private]
m_constantBuffer | ResourceLoading | [private]
m_constantBufferData | ResourceLoading | [private]
m_controller | ResourceLoading | [private]
m_indexBuffer | ResourceLoading | [private]
m_indexCount | ResourceLoading | [private]
m_inputLayout | ResourceLoading | [private]
m_loadingComplete | ResourceLoading | [private]
m_pixelShader | ResourceLoading | [private]
m_sampleOverlay | ResourceLoading | [private]
m_sampler | ResourceLoading | [private]
m_textureSRV | ResourceLoading | [private]
m_vertexBuffer | ResourceLoading | [private]
m_vertexShader | ResourceLoading | [private]
Render() override | ResourceLoading | [virtual]
SaveInternalState(_In_ Windows::Foundation::Collections::IPropertySet^state) | ResourceLoading |
Update(float timeTotal, float timeDelta) | ResourceLoading |
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/Scenario1.xaml.h Source File

  • XAML animation library

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Animation
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/DirectXBase.h Source File

  • Direct2D composite effect modes

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Constants.cpp Source File

  • AtomPub

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "Retrieve", "SDKSample.AtomPub.Scenario1" },
00022     { "Create", "SDKSample.AtomPub.Scenario2" },
00023     { "Delete", "SDKSample.AtomPub.Scenario3" },
00024     { "Update", "SDKSample.AtomPub.Scenario4" }
00025 };
00026
00027 // The default values for the WordPress site.
00028 Platform::String^ CommonData::baseUri = "http://<YourWordPressSite>.wordpress.com/";
00029 Platform::String^ CommonData::user;
00030 Platform::String^ CommonData::password;
00031
00032 // The default Service Document and Edit 'URIs' for WordPress.
00033 Platform::String^ CommonData::editUri = "./wp-app.php/posts";
00034 Platform::String^ CommonData::serviceDocUri = "./wp-app.php/service";
00035 Platform::String^ CommonData::feedUri = "./?feed=atom";
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/MainPage.xaml.cpp Source File

  • Message dialog

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/MainPage.xaml.cpp Source File

  • XAML text display

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/Scenario1.xaml.h Source File

  • XAML user and custom controls

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace UserAndCustomControls
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Other_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/obj2vbo/obj2vbo.cpp Source File

  • Direct3D resource loading
  • obj2vbo

obj2vbo.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include <iostream>
00009 #include <sstream>
00010 #include <fstream>
00011 #include <vector>
00012 #include <map>
00013 #include "BasicMath.h"
00014
00015 using namespace std;
00016
00017 struct BasicVertex
00018 {
00019     float3 pos;  // position
00020     float3 norm; // surface normal vector
00021     float2 tex;  // texture coordinate
00022 };
00023
00024 struct IndexTriplet
00025 {
00026     unsigned short pos;
00027     unsigned short norm;
00028     unsigned short tex;
00029 };
00030
00031 bool operator <(const IndexTriplet& lhs, const IndexTriplet& rhs)
00032 {
00033     return memcmp(&lhs, &rhs, sizeof(IndexTriplet)) < 0;
00034 }
00035
00036 void usage()
00037 {
00038     cout << "usage: obj2vbo.exe [input obj] [output vbo] [/normalize]" << endl;
00039     cout << "  input obj    specifies the input OBJ mesh file" << endl;
00040     cout << "  output vbo   specifies the output VBO file" << endl;
00041     cout << "  /normalize   transform vertex positions to fit a unit bounding box about the origin" << endl;
00042 }
00043
00044 #pragma warning(disable : 4447)
00045
00046 int main(int argc, char *argv[])
00047 {
00048     // Parse arguments
00049
00050     if (argc < 3 || argc > 4)
00051     {
00052         usage();
00053         return -1;
00054     }
00055
00056     bool normalizePositions = false;
00057     if (argc == 4)
00058     {
00059         if (strcmp(argv[3], "/normalize") == 0)
00060         {
00061             normalizePositions = true;
00062         }
00063         else
00064         {
00065             usage();
00066             return -1;
00067         }
00068     }
00069
00070     ifstream objFile(argv[1], ifstream::in);
00071     if (!objFile.is_open())
00072     {
00073         cout << "error: could not open file \"" << argv[1] << "\" for read" << endl;
00074         return -1;
00075     }
00076
00077
00078     // Parse the object file
00079
00080     vector<float3> positions;
00081     vector<float3> normals;
00082     vector<float2> texcoords;
00083     vector<vector<IndexTriplet>> faces;
00084
00085     unsigned int lineNum = 1;
00086
00087     while (objFile.good())
00088     {
00089         string line;
00090         getline(objFile, line);
00091         istringstream lineStream(line);
00092
00093         // Parse the line if not a comment
00094         if (lineStream.peek() != '#')
00095         {
00096             string tag;
00097             lineStream >> tag;
00098
00099             // Warn on unsupported tags
00100             if (
00101                 tag.compare("mtllib") == 0 ||
00102                 tag.compare("o") == 0 ||
00103                 tag.compare("g") == 0 ||
00104                 tag.compare("usemtl") == 0 ||
00105                 tag.compare("s") == 0
00106                 )
00107             {
00108                 cout << argv[1] << "(" << lineNum << "): warning: BasicMesh VBO format does not support tag \"" << tag << "\"" << endl;
00109             }
00110
00111             // Parse the vertex position
00112             else if (tag.compare("v") == 0)
00113             {
00114                 float3 pos;
00115                 lineStream >> pos.x >> pos.y >> pos.z;
00116                 positions.push_back(pos);
00117             }
00118
00119             // Parse the vertex normal
00120             else if (tag.compare("vn") == 0)
00121             {
00122                 float3 norm;
00123                 lineStream >> norm.x >> norm.y >> norm.z;
00124                 normals.push_back(norm);
00125             }
00126
00127             // Parse the vertex texture coordinate
00128             else if (tag.compare("vt") == 0)
00129             {
00130                 float2 tex;
00131                 lineStream >> tex.x >> tex.y;
00132                 texcoords.push_back(tex);
00133             }
00134
00135             // Parse the face
00136             else if (tag.compare("f") == 0)
00137             {
00138                 vector<IndexTriplet> face;
00139                 while (lineStream.good())
00140                 {
00141                     string tripletString;
00142                     lineStream >> tripletString;
00143                     if (tripletString.size() > 0)
00144                     {
00145                         istringstream tripletStream(tripletString);
00146
00147                         IndexTriplet triplet;
00148                         triplet.pos = 0;
00149                         triplet.norm = 0;
00150                         triplet.tex = 0;
00151
00152                         // Parse the face triplet.  Valid formats include:
00153                         //  [pos] ...
00154                         //  [pos]/[tex] ...
00155                         //  [pos]/[tex]/[norm] ...
00156                         //  [pos]// [norm] ...
00157
00158                         tripletStream >> triplet.pos;
00159                         if (tripletStream.get() == '/')
00160                         {
00161                             if (tripletStream.peek() != '/')
00162                             {
00163                                 tripletStream >> triplet.tex;
00164                             }
00165                             if (tripletStream.get() == '/')
00166                             {
00167                                 tripletStream >> triplet.norm;
00168                             }
00169                         }
00170                         face.push_back(triplet);
00171                     }
00172                 }
00173                 faces.push_back(face);
00174             }
00175
00176             // Fail on unknown tag
00177             else if (tag.size() > 0)
00178             {
00179                 cout << argv[1] << "(" << lineNum << "): error: unknown tag \"" << tag << "\"" << endl;
00180             }
00181         }
00182         lineNum++;
00183     }
00184
00185     objFile.close();
00186
00187     if (positions.size() == 0 || faces.size() == 0)
00188     {
00189         cout << "error: obj file \"" << argv[1] << "\" contains no geometry" << endl;
00190         return -1;
00191     }
00192
00193     // Validate mesh data
00194
00195     for (auto face = faces.begin(); face != faces.end(); face++)
00196     {
00197         if (face->size() < 3)
00198         {
00199             cout << "error: face size " << face->size() << " invalid" << endl;
00200             return -1;
00201         }
00202         for (auto triplet = face->begin(); triplet != face->end(); triplet++)
00203         {
00204             if (triplet->pos > positions.size() || triplet->pos < 1)
00205             {
00206                 cout << "error: position index " << triplet->pos << " out of range" << endl;
00207                 return -1;
00208             }
00209             if (triplet->norm > normals.size() || triplet->norm < 0)
00210             {
00211                 cout << "error: normal index " << triplet->norm << " out of range" << endl;
00212                 return -1;
00213             }
00214             if (triplet->tex > texcoords.size() || triplet->tex < 0)
00215             {
00216                 cout << "error: texcoord index " << triplet->tex << " out of range" << endl;
00217                 return -1;
00218             }
00219         }
00220     }
00221
00222     // Get the bounding box and center of the mesh
00223
00224     float3 boxMin = positions[faces[0][0].pos - 1];
00225     float3 boxMax = boxMin;
00226     for (auto face = faces.begin(); face != faces.end(); face++)
00227     {
00228         for (auto triplet = face->begin(); triplet != face->end(); triplet++)
00229         {
00230             float3 pos = positions[triplet->pos - 1];
00231             boxMin.x = min(boxMin.x, pos.x);
00232             boxMin.y = min(boxMin.y, pos.y);
00233             boxMin.z = min(boxMin.z, pos.z);
00234             boxMax.x = max(boxMax.x, pos.x);
00235             boxMax.y = max(boxMax.y, pos.y);
00236             boxMax.z = max(boxMax.z, pos.z);
00237         }
00238     }
00239     float3 boxCenter = (boxMax+boxMin) / 2.0f;
00240
00241     // If specified in the arguments, normalize geometry to fit within a unit cube
00242
00243     if (normalizePositions)
00244     {
00245         float maxAxis = max(max(boxMax.x - boxMin.x, boxMax.y - boxMin.y), boxMax.z - boxMin.z);
00246         for (auto pos = positions.begin(); pos != positions.end(); pos++)
00247         {
00248             *pos = (*pos - boxCenter) / maxAxis;
00249         }
00250     }
00251
00252     // Generate missing normals using faceted technique
00253
00254     for (auto face = faces.begin(); face != faces.end(); face++)
00255     {
00256         float3 normal(0, 0, 0);
00257         bool normalGenerated = false;
00258         for (auto triplet = face->begin(); triplet != face->end(); triplet++)
00259         {
00260             if (!normalGenerated && triplet->norm == 0)
00261             {
00262                 for (auto triplet = face->begin(); triplet != face->end(); triplet++)
00263                 {
00264                     float3 posThis = positions[triplet->pos - 1];
00265                     float3 posPrev = positions[(triplet == face->begin() ? (face->end() - 1)->pos : (triplet - 1)->pos) - 1];
00266                     float3 posNext = positions[(triplet == face->end() - 1 ? (face->begin())->pos : (triplet + 1)->pos) - 1];
00267                     normal = normal + cross(posNext - posThis, posPrev - posThis);
00268                     triplet->norm = normals.size() + 1;
00269                 }
00270                 normals.push_back(normal);
00271                 normalGenerated = true;
00272             }
00273         }
00274     }
00275
00276     // Fill in missing texture coordinates with (0, 0)
00277
00278     bool missingTexcoordCreated = false;
00279     unsigned int missingTexcoordIndex = 0;
00280     for (auto face = faces.begin(); face != faces.end(); face++)
00281     {
00282         for (auto triplet = face->begin(); triplet != face->end(); triplet++)
00283         {
00284             if (triplet->tex == 0)
00285             {
00286                 if (!missingTexcoordCreated)
00287                 {
00288                     texcoords.push_back(float2(0.0f, 0.0f));
00289                     missingTexcoordIndex = texcoords.size();
00290                     missingTexcoordCreated = true;
00291                 }
00292                 triplet->tex = missingTexcoordIndex;
00293             }
00294         }
00295     }
00296
00297     // Generate unique vertices and convert counter-clockwise faces to clockwise triangles
00298
00299     vector<BasicVertex> vertices;
00300     vector<unsigned short> indices;
00301     map<IndexTriplet, unsigned short> tripletIndices;
00302     for (auto face = faces.begin(); face != faces.end(); face++)
00303     {
00304         for (auto triplet = face->begin(); triplet != face->end(); triplet++)
00305         {
00306             if (tripletIndices.find(*triplet) == tripletIndices.end())
00307             {
00308                 tripletIndices[*triplet] = static_cast<unsigned short>(vertices.size());
00309                 BasicVertex vertex;
00310                 vertex.pos = positions[triplet->pos - 1];
00311                 vertex.norm = normals[triplet->norm - 1];
00312                 vertex.tex = texcoords[triplet->tex - 1];
00313                 vertices.push_back(vertex);
00314             }
00315             if (triplet >= face->begin() + 2)
00316             {
00317                 indices.push_back(tripletIndices[*face->begin()]);
00318                 indices.push_back(tripletIndices[*triplet]);
00319                 indices.push_back(tripletIndices[*(triplet - 1)]);
00320             }
00321         }
00322     }
00323
00324     // Dump vertex and index data to the output VBO file
00325
00326     ofstream vboFile(argv[2], ofstream::out | ofstream::binary);
00327     if (!vboFile.is_open())
00328     {
00329         cout << "error: could not open file \"" << argv[2] << "\" for write" << endl;
00330         return -1;
00331     }
00332
00333     unsigned int numVertices = vertices.size();
00334     unsigned int numIndices = indices.size();
00335     vboFile.write(reinterpret_cast<char*>(&numVertices), sizeof(unsigned int));
00336     vboFile.write(reinterpret_cast<char*>(&numIndices), sizeof(unsigned int));
00337     vboFile.write(reinterpret_cast<char*>(&vertices[0]), sizeof(BasicVertex) * vertices.size());
00338     vboFile.write(reinterpret_cast<char*>(&indices[0]), sizeof(unsigned short) * indices.size());
00339
00340     vboFile.close();
00341
00342     return 0;
00343 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/TriColorValue.h Source File

  • UI Automation core window provider

TriColorValue.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #pragma once
00009
00010 #ifdef __cplusplus_winrt
00011 using namespace UiaCoreWindowProvider;
00012 #else
00013 using namespace ABI::UiaCoreWindowProvider;
00014 #endif
00015
00016 // Helper class for manipulating TriColorValues
00017 class TriColorValueHelper
00018 {
00019 public:
00020     static bool IsFirst(TriColorValue value)
00021     {
00022         return (value == TriColorValue::Red);
00023     }
00024
00025     static bool IsLast(TriColorValue value)
00026     {
00027         return (value == TriColorValue::Green);
00028     }
00029
00030     static TriColorValue NextValue(TriColorValue value)
00031     {
00032         return (TriColorValue)((int)value + 1);
00033     }
00034
00035     static TriColorValue PreviousValue(TriColorValue value)
00036     {
00037         return (TriColorValue)((int)value - 1);
00038     }
00039
00040     static HRESULT ValueToString(TriColorValue value, _Out_ BSTR *pszValue)
00041     {
00042         switch (value)
00043         {
00044         case TriColorValue::Red: *pszValue = SysAllocString(L"Red"); break;
00045         case TriColorValue::Green: *pszValue = SysAllocString(L"Green"); break;
00046         case TriColorValue::Yellow: *pszValue = SysAllocString(L"Yellow"); break;
00047         default: *pszValue = SysAllocString(L"Unknown Value"); break;
00048         }
00049         return (*pszValue != nullptr) ? S_OK : E_OUTOFMEMORY;
00050     }
00051 };
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Constants.h Source File

  • XAML Popup

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"XAML Popup");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Scenario1.xaml.h Source File

  • Background Transfer

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace BackgroundTransfer
00025     {
00026         struct GuidComparer
00027         {
00028           bool operator() (const Platform::Guid& lhs, const Platform::Guid& rhs) const
00029           {
00030               return false;
00031           }
00032         };
00033
00034         /// <summary>
00035         /// An empty page that can be used on its own or navigated to within a Frame.
00036         /// </summary>
00037       [Windows::Foundation::Metadata::WebHostHidden]
00038         public ref class Scenario1 sealed
00039         {
00040         public:
00041             Scenario1();
00042
00043         protected:
00044             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00045
00046         private:
00047             MainPage^ rootPage;
00048             Concurrency::cancellation_token_source* cancellationToken;
00049             std::map<int /*Platform::Guid*/, Windows::Networking::BackgroundTransfer::DownloadOperation^> activeDownloads;
00050
00051             void StartDownload_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00052             void CancelAll_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00053             void ResumeAll_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00054             void PauseAll_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00055             void HandleDownloadAsync(Windows::Networking::BackgroundTransfer::DownloadOperation^ download, boolean start);
00056             void DownloadProgress(
00057                 Windows::Foundation::IAsyncOperationWithProgress<Windows::Networking::BackgroundTransfer::DownloadOperation^, Windows::Networking::BackgroundTransfer::DownloadOperation^>^ operation,
00058                 Windows::Networking::BackgroundTransfer::DownloadOperation^);
00059             void DiscoverActiveDownloads();
00060             void LogException(Platform::String^ title, Platform::Exception^ ex);
00061             void MarshalLog(Platform::String^ value);
00062             void Log(Platform::String^ message);
00063             void LogStatus(Platform::String^ message, NotifyType type);
00064             ~Scenario1();
00065         };
00066     }
00067 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Mobile broadband account provisioning/C++/Util.cpp Source File

  • Mobile broadband account provisioning

Util.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Implementation of the Util class
00013 //
00014
00015 #include "pch.h"
00016 #include "Util.h"
00017
00018 using namespace SDKSample::ProvisioningAgent;
00019
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::UI::Xaml::Navigation;
00023 using namespace Windows::Data::Xml::Dom;
00024 using namespace Windows::System;
00025 using namespace Windows::Foundation;
00026 using namespace Platform;
00027
00028 Util::Util()
00029 {
00030 }
00031
00032 String^ Util::ParseErrorCode(String^ errorCode)
00033 {
00034     String^ returnStr = L"";
00035
00036     if (_wcsicmp(errorCode->Data(), L"80070490") == 0) // ERROR_NOT_FOUND
00037     {
00038         returnStr += L", description of error \"The given interface or subscriber ID is not present\", error code: "
00039             + errorCode;
00040     }
00041     else if (_wcsicmp(errorCode->Data(), L"80070426") == 0) // ERROR_SERVICE_NOT_ACTIVE
00042     {
00043         returnStr += L", description of error \"The service has not been started\", error code: "
00044             + errorCode;
00045     }
00046     else if (_wcsicmp(errorCode->Data(), L"80070015") == 0) // ERROR_NOT_READY
00047     {
00048         returnStr += L", description of error \"The device is not ready\", error code: "
00049             + errorCode;
00050     }
00051     else if (_wcsicmp(errorCode->Data(), L"80070037") == 0) // ERROR_DEV_NOT_EXIST
00052     {
00053         returnStr += L", description of error \"The specified network resource or device is no longer available\", error code: "
00054             + errorCode;
00055     }
00056     else if (_wcsicmp(errorCode->Data(), L"800704b6") == 0)// ERROR_BAD_PROFILE
00057     {
00058         returnStr += L", description of error \"The network connection profile is corrupted\", error code: "
00059             + errorCode;
00060     }
00061     else
00062     {
00063         returnStr += L", error code: " + errorCode;
00064     }
00065
00066     return returnStr;
00067 }
00068
00069 /* *
00070 * * Provisiong result XML looks like this:
00071 * *   <?xml version="1.0"?>
00072 * *   <CarrierProvisioningResults>
00073 * *       <MBNProfiles>
00074 * *           <DefaultProfile name="Foo1" errorCode="800704b6" />
00075 * *           <PurchaseProfile name="Foo2" errorCode="00000000 />
00076 * *           <Messages>
00077 * *                <Message position="1" errorCode="82170008" errorDetails="error description" />
00078 * *                <Message position="2" errorCode="00000000" errorDetails="error description" />
00079 * *                <Message position="3" errorCode="82170008" errorDetails="error description" />
00080 * *           </Messages>
00081 * *       </MBNProfiles>
00082 * *       <WLANProfiles errorCode="80070426" />
00083 * *       <Provisioning errorCode="82170008" />
00084 * *       <Plans>
00085 * *           <Plan name="PlanA" errorCode="00000000" />
00086 * *           <Plan name="PlanB" errorCode="82170012" />
00087 * *           <Plan name="PlanC" errorCode="00000000" />
00088 * *       </Plans>
00089 * *   </CarrierProvisioningResults>
00090 * */
00091 String^ Util::ParseResultXML(String^ resultsXml)
00092 {
00093     String^ resultStr = L"\nProvisioning Result:";
00094
00095     auto xmlDoc = ref new XmlDocument();
00096     xmlDoc->LoadXml(resultsXml);
00097
00098     auto errorCodeNodes = xmlDoc->SelectNodes(L"//*[@errorCode != '00000000']");
00099     if (errorCodeNodes->Length != 0)
00100     {
00101
00102         for (unsigned int index = 0; index < errorCodeNodes->Length; index++)
00103         {
00104             auto errorCodeNode = errorCodeNodes->Item(index);
00105             auto errorCode = ((errorCodeNode->Attributes)->GetNamedItem(L"errorCode"))->NodeValue;
00106             auto nodeName = (errorCodeNodes->Item(index))->NodeName;
00107             auto description = ParseErrorCode(dynamic_cast<String^>(errorCode));
00108
00109             if ((_wcsicmp(nodeName->Data(), L"MBNProfiles") == 0) ||
00110                 (_wcsicmp(nodeName->Data(), L"WLANProfiles") == 0) ||
00111                 (_wcsicmp(nodeName->Data(), L"Plans") == 0) ||
00112                 (_wcsicmp(nodeName->Data(), L"Provisioning") == 0))
00113             {
00114                 resultStr += L"\nError occured during provisioning at top level node \"" + nodeName +
00115                     L"\", and hence there will be no child node attached to this node" + description;
00116             }
00117             else if (_wcsicmp(nodeName->Data(), L"Message") == 0)
00118             {
00119                 auto messagePosition = ((errorCodeNode->Attributes)->GetNamedItem(L"position"))->NodeValue;
00120                 auto errorDetails = ((errorCodeNode->Attributes)->GetNamedItem(L"errorDetails"))->NodeValue;
00121                 resultStr += "\nError occured during provisioning Message[" + messagePosition + "], error code: " +
00122                     errorCode + ", error details: " + errorDetails;
00123             }
00124             else if ((_wcsicmp(nodeName->Data(), L"DefaultProfile") == 0) ||
00125                 (_wcsicmp(nodeName->Data(), L"PurchaseProfile") == 0) ||
00126                 (_wcsicmp(nodeName->Data(), L"WLANProfile") == 0) ||
00127                 (_wcsicmp(nodeName->Data(), L"Plan") == 0))
00128             {
00129                 auto nameAttribute = ((errorCodeNode->Attributes)->GetNamedItem(L"name"))->NodeValue;
00130                 resultStr += "\nError occured during provisioning " + nodeName + ", name: " +
00131                     nameAttribute + description;
00132             }
00133             else
00134             {
00135                 resultStr += "\nError occured during provisioning " + nodeName + ", error code: " + errorCode;
00136             }
00137         }
00138     }
00139
00140     return resultStr;
00141 }
00142
00143 String^ Util::PrintExceptionCode(Exception^ error)
00144 {
00145     String^ errorDescription = "";
00146
00147     wchar_t buf[5000];
00148     HRESULT hr = S_OK;
00149
00150     if (error->Message)
00151     {
00152         hr = StringCchPrintf(buf, ARRAYSIZE(buf), L"Unexpected exception occured:%s, error number: 0x%x", error->Message->Data(), error->HResult);
00153     }
00154     else
00155     {
00156         hr = StringCchPrintf(buf, ARRAYSIZE(buf), L"Unexpected exception occured, error number: 0x%x", error->HResult);
00157     }
00158
00159     if (FAILED(hr))
00160     {
00161         throw Exception::CreateException(hr);
00162     }
00163     errorDescription = ref new String(buf);
00164
00165     return errorDescription;
00166 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/common/LayoutAwarePage.h Source File

  • Bluetooth call control
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/pch.cpp Source File

  • Direct2D basic image effects

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/PortraitFlipped.xaml.cpp Source File

  • Device auto rotation preferences

PortraitFlipped.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PortraitFlipped.xaml.cpp
00013 // Implementation of the PortraitFlipped class
00014 //
00015
00016 #include "pch.h"
00017 #include "PortraitFlipped.xaml.h"
00018
00019 using namespace SDKSample::Rotation;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 PortraitFlipped::PortraitFlipped()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void PortraitFlipped::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040 }
00041
00042 void SDKSample::Rotation::PortraitFlipped::SetPortraitFlipped_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00043 {
00044     Button^ b = safe_cast<Button^>(sender);
00045     if (b != nullptr)
00046     {
00047         Windows::Graphics::Display::DisplayProperties::AutoRotationPreferences = Windows::Graphics::Display::DisplayOrientations::PortraitFlipped;
00048
00049         if (Windows::Graphics::Display::DisplayProperties::AutoRotationPreferences == Windows::Graphics::Display::DisplayOrientations::PortraitFlipped)
00050         {
00051             rootPage->NotifyUser("Succeeded: Preference set to Portrait Flipped.", NotifyType::StatusMessage);
00052         }
00053         else
00054         {
00055             rootPage->NotifyUser("Error: Failed to set the preference.", NotifyType::StatusMessage);
00056         }
00057     }
00058 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicShapes.h Source File

  • DirectX 3D shooting game

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/Scenario1.xaml.h Source File

  • Programmatic file search

Scenario1.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FileSearch
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario1 sealed
00030         {
00031         public:
00032             Scenario1();
00033
00034         private:
00035             void SearchButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036         };
00037     }
00038 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/StereoSimpleD3D.cpp Source File

  • Direct3D stereoscopic 3D

StereoSimpleD3D.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include <math.h>
00010 #include "StereoSimpleD3D.h"
00011 #include "BasicShapes.h"
00012 #include "BasicLoader.h"
00013
00014 using namespace Microsoft::WRL;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::UI::Core;
00017 using namespace Windows::UI::ViewManagement;
00018 using namespace Windows::Graphics::Display;
00019 using namespace D2D1;
00020 using namespace DirectX;
00021
00022 StereoSimpleD3D::StereoSimpleD3D()
00023 {
00024     m_stereoExaggerationFactor = 1.0f;
00025
00026     // Developer decided world unit: in this case, modeled in feet.
00027     // One world unit equals 1 foot. Therefore, m_worldScale * inches = 1 world unit.
00028     m_worldScale = 12.0f;
00029 }
00030
00031 void StereoSimpleD3D::CreateDeviceIndependentResources()
00032 {
00033     DirectXBase::CreateDeviceIndependentResources();
00034
00035     // Create a DirectWrite text format object.
00036     DX::ThrowIfFailed(
00037         m_dwriteFactory->CreateTextFormat(
00038             L"Segoe UI",                    // font family name
00039             nullptr,                        // system font collection
00040             DWRITE_FONT_WEIGHT_SEMI_BOLD,
00041             DWRITE_FONT_STYLE_NORMAL,
00042             DWRITE_FONT_STRETCH_NORMAL,
00043             40.0f,                          // font size
00044             L"en-US",                       // locale
00045             &m_textFormat
00046             )
00047         );
00048
00049     // Align the text horizontally.
00050     DX::ThrowIfFailed(
00051         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00052         );
00053
00054     // Align the text vertically.
00055     DX::ThrowIfFailed(
00056         m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00057         );
00058 }
00059
00060 void StereoSimpleD3D::CreateDeviceResources()
00061 {
00062     DirectXBase::CreateDeviceResources();
00063
00064     m_sampleOverlay = ref new SampleOverlay();
00065
00066     m_sampleOverlay->Initialize(
00067         m_d2dDevice.Get(),
00068         m_d2dContext.Get(),
00069         m_wicFactory.Get(),
00070         m_dwriteFactory.Get(),
00071         "Direct3D stereoscopic 3D sample"
00072         );
00073
00074     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00075
00076     loader->LoadShader(
00077         L"SimpleVertexShader.cso",
00078         nullptr,
00079         0,
00080         &m_vertexShader,
00081         &m_inputLayout
00082         );
00083
00084     // Create the vertex and index buffers for drawing the cube.
00085     BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());
00086
00087     shapes->CreateCube(
00088         &m_vertexBuffer,
00089         &m_indexBuffer,
00090         nullptr,
00091         &m_indexCount
00092         );
00093
00094     // Create the constant buffer for updating model and camera data.
00095     CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
00096     DX::ThrowIfFailed(
00097         m_d3dDevice->CreateBuffer(
00098             &constantBufferDescription,
00099             nullptr, // Leave the buffer uninitialized.
00100             &m_constantBuffer
00101             )
00102         );
00103
00104     loader->LoadShader(
00105         L"SimplePixelShader.cso",
00106         &m_pixelShader
00107         );
00108
00109     loader->LoadTexture(
00110         L"texture.dds",
00111         nullptr,
00112         &m_textureShaderResourceView
00113         );
00114
00115     // Create the sampler.
00116     D3D11_SAMPLER_DESC samplerDescription;
00117     ZeroMemory(&samplerDescription, sizeof(samplerDescription));
00118     samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
00119     samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
00120     samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
00121     samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
00122     samplerDescription.MipLODBias = 0.0f;
00123     samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
00124     samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
00125     samplerDescription.BorderColor[0] = 0.0f;
00126     samplerDescription.BorderColor[1] = 0.0f;
00127     samplerDescription.BorderColor[2] = 0.0f;
00128     samplerDescription.BorderColor[3] = 0.0f;
00129     samplerDescription.MinLOD = 0; // Allow use of all MIP levels.
00130     samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;
00131
00132     DX::ThrowIfFailed(
00133         m_d3dDevice->CreateSamplerState(
00134             &samplerDescription,
00135             &m_sampler
00136             )
00137         );
00138
00139     DX::ThrowIfFailed(
00140         m_d2dContext->CreateSolidColorBrush(
00141             D2D1::ColorF(D2D1::ColorF::White, 0.5f),
00142             &m_brush
00143             )
00144         );
00145 }
00146
00147 void StereoSimpleD3D::CreateWindowSizeDependentResources()
00148 {
00149     DirectXBase::CreateWindowSizeDependentResources();
00150
00151     if (m_stereoEnabled)
00152     {
00153         m_hintMessage = "Press up/down arrow keys to adjust stereo 3D exaggeration effect";
00154     }
00155     else
00156     {
00157         m_hintMessage = "Stereo 3D is not enabled on your system";
00158     }
00159
00160     m_projAspect = static_cast<float>(m_renderTargetSize.Width) / static_cast<float>(m_renderTargetSize.Height);
00161     m_nearZ = 0.01f;
00162     m_farZ = 100.0f;
00163
00164     // Initialize the view matrix.
00165     XMFLOAT3 Eye = XMFLOAT3(0.0f, 2.0f, 5.0f);
00166     XMFLOAT3 At = XMFLOAT3(0.0f, 0.0f, 0.0f);
00167     XMFLOAT3 Up = XMFLOAT3 (0.0f, 1.0f, 0.0f);
00168     XMStoreFloat4x4(
00169         &m_constantBufferData.view,
00170         XMMatrixLookAtRH(XMLoadFloat3(&Eye), XMLoadFloat3(&At), XMLoadFloat3(&Up))
00171         );
00172
00173     // Set camera parameters.
00174     m_widthInInches = m_renderTargetSize.Width / m_dpi;
00175     m_heightInInches = m_renderTargetSize.Height / m_dpi;
00176
00177     // Create the projection matrix parameters and set up the initial/mono projection matrix.
00178     StereoParameters params = CreateDefaultStereoParameters(m_widthInInches, m_heightInInches, m_worldScale, 0); // Mono uses zero exaggeration.
00179     XMStoreFloat4x4(
00180         &m_constantBufferData.projection,
00181         StereoProjectionFieldOfViewRightHand(params, m_nearZ, m_farZ, false) // Channel parameter doesn't matter for mono.
00182         );
00183
00184     m_sampleOverlay->UpdateForWindowSizeChange();
00185 }
00186
00187 // Override the default DirectXBase Render method. This class uses
00188 // its own RenderEye method instead.
00189 void StereoSimpleD3D::Render()
00190 {
00191 }
00192
00193 // Render function that supports both stereo and mono rendering.
00194 void StereoSimpleD3D::RenderEye(_In_ unsigned int eyeIndex)
00195 {
00196     ComPtr<ID3D11RenderTargetView> currentRenderTargetView;
00197
00198     // If eyeIndex == 1, set right render target view. Otherwise, set left render target view.
00199     currentRenderTargetView = eyeIndex ? m_d3dRenderTargetViewRight : m_d3dRenderTargetView;
00200
00201     // Bind the render targets.
00202     m_d3dContext->OMSetRenderTargets(
00203         1,
00204         currentRenderTargetView.GetAddressOf(),
00205         m_d3dDepthStencilView.Get()
00206         );
00207
00208     // Clear both the render target and depth stencil to default values.
00209     const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };
00210
00211     m_d3dContext->ClearRenderTargetView(
00212         currentRenderTargetView.Get(),
00213         ClearColor
00214         );
00215
00216     m_d3dContext->ClearDepthStencilView(
00217         m_d3dDepthStencilView.Get(),
00218         D3D11_CLEAR_DEPTH,
00219         1.0f,
00220         0
00221         );
00222
00223     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00224
00225     // Set the vertex and index buffers.
00226     UINT stride = sizeof(BasicVertex);
00227     UINT offset = 0;
00228     m_d3dContext->IASetVertexBuffers(
00229         0,                              // Start at the first vertex buffer slot.
00230         1,                              // Set one vertex buffer binding.
00231         m_vertexBuffer.GetAddressOf(),
00232         &stride,                        // Specify the size in bytes of a single vertex.
00233         &offset                         // Specify the base vertex in the buffer.
00234         );
00235
00236     m_d3dContext->IASetIndexBuffer(
00237         m_indexBuffer.Get(),
00238         DXGI_FORMAT_R16_UINT,   // Specify unsigned short index format.
00239         0                       // Specify the base index in the buffer.
00240         );
00241
00242     // Specify the way the vertex and index buffers define geometry.
00243     m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00244
00245     // Set the vertex shader stage state.
00246     m_d3dContext->VSSetShader(
00247         m_vertexShader.Get(),
00248         nullptr,                // Don't use shader linkage.
00249         0                       // Don't use shader linkage.
00250         );
00251
00252     m_d3dContext->VSSetConstantBuffers(
00253         0,                          // Start at the first constant buffer slot.
00254         1,                          // Set one constant buffer binding.
00255         m_constantBuffer.GetAddressOf()
00256         );
00257
00258     // Set the pixel shader stage state.
00259     m_d3dContext->PSSetShader(
00260         m_pixelShader.Get(),
00261         nullptr,                // Don't use shader linkage.
00262         0                       // Don't use shader linkage.
00263         );
00264
00265     m_d3dContext->PSSetShaderResources(
00266         0,                          // Start at the first shader resource slot.
00267         1,                          // Set one shader resource binding.
00268         m_textureShaderResourceView.GetAddressOf()
00269         );
00270
00271     m_d3dContext->PSSetSamplers(
00272         0,                          // Starting at the first sampler slot.
00273         1,                          // Set one sampler binding.
00274         m_sampler.GetAddressOf()
00275         );
00276
00277     // Draw the cube.
00278     m_d3dContext->DrawIndexed(
00279         m_indexCount,   // Draw all created vertices.
00280         0,              // Start with the first vertex.
00281         0               // Start with the first index.
00282         );
00283
00284     // Set the left/right Direct2D target bitmap.
00285     if (eyeIndex == 0)
00286     {
00287         m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00288     }
00289     else
00290     {
00291         m_d2dContext->SetTarget(m_d2dTargetBitmapRight.Get());
00292     }
00293
00294     m_sampleOverlay->Render();
00295
00296     // Render the hint message text with different margins depending on the view state.
00297     D2D1_RECT_F hintMessageRect;
00298     if (ApplicationView::Value == ApplicationViewState::Snapped)
00299     {
00300         hintMessageRect = D2D1::RectF(10.0f, 10.0f, m_windowBounds.Width - 10.0f, 500.0f);
00301     }
00302     else
00303     {
00304         hintMessageRect = D2D1::RectF(100.0f, 100.0f, 550.0f, 380.0f);
00305     }
00306
00307     m_d2dContext->BeginDraw();
00308     m_d2dContext->DrawText(
00309         m_hintMessage->Data(),
00310         m_hintMessage->Length(),
00311         m_textFormat.Get(),
00312         hintMessageRect,
00313         m_brush.Get()
00314         );
00315
00316     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00317     // is lost. It will be handled during the next call to Present.
00318     HRESULT hr = m_d2dContext->EndDraw();
00319     if (hr != D2DERR_RECREATE_TARGET)
00320     {
00321         DX::ThrowIfFailed(hr);
00322     }
00323 }
00324
00325 // Updates the stereo projection matrix and constant buffers based on the latest parameters.
00326 void StereoSimpleD3D::Update(
00327     _In_ unsigned int eyeIndex,
00328     _In_ float timeTotal,
00329     _In_ float timeDelta
00330     )
00331 {
00332     // Rotate the cube.
00333     XMStoreFloat4x4(
00334         &m_constantBufferData.model,
00335         XMMatrixRotationY(timeTotal)
00336         );
00337
00338     if (m_stereoEnabled)
00339     {
00340         StereoParameters parameters = CreateDefaultStereoParameters(m_widthInInches, m_heightInInches, m_worldScale, m_stereoExaggerationFactor);
00341         if (eyeIndex == 0)
00342         {
00343             XMStoreFloat4x4(
00344                 &m_constantBufferData.projection,
00345                 StereoProjectionFieldOfViewRightHand(parameters, m_nearZ, m_farZ, false)
00346                 );
00347         }
00348         else
00349         {
00350             XMStoreFloat4x4(
00351                 &m_constantBufferData.projection,
00352                 StereoProjectionFieldOfViewRightHand(parameters, m_nearZ, m_farZ, true)
00353                 );
00354         }
00355     }
00356
00357     // Transpose the matrices in the constant buffer.
00358     ConstantBuffer constantBuffer;
00359     XMStoreFloat4x4(
00360         &constantBuffer.model,
00361         XMMatrixTranspose(XMLoadFloat4x4(&m_constantBufferData.model))
00362         );
00363     XMStoreFloat4x4(
00364         &constantBuffer.view,
00365         XMMatrixTranspose(XMLoadFloat4x4(&m_constantBufferData.view))
00366         );
00367     XMStoreFloat4x4(
00368         &constantBuffer.projection,
00369         XMMatrixTranspose(XMLoadFloat4x4(&m_constantBufferData.projection))
00370         );
00371
00372     m_d3dContext->UpdateSubresource(m_constantBuffer.Get(), 0, nullptr, &constantBuffer, 0, 0);
00373 }
00374
00375 float StereoSimpleD3D::GetStereoExaggeration()
00376 {
00377     return m_stereoExaggerationFactor;
00378 }
00379
00380 void StereoSimpleD3D::SetStereoExaggeration(_In_ float currentExaggeration)
00381 {
00382     currentExaggeration = min(currentExaggeration, 2.0f);
00383     currentExaggeration = max(currentExaggeration, 0.0f);
00384     m_stereoExaggerationFactor = currentExaggeration;
00385 }
Generated on Sat Nov 23 2024 16:08:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/common/suspensionmanager.cpp Source File

  • USSD message management
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/pch.h Source File

  • XAML scrolling, panning, and zooming

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/Camera.cpp Source File

  • DirectX marble maze game

Camera.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007 ////----------------------------------------------------------------------
00008
00009 #include "pch.h"
00010 #include "Camera.h"
00011
00012 void Camera::GetViewMatrix(_Out_ float4x4 *viewMatrix)
00013 {
00014     *viewMatrix = m_view;
00015 }
00016
00017 void Camera::GetProjectionMatrix(_Out_ float4x4 *projectionMatrix)
00018 {
00019     *projectionMatrix = m_projection;
00020 }
00021
00022 // this method updates the view matrix based on new position and focus coordinates
00023 void Camera::SetViewParameters(
00024     _In_ float3 eyePosition,    // the position of the camera
00025     _In_ float3 lookPosition,   // the point the camera should look at
00026     _In_ float3 up              // the durection vector for up
00027     )
00028 {
00029     m_position = eyePosition;
00030     m_direction = normalize(lookPosition - eyePosition);
00031     float3 zAxis = m_direction;
00032     float3 xAxis = normalize(cross(up, zAxis));
00033     float3 yAxis = cross(zAxis, xAxis);
00034     float xOffset = -dot(xAxis, m_position);
00035     float yOffset = -dot(yAxis, m_position);
00036     float zOffset = -dot(zAxis, m_position);
00037     m_view = float4x4(
00038         xAxis.x, xAxis.y, xAxis.z, xOffset,
00039         yAxis.x, yAxis.y, yAxis.z, yOffset,
00040         zAxis.x, zAxis.y, zAxis.z, zOffset,
00041         0.0f,    0.0f,    0.0f,    1.0f
00042         );
00043 }
00044     // this method updates the projection matrix based on new parameters
00045 void Camera::SetProjectionParameters(
00046     _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00047     _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00048     _In_ float nearPlane,           // depth to map to 0
00049     _In_ float farPlane             // depth to map to 1
00050     )
00051 {
00052     float minScale = 1.0f / tan(minimumFieldOfView * PI_F / 360.0f);
00053     float xScale = 1.0f;
00054     float yScale = 1.0f;
00055     if (aspectRatio < 1.0f)
00056     {
00057         xScale = minScale;
00058         yScale = minScale * aspectRatio;
00059     }
00060     else
00061     {
00062         xScale = minScale / aspectRatio;
00063         yScale = minScale;
00064     }
00065     float zScale = farPlane / (farPlane - nearPlane);
00066     m_projection = float4x4(
00067         xScale, 0.0f,   0.0f,    0.0f,
00068         0.0f,   yScale, 0.0f,    0.0f,
00069         0.0f,   0.0f,   zScale, -nearPlane*zScale,
00070         0.0f,   0.0f,   1.0f,    0.0f
00071         );
00072 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/InkRenderer.cpp Source File

  • DirectX postcard app

InkRenderer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "InkRenderer.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::UI::Input;
00013 using namespace Windows::UI::Input::Inking;
00014 using namespace Windows::UI::Xaml::Input;
00015
00016 InkRenderer::InkRenderer() :
00017     m_inkState(InkState::StrokeCompleted),
00018     m_pointerId(0)
00019 {
00020     m_inkManager = ref new InkManager();
00021
00022     auto drawingAttributes = ref new InkDrawingAttributes();
00023     drawingAttributes->FitToCurve = true;
00024     drawingAttributes->Color = Windows::UI::Colors::Black;     // Opaque strokes.
00025     m_inkManager->SetDefaultDrawingAttributes(drawingAttributes);
00026
00027     m_inkManager->Mode = InkManipulationMode::Inking;
00028 }
00029
00030 void InkRenderer::CreateDeviceIndependentResources(ComPtr<ID2D1Factory1> d2dFactory)
00031 {
00032     // Save shared factory.
00033     m_d2dFactory = d2dFactory;
00034 }
00035
00036 void InkRenderer::CreateDeviceResources(ComPtr<ID2D1DeviceContext> d2dContext)
00037 {
00038     // Save shared device context.
00039     m_d2dContext = d2dContext;
00040
00041     // Create a solid black brush to render the ink.
00042     DX::ThrowIfFailed(
00043         m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::Black), &m_blackBrush)
00044         );
00045 }
00046
00047 void InkRenderer::CreateWindowSizeDependentResources(float dpi)
00048 {
00049     // Save shared DPI.
00050     m_dpi = dpi;
00051 }
00052
00053 void InkRenderer::DrawInk()
00054 {
00055     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00056
00057     // Render the strokes stored in the stroke geometry.
00058     if (!m_strokes.empty())
00059     {
00060         for (ComPtr<ID2D1PathGeometry> stroke : m_strokes)
00061         {
00062             m_d2dContext->DrawGeometry(
00063                 stroke.Get(),
00064                 m_blackBrush.Get(),
00065                 5.0f    // Stroke width.
00066                 );
00067         }
00068     }
00069
00070     // Render the current stroke.
00071     if (!m_currentStroke.empty())
00072     {
00073         auto previousPoint = m_currentStroke.at(0);
00074         D2D1_POINT_2F currentPoint;
00075         for (auto i = m_currentStroke.begin() + 1; i != m_currentStroke.end(); i++)
00076         {
00077             currentPoint = *i;
00078             m_d2dContext->DrawLine(
00079                 previousPoint,
00080                 currentPoint,
00081                 m_blackBrush.Get(),
00082                 5.0f
00083                 );
00084             previousPoint = currentPoint;
00085         }
00086     }
00087 }
00088
00089 void InkRenderer::StartSignature()
00090 {
00091     m_inkState = InkState::StrokeCompleted;
00092 }
00093
00094 void InkRenderer::Reset()
00095 {
00096     DeleteAllStrokes();
00097     m_inkState = InkState::StrokeCompleted;
00098 }
00099
00100 void InkRenderer::OnPointerPressed(_In_ PointerRoutedEventArgs^ args)
00101 {
00102     if (m_inkState != InkState::StrokeCompleted)
00103     {
00104         return;
00105     }
00106
00107     m_inkState = InkState::StrokeDrawing;
00108
00109     PointerPoint^ point = args->GetCurrentPoint(nullptr);
00110     m_pointerId = point->PointerId;
00111
00112     m_inkManager->ProcessPointerDown(point);
00113
00114     m_currentStroke.clear();
00115     m_currentStroke.push_back(D2D1::Point2F(point->Position.X, point->Position.Y));
00116 }
00117
00118 void InkRenderer::OnPointerReleased(_In_ PointerRoutedEventArgs^ args)
00119 {
00120     PointerPoint^ point = args->GetCurrentPoint(nullptr);
00121
00122     if (m_inkState != InkState::StrokeDrawing  || m_pointerId != point->PointerId)
00123     {
00124         return;
00125     }
00126
00127     m_inkState = InkState::StrokeCompleted;
00128
00129     auto rect = m_inkManager->ProcessPointerUp(point);
00130
00131     m_currentStroke.clear();
00132
00133     // Convert the last stroke in the ink manager to a path geometry for fast rendering.
00134     auto strokeView = m_inkManager->GetStrokes();
00135     auto strokeViewSize = strokeView->Size;
00136     if (strokeViewSize > 0)
00137     {
00138         auto lastStroke = strokeView->GetAt(strokeViewSize-1);
00139         ComPtr<ID2D1PathGeometry> strokeGeometry;
00140         ConvertStrokeToGeometry(lastStroke, &strokeGeometry);
00141         if (strokeGeometry != nullptr)
00142         {
00143             m_strokes.push_back(strokeGeometry);
00144         }
00145     }
00146 }
00147
00148 void InkRenderer::OnPointerMoved(_In_ PointerRoutedEventArgs^ args)
00149 {
00150     PointerPoint^ point = args->GetCurrentPoint(nullptr);
00151
00152     if (m_inkState == InkState::StrokeDrawing && m_pointerId == point->PointerId)
00153     {
00154         m_inkManager->ProcessPointerUpdate(point);
00155         m_currentStroke.push_back(D2D1::Point2F(point->Position.X, point->Position.Y));
00156     }
00157 }
00158
00159 void InkRenderer::DeleteAllStrokes()
00160 {
00161     auto strokes = m_inkManager->GetStrokes();
00162     for (auto stroke : strokes)
00163     {
00164         stroke->Selected = true;
00165     }
00166     m_inkManager->DeleteSelected();
00167     m_strokes.clear();
00168     m_currentStroke.clear();
00169 }
00170
00171 // Create a new path geometry and open a geometry sink.
00172 void InkRenderer::ConvertStrokeToGeometry(
00173     _In_ IInkStroke^ stroke,
00174     _Outptr_result_maybenull_ ID2D1PathGeometry** geometry
00175     )
00176 {
00177     *geometry = nullptr;
00178
00179     auto segments = stroke->GetRenderingSegments();
00180     auto segmentSize = segments->Size;
00181
00182     if (segmentSize == 0)
00183     {
00184         return;
00185     }
00186
00187     DX::ThrowIfFailed(
00188         m_d2dFactory->CreatePathGeometry(geometry)
00189         );
00190
00191     ComPtr<ID2D1GeometrySink> sink;
00192     DX::ThrowIfFailed(
00193         (*geometry)->Open(&sink)
00194         );
00195
00196     sink->SetSegmentFlags(D2D1_PATH_SEGMENT_FORCE_ROUND_LINE_JOIN);
00197     sink->SetFillMode(D2D1_FILL_MODE_ALTERNATE);
00198
00199     // Convert points and Bezier control points in each segment to a Bezier curve in the path geometry.
00200     auto segment = segments->GetAt(0);
00201     auto point = segment->Position;
00202     sink->BeginFigure(
00203         D2D1::Point2F(point.X, point.Y),
00204         D2D1_FIGURE_BEGIN_FILLED
00205         );
00206     for (uint32 j = 1; j < segmentSize; j++)
00207     {
00208         segment = segments->GetAt(j);
00209         point = segments->GetAt(j)->Position;
00210         sink->AddBezier(
00211             D2D1::BezierSegment(
00212                 D2D1::Point2F(segment->BezierControlPoint1.X, segment->BezierControlPoint1.Y),
00213                 D2D1::Point2F(segment->BezierControlPoint2.X, segment->BezierControlPoint2.Y),
00214                 D2D1::Point2F(point.X, point.Y)
00215                 )
00216             );
00217     }
00218     sink->EndFigure(D2D1_FIGURE_END_OPEN);
00219
00220     DX::ThrowIfFailed(
00221         sink->Close()
00222         );
00223 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/HubPhotoGroup.h Source File

  • Hilo C++
  • Hilo

HubPhotoGroup.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "IPhotoGroup.h"
00010
00011 namespace Hilo
00012 {
00013     interface class IPhoto;
00014     class ExceptionPolicy;
00015     class Repository;
00016
00017     // The HubPhotoGroup class provides data for the main hub page's grid control.
00018     [Windows::UI::Xaml::Data::Bindable]
00019     [Windows::Foundation::Metadata::WebHostHidden]
00020     public ref class HubPhotoGroup sealed : public IPhotoGroup, public Windows::UI::Xaml::Data::INotifyPropertyChanged
00021     {
00022     internal:
00023         HubPhotoGroup(Platform::String^ title, Platform::String^ emptyTitle, std::shared_ptr<Repository> repository, std::shared_ptr<ExceptionPolicy> exceptionPolicy);
00024         concurrency::task<void> QueryPhotosAsync();
00025
00026     public:
00027         virtual ~HubPhotoGroup();
00028
00029         virtual event Windows::UI::Xaml::Data::PropertyChangedEventHandler^ PropertyChanged;
00030
00031         property Platform::String^ Title
00032         {
00033             virtual Platform::String^ get();
00034         }
00035
00036         property Windows::Foundation::Collections::IObservableVector<IPhoto^>^ Items
00037         {
00038             virtual Windows::Foundation::Collections::IObservableVector<IPhoto^>^ get();
00039         }
00040
00041     private:
00042         Platform::String^ m_title;
00043         Platform::String^ m_emptyTitle;
00044         std::shared_ptr<Repository> m_repository;
00045         std::shared_ptr<ExceptionPolicy> m_exceptionPolicy;
00046         Platform::Collections::Vector<IPhoto^>^ m_photos;
00047         bool m_retrievedPhotos;
00048         bool m_receivedChangeWhileRunning;
00049         bool m_runningQuery;
00050         bool m_hasFileUpdateTask;
00051         ULONGLONG m_lastFileChangeTime;
00052
00053         void OnDataChanged();
00054         void ObserveFileChange();
00055         void OnPropertyChanged(Platform::String^ propertyName);
00056     };
00057 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/BooleanToBrushConverter.cpp Source File

  • Hilo C++
  • Hilo

BooleanToBrushConverter.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "BooleanToBrushConverter.h"
00009
00010 using namespace Hilo;
00011 using namespace Platform;
00012 using namespace Windows::UI::Xaml::Interop;
00013
00014 Object^ BooleanToBrushConverter::Convert(Object^ value, TypeName targetType, Object^ parameter, String^)
00015 {
00016     auto boxedBool = dynamic_cast<Box<bool>^>(value);
00017     auto boolValue = (boxedBool != nullptr && boxedBool->Value);
00018     return (boolValue ? "#FFF19720" : "#E2E2E2");
00019 }
00020
00021 Object^ BooleanToBrushConverter::ConvertBack(Object^ value, TypeName targetType, Object^ parameter, String^)
00022 {
00023     throw ref new NotImplementedException();
00024 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/App.xaml.h Source File

  • File and folder thumbnail

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/DDSTextureLoader.h Source File

  • DirectX postcard app

DDSTextureLoader.h

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.h
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #pragma once
00019
00020 void CreateDDSTextureFromMemory(
00021     _In_ ID3D11Device* d3dDevice,
00022     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
00023     _In_ size_t ddsDataSize,
00024     _Out_opt_ ID3D11Resource** texture,
00025     _Out_opt_ ID3D11ShaderResourceView** textureView,
00026     _In_ size_t maxsize = 0
00027     );
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/D3DPostProcessing.h Source File

  • Direct3D post-processing effects

D3DPostProcessing.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "BasicMath.h"
00012 #include "BasicCamera.h"
00013 #include "SampleOverlay.h"
00014
00015 // describes the constant buffer that will be used to draw the cube
00016 struct ConstantBuffer
00017 {
00018     float4x4 model;
00019     float4x4 view;
00020     float4x4 projection;
00021 };
00022
00023 static const int  numberOfGlowTextures = 2;
00024
00025 // Stuff used for drawing the "full screen quad"
00026 struct ScreenQuadVertex
00027 {
00028     float4 pos;
00029     float2 tex;
00030 };
00031
00032 // Constant buffer layout for transferring pixel size to downScaleBrightPass9 pixel shader (DX9 version)
00033
00034 struct ConstantBufferLayoutForDX9BrightPassPixelShader
00035 {
00036     float pixelWidth;   // Pixel width: will be 1.0 / intermediate render target width
00037     float pixelHeight;  // Pixel height will be 1.0 / intermediate render target height
00038 };
00039
00040 static const int blurKernelSpan = 15;
00041 static const int blurKernelMidPoint = 7;
00042
00043 // Constant buffer layout for transferring data to the Pixel Shader for glow effect
00044 struct ConstantBufferLayoutForGlowPixelShader
00045 {
00046     float4 sampleOffsets[blurKernelSpan];
00047     float4 sampleWeights[blurKernelSpan];
00048 };
00049
00050
00051 ref class D3DPostProcessing : public DirectXBase
00052 {
00053 internal:
00054     D3DPostProcessing();
00055
00056     virtual void HandleDeviceLost() override;
00057     virtual void CreateDeviceIndependentResources() override;
00058     virtual void CreateDeviceResources() override;
00059     virtual void CreateWindowSizeDependentResources() override;
00060     virtual void Render() override;
00061
00062     void Update(float timeTotal, float timeDelta);
00063
00064 private:
00065     SampleOverlay^                                      m_sampleOverlay;
00066
00067     Microsoft::WRL::ComPtr<ID3D11InputLayout>           m_inputLayout;                // cube vertex input layout
00068     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_vertexBuffer;               // cube vertex buffer
00069     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_indexBuffer;                // cube index buffer
00070     Microsoft::WRL::ComPtr<ID3D11VertexShader>          m_vertexShader;               // cube vertex shader
00071     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_pixelShader;                // cube pixel shader
00072     Microsoft::WRL::ComPtr<ID3D11Texture2D>             m_texture;                    // cube texture
00073     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_textureShaderResourceView;  // cube texture view
00074     Microsoft::WRL::ComPtr<ID3D11SamplerState>          m_sampler;                    // cube texture sampler
00075     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_constantBuffer;             // constant buffer resource
00076
00077     uint                                                m_indexCount;                  // cube index count
00078     ConstantBuffer                                      m_constantBufferData;          // constant buffer resource data
00079     BasicCamera^                                        m_camera;                      // scene camera
00080
00081     // Post Processing sample-specific members
00082     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>      m_intermediateTextureRenderTargetView;    // render target view
00083     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_intermediateTextureShaderResourceView;  // shader resource view
00084     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_quadVertexBuffer;                       // vertex buffer for full window quad
00085     Microsoft::WRL::ComPtr<ID3D11InputLayout>           m_quadLayout;                             // input layout for full window quad
00086     Microsoft::WRL::ComPtr<ID3D11VertexShader>          m_quadVertexShader;                       // vertex shader for full window quad
00087     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_brightPassConstantBuffer;               // constant buffer for DX9 brightness threshold pass pixel shader
00088     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_glowConstantBuffer;                     // constant buffer for Glow pixel shader
00089     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>      m_brightPassTextureRenderTargetView;      // render target view for brightPass texture
00090     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_brightPassTextureShaderResourceView;    // shader resource view for brightPass texture
00091     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>      m_glowTextureRenderTargetViews[numberOfGlowTextures];   // render target views
00092     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_glowTextureShaderResourceViews[numberOfGlowTextures]; // shader resource views
00093     uint                                                m_intermediateRenderTargetWidth;          // will be backbuffer width * 0.6f
00094     uint                                                m_intermediateRenderTargetHeight;         // will be backbuffer height * 0.6f
00095     uint                                                m_glowTextureWidth;                       // will be intermediate render target width / 4
00096     uint                                                m_glowTextureHeight;                      // will be intermediate render target height / 4
00097
00098     // Pixel shaders for Post Processing
00099     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_downScaleBrightPassPixelShader;         // brightness threshold pass pixel shader
00100     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_downScaleBrightPass9PixelShader;        // brightness threshold pass pixel shader for DX9 level hardware
00101     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_glowPixelShader;                        // glow/blur pixel shader
00102     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_finalPassPixelShader;                   // pixel shader to combine 3D cube scene and glow
00103     // Samplers for Post Processing
00104     Microsoft::WRL::ComPtr<ID3D11SamplerState>          m_pointSampler;                 // point sampler state for post processing shaders
00105     Microsoft::WRL::ComPtr<ID3D11SamplerState>          m_linearSampler;                // linear sampler state for post processing shaders
00106
00107     // Post Processing-specific private methods
00108     void       DrawQuad(ID3D11PixelShader* pixelShader, uint width, uint height);       // Use a pixel shader to render a quad of width and height
00109     void       BrightPassDownFilter();                                                  // Apply brightness threshold down scaling pixel shader on 3d cube scene
00110     void       RenderGlow();                                                            // Apply horizontal and vertical blur to brightness thresholded image -> glow
00111     void       CombineGlow();                                                           // Use the finalPassPixelShader to combine glow and 3d cube scene into backbuffer
00112
00113 };
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario6.xaml.h Source File

  • File access

Scenario6.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.h
00013 // Declaration of the Scenario6 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario6.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FileAccess
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario6 sealed
00030         {
00031         public:
00032             Scenario6();
00033
00034         private:
00035             MainPage^ rootPage;
00036
00037             void AddToListButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038             void ShowListButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039             void OpenFromListButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/MainPage.xaml.cpp Source File

  • App package information

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario1.xaml.cpp Source File

  • DatagramSocket

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace DatagramSocketSample;
00020
00021 using namespace Concurrency;
00022 using namespace Windows::ApplicationModel::Core;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::Networking::Sockets;
00025 using namespace Windows::UI::Core;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario1::Scenario1()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00043     // as NotifyUser()
00044     rootPage = MainPage::Current;
00045 }
00046
00047 void Scenario1::StartListener_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049     if (ServiceNameForListener->Text == nullptr)
00050     {
00051         rootPage->NotifyUser("Please provide a service name.", NotifyType::ErrorMessage);
00052         return;
00053     }
00054
00055     if (CoreApplication::Properties->HasKey("listener"))
00056     {
00057         rootPage->NotifyUser("This step has already been executed. Please move to the next one.", NotifyType::ErrorMessage);
00058         return;
00059     }
00060
00061     DatagramSocket^ listener = ref new DatagramSocket();
00062     ListenerContext^ listenerContext = ref new ListenerContext(rootPage, listener);
00063     listener->MessageReceived += ref new TypedEventHandler<DatagramSocket^, DatagramSocketMessageReceivedEventArgs^>(listenerContext, &ListenerContext::OnMessage);
00064
00065     // Events cannot be hooked up directly to the ScenarioInput1 object, as the object can fall out-of-scope and be deleted. This would render
00066     // any event hooked up to the object ineffective. The ListenerContext guarantees that both the socket and object that serves it's events have the same life time.
00067     CoreApplication::Properties->Insert("listener", listenerContext);
00068
00069     // Start listen operation.
00070     task<void>(listener->BindServiceNameAsync(ServiceNameForListener->Text)).then([this] (task<void> previousTask)
00071     {
00072         try
00073         {
00074             // Try getting an exception.
00075             previousTask.get();
00076             rootPage->NotifyUser("Listening", NotifyType::StatusMessage);
00077         }
00078         catch (Exception^ exception)
00079         {
00080             CoreApplication::Properties->Remove("listener");
00081             rootPage->NotifyUser("Start listening failed with error: " + exception->Message, NotifyType::ErrorMessage);
00082         }
00083     });
00084 }
00085
00086 void ListenerContext::OnMessage(DatagramSocket^ socket, DatagramSocketMessageReceivedEventArgs^ eventArguments)
00087 {
00088     if (outputStream != nullptr)
00089     {
00090         EchoMessage(eventArguments);
00091         return;
00092     }
00093
00094     // We do not have an output stream yet so create one.
00095     task<IOutputStream^>(socket->GetOutputStreamAsync(eventArguments->RemoteAddress, eventArguments->RemotePort)).then([this, socket, eventArguments] (IOutputStream^ stream)
00096     {
00097         // It might happen that the OnMessage was invoked more than once before the GetOutputStreamAsync completed.
00098         // In this case we will end up with multiple streams - make sure we have just one of it.
00099         EnterCriticalSection(&lock);
00100
00101         if (outputStream == nullptr)
00102         {
00103             outputStream = stream;
00104             hostName = eventArguments->RemoteAddress;
00105             port = eventArguments->RemotePort;
00106         }
00107
00108         LeaveCriticalSection(&lock);
00109
00110         EchoMessage(eventArguments);
00111     }).then([this, socket, eventArguments] (task<void> previousTask)
00112     {
00113         try
00114         {
00115             // Try getting all exceptions from the continuation chain above this point.
00116             previousTask.get();
00117         }
00118         catch (Exception^ exception)
00119         {
00120             NotifyUserFromAsyncThread("Getting an output stream failed with error: " + exception->Message, NotifyType::ErrorMessage);
00121         }
00122     });
00123 }
00124
00125 ListenerContext::ListenerContext(MainPage^ rootPage, DatagramSocket^ listener)
00126 {
00127     this->rootPage = rootPage;
00128     this->listener = listener;
00129     InitializeCriticalSectionEx(&lock, 0, 0);
00130 }
00131
00132 ListenerContext::~ListenerContext()
00133 {
00134     // The listener can be closed in two ways:
00135     //  - explicit: by using delete operator (the listener is closed even if there are outstanding references to it).
00136     //  - implicit: by removing last reference to it (i.e. falling out-of-scope).
00137     // In this case this is the last reference to the listener so both will yield the same result.
00138     delete listener;
00139     listener = nullptr;
00140
00141     DeleteCriticalSection(&lock);
00142 }
00143
00144 void ListenerContext::EchoMessage(DatagramSocketMessageReceivedEventArgs^ eventArguments)
00145 {
00146     if (!IsMatching(eventArguments->RemoteAddress, eventArguments->RemotePort))
00147     {
00148         // In the sample we are communicating with just one peer. To communicate with multiple peers application
00149         // should cache output streams (i.e. by using a hash map), because creating an output stream for each
00150         // received datagram is costly. Keep in mind though, that every cache requires logic to remove old
00151         // or unused elements; otherwise cache turns into a memory leaking structure.
00152         NotifyUserFromAsyncThread("Got datagram from " + eventArguments->RemoteAddress->DisplayName + ":" +
00153             eventArguments->RemotePort + ", but already 'connected' to " + hostName->DisplayName + ":" +
00154             port, NotifyType::ErrorMessage);
00155     }
00156
00157     task<unsigned int>(outputStream->WriteAsync(eventArguments->GetDataReader()->DetachBuffer())).then([this] (task<unsigned int> writeTask)
00158     {
00159         try
00160         {
00161             // Try getting an exception.
00162             writeTask.get();
00163         }
00164         catch (Exception^ exception)
00165         {
00166             NotifyUserFromAsyncThread("Echoing a message failed with error: " + exception->Message, NotifyType::ErrorMessage);
00167         }
00168     });
00169 }
00170
00171 bool ListenerContext::IsMatching(HostName^ hostName, String^ port)
00172 {
00173     return (this->hostName == hostName && this->port == port);
00174 }
00175
00176 void ListenerContext::NotifyUserFromAsyncThread(String^ message, NotifyType type)
00177 {
00178     rootPage->Dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this, message, type] ()
00179     {
00180         rootPage->NotifyUser(message, type);
00181     }));
00182 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXFractal.cpp Source File

  • Direct3D HLSL fractal generator

DirectXFractal.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXFractal.h"
00010 #include "BasicLoader.h"
00011
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::Foundation;
00014 using namespace Windows::Foundation::Collections;
00015 using namespace Windows::UI::Core;
00016
00017 DirectXFractal::DirectXFractal()
00018 {
00019     m_transform.scale = 4.0f;
00020     m_transform.rotation = 0.0f;
00021     m_transform.translationX = -0.6f;
00022     m_transform.translationY = 0.0f;
00023 }
00024
00025 void DirectXFractal::HandleDeviceLost()
00026 {
00027     // Release window size-dependent resources prior to creating a new device and swap chain.
00028     m_tempRTV[0] = nullptr;
00029     m_tempRTV[1] = nullptr;
00030     m_tempUAV = nullptr;
00031     m_tempSRV[0] = nullptr;
00032     m_tempSRV[1] = nullptr;
00033     m_finalRTV = nullptr;
00034     m_finalSRV = nullptr;
00035
00036     DirectXBase::HandleDeviceLost();
00037 }
00038
00039 void DirectXFractal::CreateDeviceIndependentResources()
00040 {
00041     DirectXBase::CreateDeviceIndependentResources();
00042
00043     // Create the performance throttler.
00044
00045     m_movingThrottle = ref new AutoThrottle(SampleSettings::Performance::TargetFrameTime);
00046 }
00047
00048 void DirectXFractal::DetermineFractalTechnique()
00049 {
00050     if (m_featureLevel >= D3D_FEATURE_LEVEL_11_0)
00051     {
00052         // DirectCompute is always available on 11.0 and higher feature levels.
00053         m_technique = FractalTechnique::DirectCompute;
00054
00055         // Additionally, double-precision is optionally available.  Where available,
00056         // this will enable deeper zoom into the fractal.
00057         D3D11_FEATURE_DATA_DOUBLES doubleFeatureData;
00058             DX::ThrowIfFailed(
00059                 m_d3dDevice->CheckFeatureSupport(
00060                     D3D11_FEATURE_DOUBLES,
00061                     &doubleFeatureData,
00062                     sizeof(doubleFeatureData)
00063                     )
00064                 );
00065         m_useDoubles = (doubleFeatureData.DoublePrecisionFloatShaderOps == TRUE);
00066     }
00067     else if (m_featureLevel >= D3D_FEATURE_LEVEL_10_0)
00068     {
00069         // Feature level 10.0 and 10.1 can optionally support DirectCompute.
00070         D3D11_FEATURE_DATA_D3D10_X_HARDWARE_OPTIONS computeFeatureData;
00071         DX::ThrowIfFailed(
00072             m_d3dDevice->CheckFeatureSupport(
00073                 D3D11_FEATURE_D3D10_X_HARDWARE_OPTIONS,
00074                 &computeFeatureData,
00075                 sizeof(computeFeatureData)
00076                 )
00077             );
00078
00079         if (computeFeatureData.ComputeShaders_Plus_RawAndStructuredBuffers_Via_Shader_4_x)
00080         {
00081             m_technique = FractalTechnique::DirectCompute;
00082         }
00083         else
00084         {
00085             m_technique = FractalTechnique::SinglePass;
00086         }
00087     }
00088     else
00089     {
00090         // The instruction count and register limitations of
00091         // feature level 9 shaders require multi-pass generation.
00092         m_technique = FractalTechnique::ThreePhase;
00093
00094         // Additionally, on feature level 9.1, only a handful of specific
00095         // texture formats are available for use as render targets.
00096         m_useUnormTextures = m_featureLevel < D3D_FEATURE_LEVEL_9_3;
00097     }
00098 }
00099
00100 void DirectXFractal::CreateDeviceResources()
00101 {
00102     DirectXBase::CreateDeviceResources();
00103
00104     DetermineFractalTechnique();
00105
00106     // Create vertex and index buffers.
00107     // These are sufficiently general that they can be used with all fractal generation techniques.
00108
00109     FractalVertex vertices[] =
00110     {
00111         { float2(-1.0f,  1.0f), float2(0.0f, 0.0f), float2(-0.5f,  0.5f) },
00112         { float2( 1.0f,  1.0f), float2(1.0f, 0.0f), float2( 0.5f,  0.5f) },
00113         { float2(-1.0f, -1.0f), float2(0.0f, 1.0f), float2(-0.5f, -0.5f) },
00114         { float2( 1.0f, -1.0f), float2(1.0f, 1.0f), float2( 0.5f, -0.5f) },
00115     };
00116
00117     D3D11_SUBRESOURCE_DATA vertexBufferData = {0};
00118     vertexBufferData.pSysMem = vertices;
00119     vertexBufferData.SysMemPitch = 0;
00120     vertexBufferData.SysMemSlicePitch = 0;
00121     CD3D11_BUFFER_DESC vertexBufferDesc(sizeof(vertices), D3D11_BIND_VERTEX_BUFFER);
00122     DX::ThrowIfFailed(
00123         m_d3dDevice->CreateBuffer(
00124             &vertexBufferDesc,
00125             &vertexBufferData,
00126             &m_vertexBuffer
00127             )
00128         );
00129
00130     uint16 indices[] =
00131     {
00132         0, 1, 2,
00133         1, 3, 2,
00134     };
00135     m_indexCount = ARRAYSIZE(indices);
00136
00137     D3D11_SUBRESOURCE_DATA indexBufferData = {0};
00138     indexBufferData.pSysMem = indices;
00139     indexBufferData.SysMemPitch = 0;
00140     indexBufferData.SysMemSlicePitch = 0;
00141     CD3D11_BUFFER_DESC indexBufferDesc(sizeof(indices), D3D11_BIND_INDEX_BUFFER);
00142     DX::ThrowIfFailed(
00143         m_d3dDevice->CreateBuffer(
00144             &indexBufferDesc,
00145             &indexBufferData,
00146             &m_indexBuffer
00147             )
00148         );
00149
00150     // Load all shaders and textures from the package.
00151
00152     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00153
00154     D3D11_INPUT_ELEMENT_DESC inputLayoutDesc[] =
00155     {
00156         { "POSITION", 0, DXGI_FORMAT_R32G32_FLOAT, 0,  0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00157         { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT, 0,  8, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00158         { "TEXCOORD", 1, DXGI_FORMAT_R32G32_FLOAT, 0, 16, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00159     };
00160
00161     loader->LoadShader(
00162         "DrawRect.vs.cso",
00163         inputLayoutDesc,
00164         ARRAYSIZE(inputLayoutDesc),
00165         &m_vertexShader,
00166         &m_inputLayout
00167         );
00168
00169     loader->LoadTexture(
00170         "gradient.dds",
00171         nullptr,
00172         &m_gradient
00173         );
00174
00175     if (m_technique == FractalTechnique::ThreePhase)
00176     {
00177         loader->LoadShader(
00178             m_useUnormTextures ? "Initial.unorm.ps.cso" : "Initial.ps.cso",
00179             &m_initialPS
00180             );
00181
00182         loader->LoadShader(
00183             m_useUnormTextures ? "Step.unorm.ps.cso" : "Step.ps.cso",
00184             &m_stepPS
00185             );
00186
00187         loader->LoadShader(
00188             m_useUnormTextures ? "Final.unorm.ps.cso" : "Final.ps.cso",
00189             &m_finalPS
00190             );
00191
00192         loader->LoadShader(
00193             "RenderTexture.ps.cso",
00194             &m_renderTexturePS
00195             );
00196     }
00197
00198     if (m_technique == FractalTechnique::SinglePass)
00199     {
00200         loader->LoadShader(
00201             "SinglePass.ps.cso",
00202             &m_singlePassPS
00203             );
00204
00205         loader->LoadShader(
00206             "RenderTexture.ps.cso",
00207             &m_renderTexturePS
00208             );
00209     }
00210
00211     if (m_technique == FractalTechnique::DirectCompute)
00212     {
00213         loader->LoadShader(
00214             m_useDoubles ? "DirectCompute.double.cs.cso" : "DirectCompute.cs.cso",
00215             &m_directComputeCS
00216             );
00217
00218         loader->LoadShader(
00219             "RenderBuffer.ps.cso",
00220             &m_renderBufferPS
00221             );
00222     }
00223
00224     // Create constant buffers.
00225
00226     CD3D11_BUFFER_DESC drawRectCBDesc(
00227         RoundUpTo16(sizeof(DrawRectCB)),
00228         D3D11_BIND_CONSTANT_BUFFER,
00229         D3D11_USAGE_DYNAMIC,
00230         D3D11_CPU_ACCESS_WRITE
00231         );
00232
00233     DX::ThrowIfFailed(
00234         m_d3dDevice->CreateBuffer(
00235             &drawRectCBDesc,
00236             nullptr,
00237             &m_drawRectCB
00238             )
00239         );
00240
00241     if (m_technique == FractalTechnique::DirectCompute)
00242     {
00243         CD3D11_BUFFER_DESC computeCBDesc(
00244             RoundUpTo16(
00245                 m_useDoubles ?
00246                 sizeof(ComputeDoubleCB) :
00247                 sizeof(ComputeCB)
00248                 ),
00249             D3D11_BIND_CONSTANT_BUFFER,
00250             D3D11_USAGE_DYNAMIC,
00251             D3D11_CPU_ACCESS_WRITE
00252             );
00253
00254         DX::ThrowIfFailed(
00255             m_d3dDevice->CreateBuffer(
00256                 &computeCBDesc,
00257                 nullptr,
00258                 &m_computeCB
00259                 )
00260             );
00261
00262         CD3D11_BUFFER_DESC bufferInfoCBDesc(
00263             RoundUpTo16(sizeof(int)),
00264             D3D11_BIND_CONSTANT_BUFFER,
00265             D3D11_USAGE_DYNAMIC,
00266             D3D11_CPU_ACCESS_WRITE
00267             );
00268
00269         DX::ThrowIfFailed(
00270             m_d3dDevice->CreateBuffer(
00271                 &bufferInfoCBDesc,
00272                 nullptr,
00273                 &m_bufferInfoCB
00274                 )
00275             );
00276     }
00277
00278     // Create texture samplers.
00279
00280     D3D11_SAMPLER_DESC samplerDesc;
00281     ZeroMemory(&samplerDesc, sizeof(D3D11_SAMPLER_DESC));
00282     samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_CLAMP;
00283     samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_CLAMP;
00284     samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_CLAMP;
00285     samplerDesc.MipLODBias = 0.0f;
00286     samplerDesc.MaxAnisotropy = 0;
00287     samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
00288     samplerDesc.BorderColor[0] = 0.0f;
00289     samplerDesc.BorderColor[1] = 0.0f;
00290     samplerDesc.BorderColor[2] = 0.0f;
00291     samplerDesc.BorderColor[3] = 0.0f;
00292     samplerDesc.MinLOD = 0;
00293     samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;
00294
00295     samplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_LINEAR;
00296     DX::ThrowIfFailed(
00297         m_d3dDevice->CreateSamplerState(
00298             &samplerDesc,
00299             &m_linearSampler
00300             )
00301         );
00302
00303     if (m_technique != FractalTechnique::DirectCompute)
00304     {
00305         samplerDesc.Filter = D3D11_FILTER_MIN_MAG_MIP_POINT;
00306         DX::ThrowIfFailed(
00307             m_d3dDevice->CreateSamplerState(
00308                 &samplerDesc,
00309                 &m_pointSampler
00310                 )
00311             );
00312     }
00313
00314     // Create the Sample Overlay.
00315
00316     m_sampleOverlay = ref new SampleOverlay();
00317
00318     m_sampleOverlay->Initialize(
00319         m_d2dDevice.Get(),
00320         m_d2dContext.Get(),
00321         m_wicFactory.Get(),
00322         m_dwriteFactory.Get(),
00323         "DirectX and DirectCompute fractal generator sample"
00324         );
00325 }
00326
00327 void DirectXFractal::CreateWindowSizeDependentResources()
00328 {
00329     DirectXBase::CreateWindowSizeDependentResources();
00330
00331     // Set the initial size of the intermediate render target.
00332     // This will be automatically refined based on performace measurements.
00333     m_downSampleRatio = SampleSettings::Performance::InitialDownSampleRatio;
00334
00335     // Force a regeneration of the fractal.
00336     m_fastGenerate = true;
00337     m_complete = false;
00338
00339     if (m_technique == FractalTechnique::DirectCompute)
00340     {
00341         // Create a buffer to save completed fractal calculations.
00342         m_bufferWidth =
00343             ((static_cast<int>(m_renderTargetSize.Width) + SampleSettings::DirectCompute::ThreadGroupSizeX - 1) /
00344             SampleSettings::DirectCompute::ThreadGroupSizeX) *
00345             SampleSettings::DirectCompute::ThreadGroupSizeX; // round up elements per row to match group dimension
00346         m_bufferHeight = static_cast<int>(m_renderTargetSize.Height);
00347
00348         ComPtr<ID3D11Buffer> tempBuffer;
00349         CD3D11_BUFFER_DESC tempBufferDesc(
00350             sizeof(FractalBufferElement) * m_bufferWidth * m_bufferHeight,
00351             D3D11_BIND_SHADER_RESOURCE | D3D11_BIND_UNORDERED_ACCESS,
00352             D3D11_USAGE_DEFAULT,
00353             0,
00354             D3D11_RESOURCE_MISC_BUFFER_STRUCTURED,
00355             sizeof(FractalBufferElement)
00356             );
00357         DX::ThrowIfFailed(
00358             m_d3dDevice->CreateBuffer(
00359                 &tempBufferDesc,
00360                 nullptr,
00361                 &tempBuffer
00362                 )
00363             );
00364
00365         CD3D11_SHADER_RESOURCE_VIEW_DESC tempSRVDesc(
00366             tempBuffer.Get(),
00367             DXGI_FORMAT_UNKNOWN,
00368             0,
00369             m_bufferWidth * m_bufferHeight
00370             );
00371         DX::ThrowIfFailed(
00372             m_d3dDevice->CreateShaderResourceView(
00373                 tempBuffer.Get(),
00374                 &tempSRVDesc,
00375                 &m_tempSRV[0]
00376                 )
00377             );
00378
00379         CD3D11_UNORDERED_ACCESS_VIEW_DESC tempUAVDesc(
00380             tempBuffer.Get(),
00381             DXGI_FORMAT_UNKNOWN,
00382             0,
00383             m_bufferWidth * m_bufferHeight
00384             );
00385         DX::ThrowIfFailed(
00386             m_d3dDevice->CreateUnorderedAccessView(
00387                 tempBuffer.Get(),
00388                 &tempUAVDesc,
00389                 &m_tempUAV
00390                 )
00391             );
00392
00393         // Update the buffer info constant buffer.
00394
00395         D3D11_MAPPED_SUBRESOURCE mappedResource;
00396         DX::ThrowIfFailed(
00397             m_d3dContext->Map(
00398                 m_bufferInfoCB.Get(),
00399                 0,
00400                 D3D11_MAP_WRITE_DISCARD,
00401                 0,
00402                 &mappedResource
00403                 )
00404             );
00405
00406         *static_cast<int*>(mappedResource.pData) = m_bufferWidth;
00407
00408         m_d3dContext->Unmap(
00409             m_bufferInfoCB.Get(),
00410             0
00411             );
00412     }
00413
00414     if (m_technique == FractalTechnique::ThreePhase)
00415     {
00416         // Create two intermediate textures to save partially completed fractal calculations.
00417         for (int i = 0; i < 2; i++)
00418         {
00419             ComPtr<ID3D11Texture2D> tempTexture;
00420             CD3D11_TEXTURE2D_DESC tempTextureDesc(
00421                 m_useUnormTextures ?
00422                     DXGI_FORMAT_R8G8B8A8_UNORM :
00423                     DXGI_FORMAT_R16G16B16A16_FLOAT,
00424                 static_cast<UINT>(m_renderTargetSize.Width),
00425                 static_cast<UINT>(m_renderTargetSize.Height),
00426                 1,
00427                 1,
00428                 D3D11_BIND_SHADER_RESOURCE | D3D11_BIND_RENDER_TARGET
00429                 );
00430             DX::ThrowIfFailed(
00431                 m_d3dDevice->CreateTexture2D(
00432                     &tempTextureDesc,
00433                     nullptr,
00434                     &tempTexture
00435                     )
00436                 );
00437
00438             CD3D11_RENDER_TARGET_VIEW_DESC tempRTVDesc(
00439                 tempTexture.Get(),
00440                 D3D11_RTV_DIMENSION_TEXTURE2D
00441                 );
00442             DX::ThrowIfFailed(
00443                 m_d3dDevice->CreateRenderTargetView(
00444                     tempTexture.Get(),
00445                     &tempRTVDesc,
00446                     &m_tempRTV[i]
00447                     )
00448                 );
00449
00450             CD3D11_SHADER_RESOURCE_VIEW_DESC tempSRVDesc(
00451                 tempTexture.Get(),
00452                 D3D11_SRV_DIMENSION_TEXTURE2D
00453                 );
00454             DX::ThrowIfFailed(
00455                 m_d3dDevice->CreateShaderResourceView(
00456                     tempTexture.Get(),
00457                     &tempSRVDesc,
00458                     &m_tempSRV[i]
00459                     )
00460                 );
00461         }
00462     }
00463
00464     if (m_technique != FractalTechnique::DirectCompute)
00465     {
00466         // Create a texture to save the full-resolution fractal once generated.
00467
00468         CD3D11_TEXTURE2D_DESC tempTextureDesc(
00469             DXGI_FORMAT_R8G8B8A8_UNORM,
00470             static_cast<UINT>(m_renderTargetSize.Width),
00471             static_cast<UINT>(m_renderTargetSize.Height),
00472             1,
00473             1,
00474             D3D11_BIND_SHADER_RESOURCE | D3D11_BIND_RENDER_TARGET
00475             );
00476         ComPtr<ID3D11Texture2D> tempTexture;
00477         DX::ThrowIfFailed(
00478             m_d3dDevice->CreateTexture2D(
00479                 &tempTextureDesc,
00480                 nullptr,
00481                 &tempTexture
00482                 )
00483             );
00484
00485         CD3D11_RENDER_TARGET_VIEW_DESC finalRTVDesc(
00486             tempTexture.Get(),
00487             D3D11_RTV_DIMENSION_TEXTURE2D
00488             );
00489         DX::ThrowIfFailed(
00490             m_d3dDevice->CreateRenderTargetView(
00491                 tempTexture.Get(),
00492                 &finalRTVDesc,
00493                 &m_finalRTV
00494                 )
00495             );
00496
00497         CD3D11_SHADER_RESOURCE_VIEW_DESC finalSRVDesc(
00498             tempTexture.Get(),
00499             D3D11_SRV_DIMENSION_TEXTURE2D
00500             );
00501         DX::ThrowIfFailed(
00502             m_d3dDevice->CreateShaderResourceView(
00503                 tempTexture.Get(),
00504                 &finalSRVDesc,
00505                 &m_finalSRV
00506                 )
00507             );
00508     }
00509
00510     m_sampleOverlay->UpdateForWindowSizeChange();
00511 }
00512
00513 void DirectXFractal::Update(float timeTotal, float timeDelta)
00514 {
00515     if (m_fastGenerate)
00516     {
00517         // Only update throttle settings if the performance-sensitive code path is being utilized.
00518
00519         auto control = m_movingThrottle->Update(timeDelta);
00520
00521         if (control == FrameWorkload::Increase)
00522         {
00523             m_downSampleRatio -= SampleSettings::Performance::DownSampleRatioDeltaDecrease;
00524         }
00525         if (control == FrameWorkload::Decrease)
00526         {
00527             m_downSampleRatio += SampleSettings::Performance::DownSampleRatioDeltaIncrease;
00528         }
00529         if (control != FrameWorkload::Maintain)
00530         {
00531             m_downSampleRatio = max(1.0f, min(SampleSettings::Performance::DownSampleRatioMax, m_downSampleRatio));
00532         }
00533     }
00534 }
00535
00536 void DirectXFractal::Render()
00537 {
00538     // Initialize the fractal target size to equal the screen render target size.
00539     float2 targetSize = float2(
00540         m_renderTargetSize.Width,
00541         m_renderTargetSize.Height
00542         );
00543
00544     // If the fractal is being manipulated, scale back the target size in order to reduce
00545     // frame workload, enabling more responsive manipulation.  If the fractal is not being
00546     // manipulated, iterate at the full resolution.
00547     if (m_fastGenerate)
00548     {
00549         targetSize.x = floor(targetSize.x / m_downSampleRatio);
00550         targetSize.y = floor(targetSize.y / m_downSampleRatio);
00551     }
00552
00553     // Calculate the fractal boundary transformation matrix.
00554     double4x4 boundsTransform = identityDouble();
00555     boundsTransform = mulDouble(boundsTransform, translationDouble(m_transform.translationX, m_transform.translationY, 0.0));
00556     boundsTransform = mulDouble(boundsTransform, rotationZDouble(m_transform.rotation));
00557     boundsTransform = mulDouble(boundsTransform, scaleDouble(m_transform.scale, m_transform.scale, 1.0));
00558     boundsTransform = mulDouble(boundsTransform, scaleDouble(1.0, m_windowBounds.Height / m_windowBounds.Width, 1.0));
00559
00560     // Update constant buffers.
00561     D3D11_MAPPED_SUBRESOURCE mappedResource = {0};
00562     DX::ThrowIfFailed(
00563         m_d3dContext->Map(
00564             m_drawRectCB.Get(),
00565             0,
00566             D3D11_MAP_WRITE_DISCARD,
00567             0,
00568             &mappedResource
00569             )
00570         );
00571
00572     DrawRectCB* drawRectCB = static_cast<DrawRectCB*>(mappedResource.pData);
00573
00574     drawRectCB->boundsTransform = convert(boundsTransform);
00575
00576     if (m_technique == FractalTechnique::DirectCompute)
00577     {
00578         // When using the DirectCompute generation technique, the buffer is rendered using
00579         // indexed access, so scaling the pixel shader tex coordinate to matching values
00580         // makes this task simpler.
00581         drawRectCB->texScale = targetSize;
00582     }
00583     else
00584     {
00585         if (m_fastGenerate)
00586         {
00587             // If fast generation is used, only a portion of the intermediate texture is drawn.
00588             drawRectCB->texScale.x = targetSize.x / m_renderTargetSize.Width;
00589             drawRectCB->texScale.y = targetSize.y / m_renderTargetSize.Height;
00590         }
00591         else
00592         {
00593             // Otherwise, the entire texture is drawn.
00594             drawRectCB->texScale = float2(1.0f, 1.0f);
00595         }
00596     }
00597
00598     m_d3dContext->Unmap(
00599         m_drawRectCB.Get(),
00600         0
00601         );
00602
00603     if (m_technique == FractalTechnique::DirectCompute)
00604     {
00605         // Update DirectCompute-specific constant buffers.
00606         DX::ThrowIfFailed(
00607             m_d3dContext->Map(
00608                 m_computeCB.Get(),
00609                 0,
00610                 D3D11_MAP_WRITE_DISCARD,
00611                 0,
00612                 &mappedResource
00613                 )
00614             );
00615
00616         // This constant buffer provides information on how to map a particular compute thread to
00617         // a coordinate in the complex plane, and how to map that to an index in the structured buffer.
00618         double2 topLeftCorner = mulDouble(double2(-0.5, 0.5), boundsTransform);
00619         double2 deltaAllDtidX = mulDouble(double2(0.5, 0.5), boundsTransform) - topLeftCorner;
00620         double2 deltaAllDtidY = mulDouble(double2(-0.5, -0.5), boundsTransform) - topLeftCorner;
00621
00622         if (m_useDoubles)
00623         {
00624             ComputeDoubleCB* computeCB = static_cast<ComputeDoubleCB*>(mappedResource.pData);
00625
00626             computeCB->originDtid00.x = topLeftCorner.x;
00627             computeCB->originDtid00.y = topLeftCorner.y;
00628             computeCB->deltaPerDtidX.x = deltaAllDtidX.x / targetSize.x;
00629             computeCB->deltaPerDtidX.y = deltaAllDtidX.y / targetSize.x;
00630             computeCB->deltaPerDtidY.x = deltaAllDtidY.x / targetSize.y;
00631             computeCB->deltaPerDtidY.y = deltaAllDtidY.y / targetSize.y;
00632         }
00633         else
00634         {
00635             ComputeCB* computeCB = static_cast<ComputeCB*>(mappedResource.pData);
00636
00637             computeCB->originDtid00.x = static_cast<float>(topLeftCorner.x);
00638             computeCB->originDtid00.y = static_cast<float>(topLeftCorner.y);
00639             computeCB->deltaPerDtidX.x = static_cast<float>(deltaAllDtidX.x) / targetSize.x;
00640             computeCB->deltaPerDtidX.y = static_cast<float>(deltaAllDtidX.y) / targetSize.x;
00641             computeCB->deltaPerDtidY.x = static_cast<float>(deltaAllDtidY.x) / targetSize.y;
00642             computeCB->deltaPerDtidY.y = static_cast<float>(deltaAllDtidY.y) / targetSize.y;
00643         }
00644
00645         m_d3dContext->Unmap(
00646             m_computeCB.Get(),
00647             0
00648             );
00649     }
00650
00651     // Set up pipeline state common to all fractal generation techniques.
00652     UINT stride = sizeof(FractalVertex);
00653     UINT offset = 0;
00654     m_d3dContext->IASetVertexBuffers(
00655         0,
00656         1,
00657         m_vertexBuffer.GetAddressOf(),
00658         &stride,
00659         &offset
00660         );
00661
00662     m_d3dContext->IASetIndexBuffer(
00663         m_indexBuffer.Get(),
00664         DXGI_FORMAT_R16_UINT,
00665         0
00666         );
00667
00668     m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00669
00670     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00671
00672     m_d3dContext->VSSetShader(
00673         m_vertexShader.Get(),
00674         nullptr,
00675         0
00676         );
00677
00678     m_d3dContext->VSSetConstantBuffers(
00679         0,
00680         1,
00681         m_drawRectCB.GetAddressOf()
00682         );
00683
00684     // Create null shader binding arrays.  These will be used to unbind resources from pipeline stages.
00685     ID3D11ShaderResourceView* nullSRV[] = {nullptr, nullptr};
00686     ID3D11RenderTargetView* nullRTV[] = {nullptr};
00687     ID3D11UnorderedAccessView* nullUAV[] = {nullptr};
00688
00689     if (m_technique == FractalTechnique::DirectCompute)
00690     {
00691         if (!m_complete)
00692         {
00693             // Generate the fractal using the DirectCompute technique.
00694
00695             m_d3dContext->CSSetShader(
00696                 m_directComputeCS.Get(),
00697                 nullptr,
00698                 0
00699                 );
00700
00701             ID3D11Buffer* directComputeCBs[] =
00702             {
00703                 m_bufferInfoCB.Get(),
00704                 m_computeCB.Get()
00705             };
00706
00707             m_d3dContext->CSSetConstantBuffers(
00708                 0,
00709                 ARRAYSIZE(directComputeCBs),
00710                 directComputeCBs
00711                 );
00712
00713             m_d3dContext->CSSetUnorderedAccessViews(
00714                 0,
00715                 1,
00716                 m_tempUAV.GetAddressOf(),
00717                 nullptr
00718                 );
00719
00720             // Dispatch the minimum number of threads required to assign one thread
00721             // to each complex coordinate in the fractal we wish to iterate on.
00722             m_d3dContext->Dispatch(
00723                 (static_cast<int>(targetSize.x) + SampleSettings::DirectCompute::ThreadGroupSizeX - 1) / SampleSettings::DirectCompute::ThreadGroupSizeX,
00724                 (static_cast<int>(targetSize.y) + SampleSettings::DirectCompute::ThreadGroupSizeY - 1) / SampleSettings::DirectCompute::ThreadGroupSizeY,
00725                 1
00726                 );
00727
00728             m_d3dContext->CSSetUnorderedAccessViews(
00729                 0,
00730                 ARRAYSIZE(nullUAV),
00731                 nullUAV,
00732                 nullptr
00733                 );
00734         }
00735
00736         // Draw the intermediate buffer.
00737
00738         CD3D11_VIEWPORT renderTargetViewport(
00739             0.0f,
00740             0.0f,
00741             m_renderTargetSize.Width,
00742             m_renderTargetSize.Height
00743             );
00744
00745         m_d3dContext->RSSetViewports(
00746             1,
00747             &renderTargetViewport
00748             );
00749
00750         m_d3dContext->OMSetRenderTargets(
00751             1,
00752             m_d3dRenderTargetView.GetAddressOf(),
00753             nullptr
00754             );
00755
00756         m_d3dContext->PSSetShader(
00757             m_renderBufferPS.Get(),
00758             nullptr,
00759             0
00760             );
00761
00762         m_d3dContext->PSSetConstantBuffers(
00763             0,
00764             1,
00765             m_bufferInfoCB.GetAddressOf()
00766             );
00767
00768         ID3D11ShaderResourceView* renderBufferSRVs[] =
00769         {
00770             m_tempSRV[0].Get(),
00771             m_gradient.Get()
00772         };
00773         m_d3dContext->PSSetShaderResources(
00774             0,
00775             ARRAYSIZE(renderBufferSRVs),
00776             renderBufferSRVs
00777             );
00778
00779         m_d3dContext->PSSetSamplers(
00780             0,
00781             1,
00782             m_linearSampler.GetAddressOf()
00783             );
00784
00785         m_d3dContext->DrawIndexed(
00786             m_indexCount,
00787             0,
00788             0
00789             );
00790
00791         m_d3dContext->PSSetShaderResources(
00792             0,
00793             ARRAYSIZE(nullSRV),
00794             nullSRV
00795             );
00796     }
00797
00798     if (m_technique == FractalTechnique::SinglePass)
00799     {
00800         if (!m_complete)
00801         {
00802             // Generate the fractal using the single-pass technique.
00803
00804             // Constrain the rasterizer to only draw to a portion of the intermediate texture.
00805
00806             CD3D11_VIEWPORT targetSizeViewport(
00807                 0.0f,
00808                 0.0f,
00809                 targetSize.x,
00810                 targetSize.y
00811                 );
00812
00813             m_d3dContext->RSSetViewports(
00814                 1,
00815                 &targetSizeViewport
00816                 );
00817
00818             m_d3dContext->OMSetRenderTargets(
00819                 1,
00820                 m_finalRTV.GetAddressOf(),
00821                 nullptr
00822                 );
00823
00824             m_d3dContext->PSSetShader(
00825                 m_singlePassPS.Get(),
00826                 nullptr,
00827                 0
00828                 );
00829
00830             m_d3dContext->PSSetShaderResources(
00831                 0,
00832                 1,
00833                 m_gradient.GetAddressOf()
00834                 );
00835
00836             m_d3dContext->PSSetSamplers(
00837                 0,
00838                 1,
00839                 m_linearSampler.GetAddressOf()
00840                 );
00841
00842             m_d3dContext->DrawIndexed(
00843                 m_indexCount,
00844                 0,
00845                 0
00846                 );
00847         }
00848
00849         // Draw the intermediate texture.
00850
00851         CD3D11_VIEWPORT renderTargetViewport(
00852             0.0f,
00853             0.0f,
00854             m_renderTargetSize.Width,
00855             m_renderTargetSize.Height
00856             );
00857
00858         m_d3dContext->RSSetViewports(
00859             1,
00860             &renderTargetViewport
00861             );
00862
00863         m_d3dContext->OMSetRenderTargets(
00864             1,
00865             m_d3dRenderTargetView.GetAddressOf(),
00866             nullptr
00867             );
00868
00869         m_d3dContext->PSSetShader(
00870             m_renderTexturePS.Get(),
00871             nullptr,
00872             0
00873             );
00874
00875         m_d3dContext->PSSetShaderResources(
00876             0,
00877             1,
00878             m_finalSRV.GetAddressOf()
00879             );
00880
00881         m_d3dContext->DrawIndexed(
00882             m_indexCount,
00883             0,
00884             0
00885             );
00886
00887         m_d3dContext->PSSetShaderResources(
00888             0,
00889             ARRAYSIZE(nullSRV),
00890             nullSRV
00891             );
00892     }
00893
00894     if (m_technique == FractalTechnique::ThreePhase)
00895     {
00896         if (!m_complete)
00897         {
00898             // Generate the fractal using the three-phase technique.
00899
00900             // Perform the initial pass, constraining the rasterizer to only draw to a portion of the intermediate texture.
00901             CD3D11_VIEWPORT targetSizeViewport(
00902                 0.0f,
00903                 0.0f,
00904                 targetSize.x,
00905                 targetSize.y
00906                 );
00907
00908             m_d3dContext->RSSetViewports(
00909                 1,
00910                 &targetSizeViewport
00911                 );
00912
00913             m_d3dContext->OMSetRenderTargets(
00914                 1,
00915                 m_tempRTV[0].GetAddressOf(),
00916                 nullptr
00917                 );
00918
00919             m_d3dContext->PSSetShader(
00920                 m_initialPS.Get(),
00921                 nullptr,
00922                 0
00923                 );
00924
00925             m_d3dContext->DrawIndexed(
00926                 m_indexCount,
00927                 0,
00928                 0
00929                 );
00930
00931             // Determine the number of intermediate iteration steps to run, based on the target number
00932             // of iterations, the number of iterations performed during the initial phase, and the
00933             // number of iterations to be performed during the final phase.
00934             int numStepsToRun =
00935                 (SampleSettings::TargetIterations - SampleSettings::ThreePhase::InitialIterations - SampleSettings::ThreePhase::FinalIterations) /
00936                 SampleSettings::ThreePhase::StepIterations;
00937             for (int i = 0; i < numStepsToRun; i++)
00938             {
00939                 // Use the previous generation's intermediate data (index 0) and write the output
00940                 // to the next generation's intermediate data (index 1).
00941                 m_d3dContext->OMSetRenderTargets(
00942                     1,
00943                     m_tempRTV[1].GetAddressOf(),
00944                     nullptr
00945                     );
00946
00947                 m_d3dContext->PSSetShader(
00948                     m_stepPS.Get(),
00949                     nullptr,
00950                     0
00951                     );
00952
00953                 m_d3dContext->PSSetShaderResources(
00954                     0,
00955                     1,
00956                     m_tempSRV[0].GetAddressOf()
00957                     );
00958
00959                 m_d3dContext->PSSetSamplers(
00960                     0,
00961                     1,
00962                     m_pointSampler.GetAddressOf()
00963                     );
00964
00965                 m_d3dContext->DrawIndexed(
00966                     m_indexCount,
00967                     0,
00968                     0
00969                     );
00970
00971                 m_d3dContext->PSSetShaderResources(
00972                     0,
00973                     ARRAYSIZE(nullSRV),
00974                     nullSRV
00975                     );
00976
00977                 // Swap the intermediate textures, as the output of the current generation will
00978                 // be the input of the next generation.
00979                 m_tempRTV[0].Swap(m_tempRTV[1]);
00980                 m_tempSRV[0].Swap(m_tempSRV[1]);
00981             }
00982
00983             // Perform the final generation step.
00984             m_d3dContext->OMSetRenderTargets(
00985                 1,
00986                 m_finalRTV.GetAddressOf(),
00987                 nullptr
00988                 );
00989
00990             m_d3dContext->PSSetShader(
00991                 m_finalPS.Get(),
00992                 nullptr,
00993                 0
00994                 );
00995
00996             ID3D11ShaderResourceView* finalSRVs[] =
00997             {
00998                 m_tempSRV[0].Get(),
00999                 m_gradient.Get()
01000             };
01001             m_d3dContext->PSSetShaderResources(
01002                 0,
01003                 ARRAYSIZE(finalSRVs),
01004                 finalSRVs
01005                 );
01006
01007             ID3D11SamplerState* finalSamplers[] =
01008             {
01009                 m_pointSampler.Get(),
01010                 m_linearSampler.Get()
01011             };
01012             m_d3dContext->PSSetSamplers(
01013                 0,
01014                 ARRAYSIZE(finalSamplers),
01015                 finalSamplers
01016                 );
01017
01018             m_d3dContext->DrawIndexed(
01019                 m_indexCount,
01020                 0,
01021                 0
01022                 );
01023
01024             m_d3dContext->PSSetShaderResources(
01025                 0,
01026                 ARRAYSIZE(nullSRV),
01027                 nullSRV
01028                 );
01029         }
01030
01031         // Draw the intermediate texture.
01032
01033         CD3D11_VIEWPORT renderTargetViewport(
01034             0.0f,
01035             0.0f,
01036             m_renderTargetSize.Width,
01037             m_renderTargetSize.Height
01038             );
01039
01040         m_d3dContext->RSSetViewports(
01041             1,
01042             &renderTargetViewport
01043             );
01044
01045         m_d3dContext->OMSetRenderTargets(
01046             1,
01047             m_d3dRenderTargetView.GetAddressOf(),
01048             nullptr
01049             );
01050
01051         m_d3dContext->PSSetShader(
01052             m_renderTexturePS.Get(),
01053             nullptr,
01054             0
01055             );
01056
01057         m_d3dContext->PSSetShaderResources(
01058             0,
01059             1,
01060             m_finalSRV.GetAddressOf()
01061             );
01062
01063         m_d3dContext->PSSetSamplers(
01064             0,
01065             1,
01066             m_linearSampler.GetAddressOf()
01067             );
01068
01069         m_d3dContext->DrawIndexed(
01070             m_indexCount,
01071             0,
01072             0
01073             );
01074
01075         m_d3dContext->PSSetShaderResources(
01076             0,
01077             ARRAYSIZE(nullSRV),
01078             nullSRV
01079             );
01080     }
01081
01082     if (m_fastGenerate)
01083     {
01084         // If the generation just performed was a fast generation, set the next generation
01085         // to be a full generation.  If manipulation occurs, this flag will be reset to true.
01086         m_fastGenerate = false;
01087     }
01088     else
01089     {
01090         // Otherwise, the intermediate surface contains full-resolution fractal data, and should
01091         // simply be displayed in future frames, as long as it is valid.
01092         m_complete = true;
01093     }
01094
01095     // Render the Sample Overlay.
01096     m_sampleOverlay->Render();
01097 }
01098
01099 int DirectXFractal::RoundUpTo16(int value)
01100 {
01101     // This method is useful when defining constant buffers, as
01102     // their size must be a multiple of 16 bytes.
01103     return (value + 15) & ~0xF;
01104 }
01105
01106 void DirectXFractal::HandleViewManipulation(float dRotation, float dScale, float dX, float dY)
01107 {
01108     // Save the old transform values.  If manipulation of the fractal view by the user
01109     // changes any of these values, then fast fractal generation will be enabled and any
01110     // existing intermediate surfaces will be invalidated.
01111     ViewTransform transformOld;
01112     memcpy(&transformOld, &m_transform, sizeof(transformOld));
01113
01114     // Translations must be interpreted based on the current scale and rotation of the view.
01115     float translateX = dX * static_cast<float>(m_transform.scale) / m_windowBounds.Width;
01116     float translateY = dY * static_cast<float>(m_transform.scale) / m_windowBounds.Width;
01117     float sinRotation = sinf(static_cast<float>(m_transform.rotation) * PI_F / 180.0f);
01118     float cosRotation = cosf(static_cast<float>(m_transform.rotation) * PI_F / 180.0f);
01119     m_transform.translationX -= translateX * cosRotation + translateY * sinRotation;
01120     m_transform.translationY += translateY * cosRotation - translateX * sinRotation;
01121
01122     // Scale and rotation changes are independent of the current view.
01123     m_transform.scale /= dScale;
01124     m_transform.rotation += dRotation;
01125
01126     // Ensure rotation values stay near zero to ensure trigonometric function accuracy.
01127     if (m_transform.rotation < -360.0f) m_transform.rotation += 360.0f;
01128     if (m_transform.rotation > 360.0f) m_transform.rotation -= 360.0f;
01129
01130     // Clamp the scale setting.
01131     double minScale;
01132     if (m_useDoubles)
01133     {
01134         minScale = SampleSettings::Manipulation::MinimumF64Scale;
01135     }
01136     else if (m_technique == FractalTechnique::DirectCompute || m_technique == FractalTechnique::SinglePass)
01137     {
01138         minScale = SampleSettings::Manipulation::MinimumF32Scale;
01139     }
01140     else if (!m_useUnormTextures)
01141     {
01142         minScale = SampleSettings::Manipulation::MinimumF16Scale;
01143     }
01144     else
01145     {
01146         minScale = SampleSettings::Manipulation::MinimumF8Scale;
01147     }
01148
01149
01150     m_transform.scale = min(SampleSettings::Manipulation::MaximumScale, max(minScale, m_transform.scale));
01151
01152     // Clamp translation to a certain radius about the origin of the complex plane.
01153     float translationMag = sqrtf(
01154         static_cast<float>(m_transform.translationX) * static_cast<float>(m_transform.translationX) +
01155         static_cast<float>(m_transform.translationY) * static_cast<float>(m_transform.translationY)
01156         );
01157     if (translationMag > SampleSettings::Manipulation::MaximumTranslationMagnitude)
01158     {
01159         m_transform.translationX *= SampleSettings::Manipulation::MaximumTranslationMagnitude / translationMag;
01160         m_transform.translationY *= SampleSettings::Manipulation::MaximumTranslationMagnitude / translationMag;
01161     }
01162
01163     // If the transform values have changed, enable fast fractal generation and
01164     // invalidate existing intermediate surfaces.
01165     if (memcmp(&m_transform, &transformOld, sizeof(transformOld)) != 0)
01166     {
01167         m_fastGenerate = true;
01168         m_complete = false;
01169     }
01170 }
01171
01172 void DirectXFractal::SaveInternalValue(
01173     _In_ IPropertySet^ state,
01174     _In_ Platform::String^ key,
01175     _In_ Platform::Object^ value
01176     )
01177 {
01178     if (state->HasKey(key))
01179     {
01180         state->Remove(key);
01181     }
01182     state->Insert(key, value);
01183 }
01184
01185 void DirectXFractal::SaveInternalState(_In_ IPropertySet^ state)
01186 {
01187     SaveInternalValue(state, "m_transform.scale", PropertyValue::CreateDouble(m_transform.scale));
01188     SaveInternalValue(state, "m_transform.rotation", PropertyValue::CreateDouble(m_transform.rotation));
01189     SaveInternalValue(state, "m_transform.translationX", PropertyValue::CreateDouble(m_transform.translationX));
01190     SaveInternalValue(state, "m_transform.translationY", PropertyValue::CreateDouble(m_transform.translationY));
01191 }
01192
01193 void DirectXFractal::LoadInternalState(_In_ IPropertySet^ state)
01194 {
01195     if (
01196         state->HasKey("m_transform.scale") &&
01197         state->HasKey("m_transform.rotation") &&
01198         state->HasKey("m_transform.translationX") &&
01199         state->HasKey("m_transform.translationY")
01200         )
01201     {
01202         m_transform.scale = safe_cast<IPropertyValue^>(state->Lookup("m_transform.scale"))->GetDouble();
01203         m_transform.rotation = safe_cast<IPropertyValue^>(state->Lookup("m_transform.rotation"))->GetDouble();
01204         m_transform.translationX = safe_cast<IPropertyValue^>(state->Lookup("m_transform.translationX"))->GetDouble();
01205         m_transform.translationY = safe_cast<IPropertyValue^>(state->Lookup("m_transform.translationY"))->GetDouble();
01206     }
01207 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Common/suspensionmanager.h Source File

  • XAML data binding
  • Common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/pch.h Source File

  • Search contract

pch.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include <sstream>
00021 #include <msxml6.h>
00022 #include <wrl.h>
00023 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::UserDomainName::sealed Member List

This is the complete list of members for SDKSample::UserDomainName::sealed, including all inherited members.
GetDNSDomain_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::UserDomainName::sealed | [private]
GetDomainName() | SDKSample::UserDomainName::sealed |
GetPrincipalName() | SDKSample::UserDomainName::sealed |
GetPrincipalName_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::UserDomainName::sealed | [private]
GetSIPUri() | SDKSample::UserDomainName::sealed |
GetUri_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::UserDomainName::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::UserDomainName::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::UserDomainName::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::UserDomainName::sealed | [protected, virtual]
rootPage | SDKSample::UserDomainName::sealed | [private]
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/OverrideSettings.xaml.h Source File

  • Date and time formatting

OverrideSettings.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // OverrideSettings.xaml.h
00013 // Declaration of the OverrideSettings class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "OverrideSettings.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace DateTimeFormatting
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class OverrideSettings sealed
00031         {
00032         public:
00033             OverrideSettings();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/DirectXSample.h Source File

  • Direct2D basic image effects

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/App.xaml.cpp Source File

  • CryptoWinRT

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/SampleOverlay.h Source File

  • Direct2D perspective transform

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CartoonizeImageViewModel.cpp Source File

  • Hilo C++
  • Hilo

CartoonizeImageViewModel.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008
00009 #include <amp.h>
00010
00011 #include "CartoonizeImageViewModel.h"
00012 #include "DelegateCommand.h"
00013 #include "IPhoto.h"
00014 #include "TaskExceptionsExtensions.h"
00015 #include "ImageNavigationData.h"
00016 #include "ImageUtilities.h"
00017 #include "Repository.h"
00018
00019 #include "PPLCartoon.h"
00020 #include "AmpPixel.h"
00021 #include "AmpCartoon.h"
00022
00023 using namespace concurrency;
00024 using namespace Hilo;
00025 using namespace Platform;
00026 using namespace std;
00027 using namespace Windows::Foundation::Collections;
00028 using namespace Windows::Graphics::Imaging;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::Streams;
00031 using namespace Windows::UI::ViewManagement;
00032 using namespace Windows::UI::Xaml::Input;
00033 using namespace Windows::UI::Xaml::Media;
00034 using namespace Windows::UI::Xaml::Media::Imaging;
00035 using namespace Windows::UI::Xaml::Navigation;
00036
00037 Platform::String^ const NeighborWindowKey = "neighbourWindow";
00038 Platform::String^ const PhasesKey = "phases";
00039
00040 const unsigned int MaxWidth = 1024;
00041 const unsigned int MaxHeight = 768;
00042
00043 CartoonizeImageViewModel::CartoonizeImageViewModel(shared_ptr<Repository> repository, shared_ptr<ExceptionPolicy> exceptionPolicy) :
00044     ImageBase(exceptionPolicy), m_repository(repository), m_inProgress(false), m_isSaving(false),
00045     m_isAmpPixelArrayPopulated(false), m_isSourcePixelsPopulated(false), m_checkedForHardwareAcceleration(false), m_useHardwareAcceleration(false),
00046     m_neighborWindow(3.0), m_phases(3.0), m_pOriginalPixels(nullptr), m_pSourcePixels(nullptr),
00047     m_scaledWidth(0u), m_scaledHeight(0u)
00048 {
00049     m_cartoonizeCommand = ref new DelegateCommand(
00050         ref new ExecuteDelegate(this, &CartoonizeImageViewModel::CartoonizeImage),
00051         ref new CanExecuteDelegate(this, &CartoonizeImageViewModel::IsCartoonizing));
00052     m_resumeCartoonizeCommand = ref new DelegateCommand(
00053         ref new ExecuteDelegate(this, &CartoonizeImageViewModel::Unsnap), nullptr);
00054     m_saveCommand = ref new DelegateCommand(
00055         ref new ExecuteDelegate(this, &CartoonizeImageViewModel::SaveImage),
00056         ref new CanExecuteDelegate(this, &CartoonizeImageViewModel::IsCartoonizing));
00057     m_cancelCommand = ref new DelegateCommand(
00058         ref new ExecuteDelegate(this, &CartoonizeImageViewModel::CancelCartoonize), nullptr);
00059
00060     m_initializationTask = create_empty_task();
00061     ViewModelBase::m_isAppBarSticky = true;
00062 }
00063
00064 CartoonizeImageViewModel::~CartoonizeImageViewModel()
00065 {
00066     if (m_pOriginalPixels != nullptr)
00067     {
00068         delete[] m_pOriginalPixels;
00069         m_pOriginalPixels = nullptr;
00070     }
00071     if (m_pSourcePixels != nullptr)
00072     {
00073         delete[] m_pSourcePixels;
00074         m_pSourcePixels = nullptr;
00075     }
00076 }
00077
00078 ICommand^ CartoonizeImageViewModel::CartoonizeCommand::get()
00079 {
00080     return m_cartoonizeCommand;
00081 }
00082
00083 ICommand^ CartoonizeImageViewModel::ResumeCartoonizeCommand::get()
00084 {
00085     return m_resumeCartoonizeCommand;
00086 }
00087
00088 ICommand^ CartoonizeImageViewModel::SaveCommand::get()
00089 {
00090     return m_saveCommand;
00091 }
00092
00093 ICommand^ CartoonizeImageViewModel::CancelCommand::get()
00094 {
00095     return m_cancelCommand;
00096 }
00097
00098 bool CartoonizeImageViewModel::InProgress::get()
00099 {
00100     return m_inProgress;
00101 }
00102
00103 ImageSource^ CartoonizeImageViewModel::Image::get()
00104 {
00105     return m_image;
00106 }
00107
00108 float64 CartoonizeImageViewModel::NeighborWindow::get()
00109 {
00110     return m_neighborWindow;
00111 }
00112
00113 void CartoonizeImageViewModel::NeighborWindow::set(float64 value)
00114 {
00115     if (value != m_neighborWindow)
00116     {
00117         m_neighborWindow = value;
00118     }
00119 }
00120
00121 float64 CartoonizeImageViewModel::Phases::get()
00122 {
00123     return m_phases;
00124 }
00125
00126 void CartoonizeImageViewModel::Phases::set(float64 value)
00127 {
00128     if (value != m_phases)
00129     {
00130         m_phases = value;
00131     }
00132 }
00133
00134 concurrency::task<IPhoto^> CartoonizeImageViewModel::GetImagePhotoAsync()
00135 {
00136     assert(IsMainThread());
00137     return m_repository->GetSinglePhotoAsync(m_photoPath);
00138 }
00139
00140 void CartoonizeImageViewModel::CheckForCancellation()
00141 {
00142     if (is_task_cancellation_requested())
00143     {
00144         cancel_current_task();
00145     }
00146 }
00147
00148 void CartoonizeImageViewModel::ChangeInProgress(bool value)
00149 {
00150     m_inProgress = value;
00151     OnPropertyChanged("InProgress");
00152 }
00153
00154 void CartoonizeImageViewModel::EvaluateCommands()
00155 {
00156     m_cartoonizeCommand->CanExecute(IsCartoonizing(nullptr));
00157     m_saveCommand->CanExecute(IsCartoonizing(nullptr));
00158 }
00159
00160 void CartoonizeImageViewModel::CartoonizeImage(Object^ parameter)
00161 {
00162     assert(IsMainThread());
00163     m_cts = cancellation_token_source();
00164     auto token = m_cts.get_token();
00165
00166     // Check for hardware acceleration if we haven't already.
00167     if (!m_checkedForHardwareAcceleration)
00168     {
00169         m_checkedForHardwareAcceleration = true;
00170         accelerator acc;
00171         m_useHardwareAcceleration = !acc.is_emulated;
00172     }
00173
00174     ChangeInProgress(true);
00175     EvaluateCommands();
00176     m_initializationTask = m_initializationTask.then([this, token]() -> task<void>
00177     {
00178         // Use the C++ AMP algorithim if the default accelerator is not an emulator (WARP or reference device).
00179         if (m_useHardwareAcceleration)
00180         {
00181             return CartoonizeImageAmpAsync(token);
00182         }
00183         // Otherwise, use the PPL to leverage all available CPU cores.
00184         else
00185         {
00186             return CartoonizeImagePPLAsync(token);
00187         }
00188     }, task_continuation_context::use_current()).then([this](task<void> priorTask)
00189     {
00190         m_initializationTask = create_empty_task();
00191         ChangeInProgress(false);
00192         EvaluateCommands();
00193         priorTask.get();
00194     }, task_continuation_context::use_current()).then(ObserveException<void>(m_exceptionPolicy));
00195 }
00196
00197 void CartoonizeImageViewModel::Unsnap(Object^ parameter)
00198 {
00199     if (ApplicationView::Value == ApplicationViewState::Snapped)
00200     {
00201         ApplicationView::TryUnsnap();
00202     }
00203 }
00204
00205 void CartoonizeImageViewModel::SaveImage(Object^ parameter)
00206 {
00207     if (m_isSaving) return;
00208
00209     m_isSaving = true;
00210     auto sourceStream = make_shared<IRandomAccessStreamWithContentType^>(nullptr);
00211     auto encodedStream = make_shared<IRandomAccessStream^>(nullptr);
00212
00213     GetStreamWithFailCheck().then([this, sourceStream](IRandomAccessStreamWithContentType^ stream)
00214     {
00215         assert(IsMainThread());
00216         (*sourceStream) = stream;
00217         ChangeInProgress(true);
00218         return EncodeImageAsync(stream);
00219     }).then([this, encodedStream](IRandomAccessStream^ stream)
00220     {
00221         assert(IsMainThread());
00222         (*encodedStream) = stream;
00223         // Cancel the task if the user has switched to snapped view before the FileSavePicker has appeared.
00224         if (ApplicationView::Value == ApplicationViewState::Snapped)
00225         {
00226             cancel_current_task();
00227         }
00228         return ImageBase::GetFileNameFromFileSavePickerAsync(m_photo->FileType);
00229     }).then([this, encodedStream](StorageFile^ f)
00230     {
00231         assert(IsMainThread());
00232         return ImageBase::SaveImageAsync(f, (*encodedStream));
00233     }).then([this](task<void> priorTask)
00234     {
00235         assert(IsMainThread());
00236         m_isSaving = false;
00237         ChangeInProgress(false);
00238         try
00239         {
00240             priorTask.get();
00241         }
00242         catch (const task_canceled&)
00243         {
00244         }
00245     }).then(ObserveException<void>(m_exceptionPolicy));
00246 }
00247
00248 void CartoonizeImageViewModel::CancelCartoonize(Object^ parameter)
00249 {
00250     m_cts.cancel();
00251     ViewModelBase::GoBack();
00252 }
00253
00254 bool CartoonizeImageViewModel::IsCartoonizing(Object^ parameter)
00255 {
00256     return !m_inProgress;
00257 }
00258
00259 // See http://go.microsoft.com/fwlink/?LinkId=267280 for more info on Hilo's implementation of suspend/resume.
00260 void CartoonizeImageViewModel::LoadState(IMap<String^, Object^>^ stateMap)
00261 {
00262     if (stateMap != nullptr)
00263     {
00264         if (stateMap->HasKey(NeighborWindowKey))
00265             m_neighborWindow = static_cast<float64>(stateMap->Lookup(NeighborWindowKey));
00266
00267         if (stateMap->HasKey(PhasesKey))
00268             m_phases = static_cast<float64>(stateMap->Lookup(PhasesKey));
00269     }
00270 }
00271
00272 void CartoonizeImageViewModel::SaveState(IMap<String^, Object^>^ stateMap)
00273 {
00274     stateMap->Insert(NeighborWindowKey, m_neighborWindow);
00275     stateMap->Insert(PhasesKey, m_phases);
00276 }
00277
00278 void CartoonizeImageViewModel::OnNavigatedTo(NavigationEventArgs^ e)
00279 {
00280     String^ data = dynamic_cast<String^>(e->Parameter);
00281     ImageNavigationData navigationData(data);
00282     Initialize(navigationData.GetFilePath());
00283 }
00284
00285 void CartoonizeImageViewModel::Initialize(String^ photoPath)
00286 {
00287     assert(IsMainThread());
00288     m_photo = nullptr;
00289     m_image = nullptr;
00290     m_photoPath = photoPath;
00291     auto photoStream = make_shared<IRandomAccessStreamWithContentType^>(nullptr);
00292
00293     m_initializationTask = GetImagePhotoAsync().then([this](IPhoto^ photo)
00294     {
00295         assert(IsMainThread());
00296         // Return to the hub page if the photo is no longer present.
00297         if (photo == nullptr)
00298         {
00299             GoHome();
00300             cancel_current_task();
00301         }
00302         m_photo = photo;
00303         // Read the image data.
00304         return m_photo->OpenReadAsync();
00305     }).then([photoStream](IRandomAccessStreamWithContentType^ imageData)
00306     {
00307         // Create a BitmapDecoder object to read the image's width and height.
00308         assert(IsMainThread());
00309         (*photoStream) = imageData;
00310         return BitmapDecoder::CreateAsync(imageData);
00311     }).then([this, photoStream](BitmapDecoder^ decoder)
00312     {
00313         // Scale the image if its width or height exceed the maximum.
00314         assert(IsMainThread());
00315         auto ras = ref new InMemoryRandomAccessStream();
00316         auto origWidth = decoder->PixelWidth;
00317         auto origHeight = decoder->PixelHeight;
00318
00319         return create_task(BitmapEncoder::CreateForTranscodingAsync(ras, decoder)).then([this, origWidth, origHeight](BitmapEncoder^ encoder)
00320         {
00321             assert(IsBackgroundThread());
00322             // Scale the image if either dimension is larger than the maximum.
00323             if (ScaleImageDimensions(origWidth, origHeight))
00324             {
00325                 encoder->BitmapTransform->ScaledWidth = m_scaledWidth;
00326                 encoder->BitmapTransform->ScaledHeight = m_scaledHeight;
00327                 // Because we will apply color simplification, we care more about
00328                 // speed than image quality.
00329                 encoder->BitmapTransform->InterpolationMode = BitmapInterpolationMode::NearestNeighbor;
00330             }
00331             return encoder->FlushAsync();
00332         }, task_continuation_context::use_arbitrary()).then([ras]
00333         {
00334             assert(IsBackgroundThread());
00335             return dynamic_cast<IRandomAccessStream^>(ras);
00336         }, task_continuation_context::use_arbitrary());
00337
00338     }).then([this, photoStream](IRandomAccessStream^ resizedStream)
00339     {
00340         assert(IsMainThread());
00341         m_image = ref new WriteableBitmap(m_scaledWidth, m_scaledHeight);
00342         resizedStream->Seek(0);
00343         return m_image->SetSourceAsync(resizedStream);
00344     }).then([this](task<void> priorTask)
00345     {
00346         assert(IsMainThread());
00347         OnPropertyChanged("Image");
00348         m_initializationTask = create_empty_task();
00349         priorTask.get();
00350     }).then(ObserveException<void>(m_exceptionPolicy));
00351 }
00352
00353 bool CartoonizeImageViewModel::ScaleImageDimensions(unsigned int origWidth, unsigned int origHeight)
00354 {
00355     auto& scaledWidth = m_scaledWidth;
00356     auto& scaledHeight = m_scaledHeight;
00357
00358     scaledWidth = origWidth;
00359     scaledHeight = origHeight;
00360
00361     auto scale_width = [](unsigned int& w, unsigned int& h)
00362     {
00363         float64 p = MaxWidth / static_cast<float64>(w);
00364         w = static_cast<unsigned int>(w * p);
00365         h = static_cast<unsigned int>(h * p);
00366     };
00367     auto scale_height = [](unsigned int& w, unsigned int& h)
00368     {
00369         float64 p = MaxHeight / static_cast<float64>(h);
00370         w = static_cast<unsigned int>(w * p);
00371         h = static_cast<unsigned int>(h * p);
00372     };
00373
00374     if (origWidth <= MaxWidth && origHeight <= MaxHeight)
00375     {
00376         // The image does not need to be scaled.
00377         return false;
00378     }
00379     else if (origWidth > MaxWidth && origHeight > MaxHeight)
00380     {
00381         // Both dimensions exceed the maximum.
00382         while (scaledWidth > MaxWidth || scaledHeight > MaxHeight)
00383         {
00384             if (scaledWidth > MaxWidth)
00385             {
00386                 scale_width(scaledWidth, scaledHeight);
00387             }
00388             else
00389             {
00390                 scale_height(scaledWidth, scaledHeight);
00391             }
00392         }
00393     }
00394     else if (origWidth > MaxWidth)
00395     {
00396         // Width exceeds maximum.
00397         scale_width(scaledWidth, scaledHeight);
00398     }
00399     else
00400     {
00401         // Height exceeds maximum.
00402         assert(origHeight > MaxHeight);
00403         scale_height(scaledWidth, scaledHeight);
00404     }
00405
00406     assert(scaledWidth <= MaxWidth);
00407     assert(scaledHeight <= MaxHeight);
00408     return true;
00409 }
00410
00411 void CartoonizeImageViewModel::CopyPixelDataToPlatformArray(IBuffer^ buffer, Array<unsigned char, 1>^ pixels, unsigned int width, unsigned int height)
00412 {
00413     assert(IsMainThread());
00414
00415     // Get a pointer to the image pixel data.
00416     byte* pPixels = GetPointerToPixelData(buffer);
00417
00418     // Copy pixel data from C style array to Platform::Array,
00419     // re-arranging from BGRA to RGBA.
00420     parallel_for (0u, height, [width, pixels, pPixels](unsigned int y)
00421     {
00422         for (unsigned int x = 0; x < width; x++)
00423         {
00424             pixels[(x + y * width) * 4] =
00425                 pPixels[(x + y * width) * 4 + 2]; // R
00426             pixels[(x + y * width) * 4 + 1] =
00427                 pPixels[(x + y * width) * 4 + 1]; // G
00428             pixels[(x + y * width) * 4 + 2] =
00429                 pPixels[(x + y * width) * 4];     // B
00430             pixels[(x + y * width) * 4 + 3] =
00431                 pPixels[(x + y * width) * 4 + 3]; // A
00432         }
00433     });
00434 }
00435
00436 task<IRandomAccessStream^> CartoonizeImageViewModel::EncodeImageAsync(IRandomAccessStream^ sourceStream)
00437 {
00438     assert(IsMainThread());
00439     auto bitmapEncoder = make_shared<BitmapEncoder^>(nullptr);
00440     auto backgroundContext = task_continuation_context::use_arbitrary();
00441     auto ras = ref new InMemoryRandomAccessStream();
00442     auto dpiX = make_shared<float64>(0.0);
00443     auto dpiY = make_shared<float64>(0.0);
00444     auto width = m_image->PixelWidth;
00445     auto height = m_image->PixelHeight;
00446     auto pixels = ref new Array<unsigned char>((width * height) * 4);
00447
00448     CopyPixelDataToPlatformArray(m_image->PixelBuffer, pixels, width, height);
00449
00450     return create_task(BitmapDecoder::CreateAsync(sourceStream))
00451         .then([ras, dpiX, dpiY](BitmapDecoder^ decoder)
00452     {
00453         assert(IsBackgroundThread());
00454         (*dpiX) = decoder->DpiX;
00455         (*dpiY) = decoder->DpiY;
00456         return BitmapEncoder::CreateForTranscodingAsync(ras, decoder);
00457     }, backgroundContext).then([this, width, height, dpiX, dpiY, pixels, bitmapEncoder](BitmapEncoder^ encoder)
00458     {
00459         assert(IsBackgroundThread());
00460         encoder->SetPixelData(BitmapPixelFormat::Rgba8,
00461             BitmapAlphaMode::Straight,
00462             width,
00463             height,
00464             (*dpiX),
00465             (*dpiY),
00466             pixels);
00467         // Force a new thumbnail to be generated.
00468         encoder->IsThumbnailGenerated = true;
00469         (*bitmapEncoder) = encoder;
00470         return encoder->FlushAsync();
00471     }, backgroundContext).then([this, ras, bitmapEncoder](task<void> encodeTask)
00472     {
00473         assert(IsBackgroundThread());
00474         try
00475         {
00476             encodeTask.get();
00477         }
00478         catch (Exception^ ex)
00479         {
00480             switch (ex->HResult)
00481             {
00482             case WINCODEC_ERR_UNSUPPORTEDOPERATION:
00483                 // If the encoder does not support writing a thumbnail, then
00484                 // disable thumbnail generation before trying again.
00485                 (*bitmapEncoder)->IsThumbnailGenerated = false;
00486                 break;
00487             default:
00488                 throw ex;
00489             }
00490         }
00491         return ((*bitmapEncoder)->IsThumbnailGenerated == false) ? (*bitmapEncoder)->FlushAsync() : create_async([]{});
00492     }, backgroundContext).then([ras]
00493     {
00494         assert(IsBackgroundThread());
00495         return dynamic_cast<IRandomAccessStream^>(ras);
00496     }, backgroundContext);
00497 }
00498
00499 AmpPixel* CartoonizeImageViewModel::CopyPixelDataToAmpPixelArray(byte* sourcePixels, unsigned int width, unsigned int height, const unsigned int size)
00500 {
00501     (void) size;
00502     unsigned int nPixels = width * height;
00503     assert(nPixels <= size / 4);
00504
00505     AmpPixel* pixels = new AmpPixel[(nPixels)];
00506     float r;
00507     float g;
00508     float b;
00509
00510     // Copy data from sourcePixels to originalPixels, converting the type, ignoring alpha.
00511     for (unsigned int i = 0; i < nPixels; i++)
00512     {
00513         AmpPixel p;
00514         r = sourcePixels[4 * i] / 255.0F;
00515         g = sourcePixels[4 * i + 1] / 255.0F;
00516         b = sourcePixels[4 * i + 2] / 255.0F;
00517
00518         p.SetFromRGB(r, g, b);
00519         pixels[i] = p;
00520     }
00521     return pixels;
00522 }
00523
00524 void CartoonizeImageViewModel::CopyAmpPixelArrayToPixelData(byte* destPixels, AmpPixel* newPixels, const unsigned int width, const unsigned int height)
00525 {
00526     for (unsigned int pixel = 0; pixel < (width * height); pixel++)
00527     {
00528         AmpPixel p = newPixels[pixel];
00529         destPixels[4 * pixel] = static_cast<byte>(p.r * 255.0F); // R
00530         destPixels[4 * pixel + 1] = static_cast<byte>(p.g * 255.0F); // G
00531         destPixels[4 * pixel + 2] = static_cast<byte>(p.b * 255.0F); // B
00532         destPixels[4 * pixel + 3] = 255; // A
00533     }
00534 }
00535
00536 task<void> CartoonizeImageViewModel::CartoonizeImageAmpAsync(cancellation_token token)
00537 {
00538     assert(IsMainThread());
00539
00540     const unsigned int width = m_image->PixelWidth;
00541     const unsigned int height = m_image->PixelHeight;
00542     const unsigned int size = m_image->PixelBuffer->Length;
00543
00544     byte* sourcePixels = nullptr;
00545     if (!m_isAmpPixelArrayPopulated)
00546     {
00547         sourcePixels = GetPointerToPixelData(m_image->PixelBuffer);
00548     }
00549
00550     auto destImage = ref new WriteableBitmap(m_image->PixelWidth, m_image->PixelHeight);
00551     byte* destPixels = GetPointerToPixelData(destImage->PixelBuffer);
00552
00553     // Cartoonize source pixels into destination pixels.
00554     return create_task([this, sourcePixels, destPixels, width, height, size, token]
00555     {
00556         assert(IsBackgroundThread());
00557
00558         const unsigned int neighborWindow = static_cast<unsigned int>(m_neighborWindow);
00559         const unsigned int phases = static_cast<unsigned int>(m_phases);
00560
00561         if (!m_isAmpPixelArrayPopulated)
00562         {
00563             m_pOriginalPixels = CopyPixelDataToAmpPixelArray(sourcePixels, width, height, size);
00564             m_isAmpPixelArrayPopulated = true;
00565         }
00566         CheckForCancellation();
00567
00568         auto newPixels = shared_ptr<AmpPixel>(new AmpPixel[width * height]);
00569         ApplyCartoonEffectAmp(m_pOriginalPixels, newPixels.get(), width, height, neighborWindow, phases, token);
00570         CheckForCancellation();
00571
00572         CopyAmpPixelArrayToPixelData(destPixels, newPixels.get(), width, height);
00573     }, token).then([this, destImage](task<void> priorTask)
00574     {
00575         assert(IsMainThread());
00576         try
00577         {
00578             priorTask.get();
00579
00580             // Update image on screen.
00581             m_image = destImage;
00582             OnPropertyChanged("Image");
00583         }
00584         catch (const task_canceled&)
00585         {
00586         }
00587         catch (const bad_alloc&)
00588         {
00589         }
00590     }, task_continuation_context::use_current());
00591 }
00592
00593 task<void> CartoonizeImageViewModel::CartoonizeImagePPLAsync(cancellation_token token)
00594 {
00595     assert(IsMainThread());
00596
00597     const unsigned int width = m_image->PixelWidth;
00598     const unsigned int height = m_image->PixelHeight;
00599     const unsigned int size = m_image->PixelBuffer->Length;
00600
00601     byte* sourcePixels = nullptr;
00602     if (!m_isSourcePixelsPopulated)
00603     {
00604         sourcePixels = GetPointerToPixelData(m_image->PixelBuffer);
00605         // Make a copy of the PixelBuffer data.
00606         if (m_pSourcePixels == nullptr)
00607         {
00608             m_pSourcePixels = new byte[size];
00609             memcpy(m_pSourcePixels, sourcePixels, size);
00610             m_isSourcePixelsPopulated = true;
00611         }
00612     }
00613     else
00614     {
00615         // Copy original data back to the PixelBuffer.
00616         if (sourcePixels == nullptr)
00617         {
00618             sourcePixels = GetPointerToPixelData(m_image->PixelBuffer);
00619             memcpy(sourcePixels,  m_pSourcePixels, size);
00620         }
00621     }
00622
00623     // Cartoonize source pixels into destination pixels.
00624     return create_task([this, sourcePixels, width, height, size, token]
00625     {
00626         assert(IsBackgroundThread());
00627         const unsigned int neighborWindow = static_cast<unsigned int>(m_neighborWindow);
00628         const unsigned int phases = static_cast<unsigned int>(m_phases);
00629         ApplyCartoonEffectPPL(sourcePixels, width, height, neighborWindow, phases, size, token);
00630     }, token).then([this](task<void> priorTask)
00631     {
00632         assert(IsMainThread());
00633         try
00634         {
00635             priorTask.get();
00636
00637             // Update image on screen.
00638             m_image->Invalidate();
00639         }
00640         catch (const task_canceled&)
00641         {
00642         }
00643         catch (const bad_alloc&)
00644         {
00645         }
00646     }, task_continuation_context::use_current());
00647 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S1_DeviceProperties.xaml.h Source File

  • Portable device API

S1_DeviceProperties.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // S1_DeviceProperties.xaml.h
00013 // Declaration of the S1_DeviceProperties class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "S1_DeviceProperties.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace PortableDeviceCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class S1_DeviceProperties sealed
00031         {
00032         public:
00033             S1_DeviceProperties();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         private:
00039             void Run_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void ShowDeviceSelectorAsync();
00041             void DeviceList_Tapped(Platform::Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e);
00042             void DisplayDeviceProperties(Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement);
00043
00044             MainPage^ rootPage;
00045             // Contains the device information used for populating the device selection list
00046             Windows::Devices::Enumeration::DeviceInformationCollection^ _deviceInfoCollection;
00047         };
00048     }
00049 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicReaderWriter.h Source File

  • Direct3D bump mapping

BasicReaderWriter.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <ppltasks.h>
00011
00012 // A simple reader/writer class that provides support for reading and writing
00013 // files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicReaderWriter
00015 {
00016 private:
00017     Windows::Storage::StorageFolder^ m_location;
00018     Platform::String^ m_locationPath;
00019
00020 internal:
00021     BasicReaderWriter();
00022     BasicReaderWriter(
00023         _In_ Windows::Storage::StorageFolder^ folder
00024         );
00025
00026     Platform::Array<byte>^ ReadData(
00027         _In_ Platform::String^ filename
00028         );
00029
00030     concurrency::task<Platform::Array<byte>^> ReadDataAsync(
00031         _In_ Platform::String^ filename
00032         );
00033
00034     uint32 WriteData(
00035         _In_ Platform::String^ filename,
00036         _In_ const Platform::Array<byte>^ fileData
00037         );
00038
00039     concurrency::task<void> WriteDataAsync(
00040         _In_ Platform::String^ filename,
00041         _In_ const Platform::Array<byte>^ fileData
00042         );
00043 };
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario6.xaml.cpp Source File

  • CryptoWinRT

Scenario6.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.cpp
00013 // Implementation of the Scenario6 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario6.xaml.h"
00018
00019 using namespace SDKSample::CryptoWinRT;
00020
00021 using namespace Platform;
00022 using namespace Windows::Security::Cryptography;
00023 using namespace Windows::Security::Cryptography::Core;
00024 using namespace Windows::Storage::Streams;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 Scenario6::Scenario6()
00030 {
00031     InitializeComponent();
00032     AlgorithmNames->SelectedIndex = 0;
00033     KeySizes->SelectedIndex = 0;
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void Scenario6::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046 }
00047
00048 static BYTE NonceBytes[] = { 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0, 0 };
00049
00050 IBuffer^ SDKSample::CryptoWinRT::Scenario6::GetNonce()
00051 {
00052     // NOTE:
00053     //
00054     // The security best practises require that the Encrypt operation
00055     // not be called more than once with the same nonce for the same key.
00056     //
00057     // Nonce can be predictable, but must be unique per secure session.
00058
00059     unsigned int NonceBytesLength = sizeof(NonceBytes);
00060     int carry = 1;
00061
00062     for (unsigned int i = 0; i < NonceBytesLength && carry == 1; i++)
00063     {
00064         if (NonceBytes[i] == 255)
00065         {
00066             NonceBytes[i] = 0;
00067         }
00068         else
00069         {
00070             NonceBytes[i]++;
00071             carry = 0;
00072         }
00073     }
00074
00075     TestVectorNonce = ref new Array<byte>(NonceBytesLength);
00076     for(UINT32 i = 0; i < TestVectorNonce->Length;i++)
00077     {
00078         TestVectorNonce[i]= NonceBytes[i];
00079     }
00080
00081     IBuffer ^ toReturn = CryptographicBuffer::CreateFromByteArray(TestVectorNonce);
00082     TestVectorNonce = nullptr;
00083
00084     return toReturn;
00085 }
00086
00087 void SDKSample::CryptoWinRT::Scenario6::RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00088 {
00089     String^ algName = AlgorithmNames->SelectionBoxItem->ToString();
00090     int keySize;
00091
00092     Scenario6Text->Text = "";
00093
00094     switch (KeySizes->SelectedIndex)
00095     {
00096     case 0:
00097         keySize = 128;
00098         break;
00099     case 1:
00100         keySize = 256;
00101         break;
00102     default:
00103         Scenario6Text->Text += "An invalid size was selected";
00104         return;
00105     }
00106
00107     IBuffer^ Decrypted;
00108     IBuffer^ Data;
00109     IBuffer^ Nonce;
00110     String^ Cookie = "Some Cookie to Encrypt";
00111
00112     // Data to encrypt.
00113     Data = CryptographicBuffer::ConvertStringToBinary(Cookie, BinaryStringEncoding::Utf16LE);
00114
00115     // Created a SymmetricKeyAlgorithmProvider object for the algorithm specified on input.
00116     SymmetricKeyAlgorithmProvider^ Algorithm = SymmetricKeyAlgorithmProvider::OpenAlgorithm(algName);
00117
00118     Scenario6Text->Text += "\n*** Sample Authenticated Encryption\n";
00119     Scenario6Text->Text += "    Algorithm Name: " + Algorithm->AlgorithmName + "\n";
00120     Scenario6Text->Text += "    Key Size: " + keySize + "\n";
00121     Scenario6Text->Text += "    Block length: " + Algorithm->BlockLength + "\n";
00122
00123     // Generate a random key.
00124     IBuffer^ keymaterial = CryptographicBuffer::GenerateRandom((keySize + 7) / 8);
00125     CryptographicKey^ key = Algorithm->CreateSymmetricKey(keymaterial);
00126
00127
00128     // Microsoft GCM implementation requires a 12 byte Nonce.
00129     // Microsoft CCM implementation requires a 7-13 byte Nonce.
00130     Nonce = GetNonce();
00131
00132     // Encrypt and create an authenticated tag on the encrypted data.
00133     EncryptedAndAuthenticatedData^ Encrypted = CryptographicEngine::EncryptAndAuthenticate(key, Data, Nonce, nullptr);
00134
00135     Scenario6Text->Text += "    Plain text: " + Data->Length + " bytes\n";
00136     Scenario6Text->Text += "    Encrypted: " + Encrypted->EncryptedData->Length + " bytes\n";
00137     Scenario6Text->Text += "    AuthTag: " + Encrypted->AuthenticationTag->Length + " bytes\n";
00138
00139     // Create another instance of the key from the same material.
00140     CryptographicKey^ key2 = Algorithm->CreateSymmetricKey(keymaterial);
00141
00142     if (key->KeySize != key2->KeySize)
00143     {
00144         Scenario6Text->Text += "CreateSymmetricKey failed!  The imported key's size did not match the original's!\n";
00145         return;
00146     }
00147
00148     // Decrypt and verify the authenticated tag.
00149     Decrypted = CryptographicEngine::DecryptAndAuthenticate(key2, Encrypted->EncryptedData, Nonce, Encrypted->AuthenticationTag, nullptr);
00150
00151     if (!CryptographicBuffer::Compare(Decrypted, Data))
00152     {
00153         Scenario6Text->Text += "Decrypted does not match original!\n";
00154         return;
00155     }
00156 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Audio Member List

This is the complete list of members for Audio, including all inherited members.
__pad0__ | Audio |
CreateDeviceIndependentResources() | Audio |
CreateDeviceIndependentResources() | Audio |
CreateResources() | Audio |
CreateReverb(IXAudio2 *engine, IXAudio2MasteringVoice *masteringVoice, XAUDIO2FX_REVERB_PARAMETERS *parameters, IXAudio2SubmixVoice **newSubmix, bool enableEffect) | Audio | [private]
CreateSourceVoice(SoundEvent) | Audio | [private]
HasEngineExperiencedCriticalError() | Audio | [inline]
Initialize() | Audio |
Initialize() | Audio |
Initialize() | Audio |
IsSoundEffectStarted(SoundEvent sound) | Audio |
m_audioAvailable | Audio | [private]
m_audioBuffers | Audio | [private]
m_currentBuffer | Audio | [private]
m_engineExperiencedCriticalError | Audio | [private]
m_isAudioStarted | Audio |
m_musicEngine | Audio | [private]
m_musicEngine | Audio | [private]
m_musicEngineCallback | Audio | [private]
m_musicMasteringVoice | Audio | [private]
m_musicReverbVoiceLargeRoom | Audio | [private]
m_musicReverbVoiceSmallRoom | Audio | [private]
m_musicSourceVoice | Audio | [private]
m_musicStreamer | Audio | [private]
m_reverbParametersLarge | Audio | [private]
m_reverbParametersSmall | Audio | [private]
m_soundEffectEngine | Audio | [private]
m_soundEffectEngine | Audio | [private]
m_soundEffectEngineCallback | Audio | [private]
m_soundEffectMasteringVoice | Audio | [private]
m_soundEffectReverbVoiceLargeRoom | Audio | [private]
m_soundEffectReverbVoiceSmallRoom | Audio | [private]
m_soundEffects | Audio | [private]
m_voiceContext | Audio | [private]
MusicEngine() | Audio |
MusicEngine() | Audio |
PlaySoundEffect(SoundEvent sound) | Audio |
ReleaseResources() | Audio |
Render() | Audio |
ResumeAudio() | Audio |
ResumeAudio() | Audio |
ResumeAudio() | Audio |
SetEngineExperiencedCriticalError() | Audio | [inline]
SetRoomSize(float roomSize, float *wallDistances) | Audio |
SetSoundEffectFilter(SoundEvent sound, float frequency, float oneOverQ) | Audio |
SetSoundEffectPitch(SoundEvent sound, float pitch) | Audio |
SetSoundEffectVolume(SoundEvent sound, float volume) | Audio |
SoundEffectEngine() | Audio |
SoundEffectEngine() | Audio |
Start() | Audio |
StopSoundEffect(SoundEvent sound) | Audio |
SuspendAudio() | Audio |
SuspendAudio() | Audio |
SuspendAudio() | Audio |
~Audio() | Audio |
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput1.xaml.cpp Source File

  • Print

ScenarioOutput1.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.cpp
00010 // Implementation of the Scenario1Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput1.xaml.h"
00015
00016 using namespace PrintSample;
00017
00018 ScenarioOutput1::ScenarioOutput1()
00019 {
00020     InitializeComponent();
00021 }
00022
00023 ScenarioOutput1::~ScenarioOutput1()
00024 {
00025 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupPickerScenario.xaml.h Source File

  • HomeGroup app

HomeGroupPickerScenario.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // HomeGroupPicker.xaml.h
00013 // Declaration of the HomeGroupPicker class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "HomeGroupPickerScenario.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace HomeGroup
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class HomeGroupPicker sealed
00031         {
00032         public:
00033             HomeGroupPicker();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Account picture name/C++/SetAccountPicture.xaml.h Source File

  • Account picture name

SetAccountPicture.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SetAccountPicture.xaml.h
00013 // Declaration of the SetAccountPicture class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SetAccountPicture.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace AccountPictureName
00023 {
00024     [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class SetAccountPicture sealed
00026     {
00027     public:
00028         SetAccountPicture();
00029
00030     protected:
00031         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033
00034     private:
00035         MainPage^ rootPage;
00036         void SetImageButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037         void SetVideoButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038         void PictureChanged(Platform::Object^ sender, Platform::Object^ e);
00039
00040         static Windows::Foundation::EventRegistrationToken SetAccountPicture::accountPictureChangedToken;
00041     };
00042 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::HighContrast::sealed Member List

This is the complete list of members for SDKSample::HighContrast::sealed, including all inherited members.
Accessibility() | SDKSample::HighContrast::sealed |
AccessibilityGetSettings_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HighContrast::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HighContrast::sealed | [private]
DoSomething_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HighContrast::sealed | [private]
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HighContrast::sealed | [private]
OnApplyTemplate() override | SDKSample::HighContrast::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HighContrast::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HighContrast::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HighContrast::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HighContrast::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HighContrast::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) | SDKSample::HighContrast::sealed | [protected, virtual]
Other_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HighContrast::sealed | [private]
rootPage | SDKSample::HighContrast::sealed | [private]
Scenario1() | SDKSample::HighContrast::sealed |
Scenario2() | SDKSample::HighContrast::sealed |
Scenario3() | SDKSample::HighContrast::sealed |
TargetButton() | SDKSample::HighContrast::sealed |
UI() | SDKSample::HighContrast::sealed |
UIGetSettings_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HighContrast::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/PinTile.xaml.h Source File

  • Secondary tiles
  • C#,C++

PinTile.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PinTile.xaml.h
00013 // Declaration of the PinTile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "PinTile.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SecondaryTiles
00023 {
00024     /// <summary>
00025     /// An empty page that can be used on its own or navigated to within a Frame.
00026     /// </summary>
00027     [Windows::Foundation::Metadata::WebHostHidden]
00028     public ref class PinTile sealed
00029     {
00030     public:
00031         PinTile();
00032
00033     protected:
00034         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00035         virtual void OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e) override;
00036     private:
00037         MainPage^ rootPage;
00038         Windows::UI::Xaml::Controls::AppBar^ appBar;
00039         void PinButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040     };
00041 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bluetooth call control/C++/pch.cpp Source File

  • Bluetooth call control

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/UserInterface.h Source File

  • DirectX marble maze game

UserInterface.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 class TextStyle
00011 {
00012 public:
00013     TextStyle();
00014
00015     void SetFontName(Platform::String^ fontName);
00016     void SetFontSize(float fontSize);
00017     void SetFontWeight(DWRITE_FONT_WEIGHT fontWeight);
00018     void SetFontStyle(DWRITE_FONT_STYLE fontStyle);
00019     void SetTextAlignment(DWRITE_TEXT_ALIGNMENT textAlignment);
00020
00021     IDWriteTextFormat* GetTextFormat();
00022
00023     bool HasTextFormatChanged() { return (m_textFormat == nullptr); }
00024
00025 private:
00026     Platform::String^       m_fontName;
00027     float                   m_fontSize;
00028     DWRITE_FONT_WEIGHT      m_fontWeight;
00029     DWRITE_FONT_STYLE       m_fontStyle;
00030     DWRITE_TEXT_ALIGNMENT   m_textAlignment;
00031
00032     Microsoft::WRL::ComPtr<IDWriteTextFormat>   m_textFormat;
00033 };
00034
00035 enum AlignType
00036 {
00037     AlignNear,
00038     AlignCenter,
00039     AlignFar,
00040 };
00041
00042 struct Alignment
00043 {
00044     AlignType horizontal;
00045     AlignType vertical;
00046 };
00047
00048 class ElementBase
00049 {
00050 public:
00051     virtual void Initialize() { }
00052     virtual void Update(float timeTotal, float timeDelta) { }
00053     virtual void Render() { }
00054
00055     void SetAlignment(AlignType horizontal, AlignType vertical);
00056     virtual void SetContainer(const D2D1_RECT_F& container);
00057     void SetVisible(bool visible);
00058
00059     D2D1_RECT_F GetBounds();
00060
00061     bool IsVisible() const { return m_visible; }
00062
00063 protected:
00064     ElementBase();
00065
00066     virtual void CalculateSize() { }
00067
00068     Alignment       m_alignment;
00069     D2D1_RECT_F     m_container;
00070     D2D1_SIZE_F     m_size;
00071     bool            m_visible;
00072 };
00073
00074 typedef std::set<ElementBase*> ElementSet;
00075
00076 class TextElement : public ElementBase
00077 {
00078 public:
00079     TextElement();
00080
00081     virtual void Initialize();
00082     virtual void Update(float timeTotal, float timeDelta);
00083     virtual void Render();
00084
00085     void SetTextColor(const D2D1_COLOR_F& textColor);
00086     void SetTextOpacity(float textOpacity);
00087
00088     void SetText(__nullterminated WCHAR* text);
00089     void SetText(Platform::String^ text);
00090
00091     TextStyle& GetTextStyle() { return m_textStyle; }
00092
00093     void FadeOut(float fadeOutTime);
00094
00095 protected:
00096     virtual void CalculateSize();
00097
00098     Platform::String^   m_text;
00099     D2D1_RECT_F         m_textExtents;
00100
00101     TextStyle           m_textStyle;
00102
00103     bool                m_isFadingOut;
00104     float               m_fadeStartingOpacity;
00105     float               m_fadeOutTime;
00106     float               m_fadeOutTimeElapsed;
00107
00108     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_textColorBrush;
00109     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_shadowColorBrush;
00110     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00111
00112     void CreateTextLayout();
00113 };
00114
00115 class CountdownTimer : public TextElement
00116 {
00117 public:
00118     CountdownTimer();
00119
00120     virtual void Initialize();
00121     virtual void Update(float timeTotal, float timeDelta);
00122     virtual void Render();
00123
00124     void StartCountdown(int seconds);
00125
00126     bool IsCountdownComplete() const;
00127
00128 protected:
00129     float   m_elapsedTime;
00130     int     m_secondsRemaining;
00131 };
00132
00133 class StopwatchTimer : public TextElement
00134 {
00135 public:
00136     StopwatchTimer();
00137
00138     virtual void Initialize();
00139     virtual void Update(float timeTotal, float timeDelta);
00140     virtual void Render();
00141
00142     void Start();
00143     void Stop();
00144     void Reset();
00145
00146     float GetElapsedTime() const { return m_elapsedTime; };
00147     void SetElapsedTime(float time) { m_elapsedTime = time; };
00148
00149     void GetFormattedTime(WCHAR* buffer, int length) const;
00150     template <size_t _Len>
00151     void GetFormattedTime(WCHAR (&buffer)[_Len]) const { GetFormattedTime(buffer, _Len); }
00152
00153     static void GetFormattedTime(WCHAR* buffer, int length, float time);
00154     template <size_t _Len>
00155     static void GetFormattedTime(WCHAR (&buffer)[_Len], float time) { GetFormattedTime(buffer, _Len, time); }
00156
00157 protected:
00158     bool    m_active;
00159     float   m_elapsedTime;
00160 };
00161
00162 class TextButton : public TextElement
00163 {
00164 public:
00165     TextButton();
00166
00167     virtual void Initialize();
00168     virtual void Update(float timeTotal, float timeDelta);
00169     virtual void Render();
00170
00171     void SetPadding(D2D1_SIZE_F padding);
00172     void SetSelected(bool selected);
00173
00174     bool GetSelected() const { return m_selected; }
00175
00176     void SetPressed(bool pressed);
00177     bool IsPressed() const { return m_pressed; }
00178
00179 protected:
00180     virtual void CalculateSize();
00181
00182     D2D1_SIZE_F     m_padding;
00183     bool            m_selected;
00184     bool            m_pressed;
00185 };
00186
00187 struct HighScoreEntry
00188 {
00189     Platform::String^ tag;
00190     float elapsedTime;
00191     bool wasJustAdded;
00192 };
00193
00194 #define MAX_HIGH_SCORES 5
00195 typedef std::vector<HighScoreEntry> HighScoreEntries;
00196
00197 class HighScoreTable : public TextElement
00198 {
00199 public:
00200     HighScoreTable();
00201
00202     virtual void Initialize();
00203     virtual void Update(float timeTotal, float timeDelta);
00204     virtual void Render();
00205
00206     void AddScoreToTable(HighScoreEntry& entry);
00207     HighScoreEntries GetEntries() { return m_entries; };
00208     void Reset();
00209
00210 protected:
00211     HighScoreEntries    m_entries;
00212
00213     void UpdateText();
00214 };
00215
00216 class UserInterface
00217 {
00218 public:
00219     static UserInterface& GetInstance() { return m_instance; }
00220
00221     static IDWriteFactory* GetDWriteFactory() { return m_instance.m_dwriteFactory.Get(); }
00222     static ID2D1DeviceContext* GetD2DContext() { return m_instance.m_d2dContext.Get(); }
00223
00224     void Initialize(
00225         _In_ ID2D1Device*         d2dDevice,
00226         _In_ ID2D1DeviceContext*  d2dContext,
00227         _In_ IWICImagingFactory*  wicFactory,
00228         _In_ IDWriteFactory*      dwriteFactory
00229         );
00230
00231     void Update(float timeTotal, float timeDelta);
00232     void Render();
00233
00234     void RegisterElement(ElementBase* element);
00235     void UnregisterElement(ElementBase* element);
00236
00237     void HitTest(D2D1_POINT_2F point);
00238
00239 private:
00240     UserInterface() { }
00241     ~UserInterface() { }
00242
00243     static UserInterface m_instance;
00244
00245     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00246     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00247     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00248     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00249     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00250     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00251
00252     ElementSet m_elements;
00253 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Camera Member List

This is the complete list of members for Camera, including all inherited members.
__pad0__ | Camera |
Eye(_In_ DirectX::XMFLOAT3 position) | Camera |
Eye() | Camera |
Eye(_In_ DirectX::XMFLOAT3 position) | Camera |
Eye() | Camera |
FarClipPlane() | Camera |
FarClipPlane() | Camera |
GetProjectionMatrix(_Out_ float4x4 *projectionMatrix) | Camera | [private]
LeftEyeProjection() | Camera |
LeftEyeProjection() | Camera |
LookAt() | Camera |
LookAt() | Camera |
LookDirection(_In_ DirectX::XMFLOAT3 lookDirection) | Camera |
LookDirection(_In_ DirectX::XMFLOAT3 lookDirection) | Camera |
m_aspectRatio | Camera | [private]
m_cameraPitchAngle | Camera | [private]
m_cameraYawAngle | Camera | [private]
m_direction | Camera | [private]
m_eye | Camera | [private]
m_farPlane | Camera | [private]
m_fieldOfView | Camera | [private]
m_inverseView | Camera | [private]
m_lookAt | Camera | [private]
m_nearPlane | Camera | [private]
m_position | Camera | [private]
m_projection | Camera | [private]
m_projectionMatrix | Camera | [private]
m_projectionMatrixLeft | Camera | [private]
m_projectionMatrixRight | Camera | [private]
m_up | Camera | [private]
m_view | Camera | [private]
m_viewMatrix | Camera | [private]
NearClipPlane() | Camera |
NearClipPlane() | Camera |
Pitch() | Camera |
Pitch() | Camera |
Projection() | Camera |
Projection() | Camera |
RightEyeProjection() | Camera |
RightEyeProjection() | Camera |
SetProjectionParameters(_In_ float minimumFieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane) | Camera | [private]
SetProjParams(_In_ float fieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane) | Camera |
SetProjParams(_In_ float fieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane) | Camera |
SetViewParameters(_In_ float3 eyePosition, _In_ float3 lookPosition, _In_ float3 up) | Camera | [private]
SetViewParams(_In_ DirectX::XMFLOAT3 eye, _In_ DirectX::XMFLOAT3 lookAt, _In_ DirectX::XMFLOAT3 up) | Camera |
SetViewParams(_In_ DirectX::XMFLOAT3 eye, _In_ DirectX::XMFLOAT3 lookAt, _In_ DirectX::XMFLOAT3 up) | Camera |
Up() | Camera |
Up() | Camera |
View() | Camera |
View() | Camera |
World() | Camera |
World() | Camera |
Yaw() | Camera |
Yaw() | Camera |
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchUriOutput.xaml.cpp Source File

  • Association launching

LaunchUriOutput.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // LaunchUriOutput.xaml.cpp
00010 // Implementation of the LaunchUriOutput class
00011 //
00012
00013 #include "pch.h"
00014 #include "LaunchUriOutput.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace AssociationLaunching;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 LaunchUriOutput::LaunchUriOutput()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 LaunchUriOutput::~LaunchUriOutput()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void LaunchUriOutput::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Get a pointer to our main page.
00045     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046 }
00047
00048 void LaunchUriOutput::OnNavigatedFrom(NavigationEventArgs^ e)
00049 {
00050 }
00051
00052 #pragma endregion
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/TextFlyout.xaml.cpp Source File

  • DirectX postcard app

TextFlyout.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "TextFlyout.xaml.h"
00010
00011 using namespace Postcard;
00012
00013 using namespace Platform;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Windows::System;
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::UI::Xaml::Controls;
00019 using namespace Windows::UI::Xaml::Controls::Primitives;
00020 using namespace Windows::UI::Xaml::Data;
00021 using namespace Windows::UI::Xaml::Input;
00022 using namespace Windows::UI::Xaml::Media;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 TextFlyout::TextFlyout()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 void TextFlyout::TextBoxKeyUp(Object^ sender, KeyRoutedEventArgs^ e)
00031 {
00032     Popup^ parent = dynamic_cast<Popup^>(this->Parent);
00033     if (e->Key == VirtualKey::Enter)
00034     {
00035         TextSubmitted(InputTextBox->Text);
00036         parent->IsOpen = false;
00037     }
00038     else if (e->Key == VirtualKey::Escape)
00039     {
00040         parent->IsOpen = false;
00041     }
00042 }
00043
00044 void TextFlyout::GotFocusHandler(Object^ sender, RoutedEventArgs^ e)
00045 {
00046     InputTextBox->SelectAll();
00047 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/pch.cpp Source File

  • DXGI offer and reclaim resources

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/PreviewUnavailable.xaml.h Source File

  • Print

PreviewUnavailable.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // PreviewUnavailable.xaml.h
00010 // Declaration of the PreviewUnavailable class
00011 //
00012
00013 #pragma once
00014
00015 #include "PreviewUnavailable.g.h"
00016
00017 namespace PrintSample
00018 {
00019     public ref class PreviewUnavailable sealed
00020     {
00021     public:
00022         PreviewUnavailable();
00023
00024         /// <summary>
00025         /// Preview unavailable page constructor
00026         /// </summary>
00027         /// <param name="paperSize">The printing page paper size</param>
00028         /// <param name="printableSize">The usable/"printable" area on the page</param>
00029         PreviewUnavailable(Windows::Foundation::Size paperSize, Windows::Foundation::Size printableSize);
00030     };
00031 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/sample-utils/CppSamplesUtils.h Source File

  • Clipboard app
  • sample-utils

CppSamplesUtils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/CppSamplesUtils.h Source File

  • Scheduled notifications
  • C#,C++

CppSamplesUtils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DDSTextureLoader.h Source File

  • Direct3D bump mapping

DDSTextureLoader.h

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.h
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #pragma once
00019
00020 void CreateDDSTextureFromMemory(
00021     _In_ ID3D11Device* d3dDevice,
00022     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
00023     _In_ size_t ddsDataSize,
00024     _Out_opt_ ID3D11Resource** texture,
00025     _Out_opt_ ID3D11ShaderResourceView** textureView,
00026     _In_ size_t maxsize = 0
00027     );
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/dllmain.cpp Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source

dllmain.cpp

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // dllmain.cpp
00004 //
00005 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00006 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00007 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00008 // PARTICULAR PURPOSE.
00009 //
00010 // Copyright (c) Microsoft Corporation. All rights reserved.
00011 //
00012 //////////////////////////////////////////////////////////////////////////
00013
00014 #include <wrl\module.h>
00015 #include "MPEG1Src.h"
00016 #include "MPEG1ByteStreamHandler.h"
00017
00018 using namespace Microsoft::WRL;
00019
00020 namespace Microsoft { namespace Samples {
00021     ActivatableClass(CMPEG1ByteStreamHandler);
00022 }}
00023
00024 BOOL WINAPI DllMain( _In_ HINSTANCE hInstance, _In_ DWORD dwReason, _In_opt_ LPVOID lpReserved )
00025 {
00026     if( DLL_PROCESS_ATTACH == dwReason )
00027     {
00028         //
00029         //  Don't need per-thread callbacks
00030         //
00031         DisableThreadLibraryCalls( hInstance );
00032
00033         Module<InProc>::GetModule().Create();
00034     }
00035     else if( DLL_PROCESS_DETACH == dwReason )
00036     {
00037         Module<InProc>::GetModule().Terminate();
00038     }
00039
00040     return TRUE;
00041 }
00042
00043 HRESULT WINAPI DllGetActivationFactory( _In_ HSTRING activatibleClassId, _Outptr_ IActivationFactory** factory )
00044 {
00045     auto &module = Microsoft::WRL::Module< Microsoft::WRL::InProc >::GetModule();
00046     return module.GetActivationFactory( activatibleClassId, factory );
00047 }
00048
00049 HRESULT WINAPI DllCanUnloadNow()
00050 {
00051     auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
00052     return (module.Terminate()) ? S_OK : S_FALSE;
00053 }
00054
00055 STDAPI DllGetClassObject( _In_ REFCLSID rclsid, _In_ REFIID riid, _Outptr_ LPVOID FAR* ppv )
00056 {
00057     auto &module = Microsoft::WRL::Module<Microsoft::WRL::InProc>::GetModule();
00058     return module.GetClassObject( rclsid, riid, ppv );
00059 }
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/common/LayoutAwarePage.h Source File

  • Display orientation
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ParticleData Member List

This is the complete list of members for ParticleData, including all inherited members.
pos | ParticleData
vel | ParticleData
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Audio.h Source File

  • DirectX 3D shooting game

Audio.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Audio:
00011 // This class uses XAudio2 to provide sound output.  It creates two
00012 // engines - one for music and the other for sound effects - each as
00013 // a separate mastering voice.
00014 // The SuspendAudio and ResumeAudio methods can be used to stop
00015 // and start all audio playback.
00016
00017 ref class Audio
00018 {
00019 internal:
00020     Audio();
00021
00022     void Initialize();
00023     void CreateDeviceIndependentResources();
00024     IXAudio2* MusicEngine();
00025     IXAudio2* SoundEffectEngine();
00026     void SuspendAudio();
00027     void ResumeAudio();
00028
00029 protected private:
00030     bool                                m_audioAvailable;
00031     Microsoft::WRL::ComPtr<IXAudio2>    m_musicEngine;
00032     Microsoft::WRL::ComPtr<IXAudio2>    m_soundEffectEngine;
00033     IXAudio2MasteringVoice*             m_musicMasteringVoice;
00034     IXAudio2MasteringVoice*             m_soundEffectMasteringVoice;
00035 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

PrintSample::PageDescription Member List

This is the complete list of members for PrintSample::PageDescription, including all inherited members.
IsContentCropped | PrintSample::PageDescription |
Margin | PrintSample::PageDescription |
operator!=(PageDescription pageDescriptiopn1, PageDescription pageDescription2) | PrintSample::PageDescription | [friend]
operator==(PageDescription pageDescriptiopn1, PageDescription pageDescription2) | PrintSample::PageDescription | [friend]
PageSize | PrintSample::PageDescription |
PictureViewSize | PrintSample::PageDescription |
ViewablePageSize | PrintSample::PageDescription |
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Scenario2.xaml.cpp Source File

  • SimpleOrientationSensor

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::SimpleOrientationSensorCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Devices::Sensors;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::UI::Core;
00027 using namespace Platform;
00028
00029 Scenario2::Scenario2() : rootPage(MainPage::Current)
00030 {
00031     InitializeComponent();
00032
00033     sensor = SimpleOrientationSensor::GetDefault();
00034     if (sensor == nullptr)
00035     {
00036         rootPage->NotifyUser("No simple orientation sensor found", NotifyType::ErrorMessage);
00037     }
00038 }
00039
00040 /// <summary>
00041 /// Invoked when this page is about to be displayed in a Frame.
00042 /// </summary>
00043 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00044 /// property is typically used to configure the page.</param>
00045 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00046 {
00047 }
00048
00049 void Scenario2::DisplayOrientation(SimpleOrientation orientation)
00050 {
00051     switch (orientation)
00052     {
00053         case SimpleOrientation::NotRotated:
00054             ScenarioOutput_Orientation->Text = "Not Rotated";
00055             break;
00056         case SimpleOrientation::Rotated90DegreesCounterclockwise:
00057             ScenarioOutput_Orientation->Text = "Rotated 90 Degrees Counterclockwise";
00058             break;
00059         case SimpleOrientation::Rotated180DegreesCounterclockwise:
00060             ScenarioOutput_Orientation->Text = "Rotated 180 Degrees Counterclockwise";
00061             break;
00062         case SimpleOrientation::Rotated270DegreesCounterclockwise:
00063             ScenarioOutput_Orientation->Text = "Rotated 270 Degrees Counterclockwise";
00064             break;
00065         case SimpleOrientation::Faceup:
00066             ScenarioOutput_Orientation->Text = "Faceup";
00067             break;
00068         case SimpleOrientation::Facedown:
00069             ScenarioOutput_Orientation->Text = "Facedown";
00070             break;
00071         default:
00072             ScenarioOutput_Orientation->Text = "Unknown orientation";
00073             break;
00074     }
00075 }
00076
00077 void Scenario2::ScenarioGet(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00078 {
00079     if (sensor != nullptr)
00080     {
00081         DisplayOrientation(sensor->GetCurrentOrientation());
00082     }
00083     else
00084     {
00085         rootPage->NotifyUser("No simple orientation sensor found", NotifyType::ErrorMessage);
00086     }
00087 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/Scenario2.xaml.h Source File

  • XAML two-dimensional transforms

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Transforms
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/MainPage.xaml.h Source File

  • Geolocation

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/pch.cpp Source File

  • Direct3D tutorial
  • Lesson2.Triangles

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/App.xaml.cpp Source File

  • Message dialog

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/SampleOverlay.cpp Source File

  • Direct2D effects on primitives

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/BasicMath.h Source File

  • XInput audio controller playback

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/App.xaml.cpp Source File

  • IXmlReader and IXmlWriter XML data readwrite

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/pch.cpp Source File

  • XAML personality animations

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CalendarExtensions.h Source File

  • Hilo C++
  • Hilo

CalendarExtensions.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     // The CalendarExtensions class contains helper functions for manipulating dates.
00012     class CalendarExtensions
00013     {
00014     public:
00015         static Platform::String^ CreateMonthRangeFromYearAndMonth(int year, int month);
00016         static Platform::String^ CreateMonthRangeFromDate(const Windows::Foundation::DateTime date);
00017         static int GetNumberOfMonthsInYear(const Windows::Foundation::DateTime yearDate);
00018         static Platform::String^ GetLocalizedAbbreviatedMonthName(int year, int month);
00019         static Platform::String^ GetLocalizedMonthAndYear(const Windows::Foundation::DateTime date);
00020         static Platform::String^ GetLocalizedYear(const Windows::Foundation::DateTime yearDate);
00021         static int GetNumericYear(const Windows::Foundation::DateTime yearDate);
00022         static void WriteLocalizedYearAndMonth(const Windows::Foundation::DateTime date, int& yearResult, int& monthResult);
00023         static Platform::String^ ResolvedLanguage();
00024         static Platform::String^ ResolvedGeographicRegion();
00025
00026     private:
00027         static std::wstring GetAqsFormattedDate(const Windows::Foundation::DateTime date);
00028         static Platform::String^ CreateMonthRangeFromDate(Windows::Globalization::Calendar^ cal);
00029         static Windows::Globalization::Calendar^ GetCalendar();
00030     };
00031 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Hilo::PhotoPathComparer Member List

This is the complete list of members for Hilo::PhotoPathComparer, including all inherited members.
operator()(IPhoto^left, IPhoto^right) const Hilo::PhotoPathComparer
Generated on Sat Nov 23 2024 16:09:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/common/LayoutAwarePage.cpp Source File

  • File picker
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/common/LayoutAwarePage.cpp Source File

  • Playback Manager msAudioCategory
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/app_cs/App.xaml.cs Source File

  • Custom driver access
  • C#,C++
  • app_cs

App.xaml.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using Windows.ApplicationModel;
00012 using Windows.ApplicationModel.Activation;
00013 using Windows.UI.Xaml;
00014 using Windows.UI.Xaml.Controls;
00015 using Windows.UI.Xaml.Navigation;
00016 using SDKTemplate;
00017
00018 namespace SDKTemplate
00019 {
00020     /// <summary>
00021     /// Provides application-specific behavior to supplement the default Application class.
00022     /// </summary>
00023     sealed partial class App : Application
00024     {
00025         public LaunchActivatedEventArgs LaunchArgs;
00026
00027         /// <summary>
00028         /// Initializes the singleton application object.  This is the first line of authored code
00029         /// executed, and as such is the logical equivalent of main() or WinMain().
00030         /// </summary>
00031         public App()
00032         {
00033             this.InitializeComponent();
00034             this.Suspending += new SuspendingEventHandler(OnSuspending);
00035         }
00036
00037         async void OnSuspending(object sender, SuspendingEventArgs args)
00038         {
00039             SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
00040             await SuspensionManager.SaveAsync();
00041             deferral.Complete();
00042         }
00043
00044         /// <summary>
00045         /// Invoked when the application is launched normally by the end user.  Other entry points
00046         /// will be used when the application is launched to open a specific file, to display
00047         /// search results, and so forth.
00048         /// </summary>
00049         /// <param name="args">Details about the launch request and process.</param>
00050         async protected override void OnLaunched(LaunchActivatedEventArgs args)
00051         {
00052             this.LaunchArgs = args;
00053
00054             Frame rootFrame = null;
00055             if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
00056             {
00057                 // Do an asynchronous restore
00058                 await SuspensionManager.RestoreAsync();
00059             }
00060             if (Window.Current.Content == null)
00061             {
00062                 rootFrame = new Frame();
00063                 rootFrame.Navigate(typeof(MainPage));
00064                 Window.Current.Content = rootFrame;
00065             }
00066             Window.Current.Activate();
00067         }
00068     }
00069 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Constants.h Source File

  • Folder enumeration

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Folder enumeration C++ sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042     private:
00043         static Platform::Array<Scenario>^ scenariosInner;
00044     };
00045 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideBlockAndText01 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideBlockAndText01, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBlock | NotificationsExtensions::TileContent::TileWideBlockAndText01 |
TextBody1 | NotificationsExtensions::TileContent::TileWideBlockAndText01 |
TextBody2 | NotificationsExtensions::TileContent::TileWideBlockAndText01 |
TextBody3 | NotificationsExtensions::TileContent::TileWideBlockAndText01 |
TextBody4 | NotificationsExtensions::TileContent::TileWideBlockAndText01 |
TextFields | NotificationsExtensions::NotificationBase |
TextSubBlock | NotificationsExtensions::TileContent::TileWideBlockAndText01 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBlockAndText01() | NotificationsExtensions::TileContent::TileWideBlockAndText01 | [inline]
TileWideBlockAndText01() | NotificationsExtensions::TileContent::TileWideBlockAndText01 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/MainPage.xaml.cpp Source File

  • XAML Direct2D lighting effects

MainPage.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "MainPage.xaml.h"
00010
00011 using namespace D2DLightingEffects;
00012
00013 using namespace Platform;
00014 using namespace Windows::ApplicationModel;
00015 using namespace Windows::ApplicationModel::Core;
00016 using namespace Windows::ApplicationModel::Activation;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Foundation::Collections;
00019 using namespace Windows::Graphics::Display;
00020 using namespace Windows::Storage;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::Input;
00024 using namespace Windows::UI::ViewManagement;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Controls::Primitives;
00028 using namespace Windows::UI::Xaml::Data;
00029 using namespace Windows::UI::Xaml::Input;
00030 using namespace Windows::UI::Xaml::Media;
00031 using namespace Windows::UI::Xaml::Navigation;
00032 using namespace Microsoft::WRL;
00033
00034 MainPage::MainPage()
00035 {
00036     m_renderer = ref new D2DLightingEffectsRenderer();
00037     m_renderer->Initialize(Window::Current->CoreWindow, this, DisplayProperties::LogicalDpi);
00038
00039     InitializeComponent();
00040
00041     PointerMoved += ref new PointerEventHandler(this, &MainPage::OnSwapChainPointerMoved);
00042
00043     Window::Current->CoreWindow->SizeChanged +=
00044         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &MainPage::OnWindowSizeChanged);
00045
00046     DisplayProperties::LogicalDpiChanged +=
00047         ref new DisplayPropertiesEventHandler(this, &MainPage::OnLogicalDpiChanged);
00048
00049     DisplayProperties::DisplayContentsInvalidated +=
00050         ref new DisplayPropertiesEventHandler(this, &MainPage::OnDisplayContentsInvalidated);
00051
00052     InitializeValues();
00053
00054     // Automatically position light where cursor is on
00055     // startup without waiting for mouse movement event.
00056     Point mousePosition = Window::Current->CoreWindow->PointerPosition;
00057     m_renderer->OnPointerMoved(mousePosition.X, mousePosition.Y);
00058     m_renderer->Render();
00059 }
00060
00061 void MainPage::OnEffectSelectorSelectionChanged(
00062     Object^ sender,
00063     SelectionChangedEventArgs^ e
00064     )
00065 {
00066     // Properties not used by the current lighting effect need to be hidden.
00067     // This is done using the VisualStateManager and the VisualStates defined in MainPage.xaml
00068
00069     switch (EffectSelector->SelectedIndex)
00070     {
00071     case LightingEffect::PointSpecular:
00072         VisualStateManager::GoToState(this->LayoutControl, "SpecularState", true);
00073         VisualStateManager::GoToState(this->LayoutControl, "PointState", true);
00074         break;
00075     case LightingEffect::SpotSpecular:
00076         VisualStateManager::GoToState(this->LayoutControl, "SpecularState", true);
00077         VisualStateManager::GoToState(this->LayoutControl, "SpotState", true);
00078         break;
00079     case LightingEffect::DistantSpecular:
00080         VisualStateManager::GoToState(this->LayoutControl, "SpecularState", true);
00081         VisualStateManager::GoToState(this->LayoutControl, "DistantState", true);
00082         break;
00083     case LightingEffect::PointDiffuse:
00084         VisualStateManager::GoToState(this->LayoutControl, "DiffuseState", true);
00085         VisualStateManager::GoToState(this->LayoutControl, "PointState", true);
00086         break;
00087     case LightingEffect::SpotDiffuse:
00088         VisualStateManager::GoToState(this->LayoutControl, "DiffuseState", true);
00089         VisualStateManager::GoToState(this->LayoutControl, "SpotState", true);
00090         break;
00091     case LightingEffect::DistantDiffuse:
00092         VisualStateManager::GoToState(this->LayoutControl, "DiffuseState", true);
00093         VisualStateManager::GoToState(this->LayoutControl, "DistantState", true);
00094         break;
00095     default:
00096         throw ref new Platform::FailureException();
00097         break;
00098     }
00099
00100     EffectControls->UpdateLayout();
00101
00102     SetLightingEffect(static_cast<LightingEffect>(EffectSelector->SelectedIndex));
00103 }
00104
00105 void MainPage::OnLightPositionZValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00106 {
00107     SetLightingProperty(
00108         LightingProperty::LightPositionZ,
00109         static_cast<float>(e->NewValue)
00110         );
00111 }
00112
00113 void MainPage::OnSpecularConstantValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00114 {
00115     SetLightingProperty(
00116         LightingProperty::SpecularConstant,
00117         static_cast<float>(e->NewValue)
00118         );
00119 }
00120
00121 void MainPage::OnSpecularExponentValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00122 {
00123     SetLightingProperty(
00124         LightingProperty::SpecularExponent,
00125         static_cast<float>(e->NewValue)
00126         );
00127 }
00128
00129 void MainPage::OnDiffuseConstantValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00130 {
00131     SetLightingProperty(
00132         LightingProperty::DiffuseConstant,
00133         static_cast<float>(e->NewValue)
00134         );
00135 }
00136
00137 void MainPage::OnSpotFocusValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00138 {
00139     SetLightingProperty(
00140         LightingProperty::Focus,
00141         static_cast<float>(e->NewValue)
00142         );
00143 }
00144
00145 void MainPage::OnLimitingConeAngleValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00146 {
00147     SetLightingProperty(
00148         LightingProperty::LimitingConeAngle,
00149         static_cast<float>(e->NewValue)
00150         );
00151 }
00152
00153 void MainPage::OnAzimuthValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00154 {
00155     SetLightingProperty(
00156         LightingProperty::Azimuth,
00157         static_cast<float>(e->NewValue)
00158         );
00159 }
00160
00161 void MainPage::OnElevationValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00162 {
00163     SetLightingProperty(
00164         LightingProperty::Elevation,
00165         static_cast<float>(e->NewValue)
00166         );
00167 }
00168
00169 void MainPage::OnSurfaceScaleValueChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00170 {
00171     SetLightingProperty(
00172         LightingProperty::SurfaceScale,
00173         static_cast<float>(e->NewValue)
00174         );
00175 }
00176
00177 void MainPage::OnRestoreDefaultsClick(Object^ sender, RoutedEventArgs^ e)
00178 {
00179     ResetValues();
00180     m_renderer->Render();
00181 }
00182
00183 void MainPage::InitializeValues()
00184 {
00185     ResetValues();
00186
00187     // Retrieve user-manipulated variables from the LocalSettings collection if the app was previously terminated after being suspended.
00188     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00189
00190     if (settingsValues->HasKey("CurrentEffect"))
00191     {
00192         EffectSelector->SelectedIndex = safe_cast<IPropertyValue^>(settingsValues->Lookup("CurrentEffect"))->GetInt32();
00193     }
00194
00195     if (settingsValues->HasKey("LightPositionZ"))
00196     {
00197         LightPositionZ->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("LightPositionZ"))->GetDouble();
00198     }
00199
00200     if (settingsValues->HasKey("SpecularConstant"))
00201     {
00202         SpecularConstant->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("SpecularConstant"))->GetDouble();
00203     }
00204
00205     if (settingsValues->HasKey("SpecularExponent"))
00206     {
00207         SpecularExponent->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("SpecularExponent"))->GetDouble();
00208     }
00209
00210     if (settingsValues->HasKey("DiffuseConstant"))
00211     {
00212         DiffuseConstant->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("DiffuseConstant"))->GetDouble();
00213     }
00214
00215     if (settingsValues->HasKey("SpotFocus"))
00216     {
00217         SpotFocus->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("SpotFocus"))->GetDouble();
00218     }
00219
00220     if (settingsValues->HasKey("LimitingConeAngle"))
00221     {
00222         LimitingConeAngle->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("LimitingConeAngle"))->GetDouble();
00223     }
00224
00225     if (settingsValues->HasKey("Azimuth"))
00226     {
00227         Azimuth->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("Azimuth"))->GetDouble();
00228     }
00229
00230     if (settingsValues->HasKey("Elevation"))
00231     {
00232         Elevation->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("Elevation"))->GetDouble();
00233     }
00234
00235     if (settingsValues->HasKey("SurfaceScale"))
00236     {
00237         SurfaceScale->Value = safe_cast<IPropertyValue^>(settingsValues->Lookup("SurfaceScale"))->GetDouble();
00238     }
00239 }
00240
00241 void MainPage::ResetValues()
00242 {
00243     EffectSelector->SelectedIndex = 0;
00244     LightPositionZ->Value = 100;
00245     SpecularConstant->Value = 1;
00246     SpecularExponent->Value = 2;
00247     DiffuseConstant->Value = 1;
00248     SpotFocus->Value = 1;
00249     LimitingConeAngle->Value = 90;
00250     Azimuth->Value = 0;
00251     Elevation->Value = 0;
00252     SurfaceScale->Value = 3;
00253 }
00254
00255 void MainPage::SetLightingEffect(LightingEffect lightingEffect)
00256 {
00257     m_renderer->SetLightingEffect(lightingEffect);
00258     m_renderer->Render();
00259 }
00260
00261 void MainPage::SetLightingProperty(LightingProperty lightingProperty, float value)
00262 {
00263     m_renderer->SetLightingProperty(lightingProperty, value);
00264     m_renderer->Render();
00265 }
00266
00267 void MainPage::OnSwapChainPointerMoved(
00268     Object^ sender,
00269     PointerRoutedEventArgs^ args
00270     )
00271 {
00272     PointerPoint^ point = args->GetCurrentPoint(
00273         reinterpret_cast<SwapChainBackgroundPanel^>(sender)
00274         );
00275
00276     m_renderer->OnPointerMoved(point->Position.X, point->Position.Y);
00277     m_renderer->Render();
00278 }
00279
00280 void MainPage::OnSuspending(
00281     Object^ sender,
00282     SuspendingEventArgs^ args
00283     )
00284 {
00285     // Store user-manipulated properties in the LocalSettings collection.
00286     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00287
00288     // Check to ensure each key is not already in the collection. If it is present, remove
00289     // it, before storing in the new value. These values will be retrieved in the InitializeValues method.
00290
00291     if (settingsValues->HasKey("CurrentEffect"))
00292     {
00293         settingsValues->Remove("CurrentEffect");
00294     }
00295     settingsValues->Insert("CurrentEffect", PropertyValue::CreateInt32(EffectSelector->SelectedIndex));
00296
00297     if (settingsValues->HasKey("LightPositionZ"))
00298     {
00299         settingsValues->Remove("LightPositionZ");
00300     }
00301     settingsValues->Insert("LightPositionZ", PropertyValue::CreateDouble(LightPositionZ->Value));
00302
00303     if (settingsValues->HasKey("SpecularConstant"))
00304     {
00305         settingsValues->Remove("SpecularConstant");
00306     }
00307     settingsValues->Insert("SpecularConstant", PropertyValue::CreateDouble(SpecularConstant->Value));
00308
00309     if (settingsValues->HasKey("SpecularExponent"))
00310     {
00311         settingsValues->Remove("SpecularExponent");
00312     }
00313     settingsValues->Insert("SpecularExponent", PropertyValue::CreateDouble(SpecularExponent->Value));
00314
00315     if (settingsValues->HasKey("DiffuseConstant"))
00316     {
00317         settingsValues->Remove("DiffuseConstant");
00318     }
00319     settingsValues->Insert("DiffuseConstant", PropertyValue::CreateDouble(DiffuseConstant->Value));
00320
00321     if (settingsValues->HasKey("SpotFocus"))
00322     {
00323         settingsValues->Remove("SpotFocus");
00324     }
00325     settingsValues->Insert("SpotFocus", PropertyValue::CreateDouble(SpotFocus->Value));
00326
00327     if (settingsValues->HasKey("LimitingConeAngle"))
00328     {
00329         settingsValues->Remove("LimitingConeAngle");
00330     }
00331     settingsValues->Insert("LimitingConeAngle", PropertyValue::CreateDouble(LimitingConeAngle->Value));
00332
00333     if (settingsValues->HasKey("Azimuth"))
00334     {
00335         settingsValues->Remove("Azimuth");
00336     }
00337     settingsValues->Insert("Azimuth", PropertyValue::CreateDouble(Azimuth->Value));
00338
00339     if (settingsValues->HasKey("Elevation"))
00340     {
00341         settingsValues->Remove("Elevation");
00342     }
00343     settingsValues->Insert("Elevation", PropertyValue::CreateDouble(Elevation->Value));
00344
00345     if (settingsValues->HasKey("SurfaceScale"))
00346     {
00347         settingsValues->Remove("SurfaceScale");
00348     }
00349     settingsValues->Insert("SurfaceScale", PropertyValue::CreateDouble(SurfaceScale->Value));
00350 }
00351
00352 void MainPage::OnLogicalDpiChanged(
00353     Object^ sender
00354     )
00355 {
00356     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00357     m_renderer->Render();
00358 }
00359
00360 void MainPage::OnDisplayContentsInvalidated(
00361     Object^ sender
00362     )
00363 {
00364     // Ensure the D3D Device is available for rendering.
00365     m_renderer->ValidateDevice();
00366
00367     if (m_renderer->NeedsResourceUpdate())
00368     {
00369         // Reset the effect properties since all resources were lost when the device was lost.
00370         m_renderer->SetLightingEffect(static_cast<LightingEffect>(EffectSelector->SelectedIndex));
00371         m_renderer->SetLightingProperty(LightingProperty::LightPositionZ, static_cast<float>(LightPositionZ->Value));
00372         m_renderer->SetLightingProperty(LightingProperty::SpecularConstant, static_cast<float>(SpecularConstant->Value));
00373         m_renderer->SetLightingProperty(LightingProperty::SpecularExponent, static_cast<float>(SpecularExponent->Value));
00374         m_renderer->SetLightingProperty(LightingProperty::DiffuseConstant, static_cast<float>(DiffuseConstant->Value));
00375         m_renderer->SetLightingProperty(LightingProperty::Focus, static_cast<float>(SpotFocus->Value));
00376         m_renderer->SetLightingProperty(LightingProperty::LimitingConeAngle, static_cast<float>(LimitingConeAngle->Value));
00377         m_renderer->SetLightingProperty(LightingProperty::Azimuth, static_cast<float>(Azimuth->Value));
00378         m_renderer->SetLightingProperty(LightingProperty::Elevation, static_cast<float>(Elevation->Value));
00379         m_renderer->SetLightingProperty(LightingProperty::SurfaceScale, static_cast<float>(SurfaceScale->Value));
00380
00381         // Position light at the cursor's last position.
00382         Point mousePosition = Window::Current->CoreWindow->PointerPosition;
00383         m_renderer->OnPointerMoved(mousePosition.X, mousePosition.Y);
00384     }
00385
00386     m_renderer->Render();
00387 }
00388
00389 void MainPage::OnWindowSizeChanged(
00390     CoreWindow^ sender,
00391     WindowSizeChangedEventArgs^ args
00392     )
00393 {
00394     if (ApplicationView::Value == ApplicationViewState::Snapped)
00395     {
00396         VisualStateManager::GoToState(this->LayoutControl, "SnappedState", true);
00397     }
00398     else
00399     {
00400         VisualStateManager::GoToState(this->LayoutControl, "UnsnappedState", true);
00401     }
00402
00403     m_renderer->UpdateForViewStateChanged(ApplicationView::Value);
00404     m_renderer->UpdateForWindowSizeChange();
00405     m_renderer->Render();
00406 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Mpeg1Source/MPEG1Stream.h Source File

  • Media extensions
  • MediaExtensions
  • Mpeg1Source

MPEG1Stream.h

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // MPEG1Stream.h
00004 // Implements the stream object (IMFMediaStream) for the MPEG-1 source.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015 #pragma once
00016
00017 class CMPEG1Source;
00018
00019 // The media stream object.
00020 class CMPEG1Stream : public IMFMediaStream
00021 {
00022 public:
00023
00024     CMPEG1Stream(CMPEG1Source *pSource, IMFStreamDescriptor *pSD, HRESULT& hr);
00025     ~CMPEG1Stream();
00026
00027     // IUnknown
00028     STDMETHODIMP QueryInterface(REFIID iid, void** ppv);
00029     STDMETHODIMP_(ULONG) AddRef();
00030     STDMETHODIMP_(ULONG) Release();
00031
00032     // IMFMediaEventGenerator
00033     STDMETHODIMP BeginGetEvent(IMFAsyncCallback* pCallback,IUnknown* punkState);
00034     STDMETHODIMP EndGetEvent(IMFAsyncResult* pResult, IMFMediaEvent** ppEvent);
00035     STDMETHODIMP GetEvent(DWORD dwFlags, IMFMediaEvent** ppEvent);
00036     STDMETHODIMP QueueEvent(MediaEventType met, REFGUID guidExtendedType, HRESULT hrStatus, const PROPVARIANT* pvValue);
00037
00038     // IMFMediaStream
00039     STDMETHODIMP GetMediaSource(IMFMediaSource** ppMediaSource);
00040     STDMETHODIMP GetStreamDescriptor(IMFStreamDescriptor** ppStreamDescriptor);
00041     STDMETHODIMP RequestSample(IUnknown* pToken);
00042
00043     // Other methods (called by source)
00044     HRESULT     Activate(BOOL bActive);
00045     HRESULT     Start(const PROPVARIANT& varStart);
00046     HRESULT     Pause();
00047     HRESULT     Stop();
00048     HRESULT     SetRate(float flRate);
00049     HRESULT     EndOfStream();
00050     HRESULT     Shutdown();
00051
00052     BOOL        IsActive() const { return m_bActive; }
00053     BOOL        NeedsData();
00054
00055     HRESULT     DeliverPayload(IMFSample *pSample);
00056
00057     // Callbacks
00058     HRESULT     OnDispatchSamples(IMFAsyncResult *pResult);
00059
00060 private:
00061
00062     // SourceLock class:
00063     // Small helper class to lock and unlock the source.
00064     class SourceLock
00065     {
00066     private:
00067         CMPEG1Source *m_pSource;
00068     public:
00069     _Acquires_lock_(m_pSource)
00070         SourceLock(CMPEG1Source *pSource);
00071
00072     _Releases_lock_(m_pSource)
00073         ~SourceLock();
00074     };
00075
00076 private:
00077
00078     HRESULT CheckShutdown() const
00079     {
00080         return ( m_state == STATE_SHUTDOWN ? MF_E_SHUTDOWN : S_OK );
00081     }
00082     HRESULT DispatchSamples();
00083
00084
00085 private:
00086     long                m_cRef;                 // reference count
00087
00088     CMPEG1Source        *m_pSource;             // Parent media source
00089     IMFStreamDescriptor *m_pStreamDescriptor;
00090     IMFMediaEventQueue  *m_pEventQueue;         // Event generator helper
00091
00092     SourceState         m_state;                // Current state (running, stopped, paused)
00093     BOOL                m_bActive;              // Is the stream active?
00094     BOOL                m_bEOS;                 // Did the source reach the end of the stream?
00095
00096     SampleList          m_Samples;              // Samples waiting to be delivered.
00097     TokenList           m_Requests;             // Sample requests, waiting to be dispatched.
00098
00099     float               m_flRate;
00100 };
00101
00102
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Material Member List

This is the complete list of members for Material, including all inherited members.
__pad0__ | Material |
diffuseColor | Material |
m_diffuseColor | Material | [private]
m_hitColor | Material | [private]
m_meshColor | Material | [private]
m_pixelShader | Material | [private]
m_specularColor | Material | [private]
m_specularExponent | Material | [private]
m_textureRV | Material | [private]
m_vertexShader | Material | [private]
pixelShader | Material |
RenderSetup(_In_ ID3D11DeviceContext *context, _Inout_ ConstantBufferChangesEveryPrim *constantBuffer) | Material |
RenderSetup(_In_ ID3D11DeviceContext *context, _Inout_ ConstantBufferChangesEveryPrim *constantBuffer) | Material |
SetTexture(_In_ ID3D11ShaderResourceView *textureResourceView) | Material | [inline]
SetTexture(_In_ ID3D11ShaderResourceView *textureResourceView) | Material | [inline]
specularColor | Material |
specularExponent | Material |
textureResourceView | Material |
vertexShader | Material |
Generated on Sat Nov 23 2024 16:09:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/App.xaml.cpp Source File

  • App package information

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/pch.h Source File

  • DirectWrite custom text renderer

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1_1helper.h>
00014 #include <d2d1effects.h>
00015 #include <dwrite_1.h>
00016 #include <wincodec.h>
00017 #include <math.h>
00018 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/pch.h Source File

  • XInput audio controller playback

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
00017 #include "BasicMath.h"
00018 #include <vector>
00019 #include "strsafe.h"
00020
00021 #include <XInput.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/TextFrame.cpp Source File

  • Direct2D magazine app

TextFrame.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Microsoft::WRL;
00011 using namespace Windows::Data::Xml::Dom;
00012
00013 TextFrame::TextFrame() :
00014     Element(),
00015     m_sourceName(nullptr),
00016     m_sourceText(nullptr),
00017     m_brush(),
00018     m_contentBitmap(),
00019     m_displaySize(),
00020     m_glowEffect(),
00021     m_compositeEffect(),
00022     m_topMargin(0),
00023     m_bottomMargin(0),
00024     m_leading(0),
00025     m_baseline(0),
00026     m_textAlign(DWRITE_TEXT_ALIGNMENT_LEADING),
00027     m_color(0),
00028     m_opacity(1.0f),
00029     m_fontSize()
00030 {
00031 }
00032
00033 bool TextFrame::Initialize(
00034     _In_ Document^ document,
00035     _In_ XmlElement^ xmlElement
00036     )
00037 {
00038     if (!Element::Initialize(document, xmlElement))
00039     {
00040         return false;
00041     }
00042
00043     Platform::String^ value = xmlElement->GetAttribute("source");
00044
00045     if (value != nullptr)
00046     {
00047         m_sourceName = ParseNameIdentifier(value);
00048     }
00049
00050     value = xmlElement->GetAttribute("font-size");
00051
00052     if (value != nullptr)
00053     {
00054         m_fontSize = static_cast<float>(_wtof(value->Data()));
00055     }
00056
00057     value = xmlElement->GetAttribute("color");
00058
00059     if (value != nullptr)
00060     {
00061         m_color = ParseColor(value);
00062     }
00063
00064     value = xmlElement->GetAttribute("opacity");
00065
00066     if (value != nullptr)
00067     {
00068         m_opacity = static_cast<float>(_wtof(value->Data()));
00069     }
00070
00071     value = xmlElement->GetAttribute("top-margin");
00072
00073     if (value != nullptr)
00074     {
00075         m_topMargin = static_cast<float>(_wtof(value->Data()));
00076     }
00077
00078     value = xmlElement->GetAttribute("bottom-margin");
00079
00080     if (value != nullptr)
00081     {
00082         m_bottomMargin = static_cast<float>(_wtof(value->Data()));
00083     }
00084
00085     value = xmlElement->GetAttribute("leading");
00086
00087     if (value != nullptr)
00088     {
00089         m_leading = static_cast<float>(_wtof(value->Data()));
00090     }
00091
00092     value = xmlElement->GetAttribute("baseline");
00093
00094     if (value != nullptr)
00095     {
00096         m_baseline = static_cast<float>(_wtof(value->Data()));
00097     }
00098
00099     value = xmlElement->GetAttribute("text-align");
00100
00101     if (value != nullptr)
00102     {
00103         if (value == "leading")
00104         {
00105             m_textAlign = DWRITE_TEXT_ALIGNMENT_LEADING;
00106         }
00107         else if (value == "trailing")
00108         {
00109             m_textAlign = DWRITE_TEXT_ALIGNMENT_TRAILING;
00110         }
00111         else if (value == "center")
00112         {
00113             m_textAlign = DWRITE_TEXT_ALIGNMENT_CENTER;
00114         }
00115     }
00116
00117     value = xmlElement->GetAttribute("glow");
00118
00119     if (value != nullptr)
00120     {
00121         auto renderer = document->GetRenderer();
00122
00123         ComPtr<ID2D1DeviceContext> d2dDeviceContext;
00124         renderer->GetD2DDeviceContext(&d2dDeviceContext);
00125
00126         uint32 glowColor = 0;
00127
00128         DX::ThrowIfFailed(
00129             d2dDeviceContext->CreateEffect(
00130                 CLSID_D2D1Shadow,
00131                 &m_glowEffect
00132                 )
00133             );
00134
00135         DX::ThrowIfFailed(
00136             m_glowEffect->SetValue(
00137                 D2D1_SHADOW_PROP_BLUR_STANDARD_DEVIATION,
00138                 static_cast<float>(_wtof(value->Data()))
00139                 )
00140             );
00141
00142         value = xmlElement->GetAttribute("glow-color");
00143
00144         if (value != nullptr)
00145         {
00146             glowColor = ParseColor(value);
00147         }
00148
00149         DX::ThrowIfFailed(
00150             m_glowEffect->SetValue(
00151                 D2D1_SHADOW_PROP_COLOR,
00152                 D2D1::ColorF(glowColor)
00153                 )
00154             );
00155
00156         DX::ThrowIfFailed(
00157             d2dDeviceContext->CreateEffect(
00158                 CLSID_D2D1Composite,
00159                 &m_compositeEffect
00160                 )
00161             );
00162
00163         DX::ThrowIfFailed(
00164             m_compositeEffect->SetValue(
00165                 D2D1_COMPOSITE_PROP_MODE,
00166                 D2D1_COMPOSITE_MODE_SOURCE_OVER
00167                 )
00168             );
00169
00170         m_compositeEffect->SetInputEffect(
00171             0,
00172             m_glowEffect.Get()
00173             );
00174     }
00175
00176     return true;
00177 }
00178
00179 bool TextFrame::BindResource(_In_ Element^ rootElement)
00180 {
00181     if (rootElement != nullptr)
00182     {
00183         TreeIterator<Element> it(rootElement);
00184
00185         // Traverse the tree looking for the source image
00186         do
00187         {
00188             ::Text^ text(dynamic_cast<::Text^>(it.GetCurrentNode()));
00189
00190             if (text != nullptr && text->GetName() == m_sourceName)
00191             {
00192                 m_sourceText = text;
00193                 return true;
00194             }
00195
00196         } while (++it);
00197     }
00198
00199     return false;
00200 }
00201
00202 void TextFrame::Measure(
00203     _In_ Document^ document,
00204     D2D1_SIZE_F const& parentSize,
00205     _Out_ D2D1_RECT_F* bounds
00206     )
00207 {
00208     ComPtr<IDWriteTextLayout> textLayout;
00209     m_sourceText->GetTextLayout(&textLayout);
00210
00211     if (m_fontSize != 0)
00212     {
00213         DWRITE_TEXT_RANGE range = {0};
00214         range.length = static_cast<uint32>(m_sourceText->GetLength());
00215
00216         DX::ThrowIfFailed(
00217             textLayout->SetFontSize(m_fontSize, range)
00218             );
00219     }
00220
00221     if (m_size.width <= 0 && m_size.height <= 0)
00222     {
00223         // When no size is specified, assume its parent width and height
00224         m_size = D2D1::SizeF(parentSize.width, parentSize.height);
00225     }
00226
00227     D2D1_SIZE_F size = D2D1::SizeF(m_size.width, FLT_MAX);
00228
00229     if (m_topMargin + m_bottomMargin < size.height)
00230     {
00231         size = D2D1::SizeF(size.width, size.height - m_topMargin - m_bottomMargin);
00232     }
00233     else
00234     {
00235         m_topMargin = m_bottomMargin = 0;
00236     }
00237
00238     // Set layout max width and height for text
00239     DX::ThrowIfFailed(
00240         textLayout->SetMaxWidth(size.width)
00241         );
00242
00243     DX::ThrowIfFailed(
00244         textLayout->SetMaxHeight(size.height)
00245         );
00246
00247     // Set proper horizontal alignment and line spacing
00248     DX::ThrowIfFailed(
00249         textLayout->SetTextAlignment(m_textAlign)
00250         );
00251
00252     if (m_leading != 0)
00253     {
00254         DX::ThrowIfFailed(
00255             textLayout->SetLineSpacing(
00256                 DWRITE_LINE_SPACING_METHOD_UNIFORM,
00257                 m_leading,
00258                 m_baseline
00259                 )
00260             );
00261     }
00262     else
00263     {
00264         DX::ThrowIfFailed(
00265             textLayout->SetLineSpacing(
00266                 DWRITE_LINE_SPACING_METHOD_DEFAULT,
00267                 m_leading,
00268                 m_baseline
00269                 )
00270             );
00271     }
00272
00273     // Calculate the text layout metrics
00274     DWRITE_TEXT_METRICS textMetrics = {0};
00275
00276     DX::ThrowIfFailed(
00277         textLayout->GetMetrics(&textMetrics)
00278         );
00279
00280     // The final height is the text layout height plus top and bottom margin.
00281     m_size = D2D1::SizeF(textMetrics.width, textMetrics.height + m_topMargin + m_bottomMargin);
00282
00283     *bounds = D2D1::RectF(
00284         m_offset.x,
00285         m_offset.y,
00286         m_offset.x + m_size.width,
00287         m_offset.y + m_size.height
00288         );
00289 }
00290
00291 bool TextFrame::PrepareToDraw(
00292     _In_ Document^ document,
00293     D2D1::Matrix3x2F const& transform
00294     )
00295 {
00296     auto renderer = document->GetRenderer();
00297
00298     ComPtr<ID2D1DeviceContext> d2dDeviceContext;
00299     renderer->GetD2DDeviceContext(&d2dDeviceContext);
00300
00301     if (m_brush == nullptr)
00302     {
00303         ComPtr<ID2D1SolidColorBrush> solidColorBrush;
00304
00305         DX::ThrowIfFailed(
00306             d2dDeviceContext->CreateSolidColorBrush(
00307                 D2D1::ColorF(m_color, m_opacity),
00308                 D2D1::BrushProperties(),
00309                 &solidColorBrush
00310                 )
00311             );
00312
00313         m_brush = solidColorBrush;
00314     }
00315
00316     if (    m_glowEffect != nullptr
00317         &&  m_compositeEffect != nullptr
00318         &&  (   m_contentBitmap == nullptr
00319             ||  m_displaySize.width != renderer->GetDisplayWidth()
00320             ||  m_displaySize.height != renderer->GetDisplayHeight()
00321             )
00322         )
00323     {
00324         ComPtr<IDWriteTextLayout> textLayout;
00325         m_sourceText->GetTextLayout(&textLayout);
00326
00327         D2D1_SIZE_U bitmapPixelSize = D2D1::SizeU(
00328             static_cast<uint32>(transform._11 * m_size.width),
00329             static_cast<uint32>(transform._22 * m_size.height)
00330             );
00331
00332         // Create intermediate bitmap as input to the effects.
00333         // The bitmap size is specified in pixels.
00334         DX::ThrowIfFailed(
00335             d2dDeviceContext->CreateBitmap(
00336                 bitmapPixelSize,
00337                 nullptr,
00338                 0,
00339                 D2D1::BitmapProperties1(
00340                     D2D1_BITMAP_OPTIONS_TARGET,
00341                     D2D1::PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00342                     96.0,
00343                     96.0
00344                     ),
00345                 &m_contentBitmap
00346                 )
00347             );
00348
00349         // Keep track of what display size the cached content is for.
00350         m_displaySize = renderer->GetDisplaySize();
00351
00352         // Preserve pre-existing target
00353         ComPtr<ID2D1Image> oldTarget;
00354
00355         d2dDeviceContext->GetTarget(&oldTarget);
00356
00357         // Set the view target to an intermediate bitmap
00358         d2dDeviceContext->SetTarget(m_contentBitmap.Get());
00359
00360         d2dDeviceContext->Clear(D2D1::ColorF(0, 0));
00361
00362         // Only set the scale transform and leave the translation
00363         // as we're drawing only this element to an intermediate.
00364         d2dDeviceContext->SetTransform(
00365             D2D1::Matrix3x2F::Scale(transform._11, transform._22)
00366             );
00367
00368         // Draw text onto an intermediate bitmap
00369         d2dDeviceContext->DrawTextLayout(
00370             D2D1::Point2F(0, m_topMargin),
00371             textLayout.Get(),
00372             m_brush.Get(),
00373             D2D1_DRAW_TEXT_OPTIONS_NONE
00374             );
00375
00376         // Restore the previous target
00377         d2dDeviceContext->SetTarget(oldTarget.Get());
00378     }
00379
00380     return false;
00381 }
00382
00383 bool TextFrame::Draw(
00384     _In_ Document^ document,
00385     D2D1::Matrix3x2F const& transform
00386     )
00387 {
00388     auto renderer = document->GetRenderer();
00389
00390     ComPtr<ID2D1DeviceContext> d2dDeviceContext;
00391     renderer->GetD2DDeviceContext(&d2dDeviceContext);
00392
00393     ComPtr<IDWriteTextLayout> textLayout;
00394     m_sourceText->GetTextLayout(&textLayout);
00395
00396     if (m_glowEffect == nullptr || m_compositeEffect == nullptr)
00397     {
00398         d2dDeviceContext->SetTransform(transform);
00399
00400         d2dDeviceContext->DrawTextLayout(
00401             D2D1::Point2F(m_offset.x, m_offset.y + m_topMargin),
00402             textLayout.Get(),
00403             m_brush.Get(),
00404             D2D1_DRAW_TEXT_OPTIONS_NONE
00405             );
00406     }
00407     else if (m_contentBitmap != nullptr)
00408     {
00409         // Set input bitmap for the glow effect, then set the second
00410         // input to the composite effect as the input bitmap to create
00411         // the final result where the original text is composited over
00412         // the glow.
00413         m_glowEffect->SetInput(
00414             0,
00415             m_contentBitmap.Get()
00416             );
00417
00418         m_compositeEffect->SetInput(
00419             1,
00420             m_contentBitmap.Get()
00421             );
00422
00423         ComPtr<ID2D1Image> image;
00424         m_compositeEffect->GetOutput(&image);
00425
00426         // Remove the scaling factor as the local bitmap is drawn to the render target.
00427         d2dDeviceContext->SetTransform(
00428             D2D1::Matrix3x2F::Translation(
00429                 transform._31 + transform._11 * m_offset.x,
00430                 transform._32 + transform._22 * m_offset.y
00431                 )
00432             );
00433
00434         // Execute the effect graph and draw the final result onto the
00435         // original view target.
00436         d2dDeviceContext->DrawImage(
00437             image.Get(),
00438             &m_offset,
00439             nullptr,
00440             D2D1_INTERPOLATION_MODE_HIGH_QUALITY_CUBIC,
00441             D2D1_COMPOSITE_MODE_SOURCE_OVER
00442             );
00443     }
00444
00445     return false;
00446 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizerImpl.h Source File

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp

TripOptimizerImpl.h

Go to the documentation of this file.
00001 //-----------------------------------------------------------------------
00002 //
00003 //  Copyright (C) Microsoft Corporation.  All rights reserved.
00004 //
00005 //
00006 // THIS CODE AND INFORMATION ARE PROVIDED AS-IS WITHOUT WARRANTY OF ANY
00007 // KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00008 // IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //-----------------------------------------------------------------------
00011 #pragma once
00012
00013 #include "pch.h"
00014 #include "AntSystem.h"
00015
00016 namespace TripOptimizerComponent
00017 {
00018 namespace Details
00019 {
00020     // Defines implementation details for the TripOptimizer class.
00021     class TripOptimizerImpl
00022     {
00023
00024     public:
00025         // Optimizes a trip as an asynchronous process.
00026         Windows::Foundation::IAsyncOperationWithProgress<
00027             Windows::Foundation::Collections::IMap<Platform::String^,
00028                 Windows::Foundation::Collections::IVector<Platform::String^>^>^,
00029             Platform::String^>^ OptimizeTripAsync(
00030                 Windows::Foundation::Collections::IVector<Platform::String^>^ waypoints,
00031                 Platform::String^ travelMode,
00032                 Platform::String^ optimize,
00033                 Platform::String^ bingMapsKey,
00034                 double alpha, double beta, double rho,
00035                 unsigned int iterations, bool parallel);
00036
00037     private:
00038         // Holds variables that are used throughout the trip optimization process.
00039         // We create this stucture so that common parameters can be easily passed among
00040         // task continuations.
00041         struct OptimizeTripParams
00042         {
00043             //
00044             // The inputs to OptimizeTripAsync
00045
00046             std::vector<std::wstring> Waypoints;
00047             std::wstring TravelMode;
00048             std::wstring Optimize;
00049             std::wstring BingMapsKey;
00050             double Alpha;
00051             double Beta;
00052             double Rho;
00053             unsigned long Iterations;
00054             bool Parallel;
00055
00056             //
00057             // Timer variables
00058
00059             // The following times are sent as part of a progress message.
00060             // The overall time.
00061             ULONGLONG TotalTime;
00062             // The overall time and the spent performing HTTP requests.
00063             ULONGLONG HttpTime;
00064             // The time spent performing the optimization algorithm.
00065             ULONGLONG SimulationTime;
00066
00067             //
00068             // Location graph.
00069
00070             // A collection of Node objects. There is one Node object for each location.
00071             std::vector<std::shared_ptr<AntSystem::Node>> Nodes;
00072
00073             // A collection of Edge objects. There are
00074             // (n * (n - 1) / 2) edges, where n is the number of nodes.
00075             std::vector<std::shared_ptr<AntSystem::Edge>> Edges;
00076
00077             // The number of pending HTTP requests for the current batch.
00078             long RequestsPending;
00079
00080             // Holds the unresolved locations for the first phase of the optimization process.
00081             concurrency::concurrent_vector<std::shared_ptr<AntSystem::Node>> UnresolvedLocations;
00082         };
00083
00084         // Optimizes a trip given the current state of this object.
00085         concurrency::task<Windows::Foundation::Collections::IMap<Platform::String^,
00086             Windows::Foundation::Collections::IVector<Platform::String^>^>^>
00087         InternalOptimizeTripAsync(
00088             std::shared_ptr<OptimizeTripParams> params,
00089             concurrency::cancellation_token cancellationToken,
00090             concurrency::progress_reporter<Platform::String^> reporter);
00091
00092         // Creates the graph of objects that represents the trip topography.
00093         void CreateGraph(
00094             const std::vector<std::wstring>& waypoints,
00095             std::vector<std::shared_ptr<AntSystem::Node>>& nodes,
00096             std::vector<std::shared_ptr<AntSystem::Edge>>& edges);
00097
00098         // Retrieves information about the locations from the Bing Maps location service.
00099         std::vector<concurrency::task<void>> RetrieveLocationsAsync(
00100             std::shared_ptr<OptimizeTripParams> params,
00101             concurrency::cancellation_token cancellationToken,
00102             concurrency::progress_reporter<Platform::String^> reporter);
00103
00104         // Loads information for a single location from the provided XML document.
00105         void ProcessLocation(
00106             std::shared_ptr<AntSystem::Node> node,
00107             Windows::Data::Xml::Dom::XmlDocument^ data,
00108             concurrency::concurrent_vector<std::shared_ptr<AntSystem::Node>>& unresolvedLocations);
00109
00110         // Retrieves distance information for each pair of locations from the Bing Maps route service.
00111         std::vector<concurrency::task<void>> RetrieveRoutesAsync(
00112             std::shared_ptr<OptimizeTripParams> params,
00113             concurrency::cancellation_token cancellationToken,
00114             concurrency::progress_reporter<Platform::String^> reporter);
00115
00116         // Loads route information for a single pair of locations from the provided XML document.
00117         void ProcessRoute(
00118             std::shared_ptr<AntSystem::Edge> edge,
00119             Windows::Data::Xml::Dom::XmlDocument^ data);
00120
00121     private:
00122         // Used to cancel the trip optimization task.
00123         concurrency::cancellation_token_source m_cancellationTokenSource;
00124     };
00125 }
00126 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/CopyImage.xaml.h Source File

  • Clipboard app

CopyImage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CopyImage.xaml.h
00013 // Declaration of the CopyImage class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "CopyImage.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace Clipboard
00023 {
00024     [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class CopyImage sealed
00026     {
00027     public:
00028         CopyImage();
00029
00030     protected:
00031         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032
00033     private:
00034         MainPage^ rootPage;
00035
00036         // CopyImage click events
00037         void CopyButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00038         void PasteButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         void CopyWithDelayedRenderingButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040
00041         void CopyBitmap(bool useDelayedRendering);
00042         void OnDeferredImageRequestedHandler(Windows::ApplicationModel::DataTransfer::DataProviderRequest^ request);
00043
00044         Windows::Storage::Streams::RandomAccessStreamReference^ imgStreamRef;
00045     };
00046 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario6.xaml.h Source File

  • CryptoWinRT

Scenario6.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.h
00013 // Declaration of the Scenario6 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario6.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace CryptoWinRT
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario6 sealed
00031         {
00032         public:
00033             Scenario6();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             Platform::Array<byte>^ TestVectorNonce;
00040             Windows::Storage::Streams::IBuffer^ GetNonce();
00041             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042             void RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043         };
00044     }
00045 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/common/suspensionmanager.h Source File

  • Web authentication broker
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/Remove.xaml.h Source File

  • Playlist

Remove.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Remove.xaml.h
00013 // Declaration of the Remove class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Remove.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Playlists
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Remove sealed
00031         {
00032         public:
00033             Remove();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void PickPlaylistButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/ShapesPuzzle.h Source File

  • Input Touch hit testing

ShapesPuzzle.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "Program.h"
00011 #include "DirectXBase.h"
00012 #include "SampleOverlay.h"
00013
00014 ref class ShapesPuzzle sealed : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00015 {
00016 public:
00017     ShapesPuzzle();
00018
00019     // DirectXBase Methods
00020     virtual void CreateDeviceResources() override;
00021     virtual void CreateWindowSizeDependentResources() override;
00022     virtual void Render() override;
00023
00024     // IFrameworkView Methods
00025     virtual void Initialize(Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00026     virtual void SetWindow(Windows::UI::Core::CoreWindow^ window);
00027     virtual void Load(Platform::String^ entryPoint);
00028     virtual void Run();
00029     virtual void Uninitialize();
00030
00031     // Event Handlers
00032     void OnWindowSizeChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(
00038         _In_ Platform::Object^ sender
00039         );
00040
00041     void OnDisplayContentsInvalidated(
00042         _In_ Platform::Object^ sender
00043         );
00044
00045     void OnActivated(
00046         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00047         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00048         );
00049
00050     void OnSuspending(
00051         _In_ Platform::Object^ sender,
00052         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00053         );
00054
00055     void OnResuming(
00056         _In_ Platform::Object^ sender,
00057         _In_ Platform::Object^ args
00058         );
00059
00060     void OnPointerPressed(
00061         _In_ Windows::UI::Core::CoreWindow^ sender,
00062         _In_ Windows::UI::Core::PointerEventArgs^ args
00063         );
00064
00065     void OnPointerMoved(
00066         _In_ Windows::UI::Core::CoreWindow^ sender,
00067         _In_ Windows::UI::Core::PointerEventArgs^ args
00068         );
00069
00070     void OnPointerReleased(
00071         _In_ Windows::UI::Core::CoreWindow^ sender,
00072         _In_ Windows::UI::Core::PointerEventArgs^ args
00073         );
00074
00075 private:
00076     SampleOverlay^ m_sampleOverlay;
00077
00078     Program^ m_program; // Encapsulates all Touch/Mouse Event handling
00079 };
00080
00081 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00082 {
00083 public:
00084     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00085 };
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput2.xaml.cpp Source File

  • Media extensions

ScenarioInput2.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Input.xaml.cpp
00010 // Implementation of the Scenario2Input class.
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput2.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace MediaExtensionsCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioInput2::ScenarioInput2()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioInput2::~ScenarioInput2()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioInput2::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Get a pointer to our main page.
00045     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047     // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048     _frameLoadedToken = rootPage->OutputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioInput2::rootPage_OutputFrameLoaded);
00049
00050     rootPage->ExtensionManager->RegisterSchemeHandler("GeometricSource.GeometricSchemeHandler", "myscheme:");
00051 }
00052
00053 void ScenarioInput2::OnNavigatedFrom(NavigationEventArgs^ e)
00054 {
00055     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00056 }
00057
00058 #pragma endregion
00059
00060 #pragma region Event handlers
00061 void ScenarioInput2::rootPage_OutputFrameLoaded(Object^ sender, Object^ e)
00062 {
00063     // Get a pointer to the content within the OutputFrame.
00064     Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00065
00066     // Go find the elements that we need for this scenario.
00067     outputVideo = dynamic_cast<MediaElement^>(outputFrame->FindName("Video"));
00068
00069 }
00070
00071 void ScenarioInput2::Circle_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00072 {
00073     outputVideo->Source = ref new Uri("myscheme://circle");
00074     outputVideo->Play();
00075 }
00076
00077 void ScenarioInput2::Square_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00078 {
00079     outputVideo->Source = ref new Uri("myscheme://square");
00080     outputVideo->Play();
00081 }
00082
00083 void ScenarioInput2::Triangle_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00084 {
00085     outputVideo->Source = ref new Uri("myscheme://triangle");
00086     outputVideo->Play();
00087 }
00088 #pragma endregion
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/SuspensionManager.cpp Source File

  • Hilo C++
  • Hilo
  • Common

SuspensionManager.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // SuspensionManager.cpp
00009 // Implementation of the SuspensionManager class
00010 //
00011
00012 #include "pch.h"
00013 #include "SuspensionManager.h"
00014
00015 #include <collection.h>
00016 #include <algorithm>
00017
00018 using namespace Hilo::Common;
00019
00020 using namespace Concurrency;
00021 using namespace Platform;
00022 using namespace Platform::Collections;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::Foundation::Collections;
00025 using namespace Windows::Storage;
00026 using namespace Windows::Storage::FileProperties;
00027 using namespace Windows::Storage::Streams;
00028 using namespace Windows::UI::Xaml;
00029 using namespace Windows::UI::Xaml::Controls;
00030 using namespace Windows::UI::Xaml::Interop;
00031
00032 namespace
00033 {
00034   Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00035   String^ sessionStateFilename = "_sessionState.dat";
00036
00037   // Forward declarations for object object read / write support
00038   void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00039   Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00040 }
00041
00042 /// <summary>
00043 /// Provides access to global session state for the current session.  This state is serialized by
00044 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00045 /// one of the following: boxed values including integers, floating-point singles and doubles,
00046 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00047 /// subject to the same constraints.  Session state should be as compact as possible.
00048 /// </summary>
00049 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00050 {
00051   return _sessionState;
00052 }
00053
00054 /// <summary>
00055 /// Wrap a WeakReference as a reference object for use in a collection.
00056 /// </summary>
00057 private ref class WeakFrame sealed
00058 {
00059 private:
00060   WeakReference _frameReference;
00061
00062 internal:
00063   WeakFrame(Frame^ frame) { _frameReference = frame; }
00064   property Frame^ ResolvedFrame
00065   {
00066     Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00067   };
00068 };
00069
00070 namespace
00071 {
00072   std::vector<WeakFrame^> _registeredFrames;
00073   DependencyProperty^ FrameSessionStateKeyProperty =
00074     DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00075     TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00076   DependencyProperty^ FrameSessionStateProperty =
00077     DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00078     TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00079 }
00080
00081 /// <summary>
00082 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00083 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00084 /// immediately after creation if they will participate in session state management.  Upon
00085 /// registration if state has already been restored for the specified key
00086 /// the navigation history will immediately be restored.  Subsequent invocations of
00087 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00088 /// </summary>
00089 /// <param name="frame">An instance whose navigation history should be managed by
00090 /// <see cref="SuspensionManager"/></param>
00091 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00092 /// store navigation-related information.</param>
00093 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00094 {
00095   if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00096   {
00097     throw ref new FailureException("Frames can only be registered to one session state key");
00098   }
00099
00100   if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00101   {
00102     throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00103   }
00104
00105   // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00106   // navigation state should be managed
00107   frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00108   _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00109
00110   // Check to see if navigation state can be restored
00111   RestoreFrameNavigationState(frame);
00112 }
00113
00114 /// <summary>
00115 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00116 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00117 /// removed.
00118 /// </summary>
00119 /// <param name="frame">An instance whose navigation history should no longer be
00120 /// managed.</param>
00121 void SuspensionManager::UnregisterFrame(Frame^ frame)
00122 {
00123   // Remove session state and remove the frame from the list of frames whose navigation
00124   // state will be saved (along with any weak references that are no longer reachable)
00125   auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00126   if (SessionState->HasKey(key)) SessionState->Remove(key);
00127   _registeredFrames.erase(
00128     std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00129     {
00130       auto testFrame = e->ResolvedFrame;
00131       return testFrame == nullptr || testFrame == frame;
00132     }),
00133     _registeredFrames.end()
00134   );
00135 }
00136
00137 /// <summary>
00138 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00139 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00140 /// their session state saved and restored automatically as a part of the global
00141 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00142 /// that can still be useful when restoring pages that have been discarded from the
00143 /// navigation cache.
00144 /// </summary>
00145 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00146 /// page-specific state instead of working with frame session state directly.</remarks>
00147 /// <param name="frame">The instance for which session state is desired.</param>
00148 /// <returns>A collection of state subject to the same serialization mechanism as
00149 /// <see cref="SessionState"/>.</returns>
00150 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00151 {
00152   auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00153
00154   if (frameState == nullptr)
00155   {
00156     auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00157     if (frameSessionKey != nullptr)
00158     {
00159       // Registered frames reflect the corresponding session state
00160       if (!_sessionState->HasKey(frameSessionKey))
00161       {
00162         _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00163       }
00164       frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00165     }
00166     else
00167     {
00168       // Frames that aren't registered have transient state
00169       frameState = ref new Map<String^, Object^>();
00170     }
00171     frame->SetValue(FrameSessionStateProperty, frameState);
00172   }
00173   return frameState;
00174 }
00175
00176 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00177 {
00178   auto frameState = SessionStateForFrame(frame);
00179   if (frameState->HasKey("Navigation"))
00180   {
00181     frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00182   }
00183 }
00184
00185 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00186 {
00187   auto frameState = SessionStateForFrame(frame);
00188   frameState->Insert("Navigation", frame->GetNavigationState());
00189 }
00190
00191 /// <summary>
00192 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00193 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00194 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00195 /// to save its state.
00196 /// </summary>
00197 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00198 task<void> SuspensionManager::SaveAsync(void)
00199 {
00200   // Save the navigation state for all registered frames
00201   for (auto&& weakFrame : _registeredFrames)
00202   {
00203     auto frame = weakFrame->ResolvedFrame;
00204     if (frame != nullptr) SaveFrameNavigationState(frame);
00205   }
00206
00207   // Serialize the session state synchronously to avoid asynchronous access to shared
00208   // state
00209   auto sessionData = ref new InMemoryRandomAccessStream();
00210   auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00211   WriteObject(sessionDataWriter, _sessionState);
00212
00213   // Once session state has been captured synchronously, begin the asynchronous process
00214   // of writing the result to disk
00215   return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00216   {
00217     return sessionDataWriter->FlushAsync();
00218   }).then([=](bool flushSucceeded)
00219   {
00220     (void)flushSucceeded; // Unused parameter
00221     return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00222       CreationCollisionOption::ReplaceExisting);
00223   }).then([=](StorageFile^ createdFile)
00224   {
00225     return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00226   }).then([=](IRandomAccessStream^ newStream)
00227   {
00228     return RandomAccessStream::CopyAndCloseAsync(
00229       sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00230   }).then([=](UINT64 copiedBytes)
00231   {
00232     (void)copiedBytes; // Unused parameter
00233     return;
00234   });
00235 }
00236
00237 /// <summary>
00238 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00239 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00240 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00241 /// state.
00242 /// </summary>
00243 /// <param name="version">A version identifer compared to the session state to prevent
00244 /// incompatible versions of session state from reaching app code.  Saved state with a
00245 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00246 /// dictionary.</param>
00247 /// <returns>An asynchronous task that reflects when session state has been read.  The
00248 /// content of <see cref="SessionState"/> should not be relied upon until this task
00249 /// completes.</returns>
00250 task<void> SuspensionManager::RestoreAsync(void)
00251 {
00252   _sessionState->Clear();
00253
00254   task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00255   return getFileTask.then([=](StorageFile^ stateFile)
00256   {
00257     task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00258     return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00259     {
00260       auto size = unsigned int(stateFileProperties->Size);
00261       if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00262       task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00263       return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00264       {
00265         auto stateReader = ref new DataReader(stateFileStream);
00266         return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00267         {
00268           (void)bytesRead; // Unused parameter
00269           // Deserialize the Session State
00270           Object^ content = ReadObject(stateReader);
00271           _sessionState = (Map<String^, Object^>^)content;
00272
00273           // Restore any registered frames to their saved state
00274           for (auto&& weakFrame : _registeredFrames)
00275           {
00276             auto frame = weakFrame->ResolvedFrame;
00277             if (frame != nullptr)
00278             {
00279               frame->ClearValue(FrameSessionStateProperty);
00280               RestoreFrameNavigationState(frame);
00281             }
00282           }
00283         }, task_continuation_context::use_current());
00284       });
00285     });
00286   });
00287 }
00288
00289 #pragma region Object serialization for a known set of types
00290
00291 namespace
00292 {
00293   // Codes used for identifying serialized types
00294   enum StreamTypes {
00295     NullPtrType = 0,
00296
00297     // Supported IPropertyValue types
00298     UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00299     SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00300
00301     // Additional supported types
00302     StringToObjectMapType,
00303
00304     // Marker values used to ensure stream integrity
00305     MapEndMarker
00306   };
00307
00308   void WriteString(DataWriter^ writer, String^ string)
00309   {
00310     writer->WriteByte(StringType);
00311     writer->WriteUInt32(writer->MeasureString(string));
00312     writer->WriteString(string);
00313   }
00314
00315   void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00316   {
00317     switch (propertyValue->Type)
00318     {
00319     case PropertyType::UInt8:
00320       writer->WriteByte(UInt8Type);
00321       writer->WriteByte(propertyValue->GetUInt8());
00322       return;
00323     case PropertyType::UInt16:
00324       writer->WriteByte(UInt16Type);
00325       writer->WriteUInt16(propertyValue->GetUInt16());
00326       return;
00327     case PropertyType::UInt32:
00328       writer->WriteByte(UInt32Type);
00329       writer->WriteUInt32(propertyValue->GetUInt32());
00330       return;
00331     case PropertyType::UInt64:
00332       writer->WriteByte(UInt64Type);
00333       writer->WriteUInt64(propertyValue->GetUInt64());
00334       return;
00335     case PropertyType::Int16:
00336       writer->WriteByte(Int16Type);
00337       writer->WriteUInt16(propertyValue->GetInt16());
00338       return;
00339     case PropertyType::Int32:
00340       writer->WriteByte(Int32Type);
00341       writer->WriteUInt32(propertyValue->GetInt32());
00342       return;
00343     case PropertyType::Int64:
00344       writer->WriteByte(Int64Type);
00345       writer->WriteUInt64(propertyValue->GetInt64());
00346       return;
00347     case PropertyType::Single:
00348       writer->WriteByte(SingleType);
00349       writer->WriteSingle(propertyValue->GetSingle());
00350       return;
00351     case PropertyType::Double:
00352       writer->WriteByte(DoubleType);
00353       writer->WriteDouble(propertyValue->GetDouble());
00354       return;
00355     case PropertyType::Boolean:
00356       writer->WriteByte(BooleanType);
00357       writer->WriteBoolean(propertyValue->GetBoolean());
00358       return;
00359     case PropertyType::Char16:
00360       writer->WriteByte(Char16Type);
00361       writer->WriteUInt16(propertyValue->GetChar16());
00362       return;
00363     case PropertyType::Guid:
00364       writer->WriteByte(GuidType);
00365       writer->WriteGuid(propertyValue->GetGuid());
00366       return;
00367     case PropertyType::String:
00368       WriteString(writer, propertyValue->GetString());
00369       return;
00370     default:
00371       throw ref new InvalidArgumentException("Unsupported property type");
00372     }
00373   }
00374
00375   void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00376   {
00377     writer->WriteByte(StringToObjectMapType);
00378     writer->WriteUInt32(map->Size);
00379     for (auto&& pair : map)
00380     {
00381       WriteObject(writer, pair->Key);
00382       WriteObject(writer, pair->Value);
00383     }
00384     writer->WriteByte(MapEndMarker);
00385   }
00386
00387   void WriteObject(DataWriter^ writer, Object^ object)
00388   {
00389     if (object == nullptr)
00390     {
00391       writer->WriteByte(NullPtrType);
00392       return;
00393     }
00394
00395     auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00396     if (propertyObject != nullptr)
00397     {
00398       WriteProperty(writer, propertyObject);
00399       return;
00400     }
00401
00402     auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00403     if (mapObject != nullptr)
00404     {
00405       WriteStringToObjectMap(writer, mapObject);
00406       return;
00407     }
00408
00409     throw ref new InvalidArgumentException("Unsupported data type");
00410   }
00411
00412   String^ ReadString(DataReader^ reader)
00413   {
00414     int length = reader->ReadUInt32();
00415     String^ string = reader->ReadString(length);
00416     return string;
00417   }
00418
00419   IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00420   {
00421     auto map = ref new Map<String^, Object^>();
00422     auto size = reader->ReadUInt32();
00423     for (unsigned int index = 0; index < size; index++)
00424     {
00425       auto key = safe_cast<String^>(ReadObject(reader));
00426       auto value = ReadObject(reader);
00427       map->Insert(key, value);
00428     }
00429     if (reader->ReadByte() != MapEndMarker)
00430     {
00431       throw ref new InvalidArgumentException("Invalid stream");
00432     }
00433     return map;
00434   }
00435
00436   Object^ ReadObject(DataReader^ reader)
00437   {
00438     auto type = reader->ReadByte();
00439     switch (type)
00440     {
00441     case NullPtrType:
00442       return nullptr;
00443     case UInt8Type:
00444       return reader->ReadByte();
00445     case UInt16Type:
00446       return reader->ReadUInt16();
00447     case UInt32Type:
00448       return reader->ReadUInt32();
00449     case UInt64Type:
00450       return reader->ReadUInt64();
00451     case Int16Type:
00452       return reader->ReadInt16();
00453     case Int32Type:
00454       return reader->ReadInt32();
00455     case Int64Type:
00456       return reader->ReadInt64();
00457     case SingleType:
00458       return reader->ReadSingle();
00459     case DoubleType:
00460       return reader->ReadDouble();
00461     case BooleanType:
00462       return reader->ReadBoolean();
00463     case Char16Type:
00464       return (char16_t)reader->ReadUInt16();
00465     case GuidType:
00466       return reader->ReadGuid();
00467     case StringType:
00468       return ReadString(reader);
00469     case StringToObjectMapType:
00470       return ReadStringToObjectMap(reader);
00471     default:
00472       throw ref new InvalidArgumentException("Unsupported property type");
00473     }
00474   }
00475 }
00476
00477 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/common/LayoutAwarePage.h Source File

  • Sharing content source app
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Sample-Utils/CppSamplesUtils.h Source File

  • Contact Picker app
  • Sample-Utils

CppSamplesUtils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::ApplicationSettings::sealed Member List

This is the complete list of members for SDKSample::ApplicationSettings::sealed, including all inherited members.
AddSettingsScenario() | SDKSample::ApplicationSettings::sealed |
addSettingsScenarioAdd_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ApplicationSettings::sealed | [private]
commandsRequestedEventRegistrationToken | SDKSample::ApplicationSettings::sealed | [private]
DefaultScenario() | SDKSample::ApplicationSettings::sealed |
isEventRegistered | SDKSample::ApplicationSettings::sealed | [private]
onCommandsRequested(Windows::UI::ApplicationSettings::SettingsPane^settingsPane, Windows::UI::ApplicationSettings::SettingsPaneCommandsRequestedEventArgs^eventArgs) | SDKSample::ApplicationSettings::sealed | [private]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ApplicationSettings::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ApplicationSettings::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ApplicationSettings::sealed | [protected, virtual]
onSettingsCommand(Windows::UI::Popups::IUICommand^command) | SDKSample::ApplicationSettings::sealed | [private]
rootPage | SDKSample::ApplicationSettings::sealed | [private]
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CStreamState Member List

This is the complete list of members for CStreamState, including all inherited members.
bValid | CStreamState |
CStreamState() | CStreamState | [inline]
CStreamState() | CStreamState | [inline]
m_arTS | CStreamState | [private]
m_arTS | CStreamState | [private]
m_bGOPData | CStreamState | [private]
m_cbBytes | CStreamState | [private]
m_dwNextTimeCode | CStreamState | [private]
m_dwTimeCode | CStreamState | [private]
m_rt | CStreamState | [private]
NextByte(BYTE bData) | CStreamState |
NextByte(BYTE bData) | CStreamState |
PictureTime(DWORD *pdwTimeCode) const | CStreamState | [inline]
PictureTime(DWORD *pdwTimeCode) const | CStreamState | [inline]
Reset() | CStreamState |
Reset() | CStreamState |
rt | CStreamState |
TimeStamp(REFERENCE_TIME rt) | CStreamState |
TimeStamp(REFERENCE_TIME rt) | CStreamState |
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/pch.h Source File

  • Hilo C++
  • CartoonEffect

pch.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "targetver.h"
00010
00011 #define WIN32_LEAN_AND_MEAN
00012 #include <windows.h>
00013
00014 #define _USE_MATH_DEFINES
00015 #include <math.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideText04 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideText04, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBodyWrap | NotificationsExtensions::TileContent::TileWideText04 |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideText04() | NotificationsExtensions::TileContent::TileWideText04 | [inline]
TileWideText04() | NotificationsExtensions::TileContent::TileWideText04 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Constants.cpp Source File

  • Input Device capabilities

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Mouse Capabilities", "SDKSample.DeviceCaps.Mouse" },
00022     { "Keyboard Capabilities", "SDKSample.DeviceCaps.Keyboard" },
00023     { "Touch Capabilities", "SDKSample.DeviceCaps.Touch" },
00024   { "Pointer Capabilities", "SDKSample.DeviceCaps.Pointer" }
00025 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario3.xaml.h Source File

  • File access

Scenario3.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FileAccess
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario3 sealed
00030         {
00031         public:
00032             Scenario3();
00033
00034         private:
00035             MainPage^ rootPage;
00036
00037             Windows::Storage::Streams::IBuffer^ GetBufferFromString(Platform::String^ str);
00038             void WriteBytesButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039             void ReadBytesButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/Msappdata.xaml.cpp Source File

  • Application data

Msappdata.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Msappdata.xaml.cpp
00013 // Implementation of the Msappdata class
00014 //
00015
00016 #include "pch.h"
00017 #include "Msappdata.xaml.h"
00018
00019 using namespace SDKSample::ApplicationDataSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::UI::Xaml::Media::Imaging;
00027 using namespace Windows::Storage;
00028 using namespace concurrency;
00029
00030 Msappdata::Msappdata()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 task<void> Msappdata::CopyFile(Uri^ sourceUri, StorageFolder^ destFolder, String^ destFilename)
00036 {
00037     return create_task(StorageFile::GetFileFromApplicationUriAsync(sourceUri)).then([=](StorageFile^ sourceFile)
00038     {
00039         return sourceFile->CopyAsync(destFolder, destFilename, NameCollisionOption::FailIfExists);
00040     }).then([=](task<StorageFile^> copyTask)
00041     {
00042         try
00043         {
00044             auto destFile = copyTask.get();
00045         }
00046         catch (Platform::Exception ^e)
00047         {
00048             if (e->HResult == HRESULT_FROM_WIN32(ERROR_ALREADY_EXISTS))
00049             {
00050                 // Ignore this error.  It's expected that the file may already have been copied into place.
00051             }
00052             else
00053             {
00054                 rootPage->NotifyUser(e->Message, NotifyType::ErrorMessage);
00055             }
00056         }
00057     });
00058 }
00059
00060 /// <summary>
00061 /// Invoked when this page is about to be displayed in a Frame.
00062 /// </summary>
00063 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00064 /// property is typically used to configure the page.</param>
00065 void Msappdata::OnNavigatedTo(NavigationEventArgs^ e)
00066 {
00067     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00068     // as NotifyUser()
00069     rootPage = MainPage::Current;
00070
00071     ApplicationData^ appData = ApplicationData::Current;
00072
00073     // Copy the files into their respective ApplicationData folders, and then set the image source.
00074
00075     CopyFile(ref new Uri("ms-appx:///assets/appDataLocal.png"), appData->LocalFolder, "appDataLocal.png").then([=]()
00076     {
00077         LocalImage->Source = ref new BitmapImage(ref new Uri("ms-appdata:///local/appDataLocal.png"));
00078     });
00079
00080     CopyFile(ref new Uri("ms-appx:///assets/appDataRoaming.png"), appData->RoamingFolder, "appDataRoaming.png").then([=]()
00081     {
00082         RoamingImage->Source = ref new BitmapImage(ref new Uri("ms-appdata:///roaming/appDataRoaming.png"));
00083     });
00084
00085     CopyFile(ref new Uri("ms-appx:///assets/appDataTemp.png"), appData->TemporaryFolder, "appDataTemp.png").then([=]()
00086     {
00087         TempImage->Source = ref new BitmapImage(ref new Uri("ms-appdata:///temp/appDataTemp.png"));
00088     });
00089 }
00090
00091 /// <summary>
00092 /// Invoked immediately before the Page is unloaded and is no longer the current source of a parent Frame.
00093 /// </summary>
00094 /// <param name="e">
00095 /// Event data that can be examined by overriding code. The event data is representative
00096 /// of the navigation that will unload the current Page unless canceled. The
00097 /// navigation can potentially be canceled by setting Cancel.
00098 /// </param>
00099 void Msappdata::OnNavigatingFrom(NavigatingCancelEventArgs^ e)
00100 {
00101     LocalImage->Source = nullptr;
00102     RoamingImage->Source = nullptr;
00103     TempImage->Source = nullptr;
00104 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/pch.h Source File

  • Context menu

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBase.cpp Source File

  • Hilo C++
  • Hilo

ImageBase.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "ImageBase.h"
00009 #include "IPhoto.h"
00010 #include "HiloCommonDefinitions.h"
00011
00012 using namespace concurrency;
00013 using namespace Hilo;
00014 using namespace Platform;
00015 using namespace Platform::Collections;
00016 using namespace std;
00017 using namespace Windows::Storage;
00018 using namespace Windows::Storage::Pickers;
00019 using namespace Windows::Storage::Streams;
00020
00021 ImageBase::ImageBase(shared_ptr<ExceptionPolicy> exceptionPolicy) : ViewModelBase(exceptionPolicy)
00022 {
00023 }
00024
00025 concurrency::task<IRandomAccessStreamWithContentType^> ImageBase::GetStreamWithFailCheck()
00026 {
00027     return create_task(m_photo->OpenReadAsync())
00028         .then([this](task<IRandomAccessStreamWithContentType^> openTask)
00029     {
00030         assert(IsMainThread());
00031         try
00032         {
00033             auto stream = openTask.get();
00034             return stream;
00035         }
00036         catch(Platform::Exception^ ex)
00037         {
00038             switch(ex->HResult)
00039             {
00040             case HILO_PHOTO_FILE_NOT_FOUND:
00041                 // Image has been removed, take the user home.
00042                 GoHome();
00043                 cancel_current_task();
00044                 break;
00045
00046             default:
00047                 throw;
00048             }
00049         }
00050     }, task_continuation_context::use_current());
00051 }
00052
00053
00054 task<StorageFile^> ImageBase::GetFileNameFromFileSavePickerAsync(String^ fileType)
00055 {
00056     assert(IsMainThread());
00057     auto fileExtension = ref new Vector<String^>();
00058     fileExtension->Append(fileType);
00059
00060     auto savePicker = ref new FileSavePicker();
00061     savePicker->SuggestedStartLocation = PickerLocationId::PicturesLibrary;
00062     savePicker->FileTypeChoices->Insert("Image", fileExtension);
00063     savePicker->DefaultFileExtension = fileType;
00064
00065     auto filePickerTask = create_task(savePicker->PickSaveFileAsync());
00066     return filePickerTask.then([](StorageFile^ file)
00067     {
00068         assert(IsMainThread());
00069         if (file == nullptr)
00070         {
00071             cancel_current_task();
00072         }
00073         return file;
00074     });
00075 }
00076
00077 task<void> ImageBase::SaveImageAsync(StorageFile^ file, IRandomAccessStream^ ras)
00078 {
00079     assert(IsMainThread());
00080     std::shared_ptr<IBuffer^> buffer = std::make_shared<IBuffer^>(nullptr);
00081
00082     IInputStream^ inputStream = ras->GetInputStreamAt(0);
00083     unsigned int size = static_cast<unsigned int>(ras->Size);
00084     auto streamReader = ref new DataReader(inputStream);
00085
00086     auto loadStreamTask = create_task(streamReader->LoadAsync(size));
00087     return loadStreamTask.then([streamReader, buffer, size, file](unsigned int loadedBytes)
00088     {
00089         assert(IsBackgroundThread());
00090         (void)loadedBytes; // Unused parameter
00091         *buffer = streamReader->ReadBuffer(size);
00092         return FileIO::WriteBufferAsync(file, *buffer);
00093     }, concurrency::task_continuation_context::use_arbitrary()).then([this]()
00094     {
00095         assert(IsMainThread());
00096         ViewModelBase::GoBack();
00097     });
00098 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput5.xaml.h Source File

  • Toast notifications
  • C#,C++

ScenarioInput5.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // ScenarioInput5.xaml.h
00009 // Declaration of the ScenarioInput5 class.
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "ScenarioInput5.g.h"
00016 #include "MainPage.xaml.h"
00017
00018 using namespace Windows::UI::Xaml;
00019
00020 namespace ToastsSampleCPP
00021 {
00022   [Windows::Foundation::Metadata::WebHostHidden]
00023     public ref class ScenarioInput5 sealed
00024     {
00025     public:
00026         ScenarioInput5();
00027
00028     protected:
00029         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00031
00032     private:
00033         ~ScenarioInput5();
00034
00035     MainPage^ rootPage;
00036         void rootPage_OutputFrameLoaded(Object^ sender, Object^ e);
00037         void OutputText(Platform::String^ text);
00038         void Scenario5DisplayToastWithCallbacks_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         void toast_Failed(Windows::UI::Notifications::ToastNotification^ sender, Windows::UI::Notifications::ToastFailedEventArgs^ e);
00040         void toast_Dismissed(Windows::UI::Notifications::ToastNotification^ sender, Windows::UI::Notifications::ToastDismissedEventArgs^ e);
00041
00042         void Scenario5HideToast_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043
00044         Windows::Foundation::EventRegistrationToken _frameLoadedToken;
00045         Windows::UI::Xaml::Controls::TextBlock^ outputText;
00046         Windows::UI::Core::CoreDispatcher^ dispatcher;
00047         Platform::String^ toastContext;
00048
00049         Windows::UI::Notifications::ToastNotification^ _toast;
00050     };
00051 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/Scenario4.xaml.h Source File

  • File and folder thumbnail

Scenario4.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FileThumbnails
00025     {
00026         [Windows::Foundation::Metadata::WebHostHidden]
00027         public ref class Scenario4 sealed
00028         {
00029         public:
00030             Scenario4();
00031
00032         protected:
00033             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00034
00035         private:
00036             MainPage^ rootPage;
00037
00038             void GetThumbnailButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/DefaultCloseCommand.xaml.h Source File

  • Message dialog

DefaultCloseCommand.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CustomCommand.xaml.h
00013 // Declaration of the CustomCommand class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "DefaultCloseCommand.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace MessageDialogSample
00025     {
00026         [Windows::Foundation::Metadata::WebHostHidden]
00027         public ref class DefaultCloseCommand sealed
00028         {
00029         public:
00030             DefaultCloseCommand();
00031
00032         protected:
00033             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00034         private:
00035             MainPage^ rootPage;
00036             void DefaultCloseCommandButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037         };
00038     }
00039 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/EffectsFlyout.xaml.cpp Source File

  • DirectX postcard app

EffectsFlyout.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "EffectsFlyout.xaml.h"
00010
00011 using namespace Postcard;
00012
00013 using namespace Platform;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Windows::UI::Xaml;
00017 using namespace Windows::UI::Xaml::Controls;
00018 using namespace Windows::UI::Xaml::Controls::Primitives;
00019 using namespace Windows::UI::Xaml::Data;
00020 using namespace Windows::UI::Xaml::Input;
00021 using namespace Windows::UI::Xaml::Media;
00022 using namespace Windows::UI::Xaml::Navigation;
00023
00024 EffectsFlyout::EffectsFlyout()
00025 {
00026     InitializeComponent();
00027 }
00028
00029 void EffectsFlyout::EffectIntensitySliderChanged(Object^ sender, RangeBaseValueChangedEventArgs^ e)
00030 {
00031     EffectIntensityChanged(e);
00032 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DirectX::D3DX_BC3 Member List

This is the complete list of members for DirectX::D3DX_BC3, including all inherited members.
alpha | DirectX::D3DX_BC3
bc1 | DirectX::D3DX_BC3
bitmap | DirectX::D3DX_BC3
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario4.xaml.cpp Source File

  • CryptoWinRT

Scenario4.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.cpp
00013 // Implementation of the Scenario4 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario4.xaml.h"
00018
00019 using namespace SDKSample::CryptoWinRT;
00020
00021 using namespace Platform;
00022 using namespace Windows::Security::Cryptography;
00023 using namespace Windows::Security::Cryptography::Core;
00024 using namespace Windows::Storage::Streams;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 Scenario4::Scenario4()
00030 {
00031     InitializeComponent();
00032     AlgorithmNames->SelectedIndex = 0;
00033     KeySizes->SelectedIndex = 0;
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void Scenario4::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046 }
00047
00048 void SDKSample::CryptoWinRT::Scenario4::RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00049 {
00050     Scenario4Text->Text = "";
00051
00052     int TargetSize = 0;
00053     String^ algName = AlgorithmNames->SelectionBoxItem->ToString();
00054     IBuffer^ Secret = CryptographicBuffer::ConvertStringToBinary("Master key to derive from", BinaryStringEncoding::Utf8);
00055     KeyDerivationParameters^ Params;
00056
00057     switch (AlgorithmNames->SelectedIndex)
00058     {
00059     case 0:
00060     case 1:
00061     case 2:
00062         Params = KeyDerivationParameters::BuildForPbkdf2(
00063                                         CryptographicBuffer::GenerateRandom(16),  // Salt
00064                                         10000                       // PBKDF2 Iteration Count
00065                                         );
00066         break;
00067     case 3:
00068     case 4:
00069     case 5:
00070         Params = KeyDerivationParameters::BuildForSP800108(
00071                              CryptographicBuffer::ConvertStringToBinary("Label", BinaryStringEncoding::Utf8),  // Label
00072                              CryptographicBuffer::DecodeFromHexString("303132333435363738")                   // Context
00073                              );
00074         break;
00075     case 6:
00076     case 7:
00077         Params = KeyDerivationParameters::BuildForSP80056a(
00078                         CryptographicBuffer::ConvertStringToBinary("AlgorithmId", BinaryStringEncoding::Utf8),
00079                         CryptographicBuffer::ConvertStringToBinary("VParty", BinaryStringEncoding::Utf8),
00080                         CryptographicBuffer::ConvertStringToBinary("UParty", BinaryStringEncoding::Utf8),
00081                         CryptographicBuffer::ConvertStringToBinary("SubPubInfo", BinaryStringEncoding::Utf8),
00082                         CryptographicBuffer::ConvertStringToBinary("SubPrivInfo", BinaryStringEncoding::Utf8)
00083                         );
00084         break;
00085     default:
00086         Scenario4Text->Text += "An invalid Algorithm was selected";
00087         return;
00088     }
00089     KeyDerivationAlgorithmProvider^ Algorithm = KeyDerivationAlgorithmProvider::OpenAlgorithm(algName);
00090     Scenario4Text->Text += "Sample Kdf Algorithm: " + Algorithm->AlgorithmName + "\n";
00091
00092     switch (KeySizes->SelectedIndex)
00093     {
00094     case 0:
00095         TargetSize = 64;
00096         break;
00097     case 1:
00098         TargetSize = 256;
00099         break;
00100     default:
00101         Scenario4Text->Text += "An invalid size was selected";
00102         return;
00103     }
00104     Scenario4Text->Text += "    Target Size: " + TargetSize + "\n";
00105     Scenario4Text->Text += "    Secret Size: " + Secret->Length + "\n";
00106
00107     // Create a key.
00108     CryptographicKey^ key = Algorithm->CreateKey(Secret);
00109     IBuffer^ derived;
00110
00111     // Derive a key from the created key.
00112     try
00113     {
00114         derived = CryptographicEngine::DeriveKeyMaterial(key, Params, TargetSize);
00115     }
00116     catch(Exception^ e)
00117     {
00118         Scenario4Text->Text += e->Message + "\n";
00119         return;
00120     }
00121     Scenario4Text->Text += "    Derived  " + derived->Length + " bytes\n";
00122     Scenario4Text->Text += "    Derived: " + CryptographicBuffer::EncodeToHexString(derived) + "\n";
00123 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite paragraph text/C++/DWriteParagraphText.h Source File

  • DirectWrite paragraph text

DWriteParagraphText.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012
00013 ref class DWriteParagraphText : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00014 {
00015 internal:
00016     DWriteParagraphText();
00017
00018     // DirectXBase Methods
00019     virtual void CreateDeviceIndependentResources() override;
00020     virtual void CreateDeviceResources() override;
00021     virtual void CreateWindowSizeDependentResources() override;
00022     virtual void Render() override;
00023
00024 public:
00025     // IFrameworkView Methods
00026     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00027     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00028     virtual void Load(_In_ Platform::String^ entryPoint);
00029     virtual void Run();
00030     virtual void Uninitialize();
00031
00032 private:
00033     void ShowMenu(Windows::Foundation::Point position);
00034     void UpdateJustification(Windows::UI::Popups::IUICommand^ command);
00035     void UpdateCharacterSpacing(Windows::UI::Popups::IUICommand^ command);
00036     void ApplyJustificationSettings();
00037     void ApplySpacingSettings();
00038     // Event Handlers
00039     void OnWindowSizeChanged(
00040         _In_ Windows::UI::Core::CoreWindow^ sender,
00041         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00042         );
00043
00044     void OnLogicalDpiChanged(
00045         _In_ Platform::Object^ sender
00046         );
00047
00048     void OnDisplayContentsInvalidated(
00049         _In_ Platform::Object^ sender
00050         );
00051
00052     void OnActivated(
00053         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00054         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00055         );
00056
00057     void OnSuspending(
00058         _In_ Platform::Object^ sender,
00059         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00060         );
00061
00062     void OnResuming(
00063         _In_ Platform::Object^ sender,
00064         _In_ Platform::Object^ args
00065         );
00066
00067     void OnHolding(
00068         _In_ Windows::UI::Input::GestureRecognizer^ recognizer,
00069         _In_ Windows::UI::Input::HoldingEventArgs^ args
00070         );
00071
00072     void OnPointerMoved(
00073         _In_ Windows::UI::Core::CoreWindow^ window,
00074         _In_ Windows::UI::Core::PointerEventArgs^ args
00075         );
00076
00077     void OnPointerPressed(
00078         _In_ Windows::UI::Core::CoreWindow^ window,
00079         _In_ Windows::UI::Core::PointerEventArgs^ args
00080         );
00081
00082     void OnPointerReleased(
00083         _In_ Windows::UI::Core::CoreWindow^ window,
00084         _In_ Windows::UI::Core::PointerEventArgs^ args
00085         );
00086
00087     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>                    m_blackBrush;
00088     Microsoft::WRL::ComPtr<IDWriteTextFormat>                       m_textFormat;
00089     Microsoft::WRL::ComPtr<IDWriteTypography>                       m_textTypography;
00090     SampleOverlay^                                                  m_sampleOverlay;
00091     Platform::Agile<Windows::UI::Input::GestureRecognizer>          m_gestureRecognizer;
00092     Microsoft::WRL::ComPtr<IDWriteTextLayout1>                      m_textLayout1;
00093     DWRITE_TEXT_RANGE                                               m_textRange;
00094     bool                                                            m_isJustified;
00095     bool                                                            m_isIncreasedSpacing;
00096 };
00097
00098 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00099 {
00100 public:
00101     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00102 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/LanId.xaml.h Source File

  • Network information

LanId.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // LanId.xaml.h
00013 // Declaration of the LanId class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "LanId.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::System;
00026 using namespace Windows::Foundation;
00027 using namespace Platform;
00028 using namespace Windows::Networking;
00029 using namespace Windows::Networking::Connectivity;
00030
00031 namespace SDKSample
00032 {
00033     namespace NetworkInformationApi
00034     {
00035         /// <summary>
00036         /// An empty page that can be used on its own or navigated to within a Frame.
00037         /// </summary>
00038         public ref class LanId sealed
00039         {
00040         public:
00041             LanId();
00042
00043         protected:
00044             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00045         private:
00046             MainPage^ rootPage;
00047             void LanId_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             String^ lanIdInfo;
00049             void DisplayLanIdentifierData(LanIdentifier^ lanIdentifier);
00050         };
00051     }
00052 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RotateImageView.xaml.h Source File

  • Hilo C++
  • Hilo

RotateImageView.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "RotateImageView.g.h"
00010
00011 namespace Hilo
00012 {
00013     // See http://go.microsoft.com/fwlink/?LinkId=267278 for info on how Hilo creates pages and navigates to pages.
00014
00015     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how view classes interact
00016     // with corresponding view model classes that encapsulate the app’s state, actions, and operations.
00017
00018     // See http://go.microsoft.com/fwlink/?LinkId=267279 for info on how Hilo pages use XAML controls.
00019
00020     // The RotateImageView class implements the rotate page.
00021     [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class RotateImageView sealed
00023     {
00024     public:
00025         RotateImageView();
00026
00027     protected:
00028         virtual void OnManipulationCompleted(Windows::UI::Xaml::Input::ManipulationCompletedRoutedEventArgs^ e) override;
00029         virtual void OnManipulationDelta(Windows::UI::Xaml::Input::ManipulationDeltaRoutedEventArgs^ e) override;
00030
00031
00032     private:
00033         RotateImageViewModel^ m_viewModel;
00034         void PhotoSizeChanged(Platform::Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00035     };
00036 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

PrintSample::InvalidPageException Member List

This is the complete list of members for PrintSample::InvalidPageException, including all inherited members.
get_DisplayMessage() | PrintSample::InvalidPageException | [inline]
InvalidPageException(std::wstring &message) | PrintSample::InvalidPageException | [inline]
m_displayMessage | PrintSample::InvalidPageException | [private]
~InvalidPageException() | PrintSample::InvalidPageException | [inline]
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/App.xaml.cpp Source File

  • Input Touch keyboard text input

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite inline object/C++/DirectXBase.cpp Source File

  • DirectWrite inline object

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/pch.h Source File

  • Playlist

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/common/LayoutAwarePage.h Source File

  • Application data
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DirectXBase.h Source File

  • Direct2Dapp printing

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicTimer.h Source File

  • Direct3D resource loading

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

StreamList Member List

This is the complete list of members for StreamList, including all inherited members.
AddStream(BYTE id, CMPEG1Stream *pStream) | StreamList | [inline]
AddStream(BYTE id, CMPEG1Stream *pStream) | StreamList | [inline]
Clear() | StreamList | [inline]
Clear() | StreamList | [inline]
Find(BYTE id) | StreamList | [inline]
Find(BYTE id) | StreamList | [inline]
GetCount() const | StreamList | [inline]
GetCount() const | StreamList | [inline]
m_count | StreamList | [private]
m_id | StreamList | [private]
m_streams | StreamList | [private]
operator[](DWORD index) | StreamList | [inline]
operator[](DWORD index) const | StreamList | [inline]
operator[](DWORD index) | StreamList | [inline]
operator[](DWORD index) const | StreamList | [inline]
StreamList() | StreamList | [inline]
StreamList() | StreamList | [inline]
~StreamList() | StreamList | [inline]
~StreamList() | StreamList | [inline]
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/FaceMesh.h Source File

  • DirectX 3D shooting game

FaceMesh.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // FaceMesh:
00011 // This class derives from MeshObject and creates a ID3D11Buffer of
00012 // vertices and indices to represent a canonical face defined as a
00013 // rectangle at the origin extending 1 unit in the +X and
00014 // 1 unit in the +Y direction.
00015 // The face is defined to be two sided, so it is visible from either
00016 // side.
00017
00018 #include "MeshObject.h"
00019
00020 ref class FaceMesh: public MeshObject
00021 {
00022 internal:
00023     FaceMesh(_In_ ID3D11Device *device);
00024 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario1.xaml.h Source File

  • DatagramSocket

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Platform;
00023 using namespace Windows::Networking;
00024 using namespace Windows::Networking::Sockets;
00025 using namespace Windows::Storage::Streams;
00026
00027 namespace DatagramSocketSample
00028 {
00029     [Windows::Foundation::Metadata::WebHostHidden]
00030     public ref class Scenario1 sealed
00031     {
00032     public:
00033         Scenario1();
00034
00035     protected:
00036         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037     private:
00038         MainPage^ rootPage;
00039         void StartListener_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040     };
00041
00042     [Windows::Foundation::Metadata::WebHostHidden]
00043     public ref class ListenerContext sealed
00044     {
00045     public:
00046         ListenerContext(MainPage^ rootPage, DatagramSocket^ listener);
00047
00048         void OnMessage(DatagramSocket^ socket, DatagramSocketMessageReceivedEventArgs^ eventArguments);
00049         bool IsMatching(HostName^ hostName, String^ port);
00050
00051     private:
00052         ~ListenerContext();
00053         CRITICAL_SECTION lock;
00054         MainPage^ rootPage;
00055         DatagramSocket^ listener;
00056         IOutputStream^ outputStream;
00057         HostName^ hostName;
00058         String^ port;
00059         void NotifyUserFromAsyncThread(String^ message, NotifyType type);
00060
00061         void EchoMessage(DatagramSocketMessageReceivedEventArgs^ eventArguments);
00062     };
00063 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CGrayscale Member List

This is the complete list of members for CGrayscale, including all inherited members.
AddInputStreams(DWORD cStreams, DWORD *adwStreamIDs) | CGrayscale | [private]
AddInputStreams(DWORD cStreams, DWORD *adwStreamIDs) | CGrayscale | [private]
BeginStreaming() | CGrayscale | [private]
BeginStreaming() | CGrayscale | [private]
DeleteInputStream(DWORD dwStreamID) | CGrayscale | [private]
DeleteInputStream(DWORD dwStreamID) | CGrayscale | [private]
EndStreaming() | CGrayscale | [private]
EndStreaming() | CGrayscale | [private]
GetAttributes(IMFAttributes **pAttributes) | CGrayscale | [private]
GetAttributes(IMFAttributes **pAttributes) | CGrayscale | [private]
GetInputAvailableType(DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CGrayscale | [private]
GetInputAvailableType(DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CGrayscale | [private]
GetInputCurrentType(DWORD dwInputStreamID, IMFMediaType **ppType) | CGrayscale | [private]
GetInputCurrentType(DWORD dwInputStreamID, IMFMediaType **ppType) | CGrayscale | [private]
GetInputStatus(DWORD dwInputStreamID, DWORD *pdwFlags) | CGrayscale | [private]
GetInputStatus(DWORD dwInputStreamID, DWORD *pdwFlags) | CGrayscale | [private]
GetInputStreamAttributes(DWORD dwInputStreamID, IMFAttributes **ppAttributes) | CGrayscale | [private]
GetInputStreamAttributes(DWORD dwInputStreamID, IMFAttributes **ppAttributes) | CGrayscale | [private]
GetInputStreamInfo(DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo) | CGrayscale | [private]
GetInputStreamInfo(DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo) | CGrayscale | [private]
GetOutputAvailableType(DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CGrayscale | [private]
GetOutputAvailableType(DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CGrayscale | [private]
GetOutputCurrentType(DWORD dwOutputStreamID, IMFMediaType **ppType) | CGrayscale | [private]
GetOutputCurrentType(DWORD dwOutputStreamID, IMFMediaType **ppType) | CGrayscale | [private]
GetOutputStatus(DWORD *pdwFlags) | CGrayscale | [private]
GetOutputStatus(DWORD *pdwFlags) | CGrayscale | [private]
GetOutputStreamAttributes(DWORD dwOutputStreamID, IMFAttributes **ppAttributes) | CGrayscale | [private]
GetOutputStreamAttributes(DWORD dwOutputStreamID, IMFAttributes **ppAttributes) | CGrayscale | [private]
GetOutputStreamInfo(DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo) | CGrayscale | [private]
GetOutputStreamInfo(DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo) | CGrayscale | [private]
GetStreamCount(DWORD *pcInputStreams, DWORD *pcOutputStreams) | CGrayscale | [private]
GetStreamCount(DWORD *pcInputStreams, DWORD *pcOutputStreams) | CGrayscale | [private]
GetStreamIDs(DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs) | CGrayscale | [private]
GetStreamIDs(DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs) | CGrayscale | [private]
GetStreamLimits(DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum) | CGrayscale | [private]
GetStreamLimits(DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum) | CGrayscale | [private]
HasPendingOutput() const | CGrayscale | [inline, private]
HasPendingOutput() const | CGrayscale | [inline, private]
IsValidInputStream(DWORD dwInputStreamID) const | CGrayscale | [inline, private]
IsValidInputStream(DWORD dwInputStreamID) const | CGrayscale | [inline, private]
IsValidOutputStream(DWORD dwOutputStreamID) const | CGrayscale | [inline, private]
IsValidOutputStream(DWORD dwOutputStreamID) const | CGrayscale | [inline, private]
m_bStreamingInitialized | CGrayscale | [private]
m_cbImageSize | CGrayscale | [private]
m_critSec | CGrayscale | [private]
m_imageHeightInPixels | CGrayscale | [private]
m_imageWidthInPixels | CGrayscale | [private]
m_pAttributes | CGrayscale | [private]
m_pInputType | CGrayscale | [private]
m_pOutputType | CGrayscale | [private]
m_pSample | CGrayscale | [private]
m_pTransformFn | CGrayscale | [private]
m_rcDest | CGrayscale | [private]
m_transform | CGrayscale | [private]
OnCheckInputType(IMFMediaType *pmt) | CGrayscale | [private]
OnCheckInputType(IMFMediaType *pmt) | CGrayscale | [private]
OnCheckMediaType(IMFMediaType *pmt) | CGrayscale | [private]
OnCheckMediaType(IMFMediaType *pmt) | CGrayscale | [private]
OnCheckOutputType(IMFMediaType *pmt) | CGrayscale | [private]
OnCheckOutputType(IMFMediaType *pmt) | CGrayscale | [private]
OnFlush() | CGrayscale | [private]
OnFlush() | CGrayscale | [private]
OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt) | CGrayscale | [private]
OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt) | CGrayscale | [private]
OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut) | CGrayscale | [private]
OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut) | CGrayscale | [private]
OnSetInputType(IMFMediaType *pmt) | CGrayscale | [private]
OnSetInputType(IMFMediaType *pmt) | CGrayscale | [private]
OnSetOutputType(IMFMediaType *pmt) | CGrayscale | [private]
OnSetOutputType(IMFMediaType *pmt) | CGrayscale | [private]
ProcessEvent(DWORD dwInputStreamID, IMFMediaEvent *pEvent) | CGrayscale | [private]
ProcessEvent(DWORD dwInputStreamID, IMFMediaEvent *pEvent) | CGrayscale | [private]
ProcessInput(DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags) | CGrayscale | [private]
ProcessInput(DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags) | CGrayscale | [private]
ProcessMessage(MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam) | CGrayscale | [private]
ProcessMessage(MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam) | CGrayscale | [private]
ProcessOutput(DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus) | CGrayscale | [private]
ProcessOutput(DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus) | CGrayscale | [private]
RuntimeClassInitialize() | CGrayscale | [private]
RuntimeClassInitialize() | CGrayscale | [private]
SetInputType(DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags) | CGrayscale | [private]
SetInputType(DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags) | CGrayscale | [private]
SetOutputBounds(LONGLONG hnsLowerBound, LONGLONG hnsUpperBound) | CGrayscale | [private]
SetOutputBounds(LONGLONG hnsLowerBound, LONGLONG hnsUpperBound) | CGrayscale | [private]
SetOutputType(DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags) | CGrayscale | [private]
SetOutputType(DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags) | CGrayscale | [private]
SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration) | CGrayscale | [private]
SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration) | CGrayscale | [private]
UpdateFormatInfo() | CGrayscale | [private]
UpdateFormatInfo() | CGrayscale | [private]
~CGrayscale() | CGrayscale | [private]
~CGrayscale() | CGrayscale | [private]
Generated on Sat Nov 23 2024 16:09:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/StereoProjection.cpp Source File

  • DirectX 3D shooting game

StereoProjection.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "StereoProjection.h"
00010
00011 #if !defined(XMASSERT)
00012 #define XMASSERT(Expression) ((void)0)
00013 #endif // !XMASSERT
00014
00015 using namespace DirectX;
00016
00017 void StereoCreateDefaultParameters(_Out_ STEREO_PARAMETERS* stereoParameters)
00018 {
00019     XMASSERT(stereoParameters != nullptr);
00020
00021     // Default assumption is 1920x1200 resolution, a 22" LCD monitor, and a 2' viewing distance
00022     stereoParameters->viewerDistanceInches = 24.0f;
00023     stereoParameters->pixelResolutionWidth = 1920.0f;
00024     stereoParameters->pixelResolutionHeight = 1024.0f; // 480.0f; // 1200
00025     stereoParameters->displaySizeInches = 22.0f;
00026
00027     stereoParameters->stereoSeparationFactor = 1.0f;
00028     stereoParameters->stereoExaggerationFactor = 1.0f;
00029 }
00030
00031 __forceinline bool _XMMatrixStereoProjectionHelper (
00032     const STEREO_PARAMETERS* stereoParameters,
00033     _Out_ float* virtualProjection,
00034     _Out_ float* zNearWidth,
00035     _Out_ float* zNearHeight,
00036     float fovAngleY,
00037     float aspectHByW,
00038     float nearZ
00039     )
00040 {
00041     // note that most people have difficulty fusing images into 3D
00042     // if the separation equals even just the human average. by
00043     // reducing the separation (interocular distance) by 1/2, we
00044     // guarantee a larger subset of people will see full 3D
00045
00046     // the conservative setting should always be used. the only problem
00047     // with the conservative setting is that the 3D effect will be less
00048     // impressive on smaller screens (which makes sense, since your eye
00049     // cannot be tricked as easily based on the smaller fov). to simulate
00050     // the effect of a larger screen, use the liberal settings (debug only)
00051
00052     // Conservative Settings: * max acuity angle: 0.8f degrees * interoc distance: 1.25 inches
00053
00054     // Liberal Settings: * max acuity angle: 1.6f degrees * interoc distance: 2.5f inches
00055
00056     // maximum visual accuity angle allowed is 3.2 degrees for
00057     // a physical scene, and 1.6 degrees for a virtual one.
00058     // thus we cannot allow an object to appear any closer to
00059     // the viewer than 1.6 degrees (divided by two for most
00060     // half-angle calculations)
00061
00062     static const float maxStereoDistance = 85; // 780 inches (should be between 10 and 20m)
00063     static const float maxVisualAcuityAngle = 0.8f * (XM_PI / 180.0f);  // radians
00064     static const float interocularDistance = 1.25f; // inches
00065
00066     bool comfortableResult = true;
00067
00068     float displayHeight = stereoParameters->displaySizeInches / sqrtf(aspectHByW * aspectHByW + 1.0f);
00069     float displayWidth = displayHeight * aspectHByW;
00070     float halfInterocular = 0.5f * interocularDistance * stereoParameters->stereoExaggerationFactor;
00071     float halfPixelWidth  = displayWidth / stereoParameters->pixelResolutionWidth * 0.5f;
00072     float halfMaximumAcuityAngle = maxVisualAcuityAngle * 0.5f * stereoParameters->stereoExaggerationFactor;
00073
00074     float maxSeparationAcuityAngle = atanf(halfInterocular / maxStereoDistance);
00075     float maxSeparationDistance = halfPixelWidth / tanf(maxSeparationAcuityAngle);
00076     float refinedMaxStereoDistance = maxStereoDistance - maxSeparationDistance;
00077     float fovHalfAngle = fovAngleY / 2.0f;
00078
00079     if (refinedMaxStereoDistance < 0.0f || maxSeparationDistance > 0.1f * maxStereoDistance)
00080     {
00081         // Pixel resolution is too low to offer a comfortable stereo experience
00082         comfortableResult = false;
00083     }
00084
00085     float refinedMaxSeparationAcuityAngle = atanf(halfInterocular / refinedMaxStereoDistance);
00086     float physicalZNearDistance = halfInterocular / tanf(halfMaximumAcuityAngle);
00087
00088     float nearZSeparation = tanf(refinedMaxSeparationAcuityAngle) * (refinedMaxStereoDistance - physicalZNearDistance);
00089
00090     *zNearHeight = cosf(fovHalfAngle) / sinf(fovHalfAngle);
00091     *zNearWidth = *zNearHeight / aspectHByW;
00092     *virtualProjection = (nearZSeparation * nearZ * (*zNearWidth * 4.0f)) / (2.0f * nearZ);
00093
00094     return comfortableResult;
00095 }
00096
00097
00098 XMMATRIX MatrixStereoProjectionFovLH (
00099     _In_opt_ const STEREO_PARAMETERS* stereoParameters,
00100     STEREO_CHANNEL channel,
00101     float fovAngleY,
00102     float aspectHByW,
00103     float nearZ,
00104     float farZ,
00105     STEREO_MODE stereoMode
00106     )
00107 {
00108     float virtualProjection = 0.0f;
00109     float zNearWidth = 0.0f;
00110     float zNearHeight = 0.0f;
00111     float invertedAngle;
00112     XMMATRIX patchedProjection;
00113     XMMATRIX proj;
00114     STEREO_PARAMETERS defaultParameters;
00115
00116     XMASSERT(channel == STEREO_CHANNEL::LEFT || channel == STEREO_CHANNEL::RIGHT);
00117     XMASSERT(stereoMode == STEREO_MODE::NORMAL || stereoMode == STEREO_MODE::INVERTED);
00118     XMASSERT(!XMScalarNearEqual(fovAngleY, 0.0f, 0.00001f * 2.0f));
00119     XMASSERT(!XMScalarNearEqual(aspectHByW, 0.0f, 0.00001f));
00120     XMASSERT(!XMScalarNearEqual(farZ, nearZ, 0.00001f));
00121
00122     proj = XMMatrixIdentity();
00123
00124     if (stereoParameters == nullptr)
00125     {
00126         StereoCreateDefaultParameters(&defaultParameters);
00127         stereoParameters = &defaultParameters;
00128     }
00129
00130     XMASSERT(pStereoParameters->stereoSeparationFactor >= 0.0f && stereoParameters->stereoSeparationFactor <= 1.0f);
00131     XMASSERT(pStereoParameters->stereoExaggerationFactor >= 1.0f && stereoParameters->stereoExaggerationFactor <= 2.0f);
00132
00133     _XMMatrixStereoProjectionHelper(stereoParameters, &virtualProjection, &zNearWidth, &zNearHeight, fovAngleY, aspectHByW, nearZ);
00134
00135     virtualProjection *= stereoParameters->stereoSeparationFactor; // incorporate developer defined bias
00136
00137     //
00138     // By applying a translation, we are forcing our cameras to be parallel
00139     //
00140
00141     invertedAngle = atanf(virtualProjection / (2.0f * nearZ));
00142
00143     proj = XMMatrixPerspectiveFovLH(fovAngleY, aspectHByW, nearZ, farZ);
00144
00145     if (channel == STEREO_CHANNEL::LEFT)
00146     {
00147         if (stereoMode > STEREO_MODE::NORMAL)
00148         {
00149             XMMATRIX rots, trans;
00150             rots = XMMatrixRotationY(invertedAngle);
00151             trans = XMMatrixTranslation(-virtualProjection, 0, 0);
00152             patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
00153         }
00154         else
00155         {
00156             XMMATRIX trans;
00157             trans = XMMatrixTranslation(-virtualProjection, 0, 0);
00158             patchedProjection = XMMatrixMultiply(trans, proj);
00159         }
00160     }
00161     else
00162     {
00163         if (stereoMode > STEREO_MODE::NORMAL)
00164         {
00165             XMMATRIX rots, trans;
00166             rots = XMMatrixRotationY(-invertedAngle);
00167             trans = XMMatrixTranslation(virtualProjection, 0, 0);
00168             patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
00169         }
00170         else
00171         {
00172             XMMATRIX trans;
00173             trans = XMMatrixTranslation(virtualProjection, 0, 0);
00174             patchedProjection = XMMatrixMultiply(trans, proj);
00175         }
00176     }
00177
00178     return patchedProjection;
00179 }
00180
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/common.h Source File

  • Media engine native C++ video playback

common.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #pragma once
00009
00010 #ifndef UNICODE
00011 #define UNICODE
00012 #endif
00013
00014 template <class T> void SafeRelease(T **ppT)
00015 {
00016     if (*ppT)
00017     {
00018         (*ppT)->Release();
00019         *ppT = NULL;
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/common/LayoutAwarePage.cpp Source File

  • XAML personality animations
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/common/LayoutAwarePage.h Source File

  • Windows account authorization
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/pch.cpp Source File

  • Check if current session is remote

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX swap chain implementation/C++/DirectXSample.h Source File

  • DirectX swap chain implementation

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKTemplate::Common::LayoutAwarePage Member List

This is the complete list of members for SDKTemplate::Common::LayoutAwarePage, including all inherited members.
__pad0__ | Element |
_layoutAwareControls | SDKTemplate::Common::LayoutAwarePage | [private]
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Page | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) | Element | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
DefaultViewModel | SDKTemplate::Common::LayoutAwarePage | [protected]
DefaultViewModelProperty | SDKTemplate::Common::LayoutAwarePage | [static]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
WindowSizeChanged(object sender, Windows.UI.Core.WindowSizeChangedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, private]
WindowSizeChanged(object sender, Windows.UI.Core.WindowSizeChangedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, private]
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/Custom.xaml.h Source File

  • Transcoding media

Custom.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Custom.xaml.h
00013 // Declaration of the Custom class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Custom.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Platform;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::Media;
00025 using namespace Windows::Media::MediaProperties;
00026 using namespace Windows::Media::Transcoding;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::Pickers;
00029
00030 namespace SDKSample
00031 {
00032     namespace Transcode
00033     {
00034         /// <summary>
00035         /// An empty page that can be used on its own or navigated to within a Frame.
00036         /// </summary>
00037       [Windows::Foundation::Metadata::WebHostHidden]
00038         public ref class Custom sealed
00039         {
00040         public:
00041             Custom();
00042         protected:
00043             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00044
00045         private:
00046             void GetCustomProfile();
00047             void PickFile(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void OnTargetFormatChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00049             void SetPickFileButton(bool isEnabled);
00050             void StopPlayers();
00051             void PlayFile(Windows::Storage::StorageFile^ MediaFile);
00052
00053             void TranscodeCustom(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00054             void TranscodeCancel(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00055             void TranscodeProgress(Windows::Foundation::IAsyncActionWithProgress<double>^ asyncInfo, double percent);
00056             void TranscodeComplete(Windows::Foundation::IAsyncActionWithProgress<double>^ asyncInfo, Windows::Foundation::AsyncStatus status);
00057             void TranscodeError(Platform::String^ error);
00058             void TranscodeFailure(Windows::Media::Transcoding::TranscodeFailureReason reason);
00059             void SetCancelButton(bool isEnabled);
00060             void EnableButtons();
00061             void DisableButtons();
00062
00063             // Media Controls
00064             void InputPlayButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00065             void InputPauseButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00066             void InputStopButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00067             void OutputPlayButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00068             void OutputPauseButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00069             void OutputStopButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00070
00071
00072             Platform::String^ _OutputFileName;
00073             Windows::Media::MediaProperties::MediaEncodingProfile^ _Profile;
00074             Windows::Storage::StorageFile^ _InputFile;
00075             Windows::Storage::StorageFile^ _OutputFile;
00076             Windows::Media::Transcoding::MediaTranscoder^ _Transcoder;
00077             Concurrency::cancellation_token_source _CTS;
00078
00079             boolean _UseMp4;
00080
00081             MainPage^ rootPage;
00082         };
00083     }
00084 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CylinderMesh Member List

This is the complete list of members for CylinderMesh, including all inherited members.
__pad0__ | CylinderMesh
segments | CylinderMesh
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DirectXApp.h Source File

  • Direct3D-Direct2D interop

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "TextInterop.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032     void OnVisibilityChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(
00038         _In_ Platform::Object^ sender
00039         );
00040
00041     void OnActivated(
00042         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00043         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00044         );
00045
00046     void OnWindowClosed(
00047         _In_ Windows::UI::Core::CoreWindow^ sender,
00048         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00049         );
00050
00051     TextInterop^ m_renderer;
00052     bool m_windowClosed;
00053     bool m_windowVisible;
00054 };
00055
00056 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00057 {
00058 public:
00059     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00060 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicReaderWriter.cpp Source File

  • DirectX touch input

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DirectX::D3DX_BC2 Member List

This is the complete list of members for DirectX::D3DX_BC2, including all inherited members.
bc1 | DirectX::D3DX_BC2
bitmap | DirectX::D3DX_BC2
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario3.xaml.cpp Source File

  • Display orientation

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::DisplayOrientation;
00020
00021 using namespace Windows::Graphics::Display;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025
00026 Scenario3::Scenario3()
00027 {
00028     InitializeComponent();
00029 }
00030
00031 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00032 {
00033     screenOrientation->Text = DisplayProperties::CurrentOrientation.ToString();
00034
00035     orientationChangedEventToken = DisplayProperties::OrientationChanged::add(
00036         ref new DisplayPropertiesEventHandler(this, &Scenario3::OnOrientationChanged)
00037         );
00038 }
00039
00040 void Scenario3::OnNavigatedFrom(NavigationEventArgs^ e)
00041 {
00042     DisplayProperties::OrientationChanged::remove(orientationChangedEventToken);
00043 }
00044
00045
00046 void Scenario3::OnOrientationChanged(Object^ sender)
00047 {
00048     screenOrientation->Text = DisplayProperties::CurrentOrientation.ToString();
00049 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Face Member List

This is the complete list of members for Face, including all inherited members.
__pad0__ | Face |
Active(bool active) | GameObject |
Active() | GameObject |
Active(bool active) | GameObject |
Active() | GameObject |
AnimatePosition(_In_opt_ Animate^animate) | GameObject |
AnimatePosition() | GameObject |
AnimatePosition(_In_opt_ Animate^animate) | GameObject |
AnimatePosition() | GameObject |
Face(DirectX::XMFLOAT3 origin, DirectX::XMFLOAT3 p1, DirectX::XMFLOAT3 p2) | Face |
Face(DirectX::XMFLOAT3 origin, DirectX::XMFLOAT3 p1, DirectX::XMFLOAT3 p2) | Face |
Hit(bool hit) | GameObject |
Hit() | GameObject |
Hit(bool hit) | GameObject |
Hit() | GameObject |
HitMaterial(_In_ Material^material) | GameObject |
HitMaterial() | GameObject |
HitMaterial(_In_ Material^material) | GameObject |
HitMaterial() | GameObject |
HitSound(_In_ SoundEffect^hitSound) | GameObject |
HitSound() | GameObject |
HitSound(_In_ SoundEffect^hitSound) | GameObject |
HitSound() | GameObject |
HitTime(float t) | GameObject |
HitTime() | GameObject |
HitTime(float t) | GameObject |
HitTime() | GameObject |
IsTouching(DirectX::XMFLOAT3 point, float radius, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal) override | Face | [virtual]
IsTouching(DirectX::XMFLOAT3 point, float radius, _Out_ DirectX::XMFLOAT3 *contact, _Out_ DirectX::XMFLOAT3 *normal) override | Face | [virtual]
m_height | Face | [private]
m_heightVector | Face | [private]
m_normal | Face | [private]
m_point | Face | [private]
m_rotationMatrix | Face | [private]
m_width | Face | [private]
m_widthVector | Face | [private]
Mesh(_In_ MeshObject^mesh) | GameObject |
Mesh(_In_ MeshObject^mesh) | GameObject |
ModelMatrix() | GameObject |
ModelMatrix() | GameObject |
NormalMaterial(_In_ Material^material) | GameObject |
NormalMaterial() | GameObject |
NormalMaterial(_In_ Material^material) | GameObject |
NormalMaterial() | GameObject |
OnGround(bool ground) | GameObject |
OnGround() | GameObject |
OnGround(bool ground) | GameObject |
OnGround() | GameObject |
PlaySound(float impactSpeed, DirectX::XMFLOAT3 eyePoint) | GameObject |
PlaySound(float impactSpeed, DirectX::XMFLOAT3 eyePoint) | GameObject |
Position(DirectX::XMFLOAT3 position) | GameObject |
Position(DirectX::XMVECTOR position) | GameObject |
Position() | GameObject |
Position(DirectX::XMFLOAT3 position) | GameObject |
Position(DirectX::XMVECTOR position) | GameObject |
Position() | GameObject |
Render(_In_ ID3D11DeviceContext *context, _In_ ID3D11Buffer *primitiveConstantBuffer) | GameObject |
Render(_In_ ID3D11DeviceContext *context, _In_ ID3D11Buffer *primitiveConstantBuffer) | GameObject |
SetPlane(DirectX::XMFLOAT3 origin, DirectX::XMFLOAT3 p1, DirectX::XMFLOAT3 p2) | Face |
SetPlane(DirectX::XMFLOAT3 origin, DirectX::XMFLOAT3 p1, DirectX::XMFLOAT3 p2) | Face |
Target(bool target) | GameObject |
Target() | GameObject |
Target(bool target) | GameObject |
Target() | GameObject |
TargetId(int targetId) | GameObject |
TargetId() | GameObject |
TargetId(int targetId) | GameObject |
TargetId() | GameObject |
UpdateMatrix() | Face | [private]
UpdateMatrix() | Face | [private]
UpdatePosition() override | Face | [protected, virtual]
UpdatePosition() override | Face | [protected, virtual]
VectorPosition() | GameObject |
VectorPosition() | GameObject |
VectorVelocity() | GameObject |
VectorVelocity() | GameObject |
Velocity(DirectX::XMFLOAT3 velocity) | GameObject |
Velocity(DirectX::XMVECTOR velocity) | GameObject |
Velocity() | GameObject |
Velocity(DirectX::XMFLOAT3 velocity) | GameObject |
Velocity(DirectX::XMVECTOR velocity) | GameObject |
Velocity() | GameObject |
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Proximity/C++/common/LayoutAwarePage.cpp Source File

  • Proximity
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013
00014 using namespace ProximityCPP::Common;
00015
00016 using namespace Platform;
00017 using namespace Platform::Collections;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Foundation::Collections;
00020 using namespace Windows::UI::ViewManagement;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023
00024 /// <summary>
00025 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00026 /// </summary>
00027 LayoutAwarePage::LayoutAwarePage()
00028 {
00029     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled) return;
00030
00031     // Map application view state to visual state for this page when it is part of the visual tree
00032     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::StartLayoutUpdates);
00033     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::StopLayoutUpdates);
00034
00035     // Establish the default view model as the initial DataContext
00036     DataContext = _defaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00037 }
00038
00039 /// <summary>
00040 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> set as the page's
00041 /// default <see cref="DataContext"/>.  This instance can be bound and surfaces property change
00042 /// notifications making it suitable for use as a trivial view model.
00043 /// </summary>
00044 IObservableMap<Platform::String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00045 {
00046     return _defaultViewModel;
00047 }
00048
00049 /// <summary>
00050 /// Gets a value indicating whether visual states can be a loose interpretation of the actual
00051 /// application view state.  This is often convenient when a page layout is space constrained.
00052 /// </summary>
00053 /// <remarks>
00054 /// The default value of false indicates that the visual state is identical to the view state,
00055 /// meaning that Filled is only used when another application is snapped.  When set to true
00056 /// FullScreenLandscape is used to indicate that at least 1366 virtual pixels of horizontal real
00057 /// estate are available - even if another application is snapped - and Filled indicates a lesser
00058 /// width, even if no other application is snapped.  On a smaller display such as a 1024x768
00059 /// panel this will result in the visual state Filled whenever the device is in landscape
00060 /// orientation.
00061 /// </remarks>
00062 bool LayoutAwarePage::UseFilledStateForNarrowWindow::get()
00063 {
00064     return _useFilledStateForNarrowWindow;
00065 }
00066
00067 /// <summary>
00068 /// Sets a value indicating whether visual states can be a loose interpretation of the actual
00069 /// application view state.  This is often convenient when a page layout is space constrained.
00070 /// </summary>
00071 /// <remarks>
00072 /// The default value of false indicates that the visual state is identical to the view state,
00073 /// meaning that Filled is only used when another application is snapped.  When set to true
00074 /// FullScreenLandscape is used to indicate that at least 1366 virtual pixels of horizontal real
00075 /// estate are available - even if another application is snapped - and Filled indicates a lesser
00076 /// width, even if no other application is snapped.  On a smaller display such as a 1024x768
00077 /// panel this will result in the visual state Filled whenever the device is in landscape
00078 /// orientation.
00079 /// </remarks>
00080 void LayoutAwarePage::UseFilledStateForNarrowWindow::set(bool value)
00081 {
00082     _useFilledStateForNarrowWindow = value;
00083     this->InvalidateVisualState();
00084 }
00085
00086 /// <summary>
00087 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00088 /// until it reaches the top of the navigation stack.
00089 /// </summary>
00090 /// <param name="sender">Instance that triggered the event.</param>
00091 /// <param name="e">Event data describing the conditions that led to the event.</param>
00092 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00093 {
00094     // Use the navigation frame to return to the topmost page
00095     if (Frame != nullptr)
00096     {
00097         while (Frame->CanGoBack) Frame->GoBack();
00098     }
00099 }
00100
00101 /// <summary>
00102 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00103 /// to go back one step on the navigation stack.
00104 /// </summary>
00105 /// <param name="sender">Instance that triggered the event.</param>
00106 /// <param name="e">Event data describing the conditions that led to the event.</param>
00107 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00108 {
00109     // Use the navigation frame to return to the previous page
00110     if (Frame != nullptr && Frame->CanGoBack) Frame->GoBack();
00111 }
00112
00113 /// <summary>
00114 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00115 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00116 /// visual state management changes that correspond to application view state changes.
00117 /// </summary>
00118 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00119 /// corresponding to view states.</param>
00120 /// <param name="e">Event data that describes how the request was made.</param>
00121 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00122 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00123 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00124 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00125 /// events.</remarks>
00126 /// <seealso cref="DetermineVisualState"/>
00127 /// <seealso cref="InvalidateVisualState"/>
00128 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00129 {
00130     auto control = safe_cast<Control^>(sender);
00131     if (_layoutAwareControls == nullptr) {
00132         // Start listening to view state changes when there are controls interested in updates
00133         _layoutAwareControls = ref new Vector<Control^>();
00134         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00135     }
00136     _layoutAwareControls->Append(control);
00137
00138     // Set the initial visual state of the control
00139     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00140 }
00141
00142 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00143 {
00144     InvalidateVisualState();
00145 }
00146
00147 /// <summary>
00148 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00149 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00150 /// management changes that correspond to application view state changes.
00151 /// </summary>
00152 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00153 /// corresponding to view states.</param>
00154 /// <param name="e">Event data that describes how the request was made.</param>
00155 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00156 /// when layout updates are requested.</remarks>
00157 /// <seealso cref="StartLayoutUpdates"/>
00158 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00159 {
00160     auto control = safe_cast<Control^>(sender);
00161     unsigned int index;
00162     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00163     {
00164         _layoutAwareControls->RemoveAt(index);
00165         if (_layoutAwareControls->Size == 0)
00166         {
00167             // Stop listening to view state changes when no controls are interested in updates
00168             Window::Current->SizeChanged -= _windowSizeEventToken;
00169             _layoutAwareControls = nullptr;
00170         }
00171     }
00172 }
00173
00174 /// <summary>
00175 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00176 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00177 /// override this method to control the mapping scheme used.
00178 /// </summary>
00179 /// <param name="viewState">View state for which a visual state is desired.</param>
00180 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00181 /// <seealso cref="InvalidateVisualState"/>
00182 Platform::String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00183 {
00184     auto actualViewState = viewState;
00185     if (_useFilledStateForNarrowWindow &&
00186         (viewState == ApplicationViewState::Filled ||
00187         viewState == ApplicationViewState::FullScreenLandscape))
00188     {
00189         // Allow pages to request that the Filled state be used only for landscape layouts narrower
00190         // than 1366 virtual pixels
00191         auto windowWidth = Window::Current->Bounds.Width;
00192         actualViewState = windowWidth >= 1366 ? ApplicationViewState::FullScreenLandscape : ApplicationViewState::Filled;
00193     }
00194     switch (actualViewState)
00195     {
00196     case ApplicationViewState::Filled: return "Filled";
00197     case ApplicationViewState::Snapped: return "Snapped";
00198     case ApplicationViewState::FullScreenPortrait: return "FullScreenPortrait";
00199     default: case ApplicationViewState::FullScreenLandscape: return "FullScreenLandscape";
00200     }
00201 }
00202
00203 /// <summary>
00204 /// Updates all controls that are listening for visual state changes with the correct visual
00205 /// state.
00206 /// </summary>
00207 /// <remarks>
00208 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00209 /// signal that a different value may be returned even though the view state has not changed.
00210 /// </remarks>
00211 void LayoutAwarePage::InvalidateVisualState()
00212 {
00213     if (_layoutAwareControls != nullptr)
00214     {
00215         String^ visualState = DetermineVisualState(ApplicationView::Value);
00216         auto controlIterator = _layoutAwareControls->First();
00217         while (controlIterator->HasCurrent)
00218         {
00219             auto control = controlIterator->Current;
00220             VisualStateManager::GoToState(control, visualState, false);
00221             controlIterator->MoveNext();
00222         }
00223     }
00224 }
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario2_GetPosition.xaml.h Source File

  • Geolocation

Scenario2_GetPosition.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2_GetPosition.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2_GetPosition.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace GeolocationCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Windows::Devices::Geolocation::Geolocator^ geolocator;
00042             concurrency::cancellation_token_source geopositionTaskTokenSource;
00043
00044             void GetGeolocation(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045             void CancelGetGeolocation(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046         };
00047     }
00048 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Constants.cpp Source File

  • Custom driver access
  • app_cpp

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Connecting to the Fx2 Device", "SDKSample.CustomDeviceAccess.DeviceConnect" },
00022     { "Getting and Setting device properties", "SDKSample.CustomDeviceAccess.DeviceProperties" },
00023     { "Registering for device events", "SDKSample.CustomDeviceAccess.DeviceEvents" },
00024     { "Invoking asynchronous device methods", "SDKSample.CustomDeviceAccess.DeviceAsync" }
00025 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Configure keys for media/C++/pch.cpp Source File

  • Configure keys for media

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameHud.cpp Source File

  • DirectX 3D shooting game

GameHud.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "GameHud.h"
00010 #include "GameConstants.h"
00011
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::UI::Core;
00014 using namespace Windows::ApplicationModel;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::Storage;
00017 using namespace Windows::UI::ViewManagement;
00018 using namespace Windows::Graphics::Display;
00019 using namespace D2D1;
00020
00021 //----------------------------------------------------------------------
00022
00023 GameHud::GameHud(
00024     _In_ Platform::String^ titleHeader,
00025     _In_ Platform::String^ titleBody
00026     )
00027 {
00028     m_titleHeader = titleHeader;
00029     m_titleBody = titleBody;
00030
00031     m_showTitle = true;
00032     m_titleBodyVerticalOffset = GameConstants::Margin;
00033     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00034 }
00035
00036 //----------------------------------------------------------------------
00037
00038 void GameHud::CreateDeviceIndependentResources(
00039     _In_ IDWriteFactory* dwriteFactory,
00040     _In_ IWICImagingFactory* wicFactory
00041     )
00042 {
00043     m_dwriteFactory = dwriteFactory;
00044     m_wicFactory = wicFactory;
00045
00046     DX::ThrowIfFailed(
00047         m_dwriteFactory->CreateTextFormat(
00048             L"Segoe UI",
00049             nullptr,
00050             DWRITE_FONT_WEIGHT_LIGHT,
00051             DWRITE_FONT_STYLE_NORMAL,
00052             DWRITE_FONT_STRETCH_NORMAL,
00053             GameConstants::HudBodyPointSize,
00054             L"en-us",
00055             &m_textFormatBody
00056             )
00057         );
00058     DX::ThrowIfFailed(
00059         m_dwriteFactory->CreateTextFormat(
00060             L"Segoe UI Symbol",
00061             nullptr,
00062             DWRITE_FONT_WEIGHT_LIGHT,
00063             DWRITE_FONT_STYLE_NORMAL,
00064             DWRITE_FONT_STRETCH_NORMAL,
00065             GameConstants::HudBodyPointSize,
00066             L"en-us",
00067             &m_textFormatBodySymbol
00068             )
00069         );
00070     DX::ThrowIfFailed(
00071         m_dwriteFactory->CreateTextFormat(
00072             L"Segoe UI Light",
00073             nullptr,
00074             DWRITE_FONT_WEIGHT_LIGHT,
00075             DWRITE_FONT_STYLE_NORMAL,
00076             DWRITE_FONT_STRETCH_NORMAL,
00077             GameConstants::HudTitleHeaderPointSize,
00078             L"en-us",
00079             &m_textFormatTitleHeader
00080             )
00081         );
00082     DX::ThrowIfFailed(
00083         m_dwriteFactory->CreateTextFormat(
00084             L"Segoe UI Light",
00085             nullptr,
00086             DWRITE_FONT_WEIGHT_LIGHT,
00087             DWRITE_FONT_STYLE_NORMAL,
00088             DWRITE_FONT_STRETCH_NORMAL,
00089             GameConstants::HudTitleBodyPointSize,
00090             L"en-us",
00091             &m_textFormatTitleBody
00092             )
00093         );
00094
00095     DX::ThrowIfFailed(m_textFormatBody->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
00096     DX::ThrowIfFailed(m_textFormatBody->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
00097     DX::ThrowIfFailed(m_textFormatBodySymbol->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
00098     DX::ThrowIfFailed(m_textFormatBodySymbol->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
00099     DX::ThrowIfFailed(m_textFormatTitleHeader->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
00100     DX::ThrowIfFailed(m_textFormatTitleHeader->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
00101     DX::ThrowIfFailed(m_textFormatTitleBody->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING));
00102     DX::ThrowIfFailed(m_textFormatTitleBody->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR));
00103 }
00104
00105 //----------------------------------------------------------------------
00106
00107 void GameHud::CreateDeviceResources(_In_ ID2D1DeviceContext* d2dContext)
00108 {
00109     auto location = Package::Current->InstalledLocation;
00110     Platform::String^ path = Platform::String::Concat(location->Path, "\\");
00111     path = Platform::String::Concat(path, "windows-sdk.png");
00112
00113     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00114     DX::ThrowIfFailed(
00115         m_wicFactory->CreateDecoderFromFilename(
00116             path->Data(),
00117             nullptr,
00118             GENERIC_READ,
00119             WICDecodeMetadataCacheOnDemand,
00120             &wicBitmapDecoder
00121             )
00122         );
00123
00124     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00125     DX::ThrowIfFailed(
00126         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00127         );
00128
00129     ComPtr<IWICFormatConverter> wicFormatConverter;
00130     DX::ThrowIfFailed(
00131         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00132         );
00133
00134     DX::ThrowIfFailed(
00135         wicFormatConverter->Initialize(
00136             wicBitmapFrame.Get(),
00137             GUID_WICPixelFormat32bppPBGRA,
00138             WICBitmapDitherTypeNone,
00139             nullptr,
00140             0.0,
00141             WICBitmapPaletteTypeCustom  // The BGRA format has no palette so this value is ignored.
00142             )
00143         );
00144
00145     double dpiX = 96.0f;
00146     double dpiY = 96.0f;
00147     DX::ThrowIfFailed(
00148         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00149         );
00150
00151     // Create D2D Resources
00152     DX::ThrowIfFailed(
00153         d2dContext->CreateBitmapFromWicBitmap(
00154             wicFormatConverter.Get(),
00155             BitmapProperties(
00156                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00157                 static_cast<float>(dpiX),
00158                 static_cast<float>(dpiY)
00159                 ),
00160             &m_logoBitmap
00161             )
00162         );
00163
00164     m_logoSize = m_logoBitmap->GetSize();
00165
00166     DX::ThrowIfFailed(
00167         d2dContext->CreateSolidColorBrush(
00168             D2D1::ColorF(D2D1::ColorF::White),
00169             &m_textBrush
00170             )
00171         );
00172 }
00173
00174 //----------------------------------------------------------------------
00175
00176 void GameHud::UpdateForWindowSizeChange(_In_ Windows::Foundation::Rect windowBounds)
00177 {
00178     m_maxTitleSize.width = windowBounds.Width - GameConstants::HudSafeWidth;
00179     m_maxTitleSize.height = windowBounds.Height;
00180
00181     float headerWidth = m_maxTitleSize.width - (m_logoSize.width + 2 * GameConstants::Margin);
00182
00183     if (headerWidth > 0)
00184     {
00185         // Only resize the text layout for the Title area when there is enough space.
00186         m_showTitle = true;
00187
00188         DX::ThrowIfFailed(
00189             m_dwriteFactory->CreateTextLayout(
00190                 m_titleHeader->Data(),
00191                 m_titleHeader->Length(),
00192                 m_textFormatTitleHeader.Get(),
00193                 headerWidth,
00194                 m_maxTitleSize.height,
00195                 &m_titleHeaderLayout
00196                 )
00197             );
00198
00199         DWRITE_TEXT_METRICS metrics = {0};
00200         DX::ThrowIfFailed(
00201             m_titleHeaderLayout->GetMetrics(&metrics)
00202             );
00203
00204         // Compute the vertical size of the laid out Header and logo.  This could change
00205         // based on the window size and the layout of the text.  In some cases the text
00206         // may wrap.
00207         m_titleBodyVerticalOffset = max(m_logoSize.height + GameConstants::Margin * 2, metrics.height + 2 * GameConstants::Margin);
00208
00209         DX::ThrowIfFailed(
00210             m_dwriteFactory->CreateTextLayout(
00211                 m_titleBody->Data(),
00212                 m_titleBody->Length(),
00213                 m_textFormatTitleBody.Get(),
00214                 m_maxTitleSize.width,
00215                 m_maxTitleSize.height - m_titleBodyVerticalOffset,
00216                 &m_titleBodyLayout
00217                 )
00218             );
00219     }
00220     else
00221     {
00222         // Not enough horizontal space for the titles so just turn it off.
00223         m_showTitle = false;
00224     }
00225 }
00226
00227 //----------------------------------------------------------------------
00228
00229 void GameHud::Render(
00230     _In_ Simple3DGame^ game,
00231     _In_ ID2D1DeviceContext* d2dContext,
00232     _In_ Windows::Foundation::Rect windowBounds
00233     )
00234 {
00235     if (m_showTitle)
00236     {
00237         d2dContext->DrawBitmap(
00238             m_logoBitmap.Get(),
00239             D2D1::RectF(
00240                 GameConstants::Margin,
00241                 GameConstants::Margin,
00242                 m_logoSize.width + GameConstants::Margin,
00243                 m_logoSize.height + GameConstants::Margin
00244                 )
00245             );
00246         d2dContext->DrawTextLayout(
00247             Point2F(m_logoSize.width + 2.0f * GameConstants::Margin, GameConstants::Margin),
00248             m_titleHeaderLayout.Get(),
00249             m_textBrush.Get()
00250             );
00251         d2dContext->DrawTextLayout(
00252             Point2F(GameConstants::Margin, m_titleBodyVerticalOffset),
00253             m_titleBodyLayout.Get(),
00254             m_textBrush.Get()
00255             );
00256     }
00257
00258     if (game != nullptr)
00259     {
00260         // This section is only used after the game state has been initialized.
00261         static const int bufferLength = 256;
00262         static char16 wsbuffer[bufferLength];
00263         int length = swprintf_s(
00264             wsbuffer,
00265             bufferLength,
00266             L"Hits:\t%10d\nShots:\t%10d\nTime:\t%8.1f",
00267             game->TotalHits(),
00268             game->TotalShots(),
00269             game->TimeRemaining()
00270             );
00271
00272         d2dContext->DrawText(
00273             wsbuffer,
00274             length,
00275             m_textFormatBody.Get(),
00276             D2D1::RectF(
00277                 windowBounds.Width - GameConstants::HudRightOffset,
00278                 GameConstants::HudTopOffset,
00279                 windowBounds.Width,
00280                 GameConstants::HudTopOffset + (GameConstants::HudBodyPointSize + GameConstants::Margin) * 3
00281                 ),
00282             m_textBrush.Get()
00283             );
00284
00285         // Using the unicode characters starting at 0x2780 ( ➀ ) for the consecutive levels of the game.
00286         // For completed levels start with 0x278A ( ➊ ) (This is 0x2780 + 10).
00287         uint32 levelCharacter[6];
00288         for (uint32 i = 0; i < 6; i++)
00289         {
00290             levelCharacter[i] = 0x2780 + i + ((static_cast<uint32>(game->LevelCompleted()) == i) ? 10 : 0);
00291         }
00292         length = swprintf_s(
00293             wsbuffer,
00294             bufferLength,
00295             L"%lc %lc %lc %lc %lc %lc",
00296             levelCharacter[0],
00297             levelCharacter[1],
00298             levelCharacter[2],
00299             levelCharacter[3],
00300             levelCharacter[4],
00301             levelCharacter[5]
00302             );
00303         d2dContext->DrawText(
00304             wsbuffer,
00305             length,
00306             m_textFormatBodySymbol.Get(),
00307             D2D1::RectF(
00308                 windowBounds.Width - GameConstants::HudRightOffset,
00309                 GameConstants::HudTopOffset + (GameConstants::HudBodyPointSize + GameConstants::Margin) * 3 + GameConstants::Margin,
00310                 windowBounds.Width,
00311                 GameConstants::HudTopOffset + (GameConstants::HudBodyPointSize+ GameConstants::Margin) * 4
00312                 ),
00313             m_textBrush.Get()
00314             );
00315
00316         if (game->IsActivePlay())
00317         {
00318             // Draw a rectangle for the touch input for the move control.
00319             d2dContext->DrawRectangle(
00320                 D2D1::RectF(
00321                     0.0f,
00322                     windowBounds.Height - GameConstants::TouchRectangleSize,
00323                     GameConstants::TouchRectangleSize,
00324                     windowBounds.Height
00325                     ),
00326                 m_textBrush.Get()
00327                 );
00328             // Draw a rectangle for the touch input for the fire control.
00329             d2dContext->DrawRectangle(
00330                 D2D1::RectF(
00331                     windowBounds.Width - GameConstants::TouchRectangleSize,
00332                     windowBounds.Height - GameConstants::TouchRectangleSize,
00333                     windowBounds.Width,
00334                     windowBounds.Height
00335                     ),
00336                 m_textBrush.Get()
00337                 );
00338
00339             // Draw the cross hairs
00340             d2dContext->DrawLine(
00341                 D2D1::Point2F(windowBounds.Width / 2.0f - GameConstants::CrossHairHalfSize, windowBounds.Height / 2.0f),
00342                 D2D1::Point2F(windowBounds.Width / 2.0f + GameConstants::CrossHairHalfSize, windowBounds.Height / 2.0f),
00343                 m_textBrush.Get(),
00344                 3.0f
00345                 );
00346             d2dContext->DrawLine(
00347                 D2D1::Point2F(windowBounds.Width / 2.0f, windowBounds.Height / 2.0f - GameConstants::CrossHairHalfSize),
00348                 D2D1::Point2F(windowBounds.Width / 2.0f, windowBounds.Height / 2.0f + GameConstants::CrossHairHalfSize),
00349                 m_textBrush.Get(),
00350                 3.0f
00351                 );
00352         }
00353     }
00354 }
00355
00356 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/MainPage.xaml.h Source File

  • Background task
  • BackgroundTask

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareImage.xaml.cpp Source File

  • Sharing content source app

ShareImage.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ShareImage.xaml.cpp
00013 // Implementation of the ShareImage class
00014 //
00015
00016 #include "pch.h"
00017 #include "ShareImage.xaml.h"
00018
00019 using namespace SDKSample::ShareSource;
00020 using namespace SDKSample::Common;
00021
00022 using namespace Platform;
00023 using namespace Platform::Collections;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Media::Imaging;
00026 using namespace Windows::Storage;
00027 using namespace Windows::Storage::Streams;
00028 using namespace Windows::Storage::Pickers;
00029 using namespace concurrency;
00030 using namespace Windows::ApplicationModel::DataTransfer;
00031
00032 ShareImage::ShareImage()
00033 {
00034     InitializeComponent();
00035
00036     // Get a pointer to our main page.
00037     rootPage = MainPage::Current;
00038 }
00039
00040 bool ShareImage::GetShareContent(DataRequest^ request)
00041 {
00042     bool succeeded = false;
00043
00044     if (imageFile != nullptr)
00045     {
00046         auto requestData = request->Data;
00047         requestData->Properties->Title = TitleInputBox->Text;
00048
00049         // The description is optional.
00050         auto dataPackageDescription = DescriptionInputBox->Text;
00051         if (dataPackageDescription != nullptr)
00052         {
00053             requestData->Properties->Description = dataPackageDescription;
00054         }
00055
00056         // It's recommended to use both SetBitmap and SetStorageItems for sharing a single image
00057         // since the target app may only support one or the other.
00058
00059         auto imageItems = ref new Vector<IStorageItem^>();
00060         imageItems->Append(imageFile);
00061         requestData->SetStorageItems(imageItems);
00062
00063         auto imageStreamRef = RandomAccessStreamReference::CreateFromFile(imageFile);
00064         requestData->Properties->Thumbnail = imageStreamRef;
00065         requestData->SetBitmap(imageStreamRef);
00066         succeeded = true;
00067     }
00068     else
00069     {
00070         request->FailWithDisplayText("Select an image you would like to share and try again.");
00071     }
00072     return succeeded;
00073 }
00074
00075 void ShareImage::SelectImageButton_Click(Object^ sender, RoutedEventArgs^ e)
00076 {
00077     if (rootPage->EnsureUnsnapped())
00078     {
00079         auto imagePicker = ref new FileOpenPicker();
00080         imagePicker->ViewMode = PickerViewMode::Thumbnail;
00081         imagePicker->SuggestedStartLocation = PickerLocationId::PicturesLibrary;
00082         imagePicker->FileTypeFilter->Append(".jpg");
00083         imagePicker->FileTypeFilter->Append(".png");
00084         imagePicker->FileTypeFilter->Append(".bmp");
00085         imagePicker->FileTypeFilter->Append(".gif");
00086         imagePicker->FileTypeFilter->Append(".tif");
00087
00088         create_task(imagePicker->PickSingleFileAsync()).then([this](StorageFile^ pickedFile)
00089         {
00090             if (pickedFile != nullptr)
00091             {
00092                 imageFile = pickedFile;
00093
00094                 // Display the image in the UI.
00095                 create_task(pickedFile->OpenAsync(FileAccessMode::Read)).then([this](IRandomAccessStream^ displayStream)
00096                 {
00097                     auto bitmapImage = ref new BitmapImage();
00098                     bitmapImage->SetSource(displayStream);
00099                     ImageHolder->Source = bitmapImage;
00100                 });
00101                 rootPage->NotifyUser("Selected " + imageFile->Name + ".", NotifyType::StatusMessage);
00102
00103                 ShareStep->Visibility = Windows::UI::Xaml::Visibility::Visible;
00104             }
00105         });
00106     }
00107 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/common/suspensionmanager.h Source File

  • Device enumeration
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/BasicReaderWriter.cpp Source File

  • Direct3D tutorial
  • Lesson4.Textures

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioOutput4.xaml.cpp Source File

  • Media extensions

ScenarioOutput4.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioOutput4.xaml.cpp
00010 // Implementation of the ScenarioOutput4 class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput4.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace MediaExtensionsCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput4::ScenarioOutput4()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput4::~ScenarioOutput4()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput4::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Get a pointer to our main page.
00045     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047     _mediaFailedToken = Video->MediaFailed += ref new ExceptionRoutedEventHandler(rootPage, &MediaExtensionsCPP::MainPage::VideoOnError);
00048 }
00049
00050 void ScenarioOutput4::OnNavigatedFrom(NavigationEventArgs^ e)
00051 {
00052     Video->MediaFailed -= _mediaFailedToken;
00053     Video->Source = nullptr;
00054 }
00055 #pragma endregion
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/App.xaml.cpp Source File

  • XAML high contrast style

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level3.h Source File

  • DirectX 3D shooting game

Level3.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Level3:
00011 // This class defines the third level of the game.  In this level each of the
00012 // nine targets is moving along closed paths and can be hit
00013 // in any order.
00014
00015 #include "Level.h"
00016
00017 ref class Level3: public Level
00018 {
00019 internal:
00020     Level3();
00021     virtual void Initialize(std::vector<GameObject^> objects) override;
00022 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/BasePrintPage.cpp Source File

  • Print

BasePrintPage.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasePrintPage.h"
00010 #include "ContinuationPage.xaml.h"
00011
00012 using namespace PrintSample;
00013
00014 using namespace Windows::Foundation::Collections;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::Graphics::Display;
00017 using namespace Windows::Graphics::Printing;
00018 using namespace Windows::UI;
00019 using namespace Windows::UI::Text;
00020 using namespace Windows::UI::Xaml::Controls;
00021 using namespace Windows::UI::Xaml::Documents;
00022 using namespace Windows::UI::Xaml::Media;
00023 using namespace Windows::UI::Xaml::Media::Imaging;
00024 using namespace Windows::UI::Xaml::Navigation;
00025
00026 /// <summary>
00027 /// Factory method for every scenario that will create/generate print content specific to each scenario
00028 /// For scenarios 1-5: it will create the first page from which content will flow
00029 /// </summary>
00030 void BasePrintPage::PreparetPrintContent()
00031 {
00032 }
00033
00034 /// <summary>
00035 /// This is the click handler for the 'Register' button.
00036 /// </summary>
00037 /// <param name="sender"></param>
00038 /// <param name="e"></param>
00039 void BasePrintPage::RegisterForPrintingButtonClick(Object^ sender, RoutedEventArgs^ e)
00040 {
00041     Button^ clickedButton = safe_cast<Button^>(sender);
00042
00043     // check to see if the application is registered for printing
00044     if (m_isRegisteredForPrinting)
00045     {
00046         // unregister for printing
00047         UnregisterForPrinting();
00048
00049         // change the text on the button
00050         clickedButton->Content = "Register";
00051
00052         // tell the user that the print contract has been unregistered
00053         m_rootPage->NotifyUser("Print contract unregistered.", NotifyType::StatusMessage);
00054     }
00055     else
00056     {
00057         // register for printing
00058         RegisterForPrinting();
00059
00060         // change the text on the button
00061         clickedButton->Content = "Unregister";
00062
00063         // tell the user that the print contract has been registered
00064         m_rootPage->NotifyUser("Print contract registered, use the Charms Bar to print.", NotifyType::StatusMessage);
00065     }
00066
00067     // toggel the value of isRegisteredForPrinting
00068     m_isRegisteredForPrinting = !m_isRegisteredForPrinting;
00069 }
00070
00071 void BasePrintPage::RegisterForPrinting()
00072 {
00073     // Create the PrintDocument.
00074     m_printDocument = ref new PrintDocument();
00075
00076     // Save the DocumentSource.
00077     m_printDocumentSource = m_printDocument->DocumentSource;
00078
00079     // Add an event handler which creates preview pages.
00080     m_printDocument->Paginate += ref new Windows::UI::Xaml::Printing::PaginateEventHandler(this, &BasePrintPage::CreatePrintPreviewPages);
00081
00082     // Add an event handler which provides a specified preview page.
00083     m_printDocument->GetPreviewPage += ref new Windows::UI::Xaml::Printing::GetPreviewPageEventHandler(this, &BasePrintPage::GetPrintPreviewPage);
00084
00085     // Add an event handler which provides all final print pages.
00086     m_printDocument->AddPages += ref new Windows::UI::Xaml::Printing::AddPagesEventHandler(this, &BasePrintPage::AddPrintPages);
00087
00088     // Create a PrintManager and add a handler for printing initialization.
00089     PrintManager^ printMan = PrintManager::GetForCurrentView();
00090
00091     m_printTaskRequestedEventToken = printMan->PrintTaskRequested += ref new TypedEventHandler<PrintManager^, PrintTaskRequestedEventArgs^>(this, &BasePrintPage::PrintTaskRequested);
00092
00093     // Initialize print content for this scenario
00094     PreparetPrintContent();
00095 }
00096
00097 void BasePrintPage::UnregisterForPrinting()
00098 {
00099     // Remove the handler for printing initialization.
00100     PrintManager^ printMan = PrintManager::GetForCurrentView();
00101
00102     printMan->PrintTaskRequested -= m_printTaskRequestedEventToken;
00103
00104     PrintingRoot->Children->Clear();
00105 }
00106
00107 /// <summary>
00108 /// This is the event handler for PrintManager.PrintTaskRequested.
00109 /// In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified by PrintTaskRequestedEventArgs->Request->Deadline.
00110 /// Therefore, we use this handler to only create the print task.
00111 /// The print settings customization can be done when the print document source is requested.
00112 /// </summary>
00113 /// <param name="sender">PrintManager</param>
00114 /// <param name="e">PrintTaskRequestedEventArgs</param>
00115 void BasePrintPage::PrintTaskRequested(PrintManager^ sender, PrintTaskRequestedEventArgs^ e)
00116 {
00117     auto printTaskRef = std::make_shared<PrintTask^>(nullptr);
00118     *printTaskRef = e->Request->CreatePrintTask("C++ Printing SDK Sample", ref new Windows::Graphics::Printing::PrintTaskSourceRequestedHandler(
00119                                [=](PrintTaskSourceRequestedArgs^ args)
00120                                {
00121                                    PrintTask^ printTask = *printTaskRef;
00122
00123                                    // Print Task event handler is invoked when the print job is completed.
00124                                    printTask->Completed += ref new TypedEventHandler<PrintTask^, PrintTaskCompletedEventArgs^>(
00125                                    [=](PrintTask^ sender, PrintTaskCompletedEventArgs^ e)
00126                                    {
00127                                         // Notify the user when the print operation fails.
00128                                         if (e->Completion == Windows::Graphics::Printing::PrintTaskCompletion::Failed)
00129                                         {
00130                                             auto callback = ref new Windows::UI::Core::DispatchedHandler(
00131                                             [=]()
00132                                             {
00133                                                 m_rootPage->NotifyUser(ref new String(L"Failed to print."), NotifyType::ErrorMessage);
00134                                             });
00135
00136                                             Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, callback);
00137                                         }
00138                                    });
00139
00140                                    args->SetSource(m_printDocumentSource);
00141                                }));
00142 }
00143
00144 /// <summary>
00145 /// This is the event handler for PrintDocument.Paginate. It creates print preview pages for the app.
00146 /// </summary>
00147 /// <param name="sender">PrintDocument</param>
00148 /// <param name="e">Paginate Event Arguments</param>
00149 void BasePrintPage::CreatePrintPreviewPages(Object^ sender, PaginateEventArgs^ e)
00150 {
00151     // Clear the cache of preview pages
00152     m_printPreviewPages.clear();
00153
00154     // Clear the printing root of preview pages
00155     PrintingRoot->Children->Clear();
00156
00157     // This variable keeps track of the last RichTextBlockOverflow element that was added to a page which will be printed
00158     RichTextBlockOverflow^ lastRTBOOnPage;
00159
00160     // Get the PrintTaskOptions
00161     PrintTaskOptions^ printingOptions = safe_cast<PrintTaskOptions^>(e->PrintTaskOptions);
00162
00163     // Get the page description to deterimine how big the page is
00164     PrintPageDescription pageDescription = printingOptions->GetPageDescription(0);
00165
00166     // We know there is at least one page to be printed. passing null as the first parameter to
00167     // AddOnePrintPreviewPage tells the function to add the first page.
00168     lastRTBOOnPage = AddOnePrintPreviewPage(nullptr, pageDescription);
00169
00170     // We know there are more pages to be added as long as the last RichTextBoxOverflow added to a print preview
00171     // page has extra content
00172     while (lastRTBOOnPage->HasOverflowContent && lastRTBOOnPage->Visibility == Windows::UI::Xaml::Visibility::Visible)
00173     {
00174         lastRTBOOnPage = AddOnePrintPreviewPage(lastRTBOOnPage, pageDescription);
00175     }
00176
00177     OnContentCreated();
00178
00179     PrintDocument^ printDocument = safe_cast<PrintDocument^>(sender);
00180
00181     // Report the number of preview pages created
00182     printDocument->SetPreviewPageCount(static_cast<int>(m_printPreviewPages.size()), PreviewPageCountType::Intermediate);
00183 }
00184
00185 void BasePrintPage::GetPrintPreviewPage(Object^ sender, GetPreviewPageEventArgs^ e)
00186 {
00187     PrintDocument^ localprintDocument = safe_cast<PrintDocument^>(sender);
00188     localprintDocument->SetPreviewPage(e->PageNumber, m_printPreviewPages[e->PageNumber - 1]);
00189 }
00190
00191 /// <summary>
00192 /// This is the event handler for PrintDocument.AddPages. It provides all pages to be printed, in the form of
00193 /// UIElements, to an instance of PrintDocument. PrintDocument subsequently converts the UIElements
00194 /// into a pages that the Windows print system can deal with.
00195 /// </summary>
00196 /// <param name="sender"></param>
00197 /// <param name="e">Add page event arguments containing a print task options reference</param>
00198 void BasePrintPage::AddPrintPages(Object^ sender, AddPagesEventArgs^ e)
00199 {
00200     PrintDocument^ printDocument = safe_cast<PrintDocument^>(sender);
00201
00202     // Loop over all of the preview pages and add each one to  add each page to be printied
00203     for (size_t i = 0; i < m_printPreviewPages.size(); i++)
00204     {
00205         printDocument->AddPage(m_printPreviewPages[i]);
00206     }
00207
00208     // Indicate that all of the print pages have been provided
00209     printDocument->AddPagesComplete();
00210 }
00211
00212 /// <summary>
00213 /// This function creates and adds one print preview page to the internal cache of print preview
00214 /// pages stored in m_printPreviewPages.
00215 /// </summary>
00216 /// <param name="lastRTBOAdded">Last RichTextBlockOverflow element added in the current content</param>
00217 /// <param name="printPageDescription">Printer's page description</param>
00218 RichTextBlockOverflow^ BasePrintPage::AddOnePrintPreviewPage(RichTextBlockOverflow^ lastRTBOAdded, PrintPageDescription printPageDescription)
00219 {
00220     // XAML element that is used to represent to "printing page"
00221     FrameworkElement^ page;
00222
00223     // The link container for text overflowing in this page
00224     RichTextBlockOverflow^ textLink;
00225
00226     // Check if this is the first page ( no previous RichTextBlockOverflow)
00227     if (lastRTBOAdded == nullptr)
00228     {
00229         // If this is the first page add the specific scenario content
00230         page = m_firstPage;
00231         //Hide footer since we don't know yet if it will be displayed (this might not be the last page) - wait for layout
00232         StackPanel^ footer = safe_cast<StackPanel^>(page->FindName("footer"));
00233         footer->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00234     }
00235     else
00236     {
00237         // Flow content (text) from previous pages
00238         page = ref new ContinuationPage(lastRTBOAdded);
00239     }
00240
00241     // Set "paper" width
00242     page->Width = printPageDescription.PageSize.Width;
00243     page->Height = printPageDescription.PageSize.Height;
00244
00245     Grid^ printableArea = safe_cast<Grid^>(page->FindName("printableArea"));
00246
00247     // Get the margins size
00248     // If the ImageableRect is smaller than the app provided margins use the ImageableRect
00249     double marginWidth = (std::max)(printPageDescription.PageSize.Width - printPageDescription.ImageableRect.Width, printPageDescription.PageSize.Width * ApplicationContentMarginLeft * 2);
00250     double marginHeight = (std::max)(printPageDescription.PageSize.Height - printPageDescription.ImageableRect.Height, printPageDescription.PageSize.Height * ApplicationContentMarginTop * 2);
00251
00252     // Set-up "printable area" on the "paper"
00253     printableArea->Width = m_firstPage->Width - marginWidth;
00254     printableArea->Height = m_firstPage->Height - marginHeight;
00255
00256     // Add the (newley created) page to the printing root which is part of the visual tree and force it to go
00257     // through layout so that the linked containers correctly distribute the content inside them.
00258     PrintingRoot->Children->Append(page);
00259     PrintingRoot->InvalidateMeasure();
00260     PrintingRoot->UpdateLayout();
00261
00262     // Find the last text container and see if the content is overflowing
00263     textLink = safe_cast<RichTextBlockOverflow^>(page->FindName("continuationPageLinkedContainer"));
00264
00265     // Check if this is the last page
00266     if (!textLink->HasOverflowContent && textLink->Visibility == Windows::UI::Xaml::Visibility::Visible)
00267     {
00268         StackPanel^ footer = safe_cast<StackPanel^>(page->FindName("footer"));
00269         footer->Visibility = Windows::UI::Xaml::Visibility::Visible;
00270     }
00271
00272     // Add the page to the page preview collection
00273     m_printPreviewPages.push_back(page);
00274
00275     return textLink;
00276 }
00277
00278 void BasePrintPage::RemovePageFromPrintPreviewCollection(int pageNumber)
00279 {
00280     m_printPreviewPages.erase(m_printPreviewPages.begin() + pageNumber);
00281 }
00282
00283 void BasePrintPage::OnNavigatedTo(NavigationEventArgs^ e)
00284 {
00285     // Get a pointer to our main page.
00286     m_rootPage = safe_cast<MainPage^>(e->Parameter);
00287 }
00288
00289 void BasePrintPage::OnNavigatedFrom(NavigationEventArgs^ e)
00290 {
00291     UnregisterForPrinting() ;
00292 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/App.xaml.h Source File

  • XAML AppBar control

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace AppBarControl
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028     public:
00029         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00030         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00031     private:
00032         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00033     };
00034 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BindableBase.h Source File

  • Hilo C++
  • Hilo
  • Common

BindableBase.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     namespace Common
00012     {
00013         /// <summary>
00014         /// Implementation of <see cref="INotifyPropertyChanged"/> to simplify models.
00015         /// </summary>
00016         [Windows::Foundation::Metadata::WebHostHidden]
00017         public ref class BindableBase : Windows::UI::Xaml::DependencyObject, Windows::UI::Xaml::Data::INotifyPropertyChanged, Windows::UI::Xaml::Data::ICustomPropertyProvider
00018         {
00019         public:
00020             virtual event Windows::UI::Xaml::Data::PropertyChangedEventHandler^ PropertyChanged;
00021
00022         public:
00023             // ICustomPropertyProvider
00024             virtual Windows::UI::Xaml::Data::ICustomProperty^ GetCustomProperty(Platform::String^ name);
00025             virtual Windows::UI::Xaml::Data::ICustomProperty^ GetIndexedProperty(Platform::String^ name, Windows::UI::Xaml::Interop::TypeName type);
00026             virtual Platform::String^ GetStringRepresentation();
00027
00028             property Windows::UI::Xaml::Interop::TypeName Type
00029             {
00030                 virtual Windows::UI::Xaml::Interop::TypeName get() { return this->GetType(); }
00031             }
00032
00033
00034         protected:
00035             virtual void OnPropertyChanged(Platform::String^ propertyName);
00036         };
00037     }
00038 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/C++,JavaScript/cpp/pch.h Source File

  • DirectWrite font enumeration
  • C++,JavaScript
  • cpp

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
00007 #include <wrl.h>
00008 #include <dwrite.h>
00009 #include <strsafe.h>
00010 #include <assert.h>
00011 #include <time.h>
00012 #include <WinNls.h>
00013 #include <datetimeapi.h>
00014 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/Scenario3.xaml.h Source File

  • XAML images

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Images
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario3 sealed
00031         {
00032         public:
00033             Scenario3();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWidePeekImageCollection03 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWidePeekImageCollection03, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
ImageMain | NotificationsExtensions::TileContent::TileWidePeekImageCollection03 |
Images | NotificationsExtensions::NotificationBase |
ImageSmallColumn1Row1 | NotificationsExtensions::TileContent::TileWidePeekImageCollection03 |
ImageSmallColumn1Row2 | NotificationsExtensions::TileContent::TileWidePeekImageCollection03 |
ImageSmallColumn2Row1 | NotificationsExtensions::TileContent::TileWidePeekImageCollection03 |
ImageSmallColumn2Row2 | NotificationsExtensions::TileContent::TileWidePeekImageCollection03 |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextFields | NotificationsExtensions::NotificationBase |
TextHeadingWrap | NotificationsExtensions::TileContent::TileWidePeekImageCollection03 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWidePeekImageCollection03() | NotificationsExtensions::TileContent::TileWidePeekImageCollection03 | [inline]
TileWidePeekImageCollection03() | NotificationsExtensions::TileContent::TileWidePeekImageCollection03 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusTask/pch.h Source File

  • Network status background
  • NetworkStatusTask

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/ShareCustomData.xaml.h Source File

  • Sharing content source app

ShareCustomData.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ShareCustomData.xaml.h
00013 // Declaration of the ShareCustomData class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "SharePage.h"
00020 #include "ShareCustomData.g.h"
00021 #include "MainPage.xaml.h"
00022
00023 #define CUSTOM_DATA_CONTENT "{ \
00024                                 \"type\" : \"http://schema.org/Book\", \
00025                                 \"properties\" : \
00026                                 { \
00027                                     \"image\" : \"http://sourceurl.com/catcher-in-the-rye-book-cover.jpg\", \
00028                                     \"name\" : \"The Catcher in the Rye\", \
00029                                     \"bookFormat\" : \"http://schema.org/Paperback\", \
00030                                     \"author\" : \"http://sourceurl.com/author/jd_salinger.html\", \
00031                                     \"numberOfPages\" : 224, \
00032                                     \"publisher\" : \"Little, Brown, and Company\", \
00033                                     \"datePublished\" : \"1991-05-01\", \
00034                                     \"inLanguage\" : \"English\", \
00035                                     \"isbn\" : \"0316769487\" \
00036                                 } \
00037                             }"
00038
00039 namespace SDKSample
00040 {
00041     namespace ShareSource
00042     {
00043         [Windows::Foundation::Metadata::WebHostHidden]
00044         public ref class ShareCustomData sealed
00045         {
00046         public:
00047             ShareCustomData();
00048
00049         protected:
00050             virtual bool GetShareContent(Windows::ApplicationModel::DataTransfer::DataRequest^ request) override;
00051         };
00052     }
00053 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWidePeekImageCollection01 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWidePeekImageCollection01, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
ImageMain | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 |
Images | NotificationsExtensions::NotificationBase |
ImageSmallColumn1Row1 | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 |
ImageSmallColumn1Row2 | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 |
ImageSmallColumn2Row1 | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 |
ImageSmallColumn2Row2 | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBodyWrap | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 |
TextFields | NotificationsExtensions::NotificationBase |
TextHeading | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWidePeekImageCollection01() | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 | [inline]
TileWidePeekImageCollection01() | NotificationsExtensions::TileContent::TileWidePeekImageCollection01 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::PlayTo::sealed Member List

This is the complete list of members for SDKSample::PlayTo::sealed, including all inherited members.
dispatcher | SDKSample::PlayTo::sealed | [private]
localFile | SDKSample::PlayTo::sealed | [private]
nextItem_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PlayTo::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PlayTo::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PlayTo::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PlayTo::sealed | [protected, virtual]
pauseButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
pauseSlideshow_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
playButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
Playlist_SelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
playListPlayNext() | SDKSample::PlayTo::sealed | [private]
playlistTimer | SDKSample::PlayTo::sealed | [private]
playlistTimer_Tick(Platform::Object^sender, Platform::Object^e) | SDKSample::PlayTo::sealed | [private]
playSlideshow_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
playToManager | SDKSample::PlayTo::sealed | [private]
playToManager_SourceRequested(Windows::Media::PlayTo::PlayToManager^sender, Windows::Media::PlayTo::PlayToSourceRequestedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
playToManager_SourceRequested(Windows::Media::PlayTo::PlayToManager^sender, Windows::Media::PlayTo::PlayToSourceRequestedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
previousItem_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
rootPage | SDKSample::PlayTo::sealed | [private]
Scenario1() | SDKSample::PlayTo::sealed |
Scenario2() | SDKSample::PlayTo::sealed |
sourceRequestedToken | SDKSample::PlayTo::sealed | [private]
timerTickToken | SDKSample::PlayTo::sealed | [private]
videoFile_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
webContent_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlayTo::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::DataBinding::IncrementalLoadingBase Member List

This is the complete list of members for SDKSample::DataBinding::IncrementalLoadingBase, including all inherited members.
__pad0__ | SDKSample::DataBinding::IncrementalLoadingBase |
_busy | SDKSample::DataBinding::IncrementalLoadingBase |
_isVectorChangedObserved | SDKSample::DataBinding::IncrementalLoadingBase |
_privateVectorChanged | SDKSample::DataBinding::IncrementalLoadingBase |
_storageVectorChanged(Windows::Foundation::Collections::IObservableVector< Platform::Object^>^sender, Windows::Foundation::Collections::IVectorChangedEventArgs^e) | SDKSample::DataBinding::IncrementalLoadingBase | [inline]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/DirectXSample.h Source File

  • UI Automation core window provider

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

StartOp Member List

This is the complete list of members for StartOp, including all inherited members.
CreateOp(Operation op, SourceOp **ppOp) | SourceOp | [static]
CreateOp(Operation op, SourceOp **ppOp) | SourceOp | [static]
CreateSetRateOp(BOOL fThin, float flRate, SourceOp **ppOp) | SourceOp | [static]
CreateSetRateOp(BOOL fThin, float flRate, SourceOp **ppOp) | SourceOp | [static]
CreateStartOp(IMFPresentationDescriptor *pPD, SourceOp **ppOp) | SourceOp | [static]
CreateStartOp(IMFPresentationDescriptor *pPD, SourceOp **ppOp) | SourceOp | [static]
Data() | SourceOp | [inline]
Data() | SourceOp | [inline]
GetPresentationDescriptor(IMFPresentationDescriptor **ppPD) | StartOp |
GetPresentationDescriptor(IMFPresentationDescriptor **ppPD) | StartOp |
m_cRef | SourceOp | [protected]
m_data | SourceOp | [protected]
m_op | SourceOp | [protected]
m_pPD | StartOp | [protected]
Op() const | SourceOp | [inline]
Op() const | SourceOp | [inline]
OP_END_OF_STREAM enum value | SourceOp |
OP_PAUSE enum value | SourceOp |
OP_REQUEST_DATA enum value | SourceOp |
OP_SETRATE enum value | SourceOp |
OP_START enum value | SourceOp |
OP_STOP enum value | SourceOp |
Operation enum name | SourceOp |
Operation enum name | SourceOp |
QueryInterface(REFIID iid, void **ppv) | SourceOp |
QueryInterface(REFIID iid, void **ppv) | SourceOp |
SetData(const PROPVARIANT &var) | SourceOp |
SetData(const PROPVARIANT &var) | SourceOp |
SourceOp(Operation op) | SourceOp |
SourceOp(Operation op) | SourceOp |
StartOp(IMFPresentationDescriptor *pPD) | StartOp |
StartOp(IMFPresentationDescriptor *pPD) | StartOp |
STDMETHODIMP_(ULONG) AddRef() | SourceOp |
STDMETHODIMP_(ULONG) Release() | SourceOp |
STDMETHODIMP_(ULONG) AddRef() | SourceOp |
STDMETHODIMP_(ULONG) Release() | SourceOp |
~SourceOp() | SourceOp | [virtual]
~SourceOp() | SourceOp | [virtual]
~StartOp() | StartOp |
~StartOp() | StartOp |
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Scenario2.xaml.cpp Source File

  • Background Transfer

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample;
00020 using namespace SDKSample::BackgroundTransfer;
00021
00022 using namespace Concurrency;
00023 using namespace Platform;
00024 using namespace Platform::Collections;
00025 using namespace Windows::UI::Core;
00026 using namespace Windows::UI::ViewManagement;
00027 using namespace Windows::UI::Xaml;
00028 using namespace Windows::UI::Xaml::Controls;
00029 using namespace Windows::UI::Xaml::Navigation;
00030 using namespace Windows::Networking::BackgroundTransfer;
00031 using namespace Windows::Web;
00032 using namespace Windows::Foundation;
00033 using namespace Windows::Foundation::Collections;
00034 using namespace Windows::Storage;
00035 using namespace Windows::Storage::Pickers;
00036
00037 Scenario2::Scenario2()
00038 {
00039     InitializeComponent();
00040     cancellationToken = new cancellation_token_source();
00041 }
00042
00043 Scenario2::~Scenario2()
00044 {
00045     if (cancellationToken != nullptr)
00046     {
00047         delete cancellationToken;
00048     }
00049 }
00050
00051 /// <summary>
00052 /// Invoked when this page is about to be displayed in a Frame.
00053 /// </summary>
00054 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00055 /// property is typically used to configure the page.</param>
00056 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00057 {
00058     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00059     // as NotifyUser()
00060     rootPage = MainPage::Current;
00061 }
00062
00063
00064 // Enumerate the uploads that were going on in the background while the app was closed.
00065 void Scenario2::DiscoverActiveUploads()
00066 {
00067     task<IVectorView<UploadOperation^>^>(BackgroundUploader::GetCurrentUploadsAsync()).then([this] (IVectorView<UploadOperation^>^ uploads)
00068     {
00069         Log("Loading background downloads: " + uploads->Size);
00070
00071         for (unsigned int i = 0; i < uploads->Size; i++)
00072         {
00073             UploadOperation^ upload = uploads->GetAt(i);
00074             Log("Discovered background upload: " + upload->Guid + ", Status: " + upload->Progress.Status.ToString());
00075
00076             // Attach progress and completion handlers.
00077             HandleUploadAsync(upload, false);
00078         }
00079     }).then([this] (task<void> previousTask)
00080     {
00081         try
00082         {
00083             previousTask.get();
00084         }
00085         catch (Exception^ ex)
00086         {
00087             LogException("Discovery error", ex);
00088         }
00089     });
00090 }
00091
00092 void Scenario2::StartUpload_Click(Object^ sender, RoutedEventArgs^ e)
00093 {
00094     // By default 'serverAddressField' is disabled and URI validation is not required. When enabling the text box
00095     // validating the URI is required since it was received from an untrusted source (user input).
00096     // The URI is validated by calling TryGetUri() that will return 'false' for strings that are not valid URIs.
00097     // Note that when enabling the text box users may provide URIs to machines on the intrAnet that require the
00098     // "Home or Work Networking" capability.
00099     Uri^ uri;
00100     if (!rootPage->TryGetUri(serverAddressField->Text, &uri))
00101     {
00102         return;
00103     }
00104
00105     // Verify that we are currently not snapped, or that we can unsnap to open the picker.
00106     if (ApplicationView::Value == ApplicationViewState::Snapped && !ApplicationView::TryUnsnap())
00107     {
00108         rootPage->NotifyUser("File picker cannot be opened in snapped mode. Please unsnap first.", NotifyType::ErrorMessage);
00109         return;
00110     }
00111
00112     FileOpenPicker^ picker = ref new FileOpenPicker();
00113     picker->FileTypeFilter->Append("*");
00114
00115     task<StorageFile^>(picker->PickSingleFileAsync()).then([this, uri] (StorageFile^ file)
00116     {
00117         if (file == nullptr)
00118         {
00119             rootPage->NotifyUser("Error: No file selected.", NotifyType::ErrorMessage);
00120             cancel_current_task();
00121         }
00122
00123         BackgroundUploader^ uploader = ref new BackgroundUploader();
00124         uploader->SetRequestHeader("Filename", file->Name);
00125
00126         UploadOperation^ upload = uploader->CreateUpload(uri, file);
00127         Log("Uploading " + file->Name + " to " + uri->AbsoluteUri + ", " + upload->Guid);
00128
00129         // Attach progress and completion handlers.
00130         HandleUploadAsync(upload, true);
00131     }).then([this] (task<void> previousTask)
00132     {
00133         try
00134         {
00135             previousTask.get();
00136         }
00137         catch (Exception^ ex)
00138         {
00139             LogException("Upload Error", ex);
00140         }
00141         catch (task_canceled&)
00142         {
00143             // Do nothing - we canceled the task.
00144         }
00145     });
00146 }
00147
00148 void Scenario2::StartMultipartUpload_Click(Object^ sender, RoutedEventArgs^ e)
00149 {
00150     // By default 'serverAddressField' is disabled and URI validation is not required. When enabling the text box
00151     // validating the URI is required (like TryGetUri) since it was received from an untrusted source (user input).
00152     // The URI is validated by calling TryGetUri() that will return 'false' for strings that are not valid URIs.
00153     // Note that when enabling the text box users may provide URIs to machines on the intrAnet that require the
00154     // "Home or Work Networking" capability.
00155     Uri^ uri;
00156     if (!rootPage->TryGetUri(serverAddressField->Text, &uri))
00157     {
00158         return;
00159     }
00160
00161     // Verify that we are currently not snapped, or that we can unsnap to open the picker.
00162     if (ApplicationView::Value == ApplicationViewState::Snapped && !ApplicationView::TryUnsnap())
00163     {
00164         rootPage->NotifyUser("File picker cannot be opened in snapped mode. Please unsnap first.", NotifyType::ErrorMessage);
00165         return;
00166     }
00167
00168     FileOpenPicker^ picker = ref new FileOpenPicker();
00169     picker->FileTypeFilter->Append("*");
00170
00171     task<IVectorView<StorageFile^>^>(picker->PickMultipleFilesAsync()).then([this, uri]  (IVectorView<StorageFile^>^ files)
00172     {
00173         if (files->Size == 0)
00174         {
00175             rootPage->NotifyUser("Error: No file selected.", NotifyType::ErrorMessage);
00176             cancel_current_task();
00177         }
00178
00179         Vector<BackgroundTransferContentPart^>^ parts = ref new Vector<BackgroundTransferContentPart^>;
00180         for (unsigned int i = 0; i < files->Size; i++)
00181         {
00182             BackgroundTransferContentPart^ part = ref new BackgroundTransferContentPart("File" + i, files->GetAt(i)->Name);
00183             part->SetFile(files->GetAt(i));
00184             parts->Append(part);
00185         }
00186
00187         BackgroundUploader^ uploader = ref new BackgroundUploader();
00188         return task<UploadOperation^>(uploader->CreateUploadAsync(uri, parts)).then([this, uri, files] (UploadOperation^ upload)
00189         {
00190             String^ fileNames = files->GetAt(0)->Name;
00191             for (unsigned int i = 1; i < files->Size; i++)
00192             {
00193                 fileNames += ", " + files->GetAt(i)->Name;
00194             }
00195
00196             Log("Uploading " + fileNames + " to " + uri->AbsoluteUri + ", " + upload->Guid);
00197
00198             // Attach progress and completion handlers.
00199             HandleUploadAsync(upload, true);
00200         });
00201     }).then([this] (task<void> previousTask)
00202     {
00203         try
00204         {
00205             previousTask.get();
00206         }
00207         catch (Exception^ ex)
00208         {
00209             LogException("Upload Error", ex);
00210         }
00211         catch (task_canceled&)
00212         {
00213             // Do nothing - we canceled the task.
00214         }
00215     });
00216 }
00217
00218 void Scenario2::CancelAll_Click(Object^ sender, RoutedEventArgs^ e)
00219 {
00220     Log("Cancelling all Uploads");
00221
00222     cancellationToken->cancel();
00223     cancellationToken = new cancellation_token_source();
00224 }
00225
00226 // Note that this event is invoked on a background thread, so we cannot access the UI directly.
00227 void Scenario2::UploadProgress(IAsyncOperationWithProgress<UploadOperation^, UploadOperation^>^ operation, UploadOperation^ upload)
00228 {
00229     MarshalLog("Progress: " + upload->Guid + ", Status: " + upload->Progress.Status.ToString());
00230
00231     double percentSent = 100;
00232     if (upload->Progress.TotalBytesToSend > 0)
00233     {
00234         percentSent = (double)(upload->Progress.BytesSent * 100 / upload->Progress.TotalBytesToSend);
00235     }
00236
00237     MarshalLog(" - Sent bytes: " + upload->Progress.BytesSent + " of " + upload->Progress.TotalBytesToSend +
00238         " (" + percentSent + "%), Received bytes: " + upload->Progress.BytesReceived + " of " +
00239         upload->Progress.TotalBytesToReceive);
00240
00241     if (upload->Progress.HasRestarted)
00242     {
00243         MarshalLog(" - Upload restarted");
00244     }
00245
00246     if (upload->Progress.HasResponseChanged)
00247     {
00248         // We've received new response headers from the server.
00249         MarshalLog(" - Response updated; Header count: " + upload->GetResponseInformation()->Headers->Size);
00250
00251         // If you want to stream the response data this is a good time to start.
00252         // upload.GetResultStreamAt(0);
00253     }
00254 }
00255
00256 void Scenario2::HandleUploadAsync(UploadOperation^ upload, bool start)
00257 {
00258     IAsyncOperationWithProgress<UploadOperation^, UploadOperation^>^ async;
00259
00260     LogStatus("Running: " + upload->Guid, NotifyType::StatusMessage);
00261
00262     if (start)
00263     {
00264         async = upload->StartAsync();
00265     }
00266     else
00267     {
00268         async = upload->AttachAsync();
00269     }
00270
00271     async->Progress = ref new AsyncOperationProgressHandler<UploadOperation^, UploadOperation^>(this, &Scenario2::UploadProgress);
00272     task<UploadOperation^>(async, cancellationToken->get_token()).then([this] (UploadOperation^ upload)
00273     {
00274         ResponseInformation^ response = upload->GetResponseInformation();
00275         LogStatus("Completed: " + upload->Guid + ", Status Code: " + response->StatusCode,
00276             NotifyType::StatusMessage);
00277     }).then([this, upload] (task<void> previousTask)
00278     {
00279         try
00280         {
00281             previousTask.get();
00282         }
00283         catch (Exception^ ex)
00284         {
00285             LogException("Handle download", ex);
00286         }
00287     });
00288 }
00289
00290 void Scenario2::LogException(String^ title, Exception^ ex)
00291 {
00292     WebErrorStatus error = BackgroundTransferError::GetStatus(ex->HResult);
00293     if (error == WebErrorStatus::Unknown)
00294     {
00295         LogStatus(title + ": " + ex, NotifyType::ErrorMessage);
00296     }
00297     else
00298     {
00299         LogStatus(title + ": " + error.ToString(), NotifyType::ErrorMessage);
00300     }
00301 }
00302
00303 // When operations happen on a background thread we have to marshal UI updates back to the UI thread.
00304 void Scenario2::MarshalLog(String^ value)
00305 {
00306     Dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this, value] ()
00307     {
00308         Log(value);
00309     }));
00310 }
00311
00312 void Scenario2::Log(String^ message)
00313 {
00314     outputField->Text += message + "\r\n";
00315 }
00316
00317 void Scenario2::LogStatus(String^ message, NotifyType type)
00318 {
00319     rootPage->NotifyUser(message, type);
00320     outputField->Text += message + "\r\n";
00321 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideImage Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideImage, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::TileContent::TileWideImage |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideImage() | NotificationsExtensions::TileContent::TileWideImage | [inline]
TileWideImage() | NotificationsExtensions::TileContent::TileWideImage | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Wrapper::DspSettings Member List

This is the complete list of members for Wrapper::DspSettings, including all inherited members.
isEnabled | Wrapper::DspSettings
percentOfScreen | Wrapper::DspSettings
Generated on Sat Nov 23 2024 16:09:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ConstantBufferLayoutForGlowPixelShader Member List

This is the complete list of members for ConstantBufferLayoutForGlowPixelShader, including all inherited members.
sampleOffsets | ConstantBufferLayoutForGlowPixelShader
sampleWeights | ConstantBufferLayoutForGlowPixelShader
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/App.xaml.cpp Source File

  • Direct2D 3D transform effect

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "App.xaml.h"
00010
00011 using namespace D2D3DTransforms;
00012
00013 using namespace Platform;
00014 using namespace Windows::ApplicationModel;
00015 using namespace Windows::ApplicationModel::Core;
00016 using namespace Windows::ApplicationModel::Activation;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Foundation::Collections;
00019 using namespace Windows::Graphics::Display;
00020 using namespace Windows::UI::Core;
00021 using namespace Windows::UI::ViewManagement;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Controls::Primitives;
00025 using namespace Windows::UI::Xaml::Data;
00026 using namespace Windows::UI::Xaml::Input;
00027 using namespace Windows::UI::Xaml::Media;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Media::Animation;
00030
00031
00032 App::App()
00033 {
00034     // Used by compiler-generated code.
00035     InitializeComponent();
00036 }
00037
00038 void App::OnLaunched(
00039     _In_ LaunchActivatedEventArgs^ args
00040     )
00041 {
00042     m_mainPage = ref new MainPage();
00043
00044     Window::Current->Content = m_mainPage;
00045     Window::Current->Activate();
00046
00047     Suspending += ref new SuspendingEventHandler(this, &App::OnSuspending);
00048 }
00049
00050 void App::OnSuspending(
00051     _In_ Object^ sender,
00052     _In_ SuspendingEventArgs^ args
00053     )
00054 {
00055     m_mainPage->OnSuspending(sender, args);
00056 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/Constants.cpp Source File

  • File picker contracts

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "Constants.h"
00013 #include "MainPage.xaml.h"
00014 #include "FileOpenPickerPage.xaml.h"
00015 #include "FileSavePickerPage.xaml.h"
00016 #include "CachedFileUpdaterPage.xaml.h"
00017
00018 using namespace SDKSample;
00019 using namespace SDKSample::Common;
00020 using namespace SDKSample::FilePickerContracts;
00021
00022 using namespace Platform;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::Storage::Pickers::Provider;
00025 using namespace Windows::Storage::Provider;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::ViewManagement;
00029
00030 String^ Status::FileAdded      = "File added to the basket.";
00031 String^ Status::FileRemoved    = "File removed from the basket.";
00032 String^ Status::FileAddFailed  = "Couldn't add file to the basket.";
00033
00034 Array<Scenario>^ MainPage::scenariosInner = ref new Array<Scenario>
00035 {
00036     { "File Open Picker contract",    "SDKSample.FilePickerContracts.MainPage_PickFile" },
00037     { "File Save Picker contract",    "SDKSample.FilePickerContracts.MainPage_SaveFile" },
00038     { "Cached File Updater contract", "SDKSample.FilePickerContracts.MainPage_CachedFile" },
00039 };
00040
00041 Array<Scenario>^ FileOpenPickerPage::scenariosInner = ref new Array<Scenario>
00042 {
00043     { "Pick a file from the application package", "SDKSample.FilePickerContracts.FileOpenPicker_PickAppFile" },
00044     { "Pick a file from a URI",                   "SDKSample.FilePickerContracts.FileOpenPicker_PickURLFile" },
00045     { "Pick cached file",                         "SDKSample.FilePickerContracts.FileOpenPicker_PickCachedFile" },
00046 };
00047
00048 Array<Scenario>^ FileSavePickerPage::scenariosInner = ref new Array<Scenario>
00049 {
00050     { "Save a file to app's storage",    "SDKSample.FilePickerContracts.FileSavePicker_SaveToAppStorage" },
00051     { "Fail to save a file",             "SDKSample.FilePickerContracts.FileSavePicker_FailToSave" },
00052     { "Save to cached file",             "SDKSample.FilePickerContracts.FileSavePicker_SaveToCachedFile" },
00053 };
00054
00055 Array<Scenario>^ CachedFileUpdaterPage::localScenariosInner = ref new Array<Scenario>
00056 {
00057     { "Get latest version", "SDKSample.FilePickerContracts.CachedFileUpdater_Local" },
00058 };
00059
00060 Array<Scenario>^ CachedFileUpdaterPage::remoteScenariosInner = ref new Array<Scenario>
00061 {
00062     { "Remote file update", "SDKSample.FilePickerContracts.CachedFileUpdater_Remote" },
00063 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/NotificationsExtensions/Common.cs Source File

  • App tiles and badges
  • C#,C++
  • NotificationsExtensions

Common.cs

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 using System;
00009 using System.Collections.ObjectModel;
00010 using System.Runtime.InteropServices;
00011 using System.Text;
00012 #if !WINRT_NOT_PRESENT
00013 using Windows.Data.Xml.Dom;
00014 #endif
00015
00016 namespace NotificationsExtensions
00017 {
00018     internal sealed class NotificationContentText : INotificationContentText
00019     {
00020         internal NotificationContentText() { }
00021
00022         public string Text
00023         {
00024             get { return m_Text; }
00025             set { m_Text = value; }
00026         }
00027
00028         public string Lang
00029         {
00030             get { return m_Lang; }
00031             set { m_Lang = value; }
00032         }
00033
00034         private string m_Text;
00035         private string m_Lang;
00036     }
00037
00038     internal sealed class NotificationContentImage : INotificationContentImage
00039     {
00040         internal NotificationContentImage() { }
00041
00042         public string Src
00043         {
00044             get { return m_Src; }
00045             set { m_Src = value; }
00046         }
00047
00048         public string Alt
00049         {
00050             get { return m_Alt; }
00051             set { m_Alt = value; }
00052         }
00053
00054         public bool AddImageQuery
00055         {
00056             get
00057             {
00058                 if (m_AddImageQueryNullable == null || m_AddImageQueryNullable.Value == false)
00059                 {
00060                     return false;
00061                 }
00062                 else
00063                 {
00064                     return true;
00065                 }
00066             }
00067             set { m_AddImageQueryNullable = value; }
00068         }
00069
00070         public bool? AddImageQueryNullable
00071         {
00072             get { return m_AddImageQueryNullable; }
00073             set { m_AddImageQueryNullable = value; }
00074         }
00075
00076         private string m_Src;
00077         private string m_Alt;
00078         private bool? m_AddImageQueryNullable;
00079     }
00080
00081     internal static class Util
00082     {
00083         public const int NOTIFICATION_CONTENT_VERSION = 1;
00084
00085         public static string HttpEncode(string value)
00086         {
00087             return value.Replace("&", "&amp;").Replace("<", "&lt;").Replace(">", "&gt;").Replace("\"", "&quot;").Replace("'", "&apos;");
00088         }
00089     }
00090
00091     /// <summary>
00092     /// Base class for the notification content creation helper classes.
00093     /// </summary>
00094 #if !WINRT_NOT_PRESENT
00095     internal abstract class NotificationBase
00096 #else
00097     abstract partial class NotificationBase
00098 #endif
00099     {
00100         protected NotificationBase(string templateName, int imageCount, int textCount)
00101         {
00102             m_TemplateName = templateName;
00103
00104             m_Images = new NotificationContentImage[imageCount];
00105             for (int i = 0; i < m_Images.Length; i++)
00106             {
00107                 m_Images[i] = new NotificationContentImage();
00108             }
00109
00110             m_TextFields = new INotificationContentText[textCount];
00111             for (int i = 0; i < m_TextFields.Length; i++)
00112             {
00113                 m_TextFields[i] = new NotificationContentText();
00114             }
00115         }
00116
00117         public bool StrictValidation
00118         {
00119             get { return m_StrictValidation; }
00120             set { m_StrictValidation = value; }
00121         }
00122         public abstract string GetContent();
00123
00124         public override string ToString()
00125         {
00126             return GetContent();
00127         }
00128
00129 #if !WINRT_NOT_PRESENT
00130         public XmlDocument GetXml()
00131         {
00132             XmlDocument xml = new XmlDocument();
00133             xml.LoadXml(GetContent());
00134             return xml;
00135         }
00136 #endif
00137
00138         /// <summary>
00139         /// Retrieves the list of images that can be manipulated on the notification content.
00140         /// </summary>
00141         public INotificationContentImage[] Images
00142         {
00143             get { return m_Images; }
00144         }
00145
00146         /// <summary>
00147         /// Retrieves the list of text fields that can be manipulated on the notification content.
00148         /// </summary>
00149         public INotificationContentText[] TextFields
00150         {
00151             get { return m_TextFields; }
00152         }
00153
00154         /// <summary>
00155         /// The base Uri path that should be used for all image references in the notification.
00156         /// </summary>
00157         public string BaseUri
00158         {
00159             get { return m_BaseUri; }
00160             set
00161             {
00162                 if (this.StrictValidation && !String.IsNullOrEmpty(value))
00163                 {
00164                     Uri uri;
00165                     try
00166                     {
00167                         uri = new Uri(value);
00168                     }
00169                     catch (Exception e)
00170                     {
00171                         throw new ArgumentException("Invalid URI. Use a valid URI or turn off StrictValidation", e);
00172                     }
00173                     if (!(uri.Scheme.Equals("http", StringComparison.OrdinalIgnoreCase)
00174                         || uri.Scheme.Equals("https", StringComparison.OrdinalIgnoreCase)
00175                         || uri.Scheme.Equals("ms-appx", StringComparison.OrdinalIgnoreCase)
00176                         || (uri.Scheme.Equals("ms-appdata", StringComparison.OrdinalIgnoreCase)
00177                             && (String.IsNullOrEmpty(uri.Authority)) // check to make sure the Uri isn't ms-appdata://foo/local
00178                             && (uri.AbsolutePath.StartsWith("/local/") || uri.AbsolutePath.StartsWith("local/"))))) // both ms-appdata:local/ and ms-appdata:/local/ are valid
00179                     {
00180                         throw new ArgumentException("The BaseUri must begin with http://, https://, ms-appx:///, or ms-appdata:///local/.", "value");
00181                     }
00182                 }
00183                 m_BaseUri = value;
00184             }
00185         }
00186
00187         public string Lang
00188         {
00189             get { return m_Lang; }
00190             set { m_Lang = value; }
00191         }
00192
00193         public bool AddImageQuery
00194         {
00195             get
00196             {
00197                 if (m_AddImageQueryNullable == null || m_AddImageQueryNullable.Value == false)
00198                 {
00199                     return false;
00200                 }
00201                 else
00202                 {
00203                     return true;
00204                 }
00205             }
00206             set { m_AddImageQueryNullable = value; }
00207         }
00208
00209         public bool? AddImageQueryNullable
00210         {
00211             get { return m_AddImageQueryNullable; }
00212             set { m_AddImageQueryNullable = value; }
00213         }
00214
00215         protected string SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery)
00216         {
00217             globalLang = (globalLang != null) ? globalLang : String.Empty;
00218             globalBaseUri = String.IsNullOrWhiteSpace(globalBaseUri) ? null : globalBaseUri;
00219
00220             StringBuilder builder = new StringBuilder(String.Empty);
00221             for (int i = 0; i < m_Images.Length; i++)
00222             {
00223                 if (!String.IsNullOrEmpty(m_Images[i].Src))
00224                 {
00225                     string escapedSrc = Util.HttpEncode(m_Images[i].Src);
00226                     if (!String.IsNullOrWhiteSpace(m_Images[i].Alt))
00227                     {
00228                         string escapedAlt = Util.HttpEncode(m_Images[i].Alt);
00229                         if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
00230                         {
00231                             builder.AppendFormat("<image id='{0}' src='{1}' alt='{2}'/>", i + 1, escapedSrc, escapedAlt);
00232                         }
00233                         else
00234                         {
00235                             builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}' alt='{3}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc, escapedAlt);
00236                         }
00237                     }
00238                     else
00239                     {
00240                         if (m_Images[i].AddImageQueryNullable == null || m_Images[i].AddImageQueryNullable == globalAddImageQuery)
00241                         {
00242                             builder.AppendFormat("<image id='{0}' src='{1}'/>", i + 1, escapedSrc);
00243                         }
00244                         else
00245                         {
00246                             builder.AppendFormat("<image addImageQuery='{0}' id='{1}' src='{2}'/>", m_Images[i].AddImageQuery.ToString().ToLowerInvariant(), i + 1, escapedSrc);
00247                         }
00248                     }
00249                 }
00250             }
00251
00252             for (int i = 0; i < m_TextFields.Length; i++)
00253             {
00254                 if (!String.IsNullOrWhiteSpace(m_TextFields[i].Text))
00255                 {
00256                     string escapedValue = Util.HttpEncode(m_TextFields[i].Text);
00257                     if (!String.IsNullOrWhiteSpace(m_TextFields[i].Lang) && !m_TextFields[i].Lang.Equals(globalLang))
00258                     {
00259                         string escapedLang = Util.HttpEncode(m_TextFields[i].Lang);
00260                         builder.AppendFormat("<text id='{0}' lang='{1}'>{2}</text>", i + 1, escapedLang, escapedValue);
00261                     }
00262                     else
00263                     {
00264                         builder.AppendFormat("<text id='{0}'>{1}</text>", i + 1, escapedValue);
00265                     }
00266                 }
00267             }
00268
00269             return builder.ToString();
00270         }
00271
00272         public string TemplateName { get { return m_TemplateName; } }
00273
00274         private bool m_StrictValidation = true;
00275         private NotificationContentImage[] m_Images;
00276         private INotificationContentText[] m_TextFields;
00277
00278         private string m_Lang;
00279         private string m_BaseUri;
00280         private string m_TemplateName;
00281         private bool? m_AddImageQueryNullable;
00282     }
00283
00284     /// <summary>
00285     /// Exception returned when invalid notification content is provided.
00286     /// </summary>
00287     internal sealed class NotificationContentValidationException : COMException
00288     {
00289         public NotificationContentValidationException(string message)
00290             : base(message, unchecked((int)0x80070057))
00291         {
00292         }
00293     }
00294 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Contact Member List

This is the complete list of members for Contact, including all inherited members.
CalculateContact(FXMVECTOR position, FXMVECTOR radiusIn, FXMVECTOR path) | Contact |
closingVelocity | Contact |
Contact(const Triangle &tri, size_t index, MeshID mesh) | Contact | [inline]
contactIsEdge | Contact |
contactPosition | Contact |
GetSurfaceNormal() const | Contact | [inline]
Invalidate() | Contact | [inline]
IsColliding() const | Contact | [inline]
meshID | Contact |
penetrationDistance | Contact |
plane | Contact |
Resolve(FXMVECTOR position, FXMVECTOR radius) | Contact |
triangle | Contact |
triIndex | Contact |
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Extruder::ExtrudingSink Member List

This is the complete list of members for Extruder::ExtrudingSink, including all inherited members.
Close() | Extruder::ExtrudingSink |
CreateExtrudingSink(float height, _In_ std::vector< SimpleVertex > *pVertices, _Outptr_ ExtrudingSink **ppExtrudingSink) | Extruder::ExtrudingSink | [static]
D2D1_FIGURE_BEGIN | Extruder::ExtrudingSink |
ExtrudingSink(float height, _In_ std::vector< SimpleVertex > *pVertices) | Extruder::ExtrudingSink | [private]
GetNormal(uint32 i) | Extruder::ExtrudingSink | [private]
m_figureVertices | Extruder::ExtrudingSink | [private]
m_height | Extruder::ExtrudingSink | [private]
m_lastPoint | Extruder::ExtrudingSink | [private]
m_ref | Extruder::ExtrudingSink | [private]
m_startPoint | Extruder::ExtrudingSink | [private]
m_vertices | Extruder::ExtrudingSink | [private]
Normalize(float2 pt) | Extruder::ExtrudingSink | [private]
pointsCount | Extruder::ExtrudingSink |
QueryInterface(REFIID riid, _Outptr_ void **object) override | Extruder::ExtrudingSink |
STDMETHOD_(void, AddBeziers)(const D2D1_BEZIER_SEGMENT * | Extruder::ExtrudingSink |
STDMETHOD_(void, AddLines)(const D2D1_POINT_2F *points | Extruder::ExtrudingSink |
STDMETHOD_(void, BeginFigure)(D2D1_POINT_2F startPoint | Extruder::ExtrudingSink |
STDMETHOD_(void, EndFigure)(D2D1_FIGURE_END) | Extruder::ExtrudingSink |
STDMETHOD_(void, SetFillMode)(D2D1_FILL_MODE) | Extruder::ExtrudingSink |
STDMETHOD_(void, SetSegmentFlags)(D2D1_PATH_SEGMENT) | Extruder::ExtrudingSink |
STDMETHOD_(void, AddTriangles)(const D2D1_TRIANGLE *triangles | Extruder::ExtrudingSink |
STDMETHOD_(ULONG, AddRef)() override | Extruder::ExtrudingSink |
STDMETHOD_(ULONG, Release)() override | Extruder::ExtrudingSink |
trianglesCount | Extruder::ExtrudingSink |
UINT | Extruder::ExtrudingSink |
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML high contrast style/C++/pch.cpp Source File

  • XAML high contrast style

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput5.xaml.cpp Source File

  • Toast notifications
  • C#,C++

ScenarioOutput5.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.cpp
00010 // Implementation of the Scenario1Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput5.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace ToastsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput5::ScenarioOutput5()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput5::~ScenarioOutput5()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput5::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044   // Get a pointer to our main page.
00045   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047   // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048   _frameLoadedToken = rootPage->InputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioOutput5::rootPage_InputFrameLoaded);
00049 }
00050
00051 void ScenarioOutput5::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00054 }
00055
00056 #pragma endregion
00057
00058 #pragma region Use this code if you need access to elements in the input frame - otherwise delete
00059 void ScenarioOutput5::rootPage_InputFrameLoaded(Object^ sender, Object^ e)
00060 {
00061     // Get a pointer to the content within the OutputFrame.
00062     Page^ inputFrame = dynamic_cast<Page^>(rootPage->InputFrame->Content);
00063
00064     // Go find the elements that we need for this scenario
00065     // ex: flipView1 = dynamic_cast<FlipView^>(inputFrame->FindName("FlipView1"));
00066 }
00067
00068 #pragma endregion
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/UserPreferences.xaml.cpp Source File

  • Globalization preferences

UserPreferences.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // UserPreferences.xaml.cpp
00013 // Implementation of the UserPreferences class
00014 //
00015
00016 #include "pch.h"
00017 #include "UserPreferences.xaml.h"
00018 #include "Utilities.h"
00019
00020 using namespace SDKSample::GlobalizationPreferencesSample;
00021
00022 using namespace Platform;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::Foundation::Collections;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028 using namespace Windows::System::UserProfile;
00029 using namespace Windows::Globalization;
00030
00031 UserPreferences::UserPreferences()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void UserPreferences::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046 }
00047
00048 void UserPreferences::Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00049 {
00050     // This scenario uses the Windows.System.UserProfile.GlobalizationPreferences class to
00051     // obtain the user's globalization preferences.
00052
00053     // Generate the list of languages
00054
00055
00056     // Generate the results by obtaining the user preferences.
00057     String^ results =
00058         "Languages: "                + Utilities::VectorViewToString(GlobalizationPreferences::Languages) + "\n" +
00059     "Home Region: "              + GlobalizationPreferences::HomeGeographicRegion + "\n" +
00060     "Calendar System: "          + Utilities::VectorViewToString(GlobalizationPreferences::Calendars) + "\n"+
00061     "Clock: "                    + Utilities::VectorViewToString(GlobalizationPreferences::Clocks) + "\n" +
00062         "First Day of the Week: "    + ((int)GlobalizationPreferences::WeekStartsOn).ToString();
00063
00064     // Display the results
00065     rootPage->NotifyUser(results, NotifyType::StatusMessage);
00066 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/PersistentState.cpp Source File

  • DirectX 3D shooting game

PersistentState.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "PersistentState.h"
00010 #include "DirectXSample.h"
00011
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::Foundation;
00014 using namespace Windows::Foundation::Collections;
00015 using namespace Windows::Storage;
00016 using namespace DirectX;
00017
00018 void PersistentState::Initialize(
00019     _In_ IPropertySet^ settingsValues,
00020     _In_ Platform::String^ key
00021     )
00022 {
00023     m_settingsValues = settingsValues;
00024     m_keyName = key;
00025 }
00026
00027 void PersistentState::SaveBool(Platform::String^ key, bool value)
00028 {
00029     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00030     if (m_settingsValues->HasKey(fullKey))
00031     {
00032         m_settingsValues->Remove(fullKey);
00033     }
00034     m_settingsValues->Insert(fullKey, PropertyValue::CreateInt32(value ? 1 : 0));
00035 }
00036
00037 void PersistentState::SaveInt32(Platform::String^ key, int value)
00038 {
00039     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00040     if (m_settingsValues->HasKey(fullKey))
00041     {
00042         m_settingsValues->Remove(fullKey);
00043     }
00044     m_settingsValues->Insert(fullKey, PropertyValue::CreateInt32(value));
00045 }
00046
00047 void PersistentState::SaveSingle(Platform::String^ key, float value)
00048 {
00049     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00050     if (m_settingsValues->HasKey(fullKey))
00051     {
00052         m_settingsValues->Remove(fullKey);
00053     }
00054     m_settingsValues->Insert(fullKey, PropertyValue::CreateSingle(value));
00055 }
00056
00057 void PersistentState::SaveXMFLOAT3(Platform::String^ key, DirectX::XMFLOAT3 value)
00058 {
00059     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00060     if (m_settingsValues->HasKey(fullKey))
00061     {
00062         m_settingsValues->Remove(fullKey);
00063     }
00064     Platform::Array<float>^ array3 = ref new Platform::Array<float>(3);
00065     array3[0] = value.x;
00066     array3[1] = value.y;
00067     array3[2] = value.z;
00068     m_settingsValues->Insert(fullKey, PropertyValue::CreateSingleArray(array3));
00069 }
00070
00071 void PersistentState::SaveString(Platform::String^ key, Platform::String^ string)
00072 {
00073     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00074     if (m_settingsValues->HasKey(fullKey))
00075     {
00076         m_settingsValues->Remove(fullKey);
00077     }
00078     m_settingsValues->Insert(fullKey, PropertyValue::CreateString(string));
00079 }
00080
00081 bool PersistentState::LoadBool(Platform::String^ key, bool defaultValue)
00082 {
00083     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00084     if (m_settingsValues->HasKey(fullKey))
00085     {
00086         int state = safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetInt32();
00087         return state ? true : false;
00088     }
00089     return defaultValue;
00090 }
00091
00092 int PersistentState::LoadInt32(Platform::String^ key, int defaultValue)
00093 {
00094     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00095     if (m_settingsValues->HasKey(fullKey))
00096     {
00097         return safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetInt32();
00098     }
00099     return defaultValue;
00100 }
00101
00102 float PersistentState::LoadSingle(Platform::String^ key, float defaultValue)
00103 {
00104     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00105     if (m_settingsValues->HasKey(fullKey))
00106     {
00107         return safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetSingle();
00108     }
00109     return defaultValue;
00110 }
00111
00112 XMFLOAT3 PersistentState::LoadXMFLOAT3(Platform::String^ key, DirectX::XMFLOAT3 defaultValue)
00113 {
00114     XMFLOAT3 value;
00115     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00116     if (m_settingsValues->HasKey(fullKey))
00117     {
00118         Platform::Array<float>^ array3;
00119         safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetSingleArray(&array3);
00120         value.x = array3[0];
00121         value.y = array3[1];
00122         value.z = array3[2];
00123         return value;
00124     }
00125     return defaultValue;
00126 }
00127
00128 Platform::String^ PersistentState::LoadString(Platform::String^ key, Platform::String^ defaultValue)
00129 {
00130     Platform::String^ fullKey = Platform::String::Concat(m_keyName, key);
00131     if (m_settingsValues->HasKey(fullKey))
00132     {
00133         return safe_cast<IPropertyValue^>(m_settingsValues->Lookup(fullKey))->GetString();
00134     }
00135     return defaultValue;
00136 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Physics Member List

This is the complete list of members for Physics, including all inherited members.
ApplyForces() | Physics | [private]
CalculateCurrentRoomSize() | Physics | [private]
DebugReset() | Physics | [inline]
FindInitialCollisions(float deltaT) | Physics | [private]
GetAcceleration() const | Physics | [inline]
GetCollisionEngine() | Physics | [inline]
GetCollisionInfo() const | Physics | [inline]
GetPosition() const | Physics | [inline]
GetPreviousPosition() | Physics | [inline]
GetRadius() const | Physics | [inline]
GetRoomDimensions(float *wallDistances, int size) | Physics | [inline]
GetRoomSize() | Physics | [inline]
GetVelocity() const | Physics | [inline]
HandleCollisions(float deltaT) | Physics | [private]
IntegrateSimulation(float deltaT) | Physics | [private]
IsMoving() const | Physics | [inline]
m_acceleration | Physics | [private]
m_accumulatedTime | Physics | [private]
m_collision | Physics | [private]
m_currentRoomSize | Physics | [private]
m_gravity | Physics | [private]
m_maxCollisionSpeed | Physics | [private]
m_maxRollingSpeed | Physics | [private]
m_position | Physics | [private]
m_previousPosition | Physics | [private]
m_radius | Physics | [private]
m_velDueToAccel | Physics | [private]
m_velocity | Physics | [private]
m_wallDistances | Physics | [private]
Physics() | Physics |
SetCollision(Collision *collision) | Physics | [inline]
SetGravity(const XMFLOAT3 &gravityUnitNormal) | Physics | [inline]
SetPosition(const XMFLOAT3 &position) | Physics | [inline]
SetRadius(float radius) | Physics | [inline]
SetVelocity(const XMFLOAT3 &velocity) | Physics | [inline]
UpdatePhysicsSimulation(float deltaT) | Physics |
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/SampleOverlay.cpp Source File

  • Direct3D resource loading

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/C++,JavaScript/cpp/pch.cpp Source File

  • DirectWrite font enumeration
  • C++,JavaScript
  • cpp

pch.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // pch.cpp
00003 // Include the standard header and generate the precompiled header.
00004 //
00005
00006 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network status background/C++/NetworkStatusApp/MainPage.xaml.h Source File

  • Network status background
  • NetworkStatusApp

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/SignatureFlyout.xaml.h Source File

  • DirectX postcard app

SignatureFlyout.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "SignatureFlyout.g.h"
00011
00012 namespace Postcard
00013 {
00014     public delegate void SignatureButtonClickedHandler(void);
00015
00016     [Windows::Foundation::Metadata::WebHostHidden]
00017     public ref class SignatureFlyout sealed
00018     {
00019     public:
00020         SignatureFlyout();
00021
00022         event SignatureButtonClickedHandler^ SignClicked;
00023         event SignatureButtonClickedHandler^ EraseClicked;
00024
00025     private:
00026         void SignButtonCicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00027         void EraseButtonClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00028
00029         void Hide();
00030     };
00031 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/App.xaml.cpp Source File

  • Number formatting and parsing

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/Scenario2.xaml.h Source File

  • SimpleOrientationSensor

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace SimpleOrientationSensorCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         private:
00039             MainPage^ rootPage;
00040             Windows::Devices::Sensors::SimpleOrientationSensor^ sensor;
00041
00042             void DisplayOrientation(Windows::Devices::Sensors::SimpleOrientation orientation);
00043             void ScenarioGet(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044         };
00045     }
00046 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ViewModelBase.h Source File

  • Hilo C++
  • Hilo

ViewModelBase.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008 #include "Common\BindableBase.h"
00009 #include "PageType.h"
00010
00011 namespace Hilo
00012 {
00013     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how view model classes interact
00014     // with view classes (pages) and model classes (the state and operations of business objects).
00015
00016     class ExceptionPolicy;
00017
00018     public delegate void NavigateEventHandler();
00019     public delegate void PageNavigateEventHandler(PageType page, Platform::Object^ parameter);
00020
00021     // The ViewModelBase class contains the common presentation logic used by all view models in Hilo.
00022     [Windows::Foundation::Metadata::WebHostHidden]
00023     public ref class ViewModelBase : public Common::BindableBase
00024     {
00025     internal:
00026         ViewModelBase(std::shared_ptr<ExceptionPolicy> exceptionPolicy);
00027
00028         event NavigateEventHandler^ NavigateBack;
00029         event NavigateEventHandler^ NavigateHome;
00030         event PageNavigateEventHandler^ NavigateToPage;
00031
00032         virtual void LoadState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ stateMap);
00033         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ stateMap);
00034         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e);
00035         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e);
00036
00037     public:
00038         property bool IsAppBarEnabled { bool get(); void set(bool value); }
00039         property bool IsAppBarOpen { bool get(); void set(bool value); }
00040         property bool IsAppBarSticky { bool get(); void set(bool value); }
00041
00042     protected private:
00043         virtual void GoBack();
00044         virtual void GoHome();
00045         virtual void GoToPage(PageType page, Platform::Object^ parameter);
00046
00047         bool m_isAppBarEnabled;
00048         bool m_isAppBarOpen;
00049         bool m_isAppBarSticky;
00050
00051         std::shared_ptr<ExceptionPolicy> m_exceptionPolicy;
00052     };
00053 }
00054
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/App.xaml.h Source File

  • App tiles and badges
  • C#,C++

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/Constants.h Source File

  • Input Touch keyboard text input

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"TouchKeyboardTextInput");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/MainPage.xaml.h Source File

  • XAML two-dimensional transforms

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/DisplayCalendarStatistics.xaml.h Source File

  • Calendar details and math

DisplayCalendarStatistics.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DisplayCalendarStatistics.xaml.h
00013 // Declaration of the DisplayCalendarStatistics class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "DisplayCalendarStatistics.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace CalendarSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class DisplayCalendarStatistics sealed
00031         {
00032         public:
00033             DisplayCalendarStatistics();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/pch.cpp Source File

  • Push and periodic notifications client-side

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: ControlChannelTrigger XMLHTTPRequest/C++/Background/Background.h Source File

  • ControlChannelTrigger XMLHTTPRequest
  • Background

Background.h

Go to the documentation of this file.
00001 ﻿#include "pch.h"
00002 using namespace Platform;
00003 using namespace Windows::ApplicationModel::Background;
00004
00005 namespace Background
00006 {
00007     [Windows::Foundation::Metadata::WebHostHidden]
00008     public ref class NetworkChangeTask sealed :IBackgroundTask
00009     {
00010     public:
00011         virtual void Run(IBackgroundTaskInstance^ taskInstance);
00012     };
00013
00014     [Windows::Foundation::Metadata::WebHostHidden]
00015     public ref class KATask sealed : IBackgroundTask
00016     {
00017     public:
00018         virtual void Run(IBackgroundTaskInstance^ taskInstance);
00019     };
00020
00021     [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class PushNotifyTask sealed : IBackgroundTask
00023     {
00024     public:
00025         virtual void Run(IBackgroundTaskInstance^ taskInstance);
00026         void InvokeSimpleToast(String^ messageReceived);
00027     };
00028 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKTemplate::DeviceAppPage Member List

This is the complete list of members for SDKTemplate::DeviceAppPage, including all inherited members.
DeviceAppPage() | SDKTemplate::DeviceAppPage | [inline]
Initialize(CameraSettingsActivatedEventArgs args) | SDKTemplate::DeviceAppPage | [inline]
lcWrapper | SDKTemplate::DeviceAppPage | [private]
OnBrtAutoToggleChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnBrtSliderValueChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnCrtAutoToggleChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnCrtSliderValueChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnEffectEnabledToggleChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnEffectSliderValueChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnExpAutoToggleChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnExpSliderValueChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnFocusAutoToggleChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
OnFocusSliderValueChanged(object sender, RoutedEventArgs e) | SDKTemplate::DeviceAppPage | [inline, protected]
videoDevController | SDKTemplate::DeviceAppPage | [private]
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Scenario3.xaml.h Source File

  • XAML text editing

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace TextEditing
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario3 sealed
00031         {
00032         public:
00033             Scenario3();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicCamera.h Source File

  • DXGI swap chain rotation

BasicCamera.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple camera class.
00011 ref class BasicCamera
00012 {
00013
00014 private:
00015     float3 m_position;      // the position of the camera
00016     float3 m_direction;     // the unit vector of the viewing direction
00017     float4x4 m_view;        // view matrix
00018     float4x4 m_projection;  // projection matrix
00019
00020 internal:
00021     void GetViewMatrix(_Out_ float4x4 *viewMatrix);
00022     void GetProjectionMatrix(_Out_ float4x4 *projectionMatrix);
00023
00024     // this method updates the view matrix based on new position and focus coordinates
00025     void SetViewParameters(
00026         _In_ float3 eyePosition,    // the position of the camera
00027         _In_ float3 lookPosition,   // the point the camera should look at
00028         _In_ float3 up              // the durection vector for up
00029         );
00030
00031     // this method updates the projection matrix based on new parameters
00032     void SetProjectionParameters(
00033         _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00034         _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00035         _In_ float nearPlane,           // depth to map to 0
00036         _In_ float farPlane             // depth to map to 1
00037         );
00038 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Common/LinkList.h Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Common

LinkList.h

Go to the documentation of this file.
00001 //-----------------------------------------------------------------------------
00002 // File: Linklist.h
00003 // Desc: Linked list class.
00004 //
00005 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00006 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00007 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00008 // PARTICULAR PURPOSE.
00009 //
00010 //  Copyright (C) Microsoft Corporation. All rights reserved.
00011 //-----------------------------------------------------------------------------
00012
00013 #pragma once
00014
00015 // Notes:
00016 //
00017 // The List class template implements a simple double-linked list.
00018 // It uses STL's copy semantics.
00019
00020 // There are two versions of the Clear() method:
00021 //  Clear(void) clears the list w/out cleaning up the object.
00022 //  Clear(FN fn) takes a functor object that releases the objects, if they need cleanup.
00023
00024 // The List class supports enumeration. Example of usage:
00025 //
00026 // List<T>::POSIITON pos = list.GetFrontPosition();
00027 // while (pos != list.GetEndPosition())
00028 // {
00029 //     T item;
00030 //     hr = list.GetItemPos(&item);
00031 //     pos = list.Next(pos);
00032 // }
00033
00034 // The ComPtrList class template derives from List<> and implements a list of COM pointers.
00035
00036 template <class T>
00037 struct NoOp
00038 {
00039     void operator()(T& t)
00040     {
00041     }
00042 };
00043
00044 template <class T>
00045 class List
00046 {
00047 protected:
00048
00049     // Nodes in the linked list
00050     struct Node
00051     {
00052         Node *prev;
00053         Node *next;
00054         T    item;
00055
00056         Node() : prev(nullptr), next(nullptr)
00057         {
00058         }
00059
00060         Node(T item) : prev(nullptr), next(nullptr)
00061         {
00062             this->item = item;
00063         }
00064
00065         T Item() const { return item; }
00066     };
00067
00068 public:
00069
00070     // Object for enumerating the list.
00071     class POSITION
00072     {
00073         friend class List<T>;
00074
00075     public:
00076         POSITION() : pNode(nullptr)
00077         {
00078         }
00079
00080         bool operator==(const POSITION &p) const
00081         {
00082             return pNode == p.pNode;
00083         }
00084
00085         bool operator!=(const POSITION &p) const
00086         {
00087             return pNode != p.pNode;
00088         }
00089
00090     private:
00091         const Node *pNode;
00092
00093         POSITION(Node *p) : pNode(p)
00094         {
00095         }
00096     };
00097
00098 protected:
00099     Node    m_anchor;  // Anchor node for the linked list.
00100     DWORD   m_count;   // Number of items in the list.
00101
00102     Node* Front() const
00103     {
00104         return m_anchor.next;
00105     }
00106
00107     Node* Back() const
00108     {
00109         return m_anchor.prev;
00110     }
00111
00112     virtual HRESULT InsertAfter(T item, Node *pBefore)
00113     {
00114         if (pBefore == nullptr)
00115         {
00116             return E_POINTER;
00117         }
00118
00119         Node *pNode = new Node(item);
00120         if (pNode == nullptr)
00121         {
00122             return E_OUTOFMEMORY;
00123         }
00124
00125         Node *pAfter = pBefore->next;
00126
00127         pBefore->next = pNode;
00128         pAfter->prev = pNode;
00129
00130         pNode->prev = pBefore;
00131         pNode->next = pAfter;
00132
00133         m_count++;
00134
00135         return S_OK;
00136     }
00137
00138     virtual HRESULT GetItem(const Node *pNode, T* ppItem)
00139     {
00140         if (pNode == nullptr || ppItem == nullptr)
00141         {
00142             return E_POINTER;
00143         }
00144
00145         *ppItem = pNode->item;
00146         return S_OK;
00147     }
00148
00149     // RemoveItem:
00150     // Removes a node and optionally returns the item.
00151     // ppItem can be nullptr.
00152     virtual HRESULT RemoveItem(Node *pNode, T *ppItem)
00153     {
00154         if (pNode == nullptr)
00155         {
00156             return E_POINTER;
00157         }
00158
00159         assert(pNode != &m_anchor); // We should never try to remove the anchor node.
00160         if (pNode == &m_anchor)
00161         {
00162             return E_INVALIDARG;
00163         }
00164
00165
00166         T item;
00167
00168         // The next node's previous is this node's previous.
00169         pNode->next->prev = pNode->prev;
00170
00171         // The previous node's next is this node's next.
00172         pNode->prev->next = pNode->next;
00173
00174         item = pNode->item;
00175         delete pNode;
00176
00177         m_count--;
00178
00179         if (ppItem)
00180         {
00181             *ppItem = item;
00182         }
00183
00184         return S_OK;
00185     }
00186
00187 public:
00188
00189     List()
00190     {
00191         m_anchor.next = &m_anchor;
00192         m_anchor.prev = &m_anchor;
00193
00194         m_count = 0;
00195     }
00196
00197     virtual ~List()
00198     {
00199         Clear();
00200     }
00201
00202     // Insertion functions
00203     HRESULT InsertBack(T item)
00204     {
00205         return InsertAfter(item, m_anchor.prev);
00206     }
00207
00208
00209     HRESULT InsertFront(T item)
00210     {
00211         return InsertAfter(item, &m_anchor);
00212     }
00213
00214     HRESULT InsertPos(POSITION pos, T item)
00215     {
00216         if (pos.pNode == nullptr)
00217         {
00218             return InsertBack(item);
00219         }
00220
00221         return InsertAfter(item, pos.pNode->prev);
00222     }
00223
00224     // RemoveBack: Removes the tail of the list and returns the value.
00225     // ppItem can be nullptr if you don't want the item back. (But the method does not release the item.)
00226     HRESULT RemoveBack(T *ppItem)
00227     {
00228         if (IsEmpty())
00229         {
00230             return E_FAIL;
00231         }
00232         else
00233         {
00234             return RemoveItem(Back(), ppItem);
00235         }
00236     }
00237
00238     // RemoveFront: Removes the head of the list and returns the value.
00239     // ppItem can be nullptr if you don't want the item back. (But the method does not release the item.)
00240     HRESULT RemoveFront(T *ppItem)
00241     {
00242         if (IsEmpty())
00243         {
00244             return E_FAIL;
00245         }
00246         else
00247         {
00248             return RemoveItem(Front(), ppItem);
00249         }
00250     }
00251
00252     // GetBack: Gets the tail item.
00253     HRESULT GetBack(T *ppItem)
00254     {
00255         if (IsEmpty())
00256         {
00257             return E_FAIL;
00258         }
00259         else
00260         {
00261             return GetItem(Back(), ppItem);
00262         }
00263     }
00264
00265     // GetFront: Gets the front item.
00266     HRESULT GetFront(T *ppItem)
00267     {
00268         if (IsEmpty())
00269         {
00270             return E_FAIL;
00271         }
00272         else
00273         {
00274             return GetItem(Front(), ppItem);
00275         }
00276     }
00277
00278
00279     // GetCount: Returns the number of items in the list.
00280     DWORD GetCount() const { return m_count; }
00281
00282     bool IsEmpty() const
00283     {
00284         return (GetCount() == 0);
00285     }
00286
00287     // Clear: Takes a functor object whose operator()
00288     // frees the object on the list.
00289     template <class FN>
00290     void Clear(FN& clear_fn)
00291     {
00292         Node *n = m_anchor.next;
00293
00294         // Delete the nodes
00295         while (n != &m_anchor)
00296         {
00297             clear_fn(n->item);
00298
00299             Node *tmp = n->next;
00300             delete n;
00301             n = tmp;
00302         }
00303
00304         // Reset the anchor to point at itself
00305         m_anchor.next = &m_anchor;
00306         m_anchor.prev = &m_anchor;
00307
00308         m_count = 0;
00309     }
00310
00311     // Clear: Clears the list. (Does not delete or release the list items.)
00312     virtual void Clear()
00313     {
00314         NoOp<T> clearOp;
00315         Clear<>(clearOp);
00316     }
00317
00318
00319     // Enumerator functions
00320
00321     POSITION FrontPosition()
00322     {
00323         if (IsEmpty())
00324         {
00325             return POSITION(nullptr);
00326         }
00327         else
00328         {
00329             return POSITION(Front());
00330         }
00331     }
00332
00333     POSITION EndPosition() const
00334     {
00335         return POSITION();
00336     }
00337
00338     HRESULT GetItemPos(POSITION pos, T *ppItem)
00339     {
00340         if (pos.pNode)
00341         {
00342             return GetItem(pos.pNode, ppItem);
00343         }
00344         else
00345         {
00346             return E_FAIL;
00347         }
00348     }
00349
00350     POSITION Next(const POSITION pos)
00351     {
00352         if (pos.pNode && (pos.pNode->next != &m_anchor))
00353         {
00354             return POSITION(pos.pNode->next);
00355         }
00356         else
00357         {
00358             return POSITION(nullptr);
00359         }
00360     }
00361
00362     // Remove an item at a position.
00363     // The item is returns in ppItem, unless ppItem is nullptr.
00364     // NOTE: This method invalidates the POSITION object.
00365     HRESULT Remove(POSITION& pos, T *ppItem)
00366     {
00367         if (pos.pNode)
00368         {
00369             // Remove const-ness temporarily...
00370             Node *pNode = const_cast<Node*>(pos.pNode);
00371
00372             pos = POSITION();
00373
00374             return RemoveItem(pNode, ppItem);
00375         }
00376         else
00377         {
00378             return E_INVALIDARG;
00379         }
00380     }
00381
00382 };
00383
00384
00385
00386 // Typical functors for Clear method.
00387
00388 // ComAutoRelease: Releases COM pointers.
00389 // MemDelete: Deletes pointers to new'd memory.
00390
00391 class ComAutoRelease
00392 {
00393 public:
00394     void operator()(IUnknown *p)
00395     {
00396         if (p)
00397         {
00398             p->Release();
00399         }
00400     }
00401 };
00402
00403 class MemDelete
00404 {
00405 public:
00406     void operator()(void *p)
00407     {
00408         if (p)
00409         {
00410             delete p;
00411         }
00412     }
00413 };
00414
00415
00416 // ComPtrList class
00417 // Derived class that makes it safer to store COM pointers in the List<> class.
00418 // It automatically AddRef's the pointers that are inserted onto the list
00419 // (unless the insertion method fails).
00420 //
00421 // T must be a COM interface type.
00422 // example: ComPtrList<IUnknown>
00423 //
00424 // NULLABLE: If true, client can insert nullptr pointers. This means GetItem can
00425 // succeed but return a nullptr pointer. By default, the list does not allow nullptr
00426 // pointers.
00427
00428 template <class T, bool NULLABLE = FALSE>
00429 class ComPtrList : public List<T*>
00430 {
00431 public:
00432
00433     typedef T* Ptr;
00434
00435     void Clear()
00436     {
00437         ComAutoRelease car;
00438         List<Ptr>::Clear(car);
00439     }
00440
00441     ~ComPtrList()
00442     {
00443         Clear();
00444     }
00445
00446 protected:
00447     HRESULT InsertAfter(Ptr item, Node *pBefore)
00448     {
00449         // Do not allow nullptr item pointers unless NULLABLE is true.
00450         if (item == nullptr && !NULLABLE)
00451         {
00452             return E_POINTER;
00453         }
00454
00455         if (item)
00456         {
00457             item->AddRef();
00458         }
00459
00460         HRESULT hr = List<Ptr>::InsertAfter(item, pBefore);
00461         if (FAILED(hr) && item != nullptr)
00462         {
00463             item->Release();
00464         }
00465         return hr;
00466     }
00467
00468     HRESULT GetItem(const Node *pNode, Ptr* ppItem)
00469     {
00470         Ptr pItem = nullptr;
00471
00472         // The base class gives us the pointer without AddRef'ing it.
00473         // If we return the pointer to the caller, we must AddRef().
00474         HRESULT hr = List<Ptr>::GetItem(pNode, &pItem);
00475         if (SUCCEEDED(hr))
00476         {
00477             assert(pItem || NULLABLE);
00478             if (pItem)
00479             {
00480                 *ppItem = pItem;
00481                 (*ppItem)->AddRef();
00482             }
00483         }
00484         return hr;
00485     }
00486
00487     HRESULT RemoveItem(Node *pNode, Ptr *ppItem)
00488     {
00489         // ppItem can be nullptr, but we need to get the
00490         // item so that we can release it.
00491
00492         // If ppItem is not nullptr, we will AddRef it on the way out.
00493
00494         Ptr pItem = nullptr;
00495
00496         HRESULT hr = List<Ptr>::RemoveItem(pNode, &pItem);
00497
00498         if (SUCCEEDED(hr))
00499         {
00500             assert(pItem || NULLABLE);
00501             if (ppItem && pItem)
00502             {
00503                 *ppItem = pItem;
00504                 (*ppItem)->AddRef();
00505             }
00506
00507             if (pItem)
00508             {
00509                 pItem->Release();
00510                 pItem = nullptr;
00511             }
00512         }
00513
00514         return hr;
00515     }
00516 };
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Constants.h Source File

  • StreamSocket

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace StreamSocketSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"StreamSocket");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXApp.cpp Source File

  • DXGI swap chain rotation

DirectXApp.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXApp.h"
00010 #include "BasicTimer.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::UI::Input;
00017 using namespace Windows::System;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Graphics::Display;
00020
00021 DirectXApp::DirectXApp() :
00022     m_windowClosed(false),
00023     m_windowVisible(true)
00024 {
00025 }
00026
00027 void DirectXApp::Initialize(
00028     _In_ CoreApplicationView^ applicationView
00029     )
00030 {
00031     applicationView->Activated +=
00032         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DirectXApp::OnActivated);
00033
00034     m_renderer = ref new DxgiRotation();
00035 }
00036
00037 void DirectXApp::SetWindow(
00038     _In_ CoreWindow^ window
00039     )
00040 {
00041     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00042
00043     PointerVisualizationSettings^ visualizationSettings = PointerVisualizationSettings::GetForCurrentView();
00044     visualizationSettings->IsContactFeedbackEnabled = false;
00045     visualizationSettings->IsBarrelButtonFeedbackEnabled = false;
00046
00047     window->SizeChanged +=
00048         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DirectXApp::OnWindowSizeChanged);
00049
00050     window->VisibilityChanged +=
00051         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &DirectXApp::OnVisibilityChanged);
00052
00053     window->Closed +=
00054         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &DirectXApp::OnWindowClosed);
00055
00056     DisplayProperties::LogicalDpiChanged +=
00057         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnLogicalDpiChanged);
00058
00059     DisplayProperties::OrientationChanged +=
00060         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnOrientationChanged);
00061
00062     m_renderer->Initialize(window, DisplayProperties::LogicalDpi);
00063 }
00064
00065 void DirectXApp::Load(
00066     _In_ Platform::String^ entryPoint
00067     )
00068 {
00069 }
00070
00071 void DirectXApp::Run()
00072 {
00073     BasicTimer^ timer = ref new BasicTimer();
00074
00075     while (!m_windowClosed)
00076     {
00077         if (m_windowVisible)
00078         {
00079             timer->Update();
00080             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00081             m_renderer->Update(timer->Total, timer->Delta);
00082             m_renderer->Render();
00083             m_renderer->Present(); // This call is synchronized to the display frame rate.
00084         }
00085         else
00086         {
00087             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00088         }
00089     }
00090 }
00091
00092 void DirectXApp::Uninitialize()
00093 {
00094 }
00095
00096 void DirectXApp::OnWindowSizeChanged(
00097     _In_ CoreWindow^ sender,
00098     _In_ WindowSizeChangedEventArgs^ args
00099     )
00100 {
00101     m_renderer->UpdateForWindowSizeChange();
00102 }
00103
00104 void DirectXApp::OnVisibilityChanged(
00105     _In_ CoreWindow^ sender,
00106     _In_ VisibilityChangedEventArgs^ args
00107     )
00108 {
00109     m_windowVisible = args->Visible;
00110 }
00111
00112 void DirectXApp::OnWindowClosed(
00113     _In_ CoreWindow^ sender,
00114     _In_ CoreWindowEventArgs^ args
00115     )
00116 {
00117     m_windowClosed = true;
00118 }
00119
00120 void DirectXApp::OnLogicalDpiChanged(
00121     _In_ Platform::Object^ sender
00122     )
00123 {
00124     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00125 }
00126
00127 void DirectXApp::OnOrientationChanged(
00128     _In_ Platform::Object^ sender
00129     )
00130 {
00131     m_renderer->UpdateForWindowSizeChange();
00132 }
00133
00134 void DirectXApp::OnActivated(
00135     _In_ CoreApplicationView^ applicationView,
00136     _In_ IActivatedEventArgs^ args
00137     )
00138 {
00139     applicationView->CoreWindow->Activate();
00140 }
00141
00142 IFrameworkView^ DirectXAppSource::CreateView()
00143 {
00144     return ref new DirectXApp();
00145 }
00146
00147 [Platform::MTAThread]
00148 int main(Platform::Array<Platform::String^>^)
00149 {
00150     auto directXAppSource = ref new DirectXAppSource();
00151     CoreApplication::Run(directXAppSource);
00152     return 0;
00153 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/TargetTexture.cpp Source File

  • DirectX 3D shooting game

TargetTexture.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "TargetTexture.h"
00010 #include "DirectXSample.h"
00011
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::Graphics::Display;
00014
00015 TargetTexture::TargetTexture(
00016     _In_ ID3D11Device1* d3dDevice,
00017     _In_ ID2D1Factory1* d2dFactory,
00018     _In_ IDWriteFactory1* dwriteFactory,
00019     _In_ ID2D1DeviceContext* d2dContext
00020     )
00021 {
00022     m_d3dDevice = d3dDevice;
00023     m_d2dFactory = d2dFactory;
00024     m_dwriteFactory = dwriteFactory;
00025     m_d2dContext = d2dContext;
00026
00027     DX::ThrowIfFailed(
00028         m_d2dContext->CreateSolidColorBrush(
00029             D2D1::ColorF(D2D1::ColorF::Red, 1.f),
00030             &m_redBrush
00031             )
00032         );
00033
00034     DX::ThrowIfFailed(
00035         m_d2dContext->CreateSolidColorBrush(
00036             D2D1::ColorF(D2D1::ColorF::CornflowerBlue, 1.0f),
00037             &m_blueBrush
00038             )
00039         );
00040
00041     DX::ThrowIfFailed(
00042         m_d2dContext->CreateSolidColorBrush(
00043             D2D1::ColorF(D2D1::ColorF::Green, 1.f),
00044             &m_greenBrush
00045             )
00046         );
00047
00048     DX::ThrowIfFailed(
00049         m_d2dContext->CreateSolidColorBrush(
00050             D2D1::ColorF(D2D1::ColorF::White, 1.f),
00051             &m_whiteBrush
00052             )
00053         );
00054
00055     DX::ThrowIfFailed(
00056         m_d2dContext->CreateSolidColorBrush(
00057             D2D1::ColorF(D2D1::ColorF::Black, 1.f),
00058             &m_blackBrush
00059             )
00060         );
00061
00062     DX::ThrowIfFailed(
00063         m_d2dContext->CreateSolidColorBrush(
00064             D2D1::ColorF(D2D1::ColorF::Yellow, 1.f),
00065             &m_yellowBrush
00066             )
00067         );
00068
00069     DX::ThrowIfFailed(
00070         m_d2dContext->CreateSolidColorBrush(
00071             D2D1::ColorF(D2D1::ColorF::White, 0.0f),
00072             &m_clearBrush
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         m_d2dFactory->CreateEllipseGeometry(
00078             D2D1::Ellipse(
00079                 D2D1::Point2F(256.0f, 256.0f),
00080                 50.0f,
00081                 50.0f
00082                 ),
00083             &m_circleGeometry1)
00084             );
00085
00086     DX::ThrowIfFailed(
00087         m_d2dFactory->CreateEllipseGeometry(
00088             D2D1::Ellipse(
00089                 D2D1::Point2F(256.0f, 256.0f),
00090                 100.0f,
00091                 100.0f
00092                 ),
00093             &m_circleGeometry2)
00094             );
00095
00096     DX::ThrowIfFailed(
00097         m_d2dFactory->CreateEllipseGeometry(
00098             D2D1::Ellipse(
00099                 D2D1::Point2F(256.0f, 256.0f),
00100                 150.0f,
00101                 150.0f
00102                 ),
00103             &m_circleGeometry3)
00104             );
00105
00106     DX::ThrowIfFailed(
00107         m_d2dFactory->CreateEllipseGeometry(
00108             D2D1::Ellipse(
00109                 D2D1::Point2F(256.0f, 256.0f),
00110                 200.0f,
00111                 200.0f
00112                 ),
00113             &m_circleGeometry4)
00114             );
00115
00116     DX::ThrowIfFailed(
00117         m_d2dFactory->CreateEllipseGeometry(
00118             D2D1::Ellipse(
00119                 D2D1::Point2F(256.0f, 256.0f),
00120                 250.0f,
00121                 250.0f
00122                 ),
00123             &m_circleGeometry5)
00124             );
00125
00126     DX::ThrowIfFailed(
00127         m_dwriteFactory->CreateTextFormat(
00128             L"Segoe UI",
00129             nullptr,
00130             DWRITE_FONT_WEIGHT_LIGHT,
00131             DWRITE_FONT_STYLE_NORMAL,
00132             DWRITE_FONT_STRETCH_NORMAL,
00133             425,        // fontsize
00134             L"en-US",   // locale
00135             &m_textFormat
00136             )
00137         );
00138
00139     // Center the text horizontally.
00140     DX::ThrowIfFailed(
00141         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00142         );
00143
00144     // Center the text vertically.
00145     DX::ThrowIfFailed(
00146         m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00147         );
00148 }
00149 //----------------------------------------------------------------------
00150 void TargetTexture::CreateTextureResourceView(
00151     _In_ Platform::String^ name,
00152     _Out_ ID3D11ShaderResourceView** textureResourceView
00153     )
00154 {
00155     // Allocate a offscreen D3D surface for D2D to render our 2D content into
00156     D3D11_TEXTURE2D_DESC texDesc;
00157     texDesc.ArraySize = 1;
00158     texDesc.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
00159     texDesc.CPUAccessFlags = 0;
00160     texDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00161     texDesc.Height = 512;
00162     texDesc.Width = 512;
00163     texDesc.MipLevels = 1;
00164     texDesc.MiscFlags = 0;
00165     texDesc.SampleDesc.Count = 1;
00166     texDesc.SampleDesc.Quality = 0;
00167     texDesc.Usage = D3D11_USAGE_DEFAULT;
00168
00169     ComPtr<ID3D11Texture2D> offscreenTexture;
00170     DX::ThrowIfFailed(
00171         m_d3dDevice->CreateTexture2D(&texDesc, nullptr, &offscreenTexture)
00172         );
00173
00174     // Convert the Direct2D texture into a Shader Resource View
00175     ComPtr<ID3D11ShaderResourceView> texture;
00176     DX::ThrowIfFailed(
00177         m_d3dDevice->CreateShaderResourceView(offscreenTexture.Get(), nullptr, &texture)
00178         );
00179 #if defined(_DEBUG)
00180     {
00181         char debugName[100];
00182         int l = sprintf_s(debugName, sizeof(debugName) / sizeof(debugName[0]), "Simple3DGame Target %ls", name->Data());
00183         DX::ThrowIfFailed(
00184             texture->SetPrivateData(WKPDID_D3DDebugObjectName, l, debugName)
00185             );
00186     }
00187 #endif
00188
00189     ComPtr<IDXGISurface> dxgiSurface;
00190     DX::ThrowIfFailed(
00191         offscreenTexture.As(&dxgiSurface)
00192         );
00193
00194     // Create a D2D render target which can draw into our offscreen D3D
00195     // surface. Given that we use a constant size for the texture, we
00196     // fix the DPI at 96.
00197
00198     D2D1_BITMAP_PROPERTIES1 properties;
00199     properties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
00200     properties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
00201     properties.dpiX = 96;
00202     properties.dpiY = 96;
00203     properties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
00204     properties.colorContext = nullptr;
00205
00206     ComPtr<ID2D1Bitmap1> renderTarget;
00207     DX::ThrowIfFailed(
00208         m_d2dContext->CreateBitmapFromDxgiSurface(
00209             dxgiSurface.Get(),
00210             &properties,
00211             &renderTarget
00212             )
00213         );
00214
00215     m_d2dContext->SetTarget(renderTarget.Get());
00216     float saveDpiX;
00217     float saveDpiY;
00218
00219     m_d2dContext->GetDpi(&saveDpiX, &saveDpiY);
00220     m_d2dContext->SetDpi(96.0f, 96.0f);
00221
00222     m_d2dContext->BeginDraw();
00223     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00224
00225     D2D1_SIZE_F renderTargetSize = renderTarget->GetSize();
00226
00227     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::White));
00228     m_d2dContext->FillGeometry(m_circleGeometry5.Get(), m_redBrush.Get());
00229     m_d2dContext->FillGeometry(m_circleGeometry4.Get(), m_blueBrush.Get());
00230     m_d2dContext->FillGeometry(m_circleGeometry3.Get(), m_greenBrush.Get());
00231     m_d2dContext->FillGeometry(m_circleGeometry2.Get(), m_yellowBrush.Get());
00232     m_d2dContext->FillGeometry(m_circleGeometry1.Get(), m_blackBrush.Get());
00233     m_d2dContext->DrawText(
00234         name->Data(),
00235         name->Length(),
00236         m_textFormat.Get(),
00237         D2D1::RectF(0, 0, renderTargetSize.width, renderTargetSize.height),
00238         m_whiteBrush.Get()
00239         );
00240
00241     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00242     // is lost. It will be handled during the next call to Present.
00243     HRESULT hr = m_d2dContext->EndDraw();
00244     if (hr != D2DERR_RECREATE_TARGET)
00245     {
00246         DX::ThrowIfFailed(hr);
00247     }
00248
00249     m_d2dContext->SetTarget(nullptr);
00250     m_d2dContext->SetDpi(saveDpiX, saveDpiY);
00251
00252     *textureResourceView = texture.Detach();
00253 }
00254 //----------------------------------------------------------------------
00255 void TargetTexture::CreateHitTextureResourceView(
00256     _In_ Platform::String^ name,
00257     _Out_ ID3D11ShaderResourceView** textureResourceView
00258     )
00259 {
00260     // Allocate a offscreen D3D surface for D2D to render our 2D content into
00261     D3D11_TEXTURE2D_DESC texDesc;
00262     texDesc.ArraySize = 1;
00263     texDesc.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
00264     texDesc.CPUAccessFlags = 0;
00265     texDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00266     texDesc.Height = 512;
00267     texDesc.Width = 512;
00268     texDesc.MipLevels = 1;
00269     texDesc.MiscFlags = 0;
00270     texDesc.SampleDesc.Count = 1;
00271     texDesc.SampleDesc.Quality = 0;
00272     texDesc.Usage = D3D11_USAGE_DEFAULT;
00273
00274     ComPtr<ID3D11Texture2D> offscreenTexture;
00275     DX::ThrowIfFailed(
00276         m_d3dDevice->CreateTexture2D(&texDesc, nullptr, &offscreenTexture)
00277         );
00278
00279     // Convert the Direct2D texture into a Shader Resource View
00280     ComPtr<ID3D11ShaderResourceView> texture;
00281     DX::ThrowIfFailed(
00282         m_d3dDevice->CreateShaderResourceView(offscreenTexture.Get(), nullptr, &texture)
00283         );
00284 #if defined(_DEBUG)
00285     {
00286         char debugName[100];
00287         int l = sprintf_s(debugName, sizeof(debugName) / sizeof(debugName[0]), "Simple3DGame HitTarget %ls", name->Data());
00288         DX::ThrowIfFailed(
00289             texture->SetPrivateData(WKPDID_D3DDebugObjectName, l, debugName)
00290             );
00291     }
00292 #endif
00293
00294     ComPtr<IDXGISurface> dxgiSurface;
00295     DX::ThrowIfFailed(
00296         offscreenTexture.As(&dxgiSurface)
00297         );
00298
00299     // Create a D2D render target which can draw into our offscreen D3D
00300     // surface. Given that we use a constant size for the texture, we
00301     // fix the DPI at 96.
00302
00303     D2D1_BITMAP_PROPERTIES1 properties;
00304     properties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
00305     properties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
00306     properties.dpiX = 96;
00307     properties.dpiY = 96;
00308     properties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
00309     properties.colorContext = nullptr;
00310
00311     ComPtr<ID2D1Bitmap1> renderTarget;
00312     DX::ThrowIfFailed(
00313         m_d2dContext->CreateBitmapFromDxgiSurface(
00314             dxgiSurface.Get(),
00315             &properties,
00316             &renderTarget
00317             )
00318         );
00319
00320     m_d2dContext->SetTarget(renderTarget.Get());
00321     float saveDpiX;
00322     float saveDpiY;
00323
00324     m_d2dContext->GetDpi(&saveDpiX, &saveDpiY);
00325     m_d2dContext->SetDpi(96.0f, 96.0f);
00326
00327     m_d2dContext->BeginDraw();
00328     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00329
00330     D2D1_SIZE_F renderTargetSize = renderTarget->GetSize();
00331
00332     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));
00333     m_d2dContext->FillGeometry(m_circleGeometry5.Get(), m_yellowBrush.Get());
00334     m_d2dContext->FillGeometry(m_circleGeometry4.Get(), m_greenBrush.Get());
00335     m_d2dContext->FillGeometry(m_circleGeometry3.Get(), m_blueBrush.Get());
00336     m_d2dContext->FillGeometry(m_circleGeometry2.Get(), m_redBrush.Get());
00337     m_d2dContext->FillGeometry(m_circleGeometry1.Get(), m_whiteBrush.Get());
00338     m_d2dContext->DrawText(
00339         name->Data(),
00340         name->Length(),
00341         m_textFormat.Get(),
00342         D2D1::RectF(0, 0, renderTargetSize.width, renderTargetSize.height),
00343         m_blackBrush.Get()
00344         );
00345
00346     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00347     // is lost. It will be handled during the next call to Present.
00348     HRESULT hr = m_d2dContext->EndDraw();
00349     if (hr != D2DERR_RECREATE_TARGET)
00350     {
00351         DX::ThrowIfFailed(hr);
00352     }
00353
00354     m_d2dContext->SetTarget(nullptr);
00355     m_d2dContext->SetDpi(saveDpiX, saveDpiY);
00356
00357     *textureResourceView = texture.Detach();
00358 }
00359 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage.xaml.cpp Source File

  • File picker contracts

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     LayoutRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     PageSizeChangedEventArgs^ args = ref new PageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     PageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160 }
00161
00162 /// <summary>
00163 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00164 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00165 /// and output sections into the respective UserControl on the main page.
00166 /// </summary>
00167 /// <param name="scenarioName"></param>
00168 void MainPage::LoadScenario(String^ scenarioName)
00169 {
00170     autoSizeInputSectionWhenSnapped = true;
00171
00172     // Load the ScenarioX.xaml file into the Frame.
00173     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00174     HiddenFrame->Navigate(scenarioType, this);
00175
00176     // Get the top element, the Page, so we can look up the elements
00177     // that represent the input and output sections of the ScenarioX file.
00178     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00179
00180     // Get each element.
00181     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00182     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00183
00184     if (input == nullptr)
00185     {
00186         // Malformed input section.
00187         NotifyUser("Cannot load scenario input section for " + scenarioName +
00188             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00189         return;
00190     }
00191
00192     if (output == nullptr)
00193     {
00194         // Malformed output section.
00195         NotifyUser("Cannot load scenario output section for " + scenarioName +
00196             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00197         return;
00198     }
00199
00200     // Find the LayoutRoot which parents the input and output sections in the main page.
00201     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00202
00203     if (panel != nullptr)
00204     {
00205         unsigned int index = 0;
00206         UIElementCollection^ collection = panel->Children;
00207
00208         // Get rid of the content that is currently in the intput and output sections.
00209         collection->IndexOf(input, &index);
00210         collection->RemoveAt(index);
00211
00212         collection->IndexOf(output, &index);
00213         collection->RemoveAt(index);
00214
00215         // Populate the input and output sections with the newly loaded content.
00216         InputSection->Content = input;
00217         OutputSection->Content = output;
00218
00219         ScenarioLoaded(this, nullptr);
00220     }
00221     else
00222     {
00223         // Malformed Scenario file.
00224         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00225             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00226     }
00227 }
00228
00229 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00230 {
00231     if (Scenarios->SelectedItem != nullptr)
00232     {
00233         NotifyUser("", NotifyType::StatusMessage);
00234
00235         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00236         InvalidateSize();
00237     }
00238 }
00239
00240 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00241 {
00242     switch (type)
00243     {
00244     case NotifyType::StatusMessage:
00245         // Use the status message style.
00246         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00247         break;
00248     case NotifyType::ErrorMessage:
00249         // Use the error message style.
00250         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00251         break;
00252     default:
00253         break;
00254     }
00255     StatusBlock->Text = strMessage;
00256
00257     // Collapsed the StatusBlock if it has no text to conserve real estate.
00258     if (StatusBlock->Text != "")
00259     {
00260         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00261     }
00262     else
00263     {
00264         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00265     }
00266 }
00267
00268 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00271     Windows::System::Launcher::LaunchUriAsync(uri);
00272 }
00273
00274
00275 /// <summary>
00276 /// Populates the page with content passed during navigation.  Any saved state is also
00277 /// provided when recreating a page from a prior session.
00278 /// </summary>
00279 /// <param name="navigationParameter">The parameter value passed to
00280 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00281 /// </param>
00282 /// <param name="pageState">A map of state preserved by this page during an earlier
00283 /// session.  This will be null the first time a page is visited.</param>
00284 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00285 {
00286     (void) navigationParameter; // Unused parameter
00287
00288     PopulateScenarios();
00289
00290     // Starting scenario is the first or based upon a previous state.
00291     ListBoxItem^ startingScenario = nullptr;
00292     int startingScenarioIndex = -1;
00293
00294     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00295     {
00296         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00297     }
00298
00299     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00300
00301     InvalidateViewState();
00302 }
00303
00304 /// <summary>
00305 /// Preserves state associated with this page in case the application is suspended or the
00306 /// page is discarded from the navigation cache.  Values must conform to the serialization
00307 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00308 /// </summary>
00309 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00310 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00311 {
00312     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00313     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00314 }
00315
00316 bool MainPage::EnsureUnsnapped()
00317 {
00318     // FilePicker APIs will not work if the application is in a snapped state.
00319     // If an app wants to show a FilePicker while snapped, it must attempt to unsnap first
00320     bool unsnapped = ((ApplicationView::Value != ApplicationViewState::Snapped) || ApplicationView::TryUnsnap());
00321     if (!unsnapped)
00322     {
00323         NotifyUser("Cannot unsnap the sample application", NotifyType::StatusMessage);
00324     }
00325
00326     return unsnapped;
00327 }
00328
00329 void MainPage::ResetScenarioOutput(TextBlock^ output)
00330 {
00331     // clear Error/Status
00332     NotifyUser("", NotifyType::ErrorMessage);
00333     NotifyUser("", NotifyType::StatusMessage);
00334     // clear scenario output
00335     output->Text = "";
00336 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/MainPage.xaml.h Source File

  • SimpleOrientationSensor

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario3.xaml.cpp Source File

  • XAML WebView control

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::WebViewControl;
00020
00021 using namespace Platform;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025
00026 Scenario3::Scenario3()
00027 {
00028     InitializeComponent();
00029 }
00030
00031 // Invoked when this page is about to be displayed in a Frame.
00032 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00033 {
00034     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00035     // as NotifyUser()
00036     rootPage = MainPage::Current;
00037
00038   // Let's create an HTML fragment that contains some javascript code that we will fire using
00039     // InvokeScript().
00040     String^ htmlFragment = "<!DOCTYPE html PUBLIC '-//W3C//DTD XHTML 1.0 Transitional//EN' 'http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd'>"
00041   + "\n\t<html>"
00042   + "\n\t   <head>"
00043   + "\n\t     <script type='text/javascript'>"
00044   + "\n\t       function SayGoodbye() "
00045   + "\n\t       {"
00046   + "\n\t         document.getElementById('myDiv').innerText = 'GoodBye'; "
00047   + "\n\t       }"
00048   + "\n\t     </script>"
00049   + "\n\t   </head>"
00050   + "\n\t   <body>"
00051   + "\n\t     <div id='myDiv'>Hello</div>"
00052   + "\n\t   </body>"
00053   + "\n\t </html>";
00054
00055     // Load it into the HTML text box so it will be visible.
00056     HTML3->Text = htmlFragment;
00057 }
00058
00059
00060 // Click handler for the 'Load' button.
00061 void SDKSample::WebViewControl::Scenario3::Load_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00062 {
00063   // Grab the HTML from the text box and load it into the WebView
00064     WebView3->NavigateToString(HTML3->Text);
00065 }
00066
00067
00068 // Click handler for the 'Script' button.
00069 void SDKSample::WebViewControl::Scenario3::Script_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00070 {
00071   // Invoke the javascript function called 'SayGoodbye' that is loaded into the WebView.
00072     WebView3->InvokeScript("SayGoodbye", nullptr);
00073 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard text input/C++/ScopedViews.xaml.cpp Source File

  • Input Touch keyboard text input

ScopedViews.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ScopedViews.xaml.cpp
00013 // Implementation of the ScopedViews class
00014 //
00015
00016 #include "pch.h"
00017 #include "ScopedViews.xaml.h"
00018
00019 using namespace SDKSample::TouchKeyboardTextInput;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 ScopedViews::ScopedViews()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void ScopedViews::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/StreamEffect.cpp Source File

  • XAudio2 audio stream effect

StreamEffect.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "StreamEffect.h"
00010 #include "DirectXSample.h"
00011
00012 namespace
00013 {
00014     const char16 APPLICATION_TITLE[] = L"XAudio2 audio stream playback sample";
00015     const char16 MUSIC_FILE[]        = L"Media\\Wavs\\becky.wma";
00016
00017     const size_t BUFFER_COUNT = 3;
00018
00019     const char16 MSG_NEED_AUDIO[]       = L"No usable audio devices were found; install an audio device and restart the sample.";
00020     const float INFORMATION_START_X     = 32.0f;
00021     const float INFORMATION_START_Y     = 150.0f;
00022
00023     const char16    FONT_LOCALE[]       = L"en-US";
00024     const char16    FONT_NAME[]         = L"Segoe UI";
00025     const float     FONT_SIZE_TEXT      = 18.0f;
00026 };
00027
00028 StreamEffect::StreamEffect() :
00029     m_isAudioStarted(false),
00030     m_currentBuffer(0),
00031     m_musicEngine(nullptr),
00032     m_musicMasteringVoice(nullptr),
00033     m_musicSourceVoice(nullptr),
00034     m_audioBuffers()
00035 {
00036 }
00037
00038 StreamEffect::~StreamEffect()
00039 {
00040     ReleaseAudioResources();
00041 }
00042
00043 void StreamEffect::CreateDeviceIndependentResources()
00044 {
00045     DirectXBase::CreateDeviceIndependentResources();
00046
00047     CreateAudioResources();
00048 }
00049
00050 void StreamEffect::CreateDeviceResources()
00051 {
00052     DirectXBase::CreateDeviceResources();
00053
00054     m_sampleOverlay = ref new SampleOverlay();
00055
00056     m_sampleOverlay->Initialize(
00057         m_d2dDevice.Get(),
00058         m_d2dContext.Get(),
00059         m_wicFactory.Get(),
00060         m_dwriteFactory.Get(),
00061         ref new Platform::String(APPLICATION_TITLE)
00062         );
00063
00064     //
00065     // Setup the graphics objects related to drawing text
00066     //
00067     DX::ThrowIfFailed(
00068         m_dwriteFactory->CreateTextFormat(
00069             FONT_NAME,
00070             nullptr,
00071             DWRITE_FONT_WEIGHT_NORMAL,
00072             DWRITE_FONT_STYLE_NORMAL,
00073             DWRITE_FONT_STRETCH_NORMAL,
00074             FONT_SIZE_TEXT,
00075             FONT_LOCALE,
00076             &m_dataTextFormat
00077             )
00078         );
00079
00080     DX::ThrowIfFailed(
00081         m_dataTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00082         );
00083     DX::ThrowIfFailed(
00084         m_dataTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00085         );
00086
00087     DX::ThrowIfFailed(
00088         m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::White), &m_textBrush)
00089         );
00090
00091 }
00092
00093 void StreamEffect::CreateAudioResources()
00094 {
00095     UINT32 flags = 0;
00096
00097     // Load the wave into a buffer using Media Foundation.
00098     // Media Foundation is a convenient way to get both file I/O and format decode for audio assets.
00099     // Games are welcome to replace the streamer in this sample with their own file I/O and decode routines
00100
00101     m_musicStreamer.reset(new MediaStreamer(ref new Platform::String(MUSIC_FILE)));
00102     uint32 streamSampleRate = m_musicStreamer->GetOutputWaveFormatEx().nSamplesPerSec;
00103
00104     // Create XAudio2 and a single mastering voice on the default audio device
00105
00106     // NOTE: The method for creating XAudio2 is changing for Win8 (and will be different than
00107     // what you can read on MSDN today.) Changes include:
00108     //    * XAudio2Create is a flat Win32 API and does not require CoCreateInstance
00109     //    * There is no device enumeration on IXAudio2 - GetDeviceCount and GetDeviceDetails are removed
00110     //    * CreateMasteringVoice now takes a device id string instead of index, requiring you to enumerate devices using
00111     //      the new Metro style device enumeration APIs in Windows or the desktop MMDevice enumeration APIs
00112     //      (Only the default device is supported for //BUILD.)
00113     //    * CreateMasteringVoice has an additional parameter to tag the category of the output stream
00114
00115     DX::ThrowIfFailed(
00116         XAudio2Create(&m_musicEngine, flags)
00117         );
00118
00119     // This sample plays the equivalent of background music, which we tag on the mastering voice as AudioCategory_GameMedia.
00120     // In ordinary usage, if we were playing the music track with no effects, we could route it entirely through
00121     // Media Foundation. Here we are using XAudio2 to apply a reverb effect to the music, so we use Media Foundation to
00122     // decode the data then we feed it through the XAudio2 pipeline as a separate Mastering Voice, so that we can tag it
00123     // as Game Media.
00124
00125     HRESULT hr = m_musicEngine->CreateMasteringVoice(
00126         &m_musicMasteringVoice,
00127         XAUDIO2_DEFAULT_CHANNELS,
00128         streamSampleRate,
00129         0,
00130         nullptr,    // Use the default audio device
00131         nullptr,    // No effect chain on the mastering voice
00132         AudioCategory_GameMedia
00133         );
00134     if (FAILED(hr))
00135     {
00136         //
00137         // Unable to create the mastering voice
00138         // This happens if there are no audio devices
00139         //
00140         m_musicMasteringVoice = nullptr;
00141         return;
00142     }
00143
00144     // Set up Reverb effect
00145
00146     const WAVEFORMATEX& waveFormat = m_musicStreamer->GetOutputWaveFormatEx();
00147
00148     Microsoft::WRL::ComPtr<IUnknown> pXAPO;
00149     DX::ThrowIfFailed(
00150         XAudio2CreateReverb(&pXAPO)
00151         );
00152     XAUDIO2_EFFECT_DESCRIPTOR descriptor;
00153     descriptor.InitialState = true;
00154     descriptor.OutputChannels = waveFormat.nChannels;
00155     descriptor.pEffect = pXAPO.Get();
00156     XAUDIO2_EFFECT_CHAIN chain;
00157     chain.EffectCount = 1;
00158     chain.pEffectDescriptors = &descriptor;
00159
00160     // Create the source voice and start it
00161     DX::ThrowIfFailed(
00162         m_musicEngine->CreateSourceVoice(&m_musicSourceVoice, &waveFormat, 0, 1.0f, nullptr, nullptr, &chain)
00163         );
00164
00165     XAUDIO2FX_REVERB_PARAMETERS reverbParameters;
00166     reverbParameters.ReflectionsDelay = XAUDIO2FX_REVERB_DEFAULT_REFLECTIONS_DELAY;
00167     reverbParameters.ReverbDelay = XAUDIO2FX_REVERB_DEFAULT_REVERB_DELAY;
00168     reverbParameters.RearDelay = XAUDIO2FX_REVERB_DEFAULT_REAR_DELAY;
00169     reverbParameters.PositionLeft = XAUDIO2FX_REVERB_DEFAULT_POSITION;
00170     reverbParameters.PositionRight = XAUDIO2FX_REVERB_DEFAULT_POSITION;
00171     reverbParameters.PositionMatrixLeft = XAUDIO2FX_REVERB_DEFAULT_POSITION_MATRIX;
00172     reverbParameters.PositionMatrixRight = XAUDIO2FX_REVERB_DEFAULT_POSITION_MATRIX;
00173     reverbParameters.EarlyDiffusion = XAUDIO2FX_REVERB_DEFAULT_EARLY_DIFFUSION;
00174     reverbParameters.LateDiffusion = XAUDIO2FX_REVERB_DEFAULT_LATE_DIFFUSION;
00175     reverbParameters.LowEQGain = XAUDIO2FX_REVERB_DEFAULT_LOW_EQ_GAIN;
00176     reverbParameters.LowEQCutoff = XAUDIO2FX_REVERB_DEFAULT_LOW_EQ_CUTOFF;
00177     reverbParameters.HighEQGain = XAUDIO2FX_REVERB_DEFAULT_HIGH_EQ_GAIN;
00178     reverbParameters.HighEQCutoff = XAUDIO2FX_REVERB_DEFAULT_HIGH_EQ_CUTOFF;
00179     reverbParameters.RoomFilterFreq = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_FREQ;
00180     reverbParameters.RoomFilterMain = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_MAIN;
00181     reverbParameters.RoomFilterHF = XAUDIO2FX_REVERB_DEFAULT_ROOM_FILTER_HF;
00182     reverbParameters.ReflectionsGain = XAUDIO2FX_REVERB_DEFAULT_REFLECTIONS_GAIN;
00183     reverbParameters.ReverbGain = XAUDIO2FX_REVERB_DEFAULT_REVERB_GAIN;
00184     reverbParameters.DecayTime = XAUDIO2FX_REVERB_DEFAULT_DECAY_TIME;
00185     reverbParameters.Density = XAUDIO2FX_REVERB_DEFAULT_DENSITY;
00186     reverbParameters.RoomSize = XAUDIO2FX_REVERB_DEFAULT_ROOM_SIZE;
00187     reverbParameters.WetDryMix = XAUDIO2FX_REVERB_DEFAULT_WET_DRY_MIX;
00188     reverbParameters.DisableLateField = FALSE;
00189
00190     DX::ThrowIfFailed(
00191         m_musicSourceVoice->SetEffectParameters(0, &reverbParameters, sizeof(reverbParameters))
00192         );
00193
00194     DX::ThrowIfFailed(
00195         m_musicSourceVoice->EnableEffect(0)
00196         );
00197 }
00198
00199 void StreamEffect::ReleaseAudioResources()
00200 {
00201     if (m_musicSourceVoice != nullptr)
00202     {
00203         m_musicSourceVoice->DestroyVoice();
00204         m_musicSourceVoice    = nullptr;
00205     }
00206     if (m_musicMasteringVoice != nullptr)
00207     {
00208         m_musicMasteringVoice->DestroyVoice();
00209         m_musicMasteringVoice = nullptr;
00210     }
00211     if (m_musicEngine != nullptr)
00212     {
00213         m_musicEngine->Release();
00214         m_musicEngine = nullptr;
00215     }
00216 }
00217
00218 void StreamEffect::CreateWindowSizeDependentResources()
00219 {
00220     DirectXBase::CreateWindowSizeDependentResources();
00221     m_sampleOverlay->UpdateForWindowSizeChange();
00222 }
00223
00224 void StreamEffect::Render()
00225 {
00226     // bind the render targets
00227     m_d3dContext->OMSetRenderTargets(
00228         1,
00229         m_d3dRenderTargetView.GetAddressOf(),
00230         m_d3dDepthStencilView.Get()
00231         );
00232
00233     // clear both the render target and depth stencil to default values
00234     const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };
00235
00236     m_d3dContext->ClearRenderTargetView(
00237         m_d3dRenderTargetView.Get(),
00238         ClearColor
00239         );
00240
00241     m_sampleOverlay->Render();
00242
00243     if (IsAudioSetup())
00244     {
00245         RenderAudio();
00246     }
00247     else
00248     {
00249         //
00250         // No audio, render a message indicating setup failure
00251         //
00252         D2D1_SIZE_F size = m_d2dContext->GetSize();
00253         D2D1_RECT_F pos = D2D1::RectF(INFORMATION_START_X, INFORMATION_START_Y, size.width, size.height);
00254
00255         // Display a message when controller is not connected
00256         m_d2dContext->BeginDraw();
00257         m_d2dContext->DrawText(
00258             MSG_NEED_AUDIO,
00259             static_cast<uint32>(::wcslen(MSG_NEED_AUDIO)),
00260             m_dataTextFormat.Get(),
00261             pos,
00262             m_textBrush.Get()
00263             );
00264
00265         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00266         // is lost. It will be handled during the next call to Present.
00267         HRESULT hr = m_d2dContext->EndDraw();
00268         if (hr != D2DERR_RECREATE_TARGET)
00269         {
00270             DX::ThrowIfFailed(hr);
00271         }
00272     }
00273 }
00274
00275 void StreamEffect::OnSuspending()
00276 {
00277     m_musicEngine->StopEngine();
00278 }
00279
00280 void StreamEffect::OnResuming()
00281 {
00282     DX::ThrowIfFailed(
00283         m_musicEngine->StartEngine()
00284         );
00285 }
00286
00287 // This sample processes audio buffers during the render cycle of the application.
00288 // As long as the sample maintains a high-enough frame rate, this approach should
00289 // not glitch audio. In game code, audio buffers should be processed on a separate thread
00290 // that is not synched to the main render loop of the game.
00291
00292 void StreamEffect::RenderAudio()
00293 {
00294     if (IsAudioSetup() == false)
00295     {
00296         return;
00297     }
00298
00299     // Find the current state of the playing buffers
00300     XAUDIO2_VOICE_STATE state;
00301     m_musicSourceVoice->GetState(&state);
00302
00303     // Have any of the buffer completed
00304     while (state.BuffersQueued < BUFFER_COUNT)
00305     {
00306         // Retreive the next buffer to stream from MF Music Streamer
00307         m_audioBuffers[m_currentBuffer] = m_musicStreamer->GetNextBuffer();
00308         if (m_audioBuffers[m_currentBuffer].size() == 0)
00309         {
00310             // Audio file has been fully read, restart the reader to re-loop the audio
00311             m_musicStreamer->Restart();
00312             break;
00313         }
00314
00315         //
00316         // Submit the new buffer
00317         //
00318         XAUDIO2_BUFFER buf = {0};
00319         buf.AudioBytes = static_cast<uint32>(m_audioBuffers[m_currentBuffer].size());
00320         buf.pAudioData = &m_audioBuffers[m_currentBuffer][0];
00321         DX::ThrowIfFailed(
00322             m_musicSourceVoice->SubmitSourceBuffer(&buf)
00323             );
00324
00325         // Advance the buffer index
00326         m_currentBuffer = ++m_currentBuffer % BUFFER_COUNT;
00327
00328
00329         // Get the updated state
00330         m_musicSourceVoice->GetState(&state);
00331     }
00332 }
00333
00334 bool StreamEffect::IsAudioSetup()
00335 {
00336     return ((m_musicEngine != nullptr) &&
00337             (m_musicMasteringVoice != nullptr) &&
00338             (m_musicSourceVoice != nullptr)
00339             );
00340 }
00341
00342
00343 void StreamEffect::Update(float TimeTotal, float TimeDelta)
00344 {
00345     if (!m_isAudioStarted && (m_musicSourceVoice != nullptr))
00346     {
00347         DX::ThrowIfFailed(
00348             m_musicSourceVoice->Start(0)
00349             );
00350
00351         m_isAudioStarted = true;
00352     }
00353 }
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/App.xaml.cpp Source File

  • XAML images

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/pch.cpp Source File

  • Contact Picker app

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PageType.h Source File

  • Hilo C++
  • Hilo

PageType.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     public enum class PageType
00012     {
00013         Hub,
00014         Browse,
00015         Image,
00016         Crop,
00017         Rotate,
00018         Cartoonize
00019     };
00020 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CTriColorWindowFactory Member List

This is the complete list of members for CTriColorWindowFactory, including all inherited members.
CreateView() CTriColorWindowFactory [virtual]
Generated on Sat Nov 23 2024 16:09:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/MainPage.xaml.h Source File

  • XAML animation library

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/pch.h Source File

  • Inclinometer sensor

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DirectX::D3DX_BC1 Member List

This is the complete list of members for DirectX::D3DX_BC1, including all inherited members.
bitmap | DirectX::D3DX_BC1
rgb | DirectX::D3DX_BC1
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/common/LayoutAwarePage.h Source File

  • Device auto rotation preferences
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/common/suspensionmanager.cpp Source File

  • CryptoWinRT
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/common/LayoutAwarePage.h Source File

  • Removable storage
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/pch.h Source File

  • App package information

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Folder enumeration/C++/Scenario2.xaml.h Source File

  • Folder enumeration

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace FolderEnumeration
00025     {
00026         public ref class Scenario2 sealed
00027         {
00028         public:
00029             Scenario2();
00030
00031         private:
00032             void GroupByMonthButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00033             void GroupByRatingButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00034             void GroupByTagButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00035             void GroupByHelper(Windows::Storage::Search::QueryOptions^ queryOptions);
00036             Windows::UI::Xaml::Controls::TextBlock^ CreateHeaderTextBlock(Platform::String^ contents);
00037             Windows::UI::Xaml::Controls::TextBlock^ CreateLineItemTextBlock(Platform::String^ contents);
00038         };
00039     }
00040 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/DirectXBase.cpp Source File

  • Direct2D interpolation modes

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicTimer.h Source File

  • DirectX touch input

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicTimer.cpp Source File

  • DXGI swap chain rotation

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/pch.h Source File

  • Scheduled notifications
  • C#,C++

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
00007
00008 #include <strsafe.h>
00009 #include <Windows.h>
00010 #include "CppSamplesUtils.h"
00011 #include <ppltasks.h>
00012 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/DisplayCalendarStatistics.xaml.cpp Source File

  • Calendar details and math

DisplayCalendarStatistics.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DisplayCalendarStatistics.xaml.cpp
00013 // Implementation of the DisplayCalendarStatistics class
00014 //
00015
00016 #include "pch.h"
00017 #include "DisplayCalendarStatistics.xaml.h"
00018
00019 using namespace SDKSample::CalendarSample;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Platform;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Foundation::Collections;
00027 using namespace Windows::Globalization;
00028
00029 DisplayCalendarStatistics::DisplayCalendarStatistics()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 /// <summary>
00035 /// Invoked when this page is about to be displayed in a Frame.
00036 /// </summary>
00037 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00038 /// property is typically used to configure the page.</param>
00039 void DisplayCalendarStatistics::OnNavigatedTo(NavigationEventArgs^ e)
00040 {
00041     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00042     // as NotifyUser()
00043     rootPage = MainPage::Current;
00044 }
00045
00046 void SDKSample::CalendarSample::DisplayCalendarStatistics::Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00047 {
00048     // This scenario uses the Windows.Globalization.Calendar class to display the calendar
00049     // system statistics.
00050
00051     // Store results here
00052     String^ results;
00053
00054     // Array languages used by the test
00055     auto ja = ref new Platform::Collections::Vector<String^>();
00056   ja->Append("ja-JP");
00057   auto he = ref new Platform::Collections::Vector<String^>();
00058   he->Append("he-IL");
00059
00060     // Calendar based on the current user.
00061   Calendar^ cal1 = ref new Calendar();
00062
00063   // Calendar using Japanese language and Japanese calendar.
00064   Calendar^ cal2 = ref new Calendar(ja, CalendarIdentifiers::Japanese, ClockIdentifiers::TwelveHour);
00065
00066   // Calendar using Hebrew language and Hebrew calendar.
00067   Calendar^ cal3 = ref new Calendar(he, CalendarIdentifiers::Hebrew, ClockIdentifiers::TwentyFourHour);
00068
00069   String^ calStats1 =
00070         "User's default calendar: " + cal1->GetCalendarSystem() + "\n" +
00071     "Months in this Year: " + cal1->NumberOfMonthsInThisYear + "\n" +
00072     "Days in this Month: " + cal1->NumberOfDaysInThisMonth + "\n" +
00073     "Hours in this Period: " + cal1->NumberOfHoursInThisPeriod + "\n"
00074     "Era: " + cal1->EraAsString();
00075
00076   String^ calStats2 = "Calendar system: " + cal2->GetCalendarSystem() + "\n" +
00077     "Months in this Year: " + cal2->NumberOfMonthsInThisYear + "\n" +
00078     "Days in this Month: " + cal2->NumberOfDaysInThisMonth + "\n" +
00079     "Hours in this Period: " + cal2->NumberOfHoursInThisPeriod + "\n"
00080     "Era: " + cal2->EraAsString();
00081
00082   String^ calStats3 =
00083         "Calendar system: " + cal3->GetCalendarSystem() + "\n" +
00084     "Months in this Year: " + cal3->NumberOfMonthsInThisYear + "\n" +
00085     "Days in this Month: " + cal3->NumberOfDaysInThisMonth + "\n" +
00086     "Hours in this Period: " + cal3->NumberOfHoursInThisPeriod + "\n"
00087     "Era: " + cal3->EraAsString();
00088
00089   // Generate the result.
00090   results = calStats1 + "\n\n" + calStats2 + "\n\n" + calStats3;
00091
00092     // Display the results
00093     rootPage->NotifyUser(results, NotifyType::StatusMessage);
00094 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/BasicTimer.h Source File

  • Direct3D HLSL fractal generator

BasicTimer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple timer class used to drive the render loop of the actively-animated
00011 // DirectX SDK samples. Uses the QueryPerformanceCounter function to retrieve
00012 // high-resolution timing information.
00013 ref class BasicTimer
00014 {
00015 private:
00016     LARGE_INTEGER m_frequency;
00017     LARGE_INTEGER m_currentTime;
00018     LARGE_INTEGER m_startTime;
00019     LARGE_INTEGER m_lastTime;
00020     float m_total;
00021     float m_delta;
00022
00023 internal:
00024     BasicTimer();
00025     void Reset();
00026     void Update();
00027     property float Total
00028     {
00029         float get();
00030     }
00031     property float Delta
00032     {
00033         float get();
00034     }
00035 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D effects on primitives/C++/D2DEffectsOnPrimitives.cpp Source File

  • Direct2D effects on primitives

D2DEffectsOnPrimitives.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "D2DEffectsOnPrimitives.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Platform;
00013 using namespace Windows::ApplicationModel;
00014 using namespace Windows::ApplicationModel::Core;
00015 using namespace Windows::ApplicationModel::Activation;
00016 using namespace Windows::Foundation;
00017 using namespace Windows::Graphics::Display;
00018 using namespace Windows::System;
00019 using namespace Windows::UI::Core;
00020
00021 // Define properties of the primitives (in units of DIPs).
00022 static const D2D1_SIZE_F sc_inputBitmapSize             = D2D1::SizeF(450.0f, 250.0f);
00023 static const D2D1_SIZE_F sc_largeRectangleSize          = D2D1::SizeF(400.0f, 200.0f);
00024 static const D2D1_SIZE_F sc_smallRectangleSize          = D2D1::SizeF(300.0f, 150.0f);
00025 static const float sc_roundingRadius                    = 30.0f;
00026 static const float sc_strokeWidth                       = 10.0f;
00027 static const float sc_offset                            = 150.0f;
00028
00029 // Define properties of the effects.
00030 static const float sc_gaussianBlurStDev                 = 8.0f;
00031 static const D2D_VECTOR_3F sc_specularLightPosition     = D2D1::Vector3F(300.0f, -1000.0f, 3000.0f);
00032 static const float sc_specularExponent                  = 20.0f;
00033 static const float sc_specularConstant                  = 0.75f;
00034 static const float sc_specularSurfaceScale              = 5.0f;
00035 static const D2D1_VECTOR_4F sc_arithmeticCoefficients   = D2D1::Vector4F(0.0f, 1.0f, 1.0f, 0.0f);
00036
00037 void D2DEffectsOnPrimitives::HandleDeviceLost()
00038 {
00039     // Release window size-dependent resources prior to creating a new device and swap chain.
00040     m_inputImage = nullptr;
00041     m_arithmeticCompositeEffect = nullptr;
00042
00043     DirectXBase::HandleDeviceLost();
00044 }
00045
00046 void D2DEffectsOnPrimitives::CreateDeviceIndependentResources()
00047 {
00048     DirectXBase::CreateDeviceIndependentResources();
00049
00050     // Create the string to display.
00051     m_string = L"Direct2D";
00052
00053     // Create a text format object to define the default font,
00054     // weight, stretch, style, and locale.
00055     DX::ThrowIfFailed(
00056         m_dwriteFactory->CreateTextFormat(
00057             L"Segoe UI",                    // Font family name.
00058             nullptr,                        // Font collection (use the system font collection).
00059             DWRITE_FONT_WEIGHT_REGULAR,
00060             DWRITE_FONT_STYLE_NORMAL,
00061             DWRITE_FONT_STRETCH_NORMAL,
00062             64.0f,                          // Font size.
00063             L"en-us",                       // Locale.
00064             &m_textFormat
00065             )
00066         );
00067
00068     // Center the text horizontally.
00069     DX::ThrowIfFailed(
00070         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00071         );
00072
00073     // Center the text vertically.
00074     DX::ThrowIfFailed(
00075         m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00076         );
00077 }
00078
00079 void D2DEffectsOnPrimitives::CreateDeviceResources()
00080 {
00081     DirectXBase::CreateDeviceResources();
00082
00083     // Create the sample overlay.
00084     m_sampleOverlay = ref new SampleOverlay();
00085
00086     m_sampleOverlay->Initialize(
00087         m_d2dDevice.Get(),
00088         m_d2dContext.Get(),
00089         m_wicFactory.Get(),
00090         m_dwriteFactory.Get(),
00091         L"Direct2D effects on primitives sample"
00092         );
00093
00094     // Create brushes for rendering Direct2D.
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::White), &m_whiteBrush)
00097         );
00098
00099     DX::ThrowIfFailed(
00100         m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::Red), &m_coloredBrush)
00101         );
00102 }
00103
00104 void D2DEffectsOnPrimitives::CreateWindowSizeDependentResources()
00105 {
00106     DirectXBase::CreateWindowSizeDependentResources();
00107
00108     // Create the input bitmap of primitives.
00109     CreatePrimitives();
00110
00111     // Create the image effects and apply them to the primitives.
00112     CreateEffectGraph();
00113 }
00114
00115 void D2DEffectsOnPrimitives::CreatePrimitives()
00116 {
00117     // Convert from DIPs to pixels, since bitmaps are created in units of pixels.
00118     D2D1_SIZE_U bitmapSizeInPixels = D2D1::SizeU(
00119         static_cast<UINT32>(sc_inputBitmapSize.width / 96.0f * m_dpi),
00120         static_cast<UINT32>(sc_inputBitmapSize.height / 96.0f * m_dpi)
00121         );
00122
00123     // Create the bitmap to which the effects will be applied.
00124     DX::ThrowIfFailed(
00125         m_d2dContext->CreateBitmap(
00126             bitmapSizeInPixels,
00127             nullptr,
00128             0,
00129             D2D1::BitmapProperties1(
00130                 D2D1_BITMAP_OPTIONS_TARGET,
00131                 D2D1::PixelFormat(
00132                     DXGI_FORMAT_B8G8R8A8_UNORM,
00133                     D2D1_ALPHA_MODE_PREMULTIPLIED
00134                     ),
00135                 m_dpi,
00136                 m_dpi
00137                 ),
00138             &m_inputImage
00139             )
00140         );
00141
00142     // Draw onto the input bitmap instead of the window's surface.
00143     m_d2dContext->SetTarget(m_inputImage.Get());
00144
00145     m_d2dContext->BeginDraw();
00146
00147     // Clear the bitmap with transparent white.
00148     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::White, 0.0f));
00149
00150     // Create a small rounded rectangle centered in the bitmap.
00151     D2D1_RECT_F rectangle1 = D2D1::RectF(
00152         (sc_inputBitmapSize.width - sc_smallRectangleSize.width) / 2,
00153         (sc_inputBitmapSize.height - sc_smallRectangleSize.height) / 2,
00154         (sc_inputBitmapSize.width + sc_smallRectangleSize.width) / 2,
00155         (sc_inputBitmapSize.height + sc_smallRectangleSize.height) / 2
00156         );
00157
00158     D2D1_ROUNDED_RECT roundedRect1 = D2D1::RoundedRect(rectangle1, sc_roundingRadius, sc_roundingRadius);
00159
00160     m_d2dContext->FillRoundedRectangle(&roundedRect1, m_coloredBrush.Get());
00161
00162     // Create a larger rounded rectangle centered in the bitmap.
00163     D2D1_RECT_F rectangle2 = D2D1::RectF(
00164         (sc_inputBitmapSize.width - sc_largeRectangleSize.width) / 2,
00165         (sc_inputBitmapSize.height - sc_largeRectangleSize.height) / 2,
00166         (sc_inputBitmapSize.width + sc_largeRectangleSize.width) / 2,
00167         (sc_inputBitmapSize.height + sc_largeRectangleSize.height) / 2
00168         );
00169
00170     D2D1_ROUNDED_RECT roundedRect2 = D2D1::RoundedRect(rectangle2, sc_roundingRadius, sc_roundingRadius);
00171
00172     m_d2dContext->DrawRoundedRectangle(&roundedRect2, m_coloredBrush.Get(), sc_strokeWidth);
00173
00174     // Draw some text onto the rectangles.
00175     m_d2dContext->DrawText(
00176         m_string->Data(),
00177         m_string->Length(),
00178         m_textFormat.Get(),
00179         D2D1::RectF(
00180             0,
00181             0,
00182             sc_inputBitmapSize.width,
00183             sc_inputBitmapSize.height
00184             ),
00185         m_whiteBrush.Get()
00186         );
00187
00188     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00189     // is lost. It will be handled during the next call to Present.
00190     HRESULT hr = m_d2dContext->EndDraw();
00191     if (hr != D2DERR_RECREATE_TARGET)
00192     {
00193         DX::ThrowIfFailed(hr);
00194     }
00195
00196     // Reset the device context to render to the back buffer.
00197     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00198 }
00199
00200 void D2DEffectsOnPrimitives::CreateEffectGraph()
00201 {
00202     ComPtr<ID2D1Effect> gaussianBlurEffect;
00203     ComPtr<ID2D1Effect> specularLightingEffect;
00204     ComPtr<ID2D1Effect> compositeEffect;
00205
00206     // Create the Gaussian Blur Effect
00207     DX::ThrowIfFailed(
00208         m_d2dContext->CreateEffect(CLSID_D2D1GaussianBlur, &gaussianBlurEffect)
00209         );
00210
00211     // Set the blur amount
00212     DX::ThrowIfFailed(
00213         gaussianBlurEffect->SetValue(D2D1_GAUSSIANBLUR_PROP_STANDARD_DEVIATION, sc_gaussianBlurStDev)
00214         );
00215
00216     // Create the Specular Lighting Effect
00217     DX::ThrowIfFailed(
00218         m_d2dContext->CreateEffect(CLSID_D2D1PointSpecular, &specularLightingEffect)
00219         );
00220
00221     DX::ThrowIfFailed(
00222         specularLightingEffect->SetValue(D2D1_POINTSPECULAR_PROP_LIGHT_POSITION, sc_specularLightPosition)
00223         );
00224
00225     DX::ThrowIfFailed(
00226         specularLightingEffect->SetValue(D2D1_POINTSPECULAR_PROP_SPECULAR_EXPONENT, sc_specularExponent)
00227         );
00228
00229     DX::ThrowIfFailed(
00230         specularLightingEffect->SetValue(D2D1_POINTSPECULAR_PROP_SURFACE_SCALE, sc_specularSurfaceScale)
00231         );
00232
00233     DX::ThrowIfFailed(
00234         specularLightingEffect->SetValue(D2D1_POINTSPECULAR_PROP_SPECULAR_CONSTANT, sc_specularConstant)
00235         );
00236
00237     // Create the Composite Effects
00238     DX::ThrowIfFailed(
00239         m_d2dContext->CreateEffect(CLSID_D2D1Composite, &compositeEffect)
00240         );
00241
00242     DX::ThrowIfFailed(
00243         compositeEffect->SetValue(D2D1_COMPOSITE_PROP_MODE, D2D1_COMPOSITE_MODE_SOURCE_IN)
00244         );
00245
00246     DX::ThrowIfFailed(
00247         m_d2dContext->CreateEffect(CLSID_D2D1ArithmeticComposite, &m_arithmeticCompositeEffect)
00248         );
00249
00250     DX::ThrowIfFailed(
00251         m_arithmeticCompositeEffect->SetValue(D2D1_ARITHMETICCOMPOSITE_PROP_COEFFICIENTS, sc_arithmeticCoefficients)
00252         );
00253
00254     // Connect the graph.
00255     // Apply a blur effect to the original image.
00256     gaussianBlurEffect->SetInput(0, m_inputImage.Get());
00257
00258     // Apply a specular lighting effect to the result.
00259     specularLightingEffect->SetInputEffect(0, gaussianBlurEffect.Get());
00260
00261     // Compose the original bitmap under the output from lighting and blur.
00262     compositeEffect->SetInput(0, m_inputImage.Get());
00263     compositeEffect->SetInputEffect(1, specularLightingEffect.Get());
00264
00265     // Compose the original bitmap under the output from lighting and blur.
00266     m_arithmeticCompositeEffect->SetInput(0, m_inputImage.Get());
00267     m_arithmeticCompositeEffect->SetInputEffect(1, compositeEffect.Get());
00268 }
00269
00270 void D2DEffectsOnPrimitives::Render()
00271 {
00272     m_d2dContext->BeginDraw();
00273
00274     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00275
00276     D2D1_SIZE_F size = m_d2dContext->GetSize();
00277
00278     // Draw the bitmap with the original primitives.
00279     m_d2dContext->DrawImage(
00280         m_inputImage.Get(),
00281         D2D1::Point2F(
00282             (size.width - sc_inputBitmapSize.width) / 2,
00283             (size.height - sc_inputBitmapSize.height) / 2 - sc_offset
00284             )
00285         );
00286
00287     // Draw the output of the effects graph.
00288     m_d2dContext->DrawImage(
00289         m_arithmeticCompositeEffect.Get(),
00290         D2D1::Point2F(
00291             (size.width - sc_inputBitmapSize.width) / 2,
00292             (size.height - sc_inputBitmapSize.height) / 2 + sc_offset
00293             )
00294         );
00295
00296     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00297     // is lost. It will be handled during the next call to Present.
00298     HRESULT hr = m_d2dContext->EndDraw();
00299     if (hr != D2DERR_RECREATE_TARGET)
00300     {
00301         DX::ThrowIfFailed(hr);
00302     }
00303
00304     m_sampleOverlay->Render();
00305 }
00306
00307 void D2DEffectsOnPrimitives::Initialize(
00308     _In_ CoreApplicationView^ applicationView
00309     )
00310 {
00311     applicationView->Activated +=
00312         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &D2DEffectsOnPrimitives::OnActivated);
00313 }
00314
00315 void D2DEffectsOnPrimitives::SetWindow(
00316     _In_ CoreWindow^ window
00317     )
00318 {
00319     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00320
00321     window->SizeChanged +=
00322         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &D2DEffectsOnPrimitives::OnWindowSizeChanged);
00323
00324     DisplayProperties::LogicalDpiChanged +=
00325         ref new DisplayPropertiesEventHandler(this, &D2DEffectsOnPrimitives::OnLogicalDpiChanged);
00326
00327     DisplayProperties::DisplayContentsInvalidated +=
00328         ref new DisplayPropertiesEventHandler(this, &D2DEffectsOnPrimitives::OnDisplayContentsInvalidated);
00329
00330     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00331 }
00332
00333 void D2DEffectsOnPrimitives::Load(
00334     _In_ Platform::String^ entryPoint
00335     )
00336 {
00337     // This method is intentionally left empty.
00338 }
00339
00340 void D2DEffectsOnPrimitives::Run()
00341 {
00342     Render();
00343     Present();
00344
00345     m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
00346 }
00347
00348 void D2DEffectsOnPrimitives::Uninitialize()
00349 {
00350     // This method is intentionally left empty.
00351 }
00352
00353 void D2DEffectsOnPrimitives::OnWindowSizeChanged(
00354     _In_ CoreWindow^ sender,
00355     _In_ WindowSizeChangedEventArgs^ args
00356     )
00357 {
00358     UpdateForWindowSizeChange();
00359     m_sampleOverlay->UpdateForWindowSizeChange();
00360     Render();
00361     Present();
00362 }
00363
00364 void D2DEffectsOnPrimitives::OnLogicalDpiChanged(
00365     _In_ Platform::Object^ sender
00366     )
00367 {
00368     SetDpi(DisplayProperties::LogicalDpi);
00369     Render();
00370     Present();
00371 }
00372
00373 void D2DEffectsOnPrimitives::OnDisplayContentsInvalidated(
00374     _In_ Platform::Object^ sender
00375     )
00376 {
00377     // Ensure the D3D Device is available for rendering.
00378     ValidateDevice();
00379
00380     Render();
00381     Present();
00382 }
00383
00384 void D2DEffectsOnPrimitives::OnActivated(
00385     _In_ CoreApplicationView^ applicationView,
00386     _In_ IActivatedEventArgs^ args
00387     )
00388 {
00389     m_window->Activate();
00390 }
00391
00392 IFrameworkView^ DirectXAppSource::CreateView()
00393 {
00394     return ref new D2DEffectsOnPrimitives();
00395 }
00396
00397 [Platform::MTAThread]
00398 int main(Platform::Array<Platform::String^>^)
00399 {
00400     auto directXAppSource = ref new DirectXAppSource();
00401     CoreApplication::Run(directXAppSource);
00402     return 0;
00403 }
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/pch.cpp Source File

  • XAML DirectX 3D shooting game

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/MainPage.xaml.h Source File

  • PlayToReceiver

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/Scenario3.xaml.h Source File

  • XAML FlipView control

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "SampleDataSource.h"
00022
00023 namespace SDKSample
00024 {
00025   namespace FlipViewCPP
00026   {
00027     /// <summary>
00028     /// An empty page that can be used on its own or navigated to within a Frame.
00029     /// </summary>
00030     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00031     public ref class Scenario3 sealed
00032     {
00033     public:
00034       Scenario3();
00035
00036     internal:
00037       static Scenario3^ Current;
00038
00039     protected:
00040       virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00041     private:
00042       MainPage^ rootPage;
00043       void TOCButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044     };
00045
00046
00047     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00048     public ref class ItemSelector sealed :  Windows::UI::Xaml::Controls::DataTemplateSelector
00049     {
00050     protected:
00051       virtual Windows::UI::Xaml::DataTemplate^ SelectTemplateCore(Platform::Object^  item, Windows::UI::Xaml::DependencyObject^ container) override
00052       {
00053         using namespace Windows::UI::Xaml;
00054         using namespace FlipViewData;
00055
00056         DataTemplate^ itemTemplate = dynamic_cast<DataTemplate^>(Scenario3::Current->Resources->Lookup("ImageTemplate"));
00057         DataTemplate^ tocTemplate =  dynamic_cast<DataTemplate^>(Scenario3::Current->Resources->Lookup("TOCTemplate"));
00058
00059
00060         SampleDataItem^ dataItem = dynamic_cast<SampleDataItem^>(item);
00061
00062         if (dataItem != nullptr)
00063         {
00064           return itemTemplate;
00065         }
00066         else
00067         {
00068           return tocTemplate;
00069         }
00070       }
00071     };
00072
00073   }
00074 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/pch.h Source File

  • Direct2D basic image effects

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AnimateCirclePosition Member List

This is the complete list of members for AnimateCirclePosition, including all inherited members.
__pad0__ | AnimateCirclePosition |
clockwise | AnimateCirclePosition |
continuous | AnimateCirclePosition |
duration | AnimateCirclePosition |
Evaluate(_In_ float t) override | AnimateCirclePosition | [virtual]
Evaluate(_In_ float t) override | AnimateCirclePosition | [virtual]
m_center | AnimateCirclePosition | [private]
m_clockwise | AnimateCirclePosition | [private]
m_planeNormal | AnimateCirclePosition | [private]
m_radius | AnimateCirclePosition | [private]
m_rotationMatrix | AnimateCirclePosition | [private]
m_startPosition | AnimateCirclePosition | [private]
planeNormal | AnimateCirclePosition |
startPosition | AnimateCirclePosition |
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/pch.h Source File

  • Credential locker

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/DirectXBase.cpp Source File

  • Direct2D save to image file

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_MULTI_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Page.h Source File

  • Direct2D magazine app

Page.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "Element.h"
00011
00012 //  <page> holds all the content within a page. It aligns the content to the
00013 //  display edge to ensure proper visibility in Portrait mode by aligning the
00014 //  page's specified alignment offset to the correspondent edge of the display.
00015 //
00016 ref class Page : public Element
00017 {
00018 public:
00019     virtual bool AcceptChildNode(
00020         _In_ Document^ document,
00021         _In_ Windows::Data::Xml::Dom::IXmlNode^ childXmlNode
00022         ) override;
00023 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Rectangle.h Source File

  • Direct2D magazine app

Rectangle.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "Element.h"
00011
00012 //  <rect> represents a rectangle drawing on the surface.
00013 //
00014 //  Rectangle accepts the following markup attributes:
00015 //      color = "#<rgb>"
00016 //          Color in red-green-blue format i.e. the value of "#FF0000" is red
00017 //      opacity = "<0..1>"
00018 //          Opacity value from 0.0 to 1.0 where 0.0 is fully transparent and 1.0 is fully opaque
00019 //
00020 ref class Rectangle : public Element
00021 {
00022 internal:
00023     Rectangle();
00024
00025     virtual bool Initialize(
00026         _In_ Document^ document,
00027         _In_ Windows::Data::Xml::Dom::XmlElement^ xmlElement
00028         ) override;
00029
00030     virtual void Measure(
00031         _In_ Document^ document,
00032         D2D1_SIZE_F const& parentSize,
00033         _Out_ D2D1_RECT_F* bounds
00034         ) override;
00035
00036     virtual bool Draw(
00037         _In_ Document^ document,
00038         D2D1::Matrix3x2F const& transform
00039         ) override;
00040
00041     virtual float GetOpacity() override
00042     {
00043         return m_opacity;
00044     }
00045
00046 private:
00047     // Fill color
00048     uint32 m_color;
00049
00050     // Fill opacity
00051     float m_opacity;
00052
00053     // Brush used to fill the rectangle area.
00054     Microsoft::WRL::ComPtr<ID2D1Brush> m_brush;
00055 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DirectX::DDS_HEADER_DXT10 Member List

This is the complete list of members for DirectX::DDS_HEADER_DXT10, including all inherited members.
arraySize | DirectX::DDS_HEADER_DXT10
dxgiFormat | DirectX::DDS_HEADER_DXT10
miscFlag | DirectX::DDS_HEADER_DXT10
reserved | DirectX::DDS_HEADER_DXT10
resourceDimension | DirectX::DDS_HEADER_DXT10
Generated on Sat Nov 23 2024 16:09:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/pch.cpp Source File

  • Thread pool

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Common/suspensionmanager.cpp Source File

  • XAML text display
  • Common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/WorkItemScenario.xaml.h Source File

  • Thread pool

WorkItemScenario.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // WorkItemScenario.xaml.h
00013 // Declaration of the WorkItemScenario class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "WorkItemScenario.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ThreadPool
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class WorkItemScenario sealed
00031         {
00032         public:
00033             WorkItemScenario();
00034             void UpdateUI(ThreadPool::Status status);
00035             void UpdateWorkItemProgressUI(int percentComplete);
00036
00037         protected:
00038             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00039             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00040         private:
00041             MainPage^ rootPage;
00042             void CreateThreadPoolWorkItem(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void CancelThreadPoolWorkItem(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044         };
00045     }
00046 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/MainPage.xaml.h Source File

  • Syndication

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput3.xaml.cpp Source File

  • Print

ScenarioOutput3.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Output.xaml.cpp
00010 // Implementation of the Scenario3Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput3.xaml.h"
00015
00016 using namespace PrintSample;
00017
00018 ScenarioOutput3::ScenarioOutput3()
00019 {
00020     InitializeComponent();
00021 }
00022
00023 ScenarioOutput3::~ScenarioOutput3()
00024 {
00025 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/WASAPICapture.cpp Source File

  • Windows Audio Session (WASAPI)
  • C++

WASAPICapture.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // WASAPICapture.h
00013 //
00014
00015 #include "pch.h"
00016 #include "WASAPICapture.h"
00017
00018 using namespace Windows::Storage;
00019 using namespace Windows::System::Threading;
00020 using namespace SDKSample::WASAPIAudio;
00021
00022
00023 //
00024 //  WASAPICapture()
00025 //
00026 WASAPICapture::WASAPICapture() :
00027     m_BufferFrames( 0 ),
00028     m_cbDataSize( 0 ),
00029     m_cbHeaderSize( 0 ),
00030     m_cbFlushCounter( 0 ),
00031     m_dwQueueID( 0 ),
00032     m_DeviceStateChanged( nullptr ),
00033     m_AudioClient( nullptr ),
00034     m_AudioCaptureClient( nullptr ),
00035     m_SampleReadyAsyncResult( nullptr ),
00036     m_ContentStream( nullptr ),
00037     m_OutputStream( nullptr ),
00038     m_WAVDataWriter( nullptr ),
00039     m_PlotData( nullptr ),
00040     m_fWriting( false )
00041 {
00042     // Create events for sample ready or user stop
00043     m_SampleReadyEvent = CreateEventEx( nullptr, nullptr, 0, EVENT_ALL_ACCESS );
00044     if (nullptr == m_SampleReadyEvent)
00045     {
00046         ThrowIfFailed( HRESULT_FROM_WIN32( GetLastError() ) );
00047     }
00048
00049     if (!InitializeCriticalSectionEx( &m_CritSec, 0, 0 ))
00050     {
00051         ThrowIfFailed( HRESULT_FROM_WIN32( GetLastError() ) );
00052     }
00053
00054     m_DeviceStateChanged = ref new DeviceStateChangedEvent();
00055     if (nullptr == m_DeviceStateChanged)
00056     {
00057         ThrowIfFailed( E_OUTOFMEMORY );
00058     }
00059
00060     // Register MMCSS work queue
00061     HRESULT hr = S_OK;
00062     DWORD dwTaskID = 0;
00063
00064     hr = MFLockSharedWorkQueue( L"Capture", 0, &dwTaskID, &m_dwQueueID );
00065     if (FAILED( hr ))
00066     {
00067         ThrowIfFailed( hr );
00068     }
00069
00070     // Set the capture event work queue to use the MMCSS queue
00071     m_xSampleReady.SetQueueID( m_dwQueueID );
00072 }
00073
00074 //
00075 //  ~WASAPICapture()
00076 //
00077 WASAPICapture::~WASAPICapture()
00078 {
00079     SAFE_RELEASE( m_AudioClient );
00080     SAFE_RELEASE( m_AudioCaptureClient );
00081     SAFE_RELEASE( m_SampleReadyAsyncResult );
00082     SAFE_DELETE( m_DeviceStateChanged );
00083
00084     if (INVALID_HANDLE_VALUE != m_SampleReadyEvent)
00085     {
00086         CloseHandle( m_SampleReadyEvent );
00087         m_SampleReadyEvent = INVALID_HANDLE_VALUE;
00088     }
00089
00090     MFUnlockWorkQueue( m_dwQueueID );
00091
00092     m_ContentStream = nullptr;
00093     m_OutputStream = nullptr;
00094     m_WAVDataWriter = nullptr;
00095
00096     m_PlotData = nullptr;
00097
00098     DeleteCriticalSection( &m_CritSec );
00099 }
00100
00101 //
00102 //  InitializeAudioDeviceAsync()
00103 //
00104 //  Activates the default audio capture on a asynchronous callback thread.  This needs
00105 //  to be called from the main UI thread.
00106 //
00107 HRESULT WASAPICapture::InitializeAudioDeviceAsync()
00108 {
00109     IActivateAudioInterfaceAsyncOperation *asyncOp;
00110     HRESULT hr = S_OK;
00111
00112     // Get a string representing the Default Audio Capture Device
00113     m_DeviceIdString = MediaDevice::GetDefaultAudioCaptureId( Windows::Media::Devices::AudioDeviceRole::Default );
00114
00115     // This call must be made on the main UI thread.  Async operation will call back to
00116     // IActivateAudioInterfaceCompletionHandler::ActivateCompleted, which must be an agile interface implementation
00117     hr = ActivateAudioInterfaceAsync( m_DeviceIdString->Data(), __uuidof(IAudioClient2), nullptr, this, &asyncOp );
00118     if (FAILED( hr ))
00119     {
00120         m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
00121     }
00122
00123     SAFE_RELEASE( asyncOp );
00124     return hr;
00125 }
00126
00127 //
00128 //  ActivateCompleted()
00129 //
00130 //  Callback implementation of ActivateAudioInterfaceAsync function.  This will be called on MTA thread
00131 //  when results of the activation are available.
00132 //
00133 HRESULT WASAPICapture::ActivateCompleted( IActivateAudioInterfaceAsyncOperation *operation )
00134 {
00135     HRESULT hr = S_OK;
00136     HRESULT hrActivateResult = S_OK;
00137     IUnknown *punkAudioInterface = nullptr;
00138
00139     // Check for a successful activation result
00140     hr = operation->GetActivateResult( &hrActivateResult, &punkAudioInterface );
00141     if (SUCCEEDED( hr ) && SUCCEEDED( hrActivateResult ))
00142     {
00143         // Get the pointer for the Audio Client
00144         punkAudioInterface->QueryInterface( IID_PPV_ARGS(&m_AudioClient) );
00145         if (nullptr == m_AudioClient)
00146         {
00147             hr = E_FAIL;
00148             goto exit;
00149         }
00150
00151         hr = m_AudioClient->GetMixFormat( &m_MixFormat );
00152         if (FAILED( hr ))
00153         {
00154             goto exit;
00155         }
00156
00157         // convert from Float to PCM and from WAVEFORMATEXTENSIBLE to WAVEFORMATEX
00158         if ( (m_MixFormat->wFormatTag == WAVE_FORMAT_IEEE_FLOAT) ||
00159              ( (m_MixFormat->wFormatTag == WAVE_FORMAT_EXTENSIBLE) &&
00160                (reinterpret_cast<WAVEFORMATEXTENSIBLE *>(m_MixFormat)->SubFormat == KSDATAFORMAT_SUBTYPE_IEEE_FLOAT) ) )
00161         {
00162             m_MixFormat->wFormatTag = WAVE_FORMAT_PCM;
00163             m_MixFormat->wBitsPerSample = 16;
00164             m_MixFormat->nBlockAlign = m_MixFormat->nChannels * 2;    // (nChannels * wBitsPerSample) / 8
00165             m_MixFormat->nAvgBytesPerSec = m_MixFormat->nSamplesPerSec * m_MixFormat->nBlockAlign;
00166             m_MixFormat->cbSize = 0;
00167         }
00168
00169         // Initialize the AudioClient in Shared Mode with the user specified buffer
00170         hr = m_AudioClient->Initialize( AUDCLNT_SHAREMODE_SHARED,
00171                                         AUDCLNT_STREAMFLAGS_EVENTCALLBACK,
00172                                         200000,
00173                                         0,
00174                                         m_MixFormat,
00175                                         nullptr );
00176         if (FAILED( hr ))
00177         {
00178             goto exit;
00179         }
00180
00181         // Get the maximum size of the AudioClient Buffer
00182         hr = m_AudioClient->GetBufferSize( &m_BufferFrames );
00183         if (FAILED( hr ))
00184         {
00185             goto exit;
00186         }
00187
00188         // Get the capture client
00189         hr = m_AudioClient->GetService( __uuidof(IAudioCaptureClient), (void**) &m_AudioCaptureClient );
00190         if (FAILED( hr ))
00191         {
00192             goto exit;
00193         }
00194
00195         // Create Async callback for sample events
00196         hr = MFCreateAsyncResult( nullptr, &m_xSampleReady, nullptr, &m_SampleReadyAsyncResult );
00197         if (FAILED( hr ))
00198         {
00199             goto exit;
00200         }
00201
00202         // Sets the event handle that the system signals when an audio buffer is ready to be processed by the client
00203         hr = m_AudioClient->SetEventHandle( m_SampleReadyEvent );
00204         if (FAILED( hr ))
00205         {
00206             goto exit;
00207         }
00208
00209         // Create the visualization array
00210         hr = InitializeScopeData();
00211         if (FAILED( hr ))
00212         {
00213             goto exit;
00214         }
00215
00216         // Creates the WAV file.  If successful, will set the Initialized event
00217         hr = CreateWAVFile();
00218         if (FAILED( hr ))
00219         {
00220             goto exit;
00221         }
00222     }
00223
00224 exit:
00225     SAFE_RELEASE( punkAudioInterface );
00226
00227     if (FAILED( hr ))
00228     {
00229         m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
00230         SAFE_RELEASE( m_AudioClient );
00231         SAFE_RELEASE( m_AudioCaptureClient );
00232         SAFE_RELEASE( m_SampleReadyAsyncResult );
00233     }
00234
00235     // Need to return S_OK
00236     return S_OK;
00237 }
00238
00239 //
00240 //  CreateWAVFile()
00241 //
00242 //  Creates a WAV file in KnownFolders::MusicLibrary
00243 //
00244 HRESULT WASAPICapture::CreateWAVFile()
00245 {
00246     // Create the WAV file, appending a number if file already exists
00247     concurrency::task<StorageFile^>( KnownFolders::MusicLibrary->CreateFileAsync( AUDIO_FILE_NAME, CreationCollisionOption::GenerateUniqueName )).then(
00248         [this]( StorageFile^ file )
00249     {
00250         if (nullptr == file)
00251         {
00252             ThrowIfFailed( E_INVALIDARG );
00253         }
00254
00255         return file->OpenAsync( FileAccessMode::ReadWrite );
00256     })
00257
00258     // Then create a RandomAccessStream
00259     .then([this]( IRandomAccessStream^ stream )
00260     {
00261         if (nullptr == stream)
00262         {
00263             ThrowIfFailed( E_INVALIDARG );
00264         }
00265
00266         // Get the OutputStream for the file
00267         m_ContentStream = stream;
00268         m_OutputStream = m_ContentStream->GetOutputStreamAt(0);
00269
00270         // Create the DataWriter
00271         m_WAVDataWriter = ref new DataWriter( m_OutputStream );
00272         if (nullptr == m_WAVDataWriter)
00273         {
00274             ThrowIfFailed( E_OUTOFMEMORY );
00275         }
00276
00277         // Create the WAV header
00278         DWORD header[] = {
00279             FCC('RIFF'),        // RIFF header
00280             0,                  // Total size of WAV (will be filled in later)
00281             FCC('WAVE'),        // WAVE FourCC
00282             FCC('fmt '),        // Start of 'fmt ' chunk
00283             sizeof(WAVEFORMATEX) + m_MixFormat->cbSize      // Size of fmt chunk
00284         };
00285
00286         DWORD data[] = { FCC('data'), 0 };  // Start of 'data' chunk
00287
00288         auto headerBytes = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>(header), sizeof(header) );
00289         auto formatBytes = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>(m_MixFormat), sizeof(WAVEFORMATEX) );
00290         auto dataBytes = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>(data), sizeof(data) );
00291
00292         if ( (nullptr == headerBytes) || (nullptr == formatBytes) || (nullptr == dataBytes) )
00293         {
00294             ThrowIfFailed( E_OUTOFMEMORY );
00295         }
00296
00297         // Write the header
00298         m_WAVDataWriter->WriteBytes( headerBytes );
00299         m_WAVDataWriter->WriteBytes( formatBytes );
00300         m_WAVDataWriter->WriteBytes( dataBytes );
00301
00302         return m_WAVDataWriter->StoreAsync();
00303     })
00304
00305     // Wait for file data to be written to file
00306     .then([this]( unsigned int BytesWritten )
00307     {
00308         m_cbHeaderSize = BytesWritten;
00309         return m_WAVDataWriter->FlushAsync();
00310     })
00311
00312     // Our file is ready to go, so we can now signal that initialziation is finished
00313     .then([this]( bool f )
00314     {
00315         try
00316         {
00317             m_DeviceStateChanged->SetState( DeviceState::DeviceStateInitialized, S_OK, true );
00318         }
00319         catch (Platform::Exception ^e)
00320         {
00321             m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, e->HResult, true );
00322         }
00323     });
00324
00325     return S_OK;
00326 }
00327
00328 //
00329 //  FixWAVHeader()
00330 //
00331 //  The size values were not known when we originally wrote the header, so now go through and fix the values
00332 //
00333 HRESULT WASAPICapture::FixWAVHeader()
00334 {
00335     auto DataSizeByte = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>( &m_cbDataSize ), sizeof(DWORD) );
00336
00337     // Write the size of the 'data' chunk first
00338     IOutputStream^ OutputStream = m_ContentStream->GetOutputStreamAt( m_cbHeaderSize - sizeof(DWORD) );
00339     m_WAVDataWriter = ref new DataWriter( OutputStream );
00340     m_WAVDataWriter->WriteBytes( DataSizeByte );
00341
00342     concurrency::task<unsigned int>( m_WAVDataWriter->StoreAsync()).then(
00343         [this]( unsigned int BytesWritten )
00344     {
00345         DWORD cbTotalSize = m_cbDataSize + m_cbHeaderSize - 8;
00346         auto TotalSizeByte = ref new Platform::Array<BYTE>( reinterpret_cast<BYTE*>( &cbTotalSize ), sizeof(DWORD) );
00347
00348         // Write the total file size, minus RIFF chunk and size
00349         IOutputStream^ OutputStream = m_ContentStream->GetOutputStreamAt( sizeof(DWORD) );  // sizeof(DWORD) == sizeof(FOURCC)
00350         m_WAVDataWriter = ref new DataWriter( OutputStream );
00351         m_WAVDataWriter->WriteBytes( TotalSizeByte );
00352
00353         concurrency::task<unsigned int>( m_WAVDataWriter->StoreAsync()).then(
00354             [this]( unsigned int BytesWritten )
00355         {
00356             return m_WAVDataWriter->FlushAsync();
00357         })
00358
00359         .then(
00360             [this]( bool f )
00361         {
00362             m_DeviceStateChanged->SetState( DeviceState::DeviceStateStopped, S_OK, true );
00363         });
00364     });
00365
00366     return S_OK;
00367 }
00368
00369 //
00370 //  InitializeScopeData()
00371 //
00372 //  Setup data structures for sample visualizations
00373 //
00374 HRESULT WASAPICapture::InitializeScopeData()
00375 {
00376     HRESULT hr = S_OK;
00377
00378     m_cPlotDataFilled = 0;
00379     m_cPlotDataMax = (MILLISECONDS_TO_VISUALIZE * m_MixFormat->nSamplesPerSec) / 1000;
00380
00381     m_PlotData = ref new Platform::Array<int, 1>( m_cPlotDataMax + 1 );
00382     if (nullptr == m_PlotData)
00383     {
00384         return E_OUTOFMEMORY;
00385     }
00386
00387     // Only Support 16 bit Audio for now
00388     if (m_MixFormat->wBitsPerSample == 16)
00389     {
00390         m_PlotData[ m_cPlotDataMax ] = -32768;  // INT16_MAX
00391     }
00392     else
00393     {
00394         m_PlotData = nullptr;
00395         hr = S_FALSE;
00396     }
00397
00398     return hr;
00399 }
00400
00401 //
00402 //  StartCaptureAsync()
00403 //
00404 //  Starts asynchronous capture on a separate thread via MF Work Item
00405 //
00406 HRESULT WASAPICapture::StartCaptureAsync()
00407 {
00408     HRESULT hr = S_OK;
00409
00410     // We should be in the initialzied state if this is the first time through getting ready to capture.
00411     if (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateInitialized)
00412     {
00413         m_DeviceStateChanged->SetState( DeviceState::DeviceStateStarting, S_OK, true );
00414         return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xStartCapture, nullptr );
00415     }
00416
00417     // We are in the wrong state
00418     return E_NOT_VALID_STATE;
00419 }
00420
00421 //
00422 //  OnStartCapture()
00423 //
00424 //  Callback method to start capture
00425 //
00426 HRESULT WASAPICapture::OnStartCapture( IMFAsyncResult* pResult )
00427 {
00428     HRESULT hr = S_OK;
00429
00430     // Start the capture
00431     hr = m_AudioClient->Start();
00432     if (SUCCEEDED( hr ))
00433     {
00434         m_DeviceStateChanged->SetState( DeviceState::DeviceStateCapturing, S_OK, true );
00435         MFPutWaitingWorkItem( m_SampleReadyEvent, 0, m_SampleReadyAsyncResult, &m_SampleReadyKey );
00436     }
00437     else
00438     {
00439         m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
00440     }
00441
00442     return S_OK;
00443 }
00444
00445 //
00446 //  StopCaptureAsync()
00447 //
00448 //  Stop capture asynchronously via MF Work Item
00449 //
00450 HRESULT WASAPICapture::StopCaptureAsync()
00451 {
00452     if ( (m_DeviceStateChanged->GetState() != DeviceState::DeviceStateCapturing) &&
00453          (m_DeviceStateChanged->GetState() != DeviceState::DeviceStateInError) )
00454     {
00455         return E_NOT_VALID_STATE;
00456     }
00457
00458     m_DeviceStateChanged->SetState( DeviceState::DeviceStateStopping, S_OK, true );
00459
00460     return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xStopCapture, nullptr );
00461 }
00462
00463 //
00464 //  OnStopCapture()
00465 //
00466 //  Callback method to stop capture
00467 //
00468 HRESULT WASAPICapture::OnStopCapture( IMFAsyncResult* pResult )
00469 {
00470     // Stop capture by cancelling Work Item
00471     // Cancel the queued work item (if any)
00472     if (0 != m_SampleReadyKey)
00473     {
00474         MFCancelWorkItem( m_SampleReadyKey );
00475         m_SampleReadyKey = 0;
00476     }
00477
00478     m_AudioClient->Stop();
00479     SAFE_RELEASE( m_SampleReadyAsyncResult );
00480
00481     // If this is set, it means we writing from the memory buffer to the actual file asynchronously
00482     // Since a second call to StoreAsync() can cause an exception, don't queue this now, but rather
00483     // let the async operation completion handle the call.
00484     if (!m_fWriting)
00485     {
00486         m_DeviceStateChanged->SetState( DeviceState::DeviceStateFlushing, S_OK, true );
00487
00488         concurrency::task<unsigned int>( m_WAVDataWriter->StoreAsync()).then(
00489             [this]( unsigned int BytesWritten )
00490         {
00491             FinishCaptureAsync();
00492         });
00493     }
00494
00495     return S_OK;
00496 }
00497
00498 //
00499 //  FinishCaptureAsync()
00500 //
00501 //  Finalizes WAV file on a separate thread via MF Work Item
00502 //
00503 HRESULT WASAPICapture::FinishCaptureAsync()
00504 {
00505     // We should be flushing when this is called
00506     if (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateFlushing)
00507     {
00508         return MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xFinishCapture, nullptr );
00509     }
00510
00511     // We are in the wrong state
00512     return E_NOT_VALID_STATE;
00513 }
00514
00515 //
00516 //  OnFinishCapture()
00517 //
00518 //  Because of the asynchronous nature of the MF Work Queues and the DataWriter, there could still be
00519 //  a sample processing.  So this will get called to finalize the WAV header.
00520 //
00521 HRESULT WASAPICapture::OnFinishCapture( IMFAsyncResult* pResult )
00522 {
00523     // FixWAVHeader will set the DeviceStateStopped when all async tasks are complete
00524     return FixWAVHeader();
00525 }
00526
00527 //
00528 //  OnSampleReady()
00529 //
00530 //  Callback method when ready to fill sample buffer
00531 //
00532 HRESULT WASAPICapture::OnSampleReady( IMFAsyncResult* pResult )
00533 {
00534     HRESULT hr = S_OK;
00535
00536     hr = OnAudioSampleRequested( false );
00537
00538     if (SUCCEEDED( hr ))
00539     {
00540         // Re-queue work item for next sample
00541         if (m_DeviceStateChanged->GetState() ==  DeviceState::DeviceStateCapturing)
00542         {
00543             hr = MFPutWaitingWorkItem( m_SampleReadyEvent, 0, m_SampleReadyAsyncResult, &m_SampleReadyKey );
00544         }
00545     }
00546     else
00547     {
00548         m_DeviceStateChanged->SetState( DeviceState::DeviceStateInError, hr, true );
00549     }
00550
00551     return hr;
00552 }
00553
00554 //
00555 //  OnAudioSampleRequested()
00556 //
00557 //  Called when audio device fires m_SampleReadyEvent
00558 //
00559 HRESULT WASAPICapture::OnAudioSampleRequested( Platform::Boolean IsSilence )
00560 {
00561     HRESULT hr = S_OK;
00562     UINT32 FramesAvailable = 0;
00563     BYTE *Data = nullptr;
00564     DWORD dwCaptureFlags;
00565     UINT64 u64DevicePosition = 0;
00566     UINT64 u64QPCPosition = 0;
00567     DWORD cbBytesToCapture = 0;
00568
00569     EnterCriticalSection( &m_CritSec );
00570
00571     // If this flag is set, we have already queued up the async call to finialize the WAV header
00572     // So we don't want to grab or write any more data that would possibly give us an invalid size
00573     if ( (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateStopping) ||
00574          (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateFlushing) )
00575     {
00576         goto exit;
00577     }
00578
00579     // This should equal the buffer size when GetBuffer() is called
00580     hr = m_AudioCaptureClient->GetNextPacketSize( &FramesAvailable );
00581     if (FAILED( hr ))
00582     {
00583         goto exit;
00584     }
00585
00586     if (FramesAvailable > 0)
00587     {
00588         cbBytesToCapture = FramesAvailable * m_MixFormat->nBlockAlign;
00589
00590         // WAV files have a 4GB (0xFFFFFFFF) size limit, so likely we have hit that limit when we
00591         // overflow here.  Time to stop the capture
00592         if ( (m_cbDataSize + cbBytesToCapture) < m_cbDataSize )
00593         {
00594             StopCaptureAsync();
00595             goto exit;
00596         }
00597
00598         // Get sample buffer
00599         hr = m_AudioCaptureClient->GetBuffer( &Data, &FramesAvailable, &dwCaptureFlags, &u64DevicePosition, &u64QPCPosition );
00600         if (FAILED( hr ))
00601         {
00602             goto exit;
00603         }
00604
00605         if (dwCaptureFlags & AUDCLNT_BUFFERFLAGS_DATA_DISCONTINUITY)
00606         {
00607             // Pass down a discontinuity flag in case the app is interested and reset back to capturing
00608             m_DeviceStateChanged->SetState( DeviceState::DeviceStateDiscontinutity, S_OK, true );
00609             m_DeviceStateChanged->SetState( DeviceState::DeviceStateCapturing, S_OK, false );
00610         }
00611
00612         // Zero out sample if silence
00613         if ( (dwCaptureFlags & AUDCLNT_BUFFERFLAGS_SILENT) || IsSilence )
00614         {
00615             memset( Data, 0, FramesAvailable * m_MixFormat->nBlockAlign );
00616         }
00617
00618         // Store data in array
00619         auto dataByte = ref new Platform::Array<BYTE, 1>( Data, cbBytesToCapture );
00620
00621         // Release buffer back
00622         m_AudioCaptureClient->ReleaseBuffer( FramesAvailable );
00623
00624         // Update plotter data
00625         ProcessScopeData( Data, cbBytesToCapture );
00626
00627         // Write File and async store
00628         m_WAVDataWriter->WriteBytes( dataByte );
00629
00630         // Increase the size of our 'data' chunk and flush counter.  m_cbDataSize needs to be accurate
00631         // Its OK if m_cbFlushCounter is an approximation
00632         m_cbDataSize += cbBytesToCapture;
00633         m_cbFlushCounter += cbBytesToCapture;
00634
00635         if ( (m_cbFlushCounter > ( m_MixFormat->nAvgBytesPerSec * FLUSH_INTERVAL_SEC )) && !m_fWriting )
00636         {
00637             // Set this flag when about to commit the async storage operation.  We don't want to
00638             // accidently call stop and finalize the WAV header or run into a scenario where the
00639             // store operation takes longer than FLUSH_INTERVAL_SEC as multiple concurrent calls
00640             // to StoreAsync() can cause an exception
00641             m_fWriting = true;
00642
00643             // Reset the counter now since we can process more samples during the async callback
00644             m_cbFlushCounter = 0;
00645
00646             concurrency::task<unsigned int>( m_WAVDataWriter->StoreAsync()).then(
00647                 [this]( unsigned int BytesWritten )
00648             {
00649                 m_fWriting = false;
00650
00651                 // We need to check for StopCapture while we are flusing the file.  If it has come through, then we
00652                 // can go ahead and call FinisheCaptureAsync() to write the WAV header
00653                 if (m_DeviceStateChanged->GetState() == DeviceState::DeviceStateStopping)
00654                 {
00655                     m_DeviceStateChanged->SetState( DeviceState::DeviceStateFlushing, S_OK, true );
00656                     FinishCaptureAsync();
00657                 }
00658             });
00659         }
00660     }
00661
00662 exit:
00663     LeaveCriticalSection( &m_CritSec );
00664
00665     return hr;
00666 }
00667
00668 //
00669 //  ProcessScopeData()
00670 //
00671 //  Copies sample data to the buffer array and fires the event
00672 //
00673 HRESULT WASAPICapture::ProcessScopeData( BYTE* pData, DWORD cbBytes )
00674 {
00675     HRESULT hr = S_OK;
00676
00677     // We don't have a valid pointer array, so return.  This could be the case if we aren't
00678     // dealing with 16-bit audio
00679     if (m_PlotData == nullptr)
00680     {
00681         return S_FALSE;
00682     }
00683
00684     DWORD dwNumPoints = cbBytes / m_MixFormat->nChannels / (m_MixFormat->wBitsPerSample / 8);
00685
00686     // Read the 16-bit samples from channel 0
00687     INT16 *pi16 = (INT16*)pData;
00688
00689     for ( DWORD i = 0; m_cPlotDataFilled < m_cPlotDataMax && i < dwNumPoints; i++ )
00690     {
00691         m_PlotData[ m_cPlotDataFilled ] = *pi16;
00692         pi16 += m_MixFormat->nChannels;
00693
00694         m_cPlotDataFilled++;
00695     }
00696
00697     // Send off the event and get ready for the next set of samples
00698     if (m_cPlotDataFilled == m_cPlotDataMax)
00699     {
00700         ComPtr<IUnknown> spUnknown;
00701         ComPtr<CAsyncState> spState = Make<CAsyncState>( m_PlotData, m_cPlotDataMax + 1 );
00702
00703         hr = spState.As( &spUnknown );
00704         if (SUCCEEDED( hr ))
00705         {
00706             MFPutWorkItem2( MFASYNC_CALLBACK_QUEUE_MULTITHREADED, 0, &m_xSendScopeData, spUnknown.Get() );
00707         }
00708
00709         m_cPlotDataFilled = 0;
00710     }
00711
00712     return hr;
00713 }
00714
00715 //
00716 //  OnSendScopeData()
00717 //
00718 //  Callback method to stop capture
00719 //
00720 HRESULT WASAPICapture::OnSendScopeData( IMFAsyncResult* pResult )
00721 {
00722     HRESULT hr = S_OK;
00723     CAsyncState *pState = nullptr;
00724
00725     hr = pResult->GetState( reinterpret_cast<IUnknown**>(&pState) );
00726     if (SUCCEEDED( hr ))
00727     {
00728         PlotDataReadyEvent::SendEvent( reinterpret_cast<Platform::Object^>(this), pState->m_Data , pState->m_Size );
00729     }
00730
00731     SAFE_RELEASE( pState );
00732
00733     return S_OK;
00734 }
00735
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/LonLatController.h Source File

  • Direct3D resource loading

LonLatController.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007 ////----------------------------------------------------------------------
00008
00009 #pragma once
00010
00011 #define LONLAT_GAIN    0.004f // sensitivity adjustment for mouse/touch
00012 #define LONLATKEY_GAIN 0.04f // sensitivity adjustment for keys
00013
00014 // A basic longitude/latitude controller class for navigation on a sphere.
00015 // It integrates touch, WASD keyboard, and mouse pointer movement into a
00016 // single unified controller.
00017 ref class LonLatController
00018 {
00019 private:
00020     // properties of the controller object
00021     float m_radius; // Distance from center of sphere
00022     float m_longitude; // Left-right coordinate on the sphere
00023     float m_latitude; // pole-to-pole coordinate on the sphere
00024
00025     // properties of the LonLat control
00026     BOOL m_lonLatInUse; // the look control is in use
00027     float3 m_lonLatCommand; // the net command from the move control
00028     uint32 m_lonLatPointerID; // id of the pointer in this control
00029     float2 m_lonLatLastPoint; // last point (from last frame)
00030     float2 m_lonLatLastDelta; // for smoothing
00031
00032     bool m_forward, m_back; // states for movement
00033     bool m_left, m_right;
00034     bool m_up, m_down;
00035
00036 internal:
00037     // Methods to get input from the UI pointers
00038     void OnPointerPressed(
00039         _In_ Windows::UI::Core::CoreWindow^ sender,
00040         _In_ Windows::UI::Core::PointerEventArgs^ args
00041         );
00042
00043     void OnPointerMoved(
00044         _In_ Windows::UI::Core::CoreWindow^ sender,
00045         _In_ Windows::UI::Core::PointerEventArgs^ args
00046         );
00047
00048     void OnPointerReleased(
00049         _In_ Windows::UI::Core::CoreWindow^ sender,
00050         _In_ Windows::UI::Core::PointerEventArgs^ args
00051         );
00052
00053     void OnKeyDown(
00054         _In_ Windows::UI::Core::CoreWindow^ sender,
00055         _In_ Windows::UI::Core::KeyEventArgs^ args
00056         );
00057
00058     void OnKeyUp(
00059         _In_ Windows::UI::Core::CoreWindow^ sender,
00060         _In_ Windows::UI::Core::KeyEventArgs^ args
00061         );
00062
00063     // set up the Controls supported by this controller
00064     void Initialize(_In_ Windows::UI::Core::CoreWindow^ window);
00065
00066     // accessor to set position of controller
00067     void SetPosition(_In_ float3 pos);
00068
00069     // accessor to set position of controller
00070     void SetOrientation(_In_ float latitude, _In_ float longitude);
00071
00072     // returns the position of the controller object
00073     float3 get_Position();
00074
00075     // returns the point at which the camera controller is facing
00076     float3 get_LookPoint();
00077
00078     void Update();
00079
00080     // methods to save and restore state
00081     void SaveInternalState(_In_ Windows::Foundation::Collections::IPropertySet^ state);
00082     void LoadInternalState(_In_ Windows::Foundation::Collections::IPropertySet^ state);
00083 };
00084
00085
00086
00087
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/Transliteration.xaml.cpp Source File

  • Extended Linguistic Services (ELS)
  • C++

Transliteration.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Transliteration.xaml.cpp
00013 // Implementation of the Transliteration class
00014 //
00015
00016 #include "pch.h"
00017 #include "Transliteration.xaml.h"
00018
00019 #include "elsutil.h"
00020
00021 using namespace SDKSample::ELS;
00022
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 Transliteration::Transliteration()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void Transliteration::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042 }
00043
00044
00045 void SDKSample::ELS::Transliteration::Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00046 {
00047     Button^ b = safe_cast<Button^>(sender);
00048     if (b != nullptr)
00049     {
00050         auto input = TextInput->Text;
00051     auto output = TransliterateFromCyrillicToLatin(input->Data());
00052     TextOutput->Text = ref new Platform::String(output.c_str());
00053     }
00054 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::ToastContent::ToastText02 Member List

This is the complete list of members for NotificationsExtensions::ToastContent::ToastText02, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
Audio | NotificationsExtensions::ToastContent::ToastNotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
CreateNotification() | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline]
Duration | NotificationsExtensions::ToastContent::ToastNotificationBase |
GetContent() | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline, virtual]
GetContent() | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
Launch | NotificationsExtensions::ToastContent::ToastNotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBodyWrap | NotificationsExtensions::ToastContent::ToastText02 |
TextFields | NotificationsExtensions::NotificationBase |
TextHeading | NotificationsExtensions::ToastContent::ToastText02 |
ToastNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline]
ToastNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::ToastContent::ToastNotificationBase | [inline]
ToastText02() | NotificationsExtensions::ToastContent::ToastText02 | [inline]
ToastText02() | NotificationsExtensions::ToastContent::ToastText02 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/MainPage.xaml.h Source File

  • XAML WebView control

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/common/suspensionmanager.h Source File

  • Reading and writing data
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/SampleOverlay.h Source File

  • Direct2D convolve matrix effect

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S6_DeviceStatus.xaml.h Source File

  • Portable device API

S6_DeviceStatus.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // S6_DeviceStatus.xaml.h
00013 // Declaration of the S6_DeviceStatus class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "S6_DeviceStatus.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace PortableDeviceCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class S6_DeviceStatus sealed
00031         {
00032         public:
00033             S6_DeviceStatus();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038         private:
00039             void Run_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void ShowDeviceSelectorAsync();
00041             void DeviceList_Tapped(Platform::Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e);
00042             void DisplayDeviceStatusAsync(Windows::Devices::Enumeration::DeviceInformation^ deviceInfoElement);
00043             void DisplayDeviceStatusServiceProperties(_In_ IPortableDeviceService* service);
00044
00045             MainPage^ rootPage;
00046             // Contains the device information used for populating the device selection list
00047             Windows::Devices::Enumeration::DeviceInformationCollection^ _deviceInfoCollection;
00048         };
00049
00050         // Delegate for IPortableDeviceServiceOpenCallback::OnComplete
00051         [uuid("bced49c8-8efe-41ed-960b-61313abd47a9")]
00052         delegate void OnServiceOpenComplete(HRESULT result);
00053     }
00054 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/common/suspensionmanager.cpp Source File

  • XAML WebView control
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML accessibility/C++/pch.cpp Source File

  • XAML accessibility

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/SampleOverlay.h Source File

  • Direct2D printing images and effects

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.h Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Decoder

decoder.h

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // decoder.h
00004 // Implements the MPEG-1 decoder.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015 #pragma once
00016 #include <wrl\implements.h>
00017 #include <windows.media.h>
00018
00019 #include <mftransform.h>
00020 #include <mfapi.h>
00021 #include <mferror.h>
00022 #include <assert.h>
00023
00024 const DWORD MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12;       // Minimum length of the video sequence header.
00025 static const REFERENCE_TIME INVALID_TIME = _I64_MAX;    //  Not really invalid but unlikely enough for sample code.
00026
00027 template <class T> void SafeRelease(T **ppT)
00028 {
00029     if (*ppT)
00030     {
00031         (*ppT)->Release();
00032         *ppT = NULL;
00033     }
00034 }
00035
00036
00037 //-------------------------------------------------------------------
00038 // CStreamState class.
00039 // Provides state machine for picture start codes and timestamps.
00040 //
00041 //  We need to know:
00042 //
00043 //    - The time stamp to associate with a picture start code
00044 //    - The next time stamp
00045 //
00046 //-------------------------------------------------------------------
00047
00048 class CStreamState
00049 {
00050 private:
00051
00052     DWORD m_cbBytes;    // Number of valid bytes of start code so far
00053
00054     struct
00055     {
00056         bool           bValid;
00057         REFERENCE_TIME rt;
00058     } m_arTS[4];        // Array of all the timestamps.
00059                         // m_cbBytes+1 entries are valid.
00060
00061     REFERENCE_TIME m_rt;
00062
00063     BYTE m_bGOPData[4];
00064
00065     DWORD m_dwTimeCode;
00066     DWORD m_dwNextTimeCode;
00067
00068 public:
00069     CStreamState()
00070     {
00071         Reset();
00072     }
00073
00074     //  Returns true if a start code was identifed
00075     bool NextByte(BYTE bData);
00076     void TimeStamp(REFERENCE_TIME rt);
00077     void Reset();
00078
00079     REFERENCE_TIME PictureTime(DWORD *pdwTimeCode) const
00080     {
00081         *pdwTimeCode = m_dwTimeCode;
00082         return m_rt;
00083     }
00084 };
00085
00086
00087
00088 //-------------------------------------------------------------------
00089 // CDecoder
00090 //
00091 // Implements the MPEG-1 "decoder" MFT.
00092 //
00093 // The decoder outputs RGB-32 only.
00094 //
00095 // Note: This MFT is derived from a sample that used to ship in the
00096 // DirectX SDK.
00097 //-------------------------------------------------------------------
00098 #include "MPEG1Decoder.h"
00099
00100 class CDecoder
00101     : public Microsoft::WRL::RuntimeClass<
00102            Microsoft::WRL::RuntimeClassFlags< Microsoft::WRL::RuntimeClassType::WinRtClassicComMix >,
00103            ABI::Windows::Media::IMediaExtension,
00104            IMFTransform>
00105 {
00106     InspectableClass(RuntimeClass_MPEG1Decoder_MPEG1Decoder, BaseTrust)
00107
00108 public:
00109     CDecoder();
00110     ~CDecoder();
00111
00112     // IMediaExtension
00113     IFACEMETHOD (SetProperties) (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration);
00114
00115     // IMFTransform methods
00116     STDMETHODIMP GetStreamLimits(
00117         DWORD   *pdwInputMinimum,
00118         DWORD   *pdwInputMaximum,
00119         DWORD   *pdwOutputMinimum,
00120         DWORD   *pdwOutputMaximum
00121     );
00122
00123     STDMETHODIMP GetStreamCount(
00124         DWORD   *pcInputStreams,
00125         DWORD   *pcOutputStreams
00126     );
00127
00128     STDMETHODIMP GetStreamIDs(
00129         DWORD   dwInputIDArraySize,
00130         DWORD   *pdwInputIDs,
00131         DWORD   dwOutputIDArraySize,
00132         DWORD   *pdwOutputIDs
00133     );
00134
00135     STDMETHODIMP GetInputStreamInfo(
00136         DWORD                     dwInputStreamID,
00137         MFT_INPUT_STREAM_INFO *   pStreamInfo
00138     );
00139
00140     STDMETHODIMP GetOutputStreamInfo(
00141         DWORD                     dwOutputStreamID,
00142         MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00143     );
00144
00145     STDMETHODIMP GetAttributes(IMFAttributes** pAttributes);
00146
00147     STDMETHODIMP GetInputStreamAttributes(
00148         DWORD           dwInputStreamID,
00149         IMFAttributes   **ppAttributes
00150     );
00151
00152     STDMETHODIMP GetOutputStreamAttributes(
00153         DWORD           dwOutputStreamID,
00154         IMFAttributes   **ppAttributes
00155     );
00156
00157     STDMETHODIMP DeleteInputStream(DWORD dwStreamID);
00158
00159     STDMETHODIMP AddInputStreams(
00160         DWORD   cStreams,
00161         DWORD   *adwStreamIDs
00162     );
00163
00164     STDMETHODIMP GetInputAvailableType(
00165         DWORD           dwInputStreamID,
00166         DWORD           dwTypeIndex, // 0-based
00167         IMFMediaType    **ppType
00168     );
00169
00170     STDMETHODIMP GetOutputAvailableType(
00171         DWORD           dwOutputStreamID,
00172         DWORD           dwTypeIndex, // 0-based
00173         IMFMediaType    **ppType
00174     );
00175
00176     STDMETHODIMP SetInputType(
00177         DWORD           dwInputStreamID,
00178         IMFMediaType    *pType,
00179         DWORD           dwFlags
00180     );
00181
00182     STDMETHODIMP SetOutputType(
00183         DWORD           dwOutputStreamID,
00184         IMFMediaType    *pType,
00185         DWORD           dwFlags
00186     );
00187
00188     STDMETHODIMP GetInputCurrentType(
00189         DWORD           dwInputStreamID,
00190         IMFMediaType    **ppType
00191     );
00192
00193     STDMETHODIMP GetOutputCurrentType(
00194         DWORD           dwOutputStreamID,
00195         IMFMediaType    **ppType
00196     );
00197
00198     STDMETHODIMP GetInputStatus(
00199         DWORD           dwInputStreamID,
00200         DWORD           *pdwFlags
00201     );
00202
00203     STDMETHODIMP GetOutputStatus(DWORD *pdwFlags);
00204
00205     STDMETHODIMP SetOutputBounds(
00206         LONGLONG        hnsLowerBound,
00207         LONGLONG        hnsUpperBound
00208     );
00209
00210     STDMETHODIMP ProcessEvent(
00211         DWORD              dwInputStreamID,
00212         IMFMediaEvent      *pEvent
00213     );
00214
00215     STDMETHODIMP ProcessMessage(
00216         MFT_MESSAGE_TYPE    eMessage,
00217         ULONG_PTR           ulParam
00218     );
00219
00220     STDMETHODIMP ProcessInput(
00221         DWORD               dwInputStreamID,
00222         IMFSample           *pSample,
00223         DWORD               dwFlags
00224     );
00225
00226     STDMETHODIMP ProcessOutput(
00227         DWORD                   dwFlags,
00228         DWORD                   cOutputBufferCount,
00229         MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
00230         DWORD                   *pdwStatus
00231     );
00232
00233 protected:
00234
00235     // HasPendingOutput: Returns TRUE if the MFT is holding an input sample.
00236     BOOL HasPendingOutput() const { return m_pBuffer != NULL; }
00237
00238     // IsValidInputStream: Returns TRUE if dwInputStreamID is a valid input stream identifier.
00239     BOOL IsValidInputStream(DWORD dwInputStreamID) const
00240     {
00241         return dwInputStreamID == 0;
00242     }
00243
00244     // IsValidOutputStream: Returns TRUE if dwOutputStreamID is a valid output stream identifier.
00245     BOOL IsValidOutputStream(DWORD dwOutputStreamID) const
00246     {
00247         return dwOutputStreamID == 0;
00248     }
00249
00250     //  Internal processing routine
00251     HRESULT InternalProcessOutput(IMFSample *pSample, IMFMediaBuffer *pOutputBuffer);
00252     HRESULT Process();
00253     HRESULT OnCheckInputType(IMFMediaType *pmt);
00254     HRESULT OnCheckOutputType(IMFMediaType *pmt);
00255     HRESULT OnSetInputType(IMFMediaType *pmt);
00256     HRESULT OnSetOutputType(IMFMediaType *pmt);
00257     HRESULT OnDiscontinuity();
00258     HRESULT AllocateStreamingResources();
00259     HRESULT FreeStreamingResources();
00260     HRESULT OnFlush();
00261
00262
00263 protected:
00264
00265     CRITICAL_SECTION        m_critSec;
00266
00267     //  Streaming locals
00268     IMFMediaType            *m_pInputType;              // Input media type.
00269     IMFMediaType            *m_pOutputType;             // Output media type.
00270
00271     IMFMediaBuffer          *m_pBuffer;
00272     BYTE *                  m_pbData;
00273     DWORD                   m_cbData;
00274
00275     // Fomat information
00276     UINT32                      m_imageWidthInPixels;
00277     UINT32                      m_imageHeightInPixels;
00278     MFRatio                     m_frameRate;
00279     DWORD                       m_cbImageSize;              // Image size, in bytes.
00280
00281     //  Fabricate timestamps based on the average time per from if there isn't one in the stream
00282     REFERENCE_TIME          m_rtFrame;
00283     UINT64                  m_rtLength;
00284
00285     //  Current state info
00286     CStreamState            m_StreamState;
00287     bool                    m_bPicture;
00288     bool                    m_bLowLatencyMode;
00289 };
00290
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ViewModelBase.cpp Source File

  • Hilo C++
  • Hilo

ViewModelBase.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "ViewModelBase.h"
00009 #include "ExceptionPolicy.h"
00010
00011 using namespace Hilo;
00012 using namespace Platform;
00013 using namespace std;
00014 using namespace Windows::Foundation::Collections;
00015 using namespace Windows::UI::Xaml::Navigation;
00016
00017 ViewModelBase::ViewModelBase(shared_ptr<ExceptionPolicy> exceptionPolicy) : m_exceptionPolicy(exceptionPolicy), m_isAppBarEnabled(false),
00018     m_isAppBarOpen(false), m_isAppBarSticky(false)
00019 {
00020 }
00021
00022 bool ViewModelBase::IsAppBarEnabled::get()
00023 {
00024     return m_isAppBarEnabled;
00025 }
00026
00027 void ViewModelBase::IsAppBarEnabled::set(bool value)
00028 {
00029     if (m_isAppBarEnabled != value)
00030     {
00031         m_isAppBarEnabled = value;
00032         OnPropertyChanged("IsAppBarEnabled");
00033     }
00034 }
00035
00036 bool ViewModelBase::IsAppBarOpen::get()
00037 {
00038     return m_isAppBarOpen;
00039 }
00040
00041 void ViewModelBase::IsAppBarOpen::set(bool value)
00042 {
00043     if (m_isAppBarOpen != value)
00044     {
00045         m_isAppBarOpen = value;
00046         OnPropertyChanged("IsAppBarOpen");
00047     }
00048 }
00049
00050 bool ViewModelBase::IsAppBarSticky::get()
00051 {
00052     return m_isAppBarSticky;
00053 }
00054
00055 void ViewModelBase::IsAppBarSticky::set(bool value)
00056 {
00057     if (m_isAppBarSticky != value)
00058     {
00059         m_isAppBarSticky = value;
00060         OnPropertyChanged("IsAppBarSticky");
00061     }
00062 }
00063
00064 void ViewModelBase::OnNavigatedTo(NavigationEventArgs^ e)
00065 {
00066 }
00067
00068 void ViewModelBase::OnNavigatedFrom(NavigationEventArgs^ e)
00069 {
00070 }
00071
00072 void ViewModelBase::LoadState(IMap<String^, Object^>^ stateMap)
00073 {
00074 }
00075
00076 void ViewModelBase::SaveState(IMap<String^, Object^>^ stateMap)
00077 {
00078 }
00079
00080 void ViewModelBase::GoBack()
00081 {
00082     NavigateBack();
00083 }
00084
00085 void ViewModelBase::GoHome()
00086 {
00087     NavigateHome();
00088 }
00089
00090
00091 void ViewModelBase::GoToPage(PageType page, Object^ parameter)
00092 {
00093     NavigateToPage(page, parameter);
00094 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario1.xaml.h Source File

  • HttpClient

Scenario1.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "HttpRequest.h"
00022
00023 namespace SDKSample
00024 {
00025     namespace HttpClientSample
00026     {
00027         /// <summary>
00028         /// An empty page that can be used on its own or navigated to within a Frame.
00029         /// </summary>
00030         [ Windows::Foundation::Metadata::WebHostHidden ]
00031         public ref class Scenario1 sealed
00032         {
00033         public:
00034             Scenario1();
00035
00036         protected:
00037             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Web::HttpRequest httpRequest;
00042             concurrency::cancellation_token_source cancellationTokenSource;
00043             void Start_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044             void Cancel_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045             void DisplayTextResult(const std::wstring& response, Windows::UI::Xaml::Controls::TextBox^ output);
00046         };
00047     }
00048 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/common/suspensionmanager.cpp Source File

  • Application data
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ScreenQuadVertex Member List

This is the complete list of members for ScreenQuadVertex, including all inherited members.
pos | ScreenQuadVertex
tex | ScreenQuadVertex
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario3.xaml.cpp Source File

  • Search contract

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::SearchContract;
00020
00021 using namespace std;
00022 using namespace Platform;
00023 using namespace Windows::ApplicationModel::Search;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 Scenario3::Scenario3()
00030 {
00031     InitializeComponent();
00032     searchPane = SearchPane::GetForCurrentView();
00033 }
00034
00035 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     MainPage::Current->NotifyUser("Use the search pane to submit a query", NotifyType::StatusMessage);
00038     // This event should be registered when your app first creates its main window in App::OnWindowCreated().
00039     token = searchPane->SuggestionsRequested += ref new TypedEventHandler<SearchPane^, SearchPaneSuggestionsRequestedEventArgs^>(this, &Scenario3::OnSearchPaneSuggestionsRequested);
00040 }
00041
00042 void Scenario3::OnNavigatedFrom(NavigationEventArgs^ e)
00043 {
00044     searchPane->SuggestionsRequested -= token;
00045 }
00046
00047 void Scenario3::OnSearchPaneSuggestionsRequested(SearchPane^ sender, SearchPaneSuggestionsRequestedEventArgs^ e)
00048 {
00049     // List of Japanese city/ward names
00050     static wstring suggestionList[] =
00051         {
00052             L"\u7279\u5225\u533a\u90e8", L"\u6a2a\u6d5c\u5e02", L"\u5927\u962a\u5e02", L"\u540d\u53e4\u5c4b\u5e02", L"\u672d\u5e4c\u5e02", L"\u795e\u6238\u5e02",
00053             L"\u4eac\u90fd\u5e02", L"\u798f\u5ca1\u5e02", L"\u5ddd\u5d0e\u5e02", L"\u3055\u3044\u305f\u307e\u5e02", L"\u5e83\u5cf6\u5e02", L"\u4ed9\u53f0\u5e02",
00054             L"\u5317\u4e5d\u5dde\u5e02", L"\u5343\u8449\u5e02", L"\u4e16\u7530\u8c37\u533a", L"\u583a\u5e02", L"\u65b0\u6f5f\u5e02", L"\u6d5c\u677e\u5e02",
00055             L"\u718a\u672c\u5e02", L"\u76f8\u6a21\u539f\u5e02", L"\u7df4\u99ac\u533a", L"\u9759\u5ca1\u5e02", L"\u5ca1\u5c71\u5e02", L"\u5927\u7530\u533a",
00056             L"\u8db3\u7acb\u533a", L"\u6c5f\u6238\u5ddd\u533a", L"\u8239\u6a4b\u5e02", L"\u9e7f\u5150\u5cf6\u5e02", L"\u516b\u738b\u5b50\u5e02", L"\u6749\u4e26\u533a",
00057             L"\u59eb\u8def\u5e02", L"\u677f\u6a4b\u533a", L"\u677e\u5c71\u5e02", L"\u5b87\u90fd\u5bae\u5e02", L"\u6771\u5927\u962a\u5e02", L"\u5ddd\u53e3\u5e02",
00058             L"\u677e\u6238\u5e02", L"\u897f\u5bae\u5e02", L"\u5009\u6577\u5e02", L"\u5e02\u5ddd\u5e02", L"\u5927\u5206\u5e02", L"\u91d1\u6ca2\u5e02",
00059             L"\u798f\u5c71\u5e02", L"\u6c5f\u6771\u533a", L"\u5c3c\u5d0e\u5e02", L"\u9577\u5d0e\u5e02", L"\u845b\u98fe\u533a", L"\u753a\u7530\u5e02",
00060             L"\u5bcc\u5c71\u5e02", L"\u8c4a\u7530\u5e02", L"\u9ad8\u677e\u5e02", L"\u6a2a\u9808\u8cc0\u5e02", L"\u5c90\u961c\u5e02", L"\u85e4\u6ca2\u5e02",
00061             L"\u679a\u65b9\u5e02", L"\u67cf\u5e02", L"\u5bae\u5d0e\u5e02", L"\u8c4a\u4e2d\u5e02", L"\u9577\u91ce\u5e02", L"\u8c4a\u6a4b\u5e02",
00062             L"\u4e00\u5bae\u5e02", L"\u5ca1\u5d0e\u5e02", L"\u9ad8\u5d0e\u5e02", L"\u548c\u6b4c\u5c71\u5e02", L"\u5948\u826f\u5e02", L"\u54c1\u5ddd\u533a",
00063             L"\u9ad8\u69fb\u5e02", L"\u5439\u7530\u5e02", L"\u65ed\u5ddd\u5e02", L"\u9ad8\u77e5\u5e02", L"\u5ddd\u8d8a\u5e02", L"\u3044\u308f\u304d\u5e02",
00064             L"\u6240\u6ca2\u5e02", L"\u524d\u6a4b\u5e02", L"\u90e1\u5c71\u5e02", L"\u5927\u6d25\u5e02", L"\u5317\u533a", L"\u8d8a\u8c37\u5e02",
00065             L"\u65b0\u5bbf\u533a", L"\u79cb\u7530\u5e02", L"\u90a3\u8987\u5e02", L"\u4e2d\u91ce\u533a", L"\u56db\u65e5\u5e02\u5e02", L"\u6625\u65e5\u4e95\u5e02",
00066             L"\u4e45\u7559\u7c73\u5e02", L"\u9752\u68ee\u5e02", L"\u76db\u5ca1\u5e02", L"\u798f\u5cf6\u5e02", L"\u660e\u77f3\u5e02", L"\u6d25\u5e02",
00067             L"\u8c4a\u5cf6\u533a", L"\u9577\u5ca1\u5e02", L"\u4e0b\u95a2\u5e02", L"\u5e02\u539f\u5e02", L"\u51fd\u9928\u5e02", L"\u8328\u6728\u5e02",
00068             L"\u6c34\u6238\u5e02", L"\u76ee\u9ed2\u533a", L"\u516b\u5c3e\u5e02", L"\u52a0\u53e4\u5ddd\u5e02", L"\u798f\u4e95\u5e02", L"\u5fb3\u5cf6\u5e02",
00069             L"\u4f50\u4e16\u4fdd\u5e02", L"\u5e73\u585a\u5e02", L"\u5e9c\u4e2d\u5e02", L"\u5c71\u5f62\u5e02", L"\u5bcc\u58eb\u5e02", L"\u58a8\u7530\u533a",
00070             L"\u8349\u52a0\u5e02", L"\u677e\u672c\u5e02", L"\u5449\u5e02", L"\u5bdd\u5c4b\u5ddd\u5e02", L"\u4f50\u8cc0\u5e02", L"\u516b\u6238\u5e02",
00071             L"\u6625\u65e5\u90e8\u5e02", L"\u8305\u30f6\u5d0e\u5e02", L"\u5927\u548c\u5e02", L"\u5b9d\u585a\u5e02", L"\u539a\u6728\u5e02", L"\u4e0a\u5c3e\u5e02",
00072             L"\u8abf\u5e03\u5e02", L"\u592a\u7530\u5e02", L"\u3064\u304f\u3070\u5e02", L"\u4f0a\u52e2\u5d0e\u5e02", L"\u6587\u4eac\u533a", L"\u6e2f\u533a",
00073             L"\u6e0b\u8c37\u533a", L"\u8352\u5ddd\u533a", L"\u4e0a\u8d8a\u5e02", L"\u718a\u8c37\u5e02", L"\u6cbc\u6d25\u5e02", L"\u9234\u9e7f\u5e02",
00074             L"\u5cb8\u548c\u7530\u5e02", L"\u7532\u5e9c\u5e02", L"\u5c0f\u7530\u539f\u5e02", L"\u9ce5\u53d6\u5e02", L"\u5c71\u53e3\u5e02", L"\u897f\u6771\u4eac\u5e02",
00075             L"\u4f0a\u4e39\u5e02", L"\u677e\u6c5f\u5e02", L"\u65e5\u7acb\u5e02", L"\u6771\u5e83\u5cf6\u5e02", L"\u516b\u5343\u4ee3\u5e02", L"\u5b87\u6cbb\u5e02",
00076             L"\u5c0f\u5e73\u5e02", L"\u4e09\u9df9\u5e02", L"\u548c\u6cc9\u5e02", L"\u5f18\u524d\u5e02", L"\u8c4a\u5ddd\u5e02", L"\u91e7\u8def\u5e02",
00077             L"\u7acb\u5ddd\u5e02", L"\u65e5\u91ce\u5e02", L"\u5b89\u57ce\u5e02", L"\u9ad8\u5ca1\u5e02", L"\u53f0\u6771\u533a", L"\u938c\u5009\u5e02",
00078             L"\u5b87\u90e8\u5e02", L"\u82eb\u5c0f\u7267\u5e02", L"\u4f50\u5009\u5e02", L"\u79e6\u91ce\u5e02", L"\u90fd\u57ce\u5e02", L"\u78d0\u7530\u5e02",
00079             L"\u677e\u962a\u5e02", L"\u5e2f\u5e83\u5e02", L"\u4eca\u6cbb\u5e02", L"\u897f\u5c3e\u5e02", L"\u6d66\u5b89\u5e02", L"\u5c0f\u5c71\u5e02",
00080             L"\u7fd2\u5fd7\u91ce\u5e02", L"\u6d41\u5c71\u5e02", L"\u5927\u57a3\u5e02", L"\u77f3\u5dfb\u5e02", L"\u4e0a\u7530\u5e02", L"\u65b0\u5ea7\u5e02",
00081             L"\u3072\u305f\u3061\u306a\u304b\u5e02", L"\u5ddd\u897f\u5e02", L"\u72ed\u5c71\u5e02", L"\u91ce\u7530\u5e02", L"\u8db3\u5229\u5e02",
00082             L"\u4e45\u559c\u5e02", L"\u6771\u6751\u5c71\u5e02", L"\u5165\u9593\u5e02", L"\u5468\u5357\u5e02", L"\u7c73\u5b50\u5e02", L"\u591a\u6469\u5e02",
00083             L"\u5c0f\u7267\u5e02", L"\u5b88\u53e3\u5e02", L"\u5208\u8c37\u5e02", L"\u5404\u52d9\u539f\u5e02", L"\u5c3e\u9053\u5e02", L"\u6df1\u8c37\u5e02",
00084             L"\u5ca9\u56fd\u5e02", L"\u51fa\u96f2\u5e02", L"\u713c\u6d25\u5e02", L"\u571f\u6d66\u5e02", L"\u53e4\u6cb3\u5e02", L"\u85e4\u679d\u5e02",
00085             L"\u8aeb\u65e9\u5e02", L"\u6851\u540d\u5e02", L"\u6803\u6728\u5e02", L"\u9752\u6885\u5e02", L"\u6b66\u8535\u91ce\u5e02", L"\u9db4\u5ca1\u5e02",
00086             L"\u7a32\u6ca2\u5e02", L"\u5927\u5d0e\u5e02", L"\u6211\u5b6b\u5b50\u5e02", L"\u516b\u4ee3\u5e02", L"\u702c\u6238\u5e02", L"\u5bcc\u58eb\u5bae\u5e02",
00087             L"\u5c0f\u6a3d\u5e02", L"\u98ef\u585a\u5e02", L"\u4e09\u90f7\u5e02", L"\u5ef6\u5ca1\u5e02", L"\u8349\u6d25\u5e02", L"\u9580\u771f\u5e02",
00088             L"\u4f0a\u52e2\u5e02", L"\u6c96\u7e04\u5e02", L"\u7b95\u9762\u5e02", L"\u671d\u971e\u5e02", L"\u6728\u66f4\u6d25\u5e02", L"\u5ea7\u9593\u5e02",
00089             L"\u6210\u7530\u5e02", L"\u6d77\u8001\u540d\u5e02", L"\u9727\u5cf6\u5e02", L"\u5927\u6771\u5e02", L"\u5510\u6d25\u5e02", L"\u4f1a\u6d25\u82e5\u677e\u5e02",
00090             L"\u5317\u898b\u5e02", L"\u6a7f\u539f\u5e02", L"\u5225\u5e9c\u5e02", L"\u5965\u5dde\u5e02", L"\u677e\u539f\u5e02", L"\u9577\u6d5c\u5e02",
00091             L"\u6c5f\u5225\u5e02", L"\u5927\u725f\u7530\u5e02", L"\u6238\u7530\u5e02", L"\u4e2d\u592e\u533a", L"\u65b0\u5c45\u6d5c\u5e02", L"\u6850\u751f\u5e02",
00092             L"\u4f50\u91ce\u5e02", L"\u56fd\u5206\u5bfa\u5e02", L"\u9d3b\u5de3\u5e02", L"\u5bcc\u7530\u6797\u5e02", L"\u5c0f\u91d1\u4e95\u5e02",
00093             L"\u534a\u7530\u5e02", L"\u4e00\u95a2\u5e02", L"\u751f\u99d2\u5e02", L"\u90a3\u9808\u5869\u539f\u5e02", L"\u7fbd\u66f3\u91ce\u5e02",
00094             L"\u3046\u308b\u307e\u5e02", L"\u9632\u5e9c\u5e02", L"\u6771\u4e45\u7559\u7c73\u5e02", L"\u639b\u5ddd\u5e02", L"\u6771\u8fd1\u6c5f\u5e02",
00095             L"\u52a0\u9808\u5e02", L"\u4e09\u7530\u5e02", L"\u5eff\u65e5\u5e02\u5e02", L"\u591a\u6cbb\u898b\u5e02", L"\u6cb3\u5185\u9577\u91ce\u5e02",
00096             L"\u662d\u5cf6\u5e02", L"\u897f\u6761\u5e02", L"\u5f66\u6839\u5e02", L"\u4e09\u5cf6\u5e02", L"\u9152\u7530\u5e02", L"\u767d\u5c71\u5e02",
00097             L"\u4e38\u4e80\u5e02", L"\u6d66\u6dfb\u5e02", L"\u53d6\u624b\u5e02", L"\u7b51\u897f\u5e02", L"\u5c0f\u677e\u5e02", L"\u938c\u30b1\u8c37\u5e02",
00098             L"\u6771\u6d77\u5e02", L"\u6625\u65e5\u5e02", L"\u5bcc\u58eb\u898b\u5e02", L"\u6d25\u5c71\u5e02", L"\u3075\u3058\u307f\u91ce\u5e02",
00099             L"\u98ef\u7530\u5e02", L"\u9e7f\u5c4b\u5e02", L"\u6c60\u7530\u5e02", L"\u9e7f\u6cbc\u5e02", L"\u4e09\u6761\u5e02", L"\u5742\u6238\u5e02",
00100             L"\u82b1\u5dfb\u5e02", L"\u65b0\u767a\u7530\u5e02", L"\u4f0a\u52e2\u539f\u5e02", L"\u6cc9\u4f50\u91ce\u5e02", L"\u4f50\u4e45\u5e02",
00101             L"\u4e09\u539f\u5e02", L"\u5cf6\u7530\u5e02", L"\u7b51\u7d2b\u91ce\u5e02", L"\u6c5f\u5357\u5e02", L"\u85a9\u6469\u5ddd\u5185\u5e02",
00102             L"\u7cf8\u5cf6\u5e02", L"\u6a2a\u624b\u5e02", L"\u53ef\u5150\u5e02", L"\u4f0a\u8cc0\u5e02", L"\u5b89\u66c7\u91ce\u5e02", L"\u5b97\u50cf\u5e02",
00103             L"\u5927\u91ce\u57ce\u5e02", L"\u795e\u6816\u5e02", L"\u5ba4\u862d\u5e02", L"\u9ad8\u7802\u5e02", L"\u5343\u6b73\u5e02", L"\u5c04\u6c34\u5e02",
00104             L"\u82a6\u5c4b\u5e02", L"\u5317\u4e0a\u5e02", L"\u8302\u539f\u5e02", L"\u9ad8\u5c71\u5e02", L"\u7532\u8cc0\u5e02", L"\u4e80\u5ca1\u5e02",
00105             L"\u5742\u4e95\u5e02", L"\u5b9c\u91ce\u6e7e\u5e02", L"\u67cf\u5d0e\u5e02", L"\u95a2\u5e02", L"\u8c9d\u585a\u5e02", L"\u5927\u6751\u5e02",
00106             L"\u5ca9\u898b\u6ca2\u5e02", L"\u6771\u677e\u5c71\u5e02", L"\u65e5\u5149\u5e02", L"\u56db\u56fd\u4e2d\u592e\u5e02", L"\u7c73\u6ca2\u5e02",
00107             L"\u541b\u6d25\u5e02", L"\u5929\u8349\u5e02", L"\u5fa1\u6bbf\u5834\u5e02", L"\u5927\u548c\u90e1\u5c71\u5e02", L"\u821e\u9db4\u5e02",
00108             L"\u5927\u4ed9\u5e02", L"\u5370\u897f\u5e02", L"\u56db\u8857\u9053\u5e02", L"\u3042\u307e\u5e02", L"\u884c\u7530\u5e02", L"\u8d8a\u524d\u5e02",
00109             L"\u8c4a\u5ca1\u5e02", L"\u5927\u5e9c\u5e02", L"\u7531\u5229\u672c\u8358\u5e02", L"\u888b\u4e95\u5e02", L"\u7a32\u57ce\u5e02", L"\u77e5\u591a\u5e02",
00110             L"\u4e2d\u6d25\u5e02", L"\u5b87\u548c\u5cf6\u5e02", L"\u65e5\u9032\u5e02", L"\u767b\u7c73\u5e02", L"\u6442\u6d25\u5e02", L"\u98ef\u80fd\u5e02",
00111             L"\u6e0b\u5ddd\u5e02", L"\u7dbe\u702c\u5e02", L"\u6771\u5927\u548c\u5e02", L"\u516b\u6f6e\u5e02", L"\u9999\u53d6\u5e02", L"\u771f\u5ca1\u5e02",
00112             L"\u84b2\u90e1\u5e02", L"\u672c\u5e84\u5e02", L"\u71d5\u5e02", L"\u8fd1\u6c5f\u516b\u5e61\u5e02", L"\u725b\u4e45\u5e02", L"\u5317\u540d\u53e4\u5c4b\u5e02",
00113             L"\u5c3e\u5f35\u65ed\u5e02", L"\u4e09\u6728\u5e02", L"\u4e2d\u6d25\u5ddd\u5e02", L"\u3042\u304d\u308b\u91ce\u5e02", L"\u548c\u5149\u5e02",
00114             L"\u305f\u3064\u306e\u5e02", L"\u9f8d\u30b1\u5d0e\u5e02", L"\u540d\u5f35\u5e02", L"\u57ce\u967d\u5e02", L"\u9577\u5ca1\u4eac\u5e02", L"\u77f3\u5ca1\u5e02",
00115             L"\u798f\u77e5\u5c71\u5e02", L"\u7b20\u9593\u5e02", L"\u9808\u8cc0\u5ddd\u5e02", L"\u7530\u8fba\u5e02", L"\u5927\u9928\u5e02", L"\u72db\u6c5f\u5e02",
00116             L"\u9928\u6797\u5e02", L"\u4ea4\u91ce\u5e02", L"\u5927\u7530\u539f\u5e02", L"\u6cc9\u5927\u6d25\u5e02", L"\u4f50\u4f2f\u5e02", L"\u5b88\u5c71\u5e02",
00117             L"\u963f\u5357\u5e02", L"\u56fd\u7acb\u5e02", L"\u9999\u829d\u5e02", L"\u72ac\u5c71\u5e02", L"\u6817\u539f\u5e02", L"\u67cf\u539f\u5e02",
00118             L"\u59f6\u826f\u5e02", L"\u6876\u5ddd\u5e02", L"\u516b\u5e61\u5e02", L"\u6e05\u702c\u5e02", L"\u7532\u6590\u5e02", L"\u6c17\u4ed9\u6cbc\u5e02",
00119             L"\u516b\u8857\u5e02", L"\u540d\u53d6\u5e02", L"\u5357\u30a2\u30eb\u30d7\u30b9\u5e02", L"\u78a7\u5357\u5e02", L"\u52a0\u8cc0\u5e02",
00120             L"\u8568\u5e02", L"\u4f0a\u6771\u5e02", L"\u67f3\u5ddd\u5e02", L"\u4f0a\u90a3\u5e02", L"\u65e5\u7530\u5e02", L"\u5357\u76f8\u99ac\u5e02",
00121             L"\u7b1b\u5439\u5e02", L"\u592a\u5bb0\u5e9c\u5e02", L"\u884c\u6a4b\u5e02", L"\u929a\u5b50\u5e02", L"\u6b66\u8535\u6751\u5c71\u5e02",
00122             L"\u9db4\u30f6\u5cf6\u5e02", L"\u6728\u6d25\u5ddd\u5e02", L"\u8c4a\u660e\u5e02", L"\u5fd7\u6728\u5e02", L"\u7389\u540d\u5e02", L"\u6075\u5ead\u5e02",
00123             L"\u5929\u7406\u5e02", L"\u65ed\u5e02", L"\u9ce5\u6816\u5e02", L"\u516b\u5973\u5e02", L"\u5317\u672c\u5e02", L"\u4e09\u8c4a\u5e02",
00124             L"\u5927\u548c\u9ad8\u7530\u5e02", L"\u77e5\u7acb\u5e02", L"\u85e4\u5ca1\u5e02", L"\u4eac\u7530\u8fba\u5e02", L"\u4e39\u6ce2\u5e02",
00125             L"\u6566\u8cc0\u5e02", L"\u5869\u5c3b\u5e02", L"\u9bd6\u6c5f\u5e02", L"\u7fbd\u5cf6\u5e02", L"\u79e9\u7236\u5e02", L"\u6751\u4e0a\u5e02",
00126             L"\u6a4b\u672c\u5e02", L"\u7dcf\u793e\u5e02", L"\u85e4\u4e95\u5bfa\u5e02", L"\u5341\u548c\u7530\u5e02", L"\u4f0a\u9054\u5e02", L"\u9e7f\u5d8b\u5e02",
00127             L"\u6e05\u9808\u5e02", L"\u7d00\u306e\u5ddd\u5e02", L"\u5e38\u7dcf\u5e02", L"\u5409\u5ddd\u5e02", L"\u6d25\u5cf6\u5e02", L"\u611b\u897f\u5e02",
00128             L"\u767d\u6cb3\u5e02", L"\u5c71\u967d\u5c0f\u91ce\u7530\u5e02", L"\u7389\u91ce\u5e02", L"\u6cc9\u5357\u5e02", L"\u7530\u539f\u5e02",
00129             L"\u6817\u6771\u5e02", L"\u84ee\u7530\u5e02", L"\u65e5\u5411\u5e02", L"\u591a\u8cc0\u57ce\u5e02", L"\u4f50\u6e21\u5e02", L"\u89b3\u97f3\u5bfa\u5e02",
00130             L"\u5b88\u8c37\u5e02", L"\u5929\u7ae5\u5e02", L"\u5343\u66f2\u5e02", L"\u5b87\u57ce\u5e02", L"\u6771\u91d1\u5e02", L"\u6d5c\u7530\u5e02",
00131             L"\u5357\u9b5a\u6cbc\u5e02", L"\u9cf4\u9580\u5e02", L"\u3080\u3064\u5e02", L"\u5b89\u4e2d\u5e02", L"\u9ce9\u30f6\u8c37\u5e02", L"\u571f\u5c90\u5e02",
00132             L"\u5317\u5e83\u5cf6\u5e02", L"\u8896\u30b1\u6d66\u5e02", L"\u767d\u4e95\u5e02", L"\u540d\u8b77\u5e02", L"\u685c\u4e95\u5e02",
00133             L"\u307f\u3088\u3057\u5e02", L"\u6e56\u897f\u5e02", L"\u4e8c\u672c\u677e\u5e02", L"\u798f\u751f\u5e02", L"\u9ad8\u77f3\u5e02", L"\u4e0b\u91ce\u5e02",
00134             L"\u77f3\u72e9\u5e02", L"\u5bae\u53e4\u5e02", L"\u80fd\u4ee3\u5e02", L"\u4eac\u4e39\u5f8c\u5e02", L"\u5b87\u4f50\u5e02", L"\u5341\u65e5\u753a\u5e02",
00135             L"\u5c0f\u90e1\u5e02", L"\u4e94\u6240\u5ddd\u539f\u5e02", L"\u9017\u5b50\u5e02", L"\u5927\u962a\u72ed\u5c71\u5e02", L"\u53e4\u8cc0\u5e02",
00136             L"\u4e03\u5c3e\u5e02", L"\u65e5\u5357\u5e02", L"\u76f4\u65b9\u5e02", L"\u56db\u689d\u7577\u5e02", L"\u65e5\u9ad8\u5e02", L"\u7cf8\u6e80\u5e02",
00137             L"\u8c4a\u898b\u57ce\u5e02", L"\u4f0a\u4e07\u91cc\u5e02", L"\u7fbd\u6751\u5e02", L"\u962a\u5357\u5e02", L"\u4e09\u6b21\u5e02", L"\u5869\u7ac8\u5e02",
00138             L"\u8305\u91ce\u5e02", L"\u671d\u5009\u5e02", L"\u5e38\u9678\u592a\u7530\u5e02", L"\u7fbd\u751f\u5e02", L"\u5742\u6771\u5e02", L"\u5c71\u6b66\u5e02",
00139             L"\u5742\u51fa\u5e02", L"\u51fa\u6c34\u5e02", L"\u798f\u6d25\u5e02", L"\u5c71\u9e7f\u5e02", L"\u8352\u5c3e\u5e02", L"\u4e0b\u677e\u5e02",
00140             L"\u5408\u5fd7\u5e02", L"\u5e38\u6ed1\u5e02", L"\u6d77\u5357\u5e02", L"\u7f8e\u6fc3\u52a0\u8302\u5e02", L"\u5357\u783a\u5e02", L"\u5fd7\u6469\u5e02",
00141             L"\u6e56\u5357\u5e02", L"\u4e94\u6cc9\u5e02", L"\u88fe\u91ce\u5e02", L"\u5411\u65e5\u5e02", L"\u7b20\u5ca1\u5e02", L"\u90a3\u73c2\u5e02",
00142             L"\u5e78\u624b\u5e02", L"\u8429\u5e02", L"\u6075\u90a3\u5e02", L"\u3055\u306c\u304d\u5e02", L"\u5149\u5e02", L"\u5ca9\u51fa\u5e02", L"\u5ca1\u8c37\u5e02",
00143             L"\u7d50\u57ce\u5e02", L"\u9ad8\u5cf6\u5e02", L"\u559c\u591a\u65b9\u5e02", L"\u5c0f\u7f8e\u7389\u5e02", L"\u9808\u5742\u5e02", L"\u5bcc\u5ca1\u5e02",
00144             L"\u5bae\u53e4\u5cf6\u5e02", L"\u745e\u7a42\u5e02", L"\u307f\u3069\u308a\u5e02", L"\u6c37\u898b\u5e02", L"\u767b\u5225\u5e02", L"\u6cbc\u7530\u5e02",
00145             L"\u8acf\u8a2a\u5e02", L"\u5bcc\u91cc\u5e02", L"\u4e80\u5c71\u5e02", L"\u6e6f\u6ca2\u5e02", L"\u65e5\u7f6e\u5e02", L"\u5009\u5409\u5e02",
00146             L"\u6b66\u96c4\u5e02", L"\u5bcc\u58eb\u5409\u7530\u5e02", L"\u7530\u5ddd\u5e02", L"\u8d64\u7a42\u5e02", L"\u5357\u5cf6\u539f\u5e02",
00147             L"\u83ca\u6c60\u5e02", L"\u927e\u7530\u5e02", L"\u76ca\u7530\u5e02", L"\u91ce\u6d32\u5e02", L"\u65b0\u57ce\u5e02", L"\u5357\u3042\u308f\u3058\u5e02",
00148             L"\u5c0f\u91ce\u5e02", L"\u5357\u56fd\u5e02", L"\u783a\u6ce2\u5e02", L"\u9928\u5c71\u5e02", L"\u4f0a\u8c46\u306e\u56fd\u5e02",
00149             L"\u7267\u4e4b\u539f\u5e02", L"\u771f\u5ead\u5e02", L"\u80fd\u7f8e\u5e02", L"\u7b51\u5f8c\u5e02", L"\u4e09\u6d66\u5e02", L"\u5c0f\u6797\u5e02",
00150             L"\u5bcc\u6d25\u5e02", L"\u52a0\u897f\u5e02", L"\u5317\u6597\u5e02", L"\u7cf8\u9b5a\u5ddd\u5e02", L"\u5cf6\u539f\u5e02", L"\u5ca9\u5009\u5e02",
00151             L"\u6d32\u672c\u5e02", L"\u96f2\u4ed9\u5e02", L"\u5927\u6d32\u5e02", L"\u5343\u4ee3\u7530\u533a", L"\u83ca\u5ddd\u5e02", L"\u5317\u8328\u57ce\u5e02",
00152             L"\u77f3\u57a3\u5e02", L"\u7a32\u6577\u5e02", L"\u5317\u675c\u5e02", L"\u6de1\u8def\u5e02", L"\u6771\u6839\u5e02", L"\u5944\u7f8e\u5e02",
00153             L"\u685c\u5ddd\u5e02", L"\u3044\u306a\u3079\u5e02", L"\u4e2d\u91ce\u5e02", L"\u963f\u8cc0\u91ce\u5e02", L"\u5e38\u9678\u5927\u5bae\u5e02",
00154             L"\u5c0f\u57ce\u5e02", L"\u4e0b\u59bb\u5e02", L"\u9b5a\u6d25\u5e02", L"\u3055\u304f\u3089\u5e02", L"\u90e1\u4e0a\u5e02",
00155             L"\u3064\u304f\u3070\u307f\u3089\u3044\u5e02", L"\u6307\u5bbf\u5e02", L"\u4e2d\u9593\u5e02", L"\u5ca9\u6cbc\u5e02", L"\u5409\u91ce\u5ddd\u5e02",
00156             L"\u5c0f\u8af8\u5e02", L"\u9ad8\u6d5c\u5e02", L"\u4e95\u539f\u5e02", L"\u5357\u8db3\u67c4\u5e02", L"\u304b\u3059\u307f\u304c\u3046\u3089\u5e02",
00157             L"\u8d64\u78d0\u5e02", L"\u5f25\u5bcc\u5e02", L"\u7be0\u5c71\u5e02", L"\u6edd\u5ddd\u5e02", L"\u6771\u677e\u5cf6\u5e02", L"\u897f\u8107\u5e02",
00158             L"\u5609\u9ebb\u5e02", L"\u5e9c\u4e2d\u5e02", L"\u5bd2\u6cb3\u6c5f\u5e02", L"\u5357\u623f\u7dcf\u5e02", L"\u897f\u4e88\u5e02", L"\u96f2\u5357\u5e02",
00159             L"\u898b\u9644\u5e02", L"\u9ed2\u90e8\u5e02", L"\u5b89\u6765\u5e02", L"\u81fc\u6775\u5e02", L"\u4e09\u6ca2\u5e02", L"\u7db2\u8d70\u5e02",
00160             L"\u3044\u3059\u307f\u5e02", L"\u5b8d\u7c9f\u5e02", L"\u5927\u8239\u6e21\u5e02", L"\u307f\u3084\u307e\u5e02", L"\u5c0f\u677e\u5cf6\u5e02",
00161             L"\u4e94\u5cf6\u5e02", L"\u7530\u6751\u5e02", L"\u745e\u6d6a\u5e02", L"\u9b5a\u6cbc\u5e02", L"\u5e84\u539f\u5e02", L"\u52a0\u6771\u5e02",
00162             L"\u7c73\u539f\u5e02", L"\u531d\u7473\u5e02", L"\u5357\u57ce\u5e02", L"\u7a1a\u5185\u5e02", L"\u71b1\u6d77\u5e02", L"\u91dc\u77f3\u5e02",
00163             L"\u8c4a\u5f8c\u5927\u91ce\u5e02", L"\u963f\u6ce2\u5e02", L"\u66fd\u65bc\u5e02", L"\u5357\u4e5d\u5dde\u5e02", L"\u65b0\u5e84\u5e02",
00164             L"\u5357\u3055\u3064\u307e\u5e02", L"\u5c0f\u5343\u8c37\u5e02", L"\u516b\u5e61\u6d5c\u5e02", L"\u9577\u9580\u5e02", L"\u5927\u7530\u5e02",
00165             L"\u4f0a\u4e88\u5e02", L"\u6d77\u6d25\u5e02", L"\u702c\u6238\u5185\u5e02", L"\u5099\u524d\u5e02", L"\u76f8\u99ac\u5e02", L"\u5b87\u571f\u5e02",
00166             L"\u884c\u65b9\u5e02", L"\u5927\u5ddd\u5e02", L"\u767d\u77f3\u5e02", L"\u3064\u304c\u308b\u5e02", L"\u4e45\u6148\u5e02", L"\u5c71\u68a8\u5e02",
00167             L"\u5317\u79cb\u7530\u5e02", L"\u4e0b\u5442\u5e02", L"\u4f0a\u9054\u5e02", L"\u9ed2\u77f3\u5e02", L"\u6d45\u53e3\u5e02", L"\u56db\u4e07\u5341\u5e02",
00168             L"\u845b\u57ce\u5e02", L"\u7dbe\u90e8\u5e02", L"\u9d28\u5ddd\u5e02", L"\u4eba\u5409\u5e02", L"\u5999\u9ad8\u5e02", L"\u77e2\u677f\u5e02",
00169             L"\u5927\u91ce\u5e02", L"\u6771\u6e29\u5e02", L"\u5357\u4e39\u5e02", L"\u5883\u6e2f\u5e02", L"\u672c\u5de3\u5e02", L"\u9ad8\u6881\u5e02",
00170             L"\u5e73\u6238\u5e02", L"\u67f3\u4e95\u5e02", L"\u7531\u5e03\u5e02", L"\u5fa1\u524d\u5d0e\u5e02", L"\u304b\u307b\u304f\u5e02", L"\u9e7f\u89d2\u5e02",
00171             L"\u4e94\u689d\u5e02", L"\u6f5f\u4e0a\u5e02", L"\u5bfe\u99ac\u5e02", L"\u5b87\u9640\u5e02", L"\u4f0a\u8c46\u5e02", L"\u7532\u5dde\u5e02",
00172             L"\u65b0\u898b\u5e02", L"\u4e0a\u5c71\u5e02", L"\u9999\u5357\u5e02", L"\u5584\u901a\u5bfa\u5e02", L"\u5e73\u5ddd\u5e02", L"\u99d2\u30f6\u6839\u5e02",
00173             L"\u6ed1\u5ddd\u5e02", L"\u5357\u967d\u5e02", L"\u6771\u304b\u304c\u308f\u5e02", L"\u90fd\u7559\u5e02", L"\u5fd7\u5e03\u5fd7\u5e02",
00174             L"\u795e\u57fc\u5e02", L"\u671d\u6765\u5e02", L"\u897f\u90fd\u5e02", L"\u7f8e\u99ac\u5e02", L"\u97ee\u5d0e\u5e02", L"\u7537\u9e7f\u5e02",
00175             L"\u6775\u7bc9\u5e02", L"\u5c0f\u77e2\u90e8\u5e02", L"\u56fd\u6771\u5e02", L"\u3046\u304d\u306f\u5e02", L"\u672c\u5bae\u5e02",
00176             L"\u5b89\u82b8\u9ad8\u7530\u5e02", L"\u65b0\u5bae\u5e02", L"\u80ce\u5185\u5e02", L"\u5c0f\u6d5c\u5e02", L"\u89d2\u7530\u5e02",
00177             L"\u4e2d\u592e\u5e02", L"\u897f\u6d77\u5e02", L"\u76f8\u751f\u5e02", L"\u3044\u3061\u304d\u4e32\u6728\u91ce\u5e02", L"\u9ad8\u8429\u5e02",
00178             L"\u9e7f\u5cf6\u5e02", L"\u6771\u5fa1\u5e02", L"\u6709\u7530\u5e02", L"\u540d\u5bc4\u5e02", L"\u6f6e\u6765\u5e02", L"\u7f8e\u4f5c\u5e02",
00179             L"\u5fa1\u6240\u5e02", L"\u5bae\u82e5\u5e02", L"\u3042\u308f\u3089\u5e02", L"\u4e09\u597d\u5e02", L"\u4e0a\u5929\u8349\u5e02",
00180             L"\u8f2a\u5cf6\u5e02", L"\u5927\u753a\u5e02", L"\u52a0\u8302\u5e02", L"\u4e8c\u6238\u5e02", L"\u5c71\u770c\u5e02", L"\u4ed9\u5317\u5e02",
00181             L"\u9577\u4e95\u5e02", L"\u58f1\u5c90\u5e02", L"\u9060\u91ce\u5e02", L"\u4f0a\u4f50\u5e02", L"\u6839\u5ba4\u5e02", L"\u90a3\u9808\u70cf\u5c71\u5e02",
00182             L"\u5b09\u91ce\u5e02", L"\u5927\u7af9\u5e02", L"\u9999\u7f8e\u5e02", L"\u571f\u4f50\u5e02", L"\u516b\u5e61\u5e73\u5e02", L"\u7af9\u539f\u5e02",
00183             L"\u7f8e\u7962\u5e02", L"\u963f\u8607\u5e02", L"\u5927\u6708\u5e02", L"\u306b\u304b\u307b\u5e02", L"\u4e0a\u91ce\u539f\u5e02", L"\u8c4a\u524d\u5e02",
00184             L"\u6c5f\u7530\u5cf6\u5e02", L"\u6c34\u4fe3\u5e02", L"\u6751\u5c71\u5e02", L"\u98db\u9a28\u5e02", L"\u990a\u7236\u5e02", L"\u5fa1\u574a\u5e02",
00185             L"\u7f8e\u5504\u5e02", L"\u6c5f\u6d25\u5e02", L"\u52dd\u5c71\u5e02", L"\u677e\u6d66\u5e02", L"\u4e0b\u7530\u5e02", L"\u7d0b\u5225\u5e02",
00186             L"\u9808\u5d0e\u5e02", L"\u7559\u840c\u5e02", L"\u7af9\u7530\u5e02", L"\u5bcc\u826f\u91ce\u5e02", L"\u8c4a\u5f8c\u9ad8\u7530\u5e02",
00187             L"\u6df1\u5ddd\u5e02", L"\u6795\u5d0e\u5e02", L"\u98ef\u5c71\u5e02", L"\u9678\u524d\u9ad8\u7530\u5e02", L"\u963f\u4e45\u6839\u5e02",
00188             L"\u7fbd\u548b\u5e02", L"\u7f8e\u6fc3\u5e02", L"\u5bbf\u6bdb\u5e02", L"\u58eb\u5225\u5e02", L"\u3048\u3073\u306e\u5e02", L"\u9ce5\u7fbd\u5e02",
00189             L"\u591a\u4e45\u5e02", L"\u52dd\u6d66\u5e02", L"\u4e32\u9593\u5e02", L"\u5c3e\u9df2\u5e02", L"\u5bae\u6d25\u5e02", L"\u6d25\u4e45\u898b\u5e02",
00190             L"\u718a\u91ce\u5e02", L"\u5b89\u82b8\u5e02", L"\u7802\u5ddd\u5e02", L"\u5c3e\u82b1\u6ca2\u5e02", L"\u5782\u6c34\u5e02", L"\u897f\u4e4b\u8868\u5e02",
00191             L"\u82a6\u5225\u5e02", L"\u73e0\u6d32\u5e02", L"\u571f\u4f50\u6e05\u6c34\u5e02", L"\u5ba4\u6238\u5e02", L"\u8d64\u5e73\u5e02", L"\u5915\u5f35\u5e02",
00192             L"\u4e09\u7b20\u5e02", L"\u6b4c\u5fd7\u5185\u5e02"
00193         };
00194
00195     auto queryText = e->QueryText;
00196     wstring query = wstring(queryText->Data());
00197     if (queryText->Length() == 0)
00198     {
00199         MainPage::Current->NotifyUser("Use the search pane to submit a query", NotifyType::StatusMessage);
00200     }
00201     else
00202     {
00203         auto request = e->Request;
00204         auto queryTextAlternatives = e->LinguisticDetails->QueryTextAlternatives;
00205         auto size = queryTextAlternatives->Size;
00206         wstring *alternatives = new wstring[size];
00207         for (unsigned int i = 0; i < size; i++)
00208         {
00209             alternatives[i] = wstring(queryTextAlternatives->GetAt(i)->Data());
00210         }
00211
00212         bool done = false;
00213         for (unsigned int i = 0; (i < size) && !done; i++)
00214         {
00215             for each(wstring suggestion in suggestionList)
00216             {
00217                 if (suggestion.find(alternatives[i]) == 0)
00218                 {
00219                     // if the string starts with the alternative, add suggestion to search pane.
00220                     request->SearchSuggestionCollection->AppendQuerySuggestion(ref new String(const_cast<wchar_t*>(suggestion.c_str())));
00221
00222                     // Break since the search pane can show at most 5 suggestions.
00223                     if (request->SearchSuggestionCollection->Size >= MainPage::SearchPaneMaxSuggestions)
00224                     {
00225                         done = true;
00226                         break;
00227                     }
00228                 }
00229             }
00230         }
00231         delete [] alternatives;
00232
00233         if (request->SearchSuggestionCollection->Size > 0)
00234         {
00235             MainPage::Current->NotifyUser("Suggestions provided for query: " + queryText, NotifyType::StatusMessage);
00236         }
00237         else
00238         {
00239             MainPage::Current->NotifyUser("No suggestions provided for query: " + queryText, NotifyType::StatusMessage);
00240         }
00241     }
00242 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/SampleOverlay.h Source File

  • Direct2D save to image file

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NetworkStatusTask::sealed Member List

This is the complete list of members for NetworkStatusTask::sealed, including all inherited members.
BackgroundTask() | NetworkStatusTask::sealed |
OnCanceled(IBackgroundTaskInstance^taskInstance, BackgroundTaskCancellationReason reason) | NetworkStatusTask::sealed |
Run(IBackgroundTaskInstance^taskInstance) | NetworkStatusTask::sealed | [virtual]
~BackgroundTask() | NetworkStatusTask::sealed | [private]
Generated on Sat Nov 23 2024 16:09:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupVideoStream.xaml.cpp Source File

  • HomeGroup app

HomeGroupVideoStream.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // HomeGroupVideoStream.xaml.cpp
00013 // Implementation of the HomeGroupVideoStream class
00014 //
00015
00016 #include "pch.h"
00017 #include "HomeGroupVideoStream.xaml.h"
00018
00019 using namespace SDKSample::HomeGroup;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Storage::Pickers;
00025 using namespace Windows::Storage;
00026 using namespace concurrency;
00027 using namespace Windows::Storage::Streams;
00028 using namespace Platform;
00029
00030 HomeGroupVideoStream::HomeGroupVideoStream()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void HomeGroupVideoStream::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00043     // as NotifyUser()
00044     rootPage = MainPage::Current;
00045 }
00046
00047 // Use file picker to select a video file from a HomeGroup machine and play it in 'Media Element'
00048 void SDKSample::HomeGroup::HomeGroupVideoStream::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00049 {
00050     Button^ button = safe_cast<Button^>(sender);
00051     if (button != nullptr)
00052     {
00053         if (rootPage->EnsureUnsnapped())
00054         {
00055             auto picker = ref new FileOpenPicker();
00056             picker->ViewMode = PickerViewMode::Thumbnail;
00057             picker->SuggestedStartLocation = PickerLocationId::HomeGroup;
00058             picker->FileTypeFilter->Append(".mp4");
00059             picker->FileTypeFilter->Append(".wmv");
00060             create_task(picker->PickSingleFileAsync()).then([this](StorageFile^ file)
00061             {
00062                 if (file)
00063                 {
00064                     // The video tag has built in capabilities to stream the video over the network.
00065                     create_task(file->OpenReadAsync()).then([this](IRandomAccessStreamWithContentType^ videoStream)
00066                     {
00067                         if (videoStream)
00068                         {
00069                             //Clear status that may have been previously set by a picker being cancelled.
00070                             rootPage->NotifyUser("", NotifyType::StatusMessage);
00071                             videoPlayer->SetSource(videoStream, "video/x-flv");
00072                             videoPlayer->Visibility = Windows::UI::Xaml::Visibility::Visible;
00073                             videoPlayer->Play();
00074                         }
00075                         else
00076                         {
00077                             rootPage->NotifyUser("Stream was not returned", NotifyType::ErrorMessage);
00078                         }
00079                     });
00080                 }
00081                 else
00082                 {
00083                     rootPage->NotifyUser("File was not returned", NotifyType::ErrorMessage);
00084                 }
00085             });
00086         }
00087     }
00088 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DxgiRotation.cpp Source File

  • DXGI swap chain rotation

DxgiRotation.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DxgiRotation.h"
00010 #include "BasicShapes.h"
00011 #include "BasicLoader.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::ApplicationModel;
00017 using namespace Windows::ApplicationModel::Core;
00018 using namespace Windows::ApplicationModel::Activation;
00019 using namespace D2D1;
00020
00021 void DxgiRotation::CreateDeviceIndependentResources()
00022 {
00023     DirectXBase::CreateDeviceIndependentResources();
00024
00025     // Decode a reference 2D image using WIC.
00026     // This will be used to later create a D2D bitmap.
00027     ComPtr<IWICBitmapDecoder> decoder;
00028     DX::ThrowIfFailed(
00029         m_wicFactory->CreateDecoderFromFilename(
00030             L"reference2d.png",
00031             nullptr,
00032             GENERIC_READ,
00033             WICDecodeMetadataCacheOnDemand,
00034             &decoder
00035             )
00036         );
00037
00038     Microsoft::WRL::ComPtr<IWICBitmapFrameDecode> frame;
00039     DX::ThrowIfFailed(
00040         decoder->GetFrame(0, &frame)
00041         );
00042
00043     DX::ThrowIfFailed(
00044         m_wicFactory->CreateFormatConverter(&m_referenceBitmapSource)
00045         );
00046
00047     DX::ThrowIfFailed(
00048         m_referenceBitmapSource->Initialize(
00049             frame.Get(),
00050             GUID_WICPixelFormat32bppPBGRA,
00051             WICBitmapDitherTypeNone,
00052             nullptr,
00053             0.0f,
00054             WICBitmapPaletteTypeCustom
00055             )
00056         );
00057
00058     // Create a text format for rendering 2D text.
00059     DX::ThrowIfFailed(
00060         m_dwriteFactory->CreateTextFormat(
00061             L"Segoe UI",
00062             nullptr,
00063             DWRITE_FONT_WEIGHT_REGULAR,
00064             DWRITE_FONT_STYLE_NORMAL,
00065             DWRITE_FONT_STRETCH_NORMAL,
00066             18.0f,
00067             L"en-US",
00068             &m_textFormat
00069             )
00070         );
00071
00072     DX::ThrowIfFailed(
00073         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00074         );
00075
00076     DX::ThrowIfFailed(
00077         m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00078         );
00079 }
00080
00081 void DxgiRotation::CreateDeviceResources()
00082 {
00083     DirectXBase::CreateDeviceResources();
00084
00085     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00086
00087     loader->LoadShader(
00088         "SimpleVertexShader.cso",
00089         nullptr,
00090         0,
00091         &m_vertexShader,
00092         &m_inputLayout
00093         );
00094
00095     // Create the vertex and index buffers for drawing the cube.
00096
00097     BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());
00098
00099     shapes->CreateCube(
00100         &m_vertexBuffer,
00101         &m_indexBuffer,
00102         nullptr,
00103         &m_indexCount
00104         );
00105
00106     // Create the constant buffer for updating model and camera data.
00107     CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &constantBufferDescription,
00111             nullptr,             // leave the buffer uninitialized
00112             &m_constantBuffer
00113             )
00114         );
00115
00116     loader->LoadShader(
00117         "SimplePixelShader.cso",
00118         &m_pixelShader
00119         );
00120
00121     loader->LoadTexture(
00122         "reference3d.png",
00123         &m_texture,
00124         &m_textureSRV
00125         );
00126
00127     // Create the sampler.
00128     D3D11_SAMPLER_DESC samplerDescription;
00129     ZeroMemory(&samplerDescription, sizeof(D3D11_SAMPLER_DESC));
00130     samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
00131     samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
00132     samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
00133     samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
00134     samplerDescription.MipLODBias = 0.0f;
00135     samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
00136     samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
00137     samplerDescription.BorderColor[0] = 0.0f;
00138     samplerDescription.BorderColor[1] = 0.0f;
00139     samplerDescription.BorderColor[2] = 0.0f;
00140     samplerDescription.BorderColor[3] = 0.0f;
00141     // allow use of all mip levels
00142     samplerDescription.MinLOD = 0;
00143     samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;
00144
00145     DX::ThrowIfFailed(
00146         m_d3dDevice->CreateSamplerState(
00147             &samplerDescription,
00148             &m_sampler
00149             )
00150         );
00151
00152     m_Camera = ref new BasicCamera();
00153
00154     // Create a 2D bitmap using a reference image.
00155     DX::ThrowIfFailed(
00156         m_d2dContext->CreateBitmapFromWicBitmap(
00157             m_referenceBitmapSource.Get(),
00158             &m_referenceBitmap
00159             )
00160         );
00161
00162     // Create a brush to draw the reference text with.
00163     DX::ThrowIfFailed(
00164         m_d2dContext->CreateSolidColorBrush(
00165             D2D1::ColorF(D2D1::ColorF::DarkGray),
00166             &m_textBrush
00167             )
00168         );
00169
00170     // Create the Sample Overlay.
00171
00172     m_sampleOverlay = ref new SampleOverlay();
00173
00174     m_sampleOverlay->Initialize(
00175         m_d2dDevice.Get(),
00176         m_d2dContext.Get(),
00177         m_wicFactory.Get(),
00178         m_dwriteFactory.Get(),
00179         "DXGI swap chain rotation sample"
00180         );
00181 }
00182
00183 void DxgiRotation::CreateWindowSizeDependentResources()
00184 {
00185     DirectXBase::CreateWindowSizeDependentResources();
00186
00187     // update the 3D projection matrix
00188     m_Camera->SetProjectionParameters(
00189         70.0f,                                                  // use a 70-degree minimum field of view
00190         m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
00191         0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
00192         100.0f                                                  // specify the farthest Z-distance at which to draw vertices
00193         );
00194
00195     // save the new projection matrix to the constant buffer data struct
00196     m_Camera->GetProjectionMatrix(&m_constantBufferData.projection);
00197
00198     // rotate the projection matrix as it will be used to render to the rotated swap chain
00199     m_constantBufferData.projection = mul(m_constantBufferData.projection, m_rotationTransform3D);
00200
00201     // create a text layout to fill the screen
00202     Platform::String^ repeatString =
00203         "Lorem ipsum dolor sit amet, consectetur adipiscing " \
00204         "elit. Vivamus tempor scelerisque lorem in vehicula. " \
00205         "Aliquam tincidunt, lacus ut sagittis tristique, turpis " \
00206         "massa volutpat augue, eu rutrum ligula ante a ante. " \
00207         "Pellentesque porta, mauris quis interdum vehicula, " \
00208         "urna sapien ultrices velit, nec venenatis dui odio " \
00209         "in augue. Cras posuere, enim a cursus convallis, neque " \
00210         "turpis malesuada erat, ut adipiscing neque tortor ac erat. ";
00211
00212     // repeat the text enough times to ensure that it fills the window
00213     Platform::String^ textString = "";
00214     for (int i = 0; i < 50; i++)
00215     {
00216         textString = Platform::String::Concat(textString, repeatString);
00217     }
00218
00219     DX::ThrowIfFailed(
00220         m_dwriteFactory->CreateTextLayout(
00221             textString->Data(),                 // Text to be displayed
00222             textString->Length(),               // Length of the text
00223             m_textFormat.Get(),                 // DirectWrite Text Format object
00224             m_windowBounds.Width,               // Width of the Text Layout
00225             m_windowBounds.Height,              // Height of the Text Layout
00226             &m_textLayout
00227             )
00228         );
00229
00230     m_sampleOverlay->UpdateForWindowSizeChange();
00231 }
00232
00233 void DxgiRotation::Render()
00234 {
00235     UINT stride = sizeof(BasicVertex);
00236     UINT offset = 0;
00237
00238     // bind the render targets
00239     m_d3dContext->OMSetRenderTargets(
00240         1,
00241         m_d3dRenderTargetView.GetAddressOf(),
00242         m_d3dDepthStencilView.Get()
00243         );
00244
00245     // clear both the render target and depth stencil to default values
00246     const float ClearColor[4] = {0.071f, 0.040f, 0.561f, 1.0f};
00247
00248     m_d3dContext->ClearRenderTargetView(
00249         m_d3dRenderTargetView.Get(),
00250         ClearColor
00251         );
00252
00253     m_d3dContext->ClearDepthStencilView(
00254         m_d3dDepthStencilView.Get(),
00255         D3D11_CLEAR_DEPTH,
00256         1.0f,
00257         0
00258         );
00259
00260     // render 2D reference image and text
00261     m_d2dContext->BeginDraw();
00262
00263     // draw reference text
00264     m_d2dContext->SetTransform(
00265         Matrix3x2F::Translation(0.0f, 64.0f) *
00266         m_rotationTransform2D
00267         );
00268     m_d2dContext->DrawTextLayout(
00269         Point2F(0, 0),
00270         m_textLayout.Get(),
00271         m_textBrush.Get()
00272         );
00273
00274     // draw reference bitmap at the center of the screen
00275     m_d2dContext->SetTransform(
00276         Matrix3x2F::Translation(
00277             m_windowBounds.Width / 2.0f - 768.0f / 2.0f,
00278             m_windowBounds.Height / 2.0f - 768.0f / 2.0f
00279             ) *
00280         m_rotationTransform2D // apply 2D prerotation transform
00281         );
00282     m_d2dContext->DrawBitmap(m_referenceBitmap.Get());
00283
00284     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00285     // is lost. It will be handled during the next call to Present.
00286     HRESULT hr = m_d2dContext->EndDraw();
00287     if (hr != D2DERR_RECREATE_TARGET)
00288     {
00289         DX::ThrowIfFailed(hr);
00290     }
00291
00292     // set the vertex and index buffers, and specify the way they define geometry
00293     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00294
00295     m_d3dContext->IASetVertexBuffers(
00296         0,                              // starting at the first vertex buffer slot
00297         1,                              // set one vertex buffer binding
00298         m_vertexBuffer.GetAddressOf(),
00299         &stride,                        // specify the size in bytes of a single vertex
00300         &offset                         // specify the base vertex in the buffer
00301         );
00302
00303     // set the index buffer
00304     m_d3dContext->IASetIndexBuffer(
00305         m_indexBuffer.Get(),
00306         DXGI_FORMAT_R16_UINT,   // unsigned short index format
00307         0                       // specify the base index in the buffer
00308         );
00309
00310     // specify the way the vertex and index buffers define geometry
00311     m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00312
00313     // set the vertex shader stage state
00314     m_d3dContext->VSSetShader(
00315         m_vertexShader.Get(),
00316         nullptr,                // don't use shader linkage
00317         0                       // don't use shader linkage
00318         );
00319
00320     m_d3dContext->VSSetConstantBuffers(
00321         0,                              // starting at the first constant buffer slot
00322         1,                              // set one constant buffer binding
00323         m_constantBuffer.GetAddressOf()
00324         );
00325
00326     // set the pixel shader stage state
00327     m_d3dContext->PSSetShader(
00328         m_pixelShader.Get(),
00329         nullptr,                // don't use shader linkage
00330         0                       // don't use shader linkage
00331         );
00332
00333     m_d3dContext->PSSetShaderResources(
00334         0,                          // starting at the first shader resource slot
00335         1,                          // set one shader resource binding
00336         m_textureSRV.GetAddressOf()
00337         );
00338
00339     m_d3dContext->PSSetSamplers(
00340         0,                          // starting at the first sampler slot
00341         1,                          // set one sampler binding
00342         m_sampler.GetAddressOf()
00343         );
00344
00345     // draw the cube
00346     m_d3dContext->DrawIndexed(
00347         m_indexCount,   // draw all created vertices
00348         0,              // starting with the first vertex
00349         0               // and the first index
00350         );
00351
00352     // Render the Sample Overlay.
00353     m_sampleOverlay->Render(m_rotationTransform2D);
00354 }
00355
00356 void DxgiRotation::Update(float TimeTotal, float TimeDelta)
00357 {
00358     // update the model matrix based on the time
00359     m_constantBufferData.model = rotationY(-TimeTotal * 60.0f);
00360
00361     // update the view matrix based on the camera position
00362     // note that for this sample, the camera position is fixed
00363     m_Camera->SetViewParameters(
00364         float3(0, 1, 2),
00365         float3(0, 0, 0),
00366         float3(0, 1, 0)
00367         );
00368
00369     m_Camera->GetViewMatrix(&m_constantBufferData.view);
00370
00371     // update the constant buffer with the new data
00372     m_d3dContext->UpdateSubresource(
00373         m_constantBuffer.Get(),
00374         0,
00375         nullptr,
00376         &m_constantBufferData,
00377         0,
00378         0
00379         );
00380 }
00381
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/TouchableTextBlock.xaml.h Source File

  • Input Touch keyboard

TouchableTextBlock.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // TouchableTextBlock.xaml.h
00010 // Declaration of the TouchableTextBlock class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "TouchableTextBlock.g.h"
00017
00018 namespace SDKSample
00019 {
00020     namespace TouchKeyboard
00021     {
00022       [Windows::Foundation::Metadata::WebHostHidden]
00023         public ref class TouchableTextBlock sealed
00024         {
00025         internal:
00026             virtual property Platform::String^ ContentText
00027             {
00028                 Platform::String^ get() {return contentText;}
00029                 void set(Platform::String^ text) {contentText = text;}
00030             }
00031         public:
00032             TouchableTextBlock();
00033
00034         protected:
00035             virtual Windows::UI::Xaml::Automation::Peers::AutomationPeer^ OnCreateAutomationPeer() override;
00036             virtual void OnGotFocus(Windows::UI::Xaml::RoutedEventArgs^ e) override;
00037             virtual void OnLostFocus(Windows::UI::Xaml::RoutedEventArgs^ e) override;
00038             virtual void OnTapped(Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e) override;
00039             virtual void OnKeyDown(Windows::UI::Xaml::Input::KeyRoutedEventArgs^ e) override;
00040
00041         private:
00042             Platform::String^ contentText;
00043         };
00044
00045         ref class TouchableTextBlockAutomationPeer;
00046
00047         /// <summary>
00048         /// A minimal implementation of ITextRangeProvider, used by TouchableTextBlockAutomationPeer
00049         /// A real implementation is beyond the scope of this sample
00050         /// </summary>
00051       [Windows::Foundation::Metadata::WebHostHidden]
00052         public ref class TouchableTextBlockRangeProvider sealed : public Windows::UI::Xaml::Automation::Provider::ITextRangeProvider
00053         {
00054
00055         public:
00056             TouchableTextBlockRangeProvider(Platform::String^ text, TouchableTextBlockAutomationPeer^ peer);
00057
00058     //ITextRangeProvider
00059             virtual void AddToSelection();
00060             virtual Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ Clone();
00061             virtual bool Compare(Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ textRangeProvider);
00062             virtual int CompareEndpoints(Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint endpoint,
00063                                          Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ textRangeProvider,
00064                                          Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint targetEndpoint);
00065             virtual void ExpandToEnclosingUnit(Windows::UI::Xaml::Automation::Text::TextUnit unit);
00066             virtual Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ FindAttribute(int attributeId, Platform::Object^ value, bool backward);
00067             virtual Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ FindText(Platform::String^ text, bool backward, bool ignoreCase);
00068             virtual Platform::Object^ GetAttributeValue(int attributeId);
00069             virtual void GetBoundingRectangles(Platform::Array<double>^* returnValue);
00070             virtual Platform::Array<Windows::UI::Xaml::Automation::Provider::IRawElementProviderSimple^>^ GetChildren();
00071             virtual Windows::UI::Xaml::Automation::Provider::IRawElementProviderSimple^ GetEnclosingElement();
00072             virtual Platform::String^ GetText(int maxLength);
00073             virtual int Move(Windows::UI::Xaml::Automation::Text::TextUnit unit, int count);
00074             virtual void MoveEndpointByRange(Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint endpoint,
00075                                              Windows::UI::Xaml::Automation::Provider::ITextRangeProvider^ textRangeProvider,
00076                                              Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint targetEndpoint);
00077             virtual int MoveEndpointByUnit(Windows::UI::Xaml::Automation::Text::TextPatternRangeEndpoint endpoint,
00078                                           Windows::UI::Xaml::Automation::Text::TextUnit unit,
00079                                     int count);
00080             virtual void RemoveFromSelection();
00081             virtual void ScrollIntoView(bool alignToTop);
00082             virtual void Select();
00083
00084         private:
00085            Platform::String^ _text;
00086            TouchableTextBlockAutomationPeer^ _peer;
00087         };
00088     }
00089 }
Generated on Sat Nov 23 2024 16:08:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::CertificateEnrollment::sealed Member List

This is the complete list of members for SDKSample::CertificateEnrollment::sealed, including all inherited members.
certificateRequest | SDKSample::CertificateEnrollment::sealed | [private]
CreateRequest_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CertificateEnrollment::sealed | [private]
httpRequest | SDKSample::CertificateEnrollment::sealed | [private]
ImportPfx_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CertificateEnrollment::sealed | [private]
InstallCertifiate_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::CertificateEnrollment::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::CertificateEnrollment::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::CertificateEnrollment::sealed | [protected, virtual]
rootPage | SDKSample::CertificateEnrollment::sealed | [private]
Scenario_Enroll() | SDKSample::CertificateEnrollment::sealed |
Scenario_Import() | SDKSample::CertificateEnrollment::sealed |
SubmitCertificateRequestAndGetResponse(Platform::String^certificateRequest, Platform::String^url) | SDKSample::CertificateEnrollment::sealed | [private]
Generated on Sat Nov 23 2024 16:09:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario2.xaml.cpp Source File

  • File picker

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::FilePicker;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Foundation::Collections;
00024 using namespace Windows::Storage;
00025 using namespace Windows::Storage::Pickers;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario2::Scenario2()
00031 {
00032     InitializeComponent();
00033     rootPage = MainPage::Current;
00034     PickFilesButton->Click += ref new RoutedEventHandler(this, &Scenario2::PickFilesButton_Click);
00035 }
00036
00037 void Scenario2::PickFilesButton_Click(Object^ sender, RoutedEventArgs^ e)
00038 {
00039     // Clear any previously returned files between iterations of this scenario
00040     rootPage->ResetScenarioOutput(OutputTextBlock);
00041
00042     if (rootPage->EnsureUnsnapped())
00043     {
00044         FileOpenPicker^ openPicker = ref new FileOpenPicker();
00045         openPicker->ViewMode = PickerViewMode::List;
00046         openPicker->SuggestedStartLocation = PickerLocationId::DocumentsLibrary;
00047         openPicker->FileTypeFilter->Append("*");
00048
00049         create_task(openPicker->PickMultipleFilesAsync()).then([this](IVectorView<StorageFile^>^ files)
00050         {
00051             if (files->Size > 0)
00052             {
00053                 String^ output = "Picked files:\n";
00054                 std::for_each(begin(files), end(files), [this, &output](StorageFile ^file)
00055                 {
00056                     output += file->Name + "\n";
00057                 });
00058                 OutputTextBlock->Text = output;
00059             }
00060             else
00061             {
00062                 OutputTextBlock->Text = "Operation cancelled.";
00063             }
00064         });
00065     }
00066 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

EaseInOutExponentialAnimation< T > Member List

This is the complete list of members for EaseInOutExponentialAnimation< T >, including all inherited members.
Animation(T start, T end, T duration) | Animation< T > | [inline]
ComputeValue(T time) | EaseInOutExponentialAnimation< T > | [inline, protected, virtual]
EaseInOutExponentialAnimation(T start=0, T end=0, T duration=0) | EaseInOutExponentialAnimation< T > | [inline]
GetDuration() | Animation< T > | [inline]
GetEnd() | Animation< T > | [inline]
GetStart() | Animation< T > | [inline]
GetValue(T time) | Animation< T > | [inline]
m_Duration | Animation< T > | [protected]
m_End | Animation< T > | [protected]
m_Start | Animation< T > | [protected]
SetDuration(T duration) | Animation< T > | [inline]
SetEnd(T end) | Animation< T > | [inline]
SetStart(T start) | Animation< T > | [inline]
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Common/LayoutAwarePage.h Source File

  • DatagramSocket
  • Common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include "pch.h"
00014 #include <collection.h>
00015
00016 namespace DatagramSocketSample
00017 {
00018     namespace Common
00019     {
00020         // Suppress class "not consumable from JavaScript because it's not marked 'sealed'" warning
00021         // currently emitted despite the WebHostHidden attribute
00022         #pragma warning(push)
00023         #pragma warning(disable: 4449)
00024         /// <summary>
00025         /// Typical implementation of Page that provides several important conveniences: application
00026         /// view state to visual state mapping, GoBack and GoHome event handlers, and a default view
00027         /// model.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00031         {
00032         internal:
00033             LayoutAwarePage();
00034         public:
00035             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00036             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00037             void InvalidateVisualState();
00038             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00039             {
00040                 Windows::UI::Xaml::DependencyProperty^ get();
00041             };
00042             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ DefaultViewModel
00043             {
00044                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ get();
00045                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ value);
00046             }
00047
00048         protected:
00049             virtual void GoHome(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050             virtual void GoBack(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00051             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00052
00053         private:
00054             Platform::Collections::Map<Platform::String^, Object^>^ _defaultViewModel;
00055             Windows::Foundation::EventRegistrationToken _windowSizeEventToken;
00056             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00057             void WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00058         };
00059         #pragma warning(pop)
00060     }
00061 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/fx2device.h Source File

  • Custom driver access
  • C++,JavaScript
  • DLL

fx2device.h

Go to the documentation of this file.
00001 ﻿#pragma once
00002
00003 #include <specstrings.h>
00004 #include <deviceaccess.h>
00005 #include <winioctl.h>
00006 #include <strsafe.h>
00007
00008 #include <wrl\client.h>
00009
00010 // #include "ppltasks_mod2.h"
00011 #include <ppltasks.h>
00012
00013 #include <functional>
00014
00015 #include "public.h"
00016 #include "support.h"
00017 #include "repeater.h"
00018
00019 using namespace Windows::Foundation;
00020 using namespace Platform;
00021 using namespace Microsoft::WRL;
00022 using namespace concurrency;
00023
00024 const BYTE c_NumBarsInGraph = 8;
00025 const BYTE c_NumSwitches = 8;
00026 const BYTE c_SegmentMask[] = {
00027     0xD7, // 0
00028     0x06, // 1
00029     0xB3, // 2
00030     0xA7, // 3
00031     0x66, // 4
00032     0xE5, // 5
00033     0xF4, // 6
00034     0x07, // 7
00035     0xF7, // 8
00036     0x67, // 9
00037 };
00038 const unsigned int c_SegmentMaskCe = _countof(c_SegmentMask);
00039
00040 inline void THROW_HR(HRESULT hr)
00041 {
00042     if (hr != 0) {
00043         throw Platform::Exception::ReCreateException(hr);
00044     }
00045 }
00046
00047 namespace Samples {
00048     namespace Devices {
00049         namespace Fx2 {
00050
00051             ref class Fx2Device;
00052             ref class SwitchStateChangedEventArgs;
00053             ref class BarGraphDisplayResult;
00054
00055             public delegate void SwitchStateChangedHandler(Fx2Device^ Sender, SwitchStateChangedEventArgs^ EventArgs);
00056
00057             /// <summary>
00058             /// The device projection for an OSR Fx2 device
00059             /// </summary>
00060             public ref class Fx2Device sealed
00061             {
00062
00063             private:
00064                 String^ m_Id;
00065
00066                 ComPtr<IDeviceIoControl> m_DeviceIoControl;
00067
00068                 //
00069                 // Fields to track the switch state of the fx2 board.
00070                 //
00071                 struct {
00072                     LONG ListenerCount;
00073                     Repeater Repeater;
00074
00075                     SWITCH_STATE Buffer;
00076                     ULONG_PTR CancelContext;
00077                     ULONG FailureCount;
00078                 } m_SwitchState;
00079                 event SwitchStateChangedHandler^ m_SwitchStateChangedEvent;
00080
00081                 Fx2Device(__in IDeviceIoControl* DeviceControl, __in String^ Id);
00082                 ~Fx2Device ();
00083
00084                 void StartEventLoop();
00085                 void StopEventLoop();
00086
00087             public:
00088
00089                 /// <summary>Returns the device selector that an app should use to locate Fx2 devices</summary>
00090                 /// <returns>The selector string for the Fx2 device interface</returns>
00091                 static String^ GetDeviceSelector();
00092
00093                 static Fx2Device^ FromId(__in String^ InterfacePath);
00094
00095                 property String^ Id {String^ get();}
00096                 property BYTE SevenSegmentDisplay {BYTE get(); void set(__in BYTE value);}
00097
00098                 void SetBarGraphDisplay(__in const Array<bool>^ Values);
00099                 IAsyncOperation<BarGraphDisplayResult^>^ GetBarGraphDisplayAsync(void);
00100
00101                 property Array<bool>^ SwitchState {Array<bool>^ get();}
00102
00103                 event SwitchStateChangedHandler^ SwitchStateChanged {
00104                     EventRegistrationToken add(__in SwitchStateChangedHandler^ h);
00105                     void remove(__in EventRegistrationToken cookie);
00106                     void raise(__in Fx2Device^ Sender, __in SwitchStateChangedEventArgs^ args) {m_SwitchStateChangedEvent::raise(Sender, args);}
00107                 };
00108             };
00109
00110             public ref class SwitchStateChangedEventArgs sealed {
00111                 friend ref class Fx2Device;
00112
00113             private:
00114                 HRESULT m_Hr;
00115                 Array<bool>^ m_Switches;
00116                 SWITCH_STATE m_State;
00117
00118                 SwitchStateChangedEventArgs(__in HRESULT Hr) {
00119                     m_Hr = Hr;
00120                     m_Switches = nullptr;
00121                     ZeroMemory(&m_State, sizeof(m_State));
00122                 }
00123
00124                 SwitchStateChangedEventArgs(__in SWITCH_STATE State) {
00125                     m_Hr = S_OK;
00126                     m_Switches = ref new Array<bool>(c_NumSwitches);
00127                     m_State = State;
00128                     for(int i = 0; i < c_NumSwitches; i += 1) {
00129                         m_Switches[i] = ((State.SwitchesAsUChar & (1 << i)) != 0);
00130                     }
00131                 }
00132
00133                 void CheckResult(void) {
00134                     if (m_Hr != S_OK) {
00135                         throw Platform::Exception::CreateException(m_Hr, "Error requesting switch state");
00136                     }
00137                 }
00138
00139             public:
00140
00141                 property BYTE AsByte {BYTE get() {CheckResult(); return m_State.SwitchesAsUChar;}};
00142                 property Array<bool>^ SwitchState {Array<bool>^ get() {CheckResult(); return m_Switches;}};
00143             };
00144
00145             public ref class BarGraphDisplayResult sealed {
00146                 friend ref class Fx2Device;
00147
00148             private:
00149                 Array<bool>^ m_Bars;
00150                 BAR_GRAPH_STATE m_State;
00151                 ULONG_PTR m_CancelToken;
00152
00153                 void UpdateBars() {
00154                     for(int i = 0; i < c_NumBarsInGraph; i += 1) {
00155                         m_Bars[i] = ((m_State.BarsAsUChar & (1 << i)) != 0);
00156                     }
00157                 }
00158
00159             public:
00160                 BarGraphDisplayResult() : m_CancelToken(0) {
00161                     m_Bars = ref new Array<bool>(c_NumBarsInGraph);
00162                     ZeroMemory(&m_State, sizeof(m_State));
00163                 }
00164
00165                 property BYTE AsByte {BYTE get() {return m_State.BarsAsUChar;}};
00166                 property Array<bool>^ BarGraphDisplay {Array<bool>^ get() {return m_Bars;}}
00167
00168             internal:
00169                 ULONG_PTR* GetCancelToken(void) {return &m_CancelToken;}
00170             };
00171         }
00172     }
00173 }
00174 using namespace Samples::Devices;
00175 using namespace Samples::Devices::Fx2;
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/Scenario1.xaml.cpp Source File

  • Programmatic file search

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::FileSearch;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Foundation::Collections;
00024 using namespace Windows::Storage;
00025 using namespace Windows::Storage::Search;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario1::Scenario1()
00031 {
00032     InitializeComponent();
00033     SearchButton->Click += ref new RoutedEventHandler(this, &Scenario1::SearchButton_Click);
00034 }
00035
00036 void Scenario1::SearchButton_Click(Object^ sender, RoutedEventArgs^ e)
00037 {
00038     auto musicFolder = KnownFolders::MusicLibrary;
00039
00040     auto fileTypeFilter = ref new Platform::Collections::Vector<Platform::String^>();
00041     fileTypeFilter->Append("*");
00042
00043     auto queryOptions = ref new QueryOptions(CommonFileQuery::OrderBySearchRank, fileTypeFilter);
00044     //use the user's input to make a query
00045     queryOptions->UserSearchFilter = InputTextBox->Text;
00046     auto queryResult = musicFolder->CreateFileQueryWithOptions(queryOptions);
00047
00048     //find all files that match the query
00049     create_task(queryResult->GetFilesAsync()).then([this, queryOptions](IVectorView<StorageFile^>^ files)
00050     {
00051         String^ outputText = "";
00052
00053         //output how many files that match the query were found
00054         if (files->Size == 0)
00055         {
00056             outputText += "No files found for '" + queryOptions->UserSearchFilter + "'";
00057         }
00058         else if (files->Size == 1)
00059         {
00060             outputText += files->Size.ToString() + " file found:\n\n";
00061         }
00062         else
00063         {
00064             outputText += files->Size.ToString() + " files found:\n\n";
00065         }
00066
00067         //output the name of each file that matches the query
00068         for (unsigned int i = 0; i < files->Size; i++)
00069         {
00070             outputText += files->GetAt(i)->Name + "\n";
00071         }
00072
00073         OutputTextBlock->Text = outputText;
00074     });
00075 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioInput3.xaml.cpp Source File

  • Print

ScenarioInput3.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Input.xaml.cpp
00010 // Implementation of the Scenario3Input class.
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput3.xaml.h"
00015 #include "ScenarioOutput3.xaml.h"
00016 #include "MainPage.xaml.h"
00017
00018 using namespace PrintSample;
00019
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::Foundation;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::Graphics::Printing;
00024 using namespace Windows::UI;
00025 using namespace Windows::UI::Text;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Documents;
00028 using namespace Windows::UI::Xaml::Media;
00029 using namespace Windows::UI::Xaml::Media::Imaging;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioInput3::ScenarioInput3()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 /// <summary>
00038 /// Provide print content for scenario 3 first page
00039 /// </summary>
00040 void ScenarioInput3::PreparetPrintContent()
00041 {
00042     if (FirstPage == nullptr)
00043     {
00044         FirstPage = ref new ScenarioOutput3();
00045         StackPanel^ header = safe_cast<StackPanel^>(FirstPage->FindName("header"));
00046         header->Visibility = Windows::UI::Xaml::Visibility::Visible;
00047     }
00048
00049     // Add the (newley created) page to the printing root which is part of the visual tree and force it to go
00050     // through layout so that the linked containers correctly distribute the content inside them.
00051     PrintingRoot->Children->Append(FirstPage);
00052     PrintingRoot->InvalidateMeasure();
00053     PrintingRoot->UpdateLayout();
00054 }
00055
00056 /// <summary>
00057 /// This is the event handler for PrintManager.PrintTaskRequested.
00058 /// In order to ensure a good user experience, the system requires that the app handle the PrintTaskRequested event within the time specified by PrintTaskRequestedEventArgs->Request->Deadline.
00059 /// Therefore, we use this handler to only create the print task.
00060 /// The print settings customization can be done when the print document source is requested.
00061 /// </summary>
00062 /// <param name="sender">PrintManager</param>
00063 /// <param name="e">PrintTaskRequestedEventArgs</param>
00064 void ScenarioInput3::PrintTaskRequested(PrintManager^ sender, PrintTaskRequestedEventArgs^ e)
00065 {
00066     auto printTaskRef = std::make_shared<PrintTask^>(nullptr);
00067     *printTaskRef = e->Request->CreatePrintTask("C++ Printing SDK Sample",
00068                                                 ref new Windows::Graphics::Printing::PrintTaskSourceRequestedHandler([this, printTaskRef](PrintTaskSourceRequestedArgs^ args)
00069                                                 {
00070                                                 PrintTask^ printTask = *printTaskRef;
00071
00072                                                 IVector<String^>^ displayedOptions = printTask->Options->DisplayedOptions;
00073
00074                                                 // clear the print options that are displayed beacuse adding the same one multiple times will throw an exception
00075                                                 displayedOptions->Clear();
00076
00077                                                 // Choose the printer options to be shown.
00078                                                 // The order in which the options are appended determines the order in which they appear in the UI
00079                                                 displayedOptions->Append(StandardPrintTaskOptions::Copies);
00080                                                 displayedOptions->Append(StandardPrintTaskOptions::Orientation);
00081                                                 displayedOptions->Append(StandardPrintTaskOptions::MediaSize);
00082                                                 displayedOptions->Append(StandardPrintTaskOptions::Collation);
00083                                                 displayedOptions->Append(StandardPrintTaskOptions::Duplex);
00084
00085                                                 // Preset the default value of the printer option
00086                                                 printTask->Options->MediaSize = PrintMediaSize::NorthAmericaLegal;
00087
00088                                                 // Print Task event handler is invoked when the print job is completed.
00089                                                 printTask->Completed += ref new TypedEventHandler<PrintTask^, PrintTaskCompletedEventArgs^>(
00090                                                 [=](PrintTask^ sender, PrintTaskCompletedEventArgs^ e)
00091                                                 {
00092                                                     // Notify the user when the print operation fails.
00093                                                     if (e->Completion == Windows::Graphics::Printing::PrintTaskCompletion::Failed)
00094                                                     {
00095                                                         auto callback = ref new Windows::UI::Core::DispatchedHandler(
00096                                                         [=]()
00097                                                         {
00098                                                             RootPage->NotifyUser(ref new String(L"Failed to print."), NotifyType::ErrorMessage);
00099                                                         });
00100
00101                                                         Dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, callback);
00102                                                     }
00103                                                 });
00104
00105                                                 args->SetSource(PrintDocumentSource);
00106                                                 }));
00107 }
00108
00109 void ScenarioInput3::OnNavigatedTo(NavigationEventArgs^ e)
00110 {
00111     BasePrintPage::OnNavigatedTo(e);
00112
00113     RegisterForPrinting();
00114 }
00115
00116 void ScenarioInput3::OnNavigatedFrom(NavigationEventArgs^ e)
00117 {
00118     UnregisterForPrinting() ;
00119 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/Constants.cpp Source File

  • Check if current session is remote

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Check if current Session is remote", "SDKSample.IsRemoteSession.RemoteSession" }
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/common/LayoutAwarePage.cpp Source File

  • App settings
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/common/suspensionmanager.cpp Source File

  • XAML Popup
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Animate.cpp Source File

  • XAML DirectX 3D shooting game

Animate.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Animate.h"
00010
00011 using namespace DirectX;
00012
00013 //----------------------------------------------------------------------
00014
00015 Animate::Animate():
00016     m_continuous(false),
00017     m_startTime(0.0f),
00018     m_duration(10.0f)
00019 {
00020 }
00021
00022 //----------------------------------------------------------------------
00023
00024 float Animate::Start()
00025 {
00026     return m_startTime;
00027 }
00028
00029 //----------------------------------------------------------------------
00030
00031 void Animate::Start(_In_ float start)
00032 {
00033     m_startTime = start;
00034 }
00035
00036 //----------------------------------------------------------------------
00037
00038 float Animate::Duration()
00039 {
00040     return m_duration;
00041 }
00042
00043 //----------------------------------------------------------------------
00044
00045 void Animate::Duration(_In_ float duration)
00046 {
00047     m_duration = duration;
00048 }
00049
00050 //----------------------------------------------------------------------
00051
00052 bool Animate::Continuous()
00053 {
00054     return m_continuous;
00055 }
00056
00057 //----------------------------------------------------------------------
00058
00059 void Animate::Continuous(_In_ bool continuous)
00060 {
00061     m_continuous = continuous;
00062 }
00063
00064 //----------------------------------------------------------------------
00065
00066 AnimateLinePosition::AnimateLinePosition(
00067     _In_ XMFLOAT3 startPosition,
00068     _In_ XMFLOAT3 endPosition,
00069     _In_ float duration,
00070     _In_ bool continuous)
00071 {
00072     m_startPosition = startPosition;
00073     m_endPosition = endPosition;
00074     m_duration = duration;
00075     m_continuous = continuous;
00076
00077     m_length = XMVectorGetX(
00078         XMVector3Length(XMLoadFloat3(&endPosition) - XMLoadFloat3(&startPosition))
00079         );
00080 }
00081
00082 //----------------------------------------------------------------------
00083
00084 XMFLOAT3 AnimateLinePosition::Evaluate(_In_ float t)
00085 {
00086     if (t <= m_startTime)
00087     {
00088         return m_startPosition;
00089     }
00090
00091     if ((t >= (m_startTime + m_duration)) && !m_continuous)
00092     {
00093         return m_endPosition;
00094     }
00095
00096     float startTime = m_startTime;
00097     if (m_continuous)
00098     {
00099         // For continuous operation move the start time forward to
00100         // eliminate previous iterations.
00101         startTime += ((int)((t - m_startTime) / m_duration)) * m_duration;
00102     }
00103
00104     float u = (t - startTime) / m_duration;
00105     XMFLOAT3 currentPosition;
00106     currentPosition.x = m_startPosition.x + (m_endPosition.x - m_startPosition.x)*u;
00107     currentPosition.y = m_startPosition.y + (m_endPosition.y - m_startPosition.y)*u;
00108     currentPosition.z = m_startPosition.z + (m_endPosition.z - m_startPosition.z)*u;
00109
00110     return currentPosition;
00111 }
00112
00113 //----------------------------------------------------------------------
00114
00115 AnimateLineListPosition::AnimateLineListPosition(
00116     _In_ unsigned int count,
00117     _In_reads_(count) XMFLOAT3 position[],
00118     _In_ float duration,
00119     _In_ bool continuous)
00120 {
00121     m_duration = duration;
00122     m_continuous = continuous;
00123     m_count = count;
00124
00125     std::vector<LineSegment> segment(m_count);
00126     m_segment = segment;
00127     m_totalLength = 0.0f;
00128
00129     m_segment[0].position = position[0];
00130     for (unsigned int i = 1; i < count; i++)
00131     {
00132         m_segment[i].position = position[i];
00133         m_segment[i - 1].length = XMVectorGetX(
00134             XMVector3Length(
00135                 XMLoadFloat3(&m_segment[i].position) -
00136                 XMLoadFloat3(&m_segment[i - 1].position)
00137                 )
00138             );
00139         m_totalLength += m_segment[i - 1].length;
00140     }
00141
00142     // Parameterize the segments to ensure uniform evaluation along the path.
00143     float u = 0.0f;
00144     for (unsigned int i = 0; i < (count - 1); i++)
00145     {
00146         m_segment[i].uStart = u;
00147         m_segment[i].uLength = (m_segment[i].length / m_totalLength);
00148         u += m_segment[i].uLength;
00149     }
00150     m_segment[count-1].uStart = 1.0f;
00151 }
00152
00153 //----------------------------------------------------------------------
00154
00155 XMFLOAT3 AnimateLineListPosition::Evaluate(_In_ float t)
00156 {
00157     if (t <= m_startTime)
00158     {
00159         return m_segment[0].position;
00160     }
00161
00162     if ((t >= (m_startTime + m_duration)) && !m_continuous)
00163     {
00164         return m_segment[m_count-1].position;
00165     }
00166
00167     float startTime = m_startTime;
00168     if (m_continuous)
00169     {
00170         // For continuous operation move the start time forward to
00171         // eliminate previous iterations.
00172         startTime += ((int)((t - m_startTime) / m_duration)) * m_duration;
00173     }
00174
00175     float u = (t - startTime) / m_duration;
00176     // Find the right segment.
00177     unsigned int i = 0;
00178     while (u > m_segment[i + 1].uStart)
00179     {
00180         i++;
00181     }
00182
00183     u -= m_segment[i].uStart;
00184     u /= m_segment[i].uLength;
00185
00186     XMFLOAT3 currentPosition;
00187     currentPosition.x = m_segment[i].position.x + (m_segment[i + 1].position.x - m_segment[i].position.x)*u;
00188     currentPosition.y = m_segment[i].position.y + (m_segment[i + 1].position.y - m_segment[i].position.y)*u;
00189     currentPosition.z = m_segment[i].position.z + (m_segment[i + 1].position.z - m_segment[i].position.z)*u;
00190
00191     return currentPosition;
00192 }
00193
00194 //----------------------------------------------------------------------
00195
00196 AnimateCirclePosition:: AnimateCirclePosition(
00197     _In_ XMFLOAT3 center,
00198     _In_ XMFLOAT3 startPosition,
00199     _In_ XMFLOAT3 planeNormal,
00200     _In_ float duration,
00201     _In_ bool continuous,
00202     _In_ bool clockwise)
00203 {
00204     m_center = center;
00205     m_planeNormal = planeNormal;
00206     m_startPosition = startPosition;
00207     m_duration = duration;
00208     m_continuous = continuous;
00209     m_clockwise = clockwise;
00210
00211     XMVECTOR coordX = XMLoadFloat3(&m_startPosition) - XMLoadFloat3(&m_center);
00212     m_radius = XMVectorGetX(XMVector3Length(coordX));
00213
00214     XMVector3Normalize(coordX);
00215
00216     XMVECTOR coordZ = XMLoadFloat3(&m_planeNormal);
00217     XMVector3Normalize(coordZ);
00218
00219     XMVECTOR coordY;
00220     if (m_clockwise)
00221     {
00222         coordY = XMVector3Cross(coordZ, coordX);
00223     }
00224     else
00225     {
00226         coordY = XMVector3Cross(coordX, coordZ);
00227     }
00228
00229     XMVECTOR vectorX = XMVectorSet(1.0f, 0.0f, 0.0f, 1.0f);
00230     XMVECTOR vectorY = XMVectorSet(0.0f, 1.0f, 0.0f, 1.0f);
00231     XMMATRIX mat1 = XMMatrixIdentity();
00232     XMMATRIX mat2 = XMMatrixIdentity();
00233
00234     if (!XMVector3Equal(coordX, vectorX))
00235     {
00236         float angle;
00237         angle = XMVectorGetX(
00238             XMVector3AngleBetweenVectors(vectorX, coordX)
00239             );
00240         if ((angle * angle) > 0.025)
00241         {
00242             XMVECTOR axis1 = XMVector3Cross(vectorX, coordX);
00243
00244             mat1 = XMMatrixRotationAxis(axis1, angle);
00245             vectorY = XMVector3TransformCoord(vectorY, mat1);
00246         }
00247     }
00248     if (!XMVector3Equal(vectorY, coordY))
00249     {
00250         float angle;
00251         angle = XMVectorGetX(
00252             XMVector3AngleBetweenVectors(vectorY, coordY)
00253             );
00254         if ((angle * angle) > 0.025)
00255         {
00256             XMVECTOR axis2 = XMVector3Cross(vectorY, coordY);
00257             mat2 = XMMatrixRotationAxis(axis2, angle);
00258         }
00259     }
00260     XMStoreFloat4x4(
00261         &m_rotationMatrix,
00262         mat1 *
00263         mat2 *
00264         XMMatrixTranslation(m_center.x, m_center.y, m_center.z)
00265         );
00266 }
00267
00268 //----------------------------------------------------------------------
00269
00270 XMFLOAT3 AnimateCirclePosition::Evaluate(_In_ float t)
00271 {
00272     if (t <= m_startTime)
00273     {
00274         return m_startPosition;
00275     }
00276
00277     if ((t >= (m_startTime + m_duration)) && !m_continuous)
00278     {
00279         return m_startPosition;
00280     }
00281
00282     float startTime = m_startTime;
00283     if (m_continuous)
00284     {
00285         // For continuous operation move the start time forward to
00286         // eliminate previous iterations.
00287         startTime += ((int)((t - m_startTime) / m_duration)) * m_duration;
00288     }
00289
00290     float u = (t - startTime) / m_duration * XM_2PI;
00291
00292     XMFLOAT3 currentPosition;
00293     currentPosition.x = m_radius * cos(u);
00294     currentPosition.y = m_radius * sin(u);
00295     currentPosition.z = 0.0f;
00296
00297     XMStoreFloat3(
00298         &currentPosition,
00299         XMVector3TransformCoord(
00300             XMLoadFloat3(&currentPosition),
00301             XMLoadFloat4x4(&m_rotationMatrix)
00302             )
00303         );
00304
00305     return currentPosition;
00306 }
00307
00308 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ScenarioSingle.xaml.cpp Source File

  • Contact Picker app

ScenarioSingle.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ScenarioSingle.xaml.cpp
00013 // Implementation of the ScenarioSingle class
00014 //
00015
00016 #include "pch.h"
00017 #include "ScenarioSingle.xaml.h"
00018
00019 using namespace ContactPicker;
00020 using namespace concurrency;
00021 using namespace Platform;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::Foundation::Collections;
00024 using namespace Windows::Storage::Streams;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Media::Imaging;
00028
00029 void AppendContactFieldValues(TextBlock^ header, TextBlock^ content, IVectorView<Contacts::ContactField^>^ fields);
00030
00031 ScenarioSingle::ScenarioSingle()
00032 {
00033     InitializeComponent();
00034     PickAContactButton->Click += ref new RoutedEventHandler(this, &ScenarioSingle::PickAContactButton_Click);
00035 }
00036
00037 void ScenarioSingle::PickAContactButton_Click(Object^ sender, RoutedEventArgs^ e)
00038 {
00039     MainPage^ page = MainPage::Current;
00040
00041     if (page->EnsureUnsnapped())
00042     {
00043         auto contactPicker = ref new Contacts::ContactPicker();
00044         contactPicker->CommitButtonText = "Select";
00045
00046         create_task(contactPicker->PickSingleContactAsync()).then([this](Contacts::ContactInformation^ contact)
00047         {
00048             if (contact != nullptr)
00049             {
00050                 OutputFields->Visibility = Windows::UI::Xaml::Visibility::Visible;
00051                 OutputEmpty->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00052
00053                 OutputName->Text = contact->Name;
00054                 AppendContactFieldValues(OutputEmailHeader, OutputEmails, contact->Emails);
00055                 AppendContactFieldValues(OutputPhoneNumberHeader, OutputPhoneNumbers, contact->PhoneNumbers);
00056
00057                 create_task(contact->GetThumbnailAsync()).then([this](IRandomAccessStreamWithContentType^ stream)
00058                 {
00059                     if (stream != nullptr && stream->Size > 0)
00060                     {
00061                         BitmapImage^ bitmap = ref new BitmapImage();
00062                         bitmap->SetSource(stream);
00063                         OutputThumbnail->Source = bitmap;
00064                     }
00065                     else
00066                     {
00067                         OutputThumbnail->Source = nullptr;
00068                     }
00069                 });
00070             }
00071             else
00072             {
00073                 OutputEmpty->Visibility = Windows::UI::Xaml::Visibility::Visible;
00074                 OutputFields->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00075                 OutputThumbnail->Source = nullptr;
00076             }
00077         });
00078     }
00079 }
00080
00081 void AppendContactFieldValues(TextBlock^ header, TextBlock^ content, IVectorView<Contacts::ContactField^>^ fields)
00082 {
00083     if (fields->Size > 0)
00084     {
00085         String^ output = "";
00086         std::for_each(begin(fields), end(fields), [&output](Contacts::ContactField^ field)
00087         {
00088             output += field->Value + "\n";
00089         });
00090
00091         header->Visibility = Visibility::Visible;
00092         content->Visibility = Visibility::Visible;
00093         content->Text = output;
00094     }
00095     else
00096     {
00097         header->Visibility = Visibility::Collapsed;
00098         content->Visibility = Visibility::Collapsed;
00099     }
00100 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/DataChangedEvent.xaml.h Source File

  • Application data

DataChangedEvent.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DataChangedEvent.xaml.h
00013 // Declaration of the DataChangedEvent class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "DataChangedEvent.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ApplicationDataSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class DataChangedEvent sealed
00031         {
00032         public:
00033             DataChangedEvent();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             Windows::Storage::ApplicationData^ applicationData;
00040
00041             void SimulateRoaming_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042             void WriteOutputText();
00043             void DataChangedHandler(Windows::Storage::ApplicationData^ appData, Object^);
00044             void DisplayOutput();
00045         };
00046     }
00047 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DDSTextureLoader.h Source File

  • Direct3D HLSL fractal generator

DDSTextureLoader.h

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.h
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #pragma once
00019
00020 void CreateDDSTextureFromMemory(
00021     _In_ ID3D11Device* d3dDevice,
00022     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
00023     _In_ size_t ddsDataSize,
00024     _Out_opt_ ID3D11Resource** texture,
00025     _Out_opt_ ID3D11ShaderResourceView** textureView,
00026     _In_ size_t maxsize = 0
00027     );
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/App.xaml.cpp Source File

  • Clipboard app

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "App.xaml.h"
00018 #include "MainPage.xaml.h"
00019
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::ApplicationModel::Activation;
00024 using namespace CppSamplesUtils;
00025 using namespace Clipboard;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 App::App()
00029 {
00030     InitializeComponent();
00031     Suspending += ref new SuspendingEventHandler(this, &App::OnSuspending);
00032 }
00033
00034 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00035 {
00036     auto deferral = pArgs->SuspendingOperation->GetDeferral();
00037     SuspensionManager::StartSaveTask().then(
00038         [=]()
00039         {
00040             deferral->Complete();
00041         });
00042 }
00043
00044 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00045 {
00046     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00047     {
00048         SuspensionManager::StartRestoreTask().then(
00049             [=](concurrency::task<void> restoreTask)
00050             {
00051                 try
00052                 {
00053                     restoreTask.get();
00054                 }
00055                 catch(Platform::Exception^)
00056                 {
00057                     // If restore fails, the app should proceed as though there was no restored state.
00058                 }
00059
00060                 SetupWindowing(pArgs);
00061             });
00062     }
00063     else
00064     {
00065         SetupWindowing(pArgs);
00066     }
00067 }
00068
00069 void App::SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00070 {
00071     if (Window::Current->Content == nullptr)
00072     {
00073         rootFrame = ref new Frame();
00074         TypeName pageType = { "Clipboard.MainPage", TypeKind::Custom };
00075         rootFrame->Navigate(pageType);
00076         Window::Current->Content = rootFrame;
00077     }
00078
00079     MainPage^ p = safe_cast<MainPage^>(rootFrame->Content);
00080     p->LaunchArgs = pArgs;
00081     Window::Current->Activate();
00082 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/Scenario1.xaml.h Source File

  • LightSensor

Scenario1.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace LightSensorCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             Windows::Devices::Sensors::LightSensor^ sensor;
00042             Windows::Foundation::EventRegistrationToken visibilityToken;
00043             Windows::Foundation::EventRegistrationToken readingToken;
00044             uint32 desiredReportInterval;
00045
00046             void VisibilityChanged(Platform::Object^ sender, Windows::UI::Core::VisibilityChangedEventArgs^ e);
00047             void ReadingChanged(Windows::Devices::Sensors::LightSensor^ sender, Windows::Devices::Sensors::LightSensorReadingChangedEventArgs^ e);
00048             void ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00049             void ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00050         };
00051     }
00052 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/FaceMesh.cpp Source File

  • XAML DirectX 3D shooting game

FaceMesh.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "FaceMesh.h"
00010 #include "DirectXSample.h"
00011 #include "ConstantBuffers.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace DirectX;
00015
00016 FaceMesh::FaceMesh(_In_ ID3D11Device *device)
00017 {
00018     D3D11_BUFFER_DESC bd = {0};
00019     D3D11_SUBRESOURCE_DATA initData = {0};
00020
00021     PNTVertex target_vertices[] =
00022     {
00023         {XMFLOAT3(0.0f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.0f, 1.0f), XMFLOAT2(1.0f, 1.0f)},
00024         {XMFLOAT3(1.0f, 0.0f, 0.0f), XMFLOAT3(0.0f, 0.0f, 1.0f), XMFLOAT2(0.0f, 1.0f)},
00025         {XMFLOAT3(1.0f, 1.0f, 0.0f), XMFLOAT3(0.0f, 0.0f, 1.0f), XMFLOAT2(0.0f, 0.0f)},
00026         {XMFLOAT3(0.0f, 1.0f, 0.0f), XMFLOAT3(0.0f, 0.0f, 1.0f), XMFLOAT2(1.0f, 0.0f)}
00027     };
00028     WORD target_indices[] =
00029     {
00030         0, 1, 2,
00031         0, 2, 3,
00032         0, 2, 1,
00033         0, 3, 2
00034     };
00035
00036     m_vertexCount = 4;
00037     m_indexCount = 12;
00038
00039     bd.Usage = D3D11_USAGE_DEFAULT;
00040     bd.ByteWidth = sizeof(PNTVertex) * m_vertexCount;
00041     bd.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00042     bd.CPUAccessFlags = 0;
00043     initData.pSysMem = target_vertices;
00044     DX::ThrowIfFailed(
00045         device->CreateBuffer(&bd, &initData, &m_vertexBuffer)
00046         );
00047
00048     bd.Usage = D3D11_USAGE_DEFAULT;
00049     bd.ByteWidth = sizeof(WORD) * m_indexCount;
00050     bd.BindFlags = D3D11_BIND_INDEX_BUFFER;
00051     bd.CPUAccessFlags = 0;
00052     initData.pSysMem = target_indices;
00053     DX::ThrowIfFailed(
00054         device->CreateBuffer(&bd, &initData, &m_indexBuffer)
00055         );
00056 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AccountPictureName::Common::LayoutAwarePage Member List

This is the complete list of members for AccountPictureName::Common::LayoutAwarePage, including all inherited members.
__pad0__ | AccountPictureName::Common::LayoutAwarePage |
_defaultViewModel | AccountPictureName::Common::LayoutAwarePage | [private]
_layoutAwareControls | AccountPictureName::Common::LayoutAwarePage | [private]
_windowSizeEventToken | AccountPictureName::Common::LayoutAwarePage | [private]
DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState) | AccountPictureName::Common::LayoutAwarePage | [virtual]
GoBack(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::Common::LayoutAwarePage | [virtual]
InvalidateVisualState() | AccountPictureName::Common::LayoutAwarePage |
StartLayoutUpdates(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::Common::LayoutAwarePage |
StopLayoutUpdates(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::Common::LayoutAwarePage |
WindowSizeChanged(Object^sender, Windows::UI::Core::WindowSizeChangedEventArgs^e) | AccountPictureName::Common::LayoutAwarePage | [private]
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/ImageProtocols.xaml.cpp Source File

  • App tiles and badges
  • C#,C++

ImageProtocols.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ImageProtocols.xaml.cpp
00013 // Implementation of the ImageProtocols class
00014 //
00015
00016 #include "pch.h"
00017 #include "ImageProtocols.xaml.h"
00018
00019 using namespace SDKSample::Tiles;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::Notifications;
00025 using namespace NotificationsExtensions::TileContent;
00026 using namespace Windows::Storage::Pickers;
00027 using namespace Windows::Storage;
00028 using namespace concurrency;
00029
00030 ImageProtocols::ImageProtocols()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 void ImageProtocols::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     rootPage = MainPage::Current;
00038     LocalFolder->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00039     HTTP->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00040     ProtocolList->SelectedIndex = 0;
00041     imageRelativePath = "copy a file first";
00042 }
00043
00044 void ImageProtocols::ProtocolList_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00045 {
00046     LocalFolder->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00047     HTTP->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00048
00049     if (ProtocolList->SelectedIndex == 1)
00050     {
00051         LocalFolder->Visibility = Windows::UI::Xaml::Visibility::Visible;
00052     }
00053     else if (ProtocolList->SelectedIndex == 2)
00054     {
00055         HTTP->Visibility = Windows::UI::Xaml::Visibility::Visible;
00056     }
00057 }
00058
00059 void ImageProtocols::SendTileNotification_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00060 {
00061     IWideTileNotificationContent^ tileContent;
00062     if (ProtocolList->SelectedIndex == 0) //using the ms-appx:/// protocol
00063     {
00064         auto wideContent = TileContentFactory::CreateTileWideImageAndText01();
00065         wideContent->TextCaptionWrap->Text = "The image is in the appx package";
00066         wideContent->Image->Src = "ms-appx:///redWide.png";
00067         wideContent->Image->Alt = "Red image";
00068
00069         tileContent = wideContent;
00070     }
00071     else if (ProtocolList->SelectedIndex == 1) //using the ms-appdata:///local/ protocol
00072     {
00073         auto wideContent = TileContentFactory::CreateTileWideImage();
00074         wideContent->Image->Src = imageRelativePath;
00075         wideContent->Image->Alt ="App data";
00076         tileContent = wideContent;
00077     }
00078     else if (ProtocolList->SelectedIndex == 2) //using http:// protocol
00079     {
00080         // Important - The Internet (Client) capability must be checked in the manifest in the Capabilities tab
00081         auto wideContent = TileContentFactory::CreateTileWidePeekImageCollection04();
00082         wideContent->BaseUri = HTTPBaseURI->Text;
00083         wideContent->TextBodyWrap->Text = "The base URI is " + HTTPBaseURI->Text;
00084         wideContent->ImageMain->Src = HTTPImage1->Text;
00085         wideContent->ImageSmallColumn1Row1->Src = HTTPImage2->Text;
00086         wideContent->ImageSmallColumn1Row2->Src = HTTPImage3->Text;
00087         wideContent->ImageSmallColumn2Row1->Src = HTTPImage4->Text;
00088         wideContent->ImageSmallColumn2Row2->Src = HTTPImage5->Text;
00089
00090         tileContent = wideContent;
00091     }
00092
00093     if (tileContent != nullptr)
00094     {
00095         tileContent->RequireSquareContent = false;
00096         TileUpdateManager::CreateTileUpdaterForApplication()->Update(tileContent->CreateNotification());
00097
00098         OutputTextBlock->Text = tileContent->GetContent();
00099     }
00100 }
00101
00102 void ImageProtocols::PickImage_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00103 {
00104     if (rootPage->EnsureUnsnapped())
00105     {
00106         auto openPicker = ref new FileOpenPicker();
00107         openPicker->ViewMode = PickerViewMode::Thumbnail;
00108         openPicker->SuggestedStartLocation = PickerLocationId::PicturesLibrary;
00109         openPicker->FileTypeFilter->Append(".png");
00110         openPicker->FileTypeFilter->Append(".gif");
00111
00112         task<StorageFile^> pickImageTask(openPicker->PickSingleFileAsync());
00113         TextBlock^ outputBlock = OutputTextBlock;
00114         pickImageTask.then([this, outputBlock](StorageFile^ file)
00115         {
00116             if( file != nullptr )
00117             {
00118                 // Get the returned file and copy it
00119                 auto local = ApplicationData::Current->LocalFolder;
00120                 task<StorageFile^> copyFileTask(file->CopyAsync(local, file->Name, NameCollisionOption::ReplaceExisting));
00121                 imageRelativePath = file->Name;
00122                 copyFileTask.then([outputBlock,file](task<StorageFile^> copiedFileTask)
00123                 {
00124                     StorageFile^ copiedFile;
00125                     try
00126                     {
00127                         copiedFile = copiedFileTask.get();
00128                     }
00129                     catch (Platform::Exception^ e)
00130                     {
00131                         outputBlock->Text = "Error copying file";
00132                     }
00133
00134                     if (copiedFile != nullptr)
00135                     {
00136                         outputBlock->Text = "File " + copiedFile->Name + " was copied from " + file->Name;
00137                     }
00138                 });
00139             }
00140             else
00141             {
00142                 outputBlock->Text = "File selection cancelled by user.";
00143             }
00144         });
00145     }
00146     else
00147     {
00148         OutputTextBlock->Text = "Cannot unsnap the sample application.";
00149     }
00150 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/pch.h Source File

  • Syndication

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ComputeCB Member List

This is the complete list of members for ComputeCB, including all inherited members.
deltaPerDtidX | ComputeCB
deltaPerDtidY | ComputeCB
originDtid00 | ComputeCB
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKMESH_VERTEX_BUFFER_HEADER Member List

This is the complete list of members for SDKMESH_VERTEX_BUFFER_HEADER, including all inherited members.
DataOffset | SDKMESH_VERTEX_BUFFER_HEADER
Decl | SDKMESH_VERTEX_BUFFER_HEADER
NumVertices | SDKMESH_VERTEX_BUFFER_HEADER
SizeBytes | SDKMESH_VERTEX_BUFFER_HEADER
StrideBytes | SDKMESH_VERTEX_BUFFER_HEADER
VertexBuffer | SDKMESH_VERTEX_BUFFER_HEADER
Generated on Sat Nov 23 2024 16:09:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Utils Member List

This is the complete list of members for Utils, including all inherited members.
GetDistance(COLORREF color1, COLORREF color2) | Utils | [inline, static]
RGBToYUV(COLORREF color, float64 &y, float64 &u, float64 &v) | Utils | [inline, static]
SmoothStep(float a, float b, float x) | Utils | [inline, static]
Wb | Utils | [static]
Wg | Utils | [static]
Wr | Utils | [static]
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/common/LayoutAwarePage.h Source File

  • Geolocation
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/Constants.h Source File

  • IXmlReader and IXmlWriter XML data readwrite

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME {
00027             Platform::String^ get() {  return ref new Platform::String(L"XmlLite Sample"); }
00028         }
00029
00030         static property Platform::Array<Scenario>^ scenarios {
00031             Platform::Array<Scenario>^ get()
00032             {
00033                 return scenariosInner;
00034             }
00035         }
00036     private:
00037         static Platform::Array<Scenario>^ scenariosInner;
00038     };
00039
00040
00041 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/App.xaml.cpp Source File

  • OrientationSensor

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/App.xaml.h Source File

  • Playback Manager msAudioCategory

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario4.xaml.cpp Source File

  • AtomPub

Scenario4.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.cpp
00013 // Implementation of the Scenario4 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario4.xaml.h"
00018
00019 using namespace SDKSample::AtomPub;
00020
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Concurrency;
00023 using namespace Windows::Web;
00024
00025 Scenario4::Scenario4()
00026 {
00027     InitializeComponent();
00028
00029     // Helps iterating through feeds.
00030     this->feedIterator = ref new SyndicationItemIterator();
00031 }
00032
00033 /// <summary>
00034 /// Invoked when this page is about to be displayed in a Frame.
00035 /// </summary>
00036 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00037 /// property is typically used to configure the page.</param>
00038 void Scenario4::OnNavigatedTo(NavigationEventArgs^ e)
00039 {
00040     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00041     // as NotifyUser().
00042     rootPage = MainPage::Current;
00043
00044     CommonData::Restore(this);
00045 }
00046
00047 void Scenario4::OnNavigatingFrom(NavigatingCancelEventArgs^ e)
00048 {
00049     CommonData::Save(ServiceAddressField->Text, UserNameField->Text, PasswordField->Password);
00050 }
00051
00052 // Download a feed.
00053 void Scenario4::GetFeed_Click(Object^ sender, RoutedEventArgs^ e)
00054 {
00055     OutputField->Text = "";
00056
00057     // If we retrieve the feed via the Edit uri then we will be logged in and be
00058     // able to modify/delete the resource.
00059
00060     // Since the value of 'ServiceAddressField' was provided by the user it is untrusted input. We'll validate it
00061     // by using TryGetUri().
00062     // Note that this app has both "Internet (Client)" and "Home and Work Networking" capabilities set, since
00063     // the user may provide URIs for servers located on the intErnet or intrAnet. If apps only communicate
00064     // with servers on the intErnet, only the "Internet (Client)" capability should be set. Similarly if an
00065     // app is only intended to communicate on the intrAnet, only the "Home and Work Networking" capability should be set.
00066     Uri^ resourceUri;
00067     if (!rootPage->TryGetUri(StringHelper::Trim(ServiceAddressField->Text) + CommonData::EditUri, &resourceUri))
00068     {
00069         return;
00070     }
00071
00072     rootPage->NotifyUser("Fetching feed...", NotifyType::StatusMessage);
00073     OutputField->Text = "Requested feed: " + resourceUri->DisplayUri + "\r\n";
00074
00075     task<SyndicationFeed^>(CommonData::GetClient()->RetrieveFeedAsync(resourceUri)).then([this] (SyndicationFeed^ feed)
00076     {
00077         this->feedIterator->AttachFeed(feed);
00078
00079         rootPage->NotifyUser("Fetching feed completed.", NotifyType::StatusMessage);
00080
00081         if (this->feedIterator->HasElements())
00082         {
00083             OutputField->Text += "Got feed\r\n";
00084             OutputField->Text += "Title: " + this->feedIterator->GetTitle() + "\r\n";
00085             OutputField->Text += "EditUri: " + this->feedIterator->GetEditUri()->DisplayUri + "\r\n";
00086
00087             DisplayItem();
00088         }
00089         else
00090         {
00091             OutputField->Text += "Got empty feed\r\n";
00092         }
00093     }).then([this] (task<void> t)
00094     {
00095         try
00096         {
00097             t.get();
00098         }
00099         catch (Exception^ exception)
00100         {
00101             if (!rootPage->HandleException(exception, OutputField))
00102             {
00103                 throw;
00104             }
00105         }
00106     });
00107 }
00108
00109 // Update the current item.
00110 void Scenario4::UpdateItem_Click(Object^ sender, RoutedEventArgs^ e)
00111 {
00112     if (!this->feedIterator->HasElements())
00113     {
00114         rootPage->NotifyUser("No item currently displayed, please download a feed first.", NotifyType::ErrorMessage);
00115         return;
00116     }
00117
00118     rootPage->NotifyUser("Updating item...", NotifyType::StatusMessage);
00119     OutputField->Text += "Item location: " + feedIterator->GetEditUri()->DisplayUri + "\r\n";
00120
00121     // Update the item.
00122     SyndicationItem^ updatedItem = ref new SyndicationItem();
00123     updatedItem->Title = ref new SyndicationText(TitleBox->Text, SyndicationTextType::Text);
00124     updatedItem->Content = ref new SyndicationContent(ContentBox->Text, SyndicationTextType::Html);
00125
00126     task<void>(CommonData::GetClient()->UpdateResourceAsync(this->feedIterator->GetEditUri(), updatedItem)).then([this] (task<void> t)
00127     {
00128         try
00129         {
00130             t.get();
00131
00132             rootPage->NotifyUser("Item updated.", NotifyType::StatusMessage);
00133         }
00134         catch (Exception^ exception)
00135         {
00136             if (!rootPage->HandleException(exception, OutputField))
00137             {
00138                 throw;
00139             }
00140         }
00141     });
00142 }
00143
00144 void Scenario4::PreviousItem_Click(Object^ sender, RoutedEventArgs^ e)
00145 {
00146     this->feedIterator->MovePrevious();
00147     DisplayItem();
00148 }
00149
00150 void Scenario4::NextItem_Click(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     this->feedIterator->MoveNext();
00153     DisplayItem();
00154 }
00155
00156 void Scenario4::UserNameField_TextChanged(Object^ sender, TextChangedEventArgs^ e)
00157 {
00158     CommonData::Save(ServiceAddressField->Text, UserNameField->Text, PasswordField->Password);
00159 }
00160
00161 void Scenario4::PasswordField_PasswordChanged(Object^ sender, RoutedEventArgs^ e)
00162 {
00163     CommonData::Save(ServiceAddressField->Text, UserNameField->Text, PasswordField->Password);
00164 }
00165
00166 void Scenario4::DisplayItem()
00167 {
00168     IndexField->Text = this->feedIterator->GetIndexDescription();
00169     TitleBox->Text = this->feedIterator->GetTitle();
00170     ContentBox->Text = feedIterator->GetContent();
00171 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/TripOptimizer.h Source File

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp

TripOptimizer.h

Go to the documentation of this file.
00001 ﻿//-----------------------------------------------------------------------
00002 //
00003 //  Copyright (C) Microsoft Corporation.  All rights reserved.
00004 //
00005 //
00006 // THIS CODE AND INFORMATION ARE PROVIDED AS-IS WITHOUT WARRANTY OF ANY
00007 // KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00008 // IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //-----------------------------------------------------------------------
00011 #pragma once
00012
00013 namespace TripOptimizerComponent
00014 {
00015     // Forward declarations.
00016     namespace Details
00017     {
00018         class TripOptimizerImpl;
00019     }
00020
00021     // Defines the TripOptimizer class. This class interfaces between the app
00022     // and the implementation details.
00023     public ref class TripOptimizer sealed
00024     {
00025     public:
00026         TripOptimizer();
00027
00028         // Optimizes a trip as an asynchronous process.
00029         Windows::Foundation::IAsyncOperationWithProgress<
00030             Windows::Foundation::Collections::IMap<
00031                 Platform::String^,
00032                 Windows::Foundation::Collections::IVector<Platform::String^>^>^,
00033             Platform::String^>^ OptimizeTripAsync(
00034                 Windows::Foundation::Collections::IVector<Platform::String^>^ waypoints,
00035                 Platform::String^ travelMode,
00036                 Platform::String^ optimize,
00037                 Platform::String^ bingMapsKey,
00038                 double alpha, double beta, double rho,
00039                 unsigned int iterations, bool parallel);
00040
00041     private:
00042         ~TripOptimizer();
00043         // Defines implementation details of the optimization routine.
00044         std::unique_ptr<Details::TripOptimizerImpl> m_impl;
00045     };
00046 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/RotateImageViewModel.cpp Source File

  • Hilo C++
  • Hilo

RotateImageViewModel.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "RotateImageViewModel.h"
00009 #include "DelegateCommand.h"
00010 #include "IPhoto.h"
00011 #include "ImageNavigationData.h"
00012 #include "TaskExceptionsExtensions.h"
00013 #include "Repository.h"
00014 #include "ExifExtensions.h"
00015
00016 #define EXIFOrientationPropertyName "System.Photo.Orientation"
00017
00018 using namespace concurrency;
00019 using namespace Hilo;
00020 using namespace Platform;
00021 using namespace Platform::Collections;
00022 using namespace std;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::Foundation::Collections;
00025 using namespace Windows::Graphics::Imaging;
00026 using namespace Windows::Storage;
00027 using namespace Windows::Storage::Streams;
00028 using namespace Windows::UI::ViewManagement;
00029 using namespace Windows::UI::Xaml;
00030 using namespace Windows::UI::Xaml::Input;
00031 using namespace Windows::UI::Xaml::Navigation;
00032
00033 Platform::String^ const RotationStateKey = "rotation";
00034 Platform::String^ const MarginLeftStateKey = "margin-left";
00035 Platform::String^ const MarginTopStateKey = "margin-top";
00036 Platform::String^ const MarginRightStateKey = "margin-right";
00037 Platform::String^ const MarginBottomStateKey = "margin-bottom";
00038
00039 RotateImageViewModel::RotateImageViewModel(shared_ptr<Repository> repository, shared_ptr<ExceptionPolicy> exceptionPolicy) :
00040     ImageBase(exceptionPolicy), m_repository(repository), m_imageMargin(Thickness(0.0)), m_getPhotoAsyncIsRunning(false),
00041     m_inProgress(false), m_isSaving(false), m_rotationAngle(0.0)
00042 {
00043     m_rotateCommand = ref new DelegateCommand(ref new ExecuteDelegate(this, &RotateImageViewModel::Rotate90), nullptr);
00044     m_resumeRotateCommand = ref new DelegateCommand(ref new ExecuteDelegate(this, &RotateImageViewModel::Unsnap), nullptr);
00045     m_saveCommand = ref new DelegateCommand(ref new ExecuteDelegate(this, &RotateImageViewModel::SaveImage), nullptr);
00046     m_cancelCommand = ref new DelegateCommand(ref new ExecuteDelegate(this, &RotateImageViewModel::CancelRotate), nullptr);
00047
00048     ViewModelBase::m_isAppBarSticky = true;
00049 }
00050
00051 ICommand^ RotateImageViewModel::RotateCommand::get()
00052 {
00053     return m_rotateCommand;
00054 }
00055
00056 ICommand^ RotateImageViewModel::ResumeRotateCommand::get()
00057 {
00058     return m_resumeRotateCommand;
00059 }
00060
00061 ICommand^ RotateImageViewModel::SaveCommand::get()
00062 {
00063     return m_saveCommand;
00064 }
00065
00066 ICommand^ RotateImageViewModel::CancelCommand::get()
00067 {
00068     return m_cancelCommand;
00069 }
00070
00071 Thickness RotateImageViewModel::ImageMargin::get()
00072 {
00073     return m_imageMargin;
00074 }
00075
00076 bool RotateImageViewModel::InProgress::get()
00077 {
00078     return m_inProgress;
00079 }
00080
00081 float64 RotateImageViewModel::RotationAngle::get()
00082 {
00083     return m_rotationAngle;
00084 }
00085
00086 void RotateImageViewModel::RotationAngle::set(float64 value)
00087 {
00088     m_rotationAngle = value;
00089
00090     // Derive margin so that rotated image is always fully shown on screen.
00091     Thickness margin(0.0);
00092     switch (safe_cast<unsigned int>(m_rotationAngle))
00093     {
00094     case 90:
00095     case 270:
00096         margin.Top = 110.0;
00097         margin.Bottom = 110.0;
00098         break;
00099     }
00100     m_imageMargin = margin;
00101     OnPropertyChanged("ImageMargin");
00102     OnPropertyChanged("RotationAngle");
00103 }
00104
00105 IPhoto^ RotateImageViewModel::Photo::get()
00106 {
00107     if (nullptr == m_photo && !m_getPhotoAsyncIsRunning)
00108     {
00109         m_getPhotoAsyncIsRunning = true;
00110         run_async_non_interactive([this]()
00111         {
00112             GetImagePhotoAsync().then([this] (task<IPhoto^> photoTask)
00113             {
00114                 assert(IsMainThread());
00115                 m_getPhotoAsyncIsRunning = false;
00116                 auto photo = photoTask.get();
00117                 if (photo != nullptr)
00118                 {
00119                     m_photo = photo;
00120                     OnPropertyChanged("Photo");
00121                 }
00122             }).then(ObserveException<void>(m_exceptionPolicy));
00123         });
00124     }
00125
00126     return m_photo;
00127 }
00128
00129 void RotateImageViewModel::Rotate90(Object^ parameter)
00130 {
00131     RotationAngle += 90;
00132     EndRotation();
00133 }
00134
00135 concurrency::task<RotateImageViewModel::ImageEncodingInformation> RotateImageViewModel::GetDecoderInfo(
00136     IRandomAccessStream^ source,
00137     concurrency::task_continuation_context backgroundContext)
00138 {
00139     assert(IsMainThread());
00140     auto  decoderInfo = std::make_shared<RotateImageViewModel::ImageEncodingInformation>();
00141     (*decoderInfo).usesExifOrientation = false;
00142
00143     return create_task(m_photo->OpenReadAsync()).then([](IRandomAccessStream^ stream)
00144     {
00145         assert(IsMainThread());
00146         return BitmapDecoder::CreateAsync(stream);
00147     }).then([decoderInfo](BitmapDecoder^ decoder)
00148     {
00149         assert(IsBackgroundThread());
00150         (*decoderInfo).decoder = decoder;
00151
00152         auto requestedProperty = ref new Vector<String^>();
00153         requestedProperty->Append(EXIFOrientationPropertyName);
00154         return (*decoderInfo).decoder->BitmapProperties->GetPropertiesAsync(requestedProperty);
00155     }, backgroundContext).then([decoderInfo](task<BitmapPropertySet^> propertiesTask)
00156     {
00157         assert(IsBackgroundThread());
00158         BitmapPropertySet^ properties;
00159
00160         try {
00161             properties = propertiesTask.get();
00162             if (properties->HasKey(EXIFOrientationPropertyName))
00163             {
00164                 (*decoderInfo).usesExifOrientation = true;
00165                 (*decoderInfo).exifOrientation = safe_cast<unsigned short>(properties->Lookup(EXIFOrientationPropertyName)->Value);
00166             }
00167         }
00168         catch(Exception^ ex)
00169         {
00170             // If the file format doesn't support properties, continue without using Exif orientation.
00171             switch (ex->HResult)
00172             {
00173             case WINCODEC_ERR_UNSUPPORTEDOPERATION:
00174             case WINCODEC_ERR_PROPERTYNOTSUPPORTED:
00175             case E_INVALIDARG:
00176                 (*decoderInfo).usesExifOrientation = false;
00177                 break;
00178
00179             default:
00180                 throw;
00181             }
00182         }
00183
00184         return (*decoderInfo);
00185     }, backgroundContext);
00186 }
00187
00188 unsigned int RotateImageViewModel::CheckRotationAngle(unsigned int angle)
00189 {
00190     return (angle > 360) ? angle - 360 : angle;
00191 }
00192
00193 concurrency::task<BitmapEncoder^> RotateImageViewModel::SetEncodingRotation(BitmapEncoder^ encoder, shared_ptr<ImageEncodingInformation> encodingInfo, float64 rotationAngle, concurrency::task_continuation_context backgroundContext)
00194 {
00195     // If the file format supports Exif orientation then update the orientation flag
00196     // to reflect any user-specified rotation. Otherwise, perform a hard rotate
00197     // using the BitmapTransform class.
00198     auto encodingTask = create_empty_task();
00199     if (encodingInfo->usesExifOrientation)
00200     {
00201         // Try encoding with Exif with updated values.
00202         auto currentExifOrientationDegrees = ExifExtensions::ConvertExifOrientationToDegreesRotation(ExifRotations(encodingInfo->exifOrientation));
00203         auto newRotationAngleToApply = CheckRotationAngle(safe_cast<unsigned int>(rotationAngle + currentExifOrientationDegrees));
00204         auto exifOrientationToApply = ExifExtensions::ConvertDegreesRotationToExifOrientation(newRotationAngleToApply);
00205         auto orientedTypedValue = ref new BitmapTypedValue(static_cast<unsigned short>(exifOrientationToApply), PropertyType::UInt16);
00206
00207         auto properties = ref new Map<String^, BitmapTypedValue^>();
00208         properties->Insert(EXIFOrientationPropertyName, orientedTypedValue);
00209
00210         encodingTask = encodingTask.then([encoder, properties]
00211         {
00212             assert(IsBackgroundThread());
00213             return encoder->BitmapProperties->SetPropertiesAsync(properties);
00214         }, backgroundContext).then([encoder, encodingInfo] (task<void> setPropertiesTask)
00215         {
00216             assert(IsBackgroundThread());
00217
00218             try
00219             {
00220                 setPropertiesTask.get();
00221             }
00222             catch(Exception^ ex)
00223             {
00224                 switch(ex->HResult)
00225                 {
00226                 case WINCODEC_ERR_UNSUPPORTEDOPERATION:
00227                 case WINCODEC_ERR_PROPERTYNOTSUPPORTED:
00228                 case E_INVALIDARG:
00229                     encodingInfo->usesExifOrientation = false;
00230                     break;
00231                 default:
00232                     throw;
00233                 }
00234             }
00235
00236         }, backgroundContext);
00237     }
00238
00239     return encodingTask.then([encoder, encodingInfo, rotationAngle]
00240     {
00241         assert(IsBackgroundThread());
00242         if (!encodingInfo->usesExifOrientation)
00243         {
00244             BitmapRotation rotation = static_cast<BitmapRotation>((int)floor(rotationAngle / 90));
00245             encoder->BitmapTransform->Rotation = rotation;
00246         }
00247         return encoder;
00248     });
00249 }
00250
00251 concurrency::task<IRandomAccessStream^> RotateImageViewModel::EncodeRotateImageToStream(
00252     ImageEncodingInformation encodingInformation,
00253     float64 rotationAngle,
00254     concurrency::task_continuation_context backgroundContext )
00255 {
00256     assert(IsMainThread());
00257     auto ras = ref new InMemoryRandomAccessStream();
00258     auto bitmapEncoder = make_shared<BitmapEncoder^>(nullptr);
00259     auto bitmapDecoderInfo = make_shared<ImageEncodingInformation>(encodingInformation);
00260
00261     return create_task(BitmapEncoder::CreateForTranscodingAsync(ras, (*bitmapDecoderInfo).decoder))
00262         .then([this, rotationAngle, backgroundContext, bitmapDecoderInfo](BitmapEncoder^ encoder)
00263     {
00264         assert(IsBackgroundThread());
00265         return SetEncodingRotation(encoder, bitmapDecoderInfo, rotationAngle, backgroundContext);
00266     }, backgroundContext).then([bitmapEncoder](BitmapEncoder^ encoder)
00267     {
00268         assert(IsBackgroundThread());
00269         // Force a new thumbnail to reflect any rotation operation
00270         encoder->IsThumbnailGenerated = true;
00271         (*bitmapEncoder) = encoder;
00272         return encoder->FlushAsync();
00273     }, backgroundContext).then([bitmapEncoder](task<void> encodeTask)
00274     {
00275         assert(IsBackgroundThread());
00276         try
00277         {
00278             encodeTask.get();
00279         }
00280         catch(Exception^ ex)
00281         {
00282             switch (ex->HResult)
00283             {
00284             case WINCODEC_ERR_UNSUPPORTEDOPERATION:
00285                 // If the encoder does not support writing a thumbnail, then
00286                 // disable thumbnail generation before trying again.
00287                 (*bitmapEncoder)->IsThumbnailGenerated = false;
00288                 break;
00289
00290             default:
00291                 throw ex;
00292             }
00293         }
00294         return ((*bitmapEncoder)->IsThumbnailGenerated == false) ? (*bitmapEncoder)->FlushAsync() : create_async([]{});
00295     }, backgroundContext).then([ras]
00296     {
00297         assert(IsMainThread());
00298         return safe_cast<IRandomAccessStream^>(ras);
00299     });
00300 }
00301
00302 concurrency::task<IRandomAccessStream^> RotateImageViewModel::RotateImageAsync(IRandomAccessStream^ source, float64 angle)
00303 {
00304     assert(IsMainThread());
00305     assert(angle < 360);
00306     while (angle < 0)
00307     {
00308         angle += 360;
00309     }
00310
00311     auto backgroundContext = task_continuation_context::use_arbitrary();
00312     return GetDecoderInfo(source, backgroundContext)
00313         .then([this, angle, backgroundContext](ImageEncodingInformation encodingInformation)
00314     {
00315         assert(IsMainThread());
00316         return EncodeRotateImageToStream(encodingInformation, angle, backgroundContext);
00317     });
00318 }
00319
00320 void RotateImageViewModel::ChangeInProgress(bool value)
00321 {
00322     m_inProgress = value;
00323     OnPropertyChanged("InProgress");
00324 }
00325
00326 void RotateImageViewModel::SaveImage(Object^ parameter)
00327 {
00328     if (m_isSaving) return;
00329
00330     m_isSaving = true;
00331     auto file = make_shared<StorageFile^>(nullptr);
00332     auto stream = make_shared<IRandomAccessStreamWithContentType^>(nullptr);
00333     auto rotatedStream = make_shared<IRandomAccessStream^>(nullptr);
00334
00335     GetStreamWithFailCheck().then([this, stream](IRandomAccessStreamWithContentType^ sourceStream)
00336     {
00337         assert(IsMainThread());
00338         *stream = sourceStream;
00339         ChangeInProgress(true);
00340     }).then([this, stream]
00341     {
00342         assert(IsMainThread());
00343         return RotateImageAsync((*stream), RotationAngle);
00344     }).then([this, rotatedStream](IRandomAccessStream^ pictureStream)
00345     {
00346         (*rotatedStream) = pictureStream;
00347         // Cancel the task if the user has switched to snapped view before the FileSavePicker has appeared.
00348         if (ApplicationView::Value == ApplicationViewState::Snapped)
00349         {
00350             cancel_current_task();
00351         }
00352         return ImageBase::GetFileNameFromFileSavePickerAsync(m_photo->FileType);
00353     }).then([this, file, rotatedStream](StorageFile^ f)
00354     {
00355         assert(IsMainThread());
00356         (*file) = f;
00357         return ImageBase::SaveImageAsync((*file), (*rotatedStream));
00358     }).then([this](task<void> priorTask)
00359     {
00360         assert(IsMainThread());
00361         m_isSaving = false;
00362         ChangeInProgress(false);
00363         try
00364         {
00365             priorTask.get();
00366         }
00367         catch(const concurrency::task_canceled&)
00368         {
00369         }
00370     }).then(ObserveException<void>(m_exceptionPolicy));
00371 }
00372
00373 void RotateImageViewModel::Unsnap(Object^ parameter)
00374 {
00375     if (ApplicationView::Value == ApplicationViewState::Snapped)
00376     {
00377         ApplicationView::TryUnsnap();
00378     }
00379 }
00380
00381 void RotateImageViewModel::CancelRotate(Object^ parameter)
00382 {
00383     ViewModelBase::GoBack();
00384 }
00385
00386 // See http://go.microsoft.com/fwlink/?LinkId=267280 for more info on Hilo's implementation of suspend/resume.
00387 void RotateImageViewModel::LoadState(IMap<String^, Object^>^ stateMap)
00388 {
00389     if (stateMap != nullptr)
00390     {
00391         if (stateMap->HasKey(RotationStateKey))
00392             m_rotationAngle = static_cast<float64>(stateMap->Lookup(RotationStateKey));
00393
00394         Thickness margin(0.0);
00395         if (stateMap->HasKey(MarginRightStateKey))
00396             margin.Left = static_cast<float64>(stateMap->Lookup(MarginRightStateKey));
00397
00398         if (stateMap->HasKey(MarginTopStateKey))
00399             margin.Top = static_cast<float64>(stateMap->Lookup(MarginTopStateKey));
00400
00401         if (stateMap->HasKey(MarginRightStateKey))
00402             margin.Right = static_cast<float64>(stateMap->Lookup(MarginRightStateKey));
00403
00404         if (stateMap->HasKey(MarginBottomStateKey))
00405             margin.Bottom = static_cast<float64>(stateMap->Lookup(MarginBottomStateKey));
00406
00407         m_imageMargin = margin;
00408     }
00409 }
00410
00411 void RotateImageViewModel::SaveState(IMap<String^, Object^>^ stateMap)
00412 {
00413     stateMap->Insert(RotationStateKey, m_rotationAngle);
00414     stateMap->Insert(MarginLeftStateKey, m_imageMargin.Left);
00415     stateMap->Insert(MarginTopStateKey, m_imageMargin.Top);
00416     stateMap->Insert(MarginRightStateKey, m_imageMargin.Right);
00417     stateMap->Insert(MarginBottomStateKey, m_imageMargin.Bottom);
00418 }
00419
00420 void RotateImageViewModel::OnNavigatedTo(NavigationEventArgs^ e)
00421 {
00422     String^ data = dynamic_cast<String^>(e->Parameter);
00423     ImageNavigationData navigationData(data);
00424
00425     Initialize(navigationData.GetFilePath());
00426 }
00427
00428
00429 void RotateImageViewModel::Initialize(String^ photoPath)
00430 {
00431     assert(IsMainThread());
00432     m_photo = nullptr;
00433     m_photoPath = photoPath;
00434
00435     GetImagePhotoAsync().then([this](IPhoto^ photo)
00436     {
00437         assert(IsMainThread());
00438         // Return to the hub page if the photo is no longer present
00439         if (photo == nullptr)
00440         {
00441             GoHome();
00442         }
00443     });
00444 }
00445
00446 concurrency::task<IPhoto^> RotateImageViewModel::GetImagePhotoAsync()
00447 {
00448     assert(IsMainThread());
00449     return m_repository->GetSinglePhotoAsync(m_photoPath);
00450 }
00451
00452 void RotateImageViewModel::EndRotation()
00453 {
00454     auto quarterTurns = (RotationAngle / 90);
00455     auto nearestQuarter = (int)floor(quarterTurns + 0.5) % 4;
00456     RotationAngle = (float64)nearestQuarter * 90;
00457 }
00458
00459
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DDSTextureLoader.cpp Source File

  • Direct3D-Direct2D interop

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

GeometryRealizationSample Member List

This is the complete list of members for GeometryRealizationSample, including all inherited members.
__pad0__ | GeometryRealizationSample |
CreateDeviceIndependentResources() override | GeometryRealizationSample | [virtual]
CreateDeviceResources() override | GeometryRealizationSample | [virtual]
CreateGeometries() | GeometryRealizationSample | [private]
DiscardGeometries() | GeometryRealizationSample | [private]
Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView) | GeometryRealizationSample | [virtual]
Load(_In_ Platform::String^entryPoint) | GeometryRealizationSample | [virtual]
m_antialiasMode | GeometryRealizationSample | [private]
m_blackBrush | GeometryRealizationSample | [private]
m_displayText | GeometryRealizationSample | [private]
m_drawStroke | GeometryRealizationSample | [private]
m_geometry | GeometryRealizationSample | [private]
m_gestureRecognizer | GeometryRealizationSample | [private]
m_numberOfSquares | GeometryRealizationSample | [private]
m_paused | GeometryRealizationSample | [private]
m_pausedTime | GeometryRealizationSample | [private]
m_realization | GeometryRealizationSample | [private]
m_sampleOverlay | GeometryRealizationSample | [private]
m_solidColorBrush | GeometryRealizationSample | [private]
m_textFormat | GeometryRealizationSample | [private]
m_timeDelta | GeometryRealizationSample | [private]
m_updateDisplayText | GeometryRealizationSample | [private]
m_updateRealization | GeometryRealizationSample | [private]
m_useRealizations | GeometryRealizationSample | [private]
m_windowClosed | GeometryRealizationSample | [private]
m_windowVisible | GeometryRealizationSample | [private]
OnActivated(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args) | GeometryRealizationSample | [private]
OnHolding(_In_ Windows::UI::Input::GestureRecognizer^recognizer, _In_ Windows::UI::Input::HoldingEventArgs^args) | GeometryRealizationSample | [private]
OnLogicalDpiChanged(_In_ Platform::Object^sender) | GeometryRealizationSample | [private]
OnPointerMoved(_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args) | GeometryRealizationSample | [private]
OnPointerPressed(_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args) | GeometryRealizationSample | [private]
OnPointerReleased(_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Core::PointerEventArgs^args) | GeometryRealizationSample | [private]
OnResuming(_In_ Platform::Object^sender, _In_ Platform::Object^args) | GeometryRealizationSample | [private]
OnSuspending(_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args) | GeometryRealizationSample | [private]
OnVisibilityChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::VisibilityChangedEventArgs^args) | GeometryRealizationSample | [private]
OnWindowClosed(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::CoreWindowEventArgs^args) | GeometryRealizationSample | [private]
OnWindowSizeChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args) | GeometryRealizationSample | [private]
Render() override | GeometryRealizationSample | [virtual]
RenderMainContent(float time) | GeometryRealizationSample | [private]
Run() | GeometryRealizationSample | [virtual]
SetWindow(_In_ Windows::UI::Core::CoreWindow^window) | GeometryRealizationSample | [virtual]
ShowMenu(Windows::Foundation::Point position) | GeometryRealizationSample | [private]
Uninitialize() | GeometryRealizationSample | [virtual]
UpdateDisplayText() | GeometryRealizationSample | [private]
UpdateForWindowSizeChange() override | GeometryRealizationSample | [virtual]
UpdateGeometryRendering(Windows::UI::Popups::IUICommand^command) | GeometryRealizationSample | [private]
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/common/LayoutAwarePage.cpp Source File

  • Input Device capabilities
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:31 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/DirectXBase.h Source File

  • Direct3D HLSL fractal generator

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/common/suspensionmanager.h Source File

  • CryptoWinRT
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/pch.h Source File

  • Direct2D 3D transform effect

pch.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <math.h>
00017 #include <DirectXMath.h>
00018 #include <agile.h>
00019
00020 #include "PersistentState.h"
00021
00022 #include "D2D3DTransformsRenderer.h"
00023 #include "DirectXSample.h"
00024 #include "windows.ui.xaml.media.dxinterop.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

StereoParameters Member List

This is the complete list of members for StereoParameters, including all inherited members.
interocularDistance | StereoParameters
viewerDistance | StereoParameters
viewportHeight | StereoParameters
viewportWidth | StereoParameters
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/common/suspensionmanager.h Source File

  • SimpleOrientationSensor
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::WASAPIAudio::sealed Member List

This is the complete list of members for SDKSample::WASAPIAudio::sealed, including all inherited members.
__pad0__ | SDKSample::WASAPIAudio::sealed |
btnFilePicker_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
btnPause_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
btnPlay_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
btnPlayPause_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
btnStartCapture_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
btnStop_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
btnStopCapture_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
DeviceStateChangedEvent() | SDKSample::WASAPIAudio::sealed | [inline]
Enumerate_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
EnumerateAudioDevicesAsync() | SDKSample::WASAPIAudio::sealed | [private]
GetState() | SDKSample::WASAPIAudio::sealed | [inline]
hr | SDKSample::WASAPIAudio::sealed |
InitializeCapture(Object^sender, Object^e) | SDKSample::WASAPIAudio::sealed | [private]
InitializeDevice() | SDKSample::WASAPIAudio::sealed | [private]
m_ContentStream | SDKSample::WASAPIAudio::sealed | [private]
m_ContentType | SDKSample::WASAPIAudio::sealed | [private]
m_CoreDispatcher | SDKSample::WASAPIAudio::sealed | [private]
m_DevicesList | SDKSample::WASAPIAudio::sealed | [private]
m_DeviceState | SDKSample::WASAPIAudio::sealed | [private]
m_deviceStateChangeToken | SDKSample::WASAPIAudio::sealed | [private]
m_DiscontinuityCount | SDKSample::WASAPIAudio::sealed | [private]
m_hr | SDKSample::WASAPIAudio::sealed |
m_hr(hr) | SDKSample::WASAPIAudio::sealed | [inline]
m_IsMFLoaded | SDKSample::WASAPIAudio::sealed | [private]
m_MediaControlPauseToken | SDKSample::WASAPIAudio::sealed | [private]
m_MediaControlPlayPauseToken | SDKSample::WASAPIAudio::sealed | [private]
m_MediaControlPlayToken | SDKSample::WASAPIAudio::sealed | [private]
m_MediaControlStopToken | SDKSample::WASAPIAudio::sealed | [private]
m_Oscilliscope | SDKSample::WASAPIAudio::sealed | [private]
m_plotDataReadyToken | SDKSample::WASAPIAudio::sealed | [private]
m_PointArray | SDKSample::WASAPIAudio::sealed | [private]
m_Size | SDKSample::WASAPIAudio::sealed | [private]
m_Size(size) | SDKSample::WASAPIAudio::sealed | [inline]
m_spCapture | SDKSample::WASAPIAudio::sealed | [private]
m_spRenderer | SDKSample::WASAPIAudio::sealed | [private]
m_StateChangedEvent | SDKSample::WASAPIAudio::sealed | [private]
OnDeviceStateChange(Object^sender, DeviceStateChangedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
OnDeviceStateChange(Object^sender, DeviceStateChangedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::WASAPIAudio::sealed | [protected, virtual]
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::WASAPIAudio::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::WASAPIAudio::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::WASAPIAudio::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::WASAPIAudio::sealed | [protected, virtual]
OnPickFileAsync() | SDKSample::WASAPIAudio::sealed | [private]
OnPlotDataReady(Object^sender, PlotDataReadyEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
OnSetVolume(UINT32 volume) | SDKSample::WASAPIAudio::sealed | [private]
PauseDevice(Object^sender, Object^e) | SDKSample::WASAPIAudio::sealed | [private]
PlayPauseToggle(Object^sender, Object^e) | SDKSample::WASAPIAudio::sealed | [private]
PlotDataReadyEvent() | SDKSample::WASAPIAudio::sealed | [inline]
points | SDKSample::WASAPIAudio::sealed |
points | SDKSample::WASAPIAudio::sealed |
radioFile_Checked(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
radioTone_Checked(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
rootPage | SDKSample::WASAPIAudio::sealed | [private]
Scenario1() | SDKSample::WASAPIAudio::sealed |
Scenario2() | SDKSample::WASAPIAudio::sealed |
Scenario3() | SDKSample::WASAPIAudio::sealed |
ShowStatusMessage(Platform::String^str, NotifyType messageType) | SDKSample::WASAPIAudio::sealed | [private]
ShowStatusMessage(Platform::String^str, NotifyType messageType) | SDKSample::WASAPIAudio::sealed | [private]
ShowStatusMessage(Platform::String^str, NotifyType messageType) | SDKSample::WASAPIAudio::sealed | [private]
size | SDKSample::WASAPIAudio::sealed |
sliderFrequency_ValueChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
sliderVolume_ValueChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | SDKSample::WASAPIAudio::sealed | [private]
StartDevice(Object^sender, Object^e) | SDKSample::WASAPIAudio::sealed | [private]
StateChangedEvent | SDKSample::WASAPIAudio::sealed | [static]
StopCapture(Object^sender, Object^e) | SDKSample::WASAPIAudio::sealed | [private]
StopDevice(Object^sender, Object^e) | SDKSample::WASAPIAudio::sealed | [private]
UpdateContentProps(Platform::String^str) | SDKSample::WASAPIAudio::sealed | [private]
UpdateContentUI(Platform::Boolean disableAll) | SDKSample::WASAPIAudio::sealed | [private]
UpdateMediaControlUI(DeviceState deviceState) | SDKSample::WASAPIAudio::sealed | [private]
UpdateMediaControlUI(DeviceState deviceState) | SDKSample::WASAPIAudio::sealed | [private]
~Scenario2() | SDKSample::WASAPIAudio::sealed | [private]
~Scenario3() | SDKSample::WASAPIAudio::sealed | [private]
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/pch.h Source File

  • Background Transfer

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson2.Triangles/Main.cpp Source File

  • Direct3D tutorial
  • Lesson2.Triangles

Main.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXSample.h"
00010 #include "BasicMath.h"
00011 #include "BasicReaderWriter.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::Core;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel::Core;
00017 using namespace Windows::ApplicationModel::Activation;
00018
00019 // This class defines the application as a whole.
00020 ref class Direct3DTutorialFrameworkView : public IFrameworkView
00021 {
00022 private:
00023     Platform::Agile<CoreWindow> m_window;
00024     ComPtr<IDXGISwapChain1> m_swapChain;
00025     ComPtr<ID3D11Device1> m_d3dDevice;
00026     ComPtr<ID3D11DeviceContext1> m_d3dDeviceContext;
00027     ComPtr<ID3D11RenderTargetView> m_renderTargetView;
00028
00029 public:
00030     // This method is called on application launch.
00031     virtual void Initialize(
00032         _In_ CoreApplicationView^ applicationView
00033         )
00034     {
00035         applicationView->Activated +=
00036             ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &Direct3DTutorialFrameworkView::OnActivated);
00037     }
00038
00039     // This method is called after Initialize.
00040     virtual void SetWindow(
00041         _In_ CoreWindow^ window
00042         )
00043     {
00044         m_window = window;
00045
00046         // Specify the cursor type as the standard arrow cursor.
00047         m_window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00048
00049         // Allow the application to respond when the window size changes.
00050         m_window->SizeChanged +=
00051             ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(
00052                 this,
00053                 &Direct3DTutorialFrameworkView::OnWindowSizeChanged
00054                 );
00055     }
00056
00057     void OnActivated(
00058         _In_ CoreApplicationView^ applicationView,
00059         _In_ IActivatedEventArgs^ args
00060         )
00061     {
00062         // Activate the application window, making it visible and enabling it to receive events.
00063         CoreWindow::GetForCurrentThread()->Activate();
00064     }
00065
00066     virtual void Load(_In_ Platform::String^ entryPoint)
00067     {
00068     }
00069
00070     // This method is called after Load.
00071     virtual void Run()
00072     {
00073         // First, create the Direct3D device.
00074
00075         // This flag is required in order to enable compatibility with Direct2D.
00076         UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00077
00078 #if defined(_DEBUG)
00079         // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00080         creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00081 #endif
00082
00083         // This array defines the ordering of feature levels that D3D should attempt to create.
00084         D3D_FEATURE_LEVEL featureLevels[] =
00085         {
00086             D3D_FEATURE_LEVEL_11_1,
00087             D3D_FEATURE_LEVEL_11_0,
00088             D3D_FEATURE_LEVEL_10_1,
00089             D3D_FEATURE_LEVEL_10_0,
00090             D3D_FEATURE_LEVEL_9_3,
00091             D3D_FEATURE_LEVEL_9_1
00092         };
00093
00094         ComPtr<ID3D11Device> d3dDevice;
00095         ComPtr<ID3D11DeviceContext> d3dDeviceContext;
00096         DX::ThrowIfFailed(
00097             D3D11CreateDevice(
00098                 nullptr,                    // specify nullptr to use the default adapter
00099                 D3D_DRIVER_TYPE_HARDWARE,
00100                 nullptr,                    // leave as nullptr if hardware is used
00101                 creationFlags,              // optionally set debug and Direct2D compatibility flags
00102                 featureLevels,
00103                 ARRAYSIZE(featureLevels),
00104                 D3D11_SDK_VERSION,          // always set this to D3D11_SDK_VERSION
00105                 &d3dDevice,
00106                 nullptr,
00107                 &d3dDeviceContext
00108                 )
00109             );
00110
00111         // Retrieve the Direct3D 11.1 interfaces.
00112         DX::ThrowIfFailed(
00113             d3dDevice.As(&m_d3dDevice)
00114             );
00115
00116         DX::ThrowIfFailed(
00117             d3dDeviceContext.As(&m_d3dDeviceContext)
00118             );
00119
00120
00121         // After the D3D device is created, create additional application resources.
00122         CreateWindowSizeDependentResources();
00123
00124         // Create a Basic Reader-Writer class to load data from disk.  This class is examined
00125         // in the Resource Loading sample.
00126         BasicReaderWriter^ reader = ref new BasicReaderWriter();
00127
00128         // Load the raw vertex shader bytecode from disk and create a vertex shader with it.
00129         auto vertexShaderBytecode = reader->ReadData("SimpleVertexShader.cso");
00130         ComPtr<ID3D11VertexShader> vertexShader;
00131         DX::ThrowIfFailed(
00132             m_d3dDevice->CreateVertexShader(
00133                 vertexShaderBytecode->Data,
00134                 vertexShaderBytecode->Length,
00135                 nullptr,
00136                 &vertexShader
00137                 )
00138             );
00139
00140         // Create an input layout that matches the layout defined in the vertex shader code.
00141         // For this lesson, this is simply a float2 vector defining the vertex position.
00142         const D3D11_INPUT_ELEMENT_DESC basicVertexLayoutDesc[] =
00143         {
00144             { "POSITION", 0, DXGI_FORMAT_R32G32_FLOAT, 0, 0, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00145         };
00146
00147         ComPtr<ID3D11InputLayout> inputLayout;
00148         DX::ThrowIfFailed(
00149             m_d3dDevice->CreateInputLayout(
00150                 basicVertexLayoutDesc,
00151                 ARRAYSIZE(basicVertexLayoutDesc),
00152                 vertexShaderBytecode->Data,
00153                 vertexShaderBytecode->Length,
00154                 &inputLayout
00155                 )
00156             );
00157
00158         // Load the raw pixel shader bytecode from disk and create a pixel shader with it.
00159         auto pixelShaderBytecode = reader->ReadData("SimplePixelShader.cso");
00160         ComPtr<ID3D11PixelShader> pixelShader;
00161         DX::ThrowIfFailed(
00162             m_d3dDevice->CreatePixelShader(
00163                 pixelShaderBytecode->Data,
00164                 pixelShaderBytecode->Length,
00165                 nullptr,
00166                 &pixelShader
00167                 )
00168             );
00169
00170         // Create vertex and index buffers that define a simple triangle.
00171
00172         float2 triangleVertices[] =
00173         {
00174             float2(-0.5f, -0.5f),
00175             float2( 0.0f,  0.5f),
00176             float2( 0.5f, -0.5f),
00177         };
00178
00179         unsigned short triangleIndices[] =
00180         {
00181             0, 1, 2,
00182         };
00183
00184         D3D11_BUFFER_DESC vertexBufferDesc = {0};
00185         vertexBufferDesc.ByteWidth = sizeof(float2) * ARRAYSIZE(triangleVertices);
00186         vertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00187         vertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00188         vertexBufferDesc.CPUAccessFlags = 0;
00189         vertexBufferDesc.MiscFlags = 0;
00190         vertexBufferDesc.StructureByteStride = 0;
00191
00192         D3D11_SUBRESOURCE_DATA vertexBufferData;
00193         vertexBufferData.pSysMem = triangleVertices;
00194         vertexBufferData.SysMemPitch = 0;
00195         vertexBufferData.SysMemSlicePitch = 0;
00196
00197         ComPtr<ID3D11Buffer> vertexBuffer;
00198         DX::ThrowIfFailed(
00199             m_d3dDevice->CreateBuffer(
00200                 &vertexBufferDesc,
00201                 &vertexBufferData,
00202                 &vertexBuffer
00203                 )
00204             );
00205
00206         D3D11_BUFFER_DESC indexBufferDesc;
00207         indexBufferDesc.ByteWidth = sizeof(unsigned short) * ARRAYSIZE(triangleIndices);
00208         indexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00209         indexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00210         indexBufferDesc.CPUAccessFlags = 0;
00211         indexBufferDesc.MiscFlags = 0;
00212         indexBufferDesc.StructureByteStride = 0;
00213
00214         D3D11_SUBRESOURCE_DATA indexBufferData;
00215         indexBufferData.pSysMem = triangleIndices;
00216         indexBufferData.SysMemPitch = 0;
00217         indexBufferData.SysMemSlicePitch = 0;
00218
00219         ComPtr<ID3D11Buffer> indexBuffer;
00220         DX::ThrowIfFailed(
00221             m_d3dDevice->CreateBuffer(
00222                 &indexBufferDesc,
00223                 &indexBufferData,
00224                 &indexBuffer
00225                 )
00226             );
00227
00228
00229         // Enter the render loop. Note that Windows Store apps should never exit.
00230         while (true)
00231         {
00232             // Process events incoming to the window.
00233             m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00234
00235             // Specify the render target we created as the output target.
00236             m_d3dDeviceContext->OMSetRenderTargets(
00237                 1,
00238                 m_renderTargetView.GetAddressOf(),
00239                 nullptr // use no depth stencil
00240                 );
00241
00242             // Clear the render target to a solid color.
00243             const float clearColor[4] = { 0.071f, 0.04f, 0.561f, 1.0f };
00244             m_d3dDeviceContext->ClearRenderTargetView(
00245                 m_renderTargetView.Get(),
00246                 clearColor
00247                 );
00248
00249             m_d3dDeviceContext->IASetInputLayout(inputLayout.Get());
00250
00251             // Set the vertex and index buffers, and specify the way they define geometry.
00252             UINT stride = sizeof(float2);
00253             UINT offset = 0;
00254             m_d3dDeviceContext->IASetVertexBuffers(
00255                 0,
00256                 1,
00257                 vertexBuffer.GetAddressOf(),
00258                 &stride,
00259                 &offset
00260                 );
00261
00262             m_d3dDeviceContext->IASetIndexBuffer(
00263                 indexBuffer.Get(),
00264                 DXGI_FORMAT_R16_UINT,
00265                 0
00266                 );
00267
00268             m_d3dDeviceContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00269
00270             // Set the vertex and pixel shader stage state.
00271             m_d3dDeviceContext->VSSetShader(
00272                 vertexShader.Get(),
00273                 nullptr,
00274                 0
00275                 );
00276
00277             m_d3dDeviceContext->PSSetShader(
00278                 pixelShader.Get(),
00279                 nullptr,
00280                 0
00281                 );
00282
00283             // Draw the cube.
00284             m_d3dDeviceContext->DrawIndexed(
00285                 ARRAYSIZE(triangleIndices),
00286                 0,
00287                 0
00288                 );
00289
00290             // Present the rendered image to the window.  Because the maximum frame latency is set to 1,
00291             // the render loop will generally be throttled to the screen refresh rate, typically around
00292             // 60Hz, by sleeping the application on Present until the screen is refreshed.
00293             DX::ThrowIfFailed(
00294                 m_swapChain->Present(1, 0)
00295                 );
00296         }
00297     }
00298
00299     // This method is called before the application exits.
00300     virtual void Uninitialize()
00301     {
00302     }
00303
00304 private:
00305
00306     // This method is called whenever the application window size changes.
00307     void OnWindowSizeChanged(
00308         _In_ CoreWindow^ sender,
00309         _In_ WindowSizeChangedEventArgs^ args
00310         )
00311     {
00312         m_renderTargetView = nullptr;
00313         CreateWindowSizeDependentResources();
00314     }
00315
00316     // This method creates all application resources that depend on
00317     // the application window size.  It is called at app initialization,
00318     // and whenever the application window size changes.
00319     void CreateWindowSizeDependentResources()
00320     {
00321         if (m_swapChain != nullptr)
00322         {
00323             // If the swap chain already exists, resize it.
00324             DX::ThrowIfFailed(
00325                 m_swapChain->ResizeBuffers(
00326                     2,
00327                     0,
00328                     0,
00329                     DXGI_FORMAT_B8G8R8A8_UNORM,
00330                     0
00331                     )
00332                 );
00333         }
00334         else
00335         {
00336             // If the swap chain does not exist, create it.
00337             DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00338
00339             swapChainDesc.Stereo = false;
00340             swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00341             swapChainDesc.Scaling = DXGI_SCALING_NONE;
00342             swapChainDesc.Flags = 0;
00343
00344             // Use automatic sizing.
00345             swapChainDesc.Width = 0;
00346             swapChainDesc.Height = 0;
00347
00348             // This is the most common swap chain format.
00349             swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00350
00351             // Don't use multi-sampling.
00352             swapChainDesc.SampleDesc.Count = 1;
00353             swapChainDesc.SampleDesc.Quality = 0;
00354
00355             // Use two buffers to enable flip effect.
00356             swapChainDesc.BufferCount = 2;
00357
00358             // We recommend using this swap effect for all applications.
00359             swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL;
00360
00361
00362             // Once the swap chain description is configured, it must be
00363             // created on the same adapter as the existing D3D Device.
00364
00365             // First, retrieve the underlying DXGI Device from the D3D Device.
00366             ComPtr<IDXGIDevice2> dxgiDevice;
00367             DX::ThrowIfFailed(
00368                 m_d3dDevice.As(&dxgiDevice)
00369                 );
00370
00371             // Ensure that DXGI does not queue more than one frame at a time. This both reduces
00372             // latency and ensures that the application will only render after each VSync, minimizing
00373             // power consumption.
00374             DX::ThrowIfFailed(
00375                 dxgiDevice->SetMaximumFrameLatency(1)
00376                 );
00377
00378             // Next, get the parent factory from the DXGI Device.
00379             ComPtr<IDXGIAdapter> dxgiAdapter;
00380             DX::ThrowIfFailed(
00381                 dxgiDevice->GetAdapter(&dxgiAdapter)
00382                 );
00383
00384             ComPtr<IDXGIFactory2> dxgiFactory;
00385             DX::ThrowIfFailed(
00386                 dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00387                 );
00388
00389             // Finally, create the swap chain.
00390             CoreWindow^ window = m_window.Get();
00391             DX::ThrowIfFailed(
00392                 dxgiFactory->CreateSwapChainForCoreWindow(
00393                     m_d3dDevice.Get(),
00394                     reinterpret_cast<IUnknown*>(window),
00395                     &swapChainDesc,
00396                     nullptr, // allow on all displays
00397                     &m_swapChain
00398                     )
00399                 );
00400         }
00401
00402         // Once the swap chain is created, create a render target view.  This will
00403         // allow Direct3D to render graphics to the window.
00404
00405         ComPtr<ID3D11Texture2D> backBuffer;
00406         DX::ThrowIfFailed(
00407             m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00408             );
00409
00410         DX::ThrowIfFailed(
00411             m_d3dDevice->CreateRenderTargetView(
00412                 backBuffer.Get(),
00413                 nullptr,
00414                 &m_renderTargetView
00415                 )
00416             );
00417
00418
00419         // After the render target view is created, specify that the viewport,
00420         // which describes what portion of the window to draw to, should cover
00421         // the entire window.
00422
00423         D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00424         backBuffer->GetDesc(&backBufferDesc);
00425
00426         D3D11_VIEWPORT viewport;
00427         viewport.TopLeftX = 0.0f;
00428         viewport.TopLeftY = 0.0f;
00429         viewport.Width = static_cast<float>(backBufferDesc.Width);
00430         viewport.Height = static_cast<float>(backBufferDesc.Height);
00431         viewport.MinDepth = D3D11_MIN_DEPTH;
00432         viewport.MaxDepth = D3D11_MAX_DEPTH;
00433
00434         m_d3dDeviceContext->RSSetViewports(1, &viewport);
00435     }
00436 };
00437
00438 // This class defines how to create the custom View Provider defined above.
00439 ref class Direct3DTutorialFrameworkViewSource : IFrameworkViewSource
00440 {
00441 public:
00442     virtual IFrameworkView^ CreateView()
00443     {
00444         return ref new Direct3DTutorialFrameworkView();
00445     }
00446 };
00447
00448 [Platform::MTAThread]
00449 int main(Platform::Array<Platform::String^>^)
00450 {
00451     auto frameworkViewSource = ref new Direct3DTutorialFrameworkViewSource();
00452     Windows::ApplicationModel::Core::CoreApplication::Run(frameworkViewSource);
00453     return 0;
00454 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ContactPicker::App Member List

This is the complete list of members for ContactPicker::App, including all inherited members.
__pad0__ | ContactPicker::App |
OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override | ContactPicker::App | [protected, virtual]
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | ContactPicker::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | ContactPicker::App | [virtual]
rootFrame | ContactPicker::App | [private]
SetupWindowing(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) | ContactPicker::App | [private]
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/App.xaml.cpp Source File

  • XAML vector-based drawing

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/Scenario3.xaml.h Source File

  • XAML ListView and GridView essentials

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "SampleDataSource.h"
00022
00023 namespace SDKSample
00024 {
00025   namespace ListViewSimple
00026   {
00027     /// <summary>
00028     /// An empty page that can be used on its own or navigated to within a Frame.
00029     /// </summary>
00030     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00031     public ref class Scenario3 sealed
00032     {
00033     public:
00034       Scenario3();
00035
00036     protected:
00037       virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038     private:
00039       MainPage^ rootPage;
00040       ListViewSampleDataSource::StoreData^ storeData;
00041
00042       void Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043     };
00044   }
00045 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/FontLoader.cpp Source File

  • Direct2D magazine app

FontLoader.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Microsoft::WRL;
00011 using namespace concurrency;
00012 using namespace Windows::Foundation::Collections;
00013 using namespace Windows::Storage;
00014 using namespace Windows::Storage::Search;
00015 using namespace Windows::Storage::Streams;
00016 using namespace Windows::Storage::FileProperties;
00017
00018 FontLoader::FontLoader(
00019     _In_ StorageFolder^ location,
00020     _In_ IDWriteFactory* dwriteFactory
00021     ) :
00022     m_refCount(),
00023     m_location(location),
00024     m_fontFileCount(),
00025     m_fontFileStreams(),
00026     m_fontFileStreamIndex(),
00027     m_currentFontFile(),
00028     m_dwriteFactory(dwriteFactory)
00029 {
00030 }
00031
00032 task<void> FontLoader::LoadAsync()
00033 {
00034     // Locate the "fonts" sub-folder within the document folder
00035     return task<StorageFolder^>(m_location->GetFolderAsync("fonts")).then([=](StorageFolder^ folder)
00036     {
00037         // Enumerate a list of .TTF files in the storage location
00038         auto filters = ref new Platform::Collections::Vector<Platform::String^>();
00039         filters->Append(".ttf");
00040
00041         auto queryOptions = ref new QueryOptions(CommonFileQuery::DefaultQuery, filters);
00042         auto queryResult = folder->CreateFileQueryWithOptions(queryOptions);
00043
00044         return queryResult->GetFilesAsync();
00045
00046     }).then([=](IVectorView<StorageFile^>^ files)
00047     {
00048         m_fontFileCount = files->Size;
00049
00050         std::vector<task<IBuffer^>> tasks;
00051
00052         for (uint32 i = 0; i < m_fontFileCount; ++i)
00053         {
00054             auto file = dynamic_cast<StorageFile^>(files->GetAt(i));
00055
00056             tasks.push_back(task<IBuffer^>(FileIO::ReadBufferAsync(file)));
00057         }
00058
00059         return when_all(tasks.begin(), tasks.end());
00060
00061     }).then([=](std::vector<IBuffer^> buffers)
00062     {
00063         for each (IBuffer^ buffer in buffers)
00064         {
00065             auto fileData = ref new Platform::Array<byte>(buffer->Length);
00066             DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00067
00068             ComPtr<FontFileStream> fontFileStream(new FontFileStream(fileData));
00069             m_fontFileStreams.push_back(fontFileStream);
00070         }
00071     });
00072 }
00073
00074 HRESULT STDMETHODCALLTYPE FontLoader::QueryInterface(
00075     REFIID uuid,
00076     _Outptr_ void** object
00077     )
00078 {
00079     if (    uuid == IID_IUnknown
00080         ||  uuid == __uuidof(IDWriteFontCollectionLoader)
00081         ||  uuid == __uuidof(IDWriteFontFileEnumerator)
00082         ||  uuid == __uuidof(IDWriteFontFileLoader)
00083         )
00084     {
00085         *object = this;
00086         AddRef();
00087         return S_OK;
00088     }
00089     else
00090     {
00091         *object = nullptr;
00092         return E_NOINTERFACE;
00093     }
00094 }
00095
00096 ULONG STDMETHODCALLTYPE FontLoader::AddRef()
00097 {
00098     return static_cast<ULONG>(InterlockedIncrement(&m_refCount));
00099 }
00100
00101 ULONG STDMETHODCALLTYPE FontLoader::Release()
00102 {
00103     ULONG newCount = static_cast<ULONG>(InterlockedDecrement(&m_refCount));
00104
00105     if (newCount == 0)
00106         delete this;
00107
00108     return newCount;
00109 }
00110
00111 //  Called by DirectWrite to create an enumerator for the fonts in the font collection.
00112 //  The font collection key being passed in is the same key the application passes to
00113 //  DirectWrite when calling CreateCustomFontCollection API.
00114 //
00115 HRESULT STDMETHODCALLTYPE FontLoader::CreateEnumeratorFromKey(
00116     _In_ IDWriteFactory* factory,
00117     _In_reads_bytes_(fontCollectionKeySize) void const* fontCollectionKey,
00118     uint32 fontCollectionKeySize,
00119     _Outptr_ IDWriteFontFileEnumerator** fontFileEnumerator
00120     )
00121 {
00122     *fontFileEnumerator = ComPtr<IDWriteFontFileEnumerator>(this).Detach();
00123     return S_OK;
00124 }
00125
00126 HRESULT STDMETHODCALLTYPE FontLoader::MoveNext(OUT BOOL* hasCurrentFile)
00127 {
00128     *hasCurrentFile = FALSE;
00129
00130     if (m_fontFileStreamIndex < m_fontFileCount)
00131     {
00132         DX::ThrowIfFailed(
00133             m_dwriteFactory->CreateCustomFontFileReference(
00134                 &m_fontFileStreamIndex,
00135                 sizeof(size_t),
00136                 this,
00137                 &m_currentFontFile
00138                 )
00139             );
00140
00141         *hasCurrentFile = TRUE;
00142         ++m_fontFileStreamIndex;
00143     }
00144
00145     return S_OK;
00146 }
00147
00148 HRESULT STDMETHODCALLTYPE FontLoader::GetCurrentFontFile(OUT IDWriteFontFile** currentFontFile)
00149 {
00150     *currentFontFile = ComPtr<IDWriteFontFile>(m_currentFontFile.Get()).Detach();
00151     return S_OK;
00152 }
00153
00154 //  Called by DirectWrite to create a font file stream. The font file reference
00155 //  key being passed in is the same key the application passes to DirectWrite
00156 //  when calling CreateCustomFontFileReference.
00157 //
00158 HRESULT STDMETHODCALLTYPE FontLoader::CreateStreamFromKey(
00159     _In_reads_bytes_(fontFileReferenceKeySize) void const* fontFileReferenceKey,
00160     uint32 fontFileReferenceKeySize,
00161     _Outptr_ IDWriteFontFileStream** fontFileStream
00162     )
00163 {
00164     if (fontFileReferenceKeySize != sizeof(size_t))
00165     {
00166         return E_INVALIDARG;
00167     }
00168
00169     size_t fontFileStreamIndex = *(static_cast<size_t const*>(fontFileReferenceKey));
00170
00171     *fontFileStream = ComPtr<IDWriteFontFileStream>(m_fontFileStreams.at(fontFileStreamIndex).Get()).Detach();
00172
00173     return S_OK;
00174 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/IResizable.h Source File

  • Hilo C++
  • Hilo

IResizable.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     public interface class IResizable
00012     {
00013         property int ColumnSpan
00014         {
00015             int get();
00016             void set(int value);
00017         }
00018
00019         property int RowSpan
00020         {
00021             int get();
00022             void set(int value);
00023         }
00024     };
00025 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Level2.h Source File

  • XAML DirectX 3D shooting game

Level2.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Level2:
00011 // This class defines the second level of the game.  It derives from the
00012 // first level.  In this level the targets must be hit in numeric order.
00013
00014 #include "Level1.h"
00015
00016 ref class Level2: public Level1
00017 {
00018 internal:
00019     Level2();
00020     virtual void Initialize(std::vector<GameObject^> objects) override;
00021
00022     virtual bool Update(
00023         float time,
00024         float elapsedTime,
00025         float timeRemaining,
00026         std::vector<GameObject^> objects
00027         ) override;
00028
00029     virtual void SaveState(PersistentState^ state) override;
00030     virtual void LoadState(PersistentState^ state) override;
00031
00032 private:
00033     int m_nextId;
00034 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/MainPage.xaml.cpp Source File

  • File picker

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/MainPage.xaml.cpp Source File

  • Reading and writing data

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/MainPage.xaml.h Source File

  • User domain name

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/Constants.cpp Source File

  • Contact Picker app

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "MainPagePicker.xaml.h"
00014 #include "Constants.h"
00015
00016 using namespace ContactPicker;
00017 using namespace Windows::ApplicationModel::Activation;
00018 using namespace Windows::ApplicationModel::Contacts::Provider;
00019 using namespace Windows::UI::ViewManagement;
00020 using namespace Windows::UI::Xaml;
00021
00022 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00023 {
00024     { "Pick a single contact", "ContactPicker.ScenarioSingle" },
00025     { "Pick multiple contacts", "ContactPicker.ScenarioMultiple" },
00026 };
00027
00028 bool MainPage::EnsureUnsnapped()
00029 {
00030     // The ContactPicker APIs will not work if the application is in the snapped state. If
00031     // wants to show the ContactPicker while snapped, it must attempt to unsnap first.
00032     bool unsnapped = ((ApplicationView::Value != ApplicationViewState::Snapped) || ApplicationView::TryUnsnap());
00033     if (!unsnapped)
00034     {
00035         NotifyUser("Cannot unsnap the sample application", NotifyType::StatusMessage);
00036     }
00037
00038     return unsnapped;
00039 }
00040
00041 Platform::Array<Scenario>^ MainPagePicker::scenariosInner = ref new Platform::Array<Scenario>
00042 {
00043     { "Selection contact(s)", "ContactPicker.ContactPickerPage" }
00044 };
00045
00046 void MainPagePicker::Activate(ContactPickerActivatedEventArgs^ args)
00047 {
00048     // cache ContactPickerUI
00049     contactPickerUI = args->ContactPickerUI;
00050     Window::Current->Content = this;
00051     this->OnNavigatedTo(nullptr);
00052     Window::Current->Activate();
00053 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicLoader.h Source File

  • DirectX 3D shooting game

BasicLoader.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicReaderWriter.h"
00011
00012 // A simple loader class that provides support for loading shaders, textures,
00013 // and meshes from files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicLoader
00015 {
00016 internal:
00017     BasicLoader(
00018         _In_ ID3D11Device* d3dDevice,
00019         _In_opt_ IWICImagingFactory2* wicFactory = nullptr
00020         );
00021
00022     void LoadTexture(
00023         _In_ Platform::String^ filename,
00024         _Out_opt_ ID3D11Texture2D** texture,
00025         _Out_opt_ ID3D11ShaderResourceView** textureView
00026         );
00027
00028     concurrency::task<void> LoadTextureAsync(
00029         _In_ Platform::String^ filename,
00030         _Out_opt_ ID3D11Texture2D** texture,
00031         _Out_opt_ ID3D11ShaderResourceView** textureView
00032         );
00033
00034     void LoadShader(
00035         _In_ Platform::String^ filename,
00036         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00037         _In_ uint32 layoutDescNumElements,
00038         _Out_ ID3D11VertexShader** shader,
00039         _Out_opt_ ID3D11InputLayout** layout
00040         );
00041
00042     concurrency::task<void> LoadShaderAsync(
00043         _In_ Platform::String^ filename,
00044         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00045         _In_ uint32 layoutDescNumElements,
00046         _Out_ ID3D11VertexShader** shader,
00047         _Out_opt_ ID3D11InputLayout** layout
00048         );
00049
00050     void LoadShader(
00051         _In_ Platform::String^ filename,
00052         _Out_ ID3D11PixelShader** shader
00053         );
00054
00055     concurrency::task<void> LoadShaderAsync(
00056         _In_ Platform::String^ filename,
00057         _Out_ ID3D11PixelShader** shader
00058         );
00059
00060     void LoadShader(
00061         _In_ Platform::String^ filename,
00062         _Out_ ID3D11ComputeShader** shader
00063         );
00064
00065     concurrency::task<void> LoadShaderAsync(
00066         _In_ Platform::String^ filename,
00067         _Out_ ID3D11ComputeShader** shader
00068         );
00069
00070     void LoadShader(
00071         _In_ Platform::String^ filename,
00072         _Out_ ID3D11GeometryShader** shader
00073         );
00074
00075     concurrency::task<void> LoadShaderAsync(
00076         _In_ Platform::String^ filename,
00077         _Out_ ID3D11GeometryShader** shader
00078         );
00079
00080     void LoadShader(
00081         _In_ Platform::String^ filename,
00082         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00083         _In_ uint32 numEntries,
00084         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00085         _In_ uint32 numStrides,
00086         _In_ uint32 rasterizedStream,
00087         _Out_ ID3D11GeometryShader** shader
00088         );
00089
00090     concurrency::task<void> LoadShaderAsync(
00091         _In_ Platform::String^ filename,
00092         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00093         _In_ uint32 numEntries,
00094         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00095         _In_ uint32 numStrides,
00096         _In_ uint32 rasterizedStream,
00097         _Out_ ID3D11GeometryShader** shader
00098         );
00099
00100     void LoadShader(
00101         _In_ Platform::String^ filename,
00102         _Out_ ID3D11HullShader** shader
00103         );
00104
00105     concurrency::task<void> LoadShaderAsync(
00106         _In_ Platform::String^ filename,
00107         _Out_ ID3D11HullShader** shader
00108         );
00109
00110     void LoadShader(
00111         _In_ Platform::String^ filename,
00112         _Out_ ID3D11DomainShader** shader
00113         );
00114
00115     concurrency::task<void> LoadShaderAsync(
00116         _In_ Platform::String^ filename,
00117         _Out_ ID3D11DomainShader** shader
00118         );
00119
00120     void LoadMesh(
00121         _In_ Platform::String^ filename,
00122         _Out_ ID3D11Buffer** vertexBuffer,
00123         _Out_ ID3D11Buffer** indexBuffer,
00124         _Out_opt_ uint32* vertexCount,
00125         _Out_opt_ uint32* indexCount
00126         );
00127
00128     concurrency::task<void> LoadMeshAsync(
00129         _In_ Platform::String^ filename,
00130         _Out_ ID3D11Buffer** vertexBuffer,
00131         _Out_ ID3D11Buffer** indexBuffer,
00132         _Out_opt_ uint32* vertexCount,
00133         _Out_opt_ uint32* indexCount
00134         );
00135
00136 private:
00137     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00138     Microsoft::WRL::ComPtr<IWICImagingFactory2> m_wicFactory;
00139     BasicReaderWriter^ m_basicReaderWriter;
00140
00141     template <class DeviceChildType>
00142     inline void SetDebugName(
00143         _In_ DeviceChildType* object,
00144         _In_ Platform::String^ name
00145         );
00146
00147     Platform::String^ GetExtension(
00148         _In_ Platform::String^ filename
00149         );
00150
00151     void CreateTexture(
00152         _In_ bool decodeAsDDS,
00153         _In_reads_bytes_(dataSize) byte* data,
00154         _In_ uint32 dataSize,
00155         _Out_opt_ ID3D11Texture2D** texture,
00156         _Out_opt_ ID3D11ShaderResourceView** textureView,
00157         _In_opt_ Platform::String^ debugName
00158         );
00159
00160     void CreateInputLayout(
00161         _In_reads_bytes_(bytecodeSize) byte* bytecode,
00162         _In_ uint32 bytecodeSize,
00163         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00164         _In_ uint32 layoutDescNumElements,
00165         _Out_ ID3D11InputLayout** layout
00166         );
00167
00168     void CreateMesh(
00169         _In_ byte* meshData,
00170         _Out_ ID3D11Buffer** vertexBuffer,
00171         _Out_ ID3D11Buffer** indexBuffer,
00172         _Out_opt_ uint32* vertexCount,
00173         _Out_opt_ uint32* indexCount,
00174         _In_opt_ Platform::String^ debugName
00175         );
00176 };
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/ProfileLocalUsageData.xaml.cpp Source File

  • Network information

ProfileLocalUsageData.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 // ProfileLocalUsageData.xaml.cpp
00012 // Implementation of the ProfileLocalUsageData class
00013
00014 #include "pch.h"
00015 #include "ProfileLocalUsageData.xaml.h"
00016
00017 using namespace SDKSample::NetworkInformationApi;
00018
00019 using namespace Windows::UI::Xaml;
00020 using namespace Windows::UI::Xaml::Controls;
00021 using namespace Windows::UI::Xaml::Navigation;
00022 using namespace Windows::System;
00023 using namespace Windows::Foundation;
00024 using namespace Platform;
00025 using namespace Windows::Networking;
00026 using namespace Windows::Networking::Connectivity;
00027
00028 ProfileLocalUsageData::ProfileLocalUsageData()
00029 {
00030     InitializeComponent();
00031 }
00032
00033 /// <summary>
00034 /// Invoked when this page is about to be displayed in a Frame.
00035 /// </summary>
00036 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00037 /// property is typically used to configure the page.</param>
00038 void ProfileLocalUsageData::OnNavigatedTo(NavigationEventArgs^ e)
00039 {
00040     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00041     // as NotifyUser()
00042     rootPage = MainPage::Current;
00043 }
00044
00045 // Display Local Data Usage for Internet Connection Profile for the past 1 hour
00046 void SDKSample::NetworkInformationApi::ProfileLocalUsageData::ProfileLocalUsageData_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00047 {
00048     try
00049     {
00050         FILETIME ftCurrTime;
00051
00052         //Get Current time as FILETIME in UTC
00053         GetSystemTimeAsFileTime(&ftCurrTime);
00054
00055         //Get the DateTime object with current time
00056         DateTime dtCurrentTime;
00057         dtCurrentTime.UniversalTime = (((ULONGLONG) ftCurrTime.dwHighDateTime) << 32) + ftCurrTime.dwLowDateTime;
00058
00059         //Set Start time to one hour behind current time
00060         DateTime dtStartTime;
00061         dtStartTime.UniversalTime = dtCurrentTime.UniversalTime - (3600 * 10000000ULL);;
00062
00063         ConnectionProfile^ internetConnectionProfile = NetworkInformation::GetInternetConnectionProfile();
00064
00065         if (internetConnectionProfile == nullptr)
00066         {
00067             rootPage->NotifyUser(L"Not connected to Internet\n", NotifyType::StatusMessage);
00068         }
00069         else
00070         {
00071             //Get Local Data usage for the Internet Connection Profile for the past 1 hour
00072             DataUsage^ localUsage = internetConnectionProfile->GetLocalUsage(dtStartTime, dtCurrentTime);
00073
00074             String^ localUsageInfo = L"Local Data Usage:\n";
00075             localUsageInfo += L" Bytes Sent : " + localUsage->BytesSent.ToString() + "\n";
00076             localUsageInfo += L" Bytes Received : " + localUsage->BytesReceived.ToString() + "\n";
00077             rootPage->NotifyUser(localUsageInfo, NotifyType::StatusMessage);
00078         }
00079     }
00080     catch (Exception^ ex)
00081     {
00082         rootPage->NotifyUser("An unexpected exception occured: " + ex->Message, NotifyType::ErrorMessage);
00083     }
00084 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DWriteInlineObject Member List

This is the complete list of members for DWriteInlineObject, including all inherited members.
__pad0__ | DWriteInlineObject |
CreateDeviceIndependentResources() override | DWriteInlineObject | [virtual]
CreateDeviceResources() override | DWriteInlineObject | [virtual]
CreateWindowSizeDependentResources() override | DWriteInlineObject | [virtual]
HandleDeviceLost() override | DWriteInlineObject | [virtual]
Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView) | DWriteInlineObject | [virtual]
Load(_In_ Platform::String^entryPoint) | DWriteInlineObject | [virtual]
m_blackBrush | DWriteInlineObject | [private]
m_inlineImage | DWriteInlineObject | [private]
m_sampleOverlay | DWriteInlineObject | [private]
m_textFormat | DWriteInlineObject | [private]
m_textLayout | DWriteInlineObject | [private]
m_textTypography | DWriteInlineObject | [private]
OnActivated(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args) | DWriteInlineObject | [private]
OnDisplayContentsInvalidated(_In_ Platform::Object^sender) | DWriteInlineObject | [private]
OnLogicalDpiChanged(_In_ Platform::Object^sender) | DWriteInlineObject | [private]
OnResuming(_In_ Platform::Object^sender, _In_ Platform::Object^args) | DWriteInlineObject | [private]
OnSuspending(_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args) | DWriteInlineObject | [private]
OnWindowSizeChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args) | DWriteInlineObject | [private]
Render() override | DWriteInlineObject | [virtual]
Run() | DWriteInlineObject | [virtual]
SetWindow(_In_ Windows::UI::Core::CoreWindow^window) | DWriteInlineObject | [virtual]
Uninitialize() | DWriteInlineObject | [virtual]
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::MediaButtons::sealed Member List

This is the complete list of members for SDKSample::MediaButtons::sealed, including all inherited members.
_currentSongIndex | SDKSample::MediaButtons::sealed | [private]
_dispatcher | SDKSample::MediaButtons::sealed | [private]
_nextTrackPressedEventToken | SDKSample::MediaButtons::sealed | [private]
_playlist | SDKSample::MediaButtons::sealed | [private]
_playlistCount | SDKSample::MediaButtons::sealed | [private]
_prevTrackPressedEventToken | SDKSample::MediaButtons::sealed | [private]
_wasPlaying | SDKSample::MediaButtons::sealed | [private]
artistInner | SDKSample::MediaButtons::sealed |
ChannelDown(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
ChannelUp(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
CreatePlaylist(Windows::Foundation::Collections::IVectorView< StorageFile^>^files) | SDKSample::MediaButtons::sealed | [private]
DisplayStatus(Platform::String^text) | SDKSample::MediaButtons::sealed | [private]
FastForward(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
GetTimeStampedMessage(Platform::String^EventCalled) | SDKSample::MediaButtons::sealed | [private]
IsInitialized | SDKSample::MediaButtons::sealed | [private]
mediabuttons() | SDKSample::MediaButtons::sealed |
MediaElement_CurrentStateChanged(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MediaButtons::sealed | [private]
MediaElement_MediaEnded(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MediaButtons::sealed | [private]
MediaElement_MediaOpened(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MediaButtons::sealed | [private]
NextTrack(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::MediaButtons::sealed | [protected, virtual]
Pause(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
Play(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
Play_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MediaButtons::sealed | [private]
PlayPause(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
PrevTrack(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
Record(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
Rewind(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
rootPage | SDKSample::MediaButtons::sealed | [private]
SelectFiles_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::MediaButtons::sealed | [private]
SetCurrentPlayingAsync(int playlistIndex) | SDKSample::MediaButtons::sealed | [private]
SetMediaElementSourceAsync(Song^song) | SDKSample::MediaButtons::sealed | [private]
Song(StorageFile^file) | SDKSample::MediaButtons::sealed | [inline]
Stop(Object^sender, Object^e) | SDKSample::MediaButtons::sealed | [private]
trackInner | SDKSample::MediaButtons::sealed |
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/DirectXSample.h Source File

  • XInput audio controller playback

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SimpleCommunication::sealed::StreamFilteringCriteria Member List

This is the complete list of members for SimpleCommunication::sealed::StreamFilteringCriteria, including all inherited members.
aspectRatio | SimpleCommunication::sealed::StreamFilteringCriteria
horizontalResolution | SimpleCommunication::sealed::StreamFilteringCriteria
subType | SimpleCommunication::sealed::StreamFilteringCriteria
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/MainPage.xaml.cpp Source File

  • Input Device capabilities

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SimpleCommunication::VideoChat Member List

This is the complete list of members for SimpleCommunication::VideoChat, including all inherited members.
__pad0__ | Element |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) override | Page | [virtual]
activated | SimpleCommunication::VideoChat | [private]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) | Element | [virtual]
Call_Click(object sender, RoutedEventArgs e) | SimpleCommunication::VideoChat | [inline, private]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
DefaultViewModel | SDKTemplate::Common::LayoutAwarePage | [protected]
DefaultViewModelProperty | SDKTemplate::Common::LayoutAwarePage | [static]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
DetermineVisualState(ApplicationViewState viewState) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
device | SimpleCommunication::VideoChat | [private]
device_CaptureFailed(object sender, Windows.Media.Capture.MediaCaptureFailedEventArgs e) | SimpleCommunication::VideoChat | [inline, private]
device_IncomingConnectionArrived(object sender, IncomingConnectionEventArgs e) | SimpleCommunication::VideoChat | [inline, private]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
EndCall_Click(object sender, RoutedEventArgs e) | SimpleCommunication::VideoChat | [inline, private]
EndCallAsync() | SimpleCommunication::VideoChat | [inline, private]
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoBack(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
GoHome(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline, protected, virtual]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) | Element | [virtual]
InitializeAsync(CancellationToken cancel=default(CancellationToken)) | SimpleCommunication::VideoChat | [inline, private]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
InvalidateVisualState() | SDKTemplate::Common::LayoutAwarePage | [inline]
isTerminator | SimpleCommunication::VideoChat | [private]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
LayoutAwarePage() | SDKTemplate::Common::LayoutAwarePage | [inline]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) | Element | [virtual]
OnNavigatedTo(NavigationEventArgs e) | SimpleCommunication::VideoChat | [inline, protected]
OnNavigatingFrom(NavigatingCancelEventArgs e) | SimpleCommunication::VideoChat | [inline, protected]
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) | Element | [virtual]
ReleaseParent() | Element | [virtual]
RemoteVideo_MediaFailed(object sender, ExceptionRoutedEventArgs e) | SimpleCommunication::VideoChat | [inline, private]
roleIsActive | SimpleCommunication::VideoChat | [private]
rootPage | SimpleCommunication::VideoChat | [private]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StartLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StartRecordToCustomSink() | SimpleCommunication::VideoChat | [inline, private]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
StopLayoutUpdates(object sender, RoutedEventArgs e) | SDKTemplate::Common::LayoutAwarePage | [inline]
VideoChat() | SimpleCommunication::VideoChat | [inline]
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device auto rotation preferences/C++/MainPage.xaml.h Source File

  • Device auto rotation preferences

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite vertical text/C++/SampleOverlay.cpp Source File

  • DirectWrite vertical text

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicMath.h Source File

  • Direct3D resource loading

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/MainPage.xaml.cpp Source File

  • Sharing content source app

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/AudioController.cpp Source File

  • XInput audio controller playback

AudioController.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "AudioController.h"
00010 #include "DirectXSample.h"
00011
00012
00013 namespace
00014 {
00015     const char16 APPLICATION_TITLE[]    = L"XInput audio controller playback sample";
00016     const char16 SOUND_FILE[]           = L"media\\wavs\\pow.wav";
00017
00018     const char16    FONT_LOCAL[]        = L"en-US";
00019     const char16    FONT_NAME[]         = L"Segoe UI";
00020     const float     FONT_SIZE_TEXT      = 18.0f;
00021
00022     const char16 MSG_NEED_CONTROLLER[]  = L"Please insert an Xbox 360 common controller device and attach a headset.";
00023     const char16 MSG_NEED_HEADSET[]     = L"Please attach a headset to the Xbox 360 common controller device.";
00024     const char16 MSG_INSTRUCTIONS[]     = L"Press the A button to play a sound.";
00025
00026     const float INFORMATION_START_X     = 32.0f;
00027     const float INFORMATION_START_Y     = 150.0f;
00028
00029     const uint64 XINPUT_ENUM_TIMEOUT_MS          = 2000;  // 2 seconds
00030     const uint64 XINPUT_HEADSET_CHECK_TIMEOUT_MS = 2000;  // 2 seconds
00031 };
00032
00033 AudioController::AudioController() :
00034     m_audioEngine(nullptr),
00035     m_masteringVoice(nullptr),
00036     m_sourceVoice(nullptr),
00037     m_soundEffectBuffer(),
00038     m_isControllerConnected(false),
00039     m_isHeadsetConnected(false),
00040     m_aButtonWasPressed(false)
00041 {
00042     // Want the first pass to perform ennumeration
00043     uint64 tickCount = ::GetTickCount64();
00044     m_lastEnumTime = tickCount - XINPUT_ENUM_TIMEOUT_MS;
00045     m_lastHeadsetCheckTime = tickCount - XINPUT_HEADSET_CHECK_TIMEOUT_MS;
00046
00047 }
00048
00049 AudioController::~AudioController()
00050 {
00051     ReleaseAudioResources();
00052 }
00053
00054 void AudioController::CreateDeviceResources()
00055 {
00056     DirectXBase::CreateDeviceResources();
00057
00058     //
00059     // Create and initialize the default Sample graphics object
00060     //
00061     m_sampleOverlay = ref new SampleOverlay();
00062     m_sampleOverlay->Initialize(
00063         m_d2dDevice.Get(),
00064         m_d2dContext.Get(),
00065         m_wicFactory.Get(),
00066         m_dwriteFactory.Get(),
00067         ref new Platform::String(APPLICATION_TITLE)
00068         );
00069
00070     //
00071     // Setup the local graphics objects
00072     //
00073     DX::ThrowIfFailed(
00074         m_dwriteFactory->CreateTextFormat(
00075             FONT_NAME,
00076             nullptr,
00077             DWRITE_FONT_WEIGHT_NORMAL,
00078             DWRITE_FONT_STYLE_NORMAL,
00079             DWRITE_FONT_STRETCH_NORMAL,
00080             FONT_SIZE_TEXT,
00081             FONT_LOCAL,
00082             &m_dataTextFormat
00083             )
00084         );
00085
00086     DX::ThrowIfFailed(
00087         m_dataTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00088         );
00089     DX::ThrowIfFailed(
00090         m_dataTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00091         );
00092
00093     DX::ThrowIfFailed(
00094         m_d2dContext->CreateSolidColorBrush(D2D1::ColorF(D2D1::ColorF::White), &m_textBrush)
00095         );
00096 }
00097
00098 void AudioController::CreateAudioVoices(
00099     _In_ const char16* deviceEndpointId
00100     )
00101 {
00102     uint32 flags = 0;
00103
00104     DX::ThrowIfFailed(
00105         XAudio2Create(&m_audioEngine, flags)
00106         );
00107
00108     // Load all data for the sound effect into a single in-memory buffer
00109     MediaStreamer soundStream(ref new Platform::String(SOUND_FILE));
00110     m_soundEffectBuffer = soundStream.ReadAll();
00111
00112     // Get the sample rate from the sound
00113     uint32 streamSampleRate = soundStream.GetOutputWaveFormatEx().nSamplesPerSec;
00114
00115     // Create mastering voice for the stream, use stream's sample rate
00116     DX::ThrowIfFailed(
00117         m_audioEngine->CreateMasteringVoice(
00118             &m_masteringVoice,
00119             XAUDIO2_DEFAULT_CHANNELS,
00120             streamSampleRate,
00121             0,
00122             deviceEndpointId
00123             )
00124         );
00125
00126
00127     // Create a source voice for the sound effect using the stream's format
00128     DX::ThrowIfFailed(
00129         m_audioEngine->CreateSourceVoice(&m_sourceVoice, &(soundStream.GetOutputWaveFormatEx()))
00130         );
00131 }
00132
00133 void AudioController::ReleaseAudioResources()
00134 {
00135     if (m_sourceVoice != nullptr)
00136     {
00137         m_sourceVoice->DestroyVoice();
00138         m_sourceVoice = nullptr;
00139     }
00140
00141     if (m_masteringVoice != nullptr)
00142     {
00143         m_masteringVoice->DestroyVoice();
00144         m_masteringVoice = nullptr;
00145     }
00146
00147     if (m_audioEngine != nullptr)
00148     {
00149         m_audioEngine->Release();
00150         m_audioEngine = nullptr;
00151     }
00152 }
00153
00154 void AudioController::CreateWindowSizeDependentResources()
00155 {
00156     DirectXBase::CreateWindowSizeDependentResources();
00157     m_sampleOverlay->UpdateForWindowSizeChange();
00158 }
00159
00160 void AudioController::Render()
00161 {
00162     // bind the render targets
00163     m_d3dContext->OMSetRenderTargets(
00164         1,
00165         m_d3dRenderTargetView.GetAddressOf(),
00166         m_d3dDepthStencilView.Get()
00167         );
00168
00169     // clear both the render target and depth stencil to default values
00170     const float clearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };
00171
00172     m_d3dContext->ClearRenderTargetView(
00173         m_d3dRenderTargetView.Get(),
00174         clearColor
00175         );
00176
00177     m_sampleOverlay->Render();
00178
00179     D2D1_SIZE_F size = m_d2dContext->GetSize();
00180     D2D1_RECT_F pos = D2D1::RectF(INFORMATION_START_X, INFORMATION_START_Y, size.width, size.height);
00181
00182     m_d2dContext->BeginDraw();
00183
00184     if (!m_isControllerConnected)
00185     {
00186         // Display a message when controller is not connected
00187         m_d2dContext->DrawText(
00188             MSG_NEED_CONTROLLER,
00189             static_cast<uint32>(::wcslen(MSG_NEED_CONTROLLER)),
00190             m_dataTextFormat.Get(),
00191             pos,
00192             m_textBrush.Get()
00193             );
00194     }
00195     else if (!m_isHeadsetConnected)
00196     {
00197         // Display a message when controller is connected, but not a headset
00198
00199         m_d2dContext->DrawText(
00200             MSG_NEED_HEADSET,
00201             static_cast<uint32>(::wcslen(MSG_NEED_HEADSET)),
00202             m_dataTextFormat.Get(),
00203             pos,
00204             m_textBrush.Get()
00205             );
00206     }
00207     else
00208     {
00209         // Display a message when all is connected explaining what to do
00210         m_d2dContext->DrawText(
00211             MSG_INSTRUCTIONS,
00212             static_cast<uint32>(::wcslen(MSG_INSTRUCTIONS)),
00213             m_dataTextFormat.Get(),
00214             pos,
00215             m_textBrush.Get()
00216             );
00217     }
00218
00219     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00220     // is lost. It will be handled during the next call to Present.
00221     HRESULT hr = m_d2dContext->EndDraw();
00222     if (hr != D2DERR_RECREATE_TARGET)
00223     {
00224         DX::ThrowIfFailed(hr);
00225     }
00226 }
00227
00228 void AudioController::OnSuspending()
00229 {
00230     if (m_audioEngine != nullptr)
00231     {
00232         m_audioEngine->StopEngine();
00233     }
00234 }
00235
00236 void AudioController::OnResuming()
00237 {
00238     if (m_audioEngine != nullptr)
00239     {
00240         DX::ThrowIfFailed(
00241             m_audioEngine->StartEngine()
00242             );
00243     }
00244 }
00245
00246 void AudioController::FetchControllerInput()
00247 {
00248     uint64 currentTime = ::GetTickCount64();
00249
00250     if (!m_isControllerConnected)
00251     {
00252         //
00253         // Ennumerating for XInput devices takes 'time' on the order of milliseconds.
00254         // Any time a device is not currently known as connected (not yet called XInput, or calling
00255         // an XInput function after a failure) ennumeration happens.
00256         // An app should avoid repeatedly calling XInput functions if there are no known devices connected
00257         // as this can slow down application performance.
00258         // This sample takes the simple approach of not calling XInput functions after failure
00259         // until a specified timeout has passed.
00260         //
00261         if (currentTime - m_lastEnumTime < XINPUT_ENUM_TIMEOUT_MS)
00262         {
00263             return;
00264         }
00265         m_lastEnumTime = currentTime;
00266
00267         // Check for controller connection by trying to get the capabilties
00268         uint32 capsResult = XInputGetCapabilities(0, XINPUT_FLAG_GAMEPAD, &m_xinputCaps);
00269         if (capsResult != ERROR_SUCCESS)
00270         {
00271             m_lastHeadsetCheckTime = currentTime;
00272             return;
00273         }
00274
00275         // Device is connected
00276         m_isControllerConnected = true;
00277
00278         //
00279         // Start with the assumption that the headset is not connected
00280         // and recheck the connection right away
00281         //
00282         m_isHeadsetConnected = false;
00283         m_lastHeadsetCheckTime = currentTime - XINPUT_HEADSET_CHECK_TIMEOUT_MS;
00284     }
00285
00286     uint32 stateResult = XInputGetState(0, &m_xinputState);
00287     if (stateResult != ERROR_SUCCESS)
00288     {
00289         // Device is no longer connected
00290         m_isControllerConnected = false;
00291         m_isHeadsetConnected = false;
00292         m_lastEnumTime = currentTime;
00293         m_lastHeadsetCheckTime = currentTime;
00294
00295         return;
00296     }
00297
00298     if ((m_xinputCaps.Flags & XINPUT_CAPS_VOICE_SUPPORTED) == 0)
00299     {
00300         //
00301         // Controller does not support voice
00302         // We don't keep rechecking caps in this state as they shouldn't change without
00303         // the device first getting disconnected, then reconnected
00304         //
00305         return;
00306     }
00307
00308     if (currentTime - m_lastHeadsetCheckTime < XINPUT_HEADSET_CHECK_TIMEOUT_MS)
00309     {
00310         // It is not time to test the headset connection
00311         return;
00312     }
00313     m_lastHeadsetCheckTime = currentTime;
00314
00315     // Find the Audio Endpoint ID
00316     uint32 renderCount = 0;
00317     uint32 getEndpointResult = XInputGetAudioDeviceIds(0, nullptr, &renderCount, nullptr, nullptr);
00318
00319     if ((getEndpointResult != ERROR_SUCCESS) || (renderCount == 0))
00320     {
00321         // The headset is not connected even if it was before
00322         m_isHeadsetConnected = false;
00323         return;
00324     }
00325
00326     if (m_isHeadsetConnected == true)
00327     {
00328         // Was connected, still connected
00329         return;
00330     }
00331
00332     // Newly connected, setup audio, get the full render ID
00333     char16* renderId = new char16[renderCount];
00334     getEndpointResult = XInputGetAudioDeviceIds(0, renderId, &renderCount, nullptr, nullptr);
00335     if ((getEndpointResult == ERROR_SUCCESS) && (renderId[0] != '\0'))
00336     {
00337         // Headset was there, and now is gone
00338         m_isHeadsetConnected = true;
00339         CreateAudioVoices(renderId);
00340     }
00341     delete[] renderId;
00342 }
00343
00344 void AudioController::Update(float TimeTotal, float TimeDelta)
00345 {
00346     FetchControllerInput();
00347
00348     if (m_isHeadsetConnected)
00349     {
00350         if (m_xinputState.Gamepad.wButtons & XINPUT_GAMEPAD_A)
00351         {
00352             m_aButtonWasPressed = true;
00353         }
00354         else if (m_aButtonWasPressed)
00355         {
00356             // Trigger once, only on button release
00357             m_aButtonWasPressed = false;
00358             TriggerSoundEffect();
00359         }
00360     }
00361 }
00362
00363 void AudioController::TriggerSoundEffect()
00364 {
00365     XAUDIO2_BUFFER buf = {0};
00366     XAUDIO2_VOICE_STATE state = {0};
00367
00368     // Interrupt sound effect if currently playing
00369     DX::ThrowIfFailed(
00370         m_sourceVoice->Stop()
00371         );
00372     DX::ThrowIfFailed(
00373         m_sourceVoice->FlushSourceBuffers()
00374         );
00375
00376     // Queue in-memory buffer for playback and start the voice
00377     buf.AudioBytes = static_cast<uint32>(m_soundEffectBuffer.size());
00378     buf.pAudioData = &m_soundEffectBuffer[0];
00379     buf.Flags = XAUDIO2_END_OF_STREAM;
00380
00381     DX::ThrowIfFailed(
00382         m_sourceVoice->SubmitSourceBuffer(&buf)
00383         );
00384     DX::ThrowIfFailed(
00385         m_sourceVoice->Start()
00386         );
00387 }
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MediaExtensionsCS::App Member List

This is the complete list of members for MediaExtensionsCS::App, including all inherited members.
App() | MediaExtensionsCS::App | [inline]
OnLaunched(LaunchActivatedEventArgs args) | MediaExtensionsCS::App | [inline, protected]
OnSuspending(object sender, SuspendingEventArgs args) | MediaExtensionsCS::App | [inline, protected]
Generated on Sat Nov 23 2024 16:09:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HttpClient/C++/Scenario1.xaml.cpp Source File

  • HttpClient

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::HttpClientSample;
00020
00021 using namespace concurrency;
00022 using namespace Web;
00023 using namespace Platform;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::UI::Core;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 Scenario1::Scenario1()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00043     // as NotifyUser()
00044     rootPage = MainPage::Current;
00045 }
00046
00047 void SDKSample::HttpClientSample::Scenario1::Start_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049     OutputField->Text = "";
00050
00051     // The value of 'AddressField' is set by the user and is therefore untrusted input.
00052     // The URI is validated by calling TryGetUri() that will return 'false' for strings that are not valid URIs.
00053     // Note that this app has both "Internet (Client)" and "Home and Work Networking" capabilities set,
00054     // since the user may provide URIs for servers located on the intErnet or intrAnet. If apps only
00055     // communicate with servers on the intErnet, only the "Internet (Client)" capability should be set.
00056     // Similarly if an app is only intended to communicate on the intrAnet, only the "Home and Work
00057     // Networking" capability should be set.
00058     Uri^ uri;
00059     if (!rootPage->TryGetUri(AddressField->Text, &uri))
00060     {
00061         return;
00062     }
00063
00064     Helpers::ScenarioStarted(StartButton, CancelButton);
00065     rootPage->NotifyUser("In progress", NotifyType::StatusMessage);
00066
00067     cancellationTokenSource = cancellation_token_source();
00068
00069     // Do an asynchronous GET.  We need to use use_current() with the continuations since the tasks are completed on
00070     // background threads and we need to run on the UI thread to update the UI.
00071     httpRequest.GetAsync(uri, cancellationTokenSource.get_token()).then([this](task<std::wstring> response)
00072     {
00073         Helpers::ScenarioCompleted(StartButton, CancelButton);
00074
00075         try
00076         {
00077             DisplayTextResult(response.get(), OutputField);
00078             rootPage->NotifyUser("Completed", NotifyType::StatusMessage);
00079         }
00080         catch (const task_canceled&)
00081         {
00082             rootPage->NotifyUser("Request canceled.", NotifyType::ErrorMessage);
00083         }
00084         catch (Exception^ ex)
00085         {
00086             rootPage->NotifyUser(ex->Message, NotifyType::ErrorMessage);
00087         }
00088     }, task_continuation_context::use_current());
00089 }
00090
00091 void SDKSample::HttpClientSample::Scenario1::Cancel_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00092 {
00093     cancellationTokenSource.cancel();
00094 }
00095
00096 void SDKSample::HttpClientSample::Scenario1::DisplayTextResult(const std::wstring& response, TextBox^ output)
00097 {
00098     output->Text += httpRequest.GetStatusCode() + " " + ref new String(httpRequest.GetReasonPhrase().c_str()) + "\n";
00099
00100     // Convert all instances of <br> to newline.
00101     std::wstring ws = response;
00102     Helpers::ReplaceAll(ws, L"<br>", L"\n");
00103
00104     output->Text += ref new String(ws.c_str());
00105 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/App.xaml.cs Source File

  • Media extensions
  • C#,C++

App.xaml.cs

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 using System;
00009 using System.Threading.Tasks;
00010 using Windows.ApplicationModel.Activation;
00011 using Windows.ApplicationModel;
00012 using Windows.UI.Xaml;
00013 using Windows.UI.Xaml.Controls;
00014 using SDKTemplateCS;
00015
00016 namespace MediaExtensionsCS
00017 {
00018     public partial class App
00019     {
00020         public App()
00021         {
00022             InitializeComponent();
00023             this.Suspending += new SuspendingEventHandler(OnSuspending);
00024         }
00025
00026         async protected void OnSuspending(object sender, SuspendingEventArgs args)
00027         {
00028             SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
00029             await SuspensionManager.SaveAsync();
00030             deferral.Complete();
00031         }
00032
00033         async protected override void OnLaunched(LaunchActivatedEventArgs args)
00034         {
00035             if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
00036             {
00037                 //     Do an asynchronous restore
00038                 await SuspensionManager.RestoreAsync();
00039
00040             }
00041             var rootFrame = new Frame();
00042             rootFrame.Navigate(typeof(MainPage));
00043             Window.Current.Content = rootFrame;
00044             MainPage p = rootFrame.Content as MainPage;
00045             p.RootNamespace = this.GetType().Namespace;
00046             Window.Current.Activate();
00047         }
00048     }
00049 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DDSTextureLoader.cpp Source File

  • DXGI swap chain rotation

DDSTextureLoader.cpp

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.cpp
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #include "pch.h"
00019 #include <dxgiformat.h>
00020 #include <assert.h>
00021 #include <memory>
00022 #include <algorithm>
00023 #include "DDSTextureLoader.h"
00024 #include "DirectXSample.h"
00025
00026 using namespace Microsoft::WRL;
00027
00028 //--------------------------------------------------------------------------------------
00029 // Macros
00030 //--------------------------------------------------------------------------------------
00031 #ifndef MAKEFOURCC
00032     #define MAKEFOURCC(ch0, ch1, ch2, ch3)                              \
00033                 ((uint32)(byte)(ch0) | ((uint32)(byte)(ch1) << 8) |       \
00034                 ((uint32)(byte)(ch2) << 16) | ((uint32)(byte)(ch3) << 24))
00035 #endif /* defined(MAKEFOURCC) */
00036
00037 //--------------------------------------------------------------------------------------
00038 // DDS file structure definitions
00039 //
00040 // See DDS.h in the 'Texconv' sample and the 'DirectXTex' library
00041 //--------------------------------------------------------------------------------------
00042 #pragma pack(push, 1)
00043
00044 #define DDS_MAGIC 0x20534444 // "DDS "
00045
00046 struct DDS_PIXELFORMAT
00047 {
00048     uint32  size;
00049     uint32  flags;
00050     uint32  fourCC;
00051     uint32  RGBBitCount;
00052     uint32  RBitMask;
00053     uint32  GBitMask;
00054     uint32  BBitMask;
00055     uint32  ABitMask;
00056 };
00057
00058 #define DDS_FOURCC      0x00000004  // DDPF_FOURCC
00059 #define DDS_RGB         0x00000040  // DDPF_RGB
00060 #define DDS_RGBA        0x00000041  // DDPF_RGB | DDPF_ALPHAPIXELS
00061 #define DDS_LUMINANCE   0x00020000  // DDPF_LUMINANCE
00062 #define DDS_LUMINANCEA  0x00020001  // DDPF_LUMINANCE | DDPF_ALPHAPIXELS
00063 #define DDS_ALPHA       0x00000002  // DDPF_ALPHA
00064 #define DDS_PAL8        0x00000020  // DDPF_PALETTEINDEXED8
00065
00066 #define DDS_HEADER_FLAGS_TEXTURE        0x00001007  // DDSD_CAPS | DDSD_HEIGHT | DDSD_WIDTH | DDSD_PIXELFORMAT
00067 #define DDS_HEADER_FLAGS_MIPMAP         0x00020000  // DDSD_MIPMAPCOUNT
00068 #define DDS_HEADER_FLAGS_VOLUME         0x00800000  // DDSD_DEPTH
00069 #define DDS_HEADER_FLAGS_PITCH          0x00000008  // DDSD_PITCH
00070 #define DDS_HEADER_FLAGS_LINEARSIZE     0x00080000  // DDSD_LINEARSIZE
00071
00072 #define DDS_HEIGHT 0x00000002 // DDSD_HEIGHT
00073 #define DDS_WIDTH  0x00000004 // DDSD_WIDTH
00074
00075 #define DDS_SURFACE_FLAGS_TEXTURE 0x00001000 // DDSCAPS_TEXTURE
00076 #define DDS_SURFACE_FLAGS_MIPMAP  0x00400008 // DDSCAPS_COMPLEX | DDSCAPS_MIPMAP
00077 #define DDS_SURFACE_FLAGS_CUBEMAP 0x00000008 // DDSCAPS_COMPLEX
00078
00079 #define DDS_CUBEMAP_POSITIVEX 0x00000600 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEX
00080 #define DDS_CUBEMAP_NEGATIVEX 0x00000a00 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEX
00081 #define DDS_CUBEMAP_POSITIVEY 0x00001200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEY
00082 #define DDS_CUBEMAP_NEGATIVEY 0x00002200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEY
00083 #define DDS_CUBEMAP_POSITIVEZ 0x00004200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_POSITIVEZ
00084 #define DDS_CUBEMAP_NEGATIVEZ 0x00008200 // DDSCAPS2_CUBEMAP | DDSCAPS2_CUBEMAP_NEGATIVEZ
00085
00086 #define DDS_CUBEMAP_ALLFACES (DDS_CUBEMAP_POSITIVEX | DDS_CUBEMAP_NEGATIVEX |\
00087                               DDS_CUBEMAP_POSITIVEY | DDS_CUBEMAP_NEGATIVEY |\
00088                               DDS_CUBEMAP_POSITIVEZ | DDS_CUBEMAP_NEGATIVEZ)
00089
00090 #define DDS_CUBEMAP 0x00000200 // DDSCAPS2_CUBEMAP
00091
00092 #define DDS_FLAGS_VOLUME 0x00200000 // DDSCAPS2_VOLUME
00093
00094 typedef struct
00095 {
00096     uint32          size;
00097     uint32          flags;
00098     uint32          height;
00099     uint32          width;
00100     uint32          pitchOrLinearSize;
00101     uint32          depth; // only if DDS_HEADER_FLAGS_VOLUME is set in flags
00102     uint32          mipMapCount;
00103     uint32          reserved1[11];
00104     DDS_PIXELFORMAT ddspf;
00105     uint32          caps;
00106     uint32          caps2;
00107     uint32          caps3;
00108     uint32          caps4;
00109     uint32          reserved2;
00110 } DDS_HEADER;
00111
00112 typedef struct
00113 {
00114     DXGI_FORMAT dxgiFormat;
00115     uint32      resourceDimension;
00116     uint32      miscFlag; // see D3D11_RESOURCE_MISC_FLAG
00117     uint32      arraySize;
00118     uint32      reserved;
00119 } DDS_HEADER_DXT10;
00120
00121 #pragma pack(pop)
00122
00123 //--------------------------------------------------------------------------------------
00124 // Return the BPP for a particular format
00125 //--------------------------------------------------------------------------------------
00126 static size_t BitsPerPixel(_In_ DXGI_FORMAT fmt)
00127 {
00128     switch (fmt)
00129     {
00130     case DXGI_FORMAT_R32G32B32A32_TYPELESS:
00131     case DXGI_FORMAT_R32G32B32A32_FLOAT:
00132     case DXGI_FORMAT_R32G32B32A32_UINT:
00133     case DXGI_FORMAT_R32G32B32A32_SINT:
00134         return 128;
00135
00136     case DXGI_FORMAT_R32G32B32_TYPELESS:
00137     case DXGI_FORMAT_R32G32B32_FLOAT:
00138     case DXGI_FORMAT_R32G32B32_UINT:
00139     case DXGI_FORMAT_R32G32B32_SINT:
00140         return 96;
00141
00142     case DXGI_FORMAT_R16G16B16A16_TYPELESS:
00143     case DXGI_FORMAT_R16G16B16A16_FLOAT:
00144     case DXGI_FORMAT_R16G16B16A16_UNORM:
00145     case DXGI_FORMAT_R16G16B16A16_UINT:
00146     case DXGI_FORMAT_R16G16B16A16_SNORM:
00147     case DXGI_FORMAT_R16G16B16A16_SINT:
00148     case DXGI_FORMAT_R32G32_TYPELESS:
00149     case DXGI_FORMAT_R32G32_FLOAT:
00150     case DXGI_FORMAT_R32G32_UINT:
00151     case DXGI_FORMAT_R32G32_SINT:
00152     case DXGI_FORMAT_R32G8X24_TYPELESS:
00153     case DXGI_FORMAT_D32_FLOAT_S8X24_UINT:
00154     case DXGI_FORMAT_R32_FLOAT_X8X24_TYPELESS:
00155     case DXGI_FORMAT_X32_TYPELESS_G8X24_UINT:
00156         return 64;
00157
00158     case DXGI_FORMAT_R10G10B10A2_TYPELESS:
00159     case DXGI_FORMAT_R10G10B10A2_UNORM:
00160     case DXGI_FORMAT_R10G10B10A2_UINT:
00161     case DXGI_FORMAT_R11G11B10_FLOAT:
00162     case DXGI_FORMAT_R8G8B8A8_TYPELESS:
00163     case DXGI_FORMAT_R8G8B8A8_UNORM:
00164     case DXGI_FORMAT_R8G8B8A8_UNORM_SRGB:
00165     case DXGI_FORMAT_R8G8B8A8_UINT:
00166     case DXGI_FORMAT_R8G8B8A8_SNORM:
00167     case DXGI_FORMAT_R8G8B8A8_SINT:
00168     case DXGI_FORMAT_R16G16_TYPELESS:
00169     case DXGI_FORMAT_R16G16_FLOAT:
00170     case DXGI_FORMAT_R16G16_UNORM:
00171     case DXGI_FORMAT_R16G16_UINT:
00172     case DXGI_FORMAT_R16G16_SNORM:
00173     case DXGI_FORMAT_R16G16_SINT:
00174     case DXGI_FORMAT_R32_TYPELESS:
00175     case DXGI_FORMAT_D32_FLOAT:
00176     case DXGI_FORMAT_R32_FLOAT:
00177     case DXGI_FORMAT_R32_UINT:
00178     case DXGI_FORMAT_R32_SINT:
00179     case DXGI_FORMAT_R24G8_TYPELESS:
00180     case DXGI_FORMAT_D24_UNORM_S8_UINT:
00181     case DXGI_FORMAT_R24_UNORM_X8_TYPELESS:
00182     case DXGI_FORMAT_X24_TYPELESS_G8_UINT:
00183     case DXGI_FORMAT_R9G9B9E5_SHAREDEXP:
00184     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00185     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00186     case DXGI_FORMAT_B8G8R8A8_UNORM:
00187     case DXGI_FORMAT_B8G8R8X8_UNORM:
00188     case DXGI_FORMAT_R10G10B10_XR_BIAS_A2_UNORM:
00189     case DXGI_FORMAT_B8G8R8A8_TYPELESS:
00190     case DXGI_FORMAT_B8G8R8A8_UNORM_SRGB:
00191     case DXGI_FORMAT_B8G8R8X8_TYPELESS:
00192     case DXGI_FORMAT_B8G8R8X8_UNORM_SRGB:
00193         return 32;
00194
00195     case DXGI_FORMAT_R8G8_TYPELESS:
00196     case DXGI_FORMAT_R8G8_UNORM:
00197     case DXGI_FORMAT_R8G8_UINT:
00198     case DXGI_FORMAT_R8G8_SNORM:
00199     case DXGI_FORMAT_R8G8_SINT:
00200     case DXGI_FORMAT_R16_TYPELESS:
00201     case DXGI_FORMAT_R16_FLOAT:
00202     case DXGI_FORMAT_D16_UNORM:
00203     case DXGI_FORMAT_R16_UNORM:
00204     case DXGI_FORMAT_R16_UINT:
00205     case DXGI_FORMAT_R16_SNORM:
00206     case DXGI_FORMAT_R16_SINT:
00207     case DXGI_FORMAT_B5G6R5_UNORM:
00208     case DXGI_FORMAT_B5G5R5A1_UNORM:
00209     case DXGI_FORMAT_B4G4R4A4_UNORM:
00210         return 16;
00211
00212     case DXGI_FORMAT_R8_TYPELESS:
00213     case DXGI_FORMAT_R8_UNORM:
00214     case DXGI_FORMAT_R8_UINT:
00215     case DXGI_FORMAT_R8_SNORM:
00216     case DXGI_FORMAT_R8_SINT:
00217     case DXGI_FORMAT_A8_UNORM:
00218         return 8;
00219
00220     case DXGI_FORMAT_R1_UNORM:
00221         return 1;
00222
00223     case DXGI_FORMAT_BC1_TYPELESS:
00224     case DXGI_FORMAT_BC1_UNORM:
00225     case DXGI_FORMAT_BC1_UNORM_SRGB:
00226     case DXGI_FORMAT_BC4_TYPELESS:
00227     case DXGI_FORMAT_BC4_UNORM:
00228     case DXGI_FORMAT_BC4_SNORM:
00229         return 4;
00230
00231     case DXGI_FORMAT_BC2_TYPELESS:
00232     case DXGI_FORMAT_BC2_UNORM:
00233     case DXGI_FORMAT_BC2_UNORM_SRGB:
00234     case DXGI_FORMAT_BC3_TYPELESS:
00235     case DXGI_FORMAT_BC3_UNORM:
00236     case DXGI_FORMAT_BC3_UNORM_SRGB:
00237     case DXGI_FORMAT_BC5_TYPELESS:
00238     case DXGI_FORMAT_BC5_UNORM:
00239     case DXGI_FORMAT_BC5_SNORM:
00240     case DXGI_FORMAT_BC6H_TYPELESS:
00241     case DXGI_FORMAT_BC6H_UF16:
00242     case DXGI_FORMAT_BC6H_SF16:
00243     case DXGI_FORMAT_BC7_TYPELESS:
00244     case DXGI_FORMAT_BC7_UNORM:
00245     case DXGI_FORMAT_BC7_UNORM_SRGB:
00246         return 8;
00247
00248     default:
00249         return 0;
00250     }
00251 }
00252
00253
00254 //--------------------------------------------------------------------------------------
00255 // Get surface information for a particular format
00256 //--------------------------------------------------------------------------------------
00257 static void GetSurfaceInfo(
00258     _In_ size_t width,
00259     _In_ size_t height,
00260     _In_ DXGI_FORMAT fmt,
00261     _Out_opt_ size_t* outNumBytes,
00262     _Out_opt_ size_t* outRowBytes,
00263     _Out_opt_ size_t* outNumRows
00264     )
00265 {
00266     size_t numBytes = 0;
00267     size_t rowBytes = 0;
00268     size_t numRows = 0;
00269
00270     bool bc = false;
00271     bool packed  = false;
00272     size_t bcnumBytesPerBlock = 0;
00273     switch (fmt)
00274     {
00275     case DXGI_FORMAT_BC1_TYPELESS:
00276     case DXGI_FORMAT_BC1_UNORM:
00277     case DXGI_FORMAT_BC1_UNORM_SRGB:
00278     case DXGI_FORMAT_BC4_TYPELESS:
00279     case DXGI_FORMAT_BC4_UNORM:
00280     case DXGI_FORMAT_BC4_SNORM:
00281         bc = true;
00282         bcnumBytesPerBlock = 8;
00283         break;
00284
00285     case DXGI_FORMAT_BC2_TYPELESS:
00286     case DXGI_FORMAT_BC2_UNORM:
00287     case DXGI_FORMAT_BC2_UNORM_SRGB:
00288     case DXGI_FORMAT_BC3_TYPELESS:
00289     case DXGI_FORMAT_BC3_UNORM:
00290     case DXGI_FORMAT_BC3_UNORM_SRGB:
00291     case DXGI_FORMAT_BC5_TYPELESS:
00292     case DXGI_FORMAT_BC5_UNORM:
00293     case DXGI_FORMAT_BC5_SNORM:
00294     case DXGI_FORMAT_BC6H_TYPELESS:
00295     case DXGI_FORMAT_BC6H_UF16:
00296     case DXGI_FORMAT_BC6H_SF16:
00297     case DXGI_FORMAT_BC7_TYPELESS:
00298     case DXGI_FORMAT_BC7_UNORM:
00299     case DXGI_FORMAT_BC7_UNORM_SRGB:
00300         bc = true;
00301         bcnumBytesPerBlock = 16;
00302         break;
00303
00304     case DXGI_FORMAT_R8G8_B8G8_UNORM:
00305     case DXGI_FORMAT_G8R8_G8B8_UNORM:
00306         packed = true;
00307         break;
00308     }
00309
00310     if (bc)
00311     {
00312         size_t numBlocksWide = 0;
00313         if (width > 0)
00314         {
00315             numBlocksWide = std::max<size_t>(1, (width + 3) / 4);
00316         }
00317         size_t numBlocksHigh = 0;
00318         if (height > 0)
00319         {
00320             numBlocksHigh = std::max<size_t>(1, (height + 3) / 4);
00321         }
00322         rowBytes = numBlocksWide * bcnumBytesPerBlock;
00323         numRows = numBlocksHigh;
00324     }
00325     else if (packed)
00326     {
00327         rowBytes = ((width + 1) >> 1) * 4;
00328         numRows = height;
00329     }
00330     else
00331     {
00332         size_t bpp = BitsPerPixel(fmt);
00333         rowBytes = (width * bpp + 7) / 8; // round up to nearest byte
00334         numRows = height;
00335     }
00336
00337     numBytes = rowBytes * numRows;
00338     if (outNumBytes)
00339     {
00340         *outNumBytes = numBytes;
00341     }
00342     if (outRowBytes)
00343     {
00344         *outRowBytes = rowBytes;
00345     }
00346     if (outNumRows)
00347     {
00348         *outNumRows = numRows;
00349     }
00350 }
00351
00352
00353 //--------------------------------------------------------------------------------------
00354 #define ISBITMASK(r, g, b, a) (ddpf.RBitMask == r && ddpf.GBitMask == g && ddpf.BBitMask == b && ddpf.ABitMask == a)
00355
00356 static DXGI_FORMAT GetDXGIFormat(const DDS_PIXELFORMAT& ddpf)
00357 {
00358     if (ddpf.flags & DDS_RGB)
00359     {
00360         // Note that sRGB formats are written using the "DX10" extended header
00361
00362         switch (ddpf.RGBBitCount)
00363         {
00364         case 32:
00365             if (ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0xff000000))
00366             {
00367                 return DXGI_FORMAT_R8G8B8A8_UNORM;
00368             }
00369
00370             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0xff000000))
00371             {
00372                 return DXGI_FORMAT_B8G8R8A8_UNORM;
00373             }
00374
00375             if (ISBITMASK(0x00ff0000, 0x0000ff00, 0x000000ff, 0x00000000))
00376             {
00377                 return DXGI_FORMAT_B8G8R8X8_UNORM;
00378             }
00379
00380             // No DXGI format maps to ISBITMASK(0x000000ff, 0x0000ff00, 0x00ff0000, 0x00000000) aka D3DFMT_X8B8G8R8
00381
00382             // Note that many common DDS reader/writers (including D3DX) swap the
00383             // the RED/BLUE masks for 10:10:10:2 formats. We assumme
00384             // below that the 'backwards' header mask is being used since it is most
00385             // likely written by D3DX. The more robust solution is to use the 'DX10'
00386             // header extension and specify the DXGI_FORMAT_R10G10B10A2_UNORM format directly
00387
00388             // For 'correct' writers, this should be 0x000003ff, 0x000ffc00, 0x3ff00000 for RGB data
00389             if (ISBITMASK(0x3ff00000, 0x000ffc00, 0x000003ff, 0xc0000000))
00390             {
00391                 return DXGI_FORMAT_R10G10B10A2_UNORM;
00392             }
00393
00394             // No DXGI format maps to ISBITMASK(0x000003ff, 0x000ffc00, 0x3ff00000, 0xc0000000) aka D3DFMT_A2R10G10B10
00395
00396             if (ISBITMASK(0x0000ffff, 0xffff0000, 0x00000000, 0x00000000))
00397             {
00398                 return DXGI_FORMAT_R16G16_UNORM;
00399             }
00400
00401             if (ISBITMASK(0xffffffff, 0x00000000, 0x00000000, 0x00000000))
00402             {
00403                 // Only 32-bit color channel format in D3D9 was R32F
00404                 return DXGI_FORMAT_R32_FLOAT; // D3DX writes this out as a FourCC of 114
00405             }
00406             break;
00407
00408         case 24:
00409             // No 24bpp DXGI formats aka D3DFMT_R8G8B8
00410             break;
00411
00412         case 16:
00413             if (ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x8000))
00414             {
00415                 return DXGI_FORMAT_B5G5R5A1_UNORM;
00416             }
00417             if (ISBITMASK(0xf800, 0x07e0, 0x001f, 0x0000))
00418             {
00419                 return DXGI_FORMAT_B5G6R5_UNORM;
00420             }
00421
00422             // No DXGI format maps to ISBITMASK(0x7c00, 0x03e0, 0x001f, 0x0000) aka D3DFMT_X1R5G5B5
00423             if (ISBITMASK(0x0f00, 0x00f0, 0x000f, 0xf000))
00424             {
00425                 return DXGI_FORMAT_B4G4R4A4_UNORM;
00426             }
00427
00428             // No DXGI format maps to ISBITMASK(0x0f00, 0x00f0, 0x000f, 0x0000) aka D3DFMT_X4R4G4B4
00429
00430             // No 3:3:2, 3:3:2:8, or paletted DXGI formats aka D3DFMT_A8R3G3B2, D3DFMT_R3G3B2, D3DFMT_P8, D3DFMT_A8P8, etc.
00431             break;
00432         }
00433     }
00434     else if (ddpf.flags & DDS_LUMINANCE)
00435     {
00436         if (8 == ddpf.RGBBitCount)
00437         {
00438             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x00000000))
00439             {
00440                 return DXGI_FORMAT_R8_UNORM; // D3DX10/11 writes this out as DX10 extension
00441             }
00442
00443             // No DXGI format maps to ISBITMASK(0x0f, 0x00, 0x00, 0xf0) aka D3DFMT_A4L4
00444         }
00445
00446         if (16 == ddpf.RGBBitCount)
00447         {
00448             if (ISBITMASK(0x0000ffff, 0x00000000, 0x00000000, 0x00000000))
00449             {
00450                 return DXGI_FORMAT_R16_UNORM; // D3DX10/11 writes this out as DX10 extension
00451             }
00452             if (ISBITMASK(0x000000ff, 0x00000000, 0x00000000, 0x0000ff00))
00453             {
00454                 return DXGI_FORMAT_R8G8_UNORM; // D3DX10/11 writes this out as DX10 extension
00455             }
00456         }
00457     }
00458     else if (ddpf.flags & DDS_ALPHA)
00459     {
00460         if (8 == ddpf.RGBBitCount)
00461         {
00462             return DXGI_FORMAT_A8_UNORM;
00463         }
00464     }
00465     else if (ddpf.flags & DDS_FOURCC)
00466     {
00467         if (MAKEFOURCC('D', 'X', 'T', '1') == ddpf.fourCC)
00468         {
00469             return DXGI_FORMAT_BC1_UNORM;
00470         }
00471         if (MAKEFOURCC('D', 'X', 'T', '3') == ddpf.fourCC)
00472         {
00473             return DXGI_FORMAT_BC2_UNORM;
00474         }
00475         if (MAKEFOURCC('D', 'X', 'T', '5') == ddpf.fourCC)
00476         {
00477             return DXGI_FORMAT_BC3_UNORM;
00478         }
00479
00480         // While pre-mulitplied alpha isn't directly supported by the DXGI formats,
00481         // they are basically the same as these BC formats so they can be mapped
00482         if (MAKEFOURCC('D', 'X', 'T', '2') == ddpf.fourCC)
00483         {
00484             return DXGI_FORMAT_BC2_UNORM;
00485         }
00486         if (MAKEFOURCC('D', 'X', 'T', '4') == ddpf.fourCC)
00487         {
00488             return DXGI_FORMAT_BC3_UNORM;
00489         }
00490
00491         if (MAKEFOURCC('A', 'T', 'I', '1') == ddpf.fourCC)
00492         {
00493             return DXGI_FORMAT_BC4_UNORM;
00494         }
00495         if (MAKEFOURCC('B', 'C', '4', 'U') == ddpf.fourCC)
00496         {
00497             return DXGI_FORMAT_BC4_UNORM;
00498         }
00499         if (MAKEFOURCC('B', 'C', '4', 'S') == ddpf.fourCC)
00500         {
00501             return DXGI_FORMAT_BC4_SNORM;
00502         }
00503
00504         if (MAKEFOURCC('A', 'T', 'I', '2') == ddpf.fourCC)
00505         {
00506             return DXGI_FORMAT_BC5_UNORM;
00507         }
00508         if (MAKEFOURCC('B', 'C', '5', 'U') == ddpf.fourCC)
00509         {
00510             return DXGI_FORMAT_BC5_UNORM;
00511         }
00512         if (MAKEFOURCC('B', 'C', '5', 'S') == ddpf.fourCC)
00513         {
00514             return DXGI_FORMAT_BC5_SNORM;
00515         }
00516
00517         // BC6H and BC7 are written using the "DX10" extended header
00518
00519         if (MAKEFOURCC('R', 'G', 'B', 'G') == ddpf.fourCC)
00520         {
00521             return DXGI_FORMAT_R8G8_B8G8_UNORM;
00522         }
00523         if (MAKEFOURCC('G', 'R', 'G', 'B') == ddpf.fourCC)
00524         {
00525             return DXGI_FORMAT_G8R8_G8B8_UNORM;
00526         }
00527
00528         // Check for D3DFORMAT enums being set here
00529         switch (ddpf.fourCC)
00530         {
00531         case 36: // D3DFMT_A16B16G16R16
00532             return DXGI_FORMAT_R16G16B16A16_UNORM;
00533
00534         case 110: // D3DFMT_Q16W16V16U16
00535             return DXGI_FORMAT_R16G16B16A16_SNORM;
00536
00537         case 111: // D3DFMT_R16F
00538             return DXGI_FORMAT_R16_FLOAT;
00539
00540         case 112: // D3DFMT_G16R16F
00541             return DXGI_FORMAT_R16G16_FLOAT;
00542
00543         case 113: // D3DFMT_A16B16G16R16F
00544             return DXGI_FORMAT_R16G16B16A16_FLOAT;
00545
00546         case 114: // D3DFMT_R32F
00547             return DXGI_FORMAT_R32_FLOAT;
00548
00549         case 115: // D3DFMT_G32R32F
00550             return DXGI_FORMAT_R32G32_FLOAT;
00551
00552         case 116: // D3DFMT_A32B32G32R32F
00553             return DXGI_FORMAT_R32G32B32A32_FLOAT;
00554         }
00555     }
00556
00557     return DXGI_FORMAT_UNKNOWN;
00558 }
00559
00560
00561 //--------------------------------------------------------------------------------------
00562 static void FillInitData(
00563     _In_ size_t width,
00564     _In_ size_t height,
00565     _In_ size_t depth,
00566     _In_ size_t mipCount,
00567     _In_ size_t arraySize,
00568     _In_ DXGI_FORMAT format,
00569     _In_ size_t maxsize,
00570     _In_ size_t bitSize,
00571     _In_reads_bytes_(bitSize) const byte* bitData,
00572     _Out_ size_t& twidth,
00573     _Out_ size_t& theight,
00574     _Out_ size_t& tdepth,
00575     _Out_ size_t& skipMip,
00576     _Out_writes_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData
00577     )
00578 {
00579     if (!bitData || !initData)
00580     {
00581         throw ref new Platform::InvalidArgumentException();
00582     }
00583
00584     skipMip = 0;
00585     twidth = 0;
00586     theight = 0;
00587     tdepth = 0;
00588
00589     size_t NumBytes = 0;
00590     size_t RowBytes = 0;
00591     size_t NumRows = 0;
00592     const byte* pSrcBits = bitData;
00593     const byte* pEndBits = bitData + bitSize;
00594
00595     size_t index = 0;
00596     for (size_t j = 0; j < arraySize; j++)
00597     {
00598         size_t w = width;
00599         size_t h = height;
00600         size_t d = depth;
00601         for (size_t i = 0; i < mipCount; i++)
00602         {
00603             GetSurfaceInfo(w, h, format, &NumBytes, &RowBytes, &NumRows);
00604
00605             if ((mipCount <= 1) || !maxsize || (w <= maxsize && h <= maxsize && d <= maxsize))
00606             {
00607                 if (!twidth)
00608                 {
00609                     twidth = w;
00610                     theight = h;
00611                     tdepth = d;
00612                 }
00613
00614                 initData[index].pSysMem = (const void*)pSrcBits;
00615                 initData[index].SysMemPitch = static_cast<UINT>(RowBytes);
00616                 initData[index].SysMemSlicePitch = static_cast<UINT>(NumBytes);
00617                 ++index;
00618             }
00619             else
00620             {
00621                 ++skipMip;
00622             }
00623
00624             if (pSrcBits + (NumBytes*d) > pEndBits)
00625             {
00626                 throw ref new Platform::OutOfBoundsException();
00627             }
00628
00629             pSrcBits += NumBytes * d;
00630
00631             w = w >> 1;
00632             h = h >> 1;
00633             d = d >> 1;
00634             if (w == 0)
00635             {
00636                 w = 1;
00637             }
00638             if (h == 0)
00639             {
00640                 h = 1;
00641             }
00642             if (d == 0)
00643             {
00644                 d = 1;
00645             }
00646         }
00647     }
00648
00649     if (!index)
00650     {
00651         throw ref new Platform::FailureException();
00652     }
00653 }
00654
00655
00656 //--------------------------------------------------------------------------------------
00657 static HRESULT CreateD3DResources(
00658     _In_ ID3D11Device* d3dDevice,
00659     _In_ uint32 resDim,
00660     _In_ size_t width,
00661     _In_ size_t height,
00662     _In_ size_t depth,
00663     _In_ size_t mipCount,
00664     _In_ size_t arraySize,
00665     _In_ DXGI_FORMAT format,
00666     _In_ bool isCubeMap,
00667     _In_reads_(mipCount*arraySize) D3D11_SUBRESOURCE_DATA* initData,
00668     _Out_opt_ ID3D11Resource** texture,
00669     _Out_opt_ ID3D11ShaderResourceView** textureView
00670     )
00671 {
00672     if (!d3dDevice || !initData)
00673     {
00674         return E_INVALIDARG;
00675     }
00676
00677     HRESULT hr = E_FAIL;
00678
00679     switch (resDim)
00680     {
00681         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00682             {
00683                 D3D11_TEXTURE1D_DESC desc;
00684                 desc.Width = static_cast<UINT>(width);
00685                 desc.MipLevels = static_cast<UINT>(mipCount);
00686                 desc.ArraySize = static_cast<UINT>(arraySize);
00687                 desc.Format = format;
00688                 desc.Usage = D3D11_USAGE_DEFAULT;
00689                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00690                 desc.CPUAccessFlags = 0;
00691                 desc.MiscFlags = 0;
00692
00693                 ID3D11Texture1D* tex = nullptr;
00694                 hr = d3dDevice->CreateTexture1D(&desc, initData, &tex);
00695
00696                 if (SUCCEEDED(hr) && tex != 0)
00697                 {
00698                     if (textureView != 0)
00699                     {
00700                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00701                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00702                         SRVDesc.Format = format;
00703
00704                         if (arraySize > 1)
00705                         {
00706                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1DARRAY;
00707                             SRVDesc.Texture1DArray.MipLevels = desc.MipLevels;
00708                             SRVDesc.Texture1DArray.ArraySize = static_cast<UINT>(arraySize);
00709                         }
00710                         else
00711                         {
00712                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE1D;
00713                             SRVDesc.Texture1D.MipLevels = desc.MipLevels;
00714                         }
00715
00716                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00717
00718                         if (FAILED(hr))
00719                         {
00720                             tex->Release();
00721                             return hr;
00722                         }
00723                     }
00724
00725                     if (texture != 0)
00726                     {
00727                         *texture = tex;
00728                     }
00729                     else
00730                     {
00731                         tex->Release();
00732                     }
00733                 }
00734             }
00735             break;
00736
00737         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00738             {
00739                 D3D11_TEXTURE2D_DESC desc;
00740                 desc.Width = static_cast<UINT>(width);
00741                 desc.Height = static_cast<UINT>(height);
00742                 desc.MipLevels = static_cast<UINT>(mipCount);
00743                 desc.ArraySize = static_cast<UINT>(arraySize);
00744                 desc.Format = format;
00745                 desc.SampleDesc.Count = 1;
00746                 desc.SampleDesc.Quality = 0;
00747                 desc.Usage = D3D11_USAGE_DEFAULT;
00748                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00749                 desc.CPUAccessFlags = 0;
00750                 desc.MiscFlags = (isCubeMap) ? D3D11_RESOURCE_MISC_TEXTURECUBE : 0;
00751
00752                 ID3D11Texture2D* tex = nullptr;
00753                 hr = d3dDevice->CreateTexture2D(&desc, initData, &tex);
00754
00755                 if (SUCCEEDED(hr) && tex != 0)
00756                 {
00757                     if (textureView != 0)
00758                     {
00759                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00760                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00761                         SRVDesc.Format = format;
00762
00763                         if (isCubeMap)
00764                         {
00765                             if (arraySize > 6)
00766                             {
00767                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBEARRAY;
00768                                 SRVDesc.TextureCubeArray.MipLevels = desc.MipLevels;
00769
00770                                 // Earlier we set arraySize to (NumCubes * 6)
00771                                 SRVDesc.TextureCubeArray.NumCubes = static_cast<UINT>(arraySize / 6);
00772                             }
00773                             else
00774                             {
00775                                 SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURECUBE;
00776                                 SRVDesc.TextureCube.MipLevels = desc.MipLevels;
00777                             }
00778                         }
00779                         else if (arraySize > 1)
00780                         {
00781                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2DARRAY;
00782                             SRVDesc.Texture2DArray.MipLevels = desc.MipLevels;
00783                             SRVDesc.Texture2DArray.ArraySize = static_cast<UINT>(arraySize);
00784                         }
00785                         else
00786                         {
00787                             SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE2D;
00788                             SRVDesc.Texture2D.MipLevels = desc.MipLevels;
00789                         }
00790
00791                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00792
00793                         if (FAILED(hr))
00794                         {
00795                             tex->Release();
00796                             return hr;
00797                         }
00798                     }
00799
00800                     if (texture != 0)
00801                     {
00802                         *texture = tex;
00803                     }
00804                     else
00805                     {
00806                         tex->Release();
00807                     }
00808                 }
00809             }
00810             break;
00811
00812         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00813             {
00814                 D3D11_TEXTURE3D_DESC desc;
00815                 desc.Width = static_cast<UINT>(width);
00816                 desc.Height = static_cast<UINT>(height);
00817                 desc.Depth = static_cast<UINT>(depth);
00818                 desc.MipLevels = static_cast<UINT>(mipCount);
00819                 desc.Format = format;
00820                 desc.Usage = D3D11_USAGE_DEFAULT;
00821                 desc.BindFlags = D3D11_BIND_SHADER_RESOURCE;
00822                 desc.CPUAccessFlags = 0;
00823                 desc.MiscFlags = 0;
00824
00825                 ID3D11Texture3D* tex = nullptr;
00826                 hr = d3dDevice->CreateTexture3D(&desc, initData, &tex);
00827
00828                 if (SUCCEEDED(hr) && tex != 0)
00829                 {
00830                     if (textureView != 0)
00831                     {
00832                         D3D11_SHADER_RESOURCE_VIEW_DESC SRVDesc;
00833                         memset(&SRVDesc, 0, sizeof(SRVDesc));
00834                         SRVDesc.Format = format;
00835                         SRVDesc.ViewDimension = D3D_SRV_DIMENSION_TEXTURE3D;
00836                         SRVDesc.Texture3D.MipLevels = desc.MipLevels;
00837
00838                         hr = d3dDevice->CreateShaderResourceView(tex, &SRVDesc, textureView);
00839
00840                         if (FAILED(hr))
00841                         {
00842                             tex->Release();
00843                             return hr;
00844                         }
00845                     }
00846
00847                     if (texture != 0)
00848                     {
00849                         *texture = tex;
00850                     }
00851                     else
00852                     {
00853                         tex->Release();
00854                     }
00855                 }
00856             }
00857             break;
00858     }
00859
00860     return hr;
00861 }
00862
00863
00864 //--------------------------------------------------------------------------------------
00865 static void CreateTextureFromDDS(
00866     _In_ ID3D11Device* d3dDevice,
00867     _In_ const DDS_HEADER* header,
00868     _In_reads_bytes_(bitSize) const byte* bitData,
00869     _In_ size_t bitSize,
00870     _Out_opt_ ID3D11Resource** texture,
00871     _Out_opt_ ID3D11ShaderResourceView** textureView,
00872     _In_ size_t maxsize
00873     )
00874 {
00875     HRESULT hr = S_OK;
00876
00877     size_t width = header->width;
00878     size_t height = header->height;
00879     size_t depth = header->depth;
00880
00881     uint32 resDim = D3D11_RESOURCE_DIMENSION_UNKNOWN;
00882     size_t arraySize = 1;
00883     DXGI_FORMAT format = DXGI_FORMAT_UNKNOWN;
00884     bool isCubeMap = false;
00885
00886     size_t mipCount = header->mipMapCount;
00887     if (0 == mipCount)
00888     {
00889         mipCount = 1;
00890     }
00891
00892     if ((header->ddspf.flags & DDS_FOURCC) &&
00893         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
00894     {
00895         const DDS_HEADER_DXT10* d3d10ext = reinterpret_cast<const DDS_HEADER_DXT10*>((const char*)header + sizeof(DDS_HEADER));
00896
00897         arraySize = d3d10ext->arraySize;
00898         if (arraySize == 0)
00899         {
00900             throw ref new Platform::FailureException();
00901         }
00902
00903         if (BitsPerPixel(d3d10ext->dxgiFormat) == 0)
00904         {
00905             throw ref new Platform::FailureException();
00906         }
00907
00908         format = d3d10ext->dxgiFormat;
00909
00910         switch (d3d10ext->resourceDimension)
00911         {
00912         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00913             // D3DX writes 1D textures with a fixed Height of 1
00914             if ((header->flags & DDS_HEIGHT) && height != 1)
00915             {
00916                 throw ref new Platform::FailureException();
00917             }
00918             height = depth = 1;
00919             break;
00920
00921         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
00922             if (d3d10ext->miscFlag & D3D11_RESOURCE_MISC_TEXTURECUBE)
00923             {
00924                 arraySize *= 6;
00925                 isCubeMap = true;
00926             }
00927             depth = 1;
00928             break;
00929
00930         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
00931             if (!(header->flags & DDS_HEADER_FLAGS_VOLUME))
00932             {
00933                 throw ref new Platform::FailureException();
00934             }
00935
00936             if (arraySize > 1)
00937             {
00938                 throw ref new Platform::FailureException();
00939             }
00940             break;
00941
00942         default:
00943             return throw ref new Platform::FailureException();
00944         }
00945
00946         resDim = d3d10ext->resourceDimension;
00947     }
00948     else
00949     {
00950         format = GetDXGIFormat(header->ddspf);
00951
00952         if (format == DXGI_FORMAT_UNKNOWN)
00953         {
00954             return throw ref new Platform::FailureException();
00955         }
00956
00957         if (header->flags & DDS_HEADER_FLAGS_VOLUME)
00958         {
00959             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE3D;
00960         }
00961         else
00962         {
00963             if (header->caps2 & DDS_CUBEMAP)
00964             {
00965                 // We require all six faces to be defined
00966                 if ((header->caps2 & DDS_CUBEMAP_ALLFACES) != DDS_CUBEMAP_ALLFACES)
00967                 {
00968                     return throw ref new Platform::FailureException();
00969                 }
00970
00971                 arraySize = 6;
00972                 isCubeMap = true;
00973             }
00974
00975             depth = 1;
00976             resDim = D3D11_RESOURCE_DIMENSION_TEXTURE2D;
00977
00978             // Note there's no way for a legacy Direct3D 9 DDS to express a '1D' texture
00979         }
00980
00981         assert(BitsPerPixel(format) != 0);
00982     }
00983
00984     // Bound sizes (for security purposes we don't trust DDS file metadata larger than the D3D 11.x hardware requirements)
00985     if (mipCount > D3D11_REQ_MIP_LEVELS)
00986     {
00987         return throw ref new Platform::FailureException();
00988     }
00989
00990     switch (resDim)
00991     {
00992         case D3D11_RESOURCE_DIMENSION_TEXTURE1D:
00993             if ((arraySize > D3D11_REQ_TEXTURE1D_ARRAY_AXIS_DIMENSION) ||
00994                 (width > D3D11_REQ_TEXTURE1D_U_DIMENSION))
00995             {
00996                 return throw ref new Platform::FailureException();
00997             }
00998             break;
00999
01000         case D3D11_RESOURCE_DIMENSION_TEXTURE2D:
01001             if (isCubeMap)
01002             {
01003                 // This is the right bound because we set arraySize to (NumCubes*6) above
01004                 if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01005                     (width > D3D11_REQ_TEXTURECUBE_DIMENSION) ||
01006                     (height > D3D11_REQ_TEXTURECUBE_DIMENSION))
01007                 {
01008                     return throw ref new Platform::FailureException();
01009                 }
01010             }
01011             else if ((arraySize > D3D11_REQ_TEXTURE2D_ARRAY_AXIS_DIMENSION) ||
01012                     (width > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION) ||
01013                     (height > D3D11_REQ_TEXTURE2D_U_OR_V_DIMENSION))
01014             {
01015                 return throw ref new Platform::FailureException();
01016             }
01017             break;
01018
01019         case D3D11_RESOURCE_DIMENSION_TEXTURE3D:
01020             if ((arraySize > 1) ||
01021                 (width > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01022                 (height > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION) ||
01023                 (depth > D3D11_REQ_TEXTURE3D_U_V_OR_W_DIMENSION))
01024             {
01025                 return throw ref new Platform::FailureException();
01026             }
01027             break;
01028     }
01029
01030     // Create the texture
01031     std::unique_ptr<D3D11_SUBRESOURCE_DATA> initData(new D3D11_SUBRESOURCE_DATA[mipCount * arraySize]);
01032
01033     size_t skipMip = 0;
01034     size_t twidth = 0;
01035     size_t theight = 0;
01036     size_t tdepth = 0;
01037     FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01038
01039     hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01040
01041     if (FAILED(hr) && !maxsize && (mipCount > 1))
01042     {
01043         // Retry with a maxsize determined by feature level
01044         switch (d3dDevice->GetFeatureLevel())
01045         {
01046         case D3D_FEATURE_LEVEL_9_1:
01047         case D3D_FEATURE_LEVEL_9_2:
01048             if (isCubeMap)
01049             {
01050                 maxsize = D3D_FL9_1_REQ_TEXTURECUBE_DIMENSION;
01051             }
01052             else
01053             {
01054                 maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01055                     ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01056                     : D3D_FL9_1_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01057             }
01058             break;
01059
01060         case D3D_FEATURE_LEVEL_9_3:
01061             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01062                 ? D3D_FL9_1_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01063                 : D3D_FL9_3_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01064             break;
01065
01066         default: // D3D_FEATURE_LEVEL_10_0 & D3D_FEATURE_LEVEL_10_1
01067             maxsize = (resDim == D3D11_RESOURCE_DIMENSION_TEXTURE3D)
01068                 ? D3D10_REQ_TEXTURE3D_U_V_OR_W_DIMENSION
01069                 : D3D10_REQ_TEXTURE2D_U_OR_V_DIMENSION;
01070             break;
01071         }
01072
01073         FillInitData(width, height, depth, mipCount, arraySize, format, maxsize, bitSize, bitData, twidth, theight, tdepth, skipMip, initData.get());
01074
01075         hr = CreateD3DResources(d3dDevice, resDim, twidth, theight, tdepth, mipCount - skipMip, arraySize, format, isCubeMap, initData.get(), texture, textureView);
01076     }
01077
01078     DX::ThrowIfFailed(hr);
01079 }
01080
01081 //--------------------------------------------------------------------------------------
01082 void CreateDDSTextureFromMemory(
01083     _In_ ID3D11Device* d3dDevice,
01084     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
01085     _In_ size_t ddsDataSize,
01086     _Out_opt_ ID3D11Resource** texture,
01087     _Out_opt_ ID3D11ShaderResourceView** textureView,
01088     _In_ size_t maxsize
01089     )
01090 {
01091     if (!d3dDevice || !ddsData || (!texture && !textureView))
01092     {
01093         throw ref new Platform::InvalidArgumentException();
01094     }
01095
01096     // Validate DDS file in memory
01097     if (ddsDataSize < (sizeof(uint32) + sizeof(DDS_HEADER)))
01098     {
01099         throw ref new Platform::FailureException();
01100     }
01101
01102     uint32 dwMagicNumber = *(const uint32*)(ddsData);
01103     if (dwMagicNumber != DDS_MAGIC)
01104     {
01105         throw ref new Platform::FailureException();
01106     }
01107
01108     const DDS_HEADER* header = reinterpret_cast<const DDS_HEADER*>(ddsData + sizeof(uint32));
01109
01110     // Verify header to validate DDS file
01111     if (header->size != sizeof(DDS_HEADER) ||
01112         header->ddspf.size != sizeof(DDS_PIXELFORMAT))
01113     {
01114         throw ref new Platform::FailureException();
01115     }
01116
01117     // Check for DX10 extension
01118     bool bDXT10Header = false;
01119     if ((header->ddspf.flags & DDS_FOURCC) &&
01120         (MAKEFOURCC('D', 'X', '1', '0') == header->ddspf.fourCC))
01121     {
01122         // Must be long enough for both headers and magic value
01123         if (ddsDataSize < (sizeof(DDS_HEADER) + sizeof(uint32) + sizeof(DDS_HEADER_DXT10)))
01124         {
01125             throw ref new Platform::FailureException();
01126         }
01127
01128         bDXT10Header = true;
01129     }
01130
01131     ptrdiff_t offset = sizeof(uint32) + sizeof(DDS_HEADER) + (bDXT10Header ? sizeof(DDS_HEADER_DXT10) : 0);
01132
01133     CreateTextureFromDDS(d3dDevice, header, ddsData + offset, ddsDataSize - offset, texture, textureView, maxsize);
01134 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/pch.h Source File

  • XAML data binding

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Constants.h"
00021 #include "S2Formatter.h"
00022 #include "Employee.h"
00023 #include "Team.h"
00024 #include "IncrementalLoadingBase.h"
00025 #include "GeneratorIncrementalLoadingClass.h"
00026 #include "Common\LayoutAwarePage.h"
00027 #include "Common\SuspensionManager.h"
00028 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/App.xaml.h Source File

  • Trial app and in-app purchase

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Polar/PolarEffect.h Source File

  • Media extensions
  • MediaExtensions
  • Polar

PolarEffect.h

Go to the documentation of this file.
00001 // Defines the transform class.
00002 //
00003 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00004 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00005 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00006 // PARTICULAR PURPOSE.
00007 //
00008 // Copyright (c) Microsoft Corporation. All rights reserved.
00009
00010 #ifndef POLAREFFECT_H
00011 #define POLAREFFECT_H
00012
00013 #include <new>
00014 #include <mfapi.h>
00015 #include <mftransform.h>
00016 #include <mfidl.h>
00017 #include <mferror.h>
00018 #include <strsafe.h>
00019 #include <assert.h>
00020 #include <math.h>
00021
00022 // Note: The Direct2D helper library is included for its 2D matrix operations.
00023 #include <D2d1helper.h>
00024
00025 #include <wrl\implements.h>
00026 #include <wrl\module.h>
00027 #include <windows.media.h>
00028 #include <wrl\wrappers\corewrappers.h>
00029
00030 #include "PolarTransform.h"
00031
00032 using namespace Microsoft::WRL;
00033 using namespace Microsoft::WRL::Wrappers;
00034
00035 void DllAddRef();
00036 void DllRelease();
00037
00038 template <class T> void SafeRelease(T **ppT)
00039 {
00040     if (*ppT)
00041     {
00042         (*ppT)->Release();
00043         *ppT = NULL;
00044     }
00045 }
00046
00047 template <class T> void SafeArrayDelete(T **ppT)
00048 {
00049     if (*ppT)
00050     {
00051         delete [] (*ppT);
00052         *ppT = NULL;
00053     }
00054 }
00055
00056
00057 // Function pointer for the function that transforms the image.
00058 typedef void (*IMAGE_TRANSFORM_FN)(
00059     const UINT32*           pLookup,         // Lookup buffer.
00060     BYTE*                   pDest,           // Destination buffer.
00061     LONG                    lDestStride,     // Destination stride.
00062     const BYTE*             pSrc,            // Source buffer.
00063     LONG                    lSrcStride,      // Source stride.
00064     DWORD                   dwWidthInPixels, // Image width in pixels.
00065     DWORD                   dwHeightInPixels // Image height in pixels.
00066     );
00067
00068 typedef DOUBLE (*PolarTransformer)(DOUBLE, DOUBLE, DOUBLE);
00069
00070
00071 // CPolarEffect class:
00072 // Implements a polar transformation video effect.
00073
00074 class CPolarEffect
00075     : public Microsoft::WRL::RuntimeClass<
00076            Microsoft::WRL::RuntimeClassFlags< Microsoft::WRL::RuntimeClassType::WinRtClassicComMix >,
00077            ABI::Windows::Media::IMediaExtension,
00078            IMFTransform >
00079 {
00080     InspectableClass(RuntimeClass_PolarTransform_PolarEffect,BaseTrust)
00081
00082 public:
00083     CPolarEffect();
00084
00085     ~CPolarEffect();
00086
00087     __forceinline static DOUBLE DefaultRadius(DOUBLE r, DOUBLE R, DOUBLE theta) { return r; }
00088     __forceinline static DOUBLE DefaultTheta(DOUBLE r, DOUBLE R, DOUBLE theta) { return theta; };
00089
00090     __forceinline static DOUBLE PinchRadius(DOUBLE r, DOUBLE R, DOUBLE theta) { return sqrt(r*R); };
00091     __forceinline static DOUBLE FisheyeRadius(DOUBLE r, DOUBLE R, DOUBLE theta) { return (r*r)/R; };
00092     __forceinline static DOUBLE WarpTheta(DOUBLE r, DOUBLE R, DOUBLE theta) { return theta + r / R; };
00093
00094     STDMETHOD(RuntimeClassInitialize)();
00095
00096     // IMediaExtension
00097     STDMETHODIMP SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration);
00098
00099     // IMFTransform
00100     STDMETHODIMP GetStreamLimits(
00101         DWORD   *pdwInputMinimum,
00102         DWORD   *pdwInputMaximum,
00103         DWORD   *pdwOutputMinimum,
00104         DWORD   *pdwOutputMaximum
00105     );
00106
00107     STDMETHODIMP GetStreamCount(
00108         DWORD   *pcInputStreams,
00109         DWORD   *pcOutputStreams
00110     );
00111
00112     STDMETHODIMP GetStreamIDs(
00113         DWORD   dwInputIDArraySize,
00114         DWORD   *pdwInputIDs,
00115         DWORD   dwOutputIDArraySize,
00116         DWORD   *pdwOutputIDs
00117     );
00118
00119     STDMETHODIMP GetInputStreamInfo(
00120         DWORD                     dwInputStreamID,
00121         MFT_INPUT_STREAM_INFO *   pStreamInfo
00122     );
00123
00124     STDMETHODIMP GetOutputStreamInfo(
00125         DWORD                     dwOutputStreamID,
00126         MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00127     );
00128
00129     STDMETHODIMP GetAttributes(IMFAttributes** pAttributes);
00130
00131     STDMETHODIMP GetInputStreamAttributes(
00132         DWORD           dwInputStreamID,
00133         IMFAttributes   **ppAttributes
00134     );
00135
00136     STDMETHODIMP GetOutputStreamAttributes(
00137         DWORD           dwOutputStreamID,
00138         IMFAttributes   **ppAttributes
00139     );
00140
00141     STDMETHODIMP DeleteInputStream(DWORD dwStreamID);
00142
00143     STDMETHODIMP AddInputStreams(
00144         DWORD   cStreams,
00145         DWORD   *adwStreamIDs
00146     );
00147
00148     STDMETHODIMP GetInputAvailableType(
00149         DWORD           dwInputStreamID,
00150         DWORD           dwTypeIndex, // 0-based
00151         IMFMediaType    **ppType
00152     );
00153
00154     STDMETHODIMP GetOutputAvailableType(
00155         DWORD           dwOutputStreamID,
00156         DWORD           dwTypeIndex, // 0-based
00157         IMFMediaType    **ppType
00158     );
00159
00160     STDMETHODIMP SetInputType(
00161         DWORD           dwInputStreamID,
00162         IMFMediaType    *pType,
00163         DWORD           dwFlags
00164     );
00165
00166     STDMETHODIMP SetOutputType(
00167         DWORD           dwOutputStreamID,
00168         IMFMediaType    *pType,
00169         DWORD           dwFlags
00170     );
00171
00172     STDMETHODIMP GetInputCurrentType(
00173         DWORD           dwInputStreamID,
00174         IMFMediaType    **ppType
00175     );
00176
00177     STDMETHODIMP GetOutputCurrentType(
00178         DWORD           dwOutputStreamID,
00179         IMFMediaType    **ppType
00180     );
00181
00182     STDMETHODIMP GetInputStatus(
00183         DWORD           dwInputStreamID,
00184         DWORD           *pdwFlags
00185     );
00186
00187     STDMETHODIMP GetOutputStatus(DWORD *pdwFlags);
00188
00189     STDMETHODIMP SetOutputBounds(
00190         LONGLONG        hnsLowerBound,
00191         LONGLONG        hnsUpperBound
00192     );
00193
00194     STDMETHODIMP ProcessEvent(
00195         DWORD              dwInputStreamID,
00196         IMFMediaEvent      *pEvent
00197     );
00198
00199     STDMETHODIMP ProcessMessage(
00200         MFT_MESSAGE_TYPE    eMessage,
00201         ULONG_PTR           ulParam
00202     );
00203
00204     STDMETHODIMP ProcessInput(
00205         DWORD               dwInputStreamID,
00206         IMFSample           *pSample,
00207         DWORD               dwFlags
00208     );
00209
00210     STDMETHODIMP ProcessOutput(
00211         DWORD                   dwFlags,
00212         DWORD                   cOutputBufferCount,
00213         MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
00214         DWORD                   *pdwStatus
00215     );
00216
00217
00218 private:
00219     // HasPendingOutput: Returns TRUE if the MFT is holding an input sample.
00220     BOOL HasPendingOutput() const { return m_pSample != NULL; }
00221
00222     // IsValidInputStream: Returns TRUE if dwInputStreamID is a valid input stream identifier.
00223     BOOL IsValidInputStream(DWORD dwInputStreamID) const
00224     {
00225         return dwInputStreamID == 0;
00226     }
00227
00228     // IsValidOutputStream: Returns TRUE if dwOutputStreamID is a valid output stream identifier.
00229     BOOL IsValidOutputStream(DWORD dwOutputStreamID) const
00230     {
00231         return dwOutputStreamID == 0;
00232     }
00233
00234     HRESULT OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt);
00235     HRESULT OnCheckInputType(IMFMediaType *pmt);
00236     HRESULT OnCheckOutputType(IMFMediaType *pmt);
00237     HRESULT OnCheckMediaType(IMFMediaType *pmt);
00238     void    OnSetInputType(IMFMediaType *pmt);
00239     void    OnSetOutputType(IMFMediaType *pmt);
00240     HRESULT BeginStreaming();
00241     HRESULT EndStreaming();
00242     HRESULT OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut);
00243     HRESULT OnFlush();
00244     HRESULT UpdateFormatInfo();
00245     void GeneratePolarLookup( UINT32 unWidth,
00246                                    UINT32 unHeight,
00247                                    UINT32 *pIndexLookup );
00248
00249
00250     CRITICAL_SECTION            m_critSec;
00251
00252     // Streaming
00253     bool                        m_bStreamingInitialized;
00254     IMFSample                   *m_pSample;                 // Input sample.
00255     IMFMediaType                *m_pInputType;              // Input media type.
00256     IMFMediaType                *m_pOutputType;             // Output media type.
00257
00258     // Fomat information
00259     UINT32                      m_imageWidthInPixels;
00260     UINT32                      m_imageHeightInPixels;
00261     DWORD                       m_cbImageSize;              // Image size, in bytes.
00262
00263     IMFAttributes               *m_pAttributes;
00264
00265     // Image transform function. (Changes based on the media type.)
00266     IMAGE_TRANSFORM_FN          m_pTransformFn;
00267
00268     // Lookup table to store the result of polar transformation
00269     UINT32                      *m_pIndexLookup;
00270
00271     // Polar transform function for specific effect
00272     PolarTransformer            m_pRadiusTransformFn;       // Radius transformation
00273     PolarTransformer            m_pThetaTransformFn;        // Angle transformation
00274 };
00275
00276 #endif
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/pch.h Source File

  • File picker contracts

pch.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/MainPage_CachedFile.xaml.h Source File

  • File picker contracts

MainPage_CachedFile.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage_CachedFile.xaml.h
00013 // Declaration of the MainPage_CachedFile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage_CachedFile.g.h"
00020
00021 namespace SDKSample
00022 {
00023     namespace FilePickerContracts
00024     {
00025         /// <summary>
00026         /// An empty page that can be used on its own or navigated to within a Frame.
00027         /// </summary>
00028         public ref class MainPage_CachedFile sealed
00029         {
00030         public:
00031             MainPage_CachedFile();
00032         };
00033     }
00034 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Portable device API/C++/S4_GetFromDevice.xaml.cpp Source File

  • Portable device API

S4_GetFromDevice.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // S4_GetFromDevice.xaml.cpp
00013 // Implementation of the S4_GetFromDevice class
00014 //
00015
00016 #include "pch.h"
00017 #include "S4_GetFromDevice.xaml.h"
00018
00019 using namespace SDKSample::PortableDeviceCPP;
00020
00021 using namespace concurrency;
00022 using namespace Microsoft::WRL;
00023 using namespace Platform;
00024 using namespace Platform::Collections;
00025 using namespace Windows::Devices::Enumeration;
00026 using namespace Windows::Storage;
00027 using namespace Windows::Storage::Streams;
00028 using namespace Windows::UI::Xaml;
00029 using namespace Windows::UI::Xaml::Controls;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 S4_GetFromDevice::S4_GetFromDevice() : rootPage(MainPage::Current)
00033 {
00034     InitializeComponent();
00035 }
00036
00037 /// <summary>
00038 /// Invoked when this page is about to be displayed in a Frame.
00039 /// </summary>
00040 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00041 /// property is typically used to configure the page.</param>
00042 void S4_GetFromDevice::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00045 }
00046
00047 /// <summary>
00048 /// This is the click handler for the 'Run' button.
00049 /// </summary>
00050 /// <param name="sender"></param>
00051 /// <param name="e"></param>
00052 void S4_GetFromDevice::Run_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00053 {
00054     ShowDeviceSelectorAsync();
00055 }
00056
00057 /// <summary>
00058 /// Enumerates all portable devices and populates the device selection list.
00059 /// </summary>
00060 void S4_GetFromDevice::ShowDeviceSelectorAsync()
00061 {
00062     _deviceInfoCollection = nullptr;
00063
00064     // Find all portable devices
00065     String^ aqsFilter = "System.Devices.InterfaceClassGuid:=\"{6AC27878-A6FA-4155-BA85-F98F491D4F33}\" AND System.Devices.InterfaceEnabled:=System.StructuredQueryType.Boolean#True";
00066     create_task(DeviceInformation::FindAllAsync(aqsFilter)).then([this] (DeviceInformationCollection^ deviceInfoCollection)
00067     {
00068         _deviceInfoCollection = deviceInfoCollection;
00069         if (_deviceInfoCollection->Size > 0)
00070         {
00071             auto items = ref new Vector<String^>();
00072             std::for_each(begin(_deviceInfoCollection), end(_deviceInfoCollection), [items](IDeviceInformation^ deviceInfoElement)
00073             {
00074                 items->Append(ref new String(deviceInfoElement->Name->Begin()));
00075             });
00076             cvs->Source = items;
00077             DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Visible;
00078         }
00079         else
00080         {
00081             rootPage->NotifyUser("No portable devices were found. Please attach a portable device to the system (e.g. a camera, music player, or cellular phone)", NotifyType::ErrorMessage);
00082         }
00083     });
00084 }
00085
00086 /// <summary>
00087 /// This is the tapped handler for the device selection list. It runs the scenario
00088 /// for the selected portable device.
00089 /// </summary>
00090 /// <param name="sender"></param>
00091 /// <param name="e"></param>
00092 void S4_GetFromDevice::DeviceList_Tapped(Platform::Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e)
00093 {
00094     DeviceSelector->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00095     if (_deviceInfoCollection == nullptr)
00096     {
00097         return; // not yet populated
00098     }
00099
00100     auto deviceInfo = _deviceInfoCollection->GetAt(DeviceList->SelectedIndex);
00101     GetContentFromDeviceAsync(deviceInfo);
00102 }
00103
00104 /// <summary>
00105 /// Transfers content from the selected portable device.
00106 /// </summary>
00107 /// <param name="deviceInfoElement">Contains information about a selected device.</param>
00108 void S4_GetFromDevice::GetContentFromDeviceAsync(DeviceInformation^ deviceInfoElement)
00109 {
00110     ComPtr<IPortableDevice> device;
00111     ThrowIfFailed(CoCreateInstance(CLSID_PortableDeviceFTM, nullptr, CLSCTX_INPROC_SERVER, IID_PPV_ARGS(&device)));
00112
00113     auto clientInfo = GetClientInfo();
00114     HRESULT hr = device->Open(deviceInfoElement->Id->Begin(), clientInfo.Get());
00115     if (hr == E_ACCESSDENIED)
00116     {
00117         rootPage->NotifyUser("Access to " + deviceInfoElement->Name + " is denied. Only a Privileged Application may access this device.", NotifyType::ErrorMessage);
00118         return;
00119     }
00120     ThrowIfFailed(hr);
00121
00122     // Perform the find and transfer asynchronously
00123     create_task([this, device, deviceInfoElement]() -> void
00124     {
00125         FindAndTransferFirstImageFileFromDevice(device.Get());
00126     }).then([this, deviceInfoElement] (task<void> thisTask)
00127     {
00128         // Handle errors. We're catching all exceptions here because the device may return any failure HRESULT.
00129         try
00130         {
00131             thisTask.get();
00132         }
00133         catch (Exception^ e)
00134         {
00135             // Call NotifyUser from the UI thread
00136             rootPage->DispatcherNotifyUser("Transfer from " + deviceInfoElement->Name + " failed with error: " + e->Message, NotifyType::ErrorMessage);
00137         }
00138     });
00139 }
00140
00141 /// <summary>
00142 /// Finds and transfers the first image file from the selected portable device.
00143 /// This can process many objects and is strongly recommended to be run asynchronously
00144 /// to avoid blocking the UI thread. GetContentFromDeviceAsync demonstrates how to wrap
00145 /// this function in a task and handle errors.
00146 /// </summary>
00147 /// <param name="device">Pointer to the IPortableDevice for a portable device.</param>
00148 /// <see cref="GetContentFromDeviceAsync"/>
00149 void S4_GetFromDevice::FindAndTransferFirstImageFileFromDevice(_In_ IPortableDevice* device)
00150 {
00151     ComPtr<IPortableDeviceContent> content;
00152     ComPtr<IPortableDeviceProperties> properties;
00153
00154     ThrowIfFailed(device->Content(&content));
00155     ThrowIfFailed(content->Properties(&properties));
00156
00157     // Traverse the first level under storage and look for images
00158     auto storageId = GetFirstStorageId(device);
00159     if (storageId != nullptr)
00160     {
00161         ComPtr<IEnumPortableDeviceObjectIDs> enumObjectIDs;
00162         ThrowIfFailed(content->EnumObjects(0, storageId->Begin(), nullptr, &enumObjectIDs));
00163
00164         bool found = false;
00165         HRESULT hrEnum = S_OK;
00166         while(hrEnum == S_OK && !found)
00167         {
00168             DWORD numFetched = 0;
00169             PWSTR objectIDArray[NUM_OBJECTS_TO_REQUEST] = {};
00170             CoTaskMemFreeArray arrayPtr(reinterpret_cast<void **>(objectIDArray), ARRAYSIZE(objectIDArray));
00171
00172             hrEnum = enumObjectIDs->Next(NUM_OBJECTS_TO_REQUEST, // Number of objects to request on each NEXT call
00173                                          objectIDArray,          // Array of PWSTR array which will be populated on each NEXT call
00174                                          &numFetched);           // Number of objects written to the PWSTR array
00175             ThrowIfFailed(hrEnum);
00176
00177             for (DWORD index = 0; !found && (index < numFetched) && (objectIDArray[index] != nullptr); index++)
00178             {
00179                 GUID contentType;
00180                 ComPtr<IPortableDeviceValues> objectProperties;
00181                 rootPage->DispatcherNotifyUser(ref new String(objectIDArray[index]), NotifyType::StatusMessage);
00182
00183                 ThrowIfFailed(properties->GetValues(objectIDArray[index], nullptr, &objectProperties));
00184
00185                 if (SUCCEEDED(objectProperties->GetGuidValue(WPD_OBJECT_CONTENT_TYPE, &contentType)) && (contentType == WPD_CONTENT_TYPE_IMAGE))
00186                 {
00187                     PWSTR sourceFilename = nullptr;
00188                     HRESULT hr = objectProperties->GetStringValue(WPD_OBJECT_ORIGINAL_FILE_NAME, &sourceFilename);
00189                     CoTaskMemString sourceFilenamePtr(sourceFilename);
00190                     ThrowIfFailed(hr);
00191
00192                     String^ objectToTransfer = ref new String(objectIDArray[index]);
00193                     String^ desiredFilename = ref new String(sourceFilename);
00194                     TransferFileFromDeviceToAppLocalFolderAsync(device, objectToTransfer, desiredFilename);
00195                     found = true;
00196                 }
00197             }
00198         }
00199
00200         if (!found)
00201         {
00202             rootPage->DispatcherNotifyUser("No images were found. Please run scenario 3 first to transfer an image to the device.", NotifyType::ErrorMessage);
00203         }
00204     }
00205     else
00206     {
00207         rootPage->DispatcherNotifyUser("No storages were found on the device. Please attach a device with at least 1 storage.", NotifyType::ErrorMessage);
00208     }
00209 }
00210
00211 /// <summary>
00212 /// Transfers a file from a portable device to the application local folder.
00213 /// </summary>
00214 /// <param name="device">Pointer to the IPortableDevice for a portable device.</param>
00215 /// <param name="sourceObjectId">Pointer to the IPortableDevice for a portable device.</param>
00216 /// <param name="desiredFilename">Pointer to the IPortableDevice for a portable device.</param>
00217 void S4_GetFromDevice::TransferFileFromDeviceToAppLocalFolderAsync(_In_ IPortableDevice* device, String^ sourceObjectId, String^ desiredFilename)
00218 {
00219     // Ensures the lifetime of the device extends through the lambdas
00220     ComPtr<IPortableDevice> deviceRef = device;
00221
00222     // Allows the StorageFile to be shared between task continuations
00223     auto newFileRef = std::make_shared<StorageFile^>(nullptr);
00224
00225     task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(desiredFilename, CreationCollisionOption::GenerateUniqueName));
00226     createFileTask.then([this, newFileRef] (StorageFile^ newFile)
00227     {
00228         *newFileRef = newFile; // assign for use later in the continuation
00229         rootPage->DispatcherNotifyUser("Created new file '" + newFile->Path + "', transfer data ....", NotifyType::StatusMessage);
00230         return newFile->OpenAsync(FileAccessMode::ReadWrite);
00231
00232     }).then([this, deviceRef, sourceObjectId, newFileRef] (IRandomAccessStream^ randomAccessStream)
00233     {
00234         ComPtr<IPortableDeviceContent> content;
00235         ComPtr<IPortableDeviceResources> resources;
00236
00237         ThrowIfFailed(deviceRef->Content(&content));
00238         ThrowIfFailed(content->Transfer(&resources));
00239
00240         // Get the object's size
00241         ComPtr<IPortableDeviceValues> resourceAttributes;
00242         ULONGLONG resourceSizeBytes = 0;
00243         ThrowIfFailed(resources->GetResourceAttributes(sourceObjectId->Begin(), WPD_RESOURCE_DEFAULT, &resourceAttributes));
00244         ThrowIfFailed(resourceAttributes->GetUnsignedLargeIntegerValue(WPD_RESOURCE_ATTRIBUTE_TOTAL_SIZE, &resourceSizeBytes));
00245
00246         // Get the object's data
00247         ComPtr<IStream> sourceStream, destStream;
00248         DWORD optimalTransferSizeBytes = 0;
00249         ThrowIfFailed(resources->GetStream(sourceObjectId->Begin(), // Identifier of the object we want to transfer
00250                                 WPD_RESOURCE_DEFAULT,               // We are transferring the default resource (which is the entire object's data)
00251                                 STGM_READ,                          // Opening a stream in READ mode, because we are reading data from the device.
00252                                 &optimalTransferSizeBytes,          // Optimal transfer size
00253                                 &sourceStream));                    // IStream containing the object data
00254
00255         // Transfer the object's data to to the file stream
00256         ThrowIfFailed(CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(&destStream)));
00257
00258         ULONGLONG totalTransferredBytes = StreamCopy(destStream.Get(), sourceStream.Get(), optimalTransferSizeBytes);
00259         if (totalTransferredBytes == resourceSizeBytes)
00260         {
00261             // Flush the destination stream to commit the data
00262             task<bool> flushTask(randomAccessStream->FlushAsync());
00263             flushTask.then([this, sourceObjectId, newFileRef, totalTransferredBytes] (bool result)
00264             {
00265                 rootPage->DispatcherNotifyUser("Transfer of '" + sourceObjectId + "' ("
00266                     + totalTransferredBytes.ToString() + " bytes) from device to '" + (*newFileRef)->Path
00267                     + "' " + (result ? "is successful" : "failed"), NotifyType::StatusMessage);
00268             });
00269         }
00270         else
00271         {
00272             rootPage->DispatcherNotifyUser("The object '" + sourceObjectId + "' was not completely transferred from the device (only "
00273                 + totalTransferredBytes.ToString() + " bytes were transferred).", NotifyType::ErrorMessage);
00274         }
00275     });
00276 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/MainPage.xaml.h Source File

  • Application resources and localization

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::HttpClientSample::sealed Member List

This is the complete list of members for SDKSample::HttpClientSample::sealed, including all inherited members.
Cancel_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Cancel_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Cancel_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Cancel_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Cancel_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
cancellationTokenSource | SDKSample::HttpClientSample::sealed | [private]
DisplayTextResult(const std::wstring &response, Windows::UI::Xaml::Controls::TextBox^output) | SDKSample::HttpClientSample::sealed | [private]
DisplayTextResult(const std::wstring &response, Windows::UI::Xaml::Controls::TextBox^output) | SDKSample::HttpClientSample::sealed | [private]
DisplayTextResult(const std::wstring &response, Windows::UI::Xaml::Controls::TextBox^output) | SDKSample::HttpClientSample::sealed | [private]
DisplayTextResult(const std::wstring &response, Windows::UI::Xaml::Controls::TextBox^output) | SDKSample::HttpClientSample::sealed | [private]
GenerateSampleStream(unsigned int size) | SDKSample::HttpClientSample::sealed | [private]
httpRequest | SDKSample::HttpClientSample::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HttpClientSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HttpClientSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HttpClientSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HttpClientSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::HttpClientSample::sealed | [protected, virtual]
readBuffer | SDKSample::HttpClientSample::sealed | [private]
rootPage | SDKSample::HttpClientSample::sealed | [private]
Scenario1() | SDKSample::HttpClientSample::sealed |
Scenario2() | SDKSample::HttpClientSample::sealed |
Scenario2ReadData() | SDKSample::HttpClientSample::sealed | [private]
Scenario3() | SDKSample::HttpClientSample::sealed |
Scenario4() | SDKSample::HttpClientSample::sealed |
Scenario5() | SDKSample::HttpClientSample::sealed |
Start_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Start_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Start_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Start_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Start_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::HttpClientSample::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Thread pool/C++/Constants.cpp Source File

  • Thread pool

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014 #include "DelayTimerScenario.xaml.h"
00015
00016 using namespace SDKSample;
00017 using namespace SDKSample::ThreadPool;
00018
00019 int DelayTimerMilliseconds = 0;
00020 Platform::String^ DelayTimerInfo = "";
00021 Status DelayTimerStatus = SDKSample::ThreadPool::Status::Unregistered;
00022 int DelayTimerSelectedIndex = 0;
00023
00024 int PeriodicTimerCount = 0;
00025 int PeriodicTimerMilliseconds = 0;
00026 Platform::String^ PeriodicTimerInfo = "";
00027 Status PeriodicTimerStatus = SDKSample::ThreadPool::Status::Unregistered;
00028 int PeriodicTimerSelectedIndex = 0;
00029
00030 Status WorkItemStatus = SDKSample::ThreadPool::Status::Unregistered;
00031 Platform::String^ WorkItemInfo = "";
00032 Windows::System::Threading::WorkItemPriority WorkPriority = Windows::System::Threading::WorkItemPriority::Normal;
00033 int WorkItemSelectedIndex = 1;
00034
00035 Platform::String^ ThreadPoolSample::GetStatusString(SDKSample::ThreadPool::Status status)
00036 {
00037     switch (status)
00038     {
00039     case SDKSample::ThreadPool::Status::Unregistered:
00040         return "Unregistered";
00041         break;
00042     case SDKSample::ThreadPool::Status::Started:
00043         return "Started";
00044         break;
00045     case SDKSample::ThreadPool::Status::Canceled:
00046         return "Canceled";
00047         break;
00048     case SDKSample::ThreadPool::Status::Completed:
00049         return "Completed";
00050         break;
00051     default:
00052         return "Error";
00053         break;
00054     }
00055 }
00056
00057 Windows::Foundation::TimeSpan ThreadPoolSample::MillisecondsToTimeSpan(long milliseconds)
00058 {
00059     Windows::Foundation::TimeSpan time;
00060     time.Duration = milliseconds * 10000;
00061     return time;
00062 }
00063
00064 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00065 {
00066     // The format here is the following:
00067     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00068     { "Thread pool delay timer", "SDKSample.ThreadPool.DelayTimerScenario" },
00069     { "Thread pool periodic timer", "SDKSample.ThreadPool.PeriodicTimerScenario" },
00070     { "Thread pool work item", "SDKSample.ThreadPool.WorkItemScenario" }
00071 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/DirectXApp.cpp Source File

  • XAudio2 audio file playback

DirectXApp.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXApp.h"
00010 #include "BasicTimer.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Graphics::Display;
00019
00020 DirectXApp::DirectXApp() :
00021     m_windowClosed(false),
00022     m_windowVisible(true)
00023 {
00024 }
00025
00026 void DirectXApp::Initialize(
00027     _In_ CoreApplicationView^ applicationView
00028     )
00029 {
00030     applicationView->Activated +=
00031         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DirectXApp::OnActivated);
00032
00033     CoreApplication::Suspending +=
00034         ref new EventHandler<SuspendingEventArgs^>(this, &DirectXApp::OnSuspending);
00035
00036     CoreApplication::Resuming +=
00037         ref new EventHandler<Platform::Object^>(this, &DirectXApp::OnResuming);
00038
00039     m_renderer = ref new BasicSound();
00040 }
00041
00042 void DirectXApp::SetWindow(
00043     _In_ CoreWindow^ window
00044     )
00045 {
00046     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00047
00048     window->SizeChanged +=
00049         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DirectXApp::OnWindowSizeChanged);
00050
00051     window->VisibilityChanged +=
00052         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &DirectXApp::OnVisibilityChanged);
00053
00054     window->Closed +=
00055         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &DirectXApp::OnWindowClosed);
00056
00057     DisplayProperties::LogicalDpiChanged +=
00058         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnLogicalDpiChanged);
00059
00060     window->PointerPressed +=
00061         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &DirectXApp::OnPointerPressed);
00062
00063
00064     m_renderer->Initialize(window, DisplayProperties::LogicalDpi);
00065 }
00066
00067 void DirectXApp::Load(
00068     _In_ Platform::String^ entryPoint
00069     )
00070 {
00071 }
00072
00073 void DirectXApp::Run()
00074 {
00075     BasicTimer^ timer = ref new BasicTimer();
00076
00077     while (!m_windowClosed)
00078     {
00079         if (m_windowVisible)
00080         {
00081             timer->Update();
00082             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00083             m_renderer->Render();
00084             m_renderer->Present(); // This call is synchronized to the display frame rate.
00085         }
00086         else
00087         {
00088             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00089         }
00090     }
00091 }
00092
00093 void DirectXApp::Uninitialize()
00094 {
00095 }
00096
00097 void DirectXApp::OnWindowSizeChanged(
00098     _In_ CoreWindow^ sender,
00099     _In_ WindowSizeChangedEventArgs^ args
00100     )
00101 {
00102     m_renderer->UpdateForWindowSizeChange();
00103 }
00104
00105 void DirectXApp::OnVisibilityChanged(
00106     _In_ CoreWindow^ sender,
00107     _In_ VisibilityChangedEventArgs^ args
00108     )
00109 {
00110     m_windowVisible = args->Visible;
00111 }
00112
00113 void DirectXApp::OnWindowClosed(
00114     _In_ CoreWindow^ sender,
00115     _In_ CoreWindowEventArgs^ args
00116     )
00117 {
00118     m_windowClosed = true;
00119 }
00120
00121 void DirectXApp::OnLogicalDpiChanged(
00122     _In_ Platform::Object^ sender
00123     )
00124 {
00125     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00126 }
00127
00128 void DirectXApp::OnActivated(
00129     _In_ CoreApplicationView^ applicationView,
00130     _In_ IActivatedEventArgs^ args
00131     )
00132 {
00133     CoreWindow::GetForCurrentThread()->Activate();
00134 }
00135
00136 void DirectXApp::OnSuspending(
00137     _In_ Platform::Object^ sender,
00138     _In_ SuspendingEventArgs^ args
00139     )
00140 {
00141 }
00142
00143 void DirectXApp::OnResuming(
00144     _In_ Platform::Object^ sender,
00145     _In_ Platform::Object^ args
00146     )
00147 {
00148 }
00149
00150 void DirectXApp::OnPointerPressed(
00151     _In_ Windows::UI::Core::CoreWindow^ sender,
00152     _In_ Windows::UI::Core::PointerEventArgs^ args
00153     )
00154 {
00155     Windows::UI::Input::PointerPoint^ p = args->CurrentPoint;
00156     m_renderer->OnPointerPressed(p);
00157 }
00158
00159 IFrameworkView^ DirectXAppSource::CreateView()
00160 {
00161     return ref new DirectXApp();
00162 }
00163
00164 [Platform::MTAThread]
00165 int main(Platform::Array<Platform::String^>^)
00166 {
00167     auto directXAppSource = ref new DirectXAppSource();
00168     CoreApplication::Run(directXAppSource);
00169     return 0;
00170 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Errors Member List

This is the complete list of members for SDKSample::Errors, including all inherited members.
Cancel | SDKSample::Errors | [static]
FileGroupEmpty | SDKSample::Errors | [static]
FileGroupLocation | SDKSample::Errors | [static]
NoAlbumArt | SDKSample::Errors | [static]
NoExifThumbnail | SDKSample::Errors | [static]
NoIcon | SDKSample::Errors | [static]
NoImages | SDKSample::Errors | [static]
NoThumbnail | SDKSample::Errors | [static]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/pch.h Source File

  • AtomPub

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario2.xaml.cpp Source File

  • App package information

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018
00019 using namespace SDKSample::PackageSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::ApplicationModel;
00027
00028 Scenario2::Scenario2()
00029 {
00030     InitializeComponent();
00031 }
00032
00033 /// <summary>
00034 /// Invoked when this page is about to be displayed in a Frame.
00035 /// </summary>
00036 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00037 /// property is typically used to configure the page.</param>
00038 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00039 {
00040     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00041     // as NotifyUser()
00042     rootPage = MainPage::Current;
00043 }
00044
00045 void Scenario2::GetInstalledLocation_Click(Object^ sender, RoutedEventArgs^ e)
00046 {
00047     // This will give the Installed Location.  You can use this location to access files, if you need them.
00048     Package^ package = Package::Current;
00049     Windows::Storage::StorageFolder^ installedLocation = package->InstalledLocation;
00050
00051     OutputTextBlock->Text = "Installed Location: " + installedLocation->Path;
00052 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/LaunchFileOutput.xaml.h Source File

  • Association launching

LaunchFileOutput.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // LaunchFileOutput.xaml.h
00010 // Declaration of the LaunchFileOutput class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "LaunchFileOutput.g.h"
00017 #include "MainPage.xaml.h"
00018
00019 namespace AssociationLaunching
00020 {
00021   [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class LaunchFileOutput sealed
00023     {
00024     public:
00025         LaunchFileOutput();
00026
00027     protected:
00028         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~LaunchFileOutput();
00033         MainPage^ rootPage;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/ScenarioSingle.xaml.h Source File

  • Contact Picker app

ScenarioSingle.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ScenarioSingle.xaml.h
00013 // Declaration of the ScenarioSingle class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "ScenarioSingle.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace ContactPicker
00023 {
00024     /// <summary>
00025     /// An empty page that can be used on its own or navigated to within a Frame.
00026     /// </summary>
00027     public ref class ScenarioSingle sealed
00028     {
00029     public:
00030         ScenarioSingle();
00031
00032     private:
00033         void PickAContactButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWidePeekImageCollection04 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWidePeekImageCollection04, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
ImageMain | NotificationsExtensions::TileContent::TileWidePeekImageCollection04 |
Images | NotificationsExtensions::NotificationBase |
ImageSmallColumn1Row1 | NotificationsExtensions::TileContent::TileWidePeekImageCollection04 |
ImageSmallColumn1Row2 | NotificationsExtensions::TileContent::TileWidePeekImageCollection04 |
ImageSmallColumn2Row1 | NotificationsExtensions::TileContent::TileWidePeekImageCollection04 |
ImageSmallColumn2Row2 | NotificationsExtensions::TileContent::TileWidePeekImageCollection04 |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBodyWrap | NotificationsExtensions::TileContent::TileWidePeekImageCollection04 |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWidePeekImageCollection04() | NotificationsExtensions::TileContent::TileWidePeekImageCollection04 | [inline]
TileWidePeekImageCollection04() | NotificationsExtensions::TileContent::TileWidePeekImageCollection04 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen apps/C#,C++/ScenarioList.xaml.cpp Source File

  • Lock screen apps
  • C#,C++

ScenarioList.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioList.xaml.cpp
00010 // Implementation of the ScenarioList class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioList.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace LockScreenAppsCPP;
00018
00019 using namespace Platform;
00020 using namespace CppSamplesUtils;
00021 using namespace Windows::Foundation;
00022 using namespace Windows::Foundation::Collections;
00023 using namespace Windows::Graphics::Display;
00024 using namespace Windows::UI::ViewManagement;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Controls::Primitives;
00028 using namespace Windows::UI::Xaml::Data;
00029 using namespace Windows::UI::Xaml::Input;
00030 using namespace Windows::UI::Xaml::Media;
00031 using namespace Windows::UI::Xaml::Navigation;
00032 using namespace Windows::UI::Xaml::Interop;
00033
00034 ScenarioList::ScenarioList()
00035 {
00036     InitializeComponent();
00037 }
00038
00039 ScenarioList::~ScenarioList()
00040 {
00041 }
00042
00043 void ScenarioList::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00044 {
00045     if(Scenarios->SelectedItem != nullptr)
00046     {
00047         rootPage->NotifyUser("", NotifyType::StatusMessage);
00048
00049         ListBoxItem^ selectedListBoxItem = dynamic_cast<ListBoxItem^>(Scenarios->SelectedItem);
00050         SuspensionManager::SessionState()->Insert("SelectedScenario", selectedListBoxItem->Name);
00051
00052         if (rootPage->InputFrame != nullptr && rootPage->OutputFrame != nullptr)
00053         {
00054              //Load the input and output pages for the current scenario into their respective frames
00055             TypeName inputPage = { "LockScreenAppsCPP" + "." + "ScenarioInput" + ((Scenarios->SelectedIndex + 1).ToString()), TypeKind::Custom };
00056             TypeName outputPage = { "LockScreenAppsCPP" + "." + "ScenarioOutput" + ((Scenarios->SelectedIndex + 1).ToString()), TypeKind::Custom };
00057             rootPage->DoNavigation(inputPage, rootPage->InputFrame, outputPage, rootPage->OutputFrame);
00058         }
00059     }
00060 }
00061
00062 void ScenarioList::OnNavigatedTo(NavigationEventArgs^ e)
00063 {
00064     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00065
00066     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &ScenarioList::Scenarios_SelectionChanged);
00067     ListBoxItem^ startingScenario = nullptr;
00068
00069     auto ps = SuspensionManager::SessionState();
00070     if (ps->HasKey("SelectedScenario"))
00071     {
00072         PropertyValue^ pv;
00073         String^ item = dynamic_cast<String^>(ps->Lookup("SelectedScenario"));
00074         startingScenario = dynamic_cast<ListBoxItem^>(this->FindName(item));
00075     }
00076
00077     Scenarios->SelectedItem = startingScenario != nullptr ? startingScenario : Scenario1;
00078 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/pch.cpp Source File

  • OrientationSensor

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/DirectXSample.h Source File

  • Direct3D tutorial
  • Lesson4.Textures

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioList.xaml.h Source File

  • Edge gesture invocation

ScenarioList.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioList.xaml.h
00010 // Declaration of the ScenarioList class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioList.g.h"
00017 #include "MainPage.g.h"
00018
00019 using namespace Windows::UI::Xaml::Controls;
00020 using namespace CppSamplesUtils;
00021
00022 namespace EdgeGestureSample
00023 {
00024   [Windows::Foundation::Metadata::WebHostHidden]
00025     public ref class ScenarioList sealed
00026     {
00027     public:
00028         ScenarioList();
00029
00030     protected:
00031         void Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e);
00032         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033
00034     private:
00035         ~ScenarioList();
00036
00037         MainPage^ rootPage;
00038     };
00039 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson4.Textures/BasicMath.h Source File

  • Direct3D tutorial
  • Lesson4.Textures

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/ProductItem.h Source File

  • XAML DirectX 3D shooting game

ProductItem.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 namespace Simple3DGameXaml
00011 {
00012     [Windows::UI::Xaml::Data::Bindable]
00013     [Windows::Foundation::Metadata::WebHostHidden]
00014     public ref class ProductItem sealed :
00015         public Windows::UI::Xaml::Data::INotifyPropertyChanged
00016     {
00017     internal:
00018         ProductItem(
00019             Windows::ApplicationModel::Store::ListingInformation^ listing,
00020             Windows::ApplicationModel::Store::LicenseInformation^ license,
00021             Platform::String^ productId,
00022             bool isApp
00023             );
00024
00025     public:
00026         virtual event Windows::UI::Xaml::Data::PropertyChangedEventHandler^ PropertyChanged;
00027
00028         property Platform::String^ Title
00029         {
00030             Platform::String^ get()
00031             {
00032                 return m_title;
00033             }
00034         }
00035
00036         property Platform::String^ Price
00037         {
00038             Platform::String^ get()
00039             {
00040                 return m_formattedPrice;
00041             }
00042         }
00043
00044         property Platform::String^ Status
00045         {
00046             Platform::String^ get()
00047             {
00048                 return m_status;
00049             }
00050         }
00051
00052         property int BuyVisibility
00053         {
00054             int get()
00055             {
00056                 return static_cast<int>(m_isAvailableForPurchase ? Windows::UI::Xaml::Visibility::Visible : Windows::UI::Xaml::Visibility::Collapsed);
00057             }
00058         }
00059
00060         property Platform::String^ ProductId
00061         {
00062             Platform::String^ get()
00063             {
00064                 return m_productId;
00065             }
00066         }
00067
00068         property Platform::String^ Foreground
00069         {
00070             Platform::String^ get()
00071             {
00072                 return m_foreground;
00073             }
00074         }
00075
00076         [Windows::Foundation::Metadata::DefaultOverload]
00077         void UpdateContent(Windows::ApplicationModel::Store::LicenseInformation^ license);
00078         void UpdateContent(Windows::ApplicationModel::Store::ListingInformation^ listing);
00079
00080     private:
00081         void SetStatus(Windows::ApplicationModel::Store::LicenseInformation^ license);
00082
00083         Platform::String^ m_title;
00084         Platform::String^ m_formattedPrice;
00085         Platform::String^ m_productId;
00086         Platform::String^ m_status;
00087         Platform::String^ m_foreground;
00088         bool              m_isApp;
00089         bool              m_isAppActive;
00090         bool              m_isAppTrial;
00091         bool              m_isProductActive;
00092         bool              m_isAvailableForPurchase;
00093     };
00094 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Constants.cpp Source File

  • File access

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 using namespace concurrency;
00018 using namespace Platform;
00019 using namespace Windows::Storage;
00020 using namespace Windows::UI::Xaml::Controls;
00021
00022 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00023 {
00024     { "Creating a file",                                    "SDKSample.FileAccess.Scenario1" },
00025     { "Writing and reading text in a file",                 "SDKSample.FileAccess.Scenario2" },
00026     { "Writing and reading bytes in a file",                "SDKSample.FileAccess.Scenario3" },
00027     { "Writing and reading using a stream",                 "SDKSample.FileAccess.Scenario4" },
00028     { "Displaying file properties",                         "SDKSample.FileAccess.Scenario5" },
00029     { "Persisting access to a storage item for future use", "SDKSample.FileAccess.Scenario6" },
00030     { "Copying a file",                                     "SDKSample.FileAccess.Scenario7" },
00031     { "Deleting a file",                                    "SDKSample.FileAccess.Scenario8" },
00032 };
00033
00034 void MainPage::Initialize()
00035 {
00036     sampleFile = nullptr;
00037     mruToken = nullptr;
00038     falToken = nullptr;
00039     create_task(KnownFolders::DocumentsLibrary->GetFileAsync(Filename)).then([this](task<StorageFile^> getFileTask)
00040     {
00041         try
00042         {
00043             sampleFile = getFileTask.get();
00044         }
00045         catch (Platform::Exception^)
00046         {
00047             // sample file doesn't exist so scenario one must be run first.
00048         }
00049     });
00050 }
00051
00052 void MainPage::ResetScenarioOutput(TextBlock^ output)
00053 {
00054     // clear Error/Status
00055     NotifyUser("", NotifyType::ErrorMessage);
00056     NotifyUser("", NotifyType::StatusMessage);
00057     // clear scenario output
00058     output->Text = "";
00059 }
00060
00061 void MainPage::ValidateFile(String^ scenarioName)
00062 {
00063     if (scenarioName != scenariosInner[0].ClassName && sampleFile == nullptr)
00064     {
00065         NotifyUserFileNotExist();
00066     }
00067 }
00068
00069 void MainPage::NotifyUserFileNotExist()
00070 {
00071     NotifyUser("The file '" + Filename + "' does not exist. Use scenario one to create this file.", NotifyType::ErrorMessage);
00072 }
00073
00074 void MainPage::HandleFileNotFoundException(Platform::COMException^ e)
00075 {
00076     if (e->HResult == 0x80070002) // Catch FileNotExistException
00077     {
00078         NotifyUserFileNotExist();
00079     }
00080     else
00081     {
00082         throw e;
00083     }
00084 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::PlaybackManager::sealed Member List

This is the complete list of members for SDKSample::PlaybackManager::sealed, including all inherited members.
_playback | SDKSample::PlaybackManager::sealed | [private]
AppMuted() | SDKSample::PlaybackManager::sealed | [private]
AppUnmuted() | SDKSample::PlaybackManager::sealed | [private]
Button_Pause_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlaybackManager::sealed | [private]
Button_Play_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlaybackManager::sealed | [private]
Button_Stop_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlaybackManager::sealed | [private]
cw | SDKSample::PlaybackManager::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlaybackManager::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlaybackManager::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PlaybackManager::sealed | [private]
DisplayStatus(Platform::String^text) | SDKSample::PlaybackManager::sealed | [private]
GetTimeStampedMessage(Platform::String^EventCalled) | SDKSample::PlaybackManager::sealed | [private]
IsPlaying | SDKSample::PlaybackManager::sealed | [private]
IsRegistered | SDKSample::PlaybackManager::sealed | [private, static]
MediaControl_PausePressed(Platform::Object^sender, Platform::Object^e) | SDKSample::PlaybackManager::sealed | [private]
MediaControl_PlayPauseTogglePressed(Platform::Object^sender, Platform::Object^e) | SDKSample::PlaybackManager::sealed | [private]
MediaControl_PlayPressed(Platform::Object^sender, Platform::Object^e) | SDKSample::PlaybackManager::sealed | [private]
MediaControl_SoundLevelChanged(Platform::Object^sender, Platform::Object^e) | SDKSample::PlaybackManager::sealed | [private]
MediaControl_StopPressed(Platform::Object^sender, Platform::Object^e) | SDKSample::PlaybackManager::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PlaybackManager::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PlaybackManager::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PlaybackManager::sealed | [protected, virtual]
Pause() | SDKSample::PlaybackManager::sealed |
PausePressedToken | SDKSample::PlaybackManager::sealed | [private, static]
Play() | SDKSample::PlaybackManager::sealed |
PlaybackControl() | SDKSample::PlaybackManager::sealed |
PlayPauseTogglePressedToken | SDKSample::PlaybackManager::sealed | [private, static]
PlayPressedToken | SDKSample::PlaybackManager::sealed | [private, static]
rootPage | SDKSample::PlaybackManager::sealed | [private]
SelectFile() | SDKSample::PlaybackManager::sealed |
SetAudioCategory(Windows::UI::Xaml::Media::AudioCategory category) | SDKSample::PlaybackManager::sealed |
SetAudioDeviceType(Windows::UI::Xaml::Media::AudioDeviceType devicetype) | SDKSample::PlaybackManager::sealed |
SoundLevelChangedToken | SDKSample::PlaybackManager::sealed | [private, static]
SoundLevelToString(Windows::Media::SoundLevel level) | SDKSample::PlaybackManager::sealed | [private]
Stop() | SDKSample::PlaybackManager::sealed |
StopPressedToken | SDKSample::PlaybackManager::sealed | [private, static]
StreamTypeAlert() | SDKSample::PlaybackManager::sealed |
StreamTypeMedia() | SDKSample::PlaybackManager::sealed |
StreamTypeOther() | SDKSample::PlaybackManager::sealed |
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/pch.h Source File

  • Clipboard app

pch.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include "Sample-Utils\CppSamplesUtils.h"
00019 #include <ppltasks.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/SearchHomeGroup.xaml.cpp Source File

  • HomeGroup app

SearchHomeGroup.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SearchHomeGroup.xaml.cpp
00013 // Implementation of the SearchHomeGroup class
00014 //
00015
00016 #include "pch.h"
00017 #include "SearchHomeGroup.xaml.h"
00018
00019 using namespace SDKSample::HomeGroup;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Platform;
00025 using namespace Windows::Storage;
00026 using namespace Windows::Storage::Search;
00027 using namespace concurrency;
00028 using namespace Windows::System;
00029 using namespace Windows::Foundation;
00030 using namespace Windows::Foundation::Collections;
00031 using namespace std;
00032
00033 SDKSample::HomeGroup::SearchHomeGroup::SearchHomeGroup()
00034 {
00035     InitializeComponent();
00036 }
00037
00038 /// <summary>
00039 /// Invoked when this page is about to be displayed in a Frame.
00040 /// </summary>
00041 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00042 /// property is typically used to configure the page.</param>
00043 void SDKSample::HomeGroup::SearchHomeGroup::OnNavigatedTo(NavigationEventArgs^ e)
00044 {
00045     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00046     // as NotifyUser()
00047     rootPage = MainPage::Current;
00048 }
00049
00050 void SDKSample::HomeGroup::SearchHomeGroup::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00051 {
00052     Button^ button = safe_cast<Button^>(sender);
00053     if (button != nullptr)
00054     {
00055         rootPage->NotifyUser("", NotifyType::StatusMessage);
00056         auto fileTypeFilter = ref new Platform::Collections::Vector<Platform::String^>();
00057         fileTypeFilter->Append("*");
00058         auto queryOptions = ref new QueryOptions(CommonFileQuery::OrderBySearchRank, fileTypeFilter);
00059         queryOptions->UserSearchFilter = QueryInputBox->Text;
00060
00061         // This try/catch block is for scenarios where the Homegroup Known Folder is not available.
00062         try
00063         {
00064             auto homeGroupFolder = KnownFolders::HomeGroup;
00065             auto queryResult = homeGroupFolder->CreateFileQueryWithOptions(queryOptions);
00066             OutputProgressRing->IsActive = true;
00067             create_task(queryResult->GetFilesAsync()).then([this, queryOptions](IVectorView<StorageFile^>^ files)
00068             {
00069                 if (files->Size == 0)
00070                 {
00071                     rootPage->NotifyUser("No files found for " + QueryInputBox->Text, NotifyType::StatusMessage);
00072                 }
00073                 else
00074                 {
00075                     String^ outString = (files->Size == 1) ? files->Size + " file found\n\n"
00076                         : files->Size + " files found\n\n";
00077
00078                     std::for_each(begin(files), end(files), [this, &outString](StorageFile ^file)
00079                     {
00080                         outString += file->Name + "\n";
00081                     });
00082                     rootPage->NotifyUser(outString, NotifyType::StatusMessage);
00083                 }
00084                 OutputProgressRing->IsActive = false;
00085             });
00086         }
00087         catch (Exception^ ex)
00088         {
00089             rootPage->NotifyUser(ex->Message + "\n", NotifyType::StatusMessage);
00090         }
00091     }
00092 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/common/LayoutAwarePage.cpp Source File

  • Connecting with WebSockets
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Resource.cpp Source File

  • Direct2D magazine app

Resource.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Windows::Data::Xml::Dom;
00011
00012 bool Resource::AcceptChildNode(
00013     _In_ Document^ document,
00014     _In_ IXmlNode^ childXmlNode
00015     )
00016 {
00017     if (childXmlNode->NodeType == NodeType::ElementNode)
00018     {
00019         XmlElement^ xmlElement = dynamic_cast<XmlElement^>(childXmlNode);
00020
00021         Element^ child = nullptr;
00022         Platform::String^ elementName = xmlElement->TagName;
00023
00024         if (elementName != nullptr)
00025         {
00026             if (elementName == "image")
00027             {
00028                 child = Element::Create<::Image>(document, childXmlNode);
00029             }
00030             else if (elementName == "text")
00031             {
00032                 child = Element::Create<Text>(document, childXmlNode);
00033             }
00034         }
00035
00036         if (child == nullptr)
00037         {
00038             return false;
00039         }
00040
00041         AddChild(child);
00042     }
00043
00044     return true;
00045 }
00046
00047 void Resource::Measure(
00048     _In_ Document^ document,
00049     D2D1_SIZE_F const& parentSize,
00050     _Out_ D2D1_RECT_F* bounds
00051     )
00052 {
00053     // Resource has no bounds of its own.
00054     *bounds = D2D1::RectF();
00055 }
00056
00057 bool Resource::PrepareToDraw(
00058     _In_ Document^ document,
00059     D2D1::Matrix3x2F const& transform
00060     )
00061 {
00062     // Resource doesn't draw.
00063     return false;
00064 }
00065
00066 bool Resource::Draw(
00067     _In_ Document^ document,
00068     D2D1::Matrix3x2F const& transform
00069     )
00070 {
00071     // Resource doesn't draw.
00072     return false;
00073 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/Constants.h Source File

  • Application resources and localization

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"ApplicationResources C++ Sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Search contract/C++/Scenario3.xaml.h Source File

  • Search contract

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 #pragma warning(push)
00023 #pragma warning(disable:4451) // Warns about possible invalid marshaling of objects across threads. In this case, the warning doesn't apply because the SearchPane object is only accessed from the UI thread.
00024 namespace SDKSample
00025 {
00026     namespace SearchContract
00027     {
00028         /// <summary>
00029         /// An empty page that can be used on its own or navigated to within a Frame.
00030         /// </summary>
00031         [Windows::Foundation::Metadata::WebHostHidden]
00032         public ref class Scenario3 sealed
00033         {
00034         public:
00035             Scenario3();
00036
00037         protected:
00038             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00039             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00040             void OnSearchPaneSuggestionsRequested(Windows::ApplicationModel::Search::SearchPane^ sender, Windows::ApplicationModel::Search::SearchPaneSuggestionsRequestedEventArgs^ e);
00041
00042         private:
00043             Windows::ApplicationModel::Search::SearchPane^ searchPane;
00044             Windows::Foundation::EventRegistrationToken token;
00045         };
00046     }
00047 }
00048 #pragma warning(pop) // Reenable warning 4451
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/MainPage.xaml.h Source File

  • HomeGroup app

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/Scenario3.xaml.h Source File

  • EAS policies for mail clients

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace EAS
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario3 sealed
00031         {
00032         public:
00033             Scenario3();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Launch_Click3(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Reset_Click3(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/common/suspensionmanager.h Source File

  • Splash screen
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/pch.cpp Source File

  • File picker

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicCamera.h Source File

  • DXGI offer and reclaim resources

BasicCamera.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple camera class.
00011 ref class BasicCamera
00012 {
00013
00014 private:
00015     float3 m_position;      // the position of the camera
00016     float3 m_direction;     // the unit vector of the viewing direction
00017     float4x4 m_view;        // view matrix
00018     float4x4 m_projection;  // projection matrix
00019
00020 internal:
00021     void GetViewMatrix(_Out_ float4x4 *viewMatrix);
00022     void GetProjectionMatrix(_Out_ float4x4 *projectionMatrix);
00023
00024     // this method updates the view matrix based on new position and focus coordinates
00025     void SetViewParameters(
00026         _In_ float3 eyePosition,    // the position of the camera
00027         _In_ float3 lookPosition,   // the point the camera should look at
00028         _In_ float3 up              // the durection vector for up
00029         );
00030
00031     // this method updates the projection matrix based on new parameters
00032     void SetProjectionParameters(
00033         _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00034         _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00035         _In_ float nearPlane,           // depth to map to 0
00036         _In_ float farPlane             // depth to map to 1
00037         );
00038 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/PhotoCache.h Source File

  • Hilo C++
  • Hilo

PhotoCache.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011     interface class IPhoto;
00012
00013     // The PhotoCache class is a helper class for XAML navigation. When the app wants to navigate to a particular
00014     // month, it uses the first image in that month to locate the correct position in the grid control.
00015     class PhotoCache
00016     {
00017     public:
00018         void InsertPhoto(IPhoto^ photo);
00019         IPhoto^ GetForYearAndMonth(int year, int month);
00020         void Clear();
00021
00022     private:
00023         typedef std::map<int, Platform::WeakReference> MonthPhoto;
00024         std::map<int, MonthPhoto> m_photoCache;
00025     };
00026 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/App.xaml.h Source File

  • DirectX postcard app

App.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "MainPage.xaml.h"
00011 #include "App.g.h"
00012
00013 namespace Postcard
00014 {
00015     [Windows::Foundation::Metadata::WebHostHidden]
00016     public ref class App sealed
00017     {
00018     public:
00019         App();
00020
00021         virtual void OnLaunched(
00022             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args
00023             ) override;
00024
00025     private:
00026         MainPage^ m_mainPage;
00027     };
00028 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Level5 Member List

This is the complete list of members for Level5, including all inherited members.
__pad0__ | Level5 |
Initialize(std::vector< GameObject^> objects) override | Level5 | [virtual]
Initialize(std::vector< GameObject^> objects) override | Level5 | [virtual]
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/common/suspensionmanager.cpp Source File

  • XAML animation library
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/App.xaml.cpp Source File

  • SimpleOrientationSensor

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario2.xaml.h Source File

  • XAML vector-based drawing

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Drawing
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         void FillSelection_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00040         void StrokeWidthSelection_ValueChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^ e);
00041       };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scheduled notifications/C#,C++/ScenarioOutput1.xaml.cpp Source File

  • Scheduled notifications
  • C#,C++

ScenarioOutput1.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.cpp
00010 // Implementation of the Scenario1Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput1.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace ScheduledNotificationsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput1::ScenarioOutput1()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput1::~ScenarioOutput1()
00038 {
00039 }
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageBase.h Source File

  • Hilo C++
  • Hilo

ImageBase.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "ViewModelBase.h"
00010
00011 namespace Hilo
00012 {
00013     interface class IPhoto;
00014     class ExceptionPolicy;
00015
00016     // The ImageBase class provides load and save functionality for image files.
00017     [Windows::Foundation::Metadata::WebHostHidden]
00018     public ref class ImageBase : public ViewModelBase
00019     {
00020
00021     private protected:
00022         IPhoto^ m_photo;
00023
00024     internal:
00025         ImageBase(std::shared_ptr<ExceptionPolicy> exceptionPolicy);
00026
00027         concurrency::task<Windows::Storage::Streams::IRandomAccessStreamWithContentType^> GetStreamWithFailCheck();
00028         concurrency::task<Windows::Storage::StorageFile^> GetFileNameFromFileSavePickerAsync(Platform::String^ fileType);
00029         concurrency::task<void> SaveImageAsync(Windows::Storage::StorageFile^ file, Windows::Storage::Streams::IRandomAccessStream^ ras);
00030     };
00031 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/App.xaml.cpp Source File

  • Network information

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/MainPage.xaml.h Source File

  • Web authentication broker

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/pch.h Source File

  • Direct2D animation

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <d2d1_1helper.h>
00015 #include <dwrite_1.h>
00016 #include <wincodec.h>
00017 #include <math.h>
00018 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/Scenario1.xaml.cpp Source File

  • Inclinometer sensor

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::InclinometerCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Devices::Sensors;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::UI::Core;
00027 using namespace Platform;
00028
00029 Scenario1::Scenario1() : rootPage(MainPage::Current), desiredReportInterval(0)
00030 {
00031     InitializeComponent();
00032
00033     inclinometer = Inclinometer::GetDefault();
00034     if (inclinometer != nullptr)
00035     {
00036         // Select a report interval that is both suitable for the purposes of the app and supported by the sensor.
00037         // This value will be used later to activate the sensor.
00038         uint32 minReportInterval = inclinometer->MinimumReportInterval;
00039         desiredReportInterval = minReportInterval > 16 ? minReportInterval : 16;
00040     }
00041     else
00042     {
00043         rootPage->NotifyUser("No inclinometer found", NotifyType::ErrorMessage);
00044     }
00045 }
00046
00047 /// <summary>
00048 /// Invoked when this page is about to be displayed in a Frame.
00049 /// </summary>
00050 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00051 /// property is typically used to configure the page.</param>
00052 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00053 {
00054     ScenarioEnableButton->IsEnabled = true;
00055     ScenarioDisableButton->IsEnabled = false;
00056 }
00057
00058 /// <summary>
00059 /// Invoked when this page is no longer displayed.
00060 /// </summary>
00061 /// <param name="e"></param>
00062 void Scenario1::OnNavigatedFrom(NavigationEventArgs^ e)
00063 {
00064     if (ScenarioDisableButton->IsEnabled)
00065     {
00066         Window::Current->VisibilityChanged::remove(visibilityToken);
00067         inclinometer->ReadingChanged::remove(readingToken);
00068
00069         // Restore the default report interval to release resources while the sensor is not in use
00070         inclinometer->ReportInterval = 0;
00071     }
00072 }
00073
00074 /// <summary>
00075 /// This is the event handler for VisibilityChanged events. You would register for these notifications
00076 /// if handling sensor data when the app is not visible could cause unintended actions in the app.
00077 /// </summary>
00078 /// <param name="sender"></param>
00079 /// <param name="e">
00080 /// Event data that can be examined for the current visibility state.
00081 /// </param>
00082 void Scenario1::VisibilityChanged(Object^ sender, VisibilityChangedEventArgs^ e)
00083 {
00084     // The app should watch for VisibilityChanged events to disable and re-enable sensor input as appropriate
00085     if (ScenarioDisableButton->IsEnabled)
00086     {
00087         if (e->Visible)
00088         {
00089             // Re-enable sensor input (no need to restore the desired reportInterval... it is restored for us upon app resume)
00090             readingToken = inclinometer->ReadingChanged::add(ref new TypedEventHandler<Inclinometer^, InclinometerReadingChangedEventArgs^>(this, &Scenario1::ReadingChanged));
00091         }
00092         else
00093         {
00094             // Disable sensor input (no need to restore the default reportInterval... resources will be released upon app suspension)
00095             inclinometer->ReadingChanged::remove(readingToken);
00096         }
00097     }
00098 }
00099
00100 void Scenario1::ReadingChanged(Inclinometer^ sender, InclinometerReadingChangedEventArgs^ e)
00101 {
00102     // We need to dispatch to the UI thread to display the output
00103     Dispatcher->RunAsync(
00104         CoreDispatcherPriority::Normal,
00105         ref new DispatchedHandler(
00106             [this, e]()
00107             {
00108                 InclinometerReading^ reading = e->Reading;
00109
00110                 ScenarioOutput_X->Text = reading->PitchDegrees.ToString();
00111                 ScenarioOutput_Y->Text = reading->RollDegrees.ToString();
00112                 ScenarioOutput_Z->Text = reading->YawDegrees.ToString();
00113             },
00114             CallbackContext::Any
00115             )
00116         );
00117 }
00118
00119 void Scenario1::ScenarioEnable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00120 {
00121     if (inclinometer != nullptr)
00122     {
00123         // Establish the report interval
00124         inclinometer->ReportInterval = desiredReportInterval;
00125
00126         visibilityToken = Window::Current->VisibilityChanged::add(ref new WindowVisibilityChangedEventHandler(this, &Scenario1::VisibilityChanged));
00127         readingToken = inclinometer->ReadingChanged::add(ref new TypedEventHandler<Inclinometer^, InclinometerReadingChangedEventArgs^>(this, &Scenario1::ReadingChanged));
00128
00129         ScenarioEnableButton->IsEnabled = false;
00130         ScenarioDisableButton->IsEnabled = true;
00131     }
00132     else
00133     {
00134         rootPage->NotifyUser("No inclinometer found", NotifyType::ErrorMessage);
00135     }
00136 }
00137
00138 void Scenario1::ScenarioDisable(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00139 {
00140     Window::Current->VisibilityChanged::remove(visibilityToken);
00141     inclinometer->ReadingChanged::remove(readingToken);
00142
00143     // Restore the default report interval to release resources while the sensor is not in use
00144     inclinometer->ReportInterval = 0;
00145
00146     ScenarioEnableButton->IsEnabled = true;
00147     ScenarioDisableButton->IsEnabled = false;
00148 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D interpolation modes/C++/DirectXSample.h Source File

  • Direct2D interpolation modes

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/pch.cpp Source File

  • Windows account authorization

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioOutput1.xaml.cpp Source File

  • Raw notifications
  • MainAppSample

ScenarioOutput1.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.cpp
00010 // Implementation of the Scenario1Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput1.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace RawNotificationsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput1::ScenarioOutput1()
00033 {
00034   InitializeComponent();
00035 }
00036
00037 ScenarioOutput1::~ScenarioOutput1()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput1::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044   // Get a pointer to our main page.
00045   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047   // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048   _frameLoadedToken = rootPage->InputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioOutput1::rootPage_InputFrameLoaded);
00049 }
00050
00051 void ScenarioOutput1::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053   rootPage->OutputFrameLoaded -= _frameLoadedToken;
00054 }
00055
00056 #pragma endregion
00057
00058 #pragma region Use this code if you need access to elements in the input frame - otherwise delete
00059 void ScenarioOutput1::rootPage_InputFrameLoaded(Object^ sender, Object^ e)
00060 {
00061   // Get a pointer to the content within the OutputFrame.
00062   Page^ inputFrame = dynamic_cast<Page^>(rootPage->InputFrame->Content);
00063
00064   // Go find the elements that we need for this scenario.
00065   // ex: flipView1 = dynamic_cast<FlipView^>(inputFrame->FindName("FlipView1"));
00066
00067 }
00068
00069 #pragma endregion
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/Scenario1.xaml.cpp Source File

  • Syndication

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::Syndication;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Web::Syndication;
00025 using namespace Windows::Foundation;
00026 using namespace Platform;
00027 using namespace Platform::Collections;
00028 using namespace Concurrency;
00029
00030 Scenario1::Scenario1()
00031 {
00032     currentFeed = nullptr;
00033
00034     InitializeComponent();
00035 }
00036
00037 /// <summary>
00038 /// Invoked when this page is about to be displayed in a Frame.
00039 /// </summary>
00040 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00041 /// property is typically used to configure the page.</param>
00042 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00045     // as NotifyUser()
00046     rootPage = MainPage::Current;
00047 }
00048
00049 void SDKSample::Syndication::Scenario1::GetFeed_Click(Object^ sender, RoutedEventArgs^ e)
00050 {
00051     OutputField->Text = "";
00052
00053     // By default 'FeedUri' is disabled and URI validation is not required. When enabling the text box
00054     // validating the URI is required since it was received from an untrusted source (user input).
00055     // The URI is validated by calling TryGetUri() that will return 'false' for strings that are not valid URIs.
00056     // Note that when enabling the text box users may provide URIs to machines on the intrAnet that require the
00057     // "Home or Work Networking" capability.
00058     Uri^ uri;
00059     if (!rootPage->TryGetUri(FeedUri->Text, &uri))
00060     {
00061         return;
00062     }
00063
00064     SyndicationClient^ client = ref new SyndicationClient();
00065     client->BypassCacheOnRetrieve = true;
00066
00067     // Some servers require a user-agent.
00068     client->SetRequestHeader("user-agent", "Mozilla/5.0 (compatible; MSIE 10.0; Windows NT 6.2; WOW64; Trident/6.0)");
00069
00070     rootPage->NotifyUser("Downloading feed...", NotifyType::StatusMessage);
00071     OutputField->Text = "Downloading feed: " + uri->DisplayUri + "\r\n";
00072
00073     task<SyndicationFeed^>(client->RetrieveFeedAsync(uri)).then([this] (SyndicationFeed^ feed)
00074     {
00075         currentFeed = feed;
00076         rootPage->NotifyUser("Feed download complete.", NotifyType::StatusMessage);
00077
00078         DisplayFeed();
00079     }).then([this] (task<void> t)
00080     {
00081         try
00082         {
00083             t.get();
00084         }
00085         catch (Exception^ exception)
00086         {
00087             rootPage->NotifyUser(exception->Message, NotifyType::ErrorMessage);
00088
00089             // Match HResult with a SyndicationErrorStatus value.
00090             // WebErrorStatus is also available WebErrorStatus for HTTP status error codes.
00091             SyndicationErrorStatus status = SyndicationError::GetStatus(exception->HResult);
00092             if (status == SyndicationErrorStatus::InvalidXml)
00093             {
00094                 OutputField->Text += "An invalid XML exception was thrown. " +
00095                     "Please make sure to use a URI that points to a RSS or Atom feed.";
00096             }
00097         }
00098     });
00099 }
00100
00101 void SDKSample::Syndication::Scenario1::DisplayFeed()
00102 {
00103     ISyndicationText^ title = currentFeed->Title;
00104     FeedTitleField->Text = title != nullptr ? title->Text : "(no title)";
00105
00106     currentItemIndex = 0;
00107     if (currentFeed->Items->Size > 0)
00108     {
00109         DisplayCurrentItem();
00110     }
00111
00112     // List the items.
00113     OutputField->Text += "Items: " + currentFeed->Items->Size + "\r\n";
00114 }
00115
00116 void SDKSample::Syndication::Scenario1::PreviousItem_Click(Object^ sender, RoutedEventArgs^ e)
00117 {
00118     if (currentFeed != nullptr && currentItemIndex > 0)
00119     {
00120         currentItemIndex--;
00121         DisplayCurrentItem();
00122     }
00123 }
00124
00125 void SDKSample::Syndication::Scenario1::NextItem_Click(Object^ sender, RoutedEventArgs^ e)
00126 {
00127     if (currentFeed != nullptr && currentItemIndex < (currentFeed->Items->Size - 1))
00128     {
00129         currentItemIndex++;
00130         DisplayCurrentItem();
00131     }
00132 }
00133
00134 void SDKSample::Syndication::Scenario1::DisplayCurrentItem()
00135 {
00136     SyndicationItem^ item = currentFeed->Items->GetAt(currentItemIndex);
00137
00138     // Display item number.
00139     IndexField->Text = (currentItemIndex + 1).ToString() + " of " + currentFeed->Items->Size.ToString();
00140
00141     // Display title.
00142     ItemTitleField->Text = item->Title != nullptr ? item->Title->Text : "(no title)";
00143
00144     // Display the main link.
00145     String^ link = nullptr;
00146     if (item->Links->Size > 0)
00147     {
00148         link = item->Links->GetAt(0)->Uri->AbsoluteUri;
00149     }
00150     LinkField->Content = link;
00151
00152     // Display element extensions. The ElementExtensions collection contains all the additional child elements within
00153     // the current element that do not belong to the Atom or RSS standards (e.g., Dublin Core extension elements).
00154     auto items = ref new Vector<Platform::Object^>();
00155     for each (ISyndicationNode^ elementExtension in item->ElementExtensions)
00156     {
00157         auto bindableNode = ref new BindableNode(
00158             elementExtension->NodeName,
00159             elementExtension->NodeNamespace,
00160             elementExtension->NodeValue);
00161         items->Append(bindableNode);
00162     }
00163     ExtensionsField->ItemsSource = items;
00164
00165     // Display the body as HTML.
00166     String^ content = "(no content)";
00167     if (item->Content != nullptr)
00168     {
00169         content = item->Content->Text;
00170     }
00171     else if (item->Summary != nullptr)
00172     {
00173         content = item->Summary->Text;
00174     }
00175     ContentWebView->NavigateToString(content);
00176 }
00177
00178 void SDKSample::Syndication::Scenario1::LinkField_Click(Object^ sender, RoutedEventArgs^ e)
00179 {
00180     Windows::System::Launcher::LaunchUriAsync(ref new Uri(((HyperlinkButton^)sender)->Content->ToString()));
00181 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/Scenario_Import.xaml.cpp Source File

  • Certificate enrollment

Scenario_Import.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario_Import.xaml.cpp
00013 // Implementation of the Scenario_Import class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario_Import.xaml.h"
00018
00019 using namespace SDKSample::CertificateEnrollment;
00020 using namespace Platform;
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::ApplicationModel::Resources;
00025 using namespace Windows::Security::Cryptography::Certificates;
00026 using namespace Concurrency;
00027
00028 Scenario_Import::Scenario_Import()
00029 {
00030     InitializeComponent();
00031 }
00032
00033 /// <summary>
00034 /// Invoked when this page is about to be displayed in a Frame.
00035 /// </summary>
00036 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00037 /// property is typically used to configure the page.</param>
00038 void Scenario_Import::OnNavigatedTo(NavigationEventArgs^ e)
00039 {
00040     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00041     // as NotifyUser()
00042     rootPage = MainPage::Current;
00043 }
00044
00045 void SDKSample::CertificateEnrollment::Scenario_Import::ImportPfx_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00046 {
00047   rootPage = MainPage::Current;
00048   TextBlock^ outputTextBlock =  safe_cast<TextBlock^>(rootPage->FindName(L"OutputTextBlock"));
00049
00050     try
00051     {
00052         outputTextBlock->Text = L"Importing PFX certificate ...";
00053
00054         // Load the pfx certificate from resource string.
00055         ResourceLoader^ rl = ref new ResourceLoader();
00056         String^ pfxCertificate = rl->GetString(L"Certificate");
00057
00058         String^ password = L"sampletest";     //password to access the certificate in PFX format
00059         String^ friendlyName = L"test pfx certificate";
00060
00061
00062         //call Certificate Enrollment funciton importPFXData to install the certificate
00063         create_task(CertificateEnrollmentManager::ImportPfxDataAsync(pfxCertificate,
00064             password,
00065             ExportOption::NotExportable,
00066             KeyProtectionLevel::NoConsent,
00067             InstallOptions::None,
00068             friendlyName))
00069             .then([outputTextBlock]()
00070         {
00071             outputTextBlock->Text += "\nCertificate installation succeeded. The certificate is in the appcontainer Personal certificate store";
00072         });
00073     }
00074     catch (Platform::Exception^ ex)
00075     {
00076         outputTextBlock->Text += "\nCertificate installation failed with error: " + ex->ToString();
00077     }
00078 }
00079
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Network information/C++/InternetConnectionProfile.xaml.h Source File

  • Network information

InternetConnectionProfile.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // InternetConnectionProfile.xaml.h
00013 // Declaration of the InternetConnectionProfile class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "InternetConnectionProfile.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::System;
00026 using namespace Windows::Foundation;
00027 using namespace Platform;
00028 using namespace Windows::Networking;
00029 using namespace Windows::Networking::Connectivity;
00030
00031 namespace SDKSample
00032 {
00033     namespace NetworkInformationApi
00034     {
00035         /// <summary>
00036         /// An empty page that can be used on its own or navigated to within a Frame.
00037         /// </summary>
00038         public ref class InternetConnectionProfile sealed
00039         {
00040         public:
00041             InternetConnectionProfile();
00042
00043         protected:
00044             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00045         private:
00046             MainPage^ rootPage;
00047             void InternetConnectionProfile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048
00049             Windows::Networking::Connectivity::NetworkInformation^ networkInfo;
00050             String^ GetConnectionProfile(Windows::Networking::Connectivity::ConnectionProfile^ connectionProfile);
00051             String^ GetConnectionCostInfo(Windows::Networking::Connectivity::ConnectionCost^ connectionCost);
00052             String^ GetCostBasedSuggestions(Windows::Networking::Connectivity::ConnectionCost^ connectionCost);
00053             String^ GetDataPlanStatusInfo(Windows::Networking::Connectivity::DataPlanStatus^ dataPlan);
00054             String^ GetNetworkSecuritySettingsInfo(Windows::Networking::Connectivity::NetworkSecuritySettings^ netSecuritySettings);
00055         };
00056     }
00057 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D basic image effects/C++/D2DEffectsHelloWorld.cpp Source File

  • Direct2D basic image effects

D2DEffectsHelloWorld.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "D2DEffectsHelloWorld.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::Storage::Pickers;
00017 using namespace Windows::System;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Graphics::Display;
00020
00021 // Define effects constants.
00022 static const float sc_gaussianBlurStDev = 5.0f;
00023
00024 void D2DEffectsHelloWorld::HandleDeviceLost()
00025 {
00026     // Release window size-dependent resources prior to creating a new device and swap chain.
00027     m_bitmapSourceEffect = nullptr;
00028     m_gaussianBlurEffect = nullptr;
00029
00030     DirectXBase::HandleDeviceLost();
00031 }
00032
00033 void D2DEffectsHelloWorld::CreateDeviceIndependentResources()
00034 {
00035     DirectXBase::CreateDeviceIndependentResources();
00036
00037     DecodeImage();
00038 }
00039
00040 void D2DEffectsHelloWorld::CreateDeviceResources()
00041 {
00042     DirectXBase::CreateDeviceResources();
00043
00044     m_sampleOverlay = ref new SampleOverlay();
00045
00046     m_sampleOverlay->Initialize(
00047         m_d2dDevice.Get(),
00048         m_d2dContext.Get(),
00049         m_wicFactory.Get(),
00050         m_dwriteFactory.Get(),
00051         "Direct2D basic image effects sample"
00052         );
00053 }
00054
00055 void D2DEffectsHelloWorld::CreateWindowSizeDependentResources()
00056 {
00057     DirectXBase::CreateWindowSizeDependentResources();
00058
00059     CreateEffectGraph();
00060 }
00061
00062 void D2DEffectsHelloWorld::DecodeImage()
00063 {
00064     DX::ThrowIfFailed(
00065         m_wicFactory->CreateDecoderFromFilename(
00066             L"mammoth.jpg",
00067             nullptr,
00068             GENERIC_READ,
00069             WICDecodeMetadataCacheOnDemand,
00070             &m_wicDecoder
00071             )
00072         );
00073
00074     DX::ThrowIfFailed(m_wicDecoder->GetFrame(0, &m_wicFrameDecode));
00075
00076     DX::ThrowIfFailed(m_wicFactory->CreateFormatConverter(&m_wicFormatConverter));
00077
00078     // We format convert to a pixel format that is compatible with Direct2D.
00079     // To optimize for performance when using WIC and Direct2D together, we need to
00080     // select the target pixel format based on the image's native precision:
00081     // - <= 8 bits per channel precision: use BGRA channel order
00082     //   (example: all JPEGs, including the image in this sample, are 8bpc)
00083     // -  > 8 bits per channel precision: use RGBA channel order
00084     //   (example: TIFF and JPEG-XR images support 32bpc float)
00085     // Note that a fully robust system will arbitrate between various WIC pixel formats
00086     // and hardware feature level support using the IWICPixelFormatInfo2 interface.
00087     DX::ThrowIfFailed(
00088         m_wicFormatConverter->Initialize(
00089             m_wicFrameDecode.Get(),
00090             GUID_WICPixelFormat32bppPBGRA,
00091             WICBitmapDitherTypeNone,
00092             nullptr,
00093             0.0f,
00094             WICBitmapPaletteTypeCustom
00095             )
00096         );
00097 }
00098
00099 void D2DEffectsHelloWorld::CreateEffectGraph()
00100 {
00101     UINT imageWidth;
00102     UINT imageHeight;
00103     m_wicFormatConverter->GetSize(&imageWidth, &imageHeight);
00104
00105     D2D1_POINT_2F scale = D2D1::Point2F(
00106         m_renderTargetSize.Width/imageWidth,
00107         m_renderTargetSize.Height/imageHeight
00108         );
00109
00110     // Create a Bitmap Source Effect.
00111     DX::ThrowIfFailed(m_d2dContext->CreateEffect(CLSID_D2D1BitmapSource, &m_bitmapSourceEffect));
00112
00113     // Set the scale property to the scale amount.
00114     DX::ThrowIfFailed(m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_SCALE, scale));
00115
00116     // Set the BitmapSource Property to the BitmapSource generated earlier.
00117     DX::ThrowIfFailed(
00118         m_bitmapSourceEffect->SetValue(D2D1_BITMAPSOURCE_PROP_WIC_BITMAP_SOURCE, m_wicFormatConverter.Get())
00119         );
00120
00121     // Create the Gaussian Blur Effect.
00122     DX::ThrowIfFailed(m_d2dContext->CreateEffect(CLSID_D2D1GaussianBlur, &m_gaussianBlurEffect));
00123
00124     // Set the input to recieve the bitmap from the BitmapSourceEffect.
00125     m_gaussianBlurEffect->SetInputEffect(0, m_bitmapSourceEffect.Get());
00126
00127     // Set the blur amount.
00128     DX::ThrowIfFailed(m_gaussianBlurEffect->SetValue(D2D1_GAUSSIANBLUR_PROP_STANDARD_DEVIATION, sc_gaussianBlurStDev));
00129 }
00130
00131 void D2DEffectsHelloWorld::Render()
00132 {
00133     m_d2dContext->BeginDraw();
00134
00135     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00136
00137     // Draw the scaled and blurred image.
00138     m_d2dContext->DrawImage(m_gaussianBlurEffect.Get());
00139
00140     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00141     // is lost. It will be handled during the next call to Present.
00142     HRESULT hr = m_d2dContext->EndDraw();
00143     if (hr != D2DERR_RECREATE_TARGET)
00144     {
00145         DX::ThrowIfFailed(hr);
00146     }
00147
00148     m_sampleOverlay->Render();
00149 }
00150
00151 void D2DEffectsHelloWorld::Initialize(
00152     _In_ CoreApplicationView^ applicationView
00153     )
00154 {
00155     applicationView->Activated +=
00156         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &D2DEffectsHelloWorld::OnActivated);
00157 }
00158
00159 void D2DEffectsHelloWorld::SetWindow(
00160     _In_ CoreWindow^ window
00161     )
00162 {
00163     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00164
00165     window->SizeChanged +=
00166         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &D2DEffectsHelloWorld::OnWindowSizeChanged);
00167
00168     DisplayProperties::LogicalDpiChanged +=
00169         ref new DisplayPropertiesEventHandler(this, &D2DEffectsHelloWorld::OnLogicalDpiChanged);
00170
00171     DisplayProperties::DisplayContentsInvalidated +=
00172         ref new DisplayPropertiesEventHandler(this, &D2DEffectsHelloWorld::OnDisplayContentsInvalidated);
00173
00174     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00175 }
00176
00177 void D2DEffectsHelloWorld::Load(
00178     _In_ Platform::String^ entryPoint
00179     )
00180 {
00181     // This method is intentionally left empty.
00182 }
00183
00184 void D2DEffectsHelloWorld::Run()
00185 {
00186     Render();
00187     Present();
00188
00189     m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
00190 }
00191
00192 void D2DEffectsHelloWorld::Uninitialize()
00193 {
00194     // This method is intentionally left empty.
00195 }
00196
00197 void D2DEffectsHelloWorld::OnWindowSizeChanged(
00198     _In_ CoreWindow^ sender,
00199     _In_ WindowSizeChangedEventArgs^ args
00200     )
00201 {
00202     UpdateForWindowSizeChange();
00203     m_sampleOverlay->UpdateForWindowSizeChange();
00204     Render();
00205     Present();
00206 }
00207
00208 void D2DEffectsHelloWorld::OnLogicalDpiChanged(
00209     _In_ Platform::Object^ sender
00210     )
00211 {
00212     SetDpi(DisplayProperties::LogicalDpi);
00213     Render();
00214     Present();
00215 }
00216
00217 void D2DEffectsHelloWorld::OnDisplayContentsInvalidated(
00218     _In_ Platform::Object^ sender
00219     )
00220 {
00221     // Ensure the D3D device is available for rendering.
00222     ValidateDevice();
00223
00224     Render();
00225     Present();
00226 }
00227
00228 void D2DEffectsHelloWorld::OnActivated(
00229     _In_ CoreApplicationView^ applicationView,
00230     _In_ IActivatedEventArgs^ args
00231     )
00232 {
00233     m_window->Activate();
00234 }
00235
00236 IFrameworkView^ DirectXAppSource::CreateView()
00237 {
00238     return ref new D2DEffectsHelloWorld();
00239 }
00240
00241 [Platform::MTAThread]
00242 int main(Platform::Array<Platform::String^>^)
00243 {
00244     auto directXAppSource = ref new DirectXAppSource();
00245     CoreApplication::Run(directXAppSource);
00246     return 0;
00247 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario2.xaml.cpp Source File

  • Compression

Scenario2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2.xaml.h"
00018 #include "CompressionUtils.h"
00019
00020 using namespace Windows::UI::Xaml;
00021 using namespace Windows::UI::Xaml::Controls;
00022 using namespace Windows::UI::Xaml::Navigation;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::Storage;
00025 using namespace Windows::Storage::Pickers;
00026 using namespace Windows::Storage::Streams;
00027 using namespace Windows::Storage::Compression;
00028
00029 using namespace SDKSample::Compression;
00030
00031 using namespace concurrency;
00032
00033 Scenario2::Scenario2()
00034 {
00035     InitializeComponent();
00036 }
00037
00038 /// <summary>
00039 /// Invoked when this page is about to be displayed in a Frame.
00040 /// </summary>
00041 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00042 /// property is typically used to configure the page.</param>
00043 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00044 {
00045     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00046     // as NotifyUser()
00047     rootPage = MainPage::Current;
00048 }
00049
00050
00051 void ::SDKSample::Compression::Scenario2::DoScenario(CompressAlgorithm Algorithm)
00052 {
00053     Progress->Text = "";
00054
00055     // This scenario uses File Picker which doesn't work in snapped mode - try unsnap first
00056     // and fail gracefully if we can't
00057     if ((ApplicationView::Value == ApplicationViewState::Snapped) &&
00058         !ApplicationView::TryUnsnap())
00059     {
00060         rootPage->NotifyUser("Sample doesn't work in snapped mode", NotifyType::ErrorMessage);
00061         return;
00062     }
00063
00064     rootPage->NotifyUser("Working...", NotifyType::StatusMessage);
00065
00066     auto context = std::make_shared<ScenarioContext>();
00067     context->raStream = ref new InMemoryRandomAccessStream();
00068
00069     auto picker = ref new Pickers::FileOpenPicker();
00070     picker->FileTypeFilter->Append("*");
00071
00072     // First pick a test file and open it for reading
00073     create_task(picker->PickSingleFileAsync()).then([=](StorageFile^ OriginalFile)
00074     {
00075         if (!OriginalFile)
00076         {
00077             throw std::runtime_error("No file has been selected");
00078         }
00079
00080         Progress->Text += "File \"" + OriginalFile->Name + "\" has been picked\n";
00081
00082         return OriginalFile->OpenAsync(FileAccessMode::Read);
00083     })
00084
00085     // Then read the whole file into memory buffer
00086     .then([=](IRandomAccessStream^ OriginalStream)
00087     {
00088         return ReadStreamTask(OriginalStream, context->originalData).GetTask();
00089     })
00090
00091     // Then compress data into in-memory stream
00092     .then([=](size_t BytesRead)
00093     {
00094         Progress->Text += BytesRead + " bytes have been read from disk\n";
00095
00096         auto memoryOutputStream = context->raStream->GetOutputStreamAt(0);
00097
00098         // Use default constructor if you don't need any specific algorithm and/or block size, use
00099         // "extended" constructor otherwise. This samples shows both versions for demonstration
00100         // purposes only.
00101         if (Algorithm == CompressAlgorithm::InvalidAlgorithm)
00102         {
00103             context->compressor = ref new Compressor(memoryOutputStream);
00104         }
00105         else
00106         {
00107             context->compressor = ref new Compressor(memoryOutputStream,
00108                                                         Algorithm,
00109                                                         0           // use default block size
00110                                                         );
00111         }
00112
00113         Progress->Text += "Compressor object has been created\n";
00114
00115         auto dataWriter = ref new DataWriter(context->compressor);
00116         context->writer = dataWriter;
00117         auto data = ref new Platform::Array<byte>(context->originalData.data(), (unsigned int)context->originalData.size());
00118         dataWriter->WriteBytes(data);
00119
00120         return dataWriter->StoreAsync();
00121     })
00122
00123     // Then finalize compression stream
00124     .then([=](unsigned int BytesWritten)
00125     {
00126         Progress->Text += BytesWritten + " bytes have been compressed\n";
00127
00128         return context->compressor->FinishAsync();
00129     })
00130
00131     // Then read compressed data into a stream
00132     .then([=](bool)
00133     {
00134         Progress->Text += "Compressed into " + context->raStream->Size + " bytes\n";
00135
00136         return ReadStreamTask(context->raStream->GetInputStreamAt(0), context->compressedData).GetTask();
00137     })
00138
00139     // Then decompressed data using "classic" Compression API
00140     .then([=](size_t BytesRead)
00141     {
00142         // IMPORTANT:
00143         // Tasks, that are created over IAsyncOperation (and the likes) or descended from them
00144         // have their continuations scheduled to the same ASTA apartment effectively blocking
00145         // the GUI for the length of processing continuation. Create an independent task here
00146         // instead of adding continuation on the upper level task (which descends from
00147         // "apartment-aware" task) so we will not block the GUI (ASTA) thread while decompressing.
00148         return task<size_t>([=]
00149         {
00150             // We are by convention the only thread to touch context->compressedData and
00151             // context->decompressedData at this point - no synchronization necessary
00152
00153             DECOMPRESSOR_HANDLE decompressorHandle = nullptr;
00154
00155             try
00156             {
00157                 // Enumaration values of Windows::Storage::Compression::CompressAlgorithm are
00158                 // guaranteed to match values from compressapi.h
00159                 ULONG compressAlgorithm = static_cast<ULONG>(Algorithm);
00160                 SIZE_T uncompressedDataSize = 0;
00161                 std::vector<byte> decompressedData;
00162
00163                 // Compress algorithm should always be explicit for "classic" Compression API
00164                 if (compressAlgorithm == COMPRESS_ALGORITHM_INVALID)
00165                 {
00166                     compressAlgorithm = COMPRESS_ALGORITHM_XPRESS;
00167                 }
00168
00169                 if (!CreateDecompressor(compressAlgorithm, nullptr, &decompressorHandle))
00170                 {
00171                     throw std::runtime_error("Cannot create compressor");
00172                 }
00173
00174                 if (!Decompress(decompressorHandle, context->compressedData.data(), context->compressedData.size(), nullptr, 0, &uncompressedDataSize) &&
00175                     (GetLastError() != ERROR_INSUFFICIENT_BUFFER))
00176                 {
00177                     throw std::runtime_error("Cannot get decompressed data size");
00178                 }
00179
00180                 decompressedData.resize(uncompressedDataSize);
00181
00182                 if (!Decompress(decompressorHandle,
00183                                 context->compressedData.data(),
00184                                 context->compressedData.size(),
00185                                 decompressedData.data(),
00186                                 decompressedData.size(),
00187                                 &uncompressedDataSize))
00188                 {
00189                     throw std::runtime_error("Cannot decompress data");
00190                 }
00191
00192                 CloseDecompressor(decompressorHandle);
00193
00194                 context->decompressedData = std::move(decompressedData);
00195                 return context->decompressedData.size();
00196             }
00197             catch (...)
00198             {
00199                 if (decompressorHandle != nullptr)
00200                 {
00201                     CloseDecompressor(decompressorHandle);
00202                 }
00203
00204                 throw;
00205             }
00206         });
00207     })
00208
00209     // Then verify if any data has been lost in action
00210     .then([=](size_t BytesDecompressed)
00211     {
00212         Progress->Text += BytesDecompressed + " bytes have been decompressed\n";
00213
00214         if (context->decompressedData.size() != BytesDecompressed)
00215         {
00216             throw std::runtime_error("Decompressed data size doesn't match number of bytes read from in-memory stream");
00217         }
00218
00219         if (context->originalData.size() != context->decompressedData.size())
00220         {
00221             throw std::runtime_error("Decompressed data size doesn't match original one");
00222         }
00223
00224         if (!std::equal(context->originalData.begin(), context->originalData.end(), context->decompressedData.begin()))
00225         {
00226             throw std::runtime_error("Decompressed data doesn't match original one");
00227         }
00228
00229         Progress->Text += "Decompressed data matches original\n";
00230     })
00231
00232     // Final task based continuation is used to handle exceptions in the chain above
00233     .then([=](task<void> FinalContinuation)
00234     {
00235         try
00236         {
00237             // Transport all exceptions to this thread. This task is guaranteed to be completed by now.
00238             FinalContinuation.get();
00239
00240             Progress->Text += "All done\n";
00241             rootPage->NotifyUser("Finished", NotifyType::StatusMessage);
00242         }
00243         catch (Platform::Exception ^e)
00244         {
00245             rootPage->NotifyUser(e->Message, NotifyType::ErrorMessage);
00246         }
00247         catch (const std::exception &e)
00248         {
00249             std::wstringstream wss;
00250             wss << e.what();
00251             rootPage->NotifyUser(ref new Platform::String(wss.str().c_str()), NotifyType::ErrorMessage);
00252         }
00253     });
00254 }
00255
00256 void ::SDKSample::Compression::Scenario2::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00257 {
00258     Button^ b = safe_cast<Button^>(sender);
00259
00260     if (b != nullptr)
00261     {
00262         DoScenario(CompressAlgorithm::InvalidAlgorithm);
00263     }
00264 }
00265
00266 void ::SDKSample::Compression::Scenario2::Xpress_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00267 {
00268     Button^ b = safe_cast<Button^>(sender);
00269
00270     if (b != nullptr)
00271     {
00272         DoScenario(CompressAlgorithm::Xpress);
00273     }
00274 }
00275
00276 void ::SDKSample::Compression::Scenario2::XpressHuff_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00277 {
00278     Button^ b = safe_cast<Button^>(sender);
00279
00280     if (b != nullptr)
00281     {
00282         DoScenario(CompressAlgorithm::XpressHuff);
00283     }
00284 }
00285
00286 void ::SDKSample::Compression::Scenario2::Mszip_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00287 {
00288     Button^ b = safe_cast<Button^>(sender);
00289
00290     if (b != nullptr)
00291     {
00292         DoScenario(CompressAlgorithm::Mszip);
00293     }
00294 }
00295
00296 void ::SDKSample::Compression::Scenario2::Lzms_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00297 {
00298     Button^ b = safe_cast<Button^>(sender);
00299
00300     if (b != nullptr)
00301     {
00302         DoScenario(CompressAlgorithm::Lzms);
00303     }
00304 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TextInterop Member List

This is the complete list of members for TextInterop, including all inherited members.
__pad0__ | TextInterop |
CreateDeviceIndependentResources() override | TextInterop | [virtual]
CreateDeviceResources() override | TextInterop | [virtual]
CreateWindowSizeDependentResources() override | TextInterop | [virtual]
m_camera | TextInterop | [private]
m_constantBuffer | TextInterop | [private]
m_constantBufferData | TextInterop | [private]
m_indexBuffer | TextInterop | [private]
m_indexCount | TextInterop | [private]
m_inputLayout | TextInterop | [private]
m_pixelShader | TextInterop | [private]
m_sampleOverlay | TextInterop | [private]
m_sampler | TextInterop | [private]
m_texture | TextInterop | [private]
m_textureShaderResourceView | TextInterop | [private]
m_vertexBuffer | TextInterop | [private]
m_vertexShader | TextInterop | [private]
Render() override | TextInterop | [virtual]
Update(float TimeTotal, float TimeDelta) | TextInterop |
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ScenarioContext Member List

This is the complete list of members for ScenarioContext, including all inherited members.
compressedData | ScenarioContext
compressor | ScenarioContext
decompressedData | ScenarioContext
originalData | ScenarioContext
raStream | ScenarioContext
writer | ScenarioContext
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/SampleOverlay.cpp Source File

  • DXGI swap chain rotation

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render(Matrix3x2F& transform)
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(transform);
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.h Source File

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp

HttpRequest.h

Go to the documentation of this file.
00001 //-----------------------------------------------------------------------
00002 //
00003 //  Copyright (C) Microsoft Corporation.  All rights reserved.
00004 //
00005 //
00006 // THIS CODE AND INFORMATION ARE PROVIDED AS-IS WITHOUT WARRANTY OF ANY
00007 // KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00008 // IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //-----------------------------------------------------------------------
00011 #pragma once
00012 #include "pch.h"
00013
00014 inline void CheckHResult(HRESULT hResult)
00015 {
00016     if (hResult == E_ABORT)
00017     {
00018         concurrency::cancel_current_task();
00019     }
00020     else if (FAILED(hResult))
00021     {
00022         throw Platform::Exception::CreateException(hResult);
00023     }
00024 }
00025
00026 namespace Web
00027 {
00028
00029 namespace Details
00030 {
00031
00032 // Implementation of IXMLHTTPRequest2Callback used when partial buffers are needed from the response.
00033 // When only the complete response is needed, use HttpRequestStringCallback instead.
00034 class HttpRequestBuffersCallback
00035     : public Microsoft::WRL::RuntimeClass<
00036         Microsoft::WRL::RuntimeClassFlags<Microsoft::WRL::ClassicCom>,
00037         IXMLHTTPRequest2Callback,
00038         Microsoft::WRL::FtmBase>
00039 {
00040 public:
00041     HttpRequestBuffersCallback(IXMLHTTPRequest2* httpRequest,
00042         concurrency::cancellation_token ct = concurrency::cancellation_token::none()) :
00043         request(httpRequest), cancellationToken(ct), responseReceived(false), dataHResult(S_OK), statusCode(200)
00044     {
00045         // Register a callback function that aborts the HTTP operation when
00046         // the cancellation token is canceled.
00047         if (cancellationToken != concurrency::cancellation_token::none())
00048         {
00049             registrationToken = cancellationToken.register_callback([this]()
00050             {
00051                 if (request != nullptr)
00052                 {
00053                     request->Abort();
00054                 }
00055             });
00056         }
00057
00058         dataEvent = concurrency::task_completion_event<void>();
00059     }
00060
00061     // Called when the HTTP request is being redirected to a new URL.
00062     IFACEMETHODIMP OnRedirect(IXMLHTTPRequest2*, PCWSTR)
00063     {
00064         return S_OK;
00065     }
00066
00067     // Called when HTTP headers have been received and processed.
00068     IFACEMETHODIMP OnHeadersAvailable(IXMLHTTPRequest2*, DWORD statusCode, PCWSTR reasonPhrase)
00069     {
00070         HRESULT hr = S_OK;
00071
00072         // We must not propagate exceptions back to IXHR2.
00073         try
00074         {
00075             this->statusCode = statusCode;
00076             this->reasonPhrase = reasonPhrase;
00077
00078             concurrency::critical_section::scoped_lock lock(dataEventLock);
00079             dataEvent.set();
00080         }
00081         catch (std::bad_alloc&)
00082         {
00083             hr = E_OUTOFMEMORY;
00084         }
00085         return hr;
00086     }
00087
00088     // Called when a portion of the entity body has been received.
00089     IFACEMETHODIMP OnDataAvailable(IXMLHTTPRequest2*, ISequentialStream* stream)
00090     {
00091         HRESULT hr = S_OK;
00092
00093         // We must not propagate exceptions back to IXHR2.
00094         try
00095         {
00096             // Store a reference on the stream so it can be accessed by the task.
00097             dataStream = stream;
00098
00099             // The work must be done as fast as possible, and must not block this thread,
00100             // for example, waiting on another event object.  Here we simply set an event
00101             // that can be processed by another thread.
00102             concurrency::critical_section::scoped_lock lock(dataEventLock);
00103             dataEvent.set();
00104         }
00105         catch (std::bad_alloc&)
00106         {
00107             hr = E_OUTOFMEMORY;
00108         }
00109         return hr;
00110     }
00111
00112     // Called when the entire entity response has been received.
00113     IFACEMETHODIMP OnResponseReceived(IXMLHTTPRequest2* xhr, ISequentialStream* responseStream)
00114     {
00115         responseReceived = true;
00116         return OnDataAvailable(xhr, responseStream);
00117     }
00118
00119     // Called when an error occurs during the HTTP request.
00120     IFACEMETHODIMP OnError(IXMLHTTPRequest2*, HRESULT hrError)
00121     {
00122         HRESULT hr = S_OK;
00123
00124         // We must not propagate exceptions back to IXHR2.
00125         try
00126         {
00127             concurrency::critical_section::scoped_lock lock(dataEventLock);
00128             dataHResult = hrError;
00129             dataEvent.set();
00130         }
00131         catch (std::bad_alloc&)
00132         {
00133             hr = E_OUTOFMEMORY;
00134         }
00135
00136         return hr;
00137     }
00138
00139     // Create a task that completes when data is available, in an exception-safe way.
00140     concurrency::task<void> CreateDataTask();
00141
00142     HRESULT GetError() const
00143     {
00144         return dataHResult;
00145     }
00146
00147     int GetStatusCode() const
00148     {
00149         return statusCode;
00150     }
00151
00152     std::wstring const& GetReasonPhrase() const
00153     {
00154         return reasonPhrase;
00155     }
00156
00157     bool IsResponseReceived() const
00158     {
00159         return responseReceived;
00160     }
00161
00162     // Copy bytes from the sequential stream into the buffer provided until
00163     // we reach the end of one or the other.
00164     unsigned int ReadData(
00165         _Out_writes_(outputBufferSize) byte* outputBuffer,
00166         unsigned int outputBufferSize);
00167
00168 private:
00169     ~HttpRequestBuffersCallback()
00170     {
00171         // Unregister the callback.
00172         if (cancellationToken != concurrency::cancellation_token::none())
00173         {
00174             cancellationToken.deregister_callback(registrationToken);
00175         }
00176     }
00177
00178     // Signals that the download operation was canceled.
00179     concurrency::cancellation_token cancellationToken;
00180
00181     // Used to unregister the cancellation token callback.
00182     concurrency::cancellation_token_registration registrationToken;
00183
00184     // The IXMLHTTPRequest2 that processes the HTTP request.
00185     Microsoft::WRL::ComPtr<IXMLHTTPRequest2> request;
00186
00187     // Task completion event that is set when data is available or error is triggered.
00188     concurrency::task_completion_event<void> dataEvent;
00189     concurrency::critical_section dataEventLock;
00190
00191     // We cannot store the error obtained from IXHR2 in the dataEvent since any value there is first-writer-wins,
00192     // whereas we want a subsequent error to override an initial success.
00193     HRESULT dataHResult;
00194
00195     // Referenced pointer to the data stream.
00196     Microsoft::WRL::ComPtr<ISequentialStream> dataStream;
00197
00198     // HTTP status code and reason returned by the server.
00199     int statusCode;
00200     std::wstring reasonPhrase;
00201
00202     // Whether the response has been completely received.
00203     bool responseReceived;
00204 };
00205
00206 };
00207
00208 // Utility class for performing asynchronous HTTP requests.
00209 // This class only supports one outstanding request at a time.
00210 class HttpRequest
00211 {
00212 public:
00213     HttpRequest();
00214
00215     int GetStatusCode() const
00216     {
00217         return statusCode;
00218     }
00219
00220     std::wstring const& GetReasonPhrase() const
00221     {
00222         return reasonPhrase;
00223     }
00224
00225     // Whether the response has been completely received, if using ReadAsync().
00226     bool IsResponseComplete() const
00227     {
00228         return responseComplete;
00229     }
00230
00231     // Start an HTTP GET on the specified URI.  The returned task completes once the entire response
00232     // has been received, and the task produces the HTTP response text.  The status code and reason
00233     // can be read with GetStatusCode() and GetReasonPhrase().
00234     concurrency::task<std::wstring> GetAsync(
00235         Windows::Foundation::Uri^ uri,
00236         concurrency::cancellation_token cancellationToken = concurrency::cancellation_token::none());
00237
00238     // Start an HTTP POST on the specified URI, using a string body.  The returned task produces the
00239     // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00240     concurrency::task<std::wstring> PostAsync(
00241         Windows::Foundation::Uri^ uri,
00242         PCWSTR contentType,
00243         IStream* postStream,
00244         uint64 postStreamSizeToSend,
00245         concurrency::cancellation_token cancellationToken = concurrency::cancellation_token::none());
00246
00247     // Start an HTTP POST on the specified URI, using a stream body.  The returned task produces the
00248     // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00249     concurrency::task<std::wstring> PostAsync(
00250         Windows::Foundation::Uri^ uri,
00251         const std::wstring& str,
00252         concurrency::cancellation_token cancellationToken = concurrency::cancellation_token::none());
00253
00254     // Send a request but don't return the response.  Instead, let the caller read it with ReadAsync().
00255     concurrency::task<void> SendAsync(
00256         const std::wstring& httpMethod,
00257         Windows::Foundation::Uri^ uri,
00258         concurrency::cancellation_token cancellationToken = concurrency::cancellation_token::none());
00259
00260     // Read a chunk of data from the HTTP response, up to a specified length or until we reach the end
00261     // of the response, and store the value in the provided buffer.  This is useful for large content,
00262     // enabling the streaming of the result.
00263     concurrency::task<void> ReadAsync(
00264         Windows::Storage::Streams::IBuffer^ readBuffer,
00265         unsigned int offsetInBuffer,
00266         unsigned int requestedBytesToRead);
00267
00268     static void CreateMemoryStream(IStream **stream);
00269
00270 private:
00271     // Start a download of the specified URI using the specified method.  The returned task produces the
00272     // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00273     concurrency::task<std::wstring> DownloadAsync(
00274         PCWSTR httpMethod,
00275         PCWSTR uri,
00276         concurrency::cancellation_token cancellationToken,
00277         PCWSTR contentType,
00278         IStream* postStream,
00279         uint64 postStreamBytesToSend);
00280
00281     // Referenced pointer to the callback, if using SendAsync/ReadAsync.
00282     Microsoft::WRL::ComPtr<Details::HttpRequestBuffersCallback> buffersCallback;
00283
00284     int statusCode;
00285     std::wstring reasonPhrase;
00286
00287     // Whether the response has been completely received, if using ReadAsync().
00288     bool responseComplete;
00289 };
00290
00291 };
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileSquarePeekImageAndText01, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
NotificationsExtensions::GetContent() | NotificationsExtensions::TileContent::TileSquareBase | [inline]
NotificationsExtensions::GetContent() | NotificationsExtensions::TileContent::TileSquareBase | [inline]
NotificationsExtensions::TileContent::TileNotificationBase::GetContent() | NotificationsExtensions::NotificationBase | [pure virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Image | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 |
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeBinding(string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
SerializeBinding(string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBody1 | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 |
TextBody2 | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 |
TextBody3 | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 |
TextFields | NotificationsExtensions::NotificationBase |
TextHeading | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileSquareBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
TileSquareBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
TileSquarePeekImageAndText01() | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 | [inline]
TileSquarePeekImageAndText01() | NotificationsExtensions::TileContent::TileSquarePeekImageAndText01 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioInput2.xaml.cpp Source File

  • Language font mapping

ScenarioInput2.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Input.xaml.cpp
00010 // Implementation of the Scenario2Input class.
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput2.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace LanguageFontCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031 using namespace Windows::Globalization::Fonts;
00032
00033 ScenarioInput2::ScenarioInput2()
00034 {
00035     InitializeComponent();
00036 }
00037
00038 ScenarioInput2::~ScenarioInput2()
00039 {
00040 }
00041
00042 #pragma region Template-Related Code - Do not remove
00043 void ScenarioInput2::OnNavigatedTo(NavigationEventArgs^ e)
00044 {
00045     // Get a pointer to our main page.
00046     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00047
00048     // We want to be notified with the OutputFrame is loaded so we can get to the content.
00049     _frameLoadedToken = rootPage->OutputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioInput2::rootPage_OutputFrameLoaded);
00050 }
00051
00052 void ScenarioInput2::OnNavigatedFrom(NavigationEventArgs^ e)
00053 {
00054     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00055   if (_oriHeadingUI != nullptr)
00056     {
00057     Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00058     auto headingUI = dynamic_cast<TextBlock^>(outputFrame->FindName("Scenario2Heading"));
00059     auto textUI = dynamic_cast<TextBlock^>(outputFrame->FindName("Scenario2Text"));
00060         _oriHeadingUI->Reset(headingUI);
00061         _oriTextUI->Reset(textUI);
00062     }
00063 }
00064
00065 #pragma endregion
00066
00067 #pragma region Use this code if you need access to elements in the output frame - otherwise delete
00068 void ScenarioInput2::rootPage_OutputFrameLoaded(Object^ sender, Object^ e)
00069 {
00070     // Get a pointer to the content within the OutputFrame.
00071     Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00072
00073     // Go find the elements that we need for this scenario
00074     // ex: flipView1 = dynamic_cast<FlipView^>(outputFrame->FindName("FlipView1"));
00075 }
00076
00077 #pragma endregion
00078
00079 #pragma region Sample click handlers - modify if you need them, otherwise delete
00080 void ScenarioInput2::ApplyFont_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00081 {
00082     Button^ b = dynamic_cast<Button^>(sender);
00083     if (b != nullptr)
00084     {
00085         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00086     }
00087
00088   auto languageFontGroup = ref new LanguageFontGroup("hi");
00089
00090   Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00091     auto headingUI = dynamic_cast<TextBlock^>(outputFrame->FindName("Scenario2Heading"));
00092     auto textUI = dynamic_cast<TextBlock^>(outputFrame->FindName("Scenario2Text"));
00093
00094     if (_oriHeadingUI == nullptr)
00095     {
00096         // Store original font style for Reset
00097         _oriHeadingUI = ref new FontInfoLocal();
00098         _oriTextUI = ref new FontInfoLocal();
00099         _oriHeadingUI->Set(headingUI);
00100         _oriTextUI->Set(textUI);
00101     }
00102
00103     // Change the Font value with selected font from LanguageFontGroup API.
00104     FontInfoLocal::SetFont(headingUI, languageFontGroup->DocumentHeadingFont);
00105
00106     // Not all scripts have recommended fonts for "document alternate"
00107     // categories, so need to verify before using it. Note that Hindi does
00108     // have document alternate fonts so in this case the fallback logic is
00109     // unnecessary, but (for example) Japanese does not have recommendations
00110     // for the document alternate 2 category.
00111     if (languageFontGroup->DocumentAlternate2Font != nullptr)
00112     {
00113         FontInfoLocal::SetFont(textUI, languageFontGroup->DocumentAlternate2Font);
00114     }
00115     else if (languageFontGroup->DocumentAlternate1Font != nullptr)
00116     {
00117         FontInfoLocal::SetFont(textUI, languageFontGroup->DocumentAlternate1Font);
00118     }
00119     else
00120     {
00121         FontInfoLocal::SetFont(textUI, languageFontGroup->ModernDocumentFont);
00122     }
00123 }
00124
00125 #pragma endregion
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/MainPage.xaml.cpp Source File

  • Calendar details and math

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Image Member List

This is the complete list of members for Image, including all inherited members.
__pad0__ | Image |
AcceptChildNode(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^childXmlNode) | Element | [virtual]
AddChild(_In_ Element^element) | Element |
AddSibling(_In_ Element^element) | Element |
BindResource(_In_ Element^rootElement) | Element | [virtual]
Create(_In_ Document^document, _In_ Windows::Data::Xml::Dom::IXmlNode^xmlNode) | Element | [static]
Draw(_In_ Document^document, D2D1::Matrix3x2F const &transform) override | Resource | [virtual]
DrawBitmap(_In_ Renderer^renderer, D2D1::Matrix3x2F const &transform, D2D1_RECT_F const &destinationBounds, D2D1_RECT_F const &bitmapBounds) | Image |
GetFirstChild() | Element | [inline]
GetName() | Element | [inline]
GetNextSibling() | Element | [inline]
GetOpacity() | Element | [inline, virtual]
GetParent() | Element | [inline]
GetSize() | Element | [inline]
Initialize(_In_ Document^document, _In_ Windows::Data::Xml::Dom::XmlElement^xmlElement) override | Image | [virtual]
m_bitmap | Image | [private]
m_file | Image | [private]
Measure(_In_ Document^document, D2D1_SIZE_F const &parentSize, _Out_ D2D1_RECT_F *bounds) override | Resource | [virtual]
override | Resource |
PrepareToDraw(_In_ Document^document, D2D1::Matrix3x2F const &transform) override | Resource | [virtual]
ReleaseParent() | Element | [virtual]
Generated on Sat Nov 23 2024 16:09:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/sample-utils/CppSamplesUtils.h Source File

  • Real-time communication
  • sample-utils

CppSamplesUtils.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <string>
00014 #include <sstream>
00015 #include <algorithm>
00016 #include <collection.h>
00017 #include <ppltasks.h>
00018
00019 namespace CppSamplesUtils
00020 {
00021     namespace Details
00022     {
00023         static Windows::Foundation::Collections::PropertySet^ sessionState = nullptr;
00024         static Platform::String^ sessionStateFileName = ref new Platform::String(L"_cppSessionState.xml");
00025
00026         concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file);
00027         concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file);
00028     }
00029
00030     class SuspensionManager
00031     {
00032     public:
00033         static Windows::Foundation::Collections::PropertySet^ SessionState()
00034         {
00035             using namespace Windows::Foundation::Collections;
00036             using namespace Details;
00037
00038             if (sessionState == nullptr)
00039             {
00040                 sessionState = ref new PropertySet();
00041             }
00042             return sessionState;
00043         }
00044
00045         static concurrency::task<void> StartRestoreTask()
00046         {
00047             using namespace Windows::Foundation;
00048             using namespace Windows::Storage;
00049             using namespace Windows::Storage::Streams;
00050             using namespace Details;
00051
00052             auto state = SessionState();
00053             state->Clear();
00054
00055             concurrency::task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFileName));
00056             return getFileTask.then([=](StorageFile^ file)
00057             {
00058                 return DeserializeSessionState(file);
00059             });
00060         }
00061
00062         static concurrency::task<void> StartSaveTask()
00063         {
00064             using namespace Windows::Foundation;
00065             using namespace Windows::Storage;
00066             using namespace Windows::Storage::Streams;
00067             using namespace Details;
00068
00069             concurrency::task<StorageFile^> createFileTask(ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFileName, CreationCollisionOption::ReplaceExisting));
00070             return createFileTask.then([=](StorageFile^ file)
00071             {
00072                 return SerializeSessionState(file);
00073             });
00074         }
00075     };
00076
00077     namespace Details
00078     {
00079         template <class T>
00080         inline Platform::String^ ToString(T value)
00081         {
00082             std::wstringstream wss;
00083             wss << value;
00084             return ref new Platform::String(wss.str().c_str());
00085         }
00086
00087         template <class T>
00088         inline T FromStringTo(Platform::String^ str)
00089         {
00090             std::wistringstream wiss(str->Data());
00091             T value = 0;
00092             wiss >> value;
00093             return value;
00094         }
00095
00096         template <class T>
00097         inline T FromHexStringTo(Platform::String^ str)
00098         {
00099             std::wistringstream wiss(str->Data());
00100             T value = 0;
00101             wiss >> std::hex >> value;
00102             return value;
00103         }
00104
00105         template <>
00106         inline Platform::Guid FromStringTo<Platform::Guid>(Platform::String^ str)
00107         {
00108             using namespace Platform;
00109
00110             if (str->Length() != 38)
00111             {
00112                 throw ref new InvalidArgumentException;
00113             }
00114             std::wstring ws(str->Data());
00115             if (ws[0] != L'{' || ws[37] != L'}' || ws[9] != L'-' || ws[14] != L'-' || ws[19] != L'-' || ws[24] != L'-')
00116             {
00117                 throw ref new InvalidArgumentException;
00118             }
00119             ws[0] = ws[37] = ws[9] = ws[14] = ws[19] =ws[24] = L' ';
00120             std::wistringstream wiss(ws);
00121             unsigned int a = 0;
00122             unsigned short b = 0;
00123             unsigned short c = 0;
00124             unsigned short d = 0;
00125             unsigned long long e = 0;
00126             static_assert(sizeof(d) == sizeof(char) * 2, "sizeof(d) == sizeof(char) * 2");
00127             static_assert(sizeof(e) == sizeof(char) * 8, "sizeof(e) == sizeof(char) * 8");
00128             wiss >> std::hex >> a >> b >> c >> d >> e;
00129             unsigned char *ad = (unsigned char*)(&d);
00130             unsigned char *ae = (unsigned char*)(&e);
00131             return Platform::Guid(a, b, c, ad[1], ad[0], ae[5], ae[4], ae[3], ae[2], ae[1], ae[0]);
00132         }
00133
00134         inline Platform::Object^ ConvertStringToObject(Windows::Foundation::PropertyType type, Platform::String^ str)
00135         {
00136             using namespace Platform;
00137             using namespace Windows::Foundation;
00138
00139             if (type == PropertyType::String)
00140             {
00141                 return PropertyValue::CreateString(str);
00142             }
00143
00144             switch (type)
00145             {
00146             case PropertyType::UInt8:
00147                 return PropertyValue::CreateUInt8((unsigned char)FromStringTo<unsigned short>(str));
00148             case PropertyType::UInt16:
00149                 return PropertyValue::CreateUInt16(FromStringTo<unsigned short>(str));
00150             case PropertyType::UInt32:
00151                 return PropertyValue::CreateUInt32(FromStringTo<unsigned int>(str));
00152             case PropertyType::UInt64:
00153                 return PropertyValue::CreateUInt64(FromStringTo<unsigned long long>(str));
00154             case PropertyType::Int16:
00155                 return PropertyValue::CreateInt16(FromStringTo<short>(str));
00156             case PropertyType::Int32:
00157                 return PropertyValue::CreateInt32(FromStringTo<int>(str));
00158             case PropertyType::Int64:
00159                 return PropertyValue::CreateInt64(FromStringTo<long long>(str));
00160             case PropertyType::Single:
00161                 return PropertyValue::CreateSingle(FromStringTo<float>(str));
00162             case PropertyType::Double:
00163                 return PropertyValue::CreateDouble(FromStringTo<double>(str));
00164             case PropertyType::Boolean:
00165                 return PropertyValue::CreateBoolean(FromStringTo<bool>(str));
00166             case PropertyType::Char16:
00167                 return PropertyValue::CreateChar16(str->Data()[0]);
00168             case PropertyType::Guid:
00169                 return PropertyValue::CreateGuid(FromStringTo<Guid>(str));
00170             default:
00171                 throw ref new Platform::InvalidCastException;
00172             }
00173         }
00174
00175         inline Platform::String^ ConvertPropertyValueToString(Windows::Foundation::IPropertyValue^ pv)
00176         {
00177             using namespace Platform;
00178             using namespace Windows::Foundation;
00179
00180             String^ valueString;
00181
00182             switch (pv->Type)
00183             {
00184             case PropertyType::String:
00185                 valueString = pv->GetString();
00186                 break;
00187
00188             case PropertyType::UInt8:
00189             case PropertyType::UInt16:
00190             case PropertyType::UInt32:
00191             case PropertyType::UInt64:
00192                 valueString = ToString(pv->GetUInt64());
00193                 break;
00194
00195             case PropertyType::Int16:
00196             case PropertyType::Int32:
00197             case PropertyType::Int64:
00198                 valueString = ToString(pv->GetInt64());
00199                 break;
00200
00201             case PropertyType::Single:
00202                 valueString = ToString(pv->GetSingle());
00203                 break;
00204
00205             case PropertyType::Double:
00206                 valueString = ToString(pv->GetDouble());
00207                 break;
00208
00209             case PropertyType::Boolean:
00210                 valueString = ToString(pv->GetBoolean());
00211                 break;
00212
00213             case PropertyType::Char16:
00214                 wchar_t buffer[2];
00215                 buffer[0] = pv->GetChar16();
00216                 buffer[1] = 0;
00217                 valueString = ref new String(buffer);
00218                 break;
00219
00220             case PropertyType::Guid:
00221                 valueString = pv->GetGuid().ToString();
00222                 break;
00223
00224             default:
00225                 throw ref new InvalidCastException;
00226             }
00227
00228             return valueString;
00229         }
00230
00231         inline Windows::Data::Xml::Dom::XmlElement^ CreateXmlElementFromObject(Windows::Data::Xml::Dom::XmlDocument^ doc, Platform::String^ name, Platform::Object^ value)
00232         {
00233             using namespace Platform;
00234             using namespace Windows::Foundation;
00235             using namespace Windows::Data::Xml::Dom;
00236
00237             XmlElement^ element = doc->CreateElement("item");
00238             element->SetAttribute("name", name);
00239
00240             IPropertyValue^ pv = (IPropertyValue^)value;
00241             element->SetAttribute("type", ToString((int)pv->Type));
00242             element->SetAttribute("value", ConvertPropertyValueToString(pv));
00243
00244             return element;
00245         }
00246
00247         inline concurrency::task<void> SerializeSessionState(Windows::Storage::IStorageFile^ file)
00248         {
00249             using namespace Windows::Data::Xml::Dom;
00250             using namespace Windows::Foundation;
00251             namespace WFC = Windows::Foundation::Collections;
00252             typedef Windows::Foundation::Collections::IKeyValuePair<Platform::String^, Platform::Object^> KVPair;
00253
00254             XmlDocument^ doc = ref new XmlDocument;
00255             doc->AppendChild(doc->CreateElement("items"));
00256             auto sessionState = SuspensionManager::SessionState();
00257
00258             std::for_each(WFC::begin(sessionState), WFC::end(sessionState), [doc](KVPair^ item)
00259             {
00260                 doc->DocumentElement->AppendChild(CreateXmlElementFromObject(doc, item->Key, item->Value));
00261             });
00262
00263             return concurrency::task<void>(doc->SaveToFileAsync(file));
00264         }
00265
00266         inline Windows::Foundation::PropertyType PropertyTypeFromString(Platform::String^ str)
00267         {
00268             int value = FromStringTo<int>(str);
00269             return (Windows::Foundation::PropertyType)value;
00270         }
00271
00272         inline concurrency::task<void> DeserializeSessionState(Windows::Storage::IStorageFile^ file)
00273         {
00274             using namespace Platform;
00275             using namespace Windows::Foundation;
00276             using namespace Windows::Data::Xml::Dom;
00277             namespace WFC = Windows::Foundation::Collections;
00278
00279             concurrency::task<XmlDocument^> loadFileTask(XmlDocument::LoadFromFileAsync(file));
00280             return loadFileTask.then([=](concurrency::task<XmlDocument^> docTask)
00281             {
00282                 try
00283                 {
00284                     auto doc = docTask.get();
00285                     auto items = doc->SelectNodes("/items/item");
00286                     auto sessionState = SuspensionManager::SessionState();
00287
00288                     std::for_each(WFC::begin(items), WFC::end(items), [sessionState](IXmlNode^ node)
00289                     {
00290                         auto element = (IXmlElement^)node;
00291                         String^ name = element->GetAttribute("name");
00292                         String^ value = element->GetAttribute("value");
00293                         PropertyType type = PropertyTypeFromString(element->GetAttribute("type"));
00294
00295                         Object^ valueObject = ConvertStringToObject(type, value);
00296                         sessionState->Insert(name, valueObject);
00297                     });
00298
00299                 }
00300                 catch (Platform::Exception^)
00301                 {
00302                     // Restoring is best effort
00303                 }
00304             });
00305         }
00306     } // namespace Details
00307 } // namespace CppSamplesUtils
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/SampleOverlay.h Source File

  • DXGI swap chain rotation

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 ref class SampleOverlay
00013 {
00014 internal:
00015     SampleOverlay();
00016
00017     void Initialize(
00018         _In_ ID2D1Device*         d2dDevice,
00019         _In_ ID2D1DeviceContext*  d2dContext,
00020         _In_ IWICImagingFactory*  wicFactory,
00021         _In_ IDWriteFactory*      dwriteFactory,
00022         _In_ Platform::String^    caption
00023         );
00024
00025     void ResetDirectXResources();
00026
00027     void UpdateForWindowSizeChange();
00028
00029     void Render(D2D1::Matrix3x2F& transform);
00030
00031     float GetTitleHeightInDips();
00032
00033 private:
00034
00035     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00036     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00037     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00038     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00039     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00040     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00041
00042     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00043     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00044     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00045
00046     UINT                                            m_idIncrement;
00047     bool                                            m_drawOverlay;
00048     Platform::String^                               m_sampleName;
00049     float                                           m_padding;
00050     float                                           m_textVerticalOffset;
00051     D2D1_SIZE_F                                     m_logoSize;
00052     float                                           m_overlayWidth;
00053 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/pch.cpp Source File

  • Number formatting and parsing

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/App.xaml.cpp Source File

  • XAML user and custom controls

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/MainPage.xaml.cpp Source File

  • Programmatic file search

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/Constants.h Source File

  • Connecting with WebSockets

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"WebSocket");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042         bool TryGetUri(Platform::String^ uriString, Windows::Foundation::Uri^* uri)
00043         {
00044             *uri = nullptr;
00045
00046             Windows::Foundation::Uri^ webSocketUri;
00047
00048             // Create a Uri instance and catch exceptions related to invalid input. This method returns 'true'
00049             // if the Uri instance was successfully created and 'false' otherwise.
00050             try
00051             {
00052                 webSocketUri = ref new Windows::Foundation::Uri(StringTrimmer::Trim(uriString));
00053             }
00054             catch (Platform::NullReferenceException^ exception)
00055             {
00056                 NotifyUser("Error: URI must not be null or empty.", NotifyType::ErrorMessage);
00057                 return false;
00058             }
00059             catch (Platform::InvalidArgumentException^ exception)
00060             {
00061                 NotifyUser("Error: Invalid URI", NotifyType::ErrorMessage);
00062                 return false;
00063             }
00064
00065             if (webSocketUri->Fragment != "")
00066             {
00067                 NotifyUser("Error: URI fragments not supported in WebSocket URIs.", NotifyType::ErrorMessage);
00068                 return false;
00069             }
00070
00071             Platform::String^ wsScheme = "ws";
00072             Platform::String^ wssScheme = "wss";
00073             Platform::String^ scheme = webSocketUri->SchemeName;
00074
00075             // Uri->SchemeName returns the canonicalized scheme name so we can use case-sensitive, ordinal string
00076             // comparison.
00077             if ((CompareStringOrdinal(scheme->Begin(), scheme->Length(), wsScheme->Begin(), wsScheme->Length(), false) != CSTR_EQUAL) &&
00078                 (CompareStringOrdinal(scheme->Begin(), scheme->Length(), wssScheme->Begin(), wssScheme->Length(), false) != CSTR_EQUAL))
00079             {
00080                 NotifyUser("Error: WebSockets only support ws:// and wss:// schemes.", NotifyType::ErrorMessage);
00081                 return false;
00082             }
00083
00084             *uri = webSocketUri;
00085
00086             return true;
00087         }
00088
00089     private:
00090         static Platform::Array<Scenario>^ scenariosInner;
00091     };
00092
00093     class StringTrimmer
00094     {
00095     public:
00096         static Platform::String^ Trim(Platform::String^ s)
00097         {
00098             const WCHAR* first = s->Begin();
00099             const WCHAR* last = s->End();
00100
00101             while (first != last && iswspace(*first))
00102             {
00103                 ++first;
00104             }
00105
00106             while (first != last && iswspace(last[-1]))
00107             {
00108                 --last;
00109             }
00110
00111             return ref new Platform::String(first, last - first);
00112         }
00113     };
00114 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/pch.cpp Source File

  • USSD message management

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ContinuationPage.xaml.cpp Source File

  • Print

ContinuationPage.xaml.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // ContinuationPage.xaml.cpp
00003 // Implementation of the ContinuationPage class
00004 //
00005
00006 #include "pch.h"
00007 #include "ContinuationPage.xaml.h"
00008
00009 using namespace PrintSample;
00010
00011 using namespace Platform;
00012 using namespace Windows::Foundation;
00013 using namespace Windows::Foundation::Collections;
00014 using namespace Windows::UI::Xaml;
00015 using namespace Windows::UI::Xaml::Controls;
00016 using namespace Windows::UI::Xaml::Controls::Primitives;
00017 using namespace Windows::UI::Xaml::Data;
00018 using namespace Windows::UI::Xaml::Input;
00019 using namespace Windows::UI::Xaml::Media;
00020 using namespace Windows::UI::Xaml::Navigation;
00021
00022 ContinuationPage::ContinuationPage()
00023 {
00024     InitializeComponent();
00025 }
00026
00027 /// <summary>
00028 /// Creates a continuation page and links text-flow to a text flow container
00029 /// </summary>
00030 /// <param name="textLinkContainer">Text link container which will flow text into this page</param>
00031 ContinuationPage::ContinuationPage(RichTextBlockOverflow^ textLinkContainer)
00032 {
00033     InitializeComponent();
00034     textLinkContainer->OverflowContentTarget = continuationPageLinkedContainer;
00035 }
00036
00037 /// <summary>
00038 /// Invoked when this page is about to be displayed in a Frame.
00039 /// </summary>
00040 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00041 /// property is typically used to configure the page.</param>
00042 void ContinuationPage::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     (void) e;    // Unused parameter
00045 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++,JavaScript/DLL/public.h Source File

  • Custom driver access
  • C++,JavaScript
  • DLL

public.h

Go to the documentation of this file.
00001 /*++
00002
00003 Copyright (c) Microsoft Corporation.  All rights reserved.
00004
00005 Module Name:
00006
00007     public.h
00008
00009 Abstract:
00010
00011     Public definitions for the OSR_FX2 device operations.
00012
00013 Environment:
00014
00015     User & Kernel mode
00016
00017 --*/
00018
00019 #ifndef _PUBLIC_H
00020 #define _PUBLIC_H
00021
00022 #include <initguid.h>
00023
00024 #include "WudfOsrUsbPublic.h"
00025
00026
00027 //
00028 // Define the structures that will be used by the IOCTL
00029 //  interface to the driver
00030 //
00031
00032 //
00033 // BAR_GRAPH_STATE
00034 //
00035 // BAR_GRAPH_STATE is a bit field structure with each
00036 //  bit corresponding to one of the bar graph on the
00037 //  OSRFX2 Development Board
00038 //
00039 #include <pshpack1.h>
00040
00041 #pragma warning( push )
00042 #pragma warning( disable : 4201 ) // nameless struct/union
00043 #pragma warning( disable : 4214 ) // bit-field type other than int
00044
00045 typedef struct _BAR_GRAPH_STATE {
00046
00047     union {
00048
00049         struct {
00050             //
00051             // Individual bars starting from the
00052             //  top of the stack of bars
00053             //
00054             // NOTE: There are actually 10 bars,
00055             //  but the very top two do not light
00056             //  and are not counted here
00057             //
00058             UCHAR Bar1 : 1;
00059             UCHAR Bar2 : 1;
00060             UCHAR Bar3 : 1;
00061             UCHAR Bar4 : 1;
00062             UCHAR Bar5 : 1;
00063             UCHAR Bar6 : 1;
00064             UCHAR Bar7 : 1;
00065             UCHAR Bar8 : 1;
00066         };
00067
00068         //
00069         // The state of all the bar graph as a single
00070         // UCHAR
00071         //
00072         UCHAR BarsAsUChar;
00073
00074     };
00075
00076 }BAR_GRAPH_STATE, *PBAR_GRAPH_STATE;
00077
00078 //
00079 // SWITCH_STATE
00080 //
00081 // SWITCH_STATE is a bit field structure with each
00082 //  bit corresponding to one of the switches on the
00083 //  OSRFX2 Development Board
00084 //
00085 typedef struct _SWITCH_STATE {
00086
00087     union {
00088         struct {
00089             //
00090             // Individual switches starting from the
00091             //  left of the set of switches
00092             //
00093             UCHAR Switch1 : 1;
00094             UCHAR Switch2 : 1;
00095             UCHAR Switch3 : 1;
00096             UCHAR Switch4 : 1;
00097             UCHAR Switch5 : 1;
00098             UCHAR Switch6 : 1;
00099             UCHAR Switch7 : 1;
00100             UCHAR Switch8 : 1;
00101         };
00102
00103         //
00104         // The state of all the switches as a single
00105         // UCHAR
00106         //
00107         UCHAR SwitchesAsUChar;
00108
00109     };
00110
00111
00112 }SWITCH_STATE, *PSWITCH_STATE;
00113
00114 //
00115 // Seven segment display bit values.
00116 //
00117
00118 //
00119 // Undefine conflicting MFC constant
00120 //
00121 #undef SS_CENTER
00122 #undef SS_LEFT
00123 #undef SS_RIGHT
00124
00125 #define SS_TOP          0x01
00126 #define SS_TOP_LEFT     0x40
00127 #define SS_TOP_RIGHT    0x02
00128 #define SS_CENTER       0x20
00129 #define SS_BOTTOM_LEFT  0x10
00130 #define SS_BOTTOM_RIGHT 0x04
00131 #define SS_BOTTOM       0x80
00132 #define SS_DOT          0x08
00133
00134 //
00135 // FILE_PLAYBACK
00136 //
00137 // FILE_PLAYBACK structure contains the parameters for the PLAY_FILE I/O Control.
00138 //
00139
00140 typedef struct _FILE_PLAYBACK
00141 {
00142     //
00143     // The delay between changes in the display, in milliseconds.
00144     //
00145
00146     USHORT Delay;
00147
00148     //
00149     // The data file path.
00150     //
00151
00152     WCHAR Path[1];
00153 } FILE_PLAYBACK, *PFILE_PLAYBACK;
00154
00155 #include <poppack.h>
00156
00157 #define IOCTL_INDEX             0x800
00158 #define FILE_DEVICE_OSRUSBFX2   0x65500
00159
00160 #define IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
00161                                                      IOCTL_INDEX,     \
00162                                                      METHOD_BUFFERED,         \
00163                                                      FILE_READ_ACCESS)
00164
00165 #define IOCTL_OSRUSBFX2_RESET_DEVICE  CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
00166                                                      IOCTL_INDEX + 1, \
00167                                                      METHOD_BUFFERED,         \
00168                                                      FILE_WRITE_ACCESS)
00169
00170 #define IOCTL_OSRUSBFX2_REENUMERATE_DEVICE  CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00171                                                     IOCTL_INDEX  + 3,  \
00172                                                     METHOD_BUFFERED, \
00173                                                     FILE_WRITE_ACCESS)
00174
00175 #define IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00176                                                     IOCTL_INDEX  + 4, \
00177                                                     METHOD_BUFFERED, \
00178                                                     FILE_READ_ACCESS)
00179
00180
00181 #define IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00182                                                     IOCTL_INDEX + 5, \
00183                                                     METHOD_BUFFERED, \
00184                                                     FILE_WRITE_ACCESS)
00185
00186
00187 #define IOCTL_OSRUSBFX2_READ_SWITCHES   CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00188                                                     IOCTL_INDEX + 6, \
00189                                                     METHOD_BUFFERED, \
00190                                                     FILE_READ_ACCESS)
00191
00192
00193 #define IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00194                                                     IOCTL_INDEX + 7, \
00195                                                     METHOD_BUFFERED, \
00196                                                     FILE_READ_ACCESS)
00197
00198
00199 #define IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00200                                                     IOCTL_INDEX + 8, \
00201                                                     METHOD_BUFFERED, \
00202                                                     FILE_WRITE_ACCESS)
00203
00204 #define IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00205                                                     IOCTL_INDEX + 9, \
00206                                                     METHOD_OUT_DIRECT, \
00207                                                     FILE_READ_ACCESS)
00208
00209 #define IOCTL_OSRUSBFX2_PLAY_FILE CTL_CODE(FILE_DEVICE_OSRUSBFX2,   \
00210                                            IOCTL_INDEX + 10,        \
00211                                            METHOD_BUFFERED,         \
00212                                            FILE_WRITE_ACCESS)
00213
00214 #pragma warning(pop)
00215
00216 #endif
00217
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/App.xaml.h Source File

  • StreamSocket

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace StreamSocketSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028     public:
00029         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00030         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00031     private:
00032         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00033     };
00034 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/pch.cpp Source File

  • Direct2D composite effect modes

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/pch.h Source File

  • Edge gesture invocation

pch.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // pch.h
00010 // Header for standard system include files.
00011 //
00012
00013 #pragma once
00014 #include "CppSamplesUtils.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/pch.h Source File

  • Animation metrics

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include <sstream>
00021 #include "Common\LayoutAwarePage.h"
00022 #include "Common\SuspensionManager.h"
00023 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Print/C++/ScenarioOutput2.xaml.h Source File

  • Print

ScenarioOutput2.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario2Output.xaml.h
00010 // Declaration of the Scenario2Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput2.g.h"
00017
00018 namespace PrintSample
00019 {
00020     public ref class ScenarioOutput2 sealed
00021     {
00022     public:
00023         ScenarioOutput2();
00024     private:
00025         ~ScenarioOutput2();
00026     };
00027 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/SampleOverlay.cpp Source File

  • XAudio2 audio file playback

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/audiovideoptr.xaml.h Source File

  • PlayToReceiver

audiovideoptr.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017 #include <agile.h>
00018 #include "pch.h"
00019 #include "AudioVideoPTR.g.h"
00020 #include "MainPage.xaml.h"
00021 using namespace Windows::Media::PlayTo;
00022 using namespace Windows::UI::Xaml::Media::Imaging;
00023 namespace SDKSample
00024 {
00025     namespace PlayToreceiver
00026     {
00027         /// <summary>
00028         /// An empty page that can be used on its own or navigated to within a Frame.
00029         /// </summary>
00030         [Windows::Foundation::Metadata::WebHostHidden]
00031         public ref class Scenario1 sealed
00032         {
00033         public:
00034             Scenario1();
00035
00036         protected:
00037             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038         private:
00039             MainPage^ rootPage;
00040             Platform::Agile<Windows::Media::PlayTo::PlayToReceiver> receiver;
00041             bool IsReceiverStarted;
00042             bool IsSeeking;
00043             bool IsMediaJustLoaded;
00044             bool IsPlayReceivedPreMediaLoaded;
00045             double bufferedPlaybackRate;
00046             enum MediaType { None, Image, AudioVisual};
00047             MediaType currentType;
00048             BitmapImage^ imageRecd;
00049
00050             void InitialisePlayToReceiver();
00051             void startPlayToReceiver(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00052             void stopPlayToReceiver(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00053
00054             //MediaElement Event Handlers
00055             void dmrVideo_VolumeChanged(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00056             void dmrVideo_RateChanged(Platform::Object^ sender, Windows::UI::Xaml::Media::RateChangedRoutedEventArgs^ e);
00057             void dmrVideo_MediaOpened(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00058             void dmrVideo_CurrentStateChanged(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00059             void dmrVideo_MediaEnded(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00060             void dmrVideo_MediaFailed(Platform::Object^ sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^ e);
00061             void dmrVideo_SeekCompleted(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062
00063             //Bitmap Event Handlers
00064             void btmapImage_ImageOpened(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00065
00066             //PlayToReceiver Event Handlers
00067             void receiver_PlayRequested(PlayToReceiver^, Object^);
00068             void receiver_PauseRequested(PlayToReceiver^, Object^);
00069             void receiver_StopRequested(PlayToReceiver^, Object^);
00070             void receiver_TimeUpdateRequested(PlayToReceiver^, Object^);
00071             void receiver_CurrentTimeChangeRequested(PlayToReceiver^, CurrentTimeChangeRequestedEventArgs^);
00072             void receiver_SourceChangeRequested(PlayToReceiver^, SourceChangeRequestedEventArgs^);
00073             void receiver_MuteChangeRequested(PlayToReceiver^, MuteChangeRequestedEventArgs^);
00074             void receiver_PlaybackRateChangeRequested(PlayToReceiver^, PlaybackRateChangeRequestedEventArgs^);
00075             void receiver_VolumeChangeRequestedEvent(PlayToReceiver^, VolumeChangeRequestedEventArgs^);
00076             void dmrImage_ImageFailed_1(Platform::Object^ sender, Windows::UI::Xaml::ExceptionRoutedEventArgs^ e);
00077             void dmrVideo_DownloadProgressChanged_1(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00078         };
00079     }
00080 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/WriteReadStream.xaml.cpp Source File

  • Reading and writing data

WriteReadStream.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // WriteReadStream.xaml.cpp
00013 // Implementation of the WriteReadStream class
00014 //
00015
00016 #include "pch.h"
00017 #include "WriteReadStream.xaml.h"
00018
00019 using namespace Concurrency;
00020 using namespace SDKSample::DataReaderWriter;
00021 using namespace Platform;
00022 using namespace Windows::Storage::Streams;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 Array<String^>^ _inputElements = ref new Array<String^>
00028 {
00029     "Hello", "World", "1 2 3 4 5", "Très bien!", "Goodbye"
00030 };
00031
00032 WriteReadStream::WriteReadStream()
00033 {
00034     InitializeComponent();
00035
00036     // Populate the text block with the input elements.
00037     ElementsToWrite->Text = "";
00038     for (unsigned int i = 0; i < _inputElements->Length; i++)
00039     {
00040         ElementsToWrite->Text += _inputElements[i] + ";";
00041     }
00042 }
00043
00044 /// <summary>
00045 /// Invoked when this page is about to be displayed in a Frame.
00046 /// </summary>
00047 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00048 /// property is typically used to configure the page.</param>
00049 void WriteReadStream::OnNavigatedTo(NavigationEventArgs^ e)
00050 {
00051     // Get a pointer to our main page.
00052     rootPage = MainPage::Current;
00053 }
00054
00055 /// <summary>
00056 /// This is the click handler for the 'Copy Strings' button.  Here we will parse the
00057 /// strings contained in the ElementsToWrite text block, write them to a stream using
00058 /// DataWriter, retrieve them using DataReader, and output the results in the
00059 /// ElementsRead text block.
00060 /// </summary>
00061 /// <param name="sender">Contains information about the button that fired the event.</param>
00062 /// <param name="e">Contains state information and event data associated with a routed event.</param>
00063 void SDKSample::DataReaderWriter::WriteReadStream::TransferData(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00064 {
00065     // Initialize the in-memory stream where data will be stored.
00066     InMemoryRandomAccessStream^ stream = ref new InMemoryRandomAccessStream();
00067
00068     // Create the DataWriter object backed by the in-memory stream.  When
00069     // dataWriter is deleted, it will also close the underlying stream.
00070     DataWriter^ dataWriter = ref new DataWriter(stream);
00071     dataWriter->UnicodeEncoding = UnicodeEncoding::Utf8;
00072     dataWriter->ByteOrder = ByteOrder::LittleEndian;
00073
00074     // Create the data reader by using the input stream set at position 0 so that
00075     // the stream will be read from the beginning regardless of where the position
00076     // the original stream ends up in after the store.
00077     IInputStream^ inputStream = stream->GetInputStreamAt(0);
00078     DataReader^ dataReader = ref new DataReader(inputStream);
00079     // The encoding and byte order need to match the settings of the writer we previously used.
00080     dataReader->UnicodeEncoding = UnicodeEncoding::Utf8;
00081     dataReader->ByteOrder = ByteOrder::LittleEndian;
00082
00083     // Write the input data to the output stream.  Serialize the elements by writing
00084     // each string separately, preceded by its length.
00085     for (unsigned int i = 0; i < _inputElements->Length; i++)
00086     {
00087         unsigned int inputElementSize = dataWriter->MeasureString(_inputElements[i]);
00088         dataWriter->WriteUInt32(inputElementSize);
00089         dataWriter->WriteString(_inputElements[i]);
00090     }
00091
00092     // Send the contents of the writer to the backing stream.
00093     create_task(dataWriter->StoreAsync()).then([this, dataWriter] (unsigned int bytesStored)
00094     {
00095         // For the in-memory stream implementation we are using, the FlushAsync() call is superfluous,
00096         // but other types of streams may require it.
00097         return dataWriter->FlushAsync();
00098     }).then([this, dataReader, stream] (bool flushOp)
00099     {
00100         // Once we have written the contents successfully we load the stream.
00101         return dataReader->LoadAsync((unsigned int) stream->Size);
00102     }).then([this, dataReader] (task<unsigned int> bytesLoaded)
00103     {
00104         try
00105         {
00106             // Check for possible exceptions that could have been thrown in the async call chain.
00107             bytesLoaded.get();
00108
00109             String^ readFromStream = "";
00110
00111             // Keep reading until we consume the complete stream.
00112             while (dataReader->UnconsumedBufferLength > 0)
00113             {
00114                 // Note that the call to ReadString requires a length of "code units" to read. This
00115                 // is the reason each string is preceded by its length when "on the wire".
00116                 unsigned int bytesToRead = dataReader->ReadUInt32();
00117                 readFromStream += dataReader->ReadString(bytesToRead) + "\n";
00118             }
00119
00120             // Populate the ElementsRead text block with the items we read from the stream
00121             ElementsRead->Text = readFromStream;
00122         }
00123         catch (Exception^ e)
00124         {
00125             ElementsRead->Text = "Error: " + e->Message;
00126         }
00127     });
00128 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Face.h Source File

  • XAML DirectX 3D shooting game

Face.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Face:
00011 // This class is a specialization of GameObject that represents a parallelogram primitive.
00012 // The face is defined by three points.  It is positioned at 'origin'.  The four corners
00013 // of the face are defined at 'origin', 'p1', 'p2' and 'p1' + ('p2' - 'origin').
00014
00015 #include "GameObject.h"
00016
00017 ref class Face: public GameObject
00018 {
00019 internal:
00020     Face();
00021     Face(
00022         DirectX::XMFLOAT3 origin,
00023         DirectX::XMFLOAT3 p1,
00024         DirectX::XMFLOAT3 p2
00025         );
00026
00027     void SetPlane(
00028         DirectX::XMFLOAT3 origin,
00029         DirectX::XMFLOAT3 p1,
00030         DirectX::XMFLOAT3 p2
00031         );
00032
00033     virtual bool IsTouching(
00034         DirectX::XMFLOAT3 point,
00035         float radius,
00036         _Out_ DirectX::XMFLOAT3 *contact,
00037         _Out_ DirectX::XMFLOAT3 *normal
00038         ) override;
00039
00040 protected:
00041     virtual void UpdatePosition() override;
00042
00043 private:
00044     void UpdateMatrix();
00045
00046     DirectX::XMFLOAT3   m_widthVector;
00047     DirectX::XMFLOAT3   m_heightVector;
00048     DirectX::XMFLOAT3   m_normal;
00049     DirectX::XMFLOAT3   m_point[4];
00050     float               m_width;
00051     float               m_height;
00052     DirectX::XMFLOAT4X4 m_rotationMatrix;
00053 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/Scenario1.xaml.cpp Source File

  • Media Play To

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::PlayTo;
00020
00021 using namespace Windows::UI::Core;
00022 using namespace Windows::UI::ViewManagement;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::Foundation;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::Streams;
00029 using namespace Windows::Storage::Pickers;
00030 using namespace Windows::Media::PlayTo;
00031 using namespace concurrency;
00032
00033
00034 Scenario1::Scenario1()
00035 {
00036     InitializeComponent();
00037 }
00038
00039 /// <summary>
00040 /// Invoked when this page is about to be displayed in a Frame.
00041 /// </summary>
00042 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00043 /// property is typically used to configure the page.</param>
00044 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00045 {
00046     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00047     // as NotifyUser()
00048     rootPage = MainPage::Current;
00049   dispatcher = Window::Current->CoreWindow->Dispatcher;
00050   playToManager = PlayToManager::GetForCurrentView();
00051   sourceRequestedToken = playToManager->SourceRequested += ref new TypedEventHandler<PlayToManager^, PlayToSourceRequestedEventArgs^>(this, &Scenario1::playToManager_SourceRequested);
00052 }
00053
00054 void Scenario1::playToManager_SourceRequested(Windows::Media::PlayTo::PlayToManager^ sender, Windows::Media::PlayTo::PlayToSourceRequestedEventArgs^ e)
00055 {
00056   auto deferral = e->SourceRequest->GetDeferral();
00057
00058   Windows::UI::Core::DispatchedHandler^ handler = ref new Windows::UI::Core::DispatchedHandler([=] (){
00059
00060     e->SourceRequest->SetSource(VideoSource->PlayToSource);
00061     deferral->Complete();
00062
00063   }, Platform::CallbackContext::Any);
00064
00065   auto action = dispatcher->RunAsync(Windows::UI::Core::CoreDispatcherPriority::Normal, handler);
00066 }
00067
00068 void Scenario1::OnNavigatedFrom(NavigationEventArgs^ e)
00069 {
00070   playToManager->SourceRequested -= sourceRequestedToken;
00071 }
00072
00073 void Scenario1::webContent_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00074 {
00075     Button^ b = safe_cast<Button^>(sender);
00076     if (b != nullptr)
00077     {
00078     VideoSource->Source = ref new Uri("http://ie.microsoft.com/testdrive/Graphics/VideoFormatSupport/big_buck_bunny_trailer_480p_high.mp4");
00079     rootPage->NotifyUser("You are playing a web content", NotifyType::StatusMessage);
00080     }
00081 }
00082
00083
00084 void Scenario1::videoFile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00085 {
00086     Button^ b = safe_cast<Button^>(sender);
00087     if (b != nullptr)
00088     {
00089         // Verify the snapped state and unsnap if needed
00090     Windows::UI::ViewManagement::ApplicationViewState currentSnappedState = Windows::UI::ViewManagement::ApplicationView::Value;
00091         if (currentSnappedState == Windows::UI::ViewManagement::ApplicationViewState::Snapped && !Windows::UI::ViewManagement::ApplicationView::TryUnsnap()) {
00092             rootPage->NotifyUser("Cannot unsnap the app to launch the file picker", NotifyType::StatusMessage);
00093             return;
00094         }
00095
00096     FileOpenPicker^ filePicker = ref new FileOpenPicker();
00097     filePicker->SuggestedStartLocation = PickerLocationId::VideosLibrary;
00098     filePicker->FileTypeFilter->Append(".mp4");
00099     filePicker->FileTypeFilter->Append(".wmv");
00100     filePicker->ViewMode = PickerViewMode::Thumbnail;
00101
00102     task<StorageFile^>(filePicker->PickSingleFileAsync()).then(
00103       [this](StorageFile^ videoFile)
00104     {
00105       if (videoFile)
00106       {
00107         localFile = videoFile;
00108         task<IRandomAccessStream^>(videoFile->OpenAsync(FileAccessMode::Read)).then(
00109           [this](IRandomAccessStream^ stream)
00110         {
00111           if (stream)
00112           {
00113             VideoSource->SetSource(stream, localFile->ContentType);
00114             rootPage->NotifyUser("You are playing a local video file", NotifyType::StatusMessage);
00115           }
00116         });
00117       }
00118     });
00119     }
00120 }
00121
00122
00123 void Scenario1::playButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00124 {
00125   VideoSource->Play();
00126 }
00127
00128
00129 void Scenario1::pauseButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00130 {
00131   VideoSource->Pause();
00132 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/ClearScenario.xaml.cpp Source File

  • Application data

ClearScenario.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ClearScenario.xaml.cpp
00013 // Implementation of the ClearScenario class
00014 //
00015
00016 #include "pch.h"
00017 #include "ClearScenario.xaml.h"
00018
00019 using namespace SDKSample::ApplicationDataSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::Storage;
00027
00028 #define settingName   "exampleCompositeSetting"
00029 #define settingName1  "one"
00030 #define settingValue1 1
00031 #define settingName2  "hello"
00032 #define settingValue2 "world"
00033
00034 ClearScenario::ClearScenario()
00035 {
00036     InitializeComponent();
00037 }
00038
00039 /// <summary>
00040 /// Invoked when this page is about to be displayed in a Frame.
00041 /// </summary>
00042 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00043 /// property is typically used to configure the page.</param>
00044 void ClearScenario::OnNavigatedTo(NavigationEventArgs^ e)
00045 {
00046     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00047     // as NotifyUser()
00048     rootPage = MainPage::Current;
00049 }
00050
00051 void ClearScenario::Clear_Click(Object^ sender, RoutedEventArgs^ e)
00052 {
00053     concurrency::create_task(Windows::Storage::ApplicationData::Current->ClearAsync())
00054         .then([this](concurrency::task<void> result)
00055     {
00056         try
00057         {
00058             result.get();
00059             OutputTextBlock->Text = "ApplicationData has been cleared.  Visit the other scenarios to see that their data has been cleared.";
00060         }
00061         catch (Exception ^ex)
00062         {
00063             OutputTextBlock->Text = "Unable to clear settings, make sure all files are closed.";
00064         }
00065     });
00066 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/MainHubViewModel.cpp Source File

  • Hilo C++
  • Hilo

MainHubViewModel.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "MainHubViewModel.h"
00009 #include "HubPhotoGroup.h"
00010 #include "DelegateCommand.h"
00011 #include "PageType.h"
00012 #include "HubGroupType.h"
00013 #include "ImageNavigationData.h"
00014 #include "IPhoto.h"
00015
00016 using namespace Hilo;
00017 using namespace Platform;
00018 using namespace std;
00019 using namespace Windows::Foundation::Collections;
00020 using namespace Windows::UI::Xaml::Data;
00021 using namespace Windows::UI::Xaml::Input;
00022
00023 MainHubViewModel::MainHubViewModel(IObservableVector<HubPhotoGroup^>^ photoGroups, shared_ptr<ExceptionPolicy> exceptionPolicy)
00024     : m_photoGroups(photoGroups), m_photo(nullptr), ViewModelBase(exceptionPolicy)
00025 {
00026     m_navigateToPicturesCommand = ref new DelegateCommand(
00027         ref new ExecuteDelegate(this, &MainHubViewModel::NavigateToPictures),
00028         ref new CanExecuteDelegate(this, &MainHubViewModel::CanNavigateToPictures));
00029     m_cropImageCommand = ref new DelegateCommand(
00030         ref new ExecuteDelegate(this, &MainHubViewModel::CropImage),
00031         ref new CanExecuteDelegate(this, &MainHubViewModel::CanProcessImage));
00032     m_rotateImageCommand = ref new DelegateCommand(
00033         ref new ExecuteDelegate(this, &MainHubViewModel::RotateImage),
00034         ref new CanExecuteDelegate(this, &MainHubViewModel::CanProcessImage));
00035     m_cartoonizeImageCommand = ref new DelegateCommand(
00036         ref new ExecuteDelegate(this, &MainHubViewModel::CartoonizeImage),
00037         ref new CanExecuteDelegate(this, &MainHubViewModel::CanProcessImage));
00038
00039     m_pictureGroup = static_cast<HubPhotoGroup^>(m_photoGroups->GetAt(static_cast<unsigned int>(HubGroupType::Pictures)));
00040     assert(m_pictureGroup != nullptr);
00041     m_pictureGroupPropertyChangedToken = m_pictureGroup->PropertyChanged::add(ref new PropertyChangedEventHandler(this, &MainHubViewModel::OnPictureGroupPropertyChanged));
00042 }
00043
00044 MainHubViewModel::~MainHubViewModel()
00045 {
00046     if (nullptr != m_pictureGroup)
00047     {
00048         m_pictureGroup->PropertyChanged::remove(m_pictureGroupPropertyChangedToken);
00049     }
00050 }
00051
00052 IObservableVector<HubPhotoGroup^>^ MainHubViewModel::PhotoGroups::get()
00053 {
00054     return m_photoGroups;
00055 }
00056
00057 Object^ MainHubViewModel::SelectedItem::get()
00058 {
00059     return m_photo;
00060 }
00061
00062 void MainHubViewModel::SelectedItem::set(Object^ value)
00063 {
00064     if (m_photo != value)
00065     {
00066         ViewModelBase::m_isAppBarOpen = false;
00067         m_photo = dynamic_cast<IPhoto^>(value);
00068         bool result = CanProcessImage(nullptr);
00069         m_rotateImageCommand->CanExecute(result);
00070         m_cropImageCommand->CanExecute(result);
00071         m_cartoonizeImageCommand->CanExecute(result);
00072         IsAppBarEnabled = value != nullptr;
00073         IsAppBarOpen = value != nullptr;
00074         IsAppBarSticky = value != nullptr;
00075         OnPropertyChanged("SelectedItem");
00076     }
00077 }
00078
00079 ICommand^ MainHubViewModel::NavigateToPicturesCommand::get()
00080 {
00081     return m_navigateToPicturesCommand;
00082 }
00083
00084 ICommand^ MainHubViewModel::CropImageCommand::get()
00085 {
00086     return m_cropImageCommand;
00087 }
00088
00089 ICommand^ MainHubViewModel::RotateImageCommand::get()
00090 {
00091     return m_rotateImageCommand;
00092 }
00093
00094 ICommand^ MainHubViewModel::CartoonizeImageCommand::get()
00095 {
00096     return m_cartoonizeImageCommand;
00097 }
00098
00099 void MainHubViewModel::NavigateToPictures(Object^ parameter)
00100 {
00101     ViewModelBase::GoToPage(PageType::Browse, nullptr);
00102 }
00103
00104 bool MainHubViewModel::CanNavigateToPictures(Object^ parameter)
00105 {
00106     return (m_pictureGroup->Items->Size > 0);
00107 }
00108
00109 void MainHubViewModel::CropImage(Object^ parameter)
00110 {
00111     ImageNavigationData data(m_photo);
00112     ViewModelBase::GoToPage(PageType::Crop, data.SerializeToString());
00113 }
00114
00115 void MainHubViewModel::RotateImage(Object^ parameter)
00116 {
00117     ImageNavigationData data(m_photo);
00118     ViewModelBase::GoToPage(PageType::Rotate, data.SerializeToString());
00119 }
00120
00121 void MainHubViewModel::CartoonizeImage(Object^ parameter)
00122 {
00123     ImageNavigationData data(m_photo);
00124     ViewModelBase::GoToPage(PageType::Cartoonize, data.SerializeToString());
00125 }
00126
00127 bool MainHubViewModel::CanProcessImage(Object^ parameter)
00128 {
00129     return (m_photo != nullptr && !m_photo->IsInvalidThumbnail);
00130 }
00131
00132 void MainHubViewModel::OnPictureGroupPropertyChanged(Object^ sender, PropertyChangedEventArgs^ e)
00133 {
00134     if (e->PropertyName == "Items")
00135     {
00136         m_navigateToPicturesCommand->CanExecute(nullptr);
00137     }
00138 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/Properties/AssemblyInfo.cs Source File

  • Media extensions
  • C#,C++
  • Properties

AssemblyInfo.cs

Go to the documentation of this file.
00001 ﻿using System.Reflection;
00002 using System.Runtime.CompilerServices;
00003 using System.Runtime.InteropServices;
00004
00005 // General Information about an assembly is controlled through the following
00006 // set of attributes. Change these attribute values to modify the information
00007 // associated with an assembly.
00008 [assembly: AssemblyTitle("WebView")]
00009 [assembly: AssemblyDescription("")]
00010 [assembly: AssemblyConfiguration("")]
00011 [assembly: AssemblyCompany("")]
00012 [assembly: AssemblyProduct("WebView")]
00013 [assembly: AssemblyCopyright("")]
00014 [assembly: AssemblyTrademark("")]
00015 [assembly: AssemblyCulture("")]
00016
00017 // Version information for an assembly consists of the following four values:
00018 //
00019 //      Major Version
00020 //      Minor Version
00021 //      Build Number
00022 //      Revision
00023 //
00024 // You can specify all the values or you can default the Build and Revision Numbers
00025 // by using the '*' as shown below:
00026 // [assembly: AssemblyVersion("1.0.*")]
00027 [assembly: AssemblyVersion("1.0.0.0")]
00028 [assembly: AssemblyFileVersion("1.0.0.0")]
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Layer.cpp Source File

  • Direct2D magazine app

Layer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Windows::Data::Xml::Dom;
00011
00012 Layer::Layer() :
00013     Element(),
00014     m_initialOpacity(1.0f),
00015     m_currentOpacity(m_initialOpacity)
00016 {
00017 }
00018
00019 bool Layer::AcceptChildNode(
00020     _In_ Document^ document,
00021     _In_ IXmlNode^ childXmlNode
00022     )
00023 {
00024     if (childXmlNode->NodeType == NodeType::ElementNode)
00025     {
00026         XmlElement^ xmlElement = dynamic_cast<XmlElement^>(childXmlNode);
00027
00028         Element^ child = nullptr;
00029         Platform::String^ elementName = xmlElement->TagName;
00030
00031         if (elementName != nullptr)
00032         {
00033             if (elementName == "list")
00034             {
00035                 child = Element::Create<List>(document, childXmlNode);
00036             }
00037             else if (elementName == "rect")
00038             {
00039                 child = Element::Create<Rectangle>(document, childXmlNode);
00040             }
00041         }
00042
00043         if (child == nullptr)
00044         {
00045             return false;
00046         }
00047
00048         AddChild(child);
00049     }
00050
00051     return true;
00052 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/CartoonEffect/AmpPixel.h Source File

  • Hilo C++
  • CartoonEffect

AmpPixel.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #define C_WR 0.229F
00010 #define C_WB 0.114F
00011 #define C_WG (1.0F - C_WR - C_WB)
00012 #define C_UMAX 0.436F
00013 #define C_VMAX 0.615F
00014
00015 // Data structure used to store pixel information that can be used on the GPU
00016 struct AmpPixel
00017 {
00018     float y; // Luma
00019     float u; // Blue difference + 0.5
00020     float v; // Red difference + 0.5
00021
00022     float r; // Red
00023     float g; // Green
00024     float b; // Blue
00025
00026     AmpPixel() restrict(cpu, amp) : y(0), u(0), v(0), r(0), g(0), b(0) {}
00027
00028     // Set YUV and RGB values from given RGB values
00029     inline void SetFromRGB(float r, float g, float b) restrict(cpu, amp)
00030     {
00031         y = C_WR * r + C_WB * b + C_WG * g;
00032         u = C_UMAX * (b - y) / (1 - C_WB) + 0.5F;
00033         v = C_VMAX * (r - y) / (1 - C_WR) + 0.5F;
00034         this->r = r;
00035         this->g = g;
00036         this->b = b;
00037     }
00038
00039     // Update the RGB values based on the current YUV values
00040     inline void UpdateRGB() restrict(cpu, amp)
00041     {
00042         float u = this->u - 0.5F;
00043         float v = this->v - 0.5F;
00044         r = y   + v * (1 - C_WR) / C_VMAX;
00045         g = y   - u * C_WB * (1 - C_WB) / C_WG * C_UMAX
00046             - v * C_WR * (1 - C_WR) / C_WG * C_VMAX;
00047         b = y   + u * (1 - C_WB) / C_UMAX;
00048     }
00049 };
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/AudioSource.xaml.cs Source File

  • MediaStreamSource media extension
  • C#,C++

AudioSource.xaml.cs

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using Windows.UI.Xaml;
00012 using Windows.UI.Xaml.Controls;
00013 using Windows.UI.Xaml.Navigation;
00014 using SDKTemplate;
00015 using System;
00016
00017 namespace MediaStreamSource
00018 {
00019     /// <summary>
00020     /// An empty page that can be used on its own or navigated to within a Frame.
00021     /// </summary>
00022     public sealed partial class AudioSource : SDKTemplate.Common.LayoutAwarePage
00023     {
00024         // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00025         // as NotifyUser()
00026         MainPage rootPage = MainPage.Current;
00027
00028         public AudioSource()
00029         {
00030             this.InitializeComponent();
00031         }
00032
00033         /// <summary>
00034         /// Invoked when this page is about to be displayed in a Frame.
00035         /// </summary>
00036         /// <param name="e">Event data that describes how this page was reached.  The Parameter
00037         /// property is typically used to configure the page.</param>
00038         protected override void OnNavigatedTo(NavigationEventArgs e)
00039         {
00040         }
00041
00042         /// <summary>
00043         /// This is the click handler for the 'Default' button.  You would replace this with your own handler
00044         /// if you have a button or buttons on this page.
00045         /// </summary>
00046         /// <param name="sender"></param>
00047         /// <param name="e"></param>
00048         private void Start_Click(object sender, RoutedEventArgs e)
00049         {
00050             MediaStreamSource.SetSource(Media, new PcmSource());
00051         }
00052
00053         /// <summary>
00054         /// This is the click handler for the 'Other' button.  You would replace this with your own handler
00055         /// if you have a button or buttons on this page.
00056         /// </summary>
00057         /// <param name="sender"></param>
00058         /// <param name="e"></param>
00059         private void Stop_Click(object sender, RoutedEventArgs e)
00060         {
00061             MediaStreamSource.SetSource(Media, null);
00062         }
00063     }
00064 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/Scenario1.xaml.h Source File

  • Compression

Scenario1.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Compression
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039
00040             void DoScenario(Windows::Storage::Compression::CompressAlgorithm Algorithm);
00041
00042             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void Xpress_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044             void XpressHuff_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045             void Mszip_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046             void Lzms_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047          };
00048     }
00049 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

anonymous_namespace{SoundFileReader.cpp}::ChunkHeader Member List

This is the complete list of members for anonymous_namespace{SoundFileReader.cpp}::ChunkHeader, including all inherited members.
size | anonymous_namespace{SoundFileReader.cpp}::ChunkHeader
tag | anonymous_namespace{SoundFileReader.cpp}::ChunkHeader
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::ELS::sealed Member List

This is the complete list of members for SDKSample::ELS::sealed, including all inherited members.
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ELS::sealed | [private]
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ELS::sealed | [private]
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::ELS::sealed | [private]
LanguageDetection() | SDKSample::ELS::sealed |
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ELS::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ELS::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::ELS::sealed | [protected, virtual]
rootPage | SDKSample::ELS::sealed | [private]
ScriptDetection() | SDKSample::ELS::sealed |
Transliteration() | SDKSample::ELS::sealed |
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

StopwatchTimer Member List

This is the complete list of members for StopwatchTimer, including all inherited members.
CalculateSize() | TextElement | [protected, virtual]
CreateTextLayout() | TextElement | [protected]
ElementBase() | ElementBase | [protected]
FadeOut(float fadeOutTime) | TextElement |
GetBounds() | ElementBase |
GetElapsedTime() const | StopwatchTimer | [inline]
GetFormattedTime(WCHAR *buffer, int length) const | StopwatchTimer |
GetFormattedTime(WCHAR(&buffer)[_Len]) const | StopwatchTimer | [inline]
GetFormattedTime(WCHAR *buffer, int length, float time) | StopwatchTimer | [static]
GetFormattedTime(WCHAR(&buffer)[_Len], float time) | StopwatchTimer | [inline, static]
GetTextStyle() | TextElement | [inline]
Initialize() | StopwatchTimer | [virtual]
IsVisible() const | ElementBase | [inline]
m_active | StopwatchTimer | [protected]
m_alignment | ElementBase | [protected]
m_container | ElementBase | [protected]
m_elapsedTime | StopwatchTimer | [protected]
m_fadeOutTime | TextElement | [protected]
m_fadeOutTimeElapsed | TextElement | [protected]
m_fadeStartingOpacity | TextElement | [protected]
m_isFadingOut | TextElement | [protected]
m_shadowColorBrush | TextElement | [protected]
m_size | ElementBase | [protected]
m_text | TextElement | [protected]
m_textColorBrush | TextElement | [protected]
m_textExtents | TextElement | [protected]
m_textLayout | TextElement | [protected]
m_textStyle | TextElement | [protected]
m_visible | ElementBase | [protected]
Render() | StopwatchTimer | [virtual]
Reset() | StopwatchTimer |
SetAlignment(AlignType horizontal, AlignType vertical) | ElementBase |
SetContainer(const D2D1_RECT_F &container) | ElementBase | [virtual]
SetElapsedTime(float time) | StopwatchTimer | [inline]
SetText(__nullterminated WCHAR *text) | TextElement |
SetText(Platform::String^text) | TextElement |
SetTextColor(const D2D1_COLOR_F &textColor) | TextElement |
SetTextOpacity(float textOpacity) | TextElement |
SetVisible(bool visible) | ElementBase |
Start() | StopwatchTimer |
Stop() | StopwatchTimer |
StopwatchTimer() | StopwatchTimer |
TextElement() | TextElement |
Update(float timeTotal, float timeDelta) | StopwatchTimer | [virtual]
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageView.xaml.h Source File

  • Hilo C++
  • Hilo

ImageView.xaml.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "FileSizeConverter.h" // Required by generated header
00010 #include "ImageView.g.h"
00011     // See http://go.microsoft.com/fwlink/?LinkId=267278 for info on how Hilo creates pages and navigates to pages.
00012
00013     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how view classes interact
00014     // with corresponding view model classes that encapsulate the app’s state, actions, and operations.
00015
00016     // See http://go.microsoft.com/fwlink/?LinkId=267279 for info on how Hilo pages use XAML controls.
00017
00018 namespace Hilo
00019 {
00020     // The ImageView class implements the view image page.
00021     public ref class ImageView sealed
00022     {
00023     public:
00024         ImageView();
00025         virtual ~ImageView();
00026
00027     private:
00028         void OnFilmStripLoaded(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00029         void OnImagePointerPressed(Platform::Object^ sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^ e);
00030         void OnImagePointerReleased(Platform::Object^ sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^ e);
00031         void OnImagePointerMoved(Platform::Object^ sender, Windows::UI::Xaml::Input::PointerRoutedEventArgs^ e);
00032
00033         Windows::Foundation::EventRegistrationToken m_filmStripLoadedToken;
00034         bool m_pointerPressed;
00035         Windows::Foundation::Point m_pointer;
00036     };
00037 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML personality animations/C++/Scenario3.xaml.h Source File

  • XAML personality animations

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024   namespace PersonalityAnimations
00025   {
00026     /// <summary>
00027     /// An empty page that can be used on its own or navigated to within a Frame.
00028     /// </summary>
00029     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00030     public ref class Scenario3 sealed
00031     {
00032     public:
00033       Scenario3();
00034
00035     protected:
00036       virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037
00038       void Scenario3_ClickHandler1(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039       void Scenario3_ClickHandler2(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040
00041     private:
00042       MainPage^ rootPage;
00043       void Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044     };
00045   }
00046 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

OpQueue< T, TOperation > Member List

This is the complete list of members for OpQueue< T, TOperation >, including all inherited members.
DispatchOperation(TOperation *pOp)=0 | OpQueue< T, TOperation > | [protected, pure virtual]
DispatchOperation(TOperation *pOp)=0 | OpQueue< T, TOperation > | [protected, pure virtual]
DispatchOperation(TOperation *pOp)=0 | OpQueue< T, TOperation > | [protected, pure virtual]
m_critsec | OpQueue< T, TOperation > | [protected]
m_OnProcessQueue | OpQueue< T, TOperation > | [protected]
m_OpQueue | OpQueue< T, TOperation > | [protected]
OpList typedef | OpQueue< T, TOperation > |
OpList typedef | OpQueue< T, TOperation > |
OpList typedef | OpQueue< T, TOperation > |
OpQueue(CRITICAL_SECTION &critsec) | OpQueue< T, TOperation > | [inline, protected]
OpQueue(CRITICAL_SECTION &critsec) | OpQueue< T, TOperation > | [inline, protected]
OpQueue(CRITICAL_SECTION &critsec) | OpQueue< T, TOperation > | [inline, protected]
ProcessQueue() | OpQueue< T, TOperation > | [protected]
ProcessQueue() | OpQueue< T, TOperation > | [protected]
ProcessQueue() | OpQueue< T, TOperation > | [protected]
ProcessQueueAsync(IMFAsyncResult *pResult) | OpQueue< T, TOperation > | [protected]
ProcessQueueAsync(IMFAsyncResult *pResult) | OpQueue< T, TOperation > | [protected]
ProcessQueueAsync(IMFAsyncResult *pResult) | OpQueue< T, TOperation > | [protected]
QueueOperation(TOperation *pOp) | OpQueue< T, TOperation > |
QueueOperation(TOperation *pOp) | OpQueue< T, TOperation > |
QueueOperation(TOperation *pOp) | OpQueue< T, TOperation > |
ValidateOperation(TOperation *pOp)=0 | OpQueue< T, TOperation > | [protected, pure virtual]
ValidateOperation(TOperation *pOp)=0 | OpQueue< T, TOperation > | [protected, pure virtual]
ValidateOperation(TOperation *pOp)=0 | OpQueue< T, TOperation > | [protected, pure virtual]
~OpQueue() | OpQueue< T, TOperation > | [inline, protected, virtual]
~OpQueue() | OpQueue< T, TOperation > | [inline, protected, virtual]
~OpQueue() | OpQueue< T, TOperation > | [inline, protected, virtual]
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/common/LayoutAwarePage.h Source File

  • Clipboard app
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include "pch.h"
00014 #include <collection.h>
00015
00016 namespace Clipboard
00017 {
00018     namespace Common
00019     {
00020
00021         [Windows::Foundation::Metadata::WebHostHidden]
00022         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00023         {
00024         internal:
00025             LayoutAwarePage();
00026
00027         public:
00028             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00029             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00030             void InvalidateVisualState();
00031
00032             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00033             {
00034                 Windows::UI::Xaml::DependencyProperty^ get();
00035             };
00036
00037             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ DefaultViewModel
00038             {
00039                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ get();
00040                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Object^>^ value);
00041             }
00042
00043         protected:
00044             virtual void GoHome(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045             virtual void GoBack(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00046             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00047
00048         private:
00049             Platform::Collections::Map<Platform::String^, Object^>^ _defaultViewModel;
00050             Windows::Foundation::EventRegistrationToken _windowSizeEventToken;
00051             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00052             void WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00053         };
00054
00055     }
00056 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/D2DPerspectiveTransform.cpp Source File

  • Direct2D perspective transform

D2DPerspectiveTransform.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "D2DPerspectiveTransform.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::UI::Input;
00017 using namespace Windows::System;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Foundation::Collections;
00020 using namespace Windows::Graphics::Display;
00021 using namespace Windows::Storage;
00022
00023 D2DPerspectiveTransform::D2DPerspectiveTransform():
00024     m_bitmapPerspective(nullptr),
00025     m_rotationAngle(0.0f)
00026 {
00027 }
00028
00029 void D2DPerspectiveTransform::CreateDeviceIndependentResources()
00030 {
00031     DirectXBase::CreateDeviceIndependentResources();
00032 }
00033
00034 void D2DPerspectiveTransform::CreateDeviceResources()
00035 {
00036     DirectXBase::CreateDeviceResources();
00037
00038     m_sampleOverlay = ref new SampleOverlay();
00039
00040     m_sampleOverlay->Initialize(
00041         m_d2dDevice.Get(),
00042         m_d2dContext.Get(),
00043         m_wicFactory.Get(),
00044         m_dwriteFactory.Get(),
00045         "Direct2D perspective transform sample"
00046         );
00047
00048     // Load a bitmap from the Windows Imaging Component decoder.
00049     ComPtr<IWICBitmapDecoder> decoder;
00050     DX::ThrowIfFailed(
00051         m_wicFactory->CreateDecoderFromFilename(
00052             L"mammoth_small.jpg",
00053             nullptr,
00054             GENERIC_READ,
00055             WICDecodeMetadataCacheOnDemand,
00056             &decoder
00057             )
00058         );
00059
00060     ComPtr<IWICBitmapFrameDecode> frame;
00061     DX::ThrowIfFailed(
00062         decoder->GetFrame(0, &frame)
00063         );
00064
00065     ComPtr<IWICFormatConverter> converter;
00066     DX::ThrowIfFailed(
00067         m_wicFactory->CreateFormatConverter(&converter)
00068         );
00069
00070     // We format convert to a pixel format that is compatible with Direct2D.
00071     // To optimize for performance when using WIC and Direct2D together, we need to
00072     // select the target pixel format based on the image's native precision:
00073     // - <= 8 bits per channel precision: use BGRA channel order
00074     //   (example: all JPEGs, including the image in this sample, are 8bpc)
00075     // -  > 8 bits per channel precision: use RGBA channel order
00076     //   (example: TIFF and JPEG-XR images support 32bpc float
00077     // Note that a fully robust system will arbitrate between various WIC pixel formats and
00078     // hardware feature level support using the IWICPixelFormatInfo2 interface.
00079     DX::ThrowIfFailed(
00080         converter->Initialize(
00081             frame.Get(),
00082             GUID_WICPixelFormat32bppPBGRA,
00083             WICBitmapDitherTypeNone,
00084             nullptr,
00085             0.0f,
00086             WICBitmapPaletteTypeCustom
00087             )
00088         );
00089
00090     // Create bitmap from WIC bitmap.
00091     DX::ThrowIfFailed(
00092         m_d2dContext->CreateBitmapFromWicBitmap(
00093             converter.Get(),
00094             nullptr,
00095             &m_bitmapPerspective
00096             )
00097         );
00098 }
00099
00100 void D2DPerspectiveTransform::CreateWindowSizeDependentResources()
00101 {
00102     DirectXBase::CreateWindowSizeDependentResources();
00103 }
00104
00105 void D2DPerspectiveTransform::Render()
00106 {
00107     m_d2dContext->BeginDraw();
00108     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00109
00110     D2D1_SIZE_F size = m_d2dContext->GetSize();
00111
00112     D2D1_RECT_F destRect = D2D1::RectF(
00113         size.width / 4,
00114         size.height / 4,
00115         3 * size.width / 4,
00116         3 * size.height / 4
00117         );
00118
00119     // Center the Image and apply the perspective transformation with rotation along the Y-axis.
00120     D2D1::Matrix4x4F matrix =
00121         D2D1::Matrix4x4F::Translation(-size.width/ 2, -size.height / 2, 0.0f) *
00122         D2D1::Matrix4x4F::RotationY(m_rotationAngle) *
00123         D2D1::Matrix4x4F::PerspectiveProjection(size.width/ 2) *
00124         D2D1::Matrix4x4F::Translation(size.width/ 2, size.height / 2, 0.0f);
00125
00126     m_d2dContext->DrawBitmap(
00127         m_bitmapPerspective.Get(),
00128         &destRect,
00129         1.0f, // Draw the bitmap fully opaque.
00130         D2D1_INTERPOLATION_MODE_LINEAR,
00131         nullptr, // Use the full source bitmap for sampling.
00132         &matrix
00133         );
00134
00135     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00136     // is lost. It will be handled during the next call to Present.
00137     HRESULT hr = m_d2dContext->EndDraw();
00138     if (hr != D2DERR_RECREATE_TARGET)
00139     {
00140         DX::ThrowIfFailed(hr);
00141     }
00142
00143     m_sampleOverlay->Render();
00144 }
00145
00146 void D2DPerspectiveTransform::Initialize(
00147     _In_ CoreApplicationView^ applicationView
00148     )
00149 {
00150     applicationView->Activated +=
00151         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &D2DPerspectiveTransform::OnActivated);
00152
00153     CoreApplication::Suspending +=
00154         ref new EventHandler<SuspendingEventArgs^>(this, &D2DPerspectiveTransform::OnSuspending);
00155
00156     CoreApplication::Resuming +=
00157         ref new EventHandler<Platform::Object^>(this, &D2DPerspectiveTransform::OnResuming);
00158 }
00159
00160 void D2DPerspectiveTransform::SetWindow(
00161     _In_ CoreWindow^ window
00162     )
00163 {
00164     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00165
00166     window->SizeChanged +=
00167         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &D2DPerspectiveTransform::OnWindowSizeChanged);
00168
00169     window->PointerPressed +=
00170         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DPerspectiveTransform::OnPointerPressed);
00171
00172     window->PointerReleased +=
00173         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DPerspectiveTransform::OnPointerReleased);
00174
00175     window->PointerMoved +=
00176         ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this, &D2DPerspectiveTransform::OnPointerMoved);
00177
00178     DisplayProperties::LogicalDpiChanged +=
00179         ref new DisplayPropertiesEventHandler(this, &D2DPerspectiveTransform::OnLogicalDpiChanged);
00180
00181     DisplayProperties::DisplayContentsInvalidated +=
00182         ref new DisplayPropertiesEventHandler(this, &D2DPerspectiveTransform::OnDisplayContentsInvalidated);
00183
00184     DirectXBase::Initialize(window, DisplayProperties::LogicalDpi);
00185
00186     m_gestureRecognizer = ref new GestureRecognizer();
00187
00188     m_gestureRecognizer->AutoProcessInertia = false;
00189
00190     m_gestureRecognizer->GestureSettings = GestureSettings::ManipulationTranslateX;
00191
00192     m_gestureRecognizer->ManipulationUpdated +=
00193         ref new TypedEventHandler<GestureRecognizer^, ManipulationUpdatedEventArgs^>(this, &D2DPerspectiveTransform::OnManipulationUpdated);
00194 }
00195
00196 void D2DPerspectiveTransform::Load(
00197     _In_ Platform::String^ entryPoint
00198     )
00199 {
00200     // Retrieve any stored variables from the LocalSettings collection.
00201     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00202
00203     if (settingsValues->HasKey("m_rotationAngle"))
00204     {
00205         m_rotationAngle = safe_cast<IPropertyValue^>(settingsValues->Lookup("m_rotationAngle"))->GetSingle();
00206     }
00207 }
00208
00209 void D2DPerspectiveTransform::Run()
00210 {
00211     Render();
00212     Present();
00213
00214     m_window->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessUntilQuit);
00215 }
00216
00217 void D2DPerspectiveTransform::Uninitialize()
00218 {
00219 }
00220
00221 void D2DPerspectiveTransform::OnWindowSizeChanged(
00222     _In_ CoreWindow^ sender,
00223     _In_ WindowSizeChangedEventArgs^ args
00224     )
00225 {
00226     UpdateForWindowSizeChange();
00227     m_sampleOverlay->UpdateForWindowSizeChange();
00228     Render();
00229     Present();
00230 }
00231
00232 void D2DPerspectiveTransform::OnLogicalDpiChanged(
00233     _In_ Platform::Object^ sender
00234     )
00235 {
00236     SetDpi(DisplayProperties::LogicalDpi);
00237     Render();
00238     Present();
00239 }
00240
00241 void D2DPerspectiveTransform::OnDisplayContentsInvalidated(
00242     _In_ Platform::Object^ sender
00243     )
00244 {
00245     // Ensure the D3D Device is available for rendering.
00246     ValidateDevice();
00247
00248     Render();
00249     Present();
00250 }
00251
00252 void D2DPerspectiveTransform::OnActivated(
00253     _In_ CoreApplicationView^ applicationView,
00254     _In_ IActivatedEventArgs^ args
00255     )
00256 {
00257     m_window->Activate();
00258 }
00259
00260 void D2DPerspectiveTransform::OnSuspending(
00261     _In_ Platform::Object^ sender,
00262     _In_ SuspendingEventArgs^ args
00263     )
00264 {
00265     // Store rotation angle in the LocalSettings collection.
00266     IPropertySet^ settingsValues = ApplicationData::Current->LocalSettings->Values;
00267
00268     if (settingsValues->HasKey("m_rotationAngle"))
00269     {
00270         settingsValues->Remove("m_rotationAngle");
00271     }
00272     settingsValues->Insert("m_rotationAngle", PropertyValue::CreateSingle(m_rotationAngle));
00273 }
00274
00275 void D2DPerspectiveTransform::OnResuming(
00276     _In_ Platform::Object^ sender,
00277     _In_ Platform::Object^ args
00278     )
00279 {
00280 }
00281
00282 void D2DPerspectiveTransform::OnPointerPressed(
00283     _In_ CoreWindow^ window,
00284     _In_ PointerEventArgs^ args
00285     )
00286 {
00287     m_gestureRecognizer->ProcessDownEvent(args->CurrentPoint);
00288 }
00289
00290 void D2DPerspectiveTransform::OnPointerReleased(
00291     _In_ CoreWindow^ window,
00292     _In_ PointerEventArgs^ args
00293     )
00294 {
00295     m_gestureRecognizer->ProcessUpEvent(args->CurrentPoint);
00296 }
00297
00298 void D2DPerspectiveTransform::OnPointerMoved(
00299     _In_ CoreWindow^ window,
00300     _In_ PointerEventArgs^ args
00301     )
00302 {
00303     m_gestureRecognizer->ProcessMoveEvents(args->GetIntermediatePoints());
00304 }
00305
00306 void D2DPerspectiveTransform::OnManipulationUpdated(
00307     _In_ GestureRecognizer^ gestureRecognizer,
00308     _In_ ManipulationUpdatedEventArgs^ args)
00309 {
00310     m_rotationAngle += args->Delta.Translation.X / 3.0f; // The divisor in the equation slows the pace of the rotation.
00311
00312     Render();
00313     Present();
00314 }
00315
00316 IFrameworkView^ DirectXAppSource::CreateView()
00317 {
00318     return ref new D2DPerspectiveTransform();
00319 }
00320
00321 [Platform::MTAThread]
00322 int main(Platform::Array<Platform::String^>^)
00323 {
00324     auto directXAppSource = ref new DirectXAppSource();
00325     CoreApplication::Run(directXAppSource);
00326     return 0;
00327 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/App.xaml.cpp Source File

  • Playback Manager msAudioCategory

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/MainPage.xaml.h Source File

  • Animation metrics

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/D2DPageRenderer.cpp Source File

  • Direct2D printing images and effects

D2DPageRenderer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include <math.h>
00010 #include "D2DPageRenderer.h"
00011 #include "D2DPageRendererContext.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Microsoft::WRL::Wrappers;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::UI::Core;
00017 using namespace Windows::Graphics::Display;
00018
00019 PageRenderer::PageRenderer()
00020 : m_isSnapped(false)
00021 {
00022 }
00023
00024 void PageRenderer::CreateDeviceIndependentResources()
00025 {
00026     DirectXBase::CreateDeviceIndependentResources();
00027
00028     // Create a DirectWrite text format object for the sample's content.
00029     DX::ThrowIfFailed(
00030         m_dwriteFactory->CreateTextFormat(
00031             L"Segoe UI",
00032             nullptr,
00033             DWRITE_FONT_WEIGHT_NORMAL,
00034             DWRITE_FONT_STYLE_NORMAL,
00035             DWRITE_FONT_STRETCH_NORMAL,
00036             40.0f,
00037             L"en-us", // locale
00038             &m_textFormat
00039             )
00040         );
00041
00042     // Align the text horizontally.
00043     DX::ThrowIfFailed(
00044         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00045         );
00046
00047     // Center the text vertically.
00048     DX::ThrowIfFailed(
00049         m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00050         );
00051
00052     // Create a DirectWrite text format object for status messages.
00053     DX::ThrowIfFailed(
00054         m_dwriteFactory->CreateTextFormat(
00055             L"Segoe UI",
00056             nullptr,
00057             DWRITE_FONT_WEIGHT_NORMAL,
00058             DWRITE_FONT_STYLE_NORMAL,
00059             DWRITE_FONT_STRETCH_NORMAL,
00060             20.0f,
00061             L"en-us", // locale
00062             &m_messageFormat
00063             )
00064         );
00065
00066     // Center the text horizontally.
00067     DX::ThrowIfFailed(
00068         m_messageFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00069         );
00070
00071     // Center the text vertically.
00072     DX::ThrowIfFailed(
00073         m_messageFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00074         );
00075
00076     // Load the source bitmap file into a WIC bitmap source.
00077     ComPtr<IWICBitmapDecoder> decoder;
00078     DX::ThrowIfFailed(
00079         m_wicFactory->CreateDecoderFromFilename(
00080             L"test.jpg",
00081             nullptr,
00082             GENERIC_READ,
00083             WICDecodeMetadataCacheOnDemand,
00084             &decoder
00085             )
00086         );
00087
00088     ComPtr<IWICBitmapFrameDecode> frame;
00089     DX::ThrowIfFailed(
00090         decoder->GetFrame(0, &frame)
00091         );
00092
00093     DX::ThrowIfFailed(
00094         m_wicFactory->CreateFormatConverter(&m_wicConvertedSource)
00095         );
00096
00097     DX::ThrowIfFailed(
00098         m_wicConvertedSource->Initialize(
00099             frame.Get(),
00100             GUID_WICPixelFormat32bppPBGRA,
00101             WICBitmapDitherTypeNone,
00102             nullptr,
00103             0.0f,
00104             WICBitmapPaletteTypeCustom  // Premultiplied BGRA has no paletting, so this is ignored.
00105             )
00106         );
00107
00108     // Load the source color profile.
00109     DX::ThrowIfFailed(
00110         m_wicFactory->CreateColorContext(&m_wicColorContext)
00111         );
00112
00113     DX::ThrowIfFailed(
00114         m_wicColorContext->InitializeFromFilename(L"profile.icm")
00115         );
00116
00117     // Create another BitmapSource effect, for printing only.
00118     // We first encode the WIC bitmap source and the WIC color context to an
00119     // in-memory stream, then create a new WIC bitmap source from that stream,
00120     // and finally create a BitmapSource effect based on the newly created WIC
00121     // bitmap source. By doing so, we pass the original WIC bitmap source and
00122     // the WIC color context (both embedded in that stream) directly to the
00123     // print path, and achieve better performance and fidelity with delayed
00124     // color conversion.
00125
00126     // Step 1: Encode both the WIC bitmap source and the color context to an
00127     // in-memory stream.
00128     ComPtr<IStream> stream;
00129     DX::ThrowIfFailed(
00130         CreateStreamOnHGlobal(
00131             nullptr, // To allocate a new memory handle.
00132             true,    // The underlying handle should be automatically freed when the stream object is released.
00133             &stream
00134             )
00135         );
00136
00137     ComPtr<IWICBitmapEncoder> wicBitmapEncoder;
00138     DX::ThrowIfFailed(
00139         m_wicFactory->CreateEncoder(
00140             GUID_ContainerFormatPng,    // Encode as PNG.
00141             nullptr,    // No preferred codec vendor.
00142             &wicBitmapEncoder
00143             )
00144         );
00145
00146     DX::ThrowIfFailed(
00147         wicBitmapEncoder->Initialize(
00148             stream.Get(),
00149             WICBitmapEncoderNoCache
00150             )
00151         );
00152
00153     ComPtr<IWICBitmapFrameEncode> wicFrameEncode;
00154     DX::ThrowIfFailed(
00155         wicBitmapEncoder->CreateNewFrame(
00156             &wicFrameEncode,
00157             nullptr     // No encoder options.
00158             )
00159         );
00160
00161     DX::ThrowIfFailed(
00162         wicFrameEncode->Initialize(nullptr)
00163         );
00164
00165     // Set color context to the frame.
00166     IWICColorContext* contexts[1];
00167     contexts[0] = m_wicColorContext.Get();
00168     DX::ThrowIfFailed(
00169         wicFrameEncode->SetColorContexts(1, contexts)
00170         );
00171
00172     DX::ThrowIfFailed(
00173         wicFrameEncode->WriteSource(
00174             m_wicConvertedSource.Get(),
00175             nullptr     // Write the whole bitmap.
00176             )
00177         );
00178
00179     DX::ThrowIfFailed(
00180         wicFrameEncode->Commit()
00181         );
00182
00183     DX::ThrowIfFailed(
00184         wicBitmapEncoder->Commit()
00185         );
00186
00187     // Step 2: Decode the newly created image stream.
00188     ComPtr<IWICBitmapDecoder> bitmapDecoder;
00189     DX::ThrowIfFailed(
00190         m_wicFactory->CreateDecoderFromStream(
00191             stream.Get(),
00192             nullptr,    // No preferred codec vendor.
00193             WICDecodeMetadataCacheOnLoad,
00194             &bitmapDecoder
00195             )
00196         );
00197
00198     // Get the initial frame as the new WIC bitmap source.
00199     DX::ThrowIfFailed(
00200         bitmapDecoder->GetFrame(0, &m_profiledWicBitmap)
00201         );
00202 }
00203
00204 void PageRenderer::CreateDeviceResources()
00205 {
00206     DirectXBase::CreateDeviceResources();
00207
00208     // Create and initialize sample overlay for sample title.
00209     m_sampleOverlay = ref new SampleOverlay();
00210     m_sampleOverlay->Initialize(
00211         m_d2dDevice.Get(),
00212         m_d2dContext.Get(),
00213         m_wicFactory.Get(),
00214         m_dwriteFactory.Get(),
00215         "Direct2D image and effect printing sample"
00216         );
00217
00218     D2D1_SIZE_F size = m_d2dContext->GetSize();
00219
00220     // Exclude sample title from imageable area for image drawing.
00221     float titleHeight = m_sampleOverlay->GetTitleHeightInDips();
00222
00223     // Create and initialize the page renderer context for display.
00224     m_displayPageRendererContext =
00225         ref new PageRendererContext(
00226             D2D1::RectF(0, titleHeight, size.width, size.height),
00227             m_d2dContext.Get(),
00228             DrawTypes::Rendering,
00229             this
00230             );
00231 }
00232
00233 void PageRenderer::UpdateForWindowSizeChange()
00234 {
00235     DirectXBase::UpdateForWindowSizeChange();
00236     m_sampleOverlay->UpdateForWindowSizeChange();
00237
00238     D2D1_SIZE_F size = m_d2dContext->GetSize();
00239
00240     // Exclude sample title from imageable area for image drawing.
00241     float titleHeight = m_sampleOverlay->GetTitleHeightInDips();
00242
00243     D2D1_RECT_F contentBox = D2D1::RectF(0, titleHeight, size.width, size.height);
00244     m_displayPageRendererContext->UpdateTargetBox(
00245         contentBox
00246         );
00247 }
00248
00249 // On-screen rendering.
00250 void PageRenderer::Render()
00251 {
00252     m_d2dContext->BeginDraw();
00253
00254     if (m_isSnapped)
00255     {
00256         m_displayPageRendererContext->DrawMessage("This sample does not support snapped view.");
00257     }
00258     else
00259     {
00260         // Render page context (i.e. images).
00261         m_displayPageRendererContext->Draw();
00262     }
00263
00264     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00265     // is lost. It will be handled during the next call to Present.
00266     HRESULT hr = m_d2dContext->EndDraw();
00267     if (hr != D2DERR_RECREATE_TARGET)
00268     {
00269         DX::ThrowIfFailed(hr);
00270     }
00271
00272     // Render sample title.
00273     m_sampleOverlay->Render();
00274
00275     // We are accessing D3D resources directly in Present() without D2D's knowledge,
00276     // so we must manually acquire the D2D factory lock.
00277     //
00278     // Note: it's absolutely critical that the factory lock be released upon
00279     // exiting this function, or else the entire app will deadlock. This is
00280     // ensured via the following RAII class.
00281     {
00282         D2DFactoryLock factoryLock(m_d2dFactory.Get());
00283         Present();
00284     }
00285 }
00286
00287 void PageRenderer::SetSnappedMode(_In_ bool isSnapped)
00288 {
00289     m_isSnapped = isSnapped;
00290 }
00291
00292 void PageRenderer::DrawPreviewSurface(
00293     _In_  float                             width,
00294     _In_  float                             height,
00295     _In_  float                             scale,
00296     _In_  D2D1_RECT_F                       contentBox,
00297     _In_  uint32                            desiredJobPage,
00298     _In_  IPrintPreviewDxgiPackageTarget*   previewTarget
00299     )
00300 {
00301     // We are accessing D3D resources directly without D2D's knowledge, so we
00302     // must manually acquire the D2D factory lock.
00303     //
00304     // Note: it's absolutely critical that the factory lock be released upon
00305     // exiting this function, or else the entire app will deadlock. This is
00306     // ensured via the following RAII class.
00307     D2DFactoryLock factoryLock(m_d2dFactory.Get());
00308
00309     CD3D11_TEXTURE2D_DESC textureDesc(
00310         DXGI_FORMAT_B8G8R8A8_UNORM,
00311         static_cast<uint32>(ceil(width  * m_dpi / 96)),
00312         static_cast<uint32>(ceil(height * m_dpi / 96)),
00313         1,
00314         1,
00315         D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE
00316         );
00317
00318     ComPtr<ID3D11Texture2D> texture;
00319     DX::ThrowIfFailed(
00320         m_d3dDevice->CreateTexture2D(
00321             &textureDesc,
00322             nullptr,
00323             &texture
00324             )
00325         );
00326
00327     // Create a preview DXGI surface with given size.
00328     ComPtr<IDXGISurface> dxgiSurface;
00329     DX::ThrowIfFailed(
00330         texture.As<IDXGISurface>(&dxgiSurface)
00331         );
00332
00333     // Create a new D2D device context for rendering the preview surface.
00334     // D2D device contexts are stateful, and hence a unique device must be
00335     // used on each thread.
00336     ComPtr<ID2D1DeviceContext> d2dContext;
00337     DX::ThrowIfFailed(
00338         m_d2dDevice->CreateDeviceContext(
00339             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00340             &d2dContext
00341             )
00342         );
00343
00344     // Update DPI for preview surface as well.
00345     d2dContext->SetDpi(m_dpi, m_dpi);
00346
00347     // Recommend using the screen DPI for better fidelity and better performance in the print preview
00348     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00349         D2D1::BitmapProperties1(
00350             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00351             D2D1::PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED)
00352             );
00353
00354     // Create surface bitmap on which page content is drawn.
00355     ComPtr<ID2D1Bitmap1> d2dSurfaceBitmap;
00356     DX::ThrowIfFailed(
00357         d2dContext->CreateBitmapFromDxgiSurface(
00358             dxgiSurface.Get(),
00359             &bitmapProperties,
00360             &d2dSurfaceBitmap
00361             )
00362         );
00363
00364     d2dContext->SetTarget(d2dSurfaceBitmap.Get());
00365
00366     // Create and initialize the page renderer context for preview.
00367     PageRendererContext^ previewPageRendererContext =
00368         ref new PageRendererContext(
00369             contentBox,
00370             d2dContext.Get(),
00371             DrawTypes::Preview,
00372             this
00373             );
00374
00375     d2dContext->BeginDraw();
00376
00377     // Draw page content on the preview surface.
00378     // Here contentBox is smaller than the real page size and the scale
00379     // indicates the proportion. It is faster to draw content on a smaller
00380     // surface. Set a global transform of 1/scale, allowing Draw to draw to a
00381     // virtual target box without accounting for the scale factor.
00382     d2dContext->SetTransform(D2D1::Matrix3x2F(1.0f / scale, 0.0f, 0.0f, 1.0f / scale, 0.0f, 0.0f));
00383
00384     previewPageRendererContext->Draw();
00385
00386     // The document source handles D2DERR_RECREATETARGET, so it is okay to throw this error
00387     // here.
00388     DX::ThrowIfFailed(
00389         d2dContext->EndDraw()
00390         );
00391
00392     // Must pass the same DPI as used to create the DXGI surface for the correct print preview.
00393     DX::ThrowIfFailed(
00394         previewTarget->DrawPage(
00395             desiredJobPage,
00396             dxgiSurface.Get(),
00397             m_dpi,
00398             m_dpi
00399             )
00400         );
00401 }
00402
00403 void PageRenderer::CreatePrintControl(
00404     _In_  IPrintDocumentPackageTarget*      docPackageTarget,
00405     _In_  D2D1_PRINT_CONTROL_PROPERTIES*    printControlProperties
00406     )
00407 {
00408     // Explicitly release existing D2D print control.
00409     m_d2dPrintControl = nullptr;
00410
00411     DX::ThrowIfFailed(
00412         m_d2dDevice->CreatePrintControl(
00413             m_wicFactory.Get(),
00414             docPackageTarget,
00415             printControlProperties,
00416             &m_d2dPrintControl
00417             )
00418         );
00419 }
00420
00421 HRESULT PageRenderer::ClosePrintControl()
00422 {
00423     return (m_d2dPrintControl == nullptr) ? S_OK : m_d2dPrintControl->Close();
00424 }
00425
00426 // Print out one page, with the given print ticket.
00427 // This sample has only one page and we ignore pageNumber below.
00428 void PageRenderer::PrintPage(
00429     _In_ uint32                 /*pageNumber*/,
00430     _In_ D2D1_RECT_F            imageableArea,
00431     _In_ D2D1_SIZE_F            pageSize,
00432     _In_opt_ IStream*           pagePrintTicketStream
00433     )
00434 {
00435     // Create a new D2D device context for generating the print command list.
00436     // D2D device contexts are stateful, and hence a unique device context must
00437     // be used on each thread.
00438     ComPtr<ID2D1DeviceContext> d2dContext;
00439     DX::ThrowIfFailed(
00440         m_d2dDevice->CreateDeviceContext(
00441             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00442             &d2dContext
00443             )
00444         );
00445
00446     ComPtr<ID2D1CommandList> printCommandList;
00447     DX::ThrowIfFailed(
00448         d2dContext->CreateCommandList(&printCommandList)
00449         );
00450
00451     d2dContext->SetTarget(printCommandList.Get());
00452
00453     // Create and initialize the page renderer context for print.
00454     // In this case, we want to use the bitmap source that already has
00455     // the color context embedded in it. Thus, we pass NULL for the
00456     // color context parameter.
00457     PageRendererContext^ printPageRendererContext =
00458         ref new PageRendererContext(
00459             imageableArea,
00460             d2dContext.Get(),
00461             DrawTypes::Printing,
00462             this
00463             );
00464
00465     d2dContext->BeginDraw();
00466
00467     // Draw page content on a command list.
00468     printPageRendererContext->Draw();
00469
00470     // The document source handles D2DERR_RECREATETARGET, so it is okay to throw this error
00471     // here.
00472     DX::ThrowIfFailed(
00473         d2dContext->EndDraw()
00474         );
00475
00476     DX::ThrowIfFailed(
00477         printCommandList->Close()
00478         );
00479
00480     DX::ThrowIfFailed(
00481         m_d2dPrintControl->AddPage(printCommandList.Get(), pageSize, pagePrintTicketStream)
00482         );
00483 }
00484
00485 IWICColorContext* PageRenderer::GetWicColorContextNoRef()
00486 {
00487     return m_wicColorContext.Get();
00488 }
00489
00490 IWICBitmapSource* PageRenderer::GetOriginalWicBitmapSourceNoRef()
00491 {
00492     return m_wicConvertedSource.Get();
00493 }
00494
00495 IWICBitmapSource* PageRenderer::GetWicBitmapSourceWithEmbeddedColorContextNoRef()
00496 {
00497     return m_profiledWicBitmap.Get();
00498 }
00499
00500 IDWriteTextFormat* PageRenderer::GetTextFormatNoRef()
00501 {
00502     return m_textFormat.Get();
00503 }
00504
00505 IDWriteTextFormat* PageRenderer::GetMessageFormatNoRef()
00506 {
00507     return m_messageFormat.Get();
00508 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/DirectXBase.cpp Source File

  • DXGI swap chain rotation

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height ||
00189         m_orientation != DisplayProperties::CurrentOrientation)
00190     {
00191         m_d2dContext->SetTarget(nullptr);
00192         m_d2dTargetBitmap = nullptr;
00193         m_d3dRenderTargetView = nullptr;
00194         m_d3dDepthStencilView = nullptr;
00195         m_windowSizeChangeInProgress = true;
00196         CreateWindowSizeDependentResources();
00197     }
00198 }
00199
00200 // Allocate all memory resources that change on a window SizeChanged event.
00201 void DirectXBase::CreateWindowSizeDependentResources()
00202 {
00203     // Store the window bounds so the next time we get a SizeChanged event we can
00204     // avoid rebuilding everything if the size is identical.
00205     m_windowBounds = m_window->Bounds;
00206
00207     // Calculate the necessary swap chain and render target size in pixels.
00208     auto windowWidth = ConvertDipsToPixels(m_windowBounds.Width);
00209     auto windowHeight = ConvertDipsToPixels(m_windowBounds.Height);
00210
00211     // Swap width and height based on orientation.
00212     m_orientation = DisplayProperties::CurrentOrientation;
00213     bool swapDimensions = (
00214         m_orientation == DisplayOrientations::Portrait ||
00215         m_orientation == DisplayOrientations::PortraitFlipped
00216         );
00217     m_renderTargetSize.Width = swapDimensions ? windowHeight : windowWidth;
00218     m_renderTargetSize.Height = swapDimensions ? windowWidth : windowHeight;
00219
00220     if (m_swapChain != nullptr)
00221     {
00222         // If the swap chain already exists, resize it.
00223         HRESULT hr = m_swapChain->ResizeBuffers(
00224             2,
00225             static_cast<UINT>(m_renderTargetSize.Width),
00226             static_cast<UINT>(m_renderTargetSize.Height),
00227             DXGI_FORMAT_B8G8R8A8_UNORM,
00228             0
00229             );
00230
00231         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00232         {
00233             // If the device was removed for any reason, a new device and swapchain will need to be created.
00234             HandleDeviceLost();
00235
00236             // Everything is set up now. Do not continue execution of this method.
00237             return;
00238         }
00239         else
00240         {
00241             DX::ThrowIfFailed(hr);
00242         }
00243     }
00244     else
00245     {
00246         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00247         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00248         swapChainDesc.Width = static_cast<UINT>(m_renderTargetSize.Width); // Match the size of the window.
00249         swapChainDesc.Height = static_cast<UINT>(m_renderTargetSize.Height);
00250         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00251         swapChainDesc.Stereo = false;
00252         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00253         swapChainDesc.SampleDesc.Quality = 0;
00254         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00255         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00256         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00257         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00258         swapChainDesc.Flags = 0;
00259
00260         ComPtr<IDXGIDevice1> dxgiDevice;
00261         DX::ThrowIfFailed(
00262             m_d3dDevice.As(&dxgiDevice)
00263             );
00264
00265         ComPtr<IDXGIAdapter> dxgiAdapter;
00266         DX::ThrowIfFailed(
00267             dxgiDevice->GetAdapter(&dxgiAdapter)
00268             );
00269
00270         ComPtr<IDXGIFactory2> dxgiFactory;
00271         DX::ThrowIfFailed(
00272             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00273             );
00274
00275         CoreWindow^ window = m_window.Get();
00276         DX::ThrowIfFailed(
00277             dxgiFactory->CreateSwapChainForCoreWindow(
00278                 m_d3dDevice.Get(),
00279                 reinterpret_cast<IUnknown*>(window),
00280                 &swapChainDesc,
00281                 nullptr,
00282                 &m_swapChain
00283                 )
00284             );
00285
00286         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00287         // ensures that the application will only render after each VSync, minimizing power consumption.
00288         DX::ThrowIfFailed(
00289             dxgiDevice->SetMaximumFrameLatency(1)
00290             );
00291     }
00292
00293     // Set the proper orientation for the swap chain, and generate 2D and
00294     // 3D matrix transformations for rendering to the rotated swap chain.
00295     // Note the rotation angle for the 2D and 3D transforms are different.
00296     // This is due to the difference in coordinate spaces.  Additionally,
00297     // the 3D matrix is specified explicitly to avoid rounding errors.
00298     DXGI_MODE_ROTATION rotation = DXGI_MODE_ROTATION_UNSPECIFIED;
00299     switch (m_orientation)
00300     {
00301         case DisplayOrientations::Landscape:
00302             rotation = DXGI_MODE_ROTATION_IDENTITY;
00303             m_rotationTransform2D = Matrix3x2F::Identity();
00304             m_rotationTransform3D = identity();
00305             break;
00306         case DisplayOrientations::Portrait:
00307             rotation = DXGI_MODE_ROTATION_ROTATE270;
00308             m_rotationTransform2D =
00309                 Matrix3x2F::Rotation(270.0f) *
00310                 Matrix3x2F::Translation(0.0f, m_windowBounds.Width);
00311             m_rotationTransform3D = float4x4( // 90-degree Z-rotation
00312                 0.0f, -1.0f, 0.0f, 0.0f,
00313                 1.0f, 0.0f, 0.0f, 0.0f,
00314                 0.0f, 0.0f, 1.0f, 0.0f,
00315                 0.0f, 0.0f, 0.0f, 1.0f
00316                 );
00317             break;
00318         case DisplayOrientations::LandscapeFlipped:
00319             rotation = DXGI_MODE_ROTATION_ROTATE180;
00320             m_rotationTransform2D =
00321                 Matrix3x2F::Rotation(180.0f) *
00322                 Matrix3x2F::Translation(m_windowBounds.Width, m_windowBounds.Height);
00323             m_rotationTransform3D = float4x4( // 180-degree Z-rotation
00324                 -1.0f, 0.0f, 0.0f, 0.0f,
00325                 0.0f, -1.0f, 0.0f, 0.0f,
00326                 0.0f, 0.0f, 1.0f, 0.0f,
00327                 0.0f, 0.0f, 0.0f, 1.0f
00328                 );
00329             break;
00330         case DisplayOrientations::PortraitFlipped:
00331             rotation = DXGI_MODE_ROTATION_ROTATE90;
00332             m_rotationTransform2D =
00333                 Matrix3x2F::Rotation(90.0f) *
00334                 Matrix3x2F::Translation(m_windowBounds.Height, 0.0f);
00335             m_rotationTransform3D = float4x4( // 270-degree Z-rotation
00336                 0.0f, 1.0f, 0.0f, 0.0f,
00337                 -1.0f, 0.0f, 0.0f, 0.0f,
00338                 0.0f, 0.0f, 1.0f, 0.0f,
00339                 0.0f, 0.0f, 0.0f, 1.0f
00340                 );
00341             break;
00342         default:
00343             throw ref new Platform::FailureException();
00344             break;
00345     }
00346
00347     DX::ThrowIfFailed(
00348         m_swapChain->SetRotation(rotation)
00349         );
00350
00351     // Create a Direct3D render target view of the swap chain back buffer.
00352     ComPtr<ID3D11Texture2D> backBuffer;
00353     DX::ThrowIfFailed(
00354         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00355         );
00356
00357     DX::ThrowIfFailed(
00358         m_d3dDevice->CreateRenderTargetView(
00359             backBuffer.Get(),
00360             nullptr,
00361             &m_d3dRenderTargetView
00362             )
00363         );
00364
00365     // Create a depth stencil view for use with 3D rendering if needed.
00366     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00367         DXGI_FORMAT_D24_UNORM_S8_UINT,
00368         static_cast<UINT>(m_renderTargetSize.Width),
00369         static_cast<UINT>(m_renderTargetSize.Height),
00370         1,
00371         1,
00372         D3D11_BIND_DEPTH_STENCIL
00373         );
00374
00375     ComPtr<ID3D11Texture2D> depthStencil;
00376     DX::ThrowIfFailed(
00377         m_d3dDevice->CreateTexture2D(
00378             &depthStencilDesc,
00379             nullptr,
00380             &depthStencil
00381             )
00382         );
00383
00384     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00385     DX::ThrowIfFailed(
00386         m_d3dDevice->CreateDepthStencilView(
00387             depthStencil.Get(),
00388             &viewDesc,
00389             &m_d3dDepthStencilView
00390             )
00391         );
00392
00393     // Set the 3D rendering viewport to target the entire window.
00394     CD3D11_VIEWPORT viewport(
00395         0.0f,
00396         0.0f,
00397         m_renderTargetSize.Width,
00398         m_renderTargetSize.Height
00399         );
00400
00401     m_d3dContext->RSSetViewports(1, &viewport);
00402
00403     // Create a Direct2D target bitmap associated with the
00404     // swap chain back buffer and set it as the current target.
00405     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00406         BitmapProperties1(
00407             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00408             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00409             m_dpi,
00410             m_dpi
00411             );
00412
00413     ComPtr<IDXGISurface> dxgiBackBuffer;
00414     DX::ThrowIfFailed(
00415         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00416         );
00417
00418     DX::ThrowIfFailed(
00419         m_d2dContext->CreateBitmapFromDxgiSurface(
00420             dxgiBackBuffer.Get(),
00421             &bitmapProperties,
00422             &m_d2dTargetBitmap
00423             )
00424         );
00425
00426     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00427
00428     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00429     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00430 }
00431
00432 // Method to deliver the final image to the display.
00433 void DirectXBase::Present()
00434 {
00435     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00436     // in certain scenarios.  In this sample, however, we do not utilize those features.
00437     DXGI_PRESENT_PARAMETERS parameters = {0};
00438     parameters.DirtyRectsCount = 0;
00439     parameters.pDirtyRects = nullptr;
00440     parameters.pScrollRect = nullptr;
00441     parameters.pScrollOffset = nullptr;
00442
00443     // The first argument instructs DXGI to block until VSync, putting the application
00444     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00445     // frames that will never be displayed to the screen.
00446     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00447
00448     // Discard the contents of the render target.
00449     // This is a valid operation only when the existing contents will be entirely
00450     // overwritten. If dirty or scroll rects are used, this call should be removed.
00451     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00452
00453     // Discard the contents of the depth stencil.
00454     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00455
00456     // If the device was removed either by a disconnect or a driver upgrade, we
00457     // must recreate all device resources.
00458     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00459     {
00460         HandleDeviceLost();
00461     }
00462     else
00463     {
00464         DX::ThrowIfFailed(hr);
00465     }
00466
00467     if (m_windowSizeChangeInProgress)
00468     {
00469         // A window size change has been initiated and the app has just completed presenting
00470         // the first frame with the new size. Notify the resize manager so we can
00471         // short circuit the rotation animation and prevent unnecessary delays.
00472         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00473         m_windowSizeChangeInProgress = false;
00474     }
00475 }
00476
00477 // Method to convert a length in device-independent pixels (DIPs) to a length in physical pixels.
00478 float DirectXBase::ConvertDipsToPixels(float dips)
00479 {
00480     static const float dipsPerInch = 96.0f;
00481     return floor(dips * m_dpi / dipsPerInch + 0.5f); // Round to nearest integer.
00482 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Constants.cpp Source File

  • XAML WebView control

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully qualified name for the class that implements the scenario" }
00021     { "Navigate to a URL", "SDKSample.WebViewControl.Scenario1" },
00022     { "Load HTML", "SDKSample.WebViewControl.Scenario2" },
00023     { "Ineract with script", "SDKSample.WebViewControl.Scenario3" },
00024   { "Using ScriptNotify", "SDKSample.WebViewControl.Scenario4" },
00025   { "Accessing the DOM", "SDKSample.WebViewControl.Scenario5" },
00026   { "Using the WebViewBrush", "SDKSample.WebViewControl.Scenario6" },
00027   { "Supporting the Share contract", "SDKSample.WebViewControl.Scenario7" },
00028   { "Co-existing with the AppBar", "SDKSample.WebViewControl.Scenario8" }
00029
00030 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Clipboard app/C++/pch.cpp Source File

  • Clipboard app

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Alignment Member List

This is the complete list of members for Alignment, including all inherited members.
horizontal | Alignment
vertical | Alignment
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario3.xaml.cpp Source File

  • XAML text display

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::TextDisplay;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario3::Scenario3()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040 }
00041
00042
00043 void SDKSample::TextDisplay::Scenario3::Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00044 {
00045     Button^ b = safe_cast<Button^>(sender);
00046     if (b != nullptr)
00047     {
00048         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ReadStreamTask Member List

This is the complete list of members for ReadStreamTask, including all inherited members.
_Impl | ReadStreamTask | [private]
GetTask() | ReadStreamTask |
MinReadChunkSize | ReadStreamTask | [private, static]
operator=(const ReadStreamTask &Task) | ReadStreamTask |
ReadStreamTask(Windows::Storage::Streams::IInputStream^Stream, std::vector< byte > &Destination) | ReadStreamTask |
ReadStreamTask(const ReadStreamTask &Task) | ReadStreamTask |
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/Constants.cpp Source File

  • CameraOptionsUI

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Show webcam Settings using CameraOptionsUI API", "SDKSample.CameraOptions.ShowOptionsUI" },
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Contact Picker app/C++/MainPage.xaml.cpp Source File

  • Contact Picker app

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Platform;
00026 using namespace ContactPicker;
00027 using namespace CppSamplesUtils;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     LayoutRoot->Children->Append(HiddenFrame);
00045
00046     // Populate the sample title from the constant in the GlobalVariables.cs file.
00047     SetContactPicker(FEATURE_NAME);
00048
00049     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00050     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00051
00052     MainPage::Current = this;
00053     autoSizeInputSectionWhenSnapped = true;
00054 }
00055
00056 MainPage::~MainPage()
00057 {
00058 }
00059
00060 /// <summary>
00061 /// Invoked when this page is about to be displayed in a Frame.
00062 /// </summary>
00063 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00064 /// property is typically used to configure the page.</param>
00065 void MainPage::OnNavigatedTo(NavigationEventArgs^ e)
00066 {
00067     PopulateScenarios();
00068     InvalidateViewState();
00069 }
00070
00071 /// <summary>
00072 /// We need to handle SizeChanged so that we can make the sample layout property
00073 /// in the various layouts.
00074 /// </summary>
00075 /// <param name="sender"></param>
00076 /// <param name="e"></param>
00077 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00078 {
00079     InvalidateSize();
00080     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00081     args->ViewState = ApplicationView::Value;
00082     MainPageResized(this, args);
00083
00084 }
00085
00086 void MainPage::InvalidateSize()
00087 {
00088     // Get the window width
00089     double windowWidth = this->ActualWidth;
00090
00091     if (windowWidth != 0.0)
00092     {
00093
00094         // Get the width of the ListBox.
00095         double listBoxWidth = Scenarios->ActualWidth;
00096
00097         // Is the ListBox using any margins that we need to consider?
00098         double listBoxMarginLeft = Scenarios->Margin.Left;
00099         double listBoxMarginRight = Scenarios->Margin.Right;
00100
00101         // Figure out how much room is left after considering the list box width
00102         double availableWidth = windowWidth - listBoxWidth;
00103
00104         // Is the top most child using margins?
00105         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00106         double layoutRootMarginRight = ContentRoot->Margin.Right;
00107
00108         // We have different widths to use depending on the view state
00109         if (ApplicationView::Value != ApplicationViewState::Snapped)
00110         {
00111             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00112             // and the LayoutRoot's margins
00113             InputSection->Width = ((availableWidth) -
00114                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00115         }
00116         else
00117         {
00118             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00119             if (autoSizeInputSectionWhenSnapped)
00120             {
00121                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00122             }
00123         }
00124     }
00125     InvalidateViewState();
00126 }
00127
00128 void MainPage::InvalidateViewState()
00129 {
00130     // Are we going to snapped mode?
00131     if (ApplicationView::Value == ApplicationViewState::Snapped)
00132     {
00133         Grid::SetRow(DescriptionText, 3);
00134         Grid::SetColumn(DescriptionText, 0);
00135
00136         Grid::SetRow(InputSection, 4);
00137         Grid::SetColumn(InputSection, 0);
00138
00139         Grid::SetRow(FooterPanel, 2);
00140         Grid::SetColumn(FooterPanel, 0);
00141     }
00142     else
00143     {
00144         Grid::SetRow(DescriptionText, 1);
00145         Grid::SetColumn(DescriptionText, 1);
00146
00147         Grid::SetRow(InputSection, 2);
00148         Grid::SetColumn(InputSection, 1);
00149
00150         Grid::SetRow(FooterPanel, 1);
00151         Grid::SetColumn(FooterPanel, 1);
00152     }
00153
00154 }
00155
00156 #pragma optimize("", off)
00157 void MainPage::PopulateScenarios()
00158 {
00159     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00160
00161     // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00162     for (unsigned int i = 0; i < scenarios->Length; ++i)
00163     {
00164         Scenario s = scenarios[i];
00165         ListBoxItem^ item = ref new ListBoxItem();
00166         item->Name = s.ClassName;
00167         item->Content = (i + 1).ToString() + ") " + s.Title;
00168         ScenarioList->Append(item);
00169     }
00170
00171     // Bind the ListBox to the scenario list.
00172     Scenarios->ItemsSource = ScenarioList;
00173
00174     // Starting scenario is the first or based upon a previous selection.
00175     ListBoxItem^ startingScenario = nullptr;
00176
00177     // Starting scenario is the first or based upon a previous selection.
00178     int startingScenarioIndex = -1;
00179
00180     auto ps = SuspensionManager::SessionState();
00181     if (ps->HasKey("SelectedScenarioIndex"))
00182     {
00183         int selectedScenarioIndex = safe_cast<int>(ps->Lookup("SelectedScenarioIndex"));
00184         startingScenarioIndex = selectedScenarioIndex;
00185     }
00186
00187     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00188 }
00189 #pragma optimize("", on)
00190
00191 /// <summary>
00192 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00193 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00194 /// and output sections into the respective UserControl on the main page.
00195 /// </summary>
00196 /// <param name="scenarioName"></param>
00197 void MainPage::LoadScenario(String^ scenarioName)
00198 {
00199     autoSizeInputSectionWhenSnapped = true;
00200
00201     // Load the ScenarioX.xaml file into the Frame.
00202     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00203     HiddenFrame->Navigate(scenarioType, this);
00204
00205     // Get the top element, the Page, so we can look up the elements
00206     // that represent the input and output sections of the ScenarioX file.
00207     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00208
00209     // Get each element.
00210     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00211     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00212
00213     if (input == nullptr)
00214     {
00215         // Malformed input section.
00216         NotifyUser("Cannot load scenario input section for " + scenarioName +
00217             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00218         return;
00219     }
00220
00221     if (output == nullptr)
00222     {
00223         // Malformed output section.
00224         NotifyUser("Cannot load scenario output section for " + scenarioName +
00225             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00226         return;
00227     }
00228
00229     // Find the LayoutRoot which parents the input and output sections in the main page.
00230     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00231
00232     if (panel != nullptr)
00233     {
00234         unsigned int index = 0;
00235         UIElementCollection^ collection = panel->Children;
00236
00237         // Get rid of the content that is currently in the intput and output sections.
00238         collection->IndexOf(input, &index);
00239         collection->RemoveAt(index);
00240
00241         collection->IndexOf(output, &index);
00242         collection->RemoveAt(index);
00243
00244         // Populate the input and output sections with the newly loaded content.
00245         InputSection->Content = input;
00246         OutputSection->Content = output;
00247
00248         ScenarioLoaded(this, nullptr);
00249     }
00250     else
00251     {
00252         // Malformed Scenario file.
00253         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00254             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00255     }
00256 }
00257
00258 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00259 {
00260     if (Scenarios->SelectedItem != nullptr)
00261     {
00262         NotifyUser("", NotifyType::StatusMessage);
00263
00264         int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00265         SuspensionManager::SessionState()->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00266
00267         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00268         InvalidateSize();
00269     }
00270 }
00271
00272 void MainPage::SetContactPicker(String^ strFeature)
00273 {
00274     ContactPicker->Text = strFeature;
00275 }
00276
00277 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00278 {
00279     switch (type)
00280     {
00281     case NotifyType::StatusMessage:
00282         // Use the status message style.
00283         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00284         break;
00285     case NotifyType::ErrorMessage:
00286         // Use the error message style.
00287         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00288         break;
00289     default:
00290         break;
00291     }
00292     StatusBlock->Text = strMessage;
00293
00294     // Collapsed the StatusBlock if it has no text to conserve real estate.
00295     if (StatusBlock->Text != "")
00296         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00297     else
00298         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00299 }
00300
00301 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00302 {
00303     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00304     Windows::System::Launcher::LaunchUriAsync(uri);
00305 }
00306
00307
Generated on Sat Nov 23 2024 16:07:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/pch.cpp Source File

  • App tiles and badges
  • C#,C++

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Push and periodic notifications client-side/C++/Constants.cpp Source File

  • Push and periodic notifications client-side

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     { "Opening a notification channel", "SDKSample.SDKTemplate.Scenario1" },
00020   { "Renewing channels", "SDKSample.SDKTemplate.Scenario2" },
00021     { "Listening for push notification events", "SDKSample.SDKTemplate.Scenario3" },
00022     { "Periodic tile updates", "SDKSample.SDKTemplate.Scenario4" },
00023   { "Periodic badge updates", "SDKSample.SDKTemplate.Scenario5" }
00024 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

GameRenderer Member List

This is the complete list of members for GameRenderer, including all inherited members.
__pad0__ | GameRenderer |
CreateDeviceIndependentResources() override | GameRenderer | [virtual]
CreateDeviceIndependentResources() override | GameRenderer | [virtual]
CreateDeviceResources() override | GameRenderer | [virtual]
CreateDeviceResources() override | GameRenderer | [virtual]
CreateGameDeviceResourcesAsync(_In_ Simple3DGame^game) | GameRenderer |
CreateGameDeviceResourcesAsync(_In_ Simple3DGame^game) | GameRenderer |
FinalizeCreateGameDeviceResources() | GameRenderer |
FinalizeCreateGameDeviceResources() | GameRenderer |
FinalizeLoadLevelResources() | GameRenderer |
FinalizeLoadLevelResources() | GameRenderer |
GameInfoOverlayLowerRight() | GameRenderer | [inline]
GameInfoOverlayUpperLeft() | GameRenderer | [inline]
HandleDeviceLost() override | GameRenderer | [virtual]
HandleDeviceLost() override | GameRenderer | [virtual]
Hud() | GameRenderer |
InfoOverlay() | GameRenderer | [inline]
Initialize(_In_ Windows::UI::Core::CoreWindow^window, float dpi) override | GameRenderer | [virtual]
Initialize(_In_ Windows::UI::Core::CoreWindow^window, _In_ Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^swapChainPanel, float dpi) override | GameRenderer | [virtual]
LoadLevelResourcesAsync() | GameRenderer |
LoadLevelResourcesAsync() | GameRenderer |
m_ceilingTexture | GameRenderer | [private]
m_constantBufferChangeOnResize | GameRenderer | [private]
m_constantBufferChangesEveryFrame | GameRenderer | [private]
m_constantBufferChangesEveryPrim | GameRenderer | [private]
m_constantBufferNeverChanges | GameRenderer | [private]
m_cylinderTexture | GameRenderer | [private]
m_floorTexture | GameRenderer | [private]
m_game | GameRenderer | [private]
m_gameHud | GameRenderer | [private]
m_gameInfoOverlay | GameRenderer | [private]
m_gameResourcesLoaded | GameRenderer | [private]
m_initialized | GameRenderer | [private]
m_levelResourcesLoaded | GameRenderer | [private]
m_pixelShader | GameRenderer | [private]
m_pixelShaderFlat | GameRenderer | [private]
m_samplerLinear | GameRenderer | [private]
m_sphereTexture | GameRenderer | [private]
m_vertexLayout | GameRenderer | [private]
m_vertexShader | GameRenderer | [private]
m_vertexShaderFlat | GameRenderer | [private]
m_wallsTexture | GameRenderer | [private]
Render() override | GameRenderer | [virtual]
Render() override | GameRenderer | [virtual]
SetBackground(uint32 background) | GameRenderer |
SetDpi(float dpi) override | GameRenderer | [virtual]
UpdateForWindowSizeChange() override | GameRenderer | [virtual]
UpdateForWindowSizeChange() override | GameRenderer | [virtual]
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/LocalCache.h Source File

  • Language font mapping

LocalCache.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // LocalCache.h
00009 // Declaration of the LocalCache class.
00010 //
00011
00012
00013 #include "pch.h"
00014
00015 #pragma once
00016 namespace LanguageFontCPP
00017 {
00018     [Windows::Foundation::Metadata::WebHostHidden]
00019     public ref class FontInfoLocal sealed
00020     {
00021     public:
00022         void Set(Windows::UI::Xaml::Controls::TextBlock^ textBlock);
00023         void Reset(Windows::UI::Xaml::Controls::TextBlock^ textBlock);
00024         static void SetFont(Windows::UI::Xaml::Controls::TextBlock^ textBlock, Windows::Globalization::Fonts::LanguageFont^ languageFont);
00025   private:
00026         Windows::UI::Xaml::Media::FontFamily^  _fontFamily;
00027         Windows::UI::Text::FontWeight  _fontWeight;
00028         Windows::UI::Text::FontStyle  _fontStyle;
00029         Windows::UI::Text::FontStretch  _fontStretch;
00030     };
00031 }
Generated on Sat Nov 23 2024 16:08:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SimpleSprites Member List

This is the complete list of members for SimpleSprites, including all inherited members.
__pad0__ | SimpleSprites |
AddRepulsor(_In_ uint32 id, _In_ float2 position) | SimpleSprites |
CreateDeviceIndependentResources() override | SimpleSprites | [virtual]
CreateDeviceResources() override | SimpleSprites | [virtual]
CreateWindowSizeDependentResources() override | SimpleSprites | [virtual]
m_asteroid | SimpleSprites | [private]
m_asteroidData | SimpleSprites | [private]
m_autoThrottle | SimpleSprites | [private]
m_background | SimpleSprites | [private]
m_numParticlesToDraw | SimpleSprites | [private]
m_particle | SimpleSprites | [private]
m_particleData | SimpleSprites | [private]
m_repulsors | SimpleSprites | [private]
m_sampleOverlay | SimpleSprites | [private]
m_spriteBatch | SimpleSprites | [private]
MoveRepulsor(_In_ uint32 id, _In_ float2 position) | SimpleSprites |
RandFloat(float min, float max) | SimpleSprites | [private]
RemoveRepulsor(_In_ uint32 id) | SimpleSprites |
Render() override | SimpleSprites | [virtual]
Update(float timeTotal, float timeDelta) | SimpleSprites |
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Constants.h Source File

  • Credential locker

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Password Vault");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Transcoding media/C++/MainPage.xaml.h Source File

  • Transcoding media

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML FlipView control/C++/common/LayoutAwarePage.cpp Source File

  • XAML FlipView control
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AnimateLinePosition Member List

This is the complete list of members for AnimateLinePosition, including all inherited members.
__pad0__ | AnimateLinePosition |
continuous | AnimateLinePosition |
duration | AnimateLinePosition |
endPosition | AnimateLinePosition |
Evaluate(_In_ float t) override | AnimateLinePosition | [virtual]
Evaluate(_In_ float t) override | AnimateLinePosition | [virtual]
m_endPosition | AnimateLinePosition | [private]
m_length | AnimateLinePosition | [private]
m_startPosition | AnimateLinePosition | [private]
Generated on Sat Nov 23 2024 16:09:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario1.xaml.cpp Source File

  • XAML scrolling, panning, and zooming

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::ScrollViewerCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario1::Scenario1()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 // Invoked when this page is about to be displayed in a Frame.
00031 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00032 {
00033     rootPage = MainPage::Current;
00034 }
00035
00036 // Handler for the horizontal mode visibility combo box
00037 void SDKSample::ScrollViewerCPP::Scenario1::hsmCombo_SelectionChanged_1(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00038 {
00039   if (scrollViewer == nullptr)
00040   {
00041       return;
00042   }
00043
00044   auto cb = (ComboBox^)sender;
00045
00046   if (cb != nullptr)
00047   {
00048       switch (cb->SelectedIndex)
00049       {
00050           case 0: // Auto
00051               scrollViewer->HorizontalScrollMode = ScrollMode::Auto;
00052               break;
00053           case 1: //Enabled
00054               scrollViewer->HorizontalScrollMode = ScrollMode::Enabled;
00055               break;
00056           case 2: // Disabled
00057               scrollViewer->HorizontalScrollMode = ScrollMode::Disabled;
00058               break;
00059           default:
00060               scrollViewer->HorizontalScrollMode = ScrollMode::Enabled;
00061               break;
00062       }
00063   }
00064 }
00065
00066 // Handler for the horizontal scroll visibility combo box
00067 void SDKSample::ScrollViewerCPP::Scenario1::hsbvCombo_SelectionChanged_1(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00068 {
00069   if (scrollViewer == nullptr)
00070   {
00071       return;
00072   }
00073
00074   auto cb = (ComboBox^)sender;
00075
00076   if (cb != nullptr)
00077   {
00078       switch (cb->SelectedIndex)
00079       {
00080           case 0: // Auto
00081               scrollViewer->HorizontalScrollBarVisibility = ScrollBarVisibility::Auto;
00082               break;
00083           case 1: //Enabled
00084               scrollViewer->HorizontalScrollBarVisibility = ScrollBarVisibility::Visible;
00085               break;
00086           case 2: // Disabled
00087               scrollViewer->HorizontalScrollBarVisibility = ScrollBarVisibility::Hidden;
00088               break;
00089           default:
00090               scrollViewer->HorizontalScrollBarVisibility = ScrollBarVisibility::Disabled;
00091               break;
00092       }
00093   }
00094 }
00095
00096 // Handler for the vertical scroll mode combo box
00097 void SDKSample::ScrollViewerCPP::Scenario1::vsmCombo_SelectionChanged_1(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00098 {
00099   if (scrollViewer == nullptr)
00100   {
00101       return;
00102   }
00103
00104   auto cb = (ComboBox^)sender;
00105
00106   if (cb != nullptr)
00107   {
00108       switch (cb->SelectedIndex)
00109       {
00110           case 0: // Auto
00111               scrollViewer->VerticalScrollMode = ScrollMode::Auto;
00112               break;
00113           case 1: //Enabled
00114               scrollViewer->VerticalScrollMode = ScrollMode::Enabled;
00115               break;
00116           case 2: // Disabled
00117               scrollViewer->VerticalScrollMode = ScrollMode::Disabled;
00118               break;
00119           default:
00120               scrollViewer->VerticalScrollMode = ScrollMode::Enabled;
00121               break;
00122       }
00123   }
00124 }
00125
00126 // Handler for the vertical scroll visibility combo box
00127 void SDKSample::ScrollViewerCPP::Scenario1::vsbvCombo_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e)
00128 {
00129   if (scrollViewer == nullptr)
00130   {
00131       return;
00132   }
00133
00134   auto cb = (ComboBox^) sender;
00135
00136   if (cb != nullptr)
00137   {
00138       switch (cb->SelectedIndex)
00139       {
00140           case 0: // Auto
00141               scrollViewer->VerticalScrollBarVisibility = ScrollBarVisibility::Auto;
00142               break;
00143           case 1: //Visible
00144               scrollViewer->VerticalScrollBarVisibility = ScrollBarVisibility::Visible;
00145               break;
00146           case 2: // Hidden
00147               scrollViewer->VerticalScrollBarVisibility = ScrollBarVisibility::Hidden;
00148               break;
00149           case 3: // Disabled
00150               scrollViewer->VerticalScrollBarVisibility = ScrollBarVisibility::Disabled;
00151               break;
00152           default:
00153               scrollViewer->VerticalScrollBarVisibility = ScrollBarVisibility::Disabled;
00154               break;
00155       }
00156   }
00157 }
00158
00159 // Checked handler for horizontal railed check box
00160 void SDKSample::ScrollViewerCPP::Scenario1::CheckBox_Checked_HorizontalRailed(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00161 {
00162   scrollViewer->IsHorizontalRailEnabled = true;
00163 }
00164
00165 // Unchecked handler for horizontal railed check box
00166 void SDKSample::ScrollViewerCPP::Scenario1::CheckBox_Unchecked_HorizontalRailed(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00167 {
00168   scrollViewer->IsHorizontalRailEnabled = false;
00169 }
00170
00171 // Checked handler for vertical railed check box
00172 void SDKSample::ScrollViewerCPP::Scenario1::CheckBox_Checked_VerticalRailed(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00173 {
00174   scrollViewer->IsVerticalRailEnabled = true;
00175 }
00176
00177 // Unchecked handler for vertical railed check box
00178 void SDKSample::ScrollViewerCPP::Scenario1::CheckBox_Unchecked_VerticalRailed(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00179 {
00180   scrollViewer->IsVerticalRailEnabled = false;
00181 }
00182
00183 // Call Scenario1Reset
00184 void SDKSample::ScrollViewerCPP::Scenario1::Scenario1Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00185 {
00186   Scenario1Reset();
00187 }
00188
00189 // Reset the scenario
00190 void SDKSample::ScrollViewerCPP::Scenario1::Scenario1Reset()
00191 {
00192   //Restore to defaults
00193   hsbvCombo->SelectedIndex = 3;
00194   hsmCombo->SelectedIndex = 1;
00195   vsbvCombo->SelectedIndex = 1;
00196   vsmCombo->SelectedIndex = 1;
00197   hrCheckbox->IsChecked = true;
00198   vrCheckbox->IsChecked = true;
00199 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicShapes.cpp Source File

  • DXGI swap chain rotation

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File and folder thumbnail/C++/MainPage.xaml.h Source File

  • File and folder thumbnail

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraCaptureUI/C++/MainPage.xaml.cpp Source File

  • CameraCaptureUI

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Camera.h Source File

  • DirectX 3D shooting game

Camera.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Camera:
00011 // This class defines the position, orientation and viewing frustum of a camera looking into
00012 // a 3D world.  It will generate both the View matrix and Projection matrix.  It can also
00013 // provide a pair of Projection matrices to be used when stereoscopic 3D is used.
00014
00015 ref class Camera
00016 {
00017 internal:
00018     Camera();
00019
00020     void SetViewParams(_In_ DirectX::XMFLOAT3 eye, _In_ DirectX::XMFLOAT3 lookAt, _In_ DirectX::XMFLOAT3 up);
00021     void SetProjParams(_In_ float fieldOfView, _In_ float aspectRatio, _In_ float nearPlane, _In_ float farPlane);
00022
00023     void LookDirection (_In_ DirectX::XMFLOAT3 lookDirection);
00024     void Eye (_In_ DirectX::XMFLOAT3 position);
00025
00026     DirectX::XMMATRIX View();
00027     DirectX::XMMATRIX Projection();
00028     DirectX::XMMATRIX LeftEyeProjection();
00029     DirectX::XMMATRIX RightEyeProjection();
00030     DirectX::XMMATRIX World();
00031     DirectX::XMFLOAT3 Eye();
00032     DirectX::XMFLOAT3 LookAt();
00033     DirectX::XMFLOAT3 Up();
00034     float NearClipPlane();
00035     float FarClipPlane();
00036     float Pitch();
00037     float Yaw();
00038
00039 protected private:
00040     DirectX::XMFLOAT4X4 m_viewMatrix;
00041     DirectX::XMFLOAT4X4 m_projectionMatrix;
00042     DirectX::XMFLOAT4X4 m_projectionMatrixLeft;
00043     DirectX::XMFLOAT4X4 m_projectionMatrixRight;
00044
00045     DirectX::XMFLOAT4X4 m_inverseView;
00046
00047     DirectX::XMFLOAT3 m_eye;
00048     DirectX::XMFLOAT3 m_lookAt;
00049     DirectX::XMFLOAT3 m_up;
00050     float             m_cameraYawAngle;
00051     float             m_cameraPitchAngle;
00052
00053     float             m_fieldOfView;
00054     float             m_aspectRatio;
00055     float             m_nearPlane;
00056     float             m_farPlane;
00057 };
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Decoder/decoder.cpp Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Decoder

decoder.cpp

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // decoder.cpp
00004 // Implements the MPEG-1 decoder.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015 #include "decoder.h"
00016 #include "BufferLock.h"
00017 #include <strsafe.h>
00018
00019 void    OurFillRect(PBYTE pbScanline0, DWORD dwWidth, DWORD dwHeight, LONG lStrideInBytes, COLORREF color);
00020
00021 #ifndef LODWORD
00022 #define LODWORD(x)  ((DWORD)(((DWORD_PTR)(x)) & 0xffffffff))
00023 #endif
00024
00025 const UINT32 MAX_VIDEO_WIDTH = 4095;        // per ISO/IEC 11172-2
00026 const UINT32 MAX_VIDEO_HEIGHT = 4095;
00027
00028 //-------------------------------------------------------------------
00029 // CDecoder class
00030 //-------------------------------------------------------------------
00031
00032 CDecoder::CDecoder() :
00033     m_pInputType(nullptr),
00034     m_pOutputType(nullptr),
00035     m_pBuffer(nullptr),
00036     m_pbData(nullptr),
00037     m_cbData(0),
00038     m_imageWidthInPixels(0),
00039     m_imageHeightInPixels(0),
00040     m_cbImageSize(0),
00041     m_rtFrame(0),
00042     m_rtLength(0),
00043     m_bPicture(false),
00044     m_bLowLatencyMode(false)
00045 {
00046     InitializeCriticalSectionEx(&m_critSec, 100, 0);
00047
00048     m_frameRate.Numerator = m_frameRate.Denominator = 0;
00049
00050 }
00051
00052 CDecoder::~CDecoder()
00053 {
00054     SafeRelease(&m_pBuffer);
00055     DeleteCriticalSection(&m_critSec);
00056 }
00057
00058 // IMediaExtension methods
00059
00060 //-------------------------------------------------------------------
00061 // Name: SetProperties
00062 // Sets the configuration of the decoder
00063 //-------------------------------------------------------------------
00064 IFACEMETHODIMP CDecoder::SetProperties (ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
00065 {
00066     return S_OK;
00067 }
00068
00069 // IMFTransform methods. Refer to the Media Foundation SDK documentation for details.
00070
00071 //-------------------------------------------------------------------
00072 // Name: GetStreamLimits
00073 // Returns the minimum and maximum number of streams.
00074 //-------------------------------------------------------------------
00075
00076 HRESULT CDecoder::GetStreamLimits(
00077     DWORD   *pdwInputMinimum,
00078     DWORD   *pdwInputMaximum,
00079     DWORD   *pdwOutputMinimum,
00080     DWORD   *pdwOutputMaximum
00081 )
00082 {
00083
00084     if ((pdwInputMinimum == NULL) ||
00085         (pdwInputMaximum == NULL) ||
00086         (pdwOutputMinimum == NULL) ||
00087         (pdwOutputMaximum == NULL))
00088     {
00089         return E_POINTER;
00090     }
00091
00092
00093     // This MFT has a fixed number of streams.
00094     *pdwInputMinimum = 1;
00095     *pdwInputMaximum = 1;
00096     *pdwOutputMinimum = 1;
00097     *pdwOutputMaximum = 1;
00098
00099     return S_OK;
00100 }
00101
00102
00103 //-------------------------------------------------------------------
00104 // Name: GetStreamCount
00105 // Returns the actual number of streams.
00106 //-------------------------------------------------------------------
00107
00108 HRESULT CDecoder::GetStreamCount(
00109     DWORD   *pcInputStreams,
00110     DWORD   *pcOutputStreams
00111 )
00112 {
00113     if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))
00114
00115     {
00116         return E_POINTER;
00117     }
00118
00119     // This MFT has a fixed number of streams.
00120     *pcInputStreams = 1;
00121     *pcOutputStreams = 1;
00122
00123     return S_OK;
00124 }
00125
00126
00127
00128 //-------------------------------------------------------------------
00129 // Name: GetStreamIDs
00130 // Returns stream IDs for the input and output streams.
00131 //-------------------------------------------------------------------
00132
00133 HRESULT CDecoder::GetStreamIDs(
00134     DWORD   /*dwInputIDArraySize*/,
00135     DWORD   * /*pdwInputIDs*/,
00136     DWORD   /*dwOutputIDArraySize*/,
00137     DWORD   * /*pdwOutputIDs*/
00138 )
00139 {
00140     // Do not need to implement, because this MFT has a fixed number of
00141     // streams and the stream IDs match the stream indexes.
00142     return E_NOTIMPL;
00143 }
00144
00145
00146 //-------------------------------------------------------------------
00147 // Name: GetInputStreamInfo
00148 // Returns information about an input stream.
00149 //-------------------------------------------------------------------
00150
00151 HRESULT CDecoder::GetInputStreamInfo(
00152     DWORD                     dwInputStreamID,
00153     MFT_INPUT_STREAM_INFO *   pStreamInfo
00154 )
00155 {
00156     if (pStreamInfo == NULL)
00157     {
00158         return E_POINTER;
00159     }
00160
00161     if (!IsValidInputStream(dwInputStreamID))
00162     {
00163         return MF_E_INVALIDSTREAMNUMBER;
00164     }
00165
00166     pStreamInfo->hnsMaxLatency = 0;
00167
00168     //  We can process data on any boundary.
00169     pStreamInfo->dwFlags = 0;
00170
00171     pStreamInfo->cbSize = 1;
00172     pStreamInfo->cbMaxLookahead = 0;
00173     pStreamInfo->cbAlignment = 1;
00174
00175     return S_OK;
00176 }
00177
00178
00179
00180 //-------------------------------------------------------------------
00181 // Name: GetOutputStreamInfo
00182 // Returns information about an output stream.
00183 //-------------------------------------------------------------------
00184
00185 HRESULT CDecoder::GetOutputStreamInfo(
00186     DWORD                     dwOutputStreamID,
00187     MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00188 )
00189 {
00190     if (pStreamInfo == NULL)
00191     {
00192         return E_POINTER;
00193     }
00194
00195     if (!IsValidOutputStream(dwOutputStreamID))
00196     {
00197         return MF_E_INVALIDSTREAMNUMBER;
00198     }
00199
00200     EnterCriticalSection(&m_critSec);
00201
00202     // NOTE: This method should succeed even when there is no media type on the
00203     //       stream. If there is no media type, we only need to fill in the dwFlags
00204     //       member of MFT_OUTPUT_STREAM_INFO. The other members depend on having a
00205     //       a valid media type.
00206
00207     pStreamInfo->dwFlags =
00208         MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
00209         MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
00210         MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;
00211
00212     if (m_pOutputType == NULL)
00213     {
00214         pStreamInfo->cbSize = 0;
00215         pStreamInfo->cbAlignment = 0;
00216     }
00217     else
00218     {
00219         pStreamInfo->cbSize = m_cbImageSize;
00220         pStreamInfo->cbAlignment = 1;
00221     }
00222
00223     LeaveCriticalSection(&m_critSec);
00224
00225     return S_OK;
00226 }
00227
00228
00229
00230 //-------------------------------------------------------------------
00231 // Name: GetAttributes
00232 // Returns the attributes for the MFT.
00233 //-------------------------------------------------------------------
00234
00235 HRESULT CDecoder::GetAttributes(IMFAttributes** /*pAttributes*/)
00236 {
00237     // This MFT does not support any attributes, so the method is not implemented.
00238     return E_NOTIMPL;
00239 }
00240
00241
00242
00243 //-------------------------------------------------------------------
00244 // Name: GetInputStreamAttributes
00245 // Returns stream-level attributes for an input stream.
00246 //-------------------------------------------------------------------
00247
00248 HRESULT CDecoder::GetInputStreamAttributes(
00249     DWORD           /*dwInputStreamID*/,
00250     IMFAttributes   ** /*ppAttributes*/
00251 )
00252 {
00253     // This MFT does not support any attributes, so the method is not implemented.
00254     return E_NOTIMPL;
00255 }
00256
00257
00258
00259 //-------------------------------------------------------------------
00260 // Name: GetOutputStreamAttributes
00261 // Returns stream-level attributes for an output stream.
00262 //-------------------------------------------------------------------
00263
00264 HRESULT CDecoder::GetOutputStreamAttributes(
00265     DWORD           /*dwOutputStreamID*/,
00266     IMFAttributes   ** /*ppAttributes*/
00267 )
00268 {
00269     // This MFT does not support any attributes, so the method is not implemented.
00270     return E_NOTIMPL;
00271 }
00272
00273
00274
00275 //-------------------------------------------------------------------
00276 // Name: DeleteInputStream
00277 //-------------------------------------------------------------------
00278
00279 HRESULT CDecoder::DeleteInputStream(DWORD /*dwStreamID*/)
00280 {
00281     // This MFT has a fixed number of input streams, so the method is not implemented.
00282     return E_NOTIMPL;
00283 }
00284
00285
00286
00287 //-------------------------------------------------------------------
00288 // Name: AddInputStreams
00289 //-------------------------------------------------------------------
00290
00291 HRESULT CDecoder::AddInputStreams(
00292     DWORD   /*cStreams*/,
00293     DWORD   * /*adwStreamIDs*/
00294 )
00295 {
00296     // This MFT has a fixed number of output streams, so the method is not implemented.
00297     return E_NOTIMPL;
00298 }
00299
00300
00301
00302 //-------------------------------------------------------------------
00303 // Name: GetInputAvailableType
00304 // Description: Return a preferred input type.
00305 //-------------------------------------------------------------------
00306
00307 HRESULT CDecoder::GetInputAvailableType(
00308     DWORD           /*dwInputStreamID*/,
00309     DWORD           /*dwTypeIndex*/,
00310     IMFMediaType    ** /*ppType*/
00311 )
00312 {
00313     return MF_E_NO_MORE_TYPES;
00314 }
00315
00316
00317
00318 //-------------------------------------------------------------------
00319 // Name: GetOutputAvailableType
00320 // Description: Return a preferred output type.
00321 //-------------------------------------------------------------------
00322
00323 HRESULT CDecoder::GetOutputAvailableType(
00324     DWORD           dwOutputStreamID,
00325     DWORD           dwTypeIndex, // 0-based
00326     IMFMediaType    **ppType
00327 )
00328 {
00329     if (ppType == NULL)
00330     {
00331         return E_INVALIDARG;
00332     }
00333
00334     if (!IsValidOutputStream(dwOutputStreamID))
00335     {
00336         return MF_E_INVALIDSTREAMNUMBER;
00337     }
00338
00339     if (dwTypeIndex != 0)
00340     {
00341         return MF_E_NO_MORE_TYPES;
00342     }
00343
00344     EnterCriticalSection(&m_critSec);
00345
00346     HRESULT hr = S_OK;
00347
00348     IMFMediaType *pOutputType = NULL;
00349
00350     if (m_pInputType == NULL)
00351     {
00352         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00353     }
00354
00355     if (SUCCEEDED(hr))
00356     {
00357         hr = MFCreateMediaType(&pOutputType);
00358     }
00359
00360     if (SUCCEEDED(hr))
00361     {
00362         hr = pOutputType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
00363     }
00364
00365     if (SUCCEEDED(hr))
00366     {
00367         hr = pOutputType->SetGUID(MF_MT_SUBTYPE, MFVideoFormat_RGB32);
00368     }
00369
00370     if (SUCCEEDED(hr))
00371     {
00372         hr = pOutputType->SetUINT32(MF_MT_FIXED_SIZE_SAMPLES, TRUE);
00373     }
00374
00375     if (SUCCEEDED(hr))
00376     {
00377         hr = pOutputType->SetUINT32(MF_MT_ALL_SAMPLES_INDEPENDENT, TRUE);
00378     }
00379
00380     if (SUCCEEDED(hr))
00381     {
00382         hr = pOutputType->SetUINT32(MF_MT_SAMPLE_SIZE, m_imageHeightInPixels * m_imageWidthInPixels * 4);
00383     }
00384
00385     if (SUCCEEDED(hr))
00386     {
00387         hr = MFSetAttributeSize(pOutputType, MF_MT_FRAME_SIZE, m_imageWidthInPixels, m_imageHeightInPixels);
00388     }
00389
00390     if (SUCCEEDED(hr))
00391     {
00392         hr = MFSetAttributeRatio(pOutputType, MF_MT_FRAME_RATE, m_frameRate.Numerator, m_frameRate.Denominator);
00393     }
00394
00395     if (SUCCEEDED(hr))
00396     {
00397         hr = pOutputType->SetUINT32(MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
00398     }
00399
00400     if (SUCCEEDED(hr))
00401     {
00402         hr = MFSetAttributeRatio(pOutputType, MF_MT_PIXEL_ASPECT_RATIO, 1, 1);
00403     }
00404
00405     if (SUCCEEDED(hr))
00406     {
00407         *ppType = pOutputType;
00408         (*ppType)->AddRef();
00409     }
00410
00411     SafeRelease(&pOutputType);
00412     LeaveCriticalSection(&m_critSec);
00413     return hr;
00414 }
00415
00416
00417
00418 //-------------------------------------------------------------------
00419 // Name: SetInputType
00420 //-------------------------------------------------------------------
00421
00422 HRESULT CDecoder::SetInputType(
00423     DWORD           dwInputStreamID,
00424     IMFMediaType    *pType, // Can be NULL to clear the input type.
00425     DWORD           dwFlags
00426 )
00427 {
00428     if (!IsValidInputStream(dwInputStreamID))
00429     {
00430         return MF_E_INVALIDSTREAMNUMBER;
00431     }
00432
00433     // Validate flags.
00434     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00435     {
00436         return E_INVALIDARG;
00437     }
00438
00439     HRESULT hr = S_OK;
00440
00441     EnterCriticalSection(&m_critSec);
00442
00443     // Does the caller want us to set the type, or just test it?
00444     BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);
00445
00446     // If we have an input sample, the client cannot change the type now.
00447     if (HasPendingOutput())
00448     {
00449         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00450     }
00451
00452     // Validate the type, if non-NULL.
00453     if (SUCCEEDED(hr))
00454     {
00455         if (pType)
00456         {
00457             hr = OnCheckInputType(pType);
00458         }
00459     }
00460
00461     if (SUCCEEDED(hr))
00462     {
00463         // The type is OK.
00464         // Set the type, unless the caller was just testing.
00465         if (bReallySet)
00466         {
00467             hr = OnSetInputType(pType);
00468         }
00469     }
00470
00471     LeaveCriticalSection(&m_critSec);
00472     return hr;
00473 }
00474
00475
00476
00477 //-------------------------------------------------------------------
00478 // Name: SetOutputType
00479 //-------------------------------------------------------------------
00480
00481 HRESULT CDecoder::SetOutputType(
00482     DWORD           dwOutputStreamID,
00483     IMFMediaType    *pType, // Can be NULL to clear the output type.
00484     DWORD           dwFlags
00485 )
00486 {
00487     if (!IsValidOutputStream(dwOutputStreamID))
00488     {
00489         return MF_E_INVALIDSTREAMNUMBER;
00490     }
00491
00492     // Validate flags.
00493     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00494     {
00495         return E_INVALIDARG;
00496     }
00497
00498     HRESULT hr = S_OK;
00499
00500     EnterCriticalSection(&m_critSec);
00501
00502     // Does the caller want us to set the type, or just test it?
00503      BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);
00504
00505     // If we have an input sample, the client cannot change the type now.
00506     if (HasPendingOutput())
00507     {
00508         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00509     }
00510
00511     // Validate the type, if non-NULL.
00512     if (SUCCEEDED(hr))
00513     {
00514         if (pType)
00515         {
00516             hr = OnCheckOutputType(pType);
00517         }
00518     }
00519
00520     if (SUCCEEDED(hr))
00521     {
00522         if (bReallySet)
00523         {
00524             // The type is OK.
00525             // Set the type, unless the caller was just testing.
00526             hr = OnSetOutputType(pType);
00527         }
00528     }
00529
00530     LeaveCriticalSection(&m_critSec);
00531     return hr;
00532 }
00533
00534
00535
00536 //-------------------------------------------------------------------
00537 // Name: GetInputCurrentType
00538 // Description: Returns the current input type.
00539 //-------------------------------------------------------------------
00540
00541 HRESULT CDecoder::GetInputCurrentType(
00542     DWORD           dwInputStreamID,
00543     IMFMediaType    **ppType
00544 )
00545 {
00546     if (ppType == NULL)
00547     {
00548         return E_POINTER;
00549     }
00550
00551     if (!IsValidInputStream(dwInputStreamID))
00552     {
00553         return MF_E_INVALIDSTREAMNUMBER;
00554     }
00555
00556     EnterCriticalSection(&m_critSec);
00557
00558     HRESULT hr = S_OK;
00559
00560     if (!m_pInputType)
00561     {
00562         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00563     }
00564
00565     if (SUCCEEDED(hr))
00566     {
00567         *ppType = m_pInputType;
00568         (*ppType)->AddRef();
00569     }
00570
00571     LeaveCriticalSection(&m_critSec);
00572     return hr;
00573 }
00574
00575
00576
00577 //-------------------------------------------------------------------
00578 // Name: GetOutputCurrentType
00579 // Description: Returns the current output type.
00580 //-------------------------------------------------------------------
00581
00582 HRESULT CDecoder::GetOutputCurrentType(
00583     DWORD           dwOutputStreamID,
00584     IMFMediaType    **ppType
00585 )
00586 {
00587     if (ppType == NULL)
00588     {
00589         return E_POINTER;
00590     }
00591
00592     if (!IsValidOutputStream(dwOutputStreamID))
00593     {
00594         return MF_E_INVALIDSTREAMNUMBER;
00595     }
00596
00597     EnterCriticalSection(&m_critSec);
00598
00599     HRESULT hr = S_OK;
00600
00601     if (!m_pOutputType)
00602     {
00603         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00604     }
00605
00606     if (SUCCEEDED(hr))
00607     {
00608         *ppType = m_pOutputType;
00609         (*ppType)->AddRef();
00610     }
00611
00612     LeaveCriticalSection(&m_critSec);
00613     return hr;
00614 }
00615
00616
00617
00618 //-------------------------------------------------------------------
00619 // Name: GetInputStatus
00620 // Description: Query if the MFT is accepting more input.
00621 //-------------------------------------------------------------------
00622
00623 HRESULT CDecoder::GetInputStatus(
00624     DWORD           dwInputStreamID,
00625     DWORD           *pdwFlags
00626 )
00627 {
00628     if (pdwFlags == NULL)
00629     {
00630         return E_POINTER;
00631     }
00632
00633     if (!IsValidInputStream(dwInputStreamID))
00634     {
00635         return MF_E_INVALIDSTREAMNUMBER;
00636     }
00637
00638     EnterCriticalSection(&m_critSec);
00639
00640     // If we already have an input sample, we don't accept
00641     // another one until the client calls ProcessOutput or Flush.
00642     if (HasPendingOutput())
00643     {
00644         *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
00645     }
00646     else
00647     {
00648         *pdwFlags = 0;
00649     }
00650
00651     LeaveCriticalSection(&m_critSec);
00652     return S_OK;
00653 }
00654
00655
00656
00657 //-------------------------------------------------------------------
00658 // Name: GetOutputStatus
00659 // Description: Query if the MFT can produce output.
00660 //-------------------------------------------------------------------
00661
00662 HRESULT CDecoder::GetOutputStatus(DWORD *pdwFlags)
00663 {
00664     if (pdwFlags == NULL)
00665     {
00666         return E_POINTER;
00667     }
00668
00669     EnterCriticalSection(&m_critSec);
00670
00671     // We can produce an output sample if (and only if)
00672     // we have an input sample.
00673     if (HasPendingOutput())
00674     {
00675         *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
00676     }
00677     else
00678     {
00679         *pdwFlags = 0;
00680     }
00681
00682     LeaveCriticalSection(&m_critSec);
00683     return S_OK;
00684 }
00685
00686
00687
00688 //-------------------------------------------------------------------
00689 // Name: SetOutputBounds
00690 // Sets the range of time stamps that the MFT will output.
00691 //-------------------------------------------------------------------
00692
00693 HRESULT CDecoder::SetOutputBounds(
00694     LONGLONG        /*hnsLowerBound*/,
00695     LONGLONG        /*hnsUpperBound*/
00696 )
00697 {
00698     // Implementation of this method is optional.
00699     return E_NOTIMPL;
00700 }
00701
00702
00703
00704 //-------------------------------------------------------------------
00705 // Name: ProcessEvent
00706 // Sends an event to an input stream.
00707 //-------------------------------------------------------------------
00708
00709 HRESULT CDecoder::ProcessEvent(
00710     DWORD              /*dwInputStreamID*/,
00711     IMFMediaEvent      * /*pEvent */
00712 )
00713 {
00714     // This MFT does not handle any stream events, so the method can
00715     // return E_NOTIMPL. This tells the pipeline that it can stop
00716     // sending any more events to this MFT.
00717     return E_NOTIMPL;
00718 }
00719
00720
00721
00722 //-------------------------------------------------------------------
00723 // Name: ProcessMessage
00724 //-------------------------------------------------------------------
00725
00726 HRESULT CDecoder::ProcessMessage(
00727     MFT_MESSAGE_TYPE    eMessage,
00728     ULONG_PTR           /*ulParam*/
00729 )
00730 {
00731     EnterCriticalSection(&m_critSec);
00732
00733     HRESULT hr = S_OK;
00734
00735     switch (eMessage)
00736     {
00737     case MFT_MESSAGE_COMMAND_FLUSH:
00738         // Flush the MFT.
00739         hr = OnFlush();
00740         break;
00741
00742     case MFT_MESSAGE_COMMAND_DRAIN:
00743         // Set the discontinuity flag on all of the input.
00744         hr = OnDiscontinuity();
00745         break;
00746
00747     case MFT_MESSAGE_SET_D3D_MANAGER:
00748         // The pipeline should never send this message unless the MFT
00749         // has the MF_SA_D3D_AWARE attribute set to TRUE. However, if we
00750         // do get this message, it's invalid and we don't implement it.
00751         hr = E_NOTIMPL;
00752         break;
00753
00754
00755     case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
00756         hr = AllocateStreamingResources();
00757         break;
00758
00759     case MFT_MESSAGE_NOTIFY_END_STREAMING:
00760         hr = FreeStreamingResources();
00761         break;
00762
00763     // These messages do not require a response.
00764     case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
00765     case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
00766         break;
00767
00768     }
00769
00770     LeaveCriticalSection(&m_critSec);
00771     return hr;
00772 }
00773
00774
00775
00776 //-------------------------------------------------------------------
00777 // Name: ProcessInput
00778 // Description: Process an input sample.
00779 //-------------------------------------------------------------------
00780
00781 HRESULT CDecoder::ProcessInput(
00782     DWORD               dwInputStreamID,
00783     IMFSample           *pSample,
00784     DWORD               dwFlags
00785 )
00786 {
00787     if (pSample == NULL)
00788     {
00789         return E_POINTER;
00790     }
00791
00792     if (!IsValidInputStream(dwInputStreamID))
00793     {
00794         return MF_E_INVALIDSTREAMNUMBER;
00795     }
00796
00797     if (dwFlags != 0)
00798     {
00799         return E_INVALIDARG; // dwFlags is reserved and must be zero.
00800     }
00801
00802     EnterCriticalSection(&m_critSec);
00803
00804     HRESULT hr = S_OK;
00805     LONGLONG rtTimestamp = 0;
00806
00807     if (!m_pInputType || !m_pOutputType)
00808     {
00809         hr = MF_E_NOTACCEPTING;   // Client must set input and output types.
00810     }
00811     else if (HasPendingOutput())
00812     {
00813         hr = MF_E_NOTACCEPTING;   // We already have an input sample.
00814     }
00815
00816     // Convert to a single contiguous buffer.
00817     if (SUCCEEDED(hr))
00818     {
00819         // NOTE: This does not cause a copy unless there are multiple buffers
00820         hr = pSample->ConvertToContiguousBuffer(&m_pBuffer);
00821     }
00822
00823     if (SUCCEEDED(hr))
00824     {
00825         hr = m_pBuffer->Lock(&m_pbData, NULL, &m_cbData);
00826     }
00827
00828     if (SUCCEEDED(hr))
00829     {
00830         // Get the time stamp. It is OK if this call fails.
00831         if (FAILED(pSample->GetSampleTime(&rtTimestamp)))
00832         {
00833             rtTimestamp = INVALID_TIME;
00834         }
00835
00836         m_StreamState.TimeStamp(rtTimestamp);
00837
00838         hr = Process();
00839     }
00840
00841     LeaveCriticalSection(&m_critSec);
00842     return hr;
00843 }
00844
00845
00846
00847 //-------------------------------------------------------------------
00848 // Name: ProcessOutput
00849 // Description: Process an output sample.
00850 //-------------------------------------------------------------------
00851
00852 HRESULT CDecoder::ProcessOutput(
00853     DWORD                   dwFlags,
00854     DWORD                   cOutputBufferCount,
00855     MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
00856     DWORD                   *pdwStatus
00857 )
00858 {
00859     // Check input parameters...
00860
00861     // There are no flags that we accept in this MFT.
00862     // The only defined flag is MFT_PROCESS_OUTPUT_DISCARD_WHEN_NO_BUFFER. This
00863     // flag only applies when the MFT marks an output stream as lazy or optional.
00864     // However there are no lazy or optional streams on this MFT, so the flag is
00865     // not valid.
00866     if (dwFlags != 0)
00867     {
00868         return E_INVALIDARG;
00869     }
00870
00871     if (pOutputSamples == NULL || pdwStatus == NULL)
00872     {
00873         return E_POINTER;
00874     }
00875
00876     // Must be exactly one output buffer.
00877     if (cOutputBufferCount != 1)
00878     {
00879         return E_INVALIDARG;
00880     }
00881
00882     // It must contain a sample.
00883     if (pOutputSamples[0].pSample == NULL)
00884     {
00885         return E_INVALIDARG;
00886     }
00887
00888     EnterCriticalSection(&m_critSec);
00889
00890     HRESULT hr = S_OK;
00891     DWORD cbData = 0;
00892
00893     IMFMediaBuffer *pOutput = NULL;
00894
00895     // If we don't have an input sample, we need some input before
00896     // we can generate any output.
00897     if (!HasPendingOutput())
00898     {
00899         hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
00900     }
00901
00902     // Get the output buffer.
00903
00904     if (SUCCEEDED(hr))
00905     {
00906         hr = pOutputSamples[0].pSample->GetBufferByIndex(0, &pOutput);
00907     }
00908
00909     if (SUCCEEDED(hr))
00910     {
00911         hr = pOutput->GetMaxLength(&cbData);
00912     }
00913
00914     if (SUCCEEDED(hr))
00915     {
00916         if (cbData < m_cbImageSize)
00917         {
00918             hr = E_INVALIDARG;
00919         }
00920     }
00921
00922     if (SUCCEEDED(hr))
00923     {
00924         hr = InternalProcessOutput(pOutputSamples[0].pSample, pOutput);
00925     }
00926
00927     if (SUCCEEDED(hr))
00928     {
00929         //  Update our state
00930         m_bPicture = false;
00931
00932         //  Is there any more data to output at this point?
00933         if (S_OK == Process())
00934         {
00935             pOutputSamples[0].dwStatus |= MFT_OUTPUT_DATA_BUFFER_INCOMPLETE;
00936         }
00937     }
00938
00939     SafeRelease(&pOutput);
00940     LeaveCriticalSection(&m_critSec);
00941     return hr;
00942 }
00943
00944 // Private class methods
00945
00946
00947 HRESULT CDecoder::InternalProcessOutput(IMFSample *pSample, IMFMediaBuffer *pOutputBuffer)
00948 {
00949     VideoBufferLock buffer(pOutputBuffer);
00950
00951     HRESULT hr = S_OK;
00952
00953     BYTE *pbData = NULL;
00954     LONG lDefaultStride = 0;
00955     LONG lActualStride = 0;
00956
00957     DWORD dwTimeCode = 0;
00958     LONGLONG rt = 0;
00959     TCHAR szBuffer[20];
00960
00961     lDefaultStride = m_imageWidthInPixels * 4; // Works only for RGB32
00962
00963     if (SUCCEEDED(hr))
00964     {
00965         hr = buffer.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pbData, &lActualStride);
00966     }
00967
00968     //  Generate our data
00969     if (SUCCEEDED(hr))
00970     {
00971         rt = m_StreamState.PictureTime(&dwTimeCode);
00972
00973         hr = StringCchPrintf(szBuffer, ARRAYSIZE(szBuffer),
00974             TEXT("%2.2d:%2.2d:%2.2d:%2.2d\0"),
00975              (dwTimeCode >> 19) & 0x1F,
00976              (dwTimeCode >> 13) & 0x3F,
00977              (dwTimeCode >> 6) & 0x3F,
00978               dwTimeCode & 0x3F
00979               );
00980     }
00981
00982     if (SUCCEEDED(hr))
00983     {
00984         // Update our bitmap with turquoise
00985         OurFillRect(pbData, m_imageWidthInPixels, m_imageHeightInPixels, lActualStride, RGB(0xFF,0x80,0x80));
00986         OurFillRect(pbData, m_imageWidthInPixels/2, m_imageHeightInPixels/2, lActualStride, RGB(0x00,0xff,0x00));
00987
00988     }
00989
00990     if (SUCCEEDED(hr))
00991     {
00992         hr = pOutputBuffer->SetCurrentLength(m_cbImageSize);
00993     }
00994
00995     // Clean point / key frame
00996     if (SUCCEEDED(hr))
00997     {
00998         hr = pSample->SetUINT32(MFSampleExtension_CleanPoint, TRUE);
00999     }
01000
01001     //  Set the timestamp
01002     //  Uncompressed video must always have a timestamp
01003
01004     if (SUCCEEDED(hr))
01005     {
01006         rt = m_StreamState.PictureTime(&dwTimeCode);
01007         if (rt == INVALID_TIME)
01008         {
01009             rt = m_rtFrame;
01010         }
01011         hr = pSample->SetSampleTime(rt);
01012     }
01013
01014     if (SUCCEEDED(hr))
01015     {
01016         hr = pSample->SetSampleDuration(m_rtLength);
01017
01018     }
01019
01020     if (SUCCEEDED(hr))
01021     {
01022         m_rtFrame = rt + m_rtLength;
01023     }
01024
01025     return hr;
01026 }
01027
01028
01029 HRESULT CDecoder::OnCheckInputType(IMFMediaType *pmt)
01030 {
01031     HRESULT hr = S_OK;
01032
01033     //  Check if the type is already set and if so reject any type that's not identical.
01034     if (m_pInputType)
01035     {
01036         DWORD dwFlags = 0;
01037         if (S_OK == m_pInputType->IsEqual(pmt, &dwFlags))
01038         {
01039             return S_OK;
01040         }
01041         else
01042         {
01043             return MF_E_INVALIDTYPE;
01044         }
01045     }
01046
01047     GUID majortype = { 0 };
01048     GUID subtype = { 0 };
01049     UINT32 width = 0, height = 0;
01050     MFRatio fps = { 0 };
01051     UINT32 cbSeqHeader = 0;
01052
01053     //  We accept MFMediaType_Video, MEDIASUBTYPE_MPEG1Video
01054
01055     hr = pmt->GetMajorType(&majortype);
01056
01057     if (SUCCEEDED(hr))
01058     {
01059         if (majortype != MFMediaType_Video)
01060         {
01061             hr = MF_E_INVALIDTYPE;
01062         }
01063     }
01064
01065     if (SUCCEEDED(hr))
01066     {
01067         hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
01068     }
01069
01070     if (SUCCEEDED(hr))
01071     {
01072         if (subtype != MFVideoFormat_MPG1)
01073         {
01074             hr = MF_E_INVALIDTYPE;
01075         }
01076     }
01077
01078     // At this point a real decoder would validate the MPEG-1 format.
01079
01080     // Validate the frame size.
01081
01082     if (SUCCEEDED(hr))
01083     {
01084         hr = MFGetAttributeSize(pmt, MF_MT_FRAME_SIZE, &width, &height);
01085     }
01086
01087     if (SUCCEEDED(hr))
01088     {
01089         if (width > MAX_VIDEO_WIDTH || height > MAX_VIDEO_HEIGHT)
01090         {
01091             hr = MF_E_INVALIDTYPE;
01092         }
01093     }
01094
01095     // Make sure there is a frame rate.
01096     // *** A real decoder would also validate this. ***
01097
01098     if (SUCCEEDED(hr))
01099     {
01100         hr = MFGetAttributeRatio(pmt, MF_MT_FRAME_RATE, (UINT32*)&fps.Numerator, (UINT32*)&fps.Denominator);
01101     }
01102
01103     // Check for a sequence header.
01104     // We don't actually look at it for this sample.
01105     // *** A real decoder would validate the sequence header. ***
01106
01107     if (SUCCEEDED(hr))
01108     {
01109         (void)pmt->GetBlobSize(MF_MT_MPEG_SEQUENCE_HEADER, &cbSeqHeader);
01110
01111         if (cbSeqHeader < MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE)
01112         {
01113             hr = MF_E_INVALIDTYPE;
01114         }
01115     }
01116
01117     return hr;
01118 }
01119
01120
01121 HRESULT CDecoder::OnSetInputType(IMFMediaType *pmt)
01122 {
01123     HRESULT hr = S_OK;
01124
01125     SafeRelease(&m_pInputType);
01126
01127     hr = MFGetAttributeSize(pmt, MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);
01128
01129     if (SUCCEEDED(hr))
01130     {
01131        hr = MFGetAttributeRatio(pmt, MF_MT_FRAME_RATE, (UINT32*)&m_frameRate.Numerator, (UINT32*)&m_frameRate.Denominator);
01132     }
01133
01134     // Also store the frame duration, derived from the frame rate.
01135     if (SUCCEEDED(hr))
01136     {
01137
01138         if (m_frameRate.Numerator == 0 || m_frameRate.Denominator == 0) {
01139             m_rtLength = 0;
01140             return E_FAIL;
01141         }
01142
01143         double fRate = (double)m_frameRate.Numerator / m_frameRate.Denominator;
01144
01145         m_rtLength = (UINT64)((10000000 / fRate) + 0.5);
01146     }
01147
01148     if (SUCCEEDED(hr))
01149     {
01150         m_cbImageSize = m_imageWidthInPixels * m_imageHeightInPixels * 4;
01151
01152         m_pInputType = pmt;
01153         m_pInputType->AddRef();
01154     }
01155
01156     return hr;
01157 }
01158
01159 HRESULT CDecoder::OnCheckOutputType(IMFMediaType *pmt)
01160 {
01161     //  Check if the type is already set and if so reject any type that's not identical.
01162     if (m_pOutputType)
01163     {
01164         DWORD dwFlags = 0;
01165         if (S_OK == m_pOutputType->IsEqual(pmt, &dwFlags))
01166         {
01167             return S_OK;
01168         }
01169         else
01170         {
01171             return MF_E_INVALIDTYPE;
01172         }
01173     }
01174
01175     if (m_pInputType == NULL)
01176     {
01177         return MF_E_TRANSFORM_TYPE_NOT_SET; // Input type must be set first.
01178     }
01179
01180
01181     HRESULT hr = S_OK;
01182     BOOL bMatch = FALSE;
01183
01184     IMFMediaType *pOurType = NULL;
01185
01186     // Make sure their type is a superset of our proposed output type.
01187     hr = GetOutputAvailableType(0, 0, &pOurType);
01188
01189     if (SUCCEEDED(hr))
01190     {
01191         hr = pOurType->Compare(pmt, MF_ATTRIBUTES_MATCH_OUR_ITEMS, &bMatch);
01192     }
01193
01194     if (SUCCEEDED(hr))
01195     {
01196         if (!bMatch)
01197         {
01198             hr = MF_E_INVALIDTYPE;
01199         }
01200     }
01201
01202     SafeRelease(&pOurType);
01203     return hr;
01204 }
01205
01206
01207 HRESULT CDecoder::OnSetOutputType(IMFMediaType *pmt)
01208 {
01209     SafeRelease(&m_pOutputType);
01210
01211     m_pOutputType = pmt;
01212     m_pOutputType->AddRef();
01213
01214     return S_OK;
01215 }
01216
01217
01218 HRESULT CDecoder::AllocateStreamingResources()
01219 {
01220     //  Reinitialize variables
01221     OnDiscontinuity();
01222
01223     return S_OK;
01224 }
01225
01226 HRESULT CDecoder::FreeStreamingResources()
01227 {
01228     return S_OK;
01229 }
01230
01231 HRESULT CDecoder::OnDiscontinuity()
01232 {
01233     //  Zero our timestamp
01234     m_rtFrame = 0;
01235
01236     //  No pictures yet
01237    m_bPicture   = false;
01238
01239    //  Reset state machine
01240    m_StreamState.Reset();
01241    return S_OK;
01242 }
01243
01244 HRESULT CDecoder::OnFlush()
01245 {
01246     OnDiscontinuity();
01247
01248     //  Release buffer
01249     SafeRelease(&m_pBuffer);
01250
01251     return S_OK;
01252 }
01253
01254
01255 //  Scan input data until either we're exhausted or we find
01256 //  a picture start code
01257 //  Note GOP time codes as we encounter them so we can
01258 //  output time codes
01259
01260 HRESULT CDecoder::Process()
01261 {
01262     //  Process bytes and update our state machine
01263     while (m_cbData && !m_bPicture)
01264     {
01265         m_bPicture = m_StreamState.NextByte(*m_pbData);
01266         m_cbData--;
01267         m_pbData++;
01268     }
01269
01270     //  Release buffer if we're done with it
01271     if (m_cbData == 0)
01272     {
01273         m_pBuffer->Unlock();
01274
01275         m_pbData = NULL;
01276
01277         SafeRelease(&m_pBuffer);
01278     }
01279
01280     //  assert that if have no picture to output then we ate all the data
01281     assert(m_bPicture || m_cbData == 0);
01282     return S_OK;
01283 }
01284
01285
01286 //-------------------------------------------------------------------
01287 // CStreamState
01288 //-------------------------------------------------------------------
01289 void CStreamState::TimeStamp(REFERENCE_TIME rt)
01290 {
01291     DWORD dwIndex = m_cbBytes >= 4 ? 0 : m_cbBytes;
01292
01293     m_arTS[dwIndex].bValid = true;
01294     m_arTS[dwIndex].rt = rt;
01295 }
01296
01297 void CStreamState::Reset()
01298 {
01299     m_cbBytes = 0;
01300     m_dwNextTimeCode = 0;
01301
01302     for (int i = 0; i < 4; i++) {
01303         m_arTS[i].bValid = false;
01304     }
01305 }
01306
01307 bool CStreamState::NextByte(BYTE bData)
01308 {
01309     assert(m_arTS[0].bValid);
01310
01311     switch (m_cbBytes)
01312     {
01313         case 0:
01314             if (bData == 0) {
01315                 m_cbBytes++;
01316             }
01317             return false;
01318
01319         case 1:
01320             if (bData == 0) {
01321                 m_cbBytes++;
01322             } else {
01323                 m_cbBytes = 0;
01324
01325                 //  Pick up new timestamp if there was one
01326                 if (m_arTS[1].bValid) {
01327                     m_arTS[0].rt = m_arTS[1].rt;
01328                     m_arTS[1].bValid = false;
01329                 }
01330             }
01331             return false;
01332
01333         case 2:
01334             if (bData == 1) {
01335                 m_cbBytes++;
01336             } else {
01337                 if (bData == 0) {
01338                    if (m_arTS[1].bValid) {
01339                        m_arTS[0].rt = m_arTS[1].rt;
01340                        m_arTS[1].bValid = false;
01341                    }
01342                    if (m_arTS[2].bValid) {
01343                        m_arTS[1] = m_arTS[2];
01344                        m_arTS[2].bValid = false;
01345                    }
01346                 } else {
01347                     //  Not 0 or 1, revert
01348                     m_cbBytes = 0;
01349
01350                     //  and pick up latest timestamp
01351                     if (m_arTS[1].bValid) {
01352                         m_arTS[0].rt = m_arTS[1].rt;
01353                         m_arTS[1].bValid = false;
01354                     }
01355                     if (m_arTS[2].bValid) {
01356                         m_arTS[0].rt = m_arTS[2].rt;
01357                         m_arTS[2].bValid = false;
01358                     }
01359                 }
01360             }
01361             return false;
01362
01363         case 3:
01364         {
01365             //  It's a start code
01366             //  Return the timestamp and reset everything
01367             m_rt = m_arTS[0].rt;
01368
01369             //  If it's a picture start code can't use this timestamp again.
01370             if (0 == bData) {
01371                 m_arTS[0].rt = INVALID_TIME;
01372                 m_cbBytes = 0;
01373             }
01374
01375             //  Catch up and clean out timestamps
01376             for (int i = 1; i < 4; i++) {
01377                 if (m_arTS[i].bValid) {
01378                     m_arTS[0].rt = m_arTS[i].rt;
01379                     m_arTS[i].bValid = false;
01380                 }
01381             }
01382
01383             // Picture start code?
01384             if (0 == bData) {
01385                 m_cbBytes = 0;
01386                 m_dwTimeCode = m_dwNextTimeCode;
01387                 m_dwNextTimeCode++;
01388                 return true;
01389             } else {
01390                 //  Is it a GOP start code?
01391                 if (bData == 0xb8) {
01392                     m_cbBytes++;
01393                 } else {
01394                     m_cbBytes = 0;
01395                 }
01396                 return false;
01397             }
01398         }
01399
01400         case 4:
01401         case 5:
01402         case 6:
01403         case 7:
01404             m_bGOPData[m_cbBytes - 4] = bData;
01405             m_cbBytes++;
01406
01407             if (m_cbBytes == 8) {
01408                 m_cbBytes = 0;
01409                 m_dwNextTimeCode = ((DWORD)m_bGOPData[0] << 17) +
01410                                    ((DWORD)m_bGOPData[1] << 9) +
01411                                    ((DWORD)m_bGOPData[2] << 1) +
01412                                    ((DWORD)m_bGOPData[3] >> 7);
01413             }
01414             return false;
01415     }
01416
01417     // Should never reach here
01418     return false;
01419 };
01420
01421
01422
01423 //-------------------------------------------------------------------
01424 // Static functions
01425 //-------------------------------------------------------------------
01426
01427
01428 //-------------------------------------------------------------------
01429 // OurFillRect
01430 //
01431 // Fills a bitmap with a specified color.
01432 //
01433 // pvih: Pointer to a VIDEOINFOHEADER structure that describes the
01434 //       bitmap.
01435 // pbData: Pointer to the start of the bitmap.
01436 // color: Fill color.
01437 //-------------------------------------------------------------------
01438
01439 void OurFillRect(PBYTE pbScanline0, DWORD dwWidth, DWORD dwHeight, LONG lStrideInBytes, COLORREF color)
01440 {
01441     PBYTE pbPixels = pbScanline0;
01442
01443     // For just filling we don't care which way up the bitmap is -
01444     // we just start at pbData
01445     for(DWORD dwCount = 0; dwCount < dwHeight; dwCount++) {
01446         DWORD *pWord = (DWORD *)pbPixels;
01447
01448         for(DWORD dwPixel = 0; dwPixel < dwWidth; dwPixel++) {
01449             pWord[dwPixel] = (DWORD)color;
01450         }
01451
01452         //  biWidth is the stride
01453         pbPixels += lStrideInBytes;
01454     }
01455 }
01456
01457
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ContentImageSource.cpp Source File

  • Direct2D magazine app

ContentImageSource.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Microsoft::WRL;
00011 using namespace Windows::UI::Xaml::Media;
00012 using namespace Windows::UI::Xaml::Media::Imaging;
00013
00014 ContentImageSource::ContentImageSource(
00015     _In_ Element^ content,
00016     _In_ Document^ document,
00017     bool isOpaque
00018     ) :
00019     m_refCount(),
00020     m_content(content),
00021     m_contentSize(),
00022     m_document(document),
00023     m_imageSource(nullptr),
00024     m_imageSourceNative(),
00025     m_isOpaque(isOpaque)
00026 {
00027 }
00028
00029 void ContentImageSource::Initialize()
00030 {
00031     // Measure the content and store its size.
00032     Measure(&m_contentSize);
00033
00034     // Create an image source at the initial pixel size.
00035     // The last parameter helps improve rendering performance when the image source is known to be opaque.
00036     m_imageSource = ref new VirtualSurfaceImageSource(m_contentSize.cx, m_contentSize.cy, m_isOpaque);
00037
00038     ComPtr<IUnknown> unknown(reinterpret_cast<IUnknown*>(m_imageSource));
00039     unknown.As(&m_imageSourceNative);
00040
00041     auto renderer = m_document->GetRenderer();
00042
00043     // Set DXGI device to the image source
00044     ComPtr<IDXGIDevice> dxgiDevice;
00045     renderer->GetDXGIDevice(&dxgiDevice);
00046     m_imageSourceNative->SetDevice(dxgiDevice.Get());
00047
00048     // Register image source's update callback so update can be made to it.
00049     m_imageSourceNative->RegisterForUpdatesNeeded(this);
00050 }
00051
00052 ImageSource^ ContentImageSource::GetImageSource()
00053 {
00054     if (m_imageSource == nullptr)
00055     {
00056         Initialize();
00057     }
00058
00059     return m_imageSource;
00060 }
00061
00062 SIZE ContentImageSource::GetImageSize()
00063 {
00064     if (m_imageSource == nullptr)
00065     {
00066         Initialize();
00067     }
00068
00069     return m_contentSize;
00070 }
00071
00072 // This method is called when the framework needs to update region managed by
00073 // the virtual surface image source.
00074 HRESULT STDMETHODCALLTYPE ContentImageSource::UpdatesNeeded()
00075 {
00076     HRESULT hr = S_OK;
00077
00078     try
00079     {
00080         ULONG drawingBoundsCount = 0;
00081
00082         DX::ThrowIfFailed(
00083             m_imageSourceNative->GetUpdateRectCount(&drawingBoundsCount)
00084             );
00085
00086         std::unique_ptr<RECT[]> drawingBounds(new RECT[drawingBoundsCount]);
00087
00088         DX::ThrowIfFailed(
00089             m_imageSourceNative->GetUpdateRects(drawingBounds.get(), drawingBoundsCount)
00090             );
00091
00092         // This code doesn't try to coalesce multiple drawing bounds into one. Although that
00093         // extra process will reduce the number of draw calls, it requires the virtual surface
00094         // image source to manage non-uniform tile size, which requires it to make extra copy
00095         // operations to the compositor. By using the drawing bounds it directly returns, which are
00096         // of non-overlapping uniform tile size, the compositor is able to use these tiles directly,
00097         // which can greatly reduce the amount of memory needed by the virtual surface image source.
00098         // It will result in more draw calls though, but Direct2D will be able to accommodate that
00099         // without significant impact on presentation frame rate.
00100         for (ULONG i = 0; i < drawingBoundsCount; ++i)
00101         {
00102             if (Draw(drawingBounds[i]))
00103             {
00104                 // Drawing isn't complete. This can happen when the content is still being
00105                 // asynchronously loaded. Inform the image source to invalidate the drawing
00106                 // bounds so that it calls back to redraw.
00107                 DX::ThrowIfFailed(
00108                     m_imageSourceNative->Invalidate(drawingBounds[i])
00109                     );
00110             }
00111         }
00112     }
00113     catch (Platform::Exception^ exception)
00114     {
00115         hr = exception->HResult;
00116
00117         if (hr == D2DERR_RECREATE_TARGET ||
00118             hr == DXGI_ERROR_DEVICE_REMOVED)
00119         {
00120             // If a device lost error is encountered, notify the renderer. The renderer will then
00121             // recreate the device and fire the DeviceLost event so that all listeners can take
00122             // an appropriate action.
00123             m_document->GetRenderer()->HandleDeviceLost();
00124
00125             // Invalidate the image source so that it calls back to redraw
00126             RECT bounds = { 0, 0, m_contentSize.cx, m_contentSize.cy };
00127             m_imageSourceNative->Invalidate(bounds);
00128         }
00129     }
00130
00131     return hr;
00132 }
00133
00134 void ContentImageSource::Measure(_Out_ SIZE* contentSize)
00135 {
00136     D2D1_RECT_F contentBounds = {0};
00137
00138     // Measure the drawing content
00139     m_content->Measure(
00140         m_document,
00141         m_document->GetPageSize(),
00142         &contentBounds
00143         );
00144
00145     contentSize->cx = static_cast<long>(m_document->DesignToDisplayWidth(contentBounds.right - contentBounds.left));
00146     contentSize->cy = static_cast<long>(m_document->DesignToDisplayHeight(contentBounds.bottom - contentBounds.top));
00147 }
00148
00149 bool ContentImageSource::Draw(RECT const& drawingBounds)
00150 {
00151     ComPtr<IDXGISurface> dxgiSurface;
00152     POINT surfaceOffset = {0};
00153     bool needRedraw;
00154
00155     HRESULT hr = S_OK;
00156     {
00157         // If the underlying device is lost, the virtual surface image source may return a
00158         // device lost error from BeginDraw. In this case, the error will be thrown here
00159         // and caught in UpdatesNeeded
00160         ImageSourceDrawHelper imageSourceDrawHelper(
00161             m_imageSourceNative.Get(),
00162             drawingBounds,
00163             &dxgiSurface,
00164             &surfaceOffset,
00165             &hr
00166             );
00167
00168         auto renderer = m_document->GetRenderer();
00169
00170         ComPtr<ID2D1DeviceContext> d2dDeviceContext;
00171         renderer->GetD2DDeviceContext(&d2dDeviceContext);
00172
00173         ComPtr<ID2D1Bitmap1> bitmap;
00174         DX::ThrowIfFailed(
00175             d2dDeviceContext->CreateBitmapFromDxgiSurface(
00176                 dxgiSurface.Get(),
00177                 nullptr,
00178                 &bitmap
00179                 )
00180             );
00181
00182         // Begin the drawing batch
00183         d2dDeviceContext->BeginDraw();
00184
00185         // Scale content design coordinate to the display coordinate,
00186         // then translate the drawing to the designated place on the surface.
00187         D2D1::Matrix3x2F transform =
00188             D2D1::Matrix3x2F::Scale(
00189                 m_document->DesignToDisplayWidth(1.0f),
00190                 m_document->DesignToDisplayHeight(1.0f)
00191                 ) *
00192             D2D1::Matrix3x2F::Translation(
00193                 static_cast<float>(surfaceOffset.x - drawingBounds.left),
00194                 static_cast<float>(surfaceOffset.y - drawingBounds.top)
00195                 );
00196
00197         // Prepare to draw content. This is the appropriate time for content element
00198         // to draw to an intermediate if there is any. It is important for performance
00199         // reason that SetTarget isn't called too frequently. Preparing the intermediates
00200         // upfront reduces the number of times the render target switches back and forth.
00201         needRedraw = m_content->PrepareToDraw(
00202             m_document,
00203             transform
00204             );
00205
00206         if (!needRedraw)
00207         {
00208             // Set the render target to surface given by the framework
00209             d2dDeviceContext->SetTarget(bitmap.Get());
00210
00211             d2dDeviceContext->SetTransform(D2D1::IdentityMatrix());
00212
00213             // Constrain the drawing only to the designated portion of the surface
00214             d2dDeviceContext->PushAxisAlignedClip(
00215                 D2D1::RectF(
00216                     static_cast<float>(surfaceOffset.x),
00217                     static_cast<float>(surfaceOffset.y),
00218                     static_cast<float>(surfaceOffset.x + (drawingBounds.right - drawingBounds.left)),
00219                     static_cast<float>(surfaceOffset.y + (drawingBounds.bottom - drawingBounds.top))
00220                     ),
00221                 D2D1_ANTIALIAS_MODE_ALIASED
00222                 );
00223
00224             // The Clear call must follow and not precede the PushAxisAlignedClip call.
00225             // Placing the Clear call before the clip is set violates the contract of the
00226             // virtual surface image source in that the application draws outside the
00227             // designated portion of the surface the image source hands over to it. This
00228             // violation won't actually cause the content to spill outside the designated
00229             // area because the image source will safeguard it. But this extra protection
00230             // has a runtime cost associated with it, and in some drivers this cost can be
00231             // very expensive. So the best performance strategy here is to never create a
00232             // situation where this protection is required. Not drawing outside the appropriate
00233             // clip does that the right way.
00234             d2dDeviceContext->Clear(D2D1::ColorF(0, 0));
00235
00236             // Draw the content
00237             needRedraw = m_content->Draw(
00238                 m_document,
00239                 transform
00240                 );
00241
00242             d2dDeviceContext->PopAxisAlignedClip();
00243
00244             d2dDeviceContext->SetTarget(nullptr);
00245         }
00246
00247         // End the drawing
00248         // UpdatesNeeded handles D2DERR_RECREATETARGET, so it is okay to throw this error here.
00249         DX::ThrowIfFailed(
00250             d2dDeviceContext->EndDraw()
00251             );
00252     }
00253
00254     DX::ThrowIfFailed(hr);
00255
00256     return needRedraw;
00257 }
00258
00259 void ContentImageSource::UpdateContent(_In_ Element^ content)
00260 {
00261     if (m_imageSourceNative != nullptr)
00262     {
00263         SIZE oldContentSize = m_contentSize;
00264
00265         m_content = content;
00266
00267         Measure(&m_contentSize);
00268
00269         DX::ThrowIfFailed(
00270             m_imageSourceNative->Resize(m_contentSize.cx, m_contentSize.cy)
00271             );
00272
00273         RECT bounds = {0};
00274         bounds.right =  m_contentSize.cx;
00275         bounds.bottom = m_contentSize.cy;
00276
00277         DX::ThrowIfFailed(
00278             m_imageSourceNative->Invalidate(bounds)
00279             );
00280     }
00281 }
00282
00283 HRESULT STDMETHODCALLTYPE ContentImageSource::QueryInterface(
00284     REFIID uuid,
00285     _Outptr_ void** object
00286     )
00287 {
00288     if (    uuid == IID_IUnknown
00289         ||  uuid == __uuidof(IVirtualSurfaceUpdatesCallbackNative)
00290         )
00291     {
00292         *object = this;
00293         AddRef();
00294         return S_OK;
00295     }
00296     else
00297     {
00298         *object = nullptr;
00299         return E_NOINTERFACE;
00300     }
00301 }
00302
00303 ULONG STDMETHODCALLTYPE ContentImageSource::AddRef()
00304 {
00305     return static_cast<ULONG>(InterlockedIncrement(&m_refCount));
00306 }
00307
00308 ULONG STDMETHODCALLTYPE ContentImageSource::Release()
00309 {
00310     ULONG newCount = static_cast<ULONG>(InterlockedDecrement(&m_refCount));
00311
00312     if (newCount == 0)
00313         delete this;
00314
00315     return newCount;
00316 }
00317
00318 ContentImageSource::ImageSourceDrawHelper::ImageSourceDrawHelper(
00319     IVirtualSurfaceImageSourceNative *imageSourceNative,
00320     _In_ RECT updateRect,
00321     _Out_ IDXGISurface **pSurface,
00322     _Out_ POINT *offset,
00323     _Inout_ HRESULT *hr
00324     ) :
00325     m_imageSourceNative(imageSourceNative),
00326     m_hr(hr)
00327 {
00328     DX::ThrowIfFailed(
00329         imageSourceNative->BeginDraw(
00330             updateRect,
00331             pSurface,
00332             offset
00333             )
00334         );
00335 }
00336
00337 ContentImageSource::ImageSourceDrawHelper::~ImageSourceDrawHelper()
00338 {
00339     // It is not safe to throw from a destructor. Instead we pass the error back to the caller
00340     // and let the caller throw the error.
00341     *m_hr = m_imageSourceNative->EndDraw();
00342 }
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/SimpleSprites.h Source File

  • Direct3D sprite

SimpleSprites.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXBase.h"
00011 #include "SampleOverlay.h"
00012 #include "AutoThrottle.h"
00013 #include "BasicSprites.h"
00014
00015 namespace SampleSettings
00016 {
00017     static const unsigned int NumAsteroids = 50;
00018     namespace Performance
00019     {
00020         static const float TargetFrameTime = 1.0f / 20.0f;
00021         static const unsigned int InitialParticleCount = 5000;
00022         static const unsigned int ParticleCountDelta = 32;
00023         static const unsigned int ParticleCountMin = 1000;
00024         static const unsigned int ParticleCountMax = 60000;
00025     }
00026     namespace Physics
00027     {
00028         static const float Gravity = 40000000.0f;
00029         static const float Damping = 0.015f;
00030     }
00031 }
00032
00033 struct AsteroidData
00034 {
00035     float2 pos;
00036     float2 vel;
00037     float rot;
00038     float rotVel;
00039     float scale;
00040 };
00041
00042 struct ParticleData
00043 {
00044     float2 pos;
00045     float2 vel;
00046 };
00047
00048 ref class SimpleSprites : public DirectXBase
00049 {
00050 internal:
00051     SimpleSprites();
00052     virtual void CreateDeviceIndependentResources() override;
00053     virtual void CreateDeviceResources() override;
00054     virtual void CreateWindowSizeDependentResources() override;
00055     virtual void Render() override;
00056     void Update(float timeTotal, float timeDelta);
00057     void AddRepulsor(_In_ uint32 id, _In_ float2 position);
00058     void MoveRepulsor(_In_ uint32 id, _In_ float2 position);
00059     void RemoveRepulsor(_In_ uint32 id);
00060
00061 private:
00062     float RandFloat(float min, float max);
00063     SampleOverlay^ m_sampleOverlay;
00064     AutoThrottle^ m_autoThrottle;
00065     BasicSprites::SpriteBatch^ m_spriteBatch;
00066     Microsoft::WRL::ComPtr<ID3D11Texture2D> m_background;
00067     Microsoft::WRL::ComPtr<ID3D11Texture2D> m_asteroid;
00068     Microsoft::WRL::ComPtr<ID3D11Texture2D> m_particle;
00069     std::vector<AsteroidData> m_asteroidData;
00070     std::vector<ParticleData> m_particleData;
00071     std::map<uint32, float2> m_repulsors;
00072     int m_numParticlesToDraw;
00073 };
Generated on Sat Nov 23 2024 16:08:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/BasicLoader.h Source File

  • Direct3D bump mapping

BasicLoader.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicReaderWriter.h"
00011
00012 // A simple loader class that provides support for loading shaders, textures,
00013 // and meshes from files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicLoader
00015 {
00016 internal:
00017     BasicLoader(
00018         _In_ ID3D11Device* d3dDevice,
00019         _In_opt_ IWICImagingFactory2* wicFactory = nullptr
00020         );
00021
00022     void LoadTexture(
00023         _In_ Platform::String^ filename,
00024         _Out_opt_ ID3D11Texture2D** texture,
00025         _Out_opt_ ID3D11ShaderResourceView** textureView
00026         );
00027
00028     concurrency::task<void> LoadTextureAsync(
00029         _In_ Platform::String^ filename,
00030         _Out_opt_ ID3D11Texture2D** texture,
00031         _Out_opt_ ID3D11ShaderResourceView** textureView
00032         );
00033
00034     void LoadShader(
00035         _In_ Platform::String^ filename,
00036         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00037         _In_ uint32 layoutDescNumElements,
00038         _Out_ ID3D11VertexShader** shader,
00039         _Out_opt_ ID3D11InputLayout** layout
00040         );
00041
00042     concurrency::task<void> LoadShaderAsync(
00043         _In_ Platform::String^ filename,
00044         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00045         _In_ uint32 layoutDescNumElements,
00046         _Out_ ID3D11VertexShader** shader,
00047         _Out_opt_ ID3D11InputLayout** layout
00048         );
00049
00050     void LoadShader(
00051         _In_ Platform::String^ filename,
00052         _Out_ ID3D11PixelShader** shader
00053         );
00054
00055     concurrency::task<void> LoadShaderAsync(
00056         _In_ Platform::String^ filename,
00057         _Out_ ID3D11PixelShader** shader
00058         );
00059
00060     void LoadShader(
00061         _In_ Platform::String^ filename,
00062         _Out_ ID3D11ComputeShader** shader
00063         );
00064
00065     concurrency::task<void> LoadShaderAsync(
00066         _In_ Platform::String^ filename,
00067         _Out_ ID3D11ComputeShader** shader
00068         );
00069
00070     void LoadShader(
00071         _In_ Platform::String^ filename,
00072         _Out_ ID3D11GeometryShader** shader
00073         );
00074
00075     concurrency::task<void> LoadShaderAsync(
00076         _In_ Platform::String^ filename,
00077         _Out_ ID3D11GeometryShader** shader
00078         );
00079
00080     void LoadShader(
00081         _In_ Platform::String^ filename,
00082         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00083         _In_ uint32 numEntries,
00084         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00085         _In_ uint32 numStrides,
00086         _In_ uint32 rasterizedStream,
00087         _Out_ ID3D11GeometryShader** shader
00088         );
00089
00090     concurrency::task<void> LoadShaderAsync(
00091         _In_ Platform::String^ filename,
00092         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00093         _In_ uint32 numEntries,
00094         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00095         _In_ uint32 numStrides,
00096         _In_ uint32 rasterizedStream,
00097         _Out_ ID3D11GeometryShader** shader
00098         );
00099
00100     void LoadShader(
00101         _In_ Platform::String^ filename,
00102         _Out_ ID3D11HullShader** shader
00103         );
00104
00105     concurrency::task<void> LoadShaderAsync(
00106         _In_ Platform::String^ filename,
00107         _Out_ ID3D11HullShader** shader
00108         );
00109
00110     void LoadShader(
00111         _In_ Platform::String^ filename,
00112         _Out_ ID3D11DomainShader** shader
00113         );
00114
00115     concurrency::task<void> LoadShaderAsync(
00116         _In_ Platform::String^ filename,
00117         _Out_ ID3D11DomainShader** shader
00118         );
00119
00120     void LoadMesh(
00121         _In_ Platform::String^ filename,
00122         _Out_ ID3D11Buffer** vertexBuffer,
00123         _Out_ ID3D11Buffer** indexBuffer,
00124         _Out_opt_ uint32* vertexCount,
00125         _Out_opt_ uint32* indexCount
00126         );
00127
00128     concurrency::task<void> LoadMeshAsync(
00129         _In_ Platform::String^ filename,
00130         _Out_ ID3D11Buffer** vertexBuffer,
00131         _Out_ ID3D11Buffer** indexBuffer,
00132         _Out_opt_ uint32* vertexCount,
00133         _Out_opt_ uint32* indexCount
00134         );
00135
00136 private:
00137     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00138     Microsoft::WRL::ComPtr<IWICImagingFactory2> m_wicFactory;
00139     BasicReaderWriter^ m_basicReaderWriter;
00140
00141     template <class DeviceChildType>
00142     inline void SetDebugName(
00143         _In_ DeviceChildType* object,
00144         _In_ Platform::String^ name
00145         );
00146
00147     Platform::String^ GetExtension(
00148         _In_ Platform::String^ filename
00149         );
00150
00151     void CreateTexture(
00152         _In_ bool decodeAsDDS,
00153         _In_reads_bytes_(dataSize) byte* data,
00154         _In_ uint32 dataSize,
00155         _Out_opt_ ID3D11Texture2D** texture,
00156         _Out_opt_ ID3D11ShaderResourceView** textureView,
00157         _In_opt_ Platform::String^ debugName
00158         );
00159
00160     void CreateInputLayout(
00161         _In_reads_bytes_(bytecodeSize) byte* bytecode,
00162         _In_ uint32 bytecodeSize,
00163         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00164         _In_ uint32 layoutDescNumElements,
00165         _Out_ ID3D11InputLayout** layout
00166         );
00167
00168     void CreateMesh(
00169         _In_ byte* meshData,
00170         _Out_ ID3D11Buffer** vertexBuffer,
00171         _Out_ ID3D11Buffer** indexBuffer,
00172         _Out_opt_ uint32* vertexCount,
00173         _Out_opt_ uint32* indexCount,
00174         _In_opt_ Platform::String^ debugName
00175         );
00176 };
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text editing/C++/Common/suspensionmanager.h Source File

  • XAML text editing
  • Common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/Scenario3.xaml.h Source File

  • XAML vector-based drawing

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace Drawing
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario3 sealed
00031         {
00032         public:
00033             Scenario3();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         void ColorSelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs e);
00040         void ColorOffsetValueChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs e);
00041         void LoadGradient();
00042         };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/VideoChat.xaml.cs Source File

  • Real-time communication
  • C#,C++

VideoChat.xaml.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using Windows.UI.Xaml;
00012 using Windows.UI.Xaml.Controls;
00013 using Windows.UI.Xaml.Navigation;
00014 using SDKTemplate;
00015 using System;
00016
00017 using System.Threading;
00018 using System.Threading.Tasks;
00019 using Windows.UI.Core;
00020 using Windows.Media.MediaProperties;
00021 using SimpleCommunication.Common;
00022 using Microsoft.Samples.SimpleCommunication;
00023
00024 namespace SimpleCommunication
00025 {
00026     /// <summary>
00027     /// An empty page that can be used on its own or navigated to within a Frame.
00028     /// </summary>
00029     public sealed partial class VideoChat : SDKTemplate.Common.LayoutAwarePage
00030     {
00031         // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00032         // as NotifyUser()
00033         MainPage rootPage = MainPage.Current;
00034
00035         CaptureDevice device = null;
00036         bool? roleIsActive = null;
00037         int isTerminator = 0;
00038         bool activated = false;
00039
00040         public VideoChat()
00041         {
00042             this.InitializeComponent();
00043
00044             rootPage.EnsureMediaExtensionManager();
00045         }
00046
00047         /// <summary>
00048         /// Invoked when this page is about to be displayed in a Frame.
00049         /// </summary>
00050         /// <param name="e">Event data that describes how this page was reached.  The Parameter
00051         /// property is typically used to configure the page.</param>
00052         protected async override void OnNavigatedTo(NavigationEventArgs e)
00053         {
00054             var cameraFound = await CaptureDevice.CheckForRecordingDeviceAsync();
00055
00056             if (cameraFound)
00057             {
00058                 device = new CaptureDevice();
00059                 await InitializeAsync();
00060                 device.IncomingConnectionArrived += device_IncomingConnectionArrived;
00061                 device.CaptureFailed += device_CaptureFailed;
00062                 RemoteVideo.MediaFailed += RemoteVideo_MediaFailed;
00063             }
00064             else
00065             {
00066                 rootPage.NotifyUser("A machine with a camera and a microphone is required to run this sample.", NotifyType.ErrorMessage);
00067             }
00068         }
00069
00070         protected async override void OnNavigatingFrom(NavigatingCancelEventArgs e)
00071         {
00072             base.OnNavigatingFrom(e);
00073
00074             if (activated)
00075             {
00076                 RemoteVideo.Stop();
00077                 RemoteVideo.Source = null;
00078             }
00079
00080             await device.CleanUpAsync();
00081             device = null;
00082         }
00083
00084         private async Task InitializeAsync(CancellationToken cancel = default(CancellationToken))
00085         {
00086             rootPage.NotifyUser("Initializing...", NotifyType.StatusMessage);
00087
00088             try
00089             {
00090                 await device.InitializeAsync();
00091                 await StartRecordToCustomSink();
00092
00093                 HostName.IsEnabled = Call.IsEnabled = true;
00094                 EndCall.IsEnabled = false;
00095                 RemoteVideo.Source = null;
00096                 RemoteVideo.Height = (RemoteVideo.Parent as Grid).ActualHeight;
00097
00098                 // Each client starts out as passive
00099                 roleIsActive = false;
00100                 Interlocked.Exchange(ref isTerminator, 0);
00101
00102                 rootPage.NotifyUser("Tap 'Call' button to start call", NotifyType.StatusMessage);
00103             }
00104             catch (Exception)
00105             {
00106                 rootPage.NotifyUser("Initialization error. Restart the sample to try again.", NotifyType.ErrorMessage);
00107             }
00108
00109         }
00110
00111         async void RemoteVideo_MediaFailed(object sender, ExceptionRoutedEventArgs e)
00112         {
00113             if (Interlocked.CompareExchange(ref isTerminator, 1, 0) == 0)
00114             {
00115                 await EndCallAsync();
00116             }
00117         }
00118
00119         async void device_IncomingConnectionArrived(object sender, IncomingConnectionEventArgs e)
00120         {
00121             e.Accept();
00122
00123             await Dispatcher.RunAsync(Windows.UI.Core.CoreDispatcherPriority.Normal, (() =>
00124             {
00125                 activated = true;
00126                 CallPoster.Visibility = Visibility.Collapsed;
00127                 RemoteVideo.Visibility = Visibility.Visible;
00128
00129                 var remoteAddress = e.RemoteUrl;
00130                 EndCall.IsEnabled = true;
00131                 Interlocked.Exchange(ref isTerminator, 0);
00132
00133                 if (!((bool)roleIsActive))
00134                 {
00135                     // Passive client
00136                     RemoteVideo.Source = new Uri(remoteAddress);
00137                     HostName.IsEnabled = Call.IsEnabled = false;
00138                 }
00139
00140                 remoteAddress = remoteAddress.Replace("stsp://", "");
00141                 rootPage.NotifyUser("Connected. Remote machine address: " + remoteAddress, NotifyType.StatusMessage);
00142             }));
00143         }
00144
00145         async void device_CaptureFailed(object sender, Windows.Media.Capture.MediaCaptureFailedEventArgs e)
00146         {
00147             if (Interlocked.CompareExchange(ref isTerminator, 1, 0) == 0)
00148             {
00149                 await EndCallAsync();
00150             }
00151         }
00152
00153         private async Task StartRecordToCustomSink()
00154         {
00155             MediaEncodingProfile mep = MediaEncodingProfile.CreateMp4(VideoEncodingQuality.Qvga);
00156
00157             mep.Video.FrameRate.Numerator = 15;
00158             mep.Video.FrameRate.Denominator = 1;
00159             mep.Container = null;
00160
00161             await device.StartRecordingAsync(mep);
00162         }
00163
00164         /// <summary>
00165         /// This is the click handler for the 'Default' button.  You would replace this with your own handler
00166         /// if you have a button or buttons on this page.
00167         /// </summary>
00168         /// <param name="sender"></param>
00169         /// <param name="e"></param>
00170         private void Call_Click(object sender, RoutedEventArgs e)
00171         {
00172             Button b = sender as Button;
00173             var address = HostName.Text;
00174
00175             if (b != null && !String.IsNullOrEmpty(address))
00176             {
00177                 roleIsActive = true;
00178                 RemoteVideo.Source = new Uri("stsp://" + address);
00179                 HostName.IsEnabled = Call.IsEnabled = false;
00180                 rootPage.NotifyUser("Initiating connection... Please wait.", NotifyType.StatusMessage);
00181             }
00182         }
00183
00184         /// <summary>
00185         /// This is the click handler for the 'Other' button.  You would replace this with your own handler
00186         /// if you have a button or buttons on this page.
00187         /// </summary>
00188         /// <param name="sender"></param>
00189         /// <param name="e"></param>
00190         private async void EndCall_Click(object sender, RoutedEventArgs e)
00191         {
00192             Button b = sender as Button;
00193             if (b != null && Interlocked.CompareExchange(ref isTerminator, 1, 0) == 0)
00194             {
00195                 await EndCallAsync();
00196             }
00197         }
00198
00199         private async Task EndCallAsync()
00200         {
00201             await device.CleanUpAsync();
00202
00203             // end the call session
00204             await Dispatcher.RunAsync(CoreDispatcherPriority.Normal, (() =>
00205             {
00206                 RemoteVideo.Visibility = Visibility.Collapsed;
00207                 CallPoster.Visibility = Visibility.Visible;
00208                 RemoteVideo.Stop();
00209                 RemoteVideo.Source = null;
00210             }));
00211
00212             // Start waiting for a new call
00213             await InitializeAsync();
00214         }
00215     }
00216 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicTimer.cpp Source File

  • Direct3D resource loading

BasicTimer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicTimer.h"
00010
00011 BasicTimer::BasicTimer()
00012 {
00013     if (!QueryPerformanceFrequency(&m_frequency))
00014     {
00015         throw ref new Platform::FailureException();
00016     }
00017     Reset();
00018 }
00019
00020 void BasicTimer::Reset()
00021 {
00022     Update();
00023     m_startTime = m_currentTime;
00024     m_total = 0.0f;
00025     m_delta = 1.0f / 60.0f;
00026 }
00027
00028 void BasicTimer::Update()
00029 {
00030     if (!QueryPerformanceCounter(&m_currentTime))
00031     {
00032         throw ref new Platform::FailureException();
00033     }
00034
00035     m_total = static_cast<float>(
00036         static_cast<double>(m_currentTime.QuadPart-m_startTime.QuadPart) /
00037         static_cast<double>(m_frequency.QuadPart)
00038         );
00039
00040     if (m_lastTime.QuadPart == m_startTime.QuadPart)
00041     {
00042         // If the timer was just reset, report a time delta equivalent to 60Hz frame time.
00043         m_delta = 1.0f / 60.0f;
00044     }
00045     else
00046     {
00047         m_delta = static_cast<float>(
00048             static_cast<double>(m_currentTime.QuadPart-m_lastTime.QuadPart) /
00049             static_cast<double>(m_frequency.QuadPart)
00050             );
00051     }
00052
00053     m_lastTime = m_currentTime;
00054 }
00055
00056 float BasicTimer::Total::get()
00057 {
00058     return m_total;
00059 }
00060
00061 float BasicTimer::Delta::get()
00062 {
00063     return m_delta;
00064 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioInput1.xaml.h Source File

  • Toast notifications
  • C#,C++

ScenarioInput1.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // ScenarioInput1.xaml.h
00009 // Declaration of the ScenarioInput1 class.
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "ScenarioInput1.g.h"
00016 #include "MainPage.xaml.h"
00017
00018 using namespace Windows::UI::Xaml;
00019
00020 namespace ToastsSampleCPP
00021 {
00022   [Windows::Foundation::Metadata::WebHostHidden]
00023     public ref class ScenarioInput1 sealed
00024     {
00025     public:
00026         ScenarioInput1();
00027
00028     protected:
00029         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00031
00032     private:
00033         ~ScenarioInput1();
00034
00035     MainPage^ rootPage;
00036         void OutputText(Platform::String^ text);
00037         void Scenario1DisplayToast(Windows::UI::Notifications::ToastTemplateType templateType);
00038         void Scenario1DisplayToastWithStringManipulation(Windows::UI::Notifications::ToastTemplateType templateType);
00039
00040         Windows::UI::Xaml::Controls::TextBlock^ outputText;
00041     };
00042 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/pch.h Source File

  • LightSensor

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DirectXBase.h Source File

  • Direct3D-Direct2D interop

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playlist/C++/common/LayoutAwarePage.h Source File

  • Playlist
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/BasicShapes.cpp Source File

  • Direct3D resource loading

BasicShapes.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "BasicShapes.h"
00012 #include "DirectXSample.h"
00013 #include <memory>
00014
00015 BasicShapes::BasicShapes(ID3D11Device *d3dDevice) : m_d3dDevice(d3dDevice)
00016 {
00017 }
00018
00019 void BasicShapes::CreateVertexBuffer(
00020     _In_ unsigned int numVertices,
00021     _In_ BasicVertex *vertexData,
00022     _Out_ ID3D11Buffer **vertexBuffer
00023     )
00024 {
00025     *vertexBuffer = nullptr;
00026     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00027
00028     D3D11_BUFFER_DESC VertexBufferDesc;
00029     VertexBufferDesc.ByteWidth = sizeof(BasicVertex) * numVertices;
00030     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00031     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00032     VertexBufferDesc.CPUAccessFlags = 0;
00033     VertexBufferDesc.MiscFlags = 0;
00034     VertexBufferDesc.StructureByteStride = 0;
00035
00036     D3D11_SUBRESOURCE_DATA VertexBufferData;
00037     VertexBufferData.pSysMem = vertexData;
00038     VertexBufferData.SysMemPitch = 0;
00039     VertexBufferData.SysMemSlicePitch = 0;
00040
00041     DX::ThrowIfFailed(
00042         m_d3dDevice->CreateBuffer(
00043             &VertexBufferDesc,
00044             &VertexBufferData,
00045             &vertexBufferInternal
00046             )
00047         );
00048
00049
00050     *vertexBuffer = vertexBufferInternal.Detach();
00051 }
00052
00053 void BasicShapes::CreateIndexBuffer(
00054     _In_ unsigned int numIndices,
00055     _In_ unsigned short *indexData,
00056     _Out_ ID3D11Buffer **indexBuffer
00057     )
00058 {
00059     *indexBuffer = nullptr;
00060     Microsoft::WRL::ComPtr<ID3D11Buffer> indexBufferInternal;
00061
00062     D3D11_BUFFER_DESC IndexBufferDesc;
00063     IndexBufferDesc.ByteWidth = sizeof(unsigned short) * numIndices;
00064     IndexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00065     IndexBufferDesc.BindFlags = D3D11_BIND_INDEX_BUFFER;
00066     IndexBufferDesc.CPUAccessFlags = 0;
00067     IndexBufferDesc.MiscFlags = 0;
00068     IndexBufferDesc.StructureByteStride = 0;
00069
00070     D3D11_SUBRESOURCE_DATA IndexBufferData;
00071     IndexBufferData.pSysMem = indexData;
00072     IndexBufferData.SysMemPitch = 0;
00073     IndexBufferData.SysMemSlicePitch = 0;
00074
00075     DX::ThrowIfFailed(
00076         m_d3dDevice->CreateBuffer(
00077             &IndexBufferDesc,
00078             &IndexBufferData,
00079             &indexBufferInternal
00080             )
00081         );
00082
00083     *indexBuffer = indexBufferInternal.Detach();
00084 }
00085
00086 void BasicShapes::CreateTangentVertexBuffer(
00087     _In_ unsigned int numVertices,
00088     _In_ TangentVertex *vertexData,
00089     _Out_ ID3D11Buffer **vertexBuffer
00090     )
00091 {
00092     *vertexBuffer = nullptr;
00093     Microsoft::WRL::ComPtr<ID3D11Buffer> vertexBufferInternal;
00094
00095     D3D11_BUFFER_DESC VertexBufferDesc;
00096     VertexBufferDesc.ByteWidth = sizeof(TangentVertex) * numVertices;
00097     VertexBufferDesc.Usage = D3D11_USAGE_DEFAULT;
00098     VertexBufferDesc.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00099     VertexBufferDesc.CPUAccessFlags = 0;
00100     VertexBufferDesc.MiscFlags = 0;
00101     VertexBufferDesc.StructureByteStride = 0;
00102
00103     D3D11_SUBRESOURCE_DATA VertexBufferData;
00104     VertexBufferData.pSysMem = vertexData;
00105     VertexBufferData.SysMemPitch = 0;
00106     VertexBufferData.SysMemSlicePitch = 0;
00107
00108     DX::ThrowIfFailed(
00109         m_d3dDevice->CreateBuffer(
00110             &VertexBufferDesc,
00111             &VertexBufferData,
00112             &vertexBufferInternal
00113             )
00114         );
00115
00116
00117     *vertexBuffer = vertexBufferInternal.Detach();
00118 }
00119
00120 void BasicShapes::CreateCube(
00121     _Out_ ID3D11Buffer **vertexBuffer,
00122     _Out_ ID3D11Buffer **indexBuffer,
00123     _Out_opt_ unsigned int *vertexCount,
00124     _Out_opt_ unsigned int *indexCount
00125     )
00126 {
00127     BasicVertex cubeVertices[] =
00128     {
00129         { float3(-0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f) }, // +Y (top face)
00130         { float3( 0.5f, 0.5f, -0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f) },
00131         { float3( 0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.0f) },
00132         { float3(-0.5f, 0.5f,  0.5f), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.0f) },
00133
00134         { float3(-0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 0.0f) }, // -Y (bottom face)
00135         { float3( 0.5f, -0.5f,  0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 0.0f) },
00136         { float3 (0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(1.0f, 1.0f) },
00137         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, -1.0f, 0.0f), float2(0.0f, 1.0f) },
00138
00139         { float3(0.5f,  0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // +X (right face)
00140         { float3(0.5f,  0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00141         { float3(0.5f, -0.5f, -0.5f), float3(1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00142         { float3(0.5f, -0.5f,  0.5f), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00143
00144         { float3(-0.5f,  0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f) }, // -X (left face)
00145         { float3(-0.5f,  0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 0.0f) },
00146         { float3(-0.5f, -0.5f,  0.5f), float3(-1.0f, 0.0f, 0.0f), float2(1.0f, 1.0f) },
00147         { float3(-0.5f, -0.5f, -0.5f), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.0f) },
00148
00149         { float3(-0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f) }, // +Z (front face)
00150         { float3( 0.5f,  0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 0.0f) },
00151         { float3( 0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(1.0f, 1.0f) },
00152         { float3(-0.5f, -0.5f, 0.5f), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.0f) },
00153
00154         { float3( 0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f) }, // -Z (back face)
00155         { float3(-0.5f,  0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 0.0f) },
00156         { float3(-0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(1.0f, 1.0f) },
00157         { float3( 0.5f, -0.5f, -0.5f), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.0f) },
00158     };
00159
00160     unsigned short cubeIndices[] =
00161     {
00162         0, 1, 2,
00163         0, 2, 3,
00164
00165         4, 5, 6,
00166         4, 6, 7,
00167
00168         8, 9, 10,
00169         8, 10, 11,
00170
00171         12, 13, 14,
00172         12, 14, 15,
00173
00174         16, 17, 18,
00175         16, 18, 19,
00176
00177         20, 21, 22,
00178         20, 22, 23
00179     };
00180
00181     CreateVertexBuffer(
00182         ARRAYSIZE(cubeVertices),
00183         cubeVertices,
00184         vertexBuffer
00185         );
00186     if (vertexCount != nullptr)
00187     {
00188         *vertexCount = ARRAYSIZE(cubeVertices);
00189     }
00190
00191     CreateIndexBuffer(
00192         ARRAYSIZE(cubeIndices),
00193         cubeIndices,
00194         indexBuffer
00195         );
00196     if (indexCount != nullptr)
00197     {
00198         *indexCount = ARRAYSIZE(cubeIndices);
00199     }
00200 }
00201
00202 void BasicShapes::CreateBox(
00203     float3 r,
00204     _Out_ ID3D11Buffer **vertexBuffer,
00205     _Out_ ID3D11Buffer **indexBuffer,
00206     _Out_opt_ unsigned int *vertexCount,
00207     _Out_opt_ unsigned int *indexCount
00208     )
00209 {
00210     BasicVertex boxVertices[] =
00211     {
00212         // FLOOR
00213         {float3(-r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 0.0f)},
00214         {float3( r.x, -r.y,  r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 0.0f)},
00215         {float3(-r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(0.0f, 1.5f)},
00216         {float3( r.x, -r.y, -r.z), float3(0.0f, 1.0f, 0.0f), float2(1.0f, 1.5f)},
00217         // WALL
00218         {float3(-r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 0.0f)},
00219         {float3( r.x,  r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 0.0f)},
00220         {float3(-r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(0.0f, 1.5f)},
00221         {float3( r.x, -r.y, r.z), float3(0.0f, 0.0f, -1.0f), float2(2.0f, 1.5f)},
00222         // WALL
00223         {float3(r.x,  r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00224         {float3(r.x,  r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00225         {float3(r.x, -r.y,  r.z), float3(-1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00226         {float3(r.x, -r.y, -r.z), float3(-1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00227         // WALL
00228         {float3( r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 0.0f)},
00229         {float3(-r.x,  r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 0.0f)},
00230         {float3( r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(0.0f, 1.5f)},
00231         {float3(-r.x, -r.y, -r.z), float3(0.0f, 0.0f, 1.0f), float2(2.0f, 1.5f)},
00232         // WALL
00233         {float3(-r.x,  r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 0.0f)},
00234         {float3(-r.x,  r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  0.0f)},
00235         {float3(-r.x, -r.y, -r.z), float3(1.0f, 0.0f, 0.0f), float2(0.0f, 1.5f)},
00236         {float3(-r.x, -r.y,  r.z), float3(1.0f, 0.0f, 0.0f), float2(r.y,  1.5f)},
00237         // CEILING
00238         {float3(-r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 0.0f)},
00239         {float3( r.x, r.y, -r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 0.0f)},
00240         {float3(-r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2(-0.15f, 2.1f)},
00241         {float3( r.x, r.y,  r.z), float3(0.0f, -1.0f, 0.0f), float2( 1.25f, 2.1f)},
00242     };
00243
00244     unsigned short boxIndices[] =
00245     {
00246         0, 2, 1,
00247         1, 2, 3,
00248
00249         4, 6, 5,
00250         5, 6, 7,
00251
00252         8, 10, 9,
00253         9, 10, 11,
00254
00255         12, 14, 13,
00256         13, 14, 15,
00257
00258         16, 18, 17,
00259         17, 18, 19,
00260
00261         20, 22, 21,
00262         21, 22, 23,
00263     };
00264
00265     CreateVertexBuffer(
00266         ARRAYSIZE(boxVertices),
00267         boxVertices,
00268         vertexBuffer
00269         );
00270     if (vertexCount != nullptr)
00271     {
00272         *vertexCount = ARRAYSIZE(boxVertices);
00273     }
00274
00275     CreateIndexBuffer(
00276         ARRAYSIZE(boxIndices),
00277         boxIndices,
00278         indexBuffer
00279         );
00280     if (indexCount != nullptr)
00281     {
00282         *indexCount = ARRAYSIZE(boxIndices);
00283     }
00284 }
00285
00286 void BasicShapes::CreateSphere(
00287     _Out_ ID3D11Buffer **vertexBuffer,
00288     _Out_ ID3D11Buffer **indexBuffer,
00289     _Out_opt_ unsigned int *vertexCount,
00290     _Out_opt_ unsigned int *indexCount
00291     )
00292 {
00293     const int numSegments = 64;
00294     const int numSlices = numSegments / 2;
00295
00296     const int numVertices = (numSlices + 1) * (numSegments + 1);
00297     std::unique_ptr<BasicVertex[]> sphereVertices(new BasicVertex[numVertices]);
00298
00299     for (int slice = 0; slice <= numSlices; slice++)
00300     {
00301         float v = (float)slice/(float)numSlices;
00302         float inclination = v * PI_F;
00303         float y = cos(inclination);
00304         float r = sin(inclination);
00305         for (int segment = 0; segment <= numSegments; segment++)
00306         {
00307             float u = (float)segment/(float)numSegments;
00308             float azimuth = u * PI_F * 2.0f;
00309             int index = slice * (numSegments+1) + segment;
00310             sphereVertices[index].pos = float3(r * sin(azimuth), y, r * cos(azimuth));
00311             sphereVertices[index].norm = sphereVertices[index].pos;
00312             sphereVertices[index].tex = float2(u, v);
00313         }
00314     }
00315
00316     const int numIndices = numSlices * (numSegments-2) * 6;
00317     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00318
00319     unsigned int index = 0;
00320     for (int slice = 0; slice < numSlices; slice++)
00321     {
00322         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00323         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00324         for (int segment = 0; segment < numSegments; segment++)
00325         {
00326             if (slice > 0)
00327             {
00328                 sphereIndices[index++] = sliceBase0 + segment;
00329                 sphereIndices[index++] = sliceBase0 + segment + 1;
00330                 sphereIndices[index++] = sliceBase1 + segment + 1;
00331             }
00332             if (slice < numSlices-1)
00333             {
00334                 sphereIndices[index++] = sliceBase0 + segment;
00335                 sphereIndices[index++] = sliceBase1 + segment + 1;
00336                 sphereIndices[index++] = sliceBase1 + segment;
00337             }
00338         }
00339     }
00340
00341     CreateVertexBuffer(
00342         numVertices,
00343         sphereVertices.get(),
00344         vertexBuffer
00345         );
00346     if (vertexCount != nullptr)
00347     {
00348         *vertexCount = numVertices;
00349     }
00350
00351     CreateIndexBuffer(
00352         numIndices,
00353         sphereIndices.get(),
00354         indexBuffer
00355         );
00356     if (indexCount != nullptr)
00357     {
00358         *indexCount = numIndices;
00359     }
00360 }
00361 void BasicShapes::CreateTangentSphere(
00362     _Out_ ID3D11Buffer **vertexBuffer,
00363     _Out_ ID3D11Buffer **indexBuffer,
00364     _Out_opt_ unsigned int *vertexCount,
00365     _Out_opt_ unsigned int *indexCount
00366     )
00367 {
00368     const int numSegments = 64;
00369     const int numSlices = numSegments / 2;
00370
00371     const int numVertices = (numSlices + 1) * (numSegments + 1);
00372     std::unique_ptr<TangentVertex[]> sphereVertices(new TangentVertex[numVertices]);
00373
00374     for (int slice = 0; slice <= numSlices; slice++)
00375     {
00376         float v = (float)slice/(float)numSlices;
00377         float inclination = v * PI_F;
00378         float y = cos(inclination);
00379         float r = sin(inclination);
00380         for (int segment = 0; segment <= numSegments; segment++)
00381         {
00382             float u = (float)segment/(float)numSegments;
00383             float azimuth = u * PI_F * 2.0f;
00384             int index = slice * (numSegments+1) + segment;
00385             sphereVertices[index].pos = float3(r*sin(azimuth), y, r*cos(azimuth));
00386             sphereVertices[index].tex = float2(u, v);
00387             sphereVertices[index].uTan = float3(cos(azimuth), 0, -sin(azimuth));
00388             sphereVertices[index].vTan = float3(cos(inclination)*sin(azimuth), -sin(inclination), cos(inclination)*cos(azimuth));
00389
00390         }
00391     }
00392
00393     const int numIndices = numSlices * (numSegments-2) * 6;
00394     std::unique_ptr<unsigned short[]> sphereIndices(new unsigned short[numIndices]);
00395
00396     unsigned int index = 0;
00397     for (int slice = 0; slice < numSlices; slice++)
00398     {
00399         unsigned short sliceBase0 = (unsigned short)((slice)*(numSegments+1));
00400         unsigned short sliceBase1 = (unsigned short)((slice+1)*(numSegments+1));
00401         for (int segment = 0; segment < numSegments; segment++)
00402         {
00403             if (slice > 0)
00404             {
00405                 sphereIndices[index++] = sliceBase0 + segment;
00406                 sphereIndices[index++] = sliceBase0 + segment + 1;
00407                 sphereIndices[index++] = sliceBase1 + segment + 1;
00408             }
00409             if (slice < numSlices-1)
00410             {
00411                 sphereIndices[index++] = sliceBase0 + segment;
00412                 sphereIndices[index++] = sliceBase1 + segment + 1;
00413                 sphereIndices[index++] = sliceBase1 + segment;
00414             }
00415         }
00416     }
00417
00418     CreateTangentVertexBuffer(
00419         numVertices,
00420         sphereVertices.get(),
00421         vertexBuffer
00422         );
00423     if (vertexCount != nullptr)
00424     {
00425         *vertexCount = numVertices;
00426     }
00427
00428     CreateIndexBuffer(
00429         numIndices,
00430         sphereIndices.get(),
00431         indexBuffer
00432         );
00433     if (indexCount != nullptr)
00434     {
00435         *indexCount = numIndices;
00436     }
00437 }
00438
00439 void BasicShapes::CreateReferenceAxis(
00440     _Out_ ID3D11Buffer **vertexBuffer,
00441     _Out_ ID3D11Buffer **indexBuffer,
00442     _Out_opt_ unsigned int *vertexCount,
00443     _Out_opt_ unsigned int *indexCount
00444     )
00445 {
00446     BasicVertex axisVertices[] =
00447     {
00448         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00449         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00450         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.500f, 0.500f), float2(0.250f, 0.250f) },
00451         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00452         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00453         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f, 0.500f), float2(0.250f, 0.250f) },
00454         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00455         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00456         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f,-0.500f,-0.500f), float2(0.250f, 0.250f) },
00457         { float3( 0.500f, 0.000f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00458         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00459         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.500f,-0.500f), float2(0.250f, 0.250f) },
00460         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00461         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00462         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00463         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.000f, 0.000f), float2(0.250f, 0.250f) },
00464         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00465         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00466         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f, 0.500f), float2(0.250f, 0.500f) },
00467         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00468         { float3( 0.000f, 0.125f, 0.000f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00469         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f, 0.500f,-0.500f), float2(0.250f, 0.500f) },
00470         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00471         { float3( 0.000f, 0.000f,-0.125f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00472         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f,-0.500f), float2(0.250f, 0.500f) },
00473         { float3(-0.500f, 0.000f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00474         { float3( 0.000f,-0.125f, 0.000f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00475         { float3( 0.000f, 0.000f, 0.125f), float3(-0.125f,-0.500f, 0.500f), float2(0.250f, 0.500f) },
00476         { float3( 0.000f, 0.000f, 0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00477         { float3( 0.000f,-0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00478         { float3( 0.000f, 0.000f,-0.125f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00479         { float3( 0.000f, 0.125f, 0.000f), float3( 0.125f, 0.000f, 0.000f), float2(0.250f, 0.500f) },
00480         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00481         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00482         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00483         { float3( 0.000f, 0.500f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00484         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00485         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00486         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00487         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00488         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f,-0.500f), float2(0.500f, 0.250f) },
00489         { float3( 0.000f, 0.500f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00490         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00491         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f, 0.125f, 0.500f), float2(0.500f, 0.250f) },
00492         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00493         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00494         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00495         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f,-0.125f, 0.000f), float2(0.500f, 0.250f) },
00496         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00497         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00498         { float3( 0.000f, 0.000f, 0.125f), float3( 0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00499         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00500         { float3( 0.000f, 0.000f, 0.125f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00501         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f, 0.500f), float2(0.500f, 0.500f) },
00502         { float3( 0.000f,-0.500f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00503         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00504         { float3( 0.000f, 0.000f,-0.125f), float3(-0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00505         { float3( 0.000f,-0.500f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00506         { float3( 0.000f, 0.000f,-0.125f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00507         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.125f,-0.500f), float2(0.500f, 0.500f) },
00508         { float3( 0.000f, 0.000f,-0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00509         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00510         { float3( 0.000f, 0.000f, 0.125f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00511         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.125f, 0.000f), float2(0.500f, 0.500f) },
00512         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00513         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00514         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00515         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00516         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00517         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f, 0.125f), float2(0.750f, 0.250f) },
00518         { float3( 0.000f, 0.000f, 0.500f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00519         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00520         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00521         { float3( 0.000f, 0.000f, 0.500f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00522         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00523         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f, 0.125f), float2(0.750f, 0.250f) },
00524         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00525         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00526         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00527         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f,-0.125f), float2(0.750f, 0.250f) },
00528         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00529         { float3( 0.000f, 0.125f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00530         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00531         { float3( 0.000f, 0.000f,-0.500f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00532         { float3( 0.125f, 0.000f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00533         { float3( 0.000f,-0.125f, 0.000f), float3( 0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00534         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00535         { float3( 0.000f,-0.125f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00536         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f,-0.500f,-0.125f), float2(0.750f, 0.500f) },
00537         { float3( 0.000f, 0.000f,-0.500f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00538         { float3(-0.125f, 0.000f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00539         { float3( 0.000f, 0.125f, 0.000f), float3(-0.500f, 0.500f,-0.125f), float2(0.750f, 0.500f) },
00540         { float3( 0.000f, 0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00541         { float3(-0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00542         { float3( 0.000f,-0.125f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00543         { float3( 0.125f, 0.000f, 0.000f), float3( 0.000f, 0.000f, 0.125f), float2(0.750f, 0.500f) },
00544     };
00545
00546     unsigned short axisIndices[] =
00547     {
00548          0,  2,  1,
00549          3,  5,  4,
00550          6,  8,  7,
00551          9, 11, 10,
00552         12, 14, 13,
00553         12, 15, 14,
00554         16, 18, 17,
00555         19, 21, 20,
00556         22, 24, 23,
00557         25, 27, 26,
00558         28, 30, 29,
00559         28, 31, 30,
00560         32, 34, 33,
00561         35, 37, 36,
00562         38, 40, 39,
00563         41, 43, 42,
00564         44, 46, 45,
00565         44, 47, 46,
00566         48, 50, 49,
00567         51, 53, 52,
00568         54, 56, 55,
00569         57, 59, 58,
00570         60, 62, 61,
00571         60, 63, 62,
00572         64, 66, 65,
00573         67, 69, 68,
00574         70, 72, 71,
00575         73, 75, 74,
00576         76, 78, 77,
00577         76, 79, 78,
00578         80, 82, 81,
00579         83, 85, 84,
00580         86, 88, 87,
00581         89, 91, 90,
00582         92, 94, 93,
00583         92, 95, 94,
00584     };
00585
00586     CreateVertexBuffer(
00587         ARRAYSIZE(axisVertices),
00588         axisVertices,
00589         vertexBuffer
00590         );
00591     if (vertexCount != nullptr)
00592     {
00593         *vertexCount = ARRAYSIZE(axisVertices);
00594     }
00595
00596     CreateIndexBuffer(
00597         ARRAYSIZE(axisIndices),
00598         axisIndices,
00599         indexBuffer
00600         );
00601     if (indexCount != nullptr)
00602     {
00603         *indexCount = ARRAYSIZE(axisIndices);
00604     }
00605 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/common/suspensionmanager.h Source File

  • HomeGroup app
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideText05 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideText05, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBody1 | NotificationsExtensions::TileContent::TileWideText05 |
TextBody2 | NotificationsExtensions::TileContent::TileWideText05 |
TextBody3 | NotificationsExtensions::TileContent::TileWideText05 |
TextBody4 | NotificationsExtensions::TileContent::TileWideText05 |
TextBody5 | NotificationsExtensions::TileContent::TileWideText05 |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideText05() | NotificationsExtensions::TileContent::TileWideText05 | [inline]
TileWideText05() | NotificationsExtensions::TileContent::TileWideText05 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario9.xaml.h Source File

  • CryptoWinRT

Scenario9.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario9.xaml.h
00013 // Declaration of the Scenario9 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario9.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace CryptoWinRT
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario9 sealed
00031         {
00032         public:
00033             Scenario9();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Keyboard.xaml.cpp Source File

  • Input Device capabilities

Keyboard.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Keyboard.xaml.cpp
00013 // Implementation of the Keyboard class
00014 //
00015
00016 #include "pch.h"
00017 #include "Keyboard.xaml.h"
00018
00019 using namespace SDKSample::DeviceCaps;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 using namespace Windows::Devices::Input;
00026
00027 Keyboard::Keyboard()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 /// <summary>
00033 /// Invoked when this page is about to be displayed in a Frame.
00034 /// </summary>
00035 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00036 /// property is typically used to configure the page.</param>
00037 void Keyboard::OnNavigatedTo(NavigationEventArgs^ e)
00038 {
00039     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00040     // as NotifyUser()
00041     rootPage = MainPage::Current;
00042 }
00043
00044 void SDKSample::DeviceCaps::Keyboard::KeyboardGetSettings_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00045 {
00046     Button^ b = safe_cast<Button^>(sender);
00047     if (b != nullptr)
00048     {
00049     KeyboardCapabilities^ pKeyboardCapabilities = ref new KeyboardCapabilities();
00050         Platform::String^ Buffer;
00051
00052         Buffer = "There is " + ((pKeyboardCapabilities->KeyboardPresent != 0) ? "a" : "no") + " keyboard present\n";
00053
00054         KeyboardOutputTextBlock->Text = Buffer;
00055     }
00056 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

BasicReaderWriter Member List

This is the complete list of members for BasicReaderWriter, including all inherited members.
__pad0__ | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
BasicReaderWriter(_In_ Windows::Storage::StorageFolder^folder) | BasicReaderWriter | [private]
m_location | BasicReaderWriter | [private]
m_locationPath | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadData(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
ReadDataAsync(_In_ Platform::String^filename) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteData(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
WriteDataAsync(_In_ Platform::String^filename, _In_ const Platform::Array< byte >^fileData) | BasicReaderWriter | [private]
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput game controller/C++/DirectXApp.cpp Source File

  • XInput game controller

DirectXApp.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXApp.h"
00010 #include "BasicTimer.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Graphics::Display;
00019
00020 DirectXApp::DirectXApp() :
00021     m_windowClosed(false),
00022     m_windowVisible(true)
00023 {
00024 }
00025
00026 void DirectXApp::Initialize(
00027     _In_ CoreApplicationView^ applicationView
00028     )
00029 {
00030     applicationView->Activated +=
00031         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DirectXApp::OnActivated);
00032
00033     CoreApplication::Suspending +=
00034         ref new EventHandler<SuspendingEventArgs^>(this, &DirectXApp::OnSuspending);
00035
00036     CoreApplication::Resuming +=
00037         ref new EventHandler<Platform::Object^>(this, &DirectXApp::OnResuming);
00038
00039     m_renderer = ref new SimpleController();
00040 }
00041
00042 void DirectXApp::SetWindow(
00043     _In_ CoreWindow^ window
00044     )
00045 {
00046     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00047
00048     window->SizeChanged +=
00049         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DirectXApp::OnWindowSizeChanged);
00050
00051     window->VisibilityChanged +=
00052         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &DirectXApp::OnVisibilityChanged);
00053
00054     window->Closed +=
00055         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &DirectXApp::OnWindowClosed);
00056
00057     DisplayProperties::LogicalDpiChanged +=
00058         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnLogicalDpiChanged);
00059
00060     m_renderer->Initialize(window, DisplayProperties::LogicalDpi);
00061 }
00062
00063 void DirectXApp::Load(
00064     _In_ Platform::String^ entryPoint
00065     )
00066 {
00067 }
00068
00069 void DirectXApp::Run()
00070 {
00071     BasicTimer^ timer = ref new BasicTimer();
00072
00073     while (!m_windowClosed)
00074     {
00075         if (m_windowVisible)
00076         {
00077             timer->Update();
00078             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00079             m_renderer->Update(timer->Total, timer->Delta);
00080             m_renderer->Render();
00081             m_renderer->Present(); // This call is synchronized to the display frame rate.
00082         }
00083         else
00084         {
00085             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00086         }
00087     }
00088 }
00089
00090 void DirectXApp::Uninitialize()
00091 {
00092 }
00093
00094 void DirectXApp::OnWindowSizeChanged(
00095     _In_ CoreWindow^ sender,
00096     _In_ WindowSizeChangedEventArgs^ args
00097     )
00098 {
00099     m_renderer->UpdateForWindowSizeChange();
00100 }
00101
00102 void DirectXApp::OnVisibilityChanged(
00103     _In_ CoreWindow^ sender,
00104     _In_ VisibilityChangedEventArgs^ args
00105     )
00106 {
00107     m_windowVisible = args->Visible;
00108 }
00109
00110 void DirectXApp::OnWindowClosed(
00111     _In_ CoreWindow^ sender,
00112     _In_ CoreWindowEventArgs^ args
00113     )
00114 {
00115     m_windowClosed = true;
00116 }
00117
00118 void DirectXApp::OnLogicalDpiChanged(
00119     _In_ Platform::Object^ sender
00120     )
00121 {
00122     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00123 }
00124
00125 void DirectXApp::OnActivated(
00126     _In_ CoreApplicationView^ applicationView,
00127     _In_ IActivatedEventArgs^ args
00128     )
00129 {
00130     CoreWindow::GetForCurrentThread()->Activate();
00131 }
00132
00133 void DirectXApp::OnSuspending(
00134     _In_ Platform::Object^ sender,
00135     _In_ SuspendingEventArgs^ args
00136     )
00137 {
00138 }
00139
00140 void DirectXApp::OnResuming(
00141     _In_ Platform::Object^ sender,
00142     _In_ Platform::Object^ args
00143     )
00144 {
00145 }
00146
00147 IFrameworkView^ DirectXAppSource::CreateView()
00148 {
00149     return ref new DirectXApp();
00150 }
00151
00152 [Platform::MTAThread]
00153 int main(Platform::Array<Platform::String^>^)
00154 {
00155     auto directXAppSource = ref new DirectXAppSource();
00156     CoreApplication::Run(directXAppSource);
00157     return 0;
00158 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AppBarControl::App Member List

This is the complete list of members for AppBarControl::App, including all inherited members.
__pad0__ | AppBarControl::App |
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | AppBarControl::App | [virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | AppBarControl::App | [virtual]
rootFrame | AppBarControl::App | [private]
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/MainPage.xaml.h Source File

  • Gyrometer sensor

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/BasicShapes.h Source File

  • Direct3D post-processing effects

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::StringHelper Member List

This is the complete list of members for SDKSample::StringHelper, including all inherited members.
Join(Platform::String^separator, Windows::Foundation::Collections::IVectorView< Platform::String^>^iv) | SDKSample::StringHelper | [inline, static]
Trim(Platform::String^s) | SDKSample::StringHelper | [inline, static]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::Drawing::sealed Member List

This is the complete list of members for SDKSample::Drawing::sealed, including all inherited members.
ColorOffsetValueChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs e) | SDKSample::Drawing::sealed | [private]
ColorSelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs e) | SDKSample::Drawing::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Drawing::sealed | [private]
FillSelection_SelectionChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | SDKSample::Drawing::sealed | [private]
LoadGradient() | SDKSample::Drawing::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Drawing::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Drawing::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Drawing::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::Drawing::sealed | [protected, virtual]
Other_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::Drawing::sealed | [private]
rootPage | SDKSample::Drawing::sealed | [private]
Scenario1() | SDKSample::Drawing::sealed |
Scenario2() | SDKSample::Drawing::sealed |
Scenario3() | SDKSample::Drawing::sealed |
Scenario4() | SDKSample::Drawing::sealed |
StrokeWidthSelection_ValueChanged(Platform::Object^sender, Windows::UI::Xaml::Controls::Primitives::RangeBaseValueChangedEventArgs^e) | SDKSample::Drawing::sealed | [private]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/common/suspensionmanager.h Source File

  • OrientationSensor
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/PlaybackControl.xaml.h Source File

  • Playback Manager Companion

PlaybackControl.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // PlaybackControl.xaml.h
00013 // Declaration of the PlaybackControl class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "PlaybackControl.g.h"
00020 #include "MainPage.xaml.h"
00021 #include <agile.h>
00022
00023 namespace SDKSample
00024 {
00025     namespace PlaybackManager2
00026     {
00027         /// <summary>
00028         /// An empty page that can be used on its own or navigated to within a Frame.
00029         /// </summary>
00030       [Windows::Foundation::Metadata::WebHostHidden]
00031         public ref class PlaybackControl sealed
00032         {
00033         public:
00034             PlaybackControl();
00035             void Play();
00036             void Pause();
00037             void Stop();
00038             void SetAudioCategory(Windows::UI::Xaml::Media::AudioCategory category);
00039             void SetAudioDeviceType(Windows::UI::Xaml::Media::AudioDeviceType devicetype);
00040             void SelectFile();
00041
00042         private:
00043             void DisplayStatus(Platform::String^ text);
00044             Platform::String^ GetTimeStampedMessage(Platform::String^ EventCalled);
00045             Platform::String^ SoundLevelToString(Windows::Media::SoundLevel level);
00046             void AppMuted();
00047             void AppUnmuted();
00048             void MediaControl_SoundLevelChanged(Platform::Object^ sender, Platform::Object^ e);
00049             void MediaControl_PlayPauseTogglePressed(Platform::Object^ sender, Platform::Object^ e);
00050             void MediaControl_PlayPressed(Platform::Object^ sender, Platform::Object^ e);
00051             void MediaControl_StopPressed(Platform::Object^ sender, Platform::Object^ e);
00052             void MediaControl_PausePressed(Platform::Object^ sender, Platform::Object^ e);
00053             void Button_Play_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00054             void Button_Pause_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00055             void Button_Stop_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00056
00057         private:
00058             bool IsPlaying;
00059             Platform::Agile<Windows::UI::Core::CoreWindow> cw;
00060
00061             static bool IsRegistered;
00062             static Windows::Foundation::EventRegistrationToken SoundLevelChangedToken;
00063             static Windows::Foundation::EventRegistrationToken PlayPauseTogglePressedToken;
00064             static Windows::Foundation::EventRegistrationToken PlayPressedToken;
00065             static Windows::Foundation::EventRegistrationToken PausePressedToken;
00066             static Windows::Foundation::EventRegistrationToken StopPressedToken;
00067
00068         };
00069     }
00070 }
Generated on Sat Nov 23 2024 16:08:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/App.xaml.cpp Source File

  • Trial app and in-app purchase

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/pch.cpp Source File

  • Input Touch keyboard

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS message send, receive, and SIM management/C++/pch.cpp Source File

  • SMS message send, receive, and SIM management

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/SampleBackgroundTask.h Source File

  • Background task
  • Tasks

SampleBackgroundTask.h

Go to the documentation of this file.
00001 ﻿#pragma once
00002
00003 #include "pch.h"
00004 #include <agile.h>
00005
00006 using namespace Windows::ApplicationModel::Background;
00007 using namespace Windows::System::Threading;
00008
00009 namespace Tasks
00010 {
00011     [Windows::Foundation::Metadata::WebHostHidden]
00012     public ref class SampleBackgroundTask sealed : public IBackgroundTask
00013     {
00014
00015     public:
00016         SampleBackgroundTask();
00017
00018         virtual void Run(IBackgroundTaskInstance^ taskInstance);
00019         void OnCanceled(IBackgroundTaskInstance^ taskInstance, BackgroundTaskCancellationReason reason);
00020
00021     private:
00022         ~SampleBackgroundTask();
00023
00024         volatile bool CancelRequested;
00025         Platform::Agile<Windows::ApplicationModel::Background::BackgroundTaskDeferral> Deferral;
00026         ThreadPoolTimer^ PeriodicTimer;
00027         unsigned int Progress;
00028         IBackgroundTaskInstance^ TaskInstance;
00029     };
00030 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/BasicMath.h Source File

  • DXGI offer and reclaim resources

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/pch.cpp Source File

  • XAML AppBar control

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/pch.h Source File

  • Device enumeration

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Foundation::Collections;
00027 using namespace Platform::Collections;
00028 using namespace std;
00029 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/pch.h Source File

  • Direct3D post-processing effects

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
00017 #include "BasicMath.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D bump mapping/C++/DirectXApp.cpp Source File

  • Direct3D bump mapping

DirectXApp.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXApp.h"
00010 #include "BasicTimer.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Storage;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::Foundation::Collections;
00020 using namespace Windows::Graphics::Display;
00021
00022 DirectXApp::DirectXApp() :
00023     m_windowClosed(false),
00024     m_windowVisible(true)
00025 {
00026 }
00027
00028 void DirectXApp::Initialize(
00029     _In_ CoreApplicationView^ applicationView
00030     )
00031 {
00032     applicationView->Activated +=
00033         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DirectXApp::OnActivated);
00034
00035     CoreApplication::Suspending +=
00036         ref new EventHandler<SuspendingEventArgs^>(this, &DirectXApp::OnSuspending);
00037
00038     CoreApplication::Resuming +=
00039         ref new EventHandler<Platform::Object^>(this, &DirectXApp::OnResuming);
00040
00041     m_renderer = ref new BumpMapping();
00042 }
00043
00044 void DirectXApp::SetWindow(
00045     _In_ CoreWindow^ window
00046     )
00047 {
00048     // set cursor to stop spinning
00049     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00050
00051     window->SizeChanged +=
00052         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DirectXApp::OnWindowSizeChanged);
00053
00054     window->VisibilityChanged +=
00055         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &DirectXApp::OnVisibilityChanged);
00056
00057     window->Closed +=
00058         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &DirectXApp::OnWindowClosed);
00059
00060     DisplayProperties::LogicalDpiChanged +=
00061         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnLogicalDpiChanged);
00062
00063
00064     m_renderer->Initialize(window, DisplayProperties::LogicalDpi);
00065 }
00066
00067 void DirectXApp::Load(
00068     _In_ Platform::String^ entryPoint
00069     )
00070 {
00071     IPropertySet^ appState = ApplicationData::Current->LocalSettings->Values;
00072     m_renderer->LoadInternalState(appState);
00073 }
00074
00075 void DirectXApp::Run()
00076 {
00077     BasicTimer^ timer = ref new BasicTimer();
00078
00079     while (!m_windowClosed)
00080     {
00081         if (m_windowVisible)
00082         {
00083             timer->Update();
00084             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00085             m_renderer->Update(timer->Total, timer->Delta);
00086             m_renderer->Render();
00087             m_renderer->Present(); // This call is synchronized to the display frame rate.
00088         }
00089         else
00090         {
00091             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00092         }
00093     }
00094 }
00095
00096 void DirectXApp::Uninitialize()
00097 {
00098 }
00099
00100 void DirectXApp::OnWindowSizeChanged(
00101     _In_ CoreWindow^ sender,
00102     _In_ WindowSizeChangedEventArgs^ args
00103     )
00104 {
00105     m_renderer->UpdateForWindowSizeChange();
00106 }
00107
00108 void DirectXApp::OnVisibilityChanged(
00109     _In_ CoreWindow^ sender,
00110     _In_ VisibilityChangedEventArgs^ args
00111     )
00112 {
00113     m_windowVisible = args->Visible;
00114 }
00115
00116 void DirectXApp::OnWindowClosed(
00117     _In_ CoreWindow^ sender,
00118     _In_ CoreWindowEventArgs^ args
00119     )
00120 {
00121     m_windowClosed = true;
00122 }
00123
00124 void DirectXApp::OnLogicalDpiChanged(
00125     _In_ Platform::Object^ sender
00126     )
00127 {
00128     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00129 }
00130
00131 void DirectXApp::OnActivated(
00132     _In_ CoreApplicationView^ applicationView,
00133     _In_ IActivatedEventArgs^ args
00134     )
00135 {
00136     CoreWindow::GetForCurrentThread()->Activate();
00137 }
00138
00139 void DirectXApp::OnSuspending(
00140     _In_ Platform::Object^ sender,
00141     _In_ SuspendingEventArgs^ args
00142     )
00143 {
00144     IPropertySet^ appState = ApplicationData::Current->LocalSettings->Values;
00145     m_renderer->SaveInternalState(appState);
00146 }
00147
00148 void DirectXApp::OnResuming(
00149     _In_ Platform::Object^ sender,
00150     _In_ Platform::Object^ args
00151     )
00152 {
00153 }
00154
00155 IFrameworkView^ DirectXAppSource::CreateView()
00156 {
00157     return ref new DirectXApp();
00158 }
00159
00160 [Platform::MTAThread]
00161 int main(Platform::Array<Platform::String^>^)
00162 {
00163     auto directXAppSource = ref new DirectXAppSource();
00164     CoreApplication::Run(directXAppSource);
00165     return 0;
00166 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D composite effect modes/C++/DirectXBase.cpp Source File

  • Direct2D composite effect modes

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/ImageFile.h Source File

  • Direct2D magazine app

ImageFile.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 //  Resource supporting sequential stream interface used by the DOM API.
00011 //
00012 //  This class only implements stream reading and not writing.
00013 //
00014 class ImageFile : public IStream
00015 {
00016 public:
00017     ImageFile();
00018
00019     void LoadAsync(
00020         _In_ Windows::Storage::StorageFolder^ location,
00021         _In_ Platform::String^ fileName
00022         );
00023
00024     virtual HRESULT STDMETHODCALLTYPE QueryInterface(
00025         REFIID uuid,
00026         _Outptr_ void** object
00027         ) override;
00028
00029     virtual ULONG STDMETHODCALLTYPE AddRef() override;
00030
00031     virtual ULONG STDMETHODCALLTYPE Release() override;
00032
00033     virtual HRESULT STDMETHODCALLTYPE Read(
00034         _Out_writes_bytes_(bytesToRead) void* outputBuffer,
00035         ULONG bytesToRead,
00036         _Out_ ULONG* bytesRead
00037         ) override;
00038
00039     virtual HRESULT STDMETHODCALLTYPE Write(
00040         _In_reads_bytes_(bytesToWrite) void const* inputBuffer,
00041         ULONG bytesToWrite,
00042         _Out_ ULONG* bytesWritten
00043         ) override;
00044
00045     virtual HRESULT STDMETHODCALLTYPE SetSize(ULARGE_INTEGER) override;
00046
00047     virtual HRESULT STDMETHODCALLTYPE CopyTo(
00048         _In_ IStream* destinationStream,
00049         ULARGE_INTEGER bytesToCopy,
00050         _Out_ ULARGE_INTEGER* bytesRead,
00051         _Out_ ULARGE_INTEGER* bytesWritten
00052         ) override;
00053
00054     virtual HRESULT STDMETHODCALLTYPE Commit(DWORD flags) override;
00055
00056     virtual HRESULT STDMETHODCALLTYPE Revert() override;
00057
00058     virtual HRESULT STDMETHODCALLTYPE LockRegion(
00059         ULARGE_INTEGER bytesOffset,
00060         ULARGE_INTEGER bytesToLock,
00061         DWORD lockType
00062         ) override;
00063
00064     virtual HRESULT STDMETHODCALLTYPE UnlockRegion(
00065         ULARGE_INTEGER bytesOffset,
00066         ULARGE_INTEGER bytesToLock,
00067         DWORD lockType
00068         ) override;
00069
00070     virtual HRESULT STDMETHODCALLTYPE Clone(_Outptr_ IStream **cloneStream) override;
00071
00072     virtual HRESULT STDMETHODCALLTYPE Seek(
00073         LARGE_INTEGER distance,
00074         DWORD origin,
00075         _Out_ ULARGE_INTEGER* newLocation
00076         ) override;
00077
00078     virtual HRESULT STDMETHODCALLTYPE Stat(
00079         _Out_ STATSTG* statistics,
00080         DWORD flags
00081         ) override;
00082
00083     inline bool Ready()
00084     {
00085         return m_data != nullptr;
00086     }
00087
00088 private:
00089     // Reference counter
00090     ULONG m_refCount;
00091
00092     // Resource data
00093     Platform::Array<byte>^ m_data;
00094
00095     // Current read offset in bytes
00096     ULONG m_offset;
00097 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/BasicMath.h Source File

  • DirectX 3D shooting game

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/PaperFragment.cpp Source File

  • DirectX postcard app

PaperFragment.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "pch.h"
00011 #include "PaperFragment.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::UI::Core;
00016
00017 PaperFragment::PaperFragment(
00018     ComPtr<ID2D1DeviceContext> d2dContext,
00019     ID2D1Geometry* pGeometry,
00020     D2D1_COLOR_F &color
00021     )
00022 {
00023     m_d2dContext = d2dContext;
00024     m_geometry = pGeometry;
00025     m_color = color;
00026
00027     m_position = D2D1::Point2F(0, 0);
00028
00029     DX::ThrowIfFailed(
00030         m_d2dContext->CreateSolidColorBrush(
00031             m_color,
00032             &m_brush
00033             )
00034         );
00035
00036     GeneratePaperBitmap();
00037 }
00038
00039 void PaperFragment::GeneratePaperBitmap()
00040 {
00041     ComPtr<ID2D1Device> spDevice;
00042     m_d2dContext->GetDevice(&spDevice);
00043
00044     ComPtr<ID2D1Effect> spEdgeTurbulance;
00045     DX::ThrowIfFailed(
00046         m_d2dContext->CreateEffect(
00047             CLSID_D2D1Turbulence,
00048             &spEdgeTurbulance
00049             )
00050         );
00051
00052     {
00053         D2D1_VECTOR_2F offset = {-100000, -100000};
00054         DX::ThrowIfFailed(
00055             spEdgeTurbulance->SetValue(D2D1_TURBULENCE_PROP_OFFSET, offset)
00056             );
00057
00058         D2D1_VECTOR_2F size = {200000, 200000};
00059         DX::ThrowIfFailed(
00060             spEdgeTurbulance->SetValue(D2D1_TURBULENCE_PROP_SIZE, size)
00061             );
00062
00063         D2D1_VECTOR_2F baseFrequency = {0.3f, 0.3f};
00064         DX::ThrowIfFailed(
00065             spEdgeTurbulance->SetValue(D2D1_TURBULENCE_PROP_BASE_FREQUENCY, baseFrequency)
00066             );
00067
00068         DX::ThrowIfFailed(
00069             spEdgeTurbulance->SetValue(D2D1_TURBULENCE_PROP_SEED, 42)
00070             );
00071     }
00072
00073     ComPtr<ID2D1Effect> spEdgeTurbulanceColorMatrix;
00074     DX::ThrowIfFailed(
00075         m_d2dContext->CreateEffect(
00076             CLSID_D2D1ColorMatrix,
00077             &spEdgeTurbulanceColorMatrix
00078             )
00079         );
00080
00081     {
00082         D2D_MATRIX_5X4_F colorMatrix =
00083         {
00084             2, 0, 0, 0,
00085             0, 2, 0, 0,
00086             0, 0, 2, 0,
00087             0, 0, 0, 1,
00088             0, 0, 0, 0
00089         };
00090
00091         DX::ThrowIfFailed(
00092             spEdgeTurbulanceColorMatrix->SetValue(D2D1_COLORMATRIX_PROP_COLOR_MATRIX, colorMatrix)
00093             );
00094     }
00095
00096     ComPtr<ID2D1Effect> spEdgeErode;
00097     DX::ThrowIfFailed(
00098         m_d2dContext->CreateEffect(
00099             CLSID_D2D1Morphology,
00100             &spEdgeErode
00101             )
00102         );
00103
00104     {
00105         DX::ThrowIfFailed(
00106             spEdgeErode->SetValue(D2D1_MORPHOLOGY_PROP_WIDTH, 10)
00107             );
00108
00109         DX::ThrowIfFailed(
00110             spEdgeErode->SetValue(D2D1_MORPHOLOGY_PROP_HEIGHT, 10)
00111             );
00112     }
00113
00114     ComPtr<ID2D1Effect> spEdgeDisplacement;
00115     DX::ThrowIfFailed(
00116         m_d2dContext->CreateEffect(
00117             CLSID_D2D1DisplacementMap,
00118             &spEdgeDisplacement
00119             )
00120         );
00121
00122     {
00123         DX::ThrowIfFailed(
00124             spEdgeDisplacement->SetValue(D2D1_DISPLACEMENTMAP_PROP_SCALE, 10.0f)
00125             );
00126
00127         DX::ThrowIfFailed(
00128             spEdgeDisplacement->SetValue(
00129                 D2D1_DISPLACEMENTMAP_PROP_X_CHANNEL_SELECT,
00130                 D2D1_CHANNEL_SELECTOR_R
00131                 )
00132             );
00133
00134         DX::ThrowIfFailed(
00135             spEdgeDisplacement->SetValue(
00136                 D2D1_DISPLACEMENTMAP_PROP_Y_CHANNEL_SELECT,
00137                 D2D1_CHANNEL_SELECTOR_G
00138                 )
00139             );
00140     }
00141
00142     ComPtr<ID2D1Effect> spBumpTurbulance;
00143     DX::ThrowIfFailed(
00144         m_d2dContext->CreateEffect(
00145             CLSID_D2D1Turbulence,
00146             &spBumpTurbulance
00147             )
00148         );
00149
00150     {
00151         D2D1_VECTOR_2F offset = {-100000, -100000};
00152         DX::ThrowIfFailed(
00153             spBumpTurbulance->SetValue(D2D1_TURBULENCE_PROP_OFFSET, offset)
00154             );
00155
00156         D2D1_VECTOR_2F size = {200000, 200000};
00157         DX::ThrowIfFailed(
00158             spBumpTurbulance->SetValue(D2D1_TURBULENCE_PROP_SIZE, size)
00159             );
00160
00161         D2D1_VECTOR_2F baseFrequency = {0.3f, 0.3f};
00162         DX::ThrowIfFailed(
00163             spBumpTurbulance->SetValue(D2D1_TURBULENCE_PROP_BASE_FREQUENCY, baseFrequency)
00164             );
00165
00166         DX::ThrowIfFailed(
00167             spBumpTurbulance->SetValue(D2D1_TURBULENCE_PROP_SEED, 42)
00168             );
00169     }
00170
00171     ComPtr<ID2D1Effect> spBumpDiffuse;
00172     DX::ThrowIfFailed(
00173         m_d2dContext->CreateEffect(
00174             CLSID_D2D1DistantSpecular,
00175             &spBumpDiffuse
00176             )
00177         );
00178
00179     {
00180         DX::ThrowIfFailed(
00181             spBumpDiffuse->SetValue(D2D1_DISTANTSPECULAR_PROP_SURFACE_SCALE, 0.25f)
00182             );
00183     }
00184
00185     ComPtr<ID2D1Effect> spBumpComposite;
00186     DX::ThrowIfFailed(
00187         m_d2dContext->CreateEffect(
00188             CLSID_D2D1ArithmeticComposite,
00189             &spBumpComposite
00190             )
00191         );
00192
00193     {
00194         D2D1_VECTOR_4F coefficients = {1.3f, 0, 0, 0};
00195         DX::ThrowIfFailed(
00196             spBumpComposite->SetValue(D2D1_ARITHMETICCOMPOSITE_PROP_COEFFICIENTS, coefficients)
00197             );
00198     }
00199
00200     ComPtr<ID2D1Effect> spShadow;
00201     DX::ThrowIfFailed(
00202         m_d2dContext->CreateEffect(
00203             CLSID_D2D1Shadow,
00204             &spShadow
00205             )
00206         );
00207
00208     {
00209         DX::ThrowIfFailed(
00210             spShadow->SetValue(D2D1_SHADOW_PROP_BLUR_STANDARD_DEVIATION, 3.0f)
00211             );
00212     }
00213
00214     ComPtr<ID2D1Effect> spShadowOffset;
00215     DX::ThrowIfFailed(
00216         m_d2dContext->CreateEffect(
00217             CLSID_D2D12DAffineTransform,
00218             &spShadowOffset
00219             )
00220         );
00221
00222     {
00223         DX::ThrowIfFailed(
00224             spShadowOffset->SetValue(
00225                 D2D1_2DAFFINETRANSFORM_PROP_TRANSFORM_MATRIX,
00226                 D2D1::Matrix3x2F::Translation(3, 3)
00227                 )
00228             );
00229     }
00230
00231     ComPtr<ID2D1Effect> spShadowComposite;
00232     DX::ThrowIfFailed(
00233         m_d2dContext->CreateEffect(
00234             CLSID_D2D1Composite,
00235             &spShadowComposite
00236             )
00237         );
00238
00239     ComPtr<ID2D1Effect> spEdgeDisplacementColorMatrix;
00240     DX::ThrowIfFailed(
00241         m_d2dContext->CreateEffect(
00242             CLSID_D2D1ColorMatrix,
00243             &spEdgeDisplacementColorMatrix
00244             )
00245         );
00246
00247     {
00248         D2D_MATRIX_5X4_F colorMatrix =
00249         {
00250             0, 0, 0, 0,
00251             0, 0, 0, 0,
00252             0, 0, 0, 0,
00253             0, 0, 0, 1,
00254             1, 1, 1, 0
00255         };
00256
00257         DX::ThrowIfFailed(
00258             spEdgeDisplacementColorMatrix->SetValue(
00259                 D2D1_COLORMATRIX_PROP_COLOR_MATRIX,
00260                 colorMatrix
00261                 )
00262             );
00263     }
00264
00265     ComPtr<ID2D1Effect> spEdgeDisplacementComposite;
00266     DX::ThrowIfFailed(
00267         m_d2dContext->CreateEffect(
00268             CLSID_D2D1ArithmeticComposite,
00269             &spEdgeDisplacementComposite
00270             )
00271         );
00272
00273     ComPtr<ID2D1CommandList> spCommandList;
00274     DX::ThrowIfFailed(
00275         m_d2dContext->CreateCommandList(&spCommandList)
00276         );
00277
00278     ComPtr<ID2D1Image> oldTarget;
00279     m_d2dContext->GetTarget(&oldTarget);
00280
00281     m_d2dContext->SetTarget(spCommandList.Get());
00282
00283     D2D1_MATRIX_3X2_F oldTransform;
00284     m_d2dContext->GetTransform(&oldTransform);
00285
00286     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00287
00288     m_d2dContext->BeginDraw();
00289
00290     m_d2dContext->FillGeometry(
00291         m_geometry.Get(),
00292         m_brush.Get()
00293         );
00294
00295     DX::ThrowIfFailed(
00296         m_d2dContext->EndDraw()
00297         );
00298
00299     DX::ThrowIfFailed(
00300         spCommandList->Close()
00301         );
00302
00303     spEdgeErode->SetInput(0, spCommandList.Get());
00304
00305     spEdgeTurbulanceColorMatrix->SetInputEffect(0, spEdgeTurbulance.Get());
00306
00307     spEdgeDisplacement->SetInputEffect(0, spEdgeErode.Get());
00308     spEdgeDisplacement->SetInputEffect(1, spEdgeTurbulanceColorMatrix.Get());
00309
00310     spEdgeDisplacementColorMatrix->SetInputEffect(0, spEdgeDisplacement.Get());
00311
00312     spShadow->SetInputEffect(0, spEdgeDisplacement.Get());
00313
00314     spShadowOffset->SetInputEffect(0, spShadow.Get());
00315
00316     spEdgeDisplacementComposite->SetInputEffect(0, spEdgeDisplacementColorMatrix.Get());
00317     spEdgeDisplacementComposite->SetInput(1, spCommandList.Get());
00318
00319     spBumpDiffuse->SetInputEffect(0, spBumpTurbulance.Get());
00320
00321     spBumpComposite->SetInputEffect(0, spEdgeDisplacementComposite.Get());
00322     spBumpComposite->SetInputEffect(1, spBumpDiffuse.Get());
00323
00324     spShadowComposite->SetInputEffect(0, spShadowOffset.Get());
00325     spShadowComposite->SetInputEffect(1, spBumpComposite.Get());
00326
00327     D2D1_RECT_F bounds;
00328
00329     ComPtr<ID2D1Image> spOutputImage;
00330     spShadowComposite->GetOutput(&spOutputImage);
00331
00332     DX::ThrowIfFailed(
00333         m_d2dContext->GetImageLocalBounds(
00334             spOutputImage.Get(),
00335             &bounds
00336             )
00337         );
00338
00339     m_bitmapOffset = D2D1::Point2F(
00340         static_cast<float>(bounds.left),
00341         static_cast<float>(bounds.top)
00342         );
00343
00344     DX::ThrowIfFailed(
00345         m_d2dContext->CreateBitmap(
00346             D2D1::SizeU(
00347                 static_cast<uint32>(bounds.right - bounds.left),
00348                 static_cast<uint32>(bounds.bottom - bounds.top)
00349                 ),
00350             nullptr,    // sourceData
00351             0,          // pitch
00352             D2D1::BitmapProperties1(
00353                 D2D1_BITMAP_OPTIONS_TARGET,
00354                 D2D1::PixelFormat(
00355                     DXGI_FORMAT_B8G8R8A8_UNORM,
00356                     D2D1_ALPHA_MODE_PREMULTIPLIED
00357                     )
00358                 ),
00359             &m_bitmap
00360             )
00361         );
00362
00363     m_d2dContext->SetTarget(m_bitmap.Get());
00364
00365     m_d2dContext->BeginDraw();
00366
00367     m_d2dContext->Clear(D2D1::ColorF(0, 0, 0, 0));
00368
00369     m_d2dContext->SetTransform(
00370         D2D1::Matrix3x2F::Translation(
00371             -m_bitmapOffset.x,
00372             -m_bitmapOffset.y
00373             )
00374         );
00375
00376     m_d2dContext->DrawImage(spShadowComposite.Get());
00377
00378     DX::ThrowIfFailed(
00379         m_d2dContext->EndDraw()
00380         );
00381
00382     m_d2dContext->SetTarget(oldTarget.Get());
00383
00384     m_d2dContext->SetTransform(oldTransform);
00385 }
00386
00387 void PaperFragment::Draw()
00388 {
00389     D2D1::Matrix3x2F originalTransform;
00390     m_d2dContext->GetTransform(&originalTransform);
00391
00392     {
00393         D2D1::Matrix3x2F offsetTransform =
00394             D2D1::Matrix3x2F::Translation(
00395                 m_bitmapOffset.x + m_position.x,
00396                 m_bitmapOffset.y + m_position.y
00397                 ) * originalTransform;
00398
00399         m_d2dContext->SetTransform(&offsetTransform);
00400
00401         m_d2dContext->DrawBitmap(m_bitmap.Get());
00402     }
00403
00404     m_d2dContext->SetTransform(&originalTransform);
00405 }
00406
00407 D2D1_POINT_2F PaperFragment::GetPosition()
00408 {
00409     return m_position;
00410 }
00411
00412 void PaperFragment::SetPosition(D2D1_POINT_2F position)
00413 {
00414     m_position = position;
00415 }
00416
00417 bool PaperFragment::HitTest(D2D1_POINT_2F point)
00418 {
00419     BOOL contains;
00420
00421     DX::ThrowIfFailed(
00422         m_geometry->FillContainsPoint(
00423             point,
00424             D2D1::Matrix3x2F::Translation(
00425                 m_position.x,
00426                 m_position.y
00427                 ),
00428             &contains
00429             )
00430         );
00431
00432     return (contains ? true : false);
00433 }
00434
00435 bool PaperFragment::HitTestWithGeometry(D2D1_POINT_2F point, ID2D1Geometry* pGeometry)
00436 {
00437     D2D1_GEOMETRY_RELATION relation;
00438
00439     DX::ThrowIfFailed(
00440         m_geometry->CompareWithGeometry(
00441             pGeometry,
00442             D2D1::Matrix3x2F::Translation(
00443                 point.x - m_position.x,
00444                 point.y - m_position.y
00445                 ),
00446             &relation
00447             )
00448         );
00449
00450     return (relation != D2D1_GEOMETRY_RELATION_DISJOINT);
00451 }
00452
00453 PaperFragment^ PaperFragment::GetMergeWith(
00454     D2D1_POINT_2F point,
00455     ID2D1Geometry* pGeometry,
00456     D2D1_COMBINE_MODE mode
00457     )
00458 {
00459     ComPtr<ID2D1Factory> spFactory;
00460     ComPtr<ID2D1TransformedGeometry> spTransformedGeometry;
00461
00462     m_geometry->GetFactory(&spFactory);
00463
00464     DX::ThrowIfFailed(
00465         spFactory->CreateTransformedGeometry(
00466             m_geometry.Get(),
00467             D2D1::Matrix3x2F::Translation(
00468                 m_position.x,
00469                 m_position.y
00470                 ),
00471             &spTransformedGeometry
00472             )
00473         );
00474
00475     ComPtr<ID2D1PathGeometry> spPathGeometry;
00476     ComPtr<ID2D1GeometrySink> spGeometrySink;
00477
00478     DX::ThrowIfFailed(
00479         spFactory->CreatePathGeometry(&spPathGeometry)
00480         );
00481
00482     DX::ThrowIfFailed(
00483         spPathGeometry->Open(&spGeometrySink)
00484         );
00485
00486     DX::ThrowIfFailed(
00487         spTransformedGeometry->CombineWithGeometry(
00488             pGeometry,
00489             mode,
00490             D2D1::Matrix3x2F::Translation(
00491                 point.x,
00492                 point.y
00493                 ),
00494             spGeometrySink.Get()
00495             )
00496         );
00497
00498     DX::ThrowIfFailed(
00499         spGeometrySink->Close()
00500         );
00501
00502     PaperFragment^ spNewFragment =
00503         ref new PaperFragment(
00504             m_d2dContext,
00505             spPathGeometry.Get(),
00506             m_color
00507             );
00508
00509     spNewFragment->SetPosition(D2D1::Point2F(0, 0));
00510
00511     return spNewFragment;
00512 }
00513
00514 PaperFragment^ PaperFragment::GetIntersectionWith(
00515     D2D1_POINT_2F point,
00516     ID2D1Geometry* pGeometry
00517     )
00518 {
00519     return GetMergeWith(
00520         point,
00521         pGeometry,
00522         D2D1_COMBINE_MODE_INTERSECT
00523         );
00524 }
00525
00526 PaperFragment^ PaperFragment::GetExclusionWith(
00527     D2D1_POINT_2F point,
00528     ID2D1Geometry *pGeometry
00529     )
00530 {
00531     return GetMergeWith(
00532         point,
00533         pGeometry,
00534         D2D1_COMBINE_MODE_EXCLUDE
00535         );
00536 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/DirectXBase.cpp Source File

  • Direct2Dapp printing

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_MULTI_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Windows Store apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Windows Store apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Windows Store apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compass sensor/C++/common/suspensionmanager.h Source File

  • Compass sensor
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario1.xaml.cpp Source File

  • Credential locker

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::PasswordVaultCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Security::Credentials;
00025 using namespace concurrency;
00026
00027 Scenario1::Scenario1()
00028 {
00029     InitializeComponent();
00030
00031     // Initialize the password vault, this may take less than a second
00032     // An optimistic initialization at this stage improves the UI performance
00033     // when any other call to the password vault may be made later on
00034     auto task = InitializeVaultAsync();
00035 }
00036
00037 /// <summary>
00038 /// Invoked when this page is about to be displayed in a Frame.
00039 /// </summary>
00040 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00041 /// property is typically used to configure the page.</param>
00042 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00045     // as NotifyUser()
00046     rootPage = MainPage::Current;
00047 }
00048
00049 Windows::Foundation::IAsyncAction^ Scenario1::InitializeVaultAsync()
00050 {
00051     // any call to the password vault will load the vault
00052     return create_async([](){
00053         Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00054         vault->RetrieveAll();
00055     });
00056 }
00057
00058 void DebugPrint(Page^ rootPage, Platform::String^ Trace)
00059 {
00060     Page^ outputFrame = (Page^) rootPage;
00061     TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
00062     ErrorMessage->Text += Trace + "\r\n";
00063 }
00064
00065 void Reset1(Page^ rootPage)
00066 {
00067     try
00068     {
00069         Page^ outputFrame = (Page^) rootPage;
00070         Page^ inputFrame = (Page^) rootPage;
00071         TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
00072         InputUserNameValue->Text = "";
00073         PasswordBox^ InputPasswordValue = (PasswordBox^)outputFrame->FindName("InputPasswordValue");
00074         InputPasswordValue->Password= "";
00075         TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
00076         ErrorMessage->Text = "";
00077         TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
00078         CheckBox^ SaveCredCheck = (CheckBox^) outputFrame->FindName("SaveCredCheck");
00079         SaveCredCheck->IsChecked = false;
00080     }
00081     catch (Platform::Exception^ Error)
00082     {
00083         DebugPrint(rootPage, Error->ToString());
00084     }
00085 }
00086
00087
00088 void SDKSample::PasswordVaultCPP::Scenario1::Launch_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00089 {
00090     try
00091     {
00092         Page^ outputFrame = (Page^) rootPage->Current;
00093         Page^ inputFrame = (Page^) rootPage->Current;
00094         Reset1(rootPage);
00095         CheckBox^ AuthenticationFailCheck = (CheckBox^) outputFrame->FindName("AuthenticationFailCheck");
00096         TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
00097         if (AuthenticationFailCheck->IsChecked->Value == true)
00098         {
00099             WelcomeMessage->Text = "Blocked";
00100         }
00101         else
00102         {
00103             PasswordCredential^ cred = ref new PasswordCredential();
00104             Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00105             Windows::Foundation::Collections::IVectorView<PasswordCredential^>^ Creds = vault->FindAllByResource("Scenario 1");
00106             for each (PasswordCredential^ cred in Creds)
00107             {
00108                 try
00109                 {
00110                     vault->Remove(cred);
00111                 }
00112                 catch (Platform::COMException^ Error)
00113                 {
00114                     DebugPrint(rootPage, Error->ToString());
00115                 }
00116              }
00117              WelcomeMessage->Text = "Scenario is ready, please sign in";
00118         }
00119     }
00120     catch (Platform::COMException^ Error)
00121     {
00122           DebugPrint(rootPage, Error->ToString());
00123
00124     }
00125 }
00126
00127
00128
00129 void SDKSample::PasswordVaultCPP::Scenario1::Signin_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00130 {
00131     Page^ outputFrame = (Page^) rootPage->Current;
00132     Page^ inputFrame = (Page^) rootPage->Current;
00133     TextBox^ InputUserNameValue = (TextBox^) outputFrame->FindName("InputUserNameValue");
00134     PasswordBox^ InputPasswordValue = (PasswordBox^) outputFrame->FindName("InputPasswordValue");
00135     TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
00136     CheckBox^ SaveCredCheck = (CheckBox ^) outputFrame->FindName("SaveCredCheck");
00137     if (InputUserNameValue->Text == "" || InputPasswordValue->Password == "")
00138     {
00139         TextBox^ ErrorMessage = (TextBox^) outputFrame->FindName("ErrorMessage");
00140         ErrorMessage->Text = "User name and password are not allowed to be empty, Please input user name and password";
00141     }
00142     else
00143     {
00144         try
00145         {
00146             Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00147             PasswordCredential^ c = ref new PasswordCredential("Scenario 1", InputUserNameValue->Text, InputPasswordValue->Password);
00148             if (SaveCredCheck->IsChecked)
00149             {
00150                 vault->Add(c);
00151             }
00152             Reset1(rootPage);
00153             WelcomeMessage->Text = "Welcome to " + c->Resource + ", " + c->UserName;
00154         }
00155         catch (Platform::COMException^ Error)
00156         {
00157             DebugPrint(rootPage, Error->ToString());
00158         }
00159     }
00160     Reset1(rootPage);
00161     CheckBox^ AuthenticationFailCheck = (CheckBox^) outputFrame->FindName("AuthenticationFailCheck");
00162     AuthenticationFailCheck->IsChecked= false;
00163 }
00164
00165
00166 void SDKSample::PasswordVaultCPP::Scenario1::ChangeUser_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00167 {
00168     try
00169     {
00170         Windows::Security::Credentials::PasswordVault^ vault = ref new Windows::Security::Credentials::PasswordVault();
00171         Windows::Foundation::Collections::IVectorView<PasswordCredential^>^ creds = vault->FindAllByResource("Scenario 1");
00172         for each (PasswordCredential^ c in creds)
00173         {
00174             try
00175             {
00176                 vault->Remove(c);
00177             }
00178             catch (Platform::COMException^ Error)
00179             {
00180                 DebugPrint(rootPage, Error->ToString());
00181             }
00182         }
00183     }
00184     catch (Platform::COMException^ Error)
00185     {
00186         DebugPrint(rootPage, Error->ToString());
00187     }
00188
00189     Reset1(rootPage);
00190     Page^ outputFrame = (Page^) rootPage->Current;
00191     Page^ inputFrame = (Page^) rootPage->Current;
00192     CheckBox^ AuthenticationFailCheck = (CheckBox^) outputFrame->FindName("AuthenticationFailCheck");
00193     AuthenticationFailCheck->IsChecked = false;
00194     TextBox^ WelcomeMessage = (TextBox^) inputFrame->FindName("WelcomeMessage");
00195     WelcomeMessage->Text = "User has been changed, please resign in with new credentials, choose save and launch scenario again";
00196 }
00197
00198
00199 void SDKSample::PasswordVaultCPP::Scenario1::Reset_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00200 {
00201     Reset1(rootPage);
00202 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/SampleOverlay.h Source File

  • XAudio2 audio stream effect

SampleOverlay.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // This class is responsible for initializing and rendering the title overlay visible
00013 // at the top of the DirectX SDK samples.
00014 ref class SampleOverlay
00015 {
00016 internal:
00017     SampleOverlay();
00018
00019     void Initialize(
00020         _In_ ID2D1Device*         d2dDevice,
00021         _In_ ID2D1DeviceContext*  d2dContext,
00022         _In_ IWICImagingFactory*  wicFactory,
00023         _In_ IDWriteFactory*      dwriteFactory,
00024         _In_ Platform::String^    caption
00025         );
00026
00027     void ResetDirectXResources();
00028
00029     void UpdateForWindowSizeChange();
00030
00031     void Render();
00032
00033     float GetTitleHeightInDips();
00034
00035 private:
00036
00037     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00038     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00039     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00040     Microsoft::WRL::ComPtr<IDWriteFactory>          m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush>    m_whiteBrush;
00042     Microsoft::WRL::ComPtr<ID2D1DrawingStateBlock>  m_stateBlock;
00043
00044     Microsoft::WRL::ComPtr<IWICImagingFactory>      m_wicFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Bitmap>             m_logoBitmap;
00046     Microsoft::WRL::ComPtr<IDWriteTextLayout>       m_textLayout;
00047
00048     UINT                                            m_idIncrement;
00049     bool                                            m_drawOverlay;
00050     Platform::String^                               m_sampleName;
00051     float                                           m_padding;
00052     float                                           m_textVerticalOffset;
00053     D2D1_SIZE_F                                     m_logoSize;
00054     float                                           m_overlayWidth;
00055 };
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential locker/C++/Scenario4.xaml.h Source File

  • Credential locker

Scenario4.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace PasswordVaultCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario4 sealed
00031         {
00032         public:
00033             Scenario4();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void Other_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041     void Launch_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042     void Signin_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043     void ChangeUser_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00044     void Reset_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00045     void SelectResource_Click(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00046     void SelectUser_Click(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00047   };
00048     }
00049 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/DirectXApp.cpp Source File

  • Direct3D-Direct2D interop

DirectXApp.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXApp.h"
00010 #include "BasicTimer.h"
00011
00012 using namespace Windows::ApplicationModel;
00013 using namespace Windows::ApplicationModel::Core;
00014 using namespace Windows::ApplicationModel::Activation;
00015 using namespace Windows::UI::Core;
00016 using namespace Windows::System;
00017 using namespace Windows::Foundation;
00018 using namespace Windows::Graphics::Display;
00019
00020 DirectXApp::DirectXApp() :
00021     m_windowClosed(false),
00022     m_windowVisible(true)
00023 {
00024 }
00025
00026 void DirectXApp::Initialize(
00027     _In_ CoreApplicationView^ applicationView
00028     )
00029 {
00030     applicationView->Activated +=
00031         ref new TypedEventHandler<CoreApplicationView^, IActivatedEventArgs^>(this, &DirectXApp::OnActivated);
00032
00033     m_renderer = ref new TextInterop();
00034 }
00035
00036 void DirectXApp::SetWindow(
00037     _In_ CoreWindow^ window
00038     )
00039 {
00040     window->PointerCursor = ref new CoreCursor(CoreCursorType::Arrow, 0);
00041
00042     window->SizeChanged +=
00043         ref new TypedEventHandler<CoreWindow^, WindowSizeChangedEventArgs^>(this, &DirectXApp::OnWindowSizeChanged);
00044
00045     window->VisibilityChanged +=
00046         ref new TypedEventHandler<CoreWindow^, VisibilityChangedEventArgs^>(this, &DirectXApp::OnVisibilityChanged);
00047
00048     window->Closed +=
00049         ref new TypedEventHandler<CoreWindow^, CoreWindowEventArgs^>(this, &DirectXApp::OnWindowClosed);
00050
00051     DisplayProperties::LogicalDpiChanged +=
00052         ref new DisplayPropertiesEventHandler(this, &DirectXApp::OnLogicalDpiChanged);
00053
00054     m_renderer->Initialize(window, DisplayProperties::LogicalDpi);
00055 }
00056
00057 void DirectXApp::Load(
00058     _In_ Platform::String^ entryPoint
00059     )
00060 {
00061 }
00062
00063 void DirectXApp::Run()
00064 {
00065     BasicTimer^ timer = ref new BasicTimer();
00066
00067     while (!m_windowClosed)
00068     {
00069         if (m_windowVisible)
00070         {
00071             timer->Update();
00072             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessAllIfPresent);
00073             m_renderer->Update(timer->Total, timer->Delta);
00074             m_renderer->Render();
00075             m_renderer->Present(); // This call is synchronized to the display frame rate.
00076         }
00077         else
00078         {
00079             CoreWindow::GetForCurrentThread()->Dispatcher->ProcessEvents(CoreProcessEventsOption::ProcessOneAndAllPending);
00080         }
00081     }
00082 }
00083
00084 void DirectXApp::Uninitialize()
00085 {
00086 }
00087
00088 void DirectXApp::OnWindowSizeChanged(
00089     _In_ CoreWindow^ sender,
00090     _In_ WindowSizeChangedEventArgs^ args
00091     )
00092 {
00093     m_renderer->UpdateForWindowSizeChange();
00094 }
00095
00096 void DirectXApp::OnVisibilityChanged(
00097     _In_ CoreWindow^ sender,
00098     _In_ VisibilityChangedEventArgs^ args
00099     )
00100 {
00101     m_windowVisible = args->Visible;
00102 }
00103
00104 void DirectXApp::OnWindowClosed(
00105     _In_ CoreWindow^ sender,
00106     _In_ CoreWindowEventArgs^ args
00107     )
00108 {
00109     m_windowClosed = true;
00110 }
00111
00112 void DirectXApp::OnLogicalDpiChanged(
00113     _In_ Platform::Object^ sender
00114     )
00115 {
00116     m_renderer->SetDpi(DisplayProperties::LogicalDpi);
00117 }
00118
00119 void DirectXApp::OnActivated(
00120     _In_ CoreApplicationView^ applicationView,
00121     _In_ IActivatedEventArgs^ args
00122     )
00123 {
00124     CoreWindow::GetForCurrentThread()->Activate();
00125 }
00126
00127 IFrameworkView^ DirectXAppSource::CreateView()
00128 {
00129     return ref new DirectXApp();
00130 }
00131
00132 [Platform::MTAThread]
00133 int main(Platform::Array<Platform::String^>^)
00134 {
00135     auto directXAppSource = ref new DirectXAppSource();
00136     CoreApplication::Run(directXAppSource);
00137     return 0;
00138 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI offer and reclaim resources/C++/DirectXBase.h Source File

  • DXGI offer and reclaim resources

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/D2DPageRendererContext.cpp Source File

  • Direct2Dapp printing

D2DPageRendererContext.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include <math.h>
00010 #include "D2DPageRenderer.h"
00011 #include "D2DPageRendererContext.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Microsoft::WRL::Wrappers;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::UI::Core;
00017 using namespace Windows::Graphics::Display;
00018
00019 PageRendererContext::PageRendererContext(
00020     _In_ D2D1_RECT_F targetBox,
00021     _In_ ID2D1DeviceContext* d2dContext,
00022     _In_ DrawTypes type,
00023     _In_ PageRenderer^ pageRenderer
00024     )
00025 {
00026     m_margin = 96.0f;
00027
00028     m_d2dContext = d2dContext;
00029
00030     m_type = type;
00031
00032     UpdateTargetBox(targetBox);
00033
00034     DX::ThrowIfFailed(
00035         d2dContext->CreateSolidColorBrush(
00036             D2D1::ColorF(D2D1::ColorF::Black),
00037             &m_blackBrush
00038             )
00039         );
00040
00041     // Pull out all the immutable resources from the PageRenderer that we will need.
00042     m_textFormat = pageRenderer->GetTextFormatNoRef();
00043     m_messageFormat = pageRenderer->GetMessageFormatNoRef();
00044 }
00045
00046 void PageRendererContext::UpdateTargetBox(_In_ D2D1_RECT_F& targetBox)
00047 {
00048     m_targetBox = targetBox;
00049 }
00050
00051 // Draws the scene to a rendering device context or a printing device context.
00052 void PageRendererContext::Draw(_In_ float scale)
00053 {
00054     // Clear rendering background with CornflowerBlue and clear preview
00055     // background with white color. For the printing case (command list), it
00056     // is recommended not to clear because the surface is clean when created.
00057     if (m_type == DrawTypes::Rendering)
00058     {
00059         m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00060     }
00061     else if (m_type == DrawTypes::Preview)
00062     {
00063         m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::White));
00064     }
00065
00066     // We use scale matrix to shrink the text size and scale is only available
00067     // for preview.  For on-screen rendering or printing, scale is 1.f, that
00068     // is, the Identity is the transform matrix.
00069     m_d2dContext->SetTransform(D2D1::Matrix3x2F(1/scale, 0, 0, 1/scale, 0, 0));
00070
00071     D2D1_RECT_F textBox =
00072         D2D1::RectF(
00073             m_targetBox.left + m_margin,
00074             m_targetBox.top + m_margin,
00075             m_targetBox.right - m_margin,
00076             m_targetBox.bottom - m_margin
00077             );
00078
00079     const char16 textString[] = L"\
00080         Lorem ipsum dolor sit amet, consectetur adipisicing elit, \
00081 sed do eiusmod tempor incididunt ut labore et dolore magna aliqua. \
00082 Ut enim ad minim veniam, quis nostrud exercitation ullamco laboris \
00083 nisi ut aliquip ex ea commodo consequat. Duis aute irure dolor in \
00084 reprehenderit in voluptate velit esse cillum dolore eu fugiat nulla\
00085 pariatur. Excepteur sint occaecat cupidatat non proident, sunt in \
00086 culpa qui officia deserunt mollit anim id est laborum.";
00087
00088     m_d2dContext->DrawText(
00089         textString,
00090         ARRAYSIZE(textString) - 1,
00091         m_textFormat.Get(),
00092         textBox,
00093         m_blackBrush.Get()
00094         );
00095 }
00096
00097 // Draws a string to a rendering device context or a printing device context.
00098 void PageRendererContext::DrawMessage(_In_ Platform::String^ string)
00099 {
00100     // Clear rendering background with CornflowerBlue.
00101     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::CornflowerBlue));
00102
00103     m_d2dContext->DrawText(
00104         string->Data(),
00105         string->Length(),
00106         m_messageFormat.Get(),
00107         m_targetBox,
00108         m_blackBrush.Get()
00109         );
00110 }
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/MainPage.xaml.h Source File

  • DatagramSocket

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace DatagramSocketSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     [Windows::Foundation::Metadata::WebHostHidden]
00032     public ref class MainPageSizeChangedEventArgs sealed
00033     {
00034     public:
00035         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00036         {
00037             Windows::UI::ViewManagement::ApplicationViewState get()
00038             {
00039                 return viewState;
00040             }
00041
00042             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00043             {
00044                 viewState = value;
00045             }
00046         }
00047
00048     private:
00049         Windows::UI::ViewManagement::ApplicationViewState viewState;
00050     };
00051
00052     [Windows::Foundation::Metadata::WebHostHidden]
00053     public ref class MainPage sealed
00054     {
00055     public:
00056         MainPage();
00057
00058         property bool AutoSizeInputSectionWhenSnapped
00059         {
00060             bool get()
00061             {
00062                 return autoSizeInputSectionWhenSnapped;
00063             }
00064
00065             void set(bool value)
00066             {
00067                 autoSizeInputSectionWhenSnapped = value;
00068             }
00069         }
00070
00071         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00072
00073         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00074         void LoadScenario(Platform::String^ scenarioName);
00075         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00076         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00077
00078
00079     private:
00080         ~MainPage();
00081         void SetFeatureName(Platform::String^ strFeature);
00082         void PopulateScenarios();
00083         void InvalidateSize();
00084         void InvalidateViewState();
00085
00086         Platform::Collections::Vector<Object^>^ ScenarioList;
00087         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00088         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00089         bool autoSizeInputSectionWhenSnapped;
00090
00091     protected:
00092         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00093         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00094         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00095
00096     internal:
00097         static MainPage^ Current;
00098
00099     };
00100 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/common/suspensionmanager.cpp Source File

  • File picker contracts
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application resources and localization/C++/pch.cpp Source File

  • Application resources and localization

pch.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // pch.cpp
00003 // Include the standard header and generate the precompiled header.
00004 //
00005
00006 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/Scenario10.xaml.cpp Source File

  • CryptoWinRT

Scenario10.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario10.xaml.cpp
00013 // Implementation of the Scenario10 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario10.xaml.h"
00018
00019 using namespace SDKSample::CryptoWinRT;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::Foundation::Collections;
00025 using namespace Windows::Security::Cryptography;
00026 using namespace Windows::Security::Cryptography::Core;
00027 using namespace Windows::Security::Cryptography::DataProtection;
00028 using namespace Windows::Storage::Streams;
00029 using namespace Windows::UI::Xaml;
00030 using namespace Windows::UI::Xaml::Controls;
00031 using namespace Windows::UI::Xaml::Navigation;
00032
00033 Scenario10::Scenario10()
00034 {
00035     InitializeComponent();
00036 }
00037
00038 /// <summary>
00039 /// Invoked when this page is about to be displayed in a Frame.
00040 /// </summary>
00041 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00042 /// property is typically used to configure the page.</param>
00043 void Scenario10::OnNavigatedTo(NavigationEventArgs^ e)
00044 {
00045     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00046     // as NotifyUser()
00047     rootPage = MainPage::Current;
00048 }
00049
00050 void SDKSample::CryptoWinRT::Scenario10::RunSample_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00051 {
00052     Scenario10Text->Text = "";
00053     String^ descriptor = tbDescriptor->Text;
00054
00055     Scenario10Text->Text += "*** Sample Stream Data Protection for " + descriptor + " ***\n";
00056
00057     IBuffer^ data = CryptographicBuffer::GenerateRandom(10000);
00058
00059     DataProtectionProvider^ Provider = ref new DataProtectionProvider(descriptor);
00060     InMemoryRandomAccessStream^ originalData = ref new InMemoryRandomAccessStream();
00061
00062     //Populate the new memory stream
00063     IOutputStream^ outputStream = originalData->GetOutputStreamAt(0);
00064     DataWriter^ writer = ref new DataWriter(outputStream);
00065     writer->WriteBuffer(data);
00066
00067     task<unsigned int> (writer->StoreAsync()).then([=](task<unsigned int> resultTask)
00068     {
00069         Scenario10Text->Text += "    StoreAsync completed.\n";
00070         Scenario10Text->Text += "    Stored " + resultTask.get() + " bytes.\n";
00071
00072         task<bool>(writer->FlushAsync()).then([=](bool isFlushCompleted)
00073         {
00074             if (!isFlushCompleted)
00075             {
00076                 Scenario10Text->Text += "    FlushAsync failed!\n";
00077                 return;
00078             }
00079
00080             Scenario10Text->Text += "    FlushAsync completed.\n";
00081
00082             //open new memory stream for read
00083             IInputStream^ source = originalData->GetInputStreamAt(0);
00084
00085             //Open the output memory stream
00086             InMemoryRandomAccessStream^ protectedData = ref new InMemoryRandomAccessStream();
00087             IOutputStream^ dest = protectedData->GetOutputStreamAt(0);
00088
00089             //The streams are ready for input and output.  ProtectStreamAsync can now be called
00090             create_task(Provider->ProtectStreamAsync(source,dest)).then([=]()
00091             {
00092                 Scenario10Text->Text += "    ProtectStreamAsync completed.\n";
00093
00094                 task<bool>(dest->FlushAsync()).then([=](bool isFlush2Completed)
00095                 {
00096                     if (!isFlush2Completed)
00097                     {
00098                         Scenario10Text->Text += "    FlushAsync failed!\n";
00099                         return;
00100                     }
00101
00102                     Scenario10Text->Text += "    Protected output was successfully flushed.\n";
00103
00104                     //Verify the protected data does not match the original
00105                     DataReader^ reader1 = ref new DataReader(originalData->GetInputStreamAt(0));
00106                     DataReader^ reader2 = ref new DataReader(protectedData->GetInputStreamAt(0));
00107
00108                     task<unsigned int> loadSize1(reader1->LoadAsync((unsigned int)originalData->Size));
00109                     loadSize1.then([=](task<unsigned int> size1Task)
00110                     {
00111                         unsigned int size1 = size1Task.get();
00112                         task<unsigned int> loadSize2(reader2->LoadAsync((unsigned int)protectedData->Size));
00113                         loadSize2.then([=](task<unsigned int> size2Task)
00114                         {
00115                             unsigned int size2 = size2Task.get();
00116                             Scenario10Text->Text += "    Size of original stream:  " + originalData->Size + "\n";
00117                             Scenario10Text->Text += "    Size of protected stream:  " + protectedData->Size + "\n";
00118
00119                             //Check that the data was actually protected.
00120                             if (originalData->Size == protectedData->Size)
00121                             {
00122                                 IBuffer^ buff1 = reader1->ReadBuffer((unsigned int)originalData->Size);
00123                                 IBuffer^ buff2 = reader2->ReadBuffer((unsigned int)protectedData->Size);
00124                                 if (CryptographicBuffer::Compare(buff1, buff2))
00125                                 {
00126                                     Scenario10Text->Text += "ERROR:  ProtectStreamAsync returned unprotected data!\n";
00127                                     return;
00128                                 }
00129                             }
00130
00131                             Scenario10Text->Text += "    Stream Compare completed.  Streams did not match.\n";
00132
00133                             IInputStream^ source2 = protectedData->GetInputStreamAt(0);
00134
00135                             InMemoryRandomAccessStream^ unprotectedData = ref new InMemoryRandomAccessStream();
00136                             IOutputStream^ dest2 = unprotectedData->GetOutputStreamAt(0);
00137
00138                             // Unprotect
00139                             DataProtectionProvider^ Provider2 = ref new DataProtectionProvider();
00140                             create_task(Provider2->UnprotectStreamAsync(source2,dest2)).then([=]()
00141                             {
00142                                 Scenario10Text->Text += "    UnprotectStreamAsync completed.\n";
00143
00144                                 task<bool>(dest2->FlushAsync()).then([=](bool isFlush3Completed)
00145                                 {
00146                                     if (!isFlush3Completed)
00147                                     {
00148                                         Scenario10Text->Text += "    FlushAsync failed!\n";
00149                                         return;
00150                                     }
00151                                     Scenario10Text->Text += "    Unprotected output was successfully flushed\n";
00152
00153                                     //Verify the unprotected data does match the original
00154                                     DataReader^ reader3 = ref new DataReader(originalData->GetInputStreamAt(0));
00155                                     DataReader^ reader4 = ref new DataReader(unprotectedData->GetInputStreamAt(0));
00156
00157                                     task<unsigned int> loadSize3(reader3->LoadAsync((unsigned int)originalData->Size));
00158                                     loadSize3.then([=](task<unsigned int> size3Task)
00159                                     {
00160                                         unsigned int size3 = size3Task.get();
00161                                         task<unsigned int> loadSize4(reader4->LoadAsync((unsigned int)unprotectedData->Size));
00162                                         loadSize4.then([=](task<unsigned int> size4Task)
00163                                         {
00164                                             unsigned int size4 = size4Task.get();
00165                                             Scenario10Text->Text += "    Size of original stream:  " + originalData->Size + "\n";
00166                                             Scenario10Text->Text += "    Size of unprotected stream:  " + unprotectedData->Size + "\n";
00167
00168                                             if(size3 != size4)
00169                                             {
00170                                                 Scenario10Text->Text += "ERROR:  UnprotectStreamAsync did not return expected data!\n";
00171                                                 return;
00172                                             }
00173
00174                                             IBuffer^ buff3 = reader3->ReadBuffer((unsigned int)originalData->Size);
00175                                             IBuffer^ buff4 = reader4->ReadBuffer((unsigned int)unprotectedData->Size);
00176
00177                                             if (!CryptographicBuffer::Compare(buff3, buff4))
00178                                             {
00179                                                 Scenario10Text->Text += "ERROR:  UnprotectStreamAsync did not return expected data!\n";
00180                                                 return;
00181                                             }
00182
00183                                             Scenario10Text->Text += "    UnprotectStreamAsync completed successfully.\n";
00184                                             Scenario10Text->Text += "*** Done!\n";
00185                                         });
00186                                     });
00187                                 });
00188                             });
00189                         });
00190                     });
00191                 });
00192             });
00193         });
00194     });
00195 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2Dapp printing/C++/SampleOverlay.cpp Source File

  • Direct2Dapp printing

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/MainPage.xaml.h Source File

  • Secondary tiles
  • C#,C++

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SecondaryTiles
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     [Windows::Foundation::Metadata::WebHostHidden]
00052     public ref class MainPage sealed
00053     {
00054     public:
00055         MainPage();
00056
00057         property bool AutoSizeInputSectionWhenSnapped
00058         {
00059             bool get()
00060             {
00061                 return autoSizeInputSectionWhenSnapped;
00062             }
00063
00064             void set(bool value)
00065             {
00066                 autoSizeInputSectionWhenSnapped = value;
00067             }
00068         }
00069
00070         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00071
00072         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00073         void LoadScenario(Platform::String^ scenarioName);
00074         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00075         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00076         void NavigateToLaunchedFromSecondaryTile();
00077
00078     private:
00079          ~MainPage();
00080        void SetSecondaryTiles(Platform::String^ strFeature);
00081         void PopulateScenarios();
00082         void InvalidateSize();
00083         void InvalidateViewState();
00084
00085         Platform::Collections::Vector<Object^>^ scenarioList;
00086         Windows::UI::Xaml::Controls::Frame^ hiddenFrame;
00087         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00088         bool autoSizeInputSectionWhenSnapped;
00089
00090     protected:
00091         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00092         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00093         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00094         void MainPage_Loaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00095
00096     internal:
00097         static MainPage^ current;
00098     };
00099 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/App.xaml.h Source File

  • Gyrometer sensor

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: User domain name/C++/Constants.cpp Source File

  • User domain name

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Get Principal Name", "SDKSample.UserDomainName.GetPrincipalName" },
00022     { "Get DNS Domain Name", "SDKSample.UserDomainName.GetDomainName" },
00023     { "Get SIP Uri", "SDKSample.UserDomainName.GetSIPUri" }
00024 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Connecting with WebSockets/C++/pch.h Source File

  • Connecting with WebSockets

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File access/C++/Scenario1.xaml.cpp Source File

  • File access

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::FileAccess;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Navigation;
00027
00028 Scenario1::Scenario1()
00029 {
00030     InitializeComponent();
00031     rootPage = MainPage::Current;
00032     CreateFileButton->Click += ref new RoutedEventHandler(this, &Scenario1::CreateFileButton_Click);
00033 }
00034
00035 void Scenario1::CreateFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00036 {
00037     create_task(KnownFolders::DocumentsLibrary->CreateFileAsync(rootPage->Filename, CreationCollisionOption::ReplaceExisting)).then([this](StorageFile^ file)
00038     {
00039         rootPage->SampleFile = file;
00040         OutputTextBlock->Text = "The file '" + file->Name + "' was created.";
00041     });
00042 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

List< T >::Node Member List

This is the complete list of members for List< T >::Node, including all inherited members.
item | List< T >::Node |
Item() const | List< T >::Node | [inline]
Item() const | List< T >::Node | [inline]
Item() const | List< T >::Node | [inline]
next | List< T >::Node |
Node() | List< T >::Node | [inline]
Node(T item) | List< T >::Node | [inline]
Node() | List< T >::Node | [inline]
Node(T item) | List< T >::Node | [inline]
Node() | List< T >::Node | [inline]
Node(T item) | List< T >::Node | [inline]
prev | List< T >::Node |
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XInput audio controller playback/C++/MediaStreamer.h Source File

  • XInput audio controller playback

MediaStreamer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <roapi.h>
00011 #include <mmreg.h>
00012 #include <mfidl.h>
00013 #include <mfapi.h>
00014 #include <mfreadwrite.h>
00015
00016 class MediaStreamer
00017 {
00018 public:
00019     MediaStreamer(_In_ Platform::String^ url);
00020
00021     void Restart();
00022     std::vector<byte> ReadAll();
00023     std::vector<byte> GetNextBuffer();
00024
00025     const WAVEFORMATEX& GetOutputWaveFormatEx() const
00026     {
00027         return m_waveFormat;
00028     }
00029
00030     uint32 GetMaxStreamLengthInBytes() const
00031     {
00032         return m_maxStreamLengthInBytes;
00033     }
00034
00035 private:
00036     Microsoft::WRL::ComPtr<IMFSourceReader> m_reader;
00037     WAVEFORMATEX                            m_waveFormat;
00038     uint32                                  m_maxStreamLengthInBytes;
00039 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI contrast and settings/C++/common/LayoutAwarePage.cpp Source File

  • UI contrast and settings
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/AutoThrottle.cpp Source File

  • Direct3D sprite

AutoThrottle.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 // This class provides a lightweight throttle feedback mechanism for
00009 // variable frame workloads.  The class is initialized with a target
00010 // frame time and a "history" represented as bits in an unsigned int.
00011 // A 1 bit represents a frame that missed its target frame time.
00012 // If the past N frames, corresponding to the maskDecrease/maskIncrease
00013 // values, have all been missed or made, then the update method will
00014 // return a control recommendation to Decrease or Increase the frame
00015 // workload, respectively.  The initial value for the frame history
00016 // is chosen such that the returned control recommendation is to maintain
00017 // frame workload until the history is primed with accurate values.
00018
00019 #include "pch.h"
00020 #include "AutoThrottle.h"
00021
00022 AutoThrottle::AutoThrottle(float targetFrameTime) :
00023     m_missedFrameHistory(0xCCCCCCCC),
00024     m_targetFrameTime(targetFrameTime)
00025 {
00026 }
00027
00028 FrameWorkload AutoThrottle::Update(float frameTime)
00029 {
00030     static const float epsilon = 0.005f; // Compensation for noise in the frameTime value.
00031     static const unsigned int maskIncrease = 0x0000001F; // Require 5 made frames to increase workload.
00032     static const unsigned int maskDecrease = 0x00000003; // Require 2 missed frames to decrease workload.
00033
00034     // Shift history back by one frame.  The LSB represents the most recent frame.
00035     m_missedFrameHistory <<= 1;
00036
00037     if (frameTime > m_targetFrameTime - epsilon)
00038     {
00039         m_missedFrameHistory |= 1;
00040     }
00041
00042     if ((m_missedFrameHistory & maskIncrease) == 0)
00043     {
00044         return FrameWorkload::Increase;
00045     }
00046     if ((m_missedFrameHistory & maskDecrease) == maskDecrease)
00047     {
00048         return FrameWorkload::Decrease;
00049     }
00050
00051     return FrameWorkload::Maintain;
00052 }
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DirectXApp.h Source File

  • Direct2D printing images and effects

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009 #include "DocSource.h"
00010 #include "D2DPageRenderer.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Declare Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032     void OnVisibilityChanged(
00033         _In_ Windows::UI::Core::CoreWindow^ sender,
00034         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00035         );
00036
00037     void OnLogicalDpiChanged(_In_ Platform::Object^ sender);
00038
00039     void OnActivated(
00040         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00041         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00042         );
00043
00044     void OnSuspending(
00045         _In_ Platform::Object^ sender,
00046         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00047         );
00048
00049     void OnResuming(
00050         _In_ Platform::Object^ sender,
00051         _In_ Platform::Object^ args
00052         );
00053
00054     void OnWindowClosed(
00055         _In_ Windows::UI::Core::CoreWindow^ sender,
00056         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00057         );
00058
00059     void InitPrintManager();
00060
00061     void SetPrintTask(
00062         _In_ Windows::Graphics::Printing::PrintManager^ sender,
00063         _In_ Windows::Graphics::Printing::PrintTaskRequestedEventArgs^ args
00064         );
00065
00066     PageRenderer^                                            m_renderer;
00067     Windows::Graphics::Printing::PrintManager^               m_printManager;
00068     bool                                                     m_windowClosed;
00069     bool                                                     m_windowVisible;
00070 };
00071
00072 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00073 {
00074 public:
00075     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00076 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/SphereMesh.cpp Source File

  • DirectX 3D shooting game

SphereMesh.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SphereMesh.h"
00010 #include "DirectXSample.h"
00011 #include "ConstantBuffers.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace DirectX;
00015
00016 SphereMesh::SphereMesh(_In_ ID3D11Device *device, uint32 segments)
00017 {
00018     D3D11_BUFFER_DESC bd = {0};
00019     D3D11_SUBRESOURCE_DATA initData = {0};
00020
00021     uint32 slices = segments / 2;
00022     uint32 numVertices = (slices + 1) * (segments + 1) + 1;
00023     uint32 numIndices = slices * segments * 3 * 2;
00024
00025     std::vector<PNTVertex> point(numVertices);
00026     std::vector<uint16> index(numIndices);
00027
00028     // To make the texture look right on the top and bottom of the sphere
00029     // each slice will have 'segments + 1' vertices.  The top and bottom
00030     // vertices will all be coincident, but have different U texture cooordinates.
00031     uint32 p = 0;
00032     for (uint32 a = 0; a <= slices; a++)
00033     {
00034         float angle1 = static_cast<float>(a) / static_cast<float>(slices) * XM_PI;
00035         float z = cos(angle1);
00036         float r = sin(angle1);
00037         for (uint32 b = 0; b <= segments; b++)
00038         {
00039             float angle2 = static_cast<float>(b) / static_cast<float>(segments) * XM_2PI;
00040             point[p].position = XMFLOAT3(r * cos(angle2), r * sin(angle2), z);
00041             point[p].normal = point[p].position;
00042             point[p].textureCoordinate = XMFLOAT2((1.0f-z) / 2.0f, static_cast<float>(b) / static_cast<float>(segments));
00043             p++;
00044         }
00045     }
00046     m_vertexCount = p;
00047
00048     p = 0;
00049     for (uint16 a = 0; a < slices; a++)
00050     {
00051         uint16 p1 = a * (segments + 1);
00052         uint16 p2 = (a + 1) * (segments + 1);
00053
00054         // Generate two triangles for each segment around the slice.
00055         for (uint16 b = 0; b < segments; b++)
00056         {
00057             if (a < (slices - 1))
00058             {
00059                 // For all but the bottom slice add the triangle with one
00060                 // vertex in the a slice and two vertices in the a + 1 slice.
00061                 // Skip it for the bottom slice since the triangle would be
00062                 // degenerate as all the vertices in the bottom slice are coincident.
00063                 index[p] = b + p1;
00064                 index[p+1] = b + p2;
00065                 index[p+2] = b + p2 + 1;
00066                 p = p + 3;
00067             }
00068             if (a > 0)
00069             {
00070                 // For all but the top slice add the triangle with two
00071                 // vertices in the a slice and one vertex in the a + 1 slice.
00072                 // Skip it for the top slice since the triangle would be
00073                 // degenerate as all the vertices in the top slice are coincident.
00074                 index[p] = b + p1;
00075                 index[p+1] = b + p2 + 1;
00076                 index[p+2] = b + p1 + 1;
00077                 p = p + 3;
00078             }
00079         }
00080     }
00081     m_indexCount = p;
00082
00083     bd.Usage = D3D11_USAGE_DEFAULT;
00084     bd.ByteWidth = sizeof(PNTVertex) * m_vertexCount;
00085     bd.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00086     bd.CPUAccessFlags = 0;
00087     initData.pSysMem = point.data();
00088     DX::ThrowIfFailed(
00089         device->CreateBuffer(&bd, &initData, &m_vertexBuffer)
00090         );
00091
00092     bd.Usage = D3D11_USAGE_DEFAULT;
00093     bd.ByteWidth = sizeof(uint16) * m_indexCount;
00094     bd.BindFlags = D3D11_BIND_INDEX_BUFFER;
00095     bd.CPUAccessFlags = 0;
00096     initData.pSysMem = index.data();
00097     DX::ThrowIfFailed(
00098         device->CreateBuffer(&bd, &initData, &m_indexBuffer)
00099         );
00100 }
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C++/MediaExtensions/Common/LinkList.h Source File

  • Real-time communication
  • MediaExtensions
  • Common

LinkList.h

Go to the documentation of this file.
00001 //-----------------------------------------------------------------------------
00002 // File: Linklist.h
00003 // Desc: Linked list class.
00004 //
00005 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00006 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00007 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00008 // PARTICULAR PURPOSE.
00009 //
00010 //  Copyright (C) Microsoft Corporation. All rights reserved.
00011 //-----------------------------------------------------------------------------
00012
00013 #pragma once
00014
00015 // Notes:
00016 //
00017 // The List class template implements a simple double-linked list.
00018 // It uses STL's copy semantics.
00019
00020 // There are two versions of the Clear() method:
00021 //  Clear(void) clears the list w/out cleaning up the object.
00022 //  Clear(FN fn) takes a functor object that releases the objects, if they need cleanup.
00023
00024 // The List class supports enumeration. Example of usage:
00025 //
00026 // List<T>::POSIITON pos = list.GetFrontPosition();
00027 // while (pos != list.GetEndPosition())
00028 // {
00029 //     T item;
00030 //     hr = list.GetItemPos(&item);
00031 //     pos = list.Next(pos);
00032 // }
00033
00034 // The ComPtrList class template derives from List<> and implements a list of COM pointers.
00035
00036 template <class T>
00037 struct NoOp
00038 {
00039     void operator()(T& t)
00040     {
00041     }
00042 };
00043
00044 template <class T>
00045 class List
00046 {
00047 protected:
00048
00049     // Nodes in the linked list
00050     struct Node
00051     {
00052         Node *prev;
00053         Node *next;
00054         T    item;
00055
00056         Node() : prev(nullptr), next(nullptr)
00057         {
00058         }
00059
00060         Node(T item) : prev(nullptr), next(nullptr)
00061         {
00062             this->item = item;
00063         }
00064
00065         T Item() const { return item; }
00066     };
00067
00068 public:
00069
00070     // Object for enumerating the list.
00071     class POSITION
00072     {
00073         friend class List<T>;
00074
00075     public:
00076         POSITION() : pNode(nullptr)
00077         {
00078         }
00079
00080         bool operator==(const POSITION &p) const
00081         {
00082             return pNode == p.pNode;
00083         }
00084
00085         bool operator!=(const POSITION &p) const
00086         {
00087             return pNode != p.pNode;
00088         }
00089
00090     private:
00091         const Node *pNode;
00092
00093         POSITION(Node *p) : pNode(p)
00094         {
00095         }
00096     };
00097
00098 protected:
00099     Node    m_anchor;  // Anchor node for the linked list.
00100     DWORD   m_count;   // Number of items in the list.
00101
00102     Node* Front() const
00103     {
00104         return m_anchor.next;
00105     }
00106
00107     Node* Back() const
00108     {
00109         return m_anchor.prev;
00110     }
00111
00112     virtual HRESULT InsertAfter(T item, Node *pBefore)
00113     {
00114         if (pBefore == nullptr)
00115         {
00116             return E_POINTER;
00117         }
00118
00119         Node *pNode = new Node(item);
00120         if (pNode == nullptr)
00121         {
00122             return E_OUTOFMEMORY;
00123         }
00124
00125         Node *pAfter = pBefore->next;
00126
00127         pBefore->next = pNode;
00128         pAfter->prev = pNode;
00129
00130         pNode->prev = pBefore;
00131         pNode->next = pAfter;
00132
00133         m_count++;
00134
00135         return S_OK;
00136     }
00137
00138     virtual HRESULT GetItem(const Node *pNode, T* ppItem)
00139     {
00140         if (pNode == nullptr || ppItem == nullptr)
00141         {
00142             return E_POINTER;
00143         }
00144
00145         *ppItem = pNode->item;
00146         return S_OK;
00147     }
00148
00149     // RemoveItem:
00150     // Removes a node and optionally returns the item.
00151     // ppItem can be nullptr.
00152     virtual HRESULT RemoveItem(Node *pNode, T *ppItem)
00153     {
00154         if (pNode == nullptr)
00155         {
00156             return E_POINTER;
00157         }
00158
00159         assert(pNode != &m_anchor); // We should never try to remove the anchor node.
00160         if (pNode == &m_anchor)
00161         {
00162             return E_INVALIDARG;
00163         }
00164
00165
00166         T item;
00167
00168         // The next node's previous is this node's previous.
00169         pNode->next->prev = pNode->prev;
00170
00171         // The previous node's next is this node's next.
00172         pNode->prev->next = pNode->next;
00173
00174         item = pNode->item;
00175         delete pNode;
00176
00177         m_count--;
00178
00179         if (ppItem)
00180         {
00181             *ppItem = item;
00182         }
00183
00184         return S_OK;
00185     }
00186
00187 public:
00188
00189     List()
00190     {
00191         m_anchor.next = &m_anchor;
00192         m_anchor.prev = &m_anchor;
00193
00194         m_count = 0;
00195     }
00196
00197     virtual ~List()
00198     {
00199         Clear();
00200     }
00201
00202     // Insertion functions
00203     HRESULT InsertBack(T item)
00204     {
00205         return InsertAfter(item, m_anchor.prev);
00206     }
00207
00208
00209     HRESULT InsertFront(T item)
00210     {
00211         return InsertAfter(item, &m_anchor);
00212     }
00213
00214     HRESULT InsertPos(POSITION pos, T item)
00215     {
00216         if (pos.pNode == nullptr)
00217         {
00218             return InsertBack(item);
00219         }
00220
00221         return InsertAfter(item, pos.pNode->prev);
00222     }
00223
00224     // RemoveBack: Removes the tail of the list and returns the value.
00225     // ppItem can be nullptr if you don't want the item back. (But the method does not release the item.)
00226     HRESULT RemoveBack(T *ppItem)
00227     {
00228         if (IsEmpty())
00229         {
00230             return E_FAIL;
00231         }
00232         else
00233         {
00234             return RemoveItem(Back(), ppItem);
00235         }
00236     }
00237
00238     // RemoveFront: Removes the head of the list and returns the value.
00239     // ppItem can be nullptr if you don't want the item back. (But the method does not release the item.)
00240     HRESULT RemoveFront(T *ppItem)
00241     {
00242         if (IsEmpty())
00243         {
00244             return E_FAIL;
00245         }
00246         else
00247         {
00248             return RemoveItem(Front(), ppItem);
00249         }
00250     }
00251
00252     // GetBack: Gets the tail item.
00253     HRESULT GetBack(T *ppItem)
00254     {
00255         if (IsEmpty())
00256         {
00257             return E_FAIL;
00258         }
00259         else
00260         {
00261             return GetItem(Back(), ppItem);
00262         }
00263     }
00264
00265     // GetFront: Gets the front item.
00266     HRESULT GetFront(T *ppItem)
00267     {
00268         if (IsEmpty())
00269         {
00270             return E_FAIL;
00271         }
00272         else
00273         {
00274             return GetItem(Front(), ppItem);
00275         }
00276     }
00277
00278
00279     // GetCount: Returns the number of items in the list.
00280     DWORD GetCount() const { return m_count; }
00281
00282     bool IsEmpty() const
00283     {
00284         return (GetCount() == 0);
00285     }
00286
00287     // Clear: Takes a functor object whose operator()
00288     // frees the object on the list.
00289     template <class FN>
00290     void Clear(FN& clear_fn)
00291     {
00292         Node *n = m_anchor.next;
00293
00294         // Delete the nodes
00295         while (n != &m_anchor)
00296         {
00297             clear_fn(n->item);
00298
00299             Node *tmp = n->next;
00300             delete n;
00301             n = tmp;
00302         }
00303
00304         // Reset the anchor to point at itself
00305         m_anchor.next = &m_anchor;
00306         m_anchor.prev = &m_anchor;
00307
00308         m_count = 0;
00309     }
00310
00311     // Clear: Clears the list. (Does not delete or release the list items.)
00312     virtual void Clear()
00313     {
00314         NoOp<T> clearOp;
00315         Clear<>(clearOp);
00316     }
00317
00318
00319     // Enumerator functions
00320
00321     POSITION FrontPosition()
00322     {
00323         if (IsEmpty())
00324         {
00325             return POSITION(nullptr);
00326         }
00327         else
00328         {
00329             return POSITION(Front());
00330         }
00331     }
00332
00333     POSITION EndPosition() const
00334     {
00335         return POSITION();
00336     }
00337
00338     HRESULT GetItemPos(POSITION pos, T *ppItem)
00339     {
00340         if (pos.pNode)
00341         {
00342             return GetItem(pos.pNode, ppItem);
00343         }
00344         else
00345         {
00346             return E_FAIL;
00347         }
00348     }
00349
00350     POSITION Next(const POSITION pos)
00351     {
00352         if (pos.pNode && (pos.pNode->next != &m_anchor))
00353         {
00354             return POSITION(pos.pNode->next);
00355         }
00356         else
00357         {
00358             return POSITION(nullptr);
00359         }
00360     }
00361
00362     // Remove an item at a position.
00363     // The item is returns in ppItem, unless ppItem is nullptr.
00364     // NOTE: This method invalidates the POSITION object.
00365     HRESULT Remove(POSITION& pos, T *ppItem)
00366     {
00367         if (pos.pNode)
00368         {
00369             // Remove const-ness temporarily...
00370             Node *pNode = const_cast<Node*>(pos.pNode);
00371
00372             pos = POSITION();
00373
00374             return RemoveItem(pNode, ppItem);
00375         }
00376         else
00377         {
00378             return E_INVALIDARG;
00379         }
00380     }
00381
00382 };
00383
00384
00385
00386 // Typical functors for Clear method.
00387
00388 // ComAutoRelease: Releases COM pointers.
00389 // MemDelete: Deletes pointers to new'd memory.
00390
00391 class ComAutoRelease
00392 {
00393 public:
00394     void operator()(IUnknown *p)
00395     {
00396         if (p)
00397         {
00398             p->Release();
00399         }
00400     }
00401 };
00402
00403 class MemDelete
00404 {
00405 public:
00406     void operator()(void *p)
00407     {
00408         if (p)
00409         {
00410             delete p;
00411         }
00412     }
00413 };
00414
00415
00416 // ComPtrList class
00417 // Derived class that makes it safer to store COM pointers in the List<> class.
00418 // It automatically AddRef's the pointers that are inserted onto the list
00419 // (unless the insertion method fails).
00420 //
00421 // T must be a COM interface type.
00422 // example: ComPtrList<IUnknown>
00423 //
00424 // NULLABLE: If true, client can insert nullptr pointers. This means GetItem can
00425 // succeed but return a nullptr pointer. By default, the list does not allow nullptr
00426 // pointers.
00427
00428 template <class T, bool NULLABLE = FALSE>
00429 class ComPtrList : public List<T*>
00430 {
00431 public:
00432
00433     typedef T* Ptr;
00434
00435     void Clear()
00436     {
00437         ComAutoRelease car;
00438         List<Ptr>::Clear(car);
00439     }
00440
00441     ~ComPtrList()
00442     {
00443         Clear();
00444     }
00445
00446 protected:
00447     HRESULT InsertAfter(Ptr item, Node *pBefore)
00448     {
00449         // Do not allow nullptr item pointers unless NULLABLE is true.
00450         if (item == nullptr && !NULLABLE)
00451         {
00452             return E_POINTER;
00453         }
00454
00455         if (item)
00456         {
00457             item->AddRef();
00458         }
00459
00460         HRESULT hr = List<Ptr>::InsertAfter(item, pBefore);
00461         if (FAILED(hr) && item != nullptr)
00462         {
00463             item->Release();
00464         }
00465         return hr;
00466     }
00467
00468     HRESULT GetItem(const Node *pNode, Ptr* ppItem)
00469     {
00470         Ptr pItem = nullptr;
00471
00472         // The base class gives us the pointer without AddRef'ing it.
00473         // If we return the pointer to the caller, we must AddRef().
00474         HRESULT hr = List<Ptr>::GetItem(pNode, &pItem);
00475         if (SUCCEEDED(hr))
00476         {
00477             assert(pItem || NULLABLE);
00478             if (pItem)
00479             {
00480                 *ppItem = pItem;
00481                 (*ppItem)->AddRef();
00482             }
00483         }
00484         return hr;
00485     }
00486
00487     HRESULT RemoveItem(Node *pNode, Ptr *ppItem)
00488     {
00489         // ppItem can be nullptr, but we need to get the
00490         // item so that we can release it.
00491
00492         // If ppItem is not nullptr, we will AddRef it on the way out.
00493
00494         Ptr pItem = nullptr;
00495
00496         HRESULT hr = List<Ptr>::RemoveItem(pNode, &pItem);
00497
00498         if (SUCCEEDED(hr))
00499         {
00500             assert(pItem || NULLABLE);
00501             if (ppItem && pItem)
00502             {
00503                 *ppItem = pItem;
00504                 (*ppItem)->AddRef();
00505             }
00506
00507             if (pItem)
00508             {
00509                 pItem->Release();
00510                 pItem = nullptr;
00511             }
00512         }
00513
00514         return hr;
00515     }
00516 };
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWidePeekImage06 Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWidePeekImage06, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
ImageMain | NotificationsExtensions::TileContent::TileWidePeekImage06 |
Images | NotificationsExtensions::NotificationBase |
ImageSecondary | NotificationsExtensions::TileContent::TileWidePeekImage06 |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextFields | NotificationsExtensions::NotificationBase |
TextHeadingWrap | NotificationsExtensions::TileContent::TileWidePeekImage06 |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWidePeekImage06() | NotificationsExtensions::TileContent::TileWidePeekImage06 | [inline]
TileWidePeekImage06() | NotificationsExtensions::TileContent::TileWidePeekImage06 | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML scrolling, panning, and zooming/C++/Scenario2.xaml.h Source File

  • XAML scrolling, panning, and zooming

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ScrollViewerCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         void ComboBox_SelectionChanged_1(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00040         void Scenario2Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         void Scenario2Reset();
00042       };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/Constants.h Source File

  • Gyrometer sensor

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Gyrometer Sensor Raw Data");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/pch.h Source File

  • StorageDataSource and GetVirtualizedFilesVector

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/BackgroundTask/pch.cpp Source File

  • Background task
  • BackgroundTask

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::PackageSample::sealed Member List

This is the complete list of members for SDKSample::PackageSample::sealed, including all inherited members.
ArchitectureString(Windows::System::ProcessorArchitecture architecture) | SDKSample::PackageSample::sealed | [private]
GetDependencies_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PackageSample::sealed | [private]
GetInstalledLocation_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PackageSample::sealed | [private]
GetPackage_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::PackageSample::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PackageSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PackageSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::PackageSample::sealed | [protected, virtual]
rootPage | SDKSample::PackageSample::sealed | [private]
Scenario1() | SDKSample::PackageSample::sealed |
Scenario2() | SDKSample::PackageSample::sealed |
Scenario3() | SDKSample::PackageSample::sealed |
VersionString(Windows::ApplicationModel::PackageVersion version) | SDKSample::PackageSample::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/common/LayoutAwarePage.h Source File

  • USSD message management
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Context menu/C++/Scenario1.xaml.h Source File

  • Context menu

Scenario1.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ContextMenu
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario1 sealed
00030         {
00031         public:
00032             Scenario1();
00033
00034         private:
00035             MainPage^ rootPage;
00036
00037             void AttachmentImage_RightTapped(Platform::Object^ sender, Windows::UI::Xaml::Input::RightTappedRoutedEventArgs^ e);
00038             Windows::Foundation::Rect Scenario1::GetElementRect(Windows::UI::Xaml::FrameworkElement^ element);
00039         };
00040     }
00041 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch hit testing/C++/DirectXBase.cpp Source File

  • Input Touch hit testing

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Globalization preferences/C++/CurrentInputLanguage.xaml.cpp Source File

  • Globalization preferences

CurrentInputLanguage.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CurrentInputLanguage.xaml.cpp
00013 // Implementation of the CurrentInputLanguage class
00014 //
00015
00016 #include "pch.h"
00017 #include "CurrentInputLanguage.xaml.h"
00018
00019 using namespace SDKSample::GlobalizationPreferencesSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::Foundation::Collections;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Navigation;
00027 using namespace Windows::System::UserProfile;
00028 using namespace Windows::Globalization;
00029
00030 CurrentInputLanguage::CurrentInputLanguage()
00031 {
00032     InitializeComponent();
00033 }
00034
00035 /// <summary>
00036 /// Invoked when this page is about to be displayed in a Frame.
00037 /// </summary>
00038 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00039 /// property is typically used to configure the page.</param>
00040 void CurrentInputLanguage::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00043     // as NotifyUser()
00044     rootPage = MainPage::Current;
00045 }
00046
00047 void CurrentInputLanguage::Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049     // This scenario uses the Windows.Globalization.Language class to obtain the user's current
00050     // input language.  The language tag returned reflects the current input language specified
00051     // by the user.
00052
00053     // Get the user's input language
00054     String^ userInputLanguage = Windows::Globalization::Language::CurrentInputMethodLanguageTag;
00055
00056     // Generate the results
00057     String^ results = "User's current input language: " + userInputLanguage;
00058
00059     // Display the results
00060     rootPage->NotifyUser(results, NotifyType::StatusMessage);
00061 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/ExpiringProduct.xaml.cpp Source File

  • Trial app and in-app purchase

ExpiringProduct.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ExpiringProduct.xaml.cpp
00013 // Implementation of the ExpiringProduct class
00014 //
00015
00016 #include "pch.h"
00017 #include "ExpiringProduct.xaml.h"
00018
00019 using namespace SDKSample::StoreSample;
00020
00021 using namespace concurrency;
00022 using namespace Windows::ApplicationModel;
00023 using namespace Windows::ApplicationModel::Store;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Globalization;
00026 using namespace Windows::Storage;
00027 using namespace Windows::UI::Xaml;
00028 using namespace Windows::UI::Xaml::Controls;
00029 using namespace Windows::UI::Xaml::Navigation;
00030
00031 ExpiringProduct::ExpiringProduct()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void ExpiringProduct::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046     LoadExpiringProductProxyFile();
00047 }
00048
00049 void ExpiringProduct::OnNavigatingFrom(Windows::UI::Xaml::Navigation::NavigatingCancelEventArgs^ e)
00050 {
00051     CurrentAppSimulator::LicenseInformation->LicenseChanged -= eventRegistrationToken;
00052 }
00053
00054 void ExpiringProduct::LoadExpiringProductProxyFile()
00055 {
00056     create_task(Package::Current->InstalledLocation->GetFolderAsync("data")).then([this](StorageFolder^ proxyDataFolder)
00057     {
00058         create_task(proxyDataFolder->GetFileAsync("expiring-product.xml")).then([this](StorageFile^ proxyFile)
00059         {
00060             eventRegistrationToken = (CurrentAppSimulator::LicenseInformation->LicenseChanged += ref new LicenseChangedEventHandler(this, &ExpiringProduct::ExpiringProductRefreshScenario));
00061             create_task(CurrentAppSimulator::ReloadSimulatorAsync(proxyFile)).then([this]()
00062             {
00063             });
00064         });
00065     });
00066 }
00067
00068 void ExpiringProduct::ExpiringProductRefreshScenario()
00069 {
00070     auto licenseInformation = CurrentAppSimulator::LicenseInformation;
00071     if (licenseInformation->IsActive)
00072     {
00073         if (licenseInformation->IsTrial)
00074         {
00075             rootPage->NotifyUser("You don't have full license", NotifyType::ErrorMessage);
00076         }
00077         else
00078         {
00079             auto productLicense1 = licenseInformation->ProductLicenses->Lookup("product1");
00080             if (productLicense1->IsActive)
00081             {
00082                 auto longdateTemplate = ref new DateTimeFormatting::DateTimeFormatter("longdate");
00083                 Product1Message->Text = "Product 1 expires on: " + longdateTemplate->Format(productLicense1->ExpirationDate);
00084
00085                 auto calendarObj = ref new Calendar();
00086                 calendarObj->SetToNow();
00087                 auto currentDateTime = calendarObj->GetDateTime();
00088                 auto numberOfRemainingDays = (productLicense1->ExpirationDate.UniversalTime - currentDateTime.UniversalTime) / 864000000000;
00089                 rootPage->NotifyUser("Product 1 expires in: " + numberOfRemainingDays + " days.", NotifyType::StatusMessage);
00090             }
00091             else
00092             {
00093                 rootPage->NotifyUser("Product 1 is not available.", NotifyType::ErrorMessage);
00094             }
00095         }
00096     }
00097     else
00098     {
00099         rootPage->NotifyUser("You don't have active license.", NotifyType::ErrorMessage);
00100     }
00101 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

MPEG1VideoSeqHeader Member List

This is the complete list of members for MPEG1VideoSeqHeader, including all inherited members.
bConstrained | MPEG1VideoSeqHeader
bitRate | MPEG1VideoSeqHeader
cbHeader | MPEG1VideoSeqHeader
cbVBV_Buffer | MPEG1VideoSeqHeader
frameRate | MPEG1VideoSeqHeader
header | MPEG1VideoSeqHeader
height | MPEG1VideoSeqHeader
pixelAspectRatio | MPEG1VideoSeqHeader
width | MPEG1VideoSeqHeader
Generated on Sat Nov 23 2024 16:09:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AntSystem::Ant Member List

This is the complete list of members for AntSystem::Ant, including all inherited members.
Ant(const vector< shared_ptr< Node >> &nodes, vector< shared_ptr< Edge >> &edges, const size_t initialNodeIndex, double heuristicShortestDistance, double alpha, double beta) | AntSystem::Ant | [inline, explicit]
Backtrack() | AntSystem::Ant |
Explore() | AntSystem::Ant |
GetTour(vector< size_t > &tour, double &tourLength) const | AntSystem::Ant | [inline]
m_alpha | AntSystem::Ant | [private]
m_beta | AntSystem::Ant | [private]
m_edges | AntSystem::Ant | [private]
m_heuristicShortestDistance | AntSystem::Ant | [private]
m_initialNodeIndex | AntSystem::Ant | [private]
m_lengthOfPath | AntSystem::Ant | [private]
m_nodes | AntSystem::Ant | [private]
m_route | AntSystem::Ant | [private]
MoveNext(size_t currentNodeIndex) | AntSystem::Ant | [private]
operator=(Ant const &) | AntSystem::Ant | [private]
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/common/LayoutAwarePage.cpp Source File

  • Playback Manager Companion
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:32 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D resource loading/C++/texconv/DirectXTex.h Source File

  • Direct3D resource loading
  • texconv

DirectXTex.h

Go to the documentation of this file.
00001 //-------------------------------------------------------------------------------------
00002 // DirectXTex.h
00003 //
00004 // DirectX Texture Library
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 // http://go.microsoft.com/fwlink/?LinkId=248926
00014 //-------------------------------------------------------------------------------------
00015
00016 #if defined(_MSC_VER) && (_MSC_VER > 1000)
00017 #pragma once
00018 #endif
00019
00020 #pragma warning(push)
00021 #pragma warning(disable : 4005)
00022 #include <stdint.h>
00023 #pragma warning(pop)
00024
00025 #include <algorithm>
00026
00027 #include <dxgiformat.h>
00028 #include <d3d11.h>
00029
00030 #define DIRECTX_TEX_VERSION 100
00031
00032 namespace DirectX
00033 {
00034
00035     //---------------------------------------------------------------------------------
00036     // DXGI Format Utilities
00037     bool IsValid( _In_ DXGI_FORMAT fmt );
00038     bool IsCompressed( _In_ DXGI_FORMAT fmt );
00039     bool IsPacked( _In_ DXGI_FORMAT fmt );
00040     bool IsVideo( _In_ DXGI_FORMAT fmt );
00041     bool IsSRGB( _In_ DXGI_FORMAT fmt );
00042     bool IsTypeless( _In_ DXGI_FORMAT fmt );
00043
00044     size_t BitsPerPixel( _In_ DXGI_FORMAT fmt );
00045
00046     enum CP_FLAGS
00047     {
00048         CP_FLAGS_NONE               = 0x0,      // Normal operation
00049         CP_FLAGS_LEGACY_DWORD       = 0x1,      // Assume pitch is DWORD aligned instead of BYTE aligned
00050         CP_FLAGS_24BPP              = 0x10000,  // Override with a legacy 24 bits-per-pixel format size
00051         CP_FLAGS_16BPP              = 0x20000,  // Override with a legacy 16 bits-per-pixel format size
00052         CP_FLAGS_8BPP               = 0x40000,  // Override with a legacy 8 bits-per-pixel format size
00053     };
00054
00055     void ComputePitch( _In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height,
00056                        _Out_ size_t& rowPitch, _Out_ size_t& slicePitch, _In_ DWORD flags = CP_FLAGS_NONE );
00057
00058     size_t ComputeScanlines( _In_ DXGI_FORMAT fmt, _In_ size_t height );
00059
00060     DXGI_FORMAT MakeSRGB( _In_ DXGI_FORMAT fmt );
00061
00062     //---------------------------------------------------------------------------------
00063     // Texture metadata
00064     enum TEX_DIMENSION
00065         // Subset here matches D3D10_RESOURCE_DIMENSION and D3D11_RESOURCE_DIMENSION
00066     {
00067         TEX_DIMENSION_TEXTURE1D = 2,
00068         TEX_DIMENSION_TEXTURE2D = 3,
00069         TEX_DIMENSION_TEXTURE3D = 4,
00070     };
00071
00072     enum TEX_MISC_FLAG
00073         // Subset here matches D3D10_RESOURCE_MISC_FLAG and D3D11_RESOURCE_MISC_FLAG
00074     {
00075         TEX_MISC_TEXTURECUBE = 0x4L,
00076     };
00077
00078     struct TexMetadata
00079     {
00080         size_t          width;
00081         size_t          height;     // Should be 1 for 1D textures
00082         size_t          depth;      // Should be 1 for 1D or 2D textures
00083         size_t          arraySize;  // For cubemap, this is a multiple of 6
00084         size_t          mipLevels;
00085         uint32_t        miscFlags;
00086         DXGI_FORMAT     format;
00087         TEX_DIMENSION   dimension;
00088
00089         size_t ComputeIndex( _In_ size_t mip, _In_ size_t item, _In_ size_t slice ) const;
00090             // Returns size_t(-1) to indicate an out-of-range error
00091     };
00092
00093     enum DDS_FLAGS
00094     {
00095         DDS_FLAGS_NONE                  = 0x0,
00096
00097         DDS_FLAGS_LEGACY_DWORD          = 0x1,
00098             // Assume pitch is DWORD aligned instead of BYTE aligned (used by some legacy DDS files)
00099
00100         DDS_FLAGS_NO_LEGACY_EXPANSION   = 0x2,
00101             // Do not implicitly convert legacy formats that result in larger pixel sizes (24 bpp, 3:3:2, A8L8, A4L4, P8, A8P8)
00102
00103         DDS_FLAGS_NO_R10B10G10A2_FIXUP  = 0x4,
00104             // Do not use work-around for long-standing D3DX DDS file format issue which reversed the 10:10:10:2 color order masks
00105
00106         DDS_FLAGS_FORCE_RGB             = 0x8,
00107             // Convert DXGI 1.1 BGR formats to DXGI_FORMAT_R8G8B8A8_UNORM to avoid use of optional WDDM 1.1 formats
00108
00109         DDS_FLAGS_NO_16BPP              = 0x10,
00110             // Conversions avoid use of 565, 5551, and 4444 formats and instead expand to 8888 to avoid use of optional WDDM 1.2 formats
00111
00112         DDS_FLAGS_FORCE_DX10_EXT        = 0x10000,
00113             // Always use the 'DX10' header extension for DDS writer (i.e. don't try to write DX9 compatible DDS files)
00114     };
00115
00116     enum WIC_FLAGS
00117     {
00118         WIC_FLAGS_NONE                  = 0x0,
00119
00120         WIC_FLAGS_FORCE_RGB             = 0x1,
00121             // Loads DXGI 1.1 BGR formats as DXGI_FORMAT_R8G8B8A8_UNORM to avoid use of optional WDDM 1.1 formats
00122
00123         WIC_FLAGS_NO_X2_BIAS            = 0x2,
00124             // Loads DXGI 1.1 X2 10:10:10:2 format as DXGI_FORMAT_R10G10B10A2_UNORM
00125
00126         WIC_FLAGS_NO_16BPP              = 0x4,
00127             // Loads 565, 5551, and 4444 formats as 8888 to avoid use of optional WDDM 1.2 formats
00128
00129         WIC_FLAGS_ALLOW_MONO            = 0x8,
00130             // Loads 1-bit monochrome (black & white) as R1_UNORM rather than 8-bit greyscale
00131
00132         WIC_FLAGS_ALL_FRAMES            = 0x10,
00133             // Loads all images in a multi-frame file, converting/resizing to match the first frame as needed, defaults to 0th frame otherwise
00134
00135         WIC_FLAGS_DITHER                = 0x10000,
00136             // Use ordered 4x4 dithering for any required conversions
00137
00138         WIC_FLAGS_DITHER_DIFFUSION      = 0x20000,
00139             // Use error-diffusion dithering for any required conversions
00140
00141         WIC_FLAGS_FILTER_POINT          = 0x100000,
00142         WIC_FLAGS_FILTER_LINEAR         = 0x200000,
00143         WIC_FLAGS_FILTER_CUBIC          = 0x300000,
00144         WIC_FLAGS_FILTER_FANT           = 0x400000, // Combination of Linear and Box filter
00145             // Filtering mode to use for any required image resizing (only needed when loading arrays of differently sized images; defaults to Fant)
00146     };
00147
00148     HRESULT GetMetadataFromDDSMemory( _In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags,
00149                                       _Out_ TexMetadata& metadata );
00150     HRESULT GetMetadataFromDDSFile( _In_ LPCWSTR szFile, _In_ DWORD flags,
00151                                     _Out_ TexMetadata& metadata );
00152
00153     HRESULT GetMetadataFromTGAMemory( _In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size,
00154                                       _Out_ TexMetadata& metadata );
00155     HRESULT GetMetadataFromTGAFile( _In_ LPCWSTR szFile,
00156                                     _Out_ TexMetadata& metadata );
00157
00158     HRESULT GetMetadataFromWICMemory( _In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags,
00159                                       _Out_ TexMetadata& metadata );
00160     HRESULT GetMetadataFromWICFile( _In_ LPCWSTR szFile, _In_ DWORD flags,
00161                                     _Out_ TexMetadata& metadata );
00162
00163     //---------------------------------------------------------------------------------
00164     // Bitmap image container
00165     struct Image
00166     {
00167         size_t      width;
00168         size_t      height;
00169         DXGI_FORMAT format;
00170         size_t      rowPitch;
00171         size_t      slicePitch;
00172         uint8_t*    pixels;
00173     };
00174
00175     class ScratchImage
00176     {
00177     public:
00178         ScratchImage() : _nimages(0), _size(0), _image(0), _memory(0) {}
00179         ~ScratchImage() { Release(); }
00180
00181         HRESULT Initialize( _In_ const TexMetadata& mdata );
00182
00183         HRESULT Initialize1D( _In_ DXGI_FORMAT fmt, _In_ size_t length, _In_ size_t arraySize, _In_ size_t mipLevels );
00184         HRESULT Initialize2D( _In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t arraySize, _In_ size_t mipLevels );
00185         HRESULT Initialize3D( _In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t depth, _In_ size_t mipLevels );
00186         HRESULT InitializeCube( _In_ DXGI_FORMAT fmt, _In_ size_t width, _In_ size_t height, _In_ size_t nCubes, _In_ size_t mipLevels );
00187
00188         HRESULT InitializeFromImage( _In_ const Image& srcImage, _In_ bool allow1D = false );
00189         HRESULT InitializeArrayFromImages( _In_reads_(nImages) const Image* images, _In_ size_t nImages, _In_ bool allow1D = false );
00190         HRESULT InitializeCubeFromImages( _In_reads_(nImages) const Image* images, _In_ size_t nImages );
00191         HRESULT Initialize3DFromImages( _In_reads_(depth) const Image* images, _In_ size_t depth );
00192
00193         void Release();
00194
00195         const TexMetadata& GetMetadata() const { return _metadata; }
00196         const Image* GetImage(_In_ size_t mip, _In_ size_t item, _In_ size_t slice) const;
00197
00198         const Image* GetImages() const { return _image; }
00199         size_t GetImageCount() const { return _nimages; }
00200
00201         uint8_t* GetPixels() const { return _memory; }
00202         size_t GetPixelsSize() const { return _size; }
00203
00204     private:
00205         size_t      _nimages;
00206         size_t      _size;
00207         TexMetadata _metadata;
00208         Image*      _image;
00209         uint8_t*    _memory;
00210
00211         // Hide copy constructor and assignment operator
00212         ScratchImage( const ScratchImage& );
00213         ScratchImage& operator=( const ScratchImage& );
00214     };
00215
00216     //---------------------------------------------------------------------------------
00217     // Memory blob (allocated buffer pointer is always 16-byte aligned)
00218     class Blob
00219     {
00220     public:
00221         Blob() : _buffer(0), _size(0) {}
00222         ~Blob() { Release(); }
00223
00224         HRESULT Initialize( _In_ size_t size );
00225
00226         void Release();
00227
00228         void *GetBufferPointer() const { return _buffer; }
00229         size_t GetBufferSize() const { return _size; }
00230
00231     private:
00232         void*   _buffer;
00233         size_t  _size;
00234
00235         // Hide copy constructor and assignment operator
00236         Blob( const Blob& );
00237         Blob& operator=( const Blob& );
00238     };
00239
00240     //---------------------------------------------------------------------------------
00241     // Image I/O
00242
00243     // DDS operations
00244     HRESULT LoadFromDDSMemory( _In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags,
00245                                _Out_opt_ TexMetadata* metadata, _Out_ ScratchImage& image );
00246     HRESULT LoadFromDDSFile( _In_ LPCWSTR szFile, _In_ DWORD flags,
00247                              _Out_opt_ TexMetadata* metadata, _Out_ ScratchImage& image );
00248
00249     HRESULT SaveToDDSMemory( _In_ const Image& image, _In_ DWORD flags,
00250                              _Out_ Blob& blob );
00251     HRESULT SaveToDDSMemory( _In_reads_(nimages) const Image* images, _In_ size_t nimages, _In_ const TexMetadata& metadata, _In_ DWORD flags,
00252                              _Out_ Blob& blob );
00253
00254     HRESULT SaveToDDSFile( _In_ const Image& image, _In_ DWORD flags, _In_ LPCWSTR szFile );
00255     HRESULT SaveToDDSFile( _In_reads_(nimages) const Image* images, _In_ size_t nimages, _In_ const TexMetadata& metadata, _In_ DWORD flags, _In_ LPCWSTR szFile );
00256
00257     // TGA operations
00258     HRESULT LoadFromTGAMemory( _In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size,
00259                                _Out_opt_ TexMetadata* metadata, _Out_ ScratchImage& image );
00260     HRESULT LoadFromTGAFile( _In_ LPCWSTR szFile,
00261                              _Out_opt_ TexMetadata* metadata, _Out_ ScratchImage& image );
00262
00263     HRESULT SaveToTGAMemory( _In_ const Image& image, _Out_ Blob& blob );
00264     HRESULT SaveToTGAFile( _In_ const Image& image, _In_ LPCWSTR szFile );
00265
00266     // WIC operations
00267     HRESULT LoadFromWICMemory( _In_reads_bytes_(size) LPCVOID pSource, _In_ size_t size, _In_ DWORD flags,
00268                                _Out_opt_ TexMetadata* metadata, _Out_ ScratchImage& image );
00269     HRESULT LoadFromWICFile( _In_ LPCWSTR szFile, _In_ DWORD flags,
00270                              _Out_opt_ TexMetadata* metadata, _Out_ ScratchImage& image );
00271
00272     HRESULT SaveToWICMemory( _In_ const Image& image, _In_ DWORD flags, _In_ REFGUID guidContainerFormat,
00273                              _Out_ Blob& blob );
00274     HRESULT SaveToWICMemory( _In_reads_(nimages) const Image* images, _In_ size_t nimages, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _Out_ Blob& blob );
00275
00276     HRESULT SaveToWICFile( _In_ const Image& image, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _In_ LPCWSTR szFile );
00277     HRESULT SaveToWICFile( _In_reads_(nimages) const Image* images, _In_ size_t nimages, _In_ DWORD flags, _In_ REFGUID guidContainerFormat, _In_ LPCWSTR szFile );
00278
00279     enum WICCodecs
00280     {
00281         WIC_CODEC_BMP       =1,     // Windows Bitmap (.bmp)
00282         WIC_CODEC_JPEG,             // Joint Photographic Experts Group (.jpg, .jpeg)
00283         WIC_CODEC_PNG,              // Portable Network Graphics (.png)
00284         WIC_CODEC_TIFF,             // Tagged Image File Format  (.tif, .tiff)
00285         WIC_CODEC_GIF,              // Graphics Interchange Format  (.gif)
00286         WIC_CODEC_WMP,              // Windows Media Photo / HD Photo / JPEG XR (.hdp, .jxr, .wdp)
00287         WIC_CODEC_ICO,              // Windows Icon (.ico)
00288     };
00289
00290     REFGUID GetWICCodec( _In_ WICCodecs codec );
00291
00292     //---------------------------------------------------------------------------------
00293     // Texture conversion, resizing, mipmap generation, and block compression
00294
00295     enum TEX_FR_FLAGS
00296     {
00297         TEX_FR_ROTATE0          = 0x0,
00298         TEX_FR_ROTATE90         = 0x1,
00299         TEX_FR_ROTATE180        = 0x2,
00300         TEX_FR_ROTATE270        = 0x3,
00301         TEX_FR_FLIP_HORIZONTAL  = 0x08,
00302         TEX_FR_FLIP_VERTICAL    = 0x10,
00303     };
00304
00305     HRESULT FlipRotate( _In_ const Image& srcImage, _In_ DWORD flags, _Out_ ScratchImage& image );
00306     HRESULT FlipRotate( _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00307                         _In_ DWORD flags, _Out_ ScratchImage& result );
00308         // Flip and/or rotate image
00309
00310     enum TEX_FILTER_FLAGS
00311     {
00312         TEX_FILTER_DEFAULT          = 0,
00313
00314         // Clamp filtering only
00315
00316         TEX_FILTER_SEPARATE_ALPHA   = 0x100,
00317             // Resize color and alpha channel independently
00318
00319         TEX_FILTER_DITHER           = 0x10000,
00320             // Use ordered 4x4 dithering for any required conversions
00321         TEX_FILTER_DITHER_DIFFUSION = 0x20000,
00322             // Use error-diffusion dithering for any required conversions
00323
00324         TEX_FILTER_POINT            = 0x100000,
00325         TEX_FILTER_LINEAR           = 0x200000,
00326         TEX_FILTER_CUBIC            = 0x300000,
00327         TEX_FILTER_FANT             = 0x400000, // Equiv to Box filtering for mipmap generation
00328             // Filtering mode to use for any required image resizing
00329
00330         TEX_FILTER_SRGB_IN          = 0x1000000,
00331         TEX_FILTER_SRGB_OUT         = 0x2000000,
00332         TEX_FILTER_SRGB             = 0x3000000,
00333             // sRGB <-> RGB for use in conversion operations
00334             // if the input format type is IsSRGB(), then SRGB_IN is on by default
00335             // if the output format type is IsSRGB(), then SRGB_OUT is on by default
00336     };
00337
00338     HRESULT Resize( _In_ const Image& srcImage, _In_ size_t width, _In_ size_t height, _In_ DWORD filter,
00339                     _Out_ ScratchImage& image );
00340     HRESULT Resize( _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00341                     _In_ size_t width, _In_ size_t height, _In_ DWORD filter, _Out_ ScratchImage& result );
00342         // Resize the image to width x height. Defaults to Fant filtering.
00343         // Note for a complex resize, the result will always have mipLevels == 1
00344
00345     HRESULT Convert( _In_ const Image& srcImage, _In_ DXGI_FORMAT format, _In_ DWORD filter, _In_ float threshold,
00346                      _Out_ ScratchImage& image );
00347     HRESULT Convert( _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00348                      _In_ DXGI_FORMAT format, _In_ DWORD filter, _In_ float threshold, _Out_ ScratchImage& result );
00349         // Convert the image to a new format
00350
00351     HRESULT GenerateMipMaps( _In_ const Image& baseImage, _In_ DWORD filter, _In_ size_t levels,
00352                              _Inout_ ScratchImage& mipChain, _In_ bool allow1D = false );
00353     HRESULT GenerateMipMaps( _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00354                              _In_ DWORD filter, _In_ size_t levels, _Inout_ ScratchImage& mipChain );
00355         // levels of '0' indicates a full mipchain, otherwise is generates that number of total levels (including the source base image)
00356         // Defaults to Fant filtering which is equivalent to a box filter
00357
00358     HRESULT GenerateMipMaps3D( _In_reads_(depth) const Image* baseImages, _In_ size_t depth, _In_ DWORD filter, _In_ size_t levels,
00359                                _Out_ ScratchImage& mipChain );
00360     HRESULT GenerateMipMaps3D( _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00361                                _In_ DWORD filter, _In_ size_t levels, _Out_ ScratchImage& mipChain );
00362         // levels of '0' indicates a full mipchain, otherwise is generates that number of total levels (including the source base image)
00363         // Defaults to Fant filtering which is equivalent to a box filter
00364
00365     enum TEX_COMPRESS_FLAGS
00366     {
00367         TEX_COMPRESS_DEFAULT        = 0,
00368
00369         TEX_COMPRESS_RGB_DITHER     = 0x10000,
00370             // Enables dithering RGB colors for BC1-3 compression
00371
00372         TEX_COMPRESS_A_DITHER       = 0x20000,
00373             // Enables dithering alpha for BC1-3 compression
00374
00375         TEX_COMPRESS_DITHER         = 0x30000,
00376             // Enables both RGB and alpha dithering for BC1-3 compression
00377
00378         TEX_COMPRESS_UNIFORM        = 0x40000,
00379             // Uniform color weighting for BC1-3 compression; by default uses perceptual weighting
00380
00381         TEX_COMPRESS_PARALLEL       = 0x10000000,
00382             // Compress is free to use multithreading to improve performance (by default it does not use multithreading)
00383     };
00384
00385     HRESULT Compress( _In_ const Image& srcImage, _In_ DXGI_FORMAT format, _In_ DWORD compress, _In_ float alphaRef,
00386                       _Out_ ScratchImage& cImage );
00387     HRESULT Compress( _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00388                       _In_ DXGI_FORMAT format, _In_ DWORD compress, _In_ float alphaRef, _Out_ ScratchImage& cImages );
00389         // Note that alphaRef is only used by BC1. 0.5f is a typical value to use
00390
00391     HRESULT Decompress( _In_ const Image& cImage, _In_ DXGI_FORMAT format, _Out_ ScratchImage& image );
00392     HRESULT Decompress( _In_reads_(nimages) const Image* cImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00393                         _In_ DXGI_FORMAT format, _Out_ ScratchImage& images );
00394
00395     //---------------------------------------------------------------------------------
00396     // Normal map operations
00397
00398     enum CNMAP_FLAGS
00399     {
00400         CNMAP_DEFAULT           = 0,
00401
00402         CNMAP_CHANNEL_RED       = 0x1,
00403         CNMAP_CHANNEL_GREEN     = 0x2,
00404         CNMAP_CHANNEL_BLUE      = 0x3,
00405         CNMAP_CHANNEL_ALPHA     = 0x4,
00406         CNMAP_CHANNEL_LUMINANCE = 0x5,
00407             // Channel selection when evaluting color value for height
00408             // Luminance is a combination of red, green, and blue
00409
00410         CNMAP_MIRROR_U          = 0x1000,
00411         CNMAP_MIRROR_V          = 0x2000,
00412         CNMAP_MIRROR            = 0x3000,
00413             // Use mirror semantics for scanline references (defaults to wrap)
00414
00415         CNMAP_INVERT_SIGN       = 0x4000,
00416             // Inverts normal sign
00417
00418         CNMAP_COMPUTE_OCCLUSION = 0x8000,
00419             // Computes a crude occlusion term stored in the alpha channel
00420     };
00421
00422     HRESULT ComputeNormalMap( _In_ const Image& srcImage, _In_ DWORD flags, _In_ float amplitude,
00423                               _In_ DXGI_FORMAT format, _Out_ ScratchImage& normalMap );
00424     HRESULT ComputeNormalMap( _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00425                               _In_ DWORD flags, _In_ float amplitude, _In_ DXGI_FORMAT format, _Out_ ScratchImage& normalMaps );
00426
00427     //---------------------------------------------------------------------------------
00428     // Misc image operations
00429     struct Rect
00430     {
00431         size_t x;
00432         size_t y;
00433         size_t w;
00434         size_t h;
00435
00436         Rect() {}
00437         Rect( size_t _x, size_t _y, size_t _w, size_t _h ) : x(_x), y(_y), w(_w), h(_h) {}
00438     };
00439
00440     HRESULT CopyRectangle( _In_ const Image& srcImage, _In_ const Rect& srcRect, _In_ const Image& dstImage,
00441                            _In_ DWORD filter, _In_ size_t xOffset, _In_ size_t yOffset );
00442
00443     HRESULT ComputeMSE( _In_ const Image& image1, _In_ const Image& image2, _Out_ float& mse, _Out_writes_opt_(4) float* mseV );
00444
00445     //---------------------------------------------------------------------------------
00446     // Direct3D 11 functions
00447     bool IsSupportedTexture( _In_ ID3D11Device* pDevice, _In_ const TexMetadata& metadata );
00448
00449     HRESULT CreateTexture( _In_ ID3D11Device* pDevice, _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00450                            _Outptr_ ID3D11Resource** ppResource );
00451
00452     HRESULT CreateShaderResourceView( _In_ ID3D11Device* pDevice, _In_reads_(nimages) const Image* srcImages, _In_ size_t nimages, _In_ const TexMetadata& metadata,
00453                                       _Outptr_ ID3D11ShaderResourceView** ppSRV );
00454
00455     HRESULT CaptureTexture( _In_ ID3D11Device* pDevice, _In_ ID3D11DeviceContext* pContext, _In_ ID3D11Resource* pSource, _Out_ ScratchImage& result );
00456
00457 #include "DirectXTex.inl"
00458
00459 }; // namespace
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/GameRenderer.h Source File

  • DirectX 3D shooting game

GameRenderer.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // GameRenderer:
00011 // This is the renderer for the game.  It derives from DirectXBase.
00012 // It is responsble for creating and maintaining all the D3D11 and D2D objects
00013 // used to generate the game visuals.  It maintains a reference to the Simple3DGame
00014 // object to retrieve the list of objects to render as well as status of the
00015 // game for the Heads Up Display (HUD).
00016 //
00017 // The renderer is designed to use a standard vertex layout across all objects.  This
00018 // simplifies the shader design and allows for easy changes between shaders independent
00019 // of the objects' geometry.  Each vertex is defined by a position, a normal and one set of
00020 // 2D texture coordinates.  The shaders all expect one 2D texture and 4 constant buffers:
00021 //     m_constantBufferNeverChanges - general parameters that are set only once.  This includes
00022 //         all the lights used in scene generation.
00023 //     m_constantBufferChangeOnResize - the projection matrix.  It is typically only changed when
00024 //         the window is resized, however it will be changed 2x per frame when rendering
00025 //         in 3D stereo.
00026 //     m_constantBufferChangesEveryFrame - the view transformation matrix.  This is set once per frame.
00027 //     m_constantBufferChangesEveryPrim - the parameters for each object.  It includes the object to world
00028 //         transformation matrix as well as material properties like color and specular exponent for lighting
00029 //         calculations.
00030 //
00031 // The renderer also maintains a set of texture resources that will be associated with particular game objects.
00032 // It knows which textures are to be associated with which objects and will do that association once the
00033 // textures have been loaded.
00034 //
00035 // The renderer provides a set of methods to allow for a "standard" sequence to be executed for loading general
00036 // game resources and for level specific resources.  Because D3D11 allows free threaded creation of objects,
00037 // textures will be loaded asynchronously and in parallel, however D3D11 does not allow for multiple threads to
00038 // be using the DeviceContext at the same time.
00039 //
00040 // The pattern is:
00041 //     create_task([this]()
00042 //     {
00043 //         // create/load device resources
00044 //     }).then([this]()
00045 //     {
00046 //         // create/load device context resources
00047 //     }, task_continuation_context::use_current());
00048
00049 #include "DirectXBase.h"
00050 #include "GameInfoOverlay.h"
00051 #include "GameHud.h"
00052 #include "Simple3DGame.h"
00053
00054 ref class Simple3DGame;
00055 ref class GameHud;
00056
00057 ref class GameRenderer : public DirectXBase
00058 {
00059 internal:
00060     GameRenderer();
00061
00062     virtual void Initialize(
00063         _In_ Windows::UI::Core::CoreWindow^ window,
00064         float dpi
00065         ) override;
00066
00067     virtual void CreateDeviceIndependentResources() override;
00068     virtual void CreateDeviceResources() override;
00069     virtual void UpdateForWindowSizeChange() override;
00070     virtual void Render() override;
00071     virtual void HandleDeviceLost() override;
00072     virtual void SetDpi(float dpi) override;
00073
00074     concurrency::task<void> CreateGameDeviceResourcesAsync(_In_ Simple3DGame^ game);
00075     void FinalizeCreateGameDeviceResources();
00076     concurrency::task<void> LoadLevelResourcesAsync();
00077     void FinalizeLoadLevelResources();
00078
00079     GameInfoOverlay^ InfoOverlay()  { return m_gameInfoOverlay; };
00080
00081     DirectX::XMFLOAT2 GameInfoOverlayUpperLeft()
00082     {
00083         return DirectX::XMFLOAT2(
00084             (m_windowBounds.Width  - GameInfoOverlayConstant::Width) / 2.0f,
00085             (m_windowBounds.Height - GameInfoOverlayConstant::Height) / 2.0f
00086             );
00087     };
00088     DirectX::XMFLOAT2 GameInfoOverlayLowerRight()
00089     {
00090         return DirectX::XMFLOAT2(
00091             (m_windowBounds.Width  - GameInfoOverlayConstant::Width) / 2.0f + GameInfoOverlayConstant::Width,
00092             (m_windowBounds.Height - GameInfoOverlayConstant::Height) / 2.0f + GameInfoOverlayConstant::Height
00093             );
00094     };
00095
00096 #if defined(_DEBUG)
00097     void ReportLiveDeviceObjects();
00098 #endif
00099
00100 protected private:
00101     bool                                                m_initialized;
00102     bool                                                m_gameResourcesLoaded;
00103     bool                                                m_levelResourcesLoaded;
00104     GameInfoOverlay^                                    m_gameInfoOverlay;
00105     GameHud^                                            m_gameHud;
00106     Simple3DGame^                                       m_game;
00107
00108     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_sphereTexture;
00109     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_cylinderTexture;
00110     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_ceilingTexture;
00111     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_floorTexture;
00112     Microsoft::WRL::ComPtr<ID3D11ShaderResourceView>    m_wallsTexture;
00113
00114     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_constantBufferNeverChanges;
00115     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_constantBufferChangeOnResize;
00116     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_constantBufferChangesEveryFrame;
00117     Microsoft::WRL::ComPtr<ID3D11Buffer>                m_constantBufferChangesEveryPrim;
00118     Microsoft::WRL::ComPtr<ID3D11SamplerState>          m_samplerLinear;
00119     Microsoft::WRL::ComPtr<ID3D11VertexShader>          m_vertexShader;
00120     Microsoft::WRL::ComPtr<ID3D11VertexShader>          m_vertexShaderFlat;
00121     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_pixelShader;
00122     Microsoft::WRL::ComPtr<ID3D11PixelShader>           m_pixelShaderFlat;
00123     Microsoft::WRL::ComPtr<ID3D11InputLayout>           m_vertexLayout;
00124 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager msAudioCategory/C++/pch.cpp Source File

  • Playback Manager msAudioCategory

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: PlayToReceiver/C++/Constants.cpp Source File

  • PlayToReceiver

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Create a software PlayTo Receiver", "SDKSample.PlayToreceiver.Scenario1" },
00022 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/Page2.xaml.cpp Source File

  • XAML AppBar control

Page2.xaml.cpp

Go to the documentation of this file.
00001 ﻿//
00002 // Page2.xaml.cpp
00003 // Implementation of the Page2 class
00004 //
00005
00006 #include "pch.h"
00007 #include "App.xaml.h"
00008 #include "Page2.xaml.h"
00009
00010 using namespace AppBarControl;
00011
00012 using namespace Platform;
00013 using namespace Windows::Foundation;
00014 using namespace Windows::Foundation::Collections;
00015 using namespace Windows::UI::Xaml;
00016 using namespace Windows::UI::Xaml::Controls;
00017 using namespace Windows::UI::Xaml::Controls::Primitives;
00018 using namespace Windows::UI::Xaml::Data;
00019 using namespace Windows::UI::Xaml::Input;
00020 using namespace Windows::UI::Xaml::Media;
00021 using namespace Windows::UI::Xaml::Navigation;
00022
00023 // The Blank Page item template is documented at http://go.microsoft.com/fwlink/?LinkId=234238
00024 // NOTE: the 'superstar' button does not currently load, so this part of the scenario does not work
00025
00026 Page2::Page2()
00027 {
00028   InitializeComponent();
00029   rootPage = nullptr;
00030   starButton = nullptr;
00031   rightPanel = nullptr;
00032 }
00033
00034 // Invoked when this page is about to be displayed in a Frame.
00035 void Page2::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037   rootPage = (GlobalPage^) e->Parameter;
00038
00039   // While our AppBar has global commands for navigation, we can demonstrate
00040   // how we can add contextual AppBar command buttons that only pertain to
00041   // particular pages.
00042
00043   // In this case, whenever we navigate to this page, we want to add a new command button
00044   // to our AppBar
00045
00046   // Add command buttons to the right side StackPanel within the AppBar.
00047   rightPanel = (StackPanel^) rootPage->FindName("RightCommands");
00048   if (rightPanel != nullptr)
00049   {
00050       // Create the button, add to AppBar and setup a handler to receive Click notification from it
00051       starButton = ref new Button();
00052         starButton->Style = safe_cast<Windows::UI::Xaml::Style^>(App::Current->Resources->Lookup("StarAppBarButtonStyle"));
00053       starButton->Click += ref new RoutedEventHandler(this, &Page2::starButton_Click);
00054
00055       rightPanel->Children->Append(starButton);
00056   }
00057 }
00058 void Page2::OnNavigatingFrom(NavigatingCancelEventArgs^ e)
00059 {
00060 }
00061
00062 void Page2::starButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00063 {
00064   Windows::UI::Popups::MessageDialog^ dialog = ref new Windows::UI::Popups::MessageDialog("You're a Superstar!");
00065   dialog->ShowAsync();
00066 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/ShowOptionsUI.xaml.h Source File

  • CameraOptionsUI

ShowOptionsUI.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ShowOptionsUI.xaml.h
00013 // Declaration of the ShowOptionsUI class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "ShowOptionsUI.g.h"
00020 #include "MainPage.xaml.h"
00021 #include <agile.h>
00022
00023 namespace SDKSample
00024 {
00025     namespace CameraOptions
00026     {
00027         /// <summary>
00028         /// An empty page that can be used on its own or navigated to within a Frame.
00029         /// </summary>
00030         [Windows::Foundation::Metadata::WebHostHidden]
00031         public ref class ShowOptionsUI sealed
00032         {
00033         public:
00034             ShowOptionsUI();
00035
00036         protected:
00037             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00038
00039         private:
00040             MainPage^ rootPage;
00041             void StartPreview_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042             void ShowSettings_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00043             void MediaControl_SoundLevelChanged(Platform::Object^ sender, Platform::Object^ e);
00044
00045             Platform::Agile<Windows::Media::Capture::MediaCapture> mediaCaptureMgr;
00046             bool previewStarted;
00047
00048             Windows::UI::Core::CoreDispatcher^ dispatcher;
00049         };
00050     }
00051 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SMS background task/C++/SmsBackgroundTaskSample/Constants.h Source File

  • SMS background task
  • SmsBackgroundTaskSample

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"SMS Background Task");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/Scenario4.xaml.h Source File

  • AtomPub

Scenario4.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.h
00013 // Declaration of the Scenario4 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario4.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Platform;
00025
00026 namespace SDKSample
00027 {
00028     namespace AtomPub
00029     {
00030         /// <summary>
00031         /// An empty page that can be used on its own or navigated to within a Frame.
00032         /// </summary>
00033       [Windows::Foundation::Metadata::WebHostHidden]
00034         public ref class Scenario4 sealed
00035         {
00036         public:
00037             Scenario4();
00038
00039         protected:
00040             virtual void OnNavigatedTo(NavigationEventArgs^ e) override;
00041             virtual void OnNavigatingFrom(NavigatingCancelEventArgs^ e) override;
00042
00043         private:
00044             MainPage^ rootPage;
00045             SyndicationItemIterator^ feedIterator;
00046
00047             void GetFeed_Click(Object^ sender, RoutedEventArgs^ e);
00048             void UpdateItem_Click(Object^ sender, RoutedEventArgs^ e);
00049             void PreviousItem_Click(Object^ sender, RoutedEventArgs^ e);
00050             void NextItem_Click(Object^ sender, RoutedEventArgs^ e);
00051             void UserNameField_TextChanged(Object^ sender, TextChangedEventArgs^ e);
00052             void PasswordField_PasswordChanged(Object^ sender, RoutedEventArgs^ e);
00053             void DisplayItem();
00054         };
00055     }
00056 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Extended Linguistic Services (ELS)/C++/MainPage.xaml.h Source File

  • Extended Linguistic Services (ELS)
  • C++

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/pch.cpp Source File

  • Calendar details and math

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Parser Member List

This is the complete list of members for Parser, including all inherited members.
ClearPacket() | Parser | [inline]
ClearPacket() | Parser | [inline]
FindNextStartCode(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser | [private]
FindNextStartCode(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser | [private]
GetSystemHeader(MPEG1SystemHeader **ppHeader) | Parser |
GetSystemHeader(MPEG1SystemHeader **ppHeader) | Parser |
HasPacket() const | Parser | [inline]
HasPacket() const | Parser | [inline]
HasSystemHeader() const | Parser | [inline]
HasSystemHeader() const | Parser | [inline]
IsEndOfStream() const | Parser | [inline]
IsEndOfStream() const | Parser | [inline]
m_bEOS | Parser | [private]
m_bHasPacketHeader | Parser | [private]
m_curPacketHeader | Parser | [private]
m_muxRate | Parser | [private]
m_pHeader | Parser | [private]
m_SCR | Parser | [private]
OnEndOfStream() | Parser | [private]
OnEndOfStream() | Parser | [private]
PacketHeader() | Parser | [inline]
PacketHeader() | Parser | [inline]
ParseBytes(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser |
ParseBytes(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser |
ParsePacketHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser | [private]
ParsePacketHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser | [private]
ParsePackHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser | [private]
ParsePackHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser | [private]
Parser() | Parser |
Parser() | Parser |
ParseSystemHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser | [private]
ParseSystemHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte) | Parser | [private]
PayloadSize() const | Parser | [inline]
PayloadSize() const | Parser | [inline]
~Parser() | Parser |
~Parser() | Parser |
Generated on Sat Nov 23 2024 16:09:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SuspensionManager Member List

This is the complete list of members for SuspensionManager, including all inherited members.
filename | SuspensionManager | [private]
KnownTypes | SuspensionManager | [static]
knownTypes_ | SuspensionManager | [private, static]
RestoreAsync() | SuspensionManager | [inline, static]
RestoreAsync() | SuspensionManager | [inline, static]
RestoreAsync() | SuspensionManager | [inline, static]
SaveAsync() | SuspensionManager | [inline, static]
SaveAsync() | SuspensionManager | [inline, static]
SaveAsync() | SuspensionManager | [inline, static]
SessionState | SuspensionManager | [static]
sessionState_ | SuspensionManager | [private, static]
Generated on Sat Nov 23 2024 16:09:23 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicMath.h Source File

  • Direct3D-Direct2D interop

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Playback Manager Companion/C++/MainPage.xaml.h Source File

  • Playback Manager Companion

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/pch.cpp Source File

  • Edge gesture invocation

pch.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // pch.cpp
00010 // Include the standard header and generate the precompiled header.
00011 //
00012
00013 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

FrameProcessing Member List

This is the complete list of members for FrameProcessing, including all inherited members.
ApplyColorSimplifier() | FrameProcessing | [private]
ApplyColorSimplifier(int nPhases) | FrameProcessing | [private]
ApplyColorSimplifier(unsigned int startHeight, unsigned int endHeight, unsigned int startWidth, unsigned int endWidth) | FrameProcessing | [private]
ApplyEdgeDetection() | FrameProcessing | [private]
ApplyEdgeDetectionParallel(unsigned int startHeight, unsigned int endHeight, unsigned int startWidth, unsigned int endWidth) | FrameProcessing | [private]
ApplyFilters(int nPhases) | FrameProcessing |
CalculateSobel(byte *pSource, int row, int column, float &dy, float &du, float &dv) | FrameProcessing | [private]
FrameProcessing() | FrameProcessing |
GetNeighbourArea() | FrameProcessing | [private]
GetPixel(byte *pFrame, int x, int y, int pitch, int bpp) | FrameProcessing | [inline, private, static]
m_BPP | FrameProcessing | [private]
m_colorPlanes | FrameProcessing | [private]
m_height | FrameProcessing | [private]
m_neighborWindow | FrameProcessing | [private]
m_pBufferImage | FrameProcessing | [private]
m_pCurrentImage | FrameProcessing | [private]
m_pitch | FrameProcessing | [private]
m_size | FrameProcessing | [private]
m_token | FrameProcessing | [private]
m_width | FrameProcessing | [private]
SetCancellationToken(concurrency::cancellation_token token) | FrameProcessing |
SetCurrentFrame(byte *pFrame, int size, int width, int height, int pitch, int bpp, int clrPlanes) | FrameProcessing |
SetNeighbourArea(unsigned int area) | FrameProcessing |
SetPixel(byte *pFrame, int x, int y, int pitch, int bpp, COLORREF color) | FrameProcessing | [inline, private, static]
SimplifyIndexOptimized(byte *pFrame, int x, int y) | FrameProcessing | [private]
StopFilters() | FrameProcessing | [private]
~FrameProcessing() | FrameProcessing |
Generated on Sat Nov 23 2024 16:09:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App tiles and badges/C#,C++/SendWebImageTile.xaml.cpp Source File

  • App tiles and badges
  • C#,C++

SendWebImageTile.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SendWebImageTile.xaml.cpp
00013 // Implementation of the SendWebImageTile class
00014 //
00015
00016 #include "pch.h"
00017 #include "SendWebImageTile.xaml.h"
00018
00019 using namespace SDKSample::Tiles;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::Notifications;
00025 using namespace NotificationsExtensions::TileContent;
00026
00027 SendWebImageTile::SendWebImageTile()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 void SendWebImageTile::OnNavigatedTo(NavigationEventArgs^ e)
00033 {
00034     rootPage = MainPage::Current;
00035 }
00036
00037 void SendWebImageTile::UpdateTileWithWebImage_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00038 {
00039   // Note: This sample contains an additional project, NotificationsExtensions.
00040   // NotificationsExtensions exposes an object model for creating notifications, but you can also
00041   // modify the strings directly. See UpdateTileWithWebImageWithStringManipulation_Click for an example
00042
00043   // Create notification content based on a visual template.
00044   auto tileContent = TileContentFactory::CreateTileWideImageAndText01();
00045   tileContent->TextCaptionWrap->Text = "This tile notification uses web images";
00046
00047   // !Important!
00048   // The Internet (Client) capability must be checked in the manifest in the Capabilities tab
00049   // to display web images in tiles (either the http:// or https:// protocols)
00050
00051   tileContent->Image->Src = ImageUrl->Text;
00052   tileContent->Image->Alt = "Web image";
00053
00054   // Users can resize tiles to square or wide.
00055   // Apps can choose to include only square assets (meaning the app's tile can never be wide), or
00056   // include both wide and square assets (the user can resize the tile to square or wide).
00057   // Apps cannot include only wide assets.
00058
00059   // Apps that support being wide should include square tile notifications since users
00060   // determine the size of the tile.
00061
00062   // Create square notification content based on a visual template.
00063   auto squareContent = TileContentFactory::CreateTileSquareImage();
00064
00065   squareContent->Image->Src = ImageUrl->Text;
00066   squareContent->Image->Alt = "Web image";
00067
00068   // include the square template.
00069   tileContent->SquareContent = squareContent;
00070
00071   // Send the notification to the app's application tile
00072   TileUpdateManager::CreateTileUpdaterForApplication()->Update(tileContent->CreateNotification());
00073
00074   OutputTextBlock->Text = tileContent->GetContent();
00075 }
00076
00077 void SendWebImageTile::UpdateTileWithWebImageWithStringManipulation_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00078 {
00079   // create a string with the tile template xml
00080   auto tileXmlString = "<tile>"
00081     + "<visual>"
00082     + "<binding template='TileWideImageAndText01'>"
00083     + "<text id='1'>This tile notification uses web images</text>"
00084     + "<image id='1' src='" + ImageUrl->Text + "'/>"
00085     + "</binding>"
00086     + "<binding template='TileSquareImage'>"
00087     + "<image id='1' src='" + ImageUrl->Text + "'/>"
00088     + "</binding>"
00089     + "</visual>"
00090     + "</tile>";
00091
00092   try
00093   {
00094     // create a DOM
00095     auto tileDOM = ref new Windows::Data::Xml::Dom::XmlDocument();
00096
00097     // load the xml string into the DOM, catching any invalid xml characters
00098     tileDOM->LoadXml(tileXmlString);
00099
00100     // create a tile notification
00101     auto tile = ref new TileNotification(tileDOM);
00102
00103     // Send the notification to the app's application tile
00104     TileUpdateManager::CreateTileUpdaterForApplication()->Update(tile);
00105
00106     OutputTextBlock->Text = tileDOM->GetXml();
00107   }
00108   catch (Platform::Exception^)
00109   {
00110     OutputTextBlock->Text = "Error loading the xml, check for invalid characters in the input";
00111   }
00112 }
00113
00114 void SendWebImageTile::ClearTile_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00115 {
00116   // A TileUpdater is also used to clear the tile
00117   TileUpdateManager::CreateTileUpdaterForApplication()->Clear();
00118   OutputTextBlock->Text = "Tile cleared";
00119 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/ComputeShader/DirectXSample.h Source File

  • Direct2D custom image effects
  • ComputeShader

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/App.xaml.cpp Source File

  • Hilo C++
  • Hilo

App.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "Common\SuspensionManager.h"
00009 #include "MainHubView.g.h"
00010 #include "TileUpdateScheduler.h"
00011 #include "ExceptionPolicyFactory.h"
00012 #include "HiloPage.h"
00013 #include "LocalResourceLoader.h"
00014 #include "FileSystemRepository.h"
00015
00016 using namespace Concurrency;
00017 using namespace Hilo;
00018 using namespace Hilo::Common;
00019 using namespace Platform;
00020 using namespace Windows::ApplicationModel;
00021 using namespace Windows::ApplicationModel::Activation;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Interop;
00025 using namespace Windows::Foundation;
00026
00027 // See http://go.microsoft.com/fwlink/?LinkId=267274 for info about this app.
00028
00029 /// <summary>
00030 /// Initializes the singleton application object.  This is the first line of authored code
00031 /// executed, and as such is the logical equivalent of main() or WinMain().
00032 /// </summary>
00033 App::App()
00034 {
00035 #ifndef NDEBUG
00036     // remember thread ID of main thread for assertion checking of runtime context
00037     RecordMainThread();
00038 #endif
00039     InitializeComponent();
00040     // See http://go.microsoft.com/fwlink/?LinkId=267280 for more info on Hilo's implementation of suspend/resume.
00041     Suspending += ref new SuspendingEventHandler(this, &App::OnSuspending);
00042     Resuming += ref new EventHandler<Platform::Object^>(this, &App::OnResume);
00043     m_exceptionPolicy = ExceptionPolicyFactory::GetCurrentPolicy();
00044     m_repository = std::make_shared<FileSystemRepository>(m_exceptionPolicy);
00045 }
00046
00047 /// <summary>
00048 /// Invoked when the application is launched normally by the end user.  Other entry points will
00049 /// be used when the application is launched to open a specific file, to display search results,
00050 /// and so forth.
00051 /// </summary>
00052 /// <param name="args">Details about the launch request and process.</param>
00053 void App::OnLaunched(LaunchActivatedEventArgs^ args)
00054 {
00055     assert(IsMainThread());
00056     auto rootFrame = dynamic_cast<Frame^>(Window::Current->Content);
00057
00058     // Do not repeat app initialization when the Window already has content,
00059     // just ensure that the window is active
00060     if (rootFrame == nullptr)
00061     {
00062         // Create a Frame to act as the navigation context and associate it with
00063         // a SuspensionManager key. See http://go.microsoft.com/fwlink/?LinkId=267280 for more info
00064         // on Hilo's implementation of suspend/resume.
00065         rootFrame = ref new Frame();
00066         SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00067
00068         auto prerequisite = task<void>([](){});
00069         if (args->PreviousExecutionState == ApplicationExecutionState::Terminated)
00070         {
00071             // Restore the saved session state only when appropriate, scheduling the
00072             // final launch steps after the restore is complete
00073             prerequisite = SuspensionManager::RestoreAsync();
00074         }
00075         prerequisite.then([=](task<void> prerequisite)
00076         {
00077             try
00078             {
00079                 prerequisite.get();
00080             }
00081             catch (Platform::Exception^)
00082             {
00083                 //Something went wrong restoring state.
00084                 //Assume there is no state and continue
00085             }
00086
00087             if (rootFrame->Content == nullptr)
00088             {
00089                 // When the navigation stack isn't restored navigate to the first page,
00090                 // configuring the new page by passing required information as a navigation
00091                 // parameter.  See http://go.microsoft.com/fwlink/?LinkId=267278 for a walkthrough of how
00092                 // Hilo creates pages and navigates to pages.
00093                 if (!rootFrame->Navigate(TypeName(MainHubView::typeid)))
00094                 {
00095                     throw ref new FailureException((ref new LocalResourceLoader())->GetString("ErrorFailedToCreateInitialPage"));
00096                 }
00097             }
00098
00099             // Place the frame in the current Window
00100             Window::Current->Content = rootFrame;
00101             // Ensure the current window is active
00102             Window::Current->Activate();
00103
00104         }, task_continuation_context::use_current());
00105     }
00106     else
00107     {
00108         if (rootFrame->Content == nullptr)
00109         {
00110             // When the navigation stack isn't restored navigate to the first page,
00111             // configuring the new page by passing required information as a navigation
00112             // parameter. See http://go.microsoft.com/fwlink/?LinkId=267278 for a walkthrough of how
00113             // Hilo creates pages and navigates to pages.
00114             if (!rootFrame->Navigate(TypeName(MainHubView::typeid)))
00115             {
00116                 throw ref new FailureException((ref new LocalResourceLoader())->GetString("ErrorFailedToCreateInitialPage"));
00117             }
00118         }
00119         // Ensure the current window is active
00120         Window::Current->Activate();
00121     }
00122
00123     // Schedule updates to the tile. See http://go.microsoft.com/fwlink/?LinkId=267275 for
00124     // info about how Hilo manages tiles.
00125     m_tileUpdateScheduler = std::make_shared<TileUpdateScheduler>();
00126     m_tileUpdateScheduler->ScheduleUpdateAsync(m_repository, m_exceptionPolicy);
00127 }
00128
00129 // See http://go.microsoft.com/fwlink/?LinkId=267280 for more info on Hilo's implementation of suspend/resume.
00130
00131 /// <summary>
00132 /// Invoked when application execution is being suspended.  Application state is saved
00133 /// without knowing whether the application will be terminated or resumed with the contents
00134 /// of memory still intact.
00135 /// </summary>
00136 /// <param name="sender">The source of the suspend request.</param>
00137 /// <param name="e">Details about the suspend request.</param>
00138 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00139 {
00140     (void) sender; // Unused parameter
00141     assert(IsMainThread());
00142
00143     auto deferral = e->SuspendingOperation->GetDeferral();
00144     HiloPage::IsSuspending = true;
00145     SuspensionManager::SaveAsync().then([=](task<void> antecedent)
00146     {
00147         HiloPage::IsSuspending = false;
00148         antecedent.get();
00149         deferral->Complete();
00150     });
00151 }
00152
00153 // See http://go.microsoft.com/fwlink/?LinkId=267280 for more info on Hilo's implementation of suspend/resume.
00154 void App::OnResume(Object^ sender, Platform::Object^ e)
00155 {
00156     (void) sender; // Unused parameter
00157     (void) e;      // Unused parameter
00158     assert(IsMainThread());
00159
00160     if (m_repository != nullptr)
00161     {
00162         // Hilo does not receive data change events when suspended. Create these events on resume.
00163         m_repository->NotifyAllObservers();
00164     }
00165 }
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Toast notifications/C#,C++/ScenarioOutput3.xaml.cpp Source File

  • Toast notifications
  • C#,C++

ScenarioOutput3.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario3Output.xaml.cpp
00010 // Implementation of the Scenario3Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput3.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace ToastsSampleCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput3::ScenarioOutput3()
00033 {
00034     InitializeComponent();
00035
00036 #pragma region ViewState and Resolution change code for THIS page - Remove unless you need it
00037     Loaded += ref new RoutedEventHandler(this, &ScenarioOutput3::Page_Loaded);
00038
00039     Window::Current->SizeChanged += ref new Windows::UI::Xaml::WindowSizeChangedEventHandler(this, &ScenarioOutput3::Page_SizeChanged);
00040     DisplayProperties::LogicalDpiChanged += ref new DisplayPropertiesEventHandler(this, &ScenarioOutput3::DisplayProperties_LogicalDpiChanged);
00041 #pragma endregion
00042 }
00043
00044 #pragma region ViewState and Resolution change code for THIS page - Remove unless you need it
00045 ScenarioOutput3::~ScenarioOutput3()
00046 {
00047 }
00048
00049 void ScenarioOutput3::Page_Loaded(Object^ sender, RoutedEventArgs^ e)
00050 {
00051 }
00052
00053 void ScenarioOutput3::Page_SizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00054 {
00055     CheckResolutionAndViewState();
00056 }
00057
00058 void ScenarioOutput3::DisplayProperties_LogicalDpiChanged(Object^ sender)
00059 {
00060     CheckResolutionAndViewState();
00061 }
00062
00063 void ScenarioOutput3::CheckResolutionAndViewState()
00064 {
00065     ApplicationViewState state = ApplicationView::Value;
00066     String^ stateString = rootPage->ConvertViewState(state);
00067
00068     ResolutionScale scale = DisplayProperties::ResolutionScale;
00069     String^ scaleString = rootPage->ConvertResolution(scale);
00070
00071     VisualStateManager::GoToState(this, stateString + scaleString, false);
00072 }
00073
00074 #pragma endregion
00075
00076 #pragma region Template-Related Code - Do not remove
00077 void ScenarioOutput3::OnNavigatedTo(NavigationEventArgs^ e)
00078 {
00079   // Get a pointer to our main page.
00080   rootPage = dynamic_cast<MainPage^>(e->Parameter);
00081
00082   // We want to be notified with the OutputFrame is loaded so we can get to the content.
00083   _frameLoadedToken = rootPage->InputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioOutput3::rootPage_InputFrameLoaded);
00084 }
00085
00086 void ScenarioOutput3::OnNavigatedFrom(NavigationEventArgs^ e)
00087 {
00088     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00089 }
00090
00091 #pragma endregion
00092
00093 #pragma region Use this code if you need access to elements in the input frame - otherwise deletea
00094 void ScenarioOutput3::rootPage_InputFrameLoaded(Object^ sender, Object^ e)
00095 {
00096     // Get a pointer to the content within the OutputFrame.
00097     Page^ inputFrame = dynamic_cast<Page^>(rootPage->InputFrame->Content);
00098
00099     // Go find the elements that we need for this scenario
00100     // ex: flipView1 = dynamic_cast<FlipView^>(inputFrame->FindName("FlipView1"));
00101 }
00102
00103 #pragma endregion
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ComputeDoubleCB Member List

This is the complete list of members for ComputeDoubleCB, including all inherited members.
deltaPerDtidX | ComputeDoubleCB
deltaPerDtidY | ComputeDoubleCB
originDtid00 | ComputeDoubleCB
Generated on Sat Nov 23 2024 16:09:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: IXmlReader and IXmlWriter XML data readwrite/C++/pch.h Source File

  • IXmlReader and IXmlWriter XML data readwrite

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include <shcore.h>
00021 #include <wrl.h>
00022 #include <xmllite.h>
00023
00024 #define ChkHr(stmt) do { hr = stmt; if (FAILED(hr)) return hr; } while(0)
00025
00026 #include "Common\LayoutAwarePage.h"
00027 #include "Common\SuspensionManager.h"
00028 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MediaExtensions/Polar/PolarEffect.cpp Source File

  • Media extensions
  • MediaExtensions
  • Polar

PolarEffect.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #include "PolarEffect.h"
00009 #include "bufferlock.h"
00010
00011 #pragma comment(lib, "d2d1")
00012
00013 /*
00014
00015 This sample implements video effects as a Media Foundation transform (MFT).
00016
00017 Windows Store apps using JavaScript can select one of the following effects
00018 by using PropertySet argument of msInsertVideoEffect.
00019
00020 Fisheye
00021
00022     var effect = new Windows.Foundation.Collections.PropertySet();
00023     effect["effect"] = "Fisheye";
00024
00025 Pinch
00026
00027     var effect = new Windows.Foundation.Collections.PropertySet();
00028     effect["effect"] = "Pinch";
00029
00030 Warp
00031
00032     var effect = new Windows.Foundation.Collections.PropertySet();
00033     effect["effect"] = "Warp";
00034
00035
00036 These effects are based on polar transformation.
00037
00038 Each pixel in a YUV image is represented as radius (r) and angle (theta) from
00039 the center of the image. If R is the maximum distance from the center of the
00040 image, the new pixel location is calculated by the following rules:
00041
00042 Fisheye
00043
00044     r := r*(r/R)
00045
00046 Pinch
00047
00048     r := sqrt(r/R)
00049
00050 Warp
00051
00052     theta := theta + r/R
00053
00054
00055 Before the first video frame is processed, a lookup table is created to store
00056 the result of the polar transformation. Then, the same lookup table is used
00057 until the end of the streaming session.
00058
00059
00060 NOTES ON THE MFT IMPLEMENTATION
00061
00062 1. The MFT has fixed streams: One input stream and one output stream.
00063
00064 2. The MFT supports the following formats: UYVY, YUY2, NV12.
00065
00066 3. If the MFT is holding an input sample, SetInputType and SetOutputType both fail.
00067
00068 4. The input and output types must be identical.
00069
00070 5. If both types are set, no type can be set until the current type is cleared.
00071
00072 6. Preferred input types:
00073
00074      (a) If the output type is set, that's the preferred type.
00075      (b) Otherwise, the preferred types are partial types, constructed from the
00076          list of supported subtypes.
00077
00078 7. Preferred output types: As above.
00079
00080 8. Streaming:
00081
00082     The private BeingStreaming() method is called in response to the
00083     MFT_MESSAGE_NOTIFY_BEGIN_STREAMING message.
00084
00085     If the client does not send MFT_MESSAGE_NOTIFY_BEGIN_STREAMING, the MFT calls
00086     BeginStreaming inside the first call to ProcessInput or ProcessOutput.
00087
00088     This is a good approach for allocating resources that your MFT requires for
00089     streaming.
00090
00091 9. The configuration attributes are applied in the BeginStreaming method. If the
00092    client changes the attributes during streaming, the change is ignored until
00093    streaming is stopped (either by changing the media types or by sending the
00094    MFT_MESSAGE_NOTIFY_END_STREAMING message) and then restarted.
00095
00096 */
00097
00098 // Video FOURCC codes.
00099 const DWORD FOURCC_YUY2 = '2YUY';
00100 const DWORD FOURCC_UYVY = 'YVYU';
00101 const DWORD FOURCC_NV12 = '21VN';
00102
00103 // Static array of media types (preferred and accepted).
00104 const GUID g_MediaSubtypes[] =
00105 {
00106     MFVideoFormat_NV12,
00107     MFVideoFormat_YUY2,
00108     MFVideoFormat_UYVY
00109 };
00110
00111 HRESULT GetImageSize(DWORD fcc, UINT32 width, UINT32 height, DWORD* pcbImage);
00112 HRESULT GetDefaultStride(IMFMediaType *pType, LONG *plStride);
00113
00114 //-------------------------------------------------------------------
00115 // Functions to apply the lookup table to YUV images.
00116 //
00117 // In all cases, the same transformation is applied to the YUV
00118 // image, but the pixel layout in memory differs. The transformation
00119 // is applied to the pair of pixels which share the UV component.
00120 //
00121 // The image conversion functions take the following parameters:
00122 //
00123 // pLookup          Pointer to the lookup table.
00124 // pDest             Pointer to the destination buffer.
00125 // lDestStride       Stride of the destination buffer, in bytes.
00126 // pSrc              Pointer to the source buffer.
00127 // lSrcStride        Stride of the source buffer, in bytes.
00128 // dwWidthInPixels   Frame width in pixels.
00129 // dwHeightInPixels  Frame height, in pixels.
00130 //-------------------------------------------------------------------
00131
00132 // Convert UYVY image.
00133
00134 void TransformImage_UYVY(
00135     _In_reads_(_Inexpressible_(dwWidthInPixels * dwHeightInPixels)) const UINT32* pLookup,
00136     _Inout_updates_(_Inexpressible_(lDestStride * dwHeightInPixels)) BYTE *pDest,
00137     _In_ LONG lDestStride,
00138     _In_reads_(_Inexpressible_(lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00139     _In_ LONG lSrcStride,
00140     _In_ DWORD dwWidthInPixels,
00141     _In_ DWORD dwHeightInPixels)
00142 {
00143     DWORD *pSrc_UYVY = (DWORD*) pSrc;
00144
00145     // Byte order is U0 Y0 V0 Y1
00146     // Windows is little-endian so the order appears reversed.
00147
00148     pSrc_UYVY[0] = 0x00800080;  // black
00149
00150     for (DWORD y = 0; y < dwHeightInPixels; y++)
00151     {
00152         DWORD *pDest_UYVY = (DWORD*) pDest;
00153
00154         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00155         {
00156 #pragma warning(push)
00157 #pragma warning(disable: 6385)
00158 #pragma warning(disable: 6386)
00159             UINT32 uOffset = (pLookup[x] % dwWidthInPixels) * sizeof(WORD) + (pLookup[x] / dwWidthInPixels) * lSrcStride;
00160             pDest_UYVY[x/2] = pSrc_UYVY[uOffset/sizeof(DWORD)];
00161 #pragma warning(pop)
00162         }
00163         pDest += lDestStride;
00164         pLookup += dwWidthInPixels;
00165     }
00166 }
00167
00168
00169 // Convert YUY2 image.
00170
00171 void TransformImage_YUY2(
00172     _In_reads_(_Inexpressible_(dwWidthInPixels * dwHeightInPixels)) const UINT32* pLookup,
00173     _Inout_updates_(_Inexpressible_(lDestStride * dwHeightInPixels)) BYTE *pDest,
00174     _In_ LONG lDestStride,
00175     _In_reads_(_Inexpressible_(lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00176     _In_ LONG lSrcStride,
00177     _In_ DWORD dwWidthInPixels,
00178     _In_ DWORD dwHeightInPixels)
00179 {
00180     DWORD *pSrc_UYVY = (DWORD*) pSrc;
00181
00182     // Byte order is Y0 U0 Y1 V0
00183     // Windows is little-endian so the order appears reversed.
00184
00185     pSrc_UYVY[0] = 0x80008000;  // black
00186
00187     for (DWORD y = 0; y < dwHeightInPixels; y++)
00188     {
00189         DWORD *pDest_UYVY = (DWORD*) pDest;
00190
00191         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00192         {
00193 #pragma warning(push)
00194 #pragma warning(disable: 6385)
00195 #pragma warning(disable: 6386)
00196             UINT32 uOffset = (pLookup[x] % dwWidthInPixels) * sizeof(WORD) + (pLookup[x] / dwWidthInPixels) * lSrcStride;
00197             pDest_UYVY[x/2] = pSrc_UYVY[uOffset/sizeof(DWORD)];
00198 #pragma warning(pop)
00199         }
00200         pDest += lDestStride;
00201         pLookup += dwWidthInPixels;
00202     }
00203 }
00204
00205
00206 // Convert NV12 image
00207
00208 void TransformImage_NV12(
00209     _In_reads_(_Inexpressible_(dwWidthInPixels * dwHeightInPixels)) const UINT32* pLookup,
00210     _Inout_updates_(_Inexpressible_(lDestStride * dwHeightInPixels)) BYTE *pDest,
00211     _In_ LONG lDestStride,
00212     _In_reads_(_Inexpressible_(lSrcStride * dwHeightInPixels)) const BYTE* pSrc,
00213     _In_ LONG lSrcStride,
00214     _In_ DWORD dwWidthInPixels,
00215     _In_ DWORD dwHeightInPixels)
00216 {
00217     // NV12 is planar: Y plane, followed by packed U-V plane.
00218
00219     // Y plane
00220
00221     UINT32 *pLookup_Y = (UINT32*) pLookup;
00222     WORD *pSrc_Y = (WORD*) pSrc;
00223     pSrc_Y[0] = 0x0000;    // black
00224
00225     for (DWORD y = 0; y < dwHeightInPixels; y++)
00226     {
00227         WORD *pDest_Y = (WORD*) pDest;
00228
00229         for (DWORD x = 0; (x + 1) < dwWidthInPixels; x += 2)
00230         {
00231 #pragma warning(push)
00232 #pragma warning(disable: 6385)
00233 #pragma warning(disable: 6386)
00234             UINT32 uOffset = (pLookup_Y[x] % dwWidthInPixels) + (pLookup_Y[x] / dwWidthInPixels) * lSrcStride;
00235             pDest_Y[x/2] = pSrc_Y[uOffset/2];
00236 #pragma warning(pop)
00237         }
00238         pDest += lDestStride;
00239         pLookup_Y += dwWidthInPixels;
00240     }
00241
00242     // U-V plane
00243
00244     // NOTE: The U-V plane has 1/2 the number of lines as the Y plane.
00245
00246     UINT32 *pLookup_UV = (UINT32*) pLookup;
00247     WORD *pSrc_UV = (WORD*) (pSrc + lSrcStride * dwHeightInPixels);
00248     pSrc_UV[0] = 0x8080;    // black
00249
00250     for (DWORD y = 0; y < dwHeightInPixels; y += 2)
00251     {
00252         WORD *pDest_UV = (WORD*) pDest;
00253
00254         for (DWORD x = 0; x < dwWidthInPixels; x += 2)
00255         {
00256 #pragma warning(push)
00257 #pragma warning(disable: 6385)
00258             UINT32 uOffset = (pLookup_UV[x] % dwWidthInPixels) + ((pLookup_UV[x] / dwWidthInPixels) / 2) * lSrcStride;
00259 #pragma warning(pop)
00260             pDest_UV[x/2] = pSrc_UV[uOffset/2];
00261         }
00262         pDest += lDestStride;
00263         pLookup_UV += dwWidthInPixels * 2;
00264     }
00265 }
00266
00267
00268
00269 CPolarEffect::CPolarEffect() :
00270     m_pSample(NULL), m_pInputType(NULL), m_pOutputType(NULL), m_pTransformFn(NULL),
00271     m_imageWidthInPixels(0), m_imageHeightInPixels(0), m_cbImageSize(0),
00272     m_pIndexLookup(NULL), m_bStreamingInitialized(false), m_pAttributes(NULL),
00273     m_pRadiusTransformFn(CPolarEffect::DefaultRadius),
00274     m_pThetaTransformFn(CPolarEffect::DefaultTheta)
00275 {
00276     InitializeCriticalSectionEx(&m_critSec, 3000, 0);
00277 }
00278
00279 CPolarEffect::~CPolarEffect()
00280 {
00281     SafeArrayDelete(&m_pIndexLookup);
00282     SafeRelease(&m_pInputType);
00283     SafeRelease(&m_pOutputType);
00284     SafeRelease(&m_pSample);
00285     SafeRelease(&m_pAttributes);
00286     DeleteCriticalSection(&m_critSec);
00287 }
00288
00289 // Initialize the instance.
00290 STDMETHODIMP CPolarEffect::RuntimeClassInitialize()
00291 {
00292     // Create the attribute store.
00293     return MFCreateAttributes(&m_pAttributes, 3);
00294 }
00295
00296 // IMediaExtension methods
00297
00298 //-------------------------------------------------------------------
00299 // SetProperties
00300 // Sets the configuration of the effect
00301 //-------------------------------------------------------------------
00302 HRESULT CPolarEffect::SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration)
00303 {
00304     HRESULT hr = S_OK;
00305
00306     if(pConfiguration)
00307     {
00308         Microsoft::WRL::ComPtr<IInspectable> spInsp;
00309         Microsoft::WRL::ComPtr<ABI::Windows::Foundation::Collections::IMap<HSTRING, IInspectable *>> spSetting;
00310         Microsoft::WRL::ComPtr<ABI::Windows::Foundation::IPropertyValue> spPropVal;
00311
00312         hr = pConfiguration->QueryInterface(IID_PPV_ARGS(&spSetting));
00313         if (FAILED(hr))
00314         {
00315             hr = E_FAIL;
00316             goto done;
00317         }
00318
00319         HStringReference strKey(L"effect");
00320         hr = spSetting->Lookup(strKey.Get(), spInsp.ReleaseAndGetAddressOf());
00321         if(FAILED(hr))
00322         {
00323             hr = E_INVALIDARG;
00324             goto done;
00325         }
00326
00327         hr = spInsp.As(&spPropVal);
00328         if(FAILED(hr))
00329         {
00330             hr = E_INVALIDARG;
00331             goto done;
00332         }
00333
00334         HString strEffectName;
00335         hr = spPropVal->GetString(strEffectName.GetAddressOf());
00336         if(FAILED(hr))
00337         {
00338             hr = E_INVALIDARG;
00339             goto done;
00340         }
00341
00342         LPCWSTR pszEffectName = WindowsGetStringRawBuffer(strEffectName.Get(), nullptr);
00343         if (pszEffectName == nullptr)
00344         {
00345             hr = E_INVALIDARG;
00346             goto done;
00347         }
00348
00349         if (wcscmp(pszEffectName, L"Fisheye") == 0)
00350         {
00351             m_pRadiusTransformFn = CPolarEffect::FisheyeRadius;
00352             m_pThetaTransformFn = CPolarEffect::DefaultTheta;
00353         }
00354         else if (wcscmp(pszEffectName, L"Pinch") == 0)
00355         {
00356             m_pRadiusTransformFn = CPolarEffect::PinchRadius;
00357             m_pThetaTransformFn = CPolarEffect::DefaultTheta;
00358         }
00359         else if (wcscmp(pszEffectName, L"Warp") == 0)
00360         {
00361             m_pRadiusTransformFn = CPolarEffect::DefaultRadius;
00362             m_pThetaTransformFn = CPolarEffect::WarpTheta;
00363         }
00364         else
00365         {
00366             hr = E_INVALIDARG;
00367             goto done;
00368         }
00369     }
00370
00371 done:
00372     return hr;
00373 }
00374
00375 // IMFTransform methods. Refer to the Media Foundation SDK documentation for details.
00376
00377 //-------------------------------------------------------------------
00378 // GetStreamLimits
00379 // Returns the minimum and maximum number of streams.
00380 //-------------------------------------------------------------------
00381
00382 HRESULT CPolarEffect::GetStreamLimits(
00383     DWORD   *pdwInputMinimum,
00384     DWORD   *pdwInputMaximum,
00385     DWORD   *pdwOutputMinimum,
00386     DWORD   *pdwOutputMaximum
00387 )
00388 {
00389     if ((pdwInputMinimum == NULL) ||
00390         (pdwInputMaximum == NULL) ||
00391         (pdwOutputMinimum == NULL) ||
00392         (pdwOutputMaximum == NULL))
00393     {
00394         return E_POINTER;
00395     }
00396
00397     // This MFT has a fixed number of streams.
00398     *pdwInputMinimum = 1;
00399     *pdwInputMaximum = 1;
00400     *pdwOutputMinimum = 1;
00401     *pdwOutputMaximum = 1;
00402     return S_OK;
00403 }
00404
00405
00406 //-------------------------------------------------------------------
00407 // GetStreamCount
00408 // Returns the actual number of streams.
00409 //-------------------------------------------------------------------
00410
00411 HRESULT CPolarEffect::GetStreamCount(
00412     DWORD   *pcInputStreams,
00413     DWORD   *pcOutputStreams
00414 )
00415 {
00416     if ((pcInputStreams == NULL) || (pcOutputStreams == NULL))
00417
00418     {
00419         return E_POINTER;
00420     }
00421
00422     // This MFT has a fixed number of streams.
00423     *pcInputStreams = 1;
00424     *pcOutputStreams = 1;
00425     return S_OK;
00426 }
00427
00428
00429
00430 //-------------------------------------------------------------------
00431 // GetStreamIDs
00432 // Returns stream IDs for the input and output streams.
00433 //-------------------------------------------------------------------
00434
00435 HRESULT CPolarEffect::GetStreamIDs(
00436     DWORD   dwInputIDArraySize,
00437     DWORD   *pdwInputIDs,
00438     DWORD   dwOutputIDArraySize,
00439     DWORD   *pdwOutputIDs
00440 )
00441 {
00442     // It is not required to implement this method if the MFT has a fixed number of
00443     // streams AND the stream IDs are numbered sequentially from zero (that is, the
00444     // stream IDs match the stream indexes).
00445
00446     // In that case, it is OK to return E_NOTIMPL.
00447     return E_NOTIMPL;
00448 }
00449
00450
00451 //-------------------------------------------------------------------
00452 // GetInputStreamInfo
00453 // Returns information about an input stream.
00454 //-------------------------------------------------------------------
00455
00456 HRESULT CPolarEffect::GetInputStreamInfo(
00457     DWORD                     dwInputStreamID,
00458     MFT_INPUT_STREAM_INFO *   pStreamInfo
00459 )
00460 {
00461     if (pStreamInfo == NULL)
00462     {
00463         return E_POINTER;
00464     }
00465
00466     EnterCriticalSection(&m_critSec);
00467
00468     if (!IsValidInputStream(dwInputStreamID))
00469     {
00470         LeaveCriticalSection(&m_critSec);
00471         return MF_E_INVALIDSTREAMNUMBER;
00472     }
00473
00474     // NOTE: This method should succeed even when there is no media type on the
00475     //       stream. If there is no media type, we only need to fill in the dwFlags
00476     //       member of MFT_INPUT_STREAM_INFO. The other members depend on having a
00477     //       a valid media type.
00478
00479     pStreamInfo->hnsMaxLatency = 0;
00480     pStreamInfo->dwFlags = MFT_INPUT_STREAM_WHOLE_SAMPLES | MFT_INPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER;
00481
00482     if (m_pInputType == NULL)
00483     {
00484         pStreamInfo->cbSize = 0;
00485     }
00486     else
00487     {
00488         pStreamInfo->cbSize = m_cbImageSize;
00489     }
00490
00491     pStreamInfo->cbMaxLookahead = 0;
00492     pStreamInfo->cbAlignment = 0;
00493
00494     LeaveCriticalSection(&m_critSec);
00495     return S_OK;
00496 }
00497
00498 //-------------------------------------------------------------------
00499 // GetOutputStreamInfo
00500 // Returns information about an output stream.
00501 //-------------------------------------------------------------------
00502
00503 HRESULT CPolarEffect::GetOutputStreamInfo(
00504     DWORD                     dwOutputStreamID,
00505     MFT_OUTPUT_STREAM_INFO *  pStreamInfo
00506 )
00507 {
00508     if (pStreamInfo == NULL)
00509     {
00510         return E_POINTER;
00511     }
00512
00513     EnterCriticalSection(&m_critSec);
00514
00515     if (!IsValidOutputStream(dwOutputStreamID))
00516     {
00517         LeaveCriticalSection(&m_critSec);
00518         return MF_E_INVALIDSTREAMNUMBER;
00519     }
00520
00521     // NOTE: This method should succeed even when there is no media type on the
00522     //       stream. If there is no media type, we only need to fill in the dwFlags
00523     //       member of MFT_OUTPUT_STREAM_INFO. The other members depend on having a
00524     //       a valid media type.
00525
00526     pStreamInfo->dwFlags =
00527         MFT_OUTPUT_STREAM_WHOLE_SAMPLES |
00528         MFT_OUTPUT_STREAM_SINGLE_SAMPLE_PER_BUFFER |
00529         MFT_OUTPUT_STREAM_FIXED_SAMPLE_SIZE ;
00530
00531     if (m_pOutputType == NULL)
00532     {
00533         pStreamInfo->cbSize = 0;
00534     }
00535     else
00536     {
00537         pStreamInfo->cbSize = m_cbImageSize;
00538     }
00539
00540     pStreamInfo->cbAlignment = 0;
00541
00542     LeaveCriticalSection(&m_critSec);
00543     return S_OK;
00544 }
00545
00546
00547 //-------------------------------------------------------------------
00548 // GetAttributes
00549 // Returns the attributes for the MFT.
00550 //-------------------------------------------------------------------
00551
00552 HRESULT CPolarEffect::GetAttributes(IMFAttributes** ppAttributes)
00553 {
00554     if (ppAttributes == NULL)
00555     {
00556         return E_POINTER;
00557     }
00558
00559     EnterCriticalSection(&m_critSec);
00560
00561     *ppAttributes = m_pAttributes;
00562     (*ppAttributes)->AddRef();
00563
00564     LeaveCriticalSection(&m_critSec);
00565     return S_OK;
00566 }
00567
00568
00569 //-------------------------------------------------------------------
00570 // GetInputStreamAttributes
00571 // Returns stream-level attributes for an input stream.
00572 //-------------------------------------------------------------------
00573
00574 HRESULT CPolarEffect::GetInputStreamAttributes(
00575     DWORD           dwInputStreamID,
00576     IMFAttributes   **ppAttributes
00577 )
00578 {
00579     // This MFT does not support any stream-level attributes, so the method is not implemented.
00580     return E_NOTIMPL;
00581 }
00582
00583
00584 //-------------------------------------------------------------------
00585 // GetOutputStreamAttributes
00586 // Returns stream-level attributes for an output stream.
00587 //-------------------------------------------------------------------
00588
00589 HRESULT CPolarEffect::GetOutputStreamAttributes(
00590     DWORD           dwOutputStreamID,
00591     IMFAttributes   **ppAttributes
00592 )
00593 {
00594     // This MFT does not support any stream-level attributes, so the method is not implemented.
00595     return E_NOTIMPL;
00596 }
00597
00598
00599 //-------------------------------------------------------------------
00600 // DeleteInputStream
00601 //-------------------------------------------------------------------
00602
00603 HRESULT CPolarEffect::DeleteInputStream(DWORD dwStreamID)
00604 {
00605     // This MFT has a fixed number of input streams, so the method is not supported.
00606     return E_NOTIMPL;
00607 }
00608
00609
00610 //-------------------------------------------------------------------
00611 // AddInputStreams
00612 //-------------------------------------------------------------------
00613
00614 HRESULT CPolarEffect::AddInputStreams(
00615     DWORD   cStreams,
00616     DWORD   *adwStreamIDs
00617 )
00618 {
00619     // This MFT has a fixed number of output streams, so the method is not supported.
00620     return E_NOTIMPL;
00621 }
00622
00623
00624 //-------------------------------------------------------------------
00625 // GetInputAvailableType
00626 // Returns a preferred input type.
00627 //-------------------------------------------------------------------
00628
00629 HRESULT CPolarEffect::GetInputAvailableType(
00630     DWORD           dwInputStreamID,
00631     DWORD           dwTypeIndex, // 0-based
00632     IMFMediaType    **ppType
00633 )
00634 {
00635     if (ppType == NULL)
00636     {
00637         return E_INVALIDARG;
00638     }
00639
00640     EnterCriticalSection(&m_critSec);
00641
00642     if (!IsValidInputStream(dwInputStreamID))
00643     {
00644         LeaveCriticalSection(&m_critSec);
00645         return MF_E_INVALIDSTREAMNUMBER;
00646     }
00647
00648     HRESULT hr = S_OK;
00649
00650     // If the output type is set, return that type as our preferred input type.
00651     if (m_pOutputType == NULL)
00652     {
00653         // The output type is not set. Create a partial media type.
00654         hr = OnGetPartialType(dwTypeIndex, ppType);
00655     }
00656     else if (dwTypeIndex > 0)
00657     {
00658         hr = MF_E_NO_MORE_TYPES;
00659     }
00660     else
00661     {
00662         *ppType = m_pOutputType;
00663         (*ppType)->AddRef();
00664     }
00665
00666     LeaveCriticalSection(&m_critSec);
00667     return hr;
00668 }
00669
00670
00671
00672 //-------------------------------------------------------------------
00673 // GetOutputAvailableType
00674 // Returns a preferred output type.
00675 //-------------------------------------------------------------------
00676
00677 HRESULT CPolarEffect::GetOutputAvailableType(
00678     DWORD           dwOutputStreamID,
00679     DWORD           dwTypeIndex, // 0-based
00680     IMFMediaType    **ppType
00681 )
00682 {
00683     if (ppType == NULL)
00684     {
00685         return E_INVALIDARG;
00686     }
00687
00688     EnterCriticalSection(&m_critSec);
00689
00690     if (!IsValidOutputStream(dwOutputStreamID))
00691     {
00692         LeaveCriticalSection(&m_critSec);
00693         return MF_E_INVALIDSTREAMNUMBER;
00694     }
00695
00696     HRESULT hr = S_OK;
00697
00698     if (m_pInputType == NULL)
00699     {
00700         // The input type is not set. Create a partial media type.
00701         hr = OnGetPartialType(dwTypeIndex, ppType);
00702     }
00703     else if (dwTypeIndex > 0)
00704     {
00705         hr = MF_E_NO_MORE_TYPES;
00706     }
00707     else
00708     {
00709         *ppType = m_pInputType;
00710         (*ppType)->AddRef();
00711     }
00712
00713     LeaveCriticalSection(&m_critSec);
00714     return hr;
00715 }
00716
00717
00718 //-------------------------------------------------------------------
00719 // SetInputType
00720 //-------------------------------------------------------------------
00721
00722 HRESULT CPolarEffect::SetInputType(
00723     DWORD           dwInputStreamID,
00724     IMFMediaType    *pType, // Can be NULL to clear the input type.
00725     DWORD           dwFlags
00726 )
00727 {
00728     // Validate flags.
00729     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00730     {
00731         return E_INVALIDARG;
00732     }
00733
00734     EnterCriticalSection(&m_critSec);
00735
00736     if (!IsValidInputStream(dwInputStreamID))
00737     {
00738         LeaveCriticalSection(&m_critSec);
00739         return MF_E_INVALIDSTREAMNUMBER;
00740     }
00741
00742     HRESULT hr = S_OK;
00743
00744     // Does the caller want us to set the type, or just test it?
00745     BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);
00746
00747     // If we have an input sample, the client cannot change the type now.
00748     if (HasPendingOutput())
00749     {
00750         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00751         goto done;
00752     }
00753
00754     // Validate the type, if non-NULL.
00755     if (pType)
00756     {
00757         hr = OnCheckInputType(pType);
00758         if (FAILED(hr))
00759         {
00760             goto done;
00761         }
00762     }
00763
00764     // The type is OK. Set the type, unless the caller was just testing.
00765     if (bReallySet)
00766     {
00767         OnSetInputType(pType);
00768
00769         // When the type changes, end streaming.
00770         hr = EndStreaming();
00771     }
00772
00773 done:
00774     LeaveCriticalSection(&m_critSec);
00775     return hr;
00776 }
00777
00778
00779
00780 //-------------------------------------------------------------------
00781 // SetOutputType
00782 //-------------------------------------------------------------------
00783
00784 HRESULT CPolarEffect::SetOutputType(
00785     DWORD           dwOutputStreamID,
00786     IMFMediaType    *pType, // Can be NULL to clear the output type.
00787     DWORD           dwFlags
00788 )
00789 {
00790     // Validate flags.
00791     if (dwFlags & ~MFT_SET_TYPE_TEST_ONLY)
00792     {
00793         return E_INVALIDARG;
00794     }
00795
00796     EnterCriticalSection(&m_critSec);
00797
00798     if (!IsValidOutputStream(dwOutputStreamID))
00799     {
00800         LeaveCriticalSection(&m_critSec);
00801         return MF_E_INVALIDSTREAMNUMBER;
00802     }
00803
00804     HRESULT hr = S_OK;
00805
00806     // Does the caller want us to set the type, or just test it?
00807     BOOL bReallySet = ((dwFlags & MFT_SET_TYPE_TEST_ONLY) == 0);
00808
00809     // If we have an input sample, the client cannot change the type now.
00810     if (HasPendingOutput())
00811     {
00812         hr = MF_E_TRANSFORM_CANNOT_CHANGE_MEDIATYPE_WHILE_PROCESSING;
00813         goto done;
00814     }
00815
00816     // Validate the type, if non-NULL.
00817     if (pType)
00818     {
00819         hr = OnCheckOutputType(pType);
00820         if (FAILED(hr))
00821         {
00822             goto done;
00823         }
00824     }
00825
00826     // The type is OK. Set the type, unless the caller was just testing.
00827     if (bReallySet)
00828     {
00829         OnSetOutputType(pType);
00830
00831         // When the type changes, end streaming.
00832         hr = EndStreaming();
00833     }
00834
00835 done:
00836     LeaveCriticalSection(&m_critSec);
00837     return hr;
00838 }
00839
00840
00841 //-------------------------------------------------------------------
00842 // GetInputCurrentType
00843 // Returns the current input type.
00844 //-------------------------------------------------------------------
00845
00846 HRESULT CPolarEffect::GetInputCurrentType(
00847     DWORD           dwInputStreamID,
00848     IMFMediaType    **ppType
00849 )
00850 {
00851     if (ppType == NULL)
00852     {
00853         return E_POINTER;
00854     }
00855
00856     HRESULT hr = S_OK;
00857
00858     EnterCriticalSection(&m_critSec);
00859
00860     if (!IsValidInputStream(dwInputStreamID))
00861     {
00862         hr = MF_E_INVALIDSTREAMNUMBER;
00863     }
00864     else if (!m_pInputType)
00865     {
00866         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00867     }
00868     else
00869     {
00870         *ppType = m_pInputType;
00871         (*ppType)->AddRef();
00872     }
00873     LeaveCriticalSection(&m_critSec);
00874     return hr;
00875 }
00876
00877
00878 //-------------------------------------------------------------------
00879 // GetOutputCurrentType
00880 // Returns the current output type.
00881 //-------------------------------------------------------------------
00882
00883 HRESULT CPolarEffect::GetOutputCurrentType(
00884     DWORD           dwOutputStreamID,
00885     IMFMediaType    **ppType
00886 )
00887 {
00888     if (ppType == NULL)
00889     {
00890         return E_POINTER;
00891     }
00892
00893     HRESULT hr = S_OK;
00894
00895     EnterCriticalSection(&m_critSec);
00896
00897     if (!IsValidOutputStream(dwOutputStreamID))
00898     {
00899         hr = MF_E_INVALIDSTREAMNUMBER;
00900     }
00901     else if (!m_pOutputType)
00902     {
00903         hr = MF_E_TRANSFORM_TYPE_NOT_SET;
00904     }
00905     else
00906     {
00907         *ppType = m_pOutputType;
00908         (*ppType)->AddRef();
00909     }
00910
00911     LeaveCriticalSection(&m_critSec);
00912     return hr;
00913 }
00914
00915
00916 //-------------------------------------------------------------------
00917 // GetInputStatus
00918 // Query if the MFT is accepting more input.
00919 //-------------------------------------------------------------------
00920
00921 HRESULT CPolarEffect::GetInputStatus(
00922     DWORD           dwInputStreamID,
00923     DWORD           *pdwFlags
00924 )
00925 {
00926     if (pdwFlags == NULL)
00927     {
00928         return E_POINTER;
00929     }
00930
00931     EnterCriticalSection(&m_critSec);
00932
00933     if (!IsValidInputStream(dwInputStreamID))
00934     {
00935         LeaveCriticalSection(&m_critSec);
00936         return MF_E_INVALIDSTREAMNUMBER;
00937     }
00938
00939     // If an input sample is already queued, do not accept another sample until the
00940     // client calls ProcessOutput or Flush.
00941
00942     // NOTE: It is possible for an MFT to accept more than one input sample. For
00943     // example, this might be required in a video decoder if the frames do not
00944     // arrive in temporal order. In the case, the decoder must hold a queue of
00945     // samples. For the video effect, each sample is transformed independently, so
00946     // there is no reason to queue multiple input samples.
00947
00948     if (m_pSample == NULL)
00949     {
00950         *pdwFlags = MFT_INPUT_STATUS_ACCEPT_DATA;
00951     }
00952     else
00953     {
00954         *pdwFlags = 0;
00955     }
00956
00957     LeaveCriticalSection(&m_critSec);
00958     return S_OK;
00959 }
00960
00961
00962
00963 //-------------------------------------------------------------------
00964 // GetOutputStatus
00965 // Query if the MFT can produce output.
00966 //-------------------------------------------------------------------
00967
00968 HRESULT CPolarEffect::GetOutputStatus(DWORD *pdwFlags)
00969 {
00970     if (pdwFlags == NULL)
00971     {
00972         return E_POINTER;
00973     }
00974
00975     EnterCriticalSection(&m_critSec);
00976
00977     // The MFT can produce an output sample if (and only if) there an input sample.
00978     if (m_pSample != NULL)
00979     {
00980         *pdwFlags = MFT_OUTPUT_STATUS_SAMPLE_READY;
00981     }
00982     else
00983     {
00984         *pdwFlags = 0;
00985     }
00986
00987     LeaveCriticalSection(&m_critSec);
00988     return S_OK;
00989 }
00990
00991
00992 //-------------------------------------------------------------------
00993 // SetOutputBounds
00994 // Sets the range of time stamps that the MFT will output.
00995 //-------------------------------------------------------------------
00996
00997 HRESULT CPolarEffect::SetOutputBounds(
00998     LONGLONG        hnsLowerBound,
00999     LONGLONG        hnsUpperBound
01000 )
01001 {
01002     // Implementation of this method is optional.
01003     return E_NOTIMPL;
01004 }
01005
01006
01007 //-------------------------------------------------------------------
01008 // ProcessEvent
01009 // Sends an event to an input stream.
01010 //-------------------------------------------------------------------
01011
01012 HRESULT CPolarEffect::ProcessEvent(
01013     DWORD              dwInputStreamID,
01014     IMFMediaEvent      *pEvent
01015 )
01016 {
01017     // This MFT does not handle any stream events, so the method can
01018     // return E_NOTIMPL. This tells the pipeline that it can stop
01019     // sending any more events to this MFT.
01020     return E_NOTIMPL;
01021 }
01022
01023
01024 //-------------------------------------------------------------------
01025 // ProcessMessage
01026 //-------------------------------------------------------------------
01027
01028 HRESULT CPolarEffect::ProcessMessage(
01029     MFT_MESSAGE_TYPE    eMessage,
01030     ULONG_PTR           ulParam
01031 )
01032 {
01033     EnterCriticalSection(&m_critSec);
01034
01035     HRESULT hr = S_OK;
01036
01037     switch (eMessage)
01038     {
01039     case MFT_MESSAGE_COMMAND_FLUSH:
01040         // Flush the MFT.
01041         hr = OnFlush();
01042         break;
01043
01044     case MFT_MESSAGE_COMMAND_DRAIN:
01045         // Drain: Tells the MFT to reject further input until all pending samples are
01046         // processed. That is our default behavior already, so there is nothing to do.
01047         //
01048         // For a decoder that accepts a queue of samples, the MFT might need to drain
01049         // the queue in response to this command.
01050     break;
01051
01052     case MFT_MESSAGE_SET_D3D_MANAGER:
01053         // Sets a pointer to the IDirect3DDeviceManager9 interface.
01054
01055         // The pipeline should never send this message unless the MFT sets the MF_SA_D3D_AWARE
01056         // attribute set to TRUE. Because this MFT does not set MF_SA_D3D_AWARE, it is an error
01057         // to send the MFT_MESSAGE_SET_D3D_MANAGER message to the MFT. Return an error code in
01058         // this case.
01059
01060         // NOTE: If this MFT were D3D-enabled, it would cache the IDirect3DDeviceManager9
01061         // pointer for use during streaming.
01062
01063         hr = E_NOTIMPL;
01064         break;
01065
01066     case MFT_MESSAGE_NOTIFY_BEGIN_STREAMING:
01067         hr = BeginStreaming();
01068         break;
01069
01070     case MFT_MESSAGE_NOTIFY_END_STREAMING:
01071         hr = EndStreaming();
01072         break;
01073
01074     // The next two messages do not require any action from this MFT.
01075
01076     case MFT_MESSAGE_NOTIFY_END_OF_STREAM:
01077         break;
01078
01079     case MFT_MESSAGE_NOTIFY_START_OF_STREAM:
01080         break;
01081     }
01082
01083     LeaveCriticalSection(&m_critSec);
01084     return hr;
01085 }
01086
01087
01088 //-------------------------------------------------------------------
01089 // ProcessInput
01090 // Process an input sample.
01091 //-------------------------------------------------------------------
01092
01093 HRESULT CPolarEffect::ProcessInput(
01094     DWORD               dwInputStreamID,
01095     IMFSample           *pSample,
01096     DWORD               dwFlags
01097 )
01098 {
01099     // Check input parameters.
01100     if (pSample == NULL)
01101     {
01102         return E_POINTER;
01103     }
01104
01105     if (dwFlags != 0)
01106     {
01107         return E_INVALIDARG; // dwFlags is reserved and must be zero.
01108     }
01109
01110     HRESULT hr = S_OK;
01111
01112     EnterCriticalSection(&m_critSec);
01113
01114     // Validate the input stream number.
01115     if (!IsValidInputStream(dwInputStreamID))
01116     {
01117         hr = MF_E_INVALIDSTREAMNUMBER;
01118         goto done;
01119     }
01120
01121     // Check for valid media types.
01122     // The client must set input and output types before calling ProcessInput.
01123     if (!m_pInputType || !m_pOutputType)
01124     {
01125         hr = MF_E_NOTACCEPTING;
01126         goto done;
01127     }
01128
01129     // Check if an input sample is already queued.
01130     if (m_pSample != NULL)
01131     {
01132         hr = MF_E_NOTACCEPTING;   // We already have an input sample.
01133         goto done;
01134     }
01135
01136     // Initialize streaming.
01137     hr = BeginStreaming();
01138     if (FAILED(hr))
01139     {
01140         goto done;
01141     }
01142
01143     // Cache the sample. We do the actual work in ProcessOutput.
01144     m_pSample = pSample;
01145     pSample->AddRef();  // Hold a reference count on the sample.
01146
01147 done:
01148     LeaveCriticalSection(&m_critSec);
01149     return hr;
01150 }
01151
01152
01153 //-------------------------------------------------------------------
01154 // ProcessOutput
01155 // Process an output sample.
01156 //-------------------------------------------------------------------
01157
01158 HRESULT CPolarEffect::ProcessOutput(
01159     DWORD                   dwFlags,
01160     DWORD                   cOutputBufferCount,
01161     MFT_OUTPUT_DATA_BUFFER  *pOutputSamples, // one per stream
01162     DWORD                   *pdwStatus
01163 )
01164 {
01165     // Check input parameters...
01166
01167     // This MFT does not accept any flags for the dwFlags parameter.
01168
01169     // The only defined flag is MFT_PROCESS_OUTPUT_DISCARD_WHEN_NO_BUFFER. This flag
01170     // applies only when the MFT marks an output stream as lazy or optional. But this
01171     // MFT has no lazy or optional streams, so the flag is not valid.
01172
01173     if (dwFlags != 0)
01174     {
01175         return E_INVALIDARG;
01176     }
01177
01178     if (pOutputSamples == NULL || pdwStatus == NULL)
01179     {
01180         return E_POINTER;
01181     }
01182
01183     // There must be exactly one output buffer.
01184     if (cOutputBufferCount != 1)
01185     {
01186         return E_INVALIDARG;
01187     }
01188
01189     // It must contain a sample.
01190     if (pOutputSamples[0].pSample == NULL)
01191     {
01192         return E_INVALIDARG;
01193     }
01194
01195     HRESULT hr = S_OK;
01196
01197     IMFMediaBuffer *pInput = NULL;
01198     IMFMediaBuffer *pOutput = NULL;
01199
01200     EnterCriticalSection(&m_critSec);
01201
01202     // There must be an input sample available for processing.
01203     if (m_pSample == NULL)
01204     {
01205         hr = MF_E_TRANSFORM_NEED_MORE_INPUT;
01206         goto done;
01207     }
01208
01209     // Initialize streaming.
01210
01211     hr = BeginStreaming();
01212     if (FAILED(hr))
01213     {
01214         goto done;
01215     }
01216
01217     // Get the input buffer.
01218     hr = m_pSample->ConvertToContiguousBuffer(&pInput);
01219     if (FAILED(hr))
01220     {
01221         goto done;
01222     }
01223
01224     // Get the output buffer.
01225     hr = pOutputSamples[0].pSample->ConvertToContiguousBuffer(&pOutput);
01226     if (FAILED(hr))
01227     {
01228         goto done;
01229     }
01230
01231     hr = OnProcessOutput(pInput, pOutput);
01232     if (FAILED(hr))
01233     {
01234         goto done;
01235     }
01236
01237     // Set status flags.
01238     pOutputSamples[0].dwStatus = 0;
01239     *pdwStatus = 0;
01240
01241
01242     // Copy the duration and time stamp from the input sample, if present.
01243
01244     LONGLONG hnsDuration = 0;
01245     LONGLONG hnsTime = 0;
01246
01247     if (SUCCEEDED(m_pSample->GetSampleDuration(&hnsDuration)))
01248     {
01249         hr = pOutputSamples[0].pSample->SetSampleDuration(hnsDuration);
01250         if (FAILED(hr))
01251         {
01252             goto done;
01253         }
01254     }
01255
01256     if (SUCCEEDED(m_pSample->GetSampleTime(&hnsTime)))
01257     {
01258         hr = pOutputSamples[0].pSample->SetSampleTime(hnsTime);
01259     }
01260
01261 done:
01262     SafeRelease(&m_pSample);   // Release our input sample.
01263     SafeRelease(&pInput);
01264     SafeRelease(&pOutput);
01265     LeaveCriticalSection(&m_critSec);
01266     return hr;
01267 }
01268
01269 // PRIVATE METHODS
01270
01271 // All methods that follow are private to this MFT and are not part of the IMFTransform interface.
01272
01273 // Create a partial media type from our list.
01274 //
01275 // dwTypeIndex: Index into the list of peferred media types.
01276 // ppmt:        Receives a pointer to the media type.
01277
01278 HRESULT CPolarEffect::OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt)
01279 {
01280     if (dwTypeIndex >= ARRAYSIZE(g_MediaSubtypes))
01281     {
01282         return MF_E_NO_MORE_TYPES;
01283     }
01284
01285     IMFMediaType *pmt = NULL;
01286
01287     HRESULT hr = MFCreateMediaType(&pmt);
01288     if (FAILED(hr))
01289     {
01290         goto done;
01291     }
01292
01293     hr = pmt->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Video);
01294     if (FAILED(hr))
01295     {
01296         goto done;
01297     }
01298
01299     hr = pmt->SetGUID(MF_MT_SUBTYPE, g_MediaSubtypes[dwTypeIndex]);
01300     if (FAILED(hr))
01301     {
01302         goto done;
01303     }
01304
01305     *ppmt = pmt;
01306     (*ppmt)->AddRef();
01307
01308 done:
01309     SafeRelease(&pmt);
01310     return hr;
01311 }
01312
01313
01314 // Validate an input media type.
01315
01316 HRESULT CPolarEffect::OnCheckInputType(IMFMediaType *pmt)
01317 {
01318     assert(pmt != NULL);
01319
01320     HRESULT hr = S_OK;
01321
01322     // If the output type is set, see if they match.
01323     if (m_pOutputType != NULL)
01324     {
01325         DWORD flags = 0;
01326         hr = pmt->IsEqual(m_pOutputType, &flags);
01327
01328         // IsEqual can return S_FALSE. Treat this as failure.
01329         if (hr != S_OK)
01330         {
01331             hr = MF_E_INVALIDMEDIATYPE;
01332         }
01333     }
01334     else
01335     {
01336         // Output type is not set. Just check this type.
01337         hr = OnCheckMediaType(pmt);
01338     }
01339     return hr;
01340 }
01341
01342
01343 // Validate an output media type.
01344
01345 HRESULT CPolarEffect::OnCheckOutputType(IMFMediaType *pmt)
01346 {
01347     assert(pmt != NULL);
01348
01349     HRESULT hr = S_OK;
01350
01351     // If the input type is set, see if they match.
01352     if (m_pInputType != NULL)
01353     {
01354         DWORD flags = 0;
01355         hr = pmt->IsEqual(m_pInputType, &flags);
01356
01357         // IsEqual can return S_FALSE. Treat this as failure.
01358         if (hr != S_OK)
01359         {
01360             hr = MF_E_INVALIDMEDIATYPE;
01361         }
01362
01363     }
01364     else
01365     {
01366         // Input type is not set. Just check this type.
01367         hr = OnCheckMediaType(pmt);
01368     }
01369     return hr;
01370 }
01371
01372
01373 // Validate a media type (input or output)
01374
01375 HRESULT CPolarEffect::OnCheckMediaType(IMFMediaType *pmt)
01376 {
01377     BOOL bFoundMatchingSubtype = FALSE;
01378
01379     // Major type must be video.
01380     GUID major_type;
01381     HRESULT hr = pmt->GetGUID(MF_MT_MAJOR_TYPE, &major_type);
01382     if (FAILED(hr))
01383     {
01384         goto done;
01385     }
01386
01387     if (major_type != MFMediaType_Video)
01388     {
01389         hr = MF_E_INVALIDMEDIATYPE;
01390         goto done;
01391     }
01392
01393     // Subtype must be one of the subtypes in our global list.
01394
01395     // Get the subtype GUID.
01396     GUID subtype;
01397     hr = pmt->GetGUID(MF_MT_SUBTYPE, &subtype);
01398     if (FAILED(hr))
01399     {
01400         goto done;
01401     }
01402
01403     // Look for the subtype in our list of accepted types.
01404     for (DWORD i = 0; i < ARRAYSIZE(g_MediaSubtypes); i++)
01405     {
01406         if (subtype == g_MediaSubtypes[i])
01407         {
01408             bFoundMatchingSubtype = TRUE;
01409             break;
01410         }
01411     }
01412
01413     if (!bFoundMatchingSubtype)
01414     {
01415         hr = MF_E_INVALIDMEDIATYPE; // The MFT does not support this subtype.
01416         goto done;
01417     }
01418
01419     // Reject single-field media types.
01420     UINT32 interlace = MFGetAttributeUINT32(pmt, MF_MT_INTERLACE_MODE, MFVideoInterlace_Progressive);
01421     if (interlace == MFVideoInterlace_FieldSingleUpper  || interlace == MFVideoInterlace_FieldSingleLower)
01422     {
01423         hr = MF_E_INVALIDMEDIATYPE;
01424     }
01425
01426 done:
01427     return hr;
01428 }
01429
01430
01431 // Set or clear the input media type.
01432 //
01433 // Prerequisite: The input type was already validated.
01434
01435 void CPolarEffect::OnSetInputType(IMFMediaType *pmt)
01436 {
01437     // if pmt is NULL, clear the type.
01438     // if pmt is non-NULL, set the type.
01439
01440     SafeRelease(&m_pInputType);
01441     m_pInputType = pmt;
01442     if (m_pInputType)
01443     {
01444         m_pInputType->AddRef();
01445     }
01446
01447     // Update the format information.
01448     UpdateFormatInfo();
01449 }
01450
01451
01452 // Set or clears the output media type.
01453 //
01454 // Prerequisite: The output type was already validated.
01455
01456 void CPolarEffect::OnSetOutputType(IMFMediaType *pmt)
01457 {
01458     // If pmt is NULL, clear the type. Otherwise, set the type.
01459
01460     SafeRelease(&m_pOutputType);
01461     m_pOutputType = pmt;
01462     if (m_pOutputType)
01463     {
01464         m_pOutputType->AddRef();
01465     }
01466 }
01467
01468
01469 // Initialize streaming parameters.
01470 //
01471 // This method is called if the client sends the MFT_MESSAGE_NOTIFY_BEGIN_STREAMING
01472 // message, or when the client processes a sample, whichever happens first.
01473
01474 HRESULT CPolarEffect::BeginStreaming()
01475 {
01476     HRESULT hr = S_OK;
01477
01478     if (m_pIndexLookup == NULL)
01479     {
01480         UINT32 unVideoArea = m_imageWidthInPixels * m_imageHeightInPixels;
01481
01482         m_pIndexLookup = new UINT32[unVideoArea];
01483
01484         if (m_pIndexLookup != NULL)
01485         {
01486             ZeroMemory( m_pIndexLookup, unVideoArea * sizeof(UINT32) );
01487
01488             GeneratePolarLookup( m_imageWidthInPixels,
01489                                  m_imageHeightInPixels,
01490                                  m_pIndexLookup );
01491         }
01492         else
01493         {
01494             hr = E_OUTOFMEMORY;
01495         }
01496     }
01497
01498     if (SUCCEEDED(hr))
01499     {
01500         m_bStreamingInitialized = true;
01501     }
01502
01503     return hr;
01504 }
01505
01506
01507 // End streaming.
01508
01509 // This method is called if the client sends an MFT_MESSAGE_NOTIFY_END_STREAMING
01510 // message, or when the media type changes. In general, it should be called whenever
01511 // the streaming parameters need to be reset.
01512
01513 HRESULT CPolarEffect::EndStreaming()
01514 {
01515     SafeArrayDelete(&m_pIndexLookup);
01516     m_bStreamingInitialized = false;
01517     return S_OK;
01518 }
01519
01520
01521
01522 // Generate output data.
01523
01524 HRESULT CPolarEffect::OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut)
01525 {
01526     BYTE *pDest = NULL;         // Destination buffer.
01527     LONG lDestStride = 0;       // Destination stride.
01528
01529     BYTE *pSrc = NULL;          // Source buffer.
01530     LONG lSrcStride = 0;        // Source stride.
01531
01532     // Helper objects to lock the buffers.
01533     VideoBufferLock inputLock(pIn);
01534     VideoBufferLock outputLock(pOut);
01535
01536     // Stride if the buffer does not support IMF2DBuffer
01537     LONG lDefaultStride = 0;
01538
01539     HRESULT hr = GetDefaultStride(m_pInputType, &lDefaultStride);
01540     if (FAILED(hr))
01541     {
01542         goto done;
01543     }
01544
01545     // Lock the input buffer.
01546     hr = inputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pSrc, &lSrcStride);
01547     if (FAILED(hr))
01548     {
01549         goto done;
01550     }
01551
01552     // Lock the output buffer.
01553     hr = outputLock.LockBuffer(lDefaultStride, m_imageHeightInPixels, &pDest, &lDestStride);
01554     if (FAILED(hr))
01555     {
01556         goto done;
01557     }
01558
01559     // Invoke the image transform function.
01560     assert (m_pTransformFn != NULL);
01561     if (m_pTransformFn)
01562     {
01563         (*m_pTransformFn)(m_pIndexLookup, pDest, lDestStride, pSrc, lSrcStride, m_imageWidthInPixels, m_imageHeightInPixels);
01564     }
01565     else
01566     {
01567         hr = E_UNEXPECTED;
01568         goto done;
01569     }
01570
01571
01572     // Set the data size on the output buffer.
01573     hr = pOut->SetCurrentLength(m_cbImageSize);
01574
01575     // The VideoBufferLock class automatically unlocks the buffers.
01576 done:
01577     return hr;
01578 }
01579
01580
01581 // Flush the MFT.
01582
01583 HRESULT CPolarEffect::OnFlush()
01584 {
01585     // For this MFT, flushing just means releasing the input sample.
01586     SafeRelease(&m_pSample);
01587     return S_OK;
01588 }
01589
01590
01591 // Update the format information. This method is called whenever the
01592 // input type is set.
01593
01594 HRESULT CPolarEffect::UpdateFormatInfo()
01595 {
01596     HRESULT hr = S_OK;
01597
01598     GUID subtype = GUID_NULL;
01599
01600     m_imageWidthInPixels = 0;
01601     m_imageHeightInPixels = 0;
01602     m_cbImageSize = 0;
01603
01604     m_pTransformFn = NULL;
01605
01606     if (m_pInputType != NULL)
01607     {
01608         hr = m_pInputType->GetGUID(MF_MT_SUBTYPE, &subtype);
01609         if (FAILED(hr))
01610         {
01611             goto done;
01612         }
01613         if (subtype == MFVideoFormat_YUY2)
01614         {
01615             m_pTransformFn = TransformImage_YUY2;
01616         }
01617         else if (subtype == MFVideoFormat_UYVY)
01618         {
01619             m_pTransformFn = TransformImage_UYVY;
01620         }
01621         else if (subtype == MFVideoFormat_NV12)
01622         {
01623             m_pTransformFn = TransformImage_NV12;
01624         }
01625         else
01626         {
01627             hr = E_UNEXPECTED;
01628             goto done;
01629         }
01630
01631         hr = MFGetAttributeSize(m_pInputType, MF_MT_FRAME_SIZE, &m_imageWidthInPixels, &m_imageHeightInPixels);
01632         if (FAILED(hr))
01633         {
01634             goto done;
01635         }
01636
01637         // Calculate the image size (not including padding)
01638         hr = GetImageSize(subtype.Data1, m_imageWidthInPixels, m_imageHeightInPixels, &m_cbImageSize);
01639     }
01640
01641 done:
01642     return hr;
01643 }
01644
01645
01646 // Create a lookup table which stores the result of polar transformation
01647
01648 // By controlling the radius (m_pRadiusTransformFn) and angle
01649 // (m_pThetaTransformFn) functions, different effects can be created
01650
01651 void CPolarEffect::GeneratePolarLookup(UINT32 unWidth,
01652                                             UINT32 unHeight,
01653                                             UINT32 *pIndexLookup )
01654 {
01655     LONG x, y;
01656     UINT32 *pIndex;
01657     LONG lMaxX, lMaxY;
01658     LONG lHalfWidth, lHalfHeight;
01659     LONG lTransDx, lTransDy;
01660     DOUBLE dRadius, dMaxRadius, dNewRadius;
01661     DOUBLE dTheta, dNewTheta;
01662
01663     assert(m_pRadiusTransformFn != NULL);
01664     assert(m_pThetaTransformFn != NULL);
01665
01666     lMaxX = (LONG)unWidth;
01667     lMaxY = (LONG)unHeight;
01668     lHalfWidth = unWidth / 2;
01669     lHalfHeight = unHeight / 2;
01670     dMaxRadius = floor( sqrtf( static_cast<float>(lHalfWidth*lHalfWidth+lHalfHeight*lHalfHeight) ) );
01671
01672     pIndex = pIndexLookup;
01673
01674     for(y = 0; y < lMaxY; y++)
01675     {
01676         for(x = 0; x < lMaxX; x++)
01677         {
01678             lTransDx = lHalfWidth - x;
01679             lTransDy = lHalfHeight - y;
01680
01681             dRadius = ceil( sqrtf( static_cast<float>(lTransDx*lTransDx + lTransDy*lTransDy) ) );
01682
01683             if( dRadius < dMaxRadius )
01684             {
01685                 dTheta = atan2f( static_cast<float> (lTransDy), static_cast<float> (lTransDx) );
01686
01687                 dNewRadius = m_pRadiusTransformFn(dRadius, dMaxRadius, dTheta);
01688                 dNewTheta = m_pThetaTransformFn(dRadius, dMaxRadius, dTheta);
01689
01690                 lTransDx = lHalfWidth - (LONG)(dNewRadius * cos(dNewTheta));
01691                 lTransDy = lHalfHeight - (LONG)(dNewRadius * sin(dNewTheta));
01692
01693                 if( 0 <= lTransDx && lTransDx < lMaxX &&
01694                     0 <= lTransDy && lTransDy < lMaxY )
01695                 {
01696                     *pIndex++ = lTransDy * lMaxX + lTransDx;
01697                 }
01698                 else
01699                 {
01700                     *pIndex++ = 0;
01701                 }
01702             }
01703             else
01704             {
01705                 *pIndex++ = 0;
01706             }
01707         }
01708     }
01709 }
01710
01711
01712 // Calculate the size of the buffer needed to store the image.
01713
01714 // fcc: The FOURCC code of the video format.
01715
01716 HRESULT GetImageSize(DWORD fcc, UINT32 width, UINT32 height, DWORD* pcbImage)
01717 {
01718     HRESULT hr = S_OK;
01719
01720     switch (fcc)
01721     {
01722     case FOURCC_YUY2:
01723     case FOURCC_UYVY:
01724         // check overflow
01725         if ((width > MAXDWORD / 2) || (width * 2 > MAXDWORD / height))
01726         {
01727             hr = E_INVALIDARG;
01728         }
01729         else
01730         {
01731             // 16 bpp
01732             *pcbImage = width * height * 2;
01733         }
01734         break;
01735
01736     case FOURCC_NV12:
01737         // check overflow
01738         if ((height/2 > MAXDWORD - height) || ((height + height/2) > MAXDWORD / width))
01739         {
01740             hr = E_INVALIDARG;
01741         }
01742         else
01743         {
01744             // 12 bpp
01745             *pcbImage = width * (height + (height/2));
01746         }
01747         break;
01748
01749     default:
01750         hr = E_FAIL;    // Unsupported type.
01751     }
01752     return hr;
01753 }
01754
01755 // Get the default stride for a video format.
01756 HRESULT GetDefaultStride(IMFMediaType *pType, LONG *plStride)
01757 {
01758     LONG lStride = 0;
01759
01760     // Try to get the default stride from the media type.
01761     HRESULT hr = pType->GetUINT32(MF_MT_DEFAULT_STRIDE, (UINT32*)&lStride);
01762     if (FAILED(hr))
01763     {
01764         // Attribute not set. Try to calculate the default stride.
01765         GUID subtype = GUID_NULL;
01766
01767         UINT32 width = 0;
01768         UINT32 height = 0;
01769
01770         // Get the subtype and the image size.
01771         hr = pType->GetGUID(MF_MT_SUBTYPE, &subtype);
01772         if (SUCCEEDED(hr))
01773         {
01774             hr = MFGetAttributeSize(pType, MF_MT_FRAME_SIZE, &width, &height);
01775         }
01776         if (SUCCEEDED(hr))
01777         {
01778             if (subtype == MFVideoFormat_NV12)
01779             {
01780                 lStride = width;
01781             }
01782             else if (subtype == MFVideoFormat_YUY2 || subtype == MFVideoFormat_UYVY)
01783             {
01784                 lStride = ((width * 2) + 3) & ~3;
01785             }
01786             else
01787             {
01788                 hr = E_INVALIDARG;
01789             }
01790         }
01791
01792         // Set the attribute for later reference.
01793         if (SUCCEEDED(hr))
01794         {
01795             (void)pType->SetUINT32(MF_MT_DEFAULT_STRIDE, UINT32(lStride));
01796         }
01797     }
01798     if (SUCCEEDED(hr))
01799     {
01800         *plStride = lStride;
01801     }
01802     return hr;
01803 }
01804
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML text display/C++/Scenario3.xaml.h Source File

  • XAML text display

Scenario3.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.h
00013 // Declaration of the Scenario3 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario3.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace TextDisplay
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario3 sealed
00031         {
00032         public:
00033             Scenario3();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Go_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/pch.h Source File

  • Direct2D perspective transform

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <d2d1_1.h>
00013 #include <d2d1effects.h>
00014 #include <dwrite_1.h>
00015 #include <wincodec.h>
00016 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/DirectXSample.h Source File

  • Direct2D convolve matrix effect

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/MainPage.xaml.h Source File

  • Background Transfer

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite font enumeration/C++,JavaScript/cpp/FontEnumerator.h Source File

  • DirectWrite font enumeration
  • C++,JavaScript
  • cpp

FontEnumerator.h

Go to the documentation of this file.
00001 ﻿#pragma once
00002
00003 namespace FontEnumeration
00004 {
00005     public ref class FontEnumerator sealed
00006     {
00007     public:
00008         Platform::Array<Platform::String^>^ ListSystemFonts();
00009     };
00010 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/StereoProjection.cpp Source File

  • XAML DirectX 3D shooting game

StereoProjection.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "StereoProjection.h"
00010
00011 #if !defined(XMASSERT)
00012 #define XMASSERT(Expression) ((void)0)
00013 #endif // !XMASSERT
00014
00015 using namespace DirectX;
00016
00017 void StereoCreateDefaultParameters(_Out_ STEREO_PARAMETERS* stereoParameters)
00018 {
00019     XMASSERT(stereoParameters != nullptr);
00020
00021     // Default assumption is 1920x1200 resolution, a 22" LCD monitor, and a 2' viewing distance
00022     stereoParameters->viewerDistanceInches = 24.0f;
00023     stereoParameters->pixelResolutionWidth = 1920.0f;
00024     stereoParameters->pixelResolutionHeight = 1024.0f; // 480.0f; // 1200
00025     stereoParameters->displaySizeInches = 22.0f;
00026
00027     stereoParameters->stereoSeparationFactor = 1.0f;
00028     stereoParameters->stereoExaggerationFactor = 1.0f;
00029 }
00030
00031 __forceinline bool _XMMatrixStereoProjectionHelper (
00032     const STEREO_PARAMETERS* stereoParameters,
00033     _Out_ float* virtualProjection,
00034     _Out_ float* zNearWidth,
00035     _Out_ float* zNearHeight,
00036     float fovAngleY,
00037     float aspectHByW,
00038     float nearZ
00039     )
00040 {
00041     // note that most people have difficulty fusing images into 3D
00042     // if the separation equals even just the human average. by
00043     // reducing the separation (interocular distance) by 1/2, we
00044     // guarantee a larger subset of people will see full 3D
00045
00046     // the conservative setting should always be used. the only problem
00047     // with the conservative setting is that the 3D effect will be less
00048     // impressive on smaller screens (which makes sense, since your eye
00049     // cannot be tricked as easily based on the smaller fov). to simulate
00050     // the effect of a larger screen, use the liberal settings (debug only)
00051
00052     // Conservative Settings: * max acuity angle: 0.8f degrees * interoc distance: 1.25 inches
00053
00054     // Liberal Settings: * max acuity angle: 1.6f degrees * interoc distance: 2.5f inches
00055
00056     // maximum visual accuity angle allowed is 3.2 degrees for
00057     // a physical scene, and 1.6 degrees for a virtual one.
00058     // thus we cannot allow an object to appear any closer to
00059     // the viewer than 1.6 degrees (divided by two for most
00060     // half-angle calculations)
00061
00062     static const float maxStereoDistance = 85; // 780 inches (should be between 10 and 20m)
00063     static const float maxVisualAcuityAngle = 0.8f * (XM_PI / 180.0f);  // radians
00064     static const float interocularDistance = 1.25f; // inches
00065
00066     bool comfortableResult = true;
00067
00068     float displayHeight = stereoParameters->displaySizeInches / sqrtf(aspectHByW * aspectHByW + 1.0f);
00069     float displayWidth = displayHeight * aspectHByW;
00070     float halfInterocular = 0.5f * interocularDistance * stereoParameters->stereoExaggerationFactor;
00071     float halfPixelWidth  = displayWidth / stereoParameters->pixelResolutionWidth * 0.5f;
00072     float halfMaximumAcuityAngle = maxVisualAcuityAngle * 0.5f * stereoParameters->stereoExaggerationFactor;
00073
00074     float maxSeparationAcuityAngle = atanf(halfInterocular / maxStereoDistance);
00075     float maxSeparationDistance = halfPixelWidth / tanf(maxSeparationAcuityAngle);
00076     float refinedMaxStereoDistance = maxStereoDistance - maxSeparationDistance;
00077     float fovHalfAngle = fovAngleY / 2.0f;
00078
00079     if (refinedMaxStereoDistance < 0.0f || maxSeparationDistance > 0.1f * maxStereoDistance)
00080     {
00081         // Pixel resolution is too low to offer a comfortable stereo experience
00082         comfortableResult = false;
00083     }
00084
00085     float refinedMaxSeparationAcuityAngle = atanf(halfInterocular / refinedMaxStereoDistance);
00086     float physicalZNearDistance = halfInterocular / tanf(halfMaximumAcuityAngle);
00087
00088     float nearZSeparation = tanf(refinedMaxSeparationAcuityAngle) * (refinedMaxStereoDistance - physicalZNearDistance);
00089
00090     *zNearHeight = cosf(fovHalfAngle) / sinf(fovHalfAngle);
00091     *zNearWidth = *zNearHeight / aspectHByW;
00092     *virtualProjection = (nearZSeparation * nearZ * (*zNearWidth * 4.0f)) / (2.0f * nearZ);
00093
00094     return comfortableResult;
00095 }
00096
00097
00098 XMMATRIX MatrixStereoProjectionFovLH (
00099     _In_opt_ const STEREO_PARAMETERS* stereoParameters,
00100     STEREO_CHANNEL channel,
00101     float fovAngleY,
00102     float aspectHByW,
00103     float nearZ,
00104     float farZ,
00105     STEREO_MODE stereoMode
00106     )
00107 {
00108     float virtualProjection = 0.0f;
00109     float zNearWidth = 0.0f;
00110     float zNearHeight = 0.0f;
00111     float invertedAngle;
00112     XMMATRIX patchedProjection;
00113     XMMATRIX proj;
00114     STEREO_PARAMETERS defaultParameters;
00115
00116     XMASSERT(channel == STEREO_CHANNEL::LEFT || channel == STEREO_CHANNEL::RIGHT);
00117     XMASSERT(stereoMode == STEREO_MODE::NORMAL || stereoMode == STEREO_MODE::INVERTED);
00118     XMASSERT(!XMScalarNearEqual(fovAngleY, 0.0f, 0.00001f * 2.0f));
00119     XMASSERT(!XMScalarNearEqual(aspectHByW, 0.0f, 0.00001f));
00120     XMASSERT(!XMScalarNearEqual(farZ, nearZ, 0.00001f));
00121
00122     proj = XMMatrixIdentity();
00123
00124     if (stereoParameters == nullptr)
00125     {
00126         StereoCreateDefaultParameters(&defaultParameters);
00127         stereoParameters = &defaultParameters;
00128     }
00129
00130     XMASSERT(pStereoParameters->stereoSeparationFactor >= 0.0f && stereoParameters->stereoSeparationFactor <= 1.0f);
00131     XMASSERT(pStereoParameters->stereoExaggerationFactor >= 1.0f && stereoParameters->stereoExaggerationFactor <= 2.0f);
00132
00133     _XMMatrixStereoProjectionHelper(stereoParameters, &virtualProjection, &zNearWidth, &zNearHeight, fovAngleY, aspectHByW, nearZ);
00134
00135     virtualProjection *= stereoParameters->stereoSeparationFactor; // incorporate developer defined bias
00136
00137     //
00138     // By applying a translation, we are forcing our cameras to be parallel
00139     //
00140
00141     invertedAngle = atanf(virtualProjection / (2.0f * nearZ));
00142
00143     proj = XMMatrixPerspectiveFovLH(fovAngleY, aspectHByW, nearZ, farZ);
00144
00145     if (channel == STEREO_CHANNEL::LEFT)
00146     {
00147         if (stereoMode > STEREO_MODE::NORMAL)
00148         {
00149             XMMATRIX rots, trans;
00150             rots = XMMatrixRotationY(invertedAngle);
00151             trans = XMMatrixTranslation(-virtualProjection, 0, 0);
00152             patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
00153         }
00154         else
00155         {
00156             XMMATRIX trans;
00157             trans = XMMatrixTranslation(-virtualProjection, 0, 0);
00158             patchedProjection = XMMatrixMultiply(trans, proj);
00159         }
00160     }
00161     else
00162     {
00163         if (stereoMode > STEREO_MODE::NORMAL)
00164         {
00165             XMMATRIX rots, trans;
00166             rots = XMMatrixRotationY(-invertedAngle);
00167             trans = XMMatrixTranslation(virtualProjection, 0, 0);
00168             patchedProjection = XMMatrixMultiply(XMMatrixMultiply(rots, trans), proj);
00169         }
00170         else
00171         {
00172             XMMATRIX trans;
00173             trans = XMMatrixTranslation(virtualProjection, 0, 0);
00174             patchedProjection = XMMatrixMultiply(trans, proj);
00175         }
00176     }
00177
00178     return patchedProjection;
00179 }
00180
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/Story.h Source File

  • Direct2D magazine app

Story.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "Element.h"
00011
00012 ref class Design;
00013
00014 //  <story> represents the root element of the entire content. It hosts a set of
00015 //  resources from the child <resource> element and a set of design templates defined
00016 //  in the child <design> elements that utilize the defined resources. The story element
00017 //  will choose the right design template based on the document's current aspect ratio.
00018 //
00019 //  Story accepts no additional markup attributes.
00020 //
00021 ref class Story : public Element
00022 {
00023 internal:
00024     virtual bool AcceptChildNode(
00025         _In_ Document^ document,
00026         _In_ Windows::Data::Xml::Dom::IXmlNode^ childXmlNode
00027         ) override;
00028
00029     Design^ GetDesign(D2D1_SIZE_F displaySize);
00030 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::IsRemoteSession::sealed Member List

This is the complete list of members for SDKSample::IsRemoteSession::sealed, including all inherited members.
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::IsRemoteSession::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::IsRemoteSession::sealed | [protected, virtual]
RemoteSession() | SDKSample::IsRemoteSession::sealed |
rootPage | SDKSample::IsRemoteSession::sealed | [private]
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Store device app for camera/C++/Constants.cpp Source File

  • Windows Store device app for camera

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace DeviceAppForWebcam;
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/S4_Autoplay.xaml.h Source File

  • Removable storage

S4_Autoplay.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // S4_Autoplay.xaml.h
00013 // Declaration of the S4_Autoplay class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "S4_Autoplay.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace RemovableStorageCPP
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class S4_Autoplay sealed
00031         {
00032         public:
00033             S4_Autoplay();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void GetImage_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void GetFirstImageFromStorageAsync(Windows::Storage::StorageFolder^ storage);
00041             void DisplayImageAsync(Windows::Storage::StorageFile^ imageFile);
00042         };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/app_cpp/Constants.h Source File

  • Custom driver access
  • app_cpp

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Custom Device Access");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML animation library/C++/App.xaml.h Source File

  • XAML animation library

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::TextDisplay::sealed Member List

This is the complete list of members for SDKSample::TextDisplay::sealed, including all inherited members.
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::TextDisplay::sealed | [private]
Default_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::TextDisplay::sealed | [private]
DoSomething_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::TextDisplay::sealed | [private]
Go_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::TextDisplay::sealed | [private]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::TextDisplay::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::TextDisplay::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::TextDisplay::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::TextDisplay::sealed | [protected, virtual]
Other_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::TextDisplay::sealed | [private]
Other_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::TextDisplay::sealed | [private]
rootPage | SDKSample::TextDisplay::sealed | [private]
Scenario1() | SDKSample::TextDisplay::sealed |
Scenario2() | SDKSample::TextDisplay::sealed |
Scenario3() | SDKSample::TextDisplay::sealed |
Scenario4() | SDKSample::TextDisplay::sealed |
Generated on Sat Nov 23 2024 16:09:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DWriteHitTesting Member List

This is the complete list of members for DWriteHitTesting, including all inherited members.
__pad0__ | DWriteHitTesting |
CreateDeviceIndependentResources() override | DWriteHitTesting | [virtual]
CreateDeviceResources() override | DWriteHitTesting | [virtual]
CreateWindowSizeDependentResources() override | DWriteHitTesting | [virtual]
Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView) | DWriteHitTesting | [virtual]
Load(_In_ Platform::String^entryPoint) | DWriteHitTesting | [virtual]
m_blackBrush | DWriteHitTesting | [private]
m_sampleOverlay | DWriteHitTesting | [private]
m_text | DWriteHitTesting | [private]
m_textFormat | DWriteHitTesting | [private]
m_textLayout | DWriteHitTesting | [private]
m_textTypography | DWriteHitTesting | [private]
m_underlineArray | DWriteHitTesting | [private]
OnActivated(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args) | DWriteHitTesting | [private]
OnDisplayContentsInvalidated(_In_ Platform::Object^sender) | DWriteHitTesting | [private]
OnLogicalDpiChanged(_In_ Platform::Object^sender) | DWriteHitTesting | [private]
OnPointerPressed(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | DWriteHitTesting | [private]
OnResuming(_In_ Platform::Object^sender, _In_ Platform::Object^args) | DWriteHitTesting | [private]
OnSuspending(_In_ Platform::Object^sender, _In_ Windows::ApplicationModel::SuspendingEventArgs^args) | DWriteHitTesting | [private]
OnWindowSizeChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args) | DWriteHitTesting | [private]
Render() override | DWriteHitTesting | [virtual]
Run() | DWriteHitTesting | [virtual]
SetUnderlineOnRedraw() | DWriteHitTesting | [private]
SetWindow(_In_ Windows::UI::Core::CoreWindow^window) | DWriteHitTesting | [virtual]
Uninitialize() | DWriteHitTesting | [virtual]
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Gyrometer sensor/C++/common/LayoutAwarePage.h Source File

  • Gyrometer sensor
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Association launching/C++/ReceiveFileOutput.xaml.h Source File

  • Association launching

ReceiveFileOutput.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ReceiveFileOutput.xaml.h
00010 // Declaration of the ReceiveFileOutput class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ReceiveFileOutput.g.h"
00017 #include "MainPage.xaml.h"
00018
00019 namespace AssociationLaunching
00020 {
00021   [Windows::Foundation::Metadata::WebHostHidden]
00022     public ref class ReceiveFileOutput sealed
00023     {
00024     public:
00025         ReceiveFileOutput();
00026
00027     protected:
00028         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030
00031     private:
00032         ~ReceiveFileOutput();
00033         MainPage^ rootPage;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:57 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SampleOverlay Member List

This is the complete list of members for SampleOverlay, including all inherited members.
__pad0__ | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
GetTitleHeightInDips() | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
Initialize(_In_ ID2D1Device *d2dDevice, _In_ ID2D1DeviceContext *d2dContext, _In_ IWICImagingFactory *wicFactory, _In_ IDWriteFactory *dwriteFactory, _In_ Platform::String^caption) | SampleOverlay |
m_d2dContext | SampleOverlay | [private]
m_d2dDevice | SampleOverlay | [private]
m_d2dFactory | SampleOverlay | [private]
m_drawOverlay | SampleOverlay | [private]
m_dwriteFactory | SampleOverlay | [private]
m_idIncrement | SampleOverlay | [private]
m_logoBitmap | SampleOverlay | [private]
m_logoSize | SampleOverlay | [private]
m_overlayWidth | SampleOverlay | [private]
m_padding | SampleOverlay | [private]
m_sampleName | SampleOverlay | [private]
m_stateBlock | SampleOverlay | [private]
m_textLayout | SampleOverlay | [private]
m_textVerticalOffset | SampleOverlay | [private]
m_whiteBrush | SampleOverlay | [private]
m_wicFactory | SampleOverlay | [private]
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render(D2D1::Matrix3x2F &transform) | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
Render() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
ResetDirectXResources() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
UpdateForWindowSizeChange() | SampleOverlay |
Generated on Sat Nov 23 2024 16:09:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: MediaStreamSource media extension/C#,C++/App.xaml.cs Source File

  • MediaStreamSource media extension
  • C#,C++

App.xaml.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using Windows.ApplicationModel;
00012 using Windows.ApplicationModel.Activation;
00013 using Windows.UI.Xaml;
00014 using Windows.UI.Xaml.Controls;
00015 using Windows.UI.Xaml.Navigation;
00016 using SDKTemplate;
00017
00018 namespace SDKTemplate
00019 {
00020     /// <summary>
00021     /// Provides application-specific behavior to supplement the default Application class.
00022     /// </summary>
00023     sealed partial class App : Application
00024     {
00025         public LaunchActivatedEventArgs LaunchArgs;
00026
00027         /// <summary>
00028         /// Initializes the singleton application object.  This is the first line of authored code
00029         /// executed, and as such is the logical equivalent of main() or WinMain().
00030         /// </summary>
00031         public App()
00032         {
00033             this.InitializeComponent();
00034             this.Suspending += new SuspendingEventHandler(OnSuspending);
00035         }
00036
00037         async void OnSuspending(object sender, SuspendingEventArgs args)
00038         {
00039             SuspendingDeferral deferral = args.SuspendingOperation.GetDeferral();
00040             await SuspensionManager.SaveAsync();
00041             deferral.Complete();
00042         }
00043
00044         /// <summary>
00045         /// Invoked when the application is launched normally by the end user.  Other entry points
00046         /// will be used when the application is launched to open a specific file, to display
00047         /// search results, and so forth.
00048         /// </summary>
00049         /// <param name="args">Details about the launch request and process.</param>
00050         async protected override void OnLaunched(LaunchActivatedEventArgs args)
00051         {
00052             this.LaunchArgs = args;
00053
00054             Frame rootFrame = null;
00055             if (args.PreviousExecutionState == ApplicationExecutionState.Terminated)
00056             {
00057                 // Do an asynchronous restore
00058                 await SuspensionManager.RestoreAsync();
00059             }
00060             if (Window.Current.Content == null)
00061             {
00062                 rootFrame = new Frame();
00063                 rootFrame.Navigate(typeof(MainPage));
00064                 Window.Current.Content = rootFrame;
00065             }
00066             Window.Current.Activate();
00067         }
00068     }
00069 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/MainPage.xaml.cpp Source File

  • StreamSocket

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Platform;
00026 using namespace StreamSocketSample;
00027 using namespace CppSamplesUtils;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     LayoutRoot->Children->Append(HiddenFrame);
00045
00046     // Populate the sample title from the constant in the GlobalVariables.cs file.
00047     SetFeatureName(FEATURE_NAME);
00048
00049     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00050     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00051
00052     MainPage::Current = this;
00053     autoSizeInputSectionWhenSnapped = true;
00054 }
00055
00056 MainPage::~MainPage()
00057 {
00058 }
00059
00060 /// <summary>
00061 /// Invoked when this page is about to be displayed in a Frame.
00062 /// </summary>
00063 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00064 /// property is typically used to configure the page.</param>
00065 void MainPage::OnNavigatedTo(NavigationEventArgs^ e)
00066 {
00067     PopulateScenarios();
00068     InvalidateViewState();
00069 }
00070
00071 /// <summary>
00072 /// We need to handle SizeChanged so that we can make the sample layout property
00073 /// in the various layouts.
00074 /// </summary>
00075 /// <param name="sender"></param>
00076 /// <param name="e"></param>
00077 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00078 {
00079     InvalidateSize();
00080     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00081     args->ViewState = ApplicationView::Value;
00082     MainPageResized(this, args);
00083
00084 }
00085
00086 void MainPage::InvalidateSize()
00087 {
00088     // Get the window width
00089     double windowWidth = this->ActualWidth;
00090
00091     if (windowWidth != 0.0)
00092     {
00093         // Get the width of the ListBox.
00094         double listBoxWidth = Scenarios->ActualWidth;
00095
00096         // Is the ListBox using any margins that we need to consider?
00097         double listBoxMarginLeft = Scenarios->Margin.Left;
00098         double listBoxMarginRight = Scenarios->Margin.Right;
00099
00100         // Figure out how much room is left after considering the list box width
00101         double availableWidth = windowWidth - listBoxWidth;
00102
00103         // Is the top most child using margins?
00104         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00105         double layoutRootMarginRight = ContentRoot->Margin.Right;
00106
00107         // We have different widths to use depending on the view state
00108         if (ApplicationView::Value != ApplicationViewState::Snapped)
00109         {
00110             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00111             // and the LayoutRoot's margins
00112             InputSection->Width = availableWidth -
00113                (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
00114         }
00115         else
00116         {
00117             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00118             if (autoSizeInputSectionWhenSnapped)
00119             {
00120                 InputSection->Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
00121             }
00122         }
00123     }
00124     InvalidateViewState();
00125 }
00126
00127 void MainPage::InvalidateViewState()
00128 {
00129     // Are we going to snapped mode?
00130     if (ApplicationView::Value == ApplicationViewState::Snapped)
00131     {
00132         Grid::SetRow(DescriptionText, 3);
00133         Grid::SetColumn(DescriptionText, 0);
00134
00135         Grid::SetRow(InputSection, 4);
00136         Grid::SetColumn(InputSection, 0);
00137
00138         Grid::SetRow(FooterPanel, 2);
00139         Grid::SetColumn(FooterPanel, 0);
00140     }
00141     else
00142     {
00143         Grid::SetRow(DescriptionText, 1);
00144         Grid::SetColumn(DescriptionText, 1);
00145
00146         Grid::SetRow(InputSection, 2);
00147         Grid::SetColumn(InputSection, 1);
00148
00149         Grid::SetRow(FooterPanel, 1);
00150         Grid::SetColumn(FooterPanel, 1);
00151     }
00152
00153 }
00154
00155 void MainPage::PopulateScenarios()
00156 {
00157     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00158
00159     // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00160     for (unsigned int i = 0; i < scenarios->Length; ++i)
00161     {
00162         Scenario s = scenarios[i];
00163         ListBoxItem^ item = ref new ListBoxItem();
00164         item->Name = s.ClassName;
00165         item->Content = (i + 1).ToString() + ") " + s.Title;
00166         ScenarioList->Append(item);
00167     }
00168
00169     // Bind the ListBox to the scenario list.
00170     Scenarios->ItemsSource = ScenarioList;
00171
00172     // Starting scenario is the first or based upon a previous selection.
00173     ListBoxItem^ startingScenario = nullptr;
00174
00175     // Starting scenario is the first or based upon a previous selection.
00176     int startingScenarioIndex = -1;
00177
00178     auto ps = SuspensionManager::SessionState();
00179     if (ps->HasKey("SelectedScenarioIndex"))
00180     {
00181         int selectedScenarioIndex = safe_cast<int>(ps->Lookup("SelectedScenarioIndex"));
00182         startingScenarioIndex = selectedScenarioIndex;
00183     }
00184
00185     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00186 }
00187
00188 /// <summary>
00189 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00190 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00191 /// and output sections into the respective UserControl on the main page.
00192 /// </summary>
00193 /// <param name="scenarioName"></param>
00194 void MainPage::LoadScenario(String^ scenarioName)
00195 {
00196     autoSizeInputSectionWhenSnapped = true;
00197
00198     // Load the ScenarioX.xaml file into the Frame.
00199     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00200     HiddenFrame->Navigate(scenarioType, this);
00201
00202     // Get the top element, the Page, so we can look up the elements
00203     // that represent the input and output sections of the ScenarioX file.
00204     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00205
00206     // Get each element.
00207     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00208     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00209
00210     if (input == nullptr)
00211     {
00212         // Malformed input section.
00213         NotifyUser("Cannot load scenario input section for " + scenarioName +
00214             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00215         return;
00216     }
00217
00218     if (output == nullptr)
00219     {
00220         // Malformed output section.
00221         NotifyUser("Cannot load scenario output section for " + scenarioName +
00222             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00223         return;
00224     }
00225     // Find the LayoutRoot which parents the input and output sections in the main page.
00226     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00227
00228     if (panel != nullptr)
00229     {
00230         unsigned int index = 0;
00231         UIElementCollection^ collection = panel->Children;
00232
00233         // Get rid of the content that is currently in the intput and output sections.
00234         collection->IndexOf(input, &index);
00235         collection->RemoveAt(index);
00236
00237         collection->IndexOf(output, &index);
00238         collection->RemoveAt(index);
00239
00240         // Populate the input and output sections with the newly loaded content.
00241         InputSection->Content = input;
00242         OutputSection->Content = output;
00243
00244         ScenarioLoaded(this, nullptr);
00245     }
00246     else
00247     {
00248         // Malformed Scenario file.
00249         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00250             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00251     }
00252 }
00253
00254 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00255 {
00256     if (Scenarios->SelectedItem != nullptr)
00257     {
00258         NotifyUser("", NotifyType::StatusMessage);
00259
00260         int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00261         SuspensionManager::SessionState()->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00262
00263         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00264         InvalidateSize();
00265     }
00266 }
00267
00268 void MainPage::SetFeatureName(String^ strFeature)
00269 {
00270     FeatureName->Text = strFeature;
00271 }
00272
00273 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00274 {
00275     switch (type)
00276     {
00277     case NotifyType::StatusMessage:
00278         // Use the status message style.
00279         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00280         break;
00281     case NotifyType::ErrorMessage:
00282         // Use the error message style.
00283         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00284         break;
00285     default:
00286         break;
00287     }
00288     StatusBlock->Text = strMessage;
00289
00290     // Collapsed the StatusBlock if it has no text to conserve real estate.
00291     if (StatusBlock->Text != "")
00292     {
00293         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00294     }
00295     else
00296     {
00297         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00298     }
00299 }
00300
00301 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00302 {
00303     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00304     Windows::System::Launcher::LaunchUriAsync(uri);
00305 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App settings/C++/common/suspensionmanager.cpp Source File

  • App settings
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Display orientation/C++/Scenario1.xaml.cpp Source File

  • Display orientation

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::DisplayOrientation;
00020
00021 using namespace Windows::Devices::Sensors;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::Graphics::Display;
00024 using namespace Windows::UI::Core;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Media;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029
00030 const double toDegrees = 180.0 / M_PI;
00031
00032 Scenario1::Scenario1()
00033 {
00034     InitializeComponent();
00035
00036     rotationAngle = 0;
00037     accelerometer = Accelerometer::GetDefault();
00038 }
00039
00040 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00041 {
00042     deviceRotation->Text = rotationAngle.ToString();
00043
00044     if (accelerometer != nullptr)
00045     {
00046         readingChangedEventToken = accelerometer->ReadingChanged::add(
00047             ref new TypedEventHandler<Accelerometer^, AccelerometerReadingChangedEventArgs^>(this, &Scenario1::CalculateDeviceRotation)
00048             );
00049     }
00050 }
00051
00052 void Scenario1::OnNavigatedFrom(NavigationEventArgs^ e)
00053 {
00054     if (accelerometer != nullptr)
00055     {
00056         accelerometer->ReadingChanged::remove(readingChangedEventToken);
00057     }
00058 }
00059
00060 void Scenario1::CalculateDeviceRotation(Accelerometer^ sender, AccelerometerReadingChangedEventArgs^ args)
00061 {
00062     // Compute the rotation angle based on the accelerometer's position
00063     auto angle = atan2(args->Reading->AccelerationY, args->Reading->AccelerationX) * toDegrees;
00064
00065     // Since our arrow points upwards insted of the right, we rotate the coordinate system by 90 degrees
00066     angle += 90;
00067
00068     // Ensure that the range of the value is between [0, 360)
00069     if (angle < 0)
00070     {
00071         angle += 360;
00072     }
00073
00074     rotationAngle = angle;
00075
00076     // Update the UI with the new value
00077     Dispatcher->RunAsync(
00078         CoreDispatcherPriority::Normal,
00079         ref new DispatchedHandler(
00080             [this]()
00081             {
00082                 deviceRotation->Text = rotationAngle.ToString();
00083             })
00084         );
00085
00086     UpdateArrowForRotation();
00087 }
00088
00089 void Scenario1::UpdateArrowForRotation()
00090 {
00091     // Obtain current rotation taking into account a Landscape first or a Portrait first device
00092     auto screenRotation = 0;
00093
00094     // Native orientation can only be Landscape or Portrait
00095     if (DisplayProperties::NativeOrientation == DisplayOrientations::Landscape)
00096     {
00097         switch (DisplayProperties::CurrentOrientation)
00098         {
00099             case DisplayOrientations::Landscape:
00100                 screenRotation = 0;
00101                 break;
00102
00103             case DisplayOrientations::Portrait:
00104                 screenRotation = 90;
00105                 break;
00106
00107             case DisplayOrientations::LandscapeFlipped:
00108                 screenRotation = 180;
00109                 break;
00110
00111             case DisplayOrientations::PortraitFlipped:
00112                 screenRotation = 270;
00113                 break;
00114
00115             default:
00116                 screenRotation = 0;
00117                 break;
00118         }
00119     }
00120     else
00121     {
00122         switch (DisplayProperties::CurrentOrientation)
00123         {
00124             case DisplayOrientations::Landscape:
00125                 screenRotation = 270;
00126                 break;
00127
00128             case DisplayOrientations::Portrait:
00129                 screenRotation = 0;
00130                 break;
00131
00132             case DisplayOrientations::LandscapeFlipped:
00133                 screenRotation = 90;
00134                 break;
00135
00136             case DisplayOrientations::PortraitFlipped:
00137                 screenRotation = 180;
00138                 break;
00139
00140             default:
00141                 screenRotation = 270;
00142                 break;
00143         }
00144     }
00145
00146     double steeringAngle = rotationAngle - screenRotation;
00147
00148     // Keep the steering angle positive
00149     if (steeringAngle < 0)
00150     {
00151         steeringAngle += 360;
00152     }
00153
00154     // Update the UI based on steering action
00155     Dispatcher->RunAsync(
00156         CoreDispatcherPriority::Normal,
00157         ref new DispatchedHandler(
00158             [this, steeringAngle]()
00159             {
00160                 RotateTransform^ transform = ref new RotateTransform();
00161                 transform->Angle = -steeringAngle;
00162                 transform->CenterX = scenario1Image->ActualWidth / 2;
00163                 transform->CenterY = scenario1Image->ActualHeight / 2;
00164
00165                 scenario1Image->RenderTransform = transform;
00166             })
00167         );
00168 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ImageViewModel.h Source File

  • Hilo C++
  • Hilo

ImageViewModel.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "ViewModelBase.h"
00010 #include "PhotoPathComparer.h"
00011
00012 namespace Hilo
00013 {
00014     interface class IPhoto;
00015     class ExceptionPolicy;
00016     class Repository;
00017
00018     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how view model classes interact
00019     // with view classes (pages) and model classes (the state and operations of business objects).
00020
00021     // The ImageViewModel class contains the presentation logic for the image view page (ImageView.xaml).
00022     [Windows::UI::Xaml::Data::Bindable]
00023     [Windows::Foundation::Metadata::WebHostHidden]
00024     public ref class ImageViewModel sealed : public ViewModelBase
00025     {
00026     internal:
00027         ImageViewModel(std::shared_ptr<Repository> repository, std::shared_ptr<ExceptionPolicy> exceptionPolicy);
00028
00029         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ stateMap) override;
00030         virtual void LoadState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ stateMap) override;
00031         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00032         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00033
00034         concurrency::task<void> QueryPhotosAsync();
00035         concurrency::task<void> QuerySinglePhotoAsync();
00036         void Initialize(Platform::String^ filePath, Windows::Foundation::DateTime fileDate, Platform::String^ query);
00037         Platform::String^ GetStateFilePath();
00038         Platform::String^ GetStateQuery();
00039         Windows::Foundation::DateTime GetStateFileDate();
00040
00041     public:
00042         virtual ~ImageViewModel();
00043
00044         property Windows::Foundation::Collections::IObservableVector<IPhoto^>^ Photos
00045         {
00046             Windows::Foundation::Collections::IObservableVector<IPhoto^>^ get();
00047         }
00048
00049         property Platform::Object^ SelectedItem
00050         {
00051             Platform::Object^ get();
00052             void set(Platform::Object^ value);
00053         }
00054
00055         property Platform::String^ MonthAndYear
00056         {
00057             Platform::String^ get();
00058         }
00059
00060         property Windows::UI::Xaml::Input::ICommand^ CropImageCommand
00061         {
00062             Windows::UI::Xaml::Input::ICommand^ get();
00063         }
00064
00065         property Windows::UI::Xaml::Input::ICommand^ RotateImageCommand
00066         {
00067             Windows::UI::Xaml::Input::ICommand^ get();
00068         }
00069
00070         property Windows::UI::Xaml::Input::ICommand^ CartoonizeImageCommand
00071         {
00072             Windows::UI::Xaml::Input::ICommand^ get();
00073         }
00074
00075     private:
00076         std::shared_ptr<Repository> m_repository;
00077         bool m_runningQuerySinglePhotoAsync;
00078         bool m_runningQueryPhotosAsync;
00079         Windows::Foundation::DateTime m_fileDate;
00080         Platform::String^ m_filePath;
00081         Platform::String^ m_query;
00082         IPhoto^ m_photo;
00083         Platform::Collections::Vector<IPhoto^, PhotoPathComparer>^ m_photos;
00084         concurrency::cancellation_token_source m_photosCts;
00085         concurrency::cancellation_token_source m_photoCts;
00086         Windows::UI::Xaml::Input::ICommand^ m_cropImageCommand;
00087         Windows::UI::Xaml::Input::ICommand^ m_rotateImageCommand;
00088         Windows::UI::Xaml::Input::ICommand^ m_cartoonizeImageCommand;
00089         bool m_receivedChangeWhileRunning;
00090
00091         void CropImage(Platform::Object^ parameter);
00092         void RotateImage(Platform::Object^ parameter);
00093         void CartoonizeImage(Platform::Object^ parameter);
00094         bool CanProcessImage(Object^ parameter);
00095         void OnDataChanged();
00096         void ClearCachedData();
00097     };
00098 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Level6 Member List

This is the complete list of members for Level6, including all inherited members.
__pad0__ | Level6 |
Initialize(std::vector< GameObject^> objects) override | Level5 | [virtual]
Initialize(std::vector< GameObject^> objects) override | Level5 | [virtual]
Update(float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override | Level6 | [virtual]
Update(float time, float elapsedTime, float timeRemaining, std::vector< GameObject^> objects) override | Level6 | [virtual]
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Web authentication broker/C++/Scenario2.xaml.h Source File

  • Web authentication broker

Scenario2.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2.xaml.h
00013 // Declaration of the Scenario2 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace WebAuthentication
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Launch_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/MainPage.xaml.h Source File

  • Windows Audio Session (WASAPI)
  • C++

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ContactPicker::Scenario Member List

This is the complete list of members for ContactPicker::Scenario, including all inherited members.
ClassName | ContactPicker::Scenario
Title | ContactPicker::Scenario
Generated on Sat Nov 23 2024 16:09:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/ScenarioInput4.xaml.cpp Source File

  • Media extensions

ScenarioInput4.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // ScenarioInput4.xaml.cpp
00010 // Implementation of the ScenarioInput4 class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput4.xaml.h"
00015
00016 using namespace MediaExtensionsCPP;
00017
00018 using namespace Platform;
00019 using namespace Platform::Collections;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioInput4::ScenarioInput4()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioInput4::~ScenarioInput4()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioInput4::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Get a pointer to our main page.
00045     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047     // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048     _frameLoadedToken = rootPage->OutputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioInput4::rootPage_OutputFrameLoaded);
00049 }
00050
00051 void ScenarioInput4::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00054 }
00055
00056 #pragma endregion
00057
00058 #pragma region Event handlers
00059 void ScenarioInput4::rootPage_OutputFrameLoaded(Object^ sender, Object^ e)
00060 {
00061     // Get a pointer to the content within the OutputFrame.
00062     Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00063
00064     // Go find the elements that we need for this scenario.
00065     outputVideo = dynamic_cast<MediaElement^>(outputFrame->FindName("Video"));
00066
00067 }
00068
00069 void ScenarioInput4::OpenGrayscale_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00070 {
00071     outputVideo->RemoveAllEffects();
00072     outputVideo->AddVideoEffect("GrayscaleTransform.GrayscaleEffect", true, nullptr);
00073
00074     auto v = ref new Vector<String^>();
00075     v->Append(".mp4");
00076     v->Append(".wmv");
00077     v->Append(".avi");
00078     auto me = ref new Vector<MediaElement^>();
00079     me->Append(outputVideo);
00080     rootPage->PickSingleFileAndSet(v, me);
00081 }
00082
00083 void ScenarioInput4::OpenFisheye_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00084 {
00085     OpenVideoWithPolarEffect("Fisheye");
00086 }
00087
00088 void ScenarioInput4::OpenPinch_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00089 {
00090     OpenVideoWithPolarEffect("Pinch");
00091 }
00092
00093 void ScenarioInput4::OpenWarp_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00094 {
00095     OpenVideoWithPolarEffect("Warp");
00096 }
00097
00098 void ScenarioInput4::OpenInvert_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00099 {
00100     outputVideo->RemoveAllEffects();
00101     outputVideo->AddVideoEffect("InvertTransform.InvertEffect", true, nullptr);
00102
00103     auto v = ref new Vector<String^>();
00104     v->Append(".mp4");
00105     v->Append(".wmv");
00106     v->Append(".avi");
00107     auto me = ref new Vector<MediaElement^>();
00108     me->Append(outputVideo);
00109     rootPage->PickSingleFileAndSet(v, me);
00110 }
00111
00112 void ScenarioInput4::Stop_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00113 {
00114     outputVideo->Source = nullptr;
00115 }
00116 #pragma endregion
00117
00118 void ScenarioInput4::OpenVideoWithPolarEffect(String^ effectName)
00119 {
00120     outputVideo->RemoveAllEffects();
00121     auto configuration = ref new PropertySet();
00122     configuration->Insert("effect", effectName);
00123     outputVideo->AddVideoEffect("PolarTransform.PolarEffect", true, configuration);
00124
00125     auto v = ref new Vector<String^>();
00126     v->Append(".mp4");
00127     v->Append(".wmv");
00128     v->Append(".avi");
00129     auto me = ref new Vector<MediaElement^>();
00130     me->Append(outputVideo);
00131     rootPage->PickSingleFileAndSet(v, me);
00132 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupVideoStream.xaml.h Source File

  • HomeGroup app

HomeGroupVideoStream.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // HomeGroupVideoStream.xaml.h
00013 // Declaration of the HomeGroupVideoStream class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "HomeGroupVideoStream.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace HomeGroup
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class HomeGroupVideoStream sealed
00031         {
00032         public:
00033             HomeGroupVideoStream();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/FontLoader.h Source File

  • Direct2D magazine app

FontLoader.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <vector>
00011
00012 class FontFileStream;
00013
00014 ref class Document;
00015
00016 //  This class implements the font collection and font file loader interfaces
00017 //  for DirectWrite to call to load document/application-specific font to the
00018 //  system. The font loader's lifetime is tied to the factory it's registered to.
00019 class FontLoader :  public IDWriteFontCollectionLoader,
00020                     public IDWriteFontFileEnumerator,
00021                     public IDWriteFontFileLoader
00022 {
00023 public:
00024     FontLoader(
00025         _In_ Windows::Storage::StorageFolder^ location,
00026         _In_ IDWriteFactory* dwriteFactory
00027         );
00028
00029     concurrency::task<void> LoadAsync();
00030
00031     // IUnknown
00032     virtual HRESULT STDMETHODCALLTYPE QueryInterface(
00033         REFIID uuid,
00034         _Outptr_ void** object
00035         ) override;
00036
00037     virtual ULONG STDMETHODCALLTYPE AddRef() override;
00038
00039     virtual ULONG STDMETHODCALLTYPE Release() override;
00040
00041     // IDWriteFontCollectionLoader
00042     virtual HRESULT STDMETHODCALLTYPE CreateEnumeratorFromKey(
00043         _In_ IDWriteFactory* factory,
00044         _In_reads_bytes_(fontCollectionKeySize) void const* fontCollectionKey,
00045         uint32 fontCollectionKeySize,
00046         _Outptr_ IDWriteFontFileEnumerator** fontFileEnumerator
00047         ) override;
00048
00049     // IDWriteFontFileEnumerator
00050     virtual HRESULT STDMETHODCALLTYPE MoveNext(OUT BOOL* hasCurrentFile) override;
00051
00052     virtual HRESULT STDMETHODCALLTYPE GetCurrentFontFile(OUT IDWriteFontFile** currentFontFile) override;
00053
00054     // IDWriteFontFileLoader
00055     virtual HRESULT STDMETHODCALLTYPE CreateStreamFromKey(
00056         _In_reads_bytes_(fontFileReferenceKeySize) void const* fontFileReferenceKey,
00057         uint32 fontFileReferenceKeySize,
00058         _Outptr_ IDWriteFontFileStream** fontFileStream
00059         ) override;
00060
00061 private:
00062     // Reference counter
00063     ULONG m_refCount;
00064
00065     // Storage location of the font file(s) to load
00066     Windows::Storage::StorageFolder^ m_location;
00067
00068     // Number of font files in the storage location
00069     size_t m_fontFileCount;
00070
00071     // A list of font file streams loaded
00072     std::vector<Microsoft::WRL::ComPtr<FontFileStream>> m_fontFileStreams;
00073
00074     // Index to the current font file stream in the loaded list
00075     size_t m_fontFileStreamIndex;
00076
00077     // Current DirectWrite font file being indexed
00078     Microsoft::WRL::ComPtr<IDWriteFontFile> m_currentFontFile;
00079
00080     // DirectWrite factory
00081     Microsoft::WRL::ComPtr<IDWriteFactory> m_dwriteFactory;
00082 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/CylinderMesh.cpp Source File

  • XAML DirectX 3D shooting game

CylinderMesh.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "CylinderMesh.h"
00010 #include "DirectXSample.h"
00011 #include "ConstantBuffers.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace DirectX;
00015
00016 CylinderMesh::CylinderMesh(_In_ ID3D11Device *device, uint32 segments)
00017 {
00018     D3D11_BUFFER_DESC bd = {0};
00019     D3D11_SUBRESOURCE_DATA initData = {0};
00020
00021     uint32 numVertices = 6 * (segments + 1) + 1;
00022     uint32 numIndices = 3 * segments * 3 * 2;
00023
00024     std::vector<PNTVertex> point(numVertices);
00025     std::vector<uint16> index(numIndices);
00026
00027     uint32 p = 0;
00028     // Top center point (multiple points for texture coordinates).
00029     for (uint32 a = 0; a <= segments; a++)
00030     {
00031         point[p].position = XMFLOAT3(0.0f, 0.0f, 1.0f);
00032         point[p].normal = XMFLOAT3(0.0f, 0.0f, 1.0f);
00033         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 0.0f);
00034         p++;
00035     }
00036     // Top edge of cylinder: Normals point up for lighting of top surface.
00037     for (uint32 a = 0; a <= segments; a++)
00038     {
00039         float angle = static_cast<float>(a) / static_cast<float>(segments) * XM_2PI;
00040         point[p].position = XMFLOAT3(cos(angle), sin(angle), 1.0f);
00041         point[p].normal = XMFLOAT3(0.0f, 0.0f, 1.0f);
00042         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 0.0f);
00043         p++;
00044     }
00045     // Top edge of cylinder: Normals point out for lighting of the side surface.
00046     for (uint32 a = 0; a <= segments; a++)
00047     {
00048         float angle = static_cast<float>(a) / static_cast<float>(segments) * XM_2PI;
00049         point[p].position = XMFLOAT3(cos(angle), sin(angle), 1.0f);
00050         point[p].normal = XMFLOAT3(cos(angle), sin(angle), 0.0f);
00051         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 0.0f);
00052         p++;
00053     }
00054     // Bottom edge of cylinder: Normals point out for lighting of the side surface.
00055     for (uint32 a = 0; a <= segments; a++)
00056     {
00057         float angle = static_cast<float>(a) / static_cast<float>(segments) * XM_2PI;
00058         point[p].position = XMFLOAT3(cos(angle), sin(angle), 0.0f);
00059         point[p].normal = XMFLOAT3(cos(angle), sin(angle), 0.0f);
00060         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 1.0f);
00061         p++;
00062     }
00063     // Bottom edge of cylinder: Normals point down for lighting of the bottom surface.
00064     for (uint32 a = 0; a <= segments; a++)
00065     {
00066         float angle = static_cast<float>(a) / static_cast<float>(segments) * XM_2PI;
00067         point[p].position = XMFLOAT3(cos(angle), sin(angle), 0.0f);
00068         point[p].normal = XMFLOAT3(0.0f, 0.0f, -1.0f);
00069         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 1.0f);
00070         p++;
00071     }
00072     // Bottom center of cylinder: Normals point down for lighting on the bottom surface.
00073     for (uint32 a = 0; a <= segments; a++)
00074     {
00075         point[p].position = XMFLOAT3(0.0f, 0.0f, 0.0f);
00076         point[p].normal = XMFLOAT3(0.0f, 0.0f, -1.0f);
00077         point[p].textureCoordinate = XMFLOAT2(static_cast<float>(a) / static_cast<float>(segments), 1.0f);
00078         p++;
00079     }
00080     m_vertexCount = p;
00081
00082     p = 0;
00083     for (uint16 a = 0; a < 6; a += 2)
00084     {
00085         uint16 p1 = a*(segments + 1);
00086         uint16 p2 = (a+1)*(segments + 1);
00087         for (uint16 b = 0; b < segments; b++)
00088         {
00089             if (a < 4)
00090             {
00091                 index[p] = b + p1;
00092                 index[p+1] = b + p2;
00093                 index[p+2] = b + p2 + 1;
00094                 p = p + 3;
00095             }
00096             if (a > 0)
00097             {
00098                 index[p] = b + p1;
00099                 index[p+1] = b + p2 + 1;
00100                 index[p+2] = b + p1 + 1;
00101                 p = p + 3;
00102             }
00103         }
00104     }
00105     m_indexCount = p;
00106
00107     bd.Usage = D3D11_USAGE_DEFAULT;
00108     bd.ByteWidth = sizeof(PNTVertex) * m_vertexCount;
00109     bd.BindFlags = D3D11_BIND_VERTEX_BUFFER;
00110     bd.CPUAccessFlags = 0;
00111     initData.pSysMem = point.data();
00112     DX::ThrowIfFailed(
00113         device->CreateBuffer(&bd, &initData, &m_vertexBuffer)
00114         );
00115
00116     bd.Usage = D3D11_USAGE_DEFAULT;
00117     bd.ByteWidth = sizeof(uint16) * m_indexCount;
00118     bd.BindFlags = D3D11_BIND_INDEX_BUFFER;
00119     bd.CPUAccessFlags = 0;
00120     initData.pSysMem = index.data();
00121     DX::ThrowIfFailed(
00122         device->CreateBuffer(&bd, &initData, &m_indexBuffer)
00123         );
00124 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Device enumeration/C++/Interfaces.xaml.cpp Source File

  • Device enumeration

Interfaces.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Interfaces.xaml.cpp
00013 // Implementation of the Interfaces class
00014 //
00015
00016 #include "pch.h"
00017 #include "Interfaces.xaml.h"
00018
00019 using namespace SDKSample::DeviceEnumeration;
00020
00021 Interfaces::Interfaces()
00022 {
00023     InitializeComponent();
00024 }
00025
00026 void Interfaces::InterfaceClasses_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ eventArgs)
00027 {
00028     if (InterfaceClasses->SelectedItem->Equals(PrinterInterfaceClass))
00029     {
00030         InterfaceClassGuid->Text = "{0ECEF634-6EF0-472A-8085-5AD023ECBCCD}";
00031     }
00032     else if (InterfaceClasses->SelectedItem->Equals(WebcamInterfaceClass))
00033     {
00034         InterfaceClassGuid->Text = "{E5323777-F976-4F5B-9B55-B94699C46E44}";
00035     }
00036     else if (InterfaceClasses->SelectedItem->Equals(WpdInterfaceClass))
00037     {
00038         InterfaceClassGuid->Text = "{6AC27878-A6FA-4155-BA85-F98F491D4F33}";
00039     }
00040 }
00041
00042 void Interfaces::EnumerateDeviceInterfaces(Object^ sender, RoutedEventArgs^ eventArgs)
00043 {
00044     Windows::UI::Xaml::FocusState focusState = EnumerateInterfacesButton->FocusState;
00045     EnumerateInterfacesButton->IsEnabled = false;
00046
00047     DeviceInterfacesOutputList->Items->Clear();
00048
00049     try
00050     {
00051         auto selector = "System.Devices.InterfaceClassGuid:=\"" + InterfaceClassGuid->Text + "\"";
00052         //                 + " AND System.Devices.InterfaceEnabled:=System.StructuredQueryType.Boolean#True";
00053
00054         task<DeviceInformationCollection^>(DeviceInformation::FindAllAsync(selector, nullptr))
00055             .then([this](DeviceInformationCollection^ interfaces)
00056         {
00057             rootPage->NotifyUser(interfaces->Size + " device interface(s) found\n\n", NotifyType::StatusMessage);
00058
00059             std::for_each(begin(interfaces), end(interfaces),
00060                 [this](DeviceInformation^ deviceInterface)
00061             {
00062                 DisplayDeviceInterface(deviceInterface);
00063             });
00064
00065         });
00066     }
00067     catch (InvalidArgumentException^)
00068     {
00069         //The InvalidArgumentException gets thrown by FindAllAsync when the GUID isn't formatted properly
00070         //The only reason we're catching it here is because the user is allowed to enter GUIDs without validation
00071         //In normal usage of the API, this exception handling probably wouldn't be necessary when using known-good GUIDs
00072
00073         rootPage->NotifyUser("Caught ArgumentException. Verify that you've entered a valid interface class GUID.", NotifyType::ErrorMessage);
00074     }
00075
00076     EnumerateInterfacesButton->IsEnabled = true;
00077     EnumerateInterfacesButton->Focus(focusState);
00078 }
00079
00080 void Interfaces::DisplayDeviceInterface(DeviceInformation^ deviceInterface)
00081 {
00082     String^ id = "Id: " + deviceInterface->Id;
00083     String^ name = deviceInterface->Name;
00084     String^ isEnabled = (deviceInterface->IsEnabled) ? "IsEnabled: True" : "IsEnabled: False";
00085
00086     auto item = ref new InterfaceDisplayItem(id, name, isEnabled);
00087
00088     DeviceInterfacesOutputList->Items->Append(item);
00089
00090     task<DeviceThumbnail^>(deviceInterface->GetThumbnailAsync())
00091         .then([item](DeviceThumbnail^ thumbnail)
00092     {
00093         item->Thumbnail->SetSource(thumbnail);
00094     });
00095
00096     task<DeviceThumbnail^>(deviceInterface->GetGlyphThumbnailAsync())
00097         .then([item](DeviceThumbnail^ glyphThumbnail)
00098     {
00099         item->GlyphThumbnail->SetSource(glyphThumbnail);
00100     });
00101 }
00102
00103 /// <summary>
00104 /// Invoked when this page is about to be displayed in a Frame.
00105 /// </summary>
00106 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00107 /// property is typically used to configure the page.</param>
00108 void Interfaces::OnNavigatedTo(NavigationEventArgs^ e)
00109 {
00110     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00111     // as NotifyUser()
00112     rootPage = MainPage::Current;
00113 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario8.xaml.cpp Source File

  • XAML data binding

Scenario8.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario8.xaml.cpp
00013 // Implementation of the Scenario8 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario8.xaml.h"
00018 #include "Team.h"
00019
00020 using namespace SDKSample::DataBinding;
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::Foundation::Collections;
00024 using namespace Windows::Graphics::Display;
00025 using namespace Windows::UI::ViewManagement;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Controls::Primitives;
00029 using namespace Windows::UI::Xaml::Data;
00030 using namespace Windows::UI::Xaml::Input;
00031 using namespace Windows::UI::Xaml::Media;
00032 using namespace Windows::UI::Xaml::Navigation;
00033
00034 Scenario8::Scenario8()
00035 {
00036     InitializeComponent();
00037   Scenario8Reset(nullptr,nullptr);
00038 }
00039
00040 void SDKSample::DataBinding::Scenario8::Scenario8Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00041 {
00042     if(employees != nullptr)
00043   {
00044     employees->VectorChanged -= vectorChangedHandlerToken;
00045   }
00046
00047   employees = ref new GeneratorIncrementalLoadingClass(1000);
00048   vectorChangedHandlerToken = employees->VectorChanged += ref new BindableVectorChangedEventHandler(this, &Scenario8::BindableVectorChanged);
00049
00050   employeesCVS->Source = employees;
00051
00052     tbCollectionChangeStatus->Text = "";
00053
00054 }
00055
00056 void SDKSample::DataBinding::Scenario8::BindableVectorChanged(Windows::UI::Xaml::Interop::IBindableObservableVector^ sender, Object^ e)
00057 {
00058   tbCollectionChangeStatus->Text = "Collection was changed. Count = " + employees->Size;
00059 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CInvert Member List

This is the complete list of members for CInvert, including all inherited members.
AddInputStreams(DWORD cStreams, DWORD *adwStreamIDs) | CInvert | [inline, private]
AddInputStreams(DWORD cStreams, DWORD *adwStreamIDs) | CInvert | [inline, private]
BeginStreaming() | CInvert | [private]
BeginStreaming() | CInvert | [private]
CheckDX11Device() | CInvert | [private]
CheckDX11Device() | CInvert | [private]
DeleteInputStream(DWORD dwStreamID) | CInvert | [inline, private]
DeleteInputStream(DWORD dwStreamID) | CInvert | [inline, private]
GetAttributes(IMFAttributes **pAttributes) | CInvert | [private]
GetAttributes(IMFAttributes **pAttributes) | CInvert | [private]
GetInputAvailableType(DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CInvert | [private]
GetInputAvailableType(DWORD dwInputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CInvert | [private]
GetInputCurrentType(DWORD dwInputStreamID, IMFMediaType **ppType) | CInvert | [private]
GetInputCurrentType(DWORD dwInputStreamID, IMFMediaType **ppType) | CInvert | [private]
GetInputStatus(DWORD dwInputStreamID, DWORD *pdwFlags) | CInvert | [private]
GetInputStatus(DWORD dwInputStreamID, DWORD *pdwFlags) | CInvert | [private]
GetInputStreamAttributes(DWORD dwInputStreamID, IMFAttributes **ppAttributes) | CInvert | [inline, private]
GetInputStreamAttributes(DWORD dwInputStreamID, IMFAttributes **ppAttributes) | CInvert | [inline, private]
GetInputStreamInfo(DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo) | CInvert | [private]
GetInputStreamInfo(DWORD dwInputStreamID, MFT_INPUT_STREAM_INFO *pStreamInfo) | CInvert | [private]
GetOutputAvailableType(DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CInvert | [private]
GetOutputAvailableType(DWORD dwOutputStreamID, DWORD dwTypeIndex, IMFMediaType **ppType) | CInvert | [private]
GetOutputCurrentType(DWORD dwOutputStreamID, IMFMediaType **ppType) | CInvert | [private]
GetOutputCurrentType(DWORD dwOutputStreamID, IMFMediaType **ppType) | CInvert | [private]
GetOutputStatus(DWORD *pdwFlags) | CInvert | [private]
GetOutputStatus(DWORD *pdwFlags) | CInvert | [private]
GetOutputStreamAttributes(DWORD dwOutputStreamID, IMFAttributes **ppAttributes) | CInvert | [private]
GetOutputStreamAttributes(DWORD dwOutputStreamID, IMFAttributes **ppAttributes) | CInvert | [private]
GetOutputStreamInfo(DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo) | CInvert | [private]
GetOutputStreamInfo(DWORD dwOutputStreamID, MFT_OUTPUT_STREAM_INFO *pStreamInfo) | CInvert | [private]
GetStreamCount(DWORD *pcInputStreams, DWORD *pcOutputStreams) | CInvert | [private]
GetStreamCount(DWORD *pcInputStreams, DWORD *pcOutputStreams) | CInvert | [private]
GetStreamIDs(DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs) | CInvert | [inline, private]
GetStreamIDs(DWORD dwInputIDArraySize, DWORD *pdwInputIDs, DWORD dwOutputIDArraySize, DWORD *pdwOutputIDs) | CInvert | [inline, private]
GetStreamLimits(DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum) | CInvert | [private]
GetStreamLimits(DWORD *pdwInputMinimum, DWORD *pdwInputMaximum, DWORD *pdwOutputMinimum, DWORD *pdwOutputMaximum) | CInvert | [private]
InvalidateDX11Resources() | CInvert | [private]
InvalidateDX11Resources() | CInvert | [private]
m_bStreamingInitialized | CInvert | [private]
m_cbImageSize | CInvert | [private]
m_critSec | CInvert | [private]
m_hDeviceHandle | CInvert | [private]
m_imageHeightInPixels | CInvert | [private]
m_imageWidthInPixels | CInvert | [private]
m_pAttributes | CInvert | [private]
m_pContext | CInvert | [private]
m_pDevice | CInvert | [private]
m_pDX11Manager | CInvert | [private]
m_pInBufferTex | CInvert | [private]
m_pInputType | CInvert | [private]
m_pOutBufferStage | CInvert | [private]
m_pOutBufferTex | CInvert | [private]
m_pOutputType | CInvert | [private]
m_pSample | CInvert | [private]
m_pTransform | CInvert | [private]
m_spOutputAttributes | CInvert | [private]
m_spOutputSampleAllocator | CInvert | [private]
OnCheckInputType(IMFMediaType *pmt) | CInvert | [private]
OnCheckInputType(IMFMediaType *pmt) | CInvert | [private]
OnCheckMediaType(IMFMediaType *pmt) | CInvert | [private]
OnCheckMediaType(IMFMediaType *pmt) | CInvert | [private]
OnCheckOutputType(IMFMediaType *pmt) | CInvert | [private]
OnCheckOutputType(IMFMediaType *pmt) | CInvert | [private]
OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt) | CInvert | [private]
OnGetPartialType(DWORD dwTypeIndex, IMFMediaType **ppmt) | CInvert | [private]
OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut) | CInvert | [private]
OnProcessOutput(IMFMediaBuffer *pIn, IMFMediaBuffer *pOut) | CInvert | [private]
ProcessEvent(DWORD dwInputStreamID, IMFMediaEvent *pEvent) | CInvert | [inline, private]
ProcessEvent(DWORD dwInputStreamID, IMFMediaEvent *pEvent) | CInvert | [inline, private]
ProcessInput(DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags) | CInvert | [private]
ProcessInput(DWORD dwInputStreamID, IMFSample *pSample, DWORD dwFlags) | CInvert | [private]
ProcessMessage(MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam) | CInvert | [private]
ProcessMessage(MFT_MESSAGE_TYPE eMessage, ULONG_PTR ulParam) | CInvert | [private]
ProcessOutput(DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus) | CInvert | [private]
ProcessOutput(DWORD dwFlags, DWORD cOutputBufferCount, MFT_OUTPUT_DATA_BUFFER *pOutputSamples, DWORD *pdwStatus) | CInvert | [private]
RuntimeClassInitialize() | CInvert | [private]
RuntimeClassInitialize() | CInvert | [private]
SetInputType(DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags) | CInvert | [private]
SetInputType(DWORD dwInputStreamID, IMFMediaType *pType, DWORD dwFlags) | CInvert | [private]
SetOutputBounds(LONGLONG hnsLowerBound, LONGLONG hnsUpperBound) | CInvert | [inline, private]
SetOutputBounds(LONGLONG hnsLowerBound, LONGLONG hnsUpperBound) | CInvert | [inline, private]
SetOutputType(DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags) | CInvert | [private]
SetOutputType(DWORD dwOutputStreamID, IMFMediaType *pType, DWORD dwFlags) | CInvert | [private]
SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration) | CInvert | [private]
SetProperties(ABI::Windows::Foundation::Collections::IPropertySet *pConfiguration) | CInvert | [private]
UpdateDX11Device() | CInvert | [private]
UpdateDX11Device() | CInvert | [private]
UpdateFormatInfo() | CInvert | [private]
UpdateFormatInfo() | CInvert | [private]
~CInvert() | CInvert | [private]
~CInvert() | CInvert | [private]
Generated on Sat Nov 23 2024 16:09:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Lock screen personalization/C++/pch.h Source File

  • Lock screen personalization

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D post-processing effects/C++/DDSTextureLoader.h Source File

  • Direct3D post-processing effects

DDSTextureLoader.h

Go to the documentation of this file.
00001 //--------------------------------------------------------------------------------------
00002 // File: DDSTextureLoader.h
00003 //
00004 // Function for loading a DDS texture and creating a Direct3D 11 runtime resource for it
00005 //
00006 // Note this function is useful as a light-weight runtime loader for DDS files. For
00007 // a full-featured DDS file reader, writer, and texture processing pipeline see
00008 // the 'Texconv' sample and the 'DirectXTex' library.
00009 //
00010 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00011 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00012 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00013 // PARTICULAR PURPOSE.
00014 //
00015 // Copyright (c) Microsoft Corporation. All rights reserved.
00016 //--------------------------------------------------------------------------------------
00017
00018 #pragma once
00019
00020 void CreateDDSTextureFromMemory(
00021     _In_ ID3D11Device* d3dDevice,
00022     _In_reads_bytes_(ddsDataSize) const byte* ddsData,
00023     _In_ size_t ddsDataSize,
00024     _Out_opt_ ID3D11Resource** texture,
00025     _Out_opt_ ID3D11ShaderResourceView** textureView,
00026     _In_ size_t maxsize = 0
00027     );
Generated on Sat Nov 23 2024 16:08:11 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Inclinometer sensor/C++/common/LayoutAwarePage.h Source File

  • Inclinometer sensor
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/MoveLookController.h Source File

  • XAML DirectX 3D shooting game

MoveLookController.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // MoveLookController:
00011 // This is the class that handles input events and turns it into player
00012 // intent.  It aggregates, mouse, keyboard, touch and Xbox controller input into
00013 // a unified single controller.
00014 // The controller has three modes of operation:
00015 //     None - the controller is not active and all input is ignored.
00016 //     WaitForInput - the controller is waiting for the player to acknowledge
00017 //         a message from the app.  Only a left mouse click or touch event
00018 //         in the rectangle specified in the WaitForPress method or the
00019 //         'Start' button has been pressed on the Xbox controller will
00020 //         result in IsPressComplete returning true.
00021 //     Active - the controller is in active game play mode.
00022 //
00023 // This class registers input handlers directly with the CoreWindow object
00024 // in the Initialize method.  It installs input handlers for the following events:
00025 //     PointerPressed
00026 //     PointerMoved
00027 //     PointerReleased
00028 //     PointerExited
00029 //     KeyDown
00030 //     KeyUp
00031 //     MouseMoved
00032 //
00033 // During 'Active' mode, the controller will put the mouse into relative mouse
00034 // mode by turning off the pointer cursor.  In this mode the controller separates
00035 // mouse movement from pointer movement and uses the relative mouse movements to
00036 // update the controller for the Look Control.
00037 //
00038 // The touch portion of the MoveLookController divides the window area of the app
00039 // into three distinct regions:
00040 //     MoveRect - the rectangle of the screen where touch input is converted into
00041 //         a virtual joystick where the vertical motion will be translated into
00042 //         forward/backward position motion and horizontal motion will be translated
00043 //         into left/right position motion.
00044 //     FireRect - the rectangle of the screen where touch input will be converted
00045 //         into a fire button.  A touch sequence of PointerPressed will result in
00046 //         IsFiring method to return true in AutoFire mode, otherwise a PointPressed
00047 //         followed by a PointerReleased event in the FireRect will result in the
00048 //         IsFiring method returning true once.
00049 //     Outside MoveRect & FireRect - this area of the screen controls the Look control
00050 //         and updates the LookDirection.
00051 //
00052 // The following controls are mapped from the Xbox controller using XInput:
00053 //     XINPUT_GAMEPAD_START - is mapped to IsPressComplete in the WaitForInput state and
00054 //         IsPauseRequested in the Active state.
00055 //     Left Thumb stick - is mapped to the move control in Active mode
00056 //     Right Thumb stick - is mapped to the look control in Active mode
00057 //     Right Trigger - is mapped to IsFiring in Active mode or "Fire" button.
00058 //
00059 // The keyboard/mouse are used as a pair to provide a typical PC gaming input model in Active
00060 // mode:
00061 //     Mouse - is mapped to the look control.  Left mouse is mapped to IsFiring or 'Fire' button
00062 //     W key - is mapped to the 'forward' motion of the move control
00063 //     S key - is mapped to the 'back' motion of the move control
00064 //     A key - is mapped to the 'left' motion of the move control
00065 //     D key - is mapped to the 'right' motion of the move control
00066 //     <space> key - is mapped to the 'up' motion of the move control
00067 //     X key - is mapped to the 'down' motion of the move control
00068 //     P key - is mapped to IsPauseRequested
00069 //
00070 // The MoveLookController collects input from each of the input events.  On the Update method
00071 // the Xbox Controller is polled for it's current state and all the inputs are coalesced and
00072 // merged to generate a velocity vector and update the Pitch and Yaw values.
00073
00074 // Uncomment the next line to print debug tracing information.
00075 // #define MOVELOOKCONTROLLER_TRACE 1
00076
00077 enum class MoveLookControllerState
00078 {
00079     None,
00080     WaitForInput,
00081     Active,
00082 };
00083
00084 ref class MoveLookController
00085 {
00086 internal:
00087     MoveLookController();
00088
00089     void Initialize(
00090         _In_ Windows::UI::Core::CoreWindow^ window
00091         );
00092     void SetMoveRect(
00093         _In_ DirectX::XMFLOAT2 upperLeft,
00094         _In_ DirectX::XMFLOAT2 lowerRight
00095         );
00096     void SetFireRect(
00097         _In_ DirectX::XMFLOAT2 upperLeft,
00098         _In_ DirectX::XMFLOAT2 lowerRight
00099         );
00100     void WaitForPress(
00101         _In_ DirectX::XMFLOAT2 UpperLeft,
00102         _In_ DirectX::XMFLOAT2 LowerRight
00103         );
00104     void WaitForPress();
00105
00106     void Update();
00107     bool IsFiring();
00108     bool IsPressComplete();
00109     bool IsPauseRequested();
00110
00111     DirectX::XMFLOAT3 Velocity();
00112     DirectX::XMFLOAT3 LookDirection();
00113     float Pitch();
00114     void  Pitch(_In_ float pitch);
00115     float Yaw();
00116     void  Yaw(_In_ float yaw);
00117     bool  Active();
00118     void  Active(_In_ bool active);
00119
00120     bool AutoFire();
00121     void AutoFire(_In_ bool AutoFire);
00122
00123 protected:
00124     void OnPointerPressed(
00125         _In_ Windows::UI::Core::CoreWindow^ sender,
00126         _In_ Windows::UI::Core::PointerEventArgs^ args
00127         );
00128     void OnPointerMoved(
00129         _In_ Windows::UI::Core::CoreWindow^ sender,
00130         _In_ Windows::UI::Core::PointerEventArgs^ args
00131         );
00132     void OnPointerReleased(
00133         _In_ Windows::UI::Core::CoreWindow^ sender,
00134         _In_ Windows::UI::Core::PointerEventArgs^ args
00135         );
00136     void OnPointerExited(
00137         _In_ Windows::UI::Core::CoreWindow^ sender,
00138         _In_ Windows::UI::Core::PointerEventArgs^ args
00139         );
00140     void OnKeyDown(
00141         _In_ Windows::UI::Core::CoreWindow^ sender,
00142         _In_ Windows::UI::Core::KeyEventArgs^ args
00143         );
00144     void OnKeyUp(
00145         _In_ Windows::UI::Core::CoreWindow^ sender,
00146         _In_ Windows::UI::Core::KeyEventArgs^ args
00147         );
00148
00149     void OnMouseMoved(
00150         _In_ Windows::Devices::Input::MouseDevice^ mouseDevice,
00151         _In_ Windows::Devices::Input::MouseEventArgs^ args
00152         );
00153
00154 #ifdef MOVELOOKCONTROLLER_TRACE
00155     void DebugTrace(const wchar_t *format, ...);
00156 #endif
00157
00158 private:
00159     // Properties of the controller object.
00160     MoveLookControllerState     m_state;
00161     DirectX::XMFLOAT3           m_velocity;             // How far we move in this frame.
00162     float                       m_pitch;
00163     float                       m_yaw;                  // Orientation euler angles in radians.
00164
00165     // Properties of the Move control.
00166     DirectX::XMFLOAT2           m_moveUpperLeft;        // Bounding box where this control will activate.
00167     DirectX::XMFLOAT2           m_moveLowerRight;
00168     bool                        m_moveInUse;            // The move control is in use.
00169     uint32                      m_movePointerID;        // Id of the pointer in this control.
00170     DirectX::XMFLOAT2           m_moveFirstDown;        // Point where initial contact occurred.
00171     DirectX::XMFLOAT2           m_movePointerPosition;  // Point where the move pointer is currently located.
00172     DirectX::XMFLOAT3           m_moveCommand;          // The net command from the move control.
00173
00174     // Properties of the Look control.
00175     bool                        m_lookInUse;            // The look control is in use.
00176     uint32                      m_lookPointerID;        // Id of the pointer in this control.
00177     DirectX::XMFLOAT2           m_lookLastPoint;        // Last point (from last frame).
00178     DirectX::XMFLOAT2           m_lookLastDelta;        // The delta used for smoothing between frames.
00179
00180     // Properties of the Fire control.
00181     bool                        m_autoFire;
00182     bool                        m_firePressed;
00183     DirectX::XMFLOAT2           m_fireUpperLeft;        // Bounding box where this control will activate.
00184     DirectX::XMFLOAT2           m_fireLowerRight;
00185     bool                        m_fireInUse;            // The fire control in in use.
00186     UINT32                      m_firePointerID;        // Id of the pointer in this control.
00187     DirectX::XMFLOAT2           m_fireLastPoint;        // Last fire position.
00188
00189     // Properties of the Mouse control.  This is a combination of Look and Fire.
00190     bool                        m_mouseInUse;
00191     uint32                      m_mousePointerID;
00192     DirectX::XMFLOAT2           m_mouseLastPoint;
00193     bool                        m_mouseLeftInUse;
00194     bool                        m_mouseRightInUse;
00195
00196     bool                        m_buttonInUse;
00197     uint32                      m_buttonPointerID;
00198     DirectX::XMFLOAT2           m_buttonUpperLeft;
00199     DirectX::XMFLOAT2           m_buttonLowerRight;
00200     bool                        m_buttonPressed;
00201     bool                        m_pausePressed;
00202
00203     // Xbox Input related members.
00204     bool                        m_isControllerConnected;  // Is the Xbox controller connected.
00205     XINPUT_CAPABILITIES         m_xinputCaps;             // Capabilites of the controller.
00206     XINPUT_STATE                m_xinputState;            // The current state of the controller.
00207     bool                        m_xinputStartButtonInUse;
00208     bool                        m_xinputTriggerInUse;
00209
00210     // Input states for Keyboard.
00211     bool                        m_forward;
00212     bool                        m_back;                    // States for movement.
00213     bool                        m_left;
00214     bool                        m_right;
00215     bool                        m_up;
00216     bool                        m_down;
00217     bool                        m_pause;
00218
00219 private:
00220     void     ResetState();
00221     void     UpdateGameController();
00222 };
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/App.xaml.h Source File

  • XAML DirectX 3D shooting game

App.xaml.h

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // App:
00011 // This class is the main App class required for XAML Metro style apps.
00012 // It it called on Launch activation and maintains the overall state of the game.
00013 // The App class drives and maintains a state machine for the game.  It can be in
00014 // one of seven major stated defined by the UpdateEngineState enum class.
00015 // These are:
00016 //     WaitingForResources - the game has requested the game object or the renderer object
00017 //         to load resources asynchronously.
00018 //     ResourcesLoaded - the asynchronous loading of resources has been completed.  This
00019 //         is a transient state.
00020 //     WaitingForPress - the game is waiting for the player to indicate they are ready to proceed.
00021 //         There are three possible actions from this state.  This is controlled by m_pressResult.
00022 //         The possible outcomes are:
00023 //             LoadGame - The player is ready to start a new game and has acknowledged the status
00024 //                 information provided about the previous state.
00025 //             PlayLevel - The player is ready to play the next level.  The level has already been
00026 //                 loaded so active game play will start.
00027 //             ContinueLevel - The player is ready to continue playing the current level.  Part of the
00028 //                 current level has already been played.
00029 //     Dynamics - the game is active play mode.
00030 //     Snapped - the game is currently in the snapped position on the screen.  It is not possible to
00031 //         play the game in snapped mode.
00032 //     Suspended - the game was suspended by PLM.
00033 //     Deactivated - the game has lost focus.
00034 //
00035 // App creates and maintains references to three major objects used for the game:
00036 //     MoveLookController (m_controller) - this object handles all the game specific user input and
00037 //         aggregates touch, mouse/keyboard and Xbox controller input into a unified input control.
00038 //     Simple3DGame (m_game) - this object handles all the game specific logic and game dynamics.
00039 //     GameRenderer (m_renderer) - This object handles all the graphics rendering for the game.
00040 //
00041 // App registers for all the necessary Metro style events to maintain and control all state transitions.
00042 // The App class dynamically registers and unregisters for the CompositionTarget::Rendering event based on whether
00043 // rendering is needed or not.  This event will occur on each vertical retrace to give a steady set of frames for
00044 // smooth scene rendering.
00045
00046 #if defined(_DEBUG)
00047 #define DISABLE_XAML_GENERATED_BREAK_ON_UNHANDLED_EXCEPTION 1
00048 #endif
00049
00050 #define USE_STORE_SIMULATOR 1
00051
00052 #include "MainPage.xaml.h"
00053 #include "Simple3DGame.h"
00054 #ifdef USE_STORE_SIMULATOR
00055 #include "PersistentState.h"
00056 #endif
00057 #include "App.g.h"
00058
00059 namespace Simple3DGameXaml
00060 {
00061     private enum class UpdateEngineState
00062     {
00063         WaitingForResources,
00064         ResourcesLoaded,
00065         WaitingForPress,
00066         Dynamics,
00067         Snapped,
00068         Suspended,
00069         Deactivated,
00070     };
00071
00072     private enum class PressResultState
00073     {
00074         LoadGame,
00075         PlayLevel,
00076         ContinueLevel,
00077     };
00078
00079     private enum class GameInfoOverlayState
00080     {
00081         Loading,
00082         GameStats,
00083         GameOverExpired,
00084         GameOverCompleted,
00085         LevelStart,
00086         Pause,
00087         Snapped,
00088     };
00089
00090     [Windows::Foundation::Metadata::WebHostHidden]
00091     public ref class App sealed
00092     {
00093     public:
00094         App();
00095
00096         virtual void OnLaunched(
00097             _In_ Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ args
00098             ) override;
00099
00100         void PauseRequested() { if (m_updateState == UpdateEngineState::Dynamics) m_pauseRequested = true; };
00101         void PressComplete()  { if (m_updateState == UpdateEngineState::WaitingForPress) m_pressComplete = true; };
00102         void ResetGame();
00103         void SetBackground(unsigned int background);
00104         void CycleBackground();
00105
00106 #ifdef USE_STORE_SIMULATOR
00107         void ResetLicense();
00108 #endif
00109
00110     private:
00111         ~App();
00112
00113         void OnSuspending(
00114             _In_ Platform::Object^ sender,
00115             _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00116             );
00117
00118         void OnResuming(
00119             _In_ Platform::Object^ sender,
00120             _In_ Platform::Object^ args
00121             );
00122
00123         void UpdateViewState();
00124
00125         void OnWindowActivationChanged(
00126             _In_ Platform::Object^ sender,
00127             _In_ Windows::UI::Core::WindowActivatedEventArgs^ args
00128             );
00129
00130         void OnWindowSizeChanged(
00131             _In_ Windows::UI::Core::CoreWindow^ sender,
00132             _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00133             );
00134
00135         void OnLogicalDpiChanged(
00136             _In_ Platform::Object^ sender
00137             );
00138
00139         void OnDisplayContentsInvalidated(
00140             _In_ Platform::Object^ sender
00141             );
00142
00143         void OnVisibilityChanged(
00144             _In_ Windows::UI::Core::CoreWindow^ sender,
00145             _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00146             );
00147
00148         void OnRendering(
00149             _In_ Object^ sender,
00150             _In_ Object^ args
00151             );
00152
00153         void OnLicenseChanged();
00154         void InitializeLicense();
00155         void InitializeLicenseCore();
00156
00157         void InitializeGameState();
00158         void OnDeviceLost();
00159         void OnDeviceReset();
00160         void Update();
00161         void SetGameInfoOverlay(GameInfoOverlayState state);
00162         void SetAction (GameInfoOverlayCommand command);
00163         void ShowGameInfoOverlay();
00164         void HideGameInfoOverlay();
00165         void SetSnapped();
00166         void HideSnapped();
00167
00168         Windows::Foundation::EventRegistrationToken         m_onRenderingEventToken;
00169         bool                                                m_pauseRequested;
00170         bool                                                m_pressComplete;
00171         bool                                                m_renderNeeded;
00172         bool                                                m_haveFocus;
00173         bool                                                m_visible;
00174
00175         MainPage^                                           m_mainPage;
00176         MoveLookController^                                 m_controller;
00177         GameRenderer^                                       m_renderer;
00178         Simple3DGame^                                       m_game;
00179
00180         UpdateEngineState                                   m_updateState;
00181         UpdateEngineState                                   m_updateStateNext;
00182         PressResultState                                    m_pressResult;
00183         GameInfoOverlayState                                m_gameInfoOverlayState;
00184         Windows::ApplicationModel::Store::LicenseInformation^ m_licenseInformation;
00185         Windows::ApplicationModel::Store::ListingInformation^ m_listingInformation;
00186 #ifdef USE_STORE_SIMULATOR
00187         PersistentState^                                    m_licenseState;
00188         bool                                                m_isTrial;
00189 #endif
00190     };
00191 }
00192
00193
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/MainPage.xaml.cpp Source File

  • EAS policies for mail clients

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Removable storage/C++/MainPage.xaml.cpp Source File

  • Removable storage

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/MainPage.xaml.cpp Source File

  • Certificate enrollment

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DXGI swap chain rotation/C++/BasicLoader.h Source File

  • DXGI swap chain rotation

BasicLoader.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicReaderWriter.h"
00011
00012 // A simple loader class that provides support for loading shaders, textures,
00013 // and meshes from files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicLoader
00015 {
00016 internal:
00017     BasicLoader(
00018         _In_ ID3D11Device* d3dDevice,
00019         _In_opt_ IWICImagingFactory2* wicFactory = nullptr
00020         );
00021
00022     void LoadTexture(
00023         _In_ Platform::String^ filename,
00024         _Out_opt_ ID3D11Texture2D** texture,
00025         _Out_opt_ ID3D11ShaderResourceView** textureView
00026         );
00027
00028     concurrency::task<void> LoadTextureAsync(
00029         _In_ Platform::String^ filename,
00030         _Out_opt_ ID3D11Texture2D** texture,
00031         _Out_opt_ ID3D11ShaderResourceView** textureView
00032         );
00033
00034     void LoadShader(
00035         _In_ Platform::String^ filename,
00036         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00037         _In_ uint32 layoutDescNumElements,
00038         _Out_ ID3D11VertexShader** shader,
00039         _Out_opt_ ID3D11InputLayout** layout
00040         );
00041
00042     concurrency::task<void> LoadShaderAsync(
00043         _In_ Platform::String^ filename,
00044         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC layoutDesc[],
00045         _In_ uint32 layoutDescNumElements,
00046         _Out_ ID3D11VertexShader** shader,
00047         _Out_opt_ ID3D11InputLayout** layout
00048         );
00049
00050     void LoadShader(
00051         _In_ Platform::String^ filename,
00052         _Out_ ID3D11PixelShader** shader
00053         );
00054
00055     concurrency::task<void> LoadShaderAsync(
00056         _In_ Platform::String^ filename,
00057         _Out_ ID3D11PixelShader** shader
00058         );
00059
00060     void LoadShader(
00061         _In_ Platform::String^ filename,
00062         _Out_ ID3D11ComputeShader** shader
00063         );
00064
00065     concurrency::task<void> LoadShaderAsync(
00066         _In_ Platform::String^ filename,
00067         _Out_ ID3D11ComputeShader** shader
00068         );
00069
00070     void LoadShader(
00071         _In_ Platform::String^ filename,
00072         _Out_ ID3D11GeometryShader** shader
00073         );
00074
00075     concurrency::task<void> LoadShaderAsync(
00076         _In_ Platform::String^ filename,
00077         _Out_ ID3D11GeometryShader** shader
00078         );
00079
00080     void LoadShader(
00081         _In_ Platform::String^ filename,
00082         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00083         _In_ uint32 numEntries,
00084         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00085         _In_ uint32 numStrides,
00086         _In_ uint32 rasterizedStream,
00087         _Out_ ID3D11GeometryShader** shader
00088         );
00089
00090     concurrency::task<void> LoadShaderAsync(
00091         _In_ Platform::String^ filename,
00092         _In_reads_opt_(numEntries) const D3D11_SO_DECLARATION_ENTRY* streamOutDeclaration,
00093         _In_ uint32 numEntries,
00094         _In_reads_opt_(numStrides) const uint32* bufferStrides,
00095         _In_ uint32 numStrides,
00096         _In_ uint32 rasterizedStream,
00097         _Out_ ID3D11GeometryShader** shader
00098         );
00099
00100     void LoadShader(
00101         _In_ Platform::String^ filename,
00102         _Out_ ID3D11HullShader** shader
00103         );
00104
00105     concurrency::task<void> LoadShaderAsync(
00106         _In_ Platform::String^ filename,
00107         _Out_ ID3D11HullShader** shader
00108         );
00109
00110     void LoadShader(
00111         _In_ Platform::String^ filename,
00112         _Out_ ID3D11DomainShader** shader
00113         );
00114
00115     concurrency::task<void> LoadShaderAsync(
00116         _In_ Platform::String^ filename,
00117         _Out_ ID3D11DomainShader** shader
00118         );
00119
00120     void LoadMesh(
00121         _In_ Platform::String^ filename,
00122         _Out_ ID3D11Buffer** vertexBuffer,
00123         _Out_ ID3D11Buffer** indexBuffer,
00124         _Out_opt_ uint32* vertexCount,
00125         _Out_opt_ uint32* indexCount
00126         );
00127
00128     concurrency::task<void> LoadMeshAsync(
00129         _In_ Platform::String^ filename,
00130         _Out_ ID3D11Buffer** vertexBuffer,
00131         _Out_ ID3D11Buffer** indexBuffer,
00132         _Out_opt_ uint32* vertexCount,
00133         _Out_opt_ uint32* indexCount
00134         );
00135
00136 private:
00137     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00138     Microsoft::WRL::ComPtr<IWICImagingFactory2> m_wicFactory;
00139     BasicReaderWriter^ m_basicReaderWriter;
00140
00141     template <class DeviceChildType>
00142     inline void SetDebugName(
00143         _In_ DeviceChildType* object,
00144         _In_ Platform::String^ name
00145         );
00146
00147     Platform::String^ GetExtension(
00148         _In_ Platform::String^ filename
00149         );
00150
00151     void CreateTexture(
00152         _In_ bool decodeAsDDS,
00153         _In_reads_bytes_(dataSize) byte* data,
00154         _In_ uint32 dataSize,
00155         _Out_opt_ ID3D11Texture2D** texture,
00156         _Out_opt_ ID3D11ShaderResourceView** textureView,
00157         _In_opt_ Platform::String^ debugName
00158         );
00159
00160     void CreateInputLayout(
00161         _In_reads_bytes_(bytecodeSize) byte* bytecode,
00162         _In_ uint32 bytecodeSize,
00163         _In_reads_opt_(layoutDescNumElements) D3D11_INPUT_ELEMENT_DESC* layoutDesc,
00164         _In_ uint32 layoutDescNumElements,
00165         _Out_ ID3D11InputLayout** layout
00166         );
00167
00168     void CreateMesh(
00169         _In_ byte* meshData,
00170         _Out_ ID3D11Buffer** vertexBuffer,
00171         _Out_ ID3D11Buffer** indexBuffer,
00172         _Out_opt_ uint32* vertexCount,
00173         _Out_opt_ uint32* indexCount,
00174         _In_opt_ Platform::String^ debugName
00175         );
00176 };
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/BasicCamera.cpp Source File

  • Direct3D-Direct2D interop

BasicCamera.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicCamera.h"
00010
00011 void BasicCamera::GetViewMatrix(_Out_ float4x4 *viewMatrix)
00012 {
00013     *viewMatrix = m_view;
00014 }
00015
00016 void BasicCamera::GetProjectionMatrix(_Out_ float4x4 *projectionMatrix)
00017 {
00018     *projectionMatrix = m_projection;
00019 }
00020
00021 // this method updates the view matrix based on new position and focus coordinates
00022 void BasicCamera::SetViewParameters(
00023     _In_ float3 eyePosition,    // the position of the camera
00024     _In_ float3 lookPosition,   // the point the camera should look at
00025     _In_ float3 up              // the durection vector for up
00026     )
00027 {
00028     m_position = eyePosition;
00029     m_direction = normalize(lookPosition - eyePosition);
00030     float3 zAxis = -m_direction;
00031     float3 xAxis = normalize(cross(up, zAxis));
00032     float3 yAxis = cross(zAxis, xAxis);
00033     float xOffset = -dot(xAxis, m_position);
00034     float yOffset = -dot(yAxis, m_position);
00035     float zOffset = -dot(zAxis, m_position);
00036     m_view = float4x4(
00037         xAxis.x, xAxis.y, xAxis.z, xOffset,
00038         yAxis.x, yAxis.y, yAxis.z, yOffset,
00039         zAxis.x, zAxis.y, zAxis.z, zOffset,
00040         0.0f,    0.0f,    0.0f,    1.0f
00041         );
00042 }
00043     // this method updates the projection matrix based on new parameters
00044 void BasicCamera::SetProjectionParameters(
00045     _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00046     _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00047     _In_ float nearPlane,           // depth to map to 0
00048     _In_ float farPlane             // depth to map to 1
00049     )
00050 {
00051     float minScale = 1.0f / tan(minimumFieldOfView * PI_F / 360.0f);
00052     float xScale = 1.0f;
00053     float yScale = 1.0f;
00054     if (aspectRatio < 1.0f)
00055     {
00056         xScale = minScale;
00057         yScale = minScale * aspectRatio;
00058     }
00059     else
00060     {
00061         xScale = minScale / aspectRatio;
00062         yScale = minScale;
00063     }
00064     float zScale = farPlane / (farPlane - nearPlane);
00065     m_projection = float4x4(
00066         xScale, 0.0f,   0.0f,    0.0f,
00067         0.0f,   yScale, 0.0f,    0.0f,
00068         0.0f,   0.0f,   -zScale, -nearPlane*zScale,
00069         0.0f,   0.0f,   -1.0f,   0.0f
00070         );
00071 }
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: USSD message management/C++/App.xaml.cpp Source File

  • USSD message management

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:28 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Edge gesture invocation/C++/ScenarioInput1.xaml.h Source File

  • Edge gesture invocation

ScenarioInput1.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // ScenarioInput1.xaml.h
00009 // Declaration of the ScenarioInput1 class.
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "ScenarioInput1.g.h"
00016 #include "MainPage.xaml.h"
00017
00018 using namespace Windows::UI::Xaml;
00019
00020 namespace EdgeGestureSample
00021 {
00022   [Windows::Foundation::Metadata::WebHostHidden]
00023     public ref class ScenarioInput1 sealed
00024     {
00025     public:
00026         ScenarioInput1();
00027
00028     protected:
00029         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00030         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00031
00032     private:
00033         MainPage^ rootPage;
00034         TextBlock^ outputText;
00035         Windows::Foundation::EventRegistrationToken RightClickEventToken;
00036         Windows::Foundation::EventRegistrationToken EdgeGestureStartingEventToken;
00037         Windows::Foundation::EventRegistrationToken EdgeGestureCompletedEventToken;
00038         Windows::Foundation::EventRegistrationToken EdgeGestureCanceledEventToken;
00039
00040         void rootPage_OutputFrameLoaded(Object^ sender, Object^ e);
00041
00042         void OnStarting(EdgeGesture^ sender, EdgeGestureEventArgs^ e);
00043         void OnCompleted(EdgeGesture^ sender, EdgeGestureEventArgs^ e);
00044         void OnCanceled(EdgeGesture^ sender, EdgeGestureEventArgs^ e);
00045         void OnContextMenu(Object^ sender, RightTappedRoutedEventArgs^ e);
00046         void InitializeEdgeGestureHandlers();
00047         ~ScenarioInput1();
00048
00049         Windows::Foundation::EventRegistrationToken _layoutHandlerToken;
00050         Windows::Foundation::EventRegistrationToken _frameLoadedToken;
00051     };
00052 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/App.xaml.h Source File

  • Certificate enrollment

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows Audio Session (WASAPI)/C++/common/LayoutAwarePage.h Source File

  • Windows Audio Session (WASAPI)
  • C++
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/Common/BooleanToVisibilityConverter.h Source File

  • Hilo C++
  • Hilo
  • Common

BooleanToVisibilityConverter.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 namespace Hilo
00010 {
00011   namespace Common
00012   {
00013     /// <summary>
00014     /// Value converter that translates true to <see cref="Visibility::Visible"/> and false
00015     /// to <see cref="Visibility::Collapsed"/>.
00016     /// </summary>
00017     [Windows::Foundation::Metadata::WebHostHidden]
00018     public ref class BooleanToVisibilityConverter sealed : Windows::UI::Xaml::Data::IValueConverter
00019     {
00020     public:
00021       virtual Platform::Object^ Convert(Platform::Object^ value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^ parameter, Platform::String^ language);
00022       virtual Platform::Object^ ConvertBack(Platform::Object^ value, Windows::UI::Xaml::Interop::TypeName targetType, Platform::Object^ parameter, Platform::String^ language);
00023     };
00024   }
00025 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Level4.cpp Source File

  • DirectX 3D shooting game

Level4.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Level4.h"
00010 #include "Face.h"
00011
00012 //----------------------------------------------------------------------
00013
00014 Level4::Level4()
00015 {
00016     m_timeLimit = 30.0f;
00017     m_objective = "Hit each of the moving targets in ORDER before time runs out.";
00018 }
00019
00020 //----------------------------------------------------------------------
00021
00022 void Level4::Initialize(std::vector<GameObject^> objects)
00023 {
00024     Level3::Initialize(objects);
00025
00026     int targetCount = 0;
00027     for (auto object = objects.begin(); object != objects.end(); object++)
00028     {
00029         if (Face^ target = dynamic_cast<Face^>(*object))
00030         {
00031             if (targetCount < 9)
00032             {
00033                 target->Target(targetCount == 0 ? true : false);
00034                 targetCount++;
00035             }
00036         }
00037     }
00038     m_nextId = 1;
00039 }
00040
00041 //----------------------------------------------------------------------
00042
00043 bool Level4::Update(
00044     float /* time */,
00045     float /* elapsedTime */,
00046     float /* timeRemaining */,
00047     std::vector<GameObject^> objects
00048     )
00049 {
00050     int left = 0;
00051     for (auto object = objects.begin(); object != objects.end(); object++)
00052     {
00053         if ((*object)->Active() && ((*object)->TargetId() > 0))
00054         {
00055             if ((*object)->Hit() && ((*object)->TargetId() == m_nextId))
00056             {
00057                 (*object)->Active(false);
00058                 m_nextId++;
00059             }
00060             else
00061             {
00062                 left++;
00063             }
00064         }
00065         if ((*object)->Active() && ((*object)->TargetId() == m_nextId))
00066         {
00067             (*object)->Target(true);
00068         }
00069     }
00070     return (left == 0);
00071 }
00072
00073 //----------------------------------------------------------------------
00074
00075 void Level4::SaveState(PersistentState^ state)
00076 {
00077     state->SaveInt32(":NextTarget", m_nextId);
00078 }
00079
00080 //----------------------------------------------------------------------
00081
00082 void Level4::LoadState(PersistentState^ state)
00083 {
00084     m_nextId = state->LoadInt32(":NextTarget", 1);
00085 }
00086
00087 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

CCopyModule Member List

This is the complete list of members for CCopyModule, including all inherited members.
Initialize(ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight) | CCopyModule | [inline, private, virtual]
Initialize(ID3D11Device *pDevice, UINT uiWidth, UINT uiHeight) | CCopyModule | [inline, private, virtual]
Invalidate() | CCopyModule | [inline, private, virtual]
Invalidate() | CCopyModule | [inline, private, virtual]
ProcessFrame(ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex) | CCopyModule | [inline, private, virtual]
ProcessFrame(ID3D11Device *pDevice, ID3D11Texture2D *pInput, UINT uiInIndex, ID3D11Texture2D *pOutput, UINT uiOutIndex) | CCopyModule | [inline, private, virtual]
Generated on Sat Nov 23 2024 16:09:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Syndication/C++/common/LayoutAwarePage.cpp Source File

  • Syndication
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D stereoscopic 3D/C++/DirectXApp.h Source File

  • Direct3D stereoscopic 3D

DirectXApp.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "StereoSimpleD3D.h"
00011
00012 ref class DirectXApp : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 internal:
00015     DirectXApp();
00016
00017 public:
00018     // IFrameworkView Methods
00019     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00020     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00021     virtual void Load(_In_ Platform::String^ entryPoint);
00022     virtual void Run();
00023     virtual void Uninitialize();
00024
00025 private:
00026     // Event Handlers
00027     void OnWindowSizeChanged(
00028         _In_ Windows::UI::Core::CoreWindow^ sender,
00029         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args
00030         );
00031
00032
00033     void OnVisibilityChanged(
00034         _In_ Windows::UI::Core::CoreWindow^ sender,
00035         _In_ Windows::UI::Core::VisibilityChangedEventArgs^ args
00036         );
00037
00038     void OnKeyDown(
00039         _In_ Windows::UI::Core::CoreWindow^ sender,
00040         _In_ Windows::UI::Core::KeyEventArgs^ args
00041         );
00042
00043     void OnLogicalDpiChanged(
00044         _In_ Platform::Object^ sender
00045         );
00046
00047     void OnActivated(
00048         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00049         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args
00050         );
00051
00052     void OnSuspending(
00053         _In_ Platform::Object^ sender,
00054         _In_ Windows::ApplicationModel::SuspendingEventArgs^ args
00055         );
00056
00057     void OnResuming(
00058         _In_ Platform::Object^ sender,
00059         _In_ Platform::Object^ args
00060         );
00061
00062     void OnWindowClosed(
00063         _In_ Windows::UI::Core::CoreWindow^ sender,
00064         _In_ Windows::UI::Core::CoreWindowEventArgs^ args
00065         );
00066
00067     StereoSimpleD3D^ m_renderer;
00068     bool m_windowClosed;
00069     bool m_windowVisible;
00070 };
00071
00072 ref class DirectXAppSource : Windows::ApplicationModel::Core::IFrameworkViewSource
00073 {
00074 public:
00075     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00076 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicReaderWriter.h Source File

  • DirectX touch input

BasicReaderWriter.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <ppltasks.h>
00011
00012 // A simple reader/writer class that provides support for reading and writing
00013 // files on disk. Provides synchronous and asynchronous methods.
00014 ref class BasicReaderWriter
00015 {
00016 private:
00017     Windows::Storage::StorageFolder^ m_location;
00018     Platform::String^ m_locationPath;
00019
00020 internal:
00021     BasicReaderWriter();
00022     BasicReaderWriter(
00023         _In_ Windows::Storage::StorageFolder^ folder
00024         );
00025
00026     Platform::Array<byte>^ ReadData(
00027         _In_ Platform::String^ filename
00028         );
00029
00030     concurrency::task<Platform::Array<byte>^> ReadDataAsync(
00031         _In_ Platform::String^ filename
00032         );
00033
00034     uint32 WriteData(
00035         _In_ Platform::String^ filename,
00036         _In_ const Platform::Array<byte>^ fileData
00037         );
00038
00039     concurrency::task<void> WriteDataAsync(
00040         _In_ Platform::String^ filename,
00041         _In_ const Platform::Array<byte>^ fileData
00042         );
00043 };
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background task/C++/Tasks/pch.h Source File

  • Background task
  • Tasks

pch.h

Go to the documentation of this file.
00001 ﻿//
00002 // pch.h
00003 // Header for standard system include files.
00004 //
00005
00006 #pragma once
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D printing images and effects/C++/DirectXBase.h Source File

  • Direct2D printing images and effects

DirectXBase.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(Windows::UI::Core::CoreWindow^ window, float dpi);
00020     virtual void HandleDeviceLost();
00021     virtual void CreateDeviceIndependentResources();
00022     virtual void CreateDeviceResources();
00023     virtual void SetDpi(float dpi);
00024     virtual void UpdateForWindowSizeChange();
00025     virtual void CreateWindowSizeDependentResources();
00026     virtual void Render() = 0;
00027     virtual void Present();
00028     void ValidateDevice();
00029
00030 protected private:
00031     Platform::Agile<Windows::UI::Core::CoreWindow>  m_window;
00032
00033     // DirectWrite & Windows Imaging Component Objects.
00034     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00035     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00036
00037     // DirectX Core Objects. Required for 2D and 3D.
00038     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00039     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00040     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00041     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00042
00043     // Direct2D Rendering Objects. Required for 2D.
00044     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00045     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00046     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00047     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00048
00049     // Direct3D Rendering Objects. Required for 3D.
00050     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00051
00052     // Cached renderer properties.
00053     D3D_FEATURE_LEVEL                               m_featureLevel;
00054     Windows::Foundation::Size                       m_renderTargetSize;
00055     Windows::Foundation::Rect                       m_windowBounds;
00056     float                                           m_dpi;
00057     bool                                            m_windowSizeChangeInProgress;
00058 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Compression/C++/CompressionUtils.cpp Source File

  • Compression

CompressionUtils.cpp

Go to the documentation of this file.
00001 #include "pch.h"
00002 #include "MainPage.xaml.h"
00003 #include "Constants.h"
00004 #include "CompressionUtils.h"
00005
00006 using namespace Windows::Storage;
00007 using namespace Windows::Storage::Pickers;
00008 using namespace Windows::Storage::Streams;
00009 using namespace Windows::Storage::Compression;
00010
00011 using namespace concurrency;
00012
00013 #pragma region ReadStreamTask implementation
00014 // We can't derive from task because we need to initialize task_completion_event before task itself.
00015 struct ReadStreamTask::ReadStreamTaskImpl {
00016     ReadStreamTaskImpl(IInputStream^ Stream, std::vector<byte> &Destination):
00017         _Destination(Destination),
00018         _Reader(ref new DataReader(Stream)),
00019         _CompletionEvent()
00020     {
00021         _Task = create_task(_CompletionEvent).then([this]
00022         {
00023             // Schedule resource deallocation
00024             std::unique_ptr<ReadStreamTaskImpl> thisHolder(this);
00025
00026             // Prevent user provided stream from being closed
00027             _Reader->DetachStream();
00028
00029             // Move data out
00030             _Destination = std::move(_StreamData);
00031
00032             return _Destination.size();
00033         });
00034
00035         // Start recursive reading
00036         ReadChunk();
00037     }
00038
00039     void ReadChunk()
00040     {
00041         // LoadAsync itself could throw exception if IAsyncOperation couldn't be created with
00042         // given parameters in a current state
00043         try
00044         {
00045             // Read data into the data reader
00046             _StreamData.reserve(_StreamData.size() + MinReadChunkSize);
00047             create_task(_Reader->LoadAsync(static_cast<unsigned int>(_StreamData.capacity() - _StreamData.size())))
00048
00049             // Then store it to the result vector
00050             .then([this](task<unsigned int> BytesRead)
00051             {
00052                 try
00053                 {
00054                     // exception is thrown here if LoadAsync operation has been completed with an error
00055                     auto bytesRead = BytesRead.get();
00056                     if (bytesRead)
00057                     {
00058                         // Store chunk of data in the result vector.
00059                         auto newData = ref new Platform::Array<byte>(bytesRead);
00060                         _Reader->ReadBytes(newData);
00061
00062                         _StreamData.insert(_StreamData.end(), newData->begin(), newData->end());
00063
00064                         // Then recurse to read next chunk.
00065                         ReadChunk();
00066                     }
00067                     else
00068                     {
00069                         // End of stream is reached - complete top level task with the data we've read so far
00070
00071                         // make sure that _CompletionEvent outlives continuation which deletes this ReadStreamTaskImpl
00072                         auto completionEvent = _CompletionEvent;
00073                         completionEvent.set();
00074                     }
00075                 }
00076                 catch (...)
00077                 {
00078                     // Schedule resource deallocation
00079                     std::unique_ptr<ReadStreamTaskImpl> thisHolder(this);
00080
00081                     _CompletionEvent.set_exception(std::current_exception());
00082                 }
00083             });
00084         }
00085         catch (...)
00086         {
00087             // Schedule resource deallocation
00088             std::unique_ptr<ReadStreamTaskImpl> thisHolder(this);
00089
00090             _CompletionEvent.set_exception(std::current_exception());
00091         }
00092     }
00093
00094     // All data members are accessed serially - no synchronization is done
00095     std::vector<byte> &_Destination;
00096     DataReader^ _Reader;
00097     std::vector<byte> _StreamData;
00098
00099     task_completion_event<void> _CompletionEvent;
00100     task<size_t> _Task;
00101 };
00102
00103 ReadStreamTask::ReadStreamTask(IInputStream^ Stream, std::vector<byte> &Destination):
00104     _Impl(new ReadStreamTaskImpl(Stream, Destination))
00105 {
00106 }
00107
00108 ReadStreamTask::ReadStreamTask(const ReadStreamTask& Task):
00109     _Impl(Task._Impl)
00110 {
00111 }
00112
00113 ReadStreamTask &ReadStreamTask::operator=(const ReadStreamTask& Task)
00114 {
00115     _Impl = Task._Impl;
00116     return *this;
00117 }
00118
00119 task<size_t> ReadStreamTask::GetTask()
00120 {
00121     return _Impl->_Task;
00122 }
00123 #pragma endregion
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio file playback/C++/pch.cpp Source File

  • XAudio2 audio file playback

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/CompositeSettings.xaml.cpp Source File

  • Application data

CompositeSettings.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CompositeSettings.xaml.cpp
00013 // Implementation of the CompositeSettings class
00014 //
00015
00016 #include "pch.h"
00017 #include "CompositeSettings.xaml.h"
00018
00019 using namespace SDKSample::ApplicationDataSample;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026 using namespace Windows::Storage;
00027
00028 #define settingName   "exampleCompositeSetting"
00029 #define settingName1  "one"
00030 #define settingValue1 1
00031 #define settingName2  "hello"
00032 #define settingValue2 "world"
00033
00034 CompositeSettings::CompositeSettings()
00035 {
00036     InitializeComponent();
00037
00038     roamingSettings = ApplicationData::Current->RoamingSettings;
00039
00040     DisplayOutput();
00041 }
00042
00043 /// <summary>
00044 /// Invoked when this page is about to be displayed in a Frame.
00045 /// </summary>
00046 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00047 /// property is typically used to configure the page.</param>
00048 void CompositeSettings::OnNavigatedTo(NavigationEventArgs^ e)
00049 {
00050     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00051     // as NotifyUser()
00052     rootPage = MainPage::Current;
00053 }
00054
00055 void CompositeSettings::WriteCompositeSetting_Click(Object^ sender, RoutedEventArgs^ e)
00056 {
00057     ApplicationDataCompositeValue^ composite = ref new ApplicationDataCompositeValue();
00058     composite->Insert(settingName1, dynamic_cast<PropertyValue^>(PropertyValue::CreateInt32(settingValue1)));
00059     composite->Insert(settingName2, dynamic_cast<PropertyValue^>(PropertyValue::CreateString(settingValue2)));
00060
00061     roamingSettings->Values->Insert(settingName, composite);
00062
00063     DisplayOutput();
00064 }
00065
00066 void CompositeSettings::DeleteCompositeSetting_Click(Object^ sender, RoutedEventArgs^ e)
00067 {
00068     roamingSettings->Values->Remove(settingName);
00069
00070     DisplayOutput();
00071 }
00072
00073 void CompositeSettings::DisplayOutput()
00074 {
00075     ApplicationDataCompositeValue^ composite = safe_cast<ApplicationDataCompositeValue^>(roamingSettings->Values->Lookup(settingName));
00076
00077     String^ output;
00078     if (composite == nullptr)
00079     {
00080         output = "Composite Setting: <empty>";
00081     }
00082     else
00083     {
00084         int one = safe_cast<IPropertyValue^>(composite->Lookup(settingName1))->GetInt32();
00085         String^ hello = safe_cast<String^>(composite->Lookup(settingName2));
00086
00087         output = "Composite Setting: {"
00088             + settingName1
00089             +" = "
00090             + one.ToString()
00091             + ", "
00092             + settingName2
00093             + " = \""
00094             + hello
00095             + "\"}";
00096     }
00097
00098     OutputTextBlock->Text = output;
00099 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson5.Components/BasicCamera.h Source File

  • Direct3D tutorial
  • Lesson5.Components

BasicCamera.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // A simple camera class.
00011 ref class BasicCamera
00012 {
00013
00014 private:
00015     float3 m_position;      // the position of the camera
00016     float3 m_direction;     // the unit vector of the viewing direction
00017     float4x4 m_view;        // view matrix
00018     float4x4 m_projection;  // projection matrix
00019
00020 internal:
00021     void GetViewMatrix(_Out_ float4x4 *viewMatrix);
00022     void GetProjectionMatrix(_Out_ float4x4 *projectionMatrix);
00023
00024     // this method updates the view matrix based on new position and focus coordinates
00025     void SetViewParameters(
00026         _In_ float3 eyePosition,    // the position of the camera
00027         _In_ float3 lookPosition,   // the point the camera should look at
00028         _In_ float3 up              // the durection vector for up
00029         );
00030
00031     // this method updates the projection matrix based on new parameters
00032     void SetProjectionParameters(
00033         _In_ float minimumFieldOfView,  // the minimum horizontal or vertical field of view, in degrees
00034         _In_ float aspectRatio,         // the aspect ratio of the projection (width / height)
00035         _In_ float nearPlane,           // depth to map to 0
00036         _In_ float farPlane             // depth to map to 1
00037         );
00038 };
Generated on Sat Nov 23 2024 16:08:07 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MainPage.xaml.cpp Source File

  • Media extensions

MainPage.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.cpp
00010 // Implementation of the MainPage.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "MainPage.xaml.h"
00015 #include "App.xaml.h"
00016
00017 using namespace Windows::Media;
00018 using namespace Windows::Storage;
00019 using namespace Windows::System;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::UI;
00023 using namespace Windows::UI::Core;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Data;
00027 using namespace Windows::UI::Xaml::Navigation;
00028 using namespace Windows::UI::Xaml::Interop;
00029 using namespace Platform;
00030 using namespace Platform::Collections;
00031 using namespace MediaExtensionsCPP;
00032 using namespace CppSamplesUtils;
00033 using namespace MediaExtensionsCPP;
00034
00035 using namespace concurrency;
00036
00037 MainPage::MainPage()
00038 {
00039     InitializeComponent();
00040
00041     SetFeatureName("Media Extensions");
00042
00043     _scenariosFrame = ScenarioList;
00044     _inputFrame = ScenarioInput;
00045     _outputFrame = ScenarioOutput;
00046
00047     _layoutHandlerToken = Window::Current->SizeChanged += ref new Windows::UI::Xaml::WindowSizeChangedEventHandler(this, &MainPage::Page_SizeChanged);
00048
00049     _pageLoadedHandlerToken = Loaded += ref new RoutedEventHandler(this, &MainPage::Page_Loaded);
00050     _logicalDpiChangedToken = DisplayProperties::LogicalDpiChanged += ref new DisplayPropertiesEventHandler(this, &MainPage::DisplayProperties_LogicalDpiChanged);
00051
00052     _extensionManager = ref new MediaExtensionManager();
00053 }
00054
00055 MainPage::~MainPage()
00056 {
00057 }
00058
00059 void MainPage::Page_Loaded(Object^ sender, RoutedEventArgs^ e)
00060 {
00061     // Load the ScenarioList page into the proper frame.
00062     TypeName pageType = { "MediaExtensionsCPP.ScenarioList", TypeKind::Custom };
00063     ScenarioList->Navigate(pageType, this);
00064
00065     // Figure out what resolution and orientation we are in and respond appropriately.
00066     CheckResolutionAndViewState();
00067 }
00068
00069 void MainPage::SetFeatureName(String^ strFeature)
00070 {
00071     FeatureName->Text = strFeature;
00072 }
00073
00074 void MainPage::Page_SizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00075 {
00076     CheckResolutionAndViewState();
00077 }
00078
00079 void MainPage::DisplayProperties_LogicalDpiChanged(Object^ sender)
00080 {
00081     CheckResolutionAndViewState();
00082 }
00083
00084 void MainPage::CheckResolutionAndViewState()
00085 {
00086     ApplicationViewState state = ApplicationView::Value;
00087     String^ stateString = ConvertViewState(state);
00088
00089     ResolutionScale scale = DisplayProperties::ResolutionScale;
00090     String^ scaleString = ConvertResolution(scale);
00091
00092     VisualStateManager::GoToState(this, stateString + scaleString, false);
00093 }
00094
00095 String^ MainPage::ConvertViewState(ApplicationViewState state)
00096 {
00097     switch (state)
00098     {
00099     case ApplicationViewState::Filled:
00100         return "Filled";
00101     case ApplicationViewState::FullScreenLandscape:
00102         return "FullScreenLandscape";
00103     case ApplicationViewState::FullScreenPortrait:
00104         return "FullScreenPortrait";
00105     case ApplicationViewState::Snapped:
00106         return "Snapped";
00107     }
00108     return "";
00109 }
00110
00111 String^ MainPage::ConvertResolution(ResolutionScale scale)
00112 {
00113     switch (scale)
00114     {
00115     case ResolutionScale::Scale100Percent:
00116         return "Scale100Percent";
00117     case ResolutionScale::Scale140Percent:
00118         return "Scale140Percent";
00119     case ResolutionScale::Scale180Percent:
00120         return "Scale180Percent";
00121     }
00122     return "";
00123 }
00124
00125 void MainPage::DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^ frame)
00126 {
00127     frame->Navigate(pageType, this);
00128
00129     std::wstring PageName(pageType.Name->Data());
00130     std::basic_string <wchar_t>::size_type indexSubstring;
00131     indexSubstring = PageName.find(L"Output");
00132     if (indexSubstring != std::wstring::npos)
00133     {
00134         // Raise OutputFrameLoaded so downstream pages know that the output frame content has been loaded.
00135         OutputFrameLoaded(this, nullptr);
00136     }
00137     else
00138     {
00139         // Raise InputFrameLoaded so downstream pages know that the input frame content has been loaded.
00140         InputFrameLoaded(this, nullptr);
00141     }
00142 }
00143
00144 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00145 {
00146     switch (type)
00147     {
00148     case NotifyType::StatusMessage:
00149         StatusBlock->Style = dynamic_cast<Windows::UI::Xaml::Style^>(App::Current->Resources->Lookup("StatusStyle"));
00150         break;
00151     case NotifyType::ErrorMessage:
00152         StatusBlock->Style = dynamic_cast<Windows::UI::Xaml::Style^>(App::Current->Resources->Lookup("ErrorStyle"));
00153         break;
00154     default:
00155         break;
00156     }
00157     StatusBlock->Text = strMessage;
00158 }
00159
00160 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00161 {
00162     auto _hyperlinkButton = (HyperlinkButton^)sender;
00163     auto uri = ref new Windows::Foundation::Uri((String^)_hyperlinkButton->Tag);
00164
00165     Windows::System::Launcher::LaunchUriAsync(uri);
00166 }
00167
00168 //
00169 //  Open a single file picker [with fileTypeFilter].
00170 //  And then, call media.SetSource(picked file).
00171 //  If the file is successfully opened, VideoMediaOpened() will be called and call media.Play().
00172 //
00173 void MainPage::PickSingleFileAndSet(IVector<String^>^ fileTypeFilters, IVector<MediaElement^>^ mediaElements)
00174 {
00175     auto currentState = Windows::UI::ViewManagement::ApplicationView::Value;
00176     if (currentState == Windows::UI::ViewManagement::ApplicationViewState::Snapped &&
00177         !Windows::UI::ViewManagement::ApplicationView::TryUnsnap())
00178     {
00179         // File picker cannot be used in the snapped state.
00180         NotifyUser("File picker cannot be used when application is in the snapped state.", NotifyType::StatusMessage);
00181         return;
00182     }
00183
00184     // FileOpenPicker - PickSingleFileAsync
00185     auto picker = ref new Pickers::FileOpenPicker();
00186     auto dispatcher = Window::Current->Dispatcher;
00187     picker->SuggestedStartLocation = Pickers::PickerLocationId::VideosLibrary;
00188     for (unsigned int index = 0; index < fileTypeFilters->Size; ++index)
00189     {
00190         picker->FileTypeFilter->Append(fileTypeFilters->GetAt(index));
00191     }
00192
00193     task<StorageFile^> (picker->PickSingleFileAsync()).then(
00194         [mediaElements](StorageFile^ file)
00195     {
00196         if (file)
00197         {
00198             auto contentType = file->ContentType;
00199             task<Streams::IRandomAccessStream^> (file->OpenAsync(FileAccessMode::Read)).then(
00200                 [contentType, mediaElements](Streams::IRandomAccessStream^ strm)
00201             {
00202                 {
00203                     for (unsigned int i = 0; i < mediaElements->Size; ++i)
00204                     {
00205                         MediaElement^ media = mediaElements->GetAt(i);
00206                         media->Stop();
00207
00208                         if (i + 1 < mediaElements->Size)
00209                         {
00210                             media->SetSource(strm->CloneStream(), contentType);
00211                         }
00212                         else
00213                         {
00214                             media->SetSource(strm, contentType);
00215                         }
00216                     }
00217                 }
00218             });
00219         }
00220     });
00221 }
00222
00223 void MainPage::VideoOnError(Object^ obj, ExceptionRoutedEventArgs^ args)
00224 {
00225     NotifyUser("Cannot open video file - error: " + args->ErrorMessage, NotifyType::ErrorMessage);
00226 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Credential picker/C++/ScenarioOutput1.xaml.cpp Source File

  • Credential picker

ScenarioOutput1.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.cpp
00010 // Implementation of the Scenario1Output class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioOutput1.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace CredentialPickerCPP;
00018
00019 using namespace Platform;
00020 using namespace Windows::Foundation;
00021 using namespace Windows::Foundation::Collections;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Controls::Primitives;
00027 using namespace Windows::UI::Xaml::Data;
00028 using namespace Windows::UI::Xaml::Input;
00029 using namespace Windows::UI::Xaml::Media;
00030 using namespace Windows::UI::Xaml::Navigation;
00031
00032 ScenarioOutput1::ScenarioOutput1()
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioOutput1::~ScenarioOutput1()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioOutput1::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Get a pointer to our main page.
00045     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047     // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048     _frameLoadedToken = rootPage->InputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioOutput1::rootPage_InputFrameLoaded);
00049 }
00050
00051 void ScenarioOutput1::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     rootPage->InputFrameLoaded -= _frameLoadedToken;
00054 }
00055
00056 #pragma endregion
00057
00058 #pragma region Use this code if you need access to elements in the input frame - otherwise delete
00059 void ScenarioOutput1::rootPage_InputFrameLoaded(Object^ sender, Object^ e)
00060 {
00061     // Get a pointer to the content within the OutputFrame.
00062     Page^ inputFrame = dynamic_cast<Page^>(rootPage->InputFrame->Content);
00063
00064     // Go find the elements that we need for this scenario
00065     // ex: flipView1 = dynamic_cast<FlipView^>(inputFrame->FindName("FlipView1"));
00066 }
00067
00068 #pragma endregion
Generated on Sat Nov 23 2024 16:08:00 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Date and time formatting/C++/LongAndShortFormats.xaml.h Source File

  • Date and time formatting

LongAndShortFormats.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // LongAndShortFormats.xaml.h
00013 // Declaration of the LongAndShortFormats class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "LongAndShortFormats.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace DateTimeFormatting
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class LongAndShortFormats sealed
00031         {
00032         public:
00033             LongAndShortFormats();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/DirectXBase.cpp Source File

  • Direct2D 3D transform effect

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace Windows::UI::Xaml::Controls;
00016 using namespace D2D1;
00017
00018 // Constructor.
00019 DirectXBase::DirectXBase() :
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(
00026     CoreWindow^ window,
00027     SwapChainBackgroundPanel^ swapChainPanel,
00028     float dpi
00029     )
00030 {
00031     m_window = window;
00032     m_swapChainPanel = swapChainPanel;
00033
00034     CreateDeviceIndependentResources();
00035     CreateDeviceResources();
00036     SetDpi(dpi);
00037 }
00038
00039 // Recreate all device resources and set them back to the current state.
00040 void DirectXBase::HandleDeviceLost()
00041 {
00042     // Reset these member variables to ensure that SetDpi recreates all resources.
00043     float dpi = m_dpi;
00044     m_dpi = -1.0f;
00045     m_windowBounds.Width = 0;
00046     m_windowBounds.Height = 0;
00047     m_swapChain = nullptr;
00048
00049     CreateDeviceResources();
00050     SetDpi(dpi);
00051 }
00052
00053 // These are the resources required independent of the device.
00054 void DirectXBase::CreateDeviceIndependentResources()
00055 {
00056     D2D1_FACTORY_OPTIONS options;
00057     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00058
00059 #if defined(_DEBUG)
00060     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00061     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00062 #endif
00063
00064     DX::ThrowIfFailed(
00065         D2D1CreateFactory(
00066             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00067             __uuidof(ID2D1Factory1),
00068             &options,
00069             &m_d2dFactory
00070             )
00071         );
00072
00073     DX::ThrowIfFailed(
00074         DWriteCreateFactory(
00075             DWRITE_FACTORY_TYPE_SHARED,
00076             __uuidof(IDWriteFactory),
00077             &m_dwriteFactory
00078             )
00079         );
00080
00081     DX::ThrowIfFailed(
00082         CoCreateInstance(
00083             CLSID_WICImagingFactory,
00084             nullptr,
00085             CLSCTX_INPROC_SERVER,
00086             IID_PPV_ARGS(&m_wicFactory)
00087             )
00088         );
00089 }
00090
00091 // These are the resources that depend on the device.
00092 void DirectXBase::CreateDeviceResources()
00093 {
00094     // This flag adds support for surfaces with a different color channel ordering
00095     // than the API default. It is required for compatibility with Direct2D.
00096     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00097     ComPtr<IDXGIDevice> dxgiDevice;
00098
00099 #if defined(_DEBUG)
00100     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00101     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00102 #endif
00103
00104     // This array defines the set of DirectX hardware feature levels this app will support.
00105     // Note the ordering should be preserved.
00106     // Don't forget to declare your application's minimum required feature level in its
00107     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00108     D3D_FEATURE_LEVEL featureLevels[] =
00109     {
00110         D3D_FEATURE_LEVEL_11_1,
00111         D3D_FEATURE_LEVEL_11_0,
00112         D3D_FEATURE_LEVEL_10_1,
00113         D3D_FEATURE_LEVEL_10_0,
00114         D3D_FEATURE_LEVEL_9_3,
00115         D3D_FEATURE_LEVEL_9_2,
00116         D3D_FEATURE_LEVEL_9_1
00117     };
00118
00119     // Create the Direct3D 11 API device object and a corresponding context.
00120     ComPtr<ID3D11Device> device;
00121     ComPtr<ID3D11DeviceContext> context;
00122     DX::ThrowIfFailed(
00123         D3D11CreateDevice(
00124             nullptr,                    // Specify nullptr to use the default adapter.
00125             D3D_DRIVER_TYPE_HARDWARE,
00126             0,
00127             creationFlags,              // Set debug and Direct2D compatibility flags.
00128             featureLevels,              // List of feature levels this app can support.
00129             ARRAYSIZE(featureLevels),
00130             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00131             &device,                    // Returns the Direct3D device created.
00132             &m_featureLevel,            // Returns feature level of device created.
00133             &context                    // Returns the device immediate context.
00134             )
00135         );
00136
00137     // Get the Direct3D 11.1 API device and context interfaces.
00138     DX::ThrowIfFailed(
00139         device.As(&m_d3dDevice)
00140         );
00141
00142     DX::ThrowIfFailed(
00143         context.As(&m_d3dContext)
00144         );
00145
00146     // Get the underlying DXGI device of the Direct3D device.
00147     DX::ThrowIfFailed(
00148         m_d3dDevice.As(&dxgiDevice)
00149         );
00150
00151     // Create the Direct2D device object and a corresponding context.
00152     DX::ThrowIfFailed(
00153         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00154         );
00155
00156     DX::ThrowIfFailed(
00157         m_d2dDevice->CreateDeviceContext(
00158             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00159             &m_d2dContext
00160             )
00161         );
00162 }
00163
00164 // Helps track the DPI in the helper class.
00165 // This is called in the dpiChanged event handler in the view class.
00166 void DirectXBase::SetDpi(float dpi)
00167 {
00168     if (dpi != m_dpi)
00169     {
00170         // Save the DPI of this display in our class.
00171         m_dpi = dpi;
00172
00173         // Update Direct2D's stored DPI.
00174         m_d2dContext->SetDpi(m_dpi, m_dpi);
00175
00176         // Often a DPI change implies a window size change. In some cases Windows will issue
00177         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00178         // will not change, and the window resize code will only be executed once.
00179         UpdateForWindowSizeChange();
00180     }
00181 }
00182
00183 // This routine is called in the event handler for the view SizeChanged event.
00184 void DirectXBase::UpdateForWindowSizeChange()
00185 {
00186     // Only handle window size changed if there is no pending DPI change.
00187     if (m_dpi != DisplayProperties::LogicalDpi)
00188     {
00189         return;
00190     }
00191
00192     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00193         m_window->Bounds.Height != m_windowBounds.Height)
00194     {
00195         m_d2dContext->SetTarget(nullptr);
00196         m_d2dTargetBitmap = nullptr;
00197         m_d3dRenderTargetView = nullptr;
00198         m_d3dDepthStencilView = nullptr;
00199         CreateWindowSizeDependentResources();
00200     }
00201 }
00202
00203 // Allocate all memory resources that change on a window SizeChanged event.
00204 void DirectXBase::CreateWindowSizeDependentResources()
00205 {
00206     // Store the window bounds so the next time we get a SizeChanged event we can
00207     // avoid rebuilding everything if the size is identical.
00208     m_windowBounds = m_window->Bounds;
00209
00210     // If the swap chain already exists, resize it.
00211     if (m_swapChain != nullptr)
00212     {
00213         HRESULT hr = m_swapChain->ResizeBuffers(
00214             2,
00215             static_cast<UINT>(m_window->Bounds.Width * m_dpi / 96.0f), // Can not use 0 to get the default on Composition SwapChain.
00216             static_cast<UINT>(m_window->Bounds.Height * m_dpi / 96.0f),
00217             DXGI_FORMAT_B8G8R8A8_UNORM,
00218             0
00219             );
00220
00221         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00222         {
00223             // If the device was removed for any reason, a new device and swapchain will need to be created.
00224             HandleDeviceLost();
00225
00226             // Everything is set up now. Do not continue execution of this method.
00227             return;
00228         }
00229         else
00230         {
00231             DX::ThrowIfFailed(hr);
00232         }
00233     }
00234     else // If it does not exist, create it.
00235     {
00236         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00237         swapChainDesc.Width = static_cast<UINT>(m_window->Bounds.Width * m_dpi / 96.0f); // Can not use 0 to get the default on Composition SwapChain.
00238         swapChainDesc.Height = static_cast<UINT>(m_window->Bounds.Height * m_dpi / 96.0f);
00239         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // Use the recommended color format.
00240         swapChainDesc.Stereo = false;
00241         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00242         swapChainDesc.SampleDesc.Quality = 0;
00243         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT; // Allow it to be used as a render target.
00244         swapChainDesc.BufferCount = 2;                               // Use double buffering to enable flip effect.
00245         swapChainDesc.Scaling = DXGI_SCALING_STRETCH;
00246         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // This is the recommended swap effect.
00247         swapChainDesc.Flags = 0;
00248
00249         // Once the desired swap chain description is configured, it must be created on the same adapter as our D3D Device.
00250
00251         // First, retrieve the underlying DXGI Device from the D3D Device.
00252         ComPtr<IDXGIDevice1> dxgiDevice;
00253         DX::ThrowIfFailed(
00254             m_d3dDevice.As(&dxgiDevice)
00255             );
00256
00257         // Next, get the associated adapter from the DXGI Device.
00258         ComPtr<IDXGIAdapter> dxgiAdapter;
00259         DX::ThrowIfFailed(
00260             dxgiDevice->GetAdapter(&dxgiAdapter)
00261             );
00262
00263         // Next, get the parent factory from the DXGI adapter.
00264         ComPtr<IDXGIFactory2> dxgiFactory;
00265         DX::ThrowIfFailed(
00266             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00267             );
00268
00269         // Create the swap chain and then associate it with the SwapChainBackgroundPanel.
00270         DX::ThrowIfFailed(
00271             dxgiFactory->CreateSwapChainForComposition(
00272                 m_d3dDevice.Get(),
00273                 &swapChainDesc,
00274                 nullptr,
00275                 &m_swapChain
00276                 )
00277             );
00278
00279         ComPtr<ISwapChainBackgroundPanelNative> dxRootPanelAsSwapChainBackgroundPanel;
00280
00281         // Set the swap chain on the SwapChainBackgroundPanel.
00282         reinterpret_cast<IUnknown*>(m_swapChainPanel)->QueryInterface(
00283             IID_PPV_ARGS(&dxRootPanelAsSwapChainBackgroundPanel)
00284             );
00285
00286         DX::ThrowIfFailed(
00287             dxRootPanelAsSwapChainBackgroundPanel->SetSwapChain(m_swapChain.Get())
00288             );
00289
00290         // Ensure that DXGI does not queue more than one frame at a time. This both reduces
00291         // latency and ensures that the application will only render after each VSync, minimizing
00292         // power consumption.
00293         DX::ThrowIfFailed(
00294             dxgiDevice->SetMaximumFrameLatency(1)
00295             );
00296     }
00297
00298     // Create a view on the swap chain back buffer.
00299     ComPtr<ID3D11Texture2D> backBuffer;
00300     DX::ThrowIfFailed(
00301         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00302         );
00303
00304     D3D11_RENDER_TARGET_VIEW_DESC renderTargetViewDesc = {};
00305     renderTargetViewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00306     renderTargetViewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2DARRAY;        // Render target view is a Texture2D array.
00307     renderTargetViewDesc.Texture2DArray.MipSlice = 0;                               // Each array element is one Texture2D.
00308     renderTargetViewDesc.Texture2DArray.ArraySize = 1;
00309     renderTargetViewDesc.Texture2DArray.FirstArraySlice = 0;
00310     DX::ThrowIfFailed(
00311         m_d3dDevice->CreateRenderTargetView(
00312             backBuffer.Get(),
00313             &renderTargetViewDesc,
00314             &m_d3dRenderTargetView
00315             )
00316         );
00317
00318     // Get the back buffer description for later use.
00319     D3D11_TEXTURE2D_DESC backBufferDesc;
00320     backBuffer->GetDesc(&backBufferDesc);
00321
00322     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00323     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00324
00325     D2D1_BITMAP_PROPERTIES1 bitmapProperties = {};
00326     bitmapProperties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
00327     bitmapProperties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
00328     bitmapProperties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
00329     bitmapProperties.colorContext = nullptr;
00330     bitmapProperties.dpiX = m_dpi;
00331     bitmapProperties.dpiY = m_dpi;
00332
00333     ComPtr<IDXGIResource1> dxgiBackBuffer;
00334     DX::ThrowIfFailed(
00335         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00336         );
00337
00338     ComPtr<IDXGISurface2> dxgiSurface;
00339     DX::ThrowIfFailed(
00340         dxgiBackBuffer->CreateSubresourceSurface(0, &dxgiSurface)
00341         );
00342
00343     DX::ThrowIfFailed(
00344         m_d2dContext->CreateBitmapFromDxgiSurface(
00345             dxgiSurface.Get(),
00346             &bitmapProperties,
00347             &m_d2dTargetBitmap
00348             )
00349         );
00350
00351     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00352 }
00353
00354 // Method to deliver the final image to the display.
00355 void DirectXBase::Present()
00356 {
00357     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00358     // in certain scenarios.  In this sample, however, we do not utilize those features.
00359     DXGI_PRESENT_PARAMETERS parameters = {0};
00360     parameters.DirtyRectsCount = 0;
00361     parameters.pDirtyRects = nullptr;
00362     parameters.pScrollRect = nullptr;
00363     parameters.pScrollOffset = nullptr;
00364
00365     // The first argument instructs DXGI to block until VSync, putting the application
00366     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00367     // frames that will never be displayed to the screen.
00368     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00369
00370     // If the device was removed either by a disconnect or a driver upgrade, we
00371     // must recreate all device resources.
00372     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00373     {
00374         HandleDeviceLost();
00375     }
00376     else
00377     {
00378         DX::ThrowIfFailed(hr);
00379     }
00380 }
00381
00382 void DirectXBase::ValidateDevice()
00383 {
00384     // The D3D Device is no longer valid if the default adapter changes or if
00385     // the device has been removed.
00386
00387     // First, get the information for the adapter related to the current device.
00388
00389     ComPtr<IDXGIDevice1> dxgiDevice;
00390     ComPtr<IDXGIAdapter> deviceAdapter;
00391     DXGI_ADAPTER_DESC deviceDesc;
00392     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00393     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00394     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00395
00396     // Next, get the information for the default adapter.
00397
00398     ComPtr<IDXGIFactory2> dxgiFactory;
00399     ComPtr<IDXGIAdapter1> currentAdapter;
00400     DXGI_ADAPTER_DESC currentDesc;
00401     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00402     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00403     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00404
00405     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00406     // a new D3D device must be created.
00407
00408     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00409         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00410         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00411     {
00412         // Release references to resources related to the old device.
00413         dxgiDevice = nullptr;
00414         deviceAdapter = nullptr;
00415
00416         // Create a new device and swap chain.
00417         HandleDeviceLost();
00418     }
00419 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson1.Basics/pch.h Source File

  • Direct3D tutorial
  • Lesson1.Basics

pch.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include <wrl.h>
00011 #include <d3d11_1.h>
00012 #include <agile.h>
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/Mouse.xaml.h Source File

  • Input Device capabilities

Mouse.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Mouse.xaml.h
00013 // Declaration of the Mouse class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Mouse.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace DeviceCaps
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Mouse sealed
00031         {
00032         public:
00033             Mouse();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void MouseGetSettings_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040         };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ProximityCPP::Scenario Member List

This is the complete list of members for ProximityCPP::Scenario, including all inherited members.
ClassName | ProximityCPP::Scenario
Title | ProximityCPP::Scenario
Generated on Sat Nov 23 2024 16:09:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioInput1.xaml.cpp Source File

  • Language font mapping

ScenarioInput1.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Input.xaml.cpp
00010 // Implementation of the Scenario1Input class
00011 //
00012
00013 #include "pch.h"
00014 #include "ScenarioInput1.xaml.h"
00015
00016 using namespace LanguageFontCPP;
00017
00018 using namespace Platform;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::Graphics::Display;
00022 using namespace Windows::UI::ViewManagement;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Controls::Primitives;
00026 using namespace Windows::UI::Xaml::Data;
00027 using namespace Windows::UI::Xaml::Input;
00028 using namespace Windows::UI::Xaml::Media;
00029 using namespace Windows::UI::Xaml::Navigation;
00030 using namespace Windows::Globalization::Fonts;
00031
00032 ScenarioInput1::ScenarioInput1() : _oriHeadingUI(nullptr), _oriTextUI(nullptr)
00033 {
00034     InitializeComponent();
00035 }
00036
00037 ScenarioInput1::~ScenarioInput1()
00038 {
00039 }
00040
00041 #pragma region Template-Related Code - Do not remove
00042 void ScenarioInput1::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     // Get a pointer to our main page.
00045     rootPage = dynamic_cast<MainPage^>(e->Parameter);
00046
00047     // We want to be notified with the OutputFrame is loaded so we can get to the content.
00048     _frameLoadedToken = rootPage->OutputFrameLoaded += ref new Windows::Foundation::EventHandler<Platform::Object^>(this, &ScenarioInput1::rootPage_OutputFrameLoaded);
00049 }
00050
00051 void ScenarioInput1::OnNavigatedFrom(NavigationEventArgs^ e)
00052 {
00053     rootPage->OutputFrameLoaded -= _frameLoadedToken;
00054
00055   if (_oriHeadingUI != nullptr)
00056     {
00057     Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00058     auto headingUI = dynamic_cast<TextBlock^>(outputFrame->FindName("Scenario1Heading"));
00059     auto textUI = dynamic_cast<TextBlock^>(outputFrame->FindName("Scenario1Text"));
00060         _oriHeadingUI->Reset(headingUI);
00061         _oriTextUI->Reset(textUI);
00062     }
00063 }
00064
00065 #pragma endregion
00066
00067 #pragma region Use this code if you need access to elements in the output frame - otherwise delete
00068 void ScenarioInput1::rootPage_OutputFrameLoaded(Object^ sender, Object^ e)
00069 {
00070     // Get a pointer to the content within the OutputFrame.
00071     Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00072
00073     // Go find the elements that we need for this scenario
00074     // ex: flipView1 = dynamic_cast<FlipView^>(outputFrame->FindName("FlipView1"));
00075 }
00076
00077 #pragma endregion
00078
00079 #pragma region Sample click handlers - modify if you need them, otherwise delete
00080
00081 void ScenarioInput1::ApplyFont_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00082 {
00083     Button^ b = dynamic_cast<Button^>(sender);
00084     if (b != nullptr)
00085     {
00086         rootPage->NotifyUser("You clicked the " + b->Name + " button", NotifyType::StatusMessage);
00087     }
00088
00089   auto languageFontGroup = ref new LanguageFontGroup("ja-JP");
00090
00091   Page^ outputFrame = dynamic_cast<Page^>(rootPage->OutputFrame->Content);
00092     auto headingUI = dynamic_cast<TextBlock^>(outputFrame->FindName("Scenario1Heading"));
00093     auto textUI = dynamic_cast<TextBlock^>(outputFrame->FindName("Scenario1Text"));
00094
00095     if (_oriHeadingUI == nullptr)
00096     {
00097         // Store original font style for Reset
00098         _oriHeadingUI = ref new FontInfoLocal();
00099         _oriTextUI = ref new FontInfoLocal();
00100         _oriHeadingUI->Set(headingUI);
00101         _oriTextUI->Set(textUI);
00102     }
00103
00104     // Change the Font value with selected font from LanguageFontGroup API
00105     FontInfoLocal::SetFont(headingUI, languageFontGroup->UIHeadingFont);
00106     FontInfoLocal::SetFont(textUI, languageFontGroup->UITextFont);
00107 }
00108
00109 #pragma endregion
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Reading and writing data/C++/common/suspensionmanager.cpp Source File

  • Reading and writing data
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Real-time communication/C#,C++/MainPage.xaml.cs Source File

  • Real-time communication
  • C#,C++

MainPage.xaml.cs

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 using System;
00012 using Windows.UI.ViewManagement;
00013 using Windows.UI.Xaml;
00014 using Windows.UI.Xaml.Controls;
00015 using Windows.UI.Xaml.Markup;
00016 using Windows.UI.Xaml.Navigation;
00017
00018
00019 namespace SDKTemplate
00020 {
00021     /// <summary>
00022     /// An empty page that can be used on its own or navigated to within a Frame.
00023     /// </summary>
00024     public sealed partial class MainPage : SDKTemplate.Common.LayoutAwarePage
00025     {
00026         public event System.EventHandler ScenarioLoaded;
00027         public event EventHandler<MainPageSizeChangedEventArgs> MainPageResized;
00028         public bool AutoSizeInputSectionWhenSnapped = true;
00029
00030         public Windows.ApplicationModel.Activation.LaunchActivatedEventArgs LaunchArgs
00031         {
00032             get
00033             {
00034                 return ((App)App.Current).LaunchArgs;
00035             }
00036         }
00037
00038         public static MainPage Current;
00039
00040         private Frame HiddenFrame = null;
00041
00042         public MainPage()
00043         {
00044             this.InitializeComponent();
00045
00046             // This is a static public property that will allow downstream pages to get
00047             // a handle to the MainPage instance in order to call methods that are in this class.
00048             Current = this;
00049
00050             // This frame is hidden, meaning it is never shown.  It is simply used to load
00051             // each scenario page and then pluck out the input and output sections and
00052             // place them into the UserControls on the main page.
00053             HiddenFrame = new Windows.UI.Xaml.Controls.Frame();
00054             HiddenFrame.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
00055             ContentRoot.Children.Add(HiddenFrame);
00056
00057             // Populate the sample title from the constant in the Constants.cs file.
00058             SetFeatureName(FEATURE_NAME);
00059             Scenarios.SelectionChanged += Scenarios_SelectionChanged;
00060             SizeChanged += MainPage_SizeChanged;
00061         }
00062
00063         void MainPage_SizeChanged(object sender, SizeChangedEventArgs e)
00064         {
00065             InvalidateSize();
00066             if (MainPageResized != null)
00067             {
00068                 MainPageSizeChangedEventArgs args = new MainPageSizeChangedEventArgs();
00069                 args.ViewState = ApplicationView.Value;
00070                 MainPageResized(this, args);
00071             }
00072         }
00073
00074         /// <summary>
00075         /// Invoked when this page is about to be displayed in a Frame.
00076         /// </summary>
00077         /// <param name="e">Event data that describes how this page was reached.  The Parameter
00078         /// property is typically used to configure the page.</param>
00079         protected override void OnNavigatedTo(NavigationEventArgs e)
00080         {
00081             PopulateScenarios();
00082             InvalidateViewState();
00083         }
00084
00085         private void InvalidateSize()
00086         {
00087             // Get the window width
00088             double windowWidth = this.ActualWidth;
00089             if (windowWidth != 0.0)
00090             {
00091                 // Get the width of the ListBox.
00092                 double listBoxWidth = Scenarios.ActualWidth;
00093
00094                 // Is the ListBox using any margins that we need to consider?
00095                 double listBoxMarginLeft = Scenarios.Margin.Left;
00096                 double listBoxMarginRight = Scenarios.Margin.Right;
00097
00098                 // Figure out how much room is left after considering the list box width
00099                 double availableWidth = windowWidth - listBoxWidth;
00100
00101                 // Is the top most child using margins?
00102                 double layoutRootMarginLeft = ContentRoot.Margin.Left;
00103                 double layoutRootMarginRight = ContentRoot.Margin.Right;
00104
00105                 // We have different widths to use depending on the view state
00106                 if (ApplicationView.Value != ApplicationViewState.Snapped)
00107                 {
00108                     // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00109                     // and the LayoutRoot's margins
00110                     InputSection.Width = availableWidth - (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
00111                 }
00112                 else
00113                 {
00114                     // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00115                     if (AutoSizeInputSectionWhenSnapped)
00116                     {
00117                         InputSection.Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
00118                     }
00119                 }
00120             }
00121             InvalidateViewState();
00122         }
00123
00124         private void InvalidateViewState()
00125         {
00126             if (ApplicationView.Value == ApplicationViewState.Snapped)
00127             {
00128                 Grid.SetRow(DescriptionText, 3);
00129                 Grid.SetColumn(DescriptionText, 0);
00130
00131                 Grid.SetRow(InputSection, 4);
00132                 Grid.SetColumn(InputSection, 0);
00133
00134                 Grid.SetRow(FooterPanel, 2);
00135                 Grid.SetColumn(FooterPanel, 0);
00136             }
00137             else
00138             {
00139                 Grid.SetRow(DescriptionText, 1);
00140                 Grid.SetColumn(DescriptionText, 1);
00141
00142                 Grid.SetRow(InputSection, 2);
00143                 Grid.SetColumn(InputSection, 1);
00144
00145                 Grid.SetRow(FooterPanel, 1);
00146                 Grid.SetColumn(FooterPanel, 1);
00147             }
00148
00149             // Since we don't load the scenario page in the traditional manner (we just pluck out the
00150             // input and output sections from the page) we need to ensure that any VSM code used
00151             // by the scenario's input and output sections is fired.
00152             VisualStateManager.GoToState((Control)InputSection, "Input" + ApplicationView.Value.ToString(), false);
00153             VisualStateManager.GoToState((Control)OutputSection, "Output" + ApplicationView.Value.ToString(), false);
00154         }
00155
00156         private void PopulateScenarios()
00157         {
00158             System.Collections.ObjectModel.ObservableCollection<object> ScenarioList = new System.Collections.ObjectModel.ObservableCollection<object>();
00159             int i = 0;
00160
00161             // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00162             foreach (Scenario s in scenarios)
00163             {
00164                 ListBoxItem item = new ListBoxItem();
00165                 s.Title = (++i).ToString() + ") " + s.Title;
00166                 item.Content = s;
00167                 item.Name = s.ClassType.FullName;
00168                 ScenarioList.Add(item);
00169             }
00170
00171             // Bind the ListBox to the scenario list.
00172             Scenarios.ItemsSource = ScenarioList;
00173
00174             // Starting scenario is the first or based upon a previous selection.
00175             int startingScenarioIndex = -1;
00176
00177             if (SuspensionManager.SessionState.ContainsKey("SelectedScenarioIndex"))
00178             {
00179                 int selectedScenarioIndex = Convert.ToInt32(SuspensionManager.SessionState["SelectedScenarioIndex"]);
00180                 startingScenarioIndex = selectedScenarioIndex;
00181             }
00182             Scenarios.SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00183             Scenarios.ScrollIntoView(Scenarios.SelectedItem);
00184         }
00185
00186         /// <summary>
00187         /// This method is responsible for loading the individual input and output sections for each scenario.  This
00188         /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00189         /// and output sections into the respective UserControl on the main page.
00190         /// </summary>
00191         /// <param name="scenarioName"></param>
00192         public void LoadScenario(Type scenarioClass)
00193         {
00194             AutoSizeInputSectionWhenSnapped = true;
00195
00196             // Load the ScenarioX.xaml file into the Frame.
00197             HiddenFrame.Navigate(scenarioClass, this);
00198
00199             // Get the top element, the Page, so we can look up the elements
00200             // that represent the input and output sections of the ScenarioX file.
00201             Page hiddenPage = HiddenFrame.Content as Page;
00202
00203             // Get each element.
00204             UIElement input = hiddenPage.FindName("Input") as UIElement;
00205             UIElement output = hiddenPage.FindName("Output") as UIElement;
00206
00207             if (input == null)
00208             {
00209                 // Malformed input section.
00210                 NotifyUser(String.Format(
00211                     "Cannot load scenario input section for {0}.  Make sure root of input section markup has x:Name of 'Input'",
00212                     scenarioClass.Name), NotifyType.ErrorMessage);
00213                 return;
00214             }
00215
00216             if (output == null)
00217             {
00218                 // Malformed output section.
00219                 NotifyUser(String.Format(
00220                     "Cannot load scenario output section for {0}.  Make sure root of output section markup has x:Name of 'Output'",
00221                     scenarioClass.Name), NotifyType.ErrorMessage);
00222                 return;
00223             }
00224
00225             // Find the LayoutRoot which parents the input and output sections in the main page.
00226             Panel panel = hiddenPage.FindName("LayoutRoot") as Panel;
00227
00228             if (panel != null)
00229             {
00230                 // Get rid of the content that is currently in the intput and output sections.
00231                 panel.Children.Remove(input);
00232                 panel.Children.Remove(output);
00233
00234                 // Populate the input and output sections with the newly loaded content.
00235                 InputSection.Content = input;
00236                 OutputSection.Content = output;
00237             }
00238             else
00239             {
00240                 // Malformed Scenario file.
00241                 NotifyUser(String.Format(
00242                     "Cannot load scenario: '{0}'.  Make sure root tag in the '{0}' file has an x:Name of 'LayoutRoot'",
00243                     scenarioClass.Name), NotifyType.ErrorMessage);
00244             }
00245         }
00246
00247         void Scenarios_SelectionChanged(object sender, SelectionChangedEventArgs e)
00248         {
00249             if (Scenarios.SelectedItem != null)
00250             {
00251                 NotifyUser("", NotifyType.StatusMessage);
00252
00253                 ListBoxItem selectedListBoxItem = Scenarios.SelectedItem as ListBoxItem;
00254                 SuspensionManager.SessionState["SelectedScenarioIndex"] = Scenarios.SelectedIndex;
00255
00256                 Scenario scenario = selectedListBoxItem.Content as Scenario;
00257                 LoadScenario(scenario.ClassType);
00258                 InvalidateSize();
00259
00260                 // Fire the ScenarioLoaded event since we know that everything is loaded now.
00261                 if (ScenarioLoaded != null)
00262                 {
00263                     ScenarioLoaded(this, new EventArgs());
00264                 }
00265             }
00266         }
00267
00268         public void NotifyUser(string strMessage, NotifyType type)
00269         {
00270             switch (type)
00271             {
00272                 // Use the status message style.
00273                 case NotifyType.StatusMessage:
00274                     StatusBlock.Style = Resources["StatusStyle"] as Style;
00275                     break;
00276                 // Use the error message style.
00277                 case NotifyType.ErrorMessage:
00278                     StatusBlock.Style = Resources["ErrorStyle"] as Style;
00279                     break;
00280             }
00281             StatusBlock.Text = strMessage;
00282
00283             // Collapse the StatusBlock if it has no text to conserve real estate.
00284             if (StatusBlock.Text != String.Empty)
00285             {
00286                 StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Visible;
00287             }
00288             else
00289             {
00290                 StatusBlock.Visibility = Windows.UI.Xaml.Visibility.Collapsed;
00291             }
00292         }
00293
00294         async void Footer_Click(object sender, RoutedEventArgs e)
00295         {
00296             await Windows.System.Launcher.LaunchUriAsync(new Uri(((HyperlinkButton)sender).Tag.ToString()));
00297         }
00298
00299         private void SetFeatureName(string str)
00300         {
00301             FeatureName.Text = str;
00302         }
00303     }
00304
00305     public class MainPageSizeChangedEventArgs : EventArgs
00306     {
00307         private ApplicationViewState viewState;
00308
00309         public ApplicationViewState ViewState
00310         {
00311             get { return viewState; }
00312             set { viewState = value; }
00313         }
00314     }
00315
00316     public enum NotifyType
00317     {
00318         StatusMessage,
00319         ErrorMessage
00320     };
00321 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D tutorial/C++/Lesson3.Cubes/DirectXSample.h Source File

  • Direct3D tutorial
  • Lesson3.Cubes

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media Play To/C++/common/LayoutAwarePage.h Source File

  • Media Play To
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C++/MainPage.xaml.h Source File

  • Media extensions

MainPage.xaml.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // MainPage.xaml.h
00010 // Declaration of the MainPage.xaml class.
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "MainPage.g.h"
00017
00018 using namespace Windows::UI::Xaml;
00019 using namespace Windows::UI::Xaml::Controls;
00020 using namespace Windows::Graphics::Display;
00021 using namespace Windows::UI::ViewManagement;
00022 using namespace Windows::UI::Xaml::Navigation;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::System;
00025 using namespace Platform;
00026 using namespace Windows::UI::Xaml::Interop;
00027
00028 namespace MediaExtensionsCPP
00029 {
00030     public enum class NotifyType
00031     {
00032         StatusMessage,
00033         ErrorMessage
00034     };
00035
00036     [Windows::Foundation::Metadata::WebHostHidden]
00037     public ref class MainPage sealed
00038     {
00039     public:
00040         MainPage();
00041
00042         property Windows::UI::Xaml::Controls::Frame^ ScenariosFrame
00043         {
00044             Windows::UI::Xaml::Controls::Frame^ get() { return _scenariosFrame; }
00045         }
00046         property Windows::UI::Xaml::Controls::Frame^ InputFrame
00047         {
00048             Windows::UI::Xaml::Controls::Frame^ get() { return _inputFrame; }
00049         }
00050         property Windows::UI::Xaml::Controls::Frame^ OutputFrame
00051         {
00052             Windows::UI::Xaml::Controls::Frame^ get() { return _outputFrame; }
00053         }
00054         property Windows::Media::MediaExtensionManager^ ExtensionManager
00055         {
00056             Windows::Media::MediaExtensionManager^ get() { return _extensionManager; }
00057         }
00058
00059         event Windows::Foundation::EventHandler<Platform::Object^>^ InputFrameLoaded;
00060         event Windows::Foundation::EventHandler<Platform::Object^>^ OutputFrameLoaded;
00061
00062         void NotifyUser(String^ strMessage, NotifyType type);
00063         void DoNavigation(TypeName pageType, Windows::UI::Xaml::Controls::Frame^ frame);
00064         String^ ConvertViewState(ApplicationViewState state);
00065         String^ ConvertResolution(ResolutionScale scale);
00066
00067         void PickSingleFileAndSet(Windows::Foundation::Collections::IVector<String^>^ fileTypeFilters, Windows::Foundation::Collections::IVector<MediaElement^>^ mediaElements);
00068         void VideoOnError(Object^ obj, ExceptionRoutedEventArgs^ args);
00069
00070     private:
00071         ~MainPage();
00072         Windows::UI::Xaml::Controls::Frame^ _scenariosFrame;
00073         Windows::UI::Xaml::Controls::Frame^ _inputFrame;
00074         Windows::UI::Xaml::Controls::Frame^ _outputFrame;
00075         void Footer_Click(Object^ sender, RoutedEventArgs^ e);
00076         Windows::Foundation::EventRegistrationToken _displayHandlerToken;
00077         Windows::Foundation::EventRegistrationToken _layoutHandlerToken;
00078         Windows::Foundation::EventRegistrationToken _pageLoadedHandlerToken;
00079         Windows::Foundation::EventRegistrationToken _logicalDpiChangedToken;
00080         Windows::Foundation::EventRegistrationToken _inputFrameLoadedToken;
00081         Windows::Foundation::EventRegistrationToken _outputFrameLoadedToken;
00082         void Page_SizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00083         void DisplayProperties_LogicalDpiChanged(Object^ sender);
00084         void Page_Loaded(Object^ sender, RoutedEventArgs^ e);
00085         void CheckResolutionAndViewState();
00086         void SetFeatureName(Platform::String^ strFeature);
00087         void inputFrameNavigated(Object^ sender, NavigationEventArgs^ e);
00088         void outputFrameNavigated(Object^ sender, NavigationEventArgs^ e);
00089
00090         Windows::Media::MediaExtensionManager^ _extensionManager;
00091     };
00092 }
Generated on Sat Nov 23 2024 16:07:46 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/pch.cpp Source File

  • XAudio2 audio stream effect

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Application data/C++/ClearScenario.xaml.h Source File

  • Application data

ClearScenario.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ClearScenario.xaml.h
00013 // Declaration of the ClearScenario class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "ClearScenario.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace ApplicationDataSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class ClearScenario sealed
00031         {
00032         public:
00033             ClearScenario();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039
00040             void Clear_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/FontFileStream.h Source File

  • Direct2D magazine app

FontFileStream.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 class FontFileStream : public IDWriteFontFileStream
00011 {
00012 public:
00013     FontFileStream(_In_ Platform::Array<byte>^ data);
00014
00015     virtual HRESULT STDMETHODCALLTYPE QueryInterface(
00016         REFIID uuid,
00017         _Outptr_ void** object
00018         ) override;
00019
00020     virtual ULONG STDMETHODCALLTYPE AddRef() override;
00021
00022     virtual ULONG STDMETHODCALLTYPE Release() override;
00023
00024     virtual HRESULT STDMETHODCALLTYPE ReadFileFragment(
00025         _Outptr_result_bytebuffer_(fragmentSize) void const** fragmentStart,
00026         UINT64 fileOffset,
00027         UINT64 fragmentSize,
00028         _Out_ void** fragmentContext
00029         ) override;
00030
00031     virtual void STDMETHODCALLTYPE ReleaseFileFragment(
00032         _In_ void* fragmentContext
00033         ) override;
00034
00035     virtual HRESULT STDMETHODCALLTYPE GetFileSize(
00036         _Out_ UINT64* fileSize
00037         ) override;
00038
00039     virtual HRESULT STDMETHODCALLTYPE GetLastWriteTime(
00040         _Out_ UINT64* lastWriteTime
00041         ) override;
00042
00043 private:
00044     // Reference counter
00045     ULONG m_refCount;
00046
00047     // Raw data of the file
00048     Platform::Array<byte>^ m_data;
00049 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/NonTouchableTextBlock.xaml.h Source File

  • Input Touch keyboard

NonTouchableTextBlock.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // NonTouchableTextBlock.xaml.h
00009 // Declaration of the NonTouchableTextBlock class
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "NonTouchableTextBlock.g.h"
00016
00017 namespace SDKSample
00018 {
00019     namespace TouchKeyboard
00020     {
00021       [Windows::Foundation::Metadata::WebHostHidden]
00022         public ref class NonTouchableTextBlock sealed
00023         {
00024         public:
00025             NonTouchableTextBlock();
00026
00027         protected:
00028             virtual Windows::UI::Xaml::Automation::Peers::AutomationPeer^ OnCreateAutomationPeer() override;
00029             virtual void OnGotFocus(Windows::UI::Xaml::RoutedEventArgs^ e) override;
00030             virtual void OnLostFocus(Windows::UI::Xaml::RoutedEventArgs^ e) override;
00031             virtual void OnTapped(Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e) override;
00032             virtual void OnKeyDown(Windows::UI::Xaml::Input::KeyRoutedEventArgs^ e) override;
00033         };
00034     }
00035 }
Generated on Sat Nov 23 2024 16:08:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DeviceAppForWebcam::sealed Member List

This is the complete list of members for DeviceAppForWebcam::sealed, including all inherited members.
__pad0__ | DeviceAppForWebcam::sealed | [protected]
App() | DeviceAppForWebcam::sealed |
DeviceAppPage() | DeviceAppForWebcam::sealed |
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | DeviceAppForWebcam::sealed | [private]
HiddenFrame | DeviceAppForWebcam::sealed | [private]
Initialize(CameraSettingsActivatedEventArgs^args) | DeviceAppForWebcam::sealed |
InvalidateSize() | DeviceAppForWebcam::sealed | [private]
InvalidateViewState() | DeviceAppForWebcam::sealed | [private]
LaunchArgs | DeviceAppForWebcam::sealed |
lcWrapper | DeviceAppForWebcam::sealed |
MainPage() | DeviceAppForWebcam::sealed |
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | DeviceAppForWebcam::sealed | [protected]
OnActivated(Windows::ApplicationModel::Activation::IActivatedEventArgs^args) override | DeviceAppForWebcam::sealed | [virtual]
OnBrtAutoToggleChanged(Object^sender, RoutedEventArgs^e) | DeviceAppForWebcam::sealed |
OnBrtSliderValueChanged(Object^sender, RangeBaseValueChangedEventArgs^e) | DeviceAppForWebcam::sealed |
OnCrtAutoToggleChanged(Object^sender, RoutedEventArgs^e) | DeviceAppForWebcam::sealed |
OnCrtSliderValueChanged(Object^sender, RangeBaseValueChangedEventArgs^e) | DeviceAppForWebcam::sealed |
OnEffectEnabledToggleChanged(Object^sender, RoutedEventArgs^e) | DeviceAppForWebcam::sealed |
OnEffectSliderValueChanged(Object^sender, RangeBaseValueChangedEventArgs^e) | DeviceAppForWebcam::sealed |
OnExpAutoToggleChanged(Object^sender, RoutedEventArgs^e) | DeviceAppForWebcam::sealed |
OnExpSliderValueChanged(Object^sender, RangeBaseValueChangedEventArgs^e) | DeviceAppForWebcam::sealed |
OnFocusAutoToggleChanged(Object^sender, RoutedEventArgs^e) | DeviceAppForWebcam::sealed |
OnFocusSliderValueChanged(Object^sender, RangeBaseValueChangedEventArgs^e) | DeviceAppForWebcam::sealed |
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^args) override | DeviceAppForWebcam::sealed | [virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | DeviceAppForWebcam::sealed | [protected, virtual]
OnSuspending(Platform::Object^sender, Windows::ApplicationModel::SuspendingEventArgs^pArgs) | DeviceAppForWebcam::sealed | [virtual]
rootFrame | DeviceAppForWebcam::sealed | [private]
SetDeviceAppForWebcam(Platform::String^strFeature) | DeviceAppForWebcam::sealed | [private]
videoDevController | DeviceAppForWebcam::sealed |
~DeviceAppPage() | DeviceAppForWebcam::sealed |
~MainPage() | DeviceAppForWebcam::sealed | [private]
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

AccountPictureName::sealed Member List

This is the complete list of members for AccountPictureName::sealed, including all inherited members.
__pad0__ | AccountPictureName::sealed | [protected]
_protocolEventArgs | AccountPictureName::sealed | [private]
autoSizeInputSectionWhenSnapped | AccountPictureName::sealed | [private]
Footer_Click(Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
GetAccountPicture() | AccountPictureName::sealed |
GetDisplayNameButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
GetFirstNameButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
GetLargeImageButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
GetLastNameButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
GetSmallImageButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
GetUserDisplayName() | AccountPictureName::sealed |
GetUserFirstAndLastName() | AccountPictureName::sealed |
GetVideoButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
HiddenFrame | AccountPictureName::sealed | [private]
HideImageAndVideoControls() | AccountPictureName::sealed | [private]
InvalidateSize() | AccountPictureName::sealed | [private]
InvalidateViewState() | AccountPictureName::sealed | [private]
LoadScenario(Platform::String^scenarioName) | AccountPictureName::sealed |
MainPage() | AccountPictureName::sealed |
MainPage_SizeChanged(Object^sender, Windows::UI::Xaml::SizeChangedEventArgs^e) | AccountPictureName::sealed | [protected]
MainPageResized | AccountPictureName::sealed |
NotifyUser(Platform::String^strMessage, NotifyType type) | AccountPictureName::sealed |
OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AccountPictureName::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AccountPictureName::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AccountPictureName::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AccountPictureName::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AccountPictureName::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | AccountPictureName::sealed | [protected, virtual]
PictureChanged(Platform::Object^sender, Platform::Object^e) | AccountPictureName::sealed | [private]
PopulateScenarios() | AccountPictureName::sealed | [private]
rootPage | AccountPictureName::sealed | [private]
ScenarioList | AccountPictureName::sealed | [private]
ScenarioLoaded | AccountPictureName::sealed |
Scenarios_SelectionChanged(Object^sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^e) | AccountPictureName::sealed | [protected]
SetAccountPicture() | AccountPictureName::sealed |
SetAccountPictureName(Platform::String^strFeature) | AccountPictureName::sealed | [private]
SetImageButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
SetVideoButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | AccountPictureName::sealed | [private]
~MainPage() | AccountPictureName::sealed | [private]
Generated on Sat Nov 23 2024 16:09:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML ListView and GridView essentials/C++/SampleDataSource.h Source File

  • XAML ListView and GridView essentials

SampleDataSource.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 using namespace Windows::ApplicationModel::Resources::Core;
00014 using namespace Windows::Foundation;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Windows::UI::Xaml::Data;
00017 using namespace Windows::UI::Xaml::Media;
00018 using namespace Windows::UI::Xaml::Media::Imaging;
00019
00020
00021 namespace SDKSample
00022 {
00023   namespace ListViewSampleDataSource
00024   {
00025     [Windows::UI::Xaml::Data::Bindable]
00026     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00027     public ref class Item sealed
00028     {
00029       Platform::String^  _Title;
00030       Platform::String^  _Subtitle;
00031       Platform::String^  _Link;
00032       Platform::String^  _Category;
00033       Platform::String^ _Description;
00034       Platform::String^ _Content;
00035       ImageSource^ _Image;
00036       event PropertyChangedEventHandler^ _PropertyChanged;
00037
00038
00039     public:
00040       Item();
00041
00042       void OnPropertyChanged(Platform::String^ propertyName)
00043       {
00044         PropertyChangedEventArgs^ pcea = ref new  PropertyChangedEventArgs(propertyName);
00045         _PropertyChanged(this,pcea);
00046       }
00047
00048
00049       //Title
00050       property Platform::String^ Title
00051       {
00052         Platform::String^ get()
00053         {
00054           return _Title;
00055         }
00056         void set(Platform::String^ value)
00057         {
00058           _Title = value;
00059           OnPropertyChanged("Title");
00060         }
00061       }
00062
00063       //Subtitle
00064       property Platform::String^ Subtitle
00065       {
00066         Platform::String^ get()
00067         {
00068           return _Subtitle;
00069         }
00070         void set(Platform::String^ value)
00071         {
00072           _Subtitle = value;
00073           OnPropertyChanged("Subtitle");
00074         }
00075       }
00076
00077       //Link
00078       property Platform::String^ Link
00079       {
00080         Platform::String^ get()
00081         {
00082           return _Link;
00083         }
00084         void set(Platform::String^ value)
00085         {
00086           _Link = value;
00087           OnPropertyChanged("Link");
00088         }
00089       }
00090
00091
00092       //Category
00093       property Platform::String^ Category
00094       {
00095         Platform::String^ get()
00096         {
00097           return _Category;
00098         }
00099         void set(Platform::String^ value)
00100         {
00101           _Category = value;
00102           OnPropertyChanged("Category");
00103         }
00104       }
00105
00106       //Description
00107       property Platform::String^ Description
00108       {
00109         Platform::String^ get()
00110         {
00111           return _Description;
00112         }
00113         void set(Platform::String^ value)
00114         {
00115           _Description = value;
00116           OnPropertyChanged("Description");
00117         }
00118       }
00119
00120       //Content
00121       property Platform::String^ Content
00122       {
00123         Platform::String^ get()
00124         {
00125           return _Content;
00126         }
00127         void set(Platform::String^ value)
00128         {
00129           _Content = value;
00130           OnPropertyChanged("Content");
00131         }
00132       }
00133
00134       //Image
00135       property ImageSource^ Image
00136       {
00137         ImageSource^ get()
00138         {
00139           return _Image;
00140         }
00141         void set(ImageSource^ value)
00142         {
00143           _Image = value;
00144           OnPropertyChanged("Image");
00145         }
00146       }
00147
00148       void SetImage(Windows::Foundation::Uri^ baseUri, Platform::String^ path) //SetImage() in C# code
00149       {
00150         Windows::Foundation::Uri^ uri = ref new Windows::Foundation::Uri("ms-appx:///" + path);
00151         Image = ref new BitmapImage(uri);
00152       }
00153     };
00154
00155
00156     [Windows::Foundation::Metadata::WebHostHiddenAttribute]
00157     public ref class StoreData sealed
00158     {
00159       Windows::UI::Xaml::Interop::IBindableObservableVector^  _items;
00160
00161     public:
00162       StoreData()
00163       {
00164         _items = ref new Platform::Collections::Vector<Item^>();
00165         Windows::Foundation::Uri^ _baseUri = ref new Windows::Foundation::Uri("ms-appx:///");
00166         Platform::String^ LONG_LOREM_IPSUM = "";//"Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
00167
00168         Item^ item;
00169         item = ref new Item();
00170         item->Title="Banana Blast Frozen Yogurt";
00171         item->Subtitle="Maecenas class nam praesent cras aenean mauris aliquam nullam aptent accumsan duis nunc curae donec integer auctor sed congue amet";
00172         item->SetImage(_baseUri, "SampleData/Images/60Banana.png");
00173         item->Link = "http://www.adatum.com/";
00174         item->Category = "Low-fat frozen yogurt";
00175         item->Description = "Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
00176         item->Content = LONG_LOREM_IPSUM;
00177         _items->Append(item);
00178
00179         item = ref new Item();
00180         item->Title = "Lavish Lemon Ice";
00181         item->Subtitle = "Quisque vivamus bibendum cursus dictum dictumst dis aliquam aliquet etiam lectus eleifend fusce libero ante facilisi ligula est";
00182         item->SetImage(_baseUri, "SampleData/Images/60Lemon.png");
00183         item->Link = "http://www.adventure-works.com/";
00184         item->Category = "Sorbet";
00185         item->Description = "Enim cursus nascetur dictum habitasse hendrerit nec gravida vestibulum pellentesque vestibulum adipiscing iaculis erat consectetuer pellentesque parturient lacinia himenaeos pharetra condimentum non sollicitudin eros dolor vestibulum per lectus pellentesque nibh imperdiet laoreet consectetuer placerat libero malesuada pellentesque fames penatibus ligula scelerisque litora nisi luctus vestibulum nisl ullamcorper sed sem natoque suspendisse felis sit condimentum pulvinar nunc posuere magnis vel scelerisque sagittis porttitor potenti tincidunt mattis ipsum adipiscing sollicitudin parturient mauris nam senectus ullamcorper mollis tristique sociosqu suspendisse ultricies montes sed condimentum dis nostra suscipit justo ornare pretium odio pellentesque lacus lorem torquent orci";
00186         item->Content = LONG_LOREM_IPSUM;
00187         _items->Append(item);
00188
00189
00190         item = ref new Item();
00191         item->Title = "Marvelous Mint";
00192         item->Subtitle = "Litora luctus magnis arcu lorem morbi blandit faucibus mattis commodo hac habitant inceptos conubia cubilia nulla mauris diam proin augue eget dolor mollis interdum lobortis";
00193         item->SetImage(_baseUri, "SampleData/Images/60Mint.png");
00194         item->Link = "http://www.adventure-works.com/";
00195         item->Category = "Gelato";
00196         item->Description = "Vestibulum vestibulum magna scelerisque ultrices consectetuer vehicula rhoncus pellentesque massa adipiscing platea primis sodales parturient metus sollicitudin morbi vestibulum pellentesque consectetuer pellentesque volutpat rutrum sollicitudin sapien pellentesque vestibulum venenatis consectetuer viverra est aliquam semper hac maecenas integer adipiscing sociis vulputate ullamcorper curabitur pellentesque parturient praesent neque sollicitudin pellentesque vestibulum suspendisse consectetuer leo quisque phasellus pede vestibulum quam pellentesque sollicitudin quis mus adipiscing parturient pellentesque vestibulum";
00197         item->Content = LONG_LOREM_IPSUM;
00198         _items->Append(item);
00199
00200         item = ref new Item();
00201         item->Title = "Creamy Orange";
00202         item->Subtitle = "Leo mus nec nascetur dapibus non fames per felis ipsum pharetra egestas montes elit nostra placerat euismod enim justo ornare feugiat platea pulvinar sed sagittis";
00203         item->SetImage(_baseUri, "SampleData/Images/60Orange.png");
00204         item->Link = "http://www.alpineskihouse.com/";
00205         item->Category = "Sorbet";
00206         item->Description = "Consequat condimentum consectetuer vivamus urna vestibulum netus pellentesque cras nec taciti non scelerisque adipiscing parturient tellus sollicitudin per vestibulum pellentesque aliquam convallis ullamcorper nulla porta aliquet accumsan suspendisse duis bibendum nunc condimentum consectetuer pellentesque scelerisque tempor sed dictumst eleifend amet vestibulum sem tempus facilisi ullamcorper adipiscing tortor ante purus parturient sit dignissim vel nam turpis sed sollicitudin elementum arcu vestibulum risus blandit suspendisse faucibus pellentesque commodo dis condimentum consectetuer varius aenean conubia cubilia facilisis velit mauris nullam aptent dapibus habitant";
00207         item->Content = LONG_LOREM_IPSUM;
00208          _items->Append(item);
00209
00210         item = ref new Item();
00211         item->Title = "Succulent Strawberry";
00212         item->Subtitle = "Senectus sem lacus erat sociosqu eros suscipit primis nibh nisi nisl gravida torquent";
00213         item->SetImage(_baseUri, "SampleData/Images/60Strawberry.png");
00214         item->Link = "http://www.baldwinmuseumofscience.com/";
00215         item->Category = "Sorbet";
00216         item->Description = "Est auctor inceptos congue interdum egestas scelerisque pellentesque fermentum ullamcorper cursus dictum lectus suspendisse condimentum libero vitae vestibulum lobortis ligula fringilla euismod class scelerisque feugiat habitasse diam litora adipiscing sollicitudin parturient hendrerit curae himenaeos imperdiet ullamcorper suspendisse nascetur hac gravida pharetra eget donec leo mus nec non malesuada vestibulum pellentesque elit penatibus vestibulum per condimentum porttitor sed adipiscing scelerisque ullamcorper etiam iaculis enim tincidunt erat parturient sem vestibulum eros";
00217         item->Content = LONG_LOREM_IPSUM;
00218         _items->Append(item);
00219
00220         item = ref new Item();
00221         item->Title = "Very Vanilla";
00222         item->Subtitle = "Ultrices rutrum sapien vehicula semper lorem volutpat sociis sit maecenas praesent taciti magna nunc odio orci vel tellus nam sed accumsan iaculis dis est";
00223         item->SetImage(_baseUri, "SampleData/Images/60Vanilla.png");
00224         item->Link = "http://www.blueyonderairlines.com/";
00225         item->Category = "Ice Cream";
00226         item->Description = "Consectetuer lacinia vestibulum tristique sit adipiscing laoreet fusce nibh suspendisse natoque placerat pulvinar ultricies condimentum scelerisque nisi ullamcorper nisl parturient vel suspendisse nam venenatis nunc lorem sed dis sagittis pellentesque luctus sollicitudin morbi posuere vestibulum potenti magnis pellentesque vulputate mattis mauris mollis consectetuer pellentesque pretium montes vestibulum condimentum nulla adipiscing sollicitudin scelerisque ullamcorper pellentesque odio orci rhoncus pede sodales suspendisse parturient viverra curabitur proin aliquam integer augue quam condimentum quisque senectus quis urna scelerisque nostra phasellus ullamcorper cras duis suspendisse sociosqu dolor vestibulum condimentum consectetuer vivamus est fames felis suscipit hac";
00227         item->Content = LONG_LOREM_IPSUM;
00228          _items->Append(item);
00229
00230         item = ref new Item();
00231         item->Title = "Creamy Caramel Frozen Yogurt";
00232         item->Subtitle = "Maecenas class nam praesent cras aenean mauris aliquam nullam aptent accumsan duis nunc curae donec integer auctor sed congue amet";
00233         item->SetImage(_baseUri, "SampleData/Images/60SauceCaramel.png");
00234         item->Link = "http://www.adatum.com/";
00235         item->Category = "Low-fat frozen yogurt";
00236         item->Description = "Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
00237         item->Content = LONG_LOREM_IPSUM;
00238          _items->Append(item);
00239
00240         item = ref new Item();
00241         item->Title = "Chocolate Lovers Frozen Yougurt";
00242         item->Subtitle = "Quisque vivamus bibendum cursus dictum dictumst dis aliquam aliquet etiam lectus eleifend fusce libero ante facilisi ligula est";
00243         item->SetImage(_baseUri, "SampleData/Images/60SauceChocolate.png");
00244         item->Link = "http://www.adventure-works.com/";
00245         item->Category = "Low-fat frozen yogurt";
00246         item->Description = "Enim cursus nascetur dictum habitasse hendrerit nec gravida vestibulum pellentesque vestibulum adipiscing iaculis erat consectetuer pellentesque parturient lacinia himenaeos pharetra condimentum non sollicitudin eros dolor vestibulum per lectus pellentesque nibh imperdiet laoreet consectetuer placerat libero malesuada pellentesque fames penatibus ligula scelerisque litora nisi luctus vestibulum nisl ullamcorper sed sem natoque suspendisse felis sit condimentum pulvinar nunc posuere magnis vel scelerisque sagittis porttitor potenti tincidunt mattis ipsum adipiscing sollicitudin parturient mauris nam senectus ullamcorper mollis tristique sociosqu suspendisse ultricies montes sed condimentum dis nostra suscipit justo ornare pretium odio pellentesque lacus lorem torquent orci";
00247         item->Content = LONG_LOREM_IPSUM;
00248          _items->Append(item);
00249
00250         item = ref new Item();
00251         item->Title = "Roma Strawberry";
00252         item->Subtitle = "Litora luctus magnis arcu lorem morbi blandit faucibus mattis commodo hac habitant inceptos conubia cubilia nulla mauris diam proin augue eget dolor mollis interdum lobortis";
00253         item->SetImage(_baseUri, "SampleData/Images/60Strawberry.png");
00254         item->Link = "http://www.adventure-works.com/";
00255         item->Category = "Gelato";
00256         item->Description = "Vestibulum vestibulum magna scelerisque ultrices consectetuer vehicula rhoncus pellentesque massa adipiscing platea primis sodales parturient metus sollicitudin morbi vestibulum pellentesque consectetuer pellentesque volutpat rutrum sollicitudin sapien pellentesque vestibulum venenatis consectetuer viverra est aliquam semper hac maecenas integer adipiscing sociis vulputate ullamcorper curabitur pellentesque parturient praesent neque sollicitudin pellentesque vestibulum suspendisse consectetuer leo quisque phasellus pede vestibulum quam pellentesque sollicitudin quis mus adipiscing parturient pellentesque vestibulum";
00257         item->Content = LONG_LOREM_IPSUM;
00258          _items->Append(item);
00259
00260         item = ref new Item();
00261         item->Title = "Italian Rainbow";
00262         item->Subtitle = "Leo mus nec nascetur dapibus non fames per felis ipsum pharetra egestas montes elit nostra placerat euismod enim justo ornare feugiat platea pulvinar sed sagittis";
00263         item->SetImage(_baseUri, "SampleData/Images/60SprinklesRainbow.png");
00264         item->Link = "http://www.alpineskihouse.com/";
00265         item->Category = "Gelato";
00266         item->Description = "Consequat condimentum consectetuer vivamus urna vestibulum netus pellentesque cras nec taciti non scelerisque adipiscing parturient tellus sollicitudin per vestibulum pellentesque aliquam convallis ullamcorper nulla porta aliquet accumsan suspendisse duis bibendum nunc condimentum consectetuer pellentesque scelerisque tempor sed dictumst eleifend amet vestibulum sem tempus facilisi ullamcorper adipiscing tortor ante purus parturient sit dignissim vel nam turpis sed sollicitudin elementum arcu vestibulum risus blandit suspendisse faucibus pellentesque commodo dis condimentum consectetuer varius aenean conubia cubilia facilisis velit mauris nullam aptent dapibus habitant";
00267         item->Content = LONG_LOREM_IPSUM;
00268          _items->Append(item);
00269
00270         item = ref new Item();
00271         item->Title = "Straweberry";
00272         item->Subtitle = "Ultrices rutrum sapien vehicula semper lorem volutpat sociis sit maecenas praesent taciti magna nunc odio orci vel tellus nam sed accumsan iaculis dis est";
00273         item->SetImage(_baseUri, "SampleData/Images/60Strawberry.png");
00274         item->Link = "http://www.blueyonderairlines.com/";
00275         item->Category = "Ice Cream";
00276         item->Description = "Consectetuer lacinia vestibulum tristique sit adipiscing laoreet fusce nibh suspendisse natoque placerat pulvinar ultricies condimentum scelerisque nisi ullamcorper nisl parturient vel suspendisse nam venenatis nunc lorem sed dis sagittis pellentesque luctus sollicitudin morbi posuere vestibulum potenti magnis pellentesque vulputate mattis mauris mollis consectetuer pellentesque pretium montes vestibulum condimentum nulla adipiscing sollicitudin scelerisque ullamcorper pellentesque odio orci rhoncus pede sodales suspendisse parturient viverra curabitur proin aliquam integer augue quam condimentum quisque senectus quis urna scelerisque nostra phasellus ullamcorper cras duis suspendisse sociosqu dolor vestibulum condimentum consectetuer vivamus est fames felis suscipit hac";
00277         item->Content = LONG_LOREM_IPSUM;
00278          _items->Append(item);
00279
00280         item = ref new Item();
00281         item->Title = "Strawberry Frozen Yogurt";
00282         item->Subtitle = "Maecenas class nam praesent cras aenean mauris aliquam nullam aptent accumsan duis nunc curae donec integer auctor sed congue amet";
00283         item->SetImage(_baseUri, "SampleData/Images/60Strawberry.png");
00284         item->Link = "http://www.adatum.com/";
00285         item->Category = "Low-fat frozen yogurt";
00286         item->Description = "Curabitur class aliquam vestibulum nam curae maecenas sed integer cras phasellus suspendisse quisque donec dis praesent accumsan bibendum pellentesque condimentum adipiscing etiam consequat vivamus dictumst aliquam duis convallis scelerisque est parturient ullamcorper aliquet fusce suspendisse nunc hac eleifend amet blandit facilisi condimentum commodo scelerisque faucibus aenean ullamcorper ante mauris dignissim consectetuer nullam lorem vestibulum habitant conubia elementum pellentesque morbi facilisis arcu sollicitudin diam cubilia aptent vestibulum auctor eget dapibus pellentesque inceptos leo egestas interdum nulla consectetuer suspendisse adipiscing pellentesque proin lobortis sollicitudin augue elit mus congue fermentum parturient fringilla euismod feugiat";
00287         item->Content = LONG_LOREM_IPSUM;
00288          _items->Append(item);
00289
00290         item = ref new Item();
00291         item->Title = "Bongo Banana";
00292         item->Subtitle = "Quisque vivamus bibendum cursus dictum dictumst dis aliquam aliquet etiam lectus eleifend fusce libero ante facilisi ligula est";
00293         item->SetImage(_baseUri, "SampleData/Images/60Banana.png");
00294         item->Link = "http://www.adventure-works.com/";
00295         item->Category = "Sorbet";
00296         item->Description = "Enim cursus nascetur dictum habitasse hendrerit nec gravida vestibulum pellentesque vestibulum adipiscing iaculis erat consectetuer pellentesque parturient lacinia himenaeos pharetra condimentum non sollicitudin eros dolor vestibulum per lectus pellentesque nibh imperdiet laoreet consectetuer placerat libero malesuada pellentesque fames penatibus ligula scelerisque litora nisi luctus vestibulum nisl ullamcorper sed sem natoque suspendisse felis sit condimentum pulvinar nunc posuere magnis vel scelerisque sagittis porttitor potenti tincidunt mattis ipsum adipiscing sollicitudin parturient mauris nam senectus ullamcorper mollis tristique sociosqu suspendisse ultricies montes sed condimentum dis nostra suscipit justo ornare pretium odio pellentesque lacus lorem torquent orci";
00297         item->Content = LONG_LOREM_IPSUM;
00298          _items->Append(item);
00299
00300         item = ref new Item();
00301         item->Title = "Firenze Vanilla";
00302         item->Subtitle = "Litora luctus magnis arcu lorem morbi blandit faucibus mattis commodo hac habitant inceptos conubia cubilia nulla mauris diam proin augue eget dolor mollis interdum lobortis";
00303         item->SetImage(_baseUri, "SampleData/Images/60Vanilla.png");
00304         item->Link = "http://www.adventure-works.com/";
00305         item->Category = "Gelato";
00306         item->Description = "Vestibulum vestibulum magna scelerisque ultrices consectetuer vehicula rhoncus pellentesque massa adipiscing platea primis sodales parturient metus sollicitudin morbi vestibulum pellentesque consectetuer pellentesque volutpat rutrum sollicitudin sapien pellentesque vestibulum venenatis consectetuer viverra est aliquam semper hac maecenas integer adipiscing sociis vulputate ullamcorper curabitur pellentesque parturient praesent neque sollicitudin pellentesque vestibulum suspendisse consectetuer leo quisque phasellus pede vestibulum quam pellentesque sollicitudin quis mus adipiscing parturient pellentesque vestibulum";
00307         item->Content = LONG_LOREM_IPSUM;
00308          _items->Append(item);
00309
00310         item = ref new Item();
00311         item->Title = "Choco-wocko";
00312         item->Subtitle = "Leo mus nec nascetur dapibus non fames per felis ipsum pharetra egestas montes elit nostra placerat euismod enim justo ornare feugiat platea pulvinar sed sagittis";
00313         item->SetImage(_baseUri, "SampleData/Images/60SauceChocolate.png");
00314         item->Link = "http://www.alpineskihouse.com/";
00315         item->Category = "Sorbet";
00316         item->Description = "Consequat condimentum consectetuer vivamus urna vestibulum netus pellentesque cras nec taciti non scelerisque adipiscing parturient tellus sollicitudin per vestibulum pellentesque aliquam convallis ullamcorper nulla porta aliquet accumsan suspendisse duis bibendum nunc condimentum consectetuer pellentesque scelerisque tempor sed dictumst eleifend amet vestibulum sem tempus facilisi ullamcorper adipiscing tortor ante purus parturient sit dignissim vel nam turpis sed sollicitudin elementum arcu vestibulum risus blandit suspendisse faucibus pellentesque commodo dis condimentum consectetuer varius aenean conubia cubilia facilisis velit mauris nullam aptent dapibus habitant";
00317         item->Content = LONG_LOREM_IPSUM;
00318          _items->Append(item);
00319
00320         item = ref new Item();
00321         item->Title = "Chocolate";
00322         item->Subtitle = "Ultrices rutrum sapien vehicula semper lorem volutpat sociis sit maecenas praesent taciti magna nunc odio orci vel tellus nam sed accumsan iaculis dis est";
00323         item->SetImage(_baseUri, "SampleData/Images/60SauceChocolate.png");
00324         item->Link = "http://www.blueyonderairlines.com/";
00325         item->Category = "Ice Cream";
00326         item->Description = "Consectetuer lacinia vestibulum tristique sit adipiscing laoreet fusce nibh suspendisse natoque placerat pulvinar ultricies condimentum scelerisque nisi ullamcorper nisl parturient vel suspendisse nam venenatis nunc lorem sed dis sagittis pellentesque luctus sollicitudin morbi posuere vestibulum potenti magnis pellentesque vulputate mattis mauris mollis consectetuer pellentesque pretium montes vestibulum condimentum nulla adipiscing sollicitudin scelerisque ullamcorper pellentesque odio orci rhoncus pede sodales suspendisse parturient viverra curabitur proin aliquam integer augue quam condimentum quisque senectus quis urna scelerisque nostra phasellus ullamcorper cras duis suspendisse sociosqu dolor vestibulum condimentum consectetuer vivamus est fames felis suscipit hac";
00327         item->Content = LONG_LOREM_IPSUM;
00328          _items->Append(item);
00329
00330       }
00331
00332       property Windows::UI::Xaml::Interop::IBindableObservableVector^ Items
00333       {
00334         Windows::UI::Xaml::Interop::IBindableObservableVector^ get()
00335         {
00336           return _items;
00337         }
00338
00339       }
00340     };
00341
00342   }
00343 }
Generated on Sat Nov 23 2024 16:08:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Certificate enrollment/C++/common/suspensionmanager.h Source File

  • Certificate enrollment
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D custom image effects/C++/PixelShader/RippleEffect.h Source File

  • Direct2D custom image effects
  • PixelShader

RippleEffect.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 DEFINE_GUID(GUID_RipplePixelShader, 0x6716FB29, 0x06A0, 0x460F, 0xAA, 0x9C, 0x8B, 0x8F, 0xF0, 0x33, 0x5E, 0xA6);
00009 DEFINE_GUID(CLSID_CustomRippleEffect, 0xB7B36C92, 0x3498, 0x4A94, 0x9E, 0x95, 0x9F, 0x24, 0x6F, 0x92, 0x45, 0xBF);
00010
00011 typedef enum RIPPLE_PROP
00012 {
00013     RIPPLE_PROP_FREQUENCY = 0,
00014     RIPPLE_PROP_PHASE = 1,
00015     RIPPLE_PROP_AMPLITUDE = 2,
00016     RIPPLE_PROP_SPREAD = 3,
00017     RIPPLE_PROP_CENTER = 4
00018 };
00019
00020 // Our effect contains one transform, which is simply a wrapper around a pixel shader. As such,
00021 // we can simply make the effect itself act as the transform.
00022 class RippleEffect : public ID2D1EffectImpl, public ID2D1DrawTransform
00023 {
00024 public:
00025     // Declare effect registration methods.
00026     static HRESULT Register(_In_ ID2D1Factory1* pFactory);
00027
00028     static HRESULT __stdcall CreateRippleImpl(_Outptr_ IUnknown** ppEffectImpl);
00029
00030     // Declare property getter/setter methods.
00031     HRESULT SetCenter(D2D1_POINT_2F center);
00032     D2D1_POINT_2F GetCenter() const;
00033
00034     HRESULT SetFrequency(float frequency);
00035     float GetFrequency() const;
00036
00037     HRESULT SetPhase(float phase);
00038     float GetPhase() const;
00039
00040     HRESULT SetAmplitude(float amplitude);
00041     float GetAmplitude() const;
00042
00043     HRESULT SetSpread(float spread);
00044     float GetSpread() const;
00045
00046     // Declare ID2D1EffectImpl implementation methods.
00047     IFACEMETHODIMP Initialize(
00048         _In_ ID2D1EffectContext* pContextInternal,
00049         _In_ ID2D1TransformGraph* pTransformGraph
00050         );
00051
00052     IFACEMETHODIMP PrepareForRender(D2D1_CHANGE_TYPE changeType);
00053
00054     IFACEMETHODIMP SetGraph(_In_ ID2D1TransformGraph* pGraph);
00055
00056     // Declare ID2D1DrawTransform implementation methods.
00057     IFACEMETHODIMP SetDrawInfo(_In_ ID2D1DrawInfo* pRenderInfo);
00058
00059     // Declare ID2D1Transform implementation methods.
00060     IFACEMETHODIMP MapOutputRectToInputRects(
00061         _In_ const D2D1_RECT_L* pOutputRect,
00062         _Out_writes_(inputRectCount) D2D1_RECT_L* pInputRects,
00063         UINT32 inputRectCount
00064         ) const;
00065
00066     IFACEMETHODIMP MapInputRectsToOutputRect(
00067         _In_reads_(inputRectCount) CONST D2D1_RECT_L* pInputRects,
00068         _In_reads_(inputRectCount) CONST D2D1_RECT_L* pInputOpaqueSubRects,
00069         UINT32 inputRectCount,
00070         _Out_ D2D1_RECT_L* pOutputRect,
00071         _Out_ D2D1_RECT_L* pOutputOpaqueSubRect
00072         );
00073
00074     IFACEMETHODIMP MapInvalidRect(
00075         UINT32 inputIndex,
00076         D2D1_RECT_L invalidInputRect,
00077         _Out_ D2D1_RECT_L* pInvalidOutputRect
00078         ) const;
00079
00080     // Declare ID2D1TransformNode implementation methods.
00081     IFACEMETHODIMP_(UINT32) GetInputCount() const;
00082
00083     // Declare IUnknown implementation methods.
00084     IFACEMETHODIMP_(ULONG) AddRef();
00085     IFACEMETHODIMP_(ULONG) Release();
00086     IFACEMETHODIMP QueryInterface(_In_ REFIID riid, _Outptr_ void** ppOutput);
00087
00088 private:
00089     RippleEffect();
00090     HRESULT UpdateConstants();
00091
00092     inline static float Clamp(float v, float low, float high)
00093     {
00094         return (v < low) ? low : (v > high) ? high : v;
00095     }
00096
00097     inline static float Round(float v)
00098     {
00099         return floor(v + 0.5f);
00100     }
00101
00102     // Prevents over/underflows when adding longs.
00103     inline static long SafeAdd(long base, long valueToAdd)
00104     {
00105         if (valueToAdd >= 0)
00106         {
00107             return ((base + valueToAdd) >= base) ? (base + valueToAdd) : LONG_MAX;
00108         }
00109         else
00110         {
00111             return ((base + valueToAdd) <= base) ? (base + valueToAdd) : LONG_MIN;
00112         }
00113     }
00114
00115     // This struct defines the constant buffer of our pixel shader.
00116     struct
00117     {
00118         float frequency;
00119         float phase;
00120         float amplitude;
00121         float spread;
00122         D2D1_POINT_2F center;
00123         float dpi;
00124     } m_constants;
00125
00126     Microsoft::WRL::ComPtr<ID2D1DrawInfo>      m_drawInfo;
00127     Microsoft::WRL::ComPtr<ID2D1EffectContext> m_effectContext;
00128     LONG                                       m_refCount;
00129     D2D1_RECT_L                                m_inputRect;
00130     float                                      m_dpi;
00131 };
Generated on Sat Nov 23 2024 16:08:05 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Sharing content source app/C++/pch.cpp Source File

  • Sharing content source app

pch.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D sprite/C++/BasicReaderWriter.cpp Source File

  • Direct3D sprite

BasicReaderWriter.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "BasicReaderWriter.h"
00010
00011 using namespace Microsoft::WRL;
00012 using namespace Windows::Storage;
00013 using namespace Windows::Storage::FileProperties;
00014 using namespace Windows::Storage::Streams;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::ApplicationModel;
00017 using namespace concurrency;
00018
00019 BasicReaderWriter::BasicReaderWriter()
00020 {
00021     m_location = Package::Current->InstalledLocation;
00022     m_locationPath = Platform::String::Concat(m_location->Path, "\\");
00023 }
00024
00025 BasicReaderWriter::BasicReaderWriter(
00026     _In_ Windows::Storage::StorageFolder^ folder
00027     )
00028 {
00029     m_location = folder;
00030     Platform::String^ path = m_location->Path;
00031     if (path->Length() == 0)
00032     {
00033         // Applications are not permitted to access certain
00034         // folders, such as the Documents folder, using this
00035         // code path.  In such cases, the Path property for
00036         // the folder will be an empty string.
00037         throw ref new Platform::FailureException();
00038     }
00039     m_locationPath = Platform::String::Concat(path, "\\");
00040 }
00041
00042 Platform::Array<byte>^ BasicReaderWriter::ReadData(
00043     _In_ Platform::String^ filename
00044     )
00045 {
00046     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00047     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00048     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00049     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00050     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00051     extendedParams.lpSecurityAttributes = nullptr;
00052     extendedParams.hTemplateFile = nullptr;
00053
00054     Wrappers::FileHandle file(
00055         CreateFile2(
00056             Platform::String::Concat(m_locationPath, filename)->Data(),
00057             GENERIC_READ,
00058             FILE_SHARE_READ,
00059             OPEN_EXISTING,
00060             &extendedParams
00061             )
00062         );
00063     if (file.Get() == INVALID_HANDLE_VALUE)
00064     {
00065         throw ref new Platform::FailureException();
00066     }
00067
00068     FILE_STANDARD_INFO fileInfo = {0};
00069     if (!GetFileInformationByHandleEx(
00070         file.Get(),
00071         FileStandardInfo,
00072         &fileInfo,
00073         sizeof(fileInfo)
00074         ))
00075     {
00076         throw ref new Platform::FailureException();
00077     }
00078
00079     if (fileInfo.EndOfFile.HighPart != 0)
00080     {
00081         throw ref new Platform::OutOfMemoryException();
00082     }
00083
00084     Platform::Array<byte>^ fileData = ref new Platform::Array<byte>(fileInfo.EndOfFile.LowPart);
00085
00086     if (!ReadFile(
00087         file.Get(),
00088         fileData->Data,
00089         fileData->Length,
00090         nullptr,
00091         nullptr
00092         ))
00093     {
00094         throw ref new Platform::FailureException();
00095     }
00096
00097     return fileData;
00098 }
00099
00100 task<Platform::Array<byte>^> BasicReaderWriter::ReadDataAsync(
00101     _In_ Platform::String^ filename
00102     )
00103 {
00104     return task<StorageFile^>(m_location->GetFileAsync(filename)).then([=](StorageFile^ file)
00105     {
00106         return FileIO::ReadBufferAsync(file);
00107     }).then([=](IBuffer^ buffer)
00108     {
00109         auto fileData = ref new Platform::Array<byte>(buffer->Length);
00110         DataReader::FromBuffer(buffer)->ReadBytes(fileData);
00111         return fileData;
00112     });
00113 }
00114
00115 uint32 BasicReaderWriter::WriteData(
00116     _In_ Platform::String^ filename,
00117     _In_ const Platform::Array<byte>^ fileData
00118     )
00119 {
00120     CREATEFILE2_EXTENDED_PARAMETERS extendedParams = {0};
00121     extendedParams.dwSize = sizeof(CREATEFILE2_EXTENDED_PARAMETERS);
00122     extendedParams.dwFileAttributes = FILE_ATTRIBUTE_NORMAL;
00123     extendedParams.dwFileFlags = FILE_FLAG_SEQUENTIAL_SCAN;
00124     extendedParams.dwSecurityQosFlags = SECURITY_ANONYMOUS;
00125     extendedParams.lpSecurityAttributes = nullptr;
00126     extendedParams.hTemplateFile = nullptr;
00127
00128     Wrappers::FileHandle file(
00129         CreateFile2(
00130             Platform::String::Concat(m_locationPath, filename)->Data(),
00131             GENERIC_WRITE,
00132             0,
00133             CREATE_ALWAYS,
00134             &extendedParams
00135             )
00136         );
00137     if (file.Get() == INVALID_HANDLE_VALUE)
00138     {
00139         throw ref new Platform::FailureException();
00140     }
00141
00142     DWORD numBytesWritten;
00143     if (
00144         !WriteFile(
00145             file.Get(),
00146             fileData->Data,
00147             fileData->Length,
00148             &numBytesWritten,
00149             nullptr
00150             ) ||
00151         numBytesWritten != fileData->Length
00152         )
00153     {
00154         throw ref new Platform::FailureException();
00155     }
00156
00157     return numBytesWritten;
00158 }
00159
00160 task<void> BasicReaderWriter::WriteDataAsync(
00161     _In_ Platform::String^ filename,
00162     _In_ const Platform::Array<byte>^ fileData
00163     )
00164 {
00165     return task<StorageFile^>(m_location->CreateFileAsync(filename, CreationCollisionOption::ReplaceExisting)).then([=](StorageFile^ file)
00166     {
00167         FileIO::WriteBytesAsync(file, fileData);
00168     });
00169 }
Generated on Sat Nov 23 2024 16:08:09 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/MarbleMaze.cpp Source File

  • DirectX marble maze game

MarbleMaze.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace DirectX;
00011
00012 #include "MarbleMaze.h"
00013 #include "BasicLoader.h"
00014 #include "BasicTimer.h"
00015 #include "DDSTextureLoader.h"
00016
00017 using namespace Microsoft::WRL;
00018 using namespace Windows::Foundation;
00019 using namespace Windows::UI::Core;
00020 using namespace Windows::System;
00021 using namespace Windows::Storage;
00022 using namespace Windows::UI::ViewManagement;
00023
00024 MarbleMaze::MarbleMaze() :
00025     m_gameState(GameState::Initial),
00026     m_windowActive(false),
00027     m_viewState(ApplicationViewState::FullScreenLandscape),
00028     m_deferredResourcesReady(false)
00029 {
00030     m_lightStrength = 0.0f;
00031     m_targetLightStrength = 0.0f;
00032     m_resetCamera = true;
00033     m_resetMarbleRotation = true;
00034
00035     // Checkpoints (from start to goal).
00036     m_checkpoints.push_back(XMFLOAT3( 45.7f,  -43.6f, -45.0f)); // Start
00037     m_checkpoints.push_back(XMFLOAT3(120.7f,  -35.0f, -45.0f)); // Checkpoint 1
00038     m_checkpoints.push_back(XMFLOAT3(297.6f, -194.6f, -45.0f)); // Checkpoint 2
00039     m_checkpoints.push_back(XMFLOAT3(770.1f, -391.5f, -45.0f)); // Checkpoint 3
00040     m_checkpoints.push_back(XMFLOAT3(552.0f, -148.6f, -45.0f)); // Checkpoint 4
00041     m_checkpoints.push_back(XMFLOAT3(846.8f, -377.0f, -45.0f)); // Goal
00042
00043     m_persistentState = ref new PersistentState();
00044     m_persistentState->Initialize(ApplicationData::Current->LocalSettings->Values, "MarbleMaze");
00045 }
00046
00047 void MarbleMaze::Initialize(Windows::UI::Core::CoreWindow^ window, float dpi)
00048 {
00049     // Apps must start processing events in 5 seconds or less,
00050     // so we only set up essential initial state and resources here.
00051     // Additional setup and resource loading happens in
00052     // LoadDeferredResources, which is typically called from
00053     // DirectXApp::Load().
00054
00055     // Must happen before initializing base.
00056     m_audio.Initialize();
00057
00058     // Returns accelerometer ref if there is one; nullptr otherwise.
00059     m_accelerometer = Windows::Devices::Sensors::Accelerometer::GetDefault();
00060
00061     DirectXBase::Initialize(window, dpi);
00062
00063     LoadState();
00064 }
00065
00066 void MarbleMaze::HandleDeviceLost()
00067 {
00068     m_deferredResourcesReady = false;
00069
00070     m_d3dContext->OMSetRenderTargets(0, nullptr, nullptr);
00071     m_d3dDepthStencilView = nullptr;
00072     m_d3dRenderTargetView = nullptr;
00073
00074     m_d2dContext->SetTarget(nullptr);
00075     m_d2dTargetBitmap = nullptr;
00076     m_d2dContext = nullptr;
00077     m_d2dDevice = nullptr;
00078
00079     m_d3dContext->Flush();
00080
00081     DirectXBase::HandleDeviceLost();
00082
00083     LoadDeferredResources(false, true);
00084 }
00085
00086 void MarbleMaze::CreateDeviceResources()
00087 {
00088     DirectXBase::CreateDeviceResources();
00089     m_camera = ref new Camera();
00090     m_sampleOverlay = ref new SampleOverlay();
00091     m_loadScreen = ref new LoadScreen();
00092
00093     m_sampleOverlay->Initialize(
00094         m_d2dDevice.Get(),
00095         m_d2dContext.Get(),
00096         m_wicFactory.Get(),
00097         m_dwriteFactory.Get(),
00098         "DirectX Marble Maze game sample"
00099         );
00100
00101     m_loadScreen->Initialize(
00102         m_d2dDevice.Get(),
00103         m_d2dContext.Get(),
00104         m_wicFactory.Get()
00105         );
00106
00107     UserInterface::GetInstance().Initialize(
00108         m_d2dDevice.Get(),
00109         m_d2dContext.Get(),
00110         m_wicFactory.Get(),
00111         m_dwriteFactory.Get()
00112         );
00113 }
00114
00115 inline D2D1_RECT_F ConvertRect(Windows::Foundation::Rect source)
00116 {
00117     // ignore the source.X and source.Y  These are the location on the screen
00118     // yet we don't want to use them because all coordinates are window relative.
00119     return D2D1::RectF(0.0f, 0.0f, source.Width, source.Height);
00120 }
00121
00122 inline void InflateRect(D2D1_RECT_F& rect, float x, float y)
00123 {
00124     rect.left -= x;
00125     rect.right += x;
00126     rect.top -= y;
00127     rect.bottom += y;
00128 }
00129
00130 void MarbleMaze::CreateWindowSizeDependentResources()
00131 {
00132     DirectXBase::CreateWindowSizeDependentResources();
00133
00134     // update the 3D projection matrix
00135     m_camera->SetProjectionParameters(
00136         40.0f,                                                  // use a 70-degree vertical field of view
00137         m_renderTargetSize.Width /  m_renderTargetSize.Height,  // specify the aspect ratio of the window
00138         50.0f,                                                  // specify the nearest Z-distance at which to draw vertices
00139         500.0f                                                  // specify the farthest Z-distance at which to draw vertice
00140         );
00141
00142     // MarbleMaze specific
00143     float4x4 projection;
00144     m_camera->GetProjectionMatrix(&projection);
00145     m_mazeConstantBufferData.projection = projection;
00146     m_marbleConstantBufferData.projection = projection;
00147
00148     // user interface
00149     const float padding = 32.0f;
00150     D2D1_RECT_F clientRect = ConvertRect(m_windowBounds);
00151     InflateRect(clientRect, -padding, -padding);
00152
00153     bool snapped = m_viewState == ApplicationViewState::Snapped;
00154
00155     D2D1_RECT_F topHalfRect = clientRect;
00156     topHalfRect.bottom = ((clientRect.top + clientRect.bottom) / 2.0f) - (padding / 2.0f);
00157     D2D1_RECT_F bottomHalfRect = clientRect;
00158     bottomHalfRect.top = topHalfRect.bottom + padding;
00159
00160     m_startGameButton.Initialize();
00161     m_startGameButton.SetAlignment(AlignCenter, AlignFar);
00162     m_startGameButton.SetContainer(topHalfRect);
00163     m_startGameButton.SetText(L"Start Game");
00164     m_startGameButton.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
00165     m_startGameButton.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
00166     if (snapped)
00167     {
00168         m_startGameButton.SetPadding(D2D1::SizeF(8.0f, 4.0f));
00169         m_startGameButton.GetTextStyle().SetFontSize(36.0f);
00170     }
00171     else
00172     {
00173         m_startGameButton.SetPadding(D2D1::SizeF(32.0f, 16.0f));
00174         m_startGameButton.GetTextStyle().SetFontSize(72.0f);
00175     }
00176     UserInterface::GetInstance().RegisterElement(&m_startGameButton);
00177
00178     m_highScoreButton.Initialize();
00179     m_highScoreButton.SetAlignment(AlignCenter, AlignNear);
00180     m_highScoreButton.SetContainer(bottomHalfRect);
00181     m_highScoreButton.SetText(L"High Scores");
00182     m_highScoreButton.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
00183     m_highScoreButton.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
00184     if (snapped)
00185     {
00186         m_highScoreButton.SetPadding(D2D1::SizeF(8.0f, 4.0f));
00187         m_highScoreButton.GetTextStyle().SetFontSize(36.0f);
00188     }
00189     else
00190     {
00191         m_highScoreButton.SetPadding(D2D1::SizeF(32.0f, 16.0f));
00192         m_highScoreButton.GetTextStyle().SetFontSize(72.0f);
00193     }
00194     UserInterface::GetInstance().RegisterElement(&m_highScoreButton);
00195
00196     m_highScoreTable.Initialize();
00197     m_highScoreTable.SetAlignment(AlignCenter, AlignCenter);
00198     m_highScoreTable.SetContainer(clientRect);
00199     m_highScoreTable.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
00200     m_highScoreTable.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BOLD);
00201     m_highScoreTable.GetTextStyle().SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER);
00202     if (snapped)
00203     {
00204         m_highScoreTable.GetTextStyle().SetFontSize(20.0f);
00205     }
00206     else
00207     {
00208         m_highScoreTable.GetTextStyle().SetFontSize(60.0f);
00209     }
00210     UserInterface::GetInstance().RegisterElement(&m_highScoreTable);
00211
00212     m_preGameCountdownTimer.Initialize();
00213     m_preGameCountdownTimer.SetAlignment(AlignCenter, AlignCenter);
00214     m_preGameCountdownTimer.SetContainer(clientRect);
00215     m_preGameCountdownTimer.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
00216     m_preGameCountdownTimer.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
00217     if (snapped)
00218     {
00219         m_preGameCountdownTimer.GetTextStyle().SetFontSize(72.0f);
00220     }
00221     else
00222     {
00223         m_preGameCountdownTimer.GetTextStyle().SetFontSize(144.0f);
00224     }
00225     UserInterface::GetInstance().RegisterElement(&m_preGameCountdownTimer);
00226
00227     m_inGameStopwatchTimer.Initialize();
00228     m_inGameStopwatchTimer.SetAlignment(AlignNear, AlignFar);
00229     m_inGameStopwatchTimer.SetContainer(clientRect);
00230     m_inGameStopwatchTimer.SetTextColor(D2D1::ColorF(D2D1::ColorF::White, 0.75f));
00231     m_inGameStopwatchTimer.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
00232     if (snapped)
00233     {
00234         m_inGameStopwatchTimer.GetTextStyle().SetFontSize(48.0f);
00235     }
00236     else
00237     {
00238         m_inGameStopwatchTimer.GetTextStyle().SetFontSize(96.0f);
00239     }
00240     UserInterface::GetInstance().RegisterElement(&m_inGameStopwatchTimer);
00241
00242     m_checkpointText.Initialize();
00243     m_checkpointText.SetAlignment(AlignCenter, AlignCenter);
00244     m_checkpointText.SetContainer(clientRect);
00245     m_checkpointText.SetText(L"Checkpoint!");
00246     m_checkpointText.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
00247     m_checkpointText.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
00248     if (snapped)
00249     {
00250         m_checkpointText.GetTextStyle().SetFontSize(36.0f);
00251     }
00252     else
00253     {
00254         m_checkpointText.GetTextStyle().SetFontSize(72.0f);
00255     }
00256     UserInterface::GetInstance().RegisterElement(&m_checkpointText);
00257
00258     m_pausedText.Initialize();
00259     m_pausedText.SetAlignment(AlignCenter, AlignCenter);
00260     m_pausedText.SetContainer(clientRect);
00261     m_pausedText.SetText(L"Paused");
00262     m_pausedText.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
00263     m_pausedText.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BLACK);
00264     if (snapped)
00265     {
00266         m_pausedText.GetTextStyle().SetFontSize(36.0f);
00267     }
00268     else
00269     {
00270         m_pausedText.GetTextStyle().SetFontSize(72.0f);
00271     }
00272     UserInterface::GetInstance().RegisterElement(&m_pausedText);
00273
00274     m_resultsText.Initialize();
00275     m_resultsText.SetAlignment(AlignCenter, AlignCenter);
00276     m_resultsText.SetContainer(clientRect);
00277     m_resultsText.SetTextColor(D2D1::ColorF(D2D1::ColorF::White));
00278     m_resultsText.GetTextStyle().SetFontWeight(DWRITE_FONT_WEIGHT_BOLD);
00279     m_resultsText.GetTextStyle().SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER);
00280     if (snapped)
00281     {
00282         m_resultsText.GetTextStyle().SetFontSize(36.0f);
00283     }
00284     else
00285     {
00286         m_resultsText.GetTextStyle().SetFontSize(72.0f);
00287     }
00288     UserInterface::GetInstance().RegisterElement(&m_resultsText);
00289
00290     m_sampleOverlay->UpdateForWindowSizeChange();
00291     if ((!m_deferredResourcesReady) && m_loadScreen)
00292     {
00293         m_loadScreen->UpdateForWindowSizeChange();
00294     }
00295 }
00296
00297 void MarbleMaze::LoadDeferredResources(bool delay, bool deviceOnly)
00298 {
00299     BasicTimer^ loadingTimer = ref new BasicTimer;
00300     loadingTimer->Reset();
00301
00302     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00303
00304     D3D11_INPUT_ELEMENT_DESC layoutDesc[] =
00305         {
00306             { "POSITION", 0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 0,  D3D11_INPUT_PER_VERTEX_DATA, 0 },
00307             { "NORMAL",   0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 12, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00308             { "TEXCOORD", 0, DXGI_FORMAT_R32G32_FLOAT,    0, 24, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00309             { "TANGENT",  0, DXGI_FORMAT_R32G32B32_FLOAT, 0, 32, D3D11_INPUT_PER_VERTEX_DATA, 0 },
00310         };
00311     m_vertexStride = 44; // must set this to match the size of layoutDesc above
00312
00313     loader->LoadShader(
00314         L"BasicVertexShader.cso",
00315         layoutDesc,
00316         ARRAYSIZE(layoutDesc),
00317         &m_vertexShader,
00318         &m_inputLayout
00319         );
00320
00321     // create the constant buffer for updating model and camera data.
00322     D3D11_BUFFER_DESC constantBufferDesc = {0};
00323     constantBufferDesc.ByteWidth           = ((sizeof(ConstantBuffer) + 15) / 16) * 16; // multiple of 16 bytes
00324     constantBufferDesc.Usage               = D3D11_USAGE_DEFAULT;
00325     constantBufferDesc.BindFlags           = D3D11_BIND_CONSTANT_BUFFER;
00326     constantBufferDesc.CPUAccessFlags      = 0;
00327     constantBufferDesc.MiscFlags           = 0;
00328     // this will not be used as a structured buffer, so this parameter is ignored
00329     constantBufferDesc.StructureByteStride = 0;
00330
00331     DX::ThrowIfFailed(
00332         m_d3dDevice->CreateBuffer(
00333             &constantBufferDesc,
00334             nullptr,             // leave the buffer uninitialized
00335             &m_constantBuffer
00336             )
00337         );
00338
00339     loader->LoadShader(
00340         L"BasicPixelShader.cso",
00341         &m_pixelShader
00342         );
00343
00344     // create the blend state.
00345     D3D11_BLEND_DESC blendDesc = {0};
00346     blendDesc.RenderTarget[0].BlendEnable = TRUE;
00347     blendDesc.RenderTarget[0].SrcBlend = D3D11_BLEND_SRC_ALPHA;
00348     blendDesc.RenderTarget[0].DestBlend = D3D11_BLEND_INV_SRC_ALPHA;
00349     blendDesc.RenderTarget[0].BlendOp = D3D11_BLEND_OP_ADD;
00350     blendDesc.RenderTarget[0].SrcBlendAlpha = D3D11_BLEND_ONE;
00351     blendDesc.RenderTarget[0].DestBlendAlpha = D3D11_BLEND_ZERO;
00352     blendDesc.RenderTarget[0].BlendOpAlpha = D3D11_BLEND_OP_ADD;
00353     blendDesc.RenderTarget[0].RenderTargetWriteMask = D3D11_COLOR_WRITE_ENABLE_ALL;
00354
00355     DX::ThrowIfFailed(
00356         m_d3dDevice->CreateBlendState(
00357             &blendDesc,
00358             &m_blendState
00359             )
00360         );
00361
00362     // create the sampler
00363     D3D11_SAMPLER_DESC samplerDesc;
00364     samplerDesc.Filter = D3D11_FILTER_ANISOTROPIC;
00365     samplerDesc.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
00366     samplerDesc.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
00367     samplerDesc.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
00368     samplerDesc.MipLODBias = 0.0f;
00369     samplerDesc.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
00370     samplerDesc.ComparisonFunc = D3D11_COMPARISON_NEVER;
00371     samplerDesc.BorderColor[0] = 0.0f;
00372     samplerDesc.BorderColor[1] = 0.0f;
00373     samplerDesc.BorderColor[2] = 0.0f;
00374     samplerDesc.BorderColor[3] = 0.0f;
00375     // allow use of all mip levels
00376     samplerDesc.MinLOD = 0;
00377     samplerDesc.MaxLOD = D3D11_FLOAT32_MAX;
00378
00379     DX::ThrowIfFailed(
00380         m_d3dDevice->CreateSamplerState(
00381             &samplerDesc,
00382             &m_sampler
00383             )
00384         );
00385
00386     // Load the meshes.
00387     DX::ThrowIfFailed(
00388         m_mazeMesh.Create(
00389             m_d3dDevice.Get(),
00390             L"Media\\Models\\maze1.sdkmesh",
00391             false
00392             )
00393         );
00394
00395     DX::ThrowIfFailed(
00396         m_marbleMesh.Create(
00397             m_d3dDevice.Get(),
00398             L"Media\\Models\\marble2.sdkmesh",
00399             false
00400             )
00401         );
00402
00403     // Extract mesh geometry for physics system.
00404     DX::ThrowIfFailed(
00405         ExtractTrianglesFromMesh(
00406             m_mazeMesh,
00407             "Mesh_walls",
00408             m_collision.m_wallTriList
00409             )
00410         );
00411
00412     DX::ThrowIfFailed(
00413         ExtractTrianglesFromMesh(
00414             m_mazeMesh,
00415             "Mesh_Floor",
00416             m_collision.m_groundTriList
00417             )
00418         );
00419
00420     DX::ThrowIfFailed(
00421         ExtractTrianglesFromMesh(
00422             m_mazeMesh,
00423             "Mesh_floorSides",
00424             m_collision.m_floorTriList
00425             )
00426         );
00427
00428     m_physics.SetCollision(&m_collision);
00429     float radius = m_marbleMesh.GetMeshBoundingBoxExtents(0).x / 2;
00430     m_physics.SetRadius(radius);
00431
00432     if (!deviceOnly)
00433     {
00434         // When handling device lost, we only need to recreate the graphics-device related
00435         // resources. All other delayed resources that only need to be created on app
00436         // startup go here.
00437
00438         m_audio.CreateResources();
00439     }
00440
00441     if (delay)
00442     {
00443         while (loadingTimer->Total < 3.5)
00444         {
00445             // MarbleMaze doesn't take long to load resources,
00446             // so we're simulating a longer load time to demonstrate
00447             // a more real world example
00448             loadingTimer->Update();
00449         }
00450     }
00451
00452     m_deferredResourcesReady = true;
00453 }
00454
00455 void MarbleMaze::Render()
00456 {
00457     // Bind the render targets.
00458     m_d3dContext->OMSetRenderTargets(
00459         1,
00460         m_d3dRenderTargetView.GetAddressOf(),
00461         m_d3dDepthStencilView.Get()
00462         );
00463
00464     // Clear the render target and depth stencil to default values.
00465     const float clearColor[4] = { 0.0f, 0.0f, 0.0f, 1.0f };
00466
00467     m_d3dContext->ClearRenderTargetView(
00468         m_d3dRenderTargetView.Get(),
00469         clearColor
00470         );
00471
00472     m_d3dContext->ClearDepthStencilView(
00473         m_d3dDepthStencilView.Get(),
00474         D3D11_CLEAR_DEPTH,
00475         1.0f,
00476         0
00477         );
00478
00479     if (!m_deferredResourcesReady)
00480     {
00481         // Only render the loading screen for now.
00482
00483         m_loadScreen->Render();
00484         return;
00485     }
00486
00487     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00488
00489     FLOAT blendFactors[4] = { 0, };
00490     m_d3dContext->OMSetBlendState(m_blendState.Get(), blendFactors, 0xffffffff);
00491
00492     // Set the vertex shader stage state.
00493     m_d3dContext->VSSetShader(
00494         m_vertexShader.Get(),   // use this vertex shader
00495         nullptr,                // don't use shader linkage
00496         0                       // don't use shader linkage
00497         );
00498
00499     // Set the pixel shader stage state.
00500     m_d3dContext->PSSetShader(
00501         m_pixelShader.Get(),    // use this pixel shader
00502         nullptr,                // don't use shader linkage
00503         0                       // don't use shader linkage
00504         );
00505
00506     m_d3dContext->PSSetSamplers(
00507         0,                       // starting at the first sampler slot
00508         1,                       // set one sampler binding
00509         m_sampler.GetAddressOf() // to use this sampler
00510         );
00511
00512 #pragma region Rendering Maze
00513
00514     // Update the constant buffer with the new data.
00515     m_d3dContext->UpdateSubresource(
00516         m_constantBuffer.Get(),
00517         0,
00518         nullptr,
00519         &m_mazeConstantBufferData,
00520         0,
00521         0
00522         );
00523
00524     m_d3dContext->VSSetConstantBuffers(
00525         0,                // starting at the first constant buffer slot
00526         1,                // set one constant buffer binding
00527         m_constantBuffer.GetAddressOf() // to use this buffer
00528         );
00529
00530     m_d3dContext->PSSetConstantBuffers(
00531         0,                // starting at the first constant buffer slot
00532         1,                // set one constant buffer binding
00533         m_constantBuffer.GetAddressOf() // to use this buffer
00534         );
00535
00536     m_mazeMesh.Render(m_d3dContext.Get(), 0, INVALID_SAMPLER_SLOT, INVALID_SAMPLER_SLOT);
00537
00538 #pragma endregion
00539
00540 #pragma region Rendering Marble
00541
00542     // update the constant buffer with the new data
00543     m_d3dContext->UpdateSubresource(
00544         m_constantBuffer.Get(),
00545         0,
00546         nullptr,
00547         &m_marbleConstantBufferData,
00548         0,
00549         0
00550         );
00551
00552     m_d3dContext->VSSetConstantBuffers(
00553         0,                // starting at the first constant buffer slot
00554         1,                // set one constant buffer binding
00555         m_constantBuffer.GetAddressOf() // to use this buffer
00556         );
00557
00558     m_d3dContext->PSSetConstantBuffers(
00559         0,                // starting at the first constant buffer slot
00560         1,                // set one constant buffer binding
00561         m_constantBuffer.GetAddressOf() // to use this buffer
00562         );
00563
00564     m_marbleMesh.Render(m_d3dContext.Get(), 0, INVALID_SAMPLER_SLOT, INVALID_SAMPLER_SLOT);
00565
00566 #pragma endregion
00567
00568     // Process audio.
00569     m_audio.Render();
00570
00571     // Draw the user interface and the overlay.
00572     UserInterface::GetInstance().Render();
00573
00574     m_sampleOverlay->Render();
00575 }
00576
00577 void MarbleMaze::SetGameState(GameState nextState)
00578 {
00579     // previous state cleanup
00580     switch (m_gameState)
00581     {
00582     case GameState::MainMenu:
00583         m_startGameButton.SetVisible(false);
00584         m_highScoreButton.SetVisible(false);
00585         break;
00586
00587     case GameState::HighScoreDisplay:
00588         m_highScoreTable.SetVisible(false);
00589         break;
00590
00591     case GameState::PreGameCountdown:
00592         m_inGameStopwatchTimer.Reset();
00593         m_inGameStopwatchTimer.SetVisible(true);
00594         break;
00595
00596     case GameState::PostGameResults:
00597         m_resultsText.SetVisible(false);
00598         break;
00599     }
00600
00601     // next state setup
00602     switch (nextState)
00603     {
00604     case GameState::MainMenu:
00605         m_startGameButton.SetVisible(true);
00606         m_startGameButton.SetSelected(true);
00607         m_highScoreButton.SetVisible(true);
00608         m_highScoreButton.SetSelected(false);
00609         m_pausedText.SetVisible(false);
00610
00611         m_resetCamera = true;
00612         m_resetMarbleRotation = true;
00613         m_physics.SetPosition(XMFLOAT3(305, -210, -43));
00614         m_targetLightStrength = 0.6f;
00615         break;
00616
00617     case GameState::HighScoreDisplay:
00618         m_highScoreTable.SetVisible(true);
00619         break;
00620
00621     case GameState::PreGameCountdown:
00622         m_inGameStopwatchTimer.SetVisible(false);
00623         m_preGameCountdownTimer.SetVisible(true);
00624         m_preGameCountdownTimer.StartCountdown(3);
00625
00626         ResetCheckpoints();
00627         m_resetCamera = true;
00628         m_resetMarbleRotation = true;
00629         m_physics.SetPosition(m_checkpoints[0]);
00630         m_physics.SetVelocity(XMFLOAT3(0, 0, 0));
00631         m_targetLightStrength = 1.0f;
00632         break;
00633
00634     case GameState::InGameActive:
00635         m_pausedText.SetVisible(false);
00636         m_inGameStopwatchTimer.Start();
00637         m_targetLightStrength = 1.0f;
00638         break;
00639
00640     case GameState::InGamePaused:
00641         m_pausedText.SetVisible(true);
00642         m_inGameStopwatchTimer.Stop();
00643         m_targetLightStrength = 0.6f;
00644         break;
00645
00646     case GameState::PostGameResults:
00647         m_inGameStopwatchTimer.Stop();
00648         m_inGameStopwatchTimer.SetVisible(false);
00649         m_resultsText.SetVisible(true);
00650         {
00651             WCHAR formattedTime[32];
00652             m_inGameStopwatchTimer.GetFormattedTime(formattedTime, m_newHighScore.elapsedTime);
00653             WCHAR buffer[64];
00654             swprintf_s(
00655                 buffer,
00656                 L"%s\nYour time: %s",
00657                 (m_newHighScore.wasJustAdded ? L"New High Score!" : L"Finished!"),
00658                 formattedTime
00659                 );
00660             m_resultsText.SetText(buffer);
00661             m_resultsText.SetVisible(true);
00662         }
00663         m_targetLightStrength = 0.6f;
00664         break;
00665     }
00666
00667     m_gameState = nextState;
00668 }
00669
00670 void MarbleMaze::ResetCheckpoints()
00671 {
00672     m_currentCheckpoint = 0;
00673 }
00674
00675 CheckpointState MarbleMaze::UpdateCheckpoints()
00676 {
00677     if (m_currentCheckpoint >= (m_checkpoints.size() - 1))
00678         return CheckpointState::None;
00679
00680     const float checkpointRadius = 20.0f;
00681     float radius = m_physics.GetRadius();
00682     float horizDistSq = (radius + checkpointRadius) * (radius + checkpointRadius);
00683     XMVECTOR horizDistSqLimit = XMVectorSet(horizDistSq, horizDistSq, horizDistSq, horizDistSq);
00684     float vertDistSq = radius * radius;
00685     XMVECTOR vertDistSqLimit = XMVectorSet(vertDistSq, vertDistSq, vertDistSq, vertDistSq);
00686
00687     XMVECTOR position = XMLoadFloat3(&m_physics.GetPosition());
00688     XMVECTOR up = XMVectorSet(0.0f, 0.0f, -1.0f, 0.0f);
00689
00690     for (size_t i = m_currentCheckpoint + 1; i < m_checkpoints.size(); ++i)
00691     {
00692         XMVECTOR checkpointPos = XMLoadFloat3(&m_checkpoints[i]);
00693         XMVECTOR posCheckSpace = position - checkpointPos;
00694         XMVECTOR posVertical = up * XMVector3Dot(up, posCheckSpace);
00695         XMVECTOR posHorizontal = posCheckSpace - posVertical;
00696         XMVECTOR vHorizDistSq = XMVector3LengthSq(posHorizontal);
00697         XMVECTOR vVertDistSq = XMVector3LengthSq(posVertical);
00698
00699         XMVECTOR check = XMVectorAndInt(
00700             XMVectorLessOrEqual(vHorizDistSq, horizDistSqLimit),
00701             XMVectorLessOrEqual(vVertDistSq, vertDistSqLimit)
00702             );
00703         if (XMVector3EqualInt(check, XMVectorTrueInt()))
00704         {
00705             m_currentCheckpoint = i;
00706
00707             if (i == (m_checkpoints.size() - 1))
00708                 return CheckpointState::Goal;
00709             else
00710                 return CheckpointState::Save;
00711         }
00712     }
00713
00714     return CheckpointState::None;
00715 }
00716
00717 void MarbleMaze::Update(float timeTotal, float timeDelta)
00718 {
00719     // When the game is first loaded, we display a load screen
00720     // and load any deferred resources that might be too expensive
00721     // to load during initialization.
00722     if (!m_deferredResourcesReady)
00723     {
00724         // At this point we can draw a progress bar, or if we had
00725         // loaded audio, we could play audio during the loading process.
00726
00727         return;
00728     }
00729
00730     if (!m_audio.m_isAudioStarted)
00731     {
00732         m_audio.Start();
00733     }
00734
00735     UserInterface::GetInstance().Update(timeTotal, timeDelta);
00736
00737     if (m_gameState == GameState::Initial)
00738         SetGameState(GameState::MainMenu);
00739
00740     switch (m_gameState)
00741     {
00742         case GameState::PreGameCountdown:
00743             if (m_preGameCountdownTimer.IsCountdownComplete())
00744                 SetGameState(GameState::InGameActive);
00745             break;
00746     }
00747
00748 #pragma region Process Input
00749
00750     float combinedTiltX = 0.0f;
00751     float combinedTiltY = 0.0f;
00752
00753     // This array contains the constants from XINPUT that map to the
00754     // particular buttons that are used by the game.
00755     // The index of the array is used to associate the state of that button in
00756     // the wasButtonDown, isButtonDown, and combinedButtonPressed variables.
00757
00758     static const WORD buttons[] =
00759     {
00760         XINPUT_GAMEPAD_A,
00761         XINPUT_GAMEPAD_START,
00762         XINPUT_GAMEPAD_DPAD_UP,
00763         XINPUT_GAMEPAD_DPAD_DOWN,
00764         XINPUT_GAMEPAD_DPAD_LEFT,
00765         XINPUT_GAMEPAD_DPAD_RIGHT,
00766         XINPUT_GAMEPAD_BACK,
00767     };
00768
00769     static const int buttonCount = ARRAYSIZE(buttons);
00770     static bool wasButtonDown[XUSER_MAX_COUNT][buttonCount] = { false, };
00771     bool isButtonDown[XUSER_MAX_COUNT][buttonCount] = { false, };
00772
00773     // Account for input on any connected controller.
00774     XINPUT_STATE inputState = {0};
00775     for (DWORD userIndex = 0; userIndex < XUSER_MAX_COUNT; ++userIndex)
00776     {
00777         DWORD result = XInputGetState(userIndex, &inputState);
00778         if (result != ERROR_SUCCESS)
00779             continue;
00780
00781         SHORT thumbLeftX = inputState.Gamepad.sThumbLX;
00782         if (abs(thumbLeftX) < XINPUT_GAMEPAD_LEFT_THUMB_DEADZONE)
00783             thumbLeftX = 0;
00784
00785         SHORT thumbLeftY = inputState.Gamepad.sThumbLY;
00786         if (abs(thumbLeftY) < XINPUT_GAMEPAD_LEFT_THUMB_DEADZONE)
00787             thumbLeftY = 0;
00788
00789         combinedTiltX += static_cast<float>(thumbLeftX) / 32768.0f;
00790         combinedTiltY += static_cast<float>(thumbLeftY) / 32768.0f;
00791
00792         for (int i = 0; i < buttonCount; ++i)
00793             isButtonDown[userIndex][i] = (inputState.Gamepad.wButtons & buttons[i]) == buttons[i];
00794     }
00795
00796     bool combinedButtonPressed[buttonCount] = { false, };
00797     for (int i = 0; i < buttonCount; ++i)
00798     {
00799         for (DWORD userIndex = 0; userIndex < XUSER_MAX_COUNT; ++userIndex)
00800         {
00801             bool pressed = !wasButtonDown[userIndex][i] && isButtonDown[userIndex][i];
00802             combinedButtonPressed[i] = combinedButtonPressed[i] || pressed;
00803         }
00804     }
00805
00806     // Check whether the user paused or resumed the game.
00807     // XINPUT_GAMEPAD_START
00808     if (combinedButtonPressed[1] || m_pauseKeyPressed)
00809     {
00810         m_pauseKeyPressed = false;
00811         if (m_gameState == GameState::InGameActive)
00812             SetGameState(GameState::InGamePaused);
00813         else if (m_gameState == GameState::InGamePaused)
00814             SetGameState(GameState::InGameActive);
00815     }
00816
00817     // Check whether the user restarted the game or cleared the high score table.
00818     // XINPUT_GAMEPAD_BACK
00819     if (combinedButtonPressed[6] || m_homeKeyPressed)
00820     {
00821         m_homeKeyPressed = false;
00822         if (m_gameState == GameState::InGameActive ||
00823             m_gameState == GameState::InGamePaused ||
00824             m_gameState == GameState::PreGameCountdown)
00825         {
00826             SetGameState(GameState::MainMenu);
00827             m_inGameStopwatchTimer.SetVisible(false);
00828             m_preGameCountdownTimer.SetVisible(false);
00829         }
00830         else if (m_gameState == GameState::HighScoreDisplay)
00831         {
00832             m_highScoreTable.Reset();
00833         }
00834     }
00835
00836     // Check whether the user chose a button from the UI.
00837     bool anyPoints = !m_pointQueue.empty();
00838     while (!m_pointQueue.empty())
00839     {
00840         UserInterface::GetInstance().HitTest(m_pointQueue.front());
00841         m_pointQueue.pop();
00842     }
00843
00844     // Handle menu navigation.
00845
00846     // XINPUT_GAMEPAD_A or XINPUT_GAMEPAD_START
00847     bool chooseSelection = (combinedButtonPressed[0] || combinedButtonPressed[1]);
00848
00849     // XINPUT_GAMEPAD_DPAD_UP
00850     bool moveUp = combinedButtonPressed[2];
00851
00852     // XINPUT_GAMEPAD_DPAD_DOWN
00853     bool moveDown = combinedButtonPressed[3];
00854
00855     switch (m_gameState)
00856     {
00857     case GameState::MainMenu:
00858         if (chooseSelection)
00859         {
00860             m_audio.PlaySoundEffect(MenuSelectedEvent);
00861
00862             if (m_startGameButton.GetSelected())
00863                 m_startGameButton.SetPressed(true);
00864
00865             if (m_highScoreButton.GetSelected())
00866                 m_highScoreButton.SetPressed(true);
00867         }
00868         if (moveUp || moveDown)
00869         {
00870             m_startGameButton.SetSelected(!m_startGameButton.GetSelected());
00871             m_highScoreButton.SetSelected(!m_startGameButton.GetSelected());
00872
00873             m_audio.PlaySoundEffect(MenuChangeEvent);
00874         }
00875         break;
00876
00877     case GameState::HighScoreDisplay:
00878         if (chooseSelection || anyPoints)
00879             SetGameState(GameState::MainMenu);
00880         break;
00881
00882     case GameState::PostGameResults:
00883         if (chooseSelection || anyPoints)
00884             SetGameState(GameState::HighScoreDisplay);
00885         break;
00886
00887     case GameState::InGamePaused:
00888         if (m_pausedText.IsPressed())
00889         {
00890             m_pausedText.SetPressed(false);
00891             SetGameState(GameState::InGameActive);
00892         }
00893         break;
00894     }
00895
00896     // Update button state for next frame.
00897     memcpy(wasButtonDown, isButtonDown, sizeof(wasButtonDown));
00898
00899     // Update the game state if the user chose a menu option.
00900     if (m_startGameButton.IsPressed())
00901     {
00902         SetGameState(GameState::PreGameCountdown);
00903         m_startGameButton.SetPressed(false);
00904     }
00905     if (m_highScoreButton.IsPressed())
00906     {
00907         SetGameState(GameState::HighScoreDisplay);
00908         m_highScoreButton.SetPressed(false);
00909     }
00910
00911     // Account for touch input.
00912     const float touchScalingFactor = 2.0f;
00913     for (TouchMap::const_iterator iter = m_touches.cbegin(); iter != m_touches.cend(); ++iter)
00914     {
00915         combinedTiltX += iter->second.x * touchScalingFactor;
00916         combinedTiltY += iter->second.y * touchScalingFactor;
00917     }
00918
00919     // Account for sensors.
00920     const float acceleromterScalingFactor = 3.5f;
00921     if (m_accelerometer != nullptr)
00922     {
00923         Windows::Devices::Sensors::AccelerometerReading^ reading =
00924             m_accelerometer->GetCurrentReading();
00925
00926         if (reading != nullptr)
00927         {
00928             combinedTiltX += static_cast<float>(reading->AccelerationX) * acceleromterScalingFactor;
00929             combinedTiltY += static_cast<float>(reading->AccelerationY) * acceleromterScalingFactor;
00930         }
00931     }
00932
00933     // Clamp input.
00934     combinedTiltX = max(-1, min(1, combinedTiltX));
00935     combinedTiltY = max(-1, min(1, combinedTiltY));
00936
00937     if (m_gameState != GameState::PreGameCountdown &&
00938         m_gameState != GameState::InGameActive &&
00939         m_gameState != GameState::InGamePaused)
00940     {
00941         // Ignore tilt when the menu is active.
00942         combinedTiltX = 0.0f;
00943         combinedTiltY = 0.0f;
00944     }
00945
00946 #pragma endregion
00947
00948 #pragma region Physics
00949
00950     const float maxTilt = 1.0f / 8.0f;
00951     XMVECTOR gravity = XMVectorSet(combinedTiltX * maxTilt, combinedTiltY * maxTilt, 1.0f, 0.0f);
00952     gravity = XMVector3Normalize(gravity);
00953
00954     XMFLOAT3 g;
00955     XMStoreFloat3(&g, gravity);
00956     m_physics.SetGravity(g);
00957
00958     if (m_gameState == GameState::InGameActive)
00959     {
00960         // Only update physics when gameplay is active.
00961         m_physics.UpdatePhysicsSimulation(timeDelta);
00962
00963         // Handle checkpoints.
00964         switch (UpdateCheckpoints())
00965         {
00966         case CheckpointState::Save:
00967             // Display checkpoint notice.
00968             m_checkpointText.SetVisible(true);
00969             m_checkpointText.SetTextOpacity(1.0f);
00970             m_checkpointText.FadeOut(2.0f);
00971             m_audio.PlaySoundEffect(CheckpointEvent);
00972             SaveState();
00973             break;
00974
00975         case CheckpointState::Goal:
00976             m_inGameStopwatchTimer.Stop();
00977             m_newHighScore.elapsedTime = m_inGameStopwatchTimer.GetElapsedTime();
00978             SYSTEMTIME systemTime;
00979             GetLocalTime(&systemTime);
00980             WCHAR buffer[64];
00981             swprintf_s(buffer, L"%d/%d/%d", systemTime.wYear, systemTime.wMonth, systemTime.wDay);
00982             m_newHighScore.tag = ref new Platform::String(buffer);
00983             m_highScoreTable.AddScoreToTable(m_newHighScore);
00984
00985             m_audio.PlaySoundEffect(CheckpointEvent);
00986             m_audio.StopSoundEffect(RollingEvent);
00987
00988             // Display game results.
00989             SetGameState(GameState::PostGameResults);
00990             SaveState();
00991             break;
00992         }
00993     }
00994
00995     float3 marblePosition;
00996     memcpy(&marblePosition, &m_physics.GetPosition(), sizeof(float3));
00997     static float3 oldMarblePosition = marblePosition;
00998
00999     const float4x4 initialMarbleRotationMatrix = mul(rotationY(90.0f), rotationX(90.0f));
01000     static float4x4 marbleRotationMatrix = initialMarbleRotationMatrix;
01001
01002     // Check whether the marble fell off of the maze.
01003     const float fadeOutDepth = 0.0f;
01004     const float resetDepth = 80.0f;
01005     if (marblePosition.z >= fadeOutDepth)
01006     {
01007         m_targetLightStrength = 0.0f;
01008     }
01009     if (marblePosition.z >= resetDepth)
01010     {
01011         // Reset marble.
01012         memcpy(&marblePosition, &m_checkpoints[m_currentCheckpoint], sizeof(XMFLOAT3));
01013         oldMarblePosition = marblePosition;
01014         m_physics.SetPosition((const XMFLOAT3&)marblePosition);
01015         m_physics.SetVelocity(XMFLOAT3(0, 0, 0));
01016         m_lightStrength = 0.0f;
01017         m_targetLightStrength = 1.0f;
01018
01019         m_resetCamera = true;
01020         m_resetMarbleRotation = true;
01021         m_audio.PlaySoundEffect(FallingEvent);
01022     }
01023
01024     float3 marbleRotation = (oldMarblePosition - marblePosition) / m_physics.GetRadius();
01025     oldMarblePosition = marblePosition;
01026
01027     if (m_resetMarbleRotation)
01028     {
01029         marbleRotationMatrix = initialMarbleRotationMatrix;
01030         m_resetMarbleRotation = false;
01031     }
01032     else
01033     {
01034         marbleRotationMatrix = mul(rotationY(marbleRotation.x * 180.0f / 3.1415926535f), marbleRotationMatrix);
01035         marbleRotationMatrix = mul(rotationX(marbleRotation.y * -180.0f / 3.1415926535f), marbleRotationMatrix);
01036     }
01037
01038 #pragma endregion
01039
01040 #pragma region Update Camera
01041
01042     static float eyeDistance = 200.0f;
01043     static float3 eyePosition = float3(0, 0, 0);
01044
01045     // Gradually move the camera above the marble.
01046     float3 targetEyePosition = marblePosition - (eyeDistance * float3(g.x, g.y, g.z));
01047     if (m_resetCamera)
01048     {
01049         eyePosition = targetEyePosition;
01050         m_resetCamera = false;
01051     }
01052     else
01053     {
01054         eyePosition = eyePosition + ((targetEyePosition - eyePosition) * min(1, timeDelta * 8));
01055     }
01056
01057     // Look at the marble.
01058     if ((m_gameState == GameState::MainMenu) || (m_gameState == GameState::HighScoreDisplay))
01059     {
01060         // Override camera position for menus.
01061         eyePosition = marblePosition + float3(75.0f, -150.0f, -75.0f);
01062         m_camera->SetViewParameters(eyePosition, marblePosition, float3(0.0f, 0.0f, -1.0f));
01063     }
01064     else
01065     {
01066         m_camera->SetViewParameters(eyePosition, marblePosition, float3(0.0f, 1.0f, 0.0f));
01067     }
01068
01069 #pragma endregion
01070
01071 #pragma region Update Constant Buffers
01072
01073     // Update the model matrices based on the simulation.
01074     m_mazeConstantBufferData.model = identity();
01075     m_marbleConstantBufferData.model = mul(
01076         translation(marblePosition.x, marblePosition.y, marblePosition.z),
01077         marbleRotationMatrix
01078         );
01079
01080     // Update the view matrix based on the camera.
01081     float4x4 view;
01082     m_camera->GetViewMatrix(&view);
01083     m_mazeConstantBufferData.view = view;
01084     m_marbleConstantBufferData.view = view;
01085
01086     // Update lighting constants.
01087     m_lightStrength += (m_targetLightStrength - m_lightStrength) * min(1, timeDelta * 4);
01088
01089     m_mazeConstantBufferData.marblePosition = marblePosition;
01090     m_mazeConstantBufferData.marbleRadius = m_physics.GetRadius();
01091     m_mazeConstantBufferData.lightStrength = m_lightStrength;
01092     m_marbleConstantBufferData.marblePosition = marblePosition;
01093     m_marbleConstantBufferData.marbleRadius = m_physics.GetRadius();
01094     m_marbleConstantBufferData.lightStrength = m_lightStrength;
01095
01096 #pragma endregion
01097
01098 #pragma region Update Audio
01099
01100     if (! m_audio.HasEngineExperiencedCriticalError())
01101     {
01102         if (m_gameState == GameState::InGameActive)
01103         {
01104             float wallDistances[8];
01105             int returnedCount = m_physics.GetRoomDimensions(wallDistances, ARRAYSIZE(wallDistances));
01106             assert(returnedCount == ARRAYSIZE(wallDistances));
01107             m_audio.SetRoomSize(m_physics.GetRoomSize(), wallDistances);
01108             CollisionInfo ci = m_physics.GetCollisionInfo();
01109
01110             // Calculate roll sound, and pitch according to velocity.
01111             XMFLOAT3 velocity = m_physics.GetVelocity();
01112             XMFLOAT3 position = m_physics.GetPosition();
01113             float volumeX = abs(velocity.x) / 200;
01114             if (volumeX > 1.0) volumeX = 1.0;
01115             if (volumeX < 0.0) volumeX = 0.0;
01116             float volumeY = abs(velocity.y) / 200;
01117             if (volumeY > 1.0) volumeY = 1.0;
01118             if (volumeY < 0.0) volumeY = 0.0;
01119             float volume = max(volumeX, volumeY);
01120
01121             // Pitch of the rolling sound ranges from .85 to 1.05f,
01122             // increasing logarithmically.
01123             float pitch = .85f + (volume * volume / 5.0f);
01124
01125             // Play the roll sound only if the marble is actually rolling.
01126             if (ci.isRollingOnFloor && volume > 0)
01127             {
01128                 if (!m_audio.IsSoundEffectStarted(RollingEvent))
01129                 {
01130                     m_audio.PlaySoundEffect(RollingEvent);
01131                 }
01132
01133                 // Update the volume and pitch by the velocity.
01134                 m_audio.SetSoundEffectVolume(RollingEvent, volume);
01135                 m_audio.SetSoundEffectPitch(RollingEvent, pitch);
01136
01137                 // The rolling sound has at most 8000Hz sounds, so we linearly
01138                 // ramp up the low-pass filter the faster we go.
01139                 // We also reduce the Q-value of the filter, starting with a
01140                 // relatively broad cutoff and get progressively tighter.
01141                 m_audio.SetSoundEffectFilter(
01142                     RollingEvent,
01143                     600.0f + 8000.0f * volume,
01144                     XAUDIO2_MAX_FILTER_ONEOVERQ - volume*volume
01145                     );
01146             }
01147             else
01148             {
01149                 m_audio.SetSoundEffectVolume(RollingEvent, 0);
01150             }
01151
01152             if (ci.elasticCollision && ci.maxCollisionSpeed > 10)
01153             {
01154                 m_audio.PlaySoundEffect(CollisionEvent);
01155
01156                 float collisionVolume = ci.maxCollisionSpeed/150.0f;
01157                 collisionVolume = min(collisionVolume * collisionVolume, 1.0f);
01158                 m_audio.SetSoundEffectVolume(CollisionEvent, collisionVolume);
01159             }
01160         }
01161         else
01162         {
01163             m_audio.SetSoundEffectVolume(RollingEvent, 0);
01164         }
01165     }
01166 #pragma endregion
01167
01168 }
01169
01170 void MarbleMaze::SaveState()
01171 {
01172     m_persistentState->SaveXMFLOAT3(":Position", m_physics.GetPosition());
01173     m_persistentState->SaveXMFLOAT3(":Velocity", m_physics.GetVelocity());
01174     m_persistentState->SaveSingle(":ElapsedTime", m_inGameStopwatchTimer.GetElapsedTime());
01175
01176     m_persistentState->SaveInt32(":GameState", static_cast<int>(m_gameState));
01177     m_persistentState->SaveInt32(":Checkpoint", static_cast<int>(m_currentCheckpoint));
01178
01179     int i = 0;
01180     HighScoreEntries entries = m_highScoreTable.GetEntries();
01181     const int bufferLength = 16;
01182     char16 str[bufferLength];
01183
01184     m_persistentState->SaveInt32(":ScoreCount", static_cast<int>(entries.size()));
01185     for (auto iter = entries.begin(); iter != entries.end(); ++iter)
01186     {
01187         int len = swprintf_s(str, bufferLength, L"%d", i++);
01188         Platform::String^ string = ref new Platform::String(str, len);
01189
01190         m_persistentState->SaveSingle(Platform::String::Concat(":ScoreTime", string), iter->elapsedTime);
01191         m_persistentState->SaveString(Platform::String::Concat(":ScoreTag", string), iter->tag);
01192     }
01193 }
01194
01195 void MarbleMaze::LoadState()
01196 {
01197     XMFLOAT3 position = m_persistentState->LoadXMFLOAT3(":Position", m_physics.GetPosition());
01198     XMFLOAT3 velocity = m_persistentState->LoadXMFLOAT3(":Velocity", m_physics.GetVelocity());
01199     float elapsedTime = m_persistentState->LoadSingle(":ElapsedTime", 0.0f);
01200
01201     int gameState = m_persistentState->LoadInt32(":GameState", static_cast<int>(m_gameState));
01202     int currentCheckpoint = m_persistentState->LoadInt32(":Checkpoint", static_cast<int>(m_currentCheckpoint));
01203
01204     switch (static_cast<GameState>(gameState))
01205     {
01206     case GameState::Initial:
01207         break;
01208
01209     case GameState::MainMenu:
01210     case GameState::HighScoreDisplay:
01211     case GameState::PreGameCountdown:
01212     case GameState::PostGameResults:
01213         SetGameState(GameState::MainMenu);
01214         break;
01215
01216     case GameState::InGameActive:
01217     case GameState::InGamePaused:
01218         m_inGameStopwatchTimer.SetVisible(true);
01219         m_inGameStopwatchTimer.SetElapsedTime(elapsedTime);
01220         m_physics.SetPosition(position);
01221         m_physics.SetVelocity(velocity);
01222         m_currentCheckpoint = currentCheckpoint;
01223         SetGameState(GameState::InGamePaused);
01224         break;
01225     }
01226
01227     int count = m_persistentState->LoadInt32(":ScoreCount", 0);
01228
01229     const int bufferLength = 16;
01230     char16 str[bufferLength];
01231
01232     for (int i = 0; i < count; i++)
01233     {
01234         HighScoreEntry entry;
01235         int len = swprintf_s(str, bufferLength, L"%d", i);
01236         Platform::String^ string = ref new Platform::String(str, len);
01237
01238         entry.elapsedTime = m_persistentState->LoadSingle(Platform::String::Concat(":ScoreTime", string), 0.0f);
01239         entry.tag = m_persistentState->LoadString(Platform::String::Concat(":ScoreTag", string), L"");
01240         m_highScoreTable.AddScoreToTable(entry);
01241     }
01242 }
01243
01244 inline XMFLOAT2 PointToTouch(Windows::Foundation::Point point, Windows::Foundation::Rect bounds)
01245 {
01246     float touchRadius = min(bounds.Width, bounds.Height);
01247     float dx = (point.X - (bounds.Width / 2.0f)) / touchRadius;
01248     float dy = ((bounds.Height / 2.0f) - point.Y) / touchRadius;
01249
01250     return XMFLOAT2(dx, dy);
01251 }
01252
01253 void MarbleMaze::AddTouch(int id, Windows::Foundation::Point point)
01254 {
01255     m_touches[id] = PointToTouch(point, m_windowBounds);
01256
01257     m_pointQueue.push(D2D1::Point2F(point.X, point.Y));
01258 }
01259
01260 void MarbleMaze::UpdateTouch(int id, Windows::Foundation::Point point)
01261 {
01262     if (m_touches.find(id) != m_touches.end())
01263         m_touches[id] = PointToTouch(point, m_windowBounds);
01264 }
01265
01266 void MarbleMaze::RemoveTouch(int id)
01267 {
01268     m_touches.erase(id);
01269 }
01270
01271 void MarbleMaze::KeyDown(VirtualKey key)
01272 {
01273     if (key == VirtualKey::P)       // Pause
01274     {
01275         m_pauseKeyActive = true;
01276     }
01277     if (key == VirtualKey::Home)
01278     {
01279         m_homeKeyActive = true;
01280     }
01281 }
01282
01283 void MarbleMaze::KeyUp(VirtualKey key)
01284 {
01285     if (key == VirtualKey::P)
01286     {
01287         if (m_pauseKeyActive)
01288         {
01289             // trigger pause only once on button release
01290             m_pauseKeyPressed = true;
01291             m_pauseKeyActive = false;
01292         }
01293     }
01294     if (key == VirtualKey::Home)
01295     {
01296         if (m_homeKeyActive)
01297         {
01298             m_homeKeyPressed = true;
01299             m_homeKeyActive = false;
01300         }
01301     }
01302 }
01303
01304 void MarbleMaze::OnSuspending()
01305 {
01306     SaveState();
01307     m_audio.SuspendAudio();
01308 }
01309
01310 void MarbleMaze::OnResuming()
01311 {
01312     m_audio.ResumeAudio();
01313 }
01314
01315 void MarbleMaze::OnFocusChange(bool active)
01316 {
01317     static bool lostFocusPause = false;
01318
01319     if (m_deferredResourcesReady)
01320     {
01321         if (m_windowActive != active)
01322         {
01323             if (active)
01324             {
01325                 m_audio.ResumeAudio();
01326                 if ((m_gameState == GameState::InGamePaused) && lostFocusPause)
01327                 {
01328                     SetGameState(GameState::InGameActive);
01329                 }
01330             }
01331             else
01332             {
01333                 m_audio.SuspendAudio();
01334                 if (m_gameState == GameState::InGameActive)
01335                 {
01336                     SetGameState(GameState::InGamePaused);
01337                     lostFocusPause = true;
01338                     SaveState();
01339                 }
01340                 else if (m_gameState == GameState::PreGameCountdown)
01341                 {
01342                     SetGameState(GameState::MainMenu);
01343                     m_inGameStopwatchTimer.SetVisible(false);
01344                     m_preGameCountdownTimer.SetVisible(false);
01345                 }
01346             }
01347             m_windowActive = active;
01348         }
01349     }
01350 }
01351
01352 void MarbleMaze::OnViewChange(ApplicationViewState state)
01353 {
01354     m_viewState = state;
01355 }
01356
01357
01358 FORCEINLINE int FindMeshIndexByName(SDKMesh &mesh, const char *meshName)
01359 {
01360     UINT meshCount = mesh.GetNumMeshes();
01361     for (UINT i = 0; i < meshCount; ++i)
01362     {
01363         if (0 == _stricmp(mesh.GetMesh(i)->Name, meshName))
01364             return i;
01365     }
01366
01367     return -1; // Not found.
01368 }
01369
01370 HRESULT MarbleMaze::ExtractTrianglesFromMesh(
01371     SDKMesh &mesh,
01372     const char *meshName,
01373     std::vector<Triangle> &triangles
01374     )
01375 {
01376     triangles.clear();
01377
01378     int meshIndex = FindMeshIndexByName(mesh, meshName);
01379     if (meshIndex < 0)
01380     {
01381         return E_FAIL;
01382     }
01383     SDKMESH_MESH *currentmesh = mesh.GetMesh(meshIndex);
01384
01385     for (UINT i = 0; i < currentmesh->NumSubsets; ++i)
01386     {
01387         SDKMESH_SUBSET *subsetmesh = mesh.GetSubset(meshIndex, i);
01388
01389         USHORT *indices = (USHORT*)mesh.GetRawIndicesAt(currentmesh->IndexBuffer) + subsetmesh->IndexStart;
01390         BYTE *vertices = mesh.GetRawVerticesAt(currentmesh->VertexBuffers[0]) + (subsetmesh->VertexStart * m_vertexStride);
01391         for (UINT j = 0; j < subsetmesh->IndexCount; j += 3)
01392         {
01393             XMFLOAT3 a, b, c;
01394             memcpy(&a, vertices + (*(indices++) * m_vertexStride), sizeof(XMFLOAT3));
01395             memcpy(&b, vertices + (*(indices++) * m_vertexStride), sizeof(XMFLOAT3));
01396             memcpy(&c, vertices + (*(indices++) * m_vertexStride), sizeof(XMFLOAT3));
01397             triangles.push_back(Triangle(a, b, c));
01398         }
01399     }
01400
01401     return S_OK;
01402 }
01403
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/TargetTexture.cpp Source File

  • XAML DirectX 3D shooting game

TargetTexture.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "TargetTexture.h"
00010 #include "DirectXSample.h"
00011
00012 using namespace Microsoft::WRL;
00013 using namespace Windows::Graphics::Display;
00014
00015 TargetTexture::TargetTexture(
00016     _In_ ID3D11Device1* d3dDevice,
00017     _In_ ID2D1Factory1* d2dFactory,
00018     _In_ IDWriteFactory1* dwriteFactory,
00019     _In_ ID2D1DeviceContext* d2dContext
00020     )
00021 {
00022     m_d3dDevice = d3dDevice;
00023     m_d2dFactory = d2dFactory;
00024     m_dwriteFactory = dwriteFactory;
00025     m_d2dContext = d2dContext;
00026
00027     DX::ThrowIfFailed(
00028         m_d2dContext->CreateSolidColorBrush(
00029             D2D1::ColorF(D2D1::ColorF::Red, 1.f),
00030             &m_redBrush
00031             )
00032         );
00033
00034     DX::ThrowIfFailed(
00035         m_d2dContext->CreateSolidColorBrush(
00036             D2D1::ColorF(D2D1::ColorF::CornflowerBlue, 1.0f),
00037             &m_blueBrush
00038             )
00039         );
00040
00041     DX::ThrowIfFailed(
00042         m_d2dContext->CreateSolidColorBrush(
00043             D2D1::ColorF(D2D1::ColorF::Green, 1.f),
00044             &m_greenBrush
00045             )
00046         );
00047
00048     DX::ThrowIfFailed(
00049         m_d2dContext->CreateSolidColorBrush(
00050             D2D1::ColorF(D2D1::ColorF::White, 1.f),
00051             &m_whiteBrush
00052             )
00053         );
00054
00055     DX::ThrowIfFailed(
00056         m_d2dContext->CreateSolidColorBrush(
00057             D2D1::ColorF(D2D1::ColorF::Black, 1.f),
00058             &m_blackBrush
00059             )
00060         );
00061
00062     DX::ThrowIfFailed(
00063         m_d2dContext->CreateSolidColorBrush(
00064             D2D1::ColorF(D2D1::ColorF::Yellow, 1.f),
00065             &m_yellowBrush
00066             )
00067         );
00068
00069     DX::ThrowIfFailed(
00070         m_d2dContext->CreateSolidColorBrush(
00071             D2D1::ColorF(D2D1::ColorF::White, 0.0f),
00072             &m_clearBrush
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         m_d2dFactory->CreateEllipseGeometry(
00078             D2D1::Ellipse(
00079                 D2D1::Point2F(256.0f, 256.0f),
00080                 50.0f,
00081                 50.0f
00082                 ),
00083             &m_circleGeometry1)
00084             );
00085
00086     DX::ThrowIfFailed(
00087         m_d2dFactory->CreateEllipseGeometry(
00088             D2D1::Ellipse(
00089                 D2D1::Point2F(256.0f, 256.0f),
00090                 100.0f,
00091                 100.0f
00092                 ),
00093             &m_circleGeometry2)
00094             );
00095
00096     DX::ThrowIfFailed(
00097         m_d2dFactory->CreateEllipseGeometry(
00098             D2D1::Ellipse(
00099                 D2D1::Point2F(256.0f, 256.0f),
00100                 150.0f,
00101                 150.0f
00102                 ),
00103             &m_circleGeometry3)
00104             );
00105
00106     DX::ThrowIfFailed(
00107         m_d2dFactory->CreateEllipseGeometry(
00108             D2D1::Ellipse(
00109                 D2D1::Point2F(256.0f, 256.0f),
00110                 200.0f,
00111                 200.0f
00112                 ),
00113             &m_circleGeometry4)
00114             );
00115
00116     DX::ThrowIfFailed(
00117         m_d2dFactory->CreateEllipseGeometry(
00118             D2D1::Ellipse(
00119                 D2D1::Point2F(256.0f, 256.0f),
00120                 250.0f,
00121                 250.0f
00122                 ),
00123             &m_circleGeometry5)
00124             );
00125
00126     DX::ThrowIfFailed(
00127         m_dwriteFactory->CreateTextFormat(
00128             L"Segoe UI",
00129             nullptr,
00130             DWRITE_FONT_WEIGHT_LIGHT,
00131             DWRITE_FONT_STYLE_NORMAL,
00132             DWRITE_FONT_STRETCH_NORMAL,
00133             425,        // fontsize
00134             L"en-US",   // locale
00135             &m_textFormat
00136             )
00137         );
00138
00139     // Center the text horizontally.
00140     DX::ThrowIfFailed(
00141         m_textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00142         );
00143
00144     // Center the text vertically.
00145     DX::ThrowIfFailed(
00146         m_textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00147         );
00148 }
00149 //----------------------------------------------------------------------
00150 void TargetTexture::CreateTextureResourceView(
00151     _In_ Platform::String^ name,
00152     _Out_ ID3D11ShaderResourceView** textureResourceView
00153     )
00154 {
00155     // Allocate a offscreen D3D surface for D2D to render our 2D content into
00156     D3D11_TEXTURE2D_DESC texDesc;
00157     texDesc.ArraySize = 1;
00158     texDesc.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
00159     texDesc.CPUAccessFlags = 0;
00160     texDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00161     texDesc.Height = 512;
00162     texDesc.Width = 512;
00163     texDesc.MipLevels = 1;
00164     texDesc.MiscFlags = 0;
00165     texDesc.SampleDesc.Count = 1;
00166     texDesc.SampleDesc.Quality = 0;
00167     texDesc.Usage = D3D11_USAGE_DEFAULT;
00168
00169     ComPtr<ID3D11Texture2D> offscreenTexture;
00170     DX::ThrowIfFailed(
00171         m_d3dDevice->CreateTexture2D(&texDesc, nullptr, &offscreenTexture)
00172         );
00173
00174     // Convert the Direct2D texture into a Shader Resource View
00175     ComPtr<ID3D11ShaderResourceView> texture;
00176     DX::ThrowIfFailed(
00177         m_d3dDevice->CreateShaderResourceView(offscreenTexture.Get(), nullptr, &texture)
00178         );
00179 #if defined(_DEBUG)
00180     {
00181         char debugName[100];
00182         int l = sprintf_s(debugName, sizeof(debugName) / sizeof(debugName[0]), "Simple3DGame Target %ls", name->Data());
00183         DX::ThrowIfFailed(
00184             texture->SetPrivateData(WKPDID_D3DDebugObjectName, l, debugName)
00185             );
00186     }
00187 #endif
00188
00189     ComPtr<IDXGISurface> dxgiSurface;
00190     DX::ThrowIfFailed(
00191         offscreenTexture.As(&dxgiSurface)
00192         );
00193
00194     // Create a D2D render target which can draw into our offscreen D3D
00195     // surface. Given that we use a constant size for the texture, we
00196     // fix the DPI at 96.
00197
00198     D2D1_BITMAP_PROPERTIES1 properties;
00199     properties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
00200     properties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
00201     properties.dpiX = 96;
00202     properties.dpiY = 96;
00203     properties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
00204     properties.colorContext = nullptr;
00205
00206     ComPtr<ID2D1Bitmap1> renderTarget;
00207     DX::ThrowIfFailed(
00208         m_d2dContext->CreateBitmapFromDxgiSurface(
00209             dxgiSurface.Get(),
00210             &properties,
00211             &renderTarget
00212             )
00213         );
00214
00215     m_d2dContext->SetTarget(renderTarget.Get());
00216     float saveDpiX;
00217     float saveDpiY;
00218
00219     m_d2dContext->GetDpi(&saveDpiX, &saveDpiY);
00220     m_d2dContext->SetDpi(96.0f, 96.0f);
00221
00222     m_d2dContext->BeginDraw();
00223     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00224
00225     D2D1_SIZE_F renderTargetSize = renderTarget->GetSize();
00226
00227     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::White));
00228     m_d2dContext->FillGeometry(m_circleGeometry5.Get(), m_redBrush.Get());
00229     m_d2dContext->FillGeometry(m_circleGeometry4.Get(), m_blueBrush.Get());
00230     m_d2dContext->FillGeometry(m_circleGeometry3.Get(), m_greenBrush.Get());
00231     m_d2dContext->FillGeometry(m_circleGeometry2.Get(), m_yellowBrush.Get());
00232     m_d2dContext->FillGeometry(m_circleGeometry1.Get(), m_blackBrush.Get());
00233     m_d2dContext->DrawText(
00234         name->Data(),
00235         name->Length(),
00236         m_textFormat.Get(),
00237         D2D1::RectF(0, 0, renderTargetSize.width, renderTargetSize.height),
00238         m_whiteBrush.Get()
00239         );
00240
00241     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00242     // is lost. It will be handled during the next call to Present.
00243     HRESULT hr = m_d2dContext->EndDraw();
00244     if (hr != D2DERR_RECREATE_TARGET)
00245     {
00246         DX::ThrowIfFailed(hr);
00247     }
00248
00249     m_d2dContext->SetTarget(nullptr);
00250     m_d2dContext->SetDpi(saveDpiX, saveDpiY);
00251
00252     *textureResourceView = texture.Detach();
00253 }
00254 //----------------------------------------------------------------------
00255 void TargetTexture::CreateHitTextureResourceView(
00256     _In_ Platform::String^ name,
00257     _Out_ ID3D11ShaderResourceView** textureResourceView
00258     )
00259 {
00260     // Allocate a offscreen D3D surface for D2D to render our 2D content into
00261     D3D11_TEXTURE2D_DESC texDesc;
00262     texDesc.ArraySize = 1;
00263     texDesc.BindFlags = D3D11_BIND_RENDER_TARGET | D3D11_BIND_SHADER_RESOURCE;
00264     texDesc.CPUAccessFlags = 0;
00265     texDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00266     texDesc.Height = 512;
00267     texDesc.Width = 512;
00268     texDesc.MipLevels = 1;
00269     texDesc.MiscFlags = 0;
00270     texDesc.SampleDesc.Count = 1;
00271     texDesc.SampleDesc.Quality = 0;
00272     texDesc.Usage = D3D11_USAGE_DEFAULT;
00273
00274     ComPtr<ID3D11Texture2D> offscreenTexture;
00275     DX::ThrowIfFailed(
00276         m_d3dDevice->CreateTexture2D(&texDesc, nullptr, &offscreenTexture)
00277         );
00278
00279     // Convert the Direct2D texture into a Shader Resource View
00280     ComPtr<ID3D11ShaderResourceView> texture;
00281     DX::ThrowIfFailed(
00282         m_d3dDevice->CreateShaderResourceView(offscreenTexture.Get(), nullptr, &texture)
00283         );
00284 #if defined(_DEBUG)
00285     {
00286         char debugName[100];
00287         int l = sprintf_s(debugName, sizeof(debugName) / sizeof(debugName[0]), "Simple3DGame HitTarget %ls", name->Data());
00288         DX::ThrowIfFailed(
00289             texture->SetPrivateData(WKPDID_D3DDebugObjectName, l, debugName)
00290             );
00291     }
00292 #endif
00293
00294     ComPtr<IDXGISurface> dxgiSurface;
00295     DX::ThrowIfFailed(
00296         offscreenTexture.As(&dxgiSurface)
00297         );
00298
00299     // Create a D2D render target which can draw into our offscreen D3D
00300     // surface. Given that we use a constant size for the texture, we
00301     // fix the DPI at 96.
00302
00303     D2D1_BITMAP_PROPERTIES1 properties;
00304     properties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
00305     properties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
00306     properties.dpiX = 96;
00307     properties.dpiY = 96;
00308     properties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
00309     properties.colorContext = nullptr;
00310
00311     ComPtr<ID2D1Bitmap1> renderTarget;
00312     DX::ThrowIfFailed(
00313         m_d2dContext->CreateBitmapFromDxgiSurface(
00314             dxgiSurface.Get(),
00315             &properties,
00316             &renderTarget
00317             )
00318         );
00319
00320     m_d2dContext->SetTarget(renderTarget.Get());
00321     float saveDpiX;
00322     float saveDpiY;
00323
00324     m_d2dContext->GetDpi(&saveDpiX, &saveDpiY);
00325     m_d2dContext->SetDpi(96.0f, 96.0f);
00326
00327     m_d2dContext->BeginDraw();
00328     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00329
00330     D2D1_SIZE_F renderTargetSize = renderTarget->GetSize();
00331
00332     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Black));
00333     m_d2dContext->FillGeometry(m_circleGeometry5.Get(), m_yellowBrush.Get());
00334     m_d2dContext->FillGeometry(m_circleGeometry4.Get(), m_greenBrush.Get());
00335     m_d2dContext->FillGeometry(m_circleGeometry3.Get(), m_blueBrush.Get());
00336     m_d2dContext->FillGeometry(m_circleGeometry2.Get(), m_redBrush.Get());
00337     m_d2dContext->FillGeometry(m_circleGeometry1.Get(), m_whiteBrush.Get());
00338     m_d2dContext->DrawText(
00339         name->Data(),
00340         name->Length(),
00341         m_textFormat.Get(),
00342         D2D1::RectF(0, 0, renderTargetSize.width, renderTargetSize.height),
00343         m_blackBrush.Get()
00344         );
00345
00346     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00347     // is lost. It will be handled during the next call to Present.
00348     HRESULT hr = m_d2dContext->EndDraw();
00349     if (hr != D2DERR_RECREATE_TARGET)
00350     {
00351         DX::ThrowIfFailed(hr);
00352     }
00353
00354     m_d2dContext->SetTarget(nullptr);
00355     m_d2dContext->SetDpi(saveDpiX, saveDpiY);
00356
00357     *textureResourceView = texture.Detach();
00358 }
00359 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ManipulatableObject Member List

This is the complete list of members for ManipulatableObject, including all inherited members.
__pad0__ | ManipulatableObject |
__pad1__ | ManipulatableObject |
_mxManip | ManipulatableObject | [private]
_parent | ManipulatableObject | [private]
_ptInit | ManipulatableObject | [private]
Deserialize(_In_ Windows::Foundation::Collections::IPropertySet^properties) | ManipulatableObject | [virtual]
LimitManipulationScale(_In_ Windows::UI::Input::ManipulationDelta delta, _In_ float minScale, _In_ float maxScale) | ManipulatableObject |
LocalTransform() | ManipulatableObject | [inline]
ManipulationTransform() | ManipulatableObject | [inline]
Parent() | ManipulatableObject | [inline]
ParentTransform() | ManipulatableObject | [inline]
Serialize(_In_ Windows::Foundation::Collections::IPropertySet^properties) | ManipulatableObject | [virtual]
SetInitialPosition(_In_ D2D1_POINT_2F ptInit) | ManipulatableObject | [inline]
SetManipulationTransform(_In_ D2D1::Matrix3x2F mxManip) | ManipulatableObject | [inline]
SingleFingerRotation(_In_ Windows::UI::Input::GestureRecognizer^gestureRecognizer, _In_ Windows::Foundation::Point position, _In_ float pivotRadius) | ManipulatableObject |
UpdateManipulationTransform(_In_ Windows::UI::Input::ManipulationDelta delta, _In_ Windows::Foundation::Point position) | ManipulatableObject |
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Check if current session is remote/C++/App.xaml.h Source File

  • Check if current session is remote

App.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.h
00013 // Declaration of the App.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "App.g.h"
00020 #include "MainPage.g.h"
00021
00022 namespace SDKSample
00023 {
00024     ref class App
00025     {
00026     internal:
00027         App();
00028         virtual void OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs);
00029         Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs;
00030     protected:
00031         virtual void OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs) override;
00032     private:
00033         Windows::UI::Xaml::Controls::Frame^ rootFrame;
00034     };
00035 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CropImageView.xaml.cpp Source File

  • Hilo C++
  • Hilo

CropImageView.xaml.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "CropImageView.xaml.h"
00009 #include "CropImageViewModel.h"
00010
00011 using namespace Hilo;
00012 using namespace Platform;
00013 using namespace Windows::UI::Xaml;
00014 using namespace Windows::UI::Xaml::Controls::Primitives;
00015 using namespace Windows::UI::Xaml::Input;
00016
00017 // See http://go.microsoft.com/fwlink/?LinkId=267278 for info on how Hilo creates pages and navigates to pages.
00018
00019 CropImageView::CropImageView()
00020 {
00021     InitializeComponent();
00022     m_cropImageViewModel = static_cast<CropImageViewModel^>(DataContext);
00023     m_sizeChangedAttached = false;
00024 }
00025
00026 void CropImageView::OnSizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00027 {
00028     m_cropImageViewModel->CalculateInitialCropOverlayPosition(
00029         Photo->TransformToVisual(CropImageGrid),
00030         Photo->RenderSize.Width, Photo->RenderSize.Height);
00031
00032     if (!m_sizeChangedAttached)
00033     {
00034         SizeChanged += ref new SizeChangedEventHandler(this, &CropImageView::OnSizeChanged);
00035         m_sizeChangedAttached = true;
00036     }
00037 }
00038
00039 void CropImageView::OnThumbDragDelta(Object^ sender, DragDeltaEventArgs^ e)
00040 {
00041     if (!m_cropImageViewModel->InProgress)
00042     {
00043         m_cropImageViewModel->UpdateCropOverlayPostion(safe_cast<Thumb^>(sender),
00044             e->VerticalChange,
00045             e->HorizontalChange,
00046             CropOverlay->MinWidth, CropOverlay->MinHeight);
00047     }
00048 }
00049
00050 void CropImageView::OnCropRectangleTapped(Object^ sender, TappedRoutedEventArgs^ e)
00051 {
00052     if (!m_cropImageViewModel->InProgress)
00053     {
00054         m_cropImageViewModel->CropImageAsync(Photo->ActualWidth);
00055     }
00056 }
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CameraOptionsUI/C++/ShowOptionsUI.xaml.cpp Source File

  • CameraOptionsUI

ShowOptionsUI.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // ShowOptionsUI.xaml.cpp
00013 // Implementation of the ShowOptionsUI class
00014 //
00015
00016 #include "pch.h"
00017 #include "ShowOptionsUI.xaml.h"
00018
00019 using namespace SDKSample::CameraOptions;
00020
00021 using namespace Windows::UI::Core;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::Media;
00026 using namespace Windows::Media::Capture;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Devices::Enumeration;
00029
00030 ShowOptionsUI::ShowOptionsUI()
00031 {
00032     InitializeComponent();
00033     previewStarted = false;
00034     ShowSettings->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00035     mediaCaptureMgr = nullptr;
00036     dispatcher = Window::Current->Dispatcher;
00037     // Using the SoundLevelChanged event to determine when the app can stream from the webcam
00038     MediaControl::SoundLevelChanged += ref new EventHandler<Object^>(this, &ShowOptionsUI::MediaControl_SoundLevelChanged);
00039 }
00040
00041 /// <summary>
00042 /// Invoked when this page is about to be displayed in a Frame.
00043 /// </summary>
00044 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00045 /// property is typically used to configure the page.</param>
00046 void ShowOptionsUI::OnNavigatedTo(NavigationEventArgs^ e)
00047 {
00048     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00049     // as NotifyUser()
00050     rootPage = MainPage::Current;
00051 }
00052
00053 void SDKSample::CameraOptions::ShowOptionsUI::StartPreview_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00054 {
00055     // Check if the machine has a webcam
00056     concurrency::task<DeviceInformationCollection^>(DeviceInformation::FindAllAsync(DeviceClass::VideoCapture))
00057         .then([this](concurrency::task<DeviceInformationCollection^> getDevicesTask)
00058     {
00059         try
00060         {
00061             DeviceInformationCollection^ devices = getDevicesTask.get();
00062             if (devices->Size > 0)
00063             {
00064                 rootPage->NotifyUser("", NotifyType::ErrorMessage);
00065
00066                 if (mediaCaptureMgr == nullptr)
00067                 {
00068                     // Using Windows::Media::Capture::MediaCapture APIs to stream from Webcam
00069                     mediaCaptureMgr = ref new Windows::Media::Capture::MediaCapture();
00070
00071                     concurrency::task<void>(mediaCaptureMgr->InitializeAsync()).then([this] ()
00072                     {
00073                         VideoStream->Source = mediaCaptureMgr.Get();
00074                         return mediaCaptureMgr->StartPreviewAsync();
00075                     })
00076                         .then([this](concurrency::task<void> previewTask)
00077                     {
00078                         try
00079                         {
00080                             previewTask.get();
00081                             previewStarted = true;
00082                             ShowSettings->Visibility = Windows::UI::Xaml::Visibility::Visible;
00083                             StartPreview->IsEnabled = false;
00084                         }
00085                         catch (Platform::Exception^ ex)
00086                         {
00087                             mediaCaptureMgr = nullptr;
00088                             rootPage->NotifyUser(ex->Message, NotifyType::ErrorMessage);
00089                         }
00090                     });
00091                 }
00092             }
00093             else
00094             {
00095                 rootPage->NotifyUser("A webcam is required to run this sample.", NotifyType::ErrorMessage);
00096             }
00097         }
00098         catch (Platform::Exception^ ex)
00099         {
00100             mediaCaptureMgr = nullptr;
00101             rootPage->NotifyUser(ex->Message, NotifyType::ErrorMessage);
00102         }
00103     });
00104 }
00105
00106 void SDKSample::CameraOptions::ShowOptionsUI::ShowSettings_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00107 {
00108     try
00109     {
00110         if (mediaCaptureMgr.Get() != nullptr)
00111         {
00112             // Using Windows::Media::Capture::MediaCapture APIs to show webcam settings
00113             CameraOptionsUI::Show(mediaCaptureMgr.Get());
00114         }
00115     }
00116     catch (Platform::Exception^ ex)
00117     {
00118         rootPage->NotifyUser(ex->Message, NotifyType::ErrorMessage);
00119     }
00120 }
00121
00122 void SDKSample::CameraOptions::ShowOptionsUI::MediaControl_SoundLevelChanged(Object^ sender, Object^ e)
00123 {
00124     // The callbacks for MediaControl_SoundLevelChanged and StopPreviewAsync may be invoked on threads other
00125     // than the UI thread, so to ensure there's no synchronization issue, the Dispatcher is used here to
00126     // ensure all operations run on the UI thread.
00127     dispatcher->RunAsync(CoreDispatcherPriority::Normal, ref new DispatchedHandler([this] ()
00128     {
00129         if (MediaControl::SoundLevel == Windows::Media::SoundLevel::Muted)
00130         {
00131             if (previewStarted)
00132             {
00133                 concurrency::task<void>(mediaCaptureMgr->StopPreviewAsync()).then([this] ()
00134                 {
00135                     mediaCaptureMgr = nullptr;
00136                     previewStarted = false;
00137                     VideoStream->Source = nullptr;
00138                 });
00139             }
00140         }
00141         else
00142         {
00143             if (!previewStarted)
00144             {
00145                 ShowSettings->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00146                 StartPreview->IsEnabled = true;
00147             }
00148         }
00149     }));
00150 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/ThumbnailGenerator.cpp Source File

  • Hilo C++
  • Hilo

ThumbnailGenerator.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #include "pch.h"
00008 #include "ThumbnailGenerator.h"
00009 #include "ExceptionPolicy.h"
00010
00011 using namespace concurrency;
00012 using namespace std;
00013 using namespace Platform;
00014 using namespace Platform::Collections;
00015 using namespace Windows::Foundation::Collections;
00016 using namespace Windows::Graphics::Imaging;
00017 using namespace Windows::Storage;
00018 using namespace Windows::Storage::Streams;
00019 using namespace Windows::Storage::FileProperties;
00020
00021 using namespace Hilo;
00022
00023 // See http://go.microsoft.com/fwlink/?LinkId=267275 for info about Hilo's implementation of tiles.
00024
00025 const unsigned int ThumbnailSize = 270;
00026 const wstring ThumbnailImagePrefix = L"thumbImage_";
00027
00028 ThumbnailGenerator::ThumbnailGenerator(std::shared_ptr<ExceptionPolicy> policy) : m_exceptionPolicy(policy)
00029 {
00030 }
00031
00032 task<Vector<StorageFile^>^> ThumbnailGenerator::Generate(
00033     IVector<StorageFile^>^ files,
00034     StorageFolder^ thumbnailsFolder)
00035 {
00036     vector<task<StorageFile^>> thumbnailTasks;
00037
00038     unsigned int imageCounter = 0;
00039     for (auto imageFile : files)
00040     {
00041         wstringstream localFileName;
00042         localFileName << ThumbnailImagePrefix << imageCounter++ << ".jpg";
00043
00044         thumbnailTasks.push_back(
00045             CreateLocalThumbnailAsync(
00046             thumbnailsFolder,
00047             imageFile,
00048             ref new String(localFileName.str().c_str()),
00049             ThumbnailSize,
00050             m_exceptionPolicy));
00051     }
00052
00053     return when_all(begin(thumbnailTasks), end(thumbnailTasks)).then(
00054         [](vector<StorageFile^> files)
00055     {
00056         auto result = ref new Vector<StorageFile^>();
00057         for (auto file : files)
00058         {
00059             if (file != nullptr)
00060             {
00061                 result->Append(file);
00062             }
00063         }
00064
00065         return result;
00066     });
00067 }
00068
00069 task<StorageFile^> ThumbnailGenerator::CreateLocalThumbnailAsync(
00070     StorageFolder^ folder,
00071     StorageFile^ imageFile,
00072     String^ localFileName,
00073     unsigned int thumbSize,
00074     std::shared_ptr<ExceptionPolicy> exceptionPolicy)
00075 {
00076     auto createThumbnail = create_task(
00077         CreateThumbnailFromPictureFileAsync(imageFile, thumbSize));
00078
00079     return createThumbnail.then([exceptionPolicy, folder, localFileName](
00080         task<InMemoryRandomAccessStream^> createdThumbnailTask)
00081     {
00082         InMemoryRandomAccessStream^ createdThumbnail;
00083         try
00084         {
00085             createdThumbnail = createdThumbnailTask.get();
00086         }
00087         catch(Exception^ ex)
00088         {
00089             exceptionPolicy->HandleException(ex);
00090             // If we have any exceptions we won't return the results
00091             // of this task, but instead nullptr.  Downstream
00092             // tasks will need to account for this.
00093             return create_task_from_result<StorageFile^>(nullptr);
00094         }
00095
00096         return InternalSaveToFile(folder, createdThumbnail, localFileName);
00097     });
00098 }
00099
00100 task<StorageFile^> ThumbnailGenerator::InternalSaveToFile(
00101     StorageFolder^ thumbnailsFolder,
00102     InMemoryRandomAccessStream^ stream,
00103     Platform::String^ filename)
00104 {
00105     auto imageFile = make_shared<StorageFile^>(nullptr);
00106     auto streamReader = ref new DataReader(stream);
00107     auto loadStreamTask = create_task(
00108         streamReader->LoadAsync(static_cast<unsigned int>(stream->Size)));
00109
00110     return loadStreamTask.then(
00111         [thumbnailsFolder, filename](unsigned int loadedBytes)
00112     {
00113         (void)loadedBytes; // Unused parameter
00114
00115         return thumbnailsFolder->CreateFileAsync(
00116             filename,
00117             CreationCollisionOption::ReplaceExisting);
00118
00119     }).then([streamReader, imageFile](StorageFile^ thumbnailDestinationFile)
00120     {
00121         (*imageFile) = thumbnailDestinationFile;
00122         auto buffer = streamReader->ReadBuffer(
00123             streamReader->UnconsumedBufferLength);
00124
00125         return FileIO::WriteBufferAsync(thumbnailDestinationFile, buffer);
00126
00127     }).then([imageFile]()
00128     {
00129         return (*imageFile);
00130     });
00131 }
00132
00133 task<InMemoryRandomAccessStream^> ThumbnailGenerator::CreateThumbnailFromPictureFileAsync(
00134     StorageFile^ sourceFile,
00135     unsigned int thumbSize)
00136 {
00137     (void)thumbSize; // Unused parameter
00138     auto decoder = make_shared<BitmapDecoder^>(nullptr);
00139     auto pixelProvider = make_shared<PixelDataProvider^>(nullptr);
00140     auto resizedImageStream = ref new InMemoryRandomAccessStream();
00141     auto createThumbnail = create_task(
00142         sourceFile->GetThumbnailAsync(
00143         ThumbnailMode::PicturesView,
00144         ThumbnailSize));
00145
00146     return createThumbnail.then([](StorageItemThumbnail^ thumbnail)
00147     {
00148         IRandomAccessStream^ imageFileStream =
00149             static_cast<IRandomAccessStream^>(thumbnail);
00150
00151         return BitmapDecoder::CreateAsync(imageFileStream);
00152
00153     }).then([decoder](BitmapDecoder^ createdDecoder)
00154     {
00155         (*decoder) = createdDecoder;
00156         return createdDecoder->GetPixelDataAsync(
00157             BitmapPixelFormat::Rgba8,
00158             BitmapAlphaMode::Straight,
00159             ref new BitmapTransform(),
00160             ExifOrientationMode::IgnoreExifOrientation,
00161             ColorManagementMode::ColorManageToSRgb);
00162
00163     }).then([pixelProvider, resizedImageStream](PixelDataProvider^ provider)
00164     {
00165         (*pixelProvider) = provider;
00166         return BitmapEncoder::CreateAsync(
00167             BitmapEncoder::JpegEncoderId,
00168             resizedImageStream);
00169
00170     }).then([pixelProvider, decoder](BitmapEncoder^ createdEncoder)
00171     {
00172         createdEncoder->SetPixelData(BitmapPixelFormat::Rgba8,
00173             BitmapAlphaMode::Straight,
00174             (*decoder)->PixelWidth,
00175             (*decoder)->PixelHeight,
00176             (*decoder)->DpiX,
00177             (*decoder)->DpiY,
00178             (*pixelProvider)->DetachPixelData());
00179         return createdEncoder->FlushAsync();
00180
00181     }).then([resizedImageStream]
00182     {
00183         resizedImageStream->Seek(0);
00184         return resizedImageStream;
00185     });
00186 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StreamSocket/C++/Scenario3.xaml.cpp Source File

  • StreamSocket

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace StreamSocketSample;
00020
00021 using namespace Concurrency;
00022 using namespace Platform;
00023 using namespace Windows::ApplicationModel::Core;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Networking::Sockets;
00026 using namespace Windows::Storage::Streams;
00027 using namespace Windows::UI::Xaml;
00028 using namespace Windows::UI::Xaml::Controls;
00029 using namespace Windows::UI::Xaml::Navigation;
00030
00031 Scenario3::Scenario3()
00032 {
00033     InitializeComponent();
00034 }
00035
00036 /// <summary>
00037 /// Invoked when this page is about to be displayed in a Frame.
00038 /// </summary>
00039 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00040 /// property is typically used to configure the page.</param>
00041 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00042 {
00043     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00044     // as NotifyUser()
00045     rootPage = MainPage::Current;
00046 }
00047
00048
00049 void Scenario3::SendHello_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00050 {
00051     if (!CoreApplication::Properties->HasKey("connected"))
00052     {
00053         rootPage->NotifyUser("Please run previous steps before doing this one.", NotifyType::ErrorMessage);
00054         return;
00055     }
00056
00057     StreamSocket^ socket = dynamic_cast<StreamSocket^>(CoreApplication::Properties->Lookup("clientSocket"));
00058     DataWriter^ writer;
00059
00060     // If possible, use the DataWriter we created previously. If not, then create new one.
00061     if (!CoreApplication::Properties->HasKey("clientDataWriter"))
00062     {
00063         writer = ref new DataWriter(socket->OutputStream);
00064         CoreApplication::Properties->Insert("clientDataWriter", writer);
00065     }
00066     else
00067     {
00068         writer = dynamic_cast<DataWriter^>(CoreApplication::Properties->Lookup("clientDataWriter"));
00069     }
00070
00071     // Write first the length of the string a UINT32 value followed up by the string. The operation will just store the data locally.
00072     String^ stringToSend("Hello");
00073     writer->WriteUInt32(writer->MeasureString(stringToSend));
00074     writer->WriteString(stringToSend);
00075
00076     // Write the locally buffered data to the network.
00077     task<unsigned int>(writer->StoreAsync()).then([this, socket, stringToSend] (task<unsigned int> writeTask)
00078     {
00079         try
00080         {
00081             // Try getting an exception.
00082             writeTask.get();
00083             SendOutput->Style = dynamic_cast<Windows::UI::Xaml::Style^>(rootPage->Resources->Lookup("StatusStyle"));
00084             SendOutput->Text = "\"" + stringToSend + "\" sent successfully";
00085         }
00086         catch (Exception^ exception)
00087         {
00088             rootPage->NotifyUser("Send failed with error: " + exception->Message, NotifyType::ErrorMessage);
00089         }
00090     });
00091 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX marble maze game/C++/BasicShapes.h Source File

  • DirectX marble maze game

BasicShapes.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "BasicMath.h"
00011
00012 // Defines the vertex format for the shapes generated in the functions below.
00013 struct BasicVertex
00014 {
00015     float3 pos;  // position
00016     float3 norm; // surface normal vector
00017     float2 tex;  // texture coordinate
00018 };
00019
00020 // Defines the vertex format for all shapes generated in the functions below.
00021 struct TangentVertex
00022 {
00023     float3 pos;  // position
00024     float2 tex;  // texture coordinate
00025     float3 uTan; // texture coordinate u-tangent vector
00026     float3 vTan; // texture coordinate v-tangent vector
00027 };
00028
00029 // A helper class that provides convenient functions for creating common
00030 // geometrical shapes used by DirectX SDK samples.
00031 ref class BasicShapes
00032 {
00033 internal:
00034     BasicShapes(ID3D11Device *d3dDevice);
00035     void CreateCube(
00036         _Out_ ID3D11Buffer **vertexBuffer,
00037         _Out_ ID3D11Buffer **indexBuffer,
00038         _Out_opt_ unsigned int *vertexCount,
00039         _Out_opt_ unsigned int *indexCount
00040         );
00041     void CreateBox(
00042         float3 radii,
00043         _Out_ ID3D11Buffer **vertexBuffer,
00044         _Out_ ID3D11Buffer **indexBuffer,
00045         _Out_opt_ unsigned int *vertexCount,
00046         _Out_opt_ unsigned int *indexCount
00047         );
00048     void CreateSphere(
00049         _Out_ ID3D11Buffer **vertexBuffer,
00050         _Out_ ID3D11Buffer **indexBuffer,
00051         _Out_opt_ unsigned int *vertexCount,
00052         _Out_opt_ unsigned int *indexCount
00053         );
00054     void CreateTangentSphere(
00055         _Out_ ID3D11Buffer **vertexBuffer,
00056         _Out_ ID3D11Buffer **indexBuffer,
00057         _Out_opt_ unsigned int *vertexCount,
00058         _Out_opt_ unsigned int *indexCount
00059         );
00060     void CreateReferenceAxis(
00061         _Out_ ID3D11Buffer **vertexBuffer,
00062         _Out_ ID3D11Buffer **indexBuffer,
00063         _Out_opt_ unsigned int *vertexCount,
00064         _Out_opt_ unsigned int *indexCount
00065         );
00066
00067 private:
00068     Microsoft::WRL::ComPtr<ID3D11Device> m_d3dDevice;
00069
00070     void CreateVertexBuffer(
00071         _In_ unsigned int numVertices,
00072         _In_ BasicVertex *vertexData,
00073         _Out_ ID3D11Buffer **vertexBuffer
00074         );
00075
00076     void CreateIndexBuffer(
00077         _In_ unsigned int numIndices,
00078         _In_ unsigned short *indexData,
00079         _Out_ ID3D11Buffer **indexBuffer
00080         );
00081
00082     void CreateTangentVertexBuffer(
00083         _In_ unsigned int numVertices,
00084         _In_ TangentVertex *vertexData,
00085         _Out_ ID3D11Buffer **vertexBuffer
00086         );
00087
00088 };
Generated on Sat Nov 23 2024 16:08:10 for Win8-Examples by doxygen 1.7.1


Win8-Examples: AtomPub/C++/common/LayoutAwarePage.cpp Source File

  • AtomPub
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:30 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/common/suspensionmanager.h Source File

  • XAML two-dimensional transforms
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario6.xaml.cpp Source File

  • File picker

Scenario6.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.cpp
00013 // Implementation of the Scenario6 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario6.xaml.h"
00018
00019 using namespace SDKSample::FilePicker;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::Pickers;
00025 using namespace Windows::Storage::Provider;
00026 using namespace Windows::UI::Xaml;
00027 using namespace Windows::UI::Xaml::Controls;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::Globalization::DateTimeFormatting;
00030
00031 Scenario6::Scenario6()
00032 {
00033     InitializeComponent();
00034     rootPage = MainPage::Current;
00035     SaveFileButton->Click += ref new RoutedEventHandler(this, &Scenario6::SaveFileButton_Click);
00036     WriteFileButton->Click += ref new RoutedEventHandler(this, &Scenario6::WriteFileButton_Click);
00037 }
00038
00039 void Scenario6::SaveFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00040 {
00041     // Clear previous returned file name, if it exists, between iterations of this scenario
00042     rootPage->ResetScenarioOutput(OutputFileName);
00043     rootPage->ResetScenarioOutput(OutputFileContent);
00044
00045     if (rootPage->EnsureUnsnapped())
00046     {
00047         FileSavePicker^ savePicker = ref new FileSavePicker();
00048
00049         auto plainTextExtensions = ref new Platform::Collections::Vector<String^>();
00050         plainTextExtensions->Append(".txt");
00051         savePicker->FileTypeChoices->Insert("Plain Text", plainTextExtensions);
00052         savePicker->SuggestedFileName = "New Document";
00053
00054         create_task(savePicker->PickSaveFileAsync()).then([this](StorageFile^ file)
00055         {
00056             if (file != nullptr)
00057             {
00058                 fileToken = Windows::Storage::AccessCache::StorageApplicationPermissions::FutureAccessList->Add(file);
00059                 MainPage::Current->NotifyUser(L"Received file: " + file->Name, NotifyType::StatusMessage);
00060                 WriteFileButton->IsEnabled = true;
00061             }
00062             else
00063             {
00064                 MainPage::Current->NotifyUser("Operation cancelled.", NotifyType::StatusMessage);
00065             }
00066         });
00067     }
00068 }
00069
00070 void Scenario6::WriteFileButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00071 {
00072     if (fileToken != nullptr)
00073     {
00074         create_task(Windows::Storage::AccessCache::StorageApplicationPermissions::FutureAccessList->GetFileAsync(fileToken)).then([this](StorageFile^ file)
00075         {
00076             // Prevent updates to the remote version of the file until we finish making changes and call CompleteUpdatesAsync.
00077             CachedFileManager::DeferUpdates(file);
00078             // write to file
00079             Windows::Globalization::Calendar^ Calendar = ref new Windows::Globalization::Calendar;
00080             create_task(FileIO::AppendTextAsync(file, L"\nText Added @ " + DateTimeFormatter::LongTime->Format(Calendar->GetDateTime()))).then([this, file]()
00081             {
00082                 // Let Windows know that we're finished changing the file so the other app can update the remote version of the file.
00083                 // Completing updates may require Windows to ask for user input.
00084                 create_task(CachedFileManager::CompleteUpdatesAsync(file)).then([this, file](FileUpdateStatus status)
00085                 {
00086                     switch (status)
00087                     {
00088                     case FileUpdateStatus::Complete:
00089                         MainPage::Current->NotifyUser("File " + file->Name + " was saved.", NotifyType::StatusMessage);
00090                         OutputFileAsync(file);
00091                         break;
00092
00093                     case FileUpdateStatus::CompleteAndRenamed:
00094                         MainPage::Current->NotifyUser("File " + file->Name + " was renamed and saved.", NotifyType::StatusMessage);
00095                         Windows::Storage::AccessCache::StorageApplicationPermissions::FutureAccessList->AddOrReplace(fileToken, file);
00096                         OutputFileAsync(file);
00097                         break;
00098
00099                     default:
00100                         MainPage::Current->NotifyUser("File " + file->Name + " couldn't be saved.", NotifyType::StatusMessage);
00101                         break;
00102                     }
00103                 });
00104             });
00105         });
00106     }
00107 }
00108
00109 void Scenario6::OutputFileAsync(StorageFile^ file)
00110 {
00111     create_task(FileIO::ReadTextAsync(file)).then([this, file](String^ fileContent)
00112     {
00113         OutputFileName->Text = L"Received file: " + file->Name;
00114         OutputFileContent->Text = L"File content:\n" + fileContent;
00115     });
00116 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Message dialog/C++/CompletedCallback.xaml.cpp Source File

  • Message dialog

CompletedCallback.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // CompletedCallback.xaml.cpp
00013 // Implementation of the CompletedCallback class
00014 //
00015
00016 #include "pch.h"
00017 #include "CompletedCallback.xaml.h"
00018
00019 using namespace SDKSample::MessageDialogSample;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Foundation;
00024 using namespace Windows::UI::Popups;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 CompletedCallback::CompletedCallback()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 void CompletedCallback::OnNavigatedTo(NavigationEventArgs^ e)
00035 {
00036     rootPage = MainPage::Current;
00037 }
00038
00039 /// <summary>
00040 /// Click handler for the 'CompletedCallbackButton' button.
00041 /// Demonstrates the use of a message dialog with custom commands and using a completed callback instead of delegates.
00042 /// A message will be displayed indicating which command was invoked on the dialog.
00043 /// In this scenario, 'Install updates' is selected as the default choice.
00044 /// </summary>
00045 /// <param name="sender">The Object that caused this event to be fired.</param>
00046 /// <param name="e">State information and event data associated with the routed event.</param>
00047 void SDKSample::MessageDialogSample::CompletedCallback::CompletedCallbackButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049     // Create the message dialog and set its content and title
00050     auto messageDialog = ref new MessageDialog("New updates have been found for this program. Would you like to install the new updates?", "Updates available");
00051
00052     // Add the commands to the dialog, use ids for the commands instead of delegates
00053     messageDialog->Commands->Append(ref new UICommand("Don't install", nullptr, PropertyValue::CreateInt32(0)));
00054     messageDialog->Commands->Append(ref new UICommand("Install updates", nullptr, PropertyValue::CreateInt32(1)));
00055
00056     // Set the command that will be invoked by default
00057     messageDialog->DefaultCommandIndex = 1;
00058
00059     // Show the message dialog and retrieve the id of the chosen command
00060     create_task(messageDialog->ShowAsync()).then([this](IUICommand^ command)
00061     {
00062         if (command->Id != nullptr)
00063         {
00064             rootPage->NotifyUser("The '" + command->Label + "' (" +  command->Id + ") command has been selected.", NotifyType::StatusMessage);
00065         }
00066         else
00067         {
00068             rootPage->NotifyUser("The dialog has now been closed", NotifyType::StatusMessage);
00069         }
00070     });
00071 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/MainPage.xaml.cpp Source File

  • XAML AppBar control

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 //#include "GlobalPage.xaml.h"
00019 #include "App.xaml.h"
00020
00021 #include <collection.h>
00022
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::Foundation;
00026 using namespace Platform;
00027 using namespace AppBarControl;
00028 using namespace CppSamplesUtils;
00029 using namespace Windows::UI::Xaml::Navigation;
00030 using namespace Windows::UI::Xaml::Interop;
00031 using namespace Windows::Graphics::Display;
00032 using namespace Windows::UI::ViewManagement;
00033
00034
00035 MainPage^ MainPage::Current = nullptr;
00036
00037 MainPage::MainPage()
00038 {
00039     InitializeComponent();
00040
00041     // This frame is hidden, meaning it is never shown.  It is simply used to load
00042     // each scenario page and then pluck out the input and output sections and
00043     // place them into the UserControls on the main page.
00044     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00045     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00046     LayoutRoot->Children->Append(HiddenFrame);
00047
00048     // Populate the sample title from the constant in the GlobalVariables.cs file.
00049     SetFeatureName(FEATURE_NAME);
00050
00051     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00052     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00053   BottomAppBar->Loaded += ref new RoutedEventHandler(this, &MainPage::BottonAppBar_Loaded);
00054
00055     MainPage::Current = this;
00056     autoSizeInputSectionWhenSnapped = true;
00057 }
00058
00059 MainPage::~MainPage()
00060 {
00061 }
00062
00063 /// <summary>
00064 /// Invoked when this page is about to be displayed in a Frame.
00065 /// </summary>
00066 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00067 /// property is typically used to configure the page.</param>
00068 void MainPage::OnNavigatedTo(NavigationEventArgs^ e)
00069 {
00070     PopulateScenarios();
00071     InvalidateViewState();
00072 }
00073
00074 void MainPage::BottonAppBar_Loaded(Object^ sender, RoutedEventArgs^ e)
00075 {
00076   RegisterAppBarButtons();
00077 }
00078
00079 void MainPage::RegisterAppBarButtons()
00080 {
00081   Grid^ rootGrid = safe_cast<Grid^>(BottomAppBar->Content);
00082   for each (UIElement^ e in rootGrid->Children)
00083   {
00084     for each (UIElement^ c in ((StackPanel^)e)->Children)
00085     {
00086       if (c->GetType()->FullName == Button::typeid->FullName)
00087       {
00088         AppBarControl::Common::LayoutAwarePage::StartLayoutUpdates(c, nullptr);
00089       }
00090     }
00091   }
00092 }
00093
00094 /// <summary>
00095 /// We need to handle SizeChanged so that we can make the sample layout property
00096 /// in the various layouts.
00097 /// </summary>
00098 /// <param name="sender"></param>
00099 /// <param name="e"></param>
00100 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00101 {
00102     InvalidateSize();
00103     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00104     args->ViewState = ApplicationView::Value;
00105     MainPageResized(this, args);
00106
00107 }
00108
00109 void MainPage::InvalidateSize()
00110 {
00111     // Get the window width
00112     double windowWidth = this->ActualWidth;
00113
00114     if (windowWidth != 0.0)
00115     {
00116         // Get the width of the ListBox.
00117         double listBoxWidth = Scenarios->ActualWidth;
00118
00119         // Is the ListBox using any margins that we need to consider?
00120         double listBoxMarginLeft = Scenarios->Margin.Left;
00121         double listBoxMarginRight = Scenarios->Margin.Right;
00122
00123         // Figure out how much room is left after considering the list box width
00124         double availableWidth = windowWidth - listBoxWidth;
00125
00126         // Is the top most child using margins?
00127         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00128         double layoutRootMarginRight = ContentRoot->Margin.Right;
00129
00130         // We have different widths to use depending on the view state
00131         if (ApplicationView::Value != ApplicationViewState::Snapped)
00132         {
00133             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00134             // and the LayoutRoot's margins
00135             InputSection->Width = availableWidth -
00136                (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight);
00137         }
00138         else
00139         {
00140             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00141             if (autoSizeInputSectionWhenSnapped)
00142             {
00143                 InputSection->Width = windowWidth - (layoutRootMarginLeft + layoutRootMarginRight);
00144             }
00145         }
00146     }
00147     InvalidateViewState();
00148 }
00149
00150 void MainPage::InvalidateViewState()
00151 {
00152     // Are we going to snapped mode?
00153     if (ApplicationView::Value == ApplicationViewState::Snapped)
00154     {
00155         Grid::SetRow(DescriptionText, 3);
00156         Grid::SetColumn(DescriptionText, 0);
00157
00158         Grid::SetRow(InputSection, 4);
00159         Grid::SetColumn(InputSection, 0);
00160
00161         Grid::SetRow(FooterPanel, 2);
00162         Grid::SetColumn(FooterPanel, 0);
00163
00164     Grid::SetRow(RightPanel, 1);
00165     }
00166     else
00167     {
00168         Grid::SetRow(DescriptionText, 1);
00169         Grid::SetColumn(DescriptionText, 1);
00170
00171         Grid::SetRow(InputSection, 2);
00172         Grid::SetColumn(InputSection, 1);
00173
00174         Grid::SetRow(FooterPanel, 1);
00175         Grid::SetColumn(FooterPanel, 1);
00176
00177     Grid::SetRow(RightPanel, 0);
00178     Grid::SetColumn(RightPanel, 1);
00179     }
00180
00181 }
00182
00183 void MainPage::PopulateScenarios()
00184 {
00185     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00186
00187     // Populate the ListBox with the list of scenarios as defined in Constants.cs.
00188     for (unsigned int i = 0; i < scenarios->Length; ++i)
00189     {
00190         Scenario s = scenarios[i];
00191         ListBoxItem^ item = ref new ListBoxItem();
00192         item->Name = s.ClassName;
00193         item->Content = (i + 1).ToString() + ") " + s.Title;
00194         ScenarioList->Append(item);
00195     }
00196
00197     // Bind the ListBox to the scenario list.
00198     Scenarios->ItemsSource = ScenarioList;
00199
00200     // Starting scenario is the first or based upon a previous selection.
00201     ListBoxItem^ startingScenario = nullptr;
00202
00203     // Starting scenario is the first or based upon a previous selection.
00204     int startingScenarioIndex = -1;
00205
00206     auto ps = SuspensionManager::SessionState();
00207     if (ps->HasKey("SelectedScenarioIndex"))
00208     {
00209         int selectedScenarioIndex = safe_cast<int>(ps->Lookup("SelectedScenarioIndex"));
00210         startingScenarioIndex = selectedScenarioIndex;
00211     }
00212
00213     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00214 }
00215
00216 /// <summary>
00217 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00218 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00219 /// and output sections into the respective UserControl on the main page.
00220 /// </summary>
00221 /// <param name="scenarioName"></param>
00222 void MainPage::LoadScenario(String^ scenarioName)
00223 {
00224     autoSizeInputSectionWhenSnapped = true;
00225
00226     // LoTypeName scenarioType = {scenarioName, TypeKind::Custom};ad the ScenarioX.xaml file into the Frame.
00227     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00228     HiddenFrame->Navigate(scenarioType, this);
00229
00230     // Get the top element, the Page, so we can look up the elements
00231     // that represent the input and output sections of the ScenarioX file.
00232     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00233
00234     // Get each element.
00235     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00236     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00237
00238     if (input == nullptr)
00239     {
00240         // Malformed input section.
00241         NotifyUser("Cannot load scenario input section for " + scenarioName +
00242             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00243         return;
00244     }
00245
00246     if (output == nullptr)
00247     {
00248         // Malformed output section.
00249         NotifyUser("Cannot load scenario output section for " + scenarioName +
00250             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00251         return;
00252     }
00253     // Find the LayoutRoot which parents the input and output sections in the main page.
00254     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00255
00256     if (panel != nullptr)
00257     {
00258         unsigned int index = 0;
00259         UIElementCollection^ collection = panel->Children;
00260
00261         // Get rid of the content that is currently in the intput and output sections.
00262         collection->IndexOf(input, &index);
00263         collection->RemoveAt(index);
00264
00265         collection->IndexOf(output, &index);
00266         collection->RemoveAt(index);
00267
00268         // Populate the input and output sections with the newly loaded content.
00269         InputSection->Content = input;
00270         OutputSection->Content = output;
00271
00272         ScenarioLoaded(this, nullptr);
00273     }
00274     else
00275     {
00276         // Malformed Scenario file.
00277         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00278             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00279     }
00280 }
00281
00282 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00283 {
00284     if (Scenarios->SelectedItem != nullptr)
00285     {
00286         NotifyUser("", NotifyType::StatusMessage);
00287
00288         int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00289         SuspensionManager::SessionState()->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00290
00291         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00292         InvalidateSize();
00293     }
00294 }
00295
00296 void MainPage::SetFeatureName(String^ strFeature)
00297 {
00298   FeatureName->Text = strFeature;
00299 }
00300
00301 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00302 {
00303     switch (type)
00304     {
00305     case NotifyType::StatusMessage:
00306         // Use the status message style.
00307         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00308         break;
00309     case NotifyType::ErrorMessage:
00310         // Use the error message style.
00311         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00312         break;
00313     default:
00314         break;
00315     }
00316     StatusBlock->Text = strMessage;
00317
00318     // Collapsed the StatusBlock if it has no text to conserve real estate.
00319     if (StatusBlock->Text != "")
00320     {
00321         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00322     }
00323     else
00324     {
00325         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00326     }
00327 }
00328
00329 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00330 {
00331     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00332     Windows::System::Launcher::LaunchUriAsync(uri);
00333 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Raw notifications/C++/MainAppSample/ScenarioOutput2.xaml.h Source File

  • Raw notifications
  • MainAppSample

ScenarioOutput2.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Scenario1Output.xaml.h
00010 // Declaration of the Scenario1Output class
00011 //
00012
00013 #pragma once
00014
00015 #include "pch.h"
00016 #include "ScenarioOutput2.g.h"
00017 #include "MainPage.xaml.h"
00018
00019 namespace RawNotificationsSampleCPP
00020 {
00021   public ref class ScenarioOutput2 sealed
00022   {
00023   public:
00024     ScenarioOutput2();
00025   private:
00026     ~ScenarioOutput2();
00027   };
00028 }
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DeviceAppForPrinters::Scenario Member List

This is the complete list of members for DeviceAppForPrinters::Scenario, including all inherited members.
ClassName | DeviceAppForPrinters::Scenario
Title | DeviceAppForPrinters::Scenario
Generated on Sat Nov 23 2024 16:09:37 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/pch.cpp Source File

  • XAML data binding

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

Extruder::ExtrudingSink::Vertex2D Member List

This is the complete list of members for Extruder::ExtrudingSink::Vertex2D, including all inherited members.
interpNorm1 | Extruder::ExtrudingSink::Vertex2D
interpNorm2 | Extruder::ExtrudingSink::Vertex2D
norm | Extruder::ExtrudingSink::Vertex2D
pt | Extruder::ExtrudingSink::Vertex2D
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: OrientationSensor/C++/pch.h Source File

  • OrientationSensor

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/Scenario2_GetPosition.xaml.cpp Source File

  • Geolocation

Scenario2_GetPosition.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario2_GetPosition.xaml.cpp
00013 // Implementation of the Scenario2 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario2_GetPosition.xaml.h"
00018
00019 using namespace SDKSample::GeolocationCPP;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::Devices::Geolocation;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::UI::Core;
00027 using namespace Platform;
00028 using namespace concurrency;
00029
00030 Scenario2::Scenario2() : rootPage(MainPage::Current)
00031 {
00032     InitializeComponent();
00033
00034     geolocator = ref new Geolocator();
00035 }
00036
00037 /// <summary>
00038 /// Invoked when this page is about to be displayed in a Frame.
00039 /// </summary>
00040 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00041 /// property is typically used to configure the page.</param>
00042 void Scenario2::OnNavigatedTo(NavigationEventArgs^ e)
00043 {
00044     GetGeolocationButton->IsEnabled = true;
00045     CancelGetGeolocationButton->IsEnabled = false;
00046 }
00047
00048 /// <summary>
00049 /// Invoked when this page is no longer displayed.
00050 /// </summary>
00051 /// <param name="e"></param>
00052 void Scenario2::OnNavigatedFrom(NavigationEventArgs^ e)
00053 {
00054     if (CancelGetGeolocationButton->IsEnabled)
00055     {
00056         geopositionTaskTokenSource.cancel();
00057     }
00058 }
00059
00060 void Scenario2::GetGeolocation(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00061 {
00062     rootPage->NotifyUser("Waiting for update...", NotifyType::StatusMessage);
00063
00064     GetGeolocationButton->IsEnabled = false;
00065     CancelGetGeolocationButton->IsEnabled = true;
00066
00067     task<Geoposition^> geopositionTask(geolocator->GetGeopositionAsync(), geopositionTaskTokenSource.get_token());
00068     geopositionTask.then([this](task<Geoposition^> getPosTask)
00069     {
00070         try
00071         {
00072             // Get will throw an exception if the task was canceled or failed with an error
00073             Geoposition^ pos = getPosTask.get();
00074
00075             rootPage->NotifyUser("Updated", NotifyType::StatusMessage);
00076
00077             ScenarioOutput_Latitude->Text = pos->Coordinate->Latitude.ToString();
00078             ScenarioOutput_Longitude->Text = pos->Coordinate->Longitude.ToString();
00079             ScenarioOutput_Accuracy->Text = pos->Coordinate->Accuracy.ToString();
00080         }
00081         catch (AccessDeniedException^)
00082         {
00083             rootPage->NotifyUser("Disabled", NotifyType::ErrorMessage);
00084
00085             // Clear cached location data if any
00086             ScenarioOutput_Latitude->Text = "No data";
00087             ScenarioOutput_Longitude->Text = "No data";
00088             ScenarioOutput_Accuracy->Text = "No data";
00089         }
00090         catch (task_canceled&)
00091         {
00092             rootPage->NotifyUser("Operation canceled", NotifyType::StatusMessage);
00093         }
00094
00095         GetGeolocationButton->IsEnabled = true;
00096         CancelGetGeolocationButton->IsEnabled = false;
00097     });
00098 }
00099
00100 void Scenario2::CancelGetGeolocation(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00101 {
00102     geopositionTaskTokenSource.cancel();
00103
00104     GetGeolocationButton->IsEnabled = true;
00105     CancelGetGeolocationButton->IsEnabled = false;
00106 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML AppBar control/C++/GlobalPage.xaml.h Source File

  • XAML AppBar control

GlobalPage.xaml.h

Go to the documentation of this file.
00001 ﻿//
00002 // GlobalPage.xaml.h
00003 // Declaration of the GlobalPage class
00004 //
00005
00006 #pragma once
00007
00008 #include "pch.h"
00009 #include "MainPage.xaml.h"
00010 #include "GlobalPage.g.h"
00011
00012 namespace AppBarControl
00013 {
00014   /// <summary>
00015   /// An empty page that can be used on its own or navigated to within a Frame.
00016   /// </summary>
00017   [Windows::Foundation::Metadata::WebHostHidden]
00018   public ref class GlobalPage sealed
00019   {
00020   public:
00021     GlobalPage();
00022
00023   protected:
00024     virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00025
00026   private:
00027     void Back_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00028
00029   //internal:
00030         static MainPage^ rootPage;
00031   };
00032
00033
00034 }
Generated on Sat Nov 23 2024 16:08:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Geolocation/C++/MainPage.xaml.cpp Source File

  • Geolocation

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:42 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Device capabilities/C++/common/suspensionmanager.cpp Source File

  • Input Device capabilities
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupAdvancedSearch.xaml.h Source File

  • HomeGroup app

HomeGroupAdvancedSearch.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // HomeGroupAdvancedSearch.xaml.h
00013 // Declaration of the HomeGroupAdvancedSearch class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "HomeGroupAdvancedSearch.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace HomeGroup
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class HomeGroupAdvancedSearch sealed
00031         {
00032         public:
00033             HomeGroupAdvancedSearch();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             void SetButtons();
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Manipulations and gestures (C++)/C++/ManipulatableObject.h Source File

  • Input Manipulations and gestures (C++)
  • C++

ManipulatableObject.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #pragma once
00009
00010 interface class IRenderer
00011 {
00012     virtual void RequestRedraw() = 0;
00013     virtual Windows::Foundation::Size ViewSize() = 0;
00014 };
00015
00016 ref class ManipulatableObject
00017 {
00018 internal:
00019     ManipulatableObject(_In_opt_ ManipulatableObject^ parent);
00020
00021 public:
00022
00023     ManipulatableObject^ Parent() { return _parent; }
00024
00025     // Manipulation update calculations.
00026     // Handle single finger rotation. Returns modified position.
00027     Windows::Foundation::Point SingleFingerRotation(
00028         _In_ Windows::UI::Input::GestureRecognizer^ gestureRecognizer,
00029         _In_ Windows::Foundation::Point position,
00030         _In_ float pivotRadius);
00031     // Limits total manipulation scale to range [min, max]. 0.0f disables min or max limit.
00032     // Returns modified manipulation delta.
00033     Windows::UI::Input::ManipulationDelta LimitManipulationScale(
00034         _In_ Windows::UI::Input::ManipulationDelta delta,
00035         _In_ float minScale,
00036         _In_ float maxScale);
00037     // Update manipulation transform, given manipulation delta and position in parent coordinate system.
00038     void UpdateManipulationTransform(
00039         _In_ Windows::UI::Input::ManipulationDelta delta,
00040         _In_ Windows::Foundation::Point position);
00041
00042     // Serialization/deserialization
00043     virtual void Serialize(_In_ Windows::Foundation::Collections::IPropertySet^ properties);
00044     virtual void Deserialize(_In_ Windows::Foundation::Collections::IPropertySet^ properties);
00045
00046 internal:
00047     // Local to client(global) coordinate system transform
00048     // This transform includes all transforms in the object parent chain
00049     virtual D2D1::Matrix3x2F Transform() { return LocalTransform() * ParentTransform(); }
00050
00051     // Components of the transform.
00052     // Local transform, transforms from this object's intrinsic coordinate system to parent coordinate system.
00053     D2D1::Matrix3x2F LocalTransform() { return D2D1::Matrix3x2F::Translation(_ptInit.x, _ptInit.y) * _mxManip; }
00054     // Parent transform, transforms from parent coordinate system to client(global) coordinate system.
00055     D2D1::Matrix3x2F ParentTransform() { return _parent ? _parent->Transform() : D2D1::Matrix3x2F::Identity(); }
00056
00057     // Components of the local transform.
00058     void SetInitialPosition(_In_ D2D1_POINT_2F ptInit) { _ptInit = ptInit; }
00059     void SetManipulationTransform(_In_ D2D1::Matrix3x2F mxManip) { _mxManip = mxManip; }
00060     D2D1::Matrix3x2F ManipulationTransform() { return _mxManip; }
00061
00062 private:
00063     ManipulatableObject^ _parent;   // parent object
00064     D2D1::Matrix3x2F _mxManip;      // manipulation transform
00065     D2D1_POINT_2F _ptInit;          // initial position
00066 };
00067
00068 ref class ManipulatableObjectTransform sealed : public Windows::UI::Input::IPointerPointTransform
00069 {
00070 public:
00071     ManipulatableObjectTransform(_In_opt_ ManipulatableObject^ referentObject);
00072
00073     virtual bool TryTransform(_In_ Windows::Foundation::Point inPoint, _Out_ Windows::Foundation::Point* outPoint);
00074     virtual Windows::Foundation::Rect TransformBounds(_In_ Windows::Foundation::Rect rect);
00075     virtual property Windows::UI::Input::IPointerPointTransform^ Inverse { Windows::UI::Input::IPointerPointTransform^ get(); }
00076
00077 private:
00078     void SetMatrix(D2D1::Matrix3x2F matrix) { _matrix = matrix; }
00079
00080     D2D1::Matrix3x2F _matrix; // client (global) to object parent coordinate system transform
00081 };
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Direct2D lighting effects/C++/DirectXBase.h Source File

  • XAML Direct2D lighting effects

DirectXBase.h

Go to the documentation of this file.
00001     //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "DirectXSample.h"
00011
00012 // Helper class that initializes DirectX APIs for both 2D and 3D rendering.
00013 // Some of the code in this class may be omitted if only 2D or only 3D rendering is being used.
00014 ref class DirectXBase abstract
00015 {
00016 internal:
00017     DirectXBase();
00018
00019     virtual void Initialize(
00020         Windows::UI::Core::CoreWindow^ window,
00021         Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^ swapChainPanel,
00022         float dpi
00023         );
00024
00025     virtual void HandleDeviceLost();
00026     virtual void CreateDeviceIndependentResources();
00027     virtual void CreateDeviceResources();
00028     virtual void SetDpi(float dpi);
00029     virtual void UpdateForWindowSizeChange();
00030     virtual void CreateWindowSizeDependentResources();
00031     virtual void Render() = 0;
00032     virtual void Present();
00033     void ValidateDevice();
00034
00035 protected private:
00036     Windows::UI::Xaml::Controls::SwapChainBackgroundPanel^  m_swapChainPanel;
00037     Platform::Agile<Windows::UI::Core::CoreWindow>          m_window;
00038
00039     // DirectWrite & Windows Imaging Component Objects.
00040     Microsoft::WRL::ComPtr<IDWriteFactory1>         m_dwriteFactory;
00041     Microsoft::WRL::ComPtr<IWICImagingFactory2>     m_wicFactory;
00042
00043     // DirectX Core Objects. Required for 2D and 3D.
00044     Microsoft::WRL::ComPtr<ID3D11Device1>           m_d3dDevice;
00045     Microsoft::WRL::ComPtr<ID3D11DeviceContext1>    m_d3dContext;
00046     Microsoft::WRL::ComPtr<IDXGISwapChain1>         m_swapChain;
00047     Microsoft::WRL::ComPtr<ID3D11RenderTargetView>  m_d3dRenderTargetView;
00048
00049     // Direct2D Rendering Objects. Required for 2D.
00050     Microsoft::WRL::ComPtr<ID2D1Factory1>           m_d2dFactory;
00051     Microsoft::WRL::ComPtr<ID2D1Device>             m_d2dDevice;
00052     Microsoft::WRL::ComPtr<ID2D1DeviceContext>      m_d2dContext;
00053     Microsoft::WRL::ComPtr<ID2D1Bitmap1>            m_d2dTargetBitmap;
00054
00055     // Direct3D Rendering Objects. Required for 3D.
00056     Microsoft::WRL::ComPtr<ID3D11DepthStencilView>  m_d3dDepthStencilView;
00057
00058     // Cached renderer properties.
00059     D3D_FEATURE_LEVEL                               m_featureLevel;
00060     Windows::Foundation::Size                       m_renderTargetSize;
00061     Windows::Foundation::Rect                       m_windowBounds;
00062     float                                           m_dpi;
00063 };
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Bing Maps Trip Optimizer/C++,JavaScript/cpp/HttpRequest.cpp Source File

  • Bing Maps Trip Optimizer
  • C++,JavaScript
  • cpp

HttpRequest.cpp

Go to the documentation of this file.
00001 //-----------------------------------------------------------------------
00002 //
00003 //  Copyright (C) Microsoft Corporation.  All rights reserved.
00004 //
00005 //
00006 // THIS CODE AND INFORMATION ARE PROVIDED AS-IS WITHOUT WARRANTY OF ANY
00007 // KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO THE
00008 // IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //-----------------------------------------------------------------------
00011 #include "pch.h"
00012 #include "HttpRequest.h"
00013 #include <robuffer.h>
00014 #include <shcore.h>
00015
00016 using namespace concurrency;
00017 using namespace Microsoft::WRL;
00018 using namespace Platform;
00019 using namespace std;
00020 using namespace Web;
00021 using namespace Windows::Foundation;
00022 using namespace Windows::Storage::Streams;
00023
00024 // Implementation of IXMLHTTPRequest2Callback used when only the complete response is needed.
00025 // When processing chunks of response data as they are received, use HttpRequestBuffersCallback instead.
00026 class HttpRequestStringCallback
00027     : public RuntimeClass<RuntimeClassFlags<ClassicCom>, IXMLHTTPRequest2Callback, FtmBase>
00028 {
00029 public:
00030     HttpRequestStringCallback(IXMLHTTPRequest2* httpRequest,
00031         cancellation_token ct = concurrency::cancellation_token::none()) :
00032         request(httpRequest), cancellationToken(ct)
00033     {
00034         // Register a callback function that aborts the HTTP operation when
00035         // the cancellation token is canceled.
00036         if (cancellationToken != cancellation_token::none())
00037         {
00038             registrationToken = cancellationToken.register_callback([this]()
00039             {
00040                 if (request != nullptr)
00041                 {
00042                     request->Abort();
00043                 }
00044             });
00045         }
00046     }
00047
00048     // Called when the HTTP request is being redirected to a new URL.
00049     IFACEMETHODIMP OnRedirect(IXMLHTTPRequest2*, PCWSTR)
00050     {
00051         return S_OK;
00052     }
00053
00054     // Called when HTTP headers have been received and processed.
00055     IFACEMETHODIMP OnHeadersAvailable(IXMLHTTPRequest2*, DWORD statusCode, PCWSTR reasonPhrase)
00056     {
00057         HRESULT hr = S_OK;
00058
00059         // We must not propagate exceptions back to IXHR2.
00060         try
00061         {
00062             this->statusCode = statusCode;
00063             this->reasonPhrase = reasonPhrase;
00064         }
00065         catch (std::bad_alloc&)
00066         {
00067             hr = E_OUTOFMEMORY;
00068         }
00069
00070         return hr;
00071     }
00072
00073     // Called when a portion of the entity body has been received.
00074     IFACEMETHODIMP OnDataAvailable(IXMLHTTPRequest2*, ISequentialStream*)
00075     {
00076         return S_OK;
00077     }
00078
00079     // Called when the entire entity response has been received.
00080     IFACEMETHODIMP OnResponseReceived(IXMLHTTPRequest2*, ISequentialStream* responseStream)
00081     {
00082         wstring wstr;
00083         HRESULT hr = ReadUtf8StringFromSequentialStream(responseStream, wstr);
00084
00085         // We must not propagate exceptions back to IXHR2.
00086         try
00087         {
00088             completionEvent.set(make_tuple<HRESULT, wstring>(move(hr), move(wstr)));
00089         }
00090         catch (std::bad_alloc&)
00091         {
00092             hr = E_OUTOFMEMORY;
00093         }
00094
00095         return hr;
00096     }
00097
00098     // Simulate the functionality of DataReader.ReadString().
00099     // This is needed because DataReader requires IRandomAccessStream and this
00100     // code has an ISequentialStream that does not have a conversion to IRandomAccessStream like IStream does.
00101     HRESULT ReadUtf8StringFromSequentialStream(ISequentialStream* readStream, wstring& str)
00102     {
00103         // Convert the response to Unicode wstring.
00104         HRESULT hr;
00105
00106         // Holds the response as a Unicode string.
00107         wstringstream ss;
00108
00109         while (true)
00110         {
00111             ULONG cb;
00112             char buffer[4096];
00113
00114             // Read the response as a UTF-8 string.  Since UTF-8 characters are 1-4 bytes long,
00115             // we need to make sure we only read an integral number of characters.  So we'll
00116             // start with 4093 bytes.
00117             hr = readStream->Read(buffer, sizeof(buffer) - 3, &cb);
00118             if (FAILED(hr) || (cb == 0))
00119             {
00120                 break; // Error or no more data to process, exit loop.
00121             }
00122
00123             if (cb == sizeof(buffer) - 3)
00124             {
00125                 ULONG subsequentBytesRead;
00126                 unsigned int i, cl;
00127
00128                 // Find the first byte of the last UTF-8 character in the buffer.
00129                 for (i = cb - 1; (i >= 0) && ((buffer[i] & 0xC0) == 0x80); i--);
00130
00131                 // Calculate the number of subsequent bytes in the UTF-8 character.
00132                 if (((unsigned char)buffer[i]) < 0x80)
00133                 {
00134                     cl = 1;
00135                 }
00136                 else if (((unsigned char)buffer[i]) < 0xE0)
00137                 {
00138                     cl = 2;
00139                 }
00140                 else if (((unsigned char)buffer[i]) < 0xF0)
00141                 {
00142                     cl = 3;
00143                 }
00144                 else
00145                 {
00146                     cl = 4;
00147                 }
00148
00149                 // Read any remaining bytes.
00150                 if (cb < i + cl)
00151                 {
00152                     hr = readStream->Read(buffer + cb, i + cl - cb, &subsequentBytesRead);
00153                     if (FAILED(hr))
00154                     {
00155                         break; // Error, exit loop.
00156                     }
00157                     cb += subsequentBytesRead;
00158                 }
00159             }
00160
00161             // First determine the size required to store the Unicode string.
00162             int const sizeRequired = MultiByteToWideChar(CP_UTF8, 0, buffer, cb, nullptr, 0);
00163             if (sizeRequired == 0)
00164             {
00165                 // Invalid UTF-8.
00166                 hr = HRESULT_FROM_WIN32(GetLastError());
00167                 break;
00168             }
00169             unique_ptr<char16[]> wstr(new(std::nothrow) char16[sizeRequired + 1]);
00170             if (wstr.get() == nullptr)
00171             {
00172                 hr = E_OUTOFMEMORY;
00173                 break;
00174             }
00175
00176             // Convert the string from UTF-8 to UTF-16LE.  This can never fail, since
00177             // the previous call above succeeded.
00178             MultiByteToWideChar(CP_UTF8, 0, buffer, cb, wstr.get(), sizeRequired);
00179             wstr[sizeRequired] = L'\0'; // Terminate the string.
00180             ss << wstr.get(); // Write the string to the stream.
00181         }
00182
00183         str = SUCCEEDED(hr) ? ss.str() : wstring();
00184         return (SUCCEEDED(hr)) ? S_OK : hr; // Don't return S_FALSE.
00185     }
00186
00187     // Called when an error occurs during the HTTP request.
00188     IFACEMETHODIMP OnError(IXMLHTTPRequest2*, HRESULT hrError)
00189     {
00190         HRESULT hr = S_OK;
00191
00192         // We must not propagate exceptions back to IXHR2.
00193         try
00194         {
00195             completionEvent.set(make_tuple<HRESULT, wstring>(move(hrError), wstring()));
00196         }
00197         catch (std::bad_alloc&)
00198         {
00199             hr = E_OUTOFMEMORY;
00200         }
00201
00202         return hr;
00203     }
00204
00205     // Retrieves the completion event for the HTTP operation.
00206     task_completion_event<tuple<HRESULT, wstring>> const& GetCompletionEvent() const
00207     {
00208         return completionEvent;
00209     }
00210
00211     int GetStatusCode() const
00212     {
00213         return statusCode;
00214     }
00215
00216     wstring GetReasonPhrase() const
00217     {
00218         return reasonPhrase;
00219     }
00220
00221 private:
00222     ~HttpRequestStringCallback()
00223     {
00224         // Unregister the callback.
00225         if (cancellationToken != cancellation_token::none())
00226         {
00227             cancellationToken.deregister_callback(registrationToken);
00228         }
00229     }
00230
00231     // Signals that the download operation was canceled.
00232     cancellation_token cancellationToken;
00233
00234     // Used to unregister the cancellation token callback.
00235     cancellation_token_registration registrationToken;
00236
00237     // The IXMLHTTPRequest2 that processes the HTTP request.
00238     ComPtr<IXMLHTTPRequest2> request;
00239
00240     // Task completion event that is set when the
00241     // download operation completes.
00242     task_completion_event<tuple<HRESULT, wstring>> completionEvent;
00243
00244     int statusCode;
00245     wstring reasonPhrase;
00246 };
00247
00248 // Copy bytes from the sequential stream into the buffer provided until
00249 // we reach the end of one or the other.
00250 unsigned int Web::Details::HttpRequestBuffersCallback::ReadData(
00251     _Out_writes_(outputBufferSize) byte* outputBuffer,
00252     unsigned int outputBufferSize)
00253 {
00254     // Lock the data event while doing the read, to ensure that any bytes we don't read will
00255     // result in the correct event getting triggered.
00256     concurrency::critical_section::scoped_lock lock(dataEventLock);
00257
00258     ULONG bytesRead;
00259     CheckHResult(dataStream.Get()->Read(outputBuffer, outputBufferSize, &bytesRead));
00260     if (bytesRead < outputBufferSize)
00261     {
00262         // We need to reset the data event, which we can only do by creating a new one.
00263         dataEvent = task_completion_event<void>();
00264     }
00265
00266     return bytesRead;
00267 }
00268
00269 // Create a task that completes when data is available, in an exception-safe way.
00270 task<void> Web::Details::HttpRequestBuffersCallback::CreateDataTask()
00271 {
00272     concurrency::critical_section::scoped_lock lock(dataEventLock);
00273     return create_task(dataEvent, cancellationToken);
00274 }
00275
00276 HttpRequest::HttpRequest() : responseComplete(true), statusCode(200)
00277 {
00278 }
00279
00280 // Start a download of the specified URI using the specified method.  The returned task produces the
00281 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00282 task<wstring> HttpRequest::DownloadAsync(PCWSTR httpMethod, PCWSTR uri, cancellation_token cancellationToken,
00283     PCWSTR contentType, IStream* postStream, uint64 postStreamSizeToSend)
00284 {
00285     // Create an IXMLHTTPRequest2 object.
00286     ComPtr<IXMLHTTPRequest2> xhr;
00287     CheckHResult(CoCreateInstance(CLSID_XmlHttpRequest, nullptr, CLSCTX_INPROC, IID_PPV_ARGS(&xhr)));
00288
00289     // Create callback.
00290     auto stringCallback = Make<HttpRequestStringCallback>(xhr.Get(), cancellationToken);
00291     CheckHResult(stringCallback ? S_OK : E_OUTOFMEMORY);
00292
00293     auto completionTask = create_task(stringCallback->GetCompletionEvent());
00294
00295     // Create a request.
00296     CheckHResult(xhr->Open(httpMethod, uri, stringCallback.Get(), nullptr, nullptr, nullptr, nullptr));
00297
00298     if (postStream != nullptr && contentType != nullptr)
00299     {
00300         CheckHResult(xhr->SetRequestHeader(L"Content-Type", contentType));
00301     }
00302
00303     // Send the request.
00304     CheckHResult(xhr->Send(postStream, postStreamSizeToSend));
00305
00306     // Return a task that completes when the HTTP operation completes.
00307     // We pass the callback to the continuation because the lifetime of the
00308     // callback must exceed the operation to ensure that cancellation
00309     // works correctly.
00310     return completionTask.then([this, stringCallback](tuple<HRESULT, wstring> resultTuple)
00311     {
00312         // If the GET operation failed, throw an Exception.
00313         CheckHResult(std::get<0>(resultTuple));
00314
00315         statusCode = stringCallback->GetStatusCode();
00316         reasonPhrase = stringCallback->GetReasonPhrase();
00317
00318         return std::get<1>(resultTuple);
00319     });
00320 }
00321
00322 // Start an HTTP GET on the specified URI.  The returned task completes once the entire response
00323 // has been received, and the task produces the HTTP response text.  The status code and reason
00324 // can be read with GetStatusCode() and GetReasonPhrase().
00325 task<wstring> HttpRequest::GetAsync(Uri^ uri, cancellation_token cancellationToken)
00326 {
00327     return DownloadAsync(L"GET",
00328                          uri->AbsoluteUri->Data(),
00329                          cancellationToken,
00330                          nullptr,
00331                          nullptr,
00332                          0);
00333 }
00334
00335 void HttpRequest::CreateMemoryStream(IStream **stream)
00336 {
00337     auto randomAccessStream = ref new Windows::Storage::Streams::InMemoryRandomAccessStream();
00338     CheckHResult(CreateStreamOverRandomAccessStream(randomAccessStream, IID_PPV_ARGS(stream)));
00339 }
00340
00341 // Start an HTTP POST on the specified URI, using a string body.  The returned task produces the
00342 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00343 task<wstring> HttpRequest::PostAsync(Uri^ uri, const wstring& body, cancellation_token cancellationToken)
00344 {
00345     int length = 0;
00346     ComPtr<IStream> postStream;
00347     CreateMemoryStream(&postStream);
00348
00349     if (body.length() > 0)
00350     {
00351         // Get the required buffer size.
00352         int size = WideCharToMultiByte(CP_UTF8,                         // UTF-8
00353                                        0,                               // Conversion type
00354                                        body.c_str(),                    // Unicode string to convert
00355                                        static_cast<int>(body.length()), // Size
00356                                        nullptr,                         // Output buffer
00357                                        0,                               // Output buffer size
00358                                        nullptr,
00359                                        nullptr);
00360         CheckHResult((size != 0) ? S_OK : HRESULT_FROM_WIN32(GetLastError()));
00361
00362         std::unique_ptr<char[]> tempData(new char[size]);
00363         length = WideCharToMultiByte(CP_UTF8,                         // UTF-8
00364                                      0,                               // Conversion type
00365                                      body.c_str(),                    // Unicode string to convert
00366                                      static_cast<int>(body.length()), // Size
00367                                      tempData.get(),                  // Output buffer
00368                                      size,                            // Output buffer size
00369                                      nullptr,
00370                                      nullptr);
00371         CheckHResult((length != 0) ? S_OK : HRESULT_FROM_WIN32(GetLastError()));
00372         CheckHResult(postStream->Write(tempData.get(), length, nullptr));
00373     }
00374
00375     return DownloadAsync(L"POST",
00376                          uri->AbsoluteUri->Data(),
00377                          cancellationToken,
00378                          L"text/plain;charset=utf-8",
00379                          postStream.Get(),
00380                          length);
00381 }
00382
00383 // Start an HTTP POST on the specified URI, using a stream body.  The returned task produces the
00384 // HTTP response text.  The status code and reason can be read with GetStatusCode() and GetReasonPhrase().
00385 task<wstring> HttpRequest::PostAsync(Uri^ uri, PCWSTR contentType, IStream* postStream,
00386     uint64 postStreamSizeToSend, cancellation_token cancellationToken)
00387 {
00388     return DownloadAsync(L"POST",
00389                          uri->AbsoluteUri->Data(),
00390                          cancellationToken,
00391                          contentType,
00392                          postStream,
00393                          postStreamSizeToSend);
00394 }
00395
00396 // Send a request but don't return the response.  Instead, let the caller read it with ReadAsync().
00397 task<void> HttpRequest::SendAsync(const wstring& httpMethod, Uri^ uri, cancellation_token cancellationToken)
00398 {
00399     // Create an IXMLHTTPRequest2 object.
00400     ComPtr<IXMLHTTPRequest2> xhr;
00401     CheckHResult(CoCreateInstance(CLSID_XmlHttpRequest, nullptr, CLSCTX_INPROC, IID_PPV_ARGS(&xhr)));
00402
00403     // Create callback.
00404     buffersCallback = Make<Web::Details::HttpRequestBuffersCallback>(xhr.Get(), cancellationToken);
00405     CheckHResult(buffersCallback ? S_OK : E_OUTOFMEMORY);
00406
00407     ComPtr<IXMLHTTPRequest2Callback> xhrCallback;
00408     CheckHResult(buffersCallback.As(&xhrCallback));
00409
00410     // Open and send the request.
00411     CheckHResult(xhr->Open(httpMethod.c_str(),
00412                            uri->AbsoluteUri->Data(),
00413                            xhrCallback.Get(),
00414                            nullptr,
00415                            nullptr,
00416                            nullptr,
00417                            nullptr));
00418
00419     responseComplete = false;
00420
00421     CheckHResult(xhr->Send(nullptr, 0));
00422
00423     // Return a task that completes when the HTTP operation completes.
00424     // Since buffersCallback holds a reference on the callback, the lifetime of the callback will exceed
00425     // the operation and ensure that cancellation works correctly.
00426     return buffersCallback->CreateDataTask().then([this]()
00427     {
00428         CheckHResult(buffersCallback->GetError());
00429
00430         statusCode = buffersCallback->GetStatusCode();
00431         reasonPhrase = buffersCallback->GetReasonPhrase();
00432     });
00433 }
00434
00435 // Read a chunk of data from the HTTP response, up to a specified length or until we reach the end
00436 // of the response, and store the value in the provided buffer.  This is useful for large content,
00437 // enabling the streaming of the result.
00438 task<void> HttpRequest::ReadAsync(Windows::Storage::Streams::IBuffer^ readBuffer, unsigned int offsetInBuffer,
00439     unsigned int requestedBytesToRead)
00440 {
00441     if (offsetInBuffer + requestedBytesToRead > readBuffer->Capacity)
00442     {
00443         throw ref new InvalidArgumentException();
00444     }
00445
00446     // Return a task that completes when a read completes.
00447     // We pass the callback to the continuation because the lifetime of the
00448     // callback must exceed the operation to ensure that cancellation
00449     // works correctly.
00450     return buffersCallback->CreateDataTask().then([this, readBuffer, offsetInBuffer, requestedBytesToRead]()
00451     {
00452         CheckHResult(buffersCallback->GetError());
00453
00454         // Get a pointer to the location to copy data into.
00455         ComPtr<IBufferByteAccess> bufferByteAccess;
00456         CheckHResult(reinterpret_cast<IUnknown*>(readBuffer)->QueryInterface(IID_PPV_ARGS(&bufferByteAccess)));
00457         byte* outputBuffer; // Returned internal pointer, do not free this value.
00458         CheckHResult(bufferByteAccess->Buffer(&outputBuffer));
00459
00460         // Copy bytes from the sequential stream into the buffer provided until
00461         // we reach the end of one or the other.
00462         readBuffer->Length = buffersCallback->ReadData(outputBuffer + offsetInBuffer, requestedBytesToRead);
00463         if (buffersCallback->IsResponseReceived() && (readBuffer->Length < requestedBytesToRead))
00464         {
00465             responseComplete = true;
00466         }
00467     });
00468 }
Generated on Sat Nov 23 2024 16:07:58 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Scaling according to DPI/C++/common/LayoutAwarePage.h Source File

  • Scaling according to DPI
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C#,C++/DLL/WUDFOsrUsbPublic.h Source File

  • Custom driver access
  • C#,C++
  • DLL

WUDFOsrUsbPublic.h

Go to the documentation of this file.
00001 /*++
00002
00003 Copyright (c) Microsoft Corporation, All Rights Reserved
00004
00005 Module Name:
00006
00007     WUDFOsrUsbPublic.h
00008
00009 Abstract:
00010
00011     This module contains the common declarations shared by driver
00012     and user applications for the UMDF OSR device sample.
00013
00014     Note that this driver does NOT use the same device interface GUID
00015     as the KMDF OSR USB sample.
00016
00017 Environment:
00018
00019     user and kernel
00020
00021 --*/
00022
00023 #pragma once
00024
00025 //
00026 // Define an Interface Guid so that app can find the device and talk to it.
00027 //
00028
00029 // {573E8C73-0CB4-4471-A1BF-FAB26C31D384}
00030 DEFINE_GUID(GUID_DEVINTERFACE_OSRUSBFX2,
00031             0x573e8c73, 0xcb4, 0x4471, 0xa1, 0xbf, 0xfa, 0xb2, 0x6c, 0x31, 0xd3, 0x84);
00032
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D perspective transform/C++/pch.cpp Source File

  • Direct2D perspective transform

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D HLSL fractal generator/C++/pch.cpp Source File

  • Direct3D HLSL fractal generator

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Custom driver access/C++/DLL/public.h Source File

  • Custom driver access
  • DLL

public.h

Go to the documentation of this file.
00001 /*++
00002
00003 Copyright (c) Microsoft Corporation.  All rights reserved.
00004
00005 Module Name:
00006
00007     public.h
00008
00009 Abstract:
00010
00011     Public definitions for the OSR_FX2 device operations.
00012
00013 Environment:
00014
00015     User & Kernel mode
00016
00017 --*/
00018
00019 #ifndef _PUBLIC_H
00020 #define _PUBLIC_H
00021
00022 #include <initguid.h>
00023
00024 #include "WudfOsrUsbPublic.h"
00025
00026
00027 //
00028 // Define the structures that will be used by the IOCTL
00029 //  interface to the driver
00030 //
00031
00032 //
00033 // BAR_GRAPH_STATE
00034 //
00035 // BAR_GRAPH_STATE is a bit field structure with each
00036 //  bit corresponding to one of the bar graph on the
00037 //  OSRFX2 Development Board
00038 //
00039 #include <pshpack1.h>
00040
00041 #pragma warning( push )
00042 #pragma warning( disable : 4201 ) // nameless struct/union
00043 #pragma warning( disable : 4214 ) // bit-field type other than int
00044
00045 typedef struct _BAR_GRAPH_STATE {
00046
00047     union {
00048
00049         struct {
00050             //
00051             // Individual bars starting from the
00052             //  top of the stack of bars
00053             //
00054             // NOTE: There are actually 10 bars,
00055             //  but the very top two do not light
00056             //  and are not counted here
00057             //
00058             UCHAR Bar1 : 1;
00059             UCHAR Bar2 : 1;
00060             UCHAR Bar3 : 1;
00061             UCHAR Bar4 : 1;
00062             UCHAR Bar5 : 1;
00063             UCHAR Bar6 : 1;
00064             UCHAR Bar7 : 1;
00065             UCHAR Bar8 : 1;
00066         };
00067
00068         //
00069         // The state of all the bar graph as a single
00070         // UCHAR
00071         //
00072         UCHAR BarsAsUChar;
00073
00074     };
00075
00076 }BAR_GRAPH_STATE, *PBAR_GRAPH_STATE;
00077
00078 //
00079 // SWITCH_STATE
00080 //
00081 // SWITCH_STATE is a bit field structure with each
00082 //  bit corresponding to one of the switches on the
00083 //  OSRFX2 Development Board
00084 //
00085 typedef struct _SWITCH_STATE {
00086
00087     union {
00088         struct {
00089             //
00090             // Individual switches starting from the
00091             //  left of the set of switches
00092             //
00093             UCHAR Switch1 : 1;
00094             UCHAR Switch2 : 1;
00095             UCHAR Switch3 : 1;
00096             UCHAR Switch4 : 1;
00097             UCHAR Switch5 : 1;
00098             UCHAR Switch6 : 1;
00099             UCHAR Switch7 : 1;
00100             UCHAR Switch8 : 1;
00101         };
00102
00103         //
00104         // The state of all the switches as a single
00105         // UCHAR
00106         //
00107         UCHAR SwitchesAsUChar;
00108
00109     };
00110
00111
00112 }SWITCH_STATE, *PSWITCH_STATE;
00113
00114 //
00115 // Seven segment display bit values.
00116 //
00117
00118 //
00119 // Undefine conflicting MFC constant
00120 //
00121 #undef SS_CENTER
00122 #undef SS_LEFT
00123 #undef SS_RIGHT
00124
00125 #define SS_TOP          0x01
00126 #define SS_TOP_LEFT     0x40
00127 #define SS_TOP_RIGHT    0x02
00128 #define SS_CENTER       0x20
00129 #define SS_BOTTOM_LEFT  0x10
00130 #define SS_BOTTOM_RIGHT 0x04
00131 #define SS_BOTTOM       0x80
00132 #define SS_DOT          0x08
00133
00134 //
00135 // FILE_PLAYBACK
00136 //
00137 // FILE_PLAYBACK structure contains the parameters for the PLAY_FILE I/O Control.
00138 //
00139
00140 typedef struct _FILE_PLAYBACK
00141 {
00142     //
00143     // The delay between changes in the display, in milliseconds.
00144     //
00145
00146     USHORT Delay;
00147
00148     //
00149     // The data file path.
00150     //
00151
00152     WCHAR Path[1];
00153 } FILE_PLAYBACK, *PFILE_PLAYBACK;
00154
00155 #include <poppack.h>
00156
00157 #define IOCTL_INDEX             0x800
00158 #define FILE_DEVICE_OSRUSBFX2   0x65500
00159
00160 #define IOCTL_OSRUSBFX2_GET_CONFIG_DESCRIPTOR CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
00161                                                      IOCTL_INDEX,     \
00162                                                      METHOD_BUFFERED,         \
00163                                                      FILE_READ_ACCESS)
00164
00165 #define IOCTL_OSRUSBFX2_RESET_DEVICE  CTL_CODE(FILE_DEVICE_OSRUSBFX2,     \
00166                                                      IOCTL_INDEX + 1, \
00167                                                      METHOD_BUFFERED,         \
00168                                                      FILE_WRITE_ACCESS)
00169
00170 #define IOCTL_OSRUSBFX2_REENUMERATE_DEVICE  CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00171                                                     IOCTL_INDEX  + 3,  \
00172                                                     METHOD_BUFFERED, \
00173                                                     FILE_WRITE_ACCESS)
00174
00175 #define IOCTL_OSRUSBFX2_GET_BAR_GRAPH_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00176                                                     IOCTL_INDEX  + 4, \
00177                                                     METHOD_BUFFERED, \
00178                                                     FILE_READ_ACCESS)
00179
00180
00181 #define IOCTL_OSRUSBFX2_SET_BAR_GRAPH_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00182                                                     IOCTL_INDEX + 5, \
00183                                                     METHOD_BUFFERED, \
00184                                                     FILE_WRITE_ACCESS)
00185
00186
00187 #define IOCTL_OSRUSBFX2_READ_SWITCHES   CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00188                                                     IOCTL_INDEX + 6, \
00189                                                     METHOD_BUFFERED, \
00190                                                     FILE_READ_ACCESS)
00191
00192
00193 #define IOCTL_OSRUSBFX2_GET_7_SEGMENT_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00194                                                     IOCTL_INDEX + 7, \
00195                                                     METHOD_BUFFERED, \
00196                                                     FILE_READ_ACCESS)
00197
00198
00199 #define IOCTL_OSRUSBFX2_SET_7_SEGMENT_DISPLAY CTL_CODE(FILE_DEVICE_OSRUSBFX2, \
00200                                                     IOCTL_INDEX + 8, \
00201                                                     METHOD_BUFFERED, \
00202                                                     FILE_WRITE_ACCESS)
00203
00204 #define IOCTL_OSRUSBFX2_GET_INTERRUPT_MESSAGE CTL_CODE(FILE_DEVICE_OSRUSBFX2,\
00205                                                     IOCTL_INDEX + 9, \
00206                                                     METHOD_OUT_DIRECT, \
00207                                                     FILE_READ_ACCESS)
00208
00209 #define IOCTL_OSRUSBFX2_PLAY_FILE CTL_CODE(FILE_DEVICE_OSRUSBFX2,   \
00210                                            IOCTL_INDEX + 10,        \
00211                                            METHOD_BUFFERED,         \
00212                                            FILE_WRITE_ACCESS)
00213
00214 #pragma warning(pop)
00215
00216 #endif
00217
Generated on Sat Nov 23 2024 16:08:01 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/App.xaml.cpp Source File

  • Language font mapping

App.xaml.cpp

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // App.xaml.cpp
00010 // Implementation of the App.xaml class.
00011 //
00012
00013 #include "pch.h"
00014 #include "App.xaml.h"
00015 #include "MainPage.xaml.h"
00016
00017 using namespace Windows::UI::Xaml;
00018 using namespace Windows::UI::Xaml::Controls;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::ApplicationModel;
00021 using namespace Windows::ApplicationModel::Activation;
00022 using namespace CppSamplesUtils;
00023 using namespace LanguageFontCPP;
00024 using namespace Windows::UI::Xaml::Interop;
00025
00026 App::App()
00027 {
00028     InitializeComponent();
00029     this->Suspending += ref new SuspendingEventHandler(this, &LanguageFontCPP::App::OnSuspending);
00030 }
00031
00032
00033 void App::OnSuspending(Platform::Object^ sender, Windows::ApplicationModel::SuspendingEventArgs^ pArgs)
00034 {
00035     auto deferral = pArgs->SuspendingOperation->GetDeferral();
00036     SuspensionManager::StartSaveTask().then([=]() {
00037         deferral->Complete();
00038     });
00039 }
00040
00041 void App::OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ pArgs)
00042 {
00043     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00044     {
00045         SuspensionManager::StartRestoreTask().then([=]() {
00046             Window::Current->Content = ref new MainPage();
00047             Window::Current->Activate();
00048         });
00049     }
00050     else
00051     {
00052         auto rootFrame = ref new Frame();
00053         TypeName pageType = { "LanguageFontCPP.MainPage", TypeKind::Custom };
00054         rootFrame->Navigate(pageType);
00055         Window::Current->Content = rootFrame;
00056         Window::Current->Activate();
00057     }
00058 }
00059
Generated on Sat Nov 23 2024 16:07:27 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/common/LayoutAwarePage.h Source File

  • XAML images
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animated text/C++/pch.cpp Source File

  • Direct2D animated text

pch.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

LineSegment Member List

This is the complete list of members for LineSegment, including all inherited members.
length | LineSegment
position | LineSegment
uLength | LineSegment
uStart | LineSegment
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/Extruder.h Source File

  • DirectX postcard app

Extruder.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "PointSnapper.h"
00011
00012 // The vertex class taken from the Win7 sample and used by Extrude.
00013 struct SimpleVertex
00014 {
00015     float3 Pos;
00016     float3 Norm;
00017 };
00018
00019 class Extruder
00020 {
00021 public:
00022     static void ExtrudeGeometry(
00023         ID2D1Geometry* pGeometry,
00024         float height,
00025         std::vector<SimpleVertex>* vertices
00026         );
00027
00028 private:
00029     static void D2DFlatten(ID2D1Geometry* pGeometry, float flatteningTolerance, ID2D1Geometry** ppGeometry);
00030     static void D2DOutline(ID2D1Geometry* pGeometry, ID2D1Geometry** ppGeometry);
00031
00032     class ExtrudingSink : public ID2D1SimplifiedGeometrySink, public ID2D1TessellationSink
00033     {
00034     public:
00035         static void CreateExtrudingSink(
00036             float height,
00037             _In_ std::vector<SimpleVertex>* pVertices,
00038             _Outptr_ ExtrudingSink** ppExtrudingSink
00039             );
00040
00041         // ID2D1SimplifiedGeometrySink and ID2D1TessellationSink methods.
00042         STDMETHOD_(void, AddBeziers)(const D2D1_BEZIER_SEGMENT* /*beziers*/, UINT /*beziersCount*/);
00043         STDMETHOD_(void, AddLines)(const D2D1_POINT_2F* points, UINT pointsCount);
00044         STDMETHOD_(void, BeginFigure)(D2D1_POINT_2F startPoint, D2D1_FIGURE_BEGIN /*figureBegin*/);
00045         STDMETHOD(Close)();
00046         STDMETHOD_(void, EndFigure)(D2D1_FIGURE_END /*figureEnd*/);
00047         STDMETHOD_(void, SetFillMode)(D2D1_FILL_MODE /*fillMode*/);
00048         STDMETHOD_(void, SetSegmentFlags)(D2D1_PATH_SEGMENT /*vertexFlags*/);
00049         STDMETHOD_(void, AddTriangles)(const D2D1_TRIANGLE* triangles, UINT trianglesCount);
00050
00051         // IUknown methods.
00052         STDMETHOD(QueryInterface)(REFIID riid, _Outptr_ void** object) override;
00053         STDMETHOD_(ULONG, AddRef)() override;
00054         STDMETHOD_(ULONG, Release)() override;
00055
00056     private:
00057         // Private constructor used by CreateExtrudingSink method.
00058         ExtrudingSink(float height, _In_ std::vector<SimpleVertex>* pVertices);
00059
00060         float2 GetNormal(uint32 i);
00061         float2 Normalize(float2 pt);
00062
00063         struct Vertex2D
00064         {
00065             float2 pt;
00066             float2 norm;
00067             float2 interpNorm1;
00068             float2 interpNorm2;
00069         };
00070
00071         float m_height;
00072         D2D1_POINT_2F m_lastPoint;
00073         D2D1_POINT_2F m_startPoint;
00074
00075         std::vector<SimpleVertex>* m_vertices;
00076         std::vector<Vertex2D> m_figureVertices;
00077
00078         ULONG m_ref;    // Reference count for AddRef and Release.
00079     };
00080 };
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: StorageDataSource and GetVirtualizedFilesVector/C++/Constants.h Source File

  • StorageDataSource and GetVirtualizedFilesVector

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"GetVirtualizedFilesVector C++ sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041
00042     private:
00043         static Platform::Array<Scenario>^ scenariosInner;
00044     };
00045 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/Scenario8.xaml.h Source File

  • XAML data binding

Scenario8.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario8.xaml.h
00013 // Declaration of the Scenario8 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario8.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "Employee.h"
00022
00023 namespace SDKSample
00024 {
00025     namespace DataBinding
00026     {
00027         /// <summary>
00028         /// An empty page that can be used on its own or navigated to within a Frame.
00029         /// </summary>
00030       [Windows::Foundation::Metadata::WebHostHidden]
00031         public ref class Scenario8 sealed
00032         {
00033         public:
00034             Scenario8();
00035         property Teams^ _observableTeams;
00036
00037         protected:
00038         void Scenario8Reset(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00039         void BindableVectorChanged(Windows::UI::Xaml::Interop::IBindableObservableVector^ sender, Object^ e);
00040
00041         private:
00042             MainPage^ rootPage;
00043         GeneratorIncrementalLoadingClass^ employees;
00044         Windows::Foundation::EventRegistrationToken vectorChangedHandlerToken;
00045
00046         };
00047     }
00048 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::MainPage Member List

This is the complete list of members for SDKSample::MainPage, including all inherited members.
_placeholder | SDKSample::MainPage | [private]
audioExtensionsInner | SDKSample::MainPage | [private, static]
autoplayFileSystemDeviceFolder | SDKSample::MainPage |
autoplayNonFileSystemDeviceId | SDKSample::MainPage |
autoplayScenarioIndex | SDKSample::MainPage | [static]
channel | SDKSample::MainPage |
ConvertIndexToColor(int index) | SDKSample::MainPage | [inline, static]
DisplayResult(Windows::UI::Xaml::Controls::Image^image, Windows::UI::Xaml::Controls::TextBlock^textBlock, Platform::String^thumbnailModeName, size_t size, Windows::Storage::IStorageItem^item, Windows::Storage::FileProperties::StorageItemThumbnail^thumbnail, bool isGroup) | SDKSample::MainPage | [static]
EnsureUnsnapped() | SDKSample::MainPage | [static]
falToken | SDKSample::MainPage | [private]
fileActivationFiles | SDKSample::MainPage |
GetPlaceHolderImage() | SDKSample::MainPage | [private]
HandleFileNotFoundException(Platform::COMException^e) | SDKSample::MainPage |
Initialize() | SDKSample::MainPage | [private]
mruToken | SDKSample::MainPage | [private]
notifier | SDKSample::MainPage |
NotifyUserFileNotExist() | SDKSample::MainPage |
PickPlaylist() | SDKSample::MainPage | [static]
playlistExtensionsInner | SDKSample::MainPage | [private, static]
playlistInner | SDKSample::MainPage | [private, static]
ReplaceUrlSearchTerms(Platform::String^strUrl, Platform::String^queryText) | SDKSample::MainPage | [static]
ResetOutput(Windows::UI::Xaml::Controls::Image^image, Windows::UI::Xaml::Controls::TextBlock^output, Windows::UI::Xaml::Controls::TextBlock^outputDetails) | SDKSample::MainPage |
ResetScenarioOutput(Windows::UI::Xaml::Controls::TextBlock^textblock) | SDKSample::MainPage |
sampleFile | SDKSample::MainPage | [private]
scenariosInner | SDKSample::MainPage | [private, static]
scenariosInner | SDKSample::MainPage | [private, static]
SearchPaneMaxSuggestions | SDKSample::MainPage | [static]
token | SDKSample::MainPage |
ValidateFile(Platform::String^scenarioName) | SDKSample::MainPage | [private]
Generated on Sat Nov 23 2024 16:09:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct3D-Direct2D interop/C++/TextInterop.cpp Source File

  • Direct3D-Direct2D interop

TextInterop.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "TextInterop.h"
00010 #include "BasicShapes.h"
00011 #include "BasicLoader.h"
00012
00013 using namespace Microsoft::WRL;
00014 using namespace Platform;
00015 using namespace Windows::Foundation;
00016 using namespace Windows::UI::Core;
00017
00018 TextInterop::TextInterop()
00019 {
00020 }
00021
00022 void TextInterop::CreateDeviceIndependentResources()
00023 {
00024     DirectXBase::CreateDeviceIndependentResources();
00025 }
00026
00027 void TextInterop::CreateDeviceResources()
00028 {
00029     DirectXBase::CreateDeviceResources();
00030
00031     m_sampleOverlay = ref new SampleOverlay();
00032
00033     String^ title = "Direct3D-Direct2D interop sample";
00034
00035     m_sampleOverlay->Initialize(
00036         m_d2dDevice.Get(),
00037         m_d2dContext.Get(),
00038         m_wicFactory.Get(),
00039         m_dwriteFactory.Get(),
00040         title
00041         );
00042
00043     BasicLoader^ loader = ref new BasicLoader(m_d3dDevice.Get());
00044
00045     loader->LoadShader(
00046         L"SimpleVertexShader.cso",
00047         nullptr,
00048         0,
00049         &m_vertexShader,
00050         &m_inputLayout
00051         );
00052
00053     // create the vertex and index buffers for drawing the cube
00054
00055     BasicShapes^ shapes = ref new BasicShapes(m_d3dDevice.Get());
00056
00057     shapes->CreateCube(
00058         &m_vertexBuffer,
00059         &m_indexBuffer,
00060         nullptr,
00061         &m_indexCount
00062         );
00063
00064     // create the constant buffer for updating model and camera data
00065     CD3D11_BUFFER_DESC constantBufferDescription(sizeof(ConstantBuffer), D3D11_BIND_CONSTANT_BUFFER);
00066     DX::ThrowIfFailed(
00067         m_d3dDevice->CreateBuffer(
00068             &constantBufferDescription,
00069             nullptr,             // leave the buffer uninitialized
00070             &m_constantBuffer
00071             )
00072         );
00073
00074     loader->LoadShader(
00075         L"SimplePixelShader.cso",
00076         &m_pixelShader
00077         );
00078
00079     // Create a Direct3D texture and view, which will be used to texture a spinning cube.
00080
00081     CD3D11_TEXTURE2D_DESC textureDesc(
00082         DXGI_FORMAT_B8G8R8A8_UNORM,
00083         512,        // Width
00084         512,        // Height
00085         1,          // MipLevels
00086         1,          // ArraySize
00087         D3D11_BIND_SHADER_RESOURCE | D3D11_BIND_RENDER_TARGET
00088         );
00089
00090     DX::ThrowIfFailed(
00091         m_d3dDevice->CreateTexture2D(
00092             &textureDesc,
00093             nullptr,
00094             &m_texture
00095             )
00096         );
00097
00098     CD3D11_SHADER_RESOURCE_VIEW_DESC shaderResourceViewDesc(
00099         m_texture.Get(),
00100         D3D11_SRV_DIMENSION_TEXTURE2D
00101         );
00102
00103     DX::ThrowIfFailed(
00104         m_d3dDevice->CreateShaderResourceView(
00105             m_texture.Get(),
00106             &shaderResourceViewDesc,
00107             &m_textureShaderResourceView
00108             )
00109         );
00110
00111     // Use D2D to attach to and draw some text to the cube texture.  Note that the cube
00112     // texture is DPI-independent, so when drawing content to it using D2D, a fixed DPI
00113     // value should be used.
00114
00115     const float dxgiDpi = 96.0f;
00116
00117     m_d2dContext->SetDpi(dxgiDpi, dxgiDpi);
00118
00119     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00120         D2D1::BitmapProperties1(
00121             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00122             D2D1::PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00123             dxgiDpi,
00124             dxgiDpi
00125             );
00126
00127     ComPtr<ID2D1Bitmap1> cubeTextureTarget;
00128     ComPtr<IDXGISurface> cubeTextureSurface;
00129     DX::ThrowIfFailed(
00130         m_texture.As(&cubeTextureSurface)
00131         );
00132
00133     DX::ThrowIfFailed(
00134         m_d2dContext->CreateBitmapFromDxgiSurface(
00135             cubeTextureSurface.Get(),
00136             &bitmapProperties,
00137             &cubeTextureTarget
00138             )
00139         );
00140
00141     m_d2dContext->SetTarget(cubeTextureTarget.Get());
00142
00143     ComPtr<ID2D1SolidColorBrush> whiteBrush;
00144     DX::ThrowIfFailed(
00145         m_d2dContext->CreateSolidColorBrush(
00146             D2D1::ColorF(D2D1::ColorF::White),
00147             &whiteBrush
00148             )
00149         );
00150
00151     D2D1_SIZE_F renderTargetSize = m_d2dContext->GetSize();
00152
00153     m_d2dContext->BeginDraw();
00154
00155     m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00156
00157     m_d2dContext->Clear(D2D1::ColorF(D2D1::ColorF::Red));
00158
00159     ComPtr<IDWriteTextFormat> textFormat;
00160
00161     DX::ThrowIfFailed(
00162         m_dwriteFactory->CreateTextFormat(
00163             L"Verdana",
00164             nullptr,
00165             DWRITE_FONT_WEIGHT_LIGHT,
00166             DWRITE_FONT_STYLE_NORMAL,
00167             DWRITE_FONT_STRETCH_NORMAL,
00168             52,
00169             L"en-US", // locale
00170             &textFormat
00171             )
00172         );
00173
00174     // Center the text horizontally.
00175     DX::ThrowIfFailed(
00176         textFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_CENTER)
00177         );
00178
00179     // Center the text vertically.
00180     DX::ThrowIfFailed(
00181         textFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_CENTER)
00182         );
00183
00184     m_d2dContext->DrawText(
00185         title->Data(),
00186         title->Length(),
00187         textFormat.Get(),
00188         D2D1::RectF(0.0f, 0.0f, renderTargetSize.width, renderTargetSize.height),
00189         whiteBrush.Get()
00190         );
00191
00192     // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00193     // is lost. It will be handled during the next call to Present.
00194     HRESULT hr = m_d2dContext->EndDraw();
00195     if (hr != D2DERR_RECREATE_TARGET)
00196     {
00197         DX::ThrowIfFailed(hr);
00198     }
00199
00200     // create the sampler
00201     D3D11_SAMPLER_DESC samplerDescription;
00202     ZeroMemory(&samplerDescription, sizeof(D3D11_SAMPLER_DESC));
00203     samplerDescription.Filter = D3D11_FILTER_ANISOTROPIC;
00204     samplerDescription.AddressU = D3D11_TEXTURE_ADDRESS_WRAP;
00205     samplerDescription.AddressV = D3D11_TEXTURE_ADDRESS_WRAP;
00206     samplerDescription.AddressW = D3D11_TEXTURE_ADDRESS_WRAP;
00207     samplerDescription.MipLODBias = 0.0f;
00208     samplerDescription.MaxAnisotropy = m_featureLevel > D3D_FEATURE_LEVEL_9_1 ? 4 : 2;
00209     samplerDescription.ComparisonFunc = D3D11_COMPARISON_NEVER;
00210     samplerDescription.BorderColor[0] = 0.0f;
00211     samplerDescription.BorderColor[1] = 0.0f;
00212     samplerDescription.BorderColor[2] = 0.0f;
00213     samplerDescription.BorderColor[3] = 0.0f;
00214     // allow use of all mip levels
00215     samplerDescription.MinLOD = 0;
00216     samplerDescription.MaxLOD = D3D11_FLOAT32_MAX;
00217
00218     DX::ThrowIfFailed(
00219         m_d3dDevice->CreateSamplerState(
00220             &samplerDescription,
00221             &m_sampler
00222             )
00223         );
00224
00225     m_camera = ref new BasicCamera();
00226 }
00227
00228 void TextInterop::CreateWindowSizeDependentResources()
00229 {
00230     DirectXBase::CreateWindowSizeDependentResources();
00231
00232     // update the 3D projection matrix
00233     m_camera->SetProjectionParameters(
00234         70.0f,                                                  // use a 70-degree vertical field of view
00235         m_renderTargetSize.Width / m_renderTargetSize.Height,  // specify the aspect ratio of the window
00236         0.01f,                                                  // specify the nearest Z-distance at which to draw vertices
00237         100.0f                                                  // specify the farthest Z-distance at which to draw vertices
00238         );
00239
00240     // save the new projection matrix to the constant buffer data struct
00241     m_camera->GetProjectionMatrix(&m_constantBufferData.projection);
00242
00243     m_sampleOverlay->UpdateForWindowSizeChange();
00244 }
00245
00246 void TextInterop::Render()
00247 {
00248     // bind the render targets
00249     m_d3dContext->OMSetRenderTargets(
00250         1,
00251         m_d3dRenderTargetView.GetAddressOf(),
00252         m_d3dDepthStencilView.Get()
00253         );
00254
00255     // clear both the render target and depth stencil to default values
00256     const float ClearColor[4] = { 0.071f, 0.040f, 0.561f, 1.0f };
00257
00258     m_d3dContext->ClearRenderTargetView(
00259         m_d3dRenderTargetView.Get(),
00260         ClearColor
00261         );
00262
00263     m_d3dContext->ClearDepthStencilView(
00264         m_d3dDepthStencilView.Get(),
00265         D3D11_CLEAR_DEPTH,
00266         1.0f,
00267         0
00268         );
00269
00270     m_d3dContext->IASetInputLayout(m_inputLayout.Get());
00271
00272     // set the vertex and index buffers, and specify the way they define geometry
00273     UINT stride = sizeof(BasicVertex);
00274     UINT offset = 0;
00275     m_d3dContext->IASetVertexBuffers(
00276         0,
00277         1,
00278         m_vertexBuffer.GetAddressOf(),
00279         &stride,
00280         &offset
00281         );
00282
00283     // set the index buffer
00284     m_d3dContext->IASetIndexBuffer(
00285         m_indexBuffer.Get(),
00286         DXGI_FORMAT_R16_UINT,   // unsigned short index format
00287         0                       // specify the base index in the buffer
00288         );
00289
00290     // specify the way the vertex and index buffers define geometry
00291     m_d3dContext->IASetPrimitiveTopology(D3D11_PRIMITIVE_TOPOLOGY_TRIANGLELIST);
00292
00293     // set the vertex shader stage state
00294     m_d3dContext->VSSetShader(
00295         m_vertexShader.Get(),
00296         nullptr,                // don't use shader linkage
00297         0                       // don't use shader linkage
00298         );
00299
00300     m_d3dContext->VSSetConstantBuffers(
00301         0,                              // starting at the first constant buffer slot
00302         1,                              // set one constant buffer binding
00303         m_constantBuffer.GetAddressOf()
00304         );
00305
00306     // set the pixel shader stage state
00307     m_d3dContext->PSSetShader(
00308         m_pixelShader.Get(),
00309         nullptr,                // don't use shader linkage
00310         0                       // don't use shader linkage
00311         );
00312
00313     m_d3dContext->PSSetShaderResources(
00314         0,                          // starting at the first shader resource slot
00315         1,                          // set one shader resource binding
00316         m_textureShaderResourceView.GetAddressOf()
00317         );
00318
00319     m_d3dContext->PSSetSamplers(
00320         0,                          // starting at the first sampler slot
00321         1,                          // set one sampler binding
00322         m_sampler.GetAddressOf()
00323         );
00324
00325     // draw the cube
00326     m_d3dContext->DrawIndexed(
00327         m_indexCount,   // draw all created vertices
00328         0,              // starting with the first vertex
00329         0               // and the first index
00330         );
00331
00332     m_sampleOverlay->Render();
00333 }
00334
00335 void TextInterop::Update(float timeTotal, float timeDelta)
00336 {
00337     // update the model matrix based on the time
00338     m_constantBufferData.model = rotationY(-timeTotal * 60.0f);
00339
00340     // update the view matrix based on the camera position
00341     // note that for this sample, the camera position is fixed
00342     m_camera->SetViewParameters(
00343         float3(0, 1.0f, 2.0f),
00344         float3(0, 0, 0),
00345         float3(0, 1, 0)
00346         );
00347
00348     m_camera->GetViewMatrix(&m_constantBufferData.view);
00349
00350     // update the constant buffer with the new data
00351     m_d3dContext->UpdateSubresource(
00352         m_constantBuffer.Get(),
00353         0,
00354         nullptr,
00355         &m_constantBufferData,
00356         0,
00357         0
00358         );
00359 }
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML images/C++/common/LayoutAwarePage.cpp Source File

  • XAML images
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/common/LayoutAwarePage.cpp Source File

  • XAML WebView control
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/PageRoll.cpp Source File

  • Direct2D magazine app

PageRoll.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 using namespace Windows::Data::Xml::Dom;
00011
00012 bool PageRoll::AcceptChildNode(
00013     _In_ Document^ document,
00014     _In_ IXmlNode^ childXmlNode
00015     )
00016 {
00017     if (childXmlNode->NodeType == NodeType::ElementNode)
00018     {
00019         XmlElement^ xmlElement = dynamic_cast<XmlElement^>(childXmlNode);
00020
00021         Element^ child = nullptr;
00022         Platform::String^ elementName = xmlElement->TagName;
00023
00024         if (elementName != nullptr)
00025         {
00026             if (elementName == "page")
00027             {
00028                 child = Element::Create<::Page>(document, childXmlNode);
00029             }
00030         }
00031
00032         if (child == nullptr)
00033         {
00034             return false;
00035         }
00036
00037         AddChild(child);
00038     }
00039
00040     return true;
00041 }
00042
00043 //  Page roll places its children side-by-side horizontally.
00044 //
00045 void PageRoll::Measure(
00046     _In_ Document^ document,
00047     D2D1_SIZE_F const& parentSize,
00048     _Out_ D2D1_RECT_F* bounds
00049     )
00050 {
00051     D2D1_SIZE_F size = m_size;
00052
00053     if (size.width <= 0 && size.height <= 0)
00054     {
00055         // When no size is specified, assume its parent size.
00056         size = parentSize;
00057     }
00058
00059     D2D1_RECT_F maxBounds = {0};
00060
00061     Element^ child = GetFirstChild();
00062
00063     while (child)
00064     {
00065         D2D1_RECT_F childBounds = {0};
00066
00067         child->Measure(document, size, &childBounds);
00068
00069         if (maxBounds.right + childBounds.left < maxBounds.left)
00070         {
00071             // Accommodate child placed left to all other previous children.
00072             maxBounds.left = childBounds.left;
00073         }
00074
00075         // The current child is laid next to the right of the previous child.
00076         maxBounds.right += childBounds.right;
00077
00078         if (childBounds.top < maxBounds.top)
00079         {
00080             maxBounds.top = childBounds.top;
00081         }
00082
00083         if (childBounds.bottom > maxBounds.bottom)
00084         {
00085             maxBounds.bottom = childBounds.bottom;
00086         }
00087
00088         child = child->GetNextSibling();
00089     }
00090
00091     m_size = D2D1::SizeF(maxBounds.right - maxBounds.left, maxBounds.bottom - maxBounds.top);
00092
00093     *bounds = D2D1::RectF(
00094         maxBounds.left + m_offset.x,
00095         maxBounds.top + m_offset.y,
00096         maxBounds.right + m_offset.x,
00097         maxBounds.bottom + m_offset.y
00098         );
00099 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario1.xaml.cpp Source File

  • XAML WebView control

Scenario1.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.cpp
00013 // Implementation of the Scenario1 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario1.xaml.h"
00018
00019 using namespace SDKSample::WebViewControl;
00020
00021 using namespace Platform;
00022 using namespace Windows::Foundation;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Input;
00026 using namespace Windows::UI::Xaml::Navigation;
00027
00028 Scenario1::Scenario1()
00029 {
00030     InitializeComponent();
00031
00032 }
00033
00034 // Invoked when this page is about to be displayed in a Frame.
00035 void Scenario1::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00038     // as NotifyUser()
00039     rootPage = MainPage::Current;
00040   Address->KeyUp += ref new KeyEventHandler(this, &SDKSample::WebViewControl::Scenario1::Address_KeyUp);
00041   Address->Text = "http://www.msn.com";
00042
00043 }
00044
00045 // Click handler for Navigate button
00046 void SDKSample::WebViewControl::Scenario1::NavigateButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00047 {
00048   ProgressRing1->IsActive = true;
00049
00050   // Provide an indication as to where we are trying to navigate to
00051   String^ str = "Navigating to: {0}" + Address->Text;
00052     rootPage->NotifyUser(str, NotifyType::StatusMessage);
00053
00054   // Hook the LoadCompleted event for the WebView to know when the URL is fully loaded
00055   WebView1->LoadCompleted += ref new LoadCompletedEventHandler(this, &Scenario1::WebView1_LoadCompleted);
00056
00057   // Attempt to navigate to the specified URL.  Notice that a malformed URL will raise a FormatException
00058     // which we catch and let the user know that the URL is bad and to enter a new well-formed one.
00059   try
00060     {
00061         Uri^ targetUri = ref new Uri(Address->Text);
00062         WebView1->Navigate(targetUri);
00063     }
00064     catch (FailureException^ myE)
00065     {
00066         // Bad address
00067     String^ str = "Address is invalid, try again.  Details --> {0}" + myE->Message;
00068         rootPage->NotifyUser(str, NotifyType::ErrorMessage);
00069     }
00070 }
00071
00072
00073 // Load completed handler for WebView1
00074 void SDKSample::WebViewControl::Scenario1::WebView1_LoadCompleted(Platform::Object^ sender, Windows::UI::Xaml::Navigation::NavigationEventArgs^ e)
00075 {
00076   WebView1->Visibility = Windows::UI::Xaml::Visibility::Visible;
00077   BlockingRect->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00078   ProgressRing1->IsActive = false;
00079
00080   // Tell the user that the page has loaded
00081     rootPage->NotifyUser("Page loaded", NotifyType::StatusMessage);
00082 }
00083
00084
00085 // Key up handler for Address text box
00086 void SDKSample::WebViewControl::Scenario1::Address_KeyUp(Platform::Object^ sender, Windows::UI::Xaml::Input::KeyRoutedEventArgs^ e)
00087 {
00088    if (e->Key == Windows::System::VirtualKey::Enter)
00089   {
00090     NavigateButton_Click(this, ref new RoutedEventArgs());
00091   }
00092 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TextAnalysis::LinkedRun Member List

This is the complete list of members for TextAnalysis::LinkedRun, including all inherited members.
bidiLevel | TextAnalysis::Run |
ContainsTextPosition(UINT32 desiredTextPosition) const | TextAnalysis::Run | [inline]
glyphCount | TextAnalysis::Run |
glyphOrientation | TextAnalysis::Run |
glyphStart | TextAnalysis::Run |
isNumberSubstituted | TextAnalysis::Run |
isReversed | TextAnalysis::Run |
isSideways | TextAnalysis::Run |
LinkedRun() | TextAnalysis::LinkedRun | [inline]
nextRunIndex | TextAnalysis::LinkedRun |
operator==(UINT32 desiredTextPosition) const | TextAnalysis::Run | [inline]
Run() | TextAnalysis::Run | [inline]
script | TextAnalysis::Run |
textLength | TextAnalysis::Run |
textStart | TextAnalysis::Run |
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Snap/C++/Scenario1.xaml.h Source File

  • Snap

Scenario1.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace SnapSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         public ref class Scenario1 sealed
00030         {
00031         public:
00032             Scenario1();
00033
00034         private:
00035             Platform::String^ ConvertViewState(Windows::UI::ViewManagement::ApplicationViewState state);
00036             void UpdateForViewState();
00037
00038             void Page_SizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00039             void UnsnapButton_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00040             Windows::Foundation::EventRegistrationToken _layoutHandlerToken;    };
00041     }
00042 }
Generated on Sat Nov 23 2024 16:07:50 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite hello world/C++/DirectXBase.cpp Source File

  • DirectWrite hello world

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileSquareBlock Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileSquareBlock, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
NotificationsExtensions::GetContent() | NotificationsExtensions::TileContent::TileSquareBase | [inline]
NotificationsExtensions::GetContent() | NotificationsExtensions::TileContent::TileSquareBase | [inline]
NotificationsExtensions::TileContent::TileNotificationBase::GetContent() | NotificationsExtensions::NotificationBase | [pure virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
Images | NotificationsExtensions::NotificationBase |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeBinding(string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
SerializeBinding(string globalLang, string globalBaseUri, TileBranding globalBranding, bool globalAddImageQuery) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextBlock | NotificationsExtensions::TileContent::TileSquareBlock |
TextFields | NotificationsExtensions::NotificationBase |
TextSubBlock | NotificationsExtensions::TileContent::TileSquareBlock |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileSquareBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
TileSquareBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileSquareBase | [inline]
TileSquareBlock() | NotificationsExtensions::TileContent::TileSquareBlock | [inline]
TileSquareBlock() | NotificationsExtensions::TileContent::TileSquareBlock | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:43 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/App.xaml.cpp Source File

  • Background Transfer

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:26 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/List.h Source File

  • Direct2D magazine app

List.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #include "Rectangle.h"
00011
00012 //  <list> arranges its child content by stacking them vertically from top to bottom.
00013 //  If the child content can't fit within the original size of the list, the list will
00014 //  expand to accommodate them. List is direct subclass of Rectangle. It has all the
00015 //  characteristic of a rectangle drawing.
00016 //
00017 //  List accepts the following additional markup attributes:
00018 //      margin = "<float>"
00019 //          Amount of spacing around the four edges of the list to where the child
00020 //          element is drawn
00021 //
00022 ref class List : public Rectangle
00023 {
00024 internal:
00025     List();
00026
00027     virtual bool AcceptChildNode(
00028         _In_ Document^ document,
00029         _In_ Windows::Data::Xml::Dom::IXmlNode^ childXmlNode
00030         ) override;
00031
00032     virtual bool Initialize(
00033         _In_ Document^ document,
00034         _In_ Windows::Data::Xml::Dom::XmlElement^ xmlElement
00035         ) override;
00036
00037     virtual void Measure(
00038         _In_ Document^ document,
00039         D2D1_SIZE_F const& parentSize,
00040         _Out_ D2D1_RECT_F* bounds
00041         ) override;
00042
00043     virtual bool Draw(
00044         _In_ Document^ document,
00045         D2D1::Matrix3x2F const& transform
00046         ) override;
00047
00048 private:
00049     // Amount of margin around the drawing area of a list.
00050     float m_margin;
00051 };
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Camera.cpp Source File

  • DirectX 3D shooting game

Camera.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Camera.h"
00010 #include "StereoProjection.h"
00011
00012 using namespace DirectX;
00013
00014 #undef min // Use __min instead.
00015 #undef max // Use __max instead.
00016
00017 //--------------------------------------------------------------------------------------
00018
00019 Camera::Camera()
00020 {
00021     // Setup the view matrix.
00022     SetViewParams(
00023         XMFLOAT3(0.0f, 0.0f, 0.0f),   // Default eye position.
00024         XMFLOAT3(0.0f, 0.0f, 1.0f),   // Default look at position.
00025         XMFLOAT3(0.0f, 1.0f, 0.0f)    // Default up vector.
00026         );
00027
00028     // Setup the projection matrix.
00029     SetProjParams(XM_PI / 4, 1.0f, 1.0f, 1000.0f);
00030 }
00031
00032 //--------------------------------------------------------------------------------------
00033
00034 void Camera::LookDirection (_In_ XMFLOAT3 lookDirection)
00035 {
00036     XMFLOAT3 lookAt;
00037     lookAt.x = m_eye.x + lookDirection.x;
00038     lookAt.y = m_eye.y + lookDirection.y;
00039     lookAt.z = m_eye.z + lookDirection.z;
00040
00041     SetViewParams(m_eye, lookAt, m_up);
00042 }
00043
00044 //--------------------------------------------------------------------------------------
00045
00046 void Camera::Eye(_In_ XMFLOAT3 eye)
00047 {
00048     SetViewParams(eye, m_lookAt, m_up);
00049 }
00050
00051 //--------------------------------------------------------------------------------------
00052
00053 void Camera::SetViewParams(
00054     _In_ XMFLOAT3 eye,
00055     _In_ XMFLOAT3 lookAt,
00056     _In_ XMFLOAT3 up
00057     )
00058 {
00059     m_eye = eye;
00060     m_lookAt = lookAt;
00061     m_up = up;
00062
00063     // Calculate the view matrix.
00064     XMMATRIX view = XMMatrixLookAtLH(
00065         XMLoadFloat3(&m_eye),
00066         XMLoadFloat3(&m_lookAt),
00067         XMLoadFloat3(&m_up)
00068         );
00069
00070     XMVECTOR det;
00071     XMMATRIX inverseView = XMMatrixInverse(&det, view);
00072     XMStoreFloat4x4(&m_viewMatrix, view);
00073     XMStoreFloat4x4(&m_inverseView, inverseView);
00074
00075     // The axis basis vectors and camera position are stored inside the
00076     // position matrix in the 4 rows of the camera's world matrix.
00077     // To figure out the yaw/pitch of the camera, we just need the Z basis vector.
00078     XMFLOAT3 zBasis;
00079     XMStoreFloat3(&zBasis, inverseView.r[2]);
00080
00081     m_cameraYawAngle = atan2f(zBasis.x, zBasis.z);
00082
00083     float len = sqrtf(zBasis.z * zBasis.z + zBasis.x * zBasis.x);
00084     m_cameraPitchAngle = atan2f(zBasis.y, len);
00085 }
00086
00087 //--------------------------------------------------------------------------------------
00088
00089 void Camera::SetProjParams(
00090     _In_ float fieldOfView,
00091     _In_ float aspectRatio,
00092     _In_ float nearPlane,
00093     _In_ float farPlane
00094     )
00095 {
00096     // Set attributes for the projection matrix.
00097     m_fieldOfView = fieldOfView;
00098     m_aspectRatio = aspectRatio;
00099     m_nearPlane = nearPlane;
00100     m_farPlane = farPlane;
00101     XMStoreFloat4x4(
00102         &m_projectionMatrix,
00103         XMMatrixPerspectiveFovLH(
00104             m_fieldOfView,
00105             m_aspectRatio,
00106             m_nearPlane,
00107             m_farPlane
00108             )
00109         );
00110
00111     STEREO_PARAMETERS* stereoParams = nullptr;
00112     // Update the projection matrix.
00113     XMStoreFloat4x4(
00114         &m_projectionMatrixLeft,
00115         MatrixStereoProjectionFovLH(
00116             stereoParams,
00117             STEREO_CHANNEL::LEFT,
00118             m_fieldOfView,
00119             m_aspectRatio,
00120             m_nearPlane,
00121             m_farPlane,
00122             STEREO_MODE::NORMAL
00123             )
00124         );
00125
00126     XMStoreFloat4x4(
00127         &m_projectionMatrixRight,
00128         MatrixStereoProjectionFovLH(
00129             stereoParams,
00130             STEREO_CHANNEL::RIGHT,
00131             m_fieldOfView,
00132             m_aspectRatio,
00133             m_nearPlane,
00134             m_farPlane,
00135             STEREO_MODE::NORMAL
00136             )
00137         );
00138 }
00139
00140 //--------------------------------------------------------------------------------------
00141
00142 DirectX::XMMATRIX Camera::View()
00143 {
00144     return XMLoadFloat4x4(&m_viewMatrix);
00145 }
00146
00147 //--------------------------------------------------------------------------------------
00148
00149 DirectX::XMMATRIX Camera::Projection()
00150 {
00151     return XMLoadFloat4x4(&m_projectionMatrix);
00152 }
00153
00154 //--------------------------------------------------------------------------------------
00155
00156 DirectX::XMMATRIX Camera::LeftEyeProjection()
00157 {
00158     return XMLoadFloat4x4(&m_projectionMatrixLeft);
00159 }
00160
00161 //--------------------------------------------------------------------------------------
00162
00163 DirectX::XMMATRIX Camera::RightEyeProjection()
00164 {
00165     return XMLoadFloat4x4(&m_projectionMatrixRight);
00166 }
00167
00168 //--------------------------------------------------------------------------------------
00169
00170 DirectX::XMMATRIX Camera::World()
00171 {
00172     return XMLoadFloat4x4(&m_inverseView);
00173 }
00174
00175 //--------------------------------------------------------------------------------------
00176
00177 DirectX::XMFLOAT3 Camera::Eye()
00178 {
00179     return m_eye;
00180 }
00181
00182 //--------------------------------------------------------------------------------------
00183
00184 DirectX::XMFLOAT3 Camera::LookAt()
00185 {
00186     return m_lookAt;
00187 }
00188
00189 //--------------------------------------------------------------------------------------
00190
00191 float Camera::NearClipPlane()
00192 {
00193     return m_nearPlane;
00194 }
00195
00196 //--------------------------------------------------------------------------------------
00197
00198 float Camera::FarClipPlane()
00199 {
00200     return m_farPlane;
00201 }
00202
00203 //--------------------------------------------------------------------------------------
00204
00205 float Camera::Pitch()
00206 {
00207     return m_cameraPitchAngle;
00208 }
00209
00210 //--------------------------------------------------------------------------------------
00211
00212 float Camera::Yaw()
00213 {
00214     return m_cameraYawAngle;
00215 }
00216
00217 //--------------------------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML data binding/C++/MainPage.xaml.cpp Source File

  • XAML data binding

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Calendar details and math/C++/pch.h Source File

  • Calendar details and math

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: CryptoWinRT/C++/MainPage.xaml.cpp Source File

  • CryptoWinRT

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:41 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker/C++/Scenario3.xaml.cpp Source File

  • File picker

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::FilePicker;
00020
00021 using namespace concurrency;
00022 using namespace Platform;
00023 using namespace Windows::Storage;
00024 using namespace Windows::Storage::Pickers;
00025 using namespace Windows::UI::Xaml;
00026 using namespace Windows::UI::Xaml::Controls;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 Scenario3::Scenario3()
00030 {
00031     InitializeComponent();
00032     rootPage = MainPage::Current;
00033     PickFolderButton->Click += ref new RoutedEventHandler(this, &Scenario3::PickFolderButton_Click);
00034 }
00035
00036 void Scenario3::PickFolderButton_Click(Object^ sender, RoutedEventArgs^ e)
00037 {
00038     // Clear previous returned folder name, if it exists, between iterations of this scenario
00039     rootPage->ResetScenarioOutput(OutputTextBlock);
00040
00041     if (rootPage->EnsureUnsnapped())
00042     {
00043         FolderPicker^ folderPicker = ref new FolderPicker();
00044         folderPicker->SuggestedStartLocation = PickerLocationId::Desktop;
00045
00046         // Users expect to have a filtered view of their folders depending on the scenario.
00047         // For example, when choosing a documents folder, restrict the filetypes to documents for your application.
00048         folderPicker->FileTypeFilter->Append(".docx");
00049         folderPicker->FileTypeFilter->Append(".xlsx");
00050         folderPicker->FileTypeFilter->Append(".pptx");
00051
00052         create_task(folderPicker->PickSingleFolderAsync()).then([this](StorageFolder^ folder)
00053         {
00054             if (folder)
00055             {
00056                 OutputTextBlock->Text = "Picked folder: " + folder->Name;
00057             }
00058             else
00059             {
00060                 OutputTextBlock->Text = "Operation cancelled.";
00061             }
00062         });
00063     }
00064 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/NumberParsing.xaml.cpp Source File

  • Number formatting and parsing

NumberParsing.xaml.cpp

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // NumberParsing.xaml.cpp
00013 // Implementation of the NumberParsing class
00014 //
00015
00016 #include "pch.h"
00017 #include "NumberParsing.xaml.h"
00018
00019 using namespace SDKSample::NumberFormatting;
00020
00021 using namespace Platform;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::Foundation;
00026 using namespace Windows::Foundation::Collections;
00027 using namespace Windows::Globalization::NumberFormatting;
00028
00029 NumberParsing::NumberParsing()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 /// <summary>
00035 /// Invoked when this page is about to be displayed in a Frame.
00036 /// </summary>
00037 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00038 /// property is typically used to configure the page.</param>
00039 void NumberParsing::OnNavigatedTo(NavigationEventArgs^ e)
00040 {
00041     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00042     // as NotifyUser()
00043     rootPage = MainPage::Current;
00044 }
00045
00046 void SDKSample::NumberFormatting::NumberParsing::Display_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00047 {
00048     // This scenario uses the Windows.Globalization.NumberFormatting.DecimalFormatter,
00049     // Windows.Globalization.NumberFormatting.CurrencyFormatter and
00050     // Windows.Globalization.NumberFormatting.PercentFormatter classes to format and parse a number
00051     // percentage or currency.
00052
00053     // Define percent formatters.
00054     PercentFormatter^ percentFormat = ref new PercentFormatter();
00055
00056     auto ja = ref new Platform::Collections::Vector<String^>();
00057     ja->Append("ja-JP");
00058     PercentFormatter^ percentFormatJP = ref new PercentFormatter(ja, "JP");
00059
00060     auto fr = ref new Platform::Collections::Vector<String^>();
00061     fr->Append("fr-FR");
00062     PercentFormatter^ percentFormatFR = ref new PercentFormatter(fr, "FR");
00063
00064     // Define decimal formatters.
00065     DecimalFormatter^ decimalFormat = ref new DecimalFormatter();
00066     decimalFormat->IsGrouped = true;
00067     DecimalFormatter^ decimalFormatJP = ref new DecimalFormatter(ja, "JP");
00068     decimalFormatJP->IsGrouped = true;
00069     DecimalFormatter^ decimalFormatFR = ref new DecimalFormatter(fr, "FR");
00070     decimalFormatFR->IsGrouped = true;
00071
00072     // Define currency formatters
00073     auto userCurrency = Windows::System::UserProfile::GlobalizationPreferences::Currencies->First()->Current;
00074     CurrencyFormatter^ currencyFormat = ref new CurrencyFormatter(userCurrency);
00075     CurrencyFormatter^ currencyFormatJP = ref new CurrencyFormatter("JPY", ja, "JP");
00076     CurrencyFormatter^ currencyFormatFR = ref new CurrencyFormatter("EUR", fr, "FR");
00077
00078     // Generate numbers for parsing.
00079     double percentNumber = 0.523;
00080     double decimalNumber = 12345.67;
00081     double currencyNumber = 1234.56;
00082
00083     // Roundtrip the percent numbers by formatting and parsing.
00084     String^ percent1 = percentFormat->Format(percentNumber);
00085     double percent1Parsed = percentFormat->ParseDouble(percent1)->Value;
00086
00087     String^ percent1JP = percentFormatJP->Format(percentNumber);
00088     double percent1JPParsed = percentFormatJP->ParseDouble(percent1JP)->Value;
00089
00090     String^ percent1FR = percentFormatFR->Format(percentNumber);
00091     double percent1FRParsed = percentFormatFR->ParseDouble(percent1FR)->Value;
00092
00093     // Generate the results for percent parsing.
00094     String^ results1 = "Percent parsing of " + percentNumber + "\n" +
00095     "Formatted for current user: " + percent1   + " Parsed as current user: " + percent1Parsed   + "\n" +
00096     "Formatted for ja-JP: "        + percent1JP + " Parsed for ja-JP: "       + percent1JPParsed + "\n" +
00097     "Formatted for fr-FR: "        + percent1FR + " Parsed for fr-FR: "       + percent1FRParsed;
00098
00099     // Roundtrip the decimal numbers for formatting and parsing.
00100     String^ decimal1 = decimalFormat->Format(decimalNumber);
00101     double decimal1Parsed = decimalFormat->ParseDouble(decimal1)->Value;
00102
00103     String^ decimal1JP = decimalFormatJP->Format(decimalNumber);
00104     double decimal1JPParsed = decimalFormatJP->ParseDouble(decimal1JP)->Value;
00105
00106     String^ decimal1FR = decimalFormatFR->Format(decimalNumber);
00107     double decimal1FRParsed = decimalFormatFR->ParseDouble(decimal1FR)->Value;
00108
00109     // Generate the results for decimal parsing.
00110     String^ results2 = "Decimal parsing of " + decimalNumber + "\n" +
00111     "Formatted for current user: " + decimal1   + " Parsed as current user: " + decimal1Parsed   + "\n" +
00112     "Formatted for ja-JP: "        + decimal1JP + " Parsed for ja-JP: "       + decimal1JPParsed + "\n" +
00113     "Formatted for fr-FR: "        + decimal1FR + " Parsed for fr-FR: "       + decimal1FRParsed;
00114
00115     // Roundtrip the currency numbers for formatting and parsing.
00116     String^ currency1 = currencyFormat->Format(currencyNumber);
00117     double currency1Parsed = currencyFormat->ParseDouble(currency1)->Value;
00118
00119     String^ currency1JP = currencyFormatJP->Format(currencyNumber);
00120     double currency1JPParsed = currencyFormatJP->ParseDouble(currency1JP)->Value;
00121
00122     String^ currency1FR = currencyFormatFR->Format(currencyNumber);
00123     double currency1FRParsed = currencyFormatFR->ParseDouble(currency1FR)->Value;
00124
00125     // Generate the results for decimal parsing.
00126     String^ results3 = "Currency parsing of " + currencyNumber + "\n" +
00127     "Formatted for current user: " + currency1   + " Parsed as current user: " + currency1Parsed   + "\n" +
00128     "Formatted for ja-JP: "        + currency1JP + " Parsed for ja-JP: "       + currency1JPParsed + "\n" +
00129     "Formatted for fr-FR: "        + currency1FR + " Parsed for fr-FR: "       + currency1FRParsed;
00130
00131     // Display the results.
00132     String^ results = results1 + "\n\n" + results2 + "\n\n" + results3;
00133     rootPage->NotifyUser(results, NotifyType::StatusMessage);
00134 }
Generated on Sat Nov 23 2024 16:08:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX 3D shooting game/C++/Material.cpp Source File

  • DirectX 3D shooting game

Material.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "Material.h"
00010 #include "GameConstants.h"
00011
00012 using namespace DirectX;
00013
00014 //--------------------------------------------------------------------------------
00015
00016 Material::Material(
00017     XMFLOAT4 meshColor,
00018     XMFLOAT4 diffuseColor,
00019     XMFLOAT4 specularColor,
00020     float specularExponent,
00021     _In_ ID3D11ShaderResourceView* textureResourceView,
00022     _In_ ID3D11VertexShader* vertexShader,
00023     _In_ ID3D11PixelShader* pixelShader
00024     )
00025 {
00026     m_meshColor = meshColor;
00027     m_diffuseColor = diffuseColor;
00028     m_specularColor = specularColor;
00029     m_specularExponent = specularExponent;
00030
00031     m_vertexShader = vertexShader;
00032     m_pixelShader = pixelShader;
00033     m_textureRV = textureResourceView;
00034 }
00035
00036 //--------------------------------------------------------------------------------
00037
00038 void Material::RenderSetup(
00039     _In_ ID3D11DeviceContext* context,
00040     _Inout_ ConstantBufferChangesEveryPrim* constantBuffer
00041     )
00042 {
00043     constantBuffer->meshColor = m_meshColor;
00044     constantBuffer->specularColor = m_specularColor;
00045     constantBuffer->specularPower = m_specularExponent;
00046     constantBuffer->diffuseColor = m_diffuseColor;
00047
00048     context->PSSetShaderResources(0, 1, m_textureRV.GetAddressOf());
00049     context->VSSetShader(m_vertexShader.Get(), nullptr, 0);
00050     context->PSSetShader(m_pixelShader.Get(), nullptr, 0);
00051 }
Generated on Sat Nov 23 2024 16:08:14 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/Scenario4.xaml.cpp Source File

  • DatagramSocket

Scenario4.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario4.xaml.cpp
00013 // Implementation of the Scenario4 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario4.xaml.h"
00018
00019 using namespace DatagramSocketSample;
00020
00021 using namespace Windows::ApplicationModel::Core;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025
00026 Scenario4::Scenario4()
00027 {
00028     InitializeComponent();
00029 }
00030
00031 /// <summary>
00032 /// Invoked when this page is about to be displayed in a Frame.
00033 /// </summary>
00034 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00035 /// property is typically used to configure the page.</param>
00036 void Scenario4::OnNavigatedTo(NavigationEventArgs^ e)
00037 {
00038     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00039     // as NotifyUser()
00040     rootPage = MainPage::Current;
00041 }
00042
00043 void Scenario4::CloseSockets_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00044 {
00045     if (CoreApplication::Properties->HasKey("clientSocket"))
00046     {
00047         // This is the last reference to the context, so once removed the object will be deleted.
00048         CoreApplication::Properties->Remove("clientSocket");
00049     }
00050
00051     if (CoreApplication::Properties->HasKey("listener"))
00052     {
00053         // This is the last reference to the context, so once removed the object will be deleted.
00054         CoreApplication::Properties->Remove("listener");
00055     }
00056
00057     rootPage->NotifyUser("Socket and listener closed", NotifyType::StatusMessage);
00058 }
Generated on Sat Nov 23 2024 16:07:55 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Simplified ink/C++/simpleInk.h Source File

  • Input Simplified ink

simpleInk.h

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #pragma once
00009 #pragma warning (disable: 4451)  // warns about possible invalid marshaling of objects across contexts, however we don't need to worry about this because the classes in the Inking API are INoMarshal
00010
00011 #include "DirectXBase.h"
00012
00013 // A NOTE ON RENDERING
00014 // We have two rendering modes: live rendering and Bezier (re-)rendering. Live rendering is active from the moment the
00015 // pointer makes contact to the moment it is released. In order to reduce latencies, in live rendering mode we interpolate
00016 // inking samples with lines. Bezier rendering improves the quality of the stroke once the pointer is released by
00017 // re-rendering it with Bezier curves interpolation.
00018 // Live rendering begins with OnPointerPressed, is updated by OnPointerMoved and ends with OnPointerReleased.
00019 // BezierRender, called by Render, renders all the strokes contained in the stroke container using Bezier curves.
00020 //
00021 // In the interest of minimizing lagging between the rendered stroke and the position of the inking device,
00022 // we shall use immediate-mode presentation (Present(0, ...)) while in live rendering. This way we can always present
00023 // the most up to date inking sample. However immediate mode presentation drains the battery so we shall switch back
00024 // to non-immediate mode presentation (Present(1, ...)) as soon as we exit live rendering.
00025
00026 typedef enum {
00027     Bezier,
00028     Live
00029 } RenderingMode;
00030
00031 ref class simpleInk sealed : public DirectXBase, public Windows::ApplicationModel::Core::IFrameworkView
00032 {
00033 public:
00034     simpleInk();
00035
00036     // DirectXBase Methods
00037     virtual void CreateDeviceIndependentResources() override;
00038     virtual void CreateDeviceResources() override;
00039     virtual void CreateWindowSizeDependentResources() override;
00040     virtual void Present() override;
00041     virtual void Render() override;
00042
00043     // IFrameworkView Methods
00044     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00045     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00046     virtual void Load(_In_ Platform::String^ entryPoint);
00047     virtual void Run();
00048     virtual void Uninitialize();
00049
00050 protected:
00051     // Event Handlers
00052     void OnWindowSizeChanged(
00053         _In_ Windows::UI::Core::CoreWindow^ sender,
00054         _In_ Windows::UI::Core::WindowSizeChangedEventArgs^ args);
00055     void OnLogicalDpiChanged(_In_ Platform::Object^ sender);
00056     void OnDisplayContentsInvalidated(_In_ Platform::Object^ sender);
00057     void OnActivated(
00058         _In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView,
00059         _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^ args);
00060     void OnCharacterReceived(
00061         _In_ Windows::UI::Core::CoreWindow^ sender,
00062         _In_ Windows::UI::Core::CharacterReceivedEventArgs^ args);
00063     void OnPointerPressed(
00064         _In_ Windows::UI::Core::CoreWindow^ sender,
00065         _In_ Windows::UI::Core::PointerEventArgs^ args);
00066     void OnPointerMoved(
00067         _In_ Windows::UI::Core::CoreWindow^ sender,
00068         _In_ Windows::UI::Core::PointerEventArgs^ args);
00069     void OnPointerReleased(
00070         _In_ Windows::UI::Core::CoreWindow^ sender,
00071         _In_ Windows::UI::Core::PointerEventArgs^ args);
00072
00073     void OnCopyToClipboard();
00074     void OnCopyTextToClipboard();
00075     void OnPasteFromClipboard();
00076     void OnSave();
00077     void OnLoad();
00078     void OnSelectAll();
00079     void OnDelete();
00080     void OnChangeDrawingAttributes();
00081     void OnChangeRecognizer();
00082     void OnRecognize();
00083
00084     void BezierRender();
00085
00086 internal:
00087     void ConvertStrokeToGeometry(
00088         _In_ Windows::UI::Input::Inking::InkStroke^ stroke,
00089         _Outptr_ ID2D1PathGeometry** geometry);
00090
00091 private:
00092     // D2D data members
00093     Microsoft::WRL::ComPtr<ID3D11Texture2D> _currentBuffer;
00094     Microsoft::WRL::ComPtr<ID3D11Texture2D> _previousBuffer;
00095     Microsoft::WRL::ComPtr<IDWriteTextFormat> _eventTextFormat;
00096     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> _backgroundBrush;
00097     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> _messageBrush;
00098     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> _inkBrush;
00099     Microsoft::WRL::ComPtr<ID2D1SolidColorBrush> _selectionBrush;
00100     Microsoft::WRL::ComPtr<ID2D1StrokeStyle> _inkStyle;
00101     Microsoft::WRL::ComPtr<ID2D1StrokeStyle> _selectionStyle;
00102
00103     Windows::UI::Color _backgroundColor;
00104
00105     // Inking members
00106     Windows::UI::Input::Inking::InkStrokeBuilder^ _strokeBuilder;
00107     Windows::UI::Input::Inking::InkStrokeContainer^ _strokeContainer;
00108     Windows::UI::Input::Inking::InkRecognizerContainer^ _recognizerContainer;
00109     Windows::UI::Input::Inking::InkRecognizer^ _recognizer;
00110     Windows::UI::Input::Inking::InkDrawingAttributes^ _drawingAttributes;
00111
00112     unsigned int _recognizerId;
00113     Platform::String^ _recognitionText;
00114     Platform::String^ _statusMessage;
00115
00116     // Stores the id of the 'active' pointer, -1 if none. We are allowing only
00117     // one 'active' pointer at a time. This variable is set by OnPointerPressed,
00118     // checked by OnPointerMoved, and reset by OnPointerReleased.
00119     int _pointerId;
00120
00121     Windows::Foundation::Collections::IVector<Windows::Foundation::Point>^ _manipulationPoints;
00122     Windows::UI::Input::Inking::InkManipulationMode _manipulationMode;
00123
00124     RenderingMode _renderingMode;
00125 };
00126
00127 ref class DirectXAppSource sealed : Windows::ApplicationModel::Core::IFrameworkViewSource
00128 {
00129 public:
00130     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView();
00131 };
00132
00133 #pragma warning (default: 4451)
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/common/LayoutAwarePage.h Source File

  • XAML vector-based drawing
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/Animate.h Source File

  • XAML DirectX 3D shooting game

Animate.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // Animate:
00011 // This is an abstract class for animations.  It defines a set of
00012 // capabilities for animating XMFLOAT3 variables.  An animation has the following
00013 // characteristics:
00014 //     Start - the time for the animation to start.
00015 //     Duration - the length of time the animation is to run.
00016 //     Continuous - whether the animation loops after duration is reached or just
00017 //         stops.
00018 // There are two query functions:
00019 //     IsActive - determines if the animation is active at time t.
00020 //     IsFinished - determines if the animation is done at time t.
00021 // It is expected that each derived class will provide an Evaluate method for the
00022 // specific kind of animation.
00023
00024 ref class Animate abstract
00025 {
00026 internal:
00027     Animate();
00028
00029     virtual DirectX::XMFLOAT3 Evaluate (_In_ float t) = 0;
00030
00031     bool  IsActive(_In_ float t) { return ((t >= m_startTime) && (m_continuous || (t < (m_startTime + m_duration)))); };
00032     bool  IsFinished(_In_ float t) { return (!m_continuous && (t >= (m_startTime + m_duration))); }
00033     float Start();
00034     void  Start(_In_ float start);
00035     float Duration();
00036     void  Duration(_In_ float duration);
00037     bool  Continuous();
00038     void  Continuous(_In_ bool continuous);
00039
00040 protected private:
00041     bool  m_continuous;      // if true means at end cycle back to beginning
00042     float m_startTime;       // time at which animation begins
00043     float m_duration;        // for continuous this is the duration of 1 cycle through path
00044 };
00045
00046 //----------------------------------------------------------------------
00047
00048 // AnimateLinePosition:
00049 // This class is a specialization of Animate that defines an animation of a position vector
00050 // along a straight line defined in world coordinates from startPosition to endPosition.
00051
00052 ref class AnimateLinePosition: public Animate
00053 {
00054 internal:
00055     AnimateLinePosition(
00056         _In_ DirectX::XMFLOAT3 startPosition,
00057         _In_ DirectX::XMFLOAT3 endPosition,
00058         _In_ float duration,
00059         _In_ bool continuous
00060         );
00061     virtual DirectX::XMFLOAT3 Evaluate(_In_ float t) override;
00062
00063 private:
00064     DirectX::XMFLOAT3 m_startPosition;
00065     DirectX::XMFLOAT3 m_endPosition;
00066     float             m_length;
00067 };
00068
00069 //----------------------------------------------------------------------
00070
00071 struct LineSegment
00072 {
00073     DirectX::XMFLOAT3 position;
00074     float             length;
00075     float             uStart;
00076     float             uLength;
00077 };
00078
00079 // AnimateLineListPosition:
00080 // This class is a specialization of Animate that defines an animation of a position vector
00081 // along a set of line segments defined by a set of points.  The animation along the path is
00082 // such that the evaluation of the position along the path will be uniform independent of
00083 // the length of each of the line segments.  A continuous loop can be achieved by having the
00084 // first and last points of the list be the same.
00085
00086 ref class AnimateLineListPosition: public Animate
00087 {
00088 internal:
00089     AnimateLineListPosition(
00090         _In_ unsigned int count,
00091         _In_reads_(count) DirectX::XMFLOAT3 position[],
00092         _In_ float duration,
00093         _In_ bool continuous
00094         );
00095     virtual DirectX::XMFLOAT3 Evaluate(_In_ float t) override;
00096
00097 private:
00098     unsigned int             m_count;
00099     float                    m_totalLength;
00100     std::vector<LineSegment> m_segment;
00101 };
00102
00103 //----------------------------------------------------------------------
00104
00105 // AnimateCirclePosition:
00106 // This class is a specialization of Animate that defines an animation of a position vector
00107 // along a circular path centered at 'center' with a starting point of 'startPosition'.  The
00108 // distance between 'center' and 'startPosition' defines the radius of the circle.  The plane
00109 // of the circle will pass through 'center' and 'startPosition' and have a normal of 'planeNormal'.
00110 // The direction of the animation can be either clockwise or counterclockwise based
00111 // on the 'clockwise' parameter.
00112
00113 ref class AnimateCirclePosition: public Animate
00114 {
00115 internal:
00116     AnimateCirclePosition(
00117         _In_ DirectX::XMFLOAT3 center,
00118         _In_ DirectX::XMFLOAT3 startPosition,
00119         _In_ DirectX::XMFLOAT3 planeNormal,
00120         _In_ float duration,
00121         _In_ bool continuous,
00122         _In_ bool clockwise
00123         );
00124     virtual DirectX::XMFLOAT3 Evaluate(_In_ float t) override;
00125
00126 private:
00127     DirectX::XMFLOAT4X4 m_rotationMatrix;
00128     DirectX::XMFLOAT3   m_center;
00129     DirectX::XMFLOAT3   m_planeNormal;
00130     DirectX::XMFLOAT3   m_startPosition;
00131     float               m_radius;
00132     bool                m_clockwise;
00133 };
00134
00135 //----------------------------------------------------------------------
Generated on Sat Nov 23 2024 16:08:13 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAudio2 audio stream effect/C++/MediaStreamer.cpp Source File

  • XAudio2 audio stream effect

MediaStreamer.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010 #include "directxsample.h"
00011
00012 #include <initguid.h>
00013 #include "MediaStreamer.h"
00014
00015 MediaStreamer::MediaStreamer(_In_ Platform::String^ url)
00016 {
00017     Microsoft::WRL::ComPtr<IMFMediaType> outputMediaType;
00018     Microsoft::WRL::ComPtr<IMFMediaType> mediaType;
00019
00020     DX::ThrowIfFailed(
00021         MFStartup(MF_VERSION)
00022         );
00023
00024     //
00025     // Build an attribute object to set MF_LOW_LATENCY
00026     // Each title should evaluate whether the latency v. power trade-off is appropriate
00027     // Longer running music tracks that are not latency sensitive may need this flag less than shorter sounds.
00028     // This sample is using the flag on a music track for demonstrative purposes.
00029     //
00030     Microsoft::WRL::ComPtr<IMFAttributes> lowLatencyAttribute;
00031     DX::ThrowIfFailed(
00032         MFCreateAttributes(&lowLatencyAttribute, 1)
00033         );
00034
00035     DX::ThrowIfFailed(
00036         lowLatencyAttribute->SetUINT32(MF_LOW_LATENCY, TRUE)
00037         );
00038
00039     //
00040     // Create the source reader on the url (file) with the low latency attributes
00041     //
00042     DX::ThrowIfFailed(
00043         MFCreateSourceReaderFromURL(url->Data(), lowLatencyAttribute.Get(), &m_reader)
00044         );
00045
00046     // Set the decoded output format as PCM
00047     // XAudio2 on Windows can process PCM and ADPCM-encoded buffers.
00048     // When using MF, this sample always decodes into PCM.
00049
00050     DX::ThrowIfFailed(
00051         MFCreateMediaType(&mediaType)
00052         );
00053
00054     DX::ThrowIfFailed(
00055         mediaType->SetGUID(MF_MT_MAJOR_TYPE, MFMediaType_Audio)
00056         );
00057
00058     DX::ThrowIfFailed(
00059         mediaType->SetGUID(MF_MT_SUBTYPE, MFAudioFormat_PCM)
00060         );
00061
00062     DX::ThrowIfFailed(
00063         m_reader->SetCurrentMediaType(MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, mediaType.Get())
00064         );
00065
00066     // Get the complete WAVEFORMAT from the Media Type
00067     DX::ThrowIfFailed(
00068         m_reader->GetCurrentMediaType(MF_SOURCE_READER_FIRST_AUDIO_STREAM, &outputMediaType)
00069         );
00070
00071     uint32 formatByteCount = 0;
00072     WAVEFORMATEX* waveFormat;
00073     DX::ThrowIfFailed(
00074         MFCreateWaveFormatExFromMFMediaType(outputMediaType.Get(), &waveFormat, &formatByteCount)
00075         );
00076     CopyMemory(&m_waveFormat, waveFormat, sizeof(m_waveFormat));
00077     CoTaskMemFree(waveFormat);
00078
00079     // Get the total length of the stream in bytes
00080     PROPVARIANT var;
00081     DX::ThrowIfFailed(
00082         m_reader->GetPresentationAttribute(MF_SOURCE_READER_MEDIASOURCE, MF_PD_DURATION, &var)
00083         );
00084     LONGLONG duration = var.uhVal.QuadPart;
00085     float64 durationInSeconds = (duration / (float64)(10000 * 1000));
00086     m_maxStreamLengthInBytes = (uint32)(durationInSeconds * m_waveFormat.nAvgBytesPerSec);
00087 }
00088
00089 std::vector<byte> MediaStreamer::GetNextBuffer()
00090 {
00091     std::vector<byte> resultData;
00092
00093     Microsoft::WRL::ComPtr<IMFSample> sample;
00094     Microsoft::WRL::ComPtr<IMFMediaBuffer> mediaBuffer;
00095
00096     uint8* audioData = nullptr;
00097     uint32 sampleBufferLength = 0;
00098     uint32 flags = 0;
00099
00100     DX::ThrowIfFailed(
00101         m_reader->ReadSample(MF_SOURCE_READER_FIRST_AUDIO_STREAM, 0, nullptr, reinterpret_cast<DWORD*>(&flags), nullptr, &sample)
00102         );
00103
00104     // End of stream
00105     if (flags & MF_SOURCE_READERF_ENDOFSTREAM)
00106     {
00107         return resultData;
00108     }
00109     if (sample == nullptr)
00110     {
00111         throw ref new Platform::FailureException();
00112     }
00113
00114     DX::ThrowIfFailed(
00115         sample->ConvertToContiguousBuffer(&mediaBuffer)
00116         );
00117
00118     DX::ThrowIfFailed(
00119         mediaBuffer->Lock(&audioData, nullptr, reinterpret_cast<DWORD*>(&sampleBufferLength))
00120         );
00121
00122     //
00123     // Prepare and return the resultant array of data
00124     //
00125     resultData.resize(sampleBufferLength);
00126     CopyMemory(&resultData[0], audioData, sampleBufferLength);
00127
00128     // Release the lock
00129     DX::ThrowIfFailed(
00130         mediaBuffer->Unlock()
00131         );
00132
00133     return resultData;
00134 }
00135
00136 std::vector<byte> MediaStreamer::ReadAll()
00137 {
00138     std::vector<byte> resultData;
00139
00140     // Make sure stream is set to start
00141     // Restart();
00142
00143     for (;;)
00144     {
00145         std::vector<byte> nextBuffer = GetNextBuffer();
00146         if (nextBuffer.size() == 0)
00147         {
00148             break;
00149         }
00150
00151         // Append the new buffer to the running total
00152         size_t lastBufferSize = resultData.size();
00153         resultData.resize(lastBufferSize + nextBuffer.size());
00154         CopyMemory(&resultData[lastBufferSize], &nextBuffer[0], nextBuffer.size());
00155     }
00156
00157     return resultData;
00158 }
00159
00160 void MediaStreamer::Restart()
00161 {
00162     PROPVARIANT var;
00163     ZeroMemory(&var, sizeof(var));
00164     var.vt = VT_I8;
00165
00166     DX::ThrowIfFailed(
00167         m_reader->SetCurrentPosition(GUID_NULL, var)
00168     );
00169
00170 }
Generated on Sat Nov 23 2024 16:08:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Programmatic file search/C++/common/LayoutAwarePage.h Source File

  • Programmatic file search
  • common

LayoutAwarePage.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     namespace Common
00018     {
00019         /// <summary>
00020         /// Typical implementation of Page that provides several important conveniences:
00021         /// <list type="bullet">
00022         /// <item>
00023         /// <description>Application view state to visual state mapping</description>
00024         /// </item>
00025         /// <item>
00026         /// <description>GoBack, GoForward, and GoHome event handlers</description>
00027         /// </item>
00028         /// <item>
00029         /// <description>Mouse and keyboard shortcuts for navigation</description>
00030         /// </item>
00031         /// <item>
00032         /// <description>State management for navigation and process lifetime management</description>
00033         /// </item>
00034         /// <item>
00035         /// <description>A default view model</description>
00036         /// </item>
00037         /// </list>
00038         /// </summary>
00039         [Windows::Foundation::Metadata::WebHostHidden]
00040         public ref class LayoutAwarePage : Windows::UI::Xaml::Controls::Page
00041         {
00042         internal:
00043             LayoutAwarePage();
00044
00045         public:
00046             void StartLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00047             void StopLayoutUpdates(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00048             void InvalidateVisualState();
00049             static property Windows::UI::Xaml::DependencyProperty^ DefaultViewModelProperty
00050             {
00051                 Windows::UI::Xaml::DependencyProperty^ get();
00052             };
00053             property Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ DefaultViewModel
00054             {
00055                 Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ get();
00056                 void set(Windows::Foundation::Collections::IObservableMap<Platform::String^, Platform::Object^>^ value);
00057             }
00058
00059         protected:
00060             virtual void GoHome(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00061             virtual void GoBack(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00062             virtual void GoForward(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00063             virtual Platform::String^ DetermineVisualState(Windows::UI::ViewManagement::ApplicationViewState viewState);
00064             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00065             virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00066             virtual void LoadState(Platform::Object^ navigationParameter,
00067                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00068             virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState);
00069
00070         private:
00071             Platform::String^ _pageKey;
00072             bool _navigationShortcutsRegistered;
00073             Platform::Collections::Map<Platform::String^, Platform::Object^>^ _defaultViewModel;
00074             Windows::Foundation::EventRegistrationToken _windowSizeEventToken,
00075                 _acceleratorKeyEventToken, _pointerPressedEventToken;
00076             Platform::Collections::Vector<Windows::UI::Xaml::Controls::Control^>^ _layoutAwareControls;
00077             void WindowSizeChanged(Platform::Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e);
00078             void OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00079             void OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080
00081             void CoreDispatcher_AcceleratorKeyActivated(Windows::UI::Core::CoreDispatcher^ sender,
00082                 Windows::UI::Core::AcceleratorKeyEventArgs^ args);
00083             void CoreWindow_PointerPressed(Windows::UI::Core::CoreWindow^ sender,
00084                 Windows::UI::Core::PointerEventArgs^ args);
00085             LayoutAwarePage^ _this; // Strong reference to self, cleaned up in OnUnload
00086         };
00087     }
00088 }
Generated on Sat Nov 23 2024 16:07:34 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/TilePinned.xaml.cpp Source File

  • Secondary tiles
  • C#,C++

TilePinned.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // TilePinned.xaml.cpp
00013 // Implementation of the TilePinned class
00014 //
00015
00016 #include "pch.h"
00017 #include "TilePinned.xaml.h"
00018
00019 using namespace SecondaryTiles;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024 using namespace Windows::UI::StartScreen;
00025
00026 TilePinned::TilePinned()
00027 {
00028     InitializeComponent();
00029 }
00030
00031 /// <summary>
00032 /// Invoked when this page is about to be displayed in a Frame.
00033 /// </summary>
00034 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00035 /// property is typically used to configure the page.</param>
00036 void TilePinned::OnNavigatedTo(NavigationEventArgs^ e)
00037 {
00038     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00039     // as NotifyUser()
00040     rootPage = MainPage::current;
00041     // Preserve the app bar
00042     appBar = rootPage->BottomAppBar;
00043     // Now null it so we don't show the appbar in this scenario
00044     rootPage->BottomAppBar = nullptr;
00045 }
00046
00047 /// <summary>
00048 /// Invoked when this page is about to be navigated out in a Frame
00049 /// </summary>
00050 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00051 /// property is typically used to configure the page.</param>
00052 void TilePinned::OnNavigatingFrom(NavigatingCancelEventArgs^ e)
00053 {
00054     // Restore the app bar
00055     rootPage->BottomAppBar = appBar;
00056 }
00057
00058 void SecondaryTiles::TilePinned::TileExists_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00059 {
00060     Button^ button = safe_cast<Button^>(sender);
00061     if (button != nullptr)
00062     {
00063         if (SecondaryTile::Exists(rootPage->tileId))
00064         {
00065             rootPage->NotifyUser(rootPage->tileId + " is Pinned.", NotifyType::StatusMessage);
00066         }
00067         else
00068         {
00069             rootPage->NotifyUser(rootPage->tileId + " not currently pinned.", NotifyType::ErrorMessage);
00070         }
00071     }
00072 }
Generated on Sat Nov 23 2024 16:08:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::WASAPIAudio::ToneSampleGenerator Member List

This is the complete list of members for SDKSample::WASAPIAudio::ToneSampleGenerator, including all inherited members.
FillSampleBuffer(UINT32 BytesToRead, BYTE *Data) | SDKSample::WASAPIAudio::ToneSampleGenerator |
Flush() | SDKSample::WASAPIAudio::ToneSampleGenerator |
GenerateSampleBuffer(DWORD Frequency, UINT32 FramesPerPeriod, WAVEFORMATEX *wfx) | SDKSample::WASAPIAudio::ToneSampleGenerator |
GenerateSineSamples(BYTE *Buffer, size_t BufferLength, DWORD Frequency, WORD ChannelCount, DWORD SamplesPerSecond, double Amplitude, double *InitialTheta) | SDKSample::WASAPIAudio::ToneSampleGenerator | [private]
GetBufferLength() | SDKSample::WASAPIAudio::ToneSampleGenerator | [inline]
IsEOF() | SDKSample::WASAPIAudio::ToneSampleGenerator | [inline]
m_SampleQueue | SDKSample::WASAPIAudio::ToneSampleGenerator | [private]
m_SampleQueueTail | SDKSample::WASAPIAudio::ToneSampleGenerator | [private]
ToneSampleGenerator() | SDKSample::WASAPIAudio::ToneSampleGenerator |
~ToneSampleGenerator() | SDKSample::WASAPIAudio::ToneSampleGenerator |
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Animation metrics/C++/Scenario1.xaml.h Source File

  • Animation metrics

Scenario1.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario1.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace AnimationMetrics
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario1 sealed
00031         {
00032         public:
00033             Scenario1();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039             void DisplayMetrics(Windows::UI::Core::AnimationMetrics::AnimationEffect effect, Windows::UI::Core::AnimationMetrics::AnimationEffectTarget target);
00040             void Animations_SelectionChanged(Platform::Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:49 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectWrite custom text renderer/C++/DirectXBase.cpp Source File

  • DirectWrite custom text renderer

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D save to image file/C++/SampleOverlay.cpp Source File

  • Direct2D save to image file

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

NotificationsExtensions::TileContent::TileWideImageCollection Member List

This is the complete list of members for NotificationsExtensions::TileContent::TileWideImageCollection, including all inherited members.
AddImageQuery | NotificationsExtensions::NotificationBase |
AddImageQueryNullable | NotificationsExtensions::NotificationBase |
BaseUri | NotificationsExtensions::NotificationBase |
Branding | NotificationsExtensions::TileContent::TileNotificationBase |
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
CreateNotification() | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetContent() | NotificationsExtensions::TileContent::TileWideBase | [inline, virtual]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
GetXml() | NotificationsExtensions::NotificationBase | [inline]
ImageMain | NotificationsExtensions::TileContent::TileWideImageCollection |
Images | NotificationsExtensions::NotificationBase |
ImageSmallColumn1Row1 | NotificationsExtensions::TileContent::TileWideImageCollection |
ImageSmallColumn1Row2 | NotificationsExtensions::TileContent::TileWideImageCollection |
ImageSmallColumn2Row1 | NotificationsExtensions::TileContent::TileWideImageCollection |
ImageSmallColumn2Row2 | NotificationsExtensions::TileContent::TileWideImageCollection |
Lang | NotificationsExtensions::NotificationBase |
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
NotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::NotificationBase | [inline, protected]
RequireSquareContent | NotificationsExtensions::TileContent::TileWideBase |
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SerializeProperties(string globalLang, string globalBaseUri, bool globalAddImageQuery) | NotificationsExtensions::NotificationBase | [inline, protected]
SquareContent | NotificationsExtensions::TileContent::TileWideBase |
StrictValidation | NotificationsExtensions::NotificationBase |
TemplateName | NotificationsExtensions::NotificationBase |
TextFields | NotificationsExtensions::NotificationBase |
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileNotificationBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileNotificationBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideBase(string templateName, int imageCount, int textCount) | NotificationsExtensions::TileContent::TileWideBase | [inline]
TileWideImageCollection() | NotificationsExtensions::TileContent::TileWideImageCollection | [inline]
TileWideImageCollection() | NotificationsExtensions::TileContent::TileWideImageCollection | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
ToString() | NotificationsExtensions::NotificationBase | [inline]
Generated on Sat Nov 23 2024 16:09:44 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media engine native C++ video playback/C++/frameworkview.h Source File

  • Media engine native C++ video playback

frameworkview.h

Go to the documentation of this file.
00001 #pragma once
00002 #include <agile.h>
00003
00004 #include <agile.h>
00005
00006 enum class ActivationEntryPoint
00007 {
00008     Unknown,
00009     MEPlaybackNative
00010 };
00011
00012 ref class FrameworkView sealed : public Windows::ApplicationModel::Core::IFrameworkView
00013 {
00014 public:
00015     FrameworkView();
00016
00017     virtual void Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^ applicationView);
00018     virtual void SetWindow(_In_ Windows::UI::Core::CoreWindow^ window);
00019     virtual void Load(Platform::String^ entryPoint);
00020     virtual void Run();
00021     virtual void Uninitialize();
00022
00023 private:
00024     ActivationEntryPoint m_activationEntryPoint;
00025     Platform::Agile<Windows::UI::Core::CoreWindow> m_window;
00026     Platform::Agile<Windows::ApplicationModel::Core::CoreApplicationView> m_applicationView;
00027 };
00028
00029 ref class FrameworkViewSource sealed : Windows::ApplicationModel::Core::IFrameworkViewSource
00030 {
00031 public:
00032     FrameworkViewSource() {}
00033     virtual Windows::ApplicationModel::Core::IFrameworkView^ CreateView()
00034     {
00035         return ref new FrameworkView();
00036     }
00037 };
Generated on Sat Nov 23 2024 16:08:20 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Hilo C++/C++/Hilo/CropImageView.xaml.h Source File

  • Hilo C++
  • Hilo

CropImageView.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 #pragma once
00008
00009 #include "Common\BooleanToVisibilityConverter.h" // Required by generated header
00010 #include "CropImageView.g.h"
00011
00012 namespace Hilo
00013 {
00014     // See http://go.microsoft.com/fwlink/?LinkId=267278 for info on how Hilo creates pages and navigates to pages.
00015
00016     // See http://go.microsoft.com/fwlink/?LinkId=267276 for info on how view classes interact
00017     // with corresponding view model classes that encapsulate the app’s state, actions, and operations.
00018
00019     // See http://go.microsoft.com/fwlink/?LinkId=267279 for info on how Hilo pages use XAML controls.
00020
00021     ref class CropImageViewModel;
00022
00023     // The CropImageView class implements the app's crop page.
00024     public ref class CropImageView sealed
00025     {
00026     public:
00027         CropImageView();
00028
00029     private:
00030         CropImageViewModel^ m_cropImageViewModel;
00031         bool m_sizeChangedAttached;
00032
00033         void OnCropRectangleTapped(Platform::Object^ sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^ e);
00034         void OnThumbDragDelta(Platform::Object^ sender, Windows::UI::Xaml::Controls::Primitives::DragDeltaEventArgs^ e);
00035         void OnSizeChanged(Platform::Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00036     };
00037 }
00038
00039
00040
00041
00042
Generated on Sat Nov 23 2024 16:08:17 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML DirectX 3D shooting game/C++/DirectXSample.h Source File

  • XAML DirectX 3D shooting game

DirectXSample.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 // This header defines helper utilities to make DirectX APIs work with exceptions.
00011 namespace DX
00012 {
00013     inline void ThrowIfFailed(HRESULT hr)
00014     {
00015         if (FAILED(hr))
00016         {
00017             // Set a breakpoint on this line to catch DX API errors.
00018             throw Platform::Exception::CreateException(hr);
00019         }
00020     }
00021 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML vector-based drawing/C++/MainPage.xaml.cpp Source File

  • XAML vector-based drawing

MainPage.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.cpp
00013 // Implementation of the MainPage.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "App.xaml.h"
00019
00020 #include <collection.h>
00021
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::Foundation;
00025 using namespace Windows::Foundation::Collections;
00026 using namespace Platform;
00027 using namespace SDKSample;
00028 using namespace Windows::UI::Xaml::Navigation;
00029 using namespace Windows::UI::Xaml::Interop;
00030 using namespace Windows::Graphics::Display;
00031 using namespace Windows::UI::ViewManagement;
00032
00033 MainPage^ MainPage::Current = nullptr;
00034
00035 MainPage::MainPage()
00036 {
00037     InitializeComponent();
00038
00039     // This frame is hidden, meaning it is never shown.  It is simply used to load
00040     // each scenario page and then pluck out the input and output sections and
00041     // place them into the UserControls on the main page.
00042     HiddenFrame = ref new Windows::UI::Xaml::Controls::Frame();
00043     HiddenFrame->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00044     ContentRoot->Children->Append(HiddenFrame);
00045
00046     FeatureName->Text = FEATURE_NAME;
00047
00048     this->SizeChanged += ref new SizeChangedEventHandler(this, &MainPage::MainPage_SizeChanged);
00049     Scenarios->SelectionChanged += ref new SelectionChangedEventHandler(this, &MainPage::Scenarios_SelectionChanged);
00050
00051     MainPage::Current = this;
00052     autoSizeInputSectionWhenSnapped = true;
00053 }
00054
00055 /// <summary>
00056 /// We need to handle SizeChanged so that we can make the sample layout property
00057 /// in the various layouts.
00058 /// </summary>
00059 /// <param name="sender"></param>
00060 /// <param name="e"></param>
00061 void MainPage::MainPage_SizeChanged(Object^ sender, SizeChangedEventArgs^ e)
00062 {
00063     InvalidateSize();
00064     MainPageSizeChangedEventArgs^ args = ref new MainPageSizeChangedEventArgs();
00065     args->ViewState = ApplicationView::Value;
00066     MainPageResized(this, args);
00067
00068 }
00069
00070 void MainPage::InvalidateSize()
00071 {
00072     // Get the window width
00073     double windowWidth = this->ActualWidth;
00074
00075     if (windowWidth != 0.0)
00076     {
00077         // Get the width of the ListBox.
00078         double listBoxWidth = Scenarios->ActualWidth;
00079
00080         // Is the ListBox using any margins that we need to consider?
00081         double listBoxMarginLeft = Scenarios->Margin.Left;
00082         double listBoxMarginRight = Scenarios->Margin.Right;
00083
00084         // Figure out how much room is left after considering the list box width
00085         double availableWidth = windowWidth - listBoxWidth;
00086
00087         // Is the top most child using margins?
00088         double layoutRootMarginLeft = ContentRoot->Margin.Left;
00089         double layoutRootMarginRight = ContentRoot->Margin.Right;
00090
00091         // We have different widths to use depending on the view state
00092         if (ApplicationView::Value != ApplicationViewState::Snapped)
00093         {
00094             // Make us as big as the the left over space, factoring in the ListBox width, the ListBox margins.
00095             // and the LayoutRoot's margins
00096             InputSection->Width = ((availableWidth) -
00097                 (layoutRootMarginLeft + layoutRootMarginRight + listBoxMarginLeft + listBoxMarginRight));
00098         }
00099         else
00100         {
00101             // Make us as big as the left over space, factoring in just the LayoutRoot's margins.
00102             if (autoSizeInputSectionWhenSnapped)
00103             {
00104                 InputSection->Width = (windowWidth - (layoutRootMarginLeft + layoutRootMarginRight));
00105             }
00106         }
00107     }
00108     InvalidateViewState();
00109 }
00110
00111 void MainPage::InvalidateViewState()
00112 {
00113     // Are we going to snapped mode?
00114     if (ApplicationView::Value == ApplicationViewState::Snapped)
00115     {
00116         Grid::SetRow(DescriptionText, 3);
00117         Grid::SetColumn(DescriptionText, 0);
00118
00119         Grid::SetRow(InputSection, 4);
00120         Grid::SetColumn(InputSection, 0);
00121
00122         Grid::SetRow(FooterPanel, 2);
00123         Grid::SetColumn(FooterPanel, 0);
00124     }
00125     else
00126     {
00127         Grid::SetRow(DescriptionText, 1);
00128         Grid::SetColumn(DescriptionText, 1);
00129
00130         Grid::SetRow(InputSection, 2);
00131         Grid::SetColumn(InputSection, 1);
00132
00133         Grid::SetRow(FooterPanel, 1);
00134         Grid::SetColumn(FooterPanel, 1);
00135     }
00136
00137     //  Since we don't load the scenario page in the traditional manner (we just pluck out the
00138     // input and output sections from the page) we need to ensure that any VSM code used
00139     // by the scenario's input and output sections is fired.
00140     VisualStateManager::GoToState(InputSection, "Input" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00141     VisualStateManager::GoToState(OutputSection, "Output" + LayoutAwarePage::DetermineVisualState(ApplicationView::Value), false);
00142 }
00143
00144 void MainPage::PopulateScenarios()
00145 {
00146     ScenarioList = ref new Platform::Collections::Vector<Object^>();
00147
00148     // Populate the ListBox with the list of scenarios as defined in Constants.cpp.
00149     for (unsigned int i = 0; i < scenarios->Length; ++i)
00150     {
00151         Scenario s = scenarios[i];
00152         ListBoxItem^ item = ref new ListBoxItem();
00153         item->Name = s.ClassName;
00154         item->Content = (i + 1).ToString() + ") " + s.Title;
00155         ScenarioList->Append(item);
00156     }
00157
00158     // Bind the ListBox to the scenario list.
00159     Scenarios->ItemsSource = ScenarioList;
00160     Scenarios->ScrollIntoView(Scenarios->SelectedItem);
00161 }
00162
00163 /// <summary>
00164 /// This method is responsible for loading the individual input and output sections for each scenario.  This
00165 /// is based on navigating a hidden Frame to the ScenarioX.xaml page and then extracting out the input
00166 /// and output sections into the respective UserControl on the main page.
00167 /// </summary>
00168 /// <param name="scenarioName"></param>
00169 void MainPage::LoadScenario(String^ scenarioName)
00170 {
00171     autoSizeInputSectionWhenSnapped = true;
00172
00173     // Load the ScenarioX.xaml file into the Frame.
00174     TypeName scenarioType = {scenarioName, TypeKind::Custom};
00175     HiddenFrame->Navigate(scenarioType, this);
00176
00177     // Get the top element, the Page, so we can look up the elements
00178     // that represent the input and output sections of the ScenarioX file.
00179     Page^ hiddenPage = safe_cast<Page^>(HiddenFrame->Content);
00180
00181     // Get each element.
00182     UIElement^ input = safe_cast<UIElement^>(hiddenPage->FindName("Input"));
00183     UIElement^ output = safe_cast<UIElement^>(hiddenPage->FindName("Output"));
00184
00185     if (input == nullptr)
00186     {
00187         // Malformed input section.
00188         NotifyUser("Cannot load scenario input section for " + scenarioName +
00189             "  Make sure root of input section markup has x:Name of 'Input'", NotifyType::ErrorMessage);
00190         return;
00191     }
00192
00193     if (output == nullptr)
00194     {
00195         // Malformed output section.
00196         NotifyUser("Cannot load scenario output section for " + scenarioName +
00197             "  Make sure root of output section markup has x:Name of 'Output'", NotifyType::ErrorMessage);
00198         return;
00199     }
00200
00201     // Find the LayoutRoot which parents the input and output sections in the main page.
00202     Panel^ panel = safe_cast<Panel^>(hiddenPage->FindName("LayoutRoot"));
00203
00204     if (panel != nullptr)
00205     {
00206         unsigned int index = 0;
00207         UIElementCollection^ collection = panel->Children;
00208
00209         // Get rid of the content that is currently in the intput and output sections.
00210         collection->IndexOf(input, &index);
00211         collection->RemoveAt(index);
00212
00213         collection->IndexOf(output, &index);
00214         collection->RemoveAt(index);
00215
00216         // Populate the input and output sections with the newly loaded content.
00217         InputSection->Content = input;
00218         OutputSection->Content = output;
00219
00220         ScenarioLoaded(this, nullptr);
00221     }
00222     else
00223     {
00224         // Malformed Scenario file.
00225         NotifyUser("Cannot load scenario: " + scenarioName + ".  Make sure root tag in the '" +
00226             scenarioName + "' file has an x:Name of 'LayoutRoot'", NotifyType::ErrorMessage);
00227     }
00228 }
00229
00230 void MainPage::Scenarios_SelectionChanged(Object^ sender, SelectionChangedEventArgs^ e)
00231 {
00232     if (Scenarios->SelectedItem != nullptr)
00233     {
00234         NotifyUser("", NotifyType::StatusMessage);
00235
00236         LoadScenario((safe_cast<ListBoxItem^>(Scenarios->SelectedItem))->Name);
00237         InvalidateSize();
00238     }
00239 }
00240
00241 void MainPage::NotifyUser(String^ strMessage, NotifyType type)
00242 {
00243     switch (type)
00244     {
00245     case NotifyType::StatusMessage:
00246         // Use the status message style.
00247         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("StatusStyle"));
00248         break;
00249     case NotifyType::ErrorMessage:
00250         // Use the error message style.
00251         StatusBlock->Style = safe_cast<Windows::UI::Xaml::Style^>(this->Resources->Lookup("ErrorStyle"));
00252         break;
00253     default:
00254         break;
00255     }
00256     StatusBlock->Text = strMessage;
00257
00258     // Collapsed the StatusBlock if it has no text to conserve real estate.
00259     if (StatusBlock->Text != "")
00260     {
00261         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Visible;
00262     }
00263     else
00264     {
00265         StatusBlock->Visibility = Windows::UI::Xaml::Visibility::Collapsed;
00266     }
00267 }
00268
00269 void MainPage::Footer_Click(Object^ sender, RoutedEventArgs^ e)
00270 {
00271     auto uri = ref new Uri((String^)((HyperlinkButton^)sender)->Tag);
00272     Windows::System::Launcher::LaunchUriAsync(uri);
00273 }
00274
00275
00276 /// <summary>
00277 /// Populates the page with content passed during navigation.  Any saved state is also
00278 /// provided when recreating a page from a prior session.
00279 /// </summary>
00280 /// <param name="navigationParameter">The parameter value passed to
00281 /// <see cref="Frame::Navigate(Type, Object)"/> when this page was initially requested.
00282 /// </param>
00283 /// <param name="pageState">A map of state preserved by this page during an earlier
00284 /// session.  This will be null the first time a page is visited.</param>
00285 void MainPage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00286 {
00287     (void) navigationParameter; // Unused parameter
00288
00289     PopulateScenarios();
00290
00291     // Starting scenario is the first or based upon a previous state.
00292     ListBoxItem^ startingScenario = nullptr;
00293     int startingScenarioIndex = -1;
00294
00295     if (pageState != nullptr && pageState->HasKey("SelectedScenarioIndex"))
00296     {
00297         startingScenarioIndex = safe_cast<int>(pageState->Lookup("SelectedScenarioIndex"));
00298     }
00299
00300     Scenarios->SelectedIndex = startingScenarioIndex != -1 ? startingScenarioIndex : 0;
00301
00302     InvalidateViewState();
00303 }
00304
00305 /// <summary>
00306 /// Preserves state associated with this page in case the application is suspended or the
00307 /// page is discarded from the navigation cache.  Values must conform to the serialization
00308 /// requirements of <see cref="SuspensionManager::SessionState"/>.
00309 /// </summary>
00310 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00311 void MainPage::SaveState(IMap<String^, Object^>^ pageState)
00312 {
00313     int selectedListBoxItemIndex = Scenarios->SelectedIndex;
00314     pageState->Insert("SelectedScenarioIndex", selectedListBoxItemIndex);
00315 }
Generated on Sat Nov 23 2024 16:07:45 for Win8-Examples by doxygen 1.7.1


Win8-Examples: LightSensor/C++/common/suspensionmanager.cpp Source File

  • LightSensor
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX touch input/C++/BasicMath.h Source File

  • DirectX touch input

BasicMath.h

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #pragma once
00009
00010 #define _USE_MATH_DEFINES
00011 #include <math.h>
00012
00013 // This header defines math and matrix helper functions and structures used
00014 // by DirectX SDK samples.
00015
00016 // Common Constants
00017
00018 #define PI_F 3.1415927f
00019
00020 // Template Vector & Matrix Classes
00021
00022 template <class T> struct Vector2
00023 {
00024     union
00025     {
00026         struct
00027         {
00028             T x;
00029             T y;
00030         };
00031         struct
00032         {
00033             T r;
00034             T g;
00035         };
00036         struct
00037         {
00038             T u;
00039             T v;
00040         };
00041     };
00042
00043     T& operator[](unsigned int index)
00044     {
00045         return static_cast<T*>(this)[index];
00046     }
00047
00048     Vector2(T _x = 0, T _y = 0) : x(_x), y(_y) { }
00049 };
00050
00051 template <class T> struct Vector3
00052 {
00053     union
00054     {
00055         struct
00056         {
00057             T x;
00058             T y;
00059             T z;
00060         };
00061         struct
00062         {
00063             T r;
00064             T g;
00065             T b;
00066         };
00067         struct
00068         {
00069             T u;
00070             T v;
00071             T w;
00072         };
00073     };
00074
00075     T& operator[](unsigned int index)
00076     {
00077         return static_cast<T*>(this)[index];
00078     }
00079
00080     Vector3(T _x = 0, T _y = 0, T _z = 0) : x(_x), y(_y), z(_z) { }
00081 };
00082
00083 template <class T> struct Vector4
00084 {
00085     union
00086     {
00087         struct
00088         {
00089             T x;
00090             T y;
00091             T z;
00092             T w;
00093         };
00094         struct
00095         {
00096             T r;
00097             T g;
00098             T b;
00099             T a;
00100         };
00101     };
00102
00103     T& operator[](unsigned int index)
00104     {
00105         return static_cast<T*>(this)[index];
00106     }
00107
00108     Vector4(T _x = 0, T _y = 0, T _z = 0, T _w = 0) : x(_x), y(_y), z(_z), w(_w) { }
00109 };
00110
00111 template <class T> struct Matrix4x4
00112 {
00113     union
00114     {
00115         struct
00116         {
00117             T _11; T _12; T _13; T _14;
00118             T _21; T _22; T _23; T _24;
00119             T _31; T _32; T _33; T _34;
00120             T _41; T _42; T _43; T _44;
00121         };
00122         struct
00123         {
00124             T _m00; T _m01; T _m02; T _m03;
00125             T _m10; T _m11; T _m12; T _m13;
00126             T _m20; T _m21; T _m22; T _m23;
00127             T _m30; T _m31; T _m32; T _m33;
00128         };
00129     };
00130
00131     Matrix4x4(T value = 0)
00132     {
00133         _11 = _12 = _13 = _14 = value;
00134         _21 = _22 = _23 = _24 = value;
00135         _31 = _32 = _33 = _34 = value;
00136         _41 = _42 = _43 = _44 = value;
00137     }
00138
00139     Matrix4x4(
00140         T i11, T i12, T i13, T i14,
00141         T i21, T i22, T i23, T i24,
00142         T i31, T i32, T i33, T i34,
00143         T i41, T i42, T i43, T i44
00144         )
00145     {
00146         _11 = i11; _12 = i12; _13 = i13; _14 = i14;
00147         _21 = i21; _22 = i22; _23 = i23; _24 = i24;
00148         _31 = i31; _32 = i32; _33 = i33; _34 = i34;
00149         _41 = i41; _42 = i42; _43 = i43; _44 = i44;
00150     }
00151
00152     T* operator[](unsigned int index)
00153     {
00154         return &(reinterpret_cast<T*>(this)[index*4]);
00155     }
00156 };
00157
00158 // Template Vector Operations
00159
00160 template <class T>
00161 T dot(Vector2<T> a, Vector2<T> b)
00162 {
00163     return a.x * b.x + a.y * b.y;
00164 }
00165
00166 template <class T>
00167 T dot(Vector3<T> a, Vector3<T> b)
00168 {
00169     return a.x * b.x + a.y * b.y + a.z * b.z;
00170 }
00171
00172 template <class T>
00173 T dot(Vector4<T> a, Vector4<T> b)
00174 {
00175     return a.x * b.x + a.y * b.y + a.z * b.z + a.w + b.w;
00176 }
00177
00178 template <class T>
00179 T length(Vector2<T> a)
00180 {
00181     return sqrt(a.x * a.x + a.y * a.y);
00182 }
00183
00184 template <class T>
00185 T length(Vector3<T> a)
00186 {
00187     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z);
00188 }
00189
00190 template <class T>
00191 T length(Vector4<T> a)
00192 {
00193     return sqrt(a.x * a.x + a.y * a.y + a.z * a.z + a.w * a.w);
00194 }
00195
00196 template <class T>
00197 Vector3<T> cross(Vector3<T> a, Vector3<T> b)
00198 {
00199     return Vector3<T>((a.y*b.z)-(a.z*b.y), (a.z*b.x)-(a.x*b.z), (a.x*b.y)-(a.y*b.x));
00200 }
00201
00202 template <class T>
00203 Vector2<T> normalize(Vector2<T> a)
00204 {
00205     T len = length(a);
00206     return Vector2<T>(a.x / len, a.y / len);
00207 }
00208
00209 template <class T>
00210 Vector3<T> normalize(Vector3<T> a)
00211 {
00212     T len = length(a);
00213     return Vector3<T>(a.x / len, a.y / len, a.z / len);
00214 }
00215
00216 template <class T>
00217 Vector4<T> normalize(Vector4<T> a)
00218 {
00219     T len = length(a);
00220     return Vector4<T>(a.x / len, a.y / len, a.z / len, a.w / len);
00221 }
00222
00223 // Template Vector Operators
00224
00225 template <class T>
00226 Vector2<T> operator-(Vector2<T> a, Vector2<T> b)
00227 {
00228     return Vector2<T>(a.x - b.x, a.y - b.y);
00229 }
00230
00231 template <class T>
00232 Vector2<T> operator-(Vector2<T> a)
00233 {
00234     return Vector2<T>(-a.x, -a.y);
00235 }
00236
00237 template <class T>
00238 Vector3<T> operator-(Vector3<T> a, Vector3<T> b)
00239 {
00240     return Vector3<T>(a.x - b.x, a.y - b.y, a.z - b.z);
00241 }
00242
00243 template <class T>
00244 Vector3<T> operator-(Vector3<T> a)
00245 {
00246     return Vector3<T>(-a.x, -a.y, -a.z);
00247 }
00248
00249 template <class T>
00250 Vector4<T> operator-(Vector4<T> a, Vector4<T> b)
00251 {
00252     return Vector4<T>(a.x - b.x, a.y - b.y, a.z - b.z, a.w - b.w);
00253 }
00254
00255 template <class T>
00256 Vector4<T> operator-(Vector4<T> a)
00257 {
00258     return Vector4<T>(-a.x, -a.y, -a.z, -a.w);
00259 }
00260
00261 template <class T>
00262 Vector2<T> operator+(Vector2<T> a, Vector2<T> b)
00263 {
00264     return Vector2<T>(a.x + b.x, a.y + b.y);
00265 }
00266
00267 template <class T>
00268 Vector3<T> operator+(Vector3<T> a, Vector3<T> b)
00269 {
00270     return Vector3<T>(a.x + b.x, a.y + b.y, a.z + b.z);
00271 }
00272
00273 template <class T>
00274 Vector4<T> operator+(Vector4<T> a, Vector4<T> b)
00275 {
00276     return Vector4<T>(a.x + b.x, a.y + b.y, a.z + b.z, a.w + b.w);
00277 }
00278
00279 template <class T>
00280 Vector2<T> operator*(Vector2<T> a, T s)
00281 {
00282     return Vector2<T>(a.x * s, a.y * s);
00283 }
00284
00285 template <class T>
00286 Vector2<T> operator*(T s, Vector2<T> a)
00287 {
00288     return a * s;
00289 }
00290
00291 template <class T>
00292 Vector2<T> operator*(Vector2<T> a, Vector2<T> b)
00293 {
00294     return Vector2<T>(a.x * b.x, a.y * b.y);
00295 }
00296
00297 template <class T>
00298 Vector2<T> operator/(Vector2<T> a, T s)
00299 {
00300     return Vector2<T>(a.x / s, a.y / s);
00301 }
00302
00303 template <class T>
00304 Vector3<T> operator*(Vector3<T> a, T s)
00305 {
00306     return Vector3<T>(a.x * s, a.y * s, a.z * s);
00307 }
00308
00309 template <class T>
00310 Vector3<T> operator*(T s, Vector3<T> a)
00311 {
00312     return a * s;
00313 }
00314
00315 template <class T>
00316 Vector3<T> operator*(Vector3<T> a, Vector3<T> b)
00317 {
00318     return Vector3<T>(a.x * b.x, a.y * b.y, a.z * b.z);
00319 }
00320
00321 template <class T>
00322 Vector3<T> operator/(Vector3<T> a, T s)
00323 {
00324     return Vector3<T>(a.x / s, a.y / s, a.z / s);
00325 }
00326
00327 template <class T>
00328 Vector4<T> operator*(Vector4<T> a, T s)
00329 {
00330     return Vector4<T>(a.x * s, a.y * s, a.z * s, a.w * s);
00331 }
00332
00333 template <class T>
00334 Vector4<T> operator*(T s, Vector4<T> a)
00335 {
00336     return a * s;
00337 }
00338
00339 template <class T>
00340 Vector4<T> operator*(Vector4<T> a, Vector4<T> b)
00341 {
00342     return Vector4<T>(a.x * b.x, a.y * b.y, a.z * b.z, a.w * b.w);
00343 }
00344
00345 template <class T>
00346 Vector4<T> operator/(Vector4<T> a, T s)
00347 {
00348     return Vector4<T>(a.x / s, a.y / s, a.z / s, a.w / s);
00349 }
00350
00351
00352
00353 // Template Matrix Operations
00354
00355 template <class T>
00356 Matrix4x4<T> transpose(Matrix4x4<T> m)
00357 {
00358     return Matrix4x4<T>(
00359         m._11, m._21, m._31, m._41,
00360         m_.12, m._22, m._32, m._42,
00361         m._13, m._23, m._33, m._43,
00362         m._14, m._24, m._34, m._44
00363         );
00364 }
00365
00366 template <class T>
00367 Matrix4x4<T> mul(Matrix4x4<T> m1, Matrix4x4<T> m2)
00368 {
00369     Matrix4x4<T> mOut;
00370
00371     for (int i = 0; i < 4; i++)
00372     {
00373         for (int j = 0; j < 4; j++)
00374         {
00375             for (int k = 0; k < 4; k++)
00376             {
00377                 mOut[i][j] += m1[i][k] * m2[k][j];
00378             }
00379         }
00380     }
00381
00382     return mOut;
00383 }
00384
00385 // Common HLSL-compatible vector typedefs
00386
00387 typedef unsigned int uint;
00388
00389 typedef Vector2<float> float2;
00390 typedef Vector3<float> float3;
00391 typedef Vector4<float> float4;
00392
00393 typedef Matrix4x4<float> float4x4;
00394
00395 // Standard Matrix Intializers
00396
00397 inline float4x4 identity()
00398 {
00399     float4x4 mOut;
00400
00401     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00402     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = 0.0f;
00403     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = 0.0f;
00404     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00405
00406     return mOut;
00407 }
00408
00409 inline float4x4 translation(float x, float y, float z)
00410 {
00411     float4x4 mOut;
00412
00413     mOut._11 = 1.0f; mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = x;
00414     mOut._21 = 0.0f; mOut._22 = 1.0f; mOut._23 = 0.0f; mOut._24 = y;
00415     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = 1.0f; mOut._34 = z;
00416     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00417
00418     return mOut;
00419 }
00420
00421 inline float4x4 scale(float x, float y, float z)
00422 {
00423     float4x4 mOut;
00424
00425     mOut._11 = x;    mOut._12 = 0.0f; mOut._13 = 0.0f; mOut._14 = 0.0f;
00426     mOut._21 = 0.0f; mOut._22 = y;    mOut._23 = 0.0f; mOut._24 = 0.0f;
00427     mOut._31 = 0.0f; mOut._32 = 0.0f; mOut._33 = z;    mOut._34 = 0.0f;
00428     mOut._41 = 0.0f; mOut._42 = 0.0f; mOut._43 = 0.0f; mOut._44 = 1.0f;
00429
00430     return mOut;
00431 }
00432
00433 inline float4x4 rotationX(float degreeX)
00434 {
00435     float angleInRadians = degreeX * (PI_F / 180.0f);
00436
00437     float sinAngle = sinf(angleInRadians);
00438     float cosAngle = cosf(angleInRadians);
00439
00440     float4x4 mOut;
00441
00442     mOut._11 = 1.0f; mOut._12 = 0.0f;     mOut._13 = 0.0f;      mOut._14 = 0.0f;
00443     mOut._21 = 0.0f; mOut._22 = cosAngle; mOut._23 = -sinAngle; mOut._24 = 0.0f;
00444     mOut._31 = 0.0f; mOut._32 = sinAngle; mOut._33 = cosAngle;  mOut._34 = 0.0f;
00445     mOut._41 = 0.0f; mOut._42 = 0.0f;     mOut._43 = 0.0f;      mOut._44 = 1.0f;
00446
00447     return mOut;
00448 }
00449
00450 inline float4x4 rotationY(float degreeY)
00451 {
00452     float angleInRadians = degreeY * (PI_F / 180.0f);
00453
00454     float sinAngle = sinf(angleInRadians);
00455     float cosAngle = cosf(angleInRadians);
00456
00457     float4x4 mOut;
00458
00459     mOut._11 = cosAngle;  mOut._12 = 0.0f; mOut._13 = sinAngle; mOut._14 = 0.0f;
00460     mOut._21 = 0.0f;      mOut._22 = 1.0f; mOut._23 = 0.0f;     mOut._24 = 0.0f;
00461     mOut._31 = -sinAngle; mOut._32 = 0.0f; mOut._33 = cosAngle; mOut._34 = 0.0f;
00462     mOut._41 = 0.0f;      mOut._42 = 0.0f; mOut._43 = 0.0f;     mOut._44 = 1.0f;
00463
00464     return mOut;
00465 }
00466
00467 inline float4x4 rotationZ(float degreeZ)
00468 {
00469     float angleInRadians = degreeZ * (PI_F / 180.0f);
00470
00471     float sinAngle = sinf(angleInRadians);
00472     float cosAngle = cosf(angleInRadians);
00473
00474     float4x4 mOut;
00475
00476     mOut._11 = cosAngle; mOut._12 = -sinAngle; mOut._13 = 0.0f; mOut._14 = 0.0f;
00477     mOut._21 = sinAngle; mOut._22 = cosAngle;  mOut._23 = 0.0f; mOut._24 = 0.0f;
00478     mOut._31 = 0.0f;     mOut._32 = 0.0f;      mOut._33 = 1.0f; mOut._34 = 0.0f;
00479     mOut._41 = 0.0f;     mOut._42 = 0.0f;      mOut._43 = 0.0f; mOut._44 = 1.0f;
00480
00481     return mOut;
00482 }
00483
00484 // 3D Rotation matrix for an arbitrary axis specified by x, y and z
00485 inline float4x4 rotationArbitrary(float3 axis, float degree)
00486 {
00487     axis = normalize(axis);
00488
00489     float angleInRadians = degree * (PI_F / 180.0f);
00490
00491     float sinAngle = sinf(angleInRadians);
00492     float cosAngle = cosf(angleInRadians);
00493     float oneMinusCosAngle = 1 - cosAngle;
00494
00495     float4x4 mOut;
00496
00497     mOut._11 = 1.0f + oneMinusCosAngle * (axis.x * axis.x - 1.0f);
00498     mOut._12 = axis.z * sinAngle + oneMinusCosAngle * axis.x * axis.y;
00499     mOut._13 = -axis.y * sinAngle + oneMinusCosAngle * axis.x * axis.z;
00500     mOut._41 = 0.0f;
00501
00502     mOut._21 = -axis.z * sinAngle + oneMinusCosAngle * axis.y * axis.x;
00503     mOut._22 = 1.0f + oneMinusCosAngle * (axis.y * axis.y - 1.0f);
00504     mOut._23 = axis.x * sinAngle + oneMinusCosAngle * axis.y * axis.z;
00505     mOut._24 = 0.0f;
00506
00507     mOut._31 = axis.y * sinAngle + oneMinusCosAngle * axis.z * axis.x;
00508     mOut._32 = -axis.x * sinAngle + oneMinusCosAngle * axis.z * axis.y;
00509     mOut._33 = 1.0f + oneMinusCosAngle * (axis.z * axis.z - 1.0f);
00510     mOut._34 = 0.0f;
00511
00512     mOut._41 = 0.0f;
00513     mOut._42 = 0.0f;
00514     mOut._43 = 0.0f;
00515     mOut._44 = 1.0f;
00516
00517     return mOut;
00518 }
Generated on Sat Nov 23 2024 16:08:08 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

TextureLock Member List

This is the complete list of members for TextureLock, including all inherited members.
_bLocked | TextureLock | [private]
_pContext | TextureLock | [private]
_pTex | TextureLock | [private]
_uiIndex | TextureLock | [private]
Map(UINT uiIndex, D3D11_MAP mapType, UINT mapFlags) | TextureLock | [inline]
Map(UINT uiIndex, D3D11_MAP mapType, UINT mapFlags) | TextureLock | [inline]
map | TextureLock |
TextureLock(ID3D11DeviceContext *pContext, ID3D11Texture2D *pTex) | TextureLock | [inline]
TextureLock(ID3D11DeviceContext *pContext, ID3D11Texture2D *pTex) | TextureLock | [inline]
~TextureLock() | TextureLock | [inline]
~TextureLock() | TextureLock | [inline]
Generated on Sat Nov 23 2024 16:09:24 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

BasicSprites::InstanceData Member List

This is the complete list of members for BasicSprites::InstanceData, including all inherited members.
color | BasicSprites::InstanceData
offset | BasicSprites::InstanceData
origin | BasicSprites::InstanceData
rotation | BasicSprites::InstanceData
Generated on Sat Nov 23 2024 16:09:35 for Win8-Examples by doxygen 1.7.1


Win8-Examples: SimpleOrientationSensor/C++/pch.h Source File

  • SimpleOrientationSensor

pch.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.h
00013 // Header for standard system include files.
00014 //
00015
00016 #pragma once
00017
00018 #include <collection.h>
00019 #include <ppltasks.h>
00020 #include "Common\LayoutAwarePage.h"
00021 #include "Common\SuspensionManager.h"
00022 #include "App.xaml.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/ScenarioInput1.xaml.h Source File

  • Language font mapping

ScenarioInput1.xaml.h

Go to the documentation of this file.
00001 ﻿// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // ScenarioInput1.xaml.h
00009 // Declaration of the ScenarioInput1 class.
00010 //
00011
00012 #pragma once
00013
00014 #include "pch.h"
00015 #include "ScenarioInput1.g.h"
00016 #include "MainPage.xaml.h"
00017
00018 namespace LanguageFontCPP
00019 {
00020     [Windows::Foundation::Metadata::WebHostHidden]
00021     public ref class ScenarioInput1 sealed
00022     {
00023     public:
00024         ScenarioInput1();
00025
00026     protected:
00027         virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00028         virtual void OnNavigatedFrom(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00029
00030     private:
00031         ~ScenarioInput1();
00032         MainPage^ rootPage;
00033         void rootPage_OutputFrameLoaded(Object^ sender, Object^ e);
00034         void ApplyFont_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00035         Windows::Foundation::EventRegistrationToken _frameLoadedToken;
00036
00037     FontInfoLocal^ _oriHeadingUI;
00038     FontInfoLocal^ _oriTextUI;
00039     };
00040 }
Generated on Sat Nov 23 2024 16:07:59 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D magazine app/C++/FontFileStream.cpp Source File

  • Direct2D magazine app

FontFileStream.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009
00010 FontFileStream::FontFileStream(_In_ Platform::Array<byte>^ data) :
00011     m_refCount(),
00012     m_data(data)
00013 {
00014 }
00015
00016 HRESULT STDMETHODCALLTYPE FontFileStream::QueryInterface(
00017     REFIID uuid,
00018     _Outptr_ void** object
00019     )
00020 {
00021     if (    uuid == IID_IUnknown
00022         ||  uuid == __uuidof(IDWriteFontFileStream)
00023         )
00024     {
00025         *object = this;
00026         AddRef();
00027         return S_OK;
00028     }
00029     else
00030     {
00031         *object = nullptr;
00032         return E_NOINTERFACE;
00033     }
00034 }
00035
00036 ULONG STDMETHODCALLTYPE FontFileStream::AddRef()
00037 {
00038     return static_cast<ULONG>(InterlockedIncrement(&m_refCount));
00039 }
00040
00041 ULONG STDMETHODCALLTYPE FontFileStream::Release()
00042 {
00043     ULONG newCount = static_cast<ULONG>(InterlockedDecrement(&m_refCount));
00044
00045     if (newCount == 0)
00046     {
00047         delete this;
00048     }
00049
00050     return newCount;
00051 }
00052
00053 HRESULT STDMETHODCALLTYPE FontFileStream::ReadFileFragment(
00054     _Outptr_result_bytebuffer_(fragmentSize) void const** fragmentStart,
00055     UINT64 fileOffset,
00056     UINT64 fragmentSize,
00057     _Out_ void** fragmentContext
00058     )
00059 {
00060     // The loader is responsible for doing a bounds check.
00061     if (    fileOffset <= m_data->Length
00062         &&  fragmentSize + fileOffset <= m_data->Length
00063         )
00064     {
00065         *fragmentStart = m_data->Data + static_cast<ULONG>(fileOffset);
00066         *fragmentContext = nullptr;
00067         return S_OK;
00068     }
00069     else
00070     {
00071         *fragmentStart = nullptr;
00072         *fragmentContext = nullptr;
00073         return E_FAIL;
00074     }
00075 }
00076
00077 void STDMETHODCALLTYPE FontFileStream::ReleaseFileFragment(
00078     _In_ void* fragmentContext
00079     )
00080 {
00081 }
00082
00083 HRESULT STDMETHODCALLTYPE FontFileStream::GetFileSize(
00084     _Out_ UINT64* fileSize
00085     )
00086 {
00087     *fileSize = m_data->Length;
00088     return S_OK;
00089 }
00090
00091 HRESULT STDMETHODCALLTYPE FontFileStream::GetLastWriteTime(
00092     _Out_ UINT64* lastWriteTime
00093     )
00094 {
00095     // The concept of last write time does not apply to this loader.
00096     *lastWriteTime = 0;
00097     return E_NOTIMPL;
00098 }
Generated on Sat Nov 23 2024 16:08:06 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Trial app and in-app purchase/C++/Constants.h Source File

  • Trial app and in-app purchase

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SDKSample
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ Title;
00020         Platform::String^ ClassName;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"In-app purchase and trial management sample");
00031             }
00032         }
00033
00034         static property Platform::Array<Scenario>^ scenarios
00035         {
00036             Platform::Array<Scenario>^ get()
00037             {
00038                 return scenariosInner;
00039             }
00040         }
00041     private:
00042         static Platform::Array<Scenario>^ scenariosInner;
00043     };
00044
00045
00046 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

DWriteVerticalText Member List

This is the complete list of members for DWriteVerticalText, including all inherited members.
__pad0__ | DWriteVerticalText |
CreateDeviceIndependentResources() override | DWriteVerticalText | [virtual]
CreateDeviceResources() override | DWriteVerticalText | [virtual]
CreateWindowSizeDependentResources() override | DWriteVerticalText | [virtual]
Initialize(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView) | DWriteVerticalText | [virtual]
Load(_In_ Platform::String^entryPoint) | DWriteVerticalText | [virtual]
m_blackBrush | DWriteVerticalText | [private]
m_flowLayout | DWriteVerticalText | [private]
m_flowLayoutSink | DWriteVerticalText | [private]
m_flowLayoutSource | DWriteVerticalText | [private]
m_fontName | DWriteVerticalText | [private]
m_fontSize | DWriteVerticalText | [private]
m_localeName | DWriteVerticalText | [private]
m_readingDirection | DWriteVerticalText | [private]
m_renderingParams | DWriteVerticalText | [private]
m_sampleOverlay | DWriteVerticalText | [private]
m_text | DWriteVerticalText | [private]
m_textFormat | DWriteVerticalText | [private]
m_textLayout | DWriteVerticalText | [private]
m_textLength | DWriteVerticalText | [private]
m_textTypography | DWriteVerticalText | [private]
OnActivated(_In_ Windows::ApplicationModel::Core::CoreApplicationView^applicationView, _In_ Windows::ApplicationModel::Activation::IActivatedEventArgs^args) | DWriteVerticalText | [private]
OnDisplayContentsInvalidated(_In_ Platform::Object^sender) | DWriteVerticalText | [private]
OnLogicalDpiChanged(_In_ Platform::Object^sender) | DWriteVerticalText | [private]
OnWindowSizeChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::WindowSizeChangedEventArgs^args) | DWriteVerticalText | [private]
Render() override | DWriteVerticalText | [virtual]
Run() | DWriteVerticalText | [virtual]
SetWindow(_In_ Windows::UI::Core::CoreWindow^window) | DWriteVerticalText | [virtual]
Uninitialize() | DWriteVerticalText | [virtual]
Generated on Sat Nov 23 2024 16:09:12 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

LonLatController Member List

This is the complete list of members for LonLatController, including all inherited members.
__pad0__ | LonLatController | [private]
args | LonLatController | [private]
get_LookPoint() | LonLatController | [private]
get_LookPoint() | LonLatController | [private]
get_Position() | LonLatController | [private]
get_Position() | LonLatController | [private]
Initialize(_In_ Windows::UI::Core::CoreWindow^window) | LonLatController | [private]
LoadInternalState(_In_ Windows::Foundation::Collections::IPropertySet^state) | LonLatController | [private]
LoadInternalState(_In_ Windows::Foundation::Collections::IPropertySet^state) | LonLatController | [private]
m_back | LonLatController | [private]
m_down | LonLatController | [private]
m_forward | LonLatController | [private]
m_lastDistance | LonLatController | [private]
m_latitude | LonLatController | [private]
m_left | LonLatController | [private]
m_longitude | LonLatController | [private]
m_lonLatCommand | LonLatController | [private]
m_lonLatInUse | LonLatController | [private]
m_lonLatLastDelta | LonLatController | [private]
m_lonLatLastPoint | LonLatController | [private]
m_lonLatLastPoint1 | LonLatController | [private]
m_lonLatLastPoint2 | LonLatController | [private]
m_lonLatPointerID | LonLatController | [private]
m_lonLatPointerID1 | LonLatController | [private]
m_lonLatPointerID2 | LonLatController | [private]
m_numPointersDown | LonLatController | [private]
m_position | LonLatController | [private]
m_radius | LonLatController | [private]
m_right | LonLatController | [private]
m_up | LonLatController | [private]
OnKeyDown(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args) | LonLatController | [private]
OnKeyDown(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args) | LonLatController | [private]
OnKeyUp(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args) | LonLatController | [private]
OnKeyUp(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::KeyEventArgs^args) | LonLatController | [private]
OnPointerMoved(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | LonLatController | [private]
OnPointerMoved(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | LonLatController | [private]
OnPointerPressed(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | LonLatController | [private]
OnPointerReleased(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | LonLatController | [private]
OnPointerReleased(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | LonLatController | [private]
OnPointerWheelChanged(_In_ Windows::UI::Core::CoreWindow^sender, _In_ Windows::UI::Core::PointerEventArgs^args) | LonLatController | [private]
SaveInternalState(_In_ Windows::Foundation::Collections::IPropertySet^state) | LonLatController | [private]
SaveInternalState(_In_ Windows::Foundation::Collections::IPropertySet^state) | LonLatController | [private]
SetOrientation(_In_ float latitude, _In_ float longitude) | LonLatController | [private]
SetOrientation(_In_ float latitude, _In_ float longitude) | LonLatController | [private]
SetPosition(_In_ float3 pos) | LonLatController | [private]
SetPosition(_In_ float3 pos) | LonLatController | [private]
Update(_In_ Windows::UI::Core::CoreWindow^window) | LonLatController | [private]
Update() | LonLatController | [private]
Generated on Sat Nov 23 2024 16:09:15 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::WASAPIAudio::WASAPICapture Member List

This is the complete list of members for SDKSample::WASAPIAudio::WASAPICapture, including all inherited members.
ActivateCompleted(IActivateAudioInterfaceAsyncOperation *operation) | SDKSample::WASAPIAudio::WASAPICapture |
CreateWAVFile() | SDKSample::WASAPIAudio::WASAPICapture | [private]
FinishCaptureAsync() | SDKSample::WASAPIAudio::WASAPICapture |
FixWAVHeader() | SDKSample::WASAPIAudio::WASAPICapture | [private]
GetDeviceStateEvent() | SDKSample::WASAPIAudio::WASAPICapture | [inline]
InitializeAudioDeviceAsync() | SDKSample::WASAPIAudio::WASAPICapture |
InitializeScopeData() | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_AudioCaptureClient | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_AudioClient | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_BufferFrames | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_cbDataSize | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_cbFlushCounter | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_cbHeaderSize | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_ContentStream | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_cPlotDataFilled | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_cPlotDataMax | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_CritSec | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_DeviceIdString | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_DeviceStateChanged | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_dwQueueID | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_fWriting | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_MixFormat | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_OutputStream | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_PlotData | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_SampleReadyAsyncResult | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_SampleReadyEvent | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_SampleReadyKey | SDKSample::WASAPIAudio::WASAPICapture | [private]
m_WAVDataWriter | SDKSample::WASAPIAudio::WASAPICapture | [private]
METHODASYNCCALLBACK(WASAPICapture, StartCapture, OnStartCapture) | SDKSample::WASAPIAudio::WASAPICapture |
METHODASYNCCALLBACK(WASAPICapture, StopCapture, OnStopCapture) | SDKSample::WASAPIAudio::WASAPICapture |
METHODASYNCCALLBACK(WASAPICapture, SampleReady, OnSampleReady) | SDKSample::WASAPIAudio::WASAPICapture |
METHODASYNCCALLBACK(WASAPICapture, FinishCapture, OnFinishCapture) | SDKSample::WASAPIAudio::WASAPICapture |
METHODASYNCCALLBACK(WASAPICapture, SendScopeData, OnSendScopeData) | SDKSample::WASAPIAudio::WASAPICapture |
OnAudioSampleRequested(Platform::Boolean IsSilence=false) | SDKSample::WASAPIAudio::WASAPICapture | [private]
OnFinishCapture(IMFAsyncResult *pResult) | SDKSample::WASAPIAudio::WASAPICapture | [private]
OnSampleReady(IMFAsyncResult *pResult) | SDKSample::WASAPIAudio::WASAPICapture | [private]
OnSendScopeData(IMFAsyncResult *pResult) | SDKSample::WASAPIAudio::WASAPICapture | [private]
OnStartCapture(IMFAsyncResult *pResult) | SDKSample::WASAPIAudio::WASAPICapture | [private]
OnStopCapture(IMFAsyncResult *pResult) | SDKSample::WASAPIAudio::WASAPICapture | [private]
ProcessScopeData(BYTE *pData, DWORD cbBytes) | SDKSample::WASAPIAudio::WASAPICapture | [private]
StartCaptureAsync() | SDKSample::WASAPIAudio::WASAPICapture |
StopCaptureAsync() | SDKSample::WASAPIAudio::WASAPICapture |
WASAPICapture() | SDKSample::WASAPIAudio::WASAPICapture |
~WASAPICapture() | SDKSample::WASAPIAudio::WASAPICapture | [private]
Generated on Sat Nov 23 2024 16:09:53 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

ShareTarget::sealed Member List

This is the complete list of members for ShareTarget::sealed, including all inherited members.
AddContentValue(Platform::String^title) | ShareTarget::sealed | [private]
AddContentValue(Platform::String^title, Platform::String^description) | ShareTarget::sealed | [private]
AddQuickLink_Checked(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
AddQuickLink_Unchecked(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
App() | ShareTarget::sealed |
DefaultPage() | ShareTarget::sealed |
ExpandLongRunningShareSection_Checked(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
ExpandLongRunningShareSection_Unchecked(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
Footer_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
Footer_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
LongRunningShareLabel_Tapped(Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e) | ShareTarget::sealed | [private]
MainPage() | ShareTarget::sealed |
NotifyUser(Platform::String^strmessage, NotifyType type) | ShareTarget::sealed |
NotifyUserBackgroundThread(Platform::String^message, NotifyType type) | ShareTarget::sealed |
OnLaunched(Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^pArgs) override | ShareTarget::sealed | [virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | ShareTarget::sealed | [virtual]
OnShareTargetActivated(Windows::ApplicationModel::Activation::ShareTargetActivatedEventArgs^args) override | ShareTarget::sealed | [virtual]
QuickLinkSectionLabel_Tapped(Platform::Object^sender, Windows::UI::Xaml::Input::TappedRoutedEventArgs^e) | ShareTarget::sealed | [private]
ReportCompleted_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
ReportDataRetrieved_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
ReportErrorButton_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
ReportStarted_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
ReportSubmittedBackgroundTask_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | ShareTarget::sealed | [private]
sharedBitmapStreamRef | ShareTarget::sealed | [private]
sharedCustomData | ShareTarget::sealed | [private]
sharedDataDescription | ShareTarget::sealed | [private]
sharedDataTitle | ShareTarget::sealed | [private]
sharedHtmlFormat | ShareTarget::sealed | [private]
sharedResourceMap | ShareTarget::sealed | [private]
sharedStorageItems | ShareTarget::sealed | [private]
sharedText | ShareTarget::sealed | [private]
sharedThumbnailStreamRef | ShareTarget::sealed | [private]
sharedUri | ShareTarget::sealed | [private]
shareOperation | ShareTarget::sealed | [private]
shareQuickLinkId | ShareTarget::sealed | [private]
~MainPage() | ShareTarget::sealed | [private]
Generated on Sat Nov 23 2024 16:09:54 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DirectX postcard app/C++/DirectXBase.cpp Source File

  • DirectX postcard app

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace Windows::UI::Xaml::Controls;
00016 using namespace D2D1;
00017
00018 // Constructor.
00019 DirectXBase::DirectXBase() :
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(
00026     CoreWindow^ window,
00027     SwapChainBackgroundPanel^ swapChainPanel,
00028     float dpi
00029     )
00030 {
00031     m_window = window;
00032     m_swapChainPanel = swapChainPanel;
00033
00034     CreateDeviceIndependentResources();
00035     CreateDeviceResources();
00036     SetDpi(dpi);
00037 }
00038
00039 // Recreate all device resources and set them back to the current state.
00040 void DirectXBase::HandleDeviceLost()
00041 {
00042     // Reset these member variables to ensure that SetDpi recreates all resources.
00043     float dpi = m_dpi;
00044     m_dpi = -1.0f;
00045     m_windowBounds.Width = 0;
00046     m_windowBounds.Height = 0;
00047     m_swapChain = nullptr;
00048
00049     CreateDeviceResources();
00050     SetDpi(dpi);
00051 }
00052
00053 // These are the resources required independent of the device.
00054 void DirectXBase::CreateDeviceIndependentResources()
00055 {
00056     D2D1_FACTORY_OPTIONS options;
00057     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00058
00059 #if defined(_DEBUG)
00060     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00061     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00062 #endif
00063
00064     DX::ThrowIfFailed(
00065         D2D1CreateFactory(
00066             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00067             __uuidof(ID2D1Factory1),
00068             &options,
00069             &m_d2dFactory
00070             )
00071         );
00072
00073     DX::ThrowIfFailed(
00074         DWriteCreateFactory(
00075             DWRITE_FACTORY_TYPE_SHARED,
00076             __uuidof(IDWriteFactory),
00077             &m_dwriteFactory
00078             )
00079         );
00080
00081     DX::ThrowIfFailed(
00082         CoCreateInstance(
00083             CLSID_WICImagingFactory,
00084             nullptr,
00085             CLSCTX_INPROC_SERVER,
00086             IID_PPV_ARGS(&m_wicFactory)
00087             )
00088         );
00089 }
00090
00091 // These are the resources that depend on the device.
00092 void DirectXBase::CreateDeviceResources()
00093 {
00094     // This flag adds support for surfaces with a different color channel ordering
00095     // than the API default. It is required for compatibility with Direct2D.
00096     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00097     ComPtr<IDXGIDevice> dxgiDevice;
00098
00099 #if defined(_DEBUG)
00100     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00101     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00102 #endif
00103
00104     // This array defines the set of DirectX hardware feature levels this app will support.
00105     // Note the ordering should be preserved.
00106     // Don't forget to declare your application's minimum required feature level in its
00107     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00108     D3D_FEATURE_LEVEL featureLevels[] =
00109     {
00110         D3D_FEATURE_LEVEL_11_1,
00111         D3D_FEATURE_LEVEL_11_0,
00112         D3D_FEATURE_LEVEL_10_1,
00113         D3D_FEATURE_LEVEL_10_0,
00114         D3D_FEATURE_LEVEL_9_3,
00115         D3D_FEATURE_LEVEL_9_2,
00116         D3D_FEATURE_LEVEL_9_1
00117     };
00118
00119     // Create the Direct3D 11 API device object and a corresponding context.
00120     ComPtr<ID3D11Device> device;
00121     ComPtr<ID3D11DeviceContext> context;
00122     DX::ThrowIfFailed(
00123         D3D11CreateDevice(
00124             nullptr,                    // Specify nullptr to use the default adapter.
00125             D3D_DRIVER_TYPE_HARDWARE,
00126             0,
00127             creationFlags,              // Set debug and Direct2D compatibility flags.
00128             featureLevels,              // List of feature levels this app can support.
00129             ARRAYSIZE(featureLevels),
00130             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00131             &device,                    // Returns the Direct3D device created.
00132             &m_featureLevel,            // Returns feature level of device created.
00133             &context                    // Returns the device immediate context.
00134             )
00135         );
00136
00137     // Get the Direct3D 11.1 API device and context interfaces.
00138     DX::ThrowIfFailed(
00139         device.As(&m_d3dDevice)
00140         );
00141
00142     DX::ThrowIfFailed(
00143         context.As(&m_d3dContext)
00144         );
00145
00146     // Get the underlying DXGI device of the Direct3D device.
00147     DX::ThrowIfFailed(
00148         m_d3dDevice.As(&dxgiDevice)
00149         );
00150
00151     // Create the Direct2D device object and a corresponding context.
00152     DX::ThrowIfFailed(
00153         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00154         );
00155
00156     DX::ThrowIfFailed(
00157         m_d2dDevice->CreateDeviceContext(
00158             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00159             &m_d2dContext
00160             )
00161         );
00162 }
00163
00164 // Helps track the DPI in the helper class.
00165 // This is called in the dpiChanged event handler in the view class.
00166 void DirectXBase::SetDpi(float dpi)
00167 {
00168     if (dpi != m_dpi)
00169     {
00170         // Save the DPI of this display in our class.
00171         m_dpi = dpi;
00172
00173         // Update Direct2D's stored DPI.
00174         m_d2dContext->SetDpi(m_dpi, m_dpi);
00175
00176         // Often a DPI change implies a window size change. In some cases Windows will issue
00177         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00178         // will not change, and the window resize code will only be executed once.
00179         UpdateForWindowSizeChange();
00180     }
00181 }
00182
00183 // This routine is called in the event handler for the view SizeChanged event.
00184 void DirectXBase::UpdateForWindowSizeChange()
00185 {
00186     // Only handle window size changed if there is no pending DPI change.
00187     if (m_dpi != DisplayProperties::LogicalDpi)
00188     {
00189         return;
00190     }
00191
00192     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00193         m_window->Bounds.Height != m_windowBounds.Height)
00194     {
00195         m_d2dContext->SetTarget(nullptr);
00196         m_d2dTargetBitmap = nullptr;
00197         m_d3dRenderTargetView = nullptr;
00198         m_d3dDepthStencilView = nullptr;
00199         CreateWindowSizeDependentResources();
00200     }
00201 }
00202
00203 // Allocate all memory resources that change on a window SizeChanged event.
00204 void DirectXBase::CreateWindowSizeDependentResources()
00205 {
00206     // Store the window bounds so the next time we get a SizeChanged event we can
00207     // avoid rebuilding everything if the size is identical.
00208     m_windowBounds = m_window->Bounds;
00209
00210     // If the swap chain already exists, resize it.
00211     if (m_swapChain != nullptr)
00212     {
00213         HRESULT hr = m_swapChain->ResizeBuffers(
00214             2,
00215             static_cast<UINT>(m_window->Bounds.Width * m_dpi / 96.0f), // Can not use 0 to get the default on Composition SwapChain.
00216             static_cast<UINT>(m_window->Bounds.Height * m_dpi / 96.0f),
00217             DXGI_FORMAT_B8G8R8A8_UNORM,
00218             0
00219             );
00220
00221         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00222         {
00223             // If the device was removed for any reason, a new device and swapchain will need to be created.
00224             HandleDeviceLost();
00225
00226             // Everything is set up now. Do not continue execution of this method.
00227             return;
00228         }
00229         else
00230         {
00231             DX::ThrowIfFailed(hr);
00232         }
00233     }
00234     else // If it does not exist, create it.
00235     {
00236         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00237         swapChainDesc.Width = static_cast<UINT>(m_window->Bounds.Width * m_dpi / 96.0f); // Can not use 0 to get the default on Composition SwapChain.
00238         swapChainDesc.Height = static_cast<UINT>(m_window->Bounds.Height * m_dpi / 96.0f);
00239         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // Use the recommended color format.
00240         swapChainDesc.Stereo = false;
00241         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00242         swapChainDesc.SampleDesc.Quality = 0;
00243         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT; // Allow it to be used as a render target.
00244         swapChainDesc.BufferCount = 2;                               // Use double buffering to enable flip effect.
00245         swapChainDesc.Scaling = DXGI_SCALING_STRETCH;
00246         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // This is the recommended swap effect.
00247         swapChainDesc.Flags = 0;
00248
00249         // Once the desired swap chain description is configured, it must be created on the same adapter as our D3D Device.
00250
00251         // First, retrieve the underlying DXGI Device from the D3D Device.
00252         ComPtr<IDXGIDevice1> dxgiDevice;
00253         DX::ThrowIfFailed(
00254             m_d3dDevice.As(&dxgiDevice)
00255             );
00256
00257         // Next, get the associated adapter from the DXGI Device.
00258         ComPtr<IDXGIAdapter> dxgiAdapter;
00259         DX::ThrowIfFailed(
00260             dxgiDevice->GetAdapter(&dxgiAdapter)
00261             );
00262
00263         // Next, get the parent factory from the DXGI adapter.
00264         ComPtr<IDXGIFactory2> dxgiFactory;
00265         DX::ThrowIfFailed(
00266             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00267             );
00268
00269         // Create the swap chain and then associate it with the SwapChainBackgroundPanel.
00270         DX::ThrowIfFailed(
00271             dxgiFactory->CreateSwapChainForComposition(
00272                 m_d3dDevice.Get(),
00273                 &swapChainDesc,
00274                 nullptr,
00275                 &m_swapChain
00276                 )
00277             );
00278
00279         ComPtr<ISwapChainBackgroundPanelNative> dxRootPanelAsSwapChainBackgroundPanel;
00280
00281         // Set the swap chain on the SwapChainBackgroundPanel.
00282         reinterpret_cast<IUnknown*>(m_swapChainPanel)->QueryInterface(
00283             IID_PPV_ARGS(&dxRootPanelAsSwapChainBackgroundPanel)
00284             );
00285
00286         DX::ThrowIfFailed(
00287             dxRootPanelAsSwapChainBackgroundPanel->SetSwapChain(m_swapChain.Get())
00288             );
00289
00290         // Ensure that DXGI does not queue more than one frame at a time. This both reduces
00291         // latency and ensures that the application will only render after each VSync, minimizing
00292         // power consumption.
00293         DX::ThrowIfFailed(
00294             dxgiDevice->SetMaximumFrameLatency(1)
00295             );
00296     }
00297
00298     // Create a view on the swap chain back buffer.
00299     ComPtr<ID3D11Texture2D> backBuffer;
00300     DX::ThrowIfFailed(
00301         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00302         );
00303
00304     D3D11_RENDER_TARGET_VIEW_DESC renderTargetViewDesc = {};
00305     renderTargetViewDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;
00306     renderTargetViewDesc.ViewDimension = D3D11_RTV_DIMENSION_TEXTURE2DARRAY;        // Render target view is a Texture2D array.
00307     renderTargetViewDesc.Texture2DArray.MipSlice = 0;                               // Each array element is one Texture2D.
00308     renderTargetViewDesc.Texture2DArray.ArraySize = 1;
00309     renderTargetViewDesc.Texture2DArray.FirstArraySlice = 0;
00310     DX::ThrowIfFailed(
00311         m_d3dDevice->CreateRenderTargetView(
00312             backBuffer.Get(),
00313             &renderTargetViewDesc,
00314             &m_d3dRenderTargetView
00315             )
00316         );
00317
00318     // Get the back buffer description for later use.
00319     D3D11_TEXTURE2D_DESC backBufferDesc;
00320     backBuffer->GetDesc(&backBufferDesc);
00321
00322     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00323     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00324
00325     D2D1_BITMAP_PROPERTIES1 bitmapProperties = {};
00326     bitmapProperties.pixelFormat.format = DXGI_FORMAT_B8G8R8A8_UNORM;
00327     bitmapProperties.pixelFormat.alphaMode = D2D1_ALPHA_MODE_PREMULTIPLIED;
00328     bitmapProperties.bitmapOptions = D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW;
00329     bitmapProperties.colorContext = nullptr;
00330     bitmapProperties.dpiX = m_dpi;
00331     bitmapProperties.dpiY = m_dpi;
00332
00333     ComPtr<IDXGIResource1> dxgiBackBuffer;
00334     DX::ThrowIfFailed(
00335         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00336         );
00337
00338     ComPtr<IDXGISurface2> dxgiSurface;
00339     DX::ThrowIfFailed(
00340         dxgiBackBuffer->CreateSubresourceSurface(0, &dxgiSurface)
00341         );
00342
00343     DX::ThrowIfFailed(
00344         m_d2dContext->CreateBitmapFromDxgiSurface(
00345             dxgiSurface.Get(),
00346             &bitmapProperties,
00347             &m_d2dTargetBitmap
00348             )
00349         );
00350
00351     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00352 }
00353
00354 // Method to deliver the final image to the display.
00355 void DirectXBase::Present()
00356 {
00357     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00358     // in certain scenarios.  In this sample, however, we do not utilize those features.
00359     DXGI_PRESENT_PARAMETERS parameters = {0};
00360     parameters.DirtyRectsCount = 0;
00361     parameters.pDirtyRects = nullptr;
00362     parameters.pScrollRect = nullptr;
00363     parameters.pScrollOffset = nullptr;
00364
00365     // The first argument instructs DXGI to block until VSync, putting the application
00366     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00367     // frames that will never be displayed to the screen.
00368     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00369
00370     // If the device was removed either by a disconnect or a driver upgrade, we
00371     // must recreate all device resources.
00372     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00373     {
00374         HandleDeviceLost();
00375     }
00376     else
00377     {
00378         DX::ThrowIfFailed(hr);
00379     }
00380 }
00381
00382 void DirectXBase::ValidateDevice()
00383 {
00384     // The D3D Device is no longer valid if the default adapter changes or if
00385     // the device has been removed.
00386
00387     // First, get the information for the adapter related to the current device.
00388
00389     ComPtr<IDXGIDevice1> dxgiDevice;
00390     ComPtr<IDXGIAdapter> deviceAdapter;
00391     DXGI_ADAPTER_DESC deviceDesc;
00392     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00393     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00394     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00395
00396     // Next, get the information for the default adapter.
00397
00398     ComPtr<IDXGIFactory2> dxgiFactory;
00399     ComPtr<IDXGIAdapter1> currentAdapter;
00400     DXGI_ADAPTER_DESC currentDesc;
00401     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00402     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00403     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00404
00405     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00406     // a new D3D device must be created.
00407
00408     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00409         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00410         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00411     {
00412         // Release references to resources related to the old device.
00413         dxgiDevice = nullptr;
00414         deviceAdapter = nullptr;
00415
00416         // Create a new device and swap chain.
00417         HandleDeviceLost();
00418     }
00419 }
Generated on Sat Nov 23 2024 16:08:03 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Background Transfer/C++/Constants.cpp Source File

  • Background Transfer

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "File Download", "SDKSample.BackgroundTransfer.Scenario1" },
00022     { "File Upload", "SDKSample.BackgroundTransfer.Scenario2" }
00023 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SDKSample::GlobalizationPreferencesSample::sealed Member List

This is the complete list of members for SDKSample::GlobalizationPreferencesSample::sealed, including all inherited members.
CurrentInputLanguage() | SDKSample::GlobalizationPreferencesSample::sealed |
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::GlobalizationPreferencesSample::sealed | [private]
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::GlobalizationPreferencesSample::sealed | [private]
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::GlobalizationPreferencesSample::sealed | [private]
Display_Click(Platform::Object^sender, Windows::UI::Xaml::RoutedEventArgs^e) | SDKSample::GlobalizationPreferencesSample::sealed | [private]
GeographicRegionScenario() | SDKSample::GlobalizationPreferencesSample::sealed |
LanguageScenario() | SDKSample::GlobalizationPreferencesSample::sealed |
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::GlobalizationPreferencesSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::GlobalizationPreferencesSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::GlobalizationPreferencesSample::sealed | [protected, virtual]
OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^e) override | SDKSample::GlobalizationPreferencesSample::sealed | [protected, virtual]
rootPage | SDKSample::GlobalizationPreferencesSample::sealed | [private]
UserPreferences() | SDKSample::GlobalizationPreferencesSample::sealed |
VectorViewToString(Windows::Foundation::Collections::IVectorView< Platform::String^>^data) | SDKSample::GlobalizationPreferencesSample::sealed | [static]
Generated on Sat Nov 23 2024 16:09:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D 3D transform effect/C++/pch.cpp Source File

  • Direct2D 3D transform effect

pch.cpp

Go to the documentation of this file.
00001 ﻿//// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 //
00009 // Include the standard header and generate the precompiled header.
00010 //
00011
00012 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:48 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario6.xaml.h Source File

  • XAML WebView control

Scenario6.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario6.xaml.h
00013 // Declaration of the Scenario6 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario6.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace WebViewControl
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029         [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario6 sealed
00031         {
00032         public:
00033             Scenario6();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         void ComboBox1_DropDownClosed(Platform::Object^ sender, Platform::Object^ e);
00040         void ComboBox1_DropDownOpened(Platform::Object^ sender, Platform::Object^ e);
00041         void Solution_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00042       };
00043     }
00044 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML WebView control/C++/Scenario8.xaml.cpp Source File

  • XAML WebView control

Scenario8.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario8.xaml.cpp
00013 // Implementation of the Scenario8 class
00014 //
00015
00016 #include "pch.h"
00017 #include "PageWithAppBar.xaml.h"
00018 #include "Scenario8.xaml.h"
00019
00020 using namespace SDKSample::WebViewControl;
00021
00022 using namespace Windows::UI::Xaml::Interop;
00023 using namespace Windows::UI::Xaml;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Navigation;
00026
00027 Scenario8::Scenario8()
00028 {
00029     InitializeComponent();
00030 }
00031
00032 // Invoked when this page is about to be displayed in a Frame.
00033 void Scenario8::OnNavigatedTo(NavigationEventArgs^ e)
00034 {
00035     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00036     // as NotifyUser()
00037     rootPage = MainPage::Current;
00038 }
00039
00040
00041 // Click handler for 'Show Me' button
00042 void SDKSample::WebViewControl::Scenario8::ShowMe_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00043 {
00044   TypeName scenarioType = {PageWithAppBar::typeid->FullName, TypeKind::Custom};
00045   rootPage->Frame->Navigate(scenarioType);
00046 }
Generated on Sat Nov 23 2024 16:07:56 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/Launch.xaml.h Source File

  • Input Touch keyboard

Launch.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Launch.xaml.h
00013 // Declaration of the Launch class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Launch.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace TouchKeyboard
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Launch sealed
00031         {
00032         public:
00033             Launch();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039         };
00040
00041         /// <summary>
00042         /// Custom Text box control derived from Textbox class.
00043         /// </summary>
00044         public ref class CustomTextBox sealed : public Windows::UI::Xaml::Controls::TextBox
00045         {
00046         public:
00047             CustomTextBox()
00048             {
00049                 this->Background = ref new Windows::UI::Xaml::Media::SolidColorBrush(Windows::UI::Colors::Coral);
00050                 this->BorderThickness = Windows::UI::Xaml::Thickness(1);
00051                 this->HorizontalAlignment = Windows::UI::Xaml::HorizontalAlignment::Center;
00052             }
00053         };
00054     }
00055 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Number formatting and parsing/C++/Constants.cpp Source File

  • Number formatting and parsing

Constants.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "MainPage.xaml.h"
00013 #include "Constants.h"
00014
00015 using namespace SDKSample;
00016
00017 Platform::Array<Scenario>^ MainPage::scenariosInner = ref new Platform::Array<Scenario>
00018 {
00019     // The format here is the following:
00020     //     { "Description for the sample", "Fully quaified name for the class that implements the scenario" }
00021     { "Percent and Permille Formatting", "SDKSample.NumberFormatting.PercentPermilleFormatting" },
00022     { "Decimal Formatting", "SDKSample.NumberFormatting.DecimalFormatting" },
00023     { "Currency Formatting", "SDKSample.NumberFormatting.CurrencyFormatting" },
00024     { "Number Parsing", "SDKSample.NumberFormatting.NumberParsing" }
00025 };
Generated on Sat Nov 23 2024 16:07:39 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D convolve matrix effect/C++/SampleOverlay.cpp Source File

  • Direct2D convolve matrix effect

SampleOverlay.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "SampleOverlay.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::UI::ViewManagement;
00015 using namespace Windows::Graphics::Display;
00016 using namespace D2D1;
00017
00018 SampleOverlay::SampleOverlay() :
00019     m_drawOverlay(true)
00020 {
00021 }
00022
00023 void SampleOverlay::Initialize(
00024     _In_ ID2D1Device*         d2dDevice,
00025     _In_ ID2D1DeviceContext*  d2dContext,
00026     _In_ IWICImagingFactory*  wicFactory,
00027     _In_ IDWriteFactory*      dwriteFactory,
00028     _In_ Platform::String^    caption
00029     )
00030 {
00031     m_wicFactory = wicFactory;
00032     m_dwriteFactory = dwriteFactory;
00033     m_sampleName = caption;
00034     m_d2dDevice = d2dDevice;
00035     m_d2dContext = d2dContext;
00036     m_padding = 3.0f;
00037     m_textVerticalOffset = 5.0f;
00038     m_logoSize = D2D1::SizeF(0.0f, 0.0f);
00039     m_overlayWidth = 0.0f;
00040
00041     ComPtr<ID2D1Factory> factory;
00042     d2dDevice->GetFactory(&factory);
00043
00044     DX::ThrowIfFailed(
00045         factory.As(&m_d2dFactory)
00046         );
00047
00048     ResetDirectXResources();
00049 }
00050
00051 void SampleOverlay::ResetDirectXResources()
00052 {
00053     DX::ThrowIfFailed(
00054         m_d2dContext->CreateSolidColorBrush(ColorF(ColorF::White), &m_whiteBrush)
00055         );
00056
00057     ComPtr<IWICBitmapDecoder> wicBitmapDecoder;
00058     DX::ThrowIfFailed(
00059         m_wicFactory->CreateDecoderFromFilename(
00060             L"windowsbig-sdk.png",
00061             nullptr,
00062             GENERIC_READ,
00063             WICDecodeMetadataCacheOnDemand,
00064             &wicBitmapDecoder
00065             )
00066         );
00067
00068     ComPtr<IWICBitmapFrameDecode> wicBitmapFrame;
00069     DX::ThrowIfFailed(
00070         wicBitmapDecoder->GetFrame(0, &wicBitmapFrame)
00071         );
00072
00073     ComPtr<IWICFormatConverter> wicFormatConverter;
00074     DX::ThrowIfFailed(
00075         m_wicFactory->CreateFormatConverter(&wicFormatConverter)
00076         );
00077
00078     DX::ThrowIfFailed(
00079         wicFormatConverter->Initialize(
00080             wicBitmapFrame.Get(),
00081             GUID_WICPixelFormat32bppPBGRA,
00082             WICBitmapDitherTypeNone,
00083             nullptr,
00084             0.0,
00085             WICBitmapPaletteTypeCustom  // the BGRA format has no palette so this value is ignored
00086             )
00087         );
00088
00089     double dpiX = 96.0f;
00090     double dpiY = 96.0f;
00091     DX::ThrowIfFailed(
00092         wicFormatConverter->GetResolution(&dpiX, &dpiY)
00093         );
00094
00095     DX::ThrowIfFailed(
00096         m_d2dContext->CreateBitmapFromWicBitmap(
00097             wicFormatConverter.Get(),
00098             BitmapProperties(
00099                 PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00100                 static_cast<float>(dpiX),
00101                 static_cast<float>(dpiY)
00102                 ),
00103             &m_logoBitmap
00104             )
00105         );
00106
00107     m_logoSize = m_logoBitmap->GetSize();
00108
00109     ComPtr<IDWriteTextFormat> nameTextFormat;
00110     DX::ThrowIfFailed(
00111         m_dwriteFactory->CreateTextFormat(
00112             L"Segoe UI",
00113             nullptr,
00114             DWRITE_FONT_WEIGHT_LIGHT,
00115             DWRITE_FONT_STYLE_NORMAL,
00116             DWRITE_FONT_STRETCH_NORMAL,
00117             36.0f,
00118             L"en-US",
00119             &nameTextFormat
00120             )
00121         );
00122
00123     DX::ThrowIfFailed(
00124         nameTextFormat->SetTextAlignment(DWRITE_TEXT_ALIGNMENT_LEADING)
00125         );
00126
00127     DX::ThrowIfFailed(
00128         nameTextFormat->SetParagraphAlignment(DWRITE_PARAGRAPH_ALIGNMENT_NEAR)
00129         );
00130
00131     DX::ThrowIfFailed(
00132         m_dwriteFactory->CreateTextLayout(
00133             m_sampleName->Data(),
00134             m_sampleName->Length(),
00135             nameTextFormat.Get(),
00136             4096.0f,
00137             4096.0f,
00138             &m_textLayout
00139             )
00140         );
00141
00142     DWRITE_TEXT_METRICS metrics = {0};
00143     DX::ThrowIfFailed(
00144         m_textLayout->GetMetrics(&metrics)
00145         );
00146
00147     m_overlayWidth = m_padding * 3.0f + m_logoSize.width + metrics.width;
00148
00149     DX::ThrowIfFailed(
00150         m_d2dFactory->CreateDrawingStateBlock(&m_stateBlock)
00151         );
00152
00153     UpdateForWindowSizeChange();
00154 }
00155
00156 void SampleOverlay::UpdateForWindowSizeChange()
00157 {
00158     if (CoreWindow::GetForCurrentThread()->Bounds.Width < m_overlayWidth)
00159     {
00160         m_drawOverlay = false;
00161     }
00162     else
00163     {
00164         m_drawOverlay = true;
00165     }
00166 }
00167
00168 void SampleOverlay::Render()
00169 {
00170     if (m_drawOverlay)
00171     {
00172         m_d2dContext->SaveDrawingState(m_stateBlock.Get());
00173
00174         m_d2dContext->BeginDraw();
00175         m_d2dContext->SetTransform(D2D1::Matrix3x2F::Identity());
00176         m_d2dContext->DrawBitmap(
00177             m_logoBitmap.Get(),
00178             D2D1::RectF(m_padding, 0.0f, m_logoSize.width + m_padding, m_logoSize.height)
00179             );
00180
00181         m_d2dContext->DrawTextLayout(
00182             Point2F(m_logoSize.width + 2.0f * m_padding, m_textVerticalOffset),
00183             m_textLayout.Get(),
00184             m_whiteBrush.Get()
00185             );
00186
00187         // We ignore D2DERR_RECREATE_TARGET here. This error indicates that the device
00188         // is lost. It will be handled during the next call to Present.
00189         HRESULT hr = m_d2dContext->EndDraw();
00190         if (hr != D2DERR_RECREATE_TARGET)
00191         {
00192             DX::ThrowIfFailed(hr);
00193         }
00194
00195         m_d2dContext->RestoreDrawingState(m_stateBlock.Get());
00196     }
00197 }
00198
00199 float SampleOverlay::GetTitleHeightInDips()
00200 {
00201     return m_logoSize.height;
00202 }
Generated on Sat Nov 23 2024 16:08:04 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML Popup/C++/Scenario3.xaml.cpp Source File

  • XAML Popup

Scenario3.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario3.xaml.cpp
00013 // Implementation of the Scenario3 class
00014 //
00015
00016 #include "pch.h"
00017 #include "Scenario3.xaml.h"
00018
00019 using namespace SDKSample::XAMLPopup;
00020
00021 using namespace Windows::UI::Xaml;
00022 using namespace Windows::UI::Xaml::Controls;
00023 using namespace Windows::UI::Xaml::Navigation;
00024
00025 Scenario3::Scenario3()
00026 {
00027     InitializeComponent();
00028 }
00029
00030 /// <summary>
00031 /// Invoked when this page is about to be displayed in a Frame.
00032 /// </summary>
00033 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00034 /// property is typically used to configure the page.</param>
00035 void Scenario3::OnNavigatedTo(NavigationEventArgs^ e)
00036 {
00037     rootPage = MainPage::Current;
00038 }
00039
00040 // handles the Click event of the Button for showing the light dismiss behavior
00041 void SDKSample::XAMLPopup::Scenario3::ShowPopupLightDismissClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00042 {
00043   if (!LightDismissSimplePopup->IsOpen) { LightDismissSimplePopup->IsOpen = true; }
00044 }
00045
00046 // handles the Click event of the Button for showing the light dismiss with animations behavior
00047 void SDKSample::XAMLPopup::Scenario3::ShowPopupAnimationClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049   if (!LightDismissAnimatedPopup->IsOpen) { LightDismissAnimatedPopup->IsOpen = true; }
00050 }
00051
00052 // handles the Click event of the Button for showing the light dismiss with settings behavior
00053 void SDKSample::XAMLPopup::Scenario3::ShowPopupSettingsClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00054 {
00055   if (!SettingsAnimatedPopup->IsOpen)
00056     {
00057     /* The UI guidelines for a proper 'Settings' flyout are such that it should fill the height of the
00058      current Window and be either narrow (346px) or wide (646px)
00059      Using the measurements of the Window::Curent::Bounds will help you position correctly.
00060      This sample here shows a simple *example* of this using the Width to get the HorizontalOffset but
00061      the app developer will have to perform these measurements depending on the structure of the app's
00062      views in their code*/
00063         RootPopupBorder->Width = 646;
00064     auto windowBounds = Window::Current->Bounds;
00065     SettingsAnimatedPopup->HorizontalOffset = windowBounds.Width- 646;
00066
00067         SettingsAnimatedPopup->IsOpen = true;
00068     }
00069 }
00070
00071 // Handles the Click event on the Button within the simple Popup control and simply closes it.
00072 void SDKSample::XAMLPopup::Scenario3::ClosePopupClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00073 {
00074   // if the Popup is open, then close it
00075   if (LightDismissSimplePopup->IsOpen) { LightDismissSimplePopup->IsOpen = false; }
00076 }
00077
00078 // Handles the Click event on the Button within the simple Popup control and simply closes it.
00079 void SDKSample::XAMLPopup::Scenario3::CloseAnimatedPopupClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00080 {
00081   if (LightDismissAnimatedPopup->IsOpen) { LightDismissAnimatedPopup->IsOpen = false; }
00082 }
00083
00084 // Handles the Click event on the Button within the simple Popup control and simply closes it.
00085 void SDKSample::XAMLPopup::Scenario3::CloseSettingsPopupClicked(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00086 {
00087   if (SettingsAnimatedPopup->IsOpen) { SettingsAnimatedPopup->IsOpen = false; }
00088 }
Generated on Sat Nov 23 2024 16:07:52 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Language font mapping/C++/LocalCache.cpp Source File

  • Language font mapping

LocalCache.cpp

Go to the documentation of this file.
00001 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 // PARTICULAR PURPOSE.
00005 //
00006 // Copyright (c) Microsoft Corporation. All rights reserved
00007 //
00008 // LocalCache.h
00009 // Declaration of the LocalCache class.
00010 //
00011
00012
00013 #include "pch.h"
00014 #include "ScenarioInput1.xaml.h"
00015
00016 using namespace LanguageFontCPP;
00017
00018 using namespace Platform;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::Globalization::Fonts;
00022 using namespace Windows::Graphics::Display;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml::Controls;
00025 using namespace Windows::UI::Xaml::Media;
00026
00027 void FontInfoLocal::Set(TextBlock^ textBlock)
00028 {
00029     _fontFamily = textBlock->FontFamily;
00030     _fontWeight = textBlock->FontWeight;
00031     _fontStyle = textBlock->FontStyle;
00032     _fontStretch = textBlock->FontStretch;
00033 }
00034
00035 void FontInfoLocal::Reset(TextBlock^ textBlock)
00036 {
00037   String^ fonName = textBlock->FontFamily->Source;
00038     textBlock->FontFamily = _fontFamily;
00039     textBlock->FontWeight = _fontWeight;
00040     textBlock->FontStyle = _fontStyle;
00041     textBlock->FontStretch = _fontStretch;
00042 }
00043
00044 void FontInfoLocal::SetFont(TextBlock^ textBlock, Windows::Globalization::Fonts::LanguageFont^ languageFont)
00045 {
00046   String^ fonName = languageFont->FontFamily;
00047     FontFamily^ fontFamily = ref new FontFamily(languageFont->FontFamily);
00048     textBlock->FontFamily = fontFamily;
00049     textBlock->FontWeight = languageFont->FontWeight;
00050     textBlock->FontStyle = languageFont->FontStyle;
00051     textBlock->FontStretch = languageFont->FontStretch;
00052 }
Generated on Sat Nov 23 2024 16:08:19 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Member List

  • Class List
  • Class Index
  • Class Hierarchy
  • Class Members

SimpleCubeVertex Member List

This is the complete list of members for SimpleCubeVertex, including all inherited members.
color | SimpleCubeVertex
pos | SimpleCubeVertex
Generated on Sat Nov 23 2024 16:09:22 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML user and custom controls/C++/MainPage.xaml.h Source File

  • XAML user and custom controls

MainPage.xaml.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // MainPage.xaml.h
00013 // Declaration of the MainPage.xaml class.
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "MainPage.g.h"
00020 #include "Common\LayoutAwarePage.h" // Required by generated header
00021 #include "Constants.h"
00022
00023 namespace SDKSample
00024 {
00025     public enum class NotifyType
00026     {
00027         StatusMessage,
00028         ErrorMessage
00029     };
00030
00031     public ref class MainPageSizeChangedEventArgs sealed
00032     {
00033     public:
00034         property Windows::UI::ViewManagement::ApplicationViewState ViewState
00035         {
00036             Windows::UI::ViewManagement::ApplicationViewState get()
00037             {
00038                 return viewState;
00039             }
00040
00041             void set(Windows::UI::ViewManagement::ApplicationViewState value)
00042             {
00043                 viewState = value;
00044             }
00045         }
00046
00047     private:
00048         Windows::UI::ViewManagement::ApplicationViewState viewState;
00049     };
00050
00051     public ref class MainPage sealed
00052     {
00053     public:
00054         MainPage();
00055
00056     protected:
00057         virtual void LoadState(Platform::Object^ navigationParameter,
00058             Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00059         virtual void SaveState(Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ pageState) override;
00060
00061     internal:
00062         property bool AutoSizeInputSectionWhenSnapped
00063         {
00064             bool get()
00065             {
00066                 return autoSizeInputSectionWhenSnapped;
00067             }
00068
00069             void set(bool value)
00070             {
00071                 autoSizeInputSectionWhenSnapped = value;
00072             }
00073         }
00074
00075         property Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ LaunchArgs
00076        {
00077             Windows::ApplicationModel::Activation::LaunchActivatedEventArgs^ get()
00078             {
00079                 return safe_cast<App^>(App::Current)->LaunchArgs;
00080             }
00081         }
00082
00083         void NotifyUser(Platform::String^ strMessage, NotifyType type);
00084         void LoadScenario(Platform::String^ scenarioName);
00085         event Windows::Foundation::EventHandler<Platform::Object^>^ ScenarioLoaded;
00086         event Windows::Foundation::EventHandler<MainPageSizeChangedEventArgs^>^ MainPageResized;
00087
00088     private:
00089         void PopulateScenarios();
00090         void InvalidateSize();
00091         void InvalidateViewState();
00092
00093         Platform::Collections::Vector<Object^>^ ScenarioList;
00094         Windows::UI::Xaml::Controls::Frame^ HiddenFrame;
00095         void Footer_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00096         bool autoSizeInputSectionWhenSnapped;
00097
00098         void MainPage_SizeChanged(Object^ sender, Windows::UI::Xaml::SizeChangedEventArgs^ e);
00099         void Scenarios_SelectionChanged(Object^ sender, Windows::UI::Xaml::Controls::SelectionChangedEventArgs^ e);
00100
00101     internal:
00102         static MainPage^ Current;
00103
00104     };
00105 }
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: DatagramSocket/C++/pch.cpp Source File

  • DatagramSocket

pch.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // pch.cpp
00013 // Include the standard header and generate the precompiled header.
00014 //
00015
00016 #include "pch.h"
Generated on Sat Nov 23 2024 16:07:47 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Media extensions/C#,C++/MediaExtensions/Mpeg1Source/Parse.h Source File

  • Media extensions
  • C#,C++
  • MediaExtensions
  • Mpeg1Source

Parse.h

Go to the documentation of this file.
00001 //////////////////////////////////////////////////////////////////////////
00002 //
00003 // Parse.h
00004 // MPEG-1 parsing code.
00005 //
00006 // THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00007 // ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00008 // THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00009 // PARTICULAR PURPOSE.
00010 //
00011 // Copyright (c) Microsoft Corporation. All rights reserved.
00012 //
00013 //////////////////////////////////////////////////////////////////////////
00014
00015 #pragma once
00016
00017
00018 // Note: The structs, enums, and constants defined in this header are not taken from
00019 // Media Foundation or DirectShow headers. The parser code is written to be API-agnostic.
00020 // The only exceptions are:
00021 //    - Use of the MFRatio structure to describe ratios.
00022 //    - The MPEG1AudioFlags enum defined here maps directly to the equivalent DirectShow flags.
00023
00024 // Sizes
00025 const DWORD MPEG1_MAX_PACKET_SIZE = 65535 + 6;          // Maximum packet size.
00026 const DWORD MPEG1_PACK_HEADER_SIZE = 12;                // Pack header.
00027
00028 const DWORD MPEG1_SYSTEM_HEADER_MIN_SIZE = 12;          // System header, excluding the stream info.
00029 const DWORD MPEG1_SYSTEM_HEADER_PREFIX = 6;             // This value + header length = total size of the system header.
00030 const DWORD MPEG1_SYSTEM_HEADER_STREAM = 3;             // Size of each stream info in the system header.
00031
00032 const DWORD MPEG1_PACKET_HEADER_MIN_SIZE = 6;           // Minimum amount to read in the packet header. (Up to the variable-sized padding bytes)
00033 const DWORD MPEG1_PACKET_HEADER_MAX_STUFFING_BYTE = 16; // Maximum number of stuffing bytes in a packet header.
00034 const DWORD MPEG1_PACKET_HEADER_MAX_SIZE = 34;          // Maximum size of a packet header.
00035
00036 const DWORD MPEG1_VIDEO_SEQ_HEADER_MIN_SIZE = 12;       // Minimum length of the video sequence header.
00037 const DWORD MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE = 140;      // Maximum length of the video sequence header.
00038
00039 const DWORD MPEG1_AUDIO_FRAME_HEADER_SIZE = 4;
00040
00041
00042 // Codes
00043 const DWORD MPEG1_START_CODE_PREFIX     = 0x00000100;
00044 const DWORD MPEG1_PACK_START_CODE       = 0x000001BA;
00045 const DWORD MPEG1_SYSTEM_HEADER_CODE    = 0x000001BB;
00046 const DWORD MPEG1_SEQUENCE_HEADER_CODE  = 0x000001B3;
00047 const DWORD MPEG1_STOP_CODE             = 0x000001B9;
00048
00049 // Stream ID codes
00050 const BYTE MPEG1_STREAMTYPE_ALL_AUDIO = 0xB8;
00051 const BYTE MPEG1_STREAMTYPE_ALL_VIDEO = 0xB9;
00052 const BYTE MPEG1_STREAMTYPE_RESERVED = 0xBC;
00053 const BYTE MPEG1_STREAMTYPE_PRIVATE1 = 0xBD;
00054 const BYTE MPEG1_STREAMTYPE_PADDING = 0xBE;
00055 const BYTE MPEG1_STREAMTYPE_PRIVATE2 = 0xBF;
00056 const BYTE MPEG1_STREAMTYPE_AUDIO_MASK = 0xC0;
00057 const BYTE MPEG1_STREAMTYPE_VIDEO_MASK = 0xE0;
00058 const BYTE MPEG1_STREAMTYPE_DATA_MASK = 0xF0;
00059
00060
00061
00062 // Systems layer
00063
00064 enum StreamType
00065 {
00066     StreamType_Unknown,
00067     StreamType_AllAudio,
00068     StreamType_AllVideo,
00069     StreamType_Reserved,
00070     StreamType_Private1,
00071     StreamType_Padding,
00072     StreamType_Private2,
00073     StreamType_Audio,   // ISO/IEC 11172-3
00074     StreamType_Video,   // ISO/IEC 11172-2
00075     StreamType_Data
00076 };
00077
00078 struct MPEG1StreamHeader
00079 {
00080     BYTE        stream_id;  // Raw stream_id field.
00081     StreamType  type;       // Stream type (audio, video, etc)
00082     BYTE        number;     // Index within the stream type (audio 0, audio 1, etc)
00083     DWORD       sizeBound;
00084 };
00085
00086 // MPEG1SystemHeader
00087 // Holds information from the system header. This structure is variable
00088 // length, because the last field is an array of stream headers.
00089 struct MPEG1SystemHeader
00090 {
00091     DWORD   cbSize;     // Size of this structure, including the streams array.
00092     DWORD   rateBound;
00093     BYTE    cAudioBound;
00094     BOOL    bFixed;
00095     BOOL    bCSPS;
00096     BOOL    bAudioLock;
00097     BOOL    bVideoLock;
00098     BYTE    cVideoBound;
00099     DWORD   cStreams;
00100     MPEG1StreamHeader streams[1];   // Array of 1 or more stream headers.
00101 };
00102
00103 struct MPEG1PacketHeader
00104 {
00105     BYTE        stream_id;      // Raw stream_id field.
00106     StreamType  type;           // Stream type (audio, video, etc)
00107     BYTE        number;         // Index within the stream type (audio 0, audio 1, etc)
00108     DWORD       cbPacketSize;   // Size of the entire packet (header + payload).
00109     DWORD       cbPayload;      // Size of the packet payload (packet size - header size).
00110     BOOL        bHasPTS;        // Did the packet header contain a Presentation Time Stamp (PTS)?
00111     LONGLONG    PTS;            // Presentation Time Stamp (in 90 kHz clock)
00112 };
00113
00114 // Video
00115
00116 struct MPEG1VideoSeqHeader
00117 {
00118     WORD        width;
00119     WORD        height;
00120     MFRatio     pixelAspectRatio;
00121     MFRatio     frameRate;
00122     DWORD       bitRate;
00123     WORD        cbVBV_Buffer;
00124     BOOL        bConstrained;
00125     DWORD       cbHeader;
00126     BYTE        header[MPEG1_VIDEO_SEQ_HEADER_MAX_SIZE];    // Raw header.
00127 };
00128
00129 // Audio
00130
00131 enum MPEG1AudioLayer
00132 {
00133     MPEG1_Audio_Layer1 = 0,
00134     MPEG1_Audio_Layer2,
00135     MPEG1_Audio_Layer3
00136 };
00137
00138 enum MPEG1AudioMode
00139 {
00140     MPEG1_Audio_Stereo = 0,
00141     MPEG1_Audio_JointStereo,
00142     MPEG1_Audio_DualChannel,
00143     MPEG1_Audio_SingleChannel
00144 };
00145
00146
00147 // Various bit flags used in the audio frame header.
00148 // (Note: These enum values are not the actual values in the audio frame header.)
00149 enum MPEG1AudioFlags
00150 {
00151     MPEG1_AUDIO_PRIVATE_BIT    = 0x01,  // = ACM_MPEG_PRIVATEBIT
00152     MPEG1_AUDIO_COPYRIGHT_BIT  = 0x02,  // = ACM_MPEG_COPYRIGHT
00153     MPEG1_AUDIO_ORIGINAL_BIT   = 0x04,  // = ACM_MPEG_ORIGINALHOME
00154     MPEG1_AUDIO_PROTECTION_BIT = 0x08,  // = ACM_MPEG_PROTECTIONBIT
00155 };
00156
00157
00158 struct MPEG1AudioFrameHeader
00159 {
00160     MPEG1AudioLayer     layer;
00161     DWORD               dwBitRate;        // Bit rate in Kbits / sec
00162     DWORD               dwSamplesPerSec;
00163     WORD                nBlockAlign;
00164     WORD                nChannels;
00165     MPEG1AudioMode      mode;
00166     BYTE                modeExtension;
00167     BYTE                emphasis;
00168     WORD                wFlags;    // bitwise OR of MPEG1AudioFlags
00169 };
00170
00171
00172 // Buffer class:
00173 // Resizable buffer used to hold the MPEG-1 data.
00174
00175 class Buffer
00176 {
00177 public:
00178     Buffer();
00179     ~Buffer()
00180     {
00181         delete [] m_pArray;
00182     }
00183     HRESULT Initalize(DWORD cbSize);
00184
00185     BYTE*   DataPtr();
00186     DWORD   DataSize() const;
00187
00188     // Reserve: Reserves cb bytes of free data in the buffer.
00189     // The reserved bytes start at DataPtr() + DataSize().
00190     HRESULT Reserve(DWORD cb);
00191
00192     // MoveStart: Moves the front of the buffer.
00193     // Call this method after consuming data from the buffer.
00194     HRESULT MoveStart(DWORD cb);
00195
00196     // MoveEnd: Moves the end of the buffer.
00197     // Call this method after reading data into the buffer.
00198     HRESULT MoveEnd(DWORD cb);
00199
00200 private:
00201     BYTE* Ptr() { return m_pArray; }
00202
00203     HRESULT SetSize(DWORD count);
00204     HRESULT Allocate(DWORD alloc);
00205
00206     DWORD   CurrentFreeSize() const;
00207
00208 private:
00209
00210     BYTE       *m_pArray;
00211     DWORD   m_count;        // Nominal count.
00212     DWORD   m_allocated;    // Actual allocation size.
00213
00214     DWORD   m_begin;
00215     DWORD   m_end;  // 1 past the last element
00216 };
00217
00218
00219 // Parser class:
00220 // Parses an MPEG-1 systems-layer stream.
00221 class Parser
00222 {
00223 public:
00224
00225     Parser();
00226     ~Parser();
00227
00228     HRESULT ParseBytes(const BYTE *pData, DWORD cbLen, DWORD *pAte);
00229
00230     BOOL    HasSystemHeader() const { return m_pHeader != NULL; }
00231     HRESULT GetSystemHeader(MPEG1SystemHeader **ppHeader);
00232
00233     BOOL    HasPacket() const { return m_bHasPacketHeader; }
00234     const MPEG1PacketHeader& PacketHeader() { assert(m_bHasPacketHeader); return m_curPacketHeader; }
00235
00236     DWORD   PayloadSize() const { assert(m_bHasPacketHeader); return m_curPacketHeader.cbPayload; }
00237     void    ClearPacket() { m_bHasPacketHeader = FALSE; }
00238
00239     BOOL    IsEndOfStream() const { return m_bEOS; }
00240
00241 private:
00242
00243     HRESULT FindNextStartCode(const BYTE *pData, DWORD cbLen, DWORD *pAte);
00244     HRESULT ParsePackHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte);
00245     HRESULT ParseSystemHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte);
00246     HRESULT ParsePacketHeader(const BYTE *pData, DWORD cbLen, DWORD *pAte);
00247     HRESULT OnEndOfStream();
00248
00249 private:
00250
00251     LONGLONG            m_SCR;
00252     DWORD               m_muxRate;
00253
00254     MPEG1SystemHeader   *m_pHeader;
00255     // Note: Size of header = sizeof(MPEG1SystemHeader) + (sizeof(MPEG1StreamHeader) * (cStreams - 1))
00256
00257     BOOL                m_bHasPacketHeader;
00258     MPEG1PacketHeader   m_curPacketHeader;  // Most recent packet header.
00259
00260     BOOL                m_bEOS;
00261 };
00262
00263
00264 HRESULT ReadVideoSequenceHeader(_In_reads_bytes_(cbData) const BYTE *pData, DWORD cbData, MPEG1VideoSeqHeader& seqHeader, _Out_ DWORD *pAte);
00265
00266 HRESULT ReadAudioFrameHeader(const BYTE *pData, DWORD cbData, MPEG1AudioFrameHeader& audioHeader, DWORD *pAte);
Generated on Sat Nov 23 2024 16:08:21 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Secondary tiles/C#,C++/Constants.h Source File

  • Secondary tiles
  • C#,C++

Constants.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #pragma once
00012
00013 #include <collection.h>
00014
00015 namespace SecondaryTiles
00016 {
00017     public value struct Scenario
00018     {
00019         Platform::String^ title;
00020         Platform::String^ className;
00021     };
00022
00023     partial ref class MainPage
00024     {
00025     public:
00026         static property Platform::String^ FEATURE_NAME
00027         {
00028             Platform::String^ get()
00029             {
00030                 return ref new Platform::String(L"Secondary Tile C++");
00031             }
00032         }
00033
00034         static property Platform::String^ tileId
00035         {
00036             Platform::String^ get()
00037             {
00038                 return ref new Platform::String(L"SecondaryTile.Logo");
00039             }
00040         }
00041
00042         static property Platform::String^ dynamicTileId
00043         {
00044             Platform::String^ get()
00045             {
00046                 return ref new Platform::String(L"SecondaryTile.LiveTile");
00047             }
00048         }
00049
00050         static property Platform::String^ appbarTileId
00051         {
00052             Platform::String^ get()
00053             {
00054                 return ref new Platform::String(L"SecondaryTile.AppBar");
00055             }
00056         }
00057
00058         static property Platform::Array<Scenario>^ scenarios
00059         {
00060             Platform::Array<Scenario>^ get()
00061             {
00062                 return scenariosInner;
00063             }
00064         }
00065
00066         static Windows::Foundation::Rect GetElementRect(Windows::UI::Xaml::FrameworkElement^ element);
00067
00068     private:
00069         static Platform::Array<Scenario>^ scenariosInner;
00070     };
00071
00072
00073 }
Generated on Sat Nov 23 2024 16:07:40 for Win8-Examples by doxygen 1.7.1


Win8-Examples: EAS policies for mail clients/C++/common/suspensionmanager.h Source File

  • EAS policies for mail clients
  • common

suspensionmanager.h

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.h
00013 // Declaration of the SuspensionManager class
00014 //
00015
00016 #pragma once
00017
00018 #include <ppltasks.h>
00019
00020 namespace SDKSample
00021 {
00022     namespace Common
00023     {
00024         /// <summary>
00025         /// SuspensionManager captures global session state to simplify process lifetime management
00026         /// for an application.  Note that session state will be automatically cleared under a variety
00027         /// of conditions and should only be used to store information that would be convenient to
00028         /// carry across sessions, but that should be disacarded when an application crashes or is
00029         /// upgraded.
00030         /// </summary>
00031         ref class SuspensionManager sealed
00032         {
00033         internal:
00034             static void RegisterFrame(Windows::UI::Xaml::Controls::Frame^ frame, Platform::String^ sessionStateKey);
00035             static void UnregisterFrame(Windows::UI::Xaml::Controls::Frame^ frame);
00036             static Concurrency::task<void> SaveAsync(void);
00037             static Concurrency::task<void> RestoreAsync(void);
00038             static property Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionState
00039             {
00040                 Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ get(void);
00041             };
00042             static Windows::Foundation::Collections::IMap<Platform::String^, Platform::Object^>^ SessionStateForFrame(
00043                 Windows::UI::Xaml::Controls::Frame^ frame);
00044
00045         private:
00046             static void RestoreFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00047             static void SaveFrameNavigationState(Windows::UI::Xaml::Controls::Frame^ frame);
00048         };
00049     }
00050 }
Generated on Sat Nov 23 2024 16:07:38 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Windows account authorization/C++/DelegationTickets.xaml.h Source File

  • Windows account authorization

DelegationTickets.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // DelegationTickets.xaml.h
00013 // Declaration of the DelegationTickets class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "DelegationTickets.g.h"
00020 #include "MainPage.xaml.h"
00021 #include "HttpRequest.h"
00022
00023 using namespace Windows::Foundation;
00024
00025 namespace SDKSample
00026 {
00027     namespace MicrosoftAccount
00028     {
00029         /// <summary>
00030         /// An empty page that can be used on its own or navigated to within a Frame.
00031         /// </summary>
00032         [ Windows::Foundation::Metadata::WebHostHidden ]
00033         public ref class DelegationTickets sealed
00034         {
00035         public:
00036             DelegationTickets();
00037
00038             property Platform::String^ AccessTicket
00039             {
00040                 Platform::String^ get()
00041                 {
00042                     return accessTicket;
00043                 }
00044
00045                 void set(Platform::String^ value)
00046                 {
00047                     accessTicket = value;
00048                 }
00049             }
00050
00051             property bool NeedsToGetTicket
00052             {
00053                 bool get()
00054                 {
00055                     return accessTicket == "";
00056                 }
00057             }
00058
00059             property bool CanSignOut
00060             {
00061                 bool get()
00062                 {
00063                     return authenticator->CanSignOut;
00064                 }
00065             }
00066
00067         protected:
00068
00069             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00070
00071         private:
00072
00073             Windows::Security::Authentication::OnlineId::OnlineIdAuthenticator^ authenticator;
00074             MainPage^ rootPage;
00075             Platform::String^ accessTicket;
00076             Web::HttpRequest httpRequest;
00077             concurrency::cancellation_token_source cancellationTokenSource;
00078
00079             void SignInButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00080             void SignOutButton_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00081         };
00082     }
00083 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Splash screen/C++/common/LayoutAwarePage.cpp Source File

  • Splash screen
  • common

LayoutAwarePage.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 #include "pch.h"
00012 #include "LayoutAwarePage.h"
00013 #include "SuspensionManager.h"
00014
00015 using namespace SDKSample::Common;
00016
00017 using namespace Platform;
00018 using namespace Platform::Collections;
00019 using namespace Windows::Foundation;
00020 using namespace Windows::Foundation::Collections;
00021 using namespace Windows::System;
00022 using namespace Windows::UI::Core;
00023 using namespace Windows::UI::ViewManagement;
00024 using namespace Windows::UI::Xaml;
00025 using namespace Windows::UI::Xaml::Controls;
00026 using namespace Windows::UI::Xaml::Interop;
00027 using namespace Windows::UI::Xaml::Navigation;
00028
00029 /// <summary>
00030 /// Initializes a new instance of the <see cref="LayoutAwarePage"/> class.
00031 /// </summary>
00032 LayoutAwarePage::LayoutAwarePage()
00033 {
00034     if (Windows::ApplicationModel::DesignMode::DesignModeEnabled)
00035     {
00036         return;
00037     }
00038
00039     // Create an empty default view model
00040     DefaultViewModel = ref new Map<String^, Object^>(std::less<String^>());
00041
00042     // When this page is part of the visual tree make two changes:
00043     // 1) Map application view state to visual state for the page
00044     // 2) Handle keyboard and mouse navigation requests
00045     Loaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnLoaded);
00046
00047     // Undo the same changes when the page is no longer visible
00048     Unloaded += ref new RoutedEventHandler(this, &LayoutAwarePage::OnUnloaded);
00049 }
00050
00051 static DependencyProperty^ _defaultViewModelProperty =
00052     DependencyProperty::Register("DefaultViewModel",
00053     TypeName(IObservableMap<String^, Object^>::typeid), TypeName(LayoutAwarePage::typeid), nullptr);
00054
00055 /// <summary>
00056 /// Identifies the <see cref="DefaultViewModel"/> dependency property.
00057 /// </summary>
00058 DependencyProperty^ LayoutAwarePage::DefaultViewModelProperty::get()
00059 {
00060     return _defaultViewModelProperty;
00061 }
00062
00063 /// <summary>
00064 /// Gets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00065 /// used as a trivial view model.
00066 /// </summary>
00067 IObservableMap<String^, Object^>^ LayoutAwarePage::DefaultViewModel::get()
00068 {
00069     return safe_cast<IObservableMap<String^, Object^>^>(GetValue(DefaultViewModelProperty));
00070 }
00071
00072 /// <summary>
00073 /// Sets an implementation of <see cref="IObservableMap&lt;String, Object&gt;"/> designed to be
00074 /// used as a trivial view model.
00075 /// </summary>
00076 void LayoutAwarePage::DefaultViewModel::set(IObservableMap<String^, Object^>^ value)
00077 {
00078     SetValue(DefaultViewModelProperty, value);
00079 }
00080
00081 /// <summary>
00082 /// Invoked when the page is part of the visual tree
00083 /// </summary>
00084 /// <param name="sender">Instance that triggered the event.</param>
00085 /// <param name="e">Event data describing the conditions that led to the event.</param>
00086 void LayoutAwarePage::OnLoaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00087 {
00088   this->StartLayoutUpdates(sender, e);
00089
00090   // Keyboard and mouse navigation only apply when occupying the entire window
00091   if (this->ActualHeight == Window::Current->Bounds.Height &&
00092     this->ActualWidth == Window::Current->Bounds.Width)
00093   {
00094     // Listen to the window directly so focus isn't required
00095     _acceleratorKeyEventToken = Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated +=
00096       ref new TypedEventHandler<CoreDispatcher^, AcceleratorKeyEventArgs^>(this,
00097       &LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated);
00098     _pointerPressedEventToken = Window::Current->CoreWindow->PointerPressed +=
00099       ref new TypedEventHandler<CoreWindow^, PointerEventArgs^>(this,
00100       &LayoutAwarePage::CoreWindow_PointerPressed);
00101     _navigationShortcutsRegistered = true;
00102   }
00103 }
00104
00105 /// <summary>
00106 /// Invoked when the page is removed from visual tree
00107 /// </summary>
00108 /// <param name="sender">Instance that triggered the event.</param>
00109 /// <param name="e">Event data describing the conditions that led to the event.</param>
00110 void LayoutAwarePage::OnUnloaded(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00111 {
00112   if (_navigationShortcutsRegistered)
00113   {
00114     Window::Current->CoreWindow->Dispatcher->AcceleratorKeyActivated -= _acceleratorKeyEventToken;
00115     Window::Current->CoreWindow->PointerPressed -= _pointerPressedEventToken;
00116     _navigationShortcutsRegistered = false;
00117   }
00118   StopLayoutUpdates(sender, e);
00119 }
00120
00121 #pragma region Navigation support
00122
00123 /// <summary>
00124 /// Invoked as an event handler to navigate backward in the page's associated <see cref="Frame"/>
00125 /// until it reaches the top of the navigation stack.
00126 /// </summary>
00127 /// <param name="sender">Instance that triggered the event.</param>
00128 /// <param name="e">Event data describing the conditions that led to the event.</param>
00129 void LayoutAwarePage::GoHome(Object^ sender, RoutedEventArgs^ e)
00130 {
00131     (void) sender;  // Unused parameter
00132     (void) e; // Unused parameter
00133
00134     // Use the navigation frame to return to the topmost page
00135     if (Frame != nullptr)
00136     {
00137         while (Frame->CanGoBack)
00138         {
00139             Frame->GoBack();
00140         }
00141     }
00142 }
00143
00144 /// <summary>
00145 /// Invoked as an event handler to navigate backward in the navigation stack
00146 /// associated with this page's <see cref="Frame"/>.
00147 /// </summary>
00148 /// <param name="sender">Instance that triggered the event.</param>
00149 /// <param name="e">Event data describing the conditions that led to the event.</param>
00150 void LayoutAwarePage::GoBack(Object^ sender, RoutedEventArgs^ e)
00151 {
00152     (void) sender;  // Unused parameter
00153     (void) e; // Unused parameter
00154
00155     // Use the navigation frame to return to the previous page
00156     if (Frame != nullptr && Frame->CanGoBack)
00157     {
00158         Frame->GoBack();
00159     }
00160 }
00161
00162 /// <summary>
00163 /// Invoked as an event handler to navigate forward in the navigation stack
00164 /// associated with this page's <see cref="Frame"/>.
00165 /// </summary>
00166 /// <param name="sender">Instance that triggered the event.</param>
00167 /// <param name="e">Event data describing the conditions that led to the event.</param>
00168 void LayoutAwarePage::GoForward(Object^ sender, RoutedEventArgs^ e)
00169 {
00170     (void) sender;  // Unused parameter
00171     (void) e; // Unused parameter
00172
00173     // Use the navigation frame to advance to the next page
00174     if (Frame != nullptr && Frame->CanGoForward)
00175     {
00176         Frame->GoForward();
00177     }
00178 }
00179
00180 /// <summary>
00181 /// Invoked on every keystroke, including system keys such as Alt key combinations, when
00182 /// this page is active and occupies the entire window.  Used to detect keyboard navigation
00183 /// between pages even when the page itself doesn't have focus.
00184 /// </summary>
00185 /// <param name="sender">Instance that triggered the event.</param>
00186 /// <param name="args">Event data describing the conditions that led to the event.</param>
00187 void LayoutAwarePage::CoreDispatcher_AcceleratorKeyActivated(CoreDispatcher^ sender, AcceleratorKeyEventArgs^ args)
00188 {
00189     auto virtualKey = args->VirtualKey;
00190
00191     // Only investigate further when Left, Right, or the dedicated Previous or Next keys
00192     // are pressed
00193     if ((args->EventType == CoreAcceleratorKeyEventType::SystemKeyDown ||
00194         args->EventType == CoreAcceleratorKeyEventType::KeyDown) &&
00195         (virtualKey == VirtualKey::Left || virtualKey == VirtualKey::Right ||
00196         (int)virtualKey == 166 || (int)virtualKey == 167))
00197     {
00198         auto coreWindow = Window::Current->CoreWindow;
00199         auto downState = Windows::UI::Core::CoreVirtualKeyStates::Down;
00200         bool menuKey = (coreWindow->GetKeyState(VirtualKey::Menu) & downState) == downState;
00201         bool controlKey = (coreWindow->GetKeyState(VirtualKey::Control) & downState) == downState;
00202         bool shiftKey = (coreWindow->GetKeyState(VirtualKey::Shift) & downState) == downState;
00203         bool noModifiers = !menuKey && !controlKey && !shiftKey;
00204         bool onlyAlt = menuKey && !controlKey && !shiftKey;
00205
00206         if (((int)virtualKey == 166 && noModifiers) ||
00207             (virtualKey == VirtualKey::Left && onlyAlt))
00208         {
00209             // When the previous key or Alt+Left are pressed navigate back
00210             args->Handled = true;
00211             GoBack(this, ref new RoutedEventArgs());
00212         }
00213         else if (((int)virtualKey == 167 && noModifiers) ||
00214             (virtualKey == VirtualKey::Right && onlyAlt))
00215         {
00216             // When the next key or Alt+Right are pressed navigate forward
00217             args->Handled = true;
00218             GoForward(this, ref new RoutedEventArgs());
00219         }
00220     }
00221 }
00222
00223 /// <summary>
00224 /// Invoked on every mouse click, touch screen tap, or equivalent interaction when this
00225 /// page is active and occupies the entire window.  Used to detect browser-style next and
00226 /// previous mouse button clicks to navigate between pages.
00227 /// </summary>
00228 /// <param name="sender">Instance that triggered the event.</param>
00229 /// <param name="args">Event data describing the conditions that led to the event.</param>
00230 void LayoutAwarePage::CoreWindow_PointerPressed(CoreWindow^ sender, PointerEventArgs^ args)
00231 {
00232     auto properties = args->CurrentPoint->Properties;
00233
00234     // Ignore button chords with the left, right, and middle buttons
00235     if (properties->IsLeftButtonPressed || properties->IsRightButtonPressed ||
00236         properties->IsMiddleButtonPressed) return;
00237
00238     // If back or foward are pressed (but not both) navigate appropriately
00239     bool backPressed = properties->IsXButton1Pressed;
00240     bool forwardPressed = properties->IsXButton2Pressed;
00241     if (backPressed ^ forwardPressed)
00242     {
00243         args->Handled = true;
00244         if (backPressed) GoBack(this, ref new RoutedEventArgs());
00245         if (forwardPressed) GoForward(this, ref new RoutedEventArgs());
00246     }
00247 }
00248
00249 #pragma endregion
00250
00251 #pragma region Visual state switching
00252
00253 /// <summary>
00254 /// Invoked as an event handler, typically on the <see cref="Loaded"/> event of a
00255 /// <see cref="Control"/> within the page, to indicate that the sender should start receiving
00256 /// visual state management changes that correspond to application view state changes.
00257 /// </summary>
00258 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00259 /// corresponding to view states.</param>
00260 /// <param name="e">Event data that describes how the request was made.</param>
00261 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00262 /// when layout updates are requested.  A corresponding <see cref="Unloaded"/> event handler
00263 /// connected to <see cref="StopLayoutUpdates"/> is strongly encouraged.  Instances of
00264 /// <see cref="LayoutAwarePage"/> automatically invoke these handlers in their Loaded and Unloaded
00265 /// events.</remarks>
00266 /// <seealso cref="DetermineVisualState"/>
00267 /// <seealso cref="InvalidateVisualState"/>
00268 void LayoutAwarePage::StartLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00269 {
00270     (void) e; // Unused parameter
00271
00272     auto control = safe_cast<Control^>(sender);
00273     if (_layoutAwareControls == nullptr)
00274     {
00275         // Start listening to view state changes when there are controls interested in updates
00276         _layoutAwareControls = ref new Vector<Control^>();
00277         _windowSizeEventToken = Window::Current->SizeChanged += ref new WindowSizeChangedEventHandler(this, &LayoutAwarePage::WindowSizeChanged);
00278
00279         // Page receives notifications for children. Protect the page until we stopped layout updates for all controls.
00280         _this = this;
00281     }
00282     _layoutAwareControls->Append(control);
00283
00284     // Set the initial visual state of the control
00285     VisualStateManager::GoToState(control, DetermineVisualState(ApplicationView::Value), false);
00286 }
00287
00288 void LayoutAwarePage::WindowSizeChanged(Object^ sender, Windows::UI::Core::WindowSizeChangedEventArgs^ e)
00289 {
00290     (void) sender;  // Unused parameter
00291     (void) e; // Unused parameter
00292
00293     InvalidateVisualState();
00294 }
00295
00296 /// <summary>
00297 /// Invoked as an event handler, typically on the <see cref="Unloaded"/> event of a
00298 /// <see cref="Control"/>, to indicate that the sender should start receiving visual state
00299 /// management changes that correspond to application view state changes.
00300 /// </summary>
00301 /// <param name="sender">Instance of <see cref="Control"/> that supports visual state management
00302 /// corresponding to view states.</param>
00303 /// <param name="e">Event data that describes how the request was made.</param>
00304 /// <remarks>The current view state will immediately be used to set the corresponding visual state
00305 /// when layout updates are requested.</remarks>
00306 /// <seealso cref="StartLayoutUpdates"/>
00307 void LayoutAwarePage::StopLayoutUpdates(Object^ sender, RoutedEventArgs^ e)
00308 {
00309     (void) e; // Unused parameter
00310
00311     auto control = safe_cast<Control^>(sender);
00312     unsigned int index;
00313     if (_layoutAwareControls != nullptr && _layoutAwareControls->IndexOf(control, &index))
00314     {
00315         _layoutAwareControls->RemoveAt(index);
00316         if (_layoutAwareControls->Size == 0)
00317         {
00318             // Stop listening to view state changes when no controls are interested in updates
00319             Window::Current->SizeChanged -= _windowSizeEventToken;
00320             _layoutAwareControls = nullptr;
00321             // Last control has received the Unload notification.
00322             _this = nullptr;
00323         }
00324     }
00325 }
00326
00327 /// <summary>
00328 /// Translates <see cref="ApplicationViewState"/> values into strings for visual state management
00329 /// within the page.  The default implementation uses the names of enum values.  Subclasses may
00330 /// override this method to control the mapping scheme used.
00331 /// </summary>
00332 /// <param name="viewState">View state for which a visual state is desired.</param>
00333 /// <returns>Visual state name used to drive the <see cref="VisualStateManager"/></returns>
00334 /// <seealso cref="InvalidateVisualState"/>
00335 String^ LayoutAwarePage::DetermineVisualState(ApplicationViewState viewState)
00336 {
00337     switch (viewState)
00338     {
00339     case ApplicationViewState::Filled:
00340         return "Filled";
00341     case ApplicationViewState::Snapped:
00342         return "Snapped";
00343     case ApplicationViewState::FullScreenPortrait:
00344         return "FullScreenPortrait";
00345     case ApplicationViewState::FullScreenLandscape:
00346     default:
00347         return "FullScreenLandscape";
00348     }
00349 }
00350
00351 /// <summary>
00352 /// Updates all controls that are listening for visual state changes with the correct visual
00353 /// state.
00354 /// </summary>
00355 /// <remarks>
00356 /// Typically used in conjunction with overriding <see cref="DetermineVisualState"/> to
00357 /// signal that a different value may be returned even though the view state has not changed.
00358 /// </remarks>
00359 void LayoutAwarePage::InvalidateVisualState()
00360 {
00361     if (_layoutAwareControls != nullptr)
00362     {
00363         String^ visualState = DetermineVisualState(ApplicationView::Value);
00364         auto controlIterator = _layoutAwareControls->First();
00365         while (controlIterator->HasCurrent)
00366         {
00367             auto control = controlIterator->Current;
00368             VisualStateManager::GoToState(control, visualState, false);
00369             controlIterator->MoveNext();
00370         }
00371     }
00372 }
00373
00374 #pragma endregion
00375
00376 #pragma region Process lifetime management
00377
00378 /// <summary>
00379 /// Invoked when this page is about to be displayed in a Frame.
00380 /// </summary>
00381 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00382 /// property provides the group to be displayed.</param>
00383 void LayoutAwarePage::OnNavigatedTo(NavigationEventArgs^ e)
00384 {
00385     // Returning to a cached page through navigation shouldn't trigger state loading
00386     if (_pageKey != nullptr) return;
00387
00388     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00389     _pageKey = "Page-" + Frame->BackStackDepth;
00390
00391     if (e->NavigationMode == NavigationMode::New)
00392     {
00393         // Clear existing state for forward navigation when adding a new page to the
00394         // navigation stack
00395         auto nextPageKey = _pageKey;
00396         int nextPageIndex = Frame->BackStackDepth;
00397         while (frameState->HasKey(nextPageKey))
00398         {
00399             frameState->Remove(nextPageKey);
00400             nextPageIndex++;
00401             nextPageKey = "Page-" + nextPageIndex;
00402         }
00403
00404         // Pass the navigation parameter to the new page
00405         LoadState(e->Parameter, nullptr);
00406     }
00407     else
00408     {
00409         // Pass the navigation parameter and preserved page state to the page, using
00410         // the same strategy for loading suspended state and recreating pages discarded
00411         // from cache
00412         LoadState(e->Parameter, safe_cast<IMap<String^, Object^>^>(frameState->Lookup(_pageKey)));
00413     }
00414 }
00415
00416 /// <summary>
00417 /// Invoked when this page will no longer be displayed in a Frame.
00418 /// </summary>
00419 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00420 /// property provides the group to be displayed.</param>
00421 void LayoutAwarePage::OnNavigatedFrom(NavigationEventArgs^ e)
00422 {
00423     auto frameState = SuspensionManager::SessionStateForFrame(Frame);
00424     auto pageState = ref new Map<String^, Object^>();
00425     SaveState(pageState);
00426     frameState->Insert(_pageKey, pageState);
00427 }
00428
00429 /// <summary>
00430 /// Populates the page with content passed during navigation.  Any saved state is also
00431 /// provided when recreating a page from a prior session.
00432 /// </summary>
00433 /// <param name="navigationParameter">The parameter value passed to
00434 /// <see cref="Frame.Navigate(Type, Object)"/> when this page was initially requested.
00435 /// </param>
00436 /// <param name="pageState">A map of state preserved by this page during an earlier
00437 /// session.  This will be null the first time a page is visited.</param>
00438 void LayoutAwarePage::LoadState(Object^ navigationParameter, IMap<String^, Object^>^ pageState)
00439 {
00440 }
00441
00442 /// <summary>
00443 /// Preserves state associated with this page in case the application is suspended or the
00444 /// page is discarded from the navigation cache.  Values must conform to the serialization
00445 /// requirements of <see cref="SuspensionManager.SessionState"/>.
00446 /// </summary>
00447 /// <param name="pageState">An empty map to be populated with serializable state.</param>
00448 void LayoutAwarePage::SaveState(IMap<String^, Object^>^ pageState)
00449 {
00450 }
00451
00452 #pragma endregion
Generated on Sat Nov 23 2024 16:07:33 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Direct2D animation/C++/DirectXBase.cpp Source File

  • Direct2D animation

DirectXBase.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved
00007
00008 #include "pch.h"
00009 #include "DirectXBase.h"
00010
00011 using namespace Windows::UI::Core;
00012 using namespace Windows::Foundation;
00013 using namespace Microsoft::WRL;
00014 using namespace Windows::Graphics::Display;
00015 using namespace D2D1;
00016
00017 // Constructor.
00018 DirectXBase::DirectXBase() :
00019     m_windowSizeChangeInProgress(false),
00020     m_dpi(-1.0f)
00021 {
00022 }
00023
00024 // Initialize the DirectX resources required to run.
00025 void DirectXBase::Initialize(CoreWindow^ window, float dpi)
00026 {
00027     m_window = window;
00028
00029     CreateDeviceIndependentResources();
00030     CreateDeviceResources();
00031     SetDpi(dpi);
00032 }
00033
00034 // Recreate all device resources and set them back to the current state.
00035 void DirectXBase::HandleDeviceLost()
00036 {
00037     // Reset these member variables to ensure that SetDpi recreates all resources.
00038     float dpi = m_dpi;
00039     m_dpi = -1.0f;
00040     m_windowBounds.Width = 0;
00041     m_windowBounds.Height = 0;
00042     m_swapChain = nullptr;
00043
00044     CreateDeviceResources();
00045     SetDpi(dpi);
00046 }
00047
00048 // These are the resources required independent of the device.
00049 void DirectXBase::CreateDeviceIndependentResources()
00050 {
00051     D2D1_FACTORY_OPTIONS options;
00052     ZeroMemory(&options, sizeof(D2D1_FACTORY_OPTIONS));
00053
00054 #if defined(_DEBUG)
00055     // If the project is in a debug build, enable Direct2D debugging via SDK Layers.
00056     options.debugLevel = D2D1_DEBUG_LEVEL_INFORMATION;
00057 #endif
00058
00059     DX::ThrowIfFailed(
00060         D2D1CreateFactory(
00061             D2D1_FACTORY_TYPE_SINGLE_THREADED,
00062             __uuidof(ID2D1Factory1),
00063             &options,
00064             &m_d2dFactory
00065             )
00066         );
00067
00068     DX::ThrowIfFailed(
00069         DWriteCreateFactory(
00070             DWRITE_FACTORY_TYPE_SHARED,
00071             __uuidof(IDWriteFactory),
00072             &m_dwriteFactory
00073             )
00074         );
00075
00076     DX::ThrowIfFailed(
00077         CoCreateInstance(
00078             CLSID_WICImagingFactory,
00079             nullptr,
00080             CLSCTX_INPROC_SERVER,
00081             IID_PPV_ARGS(&m_wicFactory)
00082             )
00083         );
00084 }
00085
00086 // These are the resources that depend on the device.
00087 void DirectXBase::CreateDeviceResources()
00088 {
00089     // This flag adds support for surfaces with a different color channel ordering
00090     // than the API default. It is required for compatibility with Direct2D.
00091     UINT creationFlags = D3D11_CREATE_DEVICE_BGRA_SUPPORT;
00092     ComPtr<IDXGIDevice> dxgiDevice;
00093
00094 #if defined(_DEBUG)
00095     // If the project is in a debug build, enable debugging via SDK Layers with this flag.
00096     creationFlags |= D3D11_CREATE_DEVICE_DEBUG;
00097 #endif
00098
00099     // This array defines the set of DirectX hardware feature levels this app will support.
00100     // Note the ordering should be preserved.
00101     // Don't forget to declare your application's minimum required feature level in its
00102     // description.  All applications are assumed to support 9.1 unless otherwise stated.
00103     D3D_FEATURE_LEVEL featureLevels[] =
00104     {
00105         D3D_FEATURE_LEVEL_11_1,
00106         D3D_FEATURE_LEVEL_11_0,
00107         D3D_FEATURE_LEVEL_10_1,
00108         D3D_FEATURE_LEVEL_10_0,
00109         D3D_FEATURE_LEVEL_9_3,
00110         D3D_FEATURE_LEVEL_9_2,
00111         D3D_FEATURE_LEVEL_9_1
00112     };
00113
00114     // Create the Direct3D 11 API device object and a corresponding context.
00115     ComPtr<ID3D11Device> device;
00116     ComPtr<ID3D11DeviceContext> context;
00117     DX::ThrowIfFailed(
00118         D3D11CreateDevice(
00119             nullptr,                    // Specify nullptr to use the default adapter.
00120             D3D_DRIVER_TYPE_HARDWARE,
00121             0,
00122             creationFlags,              // Set debug and Direct2D compatibility flags.
00123             featureLevels,              // List of feature levels this app can support.
00124             ARRAYSIZE(featureLevels),
00125             D3D11_SDK_VERSION,          // Always set this to D3D11_SDK_VERSION for Metro style apps.
00126             &device,                    // Returns the Direct3D device created.
00127             &m_featureLevel,            // Returns feature level of device created.
00128             &context                    // Returns the device immediate context.
00129             )
00130         );
00131
00132     // Get the Direct3D 11.1 API device and context interfaces.
00133     DX::ThrowIfFailed(
00134         device.As(&m_d3dDevice)
00135         );
00136
00137     DX::ThrowIfFailed(
00138         context.As(&m_d3dContext)
00139         );
00140
00141     // Get the underlying DXGI device of the Direct3D device.
00142     DX::ThrowIfFailed(
00143         m_d3dDevice.As(&dxgiDevice)
00144         );
00145
00146     // Create the Direct2D device object and a corresponding context.
00147     DX::ThrowIfFailed(
00148         m_d2dFactory->CreateDevice(dxgiDevice.Get(), &m_d2dDevice)
00149         );
00150
00151     DX::ThrowIfFailed(
00152         m_d2dDevice->CreateDeviceContext(
00153             D2D1_DEVICE_CONTEXT_OPTIONS_NONE,
00154             &m_d2dContext
00155             )
00156         );
00157 }
00158
00159 // Helps track the DPI in the helper class.
00160 // This is called in the dpiChanged event handler in the view class.
00161 void DirectXBase::SetDpi(float dpi)
00162 {
00163     if (dpi != m_dpi)
00164     {
00165         // Save the DPI of this display in our class.
00166         m_dpi = dpi;
00167
00168         // Update Direct2D's stored DPI.
00169         m_d2dContext->SetDpi(m_dpi, m_dpi);
00170
00171         // Often a DPI change implies a window size change. In some cases Windows will issue
00172         // both a size changed event and a DPI changed event. In this case, the resulting bounds
00173         // will not change, and the window resize code will only be executed once.
00174         UpdateForWindowSizeChange();
00175     }
00176 }
00177
00178 // This routine is called in the event handler for the view SizeChanged event.
00179 void DirectXBase::UpdateForWindowSizeChange()
00180 {
00181     // Only handle window size changed if there is no pending DPI change.
00182     if (m_dpi != DisplayProperties::LogicalDpi)
00183     {
00184         return;
00185     }
00186
00187     if (m_window->Bounds.Width  != m_windowBounds.Width ||
00188         m_window->Bounds.Height != m_windowBounds.Height)
00189     {
00190         m_d2dContext->SetTarget(nullptr);
00191         m_d2dTargetBitmap = nullptr;
00192         m_d3dRenderTargetView = nullptr;
00193         m_d3dDepthStencilView = nullptr;
00194         m_windowSizeChangeInProgress = true;
00195         CreateWindowSizeDependentResources();
00196     }
00197 }
00198
00199 // Allocate all memory resources that change on a window SizeChanged event.
00200 void DirectXBase::CreateWindowSizeDependentResources()
00201 {
00202     // Store the window bounds so the next time we get a SizeChanged event we can
00203     // avoid rebuilding everything if the size is identical.
00204     m_windowBounds = m_window->Bounds;
00205
00206     if (m_swapChain != nullptr)
00207     {
00208         // If the swap chain already exists, resize it.
00209         HRESULT hr = m_swapChain->ResizeBuffers(2, 0, 0, DXGI_FORMAT_B8G8R8A8_UNORM, 0);
00210
00211         if (hr == DXGI_ERROR_DEVICE_REMOVED)
00212         {
00213             // If the device was removed for any reason, a new device and swapchain will need to be created.
00214             HandleDeviceLost();
00215
00216             // Everything is set up now. Do not continue execution of this method.
00217             return;
00218         }
00219         else
00220         {
00221             DX::ThrowIfFailed(hr);
00222         }
00223     }
00224     else
00225     {
00226         // Otherwise, create a new one using the same adapter as the existing Direct3D device.
00227         DXGI_SWAP_CHAIN_DESC1 swapChainDesc = {0};
00228         swapChainDesc.Width = 0;                                     // Use automatic sizing.
00229         swapChainDesc.Height = 0;
00230         swapChainDesc.Format = DXGI_FORMAT_B8G8R8A8_UNORM;           // This is the most common swap chain format.
00231         swapChainDesc.Stereo = false;
00232         swapChainDesc.SampleDesc.Count = 1;                          // Don't use multi-sampling.
00233         swapChainDesc.SampleDesc.Quality = 0;
00234         swapChainDesc.BufferUsage = DXGI_USAGE_RENDER_TARGET_OUTPUT;
00235         swapChainDesc.BufferCount = 2;                               // Use double-buffering to minimize latency.
00236         swapChainDesc.Scaling = DXGI_SCALING_NONE;
00237         swapChainDesc.SwapEffect = DXGI_SWAP_EFFECT_FLIP_SEQUENTIAL; // All Metro style apps must use this SwapEffect.
00238         swapChainDesc.Flags = 0;
00239
00240         ComPtr<IDXGIDevice1> dxgiDevice;
00241         DX::ThrowIfFailed(
00242             m_d3dDevice.As(&dxgiDevice)
00243             );
00244
00245         ComPtr<IDXGIAdapter> dxgiAdapter;
00246         DX::ThrowIfFailed(
00247             dxgiDevice->GetAdapter(&dxgiAdapter)
00248             );
00249
00250         ComPtr<IDXGIFactory2> dxgiFactory;
00251         DX::ThrowIfFailed(
00252             dxgiAdapter->GetParent(IID_PPV_ARGS(&dxgiFactory))
00253             );
00254
00255         CoreWindow^ window = m_window.Get();
00256         DX::ThrowIfFailed(
00257             dxgiFactory->CreateSwapChainForCoreWindow(
00258                 m_d3dDevice.Get(),
00259                 reinterpret_cast<IUnknown*>(window),
00260                 &swapChainDesc,
00261                 nullptr,
00262                 &m_swapChain
00263                 )
00264             );
00265
00266         // Ensure that DXGI does not queue more than one frame at a time. This both reduces latency and
00267         // ensures that the application will only render after each VSync, minimizing power consumption.
00268         DX::ThrowIfFailed(
00269             dxgiDevice->SetMaximumFrameLatency(1)
00270             );
00271     }
00272
00273     // Create a Direct3D render target view of the swap chain back buffer.
00274     ComPtr<ID3D11Texture2D> backBuffer;
00275     DX::ThrowIfFailed(
00276         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&backBuffer))
00277         );
00278
00279     DX::ThrowIfFailed(
00280         m_d3dDevice->CreateRenderTargetView(
00281             backBuffer.Get(),
00282             nullptr,
00283             &m_d3dRenderTargetView
00284             )
00285         );
00286
00287     // Cache the rendertarget dimensions in our helper class for convenient use.
00288     D3D11_TEXTURE2D_DESC backBufferDesc = {0};
00289     backBuffer->GetDesc(&backBufferDesc);
00290     m_renderTargetSize.Width  = static_cast<float>(backBufferDesc.Width);
00291     m_renderTargetSize.Height = static_cast<float>(backBufferDesc.Height);
00292
00293     // Create a depth stencil view for use with 3D rendering if needed.
00294     CD3D11_TEXTURE2D_DESC depthStencilDesc(
00295         DXGI_FORMAT_D24_UNORM_S8_UINT,
00296         backBufferDesc.Width,
00297         backBufferDesc.Height,
00298         1,
00299         1,
00300         D3D11_BIND_DEPTH_STENCIL
00301         );
00302
00303     ComPtr<ID3D11Texture2D> depthStencil;
00304     DX::ThrowIfFailed(
00305         m_d3dDevice->CreateTexture2D(
00306             &depthStencilDesc,
00307             nullptr,
00308             &depthStencil
00309             )
00310         );
00311
00312     auto viewDesc = CD3D11_DEPTH_STENCIL_VIEW_DESC(D3D11_DSV_DIMENSION_TEXTURE2D);
00313     DX::ThrowIfFailed(
00314         m_d3dDevice->CreateDepthStencilView(
00315             depthStencil.Get(),
00316             &viewDesc,
00317             &m_d3dDepthStencilView
00318             )
00319         );
00320
00321     // Set the 3D rendering viewport to target the entire window.
00322     CD3D11_VIEWPORT viewport(
00323         0.0f,
00324         0.0f,
00325         static_cast<float>(backBufferDesc.Width),
00326         static_cast<float>(backBufferDesc.Height)
00327         );
00328
00329     m_d3dContext->RSSetViewports(1, &viewport);
00330
00331     // Create a Direct2D target bitmap associated with the
00332     // swap chain back buffer and set it as the current target.
00333     D2D1_BITMAP_PROPERTIES1 bitmapProperties =
00334         BitmapProperties1(
00335             D2D1_BITMAP_OPTIONS_TARGET | D2D1_BITMAP_OPTIONS_CANNOT_DRAW,
00336             PixelFormat(DXGI_FORMAT_B8G8R8A8_UNORM, D2D1_ALPHA_MODE_PREMULTIPLIED),
00337             m_dpi,
00338             m_dpi
00339             );
00340
00341     ComPtr<IDXGISurface> dxgiBackBuffer;
00342     DX::ThrowIfFailed(
00343         m_swapChain->GetBuffer(0, IID_PPV_ARGS(&dxgiBackBuffer))
00344         );
00345
00346     DX::ThrowIfFailed(
00347         m_d2dContext->CreateBitmapFromDxgiSurface(
00348             dxgiBackBuffer.Get(),
00349             &bitmapProperties,
00350             &m_d2dTargetBitmap
00351             )
00352         );
00353
00354     m_d2dContext->SetTarget(m_d2dTargetBitmap.Get());
00355
00356     // Grayscale text anti-aliasing is recommended for all Metro style apps.
00357     m_d2dContext->SetTextAntialiasMode(D2D1_TEXT_ANTIALIAS_MODE_GRAYSCALE);
00358 }
00359
00360 // Method to deliver the final image to the display.
00361 void DirectXBase::Present()
00362 {
00363     // The application may optionally specify "dirty" or "scroll" rects to improve efficiency
00364     // in certain scenarios.  In this sample, however, we do not utilize those features.
00365     DXGI_PRESENT_PARAMETERS parameters = {0};
00366     parameters.DirtyRectsCount = 0;
00367     parameters.pDirtyRects = nullptr;
00368     parameters.pScrollRect = nullptr;
00369     parameters.pScrollOffset = nullptr;
00370
00371     // The first argument instructs DXGI to block until VSync, putting the application
00372     // to sleep until the next VSync. This ensures we don't waste any cycles rendering
00373     // frames that will never be displayed to the screen.
00374     HRESULT hr = m_swapChain->Present1(1, 0, &parameters);
00375
00376     // Discard the contents of the render target.
00377     // This is a valid operation only when the existing contents will be entirely
00378     // overwritten. If dirty or scroll rects are used, this call should be removed.
00379     m_d3dContext->DiscardView(m_d3dRenderTargetView.Get());
00380
00381     // Discard the contents of the depth stencil.
00382     m_d3dContext->DiscardView(m_d3dDepthStencilView.Get());
00383
00384     // If the device was removed either by a disconnect or a driver upgrade, we
00385     // must recreate all device resources.
00386     if (hr == DXGI_ERROR_DEVICE_REMOVED)
00387     {
00388         HandleDeviceLost();
00389     }
00390     else
00391     {
00392         DX::ThrowIfFailed(hr);
00393     }
00394
00395     if (m_windowSizeChangeInProgress)
00396     {
00397         // A window size change has been initiated and the app has just completed presenting
00398         // the first frame with the new size. Notify the resize manager so we can short
00399         // circuit any resize animation and prevent unnecessary delays.
00400         CoreWindowResizeManager::GetForCurrentView()->NotifyLayoutCompleted();
00401         m_windowSizeChangeInProgress = false;
00402     }
00403 }
00404
00405 void DirectXBase::ValidateDevice()
00406 {
00407     // The D3D Device is no longer valid if the default adapter changes or if
00408     // the device has been removed.
00409
00410     // First, get the information for the adapter related to the current device.
00411
00412     ComPtr<IDXGIDevice1> dxgiDevice;
00413     ComPtr<IDXGIAdapter> deviceAdapter;
00414     DXGI_ADAPTER_DESC deviceDesc;
00415     DX::ThrowIfFailed(m_d3dDevice.As(&dxgiDevice));
00416     DX::ThrowIfFailed(dxgiDevice->GetAdapter(&deviceAdapter));
00417     DX::ThrowIfFailed(deviceAdapter->GetDesc(&deviceDesc));
00418
00419     // Next, get the information for the default adapter.
00420
00421     ComPtr<IDXGIFactory2> dxgiFactory;
00422     ComPtr<IDXGIAdapter1> currentAdapter;
00423     DXGI_ADAPTER_DESC currentDesc;
00424     DX::ThrowIfFailed(CreateDXGIFactory1(IID_PPV_ARGS(&dxgiFactory)));
00425     DX::ThrowIfFailed(dxgiFactory->EnumAdapters1(0, &currentAdapter));
00426     DX::ThrowIfFailed(currentAdapter->GetDesc(&currentDesc));
00427
00428     // If the adapter LUIDs don't match, or if the device reports that it has been removed,
00429     // a new D3D device must be created.
00430
00431     if ((deviceDesc.AdapterLuid.LowPart != currentDesc.AdapterLuid.LowPart) ||
00432         (deviceDesc.AdapterLuid.HighPart != currentDesc.AdapterLuid.HighPart) ||
00433         FAILED(m_d3dDevice->GetDeviceRemovedReason()))
00434     {
00435         // Release references to resources related to the old device.
00436         dxgiDevice = nullptr;
00437         deviceAdapter = nullptr;
00438
00439         // Create a new device and swap chain.
00440         HandleDeviceLost();
00441     }
00442 }
Generated on Sat Nov 23 2024 16:08:02 for Win8-Examples by doxygen 1.7.1


Win8-Examples: XAML two-dimensional transforms/C++/App.xaml.cpp Source File

  • XAML two-dimensional transforms

App.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // App.xaml.cpp
00013 // Implementation of the App.xaml class.
00014 //
00015
00016 #include "pch.h"
00017 #include "MainPage.xaml.h"
00018 #include "Common\SuspensionManager.h"
00019
00020 using namespace SDKSample;
00021 using namespace SDKSample::Common;
00022
00023 using namespace Concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::ApplicationModel::Activation;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Controls::Primitives;
00033 using namespace Windows::UI::Xaml::Data;
00034 using namespace Windows::UI::Xaml::Input;
00035 using namespace Windows::UI::Xaml::Interop;
00036 using namespace Windows::UI::Xaml::Media;
00037 using namespace Windows::UI::Xaml::Navigation;
00038
00039 /// <summary>
00040 /// Initializes the singleton application object.  This is the first line of authored code
00041 /// executed, and as such is the logical equivalent of main() or WinMain().
00042 /// </summary>
00043 App::App()
00044 {
00045     InitializeComponent();
00046     this->Suspending += ref new SuspendingEventHandler(this, &SDKSample::App::OnSuspending);
00047 }
00048
00049 /// <summary>
00050 /// Invoked when the application is launched normally by the end user.  Other entry points will
00051 /// be used when the application is launched to open a specific file, to display search results,
00052 /// and so forth.
00053 /// </summary>
00054 /// <param name="pArgs">Details about the launch request and process.</param>
00055 void App::OnLaunched(LaunchActivatedEventArgs^ pArgs)
00056 {
00057     this->LaunchArgs = pArgs;
00058
00059     // Do not repeat app initialization when already running, just ensure that
00060     // the window is active
00061     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Running)
00062     {
00063         Window::Current->Activate();
00064         return;
00065     }
00066
00067     // Create a Frame to act as the navigation context and associate it with
00068     // a SuspensionManager key
00069     auto rootFrame = ref new Frame();
00070     SuspensionManager::RegisterFrame(rootFrame, "AppFrame");
00071
00072     auto prerequisite = task<void>([](){});
00073     if (pArgs->PreviousExecutionState == ApplicationExecutionState::Terminated)
00074     {
00075         // Restore the saved session state only when appropriate, scheduling the
00076         // final launch steps after the restore is complete
00077         prerequisite = SuspensionManager::RestoreAsync();
00078     }
00079     prerequisite.then([=]()
00080     {
00081         // When the navigation stack isn't restored navigate to the first page,
00082         // configuring the new page by passing required information as a navigation
00083         // parameter
00084         if (rootFrame->Content == nullptr)
00085         {
00086             if (!rootFrame->Navigate(TypeName(MainPage::typeid)))
00087             {
00088                 throw ref new FailureException("Failed to create initial page");
00089             }
00090         }
00091
00092         // Place the frame in the current Window and ensure that it is active
00093         Window::Current->Content = rootFrame;
00094         Window::Current->Activate();
00095     }, task_continuation_context::use_current());
00096 }
00097
00098 /// <summary>
00099 /// Invoked when application execution is being suspended.  Application state is saved
00100 /// without knowing whether the application will be terminated or resumed with the contents
00101 /// of memory still intact.
00102 /// </summary>
00103 /// <param name="sender">The source of the suspend request.</param>
00104 /// <param name="e">Details about the suspend request.</param>
00105 void App::OnSuspending(Object^ sender, SuspendingEventArgs^ e)
00106 {
00107     (void) sender;  // Unused parameter
00108
00109     auto deferral = e->SuspendingOperation->GetDeferral();
00110     SuspensionManager::SaveAsync().then([=]()
00111     {
00112         deferral->Complete();
00113     });
00114 }
Generated on Sat Nov 23 2024 16:07:29 for Win8-Examples by doxygen 1.7.1


Win8-Examples: UI Automation core window provider/C++/AppWindowProvider.cpp Source File

  • UI Automation core window provider

AppWindowProvider.cpp

Go to the documentation of this file.
00001 //// THIS CODE AND INFORMATION IS PROVIDED "AS IS" WITHOUT WARRANTY OF
00002 //// ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO
00003 //// THE IMPLIED WARRANTIES OF MERCHANTABILITY AND/OR FITNESS FOR A
00004 //// PARTICULAR PURPOSE.
00005 ////
00006 //// Copyright (c) Microsoft Corporation. All rights reserved.
00007
00008 #include "pch.h"
00009
00010 #include <windows.system.h>
00011 #include <windows.ui.core.h>
00012
00013 #include <UIAutomationCore.h>
00014 #include <UIAutomationCoreApi.h>
00015
00016 #include "InternalInterfaces_h.h"
00017
00018 using namespace ABI::Windows::Foundation;
00019 using namespace Microsoft::WRL;
00020 using namespace ABI::Windows::UI;
00021 using namespace ABI::Windows::UI::Core;
00022 using namespace ABI::Windows::System;
00023 using namespace ABI::UiaCoreWindowProvider;
00024
00025 // CAppWindowProvider: provider for the main application window
00026
00027 [uuid("1F3AB6DE-000A-4C93-9BA4-A629E399A463")]
00028 class CAppWindowProvider:
00029     public Microsoft::WRL::RuntimeClass<
00030         Microsoft::WRL::RuntimeClassFlags<Microsoft::WRL::RuntimeClassType::WinRtClassicComMix>,
00031         IAppWindowProvider,
00032         IRawElementProviderSimple,
00033         IRawElementProviderFragment,
00034         IRawElementProviderFragmentRoot,
00035         IRawElementProviderAdviseEvents,
00036         IDisconnectableProvider>
00037 {
00038     InspectableClass(RuntimeClass_UiaCoreWindowProvider_AppWindowProvider, BaseTrust);
00039
00040 public:
00041     CAppWindowProvider();
00042
00043     // IAppWindowProvider methods
00044     IFACEMETHODIMP Initialize(_In_ ITriColorControlInternal* pControl, _In_ IInspectable* pWindow);
00045
00046     // IRawElementProviderSimple methods
00047     IFACEMETHODIMP get_ProviderOptions(_Out_ ProviderOptions * retVal);
00048     IFACEMETHODIMP GetPatternProvider(_In_ PATTERNID iid, _Outptr_result_maybenull_ IUnknown * * retVal );
00049     IFACEMETHODIMP GetPropertyValue(_In_ PROPERTYID idProp, _Out_ VARIANT * retVal );
00050     IFACEMETHODIMP get_HostRawElementProvider(_Outptr_result_maybenull_ IRawElementProviderSimple ** retVal );
00051
00052     // IRawElementProviderFragment methods
00053     IFACEMETHODIMP Navigate(_In_ NavigateDirection direction, _Outptr_result_maybenull_ IRawElementProviderFragment ** retVal );
00054     IFACEMETHODIMP GetRuntimeId(_Outptr_result_maybenull_ SAFEARRAY ** retVal );
00055     IFACEMETHODIMP get_BoundingRectangle(_Out_ UiaRect * retVal );
00056     IFACEMETHODIMP GetEmbeddedFragmentRoots(_Outptr_result_maybenull_ SAFEARRAY ** retVal );
00057     IFACEMETHODIMP SetFocus();
00058     IFACEMETHODIMP get_FragmentRoot(_Outptr_result_maybenull_ IRawElementProviderFragmentRoot * * retVal);
00059
00060     // IRawElementProviderFragmentRoot methods
00061     IFACEMETHODIMP ElementProviderFromPoint(_In_ double x, _In_ double y, _Outptr_result_maybenull_ IRawElementProviderFragment ** retVal);
00062     IFACEMETHODIMP GetFocus(_Outptr_result_maybenull_ IRawElementProviderFragment ** retVal );
00063
00064     // IRawElementProviderAdviseEvents methods
00065     IFACEMETHODIMP AdviseEventAdded(_In_ EVENTID eventId, _In_ SAFEARRAY * propertyIDs);
00066     IFACEMETHODIMP AdviseEventRemoved(_In_ EVENTID eventId, _In_ SAFEARRAY * propertyIDs);
00067
00068     // IDisconnectableProvider methods
00069     IFACEMETHODIMP Disconnect();
00070
00071 protected:
00072
00073     // Make sure we haven't been disconnected; return the right error if we have.
00074     HRESULT CheckDisconnected();
00075
00076 protected:
00077
00078     // Pointer to the window this represents
00079     Microsoft::WRL::ComPtr<ABI::Windows::UI::Core::ICoreWindow> m_window;
00080
00081     // Pointer to the main UI object
00082     Microsoft::WRL::ComPtr<ITriColorControlInternal> m_control;
00083
00084     // Has this provider been disconnected?
00085     BOOL m_disconnected;
00086 };
00087
00088 CAppWindowProvider::CAppWindowProvider()
00089     : m_disconnected(FALSE)
00090 {
00091 }
00092
00093 //
00094 // IAppWindowProvider Implementation
00095 //
00096
00097 IFACEMETHODIMP CAppWindowProvider::Initialize(_In_ ITriColorControlInternal* pControl, _In_ IInspectable* pWindow)
00098 {
00099     m_control = pControl;
00100     return pWindow->QueryInterface(IID_PPV_ARGS(&m_window));
00101 }
00102
00103 //
00104 // IRawElementProviderSimple Implementation
00105 //
00106
00107 IFACEMETHODIMP CAppWindowProvider::get_ProviderOptions(_Out_ ProviderOptions * pRetVal)
00108 {
00109     *pRetVal = ProviderOptions_ServerSideProvider |
00110                ProviderOptions_UseComThreading |
00111                ProviderOptions_UseClientCoordinates;
00112     return S_OK;
00113 }
00114
00115 IFACEMETHODIMP CAppWindowProvider::GetPatternProvider(_In_ PATTERNID /*patternId*/, _Outptr_result_maybenull_ IUnknown **ppRetVal)
00116 {
00117     *ppRetVal = nullptr;
00118     return CheckDisconnected();
00119 }
00120
00121 IFACEMETHODIMP CAppWindowProvider::GetPropertyValue(_In_ PROPERTYID idProp, _Out_ VARIANT * pRetVal)
00122 {
00123     pRetVal->vt = VT_EMPTY;
00124     HRESULT hr = CheckDisconnected();
00125     if (SUCCEEDED(hr))
00126     {
00127         switch (idProp)
00128         {
00129         case UIA_ProviderDescriptionPropertyId:
00130             pRetVal->bstrVal = SysAllocString(L"CAppWindowProvider");
00131             if (pRetVal->bstrVal != nullptr)
00132             {
00133                 pRetVal->vt = VT_BSTR;
00134             }
00135             break;
00136
00137         // case UIA_NamePropertyId:
00138         // The Name property is deliberately not set.
00139         // Names for Metro-style applications are set from their manifests.
00140         // Setting a name here would be confusing and redundant.
00141
00142         case UIA_AutomationIdPropertyId:
00143             pRetVal->bstrVal = SysAllocString(L"CAppWindowProvider0001");
00144             if (pRetVal->bstrVal != nullptr)
00145             {
00146                 pRetVal->vt = VT_BSTR;
00147             }
00148             break;
00149
00150         case UIA_IsPasswordPropertyId:
00151             pRetVal->vt = VT_BOOL;
00152             pRetVal->boolVal = VARIANT_FALSE;
00153             break;
00154
00155         case UIA_ControlTypePropertyId:
00156             pRetVal->vt = VT_I4;
00157             pRetVal->lVal = UIA_WindowControlTypeId;
00158             break;
00159
00160         case UIA_HasKeyboardFocusPropertyId:
00161             hr = m_control->get_HasFocus(&pRetVal->boolVal);
00162             if (SUCCEEDED(hr))
00163             {
00164                 pRetVal->vt = VT_BOOL;
00165             }
00166             break;
00167         }
00168     }
00169     return hr;
00170 }
00171
00172 // Respond to UIA's request for a host provider.
00173 // We can get a host provider from ICoreWindow, but we need to QI it for IRawElementProviderSimple
00174 // before we can return it.
00175 IFACEMETHODIMP CAppWindowProvider::get_HostRawElementProvider(_Outptr_result_maybenull_ IRawElementProviderSimple **ppRetVal)
00176 {
00177     *ppRetVal = nullptr;
00178     if (m_window != nullptr)
00179     {
00180         IInspectable *pHostAsInspectable = nullptr;
00181         if (SUCCEEDED(m_window->get_AutomationHostProvider(&pHostAsInspectable)))
00182         {
00183             pHostAsInspectable->QueryInterface(ppRetVal);
00184             pHostAsInspectable->Release();
00185         }
00186     }
00187     return S_OK;
00188 }
00189
00190 //
00191 // IRawElementProviderFragment Implementation
00192 //
00193
00194 IFACEMETHODIMP CAppWindowProvider::Navigate(_In_ NavigateDirection direction, _Outptr_result_maybenull_ IRawElementProviderFragment ** retVal)
00195 {
00196     *retVal = nullptr;
00197     HRESULT hr = CheckDisconnected();
00198     if (SUCCEEDED(hr))
00199     {
00200         if (direction == NavigateDirection_FirstChild || direction == NavigateDirection_LastChild)
00201         {
00202             ComPtr<IInspectable> spControlProvider;
00203             hr = m_control->GetTriColorControlProvider(&spControlProvider);
00204             if (SUCCEEDED(hr))
00205             {
00206                 hr = spControlProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
00207             }
00208         }
00209     }
00210
00211     // For the other directions (parent, next, previous) the default of nullptr is correct
00212     return hr;
00213 }
00214
00215 IFACEMETHODIMP CAppWindowProvider::GetRuntimeId(_Outptr_result_maybenull_ SAFEARRAY ** retVal)
00216 {
00217     *retVal = nullptr;
00218
00219     // UIA implements this method on behalf of the root window
00220     return CheckDisconnected();
00221 }
00222
00223 IFACEMETHODIMP CAppWindowProvider::get_BoundingRectangle(_Out_ UiaRect * retVal)
00224 {
00225     ZeroMemory(retVal, sizeof(*retVal));
00226
00227     // UIA implements this method on behalf of the root window
00228     return CheckDisconnected();
00229 }
00230
00231 IFACEMETHODIMP CAppWindowProvider::GetEmbeddedFragmentRoots(_Outptr_result_maybenull_ SAFEARRAY ** retVal)
00232 {
00233     *retVal = nullptr;
00234
00235     // We don't have any embedded fragment roots
00236     return CheckDisconnected();
00237 }
00238
00239 IFACEMETHODIMP CAppWindowProvider::SetFocus()
00240 {
00241     // UIA implements this method on behalf of the root window
00242     return CheckDisconnected();
00243 }
00244
00245 IFACEMETHODIMP CAppWindowProvider::get_FragmentRoot(_Outptr_result_maybenull_ IRawElementProviderFragmentRoot ** retVal)
00246 {
00247     *retVal = nullptr;
00248     HRESULT hr = CheckDisconnected();
00249     if (SUCCEEDED(hr))
00250     {
00251         return QueryInterface(IID_PPV_ARGS(retVal));
00252     }
00253     return hr;
00254 }
00255
00256 //
00257 // IRawElementProviderFragmentRoot Implementation
00258 //
00259
00260 IFACEMETHODIMP CAppWindowProvider::ElementProviderFromPoint(_In_ double x, _In_ double y, _Outptr_result_maybenull_ IRawElementProviderFragment ** retVal)
00261 {
00262     *retVal = nullptr;
00263     HRESULT hr = CheckDisconnected();
00264     if (SUCCEEDED(hr))
00265     {
00266         ABI::Windows::Foundation::Point pt = { static_cast<float>(x), static_cast<float>(y) };
00267
00268         // Did we hit a color region?
00269         TriColorValue value;
00270         if (SUCCEEDED(m_control->ValueFromPoint(pt, &value)))
00271         {
00272             // Return the color region
00273             ComPtr<IInspectable> spFragmentProvider;
00274             hr = m_control->GetTriColorFragmentProvider(value, &spFragmentProvider);
00275             if (SUCCEEDED(hr))
00276             {
00277                 hr = spFragmentProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
00278             }
00279         }
00280         // Otherwise, we just hit the app window itself, and we don't need to do anything for that;
00281         // nullptr is the correct response.
00282     }
00283
00284     return hr;
00285 }
00286
00287 IFACEMETHODIMP CAppWindowProvider::GetFocus(_Outptr_result_maybenull_ IRawElementProviderFragment ** retVal)
00288 {
00289     *retVal = nullptr;
00290     HRESULT hr = CheckDisconnected();
00291     if (SUCCEEDED(hr))
00292     {
00293         // If we are being asked the question at all, then this window must already have focus.
00294         // In that case, the focused provider is always the control.
00295         ComPtr<IInspectable> spControlProvider;
00296         hr = m_control->GetTriColorControlProvider(&spControlProvider);
00297         if (SUCCEEDED(hr))
00298         {
00299             hr = spControlProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
00300         }
00301     }
00302
00303     return hr;
00304 }
00305
00306 //
00307 // IRawElementProviderAdviseEvents implementation
00308 //
00309
00310 // Method exists simply to tell UIA that we want to receive event registrations
00311 IFACEMETHODIMP CAppWindowProvider::AdviseEventAdded(_In_ EVENTID /*eventId*/, _In_ SAFEARRAY * /*propertyIDs*/)
00312 {
00313     return S_OK;
00314 }
00315
00316 // Method exists simply to tell UIA that we want to receive event registrations
00317 IFACEMETHODIMP CAppWindowProvider::AdviseEventRemoved(_In_ EVENTID /*eventId*/, _In_ SAFEARRAY * /*propertyIDs*/)
00318 {
00319     return S_OK;
00320 }
00321
00322 //
00323 // IDisconnectableProvider Implementation
00324 //
00325
00326 IFACEMETHODIMP CAppWindowProvider::Disconnect()
00327 {
00328     // Disconnect and drop our back reference
00329     m_disconnected = TRUE;
00330     m_window = nullptr;
00331     return S_OK;
00332 }
00333
00334 HRESULT CAppWindowProvider::CheckDisconnected()
00335 {
00336     return (m_disconnected) ? UIA_E_ELEMENTNOTAVAILABLE : S_OK;
00337 }
00338
00339 // Factory function for this class
00340 HRESULT CAppWindowProvider_CreateInstance(IInspectable **retVal)
00341 {
00342     HRESULT hr = E_OUTOFMEMORY;
00343     *retVal = nullptr;
00344     ComPtr<CAppWindowProvider> spProvider = Make<CAppWindowProvider>();
00345     if (spProvider != nullptr)
00346     {
00347         hr = spProvider.Get()->QueryInterface(IID_PPV_ARGS(retVal));
00348     }
00349     return hr;
00350 }
Generated on Sat Nov 23 2024 16:08:25 for Win8-Examples by doxygen 1.7.1


Win8-Examples: Input Touch keyboard/C++/common/suspensionmanager.cpp Source File

  • Input Touch keyboard
  • common

suspensionmanager.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // SuspensionManager.cpp
00013 // Implementation of the SuspensionManager class
00014 //
00015
00016 #include "pch.h"
00017 #include "SuspensionManager.h"
00018
00019 #include <collection.h>
00020 #include <algorithm>
00021
00022 using namespace SDKSample::Common;
00023
00024 using namespace Concurrency;
00025 using namespace Platform;
00026 using namespace Platform::Collections;
00027 using namespace Windows::Foundation;
00028 using namespace Windows::Foundation::Collections;
00029 using namespace Windows::Storage;
00030 using namespace Windows::Storage::FileProperties;
00031 using namespace Windows::Storage::Streams;
00032 using namespace Windows::UI::Xaml;
00033 using namespace Windows::UI::Xaml::Controls;
00034 using namespace Windows::UI::Xaml::Interop;
00035
00036 namespace
00037 {
00038     Map<String^, Object^>^ _sessionState = ref new Map<String^, Object^>();
00039     String^ sessionStateFilename = "_sessionState.dat";
00040
00041     // Forward declarations for object object read / write support
00042     void WriteObject(Windows::Storage::Streams::DataWriter^ writer, Platform::Object^ object);
00043     Platform::Object^ ReadObject(Windows::Storage::Streams::DataReader^ reader);
00044 }
00045
00046 /// <summary>
00047 /// Provides access to global session state for the current session.  This state is serialized by
00048 /// <see cref="SaveAsync"/> and restored by <see cref="RestoreAsync"/> which require values to be
00049 /// one of the following: boxed values including integers, floating-point singles and doubles,
00050 /// wide characters, boolean, Strings and Guids, or Map<String^, Object^> where map values are
00051 /// subject to the same constraints.  Session state should be as compact as possible.
00052 /// </summary>
00053 IMap<String^, Object^>^ SuspensionManager::SessionState::get(void)
00054 {
00055     return _sessionState;
00056 }
00057
00058 /// <summary>
00059 /// Wrap a WeakReference as a reference object for use in a collection.
00060 /// </summary>
00061 private ref class WeakFrame sealed
00062 {
00063 private:
00064     WeakReference _frameReference;
00065
00066 internal:
00067     WeakFrame(Frame^ frame) { _frameReference = frame; }
00068     property Frame^ ResolvedFrame
00069     {
00070         Frame^ get(void) { return _frameReference.Resolve<Frame>(); }
00071     };
00072 };
00073
00074 namespace
00075 {
00076     std::vector<WeakFrame^> _registeredFrames;
00077     DependencyProperty^ FrameSessionStateKeyProperty =
00078         DependencyProperty::RegisterAttached("_FrameSessionStateKeyProperty",
00079         TypeName(String::typeid), TypeName(SuspensionManager::typeid), nullptr);
00080     DependencyProperty^ FrameSessionStateProperty =
00081         DependencyProperty::RegisterAttached("_FrameSessionStateProperty",
00082         TypeName(IMap<String^, Object^>::typeid), TypeName(SuspensionManager::typeid), nullptr);
00083 }
00084
00085 /// <summary>
00086 /// Registers a <see cref="Frame"/> instance to allow its navigation history to be saved to
00087 /// and restored from <see cref="SessionState"/>.  Frames should be registered once
00088 /// immediately after creation if they will participate in session state management.  Upon
00089 /// registration if state has already been restored for the specified key
00090 /// the navigation history will immediately be restored.  Subsequent invocations of
00091 /// <see cref="RestoreAsync(String)"/> will also restore navigation history.
00092 /// </summary>
00093 /// <param name="frame">An instance whose navigation history should be managed by
00094 /// <see cref="SuspensionManager"/></param>
00095 /// <param name="sessionStateKey">A unique key into <see cref="SessionState"/> used to
00096 /// store navigation-related information.</param>
00097 void SuspensionManager::RegisterFrame(Frame^ frame, String^ sessionStateKey)
00098 {
00099     if (frame->GetValue(FrameSessionStateKeyProperty) != nullptr)
00100     {
00101         throw ref new FailureException("Frames can only be registered to one session state key");
00102     }
00103
00104     if (frame->GetValue(FrameSessionStateProperty) != nullptr)
00105     {
00106         throw ref new FailureException("Frames must be either be registered before accessing frame session state, or not registered at all");
00107     }
00108
00109     // Use a dependency property to associate the session key with a frame, and keep a list of frames whose
00110     // navigation state should be managed
00111     frame->SetValue(FrameSessionStateKeyProperty, sessionStateKey);
00112     _registeredFrames.insert(_registeredFrames.begin(), ref new WeakFrame(frame));
00113
00114     // Check to see if navigation state can be restored
00115     RestoreFrameNavigationState(frame);
00116 }
00117
00118 /// <summary>
00119 /// Disassociates a <see cref="Frame"/> previously registered by <see cref="RegisterFrame"/>
00120 /// from <see cref="SessionState"/>.  Any navigation state previously captured will be
00121 /// removed.
00122 /// </summary>
00123 /// <param name="frame">An instance whose navigation history should no longer be
00124 /// managed.</param>
00125 void SuspensionManager::UnregisterFrame(Frame^ frame)
00126 {
00127     // Remove session state and remove the frame from the list of frames whose navigation
00128     // state will be saved (along with any weak references that are no longer reachable)
00129     auto key = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00130     if (SessionState->HasKey(key)) SessionState->Remove(key);
00131     _registeredFrames.erase(
00132         std::remove_if(_registeredFrames.begin(), _registeredFrames.end(), [=](WeakFrame^& e)
00133         {
00134             auto testFrame = e->ResolvedFrame;
00135             return testFrame == nullptr || testFrame == frame;
00136         }),
00137         _registeredFrames.end()
00138     );
00139 }
00140
00141 /// <summary>
00142 /// Provides storage for session state associated with the specified <see cref="Frame"/>.
00143 /// Frames that have been previously registered with <see cref="RegisterFrame"/> have
00144 /// their session state saved and restored automatically as a part of the global
00145 /// <see cref="SessionState"/>.  Frames that are not registered have transient state
00146 /// that can still be useful when restoring pages that have been discarded from the
00147 /// navigation cache.
00148 /// </summary>
00149 /// <remarks>Apps may choose to rely on <see cref="LayoutAwarePage"/> to manage
00150 /// page-specific state instead of working with frame session state directly.</remarks>
00151 /// <param name="frame">The instance for which session state is desired.</param>
00152 /// <returns>A collection of state subject to the same serialization mechanism as
00153 /// <see cref="SessionState"/>.</returns>
00154 IMap<String^, Object^>^ SuspensionManager::SessionStateForFrame(Frame^ frame)
00155 {
00156     auto frameState = safe_cast<IMap<String^, Object^>^>(frame->GetValue(FrameSessionStateProperty));
00157
00158     if (frameState == nullptr)
00159     {
00160         auto frameSessionKey = safe_cast<String^>(frame->GetValue(FrameSessionStateKeyProperty));
00161         if (frameSessionKey != nullptr)
00162         {
00163             // Registered frames reflect the corresponding session state
00164             if (!_sessionState->HasKey(frameSessionKey))
00165             {
00166                 _sessionState->Insert(frameSessionKey, ref new Map<String^, Object^>());
00167             }
00168             frameState = safe_cast<IMap<String^, Object^>^>(_sessionState->Lookup(frameSessionKey));
00169         }
00170         else
00171         {
00172             // Frames that aren't registered have transient state
00173             frameState = ref new Map<String^, Object^>();
00174         }
00175         frame->SetValue(FrameSessionStateProperty, frameState);
00176     }
00177     return frameState;
00178 }
00179
00180 void SuspensionManager::RestoreFrameNavigationState(Frame^ frame)
00181 {
00182     auto frameState = SessionStateForFrame(frame);
00183     if (frameState->HasKey("Navigation"))
00184     {
00185         frame->SetNavigationState(safe_cast<String^>(frameState->Lookup("Navigation")));
00186     }
00187 }
00188
00189 void SuspensionManager::SaveFrameNavigationState(Frame^ frame)
00190 {
00191     auto frameState = SessionStateForFrame(frame);
00192     frameState->Insert("Navigation", frame->GetNavigationState());
00193 }
00194
00195 /// <summary>
00196 /// Save the current <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00197 /// registered with <see cref="RegisterFrame"/> will also preserve their current
00198 /// navigation stack, which in turn gives their active <see cref="Page"/> an opportunity
00199 /// to save its state.
00200 /// </summary>
00201 /// <returns>An asynchronous task that reflects when session state has been saved.</returns>
00202 task<void> SuspensionManager::SaveAsync(void)
00203 {
00204     // Save the navigation state for all registered frames
00205     for (auto&& weakFrame : _registeredFrames)
00206     {
00207         auto frame = weakFrame->ResolvedFrame;
00208         if (frame != nullptr) SaveFrameNavigationState(frame);
00209     }
00210
00211     // Serialize the session state synchronously to avoid asynchronous access to shared
00212     // state
00213     auto sessionData = ref new InMemoryRandomAccessStream();
00214     auto sessionDataWriter = ref new DataWriter(sessionData->GetOutputStreamAt(0));
00215     WriteObject(sessionDataWriter, _sessionState);
00216
00217     // Once session state has been captured synchronously, begin the asynchronous process
00218     // of writing the result to disk
00219     return task<unsigned int>(sessionDataWriter->StoreAsync()).then([=](unsigned int)
00220     {
00221         return sessionDataWriter->FlushAsync();
00222     }).then([=](bool flushSucceeded)
00223     {
00224         (void)flushSucceeded; // Unused parameter
00225         return ApplicationData::Current->LocalFolder->CreateFileAsync(sessionStateFilename,
00226             CreationCollisionOption::ReplaceExisting);
00227     }).then([=](StorageFile^ createdFile)
00228     {
00229         return createdFile->OpenAsync(FileAccessMode::ReadWrite);
00230     }).then([=](IRandomAccessStream^ newStream)
00231     {
00232         return RandomAccessStream::CopyAndCloseAsync(
00233             sessionData->GetInputStreamAt(0), newStream->GetOutputStreamAt(0));
00234     }).then([=](UINT64 copiedBytes)
00235     {
00236         (void)copiedBytes; // Unused parameter
00237         return;
00238     });
00239 }
00240
00241 /// <summary>
00242 /// Restores previously saved <see cref="SessionState"/>.  Any <see cref="Frame"/> instances
00243 /// registered with <see cref="RegisterFrame"/> will also restore their prior navigation
00244 /// state, which in turn gives their active <see cref="Page"/> an opportunity restore its
00245 /// state.
00246 /// </summary>
00247 /// <param name="version">A version identifer compared to the session state to prevent
00248 /// incompatible versions of session state from reaching app code.  Saved state with a
00249 /// different version will be ignored, resulting in an empty <see cref="SessionState"/>
00250 /// dictionary.</param>
00251 /// <returns>An asynchronous task that reflects when session state has been read.  The
00252 /// content of <see cref="SessionState"/> should not be relied upon until this task
00253 /// completes.</returns>
00254 task<void> SuspensionManager::RestoreAsync(void)
00255 {
00256     _sessionState->Clear();
00257
00258     task<StorageFile^> getFileTask(ApplicationData::Current->LocalFolder->GetFileAsync(sessionStateFilename));
00259     return getFileTask.then([=](StorageFile^ stateFile)
00260     {
00261         task<BasicProperties^> getBasicPropertiesTask(stateFile->GetBasicPropertiesAsync());
00262         return getBasicPropertiesTask.then([=](BasicProperties^ stateFileProperties)
00263         {
00264             auto size = unsigned int(stateFileProperties->Size);
00265             if (size != stateFileProperties->Size) throw ref new FailureException("Session state larger than 4GB");
00266             task<IRandomAccessStreamWithContentType^> openReadTask(stateFile->OpenReadAsync());
00267             return openReadTask.then([=](IRandomAccessStreamWithContentType^ stateFileStream)
00268             {
00269                 auto stateReader = ref new DataReader(stateFileStream);
00270                 return task<unsigned int>(stateReader->LoadAsync(size)).then([=](unsigned int bytesRead)
00271                 {
00272                     (void)bytesRead; // Unused parameter
00273                     // Deserialize the Session State
00274                     Object^ content = ReadObject(stateReader);
00275                     _sessionState = (Map<String^, Object^>^)content;
00276
00277                     // Restore any registered frames to their saved state
00278                     for (auto&& weakFrame : _registeredFrames)
00279                     {
00280                         auto frame = weakFrame->ResolvedFrame;
00281                         if (frame != nullptr)
00282                         {
00283                             frame->ClearValue(FrameSessionStateProperty);
00284                             RestoreFrameNavigationState(frame);
00285                         }
00286                     }
00287                 }, task_continuation_context::use_current());
00288             });
00289         });
00290     });
00291 }
00292
00293 #pragma region Object serialization for a known set of types
00294
00295 namespace
00296 {
00297     // Codes used for identifying serialized types
00298     enum StreamTypes {
00299         NullPtrType = 0,
00300
00301         // Supported IPropertyValue types
00302         UInt8Type, UInt16Type, UInt32Type, UInt64Type, Int16Type, Int32Type, Int64Type,
00303         SingleType, DoubleType, BooleanType, Char16Type, GuidType, StringType,
00304
00305         // Additional supported types
00306         StringToObjectMapType,
00307
00308         // Marker values used to ensure stream integrity
00309         MapEndMarker
00310     };
00311
00312     void WriteString(DataWriter^ writer, String^ string)
00313     {
00314         writer->WriteByte(StringType);
00315         writer->WriteUInt32(writer->MeasureString(string));
00316         writer->WriteString(string);
00317     }
00318
00319     void WriteProperty(DataWriter^ writer, IPropertyValue^ propertyValue)
00320     {
00321         switch (propertyValue->Type)
00322         {
00323         case PropertyType::UInt8:
00324             writer->WriteByte(UInt8Type);
00325             writer->WriteByte(propertyValue->GetUInt8());
00326             return;
00327         case PropertyType::UInt16:
00328             writer->WriteByte(UInt16Type);
00329             writer->WriteUInt16(propertyValue->GetUInt16());
00330             return;
00331         case PropertyType::UInt32:
00332             writer->WriteByte(UInt32Type);
00333             writer->WriteUInt32(propertyValue->GetUInt32());
00334             return;
00335         case PropertyType::UInt64:
00336             writer->WriteByte(UInt64Type);
00337             writer->WriteUInt64(propertyValue->GetUInt64());
00338             return;
00339         case PropertyType::Int16:
00340             writer->WriteByte(Int16Type);
00341             writer->WriteUInt16(propertyValue->GetInt16());
00342             return;
00343         case PropertyType::Int32:
00344             writer->WriteByte(Int32Type);
00345             writer->WriteUInt32(propertyValue->GetInt32());
00346             return;
00347         case PropertyType::Int64:
00348             writer->WriteByte(Int64Type);
00349             writer->WriteUInt64(propertyValue->GetInt64());
00350             return;
00351         case PropertyType::Single:
00352             writer->WriteByte(SingleType);
00353             writer->WriteSingle(propertyValue->GetSingle());
00354             return;
00355         case PropertyType::Double:
00356             writer->WriteByte(DoubleType);
00357             writer->WriteDouble(propertyValue->GetDouble());
00358             return;
00359         case PropertyType::Boolean:
00360             writer->WriteByte(BooleanType);
00361             writer->WriteBoolean(propertyValue->GetBoolean());
00362             return;
00363         case PropertyType::Char16:
00364             writer->WriteByte(Char16Type);
00365             writer->WriteUInt16(propertyValue->GetChar16());
00366             return;
00367         case PropertyType::Guid:
00368             writer->WriteByte(GuidType);
00369             writer->WriteGuid(propertyValue->GetGuid());
00370             return;
00371         case PropertyType::String:
00372             WriteString(writer, propertyValue->GetString());
00373             return;
00374         default:
00375             throw ref new InvalidArgumentException("Unsupported property type");
00376         }
00377     }
00378
00379     void WriteStringToObjectMap(DataWriter^ writer, IMap<String^, Object^>^ map)
00380     {
00381         writer->WriteByte(StringToObjectMapType);
00382         writer->WriteUInt32(map->Size);
00383         for (auto&& pair : map)
00384         {
00385             WriteObject(writer, pair->Key);
00386             WriteObject(writer, pair->Value);
00387         }
00388         writer->WriteByte(MapEndMarker);
00389     }
00390
00391     void WriteObject(DataWriter^ writer, Object^ object)
00392     {
00393         if (object == nullptr)
00394         {
00395             writer->WriteByte(NullPtrType);
00396             return;
00397         }
00398
00399         auto propertyObject = dynamic_cast<IPropertyValue^>(object);
00400         if (propertyObject != nullptr)
00401         {
00402             WriteProperty(writer, propertyObject);
00403             return;
00404         }
00405
00406         auto mapObject = dynamic_cast<IMap<String^, Object^>^>(object);
00407         if (mapObject != nullptr)
00408         {
00409             WriteStringToObjectMap(writer, mapObject);
00410             return;
00411         }
00412
00413         throw ref new InvalidArgumentException("Unsupported data type");
00414     }
00415
00416     String^ ReadString(DataReader^ reader)
00417     {
00418         int length = reader->ReadUInt32();
00419         String^ string = reader->ReadString(length);
00420         return string;
00421     }
00422
00423     IMap<String^, Object^>^ ReadStringToObjectMap(DataReader^ reader)
00424     {
00425         auto map = ref new Map<String^, Object^>();
00426         auto size = reader->ReadUInt32();
00427         for (unsigned int index = 0; index < size; index++)
00428         {
00429             auto key = safe_cast<String^>(ReadObject(reader));
00430             auto value = ReadObject(reader);
00431             map->Insert(key, value);
00432         }
00433         if (reader->ReadByte() != MapEndMarker)
00434         {
00435             throw ref new InvalidArgumentException("Invalid stream");
00436         }
00437         return map;
00438     }
00439
00440     Object^ ReadObject(DataReader^ reader)
00441     {
00442         auto type = reader->ReadByte();
00443         switch (type)
00444         {
00445         case NullPtrType:
00446             return nullptr;
00447         case UInt8Type:
00448             return reader->ReadByte();
00449         case UInt16Type:
00450             return reader->ReadUInt16();
00451         case UInt32Type:
00452             return reader->ReadUInt32();
00453         case UInt64Type:
00454             return reader->ReadUInt64();
00455         case Int16Type:
00456             return reader->ReadInt16();
00457         case Int32Type:
00458             return reader->ReadInt32();
00459         case Int64Type:
00460             return reader->ReadInt64();
00461         case SingleType:
00462             return reader->ReadSingle();
00463         case DoubleType:
00464             return reader->ReadDouble();
00465         case BooleanType:
00466             return reader->ReadBoolean();
00467         case Char16Type:
00468             return (char16_t)reader->ReadUInt16();
00469         case GuidType:
00470             return reader->ReadGuid();
00471         case StringType:
00472             return ReadString(reader);
00473         case StringToObjectMapType:
00474             return ReadStringToObjectMap(reader);
00475         default:
00476             throw ref new InvalidArgumentException("Unsupported property type");
00477         }
00478     }
00479 }
00480
00481 #pragma endregion
Generated on Sat Nov 23 2024 16:07:36 for Win8-Examples by doxygen 1.7.1


Win8-Examples: App package information/C++/Scenario2.xaml.h Source File

  • App package information

Scenario2.xaml.h

Go to the documentation of this file.
00001 ﻿//*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // Scenario1.xaml.h
00013 // Declaration of the Scenario1 class
00014 //
00015
00016 #pragma once
00017
00018 #include "pch.h"
00019 #include "Scenario2.g.h"
00020 #include "MainPage.xaml.h"
00021
00022 namespace SDKSample
00023 {
00024     namespace PackageSample
00025     {
00026         /// <summary>
00027         /// An empty page that can be used on its own or navigated to within a Frame.
00028         /// </summary>
00029       [Windows::Foundation::Metadata::WebHostHidden]
00030         public ref class Scenario2 sealed
00031         {
00032         public:
00033             Scenario2();
00034
00035         protected:
00036             virtual void OnNavigatedTo(Windows::UI::Xaml::Navigation::NavigationEventArgs^ e) override;
00037         private:
00038             MainPage^ rootPage;
00039
00040             void GetInstalledLocation_Click(Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e);
00041         };
00042     }
00043 }
Generated on Sat Nov 23 2024 16:07:51 for Win8-Examples by doxygen 1.7.1


Win8-Examples: File picker contracts/C++/FileOpenPicker_PickAppFile.xaml.cpp Source File

  • File picker contracts

FileOpenPicker_PickAppFile.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // FileOpenPicker_PickAppFile.xaml.cpp
00013 // Implementation of the FileOpenPicker_PickAppFile class
00014 //
00015
00016 #include "pch.h"
00017 #include "FileOpenPickerPage.xaml.h"
00018 #include "FileOpenPicker_PickAppFile.xaml.h"
00019 #include "Constants.h"
00020
00021 using namespace SDKSample::FilePickerContracts;
00022
00023 using namespace concurrency;
00024 using namespace Platform;
00025 using namespace Windows::ApplicationModel;
00026 using namespace Windows::Foundation;
00027 using namespace Windows::Storage;
00028 using namespace Windows::Storage::Pickers::Provider;
00029 using namespace Windows::UI::Core;
00030 using namespace Windows::UI::Xaml;
00031 using namespace Windows::UI::Xaml::Controls;
00032 using namespace Windows::UI::Xaml::Navigation;
00033
00034 FileOpenPicker_PickAppFile::FileOpenPicker_PickAppFile()
00035 {
00036     InitializeComponent();
00037
00038     fileID = ref new String(L"MyLocalFile");
00039     fileOpenPickerUI = FileOpenPickerPage::Current->fileOpenPickerUI;
00040
00041     AddLocalFileButton->Click += ref new RoutedEventHandler(this, &FileOpenPicker_PickAppFile::AddLocalFileButton_Click);
00042     RemoveLocalFileButton->Click += ref new RoutedEventHandler(this, &FileOpenPicker_PickAppFile::RemoveLocalFileButton_Click);
00043 }
00044
00045 void FileOpenPicker_PickAppFile::UpdateButtonState(bool fileInBasket)
00046 {
00047     AddLocalFileButton->IsEnabled = !fileInBasket;
00048     RemoveLocalFileButton->IsEnabled = fileInBasket;
00049 }
00050
00051 void FileOpenPicker_PickAppFile::OnNavigatedTo(NavigationEventArgs^ e)
00052 {
00053     UpdateButtonState(fileOpenPickerUI->ContainsFile(fileID));
00054     token = fileOpenPickerUI->FileRemoved += ref new TypedEventHandler<FileOpenPickerUI^, FileRemovedEventArgs^>(this, &FileOpenPicker_PickAppFile::OnFileRemoved, CallbackContext::Same);
00055 }
00056
00057 void FileOpenPicker_PickAppFile::OnNavigatedFrom(NavigationEventArgs^ e)
00058 {
00059     fileOpenPickerUI->FileRemoved -= token;
00060 }
00061
00062 void FileOpenPicker_PickAppFile::OnFileRemoved(FileOpenPickerUI^ fileOPenPickerUI, FileRemovedEventArgs^ e)
00063 {
00064     // make sure that the item got removed matches the one we added.
00065     if (e->Id == fileID)
00066     {
00067         OutputTextBlock->Text = Status::FileRemoved;
00068         UpdateButtonState(false);
00069     }
00070 }
00071
00072 void FileOpenPicker_PickAppFile::AddLocalFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00073 {
00074     create_task(Package::Current->InstalledLocation->GetFileAsync(L"Assets\\squareTile-sdk.png")).then([this](StorageFile^ file)
00075     {
00076         bool inBasket;
00077         switch (fileOpenPickerUI->AddFile(fileID, file))
00078         {
00079         case AddFileResult::Added:
00080         case AddFileResult::AlreadyAdded:
00081             inBasket = true;
00082             OutputTextBlock->Text = Status::FileAdded;
00083             break;
00084
00085         default:
00086             inBasket = false;
00087             OutputTextBlock->Text = Status::FileAddFailed;
00088             break;
00089         }
00090         UpdateButtonState(inBasket);
00091     });
00092 }
00093
00094 void FileOpenPicker_PickAppFile::RemoveLocalFileButton_Click(Object^ sender, RoutedEventArgs^ e)
00095 {
00096     if (fileOpenPickerUI->ContainsFile(fileID))
00097     {
00098         fileOpenPickerUI->RemoveFile(fileID);
00099         OutputTextBlock->Text = Status::FileRemoved;
00100     }
00101     UpdateButtonState(false);
00102 }
Generated on Sat Nov 23 2024 16:08:16 for Win8-Examples by doxygen 1.7.1


Win8-Examples: HomeGroup app/C++/HomeGroupPickerScenario.xaml.cpp Source File

  • HomeGroup app

HomeGroupPickerScenario.xaml.cpp

Go to the documentation of this file.
00001 //*********************************************************
00002 //
00003 // Copyright (c) Microsoft. All rights reserved.
00004 // THIS CODE IS PROVIDED *AS IS* WITHOUT WARRANTY OF
00005 // ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING ANY
00006 // IMPLIED WARRANTIES OF FITNESS FOR A PARTICULAR
00007 // PURPOSE, MERCHANTABILITY, OR NON-INFRINGEMENT.
00008 //
00009 //*********************************************************
00010
00011 //
00012 // HomeGroupPicker.xaml.cpp
00013 // Implementation of the HomeGroupPicker class
00014 //
00015
00016 #include "pch.h"
00017 #include "HomeGroupPickerScenario.xaml.h"
00018
00019 using namespace SDKSample::HomeGroup;
00020
00021 using namespace concurrency;
00022 using namespace Windows::UI::Xaml;
00023 using namespace Windows::UI::Xaml::Controls;
00024 using namespace Windows::UI::Xaml::Navigation;
00025 using namespace Windows::Storage::Pickers;
00026 using namespace Windows::Storage;
00027 using namespace Platform;
00028
00029 HomeGroupPicker::HomeGroupPicker()
00030 {
00031     InitializeComponent();
00032 }
00033
00034 /// <summary>
00035 /// Invoked when this page is about to be displayed in a Frame.
00036 /// </summary>
00037 /// <param name="e">Event data that describes how this page was reached.  The Parameter
00038 /// property is typically used to configure the page.</param>
00039 void HomeGroupPicker::OnNavigatedTo(NavigationEventArgs^ e)
00040 {
00041     // A pointer back to the main page.  This is needed if you want to call methods in MainPage such
00042     // as NotifyUser()
00043     rootPage = MainPage::Current;
00044 }
00045
00046 // Suggest that the picker opens in homegroup.  Show how the UNC path is returned.
00047 void SDKSample::HomeGroup::HomeGroupPicker::Default_Click(Platform::Object^ sender, Windows::UI::Xaml::RoutedEventArgs^ e)
00048 {
00049     Button^ button = safe_cast<Button^>(sender);
00050     if (button != nullptr)
00051     {
00052         if (rootPage->EnsureUnsnapped())
00053         {
00054             auto picker = ref new FileOpenPicker();
00055             picker->ViewMode = PickerViewMode::Thumbnail;
00056             picker->SuggestedStartLocation = PickerLocationId::HomeGroup;
00057             picker->FileTypeFilter->Append("*");
00058             create_task(picker->PickSingleFileAsync()).then([this](StorageFile^ file)
00059             {
00060                 if (file)
00061                 {
00062                     // Application now has read/write access to the picked file
00063                     rootPage->NotifyUser("1 file selected: " + file->Path, NotifyType::StatusMessage);
00064                 }
00065                 else
00066                 {
00067                     rootPage->NotifyUser("File was not returned", NotifyType::ErrorMessage);
00068                 }
00069             });
00070         }
00071     }
00072 }
Generated on Sat Nov 23 2024 16:08:18 for Win8-Examples by doxygen 1.7.1